Generated (Java(TM) EE 7 Specification APIs)

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation

Annotation Type Generated

  • @Documented
@Retention(value=SOURCE)
@Target(value={PACKAGE,TYPE,ANNOTATION_TYPE,METHOD,CONSTRUCTOR,FIELD,LOCAL_VARIABLE,PARAMETER})
public @interface Generated
    The Generated annotation is used to mark source code that has been generated. It can also be used to differentiate user written code from generated code in a single file. When used, the value element must have the name of the code generator. The recommended convention is to use the fully qualified name of the code generator in the value field .

    For example: com.company.package.classname. The date element is used to indicate the date the source was generated. The date element must follow the ISO 8601 standard. For example the date element would have the following value 2001-07-04T12:08:56.235-0700 which represents 2001-07-04 12:08:56 local time in the U.S. Pacific Time time zone.

    The comment element is a place holder for any comments that the code generator may want to include in the generated code.

    Since:
    Common Annotations 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String[] value
      The value element MUST have the name of the code generator.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String comments
      A place holder for any comments that the code generator may want to include in the generated code.
      String date
      Date when the source was generated.

    • Element Detail

      • value

        public abstract String[] value
        The value element MUST have the name of the code generator. The recommended convention is to use the fully qualified name of the code generator. For example: com.acme.generator.CodeGen.

      • date

        public abstract String date
        Date when the source was generated.
        Default:
        ""

      • comments

        public abstract String comments
        A place holder for any comments that the code generator may want to include in the generated code.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element

Copyright © 1996-2013, Oracle and/or its affiliates. All Rights Reserved. Use is subject to license terms.


javax.annotation (Java(TM) EE 7 Specification APIs)

javax.annotation

Enums

  • Resource.AuthenticationType

Annotation Types

  • Generated
  • ManagedBean
  • PostConstruct
  • PreDestroy
  • Priority
  • Resource
  • Resources


javax.annotation (Java(TM) EE 7 Specification APIs)

  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.annotation

This package defines the common annotations.

See: Description

  • Enum Summary
    Enum Description
    Resource.AuthenticationType
    The two possible authentication types for a resource.
  • Annotation Types Summary
    Annotation Type Description
    Generated
    The Generated annotation is used to mark source code that has been generated.
    ManagedBean
    The ManagedBean annotation marks a POJO (Plain Old Java Object) as a ManagedBean.A ManagedBean supports a small set of basic services such as resource injection, lifecycle callbacks and interceptors.
    PostConstruct
    The PostConstruct annotation is used on a method that needs to be executed after dependency injection is done to perform any initialization.
    PreDestroy
    The PreDestroy annotation is used on methods as a callback notification to signal that the instance is in the process of being removed by the container.
    Priority
    The Priority annotation can be applied to classes to indicate in what order the classes should be used.
    Resource
    The Resource annotation marks a resource that is needed by the application.
    Resources
    This class is used to allow multiple resources declarations.

Package javax.annotation Description

This package defines the common annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes


javax.annotation Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.annotation

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.annotation.Priority (implements java.lang.annotation.Annotation)
  • javax.annotation.ManagedBean (implements java.lang.annotation.Annotation)
  • javax.annotation.Resources (implements java.lang.annotation.Annotation)
  • javax.annotation.Resource (implements java.lang.annotation.Annotation)
  • javax.annotation.PreDestroy (implements java.lang.annotation.Annotation)
  • javax.annotation.PostConstruct (implements java.lang.annotation.Annotation)
  • javax.annotation.Generated (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.annotation.Resource.AuthenticationType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ManagedBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation

Annotation Type ManagedBean

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface ManagedBean
    The ManagedBean annotation marks a POJO (Plain Old Java Object) as a ManagedBean.A ManagedBean supports a small set of basic services such as resource injection, lifecycle callbacks and interceptors.
    Since:
    Common Annotations 1.1

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String value
      The name of the Managed Bean.

    • Element Detail

      • value

        public abstract String value
        The name of the Managed Bean. Managed Bean names must be unique within a Java EE module. For each named Managed Bean, Java EE containers must make available the following entries in JNDI, using the same naming scheme used for EJB components.

        In the application namespace:

        java:app/<module-name>/<bean-name>

        In the module namespace of the module containing the Managed Bean:

        java:module/<bean-name>

        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PostConstruct (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation

Annotation Type PostConstruct

  • @Documented
@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface PostConstruct
    The PostConstruct annotation is used on a method that needs to be executed after dependency injection is done to perform any initialization. This method MUST be invoked before the class is put into service. This annotation MUST be supported on all classes that support dependency injection. The method annotated with PostConstruct MUST be invoked even if the class does not request any resources to be injected. Only one method can be annotated with this annotation. The method on which the PostConstruct annotation is applied MUST fulfill all of the following criteria:

    • The method MUST NOT have any parameters except in the case of interceptors in which case it takes an InvocationContext object as defined by the Interceptors specification.
    • The method defined on an interceptor class MUST HAVE one of the following signatures:

      void <METHOD>(InvocationContext)

      Object <METHOD>(InvocationContext) throws Exception

      Note: A PostConstruct interceptor method must not throw application exceptions, but it may be declared to throw checked exceptions including the java.lang.Exception if the same interceptor method interposes on business or timeout methods in addition to lifecycle events. If a PostConstruct interceptor method returns a value, it is ignored by the container.

    • The method defined on a non-interceptor class MUST HAVE the following signature:

      void <METHOD>()

    • The method on which PostConstruct is applied MAY be public, protected, package private or private.
    • The method MUST NOT be static except for the application client.
    • The method MAY be final.
    • If the method throws an unchecked exception the class MUST NOT be put into service except in the case of EJBs where the EJB can handle exceptions and even recover from them.
    Since:
    Common Annotations 1.0
    See Also:
    PreDestroy, Resource
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PreDestroy (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation

Annotation Type PreDestroy

  • @Documented
@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface PreDestroy
    The PreDestroy annotation is used on methods as a callback notification to signal that the instance is in the process of being removed by the container. The method annotated with PreDestroy is typically used to release resources that it has been holding. This annotation MUST be supported by all container managed objects that support PostConstruct except the application client container in Java EE 5. The method on which the PreDestroy annotation is applied MUST fulfill all of the following criteria:

    • The method MUST NOT have any parameters except in the case of interceptors in which case it takes an InvocationContext object as defined by the Interceptors specification.
    • The method defined on an interceptor class MUST HAVE one of the following signatures:

      void <METHOD>(InvocationContext)

      Object <METHOD>(InvocationContext) throws Exception

      Note: A PreDestroy interceptor method must not throw application exceptions, but it may be declared to throw checked exceptions including the java.lang.Exception if the same interceptor method interposes on business or timeout methods in addition to lifecycle events. If a PreDestroy interceptor method returns a value, it is ignored by the container.

    • The method defined on a non-interceptor class MUST HAVE the following signature:

      void <METHOD>()

    • The method on which PreDestroy is applied MAY be public, protected, package private or private.
    • The method MUST NOT be static.
    • The method MAY be final.
    • If the method throws an unchecked exception it is ignored except in the case of EJBs where the EJB can handle exceptions.
    Since:
    Common Annotations 1.0
    See Also:
    PostConstruct, Resource
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Priority (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation

Annotation Type Priority

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface Priority
    The Priority annotation can be applied to classes to indicate in what order the classes should be used. The effect of using the Priority annotation in any particular instance is defined by other specifications that define the use of a specific class.

    For example, the Interceptors specification defines the use of priorities on interceptors to control the order in which interceptors are called.

    Priority values should generally be non-negative, with negative values reserved for special meanings such as "undefined" or "not specified". A specification that defines use of the Priority annotation may define the range of allowed priorities and any priority values with special meaning.

    Since:
    Common Annotations 1.2

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      int value
      The priority value.

    • Element Detail

      • value

        public abstract int value
        The priority value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Resource (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation

Annotation Type Resource

  • @Target(value={TYPE,FIELD,METHOD})
@Retention(value=RUNTIME)
public @interface Resource
    The Resource annotation marks a resource that is needed by the application. This annotation may be applied to an application component class, or to fields or methods of the component class. When the annotation is applied to a field or method, the container will inject an instance of the requested resource into the application component when the component is initialized. If the annotation is applied to the component class, the annotation declares a resource that the application will look up at runtime.

    Even though this annotation is not marked Inherited, deployment tools are required to examine all superclasses of any component class to discover all uses of this annotation in all superclasses. All such annotation instances specify resources that are needed by the application component. Note that this annotation may appear on private fields and methods of superclasses; the container is required to perform injection in these cases as well.

    Since:
    Common Annotations 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Resource.AuthenticationType authenticationType
      The authentication type to use for this resource.
      String description
      Description of this resource.
      String lookup
      The name of the resource that the reference points to.
      String mappedName
      A product specific name that this resource should be mapped to.
      String name
      The JNDI name of the resource.
      boolean shareable
      Indicates whether this resource can be shared between this component and other components.
      Class<?> type
      The Java type of the resource.

    • Element Detail

      • name

        public abstract String name
        The JNDI name of the resource. For field annotations, the default is the field name. For method annotations, the default is the JavaBeans property name corresponding to the method. For class annotations, there is no default and this must be specified.
        Default:
        ""

      • lookup

        public abstract String lookup
        The name of the resource that the reference points to. It can link to any compatible resource using the global JNDI names.
        Since:
        Common Annotations 1.1
        Default:
        ""

      • type

        public abstract Class<?> type
        The Java type of the resource. For field annotations, the default is the type of the field. For method annotations, the default is the type of the JavaBeans property. For class annotations, there is no default and this must be specified.
        Default:
        java.lang.Object.class

      • authenticationType

        public abstract Resource.AuthenticationType authenticationType
        The authentication type to use for this resource. This may be specified for resources representing a connection factory of any supported type, and must not be specified for resources of other types.
        Default:
        javax.annotation.Resource.AuthenticationType.CONTAINER

      • shareable

        public abstract boolean shareable
        Indicates whether this resource can be shared between this component and other components. This may be specified for resources representing a connection factory of any supported type, and must not be specified for resources of other types.
        Default:
        true

      • mappedName

        public abstract String mappedName
        A product specific name that this resource should be mapped to. The name of this resource, as defined by the name element or defaulted, is a name that is local to the application component using the resource. (It's a name in the JNDI java:comp/env namespace.) Many application servers provide a way to map these local names to names of resources known to the application server. This mapped name is often a global JNDI name, but may be a name of any form.

        Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

        Default:
        ""

      • description

        public abstract String description
        Description of this resource. The description is expected to be in the default language of the system on which the application is deployed. The description can be presented to the Deployer to help in choosing the correct resource.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Resource.AuthenticationType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.annotation

Enum Resource.AuthenticationType

  • java.lang.Object
    • java.lang.Enum<Resource.AuthenticationType>
      • javax.annotation.Resource.AuthenticationType
  • All Implemented Interfaces:
    Serializable, Comparable<Resource.AuthenticationType>
    Enclosing class:
    Resource

    public static enum Resource.AuthenticationType
extends Enum<Resource.AuthenticationType>
    The two possible authentication types for a resource.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      APPLICATION
      CONTAINER

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Resource.AuthenticationType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Resource.AuthenticationType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CONTAINER

        public static final Resource.AuthenticationType CONTAINER

      • APPLICATION

        public static final Resource.AuthenticationType APPLICATION

    • Method Detail

      • values

        public static Resource.AuthenticationType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Resource.AuthenticationType c : Resource.AuthenticationType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Resource.AuthenticationType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Resources (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation

Annotation Type Resources

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface Resources
    This class is used to allow multiple resources declarations.
    Since:
    Common Annotations 1.0
    See Also:
    Resource

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Resource[] value
      Array used for multiple resource declarations.

    • Element Detail

      • value

        public abstract Resource[] value
        Array used for multiple resource declarations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.annotation (Java(TM) EE 7 Specification APIs)

  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.annotation

  • Packages that use javax.annotation
    Package Description
    javax.annotation
    This package defines the common annotations.
  • Classes in javax.annotation used by javax.annotation
    Class and Description
    Resource.AuthenticationType
    The two possible authentication types for a resource.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.Generated (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.Generated

No usage of javax.annotation.Generated
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.ManagedBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.ManagedBean

No usage of javax.annotation.ManagedBean
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.PostConstruct (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.PostConstruct

No usage of javax.annotation.PostConstruct
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.PreDestroy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.PreDestroy

No usage of javax.annotation.PreDestroy
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.Priority (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.Priority

No usage of javax.annotation.Priority
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.Resource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.Resource

No usage of javax.annotation.Resource
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.Resource.AuthenticationType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.Resource.AuthenticationType

  • Packages that use Resource.AuthenticationType
    Package Description
    javax.annotation
    This package defines the common annotations.

    • Uses of Resource.AuthenticationType in javax.annotation

      Methods in javax.annotation that return Resource.AuthenticationType
      Modifier and Type Method and Description
      static Resource.AuthenticationType Resource.AuthenticationType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Resource.AuthenticationType[] Resource.AuthenticationType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.Resources (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.Resources

No usage of javax.annotation.Resources
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


DeclareRoles (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation.security

Annotation Type DeclareRoles

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface DeclareRoles
    Used by application to declare roles. It can be specified on a class.
    Since:
    Common Annotations 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String[] value

    • Element Detail

      • value

        public abstract String[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DenyAll (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation.security

Annotation Type DenyAll

  • @Documented
@Retention(value=RUNTIME)
@Target(value={TYPE,METHOD})
public @interface DenyAll
    Specifies that no security roles are allowed to invoke the specified method(s) - i.e that the methods are to be excluded from execution in the J2EE container.
    Since:
    Common Annotations 1.0
    See Also:
    RolesAllowed, PermitAll
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.annotation.security (Java(TM) EE 7 Specification APIs)

javax.annotation.security

Annotation Types

  • DeclareRoles
  • DenyAll
  • PermitAll
  • RolesAllowed
  • RunAs


javax.annotation.security (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.annotation.security

This package contains the security common annotations.

See: Description

  • Annotation Types Summary
    Annotation Type Description
    DeclareRoles
    Used by application to declare roles.
    DenyAll
    Specifies that no security roles are allowed to invoke the specified method(s) - i.e that the methods are to be excluded from execution in the J2EE container.
    PermitAll
    Specifies that all security roles are allowed to invoke the specified method(s) i.e that the specified method(s) are "unchecked".
    RolesAllowed
    Specifies the list of roles permitted to access method(s) in an application.
    RunAs
    Defines the identity of the application during execution in a J2EE container.

Package javax.annotation.security Description

This package contains the security common annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.annotation.security Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.annotation.security

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.annotation.security.RunAs (implements java.lang.annotation.Annotation)
  • javax.annotation.security.RolesAllowed (implements java.lang.annotation.Annotation)
  • javax.annotation.security.PermitAll (implements java.lang.annotation.Annotation)
  • javax.annotation.security.DenyAll (implements java.lang.annotation.Annotation)
  • javax.annotation.security.DeclareRoles (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


PermitAll (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation.security

Annotation Type PermitAll

  • @Documented
@Retention(value=RUNTIME)
@Target(value={TYPE,METHOD})
public @interface PermitAll
    Specifies that all security roles are allowed to invoke the specified method(s) i.e that the specified method(s) are "unchecked". It can be specified on a class or on methods. Specifying it on the class means that it applies to all methods of the class. If specified at the method level, it only affects that method. If the RolesAllowed is specified at the class level and this annotation is applied at the method level, the PermitAll annotation overrides the RolesAllowed for the specified method.
    Since:
    Common Annotations 1.0
    See Also:
    RolesAllowed, DenyAll
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


RolesAllowed (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation.security

Annotation Type RolesAllowed

  • @Documented
@Retention(value=RUNTIME)
@Target(value={TYPE,METHOD})
public @interface RolesAllowed
    Specifies the list of roles permitted to access method(s) in an application. The value of the RolesAllowed annotation is a list of security role names. This annotation can be specified on a class or on method(s). Specifying it at a class level means that it applies to all the methods in the class. Specifying it on a method means that it is applicable to that method only. If applied at both the class and methods level , the method value overrides the class value if the two conflict.
    Since:
    Common Annotations 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String[] value

    • Element Detail

      • value

        public abstract String[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


RunAs (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation.security

Annotation Type RunAs

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface RunAs
    Defines the identity of the application during execution in a J2EE container. This allows developers to execute under a particular role. The role must map to the user / group information in the containers security realm. It's value is the name of a security role.
    Since:
    Common Annotations 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value

    • Element Detail

      • value

        public abstract String value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.annotation.security (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.annotation.security

No usage of javax.annotation.security
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.security.DeclareRoles (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.security.DeclareRoles

No usage of javax.annotation.security.DeclareRoles
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.security.DenyAll (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.security.DenyAll

No usage of javax.annotation.security.DenyAll
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.security.PermitAll (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.security.PermitAll

No usage of javax.annotation.security.PermitAll
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.security.RolesAllowed (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.security.RolesAllowed

No usage of javax.annotation.security.RolesAllowed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.security.RunAs (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.security.RunAs

No usage of javax.annotation.security.RunAs
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


DataSourceDefinition (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation.sql

Annotation Type DataSourceDefinition

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface DataSourceDefinition
    Annotation used to define a container DataSource and be registered with JNDI. The DataSource may be configured by setting the annotation elements for commonly used DataSource properties. Additional standard and vendor-specific properties may be specified using the properties element.

    The data source will be registered under the name specified in the name element. It may be defined to be in any valid Java EE namespace, and will determine the accessibility of the data source from other components.

    A JDBC driver implementation class of the appropriate type, either DataSource, ConnectionPoolDataSource, or XADataSource, must be indicated by the className element. The availability of the driver class will be assumed at runtime.

    DataSource properties should not be specified more than once. If the url annotation element contains a DataSource property that was also specified using the corresponding annotation element or was specified in the properties annotation element, the precedence order is undefined and implementation specific:

       @DataSourceDefinition(name="java:global/MyApp/MyDataSource",
      className="org.apache.derby.jdbc.ClientDataSource",
      url="jdbc:derby://localhost:1527/myDB;user=bill",
      user="lance",
      password="secret",
      databaseName="testDB",
      serverName="luckydog"
   )// DO NOT DO THIS!!!

    In the above example, the databaseName, user and serverName properties were specified as part of the url property and using the corresponding annotation elements. This should be avoided.

    If the properties annotation element is used and contains a DataSource property that was also specified using the corresponding annotation element, the annotation element value takes precedence. For example:

       @DataSourceDefinition(name="java:global/MyApp/MyDataSource",
      className="org.apache.derby.jdbc.ClientDataSource",
      user="lance",
      password="secret",
      databaseName="testDB",
      serverName="luckydog",
       properties= {"databaseName=myDB", "databaseProp=doThis"}
   )// DO NOT DO THIS!!!

    Would result in the following values being used when configuring the DataSource:

    • serverName=luckydog
    • portNumber=1527
    • databaseName=testDB
    • user=lance
    • password=secret
    • databaseProp=doThis

    Vendors are not required to support properties that do not normally apply to a specific data source type. For example, specifying the transactional property to be true but supplying a value for className that implements a data source class other than XADataSource may not be supported.

    Vendor-specific properties may be combined with or used to override standard data source properties defined using this annotation.

    DataSource properties that are specified and are not supported in a given configuration or cannot be mapped to a vendor specific configuration property may be ignored.

    Examples:

       @DataSourceDefinition(name="java:global/MyApp/MyDataSource",
      className="com.foobar.MyDataSource",
      portNumber=6689,
      serverName="myserver.com",
      user="lance",
      password="secret"
   )

    Using a URL:

      @DataSourceDefinition(name="java:global/MyApp/MyDataSource",
    className="org.apache.derby.jdbc.ClientDataSource",
    url="jdbc:derby://localhost:1527/myDB",
    user="lance",
    password="secret"
 )

    An example lookup of the DataSource from an EJB:

     @Stateless
 public class MyStatelessEJB {
   @Resource(lookup="java:global/MyApp/myDataSource")
    DataSource myDB;
      ...
 }

    Since:
    Common Annotations 1.1
    See Also:
    DataSource, XADataSource, ConnectionPoolDataSource

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String className
      DataSource implementation class name which implements: javax.sql.DataSource or javax.sql.XADataSource or javax.sql.ConnectionPoolDataSource.
      String name
      JNDI name by which the data source will be registered.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String databaseName
      Name of a database on a server.
      String description
      Description of this data source
      int initialPoolSize
      Number of connections that should be created when a connection pool is initialized.
      int isolationLevel
      Isolation level for connections.
      int loginTimeout
      Sets the maximum time in seconds that this data source will wait while attempting to connect to a database.
      int maxIdleTime
      The number of seconds that a physical connection should remain unused in the pool before the connection is closed for a connection pool.
      int maxPoolSize
      Maximum number of connections that should be concurrently allocated for a connection pool.
      int maxStatements
      The total number of statements that a connection pool should keep open.
      int minPoolSize
      Minimum number of connections that should be allocated for a connection pool.
      String password
      Password to use for connection authentication.
      int portNumber
      Port number where a server is listening for requests.
      String[] properties
      Used to specify Vendor specific properties and less commonly used DataSource properties such as:
      String serverName
      Database server name.
      boolean transactional
      Set to false if connections should not participate in transactions.
      String url
      A JDBC URL.
      String user
      User name to use for connection authentication.

    • Element Detail

      • name

        public abstract String name
        JNDI name by which the data source will be registered.
        Since:
        1.1

      • className

        public abstract String className
        DataSource implementation class name which implements: javax.sql.DataSource or javax.sql.XADataSource or javax.sql.ConnectionPoolDataSource.
        Since:
        1.1

      • description

        public abstract String description
        Description of this data source
        Since:
        1.1
        Default:
        ""

      • url

        public abstract String url
        A JDBC URL. If the url annotation element contains a DataSource property that was also specified using the corresponding annotation element, the precedence order is undefined and implementation specific.
        Since:
        1.1
        Default:
        ""

      • user

        public abstract String user
        User name to use for connection authentication.
        Since:
        1.1
        Default:
        ""

      • password

        public abstract String password
        Password to use for connection authentication.
        Since:
        1.1
        Default:
        ""

      • databaseName

        public abstract String databaseName
        Name of a database on a server.
        Since:
        1.1
        Default:
        ""

      • portNumber

        public abstract int portNumber
        Port number where a server is listening for requests.
        Since:
        1.1
        Default:
        -1

      • serverName

        public abstract String serverName
        Database server name.
        Since:
        1.1
        Default:
        "localhost"

      • isolationLevel

        public abstract int isolationLevel
        Isolation level for connections. The Isolation level must be one of the following:

        • Connection.TRANSACTION_NONE,
        • Connection.TRANSACTION_READ_ UNCOMMITTED,
        • Connection.TRANSACTION_READ_COMMITTED,
        • Connection.TRANSACTION_REPEATABLE_READ,
        • Connection.TRANSACTION_SERIALIZABLE

        Default is vendor-specific.

        Since:
        1.1
        Default:
        -1

      • transactional

        public abstract boolean transactional
        Set to false if connections should not participate in transactions.

        Default is to enlist in a transaction when one is active or becomes active.

        Since:
        1.1
        Default:
        true

      • initialPoolSize

        public abstract int initialPoolSize
        Number of connections that should be created when a connection pool is initialized.

        Default is vendor-specific

        Since:
        1.1
        Default:
        -1

      • maxPoolSize

        public abstract int maxPoolSize
        Maximum number of connections that should be concurrently allocated for a connection pool.

        Default is vendor-specific.

        Since:
        1.1
        Default:
        -1

      • minPoolSize

        public abstract int minPoolSize
        Minimum number of connections that should be allocated for a connection pool.

        Default is vendor-specific.

        Since:
        1.1
        Default:
        -1

      • maxIdleTime

        public abstract int maxIdleTime
        The number of seconds that a physical connection should remain unused in the pool before the connection is closed for a connection pool.

        Default is vendor-specific

        Since:
        1.1
        Default:
        -1

      • maxStatements

        public abstract int maxStatements
        The total number of statements that a connection pool should keep open. A value of 0 indicates that the caching of statements is disabled for a connection pool.

        Default is vendor-specific

        Since:
        1.1
        Default:
        -1

      • properties

        public abstract String[] properties
        Used to specify Vendor specific properties and less commonly used DataSource properties such as:

        • dataSourceName
        • networkProtocol
        • propertyCycle
        • roleName

        Properties are specified using the format: propertyName=propertyValue with one property per array element.

        If a DataSource property is specified in the properties element and the annotation element for the property is also specified, the annotation element value takes precedence.

        Since:
        1.1
        Default:
        {}

      • loginTimeout

        public abstract int loginTimeout
        Sets the maximum time in seconds that this data source will wait while attempting to connect to a database. A value of zero specifies that the timeout is the default system timeout if there is one; otherwise, it specifies that there is no timeout.

        Default is vendor-specific.

        Since:
        1.1
        Default:
        0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DataSourceDefinitions (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.annotation.sql

Annotation Type DataSourceDefinitions

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface DataSourceDefinitions
    Declares one or more DataSourceDefinition annotations.
    Since:
    Common Annotations 1.1
    See Also:
    DataSourceDefinition

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      DataSourceDefinition[] value

    • Element Detail

      • value

        public abstract DataSourceDefinition[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.annotation.sql (Java(TM) EE 7 Specification APIs)

javax.annotation.sql

Annotation Types

  • DataSourceDefinition
  • DataSourceDefinitions


javax.annotation.sql (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.annotation.sql

  • Annotation Types Summary
    Annotation Type Description
    DataSourceDefinition
    Annotation used to define a container DataSource and be registered with JNDI.
    DataSourceDefinitions
    Declares one or more DataSourceDefinition annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.annotation.sql Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.annotation.sql

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.annotation.sql.DataSourceDefinitions (implements java.lang.annotation.Annotation)
  • javax.annotation.sql.DataSourceDefinition (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.annotation.sql (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.annotation.sql

No usage of javax.annotation.sql
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.sql.DataSourceDefinition (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.sql.DataSourceDefinition

No usage of javax.annotation.sql.DataSourceDefinition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.annotation.sql.DataSourceDefinitions (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.annotation.sql.DataSourceDefinitions

No usage of javax.annotation.sql.DataSourceDefinitions
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AbstractBatchlet (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api

Class AbstractBatchlet

  • java.lang.Object
    • javax.batch.api.AbstractBatchlet
  • All Implemented Interfaces:
    Batchlet

    public abstract class AbstractBatchlet
extends Object
implements Batchlet
    The AbstractBatchlet provides default implementations of less commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractBatchlet()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract String process()
      Implement process logic for the Batchlet in this method.
      void stop()
      Override this method if the Batchlet will end in response to the JobOperator.stop() operation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractBatchlet

        public AbstractBatchlet()

    • Method Detail

      • process

        public abstract String process()
                        throws Exception
        Implement process logic for the Batchlet in this method.
        Specified by:
        process in interface Batchlet
        Returns:
        exit status string
        Throws:
        Exception - (or subclass) if an error occurs.

      • stop

        public void stop()
          throws Exception
        Override this method if the Batchlet will end in response to the JobOperator.stop() operation. The default implementation does nothing.
        Specified by:
        stop in interface Batchlet
        Throws:
        Exception - (or subclass) if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Batchlet (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api

Interface Batchlet

  • All Known Implementing Classes:
    AbstractBatchlet

    public interface Batchlet
    A batchlet is type of batch step that can be used for any type of background processing that does not explicitly call for a chunk oriented approach.

    A well-behaved batchlet responds to stop requests by implementing the stop method.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String process()
      The process method does the work of the batchlet.
      void stop()
      The stop method is invoked by the batch runtime as part of JobOperator.stop() method processing.

    • Method Detail

      • process

        String process()
               throws Exception
        The process method does the work of the batchlet. If this method throws an exception, the batchlet step ends with a batch status of FAILED.
        Returns:
        exit status string
        Throws:
        Exception - if an error occurs.

      • stop

        void stop()
          throws Exception
        The stop method is invoked by the batch runtime as part of JobOperator.stop() method processing. This method is invoked on a thread other than the thread on which the batchlet process method is running.
        Throws:
        Exception - if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BatchProperty (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.batch.api

Annotation Type BatchProperty

  • @Qualifier
@Target(value={FIELD,METHOD,PARAMETER})
@Retention(value=RUNTIME)
public @interface BatchProperty

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name

    • Element Detail

      • name

        public abstract String name
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Decider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api

Interface Decider

  • public interface Decider
    A Decider receives control as part of a decision element in a job. It is used to direct execution flow during job processing. It returns an exit status that updates the current job execution's exit status. This exit status value also directs the execution transition based on next, end, stop, fail child elements configured on the same decision element as the decider.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String decide(StepExecution[] executions)
      The decide method sets a new exit status for a job.

    • Method Detail

      • decide

        String decide(StepExecution[] executions)
              throws Exception
        The decide method sets a new exit status for a job. It receives an array of StepExecution objects as input. These StepExecution objects represent the execution element that transitions to this decider as follows:

        • Step

          • When the transition is from a step, the decide method receives the StepExecution corresponding to the step as input.

        • Split

          • When the transition is from a split, the decide method receives a StepExecution from each flow defined to the split as input.

        • Flow

          • When the transition is from a flow, the decide method receives a StepExecution corresponding to the last execution element that completed in the flow. This will be a single StepExecution if the last element was a step and multiple StepExecutions if the last element was a split.

        Parameters:
        executions - specifies the StepExecution(s) of the preceding element.
        Returns:
        updated job exit status
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.batch.api (Java(TM) EE 7 Specification APIs)

javax.batch.api

Interfaces

  • Batchlet
  • Decider

Classes

  • AbstractBatchlet

Annotation Types

  • BatchProperty


javax.batch.api (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.batch.api

Provides APIs used by Batch artifacts.

See: Description

  • Interface Summary
    Interface Description
    Batchlet
    A batchlet is type of batch step that can be used for any type of background processing that does not explicitly call for a chunk oriented approach.
    Decider
    A Decider receives control as part of a decision element in a job.
  • Class Summary
    Class Description
    AbstractBatchlet
    The AbstractBatchlet provides default implementations of less commonly implemented methods.
  • Annotation Types Summary
    Annotation Type Description
    BatchProperty

Package javax.batch.api Description

Provides APIs used by Batch artifacts.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.batch.api Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.batch.api

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.batch.api.AbstractBatchlet (implements javax.batch.api.Batchlet)

Interface Hierarchy

  • javax.batch.api.Batchlet
  • javax.batch.api.Decider

Annotation Type Hierarchy

  • javax.batch.api.BatchProperty (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.batch.api (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.batch.api

  • Packages that use javax.batch.api
    Package Description
    javax.batch.api
    Provides APIs used by Batch artifacts.
  • Classes in javax.batch.api used by javax.batch.api
    Class and Description
    Batchlet
    A batchlet is type of batch step that can be used for any type of background processing that does not explicitly call for a chunk oriented approach.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AbstractCheckpointAlgorithm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk

Class AbstractCheckpointAlgorithm

  • java.lang.Object
    • javax.batch.api.chunk.AbstractCheckpointAlgorithm
  • All Implemented Interfaces:
    CheckpointAlgorithm

    public abstract class AbstractCheckpointAlgorithm
extends Object
implements CheckpointAlgorithm
    The AbstractCheckpointAlgorithm provides default implementations of less commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractCheckpointAlgorithm()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void beginCheckpoint()
      Override this method for the CheckpointAlgorithm to do something before a checkpoint begins.
      int checkpointTimeout()
      Override this method if the CheckpointAlgorithm establishes a checkpoint timeout.
      void endCheckpoint()
      Override this method for the CheckpointAlgorithm to do something after a checkpoint ends.
      abstract boolean isReadyToCheckpoint()
      Implement logic in this method to decide if a checkpoint should be taken now.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractCheckpointAlgorithm

        public AbstractCheckpointAlgorithm()

    • Method Detail

      • checkpointTimeout

        public int checkpointTimeout()
                      throws Exception
        Override this method if the CheckpointAlgorithm establishes a checkpoint timeout. The default implementation returns 0, which means maximum permissible timeout allowed by runtime environment.
        Specified by:
        checkpointTimeout in interface CheckpointAlgorithm
        Returns:
        the timeout interval to use for the next checkpoint interval
        Throws:
        Exception - (or subclass) if an error occurs.

      • beginCheckpoint

        public void beginCheckpoint()
                     throws Exception
        Override this method for the CheckpointAlgorithm to do something before a checkpoint begins. The default implementation does nothing.
        Specified by:
        beginCheckpoint in interface CheckpointAlgorithm
        Throws:
        Exception - (or subclass) if an error occurs.

      • isReadyToCheckpoint

        public abstract boolean isReadyToCheckpoint()
                                     throws Exception
        Implement logic in this method to decide if a checkpoint should be taken now.
        Specified by:
        isReadyToCheckpoint in interface CheckpointAlgorithm
        Returns:
        boolean indicating whether or not to checkpoint now.
        Throws:
        Exception - (or subclass) if an error occurs.

      • endCheckpoint

        public void endCheckpoint()
                   throws Exception
        Override this method for the CheckpointAlgorithm to do something after a checkpoint ends. The default implementation does nothing.
        Specified by:
        endCheckpoint in interface CheckpointAlgorithm
        Throws:
        Exception - (or subclass) if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AbstractItemReader (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk

Class AbstractItemReader

  • java.lang.Object
    • javax.batch.api.chunk.AbstractItemReader
  • All Implemented Interfaces:
    ItemReader

    public abstract class AbstractItemReader
extends Object
implements ItemReader
    The AbstractItemReader provides default implementations of less commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractItemReader()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Serializable checkpointInfo()
      Override this method if the ItemReader supports checkpoints.
      void close()
      Override this method if the ItemReader requires any close time processing.
      void open(Serializable checkpoint)
      Override this method if the ItemReader requires any open time processing.
      abstract Object readItem()
      Implement read logic for the ItemReader in this method.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractItemReader

        public AbstractItemReader()

    • Method Detail

      • open

        public void open(Serializable checkpoint)
          throws Exception
        Override this method if the ItemReader requires any open time processing. The default implementation does nothing.
        Specified by:
        open in interface ItemReader
        Parameters:
        last - checkpoint for this ItemReader - may be null.
        Throws:
        Exception - (or subclass) if an error occurs.

      • close

        public void close()
           throws Exception
        Override this method if the ItemReader requires any close time processing. The default implementation does nothing.
        Specified by:
        close in interface ItemReader
        Throws:
        Exception - (or subclass) if an error occurs.

      • readItem

        public abstract Object readItem()
                         throws Exception
        Implement read logic for the ItemReader in this method.
        Specified by:
        readItem in interface ItemReader
        Returns:
        next item or null
        Throws:
        Exception - (or subclass) if an error occurs.

      • checkpointInfo

        public Serializable checkpointInfo()
                            throws Exception
        Override this method if the ItemReader supports checkpoints. The default implementation returns null.
        Specified by:
        checkpointInfo in interface ItemReader
        Returns:
        checkpoint data
        Throws:
        Exception - (or subclass) if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AbstractItemWriter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk

Class AbstractItemWriter

  • java.lang.Object
    • javax.batch.api.chunk.AbstractItemWriter
  • All Implemented Interfaces:
    ItemWriter

    public abstract class AbstractItemWriter
extends Object
implements ItemWriter
    The AbstractItemWriter provides default implementations of not commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractItemWriter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Serializable checkpointInfo()
      Override this method if the ItemWriter supports checkpoints.
      void close()
      Override this method if the ItemWriter requires any close time processing.
      void open(Serializable checkpoint)
      Override this method if the ItemWriter requires any open time processing.
      abstract void writeItems(List<Object> items)
      Implement write logic for the ItemWriter in this method.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractItemWriter

        public AbstractItemWriter()

    • Method Detail

      • open

        public void open(Serializable checkpoint)
          throws Exception
        Override this method if the ItemWriter requires any open time processing. The default implementation does nothing.
        Specified by:
        open in interface ItemWriter
        Parameters:
        last - checkpoint for this ItemReader
        Throws:
        Exception - (or subclass) if an error occurs.

      • close

        public void close()
           throws Exception
        Override this method if the ItemWriter requires any close time processing. The default implementation does nothing.
        Specified by:
        close in interface ItemWriter
        Throws:
        Exception - (or subclass) if an error occurs.

      • writeItems

        public abstract void writeItems(List<Object> items)
                         throws Exception
        Implement write logic for the ItemWriter in this method.
        Specified by:
        writeItems in interface ItemWriter
        Parameters:
        items - specifies the list of items to write.
        Throws:
        Exception - (or subclass) if an error occurs.

      • checkpointInfo

        public Serializable checkpointInfo()
                            throws Exception
        Override this method if the ItemWriter supports checkpoints. The default implementation returns null.
        Specified by:
        checkpointInfo in interface ItemWriter
        Returns:
        checkpoint data
        Throws:
        Exception - (or subclass) if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CheckpointAlgorithm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk

Interface CheckpointAlgorithm

  • All Known Implementing Classes:
    AbstractCheckpointAlgorithm

    public interface CheckpointAlgorithm
    CheckpointAlgorithm provides a custom checkpoint policy for chunk steps.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void beginCheckpoint()
      The beginCheckpoint method is invoked before the next checkpoint interval begins.
      int checkpointTimeout()
      The checkpointTimeout is invoked at the beginning of a new checkpoint interval for the purpose of establishing the checkpoint timeout.
      void endCheckpoint()
      The endCheckpoint method is invoked after the current checkpoint ends.
      boolean isReadyToCheckpoint()
      The isReadyToCheckpoint method is invoked by the batch runtime after each item processed to determine if now is the time to checkpoint the current chunk.

    • Method Detail

      • checkpointTimeout

        int checkpointTimeout()
                      throws Exception
        The checkpointTimeout is invoked at the beginning of a new checkpoint interval for the purpose of establishing the checkpoint timeout. It is invoked before the next checkpoint transaction begins. This method returns an integer value, which is the timeout value that will be used for the next checkpoint transaction. This method is useful to automate the setting of the checkpoint timeout based on factors known outside the job * definition.
        Parameters:
        timeout - specifies the checkpoint timeout value for the * next checkpoint interval.
        Returns:
        the timeout interval to use for the next checkpoint interval
        Throws:
        Exception - thrown for any errors.

      • beginCheckpoint

        void beginCheckpoint()
                     throws Exception
        The beginCheckpoint method is invoked before the next checkpoint interval begins.
        Throws:
        Exception - thrown for any errors.

      • isReadyToCheckpoint

        boolean isReadyToCheckpoint()
                            throws Exception
        The isReadyToCheckpoint method is invoked by the batch runtime after each item processed to determine if now is the time to checkpoint the current chunk.
        Returns:
        boolean indicating whether or not to checkpoint now.
        Throws:
        Exception - thrown for any errors.

      • endCheckpoint

        void endCheckpoint()
                   throws Exception
        The endCheckpoint method is invoked after the current checkpoint ends.
        Throws:
        Exception - thrown for any errors.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ItemProcessor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk

Interface ItemProcessor

  • public interface ItemProcessor
    ItemProcessor is used in chunk processing to operate on an input item and produce an output item.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object processItem(Object item)
      The processItem method is part of a chunk step.

    • Method Detail

      • processItem

        Object processItem(Object item)
                   throws Exception
        The processItem method is part of a chunk step. It accepts an input item from an item reader and returns an item that gets passed onto the item writer. Returning null indicates that the item should not be continued to be processed. This effectively enables processItem to filter out unwanted input items.
        Parameters:
        item - specifies the input item to process.
        Returns:
        output item to write.
        Throws:
        Exception - thrown for any errors.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ItemReader (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk

Interface ItemReader

  • All Known Implementing Classes:
    AbstractItemReader

    public interface ItemReader
    ItemReader defines the batch artifact that reads items for chunk processing.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Serializable checkpointInfo()
      The checkpointInfo method returns the current checkpoint data for this reader.
      void close()
      The close method marks the end of use of the ItemReader.
      void open(Serializable checkpoint)
      The open method prepares the reader to read items.
      Object readItem()
      The readItem method returns the next item for chunk processing.

    • Method Detail

      • open

        void open(Serializable checkpoint)
          throws Exception
        The open method prepares the reader to read items. The input parameter represents the last checkpoint for this reader in a given job instance. The checkpoint data is defined by this reader and is provided by the checkpointInfo method. The checkpoint data provides the reader whatever information it needs to resume reading items upon restart. A checkpoint value of null is passed upon initial start.
        Parameters:
        checkpoint - specifies the last checkpoint
        Throws:
        Exception - is thrown for any errors.

      • close

        void close()
           throws Exception
        The close method marks the end of use of the ItemReader. The reader is free to do any cleanup necessary.
        Throws:
        Exception - is thrown for any errors.

      • readItem

        Object readItem()
                throws Exception
        The readItem method returns the next item for chunk processing. It returns null to indicate no more items, which also means the current chunk will be committed and the step will end.
        Returns:
        next item or null
        Throws:
        Exception - is thrown for any errors.

      • checkpointInfo

        Serializable checkpointInfo()
                            throws Exception
        The checkpointInfo method returns the current checkpoint data for this reader. It is called before a chunk checkpoint is committed.
        Returns:
        checkpoint data
        Throws:
        Exception - is thrown for any errors.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ItemWriter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk

Interface ItemWriter

  • All Known Implementing Classes:
    AbstractItemWriter

    public interface ItemWriter
    ItemWriter defines the batch artifact that writes to a list of items for chunk processing.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Serializable checkpointInfo()
      The checkpointInfo method returns the current checkpoint data for this writer.
      void close()
      The close method marks the end of use of the ItemWriter.
      void open(Serializable checkpoint)
      The open method prepares the writer to write items.
      void writeItems(List<Object> items)
      The writeItems method writes a list of item for the current chunk.

    • Method Detail

      • open

        void open(Serializable checkpoint)
          throws Exception
        The open method prepares the writer to write items. The input parameter represents the last checkpoint for this writer in a given job instance. The checkpoint data is defined by this writer and is provided by the checkpointInfo method. The checkpoint data provides the writer whatever information it needs to resume writing items upon restart. A checkpoint value of null is passed upon initial start.
        Parameters:
        checkpoint - specifies the last checkpoint
        Throws:
        Exception - is thrown for any errors.

      • close

        void close()
           throws Exception
        The close method marks the end of use of the ItemWriter. The writer is free to do any cleanup necessary.
        Throws:
        Exception - is thrown for any errors.

      • writeItems

        void writeItems(List<Object> items)
                throws Exception
        The writeItems method writes a list of item for the current chunk.
        Parameters:
        items - specifies the list of items to write.
        Throws:
        Exception - is thrown for any errors.

      • checkpointInfo

        Serializable checkpointInfo()
                            throws Exception
        The checkpointInfo method returns the current checkpoint data for this writer. It is called before a chunk checkpoint is committed.
        Returns:
        checkpoint data
        Throws:
        Exception - is thrown for any errors.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.batch.api.chunk (Java(TM) EE 7 Specification APIs)

javax.batch.api.chunk

Interfaces

  • CheckpointAlgorithm
  • ItemProcessor
  • ItemReader
  • ItemWriter

Classes

  • AbstractCheckpointAlgorithm
  • AbstractItemReader
  • AbstractItemWriter


javax.batch.api.chunk (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.batch.api.chunk

Provides APIs used by artifacts in a Batch chunk step.

See: Description

  • Interface Summary
    Interface Description
    CheckpointAlgorithm
    CheckpointAlgorithm provides a custom checkpoint policy for chunk steps.
    ItemProcessor
    ItemProcessor is used in chunk processing to operate on an input item and produce an output item.
    ItemReader
    ItemReader defines the batch artifact that reads items for chunk processing.
    ItemWriter
    ItemWriter defines the batch artifact that writes to a list of items for chunk processing.
  • Class Summary
    Class Description
    AbstractCheckpointAlgorithm
    The AbstractCheckpointAlgorithm provides default implementations of less commonly implemented methods.
    AbstractItemReader
    The AbstractItemReader provides default implementations of less commonly implemented methods.
    AbstractItemWriter
    The AbstractItemWriter provides default implementations of not commonly implemented methods.

Package javax.batch.api.chunk Description

Provides APIs used by artifacts in a Batch chunk step.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.batch.api.chunk Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.batch.api.chunk

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.batch.api.chunk.AbstractCheckpointAlgorithm (implements javax.batch.api.chunk.CheckpointAlgorithm)
    • javax.batch.api.chunk.AbstractItemReader (implements javax.batch.api.chunk.ItemReader)
    • javax.batch.api.chunk.AbstractItemWriter (implements javax.batch.api.chunk.ItemWriter)

Interface Hierarchy

  • javax.batch.api.chunk.CheckpointAlgorithm
  • javax.batch.api.chunk.ItemProcessor
  • javax.batch.api.chunk.ItemReader
  • javax.batch.api.chunk.ItemWriter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.batch.api.chunk (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.batch.api.chunk

  • Packages that use javax.batch.api.chunk
    Package Description
    javax.batch.api.chunk
    Provides APIs used by artifacts in a Batch chunk step.
  • Classes in javax.batch.api.chunk used by javax.batch.api.chunk
    Class and Description
    CheckpointAlgorithm
    CheckpointAlgorithm provides a custom checkpoint policy for chunk steps.
    ItemReader
    ItemReader defines the batch artifact that reads items for chunk processing.
    ItemWriter
    ItemWriter defines the batch artifact that writes to a list of items for chunk processing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.chunk.AbstractCheckpointAlgorithm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.chunk.AbstractCheckpointAlgorithm

No usage of javax.batch.api.chunk.AbstractCheckpointAlgorithm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.chunk.AbstractItemReader (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.chunk.AbstractItemReader

No usage of javax.batch.api.chunk.AbstractItemReader
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.chunk.AbstractItemWriter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.chunk.AbstractItemWriter

No usage of javax.batch.api.chunk.AbstractItemWriter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.CheckpointAlgorithm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.CheckpointAlgorithm

  • Packages that use CheckpointAlgorithm
    Package Description
    javax.batch.api.chunk
    Provides APIs used by artifacts in a Batch chunk step.

    • Uses of CheckpointAlgorithm in javax.batch.api.chunk

      Classes in javax.batch.api.chunk that implement CheckpointAlgorithm
      Modifier and Type Class and Description
      class  AbstractCheckpointAlgorithm
      The AbstractCheckpointAlgorithm provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.ItemProcessor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.ItemProcessor

No usage of javax.batch.api.chunk.ItemProcessor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.ItemReader (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.ItemReader

  • Packages that use ItemReader
    Package Description
    javax.batch.api.chunk
    Provides APIs used by artifacts in a Batch chunk step.

    • Uses of ItemReader in javax.batch.api.chunk

      Classes in javax.batch.api.chunk that implement ItemReader
      Modifier and Type Class and Description
      class  AbstractItemReader
      The AbstractItemReader provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.ItemWriter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.ItemWriter

  • Packages that use ItemWriter
    Package Description
    javax.batch.api.chunk
    Provides APIs used by artifacts in a Batch chunk step.

    • Uses of ItemWriter in javax.batch.api.chunk

      Classes in javax.batch.api.chunk that implement ItemWriter
      Modifier and Type Class and Description
      class  AbstractItemWriter
      The AbstractItemWriter provides default implementations of not commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AbstractChunkListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Class AbstractChunkListener

  • java.lang.Object
    • javax.batch.api.chunk.listener.AbstractChunkListener
  • All Implemented Interfaces:
    ChunkListener

    public abstract class AbstractChunkListener
extends Object
implements ChunkListener
    The AbstractChunkListener provides default implementations of less commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractChunkListener()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterChunk()
      Override this method if the ChunkListener will do something after the chunk ends.
      void beforeChunk()
      Override this method if the ChunkListener will do something before the chunk begins.
      void onError(Exception ex)
      Override this method if the ChunkListener will do something before the chunk transaction is rolled back.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractChunkListener

        public AbstractChunkListener()

    • Method Detail

      • beforeChunk

        public void beforeChunk()
                 throws Exception
        Override this method if the ChunkListener will do something before the chunk begins. The default implementation does nothing.
        Specified by:
        beforeChunk in interface ChunkListener
        Throws:
        Exception - (or subclass) if an error occurs.

      • onError

        public void onError(Exception ex)
             throws Exception
        Override this method if the ChunkListener will do something before the chunk transaction is rolled back. Note afterChunk is not invoked in this case.
        Specified by:
        onError in interface ChunkListener
        Parameters:
        ex - specifies the exception that caused the roll back.
        Throws:
        Exception - (or subclass) throw if an error occurs.

      • afterChunk

        public void afterChunk()
                throws Exception
        Override this method if the ChunkListener will do something after the chunk ends. The default implementation does nothing.
        Specified by:
        afterChunk in interface ChunkListener
        Throws:
        Exception - (or subclass) if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AbstractItemProcessListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Class AbstractItemProcessListener

  • java.lang.Object
    • javax.batch.api.chunk.listener.AbstractItemProcessListener
  • All Implemented Interfaces:
    ItemProcessListener

    public abstract class AbstractItemProcessListener
extends Object
implements ItemProcessListener
    The AbstractItemProcessListener provides default implementations of less commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractItemProcessListener()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterProcess(Object item, Object result)
      Override this method if the ItemProcessListener will do something after the item is processed.
      void beforeProcess(Object item)
      Override this method if the ItemProcessListener will do something before the item is processed.
      void onProcessError(Object item, Exception ex)
      Override this method if the ItemProcessListener will do something when the ItemProcessor processItem method throws an exception.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractItemProcessListener

        public AbstractItemProcessListener()

    • Method Detail

      • beforeProcess

        public void beforeProcess(Object item)
                   throws Exception
        Override this method if the ItemProcessListener will do something before the item is processed. The default implementation does nothing.
        Specified by:
        beforeProcess in interface ItemProcessListener
        Parameters:
        item - specifies the item about to be processed.
        Throws:
        Exception - (or subclass) if an error occurs.

      • afterProcess

        public void afterProcess(Object item,
                Object result)
                  throws Exception
        Override this method if the ItemProcessListener will do something after the item is processed. The default implementation does nothing.
        Specified by:
        afterProcess in interface ItemProcessListener
        Parameters:
        item - specifies the item about to be processed.
        result - specifies the item to pass to the item writer.
        Throws:
        Exception - (or subclass) if an error occurs.

      • onProcessError

        public void onProcessError(Object item,
                  Exception ex)
                    throws Exception
        Override this method if the ItemProcessListener will do something when the ItemProcessor processItem method throws an exception. The default implementation does nothing.
        Specified by:
        onProcessError in interface ItemProcessListener
        Parameters:
        item - specifies the item about to be processed.
        ex - specifies the exception thrown by the item processor.
        Throws:
        Exception - (or subclass) if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AbstractItemReadListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Class AbstractItemReadListener

  • java.lang.Object
    • javax.batch.api.chunk.listener.AbstractItemReadListener
  • All Implemented Interfaces:
    ItemReadListener

    public abstract class AbstractItemReadListener
extends Object
implements ItemReadListener
    The AbstractItemReadListener provides default implementations of less commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractItemReadListener()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterRead(Object item)
      Override this method if the ItemReadListener will do something after the item is read.
      void beforeRead()
      Override this method if the ItemReadListener will do something before the item is read.
      void onReadError(Exception ex)
      Override this method if the ItemReadListener will do something when the ItemReader readItem method throws an exception.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractItemReadListener

        public AbstractItemReadListener()

    • Method Detail

      • beforeRead

        public void beforeRead()
                throws Exception
        Override this method if the ItemReadListener will do something before the item is read. The default implementation does nothing.
        Specified by:
        beforeRead in interface ItemReadListener
        Throws:
        Exception - (or subclass) if an error occurs.

      • afterRead

        public void afterRead(Object item)
               throws Exception
        Override this method if the ItemReadListener will do something after the item is read. The default implementation does nothing.
        Specified by:
        afterRead in interface ItemReadListener
        Parameters:
        item - specifies the item read by the item reader.
        Throws:
        Exception - (or subclass) if an error occurs.

      • onReadError

        public void onReadError(Exception ex)
                 throws Exception
        Override this method if the ItemReadListener will do something when the ItemReader readItem method throws an exception. The default implementation does nothing.
        Specified by:
        onReadError in interface ItemReadListener
        Parameters:
        ex - specifies the exception that occurred in the item reader.
        Throws:
        Exception - (or subclass) if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AbstractItemWriteListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Class AbstractItemWriteListener

  • java.lang.Object
    • javax.batch.api.chunk.listener.AbstractItemWriteListener
  • All Implemented Interfaces:
    ItemWriteListener

    public abstract class AbstractItemWriteListener
extends Object
implements ItemWriteListener
    The AbstractItemWriteListener provides default implementations of less commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractItemWriteListener()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterWrite(List<Object> items)
      Override this method if the ItemWriteListener will do something after the items are written.
      void beforeWrite(List<Object> items)
      Override this method if the ItemWriteListener will do something before the items are written.
      void onWriteError(List<Object> items, Exception ex)
      Override this method if the ItemWriteListener will do something when the ItemWriter writeItems method throws an exception.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractItemWriteListener

        public AbstractItemWriteListener()

    • Method Detail

      • beforeWrite

        public void beforeWrite(List<Object> items)
                 throws Exception
        Override this method if the ItemWriteListener will do something before the items are written. The default implementation does nothing.
        Specified by:
        beforeWrite in interface ItemWriteListener
        Parameters:
        items - specifies the items about to be written.
        Throws:
        Exception - (or subclass) if an error occurs.

      • afterWrite

        public void afterWrite(List<Object> items)
                throws Exception
        Override this method if the ItemWriteListener will do something after the items are written. The default implementation does nothing.
        Specified by:
        afterWrite in interface ItemWriteListener
        Parameters:
        items - specifies the items about to be written.
        Throws:
        Exception - (or subclass) if an error occurs.

      • onWriteError

        public void onWriteError(List<Object> items,
                Exception ex)
                  throws Exception
        Override this method if the ItemWriteListener will do something when the ItemWriter writeItems method throws an exception. The default implementation does nothing.
        Specified by:
        onWriteError in interface ItemWriteListener
        Parameters:
        items - specifies the items about to be written.
        ex - specifies the exception thrown by the item writer.
        Throws:
        Exception - (or subclass) if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ChunkListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Interface ChunkListener

  • All Known Implementing Classes:
    AbstractChunkListener

    public interface ChunkListener
    ChunkListener intercepts chunk processing.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterChunk()
      The afterChunk method receives control after processing of the current chunk ends.
      void beforeChunk()
      The beforeChunk method receives control before processing of the next chunk begins.
      void onError(Exception ex)
      The onError method receives control before the chunk transaction is rolled back.

    • Method Detail

      • beforeChunk

        void beforeChunk()
                 throws Exception
        The beforeChunk method receives control before processing of the next chunk begins. This method is invoked in the same transaction as the chunk processing.
        Throws:
        Exception - throw if an error occurs.

      • onError

        void onError(Exception ex)
             throws Exception
        The onError method receives control before the chunk transaction is rolled back. Note afterChunk is not invoked in this case.
        Parameters:
        ex - specifies the exception that caused the roll back.
        Throws:
        Exception - throw if an error occurs.

      • afterChunk

        void afterChunk()
                throws Exception
        The afterChunk method receives control after processing of the current chunk ends. This method is invoked in the same transaction as the chunk processing.
        Throws:
        Exception - throw if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ItemProcessListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Interface ItemProcessListener

  • All Known Implementing Classes:
    AbstractItemProcessListener

    public interface ItemProcessListener
    ItemProcessListener intercepts item processing.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterProcess(Object item, Object result)
      The afterProcess method receives control after an item processor processes an item.
      void beforeProcess(Object item)
      The beforeProcess method receives control before an item processor is called to process the next item.
      void onProcessError(Object item, Exception ex)
      The afterProcess method receives control after an item processor processes an item.

    • Method Detail

      • beforeProcess

        void beforeProcess(Object item)
                   throws Exception
        The beforeProcess method receives control before an item processor is called to process the next item. The method receives the item to be processed as an input.
        Parameters:
        item - specifies the item about to be processed.
        Throws:
        Exception - if an error occurs.

      • afterProcess

        void afterProcess(Object item,
                Object result)
                  throws Exception
        The afterProcess method receives control after an item processor processes an item. The method receives the item processed and the result item as an input.
        Parameters:
        item - specifies the item about to be processed.
        result - specifies the item to pass to the item writer.
        Throws:
        Exception - if an error occurs.

      • onProcessError

        void onProcessError(Object item,
                  Exception ex)
                    throws Exception
        The afterProcess method receives control after an item processor processes an item. The method receives the item processed and the result item as an input.
        Parameters:
        item - specifies the item about to be processed.
        ex - specifies the exception thrown by the item processor.
        Throws:
        Exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ItemReadListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Interface ItemReadListener

  • All Known Implementing Classes:
    AbstractItemReadListener

    public interface ItemReadListener
    ItemReadListener intercepts item reader processing.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterRead(Object item)
      The afterRead method receives control after an item reader reads an item.
      void beforeRead()
      The beforeRead method receives control before an item reader is called to read the next item.
      void onReadError(Exception ex)
      The onReadError method receives control after an item reader throws an exception in the readItem method.

    • Method Detail

      • beforeRead

        void beforeRead()
                throws Exception
        The beforeRead method receives control before an item reader is called to read the next item.
        Throws:
        Exception - is thrown if an error occurs.

      • afterRead

        void afterRead(Object item)
               throws Exception
        The afterRead method receives control after an item reader reads an item. The method receives the item read as an input.
        Parameters:
        item - specifies the item read by the item reader.
        Throws:
        Exception - is thrown if an error occurs.

      • onReadError

        void onReadError(Exception ex)
                 throws Exception
        The onReadError method receives control after an item reader throws an exception in the readItem method. This method receives the exception as an input.
        Parameters:
        ex - specifies the exception that occurred in the item reader.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ItemWriteListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Interface ItemWriteListener

  • All Known Implementing Classes:
    AbstractItemWriteListener

    public interface ItemWriteListener
    ItemWriteListener intercepts item writer processing.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterWrite(List<Object> items)
      The afterWrite method receives control after an item writer writes its items.
      void beforeWrite(List<Object> items)
      The beforeWrite method receives control before an item writer is called to write its items.
      void onWriteError(List<Object> items, Exception ex)
      The onWriteError method receives control after an item writer writeItems throws an exception.

    • Method Detail

      • beforeWrite

        void beforeWrite(List<Object> items)
                 throws Exception
        The beforeWrite method receives control before an item writer is called to write its items. The method receives the list of items sent to the item reader as an input.
        Parameters:
        items - specifies the items about to be written.
        Throws:
        Exception - is thrown if an error occurs.

      • afterWrite

        void afterWrite(List<Object> items)
                throws Exception
        The afterWrite method receives control after an item writer writes its items. The method receives the list of items sent to the item reader as an input.
        Parameters:
        items - specifies the items about to be written.
        Throws:
        Exception - is thrown if an error occurs.

      • onWriteError

        void onWriteError(List<Object> items,
                Exception ex)
                  throws Exception
        The onWriteError method receives control after an item writer writeItems throws an exception. The method receives the list of items sent to the item reader as an input.
        Parameters:
        items - specifies the items about to be written.
        ex - specifies the exception thrown by the item writer.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.batch.api.chunk.listener (Java(TM) EE 7 Specification APIs)

javax.batch.api.chunk.listener

Interfaces

  • ChunkListener
  • ItemProcessListener
  • ItemReadListener
  • ItemWriteListener
  • RetryProcessListener
  • RetryReadListener
  • RetryWriteListener
  • SkipProcessListener
  • SkipReadListener
  • SkipWriteListener

Classes

  • AbstractChunkListener
  • AbstractItemProcessListener
  • AbstractItemReadListener
  • AbstractItemWriteListener


javax.batch.api.chunk.listener (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.batch.api.chunk.listener

Provides APIs defining listener artifacts for a Batch chunk step.

See: Description

  • Interface Summary
    Interface Description
    ChunkListener
    ChunkListener intercepts chunk processing.
    ItemProcessListener
    ItemProcessListener intercepts item processing.
    ItemReadListener
    ItemReadListener intercepts item reader processing.
    ItemWriteListener
    ItemWriteListener intercepts item writer processing.
    RetryProcessListener
    RetryProcessListener intercepts retry processing for an ItemProcessor.
    RetryReadListener
    RetryReadListener intercepts retry processing for an ItemReader.
    RetryWriteListener
    RetryWriteListener intercepts retry processing for an ItemWriter.
    SkipProcessListener
    SkipProcessListener intercepts skippable itemProcess exception handling.
    SkipReadListener
    SkipReadListener intercepts skippable itemReader exception handling.
    SkipWriteListener
    SkipWriteListener intercepts skippable itemWriter exception handling.
  • Class Summary
    Class Description
    AbstractChunkListener
    The AbstractChunkListener provides default implementations of less commonly implemented methods.
    AbstractItemProcessListener
    The AbstractItemProcessListener provides default implementations of less commonly implemented methods.
    AbstractItemReadListener
    The AbstractItemReadListener provides default implementations of less commonly implemented methods.
    AbstractItemWriteListener
    The AbstractItemWriteListener provides default implementations of less commonly implemented methods.

Package javax.batch.api.chunk.listener Description

Provides APIs defining listener artifacts for a Batch chunk step.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.batch.api.chunk.listener Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.batch.api.chunk.listener

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.batch.api.chunk.listener.AbstractChunkListener (implements javax.batch.api.chunk.listener.ChunkListener)
    • javax.batch.api.chunk.listener.AbstractItemProcessListener (implements javax.batch.api.chunk.listener.ItemProcessListener)
    • javax.batch.api.chunk.listener.AbstractItemReadListener (implements javax.batch.api.chunk.listener.ItemReadListener)
    • javax.batch.api.chunk.listener.AbstractItemWriteListener (implements javax.batch.api.chunk.listener.ItemWriteListener)

Interface Hierarchy

  • javax.batch.api.chunk.listener.ChunkListener
  • javax.batch.api.chunk.listener.ItemProcessListener
  • javax.batch.api.chunk.listener.ItemReadListener
  • javax.batch.api.chunk.listener.ItemWriteListener
  • javax.batch.api.chunk.listener.RetryProcessListener
  • javax.batch.api.chunk.listener.RetryReadListener
  • javax.batch.api.chunk.listener.RetryWriteListener
  • javax.batch.api.chunk.listener.SkipProcessListener
  • javax.batch.api.chunk.listener.SkipReadListener
  • javax.batch.api.chunk.listener.SkipWriteListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


RetryProcessListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Interface RetryProcessListener

  • public interface RetryProcessListener
    RetryProcessListener intercepts retry processing for an ItemProcessor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onRetryProcessException(Object item, Exception ex)
      The onRetryProcessException method receives control when a retryable exception is thrown from an ItemProcessor processItem method.

    • Method Detail

      • onRetryProcessException

        void onRetryProcessException(Object item,
                           Exception ex)
                             throws Exception
        The onRetryProcessException method receives control when a retryable exception is thrown from an ItemProcessor processItem method. This method receives the exception and the item being processed as inputs. This method receives control in same checkpoint scope as the ItemProcessor. If this method throws a an exception, the job ends in the FAILED state.
        Parameters:
        item - specifies the item passed to the ItemProcessor.
        ex - specifies the exception thrown by the ItemProcessor.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RetryReadListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Interface RetryReadListener

  • public interface RetryReadListener
    RetryReadListener intercepts retry processing for an ItemReader.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onRetryReadException(Exception ex)
      The onRetryReadException method receives control when a retryable exception is thrown from an ItemReader readItem method.

    • Method Detail

      • onRetryReadException

        void onRetryReadException(Exception ex)
                          throws Exception
        The onRetryReadException method receives control when a retryable exception is thrown from an ItemReader readItem method. This method receives the exception as input. This method receives control in the same checkpoint scope as the ItemReader. If this method throws a an exception, the job ends in the FAILED state.
        Parameters:
        ex - specifies the exception thrown by the item reader.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RetryWriteListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Interface RetryWriteListener

  • public interface RetryWriteListener
    RetryWriteListener intercepts retry processing for an ItemWriter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onRetryWriteException(List<Object> items, Exception ex)
      The onRetryWriteException method receives control when a retryable exception is thrown from an ItemWriter writeItems method.

    • Method Detail

      • onRetryWriteException

        void onRetryWriteException(List<Object> items,
                         Exception ex)
                           throws Exception
        The onRetryWriteException method receives control when a retryable exception is thrown from an ItemWriter writeItems method. This method receives the exception and the list of items being written as inputs. This method receives control in same checkpoint scope as the ItemWriter. If this method throws a an exception, the job ends in the FAILED state.
        Parameters:
        items - specify the items passed to an item writer.
        ex - specifies the exception thrown by an item writer.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SkipProcessListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Interface SkipProcessListener

  • public interface SkipProcessListener
    SkipProcessListener intercepts skippable itemProcess exception handling.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onSkipProcessItem(Object item, Exception ex)
      The onSkipProcessItem method receives control when a skippable exception is thrown from an ItemProcess processItem method.

    • Method Detail

      • onSkipProcessItem

        void onSkipProcessItem(Object item,
                     Exception ex)
                       throws Exception
        The onSkipProcessItem method receives control when a skippable exception is thrown from an ItemProcess processItem method. This method receives the exception and the item to process as an input.
        Parameters:
        item - specifies the item passed to the ItemProcessor.
        ex - specifies the exception thrown by the ItemProcessor.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SkipReadListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Interface SkipReadListener

  • public interface SkipReadListener
    SkipReadListener intercepts skippable itemReader exception handling.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onSkipReadItem(Exception ex)
      The onSkipReadItem method receives control when a skippable exception is thrown from an ItemReader readItem method.

    • Method Detail

      • onSkipReadItem

        void onSkipReadItem(Exception ex)
                    throws Exception
        The onSkipReadItem method receives control when a skippable exception is thrown from an ItemReader readItem method. This method receives the exception as an input.
        Parameters:
        ex - specifies the exception thrown by the ItemReader.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SkipWriteListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.chunk.listener

Interface SkipWriteListener

  • public interface SkipWriteListener
    SkipWriteListener intercepts skippable itemWriter exception handling.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onSkipWriteItem(List<Object> items, Exception ex)
      The onSkipWriteItems method receives control when a skippable exception is thrown from an ItemWriter writeItems method.

    • Method Detail

      • onSkipWriteItem

        void onSkipWriteItem(List<Object> items,
                   Exception ex)
                     throws Exception
        The onSkipWriteItems method receives control when a skippable exception is thrown from an ItemWriter writeItems method. This method receives the exception and the items that were skipped as an input.
        Parameters:
        items - specifies the list of item passed to the item writer.
        ex - specifies the exception thrown by the ItemWriter.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.batch.api.chunk.listener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.batch.api.chunk.listener

  • Packages that use javax.batch.api.chunk.listener
    Package Description
    javax.batch.api.chunk.listener
    Provides APIs defining listener artifacts for a Batch chunk step.
  • Classes in javax.batch.api.chunk.listener used by javax.batch.api.chunk.listener
    Class and Description
    ChunkListener
    ChunkListener intercepts chunk processing.
    ItemProcessListener
    ItemProcessListener intercepts item processing.
    ItemReadListener
    ItemReadListener intercepts item reader processing.
    ItemWriteListener
    ItemWriteListener intercepts item writer processing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.chunk.listener.AbstractChunkListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.chunk.listener.AbstractChunkListener

No usage of javax.batch.api.chunk.listener.AbstractChunkListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.chunk.listener.AbstractItemProcessListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.chunk.listener.AbstractItemProcessListener

No usage of javax.batch.api.chunk.listener.AbstractItemProcessListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.chunk.listener.AbstractItemReadListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.chunk.listener.AbstractItemReadListener

No usage of javax.batch.api.chunk.listener.AbstractItemReadListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.chunk.listener.AbstractItemWriteListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.chunk.listener.AbstractItemWriteListener

No usage of javax.batch.api.chunk.listener.AbstractItemWriteListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.listener.ChunkListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.listener.ChunkListener

  • Packages that use ChunkListener
    Package Description
    javax.batch.api.chunk.listener
    Provides APIs defining listener artifacts for a Batch chunk step.

    • Uses of ChunkListener in javax.batch.api.chunk.listener

      Classes in javax.batch.api.chunk.listener that implement ChunkListener
      Modifier and Type Class and Description
      class  AbstractChunkListener
      The AbstractChunkListener provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.listener.ItemProcessListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.listener.ItemProcessListener

  • Packages that use ItemProcessListener
    Package Description
    javax.batch.api.chunk.listener
    Provides APIs defining listener artifacts for a Batch chunk step.

    • Uses of ItemProcessListener in javax.batch.api.chunk.listener

      Classes in javax.batch.api.chunk.listener that implement ItemProcessListener
      Modifier and Type Class and Description
      class  AbstractItemProcessListener
      The AbstractItemProcessListener provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.listener.ItemReadListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.listener.ItemReadListener

  • Packages that use ItemReadListener
    Package Description
    javax.batch.api.chunk.listener
    Provides APIs defining listener artifacts for a Batch chunk step.

    • Uses of ItemReadListener in javax.batch.api.chunk.listener

      Classes in javax.batch.api.chunk.listener that implement ItemReadListener
      Modifier and Type Class and Description
      class  AbstractItemReadListener
      The AbstractItemReadListener provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.listener.ItemWriteListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.listener.ItemWriteListener

  • Packages that use ItemWriteListener
    Package Description
    javax.batch.api.chunk.listener
    Provides APIs defining listener artifacts for a Batch chunk step.

    • Uses of ItemWriteListener in javax.batch.api.chunk.listener

      Classes in javax.batch.api.chunk.listener that implement ItemWriteListener
      Modifier and Type Class and Description
      class  AbstractItemWriteListener
      The AbstractItemWriteListener provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.listener.RetryProcessListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.listener.RetryProcessListener

No usage of javax.batch.api.chunk.listener.RetryProcessListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.listener.RetryReadListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.listener.RetryReadListener

No usage of javax.batch.api.chunk.listener.RetryReadListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.listener.RetryWriteListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.listener.RetryWriteListener

No usage of javax.batch.api.chunk.listener.RetryWriteListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.listener.SkipProcessListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.listener.SkipProcessListener

No usage of javax.batch.api.chunk.listener.SkipProcessListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.listener.SkipReadListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.listener.SkipReadListener

No usage of javax.batch.api.chunk.listener.SkipReadListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.chunk.listener.SkipWriteListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.chunk.listener.SkipWriteListener

No usage of javax.batch.api.chunk.listener.SkipWriteListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.AbstractBatchlet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.AbstractBatchlet

No usage of javax.batch.api.AbstractBatchlet
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.BatchProperty (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.BatchProperty

No usage of javax.batch.api.BatchProperty
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.Batchlet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.Batchlet

  • Packages that use Batchlet
    Package Description
    javax.batch.api
    Provides APIs used by Batch artifacts.

    • Uses of Batchlet in javax.batch.api

      Classes in javax.batch.api that implement Batchlet
      Modifier and Type Class and Description
      class  AbstractBatchlet
      The AbstractBatchlet provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.Decider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.Decider

No usage of javax.batch.api.Decider
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AbstractJobListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.listener

Class AbstractJobListener

  • java.lang.Object
    • javax.batch.api.listener.AbstractJobListener
  • All Implemented Interfaces:
    JobListener

    public abstract class AbstractJobListener
extends Object
implements JobListener
    The AbstractJobListener provides default implementations of less commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractJobListener()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterJob()
      Override this method if the JobListener will do something after the job ends.
      void beforeJob()
      Override this method if the JobListener will do something before the job begins.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractJobListener

        public AbstractJobListener()

    • Method Detail

      • beforeJob

        public void beforeJob()
               throws Exception
        Override this method if the JobListener will do something before the job begins. The default implementation does nothing.
        Specified by:
        beforeJob in interface JobListener
        Throws:
        Exception - (or subclass) if an error occurs.

      • afterJob

        public void afterJob()
              throws Exception
        Override this method if the JobListener will do something after the job ends. The default implementation does nothing.
        Specified by:
        afterJob in interface JobListener
        Throws:
        Exception - (or subclass) if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AbstractStepListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.listener

Class AbstractStepListener

  • java.lang.Object
    • javax.batch.api.listener.AbstractStepListener
  • All Implemented Interfaces:
    StepListener

    public abstract class AbstractStepListener
extends Object
implements StepListener
    The AbstractStepListener provides default implementations of less commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractStepListener()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterStep()
      Override this method if the StepListener will do something after the step ends.
      void beforeStep()
      Override this method if the StepListener will do something before the step begins.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractStepListener

        public AbstractStepListener()

    • Method Detail

      • beforeStep

        public void beforeStep()
                throws Exception
        Override this method if the StepListener will do something before the step begins. The default implementation does nothing.
        Specified by:
        beforeStep in interface StepListener
        Throws:
        Exception - (or subclass) if an error occurs.

      • afterStep

        public void afterStep()
               throws Exception
        Override this method if the StepListener will do something after the step ends. The default implementation does nothing.
        Specified by:
        afterStep in interface StepListener
        Throws:
        Exception - (or subclass) if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.batch.api.listener (Java(TM) EE 7 Specification APIs)

javax.batch.api.listener

Interfaces

  • JobListener
  • StepListener

Classes

  • AbstractJobListener
  • AbstractStepListener


javax.batch.api.listener (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.batch.api.listener

Provides APIs defining Batch job-level and step-level listener artifacts.

See: Description

  • Interface Summary
    Interface Description
    JobListener
    JobListener intercepts job execution.
    StepListener
    StepListener intercepts step execution.
  • Class Summary
    Class Description
    AbstractJobListener
    The AbstractJobListener provides default implementations of less commonly implemented methods.
    AbstractStepListener
    The AbstractStepListener provides default implementations of less commonly implemented methods.

Package javax.batch.api.listener Description

Provides APIs defining Batch job-level and step-level listener artifacts.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.batch.api.listener Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.batch.api.listener

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.batch.api.listener.AbstractJobListener (implements javax.batch.api.listener.JobListener)
    • javax.batch.api.listener.AbstractStepListener (implements javax.batch.api.listener.StepListener)

Interface Hierarchy

  • javax.batch.api.listener.JobListener
  • javax.batch.api.listener.StepListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JobListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.listener

Interface JobListener

  • All Known Implementing Classes:
    AbstractJobListener

    public interface JobListener
    JobListener intercepts job execution.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterJob()
      The afterJob method receives control after the job execution ends.
      void beforeJob()
      The beforeJob method receives control before the job execution begins.

    • Method Detail

      • beforeJob

        void beforeJob()
               throws Exception
        The beforeJob method receives control before the job execution begins.
        Throws:
        Exception - throw if an error occurs.

      • afterJob

        void afterJob()
              throws Exception
        The afterJob method receives control after the job execution ends.
        Throws:
        Exception - throw if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StepListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.listener

Interface StepListener

  • All Known Implementing Classes:
    AbstractStepListener

    public interface StepListener
    StepListener intercepts step execution.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterStep()
      The afterStep method receives control after a step execution ends.
      void beforeStep()
      The beforeStep method receives control before a step execution begins.

    • Method Detail

      • beforeStep

        void beforeStep()
                throws Exception
        The beforeStep method receives control before a step execution begins.
        Throws:
        Exception - throw if an error occurs.

      • afterStep

        void afterStep()
               throws Exception
        The afterStep method receives control after a step execution ends.
        Throws:
        Exception - throw if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.batch.api.listener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.batch.api.listener

  • Packages that use javax.batch.api.listener
    Package Description
    javax.batch.api.listener
    Provides APIs defining Batch job-level and step-level listener artifacts.
  • Classes in javax.batch.api.listener used by javax.batch.api.listener
    Class and Description
    JobListener
    JobListener intercepts job execution.
    StepListener
    StepListener intercepts step execution.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.listener.AbstractJobListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.listener.AbstractJobListener

No usage of javax.batch.api.listener.AbstractJobListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.listener.AbstractStepListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.listener.AbstractStepListener

No usage of javax.batch.api.listener.AbstractStepListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.listener.JobListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.listener.JobListener

  • Packages that use JobListener
    Package Description
    javax.batch.api.listener
    Provides APIs defining Batch job-level and step-level listener artifacts.

    • Uses of JobListener in javax.batch.api.listener

      Classes in javax.batch.api.listener that implement JobListener
      Modifier and Type Class and Description
      class  AbstractJobListener
      The AbstractJobListener provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.listener.StepListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.listener.StepListener

  • Packages that use StepListener
    Package Description
    javax.batch.api.listener
    Provides APIs defining Batch job-level and step-level listener artifacts.

    • Uses of StepListener in javax.batch.api.listener

      Classes in javax.batch.api.listener that implement StepListener
      Modifier and Type Class and Description
      class  AbstractStepListener
      The AbstractStepListener provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AbstractPartitionAnalyzer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.partition

Class AbstractPartitionAnalyzer

  • java.lang.Object
    • javax.batch.api.partition.AbstractPartitionAnalyzer
  • All Implemented Interfaces:
    PartitionAnalyzer

    public abstract class AbstractPartitionAnalyzer
extends Object
implements PartitionAnalyzer
    The AbstractPartitionAnalyzer provides default implementations of less commonly implemented methods.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractPartitionAnalyzer()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void analyzeCollectorData(Serializable data)
      Override this method to analyze PartitionCollector payloads.
      void analyzeStatus(BatchStatus batchStatus, String exitStatus)
      Override this method to analyze partition end status.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractPartitionAnalyzer

        public AbstractPartitionAnalyzer()

    • Method Detail

      • analyzeCollectorData

        public void analyzeCollectorData(Serializable data)
                          throws Exception
        Override this method to analyze PartitionCollector payloads.
        Specified by:
        analyzeCollectorData in interface PartitionAnalyzer
        Parameters:
        data - specifies the payload sent by the PartitionCollector.
        Throws:
        Exception - is thrown if an error occurs.

      • analyzeStatus

        public void analyzeStatus(BatchStatus batchStatus,
                 String exitStatus)
                   throws Exception
        Override this method to analyze partition end status.
        Specified by:
        analyzeStatus in interface PartitionAnalyzer
        Parameters:
        batchStatus - specifies the batch status of a partition.
        exitStatus - specifies the exit status of a partition.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AbstractPartitionReducer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.partition

Class AbstractPartitionReducer

  • java.lang.Object
    • javax.batch.api.partition.AbstractPartitionReducer
  • All Implemented Interfaces:
    PartitionReducer

    public abstract class AbstractPartitionReducer
extends Object
implements PartitionReducer
    The AbstractBatchlet provides default implementations of less commonly implemented methods.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.batch.api.partition.PartitionReducer

        PartitionReducer.PartitionStatus

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractPartitionReducer()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterPartitionedStepCompletion(PartitionReducer.PartitionStatus status)
      Override this method to take action after partitioned step processing ends.
      void beforePartitionedStepCompletion()
      Override this method to take action before normal partitioned step processing ends.
      void beginPartitionedStep()
      Override this method to take action before partitioned step processing begins.
      void rollbackPartitionedStep()
      Override this method to take action when a partitioned step is rolling back.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AbstractPartitionReducer

        public AbstractPartitionReducer()

    • Method Detail

      • beginPartitionedStep

        public void beginPartitionedStep()
                          throws Exception
        Override this method to take action before partitioned step processing begins.
        Specified by:
        beginPartitionedStep in interface PartitionReducer
        Throws:
        Exception - is thrown if an error occurs.

      • beforePartitionedStepCompletion

        public void beforePartitionedStepCompletion()
                                     throws Exception
        Override this method to take action before normal partitioned step processing ends.
        Specified by:
        beforePartitionedStepCompletion in interface PartitionReducer
        Throws:
        Exception - is thrown if an error occurs.

      • rollbackPartitionedStep

        public void rollbackPartitionedStep()
                             throws Exception
        Override this method to take action when a partitioned step is rolling back.
        Specified by:
        rollbackPartitionedStep in interface PartitionReducer
        Throws:
        Exception - is thrown if an error occurs.

      • afterPartitionedStepCompletion

        public void afterPartitionedStepCompletion(PartitionReducer.PartitionStatus status)
                                    throws Exception
        Override this method to take action after partitioned step processing ends.
        Specified by:
        afterPartitionedStepCompletion in interface PartitionReducer
        Parameters:
        status - specifies the outcome of the partitioned step. Values are "COMMIT" or "ROLLBACK".
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.batch.api.partition (Java(TM) EE 7 Specification APIs)

javax.batch.api.partition

Interfaces

  • PartitionAnalyzer
  • PartitionCollector
  • PartitionMapper
  • PartitionPlan
  • PartitionReducer

Classes

  • AbstractPartitionAnalyzer
  • AbstractPartitionReducer
  • PartitionPlanImpl

Enums

  • PartitionReducer.PartitionStatus


javax.batch.api.partition (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.batch.api.partition

Provides APIs for artifacts specific to a Batch partitioned step.

See: Description

  • Interface Summary
    Interface Description
    PartitionAnalyzer
    PartitionAnalyzer receives control to process data and final results from each partition.
    PartitionCollector
    PartitionCollector provides a way to pass data from individual partitions to a single point of control running on the step's parent thread.
    PartitionMapper
    PartitionMapper receives control at the start of a partitioned execution.
    PartitionPlan
    PartitionReducer
    PartitionReducer provides unit of work demarcation across partitions.
  • Class Summary
    Class Description
    AbstractPartitionAnalyzer
    The AbstractPartitionAnalyzer provides default implementations of less commonly implemented methods.
    AbstractPartitionReducer
    The AbstractBatchlet provides default implementations of less commonly implemented methods.
    PartitionPlanImpl
    The PartitionPlanImpl class provides a basic implementation of the PartitionPlan interface.
  • Enum Summary
    Enum Description
    PartitionReducer.PartitionStatus

Package javax.batch.api.partition Description

Provides APIs for artifacts specific to a Batch partitioned step.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.batch.api.partition Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.batch.api.partition

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.batch.api.partition.AbstractPartitionAnalyzer (implements javax.batch.api.partition.PartitionAnalyzer)
    • javax.batch.api.partition.AbstractPartitionReducer (implements javax.batch.api.partition.PartitionReducer)
    • javax.batch.api.partition.PartitionPlanImpl (implements javax.batch.api.partition.PartitionPlan)

Interface Hierarchy

  • javax.batch.api.partition.PartitionAnalyzer
  • javax.batch.api.partition.PartitionCollector
  • javax.batch.api.partition.PartitionMapper
  • javax.batch.api.partition.PartitionPlan
  • javax.batch.api.partition.PartitionReducer

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.batch.api.partition.PartitionReducer.PartitionStatus
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


PartitionAnalyzer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.partition

Interface PartitionAnalyzer

  • All Known Implementing Classes:
    AbstractPartitionAnalyzer

    public interface PartitionAnalyzer
    PartitionAnalyzer receives control to process data and final results from each partition. If a PartitionCollector is configured on the step, the PartitionAnalyzer receives control to process the data and results from the partition collector. While a separate PartitionCollector instance is invoked on each thread processing a step partition, a single PartitionAnalyzer instance runs on a single, consistent thread each time it is invoked.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void analyzeCollectorData(Serializable data)
      The analyzeCollectorData method receives control each time a Partition collector sends its payload.
      void analyzeStatus(BatchStatus batchStatus, String exitStatus)
      The analyzeStatus method receives control each time a partition ends.

    • Method Detail

      • analyzeCollectorData

        void analyzeCollectorData(Serializable data)
                          throws Exception
        The analyzeCollectorData method receives control each time a Partition collector sends its payload. It receives the Serializable object from the collector as an input.
        Parameters:
        data - specifies the payload sent by a PartitionCollector.
        Throws:
        Exception - is thrown if an error occurs.

      • analyzeStatus

        void analyzeStatus(BatchStatus batchStatus,
                 String exitStatus)
                   throws Exception
        The analyzeStatus method receives control each time a partition ends. It receives the batch and exit status strings of the partition as inputs.
        Parameters:
        batchStatus - specifies the batch status of a partition.
        exitStatus - specifies the exit status of a partition.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PartitionCollector (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.partition

Interface PartitionCollector

  • public interface PartitionCollector
    PartitionCollector provides a way to pass data from individual partitions to a single point of control running on the step's parent thread. The PartitionAnalyzer is used to receive and process this data.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Serializable collectPartitionData()
      The collectPartitionData method receives control periodically during partition processing.

    • Method Detail

      • collectPartitionData

        Serializable collectPartitionData()
                                  throws Exception
        The collectPartitionData method receives control periodically during partition processing. This method receives control on each thread processing a partition as follows:

        1. for a chunk type step, it receives control after every chunk checkpoint and then one last time at the end of the partition;
        2. for a batchlet type step, it receives control once at the end of the batchlet.

        Note the collector is not called if the partition terminates due to an unhandled exception.

        Returns:
        an Serializable object to pass to the PartitionAnalyzer.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PartitionMapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.partition

Interface PartitionMapper

  • public interface PartitionMapper
    PartitionMapper receives control at the start of a partitioned execution. A PartitionMapper is responsible to provide unique batch properties for each partition.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      PartitionPlan mapPartitions()
      The mapPartitions method that receives control at the start of partitioned step processing.

    • Method Detail

      • mapPartitions

        PartitionPlan mapPartitions()
                            throws Exception
        The mapPartitions method that receives control at the start of partitioned step processing. The method returns a PartitionPlan, which specifies the batch properties for each partition.
        Returns:
        partition plan for a partitioned step.
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PartitionPlan (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.partition

Interface PartitionPlan

  • All Known Implementing Classes:
    PartitionPlanImpl

    public interface PartitionPlan

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Properties[] getPartitionProperties()
      Gets array of Partition Properties objects for Partitions.
      int getPartitions()
      Gets count of Partitions.
      boolean getPartitionsOverride()
      Return current value of partition override setting.
      int getThreads()
      Gets count of threads.
      void setPartitionProperties(Properties[] props)
      Sets array of substitution Properties objects for the set of Partitions.
      void setPartitions(int count)
      Set number of partitions.
      void setPartitionsOverride(boolean override)
      Specify whether or not to override the partition count from the previous job execution.
      void setThreads(int count)
      Set number of threads.

    • Method Detail

      • setPartitions

        void setPartitions(int count)
        Set number of partitions.
        Parameters:
        count - specifies the partition count

      • setPartitionsOverride

        void setPartitionsOverride(boolean override)
        Specify whether or not to override the partition count from the previous job execution. This applies only to step restart. The default is false.

        When false is specified, the partition count from the previous job execution is used and any new value set for partition count in the current run is ignored. In addition, partition results from the previous job execution are remembered, and only incomplete partitions are reprocessed.

        When true is specified, the partition count from the current run is used and all results from past partitions are discarded. Any resource cleanup or back out of work done in the previous run is the responsibility of the application. The PartitionReducer artifact's rollbackPartitionedStep method is invoked during restart before any partitions begin processing to provide a cleanup hook.

      • getPartitionsOverride

        boolean getPartitionsOverride()
        Return current value of partition override setting.
        Returns:
        override setting.

      • setThreads

        void setThreads(int count)
        Set number of threads. Defaults to zero, which means thread count is equal to partition count.
        Parameters:
        count - specifies the thread count

      • setPartitionProperties

        void setPartitionProperties(Properties[] props)
        Sets array of substitution Properties objects for the set of Partitions.
        Parameters:
        props - specifies the Properties object array

      • getPartitions

        int getPartitions()
        Gets count of Partitions.
        Returns:
        Partition count

      • getThreads

        int getThreads()
        Gets count of threads.
        Returns:
        thread count

      • getPartitionProperties

        Properties[] getPartitionProperties()
        Gets array of Partition Properties objects for Partitions.
        Returns:
        Partition Properties object array
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PartitionPlanImpl (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.partition

Class PartitionPlanImpl

  • java.lang.Object
    • javax.batch.api.partition.PartitionPlanImpl
  • All Implemented Interfaces:
    PartitionPlan

    public class PartitionPlanImpl
extends Object
implements PartitionPlan
    The PartitionPlanImpl class provides a basic implementation of the PartitionPlan interface.

    • Constructor Summary

      Constructors
      Constructor and Description
      PartitionPlanImpl()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Properties[] getPartitionProperties()
      Gets array of Partition Properties objects for Partitions.
      int getPartitions()
      Gets count of Partitions.
      boolean getPartitionsOverride()
      Return current value of partition override setting.
      int getThreads()
      Gets count of threads.
      void setPartitionProperties(Properties[] props)
      Sets array of substitution Properties objects for the set of Partitions.
      void setPartitions(int count)
      Set number of partitions.
      void setPartitionsOverride(boolean override)
      Specify whether or not to override the partition count from the previous job execution.
      void setThreads(int count)
      Set number of threads.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PartitionPlanImpl

        public PartitionPlanImpl()

    • Method Detail

      • setPartitions

        public void setPartitions(int count)
        Description copied from interface: PartitionPlan
        Set number of partitions.
        Specified by:
        setPartitions in interface PartitionPlan
        Parameters:
        count - specifies the partition count

      • setThreads

        public void setThreads(int count)
        Description copied from interface: PartitionPlan
        Set number of threads. Defaults to zero, which means thread count is equal to partition count.
        Specified by:
        setThreads in interface PartitionPlan
        Parameters:
        count - specifies the thread count

      • setPartitionsOverride

        public void setPartitionsOverride(boolean override)
        Description copied from interface: PartitionPlan
        Specify whether or not to override the partition count from the previous job execution. This applies only to step restart. The default is false.

        When false is specified, the partition count from the previous job execution is used and any new value set for partition count in the current run is ignored. In addition, partition results from the previous job execution are remembered, and only incomplete partitions are reprocessed.

        When true is specified, the partition count from the current run is used and all results from past partitions are discarded. Any resource cleanup or back out of work done in the previous run is the responsibility of the application. The PartitionReducer artifact's rollbackPartitionedStep method is invoked during restart before any partitions begin processing to provide a cleanup hook.

        Specified by:
        setPartitionsOverride in interface PartitionPlan

      • getPartitionsOverride

        public boolean getPartitionsOverride()
        Description copied from interface: PartitionPlan
        Return current value of partition override setting.
        Specified by:
        getPartitionsOverride in interface PartitionPlan
        Returns:
        override setting.

      • setPartitionProperties

        public void setPartitionProperties(Properties[] props)
        Description copied from interface: PartitionPlan
        Sets array of substitution Properties objects for the set of Partitions.
        Specified by:
        setPartitionProperties in interface PartitionPlan
        Parameters:
        props - specifies the Properties object array

      • getPartitions

        public int getPartitions()
        Description copied from interface: PartitionPlan
        Gets count of Partitions.
        Specified by:
        getPartitions in interface PartitionPlan
        Returns:
        Partition count

      • getThreads

        public int getThreads()
        Description copied from interface: PartitionPlan
        Gets count of threads.
        Specified by:
        getThreads in interface PartitionPlan
        Returns:
        thread count

      • getPartitionProperties

        public Properties[] getPartitionProperties()
        Description copied from interface: PartitionPlan
        Gets array of Partition Properties objects for Partitions.
        Specified by:
        getPartitionProperties in interface PartitionPlan
        Returns:
        Partition Properties object array
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PartitionReducer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.api.partition

Interface PartitionReducer

  • All Known Implementing Classes:
    AbstractPartitionReducer

    public interface PartitionReducer
    PartitionReducer provides unit of work demarcation across partitions. It is not a JTA transaction; no resources are enlisted. Rather, it provides transactional flow semantics to facilitate finalizing merge or compensation logic.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Interface and Description
      static class  | PartitionReducer.PartitionStatus

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterPartitionedStepCompletion(PartitionReducer.PartitionStatus status)
      The afterPartitionedStepCompletion method receives control at the end of a partition processing.
      void beforePartitionedStepCompletion()
      The beforePartitionedStepCompletion method receives control at the end of partitioned step processing.
      void beginPartitionedStep()
      The beginPartitionedStep method receives control at the start of partition processing.
      void rollbackPartitionedStep()
      The rollbackPartitionedStep method receives control if the runtime is rolling back a partitioned step.

    • Method Detail

      • beginPartitionedStep

        void beginPartitionedStep()
                          throws Exception
        The beginPartitionedStep method receives control at the start of partition processing. It receives control before the PartitionMapper is invoked and before any partitions are started.
        Throws:
        Exception - is thrown if an error occurs.

      • beforePartitionedStepCompletion

        void beforePartitionedStepCompletion()
                                     throws Exception
        The beforePartitionedStepCompletion method receives control at the end of partitioned step processing. It receives control after all partitions have completed. It does not receive control if the PartitionReducer is rolling back.
        Throws:
        Exception - is thrown if an error occurs.

      • rollbackPartitionedStep

        void rollbackPartitionedStep()
                             throws Exception
        The rollbackPartitionedStep method receives control if the runtime is rolling back a partitioned step. Any partition threads still running are allowed to complete before this method is invoked. This method receives control if any of the following conditions are true:

        1. One or more partitions end with a Batch Status of STOPPED or FAILED.
        2. Any of the following partitioned step callbacks throw an exception:
          1. PartitionMapper
          2. PartitionReducer
          3. PartitionCollector
          4. PartitionAnalyzer
        3. A job with partitioned steps is restarted.
        Throws:
        Exception - is thrown if an error occurs.

      • afterPartitionedStepCompletion

        void afterPartitionedStepCompletion(PartitionReducer.PartitionStatus status)
                                    throws Exception
        The afterPartitionedStepCompletion method receives control at the end of a partition processing. It receives a status value that identifies the outcome of the partition processing. The status string value is either "COMMIT" or "ROLLBACK".
        Parameters:
        status - specifies the outcome of the partitioned step. Values are "COMMIT" or "ROLLBACK".
        Throws:
        Exception - is thrown if an error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PartitionReducer.PartitionStatus (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.batch.api.partition

Enum PartitionReducer.PartitionStatus

  • java.lang.Object
    • java.lang.Enum<PartitionReducer.PartitionStatus>
      • javax.batch.api.partition.PartitionReducer.PartitionStatus
  • All Implemented Interfaces:
    Serializable, Comparable<PartitionReducer.PartitionStatus>
    Enclosing interface:
    PartitionReducer

    public static enum PartitionReducer.PartitionStatus
extends Enum<PartitionReducer.PartitionStatus>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      COMMIT
      ROLLBACK

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static PartitionReducer.PartitionStatus valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static PartitionReducer.PartitionStatus[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • COMMIT

        public static final PartitionReducer.PartitionStatus COMMIT

      • ROLLBACK

        public static final PartitionReducer.PartitionStatus ROLLBACK

    • Method Detail

      • values

        public static PartitionReducer.PartitionStatus[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (PartitionReducer.PartitionStatus c : PartitionReducer.PartitionStatus.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static PartitionReducer.PartitionStatus valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Uses of Package javax.batch.api.partition (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.batch.api.partition

  • Packages that use javax.batch.api.partition
    Package Description
    javax.batch.api.partition
    Provides APIs for artifacts specific to a Batch partitioned step.
  • Classes in javax.batch.api.partition used by javax.batch.api.partition
    Class and Description
    PartitionAnalyzer
    PartitionAnalyzer receives control to process data and final results from each partition.
    PartitionPlan
    PartitionReducer
    PartitionReducer provides unit of work demarcation across partitions.
    PartitionReducer.PartitionStatus
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.partition.AbstractPartitionAnalyzer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.partition.AbstractPartitionAnalyzer

No usage of javax.batch.api.partition.AbstractPartitionAnalyzer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.partition.AbstractPartitionReducer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.partition.AbstractPartitionReducer

No usage of javax.batch.api.partition.AbstractPartitionReducer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.partition.PartitionPlanImpl (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.partition.PartitionPlanImpl

No usage of javax.batch.api.partition.PartitionPlanImpl
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.api.partition.PartitionReducer.PartitionStatus (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.api.partition.PartitionReducer.PartitionStatus

  • Packages that use PartitionReducer.PartitionStatus
    Package Description
    javax.batch.api.partition
    Provides APIs for artifacts specific to a Batch partitioned step.

    • Uses of PartitionReducer.PartitionStatus in javax.batch.api.partition

      Methods in javax.batch.api.partition that return PartitionReducer.PartitionStatus
      Modifier and Type Method and Description
      static PartitionReducer.PartitionStatus PartitionReducer.PartitionStatus.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static PartitionReducer.PartitionStatus[] PartitionReducer.PartitionStatus.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.batch.api.partition with parameters of type PartitionReducer.PartitionStatus
      Modifier and Type Method and Description
      void PartitionReducer.afterPartitionedStepCompletion(PartitionReducer.PartitionStatus status)
      The afterPartitionedStepCompletion method receives control at the end of a partition processing.
      void AbstractPartitionReducer.afterPartitionedStepCompletion(PartitionReducer.PartitionStatus status)
      Override this method to take action after partitioned step processing ends.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.partition.PartitionAnalyzer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.partition.PartitionAnalyzer

  • Packages that use PartitionAnalyzer
    Package Description
    javax.batch.api.partition
    Provides APIs for artifacts specific to a Batch partitioned step.

    • Uses of PartitionAnalyzer in javax.batch.api.partition

      Classes in javax.batch.api.partition that implement PartitionAnalyzer
      Modifier and Type Class and Description
      class  AbstractPartitionAnalyzer
      The AbstractPartitionAnalyzer provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.partition.PartitionCollector (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.partition.PartitionCollector

No usage of javax.batch.api.partition.PartitionCollector
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.partition.PartitionMapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.partition.PartitionMapper

No usage of javax.batch.api.partition.PartitionMapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.partition.PartitionPlan (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.partition.PartitionPlan

  • Packages that use PartitionPlan
    Package Description
    javax.batch.api.partition
    Provides APIs for artifacts specific to a Batch partitioned step.

    • Uses of PartitionPlan in javax.batch.api.partition

      Classes in javax.batch.api.partition that implement PartitionPlan
      Modifier and Type Class and Description
      class  PartitionPlanImpl
      The PartitionPlanImpl class provides a basic implementation of the PartitionPlan interface.
      Methods in javax.batch.api.partition that return PartitionPlan
      Modifier and Type Method and Description
      PartitionPlan PartitionMapper.mapPartitions()
      The mapPartitions method that receives control at the start of partitioned step processing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.api.partition.PartitionReducer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.api.partition.PartitionReducer

  • Packages that use PartitionReducer
    Package Description
    javax.batch.api.partition
    Provides APIs for artifacts specific to a Batch partitioned step.

    • Uses of PartitionReducer in javax.batch.api.partition

      Classes in javax.batch.api.partition that implement PartitionReducer
      Modifier and Type Class and Description
      class  AbstractPartitionReducer
      The AbstractBatchlet provides default implementations of less commonly implemented methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BatchRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class BatchRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    JobExecutionAlreadyCompleteException, JobExecutionIsRunningException, JobExecutionNotMostRecentException, JobExecutionNotRunningException, JobRestartException, JobSecurityException, JobStartException, NoSuchJobException, NoSuchJobExecutionException, NoSuchJobInstanceException

    public class BatchRuntimeException
extends RuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      BatchRuntimeException()
      BatchRuntimeException(String message)
      BatchRuntimeException(String message, Throwable cause)
      BatchRuntimeException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BatchRuntimeException

        public BatchRuntimeException()

      • BatchRuntimeException

        public BatchRuntimeException(String message)

      • BatchRuntimeException

        public BatchRuntimeException(Throwable cause)

      • BatchRuntimeException

        public BatchRuntimeException(String message,
                     Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.batch.operations (Java(TM) EE 7 Specification APIs)

javax.batch.operations

Interfaces

  • JobOperator

Exceptions

  • BatchRuntimeException
  • JobExecutionAlreadyCompleteException
  • JobExecutionIsRunningException
  • JobExecutionNotMostRecentException
  • JobExecutionNotRunningException
  • JobRestartException
  • JobSecurityException
  • JobStartException
  • NoSuchJobException
  • NoSuchJobExecutionException
  • NoSuchJobInstanceException


javax.batch.operations (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.batch.operations

Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

See: Description

  • Interface Summary
    Interface Description
    JobOperator
    JobOperator provide the interface for operating on batch jobs.
  • Exception Summary
    Exception Description
    BatchRuntimeException
    JobExecutionAlreadyCompleteException
    JobExecutionIsRunningException
    JobExecutionNotMostRecentException
    JobExecutionNotRunningException
    JobRestartException
    JobSecurityException
    JobStartException
    NoSuchJobException
    NoSuchJobExecutionException
    NoSuchJobInstanceException

Package javax.batch.operations Description

Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.batch.operations Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.batch.operations

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.JobExecutionAlreadyCompleteException
            • javax.batch.operations.JobExecutionIsRunningException
            • javax.batch.operations.JobExecutionNotMostRecentException
            • javax.batch.operations.JobExecutionNotRunningException
            • javax.batch.operations.JobRestartException
            • javax.batch.operations.JobSecurityException
            • javax.batch.operations.JobStartException
            • javax.batch.operations.NoSuchJobException
            • javax.batch.operations.NoSuchJobExecutionException
            • javax.batch.operations.NoSuchJobInstanceException

Interface Hierarchy

  • javax.batch.operations.JobOperator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JobExecutionAlreadyCompleteException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class JobExecutionAlreadyCompleteException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.JobExecutionAlreadyCompleteException
  • All Implemented Interfaces:
    Serializable

    public class JobExecutionAlreadyCompleteException
extends BatchRuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JobExecutionAlreadyCompleteException()
      JobExecutionAlreadyCompleteException(String message)
      JobExecutionAlreadyCompleteException(String message, Throwable cause)
      JobExecutionAlreadyCompleteException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JobExecutionAlreadyCompleteException

        public JobExecutionAlreadyCompleteException()

      • JobExecutionAlreadyCompleteException

        public JobExecutionAlreadyCompleteException(String message)

      • JobExecutionAlreadyCompleteException

        public JobExecutionAlreadyCompleteException(Throwable cause)

      • JobExecutionAlreadyCompleteException

        public JobExecutionAlreadyCompleteException(String message,
                                    Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JobExecutionIsRunningException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class JobExecutionIsRunningException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.JobExecutionIsRunningException
  • All Implemented Interfaces:
    Serializable

    public class JobExecutionIsRunningException
extends BatchRuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JobExecutionIsRunningException()
      JobExecutionIsRunningException(String message)
      JobExecutionIsRunningException(String message, Throwable cause)
      JobExecutionIsRunningException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JobExecutionIsRunningException

        public JobExecutionIsRunningException()

      • JobExecutionIsRunningException

        public JobExecutionIsRunningException(String message)

      • JobExecutionIsRunningException

        public JobExecutionIsRunningException(Throwable cause)

      • JobExecutionIsRunningException

        public JobExecutionIsRunningException(String message,
                              Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JobExecutionNotMostRecentException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class JobExecutionNotMostRecentException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.JobExecutionNotMostRecentException
  • All Implemented Interfaces:
    Serializable

    public class JobExecutionNotMostRecentException
extends BatchRuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JobExecutionNotMostRecentException()
      JobExecutionNotMostRecentException(String message)
      JobExecutionNotMostRecentException(String message, Throwable cause)
      JobExecutionNotMostRecentException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JobExecutionNotMostRecentException

        public JobExecutionNotMostRecentException()

      • JobExecutionNotMostRecentException

        public JobExecutionNotMostRecentException(String message)

      • JobExecutionNotMostRecentException

        public JobExecutionNotMostRecentException(Throwable cause)

      • JobExecutionNotMostRecentException

        public JobExecutionNotMostRecentException(String message,
                                  Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JobExecutionNotRunningException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class JobExecutionNotRunningException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.JobExecutionNotRunningException
  • All Implemented Interfaces:
    Serializable

    public class JobExecutionNotRunningException
extends BatchRuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JobExecutionNotRunningException()
      JobExecutionNotRunningException(String message)
      JobExecutionNotRunningException(String message, Throwable cause)
      JobExecutionNotRunningException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JobExecutionNotRunningException

        public JobExecutionNotRunningException()

      • JobExecutionNotRunningException

        public JobExecutionNotRunningException(String message)

      • JobExecutionNotRunningException

        public JobExecutionNotRunningException(Throwable cause)

      • JobExecutionNotRunningException

        public JobExecutionNotRunningException(String message,
                               Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JobOperator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Interface JobOperator

  • public interface JobOperator
    JobOperator provide the interface for operating on batch jobs. Through the JobOperator a program can start, stop, and restart jobs. It can additionally inspect job history, to discover what jobs are currently running and what jobs have previously run. The JobOperator interface imposes no security constraints. However, the implementer is free to limit JobOperator methods with a security scheme of its choice. The implementer should terminate any method that is limited by the security scheme with a JobSecurityException.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void abandon(long executionId)
      Set batch status to ABANDONED.
      JobExecution getJobExecution(long executionId)
      Return job execution for specified execution id
      List<JobExecution> getJobExecutions(JobInstance instance)
      Return all job executions belonging to the specified job instance.
      JobInstance getJobInstance(long executionId)
      Return the job instance for the specified execution id.
      int getJobInstanceCount(String jobName)
      Returns number of instances of a job with a particular name.
      List<JobInstance> getJobInstances(String jobName, int start, int count)
      Returns all JobInstances belonging to a job with a particular name in reverse chronological order.
      Set<String> getJobNames()
      Returns a set of all job names known to the batch runtime.
      Properties getParameters(long executionId)
      Returns job parameters for a specified job instance.
      List<Long> getRunningExecutions(String jobName)
      Returns execution ids for job instances with the specified name that have running executions.
      List<StepExecution> getStepExecutions(long jobExecutionId)
      Return StepExecutions for specified execution id.
      long restart(long executionId, Properties restartParameters)
      Restarts a failed or stopped job instance.
      long start(String jobXMLName, Properties jobParameters)
      Creates a new job instance and starts the first execution of that instance.
      void stop(long executionId)
      Request a running job execution stops.

    • Method Detail

      • getJobNames

        Set<String> getJobNames()
                        throws JobSecurityException
        Returns a set of all job names known to the batch runtime.
        Returns:
        a set of job names.
        Throws:
        JobSecurityException

      • getJobInstanceCount

        int getJobInstanceCount(String jobName)
                        throws NoSuchJobException,
                               JobSecurityException
        Returns number of instances of a job with a particular name.
        Parameters:
        jobName - specifies the name of the job.
        Returns:
        count of instances of the named job.
        Throws:
        NoSuchJobException
        JobSecurityException

      • getJobInstances

        List<JobInstance> getJobInstances(String jobName,
                                int start,
                                int count)
                                  throws NoSuchJobException,
                                         JobSecurityException
        Returns all JobInstances belonging to a job with a particular name in reverse chronological order.
        Parameters:
        jobName - specifies the job name.
        start - specifies the relative starting number (zero based) to return from the maximal list of job instances.
        count - specifies the number of job instances to return from the starting position of the maximal list of job instances.
        Returns:
        list of JobInstances.
        Throws:
        NoSuchJobException
        JobSecurityException

      • getRunningExecutions

        List<Long> getRunningExecutions(String jobName)
                                throws NoSuchJobException,
                                       JobSecurityException
        Returns execution ids for job instances with the specified name that have running executions.
        Parameters:
        jobName - specifies the job name.
        Returns:
        a list of execution ids.
        Throws:
        NoSuchJobException
        JobSecurityException

      • getParameters

        Properties getParameters(long executionId)
                         throws NoSuchJobExecutionException,
                                JobSecurityException
        Returns job parameters for a specified job instance. These are the key/value pairs specified when the instance was originally created by the start method.
        Parameters:
        executionId - specifies the execution from which to retrieve the parameters.
        Returns:
        a Properties object containing the key/value job parameter pairs.
        Throws:
        NoSuchJobExecutionException
        JobSecurityException

      • start

        long start(String jobXMLName,
         Properties jobParameters)
           throws JobStartException,
                  JobSecurityException
        Creates a new job instance and starts the first execution of that instance. Note the Job XML describing the job is first searched for by name according to a means prescribed by the batch runtime implementation. This may vary by implementation. If the Job XML is not found by that means, then the batch runtime must search for the specified Job XML as a resource from the META-INF/batch-jobs directory based on the current class loader. Job XML files under META-INF/batch-jobs directory follow a naming convention of "name".xml where "name" is the value of the jobXMLName parameter (see below).
        Parameters:
        jobXMLName - specifies the name of the Job XML describing the job.
        jobParameters - specifies the keyword/value pairs for attribute substitution in the Job XML.
        Returns:
        executionId for the job execution.
        Throws:
        JobStartException
        JobSecurityException

      • restart

        long restart(long executionId,
           Properties restartParameters)
             throws JobExecutionAlreadyCompleteException,
                    NoSuchJobExecutionException,
                    JobExecutionNotMostRecentException,
                    JobRestartException,
                    JobSecurityException
        Restarts a failed or stopped job instance.
        Parameters:
        executionId - specifies the execution to to restart. This execution must be the most recent execution that ran.
        restartParameters - specifies the keyword/value pairs for attribute substitution in the Job XML.
        Returns:
        new executionId
        Throws:
        JobExecutionAlreadyCompleteException
        NoSuchJobExecutionException
        JobExecutionNotMostRecentException,
        JobRestartException
        JobSecurityException
        JobExecutionNotMostRecentException

      • stop

        void stop(long executionId)
          throws NoSuchJobExecutionException,
                 JobExecutionNotRunningException,
                 JobSecurityException
        Request a running job execution stops. This method notifies the job execution to stop and then returns. The job execution normally stops and does so asynchronously. Note JobOperator cannot guarantee the jobs stops: it is possible a badly behaved batch application does not relinquish control.

        Note for partitioned batchlet steps the Batchlet stop method is invoked on each thread actively processing a partition.

        Parameters:
        executionId - specifies the job execution to stop. The job execution must be running.
        Throws:
        NoSuchJobExecutionException
        JobExecutionNotRunningException
        JobSecurityException

      • abandon

        void abandon(long executionId)
             throws NoSuchJobExecutionException,
                    JobExecutionIsRunningException,
                    JobSecurityException
        Set batch status to ABANDONED. The instance must have no running execution.

        Note that ABANDONED executions cannot be restarted.

        Parameters:
        executionId - specifies the job execution to abandon.
        Throws:
        NoSuchJobExecutionException
        JobExecutionIsRunningException
        JobSecurityException

      • getJobInstance

        JobInstance getJobInstance(long executionId)
                           throws NoSuchJobExecutionException,
                                  JobSecurityException
        Return the job instance for the specified execution id.
        Parameters:
        executionId - specifies the job execution.
        Returns:
        job instance
        Throws:
        NoSuchJobExecutionException
        JobSecurityException

      • getJobExecutions

        List<JobExecution> getJobExecutions(JobInstance instance)
                                    throws NoSuchJobInstanceException,
                                           JobSecurityException
        Return all job executions belonging to the specified job instance.
        Parameters:
        jobInstance - specifies the job instance.
        Returns:
        list of job executions
        Throws:
        NoSuchJobInstanceException
        JobSecurityException

      • getJobExecution

        JobExecution getJobExecution(long executionId)
                             throws NoSuchJobExecutionException,
                                    JobSecurityException
        Return job execution for specified execution id
        Parameters:
        executionId - specifies the job execution.
        Returns:
        job execution
        Throws:
        NoSuchJobExecutionException
        JobSecurityException

      • getStepExecutions

        List<StepExecution> getStepExecutions(long jobExecutionId)
                                      throws NoSuchJobExecutionException,
                                             JobSecurityException
        Return StepExecutions for specified execution id.
        Parameters:
        executionId - specifies the job execution.
        Returns:
        step executions (order not guaranteed)
        Throws:
        NoSuchJobExecutionException
        JobSecurityException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JobRestartException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class JobRestartException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.JobRestartException
  • All Implemented Interfaces:
    Serializable

    public class JobRestartException
extends BatchRuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JobRestartException()
      JobRestartException is thrown when an error occurs during the JobOperator restart operation.
      JobRestartException(String message)
      JobRestartException(String message, Throwable cause)
      JobRestartException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JobRestartException

        public JobRestartException()
        JobRestartException is thrown when an error occurs during the JobOperator restart operation.

      • JobRestartException

        public JobRestartException(String message)

      • JobRestartException

        public JobRestartException(Throwable cause)

      • JobRestartException

        public JobRestartException(String message,
                   Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JobSecurityException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class JobSecurityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.JobSecurityException
  • All Implemented Interfaces:
    Serializable

    public class JobSecurityException
extends BatchRuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JobSecurityException()
      SecurityException is thrown when an user is not authorized to run a JobOperator method, such as restart, stop, abandon, any getters, etc
      JobSecurityException(String message)
      JobSecurityException(String message, Throwable cause)
      JobSecurityException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JobSecurityException

        public JobSecurityException()
        SecurityException is thrown when an user is not authorized to run a JobOperator method, such as restart, stop, abandon, any getters, etc

      • JobSecurityException

        public JobSecurityException(String message)

      • JobSecurityException

        public JobSecurityException(Throwable cause)

      • JobSecurityException

        public JobSecurityException(String message,
                    Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JobStartException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class JobStartException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.JobStartException
  • All Implemented Interfaces:
    Serializable

    public class JobStartException
extends BatchRuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JobStartException()
      JobStartException is thrown when an error occurs during the JobOperator start operation.
      JobStartException(String message)
      JobStartException(String message, Throwable cause)
      JobStartException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JobStartException

        public JobStartException()
        JobStartException is thrown when an error occurs during the JobOperator start operation.

      • JobStartException

        public JobStartException(String message)

      • JobStartException

        public JobStartException(Throwable cause)

      • JobStartException

        public JobStartException(String message,
                 Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoSuchJobException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class NoSuchJobException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.NoSuchJobException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchJobException
extends BatchRuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoSuchJobException()
      NoSuchJobException(String message)
      NoSuchJobException(String message, Throwable cause)
      NoSuchJobException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoSuchJobException

        public NoSuchJobException()

      • NoSuchJobException

        public NoSuchJobException(String message)

      • NoSuchJobException

        public NoSuchJobException(Throwable cause)

      • NoSuchJobException

        public NoSuchJobException(String message,
                  Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoSuchJobExecutionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class NoSuchJobExecutionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.NoSuchJobExecutionException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchJobExecutionException
extends BatchRuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoSuchJobExecutionException()
      NoSuchJobExecutionException(String message)
      NoSuchJobExecutionException(String message, Throwable cause)
      NoSuchJobExecutionException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoSuchJobExecutionException

        public NoSuchJobExecutionException()

      • NoSuchJobExecutionException

        public NoSuchJobExecutionException(String message)

      • NoSuchJobExecutionException

        public NoSuchJobExecutionException(Throwable cause)

      • NoSuchJobExecutionException

        public NoSuchJobExecutionException(String message,
                           Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoSuchJobInstanceException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.operations

Class NoSuchJobInstanceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.NoSuchJobInstanceException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchJobInstanceException
extends BatchRuntimeException
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoSuchJobInstanceException()
      NoSuchJobInstanceException(String message)
      NoSuchJobInstanceException(String message, Throwable cause)
      NoSuchJobInstanceException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoSuchJobInstanceException

        public NoSuchJobInstanceException()

      • NoSuchJobInstanceException

        public NoSuchJobInstanceException(String message)

      • NoSuchJobInstanceException

        public NoSuchJobInstanceException(Throwable cause)

      • NoSuchJobInstanceException

        public NoSuchJobInstanceException(String message,
                          Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.batch.operations (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.batch.operations

  • Packages that use javax.batch.operations
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.
    javax.batch.runtime
    Provides APIs for viewing the detailed outcomes and metrics of Batch job executions.
  • Classes in javax.batch.operations used by javax.batch.operations
    Class and Description
    BatchRuntimeException
    JobExecutionAlreadyCompleteException
    JobExecutionIsRunningException
    JobExecutionNotMostRecentException
    JobExecutionNotRunningException
    JobRestartException
    JobSecurityException
    JobStartException
    NoSuchJobException
    NoSuchJobExecutionException
    NoSuchJobInstanceException
  • Classes in javax.batch.operations used by javax.batch.runtime
    Class and Description
    JobOperator
    JobOperator provide the interface for operating on batch jobs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.BatchRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.BatchRuntimeException

  • Packages that use BatchRuntimeException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of BatchRuntimeException in javax.batch.operations

      Subclasses of BatchRuntimeException in javax.batch.operations
      Modifier and Type | Class and Description
      class  | JobExecutionAlreadyCompleteException
      class  | JobExecutionIsRunningException
      class  | JobExecutionNotMostRecentException
      class  | JobExecutionNotRunningException
      class  | JobRestartException
      class  | JobSecurityException
      class  | JobStartException
      class  | NoSuchJobException
      class  | NoSuchJobExecutionException
      class  | NoSuchJobInstanceException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.JobExecutionAlreadyCompleteException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.JobExecutionAlreadyCompleteException

  • Packages that use JobExecutionAlreadyCompleteException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of JobExecutionAlreadyCompleteException in javax.batch.operations

      Methods in javax.batch.operations that throw JobExecutionAlreadyCompleteException
      Modifier and Type Method and Description
      long JobOperator.restart(long executionId, Properties restartParameters)
      Restarts a failed or stopped job instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.JobExecutionIsRunningException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.JobExecutionIsRunningException

  • Packages that use JobExecutionIsRunningException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of JobExecutionIsRunningException in javax.batch.operations

      Methods in javax.batch.operations that throw JobExecutionIsRunningException
      Modifier and Type Method and Description
      void JobOperator.abandon(long executionId)
      Set batch status to ABANDONED.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.JobExecutionNotMostRecentException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.JobExecutionNotMostRecentException

  • Packages that use JobExecutionNotMostRecentException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of JobExecutionNotMostRecentException in javax.batch.operations

      Methods in javax.batch.operations that throw JobExecutionNotMostRecentException
      Modifier and Type Method and Description
      long JobOperator.restart(long executionId, Properties restartParameters)
      Restarts a failed or stopped job instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.JobExecutionNotRunningException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.JobExecutionNotRunningException

  • Packages that use JobExecutionNotRunningException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of JobExecutionNotRunningException in javax.batch.operations

      Methods in javax.batch.operations that throw JobExecutionNotRunningException
      Modifier and Type Method and Description
      void JobOperator.stop(long executionId)
      Request a running job execution stops.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.JobRestartException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.JobRestartException

  • Packages that use JobRestartException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of JobRestartException in javax.batch.operations

      Methods in javax.batch.operations that throw JobRestartException
      Modifier and Type Method and Description
      long JobOperator.restart(long executionId, Properties restartParameters)
      Restarts a failed or stopped job instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.JobSecurityException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.JobSecurityException

  • Packages that use JobSecurityException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of JobSecurityException in javax.batch.operations

      Methods in javax.batch.operations that throw JobSecurityException
      Modifier and Type Method and Description
      void JobOperator.abandon(long executionId)
      Set batch status to ABANDONED.
      JobExecution JobOperator.getJobExecution(long executionId)
      Return job execution for specified execution id
      List<JobExecution> JobOperator.getJobExecutions(JobInstance instance)
      Return all job executions belonging to the specified job instance.
      JobInstance JobOperator.getJobInstance(long executionId)
      Return the job instance for the specified execution id.
      int JobOperator.getJobInstanceCount(String jobName)
      Returns number of instances of a job with a particular name.
      List<JobInstance> JobOperator.getJobInstances(String jobName, int start, int count)
      Returns all JobInstances belonging to a job with a particular name in reverse chronological order.
      Set<String> JobOperator.getJobNames()
      Returns a set of all job names known to the batch runtime.
      Properties JobOperator.getParameters(long executionId)
      Returns job parameters for a specified job instance.
      List<Long> JobOperator.getRunningExecutions(String jobName)
      Returns execution ids for job instances with the specified name that have running executions.
      List<StepExecution> JobOperator.getStepExecutions(long jobExecutionId)
      Return StepExecutions for specified execution id.
      long JobOperator.restart(long executionId, Properties restartParameters)
      Restarts a failed or stopped job instance.
      long JobOperator.start(String jobXMLName, Properties jobParameters)
      Creates a new job instance and starts the first execution of that instance.
      void JobOperator.stop(long executionId)
      Request a running job execution stops.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.JobStartException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.JobStartException

  • Packages that use JobStartException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of JobStartException in javax.batch.operations

      Methods in javax.batch.operations that throw JobStartException
      Modifier and Type Method and Description
      long JobOperator.start(String jobXMLName, Properties jobParameters)
      Creates a new job instance and starts the first execution of that instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.NoSuchJobException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.NoSuchJobException

  • Packages that use NoSuchJobException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of NoSuchJobException in javax.batch.operations

      Methods in javax.batch.operations that throw NoSuchJobException
      Modifier and Type Method and Description
      int JobOperator.getJobInstanceCount(String jobName)
      Returns number of instances of a job with a particular name.
      List<JobInstance> JobOperator.getJobInstances(String jobName, int start, int count)
      Returns all JobInstances belonging to a job with a particular name in reverse chronological order.
      List<Long> JobOperator.getRunningExecutions(String jobName)
      Returns execution ids for job instances with the specified name that have running executions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.NoSuchJobExecutionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.NoSuchJobExecutionException

  • Packages that use NoSuchJobExecutionException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of NoSuchJobExecutionException in javax.batch.operations

      Methods in javax.batch.operations that throw NoSuchJobExecutionException
      Modifier and Type Method and Description
      void JobOperator.abandon(long executionId)
      Set batch status to ABANDONED.
      JobExecution JobOperator.getJobExecution(long executionId)
      Return job execution for specified execution id
      JobInstance JobOperator.getJobInstance(long executionId)
      Return the job instance for the specified execution id.
      Properties JobOperator.getParameters(long executionId)
      Returns job parameters for a specified job instance.
      List<StepExecution> JobOperator.getStepExecutions(long jobExecutionId)
      Return StepExecutions for specified execution id.
      long JobOperator.restart(long executionId, Properties restartParameters)
      Restarts a failed or stopped job instance.
      void JobOperator.stop(long executionId)
      Request a running job execution stops.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.operations.NoSuchJobInstanceException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.operations.NoSuchJobInstanceException

  • Packages that use NoSuchJobInstanceException
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of NoSuchJobInstanceException in javax.batch.operations

      Methods in javax.batch.operations that throw NoSuchJobInstanceException
      Modifier and Type Method and Description
      List<JobExecution> JobOperator.getJobExecutions(JobInstance instance)
      Return all job executions belonging to the specified job instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.operations.JobOperator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.operations.JobOperator

  • Packages that use JobOperator
    Package Description
    javax.batch.runtime
    Provides APIs for viewing the detailed outcomes and metrics of Batch job executions.

    • Uses of JobOperator in javax.batch.runtime

      Methods in javax.batch.runtime that return JobOperator
      Modifier and Type Method and Description
      static JobOperator BatchRuntime.getJobOperator()
      The getJobOperator factory method returns an instance of the JobOperator interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BatchRuntime (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.runtime

Class BatchRuntime

  • java.lang.Object
    • javax.batch.runtime.BatchRuntime

  • public class BatchRuntime
extends Object
    BatchRuntime represents the JSR 352 Batch Runtime. It provides factory access to the JobOperator interface.

    • Constructor Summary

      Constructors
      Constructor and Description
      BatchRuntime()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static JobOperator getJobOperator()
      The getJobOperator factory method returns an instance of the JobOperator interface.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BatchRuntime

        public BatchRuntime()

    • Method Detail

      • getJobOperator

        public static JobOperator getJobOperator()
        The getJobOperator factory method returns an instance of the JobOperator interface.
        Returns:
        JobOperator instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BatchStatus (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.batch.runtime

Enum BatchStatus

  • java.lang.Object
    • java.lang.Enum<BatchStatus>
      • javax.batch.runtime.BatchStatus
  • All Implemented Interfaces:
    Serializable, Comparable<BatchStatus>

    public enum BatchStatus
extends Enum<BatchStatus>
    BatchStatus enum defines the batch status values possible for a job.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ABANDONED
      COMPLETED
      FAILED
      STARTED
      STARTING
      STOPPED
      STOPPING

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static BatchStatus valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static BatchStatus[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • STARTING

        public static final BatchStatus STARTING

      • STARTED

        public static final BatchStatus STARTED

      • STOPPING

        public static final BatchStatus STOPPING

      • STOPPED

        public static final BatchStatus STOPPED

      • FAILED

        public static final BatchStatus FAILED

      • COMPLETED

        public static final BatchStatus COMPLETED

      • ABANDONED

        public static final BatchStatus ABANDONED

    • Method Detail

      • values

        public static BatchStatus[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (BatchStatus c : BatchStatus.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static BatchStatus valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


javax.batch.runtime (Java(TM) EE 7 Specification APIs)

javax.batch.runtime

Interfaces

  • JobExecution
  • JobInstance
  • Metric
  • StepExecution

Classes

  • BatchRuntime

Enums

  • BatchStatus
  • Metric.MetricType


javax.batch.runtime (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.batch.runtime

Provides APIs for viewing the detailed outcomes and metrics of Batch job executions.

See: Description

  • Interface Summary
    Interface Description
    JobExecution
    JobInstance
    Metric
    The Metric interface defines job metrics recorded by the batch runtime.
    StepExecution
  • Class Summary
    Class Description
    BatchRuntime
    BatchRuntime represents the JSR 352 Batch Runtime.
  • Enum Summary
    Enum Description
    BatchStatus
    BatchStatus enum defines the batch status values possible for a job.
    Metric.MetricType

Package javax.batch.runtime Description

Provides APIs for viewing the detailed outcomes and metrics of Batch job executions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.batch.runtime Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.batch.runtime

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.batch.runtime.BatchRuntime

Interface Hierarchy

  • javax.batch.runtime.JobExecution
  • javax.batch.runtime.JobInstance
  • javax.batch.runtime.Metric
  • javax.batch.runtime.StepExecution

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.batch.runtime.Metric.MetricType
      • javax.batch.runtime.BatchStatus
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JobExecution (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.runtime

Interface JobExecution

  • public interface JobExecution

    • Method Summary

      Methods
      Modifier and Type Method and Description
      BatchStatus getBatchStatus()
      Get batch status of this execution.
      Date getCreateTime()
      Get time execution was created.
      Date getEndTime()
      Get time execution entered end status: COMPLETED, STOPPED, FAILED
      long getExecutionId()
      Get unique id for this JobExecution.
      String getExitStatus()
      Get execution exit status.
      String getJobName()
      Get job name.
      Properties getJobParameters()
      Get job parameters for this execution.
      Date getLastUpdatedTime()
      Get time execution was last updated updated.
      Date getStartTime()
      Get time execution entered STARTED status.

    • Method Detail

      • getExecutionId

        long getExecutionId()
        Get unique id for this JobExecution.
        Returns:
        execution id

      • getJobName

        String getJobName()
        Get job name.
        Returns:
        value of 'id' attribute from

      • getBatchStatus

        BatchStatus getBatchStatus()
        Get batch status of this execution.
        Returns:
        batch status value.

      • getStartTime

        Date getStartTime()
        Get time execution entered STARTED status.
        Returns:
        date (time)

      • getEndTime

        Date getEndTime()
        Get time execution entered end status: COMPLETED, STOPPED, FAILED
        Returns:
        date (time)

      • getExitStatus

        String getExitStatus()
        Get execution exit status.
        Returns:
        exit status.

      • getCreateTime

        Date getCreateTime()
        Get time execution was created.
        Returns:
        date (time)

      • getLastUpdatedTime

        Date getLastUpdatedTime()
        Get time execution was last updated updated.
        Returns:
        date (time)

      • getJobParameters

        Properties getJobParameters()
        Get job parameters for this execution.
        Returns:
        job parameters
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JobInstance (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.runtime

Interface JobInstance

  • public interface JobInstance

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getInstanceId()
      Get unique id for this JobInstance.
      String getJobName()
      Get job name.

    • Method Detail

      • getInstanceId

        long getInstanceId()
        Get unique id for this JobInstance.
        Returns:
        instance id

      • getJobName

        String getJobName()
        Get job name.
        Returns:
        value of 'id' attribute from
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Metric (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.runtime

Interface Metric

  • public interface Metric
    The Metric interface defines job metrics recorded by the batch runtime.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Interface and Description
      static class  | Metric.MetricType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Metric.MetricType getType()
      The getName method returns the metric type.
      long getValue()
      The getValue method returns the metric value.

    • Method Detail

      • getType

        Metric.MetricType getType()
        The getName method returns the metric type.
        Returns:
        metric type.

      • getValue

        long getValue()
        The getValue method returns the metric value.
        Returns:
        metric value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Metric.MetricType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.batch.runtime

Enum Metric.MetricType

  • java.lang.Object
    • java.lang.Enum<Metric.MetricType>
      • javax.batch.runtime.Metric.MetricType
  • All Implemented Interfaces:
    Serializable, Comparable<Metric.MetricType>
    Enclosing interface:
    Metric

    public static enum Metric.MetricType
extends Enum<Metric.MetricType>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      COMMIT_COUNT
      FILTER_COUNT
      PROCESS_SKIP_COUNT
      READ_COUNT
      READ_SKIP_COUNT
      ROLLBACK_COUNT
      WRITE_COUNT
      WRITE_SKIP_COUNT

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Metric.MetricType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Metric.MetricType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • READ_COUNT

        public static final Metric.MetricType READ_COUNT

      • WRITE_COUNT

        public static final Metric.MetricType WRITE_COUNT

      • COMMIT_COUNT

        public static final Metric.MetricType COMMIT_COUNT

      • ROLLBACK_COUNT

        public static final Metric.MetricType ROLLBACK_COUNT

      • READ_SKIP_COUNT

        public static final Metric.MetricType READ_SKIP_COUNT

      • PROCESS_SKIP_COUNT

        public static final Metric.MetricType PROCESS_SKIP_COUNT

      • FILTER_COUNT

        public static final Metric.MetricType FILTER_COUNT

      • WRITE_SKIP_COUNT

        public static final Metric.MetricType WRITE_SKIP_COUNT

    • Method Detail

      • values

        public static Metric.MetricType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Metric.MetricType c : Metric.MetricType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Metric.MetricType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


StepExecution (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.runtime

Interface StepExecution

  • public interface StepExecution

    • Method Summary

      Methods
      Modifier and Type Method and Description
      BatchStatus getBatchStatus()
      Get batch status of this step execution.
      Date getEndTime()
      Get time this step ended.
      String getExitStatus()
      Get exit status of step.
      Metric[] getMetrics()
      Get step metrics
      Serializable getPersistentUserData()
      Get user persistent data
      Date getStartTime()
      Get time this step started.
      long getStepExecutionId()
      Get unique id for this StepExecution.
      String getStepName()
      Get step name.

    • Method Detail

      • getStepExecutionId

        long getStepExecutionId()
        Get unique id for this StepExecution.
        Returns:
        StepExecution id

      • getStepName

        String getStepName()
        Get step name.
        Returns:
        value of 'id' attribute from

      • getBatchStatus

        BatchStatus getBatchStatus()
        Get batch status of this step execution.
        Returns:
        batch status.

      • getStartTime

        Date getStartTime()
        Get time this step started.
        Returns:
        date (time)

      • getEndTime

        Date getEndTime()
        Get time this step ended.
        Returns:
        date (time)

      • getExitStatus

        String getExitStatus()
        Get exit status of step.
        Returns:
        exit status

      • getPersistentUserData

        Serializable getPersistentUserData()
        Get user persistent data
        Returns:
        persistent data

      • getMetrics

        Metric[] getMetrics()
        Get step metrics
        Returns:
        array of metrics
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.batch.runtime (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.batch.runtime

  • Packages that use javax.batch.runtime
    Package Description
    javax.batch.api
    Provides APIs used by Batch artifacts.
    javax.batch.api.partition
    Provides APIs for artifacts specific to a Batch partitioned step.
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.
    javax.batch.runtime
    Provides APIs for viewing the detailed outcomes and metrics of Batch job executions.
    javax.batch.runtime.context
    Provides APIs for context classes allowing data sharing across Batch artifacts within a job instance and within a step.
  • Classes in javax.batch.runtime used by javax.batch.api
    Class and Description
    StepExecution
  • Classes in javax.batch.runtime used by javax.batch.api.partition
    Class and Description
    BatchStatus
    BatchStatus enum defines the batch status values possible for a job.
  • Classes in javax.batch.runtime used by javax.batch.operations
    Class and Description
    JobExecution
    JobInstance
    StepExecution
  • Classes in javax.batch.runtime used by javax.batch.runtime
    Class and Description
    BatchStatus
    BatchStatus enum defines the batch status values possible for a job.
    Metric
    The Metric interface defines job metrics recorded by the batch runtime.
    Metric.MetricType
  • Classes in javax.batch.runtime used by javax.batch.runtime.context
    Class and Description
    BatchStatus
    BatchStatus enum defines the batch status values possible for a job.
    Metric
    The Metric interface defines job metrics recorded by the batch runtime.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.runtime.BatchRuntime (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.runtime.BatchRuntime

No usage of javax.batch.runtime.BatchRuntime
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.runtime.BatchStatus (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.runtime.BatchStatus

  • Packages that use BatchStatus
    Package Description
    javax.batch.api.partition
    Provides APIs for artifacts specific to a Batch partitioned step.
    javax.batch.runtime
    Provides APIs for viewing the detailed outcomes and metrics of Batch job executions.
    javax.batch.runtime.context
    Provides APIs for context classes allowing data sharing across Batch artifacts within a job instance and within a step.

    • Uses of BatchStatus in javax.batch.api.partition

      Methods in javax.batch.api.partition with parameters of type BatchStatus
      Modifier and Type Method and Description
      void PartitionAnalyzer.analyzeStatus(BatchStatus batchStatus, String exitStatus)
      The analyzeStatus method receives control each time a partition ends.
      void AbstractPartitionAnalyzer.analyzeStatus(BatchStatus batchStatus, String exitStatus)
      Override this method to analyze partition end status.

    • Uses of BatchStatus in javax.batch.runtime

      Methods in javax.batch.runtime that return BatchStatus
      Modifier and Type Method and Description
      BatchStatus StepExecution.getBatchStatus()
      Get batch status of this step execution.
      BatchStatus JobExecution.getBatchStatus()
      Get batch status of this execution.
      static BatchStatus BatchStatus.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static BatchStatus[] BatchStatus.values()
      Returns an array containing the constants of this enum type, in the order they are declared.

    • Uses of BatchStatus in javax.batch.runtime.context

      Methods in javax.batch.runtime.context that return BatchStatus
      Modifier and Type Method and Description
      BatchStatus StepContext.getBatchStatus()
      The getBatchStatus method returns the current batch status of the current step.
      BatchStatus JobContext.getBatchStatus()
      The getBatchStatus method simply returns the batch status value set by the batch runtime into the job context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.batch.runtime.Metric.MetricType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.batch.runtime.Metric.MetricType

  • Packages that use Metric.MetricType
    Package Description
    javax.batch.runtime
    Provides APIs for viewing the detailed outcomes and metrics of Batch job executions.

    • Uses of Metric.MetricType in javax.batch.runtime

      Methods in javax.batch.runtime that return Metric.MetricType
      Modifier and Type Method and Description
      Metric.MetricType Metric.getType()
      The getName method returns the metric type.
      static Metric.MetricType Metric.MetricType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Metric.MetricType[] Metric.MetricType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.runtime.JobExecution (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.runtime.JobExecution

  • Packages that use JobExecution
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of JobExecution in javax.batch.operations

      Methods in javax.batch.operations that return JobExecution
      Modifier and Type Method and Description
      JobExecution JobOperator.getJobExecution(long executionId)
      Return job execution for specified execution id
      Methods in javax.batch.operations that return types with arguments of type JobExecution
      Modifier and Type Method and Description
      List<JobExecution> JobOperator.getJobExecutions(JobInstance instance)
      Return all job executions belonging to the specified job instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.runtime.JobInstance (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.runtime.JobInstance

  • Packages that use JobInstance
    Package Description
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of JobInstance in javax.batch.operations

      Methods in javax.batch.operations that return JobInstance
      Modifier and Type Method and Description
      JobInstance JobOperator.getJobInstance(long executionId)
      Return the job instance for the specified execution id.
      Methods in javax.batch.operations that return types with arguments of type JobInstance
      Modifier and Type Method and Description
      List<JobInstance> JobOperator.getJobInstances(String jobName, int start, int count)
      Returns all JobInstances belonging to a job with a particular name in reverse chronological order.
      Methods in javax.batch.operations with parameters of type JobInstance
      Modifier and Type Method and Description
      List<JobExecution> JobOperator.getJobExecutions(JobInstance instance)
      Return all job executions belonging to the specified job instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.runtime.Metric (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.runtime.Metric

  • Packages that use Metric
    Package Description
    javax.batch.runtime
    Provides APIs for viewing the detailed outcomes and metrics of Batch job executions.
    javax.batch.runtime.context
    Provides APIs for context classes allowing data sharing across Batch artifacts within a job instance and within a step.

    • Uses of Metric in javax.batch.runtime

      Methods in javax.batch.runtime that return Metric
      Modifier and Type Method and Description
      Metric[] StepExecution.getMetrics()
      Get step metrics

    • Uses of Metric in javax.batch.runtime.context

      Methods in javax.batch.runtime.context that return Metric
      Modifier and Type Method and Description
      Metric[] StepContext.getMetrics()
      The getMetrics method returns an array of step level metrics.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.runtime.StepExecution (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.runtime.StepExecution

  • Packages that use StepExecution
    Package Description
    javax.batch.api
    Provides APIs used by Batch artifacts.
    javax.batch.operations
    Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

    • Uses of StepExecution in javax.batch.api

      Methods in javax.batch.api with parameters of type StepExecution
      Modifier and Type Method and Description
      String Decider.decide(StepExecution[] executions)
      The decide method sets a new exit status for a job.

    • Uses of StepExecution in javax.batch.operations

      Methods in javax.batch.operations that return types with arguments of type StepExecution
      Modifier and Type Method and Description
      List<StepExecution> JobOperator.getStepExecutions(long jobExecutionId)
      Return StepExecutions for specified execution id.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.batch.runtime.context (Java(TM) EE 7 Specification APIs)

javax.batch.runtime.context

Interfaces

  • JobContext
  • StepContext


javax.batch.runtime.context (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.batch.runtime.context

Provides APIs for context classes allowing data sharing across Batch artifacts within a job instance and within a step.

See: Description

  • Interface Summary
    Interface Description
    JobContext
    StepContext

Package javax.batch.runtime.context Description

Provides APIs for context classes allowing data sharing across Batch artifacts within a job instance and within a step.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.batch.runtime.context Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.batch.runtime.context

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.batch.runtime.context.JobContext
  • javax.batch.runtime.context.StepContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JobContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.runtime.context

Interface JobContext

  • public interface JobContext

    • Method Summary

      Methods
      Modifier and Type Method and Description
      BatchStatus getBatchStatus()
      The getBatchStatus method simply returns the batch status value set by the batch runtime into the job context.
      long getExecutionId()
      The getExecutionId method returns the current job's current execution id.
      String getExitStatus()
      The getExitStatus method simply returns the exit status value stored into the job context through the setExitStatus method or null.
      long getInstanceId()
      The getInstanceId method returns the current job's instance id.
      String getJobName()
      Get job name
      Properties getProperties()
      The getProperties method returns the job level properties specified in a job definition.
      Object getTransientUserData()
      The getTransientUserData method returns a transient data object belonging to the current Job XML execution element.
      void setExitStatus(String status)
      The setExitStatus method assigns the user-specified exit status for the current job.
      void setTransientUserData(Object data)
      The setTransientUserData method stores a transient data object into the current batch context.

    • Method Detail

      • getJobName

        String getJobName()
        Get job name
        Returns:
        value of 'id' attribute from

      • getTransientUserData

        Object getTransientUserData()
        The getTransientUserData method returns a transient data object belonging to the current Job XML execution element.
        Returns:
        user-specified type

      • setTransientUserData

        void setTransientUserData(Object data)
        The setTransientUserData method stores a transient data object into the current batch context.
        Parameters:
        data - is the user-specified type

      • getInstanceId

        long getInstanceId()
        The getInstanceId method returns the current job's instance id.
        Returns:
        job instance id

      • getExecutionId

        long getExecutionId()
        The getExecutionId method returns the current job's current execution id.
        Returns:
        job execution id

      • getProperties

        Properties getProperties()
        The getProperties method returns the job level properties specified in a job definition.
        Returns:
        job level properties

      • getBatchStatus

        BatchStatus getBatchStatus()
        The getBatchStatus method simply returns the batch status value set by the batch runtime into the job context.
        Returns:
        batch status string

      • getExitStatus

        String getExitStatus()
        The getExitStatus method simply returns the exit status value stored into the job context through the setExitStatus method or null.
        Returns:
        exit status string

      • setExitStatus

        void setExitStatus(String status)
        The setExitStatus method assigns the user-specified exit status for the current job. When the job ends, the exit status of the job is the value specified through setExitStatus. If setExitStatus was not called or was called with a null value, then the exit status defaults to the batch status of the job.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StepContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.batch.runtime.context

Interface StepContext

  • public interface StepContext

    • Method Summary

      Methods
      Modifier and Type Method and Description
      BatchStatus getBatchStatus()
      The getBatchStatus method returns the current batch status of the current step.
      Exception getException()
      The getException method returns the last exception thrown from a step level batch artifact to the batch runtime.
      String getExitStatus()
      The getExitStatus method simply returns the exit status value stored into the step context through the setExitStatus method or null.
      Metric[] getMetrics()
      The getMetrics method returns an array of step level metrics.
      Serializable getPersistentUserData()
      The getPersistentUserData method returns a persistent data object belonging to the current step.
      Properties getProperties()
      The getProperties method returns the step level properties specified in a job definition.
      long getStepExecutionId()
      The getStepExecutionId method returns the current step's execution id.
      String getStepName()
      Get step name
      Object getTransientUserData()
      The getTransientUserData method returns a transient data object belonging to the current Job XML execution element.
      void setExitStatus(String status)
      The setExitStatus method assigns the user-specified exit status for the current step.
      void setPersistentUserData(Serializable data)
      The setPersistentUserData method stores a persistent data object into the current step.
      void setTransientUserData(Object data)
      The setTransientUserData method stores a transient data object into the current batch context.

    • Method Detail

      • getStepName

        String getStepName()
        Get step name
        Returns:
        value of 'id' attribute from

      • getTransientUserData

        Object getTransientUserData()
        The getTransientUserData method returns a transient data object belonging to the current Job XML execution element.
        Returns:
        user-specified type

      • setTransientUserData

        void setTransientUserData(Object data)
        The setTransientUserData method stores a transient data object into the current batch context.
        Parameters:
        data - is the user-specified type

      • getStepExecutionId

        long getStepExecutionId()
        The getStepExecutionId method returns the current step's execution id.
        Returns:
        step execution id

      • getProperties

        Properties getProperties()
        The getProperties method returns the step level properties specified in a job definition.
        Returns:
        job level properties

      • getPersistentUserData

        Serializable getPersistentUserData()
        The getPersistentUserData method returns a persistent data object belonging to the current step. The user data type must implement java.util.Serializable. This data is saved as part of a step's checkpoint. For a step that does not do checkpoints, it is saved after the step ends. It is available upon restart.
        Returns:
        user-specified type

      • setPersistentUserData

        void setPersistentUserData(Serializable data)
        The setPersistentUserData method stores a persistent data object into the current step. The user data type must implement java.util.Serializable. This data is saved as part of a step's checkpoint. For a step that does not do checkpoints, it is saved after the step ends. It is available upon restart.
        Parameters:
        data - is the user-specified type

      • getBatchStatus

        BatchStatus getBatchStatus()
        The getBatchStatus method returns the current batch status of the current step. This value is set by the batch runtime and changes as the batch status changes.
        Returns:
        batch status string

      • getExitStatus

        String getExitStatus()
        The getExitStatus method simply returns the exit status value stored into the step context through the setExitStatus method or null.
        Returns:
        exit status string

      • setExitStatus

        void setExitStatus(String status)
        The setExitStatus method assigns the user-specified exit status for the current step. When the step ends, the exit status of the step is the value specified through setExitStatus. If setExitStatus was not called or was called with a null value, then the exit status defaults to the batch status of the step.

      • getException

        Exception getException()
        The getException method returns the last exception thrown from a step level batch artifact to the batch runtime.
        Returns:
        the last exception

      • getMetrics

        Metric[] getMetrics()
        The getMetrics method returns an array of step level metrics. These are things like commits, skips, etc.
        Returns:
        metrics array
        See Also:
        for definition of standard metrics.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.batch.runtime.context (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.batch.runtime.context

No usage of javax.batch.runtime.context
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.runtime.context.JobContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.runtime.context.JobContext

No usage of javax.batch.runtime.context.JobContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.batch.runtime.context.StepContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.batch.runtime.context.StepContext

No usage of javax.batch.runtime.context.StepContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Decorator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.decorator

Annotation Type Decorator

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
@Stereotype
public @interface Decorator

    Specifies that a class is a decorator. May be applied to a managed bean class.

     @Decorator
 class TimestampLogger implements Logger { ... }

    Decorators of a session bean must comply with the bean provider programming restrictions defined by the EJB specification. Decorators of a stateful session bean must comply with the rules for instance passivation and conversational state defined by the EJB specification.

    Author:
    Gavin King, Pete Muir
    See Also:
    @Delegate identifies the delegate injection point of a decorator.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Delegate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.decorator

Annotation Type Delegate

  • @Target(value={FIELD,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public @interface Delegate

    Identifies the delegate injection point of a decorator. May be applied to a field, bean constructor parameter or initializer method parameter of a decorator bean class.

     @Decorator
 class TimestampLogger implements Logger {
    @Inject @Delegate @Any Logger logger;
    ...
 }

     @Decorator
 class TimestampLogger implements Logger {
    private Logger logger;

    @Inject
    public TimestampLogger(@Delegate @Debug Logger logger) {
       this.logger=logger;
    }
    ...
 }

    A decorator must have exactly one delegate injection point. The delegate injection point must be an injected field, initializer method parameter or bean constructor method parameter.

    The container injects a delegate object to the delegate injection point. The delegate object implements the delegate type and delegates method invocations along the decorator stack. When the container calls a decorator during business method interception, the decorator may invoke any method of the delegate object. If a decorator invokes the delegate object at any other time, the invoked method throws an IllegalStateException.

     @Decorator
 class TimestampLogger implements Logger {
    @Inject @Delegate @Any Logger logger;

    void log(String message) {
       logger.log( timestamp() + ": " + message );
    }
    ...
 }
    Author:
    Gavin King, Pete Muir
    See Also:
    @Decorator specifies that a class is a decorator.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.decorator (Java(TM) EE 7 Specification APIs)

javax.decorator

Annotation Types

  • Decorator
  • Delegate


javax.decorator (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.decorator

Annotations relating to decorators.

See: Description

  • Annotation Types Summary
    Annotation Type Description
    Decorator
    Specifies that a class is a decorator.
    Delegate
    Identifies the delegate injection point of a decorator.

Package javax.decorator Description

Annotations relating to decorators.

A decorator implements one or more bean types and intercepts business method invocations of beans which implement those bean types. These bean types are called decorated types.

A decorator is a managed bean annotated @Decorator.

Decorators are superficially similar to interceptors, but because they directly implement operations with business semantics, they are able to implement business logic and, conversely, unable to implement the cross-cutting concerns for which interceptors are optimized. Decorators are called after interceptors.

Decorated types

The set of decorated types of a decorator includes all bean types of the managed bean that are Java interfaces, except for Serializable. The decorator bean class and its superclasses are not decorated types of the decorator. The decorator class may be abstract.

A decorator intercepts every method:

  • declared by a decorated type of the decorator
  • that is implemented by the bean class of the decorator.

A decorator may be an abstract class, and is not required to implement every method of every decorated type.

Delegate injection points

All decorators have a delegate injection point. A delegate injection point is an injection point of the bean class annotated @Delegate.

The type of the delegate injection point must implement or extend every decorated type. A decorator is not required to implement the type of the delegate injection point.

Enabled decorators

By default, a bean archive has no enabled decorators. A decorator must be explicitly enabled by listing its bean class under the <decorators> element of the beans.xml file of the bean archive. The order of the decorator declarations determines the decorator ordering. Decorators which occur earlier in the list are called first.

A decorator is bound to a bean if:

  • The bean is eligible for injection to the delegate injection point of the decorator.
  • The decorator is enabled in the bean archive of the bean.

If a managed bean class is declared final, it may not have decorators. If a managed bean has a non-static, non-private, final method, it may not have any decorator which implements that method.

A decorator instance is a dependent object of the object it decorates.

See Also:
javax.enterprise.inject, Decorator, Delegate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.decorator Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.decorator

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.decorator.Delegate (implements java.lang.annotation.Annotation)
  • javax.decorator.Decorator (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.decorator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.decorator

No usage of javax.decorator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.decorator.Decorator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.decorator.Decorator

No usage of javax.decorator.Decorator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.decorator.Delegate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.decorator.Delegate

No usage of javax.decorator.Delegate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AccessLocalException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class AccessLocalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.AccessLocalException
  • All Implemented Interfaces:
    Serializable

    public class AccessLocalException
extends EJBException
    An AccessLocalException is thrown to indicate that the caller does not have permission to call the method. This exception is thrown to local clients.
    Since:
    EJB 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      AccessLocalException()
      Constructs an AccessLocalException with no detail message.
      AccessLocalException(String message)
      Constructs an AccessLocalException with the specified detail message.
      AccessLocalException(String message, Exception ex)
      Constructs an AccessLocalException with the specified detail message and a nested exception.

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AccessLocalException

        public AccessLocalException()
        Constructs an AccessLocalException with no detail message.

      • AccessLocalException

        public AccessLocalException(String message)
        Constructs an AccessLocalException with the specified detail message.

      • AccessLocalException

        public AccessLocalException(String message,
                    Exception ex)
        Constructs an AccessLocalException with the specified detail message and a nested exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AccessTimeout (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type AccessTimeout

  • @Target(value={METHOD,TYPE})
@Retention(value=RUNTIME)
public @interface AccessTimeout
    Specifies the amount of time in a given time unit that a concurrent access attempt should block before timing out.

    This annotation may be applied to a stateful session bean or to a singleton session bean that uses container managed concurrency.

    By default, clients are allowed to make concurrent calls to a stateful session object and the container is required to serialize such concurrent requests. The AccessTimeout annotation is used to specify the amount of time a stateful session bean request should block in the case that the bean instance is already processing a different request. Use of the AccessTimeout annotation with a value of 0 specifies to the container that concurrent client requests to a stateful session bean are prohibited.

    The AccessTimeout annotation can be specified on a business method or a bean class. If it is specified on a class, it applies to all business methods of that class. If it is specified on both a class and on a business method of the class, the method-level annotation takes precedence for the given method.

    Access timeouts for a singleton session bean only apply to methods eligible for concurrency locks. The AccessTimeout annotation can be specified on the singleton session bean class or on an eligible method of the class. If AccessTimeout is specified on both a class and on a method of that class, the method-level annotation takes precedence for the given method.

    The semantics of the value element are as follows:

    • A value > 0 indicates a timeout value in the units specified by the unit element.
    • A value of 0 means concurrent access is not permitted.
    • A value of -1 indicates that the client request will block indefinitely until forward progress it can proceed.
    Values less than -1 are not valid.
    Since:
    EJB 3.1

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      long value
      The semantics of the value element are as follows: A value > 0 indicates a timeout value in the units specified by the unit element.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      TimeUnit unit
      Units used for the specified value.

    • Element Detail

      • value

        public abstract long value
        The semantics of the value element are as follows:
        • A value > 0 indicates a timeout value in the units specified by the unit element.
        • A value of 0 means concurrent access is not permitted.
        • A value of -1 indicates that the client request will block indefinitely until forward progress it can proceed.
        Values less than -1 are not valid.

      • unit

        public abstract TimeUnit unit
        Units used for the specified value.
        Default:
        java.util.concurrent.TimeUnit.MILLISECONDS
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ActivationConfigProperty (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type ActivationConfigProperty

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface ActivationConfigProperty
    Used to provide information to the deployer about the configuration of a message driven bean in its operational environment.

    The following standard properties are recognized for JMS message driven beans:

    • acknowledgeMode. This property is used to specify the JMS acknowledgement mode for the message delivery when bean-managed transaction demarcation is used. Its values are Auto_acknowledge or Dups_ok_acknowledge. If this property is not specified, JMS AUTO_ACKNOWLEDGE semantics are assumed.
    • messageSelector. This property is used to specify the JMS message selector to be used in determining which messages a JMS message driven bean is to receive.
    • destinationType. This property is used to specify whether the message driven bean is intended to be used with a queue or a topic. The value must be either javax.jms.Queue or javax.jms.Topic.
    • destinationLookup. This property is used to specify the JMS queue or topic from which a JMS message-driven bean is to receive messages.
    • connectionFactoryLookup. This property is used to specify the JMS connection factory that will be used to connect to the JMS provider from which a JMS message-driven bean is to receive messages.
    • subscriptionDurability. If the message driven bean is intended to be used with a topic, this property may be used to indicate whether a durable or non-durable subscription should be used. The value of this property must be either Durable or NonDurable
    • subscriptionName. This property is used to specify the name of the durable subscription if the message-driven bean is intended to be used with a Topic, and the bean provider has indicated that a durable subscription should be used.
    • clientId. This property is used to specify the JMS client identifier that will be used when connecting to the JMS provider from which a JMS message-driven bean is to receive messages. If this property is not specified then the client identifier will be left unset.
    Since:
    EJB 3.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String propertyName
      String propertyValue

    • Element Detail

      • propertyName

        public abstract String propertyName

      • propertyValue

        public abstract String propertyValue
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AfterBegin (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type AfterBegin

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface AfterBegin
    Designate a stateful session bean method to receive the after begin session synchronization callback.

    The after begin callback notifies a stateful session bean instance that a new transaction has started and that the subsequent business methods on the instance will be invoked in the context of the transaction.

    This method executes in the proper transaction context. A bean must have at most one AfterBegin method. The signature of this method must observe the following rules:

    • The method must not be declared as final or static.
    • The method may have any access type.
    • The return type must be void.
    • The method must take no arguments.

    A stateful session bean class may use either the SessionSynchronization interface or the session synchronization annotations, but not both.

    Since:
    EJB 3.1
    See Also:
    SessionSynchronization, BeforeCompletion, AfterCompletion
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AfterCompletion (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type AfterCompletion

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface AfterCompletion
    Designate a stateful session bean method to receive the after completion session synchronization callback.

    The after completion callback notifies a stateful session bean instance that a transaction commit protocol has completed. A completion status of true indicates that the transaction has committed. A status of false indicates that a rollback has occurred.

    A bean must have at most one AfterCompletion method. The signature of this method must observe the following rules:

    • The method must not be declared as final or static.
    • The method may have any access type.
    • The return type must be void.
    • The method must take a single argument of type boolean.

    This method executes with no transaction context.

    A stateful session bean class may use either the SessionSynchronization interface or the session synchronization annotations, but not both.

    Since:
    EJB 3.1
    See Also:
    SessionSynchronization, AfterBegin, BeforeCompletion
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ApplicationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type ApplicationException

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface ApplicationException
    Applied to an exception to denote that it is an application exception and should be reported to the client directly (i.e., unwrapped).
    Since:
    EJB 3.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean inherited
      Indicates whether the application exception designation should apply to subclasses of the annotated exception class.
      boolean rollback
      Indicates whether the container should cause the transaction to rollback when the exception is thrown.

    • Element Detail

      • rollback

        public abstract boolean rollback
        Indicates whether the container should cause the transaction to rollback when the exception is thrown.
        Default:
        false

      • inherited

        public abstract boolean inherited
        Indicates whether the application exception designation should apply to subclasses of the annotated exception class.
        Since:
        EJB 3.1
        Default:
        true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Asynchronous (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Asynchronous

  • @Target(value={METHOD,TYPE})
@Retention(value=RUNTIME)
public @interface Asynchronous
    Used to mark a session bean method as an asynchronous method or to designate all business methods of a session bean class as asynchronous.

    An asychronous method must have return type void or Future<V>, where V is the result value type.

    Asynchronous method invocation semantics only apply to the no-interface, local business, and remote business client views. Methods exposed through the EJB 2.x local, EJB 2.x remote, and web service client views must not be designated as asynchronous.

    Since:
    EJB 3.1
    See Also:
    AsyncResult
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AsyncResult (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class AsyncResult<V>

  • java.lang.Object
    • javax.ejb.AsyncResult<V>
  • All Implemented Interfaces:
    Future<V>

    public final class AsyncResult<V>
extends Object
implements Future<V>
    Wraps the result of an asynchronous method call as a Future object, preserving compatability with the business interface signature.

    The value specified in the constructor will be retrieved by the container and made available to the client.

    Note that this object is not passed to the client. It is merely a convenience for providing the result value to the container. Therefore, none of its instance methods should be called by the application.

    Since:
    EJB 3.1

    • Constructor Summary

      Constructors
      Constructor and Description
      AsyncResult(V result)
      Creates a AsyncResult instance to wrap the result of an asynchronous method call

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean cancel(boolean mayInterruptIfRunning)
      This method should not be called.
      V get()
      This method should not be called.
      V get(long timeout, TimeUnit unit)
      This method should not be called.
      boolean isCancelled()
      This method should not be called.
      boolean isDone()
      This method should not be called.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AsyncResult

        public AsyncResult(V result)
        Creates a AsyncResult instance to wrap the result of an asynchronous method call
        Parameters:
        result - the result of an asynchronous method call to be made available to the client

    • Method Detail

      • cancel

        public boolean cancel(boolean mayInterruptIfRunning)
        This method should not be called. See Class-level comments.
        Specified by:
        cancel in interface Future<V>

      • isCancelled

        public boolean isCancelled()
        This method should not be called. See Class-level comments.
        Specified by:
        isCancelled in interface Future<V>

      • isDone

        public boolean isDone()
        This method should not be called. See Class-level comments.
        Specified by:
        isDone in interface Future<V>

      • get

        public V get()
      throws InterruptedException,
             ExecutionException
        This method should not be called. See Class-level comments.
        Specified by:
        get in interface Future<V>
        Throws:
        InterruptedException
        ExecutionException

      • get

        public V get(long timeout,
    TimeUnit unit)
      throws InterruptedException,
             ExecutionException,
             TimeoutException
        This method should not be called. See Class-level comments.
        Specified by:
        get in interface Future<V>
        Throws:
        InterruptedException
        ExecutionException
        TimeoutException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BeforeCompletion (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type BeforeCompletion

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface BeforeCompletion
    Designate a stateful session bean method to receive the before completion session synchronization callback.

    The before completion callback notifies a stateful session bean instance that a transaction is about to be committed.

    This method executes in the proper transaction context.

    Note: The instance may still cause the container to rollback the transaction by invoking the setRollbackOnly() method on the session context or by throwing an exception. A bean must have at most one BeforeCompletion method. The signature of this method must observe the following rules:

    • The method must not be declared as final or static.
    • The method may have any access type.
    • The return type must be void.
    • The method must take no arguments.

    A stateful session bean class may use either the SessionSynchronization interface or the session synchronization annotations, but not both.

    Since:
    EJB 3.1
    See Also:
    SessionSynchronization, AfterBegin, AfterCompletion
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ConcurrencyManagement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type ConcurrencyManagement

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface ConcurrencyManagement
    Declares a singleton session bean's concurrency management type.

    If this annotation is not specified, the singleton bean is assumed to have container managed concurrency.

    This annotation may be applied to stateful session beans, but doing so has no impact on the semantics of concurrency management for such beans. The concurrency management type for bean-managed concurrency (BEAN) does not apply to stateful session beans.

    Since:
    EJB 3.1
    See Also:
    ConcurrencyManagementType, Lock

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      ConcurrencyManagementType value

    • Element Detail

      • value

        public abstract ConcurrencyManagementType value
        Default:
        javax.ejb.ConcurrencyManagementType.CONTAINER
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ConcurrencyManagementType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.ejb

Enum ConcurrencyManagementType

  • java.lang.Object
    • java.lang.Enum<ConcurrencyManagementType>
      • javax.ejb.ConcurrencyManagementType
  • All Implemented Interfaces:
    Serializable, Comparable<ConcurrencyManagementType>

    public enum ConcurrencyManagementType
extends Enum<ConcurrencyManagementType>
    Used to specify the value of the ConcurrencyManagement annotation for a singleton session bean.
    Since:
    EJB 3.1
    See Also:
    ConcurrencyManagement

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BEAN
      Bean developer is responsible for managing concurrent access to the bean instance.
      CONTAINER
      Container is responsible for managing concurrent access to the bean instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ConcurrencyManagementType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ConcurrencyManagementType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CONTAINER

        public static final ConcurrencyManagementType CONTAINER
        Container is responsible for managing concurrent access to the bean instance.

      • BEAN

        public static final ConcurrencyManagementType BEAN
        Bean developer is responsible for managing concurrent access to the bean instance.

    • Method Detail

      • values

        public static ConcurrencyManagementType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ConcurrencyManagementType c : ConcurrencyManagementType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ConcurrencyManagementType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ConcurrentAccessException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class ConcurrentAccessException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.ConcurrentAccessException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ConcurrentAccessTimeoutException, IllegalLoopbackException

    public class ConcurrentAccessException
extends EJBException
    A ConcurrentAccessException indicates that the client has attempted an invocation on a stateful session bean or singleton bean while another invocation is in progress and such concurrent access is not allowed.
    Since:
    EJB 3.1
    See Also:
    AccessTimeout, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ConcurrentAccessException()
      Constructs an ConcurrentAccessException with no detail message.
      ConcurrentAccessException(String message)
      Constructs an ConcurrentAccessException with the specified detailed message.
      ConcurrentAccessException(String message, Exception ex)
      Constructs an ConcurrentAccessException with the specified detail message and a nested exception.

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ConcurrentAccessException

        public ConcurrentAccessException()
        Constructs an ConcurrentAccessException with no detail message.

      • ConcurrentAccessException

        public ConcurrentAccessException(String message)
        Constructs an ConcurrentAccessException with the specified detailed message.

      • ConcurrentAccessException

        public ConcurrentAccessException(String message,
                         Exception ex)
        Constructs an ConcurrentAccessException with the specified detail message and a nested exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConcurrentAccessTimeoutException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class ConcurrentAccessTimeoutException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.ConcurrentAccessException
              • javax.ejb.ConcurrentAccessTimeoutException
  • All Implemented Interfaces:
    Serializable

    public class ConcurrentAccessTimeoutException
extends ConcurrentAccessException
    This exception indicates that an attempt to concurrently access a stateful session or singleton bean method resulted in a timeout.
    Since:
    EJB 3.1
    See Also:
    AccessTimeout, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ConcurrentAccessTimeoutException()
      ConcurrentAccessTimeoutException(String message)

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ConcurrentAccessTimeoutException

        public ConcurrentAccessTimeoutException()

      • ConcurrentAccessTimeoutException

        public ConcurrentAccessTimeoutException(String message)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CreateException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class CreateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.ejb.CreateException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    DuplicateKeyException

    public class CreateException
extends Exception
    The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise bean's home or local home interface.

    This exception is used as a standard application-level exception to report a failure to create an EJB object or local object.

    Since:
    EJB 1.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      CreateException()
      Constructs a CreateException with no detail message.
      CreateException(String message)
      Constructs a CreateException with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • CreateException

        public CreateException()
        Constructs a CreateException with no detail message.

      • CreateException

        public CreateException(String message)
        Constructs a CreateException with the specified detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DependsOn (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type DependsOn

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface DependsOn
    Used to express an initialization dependency between singleton components.

    The container ensures that all singleton beans with which a singleton has a DependsOn relationship have been initialized before the singleton's PostConstruct method is called.

    During application shutdown the container ensures that all singleton beans on with which the singleton has a DependsOn relationship are still available during the singleton's PreDestroy method.

    Since:
    EJB 3.1

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String[] value
      The ejb-names of singleton components whose initialization must occur before this singleton.

    • Element Detail

      • value

        public abstract String[] value
        The ejb-names of singleton components whose initialization must occur before this singleton. The order in which these names are listed is not significant.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DuplicateKeyException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class DuplicateKeyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.ejb.CreateException
          • javax.ejb.DuplicateKeyException
  • All Implemented Interfaces:
    Serializable

    public class DuplicateKeyException
extends CreateException
    The DuplicateKeyException exception is thrown if an entity EJB object or EJB local object cannot be created because an object with the same key already exists. This exception is thrown by the create methods defined in an entity bean's home or local home interface.

    Note: Support for entity beans is optional as of EJB 3.2

    Since:
    EJB 1.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DuplicateKeyException()
      Constructs a DuplicateKeyException with no detail message.
      DuplicateKeyException(String message)
      Constructs a DuplicateKeyException with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DuplicateKeyException

        public DuplicateKeyException()
        Constructs a DuplicateKeyException with no detail message.

      • DuplicateKeyException

        public DuplicateKeyException(String message)
        Constructs a DuplicateKeyException with the specified detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJB (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type EJB

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface EJB
    Indicates a dependency on the local, no-interface, or remote view of an Enterprise JavaBean.

    Either the beanName or the lookup element can be used to resolve the EJB dependency to its target session bean component. It is an error to specify values for both beanName and lookup.

    If no explicit linking information is provided and there is only one session bean within the same application that exposes the matching client view type, by default the EJB dependency resolves to that session bean.

    Since:
    EJB 3.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class beanInterface
      The interface type of the Enterprise Java Bean to which this reference is mapped.
      String beanName
      The beanName element references the value of the name element of the Stateful or Stateless annotation, whether defaulted or explicit.
      String description
      A string describing the bean.
      String lookup
      A portable lookup string containing the JNDI name for the target EJB component.
      String mappedName
      The product specific name of the EJB component to which this ejb reference should be mapped.
      String name
      The logical name of the ejb reference within the declaring component's (e.g., java:comp/env) environment.

    • Element Detail

      • name

        public abstract String name
        The logical name of the ejb reference within the declaring component's (e.g., java:comp/env) environment.
        Default:
        ""

      • description

        public abstract String description
        A string describing the bean.
        Default:
        ""

      • beanName

        public abstract String beanName
        The beanName element references the value of the name element of the Stateful or Stateless annotation, whether defaulted or explicit. If the deployment descriptor was used to define the name of the bean, the beanName element references the ejb-name element of the bean definition.

        The beanName element allows disambiguation if multiple session beans in the ejb-jar implement the same interface.

        In order to reference a bean in another ejb-jar file in the same application, the beanName may be composed of a path name specifying the ejb-jar containing the referenced bean with the bean name of the target bean appended and separated from the path name by #. The path name is relative to the jar file containing the component that is referencing the target bean.

        Only applicable if the target EJB is defined within the same application or stand-alone module as the declaring component.

        Default:
        ""

      • beanInterface

        public abstract Class beanInterface
        The interface type of the Enterprise Java Bean to which this reference is mapped.

        Holds one of the following types of the target EJB :

        • Local business interface
        • Bean class (for no-interface view)
        • Remote business interface
        • Local Home interface
        • Remote Home interface
        Default:
        java.lang.Object.class

      • mappedName

        public abstract String mappedName
        The product specific name of the EJB component to which this ejb reference should be mapped. This mapped name is often a global JNDI name, but may be a name of any form.

        Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

        Default:
        ""

      • lookup

        public abstract String lookup
        A portable lookup string containing the JNDI name for the target EJB component.
        Since:
        EJB 3.1
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


EJBAccessException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class EJBAccessException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.EJBAccessException
  • All Implemented Interfaces:
    Serializable

    public class EJBAccessException
extends EJBException
    This exception indicates that client access to a business method was denied.
    Since:
    EJB 3.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EJBAccessException()
      Constructs an EJBAccessException with no detail message.
      EJBAccessException(String message)
      Constructs an EJBAccessException with the specified detailed message.

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EJBAccessException

        public EJBAccessException()
        Constructs an EJBAccessException with no detail message.

      • EJBAccessException

        public EJBAccessException(String message)
        Constructs an EJBAccessException with the specified detailed message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface EJBContext

  • All Known Subinterfaces:
    EntityContext, MessageDrivenContext, SessionContext

    public interface EJBContext
    The EJBContext interface provides an instance with access to the container-provided runtime context of an enterprise bean instance.

    This interface is extended by the SessionContext, EntityContext, and MessageDrivenContext interfaces to provide additional methods specific to the enterprise interface bean type.

    Since:
    EJB 1.0
    See Also:
    SessionContext, MessageDrivenContext, EntityContext

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Identity getCallerIdentity()
      Deprecated.
      Use Principal getCallerPrincipal() instead.
      Principal getCallerPrincipal()
      Obtain the java.security.Principal that identifies the caller.
      Map<String,Object> getContextData()
      The getContextData method enables a business method, lifecycle callback method, or timeout method to retrieve any interceptor/webservices context associated with its invocation.
      EJBHome getEJBHome()
      Obtain the enterprise bean's remote home interface.
      EJBLocalHome getEJBLocalHome()
      Obtain the enterprise bean's local home interface.
      Properties getEnvironment()
      Deprecated.
      Use the JNDI naming context java:comp/env to access enterprise bean's environment.
      boolean getRollbackOnly()
      Test if the transaction has been marked for rollback only.
      TimerService getTimerService()
      Get access to the EJB Timer Service.
      UserTransaction getUserTransaction()
      Obtain the transaction demarcation interface.
      boolean isCallerInRole(Identity role)
      Deprecated.
      Use boolean isCallerInRole(String roleName) instead.
      boolean isCallerInRole(String roleName)
      Test if the caller has a given security role.
      Object lookup(String name)
      Lookup a resource within the java: namespace.
      void setRollbackOnly()
      Mark the current transaction for rollback.

    • Method Detail

      • getEJBHome

        EJBHome getEJBHome()
                   throws IllegalStateException
        Obtain the enterprise bean's remote home interface.
        Returns:
        The enterprise bean's remote home interface.
        Throws:
        IllegalStateException - if the enterprise bean does not have a remote home interface.

      • getEJBLocalHome

        EJBLocalHome getEJBLocalHome()
                             throws IllegalStateException
        Obtain the enterprise bean's local home interface.
        Returns:
        The enterprise bean's local home interface.
        Throws:
        IllegalStateException - if the enterprise bean does not have a local home interface.
        Since:
        EJB 2.0

      • getEnvironment

        Properties getEnvironment()
        Deprecated. Use the JNDI naming context java:comp/env to access enterprise bean's environment.
        Obtain the enterprise bean's environment properties.

        Note: If the enterprise bean has no environment properties this method returns an empty java.util.Properties object. This method never returns null.

        Returns:
        The environment properties for the enterprise bean.

      • getCallerIdentity

        Identity getCallerIdentity()
        Deprecated. Use Principal getCallerPrincipal() instead.
        Obtain the java.security.Identity of the caller. This method is deprecated in EJB 1.1. The Container is allowed to return always null from this method. The enterprise bean should use the getCallerPrincipal method instead.
        Returns:
        The Identity object that identifies the caller.

      • getCallerPrincipal

        Principal getCallerPrincipal()
                             throws IllegalStateException
        Obtain the java.security.Principal that identifies the caller.
        Returns:
        The Principal object that identifies the caller. This method never returns null.
        Throws:
        IllegalStateException - The Container throws the exception if the instance is not allowed to call this method.
        Since:
        EJB 1.1

      • isCallerInRole

        boolean isCallerInRole(Identity role)
        Deprecated. Use boolean isCallerInRole(String roleName) instead.
        Test if the caller has a given role.

        This method is deprecated in EJB 1.1. The enterprise bean should use the isCallerInRole(String roleName) method instead.

        Parameters:
        role - The java.security.Identity of the role to be tested.
        Returns:
        True if the caller has the specified role.

      • isCallerInRole

        boolean isCallerInRole(String roleName)
                       throws IllegalStateException
        Test if the caller has a given security role.
        Parameters:
        roleName - The name of the security role. The role must be one of the security roles that is defined in the deployment descriptor.
        Returns:
        True if the caller has the specified role.
        Throws:
        IllegalStateException - The Container throws the exception if the instance is not allowed to call this method.
        Since:
        EJB 1.1

      • getUserTransaction

        UserTransaction getUserTransaction()
                                   throws IllegalStateException
        Obtain the transaction demarcation interface. Only enterprise beans with bean-managed transactions are allowed to to use the UserTransaction interface. As entity beans must always use container-managed transactions, only session beans or message-driven beans with bean-managed transactions are allowed to invoke this method.
        Returns:
        The UserTransaction interface that the enterprise bean instance can use for transaction demarcation.
        Throws:
        IllegalStateException - The Container throws the exception if the instance is not allowed to use the UserTransaction interface (i.e. the instance is of a bean with container-managed transactions).

      • setRollbackOnly

        void setRollbackOnly()
                     throws IllegalStateException
        Mark the current transaction for rollback. The transaction will become permanently marked for rollback. A transaction marked for rollback can never commit. Only enterprise beans with container-managed transactions are allowed to use this method.
        Throws:
        IllegalStateException - The Container throws the exception if the instance is not allowed to use this method (i.e. the instance is of a bean with bean-managed transactions).

      • getRollbackOnly

        boolean getRollbackOnly()
                        throws IllegalStateException
        Test if the transaction has been marked for rollback only. An enterprise bean instance can use this operation, for example, to test after an exception has been caught, whether it is fruitless to continue computation on behalf of the current transaction. Only enterprise beans with container-managed transactions are allowed to use this method.
        Returns:
        True if the current transaction is marked for rollback, false otherwise.
        Throws:
        IllegalStateException - The Container throws the exception if the instance is not allowed to use this method (i.e. the instance is of a bean with bean-managed transactions).

      • getTimerService

        TimerService getTimerService()
                             throws IllegalStateException
        Get access to the EJB Timer Service.
        Throws:
        IllegalStateException - The Container throws the exception if the instance is not allowed to use this method (e.g. if the bean is a stateful session bean)
        Since:
        EJB 2.1

      • lookup

        Object lookup(String name)
              throws IllegalArgumentException
        Lookup a resource within the java: namespace. Names referring to entries within the private component namespace can be passed as unqualified strings. In that case the lookup will be relative to "java:comp/env/". For example, assuming an enterprise bean defines an ejb-local-ref with ejb-ref-name "ejb/BarRef" the following two calls to EJBContext.lookup are equivalent : ejbContext.lookup("ejb/BarRef"); ejbContext.lookup("java:comp/env/ejb/BarRef");
        Parameters:
        name - Name of the entry
        Throws:
        IllegalArgumentException - The Container throws the exception if the given name does not match an entry within the component's environment.
        Since:
        EJB 3.0

      • getContextData

        Map<String,Object> getContextData()
        The getContextData method enables a business method, lifecycle callback method, or timeout method to retrieve any interceptor/webservices context associated with its invocation.
        Returns:
        the context data that interceptor context associated with this invocation. If there is no context data, an empty Map<String,Object> object will be returned.
        Since:
        EJB 3.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class EJBException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    AccessLocalException, ConcurrentAccessException, EJBAccessException, EJBTransactionRequiredException, EJBTransactionRolledbackException, NoMoreTimeoutsException, NoSuchEJBException, NoSuchEntityException, NoSuchObjectLocalException, TransactionRequiredLocalException, TransactionRolledbackLocalException

    public class EJBException
extends RuntimeException
    The EJBException is thrown to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g. the instance failed to open a database connection).
    Since:
    EJB 1.1
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EJBException()
      Constructs an EJBException with no detail message.
      EJBException(Exception ex)
      Constructs an EJBException that embeds the originally thrown exception.
      EJBException(String message)
      Constructs an EJBException with the specified detailed message.
      EJBException(String message, Exception ex)
      Constructs an EJBException that embeds the originally thrown exception with the specified detail message.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Exception getCausedByException()
      Obtain the exception that caused the EJBException to be thrown.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EJBException

        public EJBException()
        Constructs an EJBException with no detail message.

      • EJBException

        public EJBException(String message)
        Constructs an EJBException with the specified detailed message.

      • EJBException

        public EJBException(Exception ex)
        Constructs an EJBException that embeds the originally thrown exception.

      • EJBException

        public EJBException(String message,
            Exception ex)
        Constructs an EJBException that embeds the originally thrown exception with the specified detail message.

    • Method Detail

      • getCausedByException

        public Exception getCausedByException()
        Obtain the exception that caused the EJBException to be thrown. It is recommended that the inherited Throwable.getCause() method be used to retrieve the cause instead of this method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBHome (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface EJBHome

  • All Superinterfaces:
    Remote
    All Known Subinterfaces:
    ManagementHome

    public interface EJBHome
extends Remote
    The EJBHome interface must be extended by all enterprise beans' remote home interfaces. An enterprise bean's remote home interface defines the methods that allow a remote client to create, find, and remove EJB objects.

    The remote home interface is defined by the enterprise bean provider and implemented by the enterprise bean container.

    Enterprise beans written to the EJB 3.0 and later APIs do not require a home interface.

    Since:
    EJB 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EJBMetaData getEJBMetaData()
      Obtain the EJBMetaData interface for the enterprise bean.
      HomeHandle getHomeHandle()
      Obtain a handle for the remote home object.
      void remove(Handle handle)
      Remove an EJB object identified by its handle.
      void remove(Object primaryKey)
      Remove an EJB object identified by its primary key.

    • Method Detail

      • remove

        void remove(Handle handle)
            throws RemoteException,
                   RemoveException
        Remove an EJB object identified by its handle.
        Parameters:
        handle - the handle of the EJB object to be removed
        Throws:
        RemoveException - Thrown if the enterprise bean or the container does not allow the client to remove the object.
        RemoteException - Thrown when the method failed due to a system-level failure.

      • remove

        void remove(Object primaryKey)
            throws RemoteException,
                   RemoveException
        Remove an EJB object identified by its primary key.

        This method can be used only for an entity bean. An attempt to call this method on a session bean will result in a RemoveException.

        Note: Support for entity beans is optional as of EJB 3.2.

        Parameters:
        primaryKey - the primary key of the EJB object to be removed
        Throws:
        RemoveException - Thrown if the enterprise bean or the container does not allow the client to remove the object.
        RemoteException - Thrown when the method failed due to a system-level failure.

      • getEJBMetaData

        EJBMetaData getEJBMetaData()
                           throws RemoteException
        Obtain the EJBMetaData interface for the enterprise bean. The EJBMetaData interface allows the client to obtain information about the enterprise bean.

        The information obtainable via the EJBMetaData interface is intended to be used by tools.

        Returns:
        The enterprise Bean's EJBMetaData interface.
        Throws:
        RemoteException - Thrown when the method failed due to a system-level failure.

      • getHomeHandle

        HomeHandle getHomeHandle()
                         throws RemoteException
        Obtain a handle for the remote home object. The handle can be used at later time to re-obtain a reference to the remote home object, possibly in a different Java Virtual Machine.
        Returns:
        A handle for the remote home object.
        Throws:
        RemoteException - Thrown when the method failed due to a system-level failure.
        Since:
        EJB 1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBLocalHome (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface EJBLocalHome

  • public interface EJBLocalHome
    The EJBLocalHome interface must be extended by all enterprise beans' local home interfaces. An enterprise bean's local home interface defines the methods that allow local clients to create, find, and remove EJB objects.

    The local home interface is defined by the enterprise bean provider and implemented by the enterprise bean container.

    Enterprise beans written to the EJB 3.0 and later APIs do not require a local home interface.

    Since:
    EJB 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void remove(Object primaryKey)
      Remove an EJB object identified by its primary key.

    • Method Detail

      • remove

        void remove(Object primaryKey)
            throws RemoveException,
                   EJBException
        Remove an EJB object identified by its primary key.

        This method can only be used by local clients of an entity bean. An attempt to call this method on a session bean will result in a RemoveException.

        Note: Support for entity beans is optional as of EJB 3.2.

        Parameters:
        primaryKey - the primary key of the EJB object to be removed
        Throws:
        RemoveException - Thrown if the enterprise bean or the container does not allow the client to remove the object.
        EJBException - Thrown when the method failed due to a system-level failure.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBLocalObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface EJBLocalObject

  • public interface EJBLocalObject
    The EJBLocalObject interface must be extended by all enterprise beans' local interfaces. An enterprise bean's local interface provides the local client view of an EJB object. An enterprise bean's local interface defines the business methods callable by local clients.

    The enterprise bean's local interface is defined by the enterprise bean provider and implemented by the enterprise bean container.

    Enterprise beans written to the EJB 3.0 and later APIs do not require a local interface that extends the EJBLocalObject interface. A local business interface can be used instead.

    Since:
    EJB 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EJBLocalHome getEJBLocalHome()
      Obtain the enterprise bean's local home interface.
      Object getPrimaryKey()
      Obtain the primary key of the EJB local object.
      boolean isIdentical(EJBLocalObject obj)
      Test if a given EJB local object is identical to the invoked EJB local object.
      void remove()
      Remove the EJB local object.

    • Method Detail

      • getEJBLocalHome

        EJBLocalHome getEJBLocalHome()
                             throws EJBException
        Obtain the enterprise bean's local home interface. The local home interface defines the enterprise bean's create, finder, remove, and home business methods that are available to local clients.
        Returns:
        A reference to the enterprise bean's local home interface.
        Throws:
        EJBException - Thrown when the method failed due to a system-level failure.

      • getPrimaryKey

        Object getPrimaryKey()
                     throws EJBException
        Obtain the primary key of the EJB local object.

        This method can be called on an entity bean. An attempt to invoke this method on a session bean will result in an EJBException.

        Note: Support for entity beans is optional as of EJB 3.2.

        Returns:
        The EJB local object's primary key.
        Throws:
        EJBException - Thrown when the method failed due to a system-level failure or when invoked on a session bean.

      • remove

        void remove()
            throws RemoveException,
                   EJBException
        Remove the EJB local object.
        Throws:
        RemoveException - The enterprise bean or the container does not allow destruction of the object.
        EJBException - Thrown when the method failed due to a system-level failure.

      • isIdentical

        boolean isIdentical(EJBLocalObject obj)
                    throws EJBException
        Test if a given EJB local object is identical to the invoked EJB local object.
        Parameters:
        obj - An object to test for identity with the invoked object.
        Returns:
        True if the given EJB local object is identical to the invoked object, false otherwise.
        Throws:
        EJBException - Thrown when the method failed due to a system-level failure.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBMetaData (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface EJBMetaData

  • public interface EJBMetaData
    The EJBMetaData interface allows a client to obtain the enterprise bean's meta-data information.

    The meta-data is intended for development tools used for building applications that use deployed enterprise beans, and for clients using a scripting language to access the enterprise bean.

    Note that the EJBMetaData is not a remote interface. The class that implements this interface (this class is typically generated by container tools) must be serializable, and must be a valid RMI/IDL value type.

    Since:
    EJB 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EJBHome getEJBHome()
      Obtain the remote home interface of the enterprise bean.
      Class getHomeInterfaceClass()
      Obtain the class object for the enterprise bean's remote home interface.
      Class getPrimaryKeyClass()
      Obtain the class object for the enterprise bean's primary key class.
      Class getRemoteInterfaceClass()
      Obtain the class object for the enterprise bean's remote interface.
      boolean isSession()
      Test if the enterprise bean's type is "session".
      boolean isStatelessSession()
      Test if the enterprise bean's type is "stateless session".

    • Method Detail

      • getEJBHome

        EJBHome getEJBHome()
        Obtain the remote home interface of the enterprise bean.
        Returns:
        the remote home interface of the enterprise bean.

      • getHomeInterfaceClass

        Class getHomeInterfaceClass()
        Obtain the class object for the enterprise bean's remote home interface.
        Returns:
        the class object for the enterprise bean's remote home interface.

      • getRemoteInterfaceClass

        Class getRemoteInterfaceClass()
        Obtain the class object for the enterprise bean's remote interface.
        Returns:
        the class object for the enterprise bean's remote interface.

      • getPrimaryKeyClass

        Class getPrimaryKeyClass()
        Obtain the class object for the enterprise bean's primary key class.
        Returns:
        the class object for the enterprise bean's primary key class.

      • isSession

        boolean isSession()
        Test if the enterprise bean's type is "session".
        Returns:
        True if the type of the enterprise bean is session bean.

      • isStatelessSession

        boolean isStatelessSession()
        Test if the enterprise bean's type is "stateless session".
        Returns:
        True if the type of the enterprise Bean is stateless session.
        Since:
        EJB 1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface EJBObject

  • All Superinterfaces:
    Remote
    All Known Subinterfaces:
    Management

    public interface EJBObject
extends Remote
    The EJBObject interface is extended by all enterprise beans' remote interfaces. An enterprise bean's remote interface provides the remote client view of an EJB object. An enterprise bean's remote interface defines the business methods callable by a remote client.

    The remote interface must extend the javax.ejb.EJBObject interface, and define the enterprise bean specific business methods.

    The enterprise bean's remote interface is defined by the enterprise bean provider and implemented by the enterprise bean container.

    Enterprise beans written to the EJB 3.0 and later APIs do not require a remote interface that extends the EJBObject interface. A remote business interface can be used instead.

    Since:
    EJB 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EJBHome getEJBHome()
      Obtain the enterprise bean's remote home interface.
      Handle getHandle()
      Obtain a handle for the EJB object.
      Object getPrimaryKey()
      Obtain the primary key of the EJB object.
      boolean isIdentical(EJBObject obj)
      Test if a given EJB object is identical to the invoked EJB object.
      void remove()
      Remove the EJB object.

    • Method Detail

      • getEJBHome

        EJBHome getEJBHome()
                   throws RemoteException
        Obtain the enterprise bean's remote home interface. The remote home interface defines the enterprise bean's create, finder, remove, and home business methods.
        Returns:
        A reference to the enterprise bean's home interface.
        Throws:
        RemoteException - Thrown when the method failed due to a system-level failure.

      • getPrimaryKey

        Object getPrimaryKey()
                     throws RemoteException
        Obtain the primary key of the EJB object.

        This method can be called on an entity bean. An attempt to invoke this method on a session bean will result in RemoteException.

        Note: Support for entity beans is optional as of EJB 3.2.

        Returns:
        The EJB object's primary key.
        Throws:
        RemoteException - Thrown when the method failed due to a system-level failure or when invoked on a session bean.

      • remove

        void remove()
            throws RemoteException,
                   RemoveException
        Remove the EJB object.
        Throws:
        RemoteException - Thrown when the method failed due to a system-level failure.
        RemoveException - The enterprise bean or the container does not allow destruction of the object.

      • getHandle

        Handle getHandle()
                 throws RemoteException
        Obtain a handle for the EJB object. The handle can be used at later time to re-obtain a reference to the EJB object, possibly in a different Java Virtual Machine.
        Returns:
        A handle for the EJB object.
        Throws:
        RemoteException - Thrown when the method failed due to a system-level failure.

      • isIdentical

        boolean isIdentical(EJBObject obj)
                    throws RemoteException
        Test if a given EJB object is identical to the invoked EJB object.
        Parameters:
        obj - An object to test for identity with the invoked object.
        Returns:
        True if the given EJB object is identical to the invoked object, false otherwise.
        Throws:
        RemoteException - Thrown when the method failed due to a system-level failure.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBs (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type EJBs

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface EJBs
    Declares multiple EJB annotations.
    Since:
    EJB 3.0
    See Also:
    EJB

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      EJB[] value

    • Element Detail

      • value

        public abstract EJB[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


EJBTransactionRequiredException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class EJBTransactionRequiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.EJBTransactionRequiredException
  • All Implemented Interfaces:
    Serializable

    public class EJBTransactionRequiredException
extends EJBException
    This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.
    Since:
    EJB 3.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EJBTransactionRequiredException()
      Constructs an EJBTransactionRequiredException with no detail message.
      EJBTransactionRequiredException(String message)
      Constructs an EJBTransactionRequiredException with the specified detailed message.

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EJBTransactionRequiredException

        public EJBTransactionRequiredException()
        Constructs an EJBTransactionRequiredException with no detail message.

      • EJBTransactionRequiredException

        public EJBTransactionRequiredException(String message)
        Constructs an EJBTransactionRequiredException with the specified detailed message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBTransactionRolledbackException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class EJBTransactionRolledbackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.EJBTransactionRolledbackException
  • All Implemented Interfaces:
    Serializable

    public class EJBTransactionRolledbackException
extends EJBException
    This exception is thrown to a remote client to indicate that the transaction associated with processing of the request has been rolled back, or marked to roll back. Thus the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless.
    Since:
    EJB 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EJBTransactionRolledbackException()
      Constructs an EJBTransactionRolledbackException with no detail message.
      EJBTransactionRolledbackException(String message)
      Constructs an EJBTransactionRolledbackException with the specified detailed message.
      EJBTransactionRolledbackException(String message, Exception ex)
      Constructs an EJBTransactionRolledbackException with the specified detail message and a nested exception.

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EJBTransactionRolledbackException

        public EJBTransactionRolledbackException()
        Constructs an EJBTransactionRolledbackException with no detail message.

      • EJBTransactionRolledbackException

        public EJBTransactionRolledbackException(String message)
        Constructs an EJBTransactionRolledbackException with the specified detailed message.

      • EJBTransactionRolledbackException

        public EJBTransactionRolledbackException(String message,
                                 Exception ex)
        Constructs an EJBTransactionRolledbackException with the specified detail message and a nested exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EnterpriseBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface EnterpriseBean

  • All Superinterfaces:
    Serializable
    All Known Subinterfaces:
    EntityBean, MessageDrivenBean, SessionBean

    public interface EnterpriseBean
extends Serializable
    The EnterpriseBean interface is a common superinterface for the SessionBean, EntityBean and MessageDrivenBean interfaces.
    Since:
    EJB 1.0
    See Also:
    SessionBean, MessageDrivenBean, EntityBean
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface EntityBean

  • All Superinterfaces:
    EnterpriseBean, Serializable

    public interface EntityBean
extends EnterpriseBean
    The EntityBean interface is implemented by every entity bean class. The container uses the EntityBean methods to notify the entity bean instances of the instance's life cycle events.

    Applications written to the EJB 3.0 and later APIs should use the facilities of the Java Persistence API (javax.persistence) to model persistent entities.

    Note: Support for entity beans is optional as of EJB 3.2.

    Since:
    EJB 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void ejbActivate()
      A container invokes this method when the instance is taken out of the pool of available instances to become associated with a specific EJB object.
      void ejbLoad()
      A container invokes this method to instruct the instance to synchronize its state by loading it state from the underlying database.
      void ejbPassivate()
      A container invokes this method on an instance before the instance becomes disassociated with a specific EJB object.
      void ejbRemove()
      A container invokes this method before it removes the EJB object that is currently associated with the instance.
      void ejbStore()
      A container invokes this method to instruct the instance to synchronize its state by storing it to the underlying database.
      void setEntityContext(EntityContext ctx)
      Set the associated entity context.
      void unsetEntityContext()
      Unset the associated entity context.

    • Method Detail

      • setEntityContext

        void setEntityContext(EntityContext ctx)
                      throws EJBException,
                             RemoteException
        Set the associated entity context. The container invokes this method on an instance after the instance has been created.

        This method is called in an unspecified transaction context.

        Parameters:
        ctx - An EntityContext interface for the instance. The instance should store the reference to the context in an instance variable.
        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

      • unsetEntityContext

        void unsetEntityContext()
                        throws EJBException,
                               RemoteException
        Unset the associated entity context. The container calls this method before removing the instance.

        This is the last method that the container invokes on the instance. The Java garbage collector will eventually invoke the finalize() method on the instance.

        This method is called in an unspecified transaction context.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

      • ejbRemove

        void ejbRemove()
               throws RemoveException,
                      EJBException,
                      RemoteException
        A container invokes this method before it removes the EJB object that is currently associated with the instance. This method is invoked when a client invokes a remove operation on the entity bean's home interface or the EJB object's remote interface. This method transitions the instance from the ready state to the pool of available instances.

        This method is called in the transaction context of the remove operation.

        Throws:
        RemoveException - The enterprise Bean does not allow destruction of the object.
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

      • ejbActivate

        void ejbActivate()
                 throws EJBException,
                        RemoteException
        A container invokes this method when the instance is taken out of the pool of available instances to become associated with a specific EJB object. This method transitions the instance to the ready state.

        This method executes in an unspecified transaction context.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

      • ejbPassivate

        void ejbPassivate()
                  throws EJBException,
                         RemoteException
        A container invokes this method on an instance before the instance becomes disassociated with a specific EJB object. After this method completes, the container will place the instance into the pool of available instances.

        This method executes in an unspecified transaction context.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

      • ejbLoad

        void ejbLoad()
             throws EJBException,
                    RemoteException
        A container invokes this method to instruct the instance to synchronize its state by loading it state from the underlying database.

        This method always executes in the transaction context determined by the value of the transaction attribute in the deployment descriptor.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

      • ejbStore

        void ejbStore()
              throws EJBException,
                     RemoteException
        A container invokes this method to instruct the instance to synchronize its state by storing it to the underlying database.

        This method always executes in the transaction context determined by the value of the transaction attribute in the deployment descriptor.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface EntityContext

  • All Superinterfaces:
    EJBContext

    public interface EntityContext
extends EJBContext
    The EntityContext interface provides an instance with access to the container-provided runtime context of an entity bean instance. The container passes the EntityContext interface to an entity bean instance after the instance has been created.

    The EntityContext interface remains associated with the instance for the lifetime of the instance. Note that the information that the instance obtains using the EntityContext interface (such as the result of the getPrimaryKey() method) may change, as the container assigns the instance to different EJB objects during the instance's life cycle.

    Note: Support for entity beans is optional as of EJB 3.2.

    Since:
    EJB 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EJBLocalObject getEJBLocalObject()
      Obtain a reference to the EJB local object that is currently associated with the instance.
      EJBObject getEJBObject()
      Obtain a reference to the EJB object that is currently associated with the instance.
      Object getPrimaryKey()
      Obtain the primary key of the EJB object that is currently associated with this instance.

      • Methods inherited from interface javax.ejb.EJBContext

        getCallerIdentity, getCallerPrincipal, getContextData, getEJBHome, getEJBLocalHome, getEnvironment, getRollbackOnly, getTimerService, getUserTransaction, isCallerInRole, isCallerInRole, lookup, setRollbackOnly

    • Method Detail

      • getEJBLocalObject

        EJBLocalObject getEJBLocalObject()
                                 throws IllegalStateException
        Obtain a reference to the EJB local object that is currently associated with the instance.

        An instance of an entity bean can call this method only when the instance is associated with an EJB local object identity, i.e. in the ejbActivate, ejbPassivate, ejbPostCreate, ejbRemove, ejbLoad, ejbStore, and business methods.

        An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

        Returns:
        The EJB local object currently associated with the instance.
        Throws:
        IllegalStateException - if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a local interface.
        Since:
        EJB 2.0

      • getEJBObject

        EJBObject getEJBObject()
                       throws IllegalStateException
        Obtain a reference to the EJB object that is currently associated with the instance.

        An instance of an entity bean can call this method only when the instance is associated with an EJB object identity, i.e. in the ejbActivate, ejbPassivate, ejbPostCreate, ejbRemove, ejbLoad, ejbStore, and business methods.

        An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

        Returns:
        The EJB object currently associated with the instance.
        Throws:
        IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a remote interface.

      • getPrimaryKey

        Object getPrimaryKey()
                     throws IllegalStateException
        Obtain the primary key of the EJB object that is currently associated with this instance.

        An instance of an entity bean can call this method only when the instance is associated with an EJB object identity, i.e. in the ejbActivate, ejbPassivate, ejbPostCreate, ejbRemove, ejbLoad, ejbStore, and business methods.

        Note: The result of this method is that same as the result of getEJBObject().getPrimaryKey().

        Returns:
        The primary key currently associated with the instance.
        Throws:
        IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FinderException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class FinderException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.ejb.FinderException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ObjectNotFoundException

    public class FinderException
extends Exception
    The FinderException exception must be included in the throws clause of every finder method of an entity bean's home or local home interface.

    The exception is used as a standard application-level exception to report a failure to find the requested EJB object(s).

    Note: Support for entity beans is optional as of EJB 3.2.

    Since:
    EJB 1.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      FinderException()
      Constructs an FinderException with no detail message.
      FinderException(String message)
      Constructs an FinderException with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FinderException

        public FinderException()
        Constructs an FinderException with no detail message.

      • FinderException

        public FinderException(String message)
        Constructs an FinderException with the specified detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Handle (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface Handle

  • All Superinterfaces:
    Serializable

    public interface Handle
extends Serializable
    The Handle interface is implemented by all EJB object handles. A handle is an abstraction of a network reference to an EJB object. A handle is intended to be used as a "robust" persistent reference to an EJB object.
    Since:
    EJB 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EJBObject getEJBObject()
      Obtain the EJB object reference represented by this handle.

    • Method Detail

      • getEJBObject

        EJBObject getEJBObject()
                       throws RemoteException
        Obtain the EJB object reference represented by this handle.
        Returns:
        the EJB object reference represented by this handle.
        Throws:
        RemoteException - The EJB object could not be obtained because of a system-level failure.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HomeHandle (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface HomeHandle

  • All Superinterfaces:
    Serializable

    public interface HomeHandle
extends Serializable
    The HomeHandle interface is implemented by all home object handles. A handle is an abstraction of a network reference to a home object. A handle is intended to be used as a "robust" persistent reference to a home object.
    Since:
    EJB 1.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EJBHome getEJBHome()
      Obtain the home object represented by this handle.

    • Method Detail

      • getEJBHome

        EJBHome getEJBHome()
                   throws RemoteException
        Obtain the home object represented by this handle.
        Returns:
        the home object represented by this handle.
        Throws:
        RemoteException - The home object could not be obtained because of a system-level failure.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IllegalLoopbackException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class IllegalLoopbackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.ConcurrentAccessException
              • javax.ejb.IllegalLoopbackException
  • All Implemented Interfaces:
    Serializable

    public class IllegalLoopbackException
extends ConcurrentAccessException
    This exception indicates that an attempt was made to perform an illegal loopback invocation. One possible cause is a loopback call to a singleton bean's container-managed concurrency Lock(WRITE) method where the current thread does not already hold a WRITE lock.
    Since:
    EJB 3.1
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      IllegalLoopbackException()
      IllegalLoopbackException(String message)

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • IllegalLoopbackException

        public IllegalLoopbackException()

      • IllegalLoopbackException

        public IllegalLoopbackException(String message)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Init (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Init

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface Init
    Designates a method of a session bean that corresponds to a create<METHOD> method of an adapted home or local home interface (an interface that adapts an EJB 2.1 or earlier EJBHome or EJBLocalHome client view respectively).

    The result type of such an Init method is required to be void, and its parameter types must be exactly the same as those of the referenced create<METHOD> method(s).

    An Init method is only required to be specified for stateful session beans that provide a RemoteHome or LocalHome interface.

    The name of the adapted create<METHOD> method of the home or local home interface must be specified if the adapted interface has more than one create<METHOD> method and the method signatures are not the same.

    Since:
    EJB 3.0
    See Also:
    LocalHome, RemoteHome

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String value
      The name of the corresponding create<METHOD> method of the adapted home or local home interface.

    • Element Detail

      • value

        public abstract String value
        The name of the corresponding create<METHOD> method of the adapted home or local home interface. This value is used to disambiguate the case where there are multiple create<METHOD> methods on an adapted home and/or local home interface. If there are multiple create<METHOD> methods on the adapted interface(s) and no value is specified, the create<METHOD> matching is based on signature only.

        Note that this value is not required to be specified if there is only a single create<METHOD> method even if the name of the method to which the Init annotation is applied does not match that of the create<METHOD> method.

        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.ejb (Java(TM) EE 7 Specification APIs)

javax.ejb

Interfaces

  • EJBContext
  • EJBHome
  • EJBLocalHome
  • EJBLocalObject
  • EJBMetaData
  • EJBObject
  • EnterpriseBean
  • EntityBean
  • EntityContext
  • Handle
  • HomeHandle
  • MessageDrivenBean
  • MessageDrivenContext
  • SessionBean
  • SessionContext
  • SessionSynchronization
  • TimedObject
  • Timer
  • TimerHandle
  • TimerService

Classes

  • AsyncResult
  • ScheduleExpression
  • TimerConfig

Enums

  • ConcurrencyManagementType
  • LockType
  • TransactionAttributeType
  • TransactionManagementType

Exceptions

  • AccessLocalException
  • ConcurrentAccessException
  • ConcurrentAccessTimeoutException
  • CreateException
  • DuplicateKeyException
  • EJBAccessException
  • EJBException
  • EJBTransactionRequiredException
  • EJBTransactionRolledbackException
  • FinderException
  • IllegalLoopbackException
  • NoMoreTimeoutsException
  • NoSuchEJBException
  • NoSuchEntityException
  • NoSuchObjectLocalException
  • ObjectNotFoundException
  • RemoveException
  • TransactionRequiredLocalException
  • TransactionRolledbackLocalException

Annotation Types

  • AccessTimeout
  • ActivationConfigProperty
  • AfterBegin
  • AfterCompletion
  • ApplicationException
  • Asynchronous
  • BeforeCompletion
  • ConcurrencyManagement
  • DependsOn
  • EJB
  • EJBs
  • Init
  • Local
  • LocalBean
  • LocalHome
  • Lock
  • MessageDriven
  • PostActivate
  • PrePassivate
  • Remote
  • RemoteHome
  • Remove
  • Schedule
  • Schedules
  • Singleton
  • Startup
  • Stateful
  • StatefulTimeout
  • Stateless
  • Timeout
  • TransactionAttribute
  • TransactionManagement


javax.ejb (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.ejb

Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

See: Description

  • Interface Summary
    Interface Description
    EJBContext
    The EJBContext interface provides an instance with access to the container-provided runtime context of an enterprise bean instance.
    EJBHome
    The EJBHome interface must be extended by all enterprise beans' remote home interfaces.
    EJBLocalHome
    The EJBLocalHome interface must be extended by all enterprise beans' local home interfaces.
    EJBLocalObject
    The EJBLocalObject interface must be extended by all enterprise beans' local interfaces.
    EJBMetaData
    The EJBMetaData interface allows a client to obtain the enterprise bean's meta-data information.
    EJBObject
    The EJBObject interface is extended by all enterprise beans' remote interfaces.
    EnterpriseBean
    The EnterpriseBean interface is a common superinterface for the SessionBean, EntityBean and MessageDrivenBean interfaces.
    EntityBean
    The EntityBean interface is implemented by every entity bean class.
    EntityContext
    The EntityContext interface provides an instance with access to the container-provided runtime context of an entity bean instance.
    Handle
    The Handle interface is implemented by all EJB object handles.
    HomeHandle
    The HomeHandle interface is implemented by all home object handles.
    MessageDrivenBean
    The MessageDrivenBean interface defines methods that the EJB container uses to notify a message driven bean instance of the instance's life cycle events.
    MessageDrivenContext
    The MessageDrivenContext interface provides access to the runtime message-driven context that the container provides for a message-driven bean instance.
    SessionBean
    The SessionBean interface defines methods that the EJB container uses to notify a session bean instance of the instance's life cycle events.
    SessionContext
    The SessionContext interface provides access to the runtime session context that the container provides for a session bean instance.
    SessionSynchronization
    The SessionSynchronization interface allows a stateful session bean instance to be notified by its container of transaction boundaries.
    TimedObject
    The TimedObject interface contains a callback method that is used to deliver timer expiration notifications.
    Timer
    The Timer interface contains information about a timer that was created through the EJB Timer Service.
    TimerHandle
    The TimerHandle interface allows the bean provider to obtain a serializable timer handle that may be persisted.
    TimerService
    The TimerService interface provides enterprise bean components with access to the container-provided Timer Service.
  • Class Summary
    Class Description
    AsyncResult<V>
    Wraps the result of an asynchronous method call as a Future object, preserving compatability with the business interface signature.
    ScheduleExpression
    A calendar-based timeout expression for an enterprise bean timer.
    TimerConfig
    TimerConfig is used to specify additional timer configuration settings during timer creation.
  • Enum Summary
    Enum Description
    ConcurrencyManagementType
    Used to specify the value of the ConcurrencyManagement annotation for a singleton session bean.
    LockType
    Concurrency lock type for singleton beans with container-managed concurrency.
    TransactionAttributeType
    The enum TransactionAttributeType is used with the TransactionAttribute annotation to specify whether the methods of a session bean or message driven bean are called with a valid transaction context.
    TransactionManagementType
    The enum TransactionManagementType is used with the TransactionManagement annotation to specify whether container-managed or bean-managed transaction management is used.
  • Exception Summary
    Exception Description
    AccessLocalException
    An AccessLocalException is thrown to indicate that the caller does not have permission to call the method.
    ConcurrentAccessException
    A ConcurrentAccessException indicates that the client has attempted an invocation on a stateful session bean or singleton bean while another invocation is in progress and such concurrent access is not allowed.
    ConcurrentAccessTimeoutException
    This exception indicates that an attempt to concurrently access a stateful session or singleton bean method resulted in a timeout.
    CreateException
    The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise bean's home or local home interface.
    DuplicateKeyException
    The DuplicateKeyException exception is thrown if an entity EJB object or EJB local object cannot be created because an object with the same key already exists.
    EJBAccessException
    This exception indicates that client access to a business method was denied.
    EJBException
    The EJBException is thrown to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g.
    EJBTransactionRequiredException
    This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.
    EJBTransactionRolledbackException
    This exception is thrown to a remote client to indicate that the transaction associated with processing of the request has been rolled back, or marked to roll back.
    FinderException
    The FinderException exception must be included in the throws clause of every finder method of an entity bean's home or local home interface.
    IllegalLoopbackException
    This exception indicates that an attempt was made to perform an illegal loopback invocation.
    NoMoreTimeoutsException
    This exception indicates that a calendar-based timer will not result in any more timeouts.
    NoSuchEJBException
    A NoSuchEJBException is thrown if an attempt is made to invoke a business method on a stateful session or singleton object that no longer exists.
    NoSuchEntityException
    The NoSuchEntityException exception is thrown by an entity bean instance to its container to report that the invoked business method or callback method could not be completed because of the underlying entity was removed from the database.
    NoSuchObjectLocalException
    A NoSuchObjectLocalException is thrown if an attempt is made to invoke a method on a local object (local EJB object or timer) that no longer exists.
    ObjectNotFoundException
    The ObjectNotFoundException exception is thrown by a finder or select method to indicate that the specified EJB object or local object does not exist.
    RemoveException
    The RemoveException is thrown at an attempt to remove an EJB object or local EJB object when the enterprise bean or the container does not allow the EJB object to be removed.
    TransactionRequiredLocalException
    This exception is thrown to a local client to indicate that a request carried a null transaction context, but the target object requires an active transaction.
    TransactionRolledbackLocalException
    This exception is thrown to a local client to indicate that the transaction associated with processing of the request has been rolled back, or marked to roll back.
  • Annotation Types Summary
    Annotation Type Description
    AccessTimeout
    Specifies the amount of time in a given time unit that a concurrent access attempt should block before timing out.
    ActivationConfigProperty
    Used to provide information to the deployer about the configuration of a message driven bean in its operational environment.
    AfterBegin
    Designate a stateful session bean method to receive the after begin session synchronization callback.
    AfterCompletion
    Designate a stateful session bean method to receive the after completion session synchronization callback.
    ApplicationException
    Applied to an exception to denote that it is an application exception and should be reported to the client directly (i.e., unwrapped).
    Asynchronous
    Used to mark a session bean method as an asynchronous method or to designate all business methods of a session bean class as asynchronous.
    BeforeCompletion
    Designate a stateful session bean method to receive the before completion session synchronization callback.
    ConcurrencyManagement
    Declares a singleton session bean's concurrency management type.
    DependsOn
    Used to express an initialization dependency between singleton components.
    EJB
    Indicates a dependency on the local, no-interface, or remote view of an Enterprise JavaBean.
    EJBs
    Declares multiple EJB annotations.
    Init
    Designates a method of a session bean that corresponds to a create<METHOD> method of an adapted home or local home interface (an interface that adapts an EJB 2.1 or earlier EJBHome or EJBLocalHome client view respectively).
    Local
    Declares the local business interface(s) for a session bean.
    LocalBean
    Designates that a session bean exposes a no-interface view.
    LocalHome
    Declares the local home or adapted local home interface for a session bean.
    Lock
    Declares a concurrency lock for a singleton session bean with container managed concurrency.
    MessageDriven
    Component-defining annotation for a message driven bean.
    PostActivate
    Designates a method to receive a callback after a stateful session bean has been activated.
    PrePassivate
    Designates a method to receive a callback before a stateful session bean is passivated.
    Remote
    Declares the remote business interface(s) for a session bean.
    RemoteHome
    Declares the remote home interface or adapted remote home interface for a session bean.
    Remove
    Applied to a business method of a stateful session bean class to indicate to the container that the stateful session bean is to be removed by the container after completion of the method.
    Schedule
    Schedule a timer for automatic creation with a timeout schedule based on a cron-like time expression.
    Schedules
    Applied to a timer callback method to schedule multiple calendar-based timers for the method.
    Singleton
    Component-defining annotation for a singleton session bean.
    Startup
    Mark a singleton bean for eager initialization during the application startup sequence.
    Stateful
    Component-defining annotation for a stateful session bean.
    StatefulTimeout
    Specifies the amount of time a stateful session bean can be idle (not receive any client invocations) before it is eligible for removal by the container.
    Stateless
    Component-defining annotation for a stateless session bean.
    Timeout
    Designates a method on a stateless session bean class, a singleton session bean class, a message driven bean class, or an EJB 2.x entity bean class that should receive EJB timer expirations for that bean.
    TransactionAttribute
    The TransactionAttribute annotation specifies whether the container is to invoke a business method within a transaction context.
    TransactionManagement
    Specifies whether a session bean or message driven bean has container managed transactions or bean managed transactions.

Package javax.ejb Description

Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.ejb Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.ejb

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.ejb.AsyncResult<V> (implements java.util.concurrent.Future<V>)
    • javax.ejb.ScheduleExpression (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.ejb.CreateException
          • javax.ejb.DuplicateKeyException
        • javax.ejb.FinderException
          • javax.ejb.ObjectNotFoundException
        • javax.ejb.RemoveException
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.AccessLocalException
            • javax.ejb.ConcurrentAccessException
              • javax.ejb.ConcurrentAccessTimeoutException
              • javax.ejb.IllegalLoopbackException
            • javax.ejb.EJBAccessException
            • javax.ejb.EJBTransactionRequiredException
            • javax.ejb.EJBTransactionRolledbackException
            • javax.ejb.NoMoreTimeoutsException
            • javax.ejb.NoSuchEJBException
            • javax.ejb.NoSuchEntityException
            • javax.ejb.NoSuchObjectLocalException
            • javax.ejb.TransactionRequiredLocalException
            • javax.ejb.TransactionRolledbackLocalException
    • javax.ejb.TimerConfig

Interface Hierarchy

  • javax.ejb.EJBContext
    • javax.ejb.EntityContext
    • javax.ejb.MessageDrivenContext
    • javax.ejb.SessionContext
  • javax.ejb.EJBLocalHome
  • javax.ejb.EJBLocalObject
  • javax.ejb.EJBMetaData
  • java.rmi.Remote
    • javax.ejb.EJBHome
    • javax.ejb.EJBObject
  • java.io.Serializable
    • javax.ejb.EnterpriseBean
      • javax.ejb.EntityBean
      • javax.ejb.MessageDrivenBean
      • javax.ejb.SessionBean
    • javax.ejb.Handle
    • javax.ejb.HomeHandle
    • javax.ejb.TimerHandle
  • javax.ejb.SessionSynchronization
  • javax.ejb.TimedObject
  • javax.ejb.Timer
  • javax.ejb.TimerService

Annotation Type Hierarchy

  • javax.ejb.TransactionManagement (implements java.lang.annotation.Annotation)
  • javax.ejb.TransactionAttribute (implements java.lang.annotation.Annotation)
  • javax.ejb.Timeout (implements java.lang.annotation.Annotation)
  • javax.ejb.Stateless (implements java.lang.annotation.Annotation)
  • javax.ejb.StatefulTimeout (implements java.lang.annotation.Annotation)
  • javax.ejb.Stateful (implements java.lang.annotation.Annotation)
  • javax.ejb.Startup (implements java.lang.annotation.Annotation)
  • javax.ejb.Singleton (implements java.lang.annotation.Annotation)
  • javax.ejb.Schedules (implements java.lang.annotation.Annotation)
  • javax.ejb.Schedule (implements java.lang.annotation.Annotation)
  • javax.ejb.Remove (implements java.lang.annotation.Annotation)
  • javax.ejb.RemoteHome (implements java.lang.annotation.Annotation)
  • javax.ejb.Remote (implements java.lang.annotation.Annotation)
  • javax.ejb.PrePassivate (implements java.lang.annotation.Annotation)
  • javax.ejb.PostActivate (implements java.lang.annotation.Annotation)
  • javax.ejb.MessageDriven (implements java.lang.annotation.Annotation)
  • javax.ejb.Lock (implements java.lang.annotation.Annotation)
  • javax.ejb.LocalHome (implements java.lang.annotation.Annotation)
  • javax.ejb.LocalBean (implements java.lang.annotation.Annotation)
  • javax.ejb.Local (implements java.lang.annotation.Annotation)
  • javax.ejb.Init (implements java.lang.annotation.Annotation)
  • javax.ejb.EJBs (implements java.lang.annotation.Annotation)
  • javax.ejb.EJB (implements java.lang.annotation.Annotation)
  • javax.ejb.DependsOn (implements java.lang.annotation.Annotation)
  • javax.ejb.ConcurrencyManagement (implements java.lang.annotation.Annotation)
  • javax.ejb.BeforeCompletion (implements java.lang.annotation.Annotation)
  • javax.ejb.Asynchronous (implements java.lang.annotation.Annotation)
  • javax.ejb.ApplicationException (implements java.lang.annotation.Annotation)
  • javax.ejb.AfterCompletion (implements java.lang.annotation.Annotation)
  • javax.ejb.AfterBegin (implements java.lang.annotation.Annotation)
  • javax.ejb.ActivationConfigProperty (implements java.lang.annotation.Annotation)
  • javax.ejb.AccessTimeout (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.ejb.TransactionManagementType
      • javax.ejb.TransactionAttributeType
      • javax.ejb.LockType
      • javax.ejb.ConcurrencyManagementType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Local (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Local

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Local
    Declares the local business interface(s) for a session bean.

    The Local annotation is applied to the session bean class or local business interface to designate a local interface of the bean.

    When used on the bean class, declares the local business interface(s) for a session bean. When used on an interface, designates that interface as a local business interface. In this case, no value element should be provided.

    The Local annotation applies only to session beans and their interfaces.

    Use of the Local annotation is required when the bean class exposes one or more local business interface and any of the following is true:

    • the bean class does not implement its business interfaces
    • the bean exposes a no-interface view
    • the bean class implements more than one interface and at least one of the interfaces is explicitly designated as a business interface by using the Local or Remote annotation on the interface, or in the deployment descriptor

    The following interfaces are excluded when determining whether the bean class has business interfaces: java.io.Serializable; java.io.Externalizable; any of the interfaces defined in javax.ejb.

    Since:
    EJB 3.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class[] value
      Specifies the local business interface(s) of the bean.

    • Element Detail

      • value

        public abstract Class[] value
        Specifies the local business interface(s) of the bean. The value element is specified only when the annotation is applied to the bean class. It is only required to be specified if any of the following is true:
        • the bean class does not implement its local business interface
        • at least one of the implemented interfaces is designated as a remote interface
        • the bean class implements two or more interfaces and at least one of the implemented interfaces is designated as local business interfaces using Local annotation on the interface, and at least one other interface (excluding java.io.Serializable, java.io.Externalizable, and any of the interfaces defined by the javax.ejb package) has no designation.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


LocalBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type LocalBean

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface LocalBean
    Designates that a session bean exposes a no-interface view.

    This annotation is required if a session bean exposes any other client views (local, remote, no-interface, 2.x Remote Home, 2.x Local Home, Web Service) in addition to the no-interface view or its implements clause contains an interface other than java.io.Serializable; java.io.Externalizable; or any of the interfaces defined by the javax.ejb package.

    This annotation is optional if a session bean exposes only a no-interface view.

    Since:
    EJB 3.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


LocalHome (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type LocalHome

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface LocalHome
    Declares the local home or adapted local home interface for a session bean.

    Clients written to the EJB 2.1 and earlier client view depend upon the existence of a home and component interface. A session bean written to the EJB 3.x API may be adapted to such earlier preexisting client view interfaces.

    The session bean designates the local home interface to be adapted by using the LocalHome annotation on the bean class. The corresponding local component interface need not be explicitly specified, as it is derived from the return type of local home interface's create method signature.

    Session beans written to the EJB 3.0 and later APIs do not otherwise make use of local home interfaces.

    Since:
    EJB 3.0
    See Also:
    Init, RemoteHome

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class value
      The local home interface.

    • Element Detail

      • value

        public abstract Class value
        The local home interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Lock (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Lock

  • @Target(value={TYPE,METHOD})
@Retention(value=RUNTIME)
public @interface Lock
    Declares a concurrency lock for a singleton session bean with container managed concurrency.

    This annotation may be specified on the bean class, the business methods of the bean class or both. Specifying the annotation on a business method overrides the value specified at class level, if any.

    If this annotation is not used, a value of Lock(WRITE) is assumed.

    Since:
    EJB 3.1

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      LockType value

    • Element Detail

      • value

        public abstract LockType value
        Default:
        javax.ejb.LockType.WRITE
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


LockType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.ejb

Enum LockType

  • java.lang.Object
    • java.lang.Enum<LockType>
      • javax.ejb.LockType
  • All Implemented Interfaces:
    Serializable, Comparable<LockType>

    public enum LockType
extends Enum<LockType>
    Concurrency lock type for singleton beans with container-managed concurrency.
    Since:
    EJB 3.1

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      READ
      For read-only operations.
      WRITE
      For exclusive access to the bean instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static LockType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static LockType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • READ

        public static final LockType READ
        For read-only operations. Allows simultaneous access to methods designated as READ, as long as no WRITE lock is held.

      • WRITE

        public static final LockType WRITE
        For exclusive access to the bean instance. A WRITE lock can only be acquired when no other method with either a READ or WRITE lock is currently held.

    • Method Detail

      • values

        public static LockType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (LockType c : LockType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static LockType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


MessageDriven (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type MessageDriven

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface MessageDriven
    Component-defining annotation for a message driven bean.

    The message driven bean must implement the appropriate message listener interface for the messaging type that the message-driven bean supports or specify the message listener interface using the messageListenerInterface element of this annotation.

    Since:
    EJB 3.0
    See Also:
    ActivationConfigProperty

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      ActivationConfigProperty[] activationConfig
      Activation config properties.
      String description
      A string describing the message driven bean.
      String mappedName
      A product specific name(e.g.
      Class messageListenerInterface
      Message-listener interface.
      String name
      The ejb-name for this bean.

    • Element Detail

      • name

        public abstract String name
        The ejb-name for this bean. Defaults to the unqualified name of the message driven bean class.
        Default:
        ""

      • messageListenerInterface

        public abstract Class messageListenerInterface
        Message-listener interface. If the message-driven bean class implements more than one interface other than java.io.Serializable, java.io.Externalizable, or any of the interfaces defined by the javax.ejb package, the message listener interface must be specified.
        Default:
        java.lang.Object.class

      • activationConfig

        public abstract ActivationConfigProperty[] activationConfig
        Activation config properties.
        Default:
        {}

      • mappedName

        public abstract String mappedName
        A product specific name(e.g. global JNDI name of a queue) that this message-driven bean should be mapped to. Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.
        Default:
        ""

      • description

        public abstract String description
        A string describing the message driven bean.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MessageDrivenBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface MessageDrivenBean

  • All Superinterfaces:
    EnterpriseBean, Serializable

    public interface MessageDrivenBean
extends EnterpriseBean
    The MessageDrivenBean interface defines methods that the EJB container uses to notify a message driven bean instance of the instance's life cycle events.

    As of EJB 3.0 it is no longer required that a message driven bean class implement this interface.

    Since:
    EJB 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void ejbRemove()
      A container invokes this method before it ends the life of the message-driven object.
      void setMessageDrivenContext(MessageDrivenContext ctx)
      Set the associated message-driven context.

    • Method Detail

      • setMessageDrivenContext

        void setMessageDrivenContext(MessageDrivenContext ctx)
                             throws EJBException
        Set the associated message-driven context. The container calls this method after the instance creation.

        The message driven bean instance should store the reference to the context object in an instance variable.

        This method is called with no transaction context.

        Parameters:
        ctx - A MessageDrivenContext interface for the instance.
        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.

      • ejbRemove

        void ejbRemove()
               throws EJBException
        A container invokes this method before it ends the life of the message-driven object. This happens when a container decides to terminate the message-driven object.

        This method is called with no transaction context.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageDrivenContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface MessageDrivenContext

  • All Superinterfaces:
    EJBContext

    public interface MessageDrivenContext
extends EJBContext
    The MessageDrivenContext interface provides access to the runtime message-driven context that the container provides for a message-driven bean instance. The container passes the MessageDrivenContext interface to an instance after the instance has been created. The message-driven context remains associated with the instance for the lifetime of the instance.
    Since:
    EJB 2.0

    • Method Summary

      • Methods inherited from interface javax.ejb.EJBContext

        getCallerIdentity, getCallerPrincipal, getContextData, getEJBHome, getEJBLocalHome, getEnvironment, getRollbackOnly, getTimerService, getUserTransaction, isCallerInRole, isCallerInRole, lookup, setRollbackOnly
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoMoreTimeoutsException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class NoMoreTimeoutsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.NoMoreTimeoutsException
  • All Implemented Interfaces:
    Serializable

    public class NoMoreTimeoutsException
extends EJBException
    This exception indicates that a calendar-based timer will not result in any more timeouts.
    Since:
    EJB 3.1
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoMoreTimeoutsException()
      NoMoreTimeoutsException(String message)

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoMoreTimeoutsException

        public NoMoreTimeoutsException()

      • NoMoreTimeoutsException

        public NoMoreTimeoutsException(String message)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoSuchEJBException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class NoSuchEJBException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.NoSuchEJBException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchEJBException
extends EJBException
    A NoSuchEJBException is thrown if an attempt is made to invoke a business method on a stateful session or singleton object that no longer exists.
    Since:
    EJB 3.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoSuchEJBException()
      Constructs a NoSuchEJBException with no detail message.
      NoSuchEJBException(String message)
      Constructs a NoSuchEJBException with the specified detail message.
      NoSuchEJBException(String message, Exception ex)
      Constructs a NoSuchEJBException with the specified detail message and a nested exception.

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoSuchEJBException

        public NoSuchEJBException()
        Constructs a NoSuchEJBException with no detail message.

      • NoSuchEJBException

        public NoSuchEJBException(String message)
        Constructs a NoSuchEJBException with the specified detail message.

      • NoSuchEJBException

        public NoSuchEJBException(String message,
                  Exception ex)
        Constructs a NoSuchEJBException with the specified detail message and a nested exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoSuchEntityException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class NoSuchEntityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.NoSuchEntityException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchEntityException
extends EJBException
    The NoSuchEntityException exception is thrown by an entity bean instance to its container to report that the invoked business method or callback method could not be completed because of the underlying entity was removed from the database.

    This exception may be thrown by the bean class methods that implement the business methods defined in the bean's component interface and by the ejbLoad and ejbStore methods.

    Note: Support for entity beans is optional as of EJB 3.2.

    Since:
    EJB 1.1
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoSuchEntityException()
      Constructs a NoSuchEntityException with no detail message.
      NoSuchEntityException(Exception ex)
      Constructs a NoSuchEntityException that embeds the originally thrown exception.
      NoSuchEntityException(String message)
      Constructs a NoSuchEntityException with the specified detailed message.

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoSuchEntityException

        public NoSuchEntityException()
        Constructs a NoSuchEntityException with no detail message.

      • NoSuchEntityException

        public NoSuchEntityException(String message)
        Constructs a NoSuchEntityException with the specified detailed message.

      • NoSuchEntityException

        public NoSuchEntityException(Exception ex)
        Constructs a NoSuchEntityException that embeds the originally thrown exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoSuchObjectLocalException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class NoSuchObjectLocalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.NoSuchObjectLocalException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchObjectLocalException
extends EJBException
    A NoSuchObjectLocalException is thrown if an attempt is made to invoke a method on a local object (local EJB object or timer) that no longer exists.
    Since:
    EJB 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoSuchObjectLocalException()
      Constructs a NoSuchObjectLocalException with no detail message.
      NoSuchObjectLocalException(String message)
      Constructs a NoSuchObjectLocalException with the specified detail message.
      NoSuchObjectLocalException(String message, Exception ex)
      Constructs a NoSuchObjectLocalException with the specified detail message and a nested exception.

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoSuchObjectLocalException

        public NoSuchObjectLocalException()
        Constructs a NoSuchObjectLocalException with no detail message.

      • NoSuchObjectLocalException

        public NoSuchObjectLocalException(String message)
        Constructs a NoSuchObjectLocalException with the specified detail message.

      • NoSuchObjectLocalException

        public NoSuchObjectLocalException(String message,
                          Exception ex)
        Constructs a NoSuchObjectLocalException with the specified detail message and a nested exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectNotFoundException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class ObjectNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.ejb.FinderException
          • javax.ejb.ObjectNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class ObjectNotFoundException
extends FinderException
    The ObjectNotFoundException exception is thrown by a finder or select method to indicate that the specified EJB object or local object does not exist.

    Only the finder and select methods that are declared to return a single object use this exception. This exception should not be thrown by finder or select methods that return a collection of objects (they should return an empty collection instead).

    Since:
    EJB 1.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectNotFoundException()
      Constructs an ObjectNotFoundException with no detail message.
      ObjectNotFoundException(String message)
      Constructs an ObjectNotFoundException with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ObjectNotFoundException

        public ObjectNotFoundException()
        Constructs an ObjectNotFoundException with no detail message.

      • ObjectNotFoundException

        public ObjectNotFoundException(String message)
        Constructs an ObjectNotFoundException with the specified detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PostActivate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type PostActivate

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PostActivate
    Designates a method to receive a callback after a stateful session bean has been activated.

    If the method to which this annotation is applied is defined on an interceptor class, it must have one of the following signatures:

     void <METHOD>(InvocationContext)

 Object <METHOD>(InvocationContext) throws Exception

    If the method to which this annotation is applied is defined on a target class, it must have the following signature:

     void <METHOD>()
    The method can have public, private, protected, or package level access. It must not be declared as final or static.
    Since:
    EJB 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PrePassivate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type PrePassivate

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PrePassivate
    Designates a method to receive a callback before a stateful session bean is passivated.

    If the method to which this annotation is applied is defined on an interceptor class, it must have one of the following signatures:

     void <METHOD>(InvocationContext)

 Object <METHOD>(InvocationContext) throws Exception

    If the method to which this annotation is applied is defined on a target class, it must have the following signature:

     void <METHOD>()
    The method can have public, private, protected, or package level access. It must not be declared as final or static.
    Since:
    EJB 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Remote (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Remote

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Remote
    Declares the remote business interface(s) for a session bean.

    The Remote annotation is applied to the session bean class or remote business interface to designate a remote business interface of the bean.

    When used on an interface, designates that interface as a remote business interface. In this case, no value element should be provided.

    The Remote annotation applies only to session beans and their interfaces.

    Since:
    EJB 3.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class[] value
      Specifies the remote business interface(s) of the bean.

    • Element Detail

      • value

        public abstract Class[] value
        Specifies the remote business interface(s) of the bean. The value element is specified only when the annotation is applied to the bean class. It is only required to be specified if any of the following is true:
        • the bean class does not implement its remote business interface
        • at least one of the implemented interfaces is designated as a local interface
        • the bean class implements two or more interfaces and at least one of the implemented interfaces is designated as a remote business interface using Remote annotation on the interface, and at least one other interface (excluding java.io.Serializable, java.io.Externalizable, and any of the interfaces defined by the javax.ejb package) has no designation.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


RemoteHome (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type RemoteHome

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface RemoteHome
    Declares the remote home interface or adapted remote home interface for a session bean. The value is never a 2.x remote component interface.

    Clients written to the EJB 2.1 and earlier client view depend upon the existence of a home and component interface. A session bean written to the EJB 3.x API may be adapted to such earlier preexisting client view interfaces.

    The session bean designates the home interface to be adapted by using the RemoteHome annotation on the bean class. The corresponding remote component interface need not be explicitly specified, as it is derived from the return type of remote home interface's create method signature.

    Session beans written to the EJB 3.0 and later APIs do not otherwise make use of remote home interfaces.

    Since:
    EJB 3.0
    See Also:
    Init, LocalHome

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class value
      The remote home interface

    • Element Detail

      • value

        public abstract Class value
        The remote home interface
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Remove (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Remove

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface Remove
    Applied to a business method of a stateful session bean class to indicate to the container that the stateful session bean is to be removed by the container after completion of the method.
    Since:
    EJB 3.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean retainIfException
      If true, the stateful session bean will not be removed if an exception is thrown from the designated method.

    • Element Detail

      • retainIfException

        public abstract boolean retainIfException
        If true, the stateful session bean will not be removed if an exception is thrown from the designated method.
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


RemoveException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class RemoveException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.ejb.RemoveException
  • All Implemented Interfaces:
    Serializable

    public class RemoveException
extends Exception
    The RemoveException is thrown at an attempt to remove an EJB object or local EJB object when the enterprise bean or the container does not allow the EJB object to be removed.
    Since:
    EJB 1.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      RemoveException()
      Constructs an RemoveException with no detail message.
      RemoveException(String message)
      Constructs an RemoveException with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • RemoveException

        public RemoveException()
        Constructs an RemoveException with no detail message.

      • RemoveException

        public RemoveException(String message)
        Constructs an RemoveException with the specified detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Schedule (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Schedule

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface Schedule
    Schedule a timer for automatic creation with a timeout schedule based on a cron-like time expression. The annotated method is used as the timeout callback method.

    All elements of this annotation are optional. If none are specified a persistent timer will be created with callbacks occuring every day at midnight in the default time zone associated with the container in which the application is executing.

    There are seven elements that constitute a schedule specification which are listed below. In addition, the timezone element may be used to specify a non-default time zone in whose context the schedule specification is to be evaluated; the persistent element may be used to specify a non-persistent timer, and the info element may be used to specify additional information that may be retrieved when the timer callback occurs.

    The elements that specify the calendar-based schedule itself are as follows:

    • second : one or more seconds within a minute

      Allowable values: [0,59]

    • minute : one or more minutes within an hour

      Allowable values : [0,59]

    • hour : one or more hours within a day

      Allowable values : [0,23]

    • dayOfMonth : one or more days within a month

      Allowable values:

      • [1,31]
      • [-7, -1]
      • "Last"
      • {"1st", "2nd", "3rd", "4th", "5th", "Last"} {"Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"}

      "Last" means the last day of the month

      -x (where x is in the range [-7, -1]) means x day(s) before the last day of the month

      "1st","2nd", etc. applied to a day of the week identifies a single occurrence of that day within the month.

    • month : one or more months within a year

      Allowable values :

      • [1,12]
      • {"Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov", Dec"}

    • dayOfWeek : one or more days within a week

      Allowable values :

      • [0,7]
      • {"Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"}

      "0" and "7" both refer to Sunday

    • year : a particular calendar year

      Allowable values : a four-digit calendar year

    Each element supports values expressed in one of the following forms

    • Single Value. This constrains the attribute to only one of its possible values.

 Example: second = "10"
 Example: month = "Sep"

    • Wild Card. "*" represents all allowable values for a given attribute.
       Example: second = "*"
 Example: dayOfWeek = "*"
    • List. This constrains the attribute to two or more allowable values or ranges, with a comma used as a separator character within the string. Each item in the list must be a single value or range. List items cannot be lists, wild cards, or increments. Duplicate values are ignored.
       Example: second = "10,20,30"
 Example: dayOfWeek = "Mon,Wed,Fri"
 Example: minute = "0-10,30,40"
    • Range. This constrains the attribute to an inclusive range of values, with a dash separating both ends of the range. Each side of the range must be a single attribute value. Members of a range cannot be lists, wild cards, ranges, or increments. If x is larger than y in a range "x-y", the range is equivalent to "x-max, min-y", where max is the largest value of the corresponding attribute and min is the smallest. The range "x-x", where both range values are the same, evaluates to the single value x. The day of the week range "0-7" is equivalent to "*".

       Example: second = "1-10"
 Example: dayOfWeek = "Fri-Mon"
 Example: dayOfMonth = "27-3" (Equivalent to "27-Last , 1-3")
    • Increments. The forward slash constrains an attribute based on a starting point and an interval, and is used to specify every N seconds, minutes, or hours within the minute, hour, or day, respectively. For the expression x/y, the attribute is constrained to every yth value within the set of allowable values beginning at time x. The x value is inclusive. The wild card character (*) can be used in the x position, and is equivalent to 0. The use of increments is only supported within the second, minute, and hour elements. For the second and minute elements, x and y must each be in the range [0,59]. For the hour element, x and y must each be in the range [0,23].

       Example: minute = "∗/5" (Every five minutes within the hour)
      This is equivalent to: minute = "0,5,10,15,20,25,30,35,40,45,50,55"

       Example: second = "30/10" (Every 10 seconds within the minute, starting at second 30)
      This is equivalent to: second = "30,40,50"

      Note that the set of matching increment values stops once the maximum value for that attribute is exceeded. It does not "roll over" past the boundary.

       Example : ( minute = "∗/14", hour="1,2")

      This is equivalent to: (minute = "0,14,28,42,56", hour = "1,2") (Every 14 minutes within the hour, for the hours of 1 and 2 a.m.)

    The following additional rules apply to the schedule specification elements:

    • If the dayOfMonth element has a non-wildcard value and the dayOfWeek element has a non-wildcard value, then any day matching either the dayOfMonth value or the dayOfWeek value will be considered to apply.
    • Whitespace is ignored, except for string constants and numeric values.
    • All string constants (e.g., "Sun", "Jan", "1st", etc.) are case insensitive.

    Schedule-based timer times are evaluated in the context of the default time zone associated with the container in which the application is executing. A schedule-based timer may optionally override this default and associate itself with a specific time zone. If the schedule-based timer is associated with a specific time zone, all its times are evaluated in the context of that time zone, regardless of the default time zone in which the container is executing.

    The timeout callback method to which the Schedule annotation is applied must have one of the following signatures, where <METHOD> designates the method name:

     void <METHOD>()
 void <METHOD>(Timer timer)
    A timeout callback method can have public, private, protected, or package level access. A timeout callback method must not be declared as final or static. Timeout callback methods must not throw application exceptions.
    Since:
    EJB 3.1

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String dayOfMonth
      Specifies one or more days within a month.
      String dayOfWeek
      Specifies one or more days within a week.
      String hour
      Specifies one or more hours within a day.
      String info
      Specifies an information string that is associated with the timer
      String minute
      Specifies one or more minutes with an hour.
      String month
      Specifies one or more months within a year.
      boolean persistent
      Specifies whether the timer that is created is persistent.
      String second
      Specifies one or more seconds with in a minute.
      String timezone
      Specifies the time zone within which the schedule is evaluated.
      String year
      Specifies one or more years.

    • Element Detail

      • second

        public abstract String second
        Specifies one or more seconds with in a minute.
        Default:
        "0"

      • minute

        public abstract String minute
        Specifies one or more minutes with an hour.
        Default:
        "0"

      • hour

        public abstract String hour
        Specifies one or more hours within a day.
        Default:
        "0"

      • dayOfMonth

        public abstract String dayOfMonth
        Specifies one or more days within a month.
        Default:
        "*"

      • month

        public abstract String month
        Specifies one or more months within a year.
        Default:
        "*"

      • dayOfWeek

        public abstract String dayOfWeek
        Specifies one or more days within a week.
        Default:
        "*"

      • year

        public abstract String year
        Specifies one or more years.
        Default:
        "*"

      • timezone

        public abstract String timezone
        Specifies the time zone within which the schedule is evaluated. Time zones are specified as an ID string. The set of required time zone IDs is defined by the Zone Name(TZ) column of the public domain zoneinfo database.

        If a timezone is not specified, the schedule is evaluated in the context of the default timezone associated with the contianer in which the application is executing.

        Default:
        ""

      • info

        public abstract String info
        Specifies an information string that is associated with the timer
        Default:
        ""

      • persistent

        public abstract boolean persistent
        Specifies whether the timer that is created is persistent.
        Default:
        true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ScheduleExpression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class ScheduleExpression

  • java.lang.Object
    • javax.ejb.ScheduleExpression
  • All Implemented Interfaces:
    Serializable

    public class ScheduleExpression
extends Object
implements Serializable

    A calendar-based timeout expression for an enterprise bean timer.

    Each attribute used to define a calendar-based timeout schedule has two overloaded setter methods, one that takes a String and one that takes an int. The int version is merely a convenience method for setting the attribute in the common case that the value is a simple integer value.

    For example,

    scheduleExpression.second(10)
    is semantically equivalent to
    scheduleExpression.second("10")

    There are seven attributes that constitute a schedule specification which are listed below. In addition, the timezone attribute may be used to specify a non-default time zone in whose context the schedule specification is to be evaluated.

    The attributes that specify the calendar-based schedule itself are as follows:

    • second : one or more seconds within a minute

      Allowable values: [0,59]

    • minute : one or more minutes within an hour

      Allowable values : [0,59]

    • hour : one or more hours within a day

      Allowable values : [0,23]

    • dayOfMonth : one or more days within a month

      Allowable values:

      • [1,31]
      • [-7, -1]
      • "Last"
      • {"1st", "2nd", "3rd", "4th", "5th", "Last"} {"Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"}

      "Last" means the last day of the month

      -x (where x is in the range [-7, -1]) means x day(s) before the last day of the month

      "1st","2nd", etc. applied to a day of the week identifies a single occurrence of that day within the month.

    • month : one or more months within a year

      Allowable values :

      • [1,12]
      • {"Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov", Dec"}

    • dayOfWeek : one or more days within a week

      Allowable values :

      • [0,7]
      • {"Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"}

      "0" and "7" both refer to Sunday

    • year : a particular calendar year

      Allowable values : a four-digit calendar year

    Each attribute supports values expressed in one of the following forms

    • Single Value. This constrains the attribute to only one of its possible values.

 Example: second = "10"
 Example: month = "Sep"

    • Wild Card. "*" represents all allowable values for a given attribute.
       Example: second = "*"
 Example: dayOfWeek = "*"
    • List. This constrains the attribute to two or more allowable values or ranges, with a comma used as a separator character within the string. Each item in the list must be a single value or range. List items cannot be lists, wild cards, or increments. Duplicate values are ignored.
       Example: second = "10,20,30"
 Example: dayOfWeek = "Mon,Wed,Fri"
 Example: minute = "0-10,30,40"
    • Range. This constrains the attribute to an inclusive range of values, with a dash separating both ends of the range. Each side of the range must be a single attribute value. Members of a range cannot be lists, wild cards, ranges, or increments. If x is larger than y in a range "x-y", the range is equivalent to "x-max, min-y", where max is the largest value of the corresponding attribute and min is the smallest. The range "x-x", where both range values are the same, evaluates to the single value x. The day of the week range "0-7" is equivalent to "*".

       Example: second = "1-10"
 Example: dayOfWeek = "Fri-Mon"
 Example: dayOfMonth = "27-3" (Equivalent to "27-Last , 1-3")
    • Increments. The forward slash constrains an attribute based on a starting point and an interval, and is used to specify every N seconds, minutes, or hours within the minute, hour, or day, respectively. For the expression x/y, the attribute is constrained to every yth value within the set of allowable values beginning at time x. The x value is inclusive. The wild card character (*) can be used in the x position, and is equivalent to 0. The use of increments is only supported within the second, minute, and hour attributes. For the second and minute attributes, x and y must each be in the range [0,59]. For the hour attribute, x and y must each be in the range [0,23].

       Example: minute = "∗/5" (Every five minutes within the hour)
      This is equivalent to: minute = "0,5,10,15,20,25,30,35,40,45,50,55"

       Example: second = "30/10" (Every 10 seconds within the minute, starting at second 30)
      This is equivalent to: second = "30,40,50"

      Note that the set of matching increment values stops once the maximum value for that attribute is exceeded. It does not "roll over" past the boundary.

       Example : ( minute = "∗/14", hour="1,2")

      This is equivalent to: (minute = "0,14,28,42,56", hour = "1,2") (Every 14 minutes within the hour, for the hours of 1 and 2 a.m.)

    The following additional rules apply to the schedule specification attributes:

    • If the dayOfMonth attribute has a non-wildcard value and the dayOfWeek attribute has a non-wildcard value, then any day matching either the dayOfMonth value or the dayOfWeek value will be considered to apply.
    • Whitespace is ignored, except for string constants and numeric values.
    • All string constants (e.g., "Sun", "Jan", "1st", etc.) are case insensitive.

    Schedule-based timer times are evaluated in the context of the default time zone associated with the container in which the application is executing. A schedule-based timer may optionally override this default and associate itself with a specific time zone. If the schedule-based timer is associated with a specific time zone, all its times are evaluated in the context of that time zone, regardless of the default time zone in which the container is executing.

    None of the ScheduleExpression methods are required to be called. The defaults are :

    • second: "0"
    • minute: "0"
    • hour: "0"
    • dayOfMonth: "*"
    • month: "*"
    • dayOfWeek: "*"
    • year: "*"
    • timezone : default JVM time zone
    • start : upon timer creation
    • end : no end date

    Applications must not rely on the getter methods that return the attributes of a calendar-based timeout schedule to return them in the same syntactic format in which they were passed in to a ScheduleExpression method or supplied to the Schedule annotation, and portable implementations must not assume any particular syntactic format. Implementations are required only to preserve semantic equivalence.

    Since:
    EJB 3.1
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ScheduleExpression()
      Create a schedule with the default values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ScheduleExpression dayOfMonth(int d)
      Set the day of the month attribute.
      ScheduleExpression dayOfMonth(String d)
      Set the day of the month attribute.
      ScheduleExpression dayOfWeek(int d)
      Set the day of the week attribute.
      ScheduleExpression dayOfWeek(String d)
      Set the day of the week attribute.
      ScheduleExpression end(Date e)
      Set the end date.
      String getDayOfMonth()
      Return the value of the day of the month attribute.
      String getDayOfWeek()
      Return the value of the day of the week attribute.
      Date getEnd()
      Return the end date, if set; otherwise null.
      String getHour()
      Return the value of the hour attribute.
      String getMinute()
      Return the value of the minute attribute.
      String getMonth()
      Return the value of the month attribute.
      String getSecond()
      Return the value of the second attribute.
      Date getStart()
      Return the start date, if set; otherwise null.
      String getTimezone()
      Return the timezone, if set; otherwise null.
      String getYear()
      Return the value of the year attribute.
      ScheduleExpression hour(int h)
      Set the hour attribute.
      ScheduleExpression hour(String h)
      Set the hour attribute.
      ScheduleExpression minute(int m)
      Set the minute attribute.
      ScheduleExpression minute(String m)
      Set the minute attribute.
      ScheduleExpression month(int m)
      Set the month attribute.
      ScheduleExpression month(String m)
      Set the month attribute.
      ScheduleExpression second(int s)
      Set the second attribute.
      ScheduleExpression second(String s)
      Set the second attribute.
      ScheduleExpression start(Date s)
      Set the start date.
      ScheduleExpression timezone(String timezoneID)
      Set the timezone.
      String toString()
      ScheduleExpression year(int y)
      Set the year attribute.
      ScheduleExpression year(String y)
      Set the year attribute.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ScheduleExpression

        public ScheduleExpression()
        Create a schedule with the default values.

    • Method Detail

      • second

        public ScheduleExpression second(String s)
        Set the second attribute.
        Parameters:
        s - the attribute value as a String

      • second

        public ScheduleExpression second(int s)
        Set the second attribute.
        Parameters:
        s - the attribute value as an int, if the value is a simple integer value

      • getSecond

        public String getSecond()
        Return the value of the second attribute.
        Returns:
        second

      • minute

        public ScheduleExpression minute(String m)
        Set the minute attribute.
        Parameters:
        m - the attribute value as a String

      • minute

        public ScheduleExpression minute(int m)
        Set the minute attribute.
        Parameters:
        m - the attribute value as an int, if the value is a simple integer value

      • getMinute

        public String getMinute()
        Return the value of the minute attribute.
        Returns:
        minute

      • hour

        public ScheduleExpression hour(String h)
        Set the hour attribute.
        Parameters:
        h - the attribute value as a String

      • hour

        public ScheduleExpression hour(int h)
        Set the hour attribute.
        Parameters:
        h - the attribute value as an int, if the value is a simple integer value

      • getHour

        public String getHour()
        Return the value of the hour attribute.
        Returns:
        hour

      • dayOfMonth

        public ScheduleExpression dayOfMonth(String d)
        Set the day of the month attribute.
        Parameters:
        d - the attribute value as a String

      • dayOfMonth

        public ScheduleExpression dayOfMonth(int d)
        Set the day of the month attribute.
        Parameters:
        d - the attribute value as an int, if the value is a simple integer value

      • getDayOfMonth

        public String getDayOfMonth()
        Return the value of the day of the month attribute.
        Returns:
        day of the month

      • month

        public ScheduleExpression month(String m)
        Set the month attribute.
        Parameters:
        m - the attribute value as a String

      • month

        public ScheduleExpression month(int m)
        Set the month attribute.
        Parameters:
        m - the attribute value as an int, if the value is a simple integer value

      • getMonth

        public String getMonth()
        Return the value of the month attribute.
        Returns:
        month

      • dayOfWeek

        public ScheduleExpression dayOfWeek(String d)
        Set the day of the week attribute.
        Parameters:
        d - the attribute value as a String

      • dayOfWeek

        public ScheduleExpression dayOfWeek(int d)
        Set the day of the week attribute.
        Parameters:
        d - the attribute value as an int, if the value is a simple integer value

      • getDayOfWeek

        public String getDayOfWeek()
        Return the value of the day of the week attribute.
        Returns:
        day of the week

      • year

        public ScheduleExpression year(String y)
        Set the year attribute.
        Parameters:
        y - the attribute value as a String

      • year

        public ScheduleExpression year(int y)
        Set the year attribute.
        Parameters:
        y - the attribute value as an int, if the value is a simple integer value

      • getYear

        public String getYear()
        Return the value of the year attribute.
        Returns:
        year

      • timezone

        public ScheduleExpression timezone(String timezoneID)
        Set the timezone.
        Parameters:
        timezoneID - the Time zone specified as an ID String

      • getTimezone

        public String getTimezone()
        Return the timezone, if set; otherwise null.
        Returns:
        timezone

      • start

        public ScheduleExpression start(Date s)
        Set the start date.
        Parameters:
        s - the start date

      • getStart

        public Date getStart()
        Return the start date, if set; otherwise null.
        Returns:
        start date

      • end

        public ScheduleExpression end(Date e)
        Set the end date.
        Parameters:
        e - the end date

      • getEnd

        public Date getEnd()
        Return the end date, if set; otherwise null.
        Returns:
        end date

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Schedules (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Schedules

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface Schedules
    Applied to a timer callback method to schedule multiple calendar-based timers for the method. The method to which the Schedules annotation is applied must have one of the following signatures, where <METHOD> designates the method name:

     void <METHOD>()
 void <METHOD>(Timer timer)
    Since:
    EJB 3.1
    See Also:
    Schedule

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Schedule[] value
      One or more calendar-based timer specifications.

    • Element Detail

      • value

        public abstract Schedule[] value
        One or more calendar-based timer specifications.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


SessionBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface SessionBean

  • All Superinterfaces:
    EnterpriseBean, Serializable

    public interface SessionBean
extends EnterpriseBean
    The SessionBean interface defines methods that the EJB container uses to notify a session bean instance of the instance's life cycle events.

    As of EJB 3.0 it is no longer required that a session bean class implement this interface.

    Since:
    EJB 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void ejbActivate()
      The activate method is called when a stateful session bean instance is activated from its "passive" state.
      void ejbPassivate()
      The passivate method is called before a stateful session bean instance enters the "passive" state.
      void ejbRemove()
      A container invokes this method before it ends the life of the session object.
      void setSessionContext(SessionContext ctx)
      Set the associated session context.

    • Method Detail

      • setSessionContext

        void setSessionContext(SessionContext ctx)
                       throws EJBException,
                              RemoteException
        Set the associated session context. The container calls this method after the instance creation.

        The session bean instance should store the reference to the context object in an instance variable.

        This method is called with no transaction context.

        Parameters:
        ctx - A SessionContext interface for the instance.
        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for applications written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

      • ejbRemove

        void ejbRemove()
               throws EJBException,
                      RemoteException
        A container invokes this method before it ends the life of the session object. This happens as a result of a client's invoking a remove operation, or when a container decides to terminate the session object after a timeout.

        This method is called with no transaction context.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

      • ejbActivate

        void ejbActivate()
                 throws EJBException,
                        RemoteException
        The activate method is called when a stateful session bean instance is activated from its "passive" state. The instance should acquire any resource that it has released earlier in the ejbPassivate method.

        This method is called with no transaction context.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

      • ejbPassivate

        void ejbPassivate()
                  throws EJBException,
                         RemoteException
        The passivate method is called before a stateful session bean instance enters the "passive" state. The instance should release any resources that it can re-acquire later in the ejbActivate method.

        After the passivate method completes, the instance must be in a state that allows the container to use the Java Serialization protocol to externalize and store away the instance's state.

        This method is called with no transaction context.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SessionContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface SessionContext

  • All Superinterfaces:
    EJBContext

    public interface SessionContext
extends EJBContext
    The SessionContext interface provides access to the runtime session context that the container provides for a session bean instance. The container passes the SessionContext interface to an instance after the instance has been created. The session context remains associated with the instance for the lifetime of the instance.
    Since:
    EJB 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T> T getBusinessObject(Class<T> businessInterface)
      Obtain an object that can be used to invoke the current bean through a particular business interface view or its no-interface view.
      EJBLocalObject getEJBLocalObject()
      Obtain a reference to the EJB local object that is associated with the instance.
      EJBObject getEJBObject()
      Obtain a reference to the EJB object that is currently associated with the instance.
      Class getInvokedBusinessInterface()
      Obtain the business interface or no-interface view type through which the current business method invocation was made.
      MessageContext getMessageContext()
      Obtain a reference to the JAX-RPC MessageContext.
      boolean wasCancelCalled()
      Check whether a client invoked the cancel method on the client Future object corresponding to the currently executing asynchronous business method.

      • Methods inherited from interface javax.ejb.EJBContext

        getCallerIdentity, getCallerPrincipal, getContextData, getEJBHome, getEJBLocalHome, getEnvironment, getRollbackOnly, getTimerService, getUserTransaction, isCallerInRole, isCallerInRole, lookup, setRollbackOnly

    • Method Detail

      • getEJBLocalObject

        EJBLocalObject getEJBLocalObject()
                                 throws IllegalStateException
        Obtain a reference to the EJB local object that is associated with the instance.

        An instance of a session bean can call this method at anytime between the PostConstruct or ejbCreate and PreDestroy or ejbRemove methods, including from within these methods.

        An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

        Returns:
        The EJB local object currently associated with the instance.
        Throws:
        IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a local interface.
        Since:
        EJB 2.0

      • getEJBObject

        EJBObject getEJBObject()
                       throws IllegalStateException
        Obtain a reference to the EJB object that is currently associated with the instance.

        An instance of a session enterprise Bean can call this method at anytime between the PostConstruct or ejbCreate and the PreDestroy or ejbRemove methods, including from within these methods.

        An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

        Returns:
        The EJB object currently associated with the instance.
        Throws:
        IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a remote interface.

      • getMessageContext

        MessageContext getMessageContext()
                                 throws IllegalStateException
        Obtain a reference to the JAX-RPC MessageContext.

        An instance of a stateless session bean can call this method from any business method invoked through its web service endpoint interface.

        Note: Support for web services invocations using JAX-RPC is optional as of EJB 3.2

        Returns:
        The MessageContext for this web service invocation.
        Throws:
        IllegalStateException - Thrown if this method is invoked while the instance is in a state that does not allow access to this method.
        Since:
        EJB 2.1

      • getBusinessObject

        <T> T getBusinessObject(Class<T> businessInterface)
                    throws IllegalStateException
        Obtain an object that can be used to invoke the current bean through a particular business interface view or its no-interface view.
        Parameters:
        businessInterface - One of the local business interfaces or remote business interfaces for this session bean. In addition, the bean class type can be used to acquire a reference to the bean's no-interface view.
        Returns:
        The business object corresponding to the given business interface or no-interface view.
        Throws:
        IllegalStateException - Thrown if invoked with a parameter that does not correspond to one of the beans' business interfaces or no-interface view.
        Since:
        EJB 3.0

      • getInvokedBusinessInterface

        Class getInvokedBusinessInterface()
                                  throws IllegalStateException
        Obtain the business interface or no-interface view type through which the current business method invocation was made.
        Throws:
        IllegalStateException - Thrown if this method is called and the bean has not been invoked through a business interface or no-interface view.
        Since:
        EJB 3.0

      • wasCancelCalled

        boolean wasCancelCalled()
                        throws IllegalStateException
        Check whether a client invoked the cancel method on the client Future object corresponding to the currently executing asynchronous business method.
        Returns:
        true if the client has invoked Future.cancel with a value of true for the mayInterruptIfRunning parameter.
        Throws:
        IllegalStateException - Thrown if not invoked from within an asynchronous business method invocation with return type Future<V>.
        Since:
        EJB 3.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SessionSynchronization (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface SessionSynchronization

  • public interface SessionSynchronization

    The SessionSynchronization interface allows a stateful session bean instance to be notified by its container of transaction boundaries.

    Only a stateful session bean with container-managed transaction demarcation can receive session synchronization notifications. Other bean types must not implement the SessionSynchronization interface or use the session synchronization annotations.

    A stateful session bean class is not required to implement this interface.

    Since:
    EJB 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterBegin()
      The afterBegin method notifies a stateful session bean instance that a new transaction has started, and that the subsequent business methods on the instance will be invoked in the context of the transaction.
      void afterCompletion(boolean committed)
      The afterCompletion method notifies a stateful session bean instance that a transaction commit protocol has completed, and tells the instance whether the transaction has been committed or rolled back.
      void beforeCompletion()
      The beforeCompletion method notifies a stateful session bean instance that a transaction is about to be committed.

    • Method Detail

      • afterBegin

        void afterBegin()
                throws EJBException,
                       RemoteException
        The afterBegin method notifies a stateful session bean instance that a new transaction has started, and that the subsequent business methods on the instance will be invoked in the context of the transaction.

        The instance can use this method, for example, to read data from a database and cache the data in the instance fields.

        This method executes in the proper transaction context.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 and later specifications should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB 2.0 and later specifications must not throw the java.rmi.RemoteException.
        See Also:
        AfterBegin

      • beforeCompletion

        void beforeCompletion()
                      throws EJBException,
                             RemoteException
        The beforeCompletion method notifies a stateful session bean instance that a transaction is about to be committed. The instance can use this method, for example, to write any cached data to a database.

        This method executes in the proper transaction context.

        Note: The instance may still cause the container to rollback the transaction by invoking the setRollbackOnly method on the session context, or by throwing an exception.

        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 and later specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB 2.0 and later specifications must not throw the java.rmi.RemoteException.
        See Also:
        BeforeCompletion

      • afterCompletion

        void afterCompletion(boolean committed)
                     throws EJBException,
                            RemoteException
        The afterCompletion method notifies a stateful session bean instance that a transaction commit protocol has completed, and tells the instance whether the transaction has been committed or rolled back.

        This method executes with no transaction context.

        Parameters:
        committed - True if the transaction has been committed, false if is has been rolled back.
        Throws:
        EJBException - Thrown by the method to indicate a failure caused by a system-level error.
        RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 and later specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB 2.0 and later specifications must not throw the java.rmi.RemoteException.
        See Also:
        AfterCompletion
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Singleton (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Singleton

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Singleton
    Component-defining annotation for a singleton session bean.
    Since:
    EJB 3.1

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String description
      A string describing the singleton session bean.
      String mappedName
      A product specific name(for example, global JNDI name) that this session bean should be mapped to.
      String name
      The ejb-name for this bean.

    • Element Detail

      • name

        public abstract String name
        The ejb-name for this bean. Defaults to the unqualified name of the singleton session bean class.
        Default:
        ""

      • mappedName

        public abstract String mappedName
        A product specific name(for example, global JNDI name) that this session bean should be mapped to. Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.
        Default:
        ""

      • description

        public abstract String description
        A string describing the singleton session bean.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Startup (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Startup

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Startup
    Mark a singleton bean for eager initialization during the application startup sequence.
    Since:
    EJB 3.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Stateful (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Stateful

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Stateful
    Component-defining annotation for a stateful session bean.
    Since:
    EJB 3.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String description
      A string describing the stateful session bean.
      String mappedName
      A product specific name(e.g.
      String name
      The ejb-name for this bean.
      boolean passivationCapable
      Specifies whether this stateful session bean is passivation capable

    • Element Detail

      • name

        public abstract String name
        The ejb-name for this bean. Defaults to the unqualified name of the stateful session bean class.
        Default:
        ""

      • mappedName

        public abstract String mappedName
        A product specific name(e.g. global JNDI name) that this session bean should be mapped to. Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.
        Default:
        ""

      • description

        public abstract String description
        A string describing the stateful session bean.
        Default:
        ""

      • passivationCapable

        public abstract boolean passivationCapable
        Specifies whether this stateful session bean is passivation capable
        Since:
        EJB 3.2
        Default:
        true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


StatefulTimeout (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type StatefulTimeout

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface StatefulTimeout
    Specifies the amount of time a stateful session bean can be idle (not receive any client invocations) before it is eligible for removal by the container.

    The semantics of the value element are as follows:

    • A value >0 indicates a timeout value in the units specified by the unit element.
    • A value of 0 means the bean is immediately eligible for removal.
    • A value of -1 means the bean will never be removed due to timeout.
    Values less than -1 are not valid.
    Since:
    EJB 3.1

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      long value
      The amount of time the stateful session bean can be idle.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      TimeUnit unit
      Units used for the specified value.

    • Element Detail

      • value

        public abstract long value
        The amount of time the stateful session bean can be idle. The semantics of this element are as follows:
        • A value >0 indicates a timeout value in the units specified by the unit element.
        • A value of 0 means the bean is immediately eligible for removal.
        • A value of -1 means the bean will never be removed due to timeout.
        Values less than -1 are not valid.

      • unit

        public abstract TimeUnit unit
        Units used for the specified value.
        Default:
        java.util.concurrent.TimeUnit.MINUTES
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Stateless (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Stateless

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Stateless
    Component-defining annotation for a stateless session bean.
    Since:
    EJB 3.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String description
      A string describing the stateless session bean.
      String mappedName
      A product specific name(e.g.
      String name
      The ejb-name for this bean.

    • Element Detail

      • name

        public abstract String name
        The ejb-name for this bean. Defaults to the unqualified name of the stateless session bean class.
        Default:
        ""

      • mappedName

        public abstract String mappedName
        A product specific name(e.g. global JNDI name) that this session bean should be mapped to. Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.
        Default:
        ""

      • description

        public abstract String description
        A string describing the stateless session bean.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


TimedObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface TimedObject

  • public interface TimedObject
    The TimedObject interface contains a callback method that is used to deliver timer expiration notifications. It can be implemented by a stateless session bean class, a singleton session bean class, a message-driven bean class, or an EJB 2.x entity bean class.

    If the bean implements the TimedObject interface, the Timeout annotation, if used, can only be applied to the ejbTimeout method.

    Since:
    EJB 2.1
    See Also:
    Timeout

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void ejbTimeout(Timer timer)
      Invoked by the EJB container upon timer expiration.

    • Method Detail

      • ejbTimeout

        void ejbTimeout(Timer timer)
        Invoked by the EJB container upon timer expiration.
        Parameters:
        timer - timer whose expiration caused this notification.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Timeout (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type Timeout

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface Timeout
    Designates a method on a stateless session bean class, a singleton session bean class, a message driven bean class, or an EJB 2.x entity bean class that should receive EJB timer expirations for that bean.

    The method to which the Timeout annotation is applied must have one of the following signatures, where <METHOD> designates the method name:

     void <METHOD>()
 void <METHOD>(Timer timer)
    A timeout callback method can have public, private, protected, or package level access. A timeout callback method must not be declared as final or static. Timeout callback methods must not throw application exceptions.

    If the bean implements the TimedObject interface, the Timeout annotation can only be applied to the ejbTimeout method.

    Since:
    EJB 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Timer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface Timer

  • public interface Timer
    The Timer interface contains information about a timer that was created through the EJB Timer Service.
    Since:
    EJB 2.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void cancel()
      Cause the timer and all its associated expiration notifications to be cancelled.
      TimerHandle getHandle()
      Get a serializable handle to the timer.
      Serializable getInfo()
      Get the information associated with the timer at the time of creation.
      Date getNextTimeout()
      Get the point in time at which the next timer expiration is scheduled to occur.
      ScheduleExpression getSchedule()
      Get the schedule expression corresponding to this timer.
      long getTimeRemaining()
      Get the number of milliseconds that will elapse before the next scheduled timer expiration.
      boolean isCalendarTimer()
      Return whether this timer is a calendar-based timer.
      boolean isPersistent()
      Return whether this timer has persistent semantics.

    • Method Detail

      • cancel

        void cancel()
            throws IllegalStateException,
                   NoSuchObjectLocalException,
                   EJBException
        Cause the timer and all its associated expiration notifications to be cancelled.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
        EJBException - If this method could not complete due to a system-level failure.

      • getTimeRemaining

        long getTimeRemaining()
                      throws IllegalStateException,
                             NoSuchObjectLocalException,
                             NoMoreTimeoutsException,
                             EJBException
        Get the number of milliseconds that will elapse before the next scheduled timer expiration.
        Returns:
        the number of milliseconds that will elapse before the next scheduled timer expiration.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
        javax.ejb.NoMoreTimeoutsExceptions - Indicates that the timer has no future timeouts
        EJBException - If this method could not complete due to a system-level failure.
        NoMoreTimeoutsException

      • getNextTimeout

        Date getNextTimeout()
                    throws IllegalStateException,
                           NoSuchObjectLocalException,
                           NoMoreTimeoutsException,
                           EJBException
        Get the point in time at which the next timer expiration is scheduled to occur.
        Returns:
        the point in time at which the next timer expiration is scheduled to occur.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
        javax.ejb.NoMoreTimeoutsExceptions - Indicates that the timer has no future timeouts
        EJBException - If this method could not complete due to a system-level failure.
        NoMoreTimeoutsException

      • getSchedule

        ScheduleExpression getSchedule()
                               throws IllegalStateException,
                                      NoSuchObjectLocalException,
                                      EJBException
        Get the schedule expression corresponding to this timer. The timer must be a calendar-based timer. It may have been created automatically or programmatically.
        Returns:
        schedule expression for the timer.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method. Also thrown if invoked on a timer that is not a calendar-based timer.
        NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
        EJBException - If this method could not complete due to a system-level failure.
        Since:
        EJB 3.1

      • isPersistent

        boolean isPersistent()
                     throws IllegalStateException,
                            NoSuchObjectLocalException,
                            EJBException
        Return whether this timer has persistent semantics.
        Returns:
        boolean indicating whether the timer is persistent.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
        EJBException - If this method could not complete due to a system-level failure.
        Since:
        EJB 3.1

      • isCalendarTimer

        boolean isCalendarTimer()
                        throws IllegalStateException,
                               NoSuchObjectLocalException,
                               EJBException
        Return whether this timer is a calendar-based timer.
        Returns:
        boolean indicating whether the timer is calendar-based.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
        EJBException - If this method could not complete due to a system-level failure.
        Since:
        EJB 3.1

      • getInfo

        Serializable getInfo()
                     throws IllegalStateException,
                            NoSuchObjectLocalException,
                            EJBException
        Get the information associated with the timer at the time of creation. This may be the info string that was passed to the timer creation method or the info element of the Schedule annotaiton.
        Returns:
        The Serializable object that was passed in at timer creation, or null if the info argument passed in at timer creation was null.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
        EJBException - If this method could not complete due to a system-level failure.

      • getHandle

        TimerHandle getHandle()
                      throws IllegalStateException,
                             NoSuchObjectLocalException,
                             EJBException
        Get a serializable handle to the timer. This handle can be used at a later time to re-obtain the timer reference.
        Returns:
        a serializable handle to the timer.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method. Also thrown if invoked on a non-persistent timer.
        NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
        EJBException - If this method could not complete due to a system-level failure.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TimerConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class TimerConfig

  • java.lang.Object
    • javax.ejb.TimerConfig

  • public class TimerConfig
extends Object

    TimerConfig is used to specify additional timer configuration settings during timer creation.

    The info object represents a serializable object made available to corresponding timer callbacks. It is optional and defaults to null.

    The persistent property determines whether the corresponding timer has a lifetime that spans the JVM in which it was created. It is optional and defaults to true.

    Since:
    EJB 3.1

    • Constructor Summary

      Constructors
      Constructor and Description
      TimerConfig()
      TimerConfig(Serializable info, boolean persistent)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Serializable getInfo()
      Return the info object made available to timer callbacks.
      boolean isPersistent()
      Return whether the timer is persistent.
      void setInfo(Serializable i)
      Set the info object made available to timer callbacks.
      void setPersistent(boolean p)
      Specify whether the timer is persistent.
      String toString()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TimerConfig

        public TimerConfig()

      • TimerConfig

        public TimerConfig(Serializable info,
           boolean persistent)

    • Method Detail

      • setInfo

        public void setInfo(Serializable i)
        Set the info object made available to timer callbacks.
        Parameters:
        i - the info object

      • getInfo

        public Serializable getInfo()
        Return the info object made available to timer callbacks.
        Returns:
        info object

      • setPersistent

        public void setPersistent(boolean p)
        Specify whether the timer is persistent.
        Parameters:
        p - boolean indicating whether the timer is to be persistent.

      • isPersistent

        public boolean isPersistent()
        Return whether the timer is persistent.
        Returns:
        boolean indicating whether the timer is persistent

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TimerHandle (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface TimerHandle

  • All Superinterfaces:
    Serializable

    public interface TimerHandle
extends Serializable
    The TimerHandle interface allows the bean provider to obtain a serializable timer handle that may be persisted.

    Since timers are local objects, a timer handle must not be passed through a bean's remote business interface, remote interface or web service interface.

    Since:
    EJB 2.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Timer getTimer()
      Obtain a reference to the timer represented by this handle.

    • Method Detail

      • getTimer

        Timer getTimer()
               throws IllegalStateException,
                      NoSuchObjectLocalException,
                      EJBException
        Obtain a reference to the timer represented by this handle.
        Returns:
        a reference to the timer represented by this handle.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        NoSuchObjectLocalException - If invoked on a handle whose associated timer has expired or has been cancelled.
        EJBException - If this method could not complete due to a system-level failure.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TimerService (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Interface TimerService

  • public interface TimerService
    The TimerService interface provides enterprise bean components with access to the container-provided Timer Service. The EJB Timer Service allows stateless session beans, singleton session beans, message-driven beans, and EJB 2.x entity beans to be registered for timer callback events at a specified time, after a specified elapsed time, after a specified interval, or according to a calendar-based schedule.
    Since:
    EJB 2.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Timer createCalendarTimer(ScheduleExpression schedule)
      Create a calendar-based timer based on the input schedule expression.
      Timer createCalendarTimer(ScheduleExpression schedule, TimerConfig timerConfig)
      Create a calendar-based timer based on the input schedule expression.
      Timer createIntervalTimer(Date initialExpiration, long intervalDuration, TimerConfig timerConfig)
      Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
      Timer createIntervalTimer(long initialDuration, long intervalDuration, TimerConfig timerConfig)
      Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
      Timer createSingleActionTimer(Date expiration, TimerConfig timerConfig)
      Create a single-action timer that expires at a given point in time.
      Timer createSingleActionTimer(long duration, TimerConfig timerConfig)
      Create a single-action timer that expires after a specified duration.
      Timer createTimer(Date initialExpiration, long intervalDuration, Serializable info)
      Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
      Timer createTimer(Date expiration, Serializable info)
      Create a single-action timer that expires at a given point in time.
      Timer createTimer(long initialDuration, long intervalDuration, Serializable info)
      Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
      Timer createTimer(long duration, Serializable info)
      Create a single-action timer that expires after a specified duration.
      Collection<Timer> getAllTimers()
      Returns all active timers associated with the beans in the same module in which the caller bean is packaged.
      Collection<Timer> getTimers()
      Returns all active timers associated with this bean.

    • Method Detail

      • createTimer

        Timer createTimer(long duration,
                Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
        Create a single-action timer that expires after a specified duration.
        Parameters:
        duration - the number of milliseconds that must elapse before the timer expires.
        info - application information to be delivered along with the timer expiration notification. This can be null.
        Returns:
        the newly created Timer.
        Throws:
        IllegalArgumentException - If duration is negative
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method fails due to a system-level failure.

      • createSingleActionTimer

        Timer createSingleActionTimer(long duration,
                            TimerConfig timerConfig)
                              throws IllegalArgumentException,
                                     IllegalStateException,
                                     EJBException
        Create a single-action timer that expires after a specified duration.
        Parameters:
        duration - the number of milliseconds that must elapse before the timer expires.
        timerConfig - timer configuration.
        Returns:
        the newly created Timer.
        Throws:
        IllegalArgumentException - If duration is negative
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method fails due to a system-level failure.
        Since:
        EJB 3.1

      • createTimer

        Timer createTimer(long initialDuration,
                long intervalDuration,
                Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
        Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
        Parameters:
        initialDuration - The number of milliseconds that must elapse before the first timer expiration notification.
        intervalDuration - The number of milliseconds that must elapse between timer expiration notifications. Expiration notifications are scheduled relative to the time of the first expiration. If expiration is delayed (e.g. due to the interleaving of other method calls on the bean), two or more expiration notifications may occur in close succession to "catch up".
        info - application information to be delivered along with the timer expiration. This can be null.
        Returns:
        the newly created Timer.
        Throws:
        IllegalArgumentException - If initialDuration is negative or intervalDuration is negative.
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method could not complete due to a system-level failure.

      • createIntervalTimer

        Timer createIntervalTimer(long initialDuration,
                        long intervalDuration,
                        TimerConfig timerConfig)
                          throws IllegalArgumentException,
                                 IllegalStateException,
                                 EJBException
        Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
        Parameters:
        initialDuration - The number of milliseconds that must elapse before the first timer expiration notification.
        intervalDuration - The number of milliseconds that must elapse between timer expiration notifications. Expiration notifications are scheduled relative to the time of the first expiration. If expiration is delayed (e.g. due to the interleaving of other method calls on the bean), two or more expiration notifications may occur in close succession to "catch up".
        timerConfig - timer configuration
        Returns:
        the newly created Timer.
        Throws:
        IllegalArgumentException - If initialDuration is negative or intervalDuration is negative.
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method could not complete due to a system-level failure.
        Since:
        EJB 3.1

      • createTimer

        Timer createTimer(Date expiration,
                Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
        Create a single-action timer that expires at a given point in time.
        Parameters:
        expiration - The point in time at which the timer must expire.
        info - application information to be delivered along with the timer expiration notification. This can be null.
        Returns:
        the newly created Timer.
        Throws:
        IllegalArgumentException - If expiration is null or expiration.getTime() is negative.
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method could not complete due to a system-level failure.

      • createSingleActionTimer

        Timer createSingleActionTimer(Date expiration,
                            TimerConfig timerConfig)
                              throws IllegalArgumentException,
                                     IllegalStateException,
                                     EJBException
        Create a single-action timer that expires at a given point in time.
        Parameters:
        expiration - the point in time at which the timer must expire.
        timerConfig - timer configuration.
        Returns:
        the newly created Timer.
        Throws:
        IllegalArgumentException - If expiration is null or expiration.getTime() is negative.
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method could not complete due to a system-level failure.
        Since:
        EJB 3.1

      • createTimer

        Timer createTimer(Date initialExpiration,
                long intervalDuration,
                Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
        Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
        Parameters:
        initialExpiration - the point in time at which the first timer expiration must occur.
        intervalDuration - the number of milliseconds that must elapse between timer expiration notifications. Expiration notifications are scheduled relative to the time of the first expiration. If expiration is delayed (e.g. due to the interleaving of other method calls on the bean), two or more expiration notifications may occur in close succession to "catch up".
        info - application information to be delivered along with the timer expiration. This can be null.
        Returns:
        the newly created Timer.
        Throws:
        IllegalArgumentException - If initialExpiration is null, if initialExpiration.getTime() is negative, or if intervalDuration is negative.
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method could not complete due to a system-level failure.

      • createIntervalTimer

        Timer createIntervalTimer(Date initialExpiration,
                        long intervalDuration,
                        TimerConfig timerConfig)
                          throws IllegalArgumentException,
                                 IllegalStateException,
                                 EJBException
        Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
        Parameters:
        initialExpiration - the point in time at which the first timer expiration must occur.
        intervalDuration - the number of milliseconds that must elapse between timer expiration notifications. Expiration notifications are scheduled relative to the time of the first expiration. If expiration is delayed (e.g. due to the interleaving of other method calls on the bean), two or more expiration notifications may occur in close succession to "catch up".
        timerConfig - timer configuration.
        Returns:
        the newly created Timer.
        Throws:
        IllegalArgumentException - If initialExpiration is null, if initialExpiration.getTime() is negative, or if intervalDuration is negative.
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method could not complete due to a system-level failure.
        Since:
        EJB 3.1

      • createCalendarTimer

        Timer createCalendarTimer(ScheduleExpression schedule)
                          throws IllegalArgumentException,
                                 IllegalStateException,
                                 EJBException
        Create a calendar-based timer based on the input schedule expression.
        Parameters:
        schedule - a schedule expression describing the timeouts for this timer.
        Returns:
        the newly created Timer.
        Throws:
        IllegalArgumentException - If Schedule represents an invalid schedule expression.
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method could not complete due to a system-level failure.
        Since:
        EJB 3.1

      • createCalendarTimer

        Timer createCalendarTimer(ScheduleExpression schedule,
                        TimerConfig timerConfig)
                          throws IllegalArgumentException,
                                 IllegalStateException,
                                 EJBException
        Create a calendar-based timer based on the input schedule expression.
        Parameters:
        schedule - a schedule expression describing the timeouts for this timer.
        timerConfig - timer configuration.
        Returns:
        the newly created Timer.
        Throws:
        IllegalArgumentException - If Schedule represents an invalid schedule expression.
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method could not complete due to a system-level failure.
        Since:
        EJB 3.1

      • getTimers

        Collection<Timer> getTimers()
                            throws IllegalStateException,
                                   EJBException
        Returns all active timers associated with this bean. These include both the programmatically-created timers and the automatically-created timers.
        Returns:
        a collection of javax.ejb.Timer objects.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method could not complete due to a system-level failure.

      • getAllTimers

        Collection<Timer> getAllTimers()
                               throws IllegalStateException,
                                      EJBException
        Returns all active timers associated with the beans in the same module in which the caller bean is packaged. These include both the programmatically-created timers and the automatically-created timers.
        Returns:
        a collection of javax.ejb.Timer objects.
        Throws:
        IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
        EJBException - If this method could not complete due to a system-level failure.
        Since:
        EJB 3.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type TransactionAttribute

  • @Target(value={METHOD,TYPE})
@Retention(value=RUNTIME)
public @interface TransactionAttribute
    The TransactionAttribute annotation specifies whether the container is to invoke a business method within a transaction context. The TransactionAttribute annotation can be used for session beans and message driven beans. It can only be specified if container managed transaction demarcation is used.

    The annotation can be specified on the bean class and/or it can be specified on methods of the class that are methods of the business interface or no-interface view.

    Specifying the TransactionAttribute annotation on the bean class means that it applies to all applicable business methods of the class. Specifying the annotation on a method applies it to that method only. If the annotation is applied at both the class and the method level, the method value overrides if the two disagree.

    The values of the TransactionAttribute annotation are defined by the enum TransactionAttributeType. If the TransactionAttribute annotation is not specified, and the bean uses container managed transaction demarcation, the semantics of the REQUIRED transaction attribute are assumed.

    Since:
    EJB 3.0
    See Also:
    TransactionAttributeType

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      TransactionAttributeType value

    • Element Detail

      • value

        public abstract TransactionAttributeType value
        Default:
        javax.ejb.TransactionAttributeType.REQUIRED
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


TransactionAttributeType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.ejb

Enum TransactionAttributeType

  • java.lang.Object
    • java.lang.Enum<TransactionAttributeType>
      • javax.ejb.TransactionAttributeType
  • All Implemented Interfaces:
    Serializable, Comparable<TransactionAttributeType>

    public enum TransactionAttributeType
extends Enum<TransactionAttributeType>
    The enum TransactionAttributeType is used with the TransactionAttribute annotation to specify whether the methods of a session bean or message driven bean are called with a valid transaction context.

    For a message-driven bean's message listener methods (or interface), only the REQUIRED and NOT_SUPPORTED values may be used.

    For an enterprise bean's timeout callback methods, only the REQUIRED, REQUIRES_NEW and NOT_SUPPORTED values may be used.

    For a session bean's asynchronous business methods, only the REQUIRED, REQUIRES_NEW, and NOT_SUPPORTED values may be used.

    For a singleton session bean's PostConstruct and PreDestroy lifecycle callback interceptor methods, only the REQUIRED, REQUIRES_NEW, and NOT_SUPPORTED values may be used.

    If an enterprise bean implements the SessionSynchronization interface or uses any of the session synchronization annotations, only the following values may be used for the transaction attributes of the bean's methods: REQUIRED, REQUIRES_NEW, MANDATORY.

    Since:
    EJB 3.0
    See Also:
    TransactionAttribute

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      MANDATORY
      If a client invokes the enterprise bean's method while the client is associated with a transaction context, the container invokes the enterprise bean's method in the client's transaction context.
      NEVER
      The client is required to call without a transaction context, otherwise an exception is thrown.
      NOT_SUPPORTED
      The container invokes an enterprise bean method whose transaction attribute NOT_SUPPORTED with an unspecified transaction context.
      REQUIRED
      If a client invokes the enterprise bean's method while the client is associated with a transaction context, the container invokes the enterprise bean's method in the client's transaction context.
      REQUIRES_NEW
      The container must invoke an enterprise bean method whose transaction attribute is set to REQUIRES_NEW with a new transaction context.
      SUPPORTS
      If the client calls with a transaction context, the container performs the same steps as described in the REQUIRED case.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static TransactionAttributeType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static TransactionAttributeType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MANDATORY

        public static final TransactionAttributeType MANDATORY
        If a client invokes the enterprise bean's method while the client is associated with a transaction context, the container invokes the enterprise bean's method in the client's transaction context.

        If there is no existing transaction, an exception is thrown.

      • REQUIRED

        public static final TransactionAttributeType REQUIRED
        If a client invokes the enterprise bean's method while the client is associated with a transaction context, the container invokes the enterprise bean's method in the client's transaction context.

        If the client invokes the enterprise bean's method while the client is not associated with a transaction context, the container automatically starts a new transaction before delegating a method call to the enterprise bean method.

      • REQUIRES_NEW

        public static final TransactionAttributeType REQUIRES_NEW
        The container must invoke an enterprise bean method whose transaction attribute is set to REQUIRES_NEW with a new transaction context.

        If the client invokes the enterprise bean's method while the client is not associated with a transaction context, the container automatically starts a new transaction before delegating a method call to the enterprise bean business method.

        If a client calls with a transaction context, the container suspends the association of the transaction context with the current thread before starting the new transaction and invoking the method. The container resumes the suspended transaction association after the method and the new transaction have been completed.

      • SUPPORTS

        public static final TransactionAttributeType SUPPORTS
        If the client calls with a transaction context, the container performs the same steps as described in the REQUIRED case.

        If the client calls without a transaction context, the container performs the same steps as described in the NOT_SUPPORTED case.

        The SUPPORTS transaction attribute must be used with caution. This is because of the different transactional semantics provided by the two possible modes of execution. Only enterprise beans that will execute correctly in both modes should use the SUPPORTS transaction attribute.

      • NOT_SUPPORTED

        public static final TransactionAttributeType NOT_SUPPORTED
        The container invokes an enterprise bean method whose transaction attribute NOT_SUPPORTED with an unspecified transaction context.

        If a client calls with a transaction context, the container suspends the association of the transaction context with the current thread before invoking the enterprise bean's business method. The container resumes the suspended association when the business method has completed.

      • NEVER

        public static final TransactionAttributeType NEVER
        The client is required to call without a transaction context, otherwise an exception is thrown.

    • Method Detail

      • values

        public static TransactionAttributeType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (TransactionAttributeType c : TransactionAttributeType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static TransactionAttributeType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


TransactionManagement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ejb

Annotation Type TransactionManagement

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface TransactionManagement
    Specifies whether a session bean or message driven bean has container managed transactions or bean managed transactions. If this annotation is not used, the bean is assumed to have container-managed transaction management.
    Since:
    EJB 3.0
    See Also:
    TransactionManagementType

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      TransactionManagementType value

    • Element Detail

      • value

        public abstract TransactionManagementType value
        Default:
        javax.ejb.TransactionManagementType.CONTAINER
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


TransactionManagementType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.ejb

Enum TransactionManagementType

  • java.lang.Object
    • java.lang.Enum<TransactionManagementType>
      • javax.ejb.TransactionManagementType
  • All Implemented Interfaces:
    Serializable, Comparable<TransactionManagementType>

    public enum TransactionManagementType
extends Enum<TransactionManagementType>
    The enum TransactionManagementType is used with the TransactionManagement annotation to specify whether container-managed or bean-managed transaction management is used.
    Since:
    EJB 3.0
    See Also:
    TransactionManagement

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BEAN
      Bean-managed transaction management is used.
      CONTAINER
      Container-managed transaction management is used.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static TransactionManagementType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static TransactionManagementType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CONTAINER

        public static final TransactionManagementType CONTAINER
        Container-managed transaction management is used.

      • BEAN

        public static final TransactionManagementType BEAN
        Bean-managed transaction management is used.

    • Method Detail

      • values

        public static TransactionManagementType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (TransactionManagementType c : TransactionManagementType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static TransactionManagementType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


TransactionRequiredLocalException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class TransactionRequiredLocalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.TransactionRequiredLocalException
  • All Implemented Interfaces:
    Serializable

    public class TransactionRequiredLocalException
extends EJBException
    This exception is thrown to a local client to indicate that a request carried a null transaction context, but the target object requires an active transaction.
    Since:
    EJB 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionRequiredLocalException()
      Constructs a TransactionRequiredLocalException with no detail message.
      TransactionRequiredLocalException(String message)
      Constructs an TransactionRequiredLocalException with the specified detailed message.

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionRequiredLocalException

        public TransactionRequiredLocalException()
        Constructs a TransactionRequiredLocalException with no detail message.

      • TransactionRequiredLocalException

        public TransactionRequiredLocalException(String message)
        Constructs an TransactionRequiredLocalException with the specified detailed message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionRolledbackLocalException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb

Class TransactionRolledbackLocalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.TransactionRolledbackLocalException
  • All Implemented Interfaces:
    Serializable

    public class TransactionRolledbackLocalException
extends EJBException
    This exception is thrown to a local client to indicate that the transaction associated with processing of the request has been rolled back, or marked to roll back. Thus the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless.
    Since:
    EJB 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionRolledbackLocalException()
      Constructs a TransactionRolledbackLocalException with no detail message.
      TransactionRolledbackLocalException(String message)
      Constructs a TransactionRolledbackLocalException with the specified detailed message.
      TransactionRolledbackLocalException(String message, Exception ex)
      Constructs a TransactionRolledbackLocalException with the specified detail message and a nested exception.

    • Method Summary

      • Methods inherited from class javax.ejb.EJBException

        getCausedByException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionRolledbackLocalException

        public TransactionRolledbackLocalException()
        Constructs a TransactionRolledbackLocalException with no detail message.

      • TransactionRolledbackLocalException

        public TransactionRolledbackLocalException(String message)
        Constructs a TransactionRolledbackLocalException with the specified detailed message.

      • TransactionRolledbackLocalException

        public TransactionRolledbackLocalException(String message,
                                   Exception ex)
        Constructs a TransactionRolledbackLocalException with the specified detail message and a nested exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.ejb (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.ejb

  • Packages that use javax.ejb
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
    javax.ejb.spi
    Defines interfaces that are implemented by the EJB container.
    javax.management.j2ee
    Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.
  • Classes in javax.ejb used by javax.ejb
    Class and Description
    ConcurrencyManagementType
    Used to specify the value of the ConcurrencyManagement annotation for a singleton session bean.
    ConcurrentAccessException
    A ConcurrentAccessException indicates that the client has attempted an invocation on a stateful session bean or singleton bean while another invocation is in progress and such concurrent access is not allowed.
    CreateException
    The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise bean's home or local home interface.
    EJBContext
    The EJBContext interface provides an instance with access to the container-provided runtime context of an enterprise bean instance.
    EJBException
    The EJBException is thrown to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g.
    EJBHome
    The EJBHome interface must be extended by all enterprise beans' remote home interfaces.
    EJBLocalHome
    The EJBLocalHome interface must be extended by all enterprise beans' local home interfaces.
    EJBLocalObject
    The EJBLocalObject interface must be extended by all enterprise beans' local interfaces.
    EJBMetaData
    The EJBMetaData interface allows a client to obtain the enterprise bean's meta-data information.
    EJBObject
    The EJBObject interface is extended by all enterprise beans' remote interfaces.
    EnterpriseBean
    The EnterpriseBean interface is a common superinterface for the SessionBean, EntityBean and MessageDrivenBean interfaces.
    EntityContext
    The EntityContext interface provides an instance with access to the container-provided runtime context of an entity bean instance.
    FinderException
    The FinderException exception must be included in the throws clause of every finder method of an entity bean's home or local home interface.
    Handle
    The Handle interface is implemented by all EJB object handles.
    HomeHandle
    The HomeHandle interface is implemented by all home object handles.
    LockType
    Concurrency lock type for singleton beans with container-managed concurrency.
    MessageDrivenContext
    The MessageDrivenContext interface provides access to the runtime message-driven context that the container provides for a message-driven bean instance.
    NoMoreTimeoutsException
    This exception indicates that a calendar-based timer will not result in any more timeouts.
    NoSuchObjectLocalException
    A NoSuchObjectLocalException is thrown if an attempt is made to invoke a method on a local object (local EJB object or timer) that no longer exists.
    RemoveException
    The RemoveException is thrown at an attempt to remove an EJB object or local EJB object when the enterprise bean or the container does not allow the EJB object to be removed.
    ScheduleExpression
    A calendar-based timeout expression for an enterprise bean timer.
    SessionContext
    The SessionContext interface provides access to the runtime session context that the container provides for a session bean instance.
    Timer
    The Timer interface contains information about a timer that was created through the EJB Timer Service.
    TimerConfig
    TimerConfig is used to specify additional timer configuration settings during timer creation.
    TimerHandle
    The TimerHandle interface allows the bean provider to obtain a serializable timer handle that may be persisted.
    TimerService
    The TimerService interface provides enterprise bean components with access to the container-provided Timer Service.
    TransactionAttributeType
    The enum TransactionAttributeType is used with the TransactionAttribute annotation to specify whether the methods of a session bean or message driven bean are called with a valid transaction context.
    TransactionManagementType
    The enum TransactionManagementType is used with the TransactionManagement annotation to specify whether container-managed or bean-managed transaction management is used.
  • Classes in javax.ejb used by javax.ejb.spi
    Class and Description
    EJBException
    The EJBException is thrown to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g.
    EJBHome
    The EJBHome interface must be extended by all enterprise beans' remote home interfaces.
    EJBObject
    The EJBObject interface is extended by all enterprise beans' remote interfaces.
  • Classes in javax.ejb used by javax.management.j2ee
    Class and Description
    CreateException
    The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise bean's home or local home interface.
    EJBHome
    The EJBHome interface must be extended by all enterprise beans' remote home interfaces.
    EJBObject
    The EJBObject interface is extended by all enterprise beans' remote interfaces.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.AccessLocalException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.AccessLocalException

No usage of javax.ejb.AccessLocalException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.AccessTimeout (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.AccessTimeout

No usage of javax.ejb.AccessTimeout
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.ActivationConfigProperty (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.ActivationConfigProperty

No usage of javax.ejb.ActivationConfigProperty
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.AfterBegin (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.AfterBegin

No usage of javax.ejb.AfterBegin
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.AfterCompletion (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.AfterCompletion

No usage of javax.ejb.AfterCompletion
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.ApplicationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.ApplicationException

No usage of javax.ejb.ApplicationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Asynchronous (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Asynchronous

No usage of javax.ejb.Asynchronous
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.AsyncResult (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.AsyncResult

No usage of javax.ejb.AsyncResult
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.BeforeCompletion (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.BeforeCompletion

No usage of javax.ejb.BeforeCompletion
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.ConcurrencyManagement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.ConcurrencyManagement

No usage of javax.ejb.ConcurrencyManagement
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.ConcurrencyManagementType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.ConcurrencyManagementType

  • Packages that use ConcurrencyManagementType
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of ConcurrencyManagementType in javax.ejb

      Methods in javax.ejb that return ConcurrencyManagementType
      Modifier and Type Method and Description
      static ConcurrencyManagementType ConcurrencyManagementType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ConcurrencyManagementType[] ConcurrencyManagementType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.ConcurrentAccessException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.ConcurrentAccessException

  • Packages that use ConcurrentAccessException
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of ConcurrentAccessException in javax.ejb

      Subclasses of ConcurrentAccessException in javax.ejb
      Modifier and Type Class and Description
      class  ConcurrentAccessTimeoutException
      This exception indicates that an attempt to concurrently access a stateful session or singleton bean method resulted in a timeout.
      class  IllegalLoopbackException
      This exception indicates that an attempt was made to perform an illegal loopback invocation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.ConcurrentAccessTimeoutException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.ConcurrentAccessTimeoutException

No usage of javax.ejb.ConcurrentAccessTimeoutException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.CreateException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.CreateException

  • Packages that use CreateException
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
    javax.management.j2ee
    Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

    • Uses of CreateException in javax.ejb

      Subclasses of CreateException in javax.ejb
      Modifier and Type Class and Description
      class  DuplicateKeyException
      The DuplicateKeyException exception is thrown if an entity EJB object or EJB local object cannot be created because an object with the same key already exists.

    • Uses of CreateException in javax.management.j2ee

      Methods in javax.management.j2ee that throw CreateException
      Modifier and Type Method and Description
      Management ManagementHome.create()
      Creates an MEJB session object which provides access to the J2EE Management Model
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.DependsOn (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.DependsOn

No usage of javax.ejb.DependsOn
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.DuplicateKeyException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.DuplicateKeyException

No usage of javax.ejb.DuplicateKeyException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.EJB (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.EJB

No usage of javax.ejb.EJB
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.EJBAccessException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.EJBAccessException

No usage of javax.ejb.EJBAccessException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.EJBException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.EJBException

  • Packages that use EJBException
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
    javax.ejb.spi
    Defines interfaces that are implemented by the EJB container.

    • Uses of EJBException in javax.ejb

      Subclasses of EJBException in javax.ejb
      Modifier and Type Class and Description
      class  AccessLocalException
      An AccessLocalException is thrown to indicate that the caller does not have permission to call the method.
      class  ConcurrentAccessException
      A ConcurrentAccessException indicates that the client has attempted an invocation on a stateful session bean or singleton bean while another invocation is in progress and such concurrent access is not allowed.
      class  ConcurrentAccessTimeoutException
      This exception indicates that an attempt to concurrently access a stateful session or singleton bean method resulted in a timeout.
      class  EJBAccessException
      This exception indicates that client access to a business method was denied.
      class  EJBTransactionRequiredException
      This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.
      class  EJBTransactionRolledbackException
      This exception is thrown to a remote client to indicate that the transaction associated with processing of the request has been rolled back, or marked to roll back.
      class  IllegalLoopbackException
      This exception indicates that an attempt was made to perform an illegal loopback invocation.
      class  NoMoreTimeoutsException
      This exception indicates that a calendar-based timer will not result in any more timeouts.
      class  NoSuchEJBException
      A NoSuchEJBException is thrown if an attempt is made to invoke a business method on a stateful session or singleton object that no longer exists.
      class  NoSuchEntityException
      The NoSuchEntityException exception is thrown by an entity bean instance to its container to report that the invoked business method or callback method could not be completed because of the underlying entity was removed from the database.
      class  NoSuchObjectLocalException
      A NoSuchObjectLocalException is thrown if an attempt is made to invoke a method on a local object (local EJB object or timer) that no longer exists.
      class  TransactionRequiredLocalException
      This exception is thrown to a local client to indicate that a request carried a null transaction context, but the target object requires an active transaction.
      class  TransactionRolledbackLocalException
      This exception is thrown to a local client to indicate that the transaction associated with processing of the request has been rolled back, or marked to roll back.
      Methods in javax.ejb that throw EJBException
      Modifier and Type Method and Description
      void SessionSynchronization.afterBegin()
      The afterBegin method notifies a stateful session bean instance that a new transaction has started, and that the subsequent business methods on the instance will be invoked in the context of the transaction.
      void SessionSynchronization.afterCompletion(boolean committed)
      The afterCompletion method notifies a stateful session bean instance that a transaction commit protocol has completed, and tells the instance whether the transaction has been committed or rolled back.
      void SessionSynchronization.beforeCompletion()
      The beforeCompletion method notifies a stateful session bean instance that a transaction is about to be committed.
      void Timer.cancel()
      Cause the timer and all its associated expiration notifications to be cancelled.
      Timer TimerService.createCalendarTimer(ScheduleExpression schedule)
      Create a calendar-based timer based on the input schedule expression.
      Timer TimerService.createCalendarTimer(ScheduleExpression schedule, TimerConfig timerConfig)
      Create a calendar-based timer based on the input schedule expression.
      Timer TimerService.createIntervalTimer(Date initialExpiration, long intervalDuration, TimerConfig timerConfig)
      Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
      Timer TimerService.createIntervalTimer(long initialDuration, long intervalDuration, TimerConfig timerConfig)
      Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
      Timer TimerService.createSingleActionTimer(Date expiration, TimerConfig timerConfig)
      Create a single-action timer that expires at a given point in time.
      Timer TimerService.createSingleActionTimer(long duration, TimerConfig timerConfig)
      Create a single-action timer that expires after a specified duration.
      Timer TimerService.createTimer(Date initialExpiration, long intervalDuration, Serializable info)
      Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
      Timer TimerService.createTimer(Date expiration, Serializable info)
      Create a single-action timer that expires at a given point in time.
      Timer TimerService.createTimer(long initialDuration, long intervalDuration, Serializable info)
      Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
      Timer TimerService.createTimer(long duration, Serializable info)
      Create a single-action timer that expires after a specified duration.
      void SessionBean.ejbActivate()
      The activate method is called when a stateful session bean instance is activated from its "passive" state.
      void EntityBean.ejbActivate()
      A container invokes this method when the instance is taken out of the pool of available instances to become associated with a specific EJB object.
      void EntityBean.ejbLoad()
      A container invokes this method to instruct the instance to synchronize its state by loading it state from the underlying database.
      void SessionBean.ejbPassivate()
      The passivate method is called before a stateful session bean instance enters the "passive" state.
      void EntityBean.ejbPassivate()
      A container invokes this method on an instance before the instance becomes disassociated with a specific EJB object.
      void SessionBean.ejbRemove()
      A container invokes this method before it ends the life of the session object.
      void MessageDrivenBean.ejbRemove()
      A container invokes this method before it ends the life of the message-driven object.
      void EntityBean.ejbRemove()
      A container invokes this method before it removes the EJB object that is currently associated with the instance.
      void EntityBean.ejbStore()
      A container invokes this method to instruct the instance to synchronize its state by storing it to the underlying database.
      Collection<Timer> TimerService.getAllTimers()
      Returns all active timers associated with the beans in the same module in which the caller bean is packaged.
      EJBLocalHome EJBLocalObject.getEJBLocalHome()
      Obtain the enterprise bean's local home interface.
      TimerHandle Timer.getHandle()
      Get a serializable handle to the timer.
      Serializable Timer.getInfo()
      Get the information associated with the timer at the time of creation.
      Date Timer.getNextTimeout()
      Get the point in time at which the next timer expiration is scheduled to occur.
      Object EJBLocalObject.getPrimaryKey()
      Obtain the primary key of the EJB local object.
      ScheduleExpression Timer.getSchedule()
      Get the schedule expression corresponding to this timer.
      Timer TimerHandle.getTimer()
      Obtain a reference to the timer represented by this handle.
      long Timer.getTimeRemaining()
      Get the number of milliseconds that will elapse before the next scheduled timer expiration.
      Collection<Timer> TimerService.getTimers()
      Returns all active timers associated with this bean.
      boolean Timer.isCalendarTimer()
      Return whether this timer is a calendar-based timer.
      boolean EJBLocalObject.isIdentical(EJBLocalObject obj)
      Test if a given EJB local object is identical to the invoked EJB local object.
      boolean Timer.isPersistent()
      Return whether this timer has persistent semantics.
      void EJBLocalObject.remove()
      Remove the EJB local object.
      void EJBLocalHome.remove(Object primaryKey)
      Remove an EJB object identified by its primary key.
      void EntityBean.setEntityContext(EntityContext ctx)
      Set the associated entity context.
      void MessageDrivenBean.setMessageDrivenContext(MessageDrivenContext ctx)
      Set the associated message-driven context.
      void SessionBean.setSessionContext(SessionContext ctx)
      Set the associated session context.
      void EntityBean.unsetEntityContext()
      Unset the associated entity context.

    • Uses of EJBException in javax.ejb.spi

      Methods in javax.ejb.spi that throw EJBException
      Modifier and Type Method and Description
      EJBContainer EJBContainerProvider.createEJBContainer(Map<?,?> properties)
      Called by the embeddable container bootstrap process to find a suitable embeddable container implementation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.EJBs (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.EJBs

No usage of javax.ejb.EJBs
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.EJBTransactionRequiredException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.EJBTransactionRequiredException

No usage of javax.ejb.EJBTransactionRequiredException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.EJBTransactionRolledbackException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.EJBTransactionRolledbackException

No usage of javax.ejb.EJBTransactionRolledbackException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.FinderException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.FinderException

  • Packages that use FinderException
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of FinderException in javax.ejb

      Subclasses of FinderException in javax.ejb
      Modifier and Type Class and Description
      class  ObjectNotFoundException
      The ObjectNotFoundException exception is thrown by a finder or select method to indicate that the specified EJB object or local object does not exist.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.IllegalLoopbackException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.IllegalLoopbackException

No usage of javax.ejb.IllegalLoopbackException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Init (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Init

No usage of javax.ejb.Init
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Local (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Local

No usage of javax.ejb.Local
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.LocalBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.LocalBean

No usage of javax.ejb.LocalBean
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.LocalHome (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.LocalHome

No usage of javax.ejb.LocalHome
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Lock (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Lock

No usage of javax.ejb.Lock
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.LockType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.LockType

  • Packages that use LockType
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of LockType in javax.ejb

      Methods in javax.ejb that return LockType
      Modifier and Type Method and Description
      static LockType LockType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static LockType[] LockType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.MessageDriven (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.MessageDriven

No usage of javax.ejb.MessageDriven
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.NoMoreTimeoutsException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.NoMoreTimeoutsException

  • Packages that use NoMoreTimeoutsException
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of NoMoreTimeoutsException in javax.ejb

      Methods in javax.ejb that throw NoMoreTimeoutsException
      Modifier and Type Method and Description
      Date Timer.getNextTimeout()
      Get the point in time at which the next timer expiration is scheduled to occur.
      long Timer.getTimeRemaining()
      Get the number of milliseconds that will elapse before the next scheduled timer expiration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.NoSuchEJBException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.NoSuchEJBException

No usage of javax.ejb.NoSuchEJBException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.NoSuchEntityException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.NoSuchEntityException

No usage of javax.ejb.NoSuchEntityException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.NoSuchObjectLocalException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.NoSuchObjectLocalException

  • Packages that use NoSuchObjectLocalException
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of NoSuchObjectLocalException in javax.ejb

      Methods in javax.ejb that throw NoSuchObjectLocalException
      Modifier and Type Method and Description
      void Timer.cancel()
      Cause the timer and all its associated expiration notifications to be cancelled.
      TimerHandle Timer.getHandle()
      Get a serializable handle to the timer.
      Serializable Timer.getInfo()
      Get the information associated with the timer at the time of creation.
      Date Timer.getNextTimeout()
      Get the point in time at which the next timer expiration is scheduled to occur.
      ScheduleExpression Timer.getSchedule()
      Get the schedule expression corresponding to this timer.
      Timer TimerHandle.getTimer()
      Obtain a reference to the timer represented by this handle.
      long Timer.getTimeRemaining()
      Get the number of milliseconds that will elapse before the next scheduled timer expiration.
      boolean Timer.isCalendarTimer()
      Return whether this timer is a calendar-based timer.
      boolean Timer.isPersistent()
      Return whether this timer has persistent semantics.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.ObjectNotFoundException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.ObjectNotFoundException

No usage of javax.ejb.ObjectNotFoundException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.PostActivate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.PostActivate

No usage of javax.ejb.PostActivate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.PrePassivate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.PrePassivate

No usage of javax.ejb.PrePassivate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Remote (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Remote

No usage of javax.ejb.Remote
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.RemoteHome (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.RemoteHome

No usage of javax.ejb.RemoteHome
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Remove (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Remove

No usage of javax.ejb.Remove
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.RemoveException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.RemoveException

  • Packages that use RemoveException
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of RemoveException in javax.ejb

      Methods in javax.ejb that throw RemoveException
      Modifier and Type Method and Description
      void EntityBean.ejbRemove()
      A container invokes this method before it removes the EJB object that is currently associated with the instance.
      void EJBObject.remove()
      Remove the EJB object.
      void EJBLocalObject.remove()
      Remove the EJB local object.
      void EJBHome.remove(Handle handle)
      Remove an EJB object identified by its handle.
      void EJBLocalHome.remove(Object primaryKey)
      Remove an EJB object identified by its primary key.
      void EJBHome.remove(Object primaryKey)
      Remove an EJB object identified by its primary key.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Schedule (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Schedule

No usage of javax.ejb.Schedule
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.ScheduleExpression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.ScheduleExpression

  • Packages that use ScheduleExpression
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of ScheduleExpression in javax.ejb

      Methods in javax.ejb that return ScheduleExpression
      Modifier and Type Method and Description
      ScheduleExpression ScheduleExpression.dayOfMonth(int d)
      Set the day of the month attribute.
      ScheduleExpression ScheduleExpression.dayOfMonth(String d)
      Set the day of the month attribute.
      ScheduleExpression ScheduleExpression.dayOfWeek(int d)
      Set the day of the week attribute.
      ScheduleExpression ScheduleExpression.dayOfWeek(String d)
      Set the day of the week attribute.
      ScheduleExpression ScheduleExpression.end(Date e)
      Set the end date.
      ScheduleExpression Timer.getSchedule()
      Get the schedule expression corresponding to this timer.
      ScheduleExpression ScheduleExpression.hour(int h)
      Set the hour attribute.
      ScheduleExpression ScheduleExpression.hour(String h)
      Set the hour attribute.
      ScheduleExpression ScheduleExpression.minute(int m)
      Set the minute attribute.
      ScheduleExpression ScheduleExpression.minute(String m)
      Set the minute attribute.
      ScheduleExpression ScheduleExpression.month(int m)
      Set the month attribute.
      ScheduleExpression ScheduleExpression.month(String m)
      Set the month attribute.
      ScheduleExpression ScheduleExpression.second(int s)
      Set the second attribute.
      ScheduleExpression ScheduleExpression.second(String s)
      Set the second attribute.
      ScheduleExpression ScheduleExpression.start(Date s)
      Set the start date.
      ScheduleExpression ScheduleExpression.timezone(String timezoneID)
      Set the timezone.
      ScheduleExpression ScheduleExpression.year(int y)
      Set the year attribute.
      ScheduleExpression ScheduleExpression.year(String y)
      Set the year attribute.
      Methods in javax.ejb with parameters of type ScheduleExpression
      Modifier and Type Method and Description
      Timer TimerService.createCalendarTimer(ScheduleExpression schedule)
      Create a calendar-based timer based on the input schedule expression.
      Timer TimerService.createCalendarTimer(ScheduleExpression schedule, TimerConfig timerConfig)
      Create a calendar-based timer based on the input schedule expression.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Schedules (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Schedules

No usage of javax.ejb.Schedules
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Singleton (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Singleton

No usage of javax.ejb.Singleton
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Startup (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Startup

No usage of javax.ejb.Startup
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Stateful (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Stateful

No usage of javax.ejb.Stateful
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.StatefulTimeout (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.StatefulTimeout

No usage of javax.ejb.StatefulTimeout
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Stateless (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Stateless

No usage of javax.ejb.Stateless
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.Timeout (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.Timeout

No usage of javax.ejb.Timeout
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.TimerConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.TimerConfig

  • Packages that use TimerConfig
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of TimerConfig in javax.ejb

      Methods in javax.ejb with parameters of type TimerConfig
      Modifier and Type Method and Description
      Timer TimerService.createCalendarTimer(ScheduleExpression schedule, TimerConfig timerConfig)
      Create a calendar-based timer based on the input schedule expression.
      Timer TimerService.createIntervalTimer(Date initialExpiration, long intervalDuration, TimerConfig timerConfig)
      Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
      Timer TimerService.createIntervalTimer(long initialDuration, long intervalDuration, TimerConfig timerConfig)
      Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
      Timer TimerService.createSingleActionTimer(Date expiration, TimerConfig timerConfig)
      Create a single-action timer that expires at a given point in time.
      Timer TimerService.createSingleActionTimer(long duration, TimerConfig timerConfig)
      Create a single-action timer that expires after a specified duration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.TransactionAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.TransactionAttribute

No usage of javax.ejb.TransactionAttribute
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.TransactionAttributeType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.TransactionAttributeType

  • Packages that use TransactionAttributeType
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of TransactionAttributeType in javax.ejb

      Methods in javax.ejb that return TransactionAttributeType
      Modifier and Type Method and Description
      static TransactionAttributeType TransactionAttributeType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static TransactionAttributeType[] TransactionAttributeType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.TransactionManagement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.TransactionManagement

No usage of javax.ejb.TransactionManagement
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.TransactionManagementType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.TransactionManagementType

  • Packages that use TransactionManagementType
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of TransactionManagementType in javax.ejb

      Methods in javax.ejb that return TransactionManagementType
      Modifier and Type Method and Description
      static TransactionManagementType TransactionManagementType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static TransactionManagementType[] TransactionManagementType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.TransactionRequiredLocalException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.TransactionRequiredLocalException

No usage of javax.ejb.TransactionRequiredLocalException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.TransactionRolledbackLocalException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.TransactionRolledbackLocalException

No usage of javax.ejb.TransactionRolledbackLocalException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.EJBContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.EJBContext

  • Packages that use EJBContext
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of EJBContext in javax.ejb

      Subinterfaces of EJBContext in javax.ejb
      Modifier and Type Interface and Description
      interface  EntityContext
      The EntityContext interface provides an instance with access to the container-provided runtime context of an entity bean instance.
      interface  MessageDrivenContext
      The MessageDrivenContext interface provides access to the runtime message-driven context that the container provides for a message-driven bean instance.
      interface  SessionContext
      The SessionContext interface provides access to the runtime session context that the container provides for a session bean instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.EJBHome (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.EJBHome

  • Packages that use EJBHome
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
    javax.ejb.spi
    Defines interfaces that are implemented by the EJB container.
    javax.management.j2ee
    Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

    • Uses of EJBHome in javax.ejb

      Methods in javax.ejb that return EJBHome
      Modifier and Type Method and Description
      EJBHome HomeHandle.getEJBHome()
      Obtain the home object represented by this handle.
      EJBHome EJBObject.getEJBHome()
      Obtain the enterprise bean's remote home interface.
      EJBHome EJBMetaData.getEJBHome()
      Obtain the remote home interface of the enterprise bean.
      EJBHome EJBContext.getEJBHome()
      Obtain the enterprise bean's remote home interface.

    • Uses of EJBHome in javax.ejb.spi

      Methods in javax.ejb.spi that return EJBHome
      Modifier and Type Method and Description
      EJBHome HandleDelegate.readEJBHome(ObjectInputStream istream)
      Deserialize the EJBHome reference corresponding to a HomeHandle.
      Methods in javax.ejb.spi with parameters of type EJBHome
      Modifier and Type Method and Description
      void HandleDelegate.writeEJBHome(EJBHome ejbHome, ObjectOutputStream ostream)
      Serialize the EJBHome reference corresponding to a HomeHandle.

    • Uses of EJBHome in javax.management.j2ee

      Subinterfaces of EJBHome in javax.management.j2ee
      Modifier and Type Interface and Description
      interface  ManagementHome
      The required home interface for the J2EE Management EJB component (MEJB).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.EJBLocalHome (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.EJBLocalHome

  • Packages that use EJBLocalHome
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of EJBLocalHome in javax.ejb

      Methods in javax.ejb that return EJBLocalHome
      Modifier and Type Method and Description
      EJBLocalHome EJBLocalObject.getEJBLocalHome()
      Obtain the enterprise bean's local home interface.
      EJBLocalHome EJBContext.getEJBLocalHome()
      Obtain the enterprise bean's local home interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.EJBLocalObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.EJBLocalObject

  • Packages that use EJBLocalObject
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of EJBLocalObject in javax.ejb

      Methods in javax.ejb that return EJBLocalObject
      Modifier and Type Method and Description
      EJBLocalObject SessionContext.getEJBLocalObject()
      Obtain a reference to the EJB local object that is associated with the instance.
      EJBLocalObject EntityContext.getEJBLocalObject()
      Obtain a reference to the EJB local object that is currently associated with the instance.
      Methods in javax.ejb with parameters of type EJBLocalObject
      Modifier and Type Method and Description
      boolean EJBLocalObject.isIdentical(EJBLocalObject obj)
      Test if a given EJB local object is identical to the invoked EJB local object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.EJBMetaData (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.EJBMetaData

  • Packages that use EJBMetaData
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of EJBMetaData in javax.ejb

      Methods in javax.ejb that return EJBMetaData
      Modifier and Type Method and Description
      EJBMetaData EJBHome.getEJBMetaData()
      Obtain the EJBMetaData interface for the enterprise bean.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.EJBObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.EJBObject

  • Packages that use EJBObject
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
    javax.ejb.spi
    Defines interfaces that are implemented by the EJB container.
    javax.management.j2ee
    Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

    • Uses of EJBObject in javax.ejb

      Methods in javax.ejb that return EJBObject
      Modifier and Type Method and Description
      EJBObject SessionContext.getEJBObject()
      Obtain a reference to the EJB object that is currently associated with the instance.
      EJBObject Handle.getEJBObject()
      Obtain the EJB object reference represented by this handle.
      EJBObject EntityContext.getEJBObject()
      Obtain a reference to the EJB object that is currently associated with the instance.
      Methods in javax.ejb with parameters of type EJBObject
      Modifier and Type Method and Description
      boolean EJBObject.isIdentical(EJBObject obj)
      Test if a given EJB object is identical to the invoked EJB object.

    • Uses of EJBObject in javax.ejb.spi

      Methods in javax.ejb.spi that return EJBObject
      Modifier and Type Method and Description
      EJBObject HandleDelegate.readEJBObject(ObjectInputStream istream)
      Deserialize the EJBObject reference corresponding to a Handle.
      Methods in javax.ejb.spi with parameters of type EJBObject
      Modifier and Type Method and Description
      void HandleDelegate.writeEJBObject(EJBObject ejbObject, ObjectOutputStream ostream)
      Serialize the EJBObject reference corresponding to a Handle.

    • Uses of EJBObject in javax.management.j2ee

      Subinterfaces of EJBObject in javax.management.j2ee
      Modifier and Type Interface and Description
      interface  Management
      The Management interface provides the APIs to navigate and manipulate managed objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.EnterpriseBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.EnterpriseBean

  • Packages that use EnterpriseBean
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of EnterpriseBean in javax.ejb

      Subinterfaces of EnterpriseBean in javax.ejb
      Modifier and Type Interface and Description
      interface  EntityBean
      The EntityBean interface is implemented by every entity bean class.
      interface  MessageDrivenBean
      The MessageDrivenBean interface defines methods that the EJB container uses to notify a message driven bean instance of the instance's life cycle events.
      interface  SessionBean
      The SessionBean interface defines methods that the EJB container uses to notify a session bean instance of the instance's life cycle events.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.EntityBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.EntityBean

No usage of javax.ejb.EntityBean
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.EntityContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.EntityContext

  • Packages that use EntityContext
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of EntityContext in javax.ejb

      Methods in javax.ejb with parameters of type EntityContext
      Modifier and Type Method and Description
      void EntityBean.setEntityContext(EntityContext ctx)
      Set the associated entity context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.Handle (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.Handle

  • Packages that use Handle
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of Handle in javax.ejb

      Methods in javax.ejb that return Handle
      Modifier and Type Method and Description
      Handle EJBObject.getHandle()
      Obtain a handle for the EJB object.
      Methods in javax.ejb with parameters of type Handle
      Modifier and Type Method and Description
      void EJBHome.remove(Handle handle)
      Remove an EJB object identified by its handle.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.HomeHandle (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.HomeHandle

  • Packages that use HomeHandle
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of HomeHandle in javax.ejb

      Methods in javax.ejb that return HomeHandle
      Modifier and Type Method and Description
      HomeHandle EJBHome.getHomeHandle()
      Obtain a handle for the remote home object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.MessageDrivenBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.MessageDrivenBean

No usage of javax.ejb.MessageDrivenBean
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.MessageDrivenContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.MessageDrivenContext

  • Packages that use MessageDrivenContext
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of MessageDrivenContext in javax.ejb

      Methods in javax.ejb with parameters of type MessageDrivenContext
      Modifier and Type Method and Description
      void MessageDrivenBean.setMessageDrivenContext(MessageDrivenContext ctx)
      Set the associated message-driven context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.SessionBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.SessionBean

No usage of javax.ejb.SessionBean
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.SessionContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.SessionContext

  • Packages that use SessionContext
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of SessionContext in javax.ejb

      Methods in javax.ejb with parameters of type SessionContext
      Modifier and Type Method and Description
      void SessionBean.setSessionContext(SessionContext ctx)
      Set the associated session context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.SessionSynchronization (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.SessionSynchronization

No usage of javax.ejb.SessionSynchronization
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.TimedObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.TimedObject

No usage of javax.ejb.TimedObject
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.Timer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.Timer

  • Packages that use Timer
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of Timer in javax.ejb

      Methods in javax.ejb that return Timer
      Modifier and Type Method and Description
      Timer TimerService.createCalendarTimer(ScheduleExpression schedule)
      Create a calendar-based timer based on the input schedule expression.
      Timer TimerService.createCalendarTimer(ScheduleExpression schedule, TimerConfig timerConfig)
      Create a calendar-based timer based on the input schedule expression.
      Timer TimerService.createIntervalTimer(Date initialExpiration, long intervalDuration, TimerConfig timerConfig)
      Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
      Timer TimerService.createIntervalTimer(long initialDuration, long intervalDuration, TimerConfig timerConfig)
      Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
      Timer TimerService.createSingleActionTimer(Date expiration, TimerConfig timerConfig)
      Create a single-action timer that expires at a given point in time.
      Timer TimerService.createSingleActionTimer(long duration, TimerConfig timerConfig)
      Create a single-action timer that expires after a specified duration.
      Timer TimerService.createTimer(Date initialExpiration, long intervalDuration, Serializable info)
      Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
      Timer TimerService.createTimer(Date expiration, Serializable info)
      Create a single-action timer that expires at a given point in time.
      Timer TimerService.createTimer(long initialDuration, long intervalDuration, Serializable info)
      Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
      Timer TimerService.createTimer(long duration, Serializable info)
      Create a single-action timer that expires after a specified duration.
      Timer TimerHandle.getTimer()
      Obtain a reference to the timer represented by this handle.
      Methods in javax.ejb that return types with arguments of type Timer
      Modifier and Type Method and Description
      Collection<Timer> TimerService.getAllTimers()
      Returns all active timers associated with the beans in the same module in which the caller bean is packaged.
      Collection<Timer> TimerService.getTimers()
      Returns all active timers associated with this bean.
      Methods in javax.ejb with parameters of type Timer
      Modifier and Type Method and Description
      void TimedObject.ejbTimeout(Timer timer)
      Invoked by the EJB container upon timer expiration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.TimerHandle (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.TimerHandle

  • Packages that use TimerHandle
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of TimerHandle in javax.ejb

      Methods in javax.ejb that return TimerHandle
      Modifier and Type Method and Description
      TimerHandle Timer.getHandle()
      Get a serializable handle to the timer.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.TimerService (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.TimerService

  • Packages that use TimerService
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of TimerService in javax.ejb

      Methods in javax.ejb that return TimerService
      Modifier and Type Method and Description
      TimerService EJBContext.getTimerService()
      Get access to the EJB Timer Service.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


EJBContainer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb.embeddable

Class EJBContainer

  • java.lang.Object
    • javax.ejb.embeddable.EJBContainer
  • All Implemented Interfaces:
    AutoCloseable

    public abstract class EJBContainer
extends Object
implements AutoCloseable
    Used to execute an EJB application in an embeddable container.
    Since:
    EJB 3.1

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String APP_NAME
      Standard property name for specifying the application name of the EJB modules executing within the embeddable container.
      static String MODULES
      Standard property name for specifying the set of modules to be initialized.
      static String PROVIDER
      Standard property name for specifying the embeddable container implementation bootstrap class.

    • Constructor Summary

      Constructors
      Constructor and Description
      EJBContainer()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void close()
      Shutdown an embeddable EJBContainer instance.
      static EJBContainer createEJBContainer()
      Create and initialize an embeddable EJB container.
      static EJBContainer createEJBContainer(Map<?,?> properties)
      Create and initialize an embeddable EJB container with a set of configuration properties.
      abstract Context getContext()
      Retrieve a naming context for looking up references to session beans executing in the embeddable container.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • PROVIDER

        public static final String PROVIDER
        Standard property name for specifying the embeddable container implementation bootstrap class. Property value is a fully-qualified class name.
        See Also:
        Constant Field Values

      • MODULES

        public static final String MODULES
        Standard property name for specifying the set of modules to be initialized. Property value is one of the following :
        • a single module name String from the JVM classpath
        • a String[] array of module names from the JVM classpath
        • a java.io.File representing an ejb-jar or exploded ejb-jar directory
        • a java.io.File array, each element of which represents an ejb-jar or exploded ejb-jar directory
        See Also:
        Constant Field Values

      • APP_NAME

        public static final String APP_NAME
        Standard property name for specifying the application name of the EJB modules executing within the embeddable container. If specified, the property value applies to the <app-name> portion of the portable global JNDI name syntax. If this property is not specified, the <app-name> portion of the portable global JNDI name syntax does not apply.
        See Also:
        Constant Field Values

    • Constructor Detail

      • EJBContainer

        public EJBContainer()

    • Method Detail

      • createEJBContainer

        public static EJBContainer createEJBContainer()
        Create and initialize an embeddable EJB container. JVM classpath is searched for all ejb-jars or exploded ejb-jars in directory format.
        Returns:
        EJBContainer instance
        Throws:
        EJBException - Thrown if the container or application could not be successfully initialized.

      • createEJBContainer

        public static EJBContainer createEJBContainer(Map<?,?> properties)
        Create and initialize an embeddable EJB container with a set of configuration properties.
        Parameters:
        properties - Spec-defined and/or vendor-specific properties. The spec reserves the prefix "javax.ejb." for spec-defined properties.
        Returns:
        EJBContainer instance
        Throws:
        EJBException - Thrown if the container or application could not be successfully initialized.

      • getContext

        public abstract Context getContext()
        Retrieve a naming context for looking up references to session beans executing in the embeddable container.
        Returns:
        naming context

      • close

        public abstract void close()
        Shutdown an embeddable EJBContainer instance. Embeddable applications should always call close() in order to free up the resources associated with the embeddable container.
        Specified by:
        close in interface AutoCloseable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.ejb.embeddable (Java(TM) EE 7 Specification APIs)

javax.ejb.embeddable

Classes

  • EJBContainer


javax.ejb.embeddable (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.ejb.embeddable

Defines the classes for the EJB Embeddable API.

See: Description

  • Class Summary
    Class Description
    EJBContainer
    Used to execute an EJB application in an embeddable container.

Package javax.ejb.embeddable Description

Defines the classes for the EJB Embeddable API.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.ejb.embeddable Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.ejb.embeddable

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.ejb.embeddable.EJBContainer (implements java.lang.AutoCloseable)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.ejb.embeddable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.ejb.embeddable

  • Packages that use javax.ejb.embeddable
    Package Description
    javax.ejb.embeddable
    Defines the classes for the EJB Embeddable API.
    javax.ejb.spi
    Defines interfaces that are implemented by the EJB container.
  • Classes in javax.ejb.embeddable used by javax.ejb.embeddable
    Class and Description
    EJBContainer
    Used to execute an EJB application in an embeddable container.
  • Classes in javax.ejb.embeddable used by javax.ejb.spi
    Class and Description
    EJBContainer
    Used to execute an EJB application in an embeddable container.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ejb.embeddable.EJBContainer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ejb.embeddable.EJBContainer

  • Packages that use EJBContainer
    Package Description
    javax.ejb.embeddable
    Defines the classes for the EJB Embeddable API.
    javax.ejb.spi
    Defines interfaces that are implemented by the EJB container.

    • Uses of EJBContainer in javax.ejb.embeddable

      Methods in javax.ejb.embeddable that return EJBContainer
      Modifier and Type Method and Description
      static EJBContainer EJBContainer.createEJBContainer()
      Create and initialize an embeddable EJB container.
      static EJBContainer EJBContainer.createEJBContainer(Map<?,?> properties)
      Create and initialize an embeddable EJB container with a set of configuration properties.

    • Uses of EJBContainer in javax.ejb.spi

      Methods in javax.ejb.spi that return EJBContainer
      Modifier and Type Method and Description
      EJBContainer EJBContainerProvider.createEJBContainer(Map<?,?> properties)
      Called by the embeddable container bootstrap process to find a suitable embeddable container implementation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


EJBContainerProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb.spi

Interface EJBContainerProvider

  • public interface EJBContainerProvider
    The EJBContainerProvider SPI is used by the embeddable container bootstrap class to initialize a suitable embeddable container.
    Since:
    EJB 3.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EJBContainer createEJBContainer(Map<?,?> properties)
      Called by the embeddable container bootstrap process to find a suitable embeddable container implementation.

    • Method Detail

      • createEJBContainer

        EJBContainer createEJBContainer(Map<?,?> properties)
                                throws EJBException
        Called by the embeddable container bootstrap process to find a suitable embeddable container implementation. An embeddable container provider may deem itself as appropriate for the embeddable application if any of the following are true :
        • The javax.ejb.embeddable.provider property was included in the Map passed to createEJBContainer and the value of the property is the provider's implementation class.
        • No javax.ejb.embeddable.provider property was specified.
        If a provider does not qualify as the provider for the embeddable application, it must return null.
        Parameters:
        properties - Spec-defined and/or vendor-specific properties, that were passed to javax.ejb.embeddable.EJBContainer#createEJBContainer(Map<?,?>) call
        Returns:
        EJBContainer instance or null
        Throws:
        EJBException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HandleDelegate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ejb.spi

Interface HandleDelegate

  • public interface HandleDelegate
    The HandleDelegate interface is implemented by the EJB container. It is used by portable implementations of javax.ejb.Handle and javax.ejb.HomeHandle. It is not used by EJB components or by client components. It provides methods to serialize and deserialize EJBObject and EJBHome references to streams.

    The HandleDelegate object is obtained by JNDI lookup at the reserved name "java:comp/HandleDelegate".

    Since:
    EJB 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EJBHome readEJBHome(ObjectInputStream istream)
      Deserialize the EJBHome reference corresponding to a HomeHandle.
      EJBObject readEJBObject(ObjectInputStream istream)
      Deserialize the EJBObject reference corresponding to a Handle.
      void writeEJBHome(EJBHome ejbHome, ObjectOutputStream ostream)
      Serialize the EJBHome reference corresponding to a HomeHandle.
      void writeEJBObject(EJBObject ejbObject, ObjectOutputStream ostream)
      Serialize the EJBObject reference corresponding to a Handle.

    • Method Detail

      • writeEJBObject

        void writeEJBObject(EJBObject ejbObject,
                  ObjectOutputStream ostream)
                    throws IOException
        Serialize the EJBObject reference corresponding to a Handle.

        This method is called from the writeObject method of portable Handle implementation classes. The ostream object is the same object that was passed in to the Handle class's writeObject method.

        Parameters:
        ejbObject - The EJBObject reference to be serialized.
        ostream - The output stream.
        Throws:
        IOException - The EJBObject could not be serialized because of a system-level failure.

      • readEJBObject

        EJBObject readEJBObject(ObjectInputStream istream)
                        throws IOException,
                               ClassNotFoundException
        Deserialize the EJBObject reference corresponding to a Handle.

        The readEJBObject method is called from the readObject method of portable Handle implementation classes. The istream object is the same object that was passed in to the Handle class's readObject method. WhenreadEJBObject is called, istream must point to the location in the stream at which the EJBObject reference can be read. The container must ensure that the EJBObject reference is capable of performing invocations immediately after deserialization.

        Parameters:
        istream - The input stream.
        Returns:
        The deserialized EJBObject reference.
        Throws:
        IOException - The EJBObject could not be deserialized because of a system-level failure.
        ClassNotFoundException - The EJBObject could not be deserialized because some class could not be found.

      • writeEJBHome

        void writeEJBHome(EJBHome ejbHome,
                ObjectOutputStream ostream)
                  throws IOException
        Serialize the EJBHome reference corresponding to a HomeHandle.

        This method is called from the writeObject method of portable HomeHandle implementation classes. The ostream object is the same object that was passed in to the Handle class's writeObject method.

        Parameters:
        ejbHome - The EJBHome reference to be serialized.
        ostream - The output stream.
        Throws:
        IOException - The EJBObject could not be serialized because of a system-level failure.

      • readEJBHome

        EJBHome readEJBHome(ObjectInputStream istream)
                    throws IOException,
                           ClassNotFoundException
        Deserialize the EJBHome reference corresponding to a HomeHandle.

        The readEJBHome method is called from the readObject method of portable HomeHandle implementation classes. The istream object is the same object that was passed in to the HomeHandle class's readObject method. When readEJBHome is called, istream must point to the location in the stream at which the EJBHome reference can be read. The container must ensure that the EJBHome reference is capable of performing invocations immediately after deserialization.

        Parameters:
        istream - The input stream.
        Returns:
        The deserialized EJBHome reference.
        Throws:
        IOException - The EJBHome could not be deserialized because of a system-level failure.
        ClassNotFoundException - The EJBHome could not be deserialized because some class could not be found.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.ejb.spi (Java(TM) EE 7 Specification APIs)

javax.ejb.spi

Interfaces

  • EJBContainerProvider
  • HandleDelegate


javax.ejb.spi (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.ejb.spi

Defines interfaces that are implemented by the EJB container.

See: Description

  • Interface Summary
    Interface Description
    EJBContainerProvider
    The EJBContainerProvider SPI is used by the embeddable container bootstrap class to initialize a suitable embeddable container.
    HandleDelegate
    The HandleDelegate interface is implemented by the EJB container.

Package javax.ejb.spi Description

Defines interfaces that are implemented by the EJB container. These interfaces are not used by application components.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.ejb.spi Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.ejb.spi

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.ejb.spi.EJBContainerProvider
  • javax.ejb.spi.HandleDelegate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.ejb.spi (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.ejb.spi

No usage of javax.ejb.spi
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.spi.EJBContainerProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.spi.EJBContainerProvider

No usage of javax.ejb.spi.EJBContainerProvider
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ejb.spi.HandleDelegate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ejb.spi.HandleDelegate

No usage of javax.ejb.spi.HandleDelegate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ArrayELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ArrayELResolver

  • java.lang.Object
    • javax.el.ELResolver
      • javax.el.ArrayELResolver

  • public class ArrayELResolver
extends ELResolver
    Defines property resolution behavior on arrays.

    This resolver handles base objects that are Java language arrays. It accepts any object as a property and coerces that object into an integer index into the array. The resulting value is the value in the array at that index.

    This resolver can be constructed in read-only mode, which means that isReadOnly will always return true and setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always throw PropertyNotWritableException.

    ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression. See the javadocs for ELResolver for details.

    Since:
    JSP 2.1
    See Also:
    CompositeELResolver, ELResolver

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      ArrayELResolver()
      Creates a new read/write ArrayELResolver.
      ArrayELResolver(boolean isReadOnly)
      Creates a new ArrayELResolver whose read-only status is determined by the given parameter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getCommonPropertyType(ELContext context, Object base)
      If the base object is a Java language array, returns the most general type that this resolver accepts for the property argument.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      Always returns null, since there is no reason to iterate through set set of all integers.
      Class<?> getType(ELContext context, Object base, Object property)
      If the base object is an array, returns the most general acceptable type for a value in this array.
      Object getValue(ELContext context, Object base, Object property)
      If the base object is a Java language array, returns the value at the given index.
      boolean isReadOnly(ELContext context, Object base, Object property)
      If the base object is a Java language array, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      void setValue(ELContext context, Object base, Object property, Object val)
      If the base object is a Java language array, attempts to set the value at the given index with the given value.

      • Methods inherited from class javax.el.ELResolver

        convertToType, invoke

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ArrayELResolver

        public ArrayELResolver()
        Creates a new read/write ArrayELResolver.

      • ArrayELResolver

        public ArrayELResolver(boolean isReadOnly)
        Creates a new ArrayELResolver whose read-only status is determined by the given parameter.
        Parameters:
        isReadOnly - true if this resolver cannot modify arrays; false otherwise.

    • Method Detail

      • getType

        public Class<?> getType(ELContext context,
               Object base,
               Object property)
        If the base object is an array, returns the most general acceptable type for a value in this array.

        If the base is a array, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Assuming the base is an array, this method will always return base.getClass().getComponentType(), which is the most general type of component that can be stored at any given index in the array.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The array to analyze. Only bases that are Java language arrays are handled by this resolver.
        property - The index of the element in the array to return the acceptable type for. Will be coerced into an integer, but otherwise ignored by this resolver.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
        Throws:
        PropertyNotFoundException - if the given index is out of bounds for this array.
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)
        If the base object is a Java language array, returns the value at the given index. The index is specified by the property argument, and coerced into an integer. If the coercion could not be performed, an IllegalArgumentException is thrown. If the index is out of bounds, null is returned.

        If the base is a Java language array, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The array to analyze. Only bases that are Java language arrays are handled by this resolver.
        property - The index of the value to be returned. Will be coerced into an integer.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the value at the given index or null if the index was out of bounds. Otherwise, undefined.
        Throws:
        IllegalArgumentException - if the property could not be coerced into an integer.
        NullPointerException - if context is null.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object val)
        If the base object is a Java language array, attempts to set the value at the given index with the given value. The index is specified by the property argument, and coerced into an integer. If the coercion could not be performed, an IllegalArgumentException is thrown. If the index is out of bounds, a PropertyNotFoundException is thrown.

        If the base is a Java language array, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value was set.

        If this resolver was constructed in read-only mode, this method will always throw PropertyNotWritableException.

        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The array to be modified. Only bases that are Java language arrays are handled by this resolver.
        property - The index of the value to be set. Will be coerced into an integer.
        val - The value to be set at the given index.
        Throws:
        ClassCastException - if the class of the specified element prevents it from being added to this array.
        NullPointerException - if context is null.
        IllegalArgumentException - if the property could not be coerced into an integer, or if some aspect of the specified element prevents it from being added to this array.
        PropertyNotWritableException - if this resolver was constructed in read-only mode.
        PropertyNotFoundException - if the given index is out of bounds for this array.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        If the base object is a Java language array, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

        If the base is a Java language array, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        If this resolver was constructed in read-only mode, this method will always return true. Otherwise, it returns false.

        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The array to analyze. Only bases that are a Java language array are handled by this resolver.
        property - The index of the element in the array to return the acceptable type for. Will be coerced into an integer, but otherwise ignored by this resolver.
        Returns:
        If the propertyResolved property of ELContext was set to true, then true if calling the setValue method will always fail or false if it is possible that such a call may succeed; otherwise undefined.
        Throws:
        PropertyNotFoundException - if the given index is out of bounds for this array.
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        Always returns null, since there is no reason to iterate through set set of all integers.

        The getCommonPropertyType(javax.el.ELContext, java.lang.Object) method returns sufficient information about what properties this resolver accepts.

        Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The array to analyze. Only bases that are a Java language array are handled by this resolver.
        Returns:
        null.
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<?> getCommonPropertyType(ELContext context,
                             Object base)
        If the base object is a Java language array, returns the most general type that this resolver accepts for the property argument. Otherwise, returns null.

        Assuming the base is an array, this method will always return Integer.class. This is because arrays accept integers for their index.

        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The array to analyze. Only bases that are a Java language array are handled by this resolver.
        Returns:
        null if base is not a Java language array; otherwise Integer.class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BeanELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class BeanELResolver

  • java.lang.Object
    • javax.el.ELResolver
      • javax.el.BeanELResolver

  • public class BeanELResolver
extends ELResolver
    Defines property resolution behavior on objects using the JavaBeans component architecture.

    This resolver handles base objects of any type, as long as the base is not null. It accepts any object as a property or method, and coerces it to a string.

    For property resolution, the property string is used to find a JavaBeans compliant property on the base object. The value is accessed using JavaBeans getters and setters.

    For method resolution, the method string is the name of the method in the bean. The parameter types can be optionally specified to identify the method. If the parameter types are not specified, the parameter objects are used in the method resolution.

    This resolver can be constructed in read-only mode, which means that isReadOnly will always return true and setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always throw PropertyNotWritableException.

    ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression. See the javadocs for ELResolver for details.

    Because this resolver handles base objects of any type, it should be placed near the end of a composite resolver. Otherwise, it will claim to have resolved a property before any resolvers that come after it get a chance to test if they can do so as well.

    Since:
    JSP 2.1
    See Also:
    CompositeELResolver, ELResolver

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      BeanELResolver()
      Creates a new read/write BeanELResolver.
      BeanELResolver(boolean isReadOnly)
      Creates a new BeanELResolver whose read-only status is determined by the given parameter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getCommonPropertyType(ELContext context, Object base)
      If the base object is not null, returns the most general type that this resolver accepts for the property argument.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      If the base object is not null, returns an Iterator containing the set of JavaBeans properties available on the given object.
      Class<?> getType(ELContext context, Object base, Object property)
      If the base object is not null, returns the most general acceptable type that can be set on this bean property.
      Object getValue(ELContext context, Object base, Object property)
      If the base object is not null, returns the current value of the given property on this bean.
      Object invoke(ELContext context, Object base, Object method, Class<?>[] paramTypes, Object[] params)
      If the base object is not null, invoke the method, with the given parameters on this bean.
      boolean isReadOnly(ELContext context, Object base, Object property)
      If the base object is not null, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      void setValue(ELContext context, Object base, Object property, Object val)
      If the base object is not null, attempts to set the value of the given property on this bean.

      • Methods inherited from class javax.el.ELResolver

        convertToType

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BeanELResolver

        public BeanELResolver()
        Creates a new read/write BeanELResolver.

      • BeanELResolver

        public BeanELResolver(boolean isReadOnly)
        Creates a new BeanELResolver whose read-only status is determined by the given parameter.
        Parameters:
        isReadOnly - true if this resolver cannot modify beans; false otherwise.

    • Method Detail

      • getType

        public Class<?> getType(ELContext context,
               Object base,
               Object property)
        If the base object is not null, returns the most general acceptable type that can be set on this bean property.

        If the base is not null, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        The provided property will first be coerced to a String. If there is a BeanInfoProperty for this property and there were no errors retrieving it, the propertyType of the propertyDescriptor is returned. Otherwise, a PropertyNotFoundException is thrown.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The bean to analyze.
        property - The name of the property to analyze. Will be coerced to a String.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if base is not null and the specified property does not exist or is not readable.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)
        If the base object is not null, returns the current value of the given property on this bean.

        If the base is not null, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        The provided property name will first be coerced to a String. If the property is a readable property of the base object, as per the JavaBeans specification, then return the result of the getter call. If the getter throws an exception, it is propagated to the caller. If the property is not found or is not readable, a PropertyNotFoundException is thrown.

        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The bean on which to get the property.
        property - The name of the property to get. Will be coerced to a String.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the value of the given property. Otherwise, undefined.
        Throws:
        NullPointerException - if context is null.
        PropertyNotFoundException - if base is not null and the specified property does not exist or is not readable.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object val)
        If the base object is not null, attempts to set the value of the given property on this bean.

        If the base is not null, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value was set.

        If this resolver was constructed in read-only mode, this method will always throw PropertyNotWritableException.

        The provided property name will first be coerced to a String. If property is a writable property of base (as per the JavaBeans Specification), the setter method is called (passing value). If the property exists but does not have a setter, then a PropertyNotFoundException is thrown. If the property does not exist, a PropertyNotFoundException is thrown.

        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The bean on which to set the property.
        property - The name of the property to set. Will be coerced to a String.
        val - The value to be associated with the specified key.
        Throws:
        NullPointerException - if context is null.
        PropertyNotFoundException - if base is not null and the specified property does not exist.
        PropertyNotWritableException - if this resolver was constructed in read-only mode, or if there is no setter for the property.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • invoke

        public Object invoke(ELContext context,
            Object base,
            Object method,
            Class<?>[] paramTypes,
            Object[] params)
        If the base object is not null, invoke the method, with the given parameters on this bean. The return value from the method is returned.

        If the base is not null, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        The provided method object will first be coerced to a String. The methods in the bean is then examined and an attempt will be made to select one for invocation. If no suitable can be found, a MethodNotFoundException is thrown. If the given paramTypes is not null, select the method with the given name and parameter types. Else select the method with the given name that has the same number of parameters. If there are more than one such method, the method selection process is undefined. Else select the method with the given name that takes a variable number of arguments. Note the resolution for overloaded methods will likely be clarified in a future version of the spec. The provide parameters are coerced to the corresponding parameter types of the method, and the method is then invoked.

        Overrides:
        invoke in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The bean on which to invoke the method
        method - The simple name of the method to invoke. Will be coerced to a String. If method is "<init>"or "<clinit>" a MethodNotFoundException is thrown.
        paramTypes - An array of Class objects identifying the method's formal parameter types, in declared order. Use an empty array if the method has no parameters. Can be null, in which case the method's formal parameter types are assumed to be unknown.
        params - The parameters to pass to the method, or null if no parameters.
        Returns:
        The result of the method invocation (null if the method has a void return type).
        Throws:
        MethodNotFoundException - if no suitable method can be found.
        ELException - if an exception was thrown while performing (base, method) resolution. The thrown exception must be included as the cause property of this exception, if available. If the exception thrown is an InvocationTargetException, extract its cause and pass it to the ELException constructor.
        Since:
        EL 2.2

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        If the base object is not null, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

        If the base is not null, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value was set.

        If this resolver was constructed in read-only mode, this method will always return true.

        The provided property name will first be coerced to a String. If property is a writable property of base, false is returned. If the property is found but is not writable, true is returned. If the property is not found, a PropertyNotFoundException is thrown.

        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The bean to analyze.
        property - The name of the property to analyzed. Will be coerced to a String.
        Returns:
        If the propertyResolved property of ELContext was set to true, then true if calling the setValue method will always fail or false if it is possible that such a call may succeed; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if base is not null and the specified property does not exist.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        If the base object is not null, returns an Iterator containing the set of JavaBeans properties available on the given object. Otherwise, returns null.

        The Iterator returned must contain zero or more instances of FeatureDescriptor. Each info object contains information about a property in the bean, as obtained by calling the BeanInfo.getPropertyDescriptors method. The FeatureDescriptor is initialized using the same fields as are present in the PropertyDescriptor, with the additional required named attributes "type" and "resolvableAtDesignTime" set as follows:

      • ELResolver.TYPE - The runtime type of the property, from PropertyDescriptor.getPropertyType().
      • ELResolver.RESOLVABLE_AT_DESIGN_TIME - true.

        • Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The bean to analyze.
        Returns:
        An Iterator containing zero or more FeatureDescriptor objects, each representing a property on this bean, or null if the base object is null.
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<?> getCommonPropertyType(ELContext context,
                             Object base)
        If the base object is not null, returns the most general type that this resolver accepts for the property argument. Otherwise, returns null.

        Assuming the base is not null, this method will always return Object.class. This is because any object is accepted as a key and is coerced into a string.

        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The bean to analyze.
        Returns:
        null if base is null; otherwise Object.class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BeanNameELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class BeanNameELResolver

  • java.lang.Object
    • javax.el.ELResolver
      • javax.el.BeanNameELResolver

  • public class BeanNameELResolver
extends ELResolver

    An ELResolver for resolving user or container managed beans.

    A BeanNameResolver is required for its proper operation. The following example creates an ELResolver that resolves the name "bean" to an instance of MyBean.

     ELResovler elr = new BeanNameELResolver(new BeanNameResolver {
    public boolean isNameResolved(String beanName) {
       return "bean".equals(beanName);
    }
    public Object getBean(String beanName) {
       return "bean".equals(beanName)? new MyBean(): null;
    }
 });

    Since:
    EL 3.0

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      BeanNameELResolver(BeanNameResolver beanNameResolver)
      Constructor

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getCommonPropertyType(ELContext context, Object base)
      Always returns String.class, since a bean name is a String.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      Always returns null, since there is no reason to iterate through a list of one element: bean name.
      Class<?> getType(ELContext context, Object base, Object property)
      If the base is null and the property is a name resolvable by the BeanNameResolver, return the type of the bean.
      Object getValue(ELContext context, Object base, Object property)
      If the base object is null and the property is a name that is resolvable by the BeanNameResolver, returns the value resolved by the BeanNameResolver.
      boolean isReadOnly(ELContext context, Object base, Object property)
      If the base is null and the property is a name resolvable by the BeanNameResolver, attempts to determine if the bean is writable.
      void setValue(ELContext context, Object base, Object property, Object value)
      If the base is null and the property is a name that is resolvable by the BeanNameResolver, the bean in the BeanNameResolver is set to the given value.

      • Methods inherited from class javax.el.ELResolver

        convertToType, invoke

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BeanNameELResolver

        public BeanNameELResolver(BeanNameResolver beanNameResolver)
        Constructor
        Parameters:
        beanNameResolver - The BeanNameResolver that resolves a bean name.

    • Method Detail

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)
        If the base object is null and the property is a name that is resolvable by the BeanNameResolver, returns the value resolved by the BeanNameResolver.

        If name is resolved by the BeanNameResolver, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - null
        property - The name of the bean.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the value of the bean with the given name. Otherwise, undefined.
        Throws:
        NullPointerException - if context is null.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object value)
        If the base is null and the property is a name that is resolvable by the BeanNameResolver, the bean in the BeanNameResolver is set to the given value.

        If the name is resolvable by the BeanNameResolver, or if the BeanNameResolver allows creating a new bean, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value has been set.

        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - null
        property - The name of the bean
        value - The value to set the bean with the given name to.
        Throws:
        NullPointerException - if context is null
        PropertyNotWritableException - if the BeanNameResolver does not allow the bean to be modified.
        ELException - if an exception was thrown while attempting to set the bean with the given name. The thrown exception must be included as the cause property of this exception, if available.

      • getType

        public Class<?> getType(ELContext context,
               Object base,
               Object property)
        If the base is null and the property is a name resolvable by the BeanNameResolver, return the type of the bean.

        If the name is resolvable by the BeanNameResolver, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value has been set.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - null
        property - The name of the bean.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the type of the bean with the given name. Otherwise, undefined.
        Throws:
        NullPointerException - if context is null.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        If the base is null and the property is a name resolvable by the BeanNameResolver, attempts to determine if the bean is writable.

        If the name is resolvable by the BeanNameResolver, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value has been set.

        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - null
        property - The name of the bean.
        Returns:
        If the propertyResolved property of ELContext was set to true, then true if the property is read-only or false if not; otherwise undefined.
        Throws:
        NullPointerException - if context is null.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        Always returns null, since there is no reason to iterate through a list of one element: bean name.
        Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - null.
        Returns:
        null.
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<?> getCommonPropertyType(ELContext context,
                             Object base)
        Always returns String.class, since a bean name is a String.
        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - null.
        Returns:
        String.class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BeanNameResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class BeanNameResolver

  • java.lang.Object
    • javax.el.BeanNameResolver

  • public abstract class BeanNameResolver
extends Object
    Resolves a bean by its known name. This class can be extended to return a bean object given its name, to set a value to an existing bean, or to create a bean with the value.
    Since:
    EL 3.0
    See Also:
    BeanNameELResolver

    • Constructor Summary

      Constructors
      Constructor and Description
      BeanNameResolver()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean canCreateBean(String beanName)
      Allow creating a bean of the given name if it does not exist.
      Object getBean(String beanName)
      Returns the bean known by its name.
      boolean isNameResolved(String beanName)
      Returns whether the given name is resolved by the BeanNameResolver
      boolean isReadOnly(String beanName)
      Indicates if the bean of the given name is read-only or writable
      void setBeanValue(String beanName, Object value)
      Sets a value to a bean of the given name.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BeanNameResolver

        public BeanNameResolver()

    • Method Detail

      • isNameResolved

        public boolean isNameResolved(String beanName)
        Returns whether the given name is resolved by the BeanNameResolver
        Parameters:
        beanName - The name of the bean.
        Returns:
        true if the name is resolved by this BeanNameResolver; false otherwise.

      • getBean

        public Object getBean(String beanName)
        Returns the bean known by its name.
        Parameters:
        beanName - The name of the bean.
        Returns:
        The bean with the given name. Can be null.

      • setBeanValue

        public void setBeanValue(String beanName,
                Object value)
                  throws PropertyNotWritableException
        Sets a value to a bean of the given name. If the bean of the given name does not exist and if canCreateBean(java.lang.String) is true, one is created with the given value.
        Parameters:
        beanName - The name of the bean
        value - The value to set the bean to. Can be null.
        Throws:
        PropertyNotWritableException - if the bean cannot be modified or created.

      • isReadOnly

        public boolean isReadOnly(String beanName)
        Indicates if the bean of the given name is read-only or writable
        Parameters:
        beanName - The name of the bean
        Returns:
        true if the bean can be set to a new value. false otherwise.

      • canCreateBean

        public boolean canCreateBean(String beanName)
        Allow creating a bean of the given name if it does not exist.
        Parameters:
        beanName - The name of the bean
        Returns:
        true if bean creation is supported false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CompositeELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class CompositeELResolver

  • java.lang.Object
    • javax.el.ELResolver
      • javax.el.CompositeELResolver

  • public class CompositeELResolver
extends ELResolver
    Maintains an ordered composite list of child ELResolvers.

    Though only a single ELResolver is associated with an ELContext, there are usually multiple resolvers considered for any given variable or property resolution. ELResolvers are combined together using a CompositeELResolver, to define rich semantics for evaluating an expression.

    For the getValue(javax.el.ELContext, java.lang.Object, java.lang.Object), getType(javax.el.ELContext, java.lang.Object, java.lang.Object), setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) and isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object) methods, an ELResolver is not responsible for resolving all possible (base, property) pairs. In fact, most resolvers will only handle a base of a single type. To indicate that a resolver has successfully resolved a particular (base, property) pair, it must set the propertyResolved property of the ELContext to true. If it could not handle the given pair, it must leave this property alone. The caller must ignore the return value of the method if propertyResolved is false.

    The CompositeELResolver initializes the ELContext.propertyResolved flag to false, and uses it as a stop condition for iterating through its component resolvers.

    The ELContext.propertyResolved flag is not used for the design-time methods getFeatureDescriptors(javax.el.ELContext, java.lang.Object) and getCommonPropertyType(javax.el.ELContext, java.lang.Object). Instead, results are collected and combined from all child ELResolvers for these methods.

    Since:
    JSP 2.1
    See Also:
    ELContext, ELResolver

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      CompositeELResolver()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void add(ELResolver elResolver)
      Adds the given resolver to the list of component resolvers.
      Object convertToType(ELContext context, Object obj, Class<?> targetType)
      Converts an object to a specific type.
      Class<?> getCommonPropertyType(ELContext context, Object base)
      Returns the most general type that this resolver accepts for the property argument, given a base object.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      Returns information about the set of variables or properties that can be resolved for the given base object.
      Class<?> getType(ELContext context, Object base, Object property)
      For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.
      Object getValue(ELContext context, Object base, Object property)
      Attempts to resolve the given property object on the given base object by querying all component resolvers.
      Object invoke(ELContext context, Object base, Object method, Class<?>[] paramTypes, Object[] params)
      Attemps to resolve and invoke the given method on the given base object by querying all component resolvers.
      boolean isReadOnly(ELContext context, Object base, Object property)
      For a given base and property, attempts to determine whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      void setValue(ELContext context, Object base, Object property, Object val)
      Attempts to set the value of the given property object on the given base object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CompositeELResolver

        public CompositeELResolver()

    • Method Detail

      • add

        public void add(ELResolver elResolver)
        Adds the given resolver to the list of component resolvers.

        Resolvers are consulted in the order in which they are added.

        Parameters:
        elResolver - The component resolver to add.
        Throws:
        NullPointerException - If the provided resolver is null.

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)
        Attempts to resolve the given property object on the given base object by querying all component resolvers.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        First, propertyResolved is set to false on the provided ELContext.

        Next, for each component resolver in this composite:

        1. The getValue() method is called, passing in the provided context, base and property.
        2. If the ELContext's propertyResolved flag is false then iteration continues.
        3. Otherwise, iteration stops and no more component resolvers are considered. The value returned by getValue() is returned by this method.

        If none of the component resolvers were able to perform this operation, the value null is returned and the propertyResolved flag remains set to false

        .

        Any exception thrown by component resolvers during the iteration is propagated to the caller of this method.

        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be returned, or null to resolve a top-level variable.
        property - The property or variable to be resolved.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the result of the variable or property resolution; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist or is not readable.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • invoke

        public Object invoke(ELContext context,
            Object base,
            Object method,
            Class<?>[] paramTypes,
            Object[] params)
        Attemps to resolve and invoke the given method on the given base object by querying all component resolvers.

        If this resolver handles the given (base, method) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        First, propertyResolved is set to false on the provided ELContext.

        Next, for each component resolver in this composite:

        1. The invoke() method is called, passing in the provided context, base, method, paramTypes, and params.
        2. If the ELContext's propertyResolved flag is false then iteration continues.
        3. Otherwise, iteration stops and no more component resolvers are considered. The value returned by getValue() is returned by this method.

        If none of the component resolvers were able to perform this operation, the value null is returned and the propertyResolved flag remains set to false

        .

        Any exception thrown by component resolvers during the iteration is propagated to the caller of this method.

        Overrides:
        invoke in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The bean on which to invoke the method
        method - The simple name of the method to invoke. Will be coerced to a String.
        paramTypes - An array of Class objects identifying the method's formal parameter types, in declared order. Use an empty array if the method has no parameters. Can be null, in which case the method's formal parameter types are assumed to be unknown.
        params - The parameters to pass to the method, or null if no parameters.
        Returns:
        The result of the method invocation (null if the method has a void return type).
        Since:
        EL 2.2

      • getType

        public Class<?> getType(ELContext context,
               Object base,
               Object property)
        For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method. The result is obtained by querying all component resolvers.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        First, propertyResolved is set to false on the provided ELContext.

        Next, for each component resolver in this composite:

        1. The getType() method is called, passing in the provided context, base and property.
        2. If the ELContext's propertyResolved flag is false then iteration continues.
        3. Otherwise, iteration stops and no more component resolvers are considered. The value returned by getType() is returned by this method.

        If none of the component resolvers were able to perform this operation, the value null is returned and the propertyResolved flag remains set to false

        .

        Any exception thrown by component resolvers during the iteration is propagated to the caller of this method.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be analyzed, or null to analyze a top-level variable.
        property - The property or variable to return the acceptable type for.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist or is not readable.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object val)
        Attempts to set the value of the given property object on the given base object. All component resolvers are asked to attempt to set the value.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value has been set.

        First, propertyResolved is set to false on the provided ELContext.

        Next, for each component resolver in this composite:

        1. The setValue() method is called, passing in the provided context, base, property and value.
        2. If the ELContext's propertyResolved flag is false then iteration continues.
        3. Otherwise, iteration stops and no more component resolvers are considered.

        If none of the component resolvers were able to perform this operation, the propertyResolved flag remains set to false

        .

        Any exception thrown by component resolvers during the iteration is propagated to the caller of this method.

        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be set, or null to set a top-level variable.
        property - The property or variable to be set.
        val - The value to set the property or variable to.
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist.
        PropertyNotWritableException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property is not writable.
        ELException - if an exception was thrown while attempting to set the property or variable. The thrown exception must be included as the cause property of this exception, if available.

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        For a given base and property, attempts to determine whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail. The result is obtained by querying all component resolvers.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        First, propertyResolved is set to false on the provided ELContext.

        Next, for each component resolver in this composite:

        1. The isReadOnly() method is called, passing in the provided context, base and property.
        2. If the ELContext's propertyResolved flag is false then iteration continues.
        3. Otherwise, iteration stops and no more component resolvers are considered. The value returned by isReadOnly() is returned by this method.

        If none of the component resolvers were able to perform this operation, the value false is returned and the propertyResolved flag remains set to false

        .

        Any exception thrown by component resolvers during the iteration is propagated to the caller of this method.

        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be analyzed, or null to analyze a top-level variable.
        property - The property or variable to return the read-only status for.
        Returns:
        If the propertyResolved property of ELContext was set to true, then true if the property is read-only or false if not; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        Returns information about the set of variables or properties that can be resolved for the given base object. One use for this method is to assist tools in auto-completion. The results are collected from all component resolvers.

        The propertyResolved property of the ELContext is not relevant to this method. The results of all ELResolvers are concatenated.

        The Iterator returned is an iterator over the collection of FeatureDescriptor objects returned by the iterators returned by each component resolver's getFeatureDescriptors method. If null is returned by a resolver, it is skipped.

        Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object whose set of valid properties is to be enumerated, or null to enumerate the set of top-level variables that this resolver can evaluate.
        Returns:
        An Iterator containing zero or more (possibly infinitely more) FeatureDescriptor objects, or null if this resolver does not handle the given base object or that the results are too complex to represent with this method
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<?> getCommonPropertyType(ELContext context,
                             Object base)
        Returns the most general type that this resolver accepts for the property argument, given a base object. One use for this method is to assist tools in auto-completion. The result is obtained by querying all component resolvers.

        The Class returned is the most specific class that is a common superclass of all the classes returned by each component resolver's getCommonPropertyType method. If null is returned by a resolver, it is skipped.

        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object to return the most general property type for, or null to enumerate the set of top-level variables that this resolver can evaluate.
        Returns:
        null if this ELResolver does not know how to handle the given base object; otherwise Object.class if any type of property is accepted; otherwise the most general property type accepted for the given base.

      • convertToType

        public Object convertToType(ELContext context,
                   Object obj,
                   Class<?> targetType)
        Converts an object to a specific type.

        An ELException is thrown if an error occurs during the conversion.

        Overrides:
        convertToType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        obj - The object to convert.
        targetType - The target type for the convertion.
        Throws:
        ELException - thrown if errors occur.
        Since:
        EL 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ELClass (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ELClass

  • java.lang.Object
    • javax.el.ELClass

  • public class ELClass
extends Object

    A runtime representation of a Class in the EL expressions. It encapsulates the java.lang.Class instance.

    This class is used only in StaticFieldELResolver and will probably only be of interest to EL implementors, and not EL users.

    Since:
    EL 3.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ELClass(Class<?> klass)
      Constructor

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getKlass()
      Returns the Class instance

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ELClass

        public ELClass(Class<?> klass)
        Constructor
        Parameters:
        klass - The Class instance

    • Method Detail

      • getKlass

        public Class<?> getKlass()
        Returns the Class instance
        Returns:
        The Class instance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ELContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ELContext

  • java.lang.Object
    • javax.el.ELContext
  • Direct Known Subclasses:
    FaceletContext, StandardELContext

    public abstract class ELContext
extends Object
    Context information for expression parsing and evaluation.

    To parse or evaluate an Expression, an ELContext must be provided. The ELContext holds:

    • a reference to FunctionMapper that will be used to resolve EL Functions. This is used only in parsing.
    • a reference to VariableMapper that will be used to resolve EL Variables. This is used only in parsing.
    • a reference to the base ELResolver that will be consulted to resolve model objects and their properties
    • a collection of all the relevant context objects for use by ELResolvers
    • state information during the evaluation of an expression, such as whether a property has been resolved yet
    • a reference to ImportHandler that will be consulted to resolve classes that have been imported
    • a reference to the arguments for the active LambdaExpressions
    • a reference to the list of registered evaluation listeners

    The collection of context objects is necessary because each ELResolver may need access to a different context object. For example, JSP and Faces resolvers need access to a JspContext and a FacesContext, respectively.

    When used in a web container, the creation of ELContext objects is controlled through the underlying technology. For example, in JSP the JspContext.getELContext() factory method is used. Some technologies provide the ability to add an ELContextListener so that applications and frameworks can ensure their own context objects are attached to any newly created ELContext.

    When used in a stand-alone environment, StandardELContext provides a default ELContext, which is managed and modified by ELManager.

    Because it stores state during expression evaluation, an ELContext object is not thread-safe. Care should be taken to never share an ELContext instance between two or more threads.

    Since:
    EL 2.1 and EL 3.0
    See Also:
    ELContextListener, ELContextEvent, ELResolver, FunctionMapper, VariableMapper, ImportHandler, LambdaExpression, StandardELContext, JspContext

    • Constructor Summary

      Constructors
      Constructor and Description
      ELContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addEvaluationListener(EvaluationListener listener)
      Registers an evaluation listener to the ELContext.
      Object convertToType(Object obj, Class<?> targetType)
      Converts an object to a specific type.
      void enterLambdaScope(Map<String,Object> args)
      Installs a Lambda argument map, in preparation for the evaluation of a Lambda expression.
      void exitLambdaScope()
      Exits the Lambda expression evaluation.
      Object getContext(Class key)
      Returns the context object associated with the given key.
      abstract ELResolver getELResolver()
      Retrieves the ELResolver associated with this context.
      List<EvaluationListener> getEvaluationListeners()
      Returns the list of registered evaluation listeners.
      abstract FunctionMapper getFunctionMapper()
      Retrieves the FunctionMapper associated with this ELContext.
      ImportHandler getImportHandler()
      Retrieves the ImportHandler associated with this ELContext.
      Object getLambdaArgument(String arg)
      Retrieves the Lambda argument associated with a formal parameter.
      Locale getLocale()
      Get the Locale stored by a previous invocation to setLocale(java.util.Locale).
      abstract VariableMapper getVariableMapper()
      Retrieves the VariableMapper associated with this ELContext.
      boolean isLambdaArgument(String arg)
      Inquires if the name is a LambdaArgument
      boolean isPropertyResolved()
      Returns whether an ELResolver has successfully resolved a given (base, property) pair.
      void notifyAfterEvaluation(String expr)
      Notifies the listeners after an EL expression is evaluated
      void notifyBeforeEvaluation(String expr)
      Notifies the listeners before an EL expression is evaluated
      void notifyPropertyResolved(Object base, Object property)
      Notifies the listeners when the (base, property) pair is resolved
      void putContext(Class key, Object contextObject)
      Associates a context object with this ELContext.
      void setLocale(Locale locale)
      Sets the Locale for this instance.
      void setPropertyResolved(boolean resolved)
      Called to indicate that a ELResolver has successfully resolved a given (base, property) pair.
      void setPropertyResolved(Object base, Object property)
      Called to indicate that a ELResolver has successfully resolved a given (base, property) pair and to notify the EvaluationListeners.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ELContext

        public ELContext()

    • Method Detail

      • setPropertyResolved

        public void setPropertyResolved(boolean resolved)
        Called to indicate that a ELResolver has successfully resolved a given (base, property) pair. Use setPropertyResolved(Object, Object) if resolved is true and to notify EvaluationListeners.

        The CompositeELResolver checks this property to determine whether it should consider or skip other component resolvers.

        Parameters:
        resolved - true if the property has been resolved, or false if not.
        See Also:
        CompositeELResolver

      • setPropertyResolved

        public void setPropertyResolved(Object base,
                       Object property)
        Called to indicate that a ELResolver has successfully resolved a given (base, property) pair and to notify the EvaluationListeners.

        The CompositeELResolver checks this property to determine whether it should consider or skip other component resolvers.

        Parameters:
        base - The base object
        property - The property object
        Since:
        EL 3.0
        See Also:
        CompositeELResolver

      • isPropertyResolved

        public boolean isPropertyResolved()
        Returns whether an ELResolver has successfully resolved a given (base, property) pair.

        The CompositeELResolver checks this property to determine whether it should consider or skip other component resolvers.

        Returns:
        true if the property has been resolved, or false if not.
        See Also:
        CompositeELResolver

      • putContext

        public void putContext(Class key,
              Object contextObject)
        Associates a context object with this ELContext.

        The ELContext maintains a collection of context objects relevant to the evaluation of an expression. These context objects are used by ELResolvers. This method is used to add a context object to that collection.

        By convention, the contextObject will be of the type specified by the key. However, this is not required and the key is used strictly as a unique identifier.

        Parameters:
        key - The key used by an @{link ELResolver} to identify this context object.
        contextObject - The context object to add to the collection.
        Throws:
        NullPointerException - if key is null or contextObject is null.

      • getContext

        public Object getContext(Class key)
        Returns the context object associated with the given key.

        The ELContext maintains a collection of context objects relevant to the evaluation of an expression. These context objects are used by ELResolvers. This method is used to retrieve the context with the given key from the collection.

        By convention, the object returned will be of the type specified by the key. However, this is not required and the key is used strictly as a unique identifier.

        Parameters:
        key - The unique identifier that was used to associate the context object with this ELContext.
        Returns:
        The context object associated with the given key, or null if no such context was found.
        Throws:
        NullPointerException - if key is null.

      • getELResolver

        public abstract ELResolver getELResolver()
        Retrieves the ELResolver associated with this context.

        The ELContext maintains a reference to the ELResolver that will be consulted to resolve variables and properties during an expression evaluation. This method retrieves the reference to the resolver.

        Once an ELContext is constructed, the reference to the ELResolver associated with the context cannot be changed.

        Returns:
        The resolver to be consulted for variable and property resolution during expression evaluation.

      • getImportHandler

        public ImportHandler getImportHandler()
        Retrieves the ImportHandler associated with this ELContext.
        Returns:
        The import handler to manage imports of classes and packages.
        Since:
        EL 3.0

      • getFunctionMapper

        public abstract FunctionMapper getFunctionMapper()
        Retrieves the FunctionMapper associated with this ELContext.
        Returns:
        The function mapper to be consulted for the resolution of EL functions.

      • getLocale

        public Locale getLocale()
        Get the Locale stored by a previous invocation to setLocale(java.util.Locale). If this method returns non null, this Locale must be used for all localization needs in the implementation. The Locale must not be cached to allow for applications that change Locale dynamically.
        Returns:
        The Locale in which this instance is operating. Used primarily for message localization.

      • setLocale

        public void setLocale(Locale locale)
        Sets the Locale for this instance. This method may be called by the party creating the instance, such as JavaServer Faces or JSP, to enable the EL implementation to provide localized messages to the user. If no Locale is set, the implementation must use the locale returned by Locale.getDefault( ).

      • getVariableMapper

        public abstract VariableMapper getVariableMapper()
        Retrieves the VariableMapper associated with this ELContext.
        Returns:
        The variable mapper to be consulted for the resolution of EL variables.

      • addEvaluationListener

        public void addEvaluationListener(EvaluationListener listener)
        Registers an evaluation listener to the ELContext.
        Parameters:
        listener - The listener to be added.
        Since:
        EL 3.0

      • getEvaluationListeners

        public List<EvaluationListener> getEvaluationListeners()
        Returns the list of registered evaluation listeners.
        Returns:
        The list of registered evaluation listeners.
        Since:
        EL 3.0

      • notifyBeforeEvaluation

        public void notifyBeforeEvaluation(String expr)
        Notifies the listeners before an EL expression is evaluated
        Parameters:
        expr - The EL expression string to be evaluated

      • notifyAfterEvaluation

        public void notifyAfterEvaluation(String expr)
        Notifies the listeners after an EL expression is evaluated
        Parameters:
        expr - The EL expression string that has been evaluated

      • notifyPropertyResolved

        public void notifyPropertyResolved(Object base,
                          Object property)
        Notifies the listeners when the (base, property) pair is resolved
        Parameters:
        base - The base object
        property - The property Object

      • isLambdaArgument

        public boolean isLambdaArgument(String arg)
        Inquires if the name is a LambdaArgument
        Parameters:
        arg - A possible Lambda formal parameter name
        Returns:
        true if arg is a LambdaArgument, false otherwise.

      • getLambdaArgument

        public Object getLambdaArgument(String arg)
        Retrieves the Lambda argument associated with a formal parameter. If the Lambda expression is nested within other Lambda expressions, the arguments for the current Lambda expression is first searched, and if not found, the arguments for the immediate nesting Lambda expression then searched, and so on.
        Parameters:
        arg - The formal parameter for the Lambda argument
        Returns:
        The object associated with formal parameter. Null if no object has been associated with the parameter.
        Since:
        EL 3.0

      • enterLambdaScope

        public void enterLambdaScope(Map<String,Object> args)
        Installs a Lambda argument map, in preparation for the evaluation of a Lambda expression. The arguments in the map will be in scope during the evaluation of the Lambda expression.
        Parameters:
        args - The Lambda arguments map
        Since:
        EL 3.0

      • exitLambdaScope

        public void exitLambdaScope()
        Exits the Lambda expression evaluation. The Lambda argument map that was previously installed is removed.
        Since:
        EL 3.0

      • convertToType

        public Object convertToType(Object obj,
                   Class<?> targetType)
        Converts an object to a specific type. If a custom converter in the ELResolver handles this conversion, it is used. Otherwise the standard coercions is applied.

        An ELException is thrown if an error occurs during the conversion.

        Parameters:
        obj - The object to convert.
        targetType - The target type for the conversion.
        Throws:
        ELException - thrown if errors occur.
        Since:
        EL 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ELContextEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ELContextEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.el.ELContextEvent
  • All Implemented Interfaces:
    Serializable

    public class ELContextEvent
extends EventObject
    An event which indicates that an ELContext has been created. The source object is the ELContext that was created.
    Since:
    JSP 2.1
    See Also:
    ELContext, ELContextListener, Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ELContextEvent(ELContext source)
      Constructs an ELContextEvent object to indicate that an ELContext has been created.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ELContext getELContext()
      Returns the ELContext that was created.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ELContextEvent

        public ELContextEvent(ELContext source)
        Constructs an ELContextEvent object to indicate that an ELContext has been created.
        Parameters:
        source - the ELContext that was created.

    • Method Detail

      • getELContext

        public ELContext getELContext()
        Returns the ELContext that was created. This is a type-safe equivalent of the EventObject.getSource() method.
        Returns:
        the ELContext that was created.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ELContextListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Interface ELContextListener

  • All Superinterfaces:
    EventListener

    public interface ELContextListener
extends EventListener
    The listener interface for receiving notification when an ELContext is created.
    Since:
    JSP 2.1
    See Also:
    ELContext, ELContextEvent

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void contextCreated(ELContextEvent ece)
      Invoked when a new ELContext has been created.

    • Method Detail

      • contextCreated

        void contextCreated(ELContextEvent ece)
        Invoked when a new ELContext has been created.
        Parameters:
        ece - the notification event.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ELException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ELException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.el.ELException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    MethodNotFoundException, PropertyNotFoundException, PropertyNotWritableException

    public class ELException
extends RuntimeException
    Represents any of the exception conditions that can arise during expression evaluation.
    Since:
    JSP 2.1
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ELException()
      Creates an ELException with no detail message.
      ELException(String pMessage)
      Creates an ELException with the provided detail message.
      ELException(String pMessage, Throwable pRootCause)
      Creates an ELException with the given detail message and root cause.
      ELException(Throwable pRootCause)
      Creates an ELException with the given cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ELException

        public ELException()
        Creates an ELException with no detail message.

      • ELException

        public ELException(String pMessage)
        Creates an ELException with the provided detail message.
        Parameters:
        pMessage - the detail message

      • ELException

        public ELException(Throwable pRootCause)
        Creates an ELException with the given cause.
        Parameters:
        pRootCause - the originating cause of this exception

      • ELException

        public ELException(String pMessage,
           Throwable pRootCause)
        Creates an ELException with the given detail message and root cause.
        Parameters:
        pMessage - the detail message
        pRootCause - the originating cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ELManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ELManager

  • java.lang.Object
    • javax.el.ELManager

  • public class ELManager
extends Object

    Manages EL parsing and evaluation environment. The ELManager maintains an instance of ExpressionFactory and StandardELContext, for parsing and evaluating EL expressions.

    Since:
    EL 3.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ELManager()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addBeanNameResolver(BeanNameResolver bnr)
      Register a BeanNameResolver.
      void addELResolver(ELResolver elr)
      Add an user defined ELResolver to the list of ELResolvers.
      void addEvaluationListener(EvaluationListener listener)
      Register an evaluation listener.
      Object defineBean(String name, Object bean)
      Define a bean in the local bean repository
      StandardELContext getELContext()
      Return the ELContext used for parsing and evaluating EL expressions.
      static ExpressionFactory getExpressionFactory()
      Return the ExpressionFactory instance used for EL evaluations.
      void importClass(String className)
      Import a class.
      void importPackage(String packageName)
      Import a package.
      void importStatic(String staticMemberName)
      Import a static field or method.
      void mapFunction(String prefix, String function, Method meth)
      Maps a static method to an EL function.
      ELContext setELContext(ELContext context)
      Set the ELContext used for parsing and evaluating EL expressions.
      void setVariable(String variable, ValueExpression expression)
      Assign a ValueExpression to an EL variable, replacing any previous assignment to the same variable.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ELManager

        public ELManager()

    • Method Detail

      • getExpressionFactory

        public static ExpressionFactory getExpressionFactory()
        Return the ExpressionFactory instance used for EL evaluations.
        Returns:
        The ExpressionFactory

      • getELContext

        public StandardELContext getELContext()
        Return the ELContext used for parsing and evaluating EL expressions. If there is currently no ELContext, a default instance of StandardELContext is returned.
        Returns:
        The ELContext used for parsing and evaluating EL expressions..

      • setELContext

        public ELContext setELContext(ELContext context)
        Set the ELContext used for parsing and evaluating EL expressions. The supplied ELContext will not be modified, except for the context object map.
        Parameters:
        context - The new ELContext.
        Returns:
        The previous ELContext, null if none.

      • addBeanNameResolver

        public void addBeanNameResolver(BeanNameResolver bnr)
        Register a BeanNameResolver. Construct a BeanNameELResolver with the BeanNameResolver and add it to the list of ELResolvers. Once registered, the BeanNameResolver cannot be removed.
        Parameters:
        bnr - The BeanNameResolver to be registered.

      • addELResolver

        public void addELResolver(ELResolver elr)
        Add an user defined ELResolver to the list of ELResolvers. Can be called multiple times. The new ELResolver is placed ahead of the default ELResolvers. The list of the ELResolvers added this way are ordered chronologically.
        Parameters:
        elr - The ELResolver to be added to the list of ELResolvers in ELContext.
        See Also:
        StandardELContext.addELResolver(javax.el.ELResolver)

      • mapFunction

        public void mapFunction(String prefix,
               String function,
               Method meth)
        Maps a static method to an EL function.
        Parameters:
        prefix - The namespace of the functions, can be "".
        function - The name of the function.
        meth - The static method to be invoked when the function is used.

      • setVariable

        public void setVariable(String variable,
               ValueExpression expression)
        Assign a ValueExpression to an EL variable, replacing any previous assignment to the same variable. The assignment for the variable is removed if the expression is null.
        Parameters:
        variable - The variable name
        expression - The ValueExpression to be assigned to the variable.

      • importStatic

        public void importStatic(String staticMemberName)
                  throws ELException
        Import a static field or method. The class of the static member must be loadable from the classloader, at class resolution time.
        Parameters:
        staticMemberName - The full class name of the class to be imported
        Throws:
        ELException - if the name is not a full class name.

      • importClass

        public void importClass(String className)
                 throws ELException
        Import a class. The imported class must be loadable from the classloader at the expression evaluation time.
        Parameters:
        className - The full class name of the class to be imported
        Throws:
        ELException - if the name is not a full class name.

      • importPackage

        public void importPackage(String packageName)
        Import a package. At the expression evaluation time, the imported package name will be used to construct the full class name, which will then be used to load the class. Inherently, this is less efficient than importing a class.
        Parameters:
        packageName - The package name to be imported

      • defineBean

        public Object defineBean(String name,
                Object bean)
        Define a bean in the local bean repository
        Parameters:
        name - The name of the bean
        bean - The bean instance to be defined. If null, the definition of the bean is removed.

      • addEvaluationListener

        public void addEvaluationListener(EvaluationListener listener)
        Register an evaluation listener.
        Parameters:
        listener - The evaluation listener to be added.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ELProcessor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ELProcessor

  • java.lang.Object
    • javax.el.ELProcessor

  • public class ELProcessor
extends Object

    Provides an API for using EL in a stand-alone environment.

    This class provides a direct and simple interface for

    • Evaluating EL expressions.
    • Assigning values to beans or setting a bean property.
    • Setting a ValueExpression to a EL variable.
    • Defining a static method as an EL function.
    • Defining an object instance as an EL name.

    This API is not a replacement for the APIs in EL 2.2. Containers that maintains EL environments can continue to do so, without using this API.

    For EL users who want to manipulate EL environments, like adding custom ELResolvers, ELManager can be used.

    Scope and Life Cycle

    Since it maintains the state of the EL environments, ELProcessor is not thread safe. In the simplest case, an instance can be created and destroyed before and after evaluating EL expressions. A more general usage is to use an instance of ELProcessor for a session, so that the user can configure the EL evaluation environment for that session.

    Automatic Bracketing of Expressions

    A note about the EL expressions strings used in the class. The strings allowed in the methods getValue(java.lang.String, java.lang.Class<?>), setValue(java.lang.String, java.lang.Object), and setVariable(java.lang.String, java.lang.String) are limited to non-composite expressions, i.e. expressions of the form ${...} or #{...} only. Also, it is not necessary (in fact not allowed) to bracket the expression strings with ${ or #{ and } in these methods: they will be automatically bracketed. This reduces the visual cluster, without any lost of functionalities (thanks to the addition of the concatenation operator).

    Example

    The following code snippet illustrates the use of ELProcessor to define a bean and evaluate its property.
       ELProcessor elp = new ELProcessor();
   elp.defineBean("employee", new Employee("Charlie Brown"));
   String name = elp.eval("employee.name");
    Since:
    EL 3.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ELProcessor()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void defineBean(String name, Object bean)
      Define a bean in a local bean repository, hiding other beans of the same name.
      void defineFunction(String prefix, String function, Method method)
      Define an EL function in the local function mapper.
      void defineFunction(String prefix, String function, String className, String method)
      Define an EL function in the local function mapper.
      Object eval(String expression)
      Evaluates an EL expression.
      ELManager getELManager()
      Return the ELManager used for EL processing.
      Object getValue(String expression, Class<?> expectedType)
      Evaluates an EL expression, and coerces the result to the specified type.
      void setValue(String expression, Object value)
      Sets an expression with a new value.
      void setVariable(String var, String expression)
      Assign an EL expression to an EL variable.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ELProcessor

        public ELProcessor()

    • Method Detail

      • getELManager

        public ELManager getELManager()
        Return the ELManager used for EL processing.
        Returns:
        The ELManager used for EL processing.

      • eval

        public Object eval(String expression)
        Evaluates an EL expression.
        Parameters:
        expression - The EL expression to be evaluated.
        Returns:
        The result of the expression evaluation.

      • getValue

        public Object getValue(String expression,
              Class<?> expectedType)
        Evaluates an EL expression, and coerces the result to the specified type.
        Parameters:
        expression - The EL expression to be evaluated.
        expectedType - Specifies the type that the resultant evaluation will be coerced to.
        Returns:
        The result of the expression evaluation.

      • setValue

        public void setValue(String expression,
            Object value)
        Sets an expression with a new value. The target expression is evaluated, up to the last property resolution, and the resultant (base, property) pair is set to the provided value.
        Parameters:
        expression - The target expression
        value - The new value to set.
        Throws:
        PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
        PropertyNotWritableException - if the final variable or property resolution failed because the specified variable or property is not writable.
        ELException - if an exception was thrown while attempting to set the property or variable. The thrown exception must be included as the cause property of this exception, if available.

      • setVariable

        public void setVariable(String var,
               String expression)
        Assign an EL expression to an EL variable. The expression is parsed, but not evaluated, and the parsed expression is mapped to the EL variable in the local variable map. Any previously assigned expression to the same variable will be replaced. If the expression is null, the variable will be removed.
        Parameters:
        var - The name of the variable.
        expression - The EL expression to be assigned to the variable.

      • defineFunction

        public void defineFunction(String prefix,
                  String function,
                  String className,
                  String method)
                    throws ClassNotFoundException,
                           NoSuchMethodException
        Define an EL function in the local function mapper.
        Parameters:
        prefix - The namespace for the function or "" for no namesapce.
        function - The name of the function. If empty (""), the method name is used as the function name.
        className - The full Java class name that implements the function.
        method - The name (specified without parenthesis) or the signature (as in the Java Language Spec) of the static method that implements the function. If the name (e.g. "sum") is given, the first declared method in class that matches the name is selected. If the signature (e.g. "int sum(int, int)" ) is given, then the declared method with the signature is selected.
        Throws:
        NullPointerException - if any of the arguments is null.
        ClassNotFoundException - if the specified class does not exists.
        NoSuchMethodException - if the method (with or without the signature) is not a declared method of the class, or if the method signature is not valid, or if the method is not a static method.

      • defineFunction

        public void defineFunction(String prefix,
                  String function,
                  Method method)
                    throws NoSuchMethodException
        Define an EL function in the local function mapper.
        Parameters:
        prefix - The namespace for the function or "" for no namesapce.
        function - The name of the function. If empty (""), the method name is used as the function name.
        method - The java.lang.reflect.Method instance of the method that implements the function.
        Throws:
        NullPointerException - if any of the arguments is null.
        NoSuchMethodException - if the method is not a static method

      • defineBean

        public void defineBean(String name,
              Object bean)
        Define a bean in a local bean repository, hiding other beans of the same name.
        Parameters:
        name - The name of the bean
        bean - The bean instance to be defined. If null, the name will be removed from the local bean repository.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ELResolver

  • java.lang.Object
    • javax.el.ELResolver
  • Direct Known Subclasses:
    ArrayELResolver, BeanELResolver, BeanNameELResolver, CompositeELResolver, ImplicitObjectELResolver, ListELResolver, MapELResolver, ResourceBundleELResolver, ScopedAttributeELResolver, StaticFieldELResolver, TypeConverter

    public abstract class ELResolver
extends Object
    Enables customization of variable, property, method call, and type conversion resolution behavior for EL expression evaluation.

    While evaluating an expression, the ELResolver associated with the ELContext is consulted to do the initial resolution of the first variable of an expression. It is also consulted when a . or [] operator is encountered.

    For example, in the EL expression ${employee.lastName}, the ELResolver determines what object employee refers to, and what it means to get the lastName property on that object.

    Most methods in this class accept a base and property parameter. In the case of variable resolution (e.g. determining what employee refers to in ${employee.lastName}), the base parameter will be null and the property parameter will always be of type String. In this case, if the property is not a String, the behavior of the ELResolver is undefined.

    In the case of property resolution, the base parameter identifies the base object and the property object identifies the property on that base. For example, in the expression ${employee.lastName}, base is the result of the variable resolution for employee and property is the string "lastName". In the expression ${y[x]}, base is the result of the variable resolution for y and property is the result of the variable resolution for x.

    In the case of method call resolution, the base parameter identifies the base object and the method parameter identifies a method on that base. In the case of overloaded methods, the paramTypes parameter can be optionally used to identify a method. The paramsparameter are the parameters for the method call, and can also be used for resolving overloaded methods when the paramTypes parameter is not specified.

    In the case of type conversion resolution, the obj parameter identifies the source object and the targetType parameter identifies the target type the source to covert to.

    Though only a single ELResolver is associated with an ELContext, there are usually multiple resolvers considered for any given variable or property resolution. ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression.

    For the getValue(javax.el.ELContext, java.lang.Object, java.lang.Object), getType(javax.el.ELContext, java.lang.Object, java.lang.Object), setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object), and isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object) methods, an ELResolver is not responsible for resolving all possible (base, property) pairs. In fact, most resolvers will only handle a base of a single type. To indicate that a resolver has successfully resolved a particular (base, property) pair, it must set the propertyResolved property of the ELContext to true. If it could not handle the given pair, it must leave this property alone. The caller must ignore the return value of the method if propertyResolved is false.

    Similarly, for the convertToType(javax.el.ELContext, java.lang.Object, java.lang.Class<?>) method an ELResolver must set the propertyResolved to true to indicate that it handles the conversion of the object to the target type.

    The getFeatureDescriptors(javax.el.ELContext, java.lang.Object) and getCommonPropertyType(javax.el.ELContext, java.lang.Object) methods are primarily designed for design-time tool support, but must handle invocation at runtime as well. The Beans.isDesignTime() method can be used to determine if the resolver is being consulted at design-time or runtime.

    Since:
    JSP 2.1
    See Also:
    CompositeELResolver, ELContext.getELResolver()

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String RESOLVABLE_AT_DESIGN_TIME
      The attribute name of the named attribute in the FeatureDescriptor that specifies whether the variable or property can be resolved at runtime.
      static String TYPE
      The attribute name of the named attribute in the FeatureDescriptor that specifies the runtime type of the variable or property.

    • Constructor Summary

      Constructors
      Constructor and Description
      ELResolver()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object convertToType(ELContext context, Object obj, Class<?> targetType)
      Converts an object to a specific type.
      abstract Class<?> getCommonPropertyType(ELContext context, Object base)
      Returns the most general type that this resolver accepts for the property argument, given a base object.
      abstract Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      Returns information about the set of variables or properties that can be resolved for the given base object.
      abstract Class<?> getType(ELContext context, Object base, Object property)
      For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.
      abstract Object getValue(ELContext context, Object base, Object property)
      Attempts to resolve the given property object on the given base object.
      Object invoke(ELContext context, Object base, Object method, Class<?>[] paramTypes, Object[] params)
      Attempts to resolve and invoke the given method on the given base object.
      abstract boolean isReadOnly(ELContext context, Object base, Object property)
      For a given base and property, attempts to determine whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      abstract void setValue(ELContext context, Object base, Object property, Object value)
      Attempts to set the value of the given property object on the given base object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • TYPE

        public static final String TYPE

        The attribute name of the named attribute in the FeatureDescriptor that specifies the runtime type of the variable or property.

        See Also:
        Constant Field Values

      • RESOLVABLE_AT_DESIGN_TIME

        public static final String RESOLVABLE_AT_DESIGN_TIME

        The attribute name of the named attribute in the FeatureDescriptor that specifies whether the variable or property can be resolved at runtime.

        See Also:
        Constant Field Values

    • Constructor Detail

      • ELResolver

        public ELResolver()

    • Method Detail

      • getValue

        public abstract Object getValue(ELContext context,
              Object base,
              Object property)
        Attempts to resolve the given property object on the given base object.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be returned, or null to resolve a top-level variable.
        property - The property or variable to be resolved.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the result of the variable or property resolution; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist or is not readable.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • invoke

        public Object invoke(ELContext context,
            Object base,
            Object method,
            Class<?>[] paramTypes,
            Object[] params)
        Attempts to resolve and invoke the given method on the given base object.

        If this resolver handles the given (base, method) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        A default implementation is provided that returns null so that existing classes that extend ELResolver can continue to function.

        Parameters:
        context - The context of this evaluation.
        base - The bean on which to invoke the method
        method - The simple name of the method to invoke. Will be coerced to a String.
        paramTypes - An array of Class objects identifying the method's formal parameter types, in declared order. Use an empty array if the method has no parameters. Can be null, in which case the method's formal parameter types are assumed to be unknown.
        params - The parameters to pass to the method, or null if no parameters.
        Returns:
        The result of the method invocation (null if the method has a void return type).
        Throws:
        MethodNotFoundException - if no suitable method can be found.
        ELException - if an exception was thrown while performing (base, method) resolution. The thrown exception must be included as the cause property of this exception, if available. If the exception thrown is an InvocationTargetException, extract its cause and pass it to the ELException constructor.
        Since:
        EL 2.2

      • getType

        public abstract Class<?> getType(ELContext context,
               Object base,
               Object property)
        For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        This is not always the same as getValue().getClass(). For example, in the case of an ArrayELResolver, the getType method will return the element type of the array, which might be a superclass of the type of the actual element that is currently in the specified array element.

        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be analyzed, or null to analyze a top-level variable.
        property - The property or variable to return the acceptable type for.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
        Throws:
        PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist or is not readable.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • setValue

        public abstract void setValue(ELContext context,
            Object base,
            Object property,
            Object value)
        Attempts to set the value of the given property object on the given base object.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value has been set.

        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be set, or null to set a top-level variable.
        property - The property or variable to be set.
        value - The value to set the property or variable to.
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist.
        PropertyNotWritableException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property is not writable.
        ELException - if an exception was thrown while attempting to set the property or variable. The thrown exception must be included as the cause property of this exception, if available.

      • isReadOnly

        public abstract boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        For a given base and property, attempts to determine whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be analyzed, or null to analyze a top-level variable.
        property - The property or variable to return the read-only status for.
        Returns:
        If the propertyResolved property of ELContext was set to true, then true if the property is read-only or false if not; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getFeatureDescriptors

        public abstract Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        Returns information about the set of variables or properties that can be resolved for the given base object. One use for this method is to assist tools in auto-completion.

        If the base parameter is null, the resolver must enumerate the list of top-level variables it can resolve.

        The Iterator returned must contain zero or more instances of FeatureDescriptor, in no guaranteed order. In the case of primitive types such as int, the value null must be returned. This is to prevent the useless iteration through all possible primitive values. A return value of null indicates that this resolver does not handle the given base object or that the results are too complex to represent with this method and the getCommonPropertyType(javax.el.ELContext, java.lang.Object) method should be used instead.

        Each FeatureDescriptor will contain information about a single variable or property. In addition to the standard properties, the FeatureDescriptor must have two named attributes (as set by the setValue method):

        • TYPE - The value of this named attribute must be an instance of java.lang.Class and specify the runtime type of the variable or property.
        • RESOLVABLE_AT_DESIGN_TIME - The value of this named attribute must be an instance of java.lang.Boolean and indicates whether it is safe to attempt to resolve this property at design-time. For instance, it may be unsafe to attempt a resolution at design time if the ELResolver needs access to a resource that is only available at runtime and no acceptable simulated value can be provided.

        The caller should be aware that the Iterator returned might iterate through a very large or even infinitely large set of properties. Care should be taken by the caller to not get stuck in an infinite loop.

        This is a "best-effort" list. Not all ELResolvers will return completely accurate results, but all must be callable at both design-time and runtime (i.e. whether or not Beans.isDesignTime() returns true), without causing errors.

        The propertyResolved property of the ELContext is not relevant to this method. The results of all ELResolvers are concatenated in the case of composite resolvers.

        Parameters:
        context - The context of this evaluation.
        base - The base object whose set of valid properties is to be enumerated, or null to enumerate the set of top-level variables that this resolver can evaluate.
        Returns:
        An Iterator containing zero or more (possibly infinitely more) FeatureDescriptor objects, or null if this resolver does not handle the given base object or that the results are too complex to represent with this method
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public abstract Class<?> getCommonPropertyType(ELContext context,
                             Object base)
        Returns the most general type that this resolver accepts for the property argument, given a base object. One use for this method is to assist tools in auto-completion.

        This assists tools in auto-completion and also provides a way to express that the resolver accepts a primitive value, such as an integer index into an array. For example, the ArrayELResolver will accept any int as a property, so the return value would be Integer.class.

        Parameters:
        context - The context of this evaluation.
        base - The base object to return the most general property type for, or null to enumerate the set of top-level variables that this resolver can evaluate.
        Returns:
        null if this ELResolver does not know how to handle the given base object; otherwise Object.class if any type of property is accepted; otherwise the most general property type accepted for the given base.

      • convertToType

        public Object convertToType(ELContext context,
                   Object obj,
                   Class<?> targetType)
        Converts an object to a specific type.

        An ELException is thrown if an error occurs during the conversion.

        Parameters:
        context - The context of this evaluation.
        obj - The object to convert.
        targetType - The target type for the convertion.
        Throws:
        ELException - thrown if errors occur.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EvaluationListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class EvaluationListener

  • java.lang.Object
    • javax.el.EvaluationListener

  • public abstract class EvaluationListener
extends Object
    The listener interface for receiving notification when an EL expression is evaluated.
    Since:
    EL 3.0

    • Constructor Summary

      Constructors
      Constructor and Description
      EvaluationListener()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterEvaluation(ELContext context, String expression)
      Receives notification after an EL expression is evaluated
      void beforeEvaluation(ELContext context, String expression)
      Receives notification before an EL expression is evaluated
      void propertyResolved(ELContext context, Object base, Object property)
      Receives notification when the (base, property) pair is resolved

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • EvaluationListener

        public EvaluationListener()

    • Method Detail

      • beforeEvaluation

        public void beforeEvaluation(ELContext context,
                    String expression)
        Receives notification before an EL expression is evaluated
        Parameters:
        context - The ELContext
        expression - The EL expression string to be evaluated

      • afterEvaluation

        public void afterEvaluation(ELContext context,
                   String expression)
        Receives notification after an EL expression is evaluated
        Parameters:
        context - The ELContext
        expression - The EL expression string to be evaluated

      • propertyResolved

        public void propertyResolved(ELContext context,
                    Object base,
                    Object property)
        Receives notification when the (base, property) pair is resolved
        Parameters:
        context - The ELContext
        base - The base object
        property - The property object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Expression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class Expression

  • java.lang.Object
    • javax.el.Expression
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    MethodExpression, ValueExpression

    public abstract class Expression
extends Object
implements Serializable
    Base class for the expression subclasses ValueExpression and MethodExpression, implementing characteristics common to both.

    All expressions must implement the equals() and hashCode() methods so that two expressions can be compared for equality. They are redefined abstract in this class to force their implementation in subclasses.

    All expressions must also be Serializable so that they can be saved and restored.

    Expressions are also designed to be immutable so that only one instance needs to be created for any given expression String / FunctionMapper. This allows a container to pre-create expressions and not have to re-parse them each time they are evaluated.

    Since:
    JSP 2.1
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      Expression()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract boolean equals(Object obj)
      Determines whether the specified object is equal to this Expression.
      abstract String getExpressionString()
      Returns the original String used to create this Expression, unmodified.
      abstract int hashCode()
      Returns the hash code for this Expression.
      abstract boolean isLiteralText()
      Returns whether this expression was created from only literal text.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Expression

        public Expression()

    • Method Detail

      • getExpressionString

        public abstract String getExpressionString()
        Returns the original String used to create this Expression, unmodified.

        This is used for debugging purposes but also for the purposes of comparison (e.g. to ensure the expression in a configuration file has not changed).

        This method does not provide sufficient information to re-create an expression. Two different expressions can have exactly the same expression string but different function mappings. Serialization should be used to save and restore the state of an Expression.

        Returns:
        The original expression String.

      • equals

        public abstract boolean equals(Object obj)
        Determines whether the specified object is equal to this Expression.

        The result is true if and only if the argument is not null, is an Expression object that is the of the same type (ValueExpression or MethodExpression), and has an identical parsed representation.

        Note that two expressions can be equal if their expression Strings are different. For example, ${fn1:foo()} and ${fn2:foo()} are equal if their corresponding FunctionMappers mapped fn1:foo and fn2:foo to the same method.

        Overrides:
        equals in class Object
        Parameters:
        obj - the Object to test for equality.
        Returns:
        true if obj equals this Expression; false otherwise.
        See Also:
        Hashtable, Object.equals(java.lang.Object)

      • hashCode

        public abstract int hashCode()
        Returns the hash code for this Expression.

        See the note in the equals(java.lang.Object) method on how two expressions can be equal if their expression Strings are different. Recall that if two objects are equal according to the equals(Object) method, then calling the hashCode method on each of the two objects must produce the same integer result. Implementations must take special note and implement hashCode correctly.

        Overrides:
        hashCode in class Object
        Returns:
        The hash code for this Expression.
        See Also:
        equals(java.lang.Object), Hashtable, Object.hashCode()

      • isLiteralText

        public abstract boolean isLiteralText()
        Returns whether this expression was created from only literal text.

        This method must return true if and only if the expression string this expression was created from contained no unescaped EL delimeters (${...} or #{...}).

        Returns:
        true if this expression was created from only literal text; false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExpressionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ExpressionFactory

  • java.lang.Object
    • javax.el.ExpressionFactory

  • public abstract class ExpressionFactory
extends Object
    Provides an implementation for creating and evaluating EL expressions.

    Classes that implement the EL expression language expose their functionality via this abstract class. An implementation supports the following functionalities.

    • Parses a String into a ValueExpression or MethodExpression instance for later evaluation.
    • Implements an ELResolver for query operators
    • Provides a default type coercion

    The newInstance() method can be used to obtain an instance of the implementation. Technologies such as JavaServer Pages and JavaServer Faces provide access to an implementation via factory methods.

    The createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>) method is used to parse expressions that evaluate to values (both l-values and r-values are supported). The createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>, java.lang.Class<?>[]) method is used to parse expressions that evaluate to a reference to a method on an object.

    Resolution of model objects is performed at evaluation time, via the ELResolver associated with the ELContext passed to the ValueExpression or MethodExpression.

    The ELContext object also provides access to the FunctionMapper and VariableMapper to be used when parsing the expression. EL function and variable mapping is performed at parse-time, and the results are bound to the expression. Therefore, the ELContext, FunctionMapper, and VariableMapper are not stored for future use and do not have to be Serializable.

    The createValueExpression and createMethodExpression methods must be thread-safe. That is, multiple threads may call these methods on the same ExpressionFactory object simultaneously. Implementations should synchronize access if they depend on transient state. Implementations should not, however, assume that only one object of each ExpressionFactory type will be instantiated; global caching should therefore be static.

    The ExpressionFactory must be able to handle the following types of input for the expression parameter:

    • Single expressions using the ${} delimiter (e.g. "${employee.lastName}").
    • Single expressions using the #{} delimiter (e.g. "#{employee.lastName}").
    • Literal text containing no ${} or #{} delimiters (e.g. "John Doe").
    • Multiple expressions using the same delimiter (e.g. "${employee.firstName}${employee.lastName}" or "#{employee.firstName}#{employee.lastName}").
    • Mixed literal text and expressions using the same delimiter (e.g. "Name: ${employee.firstName} ${employee.lastName}").

    The following types of input are illegal and must cause an ELException to be thrown:

    • Multiple expressions using different delimiters (e.g. "${employee.firstName}#{employee.lastName}").
    • Mixed literal text and expressions using different delimiters(e.g. "Name: ${employee.firstName} #{employee.lastName}").

    Since:
    JSP 2.1

    • Constructor Summary

      Constructors
      Constructor and Description
      ExpressionFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Object coerceToType(Object obj, Class<?> targetType)
      Coerces an object to a specific type according to the EL type conversion rules.
      abstract MethodExpression createMethodExpression(ELContext context, String expression, Class<?> expectedReturnType, Class<?>[] expectedParamTypes)
      Parses an expression into a MethodExpression for later evaluation.
      abstract ValueExpression createValueExpression(ELContext context, String expression, Class<?> expectedType)
      Parses an expression into a ValueExpression for later evaluation.
      abstract ValueExpression createValueExpression(Object instance, Class<?> expectedType)
      Creates a ValueExpression that wraps an object instance.
      Map<String,Method> getInitFunctionMap()
      Retrieve a function map containing a pre-configured function mapping.
      ELResolver getStreamELResolver()
      Retrieves an ELResolver that implements the operations in collections.
      static ExpressionFactory newInstance()
      Creates a new instance of a ExpressionFactory.
      static ExpressionFactory newInstance(Properties properties)
      Create a new instance of a ExpressionFactory, with optional properties.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ExpressionFactory

        public ExpressionFactory()

    • Method Detail

      • newInstance

        public static ExpressionFactory newInstance()
        Creates a new instance of a ExpressionFactory. This method uses the following ordered lookup procedure to determine the ExpressionFactory implementation class to load:
        • Use the Services API (as detailed in the JAR specification). If a resource with the name of META-INF/services/javax.el.ExpressionFactory exists, then its first line, if present, is used as the UTF-8 encoded name of the implementation class.
        • Use the properties file "lib/el.properties" in the JRE directory. If this file exists and it is readable by the java.util.Properties.load(InputStream) method, and it contains an entry whose key is "javax.el.ExpressionFactory", then the value of that entry is used as the name of the implementation class.
        • Use the javax.el.ExpressionFactory system property. If a system property with this name is defined, then its value is used as the name of the implementation class.
        • Use a platform default implementation.

      • newInstance

        public static ExpressionFactory newInstance(Properties properties)

        Create a new instance of a ExpressionFactory, with optional properties. This method uses the same lookup procedure as the one used in newInstance().

        If the argument properties is not null, and if the implementation contains a constructor with a single parameter of type java.util.Properties, then the constructor is used to create the instance.

        Properties are optional and can be ignored by an implementation.

        The name of a property should start with "javax.el."

        The following are some suggested names for properties.

        • javax.el.cacheSize

        Parameters:
        properties - Properties passed to the implementation. If null, then no properties.

      • createValueExpression

        public abstract ValueExpression createValueExpression(ELContext context,
                                    String expression,
                                    Class<?> expectedType)
        Parses an expression into a ValueExpression for later evaluation. Use this method for expressions that refer to values.

        This method should perform syntactic validation of the expression. If in doing so it detects errors, it should raise an ELException.

        Parameters:
        context - The EL context used to parse the expression. The FunctionMapper and VariableMapper stored in the ELContext are used to resolve functions and variables found in the expression. They can be null, in which case functions or variables are not supported for this expression. The object returned must invoke the same functions and access the same variable mappings regardless of whether the mappings in the provided FunctionMapper and VariableMapper instances change between calling ExpressionFactory.createValueExpression() and any method on ValueExpression.

        Note that within the EL, the ${} and #{} syntaxes are treated identically. This includes the use of VariableMapper and FunctionMapper at expression creation time. Each is invoked if not null, independent of whether the #{} or ${} syntax is used for the expression.

        expression - The expression to parse
        expectedType - The type the result of the expression will be coerced to after evaluation.
        Returns:
        The parsed expression
        Throws:
        NullPointerException - Thrown if expectedType is null.
        ELException - Thrown if there are syntactical errors in the provided expression.

      • createValueExpression

        public abstract ValueExpression createValueExpression(Object instance,
                                    Class<?> expectedType)
        Creates a ValueExpression that wraps an object instance. This method can be used to pass any object as a ValueExpression. The wrapper ValueExpression is read only, and returns the wrapped object via its getValue() method, optionally coerced.
        Parameters:
        instance - The object instance to be wrapped.
        expectedType - The type the result of the expression will be coerced to after evaluation. There will be no coercion if it is Object.class,
        Throws:
        NullPointerException - Thrown if expectedType is null.

      • createMethodExpression

        public abstract MethodExpression createMethodExpression(ELContext context,
                                      String expression,
                                      Class<?> expectedReturnType,
                                      Class<?>[] expectedParamTypes)
        Parses an expression into a MethodExpression for later evaluation. Use this method for expressions that refer to methods.

        If the expression is a String literal, a MethodExpression is created, which when invoked, returns the String literal, coerced to expectedReturnType. An ELException is thrown if expectedReturnType is void or if the coercion of the String literal to the expectedReturnType yields an error (see Section "1.16 Type Conversion").

        This method should perform syntactic validation of the expression. If in doing so it detects errors, it should raise an ELException.

        Parameters:
        context - The EL context used to parse the expression. The FunctionMapper and VariableMapper stored in the ELContext are used to resolve functions and variables found in the expression. They can be null, in which case functions or variables are not supported for this expression. The object returned must invoke the same functions and access the same variable mappings regardless of whether the mappings in the provided FunctionMapper and VariableMapper instances change between calling ExpressionFactory.createMethodExpression() and any method on MethodExpression.

        Note that within the EL, the ${} and #{} syntaxes are treated identically. This includes the use of VariableMapper and FunctionMapper at expression creation time. Each is invoked if not null, independent of whether the #{} or ${} syntax is used for the expression.

        expression - The expression to parse
        expectedReturnType - The expected return type for the method to be found. After evaluating the expression, the MethodExpression must check that the return type of the actual method matches this type. Passing in a value of null indicates the caller does not care what the return type is, and the check is disabled.
        expectedParamTypes - The expected parameter types for the method to be found. Must be an array with no elements if there are no parameters expected. It is illegal to pass null, unless the method is specified with arugments in the EL expression, in which case these arguments are used for method selection, and this parameter is ignored.
        Returns:
        The parsed expression
        Throws:
        ELException - Thrown if there are syntactical errors in the provided expression.
        NullPointerException - if paramTypes is null.

      • coerceToType

        public abstract Object coerceToType(Object obj,
                  Class<?> targetType)
        Coerces an object to a specific type according to the EL type conversion rules. The custom type conversions in the ELResolvers are not considered.

        An ELException is thrown if an error results from applying the conversion rules.

        Parameters:
        obj - The object to coerce.
        targetType - The target type for the coercion.
        Throws:
        ELException - thrown if an error results from applying the conversion rules.

      • getStreamELResolver

        public ELResolver getStreamELResolver()
        Retrieves an ELResolver that implements the operations in collections.

        This ELResolver resolves the method invocation on the pair (base, property) when base is a Collection or a Map, and property is the name of the operation.

        See EL.2 for detailed descriptions of these operators, their arguments, and return values.

        Returns:
        The ELResolver that implements the Query Operators.
        Since:
        EL 3.0

      • getInitFunctionMap

        public Map<String,Method> getInitFunctionMap()
        Retrieve a function map containing a pre-configured function mapping. It must include the following functions.
        • linq:range
        • linq:repeat
        • linq:_empty
        Returns:
        A initial map for functions, null if there is none.
        Since:
        EL 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FunctionMapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class FunctionMapper

  • java.lang.Object
    • javax.el.FunctionMapper

  • public abstract class FunctionMapper
extends Object
    The interface to a map between EL function names and methods.

    A FunctionMapper maps ${prefix:name()} style functions to a static method that can execute that function.

    Since:
    JSP 2.1

    • Constructor Summary

      Constructors
      Constructor and Description
      FunctionMapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void mapFunction(String prefix, String localName, Method meth)
      Adds a static method that can be used as a function.
      abstract Method resolveFunction(String prefix, String localName)
      Resolves the specified prefix and local name into a java.lang.Method.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FunctionMapper

        public FunctionMapper()

    • Method Detail

      • resolveFunction

        public abstract Method resolveFunction(String prefix,
                     String localName)
        Resolves the specified prefix and local name into a java.lang.Method.

        Returns null if no function could be found that matches the given prefix and local name.

        Parameters:
        prefix - the prefix of the function, or "" if no prefix. For example, "fn" in ${fn:method()}, or "" in ${method()}.
        localName - the short name of the function. For example, "method" in ${fn:method()}.
        Returns:
        the static method to invoke, or null if no match was found.

      • mapFunction

        public void mapFunction(String prefix,
               String localName,
               Method meth)
        Adds a static method that can be used as a function.
        Parameters:
        prefix - the prefix of the function, or "" if no prefix. For example, "fn" in ${fn:method()}, or "" in ${method()}.
        localName - the short name of the function. For example, "method" in ${fn:method()}.
        meth - The static method that is to be invoked, when the function is referenced. The null value causes the function to be removed from the map.
        Since:
        EL 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ImportHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ImportHandler

  • java.lang.Object
    • javax.el.ImportHandler

  • public class ImportHandler
extends Object
    Handles imports of class names and package names. An imported package name implicitly imports all the classes in the package. A class that has been imported can be used without its package name. The name is resolved to its full (package and class) name at evaluation time.

    • Constructor Summary

      Constructors
      Constructor and Description
      ImportHandler()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void importClass(String name)
      Import a class.
      void importPackage(String packageName)
      Import all the classes in a package.
      void importStatic(String name)
      Import a static field or method.
      Class<?> resolveClass(String name)
      Resolve a class name.
      Class<?> resolveStatic(String name)
      Resolve a static field or method name.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ImportHandler

        public ImportHandler()

    • Method Detail

      • importStatic

        public void importStatic(String name)
                  throws ELException
        Import a static field or method.
        Parameters:
        name - The static member name, including the full class name, to be imported
        Throws:
        ELException - if the name does not include a ".".

      • importClass

        public void importClass(String name)
                 throws ELException
        Import a class.
        Parameters:
        name - The full class name of the class to be imported
        Throws:
        ELException - if the name does not include a ".".

      • importPackage

        public void importPackage(String packageName)
        Import all the classes in a package.
        Parameters:
        packageName - The package name to be imported

      • resolveClass

        public Class<?> resolveClass(String name)
        Resolve a class name.
        Parameters:
        name - The name of the class (without package name) to be resolved.
        Returns:
        If the class has been imported previously, with importClass(java.lang.String) or importPackage(java.lang.String), then its Class instance. Otherwise null.
        Throws:
        ELException - if the class is abstract or is an interface, or not public.

      • resolveStatic

        public Class<?> resolveStatic(String name)
        Resolve a static field or method name.
        Parameters:
        name - The name of the member(without package and class name) to be resolved.
        Returns:
        If the field or method has been imported previously, with importStatic(java.lang.String), then the class object representing the class that declares the static field or method. Otherwise null.
        Throws:
        ELException - if the class is not public, or is abstract or is an interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.el (Java(TM) EE 7 Specification APIs)

javax.el

Interfaces

  • ELContextListener

Classes

  • ArrayELResolver
  • BeanELResolver
  • BeanNameELResolver
  • BeanNameResolver
  • CompositeELResolver
  • ELClass
  • ELContext
  • ELContextEvent
  • ELManager
  • ELProcessor
  • ELResolver
  • EvaluationListener
  • Expression
  • ExpressionFactory
  • FunctionMapper
  • ImportHandler
  • LambdaExpression
  • ListELResolver
  • MapELResolver
  • MethodExpression
  • MethodInfo
  • ResourceBundleELResolver
  • StandardELContext
  • StaticFieldELResolver
  • TypeConverter
  • ValueExpression
  • ValueReference
  • VariableMapper

Exceptions

  • ELException
  • MethodNotFoundException
  • PropertyNotFoundException
  • PropertyNotWritableException


javax.el (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.el

Provides the API for the Unified Expression Language 3.0

See: Description

  • Interface Summary
    Interface Description
    ELContextListener
    The listener interface for receiving notification when an ELContext is created.
  • Class Summary
    Class Description
    ArrayELResolver
    Defines property resolution behavior on arrays.
    BeanELResolver
    Defines property resolution behavior on objects using the JavaBeans component architecture.
    BeanNameELResolver
    An ELResolver for resolving user or container managed beans.
    BeanNameResolver
    Resolves a bean by its known name.
    CompositeELResolver
    Maintains an ordered composite list of child ELResolvers.
    ELClass
    A runtime representation of a Class in the EL expressions.
    ELContext
    Context information for expression parsing and evaluation.
    ELContextEvent
    An event which indicates that an ELContext has been created.
    ELManager
    Manages EL parsing and evaluation environment.
    ELProcessor
    Provides an API for using EL in a stand-alone environment.
    ELResolver
    Enables customization of variable, property, method call, and type conversion resolution behavior for EL expression evaluation.
    EvaluationListener
    The listener interface for receiving notification when an EL expression is evaluated.
    Expression
    Base class for the expression subclasses ValueExpression and MethodExpression, implementing characteristics common to both.
    ExpressionFactory
    Provides an implementation for creating and evaluating EL expressions.
    FunctionMapper
    The interface to a map between EL function names and methods.
    ImportHandler
    Handles imports of class names and package names.
    LambdaExpression
    Encapsulates a parameterized ValueExpression.
    ListELResolver
    Defines property resolution behavior on instances of List.
    MapELResolver
    Defines property resolution behavior on instances of Map.
    MethodExpression
    An Expression that refers to a method on an object.
    MethodInfo
    Holds information about a method that a MethodExpression evaluated to.
    ResourceBundleELResolver
    Defines property resolution behavior on instances of ResourceBundle.
    StandardELContext
    A standard ELContext suitable for use in a stand alone environment.
    StaticFieldELResolver
    An ELResolver for resolving static fields, enum constants and static methods.
    TypeConverter
    A convenient class for writing an ELResolver to do custom type conversions.
    ValueExpression
    An Expression that can get or set a value.
    ValueReference
    This encapsulates a base model object and one of its properties.
    VariableMapper
    The interface to a map between EL variables and the EL expressions they are associated with.
  • Exception Summary
    Exception Description
    ELException
    Represents any of the exception conditions that can arise during expression evaluation.
    MethodNotFoundException
    Thrown when a method could not be found while evaluating a MethodExpression.
    PropertyNotFoundException
    Thrown when a property could not be found while evaluating a ValueExpression or MethodExpression.
    PropertyNotWritableException
    Thrown when a property could not be written to while setting the value on a ValueExpression.

Package javax.el Description

Provides the API for the Unified Expression Language 3.0

The Expression Language (EL) is a simple language originally designed to satisfy the specific needs of web application developers. It has evloved into its own specification intended for general use inside and outside of the web containers.

This package contains the classes and interfaces that describe and define the programmatic access to the Expression Language engine. The API is logically partitioned as follows:

  • EL Context
  • Expression Objects
  • Creation of Expressions
  • Evaluation of Expressions
  • Evaluation Listeners
  • Resolution of Model Objects and their Properties
  • EL Functions
  • EL Variables
  • EL in Stand-alone environment

EL Context

An important goal of the EL is to ensure it can be used in a variety of environments. It must therefore provide enough flexibility to adapt to the specific requirements of the environment where it is being used.

Class ELContext is what links the EL with the specific environment where it is being used. It provides the mechanism through which all relevant context for creating or evaluating an expression is specified.

When EL used in a web container, the creation of ELContext objects is controlled through the underlying technology. For example, in JSP, the JspContext.getELContext() factory method is used. In an stand-alone environment, a default StandardELContext is provided.

Some technologies provide the ability to add an ELContextListener so that applications and frameworks can ensure their own context objects are attached to any newly created ELContext.

Expression Objects

At the core of the Expression Language is the notion of an expression that gets parsed according to the grammar defined by the Expression Language.

There are two types of expressions defined by the EL: value expressions and method expressions. A ValueExpression such as "${customer.name}" can be used either as an rvalue (return the value associated with property name of the model object customer) or as an lvalue (set the value of the property name of the model object customer).

A MethodExpression such as "${handler.process}" makes it possible to invoke a method (process) on a specific model object (handler).

In version 2.2 and later, either type of EL expression can represent a method invocation, such as ${trader.buy("JAVA")}, where the arugments to the method invocation are specified in the expression.

All expression classes extend the base class Expression, making them serializable and forcing them to implement equals() and hashCode(). Morevover, each method on these expression classes that actually evaluates an expression receives a parameter of class ELContext, which provides the context required to evaluate the expression.

Creation of Expressions

An expression is created through the ExpressionFactory class. The factory provides two creation methods; one for each type of expression supported by the EL.

To create an expression, one must provide an ELContext, a string representing the expression, and the expected type (ValueExpression) or signature (MethodExpression). The ELContext provides the context necessary to parse an expression. Specifically, if the expression uses an EL function (for example ${fn:toUpperCase(customer.name)}) or an EL variable, then FunctionMapper and VariableMapper objects must be available within the ELContext so that EL functions and EL variables are properly mapped.

Evaluation of Expressions

The creation and the evaluation of an expression are done in two separate steps. At the evaluation of an expression, the ELContext provides the context necessary to support property and method resolution for modal objects.

A deferred expression is one that is created but not immediately evaluated. In a JSF request processing life cycle, EL expressions are typically created in the tree building phase and evaluated in the rendering phrase.

Adding parameters to a ValueExpression further enhances the power of deferred expressions. The LambdaExpression encapsulates such a construct. A LambdaExpression can be invoked by supplying the actual parameters at evaluation. It plays an important role in the support for collections operators.

Evaluation Listeners

By registering EvaluationListeners in ELContext, a user can receive notifications during the EL expression evaluations. There are three events that trigger the notification:

  • Before evaluation
  • After evaluation
  • When (base, property) is resolved

Resolution of Model Objects and their Properties

Through the ELResolver base class, the EL features a pluggable mechanism to resolve model object references as well as properties and method invocations of these objects.

The EL API provides implementations of ELResolver supporting property resolution for common data types which include arrays (ArrayELResolver), JavaBeans (BeanELResolver), Lists (ListELResolver), Maps (MapELResolver), and ResourceBundles (ResourceBundleELResolver).

Tools can easily obtain more information about resolvable model objects and their resolvable properties by calling method getFeatureDescriptors on the ELResolver. This method exposes objects of type java.beans.FeatureDescriptor, providing all information of interest on top-level model objects as well as their properties.

EL Functions

If an EL expression uses a function (for example ${fn:toUpperCase(customer.name)}), then a FunctionMapper object must also be specified within the ELContext. The FunctionMapper is responsible to map ${prefix:name()} style functions to static methods that can execute the specified functions.

EL Variables

Just like FunctionMapper provides a flexible mechanism to add functions to the EL, VariableMapper provides a flexible mechanism to support the notion of EL variables.

An EL variable does not directly refer to a model object that can then be resolved by an ELResolver. Instead, it refers to an EL expression. The evaluation of that EL expression gives the EL variable its value.

For example, in the following code snippet

<h:inputText value="#{handler.customer.name}"/>
handler refers to a model object that can be resolved by an EL Resolver.

However, in this other example:

<c:forEach var="item" items="#{model.list}">
   <h:inputText value="#{item.name}"/>
</c:forEach>
item is an EL variable because it does not refer directly to a model object. Instead, it refers to another EL expression, namely a specific item in the collection referred to by the EL expression #{model.list}.

Assuming that there are three elements in ${model.list}, this means that for each invocation of <h:inputText>, the following information about item must be preserved in the VariableMapper:

first invocation: item maps to first element in ${model.list}
second invocation: item maps to second element in ${model.list}
third invocation: item maps to third element in ${model.list}

VariableMapper provides the mechanisms required to allow the mapping of an EL variable to the EL expression from which it gets its value.

EL in Stand-alone environment

EL 3.0 includes APIs for using EL in a stand-alone environment.

ELProcessor provides simple APIs for the direct evaluations of expressions. It also makes it easy to define functions, set variables, and define a beans locally.

ELManager provides a lower level APIs for managing the EL parsing and evaluation environment. It contains a default ELContext StandardELContext.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.el Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.el

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.el.BeanNameResolver
    • javax.el.ELClass
    • javax.el.ELContext
      • javax.el.StandardELContext
    • javax.el.ELManager
    • javax.el.ELProcessor
    • javax.el.ELResolver
      • javax.el.ArrayELResolver
      • javax.el.BeanELResolver
      • javax.el.BeanNameELResolver
      • javax.el.CompositeELResolver
      • javax.el.ListELResolver
      • javax.el.MapELResolver
      • javax.el.ResourceBundleELResolver
      • javax.el.StaticFieldELResolver
      • javax.el.TypeConverter
    • javax.el.EvaluationListener
    • java.util.EventObject (implements java.io.Serializable)
      • javax.el.ELContextEvent
    • javax.el.Expression (implements java.io.Serializable)
      • javax.el.MethodExpression
      • javax.el.ValueExpression
    • javax.el.ExpressionFactory
    • javax.el.FunctionMapper
    • javax.el.ImportHandler
    • javax.el.LambdaExpression
    • javax.el.MethodInfo
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.el.ELException
            • javax.el.MethodNotFoundException
            • javax.el.PropertyNotFoundException
            • javax.el.PropertyNotWritableException
    • javax.el.ValueReference (implements java.io.Serializable)
    • javax.el.VariableMapper

Interface Hierarchy

  • java.util.EventListener
    • javax.el.ELContextListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LambdaExpression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class LambdaExpression

  • java.lang.Object
    • javax.el.LambdaExpression

  • public class LambdaExpression
extends Object

    Encapsulates a parameterized ValueExpression.

    A LambdaExpression is a representation of the EL Lambda expression syntax. It consists of a list of the formal parameters and a body, represented by a ValueExpression. The body can be any valid Expression, including another LambdaExpression.

    A LambdaExpression is created when an EL expression containing a Lambda expression is evaluated.

    A LambdaExpression can be invoked by calling invoke(javax.el.ELContext, java.lang.Object...), with an ELContext and a list of the actual arguments. Alternately, a LambdaExpression can be invoked without passing a ELContext, in which case the ELContext previously set by calling setELContext(javax.el.ELContext) will be used. The evaluation of the ValueExpression in the body uses the ELContext to resolve references to the parameters, and to evaluate the lambda expression. The result of the evaluation is returned.

    See Also:
    ELContext.getLambdaArgument(java.lang.String),
ELContext.enterLambdaScope(java.util.Map<java.lang.String, java.lang.Object>),
ELContext.exitLambdaScope()

    • Constructor Summary

      Constructors
      Constructor and Description
      LambdaExpression(List<String> formalParameters, ValueExpression expression)
      Creates a new LambdaExpression.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object invoke(ELContext elContext, Object... args)
      Invoke the encapsulated Lambda expression.
      Object invoke(Object... args)
      Invoke the encapsulated Lambda expression.
      void setELContext(ELContext context)
      Set the ELContext to use in evaluating the LambdaExpression.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • LambdaExpression

        public LambdaExpression(List<String> formalParameters,
                ValueExpression expression)
        Creates a new LambdaExpression.
        Parameters:
        formalParameters - The list of String representing the formal parameters.
        expression - The ValueExpression representing the body.

    • Method Detail

      • setELContext

        public void setELContext(ELContext context)
        Set the ELContext to use in evaluating the LambdaExpression. The ELContext must to be set prior to the invocation of the LambdaExpression, unless it is supplied with invoke(javax.el.ELContext, java.lang.Object...).
        Parameters:
        context - The ELContext to use in evaluating the LambdaExpression.

      • invoke

        public Object invoke(ELContext elContext,
            Object... args)
              throws ELException
        Invoke the encapsulated Lambda expression.

        The supplied arguments are matched, in the same order, to the formal parameters. If there are more arguments than the formal parameters, the extra arguments are ignored. If there are less arguments than the formal parameters, an ELException is thrown.

        The actual Lambda arguments are added to the ELContext and are available during the evaluation of the Lambda expression. They are removed after the evaluation.

        Parameters:
        elContext - The ELContext used for the evaluation of the expression The ELContext set by setELContext(javax.el.ELContext) is ignored.
        args - The arguments to invoke the Lambda expression. For calls with no arguments, an empty array must be provided. A Lambda argument can be null.
        Returns:
        The result of invoking the Lambda expression
        Throws:
        ELException - if not enough arguments are provided
        NullPointerException - is elContext is null

      • invoke

        public Object invoke(Object... args)
        Invoke the encapsulated Lambda expression.

        The supplied arguments are matched, in the same order, to the formal parameters. If there are more arguments than the formal parameters, the extra arguments are ignored. If there are less arguments than the formal parameters, an ELException is thrown.

        The actual Lambda arguments are added to the ELContext and are available during the evaluation of the Lambda expression. They are removed after the evaluation.

        The ELContext set by setELContext(javax.el.ELContext) is used in the evaluation of the lambda Expression.
        Parameters:
        args - The arguments to invoke the Lambda expression. For calls with no arguments, an empty array must be provided. A Lambda argument can be null.
        Returns:
        The result of invoking the Lambda expression
        Throws:
        ELException - if not enough arguments are provided
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ListELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ListELResolver

  • java.lang.Object
    • javax.el.ELResolver
      • javax.el.ListELResolver

  • public class ListELResolver
extends ELResolver
    Defines property resolution behavior on instances of List.

    This resolver handles base objects of type java.util.List. It accepts any object as a property and coerces that object into an integer index into the list. The resulting value is the value in the list at that index.

    This resolver can be constructed in read-only mode, which means that isReadOnly will always return true and setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always throw PropertyNotWritableException.

    ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression. See the javadocs for ELResolver for details.

    Since:
    JSP 2.1
    See Also:
    CompositeELResolver, ELResolver, List

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      ListELResolver()
      Creates a new read/write ListELResolver.
      ListELResolver(boolean isReadOnly)
      Creates a new ListELResolver whose read-only status is determined by the given parameter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getCommonPropertyType(ELContext context, Object base)
      If the base object is a list, returns the most general type that this resolver accepts for the property argument.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      Always returns null, since there is no reason to iterate through set set of all integers.
      Class<?> getType(ELContext context, Object base, Object property)
      If the base object is a list, returns the most general acceptable type for a value in this list.
      Object getValue(ELContext context, Object base, Object property)
      If the base object is a list, returns the value at the given index.
      boolean isReadOnly(ELContext context, Object base, Object property)
      If the base object is a list, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      void setValue(ELContext context, Object base, Object property, Object val)
      If the base object is a list, attempts to set the value at the given index with the given value.

      • Methods inherited from class javax.el.ELResolver

        convertToType, invoke

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ListELResolver

        public ListELResolver()
        Creates a new read/write ListELResolver.

      • ListELResolver

        public ListELResolver(boolean isReadOnly)
        Creates a new ListELResolver whose read-only status is determined by the given parameter.
        Parameters:
        isReadOnly - true if this resolver cannot modify lists; false otherwise.

    • Method Detail

      • getType

        public Class<?> getType(ELContext context,
               Object base,
               Object property)
        If the base object is a list, returns the most general acceptable type for a value in this list.

        If the base is a List, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Assuming the base is a List, this method will always return Object.class. This is because Lists accept any object as an element.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The list to analyze. Only bases of type List are handled by this resolver.
        property - The index of the element in the list to return the acceptable type for. Will be coerced into an integer, but otherwise ignored by this resolver.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
        Throws:
        PropertyNotFoundException - if the given index is out of bounds for this list.
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)
        If the base object is a list, returns the value at the given index. The index is specified by the property argument, and coerced into an integer. If the coercion could not be performed, an IllegalArgumentException is thrown. If the index is out of bounds, null is returned.

        If the base is a List, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The list to be analyzed. Only bases of type List are handled by this resolver.
        property - The index of the value to be returned. Will be coerced into an integer.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the value at the given index or null if the index was out of bounds. Otherwise, undefined.
        Throws:
        IllegalArgumentException - if the property could not be coerced into an integer.
        NullPointerException - if context is null.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object val)
        If the base object is a list, attempts to set the value at the given index with the given value. The index is specified by the property argument, and coerced into an integer. If the coercion could not be performed, an IllegalArgumentException is thrown. If the index is out of bounds, a PropertyNotFoundException is thrown.

        If the base is a List, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value was set.

        If this resolver was constructed in read-only mode, this method will always throw PropertyNotWritableException.

        If a List was created using Collections.unmodifiableList(java.util.List<? extends T>), this method must throw PropertyNotWritableException. Unfortunately, there is no Collections API method to detect this. However, an implementation can create a prototype unmodifiable List and query its runtime type to see if it matches the runtime type of the base object as a workaround.

        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The list to be modified. Only bases of type List are handled by this resolver.
        property - The index of the value to be set. Will be coerced into an integer.
        val - The value to be set at the given index.
        Throws:
        ClassCastException - if the class of the specified element prevents it from being added to this list.
        NullPointerException - if context is null, or if the value is null and this List does not support null elements.
        IllegalArgumentException - if the property could not be coerced into an integer, or if some aspect of the specified element prevents it from being added to this list.
        PropertyNotWritableException - if this resolver was constructed in read-only mode, or if the set operation is not supported by the underlying list.
        PropertyNotFoundException - if the given index is out of bounds for this list.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        If the base object is a list, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

        If the base is a List, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        If this resolver was constructed in read-only mode, this method will always return true.

        If a List was created using Collections.unmodifiableList(java.util.List<? extends T>), this method must return true. Unfortunately, there is no Collections API method to detect this. However, an implementation can create a prototype unmodifiable List and query its runtime type to see if it matches the runtime type of the base object as a workaround.

        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The list to analyze. Only bases of type List are handled by this resolver.
        property - The index of the element in the list to return the acceptable type for. Will be coerced into an integer, but otherwise ignored by this resolver.
        Returns:
        If the propertyResolved property of ELContext was set to true, then true if calling the setValue method will always fail or false if it is possible that such a call may succeed; otherwise undefined.
        Throws:
        PropertyNotFoundException - if the given index is out of bounds for this list.
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        Always returns null, since there is no reason to iterate through set set of all integers.

        The getCommonPropertyType(javax.el.ELContext, java.lang.Object) method returns sufficient information about what properties this resolver accepts.

        Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The list. Only bases of type List are handled by this resolver.
        Returns:
        null.
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<?> getCommonPropertyType(ELContext context,
                             Object base)
        If the base object is a list, returns the most general type that this resolver accepts for the property argument. Otherwise, returns null.

        Assuming the base is a List, this method will always return Integer.class. This is because Lists accept integers as their index.

        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The list to analyze. Only bases of type List are handled by this resolver.
        Returns:
        null if base is not a List; otherwise Integer.class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MapELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class MapELResolver

  • java.lang.Object
    • javax.el.ELResolver
      • javax.el.MapELResolver

  • public class MapELResolver
extends ELResolver
    Defines property resolution behavior on instances of Map.

    This resolver handles base objects of type java.util.Map. It accepts any object as a property and uses that object as a key in the map. The resulting value is the value in the map that is associated with that key.

    This resolver can be constructed in read-only mode, which means that isReadOnly will always return true and setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always throw PropertyNotWritableException.

    ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression. See the javadocs for ELResolver for details.

    Since:
    JSP 2.1
    See Also:
    CompositeELResolver, ELResolver, Map

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      MapELResolver()
      Creates a new read/write MapELResolver.
      MapELResolver(boolean isReadOnly)
      Creates a new MapELResolver whose read-only status is determined by the given parameter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getCommonPropertyType(ELContext context, Object base)
      If the base object is a map, returns the most general type that this resolver accepts for the property argument.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      If the base object is a map, returns an Iterator containing the set of keys available in the Map.
      Class<?> getType(ELContext context, Object base, Object property)
      If the base object is a map, returns the most general acceptable type for a value in this map.
      Object getValue(ELContext context, Object base, Object property)
      If the base object is a map, returns the value associated with the given key, as specified by the property argument.
      boolean isReadOnly(ELContext context, Object base, Object property)
      If the base object is a map, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      void setValue(ELContext context, Object base, Object property, Object val)
      If the base object is a map, attempts to set the value associated with the given key, as specified by the property argument.

      • Methods inherited from class javax.el.ELResolver

        convertToType, invoke

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MapELResolver

        public MapELResolver()
        Creates a new read/write MapELResolver.

      • MapELResolver

        public MapELResolver(boolean isReadOnly)
        Creates a new MapELResolver whose read-only status is determined by the given parameter.
        Parameters:
        isReadOnly - true if this resolver cannot modify maps; false otherwise.

    • Method Detail

      • getType

        public Class<?> getType(ELContext context,
               Object base,
               Object property)
        If the base object is a map, returns the most general acceptable type for a value in this map.

        If the base is a Map, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Assuming the base is a Map, this method will always return Object.class. This is because Maps accept any object as the value for a given key.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The map to analyze. Only bases of type Map are handled by this resolver.
        property - The key to return the acceptable type for. Ignored by this resolver.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)
        If the base object is a map, returns the value associated with the given key, as specified by the property argument. If the key was not found, null is returned.

        If the base is a Map, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Just as in Map.get(java.lang.Object), just because null is returned doesn't mean there is no mapping for the key; it's also possible that the Map explicitly maps the key to null.

        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The map to be analyzed. Only bases of type Map are handled by this resolver.
        property - The key whose associated value is to be returned.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the value associated with the given key or null if the key was not found. Otherwise, undefined.
        Throws:
        ClassCastException - if the key is of an inappropriate type for this map (optionally thrown by the underlying Map).
        NullPointerException - if context is null, or if the key is null and this map does not permit null keys (the latter is optionally thrown by the underlying Map).
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object val)
        If the base object is a map, attempts to set the value associated with the given key, as specified by the property argument.

        If the base is a Map, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value was set.

        If this resolver was constructed in read-only mode, this method will always throw PropertyNotWritableException.

        If a Map was created using Collections.unmodifiableMap(java.util.Map<? extends K, ? extends V>), this method must throw PropertyNotWritableException. Unfortunately, there is no Collections API method to detect this. However, an implementation can create a prototype unmodifiable Map and query its runtime type to see if it matches the runtime type of the base object as a workaround.

        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The map to be modified. Only bases of type Map are handled by this resolver.
        property - The key with which the specified value is to be associated.
        val - The value to be associated with the specified key.
        Throws:
        ClassCastException - if the class of the specified key or value prevents it from being stored in this map.
        NullPointerException - if context is null, or if this map does not permit null keys or values, and the specified key or value is null.
        IllegalArgumentException - if some aspect of this key or value prevents it from being stored in this map.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.
        PropertyNotWritableException - if this resolver was constructed in read-only mode, or if the put operation is not supported by the underlying map.

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        If the base object is a map, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

        If the base is a Map, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        If this resolver was constructed in read-only mode, this method will always return true.

        If a Map was created using Collections.unmodifiableMap(java.util.Map<? extends K, ? extends V>), this method must return true. Unfortunately, there is no Collections API method to detect this. However, an implementation can create a prototype unmodifiable Map and query its runtime type to see if it matches the runtime type of the base object as a workaround.

        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The map to analyze. Only bases of type Map are handled by this resolver.
        property - The key to return the read-only status for. Ignored by this resolver.
        Returns:
        If the propertyResolved property of ELContext was set to true, then true if calling the setValue method will always fail or false if it is possible that such a call may succeed; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        If the base object is a map, returns an Iterator containing the set of keys available in the Map. Otherwise, returns null.

        The Iterator returned must contain zero or more instances of FeatureDescriptor. Each info object contains information about a key in the Map, and is initialized as follows:

      • displayName - The return value of calling the toString method on this key, or "null" if the key is null.
      • name - Same as displayName property.
      • shortDescription - Empty string
      • expert - false
      • hidden - false
      • preferred - true
        • In addition, the following named attributes must be set in the returned FeatureDescriptors:
      • ELResolver.TYPE - The return value of calling the getClass() method on this key, or null if the key is null.
      • ELResolver.RESOLVABLE_AT_DESIGN_TIME - true

        • Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The map whose keys are to be iterated over. Only bases of type Map are handled by this resolver.
        Returns:
        An Iterator containing zero or more (possibly infinitely more) FeatureDescriptor objects, each representing a key in this map, or null if the base object is not a map.
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<?> getCommonPropertyType(ELContext context,
                             Object base)
        If the base object is a map, returns the most general type that this resolver accepts for the property argument. Otherwise, returns null.

        Assuming the base is a Map, this method will always return Object.class. This is because Maps accept any object as a key.

        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The map to analyze. Only bases of type Map are handled by this resolver.
        Returns:
        null if base is not a Map; otherwise Object.class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MethodExpression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class MethodExpression

  • java.lang.Object
    • javax.el.Expression
      • javax.el.MethodExpression
  • All Implemented Interfaces:
    Serializable

    public abstract class MethodExpression
extends Expression
    An Expression that refers to a method on an object.

    The ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>, java.lang.Class<?>[]) method can be used to parse an expression string and return a concrete instance of MethodExpression that encapsulates the parsed expression. The FunctionMapper is used at parse time, not evaluation time, so one is not needed to evaluate an expression using this class. However, the ELContext is needed at evaluation time.

    The getMethodInfo(javax.el.ELContext) and invoke(javax.el.ELContext, java.lang.Object[]) methods will evaluate the expression each time they are called. The ELResolver in the ELContext is used to resolve the top-level variables and to determine the behavior of the . and [] operators. For any of the two methods, the ELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object) method is used to resolve all properties up to but excluding the last one. This provides the base object on which the method appears. If the base object is null, a PropertyNotFoundException must be thrown. At the last resolution, the final property is then coerced to a String, which provides the name of the method to be found. A method matching the name and expected parameters provided at parse time is found and it is either queried or invoked (depending on the method called on this MethodExpression).

    See the notes about comparison, serialization and immutability in the Expression javadocs.

    Since:
    JSP 2.1
    See Also:
    ELResolver, Expression, ExpressionFactory, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodExpression()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract MethodInfo getMethodInfo(ELContext context)
      Evaluates the expression relative to the provided context, and returns information about the actual referenced method.
      abstract Object invoke(ELContext context, Object[] params)
      If a String literal is specified as the expression, returns the String literal coerced to the expected return type of the method signature.
      boolean isParametersProvided()
      Return whether this MethodExpression was created with parameters.
      boolean isParmetersProvided()
      Deprecated.

      • Methods inherited from class javax.el.Expression

        equals, getExpressionString, hashCode, isLiteralText

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MethodExpression

        public MethodExpression()

    • Method Detail

      • getMethodInfo

        public abstract MethodInfo getMethodInfo(ELContext context)
        Evaluates the expression relative to the provided context, and returns information about the actual referenced method.
        Parameters:
        context - The context of this evaluation
        Returns:
        an instance of MethodInfo containing information about the method the expression evaluated to.
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
        MethodNotFoundException - if no suitable method can be found.
        ELException - if an exception was thrown while performing property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • invoke

        public abstract Object invoke(ELContext context,
            Object[] params)
        If a String literal is specified as the expression, returns the String literal coerced to the expected return type of the method signature. An ELException is thrown if expectedReturnType is void or if the coercion of the String literal to the expectedReturnType yields an error (see Section "1.18 Type Conversion" of the EL specification). If not a String literal, evaluates the expression relative to the provided context, invokes the method that was found using the supplied parameters, and returns the result of the method invocation. Any parameters passed to this method is ignored if isLiteralText() or isParmetersProvided() is true.
        Parameters:
        context - The context of this evaluation.
        params - The parameters to pass to the method, or null if no parameters.
        Returns:
        the result of the method invocation (null if the method has a void return type).
        Throws:
        NullPointerException - if context is null
        PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
        MethodNotFoundException - if no suitable method can be found.
        ELException - if a String literal is specified and expectedReturnType of the MethodExpression is void or if the coercion of the String literal to the expectedReturnType yields an error (see Section "1.18 Type Conversion").
        ELException - if an exception was thrown while performing property or variable resolution. The thrown exception must be included as the cause property of this exception, if available. If the exception thrown is an InvocationTargetException, extract its cause and pass it to the ELException constructor.

      • isParametersProvided

        public boolean isParametersProvided()
        Return whether this MethodExpression was created with parameters.

        This method must return true if and only if parameters are specified in the EL, using the expr-a.expr-b(...) syntax.

        Returns:
        true if the MethodExpression was created with parameters, false otherwise.
        Since:
        EL 2.2

      • isParmetersProvided

        @Deprecated
public boolean isParmetersProvided()
        Deprecated.
        Use isParametersProvided instead.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MethodInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class MethodInfo

  • java.lang.Object
    • javax.el.MethodInfo

  • public class MethodInfo
extends Object
    Holds information about a method that a MethodExpression evaluated to.
    Since:
    JSP 2.1

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodInfo(String name, Class<?> returnType, Class<?>[] paramTypes)
      Creates a new instance of MethodInfo with the given information.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Returns the name of the method
      Class<?>[] getParamTypes()
      Returns the parameter types of the method
      Class<?> getReturnType()
      Returns the return type of the method

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MethodInfo

        public MethodInfo(String name,
          Class<?> returnType,
          Class<?>[] paramTypes)
        Creates a new instance of MethodInfo with the given information.
        Parameters:
        name - The name of the method
        returnType - The return type of the method
        paramTypes - The types of each of the method's parameters

    • Method Detail

      • getName

        public String getName()
        Returns the name of the method
        Returns:
        the name of the method

      • getReturnType

        public Class<?> getReturnType()
        Returns the return type of the method
        Returns:
        the return type of the method

      • getParamTypes

        public Class<?>[] getParamTypes()
        Returns the parameter types of the method
        Returns:
        the parameter types of the method
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MethodNotFoundException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class MethodNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.el.ELException
            • javax.el.MethodNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class MethodNotFoundException
extends ELException
    Thrown when a method could not be found while evaluating a MethodExpression.
    Since:
    JSP 2.1
    See Also:
    MethodExpression, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodNotFoundException()
      Creates a MethodNotFoundException with no detail message.
      MethodNotFoundException(String message)
      Creates a MethodNotFoundException with the provided detail message.
      MethodNotFoundException(String pMessage, Throwable pRootCause)
      Creates a MethodNotFoundException with the given detail message and root cause.
      MethodNotFoundException(Throwable exception)
      Creates a MethodNotFoundException with the given root cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MethodNotFoundException

        public MethodNotFoundException()
        Creates a MethodNotFoundException with no detail message.

      • MethodNotFoundException

        public MethodNotFoundException(String message)
        Creates a MethodNotFoundException with the provided detail message.
        Parameters:
        message - the detail message

      • MethodNotFoundException

        public MethodNotFoundException(Throwable exception)
        Creates a MethodNotFoundException with the given root cause.
        Parameters:
        exception - the originating cause of this exception

      • MethodNotFoundException

        public MethodNotFoundException(String pMessage,
                       Throwable pRootCause)
        Creates a MethodNotFoundException with the given detail message and root cause.
        Parameters:
        pMessage - the detail message
        pRootCause - the originating cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PropertyNotFoundException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class PropertyNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.el.ELException
            • javax.el.PropertyNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class PropertyNotFoundException
extends ELException
    Thrown when a property could not be found while evaluating a ValueExpression or MethodExpression.

    For example, this could be triggered by an index out of bounds while setting an array value, or by an unreadable property while getting the value of a JavaBeans property.

    Since:
    JSP 2.1
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      PropertyNotFoundException()
      Creates a PropertyNotFoundException with no detail message.
      PropertyNotFoundException(String message)
      Creates a PropertyNotFoundException with the provided detail message.
      PropertyNotFoundException(String pMessage, Throwable pRootCause)
      Creates a PropertyNotFoundException with the given detail message and root cause.
      PropertyNotFoundException(Throwable exception)
      Creates a PropertyNotFoundException with the given root cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PropertyNotFoundException

        public PropertyNotFoundException()
        Creates a PropertyNotFoundException with no detail message.

      • PropertyNotFoundException

        public PropertyNotFoundException(String message)
        Creates a PropertyNotFoundException with the provided detail message.
        Parameters:
        message - the detail message

      • PropertyNotFoundException

        public PropertyNotFoundException(Throwable exception)
        Creates a PropertyNotFoundException with the given root cause.
        Parameters:
        exception - the originating cause of this exception

      • PropertyNotFoundException

        public PropertyNotFoundException(String pMessage,
                         Throwable pRootCause)
        Creates a PropertyNotFoundException with the given detail message and root cause.
        Parameters:
        pMessage - the detail message
        pRootCause - the originating cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PropertyNotWritableException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class PropertyNotWritableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.el.ELException
            • javax.el.PropertyNotWritableException
  • All Implemented Interfaces:
    Serializable

    public class PropertyNotWritableException
extends ELException
    Thrown when a property could not be written to while setting the value on a ValueExpression.

    For example, this could be triggered by trying to set a map value on an unmodifiable map.

    Since:
    JSP 2.1
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      PropertyNotWritableException()
      Creates a PropertyNotWritableException with no detail message.
      PropertyNotWritableException(String pMessage)
      Creates a PropertyNotWritableException with the provided detail message.
      PropertyNotWritableException(String pMessage, Throwable pRootCause)
      Creates a PropertyNotWritableException with the given detail message and root cause.
      PropertyNotWritableException(Throwable exception)
      Creates a PropertyNotWritableException with the given root cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PropertyNotWritableException

        public PropertyNotWritableException()
        Creates a PropertyNotWritableException with no detail message.

      • PropertyNotWritableException

        public PropertyNotWritableException(String pMessage)
        Creates a PropertyNotWritableException with the provided detail message.
        Parameters:
        pMessage - the detail message

      • PropertyNotWritableException

        public PropertyNotWritableException(Throwable exception)
        Creates a PropertyNotWritableException with the given root cause.
        Parameters:
        exception - the originating cause of this exception

      • PropertyNotWritableException

        public PropertyNotWritableException(String pMessage,
                            Throwable pRootCause)
        Creates a PropertyNotWritableException with the given detail message and root cause.
        Parameters:
        pMessage - the detail message
        pRootCause - the originating cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceBundleELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ResourceBundleELResolver

  • java.lang.Object
    • javax.el.ELResolver
      • javax.el.ResourceBundleELResolver

  • public class ResourceBundleELResolver
extends ELResolver
    Defines property resolution behavior on instances of ResourceBundle.

    This resolver handles base objects of type java.util.ResourceBundle. It accepts any object as a property and coerces it to a java.lang.String for invoking ResourceBundle.getObject(java.lang.String).

    This resolver is read only and will throw a PropertyNotWritableException if setValue is called.

    ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression. See the javadocs for ELResolver for details.

    Since:
    JSP 2.1
    See Also:
    CompositeELResolver, ELResolver, ResourceBundle

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceBundleELResolver()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getCommonPropertyType(ELContext context, Object base)
      If the base object is a ResourceBundle, returns the most general type that this resolver accepts for the property argument.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      If the base object is a ResourceBundle, returns an Iterator containing the set of keys available in the ResourceBundle.
      Class<?> getType(ELContext context, Object base, Object property)
      If the base object is an instance of ResourceBundle, return null, since the resolver is read only.
      Object getValue(ELContext context, Object base, Object property)
      If the base object is an instance of ResourceBundle, the provided property will first be coerced to a String.
      boolean isReadOnly(ELContext context, Object base, Object property)
      If the base object is not null and an instanceof ResourceBundle, return true.
      void setValue(ELContext context, Object base, Object property, Object value)
      If the base object is a ResourceBundle, throw a PropertyNotWritableException.

      • Methods inherited from class javax.el.ELResolver

        convertToType, invoke

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ResourceBundleELResolver

        public ResourceBundleELResolver()

    • Method Detail

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)
        If the base object is an instance of ResourceBundle, the provided property will first be coerced to a String. The Object returned by getObject on the base ResourceBundle will be returned.

        If the base is ResourceBundle, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The ResourceBundle to analyze.
        property - The name of the property to analyze. Will be coerced to a String.
        Returns:
        If the propertyResolved property of ELContext was set to true, then null if property is null; otherwise the Object for the given key (property coerced to String) from the ResourceBundle. If no object for the given key can be found, then the String "???" + key + "???".
        Throws:
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getType

        public Class<?> getType(ELContext context,
               Object base,
               Object property)
        If the base object is an instance of ResourceBundle, return null, since the resolver is read only.

        If the base is ResourceBundle, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The ResourceBundle to analyze.
        property - The name of the property to analyze.
        Returns:
        If the propertyResolved property of ELContext was set to true, then null; otherwise undefined.
        Throws:
        NullPointerException - if context is null

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object value)
        If the base object is a ResourceBundle, throw a PropertyNotWritableException.
        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The ResourceBundle to be modified. Only bases that are of type ResourceBundle are handled.
        property - The String property to use.
        value - The value to be set.
        Throws:
        NullPointerException - if context is null.
        PropertyNotWritableException - Always thrown if base is an instance of ReasourceBundle.

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        If the base object is not null and an instanceof ResourceBundle, return true.
        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The ResourceBundle to be modified. Only bases that are of type ResourceBundle are handled.
        property - The String property to use.
        Returns:
        If the propertyResolved property of ELContext was set to true, then true; otherwise undefined.
        Throws:
        NullPointerException - if context is null

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        If the base object is a ResourceBundle, returns an Iterator containing the set of keys available in the ResourceBundle. Otherwise, returns null.

        The Iterator returned must contain zero or more instances of FeatureDescriptor. Each info object contains information about a key in the ResourceBundle, and is initialized as follows:

      • displayName - The String key
      • name - Same as displayName property.
      • shortDescription - Empty string
      • expert - false
      • hidden - false
      • preferred - true
        • In addition, the following named attributes must be set in the returned FeatureDescriptors:
      • ELResolver.TYPE - String.class
      • ELResolver.RESOLVABLE_AT_DESIGN_TIME - true

        • Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The bundle whose keys are to be iterated over. Only bases of type ResourceBundle are handled by this resolver.
        Returns:
        An Iterator containing zero or more (possibly infinitely more) FeatureDescriptor objects, each representing a key in this bundle, or null if the base object is not a ResourceBundle.
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<?> getCommonPropertyType(ELContext context,
                             Object base)
        If the base object is a ResourceBundle, returns the most general type that this resolver accepts for the property argument. Otherwise, returns null.

        Assuming the base is a ResourceBundle, this method will always return String.class.

        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The bundle to analyze. Only bases of type ResourceBundle are handled by this resolver.
        Returns:
        null if base is not a ResourceBundle; otherwise String.class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StandardELContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class StandardELContext

  • java.lang.Object
    • javax.el.ELContext
      • javax.el.StandardELContext

  • public class StandardELContext
extends ELContext
    A standard ELContext suitable for use in a stand alone environment. This class provides a default implementation of an ELResolver that contains a number of useful ELResolvers. It also provides local repositories for the FunctionMapper, VariableMapper, and BeanNameResolver.
    Since:
    EL 3.0

    • Constructor Summary

      Constructors
      Constructor and Description
      StandardELContext(ELContext context)
      Construct a StandardELContext from another ELContext.
      StandardELContext(ExpressionFactory factory)
      Construct a default ELContext for a stand-alone environment.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addELResolver(ELResolver cELResolver)
      Add a custom ELResolver to the context.
      Object getContext(Class key)
      Returns the context object associated with the given key.
      ELResolver getELResolver()
      Construct (if needed) and return a default ELResolver.
      FunctionMapper getFunctionMapper()
      Construct (if needed) and return a default FunctionMapper.
      VariableMapper getVariableMapper()
      Construct (if needed) and return a default VariableMapper() {
      void putContext(Class key, Object contextObject)
      Associates a context object with this ELContext.

      • Methods inherited from class javax.el.ELContext

        addEvaluationListener, convertToType, enterLambdaScope, exitLambdaScope, getEvaluationListeners, getImportHandler, getLambdaArgument, getLocale, isLambdaArgument, isPropertyResolved, notifyAfterEvaluation, notifyBeforeEvaluation, notifyPropertyResolved, setLocale, setPropertyResolved, setPropertyResolved

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • StandardELContext

        public StandardELContext(ExpressionFactory factory)
        Construct a default ELContext for a stand-alone environment.
        Parameters:
        factory - The ExpressionFactory

      • StandardELContext

        public StandardELContext(ELContext context)
        Construct a StandardELContext from another ELContext.
        Parameters:
        context - The ELContext that acts as a delegate in most cases

    • Method Detail

      • putContext

        public void putContext(Class key,
              Object contextObject)
        Description copied from class: ELContext
        Associates a context object with this ELContext.

        The ELContext maintains a collection of context objects relevant to the evaluation of an expression. These context objects are used by ELResolvers. This method is used to add a context object to that collection.

        By convention, the contextObject will be of the type specified by the key. However, this is not required and the key is used strictly as a unique identifier.

        Overrides:
        putContext in class ELContext
        Parameters:
        key - The key used by an @{link ELResolver} to identify this context object.
        contextObject - The context object to add to the collection.

      • getContext

        public Object getContext(Class key)
        Description copied from class: ELContext
        Returns the context object associated with the given key.

        The ELContext maintains a collection of context objects relevant to the evaluation of an expression. These context objects are used by ELResolvers. This method is used to retrieve the context with the given key from the collection.

        By convention, the object returned will be of the type specified by the key. However, this is not required and the key is used strictly as a unique identifier.

        Overrides:
        getContext in class ELContext
        Parameters:
        key - The unique identifier that was used to associate the context object with this ELContext.
        Returns:
        The context object associated with the given key, or null if no such context was found.

      • getELResolver

        public ELResolver getELResolver()
        Construct (if needed) and return a default ELResolver.

        Retrieves the ELResolver associated with this context. This is a CompositeELResover consists of an ordered list of ELResolvers.

        1. A BeanNameELResolver for beans defined locally
        2. Any custom ELResolvers
        3. An ELResolver supporting the collection operations
        4. A StaticFieldELResolver for resolving static fields
        5. A MapELResolver for resolving Map properties
        6. A ResourceBundleELResolver for resolving ResourceBundle properties
        7. A ListELResolver for resolving List properties
        8. An ArrayELResolver for resolving array properties
        9. A BeanELResolver for resolving bean properties

        Specified by:
        getELResolver in class ELContext
        Returns:
        The ELResolver for this context.

      • addELResolver

        public void addELResolver(ELResolver cELResolver)
        Add a custom ELResolver to the context. The list of the custom ELResolvers will be accessed in the order they are added. A custom ELResolver added to the context cannot be removed.
        Parameters:
        cELResolver - The new ELResolver to be added to the context

      • getFunctionMapper

        public FunctionMapper getFunctionMapper()
        Construct (if needed) and return a default FunctionMapper.
        Specified by:
        getFunctionMapper in class ELContext
        Returns:
        The default FunctionMapper

      • getVariableMapper

        public VariableMapper getVariableMapper()
        Construct (if needed) and return a default VariableMapper() {
        Specified by:
        getVariableMapper in class ELContext
        Returns:
        The default Variable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StaticFieldELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class StaticFieldELResolver

  • java.lang.Object
    • javax.el.ELResolver
      • javax.el.StaticFieldELResolver

  • public class StaticFieldELResolver
extends ELResolver

    An ELResolver for resolving static fields, enum constants and static methods. Also handles constructor calls as a special case.

    The resolver handles base objects of the type ELClass, which is usually generated by an EL implementation.

    Since:
    EL 3.0
    See Also:
    ELClass

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      StaticFieldELResolver()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getCommonPropertyType(ELContext context, Object base)
      Returns the type of the property.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      Returns the properties that can be resolved.
      Class<?> getType(ELContext context, Object base, Object property)
      Returns the type of a static field.
      Object getValue(ELContext context, Object base, Object property)
      Returns the value of a static field.
      Object invoke(ELContext context, Object base, Object method, Class<?>[] paramTypes, Object[] params)
      Invokes a public static method or the constructor for a class.
      boolean isReadOnly(ELContext context, Object base, Object property)
      Inquires whether the static field is writable.
      void setValue(ELContext context, Object base, Object property, Object value)
      Attempts to write to a static field.

      • Methods inherited from class javax.el.ELResolver

        convertToType

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • StaticFieldELResolver

        public StaticFieldELResolver()

    • Method Detail

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)

        Returns the value of a static field.

        If the base object is an instance of ELClass and the property is String, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        If the property is a public static field of class specified in ELClass, return the value of the static field. An Enum constant is a public static field of an Enum object, and is a special case of this.
        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - An ELClass.
        property - A static field name.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the static field value.
        Throws:
        NullPointerException - if context is null.
        PropertyNotFoundException - if the specified class does not exist, or if the field is not a public static filed of the class, or if the field is inaccessible.

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object value)

        Attempts to write to a static field.

        If the base object is an instance of ELClassand the property is String, a PropertyNotWritableException will always be thrown, because writing to a static field is not allowed.

        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - An ELClass
        property - The name of the field
        value - The value to set the field of the class to.
        Throws:
        NullPointerException - if context is null
        PropertyNotWritableException

      • invoke

        public Object invoke(ELContext context,
            Object base,
            Object method,
            Class<?>[] paramTypes,
            Object[] params)

        Invokes a public static method or the constructor for a class.

        If the base object is an instance of ELClass and the method is a String, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Invoke the public static method specified by method.

        The process involved in the method selection is the same as that used in BeanELResolver.

        As a special case, if the name of the method is "<init>", the constructor for the class will be invoked.

        Overrides:
        invoke in class ELResolver
        Parameters:
        base - An ELClass
        method - When coerced to a String, the simple name of the method.
        paramTypes - An array of Class objects identifying the method's formal parameter types, in declared order. Use an empty array if the method has no parameters. Can be null, in which case the method's formal parameter types are assumed to be unknown.
        params - The parameters to pass to the method, or null if no parameters.
        context - The context of this evaluation.
        Returns:
        The result of the method invocation (null if the method has a void return type).
        Throws:
        MethodNotFoundException - if no suitable method can be found.
        ELException - if an exception was thrown while performing (base, method) resolution. The thrown exception must be included as the cause property of this exception, if available. If the exception thrown is an InvocationTargetException, extract its cause and pass it to the ELException constructor.

      • getType

        public Class<?> getType(ELContext context,
               Object base,
               Object property)

        Returns the type of a static field.

        If the base object is an instance of ELClassand the property is a String, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value has been set.

        If the property string is a public static field of class specified in ELClass, return the type of the static field.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - An ELClass.
        property - The name of the field.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the type of the type of the field.
        Throws:
        NullPointerException - if context is null.
        PropertyNotFoundException - if field is not a public static filed of the class, or if the field is inaccessible.

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)

        Inquires whether the static field is writable.

        If the base object is an instance of ELClassand the property is a String, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value has been set.

        Always returns a true because writing to a static field is not allowed.

        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - An ELClass.
        property - The name of the bean.
        Returns:
        true
        Throws:
        NullPointerException - if context is null.

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        Returns the properties that can be resolved. Always returns null, since there is no reason to iterate through a list of one element: field name.
        Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - An ELClass.
        Returns:
        null.
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<?> getCommonPropertyType(ELContext context,
                             Object base)
        Returns the type of the property. Always returns String.class, since a field name is a String.
        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - An ELClass.
        Returns:
        String.class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TypeConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class TypeConverter

  • java.lang.Object
    • javax.el.ELResolver
      • javax.el.TypeConverter

  • public abstract class TypeConverter
extends ELResolver
    A convenient class for writing an ELResolver to do custom type conversions.

    For example, to convert a String to an instance of MyDate, one can write

         ELProcessor elp = new ELProcessor();
     elp.getELManager().addELResolver(new TypeConverter() {
         Object convertToType(ELContext context, Object obj, Class type) {
             if ((obj instanceof String) && type == MyDate.class) {
                 context.setPropertyResolved(obj, type);
                 return (obj == null)? null: new MyDate(obj.toString());
             }
             return null;
         }
      };
    Since:
    EL 3.0

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Object convertToType(ELContext context, Object obj, Class<?> targetType)
      Converts an object to a specific type.
      Class<?> getCommonPropertyType(ELContext context, Object base)
      Returns the most general type that this resolver accepts for the property argument, given a base object.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      Returns information about the set of variables or properties that can be resolved for the given base object.
      Class<?> getType(ELContext context, Object base, Object property)
      For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.
      Object getValue(ELContext context, Object base, Object property)
      Attempts to resolve the given property object on the given base object.
      boolean isReadOnly(ELContext context, Object base, Object property)
      For a given base and property, attempts to determine whether a call to ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      void setValue(ELContext context, Object base, Object property, Object value)
      Attempts to set the value of the given property object on the given base object.

      • Methods inherited from class javax.el.ELResolver

        invoke

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TypeConverter

        public TypeConverter()

    • Method Detail

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)
        Description copied from class: ELResolver
        Attempts to resolve the given property object on the given base object.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be returned, or null to resolve a top-level variable.
        property - The property or variable to be resolved.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the result of the variable or property resolution; otherwise undefined.

      • getType

        public Class<?> getType(ELContext context,
               Object base,
               Object property)
        Description copied from class: ELResolver
        For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        This is not always the same as getValue().getClass(). For example, in the case of an ArrayELResolver, the getType method will return the element type of the array, which might be a superclass of the type of the actual element that is currently in the specified array element.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be analyzed, or null to analyze a top-level variable.
        property - The property or variable to return the acceptable type for.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object value)
        Description copied from class: ELResolver
        Attempts to set the value of the given property object on the given base object.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value has been set.

        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be set, or null to set a top-level variable.
        property - The property or variable to be set.
        value - The value to set the property or variable to.

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        Description copied from class: ELResolver
        For a given base and property, attempts to determine whether a call to ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

        If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object whose property value is to be analyzed, or null to analyze a top-level variable.
        property - The property or variable to return the read-only status for.
        Returns:
        If the propertyResolved property of ELContext was set to true, then true if the property is read-only or false if not; otherwise undefined.

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        Description copied from class: ELResolver
        Returns information about the set of variables or properties that can be resolved for the given base object. One use for this method is to assist tools in auto-completion.

        If the base parameter is null, the resolver must enumerate the list of top-level variables it can resolve.

        The Iterator returned must contain zero or more instances of FeatureDescriptor, in no guaranteed order. In the case of primitive types such as int, the value null must be returned. This is to prevent the useless iteration through all possible primitive values. A return value of null indicates that this resolver does not handle the given base object or that the results are too complex to represent with this method and the ELResolver.getCommonPropertyType(javax.el.ELContext, java.lang.Object) method should be used instead.

        Each FeatureDescriptor will contain information about a single variable or property. In addition to the standard properties, the FeatureDescriptor must have two named attributes (as set by the setValue method):

        • ELResolver.TYPE - The value of this named attribute must be an instance of java.lang.Class and specify the runtime type of the variable or property.
        • ELResolver.RESOLVABLE_AT_DESIGN_TIME - The value of this named attribute must be an instance of java.lang.Boolean and indicates whether it is safe to attempt to resolve this property at design-time. For instance, it may be unsafe to attempt a resolution at design time if the ELResolver needs access to a resource that is only available at runtime and no acceptable simulated value can be provided.

        The caller should be aware that the Iterator returned might iterate through a very large or even infinitely large set of properties. Care should be taken by the caller to not get stuck in an infinite loop.

        This is a "best-effort" list. Not all ELResolvers will return completely accurate results, but all must be callable at both design-time and runtime (i.e. whether or not Beans.isDesignTime() returns true), without causing errors.

        The propertyResolved property of the ELContext is not relevant to this method. The results of all ELResolvers are concatenated in the case of composite resolvers.

        Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object whose set of valid properties is to be enumerated, or null to enumerate the set of top-level variables that this resolver can evaluate.
        Returns:
        An Iterator containing zero or more (possibly infinitely more) FeatureDescriptor objects, or null if this resolver does not handle the given base object or that the results are too complex to represent with this method
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<?> getCommonPropertyType(ELContext context,
                             Object base)
        Description copied from class: ELResolver
        Returns the most general type that this resolver accepts for the property argument, given a base object. One use for this method is to assist tools in auto-completion.

        This assists tools in auto-completion and also provides a way to express that the resolver accepts a primitive value, such as an integer index into an array. For example, the ArrayELResolver will accept any int as a property, so the return value would be Integer.class.

        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - The base object to return the most general property type for, or null to enumerate the set of top-level variables that this resolver can evaluate.
        Returns:
        null if this ELResolver does not know how to handle the given base object; otherwise Object.class if any type of property is accepted; otherwise the most general property type accepted for the given base.

      • convertToType

        public abstract Object convertToType(ELContext context,
                   Object obj,
                   Class<?> targetType)
        Converts an object to a specific type.

        An ELException is thrown if an error occurs during the conversion.

        Overrides:
        convertToType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        obj - The object to convert.
        targetType - The target type for the conversion.
        Throws:
        ELException - thrown if errors occur.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.el (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.el

  • Packages that use javax.el
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0
    javax.enterprise.inject.spi
    The portable extension integration SPI.
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.el
    DEPRECATED Classes and interfaces for evaluating and processing reference expressions.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.el
    Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
  • Classes in javax.el used by javax.el
    Class and Description
    BeanNameResolver
    Resolves a bean by its known name.
    ELContext
    Context information for expression parsing and evaluation.
    ELContextEvent
    An event which indicates that an ELContext has been created.
    ELException
    Represents any of the exception conditions that can arise during expression evaluation.
    ELManager
    Manages EL parsing and evaluation environment.
    ELResolver
    Enables customization of variable, property, method call, and type conversion resolution behavior for EL expression evaluation.
    EvaluationListener
    The listener interface for receiving notification when an EL expression is evaluated.
    Expression
    Base class for the expression subclasses ValueExpression and MethodExpression, implementing characteristics common to both.
    ExpressionFactory
    Provides an implementation for creating and evaluating EL expressions.
    FunctionMapper
    The interface to a map between EL function names and methods.
    ImportHandler
    Handles imports of class names and package names.
    MethodExpression
    An Expression that refers to a method on an object.
    MethodInfo
    Holds information about a method that a MethodExpression evaluated to.
    PropertyNotWritableException
    Thrown when a property could not be written to while setting the value on a ValueExpression.
    StandardELContext
    A standard ELContext suitable for use in a stand alone environment.
    ValueExpression
    An Expression that can get or set a value.
    ValueReference
    This encapsulates a base model object and one of its properties.
    VariableMapper
    The interface to a map between EL variables and the EL expressions they are associated with.
  • Classes in javax.el used by javax.enterprise.inject.spi
    Class and Description
    ELResolver
    Enables customization of variable, property, method call, and type conversion resolution behavior for EL expression evaluation.
    ExpressionFactory
    Provides an implementation for creating and evaluating EL expressions.
  • Classes in javax.el used by javax.faces.application
    Class and Description
    ELContextListener
    The listener interface for receiving notification when an ELContext is created.
    ELException
    Represents any of the exception conditions that can arise during expression evaluation.
    ELResolver
    Enables customization of variable, property, method call, and type conversion resolution behavior for EL expression evaluation.
    ExpressionFactory
    Provides an implementation for creating and evaluating EL expressions.
    ValueExpression
    An Expression that can get or set a value.
  • Classes in javax.el used by javax.faces.component
    Class and Description
    MethodExpression
    An Expression that refers to a method on an object.
    ValueExpression
    An Expression that can get or set a value.
  • Classes in javax.el used by javax.faces.component.behavior
    Class and Description
    ValueExpression
    An Expression that can get or set a value.
  • Classes in javax.el used by javax.faces.context
    Class and Description
    ELContext
    Context information for expression parsing and evaluation.
  • Classes in javax.el used by javax.faces.el
    Class and Description
    ValueExpression
    An Expression that can get or set a value.
  • Classes in javax.el used by javax.faces.event
    Class and Description
    MethodExpression
    An Expression that refers to a method on an object.
  • Classes in javax.el used by javax.faces.flow
    Class and Description
    MethodExpression
    An Expression that refers to a method on an object.
    ValueExpression
    An Expression that can get or set a value.
  • Classes in javax.el used by javax.faces.flow.builder
    Class and Description
    MethodExpression
    An Expression that refers to a method on an object.
    ValueExpression
    An Expression that can get or set a value.
  • Classes in javax.el used by javax.faces.validator
    Class and Description
    MethodExpression
    An Expression that refers to a method on an object.
  • Classes in javax.el used by javax.faces.view.facelets
    Class and Description
    ELContext
    Context information for expression parsing and evaluation.
    ELException
    Represents any of the exception conditions that can arise during expression evaluation.
    ExpressionFactory
    Provides an implementation for creating and evaluating EL expressions.
    FunctionMapper
    The interface to a map between EL function names and methods.
    MethodExpression
    An Expression that refers to a method on an object.
    ValueExpression
    An Expression that can get or set a value.
    VariableMapper
    The interface to a map between EL variables and the EL expressions they are associated with.
  • Classes in javax.el used by javax.faces.webapp
    Class and Description
    ELContext
    Context information for expression parsing and evaluation.
    ValueExpression
    An Expression that can get or set a value.
  • Classes in javax.el used by javax.servlet.jsp
    Class and Description
    ELContext
    Context information for expression parsing and evaluation.
    ELContextListener
    The listener interface for receiving notification when an ELContext is created.
    ELResolver
    Enables customization of variable, property, method call, and type conversion resolution behavior for EL expression evaluation.
    ExpressionFactory
    Provides an implementation for creating and evaluating EL expressions.
  • Classes in javax.el used by javax.servlet.jsp.el
    Class and Description
    ELContext
    Context information for expression parsing and evaluation.
    ELResolver
    Enables customization of variable, property, method call, and type conversion resolution behavior for EL expression evaluation.
  • Classes in javax.el used by javax.servlet.jsp.jstl.core
    Class and Description
    ELContext
    Context information for expression parsing and evaluation.
    Expression
    Base class for the expression subclasses ValueExpression and MethodExpression, implementing characteristics common to both.
    ValueExpression
    An Expression that can get or set a value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValueExpression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ValueExpression

  • java.lang.Object
    • javax.el.Expression
      • javax.el.ValueExpression
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    IndexedValueExpression, IteratedValueExpression

    public abstract class ValueExpression
extends Expression
    An Expression that can get or set a value.

    In previous incarnations of this API, expressions could only be read. ValueExpression objects can now be used both to retrieve a value and to set a value. Expressions that can have a value set on them are referred to as l-value expressions. Those that cannot are referred to as r-value expressions. Not all r-value expressions can be used as l-value expressions (e.g. "${1+1}" or "${firstName} ${lastName}"). See the EL Specification for details. Expressions that cannot be used as l-values must always return true from isReadOnly().

    The ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>) method can be used to parse an expression string and return a concrete instance of ValueExpression that encapsulates the parsed expression. The FunctionMapper is used at parse time, not evaluation time, so one is not needed to evaluate an expression using this class. However, the ELContext is needed at evaluation time.

    The getValue(javax.el.ELContext), setValue(javax.el.ELContext, java.lang.Object), isReadOnly(javax.el.ELContext), getType(javax.el.ELContext) and getValueReference(javax.el.ELContext) methods will evaluate the expression each time they are called. The ELResolver in the ELContext is used to resolve the top-level variables and to determine the behavior of the . and [] operators. For any of the five methods, the ELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object) method is used to resolve all properties up to but excluding the last one. This provides the base object. For all methods other than the getValueReference(javax.el.ELContext) method, at the last resolution, the ValueExpression will call the corresponding ELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object), ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object), ELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object) or ELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object) method, depending on which was called on the ValueExpression. For the getValueReference(javax.el.ELContext) method, the (base, property) is not resolved by the ELResolver, but an instance of ValueReference is created to encapsulate this (base ,property), and returned.

    See the notes about comparison, serialization and immutability in the Expression javadocs.

    Since:
    JSP 2.1
    See Also:
    ELResolver, Expression, ExpressionFactory, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ValueExpression()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Class<?> getExpectedType()
      Returns the type the result of the expression will be coerced to after evaluation.
      abstract Class<?> getType(ELContext context)
      Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object) method.
      abstract Object getValue(ELContext context)
      Evaluates the expression relative to the provided context, and returns the resulting value.
      ValueReference getValueReference(ELContext context)
      Returns a ValueReference for this expression instance.
      abstract boolean isReadOnly(ELContext context)
      Evaluates the expression relative to the provided context, and returns true if a call to setValue(javax.el.ELContext, java.lang.Object) will always fail.
      abstract void setValue(ELContext context, Object value)
      Evaluates the expression relative to the provided context, and sets the result to the provided value.

      • Methods inherited from class javax.el.Expression

        equals, getExpressionString, hashCode, isLiteralText

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ValueExpression

        public ValueExpression()

    • Method Detail

      • getValue

        public abstract Object getValue(ELContext context)
        Evaluates the expression relative to the provided context, and returns the resulting value.

        The resulting value is automatically coerced to the type returned by getExpectedType(), which was provided to the ExpressionFactory when this expression was created.

        Parameters:
        context - The context of this evaluation.
        Returns:
        The result of the expression evaluation.
        Throws:
        NullPointerException - if context is null.
        PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
        ELException - if an exception was thrown while performing property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • setValue

        public abstract void setValue(ELContext context,
            Object value)
        Evaluates the expression relative to the provided context, and sets the result to the provided value.
        Parameters:
        context - The context of this evaluation.
        value - The new value to be set.
        Throws:
        NullPointerException - if context is null.
        PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
        PropertyNotWritableException - if the final variable or property resolution failed because the specified variable or property is not writable.
        ELException - if an exception was thrown while attempting to set the property or variable. The thrown exception must be included as the cause property of this exception, if available.

      • isReadOnly

        public abstract boolean isReadOnly(ELContext context)
        Evaluates the expression relative to the provided context, and returns true if a call to setValue(javax.el.ELContext, java.lang.Object) will always fail.
        Parameters:
        context - The context of this evaluation.
        Returns:
        true if the expression is read-only or false if not.
        Throws:
        NullPointerException - if context is null.
        PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
        ELException - if an exception was thrown while performing property or variable resolution. The thrown exception must be included as the cause property of this exception, if available. * @throws NullPointerException if context is null

      • getType

        public abstract Class<?> getType(ELContext context)
        Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object) method.

        This is not always the same as getValue().getClass(). For example, in the case of an expression that references an array element, the getType method will return the element type of the array, which might be a superclass of the type of the actual element that is currently in the specified array element.

        Parameters:
        context - The context of this evaluation.
        Returns:
        the most general acceptable type; otherwise undefined.
        Throws:
        NullPointerException - if context is null.
        PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
        ELException - if an exception was thrown while performing property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getExpectedType

        public abstract Class<?> getExpectedType()
        Returns the type the result of the expression will be coerced to after evaluation.
        Returns:
        the expectedType passed to the ExpressionFactory.createValueExpression method that created this ValueExpression.

      • getValueReference

        public ValueReference getValueReference(ELContext context)
        Returns a ValueReference for this expression instance.
        Parameters:
        context - the context of this evaluation
        Returns:
        the ValueReference for this ValueExpression, or null if this ValueExpression is not a reference to a base (null or non-null) and a property. If the base is null, and the property is a EL variable, return the ValueReference for the ValueExpression associated with this EL variable.
        Since:
        EL 2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValueReference (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class ValueReference

  • java.lang.Object
    • javax.el.ValueReference
  • All Implemented Interfaces:
    Serializable

    public class ValueReference
extends Object
implements Serializable
    This encapsulates a base model object and one of its properties.
    Since:
    EL 2.2
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ValueReference(Object base, Object property)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getBase()
      Object getProperty()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ValueReference

        public ValueReference(Object base,
              Object property)

    • Method Detail

      • getBase

        public Object getBase()

      • getProperty

        public Object getProperty()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


VariableMapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.el

Class VariableMapper

  • java.lang.Object
    • javax.el.VariableMapper

  • public abstract class VariableMapper
extends Object
    The interface to a map between EL variables and the EL expressions they are associated with.
    Since:
    JSP 2.1

    • Constructor Summary

      Constructors
      Constructor and Description
      VariableMapper()

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      abstract ValueExpression | resolveVariable(String variable)
      abstract ValueExpression setVariable(String variable, ValueExpression expression)
      Assign a ValueExpression to an EL variable, replacing any previously assignment to the same variable.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • VariableMapper

        public VariableMapper()

    • Method Detail

      • resolveVariable

        public abstract ValueExpression resolveVariable(String variable)
        Parameters:
        variable - The variable name
        Returns:
        the ValueExpression assigned to the variable, null if there is no previous assignment to this variable.

      • setVariable

        public abstract ValueExpression setVariable(String variable,
                          ValueExpression expression)
        Assign a ValueExpression to an EL variable, replacing any previously assignment to the same variable. The assignment for the variable is removed if the expression is null.
        Parameters:
        variable - The variable name
        expression - The ValueExpression to be assigned to the variable.
        Returns:
        The previous ValueExpression assigned to this variable, null if there is no previous assignment to this variable.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.el.ArrayELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ArrayELResolver

No usage of javax.el.ArrayELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.BeanELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.BeanELResolver

No usage of javax.el.BeanELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.BeanNameELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.BeanNameELResolver

No usage of javax.el.BeanNameELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.BeanNameResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.BeanNameResolver

  • Packages that use BeanNameResolver
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0

    • Uses of BeanNameResolver in javax.el

      Methods in javax.el with parameters of type BeanNameResolver
      Modifier and Type Method and Description
      void ELManager.addBeanNameResolver(BeanNameResolver bnr)
      Register a BeanNameResolver.
      Constructors in javax.el with parameters of type BeanNameResolver
      Constructor and Description
      BeanNameELResolver(BeanNameResolver beanNameResolver)
      Constructor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.CompositeELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.CompositeELResolver

No usage of javax.el.CompositeELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ELClass (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ELClass

No usage of javax.el.ELClass
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ELContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ELContext

  • Packages that use ELContext
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.el
    Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of ELContext in javax.el

      Subclasses of ELContext in javax.el
      Modifier and Type Class and Description
      class  StandardELContext
      A standard ELContext suitable for use in a stand alone environment.
      Methods in javax.el that return ELContext
      Modifier and Type Method and Description
      ELContext ELContextEvent.getELContext()
      Returns the ELContext that was created.
      ELContext ELManager.setELContext(ELContext context)
      Set the ELContext used for parsing and evaluating EL expressions.
      Methods in javax.el with parameters of type ELContext
      Modifier and Type | Method and Description
      void EvaluationListener.afterEvaluation(ELContext context, String expression)
      Receives notification after an EL expression is evaluated
      void EvaluationListener.beforeEvaluation(ELContext context, String expression)
      Receives notification before an EL expression is evaluated
      abstract Object TypeConverter.convertToType(ELContext context, Object obj, Class<?> targetType)
      Converts an object to a specific type.
      Object ELResolver.convertToType(ELContext context, Object obj, Class<?> targetType)
      Converts an object to a specific type.
      Object CompositeELResolver.convertToType(ELContext context, Object obj, Class<?> targetType)
      Converts an object to a specific type.
      abstract MethodExpression ExpressionFactory.createMethodExpression(ELContext context, String expression, Class<?> expectedReturnType, Class<?>[] expectedParamTypes)
      Parses an expression into a MethodExpression for later evaluation.
      abstract ValueExpression ExpressionFactory.createValueExpression(ELContext context, String expression, Class<?> expectedType)
      Parses an expression into a ValueExpression for later evaluation.
      Class<?> | TypeConverter.getCommonPropertyType(ELContext context, Object base)
      Class<?> StaticFieldELResolver.getCommonPropertyType(ELContext context, Object base)
      Returns the type of the property.
      Class<?> ResourceBundleELResolver.getCommonPropertyType(ELContext context, Object base)
      If the base object is a ResourceBundle, returns the most general type that this resolver accepts for the property argument.
      Class<?> MapELResolver.getCommonPropertyType(ELContext context, Object base)
      If the base object is a map, returns the most general type that this resolver accepts for the property argument.
      Class<?> ListELResolver.getCommonPropertyType(ELContext context, Object base)
      If the base object is a list, returns the most general type that this resolver accepts for the property argument.
      abstract Class<?> ELResolver.getCommonPropertyType(ELContext context, Object base)
      Returns the most general type that this resolver accepts for the property argument, given a base object.
      Class<?> CompositeELResolver.getCommonPropertyType(ELContext context, Object base)
      Returns the most general type that this resolver accepts for the property argument, given a base object.
      Class<?> BeanNameELResolver.getCommonPropertyType(ELContext context, Object base)
      Always returns String.class, since a bean name is a String.
      Class<?> BeanELResolver.getCommonPropertyType(ELContext context, Object base)
      If the base object is not null, returns the most general type that this resolver accepts for the property argument.
      Class<?> ArrayELResolver.getCommonPropertyType(ELContext context, Object base)
      If the base object is a Java language array, returns the most general type that this resolver accepts for the property argument.
      Iterator<FeatureDescriptor> | TypeConverter.getFeatureDescriptors(ELContext context, Object base)
      Iterator<FeatureDescriptor> StaticFieldELResolver.getFeatureDescriptors(ELContext context, Object base)
      Returns the properties that can be resolved.
      Iterator<FeatureDescriptor> ResourceBundleELResolver.getFeatureDescriptors(ELContext context, Object base)
      If the base object is a ResourceBundle, returns an Iterator containing the set of keys available in the ResourceBundle.
      Iterator<FeatureDescriptor> MapELResolver.getFeatureDescriptors(ELContext context, Object base)
      If the base object is a map, returns an Iterator containing the set of keys available in the Map.
      Iterator<FeatureDescriptor> ListELResolver.getFeatureDescriptors(ELContext context, Object base)
      Always returns null, since there is no reason to iterate through set set of all integers.
      abstract Iterator<FeatureDescriptor> ELResolver.getFeatureDescriptors(ELContext context, Object base)
      Returns information about the set of variables or properties that can be resolved for the given base object.
      Iterator<FeatureDescriptor> CompositeELResolver.getFeatureDescriptors(ELContext context, Object base)
      Returns information about the set of variables or properties that can be resolved for the given base object.
      Iterator<FeatureDescriptor> BeanNameELResolver.getFeatureDescriptors(ELContext context, Object base)
      Always returns null, since there is no reason to iterate through a list of one element: bean name.
      Iterator<FeatureDescriptor> BeanELResolver.getFeatureDescriptors(ELContext context, Object base)
      If the base object is not null, returns an Iterator containing the set of JavaBeans properties available on the given object.
      Iterator<FeatureDescriptor> ArrayELResolver.getFeatureDescriptors(ELContext context, Object base)
      Always returns null, since there is no reason to iterate through set set of all integers.
      abstract MethodInfo MethodExpression.getMethodInfo(ELContext context)
      Evaluates the expression relative to the provided context, and returns information about the actual referenced method.
      abstract Class<?> ValueExpression.getType(ELContext context)
      Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ValueExpression.setValue(javax.el.ELContext, java.lang.Object) method.
      Class<?> | TypeConverter.getType(ELContext context, Object base, Object property)
      Class<?> StaticFieldELResolver.getType(ELContext context, Object base, Object property)
      Returns the type of a static field.
      Class<?> ResourceBundleELResolver.getType(ELContext context, Object base, Object property)
      If the base object is an instance of ResourceBundle, return null, since the resolver is read only.
      Class<?> MapELResolver.getType(ELContext context, Object base, Object property)
      If the base object is a map, returns the most general acceptable type for a value in this map.
      Class<?> ListELResolver.getType(ELContext context, Object base, Object property)
      If the base object is a list, returns the most general acceptable type for a value in this list.
      abstract Class<?> ELResolver.getType(ELContext context, Object base, Object property)
      For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.
      Class<?> CompositeELResolver.getType(ELContext context, Object base, Object property)
      For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the CompositeELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.
      Class<?> BeanNameELResolver.getType(ELContext context, Object base, Object property)
      If the base is null and the property is a name resolvable by the BeanNameResolver, return the type of the bean.
      Class<?> BeanELResolver.getType(ELContext context, Object base, Object property)
      If the base object is not null, returns the most general acceptable type that can be set on this bean property.
      Class<?> ArrayELResolver.getType(ELContext context, Object base, Object property)
      If the base object is an array, returns the most general acceptable type for a value in this array.
      abstract Object ValueExpression.getValue(ELContext context)
      Evaluates the expression relative to the provided context, and returns the resulting value.
      Object | TypeConverter.getValue(ELContext context, Object base, Object property)
      Object StaticFieldELResolver.getValue(ELContext context, Object base, Object property)
      Returns the value of a static field.
      Object ResourceBundleELResolver.getValue(ELContext context, Object base, Object property)
      If the base object is an instance of ResourceBundle, the provided property will first be coerced to a String.
      Object MapELResolver.getValue(ELContext context, Object base, Object property)
      If the base object is a map, returns the value associated with the given key, as specified by the property argument.
      Object ListELResolver.getValue(ELContext context, Object base, Object property)
      If the base object is a list, returns the value at the given index.
      abstract Object ELResolver.getValue(ELContext context, Object base, Object property)
      Attempts to resolve the given property object on the given base object.
      Object CompositeELResolver.getValue(ELContext context, Object base, Object property)
      Attempts to resolve the given property object on the given base object by querying all component resolvers.
      Object BeanNameELResolver.getValue(ELContext context, Object base, Object property)
      If the base object is null and the property is a name that is resolvable by the BeanNameResolver, returns the value resolved by the BeanNameResolver.
      Object BeanELResolver.getValue(ELContext context, Object base, Object property)
      If the base object is not null, returns the current value of the given property on this bean.
      Object ArrayELResolver.getValue(ELContext context, Object base, Object property)
      If the base object is a Java language array, returns the value at the given index.
      ValueReference ValueExpression.getValueReference(ELContext context)
      Returns a ValueReference for this expression instance.
      Object LambdaExpression.invoke(ELContext elContext, Object... args)
      Invoke the encapsulated Lambda expression.
      abstract Object MethodExpression.invoke(ELContext context, Object[] params)
      If a String literal is specified as the expression, returns the String literal coerced to the expected return type of the method signature.
      Object StaticFieldELResolver.invoke(ELContext context, Object base, Object method, Class<?>[] paramTypes, Object[] params)
      Invokes a public static method or the constructor for a class.
      Object ELResolver.invoke(ELContext context, Object base, Object method, Class<?>[] paramTypes, Object[] params)
      Attempts to resolve and invoke the given method on the given base object.
      Object CompositeELResolver.invoke(ELContext context, Object base, Object method, Class<?>[] paramTypes, Object[] params)
      Attemps to resolve and invoke the given method on the given base object by querying all component resolvers.
      Object BeanELResolver.invoke(ELContext context, Object base, Object method, Class<?>[] paramTypes, Object[] params)
      If the base object is not null, invoke the method, with the given parameters on this bean.
      abstract boolean ValueExpression.isReadOnly(ELContext context)
      Evaluates the expression relative to the provided context, and returns true if a call to ValueExpression.setValue(javax.el.ELContext, java.lang.Object) will always fail.
      boolean | TypeConverter.isReadOnly(ELContext context, Object base, Object property)
      boolean StaticFieldELResolver.isReadOnly(ELContext context, Object base, Object property)
      Inquires whether the static field is writable.
      boolean ResourceBundleELResolver.isReadOnly(ELContext context, Object base, Object property)
      If the base object is not null and an instanceof ResourceBundle, return true.
      boolean MapELResolver.isReadOnly(ELContext context, Object base, Object property)
      If the base object is a map, returns whether a call to MapELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      boolean ListELResolver.isReadOnly(ELContext context, Object base, Object property)
      If the base object is a list, returns whether a call to ListELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      abstract boolean ELResolver.isReadOnly(ELContext context, Object base, Object property)
      For a given base and property, attempts to determine whether a call to ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      boolean CompositeELResolver.isReadOnly(ELContext context, Object base, Object property)
      For a given base and property, attempts to determine whether a call to CompositeELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      boolean BeanNameELResolver.isReadOnly(ELContext context, Object base, Object property)
      If the base is null and the property is a name resolvable by the BeanNameResolver, attempts to determine if the bean is writable.
      boolean BeanELResolver.isReadOnly(ELContext context, Object base, Object property)
      If the base object is not null, returns whether a call to BeanELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      boolean ArrayELResolver.isReadOnly(ELContext context, Object base, Object property)
      If the base object is a Java language array, returns whether a call to ArrayELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
      void EvaluationListener.propertyResolved(ELContext context, Object base, Object property)
      Receives notification when the (base, property) pair is resolved
      void LambdaExpression.setELContext(ELContext context)
      Set the ELContext to use in evaluating the LambdaExpression.
      ELContext ELManager.setELContext(ELContext context)
      Set the ELContext used for parsing and evaluating EL expressions.
      abstract void ValueExpression.setValue(ELContext context, Object value)
      Evaluates the expression relative to the provided context, and sets the result to the provided value.
      void | TypeConverter.setValue(ELContext context, Object base, Object property, Object value)
      void StaticFieldELResolver.setValue(ELContext context, Object base, Object property, Object value)
      Attempts to write to a static field.
      void ResourceBundleELResolver.setValue(ELContext context, Object base, Object property, Object value)
      If the base object is a ResourceBundle, throw a PropertyNotWritableException.
      void MapELResolver.setValue(ELContext context, Object base, Object property, Object val)
      If the base object is a map, attempts to set the value associated with the given key, as specified by the property argument.
      void ListELResolver.setValue(ELContext context, Object base, Object property, Object val)
      If the base object is a list, attempts to set the value at the given index with the given value.
      abstract void ELResolver.setValue(ELContext context, Object base, Object property, Object value)
      Attempts to set the value of the given property object on the given base object.
      void CompositeELResolver.setValue(ELContext context, Object base, Object property, Object val)
      Attempts to set the value of the given property object on the given base object.
      void BeanNameELResolver.setValue(ELContext context, Object base, Object property, Object value)
      If the base is null and the property is a name that is resolvable by the BeanNameResolver, the bean in the BeanNameResolver is set to the given value.
      void BeanELResolver.setValue(ELContext context, Object base, Object property, Object val)
      If the base object is not null, attempts to set the value of the given property on this bean.
      void ArrayELResolver.setValue(ELContext context, Object base, Object property, Object val)
      If the base object is a Java language array, attempts to set the value at the given index with the given value.
      Constructors in javax.el with parameters of type ELContext
      Constructor and Description
      ELContextEvent(ELContext source)
      Constructs an ELContextEvent object to indicate that an ELContext has been created.
      StandardELContext(ELContext context)
      Construct a StandardELContext from another ELContext.

    • Uses of ELContext in javax.faces.context

      Methods in javax.faces.context that return ELContext
      Modifier and Type Method and Description
      ELContext FacesContextWrapper.getELContext()
      The default behavior of this method is to call FacesContext.getELContext() on the wrapped FacesContext object.
      ELContext FacesContext.getELContext()
      Return the ELContext instance for this FacesContext instance.

    • Uses of ELContext in javax.faces.view.facelets

      Subclasses of ELContext in javax.faces.view.facelets
      Modifier and Type Class and Description
      class  FaceletContext

      Context representative of a single request from a Facelet.

    • Uses of ELContext in javax.faces.webapp

      Methods in javax.faces.webapp that return ELContext
      Modifier and Type Method and Description
      protected ELContext UIComponentTagBase.getELContext()
      Return the ELContext for the FacesContext for this request.
      protected ELContext UIComponentELTag.getELContext()
      Return the ELContext for the FacesContext for this request.

    • Uses of ELContext in javax.servlet.jsp

      Methods in javax.servlet.jsp that return ELContext
      Modifier and Type Method and Description
      abstract ELContext JspContext.getELContext()
      Returns the ELContext associated with this JspContext.

    • Uses of ELContext in javax.servlet.jsp.el

      Methods in javax.servlet.jsp.el with parameters of type ELContext
      Modifier and Type Method and Description
      Class<String> ScopedAttributeELResolver.getCommonPropertyType(ELContext context, Object base)
      If the base object is null, returns String.class.
      Class<String> ImplicitObjectELResolver.getCommonPropertyType(ELContext context, Object base)
      If the base object is null, returns String.class.
      Iterator<FeatureDescriptor> ScopedAttributeELResolver.getFeatureDescriptors(ELContext context, Object base)
      If the base object is null, returns an Iterator containing FeatureDescriptor objects with information about each scoped attribute resolved by this resolver.
      Iterator<FeatureDescriptor> ImplicitObjectELResolver.getFeatureDescriptors(ELContext context, Object base)
      If the base object is null, and the property matches the name of a JSP implicit object, returns an Iterator containing FeatureDescriptor objects with information about each JSP implicit object resolved by this resolver.
      Class<Object> ScopedAttributeELResolver.getType(ELContext context, Object base, Object property)
      If the base object is null, returns Object.class to indicate that any type is valid to set for a scoped attribute.
      Class ImplicitObjectELResolver.getType(ELContext context, Object base, Object property)
      If the base object is null, and the property matches the name of a JSP implicit object, returns null to indicate that no types are ever accepted to setValue().
      Object ScopedAttributeELResolver.getValue(ELContext context, Object base, Object property)
      If the base object is null, searches the page, request, session and application scopes for an attribute with the given name and returns it, or null if no attribute exists with the current name.
      Object ImplicitObjectELResolver.getValue(ELContext context, Object base, Object property)
      If the base object is null, and the property matches the name of a JSP implicit object, returns the implicit object.
      boolean ScopedAttributeELResolver.isReadOnly(ELContext context, Object base, Object property)
      If the base object is null, returns false to indicate that scoped attributes are never read-only.
      boolean ImplicitObjectELResolver.isReadOnly(ELContext context, Object base, Object property)
      If the base object is null, and the property matches the name of a JSP implicit object, returns true to indicate that implicit objects cannot be overwritten.
      void ScopedAttributeELResolver.setValue(ELContext context, Object base, Object property, Object val)
      If the base object is null, sets an existing scoped attribute to the new value, or creates a new scoped attribute if one does not exist by this name.
      void ImplicitObjectELResolver.setValue(ELContext context, Object base, Object property, Object val)
      If the base object is null, and the property matches the name of a JSP implicit object, throws PropertyNotWritableException to indicate that implicit objects cannot be overwritten.

    • Uses of ELContext in javax.servlet.jsp.jstl.core

      Methods in javax.servlet.jsp.jstl.core with parameters of type ELContext
      Modifier and Type | Method and Description
      Object IteratedExpression.getItem(ELContext context, int i)
      Evaluates the stored ValueExpression and return the indexed item.
      Class | IteratedValueExpression.getType(ELContext context)
      Class | IndexedValueExpression.getType(ELContext context)
      Object | IteratedValueExpression.getValue(ELContext context)
      Object | IndexedValueExpression.getValue(ELContext context)
      boolean | IteratedValueExpression.isReadOnly(ELContext context)
      boolean | IndexedValueExpression.isReadOnly(ELContext context)
      void | IteratedValueExpression.setValue(ELContext context, Object value)
      void | IndexedValueExpression.setValue(ELContext context, Object value)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ELContextEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ELContextEvent

  • Packages that use ELContextEvent
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0

    • Uses of ELContextEvent in javax.el

      Methods in javax.el with parameters of type ELContextEvent
      Modifier and Type Method and Description
      void ELContextListener.contextCreated(ELContextEvent ece)
      Invoked when a new ELContext has been created.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ELException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ELException

  • Packages that use ELException
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of ELException in javax.el

      Subclasses of ELException in javax.el
      Modifier and Type Class and Description
      class  MethodNotFoundException
      Thrown when a method could not be found while evaluating a MethodExpression.
      class  PropertyNotFoundException
      Thrown when a property could not be found while evaluating a ValueExpression or MethodExpression.
      class  PropertyNotWritableException
      Thrown when a property could not be written to while setting the value on a ValueExpression.
      Methods in javax.el that throw ELException
      Modifier and Type Method and Description
      void ImportHandler.importClass(String name)
      Import a class.
      void ELManager.importClass(String className)
      Import a class.
      void ImportHandler.importStatic(String name)
      Import a static field or method.
      void ELManager.importStatic(String staticMemberName)
      Import a static field or method.
      Object LambdaExpression.invoke(ELContext elContext, Object... args)
      Invoke the encapsulated Lambda expression.

    • Uses of ELException in javax.faces.application

      Methods in javax.faces.application that throw ELException
      Modifier and Type Method and Description
      <T> T ApplicationWrapper.evaluateExpressionGet(FacesContext context, String expression, Class<? extends T> expectedType)
      Deprecated.
      See superclass for alternative.
      <T> T Application.evaluateExpressionGet(FacesContext context, String expression, Class<? extends T> expectedType)
      Get a value by evaluating an expression.

    • Uses of ELException in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that throw ELException
      Modifier and Type Method and Description
      void DelegatingMetaTagHandler.applyNextHandler(FaceletContext ctx, UIComponent c)

      Invoke the apply() method on this instance's TagHandler.nextHandler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ELManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ELManager

  • Packages that use ELManager
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0

    • Uses of ELManager in javax.el

      Methods in javax.el that return ELManager
      Modifier and Type Method and Description
      ELManager ELProcessor.getELManager()
      Return the ELManager used for EL processing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ELProcessor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ELProcessor

No usage of javax.el.ELProcessor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ELResolver

  • Packages that use ELResolver
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0
    javax.enterprise.inject.spi
    The portable extension integration SPI.
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.el
    Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.

    • Uses of ELResolver in javax.el

      Subclasses of ELResolver in javax.el
      Modifier and Type Class and Description
      class  ArrayELResolver
      Defines property resolution behavior on arrays.
      class  BeanELResolver
      Defines property resolution behavior on objects using the JavaBeans component architecture.
      class  BeanNameELResolver
      An ELResolver for resolving user or container managed beans.
      class  CompositeELResolver
      Maintains an ordered composite list of child ELResolvers.
      class  ListELResolver
      Defines property resolution behavior on instances of List.
      class  MapELResolver
      Defines property resolution behavior on instances of Map.
      class  ResourceBundleELResolver
      Defines property resolution behavior on instances of ResourceBundle.
      class  StaticFieldELResolver
      An ELResolver for resolving static fields, enum constants and static methods.
      class  TypeConverter
      A convenient class for writing an ELResolver to do custom type conversions.
      Methods in javax.el that return ELResolver
      Modifier and Type Method and Description
      ELResolver StandardELContext.getELResolver()
      Construct (if needed) and return a default ELResolver.
      abstract ELResolver ELContext.getELResolver()
      Retrieves the ELResolver associated with this context.
      ELResolver ExpressionFactory.getStreamELResolver()
      Retrieves an ELResolver that implements the operations in collections.
      Methods in javax.el with parameters of type ELResolver
      Modifier and Type Method and Description
      void CompositeELResolver.add(ELResolver elResolver)
      Adds the given resolver to the list of component resolvers.
      void StandardELContext.addELResolver(ELResolver cELResolver)
      Add a custom ELResolver to the context.
      void ELManager.addELResolver(ELResolver elr)
      Add an user defined ELResolver to the list of ELResolvers.

    • Uses of ELResolver in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return ELResolver
      Modifier and Type Method and Description
      ELResolver BeanManager.getELResolver()
      Returns a ELResolver that resolves beans by EL name.

    • Uses of ELResolver in javax.faces.application

      Methods in javax.faces.application that return ELResolver
      Modifier and Type Method and Description
      ELResolver ApplicationWrapper.getELResolver()

      The default behavior of this method is to call Application.getELResolver() on the wrapped Application object.
      ELResolver Application.getELResolver()
      Return the singleton ELResolver instance to be used for all EL resolution.
      Methods in javax.faces.application with parameters of type ELResolver
      Modifier and Type Method and Description
      void ApplicationWrapper.addELResolver(ELResolver resolver)

      The default behavior of this method is to call Application.addELResolver(javax.el.ELResolver) on the wrapped Application object.
      void Application.addELResolver(ELResolver resolver)
      Cause an the argument resolver to be added to the resolver chain as specified in section JSF.5.5.1 of the JavaServer Faces Specification.

    • Uses of ELResolver in javax.servlet.jsp

      Methods in javax.servlet.jsp with parameters of type ELResolver
      Modifier and Type Method and Description
      void JspApplicationContext.addELResolver(ELResolver resolver)
      Adds an ELResolver to affect the way EL variables and properties are resolved for EL expressions appearing in JSP pages and tag files.

    • Uses of ELResolver in javax.servlet.jsp.el

      Subclasses of ELResolver in javax.servlet.jsp.el
      Modifier and Type Class and Description
      class  ImplicitObjectELResolver
      Defines variable resolution behavior for the EL implicit objects defined in the JSP specification.
      class  ScopedAttributeELResolver
      Defines variable resolution behavior for scoped attributes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.EvaluationListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.EvaluationListener

  • Packages that use EvaluationListener
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0

    • Uses of EvaluationListener in javax.el

      Methods in javax.el that return types with arguments of type EvaluationListener
      Modifier and Type Method and Description
      List<EvaluationListener> ELContext.getEvaluationListeners()
      Returns the list of registered evaluation listeners.
      Methods in javax.el with parameters of type EvaluationListener
      Modifier and Type Method and Description
      void ELManager.addEvaluationListener(EvaluationListener listener)
      Register an evaluation listener.
      void ELContext.addEvaluationListener(EvaluationListener listener)
      Registers an evaluation listener to the ELContext.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.Expression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.Expression

  • Packages that use Expression
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of Expression in javax.el

      Subclasses of Expression in javax.el
      Modifier and Type Class and Description
      class  MethodExpression
      An Expression that refers to a method on an object.
      class  ValueExpression
      An Expression that can get or set a value.

    • Uses of Expression in javax.servlet.jsp.jstl.core

      Subclasses of Expression in javax.servlet.jsp.jstl.core
      Modifier and Type | Class and Description
      class  | IndexedValueExpression
      class  | IteratedValueExpression
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ExpressionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ExpressionFactory

  • Packages that use ExpressionFactory
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0
    javax.enterprise.inject.spi
    The portable extension integration SPI.
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of ExpressionFactory in javax.el

      Methods in javax.el that return ExpressionFactory
      Modifier and Type Method and Description
      static ExpressionFactory ELManager.getExpressionFactory()
      Return the ExpressionFactory instance used for EL evaluations.
      static ExpressionFactory ExpressionFactory.newInstance()
      Creates a new instance of a ExpressionFactory.
      static ExpressionFactory ExpressionFactory.newInstance(Properties properties)
      Create a new instance of a ExpressionFactory, with optional properties.
      Constructors in javax.el with parameters of type ExpressionFactory
      Constructor and Description
      StandardELContext(ExpressionFactory factory)
      Construct a default ELContext for a stand-alone environment.

    • Uses of ExpressionFactory in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return ExpressionFactory
      Modifier and Type Method and Description
      ExpressionFactory BeanManager.wrapExpressionFactory(ExpressionFactory expressionFactory)
      Returns a wrapper ExpressionFactory that delegates MethodExpression and ValueExpression creation to the given ExpressionFactory.
      Methods in javax.enterprise.inject.spi with parameters of type ExpressionFactory
      Modifier and Type Method and Description
      ExpressionFactory BeanManager.wrapExpressionFactory(ExpressionFactory expressionFactory)
      Returns a wrapper ExpressionFactory that delegates MethodExpression and ValueExpression creation to the given ExpressionFactory.

    • Uses of ExpressionFactory in javax.faces.application

      Methods in javax.faces.application that return ExpressionFactory
      Modifier and Type Method and Description
      ExpressionFactory ApplicationWrapper.getExpressionFactory()

      The default behavior of this method is to call Application.getExpressionFactory() on the wrapped Application object.
      ExpressionFactory Application.getExpressionFactory()
      Return the ExpressionFactory instance for this application.

    • Uses of ExpressionFactory in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return ExpressionFactory
      Modifier and Type Method and Description
      abstract ExpressionFactory FaceletContext.getExpressionFactory()

      The ExpressionFactory to use within the Facelet this context is executing upon.

    • Uses of ExpressionFactory in javax.servlet.jsp

      Methods in javax.servlet.jsp that return ExpressionFactory
      Modifier and Type Method and Description
      ExpressionFactory JspApplicationContext.getExpressionFactory()
      Returns a factory used to create ValueExpressions and MethodExpressions so that EL expressions can be parsed and evaluated.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.FunctionMapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.FunctionMapper

  • Packages that use FunctionMapper
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of FunctionMapper in javax.el

      Methods in javax.el that return FunctionMapper
      Modifier and Type Method and Description
      FunctionMapper StandardELContext.getFunctionMapper()
      Construct (if needed) and return a default FunctionMapper.
      abstract FunctionMapper ELContext.getFunctionMapper()
      Retrieves the FunctionMapper associated with this ELContext.

    • Uses of FunctionMapper in javax.faces.view.facelets

      Methods in javax.faces.view.facelets with parameters of type FunctionMapper
      Modifier and Type Method and Description
      abstract void FaceletContext.setFunctionMapper(FunctionMapper fnMapper)

      Set the FunctionMapper to use in EL evaluation/creation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ImportHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ImportHandler

  • Packages that use ImportHandler
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0

    • Uses of ImportHandler in javax.el

      Methods in javax.el that return ImportHandler
      Modifier and Type Method and Description
      ImportHandler ELContext.getImportHandler()
      Retrieves the ImportHandler associated with this ELContext.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.LambdaExpression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.LambdaExpression

No usage of javax.el.LambdaExpression
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ListELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ListELResolver

No usage of javax.el.ListELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.MapELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.MapELResolver

No usage of javax.el.MapELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.MethodExpression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.MethodExpression

  • Packages that use MethodExpression
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of MethodExpression in javax.el

      Methods in javax.el that return MethodExpression
      Modifier and Type Method and Description
      abstract MethodExpression ExpressionFactory.createMethodExpression(ELContext context, String expression, Class<?> expectedReturnType, Class<?>[] expectedParamTypes)
      Parses an expression into a MethodExpression for later evaluation.

    • Uses of MethodExpression in javax.faces.component

      Methods in javax.faces.component that return MethodExpression
      Modifier and Type | Method and Description
      MethodExpression UIViewAction.getActionExpression()
      Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
      MethodExpression | UICommand.getActionExpression()
      MethodExpression ActionSource2.getActionExpression()
      Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
      MethodExpression UIViewRoot.getAfterPhaseListener()
      Return the MethodExpression that will be invoked after this view is rendered.
      MethodExpression UIViewRoot.getBeforePhaseListener()
      Return the MethodExpression that will be invoked before this view is rendered.
      Methods in javax.faces.component with parameters of type MethodExpression
      Modifier and Type | Method and Description
      void UIViewAction.setActionExpression(MethodExpression actionExpression)
      Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
      void | UICommand.setActionExpression(MethodExpression actionExpression)
      void ActionSource2.setActionExpression(MethodExpression action)
      Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
      void UIViewRoot.setAfterPhaseListener(MethodExpression newAfterPhase)
      Allow an arbitrary method to be called for the "afterPhase" event as the UIViewRoot runs through its lifecycle.
      void UIViewRoot.setBeforePhaseListener(MethodExpression newBeforePhase)
      Allow an arbitrary method to be called for the "beforePhase" event as the UIViewRoot runs through its lifecycle.

    • Uses of MethodExpression in javax.faces.event

      Constructors in javax.faces.event with parameters of type MethodExpression
      Constructor and Description
      MethodExpressionActionListener(MethodExpression methodExpressionOneArg)
      Construct a ValueChangeListener that contains a MethodExpression.
      MethodExpressionActionListener(MethodExpression methodExpressionOneArg, MethodExpression methodExpressionZeroArg)
      MethodExpressionValueChangeListener(MethodExpression methodExpressionOneArg)
      Construct a ValueChangeListener that contains a MethodExpression.To accomodate method expression targets that take no arguments instead of taking a ValueChangeEvent argument, the implementation of this class must take the argument methodExpressionOneArg, extract its expression string, and create another MethodExpression whose expected param types match those of a zero argument method.
      MethodExpressionValueChangeListener(MethodExpression methodExpressionOneArg, MethodExpression methodExpressionZeroArg)
      Construct a ValueChangeListener that contains a MethodExpression.

    • Uses of MethodExpression in javax.faces.flow

      Methods in javax.faces.flow that return MethodExpression
      Modifier and Type Method and Description
      abstract MethodExpression Flow.getFinalizer()

      Return the MethodExpression that must be called by the runtime as the last thing that happens before exiting this flow.
      abstract MethodExpression Flow.getInitializer()

      Return the MethodExpression that must be called by the runtime immediately after activating any FlowScoped beans declared for this flow.
      abstract MethodExpression MethodCallNode.getMethodExpression()

      Return the MethodExpression to be invoked to when control passes to this node.

    • Uses of MethodExpression in javax.faces.flow.builder

      Methods in javax.faces.flow.builder with parameters of type MethodExpression
      Modifier and Type Method and Description
      abstract MethodCallBuilder MethodCallBuilder.expression(MethodExpression methodExpression)

      Set the method expression of this method call node.
      abstract FlowBuilder FlowBuilder.finalizer(MethodExpression methodExpression)

      A MethodExpression that will be invoked when the flow is exited.
      abstract FlowBuilder FlowBuilder.initializer(MethodExpression methodExpression)

      A MethodExpression that will be invoked when the flow is entered.

    • Uses of MethodExpression in javax.faces.validator

      Constructors in javax.faces.validator with parameters of type MethodExpression
      Constructor and Description
      MethodExpressionValidator(MethodExpression methodExpression)
      Construct a Validator that contains a MethodExpression.

    • Uses of MethodExpression in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return MethodExpression
      Modifier and Type Method and Description
      abstract MethodExpression TagAttribute.getMethodExpression(FaceletContext ctx, Class type, Class[] paramTypes)
      Create a MethodExpression, using this attribute's value as the expression String.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.MethodInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.MethodInfo

  • Packages that use MethodInfo
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0

    • Uses of MethodInfo in javax.el

      Methods in javax.el that return MethodInfo
      Modifier and Type Method and Description
      abstract MethodInfo MethodExpression.getMethodInfo(ELContext context)
      Evaluates the expression relative to the provided context, and returns information about the actual referenced method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.MethodNotFoundException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.MethodNotFoundException

No usage of javax.el.MethodNotFoundException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.PropertyNotFoundException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.PropertyNotFoundException

No usage of javax.el.PropertyNotFoundException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.PropertyNotWritableException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.PropertyNotWritableException

  • Packages that use PropertyNotWritableException
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0

    • Uses of PropertyNotWritableException in javax.el

      Methods in javax.el that throw PropertyNotWritableException
      Modifier and Type Method and Description
      void BeanNameResolver.setBeanValue(String beanName, Object value)
      Sets a value to a bean of the given name.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ResourceBundleELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ResourceBundleELResolver

No usage of javax.el.ResourceBundleELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.StandardELContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.StandardELContext

  • Packages that use StandardELContext
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0

    • Uses of StandardELContext in javax.el

      Methods in javax.el that return StandardELContext
      Modifier and Type Method and Description
      StandardELContext ELManager.getELContext()
      Return the ELContext used for parsing and evaluating EL expressions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.StaticFieldELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.StaticFieldELResolver

No usage of javax.el.StaticFieldELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.TypeConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.TypeConverter

No usage of javax.el.TypeConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ValueExpression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ValueExpression

  • Packages that use ValueExpression
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.el
    DEPRECATED Classes and interfaces for evaluating and processing reference expressions.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of ValueExpression in javax.el

      Methods in javax.el that return ValueExpression
      Modifier and Type | Method and Description
      abstract ValueExpression ExpressionFactory.createValueExpression(ELContext context, String expression, Class<?> expectedType)
      Parses an expression into a ValueExpression for later evaluation.
      abstract ValueExpression ExpressionFactory.createValueExpression(Object instance, Class<?> expectedType)
      Creates a ValueExpression that wraps an object instance.
      abstract ValueExpression | VariableMapper.resolveVariable(String variable)
      abstract ValueExpression VariableMapper.setVariable(String variable, ValueExpression expression)
      Assign a ValueExpression to an EL variable, replacing any previously assignment to the same variable.
      Methods in javax.el with parameters of type ValueExpression
      Modifier and Type Method and Description
      abstract ValueExpression VariableMapper.setVariable(String variable, ValueExpression expression)
      Assign a ValueExpression to an EL variable, replacing any previously assignment to the same variable.
      void ELManager.setVariable(String variable, ValueExpression expression)
      Assign a ValueExpression to an EL variable, replacing any previous assignment to the same variable.
      Constructors in javax.el with parameters of type ValueExpression
      Constructor and Description
      LambdaExpression(List<String> formalParameters, ValueExpression expression)
      Creates a new LambdaExpression.

    • Uses of ValueExpression in javax.faces.application

      Methods in javax.faces.application with parameters of type ValueExpression
      Modifier and Type Method and Description
      UIComponent ApplicationWrapper.createComponent(ValueExpression componentExpression, FacesContext context, String componentType)

      The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String) on the wrapped Application object.
      UIComponent Application.createComponent(ValueExpression componentExpression, FacesContext context, String componentType)
      Call the getValue() method on the specified ValueExpression.
      UIComponent ApplicationWrapper.createComponent(ValueExpression componentExpression, FacesContext context, String componentType, String rendererType)

      The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String, String) on the wrapped Application object.
      UIComponent Application.createComponent(ValueExpression componentExpression, FacesContext context, String componentType, String rendererType)

      Like Application.createComponent(ValueExpression, FacesContext, String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in Application.createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method.

    • Uses of ValueExpression in javax.faces.component

      Fields in javax.faces.component with type parameters of type ValueExpression
      Modifier and Type Field and Description
      protected Map<String,ValueExpression> UIComponent.bindings
      Deprecated.
      Methods in javax.faces.component that return ValueExpression
      Modifier and Type Method and Description
      ValueExpression UISelectMany.getValueExpression(String name)
      Return any ValueExpression set for value if a ValueExpression for selectedValues is requested; otherwise, perform the default superclass processing for this method.
      ValueExpression UISelectBoolean.getValueExpression(String name)
      Return any ValueExpression set for value if a ValueExpression for selected is requested; otherwise, perform the default superclass processing for this method.
      ValueExpression UIGraphic.getValueExpression(String name)
      Return any ValueExpression set for value if a ValueExpression for url is requested; otherwise, perform the default superclass processing for this method.
      ValueExpression UIComponent.getValueExpression(String name)
      Return the ValueExpression used to calculate the value for the specified attribute or property name, if any.
      Methods in javax.faces.component with parameters of type ValueExpression
      Modifier and Type Method and Description
      void UISelectMany.setValueExpression(String name, ValueExpression binding)
      Store any ValueExpression specified for selectedValues under value instead; otherwise, perform the default superclass processing for this method.
      void UISelectBoolean.setValueExpression(String name, ValueExpression binding)
      Store any ValueExpression specified for selected under value instead; otherwise, perform the default superclass processing for this method.
      void UIGraphic.setValueExpression(String name, ValueExpression binding)
      Store any ValueExpression specified for url under value instead; otherwise, perform the default superclass processing for this method.
      void UIData.setValueExpression(String name, ValueExpression binding)
      Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.
      void UIComponent.setValueExpression(String name, ValueExpression binding)
      Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.

    • Uses of ValueExpression in javax.faces.component.behavior

      Methods in javax.faces.component.behavior that return ValueExpression
      Modifier and Type Method and Description
      ValueExpression AjaxBehavior.getValueExpression(String name)

      Returns the ValueExpression used to calculate the value for the specified property name, if any.
      Methods in javax.faces.component.behavior with parameters of type ValueExpression
      Modifier and Type Method and Description
      void AjaxBehavior.setValueExpression(String name, ValueExpression binding)

      Sets the ValueExpression used to calculate the value for the specified property name.

    • Uses of ValueExpression in javax.faces.el

      Methods in javax.faces.el that return ValueExpression
      Modifier and Type | Method and Description
      ValueExpression | CompositeComponentExpressionHolder.getExpression(String name)

    • Uses of ValueExpression in javax.faces.flow

      Methods in javax.faces.flow that return ValueExpression
      Modifier and Type Method and Description
      abstract ValueExpression MethodCallNode.getOutcome()

      Return the outcome to be used in the event of a null return from the method.
      abstract ValueExpression Parameter.getValue()

      Return a ValueExpression for the value of the parameter.

    • Uses of ValueExpression in javax.faces.flow.builder

      Methods in javax.faces.flow.builder with parameters of type ValueExpression
      Modifier and Type Method and Description
      abstract SwitchCaseBuilder SwitchCaseBuilder.condition(ValueExpression expression)

      Set the if in the previously created switch case.
      abstract NavigationCaseBuilder NavigationCaseBuilder.condition(ValueExpression condition)

      Set the if of the current navigation case.
      abstract SwitchCaseBuilder SwitchBuilder.defaultOutcome(ValueExpression outcome)

      Set the default outcome of the current switch.
      abstract MethodCallBuilder MethodCallBuilder.defaultOutcome(ValueExpression outcome)

      If the method is a void method, or the method returns null, this can be used to specify what value should be passed to runtime when the method returns.
      abstract ReturnBuilder ReturnBuilder.fromOutcome(ValueExpression outcome)

      Set the outcome of the current return node.
      abstract FlowBuilder FlowBuilder.inboundParameter(String name, ValueExpression expression)

      A parameter that will be populated with the value from a correspondingly named outbound parameter from another flow when this flow is entered from that flow.
      abstract FlowCallBuilder FlowCallBuilder.outboundParameter(String name, ValueExpression value)

      Define an outbound parameter for the flow call.

    • Uses of ValueExpression in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return ValueExpression
      Modifier and Type Method and Description
      abstract ValueExpression TagAttribute.getValueExpression(FaceletContext ctx, Class type)
      Create a ValueExpression, using this attribute's literal value and the passed expected type.

    • Uses of ValueExpression in javax.faces.webapp

      Methods in javax.faces.webapp with parameters of type ValueExpression
      Modifier and Type Method and Description
      void UIComponentELTag.setBinding(ValueExpression binding)
      Set the value expression for our component.
      void UIComponentELTag.setRendered(ValueExpression rendered)
      Set an override for the rendered attribute.

    • Uses of ValueExpression in javax.servlet.jsp.jstl.core

      Subclasses of ValueExpression in javax.servlet.jsp.jstl.core
      Modifier and Type | Class and Description
      class  | IndexedValueExpression
      class  | IteratedValueExpression
      Fields in javax.servlet.jsp.jstl.core declared as ValueExpression
      Modifier and Type | Field and Description
      protected ValueExpression LoopTagSupport.deferredExpression
      The deferred expression if any
      protected ValueExpression | IteratedExpression.orig
      protected ValueExpression | IndexedValueExpression.orig
      Methods in javax.servlet.jsp.jstl.core that return ValueExpression
      Modifier and Type | Method and Description
      ValueExpression | IteratedExpression.getValueExpression()
      Constructors in javax.servlet.jsp.jstl.core with parameters of type ValueExpression
      Constructor and Description
      IndexedValueExpression(ValueExpression orig, int i)
      IteratedExpression(ValueExpression orig, String delims)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.ValueReference (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.ValueReference

  • Packages that use ValueReference
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0

    • Uses of ValueReference in javax.el

      Methods in javax.el that return ValueReference
      Modifier and Type Method and Description
      ValueReference ValueExpression.getValueReference(ELContext context)
      Returns a ValueReference for this expression instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.el.VariableMapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.el.VariableMapper

  • Packages that use VariableMapper
    Package Description
    javax.el
    Provides the API for the Unified Expression Language 3.0
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of VariableMapper in javax.el

      Methods in javax.el that return VariableMapper
      Modifier and Type Method and Description
      VariableMapper StandardELContext.getVariableMapper()
      Construct (if needed) and return a default VariableMapper() {
      abstract VariableMapper ELContext.getVariableMapper()
      Retrieves the VariableMapper associated with this ELContext.

    • Uses of VariableMapper in javax.faces.view.facelets

      Methods in javax.faces.view.facelets with parameters of type VariableMapper
      Modifier and Type Method and Description
      abstract void FaceletContext.setVariableMapper(VariableMapper varMapper)

      Set the VariableMapper to use in EL evaluation/creation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.el.ELContextListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.el.ELContextListener

  • Packages that use ELContextListener
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of ELContextListener in javax.faces.application

      Methods in javax.faces.application that return ELContextListener
      Modifier and Type Method and Description
      ELContextListener[] ApplicationWrapper.getELContextListeners()

      The default behavior of this method is to call Application.getELContextListeners() on the wrapped Application object.
      ELContextListener[] Application.getELContextListeners()
      If no calls have been made to Application.addELContextListener(javax.el.ELContextListener), this method must return an empty array.
      Methods in javax.faces.application with parameters of type ELContextListener
      Modifier and Type Method and Description
      void ApplicationWrapper.addELContextListener(ELContextListener listener)

      The default behavior of this method is to call Application.addELContextListener(javax.el.ELContextListener) on the wrapped Application object.
      void Application.addELContextListener(ELContextListener listener)
      Provide a way for Faces applications to register an ELContextListener that will be notified on creation of ELContext instances.
      void ApplicationWrapper.removeELContextListener(ELContextListener listener)

      The default behavior of this method is to call Application.removeELContextListener(javax.el.ELContextListener) on the wrapped Application object.
      void Application.removeELContextListener(ELContextListener listener)
      Remove the argument listener from the list of ELContextListeners.

    • Uses of ELContextListener in javax.servlet.jsp

      Methods in javax.servlet.jsp with parameters of type ELContextListener
      Modifier and Type Method and Description
      void JspApplicationContext.addELContextListener(ELContextListener listener)
      Registers a ELContextListeners so that context objects can be added whenever a new ELContext is created.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AbortedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Class AbortedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.util.concurrent.ExecutionException
          • javax.enterprise.concurrent.AbortedException
  • All Implemented Interfaces:
    Serializable

    public class AbortedException
extends ExecutionException
implements Serializable
    Exception indicating that the result of a task cannot be retrieved because the task failed to run for some reason other than being cancelled.

    Use the Throwable.getCause() method to determine why the task was aborted.

    Since:
    1.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      AbortedException()
      Constructs an AbortedException with null as its detail message.
      AbortedException(String message)
      Constructs an AbortedException exception with the specified detail message.
      AbortedException(String message, Throwable cause)
      Constructs an AbortedException exception with the specified detail message and cause.
      AbortedException(Throwable cause)
      Constructs an AbortedException exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AbortedException

        public AbortedException()
        Constructs an AbortedException with null as its detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).

      • AbortedException

        public AbortedException(String message,
                Throwable cause)
        Constructs an AbortedException exception with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • AbortedException

        public AbortedException(String message)
        Constructs an AbortedException exception with the specified detail message.

        The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).

        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • AbortedException

        public AbortedException(Throwable cause)
        Constructs an AbortedException exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ContextService (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Interface ContextService

  • public interface ContextService
    The ContextService provides methods for creating dynamic proxy objects (as defined by java.lang.reflect.Proxy) with the addition of context typically associated with applications executing in a Java™ EE environment. Examples of such context are classloading, namespace, security, etc.

    The proxy objects follow the same rules as defined for the java.lang.reflect.Proxy class with the following additions:

    • The proxy instance will retain the context of the creator's thread.
    • The proxy instance will implement all of the interfaces specified on the createContextualProxy methods.
    • The object to have a proxy instance created for should not be a component managed by the Java™ EE Product Provider, such as a web component or an EJB.
    • All interface method invocations on a proxy instance run in the creator's context with the exception of hashCode, equals, toString and all other methods declared in Object.
    • The proxy instance must implement Serializable.
    • The proxied object instance must implement Serializable if the proxy instance is serialized.
    • Execution properties can be stored with the proxy instance. Custom property keys must not begin with "javax.enterprise.concurrent.".
    • Execution properties are to be used for controlling how various contextual information is retrieved and applied to the thread. Although application components can store arbitrary property keys and values, it is not recommended. Java™ EE product providers may impose limits to the size of the keys and values.

    Since:
    1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object createContextualProxy(Object instance, Class<?>... interfaces)
      Creates a new contextual object proxy for the input object instance.
      Object createContextualProxy(Object instance, Map<String,String> executionProperties, Class<?>... interfaces)
      Creates a new contextual object proxy for the input object instance.
      <T> T createContextualProxy(T instance, Class<T> intf)
      Creates a new contextual object proxy for the input object instance.
      <T> T createContextualProxy(T instance, Map<String,String> executionProperties, Class<T> intf)
      Creates a new contextual object proxy for the input object instance.
      Map<String,String> getExecutionProperties(Object contextualProxy)
      Gets the current execution properties on the context proxy instance.

    • Method Detail

      • createContextualProxy

        <T> T createContextualProxy(T instance,
                          Class<T> intf)
        Creates a new contextual object proxy for the input object instance.

        Each method invocation will have the context of the application component instance that created the contextual object proxy.

        The contextual object is useful when developing or using Java™ SE threading mechanisms propagating events to other component instances.

        If the application component that created the proxy is not started or deployed, all methods on reflected interfaces may throw an IllegalStateException.

        For example, to execute a Runnable which is contextualized with the creator's context using a Java™ SE ExecutorService:

          public class MyRunnable implements Runnable {
      public void run() {
          System.out.println("MyRunnable.run with Java EE Context available.");
      }
  }

  InitialContext ctx = new InitialContext();
  ThreadFactory threadFactory = (ThreadFactory) ctx
           .lookup("java:comp/env/concurrent/ThreadFactory");

  ContextService ctxService = (ContextService) ctx
           .lookup("java:comp/env/concurrent/ContextService");

  MyRunnable myRunnableInstance = ...;

  Runnable rProxy = ctxService.createContextualProxy(myRunnableInstance, Runnable.class);

  ExecutorService exSvc = Executors.newThreadPool(10, threadFactory);

  Future f = exSvc.submit(rProxy);

        Parameters:
        instance - the instance of the object to proxy.
        intf - the interface that the proxy should implement.
        Returns:
        a proxy for the input object that implements the specified interface.
        Throws:
        IllegalArgumentException - - if the intf argument is null or the instance does not implement the specified interface.

      • createContextualProxy

        Object createContextualProxy(Object instance,
                           Class<?>... interfaces)
        Creates a new contextual object proxy for the input object instance.

        This method is similar to <T> T createContextualProxy(T instance, Class<T> intf) except that this method can be used if the proxy has to support multiple interfaces.

        Example:

          public class MyRunnableWork implements Runnable, SomeWorkInterface {
      public void run() {
          System.out.println("MyRunnableWork.run with Java EE Context available.");
      }
      public void someWorkInterfaceMethod() {
          ...
      }
  }

  ThreadFactory threadFactory = ...;

  ContextService ctxService = ...;

  MyRunnableWork myRunnableWorkInstance = ...;

  Object proxy = ctxService.createContextualProxy(myRunnableWorkInstance,
                                   Runnable.class, SomeWorkInterface.class);

  // call SomeWorkInterface method on the proxy
  ((SomeWorkInterface) proxy).someWorkInterfaceMethod();

  ExecutorService exSvc = Executors.newThreadPool(10, threadFactory);

  // submit the proxy as a Runnable to the ExecutorService
  Future f = exSvc.submit( (Runnable)proxy);

        Parameters:
        instance - the instance of the object to proxy.
        interfaces - the interfaces that the proxy should implement.
        Returns:
        a proxy for the input object that implements all of the specified interfaces.
        Throws:
        IllegalArgumentException - - if the interfaces argument is null or the instance does not implement all the specified interfaces.

      • createContextualProxy

        <T> T createContextualProxy(T instance,
                          Map<String,String> executionProperties,
                          Class<T> intf)
        Creates a new contextual object proxy for the input object instance.

        The contextual object is useful when developing or using Java™ SE threading mechanisms propagating events to other component instances.

        If the application component that created the proxy is not started or deployed, all methods on reflected interfaces may throw an IllegalStateException.

        This method accepts a Map object which allows the contextual object creator to define what contexts or behaviors to capture when creating the contextual object. The specified properties will remain with the contextual object.

        For example, to call a Message Driven Bean (MDB) with the sender's context, but within the MDB's transaction:

         public class MyServlet ... {
     public void doPost() throws NamingException, JMSException {
        InitialContext ctx = new InitialContext();

        // Get the ContextService that only propagates
        // security context.
        ContextService ctxSvc = (ContextService)
            ctx.lookup("java:comp/env/SecurityContext");

        // Set any custom context data through execution properties
        Map<String, String> execProps = new HashMap<>();
        execProps.put("vendor_a.security.tokenexpiration", "15000");
        // Specify that contextual object should run inside the current
        // transaction.  If we have a failure, we don't want to consume
        // the message.
        execProps.put(ManagedTask.TRANSACTION, "USE_TRANSACTION_OF_EXECUTION_THREAD");

        ProcessMessage msgProcessor =
            ctxSvc.createContextualProxy(new MessageProcessor(), execProps,
            ProcessMessage.class);

        ConnectionFactory cf = (ConnectionFactory)
             ctx.lookup("java:comp/env/MyTopicConnectionFactory");
        Destination dest = (Destination) ctx.lookup("java:comp/env/MyTopic");
        Connection con = cf.createConnection();

        Session session = con.createSession(true, Session.AUTO_ACKNOWLEDGE);
        MessageProducer producer = session.createProducer(dest);

        Message msg = session.createObjectMessage((Serializable)msgProcessor);
        producer.send(dest, msg);
        ...

    }

  public class MyMDB ... {
    public void onMessage(Message msg) {
        // Get the ProcessMessage contextual object from the message.
        ObjectMessage omsg = (ObjectMessage)msg;
        ProcessMessage msgProcessor = (ProcessMessage)omsg.getObject();

        // Process the message in the specified context.
        msgProcessor.processMessage(msg);
    }
  }

  public interface  ProcessMessage {
      public void processMessage(Message msg);
  }

  public class MessageProcessor implements ProcessMessage, Serializable {
      public void processMessage(Message msg) {
          // Process the message with the application container
          // context that sent the message.

      }
  }

        Parameters:
        instance - the instance of the object to proxy.
        executionProperties - the properties to use when creating and running the context object.
        intf - the interface that the proxy should implement.
        Returns:
        a proxy for the input object that implements the specified interface.
        Throws:
        IllegalArgumentException - - if the intf argument null or the instance does not implement the specified interface.

      • createContextualProxy

        Object createContextualProxy(Object instance,
                           Map<String,String> executionProperties,
                           Class<?>... interfaces)
        Creates a new contextual object proxy for the input object instance.

        This method is similar to <T> T createContextualProxy(T instance, Map<String, String> executionProperties, Class<T> intf) except that this method can be used if the proxy has to support multiple interfaces.

        Parameters:
        instance - the instance of the object to proxy.
        executionProperties - the properties to use when creating and running the context object.
        interfaces - the interfaces that the proxy should implement.
        Returns:
        a proxy for the input object that implements all of the specified interfaces.
        Throws:
        IllegalArgumentException - - if the interfaces argument is null or the instance does not implement all the specified interfaces.

      • getExecutionProperties

        Map<String,String> getExecutionProperties(Object contextualProxy)
        Gets the current execution properties on the context proxy instance.
        Parameters:
        contextualProxy - the contextual proxy instance to retrieve the execution properties.
        Returns:
        A copy of the current contextual object execution properties, or null if the contextualProxy is created without specifying any execution properties.
        Throws:
        IllegalArgumentException - thrown if the input contextualProxy is not a valid contextual object proxy created with the createContextualProxy method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.concurrent (Java(TM) EE 7 Specification APIs)

javax.enterprise.concurrent

Interfaces

  • ContextService
  • LastExecution
  • ManageableThread
  • ManagedExecutorService
  • ManagedScheduledExecutorService
  • ManagedTask
  • ManagedTaskListener
  • ManagedThreadFactory
  • Trigger

Classes

  • ManagedExecutors

Exceptions

  • AbortedException
  • SkippedException


javax.enterprise.concurrent (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.concurrent

Classes and interfaces for concurrent programming in Java EE™ applications.

See: Description

  • Interface Summary
    Interface Description
    ContextService
    The ContextService provides methods for creating dynamic proxy objects (as defined by java.lang.reflect.Proxy) with the addition of context typically associated with applications executing in a Java™ EE environment.
    LastExecution
    Contains information about the last execution of a task.
    ManageableThread
    Interface to be implemented by the Java™ EE product providers on threads that are created by calling ThreadFactory.newThread(java.lang.Runnable).
    ManagedExecutorService
    A manageable version of a ExecutorService.
    ManagedScheduledExecutorService
    A manageable version of a ScheduledExecutorService.
    ManagedTask
    A task submitted to an ManagedExecutorService or ManagedScheduledExecutorService can optionally implement this interface to provide identifying information about the task, to provide a ManagedTaskListener to get notification of lifecycle events of the task, or to provide additional execution properties.
    ManagedTaskListener
    A ManagedTaskListener is used to monitor the state of a task's Future.
    ManagedThreadFactory
    A manageable version of a ThreadFactory.
    Trigger
    Triggers allow application developers to plug in rules for when and how often a task should run.
  • Class Summary
    Class Description
    ManagedExecutors
    Utility methods for classes defined in this package.
  • Exception Summary
    Exception Description
    AbortedException
    Exception indicating that the result of a task cannot be retrieved because the task failed to run for some reason other than being cancelled.
    SkippedException
    Exception indicating that the result of a value-producing task cannot be retrieved because the task run was skipped.

Package javax.enterprise.concurrent Description

Classes and interfaces for concurrent programming in Java EE™ applications.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.concurrent Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.concurrent

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.enterprise.concurrent.ManagedExecutors
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.util.concurrent.ExecutionException
          • javax.enterprise.concurrent.AbortedException (implements java.io.Serializable)
          • javax.enterprise.concurrent.SkippedException (implements java.io.Serializable)

Interface Hierarchy

  • javax.enterprise.concurrent.ContextService
  • java.util.concurrent.Executor
    • java.util.concurrent.ExecutorService
      • javax.enterprise.concurrent.ManagedExecutorService
        • javax.enterprise.concurrent.ManagedScheduledExecutorService (also extends java.util.concurrent.ScheduledExecutorService)
      • java.util.concurrent.ScheduledExecutorService
        • javax.enterprise.concurrent.ManagedScheduledExecutorService (also extends javax.enterprise.concurrent.ManagedExecutorService)
  • javax.enterprise.concurrent.LastExecution
  • javax.enterprise.concurrent.ManageableThread
  • javax.enterprise.concurrent.ManagedTask
  • javax.enterprise.concurrent.ManagedTaskListener
  • java.util.concurrent.ThreadFactory
    • javax.enterprise.concurrent.ManagedThreadFactory
  • javax.enterprise.concurrent.Trigger
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LastExecution (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Interface LastExecution

  • public interface LastExecution
    Contains information about the last execution of a task. This is used by the methods in the Trigger class to determine the next scheduled timeout or whether a run should be skipped.
    Since:
    1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getIdentityName()
      The name or ID of the identifiable object, as specified in the ManagedTask.IDENTITY_NAME execution property of the task if it also implements the ManagedTask interface.
      Object getResult()
      Result of the last execution.
      Date getRunEnd()
      The last time in which the task was completed.
      Date getRunStart()
      The last time in which the task started running.
      Date getScheduledStart()
      The last time in which task was scheduled to run.

    • Method Detail

      • getIdentityName

        String getIdentityName()
        The name or ID of the identifiable object, as specified in the ManagedTask.IDENTITY_NAME execution property of the task if it also implements the ManagedTask interface.
        Returns:
        the name or ID of the identifiable object.

      • getResult

        Object getResult()
        Result of the last execution.
        Returns:
        The result of the last execution. It could return null if the last execution did not complete, or the result of the task was null.

      • getScheduledStart

        Date getScheduledStart()
        The last time in which task was scheduled to run.
        Returns:
        The last date/time in which the task was scheduled to run.

      • getRunStart

        Date getRunStart()
        The last time in which the task started running.
        Returns:
        the last date/time in which the task started running, or null if the task was canceled before it was started.

      • getRunEnd

        Date getRunEnd()
        The last time in which the task was completed.
        Returns:
        the last date/time in which the task was completed, or null if the task was canceled before it was completed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManageableThread (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Interface ManageableThread

  • public interface ManageableThread
    Interface to be implemented by the Java™ EE product providers on threads that are created by calling ThreadFactory.newThread(java.lang.Runnable).
    Since:
    1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isShutdown()
      This method is used by the application component provider to check whether a thread created by the newThread method of ManagedThreadFactory has been marked for shut down.

    • Method Detail

      • isShutdown

        boolean isShutdown()
        This method is used by the application component provider to check whether a thread created by the newThread method of ManagedThreadFactory has been marked for shut down. If the value is true, the application component provider should finish any work on this thread as soon as possible.
        Returns:
        true if this thread has been marked for shutdown.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagedExecutors (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Class ManagedExecutors

  • java.lang.Object
    • javax.enterprise.concurrent.ManagedExecutors

  • public class ManagedExecutors
extends Object
    Utility methods for classes defined in this package.
    Since:
    1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static boolean isCurrentThreadShutdown()
      Utility method for checking the isShutdown() value of the current thread if it is a ManageableThread created from ManagedThreadFactory.newThread() .
      static <V> Callable<V> managedTask(Callable<V> task, ManagedTaskListener taskListener)
      Returns a Callable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.
      static <V> Callable<V> managedTask(Callable<V> task, Map<String,String> executionProperties, ManagedTaskListener taskListener)
      Returns a Callable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener and to provide additional execution properties when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.
      static Runnable managedTask(Runnable task, ManagedTaskListener taskListener)
      Returns a Runnable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.
      static Runnable managedTask(Runnable task, Map<String,String> executionProperties, ManagedTaskListener taskListener)
      Returns a Runnable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener and to provide additional execution properties when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • isCurrentThreadShutdown

        public static boolean isCurrentThreadShutdown()
        Utility method for checking the isShutdown() value of the current thread if it is a ManageableThread created from ManagedThreadFactory.newThread() .
        Returns:
        Returns the isShutdown() value if the current thread is a ManageableThread created by ManagedThreadFactory, or false if the current thread is not a ManageableThread.

      • managedTask

        public static Runnable managedTask(Runnable task,
                   ManagedTaskListener taskListener)
                            throws IllegalArgumentException
        Returns a Runnable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.

        Example:

         Runnable task = ...;
 ManagedTaskListener myTaskListener = ...;
 ManagedExecutorService executor = ...;

 Runnable taskWithListener = ManagedExecutors.managedTask(task, myTaskListener);
 executor.submit(taskWithListener);
        Parameters:
        task - the task to have the given ManagedTaskListener associated with
        taskListener - (optional) the ManagedTaskListener to receive lifecycle events notification when the task is submitted. If task implements ManagedTask, and taskListener is not null, the ManagedTaskListener interface methods of the task will not be called.
        Returns:
        a Runnable object
        Throws:
        IllegalArgumentException - if task is null

      • managedTask

        public static Runnable managedTask(Runnable task,
                   Map<String,String> executionProperties,
                   ManagedTaskListener taskListener)
                            throws IllegalArgumentException
        Returns a Runnable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener and to provide additional execution properties when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.
        Parameters:
        task - the task to have the given ManagedTaskListener associated with
        taskListener - (optional) the ManagedTaskListener to receive lifecycle events notification when the task is submitted. If task implements ManagedTask, and taskListener is not null, the ManagedTaskListener interface methods of the task will not be called.
        executionProperties - (optional) execution properties to provide additional hints to ManagedExecutorService or ManagedScheduledExecutorService when the task is submitted. If task implements ManagedTask with non-empty execution properties, the Runnable returned will contain the union of the execution properties specified in the task and the executionProperties argument, with the latter taking precedence if the same property key is specified in both. After the method is called, further changes to the Map object will not be reflected in the Runnable returned by this method.
        Returns:
        a Runnable object
        Throws:
        IllegalArgumentException - if task is null

      • managedTask

        public static <V> Callable<V> managedTask(Callable<V> task,
                          ManagedTaskListener taskListener)
                               throws IllegalArgumentException
        Returns a Callable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.
        Parameters:
        task - the task to have the given ManagedTaskListener associated with
        taskListener - (optional) the ManagedTaskListener to receive lifecycle events notification when the task is submitted. If task implements ManagedTask, and taskListener is not null, the ManagedTaskListener interface methods of the task will not be called.
        Returns:
        a Callable object
        Throws:
        IllegalArgumentException - if task is null

      • managedTask

        public static <V> Callable<V> managedTask(Callable<V> task,
                          Map<String,String> executionProperties,
                          ManagedTaskListener taskListener)
                               throws IllegalArgumentException
        Returns a Callable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener and to provide additional execution properties when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.
        Parameters:
        task - the task to have the given ManagedTaskListener associated with
        taskListener - (optional) the ManagedTaskListener to receive lifecycle events notification when the task is submitted. If task implements ManagedTask, and taskListener is not null, the ManagedTaskListener interface methods of the task will not be called.
        executionProperties - (optional) execution properties to provide additional hints to ManagedExecutorService or ManagedScheduledExecutorService when the task is submitted. If task implements ManagedTask with non-empty execution properties, the Runnable returned will contain the union of the execution properties specified in the task and the executionProperties argument, with the latter taking precedence if the same property key is specified in both. After the method is called, further changes to the Map object will not be reflected in the Callable returned by this method.
        Returns:
        a Callable object
        Throws:
        IllegalArgumentException - if task is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagedExecutorService (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Interface ManagedExecutorService

  • All Superinterfaces:
    Executor, ExecutorService
    All Known Subinterfaces:
    ManagedScheduledExecutorService

    public interface ManagedExecutorService
extends ExecutorService
    A manageable version of a ExecutorService.

    A ManagedExecutorService extends the Java™ SE ExecutorService to provide methods for submitting tasks for execution in a Java™ EE environment. Implementations of the ManagedExecutorService are provided by a Java™ EE Product Provider. Application Component Providers use the Java Naming and Directory Interface™ (JNDI) to look-up instances of one or more ManagedExecutorService objects using resource environment references. ManagedExecutorService instances can also be injected into application components through the use of the Resource annotation.

    The Concurrency Utilities for Java™ EE specification describes several behaviors that a ManagedExecutorService can implement. The Application Component Provider and Deployer identify these requirements and map the resource environment reference appropriately.

    The most common uses for a ManagedExecutorService is to run short-duration asynchronous tasks such as for processing of asynchronous methods in Enterprise JavaBean™ (EJB™) or for processing async tasks for Servlets that supports asynchronous processing.

    Tasks are run in managed threads provided by the Java™ EE Product Provider and are run within the application component context that submitted the task. All tasks run without an explicit transaction (they do not enlist in the application component's transaction). If a transaction is required, use a UserTransaction instance. A UserTransaction instance is available in JNDI using the name: "java:comp/UserTransaction" or by requesting an injection of a UserTransaction object using the Resource annotation.

    Example:

     public run() {
   // Begin of task
   InitialContext ctx = new InitialContext();
   UserTransaction ut = (UserTransaction) ctx.lookup("java:comp/UserTransaction");
   ut.begin();

   // Perform transactional business logic

   ut.commit();
 }
    Tasks can optionally provide an ManagedTaskListener to receive notifications of lifecycle events, through the use of ManagedTask interface.

    Example:

     public class MyRunnable implements Runnable, ManagedTask {
   ...
   public void run() {
     ...
   }

   public ManagedTaskListener getManagedTaskListener() {
     return myManagedTaskListener;
   }
   ...
 }

 MyRunnable task = ...;
 ManagedExecutorService executor = ...;

 executor.submit(task); // lifecycle events will be notified to myManagedTaskListener
    Asynchronous tasks are typically submitted to the ManagedExecutorService using one of the submit methods, each of which return a Future instance. The Future represents the result of the task and can also be used to check if the task is complete or wait for its completion.

    If the task is canceled, the result for the task is a CancellationException exception. If the task is unable to run due to a reason other than cancellation, the result is a AbortedException exception.

    Example:

     /**
  * Retrieve all accounts from several account databases in parallel.
  * Resource Mappings:
  *  type:      javax.enterprise.concurrent.ManagedExecutorService
  *  jndi-name: concurrent/ThreadPool
  */
 public List<Account> getAccounts(long accountId) {
   try {
       javax.naming.InitialContext ctx = new InitialContext();
       ManagedExecutorService mes = (ManagedExecutorService)
           ctx.lookup("java:comp/env/concurrent/ThreadPool");

       // Create a set of tasks to perform the account retrieval.
       ArrayList<Callable<Account>> retrieverTasks = new ArrayList<Callable<Account>>();
       retrieverTasks.add(new EISAccountRetriever());
       retrieverTasks.add(new RDBAccountRetriever());

       // Submit the tasks to the thread pool and wait for them
       // to complete (successfully or otherwise).
       List<Future<Account>> taskResults= mes.invokeAll(retrieverTasks);

       // Retrieve the results from the resulting Future list.
       ArrayList<Account> results = new ArrayList<Account>();
       for(Future<Account> taskResult : taskResults) {
           try {
               results.add(taskResult.get());
           } catch (ExecutionException e) {
               Throwable cause = e.getCause();
               // Handle the AccountRetrieverError.
           }
       }

       return results;

   } catch (NamingException e) {
       // Throw exception for fatal error.
   } catch (InterruptedException e) {
       // Throw exception for shutdown or other interrupt condition.
   }
 }

 public class EISAccountRetriever implements Callable<Account> {
     public Account call() {
         // Connect to our eis system and retrieve the info for the account.
         //...
         return null;
   }
 }

 public class RDBAccountRetriever implements Callable<Account>> {
     public Account call() {
         // Connect to our database and retrieve the info for the account.
         //...
   }
 }

 public class Account {
     // Some account data...
 }

    Since:
    1.0

    • Method Summary

      • Methods inherited from interface java.util.concurrent.ExecutorService

        awaitTermination, invokeAll, invokeAll, invokeAny, invokeAny, isShutdown, isTerminated, shutdown, shutdownNow, submit, submit, submit

      • Methods inherited from interface java.util.concurrent.Executor

        execute
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagedScheduledExecutorService (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Interface ManagedScheduledExecutorService

  • All Superinterfaces:
    Executor, ExecutorService, ManagedExecutorService, ScheduledExecutorService

    public interface ManagedScheduledExecutorService
extends ManagedExecutorService, ScheduledExecutorService
    A manageable version of a ScheduledExecutorService.

    A ManagedScheduledExecutorService extends the Java™ SE ScheduledExecutorService to provide methods for submitting delayed or periodic tasks for execution in a Java™ EE environment. Implementations of the ManagedScheduledExecutorService are provided by a Java™ EE Product Provider. Application Component Providers use the Java Naming and Directory Interface™ (JNDI) to look-up instances of one or more ManagedScheduledExecutorService objects using resource environment references. ManagedScheduledExecutorService instances can also be injected into application components through the use of the Resource annotation.

    The Concurrency Utilities for Java™ EE specification describes several behaviors that a ManagedScheduledExecutorService can implement. The Application Component Provider and Deployer identify these requirements and map the resource environment reference appropriately.

    Tasks are run in managed threads provided by the Java™ EE Product Provider and are run within the application component context that submitted the task. All tasks run without an explicit transaction (they do not enlist in the application component's transaction). If a transaction is required, use a javax.transaction.UserTransaction instance. A UserTransaction instance is available in JNDI using the name: "java:comp/UserTransaction" or by requesting an injection of a UserTransaction object using the Resource annotation.

    Example:

 public run() {
   // Begin of task
   InitialContext ctx = new InitialContext();
   UserTransaction ut = (UserTransaction) ctx.lookup("java:comp/UserTransaction");
   ut.begin();

   // Perform transactional business logic

   ut.commit();
 }
    Tasks can optionally provide an ManagedTaskListener to receive notifications of lifecycle events, through the use of ManagedTask interface.

    Asynchronous tasks are typically submitted to the ManagedScheduledExecutorService using one of the submit or schedulemethods, each of which return a Future instance. The Future represents the result of the task and can also be used to check if the task is complete or wait for its completion.

    If the task is cancelled, the result for the task is a CancellationException exception. If the task is unable to run due to start due to a reason other than cancellation, the result is a AbortedException exception. If the task is scheduled with a Trigger and the Trigger forces the task to be skipped, the result will be a SkippedException exception.

    Tasks can be scheduled to run periodically using the schedule methods that take a Trigger as an argument and the scheduleAtFixedRate and scheduleWithFixedDelay methods. The result of the Future will be represented by the currently scheduled or running instance of the task. Future and past executions of the task are not represented by the Future. The state of the Future will therefore change and multiple results are expected.

    For example, if a task is repeating, the lifecycle of the task would be:
    (Note: See ManagedTaskListener for task lifecycle management details.)

    Sequence | State | Action | Listener | Next state
    1A. | None | submit() | taskSubmitted | Submitted
    2A. | Submitted | About to call run() | taskStarting | Started
    3A. | Started | Exit run() | taskDone | Reschedule
    1B. | Reschedule | taskSubmitted | Submitted
    2B. | Submitted | About to call run() | taskStarting | Started
    3B. | Started | Exit run() | taskDone | Reschedule

    Since:
    1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <V> ScheduledFuture<V> schedule(Callable<V> callable, Trigger trigger)
      Creates and executes a task based on a Trigger.
      ScheduledFuture<?> schedule(Runnable command, Trigger trigger)
      Creates and executes a task based on a Trigger.

      • Methods inherited from interface java.util.concurrent.ScheduledExecutorService

        schedule, schedule, scheduleAtFixedRate, scheduleWithFixedDelay

      • Methods inherited from interface java.util.concurrent.ExecutorService

        awaitTermination, invokeAll, invokeAll, invokeAny, invokeAny, isShutdown, isTerminated, shutdown, shutdownNow, submit, submit, submit

      • Methods inherited from interface java.util.concurrent.Executor

        execute

    • Method Detail

      • schedule

        ScheduledFuture<?> schedule(Runnable command,
                          Trigger trigger)
        Creates and executes a task based on a Trigger. The Trigger determines when the task should run and how often.
        Parameters:
        command - the task to execute.
        trigger - the trigger that determines when the task should fire.
        Returns:
        a Future representing pending completion of the task, and whose get() method will return null upon completion.
        Throws:
        RejectedExecutionException - if task cannot be scheduled for execution.
        NullPointerException - if command is null.

      • schedule

        <V> ScheduledFuture<V> schedule(Callable<V> callable,
                              Trigger trigger)
        Creates and executes a task based on a Trigger. The Trigger determines when the task should run and how often.
        Parameters:
        callable - the function to execute.
        trigger - the trigger that determines when the task should fire.
        Returns:
        a ScheduledFuture that can be used to extract result or cancel.
        Throws:
        RejectedExecutionException - if task cannot be scheduled for execution.
        NullPointerException - if callable is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagedTask (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Interface ManagedTask

  • public interface ManagedTask
    A task submitted to an ManagedExecutorService or ManagedScheduledExecutorService can optionally implement this interface to provide identifying information about the task, to provide a ManagedTaskListener to get notification of lifecycle events of the task, or to provide additional execution properties.

    See also ManagedExecutors.managedTask().

    Since:
    1.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String IDENTITY_NAME
      Execution property to be returned in getExecutionProperties() or ContextService.createContextualProxy() to provide a String that identifies the task.
      static String LONGRUNNING_HINT
      Execution property to be returned in getExecutionProperties() or ContextService.createContextualProxy() to provide hint about whether the task could take a long time to complete.
      static String SUSPEND
      Constant for the "SUSPEND" value of the TRANSACTION execution property.
      static String TRANSACTION
      Execution property to be returned in getExecutionProperties() or ContextService.createContextualProxy() to inform the Java™ EE Product Provider under which transaction should the task or proxy method of contextual proxy object be executed in.
      static String USE_TRANSACTION_OF_EXECUTION_THREAD
      Constant for the "USE_TRANSACTION_OF_EXECUTION_THREAD" value of the TRANSACTION execution property.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Map<String,String> getExecutionProperties()
      Provides additional information to the ManagedExecutorService or ManagedScheduledExecutorService when executing this task.
      ManagedTaskListener getManagedTaskListener()
      The ManagedTaskListener to receive notification of lifecycle events of this task.

    • Field Detail

      • LONGRUNNING_HINT

        static final String LONGRUNNING_HINT
        Execution property to be returned in getExecutionProperties() or ContextService.createContextualProxy() to provide hint about whether the task could take a long time to complete. Java™ EE Product Providers may make use of this hint value to decide how to allocate thread resource for running this task. Valid values are "true" or "false".
        See Also:
        Constant Field Values

      • TRANSACTION

        static final String TRANSACTION
        Execution property to be returned in getExecutionProperties() or ContextService.createContextualProxy() to inform the Java™ EE Product Provider under which transaction should the task or proxy method of contextual proxy object be executed in. Valid values are:

        "SUSPEND" (the default if unspecified) - Any transaction that is currently active on the thread will be suspended and a UserTransaction (accessible in the local JNDI namespace as "java:comp/UserTransaction") will be available. The original transaction, if any was active on the thread, will be resumed when the task or contextual proxy object method returns.

        "USE_TRANSACTION_OF_EXECUTION_THREAD" - The contextual proxy object method will run within the transaction (if any) of the execution thread. A UserTransaction will only be available if it is also available in the execution thread (for example, when the proxy method is invoked from a Servlet or Bean Managed Transaction EJB). When there is no existing transaction on the execution thread, such as when running tasks that are submitted to a ManagedExecutorService or a ManagedScheduledExecutorService, a UserTransaction will be available.

        See Also:
        Constant Field Values

      • SUSPEND

        static final String SUSPEND
        Constant for the "SUSPEND" value of the TRANSACTION execution property. See TRANSACTION.
        See Also:
        Constant Field Values

      • USE_TRANSACTION_OF_EXECUTION_THREAD

        static final String USE_TRANSACTION_OF_EXECUTION_THREAD
        Constant for the "USE_TRANSACTION_OF_EXECUTION_THREAD" value of the TRANSACTION execution property. See TRANSACTION.
        See Also:
        Constant Field Values

      • IDENTITY_NAME

        static final String IDENTITY_NAME
        Execution property to be returned in getExecutionProperties() or ContextService.createContextualProxy() to provide a String that identifies the task. It may be the name or ID that allow management facilities to inspect the task to determine the intent of the task and its state. Implementations should not depend upon any thread execution context and should typically return only readily-available instance data to identify the task.
        See Also:
        Constant Field Values

    • Method Detail

      • getManagedTaskListener

        ManagedTaskListener getManagedTaskListener()
        The ManagedTaskListener to receive notification of lifecycle events of this task.
        Returns:
        The ManagedTaskListener to receive notification of lifecycle events of this task, or null if it is not necessary to get notified of such events.

      • getExecutionProperties

        Map<String,String> getExecutionProperties()
        Provides additional information to the ManagedExecutorService or ManagedScheduledExecutorService when executing this task.

        Some standard property keys are defined in this class. Custom property keys may be defined but must not begin with "javax.enterprise.concurrent.".

        Returns:
        A Map<String, String> containing additional execution properties, or null if no additional information is provided for this task.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagedTaskListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Interface ManagedTaskListener

  • public interface ManagedTaskListener
    A ManagedTaskListener is used to monitor the state of a task's Future. It can be registered with a ManagedExecutorService using the submit methods and will be invoked when the state of the Future changes. Each listener method will run with unspecified context. All listeners run without an explicit transaction (they do not enlist in the application component's transaction). If a transaction is required, use a UserTransaction instance.

    Each listener instance will be invoked within the same process in which the listener was registered. If a single listener is submitted to multiple ManagedExecutorService instances, the listener object may be invoked concurrently by multiple threads.

    Each listener method supports a minimum quality of service of at-most-once. A listener is not guaranteed to be invoked due to a process failure or termination.

    State Transition Diagram

    The following state transition figure and tables describe the possible task lifecycle events that can occur when a ManagedTaskListener is associated with a task. Each method is invoked when the state of the Future moves from one state to another.

    A. The task runs normally:

    Sequence | State | Action | Listener | Next state
    1. | None | submit() | taskSubmitted | Submitted
    2. | Submitted | About to call run() | taskStarting | Started
    3. | Started | Exit run() | taskDone | Done

    B. The task is cancelled during taskSubmitted():

    Sequence | State | Action | Listener | Next state
    1. None submit() taskSubmitted
    Future is cancelled.     		Cancelling
    2. | Cancelling | taskAborted | Cancelled
    3. | Cancelled | taskDone | Done

    C. The task is cancelled or aborted after submitted, but before started:

    Sequence | State | Action | Listener | Next state
    1. | None | submit() | taskSubmitted | Submitted
    2. | Submitted | cancel() or abort | taskAborted | Cancelled
    3. | Cancelled | taskDone | Done

    D. The task is cancelled when it is starting:

    Sequence | State | Action | Listener | Next state
    1. | None | submit() | taskSubmitted | Submitted
    2. Submitted About to call run() taskStarting
    Future is cancelled.     		Cancelling
    3. | Cancelling | taskAborted | Cancelled
    4. | Cancelled | taskDone | Done

    Since:
    1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void taskAborted(Future<?> future, ManagedExecutorService executor, Object task, Throwable exception)
      Called when a task's Future has been cancelled anytime during the life of a task.
      void taskDone(Future<?> future, ManagedExecutorService executor, Object task, Throwable exception)
      Called when a submitted task has completed running, either successfully or failed due to any exception thrown from the task, task being cancelled, rejected, or aborted.
      void taskStarting(Future<?> future, ManagedExecutorService executor, Object task)
      This method is called before the task is about to start.
      void taskSubmitted(Future<?> future, ManagedExecutorService executor, Object task)
      Called after the task has been submitted to the Executor.

    • Method Detail

      • taskSubmitted

        void taskSubmitted(Future<?> future,
                 ManagedExecutorService executor,
                 Object task)
        Called after the task has been submitted to the Executor. The task will not enter the starting state until the taskSubmitted listener has completed. This method may be called from the same thread that the task was submitted with.

        This event does not indicate that the task has been scheduled for execution.

        Parameters:
        future - the Future instance that was created when the task was submitted.
        executor - the executor used to run the associated Future.
        task - the task that was submitted.

      • taskAborted

        void taskAborted(Future<?> future,
               ManagedExecutorService executor,
               Object task,
               Throwable exception)
        Called when a task's Future has been cancelled anytime during the life of a task. This method may be called after taskDone(). The Future.isCancelled() method returns false if the task was aborted through another means other than Future.cancel(boolean). The exception argument will represent the cause of the cancellation:
        • CancellationException if the task was cancelled,
        • SkippedException if the task was skipped or
        • AbortedException if the task failed to start for another reason.
        The AbortedException.getCause() method will return the exception that caused the task to fail to start.
        Parameters:
        future - the Future instance that was created when the task was submitted.
        executor - the executor used to run the associated Future.
        task - the task that was submitted.
        exception - the cause of the task abort.

      • taskDone

        void taskDone(Future<?> future,
            ManagedExecutorService executor,
            Object task,
            Throwable exception)
        Called when a submitted task has completed running, either successfully or failed due to any exception thrown from the task, task being cancelled, rejected, or aborted.
        Parameters:
        future - the Future instance that was created when the task was submitted.
        executor - the executor used to run the associated Future.
        task - the task that was submitted.
        exception - if not null, the exception that caused the task to fail.

      • taskStarting

        void taskStarting(Future<?> future,
                ManagedExecutorService executor,
                Object task)
        This method is called before the task is about to start. The task will not enter the starting state until the taskSubmitted listener has completed. This method may be called from the same thread that the task was submitted with.
        Parameters:
        future - the Future instance that was created when the task was submitted.
        executor - the executor used to run the associated Future.
        task - the task that was submitted.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagedThreadFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Interface ManagedThreadFactory

  • All Superinterfaces:
    ThreadFactory

    public interface ManagedThreadFactory
extends ThreadFactory
    A manageable version of a ThreadFactory.

    A ManagedThreadFactory extends the Java™ SE ThreadFactory to provide a method for creating threads for execution in a Java™ EE environment. Implementations of the ManagedThreadFactory are provided by a Java™ EE Product Provider. Application Component Providers use the Java Naming and Directory Interface™ (JNDI) to look-up instances of one or more ManagedThreadFactory objects using resource environment references.

    The Concurrency Utilities for Java™ EE specification describes several behaviors that a ManagedThreadFactory can implement. The Application Component Provider and Deployer identify these requirements and map the resource environment reference appropriately.

    Threads returned from the newThread() method should implement the ManageableThread interface. The Runnable task that is allocated to the new thread using the ThreadFactory.newThread(Runnable) method will run with the application component context of the component instance that created (looked-up) this ManagedThreadFactory instance.

    The task runs without an explicit transaction (they do not enlist in the application component's transaction). If a transaction is required, use a javax.transaction.UserTransaction instance. A UserTransaction instance is available in JNDI using the name: "java:comp/UserTransaction"

    Example:

     public run() {
   // Begin of task
   InitialContext ctx = new InitialContext();
   UserTransaction ut = (UserTransaction) ctx.lookup("java:comp/UserTransaction");
   ut.begin();

   // Perform transactional business logic

   ut.commit();
 }
    A ManagedThreadFactory can be used with Java SE ExecutorService implementations directly.

    Example:

     /**
 * Create a ThreadPoolExecutor using a ManagedThreadFactory.
 * Resource Mappings:
 *  type:      javax.enterprise.concurrent.ManagedThreadFactory
 *  jndi-name: concurrent/tf/DefaultThreadFactory
 */

 @Resource(name="concurrent/tf/DefaultThreadFactory")
 ManagedThreadFactory tf;

 public ExecutorService getManagedThreadPool() {

   // All threads will run as part of this application component.
   return new ThreadPoolExecutor(5, 10, 5, TimeUnit.SECONDS,
       new ArrayBlockingQueue<Runnable>(10), tf);
 }

    Since:
    1.0

    • Method Summary

      • Methods inherited from interface java.util.concurrent.ThreadFactory

        newThread
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SkippedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Class SkippedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.util.concurrent.ExecutionException
          • javax.enterprise.concurrent.SkippedException
  • All Implemented Interfaces:
    Serializable

    public class SkippedException
extends ExecutionException
implements Serializable
    Exception indicating that the result of a value-producing task cannot be retrieved because the task run was skipped. A task can be skipped if the Trigger.skipRun(javax.enterprise.concurrent.LastExecution, java.util.Date) method returns true or if it throws an unchecked exception.

    Use the Throwable.getCause() method to determine if an unchecked exception was thrown from the Trigger.

    Since:
    1.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SkippedException()
      Constructs an SkippedException with null as its detail message.
      SkippedException(String message)
      Constructs an SkippedException exception with the specified detail message.
      SkippedException(String message, Throwable cause)
      Constructs an SkippedException exception with the specified detail message and cause.
      SkippedException(Throwable cause)
      Constructs an SkippedException exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SkippedException

        public SkippedException()
        Constructs an SkippedException with null as its detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).

      • SkippedException

        public SkippedException(String message)
        Constructs an SkippedException exception with the specified detail message.

        The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).

        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • SkippedException

        public SkippedException(String message,
                Throwable cause)
        Constructs an SkippedException exception with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • SkippedException

        public SkippedException(Throwable cause)
        Constructs an SkippedException exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Trigger (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.concurrent

Interface Trigger

  • public interface Trigger
    Triggers allow application developers to plug in rules for when and how often a task should run. The trigger can be as simple as a single, absolute date-time or can include Java™ EE business calendar logic. A Trigger implementation is created by the application developer (or may be supplied to the application externally) and is registered with a task when it is submitted to a ManagedScheduledExecutorService using any of the schedule methods. Each method will run with unspecified context. The methods can be made contextual through creating contextual proxy objects using ContextService.

    Each Trigger instance will be invoked within the same process in which it was registered.

    Example:

     /**
  * A trigger that only returns a single date.
  */
  public class SingleDateTrigger implements Trigger {
      private Date fireTime;

      public TriggerSingleDate(Date newDate) {
          fireTime = newDate;
      }

      public Date getNextRunTime(
         LastExecution lastExecutionInfo, Date taskScheduledTime) {

         if(taskScheduledTime.after(fireTime)) {
             return null;
         }
         return fireTime;
      }

      public boolean skipRun(LastExecution lastExecutionInfo, Date scheduledRunTime) {
          return scheduledRunTime.after(fireTime);
      }
  }

 /**
  * A fixed-rate trigger that will skip any runs if
  * the latencyAllowance threshold is exceeded (the task
  * ran too late).
  */
  public class TriggerFixedRateLatencySensitive implements Trigger {
      private Date startTime;
      private long delta;
      private long latencyAllowance;

      public TriggerFixedRateLatencySensitive(Date startTime, long delta, long latencyAllowance) {
          this.startTime = startTime;
          this.delta = delta;
          this.latencyAllowance = latencyAllowance;
      }

      public Date getNextRunTime(LastExecution lastExecutionInfo,
                                 Date taskScheduledTime) {
          if(lastExecutionInfo==null) {
              return startTime;
          }
          return new Date(lastExecutionInfo.getScheduledStart().getTime() + delta);
      }

      public boolean skipRun(LastExecution lastExecutionInfo, Date scheduledRunTime) {
          return System.currentTimeMillis() - scheduledRunTime.getTime() > latencyAllowance;
      }
  }

    Since:
    1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Date getNextRunTime(LastExecution lastExecutionInfo, Date taskScheduledTime)
      Retrieve the next time that the task should run after.
      boolean skipRun(LastExecution lastExecutionInfo, Date scheduledRunTime)
      Return true if this run instance should be skipped.

    • Method Detail

      • getNextRunTime

        Date getNextRunTime(LastExecution lastExecutionInfo,
                  Date taskScheduledTime)
        Retrieve the next time that the task should run after.
        Parameters:
        lastExecutionInfo - information about the last execution of the task. This value will be null if the task has not yet run.
        taskScheduledTime - the date/time in which the task was scheduled using the ManagedScheduledExecutorService.schedule method.
        Returns:
        the date/time in which the next task iteration should execute on or after.

      • skipRun

        boolean skipRun(LastExecution lastExecutionInfo,
              Date scheduledRunTime)
        Return true if this run instance should be skipped.

        This is useful if the task shouldn't run because it is late or if the task is paused or suspended.

        Once this task is skipped, the state of it's Future's result will throw a SkippedException. Unchecked exceptions will be wrapped in a SkippedException.

        Parameters:
        lastExecutionInfo - information about the last execution of the task. This value will be null if the task has not yet run.
        scheduledRunTime - the date/time that the task was originally scheduled to run.
        Returns:
        true if the task should be skipped and rescheduled.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.enterprise.concurrent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.concurrent

  • Packages that use javax.enterprise.concurrent
    Package Description
    javax.enterprise.concurrent
    Classes and interfaces for concurrent programming in Java EE™ applications.
  • Classes in javax.enterprise.concurrent used by javax.enterprise.concurrent
    Class and Description
    LastExecution
    Contains information about the last execution of a task.
    ManagedExecutorService
    A manageable version of a ExecutorService.
    ManagedTaskListener
    A ManagedTaskListener is used to monitor the state of a task's Future.
    Trigger
    Triggers allow application developers to plug in rules for when and how often a task should run.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.concurrent.AbortedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.concurrent.AbortedException

No usage of javax.enterprise.concurrent.AbortedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.concurrent.ManagedExecutors (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.concurrent.ManagedExecutors

No usage of javax.enterprise.concurrent.ManagedExecutors
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.concurrent.SkippedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.concurrent.SkippedException

No usage of javax.enterprise.concurrent.SkippedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.concurrent.ContextService (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.concurrent.ContextService

No usage of javax.enterprise.concurrent.ContextService
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.concurrent.LastExecution (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.concurrent.LastExecution

  • Packages that use LastExecution
    Package Description
    javax.enterprise.concurrent
    Classes and interfaces for concurrent programming in Java EE™ applications.

    • Uses of LastExecution in javax.enterprise.concurrent

      Methods in javax.enterprise.concurrent with parameters of type LastExecution
      Modifier and Type Method and Description
      Date Trigger.getNextRunTime(LastExecution lastExecutionInfo, Date taskScheduledTime)
      Retrieve the next time that the task should run after.
      boolean Trigger.skipRun(LastExecution lastExecutionInfo, Date scheduledRunTime)
      Return true if this run instance should be skipped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.concurrent.ManageableThread (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.concurrent.ManageableThread

No usage of javax.enterprise.concurrent.ManageableThread
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.concurrent.ManagedExecutorService (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.concurrent.ManagedExecutorService

  • Packages that use ManagedExecutorService
    Package Description
    javax.enterprise.concurrent
    Classes and interfaces for concurrent programming in Java EE™ applications.

    • Uses of ManagedExecutorService in javax.enterprise.concurrent

      Subinterfaces of ManagedExecutorService in javax.enterprise.concurrent
      Modifier and Type Interface and Description
      interface  ManagedScheduledExecutorService
      A manageable version of a ScheduledExecutorService.
      Methods in javax.enterprise.concurrent with parameters of type ManagedExecutorService
      Modifier and Type Method and Description
      void ManagedTaskListener.taskAborted(Future<?> future, ManagedExecutorService executor, Object task, Throwable exception)
      Called when a task's Future has been cancelled anytime during the life of a task.
      void ManagedTaskListener.taskDone(Future<?> future, ManagedExecutorService executor, Object task, Throwable exception)
      Called when a submitted task has completed running, either successfully or failed due to any exception thrown from the task, task being cancelled, rejected, or aborted.
      void ManagedTaskListener.taskStarting(Future<?> future, ManagedExecutorService executor, Object task)
      This method is called before the task is about to start.
      void ManagedTaskListener.taskSubmitted(Future<?> future, ManagedExecutorService executor, Object task)
      Called after the task has been submitted to the Executor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.concurrent.ManagedScheduledExecutorService (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.concurrent.ManagedScheduledExecutorService

No usage of javax.enterprise.concurrent.ManagedScheduledExecutorService
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.concurrent.ManagedTask (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.concurrent.ManagedTask

No usage of javax.enterprise.concurrent.ManagedTask
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.concurrent.ManagedTaskListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.concurrent.ManagedTaskListener

  • Packages that use ManagedTaskListener
    Package Description
    javax.enterprise.concurrent
    Classes and interfaces for concurrent programming in Java EE™ applications.

    • Uses of ManagedTaskListener in javax.enterprise.concurrent

      Methods in javax.enterprise.concurrent that return ManagedTaskListener
      Modifier and Type Method and Description
      ManagedTaskListener ManagedTask.getManagedTaskListener()
      The ManagedTaskListener to receive notification of lifecycle events of this task.
      Methods in javax.enterprise.concurrent with parameters of type ManagedTaskListener
      Modifier and Type Method and Description
      static <V> Callable<V> ManagedExecutors.managedTask(Callable<V> task, ManagedTaskListener taskListener)
      Returns a Callable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.
      static <V> Callable<V> ManagedExecutors.managedTask(Callable<V> task, Map<String,String> executionProperties, ManagedTaskListener taskListener)
      Returns a Callable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener and to provide additional execution properties when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.
      static Runnable ManagedExecutors.managedTask(Runnable task, ManagedTaskListener taskListener)
      Returns a Runnable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.
      static Runnable ManagedExecutors.managedTask(Runnable task, Map<String,String> executionProperties, ManagedTaskListener taskListener)
      Returns a Runnable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener and to provide additional execution properties when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.concurrent.ManagedThreadFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.concurrent.ManagedThreadFactory

No usage of javax.enterprise.concurrent.ManagedThreadFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.concurrent.Trigger (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.concurrent.Trigger

  • Packages that use Trigger
    Package Description
    javax.enterprise.concurrent
    Classes and interfaces for concurrent programming in Java EE™ applications.

    • Uses of Trigger in javax.enterprise.concurrent

      Methods in javax.enterprise.concurrent with parameters of type Trigger
      Modifier and Type Method and Description
      <V> ScheduledFuture<V> ManagedScheduledExecutorService.schedule(Callable<V> callable, Trigger trigger)
      Creates and executes a task based on a Trigger.
      ScheduledFuture<?> ManagedScheduledExecutorService.schedule(Runnable command, Trigger trigger)
      Creates and executes a task based on a Trigger.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ApplicationScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.context

Annotation Type ApplicationScoped

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
@NormalScope
@Inherited
public @interface ApplicationScoped

    Specifies that a bean is application scoped.

    The application scope is active:

    • during the service() method of any servlet in the web application, during the doFilter() method of any servlet filter and when the container calls any ServletContextListener, HttpSessionListener, AsyncListener or ServletRequestListener,
    • during any Java EE web service invocation,
    • during any remote method invocation of any EJB, during any asynchronous method invocation of any EJB, during any call to an EJB timeout method and during message delivery to any EJB message-driven bean,
    • during any message delivery to a MessageListener for a JMS topic or queue obtained from the Java EE component environment, and
    • when the disposer method or @PreDestroy callback of any bean with any normal scope other than @ApplicationScoped is called.

    The application context is shared between all servlet requests, web service invocations, EJB remote method invocations, EJB asynchronous method invocations, EJB timeouts and message deliveries to message-driven beans that execute within the same application. The application context is destroyed when the application is shut down.

    Author:
    Gavin King, Pete Muir
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


BusyConversationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.context

Class BusyConversationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.context.ContextException
            • javax.enterprise.context.BusyConversationException
  • All Implemented Interfaces:
    Serializable

    public class BusyConversationException
extends ContextException

    Indicates that the container has rejected a request because a concurrent request is associated with the same conversation context.

    The container ensures that a long-running conversation may be associated with at most one request at a time, by blocking or rejecting concurrent requests. If the container rejects a request, it must associate the request with a new transient conversation and throw an exception of type BusyConversationException from the restore view phase of the JSF lifecycle.

    Author:
    Pete Muir, Gavin King
    See Also:
    ConversationScoped, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      BusyConversationException()
      BusyConversationException(String message)
      BusyConversationException(String message, Throwable cause)
      BusyConversationException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BusyConversationException

        public BusyConversationException()

      • BusyConversationException

        public BusyConversationException(String message)

      • BusyConversationException

        public BusyConversationException(Throwable cause)

      • BusyConversationException

        public BusyConversationException(String message,
                         Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ContextException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.context

Class ContextException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.context.ContextException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    BusyConversationException, ContextNotActiveException, NonexistentConversationException

    public class ContextException
extends RuntimeException

    Indicates a problem relating to context management.

    Author:
    Pete Muir, Shane Bryzak
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ContextException()
      ContextException(String message)
      ContextException(String message, Throwable cause)
      ContextException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ContextException

        public ContextException()

      • ContextException

        public ContextException(String message)

      • ContextException

        public ContextException(Throwable cause)

      • ContextException

        public ContextException(String message,
                Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ContextNotActiveException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.context

Class ContextNotActiveException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.context.ContextException
            • javax.enterprise.context.ContextNotActiveException
  • All Implemented Interfaces:
    Serializable

    public class ContextNotActiveException
extends ContextException

    Indicates that a context is not active.

    Author:
    Pete Muir, Shane Bryzak, Gavin King
    See Also:
    Context, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ContextNotActiveException()
      ContextNotActiveException(String message)
      ContextNotActiveException(String message, Throwable cause)
      ContextNotActiveException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ContextNotActiveException

        public ContextNotActiveException()

      • ContextNotActiveException

        public ContextNotActiveException(String message)

      • ContextNotActiveException

        public ContextNotActiveException(Throwable cause)

      • ContextNotActiveException

        public ContextNotActiveException(String message,
                         Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Conversation (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.context

Interface Conversation

  • public interface Conversation

    Allows the application to manage the conversation context by marking the current conversation as transient or long-running, specifying a conversation identifier, or setting the conversation timeout.

    An instance may be injected:

     @Inject
 Conversation conversation;

    The conversation timeout is a hint to the container that a conversation should not be destroyed if it has been active within the last given interval in milliseconds.

    Author:
    Pete Muir, Gavin King
    See Also:
    @ConversationScoped

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void begin()
      Mark the current transient conversation long-running.
      void begin(String id)
      Mark the current transient conversation long-running, with a specified identifier.
      void end()
      Marks the current long-running conversation transient.
      String getId()
      Get the identifier of the current long-running conversation.
      long getTimeout()
      Get the timeout of the current conversation.
      boolean isTransient()
      Determine if the conversation is marked transient or long-running.
      void setTimeout(long milliseconds)
      Set the timeout of the current conversation.

    • Method Detail

      • begin

        void begin()

        Mark the current transient conversation long-running. A conversation identifier is generated by the container.

        Throws:
        IllegalStateException - if the current conversation is already marked long-running.

      • begin

        void begin(String id)

        Mark the current transient conversation long-running, with a specified identifier.

        Throws:
        IllegalStateException - if the current conversation is already marked long-running.
        IllegalArgumentException - if a conversation with the specified identifier already exists.

      • end

        void end()

        Marks the current long-running conversation transient.

        Throws:
        IllegalStateException - if the current conversation is already marked transient.

      • getId

        String getId()

        Get the identifier of the current long-running conversation.

        Returns:
        the identifier of the current long-running conversation, or a null value if the current conversation is transient.

      • getTimeout

        long getTimeout()

        Get the timeout of the current conversation.

        Returns:
        the current timeout in milliseconds.

      • setTimeout

        void setTimeout(long milliseconds)

        Set the timeout of the current conversation.

        Parameters:
        milliseconds - the new timeout in milliseconds.

      • isTransient

        boolean isTransient()

        Determine if the conversation is marked transient or long-running.

        Returns:
        true if the conversation is marked transient, or falseif it is marked long-running.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConversationScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.context

Annotation Type ConversationScoped

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
@NormalScope(passivating=true)
@Inherited
public @interface ConversationScoped

    Specifies that a bean is conversation scoped.

    The conversation scope is active:

    • during all standard lifecycle phases of any Servlet request.

    The conversation context provides access to state associated with a particular conversation. Every Servlet request has an associated conversation. This association is managed automatically by the container according to the following rules:

    • Any Servlet request has exactly one associated conversation.
    • The conversation associated with a Servlet request is determined at the beginning of the request and does not change during the request.

    Any conversation is in one of two states: transient or long-running.

    • By default, a conversation is transient
    • A transient conversation may be marked long-running by calling Conversation.begin()
    • A long-running conversation may be marked transient by calling Conversation.end()

    All long-running conversations have a string-valued unique identifier, which may be set by the application when the conversation is marked long-running, or generated by the container.

    If the conversation associated with the current Servlet request is in the transient state at the end of a Servlet request, it is destroyed, and the conversation context is also destroyed.

    If the conversation associated with the current Servlet request is in the long-running state at the end of a Servlet request, it is not destroyed. The long-running conversation associated with a request may be propagated to any Servlet request via use of a GET request parameter named cid containing the unique identifier of the conversation. In this case, the application must manage this request parameter.

    If the current Servlet request is a JSF request, and the conversation is in long-running state, it is propagated according to the following rules:

    • The long-running conversation context associated with a request that renders a JSF view is automatically propagated to any faces request (JSF form submission) that originates from that rendered page.
    • The long-running conversation context associated with a request that results in a JSF redirect (a redirect resulting from a navigation rule or JSF NavigationHandler) is automatically propagated to the resulting non-faces request, and to any other subsequent request to the same URL. This is accomplished via use of a GET request parameter named cid containing the unique identifier of the conversation.

    When no conversation is propagated to a Servlet request, the request is associated with a new transient conversation. All long-running conversations are scoped to a particular HTTP servlet session and may not cross session boundaries. In the following cases, a propagated long-running conversation cannot be restored and reassociated with the request:

    • When the HTTP servlet session is invalidated, all long-running conversation contexts created during the current session are destroyed, after the servlet service() method completes.
    • The container is permitted to arbitrarily destroy any long-running conversation that is associated with no current Servlet request, in order to conserve resources.
    Author:
    Gavin King, Pete Muir
    See Also:
    Conversation, NonexistentConversationException, BusyConversationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Dependent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.context

Annotation Type Dependent

  • @Target(value={METHOD,TYPE,FIELD})
@Retention(value=RUNTIME)
@Documented
@Scope
@Inherited
public @interface Dependent

    Specifies that a bean belongs to the dependent pseudo-scope.

    Beans declared with scope @Dependent behave differently to beans with other built-in scope types. When a bean is declared to have scope @Dependent:

    • No injected instance of the bean is ever shared between multiple injection points.
    • Any instance of the bean injected into an object that is being created by the container is bound to the lifecycle of the newly created object.
    • When a Unified EL expression in a JSF or JSP page that refers to the bean by its EL name is evaluated, at most one instance of the bean is instantiated. This instance exists to service just a single evaluation of the EL expression. It is reused if the bean EL name appears multiple times in the EL expression, but is never reused when the EL expression is evaluated again, or when another EL expression is evaluated.
    • Any instance of the bean that receives a producer method, producer field, disposer method or observer method invocation exists to service that invocation only.
    • Any instance of the bean injected into method parameters of a disposer method or observer method exists to service the method invocation only.

    Every invocation of the Context.get(Contextual, CreationalContext) operation of the context object for the @Dependent scope returns a new instance of the given bean.

    Every invocation of the Context.get(Contextual) operation of the context object for the @Dependent scope returns a null value.

    The @Dependent scope is always active.

    Many instances of beans with scope @Dependent belong to some other bean or Java EE component class instance and are called dependent objects.

    • Instances of decorators and interceptors are dependent objects of the bean instance they decorate.
    • An instance of a bean with scope @Dependent injected into a field, bean constructor or initializer method is a dependent object of the bean or Java EE component class instance into which it was injected.
    • An instance of a bean with scope @Dependent injected into a producer method is a dependent object of the producer method bean instance that is being produced.
    • An instance of a bean with scope @Dependent obtained by direct invocation of an Instance is a dependent object of the instance of Instance.

    When the container destroys an instance of a bean or of any Java EE component class supporting injection, the container destroys all its dependent objects, after the @PreDestroy callback completes and after the servlet destroy() method is called.

    Author:
    Gavin King, Pete Muir
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Destroyed (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.context

Annotation Type Destroyed

  • @Qualifier
@Target(value={TYPE,METHOD,PARAMETER,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface Destroyed

    The @Destroyed qualifier.

    Since:
    1.1
    Author:
    Pete Muir
    See Also:
    Initialized

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<? extends Annotation> value
      The scope for which to observe initialization

    • Element Detail

      • value

        public abstract Class<? extends Annotation> value
        The scope for which to observe initialization
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Initialized (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.context

Annotation Type Initialized

  • @Qualifier
@Target(value={TYPE,METHOD,PARAMETER,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface Initialized

    The @Initialized qualifier.

    Since:
    1.1
    Author:
    Pete Muir
    See Also:
    Destroyed

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<? extends Annotation> value
      The scope for which to observe initialization

    • Element Detail

      • value

        public abstract Class<? extends Annotation> value
        The scope for which to observe initialization
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.enterprise.context (Java(TM) EE 7 Specification APIs)

javax.enterprise.context

Interfaces

  • Conversation

Exceptions

  • BusyConversationException
  • ContextException
  • ContextNotActiveException
  • NonexistentConversationException

Annotation Types

  • ApplicationScoped
  • ConversationScoped
  • Dependent
  • Destroyed
  • Initialized
  • NormalScope
  • RequestScoped
  • SessionScoped


javax.enterprise.context (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.context

Annotations and interfaces relating to scopes and contexts.

See: Description

  • Interface Summary
    Interface Description
    Conversation
    Allows the application to manage the conversation context by marking the current conversation as transient or long-running, specifying a conversation identifier, or setting the conversation timeout.
  • Exception Summary
    Exception Description
    BusyConversationException
    Indicates that the container has rejected a request because a concurrent request is associated with the same conversation context.
    ContextException
    Indicates a problem relating to context management.
    ContextNotActiveException
    Indicates that a context is not active.
    NonexistentConversationException
    Indicates that the conversation context could not be restored.
  • Annotation Types Summary
    Annotation Type Description
    ApplicationScoped
    Specifies that a bean is application scoped.
    ConversationScoped
    Specifies that a bean is conversation scoped.
    Dependent
    Specifies that a bean belongs to the dependent pseudo-scope.
    Destroyed
    The @Destroyed qualifier.
    Initialized
    The @Initialized qualifier.
    NormalScope
    Specifies that an annotation type is a normal scope type.
    RequestScoped
    Specifies that a bean is request scoped.
    SessionScoped
    Specifies that a bean is session scoped.

Package javax.enterprise.context Description

Annotations and interfaces relating to scopes and contexts.

A scope type is a Java annotation annotated @Scope or @NormalScope. The scope of a bean determines the lifecycle and visibility of its instances. In particular, the scope determines:

  • When a new instance of the bean is created
  • When an existing instance of the bean is destroyed
  • Which injected references refer to any instance of the bean

Built-in scopes

The following built-in scopes are provided: @Dependent, @RequestScoped, @ConversationScoped, @SessionScoped, @ApplicationScoped, @Singleton.

The container provides an implementation of the Context interface for each of the built-in scopes. The built-in request, session, and application contexts support servlet, web service and EJB invocations. The built-in conversation context supports JSF requests.

For other kinds of invocations, a portable extension may define a custom context object for any or all of the built-in scopes. For example, a third-party web application framework might provide a conversation context object for the built-in conversation scope.

The context associated with a built-in scope propagates across local, synchronous Java method calls, including invocation of EJB local business methods. The context does not propagate across remote method invocations or to asynchronous processes such as JMS message listeners or EJB timer service timeouts.

Normal scopes and pseudo-scopes

Most scopes are normal scopes. Normal scopes are declared using @NormalScope. If a bean has a normal scope, every client executing in a certain thread sees the same contextual instance of the bean. This instance is called the current instance of the bean. The operation Context.get(Contextual) of the context object for a normal scope type always returns the current instance of the given bean.

Any scope that is not a normal scope is called a pseudo-scope. Pseudo-scopes are declared using @Scope. The concept of a current instance is not well-defined in the case of a pseudo-scope. Different clients executing in the same thread may see different instances of the bean. In the extreme case of the @Dependent pseudo-scope, every client has its own private instance of the bean.

All built-in scopes are normal scopes, except for the @Dependent and @Singleton pseudo-scopes.

Contextual and injected reference validity

A reference to a bean obtained from the container via programmatic lookup is called a contextual reference. A contextual reference for a bean with a normal scope refers to the current instance of the bean. A contextual reference for a bean are valid only for a certain period of time. The application should not invoke a method of an invalid reference.

The validity of a contextual reference for a bean depends upon whether the scope of the bean is a normal scope or a pseudo-scope:

  • Any reference to a bean with a normal scope is valid as long as the application maintains a hard reference to it. However, it may only be invoked when the context associated with the normal scope is active. If it is invoked when the context is inactive, a ContextNotActiveException is thrown by the container.
  • Any reference to a bean with a pseudo-scope is valid until the bean instance to which it refers is destroyed. It may be invoked even if the context associated with the pseudo-scope is not active. If the application invokes a method of a reference to an instance that has already been destroyed, the behavior is undefined.

A reference to a bean obtained from the container via dependency injection is a special kind of contextual reference, called an injected reference. Additional restrictions apply to the validity of an injected reference:

  • A reference to a bean injected into a field, bean constructor or initializer method is only valid until the object into which it was injected is destroyed.
  • A reference to a bean injected into a producer method is only valid until the producer method bean instance that is being produced is destroyed.
  • A reference to a bean injected into a disposer method or observer method is only valid until the invocation of the method completes.
See Also:
javax.enterprise.inject
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.context Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.context

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.context.ContextException
            • javax.enterprise.context.BusyConversationException
            • javax.enterprise.context.ContextNotActiveException
            • javax.enterprise.context.NonexistentConversationException

Interface Hierarchy

  • javax.enterprise.context.Conversation

Annotation Type Hierarchy

  • javax.enterprise.context.SessionScoped (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.RequestScoped (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.NormalScope (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.Initialized (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.Destroyed (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.Dependent (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.ConversationScoped (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.ApplicationScoped (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


NonexistentConversationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.context

Class NonexistentConversationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.context.ContextException
            • javax.enterprise.context.NonexistentConversationException
  • All Implemented Interfaces:
    Serializable

    public class NonexistentConversationException
extends ContextException

    Indicates that the conversation context could not be restored.

    If the propagated conversation cannot be restored, the container must associate the request with a new transient conversation and throw an exception of type NonexistentConversationException from the restore view phase of the JSF lifecycle.

    Author:
    Pete Muir, Gavin King
    See Also:
    ConversationScoped, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NonexistentConversationException()
      NonexistentConversationException(String message)
      NonexistentConversationException(String message, Throwable cause)
      NonexistentConversationException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NonexistentConversationException

        public NonexistentConversationException()

      • NonexistentConversationException

        public NonexistentConversationException(String message)

      • NonexistentConversationException

        public NonexistentConversationException(Throwable cause)

      • NonexistentConversationException

        public NonexistentConversationException(String message,
                                Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NormalScope (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.context

Annotation Type NormalScope

  • @Target(value=ANNOTATION_TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface NormalScope

    Specifies that an annotation type is a normal scope type.

    Author:
    Gavin King, Pete Muir
    See Also:
    @Scope is used to declare pseudo-scopes.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean passivating
      Determines whether the normal scope type is a passivating scope.

    • Element Detail

      • passivating

        public abstract boolean passivating

        Determines whether the normal scope type is a passivating scope.

        A bean is called passivation capable if the container is able to temporarily transfer the state of any idle instance to secondary storage. A passivating scope requires that beans with the scope are passivation capable.

        Returns:
        true if the scope type is a passivating scope type
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


RequestScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.context

Annotation Type RequestScoped

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
@NormalScope
@Inherited
public @interface RequestScoped

    Specifies that a bean is request scoped.

    The request scope is active:

    • during the service() method of any servlet in the web application, during the doFilter() method of any servlet filter and when the container calls any ServletRequestListener or AsyncListener,
    • during any Java EE web service invocation,
    • during any remote method invocation of any EJB, during any asynchronous method invocation of any EJB, during any call to an EJB timeout method and during message delivery to any EJB message-driven bean, and
    • during any message delivery to a MessageListener for a JMS topic or queue obtained from the Java EE component environment.

    The request context is destroyed:

    • at the end of the servlet request, after the service() method, all doFilter() methods, and all requestDestroyed() and onComplete() notifications return,
    • after the web service invocation completes,
    • after the EJB remote method invocation, asynchronous method invocation, timeout or message delivery completes, or
    • after the message delivery to the MessageListener completes.
    Author:
    Gavin King, Pete Muir
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


SessionScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.context

Annotation Type SessionScoped

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
@NormalScope(passivating=true)
@Inherited
public @interface SessionScoped

    Specifies that a bean is session scoped.

    The session scope is active:

    • during the service() method of any servlet in the web application, during the doFilter() method of any servlet filter and when the container calls any HttpSessionListener, AsyncListener or ServletRequestListener.

    The session context is shared between all servlet requests that occur in the same HTTP session. The session context is destroyed when the HTTPSession times out, after all HttpSessionListeners have been called, and at the very end of any request in which invalidate() was called, after all filters and ServletRequestListeners have been called.

    Author:
    Gavin King, Pete Muir
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.enterprise.context (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.context

  • Packages that use javax.enterprise.context
    Package Description
    javax.enterprise.context
    Annotations and interfaces relating to scopes and contexts.
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.
  • Classes in javax.enterprise.context used by javax.enterprise.context
    Class and Description
    ContextException
    Indicates a problem relating to context management.
    NormalScope
    Specifies that an annotation type is a normal scope type.
  • Classes in javax.enterprise.context used by javax.enterprise.inject
    Class and Description
    RequestScoped
    Specifies that a bean is request scoped.
  • Classes in javax.enterprise.context used by javax.faces.flow
    Class and Description
    NormalScope
    Specifies that an annotation type is a normal scope type.
  • Classes in javax.enterprise.context used by javax.faces.view
    Class and Description
    NormalScope
    Specifies that an annotation type is a normal scope type.
  • Classes in javax.enterprise.context used by javax.transaction
    Class and Description
    NormalScope
    Specifies that an annotation type is a normal scope type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.ApplicationScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.ApplicationScoped

No usage of javax.enterprise.context.ApplicationScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.BusyConversationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.BusyConversationException

No usage of javax.enterprise.context.BusyConversationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.ContextException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.ContextException

  • Packages that use ContextException
    Package Description
    javax.enterprise.context
    Annotations and interfaces relating to scopes and contexts.

    • Uses of ContextException in javax.enterprise.context

      Subclasses of ContextException in javax.enterprise.context
      Modifier and Type Class and Description
      class  BusyConversationException
      Indicates that the container has rejected a request because a concurrent request is associated with the same conversation context.
      class  ContextNotActiveException
      Indicates that a context is not active.
      class  NonexistentConversationException
      Indicates that the conversation context could not be restored.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.ContextNotActiveException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.ContextNotActiveException

No usage of javax.enterprise.context.ContextNotActiveException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.ConversationScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.ConversationScoped

No usage of javax.enterprise.context.ConversationScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.Dependent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.Dependent

No usage of javax.enterprise.context.Dependent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.Destroyed (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.Destroyed

No usage of javax.enterprise.context.Destroyed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.Initialized (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.Initialized

No usage of javax.enterprise.context.Initialized
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.NonexistentConversationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.NonexistentConversationException

No usage of javax.enterprise.context.NonexistentConversationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.NormalScope (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.NormalScope

  • Packages that use NormalScope
    Package Description
    javax.enterprise.context
    Annotations and interfaces relating to scopes and contexts.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of NormalScope in javax.enterprise.context

      Classes in javax.enterprise.context with annotations of type NormalScope
      Modifier and Type Class and Description
      interface  ApplicationScoped
      Specifies that a bean is application scoped.
      interface  ConversationScoped
      Specifies that a bean is conversation scoped.
      interface  RequestScoped
      Specifies that a bean is request scoped.
      interface  SessionScoped
      Specifies that a bean is session scoped.

    • Uses of NormalScope in javax.faces.flow

      Classes in javax.faces.flow with annotations of type NormalScope
      Modifier and Type Class and Description
      interface  FlowScoped

      FlowScoped is a CDI scope that causes the runtime to consider classes with this annotation to be in the scope of the specified Flow.

    • Uses of NormalScope in javax.faces.view

      Classes in javax.faces.view with annotations of type NormalScope
      Modifier and Type Class and Description
      interface  ViewScoped

      When this annotation, along with javax.inject.Named is found on a class, the runtime must place the bean in a CDI scope such that it remains active as long as NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) does not cause a navigation to a view with a viewId that is different than the viewId of the current view.

    • Uses of NormalScope in javax.transaction

      Classes in javax.transaction with annotations of type NormalScope
      Modifier and Type Class and Description
      interface  TransactionScoped
      The javax.transaction.TransactionScoped annotation provides the ability to specify a standard CDI scope to define bean instances whose lifecycle is scoped to the currently active JTA transaction.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.RequestScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.RequestScoped

  • Packages that use RequestScoped
    Package Description
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.

    • Uses of RequestScoped in javax.enterprise.inject

      Classes in javax.enterprise.inject with annotations of type RequestScoped
      Modifier and Type Class and Description
      interface  Model
      The built-in stereotype intended for use with beans that define the model layer of an MVC web application architecture such as JSF.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.context.SessionScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.context.SessionScoped

No usage of javax.enterprise.context.SessionScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.context.Conversation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.context.Conversation

No usage of javax.enterprise.context.Conversation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AlterableContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.context.spi

Interface AlterableContext

  • All Superinterfaces:
    Context

    public interface AlterableContext
extends Context

    Provides an operation for obtaining and destroying contextual instances with a particular scope of any contextual type. Any instance of Context is called a context object.

    AlterableContext was introduced in CDI 1.1 to allow bean instances to be destroyed by the application. Extensions should implement AlterableContext instead of Context.

    The context object is responsible for creating and destroying contextual instances by calling operations of Contextual. In particular, the context object is responsible for destroying any contextual instance it creates by passing the instance to Contextual.destroy(Object, CreationalContext) . A destroyed instance must not subsequently be returned by get(). The context object must pass the same instance of CreationalContext to Contextual.destroy() that it passed to Contextual.create() when it created the instance.

    A custom context object may be registered with the container using AfterBeanDiscovery.addContext(Context).

    Since:
    1.1
    Author:
    Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy(Contextual<?> contextual)
      Destroy the existing contextual instance.

      • Methods inherited from interface javax.enterprise.context.spi.Context

        get, get, getScope, isActive

    • Method Detail

      • destroy

        void destroy(Contextual<?> contextual)

        Destroy the existing contextual instance. If there is no existing instance, no action is taken.

        Parameters:
        contextual - the contextual type
        Throws:
        ContextNotActiveException - if the context is not active
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Context (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.context.spi

Interface Context

  • All Known Subinterfaces:
    AlterableContext

    public interface Context

    Provides an operation for obtaining contextual instances with a particular scope of any contextual type. Any instance of Context is called a context object.

    AlterableContext was introduced in CDI 1.1 to allow bean instances to be destroyed by the application. Extensions should implement AlterableContext instead of Context.

    The context object is responsible for creating and destroying contextual instances by calling operations of Contextual. In particular, the context object is responsible for destroying any contextual instance it creates by passing the instance to Contextual.destroy(Object, CreationalContext) . A destroyed instance must not subsequently be returned by get(). The context object must pass the same instance of CreationalContext to Contextual.destroy() that it passed to Contextual.create() when it created the instance.

    A custom context object may be registered with the container using AfterBeanDiscovery.addContext(Context).

    Author:
    Gavin King, Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T> T get(Contextual<T> contextual)
      Return an existing instance of a certain contextual type or a null value.
      <T> T get(Contextual<T> contextual, CreationalContext<T> creationalContext)
      Return an existing instance of certain contextual type or create a new instance by calling Contextual.create(CreationalContext) and return the new instance.
      Class<? extends Annotation> getScope()
      Get the scope type of the context object.
      boolean isActive()
      Determines if the context object is active.

    • Method Detail

      • getScope

        Class<? extends Annotation> getScope()
        Get the scope type of the context object.
        Returns:
        the scope

      • get

        <T> T get(Contextual<T> contextual,
        CreationalContext<T> creationalContext)
        Return an existing instance of certain contextual type or create a new instance by calling Contextual.create(CreationalContext) and return the new instance.
        Type Parameters:
        T - the type of contextual type
        Parameters:
        contextual - the contextual type
        creationalContext - the context in which the new instance will be created
        Returns:
        the contextual instance
        Throws:
        ContextNotActiveException - if the context is not active

      • get

        <T> T get(Contextual<T> contextual)
        Return an existing instance of a certain contextual type or a null value.
        Type Parameters:
        T - the type of the contextual type
        Parameters:
        contextual - the contextual type
        Returns:
        the contextual instance, or a null value
        Throws:
        ContextNotActiveException - if the context is not active

      • isActive

        boolean isActive()
        Determines if the context object is active.
        Returns:
        true if the context is active, or false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Contextual (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.context.spi

Interface Contextual<T>

  • All Known Subinterfaces:
    Bean<T>, Decorator<T>, Interceptor<T>

    public interface Contextual<T>

    Defines operations to create and destroy contextual instances of a certain type. Any implementation of Contextual is called a contextual type. In particular, all beans are contextual types.

    Author:
    Gavin King, Nicklas Karlsson, Pete Muir
    See Also:
    Bean

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T create(CreationalContext<T> creationalContext)
      Create a new instance of the contextual type.
      void destroy(T instance, CreationalContext<T> creationalContext)
      Destroy an instance of the contextual type.

    • Method Detail

      • create

        T create(CreationalContext<T> creationalContext)
        Create a new instance of the contextual type. Instances should use the given CreationalContext when obtaining contextual references to inject, in order to ensure that any dependent objects are associated with the contextual instance that is being created. An implementation may call CreationalContext.push(Object) between instantiation and injection to help the container minimize the use of client proxy objects.
        Parameters:
        creationalContext - the context in which this instance is being created
        Returns:
        the contextual instance
        Throws:
        CreationException - if a checked exception occurs while creating the instance

      • destroy

        void destroy(T instance,
           CreationalContext<T> creationalContext)
        Destroy an instance of the contextual type. Implementations should call CreationalContext.release() to allow the container to destroy dependent objects of the contextual instance.
        Parameters:
        instance - the contextual instance to destroy
        creationalContext - the context in which this instance was created
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CreationalContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.context.spi

Interface CreationalContext<T>

  • public interface CreationalContext<T>

    Provides operations that are used by the Contextual implementation during instance creation and destruction.

    Author:
    Gavin King, Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void push(T incompleteInstance)
      Registers an incompletely initialized contextual instance the with the container.
      void release()
      Destroys all dependent objects of the instance which is being destroyed, by passing each dependent object to Contextual.destroy(Object, CreationalContext) .

    • Method Detail

      • push

        void push(T incompleteInstance)
        Registers an incompletely initialized contextual instance the with the container. A contextual instance is considered incompletely initialized until it is returned by Contextual.create(CreationalContext) .
        Parameters:
        incompleteInstance - the incompletely initialized instance

      • release

        void release()
        Destroys all dependent objects of the instance which is being destroyed, by passing each dependent object to Contextual.destroy(Object, CreationalContext) .
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.context.spi (Java(TM) EE 7 Specification APIs)

javax.enterprise.context.spi

Interfaces

  • AlterableContext
  • Context
  • Contextual
  • CreationalContext


javax.enterprise.context.spi (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.context.spi

The custom context SPI.

See: Description

  • Interface Summary
    Interface Description
    AlterableContext
    Provides an operation for obtaining and destroying contextual instances with a particular scope of any contextual type.
    Context
    Provides an operation for obtaining contextual instances with a particular scope of any contextual type.
    Contextual<T>
    Defines operations to create and destroy contextual instances of a certain type.
    CreationalContext<T>
    Provides operations that are used by the Contextual implementation during instance creation and destruction.

Package javax.enterprise.context.spi Description

The custom context SPI.

Associated with every scope type is a context object. The context object implements the semantics of the scope type.

The context implementation collaborates with the container via the Context and Contextual interfaces to create and destroy contextual instances.

See Also:
javax.enterprise.context, javax.enterprise.inject.spi
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.context.spi Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.context.spi

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.enterprise.context.spi.Context
    • javax.enterprise.context.spi.AlterableContext
  • javax.enterprise.context.spi.Contextual<T>
  • javax.enterprise.context.spi.CreationalContext<T>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.enterprise.context.spi (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.context.spi

  • Packages that use javax.enterprise.context.spi
    Package Description
    javax.enterprise.context.spi
    The custom context SPI.
    javax.enterprise.inject.spi
    The portable extension integration SPI.
  • Classes in javax.enterprise.context.spi used by javax.enterprise.context.spi
    Class and Description
    Context
    Provides an operation for obtaining contextual instances with a particular scope of any contextual type.
    Contextual
    Defines operations to create and destroy contextual instances of a certain type.
    CreationalContext
    Provides operations that are used by the Contextual implementation during instance creation and destruction.
  • Classes in javax.enterprise.context.spi used by javax.enterprise.inject.spi
    Class and Description
    Context
    Provides an operation for obtaining contextual instances with a particular scope of any contextual type.
    Contextual
    Defines operations to create and destroy contextual instances of a certain type.
    CreationalContext
    Provides operations that are used by the Contextual implementation during instance creation and destruction.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.context.spi.AlterableContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.context.spi.AlterableContext

No usage of javax.enterprise.context.spi.AlterableContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.context.spi.Context (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.context.spi.Context

  • Packages that use Context
    Package Description
    javax.enterprise.context.spi
    The custom context SPI.
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Context in javax.enterprise.context.spi

      Subinterfaces of Context in javax.enterprise.context.spi
      Modifier and Type Interface and Description
      interface  AlterableContext
      Provides an operation for obtaining and destroying contextual instances with a particular scope of any contextual type.

    • Uses of Context in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return Context
      Modifier and Type Method and Description
      Context BeanManager.getContext(Class<? extends Annotation> scopeType)
      Obtains an active context object for the given scope .
      Methods in javax.enterprise.inject.spi with parameters of type Context
      Modifier and Type Method and Description
      void AfterBeanDiscovery.addContext(Context context)
      Registers a custom Context object with the container.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.context.spi.Contextual (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.context.spi.Contextual

  • Packages that use Contextual
    Package Description
    javax.enterprise.context.spi
    The custom context SPI.
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Contextual in javax.enterprise.context.spi

      Methods in javax.enterprise.context.spi with parameters of type Contextual
      Modifier and Type Method and Description
      void AlterableContext.destroy(Contextual<?> contextual)
      Destroy the existing contextual instance.
      <T> T Context.get(Contextual<T> contextual)
      Return an existing instance of a certain contextual type or a null value.
      <T> T Context.get(Contextual<T> contextual, CreationalContext<T> creationalContext)
      Return an existing instance of certain contextual type or create a new instance by calling create(CreationalContext) and return the new instance.

    • Uses of Contextual in javax.enterprise.inject.spi

      Subinterfaces of Contextual in javax.enterprise.inject.spi
      Modifier and Type Interface and Description
      interface  Bean<T>
      Represents an enabled bean.
      interface  Decorator<T>
      Represents an enabled decorator.
      interface  Interceptor<T>
      Represents an enabled interceptor.
      Methods in javax.enterprise.inject.spi with parameters of type Contextual
      Modifier and Type Method and Description
      <T> CreationalContext<T> BeanManager.createCreationalContext(Contextual<T> contextual)
      Obtain an instance of a CreationalContext for the given contextual type, or for a non-contextual object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.context.spi.CreationalContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.context.spi.CreationalContext

  • Packages that use CreationalContext
    Package Description
    javax.enterprise.context.spi
    The custom context SPI.
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of CreationalContext in javax.enterprise.context.spi

      Methods in javax.enterprise.context.spi with parameters of type CreationalContext
      Modifier and Type Method and Description
      T Contextual.create(CreationalContext<T> creationalContext)
      Create a new instance of the contextual type.
      void Contextual.destroy(T instance, CreationalContext<T> creationalContext)
      Destroy an instance of the contextual type.
      <T> T Context.get(Contextual<T> contextual, CreationalContext<T> creationalContext)
      Return an existing instance of certain contextual type or create a new instance by calling Contextual.create(CreationalContext) and return the new instance.

    • Uses of CreationalContext in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return CreationalContext
      Modifier and Type Method and Description
      <T> CreationalContext<T> BeanManager.createCreationalContext(Contextual<T> contextual)
      Obtain an instance of a CreationalContext for the given contextual type, or for a non-contextual object.
      Methods in javax.enterprise.inject.spi with parameters of type CreationalContext
      Modifier and Type Method and Description
      Object BeanManager.getInjectableReference(InjectionPoint ij, CreationalContext<?> ctx)
      Obtains an injectable reference for a certain injection point.
      Object BeanManager.getReference(Bean<?> bean, Type beanType, CreationalContext<?> ctx)
      Obtains a contextual reference for a certain bean and a certain bean type of the bean.
      void InjectionTarget.inject(T instance, CreationalContext<T> ctx)
      Performs dependency injection upon the given object.
      T Producer.produce(CreationalContext<T> ctx)
      Causes an instance to be produced via the Producer.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


DDBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.model

Interface DDBean

  • All Known Subinterfaces:
    DDBeanRoot

    public interface DDBean
    An interface for beans that represent a fragment of a standard deployment descriptor. A link is provided to the Java EE application that includes this bean.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addXpathListener(String xpath, XpathListener xpl)
      Register a listener for a specific XPath.
      String[] getAttributeNames()
      Returns the list of attribute names associated with the XML element.
      String getAttributeValue(String attrName)
      Returns the string value of the named attribute.
      DDBean[] getChildBean(String xpath)
      Return a list of DDBeans based upon the XPath.
      String getId()
      Returns a tool-specific reference for attribute ID on an element in the deployment descriptor.
      DDBeanRoot getRoot()
      Return the root element for this DDBean.
      String getText()
      Returns the XML text for by this bean.
      String[] getText(String xpath)
      Return a list of text values for a given XPath in the deployment descriptor.
      String getXpath()
      Returns the original xpath string provided by the DConfigBean.
      void removeXpathListener(String xpath, XpathListener xpl)
      Unregister a listener for a specific XPath.

    • Method Detail

      • getXpath

        String getXpath()
        Returns the original xpath string provided by the DConfigBean.
        Returns:
        The XPath of this Bean.

      • getText

        String getText()
        Returns the XML text for by this bean.
        Returns:
        The XML text for this Bean.

      • getId

        String getId()
        Returns a tool-specific reference for attribute ID on an element in the deployment descriptor. This attribute is defined for J2EE 1.2 and 1.3 components.
        Returns:
        The XML text for this Bean or 'null' if no attribute was specifed with the tag.

      • getRoot

        DDBeanRoot getRoot()
        Return the root element for this DDBean.
        Returns:
        The DDBeanRoot at the root of this DDBean tree.

      • getChildBean

        DDBean[] getChildBean(String xpath)
        Return a list of DDBeans based upon the XPath.
        Parameters:
        xpath - An XPath string referring to a location in the same deployment descriptor as this standard bean.
        Returns:
        a list of DDBeans or 'null' if no matching XML data is found.

      • getText

        String[] getText(String xpath)
        Return a list of text values for a given XPath in the deployment descriptor.
        Parameters:
        xpath - An XPath.
        Returns:
        The list text values for this XPath or 'null' if no matching XML data is found.

      • addXpathListener

        void addXpathListener(String xpath,
                    XpathListener xpl)
        Register a listener for a specific XPath.
        Parameters:
        xpath - The XPath this listener is to be registered for.
        xpl - The listener object.

      • removeXpathListener

        void removeXpathListener(String xpath,
                       XpathListener xpl)
        Unregister a listener for a specific XPath.
        Parameters:
        xpath - The XPath from which this listener is to be unregistered.
        xpl - The listener object.

      • getAttributeNames

        String[] getAttributeNames()
        Returns the list of attribute names associated with the XML element.
        Returns:
        a list of attribute names on this element. Null is returned if there are no attributes.

      • getAttributeValue

        String getAttributeValue(String attrName)
        Returns the string value of the named attribute.
        Returns:
        a the value of the attribute. Null is returned if there is no such attribute.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DDBeanRoot (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.model

Interface DDBeanRoot

  • All Superinterfaces:
    DDBean

    public interface DDBeanRoot
extends DDBean
    An interface that represents the root of a standard deployment descriptor. A DDBeanRoot is a type of DDBean.
    Author:
    gfink

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDDBeanRootVersion()
      Returns the version number of an XML instance document.
      DeployableObject getDeployableObject()
      Return the containing DeployableObject
      String getFilename()
      Returns the filename relative to the root of the module of the XML instance document this DDBeanRoot represents.
      String getModuleDTDVersion()
      Deprecated.
      As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
      ModuleType getType()
      Return the ModuleType of deployment descriptor.
      String getXpath()
      Return the XPath for this standard bean.

      • Methods inherited from interface javax.enterprise.deploy.model.DDBean

        addXpathListener, getAttributeNames, getAttributeValue, getChildBean, getId, getRoot, getText, getText, removeXpathListener

    • Method Detail

      • getType

        ModuleType getType()
        Return the ModuleType of deployment descriptor.
        Returns:
        The ModuleType of deployment descriptor

      • getDeployableObject

        DeployableObject getDeployableObject()
        Return the containing DeployableObject
        Returns:
        The DeployableObject that contains this deployment descriptor

      • getModuleDTDVersion

        String getModuleDTDVersion()
        Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
        A convenience method to return the DTD version number. The DeployableObject has this information.
        Returns:
        a string containing the DTD version number This method is being deprecated. Two DD data formats are being used, DTD and XML Schema. DDBeanRoot.getDDBeanRootVersion should be used in its place.

      • getDDBeanRootVersion

        String getDDBeanRootVersion()
        Returns the version number of an XML instance document. This method is replacing the methods DDBeanRoot.getModuleDTDVersion and DeployableObject.getModuleDTDVersion. This method returns the version number of any Java EE XML instance document.
        Returns:
        a string that is the version number of the XML instance document. Null is returned if no version number can be found.

      • getXpath

        String getXpath()
        Return the XPath for this standard bean. The root XPath is "/".
        Specified by:
        getXpath in interface DDBean
        Returns:
        "/" this is the root standard bean.

      • getFilename

        String getFilename()
        Returns the filename relative to the root of the module of the XML instance document this DDBeanRoot represents.
        Returns:
        String the filename relative to the root of the module
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeployableObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.model

Interface DeployableObject

  • All Known Subinterfaces:
    J2eeApplicationObject

    public interface DeployableObject
    The DeployableObject interface is an abstract representation of a Java EE deployable module (JAR, WAR, RAR, EAR). A DeployableObject provides access to the module's deployment descriptor and class files.
    Version:
    0.1
    Author:
    gfink

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Enumeration entries()
      Returns an enumeration of the module file entries.
      DDBean[] getChildBean(String xpath)
      Return an array of standard beans representing the XML content returned based upon the XPath.
      Class getClassFromScope(String className)
      Retrieve the specified class from this deployable module.
      DDBeanRoot getDDBeanRoot()
      Return the top level standard bean representing the root of the deployment descriptor.
      DDBeanRoot getDDBeanRoot(String filename)
      Returns a DDBeanRoot object for the XML instance document named.
      InputStream getEntry(String name)
      Returns the InputStream for the given entry name The file name must be relative to the root of the module.
      String getModuleDTDVersion()
      Deprecated.
      As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
      String[] getText(String xpath)
      Return the XML content associated with the XPath from a deployment descriptor.
      ModuleType getType()
      Return the ModuleType of deployment descriptor (i.e., EAR, JAR, WAR, RAR) this deployable object represents.

    • Method Detail

      • getType

        ModuleType getType()
        Return the ModuleType of deployment descriptor (i.e., EAR, JAR, WAR, RAR) this deployable object represents. Values are found in DeploymentManager.
        Returns:
        The ModuleType of deployable object

      • getDDBeanRoot

        DDBeanRoot getDDBeanRoot()
        Return the top level standard bean representing the root of the deployment descriptor.
        Returns:
        A standard bean representing the deployment descriptor.

      • getChildBean

        DDBean[] getChildBean(String xpath)
        Return an array of standard beans representing the XML content returned based upon the XPath.
        Parameters:
        xpath - An XPath string identifying the data to be extracted from the deployment descriptor.
        Returns:
        a array of DDBeans or 'null' if no matching data found.

      • getText

        String[] getText(String xpath)
        Return the XML content associated with the XPath from a deployment descriptor.
        Parameters:
        xpath - An xpath string referring to a location in the deployment descriptor
        Returns:
        a list XML content or 'null' if no matching data found.

      • getClassFromScope

        Class getClassFromScope(String className)
        Retrieve the specified class from this deployable module.

        One use: to get all finder methods from an EJB If the tool is attempting to package an module and retrieve a class from the package, the class request may fail. The class may not yet be available. The tool should respect the manifest cross-path entries.

        Parameters:
        className - Class to retrieve.
        Returns:
        Class representation of the class

      • getModuleDTDVersion

        String getModuleDTDVersion()
        Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
        Returns the DTD version number given in the XML DOCTYPE text provided in every standard Java EE module's deployment descriptor file.
        Returns:
        a string containing the DTD version number
         A module's deployment descriptor file always contains
 a document type identifier, DOCTYPE.  The DOCTYPE statement
 contains the module DTD version number in the label of the
 statement.

        The format of the DOCTYPE statement is:

        <!DOCTYPE root_element PUBLIC
        "-//organization//label//language" "location">

 root_element - is the name of the root document in the DTD.
 organization  - is the name of the organization responsible
                 for the creation and maintenance of the DTD
                 being referenced.
 label - is a unique descriptive name for the public text being
                 referenced.
 language - is the ISO 639 language id representing the natural
                 language encoding of th DTD.
 location - is the URL of the DTD.

 An example Java EE deployment descriptor DOCTYPE statement is:

   <!DOCTYPE application-client PUBLIC
   "-//Sun Microsystems, Inc.//DTD J2EE Application Client 1.3//EN"
   "http://java.sun.com/dtd/application-client_1_3.dtd">

 In this example the label is, "DTD J2EE Application Client 1.3",
 and the DTD version number is 1.3. A call to getModuleDTDVersion
 would return a string containing, "1.3".
        This method is being deprecated. With the addition of multiple deployment descritors in components for J2EE 1.4 this method is being replaced by DDBeanRoot.getDDBeanRootVersion.

      • getDDBeanRoot

        DDBeanRoot getDDBeanRoot(String filename)
                         throws FileNotFoundException,
                                DDBeanCreateException
        Returns a DDBeanRoot object for the XML instance document named. This method should be used to return DDBeanRoot objects for non deployment descriptor XML instance documents such as WSDL files.
        Returns:
        a DDBeanRoot object for the XML data.
        Throws:
        java.io.FileNotFoundException, - if the named file can not be found
        DDBeanCreateException - if an error is encountered creating the DDBeanRoot object.
        FileNotFoundException

      • entries

        Enumeration entries()
        Returns an enumeration of the module file entries. All elements in the enumeration are of type String. Each String represents a file name relative to the root of the module.
        Returns:
        an enumeration of the archive file entries.

      • getEntry

        InputStream getEntry(String name)
        Returns the InputStream for the given entry name The file name must be relative to the root of the module.
        Parameters:
        name - the file name relative to the root of the module.
        Returns:
        the InputStream for the given entry name or null if not found.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


J2eeApplicationObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.model

Interface J2eeApplicationObject

  • All Superinterfaces:
    DeployableObject

    public interface J2eeApplicationObject
extends DeployableObject
    J2eeApplicationObject is an interface that represents a Java EE application (EAR); it maintains a DeployableObject for each module in the archive.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addXpathListener(ModuleType type, String xpath, XpathListener xpl)
      Register a listener for changes in XPath that are related to this deployableObject.
      DDBean[] getChildBean(ModuleType type, String xpath)
      Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.
      DeployableObject getDeployableObject(String uri)
      Return the DeployableObject of the specified URI designator.
      DeployableObject[] getDeployableObjects()
      Return the all DeployableObjects in this application.
      DeployableObject[] getDeployableObjects(ModuleType type)
      Return the all DeployableObjects of the specified type.
      String[] getModuleUris()
      Return the list of URIs for all modules in the application.
      String[] getModuleUris(ModuleType type)
      Return the list of URIs of the designated module type.
      String[] getText(ModuleType type, String xpath)
      Return the text value from the XPath; search only the deployment descriptors of the specified type.
      void removeXpathListener(ModuleType type, String xpath, XpathListener xpl)
      Unregister the listener for an XPath.

      • Methods inherited from interface javax.enterprise.deploy.model.DeployableObject

        entries, getChildBean, getClassFromScope, getDDBeanRoot, getDDBeanRoot, getEntry, getModuleDTDVersion, getText, getType

    • Method Detail

      • getDeployableObject

        DeployableObject getDeployableObject(String uri)
        Return the DeployableObject of the specified URI designator.
        Parameters:
        uri - Describes where to get the module from.
        Returns:
        the DeployableObject describing the j2ee module at this uri or 'null' if there is not match.

      • getDeployableObjects

        DeployableObject[] getDeployableObjects(ModuleType type)
        Return the all DeployableObjects of the specified type.
        Parameters:
        type - The type of module to return.
        Returns:
        the list of DeployableObjects describing the j2ee module at this uri or 'null' if there are no matches.

      • getDeployableObjects

        DeployableObject[] getDeployableObjects()
        Return the all DeployableObjects in this application.
        Returns:
        the DeployableObject describing the j2ee module at this uri or 'null' if there are no matches.

      • getModuleUris

        String[] getModuleUris(ModuleType type)
        Return the list of URIs of the designated module type.
        Parameters:
        type - The type of module to return.
        Returns:
        the Uris of the contained modules or 'null' if there are no matches.

      • getModuleUris

        String[] getModuleUris()
        Return the list of URIs for all modules in the application.
        Returns:
        the Uris of the contained modules or 'null' if there are no matches.

      • getChildBean

        DDBean[] getChildBean(ModuleType type,
                    String xpath)
        Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.
        Parameters:
        type - The type of deployment descriptor to query.
        xpath - An XPath string referring to a location in the deployment descriptor
        Returns:
        The list of DDBeans or 'null' of there are no matches.

      • getText

        String[] getText(ModuleType type,
               String xpath)
        Return the text value from the XPath; search only the deployment descriptors of the specified type.
        Parameters:
        type - The type of deployment descriptor to query.
        xpath - An xpath string referring to a location in the deployment descriptor
        Returns:
        The text values of this xpath or 'null' if there are no matches.

      • addXpathListener

        void addXpathListener(ModuleType type,
                    String xpath,
                    XpathListener xpl)
        Register a listener for changes in XPath that are related to this deployableObject.
        Parameters:
        type - The type of deployment descriptor to query.
        xpath - The xpath to listen for.
        xpl - The listener.

      • removeXpathListener

        void removeXpathListener(ModuleType type,
                       String xpath,
                       XpathListener xpl)
        Unregister the listener for an XPath.
        Parameters:
        type - The type of deployment descriptor to query.
        xpath - he XPath to listen for
        xpl - The listener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.deploy.model (Java(TM) EE 7 Specification APIs)

javax.enterprise.deploy.model

Interfaces

  • DDBean
  • DDBeanRoot
  • DeployableObject
  • J2eeApplicationObject
  • XpathListener

Classes

  • XpathEvent


javax.enterprise.deploy.model (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.deploy.model

Provides Tool Vendor implementation classes.

See: Description

  • Interface Summary
    Interface Description
    DDBean
    An interface for beans that represent a fragment of a standard deployment descriptor.
    DDBeanRoot
    An interface that represents the root of a standard deployment descriptor.
    DeployableObject
    The DeployableObject interface is an abstract representation of a Java EE deployable module (JAR, WAR, RAR, EAR).
    J2eeApplicationObject
    J2eeApplicationObject is an interface that represents a Java EE application (EAR); it maintains a DeployableObject for each module in the archive.
    XpathListener
    The listener interface for receiving XpathEvents
  • Class Summary
    Class Description
    XpathEvent
    An Event class describing ConfigBeans being added/subtracted from a server configuration.

Package javax.enterprise.deploy.model Description

Provides Tool Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.deploy.model Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.deploy.model

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.enterprise.deploy.model.XpathEvent

Interface Hierarchy

  • javax.enterprise.deploy.model.DDBean
    • javax.enterprise.deploy.model.DDBeanRoot
  • javax.enterprise.deploy.model.DeployableObject
    • javax.enterprise.deploy.model.J2eeApplicationObject
  • javax.enterprise.deploy.model.XpathListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.enterprise.deploy.model (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.deploy.model

  • Packages that use javax.enterprise.deploy.model
    Package Description
    javax.enterprise.deploy.model
    Provides Tool Vendor implementation classes.
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.
  • Classes in javax.enterprise.deploy.model used by javax.enterprise.deploy.model
    Class and Description
    DDBean
    An interface for beans that represent a fragment of a standard deployment descriptor.
    DDBeanRoot
    An interface that represents the root of a standard deployment descriptor.
    DeployableObject
    The DeployableObject interface is an abstract representation of a Java EE deployable module (JAR, WAR, RAR, EAR).
    XpathEvent
    An Event class describing ConfigBeans being added/subtracted from a server configuration.
    XpathListener
    The listener interface for receiving XpathEvents
  • Classes in javax.enterprise.deploy.model used by javax.enterprise.deploy.spi
    Class and Description
    DDBean
    An interface for beans that represent a fragment of a standard deployment descriptor.
    DDBeanRoot
    An interface that represents the root of a standard deployment descriptor.
    DeployableObject
    The DeployableObject interface is an abstract representation of a Java EE deployable module (JAR, WAR, RAR, EAR).
    XpathEvent
    An Event class describing ConfigBeans being added/subtracted from a server configuration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


XpathEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.model

Class XpathEvent

  • java.lang.Object
    • javax.enterprise.deploy.model.XpathEvent

  • public final class XpathEvent
extends Object
    An Event class describing ConfigBeans being added/subtracted from a server configuration.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static Object BEAN_ADDED
      Adding a DDBean
      static Object BEAN_CHANGED
      Changing a DDBean
      static Object BEAN_REMOVED
      Removing a DDBean

    • Constructor Summary

      Constructors
      Constructor and Description
      XpathEvent(DDBean bean, Object typ)
      A description of a change in the ConfigBean tree.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      DDBean getBean()
      The bean being added/removed/changed.
      PropertyChangeEvent getChangeEvent()
      boolean isAddEvent()
      Is this an add event?
      boolean isChangeEvent()
      Is this a change event?
      boolean isRemoveEvent()
      Is this a remove event?
      void | setChangeEvent(PropertyChangeEvent pce)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • BEAN_ADDED

        public static final Object BEAN_ADDED
        Adding a DDBean

      • BEAN_REMOVED

        public static final Object BEAN_REMOVED
        Removing a DDBean

      • BEAN_CHANGED

        public static final Object BEAN_CHANGED
        Changing a DDBean

    • Constructor Detail

      • XpathEvent

        public XpathEvent(DDBean bean,
          Object typ)
        A description of a change in the ConfigBean tree.
        Parameters:
        bean - The ConfigBean being added/removed.
        typ - Indicates an add/remove event.

    • Method Detail

      • getChangeEvent

        public PropertyChangeEvent getChangeEvent()

      • setChangeEvent

        public void setChangeEvent(PropertyChangeEvent pce)

      • getBean

        public DDBean getBean()
        The bean being added/removed/changed.
        Returns:
        The bean being added/removed/changed.

      • isAddEvent

        public boolean isAddEvent()
        Is this an add event?
        Returns:
        true if this is an add event.

      • isRemoveEvent

        public boolean isRemoveEvent()
        Is this a remove event?
        Returns:
        true if this is a remove event.

      • isChangeEvent

        public boolean isChangeEvent()
        Is this a change event?
        Returns:
        true if this is a change event.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XpathListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.model

Interface XpathListener

  • public interface XpathListener
    The listener interface for receiving XpathEvents
    Author:
    gfink

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void | fireXpathEvent(XpathEvent xpe)

    • Method Detail

      • fireXpathEvent

        void fireXpathEvent(XpathEvent xpe)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.enterprise.deploy.model.XpathEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.model.XpathEvent

  • Packages that use XpathEvent
    Package Description
    javax.enterprise.deploy.model
    Provides Tool Vendor implementation classes.
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of XpathEvent in javax.enterprise.deploy.model

      Methods in javax.enterprise.deploy.model with parameters of type XpathEvent
      Modifier and Type | Method and Description
      void | XpathListener.fireXpathEvent(XpathEvent xpe)

    • Uses of XpathEvent in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi with parameters of type XpathEvent
      Modifier and Type Method and Description
      void DConfigBean.notifyDDChange(XpathEvent event)
      A notification that the DDBean provided in the event has changed and this bean or its child beans need to reevaluate themselves.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.model.DDBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.model.DDBean

  • Packages that use DDBean
    Package Description
    javax.enterprise.deploy.model
    Provides Tool Vendor implementation classes.
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of DDBean in javax.enterprise.deploy.model

      Subinterfaces of DDBean in javax.enterprise.deploy.model
      Modifier and Type Interface and Description
      interface  DDBeanRoot
      An interface that represents the root of a standard deployment descriptor.
      Methods in javax.enterprise.deploy.model that return DDBean
      Modifier and Type Method and Description
      DDBean XpathEvent.getBean()
      The bean being added/removed/changed.
      DDBean[] J2eeApplicationObject.getChildBean(ModuleType type, String xpath)
      Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.
      DDBean[] DeployableObject.getChildBean(String xpath)
      Return an array of standard beans representing the XML content returned based upon the XPath.
      DDBean[] DDBean.getChildBean(String xpath)
      Return a list of DDBeans based upon the XPath.
      Constructors in javax.enterprise.deploy.model with parameters of type DDBean
      Constructor and Description
      XpathEvent(DDBean bean, Object typ)
      A description of a change in the ConfigBean tree.

    • Uses of DDBean in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that return DDBean
      Modifier and Type Method and Description
      DDBean DConfigBean.getDDBean()
      Return the JavaBean containing the deployment descriptor XML text associated with this DConfigBean.
      Methods in javax.enterprise.deploy.spi with parameters of type DDBean
      Modifier and Type Method and Description
      DConfigBean DConfigBean.getDConfigBean(DDBean bean)
      Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.model.DDBeanRoot (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.model.DDBeanRoot

  • Packages that use DDBeanRoot
    Package Description
    javax.enterprise.deploy.model
    Provides Tool Vendor implementation classes.
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of DDBeanRoot in javax.enterprise.deploy.model

      Methods in javax.enterprise.deploy.model that return DDBeanRoot
      Modifier and Type Method and Description
      DDBeanRoot DeployableObject.getDDBeanRoot()
      Return the top level standard bean representing the root of the deployment descriptor.
      DDBeanRoot DeployableObject.getDDBeanRoot(String filename)
      Returns a DDBeanRoot object for the XML instance document named.
      DDBeanRoot DDBean.getRoot()
      Return the root element for this DDBean.

    • Uses of DDBeanRoot in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi with parameters of type DDBeanRoot
      Modifier and Type Method and Description
      DConfigBean DConfigBeanRoot.getDConfigBean(DDBeanRoot ddBeanRoot)
      Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor.
      DConfigBeanRoot DeploymentConfiguration.getDConfigBeanRoot(DDBeanRoot bean)
      Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.
      DConfigBeanRoot DeploymentConfiguration.restoreDConfigBean(InputStream inputArchive, DDBeanRoot bean)
      Restore from disk to instantated objects all the DConfigBeans associated with a specific deployment descriptor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.model.DeployableObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.model.DeployableObject

  • Packages that use DeployableObject
    Package Description
    javax.enterprise.deploy.model
    Provides Tool Vendor implementation classes.
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of DeployableObject in javax.enterprise.deploy.model

      Subinterfaces of DeployableObject in javax.enterprise.deploy.model
      Modifier and Type Interface and Description
      interface  J2eeApplicationObject
      J2eeApplicationObject is an interface that represents a Java EE application (EAR); it maintains a DeployableObject for each module in the archive.
      Methods in javax.enterprise.deploy.model that return DeployableObject
      Modifier and Type Method and Description
      DeployableObject DDBeanRoot.getDeployableObject()
      Return the containing DeployableObject
      DeployableObject J2eeApplicationObject.getDeployableObject(String uri)
      Return the DeployableObject of the specified URI designator.
      DeployableObject[] J2eeApplicationObject.getDeployableObjects()
      Return the all DeployableObjects in this application.
      DeployableObject[] J2eeApplicationObject.getDeployableObjects(ModuleType type)
      Return the all DeployableObjects of the specified type.

    • Uses of DeployableObject in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that return DeployableObject
      Modifier and Type Method and Description
      DeployableObject DeploymentConfiguration.getDeployableObject()
      Returns an object that provides access to the deployment descriptor data and classes of a Java EE module.
      Methods in javax.enterprise.deploy.spi with parameters of type DeployableObject
      Modifier and Type Method and Description
      DeploymentConfiguration DeploymentManager.createConfiguration(DeployableObject dObj)
      Retrieve the object that provides server-specific deployment configuration information for the Java EE deployable component.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.model.J2eeApplicationObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.model.J2eeApplicationObject

No usage of javax.enterprise.deploy.model.J2eeApplicationObject
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.model.XpathListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.model.XpathListener

  • Packages that use XpathListener
    Package Description
    javax.enterprise.deploy.model
    Provides Tool Vendor implementation classes.

    • Uses of XpathListener in javax.enterprise.deploy.model

      Methods in javax.enterprise.deploy.model with parameters of type XpathListener
      Modifier and Type Method and Description
      void J2eeApplicationObject.addXpathListener(ModuleType type, String xpath, XpathListener xpl)
      Register a listener for changes in XPath that are related to this deployableObject.
      void DDBean.addXpathListener(String xpath, XpathListener xpl)
      Register a listener for a specific XPath.
      void J2eeApplicationObject.removeXpathListener(ModuleType type, String xpath, XpathListener xpl)
      Unregister the listener for an XPath.
      void DDBean.removeXpathListener(String xpath, XpathListener xpl)
      Unregister a listener for a specific XPath.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


DDBeanCreateException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.model.exceptions

Class DDBeanCreateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.enterprise.deploy.model.exceptions.DDBeanCreateException
  • All Implemented Interfaces:
    Serializable

    public class DDBeanCreateException
extends Exception
    This exception reports errors in generating a DDBean.
    Author:
    gfink
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DDBeanCreateException()
      Creates new DDBeanCreateException without detail message.
      DDBeanCreateException(String msg)
      Constructs an DDBeanCreateException with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DDBeanCreateException

        public DDBeanCreateException()
        Creates new DDBeanCreateException without detail message.

      • DDBeanCreateException

        public DDBeanCreateException(String msg)
        Constructs an DDBeanCreateException with the specified detail message.
        Parameters:
        msg - the detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.deploy.model.exceptions (Java(TM) EE 7 Specification APIs)

javax.enterprise.deploy.model.exceptions

Exceptions

  • DDBeanCreateException


javax.enterprise.deploy.model.exceptions (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.deploy.model.exceptions

Provides Tool Vendor exception implementation classes.

See: Description

  • Exception Summary
    Exception Description
    DDBeanCreateException
    This exception reports errors in generating a DDBean.

Package javax.enterprise.deploy.model.exceptions Description

Provides Tool Vendor exception implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.deploy.model.exceptions Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.deploy.model.exceptions

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.enterprise.deploy.model.exceptions.DDBeanCreateException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.enterprise.deploy.model.exceptions (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.deploy.model.exceptions

  • Packages that use javax.enterprise.deploy.model.exceptions
    Package Description
    javax.enterprise.deploy.model
    Provides Tool Vendor implementation classes.
  • Classes in javax.enterprise.deploy.model.exceptions used by javax.enterprise.deploy.model
    Class and Description
    DDBeanCreateException
    This exception reports errors in generating a DDBean.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.model.exceptions.DDBeanCreateException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.model.exceptions.DDBeanCreateException

  • Packages that use DDBeanCreateException
    Package Description
    javax.enterprise.deploy.model
    Provides Tool Vendor implementation classes.

    • Uses of DDBeanCreateException in javax.enterprise.deploy.model

      Methods in javax.enterprise.deploy.model that throw DDBeanCreateException
      Modifier and Type Method and Description
      DDBeanRoot DeployableObject.getDDBeanRoot(String filename)
      Returns a DDBeanRoot object for the XML instance document named.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ActionType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.shared

Class ActionType

  • java.lang.Object
    • javax.enterprise.deploy.shared.ActionType

  • public class ActionType
extends Object
    Class ActionTypes defines enumeration values for the Java EE DeploymentStatus actions.
    Author:
    rsearls

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static ActionType CANCEL
      A cancel operation is being preformed on the DeploymentManager action command.
      static ActionType EXECUTE
      The DeploymentManager action command is executing.
      static ActionType STOP
      A stop operation is being preformed on the DeploymentManager action command.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected ActionType(int value)
      Construct a new enumeration value with the given integer value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ActionType getActionType(int value)
      Return an object of the specified value.
      protected ActionType[] getEnumValueTable()
      Returns the enumeration value table for class ActionType
      protected int getOffset()
      Returns the lowest integer value used by this enumeration value's enumeration class.
      protected String[] getStringTable()
      Returns the string table for class ActionType
      int getValue()
      Returns this enumeration value's integer value.
      String toString()
      Return the string name of this ActionType or the integer value if outside the bounds of the table

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • EXECUTE

        public static final ActionType EXECUTE
        The DeploymentManager action command is executing.

      • CANCEL

        public static final ActionType CANCEL
        A cancel operation is being preformed on the DeploymentManager action command.

      • STOP

        public static final ActionType STOP
        A stop operation is being preformed on the DeploymentManager action command.

    • Constructor Detail

      • ActionType

        protected ActionType(int value)
        Construct a new enumeration value with the given integer value.
        Parameters:
        value - Integer value.

    • Method Detail

      • getValue

        public int getValue()
        Returns this enumeration value's integer value.
        Returns:
        the value

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class ActionType

      • getEnumValueTable

        protected ActionType[] getEnumValueTable()
        Returns the enumeration value table for class ActionType

      • getActionType

        public static ActionType getActionType(int value)
        Return an object of the specified value.
        Parameters:
        value - a designator for the object.

      • toString

        public String toString()
        Return the string name of this ActionType or the integer value if outside the bounds of the table
        Overrides:
        toString in class Object

      • getOffset

        protected int getOffset()
        Returns the lowest integer value used by this enumeration value's enumeration class.

        The default implementation returns 0.

        Returns:
        the offset of the lowest enumeration value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CommandType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.shared

Class CommandType

  • java.lang.Object
    • javax.enterprise.deploy.shared.CommandType

  • public class CommandType
extends Object
    Class CommandTypes defines enumeration values for the DeploymentStatus object.
    Author:
    rsearls

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static CommandType DISTRIBUTE
      The DeploymentManger action operation being processed is distribute.
      static CommandType REDEPLOY
      The DeploymentManger action operation being processed is redeploy.
      static CommandType START
      The DeploymentManger action operation being processed is start.
      static CommandType STOP
      The DeploymentManger action operation being processed is stop.
      static CommandType UNDEPLOY
      The DeploymentManger action operation being processed is undeploy.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected CommandType(int value)
      Construct a new enumeration value with the given integer value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static CommandType getCommandType(int value)
      Return an object of the specified value.
      protected CommandType[] getEnumValueTable()
      Returns the enumeration value table for class CommandType
      protected int getOffset()
      Returns the lowest integer value used by this enumeration value's enumeration class.
      protected String[] getStringTable()
      Returns the string table for class CommandType
      int getValue()
      Returns this enumeration value's integer value.
      String toString()
      Return the string name of this CommandType or the integer value if outside the bounds of the table

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • DISTRIBUTE

        public static final CommandType DISTRIBUTE
        The DeploymentManger action operation being processed is distribute.

      • START

        public static final CommandType START
        The DeploymentManger action operation being processed is start.

      • STOP

        public static final CommandType STOP
        The DeploymentManger action operation being processed is stop.

      • UNDEPLOY

        public static final CommandType UNDEPLOY
        The DeploymentManger action operation being processed is undeploy.

      • REDEPLOY

        public static final CommandType REDEPLOY
        The DeploymentManger action operation being processed is redeploy.

    • Constructor Detail

      • CommandType

        protected CommandType(int value)
        Construct a new enumeration value with the given integer value.
        Parameters:
        value - Integer value.

    • Method Detail

      • getValue

        public int getValue()
        Returns this enumeration value's integer value.
        Returns:
        the value

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class CommandType

      • getEnumValueTable

        protected CommandType[] getEnumValueTable()
        Returns the enumeration value table for class CommandType

      • getCommandType

        public static CommandType getCommandType(int value)
        Return an object of the specified value.
        Parameters:
        value - a designator for the object.

      • toString

        public String toString()
        Return the string name of this CommandType or the integer value if outside the bounds of the table
        Overrides:
        toString in class Object

      • getOffset

        protected int getOffset()
        Returns the lowest integer value used by this enumeration value's enumeration class.

        The default implementation returns 0.

        Returns:
        the offset of the lowest enumeration value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DConfigBeanVersionType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.shared

Class DConfigBeanVersionType

  • java.lang.Object
    • javax.enterprise.deploy.shared.DConfigBeanVersionType

  • public class DConfigBeanVersionType
extends Object
    Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.
    Author:
    rsearls

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static DConfigBeanVersionType V1_3
      J2EE Platform version 1.3
      static DConfigBeanVersionType V1_3_1
      J2EE Platform version 1.3.1 THIS CONSTANT SHOULD NEVER BE USED.
      static DConfigBeanVersionType V1_4
      J2EE Platform version 1.4
      static DConfigBeanVersionType V5
      Java EE Platform version 5

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected DConfigBeanVersionType(int value)
      Construct a new enumeration value with the given integer value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static DConfigBeanVersionType getDConfigBeanVersionType(int value)
      Return an object of the specified value.
      protected DConfigBeanVersionType[] getEnumValueTable()
      Returns the enumeration value table for class DConfigBeanVersionType
      protected int getOffset()
      Returns the lowest integer value used by this enumeration value's enumeration class.
      protected String[] getStringTable()
      Returns the string table for class DConfigBeanVersionType
      int getValue()
      Returns this enumeration value's integer value.
      String toString()
      Return the string name of this DConfigBeanVersionType or the integer value if outside the bounds of the table

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • V1_3

        public static final DConfigBeanVersionType V1_3
        J2EE Platform version 1.3

      • V1_3_1

        public static final DConfigBeanVersionType V1_3_1
        J2EE Platform version 1.3.1 THIS CONSTANT SHOULD NEVER BE USED. Use V1_3 instead.

      • V1_4

        public static final DConfigBeanVersionType V1_4
        J2EE Platform version 1.4

      • V5

        public static final DConfigBeanVersionType V5
        Java EE Platform version 5

    • Constructor Detail

      • DConfigBeanVersionType

        protected DConfigBeanVersionType(int value)
        Construct a new enumeration value with the given integer value.
        Parameters:
        value - Integer value.

    • Method Detail

      • getValue

        public int getValue()
        Returns this enumeration value's integer value.
        Returns:
        the value

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class DConfigBeanVersionType

      • getEnumValueTable

        protected DConfigBeanVersionType[] getEnumValueTable()
        Returns the enumeration value table for class DConfigBeanVersionType

      • getDConfigBeanVersionType

        public static DConfigBeanVersionType getDConfigBeanVersionType(int value)
        Return an object of the specified value.
        Parameters:
        value - a designator for the object.

      • toString

        public String toString()
        Return the string name of this DConfigBeanVersionType or the integer value if outside the bounds of the table
        Overrides:
        toString in class Object

      • getOffset

        protected int getOffset()
        Returns the lowest integer value used by this enumeration value's enumeration class.

        The default implementation returns 0.

        Returns:
        the offset of the lowest enumeration value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.deploy.shared (Java(TM) EE 7 Specification APIs)

javax.enterprise.deploy.shared

Classes

  • ActionType
  • CommandType
  • DConfigBeanVersionType
  • ModuleType
  • StateType


javax.enterprise.deploy.shared (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.deploy.shared

Provides shared objects for Tool Vendor and Product Vendor implementation classes.

See: Description

  • Class Summary
    Class Description
    ActionType
    Class ActionTypes defines enumeration values for the Java EE DeploymentStatus actions.
    CommandType
    Class CommandTypes defines enumeration values for the DeploymentStatus object.
    DConfigBeanVersionType
    Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.
    ModuleType
    Class ModuleTypes defines enumeration values for the Java EE module types.
    StateType
    Class StateTypes defines enumeration values for the DeploymentStatus object.

Package javax.enterprise.deploy.shared Description

Provides shared objects for Tool Vendor and Product Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.deploy.shared Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.deploy.shared

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.enterprise.deploy.shared.ActionType
    • javax.enterprise.deploy.shared.CommandType
    • javax.enterprise.deploy.shared.DConfigBeanVersionType
    • javax.enterprise.deploy.shared.ModuleType
    • javax.enterprise.deploy.shared.StateType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ModuleType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.shared

Class ModuleType

  • java.lang.Object
    • javax.enterprise.deploy.shared.ModuleType

  • public class ModuleType
extends Object
    Class ModuleTypes defines enumeration values for the Java EE module types.
    Author:
    Rebecca Searls

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static ModuleType CAR
      The module is an Client Application archive.
      static ModuleType EAR
      The module is an EAR archive.
      static ModuleType EJB
      The module is an Enterprise Java Bean archive.
      static ModuleType RAR
      The module is an Connector archive.
      static ModuleType WAR
      The module is an Web Application archive.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected ModuleType(int value)
      Construct a new enumeration value with the given integer value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected ModuleType[] getEnumValueTable()
      Returns the enumeration value table for class ModuleType
      String getModuleExtension()
      Return the file extension string for this enumeration.
      static ModuleType getModuleType(int value)
      Return an object of the specified value.
      protected int getOffset()
      Returns the lowest integer value used by this enumeration value's enumeration class.
      protected String[] getStringTable()
      Returns the string table for class ModuleType
      int getValue()
      Returns this enumeration value's integer value.
      String toString()
      Return the string name of this ModuleType or the integer value if outside the bounds of the table

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • EAR

        public static final ModuleType EAR
        The module is an EAR archive.

      • EJB

        public static final ModuleType EJB
        The module is an Enterprise Java Bean archive.

      • CAR

        public static final ModuleType CAR
        The module is an Client Application archive.

      • RAR

        public static final ModuleType RAR
        The module is an Connector archive.

      • WAR

        public static final ModuleType WAR
        The module is an Web Application archive.

    • Constructor Detail

      • ModuleType

        protected ModuleType(int value)
        Construct a new enumeration value with the given integer value.
        Parameters:
        value - Integer value.

    • Method Detail

      • getValue

        public int getValue()
        Returns this enumeration value's integer value.
        Returns:
        the value

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class ModuleType

      • getEnumValueTable

        protected ModuleType[] getEnumValueTable()
        Returns the enumeration value table for class ModuleType

      • getModuleExtension

        public String getModuleExtension()
        Return the file extension string for this enumeration.

      • getModuleType

        public static ModuleType getModuleType(int value)
        Return an object of the specified value.
        Parameters:
        value - a designator for the object.

      • toString

        public String toString()
        Return the string name of this ModuleType or the integer value if outside the bounds of the table
        Overrides:
        toString in class Object

      • getOffset

        protected int getOffset()
        Returns the lowest integer value used by this enumeration value's enumeration class.

        The default implementation returns 0. If the enumeration class (a subclass of class EnumSyntax) uses integer values starting at other than 0, override this method in the subclass.

        Returns:
        the offset of the lowest enumeration value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StateType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.shared

Class StateType

  • java.lang.Object
    • javax.enterprise.deploy.shared.StateType

  • public class StateType
extends Object
    Class StateTypes defines enumeration values for the DeploymentStatus object.
    Author:
    rsearls

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static StateType COMPLETED
      The action operation has completed normally.
      static StateType FAILED
      The action operation has failed.
      static StateType RELEASED
      The DeploymentManager is running in discommected mode.
      static StateType RUNNING
      The action operation is running normally.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected StateType(int value)
      Construct a new enumeration value with the given integer value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected StateType[] getEnumValueTable()
      Returns the enumeration value table for class StateType
      protected int getOffset()
      Returns the lowest integer value used by this enumeration value's enumeration class.
      static StateType getStateType(int value)
      Return an object of the specified value.
      protected String[] getStringTable()
      Returns the string table for class StateType
      int getValue()
      Returns this enumeration value's integer value.
      String toString()
      Return the string name of this StateType or the integer value if outside the bounds of the table

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • RUNNING

        public static final StateType RUNNING
        The action operation is running normally.

      • COMPLETED

        public static final StateType COMPLETED
        The action operation has completed normally.

      • FAILED

        public static final StateType FAILED
        The action operation has failed.

      • RELEASED

        public static final StateType RELEASED
        The DeploymentManager is running in discommected mode.

    • Constructor Detail

      • StateType

        protected StateType(int value)
        Construct a new enumeration value with the given integer value.
        Parameters:
        value - Integer value.

    • Method Detail

      • getValue

        public int getValue()
        Returns this enumeration value's integer value.
        Returns:
        the value

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class StateType

      • getEnumValueTable

        protected StateType[] getEnumValueTable()
        Returns the enumeration value table for class StateType

      • getStateType

        public static StateType getStateType(int value)
        Return an object of the specified value.
        Parameters:
        value - a designator for the object.

      • toString

        public String toString()
        Return the string name of this StateType or the integer value if outside the bounds of the table
        Overrides:
        toString in class Object

      • getOffset

        protected int getOffset()
        Returns the lowest integer value used by this enumeration value's enumeration class.

        The default implementation returns 0.

        Returns:
        the offset of the lowest enumeration value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.enterprise.deploy.shared (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.deploy.shared

  • Packages that use javax.enterprise.deploy.shared
    Package Description
    javax.enterprise.deploy.model
    Provides Tool Vendor implementation classes.
    javax.enterprise.deploy.shared
    Provides shared objects for Tool Vendor and Product Vendor implementation classes.
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.
  • Classes in javax.enterprise.deploy.shared used by javax.enterprise.deploy.model
    Class and Description
    ModuleType
    Class ModuleTypes defines enumeration values for the Java EE module types.
  • Classes in javax.enterprise.deploy.shared used by javax.enterprise.deploy.shared
    Class and Description
    ActionType
    Class ActionTypes defines enumeration values for the Java EE DeploymentStatus actions.
    CommandType
    Class CommandTypes defines enumeration values for the DeploymentStatus object.
    DConfigBeanVersionType
    Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.
    ModuleType
    Class ModuleTypes defines enumeration values for the Java EE module types.
    StateType
    Class StateTypes defines enumeration values for the DeploymentStatus object.
  • Classes in javax.enterprise.deploy.shared used by javax.enterprise.deploy.spi
    Class and Description
    DConfigBeanVersionType
    Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.
    ModuleType
    Class ModuleTypes defines enumeration values for the Java EE module types.
  • Classes in javax.enterprise.deploy.shared used by javax.enterprise.deploy.spi.status
    Class and Description
    ActionType
    Class ActionTypes defines enumeration values for the Java EE DeploymentStatus actions.
    CommandType
    Class CommandTypes defines enumeration values for the DeploymentStatus object.
    StateType
    Class StateTypes defines enumeration values for the DeploymentStatus object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.shared.ActionType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.shared.ActionType

  • Packages that use ActionType
    Package Description
    javax.enterprise.deploy.shared
    Provides shared objects for Tool Vendor and Product Vendor implementation classes.
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.

    • Uses of ActionType in javax.enterprise.deploy.shared

      Fields in javax.enterprise.deploy.shared declared as ActionType
      Modifier and Type Field and Description
      static ActionType ActionType.CANCEL
      A cancel operation is being preformed on the DeploymentManager action command.
      static ActionType ActionType.EXECUTE
      The DeploymentManager action command is executing.
      static ActionType ActionType.STOP
      A stop operation is being preformed on the DeploymentManager action command.
      Methods in javax.enterprise.deploy.shared that return ActionType
      Modifier and Type Method and Description
      static ActionType ActionType.getActionType(int value)
      Return an object of the specified value.
      protected ActionType[] ActionType.getEnumValueTable()
      Returns the enumeration value table for class ActionType

    • Uses of ActionType in javax.enterprise.deploy.spi.status

      Methods in javax.enterprise.deploy.spi.status that return ActionType
      Modifier and Type Method and Description
      ActionType DeploymentStatus.getAction()
      Retrieve the deployment ActionType for this event.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.shared.CommandType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.shared.CommandType

  • Packages that use CommandType
    Package Description
    javax.enterprise.deploy.shared
    Provides shared objects for Tool Vendor and Product Vendor implementation classes.
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.

    • Uses of CommandType in javax.enterprise.deploy.shared

      Fields in javax.enterprise.deploy.shared declared as CommandType
      Modifier and Type Field and Description
      static CommandType CommandType.DISTRIBUTE
      The DeploymentManger action operation being processed is distribute.
      static CommandType CommandType.REDEPLOY
      The DeploymentManger action operation being processed is redeploy.
      static CommandType CommandType.START
      The DeploymentManger action operation being processed is start.
      static CommandType CommandType.STOP
      The DeploymentManger action operation being processed is stop.
      static CommandType CommandType.UNDEPLOY
      The DeploymentManger action operation being processed is undeploy.
      Methods in javax.enterprise.deploy.shared that return CommandType
      Modifier and Type Method and Description
      static CommandType CommandType.getCommandType(int value)
      Return an object of the specified value.
      protected CommandType[] CommandType.getEnumValueTable()
      Returns the enumeration value table for class CommandType

    • Uses of CommandType in javax.enterprise.deploy.spi.status

      Methods in javax.enterprise.deploy.spi.status that return CommandType
      Modifier and Type Method and Description
      CommandType DeploymentStatus.getCommand()
      Retrieve the deployment CommandType of this event.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.shared.DConfigBeanVersionType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.shared.DConfigBeanVersionType

  • Packages that use DConfigBeanVersionType
    Package Description
    javax.enterprise.deploy.shared
    Provides shared objects for Tool Vendor and Product Vendor implementation classes.
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of DConfigBeanVersionType in javax.enterprise.deploy.shared

      Fields in javax.enterprise.deploy.shared declared as DConfigBeanVersionType
      Modifier and Type Field and Description
      static DConfigBeanVersionType DConfigBeanVersionType.V1_3
      J2EE Platform version 1.3
      static DConfigBeanVersionType DConfigBeanVersionType.V1_3_1
      J2EE Platform version 1.3.1 THIS CONSTANT SHOULD NEVER BE USED.
      static DConfigBeanVersionType DConfigBeanVersionType.V1_4
      J2EE Platform version 1.4
      static DConfigBeanVersionType DConfigBeanVersionType.V5
      Java EE Platform version 5
      Methods in javax.enterprise.deploy.shared that return DConfigBeanVersionType
      Modifier and Type Method and Description
      static DConfigBeanVersionType DConfigBeanVersionType.getDConfigBeanVersionType(int value)
      Return an object of the specified value.
      protected DConfigBeanVersionType[] DConfigBeanVersionType.getEnumValueTable()
      Returns the enumeration value table for class DConfigBeanVersionType

    • Uses of DConfigBeanVersionType in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that return DConfigBeanVersionType
      Modifier and Type Method and Description
      DConfigBeanVersionType DeploymentManager.getDConfigBeanVersion()
      Returns the Java EE platform version number for which the configuration beans are provided.
      Methods in javax.enterprise.deploy.spi with parameters of type DConfigBeanVersionType
      Modifier and Type Method and Description
      boolean DeploymentManager.isDConfigBeanVersionSupported(DConfigBeanVersionType version)
      Returns 'true' if the configuration beans support the Java EE platform version specified.
      void DeploymentManager.setDConfigBeanVersion(DConfigBeanVersionType version)
      Set the configuration beans to be used to the Java EE platform version specificed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.shared.ModuleType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.shared.ModuleType

  • Packages that use ModuleType
    Package Description
    javax.enterprise.deploy.model
    Provides Tool Vendor implementation classes.
    javax.enterprise.deploy.shared
    Provides shared objects for Tool Vendor and Product Vendor implementation classes.
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of ModuleType in javax.enterprise.deploy.model

      Methods in javax.enterprise.deploy.model that return ModuleType
      Modifier and Type Method and Description
      ModuleType DeployableObject.getType()
      Return the ModuleType of deployment descriptor (i.e., EAR, JAR, WAR, RAR) this deployable object represents.
      ModuleType DDBeanRoot.getType()
      Return the ModuleType of deployment descriptor.
      Methods in javax.enterprise.deploy.model with parameters of type ModuleType
      Modifier and Type Method and Description
      void J2eeApplicationObject.addXpathListener(ModuleType type, String xpath, XpathListener xpl)
      Register a listener for changes in XPath that are related to this deployableObject.
      DDBean[] J2eeApplicationObject.getChildBean(ModuleType type, String xpath)
      Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.
      DeployableObject[] J2eeApplicationObject.getDeployableObjects(ModuleType type)
      Return the all DeployableObjects of the specified type.
      String[] J2eeApplicationObject.getModuleUris(ModuleType type)
      Return the list of URIs of the designated module type.
      String[] J2eeApplicationObject.getText(ModuleType type, String xpath)
      Return the text value from the XPath; search only the deployment descriptors of the specified type.
      void J2eeApplicationObject.removeXpathListener(ModuleType type, String xpath, XpathListener xpl)
      Unregister the listener for an XPath.

    • Uses of ModuleType in javax.enterprise.deploy.shared

      Fields in javax.enterprise.deploy.shared declared as ModuleType
      Modifier and Type Field and Description
      static ModuleType ModuleType.CAR
      The module is an Client Application archive.
      static ModuleType ModuleType.EAR
      The module is an EAR archive.
      static ModuleType ModuleType.EJB
      The module is an Enterprise Java Bean archive.
      static ModuleType ModuleType.RAR
      The module is an Connector archive.
      static ModuleType ModuleType.WAR
      The module is an Web Application archive.
      Methods in javax.enterprise.deploy.shared that return ModuleType
      Modifier and Type Method and Description
      protected ModuleType[] ModuleType.getEnumValueTable()
      Returns the enumeration value table for class ModuleType
      static ModuleType ModuleType.getModuleType(int value)
      Return an object of the specified value.

    • Uses of ModuleType in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi with parameters of type ModuleType
      Modifier and Type Method and Description
      ProgressObject DeploymentManager.distribute(Target[] targetList, ModuleType type, InputStream moduleArchive, InputStream deploymentPlan)
      The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
      TargetModuleID[] DeploymentManager.getAvailableModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of all Java EE application modules running or not running on the identified targets.
      TargetModuleID[] DeploymentManager.getNonRunningModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of Java EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.
      TargetModuleID[] DeploymentManager.getRunningModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of Java EE application modules distributed to the identified targets and that are currently running on the associated server or servers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.shared.StateType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.shared.StateType

  • Packages that use StateType
    Package Description
    javax.enterprise.deploy.shared
    Provides shared objects for Tool Vendor and Product Vendor implementation classes.
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.

    • Uses of StateType in javax.enterprise.deploy.shared

      Fields in javax.enterprise.deploy.shared declared as StateType
      Modifier and Type Field and Description
      static StateType StateType.COMPLETED
      The action operation has completed normally.
      static StateType StateType.FAILED
      The action operation has failed.
      static StateType StateType.RELEASED
      The DeploymentManager is running in discommected mode.
      static StateType StateType.RUNNING
      The action operation is running normally.
      Methods in javax.enterprise.deploy.shared that return StateType
      Modifier and Type Method and Description
      protected StateType[] StateType.getEnumValueTable()
      Returns the enumeration value table for class StateType
      static StateType StateType.getStateType(int value)
      Return an object of the specified value.

    • Uses of StateType in javax.enterprise.deploy.spi.status

      Methods in javax.enterprise.deploy.spi.status that return StateType
      Modifier and Type Method and Description
      StateType DeploymentStatus.getState()
      Retrieve the StateType value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


DeploymentFactoryManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.shared.factories

Class DeploymentFactoryManager

  • java.lang.Object
    • javax.enterprise.deploy.shared.factories.DeploymentFactoryManager

  • public final class DeploymentFactoryManager
extends Object
    The DeploymentFactoryManager class is a central registry for Java EE DeploymentFactory objects. The DeploymentFactoryManager retains references to DeploymentFactory objects loaded by a tool. A DeploymentFactory object provides a reference to a DeploymentManager. The DeploymentFactoryManager has been implemented as a singleton. A tool gets a reference to the DeploymentFactoryManager via the getInstance method. The DeploymentFactoryManager can return two types of DeploymentManagers, a connected DeploymentManager and a disconnected DeploymentManager. The connected DeploymentManager provides access to any product resources that may be required for configurations and deployment. The method to retrieve a connected DeploymentManager is getDeploymentManager. This method provides parameters for user name and password that the product may require for user authentication. A disconnected DeploymentManager does not provide access to a running Java EE product. The method to retrieve a disconnected DeploymentManager is getDisconnectedDeploymentManager. A disconnected DeploymentManager does not need user authentication information.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      DeploymentFactory[] getDeploymentFactories()
      Retrieve the lists of currently registered DeploymentFactories.
      DeploymentManager getDeploymentManager(String uri, String username, String password)
      Retrieves a DeploymentManager instance to use for deployment.
      DeploymentManager getDisconnectedDeploymentManager(String uri)
      Return a disconnected DeploymentManager instance.
      static DeploymentFactoryManager getInstance()
      Retrieve the Singleton DeploymentFactoryManager
      void registerDeploymentFactory(DeploymentFactory factory)
      Registers a DeploymentFactory so it will be able to handle requests.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • getInstance

        public static DeploymentFactoryManager getInstance()
        Retrieve the Singleton DeploymentFactoryManager
        Returns:
        DeploymentFactoryManager instance

      • getDeploymentFactories

        public DeploymentFactory[] getDeploymentFactories()
        Retrieve the lists of currently registered DeploymentFactories.
        Returns:
        the list of DeploymentFactory objects or an empty array if there are none.

      • getDeploymentManager

        public DeploymentManager getDeploymentManager(String uri,
                                     String username,
                                     String password)
                                       throws DeploymentManagerCreationException
        Retrieves a DeploymentManager instance to use for deployment. The caller provides a URI and optional username and password, and all registered DeploymentFactories will be checked. The first one to understand the URI provided will attempt to initiate a server connection and return a ready DeploymentManager instance.
        Parameters:
        uri - The uri to check
        username - An optional username (may be null if no authentication is required for this platform).
        password - An optional password (may be null if no authentication is required for this platform).
        Returns:
        A ready DeploymentManager instance.
        Throws:
        DeploymentManagerCreationException - Occurs when the factory appropriate to the specified URI was unable to initialize a DeploymentManager instance (server down, unable to authenticate, etc.).

      • registerDeploymentFactory

        public void registerDeploymentFactory(DeploymentFactory factory)
        Registers a DeploymentFactory so it will be able to handle requests.

      • getDisconnectedDeploymentManager

        public DeploymentManager getDisconnectedDeploymentManager(String uri)
                                                   throws DeploymentManagerCreationException
        Return a disconnected DeploymentManager instance.
        Parameters:
        uri - identifier of the disconnected DeploymentManager to return.
        Returns:
        A DeploymentManager instance.
        Throws:
        DeploymentDriverException - occurs if the DeploymentManager could not be created.
        DeploymentManagerCreationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.deploy.shared.factories (Java(TM) EE 7 Specification APIs)

javax.enterprise.deploy.shared.factories

Classes

  • DeploymentFactoryManager


javax.enterprise.deploy.shared.factories (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.deploy.shared.factories

Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.

See: Description

  • Class Summary
    Class Description
    DeploymentFactoryManager
    The DeploymentFactoryManager class is a central registry for Java EE DeploymentFactory objects.

Package javax.enterprise.deploy.shared.factories Description

Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.deploy.shared.factories Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.deploy.shared.factories

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.enterprise.deploy.shared.factories (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.deploy.shared.factories

  • Packages that use javax.enterprise.deploy.shared.factories
    Package Description
    javax.enterprise.deploy.shared.factories
    Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
  • Classes in javax.enterprise.deploy.shared.factories used by javax.enterprise.deploy.shared.factories
    Class and Description
    DeploymentFactoryManager
    The DeploymentFactoryManager class is a central registry for Java EE DeploymentFactory objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.shared.factories.DeploymentFactoryManager

  • Packages that use DeploymentFactoryManager
    Package Description
    javax.enterprise.deploy.shared.factories
    Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.

    • Uses of DeploymentFactoryManager in javax.enterprise.deploy.shared.factories

      Methods in javax.enterprise.deploy.shared.factories that return DeploymentFactoryManager
      Modifier and Type Method and Description
      static DeploymentFactoryManager DeploymentFactoryManager.getInstance()
      Retrieve the Singleton DeploymentFactoryManager
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


DConfigBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi

Interface DConfigBean

  • All Known Subinterfaces:
    DConfigBeanRoot

    public interface DConfigBean
    The DConfigBean is a deployment configuration bean (DConfigBean) that is associated with one or more deployment descriptor beans, (DDBean). A DConfigBean represents a logical grouping of deployment configuration data to be presented to the Deployer. A DConfigBean provides zero or more XPaths that identifies the XML information it requires. A DConfigBean may contain other DConfigBeans and regular JavaBeans. The top most DConfigBean is a DConfigBeanRoot object which represents a single XML instance document.

    A DConfigBean is created by calling DConfigBean.getDConfigBean(DDBean) method, where DConfigBean is the object that provided the XPath which the DDBean represents.

    A DConfigBean is a JavaBean component that presents the dynamic deployment configuration information for a Java EE plugin to the deployer. It is a JavaBean. The JavaBean architecture was chosen because of its versatility in providing both simple and complex components. JavaBeans also enable the development of property sheets and property editors, as well as sophisticated customization wizards.

    It is expected that a plugin vendor will provide a Property Editor for any complex datatype in a DConfigBean that a deployer needs to edit through a property sheet. The Property Editor should be implemented and made available to a tool according to the guidelines defined in the JavaBeans API Specification version 1.01.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addPropertyChangeListener(PropertyChangeListener pcl)
      Register a property listener for this bean.
      DConfigBean getDConfigBean(DDBean bean)
      Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.
      DDBean getDDBean()
      Return the JavaBean containing the deployment descriptor XML text associated with this DConfigBean.
      String[] getXpaths()
      Return a list of XPaths designating the deployment descriptor information this DConfigBean requires.
      void notifyDDChange(XpathEvent event)
      A notification that the DDBean provided in the event has changed and this bean or its child beans need to reevaluate themselves.
      void removeDConfigBean(DConfigBean bean)
      Remove a child DConfigBean from this bean.
      void removePropertyChangeListener(PropertyChangeListener pcl)
      Unregister a property listener for this bean.

    • Method Detail

      • getDDBean

        DDBean getDDBean()
        Return the JavaBean containing the deployment descriptor XML text associated with this DConfigBean.
        Returns:
        The bean class containing the XML text for this DConfigBean.

      • getXpaths

        String[] getXpaths()
        Return a list of XPaths designating the deployment descriptor information this DConfigBean requires. A given server vendor will need to specify some server-specific information. Each String returned by this method is an XPath describing a certain portion of the standard deployment descriptor for which there is corresponding server-specific configuration.
        Returns:
        a list of XPath Strings representing XML data to be retrieved or 'null' if there are none.

      • getDConfigBean

        DConfigBean getDConfigBean(DDBean bean)
                           throws ConfigurationException
        Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.
        Parameters:
        bean - The DDBean containing the XML data to be evaluated.
        Returns:
        The DConfigBean to display the server-specific properties for the standard bean.
        Throws:
        ConfigurationException - reports errors in generating a configuration bean. This DDBean is considered undeployable to this server until this exception is resolved. A suitably descriptive message is required so the user can diagnose the error.

      • removeDConfigBean

        void removeDConfigBean(DConfigBean bean)
                       throws BeanNotFoundException
        Remove a child DConfigBean from this bean.
        Parameters:
        bean - The child DConfigBean to be removed.
        Throws:
        BeanNotFoundException - the bean provided is not in the child list of this bean.

      • notifyDDChange

        void notifyDDChange(XpathEvent event)
        A notification that the DDBean provided in the event has changed and this bean or its child beans need to reevaluate themselves.
        Parameters:
        event - an event containing a reference to the DDBean which has changed.

      • addPropertyChangeListener

        void addPropertyChangeListener(PropertyChangeListener pcl)
        Register a property listener for this bean.
        Parameters:
        pcl - PropertyChangeListener to add

      • removePropertyChangeListener

        void removePropertyChangeListener(PropertyChangeListener pcl)
        Unregister a property listener for this bean.
        Parameters:
        pcl - Listener to remove.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DConfigBeanRoot (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi

Interface DConfigBeanRoot

  • All Superinterfaces:
    DConfigBean

    public interface DConfigBeanRoot
extends DConfigBean
    A Java EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents. A module must contain a component-specific deployment descriptor file (see the component specification for details). It may contain one or more secondary deployment descriptor files that define extra functionality on the component and zero or more non-deployment descriptor XML instance documents (see the Web Services specification).

    The DConfigBeanRoot object is a deployment configuration bean (DConfigBean) that is associated with the root of the component's deployment descriptor. It must be created by calling the DeploymentConfiguration.getDConfigBean(DDBeanRoot) method, where DDBeanRoot represents the component's deployment descriptor.

    A DConfigBean object is associated with a deployment descriptor that extends a component's functionality. It must be created by calling the DConfigBeanRoot.getDConfigBean(DDBeanRoot) method. This DConfigBean object is a child of the compontent's DConfigBeanRoot object. The DDBeanRoot argument represents the secondary deployment descriptor. Deployment descriptor files such as webservice.xml and webserviceclient.xml are examples of secondary deployment descriptor files.

    The server plugin must request a DDBeanRoot object for any non-deployment descriptor XML instance document data it requires. The plugin must call method DeployableObject.getDDBeanRoot(String) where String is the full path name from the root of the module to the file to be represented. A WSDL file is an example of a non-deployment descriptor XML instance document.

    Author:
    gfink

    • Method Summary

      Methods
      Modifier and Type Method and Description
      DConfigBean getDConfigBean(DDBeanRoot ddBeanRoot)
      Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor.

      • Methods inherited from interface javax.enterprise.deploy.spi.DConfigBean

        addPropertyChangeListener, getDConfigBean, getDDBean, getXpaths, notifyDDChange, removeDConfigBean, removePropertyChangeListener

    • Method Detail

      • getDConfigBean

        DConfigBean getDConfigBean(DDBeanRoot ddBeanRoot)
        Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor. Web services provides a deployment descriptor in addition to the module's primary deployment descriptor. Only the DDBeanRoot for this catagory of secondary deployment descriptors are to be passed as arguments through this method. Web service has two deployment descriptor files, one that defines the web service and one that defines a client of a web service. See the Web Service specificiation for the details.
        Parameters:
        ddBeanRoot - represents the root element of a deployment descriptor file.
        Returns:
        a DConfigBean to be used for processing this deployment descriptor data. Null may be returned if no DConfigBean is required for this deployment descriptor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeploymentConfiguration (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi

Interface DeploymentConfiguration

  • public interface DeploymentConfiguration
    An interface that defines a container for all the server-specific configuration information for a single top-level Java EE module. The DeploymentConfiguration object could represent a single stand alone module or an EAR file that contains several sub-modules.
    Version:
    0.1
    Author:
    gfink

    • Method Summary

      Methods
      Modifier and Type Method and Description
      DConfigBeanRoot getDConfigBeanRoot(DDBeanRoot bean)
      Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.
      DeployableObject getDeployableObject()
      Returns an object that provides access to the deployment descriptor data and classes of a Java EE module.
      void removeDConfigBean(DConfigBeanRoot bean)
      Remove the root DConfigBean and all its children.
      void restore(InputStream inputArchive)
      Restore from disk to a full set of configuration beans previously stored.
      DConfigBeanRoot restoreDConfigBean(InputStream inputArchive, DDBeanRoot bean)
      Restore from disk to instantated objects all the DConfigBeans associated with a specific deployment descriptor.
      void save(OutputStream outputArchive)
      Save to disk the current set configuration beans created for this deployable module.
      void saveDConfigBean(OutputStream outputArchive, DConfigBeanRoot bean)
      Save to disk all the configuration beans associated with a particular deployment descriptor file.

    • Method Detail

      • getDeployableObject

        DeployableObject getDeployableObject()
        Returns an object that provides access to the deployment descriptor data and classes of a Java EE module.
        Returns:
        DeployableObject

      • getDConfigBeanRoot

        DConfigBeanRoot getDConfigBeanRoot(DDBeanRoot bean)
                                   throws ConfigurationException
        Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.
        Parameters:
        bean - The top level bean that represents the associated deployment descriptor.
        Returns:
        the DConfigBeanRoot for editing the server-specific properties required by the module.
        Throws:
        ConfigurationException - reports errors in generating a configuration bean

      • removeDConfigBean

        void removeDConfigBean(DConfigBeanRoot bean)
                       throws BeanNotFoundException
        Remove the root DConfigBean and all its children.
        Parameters:
        bean - the top leve DConfigBean to remove.
        Throws:
        BeanNotFoundException - the bean provides is not in this beans child list.

      • restoreDConfigBean

        DConfigBeanRoot restoreDConfigBean(InputStream inputArchive,
                                 DDBeanRoot bean)
                                   throws ConfigurationException
        Restore from disk to instantated objects all the DConfigBeans associated with a specific deployment descriptor. The beans may be fully or partially configured.
        Parameters:
        inputArchive - The input stream for the file from which the DConfigBeans should be restored.
        bean - The DDBeanRoot bean associated with the deployment descriptor file.
        Returns:
        The top most parent configuration bean, DConfigBeanRoot
        Throws:
        ConfigurationException - reports errors in generating a configuration bean

      • saveDConfigBean

        void saveDConfigBean(OutputStream outputArchive,
                   DConfigBeanRoot bean)
                     throws ConfigurationException
        Save to disk all the configuration beans associated with a particular deployment descriptor file. The saved data may be fully or partially configured DConfigBeans. The output file format is recommended to be XML.
        Parameters:
        outputArchive - The output stream to which the DConfigBeans should be saved.
        bean - The top level bean, DConfigBeanRoot, from which to be save.
        Throws:
        ConfigurationException - reports errors in generating a configuration bean

      • restore

        void restore(InputStream inputArchive)
             throws ConfigurationException
        Restore from disk to a full set of configuration beans previously stored.
        Parameters:
        inputArchive - The input stream from which to restore the Configuration.
        Throws:
        ConfigurationException - reports errors in generating a configuration bean

      • save

        void save(OutputStream outputArchive)
          throws ConfigurationException
        Save to disk the current set configuration beans created for this deployable module. It is recommended the file format be XML.
        Parameters:
        outputArchive - The output stream to which to save the Configuration.
        Throws:
        ConfigurationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeploymentManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi

Interface DeploymentManager

  • public interface DeploymentManager
    The DeploymentManager object provides the core set of functions a Java EE platform must provide for Java EE application deployment. It provides server related information, such as, a list of deployment targets, and vendor unique runtime configuration information.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      DeploymentConfiguration createConfiguration(DeployableObject dObj)
      Retrieve the object that provides server-specific deployment configuration information for the Java EE deployable component.
      ProgressObject distribute(Target[] targetList, File moduleArchive, File deploymentPlan)
      The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
      ProgressObject distribute(Target[] targetList, InputStream moduleArchive, InputStream deploymentPlan)
      Deprecated.
      as of Java EE 5, replaced with distribute(Target[], ModuleType, InputStream, InputStream)
      ProgressObject distribute(Target[] targetList, ModuleType type, InputStream moduleArchive, InputStream deploymentPlan)
      The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
      TargetModuleID[] getAvailableModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of all Java EE application modules running or not running on the identified targets.
      Locale getCurrentLocale()
      Returns the active locale this implementation of javax.enterprise.deploy.spi subpackages is running.
      DConfigBeanVersionType getDConfigBeanVersion()
      Returns the Java EE platform version number for which the configuration beans are provided.
      Locale getDefaultLocale()
      Returns the default locale supported by this implementation of javax.enterprise.deploy.spi subpackages.
      TargetModuleID[] getNonRunningModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of Java EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.
      TargetModuleID[] getRunningModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of Java EE application modules distributed to the identified targets and that are currently running on the associated server or servers.
      Locale[] getSupportedLocales()
      Returns an array of supported locales for this implementation.
      Target[] getTargets()
      Retrieve the list of deployment targets supported by this DeploymentManager.
      boolean isDConfigBeanVersionSupported(DConfigBeanVersionType version)
      Returns 'true' if the configuration beans support the Java EE platform version specified.
      boolean isLocaleSupported(Locale locale)
      Reports if this implementation supports the designated locale.
      boolean isRedeploySupported()
      This method designates whether this platform vendor provides application redeployment functionality.
      ProgressObject redeploy(TargetModuleID[] moduleIDList, File moduleArchive, File deploymentPlan)
      (optional) The redeploy method provides a means for updating currently deployed Java EE applications.
      ProgressObject redeploy(TargetModuleID[] moduleIDList, InputStream moduleArchive, InputStream deploymentPlan)
      (optional) The redeploy method provides a means for updating currently deployed Java EE applications.
      void release()
      The release method is the mechanism by which the tool signals to the DeploymentManager that the tool does not need it to continue running connected to the platform.
      void setDConfigBeanVersion(DConfigBeanVersionType version)
      Set the configuration beans to be used to the Java EE platform version specificed.
      void setLocale(Locale locale)
      Set the active locale for this implementation of javax.enterprise.deploy.spi subpackages to run.
      ProgressObject start(TargetModuleID[] moduleIDList)
      Start the application running.
      ProgressObject stop(TargetModuleID[] moduleIDList)
      Stop the application running.
      ProgressObject undeploy(TargetModuleID[] moduleIDList)
      Remove the application from the target server.

    • Method Detail

      • getTargets

        Target[] getTargets()
                    throws IllegalStateException
        Retrieve the list of deployment targets supported by this DeploymentManager.
        Returns:
        A list of deployment Target designators the user may select for application deployment or 'null' if there are none.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.

      • getRunningModules

        TargetModuleID[] getRunningModules(ModuleType moduleType,
                                 Target[] targetList)
                                   throws TargetException,
                                          IllegalStateException
        Retrieve the list of Java EE application modules distributed to the identified targets and that are currently running on the associated server or servers.
        Parameters:
        moduleType - A predefined designator for a Java EE module type.
        targetList - A list of deployment Target designators the user wants checked for module run status.
        Returns:
        An array of TargetModuleID objects representing the running modules or 'null' if there are none.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.
        TargetException - An invalid Target designator encountered.

      • getNonRunningModules

        TargetModuleID[] getNonRunningModules(ModuleType moduleType,
                                    Target[] targetList)
                                      throws TargetException,
                                             IllegalStateException
        Retrieve the list of Java EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.
        Parameters:
        moduleType - A predefined designator for a Java EE module type.
        targetList - A list of deployment Target designators the user wants checked for module not running status.
        Returns:
        An array of TargetModuleID objects representing the non-running modules or 'null' if there are none.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.
        TargetException - An invalid Target designator encountered.

      • getAvailableModules

        TargetModuleID[] getAvailableModules(ModuleType moduleType,
                                   Target[] targetList)
                                     throws TargetException,
                                            IllegalStateException
        Retrieve the list of all Java EE application modules running or not running on the identified targets.
        Parameters:
        moduleType - A predefined designator for a Java EE module type.
        targetList - A list of deployment Target designators the user wants checked for module not running status.
        Returns:
        An array of TargetModuleID objects representing all deployed modules running or not or 'null' if there are no deployed modules.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.
        TargetException - An invalid Target designator encountered.

      • createConfiguration

        DeploymentConfiguration createConfiguration(DeployableObject dObj)
                                            throws InvalidModuleException
        Retrieve the object that provides server-specific deployment configuration information for the Java EE deployable component.
        Parameters:
        dObj - An object representing a Java EE deployable component.
        Throws:
        InvalidModuleException - The DeployableObject is an unknown or unsupport component for this configuration tool.

      • distribute

        ProgressObject distribute(Target[] targetList,
                        File moduleArchive,
                        File deploymentPlan)
                          throws IllegalStateException
        The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
        Parameters:
        targetList - A list of server targets the user is specifying this application be deployed to.
        moduleArchive - The file name of the application archive to be disrtibuted.
        deploymentPlan - The XML file containing the runtime configuration information associated with this application archive.
        Returns:
        ProgressObject an object that tracks and reports the status of the distribution process.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.

      • distribute

        ProgressObject distribute(Target[] targetList,
                        InputStream moduleArchive,
                        InputStream deploymentPlan)
                          throws IllegalStateException
        Deprecated. as of Java EE 5, replaced with distribute(Target[], ModuleType, InputStream, InputStream)
        The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
        Parameters:
        targetList - A list of server targets the user is specifying this application be deployed to.
        moduleArchive - The input stream containing the application archive to be disrtibuted.
        deploymentPlan - The input stream containing the deployment configuration information associated with this application archive.
        Returns:
        ProgressObject an object that tracks and reports the status of the distribution process.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.

      • distribute

        ProgressObject distribute(Target[] targetList,
                        ModuleType type,
                        InputStream moduleArchive,
                        InputStream deploymentPlan)
                          throws IllegalStateException
        The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
        Parameters:
        targetList - A list of server targets the user is specifying this application be deployed to.
        moduleType - The module type of this application archive.
        moduleArchive - The input stream containing the application archive to be disrtibuted.
        deploymentPlan - The input stream containing the deployment configuration information associated with this application archive.
        Returns:
        ProgressObject an object that tracks and reports the status of the distribution process.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.

      • start

        ProgressObject start(TargetModuleID[] moduleIDList)
                     throws IllegalStateException
        Start the application running.

        Only the TargetModuleIDs which represent a root module are valid for being started. A root TargetModuleID has no parent. A TargetModuleID with a parent can not be individually started. A root TargetModuleID module and all its child modules will be started.

        Parameters:
        moduleIDList - A array of TargetModuleID objects representing the modules to be started.
        Returns:
        ProgressObject an object that tracks and reports the status of the start operation.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.

      • stop

        ProgressObject stop(TargetModuleID[] moduleIDList)
                    throws IllegalStateException
        Stop the application running.

        Only the TargetModuleIDs which represent a root module are valid for being stopped. A root TargetModuleID has no parent. A TargetModuleID with a parent can not be individually stopped. A root TargetModuleID module and all its child modules will be stopped.

        Parameters:
        moduleIDList - A array of TargetModuleID objects representing the modules to be stopped.
        Returns:
        ProgressObject an object that tracks and reports the status of the stop operation.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.

      • undeploy

        ProgressObject undeploy(TargetModuleID[] moduleIDList)
                        throws IllegalStateException
        Remove the application from the target server.

        Only the TargetModuleIDs which represent a root module are valid for undeployment. A root TargetModuleID has no parent. A TargetModuleID with a parent can not be undeployed. A root TargetModuleID module and all its child modules will be undeployed. The root TargetModuleID module and all its child modules must stopped before they can be undeployed.

        Parameters:
        moduleIDList - An array of TargetModuleID objects representing the root modules to be stopped.
        Returns:
        ProgressObject an object that tracks and reports the status of the stop operation.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.

      • isRedeploySupported

        boolean isRedeploySupported()
        This method designates whether this platform vendor provides application redeployment functionality. A value of true means it is supported. False means it is not.
        Returns:
        A value of true means redeployment is supported by this vendor's DeploymentManager. False means it is not.

      • redeploy

        ProgressObject redeploy(TargetModuleID[] moduleIDList,
                      File moduleArchive,
                      File deploymentPlan)
                        throws UnsupportedOperationException,
                               IllegalStateException
        (optional) The redeploy method provides a means for updating currently deployed Java EE applications. This is an optional method for vendor implementation. Redeploy replaces a currently deployed application with an updated version. The runtime configuration information for the updated application must remain identical to the application it is updating. When an application update is redeployed, all existing client connections to the original running application must not be disrupted; new clients will connect to the application update. This operation is valid for TargetModuleIDs that represent a root module. A root TargetModuleID has no parent. A root TargetModuleID module and all its child modules will be redeployed. A child TargetModuleID module cannot be individually redeployed. The redeploy operation is complete only when this action for all the modules has completed.
        Parameters:
        moduleIDList - An array of designators of the applications to be updated.
        moduleArchive - The file name of the application archive to be disrtibuted.
        deploymentPlan - The deployment configuration information associated with this application archive.
        Returns:
        ProgressObject an object that tracks and reports the status of the redeploy operation.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.
        UnsupportedOperationException - this optional command is not supported by this implementation.

      • redeploy

        ProgressObject redeploy(TargetModuleID[] moduleIDList,
                      InputStream moduleArchive,
                      InputStream deploymentPlan)
                        throws UnsupportedOperationException,
                               IllegalStateException
        (optional) The redeploy method provides a means for updating currently deployed Java EE applications. This is an optional method for vendor implementation. Redeploy replaces a currently deployed application with an updated version. The runtime configuration information for the updated application must remain identical to the application it is updating. When an application update is redeployed, all existing client connections to the original running application must not be disrupted; new clients will connect to the application update. This operation is valid for TargetModuleIDs that represent a root module. A root TargetModuleID has no parent. A root TargetModuleID module and all its child modules will be redeployed. A child TargetModuleID module cannot be individually redeployed. The redeploy operation is complete only when this action for all the modules has completed.
        Parameters:
        moduleIDList - An array of designators of the applications to be updated.
        moduleArchive - The input stream containing the application archive to be disrtibuted.
        deploymentPlan - The input stream containing the runtime configuration information associated with this application archive.
        Returns:
        ProgressObject an object that tracks and reports the status of the redeploy operation.
        Throws:
        IllegalStateException - is thrown when the method is called when running in disconnected mode.
        UnsupportedOperationException - this optional command is not supported by this implementation.

      • release

        void release()
        The release method is the mechanism by which the tool signals to the DeploymentManager that the tool does not need it to continue running connected to the platform. The tool may be signaling it wants to run in a disconnected mode or it is planning to shutdown. When release is called the DeploymentManager may close any Java EE resource connections it had for deployment configuration and perform other related resource cleanup. It should not accept any new operation requests (i.e., distribute, start stop, undeploy, redeploy. It should finish any operations that are currently in process. Each ProgressObject associated with a running operation should be marked as released (see the ProgressObject).

      • getDefaultLocale

        Locale getDefaultLocale()
        Returns the default locale supported by this implementation of javax.enterprise.deploy.spi subpackages.
        Returns:
        Locale the default locale for this implementation.

      • getCurrentLocale

        Locale getCurrentLocale()
        Returns the active locale this implementation of javax.enterprise.deploy.spi subpackages is running.
        Returns:
        Locale the active locale of this implementation.

      • setLocale

        void setLocale(Locale locale)
               throws UnsupportedOperationException
        Set the active locale for this implementation of javax.enterprise.deploy.spi subpackages to run.
        Throws:
        UnsupportedOperationException - the provide locale is not supported.

      • getSupportedLocales

        Locale[] getSupportedLocales()
        Returns an array of supported locales for this implementation.
        Returns:
        Locale[] the list of supported locales.

      • isLocaleSupported

        boolean isLocaleSupported(Locale locale)
        Reports if this implementation supports the designated locale.
        Returns:
        A value of 'true' means it is support and 'false' it is not.

      • getDConfigBeanVersion

        DConfigBeanVersionType getDConfigBeanVersion()
        Returns the Java EE platform version number for which the configuration beans are provided. The beans must have been compiled with the J2SE version required by the Java EE platform.
        Returns:
        a DConfigBeanVersionType object representing the platform version number for which these beans are provided.

      • isDConfigBeanVersionSupported

        boolean isDConfigBeanVersionSupported(DConfigBeanVersionType version)
        Returns 'true' if the configuration beans support the Java EE platform version specified. It returns 'false' if the version is not supported.
        Parameters:
        version - a DConfigBeanVersionType object representing the Java EE platform version for which support is requested.
        Returns:
        'true' if the version is supported and 'false if not.

      • setDConfigBeanVersion

        void setDConfigBeanVersion(DConfigBeanVersionType version)
                           throws DConfigBeanVersionUnsupportedException
        Set the configuration beans to be used to the Java EE platform version specificed.
        Parameters:
        version - a DConfigBeanVersionType object representing the Java EE platform version for which support is requested.
        Throws:
        DConfigBeanVersionUnsupportedException - when the requested bean version is not supported.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.deploy.spi (Java(TM) EE 7 Specification APIs)

javax.enterprise.deploy.spi

Interfaces

  • DConfigBean
  • DConfigBeanRoot
  • DeploymentConfiguration
  • DeploymentManager
  • Target
  • TargetModuleID


javax.enterprise.deploy.spi (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.deploy.spi

Provides J2EE Product Vendor implementation classes.

See: Description

  • Interface Summary
    Interface Description
    DConfigBean
    The DConfigBean is a deployment configuration bean (DConfigBean) that is associated with one or more deployment descriptor beans, (DDBean).
    DConfigBeanRoot
    A Java EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents.
    DeploymentConfiguration
    An interface that defines a container for all the server-specific configuration information for a single top-level Java EE module.
    DeploymentManager
    The DeploymentManager object provides the core set of functions a Java EE platform must provide for Java EE application deployment.
    Target
    A Target interface represents a single logical core server of one instance of a Java EE platform product.
    TargetModuleID
    A TargetModuleID interface represents a unique identifier for a deployed application module.

Package javax.enterprise.deploy.spi Description

Provides J2EE Product Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.deploy.spi Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.deploy.spi

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.enterprise.deploy.spi.DConfigBean
    • javax.enterprise.deploy.spi.DConfigBeanRoot
  • javax.enterprise.deploy.spi.DeploymentConfiguration
  • javax.enterprise.deploy.spi.DeploymentManager
  • javax.enterprise.deploy.spi.Target
  • javax.enterprise.deploy.spi.TargetModuleID
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Target (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi

Interface Target

  • public interface Target
    A Target interface represents a single logical core server of one instance of a Java EE platform product. It is a designator for a server and the implied location to copy a configured application for the server to access.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDescription()
      Retrieve other descriptive information about the target.
      String getName()
      Retrieve the name of the target server.

    • Method Detail

      • getName

        String getName()
        Retrieve the name of the target server.

      • getDescription

        String getDescription()
        Retrieve other descriptive information about the target.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TargetModuleID (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi

Interface TargetModuleID

  • public interface TargetModuleID
    A TargetModuleID interface represents a unique identifier for a deployed application module. A deployable application module can be an EAR, JAR, WAR or RAR file. A TargetModuleID can represent a root module or a child module. A root module TargetModuleID has no parent. It represents a deployed EAR file or stand alone module. A child module TargetModuleID represents a deployed sub module of a Java EE application. A child TargetModuleID has only one parent, the super module it was bundled and deployed with. The identifier consists of the target name and the unique identifier for the deployed application module.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      TargetModuleID[] getChildTargetModuleID()
      Retrieve a list of identifiers of the children of this deployed module.
      String getModuleID()
      Retrieve the id assigned to represent the deployed module.
      TargetModuleID getParentTargetModuleID()
      Retrieve the identifier of the parent object of this deployed module.
      Target getTarget()
      Retrieve the name of the target server.
      String getWebURL()
      If this TargetModulID represents a web module retrieve the URL for it.
      String toString()
      Retrieve the identifier representing the deployed module.

    • Method Detail

      • getTarget

        Target getTarget()
        Retrieve the name of the target server. this module was deployed to.
        Returns:
        Target an object representing a server target.

      • getModuleID

        String getModuleID()
        Retrieve the id assigned to represent the deployed module.

      • getWebURL

        String getWebURL()
        If this TargetModulID represents a web module retrieve the URL for it.
        Returns:
        the URL of a web module or null if the module is not a web module.

      • toString

        String toString()
        Retrieve the identifier representing the deployed module.
        Overrides:
        toString in class Object

      • getParentTargetModuleID

        TargetModuleID getParentTargetModuleID()
        Retrieve the identifier of the parent object of this deployed module. If there is no parent then this is the root object deployed. The root could represent an EAR file or it could be a stand alone module that was deployed.
        Returns:
        the TargetModuleID of the parent of this object. A null value means this module is the root object deployed.

      • getChildTargetModuleID

        TargetModuleID[] getChildTargetModuleID()
        Retrieve a list of identifiers of the children of this deployed module.
        Returns:
        a list of TargetModuleIDs identifying the childern of this object. A null value means this module has no childern
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.enterprise.deploy.spi (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.deploy.spi

  • Packages that use javax.enterprise.deploy.spi
    Package Description
    javax.enterprise.deploy.shared.factories
    Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.
    javax.enterprise.deploy.spi.factories
    Provides J2EE Product Vendor deployment factory implementation classes.
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.
  • Classes in javax.enterprise.deploy.spi used by javax.enterprise.deploy.shared.factories
    Class and Description
    DeploymentManager
    The DeploymentManager object provides the core set of functions a Java EE platform must provide for Java EE application deployment.
  • Classes in javax.enterprise.deploy.spi used by javax.enterprise.deploy.spi
    Class and Description
    DConfigBean
    The DConfigBean is a deployment configuration bean (DConfigBean) that is associated with one or more deployment descriptor beans, (DDBean).
    DConfigBeanRoot
    A Java EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents.
    DeploymentConfiguration
    An interface that defines a container for all the server-specific configuration information for a single top-level Java EE module.
    Target
    A Target interface represents a single logical core server of one instance of a Java EE platform product.
    TargetModuleID
    A TargetModuleID interface represents a unique identifier for a deployed application module.
  • Classes in javax.enterprise.deploy.spi used by javax.enterprise.deploy.spi.factories
    Class and Description
    DeploymentManager
    The DeploymentManager object provides the core set of functions a Java EE platform must provide for Java EE application deployment.
  • Classes in javax.enterprise.deploy.spi used by javax.enterprise.deploy.spi.status
    Class and Description
    TargetModuleID
    A TargetModuleID interface represents a unique identifier for a deployed application module.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.DConfigBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.DConfigBean

  • Packages that use DConfigBean
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of DConfigBean in javax.enterprise.deploy.spi

      Subinterfaces of DConfigBean in javax.enterprise.deploy.spi
      Modifier and Type Interface and Description
      interface  DConfigBeanRoot
      A Java EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents.
      Methods in javax.enterprise.deploy.spi that return DConfigBean
      Modifier and Type Method and Description
      DConfigBean DConfigBean.getDConfigBean(DDBean bean)
      Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.
      DConfigBean DConfigBeanRoot.getDConfigBean(DDBeanRoot ddBeanRoot)
      Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor.
      Methods in javax.enterprise.deploy.spi with parameters of type DConfigBean
      Modifier and Type Method and Description
      void DConfigBean.removeDConfigBean(DConfigBean bean)
      Remove a child DConfigBean from this bean.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.DConfigBeanRoot (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.DConfigBeanRoot

  • Packages that use DConfigBeanRoot
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of DConfigBeanRoot in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that return DConfigBeanRoot
      Modifier and Type Method and Description
      DConfigBeanRoot DeploymentConfiguration.getDConfigBeanRoot(DDBeanRoot bean)
      Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.
      DConfigBeanRoot DeploymentConfiguration.restoreDConfigBean(InputStream inputArchive, DDBeanRoot bean)
      Restore from disk to instantated objects all the DConfigBeans associated with a specific deployment descriptor.
      Methods in javax.enterprise.deploy.spi with parameters of type DConfigBeanRoot
      Modifier and Type Method and Description
      void DeploymentConfiguration.removeDConfigBean(DConfigBeanRoot bean)
      Remove the root DConfigBean and all its children.
      void DeploymentConfiguration.saveDConfigBean(OutputStream outputArchive, DConfigBeanRoot bean)
      Save to disk all the configuration beans associated with a particular deployment descriptor file.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.DeploymentConfiguration (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.DeploymentConfiguration

  • Packages that use DeploymentConfiguration
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of DeploymentConfiguration in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that return DeploymentConfiguration
      Modifier and Type Method and Description
      DeploymentConfiguration DeploymentManager.createConfiguration(DeployableObject dObj)
      Retrieve the object that provides server-specific deployment configuration information for the Java EE deployable component.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.DeploymentManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.DeploymentManager

  • Packages that use DeploymentManager
    Package Description
    javax.enterprise.deploy.shared.factories
    Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
    javax.enterprise.deploy.spi.factories
    Provides J2EE Product Vendor deployment factory implementation classes.

    • Uses of DeploymentManager in javax.enterprise.deploy.shared.factories

      Methods in javax.enterprise.deploy.shared.factories that return DeploymentManager
      Modifier and Type Method and Description
      DeploymentManager DeploymentFactoryManager.getDeploymentManager(String uri, String username, String password)
      Retrieves a DeploymentManager instance to use for deployment.
      DeploymentManager DeploymentFactoryManager.getDisconnectedDeploymentManager(String uri)
      Return a disconnected DeploymentManager instance.

    • Uses of DeploymentManager in javax.enterprise.deploy.spi.factories

      Methods in javax.enterprise.deploy.spi.factories that return DeploymentManager
      Modifier and Type Method and Description
      DeploymentManager DeploymentFactory.getDeploymentManager(String uri, String username, String password)
      Return a connected DeploymentManager instance.
      DeploymentManager DeploymentFactory.getDisconnectedDeploymentManager(String uri)
      Return a disconnected DeploymentManager instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.Target (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.Target

  • Packages that use Target
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of Target in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that return Target
      Modifier and Type Method and Description
      Target TargetModuleID.getTarget()
      Retrieve the name of the target server.
      Target[] DeploymentManager.getTargets()
      Retrieve the list of deployment targets supported by this DeploymentManager.
      Methods in javax.enterprise.deploy.spi with parameters of type Target
      Modifier and Type Method and Description
      ProgressObject DeploymentManager.distribute(Target[] targetList, File moduleArchive, File deploymentPlan)
      The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
      ProgressObject DeploymentManager.distribute(Target[] targetList, InputStream moduleArchive, InputStream deploymentPlan)
      Deprecated.
      as of Java EE 5, replaced with DeploymentManager.distribute(Target[], ModuleType, InputStream, InputStream)
      ProgressObject DeploymentManager.distribute(Target[] targetList, ModuleType type, InputStream moduleArchive, InputStream deploymentPlan)
      The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
      TargetModuleID[] DeploymentManager.getAvailableModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of all Java EE application modules running or not running on the identified targets.
      TargetModuleID[] DeploymentManager.getNonRunningModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of Java EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.
      TargetModuleID[] DeploymentManager.getRunningModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of Java EE application modules distributed to the identified targets and that are currently running on the associated server or servers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.TargetModuleID (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.TargetModuleID

  • Packages that use TargetModuleID
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.

    • Uses of TargetModuleID in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that return TargetModuleID
      Modifier and Type Method and Description
      TargetModuleID[] DeploymentManager.getAvailableModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of all Java EE application modules running or not running on the identified targets.
      TargetModuleID[] TargetModuleID.getChildTargetModuleID()
      Retrieve a list of identifiers of the children of this deployed module.
      TargetModuleID[] DeploymentManager.getNonRunningModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of Java EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.
      TargetModuleID TargetModuleID.getParentTargetModuleID()
      Retrieve the identifier of the parent object of this deployed module.
      TargetModuleID[] DeploymentManager.getRunningModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of Java EE application modules distributed to the identified targets and that are currently running on the associated server or servers.
      Methods in javax.enterprise.deploy.spi with parameters of type TargetModuleID
      Modifier and Type Method and Description
      ProgressObject DeploymentManager.redeploy(TargetModuleID[] moduleIDList, File moduleArchive, File deploymentPlan)
      (optional) The redeploy method provides a means for updating currently deployed Java EE applications.
      ProgressObject DeploymentManager.redeploy(TargetModuleID[] moduleIDList, InputStream moduleArchive, InputStream deploymentPlan)
      (optional) The redeploy method provides a means for updating currently deployed Java EE applications.
      ProgressObject DeploymentManager.start(TargetModuleID[] moduleIDList)
      Start the application running.
      ProgressObject DeploymentManager.stop(TargetModuleID[] moduleIDList)
      Stop the application running.
      ProgressObject DeploymentManager.undeploy(TargetModuleID[] moduleIDList)
      Remove the application from the target server.

    • Uses of TargetModuleID in javax.enterprise.deploy.spi.status

      Methods in javax.enterprise.deploy.spi.status that return TargetModuleID
      Modifier and Type Method and Description
      TargetModuleID[] ProgressObject.getResultTargetModuleIDs()
      Retrieve the list of TargetModuleIDs successfully processed or created by the associated DeploymentManager operation.
      TargetModuleID ProgressEvent.getTargetModuleID()
      Retrieve the TargetModuleID for this event
      Methods in javax.enterprise.deploy.spi.status with parameters of type TargetModuleID
      Modifier and Type Method and Description
      ClientConfiguration ProgressObject.getClientConfiguration(TargetModuleID id)
      Return the ClientConfiguration object associated with the TargetModuleID.
      Constructors in javax.enterprise.deploy.spi.status with parameters of type TargetModuleID
      Constructor and Description
      ProgressEvent(Object source, TargetModuleID targetModuleID, DeploymentStatus sCode)
      Creates a new object representing a deployment progress event.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BeanNotFoundException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.exceptions

Class BeanNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class BeanNotFoundException
extends Exception
    This exception is to report that the bean is not a child of the parent bean.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      BeanNotFoundException(String s)
      Creates an new BeanNotFoundException object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BeanNotFoundException

        public BeanNotFoundException(String s)
        Creates an new BeanNotFoundException object.
        Parameters:
        s - a string indicating what was wrong with the target.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientExecuteException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.exceptions

Class ClientExecuteException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.ClientExecuteException
  • All Implemented Interfaces:
    Serializable

    public class ClientExecuteException
extends Exception
    This exception reports errors in setting up an application client for execution.
    Author:
    gfink
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ClientExecuteException()
      Creates new ClientExecuteException without detail message.
      ClientExecuteException(String msg)
      Constructs an ClientExecuteException with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ClientExecuteException

        public ClientExecuteException()
        Creates new ClientExecuteException without detail message.

      • ClientExecuteException

        public ClientExecuteException(String msg)
        Constructs an ClientExecuteException with the specified detail message.
        Parameters:
        msg - the detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConfigurationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.exceptions

Class ConfigurationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.ConfigurationException
  • All Implemented Interfaces:
    Serializable

    public class ConfigurationException
extends Exception
    This exception reports errors in generating a configuration bean.
    Author:
    gfink
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ConfigurationException()
      Creates new ConfigurationException without detail message.
      ConfigurationException(String msg)
      Constructs an ConfigurationException with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ConfigurationException

        public ConfigurationException()
        Creates new ConfigurationException without detail message.

      • ConfigurationException

        public ConfigurationException(String msg)
        Constructs an ConfigurationException with the specified detail message.
        Parameters:
        msg - the detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DConfigBeanVersionUnsupportedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.exceptions

Class DConfigBeanVersionUnsupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
  • All Implemented Interfaces:
    Serializable

    public class DConfigBeanVersionUnsupportedException
extends Exception
    This exception is to report that there is no support for the DConfigBean version requested.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DConfigBeanVersionUnsupportedException(String s)
      Creates an new DConfigBeanVersionUnsupportedException object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DConfigBeanVersionUnsupportedException

        public DConfigBeanVersionUnsupportedException(String s)
        Creates an new DConfigBeanVersionUnsupportedException object.
        Parameters:
        s - a string indicating what was wrong with the version request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeploymentManagerCreationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.exceptions

Class DeploymentManagerCreationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
  • All Implemented Interfaces:
    Serializable

    public class DeploymentManagerCreationException
extends Exception
    This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DeploymentManagerCreationException(String s)
      Creates an new DeploymentManagerCreationException object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DeploymentManagerCreationException

        public DeploymentManagerCreationException(String s)
        Creates an new DeploymentManagerCreationException object.
        Parameters:
        s - a string providing more information about the problem.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidModuleException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.exceptions

Class InvalidModuleException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.InvalidModuleException
  • All Implemented Interfaces:
    Serializable

    public class InvalidModuleException
extends Exception
    This exception is to report an invalid Java EE deployment module type.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidModuleException(String s)
      Creates an new InvalidModuleException object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidModuleException

        public InvalidModuleException(String s)
        Creates an new InvalidModuleException object.
        Parameters:
        s - a string indicating what was wrong with the module type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.deploy.spi.exceptions (Java(TM) EE 7 Specification APIs)

javax.enterprise.deploy.spi.exceptions

Exceptions

  • BeanNotFoundException
  • ClientExecuteException
  • ConfigurationException
  • DConfigBeanVersionUnsupportedException
  • DeploymentManagerCreationException
  • InvalidModuleException
  • OperationUnsupportedException
  • TargetException


javax.enterprise.deploy.spi.exceptions (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.deploy.spi.exceptions

Provides J2EE Product Vendor deployment exception implementation classes.

See: Description

  • Exception Summary
    Exception Description
    BeanNotFoundException
    This exception is to report that the bean is not a child of the parent bean.
    ClientExecuteException
    This exception reports errors in setting up an application client for execution.
    ConfigurationException
    This exception reports errors in generating a configuration bean.
    DConfigBeanVersionUnsupportedException
    This exception is to report that there is no support for the DConfigBean version requested.
    DeploymentManagerCreationException
    This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.
    InvalidModuleException
    This exception is to report an invalid Java EE deployment module type.
    OperationUnsupportedException
    This exception is to report that the method called is not supported by this implementation.
    TargetException
    This exception is to report bad target designators.

Package javax.enterprise.deploy.spi.exceptions Description

Provides J2EE Product Vendor deployment exception implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.deploy.spi.exceptions Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.deploy.spi.exceptions

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
        • javax.enterprise.deploy.spi.exceptions.ClientExecuteException
        • javax.enterprise.deploy.spi.exceptions.ConfigurationException
        • javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
        • javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
        • javax.enterprise.deploy.spi.exceptions.InvalidModuleException
        • javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException
        • javax.enterprise.deploy.spi.exceptions.TargetException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


OperationUnsupportedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.exceptions

Class OperationUnsupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException
  • All Implemented Interfaces:
    Serializable

    public class OperationUnsupportedException
extends Exception
    This exception is to report that the method called is not supported by this implementation.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      OperationUnsupportedException(String s)
      Creates an new OperationUnsupportedException object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • OperationUnsupportedException

        public OperationUnsupportedException(String s)
        Creates an new OperationUnsupportedException object.
        Parameters:
        s - a string indicating what was wrong with the target.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TargetException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.exceptions

Class TargetException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.TargetException
  • All Implemented Interfaces:
    Serializable

    public class TargetException
extends Exception
    This exception is to report bad target designators.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TargetException(String s)
      Creates an new TargetException object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TargetException

        public TargetException(String s)
        Creates an new TargetException object.
        Parameters:
        s - a string indicating what was wrong with the target.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.enterprise.deploy.spi.exceptions (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.deploy.spi.exceptions

  • Packages that use javax.enterprise.deploy.spi.exceptions
    Package Description
    javax.enterprise.deploy.shared.factories
    Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.
    javax.enterprise.deploy.spi.factories
    Provides J2EE Product Vendor deployment factory implementation classes.
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.
  • Classes in javax.enterprise.deploy.spi.exceptions used by javax.enterprise.deploy.shared.factories
    Class and Description
    DeploymentManagerCreationException
    This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.
  • Classes in javax.enterprise.deploy.spi.exceptions used by javax.enterprise.deploy.spi
    Class and Description
    BeanNotFoundException
    This exception is to report that the bean is not a child of the parent bean.
    ConfigurationException
    This exception reports errors in generating a configuration bean.
    DConfigBeanVersionUnsupportedException
    This exception is to report that there is no support for the DConfigBean version requested.
    InvalidModuleException
    This exception is to report an invalid Java EE deployment module type.
    TargetException
    This exception is to report bad target designators.
  • Classes in javax.enterprise.deploy.spi.exceptions used by javax.enterprise.deploy.spi.factories
    Class and Description
    DeploymentManagerCreationException
    This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.
  • Classes in javax.enterprise.deploy.spi.exceptions used by javax.enterprise.deploy.spi.status
    Class and Description
    ClientExecuteException
    This exception reports errors in setting up an application client for execution.
    OperationUnsupportedException
    This exception is to report that the method called is not supported by this implementation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.spi.exceptions.BeanNotFoundException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.spi.exceptions.BeanNotFoundException

  • Packages that use BeanNotFoundException
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of BeanNotFoundException in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that throw BeanNotFoundException
      Modifier and Type Method and Description
      void DConfigBean.removeDConfigBean(DConfigBean bean)
      Remove a child DConfigBean from this bean.
      void DeploymentConfiguration.removeDConfigBean(DConfigBeanRoot bean)
      Remove the root DConfigBean and all its children.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.spi.exceptions.ClientExecuteException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.spi.exceptions.ClientExecuteException

  • Packages that use ClientExecuteException
    Package Description
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.

    • Uses of ClientExecuteException in javax.enterprise.deploy.spi.status

      Methods in javax.enterprise.deploy.spi.status that throw ClientExecuteException
      Modifier and Type Method and Description
      void ClientConfiguration.execute()
      This method performs an exec and starts the application client running in another process.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.spi.exceptions.ConfigurationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.spi.exceptions.ConfigurationException

  • Packages that use ConfigurationException
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of ConfigurationException in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that throw ConfigurationException
      Modifier and Type Method and Description
      DConfigBean DConfigBean.getDConfigBean(DDBean bean)
      Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.
      DConfigBeanRoot DeploymentConfiguration.getDConfigBeanRoot(DDBeanRoot bean)
      Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.
      void DeploymentConfiguration.restore(InputStream inputArchive)
      Restore from disk to a full set of configuration beans previously stored.
      DConfigBeanRoot DeploymentConfiguration.restoreDConfigBean(InputStream inputArchive, DDBeanRoot bean)
      Restore from disk to instantated objects all the DConfigBeans associated with a specific deployment descriptor.
      void DeploymentConfiguration.save(OutputStream outputArchive)
      Save to disk the current set configuration beans created for this deployable module.
      void DeploymentConfiguration.saveDConfigBean(OutputStream outputArchive, DConfigBeanRoot bean)
      Save to disk all the configuration beans associated with a particular deployment descriptor file.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException

  • Packages that use DConfigBeanVersionUnsupportedException
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of DConfigBeanVersionUnsupportedException in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that throw DConfigBeanVersionUnsupportedException
      Modifier and Type Method and Description
      void DeploymentManager.setDConfigBeanVersion(DConfigBeanVersionType version)
      Set the configuration beans to be used to the Java EE platform version specificed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException

  • Packages that use DeploymentManagerCreationException
    Package Description
    javax.enterprise.deploy.shared.factories
    Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
    javax.enterprise.deploy.spi.factories
    Provides J2EE Product Vendor deployment factory implementation classes.

    • Uses of DeploymentManagerCreationException in javax.enterprise.deploy.shared.factories

      Methods in javax.enterprise.deploy.shared.factories that throw DeploymentManagerCreationException
      Modifier and Type Method and Description
      DeploymentManager DeploymentFactoryManager.getDeploymentManager(String uri, String username, String password)
      Retrieves a DeploymentManager instance to use for deployment.
      DeploymentManager DeploymentFactoryManager.getDisconnectedDeploymentManager(String uri)
      Return a disconnected DeploymentManager instance.

    • Uses of DeploymentManagerCreationException in javax.enterprise.deploy.spi.factories

      Methods in javax.enterprise.deploy.spi.factories that throw DeploymentManagerCreationException
      Modifier and Type Method and Description
      DeploymentManager DeploymentFactory.getDeploymentManager(String uri, String username, String password)
      Return a connected DeploymentManager instance.
      DeploymentManager DeploymentFactory.getDisconnectedDeploymentManager(String uri)
      Return a disconnected DeploymentManager instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.spi.exceptions.InvalidModuleException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.spi.exceptions.InvalidModuleException

  • Packages that use InvalidModuleException
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of InvalidModuleException in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that throw InvalidModuleException
      Modifier and Type Method and Description
      DeploymentConfiguration DeploymentManager.createConfiguration(DeployableObject dObj)
      Retrieve the object that provides server-specific deployment configuration information for the Java EE deployable component.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException

  • Packages that use OperationUnsupportedException
    Package Description
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.

    • Uses of OperationUnsupportedException in javax.enterprise.deploy.spi.status

      Methods in javax.enterprise.deploy.spi.status that throw OperationUnsupportedException
      Modifier and Type Method and Description
      void ProgressObject.cancel()
      (optional) A cancel request on an in-process operation stops all further processing of the operation and returns the environment to it original state before the operation was executed.
      void ProgressObject.stop()
      (optional) A stop request on an in-process operation allows the operation on the current TargetModuleID to run to completion but does not process any of the remaining unprocessed TargetModuleID objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.spi.exceptions.TargetException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.spi.exceptions.TargetException

  • Packages that use TargetException
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of TargetException in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that throw TargetException
      Modifier and Type Method and Description
      TargetModuleID[] DeploymentManager.getAvailableModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of all Java EE application modules running or not running on the identified targets.
      TargetModuleID[] DeploymentManager.getNonRunningModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of Java EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.
      TargetModuleID[] DeploymentManager.getRunningModules(ModuleType moduleType, Target[] targetList)
      Retrieve the list of Java EE application modules distributed to the identified targets and that are currently running on the associated server or servers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


DeploymentFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.factories

Interface DeploymentFactory

  • public interface DeploymentFactory
    The DeploymentFactory interface is a deployment driver for a Java EE plaform product. It returns a DeploymentManager object which represents a connection to a specific Java EE platform product.

    Each application server vendor must provide an implementation of this class in order for the Java EE Deployment API to work with their product.

    The class implementing this interface should have a public no-argument constructor, and it should be stateless (two instances of the class should always behave the same). It is suggested but not required that the class have a static initializer that registers an instance of the class with the DeploymentFactoryManager class.

    A connected or disconnected DeploymentManager can be requested. A DeploymentManager that runs connected to the platform can provide access to Java EE resources. A DeploymentManager that runs disconnected only provides module deployment configuration support.

    See Also:
    DeploymentFactoryManager

    • Method Summary

      Methods
      Modifier and Type Method and Description
      DeploymentManager getDeploymentManager(String uri, String username, String password)
      Return a connected DeploymentManager instance.
      DeploymentManager getDisconnectedDeploymentManager(String uri)
      Return a disconnected DeploymentManager instance.
      String getDisplayName()
      Provide a string with the name of this vendor's DeploymentManager.
      String getProductVersion()
      Provide a string identifying version of this vendor's DeploymentManager.
      boolean handlesURI(String uri)
      Tests whether this factory can create a DeploymentManager object based on the specificed URI.

    • Method Detail

      • handlesURI

        boolean handlesURI(String uri)
        Tests whether this factory can create a DeploymentManager object based on the specificed URI. This does not indicate whether such an attempt will be successful, only whether the factory can handle the uri.
        Parameters:
        uri - The uri to check
        Returns:
        true if the factory can handle the uri.

      • getDeploymentManager

        DeploymentManager getDeploymentManager(String uri,
                                     String username,
                                     String password)
                                       throws DeploymentManagerCreationException
        Return a connected DeploymentManager instance.
        Parameters:
        uri - The URI that specifies the connection parameters
        username - An optional username (may be null if no authentication is required for this platform).
        password - An optional password (may be null if no authentication is required for this platform).
        Returns:
        A ready DeploymentManager instance.
        Throws:
        DeploymentManagerCreationException - occurs when a DeploymentManager could not be returned (server down, unable to authenticate, etc).

      • getDisconnectedDeploymentManager

        DeploymentManager getDisconnectedDeploymentManager(String uri)
                                                   throws DeploymentManagerCreationException
        Return a disconnected DeploymentManager instance.
        Parameters:
        uri - the uri of the DeploymentManager to return.
        Returns:
        A DeploymentManager disconnected instance.
        Throws:
        DeploymentManagerCreationException - occurs if the DeploymentManager could not be created.

      • getDisplayName

        String getDisplayName()
        Provide a string with the name of this vendor's DeploymentManager.
        Returns:
        the name of the vendor's DeploymentManager.

      • getProductVersion

        String getProductVersion()
        Provide a string identifying version of this vendor's DeploymentManager.
        Returns:
        the name of the vendor's DeploymentManager.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.deploy.spi.factories (Java(TM) EE 7 Specification APIs)

javax.enterprise.deploy.spi.factories

Interfaces

  • DeploymentFactory


javax.enterprise.deploy.spi.factories (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.deploy.spi.factories

Provides J2EE Product Vendor deployment factory implementation classes.

See: Description

  • Interface Summary
    Interface Description
    DeploymentFactory
    The DeploymentFactory interface is a deployment driver for a Java EE plaform product.

Package javax.enterprise.deploy.spi.factories Description

Provides J2EE Product Vendor deployment factory implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.deploy.spi.factories Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.deploy.spi.factories

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.enterprise.deploy.spi.factories.DeploymentFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.enterprise.deploy.spi.factories (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.deploy.spi.factories

  • Packages that use javax.enterprise.deploy.spi.factories
    Package Description
    javax.enterprise.deploy.shared.factories
    Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
  • Classes in javax.enterprise.deploy.spi.factories used by javax.enterprise.deploy.shared.factories
    Class and Description
    DeploymentFactory
    The DeploymentFactory interface is a deployment driver for a Java EE plaform product.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.factories.DeploymentFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.factories.DeploymentFactory

  • Packages that use DeploymentFactory
    Package Description
    javax.enterprise.deploy.shared.factories
    Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.

    • Uses of DeploymentFactory in javax.enterprise.deploy.shared.factories

      Methods in javax.enterprise.deploy.shared.factories that return DeploymentFactory
      Modifier and Type Method and Description
      DeploymentFactory[] DeploymentFactoryManager.getDeploymentFactories()
      Retrieve the lists of currently registered DeploymentFactories.
      Methods in javax.enterprise.deploy.shared.factories with parameters of type DeploymentFactory
      Modifier and Type Method and Description
      void DeploymentFactoryManager.registerDeploymentFactory(DeploymentFactory factory)
      Registers a DeploymentFactory so it will be able to handle requests.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ClientConfiguration (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.status

Interface ClientConfiguration

  • All Superinterfaces:
    Serializable

    public interface ClientConfiguration
extends Serializable
    The ClientConfiguration object installs, configures and executes an Application Client. This class resolves the settings for installing and running the application client.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void execute()
      This method performs an exec and starts the application client running in another process.

    • Method Detail

      • execute

        void execute()
             throws ClientExecuteException
        This method performs an exec and starts the application client running in another process.
        Throws:
        ClientExecuteException - when the configuration is incomplete.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeploymentStatus (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.status

Interface DeploymentStatus

  • public interface DeploymentStatus
    The DeploymentStatus interface provides information about the progress status of a deployment action.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ActionType getAction()
      Retrieve the deployment ActionType for this event.
      CommandType getCommand()
      Retrieve the deployment CommandType of this event.
      String getMessage()
      Retrieve any additional information about the status of this event.
      StateType getState()
      Retrieve the StateType value.
      boolean isCompleted()
      A convience method to report if the operation is in the completed state.
      boolean isFailed()
      A convience method to report if the operation is in the failed state.
      boolean isRunning()
      A convience method to report if the operation is in the running state.

    • Method Detail

      • getState

        StateType getState()
        Retrieve the StateType value.
        Returns:
        the StateType object

      • getCommand

        CommandType getCommand()
        Retrieve the deployment CommandType of this event.
        Returns:
        the CommandType Object

      • getAction

        ActionType getAction()
        Retrieve the deployment ActionType for this event.
        Returns:
        the ActionType Object

      • getMessage

        String getMessage()
        Retrieve any additional information about the status of this event.
        Returns:
        message text

      • isCompleted

        boolean isCompleted()
        A convience method to report if the operation is in the completed state.
        Returns:
        true if this command has completed successfully

      • isFailed

        boolean isFailed()
        A convience method to report if the operation is in the failed state.
        Returns:
        true if this command has failed

      • isRunning

        boolean isRunning()
        A convience method to report if the operation is in the running state.
        Returns:
        true if this command is still running
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.deploy.spi.status (Java(TM) EE 7 Specification APIs)

javax.enterprise.deploy.spi.status

Interfaces

  • ClientConfiguration
  • DeploymentStatus
  • ProgressListener
  • ProgressObject

Classes

  • ProgressEvent


javax.enterprise.deploy.spi.status (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.deploy.spi.status

Provides J2EE Product Vendor deployment status implementation classes.

See: Description

  • Interface Summary
    Interface Description
    ClientConfiguration
    The ClientConfiguration object installs, configures and executes an Application Client.
    DeploymentStatus
    The DeploymentStatus interface provides information about the progress status of a deployment action.
    ProgressListener
    The listener interface for receiving deployment progress events.
    ProgressObject
    The ProgressObject interface tracks and reports the progress of the deployment activities, distribute, start, stop, undeploy.
  • Class Summary
    Class Description
    ProgressEvent
    An event which indicates that a deployment status change has occurred.

Package javax.enterprise.deploy.spi.status Description

Provides J2EE Product Vendor deployment status implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.deploy.spi.status Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.deploy.spi.status

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.enterprise.deploy.spi.status.ProgressEvent

Interface Hierarchy

  • javax.enterprise.deploy.spi.status.DeploymentStatus
  • java.util.EventListener
    • javax.enterprise.deploy.spi.status.ProgressListener
  • javax.enterprise.deploy.spi.status.ProgressObject
  • java.io.Serializable
    • javax.enterprise.deploy.spi.status.ClientConfiguration
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ProgressEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.status

Class ProgressEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.enterprise.deploy.spi.status.ProgressEvent
  • All Implemented Interfaces:
    Serializable

    public class ProgressEvent
extends EventObject
    An event which indicates that a deployment status change has occurred.
    See Also:
    ProgressListener, ProgressObject, Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ProgressEvent(Object source, TargetModuleID targetModuleID, DeploymentStatus sCode)
      Creates a new object representing a deployment progress event.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      DeploymentStatus getDeploymentStatus()
      Retrieve the status information.
      TargetModuleID getTargetModuleID()
      Retrieve the TargetModuleID for this event

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ProgressEvent

        public ProgressEvent(Object source,
             TargetModuleID targetModuleID,
             DeploymentStatus sCode)
        Creates a new object representing a deployment progress event.
        Parameters:
        source - the object on which the Event initially occurred.
        sCode - the object containing the status information.

    • Method Detail

      • getTargetModuleID

        public TargetModuleID getTargetModuleID()
        Retrieve the TargetModuleID for this event
        Returns:
        the object containing the TargetModuleID

      • getDeploymentStatus

        public DeploymentStatus getDeploymentStatus()
        Retrieve the status information.
        Returns:
        the object containing the status information.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProgressListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.status

Interface ProgressListener

  • All Superinterfaces:
    EventListener

    public interface ProgressListener
extends EventListener
    The listener interface for receiving deployment progress events.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void handleProgressEvent(ProgressEvent event)
      Invoked when a deployment progress event occurs.

    • Method Detail

      • handleProgressEvent

        void handleProgressEvent(ProgressEvent event)
        Invoked when a deployment progress event occurs.
        Parameters:
        event - the progress status event.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProgressObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.deploy.spi.status

Interface ProgressObject

  • public interface ProgressObject
    The ProgressObject interface tracks and reports the progress of the deployment activities, distribute, start, stop, undeploy.

    This class has an optional cancel method. The support of the cancel function can be tested by the isCancelSupported method.

    The ProgressObject structure allows the user the option of polling for status or to provide a callback.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addProgressListener(ProgressListener pol)
      Add a listener to receive Progress events on deployment actions.
      void cancel()
      (optional) A cancel request on an in-process operation stops all further processing of the operation and returns the environment to it original state before the operation was executed.
      ClientConfiguration getClientConfiguration(TargetModuleID id)
      Return the ClientConfiguration object associated with the TargetModuleID.
      DeploymentStatus getDeploymentStatus()
      Retrieve the status of this activity.
      TargetModuleID[] getResultTargetModuleIDs()
      Retrieve the list of TargetModuleIDs successfully processed or created by the associated DeploymentManager operation.
      boolean isCancelSupported()
      Tests whether the vendor supports a cancel opertation for deployment activities.
      boolean isStopSupported()
      Tests whether the vendor supports a stop opertation for deployment activities.
      void removeProgressListener(ProgressListener pol)
      Remove a ProgressObject listener.
      void stop()
      (optional) A stop request on an in-process operation allows the operation on the current TargetModuleID to run to completion but does not process any of the remaining unprocessed TargetModuleID objects.

    • Method Detail

      • getDeploymentStatus

        DeploymentStatus getDeploymentStatus()
        Retrieve the status of this activity.
        Returns:
        An object containing the status information.

      • getResultTargetModuleIDs

        TargetModuleID[] getResultTargetModuleIDs()
        Retrieve the list of TargetModuleIDs successfully processed or created by the associated DeploymentManager operation.
        Returns:
        a list of TargetModuleIDs.

      • getClientConfiguration

        ClientConfiguration getClientConfiguration(TargetModuleID id)
        Return the ClientConfiguration object associated with the TargetModuleID.
        Returns:
        ClientConfiguration for a given TargetModuleID or null if none exists.

      • isCancelSupported

        boolean isCancelSupported()
        Tests whether the vendor supports a cancel opertation for deployment activities.
        Returns:
        true if canceling an activity is supported by this platform.

      • cancel

        void cancel()
            throws OperationUnsupportedException
        (optional) A cancel request on an in-process operation stops all further processing of the operation and returns the environment to it original state before the operation was executed. An operation that has run to completion cannot be cancelled.
        Throws:
        OperationUnsupportedException - this optional command is not supported by this implementation.

      • isStopSupported

        boolean isStopSupported()
        Tests whether the vendor supports a stop opertation for deployment activities.
        Returns:
        true if canceling an activity is supported by this platform.

      • stop

        void stop()
          throws OperationUnsupportedException
        (optional) A stop request on an in-process operation allows the operation on the current TargetModuleID to run to completion but does not process any of the remaining unprocessed TargetModuleID objects. The processed TargetModuleIDs must be returned by the method getResultTargetModuleIDs.
        Throws:
        OperationUnsupportedException - this optional command is not supported by this implementation.

      • addProgressListener

        void addProgressListener(ProgressListener pol)
        Add a listener to receive Progress events on deployment actions.
        Parameters:
        pol - the listener to receive events
        See Also:
        ProgressEvent

      • removeProgressListener

        void removeProgressListener(ProgressListener pol)
        Remove a ProgressObject listener.
        Parameters:
        pol - the listener being removed
        See Also:
        ProgressEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.enterprise.deploy.spi.status (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.deploy.spi.status

  • Packages that use javax.enterprise.deploy.spi.status
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.
  • Classes in javax.enterprise.deploy.spi.status used by javax.enterprise.deploy.spi
    Class and Description
    ProgressObject
    The ProgressObject interface tracks and reports the progress of the deployment activities, distribute, start, stop, undeploy.
  • Classes in javax.enterprise.deploy.spi.status used by javax.enterprise.deploy.spi.status
    Class and Description
    ClientConfiguration
    The ClientConfiguration object installs, configures and executes an Application Client.
    DeploymentStatus
    The DeploymentStatus interface provides information about the progress status of a deployment action.
    ProgressEvent
    An event which indicates that a deployment status change has occurred.
    ProgressListener
    The listener interface for receiving deployment progress events.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.deploy.spi.status.ProgressEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.deploy.spi.status.ProgressEvent

  • Packages that use ProgressEvent
    Package Description
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.

    • Uses of ProgressEvent in javax.enterprise.deploy.spi.status

      Methods in javax.enterprise.deploy.spi.status with parameters of type ProgressEvent
      Modifier and Type Method and Description
      void ProgressListener.handleProgressEvent(ProgressEvent event)
      Invoked when a deployment progress event occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.status.ClientConfiguration (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.status.ClientConfiguration

  • Packages that use ClientConfiguration
    Package Description
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.

    • Uses of ClientConfiguration in javax.enterprise.deploy.spi.status

      Methods in javax.enterprise.deploy.spi.status that return ClientConfiguration
      Modifier and Type Method and Description
      ClientConfiguration ProgressObject.getClientConfiguration(TargetModuleID id)
      Return the ClientConfiguration object associated with the TargetModuleID.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.status.DeploymentStatus (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.status.DeploymentStatus

  • Packages that use DeploymentStatus
    Package Description
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.

    • Uses of DeploymentStatus in javax.enterprise.deploy.spi.status

      Methods in javax.enterprise.deploy.spi.status that return DeploymentStatus
      Modifier and Type Method and Description
      DeploymentStatus ProgressObject.getDeploymentStatus()
      Retrieve the status of this activity.
      DeploymentStatus ProgressEvent.getDeploymentStatus()
      Retrieve the status information.
      Constructors in javax.enterprise.deploy.spi.status with parameters of type DeploymentStatus
      Constructor and Description
      ProgressEvent(Object source, TargetModuleID targetModuleID, DeploymentStatus sCode)
      Creates a new object representing a deployment progress event.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.status.ProgressListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.status.ProgressListener

  • Packages that use ProgressListener
    Package Description
    javax.enterprise.deploy.spi.status
    Provides J2EE Product Vendor deployment status implementation classes.

    • Uses of ProgressListener in javax.enterprise.deploy.spi.status

      Methods in javax.enterprise.deploy.spi.status with parameters of type ProgressListener
      Modifier and Type Method and Description
      void ProgressObject.addProgressListener(ProgressListener pol)
      Add a listener to receive Progress events on deployment actions.
      void ProgressObject.removeProgressListener(ProgressListener pol)
      Remove a ProgressObject listener.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.deploy.spi.status.ProgressObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.deploy.spi.status.ProgressObject

  • Packages that use ProgressObject
    Package Description
    javax.enterprise.deploy.spi
    Provides J2EE Product Vendor implementation classes.

    • Uses of ProgressObject in javax.enterprise.deploy.spi

      Methods in javax.enterprise.deploy.spi that return ProgressObject
      Modifier and Type Method and Description
      ProgressObject DeploymentManager.distribute(Target[] targetList, File moduleArchive, File deploymentPlan)
      The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
      ProgressObject DeploymentManager.distribute(Target[] targetList, InputStream moduleArchive, InputStream deploymentPlan)
      Deprecated.
      as of Java EE 5, replaced with DeploymentManager.distribute(Target[], ModuleType, InputStream, InputStream)
      ProgressObject DeploymentManager.distribute(Target[] targetList, ModuleType type, InputStream moduleArchive, InputStream deploymentPlan)
      The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
      ProgressObject DeploymentManager.redeploy(TargetModuleID[] moduleIDList, File moduleArchive, File deploymentPlan)
      (optional) The redeploy method provides a means for updating currently deployed Java EE applications.
      ProgressObject DeploymentManager.redeploy(TargetModuleID[] moduleIDList, InputStream moduleArchive, InputStream deploymentPlan)
      (optional) The redeploy method provides a means for updating currently deployed Java EE applications.
      ProgressObject DeploymentManager.start(TargetModuleID[] moduleIDList)
      Start the application running.
      ProgressObject DeploymentManager.stop(TargetModuleID[] moduleIDList)
      Stop the application running.
      ProgressObject DeploymentManager.undeploy(TargetModuleID[] moduleIDList)
      Remove the application from the target server.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Event (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.event

Interface Event<T>

  • Type Parameters:
    T - the type of the event object

    public interface Event<T>

    Allows the application to fire events of a particular type.

    Beans fire events via an instance of the Event interface, which may be injected:

     @Inject
 @Any
 Event<LoggedInEvent> loggedInEvent;

    The fire() method accepts an event object:

     public void login() {
    ...
    loggedInEvent.fire( new LoggedInEvent(user) );
 }

    Any combination of qualifiers may be specified at the injection point:

     @Inject
 @Admin
 Event<LoggedInEvent> adminLoggedInEvent;

    Or, the @Any qualifier may be used, allowing the application to specify qualifiers dynamically:

     @Inject
 @Any
 Event<LoggedInEvent> loggedInEvent;

    For an injected Event:

    • the specified type is the type parameter specified at the injection point, and
    • the specified qualifiers are the qualifiers specified at the injection point.
    Author:
    Gavin King, Pete Muir, David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void fire(T event)
      Fires an event with the specified qualifiers and notifies observers.
      Event<T> select(Annotation... qualifiers)
      Obtains a child Event for the given additional required qualifiers.
      <U extends T>
      Event<U>             		select(Class<U> subtype, Annotation... qualifiers)
      Obtains a child Event for the given required type and additional required qualifiers.
      <U extends T>
      Event<U>             		select(TypeLiteral<U> subtype, Annotation... qualifiers)
      Obtains a child Event for the given required type and additional required qualifiers.

    • Method Detail

      • fire

        void fire(T event)

        Fires an event with the specified qualifiers and notifies observers.

        Parameters:
        event - the event object
        Throws:
        IllegalArgumentException - if the runtime type of the event object contains a type variable
        ObserverException - if a notified observer throws a checked exception, it will be wrapped and rethrown as an (unchecked) ObserverException

      • select

        Event<T> select(Annotation... qualifiers)

        Obtains a child Event for the given additional required qualifiers.

        Parameters:
        qualifiers - the additional specified qualifiers
        Returns:
        the child Event
        Throws:
        IllegalArgumentException - if passed two instances of the same qualifier type, or an instance of an annotation that is not a qualifier type

      • select

        <U extends T> Event<U> select(Class<U> subtype,
                            Annotation... qualifiers)

        Obtains a child Event for the given required type and additional required qualifiers.

        Type Parameters:
        U - the specified type
        Parameters:
        subtype - a Class representing the specified type
        qualifiers - the additional specified qualifiers
        Returns:
        the child Event
        Throws:
        IllegalArgumentException - if passed two instances of the same qualifier type, or an instance of an annotation that is not a qualifier type

      • select

        <U extends T> Event<U> select(TypeLiteral<U> subtype,
                            Annotation... qualifiers)

        Obtains a child Event for the given required type and additional required qualifiers.

        Type Parameters:
        U - the specified type
        Parameters:
        subtype - a TypeLiteral representing the specified type
        qualifiers - the additional specified qualifiers
        Returns:
        the child Event
        Throws:
        IllegalArgumentException - if passed two instances of the same qualifier type, or an instance of an annotation that is not a qualifier type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.event (Java(TM) EE 7 Specification APIs)

javax.enterprise.event

Interfaces

  • Event

Enums

  • Reception
  • TransactionPhase

Exceptions

  • ObserverException

Annotation Types

  • Observes


javax.enterprise.event (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.event

Annotations and interfaces relating to events.

See: Description

  • Interface Summary
    Interface Description
    Event<T>
    Allows the application to fire events of a particular type.
  • Enum Summary
    Enum Description
    Reception
    Distinguishes conditional observer methods from observer methods which are always notified.
    TransactionPhase
    Distinguishes the various kinds of transactional observer methods from regular observer methods which are notified immediately.
  • Exception Summary
    Exception Description
    ObserverException
    Indicates that a checked exception was thrown by an observer method during event notification.
  • Annotation Types Summary
    Annotation Type Description
    Observes
    Identifies the event parameter of an observer method.

Package javax.enterprise.event Description

Annotations and interfaces relating to events.

Beans may produce and consume events. Events allows beans to interact in a completely decoupled fashion, with no compile-time dependency between the interacting beans. Most importantly, it allows stateful beans in one architectural tier of the application to synchronize their internal state with state changes that occur in a different tier.

An event comprises:

  • A Java object, called the event object
  • A (possibly empty) set of instances of qualifier types, called the event qualifiers

The Event interface is used to fire events.

Event objects and event types

The event object acts as a payload, to propagate state from producer to consumer. An event object is an instance of a concrete Java class with no type variables.

The event types of the event include all superclasses and interfaces of the runtime class of the event object. An event type may not contain a type variable.

Event qualifiers

The event qualifiers act as topic selectors, allowing the consumer to narrow the set of events it observes. An event qualfier may be an instance of any qualifier type.

Observer methods

An observer method allows the application to receive and respond to event notifications. It acts as event consumer, observing events of a specific type, with a specific set of qualifiers. Any Java type may be observed by an observer method.

An observer method is a method of a bean class or extension with a parameter annotated @Observes.

An observer method will be notified of an event if:

  • the event object is assignable to the type observed by the observer method,
  • the observer method has all the event qualifiers of the event, and
  • either the event is not a container lifecycle event, or the observer method belongs to an extension.

If the observer method is a transactional observer method and there is a JTA transaction in progress when the event is fired, the observer method is notified during the appropriate transaction completion phase. Otherwise, the observer is notified when the event is fired.

The order in which observer methods are called is not defined, and so portable applications should not rely upon the order in which observers are called.

Observer methods may throw exceptions:

  • If the observer method is a transactional observer method, any exception is caught and logged by the container.
  • Otherwise, the exception aborts processing of the event. No other observer methods of that event will be called. The exception is rethrown. If the exception is a checked exception, it is wrapped and rethrown as an (unchecked) ObserverException.
See Also:
javax.enterprise.inject, Observes, Event, Qualifier
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.event Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.event

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.event.ObserverException

Interface Hierarchy

  • javax.enterprise.event.Event<T>

Annotation Type Hierarchy

  • javax.enterprise.event.Observes (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.enterprise.event.TransactionPhase
      • javax.enterprise.event.Reception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ObserverException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.event

Class ObserverException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.event.ObserverException
  • All Implemented Interfaces:
    Serializable

    public class ObserverException
extends RuntimeException

    Indicates that a checked exception was thrown by an observer method during event notification.

    Author:
    Pete Muir, Gavin King
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ObserverException()
      ObserverException(String message)
      ObserverException(String message, Throwable cause)
      ObserverException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ObserverException

        public ObserverException()

      • ObserverException

        public ObserverException(String message)

      • ObserverException

        public ObserverException(Throwable cause)

      • ObserverException

        public ObserverException(String message,
                 Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Observes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.event

Annotation Type Observes

  • @Target(value=PARAMETER)
@Retention(value=RUNTIME)
@Documented
public @interface Observes

    Identifies the event parameter of an observer method. May be applied to a parameter of a method of a bean class or extension.

     public void afterLogin(@Observes LoggedInEvent event) { ... }

    An observer method is a non-abstract method of a managed bean class or session bean class (or of an extension). An observer method may be either static or non-static. If the bean is a session bean, the observer method must be either a business method of the EJB or a static method of the bean class.

    Each observer method must have exactly one event parameter, of the same type as the event type it observes. Event qualifiers may be declared by annotating the event parameter. When searching for observer methods for an event, the container considers the type and qualifiers of the event parameter.

    If the event parameter does not explicitly declare any qualifier, the observer method observes events with no qualifier.

    The event parameter type may contain a type variable or wildcard.

    In addition to the event parameter, observer methods may declare additional parameters, which may declare qualifiers. These additional parameters are injection points.

     public void afterLogin(@Observes LoggedInEvent event, @Manager User user, Logger log) { ... }

    A bean (or extension) may declare multiple observer methods.

    Observer methods are inherited by bean subclasses.

    Interceptors and decorators may not declare observer methods.

    Author:
    Gavin King, Pete Muir, David Allen

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      TransactionPhase during
      Specifies at what time the observer method is notified.
      Reception notifyObserver
      Specifies under what conditions the observer method is notified.

    • Element Detail

      • notifyObserver

        public abstract Reception notifyObserver

        Specifies under what conditions the observer method is notified.

        By default, the observer method is notified even if no instance of the bean that defines the observer method already exists in the current context.

        Default:
        javax.enterprise.event.Reception.ALWAYS

      • during

        public abstract TransactionPhase during

        Specifies at what time the observer method is notified.

        By default, the observer method is notified when the event is fired.

        Default:
        javax.enterprise.event.TransactionPhase.IN_PROGRESS
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Reception (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.enterprise.event

Enum Reception

  • java.lang.Object
    • java.lang.Enum<Reception>
      • javax.enterprise.event.Reception
  • All Implemented Interfaces:
    Serializable, Comparable<Reception>

    public enum Reception
extends Enum<Reception>

    Distinguishes conditional observer methods from observer methods which are always notified.

    A conditional observer method is an observer method which is notified of an event only if an instance of the bean that defines the observer method already exists in the current context.

    Beans with scope @Dependent may not have conditional observer methods.

    Author:
    Gavin King, Dan Allen, David Allen

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ALWAYS
      Specifies that an observer method always receives event notifications.
      IF_EXISTS
      Specifies that an observer method is only called if the current instance of the bean declaring the observer method already exists.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Reception valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Reception[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • IF_EXISTS

        public static final Reception IF_EXISTS

        Specifies that an observer method is only called if the current instance of the bean declaring the observer method already exists.

        If there is no active context for the scope to which the bean declaring this observer method belongs, then the observer method is not called.

      • ALWAYS

        public static final Reception ALWAYS
        Specifies that an observer method always receives event notifications.

    • Method Detail

      • values

        public static Reception[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Reception c : Reception.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Reception valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


TransactionPhase (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.enterprise.event

Enum TransactionPhase

  • java.lang.Object
    • java.lang.Enum<TransactionPhase>
      • javax.enterprise.event.TransactionPhase
  • All Implemented Interfaces:
    Serializable, Comparable<TransactionPhase>

    public enum TransactionPhase
extends Enum<TransactionPhase>

    Distinguishes the various kinds of transactional observer methods from regular observer methods which are notified immediately.

    Transactional observer methods are observer methods which receive event notifications during the before or after completion phase of the transaction in which the event was fired. If no transaction is in progress when the event is fired, they are notified at the same time as other observers.

    Author:
    Pete Muir, Gavin King

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      AFTER_COMPLETION
      Identifies an after completion observer method, called during the after completion phase of the transaction.
      AFTER_FAILURE
      Identifies an after failure observer method, called during the after completion phase of the transaction, only when the transaction fails.
      AFTER_SUCCESS
      Identifies an after success observer method, called during the after completion phase of the transaction, only when the transaction completes successfully.
      BEFORE_COMPLETION
      Identifies a before completion observer method, called during the before completion phase of the transaction.
      IN_PROGRESS
      Identifies a regular observer method, called when the event is fired.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static TransactionPhase valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static TransactionPhase[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • IN_PROGRESS

        public static final TransactionPhase IN_PROGRESS

        Identifies a regular observer method, called when the event is fired.

      • BEFORE_COMPLETION

        public static final TransactionPhase BEFORE_COMPLETION

        Identifies a before completion observer method, called during the before completion phase of the transaction.

      • AFTER_COMPLETION

        public static final TransactionPhase AFTER_COMPLETION

        Identifies an after completion observer method, called during the after completion phase of the transaction.

      • AFTER_FAILURE

        public static final TransactionPhase AFTER_FAILURE

        Identifies an after failure observer method, called during the after completion phase of the transaction, only when the transaction fails.

      • AFTER_SUCCESS

        public static final TransactionPhase AFTER_SUCCESS

        Identifies an after success observer method, called during the after completion phase of the transaction, only when the transaction completes successfully.

    • Method Detail

      • values

        public static TransactionPhase[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (TransactionPhase c : TransactionPhase.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static TransactionPhase valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Uses of Package javax.enterprise.event (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.event

  • Packages that use javax.enterprise.event
    Package Description
    javax.enterprise.event
    Annotations and interfaces relating to events.
    javax.enterprise.inject.spi
    The portable extension integration SPI.
  • Classes in javax.enterprise.event used by javax.enterprise.event
    Class and Description
    Event
    Allows the application to fire events of a particular type.
    Reception
    Distinguishes conditional observer methods from observer methods which are always notified.
    TransactionPhase
    Distinguishes the various kinds of transactional observer methods from regular observer methods which are notified immediately.
  • Classes in javax.enterprise.event used by javax.enterprise.inject.spi
    Class and Description
    Reception
    Distinguishes conditional observer methods from observer methods which are always notified.
    TransactionPhase
    Distinguishes the various kinds of transactional observer methods from regular observer methods which are notified immediately.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.event.ObserverException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.event.ObserverException

No usage of javax.enterprise.event.ObserverException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.event.Observes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.event.Observes

No usage of javax.enterprise.event.Observes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.event.Reception (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.event.Reception

  • Packages that use Reception
    Package Description
    javax.enterprise.event
    Annotations and interfaces relating to events.
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Reception in javax.enterprise.event

      Methods in javax.enterprise.event that return Reception
      Modifier and Type Method and Description
      static Reception Reception.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Reception[] Reception.values()
      Returns an array containing the constants of this enum type, in the order they are declared.

    • Uses of Reception in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return Reception
      Modifier and Type Method and Description
      Reception ObserverMethod.getReception()
      Obtains the specified Reception for the observer method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.event.TransactionPhase (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.event.TransactionPhase

  • Packages that use TransactionPhase
    Package Description
    javax.enterprise.event
    Annotations and interfaces relating to events.
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of TransactionPhase in javax.enterprise.event

      Methods in javax.enterprise.event that return TransactionPhase
      Modifier and Type Method and Description
      static TransactionPhase TransactionPhase.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static TransactionPhase[] TransactionPhase.values()
      Returns an array containing the constants of this enum type, in the order they are declared.

    • Uses of TransactionPhase in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return TransactionPhase
      Modifier and Type Method and Description
      TransactionPhase ObserverMethod.getTransactionPhase()
      Obtains the specified TransactionPhase for the observer method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.event.Event (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.event.Event

  • Packages that use Event
    Package Description
    javax.enterprise.event
    Annotations and interfaces relating to events.

    • Uses of Event in javax.enterprise.event

      Methods in javax.enterprise.event that return Event
      Modifier and Type Method and Description
      Event<T> Event.select(Annotation... qualifiers)
      Obtains a child Event for the given additional required qualifiers.
      <U extends T>
      Event<U>             		Event.select(Class<U> subtype, Annotation... qualifiers)
      Obtains a child Event for the given required type and additional required qualifiers.
      <U extends T>
      Event<U>             		Event.select(TypeLiteral<U> subtype, Annotation... qualifiers)
      Obtains a child Event for the given required type and additional required qualifiers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Alternative (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Alternative

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface Alternative

    Specifies that a bean is an alternative. May be applied to a bean class, producer method or field or stereotype.

     @Alternative
 public class MockOrder extends Order { ... }

    An alternative is not available for injection, lookup or EL resolution to classes or JSP/JSF pages in a module unless the module is a bean archive and the alternative is explicitly selected in that bean archive. An alternative is never available for injection, lookup or EL resolution in a module that is not a bean archive.

    By default, a bean archive has no selected alternatives. An alternative must be explicitly declared using the <alternatives> element of the beans.xml file of the bean archive. The <alternatives> element contains a list of bean classes and stereotypes. An alternative is selected for the bean archive if either:

    • the alternative is a managed bean or session bean and the bean class of the bean is listed,
    • the alternative is a producer method, field or resource, and the bean class that declares the method or field is listed, or
    • any @Alternative stereotype of the alternative is listed.
    Author:
    Gavin King, Pete Muir
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AmbiguousResolutionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject

Class AmbiguousResolutionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.InjectionException
            • javax.enterprise.inject.ResolutionException
              • javax.enterprise.inject.AmbiguousResolutionException
  • All Implemented Interfaces:
    Serializable

    public class AmbiguousResolutionException
extends ResolutionException

    Indicates that multiple beans match a certain combination of required type and required qualifiers and are eligible for injection into a certain class.

    Author:
    Pete Muir, Gavin King
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      AmbiguousResolutionException()
      AmbiguousResolutionException(String message)
      AmbiguousResolutionException(String message, Throwable throwable)
      AmbiguousResolutionException(Throwable throwable)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AmbiguousResolutionException

        public AmbiguousResolutionException()

      • AmbiguousResolutionException

        public AmbiguousResolutionException(String message,
                            Throwable throwable)

      • AmbiguousResolutionException

        public AmbiguousResolutionException(String message)

      • AmbiguousResolutionException

        public AmbiguousResolutionException(Throwable throwable)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Any (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Any

  • @Qualifier
@Retention(value=RUNTIME)
@Target(value={TYPE,METHOD,FIELD,PARAMETER})
@Documented
public @interface Any

    The built-in qualifier type.

    Every bean has the qualifier @Any, even if it does not explicitly declare this qualifier, except for the special @New qualified beans.

    Every event has the qualifier @Any, even if it was raised without explicitly declaration of this qualifier.

    The @Any qualifier allows an injection point to refer to all beans or all events of a certain bean type.

     @Inject
 @Any
 Instance<PaymentProcessor> anyPaymentProcessor;

     @Inject
 @Any
 Event<User> anyUserEvent;

     @Inject
 @Delegate
 @Any
 Logger logger;
    Author:
    Gavin King, David Allen
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


CreationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject

Class CreationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.InjectionException
            • javax.enterprise.inject.CreationException
  • All Implemented Interfaces:
    Serializable

    public class CreationException
extends InjectionException

    Indicates that a checked exception was thrown during creation of a bean.

    Author:
    Pete Muir, Gavin King
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      CreationException()
      CreationException(String message)
      CreationException(String message, Throwable cause)
      CreationException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • CreationException

        public CreationException()

      • CreationException

        public CreationException(String message)

      • CreationException

        public CreationException(Throwable cause)

      • CreationException

        public CreationException(String message,
                 Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Decorated (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Decorated

  • @Target(value={PARAMETER,FIELD})
@Retention(value=RUNTIME)
@Documented
@Qualifier
public @interface Decorated

    A decorator may inject metadata about the bean it is decorating

     @Decorator
 class TimestampLogger implements Logger {
     @Inject
     @Delegate
     @Any
     Logger logger;

     @Inject
     @Decorated
     Bean<Logger> bean;

     void log(String message) {
       ...
    }
 }
    Since:
    1.1
    Author:
    Pete Muir
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Default (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Default

  • @Target(value={TYPE,METHOD,PARAMETER,FIELD})
@Retention(value=RUNTIME)
@Documented
@Qualifier
public @interface Default

    The default qualifier type.

    If a bean does not explicitly declare a qualifier other than @Named, the bean has the qualifier @Default.

    If an injection point declares no qualifier, the injection point has exactly one qualifier, the default qualifier @Default.

    The following are equivalent:

     @ConversationScoped
 public class Order {

     private Product product;
     private User customer;

     @Inject
     public void init(@Selected Product product, User customer) {
         this.product = product;
         this.customer = customer;
     }

 }

     @Default
 @ConversationScoped
 public class Order {

     private Product product;
     private User customer;

     @Inject
     public void init(@Selected Product product, @Default User customer) {
         this.product = product;
         this.customer = customer;
     }

 }
    Author:
    Pete Muir, Gavin King
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Disposes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Disposes

  • @Target(value=PARAMETER)
@Retention(value=RUNTIME)
@Documented
public @interface Disposes

    Identifies the disposed parameter of a disposer method. May be applied to a parameter of a method of a bean class.

     public class UserDatabaseEntityManager {

     @Produces
     @ConversationScoped
     @UserDatabase
     public EntityManager create(EntityManagerFactory emf) {
         return emf.createEntityManager();
     }

     public void close(@Disposes @UserDatabase EntityManager em) {
         em.close();
     }

 }

     public class Resources {

     @PersistenceContext
     @Produces
     @UserDatabase
     private EntityManager em;

     public void close(@Disposes @UserDatabase EntityManager em) {
         em.close();
     }

 }

    A disposer method allows the application to perform customized cleanup of an object returned by a producer method or producer field.

    A disposer method must be a non-abstract method of a managed bean class or session bean class. A disposer method may be either static or non-static. If the bean is a session bean, the disposer method must be a business method of the EJB or a static method of the bean class.

    A bean may declare multiple disposer methods.

    Each disposer method must have exactly one disposed parameter, of the same type as the corresponding producer method or producer field return type. When searching for disposer methods for a producer method or producer field, the container considers the type and qualifiers of the disposed parameter. If a disposed parameter resolves to a producer method or producer field declared by the same bean class, the container must call this method when destroying any instance returned by that producer method or producer field.

    In addition to the disposed parameter, a disposer method may declare additional parameters, which may also specify qualifiers. These additional parameters are injection points.

     public void close(@Disposes @UserDatabase EntityManager em, Logger log) { ... }

    A disposer method may resolve to multiple producer methods or producer fields declared by the bean class, in which case the container must call it when destroying any instance returned by any of these producer methods or producer fields.

    Disposer methods are not inherited by bean subclasses.

    Interceptors and decorators may not declare disposer methods.

    Author:
    Gavin King, Pete Muir
    See Also:
    @Produces
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


IllegalProductException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject

Class IllegalProductException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.InjectionException
            • javax.enterprise.inject.IllegalProductException
  • All Implemented Interfaces:
    Serializable

    public class IllegalProductException
extends InjectionException

    Indicates that a producer method returned a null value or a producer field contained a null value, and the scope of the producer method or field was not Dependent.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      IllegalProductException()
      IllegalProductException(String message)
      IllegalProductException(String message, Throwable cause)
      IllegalProductException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • IllegalProductException

        public IllegalProductException()

      • IllegalProductException

        public IllegalProductException(String message,
                       Throwable cause)

      • IllegalProductException

        public IllegalProductException(String message)

      • IllegalProductException

        public IllegalProductException(Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InjectionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject

Class InjectionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.InjectionException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    CreationException, IllegalProductException, ResolutionException

    public class InjectionException
extends RuntimeException
    Indicates a problem relating to dependency injection.
    Author:
    Pete Muir
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      InjectionException()
      InjectionException(String message)
      InjectionException(String message, Throwable throwable)
      InjectionException(Throwable throwable)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InjectionException

        public InjectionException()

      • InjectionException

        public InjectionException(String message,
                  Throwable throwable)

      • InjectionException

        public InjectionException(String message)

      • InjectionException

        public InjectionException(Throwable throwable)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Instance (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject

Interface Instance<T>

  • Type Parameters:
    T - the required bean type
    All Superinterfaces:
    Iterable<T>, Provider<T>
    All Known Implementing Classes:
    CDI

    public interface Instance<T>
extends Iterable<T>, Provider<T>

    Allows the application to dynamically obtain instances of beans with a specified combination of required type and qualifiers.

    In certain situations, injection is not the most convenient way to obtain a contextual reference. For example, it may not be used when:

    • the bean type or qualifiers vary dynamically at runtime, or
    • depending upon the deployment, there may be no bean which satisfies the type and qualifiers, or
    • we would like to iterate over all beans of a certain type.

    In these situations, an instance of the Instance may be injected:

     @Inject
 Instance<PaymentProcessor> paymentProcessor;

    Any combination of qualifiers may be specified at the injection point:

     @Inject
 @PayBy(CHEQUE)
 Instance<PaymentProcessor> chequePaymentProcessor;

    Or, the @Any qualifier may be used, allowing the application to specify qualifiers dynamically:

     @Inject
 @Any
 Instance<PaymentProcessor> anyPaymentProcessor;

    Finally, the @New qualifier may be used, allowing the application to obtain a @New qualified bean:

     @Inject
 @New(ChequePaymentProcessor.class)
 Instance<PaymentProcessor> chequePaymentProcessor;

    For an injected Instance:

    • the required type is the type parameter specified at the injection point, and
    • the required qualifiers are the qualifiers specified at the injection point.

    The inherited Provider.get() method returns a contextual references for the unique bean that matches the required type and required qualifiers and is eligible for injection into the class into which the parent Instance was injected, or throws an UnsatisfiedResolutionException or AmbiguousResolutionException.

     PaymentProcessor pp = chequePaymentProcessor.get();

    The inherited Iterable.iterator() method returns an iterator over contextual references for beans that match the required type and required qualifiers and are eligible for injection into the class into which the parent Instance was injected.

     for (PaymentProcessor pp : anyPaymentProcessor)
     pp.test();
    Author:
    Gavin King
    See Also:
    Provider.get(), Iterable.iterator(), AnnotationLiteral, TypeLiteral

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy(T instance)
      On destroy(Object) being called, the container destroys the instance if the active context object for the scope type of the bean supports destroying bean instances.
      boolean isAmbiguous()
      Determines if there is more than one bean that matches the required type and qualifiers and is eligible for injection into the class into which the parent Instance was injected.
      boolean isUnsatisfied()
      Determines if there is no bean that matches the required type and qualifiers and is eligible for injection into the class into which the parent Instance was injected.
      Instance<T> select(Annotation... qualifiers)
      Obtains a child Instance for the given additional required qualifiers.
      <U extends T>
      Instance<U>             		select(Class<U> subtype, Annotation... qualifiers)
      Obtains a child Instance for the given required type and additional required qualifiers.
      <U extends T>
      Instance<U>             		select(TypeLiteral<U> subtype, Annotation... qualifiers)
      Obtains a child Instance for the given required type and additional required qualifiers.

      • Methods inherited from interface java.lang.Iterable

        iterator

      • Methods inherited from interface javax.inject.Provider

        get

    • Method Detail

      • select

        Instance<T> select(Annotation... qualifiers)

        Obtains a child Instance for the given additional required qualifiers.

        Parameters:
        qualifiers - the additional required qualifiers
        Returns:
        the child Instance
        Throws:
        IllegalArgumentException - if passed two instances of the same qualifier type, or an instance of an annotation that is not a qualifier type

      • select

        <U extends T> Instance<U> select(Class<U> subtype,
                               Annotation... qualifiers)

        Obtains a child Instance for the given required type and additional required qualifiers.

        Type Parameters:
        U - the required type
        Parameters:
        subtype - a Class representing the required type
        qualifiers - the additional required qualifiers
        Returns:
        the child Instance
        Throws:
        IllegalArgumentException - if passed two instances of the same qualifier type, or an instance of an annotation that is not a qualifier type

      • select

        <U extends T> Instance<U> select(TypeLiteral<U> subtype,
                               Annotation... qualifiers)

        Obtains a child Instance for the given required type and additional required qualifiers.

        Type Parameters:
        U - the required type
        Parameters:
        subtype - a TypeLiteral representing the required type
        qualifiers - the additional required qualifiers
        Returns:
        the child Instance
        Throws:
        IllegalArgumentException - if passed two instances of the same qualifier type, or an instance of an annotation that is not a qualifier type

      • isUnsatisfied

        boolean isUnsatisfied()

        Determines if there is no bean that matches the required type and qualifiers and is eligible for injection into the class into which the parent Instance was injected.

        Returns:
        true if there is no bean that matches the required type and qualifiers and is eligible for injection into the class into which the parent Instance was injected, or false otherwise.

      • isAmbiguous

        boolean isAmbiguous()

        Determines if there is more than one bean that matches the required type and qualifiers and is eligible for injection into the class into which the parent Instance was injected.

        Returns:
        true if there is more than one bean that matches the required type and qualifiers and is eligible for injection into the class into which the parent Instance was injected, or false otherwise.

      • destroy

        void destroy(T instance)

        On destroy(Object) being called, the container destroys the instance if the active context object for the scope type of the bean supports destroying bean instances. All normal scoped built-in contexts support destroying bean instances.

        The instance passed should either be a dependent scoped bean instance, or the client proxy for a normal scoped bean instance.

        Parameters:
        instance - the instance to destroy
        Throws:
        UnsupportedOperationException - if the active context object for the scope type of the bean does not support destroying bean instances
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Intercepted (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Intercepted

  • @Target(value={PARAMETER,FIELD})
@Retention(value=RUNTIME)
@Documented
@Qualifier
public @interface Intercepted

    An interceptor may inject metadata about the bean it is intercepting.

     @Transactional @@Interceptor
 public class TransactionInterceptor {

    @Inject @Intercepted Bean<?> bean;

    @AroundInvoke
    public Object manageTransaction(InvocationContext ctx) throws Exception { ... }

 }
    Since:
    1.1
    Author:
    Pete Muir
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.enterprise.inject (Java(TM) EE 7 Specification APIs)

javax.enterprise.inject

Interfaces

  • Instance

Exceptions

  • AmbiguousResolutionException
  • CreationException
  • IllegalProductException
  • InjectionException
  • ResolutionException
  • UnproxyableResolutionException
  • UnsatisfiedResolutionException

Annotation Types

  • Alternative
  • Any
  • Decorated
  • Default
  • Disposes
  • Intercepted
  • Model
  • New
  • Produces
  • Specializes
  • Stereotype
  • TransientReference
  • Typed
  • Vetoed


javax.enterprise.inject (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.inject

Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.

See: Description

  • Interface Summary
    Interface Description
    Instance<T>
    Allows the application to dynamically obtain instances of beans with a specified combination of required type and qualifiers.
  • Exception Summary
    Exception Description
    AmbiguousResolutionException
    Indicates that multiple beans match a certain combination of required type and required qualifiers and are eligible for injection into a certain class.
    CreationException
    Indicates that a checked exception was thrown during creation of a bean.
    IllegalProductException
    Indicates that a producer method returned a null value or a producer field contained a null value, and the scope of the producer method or field was not Dependent.
    InjectionException
    Indicates a problem relating to dependency injection.
    ResolutionException
    Indicates a problem relating to typesafe resolution.
    UnproxyableResolutionException
    Indicates that a contextual reference for a bean with a normal scope and a certain bean type cannot be obtained because the bean type cannot be proxied by the container.
    UnsatisfiedResolutionException
    Indicates that no bean matches a certain combination of required type and required qualifiers and is eligible for injection into a certain class.
  • Annotation Types Summary
    Annotation Type Description
    Alternative
    Specifies that a bean is an alternative.
    Any
    The built-in qualifier type.
    Decorated
    A decorator may inject metadata about the bean it is decorating
    Default
    The default qualifier type.
    Disposes
    Identifies the disposed parameter of a disposer method.
    Intercepted
    An interceptor may inject metadata about the bean it is intercepting.
    Model
    The built-in stereotype intended for use with beans that define the model layer of an MVC web application architecture such as JSF.
    New
    The New qualifier was deprecated in CDI 1.1.
    Produces
    Identifies a producer method or field.
    Specializes
    Indicates that a bean directly specializes another bean.
    Stereotype
    Specifies that an annotation type is a stereotype.
    TransientReference
    If a parameter annotated with @TransientReference resolves to a dependent scoped bean, then the bean will be destroyed after the invocation completes.
    Typed
    Restricts the bean types of a bean.
    Vetoed
    Veto the processing of the class.

Package javax.enterprise.inject Description

Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.

A bean is a source of contextual objects which define application state and/or logic. These objects are called contextual instances of the bean. The container creates and destroys these instances and associates them with the appropriate context. Contextual instances of a bean may be injected into other objects (including other bean instances) that execute in the same context, and may be used in Unified EL expressions that are evaluated in the same context.

The lifecycle of contextual instances is managed by the container according to the lifecycle context model. Annotations define the lifecycle of the bean and its interactions with other beans.

A bean comprises the following attributes:

  • A (nonempty) set of bean types
  • A (nonempty) set of qualifiers
  • A scope
  • Optionally, a bean EL name
  • A set of interceptor bindings
  • A bean implementation

Bean types

A bean type is a client-visible type of the bean. A bean may have multiple bean types. The following bean has bean types BookShop, Business, Shop<Book> and Object.

 public class BookShop
       extends Business
       implements Shop<Book> {
    ...
 }

Almost any Java type may be a bean type of a bean:

  • A bean type may be an interface, a concrete class or an abstract class, and may be declared final or have final methods.
  • A bean type may be a parameterized type with actual type parameters and type variables.
  • A bean type may be an array type. Two array types are considered identical only if the element type is identical.
  • A bean type may be a primitive type. Primitive types are considered to be identical to their corresponding wrapper types in java.lang.
  • A bean type may be a raw type.

A type variable is not a legal bean type. A parameterized type that contains a wildcard type parameter is not a legal bean type.

The bean types of a bean are determined automatically. However, the set of bean types may be resticted using the @Typed annotation.

Qualifiers

A qualifier represents some client-visible semantic associated with a type that is satisfied by some implementations of the type (and not by others). Qualifiers are applied to injection points to distinguish which implementation is required by the client.

 @Inject @Synchronous PaymentProcessor paymentProcessor;

A qualifier type is a Java annotation annotated @Qualifier. The qualifiers of a bean are declared by annotating the bean class or producer method or field with the qualifier types.

 @Synchronous @Reliable
 class SynchronousReliablePaymentProcessor
       implements PaymentProcessor {
    ...
 }

If a bean does not explicitly declare a qualifier other than @Named, the bean has the qualifier @Default.

Scope

All beans have a scope. The scope of a bean determines the lifecycle of its instances, and which instances of the bean are visible to instances of other beans.

A scope type is a Java annotation annotated @Scope or @NormalScope. The scope of a bean is defined by annotating the bean class or producer method or field with a scope type or with a stereotype that declares a default scope.

 @ConversationScoped
 public class Order { ... }

A bean class or producer method or field may specify at most one scope type annotation.

If the bean does not explicitly declare a scope or a stereotype with a default scope, the scope defaults to @Dependent.

Bean EL name

A bean may have a bean EL name. A bean with an EL name may be referred to by its name in Unified EL expressions. A valid bean EL name is a period-separated list of valid EL identifiers.

To specify the EL name of a bean, the qualifier @Named is applied to the bean class or producer method or field.

 @Named("currentOrder")
 public class Order { ... }
If the @Named annotation does not specify the value member, the EL name is defaulted.

Interceptor bindings

Interceptors may be bound to any managed bean that is not itself an interceptor or decorator or to any EJB session or message-driven bean. An interceptor that is annotated @Interceptor may be identified by its interceptor bindings.

 @Transactional @Interceptor
 public class TransactionInterceptor {
    @AroundInvoke
    public Object manageTransaction(InvocationContext ctx) { ... }
 }

An interceptor binding type is a Java annotation annotated @InterceptorBinding. An interceptor binding of a bean may be declared by annotating the bean class, or a method of the bean class, with an interceptor binding type or with a stereotype that declares the interceptor binding.

In the following example, the TransactionInterceptor will be applied at the class level, and therefore applies to all business methods of the class:

 @Transactional
 public class ShoppingCart { ... }

In this example, the TransactionInterceptor will be applied at the method level:

 public class ShoppingCart {
    @Transactional
    public void placeOrder() { ... }
 }

If a managed bean class is declared final, it may not have any interceptor bindings. If a managed bean has a non-static, non-private, final method, it may not have any class-level interceptor bindings, and that method may not have any method-level interceptor bindings.

Bean implementation

The container provides built-in support for injection and contextual lifecycle management of the following kinds of bean:

  • Managed beans
  • Session beans
  • Producer methods and fields
  • Resources (Java EE resources, persistence contexts, persistence units, remote EJBs and web services)

Managed beans

A managed bean is a bean that is implemented by a Java class. The basic lifecycle and semantics of managed beans are defined by the Managed Beans specification.

A top-level Java class is a managed bean if it is defined to be a managed bean by any other Java EE specification, or if it meets all of the following conditions:

  • It is not a non-static inner class.
  • It is a concrete class, or is annotated @Decorator.
  • It is not annotated with an EJB component-defining annotation or declared as an EJB bean class in ejb-jar.xml.
  • It does not implement Extension.
  • It has an appropriate constructor; either the class has a constructor with no parameters, or the class declares a constructor annotated @Inject.

All Java classes that meet these conditions are managed beans and thus no special declaration is required to define a managed bean. Optionally, a managed bean may be annotated ManagedBean.

If a managed bean has a public field, it must have scope @Dependent.

If the managed bean class is a generic type, it must have scope @Dependent.

Session beans

The basic lifecycle and semantics of EJB session beans are defined by the EJB specification.

  • A stateless session bean must belong to the @Dependent pseudo-scope.
  • A singleton bean must belong to either the @ApplicationScoped scope or to the @Dependent pseudo-scope.
  • A stateful session bean may have any scope.

If the session bean class is a generic type, it must have scope @Dependent.

If a session bean is a stateful session bean:

  • If the scope is @Dependent, the application may call any EJB remove method of a contextual instance of the session bean.
  • Otherwise, the application may not directly call any EJB remove method of any contextual instance of the session bean.

Producer methods and fields

A producer method or field acts as a source of objects to be injected, where:

  • the objects to be injected are not required to be instances of beans, or
  • the concrete type of the objects to be injected may vary at runtime, or
  • the objects require some custom initialization that is not performed by the bean constructor.

A producer method or field is a method or field of a bean class annotated @Produces.

A common pattern in generic code is a producer method that injects an InjectionPoint object.

Resources

A resource is a bean that represents a reference to a resource, persistence context, persistence unit, remote EJB or web service in the Java EE component environment.

A resource may be declared by specifying a Java EE component environment injection annotation as part of a producer field declaration.

  • For a Java EE resource, @Resource must be specified.
  • For a persistence context, @PersistenceContext must be specified.
  • For a persistence unit, @PersistenceUnit must be specified.
  • For a remote EJB, @EJB must be specified.
  • or a web service, @WebServiceRef must be specified.

The injection annotation specifies the metadata needed to obtain the resources, entity manager, entity manager factory, remote EJB instance or web service reference from the component environment.

 @Produces @WebServiceRef(lookup="java:app/service/PaymentService")
 PaymentService paymentService;

 @Produces @EJB(ejbLink="../their.jar#PaymentService")
 PaymentService paymentService;

 @Produces @Resource(lookup="java:global/env/jdbc/CustomerDatasource")
 @CustomerDatabase Datasource customerDatabase;

 @Produces @PersistenceContext(unitName="CustomerDatabase")
 @CustomerDatabase EntityManager customerDatabasePersistenceContext;

 @Produces @PersistenceUnit(unitName="CustomerDatabase")
 @CustomerDatabase EntityManagerFactory customerDatabasePersistenceUnit;

A resource may not have an EL name.

Enabled and disabled beans

A bean is said to be enabled if:

  • it is deployed in a bean archive, and
  • it is not a producer method or field of a disabled bean, and
  • it is not specialized by any other enabled bean, and either
  • it is not an alternative, or it is a selected alternative of at least one bean archive.

Otherwise, the bean is said to be disabled.

Inter-module injection

Beans and their clients may be deployed in modules in a module architecture such as the Java EE environment. In a module architecture, certain modules are considered bean archives. In the Java EE module architecture, any Java EE module or library is a module. The Java EE module or library is a bean archive if it contains a beans.xml file in the metadata directory.

A bean is available for injection in a certain module if:

  • the bean is not an interceptor or decorator,
  • the bean is enabled,
  • the bean is either not an alternative, or the module is a bean archive and the bean is a selected alternative of the bean archive, and
  • the bean class is required to be accessible to classes in the module, according to the class accessibility requirements of the module architecture.

Injection points

The following kinds of injection point exist:

  • When the container instantiates a bean class, it calls the bean constructor. The bean constructor is a constructor of the bean class. The bean constructor may be identified by annotating the constructor @javax.inject.Inject. If a bean class does not explicitly declare a constructor using @Inject, the constructor that accepts no parameters is the bean constructor. A bean constructor may have any number of parameters. All parameters of a bean constructor are injection points.
  • An injected field is a non-static, non-final field of a bean class, or of any Java EE component class supporting injection. An injected field may be declared by annotating the field @javax.inject.Inject.
  • An initializer method is a non-abstract, non-static, non-generic method of a bean class, or of any Java EE component class supporting injection. If the bean is a session bean, the initializer method is not required to be a business method of the session bean. An initializer method may be declared by annotating the method @javax.inject.Inject. An initializer method may have any number of parameters. All initializer method parameters are injection points.
  • Finally, parameters of producer methods, diposer methods and observer methods are injection points.

Dependency injection

A bean is assignable to a given injection point if:

  • The bean has a bean type that matches the type of the injection point. For this purpose, primitive types are considered to match their corresponding wrapper types in java.lang and array types are considered to match only if their element types are identical.
  • The bean has all the qualifiers of the injection point. If the injection point does not explicitly declare a qualifier, it has the default qualifier @Default.
  • The bean is eligible for injection into the class that declares the injection point.

A bean is eligible for injection into a given injection point if:

  • it is available for injection in the module that contains the class that declares the injection point, and
  • it is assignable to the injection point.

If more than one bean is eligible for injection to the injection point, the container attempts to resolve the ambiguity by eliminating all beans which are not alternatives, except for producer methods and fields of beans that are alternatives.

Certain legal bean types cannot be proxied by the container:

  • classes which don't have a non-private constructor with no parameters,
  • classes which are declared final or have final methods,
  • primitive types,
  • and array types.

An injection point whose declared type cannot be proxied by the container must not resolve to a bean with a normal scope.

EL name resolution

EL names are resolved when Unified EL expressions are evaluated. An EL name resolves to a bean if:

  • the bean has the given EL name, and
  • the bean is available for injection in the war containing the JSP or JSF page with the EL expression.

If an EL name resolves to more than one bean, the container attempts to resolve the ambiguity by eliminating all beans which are not alternatives, except for producer methods and fields of beans that are alternatives.

Enabled interceptors

By default, a bean archive has no enabled interceptors. An interceptor must be explicitly enabled by listing its bean class under the <interceptors> element of the beans.xml file of the bean archive. The order of the interceptor declarations determines the interceptor ordering. Interceptors which occur earlier in the list are called first.

An interceptor is bound to a bean if:

  • The bean has all the interceptor bindings of the interceptor.
  • The interceptor is enabled in the bean archive of the bean.

An interceptor instance is a dependent object of the object it intercepts.

See Also:
javax.enterprise.context, javax.inject, javax.interceptor, javax.decorator, javax.enterprise.event, Produces, Alternative
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.inject Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.inject

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.InjectionException
            • javax.enterprise.inject.CreationException
            • javax.enterprise.inject.IllegalProductException
            • javax.enterprise.inject.ResolutionException
              • javax.enterprise.inject.AmbiguousResolutionException
              • javax.enterprise.inject.UnproxyableResolutionException
              • javax.enterprise.inject.UnsatisfiedResolutionException

Interface Hierarchy

  • java.lang.Iterable<T>
    • javax.enterprise.inject.Instance<T> (also extends javax.inject.Provider<T>)
  • javax.inject.Provider<T>
    • javax.enterprise.inject.Instance<T> (also extends java.lang.Iterable<T>)

Annotation Type Hierarchy

  • javax.enterprise.inject.Vetoed (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Typed (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.TransientReference (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Stereotype (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Specializes (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Produces (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.New (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Model (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Intercepted (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Disposes (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Default (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Decorated (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Any (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Alternative (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Model (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Model

  • @Named
@RequestScoped
@Documented
@Stereotype
@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Model

    The built-in stereotype intended for use with beans that define the model layer of an MVC web application architecture such as JSF.

    Author:
    Gavin King
    See Also:
    Stereotype
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


New (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type New

  • @Target(value={FIELD,PARAMETER,METHOD,TYPE})
@Retention(value=RUNTIME)
@Documented
@Qualifier
public @interface New

    The New qualifier was deprecated in CDI 1.1. CDI applications are encouraged to inject Dependent scoped beans instead.

    The @New qualifier allows the application to obtain a new instance of a bean which is not bound to the declared scope, but has had dependency injection performed.

     @Produces @ConversationScoped
 @Special Order getSpecialOrder(@New(Order.class) Order order) {
    ...
    return order;
 }

    When the @New qualifier is specified at an injection point and no value member is explicitly specified, the container defaults the value to the declared type of the injection point. So the following injection point has qualifier @New(Order.class):

     @Produces @ConversationScoped
 @Special Order getSpecialOrder(@New Order order) { ... }
    Author:
    Gavin King, Pete Muir

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class<?> value
      Specifies the bean class of the new instance.

    • Element Detail

      • value

        public abstract Class<?> value

        Specifies the bean class of the new instance. The class must be the bean class of an enabled or disabled bean. The bean class need not be deployed in a bean archive.

        Defaults to the declared type of the injection point if not specified.

        Returns:
        the bean class of the new instance
        Default:
        javax.enterprise.inject.New.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Produces (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Produces

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface Produces

    Identifies a producer method or field. May be applied to a method or field of a bean class.

    A producer method must be a non-abstract method of a managed bean class or session bean class. A producer method may be either static or non-static. If the bean is a session bean, the producer method must be either a business method of the EJB or a static method of the bean class.

     public class Shop {
    @Produces @ApplicationScoped
    @Catalog @Named("catalog")
    List<Product> getProducts() { ... }
    ...
 }

    A producer field must be a field of a managed bean class or session bean class. A producer field may be either static or non-static. If the bean is a session bean, the producer field must be a static field of the bean class.

     public class Shop {
    @Produces @ApplicationScoped
    @Catalog @Named("catalog")
    List<Product> products = ...;
    ...
 }

    If a producer method sometimes returns a null value, or if a producer field sometimes contains a null value when accessed, then the producer method or field must have scope @Dependent.

    A producer method return type or producer field type may not be a type variable.

    If the producer method return type or producer field type is a parameterized type, it must specify an actual type parameter or type variable for each type parameter.

    If the producer method return type or producer field type is a parameterized type with a type variable, it must have scope @Dependent.

    A producer method may have any number of parameters. All producer method parameters are injection points.

     public class OrderFactory {

     @Produces
     @ConversationScoped
     public Order createCurrentOrder(Shop shop, @Selected Product product) {
         Order order = new Order(product, shop);
         return order;
     }

 }

    A bean may declare multiple producer methods or fields.

    Producer methods and fields are not inherited by bean subclasses.

    Interceptors and decorators may not declare producer methods or fields.

    Author:
    Gavin King, Pete Muir
    See Also:
    @Disposes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ResolutionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject

Class ResolutionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.InjectionException
            • javax.enterprise.inject.ResolutionException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    AmbiguousResolutionException, UnproxyableResolutionException, UnsatisfiedResolutionException

    public class ResolutionException
extends InjectionException
    Indicates a problem relating to typesafe resolution.
    Author:
    Gavin King
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ResolutionException()
      ResolutionException(String message)
      ResolutionException(String message, Throwable cause)
      ResolutionException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ResolutionException

        public ResolutionException()

      • ResolutionException

        public ResolutionException(String message,
                   Throwable cause)

      • ResolutionException

        public ResolutionException(String message)

      • ResolutionException

        public ResolutionException(Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Specializes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Specializes

  • @Target(value={TYPE,METHOD})
@Retention(value=RUNTIME)
@Documented
public @interface Specializes

    Indicates that a bean directly specializes another bean. May be applied to a bean class or producer method.

    If a bean directly specializes a second bean, it inherits:

    • all qualifiers of the second bean, and
    • the name, if any, of the second bean.

    If the second bean has a name, the bean may not declare a name using @Named. Furthermore, the bean must have all the bean types of the second bean.

    • If a bean class of a managed bean is annotated @Specializes , then the bean class must directly extend the bean class of a second managed bean. Then the first managed bean directly specializes the second managed bean.
    • If a bean class of a session bean is annotated @Specializes , then the bean class must directly extend the bean class of a second session bean. Then the first session bean directly specializes the second session bean.
    • If a producer method is annotated @Specializes, then it must be non-static and directly override another producer method. Then the first producer method directly specializes the second producer method.

    If a bean is specialized by any enabled bean, the first bean is disabled.

    Author:
    Gavin King, Pete Muir
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Stereotype (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Stereotype

  • @Retention(value=RUNTIME)
@Target(value=ANNOTATION_TYPE)
@Documented
public @interface Stereotype

    Specifies that an annotation type is a stereotype.

    In many systems, use of architectural patterns produces a set of recurring bean roles. A stereotype allows a framework developer to identify such a role and declare some common metadata for beans with that role in a central place.

    A bean may declare zero, one or multiple stereotypes, by applying the stereotype annotation to the bean class or producer method or field.

    A stereotype encapsulates any combination of:

    • a default scope, and
    • a set of interceptor bindings.

    The default scope of a stereotype is defined by annotating the stereotype with a scope type. A stereotype may declare at most one scope. If a bean explicitly declares a scope, any default scopes declared by its stereotypes are ignored.

     @RequestScoped
 @Stereotype
 @Target(TYPE)
 @Retention(RUNTIME)
 public @interface Action {
 }

    The interceptor bindings of a stereotype are defined by annotating the stereotype with the interceptor binding types. A stereotype may declare zero, one or multiple interceptor bindings. An interceptor binding declared by a stereotype is inherited by any bean that declares that stereotype.

     @RequestScoped
 @Secure
 @Transactional
 @Stereotype
 @Target(TYPE)
 @Retention(RUNTIME)
 public @interface Action {
 }

    A stereotype may also specify that:

    • all beans with the stereotype have defaulted bean EL names, or that
    • all beans with the stereotype are alternatives.

    A stereotype may declare an empty @Named annotation, which specifies that every bean with the stereotype has a defaulted name when a name is not explicitly specified by the bean.

     @RequestScoped
 @Named
 @Secure
 @Transactional
 @Stereotype
 @Target(TYPE)
 @Retention(RUNTIME)
 public @interface Action {
 }

    A stereotype may declare an @Alternative annotation, which specifies that every bean with the stereotype is an alternative.

     @Alternative
 @Stereotype
 @Target(TYPE)
 @Retention(RUNTIME)
 public @interface Mock {
 }

    A stereotype may declare other stereotypes. Stereotype declarations are transitive. A stereotype declared by a second stereotype is inherited by all beans and other stereotypes that declare the second stereotype.

    Author:
    Pete Muir, Gavin King
    See Also:
    the built-in stereotype @Model
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


TransientReference (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type TransientReference

  • @Target(value=PARAMETER)
@Retention(value=RUNTIME)
@Documented
public @interface TransientReference

    If a parameter annotated with @TransientReference resolves to a dependent scoped bean, then the bean will be destroyed after the invocation completes.

     public class OrderManager {

     @Inject
     public OrderManager(@TransientReference Order order) {
        ...

     }
 }
    Since:
    1.1
    Author:
    Pete Muir
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Typed (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Typed

  • @Target(value={FIELD,METHOD,TYPE})
@Retention(value=RUNTIME)
@Documented
public @interface Typed

    Restricts the bean types of a bean. May be applied to a bean class or producer method or field.

     @Typed(Shop.class)
 public class BookShop
       extends Business
       implements Shop<Book> {
    ...
 }

    When a @Typed annotation is specified, only the types whose classes are explicitly listed using the value member, along with Object, are bean types of the bean.

    Author:
    Pete Muir, Gavin King

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class<?>[] value
      Selects the bean types of the bean.

    • Element Detail

      • value

        public abstract Class<?>[] value

        Selects the bean types of the bean. Every class must correspond to a type in the unrestricted set of bean types of a bean.

        Returns:
        the classes corresponding to the bean types of the bean
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


UnproxyableResolutionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject

Class UnproxyableResolutionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.InjectionException
            • javax.enterprise.inject.ResolutionException
              • javax.enterprise.inject.UnproxyableResolutionException
  • All Implemented Interfaces:
    Serializable

    public class UnproxyableResolutionException
extends ResolutionException

    Indicates that a contextual reference for a bean with a normal scope and a certain bean type cannot be obtained because the bean type cannot be proxied by the container.

    Author:
    Pete Muir, Gavin King
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      UnproxyableResolutionException()
      UnproxyableResolutionException(String message)
      UnproxyableResolutionException(String message, Throwable throwable)
      UnproxyableResolutionException(Throwable throwable)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnproxyableResolutionException

        public UnproxyableResolutionException()

      • UnproxyableResolutionException

        public UnproxyableResolutionException(String message,
                              Throwable throwable)

      • UnproxyableResolutionException

        public UnproxyableResolutionException(String message)

      • UnproxyableResolutionException

        public UnproxyableResolutionException(Throwable throwable)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UnsatisfiedResolutionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject

Class UnsatisfiedResolutionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.InjectionException
            • javax.enterprise.inject.ResolutionException
              • javax.enterprise.inject.UnsatisfiedResolutionException
  • All Implemented Interfaces:
    Serializable

    public class UnsatisfiedResolutionException
extends ResolutionException

    Indicates that no bean matches a certain combination of required type and required qualifiers and is eligible for injection into a certain class.

    Author:
    Pete Muir, Gavin King
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      UnsatisfiedResolutionException()
      UnsatisfiedResolutionException(String message)
      UnsatisfiedResolutionException(String message, Throwable throwable)
      UnsatisfiedResolutionException(Throwable throwable)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnsatisfiedResolutionException

        public UnsatisfiedResolutionException()

      • UnsatisfiedResolutionException

        public UnsatisfiedResolutionException(String message,
                              Throwable throwable)

      • UnsatisfiedResolutionException

        public UnsatisfiedResolutionException(String message)

      • UnsatisfiedResolutionException

        public UnsatisfiedResolutionException(Throwable throwable)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.enterprise.inject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.inject

  • Packages that use javax.enterprise.inject
    Package Description
    javax.decorator
    Annotations relating to decorators.
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.
    javax.enterprise.inject.spi
    The portable extension integration SPI.
  • Classes in javax.enterprise.inject used by javax.decorator
    Class and Description
    Stereotype
    Specifies that an annotation type is a stereotype.
  • Classes in javax.enterprise.inject used by javax.enterprise.inject
    Class and Description
    InjectionException
    Indicates a problem relating to dependency injection.
    Instance
    Allows the application to dynamically obtain instances of beans with a specified combination of required type and qualifiers.
    ResolutionException
    Indicates a problem relating to typesafe resolution.
    Stereotype
    Specifies that an annotation type is a stereotype.
  • Classes in javax.enterprise.inject used by javax.enterprise.inject.spi
    Class and Description
    Instance
    Allows the application to dynamically obtain instances of beans with a specified combination of required type and qualifiers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Vetoed (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject

Annotation Type Vetoed

  • @Target(value={TYPE,PACKAGE})
@Retention(value=RUNTIME)
@Documented
public @interface Vetoed

    Veto the processing of the class. Any beans or observer methods defined by this class will not be installed.

    When placed on package, all beans in the package are prevented from being installed. If packages are split across jars, non-portable behavior results. An application can prevent packages being split across jars by sealing the package.

    No container lifecycle events are fired for classes annotated Vetoed.

    Since:
    1.1
    Author:
    Stuart Douglas
    See Also:
    The Extension Mechanism Architecture
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.enterprise.inject.Alternative (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Alternative

No usage of javax.enterprise.inject.Alternative
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.AmbiguousResolutionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.AmbiguousResolutionException

No usage of javax.enterprise.inject.AmbiguousResolutionException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Any (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Any

No usage of javax.enterprise.inject.Any
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.CreationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.CreationException

No usage of javax.enterprise.inject.CreationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Decorated (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Decorated

No usage of javax.enterprise.inject.Decorated
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Default (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Default

No usage of javax.enterprise.inject.Default
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Disposes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Disposes

No usage of javax.enterprise.inject.Disposes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.IllegalProductException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.IllegalProductException

No usage of javax.enterprise.inject.IllegalProductException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.InjectionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.InjectionException

  • Packages that use InjectionException
    Package Description
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.

    • Uses of InjectionException in javax.enterprise.inject

      Subclasses of InjectionException in javax.enterprise.inject
      Modifier and Type Class and Description
      class  AmbiguousResolutionException
      Indicates that multiple beans match a certain combination of required type and required qualifiers and are eligible for injection into a certain class.
      class  CreationException
      Indicates that a checked exception was thrown during creation of a bean.
      class  IllegalProductException
      Indicates that a producer method returned a null value or a producer field contained a null value, and the scope of the producer method or field was not Dependent.
      class  ResolutionException
      Indicates a problem relating to typesafe resolution.
      class  UnproxyableResolutionException
      Indicates that a contextual reference for a bean with a normal scope and a certain bean type cannot be obtained because the bean type cannot be proxied by the container.
      class  UnsatisfiedResolutionException
      Indicates that no bean matches a certain combination of required type and required qualifiers and is eligible for injection into a certain class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Intercepted (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Intercepted

No usage of javax.enterprise.inject.Intercepted
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Model (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Model

No usage of javax.enterprise.inject.Model
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.New (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.New

No usage of javax.enterprise.inject.New
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Produces (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Produces

No usage of javax.enterprise.inject.Produces
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.ResolutionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.ResolutionException

  • Packages that use ResolutionException
    Package Description
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.

    • Uses of ResolutionException in javax.enterprise.inject

      Subclasses of ResolutionException in javax.enterprise.inject
      Modifier and Type Class and Description
      class  AmbiguousResolutionException
      Indicates that multiple beans match a certain combination of required type and required qualifiers and are eligible for injection into a certain class.
      class  UnproxyableResolutionException
      Indicates that a contextual reference for a bean with a normal scope and a certain bean type cannot be obtained because the bean type cannot be proxied by the container.
      class  UnsatisfiedResolutionException
      Indicates that no bean matches a certain combination of required type and required qualifiers and is eligible for injection into a certain class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Specializes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Specializes

No usage of javax.enterprise.inject.Specializes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Stereotype (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Stereotype

  • Packages that use Stereotype
    Package Description
    javax.decorator
    Annotations relating to decorators.
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.

    • Uses of Stereotype in javax.decorator

      Classes in javax.decorator with annotations of type Stereotype
      Modifier and Type Class and Description
      interface  Decorator
      Specifies that a class is a decorator.

    • Uses of Stereotype in javax.enterprise.inject

      Classes in javax.enterprise.inject with annotations of type Stereotype
      Modifier and Type Class and Description
      interface  Model
      The built-in stereotype intended for use with beans that define the model layer of an MVC web application architecture such as JSF.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.TransientReference (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.TransientReference

No usage of javax.enterprise.inject.TransientReference
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Typed (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Typed

No usage of javax.enterprise.inject.Typed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.UnproxyableResolutionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.UnproxyableResolutionException

No usage of javax.enterprise.inject.UnproxyableResolutionException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.UnsatisfiedResolutionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.UnsatisfiedResolutionException

No usage of javax.enterprise.inject.UnsatisfiedResolutionException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.Vetoed (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.Vetoed

No usage of javax.enterprise.inject.Vetoed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.Instance (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.Instance

  • Packages that use Instance
    Package Description
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Instance in javax.enterprise.inject

      Methods in javax.enterprise.inject that return Instance
      Modifier and Type Method and Description
      Instance<T> Instance.select(Annotation... qualifiers)
      Obtains a child Instance for the given additional required qualifiers.
      <U extends T>
      Instance<U>             		Instance.select(Class<U> subtype, Annotation... qualifiers)
      Obtains a child Instance for the given required type and additional required qualifiers.
      <U extends T>
      Instance<U>             		Instance.select(TypeLiteral<U> subtype, Annotation... qualifiers)
      Obtains a child Instance for the given required type and additional required qualifiers.

    • Uses of Instance in javax.enterprise.inject.spi

      Classes in javax.enterprise.inject.spi that implement Instance
      Modifier and Type Class and Description
      class  CDI<T>
      Provides access to the current container.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AfterBeanDiscovery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface AfterBeanDiscovery

  • public interface AfterBeanDiscovery

    The event type of the second event fired by the container when it has fully completed the bean discovery process, validated that there are no definition errors relating to the discovered beans, and registered Bean and ObserverMethod objects for the discovered beans, but before detecting deployment problems.

    A portable extension may take advantage of this event to register beans, interceptors, decorators, observer methods and custom context objects with the container.

         void afterBeanDiscovery(@Observes AfterBeanDiscovery event, BeanManager manager) { ... }

    If any observer method of the AfterBeanDiscovery event throws an exception, the exception is treated as a definition error by the container.

    Author:
    David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addBean(Bean<?> bean)
      Fires an event of type ProcessBean containing the given Bean and then registers the Bean with the container, thereby making it available for injection into other beans.
      void addContext(Context context)
      Registers a custom Context object with the container.
      void addDefinitionError(Throwable t)
      Registers a definition error with the container, causing the container to abort deployment after all observers have been notified.
      void addObserverMethod(ObserverMethod<?> observerMethod)
      Fires an event of type ProcessObserverMethod containing the given ObserverMethod and then registers the ObserverMethod with the container, thereby making it available for event notifications.
      <T> AnnotatedType<T> getAnnotatedType(Class<T> type, String id)
      Obtain the AnnotatedType that may be used to read the annotations of the given class or interface as defined during container initialization.
      <T> Iterable<AnnotatedType<T>> getAnnotatedTypes(Class<T> type)
      Obtain the AnnotatedTypes that may be used to read the annotations of the given class or interface as defined during container initialization.

    • Method Detail

      • addDefinitionError

        void addDefinitionError(Throwable t)
        Registers a definition error with the container, causing the container to abort deployment after all observers have been notified.
        Parameters:
        t - The definition error as a Throwable

      • addBean

        void addBean(Bean<?> bean)
        Fires an event of type ProcessBean containing the given Bean and then registers the Bean with the container, thereby making it available for injection into other beans. The given Bean may implement Interceptor or Decorator.
        Parameters:
        bean - The bean to add to the deployment

      • addObserverMethod

        void addObserverMethod(ObserverMethod<?> observerMethod)
        Fires an event of type ProcessObserverMethod containing the given ObserverMethod and then registers the ObserverMethod with the container, thereby making it available for event notifications.
        Parameters:
        observerMethod - The custom observer method to add to the deployment

      • addContext

        void addContext(Context context)
        Registers a custom Context object with the container.
        Parameters:
        context - The custom context to add to the deployment

      • getAnnotatedType

        <T> AnnotatedType<T> getAnnotatedType(Class<T> type,
                                    String id)
        Obtain the AnnotatedType that may be used to read the annotations of the given class or interface as defined during container initialization.
        Type Parameters:
        T - the class or interface
        Parameters:
        type - the Class object
        id - the type identifier. If null, the fully qualifier class name of type is used
        Returns:
        the AnnotatedType
        Since:
        1.1

      • getAnnotatedTypes

        <T> Iterable<AnnotatedType<T>> getAnnotatedTypes(Class<T> type)
        Obtain the AnnotatedTypes that may be used to read the annotations of the given class or interface as defined during container initialization.
        Type Parameters:
        T - the class or interface
        Parameters:
        type - the Class object
        Returns:
        the AnnotatedTypes
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AfterDeploymentValidation (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface AfterDeploymentValidation

  • public interface AfterDeploymentValidation

    The event type of the third event fired by the container after it has validated that there are no deployment problems and before creating contexts or processing requests. If any observer method of the AfterDeploymentValidation event throws an exception, the exception is treated as a deployment problem by the container.

    No requests will be processed by the deployment until all observers of this event return.

    Author:
    David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addDeploymentProblem(Throwable t)
      Registers a deployment problem with the container, causing the container to abort deployment after all observers have been notified.

    • Method Detail

      • addDeploymentProblem

        void addDeploymentProblem(Throwable t)
        Registers a deployment problem with the container, causing the container to abort deployment after all observers have been notified.
        Parameters:
        t - The deployment problem as a Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AfterTypeDiscovery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface AfterTypeDiscovery

  • public interface AfterTypeDiscovery

    This event type is thrown by the container after type discovery is complete. If any observer method of the AfterTypeDiscovery event throws an exception, the exception is treated as a definition error by the container.

    Any observer of this event is permitted to add classes to, or remove classes from, the list of alternatives, list of interceptors or list of decorators. The container will use the final values of these lists, after all observers have been called, to determine the enabled alternatives, interceptors, and decorators for application.

    Since:
    1.1
    Author:
    Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addAnnotatedType(AnnotatedType<?> type, String id)
      Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.
      List<Class<?>> getAlternatives()
      List<Class<?>> getDecorators()
      List<Class<?>> getInterceptors()

    • Method Detail

      • getAlternatives

        List<Class<?>> getAlternatives()
        Returns:
        the ordered list of enabled alternatives of the bean deployment archive

      • getInterceptors

        List<Class<?>> getInterceptors()
        Returns:
        the ordered list of enabled interceptors of the bean deployment archive.

      • getDecorators

        List<Class<?>> getDecorators()
        Returns:
        the ordered list of enabled decorators of the bean deployment archive

      • addAnnotatedType

        void addAnnotatedType(AnnotatedType<?> type,
                    String id)

        Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.

        This method allows multiple annotated types, based on the same underlying type, to be defined. AnnotatedTypes discovered by the container use the fully qualified class name of AnnotatedType.getJavaClass() to identify the type.

        AfterBeanDiscovery.getAnnotatedType(Class, String) and AfterBeanDiscovery.getAnnotatedTypes(Class) allows annotated types to be obtained by identifier.

        Parameters:
        type - The AnnotatedType to add for later scanning
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Annotated (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface Annotated

  • All Known Subinterfaces:
    AnnotatedCallable<X>, AnnotatedConstructor<X>, AnnotatedField<X>, AnnotatedMember<X>, AnnotatedMethod<X>, AnnotatedParameter<X>, AnnotatedType<X>

    public interface Annotated

    Represents a Java program element that can be annotated.

    Author:
    Gavin King, Pete Muir, Clint Popetz
    See Also:
    AnnotatedElement

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T extends Annotation>
      T             		getAnnotation(Class<T> annotationType)
      Get program element annotation of a certain annotation type.
      Set<Annotation> getAnnotations()
      Get all annotations of the program element.
      Type getBaseType()
      Get the type of the annotated program element.
      Set<Type> getTypeClosure()
      Get all types to which the base type should be considered assignable.
      boolean isAnnotationPresent(Class<? extends Annotation> annotationType)
      Determine if the program element has an annotation of a certain annotation type.

    • Method Detail

      • getBaseType

        Type getBaseType()

        Get the type of the annotated program element.

        Returns:
        the type of the annotated program element

      • getTypeClosure

        Set<Type> getTypeClosure()

        Get all types to which the base type should be considered assignable.

        Returns:
        a set of all types to which the base type should be considered assignable

      • getAnnotation

        <T extends Annotation> T getAnnotation(Class<T> annotationType)

        Get program element annotation of a certain annotation type.

        Type Parameters:
        T - the type of the annotation
        Parameters:
        annotationType - the class of the annotation type
        Returns:
        the program element annotation of the given annotation type, or a null value

      • getAnnotations

        Set<Annotation> getAnnotations()

        Get all annotations of the program element.

        Returns:
        all annotations of the program element, or an empty set if no annotations are present

      • isAnnotationPresent

        boolean isAnnotationPresent(Class<? extends Annotation> annotationType)

        Determine if the program element has an annotation of a certain annotation type.

        Parameters:
        annotationType - the annotation type to check for
        Returns:
        true if the program element has an annotation of the given annotation type, or false otherwise
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AnnotatedCallable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface AnnotatedCallable<X>

  • Type Parameters:
    X - the declaring type
    All Superinterfaces:
    Annotated, AnnotatedMember<X>
    All Known Subinterfaces:
    AnnotatedConstructor<X>, AnnotatedMethod<X>

    public interface AnnotatedCallable<X>
extends AnnotatedMember<X>

    Represents a callable member of a Java type.

    Author:
    Gavin King, Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<AnnotatedParameter<X>> getParameters()
      Get the parameters of the callable member.

      • Methods inherited from interface javax.enterprise.inject.spi.AnnotatedMember

        getDeclaringType, getJavaMember, isStatic

      • Methods inherited from interface javax.enterprise.inject.spi.Annotated

        getAnnotation, getAnnotations, getBaseType, getTypeClosure, isAnnotationPresent

    • Method Detail

      • getParameters

        List<AnnotatedParameter<X>> getParameters()

        Get the parameters of the callable member.

        Returns:
        the parameters
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AnnotatedConstructor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface AnnotatedConstructor<X>

  • Type Parameters:
    X - the declaring class
    All Superinterfaces:
    Annotated, AnnotatedCallable<X>, AnnotatedMember<X>

    public interface AnnotatedConstructor<X>
extends AnnotatedCallable<X>

    Represents a constructor of a Java class.

    Author:
    Gavin King, Pete Muir
    See Also:
    Constructor

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Constructor<X> getJavaMember()
      Get the underlying Constructor.

      • Methods inherited from interface javax.enterprise.inject.spi.AnnotatedCallable

        getParameters

      • Methods inherited from interface javax.enterprise.inject.spi.AnnotatedMember

        getDeclaringType, isStatic

      • Methods inherited from interface javax.enterprise.inject.spi.Annotated

        getAnnotation, getAnnotations, getBaseType, getTypeClosure, isAnnotationPresent

    • Method Detail

      • getJavaMember

        Constructor<X> getJavaMember()

        Get the underlying Constructor.

        Specified by:
        getJavaMember in interface AnnotatedMember<X>
        Returns:
        the constructor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AnnotatedField (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface AnnotatedField<X>

  • Type Parameters:
    X - the declaring type
    All Superinterfaces:
    Annotated, AnnotatedMember<X>

    public interface AnnotatedField<X>
extends AnnotatedMember<X>

    Represents a field of a Java class.

    Author:
    Gavin King, Pete Muir
    See Also:
    Field

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Field getJavaMember()
      Get the underlying Field.

      • Methods inherited from interface javax.enterprise.inject.spi.AnnotatedMember

        getDeclaringType, isStatic

      • Methods inherited from interface javax.enterprise.inject.spi.Annotated

        getAnnotation, getAnnotations, getBaseType, getTypeClosure, isAnnotationPresent

    • Method Detail

      • getJavaMember

        Field getJavaMember()

        Get the underlying Field.

        Specified by:
        getJavaMember in interface AnnotatedMember<X>
        Returns:
        the Field
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AnnotatedMember (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface AnnotatedMember<X>

  • Type Parameters:
    X - the declaring type
    All Superinterfaces:
    Annotated
    All Known Subinterfaces:
    AnnotatedCallable<X>, AnnotatedConstructor<X>, AnnotatedField<X>, AnnotatedMethod<X>

    public interface AnnotatedMember<X>
extends Annotated

    Represents a member of a Java type.

    Author:
    Gavin King, Pete Muir
    See Also:
    Member

    • Method Summary

      Methods
      Modifier and Type Method and Description
      AnnotatedType<X> getDeclaringType()
      Get the type which defines this member.
      Member getJavaMember()
      Get the underlying Member.
      boolean isStatic()
      Determines if the member is static.

      • Methods inherited from interface javax.enterprise.inject.spi.Annotated

        getAnnotation, getAnnotations, getBaseType, getTypeClosure, isAnnotationPresent

    • Method Detail

      • getJavaMember

        Member getJavaMember()

        Get the underlying Member.

        Returns:
        the Member

      • isStatic

        boolean isStatic()

        Determines if the member is static.

        Returns:
        true if the member is static

      • getDeclaringType

        AnnotatedType<X> getDeclaringType()

        Get the type which defines this member.

        Returns:
        the type which defines this member
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AnnotatedMethod (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface AnnotatedMethod<X>

  • Type Parameters:
    X - the declaring type
    All Superinterfaces:
    Annotated, AnnotatedCallable<X>, AnnotatedMember<X>

    public interface AnnotatedMethod<X>
extends AnnotatedCallable<X>

    Represents a method of a Java type.

    Author:
    Gavin King, Pete Muir
    See Also:
    Method

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Method getJavaMember()
      Get the underlying Method.

      • Methods inherited from interface javax.enterprise.inject.spi.AnnotatedCallable

        getParameters

      • Methods inherited from interface javax.enterprise.inject.spi.AnnotatedMember

        getDeclaringType, isStatic

      • Methods inherited from interface javax.enterprise.inject.spi.Annotated

        getAnnotation, getAnnotations, getBaseType, getTypeClosure, isAnnotationPresent

    • Method Detail

      • getJavaMember

        Method getJavaMember()

        Get the underlying Method.

        Specified by:
        getJavaMember in interface AnnotatedMember<X>
        Returns:
        the Method
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AnnotatedParameter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface AnnotatedParameter<X>

  • Type Parameters:
    X - the type that declares the method or constructor
    All Superinterfaces:
    Annotated

    public interface AnnotatedParameter<X>
extends Annotated

    Represents a parameter of a method or constructor.

    Author:
    Gavin King, Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      AnnotatedCallable<X> getDeclaringCallable()
      Get the declaring method or constructor.
      int getPosition()
      Get the position of the parameter in the method or constructor argument list.

      • Methods inherited from interface javax.enterprise.inject.spi.Annotated

        getAnnotation, getAnnotations, getBaseType, getTypeClosure, isAnnotationPresent

    • Method Detail

      • getPosition

        int getPosition()

        Get the position of the parameter in the method or constructor argument list.

        Returns:
        the position of the parameter

      • getDeclaringCallable

        AnnotatedCallable<X> getDeclaringCallable()

        Get the declaring method or constructor.

        Returns:
        the declaring callable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AnnotatedType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface AnnotatedType<X>

  • Type Parameters:
    X - the type
    All Superinterfaces:
    Annotated

    public interface AnnotatedType<X>
extends Annotated

    Represents a Java class or interface.

    Author:
    Gavin King, Pete Muir
    See Also:
    Class

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<AnnotatedConstructor<X>> getConstructors()
      Get the constructors of the type.
      Set<AnnotatedField<? super X>> getFields()
      Get the fields of the type.
      Class<X> getJavaClass()
      Get the underlying Class.
      Set<AnnotatedMethod<? super X>> getMethods()
      Get the methods of the type.

      • Methods inherited from interface javax.enterprise.inject.spi.Annotated

        getAnnotation, getAnnotations, getBaseType, getTypeClosure, isAnnotationPresent

    • Method Detail

      • getJavaClass

        Class<X> getJavaClass()

        Get the underlying Class.

        Returns:
        the Class

      • getConstructors

        Set<AnnotatedConstructor<X>> getConstructors()

        Get the constructors of the type. If an empty set is returned, a default constructor with no parameters will be assumed.

        Returns:
        the constructors, or an empty set if none are defined

      • getMethods

        Set<AnnotatedMethod<? super X>> getMethods()

        Get the methods of the type.

        Returns:
        the methods, or an empty set if none are defined

      • getFields

        Set<AnnotatedField<? super X>> getFields()

        Get the fields of the type.

        Returns:
        the fields, or an empty set if none are defined
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Bean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface Bean<T>

  • Type Parameters:
    T - the class of the bean instance
    All Superinterfaces:
    BeanAttributes<T>, Contextual<T>
    All Known Subinterfaces:
    Decorator<T>, Interceptor<T>

    public interface Bean<T>
extends Contextual<T>, BeanAttributes<T>

    Represents an enabled bean. This interface defines everything the container needs to manage instances of the bean.

    Author:
    Gavin King, David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getBeanClass()
      The bean class of the managed bean or session bean or of the bean that declares the producer method or field.
      Set<InjectionPoint> getInjectionPoints()
      Obtains the InjectionPoint objects representing injection points of the bean, that will be validated by the container at initialization time.
      boolean isNullable()
      Determines if Contextual.create(CreationalContext) sometimes return a null value.

      • Methods inherited from interface javax.enterprise.context.spi.Contextual

        create, destroy

      • Methods inherited from interface javax.enterprise.inject.spi.BeanAttributes

        getName, getQualifiers, getScope, getStereotypes, getTypes, isAlternative

    • Method Detail

      • getBeanClass

        Class<?> getBeanClass()
        The bean class of the managed bean or session bean or of the bean that declares the producer method or field.
        Returns:
        the bean class

      • getInjectionPoints

        Set<InjectionPoint> getInjectionPoints()
        Obtains the InjectionPoint objects representing injection points of the bean, that will be validated by the container at initialization time.
        Returns:
        the set of injection points of the bean

      • isNullable

        boolean isNullable()

        Determines if Contextual.create(CreationalContext) sometimes return a null value.

        As of CDI 1.1 this method is deprecated and can safely always return false.

        Returns:
        true if the create() method may return a null value, and false otherwise
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BeanAttributes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface BeanAttributes<T>

  • Type Parameters:
    T - the class of the bean instance
    All Known Subinterfaces:
    Bean<T>, Decorator<T>, Interceptor<T>

    public interface BeanAttributes<T>
    The BeanAttributes interface exposes the basic attributes of a bean.
    Since:
    1.1
    Author:
    Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Obtains the EL name of a bean, if it has one.
      Set<Annotation> getQualifiers()
      Obtains the qualifiers of the bean.
      Class<? extends Annotation> getScope()
      Obtains the scope of the bean.
      Set<Class<? extends Annotation>> getStereotypes()
      Obtains the stereotypes of the bean.
      Set<Type> getTypes()
      Obtains the bean types of the bean.
      boolean isAlternative()
      Determines if the bean is an alternative.

    • Method Detail

      • getTypes

        Set<Type> getTypes()
        Obtains the bean types of the bean.
        Returns:
        the bean types

      • getQualifiers

        Set<Annotation> getQualifiers()
        Obtains the qualifiers of the bean.
        Returns:
        the qualifiers

      • getScope

        Class<? extends Annotation> getScope()
        Obtains the scope of the bean.
        Returns:
        the scope

      • getName

        String getName()
        Obtains the EL name of a bean, if it has one.
        Returns:
        the EL name

      • getStereotypes

        Set<Class<? extends Annotation>> getStereotypes()
        Obtains the stereotypes of the bean.
        Returns:
        the set of stereotypes

      • isAlternative

        boolean isAlternative()
        Determines if the bean is an alternative.
        Returns:
        true if the bean is an alternative, and false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BeanManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface BeanManager

  • public interface BeanManager

    Allows a portable extension to interact directly with the container. Provides operations for obtaining contextual references for beans, along with many other operations of use to portable extensions.

    Any bean may obtain an instance of BeanManager by injecting it:

     @Inject
 BeanManager manager;

    Java EE components may obtain an instance of BeanManager from JNDI by looking up the name java:comp/BeanManager.

    Any operation of BeanManager may be called at any time during the execution of the application.

    Author:
    Gavin King, Pete Muir, Clint Popetz, David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean areInterceptorBindingsEquivalent(Annotation interceptorBinding1, Annotation interceptorBinding2)
      Determine if two interceptor bindings are considered equivalent for the purposes of typesafe resolution, taking into account any members annotated with Nonbinding.
      boolean areQualifiersEquivalent(Annotation qualifier1, Annotation qualifier2)
      Determine if two qualifiers are considered equivalent for the purposes of typesafe resolution, taking into account any members annotated with Nonbinding.
      <T> AnnotatedType<T> createAnnotatedType(Class<T> type)
      Obtain an AnnotatedType that may be used to read the annotations of the given class or interface.
      <T> Bean<T> createBean(BeanAttributes<T> attributes, Class<T> beanClass, InjectionTargetFactory<T> injectionTargetFactory)
      Obtains a Bean for the given BeanAttributes, bean class and InjectionTarget.
      <T,X> Bean<T> createBean(BeanAttributes<T> attributes, Class<X> beanClass, ProducerFactory<X> producerFactory)
      Obtains a Bean for the given BeanAttributes, bean class and Producer.
      BeanAttributes<?> createBeanAttributes(AnnotatedMember<?> type)
      Obtains a BeanAttributes for the given AnnotatedType.
      <T> BeanAttributes<T> createBeanAttributes(AnnotatedType<T> type)
      Obtains a BeanAttributes for the given AnnotatedType.
      <T> CreationalContext<T> createCreationalContext(Contextual<T> contextual)
      Obtain an instance of a CreationalContext for the given contextual type, or for a non-contextual object.
      InjectionPoint createInjectionPoint(AnnotatedField<?> field)
      Obtains a container provided implementation of InjectionPoint for the given AnnotatedField.
      InjectionPoint createInjectionPoint(AnnotatedParameter<?> parameter)
      Obtains a container provided implementation of InjectionPoint for the given AnnotatedParameter.
      <T> InjectionTarget<T> createInjectionTarget(AnnotatedType<T> type)
      Obtains an InjectionTarget for the given AnnotatedType.
      void fireEvent(Object event, Annotation... qualifiers)
      Fire an event and notify observers.
      Set<Bean<?>> getBeans(String name)
      Return the set of beans which have the given EL name and are available for injection in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained, according to the rules of EL name resolution.
      Set<Bean<?>> getBeans(Type beanType, Annotation... qualifiers)
      Return the set of beans which have the given required type and qualifiers and are available for injection in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained, according to the rules of typesafe resolution.
      Context getContext(Class<? extends Annotation> scopeType)
      Obtains an active context object for the given scope .
      ELResolver getELResolver()
      Returns a ELResolver that resolves beans by EL name.
      <T extends Extension>
      T             		getExtension(Class<T> extensionClass)
      Obtains the container's instance of an Extension class declared in META-INF/services.
      Object getInjectableReference(InjectionPoint ij, CreationalContext<?> ctx)
      Obtains an injectable reference for a certain injection point.
      <T> InjectionTargetFactory<T> getInjectionTargetFactory(AnnotatedType<T> annotatedType)
      An implementation of InjectionTargetFactory that provides container created InjectionTarget instances.
      Set<Annotation> getInterceptorBindingDefinition(Class<? extends Annotation> bindingType)
      Obtains the set of meta-annotations for a certain interceptor binding type .
      int getInterceptorBindingHashCode(Annotation interceptorBinding)
      Determine the hash code of an interceptor binding, using the JDK algorithm for determining an annotation hash code, ignoring any members annotated with Nonbinding.
      Bean<?> getPassivationCapableBean(String id)
      Returns the PassivationCapable bean with the given identifier.
      <X> ProducerFactory<X> getProducerFactory(AnnotatedField<? super X> field, Bean<X> declaringBean)
      An implementation of ProducerFactory that provides container created Producer instances for the given field.
      <X> ProducerFactory<X> getProducerFactory(AnnotatedMethod<? super X> method, Bean<X> declaringBean)
      An implementation of ProducerFactory that provides container created Producer instances for the given method.
      int getQualifierHashCode(Annotation qualifier)
      Determine the hash code of a qualifier, using the JDK algorithm for determining an annotation hash code, ignoring any members annotated with Nonbinding.
      Object getReference(Bean<?> bean, Type beanType, CreationalContext<?> ctx)
      Obtains a contextual reference for a certain bean and a certain bean type of the bean.
      Set<Annotation> getStereotypeDefinition(Class<? extends Annotation> stereotype)
      Obtains meta-annotations for a certain stereotype.
      boolean isInterceptorBinding(Class<? extends Annotation> annotationType)
      Test the given annotation type to determine if it is an interceptor binding type .
      boolean isNormalScope(Class<? extends Annotation> annotationType)
      Test the given annotation type to determine if it is a normal scope type.
      boolean isPassivatingScope(Class<? extends Annotation> annotationType)
      Test the given annotation type to determine if it is a passivating scope type.
      boolean isQualifier(Class<? extends Annotation> annotationType)
      Test the given annotation type to determine if it is a qualifier type.
      boolean isScope(Class<? extends Annotation> annotationType)
      Test the given annotation type to determine if it is a scope type.
      boolean isStereotype(Class<? extends Annotation> annotationType)
      Test the given annotation type to determine if it is a stereotype.
      <X> Bean<? extends X> resolve(Set<Bean<? extends X>> beans)
      Apply the ambiguous dependency resolution rules to a set of beans.
      List<Decorator<?>> resolveDecorators(Set<Type> types, Annotation... qualifiers)
      Return an ordered list of decorators for a set of bean types and a set of qualifiers and which are enabled in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained.
      List<Interceptor<?>> resolveInterceptors(InterceptionType type, Annotation... interceptorBindings)
      Return an ordered list of enabled interceptors for a set of interceptor bindings and a type of interception and which are enabled in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained.
      <T> Set<ObserverMethod<? super T>> resolveObserverMethods(T event, Annotation... qualifiers)
      Return the set of observers for an event.
      void validate(InjectionPoint injectionPoint)
      Validate a certain injection point.
      ExpressionFactory wrapExpressionFactory(ExpressionFactory expressionFactory)
      Returns a wrapper ExpressionFactory that delegates MethodExpression and ValueExpression creation to the given ExpressionFactory.

    • Method Detail

      • getReference

        Object getReference(Bean<?> bean,
                  Type beanType,
                  CreationalContext<?> ctx)

        Obtains a contextual reference for a certain bean and a certain bean type of the bean.

        Parameters:
        bean - the Bean object representing the bean
        beanType - a bean type that must be implemented by any client proxy that is returned
        ctx - a CreationalContext that may be used to destroy any object with scope Dependent that is created
        Returns:
        a contextual reference representing the bean
        Throws:
        IllegalArgumentException - if the given type is not a bean type of the given bean
        IllegalStateException - if called during application initialization, before the AfterDeploymentValidation event is fired The container is permitted to define a non-portable mode in which getReference(Bean, Type, CreationalContext) may be called from an observer of the AfterBeanDiscovery event.

      • getInjectableReference

        Object getInjectableReference(InjectionPoint ij,
                            CreationalContext<?> ctx)

        Obtains an injectable reference for a certain injection point.

        Parameters:
        ij - the target injection point
        ctx - a CreationalContext that may be used to destroy any object with scope Dependent that is created
        Returns:
        the injectable reference
        Throws:
        UnsatisfiedResolutionException - if typesafe resolution results in an unsatisfied dependency
        AmbiguousResolutionException - typesafe resolution results in an unresolvable ambiguous dependency
        IllegalStateException - if called during application initialization, before the AfterDeploymentValidation event is fired The container is permitted to define a non-portable mode in which getInjectableReference(InjectionPoint, CreationalContext) may be called from an observer of the AfterBeanDiscovery event.

      • createCreationalContext

        <T> CreationalContext<T> createCreationalContext(Contextual<T> contextual)
        Obtain an instance of a CreationalContext for the given contextual type, or for a non-contextual object.
        Parameters:
        contextual - the Contextual, or a null value in the case of a non-contextual object
        Returns:
        the new CreationalContext

      • getBeans

        Set<Bean<?>> getBeans(Type beanType,
                    Annotation... qualifiers)
        Return the set of beans which have the given required type and qualifiers and are available for injection in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained, according to the rules of typesafe resolution. If no qualifiers are given, the default qualifier is assumed.
        Parameters:
        beanType - the required bean type
        qualifiers - the required qualifiers
        Returns:
        the resulting set of beans
        Throws:
        IllegalArgumentException - if the given type represents a type variable
        IllegalArgumentException - if two instances of the same qualifier type are given
        IllegalArgumentException - if an instance of an annotation that is not a qualifier type is given
        IllegalStateException - if called during application initialization, before the AfterDeploymentValidation event is fired The container is permitted to define a non-portable mode in which getBeans(Type, Annotation...) may be called from an observer of the AfterBeanDiscovery event.

      • getBeans

        Set<Bean<?>> getBeans(String name)
        Return the set of beans which have the given EL name and are available for injection in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained, according to the rules of EL name resolution.
        Parameters:
        name - the EL name
        Returns:
        the resulting set of beans
        Throws:
        IllegalStateException - if called during application initialization, before the AfterDeploymentValidation event is fired The container is permitted to define a non-portable mode in which getBeans(String) may be called from an observer of the AfterBeanDiscovery event.

      • getPassivationCapableBean

        Bean<?> getPassivationCapableBean(String id)
        Returns the PassivationCapable bean with the given identifier.
        Parameters:
        id - the identifier
        Returns:
        a Bean that implements PassivationCapable and has the given identifier, or a null value if there is no such bean
        Throws:
        IllegalStateException - if called during application initialization, before the AfterDeploymentValidation event is fired The container is permitted to define a non-portable mode in which getPassivationCapableBean(String) may be called from an observer of the AfterBeanDiscovery event.

      • resolve

        <X> Bean<? extends X> resolve(Set<Bean<? extends X>> beans)
        Apply the ambiguous dependency resolution rules to a set of beans.
        Type Parameters:
        X - a common type of the beans
        Parameters:
        beans - a set of beans of the given type
        Throws:
        AmbiguousResolutionException - if the ambiguous dependency resolution rules fail
        IllegalStateException - if called during application initialization, before the AfterDeploymentValidation event is fired The container is permitted to define a non-portable mode in which resolve(Set) may be called from an observer of the AfterBeanDiscovery event.

      • validate

        void validate(InjectionPoint injectionPoint)
        Validate a certain injection point.
        Parameters:
        injectionPoint - the injection point to validate
        Throws:
        InjectionException - if there is a deployment problem (for example, an unsatisfied or unresolvable ambiguous dependency) associated with the injection point
        IllegalStateException - if called during application initialization, before the AfterDeploymentValidation event is fired The container is permitted to define a non-portable mode in which validate(InjectionPoint) may be called from an observer of the AfterBeanDiscovery event.

      • fireEvent

        void fireEvent(Object event,
             Annotation... qualifiers)
        Fire an event and notify observers.
        Parameters:
        event - the event object
        qualifiers - the event qualifiers
        Throws:
        IllegalArgumentException - if the runtime type of the event object contains a type variable
        IllegalArgumentException - if two instances of the same qualifier type are given
        IllegalArgumentException - if an instance of an annotation that is not a qualifier type is given
        IllegalArgumentException - if the runtime type of the event object is assignable to the type of a container lifecycle event
        ObserverException - if a notified observer throws a checked exception, it will be wrapped and rethrown as an (unchecked) ObserverException

      • resolveObserverMethods

        <T> Set<ObserverMethod<? super T>> resolveObserverMethods(T event,
                                                        Annotation... qualifiers)
        Return the set of observers for an event.
        Type Parameters:
        T - the type of the event
        Parameters:
        event - the event object
        qualifiers - the event qualifiers
        Throws:
        IllegalArgumentException - if the runtime type of the event object contains a type variable
        IllegalArgumentException - if two instances of the same qualifier type are given
        IllegalArgumentException - if an instance of an annotation that is not a qualifier type is given
        IllegalStateException - if called during application initialization, before the AfterDeploymentValidation event is fired The container is permitted to define a non-portable mode in which resolveObserverMethods(Object, Annotation...) may be called from an observer of the AfterBeanDiscovery event.

      • resolveDecorators

        List<Decorator<?>> resolveDecorators(Set<Type> types,
                                   Annotation... qualifiers)
        Return an ordered list of decorators for a set of bean types and a set of qualifiers and which are enabled in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained.
        Parameters:
        types - the set of bean types of the decorated bean
        qualifiers - the qualifiers declared by the decorated bean
        Returns:
        the resulting set of decorators
        Throws:
        IllegalArgumentException - if the set of bean types is empty
        IllegalArgumentException - if an annotation which is not a binding type is passed
        IllegalArgumentException - if two instances of the same binding type are passed
        IllegalStateException - if called during application initialization, before the AfterDeploymentValidation event is fired The container is permitted to define a non-portable mode in which resolveDecorators(Set, Annotation...) may be called from an observer of the AfterBeanDiscovery event.

      • resolveInterceptors

        List<Interceptor<?>> resolveInterceptors(InterceptionType type,
                                       Annotation... interceptorBindings)
        Return an ordered list of enabled interceptors for a set of interceptor bindings and a type of interception and which are enabled in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained.
        Parameters:
        type - the type of the interception
        interceptorBindings - the interceptor bindings
        Returns:
        the resulting set of interceptors
        Throws:
        IllegalArgumentException - if no interceptor binding type is given
        IllegalArgumentException - if two instances of the same interceptor binding type are given
        IllegalArgumentException - if an instance of an annotation that is not an interceptor binding type is given
        IllegalStateException - if called during application initialization, before the AfterDeploymentValidation event is fired The container is permitted to define a non-portable mode in which resolveInterceptors(InterceptionType, Annotation...) may be called from an observer of the AfterBeanDiscovery event.

      • isScope

        boolean isScope(Class<? extends Annotation> annotationType)
        Test the given annotation type to determine if it is a scope type.
        Parameters:
        annotationType - the annotation type
        Returns:
        true if the annotation type is a scope type

      • isNormalScope

        boolean isNormalScope(Class<? extends Annotation> annotationType)
        Test the given annotation type to determine if it is a normal scope type.
        Parameters:
        annotationType - the annotation type
        Returns:
        true if the annotation type is a normal scope type

      • isPassivatingScope

        boolean isPassivatingScope(Class<? extends Annotation> annotationType)
        Test the given annotation type to determine if it is a passivating scope type.
        Parameters:
        annotationType - the annotation type
        Returns:
        true if the annotation type is a passivating scope type

      • isQualifier

        boolean isQualifier(Class<? extends Annotation> annotationType)
        Test the given annotation type to determine if it is a qualifier type.
        Parameters:
        annotationType - the annotation type
        Returns:
        true if the annotation type is a qualifier type

      • isInterceptorBinding

        boolean isInterceptorBinding(Class<? extends Annotation> annotationType)
        Test the given annotation type to determine if it is an interceptor binding type .
        Parameters:
        annotationType - the annotation to test
        Returns:
        true if the annotation type is a interceptor binding type

      • isStereotype

        boolean isStereotype(Class<? extends Annotation> annotationType)
        Test the given annotation type to determine if it is a stereotype.
        Parameters:
        annotationType - the annotation type
        Returns:
        true if the annotation type is a stereotype

      • getInterceptorBindingDefinition

        Set<Annotation> getInterceptorBindingDefinition(Class<? extends Annotation> bindingType)
        Obtains the set of meta-annotations for a certain interceptor binding type .
        Parameters:
        bindingType - the interceptor binding type
        Returns:
        the set of meta-annotations

      • getStereotypeDefinition

        Set<Annotation> getStereotypeDefinition(Class<? extends Annotation> stereotype)
        Obtains meta-annotations for a certain stereotype.
        Parameters:
        stereotype - the stereotype
        Returns:
        the set of meta-annotations

      • areQualifiersEquivalent

        boolean areQualifiersEquivalent(Annotation qualifier1,
                              Annotation qualifier2)
        Determine if two qualifiers are considered equivalent for the purposes of typesafe resolution, taking into account any members annotated with Nonbinding.
        Parameters:
        a1 - a qualifier to check
        a2 - a qualifier to check
        Returns:
        true if the two qualifiers are equivalent, otherwise false
        Since:
        1.1

      • areInterceptorBindingsEquivalent

        boolean areInterceptorBindingsEquivalent(Annotation interceptorBinding1,
                                       Annotation interceptorBinding2)
        Determine if two interceptor bindings are considered equivalent for the purposes of typesafe resolution, taking into account any members annotated with Nonbinding.
        Parameters:
        a1 - an interceptor binding to check
        a2 - an interceptor binding to check
        Returns:
        true if the two interceptor bindings are equivalent, otherwise false
        Since:
        1.1

      • getQualifierHashCode

        int getQualifierHashCode(Annotation qualifier)
        Determine the hash code of a qualifier, using the JDK algorithm for determining an annotation hash code, ignoring any members annotated with Nonbinding.
        Parameters:
        qualifier - the qualifier to consider
        Returns:
        the hashCode for the qualifier
        Since:
        1.1

      • getInterceptorBindingHashCode

        int getInterceptorBindingHashCode(Annotation interceptorBinding)
        Determine the hash code of an interceptor binding, using the JDK algorithm for determining an annotation hash code, ignoring any members annotated with Nonbinding.
        Parameters:
        interceptorBinding - the interceptor binding to consider
        Returns:
        the hashCode for the interceptor binding
        Since:
        1.1

      • getContext

        Context getContext(Class<? extends Annotation> scopeType)
        Obtains an active context object for the given scope .
        Parameters:
        scopeType - the scope
        Returns:
        the context object
        Throws:
        ContextNotActiveException - if there is no active context object for the given scope
        IllegalArgumentException - if there is more than one active context object for the given scope

      • getELResolver

        ELResolver getELResolver()
        Returns a ELResolver that resolves beans by EL name.

      • wrapExpressionFactory

        ExpressionFactory wrapExpressionFactory(ExpressionFactory expressionFactory)
        Returns a wrapper ExpressionFactory that delegates MethodExpression and ValueExpression creation to the given ExpressionFactory. When a Unified EL expression is evaluated using a MethodExpression or ValueExpression returned by the wrapper ExpressionFactory, the container handles destruction of objects with scope Dependent.
        Parameters:
        expressionFactory - the ExpressionFactory to wrap
        Returns:
        the wrapped ExpressionFactory

      • createAnnotatedType

        <T> AnnotatedType<T> createAnnotatedType(Class<T> type)
        Obtain an AnnotatedType that may be used to read the annotations of the given class or interface.
        Type Parameters:
        T - the class or interface
        Parameters:
        type - the Class object
        Returns:
        the AnnotatedType

      • createInjectionTarget

        <T> InjectionTarget<T> createInjectionTarget(AnnotatedType<T> type)

        Obtains an InjectionTarget for the given AnnotatedType. The container ignores the annotations and types declared by the elements of the actual Java class and uses the metadata provided via the Annotated interface instead.

        This method is deprecated from CDI 1.1 and getInjectionTargetFactory(AnnotatedType) should be used instead.

        Type Parameters:
        T - the type
        Parameters:
        type - the AnnotatedType
        Throws:
        IllegalArgumentException - if there is a definition error associated with any injection point of the type

      • getInjectionTargetFactory

        <T> InjectionTargetFactory<T> getInjectionTargetFactory(AnnotatedType<T> annotatedType)

        An implementation of InjectionTargetFactory that provides container created InjectionTarget instances.

        This factory can be wrapped to add behavior to container created injection targets.

        Parameters:
        annotatedType - the annotated type to create the injection target factory for
        Returns:
        an InjectionTargetFactory
        Since:
        1.1

      • getProducerFactory

        <X> ProducerFactory<X> getProducerFactory(AnnotatedField<? super X> field,
                                        Bean<X> declaringBean)

        An implementation of ProducerFactory that provides container created Producer instances for the given field.

        This factory can be wrapped to add behavior to container created producers.

        Parameters:
        field - the field to create the producer factory for
        declaringBean - the bean declaring the producer. May be null if the producer is static or the declaring object is non-contextual
        Returns:
        the producer factory for the field
        Since:
        1.1

      • getProducerFactory

        <X> ProducerFactory<X> getProducerFactory(AnnotatedMethod<? super X> method,
                                        Bean<X> declaringBean)

        An implementation of ProducerFactory that provides container created Producer instances for the given method.

        This factory can be wrapped to add behavior to container created producers.

        Parameters:
        method - the method to create the producer factory for
        declaringBean - the bean declaring the producer. May be null if the producer is static or the declaring object is non-contextual
        Returns:
        the producer factory for the method
        Since:
        1.1

      • createBeanAttributes

        <T> BeanAttributes<T> createBeanAttributes(AnnotatedType<T> type)
        Obtains a BeanAttributes for the given AnnotatedType. The container ignores the annotations and types declared by the elements of the actual Java class and uses the metadata provided via the Annotated interface instead.
        Type Parameters:
        T - the type
        Parameters:
        type - the AnnotatedType
        Returns:
        a container provided implementation of InjectionTarget
        Since:
        1.1

      • createBeanAttributes

        BeanAttributes<?> createBeanAttributes(AnnotatedMember<?> type)
        Obtains a BeanAttributes for the given AnnotatedType. The container ignores the annotations and types declared by the elements of the actual Java class and uses the metadata provided via the Annotated interface instead.
        Type Parameters:
        T - the type
        Parameters:
        type - the AnnotatedType
        Returns:
        a container provided implementation of InjectionTarget
        Since:
        1.1

      • createBean

        <T> Bean<T> createBean(BeanAttributes<T> attributes,
                     Class<T> beanClass,
                     InjectionTargetFactory<T> injectionTargetFactory)

        Obtains a Bean for the given BeanAttributes, bean class and InjectionTarget.

        The InjectionTarget creates and destroys instances of the bean, performs dependency injection and lifecycle callbacks, and determines the return value of Bean.getInjectionPoints(). The InjectionTarget is obtained from the InjectionTargetFactory. #getInjectionTargetFactory() allows use of a container created InjectionTarget.

        Type Parameters:
        T - the type
        Parameters:
        attributes - a BeanAttributes which determines the bean types, qualifiers, scope, name and stereotypes of the returned Bean, and the return values of BeanAttributes.isAlternative() and Bean.isNullable()
        beanClass - a class, which determines the return value of Bean.getBeanClass()
        injectionTargetFactory - an InjectionTargetFactory, used to obtain an InjectionTarget
        Returns:
        a container provided implementation of Bean
        Since:
        1.1

      • createBean

        <T,X> Bean<T> createBean(BeanAttributes<T> attributes,
                       Class<X> beanClass,
                       ProducerFactory<X> producerFactory)

        Obtains a Bean for the given BeanAttributes, bean class and Producer.

        The Producer creates and destroys instances of the decorator, and determines the return value of Bean.getInjectionPoints(). The Producer is obtained from the ProducerFactory. #getProducerFactory() allows use of a container created Producer.

        Type Parameters:
        T - the type
        X - the type of the declaring bean
        Parameters:
        attributes - a BeanAttributes which determines the bean types, qualifiers, scope, name and stereotypes of the returned Bean, and the return values of BeanAttributes.isAlternative() and Bean.isNullable()
        beanClass - a class, which determines the return value of Bean#getClass()
        producerFactory - a ProducerFactory, used to obtain a Producer
        Returns:
        a container provided implementation of Bean
        Since:
        1.1

      • createInjectionPoint

        InjectionPoint createInjectionPoint(AnnotatedField<?> field)
        Obtains a container provided implementation of InjectionPoint for the given AnnotatedField.
        Parameters:
        field - the AnnotatedField defining the injection point
        Returns:
        the container provided InjectionPoint
        Throws:
        IllegalArgumentException - if there is a definition error associated with the injection point
        Since:
        1.1

      • createInjectionPoint

        InjectionPoint createInjectionPoint(AnnotatedParameter<?> parameter)
        Obtains a container provided implementation of InjectionPoint for the given AnnotatedParameter.
        Parameters:
        parameter - the AnnotatedParameter defining the injection point
        Returns:
        the container provided InjectionPoint
        Throws:
        IllegalArgumentException - if there is a definition error associated with the injection point
        Since:
        1.1

      • getExtension

        <T extends Extension> T getExtension(Class<T> extensionClass)
        Obtains the container's instance of an Extension class declared in META-INF/services.
        Type Parameters:
        T - the type of the extension
        Parameters:
        extensionClass - the type of the extension class
        Returns:
        the extension instance
        Throws:
        IllegalArgumentException - if the container has no instance of the given class
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BeforeBeanDiscovery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface BeforeBeanDiscovery

  • public interface BeforeBeanDiscovery

    This event type is thrown by the container before the bean discovery process begins. If any observer method of the BeforeBeanDiscovery event throws an exception, the exception is treated as a definition error by the container.

    Author:
    Pete Muir, David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addAnnotatedType(AnnotatedType<?> type)
      Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.
      void addAnnotatedType(AnnotatedType<?> type, String id)
      Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.
      void addInterceptorBinding(AnnotatedType<? extends Annotation> bindingType)
      Declares an annotation type as an interceptor binding type.
      void addInterceptorBinding(Class<? extends Annotation> bindingType, Annotation... bindingTypeDef)
      Declares an annotation type as an interceptor binding type, and specifies its meta-annotations.
      void addQualifier(AnnotatedType<? extends Annotation> qualifier)
      Declares an annotation type as a Qualifier qualifier type.
      void addQualifier(Class<? extends Annotation> qualifier)
      Declares an annotation type as a Qualifier qualifier type.
      void addScope(Class<? extends Annotation> scopeType, boolean normal, boolean passivating)
      Declares an annotation type as a scope type.
      void addStereotype(Class<? extends Annotation> stereotype, Annotation... stereotypeDef)
      Declares an annotation type as a stereotype, and specifies its meta-annotations.

    • Method Detail

      • addQualifier

        void addQualifier(Class<? extends Annotation> qualifier)

        Declares an annotation type as a Qualifier qualifier type.

        This is only required if you wish to make an annotation a qualifier without adding Qualifier to it.

        Parameters:
        qualifier - The annotation to treat as a qualifier

      • addQualifier

        void addQualifier(AnnotatedType<? extends Annotation> qualifier)

        Declares an annotation type as a Qualifier qualifier type.

        This is only required if you wish to make an annotation a qualifier without adding Qualifier to it.

        Parameters:
        qualifier - The annotation to treat as a qualifier
        Since:
        1.1

      • addScope

        void addScope(Class<? extends Annotation> scopeType,
            boolean normal,
            boolean passivating)

        Declares an annotation type as a scope type.

        This is only required if you wish to make an annotation a scope type without adding the NormalScope or Scope annotations to it. You can also use this method to override an existing normal scope definition.

        Parameters:
        scopeType - The annotation type to treat as a scope type
        normal - Indicates if the scope is normal
        passivating - Indicates if the scope is passivation capable
        See Also:
        AfterBeanDiscovery.addContext(javax.enterprise.context.spi.Context)

      • addStereotype

        void addStereotype(Class<? extends Annotation> stereotype,
                 Annotation... stereotypeDef)

        Declares an annotation type as a stereotype, and specifies its meta-annotations.

        This is only required if you wish to make an annotation a stereotype without adding Stereotype to it. You can also use this method to override an existing stereotype definition.

        Parameters:
        stereotype - The annotation type to treat as a stereotype
        stereotypeDef - An optional list of annotations defining the stereotype

      • addInterceptorBinding

        void addInterceptorBinding(AnnotatedType<? extends Annotation> bindingType)

        Declares an annotation type as an interceptor binding type.

        This is only required if you wish to make an annotation an interceptor binding type without adding InterceptorBinding to it.

        Parameters:
        bindingType - The annotation type to treat as an interceptor binding type

      • addInterceptorBinding

        void addInterceptorBinding(Class<? extends Annotation> bindingType,
                         Annotation... bindingTypeDef)

        Declares an annotation type as an interceptor binding type, and specifies its meta-annotations.

        This is only required if you wish to make an annotation an interceptor binding type without adding InterceptorBinding to it.

        Parameters:
        bindingType - The annotation type to treat as an interceptor binding type
        bindingTypeDef - An optional list of annotations defining the interceptor
        Since:
        1.1

      • addAnnotatedType

        void addAnnotatedType(AnnotatedType<?> type)

        Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.

        This method is deprecated from CDI 1.1 and addAnnotatedType(AnnotatedType, String) should be used instead.

        Parameters:
        type - The AnnotatedType to add for later scanning

      • addAnnotatedType

        void addAnnotatedType(AnnotatedType<?> type,
                    String id)

        Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.

        This method allows multiple annotated types, based on the same underlying type, to be defined. AnnotatedTypes discovered by the container use the fully qualified class name of AnnotatedType.getJavaClass() to identify the type.

        AfterBeanDiscovery.getAnnotatedType(Class, String) and AfterBeanDiscovery.getAnnotatedTypes(Class) allows annotated types to be obtained by identifier.

        Parameters:
        type - The AnnotatedType to add for later scanning
        id - The id of the annotated type
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BeforeShutdown (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface BeforeShutdown

  • public interface BeforeShutdown

    The type of the final event the container fires after it has finished processing requests and destroyed all contexts. If any observer method of the BeforeShutdown event throws an exception, the exception is ignored by the container.

    Author:
    David Allen
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CDI (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Class CDI<T>

  • java.lang.Object
    • javax.enterprise.inject.spi.CDI<T>
  • All Implemented Interfaces:
    Iterable<T>, Instance<T>, Provider<T>

    public abstract class CDI<T>
extends Object
implements Instance<T>
    Provides access to the current container.
    Since:
    1.1
    Author:
    Pete Muir

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected static CDIProvider | configuredProvider
      protected static Set<CDIProvider> | discoveredProviders

    • Constructor Summary

      Constructors
      Constructor and Description
      CDI()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static CDI<Object> current()
      Get the CDI instance that provides access to the current container.
      abstract BeanManager getBeanManager()
      Get the CDI BeanManager for the current context
      static void setCDIProvider(CDIProvider provider)
      Set the CDIProvider to use.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.enterprise.inject.Instance

        destroy, isAmbiguous, isUnsatisfied, select, select, select

      • Methods inherited from interface java.lang.Iterable

        iterator

      • Methods inherited from interface javax.inject.Provider

        get

    • Field Detail

      • discoveredProviders

        protected static volatile Set<CDIProvider> discoveredProviders

      • configuredProvider

        protected static volatile CDIProvider configuredProvider

    • Constructor Detail

      • CDI

        public CDI()

    • Method Detail

      • current

        public static CDI<Object> current()

        Get the CDI instance that provides access to the current container.

        If there are no providers available, an IllegalStateException is thrown, otherwise the first provider which can access the container is used.

        Throws:
        IllegalStateException - if no CDI provider is available

      • setCDIProvider

        public static void setCDIProvider(CDIProvider provider)

        Set the CDIProvider to use.

        If a CDIProvider is set using this method, any provider specified as a service provider will not be used.

        Parameters:
        provider - the provider to use
        Throws:
        IllegalStateException - if the CDIProvider is already set

      • getBeanManager

        public abstract BeanManager getBeanManager()
        Get the CDI BeanManager for the current context
        Returns:
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CDIProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface CDIProvider

  • public interface CDIProvider
    Interface implemented by a CDI provider to provide access to the current container
    Since:
    1.1
    Author:
    Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CDI<Object> getCDI()
      Provides access to the current container

    • Method Detail

      • getCDI

        CDI<Object> getCDI()
        Provides access to the current container
        Returns:
        the CDI instance for the current container
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Decorator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface Decorator<T>

  • Type Parameters:
    T - the decorator bean class
    All Superinterfaces:
    Bean<T>, BeanAttributes<T>, Contextual<T>

    public interface Decorator<T>
extends Bean<T>

    Represents an enabled decorator.

    Author:
    Gavin King, Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<Type> getDecoratedTypes()
      Obtains the decorated types.
      Set<Annotation> getDelegateQualifiers()
      Obtains the qualifiers of the delegate injection point.
      Type getDelegateType()
      Obtains the type of the delegate injection point.

      • Methods inherited from interface javax.enterprise.inject.spi.Bean

        getBeanClass, getInjectionPoints, isNullable

      • Methods inherited from interface javax.enterprise.context.spi.Contextual

        create, destroy

      • Methods inherited from interface javax.enterprise.inject.spi.BeanAttributes

        getName, getQualifiers, getScope, getStereotypes, getTypes, isAlternative

    • Method Detail

      • getDelegateType

        Type getDelegateType()

        Obtains the type of the delegate injection point.

        Returns:
        the delegate type

      • getDelegateQualifiers

        Set<Annotation> getDelegateQualifiers()

        Obtains the qualifiers of the delegate injection point.

        Returns:
        the delegate qualifiers

      • getDecoratedTypes

        Set<Type> getDecoratedTypes()

        Obtains the decorated types.

        Returns:
        the set of decorated types
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DefinitionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Class DefinitionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.spi.DefinitionException
  • All Implemented Interfaces:
    Serializable

    public class DefinitionException
extends RuntimeException

    Thrown when a definition error occurs.

    Definition errors are developer errors. They may be detected by tooling at development time, and are also detected by the container at initialization time. If a definition error exists in a deployment, initialization will be aborted by the container.

    The container is permitted to define a non-portable mode, for use at development time, in which some definition errors do not cause application initialization to abort.

    An implementation is permitted to throw a subclass of DefinitionException for any definition error which exists.

    Since:
    1.1
    Author:
    Pete Muir
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DefinitionException(String message)
      DefinitionException(String message, Throwable t)
      DefinitionException(Throwable t)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DefinitionException

        public DefinitionException(String message,
                   Throwable t)

      • DefinitionException

        public DefinitionException(String message)

      • DefinitionException

        public DefinitionException(Throwable t)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeploymentException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Class DeploymentException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.spi.DeploymentException
  • All Implemented Interfaces:
    Serializable

    public class DeploymentException
extends RuntimeException

    Thrown when a deployment problem occurs.

    Deployment problems are detected by the container at initialization time. If a deployment problem exists in a deployment, initialization will be aborted by the container.

    The container is permitted to define a non-portable mode, for use at development time, in which some deployment problems do not cause application initialization to abort.

    An implementation is permitted to throw a subclass of DeploymentException for any deployment problem.

    Since:
    1.1
    Author:
    Pete Muir
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DeploymentException(String message)
      DeploymentException(String message, Throwable t)
      DeploymentException(Throwable t)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DeploymentException

        public DeploymentException(String message,
                   Throwable t)

      • DeploymentException

        public DeploymentException(String message)

      • DeploymentException

        public DeploymentException(Throwable t)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EventMetadata (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface EventMetadata

  • public interface EventMetadata

    Provides access to metadata about an observed event payload. The metadata may be for events fired with either of Event or BeanManager.fireEvent(Object, Annotation...).

    EventMetadata may only be injected into an observer method. For example:

     public void afterLogin(@Observes LoggedInEvent event, EventMetadata eventMetadata) { ... }
    Since:
    1.1
    Author:
    Lincoln Baxter, III, Pete Muir
    See Also:
    Observes

    • Method Summary

      Methods
      Modifier and Type Method and Description
      InjectionPoint getInjectionPoint()
      Get the InjectionPoint representing the injected Event instance which fired the event, or null if it was fired from BeanManager.fireEvent(Object, Annotation...);
      Set<Annotation> getQualifiers()
      Get the qualifiers for which event payload was fired.
      Type getType()
      Get the type representing runtime class of the event object with type variables resolved.

    • Method Detail

      • getQualifiers

        Set<Annotation> getQualifiers()
        Get the qualifiers for which event payload was fired.

      • getInjectionPoint

        InjectionPoint getInjectionPoint()
        Get the InjectionPoint representing the injected Event instance which fired the event, or null if it was fired from BeanManager.fireEvent(Object, Annotation...);

      • getType

        Type getType()
        Get the type representing runtime class of the event object with type variables resolved.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Extension (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface Extension

  • public interface Extension

    Service interface implemented by extensions. An extension is a service provider declared in META-INF/services.

    Service providers may have observer methods, which may observe any event, including any container lifecycle event, and obtain an injected BeanManager.

    The container instantiates a single instance of each extension at the beginning of the application initialization process and maintains a reference to it until the application shuts down. The container delivers event notifications to this instance by calling its observer methods.

    Service providers are made available for injection as beans with the qualifier @Default.

    Author:
    Gavin King, Pete Muir
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InjectionPoint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface InjectionPoint

  • public interface InjectionPoint

    Provides access to metadata about an injection point. May represent an injected field or a parameter of a bean constructor, initializer method, producer method, disposer method or observer method.

    If the injection point is a dynamically selected reference obtained then the metadata obtain reflects the injection point of the Instance, with the required type and any additional required qualifers defined by Instance.select().

    Occasionally, a bean with scope @Dependent needs to access metadata relating to the object to which it belongs. The bean may inject an InjectionPoint representing the injection point into which the bean was injected.

    For example, the following producer method creates injectable Logger s. The log category of a Logger depends upon the class of the object into which it is injected.

     @Produces
 Logger createLogger(InjectionPoint injectionPoint) {
     return Logger.getLogger(injectionPoint.getMember().getDeclaringClass().getName());
 }

    Only dependent objects, may obtain information about the injection point to which they belong.

    Author:
    Gavin King, Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Annotated getAnnotated()
      Obtain an instance of AnnotatedField or AnnotatedParameter, depending upon whether the injection point is an injected field or a constructor/method parameter.
      Bean<?> getBean()
      Get the Bean object representing the bean that defines the injection point.
      Member getMember()
      Get the Field object in the case of field injection, the Method object in the case of method parameter injection or the Constructor object in the case of constructor parameter injection.
      Set<Annotation> getQualifiers()
      Get the required qualifiers of the injection point.
      Type getType()
      Get the required type of injection point.
      boolean isDelegate()
      Determines if the injection point is a decorator delegate injection point.
      boolean isTransient()
      Determines if the injection is a transient field.

    • Method Detail

      • getType

        Type getType()
        Get the required type of injection point.
        Returns:
        the required type

      • getQualifiers

        Set<Annotation> getQualifiers()
        Get the required qualifiers of the injection point.
        Returns:
        the required qualifiers

      • getBean

        Bean<?> getBean()
        Get the Bean object representing the bean that defines the injection point. If the injection point does not belong to a bean, return a null value.
        Returns:
        the Bean object representing bean that defines the injection point, of null if the injection point does not belong to a bean

      • getMember

        Member getMember()
        Get the Field object in the case of field injection, the Method object in the case of method parameter injection or the Constructor object in the case of constructor parameter injection.
        Returns:
        the member

      • getAnnotated

        Annotated getAnnotated()
        Obtain an instance of AnnotatedField or AnnotatedParameter, depending upon whether the injection point is an injected field or a constructor/method parameter.
        Returns:
        an AnnotatedField or AnnotatedParameter

      • isDelegate

        boolean isDelegate()
        Determines if the injection point is a decorator delegate injection point.
        Returns:
        true if the injection point is a decorator delegate injection point, and false otherwise

      • isTransient

        boolean isTransient()
        Determines if the injection is a transient field.
        Returns:
        true if the injection point is a transient field, and false otherwise
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InjectionTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface InjectionTarget<T>

  • Type Parameters:
    T - The class of the instance
    All Superinterfaces:
    Producer<T>

    public interface InjectionTarget<T>
extends Producer<T>

    Provides operations for performing dependency injection and lifecycle callbacks on an instance of a type.

    Author:
    Pete Muir, David Allen
    See Also:
    PostConstruct, PreDestroy

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void inject(T instance, CreationalContext<T> ctx)
      Performs dependency injection upon the given object.
      void postConstruct(T instance)
      Calls the PostConstruct callback, if it exists, according to the semantics required by the Java EE platform specification.
      void preDestroy(T instance)
      Calls the PreDestroy callback, if it exists, according to the semantics required by the Java EE platform specification.

      • Methods inherited from interface javax.enterprise.inject.spi.Producer

        dispose, getInjectionPoints, produce

    • Method Detail

      • inject

        void inject(T instance,
          CreationalContext<T> ctx)

        Performs dependency injection upon the given object. Performs Java EE component environment injection, sets the value of all injected fields, and calls all initializer methods.

        Parameters:
        instance - The instance upon which to perform injection
        ctx - The CreationalContext to use for creating new instances

      • postConstruct

        void postConstruct(T instance)

        Calls the PostConstruct callback, if it exists, according to the semantics required by the Java EE platform specification.

        Parameters:
        instance - The instance on which to invoke the PostConstruct method

      • preDestroy

        void preDestroy(T instance)

        Calls the PreDestroy callback, if it exists, according to the semantics required by the Java EE platform specification.

        Parameters:
        instance - The instance on which to invoke the PreDestroy method
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InjectionTargetFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface InjectionTargetFactory<T>

  • public interface InjectionTargetFactory<T>

    An InjectionTargetFactory can create an InjectionTarget for a given bean.

    The InjectionTargetFactory obtained from BeanManager#getInjectionTargetFactory() is capable of providing container created injection targets. This factory can be wrapped to add behavior to container created injection targets.

    For example:

     BeanAttributes<MyBean> myBeanAttributes = beanManager.createBeanAttributes(myBeanAnnotatedType);
 beanManager.createBean(myBeanAttributes, MyBean.class, new InjectionTargetFactory() {

     public <T> InjectionTarget<T> createInjectionTarget(Bean<T> bean) {
         return new WrappingInjectionTarget<T>(beanManager.getInjectionTargetFactory(myBeanAnnotatedType).createInjectionTarget(
                 bean));
     }
 });
    Since:
    1.1
    Author:
    Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      InjectionTarget<T> createInjectionTarget(Bean<T> bean)
      Create a new injection target for a bean.

    • Method Detail

      • createInjectionTarget

        InjectionTarget<T> createInjectionTarget(Bean<T> bean)
        Create a new injection target for a bean.
        Parameters:
        bean - the bean to create the injection target for, or null if creating a non-contextual object
        Returns:
        the injection target
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InterceptionType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.enterprise.inject.spi

Enum InterceptionType

  • java.lang.Object
    • java.lang.Enum<InterceptionType>
      • javax.enterprise.inject.spi.InterceptionType
  • All Implemented Interfaces:
    Serializable, Comparable<InterceptionType>

    public enum InterceptionType
extends Enum<InterceptionType>

    Identifies the kind of lifecycle callback, EJB timeout method or business method interception.

    Author:
    Gavin King, Pete Muir

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      AROUND_CONSTRUCT
      Intercepts a constructor invocation
      AROUND_INVOKE
      Intercepts method invocation
      AROUND_TIMEOUT
      Intercepts a timeout
      POST_ACTIVATE
      Intercepts bean activation, only called for EJBs
      POST_CONSTRUCT
      Intercepts bean construction
      PRE_DESTROY
      Intercepts bean destruction
      PRE_PASSIVATE
      Intercepts bean passivation, only called for EJBs

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static InterceptionType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static InterceptionType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • AROUND_INVOKE

        public static final InterceptionType AROUND_INVOKE
        Intercepts method invocation

      • AROUND_TIMEOUT

        public static final InterceptionType AROUND_TIMEOUT
        Intercepts a timeout

      • AROUND_CONSTRUCT

        public static final InterceptionType AROUND_CONSTRUCT
        Intercepts a constructor invocation

      • POST_CONSTRUCT

        public static final InterceptionType POST_CONSTRUCT
        Intercepts bean construction

      • PRE_DESTROY

        public static final InterceptionType PRE_DESTROY
        Intercepts bean destruction

      • PRE_PASSIVATE

        public static final InterceptionType PRE_PASSIVATE
        Intercepts bean passivation, only called for EJBs

      • POST_ACTIVATE

        public static final InterceptionType POST_ACTIVATE
        Intercepts bean activation, only called for EJBs

    • Method Detail

      • values

        public static InterceptionType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (InterceptionType c : InterceptionType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static InterceptionType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Interceptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface Interceptor<T>

  • Type Parameters:
    T - the interceptor bean class
    All Superinterfaces:
    Bean<T>, BeanAttributes<T>, Contextual<T>

    public interface Interceptor<T>
extends Bean<T>

    Represents an enabled interceptor.

    Author:
    Gavin King, Pete Muir, David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<Annotation> getInterceptorBindings()
      Obtains the interceptor bindings of the interceptor.
      Object intercept(InterceptionType type, T instance, InvocationContext ctx)
      Invokes the specified kind of lifecycle callback or method invocation interception upon the given interceptor instance.
      boolean intercepts(InterceptionType type)
      Determines if the interceptor intercepts the specified kind of lifecycle callback or method invocation.

      • Methods inherited from interface javax.enterprise.inject.spi.Bean

        getBeanClass, getInjectionPoints, isNullable

      • Methods inherited from interface javax.enterprise.context.spi.Contextual

        create, destroy

      • Methods inherited from interface javax.enterprise.inject.spi.BeanAttributes

        getName, getQualifiers, getScope, getStereotypes, getTypes, isAlternative

    • Method Detail

      • getInterceptorBindings

        Set<Annotation> getInterceptorBindings()

        Obtains the interceptor bindings of the interceptor.

        Returns:
        the set of interceptor bindings

      • intercepts

        boolean intercepts(InterceptionType type)

        Determines if the interceptor intercepts the specified kind of lifecycle callback or method invocation.

        Parameters:
        type - the kind of interception
        Returns:
        returns true if the interceptor intercepts callbacks or business methods of the given type, and false otherwise.

      • intercept

        Object intercept(InterceptionType type,
               T instance,
               InvocationContext ctx)
                 throws Exception

        Invokes the specified kind of lifecycle callback or method invocation interception upon the given interceptor instance.

        Parameters:
        type - the kind of interception
        instance - the interceptor instance to invoke
        ctx - the context for the invocation
        Returns:
        the invocation return value
        Throws:
        exceptions - thrown by the target method and/or the following interceptors in the chain
        Exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.inject.spi (Java(TM) EE 7 Specification APIs)

javax.enterprise.inject.spi

Interfaces

  • AfterBeanDiscovery
  • AfterDeploymentValidation
  • AfterTypeDiscovery
  • Annotated
  • AnnotatedCallable
  • AnnotatedConstructor
  • AnnotatedField
  • AnnotatedMember
  • AnnotatedMethod
  • AnnotatedParameter
  • AnnotatedType
  • Bean
  • BeanAttributes
  • BeanManager
  • BeforeBeanDiscovery
  • BeforeShutdown
  • CDIProvider
  • Decorator
  • EventMetadata
  • Extension
  • InjectionPoint
  • InjectionTarget
  • InjectionTargetFactory
  • Interceptor
  • ObserverMethod
  • PassivationCapable
  • ProcessAnnotatedType
  • ProcessBean
  • ProcessBeanAttributes
  • ProcessInjectionPoint
  • ProcessInjectionTarget
  • ProcessManagedBean
  • ProcessObserverMethod
  • ProcessProducer
  • ProcessProducerField
  • ProcessProducerMethod
  • ProcessSessionBean
  • ProcessSyntheticAnnotatedType
  • Producer
  • ProducerFactory

Classes

  • CDI
  • Unmanaged
  • Unmanaged.UnmanagedInstance

Enums

  • InterceptionType
  • SessionBeanType

Exceptions

  • DefinitionException
  • DeploymentException

Annotation Types

  • WithAnnotations


javax.enterprise.inject.spi (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.inject.spi

The portable extension integration SPI.

See: Description

  • Interface Summary
    Interface Description
    AfterBeanDiscovery
    The event type of the second event fired by the container when it has fully completed the bean discovery process, validated that there are no definition errors relating to the discovered beans, and registered Bean and ObserverMethod objects for the discovered beans, but before detecting deployment problems.
    AfterDeploymentValidation
    The event type of the third event fired by the container after it has validated that there are no deployment problems and before creating contexts or processing requests.
    AfterTypeDiscovery
    This event type is thrown by the container after type discovery is complete.
    Annotated
    Represents a Java program element that can be annotated.
    AnnotatedCallable<X>
    Represents a callable member of a Java type.
    AnnotatedConstructor<X>
    Represents a constructor of a Java class.
    AnnotatedField<X>
    Represents a field of a Java class.
    AnnotatedMember<X>
    Represents a member of a Java type.
    AnnotatedMethod<X>
    Represents a method of a Java type.
    AnnotatedParameter<X>
    Represents a parameter of a method or constructor.
    AnnotatedType<X>
    Represents a Java class or interface.
    Bean<T>
    Represents an enabled bean.
    BeanAttributes<T>
    The BeanAttributes interface exposes the basic attributes of a bean.
    BeanManager
    Allows a portable extension to interact directly with the container.
    BeforeBeanDiscovery
    This event type is thrown by the container before the bean discovery process begins.
    BeforeShutdown
    The type of the final event the container fires after it has finished processing requests and destroyed all contexts.
    CDIProvider
    Interface implemented by a CDI provider to provide access to the current container
    Decorator<T>
    Represents an enabled decorator.
    EventMetadata
    Provides access to metadata about an observed event payload.
    Extension
    Service interface implemented by extensions.
    InjectionPoint
    Provides access to metadata about an injection point.
    InjectionTarget<T>
    Provides operations for performing dependency injection and lifecycle callbacks on an instance of a type.
    InjectionTargetFactory<T>
    An InjectionTargetFactory can create an InjectionTarget for a given bean.
    Interceptor<T>
    Represents an enabled interceptor.
    ObserverMethod<T>
    Represents an observer method of an enabled bean.
    PassivationCapable
    Indicates that a custom implementation of Bean or Contextual is passivation capable.
    ProcessAnnotatedType<X>
    The container fires an event of this type for each Java class or interface it discovers in a bean archive, before it reads the declared annotations.
    ProcessBean<X>
    The container fires an event of this type for each enabled bean, interceptor or decorator deployed in a bean archive, before registering the Bean object.
    ProcessBeanAttributes<T>
    The container fires an event of this type for each enabled bean, interceptor or decorator deployed in a bean archive before registering the Bean object.
    ProcessInjectionPoint<T,X>
    The container fires an event of this type for every injection point of every Java EE component class supporting injection that may be instantiated by the container at runtime, including every managed bean declared using javax.annotation.ManagedBean, EJB session or message-driven bean, enabled bean, enabled interceptor or enabled decorator.
    ProcessInjectionTarget<X>
    The container fires an event of this type for every Java EE component class supporting injection that may be instantiated by the container at runtime, including every managed bean declared using javax.annotation.ManagedBean, EJB session or message-driven bean, enabled bean, enabled interceptor or enabled decorator.
    ProcessManagedBean<X>
    The container fires an event of this type for each enabled managed bean, before registering the Bean object.
    ProcessObserverMethod<T,X>
    The container fires an event of this type for each observer method of each enabled bean, before registering the ObserverMethod object.
    ProcessProducer<T,X>
    The container fires an event of this type for each producer method or field of each enabled bean, including resources.
    ProcessProducerField<T,X>
    The container fires an event of this type for each enabled producer field, before registering the Bean object.
    ProcessProducerMethod<T,X>
    The container fires an event of this type for each enabled producer method, before registering the Bean object.
    ProcessSessionBean<X>
    The container fires an event of this type for each enabled session bean, before registering the Bean object.
    ProcessSyntheticAnnotatedType<X>
    The container fires an event of this type for each Java class or interface added by BeforeBeanDiscovery.addAnnotatedType(AnnotatedType).
    Producer<T>
    Provides a generic operation for producing an instance of a type.
    ProducerFactory<X>
    An ProducerFactory can create an Producer for a given bean.
  • Class Summary
    Class Description
    CDI<T>
    Provides access to the current container.
    Unmanaged<T>
    Helper class for injecting and calling lifecycle callbacks unmanaged instances for use by framework and library integrators.
    Unmanaged.UnmanagedInstance<T>
    Represents a non-contextual instance.
  • Enum Summary
    Enum Description
    InterceptionType
    Identifies the kind of lifecycle callback, EJB timeout method or business method interception.
    SessionBeanType
    Identifies the kind of EJB session bean.
  • Exception Summary
    Exception Description
    DefinitionException
    Thrown when a definition error occurs.
    DeploymentException
    Thrown when a deployment problem occurs.
  • Annotation Types Summary
    Annotation Type Description
    WithAnnotations
    WithAnnotations may be applied to any portable extension observer method with an event parameter type of ProcessAnnotatedType to filter the events delivered.

Package javax.enterprise.inject.spi Description

The portable extension integration SPI.

A portable extension may integrate with the container by:

  • Providing its own beans, interceptors and decorators to the container
  • Injecting dependencies into its own objects using the dependency injection service
  • Providing a context implementation for a custom scope
  • Augmenting or overriding the annotation-based metadata with metadata from some other source

The BeanManager object

Portable extensions sometimes interact directly with the container via programmatic API call. The interface BeanManager provides operations for obtaining contextual references for beans, along with many other operations of use to portable extensions.

Container lifecycle events

During the application initialization process, the container fires a series of events, allowing portable extensions to integrate with the container initialization process. Observer methods of these events must belong to extensions declared in META-INF/services.

Lifecycle events include BeforeBeanDiscovery, AfterBeanDiscovery, AfterDeploymentValidation and BeforeShutdown.

Interfaces representing enabled beans

The interfaces Bean, Decorator, Interceptor and ObserverMethod define everything the container needs to manage instances of a bean, interceptor, decorator or observer method.

An instance of Bean exists for every enabled bean. A portable extension may add support for new kinds of beans by implementing Bean, observing the event AfterBeanDiscovery event registering beans with the container. An instance of ObserverMethod exists for every observer method of every enabled bean. A portable extension may add observers by implementing ObserverMethod and registering an instance with the container.

A portable extension may be notified of the existence of an enabled bean by observing the container lifecycle event type ProcessBean or one of its subtypes, or of the existence of an observer method of an enabled bean by observing the event type ProcessObserverMethod.

Alternate metadata sources

A portable extension may provide an alternative metadata source, such as configuration by XML.

Annotated and its subtypes allow a portable extension to specify metadata that overrides the annotations that exist on a bean class. The portable extension is responsible for implementing the interfaces, thereby exposing the metadata to the container. The container must use the operations of Annotated and its subinterfaces to discover program element types and annotations, instead of directly calling the Java Reflection API.

A portable extension provides its metadata to the container by observing the event ProcessAnnotatedType and wrapping the AnnotatedType.

Producer and InjectionTarget

The interfaces Producer and InjectionTarget abstract the basic lifecycle of (contextual or non-contextual) container managed objects, including instantiation and destruction, dependency injection and lifecycle callbacks.

An instance of InjectionTarget may be obtained from the BeanManager, allowing a portable extension to request these container services for objects under the control of the portable extension.

Furthermore, a portable extension may replace the implementation of InjectionTarget or Producer used by the container with its own implementation by observing the events ProcessInjectionTarget or ProcessProducer.

See Also:
javax.enterprise.inject, javax.enterprise.context.spi
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.inject.spi Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.inject.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.enterprise.inject.spi.CDI<T> (implements javax.enterprise.inject.Instance<T>)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.enterprise.inject.spi.DefinitionException
          • javax.enterprise.inject.spi.DeploymentException
    • javax.enterprise.inject.spi.Unmanaged<T>
    • javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance<T>

Interface Hierarchy

  • javax.enterprise.inject.spi.AfterBeanDiscovery
  • javax.enterprise.inject.spi.AfterDeploymentValidation
  • javax.enterprise.inject.spi.AfterTypeDiscovery
  • javax.enterprise.inject.spi.Annotated
    • javax.enterprise.inject.spi.AnnotatedMember<X>
      • javax.enterprise.inject.spi.AnnotatedCallable<X>
        • javax.enterprise.inject.spi.AnnotatedConstructor<X>
        • javax.enterprise.inject.spi.AnnotatedMethod<X>
      • javax.enterprise.inject.spi.AnnotatedField<X>
    • javax.enterprise.inject.spi.AnnotatedParameter<X>
    • javax.enterprise.inject.spi.AnnotatedType<X>
  • javax.enterprise.inject.spi.BeanAttributes<T>
    • javax.enterprise.inject.spi.Bean<T> (also extends javax.enterprise.context.spi.Contextual<T>)
      • javax.enterprise.inject.spi.Decorator<T>
      • javax.enterprise.inject.spi.Interceptor<T>
  • javax.enterprise.inject.spi.BeanManager
  • javax.enterprise.inject.spi.BeforeBeanDiscovery
  • javax.enterprise.inject.spi.BeforeShutdown
  • javax.enterprise.inject.spi.CDIProvider
  • javax.enterprise.context.spi.Contextual<T>
    • javax.enterprise.inject.spi.Bean<T> (also extends javax.enterprise.inject.spi.BeanAttributes<T>)
      • javax.enterprise.inject.spi.Decorator<T>
      • javax.enterprise.inject.spi.Interceptor<T>
  • javax.enterprise.inject.spi.EventMetadata
  • javax.enterprise.inject.spi.Extension
  • javax.enterprise.inject.spi.InjectionPoint
  • javax.enterprise.inject.spi.InjectionTargetFactory<T>
  • javax.enterprise.inject.spi.ObserverMethod<T>
  • javax.enterprise.inject.spi.PassivationCapable
  • javax.enterprise.inject.spi.ProcessAnnotatedType<X>
    • javax.enterprise.inject.spi.ProcessSyntheticAnnotatedType<X>
  • javax.enterprise.inject.spi.ProcessBean<X>
    • javax.enterprise.inject.spi.ProcessManagedBean<X>
      • javax.enterprise.inject.spi.ProcessSessionBean<X>
    • javax.enterprise.inject.spi.ProcessProducerField<T,X>
    • javax.enterprise.inject.spi.ProcessProducerMethod<T,X>
  • javax.enterprise.inject.spi.ProcessBeanAttributes<T>
  • javax.enterprise.inject.spi.ProcessInjectionPoint<T,X>
  • javax.enterprise.inject.spi.ProcessInjectionTarget<X>
  • javax.enterprise.inject.spi.ProcessObserverMethod<T,X>
  • javax.enterprise.inject.spi.ProcessProducer<T,X>
  • javax.enterprise.inject.spi.Producer<T>
    • javax.enterprise.inject.spi.InjectionTarget<T>
  • javax.enterprise.inject.spi.ProducerFactory<X>

Annotation Type Hierarchy

  • javax.enterprise.inject.spi.WithAnnotations (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.enterprise.inject.spi.SessionBeanType
      • javax.enterprise.inject.spi.InterceptionType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ObserverMethod (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ObserverMethod<T>

  • Type Parameters:
    T - the event type

    public interface ObserverMethod<T>

    Represents an observer method of an enabled bean. Defines everything the container needs to know about an observer method.

    Author:
    Gavin King, David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getBeanClass()
      Obtains the class of the type that declares the observer method.
      Set<Annotation> getObservedQualifiers()
      Obtains the set of observed event qualifiers.
      Type getObservedType()
      Obtains the observed event type.
      Reception getReception()
      Obtains the specified Reception for the observer method.
      TransactionPhase getTransactionPhase()
      Obtains the specified TransactionPhase for the observer method.
      void notify(T event)
      Calls the observer method, passing the given event object.

    • Method Detail

      • getBeanClass

        Class<?> getBeanClass()

        Obtains the class of the type that declares the observer method.

        Returns:
        the defining class

      • getObservedType

        Type getObservedType()
        Obtains the observed event type.
        Returns:
        the observed event type

      • getObservedQualifiers

        Set<Annotation> getObservedQualifiers()
        Obtains the set of observed event qualifiers.
        Returns:
        the observed event qualifiers

      • getReception

        Reception getReception()
        Obtains the specified Reception for the observer method. This indicates if the observer is conditional or not.
        Returns:
        the Reception

      • getTransactionPhase

        TransactionPhase getTransactionPhase()
        Obtains the specified TransactionPhase for the observer method.
        Returns:
        the TransactionPhase

      • notify

        void notify(T event)

        Calls the observer method, passing the given event object.

        The implementation of notify(Object) for a custom observer method is responsible for deciding whether to call the method if the getReception() returns Reception.IF_EXISTS.

        Parameters:
        event - the event object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PassivationCapable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface PassivationCapable

  • public interface PassivationCapable
    Indicates that a custom implementation of Bean or Contextual is passivation capable.
    Author:
    Gavin King, David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getId()
      A string that uniquely identifies the instance of Bean or Contextual.

    • Method Detail

      • getId

        String getId()
        A string that uniquely identifies the instance of Bean or Contextual. It is recommended that the string contain the package name of the class that implements Bean or Contextual.
        Returns:
        a unique identifier for the Bean or Contextual
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessAnnotatedType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessAnnotatedType<X>

  • Type Parameters:
    X - The class being annotated
    All Known Subinterfaces:
    ProcessSyntheticAnnotatedType<X>

    public interface ProcessAnnotatedType<X>

    The container fires an event of this type for each Java class or interface it discovers in a bean archive, before it reads the declared annotations.

    Any observer of this event is permitted to wrap and/or replace the AnnotatedType. The container must use the final value of this property, after all observers have been called, to discover the types and read the annotations of the program elements.

    For example, the following observer decorates the AnnotatedType for every class that is discovered by the container.

     public <T> void decorateAnnotatedType(@Observes ProcessAnnotatedType<T> pat) {
     pat.setAnnotatedType(decorate(pat.getAnnotatedType()));
 }

    If any observer method of a ProcessAnnotatedType event throws an exception, the exception is treated as a definition error by the container.

    Author:
    David Allen
    See Also:
    AnnotatedType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      AnnotatedType<X> getAnnotatedType()
      Returns the AnnotatedType object that will be used by the container to read the declared annotations.
      void setAnnotatedType(AnnotatedType<X> type)
      Replaces the AnnotatedType.
      void veto()
      Forces the container to ignore this type.

    • Method Detail

      • getAnnotatedType

        AnnotatedType<X> getAnnotatedType()
        Returns the AnnotatedType object that will be used by the container to read the declared annotations.
        Returns:
        the AnnotatedType object

      • setAnnotatedType

        void setAnnotatedType(AnnotatedType<X> type)
        Replaces the AnnotatedType.
        Parameters:
        type - the new AnnotatedType object to use

      • veto

        void veto()
        Forces the container to ignore this type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessBean<X>

  • Type Parameters:
    X - The class of the bean
    All Known Subinterfaces:
    ProcessManagedBean<X>, ProcessProducerField<T,X>, ProcessProducerMethod<T,X>, ProcessSessionBean<X>

    public interface ProcessBean<X>

    The container fires an event of this type for each enabled bean, interceptor or decorator deployed in a bean archive, before registering the Bean object.

    The event object type depends upon what kind of bean was discovered:

    • For a managed bean with bean class X, the container must raise an event of type ProcessManagedBean .
    • For a session bean with bean class X, the container must raise an event of type ProcessSessionBean .
    • For a producer method with method return type X of a bean with bean class T, the container must raise an event of type ProcessProducerMethod .
    • For a producer field with field type X of a bean with bean class T, the container must raise an event of type ProcessProducerField .

    Resources are considered to be producer fields.

    If any observer method of a ProcessBean event throws an exception, the exception is treated as a definition error by the container.

    Author:
    David Allen
    See Also:
    Bean

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addDefinitionError(Throwable t)
      Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
      Annotated getAnnotated()
      Returns the AnnotatedType representing the bean class, the AnnotatedMethod representing the producer method, or the AnnotatedField representing the producer field.
      Bean<X> getBean()
      Returns the Bean object that is about to be registered.

    • Method Detail

      • getAnnotated

        Annotated getAnnotated()
        Returns the AnnotatedType representing the bean class, the AnnotatedMethod representing the producer method, or the AnnotatedField representing the producer field.
        Returns:
        the AnnotatedType for the bean being registered

      • getBean

        Bean<X> getBean()
        Returns the Bean object that is about to be registered. The Bean may implement Interceptor or Decorator.
        Returns:
        the Bean object about to be registered

      • addDefinitionError

        void addDefinitionError(Throwable t)
        Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
        Parameters:
        t - The definition error to register as a Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessBeanAttributes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessBeanAttributes<T>

  • Type Parameters:
    T - The class of the bean

    public interface ProcessBeanAttributes<T>

    The container fires an event of this type for each enabled bean, interceptor or decorator deployed in a bean archive before registering the Bean object.

    No event is fired for New qualified beans.

    If any observer method of a ProcessBeanAttributes event throws an exception, the exception is treated as a definition error by the container.

    Since:
    1.1
    Author:
    Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addDefinitionError(Throwable t)
      Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
      Annotated getAnnotated()
      BeanAttributes<T> getBeanAttributes()
      void setBeanAttributes(BeanAttributes<T> beanAttributes)
      Replaces the BeanAttributes.
      void veto()
      Forces the container to ignore the bean.

    • Method Detail

      • getAnnotated

        Annotated getAnnotated()
        Returns:
        the AnnotatedType representing the managed bean class or session bean class, the AnnotatedMethod representing the producer field, or the AnnotatedField representing the producer field

      • getBeanAttributes

        BeanAttributes<T> getBeanAttributes()
        Returns:
        the BeanAttributes object that will be used by the container to manage instances of the bean

      • setBeanAttributes

        void setBeanAttributes(BeanAttributes<T> beanAttributes)
        Replaces the BeanAttributes.
        Parameters:
        beanAttributes - the new BeanAttributes to use

      • addDefinitionError

        void addDefinitionError(Throwable t)
        Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
        Parameters:
        t - the error to add

      • veto

        void veto()
        Forces the container to ignore the bean.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessInjectionPoint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessInjectionPoint<T,X>

  • Type Parameters:
    X - the declared type of the injection point.
    T - the bean class of the bean that declares the injectoion point

    public interface ProcessInjectionPoint<T,X>

    The container fires an event of this type for every injection point of every Java EE component class supporting injection that may be instantiated by the container at runtime, including every managed bean declared using javax.annotation.ManagedBean, EJB session or message-driven bean, enabled bean, enabled interceptor or enabled decorator.

    Any observer of this event is permitted to wrap and/or replace the InjectionPoint. The container must use the final value of this property, after all observers have been called, he container must use the final value of this property, after all observers have been called, whenever it performs injection upon the injection point.

    If any observer method of a ProcessInjectionPoint event throws an exception, the exception is treated as a definition error by the container.

    Author:
    Pete Muir
    See Also:
    InjectionPoint

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addDefinitionError(Throwable t)
      Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
      InjectionPoint getInjectionPoint()
      void setInjectionPoint(InjectionPoint injectionPoint)
      Replaces the InjectionPoint.

    • Method Detail

      • getInjectionPoint

        InjectionPoint getInjectionPoint()
        Returns:
        the InjectionPoint object that will be used by the container to perform injection

      • setInjectionPoint

        void setInjectionPoint(InjectionPoint injectionPoint)
        Replaces the InjectionPoint.
        Parameters:
        injectionPoint - the new injection point

      • addDefinitionError

        void addDefinitionError(Throwable t)
        Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
        Parameters:
        t - the definition error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessInjectionTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessInjectionTarget<X>

  • Type Parameters:
    X - The managed bean class, session bean class or Java EE component class supporting injection

    public interface ProcessInjectionTarget<X>

    The container fires an event of this type for every Java EE component class supporting injection that may be instantiated by the container at runtime, including every managed bean declared using javax.annotation.ManagedBean, EJB session or message-driven bean, enabled bean, enabled interceptor or enabled decorator.

    Any observer of this event is permitted to wrap and/or replace the InjectionTarget. The container must use the final value of this property, after all observers have been called, whenever it performs injection upon the managed bean, session bean or other Java EE component class supporting injection.

    For example, this observer decorates the InjectionTarget for all servlets.

     public <T extends Servlet> void decorateServlet(@Observes ProcessInjectionTarget<T> pit) {
     pit.setInjectionTarget(decorate(pit.getInjectionTarget()));
 }

    If any observer method of a ProcessInjectionTarget event throws an exception, the exception is treated as a definition error by the container.

    Author:
    David Allen
    See Also:
    InjectionTarget

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addDefinitionError(Throwable t)
      Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
      AnnotatedType<X> getAnnotatedType()
      Returns the AnnotatedType representing the managed bean class, session bean class or other Java EE component class supporting injection.
      InjectionTarget<X> getInjectionTarget()
      Returns the InjectionTarget object that will be used by the container to perform injection.
      void setInjectionTarget(InjectionTarget<X> injectionTarget)
      Replaces the InjectionTarget which performs injection for this target.

    • Method Detail

      • getAnnotatedType

        AnnotatedType<X> getAnnotatedType()
        Returns the AnnotatedType representing the managed bean class, session bean class or other Java EE component class supporting injection.
        Returns:
        the AnnotatedType of the bean with an injection target

      • getInjectionTarget

        InjectionTarget<X> getInjectionTarget()
        Returns the InjectionTarget object that will be used by the container to perform injection.
        Returns:
        the InjectionTarget object which performs the injection

      • setInjectionTarget

        void setInjectionTarget(InjectionTarget<X> injectionTarget)
        Replaces the InjectionTarget which performs injection for this target.
        Parameters:
        injectionTarget - The new InjectionTarget to use

      • addDefinitionError

        void addDefinitionError(Throwable t)
        Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
        Parameters:
        t - A Throwable representing the definition error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessManagedBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessManagedBean<X>

  • Type Parameters:
    X - The class of the bean
    All Superinterfaces:
    ProcessBean<X>
    All Known Subinterfaces:
    ProcessSessionBean<X>

    public interface ProcessManagedBean<X>
extends ProcessBean<X>

    The container fires an event of this type for each enabled managed bean, before registering the Bean object.

    If any observer method of a ProcessManagedBean event throws an exception, the exception is treated as a definition error by the container.

    Author:
    David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      AnnotatedType<X> getAnnotatedBeanClass()
      Returns the AnnotatedType representing the bean class.

      • Methods inherited from interface javax.enterprise.inject.spi.ProcessBean

        addDefinitionError, getAnnotated, getBean

    • Method Detail

      • getAnnotatedBeanClass

        AnnotatedType<X> getAnnotatedBeanClass()
        Returns the AnnotatedType representing the bean class.
        Returns:
        the AnnotatedType for the bean being registered
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessObserverMethod (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessObserverMethod<T,X>

  • Type Parameters:
    T - The type of the event being observed
    X - The bean type containing the observer method

    public interface ProcessObserverMethod<T,X>

    The container fires an event of this type for each observer method of each enabled bean, before registering the ObserverMethod object.

    If any observer method of a ProcessObserverMethod event throws an exception, the exception is treated as a definition error by the container.

    Author:
    Gavin King, David Allen
    See Also:
    ObserverMethod

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addDefinitionError(Throwable t)
      Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
      AnnotatedMethod<X> getAnnotatedMethod()
      The AnnotatedMethod representing the observer method.
      ObserverMethod<T> getObserverMethod()
      The ObserverMethod object that will be used by the container to invoke the observer when a matching event is fired.

    • Method Detail

      • getAnnotatedMethod

        AnnotatedMethod<X> getAnnotatedMethod()
        The AnnotatedMethod representing the observer method.
        Returns:
        the AnnotatedMethod representing the observer method

      • getObserverMethod

        ObserverMethod<T> getObserverMethod()
        The ObserverMethod object that will be used by the container to invoke the observer when a matching event is fired.
        Returns:
        the ObserverMethod object that will be used by the container to call the observer method

      • addDefinitionError

        void addDefinitionError(Throwable t)
        Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
        Parameters:
        t - A Throwable representing the definition error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessProducer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessProducer<T,X>

  • Type Parameters:
    T - The bean class of the bean that declares the producer method or field
    X - The return type of the producer method or the type of the producer field

    public interface ProcessProducer<T,X>

    The container fires an event of this type for each producer method or field of each enabled bean, including resources.

    Any observer of this event is permitted to wrap and/or replace the Producer. The container must use the final value of this property, after all observers have been called, whenever it calls the producer or disposer.

    For example, this observer decorates the Producer for the all producer methods and field of type EntityManager.

     void decorateEntityManager(@Observes ProcessProducer<?, EntityManager> pp) {
     pit.setProducer(decorate(pp.getProducer()));
 }

    If any observer method of a ProcessProducer event throws an exception, the exception is treated as a definition error by the container.

    Author:
    David Allen
    See Also:
    Producer

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addDefinitionError(Throwable t)
      Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
      AnnotatedMember<T> getAnnotatedMember()
      Returns the AnnotatedField representing the producer field or the AnnotatedMethod representing the producer method.
      Producer<X> getProducer()
      Returns the Producer object that will be used by the container to call the producer method or read the producer field.
      void setProducer(Producer<X> producer)
      Replaces the Producer object that will be used by the container to call the producer method or read the producer field.

    • Method Detail

      • getAnnotatedMember

        AnnotatedMember<T> getAnnotatedMember()
        Returns the AnnotatedField representing the producer field or the AnnotatedMethod representing the producer method.
        Returns:
        the AnnotatedMember representing the producer

      • getProducer

        Producer<X> getProducer()
        Returns the Producer object that will be used by the container to call the producer method or read the producer field.
        Returns:
        the Producer invoker object used by the container

      • setProducer

        void setProducer(Producer<X> producer)
        Replaces the Producer object that will be used by the container to call the producer method or read the producer field.
        Parameters:
        producer - the new Producer object to use

      • addDefinitionError

        void addDefinitionError(Throwable t)
        Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.
        Parameters:
        t - The definition error to register as a Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessProducerField (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessProducerField<T,X>

  • Type Parameters:
    T - The type of the producer field
    X - The class of the bean declaring the producer field
    All Superinterfaces:
    ProcessBean<X>

    public interface ProcessProducerField<T,X>
extends ProcessBean<X>

    The container fires an event of this type for each enabled producer field, before registering the Bean object. Resources are considered to be producer fields.

    If any observer method of a ProcessProducerField event throws an exception, the exception is treated as a definition error by the container.

    Author:
    David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      AnnotatedParameter<T> getAnnotatedDisposedParameter()
      Returns the AnnotatedParameter for any matching injection point of the same type as the producer field return type found on a disposal method.
      AnnotatedField<T> getAnnotatedProducerField()
      Returns the AnnotatedField representing the producer field.

      • Methods inherited from interface javax.enterprise.inject.spi.ProcessBean

        addDefinitionError, getAnnotated, getBean

    • Method Detail

      • getAnnotatedProducerField

        AnnotatedField<T> getAnnotatedProducerField()
        Returns the AnnotatedField representing the producer field.
        Returns:
        the AnnotatedField for the producer field being registered

      • getAnnotatedDisposedParameter

        AnnotatedParameter<T> getAnnotatedDisposedParameter()
        Returns the AnnotatedParameter for any matching injection point of the same type as the producer field return type found on a disposal method.
        Returns:
        the disposal method's AnnotatedParameter
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessProducerMethod (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessProducerMethod<T,X>

  • Type Parameters:
    T - The return type of the producer method
    X - The class of the bean declaring the producer method
    All Superinterfaces:
    ProcessBean<X>

    public interface ProcessProducerMethod<T,X>
extends ProcessBean<X>

    The container fires an event of this type for each enabled producer method, before registering the Bean object.

    If any observer method of a ProcessProducerMethod event throws an exception, the exception is treated as a definition error by the container.

    Author:
    David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      AnnotatedParameter<T> getAnnotatedDisposedParameter()
      Returns the AnnotatedParameter for any matching injection point of the same type as the producer method return type found on a disposal method.
      AnnotatedMethod<T> getAnnotatedProducerMethod()
      Returns the AnnotatedMethod representing the producer method.

      • Methods inherited from interface javax.enterprise.inject.spi.ProcessBean

        addDefinitionError, getAnnotated, getBean

    • Method Detail

      • getAnnotatedProducerMethod

        AnnotatedMethod<T> getAnnotatedProducerMethod()
        Returns the AnnotatedMethod representing the producer method.
        Returns:
        the AnnotatedMethod for the producer method being registered

      • getAnnotatedDisposedParameter

        AnnotatedParameter<T> getAnnotatedDisposedParameter()
        Returns the AnnotatedParameter for any matching injection point of the same type as the producer method return type found on a disposal method.
        Returns:
        the disposal method's AnnotatedParameter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessSessionBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessSessionBean<X>

  • Type Parameters:
    X -
    All Superinterfaces:
    ProcessBean<Object>, ProcessManagedBean<Object>

    public interface ProcessSessionBean<X>
extends ProcessManagedBean<Object>

    The container fires an event of this type for each enabled session bean, before registering the Bean object.

    If any observer method of a ProcessSessionBean event throws an exception, the exception is treated as a definition error by the container.

    Note that the type parameter of the super-interface of ProcessSessionBean is Object as ProcessBean allows you access to the Bean, which in turn allows you to instantiate an instance, which, for interface-view EJBs will not be an instance of X.

    Author:
    David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getEjbName()
      Returns the EJB name of the session bean.
      SessionBeanType getSessionBeanType()
      Returns a SessionBeanType representing the kind of session bean.

      • Methods inherited from interface javax.enterprise.inject.spi.ProcessManagedBean

        getAnnotatedBeanClass

      • Methods inherited from interface javax.enterprise.inject.spi.ProcessBean

        addDefinitionError, getAnnotated, getBean

    • Method Detail

      • getEjbName

        String getEjbName()
        Returns the EJB name of the session bean.
        Returns:
        the name of the EJB

      • getSessionBeanType

        SessionBeanType getSessionBeanType()
        Returns a SessionBeanType representing the kind of session bean.
        Returns:
        the SessionBeanType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessSyntheticAnnotatedType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProcessSyntheticAnnotatedType<X>

  • Type Parameters:
    X - The class being annotated
    All Superinterfaces:
    ProcessAnnotatedType<X>

    public interface ProcessSyntheticAnnotatedType<X>
extends ProcessAnnotatedType<X>

    The container fires an event of this type for each Java class or interface added by BeforeBeanDiscovery.addAnnotatedType(AnnotatedType).

    Any observer of this event is permitted to wrap and/or replace the AnnotatedType. The container must use the final value of this property, after all observers have been called, to discover the types and read the annotations of the program elements.

    For example, the following observer decorates the AnnotatedType for every class that is added by BeforeBeanDiscovery.addAnnotatedType(AnnotatedType).

     public <T> void decorateAnnotatedType(@Observes ProcessSyntheticAnnotatedType<T> pat) {
     pat.setAnnotatedType(decorate(pat.getAnnotatedType()));
 }

    If any observer method of a ProcessSyntheticAnnotatedType event throws an exception, the exception is treated as a definition error by the container.

    Since:
    1.1
    Author:
    David Allen, Pete Muir
    See Also:
    AnnotatedType, ProcessAnnotatedType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Extension getSource()
      Get the extension instance which added the AnnotatedType for which this event is being fired.

      • Methods inherited from interface javax.enterprise.inject.spi.ProcessAnnotatedType

        getAnnotatedType, setAnnotatedType, veto

    • Method Detail

      • getSource

        Extension getSource()
        Get the extension instance which added the AnnotatedType for which this event is being fired.
        Returns:
        the extension instance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Producer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface Producer<T>

  • Type Parameters:
    T - The class of object produced by the producer
    All Known Subinterfaces:
    InjectionTarget<T>

    public interface Producer<T>

    Provides a generic operation for producing an instance of a type.

    Author:
    Pete Muir, David Allen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void dispose(T instance)
      Destroys the instance.
      Set<InjectionPoint> getInjectionPoints()
      Returns the set of all InjectionPoints.
      T produce(CreationalContext<T> ctx)
      Causes an instance to be produced via the Producer.

    • Method Detail

      • produce

        T produce(CreationalContext<T> ctx)

        Causes an instance to be produced via the Producer.

        If the Producer represents a class, this will invoke the constructor annotated Inject if it exists, or the constructor with no parameters otherwise. If the class has interceptors, produce() is responsible for building the interceptors and decorators of the instance.

        If the Producer represents a producer field or method, this will invoke the producer method on, or access the producer field of, a contextual instance of the bean that declares the producer.

        Parameters:
        ctx - The CreationalContext to use for the produced object
        Returns:
        the instance produced

      • dispose

        void dispose(T instance)

        Destroys the instance.

        If the Producer represents a class, then this operation does nothing.

        If the Producer represents a producer field or method, this calls the disposer method, if any, on a contextual instance of the bean that declares the disposer method or performs any additional required cleanup, if any, to destroy state associated with a resource.

        Parameters:
        instance - The instance to dispose

      • getInjectionPoints

        Set<InjectionPoint> getInjectionPoints()

        Returns the set of all InjectionPoints. If the Producer represents a class, then this returns returns the set of InjectionPoint objects representing all injected fields, bean constructor parameters and initializer method parameters. For a producer method, this returns the set of InjectionPoint objects representing all parameters of the producer method.

        Returns:
        the set of all injection points for the producer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProducerFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Interface ProducerFactory<X>

  • public interface ProducerFactory<X>

    An ProducerFactory can create an Producer for a given bean.

    The ProducerFactory obtained from BeanManager#getProducerFactory() is capable of providing container created producers. This factory can be wrapped to add behavior to container created producers.

    For example:

     BeanAttributes<MyBean> myBeanAttributes = beanManager.createBeanAttributes(myBeanAnnotatedFieldField);
 beanManager.createBean(myBeanAttributes, MyBean.class, new ProducerFactory() {

     public <T> Producer<T> createProducer(Bean<T> bean) {
         return new WrappingProducer<T>(beanManager.getProducerFactory(myBeanAnnotatedField).createProducer(bean));
     }
 });
    Since:
    1.1
    Author:
    Pete Muir

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T> Producer<T> createProducer(Bean<T> bean)
      Create a new producer for a bean.

    • Method Detail

      • createProducer

        <T> Producer<T> createProducer(Bean<T> bean)
        Create a new producer for a bean.
        Parameters:
        bean - the bean to create the producer for, or null if creating a non-contextual object
        Returns:
        the producer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SessionBeanType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.enterprise.inject.spi

Enum SessionBeanType

  • java.lang.Object
    • java.lang.Enum<SessionBeanType>
      • javax.enterprise.inject.spi.SessionBeanType
  • All Implemented Interfaces:
    Serializable, Comparable<SessionBeanType>

    public enum SessionBeanType
extends Enum<SessionBeanType>
    Identifies the kind of EJB session bean.
    Author:
    Gavin King

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      SINGLETON
      A singleton session bean
      STATEFUL
      A stateful session bean
      STATELESS
      A stateless session bean

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static SessionBeanType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SessionBeanType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • STATELESS

        public static final SessionBeanType STATELESS
        A stateless session bean

      • STATEFUL

        public static final SessionBeanType STATEFUL
        A stateful session bean

      • SINGLETON

        public static final SessionBeanType SINGLETON
        A singleton session bean

    • Method Detail

      • values

        public static SessionBeanType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SessionBeanType c : SessionBeanType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SessionBeanType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Unmanaged (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Class Unmanaged<T>

  • java.lang.Object
    • javax.enterprise.inject.spi.Unmanaged<T>

  • public class Unmanaged<T>
extends Object

    Helper class for injecting and calling lifecycle callbacks unmanaged instances for use by framework and library integrators.

     Unmanaged<Foo> unmanagedFoo = new Unmanaged<Foo>(Foo.class);
 UnmanagedInstance<Foo> fooInstance = unmanagedFoo.newInstance();
 Foo foo = fooInstance.produce().inject().postConstruct().get();
 ... // Use the foo instance
 fooInstance.preDestroy().dispose();

    An instance of this class can be safely held for the lifetime of the application.

    Unmanaged.UnmanagedInstances created by this class are not suitable for sharing between threads.

    Since:
    1.1
    Author:
    Pete Muir

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  Unmanaged.UnmanagedInstance<T>
      Represents a non-contextual instance.

    • Constructor Summary

      Constructors
      Constructor and Description
      Unmanaged(BeanManager manager, Class<T> clazz)
      Create an injector for the given class
      Unmanaged(Class<T> clazz)
      Create an injector for the given class, using the current bean manager

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Unmanaged.UnmanagedInstance<T> newInstance()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Unmanaged

        public Unmanaged(BeanManager manager,
         Class<T> clazz)
        Create an injector for the given class

      • Unmanaged

        public Unmanaged(Class<T> clazz)
        Create an injector for the given class, using the current bean manager

    • Method Detail

      • newInstance

        public Unmanaged.UnmanagedInstance<T> newInstance()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Unmanaged.UnmanagedInstance (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.inject.spi

Class Unmanaged.UnmanagedInstance<T>

  • java.lang.Object
    • javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance<T>
  • Enclosing class:
    Unmanaged<T>

    public static class Unmanaged.UnmanagedInstance<T>
extends Object
    Represents a non-contextual instance.
    See Also:
    Unmanaged

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Unmanaged.UnmanagedInstance<T> dispose()
      Dispose of the instance, doing any necessary cleanup
      T get()
      Get the instance
      Unmanaged.UnmanagedInstance<T> inject()
      Inject the instance
      Unmanaged.UnmanagedInstance<T> postConstruct()
      Call the @PostConstruct callback
      Unmanaged.UnmanagedInstance<T> preDestroy()
      Call the @PreDestroy callback
      Unmanaged.UnmanagedInstance<T> produce()
      Create the instance

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • get

        public T get()
        Get the instance

      • produce

        public Unmanaged.UnmanagedInstance<T> produce()
        Create the instance
        Throws:
        IllegalStateException - if produce() is called on an already produced instance
        IllegalStateException - if produce() is called on an instance that has already been disposed

      • inject

        public Unmanaged.UnmanagedInstance<T> inject()
        Inject the instance
        Throws:
        IllegalStateException - if inject() is called before produce() is called
        IllegalStateException - if inject() is called on an instance that has already been disposed

      • postConstruct

        public Unmanaged.UnmanagedInstance<T> postConstruct()
        Call the @PostConstruct callback
        Throws:
        IllegalStateException - if postConstruct() is called before produce() is called
        IllegalStateException - if postConstruct() is called on an instance that has already been disposed

      • preDestroy

        public Unmanaged.UnmanagedInstance<T> preDestroy()
        Call the @PreDestroy callback
        Throws:
        IllegalStateException - if preDestroy() is called before produce() is called
        IllegalStateException - if preDestroy() is called on an instance that has already been disposed

      • dispose

        public Unmanaged.UnmanagedInstance<T> dispose()
        Dispose of the instance, doing any necessary cleanup
        Throws:
        IllegalStateException - if dispose() is called before produce() is called
        IllegalStateException - if dispose() is called on an instance that has already been disposed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.enterprise.inject.spi (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.inject.spi

  • Packages that use javax.enterprise.inject.spi
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.
  • Classes in javax.enterprise.inject.spi used by javax.enterprise.inject.spi
    Class and Description
    Annotated
    Represents a Java program element that can be annotated.
    AnnotatedCallable
    Represents a callable member of a Java type.
    AnnotatedConstructor
    Represents a constructor of a Java class.
    AnnotatedField
    Represents a field of a Java class.
    AnnotatedMember
    Represents a member of a Java type.
    AnnotatedMethod
    Represents a method of a Java type.
    AnnotatedParameter
    Represents a parameter of a method or constructor.
    AnnotatedType
    Represents a Java class or interface.
    Bean
    Represents an enabled bean.
    BeanAttributes
    The BeanAttributes interface exposes the basic attributes of a bean.
    BeanManager
    Allows a portable extension to interact directly with the container.
    CDI
    Provides access to the current container.
    CDIProvider
    Interface implemented by a CDI provider to provide access to the current container
    Decorator
    Represents an enabled decorator.
    Extension
    Service interface implemented by extensions.
    InjectionPoint
    Provides access to metadata about an injection point.
    InjectionTarget
    Provides operations for performing dependency injection and lifecycle callbacks on an instance of a type.
    InjectionTargetFactory
    An InjectionTargetFactory can create an InjectionTarget for a given bean.
    InterceptionType
    Identifies the kind of lifecycle callback, EJB timeout method or business method interception.
    Interceptor
    Represents an enabled interceptor.
    ObserverMethod
    Represents an observer method of an enabled bean.
    ProcessAnnotatedType
    The container fires an event of this type for each Java class or interface it discovers in a bean archive, before it reads the declared annotations.
    ProcessBean
    The container fires an event of this type for each enabled bean, interceptor or decorator deployed in a bean archive, before registering the Bean object.
    ProcessManagedBean
    The container fires an event of this type for each enabled managed bean, before registering the Bean object.
    Producer
    Provides a generic operation for producing an instance of a type.
    ProducerFactory
    An ProducerFactory can create an Producer for a given bean.
    SessionBeanType
    Identifies the kind of EJB session bean.
    Unmanaged.UnmanagedInstance
    Represents a non-contextual instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WithAnnotations (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.inject.spi

Annotation Type WithAnnotations

  • @Retention(value=RUNTIME)
@Target(value=PARAMETER)
public @interface WithAnnotations

    WithAnnotations may be applied to any portable extension observer method with an event parameter type of ProcessAnnotatedType to filter the events delivered.

    If the WithAnnotations annotation is applied to a portable extension observer method, then only ProcessAnnotatedType events for types which have at least one of the annotations specified are observed. The annotation can appear on the type, or any of it's supertypes, on any field, method or constructor declared by the type, or any of its supertypes, or on any parameter of any method or constructor declared by the type, or any of it's supertypes or may be applied as a meta-annotation.

    Since:
    1.1
    Author:
    Pete Muir

    • Required Element Summary

      Required Elements
      Modifier and Type | Required Element and Description
      Class<? extends Annotation>[] | value

    • Element Detail

      • value

        public abstract Class<? extends Annotation>[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.enterprise.inject.spi.CDI (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.spi.CDI

  • Packages that use CDI
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of CDI in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return CDI
      Modifier and Type Method and Description
      static CDI<Object> CDI.current()
      Get the CDI instance that provides access to the current container.
      CDI<Object> CDIProvider.getCDI()
      Provides access to the current container
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.spi.DefinitionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.spi.DefinitionException

No usage of javax.enterprise.inject.spi.DefinitionException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.spi.DeploymentException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.spi.DeploymentException

No usage of javax.enterprise.inject.spi.DeploymentException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.spi.InterceptionType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.spi.InterceptionType

  • Packages that use InterceptionType
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of InterceptionType in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return InterceptionType
      Modifier and Type Method and Description
      static InterceptionType InterceptionType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static InterceptionType[] InterceptionType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.enterprise.inject.spi with parameters of type InterceptionType
      Modifier and Type Method and Description
      Object Interceptor.intercept(InterceptionType type, T instance, InvocationContext ctx)
      Invokes the specified kind of lifecycle callback or method invocation interception upon the given interceptor instance.
      boolean Interceptor.intercepts(InterceptionType type)
      Determines if the interceptor intercepts the specified kind of lifecycle callback or method invocation.
      List<Interceptor<?>> BeanManager.resolveInterceptors(InterceptionType type, Annotation... interceptorBindings)
      Return an ordered list of enabled interceptors for a set of interceptor bindings and a type of interception and which are enabled in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.spi.SessionBeanType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.spi.SessionBeanType

  • Packages that use SessionBeanType
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of SessionBeanType in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return SessionBeanType
      Modifier and Type Method and Description
      SessionBeanType ProcessSessionBean.getSessionBeanType()
      Returns a SessionBeanType representing the kind of session bean.
      static SessionBeanType SessionBeanType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SessionBeanType[] SessionBeanType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.spi.Unmanaged (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.spi.Unmanaged

No usage of javax.enterprise.inject.spi.Unmanaged
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance

  • Packages that use Unmanaged.UnmanagedInstance
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Unmanaged.UnmanagedInstance in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return Unmanaged.UnmanagedInstance
      Modifier and Type | Method and Description
      Unmanaged.UnmanagedInstance<T> Unmanaged.UnmanagedInstance.dispose()
      Dispose of the instance, doing any necessary cleanup
      Unmanaged.UnmanagedInstance<T> Unmanaged.UnmanagedInstance.inject()
      Inject the instance
      Unmanaged.UnmanagedInstance<T> | Unmanaged.newInstance()
      Unmanaged.UnmanagedInstance<T> Unmanaged.UnmanagedInstance.postConstruct()
      Call the @PostConstruct callback
      Unmanaged.UnmanagedInstance<T> Unmanaged.UnmanagedInstance.preDestroy()
      Call the @PreDestroy callback
      Unmanaged.UnmanagedInstance<T> Unmanaged.UnmanagedInstance.produce()
      Create the instance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.inject.spi.WithAnnotations (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.inject.spi.WithAnnotations

No usage of javax.enterprise.inject.spi.WithAnnotations
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.AfterBeanDiscovery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.AfterBeanDiscovery

No usage of javax.enterprise.inject.spi.AfterBeanDiscovery
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.AfterDeploymentValidation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.AfterDeploymentValidation

No usage of javax.enterprise.inject.spi.AfterDeploymentValidation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.AfterTypeDiscovery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.AfterTypeDiscovery

No usage of javax.enterprise.inject.spi.AfterTypeDiscovery
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.Annotated (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.Annotated

  • Packages that use Annotated
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Annotated in javax.enterprise.inject.spi

      Subinterfaces of Annotated in javax.enterprise.inject.spi
      Modifier and Type Interface and Description
      interface  AnnotatedCallable<X>
      Represents a callable member of a Java type.
      interface  AnnotatedConstructor<X>
      Represents a constructor of a Java class.
      interface  AnnotatedField<X>
      Represents a field of a Java class.
      interface  AnnotatedMember<X>
      Represents a member of a Java type.
      interface  AnnotatedMethod<X>
      Represents a method of a Java type.
      interface  AnnotatedParameter<X>
      Represents a parameter of a method or constructor.
      interface  AnnotatedType<X>
      Represents a Java class or interface.
      Methods in javax.enterprise.inject.spi that return Annotated
      Modifier and Type | Method and Description
      Annotated | ProcessBeanAttributes.getAnnotated()
      Annotated ProcessBean.getAnnotated()
      Returns the AnnotatedType representing the bean class, the AnnotatedMethod representing the producer method, or the AnnotatedField representing the producer field.
      Annotated InjectionPoint.getAnnotated()
      Obtain an instance of AnnotatedField or AnnotatedParameter, depending upon whether the injection point is an injected field or a constructor/method parameter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.AnnotatedCallable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.AnnotatedCallable

  • Packages that use AnnotatedCallable
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of AnnotatedCallable in javax.enterprise.inject.spi

      Subinterfaces of AnnotatedCallable in javax.enterprise.inject.spi
      Modifier and Type Interface and Description
      interface  AnnotatedConstructor<X>
      Represents a constructor of a Java class.
      interface  AnnotatedMethod<X>
      Represents a method of a Java type.
      Methods in javax.enterprise.inject.spi that return AnnotatedCallable
      Modifier and Type Method and Description
      AnnotatedCallable<X> AnnotatedParameter.getDeclaringCallable()
      Get the declaring method or constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.AnnotatedConstructor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.AnnotatedConstructor

  • Packages that use AnnotatedConstructor
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of AnnotatedConstructor in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return types with arguments of type AnnotatedConstructor
      Modifier and Type Method and Description
      Set<AnnotatedConstructor<X>> AnnotatedType.getConstructors()
      Get the constructors of the type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.AnnotatedField (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.AnnotatedField

  • Packages that use AnnotatedField
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of AnnotatedField in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return AnnotatedField
      Modifier and Type Method and Description
      AnnotatedField<T> ProcessProducerField.getAnnotatedProducerField()
      Returns the AnnotatedField representing the producer field.
      Methods in javax.enterprise.inject.spi that return types with arguments of type AnnotatedField
      Modifier and Type Method and Description
      Set<AnnotatedField<? super X>> AnnotatedType.getFields()
      Get the fields of the type.
      Methods in javax.enterprise.inject.spi with parameters of type AnnotatedField
      Modifier and Type Method and Description
      InjectionPoint BeanManager.createInjectionPoint(AnnotatedField<?> field)
      Obtains a container provided implementation of InjectionPoint for the given AnnotatedField.
      <X> ProducerFactory<X> BeanManager.getProducerFactory(AnnotatedField<? super X> field, Bean<X> declaringBean)
      An implementation of ProducerFactory that provides container created Producer instances for the given field.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.AnnotatedMember (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.AnnotatedMember

  • Packages that use AnnotatedMember
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of AnnotatedMember in javax.enterprise.inject.spi

      Subinterfaces of AnnotatedMember in javax.enterprise.inject.spi
      Modifier and Type Interface and Description
      interface  AnnotatedCallable<X>
      Represents a callable member of a Java type.
      interface  AnnotatedConstructor<X>
      Represents a constructor of a Java class.
      interface  AnnotatedField<X>
      Represents a field of a Java class.
      interface  AnnotatedMethod<X>
      Represents a method of a Java type.
      Methods in javax.enterprise.inject.spi that return AnnotatedMember
      Modifier and Type Method and Description
      AnnotatedMember<T> ProcessProducer.getAnnotatedMember()
      Returns the AnnotatedField representing the producer field or the AnnotatedMethod representing the producer method.
      Methods in javax.enterprise.inject.spi with parameters of type AnnotatedMember
      Modifier and Type Method and Description
      BeanAttributes<?> BeanManager.createBeanAttributes(AnnotatedMember<?> type)
      Obtains a BeanAttributes for the given AnnotatedType.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.AnnotatedMethod (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.AnnotatedMethod

  • Packages that use AnnotatedMethod
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of AnnotatedMethod in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return AnnotatedMethod
      Modifier and Type Method and Description
      AnnotatedMethod<X> ProcessObserverMethod.getAnnotatedMethod()
      The AnnotatedMethod representing the observer method.
      AnnotatedMethod<T> ProcessProducerMethod.getAnnotatedProducerMethod()
      Returns the AnnotatedMethod representing the producer method.
      Methods in javax.enterprise.inject.spi that return types with arguments of type AnnotatedMethod
      Modifier and Type Method and Description
      Set<AnnotatedMethod<? super X>> AnnotatedType.getMethods()
      Get the methods of the type.
      Methods in javax.enterprise.inject.spi with parameters of type AnnotatedMethod
      Modifier and Type Method and Description
      <X> ProducerFactory<X> BeanManager.getProducerFactory(AnnotatedMethod<? super X> method, Bean<X> declaringBean)
      An implementation of ProducerFactory that provides container created Producer instances for the given method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.AnnotatedParameter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.AnnotatedParameter

  • Packages that use AnnotatedParameter
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of AnnotatedParameter in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return AnnotatedParameter
      Modifier and Type Method and Description
      AnnotatedParameter<T> ProcessProducerMethod.getAnnotatedDisposedParameter()
      Returns the AnnotatedParameter for any matching injection point of the same type as the producer method return type found on a disposal method.
      AnnotatedParameter<T> ProcessProducerField.getAnnotatedDisposedParameter()
      Returns the AnnotatedParameter for any matching injection point of the same type as the producer field return type found on a disposal method.
      Methods in javax.enterprise.inject.spi that return types with arguments of type AnnotatedParameter
      Modifier and Type Method and Description
      List<AnnotatedParameter<X>> AnnotatedCallable.getParameters()
      Get the parameters of the callable member.
      Methods in javax.enterprise.inject.spi with parameters of type AnnotatedParameter
      Modifier and Type Method and Description
      InjectionPoint BeanManager.createInjectionPoint(AnnotatedParameter<?> parameter)
      Obtains a container provided implementation of InjectionPoint for the given AnnotatedParameter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.AnnotatedType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.AnnotatedType

  • Packages that use AnnotatedType
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of AnnotatedType in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return AnnotatedType
      Modifier and Type Method and Description
      <T> AnnotatedType<T> BeanManager.createAnnotatedType(Class<T> type)
      Obtain an AnnotatedType that may be used to read the annotations of the given class or interface.
      AnnotatedType<X> ProcessManagedBean.getAnnotatedBeanClass()
      Returns the AnnotatedType representing the bean class.
      AnnotatedType<X> ProcessInjectionTarget.getAnnotatedType()
      Returns the AnnotatedType representing the managed bean class, session bean class or other Java EE component class supporting injection.
      AnnotatedType<X> ProcessAnnotatedType.getAnnotatedType()
      Returns the AnnotatedType object that will be used by the container to read the declared annotations.
      <T> AnnotatedType<T> AfterBeanDiscovery.getAnnotatedType(Class<T> type, String id)
      Obtain the AnnotatedType that may be used to read the annotations of the given class or interface as defined during container initialization.
      AnnotatedType<X> AnnotatedMember.getDeclaringType()
      Get the type which defines this member.
      Methods in javax.enterprise.inject.spi that return types with arguments of type AnnotatedType
      Modifier and Type Method and Description
      <T> Iterable<AnnotatedType<T>> AfterBeanDiscovery.getAnnotatedTypes(Class<T> type)
      Obtain the AnnotatedTypes that may be used to read the annotations of the given class or interface as defined during container initialization.
      Methods in javax.enterprise.inject.spi with parameters of type AnnotatedType
      Modifier and Type Method and Description
      void BeforeBeanDiscovery.addAnnotatedType(AnnotatedType<?> type)
      Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.
      void BeforeBeanDiscovery.addAnnotatedType(AnnotatedType<?> type, String id)
      Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.
      void AfterTypeDiscovery.addAnnotatedType(AnnotatedType<?> type, String id)
      Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.
      void BeforeBeanDiscovery.addInterceptorBinding(AnnotatedType<? extends Annotation> bindingType)
      Declares an annotation type as an interceptor binding type.
      void BeforeBeanDiscovery.addQualifier(AnnotatedType<? extends Annotation> qualifier)
      Declares an annotation type as a Qualifier qualifier type.
      <T> BeanAttributes<T> BeanManager.createBeanAttributes(AnnotatedType<T> type)
      Obtains a BeanAttributes for the given AnnotatedType.
      <T> InjectionTarget<T> BeanManager.createInjectionTarget(AnnotatedType<T> type)
      Obtains an InjectionTarget for the given AnnotatedType.
      <T> InjectionTargetFactory<T> BeanManager.getInjectionTargetFactory(AnnotatedType<T> annotatedType)
      An implementation of InjectionTargetFactory that provides container created InjectionTarget instances.
      void ProcessAnnotatedType.setAnnotatedType(AnnotatedType<X> type)
      Replaces the AnnotatedType.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.Bean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.Bean

  • Packages that use Bean
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Bean in javax.enterprise.inject.spi

      Subinterfaces of Bean in javax.enterprise.inject.spi
      Modifier and Type Interface and Description
      interface  Decorator<T>
      Represents an enabled decorator.
      interface  Interceptor<T>
      Represents an enabled interceptor.
      Methods in javax.enterprise.inject.spi that return Bean
      Modifier and Type Method and Description
      <T> Bean<T> BeanManager.createBean(BeanAttributes<T> attributes, Class<T> beanClass, InjectionTargetFactory<T> injectionTargetFactory)
      Obtains a Bean for the given BeanAttributes, bean class and InjectionTarget.
      <T,X> Bean<T> BeanManager.createBean(BeanAttributes<T> attributes, Class<X> beanClass, ProducerFactory<X> producerFactory)
      Obtains a Bean for the given BeanAttributes, bean class and Producer.
      Bean<X> ProcessBean.getBean()
      Returns the Bean object that is about to be registered.
      Bean<?> InjectionPoint.getBean()
      Get the Bean object representing the bean that defines the injection point.
      Bean<?> BeanManager.getPassivationCapableBean(String id)
      Returns the PassivationCapable bean with the given identifier.
      <X> Bean<? extends X> BeanManager.resolve(Set<Bean<? extends X>> beans)
      Apply the ambiguous dependency resolution rules to a set of beans.
      Methods in javax.enterprise.inject.spi that return types with arguments of type Bean
      Modifier and Type Method and Description
      Set<Bean<?>> BeanManager.getBeans(String name)
      Return the set of beans which have the given EL name and are available for injection in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained, according to the rules of EL name resolution.
      Set<Bean<?>> BeanManager.getBeans(Type beanType, Annotation... qualifiers)
      Return the set of beans which have the given required type and qualifiers and are available for injection in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained, according to the rules of typesafe resolution.
      Methods in javax.enterprise.inject.spi with parameters of type Bean
      Modifier and Type Method and Description
      void AfterBeanDiscovery.addBean(Bean<?> bean)
      Fires an event of type ProcessBean containing the given Bean and then registers the Bean with the container, thereby making it available for injection into other beans.
      InjectionTarget<T> InjectionTargetFactory.createInjectionTarget(Bean<T> bean)
      Create a new injection target for a bean.
      <T> Producer<T> ProducerFactory.createProducer(Bean<T> bean)
      Create a new producer for a bean.
      <X> ProducerFactory<X> BeanManager.getProducerFactory(AnnotatedField<? super X> field, Bean<X> declaringBean)
      An implementation of ProducerFactory that provides container created Producer instances for the given field.
      <X> ProducerFactory<X> BeanManager.getProducerFactory(AnnotatedMethod<? super X> method, Bean<X> declaringBean)
      An implementation of ProducerFactory that provides container created Producer instances for the given method.
      Object BeanManager.getReference(Bean<?> bean, Type beanType, CreationalContext<?> ctx)
      Obtains a contextual reference for a certain bean and a certain bean type of the bean.
      Method parameters in javax.enterprise.inject.spi with type arguments of type Bean
      Modifier and Type Method and Description
      <X> Bean<? extends X> BeanManager.resolve(Set<Bean<? extends X>> beans)
      Apply the ambiguous dependency resolution rules to a set of beans.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.BeanAttributes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.BeanAttributes

  • Packages that use BeanAttributes
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of BeanAttributes in javax.enterprise.inject.spi

      Subinterfaces of BeanAttributes in javax.enterprise.inject.spi
      Modifier and Type Interface and Description
      interface  Bean<T>
      Represents an enabled bean.
      interface  Decorator<T>
      Represents an enabled decorator.
      interface  Interceptor<T>
      Represents an enabled interceptor.
      Methods in javax.enterprise.inject.spi that return BeanAttributes
      Modifier and Type | Method and Description
      BeanAttributes<?> BeanManager.createBeanAttributes(AnnotatedMember<?> type)
      Obtains a BeanAttributes for the given AnnotatedType.
      <T> BeanAttributes<T> BeanManager.createBeanAttributes(AnnotatedType<T> type)
      Obtains a BeanAttributes for the given AnnotatedType.
      BeanAttributes<T> | ProcessBeanAttributes.getBeanAttributes()
      Methods in javax.enterprise.inject.spi with parameters of type BeanAttributes
      Modifier and Type Method and Description
      <T> Bean<T> BeanManager.createBean(BeanAttributes<T> attributes, Class<T> beanClass, InjectionTargetFactory<T> injectionTargetFactory)
      Obtains a Bean for the given BeanAttributes, bean class and InjectionTarget.
      <T,X> Bean<T> BeanManager.createBean(BeanAttributes<T> attributes, Class<X> beanClass, ProducerFactory<X> producerFactory)
      Obtains a Bean for the given BeanAttributes, bean class and Producer.
      void ProcessBeanAttributes.setBeanAttributes(BeanAttributes<T> beanAttributes)
      Replaces the BeanAttributes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.BeanManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.BeanManager

  • Packages that use BeanManager
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of BeanManager in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return BeanManager
      Modifier and Type Method and Description
      abstract BeanManager CDI.getBeanManager()
      Get the CDI BeanManager for the current context
      Constructors in javax.enterprise.inject.spi with parameters of type BeanManager
      Constructor and Description
      Unmanaged(BeanManager manager, Class<T> clazz)
      Create an injector for the given class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.BeforeBeanDiscovery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.BeforeBeanDiscovery

No usage of javax.enterprise.inject.spi.BeforeBeanDiscovery
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.BeforeShutdown (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.BeforeShutdown

No usage of javax.enterprise.inject.spi.BeforeShutdown
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.CDIProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.CDIProvider

  • Packages that use CDIProvider
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of CDIProvider in javax.enterprise.inject.spi

      Fields in javax.enterprise.inject.spi declared as CDIProvider
      Modifier and Type | Field and Description
      protected static CDIProvider | CDI.configuredProvider
      Fields in javax.enterprise.inject.spi with type parameters of type CDIProvider
      Modifier and Type | Field and Description
      protected static Set<CDIProvider> | CDI.discoveredProviders
      Methods in javax.enterprise.inject.spi with parameters of type CDIProvider
      Modifier and Type Method and Description
      static void CDI.setCDIProvider(CDIProvider provider)
      Set the CDIProvider to use.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.Decorator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.Decorator

  • Packages that use Decorator
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Decorator in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return types with arguments of type Decorator
      Modifier and Type Method and Description
      List<Decorator<?>> BeanManager.resolveDecorators(Set<Type> types, Annotation... qualifiers)
      Return an ordered list of decorators for a set of bean types and a set of qualifiers and which are enabled in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.EventMetadata (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.EventMetadata

No usage of javax.enterprise.inject.spi.EventMetadata
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.Extension (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.Extension

  • Packages that use Extension
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Extension in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi with type parameters of type Extension
      Modifier and Type Method and Description
      <T extends Extension>
      T             		BeanManager.getExtension(Class<T> extensionClass)
      Obtains the container's instance of an Extension class declared in META-INF/services.
      Methods in javax.enterprise.inject.spi that return Extension
      Modifier and Type Method and Description
      Extension ProcessSyntheticAnnotatedType.getSource()
      Get the extension instance which added the AnnotatedType for which this event is being fired.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.InjectionPoint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.InjectionPoint

  • Packages that use InjectionPoint
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of InjectionPoint in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return InjectionPoint
      Modifier and Type | Method and Description
      InjectionPoint BeanManager.createInjectionPoint(AnnotatedField<?> field)
      Obtains a container provided implementation of InjectionPoint for the given AnnotatedField.
      InjectionPoint BeanManager.createInjectionPoint(AnnotatedParameter<?> parameter)
      Obtains a container provided implementation of InjectionPoint for the given AnnotatedParameter.
      InjectionPoint | ProcessInjectionPoint.getInjectionPoint()
      InjectionPoint EventMetadata.getInjectionPoint()
      Get the InjectionPoint representing the injected Event instance which fired the event, or null if it was fired from BeanManager.fireEvent(Object, Annotation...);
      Methods in javax.enterprise.inject.spi that return types with arguments of type InjectionPoint
      Modifier and Type Method and Description
      Set<InjectionPoint> Producer.getInjectionPoints()
      Returns the set of all InjectionPoints.
      Set<InjectionPoint> Bean.getInjectionPoints()
      Obtains the InjectionPoint objects representing injection points of the bean, that will be validated by the container at initialization time.
      Methods in javax.enterprise.inject.spi with parameters of type InjectionPoint
      Modifier and Type Method and Description
      Object BeanManager.getInjectableReference(InjectionPoint ij, CreationalContext<?> ctx)
      Obtains an injectable reference for a certain injection point.
      void ProcessInjectionPoint.setInjectionPoint(InjectionPoint injectionPoint)
      Replaces the InjectionPoint.
      void BeanManager.validate(InjectionPoint injectionPoint)
      Validate a certain injection point.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.InjectionTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.InjectionTarget

  • Packages that use InjectionTarget
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of InjectionTarget in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return InjectionTarget
      Modifier and Type Method and Description
      <T> InjectionTarget<T> BeanManager.createInjectionTarget(AnnotatedType<T> type)
      Obtains an InjectionTarget for the given AnnotatedType.
      InjectionTarget<T> InjectionTargetFactory.createInjectionTarget(Bean<T> bean)
      Create a new injection target for a bean.
      InjectionTarget<X> ProcessInjectionTarget.getInjectionTarget()
      Returns the InjectionTarget object that will be used by the container to perform injection.
      Methods in javax.enterprise.inject.spi with parameters of type InjectionTarget
      Modifier and Type Method and Description
      void ProcessInjectionTarget.setInjectionTarget(InjectionTarget<X> injectionTarget)
      Replaces the InjectionTarget which performs injection for this target.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.InjectionTargetFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.InjectionTargetFactory

  • Packages that use InjectionTargetFactory
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of InjectionTargetFactory in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return InjectionTargetFactory
      Modifier and Type Method and Description
      <T> InjectionTargetFactory<T> BeanManager.getInjectionTargetFactory(AnnotatedType<T> annotatedType)
      An implementation of InjectionTargetFactory that provides container created InjectionTarget instances.
      Methods in javax.enterprise.inject.spi with parameters of type InjectionTargetFactory
      Modifier and Type Method and Description
      <T> Bean<T> BeanManager.createBean(BeanAttributes<T> attributes, Class<T> beanClass, InjectionTargetFactory<T> injectionTargetFactory)
      Obtains a Bean for the given BeanAttributes, bean class and InjectionTarget.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.Interceptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.Interceptor

  • Packages that use Interceptor
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Interceptor in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return types with arguments of type Interceptor
      Modifier and Type Method and Description
      List<Interceptor<?>> BeanManager.resolveInterceptors(InterceptionType type, Annotation... interceptorBindings)
      Return an ordered list of enabled interceptors for a set of interceptor bindings and a type of interception and which are enabled in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ObserverMethod (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ObserverMethod

  • Packages that use ObserverMethod
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of ObserverMethod in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return ObserverMethod
      Modifier and Type Method and Description
      ObserverMethod<T> ProcessObserverMethod.getObserverMethod()
      The ObserverMethod object that will be used by the container to invoke the observer when a matching event is fired.
      Methods in javax.enterprise.inject.spi that return types with arguments of type ObserverMethod
      Modifier and Type Method and Description
      <T> Set<ObserverMethod<? super T>> BeanManager.resolveObserverMethods(T event, Annotation... qualifiers)
      Return the set of observers for an event.
      Methods in javax.enterprise.inject.spi with parameters of type ObserverMethod
      Modifier and Type Method and Description
      void AfterBeanDiscovery.addObserverMethod(ObserverMethod<?> observerMethod)
      Fires an event of type ProcessObserverMethod containing the given ObserverMethod and then registers the ObserverMethod with the container, thereby making it available for event notifications.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.PassivationCapable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.PassivationCapable

No usage of javax.enterprise.inject.spi.PassivationCapable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessAnnotatedType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessAnnotatedType

  • Packages that use ProcessAnnotatedType
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of ProcessAnnotatedType in javax.enterprise.inject.spi

      Subinterfaces of ProcessAnnotatedType in javax.enterprise.inject.spi
      Modifier and Type Interface and Description
      interface  ProcessSyntheticAnnotatedType<X>
      The container fires an event of this type for each Java class or interface added by BeforeBeanDiscovery.addAnnotatedType(AnnotatedType).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessBean

  • Packages that use ProcessBean
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of ProcessBean in javax.enterprise.inject.spi

      Subinterfaces of ProcessBean in javax.enterprise.inject.spi
      Modifier and Type Interface and Description
      interface  ProcessManagedBean<X>
      The container fires an event of this type for each enabled managed bean, before registering the Bean object.
      interface  ProcessProducerField<T,X>
      The container fires an event of this type for each enabled producer field, before registering the Bean object.
      interface  ProcessProducerMethod<T,X>
      The container fires an event of this type for each enabled producer method, before registering the Bean object.
      interface  ProcessSessionBean<X>
      The container fires an event of this type for each enabled session bean, before registering the Bean object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessBeanAttributes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessBeanAttributes

No usage of javax.enterprise.inject.spi.ProcessBeanAttributes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessInjectionPoint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessInjectionPoint

No usage of javax.enterprise.inject.spi.ProcessInjectionPoint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessInjectionTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessInjectionTarget

No usage of javax.enterprise.inject.spi.ProcessInjectionTarget
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessManagedBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessManagedBean

  • Packages that use ProcessManagedBean
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of ProcessManagedBean in javax.enterprise.inject.spi

      Subinterfaces of ProcessManagedBean in javax.enterprise.inject.spi
      Modifier and Type Interface and Description
      interface  ProcessSessionBean<X>
      The container fires an event of this type for each enabled session bean, before registering the Bean object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessObserverMethod (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessObserverMethod

No usage of javax.enterprise.inject.spi.ProcessObserverMethod
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessProducer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessProducer

No usage of javax.enterprise.inject.spi.ProcessProducer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessProducerField (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessProducerField

No usage of javax.enterprise.inject.spi.ProcessProducerField
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessProducerMethod (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessProducerMethod

No usage of javax.enterprise.inject.spi.ProcessProducerMethod
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessSessionBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessSessionBean

No usage of javax.enterprise.inject.spi.ProcessSessionBean
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProcessSyntheticAnnotatedType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProcessSyntheticAnnotatedType

No usage of javax.enterprise.inject.spi.ProcessSyntheticAnnotatedType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.Producer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.Producer

  • Packages that use Producer
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Producer in javax.enterprise.inject.spi

      Subinterfaces of Producer in javax.enterprise.inject.spi
      Modifier and Type Interface and Description
      interface  InjectionTarget<T>
      Provides operations for performing dependency injection and lifecycle callbacks on an instance of a type.
      Methods in javax.enterprise.inject.spi that return Producer
      Modifier and Type Method and Description
      <T> Producer<T> ProducerFactory.createProducer(Bean<T> bean)
      Create a new producer for a bean.
      Producer<X> ProcessProducer.getProducer()
      Returns the Producer object that will be used by the container to call the producer method or read the producer field.
      Methods in javax.enterprise.inject.spi with parameters of type Producer
      Modifier and Type Method and Description
      void ProcessProducer.setProducer(Producer<X> producer)
      Replaces the Producer object that will be used by the container to call the producer method or read the producer field.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.enterprise.inject.spi.ProducerFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.enterprise.inject.spi.ProducerFactory

  • Packages that use ProducerFactory
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of ProducerFactory in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi that return ProducerFactory
      Modifier and Type Method and Description
      <X> ProducerFactory<X> BeanManager.getProducerFactory(AnnotatedField<? super X> field, Bean<X> declaringBean)
      An implementation of ProducerFactory that provides container created Producer instances for the given field.
      <X> ProducerFactory<X> BeanManager.getProducerFactory(AnnotatedMethod<? super X> method, Bean<X> declaringBean)
      An implementation of ProducerFactory that provides container created Producer instances for the given method.
      Methods in javax.enterprise.inject.spi with parameters of type ProducerFactory
      Modifier and Type Method and Description
      <T,X> Bean<T> BeanManager.createBean(BeanAttributes<T> attributes, Class<X> beanClass, ProducerFactory<X> producerFactory)
      Obtains a Bean for the given BeanAttributes, bean class and Producer.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AnnotationLiteral (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.util

Class AnnotationLiteral<T extends Annotation>

  • java.lang.Object
    • javax.enterprise.util.AnnotationLiteral<T>
  • Type Parameters:
    T - the annotation type
    All Implemented Interfaces:
    Serializable, Annotation

    public abstract class AnnotationLiteral<T extends Annotation>
extends Object
implements Annotation, Serializable

    Supports inline instantiation of annotation type instances.

    An instance of an annotation type may be obtained by subclassing AnnotationLiteral.

     public abstract class PayByQualifier extends AnnotationLiteral<PayBy> implements PayBy {
 }

     PayBy paybyCheque = new PayByQualifier() {
     public PaymentMethod value() {
         return CHEQUE;
     }
 };
    Author:
    Pete Muir, Gavin King, Marko Luksa
    See Also:
    Instance.select(Annotation...), Event.select(Annotation...), Serialized Form

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | AnnotationLiteral()

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      Class<? extends Annotation> | annotationType()
      boolean | equals(Object other)
      int | hashCode()
      String toString()

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AnnotationLiteral

        protected AnnotationLiteral()

    • Method Detail

      • annotationType

        public Class<? extends Annotation> annotationType()
        Specified by:
        annotationType in interface Annotation

      • toString

        public String toString()
        Specified by:
        toString in interface Annotation
        Overrides:
        toString in class Object

      • equals

        public boolean equals(Object other)
        Specified by:
        equals in interface Annotation
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Specified by:
        hashCode in interface Annotation
        Overrides:
        hashCode in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.enterprise.util (Java(TM) EE 7 Specification APIs)

javax.enterprise.util

Classes

  • AnnotationLiteral
  • TypeLiteral

Annotation Types

  • Nonbinding


javax.enterprise.util (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.enterprise.util

Contains shared, general-purpose helper classes and annotations.

See: Description

  • Class Summary
    Class Description
    AnnotationLiteral<T extends Annotation>
    Supports inline instantiation of annotation type instances.
    TypeLiteral<T>
    Supports inline instantiation of objects that represent parameterized types with actual type parameters.
  • Annotation Types Summary
    Annotation Type Description
    Nonbinding
    Excludes a member of an annotation type (such as a qualifier type or interceptor binding type) from consideration when the container compares two annotation instances.

Package javax.enterprise.util Description

Contains shared, general-purpose helper classes and annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.enterprise.util Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.enterprise.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.enterprise.util.AnnotationLiteral<T> (implements java.lang.annotation.Annotation, java.io.Serializable)
    • javax.enterprise.util.TypeLiteral<T> (implements java.io.Serializable)

Annotation Type Hierarchy

  • javax.enterprise.util.Nonbinding (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Nonbinding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.enterprise.util

Annotation Type Nonbinding

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface Nonbinding

    Excludes a member of an annotation type (such as a qualifier type or interceptor binding type) from consideration when the container compares two annotation instances.

     @Qualifier
 @Retention(RUNTIME)
 @Target({ METHOD, FIELD, PARAMETER, TYPE })
 public @interface PayBy {
     PaymentMethod value();

     @Nonbinding
     String comment();
 }
    Author:
    Gavin King
    See Also:
    @Qualifier, @InterceptorBinding
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


TypeLiteral (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.enterprise.util

Class TypeLiteral<T>

  • java.lang.Object
    • javax.enterprise.util.TypeLiteral<T>
  • Type Parameters:
    T - the type, including all actual type parameters
    All Implemented Interfaces:
    Serializable

    public abstract class TypeLiteral<T>
extends Object
implements Serializable

    Supports inline instantiation of objects that represent parameterized types with actual type parameters.

    An object that represents any parameterized type may be obtained by subclassing TypeLiteral.

     TypeLiteral<List<String>> stringListType = new TypeLiteral<List<String>>() {
 };
    Author:
    Gavin King, Pete Muir
    See Also:
    Instance.select(TypeLiteral, Annotation...), Event.select(TypeLiteral, Annotation...), Serialized Form

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | TypeLiteral()

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      boolean | equals(Object obj)
      Class<T> getRawType()
      Type getType()
      int | hashCode()
      String toString()

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TypeLiteral

        protected TypeLiteral()

    • Method Detail

      • getType

        public final Type getType()
        Returns:
        the actual type represented by this object

      • getRawType

        public final Class<T> getRawType()
        Returns:
        the raw type represented by this object

      • equals

        public boolean equals(Object obj)
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Overrides:
        hashCode in class Object

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.enterprise.util (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.enterprise.util

  • Packages that use javax.enterprise.util
    Package Description
    javax.enterprise.event
    Annotations and interfaces relating to events.
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.
  • Classes in javax.enterprise.util used by javax.enterprise.event
    Class and Description
    TypeLiteral
    Supports inline instantiation of objects that represent parameterized types with actual type parameters.
  • Classes in javax.enterprise.util used by javax.enterprise.inject
    Class and Description
    TypeLiteral
    Supports inline instantiation of objects that represent parameterized types with actual type parameters.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.util.AnnotationLiteral (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.util.AnnotationLiteral

No usage of javax.enterprise.util.AnnotationLiteral
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.util.Nonbinding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.util.Nonbinding

No usage of javax.enterprise.util.Nonbinding
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.enterprise.util.TypeLiteral (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.enterprise.util.TypeLiteral

  • Packages that use TypeLiteral
    Package Description
    javax.enterprise.event
    Annotations and interfaces relating to events.
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.

    • Uses of TypeLiteral in javax.enterprise.event

      Methods in javax.enterprise.event with parameters of type TypeLiteral
      Modifier and Type Method and Description
      <U extends T>
      Event<U>             		Event.select(TypeLiteral<U> subtype, Annotation... qualifiers)
      Obtains a child Event for the given required type and additional required qualifiers.

    • Uses of TypeLiteral in javax.enterprise.inject

      Methods in javax.enterprise.inject with parameters of type TypeLiteral
      Modifier and Type Method and Description
      <U extends T>
      Instance<U>             		Instance.select(TypeLiteral<U> subtype, Annotation... qualifiers)
      Obtains a child Instance for the given required type and additional required qualifiers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


FacesException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces

Class FacesException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    AbortProcessingException, ConverterException, EvaluationException, FaceletException, ProtectedViewException, UpdateModelException, ValidatorException, ViewExpiredException

    public class FacesException
extends RuntimeException

    This class encapsulates general JavaServer Faces exceptions.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      FacesException()
      Construct a new exception with no detail message or root cause.
      FacesException(String message)
      Construct a new exception with the specified detail message and no root cause.
      FacesException(String message, Throwable cause)
      Construct a new exception with the specified detail message and root cause.
      FacesException(Throwable cause)
      Construct a new exception with the specified root cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Return the cause of this exception, or null if the cause is nonexistent or unknown.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FacesException

        public FacesException()

        Construct a new exception with no detail message or root cause.

      • FacesException

        public FacesException(String message)

        Construct a new exception with the specified detail message and no root cause.

        Parameters:
        message - The detail message for this exception

      • FacesException

        public FacesException(Throwable cause)

        Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

        Parameters:
        cause - The root cause for this exception

      • FacesException

        public FacesException(String message,
              Throwable cause)

        Construct a new exception with the specified detail message and root cause.

        Parameters:
        message - The detail message for this exception
        cause - The root cause for this exception

    • Method Detail

      • getCause

        public Throwable getCause()

        Return the cause of this exception, or null if the cause is nonexistent or unknown.

        Overrides:
        getCause in class Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces

Interface FacesWrapper<T>

  • All Known Implementing Classes:
    ActionListenerWrapper, ApplicationFactory, ApplicationWrapper, ClientWindowFactory, ClientWindowWrapper, ConfigurableNavigationHandlerWrapper, ExceptionHandlerFactory, ExceptionHandlerWrapper, ExternalContextFactory, ExternalContextWrapper, FaceletCacheFactory, FacesContextFactory, FacesContextWrapper, FlashFactory, FlashWrapper, FlowHandlerFactoryWrapper, LifecycleFactory, LifecycleWrapper, NavigationCaseWrapper, NavigationHandlerWrapper, PartialResponseWriter, PartialViewContextFactory, PartialViewContextWrapper, PreJsf2ExceptionHandlerFactory, RendererWrapper, RenderKitFactory, RenderKitWrapper, ResourceHandlerWrapper, ResourceWrapper, ResponseWriterWrapper, StateManagerWrapper, TagHandlerDelegateFactory, ViewDeclarationLanguageFactory, ViewDeclarationLanguageWrapper, ViewHandlerWrapper, VisitContextFactory, VisitContextWrapper

    public interface FacesWrapper<T>

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.

    • Method Detail

      • getWrapped

        T getWrapped()

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FactoryFinder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces

Class FactoryFinder

  • java.lang.Object
    • javax.faces.FactoryFinder

  • public final class FactoryFinder
extends Object

    FactoryFinder implements the standard discovery algorithm for all factory objects specified in the JavaServer Faces APIs. For a given factory class name, a corresponding implementation class is searched for based on the following algorithm. Items are listed in order of decreasing search precedence:

    • If the JavaServer Faces configuration file bundled into the WEB-INF directory of the webapp contains a factory entry of the given factory class name, that factory is used.

    • If the JavaServer Faces configuration files named by the javax.faces.CONFIG_FILES ServletContext init parameter contain any factory entries of the given factory class name, those injectionProvider are used, with the last one taking precedence.

    • If there are any JavaServer Faces configuration files bundled into the META-INF directory of any jars on the ServletContext's resource paths, the factory entries of the given factory class name in those files are used, with the last one taking precedence.

    • If a META-INF/services/{factory-class-name} resource is visible to the web application class loader for the calling application (typically as a injectionProvider of being present in the manifest of a JAR file), its first line is read and assumed to be the name of the factory implementation class to use.

    • If none of the above steps yield a match, the JavaServer Faces implementation specific class is used.

    If any of the injectionProvider found on any of the steps above happen to have a one-argument constructor, with argument the type being the abstract factory class, that constructor is invoked, and the previous match is passed to the constructor. For example, say the container vendor provided an implementation of FacesContextFactory, and identified it in META-INF/services/javax.faces.context.FacesContextFactory in a jar on the webapp ClassLoader. Also say this implementation provided by the container vendor had a one argument constructor that took a FacesContextFactory instance. The FactoryFinder system would call that one-argument constructor, passing the implementation of FacesContextFactory provided by the JavaServer Faces implementation.

    If a Factory implementation does not provide a proper one-argument constructor, it must provide a zero-arguments constructor in order to be successfully instantiated.

    Once the name of the factory implementation class is located, the web application class loader for the calling application is requested to load this class, and a corresponding instance of the class will be created. A side effect of this rule is that each web application will receive its own instance of each factory class, whether the JavaServer Faces implementation is included within the web application or is made visible through the container's facilities for shared libraries.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String APPLICATION_FACTORY
      The property name for the ApplicationFactory class name.
      static String CLIENT_WINDOW_FACTORY
      The property name for the ClientWindowFactory class name.
      static String EXCEPTION_HANDLER_FACTORY

      The property name for the ExceptionHandlerFactory class name.
      static String EXTERNAL_CONTEXT_FACTORY

      The property name for the ExternalContextFactory class name.
      static String FACELET_CACHE_FACTORY

      The property name for the FaceletCacheFactory class name.
      static String FACES_CONTEXT_FACTORY
      The property name for the FacesContextFactory class name.
      static String FLASH_FACTORY

      The property name for the FlashFactory class name.
      static String FLOW_HANDLER_FACTORY

      The property name for the FlowHandlerFactory class name.
      static String LIFECYCLE_FACTORY
      The property name for the LifecycleFactory class name.
      static String PARTIAL_VIEW_CONTEXT_FACTORY

      The property name for the PartialViewContextFactory class name.
      static String RENDER_KIT_FACTORY
      The property name for the RenderKitFactory class name.
      static String TAG_HANDLER_DELEGATE_FACTORY

      The property name for the TagHandlerDelegate class name.
      static String VIEW_DECLARATION_LANGUAGE_FACTORY

      The property name for the ViewDeclarationLanguage class name.
      static String VISIT_CONTEXT_FACTORY

      The property name for the VisitContextFactory class name.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Object getFactory(String factoryName)
      Create (if necessary) and return a per-web-application instance of the appropriate implementation class for the specified JavaServer Faces factory class, based on the discovery algorithm described in the class description.
      static void releaseFactories()
      Release any references to factory instances associated with the class loader for the calling web application.
      static void setFactory(String factoryName, String implName)
      This method will store the argument factoryName/implName mapping in such a way that getFactory(java.lang.String) will find this mapping when searching for a match.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • APPLICATION_FACTORY

        public static final String APPLICATION_FACTORY

        The property name for the ApplicationFactory class name.

        See Also:
        Constant Field Values

      • CLIENT_WINDOW_FACTORY

        public static final String CLIENT_WINDOW_FACTORY

        The property name for the ClientWindowFactory class name.

        Since:
        2.2
        See Also:
        Constant Field Values

      • EXCEPTION_HANDLER_FACTORY

        public static final String EXCEPTION_HANDLER_FACTORY

        The property name for the ExceptionHandlerFactory class name.

        See Also:
        Constant Field Values

      • EXTERNAL_CONTEXT_FACTORY

        public static final String EXTERNAL_CONTEXT_FACTORY

        The property name for the ExternalContextFactory class name.

        See Also:
        Constant Field Values

      • FACES_CONTEXT_FACTORY

        public static final String FACES_CONTEXT_FACTORY

        The property name for the FacesContextFactory class name.

        See Also:
        Constant Field Values

      • FACELET_CACHE_FACTORY

        public static final String FACELET_CACHE_FACTORY

        The property name for the FaceletCacheFactory class name.

        Since:
        2.1
        See Also:
        Constant Field Values

      • FLASH_FACTORY

        public static final String FLASH_FACTORY

        The property name for the FlashFactory class name.

        Since:
        2.2
        See Also:
        Constant Field Values

      • FLOW_HANDLER_FACTORY

        public static final String FLOW_HANDLER_FACTORY

        The property name for the FlowHandlerFactory class name.

        Since:
        2.2
        See Also:
        Constant Field Values

      • PARTIAL_VIEW_CONTEXT_FACTORY

        public static final String PARTIAL_VIEW_CONTEXT_FACTORY

        The property name for the PartialViewContextFactory class name.

        See Also:
        Constant Field Values

      • VISIT_CONTEXT_FACTORY

        public static final String VISIT_CONTEXT_FACTORY

        The property name for the VisitContextFactory class name.

        See Also:
        Constant Field Values

      • LIFECYCLE_FACTORY

        public static final String LIFECYCLE_FACTORY

        The property name for the LifecycleFactory class name.

        See Also:
        Constant Field Values

      • RENDER_KIT_FACTORY

        public static final String RENDER_KIT_FACTORY

        The property name for the RenderKitFactory class name.

        See Also:
        Constant Field Values

      • VIEW_DECLARATION_LANGUAGE_FACTORY

        public static final String VIEW_DECLARATION_LANGUAGE_FACTORY

        The property name for the ViewDeclarationLanguage class name.

        See Also:
        Constant Field Values

      • TAG_HANDLER_DELEGATE_FACTORY

        public static final String TAG_HANDLER_DELEGATE_FACTORY

        The property name for the TagHandlerDelegate class name.

        See Also:
        Constant Field Values

    • Method Detail

      • getFactory

        public static Object getFactory(String factoryName)
                         throws FacesException

        Create (if necessary) and return a per-web-application instance of the appropriate implementation class for the specified JavaServer Faces factory class, based on the discovery algorithm described in the class description.

        The standard injectionProvider and wrappers in JSF all implement the interface FacesWrapper. If the returned Object is an implementation of one of the standard injectionProvider, it must be legal to cast it to an instance of FacesWrapper and call FacesWrapper.getWrapped() on the instance.

        Parameters:
        factoryName - Fully qualified name of the JavaServer Faces factory for which an implementation instance is requested
        Throws:
        FacesException - if the web application class loader cannot be identified
        FacesException - if an instance of the configured factory implementation class cannot be loaded
        FacesException - if an instance of the configured factory implementation class cannot be instantiated
        IllegalArgumentException - if factoryName does not identify a standard JavaServer Faces factory name
        IllegalStateException - if there is no configured factory implementation class for the specified factory name
        NullPointerException - if factoryname is null

      • setFactory

        public static void setFactory(String factoryName,
              String implName)

        This method will store the argument factoryName/implName mapping in such a way that getFactory(java.lang.String) will find this mapping when searching for a match.

        This method has no effect if getFactory() has already been called looking for a factory for this factoryName.

        This method can be used by implementations to store a factory mapping while parsing the Faces configuration file

        Throws:
        IllegalArgumentException - if factoryName does not identify a standard JavaServer Faces factory name
        NullPointerException - if factoryname is null

      • releaseFactories

        public static void releaseFactories()
                             throws FacesException

        Release any references to factory instances associated with the class loader for the calling web application. This method must be called during of web application shutdown.

        Throws:
        FacesException - if the web application class loader cannot be identified
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces (Java(TM) EE 7 Specification APIs)

javax.faces

Interfaces

  • FacesWrapper

Classes

  • FactoryFinder

Exceptions

  • FacesException


javax.faces (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces

Top level classes for the JavaServer(tm) Faces API.

See: Description

  • Interface Summary
    Interface Description
    FacesWrapper<T>

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Class Summary
    Class Description
    FactoryFinder
    FactoryFinder implements the standard discovery algorithm for all factory objects specified in the JavaServer Faces APIs.
  • Exception Summary
    Exception Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.

Package javax.faces Description

Top level classes for the JavaServer(tm) Faces API. The most important class in the package is FactoryFinder, which is the mechanism by which users can override many of the key pieces of the implementation with their own.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.FactoryFinder
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException

Interface Hierarchy

  • javax.faces.FacesWrapper<T>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.faces (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces

  • Packages that use javax.faces
    Package Description
    javax.faces
    Top level classes for the JavaServer(tm) Faces API.
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.visit

    APIs for traversing a user interface component view.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.el
    DEPRECATED Classes and interfaces for evaluating and processing reference expressions.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.
    javax.faces.render
    Classes and interfaces defining the rendering model.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
  • Classes in javax.faces used by javax.faces
    Class and Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.
  • Classes in javax.faces used by javax.faces.application
    Class and Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.
    FacesWrapper

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Classes in javax.faces used by javax.faces.component
    Class and Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.
  • Classes in javax.faces used by javax.faces.component.visit
    Class and Description
    FacesWrapper

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Classes in javax.faces used by javax.faces.context
    Class and Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.
    FacesWrapper

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Classes in javax.faces used by javax.faces.convert
    Class and Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.
  • Classes in javax.faces used by javax.faces.el
    Class and Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.
  • Classes in javax.faces used by javax.faces.event
    Class and Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.
    FacesWrapper

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Classes in javax.faces used by javax.faces.flow
    Class and Description
    FacesWrapper

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Classes in javax.faces used by javax.faces.lifecycle
    Class and Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.
    FacesWrapper

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Classes in javax.faces used by javax.faces.render
    Class and Description
    FacesWrapper

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Classes in javax.faces used by javax.faces.validator
    Class and Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.
  • Classes in javax.faces used by javax.faces.view
    Class and Description
    FacesWrapper

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Classes in javax.faces used by javax.faces.view.facelets
    Class and Description
    FacesException
    This class encapsulates general JavaServer Faces exceptions.
    FacesWrapper

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Classes in javax.faces used by javax.faces.webapp
    Class and Description
    FacesWrapper

    Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Application (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class Application

  • java.lang.Object
    • javax.faces.application.Application
  • Direct Known Subclasses:
    ApplicationWrapper

    public abstract class Application
extends Object

    Application represents a per-web-application singleton object where applications based on JavaServer Faces (or implementations wishing to provide extended functionality) can register application-wide singletons that provide functionality required by JavaServer Faces. Default implementations of each object are provided for cases where the application does not choose to customize the behavior.

    The instance of Application is created by calling the getApplication() method of ApplicationFactory. Because this instance is shared, it must be implemented in a thread-safe manner.

    The application also acts as a factory for several types of Objects specified in the Faces Configuration file. Please see createComponent(java.lang.String), createConverter(java.lang.String), and createValidator(java.lang.String).

    • Constructor Summary

      Constructors
      Constructor and Description
      Application()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addBehavior(String behaviorId, String behaviorClass)
      Register a new mapping of behavior id to the name of the corresponding Behavior class.
      abstract void addComponent(String componentType, String componentClass)
      Register a new mapping of component type to the name of the corresponding UIComponent class.
      abstract void addConverter(Class<?> targetClass, String converterClass)
      Register a new converter class that is capable of performing conversions for the specified target class.
      abstract void addConverter(String converterId, String converterClass)
      Register a new mapping of converter id to the name of the corresponding Converter class.
      void addDefaultValidatorId(String validatorId)

      Register a validator by its id that is applied to all UIInput components in a view.
      void addELContextListener(ELContextListener listener)
      Provide a way for Faces applications to register an ELContextListener that will be notified on creation of ELContext instances.
      void addELResolver(ELResolver resolver)
      Cause an the argument resolver to be added to the resolver chain as specified in section JSF.5.5.1 of the JavaServer Faces Specification.
      abstract void addValidator(String validatorId, String validatorClass)
      Register a new mapping of validator id to the name of the corresponding Validator class.
      Behavior createBehavior(String behaviorId)
      Instantiate and return a new Behavior instance of the class specified by a previous call to addBehavior() for the specified behavior id.
      UIComponent createComponent(FacesContext context, Resource componentResource)

      Instantiate and return a new UIComponent instance from the argument Resource.
      UIComponent createComponent(FacesContext context, String componentType, String rendererType)

      Like createComponent(String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method.
      abstract UIComponent createComponent(String componentType)
      Instantiate and return a new UIComponent instance of the class specified by a previous call to addComponent() for the specified component type.
      abstract UIComponent createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
      Deprecated.
      This has been replaced by createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).
      UIComponent createComponent(ValueExpression componentExpression, FacesContext context, String componentType)
      Call the getValue() method on the specified ValueExpression.
      UIComponent createComponent(ValueExpression componentExpression, FacesContext context, String componentType, String rendererType)

      Like createComponent(ValueExpression, FacesContext, String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method.
      abstract Converter createConverter(Class<?> targetClass)
      Instantiate and return a new Converter instance of the class that has registered itself as capable of performing conversions for objects of the specified type.
      abstract Converter createConverter(String converterId)
      Instantiate and return a new Converter instance of the class specified by a previous call to addConverter() for the specified converter id.
      abstract MethodBinding createMethodBinding(String ref, Class<?>[] params)
      Deprecated.
      This has been replaced by calling getExpressionFactory() then ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>, java.lang.Class<?>[]).
      abstract Validator createValidator(String validatorId)
      Instantiate and return a new Validator instance of the class specified by a previous call to addValidator() for the specified validator id.
      abstract ValueBinding createValueBinding(String ref)
      Deprecated.
      This has been replaced by calling getExpressionFactory() then ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>).
      <T> T evaluateExpressionGet(FacesContext context, String expression, Class<? extends T> expectedType)
      Get a value by evaluating an expression.
      abstract ActionListener getActionListener()
      Return the default ActionListener to be registered for all ActionSource components in this application.
      Iterator<String> getBehaviorIds()
      Return an Iterator over the set of currently registered behavior ids for this Application.
      abstract Iterator<String> getComponentTypes()
      Return an Iterator over the set of currently defined component types for this Application.
      abstract Iterator<String> getConverterIds()
      Return an Iterator over the set of currently registered converter ids for this Application.
      abstract Iterator<Class<?>> getConverterTypes()
      Return an Iterator over the set of Class instances for which Converter classes have been explicitly registered.
      abstract Locale getDefaultLocale()
      Return the default Locale for this application.
      abstract String getDefaultRenderKitId()
      Return the renderKitId to be used for rendering this application.
      Map<String,String> getDefaultValidatorInfo()

      Return an immutable Map over the set of currently registered default validator IDs and their class name for this Application.
      ELContextListener[] getELContextListeners()
      If no calls have been made to addELContextListener(javax.el.ELContextListener), this method must return an empty array.
      ELResolver getELResolver()
      Return the singleton ELResolver instance to be used for all EL resolution.
      ExpressionFactory getExpressionFactory()
      Return the ExpressionFactory instance for this application.
      FlowHandler getFlowHandler()

      Return the thread-safe singleton FlowHandler for this application.
      abstract String getMessageBundle()
      Return the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application.
      abstract NavigationHandler getNavigationHandler()
      Return the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.
      ProjectStage getProjectStage()

      Return the project stage for the currently running application instance.
      abstract PropertyResolver getPropertyResolver()
      Deprecated.
      This has been replaced by getELResolver().
      ResourceBundle getResourceBundle(FacesContext ctx, String name)
      Find a ResourceBundle as defined in the application configuration resources under the specified name.
      ResourceHandler getResourceHandler()

      Return the singleton, stateless, thread-safe ResourceHandler for this application.
      abstract StateManager getStateManager()
      Return the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
      abstract Iterator<Locale> getSupportedLocales()
      Return an Iterator over the supported Locales for this appication.
      abstract Iterator<String> getValidatorIds()
      Return an Iterator over the set of currently registered validator ids for this Application.
      abstract VariableResolver getVariableResolver()
      Deprecated.
      This has been replaced by getELResolver().
      abstract ViewHandler getViewHandler()
      Return the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
      void publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Class<?> sourceBaseType, Object source)

      This method functions exactly like publishEvent(FacesContext,Class,Object), except the run-time must use the argument sourceBaseType to find the matching listener instead of using the Class of the source argument.
      void publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Object source)

      If FacesContext.isProcessingEvents() is true and there are one or more listeners for events of the type represented by systemEventClass, call those listeners, passing source as the source of the event.
      void removeELContextListener(ELContextListener listener)
      Remove the argument listener from the list of ELContextListeners.
      abstract void setActionListener(ActionListener listener)
      Set the default ActionListener to be registered for all ActionSource components.
      abstract void setDefaultLocale(Locale locale)
      Set the default Locale for this application.
      abstract void setDefaultRenderKitId(String renderKitId)
      Set the renderKitId to be used to render this application.
      void setFlowHandler(FlowHandler newHandler)

      Set the FlowHandler instance used by the NavigationHandler to satisfy the requirements of the faces flows feature.
      abstract void setMessageBundle(String bundle)
      Set the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application.
      abstract void setNavigationHandler(NavigationHandler handler)
      Set the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.
      abstract void setPropertyResolver(PropertyResolver resolver)
      Deprecated.
      The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called addELResolver(javax.el.ELResolver).
      void setResourceHandler(ResourceHandler resourceHandler)

      Set the ResourceHandler instance that will be utilized for rendering the markup for resources, and for satisfying client requests to serve up resources.
      abstract void setStateManager(StateManager manager)
      Set the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
      abstract void setSupportedLocales(Collection<Locale> locales)
      Set the Locale instances representing the supported Locales for this application.
      abstract void setVariableResolver(VariableResolver resolver)
      Deprecated.
      The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called addELResolver(javax.el.ELResolver).
      abstract void setViewHandler(ViewHandler handler)
      Set the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
      void subscribeToEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      Install the listener instance referenced by argument listener into the application as a listener for events of type systemEventClass that originate from objects of type sourceClass.
      void subscribeToEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      Install the listener instance referenced by argument listener into application as a listener for events of type systemEventClass.
      void unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      Remove the listener instance referenced by argument listener from the application as a listener for events of type systemEventClass that originate from objects of type sourceClass.
      void unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      Remove the listener instance referenced by argument listener from the application as a listener for events of type systemEventClass.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Application

        public Application()

    • Method Detail

      • getActionListener

        public abstract ActionListener getActionListener()

        Return the default ActionListener to be registered for all ActionSource components in this application. If not explicitly set, a default implementation must be provided that performs the functions as specified in the section titled "ActionListener Property" in the chapter titled "Application Integration" of the spec prose document.

        Note that the specification for the default ActionListener contiues to call for the use of a deprecated property (action) and class (MethodBinding). Unfortunately, this is necessary because the default ActionListener must continue to work with components that do not implement ActionSource2, and only implement ActionSource.

      • setActionListener

        public abstract void setActionListener(ActionListener listener)

        Set the default ActionListener to be registered for all ActionSource components.

        Parameters:
        listener - The new default ActionListener
        Throws:
        NullPointerException - if listener is null

      • getDefaultLocale

        public abstract Locale getDefaultLocale()

        Return the default Locale for this application. If not explicitly set, null is returned.

      • setDefaultLocale

        public abstract void setDefaultLocale(Locale locale)

        Set the default Locale for this application.

        Parameters:
        locale - The new default Locale
        Throws:
        NullPointerException - if locale is null

      • getDefaultRenderKitId

        public abstract String getDefaultRenderKitId()

        Return the renderKitId to be used for rendering this application. If not explicitly set, null is returned.

      • setDefaultRenderKitId

        public abstract void setDefaultRenderKitId(String renderKitId)

        Set the renderKitId to be used to render this application. Unless the client has provided a custom ViewHandler that supports the use of multiple RenderKit instances in the same application, this method must only be called at application startup, before any Faces requests have been processed. This is a limitation of the current Specification, and may be lifted in a future release.

      • getMessageBundle

        public abstract String getMessageBundle()

        Return the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application. If not explicitly set, null is returned.

      • setMessageBundle

        public abstract void setMessageBundle(String bundle)

        Set the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application. See the JavaDocs for the java.util.ResourceBundle class for more information about the syntax for resource bundle names.

        Parameters:
        bundle - Base name of the resource bundle to be used
        Throws:
        NullPointerException - if bundle is null

      • getNavigationHandler

        public abstract NavigationHandler getNavigationHandler()

        Return the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application. If not explicitly set, a default implementation must be provided that performs the functions described in the NavigationHandler class description.

      • setNavigationHandler

        public abstract void setNavigationHandler(NavigationHandler handler)

        Set the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.

        Parameters:
        handler - The new NavigationHandler instance
        Throws:
        NullPointerException - if handler is null

      • getResourceHandler

        public ResourceHandler getResourceHandler()

        Return the singleton, stateless, thread-safe ResourceHandler for this application. The JSF implementation must support the following techniques for declaring an alternate implementation of ResourceHandler.

        • The ResourceHandler implementation is declared in the application configuration resources by giving the fully qualified class name as the value of the <resource-handler> element within the <application> element.

        In all of the above cases, the runtime must employ the decorator pattern as for every other pluggable artifact in JSF.

        A default implementation is provided that throws UnsupportedOperationException so that users that decorate Application can continue to function

        .
        Since:
        2.0

      • setResourceHandler

        public void setResourceHandler(ResourceHandler resourceHandler)

        Set the ResourceHandler instance that will be utilized for rendering the markup for resources, and for satisfying client requests to serve up resources.

        Parameters:
        resourceHandler - The new ResourceHandler instance
        Throws:
        IllegalStateException - if this method is called after at least one request has been processed by the Lifecycle instance for this application.
        NullPointerException - if resourceHandler is null
        Since:
        2.0

      • getPropertyResolver

        public abstract PropertyResolver getPropertyResolver()
        Deprecated. This has been replaced by getELResolver().

        Return a PropertyResolver instance that wraps the ELResolver instance that Faces provides to the unified EL for the resolution of expressions that appear programmatically in an application.

        Note that this no longer returns the default PropertyResolver since that class is now a no-op that aids in allowing custom PropertyResolvers to affect the EL resolution process.

      • setPropertyResolver

        public abstract void setPropertyResolver(PropertyResolver resolver)
        Deprecated. The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called addELResolver(javax.el.ELResolver).

        Set the PropertyResolver instance that will be utilized to resolve method and value bindings.

        This method is now deprecated but the implementation must cause the argument to be set as the head of the legacy PropertyResolver chain, replacing any existing value that was set from the application configuration resources.

        It is illegal to call this method after the application has received any requests from the client. If an attempt is made to register a listener after that time it must have no effect.

        Parameters:
        resolver - The new PropertyResolver instance
        Throws:
        NullPointerException - if resolver is null
        IllegalStateException - if called after the first request to the FacesServlet has been serviced.

      • getResourceBundle

        public ResourceBundle getResourceBundle(FacesContext ctx,
                               String name)

        Find a ResourceBundle as defined in the application configuration resources under the specified name. If a ResourceBundle was defined for the name, return an instance that uses the locale of the current UIViewRoot.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Throws:
        FacesException - if a bundle was defined, but not resolvable
        NullPointerException - if ctx == null || name == null
        Since:
        1.2

      • getProjectStage

        public ProjectStage getProjectStage()

        Return the project stage for the currently running application instance. The default value is ProjectStage.Production

        The implementation of this method must perform the following algorithm or an equivalent with the same end result to determine the value to return.

          If the value has already been determined by a previous call to this method, simply return that value.

          Look for a JNDI environment entry under the key given by the value of ProjectStage.PROJECT_STAGE_JNDI_NAME (return type of java.lang.String). If found, continue with the algorithm below, otherwise, look for an entry in the initParamMap of the ExternalContext from the current FacesContext with the key given by the value of ProjectStage.PROJECT_STAGE_PARAM_NAME

          If a value is found, see if an enum constant can be obtained by calling ProjectStage.valueOf(), passing the value from the initParamMap. If this succeeds without exception, save the value and return it.

          If not found, or any of the previous attempts to discover the enum constant value have failed, log a descriptive error message, assign the value as ProjectStage.Production and return it.

        A default implementation is provided that throws UnsupportedOperationException so that users that decorate Application can continue to function

        .
        Since:
        2.0

      • getVariableResolver

        public abstract VariableResolver getVariableResolver()
        Deprecated. This has been replaced by getELResolver().

        Return the VariableResolver that wraps the ELResolver instance that Faces provides to the unified EL for the resolution of expressions that appear programmatically in an application. The implementation of the VariableResolvermust pass null as the base argument for any methods invoked on the underlying ELResolver.

        Note that this method no longer returns the default VariableResolver, since that class now is a no-op that aids in allowing custom VariableResolvers to affect the EL resolution process.

      • setVariableResolver

        public abstract void setVariableResolver(VariableResolver resolver)
        Deprecated. The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called addELResolver(javax.el.ELResolver).

        Set the VariableResolver instance that will be consulted to resolve method and value bindings.

        This method is now deprecated but the implementation must cause the argument to be set as the head of the legacy VariableResolver chain, replacing any existing value that was set from the application configuration resources.

        It is illegal to call this method after the application has received any requests from the client. If an attempt is made to register a listener after that time it must have no effect.

        Parameters:
        resolver - The new VariableResolver instance
        Throws:
        NullPointerException - if resolver is null
        IllegalStateException - if called after the first request to the FacesServlet has been serviced.

      • addELResolver

        public void addELResolver(ELResolver resolver)

        Cause an the argument resolver to be added to the resolver chain as specified in section JSF.5.5.1 of the JavaServer Faces Specification.

        It is not possible to remove an ELResolver registered with this method, once it has been registered.

        It is illegal to register an ELResolver after the application has received any requests from the client. If an attempt is made to register a listener after that time, an IllegalStateException must be thrown. This restriction is in place to allow the JSP container to optimize for the common case where no additional ELResolvers are in the chain, aside from the standard ones. It is permissible to add ELResolvers before or after initialization to a CompositeELResolver that is already in the chain.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend Application.

        Throws:
        IllegalStateException - if called after the first request to the FacesServlet has been serviced.
        Since:
        1.2

      • getELResolver

        public ELResolver getELResolver()

        Return the singleton ELResolver instance to be used for all EL resolution. This is actually an instance of CompositeELResolver that must contain the following ELResolver instances in the following order:

        1. ELResolver instances declared using the <el-resolver> element in the application configuration resources.

        2. An implementation that wraps the head of the legacy VariableResolver chain, as per section VariableResolver ChainWrapper in Chapter JSF.5 in the spec document.

        3. An implementation that wraps the head of the legacy PropertyResolver chain, as per section PropertyResolver ChainWrapper in Chapter JSF.5 in the spec document.

        4. Any ELResolver instances added by calls to addELResolver(javax.el.ELResolver).

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend Application.

        Since:
        1.2

      • getFlowHandler

        public FlowHandler getFlowHandler()

        Return the thread-safe singleton FlowHandler for this application. For implementations declaring compliance with version 2.2 of the specification, this method must never return null, even if the application has no flows. This is necessary to enable dynamic flow creation during the application's lifetime.

        All implementations that declare compliance with version 2.2 of the specification must implement this method. For the purpose of backward compatibility with environments that extend Application but do not override this method, an implementation is provided that returns null. Due to the decoratable nature of Application, code calling this method should always check for a null return.

        Since:
        2.2

      • setFlowHandler

        public void setFlowHandler(FlowHandler newHandler)

        Set the FlowHandler instance used by the NavigationHandler to satisfy the requirements of the faces flows feature.

        Throws:
        NullPounterException - if {code newHandler} is null
        IllegalStateException - if this method is called after at least one request has been processed by the Lifecycle instance for this application.
        Since:
        2.2

      • getViewHandler

        public abstract ViewHandler getViewHandler()

        Return the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle. If not explicitly set, a default implementation must be provided that performs the functions described in the ViewHandler description in the JavaServer Faces Specification.

      • setViewHandler

        public abstract void setViewHandler(ViewHandler handler)

        Set the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.

        Parameters:
        handler - The new ViewHandler instance
        Throws:
        IllegalStateException - if this method is called after at least one request has been processed by the Lifecycle instance for this application.
        NullPointerException - if handler is null

      • getStateManager

        public abstract StateManager getStateManager()

        Return the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle. If not explicitly set, a default implementation must be provided that performs the functions described in the StateManager description in the JavaServer Faces Specification.

      • setStateManager

        public abstract void setStateManager(StateManager manager)

        Set the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.

        Parameters:
        manager - The new StateManager instance
        Throws:
        IllegalStateException - if this method is called after at least one request has been processed by the Lifecycle instance for this application.
        NullPointerException - if manager is null

      • addBehavior

        public void addBehavior(String behaviorId,
               String behaviorClass)

        Register a new mapping of behavior id to the name of the corresponding Behavior class. This allows subsequent calls to createBehavior() to serve as a factory for Behavior instances.

        Parameters:
        behaviorId - The behavior id to be registered
        behaviorClass - The fully qualified class name of the corresponding Behavior implementation
        Throws:
        NullPointerException - if behaviorId or behaviorClass is null
        Since:
        2.0

      • createBehavior

        public Behavior createBehavior(String behaviorId)
                        throws FacesException

        Instantiate and return a new Behavior instance of the class specified by a previous call to addBehavior() for the specified behavior id.

        Parameters:
        behaviorId - The behavior id for which to create and return a new Behavior instance
        Throws:
        FacesException - if the Behavior cannot be created
        NullPointerException - if behaviorId is null

      • getBehaviorIds

        public Iterator<String> getBehaviorIds()

        Return an Iterator over the set of currently registered behavior ids for this Application.

      • addComponent

        public abstract void addComponent(String componentType,
                String componentClass)

        Register a new mapping of component type to the name of the corresponding UIComponent class. This allows subsequent calls to createComponent() to serve as a factory for UIComponent instances.

        Parameters:
        componentType - The component type to be registered
        componentClass - The fully qualified class name of the corresponding UIComponent implementation
        Throws:
        NullPointerException - if componentType or componentClass is null

      • createComponent

        public abstract UIComponent createComponent(String componentType)
                                     throws FacesException

        Instantiate and return a new UIComponent instance of the class specified by a previous call to addComponent() for the specified component type.

        Before the component instance is returned, it must be inspected for the presence of a ListenerFor (or ListenersFor) or ResourceDependency (or ResourceDependencies) annotation. If any of these annotations are present, the action listed in ListenerFor or ResourceDependency must be taken on the component, before it is returned from this method. This variant of createComponent must not inspect the Renderer for the component to be returned for any of the afore mentioned annotations. Such inspection is the province of createComponent(ValueExpression, FacesContext, String, String) or createComponent(FacesContext, String, String).

        Parameters:
        componentType - The component type for which to create and return a new UIComponent instance
        Throws:
        FacesException - if a UIComponent of the specified type cannot be created
        NullPointerException - if componentType is null

      • createComponent

        public abstract UIComponent createComponent(ValueBinding componentBinding,
                          FacesContext context,
                          String componentType)
                                     throws FacesException
        Deprecated. This has been replaced by createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).

        Wrap the argument componentBinding in an implementation of ValueExpression and call through to createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).

        Parameters:
        componentBinding - ValueBinding representing a component value binding expression (typically specified by the component attribute of a custom tag)
        context - FacesContext for the current request
        componentType - Component type to create if the ValueBinding does not return a component instance
        Throws:
        FacesException - if a UIComponent cannot be created
        NullPointerException - if any parameter is null

      • createComponent

        public UIComponent createComponent(ValueExpression componentExpression,
                          FacesContext context,
                          String componentType)
                            throws FacesException

        Call the getValue() method on the specified ValueExpression. If it returns a UIComponent instance, return it as the value of this method. If it does not, instantiate a new UIComponent instance of the specified component type, pass the new component to the setValue() method of the specified ValueExpression, and return it.

        Before the component instance is returned, it must be inspected for the presence of a ListenerFor (or ListenersFor) or ResourceDependency (or ResourceDependencies) annotation. If any of these annotations are present, the action listed in ListenerFor or ResourceDependency must be taken on the component, before it is returned from this method. This variant of createComponent must not inspect the Renderer for the component to be returned for any of the afore mentioned annotations. Such inspection is the province of createComponent(ValueExpression, FacesContext, String, String) or createComponent(FacesContext, String, String).

        Parameters:
        componentExpression - ValueExpression representing a component value expression (typically specified by the component attribute of a custom tag)
        context - FacesContext for the current request
        componentType - Component type to create if the ValueExpression does not return a component instance
        Throws:
        FacesException - if a UIComponent cannot be created
        NullPointerException - if any parameter is null

        A default implementation is provided that throws UnsupportedOperationException so that users that decorate Application can continue to function.

        Since:
        1.2

      • createComponent

        public UIComponent createComponent(ValueExpression componentExpression,
                          FacesContext context,
                          String componentType,
                          String rendererType)

        Like createComponent(ValueExpression, FacesContext, String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method. The Renderer instance to inspect must be obtained by calling FacesContext.getRenderKit() and calling RenderKit.getRenderer(java.lang.String, java.lang.String) on the result, passing the argument componentType as the first argument and the result of calling UIComponent.getFamily() on the newly created component as the second argument. If no such Renderer can be found, a message must be logged with a helpful error message. Otherwise, UIComponent.setRendererType(java.lang.String) must be called on the newly created UIComponent instance, passing the argument rendererType as the argument.

        A default implementation is provided that throws UnsupportedOperationException so that users that decorate Application can continue to function.

        Parameters:
        componentExpression - ValueExpression representing a component value expression (typically specified by the component attribute of a custom tag)
        context - FacesContext for the current request
        componentType - Component type to create if the ValueExpression does not return a component instance
        rendererType - The renderer-type of the Renderer that will render this component. A null value must be accepted for this parameter.
        Throws:
        FacesException - if a UIComponent cannot be created
        NullPointerException - if any of the parameters componentExpression, context, or componentType are null
        Since:
        2.0

      • createComponent

        public UIComponent createComponent(FacesContext context,
                          String componentType,
                          String rendererType)

        Like createComponent(String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method. The Renderer instance to inspect must be obtained by calling FacesContext.getRenderKit() and calling RenderKit.getRenderer(java.lang.String, java.lang.String) on the result, passing the argument componentType as the first argument and the result of calling UIComponent.getFamily() on the newly created component as the second argument. If no such Renderer can be found, a message must be logged with a helpful error message. Otherwise, UIComponent.setRendererType(java.lang.String) must be called on the newly created UIComponent instance, passing the argument rendererType as the argument.

        A default implementation is provided that throws UnsupportedOperationException so that users that decorate Application can continue to function

        .
        Parameters:
        context - FacesContext for the current request
        componentType - Component type to create
        rendererType - The renderer-type of the Renderer that will render this component. A null value must be accepted for this parameter.
        Throws:
        FacesException - if a UIComponent cannot be created
        NullPointerException - if any of the parameters context, or componentType are null
        Since:
        2.0

      • createComponent

        public UIComponent createComponent(FacesContext context,
                          Resource componentResource)

        Instantiate and return a new UIComponent instance from the argument Resource. An algorithm semantically equivalent to the following must be followed to instantiate the UIComponent to return.

        • Obtain a reference to the ViewDeclarationLanguage for this Application instance by calling ViewHandler.getViewDeclarationLanguage(javax.faces.context.FacesContext, java.lang.String), passing the viewId found by calling UIViewRoot.getViewId() on the UIViewRoot in the argument FacesContext.

        • Obtain a reference to the composite component metadata for this composite component by calling ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), passing the facesContext and componentResource arguments to this method. This version of JSF specification uses JavaBeans as the API to the component metadata.

        • Determine if the component author declared a componentType for this component instance by obtaining the BeanDescriptor from the component metadata and calling its getValue() method, passing UIComponent.COMPOSITE_COMPONENT_TYPE_KEY as the argument. If non-null, the result must be a ValueExpression whose value is the component-type of the UIComponent to be created for this Resource component. Call through to createComponent(java.lang.String) to create the component.

        • Otherwise, determine if a script based component for this Resource can be found by calling ViewDeclarationLanguage.getScriptComponentResource(javax.faces.context.FacesContext, javax.faces.application.Resource). If the result is non-null, and is a script written in one of the languages listed in JSF.4.3 of the specification prose document, create a UIComponent instance from the script resource.

        • Otherwise, let library-name be the return from calling Resource.getLibraryName() on the argument componentResource and resource-name be the return from calling Resource.getResourceName() on the argument componentResource. Create a fully qualified Java class name by removing any file extension from resource-name and let fqcn be library-name + "." + resource-name. If a class with the name of fqcn cannot be found, take no action and continue to the next step. If any of InstantiationException, IllegalAccessException, or ClassCastException are thrown, wrap the exception in a FacesException and re-throw it. If any other exception is thrown, log the exception and continue to the next step.

        • If none of the previous steps have yielded a UIComponent instance, call createComponent(java.lang.String) passing "javax.faces.NamingContainer" as the argument.

        • Call UIComponent.setRendererType(java.lang.String) on the UIComponent instance, passing "javax.faces.Composite" as the argument.

        • Store the argument Resource in the attributes Map of the UIComponent under the key, Resource.COMPONENT_RESOURCE_KEY.

        • Store composite component metadata in the attributes Map of the UIComponent under the key, UIComponent.BEANINFO_KEY.

        Before the component instance is returned, it must be inspected for the presence of a ListenerFor annotation. If this annotation is present, the action listed in ListenerFor must be taken on the component, before it is returned from this method.

        A default implementation is provided that throws UnsupportedOperationException so that users that decorate Application can continue to function.

        Parameters:
        context - FacesContext for the current request
        componentResource - A Resource that points to a source file that provides an implementation of a component.
        Throws:
        FacesException - if a UIComponent from the Resource cannot be created
        NullPointerException - if any parameter is null
        NullPointerException - if unable, for any reason, to obtain a ViewDeclarationLanguage instance as described above.
        Since:
        2.0

      • getComponentTypes

        public abstract Iterator<String> getComponentTypes()

        Return an Iterator over the set of currently defined component types for this Application.

      • addConverter

        public abstract void addConverter(String converterId,
                String converterClass)

        Register a new mapping of converter id to the name of the corresponding Converter class. This allows subsequent calls to createConverter() to serve as a factory for Converter instances.

        Parameters:
        converterId - The converter id to be registered
        converterClass - The fully qualified class name of the corresponding Converter implementation
        Throws:
        NullPointerException - if converterId or converterClass is null

      • addConverter

        public abstract void addConverter(Class<?> targetClass,
                String converterClass)

        Register a new converter class that is capable of performing conversions for the specified target class.

        Parameters:
        targetClass - The class for which this converter is registered
        converterClass - The fully qualified class name of the corresponding Converter implementation
        Throws:
        NullPointerException - if targetClass or converterClass is null

      • createConverter

        public abstract Converter createConverter(String converterId)

        Instantiate and return a new Converter instance of the class specified by a previous call to addConverter() for the specified converter id.

        If the toLowerCase() of the String represenation of the value of the "javax.faces.DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE" application configuration parameter is "true" (without the quotes) and the Converter instance to be returned is an instance of DateTimeConverter, DateTimeConverter.setTimeZone(java.util.TimeZone) must be called, passing the return from TimeZone.getDefault().

        The argument converter must be inspected for the presence of the ResourceDependency annotation. If the ResourceDependency annotation is present, the action described in ResourceDependency must be taken. If the ResourceDependency annotation is not present, the argument converter must be inspected for the presence of the ResourceDependencies annotation. If the ResourceDependencies annotation is present, the action described in ResourceDependencies must be taken.

        Parameters:
        converterId - The converter id for which to create and return a new Converter instance
        Throws:
        FacesException - if the Converter cannot be created
        NullPointerException - if converterId is null

      • createConverter

        public abstract Converter createConverter(Class<?> targetClass)

        Instantiate and return a new Converter instance of the class that has registered itself as capable of performing conversions for objects of the specified type. If no such Converter class can be identified, return null.

        To locate an appropriate Converter class, the following algorithm is performed, stopping as soon as an appropriate Converter class is found:

        • Locate a Converter registered for the target class itself.
        • Locate a Converter registered for interfaces that are implemented by the target class (directly or indirectly).
        • Locate a Converter registered for the superclass (if any) of the target class, recursively working up the inheritance hierarchy.

        If the Converter has a single argument constructor that accepts a Class, instantiate the Converter using that constructor, passing the argument targetClass as the sole argument. Otherwise, simply use the zero-argument constructor.

        If the toLowerCase() of the String represenation of the value of the "javax.faces.DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE" application configuration parameter is "true" (without the quotes) and the Converter instance to be returned is an instance of DateTimeConverter, DateTimeConverter.setTimeZone(java.util.TimeZone) must be called, passing the return from TimeZone.getDefault().

        Parameters:
        targetClass - Target class for which to return a Converter
        Throws:
        FacesException - if the Converter cannot be created
        NullPointerException - if targetClass is null

      • getConverterIds

        public abstract Iterator<String> getConverterIds()

        Return an Iterator over the set of currently registered converter ids for this Application.

      • getConverterTypes

        public abstract Iterator<Class<?>> getConverterTypes()

        Return an Iterator over the set of Class instances for which Converter classes have been explicitly registered.

      • addDefaultValidatorId

        public void addDefaultValidatorId(String validatorId)

        Register a validator by its id that is applied to all UIInput components in a view. The validator to most often serve this role is the BeanValidator. The usage contract for this method assumes that the validator has been registered using the normal “by-id” registration mechanism.

        An implementation is provided that takes no action so that users that decorate the Application continue to work.

        Since:
        2.0

      • getDefaultValidatorInfo

        public Map<String,String> getDefaultValidatorInfo()

        Return an immutable Map over the set of currently registered default validator IDs and their class name for this Application.

        An implementation is provided that returns Collections.emptyMap so that users that decorate the Application continue to work.

        Since:
        2.0

      • getExpressionFactory

        public ExpressionFactory getExpressionFactory()

        Return the ExpressionFactory instance for this application. This instance is used by the convenience method evaluateExpressionGet(javax.faces.context.FacesContext, java.lang.String, java.lang.Class<? extends T>).

        The implementation must return the ExpressionFactory from the JSP container by calling JspFactory.getDefaultFactory().getJspApplicationContext(servletContext).getExpressionFactory().

        An implementation is provided that throws UnsupportedOperationException so that users that decorate the Application continue to work.

        Since:
        1.2

      • evaluateExpressionGet

        public <T> T evaluateExpressionGet(FacesContext context,
                          String expression,
                          Class<? extends T> expectedType)
                        throws ELException

        Get a value by evaluating an expression.

        Call getExpressionFactory() then call ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>) passing the argument expression and expectedType. Call FacesContext.getELContext() and pass it to ValueExpression.getValue(javax.el.ELContext), returning the result.

        An implementation is provided that throws UnsupportedOperationException so that users that decorate the Application continue to work.

        Throws:
        ELException

      • createMethodBinding

        public abstract MethodBinding createMethodBinding(String ref,
                                Class<?>[] params)
                                           throws ReferenceSyntaxException
        Deprecated. This has been replaced by calling getExpressionFactory() then ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>, java.lang.Class<?>[]).

        Call getExpressionFactory() then call ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>, java.lang.Class<?>[]), passing the given arguments, and wrap the result in a MethodBinding implementation, returning it.

        Parameters:
        ref - Method binding expression for which to return a MethodBinding instance
        params - Parameter signatures that must be compatible with those of the method to be invoked, or a zero-length array or null for a method that takes no parameters
        Throws:
        NullPointerException - if ref is null
        ReferenceSyntaxException - if the specified ref has invalid syntax

      • getSupportedLocales

        public abstract Iterator<Locale> getSupportedLocales()

        Return an Iterator over the supported Locales for this appication.

      • setSupportedLocales

        public abstract void setSupportedLocales(Collection<Locale> locales)

        Set the Locale instances representing the supported Locales for this application.

        Parameters:
        locales - The set of supported Locales for this application
        Throws:
        NullPointerException - if the argument newLocales is null.

      • addELContextListener

        public void addELContextListener(ELContextListener listener)

        Provide a way for Faces applications to register an ELContextListener that will be notified on creation of ELContext instances. This listener will be called once per request.

        An implementation is provided that throws UnsupportedOperationException so that users that decorate the Application continue to work.

        Since:
        1.2

      • removeELContextListener

        public void removeELContextListener(ELContextListener listener)

        Remove the argument listener from the list of ELContextListeners. If listener is null, no exception is thrown and no action is performed. If listener is not in the list, no exception is thrown and no action is performed.

        An implementation is provided that throws UnsupportedOperationException so that users that decorate the Application continue to work.

        Since:
        1.2

      • getELContextListeners

        public ELContextListener[] getELContextListeners()

        If no calls have been made to addELContextListener(javax.el.ELContextListener), this method must return an empty array.

        Otherwise, return an array representing the list of listeners added by calls to addELContextListener(javax.el.ELContextListener).

        An implementation is provided that throws UnsupportedOperationException so that users that decorate the Application continue to work.

        Since:
        1.2

      • addValidator

        public abstract void addValidator(String validatorId,
                String validatorClass)

        Register a new mapping of validator id to the name of the corresponding Validator class. This allows subsequent calls to createValidator() to serve as a factory for Validator instances.

        Parameters:
        validatorId - The validator id to be registered
        validatorClass - The fully qualified class name of the corresponding Validator implementation
        Throws:
        NullPointerException - if validatorId or validatorClass is null

      • createValidator

        public abstract Validator createValidator(String validatorId)
                                   throws FacesException

        Instantiate and return a new Validator instance of the class specified by a previous call to addValidator() for the specified validator id.

        The argument validator must be inspected for the presence of the ResourceDependency annotation. If the ResourceDependency annotation is present, the action described in ResourceDependency must be taken. If the ResourceDependency annotation is not present, the argument validator must be inspected for the presence of the ResourceDependencies annotation. If the ResourceDependencies annotation is present, the action described in ResourceDependencies must be taken.

        Parameters:
        validatorId - The validator id for which to create and return a new Validator instance
        Throws:
        FacesException - if a Validator of the specified id cannot be created
        NullPointerException - if validatorId is null

      • getValidatorIds

        public abstract Iterator<String> getValidatorIds()

        Return an Iterator over the set of currently registered validator ids for this Application.

      • createValueBinding

        public abstract ValueBinding createValueBinding(String ref)
                                         throws ReferenceSyntaxException
        Deprecated. This has been replaced by calling getExpressionFactory() then ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>).

        Call getExpressionFactory() then call ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>), passing the argument ref, Object.class for the expectedType, and null, for the fnMapper.

        Parameters:
        ref - Value binding expression for which to return a ValueBinding instance
        Throws:
        NullPointerException - if ref is null
        ReferenceSyntaxException - if the specified ref has invalid syntax

      • publishEvent

        public void publishEvent(FacesContext context,
                Class<? extends SystemEvent> systemEventClass,
                Object source)

        If FacesContext.isProcessingEvents() is true and there are one or more listeners for events of the type represented by systemEventClass, call those listeners, passing source as the source of the event. The implementation should be as fast as possible in determining whether or not a listener for the given systemEventClass and source has been installed, and should return immediately once such a determination has been made. The implementation of publishEvent must honor the requirements stated in subscribeToEvent(java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Class<?>, javax.faces.event.SystemEventListener) regarding the storage and retrieval of listener instances. Specifically, if subscribeToEvent(Class,Class,SystemEventListener) was called, the sourceClass argument must match exactly the Class of the source argument in the call to publishEvent(). The implementation must not do any inheritance hierarachy inspection when looking for a match between the sourceClass passed to subscribeToEvent(Class,Class,SystemEventListener) and the sourceClass passed to publishEvent() in order to find any listeners to which the event should be published. In the case where the Class of the source argument does not match the Class of the sourceClass used when the listener was subscribed using subscribeToEvent(), publishEvent(FacesContext,Class,Class,Object) can be used to provide the Class used to perform the listener lookup and match.

        The default implementation must implement an algorithm semantically equivalent to the following to locate listener instances and to invoke them.

        • If the source argument implements SystemEventListenerHolder, call SystemEventListenerHolder.getListenersForEventClass(java.lang.Class<? extends javax.faces.event.SystemEvent>) on it, passing the systemEventClass argument. If the list is not empty, perform algorithm traverseListenerList on the list.

        • If any view level listeners have been installed by previous calls to subscribeToEvent(Class, Class, javax.faces.event.SystemEventListener) on the UIViewRoot, perform algorithm traverseListenerList on the list of listeners for that event installed on the UIViewRoot.

        • If any Application level listeners have been installed by previous calls to subscribeToEvent(Class, Class, javax.faces.event.SystemEventListener), perform algorithm traverseListenerList on the list.

        • If any Application level listeners have been installed by previous calls to subscribeToEvent(Class, javax.faces.event.SystemEventListener), perform algorithm traverseListenerList on the list.

        If the act of invoking the processListener method causes an AbortProcessingException to be thrown, processing of the listeners must be aborted, no further processing of the listeners for this event must take place, and the exception must be logged with Level.SEVERE.

        Algorithm traverseListenerList: For each listener in the list,

        • Call SystemEventListener.isListenerForSource(java.lang.Object), passing the source argument. If this returns false, take no action on the listener.

        • Otherwise, if the event to be passed to the listener instances has not yet been constructed, construct the event, passing source as the argument to the one-argument constructor that takes an Object. This same event instance must be passed to all listener instances.

        • Call SystemEvent.isAppropriateListener(javax.faces.event.FacesListener), passing the listener instance as the argument. If this returns false, take no action on the listener.

        • Call SystemEvent.processListener(javax.faces.event.FacesListener), passing the listener instance.

        A default implementation is provided that throws UnsupportedOperationException so that users that decorate Application can continue to function

        .
        Parameters:
        context - the FacesContext for the current request
        systemEventClass - The Class of event that is being published.
        source - The source for the event of type systemEventClass.
        Throws:
        NullPointerException - if either context, systemEventClass or source is null
        Since:
        2.0

      • publishEvent

        public void publishEvent(FacesContext context,
                Class<? extends SystemEvent> systemEventClass,
                Class<?> sourceBaseType,
                Object source)

        This method functions exactly like publishEvent(FacesContext,Class,Object), except the run-time must use the argument sourceBaseType to find the matching listener instead of using the Class of the source argument.

        A default implementation is provided that throws UnsupportedOperationException so that users that decorate Application can continue to function

        .
        Parameters:
        context - the FacesContext for the current request
        systemEventClass - The Class of event that is being published.
        sourceBaseType - The Class of the source event that must be used to lookup the listener to which this event must be published. If this argument is null the return from source.getClass() must be used as the sourceBaseType.
        source - The source for the event of type systemEventClass.
        Throws:
        NullPointerException - if any arguments except for sourceBaseType are null
        Since:
        2.0

      • subscribeToEvent

        public void subscribeToEvent(Class<? extends SystemEvent> systemEventClass,
                    Class<?> sourceClass,
                    SystemEventListener listener)

        Install the listener instance referenced by argument listener into the application as a listener for events of type systemEventClass that originate from objects of type sourceClass.

        If argument sourceClass is non-null, sourceClass and systemEventClass must be used to store the argument listener in the application in such a way that the listener can be quickly looked up by the implementation of publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) given systemEventClass and an instance of the Class referenced by sourceClass. If argument sourceClass is null, the listener must be discoverable by the implementation of publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) given only systemEventClass.

        It is valid to call this method during the processing of an event which was subscribed to by a previous call to this method.

        Parameters:
        systemEventClass - the Class of event for which listener must be fired.
        sourceClass - the Class of the instance which causes events of type systemEventClass to be fired. May be null.
        listener - the implementation of SystemEventListener whose SystemEventListener.processEvent(javax.faces.event.SystemEvent) method must be called when events of type systemEventClass are fired.
        Throws:
        NullPointerException - if any combination of systemEventClass, or listener are null.
        Since:
        2.0

      • subscribeToEvent

        public void subscribeToEvent(Class<? extends SystemEvent> systemEventClass,
                    SystemEventListener listener)

        Install the listener instance referenced by argument listener into application as a listener for events of type systemEventClass. The default implementation simply calls through to subscribeToEvent(Class, Class, javax.faces.event.SystemEventListener) passing null as the sourceClass argument

        A default implementation is provided that throws UnsupportedOperationException so that users that decorate Application can continue to function

        .
        Parameters:
        systemEventClass - the Class of event for which listener must be fired.

        listener - the implementation of SystemEventListener whose SystemEventListener.processEvent(javax.faces.event.SystemEvent) method must be called when events of type systemEventClass are fired.

        See subscribeToEvent(java.lang.Class,java.lang.Class,javax.faces.event.SystemEventListener) for an additional requirement regarding when it is valid to call this method.

        Throws:
        NullPointerException - if any combination of systemEventClass, or listener are null.
        Since:
        2.0

      • unsubscribeFromEvent

        public void unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass,
                        Class<?> sourceClass,
                        SystemEventListener listener)

        Remove the listener instance referenced by argument listener from the application as a listener for events of type systemEventClass that originate from objects of type sourceClass. See subscribeToEvent(Class, Class, javax.faces.event.SystemEventListener) for the specification of how the listener is stored, and therefore, how it must be removed.

        See subscribeToEvent(java.lang.Class,java.lang.Class,javax.faces.event.SystemEventListener) for an additional requirement regarding when it is valid to call this method.

        Parameters:
        systemEventClass - the Class of event for which listener must be fired.
        sourceClass - the Class of the instance which causes events of type systemEventClass to be fired. May be null.
        listener - the implementation of SystemEventListener to remove from the internal data structure.
        Throws:
        NullPointerException - if any combination of context, systemEventClass, or listener are null.
        Since:
        2.0

      • unsubscribeFromEvent

        public void unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass,
                        SystemEventListener listener)

        Remove the listener instance referenced by argument listener from the application as a listener for events of type systemEventClass. The default implementation simply calls through to unsubscribeFromEvent(Class, javax.faces.event.SystemEventListener) passing null as the sourceClass argument

        See subscribeToEvent(java.lang.Class,java.lang.Class,javax.faces.event.SystemEventListener) for an additional requirement regarding when it is valid to call this method.

        Parameters:
        systemEventClass - the Class of event for which listener must be fired.
        listener - the implementation of SystemEventListener to remove from the internal data structure.
        Throws:
        NullPointerException - if any combination of context, systemEventClass, or listener are null.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ApplicationConfigurationPopulator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ApplicationConfigurationPopulator

  • java.lang.Object
    • javax.faces.application.ApplicationConfigurationPopulator

  • public abstract class ApplicationConfigurationPopulator
extends Object

    This class defines a java.util.ServiceLoader service which enables programmatic configuration of the JSF runtime using the existing Application Configuration Resources schema. See the section "Application Startup Behavior" in the specification prose document for the specification on when and how implementations of this service are used.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      ApplicationConfigurationPopulator()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void populateApplicationConfiguration(Document toPopulate)

      Service providers that implement this service must be called by the JSF runtime exactly once for each implementation, at startup, before any requests have been serviced.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ApplicationConfigurationPopulator

        public ApplicationConfigurationPopulator()

    • Method Detail

      • populateApplicationConfiguration

        public abstract void populateApplicationConfiguration(Document toPopulate)

        Service providers that implement this service must be called by the JSF runtime exactly once for each implementation, at startup, before any requests have been serviced. Before calling the populateApplicationConfiguration(org.w3c.dom.Document) method, the runtime must ensure that the Document argument is empty aside from being pre-configured to be in the proper namespace for an Application Configuration Resources file: http://xmlns.jcp.org/xml/ns/javaee. Implementations of this service must ensure that any changes made to the argument Document conform to that schema as defined in the specification. The JSF runtime is not required to validate the Document after control returns from the service implementation, though it may do so.

        Ordering of Artifacts

        If the document is made to contain an <ordering> element, as specified in the section Ordering of Artifacts in the specification prose document, the document will be prioritized accordingly. Otherwise, the runtime must place the document in the list of other Application Configuration Resources documents at the "lowest" priority, meaning any conflicts that may arise between the argument document and any other Application Configuration Resources are resolved in favor of the other document.

        Parameters:
        toPopulate - The Document to populate with configuration.
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ApplicationFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ApplicationFactory

  • java.lang.Object
    • javax.faces.application.ApplicationFactory
  • All Implemented Interfaces:
    FacesWrapper<ApplicationFactory>

    public abstract class ApplicationFactory
extends Object
implements FacesWrapper<ApplicationFactory>

    ApplicationFactory is a factory object that creates (if needed) and returns Application instances. Implementations of JavaServer Faces must provide at least a default implementation of Application.

    There must be one ApplicationFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

       ApplicationFactory factory = (ApplicationFactory)
    FactoryFinder.getFactory(FactoryFinder.APPLICATION_FACTORY);

    • Constructor Summary

      Constructors
      Constructor and Description
      ApplicationFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Application getApplication()
      Create (if needed) and return an Application instance for this web application.
      ApplicationFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
      abstract void setApplication(Application application)
      Replace the Application instance that will be returned for this web application.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ApplicationFactory

        public ApplicationFactory()

    • Method Detail

      • getWrapped

        public ApplicationFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<ApplicationFactory>
        Since:
        2.0

      • getApplication

        public abstract Application getApplication()

        Create (if needed) and return an Application instance for this web application.

      • setApplication

        public abstract void setApplication(Application application)

        Replace the Application instance that will be returned for this web application.

        Parameters:
        application - The replacement Application instance
        Throws:
        NullPointerException - if application is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ApplicationWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ApplicationWrapper

  • java.lang.Object
    • javax.faces.application.Application
      • javax.faces.application.ApplicationWrapper
  • All Implemented Interfaces:
    FacesWrapper<Application>

    public abstract class ApplicationWrapper
extends Application
implements FacesWrapper<Application>

    Provides a simple implementation of Application that can be subclassed by developers wishing to provide specialized behavior to an existing Application instance. The default implementation of all methods is to call through to the wrapped Application.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ApplicationWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addBehavior(String behaviorId, String behaviorClass)

      The default behavior of this method is to call Application.addBehavior(String, String) on the wrapped Application object.
      void addComponent(String componentType, String componentClass)

      The default behavior of this method is to call Application.addComponent(String, String) on the wrapped Application object.
      void addConverter(Class<?> targetClass, String converterClass)

      The default behavior of this method is to call Application.addConverter(Class, String) on the wrapped Application object.
      void addConverter(String converterId, String converterClass)

      The default behavior of this method is to call Application.addConverter(String, String) on the wrapped Application object.
      void addDefaultValidatorId(String validatorId)

      The default behavior of this method is to call Application.addDefaultValidatorId(String) on the wrapped Application object.
      void addELContextListener(ELContextListener listener)

      The default behavior of this method is to call Application.addELContextListener(javax.el.ELContextListener) on the wrapped Application object.
      void addELResolver(ELResolver resolver)

      The default behavior of this method is to call Application.addELResolver(javax.el.ELResolver) on the wrapped Application object.
      void addValidator(String validatorId, String validatorClass)

      The default behavior of this method is to call Application.addValidator(String, String) on the wrapped Application object.
      Behavior createBehavior(String behaviorId)

      The default behavior of this method is to call Application.createBehavior(String) on the wrapped Application object.
      UIComponent createComponent(FacesContext context, Resource componentResource)

      The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, Resource) on the wrapped Application object.
      UIComponent createComponent(FacesContext context, String componentType, String rendererType)

      The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, String, String) on the wrapped Application object.
      UIComponent createComponent(String componentType)

      The default behavior of this method is to call Application.createComponent(String) on the wrapped Application object.
      UIComponent createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
      Deprecated.
      See superclass for alternative.
      UIComponent createComponent(ValueExpression componentExpression, FacesContext context, String componentType)

      The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String) on the wrapped Application object.
      UIComponent createComponent(ValueExpression componentExpression, FacesContext context, String componentType, String rendererType)

      The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String, String) on the wrapped Application object.
      Converter createConverter(Class<?> targetClass)

      The default behavior of this method is to call Application.createConverter(Class) on the wrapped Application object.
      Converter createConverter(String converterId)

      The default behavior of this method is to call Application.createConverter(String) on the wrapped Application object.
      MethodBinding createMethodBinding(String ref, Class<?>[] params)
      Deprecated.
      See superclass for alternative.
      Validator createValidator(String validatorId)

      The default behavior of this method is to call Application.createValidator(String) on the wrapped Application object.
      ValueBinding createValueBinding(String ref)

      The default behavior of this method is to call Application.createValueBinding(String) on the wrapped Application object.
      <T> T evaluateExpressionGet(FacesContext context, String expression, Class<? extends T> expectedType)
      Deprecated.
      See superclass for alternative.
      ActionListener getActionListener()

      The default behavior of this method is to call Application.getActionListener() on the wrapped Application object.
      Iterator<String> getBehaviorIds()

      The default behavior of this method is to call Application.getBehaviorIds() on the wrapped Application object.
      Iterator<String> getComponentTypes()

      The default behavior of this method is to call Application.getComponentTypes() on the wrapped Application object.
      Iterator<String> getConverterIds()

      The default behavior of this method is to call Application.getConverterIds() on the wrapped Application object.
      Iterator<Class<?>> getConverterTypes()

      The default behavior of this method is to call Application.getConverterTypes() on the wrapped Application object.
      Locale getDefaultLocale()

      The default behavior of this method is to call Application.getDefaultLocale() on the wrapped Application object.
      String getDefaultRenderKitId()

      The default behavior of this method is to call Application.getDefaultRenderKitId() on the wrapped Application object.
      Map<String,String> getDefaultValidatorInfo()

      The default behavior of this method is to call Application.getDefaultValidatorInfo() on the wrapped Application object.
      ELContextListener[] getELContextListeners()

      The default behavior of this method is to call Application.getELContextListeners() on the wrapped Application object.
      ELResolver getELResolver()

      The default behavior of this method is to call Application.getELResolver() on the wrapped Application object.
      ExpressionFactory getExpressionFactory()

      The default behavior of this method is to call Application.getExpressionFactory() on the wrapped Application object.
      FlowHandler getFlowHandler()

      Return the thread-safe singleton FlowHandler for this application.
      String getMessageBundle()

      The default behavior of this method is to call Application.getMessageBundle() on the wrapped Application object.
      NavigationHandler getNavigationHandler()

      The default behavior of this method is to call Application.getNavigationHandler() on the wrapped Application object.
      ProjectStage getProjectStage()

      The default behavior of this method is to call Application.getProjectStage() on the wrapped Application object.
      PropertyResolver getPropertyResolver()
      Deprecated.
      See superclass for alternative.
      ResourceBundle getResourceBundle(FacesContext ctx, String name)

      The default behavior of this method is to call Application.getResourceBundle(javax.faces.context.FacesContext, String) on the wrapped Application object.
      ResourceHandler getResourceHandler()

      The default behavior of this method is to call Application.getResourceHandler() on the wrapped Application object.
      StateManager getStateManager()

      The default behavior of this method is to call Application.getStateManager() on the wrapped Application object.
      Iterator<Locale> getSupportedLocales()

      The default behavior of this method is to call Application.getSupportedLocales() on the wrapped Application object.
      Iterator<String> getValidatorIds()

      The default behavior of this method is to call Application.getValidatorIds() on the wrapped Application object.
      VariableResolver getVariableResolver()
      Deprecated.
      See superclass for alternative.
      ViewHandler getViewHandler()

      The default behavior of this method is to call Application.getViewHandler() on the wrapped Application object.
      abstract Application getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Class<?> sourceBaseType, Object source)

      The default behavior of this method is to call Application.publishEvent(javax.faces.context.FacesContext, Class, Class, Object) on the wrapped Application object.
      void publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Object source)

      The default behavior of this method is to call Application.publishEvent(javax.faces.context.FacesContext, Class, Object) on the wrapped Application object.
      void removeELContextListener(ELContextListener listener)

      The default behavior of this method is to call Application.removeELContextListener(javax.el.ELContextListener) on the wrapped Application object.
      void setActionListener(ActionListener listener)

      The default behavior of this method is to call Application.setActionListener(javax.faces.event.ActionListener) on the wrapped Application object.
      void setDefaultLocale(Locale locale)

      The default behavior of this method is to call Application.setDefaultLocale(java.util.Locale) on the wrapped Application object.
      void setDefaultRenderKitId(String renderKitId)

      The default behavior of this method is to call Application.setDefaultRenderKitId(String) on the wrapped Application object.
      void setFlowHandler(FlowHandler newHandler)

      Set the FlowHandler instance used by the NavigationHandler to satisfy the requirements of the faces flows feature.
      void setMessageBundle(String bundle)

      The default behavior of this method is to call Application.setMessageBundle(String) on the wrapped Application object.
      void setNavigationHandler(NavigationHandler handler)

      The default behavior of this method is to call Application.setNavigationHandler(NavigationHandler) on the wrapped Application object.
      void setPropertyResolver(PropertyResolver resolver)
      Deprecated.
      See superclass for alternative.
      void setResourceHandler(ResourceHandler resourceHandler)

      The default behavior of this method is to call Application.setResourceHandler(ResourceHandler) on the wrapped Application object.
      void setStateManager(StateManager manager)

      The default behavior of this method is to call Application.setStateManager(StateManager) on the wrapped Application object.
      void setSupportedLocales(Collection<Locale> locales)

      The default behavior of this method is to call Application.setSupportedLocales(java.util.Collection) on the wrapped Application object.
      void setVariableResolver(VariableResolver resolver)
      Deprecated.
      See superclass for alternative.
      void setViewHandler(ViewHandler handler)

      The default behavior of this method is to call Application.setViewHandler(ViewHandler) on the wrapped Application object.
      void subscribeToEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      The default behavior of this method is to call Application.subscribeToEvent(Class, Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void subscribeToEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      The default behavior of this method is to call Application.subscribeToEvent(Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      The default behavior of this method is to call Application.unsubscribeFromEvent(Class, Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      The default behavior of this method is to call Application.unsubscribeFromEvent(Class, javax.faces.event.SystemEventListener) on the wrapped Application object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ApplicationWrapper

        public ApplicationWrapper()

    • Method Detail

      • getWrapped

        public abstract Application getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<Application>

      • getActionListener

        public ActionListener getActionListener()

        The default behavior of this method is to call Application.getActionListener() on the wrapped Application object.

        Specified by:
        getActionListener in class Application

      • setActionListener

        public void setActionListener(ActionListener listener)

        The default behavior of this method is to call Application.setActionListener(javax.faces.event.ActionListener) on the wrapped Application object.

        Specified by:
        setActionListener in class Application
        Parameters:
        listener - The new default ActionListener

      • getDefaultLocale

        public Locale getDefaultLocale()

        The default behavior of this method is to call Application.getDefaultLocale() on the wrapped Application object.

        Specified by:
        getDefaultLocale in class Application

      • setDefaultLocale

        public void setDefaultLocale(Locale locale)

        The default behavior of this method is to call Application.setDefaultLocale(java.util.Locale) on the wrapped Application object.

        Specified by:
        setDefaultLocale in class Application
        Parameters:
        locale - The new default Locale

      • getDefaultRenderKitId

        public String getDefaultRenderKitId()

        The default behavior of this method is to call Application.getDefaultRenderKitId() on the wrapped Application object.

        Specified by:
        getDefaultRenderKitId in class Application

      • addDefaultValidatorId

        public void addDefaultValidatorId(String validatorId)

        The default behavior of this method is to call Application.addDefaultValidatorId(String) on the wrapped Application object.

        Overrides:
        addDefaultValidatorId in class Application

      • getDefaultValidatorInfo

        public Map<String,String> getDefaultValidatorInfo()

        The default behavior of this method is to call Application.getDefaultValidatorInfo() on the wrapped Application object.

        Overrides:
        getDefaultValidatorInfo in class Application

      • setDefaultRenderKitId

        public void setDefaultRenderKitId(String renderKitId)

        The default behavior of this method is to call Application.setDefaultRenderKitId(String) on the wrapped Application object.

        Specified by:
        setDefaultRenderKitId in class Application

      • getMessageBundle

        public String getMessageBundle()

        The default behavior of this method is to call Application.getMessageBundle() on the wrapped Application object.

        Specified by:
        getMessageBundle in class Application

      • setMessageBundle

        public void setMessageBundle(String bundle)

        The default behavior of this method is to call Application.setMessageBundle(String) on the wrapped Application object.

        Specified by:
        setMessageBundle in class Application
        Parameters:
        bundle - Base name of the resource bundle to be used

      • getNavigationHandler

        public NavigationHandler getNavigationHandler()

        The default behavior of this method is to call Application.getNavigationHandler() on the wrapped Application object.

        Specified by:
        getNavigationHandler in class Application

      • setNavigationHandler

        public void setNavigationHandler(NavigationHandler handler)

        The default behavior of this method is to call Application.setNavigationHandler(NavigationHandler) on the wrapped Application object.

        Specified by:
        setNavigationHandler in class Application
        Parameters:
        handler - The new NavigationHandler instance

      • getPropertyResolver

        @Deprecated
public PropertyResolver getPropertyResolver()
        Deprecated. See superclass for alternative.

        The default behavior of this method is to call Application.getPropertyResolver() on the wrapped Application object.

        Specified by:
        getPropertyResolver in class Application

      • setPropertyResolver

        @Deprecated
public void setPropertyResolver(PropertyResolver resolver)
        Deprecated. See superclass for alternative.

        The default behavior of this method is to call Application.setPropertyResolver(javax.faces.el.PropertyResolver) on the wrapped Application object.

        Specified by:
        setPropertyResolver in class Application
        Parameters:
        resolver - The new PropertyResolver instance

      • getVariableResolver

        @Deprecated
public VariableResolver getVariableResolver()
        Deprecated. See superclass for alternative.

        The default behavior of this method is to call Application.getVariableResolver() on the wrapped Application object.

        Specified by:
        getVariableResolver in class Application

      • setVariableResolver

        @Deprecated
public void setVariableResolver(VariableResolver resolver)
        Deprecated. See superclass for alternative.

        The default behavior of this method is to call Application.setVariableResolver(javax.faces.el.VariableResolver) on the wrapped Application object.

        Specified by:
        setVariableResolver in class Application
        Parameters:
        resolver - The new VariableResolver instance

      • getViewHandler

        public ViewHandler getViewHandler()

        The default behavior of this method is to call Application.getViewHandler() on the wrapped Application object.

        Specified by:
        getViewHandler in class Application

      • setViewHandler

        public void setViewHandler(ViewHandler handler)

        The default behavior of this method is to call Application.setViewHandler(ViewHandler) on the wrapped Application object.

        Specified by:
        setViewHandler in class Application
        Parameters:
        handler - The new ViewHandler instance
        Throws:
        IllegalStateException - if this method is called after at least one request has been processed by the Lifecycle instance for this application.
        NullPointerException - if manager is null

      • getStateManager

        public StateManager getStateManager()

        The default behavior of this method is to call Application.getStateManager() on the wrapped Application object.

        Specified by:
        getStateManager in class Application

      • setStateManager

        public void setStateManager(StateManager manager)

        The default behavior of this method is to call Application.setStateManager(StateManager) on the wrapped Application object.

        Specified by:
        setStateManager in class Application
        Parameters:
        manager - The new StateManager instance
        Throws:
        IllegalStateException - if this method is called after at least one request has been processed by the Lifecycle instance for this application.
        NullPointerException - if manager is null

      • addComponent

        public void addComponent(String componentType,
                String componentClass)

        The default behavior of this method is to call Application.addComponent(String, String) on the wrapped Application object.

        Specified by:
        addComponent in class Application
        Parameters:
        componentType - The component type to be registered
        componentClass - The fully qualified class name of the corresponding UIComponent implementation

      • createComponent

        public UIComponent createComponent(String componentType)
                            throws FacesException

        The default behavior of this method is to call Application.createComponent(String) on the wrapped Application object.

        Specified by:
        createComponent in class Application
        Parameters:
        componentType - The component type for which to create and return a new UIComponent instance
        Throws:
        FacesException - if a UIComponent of the specified type cannot be created

      • createComponent

        @Deprecated
public UIComponent createComponent(ValueBinding componentBinding,
                                     FacesContext context,
                                     String componentType)
                            throws FacesException
        Deprecated. See superclass for alternative.

        The default behavior of this method is to call Application.createComponent(javax.faces.el.ValueBinding, javax.faces.context.FacesContext, String) on the wrapped Application object.

        Specified by:
        createComponent in class Application
        Parameters:
        componentBinding - ValueBinding representing a component value binding expression (typically specified by the component attribute of a custom tag)
        context - FacesContext for the current request
        componentType - Component type to create if the ValueBinding does not return a component instance
        Throws:
        FacesException - if a UIComponent cannot be created

      • getComponentTypes

        public Iterator<String> getComponentTypes()

        The default behavior of this method is to call Application.getComponentTypes() on the wrapped Application object.

        Specified by:
        getComponentTypes in class Application

      • addConverter

        public void addConverter(String converterId,
                String converterClass)

        The default behavior of this method is to call Application.addConverter(String, String) on the wrapped Application object.

        Specified by:
        addConverter in class Application
        Parameters:
        converterId - The converter id to be registered
        converterClass - The fully qualified class name of the corresponding Converter implementation

      • addConverter

        public void addConverter(Class<?> targetClass,
                String converterClass)

        The default behavior of this method is to call Application.addConverter(Class, String) on the wrapped Application object.

        Specified by:
        addConverter in class Application
        Parameters:
        targetClass - The class for which this converter is registered
        converterClass - The fully qualified class name of the corresponding Converter implementation

      • createConverter

        public Converter createConverter(String converterId)

        The default behavior of this method is to call Application.createConverter(String) on the wrapped Application object.

        Specified by:
        createConverter in class Application
        Parameters:
        converterId - The converter id for which to create and return a new Converter instance

      • createConverter

        public Converter createConverter(Class<?> targetClass)

        The default behavior of this method is to call Application.createConverter(Class) on the wrapped Application object.

        Specified by:
        createConverter in class Application
        Parameters:
        targetClass - Target class for which to return a Converter

      • getConverterIds

        public Iterator<String> getConverterIds()

        The default behavior of this method is to call Application.getConverterIds() on the wrapped Application object.

        Specified by:
        getConverterIds in class Application

      • getConverterTypes

        public Iterator<Class<?>> getConverterTypes()

        The default behavior of this method is to call Application.getConverterTypes() on the wrapped Application object.

        Specified by:
        getConverterTypes in class Application

      • createMethodBinding

        @Deprecated
public MethodBinding createMethodBinding(String ref,
                                           Class<?>[] params)
                                  throws ReferenceSyntaxException
        Deprecated. See superclass for alternative.

        The default behavior of this method is to call Application.createMethodBinding(String, Class[]) on the wrapped Application object.

        Specified by:
        createMethodBinding in class Application
        Parameters:
        ref - Method binding expression for which to return a MethodBinding instance
        params - Parameter signatures that must be compatible with those of the method to be invoked, or a zero-length array or null for a method that takes no parameters
        Throws:
        ReferenceSyntaxException - if the specified ref has invalid syntax

      • getSupportedLocales

        public Iterator<Locale> getSupportedLocales()

        The default behavior of this method is to call Application.getSupportedLocales() on the wrapped Application object.

        Specified by:
        getSupportedLocales in class Application

      • setSupportedLocales

        public void setSupportedLocales(Collection<Locale> locales)

        The default behavior of this method is to call Application.setSupportedLocales(java.util.Collection) on the wrapped Application object.

        Specified by:
        setSupportedLocales in class Application
        Parameters:
        locales - The set of supported Locales for this application

      • addBehavior

        public void addBehavior(String behaviorId,
               String behaviorClass)

        The default behavior of this method is to call Application.addBehavior(String, String) on the wrapped Application object.

        Overrides:
        addBehavior in class Application
        Parameters:
        behaviorId - The behavior id to be registered
        behaviorClass - The fully qualified class name of the corresponding Behavior implementation

      • createBehavior

        public Behavior createBehavior(String behaviorId)
                        throws FacesException

        The default behavior of this method is to call Application.createBehavior(String) on the wrapped Application object.

        Overrides:
        createBehavior in class Application
        Parameters:
        behaviorId - The behavior id for which to create and return a new Behavior instance
        Throws:
        FacesException - if the Behavior cannot be created

      • getBehaviorIds

        public Iterator<String> getBehaviorIds()

        The default behavior of this method is to call Application.getBehaviorIds() on the wrapped Application object.

        Overrides:
        getBehaviorIds in class Application

      • addValidator

        public void addValidator(String validatorId,
                String validatorClass)

        The default behavior of this method is to call Application.addValidator(String, String) on the wrapped Application object.

        Specified by:
        addValidator in class Application
        Parameters:
        validatorId - The validator id to be registered
        validatorClass - The fully qualified class name of the corresponding Validator implementation

      • createValidator

        public Validator createValidator(String validatorId)
                          throws FacesException

        The default behavior of this method is to call Application.createValidator(String) on the wrapped Application object.

        Specified by:
        createValidator in class Application
        Parameters:
        validatorId - The validator id for which to create and return a new Validator instance
        Throws:
        FacesException - if a Validator of the specified id cannot be created

      • getValidatorIds

        public Iterator<String> getValidatorIds()

        The default behavior of this method is to call Application.getValidatorIds() on the wrapped Application object.

        Specified by:
        getValidatorIds in class Application

      • createValueBinding

        public ValueBinding createValueBinding(String ref)
                                throws ReferenceSyntaxException

        The default behavior of this method is to call Application.createValueBinding(String) on the wrapped Application object.

        Specified by:
        createValueBinding in class Application
        Parameters:
        ref - Value binding expression for which to return a ValueBinding instance
        Throws:
        ReferenceSyntaxException - if the specified ref has invalid syntax

      • getResourceHandler

        public ResourceHandler getResourceHandler()

        The default behavior of this method is to call Application.getResourceHandler() on the wrapped Application object.

        Overrides:
        getResourceHandler in class Application

      • setResourceHandler

        public void setResourceHandler(ResourceHandler resourceHandler)

        The default behavior of this method is to call Application.setResourceHandler(ResourceHandler) on the wrapped Application object.

        Overrides:
        setResourceHandler in class Application
        Parameters:
        resourceHandler - The new ResourceHandler instance
        Throws:
        IllegalStateException - if this method is called after at least one request has been processed by the Lifecycle instance for this application.
        NullPointerException - if resourceHandler is null

      • getResourceBundle

        public ResourceBundle getResourceBundle(FacesContext ctx,
                               String name)

        The default behavior of this method is to call Application.getResourceBundle(javax.faces.context.FacesContext, String) on the wrapped Application object.

        Overrides:
        getResourceBundle in class Application

      • getProjectStage

        public ProjectStage getProjectStage()

        The default behavior of this method is to call Application.getProjectStage() on the wrapped Application object.

        Overrides:
        getProjectStage in class Application

      • addELResolver

        public void addELResolver(ELResolver resolver)

        The default behavior of this method is to call Application.addELResolver(javax.el.ELResolver) on the wrapped Application object.

        Overrides:
        addELResolver in class Application
        Throws:
        IllegalStateException - if called after the first request to the FacesServlet has been serviced.

      • getELResolver

        public ELResolver getELResolver()

        The default behavior of this method is to call Application.getELResolver() on the wrapped Application object.

        Overrides:
        getELResolver in class Application

      • createComponent

        public UIComponent createComponent(ValueExpression componentExpression,
                          FacesContext context,
                          String componentType)
                            throws FacesException

        The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String) on the wrapped Application object.

        Overrides:
        createComponent in class Application
        Parameters:
        componentExpression - ValueExpression representing a component value expression (typically specified by the component attribute of a custom tag)
        context - FacesContext for the current request
        componentType - Component type to create if the ValueExpression does not return a component instance
        Throws:
        FacesException - if a UIComponent cannot be created

      • createComponent

        public UIComponent createComponent(ValueExpression componentExpression,
                          FacesContext context,
                          String componentType,
                          String rendererType)

        The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String, String) on the wrapped Application object.

        Overrides:
        createComponent in class Application
        Parameters:
        componentExpression - ValueExpression representing a component value expression (typically specified by the component attribute of a custom tag)
        context - FacesContext for the current request
        componentType - Component type to create if the ValueExpression does not return a component instance
        rendererType - The renderer-type of the Renderer that will render this component. A null value must be accepted for this parameter.

      • createComponent

        public UIComponent createComponent(FacesContext context,
                          String componentType,
                          String rendererType)

        The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, String, String) on the wrapped Application object.

        Overrides:
        createComponent in class Application
        Parameters:
        context - FacesContext for the current request
        componentType - Component type to create
        rendererType - The renderer-type of the Renderer that will render this component. A null value must be accepted for this parameter.

      • createComponent

        public UIComponent createComponent(FacesContext context,
                          Resource componentResource)

        The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, Resource) on the wrapped Application object.

        Overrides:
        createComponent in class Application
        Parameters:
        context - FacesContext for the current request
        componentResource - A Resource that points to a source file that provides an implementation of a component.

      • getExpressionFactory

        public ExpressionFactory getExpressionFactory()

        The default behavior of this method is to call Application.getExpressionFactory() on the wrapped Application object.

        Overrides:
        getExpressionFactory in class Application

      • getFlowHandler

        public FlowHandler getFlowHandler()
        Description copied from class: Application

        Return the thread-safe singleton FlowHandler for this application. For implementations declaring compliance with version 2.2 of the specification, this method must never return null, even if the application has no flows. This is necessary to enable dynamic flow creation during the application's lifetime.

        All implementations that declare compliance with version 2.2 of the specification must implement this method. For the purpose of backward compatibility with environments that extend Application but do not override this method, an implementation is provided that returns null. Due to the decoratable nature of Application, code calling this method should always check for a null return.

        Overrides:
        getFlowHandler in class Application

      • setFlowHandler

        public void setFlowHandler(FlowHandler newHandler)
        Description copied from class: Application

        Set the FlowHandler instance used by the NavigationHandler to satisfy the requirements of the faces flows feature.

        Overrides:
        setFlowHandler in class Application

      • evaluateExpressionGet

        @Deprecated
public <T> T evaluateExpressionGet(FacesContext context,
                                     String expression,
                                     Class<? extends T> expectedType)
                        throws ELException
        Deprecated. See superclass for alternative.

        The default behavior of this method is to call Application.evaluateExpressionGet(javax.faces.context.FacesContext, String, Class) on the wrapped Application object.

        Overrides:
        evaluateExpressionGet in class Application
        Throws:
        ELException

      • addELContextListener

        public void addELContextListener(ELContextListener listener)

        The default behavior of this method is to call Application.addELContextListener(javax.el.ELContextListener) on the wrapped Application object.

        Overrides:
        addELContextListener in class Application

      • removeELContextListener

        public void removeELContextListener(ELContextListener listener)

        The default behavior of this method is to call Application.removeELContextListener(javax.el.ELContextListener) on the wrapped Application object.

        Overrides:
        removeELContextListener in class Application

      • getELContextListeners

        public ELContextListener[] getELContextListeners()

        The default behavior of this method is to call Application.getELContextListeners() on the wrapped Application object.

        Overrides:
        getELContextListeners in class Application

      • publishEvent

        public void publishEvent(FacesContext context,
                Class<? extends SystemEvent> systemEventClass,
                Object source)

        The default behavior of this method is to call Application.publishEvent(javax.faces.context.FacesContext, Class, Object) on the wrapped Application object.

        Overrides:
        publishEvent in class Application
        Parameters:
        context - the FacesContext for the current request
        systemEventClass - The Class of event that is being published.
        source - The source for the event of type systemEventClass.

      • publishEvent

        public void publishEvent(FacesContext context,
                Class<? extends SystemEvent> systemEventClass,
                Class<?> sourceBaseType,
                Object source)

        The default behavior of this method is to call Application.publishEvent(javax.faces.context.FacesContext, Class, Class, Object) on the wrapped Application object.

        Overrides:
        publishEvent in class Application
        Parameters:
        context - the FacesContext for the current request
        systemEventClass - The Class of event that is being published.
        sourceBaseType - The Class of the source event that must be used to lookup the listener to which this event must be published. If this argument is null the return from source.getClass() must be used as the sourceBaseType.
        source - The source for the event of type systemEventClass.

      • subscribeToEvent

        public void subscribeToEvent(Class<? extends SystemEvent> systemEventClass,
                    Class<?> sourceClass,
                    SystemEventListener listener)

        The default behavior of this method is to call Application.subscribeToEvent(Class, Class, javax.faces.event.SystemEventListener) on the wrapped Application object.

        Overrides:
        subscribeToEvent in class Application
        Parameters:
        systemEventClass - the Class of event for which listener must be fired.
        sourceClass - the Class of the instance which causes events of type systemEventClass to be fired. May be null.
        listener - the implementation of SystemEventListener whose SystemEventListener.processEvent(javax.faces.event.SystemEvent) method must be called when events of type systemEventClass are fired.

      • subscribeToEvent

        public void subscribeToEvent(Class<? extends SystemEvent> systemEventClass,
                    SystemEventListener listener)

        The default behavior of this method is to call Application.subscribeToEvent(Class, javax.faces.event.SystemEventListener) on the wrapped Application object.

        Overrides:
        subscribeToEvent in class Application
        Parameters:
        systemEventClass - the Class of event for which listener must be fired.

        listener - the implementation of SystemEventListener whose SystemEventListener.processEvent(javax.faces.event.SystemEvent) method must be called when events of type systemEventClass are fired.

        See Application.subscribeToEvent(java.lang.Class,java.lang.Class,javax.faces.event.SystemEventListener) for an additional requirement regarding when it is valid to call this method.

      • unsubscribeFromEvent

        public void unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass,
                        Class<?> sourceClass,
                        SystemEventListener listener)

        The default behavior of this method is to call Application.unsubscribeFromEvent(Class, Class, javax.faces.event.SystemEventListener) on the wrapped Application object.

        Overrides:
        unsubscribeFromEvent in class Application
        Parameters:
        systemEventClass - the Class of event for which listener must be fired.
        sourceClass - the Class of the instance which causes events of type systemEventClass to be fired. May be null.
        listener - the implementation of SystemEventListener to remove from the internal data structure.

      • unsubscribeFromEvent

        public void unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass,
                        SystemEventListener listener)

        The default behavior of this method is to call Application.unsubscribeFromEvent(Class, javax.faces.event.SystemEventListener) on the wrapped Application object.

        Overrides:
        unsubscribeFromEvent in class Application
        Parameters:
        systemEventClass - the Class of event for which listener must be fired.
        listener - the implementation of SystemEventListener to remove from the internal data structure.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConfigurableNavigationHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ConfigurableNavigationHandler

  • java.lang.Object
    • javax.faces.application.NavigationHandler
      • javax.faces.application.ConfigurableNavigationHandler
  • Direct Known Subclasses:
    ConfigurableNavigationHandlerWrapper

    public abstract class ConfigurableNavigationHandler
extends NavigationHandler

    ConfigurableNavigationHandler extends the contract of NavigationHandler to allow runtime inspection of the NavigationCases that make up the rule-base for navigation. An implementation compliant with the version of the specification in which this class was introduced (or a later version) must make it so that its NavigationHandler is an extension of this class.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ConfigurableNavigationHandler()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract NavigationCase getNavigationCase(FacesContext context, String fromAction, String outcome)

      Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.
      NavigationCase getNavigationCase(FacesContext context, String fromAction, String outcome, String toFlowDocumentId)

      Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.
      abstract Map<String,Set<NavigationCase>> getNavigationCases()

      Return a Map<String, Set<NavigationCase>> where the keys are <from-view-id> values and the values are Set<NavigationCase> where each element in the Set is a NavigationCase that applies to that <from-view-id>.
      void inspectFlow(FacesContext context, Flow flow)

      Called by the flow system to cause the flow to be inspected for navigation rules.
      void performNavigation(String outcome)

      A convenience method to signal the JavaServer Faces implementation to perform navigation with the provided outcome.

      • Methods inherited from class javax.faces.application.NavigationHandler

        handleNavigation, handleNavigation

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ConfigurableNavigationHandler

        public ConfigurableNavigationHandler()

    • Method Detail

      • getNavigationCase

        public abstract NavigationCase getNavigationCase(FacesContext context,
                               String fromAction,
                               String outcome)

        Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.

        Parameters:
        context - The FacesContext for the current request
        fromAction - The action binding expression that was evaluated to retrieve the specified outcome, or null if the outcome was acquired by some other means
        outcome - The logical outcome returned by a previous invoked application action (which may be null)
        Throws:
        NullPointerException - if context is null
        Since:
        2.0

      • getNavigationCase

        public NavigationCase getNavigationCase(FacesContext context,
                               String fromAction,
                               String outcome,
                               String toFlowDocumentId)

        Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case. Implementations that comply the version of the specification in which this method was introduced must override this method. For compatibility with decorated implementations that comply with an earlier version of the specification, an implementation is provided that simply calls through to getNavigationCase(javax.faces.context.FacesContext, java.lang.String, java.lang.String), ignoring the toFlowDocumentId parameter.

        Parameters:
        context - The FacesContext for the current request
        fromAction - The action binding expression that was evaluated to retrieve the specified outcome, or null if the outcome was acquired by some other means
        outcome - The logical outcome returned by a previous invoked application action (which may be null)
        toFlowDocumentId - The value of the toFlowDocumentId property for the navigation case (which may be null)
        Throws:
        NullPointerException - if context is null
        Since:
        2.2

      • getNavigationCases

        public abstract Map<String,Set<NavigationCase>> getNavigationCases()

        Return a Map<String, Set<NavigationCase>> where the keys are <from-view-id> values and the values are Set<NavigationCase> where each element in the Set is a NavigationCase that applies to that <from-view-id>. The implementation must support live modifications to this Map.

        Since:
        2.0

      • performNavigation

        public void performNavigation(String outcome)

        A convenience method to signal the JavaServer Faces implementation to perform navigation with the provided outcome. When the NavigationHandler is invoked, the current viewId is treated as the "from viewId" and the "from action" is null.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • inspectFlow

        public void inspectFlow(FacesContext context,
               Flow flow)

        Called by the flow system to cause the flow to be inspected for navigation rules. For backward compatibility with earlier implementations, an empty method is provided.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConfigurableNavigationHandlerWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ConfigurableNavigationHandlerWrapper

  • java.lang.Object
    • javax.faces.application.NavigationHandler
      • javax.faces.application.ConfigurableNavigationHandler
        • javax.faces.application.ConfigurableNavigationHandlerWrapper
  • All Implemented Interfaces:
    FacesWrapper<ConfigurableNavigationHandler>

    public abstract class ConfigurableNavigationHandlerWrapper
extends ConfigurableNavigationHandler
implements FacesWrapper<ConfigurableNavigationHandler>

    Provides a simple implementation of ConfigurableNavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ConfigurableNavigationHandler instance. The default implementation of all methods is to call through to the wrapped ConfigurableNavigationHandler.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      ConfigurableNavigationHandlerWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      NavigationCase getNavigationCase(FacesContext context, String fromAction, String outcome)

      Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.
      NavigationCase getNavigationCase(FacesContext context, String fromAction, String outcome, String toFlowDocumentId)

      Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.
      Map<String,Set<NavigationCase>> getNavigationCases()

      Return a Map<String, Set<NavigationCase>> where the keys are <from-view-id> values and the values are Set<NavigationCase> where each element in the Set is a NavigationCase that applies to that <from-view-id>.
      abstract ConfigurableNavigationHandler getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void handleNavigation(FacesContext context, String fromAction, String outcome)
      Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.
      void inspectFlow(FacesContext context, Flow flow)

      Called by the flow system to cause the flow to be inspected for navigation rules.
      void performNavigation(String outcome)

      A convenience method to signal the JavaServer Faces implementation to perform navigation with the provided outcome.

      • Methods inherited from class javax.faces.application.NavigationHandler

        handleNavigation

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ConfigurableNavigationHandlerWrapper

        public ConfigurableNavigationHandlerWrapper()

    • Method Detail

      • getWrapped

        public abstract ConfigurableNavigationHandler getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<ConfigurableNavigationHandler>
        Returns:
        the instance that we are wrapping.

      • getNavigationCase

        public NavigationCase getNavigationCase(FacesContext context,
                               String fromAction,
                               String outcome)
        Description copied from class: ConfigurableNavigationHandler

        Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.

        Specified by:
        getNavigationCase in class ConfigurableNavigationHandler
        Parameters:
        context - The FacesContext for the current request
        fromAction - The action binding expression that was evaluated to retrieve the specified outcome, or null if the outcome was acquired by some other means
        outcome - The logical outcome returned by a previous invoked application action (which may be null)

      • getNavigationCases

        public Map<String,Set<NavigationCase>> getNavigationCases()
        Description copied from class: ConfigurableNavigationHandler

        Return a Map<String, Set<NavigationCase>> where the keys are <from-view-id> values and the values are Set<NavigationCase> where each element in the Set is a NavigationCase that applies to that <from-view-id>. The implementation must support live modifications to this Map.

        Specified by:
        getNavigationCases in class ConfigurableNavigationHandler

      • getNavigationCase

        public NavigationCase getNavigationCase(FacesContext context,
                               String fromAction,
                               String outcome,
                               String toFlowDocumentId)
        Description copied from class: ConfigurableNavigationHandler

        Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case. Implementations that comply the version of the specification in which this method was introduced must override this method. For compatibility with decorated implementations that comply with an earlier version of the specification, an implementation is provided that simply calls through to ConfigurableNavigationHandler.getNavigationCase(javax.faces.context.FacesContext, java.lang.String, java.lang.String), ignoring the toFlowDocumentId parameter.

        Overrides:
        getNavigationCase in class ConfigurableNavigationHandler
        Parameters:
        context - The FacesContext for the current request
        fromAction - The action binding expression that was evaluated to retrieve the specified outcome, or null if the outcome was acquired by some other means
        outcome - The logical outcome returned by a previous invoked application action (which may be null)
        toFlowDocumentId - The value of the toFlowDocumentId property for the navigation case (which may be null)

      • handleNavigation

        public void handleNavigation(FacesContext context,
                    String fromAction,
                    String outcome)
        Description copied from class: NavigationHandler

        Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.

        If the implementation class also extends ConfigurableNavigationHandler, the implementation must guarantee that the logic used in a call to ConfigurableNavigationHandler.getNavigationCase(javax.faces.context.FacesContext, java.lang.String, java.lang.String) is used in this method to determine the correct navigation.

        This method must set the render targets (used in partial rendering) to render all invoking PartialViewContext.setRenderAll(boolean)) if the view identifier has changed as the result of an application action (to take into account Ajax requests).

        Specified by:
        handleNavigation in class NavigationHandler
        Parameters:
        context - The FacesContext for the current request
        fromAction - The action binding expression that was evaluated to retrieve the specified outcome, or null if the outcome was acquired by some other means
        outcome - The logical outcome returned by a previous invoked application action (which may be null)

      • performNavigation

        public void performNavigation(String outcome)
        Description copied from class: ConfigurableNavigationHandler

        A convenience method to signal the JavaServer Faces implementation to perform navigation with the provided outcome. When the NavigationHandler is invoked, the current viewId is treated as the "from viewId" and the "from action" is null.

        Overrides:
        performNavigation in class ConfigurableNavigationHandler

      • inspectFlow

        public void inspectFlow(FacesContext context,
               Flow flow)
        Description copied from class: ConfigurableNavigationHandler

        Called by the flow system to cause the flow to be inspected for navigation rules. For backward compatibility with earlier implementations, an empty method is provided.

        Overrides:
        inspectFlow in class ConfigurableNavigationHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class FacesMessage

  • java.lang.Object
    • javax.faces.application.FacesMessage
  • All Implemented Interfaces:
    Serializable

    public class FacesMessage
extends Object
implements Serializable

    FacesMessage represents a single validation (or other) message, which is typically associated with a particular component in the view. A FacesMessage instance may be created based on a specific messageId. The specification defines the set of messageIds for which there must be FacesMessage instances.

    The implementation must take the following steps when creating FacesMessage instances given a messageId:

      Call Application.getMessageBundle(). If non-null, locate the named ResourceBundle, using the Locale from the current UIViewRoot and see if it has a value for the argument messageId. If it does, treat the value as the summary of the FacesMessage. If it does not, or if Application.getMessageBundle() returned null, look in the ResourceBundle named by the value of the constant FACES_MESSAGES and see if it has a value for the argument messageId. If it does, treat the value as the summary of the FacesMessage. If it does not, there is no initialization information for the FacesMessage instance.

      In all cases, if a ResourceBundle hit is found for the {messageId}, look for further hits under the key {messageId}_detail. Use this value, if present, as the detail for the returned FacesMessage.

      Make sure to perform any parameter substitution required for the summary and detail of the FacesMessage.

    See Also:
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  FacesMessage.Severity
      Class used to represent message severity levels in a typesafe enumeration.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FACES_MESSAGES
      ResourceBundle identifier for messages whose message identifiers are defined in the JavaServer Faces specification.
      static FacesMessage.Severity SEVERITY_ERROR
      Message severity level indicating that an error has occurred.
      static FacesMessage.Severity SEVERITY_FATAL
      Message severity level indicating that a serious error has occurred.
      static FacesMessage.Severity SEVERITY_INFO
      Message severity level indicating an informational message rather than an error.
      static FacesMessage.Severity SEVERITY_WARN
      Message severity level indicating that an error might have occurred.
      static List VALUES
      Immutable List of valid FacesMessage.Severity instances, in ascending order of their ordinal value.
      static Map VALUES_MAP
      Immutable Map of valid FacesMessage.Severity instances, keyed by name.

    • Constructor Summary

      Constructors
      Constructor and Description
      FacesMessage()
      Construct a new FacesMessage with no initial values.
      FacesMessage(FacesMessage.Severity severity, String summary, String detail)
      Construct a new FacesMessage with the specified initial values.
      FacesMessage(String summary)
      Construct a new FacesMessage with just a summary.
      FacesMessage(String summary, String detail)
      Construct a new FacesMessage with the specified initial values.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      String getDetail()
      Return the localized detail text.
      FacesMessage.Severity getSeverity()
      Return the severity level.
      String getSummary()
      Return the localized summary text.
      boolean | isRendered()
      void rendered()
      Marks this message as having been rendered to the client.
      void setDetail(String detail)
      Set the localized detail text.
      void setSeverity(FacesMessage.Severity severity)
      Set the severity level.
      void setSummary(String summary)
      Set the localized summary text.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FACES_MESSAGES

        public static final String FACES_MESSAGES

        ResourceBundle identifier for messages whose message identifiers are defined in the JavaServer Faces specification.

        See Also:
        Constant Field Values

      • SEVERITY_INFO

        public static final FacesMessage.Severity SEVERITY_INFO

        Message severity level indicating an informational message rather than an error.

      • SEVERITY_WARN

        public static final FacesMessage.Severity SEVERITY_WARN

        Message severity level indicating that an error might have occurred.

      • SEVERITY_ERROR

        public static final FacesMessage.Severity SEVERITY_ERROR

        Message severity level indicating that an error has occurred.

      • SEVERITY_FATAL

        public static final FacesMessage.Severity SEVERITY_FATAL

        Message severity level indicating that a serious error has occurred.

      • VALUES

        public static final List VALUES

        Immutable List of valid FacesMessage.Severity instances, in ascending order of their ordinal value.

      • VALUES_MAP

        public static final Map VALUES_MAP

        Immutable Map of valid FacesMessage.Severity instances, keyed by name.

    • Constructor Detail

      • FacesMessage

        public FacesMessage()

        Construct a new FacesMessage with no initial values. The severity is set to Severity.INFO.

      • FacesMessage

        public FacesMessage(String summary)

        Construct a new FacesMessage with just a summary. The detail is null, the severity is set to Severity.INFO.

      • FacesMessage

        public FacesMessage(String summary,
            String detail)

        Construct a new FacesMessage with the specified initial values. The severity is set to Severity.INFO.

        Parameters:
        summary - Localized summary message text
        detail - Localized detail message text
        Throws:
        IllegalArgumentException - if the specified severity level is not one of the supported values

      • FacesMessage

        public FacesMessage(FacesMessage.Severity severity,
            String summary,
            String detail)

        Construct a new FacesMessage with the specified initial values.

        Parameters:
        severity - the severity
        summary - Localized summary message text
        detail - Localized detail message text
        Throws:
        IllegalArgumentException - if the specified severity level is not one of the supported values

    • Method Detail

      • getDetail

        public String getDetail()

        Return the localized detail text. If no localized detail text has been defined for this message, return the localized summary text instead.

      • setDetail

        public void setDetail(String detail)

        Set the localized detail text.

        Parameters:
        detail - The new localized detail text

      • getSeverity

        public FacesMessage.Severity getSeverity()

        Return the severity level.

      • setSeverity

        public void setSeverity(FacesMessage.Severity severity)

        Set the severity level.

        Parameters:
        severity - The new severity level
        Throws:
        IllegalArgumentException - if the specified severity level is not one of the supported values

      • getSummary

        public String getSummary()

        Return the localized summary text.

      • setSummary

        public void setSummary(String summary)

        Set the localized summary text.

        Parameters:
        summary - The new localized summary text

      • isRendered

        public boolean isRendered()
        Returns:
        true if rendered() has been called, otherwise false
        Since:
        2.0

      • rendered

        public void rendered()

        Marks this message as having been rendered to the client.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesMessage.Severity (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class FacesMessage.Severity

  • java.lang.Object
    • javax.faces.application.FacesMessage.Severity
  • All Implemented Interfaces:
    Comparable
    Enclosing class:
    FacesMessage

    public static class FacesMessage.Severity
extends Object
implements Comparable

    Class used to represent message severity levels in a typesafe enumeration.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int compareTo(Object other)
      Compare this FacesMessage.Severity instance to the specified one.
      int getOrdinal()
      Return the ordinal value of this FacesMessage.Severity instance.
      String toString()
      Return a String representation of this FacesMessage.Severity instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Method Detail

      • compareTo

        public int compareTo(Object other)

        Compare this FacesMessage.Severity instance to the specified one. Returns a negative integer, zero, or a positive integer if this object is less than, equal to, or greater than the specified object.

        Specified by:
        compareTo in interface Comparable
        Parameters:
        other - The other object to be compared to

      • getOrdinal

        public int getOrdinal()

        Return the ordinal value of this FacesMessage.Severity instance.

      • toString

        public String toString()

        Return a String representation of this FacesMessage.Severity instance.

        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces.application (Java(TM) EE 7 Specification APIs)

javax.faces.application

Classes

  • Application
  • ApplicationConfigurationPopulator
  • ApplicationFactory
  • ApplicationWrapper
  • ConfigurableNavigationHandler
  • ConfigurableNavigationHandlerWrapper
  • FacesMessage
  • FacesMessage.Severity
  • NavigationCase
  • NavigationCaseWrapper
  • NavigationHandler
  • NavigationHandlerWrapper
  • Resource
  • ResourceHandler
  • ResourceHandlerWrapper
  • ResourceWrapper
  • StateManager
  • StateManagerWrapper
  • ViewHandler
  • ViewHandlerWrapper
  • ViewResource

Enums

  • ProjectStage

Exceptions

  • ProtectedViewException
  • ViewExpiredException

Annotation Types

  • ResourceDependencies
  • ResourceDependency


javax.faces.application (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.application

APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

See: Description

  • Class Summary
    Class Description
    Application
    Application represents a per-web-application singleton object where applications based on JavaServer Faces (or implementations wishing to provide extended functionality) can register application-wide singletons that provide functionality required by JavaServer Faces.
    ApplicationConfigurationPopulator

    This class defines a java.util.ServiceLoader service which enables programmatic configuration of the JSF runtime using the existing Application Configuration Resources schema.
    ApplicationFactory
    ApplicationFactory is a factory object that creates (if needed) and returns Application instances.
    ApplicationWrapper

    Provides a simple implementation of Application that can be subclassed by developers wishing to provide specialized behavior to an existing Application instance.
    ConfigurableNavigationHandler

    ConfigurableNavigationHandler extends the contract of NavigationHandler to allow runtime inspection of the NavigationCases that make up the rule-base for navigation.
    ConfigurableNavigationHandlerWrapper

    Provides a simple implementation of ConfigurableNavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ConfigurableNavigationHandler instance.
    FacesMessage
    FacesMessage represents a single validation (or other) message, which is typically associated with a particular component in the view.
    FacesMessage.Severity
    Class used to represent message severity levels in a typesafe enumeration.
    NavigationCase

    NavigationCase represents a <navigation-case> in the navigation rule base, as well as the <from-view-id> with which this <navigation-case> is a sibling.
    NavigationCaseWrapper

    Provides a simple implementation of NavigationCase that can be subclassed by developers wishing to provide specialized behavior to an existing NavigationCase instance.
    NavigationHandler
    A NavigationHandler is passed the outcome string returned by an application action invoked for this application, and will use this (along with related state information) to choose the view to be displayed next.
    NavigationHandlerWrapper

    NavigationHandlerWrapper provides a simple implementation of NavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing NavigationHandler instance.
    Resource

    An instance of Resource is a Java object representation of the artifact that is served up in response to a resource request from the client.
    ResourceHandler

    ResourceHandler is the run-time API by which UIComponent and Renderer instances, and the ViewDeclarationLanguage can reference Resource instances. An implementation of this class must be thread-safe.
    ResourceHandlerWrapper

    Provides a simple implementation of ResourceHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ResourceHandler instance.
    ResourceWrapper

    Provides a simple implementation of Resource that can be subclassed by developers wishing to provide specialized behavior to an existing Resource instance.
    StateManager
    StateManager directs the process of saving and restoring the view between requests.
    StateManagerWrapper
    Provides a simple implementation of StateManager that can be subclassed by developers wishing to provide specialized behavior to an existing StateManager instance.
    ViewHandler
    ViewHandler is the pluggablity mechanism for allowing implementations of or applications using the JavaServer Faces specification to provide their own handling of the activities in the Render Response and Restore View phases of the request processing lifecycle.
    ViewHandlerWrapper

    Provides a simple implementation of ViewHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ViewHandler instance.
    ViewResource

    Superclass of Resource that is only for use with views.
  • Enum Summary
    Enum Description
    ProjectStage

    This class enables a feature similar to the RAILS_ENV feature of the Ruby on Rails web framework.
  • Exception Summary
    Exception Description
    ProtectedViewException

    This exception is thrown by the runtime when a violation of the view protection mechanism is encountered.
    ViewExpiredException
    Implementations must throw this FacesException when attempting to restore the view StateManager.restoreView(javax.faces.context.FacesContext, String, String) results in failure on postback.
  • Annotation Types Summary
    Annotation Type Description
    ResourceDependencies

    Container annotation to specify multiple ResourceDependency annotations on a single class.
    ResourceDependency

    Instances of UIComponent or Renderer that have this annotation (or ResourceDependencies attached at the class level will automatically have a resource dependency added so that the named resource will be present in user agent's view of the UIViewRoot in which this component or renderer is used.

Package javax.faces.application Description

APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces. The main class in this package is Application.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.application Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.application

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.application.Application
      • javax.faces.application.ApplicationWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.application.ApplicationConfigurationPopulator
    • javax.faces.application.ApplicationFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.application.FacesMessage (implements java.io.Serializable)
    • javax.faces.application.FacesMessage.Severity (implements java.lang.Comparable<T>)
    • javax.faces.application.NavigationCase
      • javax.faces.application.NavigationCaseWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.application.NavigationHandler
      • javax.faces.application.ConfigurableNavigationHandler
        • javax.faces.application.ConfigurableNavigationHandlerWrapper (implements javax.faces.FacesWrapper<T>)
      • javax.faces.application.NavigationHandlerWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.application.ResourceHandler
      • javax.faces.application.ResourceHandlerWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.application.StateManager
      • javax.faces.application.StateManagerWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.application.StateManager.SerializedView
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.application.ProtectedViewException
            • javax.faces.application.ViewExpiredException
    • javax.faces.application.ViewHandler
      • javax.faces.application.ViewHandlerWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.application.ViewResource
      • javax.faces.application.Resource
        • javax.faces.application.ResourceWrapper (implements javax.faces.FacesWrapper<T>)

Annotation Type Hierarchy

  • javax.faces.application.ResourceDependency (implements java.lang.annotation.Annotation)
  • javax.faces.application.ResourceDependencies (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.faces.application.ProjectStage
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


NavigationCase (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class NavigationCase

  • java.lang.Object
    • javax.faces.application.NavigationCase
  • Direct Known Subclasses:
    NavigationCaseWrapper

    public class NavigationCase
extends Object

    NavigationCase represents a <navigation-case> in the navigation rule base, as well as the <from-view-id> with which this <navigation-case> is a sibling.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      NavigationCase(String fromViewId, String fromAction, String fromOutcome, String condition, String toViewId, Map<String,List<String>> parameters, boolean redirect, boolean includeViewParams)

      Construct a new NavigationCase based on the provided arguments.
      NavigationCase(String fromViewId, String fromAction, String fromOutcome, String condition, String toViewId, String toFlowDocumentId, Map<String,List<String>> parameters, boolean redirect, boolean includeViewParams)

      Construct a new NavigationCase based on the provided arguments.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      boolean | equals(Object o)
      URL getActionURL(FacesContext context)

      Construct an absolute URL to this NavigationCase instance using ViewHandler.getActionURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.
      URL getBookmarkableURL(FacesContext context)

      Construct an absolute URL suitable for a bookmarkable link to this NavigationCase instance using ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url.
      Boolean getCondition(FacesContext context)

      Evaluates the <if> for this <navigation-case>, if any.
      String getFromAction()

      Return the <from-action> for this <navigation-case>
      String getFromOutcome()

      Return the <from-outcome> for this <navigation-case>
      String getFromViewId()

      Return the <from-view-id> of the <navigation-rule> inside which this <navigation-case> is nested.
      Map<String,List<String>> getParameters()

      Return the parameters to be included for navigation cases requiring a redirect.
      URL getRedirectURL(FacesContext context)

      Construct an absolute URL suitable for a "redirect" to this NavigationCase instance using ViewHandler.getRedirectURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url.
      URL getResourceURL(FacesContext context)

      Construct an absolute URL to this NavigationCase instance using ViewHandler.getResourceURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.
      String getToFlowDocumentId()

      If this navigation case represents a flow invocation, this property is the documentId in which the flow whose id is given by the return from getFromOutcome() is defined.
      String getToViewId(FacesContext context)

      Evaluates the <to-view-id> for this <navigation-case>
      boolean hasCondition()

      Test if this navigation case has an associated <if> element.
      int | hashCode()
      boolean isIncludeViewParams()

      Return the <redirect> value for this <navigation-case>.
      boolean isRedirect()

      Return the <redirect> value for this <navigation-case>.
      String toString()

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NavigationCase

        public NavigationCase(String fromViewId,
              String fromAction,
              String fromOutcome,
              String condition,
              String toViewId,
              Map<String,List<String>> parameters,
              boolean redirect,
              boolean includeViewParams)

        Construct a new NavigationCase based on the provided arguments. See section JSF.7.4.2 for how a NavigationCase is used by the standard ConfigurableNavigationHandler

        Parameters:
        fromViewId - return from getFromViewId()
        fromAction - return from getFromAction()
        fromOutcome - return from getFromOutcome()
        condition - A string to be interpreted as a ValueExpression by a call to getCondition(javax.faces.context.FacesContext)
        toViewId - return from getToViewId(javax.faces.context.FacesContext)
        parameters - return from getParameters()
        redirect - return from isRedirect()
        includeViewParams - return isIncludeViewParams()

      • NavigationCase

        public NavigationCase(String fromViewId,
              String fromAction,
              String fromOutcome,
              String condition,
              String toViewId,
              String toFlowDocumentId,
              Map<String,List<String>> parameters,
              boolean redirect,
              boolean includeViewParams)

        Construct a new NavigationCase based on the provided arguments. See section JSF.7.4.2 for how a NavigationCase is used by the standard ConfigurableNavigationHandler

        Parameters:
        fromViewId - return from getFromViewId()
        fromAction - return from getFromAction()
        fromOutcome - return from getFromOutcome()
        condition - A string to be interpreted as a ValueExpression by a call to getCondition(javax.faces.context.FacesContext)
        toViewId - return from getToViewId(javax.faces.context.FacesContext)
        parameters - return from getParameters()
        redirect - return from isRedirect()
        includeViewParams - return isIncludeViewParams()

    • Method Detail

      • getActionURL

        public URL getActionURL(FacesContext context)
                 throws MalformedURLException

        Construct an absolute URL to this NavigationCase instance using ViewHandler.getActionURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.

        Parameters:
        context - the FacesContext for the current request
        Throws:
        MalformedURLException - if the process of constructing the URL causes this exception to be thrown.

      • getResourceURL

        public URL getResourceURL(FacesContext context)
                   throws MalformedURLException

        Construct an absolute URL to this NavigationCase instance using ViewHandler.getResourceURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.

        Parameters:
        context - the FacesContext for the current request
        Throws:
        MalformedURLException - if the process of constructing the URL causes this exception to be thrown.

      • getRedirectURL

        public URL getRedirectURL(FacesContext context)
                   throws MalformedURLException

        Construct an absolute URL suitable for a "redirect" to this NavigationCase instance using ViewHandler.getRedirectURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url.

        Parameters:
        context - the FacesContext for the current request
        Throws:
        MalformedURLException - if the process of constructing the URL causes this exception to be thrown.

      • getBookmarkableURL

        public URL getBookmarkableURL(FacesContext context)
                       throws MalformedURLException

        Construct an absolute URL suitable for a bookmarkable link to this NavigationCase instance using ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url. This URL may include view parameters specified as metadata within the view.

        Parameters:
        context - the FacesContext for the current request
        Throws:
        MalformedURLException - if the process of constructing the URL causes this exception to be thrown.

      • getFromViewId

        public String getFromViewId()

        Return the <from-view-id> of the <navigation-rule> inside which this <navigation-case> is nested.

      • getFromAction

        public String getFromAction()

        Return the <from-action> for this <navigation-case>

      • getFromOutcome

        public String getFromOutcome()

        Return the <from-outcome> for this <navigation-case>

      • getToViewId

        public String getToViewId(FacesContext context)

        Evaluates the <to-view-id> for this <navigation-case>

        Parameters:
        context - the FacesContext for the current request
        Returns:
        the view ID that should be navigated to

      • getToFlowDocumentId

        public String getToFlowDocumentId()

        If this navigation case represents a flow invocation, this property is the documentId in which the flow whose id is given by the return from getFromOutcome() is defined. Implementations must override this method to return the value defined in the corresponding application configuration resources element. The base implementation returns the empty string.

        Since:
        2.2

      • hasCondition

        public boolean hasCondition()

        Test if this navigation case has an associated <if> element.

        Returns:
        true if there's an <if> element associated with this <navigation-case>, otherwise false

      • getCondition

        public Boolean getCondition(FacesContext context)

        Evaluates the <if> for this <navigation-case>, if any. The expression to be evaluated is passed into the constructor as a string. When the expression is evaluated, its value must be coerced into a boolean per the normal EL coercion rules.

        Parameters:
        context - the FacesContext for the current request
        Returns:
        null if there is no <if> element associated with this <navigation-case>, otherwise return the evaluation result of the condition
        Throws:
        any - exceptions encountered during the process of evaluating the expression or obtaining its value.

      • getParameters

        public Map<String,List<String>> getParameters()

        Return the parameters to be included for navigation cases requiring a redirect. If no parameters are defined, null will be returned. The keys in the Map are parameter names. For each key, the corresponding value is a List of unconverted values.

      • isRedirect

        public boolean isRedirect()

        Return the <redirect> value for this <navigation-case>. This will be true if the new view should be navigated to via a ExternalContext.redirect(String)

      • isIncludeViewParams

        public boolean isIncludeViewParams()

        Return the <redirect> value for this <navigation-case>. This will be true if the view parametets should be encoded into the redirect URL (only applies to redirect case)

      • equals

        public boolean equals(Object o)
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Overrides:
        hashCode in class Object

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NavigationCaseWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class NavigationCaseWrapper

  • java.lang.Object
    • javax.faces.application.NavigationCase
      • javax.faces.application.NavigationCaseWrapper
  • All Implemented Interfaces:
    FacesWrapper<NavigationCase>

    public abstract class NavigationCaseWrapper
extends NavigationCase
implements FacesWrapper<NavigationCase>

    Provides a simple implementation of NavigationCase that can be subclassed by developers wishing to provide specialized behavior to an existing NavigationCase instance. The default implementation of all methods is to call through to the wrapped NavigationCase instance.

    Usage: extend this class and override getWrapped() to return the instance being wrapping.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      NavigationCaseWrapper()

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      boolean | equals(Object o)
      URL getActionURL(FacesContext context)

      Construct an absolute URL to this NavigationCase instance using ViewHandler.getActionURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.
      URL getBookmarkableURL(FacesContext context)

      Construct an absolute URL suitable for a bookmarkable link to this NavigationCase instance using ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url.
      Boolean getCondition(FacesContext context)

      Evaluates the <if> for this <navigation-case>, if any.
      String getFromAction()

      Return the <from-action> for this <navigation-case>
      String getFromOutcome()

      Return the <from-outcome> for this <navigation-case>
      String getFromViewId()

      Return the <from-view-id> of the <navigation-rule> inside which this <navigation-case> is nested.
      Map<String,List<String>> getParameters()

      Return the parameters to be included for navigation cases requiring a redirect.
      URL getRedirectURL(FacesContext context)

      Construct an absolute URL suitable for a "redirect" to this NavigationCase instance using ViewHandler.getRedirectURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url.
      URL getResourceURL(FacesContext context)

      Construct an absolute URL to this NavigationCase instance using ViewHandler.getResourceURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.
      String getToFlowDocumentId()

      If this navigation case represents a flow invocation, this property is the documentId in which the flow whose id is given by the return from NavigationCase.getFromOutcome() is defined.
      String getToViewId(FacesContext context)

      Evaluates the <to-view-id> for this <navigation-case>
      abstract NavigationCase getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      boolean hasCondition()

      Test if this navigation case has an associated <if> element.
      int | hashCode()
      boolean isIncludeViewParams()

      Return the <redirect> value for this <navigation-case>.
      boolean isRedirect()

      Return the <redirect> value for this <navigation-case>.
      String toString()

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NavigationCaseWrapper

        public NavigationCaseWrapper()

    • Method Detail

      • equals

        public boolean equals(Object o)
        Overrides:
        equals in class NavigationCase

      • hashCode

        public int hashCode()
        Overrides:
        hashCode in class NavigationCase

      • toString

        public String toString()
        Overrides:
        toString in class NavigationCase

      • getWrapped

        public abstract NavigationCase getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<NavigationCase>

      • getActionURL

        public URL getActionURL(FacesContext context)
                 throws MalformedURLException
        Description copied from class: NavigationCase

        Construct an absolute URL to this NavigationCase instance using ViewHandler.getActionURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.

        Overrides:
        getActionURL in class NavigationCase
        Parameters:
        context - the FacesContext for the current request
        Throws:
        MalformedURLException - if the process of constructing the URL causes this exception to be thrown.

      • getBookmarkableURL

        public URL getBookmarkableURL(FacesContext context)
                       throws MalformedURLException
        Description copied from class: NavigationCase

        Construct an absolute URL suitable for a bookmarkable link to this NavigationCase instance using ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url. This URL may include view parameters specified as metadata within the view.

        Overrides:
        getBookmarkableURL in class NavigationCase
        Parameters:
        context - the FacesContext for the current request
        Throws:
        MalformedURLException - if the process of constructing the URL causes this exception to be thrown.

      • getCondition

        public Boolean getCondition(FacesContext context)
        Description copied from class: NavigationCase

        Evaluates the <if> for this <navigation-case>, if any. The expression to be evaluated is passed into the constructor as a string. When the expression is evaluated, its value must be coerced into a boolean per the normal EL coercion rules.

        Overrides:
        getCondition in class NavigationCase
        Parameters:
        context - the FacesContext for the current request
        Returns:
        null if there is no <if> element associated with this <navigation-case>, otherwise return the evaluation result of the condition

      • getFromAction

        public String getFromAction()
        Description copied from class: NavigationCase

        Return the <from-action> for this <navigation-case>

        Overrides:
        getFromAction in class NavigationCase

      • getFromOutcome

        public String getFromOutcome()
        Description copied from class: NavigationCase

        Return the <from-outcome> for this <navigation-case>

        Overrides:
        getFromOutcome in class NavigationCase

      • getFromViewId

        public String getFromViewId()
        Description copied from class: NavigationCase

        Return the <from-view-id> of the <navigation-rule> inside which this <navigation-case> is nested.

        Overrides:
        getFromViewId in class NavigationCase

      • getParameters

        public Map<String,List<String>> getParameters()
        Description copied from class: NavigationCase

        Return the parameters to be included for navigation cases requiring a redirect. If no parameters are defined, null will be returned. The keys in the Map are parameter names. For each key, the corresponding value is a List of unconverted values.

        Overrides:
        getParameters in class NavigationCase

      • getRedirectURL

        public URL getRedirectURL(FacesContext context)
                   throws MalformedURLException
        Description copied from class: NavigationCase

        Construct an absolute URL suitable for a "redirect" to this NavigationCase instance using ViewHandler.getRedirectURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url.

        Overrides:
        getRedirectURL in class NavigationCase
        Parameters:
        context - the FacesContext for the current request
        Throws:
        MalformedURLException - if the process of constructing the URL causes this exception to be thrown.

      • getResourceURL

        public URL getResourceURL(FacesContext context)
                   throws MalformedURLException
        Description copied from class: NavigationCase

        Construct an absolute URL to this NavigationCase instance using ViewHandler.getResourceURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.

        Overrides:
        getResourceURL in class NavigationCase
        Parameters:
        context - the FacesContext for the current request
        Throws:
        MalformedURLException - if the process of constructing the URL causes this exception to be thrown.

      • getToViewId

        public String getToViewId(FacesContext context)
        Description copied from class: NavigationCase

        Evaluates the <to-view-id> for this <navigation-case>

        Overrides:
        getToViewId in class NavigationCase
        Parameters:
        context - the FacesContext for the current request
        Returns:
        the view ID that should be navigated to

      • getToFlowDocumentId

        public String getToFlowDocumentId()
        Description copied from class: NavigationCase

        If this navigation case represents a flow invocation, this property is the documentId in which the flow whose id is given by the return from NavigationCase.getFromOutcome() is defined. Implementations must override this method to return the value defined in the corresponding application configuration resources element. The base implementation returns the empty string.

        Overrides:
        getToFlowDocumentId in class NavigationCase

      • hasCondition

        public boolean hasCondition()
        Description copied from class: NavigationCase

        Test if this navigation case has an associated <if> element.

        Overrides:
        hasCondition in class NavigationCase
        Returns:
        true if there's an <if> element associated with this <navigation-case>, otherwise false

      • isIncludeViewParams

        public boolean isIncludeViewParams()
        Description copied from class: NavigationCase

        Return the <redirect> value for this <navigation-case>. This will be true if the view parametets should be encoded into the redirect URL (only applies to redirect case)

        Overrides:
        isIncludeViewParams in class NavigationCase

      • isRedirect

        public boolean isRedirect()
        Description copied from class: NavigationCase

        Return the <redirect> value for this <navigation-case>. This will be true if the new view should be navigated to via a ExternalContext.redirect(String)

        Overrides:
        isRedirect in class NavigationCase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NavigationHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class NavigationHandler

  • java.lang.Object
    • javax.faces.application.NavigationHandler
  • Direct Known Subclasses:
    ConfigurableNavigationHandler, NavigationHandlerWrapper

    public abstract class NavigationHandler
extends Object

    A NavigationHandler is passed the outcome string returned by an application action invoked for this application, and will use this (along with related state information) to choose the view to be displayed next.

    A default implementation of NavigationHandler must be provided by the JSF implementation, which will be utilized unless setNavigationHandler() is called to establish a different one. An implementation of this class must be thread-safe. This default instance will compare the view identifier of the current view, the specified action binding, and the specified outcome against any navigation rules provided in faces-config.xml file(s). If a navigation case matches, the current view will be changed by a call to FacesContext.setViewRoot(). Note that a null outcome value will never match any navigation rule, so it can be used as an indicator that the current view should be redisplayed.

    • Constructor Summary

      Constructors
      Constructor and Description
      NavigationHandler()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void handleNavigation(FacesContext context, String fromAction, String outcome)
      Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.
      void handleNavigation(FacesContext context, String fromAction, String outcome, String toFlowDocumentId)

      Overloaded variant of handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) that allows the caller to provide the defining document id for a flow to be entered by this navigation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NavigationHandler

        public NavigationHandler()

    • Method Detail

      • handleNavigation

        public abstract void handleNavigation(FacesContext context,
                    String fromAction,
                    String outcome)

        Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.

        If the implementation class also extends ConfigurableNavigationHandler, the implementation must guarantee that the logic used in a call to ConfigurableNavigationHandler.getNavigationCase(javax.faces.context.FacesContext, java.lang.String, java.lang.String) is used in this method to determine the correct navigation.

        This method must set the render targets (used in partial rendering) to render all invoking PartialViewContext.setRenderAll(boolean)) if the view identifier has changed as the result of an application action (to take into account Ajax requests).

        Parameters:
        context - The FacesContext for the current request
        fromAction - The action binding expression that was evaluated to retrieve the specified outcome, or null if the outcome was acquired by some other means
        outcome - The logical outcome returned by a previous invoked application action (which may be null)
        Throws:
        NullPointerException - if context is null

      • handleNavigation

        public void handleNavigation(FacesContext context,
                    String fromAction,
                    String outcome,
                    String toFlowDocumentId)

        Overloaded variant of handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) that allows the caller to provide the defining document id for a flow to be entered by this navigation. For backward compatibility with decorated NavigationHandler implementations that conform to an earlier version of the specification, an implementation is provided that calls through to handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String), ignoring the toFlowDocumentId parameter.

        Parameters:
        context - The FacesContext for the current request
        fromAction - The action binding expression that was evaluated to retrieve the specified outcome, or null if the outcome was acquired by some other means
        outcome - The logical outcome returned by a previous invoked application action (which may be null)
        toFlowDocumentId - The defining document id of the flow into which this navigation will cause entry.
        Throws:
        NullPointerException - if context is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NavigationHandlerWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class NavigationHandlerWrapper

  • java.lang.Object
    • javax.faces.application.NavigationHandler
      • javax.faces.application.NavigationHandlerWrapper
  • All Implemented Interfaces:
    FacesWrapper<NavigationHandler>

    public abstract class NavigationHandlerWrapper
extends NavigationHandler
implements FacesWrapper<NavigationHandler>

    NavigationHandlerWrapper provides a simple implementation of NavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing NavigationHandler instance. The default implementation of all methods is to call through to the wrapped NavigationHandler instance.

    getWrapped() to return the instance being wrapping.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      NavigationHandlerWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract NavigationHandler getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void handleNavigation(FacesContext context, String fromAction, String outcome)
      Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.
      void handleNavigation(FacesContext context, String fromAction, String outcome, String toFlowDocumentId)

      Overloaded variant of NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) that allows the caller to provide the defining document id for a flow to be entered by this navigation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NavigationHandlerWrapper

        public NavigationHandlerWrapper()

    • Method Detail

      • getWrapped

        public abstract NavigationHandler getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<NavigationHandler>

      • handleNavigation

        public void handleNavigation(FacesContext context,
                    String fromAction,
                    String outcome)
        Description copied from class: NavigationHandler

        Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.

        If the implementation class also extends ConfigurableNavigationHandler, the implementation must guarantee that the logic used in a call to ConfigurableNavigationHandler.getNavigationCase(javax.faces.context.FacesContext, java.lang.String, java.lang.String) is used in this method to determine the correct navigation.

        This method must set the render targets (used in partial rendering) to render all invoking PartialViewContext.setRenderAll(boolean)) if the view identifier has changed as the result of an application action (to take into account Ajax requests).

        Specified by:
        handleNavigation in class NavigationHandler
        Parameters:
        context - The FacesContext for the current request
        fromAction - The action binding expression that was evaluated to retrieve the specified outcome, or null if the outcome was acquired by some other means
        outcome - The logical outcome returned by a previous invoked application action (which may be null)

      • handleNavigation

        public void handleNavigation(FacesContext context,
                    String fromAction,
                    String outcome,
                    String toFlowDocumentId)
        Description copied from class: NavigationHandler

        Overloaded variant of NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) that allows the caller to provide the defining document id for a flow to be entered by this navigation. For backward compatibility with decorated NavigationHandler implementations that conform to an earlier version of the specification, an implementation is provided that calls through to NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String), ignoring the toFlowDocumentId parameter.

        Overrides:
        handleNavigation in class NavigationHandler
        Parameters:
        context - The FacesContext for the current request
        fromAction - The action binding expression that was evaluated to retrieve the specified outcome, or null if the outcome was acquired by some other means
        outcome - The logical outcome returned by a previous invoked application action (which may be null)
        toFlowDocumentId - The defining document id of the flow into which this navigation will cause entry.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProjectStage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.application

Enum ProjectStage

  • java.lang.Object
    • java.lang.Enum<ProjectStage>
      • javax.faces.application.ProjectStage
  • All Implemented Interfaces:
    Serializable, Comparable<ProjectStage>

    public enum ProjectStage
extends Enum<ProjectStage>

    This class enables a feature similar to the RAILS_ENV feature of the Ruby on Rails web framework. The constants in this class represent the current state of the running application in a typical product development lifecycle. The value of this state may be queried at any time after application startup by calling Application.getProjectStage().

    Since:
    2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      Development

      This value indicates the currently running application is right now, at this moment, being developed.
      Production

      This value indicates the currently running application is deployed in production.
      SystemTest

      This value indicates the currently running application is undergoing system testing.
      UnitTest

      This value indicates the currently running application is undergoing unit testing.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String PROJECT_STAGE_JNDI_NAME

      The value of this constant is the name used for JNDI lookups for setting the current value to be returned by Application.getProjectStage().
      static String PROJECT_STAGE_PARAM_NAME

      The value of this constant is the value of the param-name for setting the current value to be returned by Application.getProjectStage().

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ProjectStage valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ProjectStage[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • Development

        public static final ProjectStage Development

        This value indicates the currently running application is right now, at this moment, being developed. This value will usually be set during iterative development.

      • UnitTest

        public static final ProjectStage UnitTest

        This value indicates the currently running application is undergoing unit testing.

      • SystemTest

        public static final ProjectStage SystemTest

        This value indicates the currently running application is undergoing system testing.

      • Production

        public static final ProjectStage Production

        This value indicates the currently running application is deployed in production.

    • Field Detail

      • PROJECT_STAGE_PARAM_NAME

        public static final String PROJECT_STAGE_PARAM_NAME

        The value of this constant is the value of the param-name for setting the current value to be returned by Application.getProjectStage().

        See Also:
        Constant Field Values

      • PROJECT_STAGE_JNDI_NAME

        public static final String PROJECT_STAGE_JNDI_NAME

        The value of this constant is the name used for JNDI lookups for setting the current value to be returned by Application.getProjectStage().

        See Also:
        Constant Field Values

    • Method Detail

      • values

        public static ProjectStage[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ProjectStage c : ProjectStage.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ProjectStage valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ProtectedViewException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ProtectedViewException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.application.ProtectedViewException
  • All Implemented Interfaces:
    Serializable

    public class ProtectedViewException
extends FacesException

    This exception is thrown by the runtime when a violation of the view protection mechanism is encountered.

    Since:
    2.2
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ProtectedViewException()
      ProtectedViewException(String message)
      ProtectedViewException(String message, Throwable cause)
      ProtectedViewException(Throwable rootCause)

    • Method Summary

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ProtectedViewException

        public ProtectedViewException(Throwable rootCause)

      • ProtectedViewException

        public ProtectedViewException(String message,
                      Throwable cause)

      • ProtectedViewException

        public ProtectedViewException(String message)

      • ProtectedViewException

        public ProtectedViewException()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Resource (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class Resource

  • java.lang.Object
    • javax.faces.application.ViewResource
      • javax.faces.application.Resource
  • Direct Known Subclasses:
    ResourceWrapper

    public abstract class Resource
extends ViewResource

    An instance of Resource is a Java object representation of the artifact that is served up in response to a resource request from the client. Instances of Resource are normally created and initialized via calls to ResourceHandler.createResource(java.lang.String). See the documentation for ResourceHandler for more information.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_RESOURCE_KEY

      This constant is used as the key in the component attribute map of a composite component to associate the component with its Resource instance.

    • Constructor Summary

      Constructors
      Constructor and Description
      Resource()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getContentType()

      Return the MIME content-type for this resource.
      abstract InputStream getInputStream()

      If the current request is a resource request, (that is, ResourceHandler.isResourceRequest(javax.faces.context.FacesContext) returns true), return an InputStream containing the bytes of the resource.
      String getLibraryName()

      Return the libraryName for this resource.
      abstract String getRequestPath()

      Return a path to this resource such that, when the browser resolves it against the base URI for the view that includes the resource, and issues a GET request to the resultant fully qualified URL, the bytes of the resource are returned in response.
      String getResourceName()

      Return the resourceName for this resource.
      abstract Map<String,String> getResponseHeaders()

      Returns a mutable Map<String, String> whose entries will be sent as response headers during ResourceHandler.handleResourceRequest(javax.faces.context.FacesContext).
      abstract URL getURL()

      Return an actual URL instance that refers to this resource instance.
      void setContentType(String contentType)

      Set the MIME content-type for this resource.
      void setLibraryName(String libraryName)

      Set the libraryName for this resource.
      void setResourceName(String resourceName)

      Set the resourceName for this resource.
      String toString()

      Call through to getRequestPath() and return the result.
      abstract boolean userAgentNeedsUpdate(FacesContext context)

      Return true if the user-agent requesting this resource needs an update.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • COMPONENT_RESOURCE_KEY

        public static final String COMPONENT_RESOURCE_KEY

        This constant is used as the key in the component attribute map of a composite component to associate the component with its Resource instance. The value for this key is the actual Resource instance.

        See Also:
        Constant Field Values

    • Constructor Detail

      • Resource

        public Resource()

    • Method Detail

      • getContentType

        public String getContentType()

        Return the MIME content-type for this resource.

        Returns:
        the MIME content-type for this resource.

      • setContentType

        public void setContentType(String contentType)

        Set the MIME content-type for this resource. The default implementation performs no validation on the argument.

        Parameters:
        contentType - the MIME content-type for this resource. The default implementation must accept null as a parameter.

      • getLibraryName

        public String getLibraryName()

        Return the libraryName for this resource. May be null. The libraryName for a resource is an optional String that indicates membership in a "resource library". All resources with the same libraryName belong to the same "resource library". The "resource library" concept allows disambiguating resources that have the same resourceName. See ResourceHandler for more information.

        Returns:
        Return the libraryName for this resource. May be null.

      • setLibraryName

        public void setLibraryName(String libraryName)

        Set the libraryName for this resource.

        Parameters:
        libraryName - the libraryName for this resource. The default implementation must accept null for the libraryName.

      • getResourceName

        public String getResourceName()

        Return the resourceName for this resource. Will never be null. All Resource instances must have a resourceName.

        Returns:
        Return the resourceName for this resource. Will never be null.

      • setResourceName

        public void setResourceName(String resourceName)

        Set the resourceName for this resource.

        Parameters:
        resourceName - a non-null String.
        Throws:
        NullPointerException - if argument resourceName is null.

      • getInputStream

        public abstract InputStream getInputStream()
                                    throws IOException

        If the current request is a resource request, (that is, ResourceHandler.isResourceRequest(javax.faces.context.FacesContext) returns true), return an InputStream containing the bytes of the resource. Otherwise, throw an IOException.

        Returns:
        an InputStream containing the bytes of the resource.

        Any EL expressions present in the resource must be evaluated before serving the bytes of the resource. Note that due to browser and server caching, EL expressions in a resource file will generally only be evaluated once, when the resource is first served up. Therefore, using EL expressions that refer to per-request data is not advisable since this data can become stale.

        Throws:
        IOException - if the current request is not a resource request.

      • getResponseHeaders

        public abstract Map<String,String> getResponseHeaders()

        Returns a mutable Map<String, String> whose entries will be sent as response headers during ResourceHandler.handleResourceRequest(javax.faces.context.FacesContext). The entries in this map must not persist beyond the scope of a single request. Any modifications made to the map after the resource has been served will be ignored by the run-time.

        Returns:
        a mutable Map<String, String> of headers that will be included with the response.

      • getRequestPath

        public abstract String getRequestPath()

        Return a path to this resource such that, when the browser resolves it against the base URI for the view that includes the resource, and issues a GET request to the resultant fully qualified URL, the bytes of the resource are returned in response.

        The default implementation must implement the following algorithm. For discussion, the return result from this method will be called result.

        • Get the context-root for this web application, not ending in slash. For discussion this will be called contextRoot.

        • Discover if the FacesServlet is prefix or extension mapped, and the value of the mapping (including the leading '.' in the case of extension mapping). For discussion, this will be facesServletMapping.

          If prefix mapped, result must be

            result = contextRoot + '/' + facesServletMapping + ResourceHandler.RESOURCE_IDENTIFIER + '/' + getResourceName()

          If extension mapped, result must be

            result = contextRoot + ResourceHandler.RESOURCE_IDENTIFIER + getResourceName() + facesServletMapping

        • Build up a string, called resourceMetaData which is an & separated string of name=value pairs suitable for inclusion in a URL query string.

            If getLibraryName() returns non-null, resourceMetaData must include "ln=" + the return from getLibraryName()

            If there is a localePrefix for this application, as defined in ResourceHandler.LOCALE_PREFIX, resourceMetaData must include "loc=" + the localePrefix.

            If this resource is contained in a resource library contract, resourceMetaData must include "con=" + the name of the resource library contract.

          Append "?" + resourceMetaData to result.

        • Make it portlet safe by passing the result through ViewHandler.getResourceURL(javax.faces.context.FacesContext, java.lang.String).

        Returns:
        the path to this resource, intended to be included in the encoded view that is sent to the browser when sending a faces response.

      • getURL

        public abstract URL getURL()

        Return an actual URL instance that refers to this resource instance.

        Specified by:
        getURL in class ViewResource
        Returns:
        Return an actual URL instance that refers to this resource instance.

      • toString

        public String toString()

        Call through to getRequestPath() and return the result.

        Overrides:
        toString in class Object
        Returns:
        Call through to getRequestPath() and return the result.

      • userAgentNeedsUpdate

        public abstract boolean userAgentNeedsUpdate(FacesContext context)

        Return true if the user-agent requesting this resource needs an update. If the If-Modified-Since HTTP header is available for this request, its value must be consulted, as specified in Section 14.25 of IETF RFC 2616, to determine the result. Returns false if the user-agent does not need an update for this resource.

        Returns:
        true or false depending on whether or not the user-agent needs an update of this resource.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceDependencies (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.application

Annotation Type ResourceDependencies

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface ResourceDependencies

    Container annotation to specify multiple ResourceDependency annotations on a single class. Example:

@ResourceDependencies( {
  @ResourceDependency(library="corporate", name="css_master.css"),
  @ResourceDependency(library="client01", name="layout.css"),
  @ResourceDependency(library="corporate", name="typography.css"),
  @ResourceDependency(library="client01", name="colorAndMedia.css"),
  @ResourceDependency(library="corporate", name="table2.css"),
  @ResourceDependency(library="fancy", name="commontaskssection.css"),
  @ResourceDependency(library="fancy", name="progressBar.css"),
  @ResourceDependency(library="fancy", name="css_ns6up.css")
                       })

    The action described in ResourceDependency must be taken for each @ResourceDependency present in the container annotation.

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      ResourceDependency[] value

    • Element Detail

      • value

        public abstract ResourceDependency[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ResourceDependency (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.application

Annotation Type ResourceDependency

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface ResourceDependency

    Instances of UIComponent or Renderer that have this annotation (or ResourceDependencies attached at the class level will automatically have a resource dependency added so that the named resource will be present in user agent's view of the UIViewRoot in which this component or renderer is used.

    The default implementation must support attaching this annotation to UIComponent or Renderer classes. In both cases, the event that precipitates the processing of this annotation is the insertion of a UIComponent instance into the view hierarchy on an initial request for a view. When that event happens, the following action must be taken.

    1. If this annotation is not present on the class in question, no action must be taken.

    2. Create a UIOutput instance by passing javax.faces.Output. to Application.createComponent(java.lang.String).

    3. Get the annotation instance from the class and obtain the values of the name, library, and target attributes.

    4. If library is the empty string, let library be null.

    5. If target is the empty string, let target be null.

    6. Obtain the renderer-type for the resource name by passing name to ResourceHandler.getRendererTypeForResourceName(java.lang.String).

    7. Call setRendererType on the UIOutput instance, passing the renderer-type.

    8. Obtain the Map of attributes from the UIOutput component by calling UIComponent.getAttributes().

    9. Store the name into the attributes Map under the key "name".

    10. If library is non-null, store it under the key "library".

    11. If target is non-null, store it under the key "target".

    12. Otherwise, if target is null, call UIViewRoot.addComponentResource(javax.faces.context.FacesContext, javax.faces.component.UIComponent), passing the UIOutput instance as the second argument.

    Example:

  @ResourceDependency(library="corporate", name="colorAndMedia.css"),
    Since:
    2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name

      The resourceName of the resource pointed to by this ResourceDependency.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String library

      The libraryName in which the resource pointed to by this ResourceDependency resides.
      String target

      The value given for this attribute will be passed as the "target" argument to UIViewRoot.addComponentResource(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String).

    • Element Detail

      • name

        public abstract String name

        The resourceName of the resource pointed to by this ResourceDependency. It is valid to have EL Expressions in the value of this attribute, as long as the expression resolves to an instance of the expected type.

      • library

        public abstract String library

        The libraryName in which the resource pointed to by this ResourceDependency resides. If not specified, defaults to the empty string. It is valid to have EL Expressions in the value of this attribute, as long as the expression resolves to an instance of the expected type.

        Default:
        ""

      • target

        public abstract String target

        The value given for this attribute will be passed as the "target" argument to UIViewRoot.addComponentResource(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String). If this attribute is specified, UIViewRoot.addComponentResource(javax.faces.context.FacesContext,javax.faces.component.UIComponent) must be called instead, as described above. It is valid to have EL Expressions in the value of this attribute, as long as the expression resolves to an instance of the expected type.

        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ResourceHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ResourceHandler

  • java.lang.Object
    • javax.faces.application.ResourceHandler
  • Direct Known Subclasses:
    ResourceHandlerWrapper

    public abstract class ResourceHandler
extends Object

    ResourceHandler is the run-time API by which UIComponent and Renderer instances, and the ViewDeclarationLanguage can reference Resource instances. An implementation of this class must be thread-safe.

    Packaging Resources

      ResourceHandler defines a path based packaging convention for resources. The default implementation of ResourceHandler must support packaging resources in the classpath or in the web application root. See section JSF.2.6.1 of the spec prose document linked in the overview summary for the normative specification of packaging resources.

      Briefly, The default implementation must support packaging resources in the web application root under the path

      resources/<resourceIdentifier>

      relative to the web app root. "resources" is the default location, but this location can be changed by the value of the WEBAPP_RESOURCES_DIRECTORY_PARAM_NAME <context-param>.

      For the default implementation, resources packaged in the classpath must reside under the JAR entry name

      META-INF/resources/<resourceIdentifier>

      In the case of Faces Flows packaged within jar files, resources packaged in the classpath must reside under the jar entry name

      META-INF/flows/<resourceIdentifier>

      <resourceIdentifier> consists of several segments, specified as follows.

      [localePrefix/][libraryName/][libraryVersion/]resourceName[/resourceVersion]

      None of the segments in the resourceIdentifier may be relative paths, such as ‘../otherLibraryName’. The implementation is not required to support the libraryVersion and resourceVersion segments for the JAR packaging case.

      Note that resourceName is the only required segment.

    Encoding Resources

      During the handling of view requests, the JSF run-time may be called upon to encode a resource in such a way as to instruct the user-agent to make a subsequent resource request. This behavior is orchestrated by one of the resource renderers (ScriptRenderer, StylesheetRenderer, ImageRenderer), which all call Resource.getRequestPath() to obtain the encoded URI for the resource. See Resource.getRequestPath() and the Standard HTML RenderKit specification for the complete specification.

      This usage of resources does not apply for resources that correspond to VDL resources.

    Decoding Resources

      During the handling of resource requests, the JSF run-time will be called upon to decode a resource in such a way as to serve up the bytes of the resource to the user-agent. This behavior is orchestrated by handleResourceRequest(javax.faces.context.FacesContext), which calls Resource.getInputStream() to obtain bytes of the resource. See handleResourceRequest(javax.faces.context.FacesContext) for the complete specification.

      This usage of resources does not apply for resources that correspond to VDL resources.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String LOCALE_PREFIX

      The name of a key within the application message bundle named by the return from Application.getMessageBundle() whose value is the locale prefix used to find a packaged resource to return from createResource(java.lang.String) (or one of its variants).
      static String RESOURCE_CONTRACT_XML

      The name of the marker file that the implementation must scan for, within sub-directories META-INF/contracts, to identify the set of available resource library contracts.
      static String RESOURCE_EXCLUDES_DEFAULT_VALUE

      The default value for the RESOURCE_EXCLUDES_PARAM_NAME init param.
      static String RESOURCE_EXCLUDES_PARAM_NAME

      The ServletContext init parameter consulted by the handleResourceRequest(javax.faces.context.FacesContext) to tell which kinds of resources must never be served up in response to a resource request.
      static String RESOURCE_IDENTIFIER

      Resource.getRequestPath() returns the value of this constant as the prefix of the URI.
      static String WEBAPP_CONTRACTS_DIRECTORY_PARAM_NAME

      If a <context-param> with the param name equal to the value of WEBAPP_CONTRACTS_DIRECTORY_PARAM_NAME exists, the runtime must interpret its value as a path, relative to the web app root, where resource library contracts are to be located.
      static String WEBAPP_RESOURCES_DIRECTORY_PARAM_NAME

      If a <context-param> with the param name equal to the value of WEBAPP_RESOURCES_DIRECTORY_PARAM_NAME exists, the runtime must interpret its value as a path, relative to the web app root, where resources are to be located.

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceHandler()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Resource createResource(String resourceName)

      Create an instance of ViewResource given the argument resourceName.
      abstract Resource createResource(String resourceName, String libraryOrContractName)

      Create an instance of Resource with a resourceName given by the value of the argument resourceName that is a member of the library named by the argument libraryName.
      abstract Resource createResource(String resourceName, String libraryName, String contentType)

      Create an instance of Resource with a resourceName given by the value of the argument resourceName that is a member of the library named by the argument libraryName that claims to have the content-type given by the argument content-type.
      Resource createResourceFromId(String resourceId)

      Create an instance of Resource given the argument resourceId.
      ViewResource createViewResource(FacesContext context, String resourceName)

      Create an instance of Resource given the argument resourceName, which may contain "/" characters.
      abstract String getRendererTypeForResourceName(String resourceName)

      Return the renderer-type for a Renderer that is capable of rendering this resource.
      abstract void handleResourceRequest(FacesContext context)

      This method specifies the contract for satisfying resource requests.
      abstract boolean isResourceRequest(FacesContext context)

      Return true if the current request is a resource request.
      boolean isResourceURL(String url)

      Return true if the argument url contains the string given by the value of the constant RESOURCE_IDENTIFIER, false otherwise.
      abstract boolean libraryExists(String libraryName)

      Return true if the resource library named by the argument libraryName can be found.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • RESOURCE_IDENTIFIER

        public static final String RESOURCE_IDENTIFIER

        Resource.getRequestPath() returns the value of this constant as the prefix of the URI. handleResourceRequest(javax.faces.context.FacesContext) looks for the value of this constant within the request URI to determine if the request is a resource request or a view request.

        See Also:
        Constant Field Values

      • RESOURCE_CONTRACT_XML

        public static final String RESOURCE_CONTRACT_XML

        The name of the marker file that the implementation must scan for, within sub-directories META-INF/contracts, to identify the set of available resource library contracts.

        Since:
        2.2
        See Also:
        Constant Field Values

      • WEBAPP_RESOURCES_DIRECTORY_PARAM_NAME

        public static final String WEBAPP_RESOURCES_DIRECTORY_PARAM_NAME

        If a <context-param> with the param name equal to the value of WEBAPP_RESOURCES_DIRECTORY_PARAM_NAME exists, the runtime must interpret its value as a path, relative to the web app root, where resources are to be located. This param value must not start with a "/", though it may contain "/" characters. If no such <context-param> exists, or its value is invalid, the value "resources", without the quotes, must be used by the runtime as the value.

        Since:
        2.2
        See Also:
        Constant Field Values

      • WEBAPP_CONTRACTS_DIRECTORY_PARAM_NAME

        public static final String WEBAPP_CONTRACTS_DIRECTORY_PARAM_NAME

        If a <context-param> with the param name equal to the value of WEBAPP_CONTRACTS_DIRECTORY_PARAM_NAME exists, the runtime must interpret its value as a path, relative to the web app root, where resource library contracts are to be located. This param value must not start with a "/", though it may contain "/" characters. If no such <context-param> exists, or its value is invalid, the value "contracts", without the quotes, must be used by the runtime as the value.

        Since:
        2.2
        See Also:
        Constant Field Values

      • LOCALE_PREFIX

        public static final String LOCALE_PREFIX

        The name of a key within the application message bundle named by the return from Application.getMessageBundle() whose value is the locale prefix used to find a packaged resource to return from createResource(java.lang.String) (or one of its variants).

        See Also:
        Constant Field Values

      • RESOURCE_EXCLUDES_PARAM_NAME

        public static final String RESOURCE_EXCLUDES_PARAM_NAME

        The ServletContext init parameter consulted by the handleResourceRequest(javax.faces.context.FacesContext) to tell which kinds of resources must never be served up in response to a resource request. The value of this parameter is a single space separated list of file extensions, including the leading '.' character (without the quotes). If not specified, the default value given in the value of the RESOURCE_EXCLUDES_DEFAULT_VALUE constant is used. If manually specified, the given value entirely overrides the default one and does not supplement it.

        See Also:
        Constant Field Values

      • RESOURCE_EXCLUDES_DEFAULT_VALUE

        public static final String RESOURCE_EXCLUDES_DEFAULT_VALUE

        The default value for the RESOURCE_EXCLUDES_PARAM_NAME init param.

        See Also:
        Constant Field Values

    • Constructor Detail

      • ResourceHandler

        public ResourceHandler()

    • Method Detail

      • createResource

        public abstract Resource createResource(String resourceName)

        Create an instance of ViewResource given the argument resourceName. The content-type of the resource is derived by passing the resourceName to ExternalContext.getMimeType(java.lang.String)

        The algorithm specified in section JSF.2.6.1.4 of the spec prose document linked in the overview summary must be executed to create the Resource. New requirements were introduced in version 2.2 of the specification. For historical reasons, this method operate correctly when the argument resourceName is of the form libraryName/resourceName, even when resourceName contains '/' characters.

        Parameters:
        resourceName - the name of the resource.
        Returns:
        a newly created Resource instance, suitable for use in encoding or decoding the named resource.
        Throws:
        NullPointerException - if resourceName is null.

      • createViewResource

        public ViewResource createViewResource(FacesContext context,
                              String resourceName)

        Create an instance of Resource given the argument resourceName, which may contain "/" characters. The ViewDeclarationLanguage calls this method when it needs to load a view from a persistent store, such as a filesystem. This method is functionality equivalent to createResource(java.lang.String), but all callsites that need to load VDL views must use this method so that classes that want to decorate the ResourceHandler in order to only affect the loading of views may do so without affecting the processing of other kinds of resources, such as scripts and stylesheets. A FacesContext must be present before calling this method. To preserve compatibility with prior revisions of the specification, a default implementation must be provided that calls createResource(java.lang.String).

        The default implementation must look for the resource in the following places, in this order.

        • Considering resource library contracts (at the locations specified in the spec prose document section Resource Library Contracts in the Request Processing Lifecycle chapter).

        • Considering the web app root.

        • Considering faces flows (at the locations specified in the spec prose document section Faces Flows in the Using JSF in Web Applications chapter).

        Call FacesContext.getResourceLibraryContracts(). If the result is non-null and not empty, for each value in the list, treat the value as the name of a resource library contract. If the argument resoureName exists as a resource in the resource library contract, return it. Otherwise, return the resource (not in the resource library contract), if found. Otherwise, return null.

        Parameters:
        context - the FacesContext for this request.
        resourceName - the name of the resource to be interpreted as a view by the ViewDeclarationLanguage.
        Returns:
        a newly created ViewResource instance, suitable for use by the ViewDeclarationLanguage.
        Throws:
        NullPointerException - if resourceName is null.
        Since:
        2.2

      • createResourceFromId

        public Resource createResourceFromId(String resourceId)

        Create an instance of Resource given the argument resourceId. The content-type of the resource is derived by passing the resourceName to ExternalContext.getMimeType(java.lang.String)

        The resource must be identified according to the specification in JSF.2.6.1.3 of the spec prose document linked in the overview summary. New requirements were introduced in version 2.2 of the specification.

        Parameters:
        resourceId - the resource identifier of the resource.
        Returns:
        a newly created Resource instance, suitable for use in encoding or decoding the named resource.
        Throws:
        NullPointerException - if resourceId is null.
        Since:
        2.2

      • createResource

        public abstract Resource createResource(String resourceName,
                      String libraryOrContractName)

        Create an instance of Resource with a resourceName given by the value of the argument resourceName that is a member of the library named by the argument libraryName. The content-type of the resource is derived by passing the resourceName to ExternalContext.getMimeType(java.lang.String).

        The algorithm specified in section JSF.2.6.1.4 of the spec prose document linked in the overview summary must be executed to create the Resource. New requirements were introduced in version 2.2 of the specification.

        Parameters:
        resourceName - the name of the resource.
        libraryOrContractName - the name of the library (or contract) in which this resource resides, may be null. If there is a conflict between the name of a resource library and a resource library contract, the resource library takes precedence. May not include relative paths, such as "../".
        Returns:
        a newly created Resource instance, suitable for use in encoding or decoding the named resource.
        Throws:
        NullPointerException - if resourceName is null

      • createResource

        public abstract Resource createResource(String resourceName,
                      String libraryName,
                      String contentType)

        Create an instance of Resource with a resourceName given by the value of the argument resourceName that is a member of the library named by the argument libraryName that claims to have the content-type given by the argument content-type.

        The algorithm specified in section JSF.2.6.1.4 of the spec prose document linked in the overview summary must be executed to create the Resource. New requirements were introduced in version 2.2 of the specification.

        Parameters:
        resourceName - the name of the resource.
        libraryName - the name of the library in which this resource resides, may be null. May not include relative paths, such as "../".
        contentType - the mime content that this Resource instance will return from Resource.getContentType(). If the value is null, The content-type of the resource is derived by passing the resourceName to ExternalContext.getMimeType(java.lang.String)

        Returns:
        a newly created Resource instance, suitable for use in encoding or decoding the named resource.
        Throws:
        NullPointerException - if resourceName is null.

      • libraryExists

        public abstract boolean libraryExists(String libraryName)

        Return true if the resource library named by the argument libraryName can be found. If there is a localePrefix for this application, as defined in LOCALE_PREFIX, first look for the library with the prefix. If no such library is found, look for the library without the prefix. This allows developers to avoid duplication of files. For example, consider the case where the developer wants to have a resource library containing a localized image resource and a non-localized script resource. By checking both locations for the existence of the library, along with other spec changes in section 2.6.1.4, this scenario is enabled.

        Since:
        2.0

      • handleResourceRequest

        public abstract void handleResourceRequest(FacesContext context)
                                    throws IOException

        This method specifies the contract for satisfying resource requests. This method is called from FacesServlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse) after that method determines the current request is a resource request by calling isResourceRequest(javax.faces.context.FacesContext). Thus, handleResourceRequest may assume that the current request is a resource request.

        The default implementation must implement an algorithm semantically identical to the following algorithm.

        For discussion, in all cases when a status code is to be set, this spec talks only using the Servlet API, but it is understood that in a portlet environment the appropriate equivalent API must be used.

        • If the resourceIdentifier ends with any of the extensions listed in the value of the RESOURCE_EXCLUDES_PARAM_NAME init parameter, HttpServletRequest.SC_NOT_FOUND must be passed to HttpServletResponse.setStatus(), then handleResourceRequest must immediately return.

        • Extract the resourceName from the resourceIdentifier by taking the substring of resourceIdentifier that starts at RESOURCE_IDENTIFIER.length() + 1 and goes to the end of resourceIdentifier. If no resourceName can be extracted, HttpServletRequest.SC_NOT_FOUND must be passed to HttpServletResponse.setStatus(), then handleResourceRequest must immediately return.

        • Extract the libraryName from the request by looking in the request parameter map for an entry under the key "ln", without the quotes. If found, use its value as the libraryName.

        • If resourceName and libraryName are present, call createResource(String, String) to create the Resource. If only resourceName is present, call createResource(String) to create the Resource. If the Resource cannot be successfully created, HttpServletRequest.SC_NOT_FOUND must be passed to HttpServletResponse.setStatus(), then handleResourceRequest must immediately return.

        • Call Resource.userAgentNeedsUpdate(javax.faces.context.FacesContext). If this method returns false, HttpServletRequest.SC_NOT_MODIFIED must be passed to HttpServletResponse.setStatus(), then handleResourceRequest must immediately return.

        • Pass the result of Resource.getContentType() to HttpServletResponse.setContentType.

        • Call Resource.getResponseHeaders(). For each entry in this Map, call HttpServletResponse.setHeader(), passing the key as the first argument and the value as the second argument.

        • Call Resource.getInputStream() and serve up the bytes of the resource to the response.

        • Call HttpServletResponse.setContentLength() passing the byte count of the resource.

        • If an IOException is thrown during any of the previous steps, log a descriptive, localized message, including the resourceName and libraryName (if present). Then, HttpServletRequest.SC_NOT_FOUND must be passed to HttpServletResponse.setStatus(), then handleResourceRequest must immediately return.

        • In all cases in this method, any streams, channels, sockets, or any other IO resources must be closed before this method returns.

        Parameters:
        context - the FacesContext for this request
        Throws:
        IOException

      • isResourceRequest

        public abstract boolean isResourceRequest(FacesContext context)

        Return true if the current request is a resource request. This method is called by FacesServlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse) to determine if this request is a view request or a resource request.

        Parameters:
        context - the FacesContext for this request
        Returns:
        true if the current request is a resource request, false otherwise.

      • isResourceURL

        public boolean isResourceURL(String url)

        Return true if the argument url contains the string given by the value of the constant RESOURCE_IDENTIFIER, false otherwise.

        Parameters:
        url - the url to inspect for the presence of RESOURCE_IDENTIFIER.
        Throws:
        NullPointerException - if the argument url is null.

      • getRendererTypeForResourceName

        public abstract String getRendererTypeForResourceName(String resourceName)

        Return the renderer-type for a Renderer that is capable of rendering this resource. The default implementation must return values according to the following table. If no renderer-type can be determined, null must be returned.

        example resource name | renderer-type
        mycomponent.js | javax.faces.resource.Script
        mystyle.css | javax.faces.resource.Stylesheet
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceHandlerWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ResourceHandlerWrapper

  • java.lang.Object
    • javax.faces.application.ResourceHandler
      • javax.faces.application.ResourceHandlerWrapper
  • All Implemented Interfaces:
    FacesWrapper<ResourceHandler>

    public abstract class ResourceHandlerWrapper
extends ResourceHandler
implements FacesWrapper<ResourceHandler>

    Provides a simple implementation of ResourceHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ResourceHandler instance. The default implementation of all methods is to call through to the wrapped ResourceHandler.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    2.0

    • Field Summary

      • Fields inherited from class javax.faces.application.ResourceHandler

        LOCALE_PREFIX, RESOURCE_CONTRACT_XML, RESOURCE_EXCLUDES_DEFAULT_VALUE, RESOURCE_EXCLUDES_PARAM_NAME, RESOURCE_IDENTIFIER, WEBAPP_CONTRACTS_DIRECTORY_PARAM_NAME, WEBAPP_RESOURCES_DIRECTORY_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceHandlerWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Resource createResource(String resourceName)

      The default behavior of this method is to call ResourceHandler.createResource(String) on the wrapped ResourceHandler object.
      Resource createResource(String resourceName, String libraryName)

      The default behavior of this method is to call ResourceHandler.createResource(String, String) on the wrapped ResourceHandler object.
      Resource createResource(String resourceName, String libraryName, String contentType)

      The default behavior of this method is to call ResourceHandler.createResource(String, String, String) on the wrapped ResourceHandler object.
      Resource createResourceFromId(String resourceId)

      The default behavior of this method is to call ResourceHandler.createResourceFromId(String) on the wrapped ResourceHandler object.
      ViewResource createViewResource(FacesContext context, String resourceName)

      The default behavior of this method is to call ResourceHandler.createViewResource(javax.faces.context.FacesContext, java.lang.String) on the wrapped ResourceHandler object.
      String getRendererTypeForResourceName(String resourceName)

      The default behavior of this method is to call ResourceHandler.getRendererTypeForResourceName(String) on the wrapped ResourceHandler object.
      abstract ResourceHandler getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void handleResourceRequest(FacesContext context)

      The default behavior of this method is to call ResourceHandler.handleResourceRequest(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.
      boolean isResourceRequest(FacesContext context)

      The default behavior of this method is to call ResourceHandler.isResourceRequest(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.
      boolean isResourceURL(String url)

      The default behavior of this method is to call ResourceHandler.isResourceURL(java.lang.String) on the wrapped ResourceHandler object.
      boolean libraryExists(String libraryName)

      The default behavior of this method is to call ResourceHandler.libraryExists(String) on the wrapped ResourceHandler object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ResourceHandlerWrapper

        public ResourceHandlerWrapper()

    • Method Detail

      • getWrapped

        public abstract ResourceHandler getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<ResourceHandler>
        Returns:
        the instance that we are wrapping.

      • createResource

        public Resource createResource(String resourceName)

        The default behavior of this method is to call ResourceHandler.createResource(String) on the wrapped ResourceHandler object.

        Specified by:
        createResource in class ResourceHandler
        Parameters:
        resourceName - the name of the resource.
        Returns:
        a newly created Resource instance, suitable for use in encoding or decoding the named resource.

      • createResourceFromId

        public Resource createResourceFromId(String resourceId)

        The default behavior of this method is to call ResourceHandler.createResourceFromId(String) on the wrapped ResourceHandler object.

        Overrides:
        createResourceFromId in class ResourceHandler
        Parameters:
        resourceId - the resource identifier of the resource.
        Returns:
        a newly created Resource instance, suitable for use in encoding or decoding the named resource.
        Since:
        2.2

      • createResource

        public Resource createResource(String resourceName,
                      String libraryName)

        The default behavior of this method is to call ResourceHandler.createResource(String, String) on the wrapped ResourceHandler object.

        Specified by:
        createResource in class ResourceHandler
        Parameters:
        resourceName - the name of the resource.
        libraryName - the name of the library (or contract) in which this resource resides, may be null. If there is a conflict between the name of a resource library and a resource library contract, the resource library takes precedence. May not include relative paths, such as "../".
        Returns:
        a newly created Resource instance, suitable for use in encoding or decoding the named resource.

      • createViewResource

        public ViewResource createViewResource(FacesContext context,
                              String resourceName)

        The default behavior of this method is to call ResourceHandler.createViewResource(javax.faces.context.FacesContext, java.lang.String) on the wrapped ResourceHandler object.

        Overrides:
        createViewResource in class ResourceHandler
        Parameters:
        context - the FacesContext for this request.
        resourceName - the name of the resource to be interpreted as a view by the ViewDeclarationLanguage.
        Returns:
        a newly created ViewResource instance, suitable for use by the ViewDeclarationLanguage.

      • createResource

        public Resource createResource(String resourceName,
                      String libraryName,
                      String contentType)

        The default behavior of this method is to call ResourceHandler.createResource(String, String, String) on the wrapped ResourceHandler object.

        Specified by:
        createResource in class ResourceHandler
        Parameters:
        resourceName - the name of the resource.
        libraryName - the name of the library in which this resource resides, may be null. May not include relative paths, such as "../".
        contentType - the mime content that this Resource instance will return from Resource.getContentType(). If the value is null, The content-type of the resource is derived by passing the resourceName to ExternalContext.getMimeType(java.lang.String)

        Returns:
        a newly created Resource instance, suitable for use in encoding or decoding the named resource.

      • handleResourceRequest

        public void handleResourceRequest(FacesContext context)
                           throws IOException

        The default behavior of this method is to call ResourceHandler.handleResourceRequest(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.

        Specified by:
        handleResourceRequest in class ResourceHandler
        Parameters:
        context - the FacesContext for this request
        Throws:
        IOException

      • isResourceRequest

        public boolean isResourceRequest(FacesContext context)

        The default behavior of this method is to call ResourceHandler.isResourceRequest(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.

        Specified by:
        isResourceRequest in class ResourceHandler
        Parameters:
        context - the FacesContext for this request
        Returns:
        true if the current request is a resource request, false otherwise.

      • isResourceURL

        public boolean isResourceURL(String url)

        The default behavior of this method is to call ResourceHandler.isResourceURL(java.lang.String) on the wrapped ResourceHandler object.

        Overrides:
        isResourceURL in class ResourceHandler
        Parameters:
        url - the url to inspect for the presence of ResourceHandler.RESOURCE_IDENTIFIER.

      • libraryExists

        public boolean libraryExists(String libraryName)

        The default behavior of this method is to call ResourceHandler.libraryExists(String) on the wrapped ResourceHandler object.

        Specified by:
        libraryExists in class ResourceHandler

      • getRendererTypeForResourceName

        public String getRendererTypeForResourceName(String resourceName)

        The default behavior of this method is to call ResourceHandler.getRendererTypeForResourceName(String) on the wrapped ResourceHandler object.

        Specified by:
        getRendererTypeForResourceName in class ResourceHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ResourceWrapper

  • java.lang.Object
    • javax.faces.application.ViewResource
      • javax.faces.application.Resource
        • javax.faces.application.ResourceWrapper
  • All Implemented Interfaces:
    FacesWrapper<Resource>

    public abstract class ResourceWrapper
extends Resource
implements FacesWrapper<Resource>

    Provides a simple implementation of Resource that can be subclassed by developers wishing to provide specialized behavior to an existing Resource instance. The default implementation of all methods is to call through to the wrapped Resource.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    2.0

    • Field Summary

      • Fields inherited from class javax.faces.application.Resource

        COMPONENT_RESOURCE_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getContentType()

      The default behavior of this method is to call Resource.getContentType() on the wrapped ResourceHandler object.
      InputStream getInputStream()

      The default behavior of this method is to call Resource.getInputStream() on the wrapped ResourceHandler object.
      String getLibraryName()

      The default behavior of this method is to call Resource.getLibraryName() on the wrapped ResourceHandler object.
      String getRequestPath()

      The default behavior of this method is to call Resource.getRequestPath() on the wrapped ResourceHandler object.
      String getResourceName()

      The default behavior of this method is to call Resource.getResourceName() on the wrapped ResourceHandler object.
      Map<String,String> getResponseHeaders()

      The default behavior of this method is to call Resource.getResponseHeaders() on the wrapped ResourceHandler object.
      URL getURL()

      The default behavior of this method is to call Resource.getURL() on the wrapped ResourceHandler object.
      abstract Resource getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void setContentType(String contentType)

      The default behavior of this method is to call Resource.setContentType(String) on the wrapped ResourceHandler object.
      void setLibraryName(String libraryName)

      The default behavior of this method is to call Resource.setLibraryName(String) on the wrapped ResourceHandler object.
      void setResourceName(String resourceName)

      The default behavior of this method is to call Resource.setResourceName(String) on the wrapped ResourceHandler object.
      boolean userAgentNeedsUpdate(FacesContext context)

      The default behavior of this method is to call Resource.userAgentNeedsUpdate(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.

      • Methods inherited from class javax.faces.application.Resource

        toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ResourceWrapper

        public ResourceWrapper()

    • Method Detail

      • getWrapped

        public abstract Resource getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<Resource>
        Returns:
        the instance that we are wrapping.

      • getInputStream

        public InputStream getInputStream()
                           throws IOException

        The default behavior of this method is to call Resource.getInputStream() on the wrapped ResourceHandler object.

        Specified by:
        getInputStream in class Resource
        Returns:
        an InputStream containing the bytes of the resource.

        Any EL expressions present in the resource must be evaluated before serving the bytes of the resource. Note that due to browser and server caching, EL expressions in a resource file will generally only be evaluated once, when the resource is first served up. Therefore, using EL expressions that refer to per-request data is not advisable since this data can become stale.

        Throws:
        IOException - if the current request is not a resource request.

      • getURL

        public URL getURL()

        The default behavior of this method is to call Resource.getURL() on the wrapped ResourceHandler object.

        Specified by:
        getURL in class Resource
        Returns:
        Return an actual URL instance that refers to this resource instance.

      • getResponseHeaders

        public Map<String,String> getResponseHeaders()

        The default behavior of this method is to call Resource.getResponseHeaders() on the wrapped ResourceHandler object.

        Specified by:
        getResponseHeaders in class Resource
        Returns:
        a mutable Map<String, String> of headers that will be included with the response.

      • getRequestPath

        public String getRequestPath()

        The default behavior of this method is to call Resource.getRequestPath() on the wrapped ResourceHandler object.

        Specified by:
        getRequestPath in class Resource
        Returns:
        the path to this resource, intended to be included in the encoded view that is sent to the browser when sending a faces response.

      • userAgentNeedsUpdate

        public boolean userAgentNeedsUpdate(FacesContext context)

        The default behavior of this method is to call Resource.userAgentNeedsUpdate(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.

        Specified by:
        userAgentNeedsUpdate in class Resource
        Returns:
        true or false depending on whether or not the user-agent needs an update of this resource.

      • getContentType

        public String getContentType()

        The default behavior of this method is to call Resource.getContentType() on the wrapped ResourceHandler object.

        Overrides:
        getContentType in class Resource
        Returns:
        the MIME content-type for this resource.

      • setContentType

        public void setContentType(String contentType)

        The default behavior of this method is to call Resource.setContentType(String) on the wrapped ResourceHandler object.

        Overrides:
        setContentType in class Resource
        Parameters:
        contentType - the MIME content-type for this resource. The default implementation must accept null as a parameter.

      • getLibraryName

        public String getLibraryName()

        The default behavior of this method is to call Resource.getLibraryName() on the wrapped ResourceHandler object.

        Overrides:
        getLibraryName in class Resource
        Returns:
        Return the libraryName for this resource. May be null.

      • setLibraryName

        public void setLibraryName(String libraryName)

        The default behavior of this method is to call Resource.setLibraryName(String) on the wrapped ResourceHandler object.

        Overrides:
        setLibraryName in class Resource
        Parameters:
        libraryName - the libraryName for this resource. The default implementation must accept null for the libraryName.

      • getResourceName

        public String getResourceName()

        The default behavior of this method is to call Resource.getResourceName() on the wrapped ResourceHandler object.

        Overrides:
        getResourceName in class Resource
        Returns:
        Return the resourceName for this resource. Will never be null.

      • setResourceName

        public void setResourceName(String resourceName)

        The default behavior of this method is to call Resource.setResourceName(String) on the wrapped ResourceHandler object.

        Overrides:
        setResourceName in class Resource
        Parameters:
        resourceName - a non-null String.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StateManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class StateManager

  • java.lang.Object
    • javax.faces.application.StateManager
  • Direct Known Subclasses:
    StateManagerWrapper

    public abstract class StateManager
extends Object

    StateManager directs the process of saving and restoring the view between requests. An implementation of this class must be thread-safe. The StateManager instance for an application is retrieved from the Application instance, and thus cannot know any details of the markup language created by the RenderKit being used to render a view. The StateManager utilizes a helper object (ResponseStateManager), that is provided by the RenderKit implementation and is therefore aware of the markup language details.

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      class  StateManager.SerializedView
      Deprecated.
      This class was not marked Serializable in the 1.0 version of the spec. It was also not a static inner class, so it can't be made to be Serializable. Therefore, it is being deprecated in version 1.2 of the spec. The replacement is to use an implementation dependent Object.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FULL_STATE_SAVING_VIEW_IDS_PARAM_NAME

      The runtime must interpret the value of this parameter as a comma separated list of view IDs, each of which must have their state saved using the state saving mechanism specified in JSF 1.2.
      static String IS_BUILDING_INITIAL_STATE

      Marker within the FacesContext attributes map to indicate we are marking initial state, so the markInitialState() method of iterating components such as UIData could recognize this fact and save the initial state of descendents.
      static String IS_SAVING_STATE

      Marker within the FacesContext attributes map to indicate we are saving state.
      static String PARTIAL_STATE_SAVING_PARAM_NAME

      The ServletContext init parameter consulted by the runtime to determine if the partial state saving mechanism should be used.
      static String SERIALIZE_SERVER_STATE_PARAM_NAME

      If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, and the javax.faces.STATE_SAVING_METHOD is set to "server" (as indicated below), the server state must be guaranteed to be Serializable such that the aggregate state implements java.io.Serializable.
      static String STATE_SAVING_METHOD_CLIENT
      Constant value for the initialization parameter named by the STATE_SAVING_METHOD_PARAM_NAME that indicates state saving should take place on the client.
      static String STATE_SAVING_METHOD_PARAM_NAME
      The ServletContext init parameter consulted by the StateManager to tell where the state should be saved.
      static String STATE_SAVING_METHOD_SERVER
      Constant value for the initialization parameter named by the STATE_SAVING_METHOD_PARAM_NAME that indicates state saving should take place on the server.

    • Constructor Summary

      Constructors
      Constructor and Description
      StateManager()

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      protected Object getComponentStateToSave(FacesContext context)
      Deprecated.
      the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
      protected Object getTreeStructureToSave(FacesContext context)
      Deprecated.
      the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
      String getViewState(FacesContext context)

      Convenience method to return the view state as a String with no RenderKit specific markup.
      boolean | isSavingStateInClient(FacesContext context)
      protected void restoreComponentState(FacesContext context, UIViewRoot viewRoot, String renderKitId)
      Deprecated.
      the distinction between tree structure and component state is now an implementation detail. The default implementation does nothing.
      protected UIViewRoot restoreTreeStructure(FacesContext context, String viewId, String renderKitId)
      Deprecated.
      the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
      abstract UIViewRoot restoreView(FacesContext context, String viewId, String renderKitId)
      Deprecated.
      StateManager.SerializedView saveSerializedView(FacesContext context)
      Deprecated.
      this has been replaced by saveView(javax.faces.context.FacesContext). The default implementation calls saveView and inspects the return. If the return is an Object [], it casts the result to an Object [] wrapping the first and second elements in an instance of StateManager.SerializedView, which it then returns. Otherwise, it returns null
      Object saveView(FacesContext context)
      Deprecated.
      void writeState(FacesContext context, Object state)
      Save the state represented in the specified state Object instance, in an implementation dependent manner.
      void writeState(FacesContext context, StateManager.SerializedView state)
      Deprecated.
      This method has been replaced by writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation calls the non-deprecated variant of the method passing an Object [] as the second argument, where the first element of the array is the return from getStructure() and the second is the return from getState() on the argument state.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • STATE_SAVING_METHOD_PARAM_NAME

        public static final String STATE_SAVING_METHOD_PARAM_NAME

        The ServletContext init parameter consulted by the StateManager to tell where the state should be saved. Valid values are given as the values of the constants: STATE_SAVING_METHOD_CLIENT or STATE_SAVING_METHOD_SERVER.

        If this parameter is not specified, the default value is the value of the constant STATE_SAVING_METHOD_CLIENT.

        See Also:
        Constant Field Values

      • PARTIAL_STATE_SAVING_PARAM_NAME

        public static final String PARTIAL_STATE_SAVING_PARAM_NAME

        The ServletContext init parameter consulted by the runtime to determine if the partial state saving mechanism should be used.

        If undefined, the runtime must determine the version level of the application.

        • For applications versioned at 1.2 and under, the runtime must not use the partial state saving mechanism.

        • For applications versioned at 2.0 and above, the runtime must use the partial state saving mechanism.

        If this parameter is defined, and the application is versioned at 1.2 and under, the runtime must not use the partial state saving mechanism. Otherwise, If this param is defined, and calling toLowerCase().equals("true") on a String representation of its value returns true, the runtime must use partial state mechanism. Otherwise the partial state saving mechanism must not be used.

        Since:
        2.0
        See Also:
        Constant Field Values

      • FULL_STATE_SAVING_VIEW_IDS_PARAM_NAME

        public static final String FULL_STATE_SAVING_VIEW_IDS_PARAM_NAME

        The runtime must interpret the value of this parameter as a comma separated list of view IDs, each of which must have their state saved using the state saving mechanism specified in JSF 1.2.

        See Also:
        Constant Field Values

      • IS_SAVING_STATE

        public static final String IS_SAVING_STATE

        Marker within the FacesContext attributes map to indicate we are saving state. The implementation must set this marker into the map before starting the state saving traversal and the marker must be cleared, in a finally block, after the traversal is complete.

        See Also:
        Constant Field Values

      • IS_BUILDING_INITIAL_STATE

        public static final String IS_BUILDING_INITIAL_STATE

        Marker within the FacesContext attributes map to indicate we are marking initial state, so the markInitialState() method of iterating components such as UIData could recognize this fact and save the initial state of descendents.

        Since:
        2.1
        See Also:
        Constant Field Values

      • SERIALIZE_SERVER_STATE_PARAM_NAME

        public static final String SERIALIZE_SERVER_STATE_PARAM_NAME

        If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, and the javax.faces.STATE_SAVING_METHOD is set to "server" (as indicated below), the server state must be guaranteed to be Serializable such that the aggregate state implements java.io.Serializable. The intent of this parameter is to ensure that the act of writing out the state to an ObjectOutputStream would not throw a NotSerializableException, but the runtime is not required verify this before saving the state.

        Since:
        2.2
        See Also:
        Constant Field Values

      • STATE_SAVING_METHOD_CLIENT

        public static final String STATE_SAVING_METHOD_CLIENT

        Constant value for the initialization parameter named by the STATE_SAVING_METHOD_PARAM_NAME that indicates state saving should take place on the client.

        See Also:
        Constant Field Values

      • STATE_SAVING_METHOD_SERVER

        public static final String STATE_SAVING_METHOD_SERVER

        Constant value for the initialization parameter named by the STATE_SAVING_METHOD_PARAM_NAME that indicates state saving should take place on the server.

        See Also:
        Constant Field Values

    • Constructor Detail

      • StateManager

        public StateManager()

    • Method Detail

      • saveSerializedView

        public StateManager.SerializedView saveSerializedView(FacesContext context)
        Deprecated. this has been replaced by saveView(javax.faces.context.FacesContext). The default implementation calls saveView and inspects the return. If the return is an Object [], it casts the result to an Object [] wrapping the first and second elements in an instance of StateManager.SerializedView, which it then returns. Otherwise, it returns null

        Return the tree structure and component state information for the view contained in the specified FacesContext instance as an object of type StateManager.SerializedView. If there is no state information to be saved, return null instead.

        Components may opt out of being included in the serialized view by setting their transient property to true. This must cause the component itself, as well as all of that component's children and facets, to be omitted from the saved tree structure and component state information.

        This method must also enforce the rule that, for components with non-null ids, all components that are descendants of the same nearest NamingContainer must have unique identifiers.

        Parameters:
        context - FacesContext for the current request
        Throws:
        IllegalStateException - if more than one component or facet within the same NamingContainer in this view has the same non-null component id

      • saveView

        @Deprecated
public Object saveView(FacesContext context)
        Deprecated.

        The functionality of this method is now handled by StateManagementStrategy.saveView(javax.faces.context.FacesContext). Return an opaque Object containing sufficient information for this same instance to restore the state of the current UIViewRoot on a subsequent request. The returned object must implement java.io.Serializable. If there is no state information to be saved, return null instead.

        Components may opt out of being included in the serialized view by setting their transient property to true. This must cause the component itself, as well as all of that component's children and facets, to be omitted from the saved tree structure and component state information.

        This method must also enforce the rule that, for components with non-null ids, all components that are descendants of the same nearest NamingContainer must have unique identifiers.

        For backwards compatability with existing StateManager implementations, the default implementation of this method calls saveSerializedView(javax.faces.context.FacesContext) and creates and returns a two element Object array with element zero containing the structure property and element one containing the state property of the SerializedView.

        Parameters:
        context - FacesContext for the current request
        Throws:
        IllegalStateException - if more than one component or facet within the same NamingContainer in this view has the same non-null component id
        Since:
        1.2

      • getTreeStructureToSave

        protected Object getTreeStructureToSave(FacesContext context)
        Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.

        Convenience method, which must be called by saveSerializedView(), to construct and return a Serializable object that represents the structure of the entire component tree (including children and facets) of this view.

        Components may opt-out of being included in the tree structure by setting their transient property to true. This must cause the component itself, as well as all of that component's children and facets, to be omitted from the saved tree structure information.

        Parameters:
        context - FacesContext for the current request

      • getComponentStateToSave

        protected Object getComponentStateToSave(FacesContext context)
        Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.

        Convenience method, which must be called by saveSerializedView(), to construct and return a Serializable object that represents the state of all component properties, attributes, and attached objects, for the entire component tree (including children and facets) of this view.

        Components may opt-out of being included in the component state by setting their transient property to true. This must cause the component itself, as well as all of that component's children and facets, to be omitted from the saved component state information.

        Parameters:
        context - FacesContext for the current request

      • writeState

        public void writeState(FacesContext context,
              Object state)
                throws IOException

        Save the state represented in the specified state Object instance, in an implementation dependent manner.

        This method will typically simply delegate the actual writing to the writeState() method of the ResponseStateManager instance provided by the RenderKit being used to render this view. This method assumes that the caller has positioned the ResponseWriter at the correct position for the saved state to be written.

        For backwards compatability with existing StateManager implementations, the default implementation of this method checks if the argument is an instance of Object [] of length greater than or equal to two. If so, it creates a SerializedView instance with the tree structure coming from element zero and the component state coming from element one and calls through to writeState(javax.faces.context.FacesContext,javax.faces.application.StateManager.SerializedView). If not, does nothing.

        Parameters:
        context - FacesContext for the current request
        state - the Serializable state to be written, as returned by saveSerializedView(javax.faces.context.FacesContext)
        Throws:
        IOException
        Since:
        1.2

      • writeState

        public void writeState(FacesContext context,
              StateManager.SerializedView state)
                throws IOException
        Deprecated. This method has been replaced by writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation calls the non-deprecated variant of the method passing an Object [] as the second argument, where the first element of the array is the return from getStructure() and the second is the return from getState() on the argument state.

        Save the state represented in the specified SerializedView isntance, in an implementation dependent manner.

        This method must consult the context initialization parameter named by the symbolic constant StateManager.STATE_SAVING_METHOD_PARAM_NAME to determine whether state should be saved on the client or the server. If not present, client side state saving is assumed.

        If the init parameter indicates that client side state saving should be used, this method must delegate the actual writing to the writeState() method of the ResponseStateManager instance provided by the RenderKit being used to render this view. This method assumes that the caller has positioned the ResponseWriter at the correct position for the saved state to be written.

        Parameters:
        context - FacesContext for the current request
        state - the serialized state to be written
        Throws:
        IOException

      • restoreView

        @Deprecated
public abstract UIViewRoot restoreView(FacesContext context,
                                String viewId,
                                String renderKitId)
        Deprecated.

        The functionality of this method is now handled by StateManagementStrategy.restoreView(javax.faces.context.FacesContext, java.lang.String, java.lang.String). Restore the tree structure and the component state of the view for the specified viewId, in an implementation dependent manner, and return the restored UIViewRoot. If there is no saved state information available for this viewId, return null instead.

        This method must consult the context initialization parameter named by the symbolic constant StateManager.STATE_SAVING_METHOD_PARAM_NAME to determine whether state should be saved on the client or the server. If not present, client side state saving is assumed.

        If the init parameter indicates that client side state saving should be used, this method must call the getTreeStructureToRestore() and (if the previous method call returned a non-null value) getComponentStateToRestore() methods of the ResponseStateManager instance provided by the RenderKit responsible for this view.

        Parameters:
        context - FacesContext for the current request
        viewId - View identifier of the view to be restored
        renderKitId - the renderKitId used to render this response. Must not be null.
        Throws:
        IllegalArgumentException - if renderKitId is null.

      • restoreTreeStructure

        protected UIViewRoot restoreTreeStructure(FacesContext context,
                              String viewId,
                              String renderKitId)
        Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.

        Convenience method, which must be called by restoreView(), to construct and return a UIViewRoot instance (populated with children and facets) representing the tree structure of the component tree being restored. If no saved state information is available, return null instead.

        Parameters:
        context - FacesContext for the current request
        viewId - View identifier of the view to be restored
        renderKitId - the renderKitId used to render this response. Must not be null.
        Throws:
        IllegalArgumentException - if renderKitId is null.

      • restoreComponentState

        protected void restoreComponentState(FacesContext context,
                         UIViewRoot viewRoot,
                         String renderKitId)
        Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation does nothing.

        Convenience method, which must be called by restoreView(), to restore the attributes, properties, and attached objects of all components in the restored component tree.

        Parameters:
        context - FacesContext for the current request
        viewRoot - UIViewRoot returned by a previous call to restoreTreeStructure()
        renderKitId - the renderKitId used to render this response. Must not be null.
        Throws:
        IllegalArgumentException - if renderKitId is null.

      • isSavingStateInClient

        public boolean isSavingStateInClient(FacesContext context)
        Returns:
        true if and only if the value of the ServletContext init parameter named by the value of the constant STATE_SAVING_METHOD_PARAM_NAME is equal to the value of the constant STATE_SAVING_METHOD_CLIENT. false otherwise.
        Throws:
        NullPointerException - if context is null.

      • getViewState

        public String getViewState(FacesContext context)

        Convenience method to return the view state as a String with no RenderKit specific markup. This default implementation of this method will call saveView(javax.faces.context.FacesContext) and passing the result to and returning the resulting value from ResponseStateManager.getViewState(javax.faces.context.FacesContext, Object).

        Parameters:
        context - FacesContext for the current request
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StateManager.SerializedView (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class StateManager.SerializedView

  • java.lang.Object
    • javax.faces.application.StateManager.SerializedView
  • Enclosing class:
    StateManager
    Deprecated.
    This class was not marked Serializable in the 1.0 version of the spec. It was also not a static inner class, so it can't be made to be Serializable. Therefore, it is being deprecated in version 1.2 of the spec. The replacement is to use an implementation dependent Object.

    public class StateManager.SerializedView
extends Object

    Convenience struct for encapsulating tree structure and component state. This is necessary to allow the API to be flexible enough to work in JSP and non-JSP environments.

    • Constructor Summary

      Constructors
      Constructor and Description
      StateManager.SerializedView(Object newStructure, Object newState)
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getState()
      Deprecated.
      Object getStructure()
      Deprecated.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • StateManager.SerializedView

        public StateManager.SerializedView(Object newStructure,
                           Object newState)
        Deprecated.

    • Method Detail

      • getStructure

        public Object getStructure()
        Deprecated.

      • getState

        public Object getState()
        Deprecated.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StateManagerWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class StateManagerWrapper

  • java.lang.Object
    • javax.faces.application.StateManager
      • javax.faces.application.StateManagerWrapper
  • All Implemented Interfaces:
    FacesWrapper<StateManager>

    public abstract class StateManagerWrapper
extends StateManager
implements FacesWrapper<StateManager>

    Provides a simple implementation of StateManager that can be subclassed by developers wishing to provide specialized behavior to an existing StateManager instance. The default implementation of all methods is to call through to the wrapped StateManager.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    1.2

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.faces.application.StateManager

        StateManager.SerializedView

    • Field Summary

      • Fields inherited from class javax.faces.application.StateManager

        FULL_STATE_SAVING_VIEW_IDS_PARAM_NAME, IS_BUILDING_INITIAL_STATE, IS_SAVING_STATE, PARTIAL_STATE_SAVING_PARAM_NAME, SERIALIZE_SERVER_STATE_PARAM_NAME, STATE_SAVING_METHOD_CLIENT, STATE_SAVING_METHOD_PARAM_NAME, STATE_SAVING_METHOD_SERVER

    • Constructor Summary

      Constructors
      Constructor and Description
      StateManagerWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected Object getComponentStateToSave(FacesContext context)
      The default behavior of this method is to call StateManager.getComponentStateToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.
      protected Object getTreeStructureToSave(FacesContext context)
      The default behavior of this method is to call StateManager.getTreeStructureToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.
      String getViewState(FacesContext context)

      The default behavior of this method is to call StateManager.getViewState(javax.faces.context.FacesContext) on the wrapped StateManager object.
      abstract StateManager getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      boolean isSavingStateInClient(FacesContext context)
      The default behavior of this method is to call StateManager.isSavingStateInClient(javax.faces.context.FacesContext) on the wrapped StateManager object.
      protected void restoreComponentState(FacesContext context, UIViewRoot viewRoot, String renderKitId)
      The default behavior of this method is to call StateManager.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, String) on the wrapped StateManager object.
      protected UIViewRoot restoreTreeStructure(FacesContext context, String viewId, String renderKitId)
      The default behavior of this method is to call StateManager.restoreTreeStructure(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.
      UIViewRoot restoreView(FacesContext context, String viewId, String renderKitId)
      The default behavior of this method is to call StateManager.restoreView(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.
      StateManager.SerializedView saveSerializedView(FacesContext context)
      The default behavior of this method is to call StateManager.saveSerializedView(javax.faces.context.FacesContext) on the wrapped StateManager object.
      Object saveView(FacesContext context)
      The default behavior of this method is to call StateManager.saveView(javax.faces.context.FacesContext) on the wrapped StateManager object.
      void writeState(FacesContext context, Object state)
      The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object) on the wrapped StateManager object.
      void writeState(FacesContext context, StateManager.SerializedView state)
      The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView) on the wrapped StateManager object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • StateManagerWrapper

        public StateManagerWrapper()

    • Method Detail

      • getWrapped

        public abstract StateManager getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<StateManager>
        Returns:
        the instance that we are wrapping.

      • saveSerializedView

        public StateManager.SerializedView saveSerializedView(FacesContext context)

        The default behavior of this method is to call StateManager.saveSerializedView(javax.faces.context.FacesContext) on the wrapped StateManager object.

        Overrides:
        saveSerializedView in class StateManager
        Parameters:
        context - FacesContext for the current request
        Since:
        1.2
        See Also:
        StateManager.saveSerializedView(javax.faces.context.FacesContext)

      • saveView

        public Object saveView(FacesContext context)

        The default behavior of this method is to call StateManager.saveView(javax.faces.context.FacesContext) on the wrapped StateManager object.

        Overrides:
        saveView in class StateManager
        Parameters:
        context - FacesContext for the current request
        Since:
        1.2
        See Also:
        StateManager.saveView(javax.faces.context.FacesContext)

      • getTreeStructureToSave

        protected Object getTreeStructureToSave(FacesContext context)

        The default behavior of this method is to call StateManager.getTreeStructureToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.

        Overrides:
        getTreeStructureToSave in class StateManager
        Parameters:
        context - FacesContext for the current request
        Since:
        1.2
        See Also:
        StateManager.getTreeStructureToSave(javax.faces.context.FacesContext)

      • getComponentStateToSave

        protected Object getComponentStateToSave(FacesContext context)

        The default behavior of this method is to call StateManager.getComponentStateToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.

        Overrides:
        getComponentStateToSave in class StateManager
        Parameters:
        context - FacesContext for the current request
        Since:
        1.2
        See Also:
        StateManager.getComponentStateToSave(javax.faces.context.FacesContext)

      • writeState

        public void writeState(FacesContext context,
              Object state)
                throws IOException

        The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object) on the wrapped StateManager object.

        Overrides:
        writeState in class StateManager
        Parameters:
        context - FacesContext for the current request
        state - the Serializable state to be written, as returned by StateManager.saveSerializedView(javax.faces.context.FacesContext)
        Throws:
        IOException
        Since:
        1.2
        See Also:
        StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object)

      • writeState

        public void writeState(FacesContext context,
              StateManager.SerializedView state)
                throws IOException

        The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView) on the wrapped StateManager object.

        Overrides:
        writeState in class StateManager
        Parameters:
        context - FacesContext for the current request
        state - the serialized state to be written
        Throws:
        IOException
        Since:
        1.2
        See Also:
        StateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView)

      • restoreView

        public UIViewRoot restoreView(FacesContext context,
                     String viewId,
                     String renderKitId)

        The default behavior of this method is to call StateManager.restoreView(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.

        Specified by:
        restoreView in class StateManager
        Parameters:
        context - FacesContext for the current request
        viewId - View identifier of the view to be restored
        renderKitId - the renderKitId used to render this response. Must not be null.
        Since:
        1.2
        See Also:
        StateManager.restoreView(javax.faces.context.FacesContext, String, String)

      • restoreTreeStructure

        protected UIViewRoot restoreTreeStructure(FacesContext context,
                              String viewId,
                              String renderKitId)

        The default behavior of this method is to call StateManager.restoreTreeStructure(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.

        Overrides:
        restoreTreeStructure in class StateManager
        Parameters:
        context - FacesContext for the current request
        viewId - View identifier of the view to be restored
        renderKitId - the renderKitId used to render this response. Must not be null.
        Since:
        1.2
        See Also:
        StateManager.restoreTreeStructure(javax.faces.context.FacesContext, String, String)

      • restoreComponentState

        protected void restoreComponentState(FacesContext context,
                         UIViewRoot viewRoot,
                         String renderKitId)

        The default behavior of this method is to call StateManager.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, String) on the wrapped StateManager object.

        Overrides:
        restoreComponentState in class StateManager
        Parameters:
        context - FacesContext for the current request
        viewRoot - UIViewRoot returned by a previous call to restoreTreeStructure()
        renderKitId - the renderKitId used to render this response. Must not be null.
        Since:
        1.2
        See Also:
        StateManager.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, String)

      • isSavingStateInClient

        public boolean isSavingStateInClient(FacesContext context)

        The default behavior of this method is to call StateManager.isSavingStateInClient(javax.faces.context.FacesContext) on the wrapped StateManager object.

        Overrides:
        isSavingStateInClient in class StateManager
        Returns:
        true if and only if the value of the ServletContext init parameter named by the value of the constant StateManager.STATE_SAVING_METHOD_PARAM_NAME is equal to the value of the constant StateManager.STATE_SAVING_METHOD_CLIENT. false otherwise.
        Since:
        1.2
        See Also:
        StateManager.isSavingStateInClient(javax.faces.context.FacesContext)

      • getViewState

        public String getViewState(FacesContext context)

        The default behavior of this method is to call StateManager.getViewState(javax.faces.context.FacesContext) on the wrapped StateManager object.

        Overrides:
        getViewState in class StateManager
        Parameters:
        context - FacesContext for the current request
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.application (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.application

  • Packages that use javax.faces.application
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.render
    Classes and interfaces defining the rendering model.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
  • Classes in javax.faces.application used by javax.faces.application
    Class and Description
    Application
    Application represents a per-web-application singleton object where applications based on JavaServer Faces (or implementations wishing to provide extended functionality) can register application-wide singletons that provide functionality required by JavaServer Faces.
    ApplicationFactory
    ApplicationFactory is a factory object that creates (if needed) and returns Application instances.
    ConfigurableNavigationHandler

    ConfigurableNavigationHandler extends the contract of NavigationHandler to allow runtime inspection of the NavigationCases that make up the rule-base for navigation.
    FacesMessage.Severity
    Class used to represent message severity levels in a typesafe enumeration.
    NavigationCase

    NavigationCase represents a <navigation-case> in the navigation rule base, as well as the <from-view-id> with which this <navigation-case> is a sibling.
    NavigationHandler
    A NavigationHandler is passed the outcome string returned by an application action invoked for this application, and will use this (along with related state information) to choose the view to be displayed next.
    ProjectStage

    This class enables a feature similar to the RAILS_ENV feature of the Ruby on Rails web framework.
    Resource

    An instance of Resource is a Java object representation of the artifact that is served up in response to a resource request from the client.
    ResourceHandler

    ResourceHandler is the run-time API by which UIComponent and Renderer instances, and the ViewDeclarationLanguage can reference Resource instances. An implementation of this class must be thread-safe.
    StateManager
    StateManager directs the process of saving and restoring the view between requests.
    StateManager.SerializedView
    Deprecated.
    This class was not marked Serializable in the 1.0 version of the spec. It was also not a static inner class, so it can't be made to be Serializable. Therefore, it is being deprecated in version 1.2 of the spec. The replacement is to use an implementation dependent Object.
    ViewHandler
    ViewHandler is the pluggablity mechanism for allowing implementations of or applications using the JavaServer Faces specification to provide their own handling of the activities in the Render Response and Restore View phases of the request processing lifecycle.
    ViewResource

    Superclass of Resource that is only for use with views.
  • Classes in javax.faces.application used by javax.faces.component
    Class and Description
    FacesMessage
    FacesMessage represents a single validation (or other) message, which is typically associated with a particular component in the view.
  • Classes in javax.faces.application used by javax.faces.context
    Class and Description
    Application
    Application represents a per-web-application singleton object where applications based on JavaServer Faces (or implementations wishing to provide extended functionality) can register application-wide singletons that provide functionality required by JavaServer Faces.
    FacesMessage
    FacesMessage represents a single validation (or other) message, which is typically associated with a particular component in the view.
    FacesMessage.Severity
    Class used to represent message severity levels in a typesafe enumeration.
    ProjectStage

    This class enables a feature similar to the RAILS_ENV feature of the Ruby on Rails web framework.
  • Classes in javax.faces.application used by javax.faces.convert
    Class and Description
    FacesMessage
    FacesMessage represents a single validation (or other) message, which is typically associated with a particular component in the view.
  • Classes in javax.faces.application used by javax.faces.event
    Class and Description
    Application
    Application represents a per-web-application singleton object where applications based on JavaServer Faces (or implementations wishing to provide extended functionality) can register application-wide singletons that provide functionality required by JavaServer Faces.
  • Classes in javax.faces.application used by javax.faces.flow
    Class and Description
    NavigationCase

    NavigationCase represents a <navigation-case> in the navigation rule base, as well as the <from-view-id> with which this <navigation-case> is a sibling.
  • Classes in javax.faces.application used by javax.faces.render
    Class and Description
    StateManager.SerializedView
    Deprecated.
    This class was not marked Serializable in the 1.0 version of the spec. It was also not a static inner class, so it can't be made to be Serializable. Therefore, it is being deprecated in version 1.2 of the spec. The replacement is to use an implementation dependent Object.
  • Classes in javax.faces.application used by javax.faces.validator
    Class and Description
    FacesMessage
    FacesMessage represents a single validation (or other) message, which is typically associated with a particular component in the view.
  • Classes in javax.faces.application used by javax.faces.view
    Class and Description
    Resource

    An instance of Resource is a Java object representation of the artifact that is served up in response to a resource request from the client.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ViewExpiredException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ViewExpiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.application.ViewExpiredException
  • All Implemented Interfaces:
    Serializable

    public class ViewExpiredException
extends FacesException

    Implementations must throw this FacesException when attempting to restore the view StateManager.restoreView(javax.faces.context.FacesContext, String, String) results in failure on postback.

    Since:
    1.2
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ViewExpiredException()
      Construct a new exception with no detail message or root cause.
      ViewExpiredException(String viewId)
      Construct a new exception with the specified view identifier.
      ViewExpiredException(String message, String viewId)
      Construct a new exception with the specified detail message and no root cause.
      ViewExpiredException(String message, Throwable cause, String viewId)
      Construct a new exception with the specified detail message and root cause.
      ViewExpiredException(Throwable cause, String viewId)
      Construct a new exception with the specified root cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getMessage()
      Return the message for this exception prepended with the view identifier if the view identifier is not null, otherwise, return the message.
      String getViewId()
      Return the view identifier of this exception, or null if the view identifier is nonexistent or unknown.

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ViewExpiredException

        public ViewExpiredException()

        Construct a new exception with no detail message or root cause.

      • ViewExpiredException

        public ViewExpiredException(String viewId)

        Construct a new exception with the specified view identifier.

        Parameters:
        viewId - The view identifier for this exception

      • ViewExpiredException

        public ViewExpiredException(String message,
                    String viewId)

        Construct a new exception with the specified detail message and no root cause.

        Parameters:
        message - The detail message for this exception
        viewId - The view identifier for this exception

      • ViewExpiredException

        public ViewExpiredException(Throwable cause,
                    String viewId)

        Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

        Parameters:
        cause - The root cause for this exception
        viewId - The view identifier for this exception

      • ViewExpiredException

        public ViewExpiredException(String message,
                    Throwable cause,
                    String viewId)

        Construct a new exception with the specified detail message and root cause.

        Parameters:
        message - The detail message for this exception
        cause - The root cause for this exception
        viewId - The view identifier for this exception

    • Method Detail

      • getViewId

        public String getViewId()

        Return the view identifier of this exception, or null if the view identifier is nonexistent or unknown.

      • getMessage

        public String getMessage()

        Return the message for this exception prepended with the view identifier if the view identifier is not null, otherwise, return the message.

        Overrides:
        getMessage in class Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ViewHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ViewHandler

  • java.lang.Object
    • javax.faces.application.ViewHandler
  • Direct Known Subclasses:
    ViewHandlerWrapper

    public abstract class ViewHandler
extends Object

    ViewHandler is the pluggablity mechanism for allowing implementations of or applications using the JavaServer Faces specification to provide their own handling of the activities in the Render Response and Restore View phases of the request processing lifecycle. This allows for implementations to support different response generation technologies, as well as alternative strategies for saving and restoring the state of each view. An implementation of this class must be thread-safe.

    Please see StateManager for information on how the ViewHandler interacts the StateManager.

    Version 2 of the specification formally introduced the concept of View Declaration Language. A View Declaration Language (VDL) is a syntax used to declare user interfaces comprised of instances of JSF UIComponents. Any of the responsibilities of the ViewHandler that specifically deal with the VDL sub-system are now the domain of the VDL implementation. These responsibilities are defined on the ViewDeclarationLanguage class. The ViewHandler provides getViewDeclarationLanguage(javax.faces.context.FacesContext, java.lang.String) as a convenience method to access the VDL implementation given a viewId.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CHARACTER_ENCODING_KEY
      The key, in the session's attribute set, under which the response character encoding may be stored and retrieved.
      static String DEFAULT_FACELETS_SUFFIX

      The value to use for the default extension for Facelet based XHTML pages if the webapp is using url extension mapping.
      static String DEFAULT_SUFFIX

      The value to use for the default extension if the webapp is using url extension mapping.
      static String DEFAULT_SUFFIX_PARAM_NAME
      Allow the web application to define a list of alternate suffixes for pages containing JSF content.
      static String DISABLE_FACELET_JSF_VIEWHANDLER_PARAM_NAME

      If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, the default ViewHandler must behave as specified in the latest 1.2 version of this specification.
      static String FACELETS_BUFFER_SIZE_PARAM_NAME

      The buffer size to set on the response when the ResponseWriter is generated.
      static String FACELETS_DECORATORS_PARAM_NAME

      A semicolon (;) delimitted list of class names of type javax.faces.view.facelets.TagDecorator, with a no-argument constructor.
      static String FACELETS_LIBRARIES_PARAM_NAME

      If this param is set, the runtime must interpret it as a semicolon (;) separated list of paths, starting with "/" (without the quotes).
      static String FACELETS_REFRESH_PERIOD_PARAM_NAME

      When a page is requested, what interval in seconds should the compiler check for changes.
      static String FACELETS_SKIP_COMMENTS_PARAM_NAME

      If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, the runtime must ensure that any XML comments in the Facelets source page are not delivered to the client.
      static String FACELETS_SUFFIX_PARAM_NAME

      Allow the web application to define an alternate suffix for Facelet based XHTML pages containing JSF content.
      static String FACELETS_VIEW_MAPPINGS_PARAM_NAME

      Allow the web application to define a semicolon (;) separated list of strings that is used to forcibly declare that certain pages in the application must be interpreted as using Facelets, regardless of their extension.

    • Constructor Summary

      Constructors
      Constructor and Description
      ViewHandler()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addProtectedView(String urlPattern)

      Add the argument urlPattern to the thread safe Set of protected views for this application.
      String calculateCharacterEncoding(FacesContext context)
      Returns the correct character encoding to be used for this request.
      abstract Locale calculateLocale(FacesContext context)
      Returns an appropriate Locale to use for this and subsequent requests for the current client.
      abstract String calculateRenderKitId(FacesContext context)
      Return an appropriate renderKitId for this and subsequent requests from the current client.
      abstract UIViewRoot createView(FacesContext context, String viewId)
      Create and return a new UIViewRoot instance initialized with information from the argument FacesContext and viewId.
      String deriveLogicalViewId(FacesContext context, String rawViewId)

      Derive and return the viewId from the current request, or the argument input by following the algorithm defined in specification section JSF.7.6.2.
      String deriveViewId(FacesContext context, String rawViewId)

      Derive and return the viewId from the current request, or the argument input by following the algorithm defined in specification section JSF.7.6.2.
      abstract String getActionURL(FacesContext context, String viewId)

      If the value returned from this method is used as the file argument to the four-argument constructor for java.net.URL (assuming appropriate values are used for the first three arguments), then a client making a request to the toExternalForm() of that URL will select the argument viewId for traversing the JSF lifecycle.
      String getBookmarkableURL(FacesContext context, String viewId, Map<String,List<String>> parameters, boolean includeViewParams)

      Return a JSF action URL derived from the viewId argument that is suitable to be used as the target of a link in a JSF response.
      Set<String> getProtectedViewsUnmodifiable()

      Return an unmodifiable Set of the protected views currently known to this ViewHandler instance.
      String getRedirectURL(FacesContext context, String viewId, Map<String,List<String>> parameters, boolean includeViewParams)

      Return a JSF action URL derived from the viewId argument that is suitable to be used by the NavigationHandler to issue a redirect request to the URL using a NonFaces request.
      abstract String getResourceURL(FacesContext context, String path)

      If the value returned from this method is used as the file argument to the four-argument constructor for java.net.URL (assuming appropriate values are used for the first three arguments), then a client making a request to the toExternalForm() of that URL will select the argument path for direct rendering.
      ViewDeclarationLanguage getViewDeclarationLanguage(FacesContext context, String viewId)

      Return the ViewDeclarationLanguage instance used for this ViewHandler instance.
      void initView(FacesContext context)
      Initialize the view for the request processing lifecycle.
      boolean removeProtectedView(String urlPattern)

      Remove the argument urlPattern from the thread safe Set of protected views for this application, if present in the Set.
      abstract void renderView(FacesContext context, UIViewRoot viewToRender)
      Perform whatever actions are required to render the response view to the response object associated with the current FacesContext.
      abstract UIViewRoot restoreView(FacesContext context, String viewId)
      Perform whatever actions are required to restore the view associated with the specified FacesContext and viewId.
      abstract void writeState(FacesContext context)
      Take any appropriate action to either immediately write out the current state information (by calling StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object), or noting where state information should later be written.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CHARACTER_ENCODING_KEY

        public static final String CHARACTER_ENCODING_KEY

        The key, in the session's attribute set, under which the response character encoding may be stored and retrieved.

        See Also:
        Constant Field Values

      • DEFAULT_SUFFIX_PARAM_NAME

        public static final String DEFAULT_SUFFIX_PARAM_NAME

        Allow the web application to define a list of alternate suffixes for pages containing JSF content. This list is a space separated list of values of the form .<extension>. The first physical resource whose extension matches one of the configured extensions will be the suffix used to create the view ID. If this init parameter is not specified, the default value is taken from the value of the constant DEFAULT_SUFFIX.

        See Also:
        Constant Field Values

      • DEFAULT_SUFFIX

        public static final String DEFAULT_SUFFIX

        The value to use for the default extension if the webapp is using url extension mapping.

        See Also:
        Constant Field Values

      • FACELETS_SKIP_COMMENTS_PARAM_NAME

        public static final String FACELETS_SKIP_COMMENTS_PARAM_NAME

        If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, the runtime must ensure that any XML comments in the Facelets source page are not delivered to the client. The runtime must also consider the facelets.SKIP_COMMENTS param name as an alias to this param name for backwards compatibility with existing facelets tag libraries.

        Since:
        2.0
        See Also:
        Constant Field Values

      • FACELETS_SUFFIX_PARAM_NAME

        public static final String FACELETS_SUFFIX_PARAM_NAME

        Allow the web application to define an alternate suffix for Facelet based XHTML pages containing JSF content. If this init parameter is not specified, the default value is taken from the value of the constant DEFAULT_FACELETS_SUFFIX

        Since:
        2.0
        See Also:
        Constant Field Values

      • DEFAULT_FACELETS_SUFFIX

        public static final String DEFAULT_FACELETS_SUFFIX

        The value to use for the default extension for Facelet based XHTML pages if the webapp is using url extension mapping.

        Since:
        2.0
        See Also:
        Constant Field Values

      • FACELETS_VIEW_MAPPINGS_PARAM_NAME

        public static final String FACELETS_VIEW_MAPPINGS_PARAM_NAME

        Allow the web application to define a semicolon (;) separated list of strings that is used to forcibly declare that certain pages in the application must be interpreted as using Facelets, regardless of their extension. Each entry in the semicolon (;) separated list of strings is either a file extension, as in *.xhtml, or a resource prefix (starting with '/' and interpreted as relative to the web application root), as in /user/*. The latter class of entry can also take the form of /<filename>.<extension>* such as /login.jsp*. The runtime must also consider the facelets.VIEW_MAPPINGS param name as an alias to this param name for backwards compatibility with existing Facelets applications.

        Since:
        2.0
        See Also:
        Constant Field Values

      • FACELETS_BUFFER_SIZE_PARAM_NAME

        public static final String FACELETS_BUFFER_SIZE_PARAM_NAME

        The buffer size to set on the response when the ResponseWriter is generated. By default the value is 1024. A value of -1 will not assign a buffer size on the response. This should be increased if you are using development mode in order to guarantee that the response isn't partially rendered when an error is generated. The runtime must also consider the facelets.BUFFER_SIZE param name as an alias to this param name for backwards compatibility with existing facelets tag libraries.

        Since:
        2.0
        See Also:
        Constant Field Values

      • FACELETS_REFRESH_PERIOD_PARAM_NAME

        public static final String FACELETS_REFRESH_PERIOD_PARAM_NAME

        When a page is requested, what interval in seconds should the compiler check for changes. If you don't want the compiler to check for changes once the page is compiled, then use a value of -1. Setting a low refresh period helps during development to be able to edit pages in a running application.The runtime must also consider the facelets.REFRESH_PERIOD param name as an alias to this param name for backwards compatibility with existing facelets tag libraries.

        Since:
        2.0
        See Also:
        Constant Field Values

      • FACELETS_LIBRARIES_PARAM_NAME

        public static final String FACELETS_LIBRARIES_PARAM_NAME

        If this param is set, the runtime must interpret it as a semicolon (;) separated list of paths, starting with "/" (without the quotes). The runtime must interpret each entry in the list as a path relative to the web application root and interpret the file found at that path as a facelet tag library, conforming to the facelet taglibrary schema and expose the tags therein according to Section "Facelet Tag Library mechanism". The runtime must also consider the facelets.LIBRARIES param name as an alias to this param name for backwards compatibility with existing facelets tag libraries.

        Since:
        2.0
        See Also:
        Constant Field Values

      • FACELETS_DECORATORS_PARAM_NAME

        public static final String FACELETS_DECORATORS_PARAM_NAME

        A semicolon (;) delimitted list of class names of type javax.faces.view.facelets.TagDecorator, with a no-argument constructor. These decorators will be loaded when the first request for a Facelets VDL view hits the ViewHandler for page compilation.The runtime must also consider the facelets.DECORATORS param name as an alias to this param name for backwards compatibility with existing facelets tag libraries.

        Since:
        2.0
        See Also:
        Constant Field Values

      • DISABLE_FACELET_JSF_VIEWHANDLER_PARAM_NAME

        public static final String DISABLE_FACELET_JSF_VIEWHANDLER_PARAM_NAME

        If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, the default ViewHandler must behave as specified in the latest 1.2 version of this specification. Any behavior specified in Section "Default ViewDeclarationLanguage Implementation" of the spec prose document and implemented in the default ViewHandler that pertains to handling requests for pages authored in the JavaServer Faces View Declaration Language must not be executed by the runtime.

        Since:
        2.0
        See Also:
        Constant Field Values

    • Constructor Detail

      • ViewHandler

        public ViewHandler()

    • Method Detail

      • calculateLocale

        public abstract Locale calculateLocale(FacesContext context)

        Returns an appropriate Locale to use for this and subsequent requests for the current client.

        Parameters:
        context - FacesContext for the current request
        Throws:
        NullPointerException - if context is null

      • calculateCharacterEncoding

        public String calculateCharacterEncoding(FacesContext context)

        Returns the correct character encoding to be used for this request.

        The following algorithm is employed.

        • Examine the Content-Type request header. If it has a charset parameter, extract it and return that as the encoding.

        • If no charset parameter was found, check for the existence of a session by calling ExternalContext.getSession(boolean) passing false as the argument. If that method returns true, get the session Map by calling ExternalContext.getSessionMap() and look for a value under the key given by the value of the symbolic constant CHARACTER_ENCODING_KEY. If present, return the value, converted to String.

        • Otherwise, return null

        Since:
        1.2

      • calculateRenderKitId

        public abstract String calculateRenderKitId(FacesContext context)

        Return an appropriate renderKitId for this and subsequent requests from the current client. It is an error for this method to return null.

        The default return value is RenderKitFactory.HTML_BASIC_RENDER_KIT.

        Parameters:
        context - FacesContext for the current request
        Throws:
        NullPointerException - if context is null

      • createView

        public abstract UIViewRoot createView(FacesContext context,
                    String viewId)

        Create and return a new UIViewRoot instance initialized with information from the argument FacesContext and viewId. Locate the ViewDeclarationLanguage implementation for the VDL used in the view. The argument viewId must be converted to a physical viewId that can refer to an actual resource suitable for use by the ViewDeclarationLanguage ViewDeclarationLanguage.createView(javax.faces.context.FacesContext, java.lang.String), which must be called by this method.

        Throws:
        NullPointerException - if context is null

      • deriveViewId

        public String deriveViewId(FacesContext context,
                  String rawViewId)

        Derive and return the viewId from the current request, or the argument input by following the algorithm defined in specification section JSF.7.6.2.

        The default implementation of this method simply returns rawViewId unchanged.

        Parameters:
        context - the FacesContext for this request
        rawViewId - the viewId to derive,
        Since:
        2.0

      • deriveLogicalViewId

        public String deriveLogicalViewId(FacesContext context,
                         String rawViewId)

        Derive and return the viewId from the current request, or the argument input by following the algorithm defined in specification section JSF.7.6.2. Note that unlike deriveViewId(), this method does not require that a physical view be present.

        The default implementation of this method simply returns rawViewId unchanged.

        Parameters:
        context - the FacesContext for this request
        rawViewId - the viewId to derive,
        Since:
        2.1

      • getActionURL

        public abstract String getActionURL(FacesContext context,
                  String viewId)

        If the value returned from this method is used as the file argument to the four-argument constructor for java.net.URL (assuming appropriate values are used for the first three arguments), then a client making a request to the toExternalForm() of that URL will select the argument viewId for traversing the JSF lifecycle. Please see section JSF.7.6.2 for the complete specification, especially for details related to view protection using the ResponseStateManager.NON_POSTBACK_VIEW_TOKEN_PARAM .

        Parameters:
        context - FacesContext for this request
        viewId - View identifier of the desired view
        Throws:
        IllegalArgumentException - if viewId is not valid for this ViewHandler, or does not start with "/".
        NullPointerException - if context or viewId is null.

      • getResourceURL

        public abstract String getResourceURL(FacesContext context,
                    String path)

        If the value returned from this method is used as the file argument to the four-argument constructor for java.net.URL (assuming appropriate values are used for the first three arguments), then a client making a request to the toExternalForm() of that URL will select the argument path for direct rendering. If the specified path starts with a slash, it must be treated as context relative; otherwise, it must be treated as relative to the action URL of the current view.

        Parameters:
        context - FacesContext for the current request
        path - Resource path to convert to a URL
        Throws:
        IllegalArgumentException - if viewId is not valid for this ViewHandler.
        NullPointerException - if context or path is null.

      • getProtectedViewsUnmodifiable

        public Set<String> getProtectedViewsUnmodifiable()

        Return an unmodifiable Set of the protected views currently known to this ViewHandler instance. Compliant implementations must return a Set that is the concatenation of the contents of all the <url-pattern> elements within all the <protected-views> in all of the application configuration resources in the current application. The runtime must support calling this method at any time after application startup. The default implementation returns an unmodifiable empty Set.

        Since:
        2.2

      • addProtectedView

        public void addProtectedView(String urlPattern)

        Add the argument urlPattern to the thread safe Set of protected views for this application. Compliant implementations make it so a subsequent call to getProtectedViewsUnmodifiable() contains the argument. The runtime must support calling this method at any time after application startup. The default implementation takes no action.

        Parameters:
        urlPattern - the url-pattern to add.
        Since:
        2.2

      • removeProtectedView

        public boolean removeProtectedView(String urlPattern)

        Remove the argument urlPattern from the thread safe Set of protected views for this application, if present in the Set. If the argument urlPattern is not present in the Set, this method has no effect. Compliant implementations must make it so a subsequent call to getProtectedViewsUnmodifiable() does not contain the argument. The runtime must support calling this method at any time after application startup. Returns true if this Set contained the argument. The default implementation takes no action and returns false.

        Parameters:
        urlPattern - the url-pattern to remove.
        Since:
        2.2

      • getRedirectURL

        public String getRedirectURL(FacesContext context,
                    String viewId,
                    Map<String,List<String>> parameters,
                    boolean includeViewParams)

        Return a JSF action URL derived from the viewId argument that is suitable to be used by the NavigationHandler to issue a redirect request to the URL using a NonFaces request. Compliant implementations must implement this method as specified in section JSF.7.6.2. The default implementation simply calls through to getActionURL(javax.faces.context.FacesContext, java.lang.String), passing the arguments context and viewId.

        Parameters:
        context - The FacesContext processing this request
        viewId - The view identifier of the target page
        parameters - A mapping of parameter names to one or more values
        includeViewParams - A flag indicating whether view parameters should be encoded into this URL
        Since:
        2.0

      • getBookmarkableURL

        public String getBookmarkableURL(FacesContext context,
                        String viewId,
                        Map<String,List<String>> parameters,
                        boolean includeViewParams)

        Return a JSF action URL derived from the viewId argument that is suitable to be used as the target of a link in a JSF response. Compiliant implementations must implement this method as specified in section JSF.7.6.2. The default implementation simply calls through to getActionURL(javax.faces.context.FacesContext, java.lang.String), passing the arguments context and viewId.

        Parameters:
        context - The FacesContext processing this request
        viewId - The view identifier of the target page
        parameters - A mapping of parameter names to one or more values
        includeViewParams - A flag indicating whether view parameters should be encoded into this URL
        Since:
        2.0

      • getViewDeclarationLanguage

        public ViewDeclarationLanguage getViewDeclarationLanguage(FacesContext context,
                                                 String viewId)

        Return the ViewDeclarationLanguage instance used for this ViewHandler instance.

        The default implementation must use ViewDeclarationLanguageFactory.getViewDeclarationLanguage(java.lang.String) to obtain the appropriate ViewDeclarationLanguage implementation for the argument viewId. Any exceptions thrown as a result of invoking that method must not be swallowed.

        The default implementation of this method returns null.

        Parameters:
        context - the FacesContext for this request.
        viewId - the logical view id, as returned from deriveLogicalViewId(javax.faces.context.FacesContext, java.lang.String) for which the ViewDeclarationLanguage should be returned.
        Since:
        2.0

      • initView

        public void initView(FacesContext context)
              throws FacesException

        Initialize the view for the request processing lifecycle.

        This method must be called at the beginning of the Restore View Phase of the Request Processing Lifecycle. It is responsible for performing any per-request initialization necessary to the operation of the lifycecle.

        The default implementation must perform the following actions. If ExternalContext.getRequestCharacterEncoding() returns null, call calculateCharacterEncoding(javax.faces.context.FacesContext) and pass the result, if non-null, into the ExternalContext.setRequestCharacterEncoding(java.lang.String) method. If ExternalContext.getRequestCharacterEncoding() returns non-null take no action.

        Throws:
        FacesException - if a problem occurs setting the encoding, such as the UnsupportedEncodingException thrown by the underlying Servlet or Portlet technology when the encoding is not supported.

      • renderView

        public abstract void renderView(FacesContext context,
              UIViewRoot viewToRender)
                         throws IOException,
                                FacesException

        Perform whatever actions are required to render the response view to the response object associated with the current FacesContext.

        Otherwise, the default implementation must obtain a reference to the ViewDeclarationLanguage for the viewId of the argument viewToRender and call its ViewDeclarationLanguage.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) method, returning the result and not swallowing any exceptions thrown by that method.

        Parameters:
        context - FacesContext for the current request
        viewToRender - the view to render
        Throws:
        IOException - if an input/output error occurs
        NullPointerException - if context or viewToRender is null
        FacesException - if a servlet error occurs

      • restoreView

        public abstract UIViewRoot restoreView(FacesContext context,
                     String viewId)

        Perform whatever actions are required to restore the view associated with the specified FacesContext and viewId. It may delegate to the restoreView of the associated StateManager to do the actual work of restoring the view. If there is no available state for the specified viewId, return null.

        Otherwise, the default implementation must obtain a reference to the ViewDeclarationLanguage for this viewId and call its ViewDeclarationLanguage.restoreView(javax.faces.context.FacesContext, java.lang.String) method, returning the result and not swallowing any exceptions thrown by that method.

        Parameters:
        context - FacesContext for the current request
        viewId - the view identifier for the current request
        Throws:
        NullPointerException - if context is null
        FacesException - if a servlet error occurs

      • writeState

        public abstract void writeState(FacesContext context)
                         throws IOException

        Take any appropriate action to either immediately write out the current state information (by calling StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object), or noting where state information should later be written.

        This method must do nothing if the current request is an Ajax request. When responding to Ajax requests, the state is obtained by calling StateManager.getViewState(javax.faces.context.FacesContext) and then written into the Ajax response during final encoding (UIViewRoot.encodeEnd(javax.faces.context.FacesContext).

        Parameters:
        context - FacesContext for the current request
        Throws:
        IOException - if an input/output error occurs
        NullPointerException - if context is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ViewHandlerWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ViewHandlerWrapper

  • java.lang.Object
    • javax.faces.application.ViewHandler
      • javax.faces.application.ViewHandlerWrapper
  • All Implemented Interfaces:
    FacesWrapper<ViewHandler>

    public abstract class ViewHandlerWrapper
extends ViewHandler
implements FacesWrapper<ViewHandler>

    Provides a simple implementation of ViewHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ViewHandler instance. The default implementation of all methods is to call through to the wrapped ViewHandler.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    1.2

    • Field Summary

      • Fields inherited from class javax.faces.application.ViewHandler

        CHARACTER_ENCODING_KEY, DEFAULT_FACELETS_SUFFIX, DEFAULT_SUFFIX, DEFAULT_SUFFIX_PARAM_NAME, DISABLE_FACELET_JSF_VIEWHANDLER_PARAM_NAME, FACELETS_BUFFER_SIZE_PARAM_NAME, FACELETS_DECORATORS_PARAM_NAME, FACELETS_LIBRARIES_PARAM_NAME, FACELETS_REFRESH_PERIOD_PARAM_NAME, FACELETS_SKIP_COMMENTS_PARAM_NAME, FACELETS_SUFFIX_PARAM_NAME, FACELETS_VIEW_MAPPINGS_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      ViewHandlerWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addProtectedView(String urlPattern)
      The default behavior of this method is to call ViewHandler.addProtectedView(java.lang.String) on the wrapped ViewHandler object.
      String calculateCharacterEncoding(FacesContext context)
      The default behavior of this method is to call ViewHandler.calculateCharacterEncoding(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
      Locale calculateLocale(FacesContext context)
      The default behavior of this method is to call ViewHandler.calculateLocale(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
      String calculateRenderKitId(FacesContext context)
      The default behavior of this method is to call ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
      UIViewRoot createView(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.createView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      String deriveLogicalViewId(FacesContext context, String input)

      The default behavior of this method is to call ViewHandler.deriveLogicalViewId(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      String deriveViewId(FacesContext context, String input)
      The default behavior of this method is to call ViewHandler.deriveViewId(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      String getActionURL(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.getActionURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      String getBookmarkableURL(FacesContext context, String viewId, Map<String,List<String>> parameters, boolean includeViewParams)
      The default behavior of this method is to call ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, String, java.util.Map, boolean) on the wrapped ViewHandler object.
      Set<String> getProtectedViewsUnmodifiable()
      The default behavior of this method is to call ViewHandler.getProtectedViewsUnmodifiable() on the wrapped ViewHandler object.
      String getRedirectURL(FacesContext context, String viewId, Map<String,List<String>> parameters, boolean includeViewParams)
      The default behavior of this method is to call ViewHandler.getRedirectURL(javax.faces.context.FacesContext, String, java.util.Map, boolean) on the wrapped ViewHandler object.
      String getResourceURL(FacesContext context, String path)
      The default behavior of this method is to call ViewHandler.getResourceURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      ViewDeclarationLanguage getViewDeclarationLanguage(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.getViewDeclarationLanguage(javax.faces.context.FacesContext, java.lang.String) on the wrapped ViewHandler object.
      abstract ViewHandler getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void initView(FacesContext context)
      The default behavior of this method is to call ViewHandler.initView(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
      boolean removeProtectedView(String urlPattern)
      The default behavior of this method is to call ViewHandler.removeProtectedView(java.lang.String) on the wrapped ViewHandler object.
      void renderView(FacesContext context, UIViewRoot viewToRender)
      The default behavior of this method is to call ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) on the wrapped ViewHandler object.
      UIViewRoot restoreView(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.restoreView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      void writeState(FacesContext context)
      The default behavior of this method is to call ViewHandler.writeState(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ViewHandlerWrapper

        public ViewHandlerWrapper()

    • Method Detail

      • getWrapped

        public abstract ViewHandler getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<ViewHandler>
        Returns:
        the instance that we are wrapping.

      • calculateCharacterEncoding

        public String calculateCharacterEncoding(FacesContext context)

        The default behavior of this method is to call ViewHandler.calculateCharacterEncoding(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

        Overrides:
        calculateCharacterEncoding in class ViewHandler
        Since:
        1.2
        See Also:
        ViewHandler.calculateCharacterEncoding(javax.faces.context.FacesContext)

      • calculateLocale

        public Locale calculateLocale(FacesContext context)

        The default behavior of this method is to call ViewHandler.calculateLocale(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

        Specified by:
        calculateLocale in class ViewHandler
        Parameters:
        context - FacesContext for the current request
        Since:
        1.2
        See Also:
        ViewHandler.calculateLocale(javax.faces.context.FacesContext)

      • deriveViewId

        public String deriveViewId(FacesContext context,
                  String input)

        The default behavior of this method is to call ViewHandler.deriveViewId(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

        Overrides:
        deriveViewId in class ViewHandler
        Parameters:
        context - the FacesContext for this request
        input - the viewId to derive,
        Since:
        2.0
        See Also:
        ViewHandler.deriveViewId(javax.faces.context.FacesContext, String)

      • deriveLogicalViewId

        public String deriveLogicalViewId(FacesContext context,
                         String input)

        The default behavior of this method is to call ViewHandler.deriveLogicalViewId(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

        Overrides:
        deriveLogicalViewId in class ViewHandler
        Parameters:
        context - the FacesContext for this request
        input - the viewId to derive,
        Since:
        2.1
        See Also:
        ViewHandler.deriveLogicalViewId(javax.faces.context.FacesContext, String)

      • calculateRenderKitId

        public String calculateRenderKitId(FacesContext context)

        The default behavior of this method is to call ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

        Specified by:
        calculateRenderKitId in class ViewHandler
        Parameters:
        context - FacesContext for the current request
        Since:
        1.2
        See Also:
        ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext)

      • createView

        public UIViewRoot createView(FacesContext context,
                    String viewId)

        The default behavior of this method is to call ViewHandler.createView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

        Specified by:
        createView in class ViewHandler
        Since:
        1.2
        See Also:
        ViewHandler.createView(javax.faces.context.FacesContext, String)

      • getActionURL

        public String getActionURL(FacesContext context,
                  String viewId)

        The default behavior of this method is to call ViewHandler.getActionURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

        Specified by:
        getActionURL in class ViewHandler
        Parameters:
        context - FacesContext for this request
        viewId - View identifier of the desired view
        Since:
        1.2
        See Also:
        ViewHandler.getActionURL(javax.faces.context.FacesContext, String)

      • getProtectedViewsUnmodifiable

        public Set<String> getProtectedViewsUnmodifiable()

        The default behavior of this method is to call ViewHandler.getProtectedViewsUnmodifiable() on the wrapped ViewHandler object.

        Overrides:
        getProtectedViewsUnmodifiable in class ViewHandler
        Since:
        2.2
        See Also:
        ViewHandler.getProtectedViewsUnmodifiable()

      • addProtectedView

        public void addProtectedView(String urlPattern)

        The default behavior of this method is to call ViewHandler.addProtectedView(java.lang.String) on the wrapped ViewHandler object.

        Overrides:
        addProtectedView in class ViewHandler
        Parameters:
        urlPattern - the url-pattern to add.
        Since:
        2.2
        See Also:
        ViewHandler.addProtectedView(java.lang.String)

      • removeProtectedView

        public boolean removeProtectedView(String urlPattern)

        The default behavior of this method is to call ViewHandler.removeProtectedView(java.lang.String) on the wrapped ViewHandler object.

        Overrides:
        removeProtectedView in class ViewHandler
        Parameters:
        urlPattern - the url-pattern to remove.
        Since:
        2.2
        See Also:
        ViewHandler.removeProtectedView(java.lang.String)

      • getRedirectURL

        public String getRedirectURL(FacesContext context,
                    String viewId,
                    Map<String,List<String>> parameters,
                    boolean includeViewParams)

        The default behavior of this method is to call ViewHandler.getRedirectURL(javax.faces.context.FacesContext, String, java.util.Map, boolean) on the wrapped ViewHandler object.

        Overrides:
        getRedirectURL in class ViewHandler
        Parameters:
        context - The FacesContext processing this request
        viewId - The view identifier of the target page
        parameters - A mapping of parameter names to one or more values
        includeViewParams - A flag indicating whether view parameters should be encoded into this URL
        Since:
        2.0
        See Also:
        ViewHandler.getRedirectURL(javax.faces.context.FacesContext, String, java.util.Map, boolean)

      • getBookmarkableURL

        public String getBookmarkableURL(FacesContext context,
                        String viewId,
                        Map<String,List<String>> parameters,
                        boolean includeViewParams)

        The default behavior of this method is to call ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, String, java.util.Map, boolean) on the wrapped ViewHandler object.

        Overrides:
        getBookmarkableURL in class ViewHandler
        Parameters:
        context - The FacesContext processing this request
        viewId - The view identifier of the target page
        parameters - A mapping of parameter names to one or more values
        includeViewParams - A flag indicating whether view parameters should be encoded into this URL
        Since:
        2.0
        See Also:
        ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, String, java.util.Map, boolean)

      • getResourceURL

        public String getResourceURL(FacesContext context,
                    String path)

        The default behavior of this method is to call ViewHandler.getResourceURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

        Specified by:
        getResourceURL in class ViewHandler
        Parameters:
        context - FacesContext for the current request
        path - Resource path to convert to a URL
        Since:
        1.2
        See Also:
        ViewHandler.getResourceURL(javax.faces.context.FacesContext, String)

      • getViewDeclarationLanguage

        public ViewDeclarationLanguage getViewDeclarationLanguage(FacesContext context,
                                                 String viewId)

        The default behavior of this method is to call ViewHandler.getViewDeclarationLanguage(javax.faces.context.FacesContext, java.lang.String) on the wrapped ViewHandler object.

        Overrides:
        getViewDeclarationLanguage in class ViewHandler
        Parameters:
        context - the FacesContext for this request.
        viewId - the logical view id, as returned from ViewHandler.deriveLogicalViewId(javax.faces.context.FacesContext, java.lang.String) for which the ViewDeclarationLanguage should be returned.
        Since:
        2.0

      • initView

        public void initView(FacesContext context)
              throws FacesException

        The default behavior of this method is to call ViewHandler.initView(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

        Overrides:
        initView in class ViewHandler
        Throws:
        FacesException - if a problem occurs setting the encoding, such as the UnsupportedEncodingException thrown by the underlying Servlet or Portlet technology when the encoding is not supported.
        Since:
        1.2
        See Also:
        ViewHandler.initView(javax.faces.context.FacesContext)

      • renderView

        public void renderView(FacesContext context,
              UIViewRoot viewToRender)
                throws IOException,
                       FacesException

        The default behavior of this method is to call ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) on the wrapped ViewHandler object.

        Specified by:
        renderView in class ViewHandler
        Parameters:
        context - FacesContext for the current request
        viewToRender - the view to render
        Throws:
        IOException - if an input/output error occurs
        FacesException - if a servlet error occurs
        Since:
        1.2
        See Also:
        ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot)

      • restoreView

        public UIViewRoot restoreView(FacesContext context,
                     String viewId)

        The default behavior of this method is to call ViewHandler.restoreView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

        Specified by:
        restoreView in class ViewHandler
        Parameters:
        context - FacesContext for the current request
        viewId - the view identifier for the current request
        Since:
        1.2
        See Also:
        ViewHandler.restoreView(javax.faces.context.FacesContext, String)

      • writeState

        public void writeState(FacesContext context)
                throws IOException

        The default behavior of this method is to call ViewHandler.writeState(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

        Specified by:
        writeState in class ViewHandler
        Parameters:
        context - FacesContext for the current request
        Throws:
        IOException - if an input/output error occurs
        Since:
        1.2
        See Also:
        ViewHandler.writeState(javax.faces.context.FacesContext)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ViewResource (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.application

Class ViewResource

  • java.lang.Object
    • javax.faces.application.ViewResource
  • Direct Known Subclasses:
    Resource

    public abstract class ViewResource
extends Object

    Superclass of Resource that is only for use with views.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      ViewResource()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract URL getURL()

      Return an actual URL instance that refers to this resource instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ViewResource

        public ViewResource()

    • Method Detail

      • getURL

        public abstract URL getURL()

        Return an actual URL instance that refers to this resource instance.

        Returns:
        Return an actual URL instance that refers to this resource instance.
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.faces.application.Application (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.Application

  • Packages that use Application
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of Application in javax.faces.application

      Subclasses of Application in javax.faces.application
      Modifier and Type Class and Description
      class  ApplicationWrapper

      Provides a simple implementation of Application that can be subclassed by developers wishing to provide specialized behavior to an existing Application instance.
      Methods in javax.faces.application that return Application
      Modifier and Type | Method and Description
      abstract Application ApplicationFactory.getApplication()
      Create (if needed) and return an Application instance for this web application.
      abstract Application | ApplicationWrapper.getWrapped()
      Methods in javax.faces.application with parameters of type Application
      Modifier and Type Method and Description
      abstract void ApplicationFactory.setApplication(Application application)
      Replace the Application instance that will be returned for this web application.

    • Uses of Application in javax.faces.context

      Methods in javax.faces.context that return Application
      Modifier and Type Method and Description
      Application FacesContextWrapper.getApplication()
      The default behavior of this method is to call FacesContext.getApplication() on the wrapped FacesContext object.
      abstract Application FacesContext.getApplication()
      Return the Application instance associated with this web application.

    • Uses of Application in javax.faces.event

      Methods in javax.faces.event that return Application
      Modifier and Type Method and Description
      Application PreDestroyApplicationEvent.getApplication()

      The source Application that sent this event.
      Application PostConstructApplicationEvent.getApplication()

      The source Application that sent this event.
      Constructors in javax.faces.event with parameters of type Application
      Constructor and Description
      PostConstructApplicationEvent(Application application)

      Constructs a new AppliationPostConstructEvent for this application.
      PreDestroyApplicationEvent(Application application)

      Constructs a new PreDestroyApplicationEvent for this application.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ApplicationConfigurationPopulator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ApplicationConfigurationPopulator

No usage of javax.faces.application.ApplicationConfigurationPopulator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ApplicationFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ApplicationFactory

  • Packages that use ApplicationFactory
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

    • Uses of ApplicationFactory in javax.faces.application

      Methods in javax.faces.application that return ApplicationFactory
      Modifier and Type Method and Description
      ApplicationFactory ApplicationFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ApplicationWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ApplicationWrapper

No usage of javax.faces.application.ApplicationWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ConfigurableNavigationHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ConfigurableNavigationHandler

  • Packages that use ConfigurableNavigationHandler
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

    • Uses of ConfigurableNavigationHandler in javax.faces.application

      Subclasses of ConfigurableNavigationHandler in javax.faces.application
      Modifier and Type Class and Description
      class  ConfigurableNavigationHandlerWrapper

      Provides a simple implementation of ConfigurableNavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ConfigurableNavigationHandler instance.
      Methods in javax.faces.application that return ConfigurableNavigationHandler
      Modifier and Type | Method and Description
      abstract ConfigurableNavigationHandler | ConfigurableNavigationHandlerWrapper.getWrapped()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ConfigurableNavigationHandlerWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ConfigurableNavigationHandlerWrapper

No usage of javax.faces.application.ConfigurableNavigationHandlerWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.FacesMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.FacesMessage

  • Packages that use FacesMessage
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.

    • Uses of FacesMessage in javax.faces.component

      Methods in javax.faces.component that return FacesMessage
      Modifier and Type Method and Description
      FacesMessage UpdateModelException.getFacesMessage()

      Return the FacesMessage passed to the constructor.
      Constructors in javax.faces.component with parameters of type FacesMessage
      Constructor and Description
      UpdateModelException(FacesMessage facesMessage, Throwable cause)

      Store the argument facesMessage so it may be returned from UpdateModelException.getFacesMessage() and pass the argument cause to the super constructor.

    • Uses of FacesMessage in javax.faces.context

      Methods in javax.faces.context that return types with arguments of type FacesMessage
      Modifier and Type Method and Description
      List<FacesMessage> FacesContextWrapper.getMessageList()
      The default behavior of this method is to call FacesContext.getMessageList() on the wrapped FacesContext object.
      List<FacesMessage> FacesContext.getMessageList()

      Like FacesContext.getMessages(), but returns a List<FacesMessage>, enabling use from EL expressions.
      List<FacesMessage> FacesContextWrapper.getMessageList(String clientId)
      The default behavior of this method is to call FacesContext.getMessageList(String) on the wrapped FacesContext object.
      List<FacesMessage> FacesContext.getMessageList(String clientId)

      Like FacesContext.getMessages(java.lang.String), but returns a List<FacesMessage> of messages for the component with client id matching argument clientId.
      Iterator<FacesMessage> FacesContextWrapper.getMessages()
      The default behavior of this method is to call FacesContext.getMessages() on the wrapped FacesContext object.
      abstract Iterator<FacesMessage> FacesContext.getMessages()
      Return an Iterator over the FacesMessages that have been queued, whether or not they are associated with any specific client identifier.
      Iterator<FacesMessage> FacesContextWrapper.getMessages(String clientId)
      The default behavior of this method is to call FacesContext.getMessages(String) on the wrapped FacesContext object.
      abstract Iterator<FacesMessage> FacesContext.getMessages(String clientId)
      Return an Iterator over the FacesMessages that have been queued that are associated with the specified client identifier (if clientId is not null), or over the FacesMessages that have been queued that are not associated with any specific client identifier (if clientId is null).
      Methods in javax.faces.context with parameters of type FacesMessage
      Modifier and Type Method and Description
      void FacesContextWrapper.addMessage(String clientId, FacesMessage message)
      The default behavior of this method is to call FacesContext.addMessage(String, FacesMessage) on the wrapped FacesContext object.
      abstract void FacesContext.addMessage(String clientId, FacesMessage message)
      Append a FacesMessage to the set of messages associated with the specified client identifier, if clientId is not null.

    • Uses of FacesMessage in javax.faces.convert

      Methods in javax.faces.convert that return FacesMessage
      Modifier and Type Method and Description
      FacesMessage ConverterException.getFacesMessage()
      Returns the FacesMessage associated with this exception; this will only be available if the converter that thew this exception instance placed it there.
      Constructors in javax.faces.convert with parameters of type FacesMessage
      Constructor and Description
      ConverterException(FacesMessage message)
      Construct a new exception with the specified detail message and no root cause.
      ConverterException(FacesMessage message, Throwable cause)
      Construct a new exception with the specified detail message and root cause.

    • Uses of FacesMessage in javax.faces.validator

      Methods in javax.faces.validator that return FacesMessage
      Modifier and Type Method and Description
      FacesMessage ValidatorException.getFacesMessage()

      Returns the FacesMessage associated with the exception.
      Methods in javax.faces.validator that return types with arguments of type FacesMessage
      Modifier and Type Method and Description
      Collection<FacesMessage> ValidatorException.getFacesMessages()

      If this instance was created with a constructor that takes Collection<FacesMessage>, this method returns the passed collection, otherwise this method returns null.
      Constructors in javax.faces.validator with parameters of type FacesMessage
      Constructor and Description
      ValidatorException(FacesMessage message)
      Construct a new exception with the specified message and no root cause.
      ValidatorException(FacesMessage message, Throwable cause)
      Construct a new exception with the specified detail message and root cause.
      Constructor parameters in javax.faces.validator with type arguments of type FacesMessage
      Constructor and Description
      ValidatorException(Collection<FacesMessage> messages)

      Allow this one exception to contain multiple messages.
      ValidatorException(Collection<FacesMessage> messages, Throwable cause)

      Allow this one exception to contain multiple messages, while passing on the root cause to the superclass
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.FacesMessage.Severity (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.FacesMessage.Severity

  • Packages that use FacesMessage.Severity
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of FacesMessage.Severity in javax.faces.application

      Fields in javax.faces.application declared as FacesMessage.Severity
      Modifier and Type Field and Description
      static FacesMessage.Severity FacesMessage.SEVERITY_ERROR
      Message severity level indicating that an error has occurred.
      static FacesMessage.Severity FacesMessage.SEVERITY_FATAL
      Message severity level indicating that a serious error has occurred.
      static FacesMessage.Severity FacesMessage.SEVERITY_INFO
      Message severity level indicating an informational message rather than an error.
      static FacesMessage.Severity FacesMessage.SEVERITY_WARN
      Message severity level indicating that an error might have occurred.
      Methods in javax.faces.application that return FacesMessage.Severity
      Modifier and Type Method and Description
      FacesMessage.Severity FacesMessage.getSeverity()
      Return the severity level.
      Methods in javax.faces.application with parameters of type FacesMessage.Severity
      Modifier and Type Method and Description
      void FacesMessage.setSeverity(FacesMessage.Severity severity)
      Set the severity level.
      Constructors in javax.faces.application with parameters of type FacesMessage.Severity
      Constructor and Description
      FacesMessage(FacesMessage.Severity severity, String summary, String detail)
      Construct a new FacesMessage with the specified initial values.

    • Uses of FacesMessage.Severity in javax.faces.context

      Methods in javax.faces.context that return FacesMessage.Severity
      Modifier and Type Method and Description
      FacesMessage.Severity FacesContextWrapper.getMaximumSeverity()
      The default behavior of this method is to call FacesContext.getMaximumSeverity() on the wrapped FacesContext object.
      abstract FacesMessage.Severity FacesContext.getMaximumSeverity()
      Return the maximum severity level recorded on any FacesMessages that has been queued, whether or not they are associated with any specific UIComponent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.NavigationCase (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.NavigationCase

  • Packages that use NavigationCase
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.flow

    The runtime API for Faces Flows.

    • Uses of NavigationCase in javax.faces.application

      Subclasses of NavigationCase in javax.faces.application
      Modifier and Type Class and Description
      class  NavigationCaseWrapper

      Provides a simple implementation of NavigationCase that can be subclassed by developers wishing to provide specialized behavior to an existing NavigationCase instance.
      Methods in javax.faces.application that return NavigationCase
      Modifier and Type | Method and Description
      NavigationCase | ConfigurableNavigationHandlerWrapper.getNavigationCase(FacesContext context, String fromAction, String outcome)
      abstract NavigationCase ConfigurableNavigationHandler.getNavigationCase(FacesContext context, String fromAction, String outcome)

      Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.
      NavigationCase | ConfigurableNavigationHandlerWrapper.getNavigationCase(FacesContext context, String fromAction, String outcome, String toFlowDocumentId)
      NavigationCase ConfigurableNavigationHandler.getNavigationCase(FacesContext context, String fromAction, String outcome, String toFlowDocumentId)

      Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.
      abstract NavigationCase | NavigationCaseWrapper.getWrapped()
      Methods in javax.faces.application that return types with arguments of type NavigationCase
      Modifier and Type | Method and Description
      Map<String,Set<NavigationCase>> | ConfigurableNavigationHandlerWrapper.getNavigationCases()
      abstract Map<String,Set<NavigationCase>> ConfigurableNavigationHandler.getNavigationCases()

      Return a Map<String, Set<NavigationCase>> where the keys are <from-view-id> values and the values are Set<NavigationCase> where each element in the Set is a NavigationCase that applies to that <from-view-id>.

    • Uses of NavigationCase in javax.faces.flow

      Methods in javax.faces.flow that return types with arguments of type NavigationCase
      Modifier and Type | Method and Description
      abstract Map<String,Set<NavigationCase>> | Flow.getNavigationCases()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.NavigationCaseWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.NavigationCaseWrapper

No usage of javax.faces.application.NavigationCaseWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.NavigationHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.NavigationHandler

  • Packages that use NavigationHandler
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

    • Uses of NavigationHandler in javax.faces.application

      Subclasses of NavigationHandler in javax.faces.application
      Modifier and Type Class and Description
      class  ConfigurableNavigationHandler

      ConfigurableNavigationHandler extends the contract of NavigationHandler to allow runtime inspection of the NavigationCases that make up the rule-base for navigation.
      class  ConfigurableNavigationHandlerWrapper

      Provides a simple implementation of ConfigurableNavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ConfigurableNavigationHandler instance.
      class  NavigationHandlerWrapper

      NavigationHandlerWrapper provides a simple implementation of NavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing NavigationHandler instance.
      Methods in javax.faces.application that return NavigationHandler
      Modifier and Type | Method and Description
      NavigationHandler ApplicationWrapper.getNavigationHandler()

      The default behavior of this method is to call Application.getNavigationHandler() on the wrapped Application object.
      abstract NavigationHandler Application.getNavigationHandler()
      Return the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.
      abstract NavigationHandler | NavigationHandlerWrapper.getWrapped()
      Methods in javax.faces.application with parameters of type NavigationHandler
      Modifier and Type Method and Description
      void ApplicationWrapper.setNavigationHandler(NavigationHandler handler)

      The default behavior of this method is to call Application.setNavigationHandler(NavigationHandler) on the wrapped Application object.
      abstract void Application.setNavigationHandler(NavigationHandler handler)
      Set the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.NavigationHandlerWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.NavigationHandlerWrapper

No usage of javax.faces.application.NavigationHandlerWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ProjectStage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ProjectStage

  • Packages that use ProjectStage
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of ProjectStage in javax.faces.application

      Methods in javax.faces.application that return ProjectStage
      Modifier and Type Method and Description
      ProjectStage ApplicationWrapper.getProjectStage()

      The default behavior of this method is to call Application.getProjectStage() on the wrapped Application object.
      ProjectStage Application.getProjectStage()

      Return the project stage for the currently running application instance.
      static ProjectStage ProjectStage.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ProjectStage[] ProjectStage.values()
      Returns an array containing the constants of this enum type, in the order they are declared.

    • Uses of ProjectStage in javax.faces.context

      Methods in javax.faces.context with parameters of type ProjectStage
      Modifier and Type Method and Description
      boolean FacesContextWrapper.isProjectStage(ProjectStage stage)
      The default behavior of this method is to call FacesContext.isProjectStage(javax.faces.application.ProjectStage) on the wrapped FacesContext object.
      boolean FacesContext.isProjectStage(ProjectStage stage)

      Return true if the current ProjectStage as returned by the Application instance is equal to stage, otherwise return false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ProtectedViewException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ProtectedViewException

No usage of javax.faces.application.ProtectedViewException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.Resource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.Resource

  • Packages that use Resource
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

    • Uses of Resource in javax.faces.application

      Subclasses of Resource in javax.faces.application
      Modifier and Type Class and Description
      class  ResourceWrapper

      Provides a simple implementation of Resource that can be subclassed by developers wishing to provide specialized behavior to an existing Resource instance.
      Methods in javax.faces.application that return Resource
      Modifier and Type | Method and Description
      Resource ResourceHandlerWrapper.createResource(String resourceName)

      The default behavior of this method is to call ResourceHandler.createResource(String) on the wrapped ResourceHandler object.
      abstract Resource ResourceHandler.createResource(String resourceName)

      Create an instance of ViewResource given the argument resourceName.
      Resource ResourceHandlerWrapper.createResource(String resourceName, String libraryName)

      The default behavior of this method is to call ResourceHandler.createResource(String, String) on the wrapped ResourceHandler object.
      abstract Resource ResourceHandler.createResource(String resourceName, String libraryOrContractName)

      Create an instance of Resource with a resourceName given by the value of the argument resourceName that is a member of the library named by the argument libraryName.
      Resource ResourceHandlerWrapper.createResource(String resourceName, String libraryName, String contentType)

      The default behavior of this method is to call ResourceHandler.createResource(String, String, String) on the wrapped ResourceHandler object.
      abstract Resource ResourceHandler.createResource(String resourceName, String libraryName, String contentType)

      Create an instance of Resource with a resourceName given by the value of the argument resourceName that is a member of the library named by the argument libraryName that claims to have the content-type given by the argument content-type.
      Resource ResourceHandlerWrapper.createResourceFromId(String resourceId)

      The default behavior of this method is to call ResourceHandler.createResourceFromId(String) on the wrapped ResourceHandler object.
      Resource ResourceHandler.createResourceFromId(String resourceId)

      Create an instance of Resource given the argument resourceId.
      abstract Resource | ResourceWrapper.getWrapped()
      Methods in javax.faces.application with parameters of type Resource
      Modifier and Type Method and Description
      UIComponent ApplicationWrapper.createComponent(FacesContext context, Resource componentResource)

      The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, Resource) on the wrapped Application object.
      UIComponent Application.createComponent(FacesContext context, Resource componentResource)

      Instantiate and return a new UIComponent instance from the argument Resource.

    • Uses of Resource in javax.faces.view

      Methods in javax.faces.view that return Resource
      Modifier and Type | Method and Description
      Resource | ViewDeclarationLanguageWrapper.getScriptComponentResource(FacesContext context, Resource componentResource)
      abstract Resource ViewDeclarationLanguage.getScriptComponentResource(FacesContext context, Resource componentResource)

      Take implementation specific action to discover a Resource given the argument componentResource.
      Methods in javax.faces.view with parameters of type Resource
      Modifier and Type | Method and Description
      BeanInfo | ViewDeclarationLanguageWrapper.getComponentMetadata(FacesContext context, Resource componentResource)
      abstract BeanInfo ViewDeclarationLanguage.getComponentMetadata(FacesContext context, Resource componentResource)

      Return a reference to the component metadata for the composite component represented by the argument componentResource, or null if the metadata cannot be found.
      Resource | ViewDeclarationLanguageWrapper.getScriptComponentResource(FacesContext context, Resource componentResource)
      abstract Resource ViewDeclarationLanguage.getScriptComponentResource(FacesContext context, Resource componentResource)

      Take implementation specific action to discover a Resource given the argument componentResource.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ResourceDependencies (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ResourceDependencies

No usage of javax.faces.application.ResourceDependencies
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ResourceDependency (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ResourceDependency

No usage of javax.faces.application.ResourceDependency
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ResourceHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ResourceHandler

  • Packages that use ResourceHandler
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

    • Uses of ResourceHandler in javax.faces.application

      Subclasses of ResourceHandler in javax.faces.application
      Modifier and Type Class and Description
      class  ResourceHandlerWrapper

      Provides a simple implementation of ResourceHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ResourceHandler instance.
      Methods in javax.faces.application that return ResourceHandler
      Modifier and Type | Method and Description
      ResourceHandler ApplicationWrapper.getResourceHandler()

      The default behavior of this method is to call Application.getResourceHandler() on the wrapped Application object.
      ResourceHandler Application.getResourceHandler()

      Return the singleton, stateless, thread-safe ResourceHandler for this application.
      abstract ResourceHandler | ResourceHandlerWrapper.getWrapped()
      Methods in javax.faces.application with parameters of type ResourceHandler
      Modifier and Type Method and Description
      void ApplicationWrapper.setResourceHandler(ResourceHandler resourceHandler)

      The default behavior of this method is to call Application.setResourceHandler(ResourceHandler) on the wrapped Application object.
      void Application.setResourceHandler(ResourceHandler resourceHandler)

      Set the ResourceHandler instance that will be utilized for rendering the markup for resources, and for satisfying client requests to serve up resources.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ResourceHandlerWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ResourceHandlerWrapper

No usage of javax.faces.application.ResourceHandlerWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ResourceWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ResourceWrapper

No usage of javax.faces.application.ResourceWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.StateManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.StateManager

  • Packages that use StateManager
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

    • Uses of StateManager in javax.faces.application

      Subclasses of StateManager in javax.faces.application
      Modifier and Type Class and Description
      class  StateManagerWrapper
      Provides a simple implementation of StateManager that can be subclassed by developers wishing to provide specialized behavior to an existing StateManager instance.
      Methods in javax.faces.application that return StateManager
      Modifier and Type | Method and Description
      StateManager ApplicationWrapper.getStateManager()

      The default behavior of this method is to call Application.getStateManager() on the wrapped Application object.
      abstract StateManager Application.getStateManager()
      Return the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
      abstract StateManager | StateManagerWrapper.getWrapped()
      Methods in javax.faces.application with parameters of type StateManager
      Modifier and Type Method and Description
      void ApplicationWrapper.setStateManager(StateManager manager)

      The default behavior of this method is to call Application.setStateManager(StateManager) on the wrapped Application object.
      abstract void Application.setStateManager(StateManager manager)
      Set the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.StateManager.SerializedView (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.StateManager.SerializedView

  • Packages that use StateManager.SerializedView
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of StateManager.SerializedView in javax.faces.application

      Methods in javax.faces.application that return StateManager.SerializedView
      Modifier and Type Method and Description
      StateManager.SerializedView StateManagerWrapper.saveSerializedView(FacesContext context)
      The default behavior of this method is to call StateManager.saveSerializedView(javax.faces.context.FacesContext) on the wrapped StateManager object.
      StateManager.SerializedView StateManager.saveSerializedView(FacesContext context)
      Deprecated.
      this has been replaced by StateManager.saveView(javax.faces.context.FacesContext). The default implementation calls saveView and inspects the return. If the return is an Object [], it casts the result to an Object [] wrapping the first and second elements in an instance of StateManager.SerializedView, which it then returns. Otherwise, it returns null
      Methods in javax.faces.application with parameters of type StateManager.SerializedView
      Modifier and Type Method and Description
      void StateManagerWrapper.writeState(FacesContext context, StateManager.SerializedView state)
      The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView) on the wrapped StateManager object.
      void StateManager.writeState(FacesContext context, StateManager.SerializedView state)
      Deprecated.
      This method has been replaced by StateManager.writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation calls the non-deprecated variant of the method passing an Object [] as the second argument, where the first element of the array is the return from getStructure() and the second is the return from getState() on the argument state.

    • Uses of StateManager.SerializedView in javax.faces.render

      Methods in javax.faces.render with parameters of type StateManager.SerializedView
      Modifier and Type Method and Description
      void ResponseStateManager.writeState(FacesContext context, StateManager.SerializedView state)
      Deprecated.
      This method has been replaced by ResponseStateManager.writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation creates a two element Object array with the first element being the return from calling getStructure(), and the second being the return from getState(). It then passes this Object array to ResponseStateManager.writeState(javax.faces.context.FacesContext, java.lang.Object).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.StateManagerWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.StateManagerWrapper

No usage of javax.faces.application.StateManagerWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ViewExpiredException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ViewExpiredException

No usage of javax.faces.application.ViewExpiredException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ViewHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ViewHandler

  • Packages that use ViewHandler
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

    • Uses of ViewHandler in javax.faces.application

      Subclasses of ViewHandler in javax.faces.application
      Modifier and Type Class and Description
      class  ViewHandlerWrapper

      Provides a simple implementation of ViewHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ViewHandler instance.
      Methods in javax.faces.application that return ViewHandler
      Modifier and Type | Method and Description
      ViewHandler ApplicationWrapper.getViewHandler()

      The default behavior of this method is to call Application.getViewHandler() on the wrapped Application object.
      abstract ViewHandler Application.getViewHandler()
      Return the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
      abstract ViewHandler | ViewHandlerWrapper.getWrapped()
      Methods in javax.faces.application with parameters of type ViewHandler
      Modifier and Type Method and Description
      void ApplicationWrapper.setViewHandler(ViewHandler handler)

      The default behavior of this method is to call Application.setViewHandler(ViewHandler) on the wrapped Application object.
      abstract void Application.setViewHandler(ViewHandler handler)
      Set the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ViewHandlerWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ViewHandlerWrapper

No usage of javax.faces.application.ViewHandlerWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.application.ViewResource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.application.ViewResource

  • Packages that use ViewResource
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

    • Uses of ViewResource in javax.faces.application

      Subclasses of ViewResource in javax.faces.application
      Modifier and Type Class and Description
      class  Resource

      An instance of Resource is a Java object representation of the artifact that is served up in response to a resource request from the client.
      class  ResourceWrapper

      Provides a simple implementation of Resource that can be subclassed by developers wishing to provide specialized behavior to an existing Resource instance.
      Methods in javax.faces.application that return ViewResource
      Modifier and Type Method and Description
      ViewResource ResourceHandlerWrapper.createViewResource(FacesContext context, String resourceName)

      The default behavior of this method is to call ResourceHandler.createViewResource(javax.faces.context.FacesContext, java.lang.String) on the wrapped ResourceHandler object.
      ViewResource ResourceHandler.createViewResource(FacesContext context, String resourceName)

      Create an instance of Resource given the argument resourceName, which may contain "/" characters.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ApplicationScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.bean

Annotation Type ApplicationScoped

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface ApplicationScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>application<managed-bean-scope> element was declared for the corresponding managed bean.

    Since:
    2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


CustomScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.bean

Annotation Type CustomScoped

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface CustomScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>VALUE<managed-bean-scope> element was declared for the corresponding managed bean, where VALUE is the value of the value() attribute, which must be an EL expression that evaluates to a Map.

    Developers must take care when using custom scopes to ensure that any object references made to or from a custom scoped bean consider the necessary scope lifetimes. The runtime is not required to perform any validations for such considerations.

    Since:
    2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value

    • Element Detail

      • value

        public abstract String value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.faces.bean (Java(TM) EE 7 Specification APIs)

javax.faces.bean

Annotation Types

  • ApplicationScoped
  • CustomScoped
  • ManagedBean
  • ManagedProperty
  • NoneScoped
  • ReferencedBean
  • RequestScoped
  • SessionScoped
  • ViewScoped


javax.faces.bean (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.bean

These javadoc files constitute the “Faces Managed Bean Annotation Specification for Containers Conforming to Servlet 2.5 and Beyond”

See: Description

  • Annotation Types Summary
    Annotation Type Description
    ApplicationScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>application<managed-bean-scope> element was declared for the corresponding managed bean.
    CustomScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>VALUE<managed-bean-scope> element was declared for the corresponding managed bean, where VALUE is the value of the CustomScoped.value() attribute, which must be an EL expression that evaluates to a Map.
    ManagedBean

    The presence of this annotation on a class automatically registers the class with the runtime as a managed bean class.
    ManagedProperty

    The presence of this annotation on a field of a class annotated with ManagedBean instructs the system to inject a value into this property as described in section JSF.5.3 of the spec prose document in the <managed-property> subsection.
    NoneScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>none<managed-bean-scope> element was declared for the corresponding managed bean.
    ReferencedBean

    The presence of this annotation on a class is equivalent to the referenced-bean element in the application configuration resources.
    RequestScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>request<managed-bean-scope> element was declared for the corresponding managed bean.
    SessionScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>session<managed-bean-scope> element was declared for the corresponding managed bean.
    ViewScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>view<managed-bean-scope> element was declared for the corresponding managed bean.

Package javax.faces.bean Description

These javadoc files constitute the “Faces Managed Bean Annotation Specification for Containers Conforming to Servlet 2.5 and Beyond”

At the time of this writing, a forthcoming JCP effort is being planned to extract the specification for managed beans from JSF and place it into its own specification. To account for this effort and to avoid introducing classes into JSF 2.0 that would have to be deprecated when this effort is complete, implementations of JSF 2.0 are not required to implement the “Faces Managed Bean Annotation Specification for Containers Conforming to Servlet 2.5”. However, JSF implementations are strongly encouraged to implement this specification, as it provides significant improvements in ease of use.

The annotations must be processed as specified in section JSF.11.5.1.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.bean Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.bean

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.faces.bean.ViewScoped (implements java.lang.annotation.Annotation)
  • javax.faces.bean.SessionScoped (implements java.lang.annotation.Annotation)
  • javax.faces.bean.RequestScoped (implements java.lang.annotation.Annotation)
  • javax.faces.bean.ReferencedBean (implements java.lang.annotation.Annotation)
  • javax.faces.bean.NoneScoped (implements java.lang.annotation.Annotation)
  • javax.faces.bean.ManagedProperty (implements java.lang.annotation.Annotation)
  • javax.faces.bean.ManagedBean (implements java.lang.annotation.Annotation)
  • javax.faces.bean.CustomScoped (implements java.lang.annotation.Annotation)
  • javax.faces.bean.ApplicationScoped (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ManagedBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.bean

Annotation Type ManagedBean

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface ManagedBean

    The presence of this annotation on a class automatically registers the class with the runtime as a managed bean class. Classes must be scanned for the presence of this annotation at application startup, before any requests have been serviced.

    The value of the name() attribute is taken to be the managed-bean-name. If the value of the name attribute is unspecified or is the empty String, the managed-bean-name is derived from taking the unqualified class name portion of the fully qualified class name and converting the first character to lower case. For example, if the ManagedBean annotation is on a class with the fully qualified class name com.foo.Bean, and there is no name attribute on the annotation, the managed-bean-name is taken to be bean. The fully qualified class name of the class to which this annotation is attached is taken to be the managed-bean-class.

    The scope of the managed bean is declared using one of NoneScoped, RequestScoped, ViewScoped, SessionScoped, ApplicationScoped, or CustomScoped annotations. If the scope annotations are omitted, the bean must be handled as if the RequestScoped annotation is present.

    If the value of the eager() attribute is true, and the managed-bean-scope value is "application", the runtime must instantiate this class when the application starts. This instantiation and storing of the instance must happen before any requests are serviced. If eager is unspecified or false, or the managed-bean-scope is something other than "application", the default "lazy" instantiation and scoped storage of the managed bean happens.

    When the runtime processes this annotation, if a managed bean exists whose name is equal to the derived managed-bean-name, a FacesException must be thrown and the application must not be placed in service.

    A class tagged with this annotation must have a public zero-argument constructor. If such a constructor is not defined on the class, a FacesException must be thrown and the application must not be placed in service.

    Since:
    2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean eager

      Taken to be the value of the eager attribute of the managed-bean.
      String name

      Taken to be the managed-bean-name.

    • Element Detail

      • name

        public abstract String name

        Taken to be the managed-bean-name. See class documentation for details.

        Default:
        ""

      • eager

        public abstract boolean eager

        Taken to be the value of the eager attribute of the managed-bean. See class documentation for details.

        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ManagedProperty (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.bean

Annotation Type ManagedProperty

  • @Retention(value=RUNTIME)
@Target(value=FIELD)
public @interface ManagedProperty

    The presence of this annotation on a field of a class annotated with ManagedBean instructs the system to inject a value into this property as described in section JSF.5.3 of the spec prose document in the <managed-property> subsection. The time of instantiation is dictated by the value of the attributes on the usage of ManagedBean and by the application logic itself. The value of the value() attribute may be a literal String or a ValueExpression. If the latter, the expression must not be evaluated until the bean is instantiated. The value of the name attribute is taken to be the managed-property-name for this property. If not specified, the managed-property-name is taken to be the name of the field to which this is attribute is attached.

    If this annotation is present on a class that does not have the ManagedBean annotation, the implementation must take no action on this annotation.

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value

      Taken to be the value that is injected into the field.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name

      Taken to be the managed-property-name.

    • Element Detail

      • value

        public abstract String value

        Taken to be the value that is injected into the field. See class documentation for details.

      • name

        public abstract String name

        Taken to be the managed-property-name. See class documentation for details.

        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NoneScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.bean

Annotation Type NoneScoped

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface NoneScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>none<managed-bean-scope> element was declared for the corresponding managed bean.

    Since:
    2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ReferencedBean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.bean

Annotation Type ReferencedBean

  • @Retention(value=CLASS)
@Target(value=TYPE)
@Inherited
public @interface ReferencedBean

    The presence of this annotation on a class is equivalent to the referenced-bean element in the application configuration resources.

    Since:
    2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name

      Taken to be the referenced-bean-name.

    • Element Detail

      • name

        public abstract String name

        Taken to be the referenced-bean-name. See class documentation for ManagedBean for details.

        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


RequestScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.bean

Annotation Type RequestScoped

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface RequestScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>request<managed-bean-scope> element was declared for the corresponding managed bean.

    Since:
    2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


SessionScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.bean

Annotation Type SessionScoped

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface SessionScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>session<managed-bean-scope> element was declared for the corresponding managed bean.

    Since:
    2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.faces.bean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.bean

No usage of javax.faces.bean
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ViewScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.bean

Annotation Type ViewScoped

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface ViewScoped

    When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>view<managed-bean-scope> element was declared for the corresponding managed bean.

    If ProjectStage is not ProjectStage.Production, verify that the current UIViewRoot does not have its transient property set to true. If so, add a FacesMessage for the current viewId to the FacesContext stating @ViewScoped beans cannot work if the view is marked as transient. Also log a Level.WARNING message to the log. If ProjectStage is ProjectStage.Production, do not do this verification.

    The bean must be stored in the map returned from javax.faces.component.UIViewRoot.getViewMap(boolean).

    The runtime must ensure that any methods on the bean annotated with PostConstruct or PreDestroy are called when the scope begins and ends, respectively. Two circumstances can cause the scope to end.

    • FacesContext.setViewRoot() is called with the new UIViewRoot being different than the current one.

    • The session, that happened to be active when the bean was created, expires. If no session existed when the bean was created, then this circumstance does not apply.

    In the session expiration case, the runtime must ensure that FacesContext.getCurrentInstance() returns a valid instance if it is called during the processing of the @PreDestroy annotated method. The set of methods on FacesContext that are valid to call in this circumstance is identical to those documented as "valid to call this method during application startup or shutdown". On the ExternalContext returned from that FacesContext, all of the methods documented as "valid to call this method during application startup or shutdown" are valid to call. In addition, the method ExternalContext.getSessionMap() is also valid to call.

    The annotations in this package may be deprecated in a future version of this specification because they duplicate functionality provided by other specifications included in JavaEE. When possible, the corresponding annotations from the appropriate Java EE specification should be used in preference to these annotations. In this case, the corresponding annotation is javax.faces.view.ViewScoped. The functionality of this corresponding annotation is identical to this one, but it is implemented as a CDI custom scope.

    Since:
    2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.faces.bean.ApplicationScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.bean.ApplicationScoped

No usage of javax.faces.bean.ApplicationScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.bean.CustomScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.bean.CustomScoped

No usage of javax.faces.bean.CustomScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.bean.ManagedBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.bean.ManagedBean

No usage of javax.faces.bean.ManagedBean
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.bean.ManagedProperty (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.bean.ManagedProperty

No usage of javax.faces.bean.ManagedProperty
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.bean.NoneScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.bean.NoneScoped

No usage of javax.faces.bean.NoneScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.bean.ReferencedBean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.bean.ReferencedBean

No usage of javax.faces.bean.ReferencedBean
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.bean.RequestScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.bean.RequestScoped

No usage of javax.faces.bean.RequestScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.bean.SessionScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.bean.SessionScoped

No usage of javax.faces.bean.SessionScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.bean.ViewScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.bean.ViewScoped

No usage of javax.faces.bean.ViewScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.FacesException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.FacesException

  • Packages that use FacesException
    Package Description
    javax.faces
    Top level classes for the JavaServer(tm) Faces API.
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.el
    DEPRECATED Classes and interfaces for evaluating and processing reference expressions.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of FacesException in javax.faces

      Methods in javax.faces that throw FacesException
      Modifier and Type Method and Description
      static Object FactoryFinder.getFactory(String factoryName)
      Create (if necessary) and return a per-web-application instance of the appropriate implementation class for the specified JavaServer Faces factory class, based on the discovery algorithm described in the class description.
      static void FactoryFinder.releaseFactories()
      Release any references to factory instances associated with the class loader for the calling web application.

    • Uses of FacesException in javax.faces.application

      Subclasses of FacesException in javax.faces.application
      Modifier and Type Class and Description
      class  ProtectedViewException

      This exception is thrown by the runtime when a violation of the view protection mechanism is encountered.
      class  ViewExpiredException
      Implementations must throw this FacesException when attempting to restore the view StateManager.restoreView(javax.faces.context.FacesContext, String, String) results in failure on postback.
      Methods in javax.faces.application that throw FacesException
      Modifier and Type Method and Description
      Behavior ApplicationWrapper.createBehavior(String behaviorId)

      The default behavior of this method is to call Application.createBehavior(String) on the wrapped Application object.
      Behavior Application.createBehavior(String behaviorId)
      Instantiate and return a new Behavior instance of the class specified by a previous call to addBehavior() for the specified behavior id.
      UIComponent ApplicationWrapper.createComponent(String componentType)

      The default behavior of this method is to call Application.createComponent(String) on the wrapped Application object.
      abstract UIComponent Application.createComponent(String componentType)
      Instantiate and return a new UIComponent instance of the class specified by a previous call to addComponent() for the specified component type.
      UIComponent ApplicationWrapper.createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
      Deprecated.
      See superclass for alternative.
      abstract UIComponent Application.createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
      Deprecated.
      This has been replaced by Application.createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).
      UIComponent ApplicationWrapper.createComponent(ValueExpression componentExpression, FacesContext context, String componentType)

      The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String) on the wrapped Application object.
      UIComponent Application.createComponent(ValueExpression componentExpression, FacesContext context, String componentType)
      Call the getValue() method on the specified ValueExpression.
      Validator ApplicationWrapper.createValidator(String validatorId)

      The default behavior of this method is to call Application.createValidator(String) on the wrapped Application object.
      abstract Validator Application.createValidator(String validatorId)
      Instantiate and return a new Validator instance of the class specified by a previous call to addValidator() for the specified validator id.
      void ViewHandlerWrapper.initView(FacesContext context)
      The default behavior of this method is to call ViewHandler.initView(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
      void ViewHandler.initView(FacesContext context)
      Initialize the view for the request processing lifecycle.
      void ViewHandlerWrapper.renderView(FacesContext context, UIViewRoot viewToRender)
      The default behavior of this method is to call ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) on the wrapped ViewHandler object.
      abstract void ViewHandler.renderView(FacesContext context, UIViewRoot viewToRender)
      Perform whatever actions are required to render the response view to the response object associated with the current FacesContext.

    • Uses of FacesException in javax.faces.component

      Subclasses of FacesException in javax.faces.component
      Modifier and Type Class and Description
      class  UpdateModelException

      This exception indicates a failure to update the model and is created to wrap any exception that occurs during UIInput.updateModel(javax.faces.context.FacesContext).
      Methods in javax.faces.component that throw FacesException
      Modifier and Type Method and Description
      boolean UIData.invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Override behavior from UIComponentBase.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) to provide special care for positioning the data properly before finding the component and invoking the callback on it.
      boolean UIComponentBase.invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.
      boolean UIComponent.invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.

    • Uses of FacesException in javax.faces.context

      Methods in javax.faces.context that throw FacesException
      Modifier and Type Method and Description
      abstract ExternalContext ExternalContextFactory.getExternalContext(Object context, Object request, Object response)
      Create (if needed) and return an ExternalContext instance that is initialized for the processing of the specified request and response objects, for this web application.
      abstract FacesContext FacesContextFactory.getFacesContext(Object context, Object request, Object response, Lifecycle lifecycle)
      Create (if needed) and return a FacesContext instance that is initialized for the processing of the specified request and response objects, utilizing the specified Lifecycle instance, for this web application.
      void ExceptionHandlerWrapper.handle()
      The default behavior of this method is to call ExceptionHandler.handle() on the wrapped ExceptionHandler object.
      abstract void ExceptionHandler.handle()

      Take action to handle the Exception instances residing inside the ExceptionQueuedEvent instances that have been queued by calls to Application().publishEvent(ExceptionQueuedEvent.class, eventContext).

    • Uses of FacesException in javax.faces.convert

      Subclasses of FacesException in javax.faces.convert
      Modifier and Type Class and Description
      class  ConverterException
      ConverterException is an exception thrown by the getAsObject() or getAsText() method of a Converter, to indicate that the requested conversion cannot be performed.

    • Uses of FacesException in javax.faces.el

      Subclasses of FacesException in javax.faces.el
      Modifier and Type Class and Description
      class  EvaluationException
      Deprecated.
      This has been replaced by ELException.
      class  MethodNotFoundException
      Deprecated.
      This has been replaced by MethodNotFoundException.
      class  PropertyNotFoundException
      Deprecated.
      This has been replaced by PropertyNotFoundException.
      class  ReferenceSyntaxException
      Deprecated.
      This has been replaced by ELException.

    • Uses of FacesException in javax.faces.event

      Subclasses of FacesException in javax.faces.event
      Modifier and Type Class and Description
      class  AbortProcessingException
      An exception that may be thrown by event listeners to terminate the processing of the current event.

    • Uses of FacesException in javax.faces.lifecycle

      Methods in javax.faces.lifecycle that throw FacesException
      Modifier and Type | Method and Description
      void | LifecycleWrapper.execute(FacesContext context)
      abstract void Lifecycle.execute(FacesContext context)
      Execute all of the phases of the request processing lifecycle, up to but not including the Render Response phase, as described in the JavaServer Faces Specification, in the specified order.
      void | LifecycleWrapper.render(FacesContext context)
      abstract void Lifecycle.render(FacesContext context)
      Execute the Render Response phase of the request processing lifecycle, unless the responseComplete() method has been called on the FacesContext instance associated with the current request.

    • Uses of FacesException in javax.faces.validator

      Subclasses of FacesException in javax.faces.validator
      Modifier and Type Class and Description
      class  ValidatorException
      A ValidatorException is an exception thrown by the validate() method of a Validator to indicate that validation failed.

    • Uses of FacesException in javax.faces.view.facelets

      Subclasses of FacesException in javax.faces.view.facelets
      Modifier and Type Class and Description
      class  FaceletException

      An Exception from the Facelet implementation
      class  TagAttributeException

      An Exception caused by a TagAttribute
      class  TagException

      An Exception caused by a Tag
      Methods in javax.faces.view.facelets that throw FacesException
      Modifier and Type Method and Description
      void DelegatingMetaTagHandler.applyNextHandler(FaceletContext ctx, UIComponent c)

      Invoke the apply() method on this instance's TagHandler.nextHandler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.FactoryFinder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.FactoryFinder

No usage of javax.faces.FactoryFinder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.FacesWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.FacesWrapper

  • Packages that use FacesWrapper
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component.visit

    APIs for traversing a user interface component view.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.
    javax.faces.render
    Classes and interfaces defining the rendering model.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of FacesWrapper in javax.faces.application

      Classes in javax.faces.application that implement FacesWrapper
      Modifier and Type Class and Description
      class  ApplicationFactory
      ApplicationFactory is a factory object that creates (if needed) and returns Application instances.
      class  ApplicationWrapper

      Provides a simple implementation of Application that can be subclassed by developers wishing to provide specialized behavior to an existing Application instance.
      class  ConfigurableNavigationHandlerWrapper

      Provides a simple implementation of ConfigurableNavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ConfigurableNavigationHandler instance.
      class  NavigationCaseWrapper

      Provides a simple implementation of NavigationCase that can be subclassed by developers wishing to provide specialized behavior to an existing NavigationCase instance.
      class  NavigationHandlerWrapper

      NavigationHandlerWrapper provides a simple implementation of NavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing NavigationHandler instance.
      class  ResourceHandlerWrapper

      Provides a simple implementation of ResourceHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ResourceHandler instance.
      class  ResourceWrapper

      Provides a simple implementation of Resource that can be subclassed by developers wishing to provide specialized behavior to an existing Resource instance.
      class  StateManagerWrapper
      Provides a simple implementation of StateManager that can be subclassed by developers wishing to provide specialized behavior to an existing StateManager instance.
      class  ViewHandlerWrapper

      Provides a simple implementation of ViewHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ViewHandler instance.

    • Uses of FacesWrapper in javax.faces.component.visit

      Classes in javax.faces.component.visit that implement FacesWrapper
      Modifier and Type Class and Description
      class  VisitContextFactory

      Provide for separation of interface and implementation for the VisitContext contract.
      class  VisitContextWrapper

      Provides a simple implementation of VisitContext that can be subclassed by developers wishing to provide specialized behavior to an existing VisitContext instance.

    • Uses of FacesWrapper in javax.faces.context

      Classes in javax.faces.context that implement FacesWrapper
      Modifier and Type Class and Description
      class  ExceptionHandlerFactory

      ExceptionHandlerFactory is a factory object that creates (if needed) and returns a new ExceptionHandler instance.
      class  ExceptionHandlerWrapper
      Provides a simple implementation of ExceptionHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ExceptionHandler instance.
      class  ExternalContextFactory
      ExternalContextFactory is a factory object that creates (if needed) and returns new ExternalContext instances, initialized for the processing of the specified request and response objects.
      class  ExternalContextWrapper

      Provides a simple implementation of ExternalContext that can be subclassed by developers wishing to provide specialized behavior to an existing ExternalContext instance.
      class  FacesContextFactory
      FacesContextFactory is a factory object that creates (if needed) and returns new FacesContext instances, initialized for the processing of the specified request and response objects.
      class  FacesContextWrapper
      Provides a simple implementation of FacesContext that can be subclassed by developers wishing to provide specialized behavior to an existing FacesContext instance.
      class  FlashFactory
      FlashFactory is a factory object that creates (if needed) and returns Flash instances.
      class  FlashWrapper

      Provides a simple implementation of Flash that can be subclassed by developers wishing to provide specialized behavior to an existing Flash instance.
      class  PartialResponseWriter

      PartialResponseWriter decorates an existing ResponseWriter to support the generation of a partial response suitable for Ajax operations.
      class  PartialViewContextFactory

      PartialViewContextFactory is a factory object that creates (if needed) and returns new PartialViewContext instances.
      class  PartialViewContextWrapper

      Provides a simple implementation of PartialViewContext that can be subclassed by developers wishing to provide specialized behavior to an existing PartialViewContext instance.
      class  ResponseWriterWrapper
      Provides a simple implementation of ResponseWriter that can be subclassed by developers wishing to provide specialized behavior to an existing ResponseWriter instance.

    • Uses of FacesWrapper in javax.faces.event

      Classes in javax.faces.event that implement FacesWrapper
      Modifier and Type Class and Description
      class  ActionListenerWrapper

      Provides a simple implementation of ActionListener that can be subclassed by developers wishing to provide specialized behavior to an existing ActionListener instance.

    • Uses of FacesWrapper in javax.faces.flow

      Classes in javax.faces.flow that implement FacesWrapper
      Modifier and Type Class and Description
      class  FlowHandlerFactoryWrapper

      FlowHandlerFactoryWrapper provides a simple implementation of FlowHandlerFactory that can be subclassed by developers wishing to provide specialized behavior to an existing FlowHandlerFactory instance.

    • Uses of FacesWrapper in javax.faces.lifecycle

      Classes in javax.faces.lifecycle that implement FacesWrapper
      Modifier and Type Class and Description
      class  ClientWindowFactory

      Create ClientWindow instances based on the incoming request.
      class  ClientWindowWrapper

      Wrapper for ClientWindow
      class  LifecycleFactory
      LifecycleFactory is a factory object that creates (if needed) and returns Lifecycle instances.
      class  LifecycleWrapper

      Provides a simple implementation of Lifecycle that can be subclassed by developers wishing to provide specialized behavior to an existing Lifecycle instance.

    • Uses of FacesWrapper in javax.faces.render

      Classes in javax.faces.render that implement FacesWrapper
      Modifier and Type Class and Description
      class  RendererWrapper

      Provides a simple implementation of Renderer that can be subclassed by developers wishing to provide specialized behavior to an existing Renderer instance.
      class  RenderKitFactory
      RenderKitFactory is a factory object that registers and returns RenderKit instances.
      class  RenderKitWrapper

      Provides a simple implementation of RenderKit that can be subclassed by developers wishing to provide specialized behavior to an existing RenderKit instance.

    • Uses of FacesWrapper in javax.faces.view

      Classes in javax.faces.view that implement FacesWrapper
      Modifier and Type Class and Description
      class  ViewDeclarationLanguageFactory

      ViewDeclarationLanguageFactory is a factory object that creates (if needed) and returns a new ViewDeclarationLanguage instance based on the VDL found in a specific view.
      class  ViewDeclarationLanguageWrapper

      Provides a simple implementation of ViewDeclarationLanguage that can be subclassed by developers wishing to provide specialized behavior to an existing ViewDeclarationLanguage instance.

    • Uses of FacesWrapper in javax.faces.view.facelets

      Classes in javax.faces.view.facelets that implement FacesWrapper
      Modifier and Type Class and Description
      class  FaceletCacheFactory

      Allows customization of the implementation of FaceletCache.
      class  TagHandlerDelegateFactory

      Abstract factory for creating instances of TagHandlerDelegate.

    • Uses of FacesWrapper in javax.faces.webapp

      Classes in javax.faces.webapp that implement FacesWrapper
      Modifier and Type Class and Description
      class  PreJsf2ExceptionHandlerFactory

      This ExceptionHandlerFactory instance produces JSF 1.2 compatible ExceptionHandler instances.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ActionSource (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface ActionSource

  • All Known Subinterfaces:
    ActionSource2
    All Known Implementing Classes:
    HtmlCommandButton, HtmlCommandLink, UICommand, UIViewAction

    public interface ActionSource

    ActionSource is an interface that may be implemented by any concrete UIComponent that wishes to be a source of ActionEvents, including the ability to invoke application actions via the default ActionListener mechanism.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addActionListener(ActionListener listener)
      Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.
      MethodBinding getAction()
      Deprecated.
      This has been replaced by ActionSource2.getActionExpression().
      MethodBinding getActionListener()
      Deprecated.
      Use getActionListeners() instead.
      ActionListener[] getActionListeners()
      Return the set of registered ActionListeners for this ActionSource instance.
      boolean isImmediate()
      Return a flag indicating that the default ActionListener provided by the JavaServer Faces implementation should be executed immediately (that is, during Apply Request Values phase of the request processing lifecycle), rather than waiting until the Invoke Application phase.
      void removeActionListener(ActionListener listener)
      Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.
      void setAction(MethodBinding action)
      Deprecated.
      This has been replaced by ActionSource2.setActionExpression(javax.el.MethodExpression).
      void setActionListener(MethodBinding actionListener)
      Deprecated.
      This has been replaced by addActionListener(javax.faces.event.ActionListener).
      void setImmediate(boolean immediate)
      Set the "immediate execution" flag for this UIComponent.

    • Method Detail

      • getAction

        MethodBinding getAction()
        Deprecated. This has been replaced by ActionSource2.getActionExpression().

        If the implementing class also implements ActionSource2, the implementation of this method must call through to ActionSource2.getActionExpression() and examine the result. If the result came from a previous call to setAction(javax.faces.el.MethodBinding), extract the MethodBinding from it and return it. Otherwise, wrap the returned MethodExpression in a MethodBinding implementation, and return it.

        If the implementing class does not implement ActionSource2, return the MethodBindingpointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

      • setAction

        void setAction(MethodBinding action)
        Deprecated. This has been replaced by ActionSource2.setActionExpression(javax.el.MethodExpression).

        If the implementing class also implements ActionSource2, the implementation of this method must wrap the argument action in a class that implements MethodExpression and call through to ActionSource2.setActionExpression(javax.el.MethodExpression), passing the wrapped action.

        If the implementing class does not implement ActionSource2, set the MethodBinding pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Any method referenced by such an expression must be public, with a return type of String, and accept no parameters.

        Parameters:
        action - The new MethodBinding expression

      • getActionListener

        MethodBinding getActionListener()
        Deprecated. Use getActionListeners() instead.

        If setActionListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to setActionListener(javax.faces.el.MethodBinding).

        The method to be invoked, if this UIComponent is activated by the user, will be called during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending upon the value of the immediate property.

      • setActionListener

        void setActionListener(MethodBinding actionListener)
        Deprecated. This has been replaced by addActionListener(javax.faces.event.ActionListener).

        Wrap the argument actionListener in an implementation of ActionListener and store it in the internal data structure that backs the getActionListeners() method, taking care to over-write any instance that was stored by a previous call to setActionListener.

        Any method referenced by such an expression must be public, with a return type of void, and accept a single parameter of type ActionEvent.

        Parameters:
        actionListener - The new method binding expression

      • isImmediate

        boolean isImmediate()

        Return a flag indicating that the default ActionListener provided by the JavaServer Faces implementation should be executed immediately (that is, during Apply Request Values phase of the request processing lifecycle), rather than waiting until the Invoke Application phase. The default value for this property must be false.

      • setImmediate

        void setImmediate(boolean immediate)

        Set the "immediate execution" flag for this UIComponent.

        Parameters:
        immediate - The new immediate execution flag

      • addActionListener

        void addActionListener(ActionListener listener)

        Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.

        Parameters:
        listener - The ActionListener to be added
        Throws:
        NullPointerException - if listener is null

      • getActionListeners

        ActionListener[] getActionListeners()

        Return the set of registered ActionListeners for this ActionSource instance. If there are no registered listeners, a zero-length array is returned.

      • removeActionListener

        void removeActionListener(ActionListener listener)

        Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.

        Parameters:
        listener - The ActionListener to be removed
        Throws:
        NullPointerException - if listener is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ActionSource2 (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface ActionSource2

  • All Superinterfaces:
    ActionSource
    All Known Implementing Classes:
    HtmlCommandButton, HtmlCommandLink, UICommand, UIViewAction

    public interface ActionSource2
extends ActionSource

    ActionSource2 extends ActionSource and provides a JavaBeans property analogous to the "action" property on ActionSource. The difference is the type of this property is a MethodExpression rather than a MethodBinding. This allows the ActionSource concept to leverage the new Unified EL API.

    Since:
    1.2

    • Method Summary

      Methods
      Modifier and Type Method and Description
      MethodExpression getActionExpression()
      Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
      void setActionExpression(MethodExpression action)
      Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

      • Methods inherited from interface javax.faces.component.ActionSource

        addActionListener, getAction, getActionListener, getActionListeners, isImmediate, removeActionListener, setAction, setActionListener, setImmediate

    • Method Detail

      • getActionExpression

        MethodExpression getActionExpression()

        Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Note that it's possible that the returned MethodExpression is just a wrapper around a MethodBinding instance whith was set by a call to ActionSource.setAction(javax.faces.el.MethodBinding). This makes it possible for the default ActionListener to continue to work properly with older components.

      • setActionExpression

        void setActionExpression(MethodExpression action)

        Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Any method referenced by such an expression must be public, with a return type of String, and accept no parameters.

        Parameters:
        action - The new method expression
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ContextCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface ContextCallback

  • public interface ContextCallback

    A simple callback interace that enables taking action on a specific UIComponent (either facet or child) in the view while preserving any contextual state for that component instance in the view.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void invokeContextCallback(FacesContext context, UIComponent target)
      This method will be called by an implementation of UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) and must be passed the component with the clientId given as an argument to invokeOnComponent.

    • Method Detail

      • invokeContextCallback

        void invokeContextCallback(FacesContext context,
                         UIComponent target)

        This method will be called by an implementation of UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) and must be passed the component with the clientId given as an argument to invokeOnComponent. At the point in time when this method is called, the argument target is guaranteed to be in the proper state with respect to its ancestors in the View.

        Parameters:
        context - the FacesContext for this request.
        target - the UIComponent that was located by clientId by a call to UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EditableValueHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface EditableValueHolder

  • All Superinterfaces:
    ValueHolder
    All Known Implementing Classes:
    HtmlInputFile, HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, UIInput, UISelectBoolean, UISelectMany, UISelectOne, UIViewParameter

    public interface EditableValueHolder
extends ValueHolder

    EditableValueHolder is an extension of ValueHolder that describes additional features supported by editable components, including ValueChangeEvents and Validators.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addValidator(Validator validator)
      Add a Validator instance to the set associated with this component.
      void addValueChangeListener(ValueChangeListener listener)
      Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.
      Object getSubmittedValue()
      Return the submittedValue value of this component.
      MethodBinding getValidator()
      Deprecated.
      getValidators() should be used instead.
      Validator[] getValidators()
      Return the set of registered Validators for this component instance.
      MethodBinding getValueChangeListener()
      Deprecated.
      Use getValueChangeListeners() instead.
      ValueChangeListener[] getValueChangeListeners()
      Return the set of registered ValueChangeListeners for this component instance.
      boolean isImmediate()
      Return the "immediate" state for this component.
      boolean isLocalValueSet()
      Return the "local value set" state for this component.
      boolean isRequired()
      Return the "required field" state for this component.
      boolean isValid()
      Return a flag indicating whether the local value of this component is valid (no conversion error has occurred).
      void removeValidator(Validator validator)
      Remove a Validator instance from the set associated with this component, if it was previously associated.
      void removeValueChangeListener(ValueChangeListener listener)
      Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.
      void resetValue()

      Convenience method to reset this component's value to the un-initialized state.
      void setImmediate(boolean immediate)
      Set the "immediate" state for this component.
      void setLocalValueSet(boolean localValueSet)
      Sets the "local value set" state for this component.
      void setRequired(boolean required)
      Set the "required field" state for this component.
      void setSubmittedValue(Object submittedValue)
      Set the submittedValue value of this component.
      void setValid(boolean valid)
      Set a flag indicating whether the local value of this component is valid (no conversion error has occurred).
      void setValidator(MethodBinding validatorBinding)
      Deprecated.
      Use addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.
      void setValueChangeListener(MethodBinding valueChangeMethod)
      Deprecated.
      Use addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, getValue, setConverter, setValue

    • Method Detail

      • getSubmittedValue

        Object getSubmittedValue()

        Return the submittedValue value of this component. This method should only be used by the encodeBegin() and/or encodeEnd() methods of this component, or its corresponding Renderer. The action taken based on whether the value is null, empty, or non-null is determined based on the value of the javax.faces.INTERPRET_EMPTY_STRING_SUBMITTED_VALUES_AS_NULLcontext-param.

      • resetValue

        void resetValue()

        Convenience method to reset this component's value to the un-initialized state.

        Since:
        2.0

      • setSubmittedValue

        void setSubmittedValue(Object submittedValue)

        Set the submittedValue value of this component. This method should only be used by the decode() and validate() method of this component, or its corresponding Renderer. The action taken based on whether the value is null, empty, or non-null is determined based on the value of the javax.faces.INTERPRET_EMPTY_STRING_SUBMITTED_VALUES_AS_NULLcontext-param.

        Parameters:
        submittedValue - The new submitted value

      • isLocalValueSet

        boolean isLocalValueSet()
        Return the "local value set" state for this component. Calls to setValue() automatically reset this property to true.

      • setLocalValueSet

        void setLocalValueSet(boolean localValueSet)
        Sets the "local value set" state for this component.

      • isValid

        boolean isValid()

        Return a flag indicating whether the local value of this component is valid (no conversion error has occurred).

      • setValid

        void setValid(boolean valid)

        Set a flag indicating whether the local value of this component is valid (no conversion error has occurred).

        Parameters:
        valid - The new valid flag

      • isRequired

        boolean isRequired()

        Return the "required field" state for this component.

      • setRequired

        void setRequired(boolean required)

        Set the "required field" state for this component.

        Parameters:
        required - The new "required field" state

      • isImmediate

        boolean isImmediate()

        Return the "immediate" state for this component.

      • setImmediate

        void setImmediate(boolean immediate)

        Set the "immediate" state for this component. When set to true, the component's value will be converted and validated immediately in the Apply Request Values phase, and ValueChangeEvents will be delivered in that phase as well. The default value for this property must be false.

        Parameters:
        immediate - The new "immediate" state

      • getValidator

        MethodBinding getValidator()
        Deprecated. getValidators() should be used instead.

        If setValidator(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to setValidator(javax.faces.el.MethodBinding).

        This method will be called during the Process Validations or Apply Request Values phases (depending on the value of the immediate property).

      • setValidator

        void setValidator(MethodBinding validatorBinding)
        Deprecated. Use addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.

        Wrap the argument validatorBinding in an implementation of Validator and store it in the internal data structure that backs the getValidators() method, taking care to over-write any instance that was stored by a previous call to setValidator.

        The argument method will be called during the Process Validations or Apply Request Values phases (depending on the value of the immediate property).

        Any method referenced by such an expression must be public, with a return type of void, and accept parameters of type FacesContext, UIComponent, and Object.

        Parameters:
        validatorBinding - The new MethodBinding instance

      • getValueChangeListener

        MethodBinding getValueChangeListener()
        Deprecated. Use getValueChangeListeners() instead.

        If setValueChangeListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to setValueChangeListener(javax.faces.el.MethodBinding).

      • setValueChangeListener

        void setValueChangeListener(MethodBinding valueChangeMethod)
        Deprecated. Use addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.

        Wrap the argument valueChangeMethod in an implementation of ValueChangeListener and store it in the internal data structure that backs the getValueChangeListeners() method, taking care to over-write any instance that was stored by a previous call to setValueChangeListener.

        This argument method will be called during the Process Validations or Apply Request Values phases (depending on the value of the immediate property).

        Any method referenced by such an expression must be public, with a return type of void, and accept a parameter of type ValueChangeEvent.

        Parameters:
        valueChangeMethod - The new method binding instance

      • addValidator

        void addValidator(Validator validator)

        Add a Validator instance to the set associated with this component.

        Parameters:
        validator - The Validator to add
        Throws:
        NullPointerException - if validator is null

      • getValidators

        Validator[] getValidators()

        Return the set of registered Validators for this component instance. If there are no registered validators, a zero-length array is returned.

      • removeValidator

        void removeValidator(Validator validator)

        Remove a Validator instance from the set associated with this component, if it was previously associated. Otherwise, do nothing.

        Parameters:
        validator - The Validator to remove

      • addValueChangeListener

        void addValueChangeListener(ValueChangeListener listener)

        Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.

        Parameters:
        listener - The ValueChangeListener to be added
        Throws:
        NullPointerException - if listener is null

      • getValueChangeListeners

        ValueChangeListener[] getValueChangeListeners()

        Return the set of registered ValueChangeListeners for this component instance. If there are no registered listeners, a zero-length array is returned.

      • removeValueChangeListener

        void removeValueChangeListener(ValueChangeListener listener)

        Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.

        Parameters:
        listener - The ValueChangeListener to be removed
        Throws:
        NullPointerException - if listener is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesComponent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.component

Annotation Type FacesComponent

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface FacesComponent

    The presence of this annotation on a class that extends UIComponent must cause the runtime to register this class as a component suitable for inclusion in a view. If the createTag attribute is true, the runtime must create a corresponding Facelet tag handler according to the rules specified in the attributes of this annotation.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean createTag

      If the value of this attribute is true, the runtime must create a Facelet tag handler, that extends from ComponentHandler, suitable for use in pages under the tag library with namespace given by the value of the namespace() attribute.
      String namespace

      If the value of the createTag() attribute is true, the value of this attribute is taken to be the tag library namespace into which this component is placed.
      String tagName

      If the value of the createTag() attribute is true, the runtime must use this value as the tag name for including an instance of the component annotated with this annotation in a view.
      String value

      The value of this annotation attribute is taken to be the component-type with which instances of this class of component can be instantiated by calling Application.createComponent(java.lang.String).

    • Element Detail

      • value

        public abstract String value

        The value of this annotation attribute is taken to be the component-type with which instances of this class of component can be instantiated by calling Application.createComponent(java.lang.String). If no value is specified, or the value is null, the value is taken to be the return of calling getSimpleName on the class to which this annotation is attached and lowercasing the first character. If more than one component with this derived name is found, the results are undefined.

        Default:
        ""

      • createTag

        public abstract boolean createTag

        If the value of this attribute is true, the runtime must create a Facelet tag handler, that extends from ComponentHandler, suitable for use in pages under the tag library with namespace given by the value of the namespace() attribute.

        Default:
        false

      • tagName

        public abstract String tagName

        If the value of the createTag() attribute is true, the runtime must use this value as the tag name for including an instance of the component annotated with this annotation in a view. If this attribute is not specified on a usage of this annotation, the simple name of the class on which this annotation is declared, with the first character lowercased, is taken to be the value.

        Default:
        ""

      • namespace

        public abstract String namespace

        If the value of the createTag() attribute is true, the value of this attribute is taken to be the tag library namespace into which this component is placed.

        Default:
        "http://xmlns.jcp.org/jsf/component"
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.faces.component (Java(TM) EE 7 Specification APIs)

javax.faces.component

Interfaces

  • ActionSource
  • ActionSource2
  • ContextCallback
  • EditableValueHolder
  • NamingContainer
  • PartialStateHolder
  • StateHelper
  • StateHolder
  • TransientStateHelper
  • TransientStateHolder
  • UniqueIdVendor
  • ValueHolder

Classes

  • UIColumn
  • UICommand
  • UIComponent
  • UIComponentBase
  • UIData
  • UIForm
  • UIGraphic
  • UIInput
  • UIMessage
  • UIMessages
  • UINamingContainer
  • UIOutcomeTarget
  • UIOutput
  • UIPanel
  • UIParameter
  • UISelectBoolean
  • UISelectItem
  • UISelectItems
  • UISelectMany
  • UISelectOne
  • UIViewAction
  • UIViewParameter
  • UIViewParameter.Reference
  • UIViewRoot

Exceptions

  • UpdateModelException

Annotation Types

  • FacesComponent


javax.faces.component (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.component

Fundamental APIs for user interface components.

See: Description

  • Interface Summary
    Interface Description
    ActionSource
    ActionSource is an interface that may be implemented by any concrete UIComponent that wishes to be a source of ActionEvents, including the ability to invoke application actions via the default ActionListener mechanism.
    ActionSource2
    ActionSource2 extends ActionSource and provides a JavaBeans property analogous to the "action" property on ActionSource.
    ContextCallback
    A simple callback interace that enables taking action on a specific UIComponent (either facet or child) in the view while preserving any contextual state for that component instance in the view.
    EditableValueHolder
    EditableValueHolder is an extension of ValueHolder that describes additional features supported by editable components, including ValueChangeEvents and Validators.
    NamingContainer
    NamingContainer is an interface that must be implemented by any UIComponent that wants to be a naming container.
    PartialStateHolder

    Components that want to leverage the partial state saving feature must implement this interface instead of implementing StateHolder, from which this interface inherits.
    StateHelper

    Define a Map-like contract that makes it easier for components to implement PartialStateHolder.
    StateHolder
    This interface is implemented by classes that need to save their state between requests.
    TransientStateHelper

    Define a Map-like contract that makes it easier for components to implement TransientStateHolder.
    TransientStateHolder

    This interface is implemented by classes that need to save state that is expected to be available only within the scope of the current request.
    UniqueIdVendor

    UniqueIdVendor is an interface implemented by UIComponents that also implement NamingContainer so that they can provide unique ids based on their own clientId.
    ValueHolder
    ValueHolder is an interface that may be implemented by any concrete UIComponent that wishes to support a local value, as well as access data in the model tier via a value expression, and support conversion between String and the model tier data's native data type.
  • Class Summary
    Class Description
    UIColumn
    UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
    UICommand
    UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
    UIComponentBase
    UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
    UIData
    UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
    UIForm
    UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
    UIGraphic
    UIGraphic is a UIComponent that displays a graphical image to the user.
    UIInput
    UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
    UIMessage
    This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.
    UIMessages
    The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
    UINamingContainer
    UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
    UIOutcomeTarget

    This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
    UIOutput
    UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
    UIPanel
    UIPanel is a UIComponent that manages the layout of its child components.
    UIParameter
    UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.
    UISelectBoolean
    UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
    UISelectItem
    UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.
    UISelectItems
    UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.
    UISelectMany
    UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
    UISelectOne
    UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
    UIViewAction

    UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.
    UIViewParameter

    UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
    UIViewParameter.Reference

    Inner class to encapsulate a UIViewParameter instance so that it may be safely referenced regardless of whether or not the current view is the same as the view in which this UIViewParameter resides.
    UIViewRoot
    UIViewRoot is the UIComponent that represents the root of the UIComponent tree.
  • Exception Summary
    Exception Description
    UpdateModelException

    This exception indicates a failure to update the model and is created to wrap any exception that occurs during UIInput.updateModel(javax.faces.context.FacesContext).
  • Annotation Types Summary
    Annotation Type Description
    FacesComponent
    The presence of this annotation on a class that extends UIComponent must cause the runtime to register this class as a component suitable for inclusion in a view.

Package javax.faces.component Description

Fundamental APIs for user interface components.

For your convenience here is a UML class diagram of the classes in this package.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.component Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.component

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.component.UpdateModelException
    • javax.faces.component.UIComponent (implements javax.faces.event.ComponentSystemEventListener, javax.faces.component.PartialStateHolder, javax.faces.event.SystemEventListenerHolder, javax.faces.component.TransientStateHolder)
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIColumn
        • javax.faces.component.UICommand (implements javax.faces.component.ActionSource2)
        • javax.faces.component.UIData (implements javax.faces.component.NamingContainer, javax.faces.component.UniqueIdVendor)
        • javax.faces.component.UIForm (implements javax.faces.component.NamingContainer, javax.faces.component.UniqueIdVendor)
        • javax.faces.component.UIGraphic
        • javax.faces.component.UIMessage
        • javax.faces.component.UIMessages
        • javax.faces.component.UINamingContainer (implements javax.faces.component.NamingContainer, javax.faces.component.StateHolder, javax.faces.component.UniqueIdVendor)
        • javax.faces.component.UIOutput (implements javax.faces.component.ValueHolder)
          • javax.faces.component.UIInput (implements javax.faces.component.EditableValueHolder)
            • javax.faces.component.UISelectBoolean
            • javax.faces.component.UISelectMany
            • javax.faces.component.UISelectOne
            • javax.faces.component.UIViewParameter
          • javax.faces.component.UIOutcomeTarget
        • javax.faces.component.UIPanel
        • javax.faces.component.UIParameter
        • javax.faces.component.UISelectItem
        • javax.faces.component.UISelectItems
        • javax.faces.component.UIViewAction (implements javax.faces.component.ActionSource2)
        • javax.faces.component.UIViewRoot (implements javax.faces.component.UniqueIdVendor)
    • javax.faces.component.UIViewParameter.Reference

Interface Hierarchy

  • javax.faces.component.ActionSource
    • javax.faces.component.ActionSource2
  • javax.faces.component.ContextCallback
  • javax.faces.component.NamingContainer
  • javax.faces.component.StateHolder
    • javax.faces.component.PartialStateHolder
    • javax.faces.component.StateHelper
  • javax.faces.component.TransientStateHolder
    • javax.faces.component.TransientStateHelper
  • javax.faces.component.UniqueIdVendor
  • javax.faces.component.ValueHolder
    • javax.faces.component.EditableValueHolder

Annotation Type Hierarchy

  • javax.faces.component.FacesComponent (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


NamingContainer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface NamingContainer

  • All Known Implementing Classes:
    HtmlDataTable, HtmlForm, UIData, UIForm, UINamingContainer

    public interface NamingContainer

    NamingContainer is an interface that must be implemented by any UIComponent that wants to be a naming container. Naming containers affect the behavior of the UIComponent.findComponent(java.lang.String) and UIComponent.getClientId() methods; see those methods for further information.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static char SEPARATOR_CHAR
      Deprecated.
      use UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext)

    • Field Detail

      • SEPARATOR_CHAR

        static final char SEPARATOR_CHAR
        Deprecated. use UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext)

        The separator character used in component identifiers to demarcate navigation to a child naming container.

        See Also:
        Constant Field Values
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PartialStateHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface PartialStateHolder

  • All Superinterfaces:
    StateHolder
    All Known Implementing Classes:
    AjaxBehavior, BeanValidator, BehaviorBase, ClientBehaviorBase, DateTimeConverter, DoubleRangeValidator, EnumConverter, HtmlBody, HtmlColumn, HtmlCommandButton, HtmlCommandLink, HtmlDataTable, HtmlDoctype, HtmlForm, HtmlGraphicImage, HtmlHead, HtmlInputFile, HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlMessage, HtmlMessages, HtmlOutcomeTargetButton, HtmlOutcomeTargetLink, HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, HtmlPanelGrid, HtmlPanelGroup, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, LengthValidator, LongRangeValidator, NumberConverter, RegexValidator, UIColumn, UICommand, UIComponent, UIComponentBase, UIData, UIForm, UIGraphic, UIInput, UIMessage, UIMessages, UINamingContainer, UIOutcomeTarget, UIOutput, UIPanel, UIParameter, UISelectBoolean, UISelectItem, UISelectItems, UISelectMany, UISelectOne, UIViewAction, UIViewParameter, UIViewRoot

    public interface PartialStateHolder
extends StateHolder

    Components that want to leverage the partial state saving feature must implement this interface instead of implementing StateHolder, from which this interface inherits.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearInitialState()

      Reset the PartialStateHolder to a non-delta tracking state.
      boolean initialStateMarked()

      Return true if delta state changes are being tracked, otherwise false
      void markInitialState()

      The runtime must ensure that the markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state.

      • Methods inherited from interface javax.faces.component.StateHolder

        isTransient, restoreState, saveState, setTransient

    • Method Detail

      • markInitialState

        void markInitialState()

        The runtime must ensure that the markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state. The implementor of the interface must ensure that initialStateMarked() returns true from the time markInitialState() is called until clearInitialState() is called, after which time initialStateMarked() must return false. Also, during the time that the instance returns true from initialStateMarked(), the implementation must return only the state that has changed in its implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Since:
        2.0

      • initialStateMarked

        boolean initialStateMarked()

        Return true if delta state changes are being tracked, otherwise false

        Since:
        2.0

      • clearInitialState

        void clearInitialState()

        Reset the PartialStateHolder to a non-delta tracking state.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StateHelper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface StateHelper

  • All Superinterfaces:
    StateHolder

    public interface StateHelper
extends StateHolder

    Define a Map-like contract that makes it easier for components to implement PartialStateHolder. Each UIComponent in the view will return an implementation of this interface from its UIComponent.getStateHelper() method.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void add(Serializable key, Object value)

      Store the specified value in a List that is internal to the StateHelper.
      Object eval(Serializable key)

      Attempts to find a value associated with the specified key, using the value expression collection from the component if no such value is found.
      Object eval(Serializable key, Object defaultValue)

      Performs the same logic as eval(java.io.Serializable) } but if no value is found, this will return the specified defaultValue
      Object get(Serializable key)

      Return the value currently associated with the specified key if any.
      Object put(Serializable key, Object value)

      Return the previously stored value and store the specified key/value pair.
      Object put(Serializable key, String mapKey, Object value)

      Store the specified mapKey/value in a Map that is internal to the helper, and return the previously stored value.
      Object remove(Serializable key)

      Remove the key/value pair from the helper, returning the value previously stored under this key.
      Object remove(Serializable key, Object valueOrKey)

      Remove a value from the inner data structure.

      • Methods inherited from interface javax.faces.component.StateHolder

        isTransient, restoreState, saveState, setTransient

    • Method Detail

      • put

        Object put(Serializable key,
         Object value)

        Return the previously stored value and store the specified key/value pair. This is intended to store data that would otherwise reside in an instance variable on the component.

        Parameters:
        key - the key for the value
        value - the value
        Since:
        2.0

      • remove

        Object remove(Serializable key)

        Remove the key/value pair from the helper, returning the value previously stored under this key.

        Parameters:
        key - the key to remove
        Since:
        2.0

      • put

        Object put(Serializable key,
         String mapKey,
         Object value)

        Store the specified mapKey/value in a Map that is internal to the helper, and return the previously stored value. The Map will then be associated with key.

        It's important to note for delta tracking that any modifications to the internal Map be made through this method or remove(java.io.Serializable, Object).

        Parameters:
        key - the key of the map itself
        mapKey - the key within the internal map
        value - the value for the key in the internal map
        Since:
        2.0

      • get

        Object get(Serializable key)

        Return the value currently associated with the specified key if any.

        Parameters:
        key - the key for which the value should be returned.
        Since:
        2.0

      • eval

        Object eval(Serializable key)

        Attempts to find a value associated with the specified key, using the value expression collection from the component if no such value is found.

        Parameters:
        key - the name of the value in the internal map, or the name of a value expression in the components value expression collection.

        Since:
        2.0

      • eval

        Object eval(Serializable key,
          Object defaultValue)

        Performs the same logic as eval(java.io.Serializable) } but if no value is found, this will return the specified defaultValue

        Parameters:
        key - the key for which the value should be returned.
        defaultValue - the value to return if no value is found in the call to eval().
        Since:
        2.0

      • add

        void add(Serializable key,
       Object value)

        Store the specified value in a List that is internal to the StateHelper.

        It's important to note for delta tracking that any modifications to the internal List be made through this method or remove(java.io.Serializable, Object).

        Parameters:
        key - the key for which the value should be returned.
        value - the value to add
        Since:
        2.0

      • remove

        Object remove(Serializable key,
            Object valueOrKey)

        Remove a value from the inner data structure. Look in the inner data structure for the value at the given key. If the value is a Map, remove and return the value under the key given by the valueOrKey argument. If the value is a Collection, simply remove the value given by the argument valueOrKey and return null.

        Parameters:
        key - the key of in the inner data structure whose value is a Collection or Map
        valueOrKey - the value or key to be removed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StateHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface StateHolder

  • All Known Subinterfaces:
    PartialStateHolder, StateHelper
    All Known Implementing Classes:
    AjaxBehavior, BeanValidator, BehaviorBase, ClientBehaviorBase, DateTimeConverter, DoubleRangeValidator, EnumConverter, HtmlBody, HtmlColumn, HtmlCommandButton, HtmlCommandLink, HtmlDataTable, HtmlDoctype, HtmlForm, HtmlGraphicImage, HtmlHead, HtmlInputFile, HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlMessage, HtmlMessages, HtmlOutcomeTargetButton, HtmlOutcomeTargetLink, HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, HtmlPanelGrid, HtmlPanelGroup, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, LengthValidator, LongRangeValidator, MethodExpressionActionListener, MethodExpressionValidator, MethodExpressionValueChangeListener, NumberConverter, RegexValidator, UIColumn, UICommand, UIComponent, UIComponentBase, UIData, UIForm, UIGraphic, UIInput, UIMessage, UIMessages, UINamingContainer, UIOutcomeTarget, UIOutput, UIPanel, UIParameter, UISelectBoolean, UISelectItem, UISelectItems, UISelectMany, UISelectOne, UIViewAction, UIViewParameter, UIViewRoot

    public interface StateHolder

    This interface is implemented by classes that need to save their state between requests.

    An implementor must implement both saveState(javax.faces.context.FacesContext) and restoreState(javax.faces.context.FacesContext, java.lang.Object) methods in this class, since these two methods have a tightly coupled contract between themselves. In other words, if there is an ineritance hierarchy, it is not permissable to have the saveState(javax.faces.context.FacesContext) and restoreState(javax.faces.context.FacesContext, java.lang.Object) methods reside at different levels of the hierarchy.

    An implementor must have a public no-args constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setTransient(boolean newTransientValue)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

    • Method Detail

      • saveState

        Object saveState(FacesContext context)

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Throws:
        NullPointerException - if context is null

      • restoreState

        void restoreState(FacesContext context,
                Object state)

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Throws:
        NullPointerException - if context is null.

      • isTransient

        boolean isTransient()

        If true, the Object implementing this interface must not participate in state saving or restoring.

      • setTransient

        void setTransient(boolean newTransientValue)

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Parameters:
        newTransientValue - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransientStateHelper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface TransientStateHelper

  • All Superinterfaces:
    TransientStateHolder

    public interface TransientStateHelper
extends TransientStateHolder

    Define a Map-like contract that makes it easier for components to implement TransientStateHolder. Each UIComponent in the view will return an implementation of this interface from its UIComponent.getTransientStateHelper() method.

    The values retrieved or saved through getTransient(java.lang.Object) or putTransient(java.lang.Object, java.lang.Object) will not be preserved between requests.

    Since:
    2.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getTransient(Object key)

      Return the value currently associated with the specified key if any.
      Object getTransient(Object key, Object defaultValue)

      Performs the same logic as getTransient(java.lang.Object) } but if no value is found, this will return the specified defaultValue
      Object putTransient(Object key, Object value)

      Return the previously stored value and store the specified key/value pair.

      • Methods inherited from interface javax.faces.component.TransientStateHolder

        restoreTransientState, saveTransientState

    • Method Detail

      • getTransient

        Object getTransient(Object key)

        Return the value currently associated with the specified key if any.

        Parameters:
        key - the key for which the value should be returned.
        Since:
        2.1

      • getTransient

        Object getTransient(Object key,
                  Object defaultValue)

        Performs the same logic as getTransient(java.lang.Object) } but if no value is found, this will return the specified defaultValue

        Parameters:
        key - the key for which the value should be returned.
        defaultValue - the value to return if no value is found in the call to get().
        Since:
        2.1

      • putTransient

        Object putTransient(Object key,
                  Object value)

        Return the previously stored value and store the specified key/value pair. This is intended to store data that would otherwise reside in an instance variable on the component.

        Parameters:
        key - the key for the value
        value - the value
        Since:
        2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransientStateHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface TransientStateHolder

  • All Known Subinterfaces:
    TransientStateHelper
    All Known Implementing Classes:
    HtmlBody, HtmlColumn, HtmlCommandButton, HtmlCommandLink, HtmlDataTable, HtmlDoctype, HtmlForm, HtmlGraphicImage, HtmlHead, HtmlInputFile, HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlMessage, HtmlMessages, HtmlOutcomeTargetButton, HtmlOutcomeTargetLink, HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, HtmlPanelGrid, HtmlPanelGroup, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, UIColumn, UICommand, UIComponent, UIComponentBase, UIData, UIForm, UIGraphic, UIInput, UIMessage, UIMessages, UINamingContainer, UIOutcomeTarget, UIOutput, UIPanel, UIParameter, UISelectBoolean, UISelectItem, UISelectItems, UISelectMany, UISelectOne, UIViewAction, UIViewParameter, UIViewRoot

    public interface TransientStateHolder

    This interface is implemented by classes that need to save state that is expected to be available only within the scope of the current request.

    An implementor must implement both saveTransientState(javax.faces.context.FacesContext) and restoreTransientState(javax.faces.context.FacesContext, java.lang.Object) methods in this class, since these two methods have a tightly coupled contract between themselves. In other words, if there is an inheritance hierarchy, it is not permissible to have the saveTransientState(javax.faces.context.FacesContext) and restoreTransientState(javax.faces.context.FacesContext, java.lang.Object) methods reside at different levels of the hierarchy.

    An example of transient state is the "submitted" property on forms.

    Since:
    2.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void restoreTransientState(FacesContext context, Object state)

      Restore the "transient state" using the object passed as state.
      Object saveTransientState(FacesContext context)

      Return the object containing related "transient states".

    • Method Detail

      • saveTransientState

        Object saveTransientState(FacesContext context)

        Return the object containing related "transient states". that could be used later to restore the "transient state".

        Parameters:
        context -
        Returns:
        object containing transient values
        Since:
        2.1

      • restoreTransientState

        void restoreTransientState(FacesContext context,
                         Object state)

        Restore the "transient state" using the object passed as state.

        If the state argument is null clear any previous transient state if any and return.

        Parameters:
        context -
        state - the object containing transient values
        Since:
        2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIColumn (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIColumn

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIColumn
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlColumn

    public class UIColumn
extends UIComponentBase

    UIColumn is a UIComponent that represents a single column of data within a parent UIData component.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIColumn()
      Create a new UIColumn instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      UIComponent getFooter()
      Return the footer facet of the column (if any).
      UIComponent getHeader()
      Return the header facet of the column (if any).
      void setFooter(UIComponent footer)
      Set the footer facet of the column.
      void setHeader(UIComponent header)
      Set the header facet of the column.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIColumn

        public UIColumn()

        Create a new UIColumn instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getFooter

        public UIComponent getFooter()

        Return the footer facet of the column (if any). A convenience method for getFacet("footer").

      • setFooter

        public void setFooter(UIComponent footer)

        Set the footer facet of the column. A convenience method for getFacets().put("footer", footer).

        Parameters:
        footer - the new footer facet
        Throws:
        NullPointerException - if footer is null

      • getHeader

        public UIComponent getHeader()

        Return the header facet of the column (if any). A convenience method for getFacet("header").

      • setHeader

        public void setHeader(UIComponent header)

        Set the header facet of the column. A convenience method for getFacets().put("header", header).

        Parameters:
        header - the new header facet
        Throws:
        NullPointerException - if header is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UICommand (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UICommand

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UICommand
  • All Implemented Interfaces:
    EventListener, ActionSource, ActionSource2, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlCommandButton, HtmlCommandLink

    public class UICommand
extends UIComponentBase
implements ActionSource2

    UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action". Such a component is typically rendered as a push button, a menu item, or a hyperlink.

    When the decode() method of this UICommand, or its corresponding Renderer, detects that this control has been activated, it will queue an ActionEvent. Later on, the broadcast() method will ensure that this event is broadcast to all interested listeners.

    Listeners will be invoked in the following order:

    1. ActionListeners, in the order in which they were registered.
    2. The "actionListener" MethodExpression (which will cover the "actionListener" that was set as a MethodBinding).
    3. The default ActionListener, retrieved from the Application - and therefore, any attached "action" MethodExpression.

    By default, the rendererType property must be set to "javax.faces.Button". This value can be changed by calling the setRendererType() method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UICommand()
      Create a new UICommand instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addActionListener(ActionListener listener)
      Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.
      void broadcast(FacesEvent event)
      In addition to to the default UIComponent.broadcast(javax.faces.event.FacesEvent) processing, pass the ActionEvent being broadcast to the method referenced by actionListener (if any), and to the default ActionListener registered on the Application.
      MethodBinding getAction()
      Deprecated.
      This has been replaced by getActionExpression().
      MethodExpression getActionExpression()
      Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
      MethodBinding getActionListener()
      Deprecated.
      Use getActionListeners() instead.
      ActionListener[] getActionListeners()
      Return the set of registered ActionListeners for this ActionSource instance.
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      Object getValue()
      Returns the value property of the UICommand.
      boolean isImmediate()
      The immediate flag.
      void queueEvent(FacesEvent e)
      Intercept queueEvent and take the following action.
      void removeActionListener(ActionListener listener)
      Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.
      void setAction(MethodBinding action)
      Deprecated.
      This has been replaced by setActionExpression(javax.el.MethodExpression).
      void setActionExpression(MethodExpression actionExpression)
      Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
      void setActionListener(MethodBinding actionListener)
      Deprecated.
      This has been replaced by addActionListener(javax.faces.event.ActionListener).
      void setImmediate(boolean immediate)
      Set the "immediate execution" flag for this UIComponent.
      void setValue(Object value)
      Sets the value property of the UICommand.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UICommand

        public UICommand()

        Create a new UICommand instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getAction

        public MethodBinding getAction()
        Deprecated. This has been replaced by getActionExpression().

        If the implementing class also implements ActionSource2, the implementation of this method must call through to ActionSource2.getActionExpression() and examine the result. If the result came from a previous call to ActionSource.setAction(javax.faces.el.MethodBinding), extract the MethodBinding from it and return it. Otherwise, wrap the returned MethodExpression in a MethodBinding implementation, and return it.

        If the implementing class does not implement ActionSource2, return the MethodBindingpointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Specified by:
        getAction in interface ActionSource

      • setAction

        public void setAction(MethodBinding action)
        Deprecated. This has been replaced by setActionExpression(javax.el.MethodExpression).

        If the implementing class also implements ActionSource2, the implementation of this method must wrap the argument action in a class that implements MethodExpression and call through to ActionSource2.setActionExpression(javax.el.MethodExpression), passing the wrapped action.

        If the implementing class does not implement ActionSource2, set the MethodBinding pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Any method referenced by such an expression must be public, with a return type of String, and accept no parameters.

        Specified by:
        setAction in interface ActionSource
        Parameters:
        action - The new MethodBinding expression

      • getActionListener

        public MethodBinding getActionListener()
        Deprecated. Use getActionListeners() instead.

        If ActionSource.setActionListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to ActionSource.setActionListener(javax.faces.el.MethodBinding).

        The method to be invoked, if this UIComponent is activated by the user, will be called during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending upon the value of the immediate property.

        Specified by:
        getActionListener in interface ActionSource

      • setActionListener

        public void setActionListener(MethodBinding actionListener)
        Deprecated. This has been replaced by addActionListener(javax.faces.event.ActionListener).

        Wrap the argument actionListener in an implementation of ActionListener and store it in the internal data structure that backs the ActionSource.getActionListeners() method, taking care to over-write any instance that was stored by a previous call to setActionListener.

        Any method referenced by such an expression must be public, with a return type of void, and accept a single parameter of type ActionEvent.

        Specified by:
        setActionListener in interface ActionSource
        Parameters:
        actionListener - The new method binding expression

      • isImmediate

        public boolean isImmediate()

        The immediate flag.

        Specified by:
        isImmediate in interface ActionSource

      • setImmediate

        public void setImmediate(boolean immediate)
        Description copied from interface: ActionSource

        Set the "immediate execution" flag for this UIComponent.

        Specified by:
        setImmediate in interface ActionSource
        Parameters:
        immediate - The new immediate execution flag

      • getValue

        public Object getValue()

        Returns the value property of the UICommand. This is most often rendered as a label.

      • setValue

        public void setValue(Object value)

        Sets the value property of the UICommand. This is most often rendered as a label.

        Parameters:
        value - the new value

      • getActionExpression

        public MethodExpression getActionExpression()
        Description copied from interface: ActionSource2

        Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Note that it's possible that the returned MethodExpression is just a wrapper around a MethodBinding instance whith was set by a call to ActionSource.setAction(javax.faces.el.MethodBinding). This makes it possible for the default ActionListener to continue to work properly with older components.

        Specified by:
        getActionExpression in interface ActionSource2

      • setActionExpression

        public void setActionExpression(MethodExpression actionExpression)
        Description copied from interface: ActionSource2

        Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Any method referenced by such an expression must be public, with a return type of String, and accept no parameters.

        Specified by:
        setActionExpression in interface ActionSource2
        Parameters:
        actionExpression - The new method expression

      • addActionListener

        public void addActionListener(ActionListener listener)
        Description copied from interface: ActionSource

        Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.

        Specified by:
        addActionListener in interface ActionSource
        Parameters:
        listener - The ActionListener to be added
        Throws:
        NullPointerException - if listener is null

      • getActionListeners

        public ActionListener[] getActionListeners()
        Description copied from interface: ActionSource

        Return the set of registered ActionListeners for this ActionSource instance. If there are no registered listeners, a zero-length array is returned.

        Specified by:
        getActionListeners in interface ActionSource

      • removeActionListener

        public void removeActionListener(ActionListener listener)
        Description copied from interface: ActionSource

        Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.

        Specified by:
        removeActionListener in interface ActionSource
        Parameters:
        listener - The ActionListener to be removed
        Throws:
        NullPointerException - if listener is null

      • broadcast

        public void broadcast(FacesEvent event)
               throws AbortProcessingException

        In addition to to the default UIComponent.broadcast(javax.faces.event.FacesEvent) processing, pass the ActionEvent being broadcast to the method referenced by actionListener (if any), and to the default ActionListener registered on the Application.

        Overrides:
        broadcast in class UIComponentBase
        Parameters:
        event - FacesEvent to be broadcast
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
        IllegalArgumentException - if the implementation class of this FacesEvent is not supported by this component
        NullPointerException - if event is null

      • queueEvent

        public void queueEvent(FacesEvent e)

        Intercept queueEvent and take the following action. If the event is an ActionEvent, obtain the UIComponent instance from the event. If the component is an ActionSource obtain the value of its "immediate" property. If it is true, mark the phaseId for the event to be PhaseId.APPLY_REQUEST_VALUES otherwise, mark the phaseId to be PhaseId.INVOKE_APPLICATION. The event must be passed on to super.queueEvent() before returning from this method.

        Overrides:
        queueEvent in class UIComponentBase
        Parameters:
        e - FacesEvent to be queued
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIComponent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIComponent

  • java.lang.Object
    • javax.faces.component.UIComponent
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    UIComponentBase

    public abstract class UIComponent
extends Object
implements PartialStateHolder, TransientStateHolder, SystemEventListenerHolder, ComponentSystemEventListener

    UIComponent is the base class for all user interface components in JavaServer Faces. The set of UIComponent instances associated with a particular request and response are organized into a component tree under a UIViewRoot that represents the entire content of the request or response.

    For the convenience of component developers, UIComponentBase provides the default behavior that is specified for a UIComponent, and is the base class for all of the concrete UIComponent "base" implementations. Component writers are encouraged to subclass UIComponentBase, instead of directly implementing this abstract class, to reduce the impact of any future changes to the method signatures.

    If the ListenerFor annotation is attached to the class definition of a Component, that class must also implement ComponentSystemEventListener.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ATTRS_WITH_DECLARED_DEFAULT_VALUES

      This constant enables one to quickly discover the names of the declared composite component attributes that have been given default values by the composite component author.
      static String BEANINFO_KEY

      The value of this constant is used as the key in the component attribute map, the value for which is a java.beans.BeanInfo implementation describing the composite component.
      protected Map<String,ValueExpression> bindings
      Deprecated.
      static String COMPOSITE_COMPONENT_TYPE_KEY

      The value of this constant is used as the key in the composite component BeanDescriptor for a ValueExpression that evaluates to the component-type of the composite component root UIComponent for this composite component, if one was declared by the composite component author.
      static String COMPOSITE_FACET_NAME

      The value of this constant is used as the key in the Map returned as described in FACETS_KEY for the PropertyDescriptor describing the composite component facet.
      static String CURRENT_COMPONENT
      Deprecated.
      static String CURRENT_COMPOSITE_COMPONENT
      Deprecated.
      static String FACETS_KEY

      The value of this constant is used as the key in the composite component BeanDescriptor for the Map<PropertyDescriptor> that contains meta-information for the declared facets for this composite component.
      static String HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME

      The ServletContext init parameter consulted by the UIComponent to tell whether or not the CURRENT_COMPONENT and CURRENT_COMPOSITE_COMPONENT attribute keys should be honored as specified.
      static String VIEW_LOCATION_KEY

      The value of this constant is used as the key in the component attributes Map for the Location in the view at which this component instance resides.

    • Constructor Summary

      Constructors
      Constructor and Description
      UIComponent()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected abstract void addFacesListener(FacesListener listener)
      Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent.
      abstract void broadcast(FacesEvent event)
      Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type.
      void clearInitialState()

      An implementation of PartialStateHolder.clearInitialState(), this method is called by the runtime to tell the instance to stop tracking state changes.
      abstract void decode(FacesContext context)
      Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.
      void encodeAll(FacesContext context)
      If this component returns true from isRendered(), take the following action.
      abstract void encodeBegin(FacesContext context)
      If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext.
      abstract void encodeChildren(FacesContext context)
      If our rendered property is true, render the child UIComponents of this UIComponent.
      abstract void encodeEnd(FacesContext context)
      If our rendered property is true, render the ending of the current state of this UIComponent.
      abstract UIComponent findComponent(String expr)
      Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.
      abstract Map<String,Object> getAttributes()
      Return a mutable Map representing the attributes (and properties, see below) associated wth this UIComponent, keyed by attribute name (which must be a String).
      abstract int getChildCount()
      Return the number of child UIComponents that are associated with this UIComponent.
      abstract List<UIComponent> getChildren()
      Return a mutable List representing the child UIComponents associated with this component.
      String getClientId()

      Enable EL to access the clientId of a component.
      abstract String getClientId(FacesContext context)
      Return a client-side identifier for this component, generating one if necessary.
      static UIComponent getCompositeComponentParent(UIComponent component)
      Finds the nearest composite component parent of the specified component.
      String getContainerClientId(FacesContext context)
      Allow components that implement NamingContainer to selectively disable prepending their clientId to their descendent's clientIds by breaking the prepending logic into a seperately callable method.
      static UIComponent getCurrentComponent(FacesContext context)

      Return the UIComponent instance that is currently processing.
      static UIComponent getCurrentCompositeComponent(FacesContext context)

      Return the closest ancestor component, relative to the component returned from getCurrentComponent(javax.faces.context.FacesContext), that is a composite component, or null if no such component exists.
      protected abstract FacesContext getFacesContext()
      Convenience method to return the FacesContext instance for the current request.
      protected abstract FacesListener[] getFacesListeners(Class clazz)
      Return an array of registered FacesListeners that are instances of the specified class.
      abstract UIComponent getFacet(String name)
      Convenience method to return the named facet, if it exists, or null otherwise.
      int getFacetCount()
      Return the number of facet UIComponents that are associated with this UIComponent.
      abstract Map<String,UIComponent> getFacets()
      Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String).
      abstract Iterator<UIComponent> getFacetsAndChildren()
      Return an Iterator over the facet followed by child UIComponents of this UIComponent.
      abstract String getFamily()
      Return the identifier of the component family to which this component belongs.
      abstract String getId()
      Return the component identifier of this UIComponent.
      List<SystemEventListener> getListenersForEventClass(Class<? extends SystemEvent> eventClass)

      This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.
      UIComponent getNamingContainer()

      Starting with "this", return the closest component in the ancestry that is a NamingContainer or null if none can be found.
      abstract UIComponent getParent()
      Return the parent UIComponent of this UIComponent, if any.
      Map<String,Object> getPassThroughAttributes()

      This is a convenience method that simply calls getPassThroughAttributes(boolean), passing true as the argument.
      Map<String,Object> getPassThroughAttributes(boolean create)

      This method has the same specification as getPassThroughAttributes() except that it is allowed to return null if and only if the argument create is false and no pass through attribute data structure exists for this instance.
      protected abstract Renderer getRenderer(FacesContext context)
      Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.
      abstract String getRendererType()
      Return the Renderer type for this UIComponent (if any).
      abstract boolean getRendersChildren()
      Return a flag indicating whether this component is responsible for rendering its child components.
      Map<String,String> getResourceBundleMap()

      Return a Map<String,String> of the ResourceBundle for this component.
      protected StateHelper getStateHelper()

      Return the StateHelper instance used to help this component implement PartialStateHolder.
      protected StateHelper getStateHelper(boolean create)

      Like getStateHelper(), but only create a state helper instance if the argument creat is true.
      TransientStateHelper getTransientStateHelper()

      Return the TransientStateHelper instance for this UIComponent instance.
      TransientStateHelper getTransientStateHelper(boolean create)

      Return the TransientStateHelper instance for this UIComponent instance.
      abstract ValueBinding getValueBinding(String name)
      Deprecated.
      This has been replaced by getValueExpression(java.lang.String).
      ValueExpression getValueExpression(String name)
      Return the ValueExpression used to calculate the value for the specified attribute or property name, if any.
      boolean initialStateMarked()

      An implementation of PartialStateHolder.initialStateMarked(), this method is called by the runtime to test if the PartialStateHolder.markInitialState() method was called.
      boolean invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.
      static boolean isCompositeComponent(UIComponent component)

      Return true if component is a composite component, otherwise false.
      boolean isInView()

      Return true if this component is within the view hierarchy otherwise false
      abstract boolean isRendered()
      Return true if this component (and its children) should be rendered during the Render Response phase of the request processing lifecycle.
      protected boolean isVisitable(VisitContext context)

      Return true if this component should be visited, false otherwise.
      void markInitialState()

      An implementation of PartialStateHolder.markInitialState(), this method is called by the runtime to indicate that the instance should start tracking changes to its state.
      void popComponentFromEL(FacesContext context)

      Pop the current UIComponent from the FacesContext attributes map so that the previous UIComponent, if any, becomes the current component.
      abstract void processDecodes(FacesContext context)
      Perform the component tree processing required by the Apply Request Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      void processEvent(ComponentSystemEvent event)

      The default implementation performs the following action.
      abstract void processRestoreState(FacesContext context, Object state)
      Perform the component tree processing required by the Restore View phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      abstract Object processSaveState(FacesContext context)
      Perform the component tree processing required by the state saving portion of the Render Response phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      abstract void processUpdates(FacesContext context)
      Perform the component tree processing required by the Update Model Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      abstract void processValidators(FacesContext context)
      Perform the component tree processing required by the Process Validations phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      void pushComponentToEL(FacesContext context, UIComponent component)

      Push the current UIComponent this to the FacesContext attribute map using the key CURRENT_COMPONENT saving the previous UIComponent associated with CURRENT_COMPONENT for a subsequent call to popComponentFromEL(javax.faces.context.FacesContext).
      abstract void queueEvent(FacesEvent event)
      Queue an event for broadcast at the end of the current request processing lifecycle phase.
      protected abstract void removeFacesListener(FacesListener listener)
      Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.
      void restoreTransientState(FacesContext context, Object state)

      For components that need to support the concept of transient state, this method will restore any state saved on a prior call to saveTransientState(javax.faces.context.FacesContext).
      Object saveTransientState(FacesContext context)

      For components that need to support the concept of transient state, this method will save any state that is known to be transient in nature.
      abstract void setId(String id)
      Set the component identifier of this UIComponent (if any).
      void setInView(boolean isInView)

      Updates the status as to whether or not this component is currently within the view hierarchy.
      abstract void setParent(UIComponent parent)

      Set the parent UIComponent of this UIComponent.
      abstract void setRendered(boolean rendered)
      Set the rendered property of this UIComponent.
      abstract void setRendererType(String rendererType)
      Set the Renderer type for this UIComponent, or null for components that render themselves.
      abstract void setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
      void setValueExpression(String name, ValueExpression binding)
      Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.
      void subscribeToEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.
      void unsubscribeFromEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.
      boolean visitTree(VisitContext context, VisitCallback callback)

      Perform a tree visit starting at this node in the tree.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.StateHolder

        isTransient, restoreState, saveState, setTransient

    • Field Detail

      • HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME

        public static final String HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME

        The ServletContext init parameter consulted by the UIComponent to tell whether or not the CURRENT_COMPONENT and CURRENT_COMPOSITE_COMPONENT attribute keys should be honored as specified.

        If this parameter is not specified, or is set to false, the contract specified by the CURRENT_COMPONENT and CURRENT_COMPOSITE_COMPONENT method is not honored. If this parameter is set to true, the contract is honored.

        See Also:
        Constant Field Values

      • CURRENT_COMPONENT

        public static final String CURRENT_COMPONENT
        Deprecated.

        The key to which the UIComponent currently being processed will be associated with within the FacesContext attributes map. The use of this constant is deprecated. Please see HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME to enable its use.

        Since:
        2.0
        See Also:
        FacesContext.getAttributes(), Constant Field Values

      • CURRENT_COMPOSITE_COMPONENT

        public static final String CURRENT_COMPOSITE_COMPONENT
        Deprecated.

        The key to which the composite UIComponent currently being processed will be associated with within the FacesContext attributes map. The use of this constant is deprecated. Please see HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME to enable its use.

        Since:
        2.0
        See Also:
        FacesContext.getAttributes(), Constant Field Values

      • BEANINFO_KEY

        public static final String BEANINFO_KEY

        The value of this constant is used as the key in the component attribute map, the value for which is a java.beans.BeanInfo implementation describing the composite component. This BeanInfo is known as the composite component BeanInfo.

        Since:
        2.0
        See Also:
        Constant Field Values

      • FACETS_KEY

        public static final String FACETS_KEY

        The value of this constant is used as the key in the composite component BeanDescriptor for the Map<PropertyDescriptor> that contains meta-information for the declared facets for this composite component. This map must contain an entry under the key COMPOSITE_FACET_NAME, even if no facets were explicitly declared. See COMPOSITE_FACET_NAME.

        Since:
        2.0
        See Also:
        Constant Field Values

      • VIEW_LOCATION_KEY

        public static final String VIEW_LOCATION_KEY

        The value of this constant is used as the key in the component attributes Map for the Location in the view at which this component instance resides.

        Since:
        2.0
        See Also:
        Constant Field Values

      • COMPOSITE_COMPONENT_TYPE_KEY

        public static final String COMPOSITE_COMPONENT_TYPE_KEY

        The value of this constant is used as the key in the composite component BeanDescriptor for a ValueExpression that evaluates to the component-type of the composite component root UIComponent for this composite component, if one was declared by the composite component author.

        Since:
        2.0
        See Also:
        Constant Field Values

      • COMPOSITE_FACET_NAME

        public static final String COMPOSITE_FACET_NAME

        The value of this constant is used as the key in the Map returned as described in FACETS_KEY for the PropertyDescriptor describing the composite component facet. The value of this constant is also used as the key in the Map returned from getFacets(). In this case, it refers to the actual facet that is the UIPanel that is the parent of the all of the components in the <composite:implementation> section of the composite component VDL file.

        Since:
        2.0
        See Also:
        Constant Field Values

      • ATTRS_WITH_DECLARED_DEFAULT_VALUES

        public static final String ATTRS_WITH_DECLARED_DEFAULT_VALUES

        This constant enables one to quickly discover the names of the declared composite component attributes that have been given default values by the composite component author. The information is exposed as a Collection<String> returned from the getValue() method on the composite component BeanDescriptor, when this constant is passed as the argument.

        Since:
        2.1
        See Also:
        Constant Field Values

      • bindings

        @Deprecated
protected Map<String,ValueExpression> bindings
        Deprecated.

    • Constructor Detail

      • UIComponent

        public UIComponent()

    • Method Detail

      • getAttributes

        public abstract Map<String,Object> getAttributes()

        Return a mutable Map representing the attributes (and properties, see below) associated wth this UIComponent, keyed by attribute name (which must be a String). The returned implementation must support all of the standard and optional Map methods, plus support the following additional requirements:

        • The Map implementation must implement the java.io.Serializable interface.
        • Any attempt to add a null key or value must throw a NullPointerException.
        • Any attempt to add a key that is not a String must throw a ClassCastException.
        • If the attribute name specified as a key matches a property of this UIComponent's implementation class, the following methods will have special behavior:
          • containsKey - Return false.
          • get() - If the property is readable, call the getter method and return the returned value (wrapping primitive values in their corresponding wrapper classes); otherwise throw IllegalArgumentException.
          • put() - If the property is writeable, call the setter method to set the corresponding value (unwrapping primitive values in their corresponding wrapper classes). If the property is not writeable, or an attempt is made to set a property of primitive type to null, throw IllegalArgumentException.
          • remove - Throw IllegalArgumentException.

      • getPassThroughAttributes

        public final Map<String,Object> getPassThroughAttributes()

        This is a convenience method that simply calls getPassThroughAttributes(boolean), passing true as the argument. This method must never return null.

        Since:
        2.2

      • getPassThroughAttributes

        public Map<String,Object> getPassThroughAttributes(boolean create)

        This method has the same specification as getPassThroughAttributes() except that it is allowed to return null if and only if the argument create is false and no pass through attribute data structure exists for this instance. The returned Map implementation must support all of the standard and optional Map methods, plus support the following additional requirements. The map must be stored in using getStateHelper().

        The Map implementation must implement java.io.Serializable.

        Any attempt to add a null key or value must throw a NullPointerException.

        Any attempt to add a key that is not a String must throw an IllegalArgumentException.

        For backward compatibility with components that extend directly from this class, a default implementation is provided that returns the empty map.

        Parameters:
        create - if true, a new Map instance will be created if it does not exist already. If false, and there is no existing Map instance, one will not be created and null will be returned.
        Returns:
        A Map instance, or null.
        Since:
        2.2

      • getValueBinding

        public abstract ValueBinding getValueBinding(String name)
        Deprecated. This has been replaced by getValueExpression(java.lang.String).

        Call through to getValueExpression(java.lang.String) and examine the result. If the result is an instance of the wrapper class mandated in setValueBinding(java.lang.String, javax.faces.el.ValueBinding), extract the ValueBinding instance and return it. Otherwise, wrap the result in an implementation of ValueBinding, and return it.

        Parameters:
        name - Name of the attribute or property for which to retrieve a ValueBinding
        Throws:
        NullPointerException - if name is null

      • setValueBinding

        public abstract void setValueBinding(String name,
                   ValueBinding binding)
        Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

        Wrap the argument binding in an implementation of ValueExpression and call through to setValueExpression(java.lang.String, javax.el.ValueExpression).

        Parameters:
        name - Name of the attribute or property for which to set a ValueBinding
        binding - The ValueBinding to set, or null to remove any currently set ValueBinding
        Throws:
        IllegalArgumentException - if name is one of id or parent
        NullPointerException - if name is null

      • getValueExpression

        public ValueExpression getValueExpression(String name)

        Return the ValueExpression used to calculate the value for the specified attribute or property name, if any.

        This method must be overridden and implemented for components that comply with JSF 1.2 and later.

        Parameters:
        name - Name of the attribute or property for which to retrieve a ValueExpression
        Throws:
        NullPointerException - if name is null
        Since:
        1.2

      • setValueExpression

        public void setValueExpression(String name,
                      ValueExpression binding)

        Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.

        The implementation must call Expression.isLiteralText() on the argument expression. If isLiteralText() returns true, invoke ValueExpression.getValue(javax.el.ELContext) on the argument expression and pass the result as the value parameter in a call to this.getAttributes().put(name, value) where name is the argument name. If an exception is thrown as a result of calling ValueExpression.getValue(javax.el.ELContext), wrap it in a FacesException and re-throw it. If isLiteralText() returns false, simply store the un-evaluated expression argument in the collection of ValueExpressions under the key given by the argument name.

        This method must be overridden and implemented for components that comply with JSF 1.2 and later.

        Parameters:
        name - Name of the attribute or property for which to set a ValueExpression
        binding - The ValueExpression to set, or null to remove any currently set ValueExpression
        Throws:
        IllegalArgumentException - if name is one of id or parent
        NullPointerException - if name is null
        Since:
        1.2

      • markInitialState

        public void markInitialState()

        An implementation of PartialStateHolder.markInitialState(), this method is called by the runtime to indicate that the instance should start tracking changes to its state.

        Specified by:
        markInitialState in interface PartialStateHolder
        Since:
        2.0

      • initialStateMarked

        public boolean initialStateMarked()

        An implementation of PartialStateHolder.initialStateMarked(), this method is called by the runtime to test if the PartialStateHolder.markInitialState() method was called.

        Specified by:
        initialStateMarked in interface PartialStateHolder
        Since:
        2.0

      • clearInitialState

        public void clearInitialState()

        An implementation of PartialStateHolder.clearInitialState(), this method is called by the runtime to tell the instance to stop tracking state changes.

        Specified by:
        clearInitialState in interface PartialStateHolder
        Since:
        2.0

      • getStateHelper

        protected StateHelper getStateHelper()

        Return the StateHelper instance used to help this component implement PartialStateHolder.

        Since:
        2.0

      • getStateHelper

        protected StateHelper getStateHelper(boolean create)

        Like getStateHelper(), but only create a state helper instance if the argument creat is true.

        Parameters:
        create - if true, a new StateHelper instance will be created if it does not exist already. If false, and there is no existing StateHelper instance, one will not be created and null will be returned.
        Since:
        2.0

      • getTransientStateHelper

        public final TransientStateHelper getTransientStateHelper()

        Return the TransientStateHelper instance for this UIComponent instance. The default implementation simply calls through to getTransientStateHelper(boolean) passing true as the argument.

        Since:
        2.1

      • getTransientStateHelper

        public TransientStateHelper getTransientStateHelper(boolean create)

        Return the TransientStateHelper instance for this UIComponent instance.

        Parameters:
        create - if true create, if necessary, any internal data structures. If false, do not create any instances. In this case, it is possible for this method to return null.
        Since:
        2.1

      • restoreTransientState

        public void restoreTransientState(FacesContext context,
                         Object state)

        For components that need to support the concept of transient state, this method will restore any state saved on a prior call to saveTransientState(javax.faces.context.FacesContext).

        Specified by:
        restoreTransientState in interface TransientStateHolder
        state - the object containing transient values
        Since:
        2.1

      • saveTransientState

        public Object saveTransientState(FacesContext context)

        For components that need to support the concept of transient state, this method will save any state that is known to be transient in nature.

        Specified by:
        saveTransientState in interface TransientStateHolder
        Returns:
        object containing transient values
        Since:
        2.1

      • isInView

        public boolean isInView()

        Return true if this component is within the view hierarchy otherwise false

        Since:
        2.0

      • setInView

        public void setInView(boolean isInView)

        Updates the status as to whether or not this component is currently within the view hierarchy. This method must never be called by developers; a UIComponent's internal implementation will call it as components are added to or removed from a parent's child List or facet Map.

        Parameters:
        isInView - flag indicating whether or not this component is within the view hierachy
        Since:
        2.0

      • getClientId

        public String getClientId()

        Enable EL to access the clientId of a component. This is particularly useful in combination with the component and cc implicit objects. A default implementation is provided that simply calls FacesContext.getCurrentInstance() and then calls through to getClientId(FacesContext).

        Since:
        2.0

      • getClientId

        public abstract String getClientId(FacesContext context)

        Return a client-side identifier for this component, generating one if necessary. The associated Renderer, if any, will be asked to convert the clientId to a form suitable for transmission to the client.

        The return from this method must be the same value throughout the lifetime of the instance, unless the id property of the component is changed, or the component is placed in a NamingContainer whose client ID changes (for example, UIData). However, even in these cases, consecutive calls to this method must always return the same value. The implementation must follow these steps in determining the clientId:

        Find the closest ancestor to this component in the view hierarchy that implements NamingContainer. Call getContainerClientId() on it and save the result as the parentId local variable. Call getId() on this component and save the result as the myId local variable. If myId is null, call context.getViewRoot().createUniqueId() and assign the result to myId. If parentId is non-null, let myId equal parentId + UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext) + myId. Call Renderer.convertClientId(javax.faces.context.FacesContext, java.lang.String), passing myId, and return the result.

        Parameters:
        context - The FacesContext for the current request
        Throws:
        NullPointerException - if context is null

      • getContainerClientId

        public String getContainerClientId(FacesContext context)

        Allow components that implement NamingContainer to selectively disable prepending their clientId to their descendent's clientIds by breaking the prepending logic into a seperately callable method. See getClientId() for usage.

        By default, this method will call through to getClientId() and return the result.

        Throws:
        NullPointerException - if context is null
        Since:
        1.2

      • getFamily

        public abstract String getFamily()

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

      • getId

        public abstract String getId()

        Return the component identifier of this UIComponent.

      • setId

        public abstract void setId(String id)

        Set the component identifier of this UIComponent (if any). Component identifiers must obey the following syntax restrictions:

        • Must not be a zero-length String.
        • First character must be a letter or an underscore ('_').
        • Subsequent characters must be a letter, a digit, an underscore ('_'), or a dash ('-').

        Component identifiers must also obey the following semantic restrictions (note that this restriction is NOT enforced by the setId() implementation):

        • The specified identifier must be unique among all the components (including facets) that are descendents of the nearest ancestor UIComponent that is a NamingContainer, or within the scope of the entire component tree if there is no such ancestor that is a NamingContainer.
        Parameters:
        id - The new component identifier, or null to indicate that this UIComponent does not have a component identifier
        Throws:
        IllegalArgumentException - if id is not syntactically valid

      • getParent

        public abstract UIComponent getParent()

        Return the parent UIComponent of this UIComponent, if any. A component must allow child components to be added to and removed from the list of children of this component, even though the child component returns null from getParent( ).

      • setParent

        public abstract void setParent(UIComponent parent)

        Set the parent UIComponent of this UIComponent. If parent.isInView() returns true, calling this method will first cause a PreRemoveFromViewEvent to be published, for this node, and then the children of this node. Then, once the re-parenting has occurred, a PostAddToViewEvent will be published as well, first for this node, and then for the node's children, but only if any of the following conditions are true.

        • FacesContext.getCurrentPhaseId() returns PhaseId.RESTORE_VIEW and partial state saving is enabled.

        • FacesContext.isPostback() returns false and FacesContext.getCurrentPhaseId() returns something other than PhaseId.RESTORE_VIEW

        This method must never be called by developers; a UIComponent's internal implementation will call it as components are added to or removed from a parent's child List or facet Map.

        Parameters:
        parent - The new parent, or null for the root node of a component tree

      • isRendered

        public abstract boolean isRendered()

        Return true if this component (and its children) should be rendered during the Render Response phase of the request processing lifecycle.

      • setRendered

        public abstract void setRendered(boolean rendered)

        Set the rendered property of this UIComponent.

        Parameters:
        rendered - If true render this component; otherwise, do not render this component

      • getRendererType

        public abstract String getRendererType()

        Return the Renderer type for this UIComponent (if any).

      • setRendererType

        public abstract void setRendererType(String rendererType)

        Set the Renderer type for this UIComponent, or null for components that render themselves.

        Parameters:
        rendererType - Logical identifier of the type of Renderer to use, or null for components that render themselves

      • getRendersChildren

        public abstract boolean getRendersChildren()

        Return a flag indicating whether this component is responsible for rendering its child components. The default implementation in UIComponentBase.getRendersChildren() tries to find the renderer for this component. If it does, it calls Renderer.getRendersChildren() and returns the result. If it doesn't, it returns false. As of version 1.2 of the JavaServer Faces Specification, component authors are encouraged to return true from this method and rely on UIComponentBase.encodeChildren(javax.faces.context.FacesContext).

      • getResourceBundleMap

        public Map<String,String> getResourceBundleMap()

        Return a Map<String,String> of the ResourceBundle for this component. A component may have a ResourceBundle associated with it. This bundle may contain localized properties relating to instances of this component. The default implementation first looks for a ResourceBundle with a base name equal to the fully qualified class name of the current UIComponent this and Locale equal to the Locale of the current UIViewRoot. If no such bundle is found, and the component is a composite component, let resourceName be the resourceName of the Resource for this composite component, replacing the file extension with ".properties". Let libraryName be the libraryName of the the Resource for this composite component. Call ResourceHandler.createResource(java.lang.String,java.lang.String), passing the derived resourceName and libraryName. Note that this will automatically allow for the localization of the ResourceBundle due to the localization facility implemented in createResource, which is specified in section JSF.2.6.1.3 of the spec prose document. If the resultant Resource exists and can be found, the InputStream for the resource is used to create a ResourceBundle. If either of the two previous steps for obtaining the ResourceBundle for this component is successful, the ResourceBundle is wrapped in a Map<String,String> and returned. Otherwise Collections.EMPTY_MAP is returned.

        Since:
        2.0

      • getChildren

        public abstract List<UIComponent> getChildren()

        Return a mutable List representing the child UIComponents associated with this component. The returned implementation must support all of the standard and optional List methods, plus support the following additional requirements:

        • The List implementation must implement the java.io.Serializable interface.
        • Any attempt to add a null must throw a NullPointerException
        • Any attempt to add an object that does not implement UIComponent must throw a ClassCastException.
        • Whenever a new child component is added, the parent property of the child must be set to this component instance. If the parent property of the child was already non-null, the child must first be removed from its previous parent (where it may have been either a child or a facet).
        • Whenever an existing child component is removed, the parent property of the child must be set to null.

        • After the child component has been added to the view, Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) must be called, passing PostAddToViewEvent .class as the first argument and the newly added component as the second argument if any the following cases are true.

          • FacesContext.getCurrentPhaseId() returns PhaseId.RESTORE_VIEW and partial state saving is enabled.

          • FacesContext.isPostback() returns false and FacesContext.getCurrentPhaseId() returns something other than PhaseId.RESTORE_VIEW

      • getChildCount

        public abstract int getChildCount()

        Return the number of child UIComponents that are associated with this UIComponent. If there are no children, this method must return 0. The method must not cause the creation of a child component list.

      • findComponent

        public abstract UIComponent findComponent(String expr)

        Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.

        WARNING: The found UIComponent instance, if any, is returned without regard for its tree traversal context. Retrieving an EL-bound attribute from the component is not safe. EL expressions can contain implicit objects, such as #{component}, which assume they are being evaluated within the scope of a tree traversal context. Evaluating expressions with these kinds of implicit objects outside of a tree traversal context produces undefined results. See invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) for a method that does correctly account for the tree traversal context when operating on the found UIComponent instance. invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) is also useful to find components given a simple clientId.

        Component identifiers are required to be unique within the scope of the closest ancestor NamingContainer that encloses this component (which might be this component itself). If there are no NamingContainer components in the ancestry of this component, the root component in the tree is treated as if it were a NamingContainer, whether or not its class actually implements the NamingContainer interface.

        A search expression consists of either an identifier (which is matched exactly against the id property of a UIComponent, or a series of such identifiers linked by the UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext) character value. The search algorithm should operates as follows, though alternate alogrithms may be used as long as the end result is the same:

        • Identify the UIComponent that will be the base for searching, by stopping as soon as one of the following conditions is met:
          • If the search expression begins with the the separator character (called an "absolute" search expression), the base will be the root UIComponent of the component tree. The leading separator character will be stripped off, and the remainder of the search expression will be treated as a "relative" search expression as described below.
          • Otherwise, if this UIComponent is a NamingContainer it will serve as the basis.
          • Otherwise, search up the parents of this component. If a NamingContainer is encountered, it will be the base.
          • Otherwise (if no NamingContainer is encountered) the root UIComponent will be the base.
        • The search expression (possibly modified in the previous step) is now a "relative" search expression that will be used to locate the component (if any) that has an id that matches, within the scope of the base component. The match is performed as follows:
          • If the search expression is a simple identifier, this value is compared to the id property, and then recursively through the facets and children of the base UIComponent (except that if a descendant NamingContainer is found, its own facets and children are not searched).
          • If the search expression includes more than one identifier separated by the separator character, the first identifier is used to locate a NamingContainer by the rules in the previous bullet point. Then, the findComponent() method of this NamingContainer will be called, passing the remainder of the search expression.
        Parameters:
        expr - Search expression identifying the UIComponent to be returned
        Returns:
        the found UIComponent, or null if the component was not found.
        Throws:
        IllegalArgumentException - if an intermediate identifier in a search expression identifies a UIComponent that is not a NamingContainer
        NullPointerException - if expr is null

      • invokeOnComponent

        public boolean invokeOnComponent(FacesContext context,
                        String clientId,
                        ContextCallback callback)
                          throws FacesException

        Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments. This method is similar to findComponent(java.lang.String) but it does not support the leading UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext) syntax for searching from the root of the View.

        The default implementation will first check if this.getClientId() is equal to the argument clientId. If so, first call pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent), then call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing through the FacesContext argument and passing this as the component argument. Then call popComponentFromEL(javax.faces.context.FacesContext). If an Exception is thrown by the callback, wrap it in a FacesException and re-throw it. Otherwise, return true.

        Otherwise, for each component returned by getFacetsAndChildren(), call invokeOnComponent() passing the arguments to this method, in order. The first time invokeOnComponent() returns true, abort traversing the rest of the Iterator and return true.

        When calling ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) the implementation of this method must guarantee that the state of the component passed to the callback correctly reflects the component's position in the View hierarchy with respect to any state found in the argument clientId. For example, an iterating component such as UIData will need to set its row index to correctly reflect the argument clientId before finding the appropriate child component backed by the correct row. When the callback returns, either normally or by throwing an Exception the implementation of this method must restore the state of the view to the way it was before invoking the callback.

        If none of the elements from getFacetsAndChildren() returned true from invokeOnComponent(), return false.

        Simple usage example to find a component by clientId.

private UIComponent found = null;

private void doFind(FacesContext context, String clientId) {
  context.getViewRoot().invokeOnComponent(context, clientId,
      new ContextCallback() {
         public void invokeContextCallback(FacesContext context,
                                       UIComponent component) {
           found = component;
         }
      });
}
        Parameters:
        context - the FacesContext for the current request
        clientId - the client identifier of the component to be passed to the argument callback.
        callback - an implementation of the Callback interface.
        Returns:
        true if the a component with the given clientId is found, the callback method was successfully invoked passing that component as an argument, and no Exception was thrown. Returns false if no component with the given clientId is found.
        Throws:
        NullPointerException - if any of the arguments are null
        FacesException - if the argument Callback throws an Exception, it is wrapped in a FacesException and re-thrown.
        Since:
        1.2

      • getFacets

        public abstract Map<String,UIComponent> getFacets()

        Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String). The returned implementation must support all of the standard and optional Map methods, plus support the following additional requirements:

        • The Map implementation must implement the java.io.Serializable interface.
        • Any attempt to add a null key or value must throw a NullPointerException.
        • Any attempt to add a key that is not a String must throw a ClassCastException.
        • Any attempt to add a value that is not a UIComponent must throw a ClassCastException.
        • Whenever a new facet UIComponent is added:
          • The parent property of the component must be set to this component instance.
          • If the parent property of the component was already non-null, the component must first be removed from its previous parent (where it may have been either a child or a facet).
        • Whenever an existing facet UIComponent is removed:
          • The parent property of the facet must be set to null.

      • getFacetCount

        public int getFacetCount()

        Return the number of facet UIComponents that are associated with this UIComponent. If there are no facets, this method must return 0. The method must not cause the creation of a facet component map.

        For backwards compatability with classes that extend UIComponent directly, a default implementation is provided that simply calls getFacets() and then calls the size() method on the returned Map. A more optimized version of this method is provided in UIComponentBase.getFacetCount().

        Since:
        1.2

      • getFacet

        public abstract UIComponent getFacet(String name)

        Convenience method to return the named facet, if it exists, or null otherwise. If the requested facet does not exist, the facets Map must not be created.

        Parameters:
        name - Name of the desired facet

      • getFacetsAndChildren

        public abstract Iterator<UIComponent> getFacetsAndChildren()

        Return an Iterator over the facet followed by child UIComponents of this UIComponent. Facets are returned in an undefined order, followed by all the children in the order they are stored in the child list. If this component has no facets or children, an empty Iterator is returned.

        The returned Iterator must not support the remove() operation.

      • broadcast

        public abstract void broadcast(FacesEvent event)
                        throws AbortProcessingException

        Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type. Listeners are called in the order in which they were added.

        If the event is an instance of BehaviorEvent and the current component is the source of the event call BehaviorEvent.getBehavior() to get the Behavior for the event. Call Behavior.broadcast(javax.faces.event.BehaviorEvent) on the Behavior instance.

        Parameters:
        event - The FacesEvent to be broadcast
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
        IllegalArgumentException - if the implementation class of this FacesEvent is not supported by this component
        NullPointerException - if event is null

      • decode

        public abstract void decode(FacesContext context)

        Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.

        During decoding, events may be enqueued for later processing (by event listeners who have registered an interest), by calling queueEvent().

        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • visitTree

        public boolean visitTree(VisitContext context,
                VisitCallback callback)

        Perform a tree visit starting at this node in the tree.

        UIComponent.visitTree() implementations do not invoke the VisitCallback directly, but instead call VisitContext.invokeVisitCallback(javax.faces.component.UIComponent, javax.faces.component.visit.VisitCallback) to invoke the callback. This allows VisitContext implementations to provide optimized tree traversals, for example by only calling the VisitCallback for a subset of components.

        UIComponent.visitTree() implementations must call
 UIComponent.pushComponentToEL() before performing the
 visit and UIComponent.popComponentFromEL() after the
 visit.

        Parameters:
        context - the VisitContext for this visit
        callback - the VisitCallback instance whose visit method will be called for each node visited.
        Returns:
        component implementations may return true to indicate that the tree visit is complete (eg. all components that need to be visited have been visited). This results in the tree visit being short-circuited such that no more components are visited.
        Since:
        2.0
        See Also:
        VisitContext.invokeVisitCallback()

      • isVisitable

        protected boolean isVisitable(VisitContext context)

        Return true if this component should be visited, false otherwise. Called by UIComponent.visitTree() to determine whether this component satisfies the hints returned by VisitContext.getHints().

        If this method returns false, the tree visited is short-circuited such that neither the component nor any of its descendents will be visited>

        Custom visitTree() implementations may call this method to determine whether the component is visitable before performing any visit-related processing.

        Since:
        2.0

      • encodeBegin

        public abstract void encodeBegin(FacesContext context)
                          throws IOException

        If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext. Call pushComponentToEL(javax.faces.context.FacesContext,javax.faces.component.UIComponent). Call Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object), passing PreRenderComponentEvent .class as the first argument and the component instance to be rendered as the second argument.

        • If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeBegin(FacesContext, UIComponent).

        If our rendered property is false, call pushComponentToEL(javax.faces.context.FacesContext,javax.faces.component.UIComponent) and return immediately.

Parameters:
context - FacesContext for the response we are creating
Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context is null

  • encodeChildren

    public abstract void encodeChildren(FacesContext context)
                             throws IOException

    If our rendered property is true, render the child UIComponents of this UIComponent. This method will only be called if the rendersChildren property is true.

    If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeChildren(FacesContext, UIComponent). If no Renderer is associated with this UIComponent, iterate over each of the children of this component and call encodeAll(javax.faces.context.FacesContext).

    Parameters:
    context - FacesContext for the response we are creating
    Throws:
    IOException - if an input/output error occurs while rendering
    NullPointerException - if context is null

  • encodeEnd

    public abstract void encodeEnd(FacesContext context)
                        throws IOException

    If our rendered property is true, render the ending of the current state of this UIComponent.

    If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeEnd(FacesContext, UIComponent).

    Call popComponentFromEL(javax.faces.context.FacesContext). before returning regardless of the value of the rendered property.

    Parameters:
    context - FacesContext for the response we are creating
    Throws:
    IOException - if an input/output error occurs while rendering
    NullPointerException - if context is null

  • encodeAll

    public void encodeAll(FacesContext context)
               throws IOException

    If this component returns true from isRendered(), take the following action.

    Render this component and all its children that return true from isRendered(), regardless of the value of the getRendersChildren() flag.

Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context is null
Since:
1.2

  • pushComponentToEL

    public final void pushComponentToEL(FacesContext context,
                     UIComponent component)

    Push the current UIComponent this to the FacesContext attribute map using the key CURRENT_COMPONENT saving the previous UIComponent associated with CURRENT_COMPONENT for a subsequent call to popComponentFromEL(javax.faces.context.FacesContext).

    This method and popComponentFromEL() form the basis for the contract that enables the EL Expression "#{component}" to resolve to the "current" component that is being processed in the lifecycle. The requirements for when pushComponentToEL() and popComponentFromEL() must be called are specified as needed in the javadoc for this class.

    After pushComponentToEL() returns, a call to getCurrentComponent(javax.faces.context.FacesContext) must return this UIComponent instance until popComponentFromEL() is called, after which point the previous UIComponent instance will be returned from getCurrentComponent()

    Parameters:
    context - the FacesContext for the current request
    component - the component to push to the EL. If component is null the UIComponent instance that this call was invoked upon will be pushed to the EL.
    Throws:
    NullPointerException - if context is null
    Since:
    2.0
    See Also:
    FacesContext.getAttributes()

  • popComponentFromEL

    public final void popComponentFromEL(FacesContext context)

    Pop the current UIComponent from the FacesContext attributes map so that the previous UIComponent, if any, becomes the current component.

    Parameters:
    context - the FacesContext for the current request
    Throws:
    NullPointerException - if context is null
    Since:
    2.0
    See Also:
    FacesContext.getAttributes()

  • isCompositeComponent

    public static boolean isCompositeComponent(UIComponent component)

    Return true if component is a composite component, otherwise false.

    Parameters:
    component - the UIComponent to test
    Throws:
    NullPointerException - if component is null
    Since:
    2.0

  • getCompositeComponentParent

    public static UIComponent getCompositeComponentParent(UIComponent component)

    Finds the nearest composite component parent of the specified component.

    Parameters:
    component - the component from which to start the search from
    Returns:
    if component is null, return null, otherwise search the component's parent hierachy for the nearest parent composite component. If no parent composite component is found, return null
    Since:
    2.0

  • getCurrentComponent

    public static UIComponent getCurrentComponent(FacesContext context)

    Return the UIComponent instance that is currently processing. This is equivalent to evaluating the EL expression "#{component}" and doing a getValue operation on the resultant ValueExpression.

    This method must return null if there is no currently processing UIComponent

    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null
    Since:
    2.0

  • getCurrentCompositeComponent

    public static UIComponent getCurrentCompositeComponent(FacesContext context)

    Return the closest ancestor component, relative to the component returned from getCurrentComponent(javax.faces.context.FacesContext), that is a composite component, or null if no such component exists.

    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null
    Since:
    2.0

  • addFacesListener

    protected abstract void addFacesListener(FacesListener listener)

    Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent. It is expected that UIComponent classes acting as event sources will have corresponding typesafe APIs for registering listeners of the required type, and the implementation of those registration methods will delegate to this method. For example:

     public class FooEvent extends FacesEvent { ... }

 public interface FooListener extends FacesListener {
   public void processFoo(FooEvent event);
 }

 public class FooComponent extends UIComponentBase {
   ...
   public void addFooListener(FooListener listener) {
     addFacesListener(listener);
   }
   public void removeFooListener(FooListener listener) {
     removeFacesListener(listener);
   }
   ...
 }
    Parameters:
    listener - The FacesListener to be registered
    Throws:
    NullPointerException - if listener is null

  • getFacesListeners

    protected abstract FacesListener[] getFacesListeners(Class clazz)

    Return an array of registered FacesListeners that are instances of the specified class. If there are no such registered listeners, a zero-length array is returned. The returned array can be safely be cast to an array strongly typed to an element type of clazz.

    Parameters:
    clazz - Class that must be implemented by a FacesListener for it to be returned
    Throws:
    IllegalArgumentException - if class is not, and does not implement, FacesListener
    NullPointerException - if clazz is null

  • removeFacesListener

    protected abstract void removeFacesListener(FacesListener listener)

    Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.

    Parameters:
    listener - The FacesListener to be deregistered
    Throws:
    NullPointerException - if listener is null

  • queueEvent

    public abstract void queueEvent(FacesEvent event)

    Queue an event for broadcast at the end of the current request processing lifecycle phase. The default implementation in UIComponentBase must delegate this call to the queueEvent() method of the parent UIComponent.

    Parameters:
    event - FacesEvent to be queued
    Throws:
    IllegalStateException - if this component is not a descendant of a UIViewRoot
    NullPointerException - if event is null

  • subscribeToEvent

    public void subscribeToEvent(Class<? extends SystemEvent> eventClass,
                    ComponentSystemEventListener componentListener)

    This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class. UIComponentBase provides the implementation of this method.

    Since:
    2.1

  • unsubscribeFromEvent

    public void unsubscribeFromEvent(Class<? extends SystemEvent> eventClass,
                        ComponentSystemEventListener componentListener)

    This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class. UIComponentBase provides the implementation of this method.

    Since:
    2.1

  • getListenersForEventClass

    public List<SystemEventListener> getListenersForEventClass(Class<? extends SystemEvent> eventClass)

    This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class. UIComponentBase provides the implementation of this method.

    Specified by:
    getListenersForEventClass in interface SystemEventListenerHolder
    Since:
    2.1

  • getNamingContainer

    public UIComponent getNamingContainer()

    Starting with "this", return the closest component in the ancestry that is a NamingContainer or null if none can be found.

    Since:
    2.0

  • processRestoreState

    public abstract void processRestoreState(FacesContext context,
                       Object state)

    Perform the component tree processing required by the Restore View phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

    • Call the restoreState() method of this component.
    • Call pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
    • Call the processRestoreState() method of all facets and children of this UIComponent in the order determined by a call to getFacetsAndChildren(). After returning from the processRestoreState() method on a child or facet, call popComponentFromEL(javax.faces.context.FacesContext)

    This method may not be called if the state saving method is set to server.

    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null

  • processDecodes

    public abstract void processDecodes(FacesContext context)

    Perform the component tree processing required by the Apply Request Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

    • If the rendered property of this UIComponent is false, skip further processing.
    • Call pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
    • Call the processDecodes() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren().
    • Call the decode() method of this component.
    • Call popComponentFromEL(javax.faces.context.FacesContext) from inside of a finally block, just before returning.
    • If a RuntimeException is thrown during decode processing, call FacesContext.renderResponse() and re-throw the exception.
    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null

  • processEvent

    public void processEvent(ComponentSystemEvent event)
                  throws AbortProcessingException

    The default implementation performs the following action. If the argument event is an instance of PostRestoreStateEvent, call this. getValueExpression(java.lang.String) passing the literal string “binding”, without the quotes, as the argument. If the result is non-null, set the value of the ValueExpression to be this.

    Specified by:
    processEvent in interface ComponentSystemEventListener
    Parameters:
    event - the ComponentSystemEvent instance that is being processed.
    Throws:
    AbortProcessingException - if lifecycle processing should cease for this request.

  • processValidators

    public abstract void processValidators(FacesContext context)

    Perform the component tree processing required by the Process Validations phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

    • If the rendered property of this UIComponent is false, skip further processing.
    • Call pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
    • Call the processValidators() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren().
    • After returning from calling getFacetsAndChildren() call popComponentFromEL(javax.faces.context.FacesContext).
    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null

  • processUpdates

    public abstract void processUpdates(FacesContext context)

    Perform the component tree processing required by the Update Model Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

    • If the rendered property of this UIComponent is false, skip further processing.
    • Call pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
    • Call the processUpdates() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren(). After returning from the processUpdates() method on a child or facet, call popComponentFromEL(javax.faces.context.FacesContext)
    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null

  • processSaveState

    public abstract Object processSaveState(FacesContext context)

    Perform the component tree processing required by the state saving portion of the Render Response phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

    • consult the transient property of this component. If true, just return null.
    • Call pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
    • Call the processSaveState() method of all facets and children of this UIComponent in the order determined by a call to getFacetsAndChildren(), skipping children and facets that are transient. Ensure that popComponentFromEL(javax.faces.context.FacesContext) is called correctly after each child or facet.
    • Call the saveState() method of this component.
    • Encapsulate the child state and your state into a Serializable Object and return it.

    This method may not be called if the state saving method is set to server.

    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null

  • getFacesContext

    protected abstract FacesContext getFacesContext()

    Convenience method to return the FacesContext instance for the current request.

  • getRenderer

    protected abstract Renderer getRenderer(FacesContext context)

    Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.

    Parameters:
    context - FacesContext for the current request
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIComponentBase (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIComponentBase

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    UIColumn, UICommand, UIData, UIForm, UIGraphic, UIMessage, UIMessages, UINamingContainer, UIOutput, UIPanel, UIParameter, UISelectItem, UISelectItems, UIViewAction, UIViewRoot

    public abstract class UIComponentBase
extends UIComponent

    UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.

    By default, this class defines getRendersChildren() to find the renderer for this component and call its getRendersChildren() method. The default implementation on the Renderer returns false. As of version 1.2 of the JavaServer Faces Specification, component authors are encouraged to return true from this method and rely on the implementation of encodeChildren(javax.faces.context.FacesContext) in this class and in the Renderer (Renderer.encodeChildren(javax.faces.context.FacesContext, javax.faces.component.UIComponent)). Subclasses that wish to manage the rendering of their children should override this method to return true instead.

    • Field Summary

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIComponentBase()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addClientBehavior(String eventName, ClientBehavior behavior)

      This is a default implementation of ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).
      protected void addFacesListener(FacesListener listener)
      Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent.
      void broadcast(FacesEvent event)
      Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type.
      void clearInitialState()

      For each of the attached objects on this instance that implement PartialStateHolder, call PartialStateHolder.clearInitialState() on the attached object.
      void decode(FacesContext context)
      Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.
      void encodeBegin(FacesContext context)
      If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext.
      void encodeChildren(FacesContext context)
      If our rendered property is true, render the child UIComponents of this UIComponent.
      void encodeEnd(FacesContext context)
      If our rendered property is true, render the ending of the current state of this UIComponent.
      UIComponent findComponent(String expr)
      Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.
      Map<String,Object> getAttributes()
      Return a mutable Map representing the attributes (and properties, see below) associated wth this UIComponent, keyed by attribute name (which must be a String).
      int getChildCount()
      Return the number of child UIComponents that are associated with this UIComponent.
      List<UIComponent> getChildren()
      Return a mutable List representing the child UIComponents associated with this component.
      Map<String,List<ClientBehavior>> getClientBehaviors()

      This is a default implementation of ClientBehaviorHolder.getClientBehaviors().
      String getClientId(FacesContext context)
      Return a client-side identifier for this component, generating one if necessary.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      protected FacesContext getFacesContext()
      Convenience method to return the FacesContext instance for the current request.
      protected FacesListener[] getFacesListeners(Class clazz)
      Return an array of registered FacesListeners that are instances of the specified class.
      UIComponent getFacet(String name)
      Convenience method to return the named facet, if it exists, or null otherwise.
      int getFacetCount()
      Return the number of facet UIComponents that are associated with this UIComponent.
      Map<String,UIComponent> getFacets()
      Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String).
      Iterator<UIComponent> getFacetsAndChildren()
      Return an Iterator over the facet followed by child UIComponents of this UIComponent.
      String getId()
      Return the component identifier of this UIComponent.
      List<SystemEventListener> getListenersForEventClass(Class<? extends SystemEvent> eventClass)

      Return the SystemEventListener instances registered on this UIComponent instance that are interested in events of type eventClass.
      UIComponent getParent()
      Return the parent UIComponent of this UIComponent, if any.
      Map<String,Object> getPassThroughAttributes(boolean create)

      This method has the same specification as UIComponent.getPassThroughAttributes() except that it is allowed to return null if and only if the argument create is false and no pass through attribute data structure exists for this instance.
      protected Renderer getRenderer(FacesContext context)
      Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.
      String getRendererType()
      Return the Renderer type for this UIComponent (if any).
      boolean getRendersChildren()
      Return a flag indicating whether this component is responsible for rendering its child components.
      ValueBinding getValueBinding(String name)
      Deprecated.
      This has been replaced by UIComponent.getValueExpression(java.lang.String).
      boolean invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.
      boolean isRendered()
      Return true if this component (and its children) should be rendered during the Render Response phase of the request processing lifecycle.
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void markInitialState()

      For each of the attached objects on this instance that implement PartialStateHolder, call PartialStateHolder.markInitialState() on the attached object.
      void processDecodes(FacesContext context)
      Perform the component tree processing required by the Apply Request Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      void processRestoreState(FacesContext context, Object state)
      Perform the component tree processing required by the Restore View phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      Object processSaveState(FacesContext context)
      Perform the component tree processing required by the state saving portion of the Render Response phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      void processUpdates(FacesContext context)
      Perform the component tree processing required by the Update Model Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      void processValidators(FacesContext context)
      Perform the component tree processing required by the Process Validations phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      void queueEvent(FacesEvent event)
      Queue an event for broadcast at the end of the current request processing lifecycle phase.
      protected void removeFacesListener(FacesListener listener)
      Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.
      static Object restoreAttachedState(FacesContext context, Object stateObj)
      This method is called by UIComponent subclasses that need to restore the objects they saved using saveAttachedState(javax.faces.context.FacesContext, java.lang.Object).
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      static Object saveAttachedState(FacesContext context, Object attachedObject)

      This method is called by UIComponent subclasses that want to save one or more attached objects.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setId(String id)
      Set the component identifier of this UIComponent (if any).
      void setParent(UIComponent parent)

      Set the parent UIComponent of this UIComponent.
      void setRendered(boolean rendered)
      Set the rendered property of this UIComponent.
      void setRendererType(String rendererType)
      Set the Renderer type for this UIComponent, or null for components that render themselves.
      void setTransient(boolean transientFlag)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
      void setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).
      void subscribeToEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      Install the listener instance referenced by argument componentListener as a listener for events of type eventClass originating from this specific instance of UIComponent.
      void unsubscribeFromEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      Remove the listener instance referenced by argument componentListener as a listener for events of type eventClass originating from this specific instance of UIComponent.

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getFamily, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • UIComponentBase

        public UIComponentBase()

    • Method Detail

      • getAttributes

        public Map<String,Object> getAttributes()
        Description copied from class: UIComponent

        Return a mutable Map representing the attributes (and properties, see below) associated wth this UIComponent, keyed by attribute name (which must be a String). The returned implementation must support all of the standard and optional Map methods, plus support the following additional requirements:

        • The Map implementation must implement the java.io.Serializable interface.
        • Any attempt to add a null key or value must throw a NullPointerException.
        • Any attempt to add a key that is not a String must throw a ClassCastException.
        • If the attribute name specified as a key matches a property of this UIComponent's implementation class, the following methods will have special behavior:
          • containsKey - Return false.
          • get() - If the property is readable, call the getter method and return the returned value (wrapping primitive values in their corresponding wrapper classes); otherwise throw IllegalArgumentException.
          • put() - If the property is writeable, call the setter method to set the corresponding value (unwrapping primitive values in their corresponding wrapper classes). If the property is not writeable, or an attempt is made to set a property of primitive type to null, throw IllegalArgumentException.
          • remove - Throw IllegalArgumentException.
        Specified by:
        getAttributes in class UIComponent

      • getPassThroughAttributes

        public Map<String,Object> getPassThroughAttributes(boolean create)
        Description copied from class: UIComponent

        This method has the same specification as UIComponent.getPassThroughAttributes() except that it is allowed to return null if and only if the argument create is false and no pass through attribute data structure exists for this instance. The returned Map implementation must support all of the standard and optional Map methods, plus support the following additional requirements. The map must be stored in using UIComponent.getStateHelper().

        The Map implementation must implement java.io.Serializable.

        Any attempt to add a null key or value must throw a NullPointerException.

        Any attempt to add a key that is not a String must throw an IllegalArgumentException.

        For backward compatibility with components that extend directly from this class, a default implementation is provided that returns the empty map.

        Overrides:
        getPassThroughAttributes in class UIComponent
        Parameters:
        create - if true, a new Map instance will be created if it does not exist already. If false, and there is no existing Map instance, one will not be created and null will be returned.
        Returns:
        A Map instance, or null.

      • getValueBinding

        public ValueBinding getValueBinding(String name)
        Deprecated. This has been replaced by UIComponent.getValueExpression(java.lang.String).

        Call through to UIComponent.getValueExpression(java.lang.String) and examine the result. If the result is an instance of the wrapper class mandated in UIComponent.setValueBinding(java.lang.String, javax.faces.el.ValueBinding), extract the ValueBinding instance and return it. Otherwise, wrap the result in an implementation of ValueBinding, and return it.

        Specified by:
        getValueBinding in class UIComponent
        Parameters:
        name - Name of the attribute or property for which to retrieve a ValueBinding
        Throws:
        NullPointerException - if name is null

      • setValueBinding

        public void setValueBinding(String name,
                   ValueBinding binding)
        Deprecated. This has been replaced by UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).

        Wrap the argument binding in an implementation of ValueExpression and call through to UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).

        Specified by:
        setValueBinding in class UIComponent
        Parameters:
        name - Name of the attribute or property for which to set a ValueBinding
        binding - The ValueBinding to set, or null to remove any currently set ValueBinding
        Throws:
        IllegalArgumentException - if name is one of id or parent
        NullPointerException - if name is null

      • getClientId

        public String getClientId(FacesContext context)
        Description copied from class: UIComponent

        Return a client-side identifier for this component, generating one if necessary. The associated Renderer, if any, will be asked to convert the clientId to a form suitable for transmission to the client.

        The return from this method must be the same value throughout the lifetime of the instance, unless the id property of the component is changed, or the component is placed in a NamingContainer whose client ID changes (for example, UIData). However, even in these cases, consecutive calls to this method must always return the same value. The implementation must follow these steps in determining the clientId:

        Find the closest ancestor to this component in the view hierarchy that implements NamingContainer. Call getContainerClientId() on it and save the result as the parentId local variable. Call UIComponent.getId() on this component and save the result as the myId local variable. If myId is null, call context.getViewRoot().createUniqueId() and assign the result to myId. If parentId is non-null, let myId equal parentId + UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext) + myId. Call Renderer.convertClientId(javax.faces.context.FacesContext, java.lang.String), passing myId, and return the result.

        Specified by:
        getClientId in class UIComponent
        Parameters:
        context - The FacesContext for the current request
        Throws:
        NullPointerException - if context is null

      • getId

        public String getId()
        Description copied from class: UIComponent

        Return the component identifier of this UIComponent.

        Specified by:
        getId in class UIComponent

      • setId

        public void setId(String id)
        Description copied from class: UIComponent

        Set the component identifier of this UIComponent (if any). Component identifiers must obey the following syntax restrictions:

        • Must not be a zero-length String.
        • First character must be a letter or an underscore ('_').
        • Subsequent characters must be a letter, a digit, an underscore ('_'), or a dash ('-').

        Component identifiers must also obey the following semantic restrictions (note that this restriction is NOT enforced by the setId() implementation):

        • The specified identifier must be unique among all the components (including facets) that are descendents of the nearest ancestor UIComponent that is a NamingContainer, or within the scope of the entire component tree if there is no such ancestor that is a NamingContainer.
        Specified by:
        setId in class UIComponent
        Parameters:
        id - The new component identifier, or null to indicate that this UIComponent does not have a component identifier
        Throws:
        IllegalArgumentException - if id is not syntactically valid
        IllegalStateException

      • getParent

        public UIComponent getParent()
        Description copied from class: UIComponent

        Return the parent UIComponent of this UIComponent, if any. A component must allow child components to be added to and removed from the list of children of this component, even though the child component returns null from getParent( ).

        Specified by:
        getParent in class UIComponent

      • setParent

        public void setParent(UIComponent parent)
        Description copied from class: UIComponent

        Set the parent UIComponent of this UIComponent. If parent.isInView() returns true, calling this method will first cause a PreRemoveFromViewEvent to be published, for this node, and then the children of this node. Then, once the re-parenting has occurred, a PostAddToViewEvent will be published as well, first for this node, and then for the node's children, but only if any of the following conditions are true.

        • FacesContext.getCurrentPhaseId() returns PhaseId.RESTORE_VIEW and partial state saving is enabled.

        • FacesContext.isPostback() returns false and FacesContext.getCurrentPhaseId() returns something other than PhaseId.RESTORE_VIEW

        This method must never be called by developers; a UIComponent's internal implementation will call it as components are added to or removed from a parent's child List or facet Map.

        Specified by:
        setParent in class UIComponent
        Parameters:
        parent - The new parent, or null for the root node of a component tree

      • isRendered

        public boolean isRendered()
        Description copied from class: UIComponent

        Return true if this component (and its children) should be rendered during the Render Response phase of the request processing lifecycle.

        Specified by:
        isRendered in class UIComponent

      • setRendered

        public void setRendered(boolean rendered)
        Description copied from class: UIComponent

        Set the rendered property of this UIComponent.

        Specified by:
        setRendered in class UIComponent
        Parameters:
        rendered - If true render this component; otherwise, do not render this component

      • getRendererType

        public String getRendererType()
        Description copied from class: UIComponent

        Return the Renderer type for this UIComponent (if any).

        Specified by:
        getRendererType in class UIComponent

      • setRendererType

        public void setRendererType(String rendererType)
        Description copied from class: UIComponent

        Set the Renderer type for this UIComponent, or null for components that render themselves.

        Specified by:
        setRendererType in class UIComponent
        Parameters:
        rendererType - Logical identifier of the type of Renderer to use, or null for components that render themselves

      • getRendersChildren

        public boolean getRendersChildren()
        Description copied from class: UIComponent

        Return a flag indicating whether this component is responsible for rendering its child components. The default implementation in getRendersChildren() tries to find the renderer for this component. If it does, it calls Renderer.getRendersChildren() and returns the result. If it doesn't, it returns false. As of version 1.2 of the JavaServer Faces Specification, component authors are encouraged to return true from this method and rely on encodeChildren(javax.faces.context.FacesContext).

        Specified by:
        getRendersChildren in class UIComponent

      • getChildren

        public List<UIComponent> getChildren()
        Description copied from class: UIComponent

        Return a mutable List representing the child UIComponents associated with this component. The returned implementation must support all of the standard and optional List methods, plus support the following additional requirements:

        • The List implementation must implement the java.io.Serializable interface.
        • Any attempt to add a null must throw a NullPointerException
        • Any attempt to add an object that does not implement UIComponent must throw a ClassCastException.
        • Whenever a new child component is added, the parent property of the child must be set to this component instance. If the parent property of the child was already non-null, the child must first be removed from its previous parent (where it may have been either a child or a facet).
        • Whenever an existing child component is removed, the parent property of the child must be set to null.

        • After the child component has been added to the view, Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) must be called, passing PostAddToViewEvent .class as the first argument and the newly added component as the second argument if any the following cases are true.

          • FacesContext.getCurrentPhaseId() returns PhaseId.RESTORE_VIEW and partial state saving is enabled.

          • FacesContext.isPostback() returns false and FacesContext.getCurrentPhaseId() returns something other than PhaseId.RESTORE_VIEW

        Specified by:
        getChildren in class UIComponent

      • getChildCount

        public int getChildCount()
        Description copied from class: UIComponent

        Return the number of child UIComponents that are associated with this UIComponent. If there are no children, this method must return 0. The method must not cause the creation of a child component list.

        Specified by:
        getChildCount in class UIComponent

      • findComponent

        public UIComponent findComponent(String expr)
        Description copied from class: UIComponent

        Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.

        WARNING: The found UIComponent instance, if any, is returned without regard for its tree traversal context. Retrieving an EL-bound attribute from the component is not safe. EL expressions can contain implicit objects, such as #{component}, which assume they are being evaluated within the scope of a tree traversal context. Evaluating expressions with these kinds of implicit objects outside of a tree traversal context produces undefined results. See UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) for a method that does correctly account for the tree traversal context when operating on the found UIComponent instance. UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) is also useful to find components given a simple clientId.

        Component identifiers are required to be unique within the scope of the closest ancestor NamingContainer that encloses this component (which might be this component itself). If there are no NamingContainer components in the ancestry of this component, the root component in the tree is treated as if it were a NamingContainer, whether or not its class actually implements the NamingContainer interface.

        A search expression consists of either an identifier (which is matched exactly against the id property of a UIComponent, or a series of such identifiers linked by the UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext) character value. The search algorithm should operates as follows, though alternate alogrithms may be used as long as the end result is the same:

        • Identify the UIComponent that will be the base for searching, by stopping as soon as one of the following conditions is met:
          • If the search expression begins with the the separator character (called an "absolute" search expression), the base will be the root UIComponent of the component tree. The leading separator character will be stripped off, and the remainder of the search expression will be treated as a "relative" search expression as described below.
          • Otherwise, if this UIComponent is a NamingContainer it will serve as the basis.
          • Otherwise, search up the parents of this component. If a NamingContainer is encountered, it will be the base.
          • Otherwise (if no NamingContainer is encountered) the root UIComponent will be the base.
        • The search expression (possibly modified in the previous step) is now a "relative" search expression that will be used to locate the component (if any) that has an id that matches, within the scope of the base component. The match is performed as follows:
          • If the search expression is a simple identifier, this value is compared to the id property, and then recursively through the facets and children of the base UIComponent (except that if a descendant NamingContainer is found, its own facets and children are not searched).
          • If the search expression includes more than one identifier separated by the separator character, the first identifier is used to locate a NamingContainer by the rules in the previous bullet point. Then, the findComponent() method of this NamingContainer will be called, passing the remainder of the search expression.
        Specified by:
        findComponent in class UIComponent
        Parameters:
        expr - Search expression identifying the UIComponent to be returned
        Returns:
        the found UIComponent, or null if the component was not found.
        Throws:
        NullPointerException - if expr is null

      • invokeOnComponent

        public boolean invokeOnComponent(FacesContext context,
                        String clientId,
                        ContextCallback callback)
                          throws FacesException

        Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments. This method is similar to UIComponent.findComponent(java.lang.String) but it does not support the leading UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext) syntax for searching from the root of the View.

        The default implementation will first check if this.getClientId() is equal to the argument clientId. If so, first call UIComponent.pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent), then call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing through the FacesContext argument and passing this as the component argument. Then call UIComponent.popComponentFromEL(javax.faces.context.FacesContext). If an Exception is thrown by the callback, wrap it in a FacesException and re-throw it. Otherwise, return true.

        Otherwise, for each component returned by UIComponent.getFacetsAndChildren(), call invokeOnComponent() passing the arguments to this method, in order. The first time invokeOnComponent() returns true, abort traversing the rest of the Iterator and return true.

        When calling ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) the implementation of this method must guarantee that the state of the component passed to the callback correctly reflects the component's position in the View hierarchy with respect to any state found in the argument clientId. For example, an iterating component such as UIData will need to set its row index to correctly reflect the argument clientId before finding the appropriate child component backed by the correct row. When the callback returns, either normally or by throwing an Exception the implementation of this method must restore the state of the view to the way it was before invoking the callback.

        If none of the elements from UIComponent.getFacetsAndChildren() returned true from invokeOnComponent(), return false.

        Simple usage example to find a component by clientId.

private UIComponent found = null;

private void doFind(FacesContext context, String clientId) {
  context.getViewRoot().invokeOnComponent(context, clientId,
      new ContextCallback() {
         public void invokeContextCallback(FacesContext context,
                                       UIComponent component) {
           found = component;
         }
      });
}
        Overrides:
        invokeOnComponent in class UIComponent
        Parameters:
        context - the FacesContext for the current request
        clientId - the client identifier of the component to be passed to the argument callback.
        callback - an implementation of the Callback interface.
        Returns:
        true if the a component with the given clientId is found, the callback method was successfully invoked passing that component as an argument, and no Exception was thrown. Returns false if no component with the given clientId is found.
        Throws:
        NullPointerException - if any of the arguments are null
        FacesException - if the argument Callback throws an Exception, it is wrapped in a FacesException and re-thrown.
        Since:
        1.2

      • getFacets

        public Map<String,UIComponent> getFacets()
        Description copied from class: UIComponent

        Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String). The returned implementation must support all of the standard and optional Map methods, plus support the following additional requirements:

        • The Map implementation must implement the java.io.Serializable interface.
        • Any attempt to add a null key or value must throw a NullPointerException.
        • Any attempt to add a key that is not a String must throw a ClassCastException.
        • Any attempt to add a value that is not a UIComponent must throw a ClassCastException.
        • Whenever a new facet UIComponent is added:
          • The parent property of the component must be set to this component instance.
          • If the parent property of the component was already non-null, the component must first be removed from its previous parent (where it may have been either a child or a facet).
        • Whenever an existing facet UIComponent is removed:
          • The parent property of the facet must be set to null.
        Specified by:
        getFacets in class UIComponent

      • getFacetCount

        public int getFacetCount()
        Description copied from class: UIComponent

        Return the number of facet UIComponents that are associated with this UIComponent. If there are no facets, this method must return 0. The method must not cause the creation of a facet component map.

        For backwards compatability with classes that extend UIComponent directly, a default implementation is provided that simply calls UIComponent.getFacets() and then calls the size() method on the returned Map. A more optimized version of this method is provided in getFacetCount().

        Overrides:
        getFacetCount in class UIComponent

      • getFacet

        public UIComponent getFacet(String name)
        Description copied from class: UIComponent

        Convenience method to return the named facet, if it exists, or null otherwise. If the requested facet does not exist, the facets Map must not be created.

        Specified by:
        getFacet in class UIComponent
        Parameters:
        name - Name of the desired facet

      • getFacetsAndChildren

        public Iterator<UIComponent> getFacetsAndChildren()
        Description copied from class: UIComponent

        Return an Iterator over the facet followed by child UIComponents of this UIComponent. Facets are returned in an undefined order, followed by all the children in the order they are stored in the child list. If this component has no facets or children, an empty Iterator is returned.

        The returned Iterator must not support the remove() operation.

        Specified by:
        getFacetsAndChildren in class UIComponent

      • broadcast

        public void broadcast(FacesEvent event)
               throws AbortProcessingException
        Description copied from class: UIComponent

        Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type. Listeners are called in the order in which they were added.

        If the event is an instance of BehaviorEvent and the current component is the source of the event call BehaviorEvent.getBehavior() to get the Behavior for the event. Call Behavior.broadcast(javax.faces.event.BehaviorEvent) on the Behavior instance.

        Specified by:
        broadcast in class UIComponent
        Parameters:
        event - The FacesEvent to be broadcast
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
        IllegalStateException
        NullPointerException - if event is null

      • decode

        public void decode(FacesContext context)
        Description copied from class: UIComponent

        Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.

        During decoding, events may be enqueued for later processing (by event listeners who have registered an interest), by calling queueEvent().

        Specified by:
        decode in class UIComponent
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • encodeBegin

        public void encodeBegin(FacesContext context)
                 throws IOException
        Description copied from class: UIComponent

        If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext. Call UIComponent.pushComponentToEL(javax.faces.context.FacesContext,javax.faces.component.UIComponent). Call Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object), passing PreRenderComponentEvent .class as the first argument and the component instance to be rendered as the second argument.

        • If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeBegin(FacesContext, UIComponent).

        If our rendered property is false, call UIComponent.pushComponentToEL(javax.faces.context.FacesContext,javax.faces.component.UIComponent) and return immediately.

Specified by:
encodeBegin in class UIComponent
Parameters:
context - FacesContext for the response we are creating
Throws:
NullPointerException - if context is null
IOException - if an input/output error occurs while rendering

  • encodeChildren

    public void encodeChildren(FacesContext context)
                    throws IOException
    Description copied from class: UIComponent

    If our rendered property is true, render the child UIComponents of this UIComponent. This method will only be called if the rendersChildren property is true.

    If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeChildren(FacesContext, UIComponent). If no Renderer is associated with this UIComponent, iterate over each of the children of this component and call UIComponent.encodeAll(javax.faces.context.FacesContext).

    Specified by:
    encodeChildren in class UIComponent
    Parameters:
    context - FacesContext for the response we are creating
    Throws:
    NullPointerException - if context is null
    IOException - if an input/output error occurs while rendering

  • encodeEnd

    public void encodeEnd(FacesContext context)
               throws IOException
    Description copied from class: UIComponent

    If our rendered property is true, render the ending of the current state of this UIComponent.

    If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeEnd(FacesContext, UIComponent).

    Call UIComponent.popComponentFromEL(javax.faces.context.FacesContext). before returning regardless of the value of the rendered property.

    Specified by:
    encodeEnd in class UIComponent
    Parameters:
    context - FacesContext for the response we are creating
    Throws:
    IOException - if an input/output error occurs while rendering
    NullPointerException - if context is null

  • addFacesListener

    protected void addFacesListener(FacesListener listener)

    Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent. It is expected that UIComponent classes acting as event sources will have corresponding typesafe APIs for registering listeners of the required type, and the implementation of those registration methods will delegate to this method. For example:

     public class FooEvent extends FacesEvent {
   ...
   protected boolean isAppropriateListener(FacesListener listener) {
     return (listener instanceof FooListener);
   }
   protected void processListener(FacesListener listener) {
     ((FooListener) listener).processFoo(this);
   }
   ...
 }

 public interface FooListener extends FacesListener {
   public void processFoo(FooEvent event);
 }

 public class FooComponent extends UIComponentBase {
   ...
   public void addFooListener(FooListener listener) {
     addFacesListener(listener);
   }
   public void removeFooListener(FooListener listener) {
     removeFacesListener(listener);
   }
   ...
 }
    Specified by:
    addFacesListener in class UIComponent
    Parameters:
    listener - The FacesListener to be registered
    Throws:
    NullPointerException - if listener is null

  • getFacesListeners

    protected FacesListener[] getFacesListeners(Class clazz)
    Description copied from class: UIComponent

    Return an array of registered FacesListeners that are instances of the specified class. If there are no such registered listeners, a zero-length array is returned. The returned array can be safely be cast to an array strongly typed to an element type of clazz.

    Specified by:
    getFacesListeners in class UIComponent
    Parameters:
    clazz - Class that must be implemented by a FacesListener for it to be returned
    Throws:
    IllegalArgumentException - if class is not, and does not implement, FacesListener
    NullPointerException - if clazz is null

  • removeFacesListener

    protected void removeFacesListener(FacesListener listener)

    Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.

    Specified by:
    removeFacesListener in class UIComponent
    Parameters:
    listener - The FacesListener to be deregistered
    Throws:
    NullPointerException - if listener is null

  • queueEvent

    public void queueEvent(FacesEvent event)
    Description copied from class: UIComponent

    Queue an event for broadcast at the end of the current request processing lifecycle phase. The default implementation in UIComponentBase must delegate this call to the queueEvent() method of the parent UIComponent.

    Specified by:
    queueEvent in class UIComponent
    Parameters:
    event - FacesEvent to be queued
    Throws:
    IllegalStateException - if this component is not a descendant of a UIViewRoot
    NullPointerException - if event is null

  • subscribeToEvent

    public void subscribeToEvent(Class<? extends SystemEvent> eventClass,
                    ComponentSystemEventListener componentListener)

    Install the listener instance referenced by argument componentListener as a listener for events of type eventClass originating from this specific instance of UIComponent. The default implementation creates an inner SystemEventListener instance that wraps argument componentListener as the listener argument. This inner class must call through to the argument componentListener in its implementation of SystemEventListener.processEvent(javax.faces.event.SystemEvent) and its implementation of SystemEventListener.isListenerForSource(java.lang.Object) must return true if the instance class of this UIComponent is assignable from the argument to isListenerForSource.

    Overrides:
    subscribeToEvent in class UIComponent
    Parameters:
    eventClass - the Class of event for which listener must be fired.
    componentListener - the implementation of ComponentSystemEventListener whose ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent) method must be called when events of type facesEventClass are fired.
    Throws:
    NullPointerException - if any of the arguments are null.
    Since:
    2.1

  • unsubscribeFromEvent

    public void unsubscribeFromEvent(Class<? extends SystemEvent> eventClass,
                        ComponentSystemEventListener componentListener)

    Remove the listener instance referenced by argument componentListener as a listener for events of type eventClass originating from this specific instance of UIComponent. When doing the comparison to determine if an existing listener is equal to the argument componentListener (and thus must be removed), the equals() method on the existing listener must be invoked, passing the argument componentListener, rather than the other way around.

    Overrides:
    unsubscribeFromEvent in class UIComponent
    Parameters:
    eventClass - the Class of event for which listener must be removed.
    componentListener - the implementation of ComponentSystemEventListener whose ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent) method must no longer be called when events of type eventClass are fired.
    Throws:
    NullPointerException - if any of the arguments are null.
    Since:
    2.1

  • getListenersForEventClass

    public List<SystemEventListener> getListenersForEventClass(Class<? extends SystemEvent> eventClass)

    Return the SystemEventListener instances registered on this UIComponent instance that are interested in events of type eventClass.

    Specified by:
    getListenersForEventClass in interface SystemEventListenerHolder
    Overrides:
    getListenersForEventClass in class UIComponent
    Parameters:
    eventClass - the Class of event for which the listeners must be returned.
    Throws:
    NullPointerException - if argument eventClass is null.
    Since:
    2.1

  • processDecodes

    public void processDecodes(FacesContext context)
    Description copied from class: UIComponent

    Perform the component tree processing required by the Apply Request Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

    • If the rendered property of this UIComponent is false, skip further processing.
    • Call UIComponent.pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
    • Call the processDecodes() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren().
    • Call the decode() method of this component.
    • Call UIComponent.popComponentFromEL(javax.faces.context.FacesContext) from inside of a finally block, just before returning.
    • If a RuntimeException is thrown during decode processing, call FacesContext.renderResponse() and re-throw the exception.
    Specified by:
    processDecodes in class UIComponent
    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null

  • processValidators

    public void processValidators(FacesContext context)
    Description copied from class: UIComponent

    Perform the component tree processing required by the Process Validations phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

    • If the rendered property of this UIComponent is false, skip further processing.
    • Call UIComponent.pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
    • Call the processValidators() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren().
    • After returning from calling getFacetsAndChildren() call UIComponent.popComponentFromEL(javax.faces.context.FacesContext).
    Specified by:
    processValidators in class UIComponent
    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null

  • processUpdates

    public void processUpdates(FacesContext context)
    Description copied from class: UIComponent

    Perform the component tree processing required by the Update Model Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

    • If the rendered property of this UIComponent is false, skip further processing.
    • Call UIComponent.pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
    • Call the processUpdates() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren(). After returning from the processUpdates() method on a child or facet, call UIComponent.popComponentFromEL(javax.faces.context.FacesContext)
    Specified by:
    processUpdates in class UIComponent
    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null

  • processSaveState

    public Object processSaveState(FacesContext context)
    Description copied from class: UIComponent

    Perform the component tree processing required by the state saving portion of the Render Response phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

    • consult the transient property of this component. If true, just return null.
    • Call UIComponent.pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
    • Call the processSaveState() method of all facets and children of this UIComponent in the order determined by a call to getFacetsAndChildren(), skipping children and facets that are transient. Ensure that UIComponent.popComponentFromEL(javax.faces.context.FacesContext) is called correctly after each child or facet.
    • Call the saveState() method of this component.
    • Encapsulate the child state and your state into a Serializable Object and return it.

    This method may not be called if the state saving method is set to server.

    Specified by:
    processSaveState in class UIComponent
    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null

  • processRestoreState

    public void processRestoreState(FacesContext context,
                       Object state)
    Description copied from class: UIComponent

    Perform the component tree processing required by the Restore View phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

    • Call the restoreState() method of this component.
    • Call UIComponent.pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
    • Call the processRestoreState() method of all facets and children of this UIComponent in the order determined by a call to getFacetsAndChildren(). After returning from the processRestoreState() method on a child or facet, call UIComponent.popComponentFromEL(javax.faces.context.FacesContext)

    This method may not be called if the state saving method is set to server.

    Specified by:
    processRestoreState in class UIComponent
    Parameters:
    context - FacesContext for the request we are processing
    Throws:
    NullPointerException - if context is null

  • getFacesContext

    protected FacesContext getFacesContext()
    Description copied from class: UIComponent

    Convenience method to return the FacesContext instance for the current request.

    Specified by:
    getFacesContext in class UIComponent

  • getRenderer

    protected Renderer getRenderer(FacesContext context)
    Description copied from class: UIComponent

    Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.

    Specified by:
    getRenderer in class UIComponent
    Parameters:
    context - FacesContext for the current request

  • markInitialState

    public void markInitialState()

    For each of the attached objects on this instance that implement PartialStateHolder, call PartialStateHolder.markInitialState() on the attached object.

    Specified by:
    markInitialState in interface PartialStateHolder
    Overrides:
    markInitialState in class UIComponent
    Since:
    2.0

  • clearInitialState

    public void clearInitialState()

    For each of the attached objects on this instance that implement PartialStateHolder, call PartialStateHolder.clearInitialState() on the attached object.

    Specified by:
    clearInitialState in interface PartialStateHolder
    Overrides:
    clearInitialState in class UIComponent
    Since:
    2.0

  • saveState

    public Object saveState(FacesContext context)
    Description copied from interface: StateHolder

    Gets the state of the instance as a Serializable Object.

    If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

    This method must not alter the state of the implementing object. In other words, after executing this code:

     Object state = component.saveState(facesContext);

    component should be the same as before executing it.

    The return from this method must be Serializable

  • restoreState

    public void restoreState(FacesContext context,
                Object state)
    Description copied from interface: StateHolder

    Perform any processing required to restore the state from the entries in the state Object.

    If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

    If the state argument is null, take no action and return.

  • isTransient

    public boolean isTransient()
    Description copied from interface: StateHolder

    If true, the Object implementing this interface must not participate in state saving or restoring.

  • setTransient

    public void setTransient(boolean transientFlag)
    Description copied from interface: StateHolder

    Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

    Parameters:
    transientFlag - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.

  • saveAttachedState

    public static Object saveAttachedState(FacesContext context,
                       Object attachedObject)

    This method is called by UIComponent subclasses that want to save one or more attached objects. It is a convenience method that does the work of saving attached objects that may or may not implement the StateHolder interface. Using this method implies the use of restoreAttachedState(javax.faces.context.FacesContext, java.lang.Object) to restore the attached objects.

    This method supports saving attached objects of the following type: Objects, null values, and Collections of these objects. If any contained objects are not Collections and do not implement StateHolder, they must have zero-argument public constructors. The exact structure of the returned object is undefined and opaque, but will be serializable.

    Parameters:
    context - the FacesContext for this request.
    attachedObject - the object, which may be a List instance, or an Object. The attachedObject (or the elements that comprise attachedObject may implement StateHolder.
    Throws:
    NullPointerException - if the context argument is null.

  • restoreAttachedState

    public static Object restoreAttachedState(FacesContext context,
                          Object stateObj)
                                   throws IllegalStateException

    This method is called by UIComponent subclasses that need to restore the objects they saved using saveAttachedState(javax.faces.context.FacesContext, java.lang.Object). This method is tightly coupled with saveAttachedState(javax.faces.context.FacesContext, java.lang.Object).

    This method supports restoring all attached objects types supported by saveAttachedState(javax.faces.context.FacesContext, java.lang.Object).

    Parameters:
    context - the FacesContext for this request
    stateObj - the opaque object returned from saveAttachedState(javax.faces.context.FacesContext, java.lang.Object)
    Throws:
    NullPointerException - if context is null.
    IllegalStateException - if the object is not previously returned by saveAttachedState(javax.faces.context.FacesContext, java.lang.Object).

  • addClientBehavior

    public void addClientBehavior(String eventName,
                     ClientBehavior behavior)

    This is a default implementation of ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

    Parameters:
    eventName - the logical name of the client-side event to attach the behavior to.
    behavior - the Behavior instance to attach for the specified event name.
    Since:
    2.0

  • getEventNames

    public Collection<String> getEventNames()

    This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

    Since:
    2.0

  • getClientBehaviors

    public Map<String,List<ClientBehavior>> getClientBehaviors()

    This is a default implementation of ClientBehaviorHolder.getClientBehaviors(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must add an implementation of ClientBehaviorHolder.getEventNames().

    Since:
    2.0

  • getDefaultEventName

    public String getDefaultEventName()

    This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIData (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIData

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIData
  • All Implemented Interfaces:
    EventListener, NamingContainer, PartialStateHolder, StateHolder, TransientStateHolder, UniqueIdVendor, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlDataTable

    public class UIData
extends UIComponentBase
implements NamingContainer, UniqueIdVendor

    UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression). During iterative processing over the rows of data in the data model, the object for the current row is exposed as a request attribute under the key specified by the var property.

    Only children of type UIColumn should be processed by renderers associated with this component.

    By default, the rendererType property is set to javax.faces.Table. This value can be changed by calling the setRendererType() method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

      • Fields inherited from interface javax.faces.component.NamingContainer

        SEPARATOR_CHAR

    • Constructor Summary

      Constructors
      Constructor and Description
      UIData()
      Create a new UIData instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void broadcast(FacesEvent event)
      Override the default UIComponentBase.broadcast(javax.faces.event.FacesEvent) processing to unwrap any wrapped FacesEvent and reset the current row index, before the event is actually broadcast.
      String createUniqueId(FacesContext context, String seed)
      Generate an identifier for a component.
      void encodeBegin(FacesContext context)
      In addition to the default behavior, ensure that any saved per-row state for our child input components is discarded unless it is needed to rerender the current page with errors.
      String getClientId(FacesContext context)
      Return a client identifier for this component that includes the current value of the rowIndex property, if it is not set to -1.
      protected DataModel getDataModel()
      Return the internal DataModel object representing the data objects that we will iterate over in this component's rendering.
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      int getFirst()
      Return the zero-relative row number of the first row to be displayed.
      UIComponent getFooter()
      Return the footer facet of this component (if any).
      UIComponent getHeader()
      Return the header facet of this component (if any).
      int getRowCount()
      Return the number of rows in the underlying data model.
      Object getRowData()
      Return the data object representing the data for the currently selected row index, if any.
      int getRowIndex()
      Return the zero-relative index of the currently selected row.
      int getRows()
      Return the number of rows to be displayed, or zero for all remaining rows in the table.
      Object getValue()
      Return the value of the UIData.
      String getVar()
      Return the request-scope attribute under which the data object for the current row will be exposed when iterating.
      boolean invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Override behavior from UIComponentBase.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) to provide special care for positioning the data properly before finding the component and invoking the callback on it.
      boolean isRowAvailable()
      Return a flag indicating whether there is rowData available at the current rowIndex.
      boolean isRowStatePreserved()

      Return the value of the rowStatePreserved JavaBeans property.
      void markInitialState()

      Override the base class method to take special action if the method is being invoked when StateManager.IS_BUILDING_INITIAL_STATE is true and the rowStatePreserved JavaBeans property for this instance is true.
      void processDecodes(FacesContext context)
      Override the default UIComponentBase.processDecodes(javax.faces.context.FacesContext) processing to perform the following steps.
      void processUpdates(FacesContext context)
      Override the default UIComponentBase.processUpdates(javax.faces.context.FacesContext) processing to perform the following steps.
      void processValidators(FacesContext context)
      Override the default UIComponentBase.processValidators(javax.faces.context.FacesContext) processing to perform the following steps.
      void queueEvent(FacesEvent event)
      Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) processing to wrap any queued events in a wrapper so that we can reset the current row index in broadcast().
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      protected void setDataModel(DataModel dataModel)
      Set the internal DataModel.
      void setFirst(int first)
      Set the zero-relative row number of the first row to be displayed.
      void setFooter(UIComponent footer)
      Set the footer facet of this component.
      void setHeader(UIComponent header)
      Set the header facet of this component.
      void setRowIndex(int rowIndex)
      Set the zero relative index of the current row, or -1 to indicate that no row is currently selected, by implementing the following algorithm.
      void setRows(int rows)
      Set the number of rows to be displayed, or zero for all remaining rows in the table.
      void setRowStatePreserved(boolean preserveComponentState)

      If this property is set to true, the UIData must take steps to ensure that modifications to its iterated children will be preserved on a per-row basis.
      void setValue(Object value)
      Set the value of the UIData.
      void setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
      void setValueExpression(String name, ValueExpression binding)
      Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.
      void setVar(String var)
      Set the request-scope attribute under which the data object for the current row wil be exposed when iterating.
      boolean visitTree(VisitContext context, VisitCallback callback)

      Override the behavior in UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback) to handle iteration correctly.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, clearInitialState, decode, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, isRendered, isTransient, processRestoreState, processSaveState, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIData

        public UIData()

        Create a new UIData instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getFirst

        public int getFirst()

        Return the zero-relative row number of the first row to be displayed.

      • setFirst

        public void setFirst(int first)

        Set the zero-relative row number of the first row to be displayed.

        Parameters:
        first - New first row number
        Throws:
        IllegalArgumentException - if first is negative

      • getFooter

        public UIComponent getFooter()

        Return the footer facet of this component (if any). A convenience method for getFacet("footer").

      • setFooter

        public void setFooter(UIComponent footer)

        Set the footer facet of this component. A convenience method for getFacets().put("footer", footer).

        Parameters:
        footer - the new footer facet
        Throws:
        NullPointerException - if footer is null

      • getHeader

        public UIComponent getHeader()

        Return the header facet of this component (if any). A convenience method for getFacet("header").

      • setHeader

        public void setHeader(UIComponent header)

        Set the header facet of this component. A convenience method for getFacets().put("header", header).

        Parameters:
        header - the new header facet
        Throws:
        NullPointerException - if header is null

      • isRowAvailable

        public boolean isRowAvailable()

        Return a flag indicating whether there is rowData available at the current rowIndex. If no wrappedData is available, return false.

        Throws:
        FacesException - if an error occurs getting the row availability

      • getRowCount

        public int getRowCount()

        Return the number of rows in the underlying data model. If the number of available rows is unknown, return -1.

        Throws:
        FacesException - if an error occurs getting the row count

      • getRowData

        public Object getRowData()

        Return the data object representing the data for the currently selected row index, if any.

        Throws:
        FacesException - if an error occurs getting the row data
        IllegalArgumentException - if now row data is available at the currently specified row index

      • getRowIndex

        public int getRowIndex()

        Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, return -1. This property is not enabled for value binding expressions.

        Throws:
        FacesException - if an error occurs getting the row index

      • setRowIndex

        public void setRowIndex(int rowIndex)

        Set the zero relative index of the current row, or -1 to indicate that no row is currently selected, by implementing the following algorithm. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

        To support transient state among descendents, please consult the specification for setRowStatePreserved(boolean), which details the requirements for setRowIndex() when the rowStatePreserved JavaBeans property is set to true.

        • Save current state information for all descendant components (as described below).
        • Store the new row index, and pass it on to the DataModel associated with this UIData instance.
        • If the new rowIndex value is -1:
          • If the var property is not null, remove the corresponding request scope attribute (if any).
          • Reset the state information for all descendant components (as described below).
        • If the new rowIndex value is not -1:
          • If the var property is not null, call getRowData() and expose the resulting data object as a request scope attribute whose key is the var property value.
          • Reset the state information for all descendant components (as described below).

        To save current state information for all descendant components, UIData must maintain per-row information for each descendant as follows:

        • If the descendant is an instance of EditableValueHolder, save the state of its localValue property.
        • If the descendant is an instance of EditableValueHolder, save the state of the localValueSet property.
        • If the descendant is an instance of EditableValueHolder, save the state of the valid property.
        • If the descendant is an instance of EditableValueHolder, save the state of the submittedValue property.

        To restore current state information for all descendant components, UIData must reference its previously stored information for the current rowIndex and call setters for each descendant as follows:

        • If the descendant is an instance of EditableValueHolder, restore the value property.
        • If the descendant is an instance of EditableValueHolder, restore the state of the localValueSet property.
        • If the descendant is an instance of EditableValueHolder, restore the state of the valid property.
        • If the descendant is an instance of EditableValueHolder, restore the state of the submittedValue property.
        Parameters:
        rowIndex - The new row index value, or -1 for no associated row
        Throws:
        FacesException - if an error occurs setting the row index
        IllegalArgumentException - if rowIndex is less than -1

      • getRows

        public int getRows()

        Return the number of rows to be displayed, or zero for all remaining rows in the table. The default value of this property is zero.

      • setRows

        public void setRows(int rows)

        Set the number of rows to be displayed, or zero for all remaining rows in the table.

        Parameters:
        rows - New number of rows
        Throws:
        IllegalArgumentException - if rows is negative

      • getVar

        public String getVar()

        Return the request-scope attribute under which the data object for the current row will be exposed when iterating. This property is not enabled for value binding expressions.

      • setVar

        public void setVar(String var)

        Set the request-scope attribute under which the data object for the current row wil be exposed when iterating.

        Parameters:
        var - The new request-scope attribute name

      • isRowStatePreserved

        public boolean isRowStatePreserved()

        Return the value of the rowStatePreserved JavaBeans property. See setRowStatePreserved(boolean).

        Since:
        2.1

      • setRowStatePreserved

        public void setRowStatePreserved(boolean preserveComponentState)

        If this property is set to true, the UIData must take steps to ensure that modifications to its iterated children will be preserved on a per-row basis. This allows applications to modify component properties, such as the style-class, for a specific row, rather than having such modifications apply to all rows.

        To accomplish this, UIData must call StateHolder.saveState(javax.faces.context.FacesContext) and TransientStateHolder.saveTransientState(javax.faces.context.FacesContext) on its children to capture their state on exiting each row. When re-entering the row, StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) and TransientStateHolder.restoreTransientState(javax.faces.context.FacesContext, java.lang.Object) must be called in order to reinitialize the children to the correct state for the new row. All of this action must take place during the processing of setRowIndex(int).

        Users should consider enabling this feature for cases where it is necessary to modify properties of UIData's children in a row-specific way. Note, however, that row-level state saving/restoring does add overhead. As such, this feature should be used judiciously.

        Since:
        2.1

      • getValue

        public Object getValue()

        Return the value of the UIData. This value must either be be of type DataModel, or a type that can be adapted into a DataModel. UIData will automatically adapt the following types:

        • Arrays
        • java.util.List
        • java.sql.ResultSet
        • javax.servlet.jsp.jstl.sql.Result
        • java.util.Collection

        All other types will be adapted using the ScalarDataModel class, which will treat the object as a single row of data.

      • setValue

        public void setValue(Object value)

        Set the value of the UIData. This value must either be be of type DataModel, or a type that can be adapted into a DataModel.

        Parameters:
        value - the new value

      • setValueBinding

        public void setValueBinding(String name,
                   ValueBinding binding)
        Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

        If "name" is something other than "value", "var", or "rowIndex", rely on the superclass conversion from ValueBinding to ValueExpression.

        Overrides:
        setValueBinding in class UIComponentBase
        Parameters:
        name - Name of the attribute or property for which to set a ValueBinding
        binding - The ValueBinding to set, or null to remove any currently set ValueBinding
        Throws:
        IllegalArgumentException - if name is one of id, parent, var, or rowIndex
        NullPointerException - if name is null

      • setValueExpression

        public void setValueExpression(String name,
                      ValueExpression binding)

        Set the ValueExpression used to calculate the value for the specified attribute or property name, if any. In addition, if a ValueExpression is set for the value property, remove any synthesized DataModel for the data previously bound to this component.

        Overrides:
        setValueExpression in class UIComponent
        Parameters:
        name - Name of the attribute or property for which to set a ValueExpression
        binding - The ValueExpression to set, or null to remove any currently set ValueExpression
        Throws:
        IllegalArgumentException - if name is one of id, parent, var, or rowIndex
        NullPointerException - if name is null
        Since:
        1.2

      • getClientId

        public String getClientId(FacesContext context)

        Return a client identifier for this component that includes the current value of the rowIndex property, if it is not set to -1. This implies that multiple calls to getClientId() may return different results, but ensures that child components can themselves generate row-specific client identifiers (since UIData is a NamingContainer).

        Overrides:
        getClientId in class UIComponentBase
        Parameters:
        context - The FacesContext for the current request
        Throws:
        NullPointerException - if context is null

      • invokeOnComponent

        public boolean invokeOnComponent(FacesContext context,
                        String clientId,
                        ContextCallback callback)
                          throws FacesException

        Override behavior from UIComponentBase.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) to provide special care for positioning the data properly before finding the component and invoking the callback on it. If the argument clientId is equal to this.getClientId() simply invoke the contextCallback, passing the context argument and this as arguments, and return true. If the argument clientId is not equal to this.getClientId(), inspect each of the facet children of this UIData instance and for each one, compare its clientId with the argument clientId. If there is a match, invoke the contextCallback, passing the context argument and this as arguments, and return true. Otherwise, attempt to extract a rowIndex from the clientId. For example, if the argument clientId was form:data:3:customerHeader the rowIndex would be 3. Let this value be called newIndex. The current rowIndex of this instance must be saved aside and restored before returning in all cases, regardless of the outcome of the search or if any exceptions are thrown in the process.

        The implementation of this method must never return true if setting the rowIndex of this instance to be equal to newIndex causes this instance to return false from isRowAvailable().

        Overrides:
        invokeOnComponent in class UIComponentBase
        Parameters:
        context - the FacesContext for the current request
        clientId - the client identifier of the component to be passed to the argument callback.
        callback - an implementation of the Callback interface.
        Returns:
        true if the a component with the given clientId is found, the callback method was successfully invoked passing that component as an argument, and no Exception was thrown. Returns false if no component with the given clientId is found.
        Throws:
        NullPointerException - if any of the arguments are null
        FacesException - if the argument Callback throws an Exception, it is wrapped in a FacesException and re-thrown. Also throws FacesException if any exception is thrown when deriving the rowIndex from the argument clientId.
        Since:
        1.2

      • queueEvent

        public void queueEvent(FacesEvent event)

        Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) processing to wrap any queued events in a wrapper so that we can reset the current row index in broadcast().

        Overrides:
        queueEvent in class UIComponentBase
        Parameters:
        event - FacesEvent to be queued
        Throws:
        IllegalStateException - if this component is not a descendant of a UIViewRoot
        NullPointerException - if event is null

      • broadcast

        public void broadcast(FacesEvent event)
               throws AbortProcessingException

        Override the default UIComponentBase.broadcast(javax.faces.event.FacesEvent) processing to unwrap any wrapped FacesEvent and reset the current row index, before the event is actually broadcast. For events that we did not wrap (in queueEvent()), default processing will occur.

        Overrides:
        broadcast in class UIComponentBase
        Parameters:
        event - The FacesEvent to be broadcast
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
        IllegalArgumentException - if the implementation class of this FacesEvent is not supported by this component
        NullPointerException - if event is null

      • encodeBegin

        public void encodeBegin(FacesContext context)
                 throws IOException

        In addition to the default behavior, ensure that any saved per-row state for our child input components is discarded unless it is needed to rerender the current page with errors.

        Overrides:
        encodeBegin in class UIComponentBase
        Parameters:
        context - FacesContext for the current request
        Throws:
        IOException - if an input/output error occurs while rendering
        NullPointerException - if context is null

      • processDecodes

        public void processDecodes(FacesContext context)

        Override the default UIComponentBase.processDecodes(javax.faces.context.FacesContext) processing to perform the following steps.

        • If the rendered property of this UIComponent is false, skip further processing.
        • Set the current rowIndex to -1.
        • Call the processDecodes() method of all facets of this UIData, in the order determined by a call to getFacets().keySet().iterator().
        • Call the processDecodes() method of all facets of the UIColumn children of this UIData.
        • Iterate over the set of rows that were included when this component was rendered (i.e. those defined by the first and rows properties), performing the following processing for each row:
          • Set the current rowIndex to the appropriate value for this row.
          • If isRowAvailable() returns true, iterate over the children components of each UIColumn child of this UIData component, calling the processDecodes() method for each such child.
        • Set the current rowIndex to -1.
        • Call the decode() method of this component.
        • If a RuntimeException is thrown during decode processing, call FacesContext.renderResponse() and re-throw the exception.
        Overrides:
        processDecodes in class UIComponentBase
        Parameters:
        context - FacesContext for the current request
        Throws:
        NullPointerException - if context is null

      • processValidators

        public void processValidators(FacesContext context)

        Override the default UIComponentBase.processValidators(javax.faces.context.FacesContext) processing to perform the following steps.

        • If the rendered property of this UIComponent is false, skip further processing.
        • Set the current rowIndex to -1.
        • Call the processValidators() method of all facets of this UIData, in the order determined by a call to getFacets().keySet().iterator().
        • Call the processValidators() method of all facets of the UIColumn children of this UIData.
        • Iterate over the set of rows that were included when this component was rendered (i.e. those defined by the first and rows properties), performing the following processing for each row:
          • Set the current rowIndex to the appropriate value for this row.
          • If isRowAvailable() returns true, iterate over the children components of each UIColumn child of this UIData component, calling the processValidators() method for each such child.
        • Set the current rowIndex to -1.
        Overrides:
        processValidators in class UIComponentBase
        Parameters:
        context - FacesContext for the current request
        Throws:
        NullPointerException - if context is null

      • processUpdates

        public void processUpdates(FacesContext context)

        Override the default UIComponentBase.processUpdates(javax.faces.context.FacesContext) processing to perform the following steps.

        • If the rendered property of this UIComponent is false, skip further processing.
        • Set the current rowIndex to -1.
        • Call the processUpdates() method of all facets of this UIData, in the order determined by a call to getFacets().keySet().iterator().
        • Call the processUpdates() method of all facets of the UIColumn children of this UIData.
        • Iterate over the set of rows that were included when this component was rendered (i.e. those defined by the first and rows properties), performing the following processing for each row:
          • Set the current rowIndex to the appropriate value for this row.
          • If isRowAvailable() returns true, iterate over the children components of each UIColumn child of this UIData component, calling the processUpdates() method for each such child.
        • Set the current rowIndex to -1.
        Overrides:
        processUpdates in class UIComponentBase
        Parameters:
        context - FacesContext for the current request
        Throws:
        NullPointerException - if context is null

      • createUniqueId

        public String createUniqueId(FacesContext context,
                    String seed)
        Description copied from interface: UniqueIdVendor

        Generate an identifier for a component. The identifier will be prefixed with UNIQUE_ID_PREFIX, and will be unique within this component-container. Optionally, a unique seed value can be supplied by component creators which should be included in the generated unique id.

        Specified by:
        createUniqueId in interface UniqueIdVendor
        Parameters:
        context - FacesContext
        seed - an optional seed value - e.g. based on the position of the component in the VDL-template
        Returns:
        a unique-id in this component-container

      • visitTree

        public boolean visitTree(VisitContext context,
                VisitCallback callback)

        Override the behavior in UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback) to handle iteration correctly.

        If the UIComponent.isVisitable(javax.faces.component.visit.VisitContext) method of this instance returns false, take no action and return.

        Call UIComponent.pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent) and invoke the visit callback on this UIData instance as described in UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback). Let the result of the invoctaion be visitResult. If visitResult is VisitResult.COMPLETE, take no further action and return true. Otherwise, determine if we need to visit our children. The default implementation calls VisitContext.getSubtreeIdsToVisit(javax.faces.component.UIComponent) passing this as the argument. If the result of that call is non-empty, let doVisitChildren be true. If doVisitChildren is true and visitResult is VisitResult.ACCEPT, take the following action.

        • If this component has facets, call UIComponent.getFacets() on this instance and invoke the values() method. For each UIComponent in the returned Map, call UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback).

        • If this component has children, for each UIColumn child:

          Call VisitContext.invokeVisitCallback(javax.faces.component.UIComponent, javax.faces.component.visit.VisitCallback) on that UIColumn instance. If such a call returns true, terminate visiting and return true from this method.

          If the child UIColumn has facets, call UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback) on each one.

          Take no action on non-UIColumn children.

        • Save aside the result of a call to getRowIndex().

          For each child component of this UIData that is also an instance of UIColumn,

          Iterate over the rows.

          • Let rowsToProcess be the return from getRows().

          • Let rowIndex be the return from getFirst() - 1.

          • While the number of rows processed is less than rowsToProcess, take the following actions.

            Call setRowIndex(int), passing the current row index.

            If isRowAvailable() returns false, take no further action and return false.

            Call UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback) on each of the children of this UIColumn instance.

        Call UIComponent.popComponentFromEL(javax.faces.context.FacesContext) and restore the saved row index with a call to setRowIndex(int).

        Return false to allow the visiting to continue.

        Overrides:
        visitTree in class UIComponent
        Parameters:
        context - the VisitContext that provides context for performing the visit.
        callback - the callback to be invoked for each node encountered in the visit.
        Returns:
        component implementations may return true to indicate that the tree visit is complete (eg. all components that need to be visited have been visited). This results in the tree visit being short-circuited such that no more components are visited.
Throws:
NullPointerException - if any of the parameters are null.
See Also:
VisitContext.invokeVisitCallback()

  • markInitialState

    public void markInitialState()

    Override the base class method to take special action if the method is being invoked when StateManager.IS_BUILDING_INITIAL_STATE is true and the rowStatePreserved JavaBeans property for this instance is true.

    The additional action taken is to traverse the descendents and save their state without regard to any particular row value.

    Specified by:
    markInitialState in interface PartialStateHolder
    Overrides:
    markInitialState in class UIComponentBase
    Since:
    2.1

  • restoreState

    public void restoreState(FacesContext context,
                Object state)
    Description copied from interface: StateHolder

    Perform any processing required to restore the state from the entries in the state Object.

    If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

    If the state argument is null, take no action and return.

    Specified by:
    restoreState in interface StateHolder
    Overrides:
    restoreState in class UIComponentBase

  • saveState

    public Object saveState(FacesContext context)
    Description copied from interface: StateHolder

    Gets the state of the instance as a Serializable Object.

    If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

    This method must not alter the state of the implementing object. In other words, after executing this code:

     Object state = component.saveState(facesContext);

    component should be the same as before executing it.

    The return from this method must be Serializable

    Specified by:
    saveState in interface StateHolder
    Overrides:
    saveState in class UIComponentBase

  • getDataModel

    protected DataModel getDataModel()

    Return the internal DataModel object representing the data objects that we will iterate over in this component's rendering.

    If the model has been cached by a previous call to setDataModel(javax.faces.model.DataModel), return it. Otherwise call getValue(). If the result is null, create an empty ListDataModel and return it. If the result is an instance of DataModel, return it. Otherwise, adapt the result as described in getValue() and return it.

  • setDataModel

    protected void setDataModel(DataModel dataModel)

    Set the internal DataModel. This UIData instance must use the given DataModel as its internal value representation from now until the next call to setDataModel. If the given DataModel is null, the internal DataModel must be reset in a manner so that the next call to getDataModel() causes lazy instantion of a newly refreshed DataModel.

    Subclasses might call this method if they either want to restore the internal DataModel during the Restore View phase or if they want to explicitly refresh the current DataModel for the Render Response phase.

    Parameters:
    dataModel - the new DataModel or null to cause the model to be refreshed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIForm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIForm

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIForm
  • All Implemented Interfaces:
    EventListener, NamingContainer, PartialStateHolder, StateHolder, TransientStateHolder, UniqueIdVendor, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlForm

    public class UIForm
extends UIComponentBase
implements NamingContainer, UniqueIdVendor

    UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.

    By default, the rendererType property must be set to "javax.faces.Form". This value can be changed by calling the setRendererType() method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

      • Fields inherited from interface javax.faces.component.NamingContainer

        SEPARATOR_CHAR

    • Constructor Summary

      Constructors
      Constructor and Description
      UIForm()
      Create a new UIForm instance with default property values.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      String createUniqueId(FacesContext context, String seed)

      Generate an identifier for a component.
      String getContainerClientId(FacesContext context)
      Override the UIComponent.getContainerClientId(javax.faces.context.FacesContext) to allow users to disable this form from prepending its clientId to its descendent's clientIds depending on the value of this form's isPrependId() property.
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      boolean isPrependId()
      The prependId flag.
      boolean isSubmitted()
      Returns the current value of the submitted property.
      void processDecodes(FacesContext context)
      Override UIComponent.processDecodes(javax.faces.context.FacesContext) to ensure that the form is decoded before its children.
      void processUpdates(FacesContext context)
      Override UIComponent.processUpdates(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if isSubmitted() returns true.
      void processValidators(FacesContext context)
      Override UIComponent.processValidators(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if isSubmitted() returns true.
      void | setPrependId(boolean prependId)
      void setSubmitted(boolean submitted)
      If this UIForm instance (as opposed to other forms in the page) is experiencing a submit during this request processing lifecycle, this method must be called, with true as the argument, during the UIComponent.decode(javax.faces.context.FacesContext) for this UIForm instance.
      boolean visitTree(VisitContext context, VisitCallback callback)

      Perform a tree visit starting at this node in the tree.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIForm

        public UIForm()

        Create a new UIForm instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • isSubmitted

        public boolean isSubmitted()

        Returns the current value of the submitted property. The default value is false. See setSubmitted(boolean) for details.

        This property must be kept as a transient property using the UIComponent.getTransientStateHelper().

      • setSubmitted

        public void setSubmitted(boolean submitted)

        If this UIForm instance (as opposed to other forms in the page) is experiencing a submit during this request processing lifecycle, this method must be called, with true as the argument, during the UIComponent.decode(javax.faces.context.FacesContext) for this UIForm instance. If this UIForm instance is not experiencing a submit, this method must be called, with false as the argument, during the UIComponent.decode(javax.faces.context.FacesContext) for this UIForm instance.

        The value of a UIForm's submitted property must not be saved as part of its state.

        This property must be kept as a transient property using the UIComponent.getTransientStateHelper().

      • isPrependId

        public boolean isPrependId()

        The prependId flag.

      • setPrependId

        public void setPrependId(boolean prependId)

      • processDecodes

        public void processDecodes(FacesContext context)

        Override UIComponent.processDecodes(javax.faces.context.FacesContext) to ensure that the form is decoded before its children. This is necessary to allow the submitted property to be correctly set.

        Overrides:
        processDecodes in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • processValidators

        public void processValidators(FacesContext context)

        Override UIComponent.processValidators(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if isSubmitted() returns true.

        Overrides:
        processValidators in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • processUpdates

        public void processUpdates(FacesContext context)

        Override UIComponent.processUpdates(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if isSubmitted() returns true.

        Overrides:
        processUpdates in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • createUniqueId

        public String createUniqueId(FacesContext context,
                    String seed)

        Generate an identifier for a component. The identifier will be prefixed with UNIQUE_ID_PREFIX, and will be unique within this component-container. Optionally, a unique seed value can be supplied by component creators which should be included in the generated unique id.

        If the prependId property has the value false, this method must call createUniqueId on the next ancestor UniqueIdVendor.

        Specified by:
        createUniqueId in interface UniqueIdVendor
        Parameters:
        context - FacesContext
        seed - an optional seed value - e.g. based on the position of the component in the VDL-template
        Returns:
        a unique-id in this component-container

      • getContainerClientId

        public String getContainerClientId(FacesContext context)

        Override the UIComponent.getContainerClientId(javax.faces.context.FacesContext) to allow users to disable this form from prepending its clientId to its descendent's clientIds depending on the value of this form's isPrependId() property.

        Overrides:
        getContainerClientId in class UIComponent

      • visitTree

        public boolean visitTree(VisitContext context,
                VisitCallback callback)
        Description copied from class: UIComponent

        Perform a tree visit starting at this node in the tree.

        UIComponent.visitTree() implementations do not invoke the VisitCallback directly, but instead call VisitContext.invokeVisitCallback(javax.faces.component.UIComponent, javax.faces.component.visit.VisitCallback) to invoke the callback. This allows VisitContext implementations to provide optimized tree traversals, for example by only calling the VisitCallback for a subset of components.

        UIComponent.visitTree() implementations must call
 UIComponent.pushComponentToEL() before performing the
 visit and UIComponent.popComponentFromEL() after the
 visit.

        Overrides:
        visitTree in class UIComponent
        Parameters:
        context - the VisitContext for this visit
        callback - the VisitCallback instance whose visit method will be called for each node visited.
        Returns:
        component implementations may return true to indicate that the tree visit is complete (eg. all components that need to be visited have been visited). This results in the tree visit being short-circuited such that no more components are visited.
        See Also:
        UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIGraphic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIGraphic

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIGraphic
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlGraphicImage

    public class UIGraphic
extends UIComponentBase

    UIGraphic is a UIComponent that displays a graphical image to the user. The user cannot manipulate this component; it is for display purposes only.

    By default, the rendererType property must be set to "javax.faces.Image". This value can be changed by calling the setRendererType() method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIGraphic()
      Create a new UIGraphic instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      String getUrl()
      Return the image URL for this UIGraphic.
      Object getValue()
      Returns the value property of the UIGraphic.
      ValueBinding getValueBinding(String name)
      Deprecated.
      This has been replaced by getValueExpression(java.lang.String).
      ValueExpression getValueExpression(String name)
      Return any ValueExpression set for value if a ValueExpression for url is requested; otherwise, perform the default superclass processing for this method.
      void setUrl(String url)
      Set the image URL for this UIGraphic.
      void setValue(Object value)
      Sets the value property of the UIGraphic.
      void setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
      void setValueExpression(String name, ValueExpression binding)
      Store any ValueExpression specified for url under value instead; otherwise, perform the default superclass processing for this method.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIGraphic

        public UIGraphic()

        Create a new UIGraphic instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getUrl

        public String getUrl()

        Return the image URL for this UIGraphic. This method is a typesafe alias for getValue().

      • setUrl

        public void setUrl(String url)

        Set the image URL for this UIGraphic. This method is a typesafe alias for setValue().

        Parameters:
        url - The new image URL

      • getValue

        public Object getValue()

        Returns the value property of the UIGraphic. This will typically be rendered as an URL.

      • setValue

        public void setValue(Object value)

        Sets the value property of the UIGraphic. This will typically be rendered as an URL.

        Parameters:
        value - the new value

      • getValueBinding

        public ValueBinding getValueBinding(String name)
        Deprecated. This has been replaced by getValueExpression(java.lang.String).

        Return any ValueBinding set for value if a ValueBinding for url is requested; otherwise, perform the default superclass processing for this method.

        Overrides:
        getValueBinding in class UIComponentBase
        Parameters:
        name - Name of the attribute or property for which to retrieve a ValueBinding
        Throws:
        NullPointerException - if name is null

      • setValueBinding

        public void setValueBinding(String name,
                   ValueBinding binding)
        Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

        Store any ValueBinding specified for url under value instead; otherwise, perform the default superclass processing for this method. In all cases, the superclass is relied on to convert the ValueBinding to a ValueExpression.

        Overrides:
        setValueBinding in class UIComponentBase
        Parameters:
        name - Name of the attribute or property for which to set a ValueBinding
        binding - The ValueBinding to set, or null to remove any currently set ValueBinding
        Throws:
        NullPointerException - if name is null

      • getValueExpression

        public ValueExpression getValueExpression(String name)

        Return any ValueExpression set for value if a ValueExpression for url is requested; otherwise, perform the default superclass processing for this method.

        Overrides:
        getValueExpression in class UIComponent
        Parameters:
        name - Name of the attribute or property for which to retrieve a ValueExpression
        Throws:
        NullPointerException - if name is null
        Since:
        1.2

      • setValueExpression

        public void setValueExpression(String name,
                      ValueExpression binding)

        Store any ValueExpression specified for url under value instead; otherwise, perform the default superclass processing for this method.

        Overrides:
        setValueExpression in class UIComponent
        Parameters:
        name - Name of the attribute or property for which to set a ValueExpression
        binding - The ValueExpression to set, or null to remove any currently set ValueExpression
        Throws:
        NullPointerException - if name is null
        Since:
        1.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIInput (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIInput

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
  • All Implemented Interfaces:
    EventListener, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlInputFile, HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, UISelectBoolean, UISelectMany, UISelectOne, UIViewParameter

    public class UIInput
extends UIOutput
implements EditableValueHolder

    UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded. There are no restrictions on the data type of the local value, or the object referenced by the value binding expression (if any); however, individual Renderers will generally impose restrictions on the type of data they know how to display.

    During the Apply Request Values phase of the request processing lifecycle, the decoded value of this component, usually but not necessarily a String, must be stored - but not yet converted - using setSubmittedValue(). If the component wishes to indicate that no particular value was submitted, it can either do nothing, or set the submitted value to null.

    By default, during the Process Validators phase of the request processing lifecycle, the submitted value will be converted to a typesafe object, and, if validation succeeds, stored as a local value using setValue(). However, if the immediate property is set to true, this processing will occur instead at the end of the Apply Request Values phase.

    During the Render Response phase of the request processing lifecycle, conversion for output occurs as for UIOutput.

    When the validate() method of this UIInput detects that a value change has actually occurred, and that all validations have been successfully passed, it will queue a ValueChangeEvent. Later on, the broadcast() method will ensure that this event is broadcast to all interested listeners. This event will be delivered by default in the Process Validators phase, but can be delivered instead during Apply Request Values if the immediate property is set to true. If the validation fails, the implementation must call FacesContext.validationFailed().

    By default, the rendererType property must be set to "Text". This value can be changed by calling the setRendererType() method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.
      static String CONVERSION_MESSAGE_ID
      The message identifier of the FacesMessage to be created if a conversion error occurs, and neither the page author nor the ConverterException provides a message.
      static String REQUIRED_MESSAGE_ID
      The message identifier of the FacesMessage to be created if a required check fails.
      static String UPDATE_MESSAGE_ID
      The message identifier of the FacesMessage to be created if a model update error occurs, and the thrown exception has no message.
      static String VALIDATE_EMPTY_FIELDS_PARAM_NAME

      The name of an application parameter that indicates how empty values should be handled with respect to validation.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIInput()
      Create a new UIInput instance with default property values.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void addValidator(Validator validator)
      Add a Validator instance to the set associated with this UIInput.
      void addValueChangeListener(ValueChangeListener listener)
      Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.
      void clearInitialState()

      For each of the attached objects on this instance that implement PartialStateHolder, call PartialStateHolder.clearInitialState() on the attached object.
      protected boolean compareValues(Object previous, Object value)
      Return true if the new value is different from the previous value.
      void decode(FacesContext context)
      Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.
      protected Object getConvertedValue(FacesContext context, Object newSubmittedValue)
      Convert the submitted value into a "local value" of the appropriate data type, if necessary.
      String getConverterMessage()
      If there has been a call to setConverterMessage(java.lang.String) on this instance, return the message.
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      String getRequiredMessage()
      If there has been a call to setRequiredMessage(java.lang.String) on this instance, return the message.
      Object getSubmittedValue()
      Return the submittedValue value of this UIInput component.
      MethodBinding getValidator()
      Deprecated.
      getValidators() should be used instead.
      String getValidatorMessage()
      If there has been a call to setValidatorMessage(java.lang.String) on this instance, return the message.
      Validator[] getValidators()
      Return the set of registered Validators for this UIInput instance.
      Object getValue()

      If there is a local value, return it, otherwise return the result of calling super.getVaue().
      MethodBinding getValueChangeListener()
      If EditableValueHolder.setValueChangeListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null.
      ValueChangeListener[] getValueChangeListeners()
      Return the set of registered ValueChangeListeners for this UIInput instance.
      static boolean | isEmpty(Object value)
      boolean isImmediate()
      Return the "immediate" state for this component.
      boolean isLocalValueSet()
      Return the "local value set" state for this component.
      boolean isRequired()
      Return the "required field" state for this component.
      boolean isValid()
      Return a flag indicating whether the local value of this component is valid (no conversion error has occurred).
      void markInitialState()
      In addition to the actions taken in UIOutput when PartialStateHolder.markInitialState() is called, check if any of the installed Validators are PartialStateHolders and if so, call PartialStateHolder.markInitialState() as appropriate.
      void processDecodes(FacesContext context)
      Specialized decode behavior on top of that provided by the superclass.
      void processUpdates(FacesContext context)
      In addition to the standard processUpdates behavior inherited from UIComponentBase, calls updateModel().
      void processValidators(FacesContext context)
      In addition to the standard processValidators behavior inherited from UIComponentBase, calls validate() if the immediate property is false (which is the default); if the component is invalid afterwards, calls FacesContext.renderResponse().
      void removeValidator(Validator validator)
      Remove a Validator instance from the set associated with this UIInput, if it was previously associated.
      void removeValueChangeListener(ValueChangeListener listener)
      Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.
      void resetValue()
      Convenience method to reset this component's value to the un-initialized state.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setConverterMessage(String message)
      Override any ValueExpression set for the "converterMessage" with the literal argument provided to this method.
      void setImmediate(boolean immediate)
      Set the "immediate" state for this component.
      void setLocalValueSet(boolean localValueSet)
      Sets the "local value set" state for this component.
      void setRequired(boolean required)
      Set the "required field" state for this component.
      void setRequiredMessage(String message)
      Override any ValueExpression set for the "requiredMessage" with the literal argument provided to this method.
      void setSubmittedValue(Object submittedValue)
      Set the submittedValue value of this UIInput component.
      void setValid(boolean valid)
      Set a flag indicating whether the local value of this component is valid (no conversion error has occurred).
      void setValidator(MethodBinding validatorBinding)
      Deprecated.
      Use addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.
      void setValidatorMessage(String message)
      Override any ValueExpression set for the "validatorMessage" with the literal argument provided to this method.
      void setValue(Object value)
      Set the value of this UIComponent (if any).
      void setValueChangeListener(MethodBinding valueChangeListener)
      Deprecated.
      Use addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.
      void updateModel(FacesContext context)
      Perform the following algorithm to update the model data associated with this UIInput, if any, as appropriate.
      void validate(FacesContext context)
      Perform the following algorithm to validate the local value of this UIInput.
      protected void validateValue(FacesContext context, Object newValue)
      Set the "valid" property according to the below algorithm.

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

      • CONVERSION_MESSAGE_ID

        public static final String CONVERSION_MESSAGE_ID

        The message identifier of the FacesMessage to be created if a conversion error occurs, and neither the page author nor the ConverterException provides a message.

        See Also:
        Constant Field Values

      • REQUIRED_MESSAGE_ID

        public static final String REQUIRED_MESSAGE_ID

        The message identifier of the FacesMessage to be created if a required check fails.

        See Also:
        Constant Field Values

      • UPDATE_MESSAGE_ID

        public static final String UPDATE_MESSAGE_ID

        The message identifier of the FacesMessage to be created if a model update error occurs, and the thrown exception has no message.

        See Also:
        Constant Field Values

      • VALIDATE_EMPTY_FIELDS_PARAM_NAME

        public static final String VALIDATE_EMPTY_FIELDS_PARAM_NAME

        The name of an application parameter that indicates how empty values should be handled with respect to validation. See validateValue(javax.faces.context.FacesContext, java.lang.Object) for the allowable values and specification of how they should be interpreted.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIInput

        public UIInput()

        Create a new UIInput instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Overrides:
        getFamily in class UIOutput

      • getSubmittedValue

        public Object getSubmittedValue()

        Return the submittedValue value of this UIInput component. This method should only be used by the decode() and validate() method of this component, or its corresponding Renderer.

        Specified by:
        getSubmittedValue in interface EditableValueHolder

      • setSubmittedValue

        public void setSubmittedValue(Object submittedValue)

        Set the submittedValue value of this UIInput component. This method should only be used by the decode() and validate() method of this component, or its corresponding Renderer.

        Specified by:
        setSubmittedValue in interface EditableValueHolder
        Parameters:
        submittedValue - The new submitted value

      • getValue

        public Object getValue()

        If there is a local value, return it, otherwise return the result of calling super.getVaue().

        Specified by:
        getValue in interface ValueHolder
        Overrides:
        getValue in class UIOutput
        Since:
        2.2

      • setValue

        public void setValue(Object value)
        Description copied from interface: ValueHolder

        Set the value of this UIComponent (if any).

        Specified by:
        setValue in interface ValueHolder
        Overrides:
        setValue in class UIOutput
        Parameters:
        value - The new local value

      • resetValue

        public void resetValue()

        Convenience method to reset this component's value to the un-initialized state. This method does the following:

        Call UIOutput.setValue(java.lang.Object).

        Call setSubmittedValue(java.lang.Object) passing null.

        Call setLocalValueSet(boolean) passing false.

        Call setValid(boolean) passing true.

        Upon return from this call if the instance had a ValueBinding associated with it for the "value" property, this binding is evaluated when UIOutput.getValue() is called. Otherwise, null is returned from getValue().

        Specified by:
        resetValue in interface EditableValueHolder
        Overrides:
        resetValue in class UIOutput

      • isLocalValueSet

        public boolean isLocalValueSet()
        Return the "local value set" state for this component. Calls to setValue() automatically reset this property to true.
        Specified by:
        isLocalValueSet in interface EditableValueHolder

      • setLocalValueSet

        public void setLocalValueSet(boolean localValueSet)
        Sets the "local value set" state for this component.
        Specified by:
        setLocalValueSet in interface EditableValueHolder

      • isRequired

        public boolean isRequired()

        Return the "required field" state for this component.

        Specified by:
        isRequired in interface EditableValueHolder

      • getRequiredMessage

        public String getRequiredMessage()

        If there has been a call to setRequiredMessage(java.lang.String) on this instance, return the message. Otherwise, call UIComponent.getValueExpression(java.lang.String) passing the key "requiredMessage", get the result of the expression, and return it. Any ELExceptions thrown during the call to getValue() must be wrapped in a FacesException and rethrown.

      • setRequiredMessage

        public void setRequiredMessage(String message)

        Override any ValueExpression set for the "requiredMessage" with the literal argument provided to this method. Subsequent calls to getRequiredMessage() will return this value;

        Parameters:
        message - the literal message value to be displayed in the event the user hasn't supplied a value and one is required.

      • getConverterMessage

        public String getConverterMessage()

        If there has been a call to setConverterMessage(java.lang.String) on this instance, return the message. Otherwise, call UIComponent.getValueExpression(java.lang.String) passing the key "converterMessage", get the result of the expression, and return it. Any ELExceptions thrown during the call to getValue() must be wrapped in a FacesException and rethrown.

      • setConverterMessage

        public void setConverterMessage(String message)

        Override any ValueExpression set for the "converterMessage" with the literal argument provided to this method. Subsequent calls to getConverterMessage() will return this value;

        Parameters:
        message - the literal message value to be displayed in the event conversion fails.

      • getValidatorMessage

        public String getValidatorMessage()

        If there has been a call to setValidatorMessage(java.lang.String) on this instance, return the message. Otherwise, call UIComponent.getValueExpression(java.lang.String) passing the key "validatorMessage", get the result of the expression, and return it. Any ELExceptions thrown during the call to getValue() must be wrapped in a FacesException and rethrown.

      • setValidatorMessage

        public void setValidatorMessage(String message)

        Override any ValueExpression set for the "validatorMessage" with the literal argument provided to this method. Subsequent calls to getValidatorMessage() will return this value;

        Parameters:
        message - the literal message value to be displayed in the event validation fails.

      • isValid

        public boolean isValid()
        Description copied from interface: EditableValueHolder

        Return a flag indicating whether the local value of this component is valid (no conversion error has occurred).

        Specified by:
        isValid in interface EditableValueHolder

      • setValid

        public void setValid(boolean valid)
        Description copied from interface: EditableValueHolder

        Set a flag indicating whether the local value of this component is valid (no conversion error has occurred).

        Specified by:
        setValid in interface EditableValueHolder
        Parameters:
        valid - The new valid flag

      • setRequired

        public void setRequired(boolean required)

        Set the "required field" state for this component.

        Specified by:
        setRequired in interface EditableValueHolder
        Parameters:
        required - The new "required field" state

      • isImmediate

        public boolean isImmediate()
        Description copied from interface: EditableValueHolder

        Return the "immediate" state for this component.

        Specified by:
        isImmediate in interface EditableValueHolder

      • setImmediate

        public void setImmediate(boolean immediate)
        Description copied from interface: EditableValueHolder

        Set the "immediate" state for this component. When set to true, the component's value will be converted and validated immediately in the Apply Request Values phase, and ValueChangeEvents will be delivered in that phase as well. The default value for this property must be false.

        Specified by:
        setImmediate in interface EditableValueHolder
        Parameters:
        immediate - The new "immediate" state

      • getValidator

        public MethodBinding getValidator()
        Deprecated. getValidators() should be used instead.

        Return a MethodBinding pointing at a method that will be called during Process Validations phase of the request processing lifecycle, to validate the current value of this component.

        Specified by:
        getValidator in interface EditableValueHolder

      • setValidator

        public void setValidator(MethodBinding validatorBinding)
        Deprecated. Use addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.

        Set a MethodBinding pointing at a method that will be called during Process Validations phase of the request processing lifecycle, to validate the current value of this component.

        Any method referenced by such an expression must be public, with a return type of void, and accept parameters of type FacesContext, UIComponent, and Object.

        Specified by:
        setValidator in interface EditableValueHolder
        Parameters:
        validatorBinding - The new MethodBinding instance

      • getValueChangeListener

        public MethodBinding getValueChangeListener()
        Description copied from interface: EditableValueHolder

        If EditableValueHolder.setValueChangeListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to EditableValueHolder.setValueChangeListener(javax.faces.el.MethodBinding).

        Specified by:
        getValueChangeListener in interface EditableValueHolder

      • setValueChangeListener

        public void setValueChangeListener(MethodBinding valueChangeListener)
        Deprecated. Use addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.

        Wrap the argument valueChangeMethod in an implementation of ValueChangeListener and store it in the internal data structure that backs the EditableValueHolder.getValueChangeListeners() method, taking care to over-write any instance that was stored by a previous call to setValueChangeListener.

        This argument method will be called during the Process Validations or Apply Request Values phases (depending on the value of the immediate property).

        Any method referenced by such an expression must be public, with a return type of void, and accept a parameter of type ValueChangeEvent.

        Specified by:
        setValueChangeListener in interface EditableValueHolder
        Parameters:
        valueChangeListener - The new method binding instance

      • markInitialState

        public void markInitialState()

        In addition to the actions taken in UIOutput when PartialStateHolder.markInitialState() is called, check if any of the installed Validators are PartialStateHolders and if so, call PartialStateHolder.markInitialState() as appropriate.

        Specified by:
        markInitialState in interface PartialStateHolder
        Overrides:
        markInitialState in class UIOutput

      • clearInitialState

        public void clearInitialState()
        Description copied from class: UIComponentBase

        For each of the attached objects on this instance that implement PartialStateHolder, call PartialStateHolder.clearInitialState() on the attached object.

        Specified by:
        clearInitialState in interface PartialStateHolder
        Overrides:
        clearInitialState in class UIOutput

      • processDecodes

        public void processDecodes(FacesContext context)

        Specialized decode behavior on top of that provided by the superclass. In addition to the standard processDecodes behavior inherited from UIComponentBase, calls validate() if the the immediate property is true; if the component is invalid afterwards or a RuntimeException is thrown, calls FacesContext.renderResponse().

        Overrides:
        processDecodes in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • processValidators

        public void processValidators(FacesContext context)

        In addition to the standard processValidators behavior inherited from UIComponentBase, calls validate() if the immediate property is false (which is the default); if the component is invalid afterwards, calls FacesContext.renderResponse(). If a RuntimeException is thrown during validation processing, calls FacesContext.renderResponse() and re-throw the exception.

        Overrides:
        processValidators in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • processUpdates

        public void processUpdates(FacesContext context)

        In addition to the standard processUpdates behavior inherited from UIComponentBase, calls updateModel(). If the component is invalid afterwards, calls FacesContext.renderResponse(). If a RuntimeException is thrown during update processing, calls FacesContext.renderResponse() and re-throw the exception.

        Overrides:
        processUpdates in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • decode

        public void decode(FacesContext context)
        Description copied from class: UIComponent

        Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.

        During decoding, events may be enqueued for later processing (by event listeners who have registered an interest), by calling queueEvent().

        Overrides:
        decode in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • updateModel

        public void updateModel(FacesContext context)

        Perform the following algorithm to update the model data associated with this UIInput, if any, as appropriate.

        • If the valid property of this component is false, take no further action.
        • If the localValueSet property of this component is false, take no further action.
        • If no ValueExpression for value exists, take no further action.
        • Call setValue() method of the ValueExpression to update the value that the ValueExpression points at.
        • If the setValue() method returns successfully:
          • Clear the local value of this UIInput.
          • Set the localValueSet property of this UIInput to false.
        • If the setValue() method throws an Exception:
          • Enqueue an error message. Create a FacesMessage with the id UPDATE_MESSAGE_ID. Create a UpdateModelException, passing the FacesMessage and the caught exception to the constructor. Create an ExceptionQueuedEventContext, passing the FacesContext, the UpdateModelException, this component instance, and PhaseId.UPDATE_MODEL_VALUES to its constructor. Call FacesContext.getExceptionHandler() and then call ExceptionHandler.processEvent(javax.faces.event.SystemEvent), passing the ExceptionQueuedEventContext.
          • Set the valid property of this UIInput to false.
          • The exception must not be re-thrown. This enables tree traversal to continue for this lifecycle phase, as in all the other lifecycle phases.
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • validate

        public void validate(FacesContext context)

        Perform the following algorithm to validate the local value of this UIInput.

        • Retrieve the submitted value with getSubmittedValue(). If this returns null, exit without further processing. (This indicates that no value was submitted for this component.)

        • If the javax.faces.INTERPRET_EMPTY_STRING_SUBMITTED_VALUES_AS_NULL context parameter value is true (ignoring case), and getSubmittedValue() returns a zero-length String call setSubmittedValue(java.lang.Object), passing null as the argument and continue processing using null as the current submitted value.

        • Convert the submitted value into a "local value" of the appropriate data type by calling getConvertedValue(javax.faces.context.FacesContext, java.lang.Object).
        • If conversion fails:
          • Enqueue an appropriate error message by calling the addMessage() method on the FacesContext.
          • Set the valid property on this component to false

        • Validate the property by calling validateValue(javax.faces.context.FacesContext, java.lang.Object).

        • If the valid property of this component is still true, retrieve the previous value of the component (with getValue()), store the new local value using setValue(), and reset the submitted value to null with a call to setSubmittedValue(java.lang.Object) passing null as the argument. If the local value is different from the previous value of this component, as determined by a call to compareValues(java.lang.Object, java.lang.Object), fire a ValueChangeEvent to be broadcast to all interested listeners.

        Application components implementing UIInput that wish to perform validation with logic embedded in the component should perform their own correctness checks, and then call the super.validate() method to perform the standard processing described above.

        Parameters:
        context - The FacesContext for the current request
        Throws:
        NullPointerException - if context is null

      • getConvertedValue

        protected Object getConvertedValue(FacesContext context,
                       Object newSubmittedValue)
                            throws ConverterException

        Convert the submitted value into a "local value" of the appropriate data type, if necessary. Employ the following algorithm to do so:

        • If a Renderer is present, call getConvertedValue() to convert the submitted value.
        • If no Renderer is present, and the submitted value is a String, locate a Converter as follows:
          • If getConverter() returns a non-null Converter, use that instance.
          • Otherwise, if a value binding for value exists, call getType() on it.
            • If this call returns null, assume the output type is String and perform no conversion.
            • Otherwise, call Application.createConverter(Class) to locate any registered Converter capable of converting data values of the specified type.
        • If a Converter instance was located, call its getAsObject() method to perform the conversion. If conversion fails, the Converter will have thrown a ConverterException which is declared as a checked exception on this method, and thus must be handled by the caller.
        • Otherwise, use the submitted value without any conversion

        • This method can be overridden by subclasses for more specific behavior.

Throws:
ConverterException

  • validateValue

    protected void validateValue(FacesContext context,
                 Object newValue)

    Set the "valid" property according to the below algorithm.

    • If the valid property on this component is still true, and the required property is also true, ensure that the local value is not empty (where "empty" is defined as null or a zero-length String). If the local value is empty:

      • Enqueue an appropriate error message by calling the addMessage() method on the FacesContext instance for the current request. If the getRequiredMessage() returns non-null, use the value as the summary and detail in the FacesMessage that is enqueued on the FacesContext, otherwise use the message for the REQUIRED_MESSAGE_ID.

      • Set the valid property on this component to false.

      • If calling ValidatorException.getFacesMessages() returns non-null, each message should be added to the FacesContext. Otherwise the single message returned from ValidatorException.getFacesMessage() should be added.

    • Otherwise, if the valid property on this component is still true, take the following action to determine if validation of this component should proceed.

      • If the value is not empty, validation should proceed.

      • If the value is empty, but the system has been directed to validate empty fields, validation should proceed. The implementation must obtain the init parameter Map from the ExternalContext and inspect the value for the key given by the value of the symbolic constant VALIDATE_EMPTY_FIELDS_PARAM_NAME. If there is no value under that key, use the same key and look in the application map from the ExternalContext. If the value is null or equal to the string “auto” (without the quotes) take appropriate action to determine if Bean Validation is present in the runtime environment. If not, validation should not proceed. If so, validation should proceed. If the value is equal (ignoring case) to “true” (without the quotes) validation should proceed. Otherwise, validation should not proceed.

        • If the above determination indicates that validation should proceed, call the validate() method of each Validator registered for this UIInput, followed by the method pointed at by the validatorBinding property (if any). If any of these validators or the method throws a ValidatorException, catch the exception, add its message (if any) to the FacesContext, and set the valid property of this component to false.

  • compareValues

    protected boolean compareValues(Object previous,
                    Object value)

    Return true if the new value is different from the previous value. First compare the two values by passing value to the equals method on argument previous. If that method returns true, return true. If that method returns false, and both arguments implement java.lang.Comparable, compare the two values by passing value to the compareTo method on argument previous. Return true if this method returns 0, false otherwise.

    Parameters:
    previous - old value of this component (if any)
    value - new value of this component (if any)

  • isEmpty

    public static boolean isEmpty(Object value)

  • addValidator

    public void addValidator(Validator validator)

    Add a Validator instance to the set associated with this UIInput.

    Specified by:
    addValidator in interface EditableValueHolder
    Parameters:
    validator - The Validator to add
    Throws:
    NullPointerException - if validator is null

  • getValidators

    public Validator[] getValidators()

    Return the set of registered Validators for this UIInput instance. If there are no registered validators, a zero-length array is returned.

    Specified by:
    getValidators in interface EditableValueHolder

  • removeValidator

    public void removeValidator(Validator validator)

    Remove a Validator instance from the set associated with this UIInput, if it was previously associated. Otherwise, do nothing.

    Specified by:
    removeValidator in interface EditableValueHolder
    Parameters:
    validator - The Validator to remove

  • addValueChangeListener

    public void addValueChangeListener(ValueChangeListener listener)

    Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.

    Specified by:
    addValueChangeListener in interface EditableValueHolder
    Parameters:
    listener - The ValueChangeListener to be added
    Throws:
    NullPointerException - if listener is null

  • getValueChangeListeners

    public ValueChangeListener[] getValueChangeListeners()

    Return the set of registered ValueChangeListeners for this UIInput instance. If there are no registered listeners, a zero-length array is returned.

    Specified by:
    getValueChangeListeners in interface EditableValueHolder

  • removeValueChangeListener

    public void removeValueChangeListener(ValueChangeListener listener)

    Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.

    Specified by:
    removeValueChangeListener in interface EditableValueHolder
    Parameters:
    listener - The ValueChangeListener to be removed
    Throws:
    NullPointerException - if listener is null

  • saveState

    public Object saveState(FacesContext context)
    Description copied from interface: StateHolder

    Gets the state of the instance as a Serializable Object.

    If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

    This method must not alter the state of the implementing object. In other words, after executing this code:

     Object state = component.saveState(facesContext);

    component should be the same as before executing it.

    The return from this method must be Serializable

    Specified by:
    saveState in interface StateHolder
    Overrides:
    saveState in class UIOutput

  • restoreState

    public void restoreState(FacesContext context,
                Object state)
    Description copied from interface: StateHolder

    Perform any processing required to restore the state from the entries in the state Object.

    If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

    If the state argument is null, take no action and return.

    Specified by:
    restoreState in interface StateHolder
    Overrides:
    restoreState in class UIOutput
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIMessage

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIMessage
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlMessage

    public class UIMessage
extends UIComponentBase

    This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer. The component obtains the messages from the FacesContext.

    By default, the rendererType property must be set to "javax.faces.Message". This value can be changed by calling the setRendererType() method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIMessage()
      Create a new UIMessage instance with default property values.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      String getFor()
      Return the Identifier of the component for which to render error messages.
      boolean | isRedisplay()
      boolean isShowDetail()
      Return the flag indicating whether the detail property of the associated message(s) should be displayed.
      boolean isShowSummary()
      Return the flag indicating whether the summary property of the associated message(s) should be displayed.
      void setFor(String newFor)
      Set the identifier of the component for which this component represents associated message(s) (if any).
      void setRedisplay(boolean redisplay)
      Set the flag indicating whether the detail property of the associated message(s) should be displayed.
      void setShowDetail(boolean showDetail)
      Set the flag indicating whether the detail property of the associated message(s) should be displayed.
      void setShowSummary(boolean showSummary)
      Set the flag indicating whether the summary property of the associated message(s) should be displayed.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIMessage

        public UIMessage()

        Create a new UIMessage instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getFor

        public String getFor()

        Return the Identifier of the component for which to render error messages. If this component is within the same NamingContainer as the target component, this must be the component identifier. Otherwise, it must be an absolute component identifier (starting with ":"). See the UIComponent.findComponent(java.lang.String) for more information.

      • setFor

        public void setFor(String newFor)

        Set the identifier of the component for which this component represents associated message(s) (if any). This property must be set before the message is displayed.

        Parameters:
        newFor - The new client id

      • isShowDetail

        public boolean isShowDetail()

        Return the flag indicating whether the detail property of the associated message(s) should be displayed. Defaults to true.

      • setShowDetail

        public void setShowDetail(boolean showDetail)

        Set the flag indicating whether the detail property of the associated message(s) should be displayed.

        Parameters:
        showDetail - The new flag

      • isShowSummary

        public boolean isShowSummary()

        Return the flag indicating whether the summary property of the associated message(s) should be displayed. Defaults to false.

      • setShowSummary

        public void setShowSummary(boolean showSummary)

        Set the flag indicating whether the summary property of the associated message(s) should be displayed.

        Parameters:
        showSummary - The new flag value

      • isRedisplay

        public boolean isRedisplay()
        Returns:
        true if this UIMessage instance should redisplay FacesMessages that have already been handled, otherwise returns false. By default this method will always return true if setRedisplay(boolean) has not been called.
        Since:
        2.0

      • setRedisplay

        public void setRedisplay(boolean redisplay)

        Set the flag indicating whether the detail property of the associated message(s) should be displayed.

        Parameters:
        redisplay - flag indicating whether previously handled messages are redisplayed or not
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIMessages (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIMessages

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIMessages
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlMessages

    public class UIMessages
extends UIComponentBase

    The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.

    This component supports the Messages renderer-type.

    By default, the rendererType property must be set to "javax.faces.Messages". This value can be changed by calling the setRendererType() method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIMessages()
      Create a new UIMessages instance with default property values.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      String getFor()

      Return the client identifier of the component for which this component represents associated message(s) (if any).
      boolean isGlobalOnly()
      Return the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered.
      boolean | isRedisplay()
      boolean isShowDetail()
      Return the flag indicating whether the detail property of the associated message(s) should be displayed.
      boolean isShowSummary()
      Return the flag indicating whether the summary property of the associated message(s) should be displayed.
      void setFor(String newFor)
      Set the client identifier of the component for which this component represents associated message(s) (if any).
      void setGlobalOnly(boolean globalOnly)
      Set the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered.
      void setRedisplay(boolean redisplay)
      Set the flag indicating whether the detail property of the associated message(s) should be displayed.
      void setShowDetail(boolean showDetail)
      Set the flag indicating whether the detail property of the associated message(s) should be displayed.
      void setShowSummary(boolean showSummary)
      Set the flag indicating whether the summary property of the associated message(s) should be displayed.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIMessages

        public UIMessages()

        Create a new UIMessages instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getFor

        public String getFor()

        Return the client identifier of the component for which this component represents associated message(s) (if any).

      • setFor

        public void setFor(String newFor)

        Set the client identifier of the component for which this component represents associated message(s) (if any). This property must be set before the message is displayed.

        Parameters:
        newFor - The new client id

      • isGlobalOnly

        public boolean isGlobalOnly()

        Return the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered. Mutually exclusive with the "for" property which takes precedence. Defaults to false.

      • setGlobalOnly

        public void setGlobalOnly(boolean globalOnly)

        Set the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered.

        Parameters:
        globalOnly - The new flag value

      • isShowDetail

        public boolean isShowDetail()

        Return the flag indicating whether the detail property of the associated message(s) should be displayed. Defaults to false.

      • setShowDetail

        public void setShowDetail(boolean showDetail)

        Set the flag indicating whether the detail property of the associated message(s) should be displayed.

        Parameters:
        showDetail - The new flag

      • isShowSummary

        public boolean isShowSummary()

        Return the flag indicating whether the summary property of the associated message(s) should be displayed. Defaults to true.

      • setShowSummary

        public void setShowSummary(boolean showSummary)

        Set the flag indicating whether the summary property of the associated message(s) should be displayed.

        Parameters:
        showSummary - The new flag value

      • isRedisplay

        public boolean isRedisplay()
        Returns:
        true if this UIMessage instance should redisplay FacesMessages that have already been handled, otherwise returns false. By default this method will always return true if setRedisplay(boolean) has not been called.
        Since:
        2.0

      • setRedisplay

        public void setRedisplay(boolean redisplay)

        Set the flag indicating whether the detail property of the associated message(s) should be displayed.

        Parameters:
        redisplay - flag indicating whether previously handled messages are redisplayed or not
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UINamingContainer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UINamingContainer

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UINamingContainer
  • All Implemented Interfaces:
    EventListener, NamingContainer, PartialStateHolder, StateHolder, TransientStateHolder, UniqueIdVendor, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class UINamingContainer
extends UIComponentBase
implements NamingContainer, UniqueIdVendor, StateHolder

    UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.
      static String SEPARATOR_CHAR_PARAM_NAME

      The context-param that allows the separator char for clientId strings to be set on a per-web application basis.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

      • Fields inherited from interface javax.faces.component.NamingContainer

        SEPARATOR_CHAR

    • Constructor Summary

      Constructors
      Constructor and Description
      UINamingContainer()
      Create a new UINamingContainer instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String createUniqueId(FacesContext context, String seed)
      Generate an identifier for a component.
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      static char getSeparatorChar(FacesContext context)

      Return the character used to separate segments of a clientId.
      boolean visitTree(VisitContext context, VisitCallback callback)

      Perform a tree visit starting at this node in the tree.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.StateHolder

        isTransient, restoreState, saveState, setTransient

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

      • SEPARATOR_CHAR_PARAM_NAME

        public static final String SEPARATOR_CHAR_PARAM_NAME

        The context-param that allows the separator char for clientId strings to be set on a per-web application basis.

        Since:
        2.0
        See Also:
        Constant Field Values

    • Constructor Detail

      • UINamingContainer

        public UINamingContainer()

        Create a new UINamingContainer instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getSeparatorChar

        public static char getSeparatorChar(FacesContext context)

        Return the character used to separate segments of a clientId. The implementation must determine if there is a <context-param> with the value given by the value of the symbolic constant SEPARATOR_CHAR_PARAM_NAME. If there is a value for this param, the first character of the value must be returned from this method. Otherwise, the value of the symbolic constant NamingContainer.SEPARATOR_CHAR must be returned.

        Parameters:
        context - the FacesContext for the current request
        Since:
        2.0

      • visitTree

        public boolean visitTree(VisitContext context,
                VisitCallback callback)
        Description copied from class: UIComponent

        Perform a tree visit starting at this node in the tree.

        UIComponent.visitTree() implementations do not invoke the VisitCallback directly, but instead call VisitContext.invokeVisitCallback(javax.faces.component.UIComponent, javax.faces.component.visit.VisitCallback) to invoke the callback. This allows VisitContext implementations to provide optimized tree traversals, for example by only calling the VisitCallback for a subset of components.

        UIComponent.visitTree() implementations must call
 UIComponent.pushComponentToEL() before performing the
 visit and UIComponent.popComponentFromEL() after the
 visit.

        Overrides:
        visitTree in class UIComponent
        Parameters:
        context - the VisitContext for this visit
        callback - the VisitCallback instance whose visit method will be called for each node visited.
        Returns:
        component implementations may return true to indicate that the tree visit is complete (eg. all components that need to be visited have been visited). This results in the tree visit being short-circuited such that no more components are visited.
        See Also:
        UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback)

      • createUniqueId

        public String createUniqueId(FacesContext context,
                    String seed)
        Description copied from interface: UniqueIdVendor

        Generate an identifier for a component. The identifier will be prefixed with UNIQUE_ID_PREFIX, and will be unique within this component-container. Optionally, a unique seed value can be supplied by component creators which should be included in the generated unique id.

        Specified by:
        createUniqueId in interface UniqueIdVendor
        Parameters:
        context - FacesContext
        seed - an optional seed value - e.g. based on the position of the component in the VDL-template
        Returns:
        a unique-id in this component-container
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIOutcomeTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIOutcomeTarget

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIOutcomeTarget
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlOutcomeTargetButton, HtmlOutcomeTargetLink

    public class UIOutcomeTarget
extends UIOutput

    This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response. This enables bookmarkability in JSF applications.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIOutcomeTarget()
      Create a new UIOutcomeTarget instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      String getOutcome()

      Returns the outcome property of the UIOutcomeTarget.
      boolean isDisableClientWindow()

      Return whether or not the client window should be encoded into the target url.
      boolean isIncludeViewParams()

      Return whether or not the view parameters should be encoded into the target url.
      void setDisableClientWindow(boolean disableClientWindow)

      Set whether or not the client window should be encoded into the target url.
      void setIncludeViewParams(boolean includeViewParams)

      Set whether or not the page parameters should be encoded into the target url.
      void setOutcome(String outcome)

      Sets the outcome property of the UIOutcomeTarget.

      • Methods inherited from class javax.faces.component.UIOutput

        clearInitialState, getConverter, getLocalValue, getValue, markInitialState, resetValue, restoreState, saveState, setConverter, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIOutcomeTarget

        public UIOutcomeTarget()

        Create a new UIOutcomeTarget instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Overrides:
        getFamily in class UIOutput

      • isIncludeViewParams

        public boolean isIncludeViewParams()

        Return whether or not the view parameters should be encoded into the target url.

        Since:
        2.0

      • setIncludeViewParams

        public void setIncludeViewParams(boolean includeViewParams)

        Set whether or not the page parameters should be encoded into the target url.

        Parameters:
        includeViewParams - The state of the switch for encoding page parameters
        Since:
        2.0

      • isDisableClientWindow

        public boolean isDisableClientWindow()

        Return whether or not the client window should be encoded into the target url.

        Since:
        2.0

      • setDisableClientWindow

        public void setDisableClientWindow(boolean disableClientWindow)

        Set whether or not the client window should be encoded into the target url.

        Parameters:
        disableClientWindow - if @{code true}, the client window will not be included in this outcome target.
        Since:
        2.2

      • getOutcome

        public String getOutcome()

        Returns the outcome property of the UIOutcomeTarget. This value is passed to the NavigationHandler when resolving the target url of this component.

        Since:
        2.0

      • setOutcome

        public void setOutcome(String outcome)

        Sets the outcome property of the UIOutcomeTarget. This value is passed to the NavigationHandler when resolving the target url of this component.

        Parameters:
        outcome - the navigation outcome
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIOutput (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIOutput

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlBody, HtmlDoctype, HtmlHead, HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, UIInput, UIOutcomeTarget

    public class UIOutput
extends UIComponentBase
implements ValueHolder

    UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user. The user cannot directly modify the rendered value; it is for display purposes only.

    During the Render Response phase of the request processing lifecycle, the current value of this component must be converted to a String (if it is not already), according to the following rules:

    • If the current value is not null, and is not already a String, locate a Converter (if any) to use for the conversion, as follows:
      • If getConverter() returns a non-null Converter, use that one, otherwise
      • If Application.createConverter(Class), passing the current value's class, returns a non-null Converter, use that one.
    • If the current value is not null and a Converter was located, call its getAsString() method to perform the conversion.
    • If the current value is not null but no Converter was located, call toString() on the current value to perform the conversion.

    By default, the rendererType property must be set to "javax.faces.Text". This value can be changed by calling the setRendererType() method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIOutput()
      Create a new UIOutput instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearInitialState()

      For each of the attached objects on this instance that implement PartialStateHolder, call PartialStateHolder.clearInitialState() on the attached object.
      Converter getConverter()
      Return the Converter (if any) that is registered for this UIComponent.
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      Object getLocalValue()
      Return the local value of this UIComponent (if any), without evaluating any associated ValueExpression.
      Object getValue()

      Return the value property.
      void markInitialState()
      In addition to the actions taken in UIComponentBase when PartialStateHolder.markInitialState() is called, check if the installed Converter is a PartialStateHolder and if it is, call PartialStateHolder.markInitialState() on it.
      void resetValue()

      Convenience method to reset this component's value to the un-initialized state.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setConverter(Converter converter)
      Set the Converter (if any) that is registered for this UIComponent.
      void setValue(Object value)
      Set the value of this UIComponent (if any).

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIOutput

        public UIOutput()

        Create a new UIOutput instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getConverter

        public Converter getConverter()
        Description copied from interface: ValueHolder

        Return the Converter (if any) that is registered for this UIComponent.

        Specified by:
        getConverter in interface ValueHolder

      • setConverter

        public void setConverter(Converter converter)
        Description copied from interface: ValueHolder

        Set the Converter (if any) that is registered for this UIComponent.

        Specified by:
        setConverter in interface ValueHolder
        Parameters:
        converter - New Converter (or null)

      • getLocalValue

        public Object getLocalValue()
        Description copied from interface: ValueHolder

        Return the local value of this UIComponent (if any), without evaluating any associated ValueExpression.

        Specified by:
        getLocalValue in interface ValueHolder

      • getValue

        public Object getValue()

        Return the value property.

        Specified by:
        getValue in interface ValueHolder
        Since:
        2.2

      • setValue

        public void setValue(Object value)
        Description copied from interface: ValueHolder

        Set the value of this UIComponent (if any).

        Specified by:
        setValue in interface ValueHolder
        Parameters:
        value - The new local value

      • resetValue

        public void resetValue()

        Convenience method to reset this component's value to the un-initialized state.

        Since:
        2.2

      • markInitialState

        public void markInitialState()

        In addition to the actions taken in UIComponentBase when PartialStateHolder.markInitialState() is called, check if the installed Converter is a PartialStateHolder and if it is, call PartialStateHolder.markInitialState() on it.

        Specified by:
        markInitialState in interface PartialStateHolder
        Overrides:
        markInitialState in class UIComponentBase

      • clearInitialState

        public void clearInitialState()
        Description copied from class: UIComponentBase

        For each of the attached objects on this instance that implement PartialStateHolder, call PartialStateHolder.clearInitialState() on the attached object.

        Specified by:
        clearInitialState in interface PartialStateHolder
        Overrides:
        clearInitialState in class UIComponentBase

      • saveState

        public Object saveState(FacesContext context)
        Description copied from interface: StateHolder

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Specified by:
        saveState in interface StateHolder
        Overrides:
        saveState in class UIComponentBase

      • restoreState

        public void restoreState(FacesContext context,
                Object state)
        Description copied from interface: StateHolder

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Specified by:
        restoreState in interface StateHolder
        Overrides:
        restoreState in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIPanel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIPanel

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIPanel
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlPanelGrid, HtmlPanelGroup

    public class UIPanel
extends UIComponentBase

    UIPanel is a UIComponent that manages the layout of its child components.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIPanel()
      Create a new UIPanel instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIPanel

        public UIPanel()

        Create a new UIPanel instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIParameter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIParameter

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIParameter
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class UIParameter
extends UIComponentBase

    UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.

    Parent components should retrieve the value of a parameter by calling getValue(). In this way, the parameter value can be set directly on the component (via setValue()), or retrieved indirectly via the value binding expression.

    In some scenarios, it is necessary to provide a parameter name, in addition to the parameter value that is accessible via the getValue() method. Renderers that support parameter names on their nested UIParameter child components should document their use of this property.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIParameter()
      Create a new UIParameter instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      String getName()
      Return the optional parameter name for this parameter.
      Object getValue()
      Returns the value property of the UIParameter.
      boolean isDisable()

      Return the value of the disable directive for this component.
      void setDisable(boolean disable)
      Sets the disable property of the UIParameter.
      void setName(String name)
      Set the optional parameter name for this parameter.
      void setValue(Object value)
      Sets the value property of the\ UIParameter.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIParameter

        public UIParameter()

        Create a new UIParameter instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getName

        public String getName()

        Return the optional parameter name for this parameter.

      • setName

        public void setName(String name)

        Set the optional parameter name for this parameter.

        Parameters:
        name - The new parameter name, or null for no name

      • getValue

        public Object getValue()

        Returns the value property of the UIParameter.

      • setValue

        public void setValue(Object value)

        Sets the value property of the\ UIParameter.

        Parameters:
        value - the new value

      • isDisable

        public boolean isDisable()

        Return the value of the disable directive for this component. This directive determines whether the parameter value should be disabled by assigning it a null value. If true, the value set on this component is ignored.

        Since:
        2.0

      • setDisable

        public void setDisable(boolean disable)

        Sets the disable property of the UIParameter.

        Parameters:
        disable -
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UISelectBoolean (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UISelectBoolean

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UISelectBoolean
  • All Implemented Interfaces:
    EventListener, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlSelectBooleanCheckbox

    public class UISelectBoolean
extends UIInput

    UISelectBoolean is a UIComponent that represents a single boolean (true or false) value. It is most commonly rendered as a checkbox.

    By default, the rendererType property must be set to "javax.faces.Checkbox". This value can be changed by calling the setRendererType() method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UISelectBoolean()
      Create a new UISelectBoolean instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      ValueBinding getValueBinding(String name)
      Deprecated.
      This has been replaced by getValueExpression(java.lang.String).
      ValueExpression getValueExpression(String name)
      Return any ValueExpression set for value if a ValueExpression for selected is requested; otherwise, perform the default superclass processing for this method.
      boolean isSelected()
      Return the local value of the selected state of this component.
      void setSelected(boolean selected)
      Set the local value of the selected state of this component.
      void setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
      void setValueExpression(String name, ValueExpression binding)
      Store any ValueExpression specified for selected under value instead; otherwise, perform the default superclass processing for this method.

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UISelectBoolean

        public UISelectBoolean()

        Create a new UISelectBoolean instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Overrides:
        getFamily in class UIInput

      • isSelected

        public boolean isSelected()

        Return the local value of the selected state of this component. This method is a typesafe alias for getValue().

      • setSelected

        public void setSelected(boolean selected)

        Set the local value of the selected state of this component. This method is a typesafe alias for setValue().

        Parameters:
        selected - The new selected state

      • getValueBinding

        public ValueBinding getValueBinding(String name)
        Deprecated. This has been replaced by getValueExpression(java.lang.String).

        Return any ValueBinding set for value if a ValueBinding for selected is requested; otherwise, perform the default superclass processing for this method.

        Rely on the superclass implementation to wrap the returned ValueExpression in a ValueBinding.

        Overrides:
        getValueBinding in class UIComponentBase
        Parameters:
        name - Name of the attribute or property for which to retrieve a ValueBinding
        Throws:
        NullPointerException - if name is null

      • setValueBinding

        public void setValueBinding(String name,
                   ValueBinding binding)
        Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

        Store any ValueBinding specified for selected under value instead; otherwise, perform the default superclass processing for this method.

        Rely on the superclass implementation to wrap the argument ValueBinding in a ValueExpression.

        Overrides:
        setValueBinding in class UIComponentBase
        Parameters:
        name - Name of the attribute or property for which to set a ValueBinding
        binding - The ValueBinding to set, or null to remove any currently set ValueBinding
        Throws:
        NullPointerException - if name is null

      • getValueExpression

        public ValueExpression getValueExpression(String name)

        Return any ValueExpression set for value if a ValueExpression for selected is requested; otherwise, perform the default superclass processing for this method.

        Overrides:
        getValueExpression in class UIComponent
        Parameters:
        name - Name of the attribute or property for which to retrieve a ValueExpression
        Throws:
        NullPointerException - if name is null
        Since:
        1.2

      • setValueExpression

        public void setValueExpression(String name,
                      ValueExpression binding)

        Store any ValueExpression specified for selected under value instead; otherwise, perform the default superclass processing for this method.

        Overrides:
        setValueExpression in class UIComponent
        Parameters:
        name - Name of the attribute or property for which to set a ValueExpression
        binding - The ValueExpression to set, or null to remove any currently set ValueExpression
        Throws:
        NullPointerException - if name is null
        Since:
        1.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UISelectItem (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UISelectItem

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UISelectItem
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class UISelectItem
extends UIComponentBase

    UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component. The contents of the SelectItem can be specified in one of the following ways:

    • The value attribute's value is an instance of SelectItem.
    • The associated ValueExpression points at a model data item of type SelectItem.
    • A new SelectItem instance is synthesized from the values of the itemDescription, itemDisabled, itemLabel, itemEscaped, and itemValue attributes.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UISelectItem()
      Create a new UISelectItem instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      String getItemDescription()
      Return the description for this selection item.
      String getItemLabel()
      Return the localized label for this selection item.
      Object getItemValue()
      Return the server value for this selection item.
      Object getValue()
      Returns the value property of the UISelectItem.
      boolean isItemDisabled()
      Return the disabled setting for this selection item.
      boolean isItemEscaped()
      Return the escape setting for the label of this selection item.
      boolean isNoSelectionOption()

      Return the value of the noSelectionOption property.
      void setItemDescription(String itemDescription)
      Set the description for this selection item.
      void setItemDisabled(boolean itemDisabled)
      Set the disabled value for this selection item.
      void setItemEscaped(boolean itemEscaped)
      Set the escape value for the label of this selection item.
      void setItemLabel(String itemLabel)
      Set the localized label for this selection item.
      void setItemValue(Object itemValue)
      Set the server value for this selection item.
      void setNoSelectionOption(boolean noSelectionOption)

      Set the value of the noSelectionOption property.
      void setValue(Object value)
      Sets the value property of the UISelectItem.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UISelectItem

        public UISelectItem()

        Create a new UISelectItem instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getItemDescription

        public String getItemDescription()

        Return the description for this selection item.

      • setItemDescription

        public void setItemDescription(String itemDescription)

        Set the description for this selection item.

        Parameters:
        itemDescription - The new description

      • isItemDisabled

        public boolean isItemDisabled()

        Return the disabled setting for this selection item.

      • setItemDisabled

        public void setItemDisabled(boolean itemDisabled)

        Set the disabled value for this selection item.

        Parameters:
        itemDisabled - The new disabled flag

      • isItemEscaped

        public boolean isItemEscaped()

        Return the escape setting for the label of this selection item.

      • setItemEscaped

        public void setItemEscaped(boolean itemEscaped)

        Set the escape value for the label of this selection item.

        Parameters:
        itemEscaped - The new disabled flag

      • getItemLabel

        public String getItemLabel()

        Return the localized label for this selection item.

      • setItemLabel

        public void setItemLabel(String itemLabel)

        Set the localized label for this selection item.

        Parameters:
        itemLabel - The new localized label

      • getItemValue

        public Object getItemValue()

        Return the server value for this selection item.

      • setItemValue

        public void setItemValue(Object itemValue)

        Set the server value for this selection item.

        Parameters:
        itemValue - The new server value

      • getValue

        public Object getValue()

        Returns the value property of the UISelectItem.

      • setValue

        public void setValue(Object value)

        Sets the value property of the UISelectItem.

        Parameters:
        value - the new value

      • isNoSelectionOption

        public boolean isNoSelectionOption()

        Return the value of the noSelectionOption property. If the value of this property is true, the system interprets the option represented by this UISelectItem instance as representing a "no selection" option. See UISelectOne.validateValue(javax.faces.context.FacesContext, java.lang.Object) and UISelectMany.validateValue(javax.faces.context.FacesContext, java.lang.Object) for usage.

        Since:
        2.0

      • setNoSelectionOption

        public void setNoSelectionOption(boolean noSelectionOption)

        Set the value of the noSelectionOption property.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UISelectItems (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UISelectItems

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UISelectItems
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class UISelectItems
extends UIComponentBase

    UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component. The value of this component (set either directly, or acquired indirectly a ValueExpression, can be of any of the following types:

    • Single instance of SelectItem - This instance is added to the set of available options for the parent tag.
    • Array of SelectItem - This set of instances is added to the set of available options for the parent component, in ascending subscript order.
    • Collection of SelectItem - This set of instances is added to the set of available options for the parent component, in the order provided by an iterator over them.
    • Map - The keys of this object (once converted to Strings) are assumed to be labels, and the values of this object (once converted to Strings) are assumed to be values, of SelectItem instances that will be constructed dynamically and added to the set of available options for the parent component, in the order provided by an iterator over the keys.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UISelectItems()
      Create a new UISelectItems instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      Object getValue()
      Returns the value property of the UISelectItems.
      void setValue(Object value)
      Sets the value property of the UISelectItems.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UISelectItems

        public UISelectItems()

        Create a new UISelectItems instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getValue

        public Object getValue()

        Returns the value property of the UISelectItems.

      • setValue

        public void setValue(Object value)

        Sets the value property of the UISelectItems.

        Parameters:
        value - the new value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UISelectMany (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UISelectMany

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UISelectMany
  • All Implemented Interfaces:
    EventListener, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu

    public class UISelectMany
extends UIInput

    UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options. The user can modify the selected values. Optionally, the component can be preconfigured with zero or more currently selected items, by storing them as an array or Collection in the value property of the component.

    This component is generally rendered as a select box or a group of checkboxes.

    By default, the rendererType property must be set to "javax.faces.Listbox". This value can be changed by calling the setRendererType() method.

    The Renderer for this component must perform the following logic on getConvertedValue():

      Obtain the Converter using the following algorithm:

        If the component has an attached Converter, use it.

        If not, look for a ValueExpression for value (if any). The ValueExpression must point to something that is:

        • An array of primitives (such as int[]). Look up the registered by-class Converter for this primitive type.

        • An array of objects (such as Integer[] or String[]). Look up the registered by-class Converter for the underlying element type.

        • A java.util.Collection. Do not convert the values.

        If for any reason a Converter cannot be found, assume the type to be a String array.

      Use the selected Converter (if any) to convert each element in the values array from the request to the proper type, and store the result of each conversion in a data structure, called targetForConvertedValues for discussion. Create targetForConvertedValues using the following algorithm.

      • If the component has a ValueExpression for value and the type of the expression is an array, let targetForConvertedValues be a new array of the expected type.

      • If the component has a ValueExpression for value, let modelType be the type of the value expression. If modelType is a Collection, do the following to arrive at targetForConvertedValues:

        • Ask the component for its attribute under the key "collectionType", without the quotes. If there is a value for that key, the value must be a String that is a fully qualified Java class name, or a Class object, or a ValueExpression that evaluates to a String or a Class. In all cases, the value serves to identify the concrete type of the class that implements Collection. For discussion, this is called collectionType. Let targetForConvertedValues be a new instance of Collection implemented by the concrete class specified in collectionType. If, collectionType can not be discovered, or an instance of Collection implemented by the concrete class specified in collectionType cannot be created, throw a FacesException with a correctly localized error message. Note that FacesException is thrown instead of ConverterException because this case would only arise from developer error, rather than end-user error.

        • If there is no "collectionType" attribute, call getValue() on the component. The result will implement Collection. If the result also implements Cloneable, let targetForConvertedValues be the result of calling its clone() method, then calling clear() on the cloned Collection. If unable to clone the value for any reason, log a message and proceed to the next step.

        • If modelType is a concrete class, let targetForConvertedValues be a new instance of that class. Otherwise, the concrete type for targetForConvertedValues is taken from the following table. All classes are in the java.util package. All collections must be created with an initial capacity equal to the length of the values array from the request.

          If modelType is an instance of | then targetForConvertedValues must be an instance of
          SortedSet | TreeSet
          Queue | LinkedList
          Set | HashSet
          anything else | ArrayList

      • If the component does not have a ValueExpression for value, let targetForConvertedValues be an array of type Object.

      Return targetForConvertedValues after populating it with the converted values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.
      static String INVALID_MESSAGE_ID
      The message identifier of the FacesMessage to be created if a value not matching the available options is specified.

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UISelectMany()
      Create a new UISelectMany instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected boolean compareValues(Object previous, Object value)
      Return true if the new value is different from the previous value.
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      Object[] getSelectedValues()
      Return the currently selected values, or null if there are no currently selected values.
      ValueBinding getValueBinding(String name)
      Deprecated.
      this has been replaced by getValueExpression(java.lang.String).
      ValueExpression getValueExpression(String name)
      Return any ValueExpression set for value if a ValueExpression for selectedValues is requested; otherwise, perform the default superclass processing for this method.
      void setSelectedValues(Object[] selectedValues)
      Set the currently selected values, or null to indicate that there are no currently selected values.
      void setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
      void setValueExpression(String name, ValueExpression binding)
      Store any ValueExpression specified for selectedValues under value instead; otherwise, perform the default superclass processing for this method.
      protected void validateValue(FacesContext context, Object value)
      In addition to the standard validation behavior inherited from UIInput, ensure that any specified values are equal to one of the available options.

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

      • INVALID_MESSAGE_ID

        public static final String INVALID_MESSAGE_ID

        The message identifier of the FacesMessage to be created if a value not matching the available options is specified.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UISelectMany

        public UISelectMany()

        Create a new UISelectMany instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Overrides:
        getFamily in class UIInput

      • getSelectedValues

        public Object[] getSelectedValues()

        Return the currently selected values, or null if there are no currently selected values. This is a typesafe alias for getValue().

      • setSelectedValues

        public void setSelectedValues(Object[] selectedValues)

        Set the currently selected values, or null to indicate that there are no currently selected values. This is a typesafe alias for setValue().

        Parameters:
        selectedValues - The new selected values (if any)

      • getValueBinding

        public ValueBinding getValueBinding(String name)
        Deprecated. this has been replaced by getValueExpression(java.lang.String).

        Return any ValueBinding set for value if a ValueBinding for selectedValues is requested; otherwise, perform the default superclass processing for this method.

        This method relies on the superclass to provide the ValueExpression to ValueBinding wrapping.

        Overrides:
        getValueBinding in class UIComponentBase
        Parameters:
        name - Name of the attribute or property for which to retrieve a ValueBinding
        Throws:
        NullPointerException - if name is null

      • setValueBinding

        public void setValueBinding(String name,
                   ValueBinding binding)
        Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

        Store any ValueBinding specified for selectedValues under value instead; otherwise, perform the default superclass processing for this method.

        This method relies on the superclass to wrap the argument ValueBinding in a ValueExpression.

        Overrides:
        setValueBinding in class UIComponentBase
        Parameters:
        name - Name of the attribute or property for which to set a ValueBinding
        binding - The ValueBinding to set, or null to remove any currently set ValueBinding
        Throws:
        NullPointerException - if name is null

      • getValueExpression

        public ValueExpression getValueExpression(String name)

        Return any ValueExpression set for value if a ValueExpression for selectedValues is requested; otherwise, perform the default superclass processing for this method.

        Overrides:
        getValueExpression in class UIComponent
        Parameters:
        name - Name of the attribute or property for which to retrieve a ValueExpression
        Throws:
        NullPointerException - if name is null
        Since:
        1.2

      • setValueExpression

        public void setValueExpression(String name,
                      ValueExpression binding)

        Store any ValueExpression specified for selectedValues under value instead; otherwise, perform the default superclass processing for this method.

        Overrides:
        setValueExpression in class UIComponent
        Parameters:
        name - Name of the attribute or property for which to set a ValueExpression
        binding - The ValueExpression to set, or null to remove any currently set ValueExpression
        Throws:
        NullPointerException - if name is null
        Since:
        1.2

      • compareValues

        protected boolean compareValues(Object previous,
                    Object value)

        Return true if the new value is different from the previous value. Value comparison must not be sensitive to element order.

        Overrides:
        compareValues in class UIInput
        Parameters:
        previous - old value of this component
        value - new value of this component

      • validateValue

        protected void validateValue(FacesContext context,
                 Object value)

        In addition to the standard validation behavior inherited from UIInput, ensure that any specified values are equal to one of the available options. Before comparing each option, coerce the option value type to the type of this component's value following the Expression Language coercion rules. If the specified value is not equal to any of the options, enqueue an error message and set the valid property to false.

        This method must explicitly support a value argument that is a single value or a value argument that is a Collection or Array of values.

        If UIInput.isRequired() returns true, and the current value is equal to the value of an inner UISelectItem whose UISelectItem.isNoSelectionOption() method returns true, enqueue an error message and set the valid property to false.

        Overrides:
        validateValue in class UIInput
        Parameters:
        context - The FacesContext for the current request
        value - The converted value to test for membership.
        Throws:
        NullPointerException - if context is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UISelectOne (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UISelectOne

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UISelectOne
  • All Implemented Interfaces:
    EventListener, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder
    Direct Known Subclasses:
    HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio

    public class UISelectOne
extends UIInput

    UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options. The user can modify the selected value. Optionally, the component can be preconfigured with a currently selected item, by storing it as the value property of the component.

    This component is generally rendered as a select box or a group of radio buttons.

    By default, the rendererType property is set to "javax.faces.Menu". This value can be changed by calling the setRendererType() method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.
      static String INVALID_MESSAGE_ID
      The message identifier of the FacesMessage to be created if a value not matching the available options is specified.

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UISelectOne()
      Create a new UISelectOne instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      protected void validateValue(FacesContext context, Object value)
      In addition to the standard validation behavior inherited from UIInput, ensure that any specified value is equal to one of the available options.

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

      • INVALID_MESSAGE_ID

        public static final String INVALID_MESSAGE_ID

        The message identifier of the FacesMessage to be created if a value not matching the available options is specified.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UISelectOne

        public UISelectOne()

        Create a new UISelectOne instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Overrides:
        getFamily in class UIInput

      • validateValue

        protected void validateValue(FacesContext context,
                 Object value)

        In addition to the standard validation behavior inherited from UIInput, ensure that any specified value is equal to one of the available options. Before comparing each option, coerce the option value type to the type of this component's value following the Expression Language coercion rules. If the specified value is not equal to any of the options, enqueue an error message and set the valid property to false.

        If UIInput.isRequired() returns true, and the current value is equal to the value of an inner UISelectItem whose UISelectItem.isNoSelectionOption() method returns true, enqueue an error message and set the valid property to false.

        Overrides:
        validateValue in class UIInput
        Parameters:
        context - The FacesContext for the current request
        value - The converted value to test for membership.
        Throws:
        NullPointerException - if context is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIViewAction (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIViewAction

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIViewAction
  • All Implemented Interfaces:
    EventListener, ActionSource, ActionSource2, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class UIViewAction
extends UIComponentBase
implements ActionSource2

    UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.

    The ViewDeclarationLanguage implementation must cause an instance of this component to be placed in the view for each occurrence of an <f:viewAction /> element placed inside of an <f:metadata /> element. The user must place <f:metadata /> as a direct child of the UIViewRoot.

    Because this class implements ActionSource2, any actions that one would normally take on a component that implements ActionSource2, such as UICommand, are valid for instances of this class. Instances of this class participate in the regular JSF lifecycle, including on Ajax requests.

    The purpose of this component is to provide a light-weight front-controller solution for executing code upon the loading of a JSF view to support the integration of system services, content retrieval, view management, and navigation. This functionality is especially useful for non-faces (initial) requests.

    The most common use case for this component is to take actions necessary for a particular view, often with the help of one or more UIViewParameters.

    The NavigationHandler is consulted after the action is invoked to carry out the navigation case that matches the action signature and outcome. If a navigation case is matched that causes the new viewId to be different from the current viewId, the runtime must force a redirect to that matched navigation case with different viewId, regardless of whether or not the matched navigation case with different viewId called for a redirect. If the response is marked complete by the action, the lifecycle advances appropriately.

    It's important to note that the full component tree is not built before the UIViewAction components are processed on an non-faces (initial) request. Rather, the component tree only contains the ViewMetadata, an important part of the optimization of this component and what sets it apart from a PreRenderViewEvent listener.

    Since:
    2.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIViewAction()
      Create a new UIViewAction instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addActionListener(ActionListener listener)
      Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.
      void broadcast(FacesEvent event)

      Enable the method invocation specified by this component instance to return a value that performs navigation, similar in spirit to UICommand.broadcast(javax.faces.event.FacesEvent).
      void decode(FacesContext context)

      Override behavior from the superclass to queue an ActionEvent that may result in the invocation of the action or any actionListeners that may be associated with this instance.
      MethodBinding getAction()
      Deprecated.
      MethodExpression getActionExpression()
      Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
      MethodBinding getActionListener()
      Deprecated.
      ActionListener[] getActionListeners()
      Return the set of registered ActionListeners for this ActionSource instance.
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      String getPhase()

      Returns the name of the lifecycle phase in which the action is to be queued.
      boolean isImmediate()

      If the value of the component's immediate attribute is true, the action will be invoked during the Apply Request Values JSF lifecycle phase.
      boolean isOnPostback()

      If true this component will operate on postback.
      static boolean isProcessingBroadcast(FacesContext context)

      Returns true if the current request processing lifecycle is in the midst of processing the broadcast of an event queued during a call to decode(javax.faces.context.FacesContext).
      boolean isRendered()

      Return true if this component should take the actions specified in the decode(javax.faces.context.FacesContext) method.
      void removeActionListener(ActionListener listener)
      Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.
      void setAction(MethodBinding action)
      Deprecated.
      void setActionExpression(MethodExpression actionExpression)
      Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
      void setActionListener(MethodBinding actionListener)
      Deprecated.
      void setImmediate(boolean immediate)
      Set the "immediate execution" flag for this UIComponent.
      void setOnPostback(boolean onPostback)

      Controls whether or not this component operates on postback.
      void setPhase(String phase)

      Attempt to set the lifecycle phase in which this instance will queue its ActionEvent.
      void setRendered(boolean condition)

      Sets the if property of this component.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, clearInitialState, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIViewAction

        public UIViewAction()

        Create a new UIViewAction instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent

      • getAction

        @Deprecated
public MethodBinding getAction()
        Deprecated.

        If the implementing class also implements ActionSource2, the implementation of this method must call through to ActionSource2.getActionExpression() and examine the result. If the result came from a previous call to ActionSource.setAction(javax.faces.el.MethodBinding), extract the MethodBinding from it and return it. Otherwise, wrap the returned MethodExpression in a MethodBinding implementation, and return it.

        If the implementing class does not implement ActionSource2, return the MethodBindingpointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Specified by:
        getAction in interface ActionSource
        Since:
        2.2

      • setAction

        @Deprecated
public void setAction(MethodBinding action)
        Deprecated.

        If the implementing class also implements ActionSource2, the implementation of this method must wrap the argument action in a class that implements MethodExpression and call through to ActionSource2.setActionExpression(javax.el.MethodExpression), passing the wrapped action.

        If the implementing class does not implement ActionSource2, set the MethodBinding pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Any method referenced by such an expression must be public, with a return type of String, and accept no parameters.

        Specified by:
        setAction in interface ActionSource
        Parameters:
        action - The new MethodBinding expression
        Since:
        2.2

      • getActionListener

        @Deprecated
public MethodBinding getActionListener()
        Deprecated.

        If ActionSource.setActionListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to ActionSource.setActionListener(javax.faces.el.MethodBinding).

        The method to be invoked, if this UIComponent is activated by the user, will be called during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending upon the value of the immediate property.

        Specified by:
        getActionListener in interface ActionSource
        Since:
        2.2

      • setActionListener

        @Deprecated
public void setActionListener(MethodBinding actionListener)
        Deprecated.

        Wrap the argument actionListener in an implementation of ActionListener and store it in the internal data structure that backs the ActionSource.getActionListeners() method, taking care to over-write any instance that was stored by a previous call to setActionListener.

        Any method referenced by such an expression must be public, with a return type of void, and accept a single parameter of type ActionEvent.

        Specified by:
        setActionListener in interface ActionSource
        Parameters:
        actionListener - The new method binding expression
        Since:
        2.2

      • isImmediate

        public boolean isImmediate()

        If the value of the component's immediate attribute is true, the action will be invoked during the Apply Request Values JSF lifecycle phase. Otherwise, the action will be invoked during the Invoke Application phase, the default behavior. The phase can be set explicitly in the phase attribute, which takes precedence over the immediate attribute.

        Specified by:
        isImmediate in interface ActionSource
        Since:
        2.2

      • setImmediate

        public void setImmediate(boolean immediate)

        Set the "immediate execution" flag for this UIComponent.

        Specified by:
        setImmediate in interface ActionSource
        Parameters:
        immediate - The new immediate execution flag
        Since:
        2.2

      • getPhase

        public String getPhase()

        Returns the name of the lifecycle phase in which the action is to be queued.

        Since:
        2.2

      • setPhase

        public void setPhase(String phase)

        Attempt to set the lifecycle phase in which this instance will queue its ActionEvent. Pass the argument phase to PhaseId.phaseIdValueOf(java.lang.String). If the result is not one of the following values, FacesException must be thrown.

        • PhaseId.APPLY_REQUEST_VALUES

        • PhaseId.PROCESS_VALIDATIONS

        • PhaseId.UPDATE_MODEL_VALUES

        • PhaseId.INVOKE_APPLICATION

        If set, this value takes precedence over the immediate flag.

        Since:
        2.2

      • isProcessingBroadcast

        public static boolean isProcessingBroadcast(FacesContext context)

        Returns true if the current request processing lifecycle is in the midst of processing the broadcast of an event queued during a call to decode(javax.faces.context.FacesContext). The implementation of broadcast(javax.faces.event.FacesEvent) is responsible for ensuring that calls to this method accurately reflect this fact.

        Parameters:
        context - FacesContext for the current request
        Since:
        2.2

      • addActionListener

        public void addActionListener(ActionListener listener)

        Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.

        Specified by:
        addActionListener in interface ActionSource
        Parameters:
        listener - The ActionListener to be added
        Since:
        2.2

      • getActionListeners

        public ActionListener[] getActionListeners()

        Return the set of registered ActionListeners for this ActionSource instance. If there are no registered listeners, a zero-length array is returned.

        Specified by:
        getActionListeners in interface ActionSource
        Since:
        2.2

      • removeActionListener

        public void removeActionListener(ActionListener listener)

        Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.

        Specified by:
        removeActionListener in interface ActionSource
        Parameters:
        listener - The ActionListener to be removed
        Since:
        2.2

      • getActionExpression

        public MethodExpression getActionExpression()

        Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Note that it's possible that the returned MethodExpression is just a wrapper around a MethodBinding instance whith was set by a call to ActionSource.setAction(javax.faces.el.MethodBinding). This makes it possible for the default ActionListener to continue to work properly with older components.

        Specified by:
        getActionExpression in interface ActionSource2
        Since:
        2.2

      • setActionExpression

        public void setActionExpression(MethodExpression actionExpression)

        Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

        Any method referenced by such an expression must be public, with a return type of String, and accept no parameters.

        Specified by:
        setActionExpression in interface ActionSource2
        Parameters:
        actionExpression - The new method expression
        Since:
        2.2

      • isOnPostback

        public boolean isOnPostback()

        If true this component will operate on postback.

        Since:
        2.2

      • setOnPostback

        public void setOnPostback(boolean onPostback)

        Controls whether or not this component operates on postback.

        Since:
        2.2

      • isRendered

        public boolean isRendered()

        Return true if this component should take the actions specified in the decode(javax.faces.context.FacesContext) method.

        Overrides:
        isRendered in class UIComponentBase
        Since:
        2.2

      • setRendered

        public void setRendered(boolean condition)

        Sets the if property of this component.

        Overrides:
        setRendered in class UIComponentBase
        Parameters:
        condition - the new value of the property.
        Since:
        2.2

      • broadcast

        public void broadcast(FacesEvent event)
               throws AbortProcessingException

        Enable the method invocation specified by this component instance to return a value that performs navigation, similar in spirit to UICommand.broadcast(javax.faces.event.FacesEvent).

        Take no action and return immediately if any of the following conditions are true.

        • The response has already been marked as complete.

        • The current UIViewRoot is different from the event's source's UIViewRoot.

        Save a local reference to the viewId of the current UIViewRoot. For discussion, let this reference be viewIdBeforeAction.

        Obtain the ActionListener from the Application. Wrap the current FacesContext in an implementation of FacesContextWrapper that overrides the FacesContext.renderResponse() method such that it takes no action. Set the current FacesContext to be the FacesContextWrapper instance. Make it so a call to isProcessingBroadcast(javax.faces.context.FacesContext) on the current FacesContext will return true. This is necessary because the NavigationHandler will call this method to determine if the navigation is happening as the result of a UIViewAction. Invoke ActionListener.processAction(javax.faces.event.ActionEvent). In a finally block, restore the original FacesContext, make it so a call to isProcessingBroadcast(javax.faces.context.FacesContext) on the current context will return false and discard the wrapper.

        If the response has been marked as complete during the invocation of processAction(), take no further action and return. Otherwise, compare viewIdBeforeAction with the viewId of the UIViewRoot on the FacesContext after the invocation of processAction(). If the two viewIds are the same and no more UIViewAction events have been queued by a call to decode(javax.faces.context.FacesContext), call FacesContext.renderResponse() and return. It is possible to detect the case where no more UIViewAction events have been queued because the number of such events queued has been noted in the specification for decode(javax.faces.context.FacesContext). Otherwise, execute the lifecycle on the new UIViewRoot.

        Overrides:
        broadcast in class UIComponentBase
        Parameters:
        event - FacesEvent to be broadcast
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
        IllegalArgumentException - if the implementation class of this FacesEvent is not supported by this component
        NullPointerException - if event is null
        Since:
        2.2

      • decode

        public void decode(FacesContext context)

        Override behavior from the superclass to queue an ActionEvent that may result in the invocation of the action or any actionListeners that may be associated with this instance.

        Take no action if any of the following conditions are true:

        • The current request is a postback and the instance has been configured to not operate on postback. See isOnPostback().

        • The condition stated in the if property evaluates to false. See isRendered()

          .

        Instantiate an ActionEvent, passing this component instance as the source. Set the phaseId property of the ActionEvent as follows.

        • If this component instance has been configured with a specific lifecycle phase with a call to setPhase(java.lang.String) use that as the phaseId

        • If the value of the immediate property is true, use PhaseId.APPLY_REQUEST_VALUES.

        • Otherwise, use PhaseId.INVOKE_APPLICATION.

        Queue the event with a call to UIComponentBase.queueEvent(javax.faces.event.FacesEvent). Keep track of the number of events that are queued in this way on this run through the lifecycle. This information is necessary during processing in broadcast(javax.faces.event.FacesEvent).

        Overrides:
        decode in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIViewParameter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIViewParameter

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UIViewParameter
  • All Implemented Interfaces:
    EventListener, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class UIViewParameter
extends UIInput

    UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property. This is a bi-directional binding.

    The ViewDeclarationLanguage implementation must cause an instance of this component to appear in the view for each occurrence of an <f:viewParam /> element placed inside of an <f:metadata /> element. The user must place this facet within the UIViewRoot.

    Because this class extends UIInput any actions that one would normally take on a UIInput instance are valid for instances of this class. Instances of this class participate in the regular JSF lifecycle, including on Ajax requests.

    Since:
    2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  UIViewParameter.Reference

      Inner class to encapsulate a UIViewParameter instance so that it may be safely referenced regardless of whether or not the current view is the same as the view in which this UIViewParameter resides.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIViewParameter()
      Create a new UIViewParameter instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void decode(FacesContext context)

      Override behavior from superclass to pull a value from the incoming request parameter map under the name given by getName() and store it with a call to UIInput.setSubmittedValue(java.lang.Object).
      void encodeAll(FacesContext context)

      Called specially by UIViewRoot.encodeEnd(javax.faces.context.FacesContext), this method simply sets the submitted value to be the return from getStringValue(javax.faces.context.FacesContext).
      protected Object getConvertedValue(FacesContext context, Object submittedValue)

      Because this class has no Renderer, leverage the one from the standard HTML_BASIC RenderKit with component-family: javax.faces.Input and renderer-type: javax.faces.Text and call its Renderer.getConvertedValue(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object) method.
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      String getName()

      Return the request parameter name from which the value is retrieved.
      String getStringValue(FacesContext context)

      If the value of this parameter comes from a ValueExpression return the value of the expression, otherwise, return the local value.
      String getStringValueFromModel(FacesContext context)

      Manually perform standard conversion steps to get a string value from the value expression.
      Object getSubmittedValue()

      Assume that the submitted value is always a string, but the return type from this method is Object..
      boolean isImmediate()

      Return false.
      void processValidators(FacesContext context)

      Specialize superclass behavior to treat null differently.
      void setName(String name)

      Set the request parameter name from which the value is retrieved.
      void setSubmittedValue(Object submittedValue)
      PENDING (docs) Interesting that submitted value isn't saved by the parent
      void updateModel(FacesContext context)

      Call through to superclass UIInput.updateModel(javax.faces.context.FacesContext) then take the additional action of pushing the value into request scope if and only if the value is not a value expression, is valid, and the local value was set on this lifecycle execution.

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, getConverterMessage, getRequiredMessage, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, validate, validateValue

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIViewParameter

        public UIViewParameter()

        Create a new UIViewParameter instance with default property values.

    • Method Detail

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Overrides:
        getFamily in class UIInput

      • getName

        public String getName()

        Return the request parameter name from which the value is retrieved.

        Since:
        2.0

      • setName

        public void setName(String name)

        Set the request parameter name from which the value is retrieved.

        Parameters:
        name - The new request parameter name.
        Since:
        2.0

      • isImmediate

        public boolean isImmediate()

        Return false. The immediate setting is not relevant for view parameters and must be assumed to be false.

        Specified by:
        isImmediate in interface EditableValueHolder
        Overrides:
        isImmediate in class UIInput
        Since:
        2.0

      • getSubmittedValue

        public Object getSubmittedValue()

        Assume that the submitted value is always a string, but the return type from this method is Object..

        Specified by:
        getSubmittedValue in interface EditableValueHolder
        Overrides:
        getSubmittedValue in class UIInput
        Since:
        2.0

      • setSubmittedValue

        public void setSubmittedValue(Object submittedValue)
        PENDING (docs) Interesting that submitted value isn't saved by the parent
        Specified by:
        setSubmittedValue in interface EditableValueHolder
        Overrides:
        setSubmittedValue in class UIInput
        Parameters:
        submittedValue - The new submitted value

      • decode

        public void decode(FacesContext context)

        Override behavior from superclass to pull a value from the incoming request parameter map under the name given by getName() and store it with a call to UIInput.setSubmittedValue(java.lang.Object).

        Overrides:
        decode in class UIInput
        Parameters:
        context - FacesContext for the request we are processing
        Since:
        2.0

      • processValidators

        public void processValidators(FacesContext context)

        Specialize superclass behavior to treat null differently. In this class, a null value along with the "required" flag being set to true will cause a validation failure.

        Overrides:
        processValidators in class UIInput
        Parameters:
        context -
        Since:
        2.0

      • updateModel

        public void updateModel(FacesContext context)

        Call through to superclass UIInput.updateModel(javax.faces.context.FacesContext) then take the additional action of pushing the value into request scope if and only if the value is not a value expression, is valid, and the local value was set on this lifecycle execution.

        Overrides:
        updateModel in class UIInput
        Parameters:
        context - FacesContext for the request we are processing
        Since:
        2.0

      • encodeAll

        public void encodeAll(FacesContext context)
               throws IOException

        Called specially by UIViewRoot.encodeEnd(javax.faces.context.FacesContext), this method simply sets the submitted value to be the return from getStringValue(javax.faces.context.FacesContext).

        Overrides:
        encodeAll in class UIComponent
        Throws:
        IOException - if an input/output error occurs while rendering
        Since:
        2.0

      • getStringValue

        public String getStringValue(FacesContext context)

        If the value of this parameter comes from a ValueExpression return the value of the expression, otherwise, return the local value.

        Since:
        2.0

      • getStringValueFromModel

        public String getStringValueFromModel(FacesContext context)
                               throws ConverterException

        Manually perform standard conversion steps to get a string value from the value expression.

        Throws:
        ConverterException
        Since:
        2.0

      • getConvertedValue

        protected Object getConvertedValue(FacesContext context,
                       Object submittedValue)
                            throws ConverterException

        Because this class has no Renderer, leverage the one from the standard HTML_BASIC RenderKit with component-family: javax.faces.Input and renderer-type: javax.faces.Text and call its Renderer.getConvertedValue(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object) method.

        Overrides:
        getConvertedValue in class UIInput
        Throws:
        ConverterException
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIViewParameter.Reference (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIViewParameter.Reference

  • java.lang.Object
    • javax.faces.component.UIViewParameter.Reference
  • Enclosing class:
    UIViewParameter

    public static class UIViewParameter.Reference
extends Object

    Inner class to encapsulate a UIViewParameter instance so that it may be safely referenced regardless of whether or not the current view is the same as the view in which this UIViewParameter resides.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      UIViewParameter.Reference(FacesContext context, UIViewParameter param, int indexInParent, String viewIdAtTimeOfConstruction)

      Construct a reference to a UIViewParameter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      UIViewParameter getUIViewParameter(FacesContext context)

      Return the UIViewParameter to which this instance refers.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • UIViewParameter.Reference

        public UIViewParameter.Reference(FacesContext context,
                         UIViewParameter param,
                         int indexInParent,
                         String viewIdAtTimeOfConstruction)

        Construct a reference to a UIViewParameter. This constructor cause the StateHolder.saveState(javax.faces.context.FacesContext) method to be called on argument UIViewParameter.

        Parameters:
        context - the FacesContextfor this request
        indexInParent - the index of the UIViewParameter in its parent UIPanel.
        viewIdAtTimeOfConstruction - the viewId of the view in which the UIViewParameter is included. This may not be the same as the viewId from the context argument.
        Since:
        2.0

    • Method Detail

      • getUIViewParameter

        public UIViewParameter getUIViewParameter(FacesContext context)

        Return the UIViewParameter to which this instance refers. If the current viewId is the same as the viewId passed to our constructor, use the index passed to the constructor to find the actual UIViewParameter instance and return it. Otherwise, call StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) on the saved state and return the result.

        Parameters:
        context - the FacesContextfor this request
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIViewRoot (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UIViewRoot

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIViewRoot
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, UniqueIdVendor, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class UIViewRoot
extends UIComponentBase
implements UniqueIdVendor

    UIViewRoot is the UIComponent that represents the root of the UIComponent tree. This component renders markup as the response to Ajax requests. It also serves as the root of the component tree, and as a place to hang per-view PhaseListeners.

    For each of the following lifecycle phase methods:

    • processDecodes(javax.faces.context.FacesContext)

    • processValidators(javax.faces.context.FacesContext)

    • processUpdates(javax.faces.context.FacesContext)

    • processApplication(javax.faces.context.FacesContext)

    • RenderResponse, via encodeBegin(javax.faces.context.FacesContext) and encodeEnd(javax.faces.context.FacesContext)

    Take the following action regarding PhaseListeners.

      Initialize a state flag to false.

      If getBeforePhaseListener() returns non-null, invoke the listener, passing in the correct corresponding PhaseId for this phase.

      Upon return from the listener, call FacesContext.getResponseComplete() and FacesContext.getRenderResponse(). If either return true set the internal state flag to true.

      If or one or more listeners have been added by a call to addPhaseListener(javax.faces.event.PhaseListener), invoke the beforePhase method on each one whose PhaseListener.getPhaseId() matches the current phaseId, passing in the same PhaseId as in the previous step.

      Upon return from each listener, call FacesContext.getResponseComplete() and FacesContext.getRenderResponse(). If either return true set the internal state flag to true.

      Execute any processing for this phase if the internal state flag was not set.

      If getAfterPhaseListener() returns non-null, invoke the listener, passing in the correct corresponding PhaseId for this phase.

      If or one or more listeners have been added by a call to addPhaseListener(javax.faces.event.PhaseListener), invoke the afterPhase method on each one whose PhaseListener.getPhaseId() matches the current phaseId, passing in the same PhaseId as in the previous step.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static String COMPONENT_FAMILY
      The standard component family for this component.
      static String COMPONENT_TYPE
      The standard component type for this component.
      static String | METADATA_FACET_NAME
      static String UNIQUE_ID_PREFIX
      The prefix that will be used for identifiers generated by the createUniqueId() method.
      static String VIEW_PARAMETERS_KEY

      The key in the value set of the view metadata BeanDescriptor, the value of which is a List<UIViewParameter.Reference>.

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      UIViewRoot()
      Create a new UIViewRoot instance with default property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addComponentResource(FacesContext context, UIComponent componentResource)

      Add argument component, which is assumed to represent a resource instance, as a resource to this view.
      void addComponentResource(FacesContext context, UIComponent componentResource, String target)

      Add argument component, which is assumed to represent a resource instance, as a resource to this view.
      void addPhaseListener(PhaseListener newPhaseListener)
      Add the argument newPhaseListener to the list of PhaseListeners on this UIViewRoot.
      void broadcastEvents(FacesContext context, PhaseId phaseId)

      Broadcast any events that have been queued.
      String createUniqueId()
      Generate an identifier for a component.
      String createUniqueId(FacesContext context, String seed)
      Generate an identifier for a component.
      void encodeBegin(FacesContext context)
      Override the default UIComponentBase.encodeBegin(javax.faces.context.FacesContext) behavior.
      void encodeChildren(FacesContext context)

      If PartialViewContext.isAjaxRequest() returns true, perform partial rendering by calling PartialViewContext.processPartial(javax.faces.event.PhaseId) with PhaseId.RENDER_RESPONSE.
      void encodeEnd(FacesContext context)

      If getAfterPhaseListener() returns non-null, invoke it, passing a PhaseEvent for the PhaseId.RENDER_RESPONSE phase.
      MethodExpression getAfterPhaseListener()
      Return the MethodExpression that will be invoked after this view is rendered.
      MethodExpression getBeforePhaseListener()
      Return the MethodExpression that will be invoked before this view is rendered.
      List<UIComponent> getComponentResources(FacesContext context, String target)

      Return an unmodifiable List of UIComponents for the provided target agrument.
      String getFamily()
      Return the identifier of the component family to which this component belongs.
      Locale getLocale()
      Return the Locale to be used in localizing the response being created for this view.
      List<PhaseListener> getPhaseListeners()

      Return an unmodifiable list of the PhaseListener instances attached to this UIViewRoot instance.
      String getRenderKitId()
      Return the render kit identifier of the RenderKit associated with this view.
      boolean getRendersChildren()

      Call UIComponentBase.getRendersChildren() If PartialViewContext.isAjaxRequest() returns true this method must return true.
      String getViewId()
      Return the view identifier for this view.
      List<SystemEventListener> getViewListenersForEventClass(Class<? extends SystemEvent> systemEvent)

      Return the SystemEventListener instances registered on this UIComponent instance that are interested in events of type eventClass.
      Map<String,Object> getViewMap()

      This implementation simply calls through to getViewMap(boolean), passing true as the argument, and returns the result.
      Map<String,Object> getViewMap(boolean create)

      Returns a Map that acts as the interface to the data store that is the "view scope", or, if this instance does not have such a Map and the create argument is true, creates one and returns it.
      boolean isInView()

      Override superclass method to always return true because a UIViewRoot is defined to always be in a view.
      void processApplication(FacesContext context)
      Broadcast any events that have been queued for the Invoke Application phase of the request processing lifecycle and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.
      void processDecodes(FacesContext context)
      void processRestoreState(FacesContext context, Object state)

      The default implementation must call UIComponentBase.processRestoreState(javax.faces.context.FacesContext, java.lang.Object) from within a try block.
      void processUpdates(FacesContext context)
      void processValidators(FacesContext context)
      void queueEvent(FacesEvent event)
      Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) behavior to accumulate the queued events for later broadcasting.
      void removeComponentResource(FacesContext context, UIComponent componentResource)

      Remove argument component, which is assumed to represent a resource instance, as a resource to this view.
      void removeComponentResource(FacesContext context, UIComponent componentResource, String target)

      Remove argument component, which is assumed to represent a resource instance, as a resource to this view.
      void removePhaseListener(PhaseListener toRemove)
      If the argument toRemove is in the list of PhaseListeners for this instance, it must be removed.
      void resetValues(FacesContext context, Collection<String> clientIds)

      Visit the clientIds and, if the component is an instance of EditableValueHolder, call its EditableValueHolder.resetValue() method.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      void restoreViewScopeState(FacesContext context, Object state)

      Restore ViewScope state.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setAfterPhaseListener(MethodExpression newAfterPhase)
      Allow an arbitrary method to be called for the "afterPhase" event as the UIViewRoot runs through its lifecycle.
      void setBeforePhaseListener(MethodExpression newBeforePhase)
      Allow an arbitrary method to be called for the "beforePhase" event as the UIViewRoot runs through its lifecycle.
      void setInView(boolean isInView)

      Overridden to take no action.
      void setLocale(Locale locale)
      Set the Locale to be used in localizing the response being created for this view.
      void setRenderKitId(String renderKitId)
      Set the render kit identifier of the RenderKit associated with this view.
      void setViewId(String viewId)
      Set the view identifier for this view.
      void subscribeToViewEvent(Class<? extends SystemEvent> systemEvent, SystemEventListener listener)

      Install the listener instance referenced by argument listener into the UIViewRoot as a listener for events of type systemEventClass.
      void unsubscribeFromViewEvent(Class<? extends SystemEvent> systemEvent, SystemEventListener listener)

      Remove the listener instance referenced by argument listener from the UIViewRoot as a listener for events of type systemEventClass.

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processSaveState, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • METADATA_FACET_NAME

        public static final String METADATA_FACET_NAME
        See Also:
        Constant Field Values

      • VIEW_PARAMETERS_KEY

        public static final String VIEW_PARAMETERS_KEY

        The key in the value set of the view metadata BeanDescriptor, the value of which is a List<UIViewParameter.Reference>.

        Since:
        2.0
        See Also:
        Constant Field Values

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

      • COMPONENT_FAMILY

        public static final String COMPONENT_FAMILY

        The standard component family for this component.

        See Also:
        Constant Field Values

      • UNIQUE_ID_PREFIX

        public static final String UNIQUE_ID_PREFIX

        The prefix that will be used for identifiers generated by the createUniqueId() method.

        See Also:
        Constant Field Values

    • Constructor Detail

      • UIViewRoot

        public UIViewRoot()

        Create a new UIViewRoot instance with default property values.

    • Method Detail

      • isInView

        public boolean isInView()

        Override superclass method to always return true because a UIViewRoot is defined to always be in a view.

        Overrides:
        isInView in class UIComponent
        Since:
        2.0

      • setInView

        public void setInView(boolean isInView)

        Overridden to take no action.

        Overrides:
        setInView in class UIComponent
        Parameters:
        isInView -
        Since:
        2.0

      • getFamily

        public String getFamily()
        Description copied from class: UIComponent

        Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

        Specified by:
        getFamily in class UIComponent
        See Also:
        UIComponent.getFamily()

      • getRenderKitId

        public String getRenderKitId()

        Return the render kit identifier of the RenderKit associated with this view. Unless explicitly set, as in ViewHandler.createView(javax.faces.context.FacesContext, java.lang.String), the returned value will be null.

      • setRenderKitId

        public void setRenderKitId(String renderKitId)

        Set the render kit identifier of the RenderKit associated with this view. This method may be called at any time between the end of Apply Request Values phase of the request processing lifecycle (i.e. when events are being broadcast) and the beginning of the Render Response phase.

        Parameters:
        renderKitId - The new RenderKit identifier, or null to disassociate this view with any specific RenderKit instance

      • getViewId

        public String getViewId()

        Return the view identifier for this view.

      • setViewId

        public void setViewId(String viewId)

        Set the view identifier for this view.

        Parameters:
        viewId - The new view identifier

      • getBeforePhaseListener

        public MethodExpression getBeforePhaseListener()

        Return the MethodExpression that will be invoked before this view is rendered.

        Returns:
        the MethodExpression that will be invoked before this view is rendered.
        Since:
        1.2

      • setBeforePhaseListener

        public void setBeforePhaseListener(MethodExpression newBeforePhase)

        Allow an arbitrary method to be called for the "beforePhase" event as the UIViewRoot runs through its lifecycle. This method will be called for all phases except PhaseId.RESTORE_VIEW. Unlike a true PhaseListener, this approach doesn't allow for only receiving PhaseEvents for a given phase.

        The method must conform to the signature of PhaseListener.beforePhase(javax.faces.event.PhaseEvent).

        Parameters:
        newBeforePhase - the MethodExpression that will be invoked before this view is rendered.
        Since:
        1.2

      • getAfterPhaseListener

        public MethodExpression getAfterPhaseListener()

        Return the MethodExpression that will be invoked after this view is rendered.

        Returns:
        the MethodExpression that will be invoked after this view is rendered.
        Since:
        1.2

      • setAfterPhaseListener

        public void setAfterPhaseListener(MethodExpression newAfterPhase)

        Allow an arbitrary method to be called for the "afterPhase" event as the UIViewRoot runs through its lifecycle. This method will be called for all phases including PhaseId.RESTORE_VIEW. Unlike a true PhaseListener, this approach doesn't allow for only receiving PhaseEvents for a given phase.

        The method must conform to the signature of PhaseListener.afterPhase(javax.faces.event.PhaseEvent).

        Parameters:
        newAfterPhase - the MethodExpression that will be invoked after this view is rendered.
        Since:
        1.2

      • removePhaseListener

        public void removePhaseListener(PhaseListener toRemove)

        If the argument toRemove is in the list of PhaseListeners for this instance, it must be removed.

        Parameters:
        toRemove - the PhaseListener to remove.
        Since:
        1.2

      • addPhaseListener

        public void addPhaseListener(PhaseListener newPhaseListener)

        Add the argument newPhaseListener to the list of PhaseListeners on this UIViewRoot.

        Parameters:
        newPhaseListener - the PhaseListener to add
        Since:
        1.2

      • getPhaseListeners

        public List<PhaseListener> getPhaseListeners()

        Return an unmodifiable list of the PhaseListener instances attached to this UIViewRoot instance.

        Since:
        2.0

      • addComponentResource

        public void addComponentResource(FacesContext context,
                        UIComponent componentResource)

        Add argument component, which is assumed to represent a resource instance, as a resource to this view. A resource instance is rendered by a resource Renderer, as described in the Standard HTML RenderKit. The default implementation must call through to addComponentResource(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String).

        Parameters:
        context - FacesContext for the current request
        componentResource - The UIComponent representing a Resource instance
        Since:
        2.0

      • addComponentResource

        public void addComponentResource(FacesContext context,
                        UIComponent componentResource,
                        String target)

        Add argument component, which is assumed to represent a resource instance, as a resource to this view. A resource instance is rendered by a resource Renderer, as described in the Standard HTML RenderKit.

        The component must be added using the following algorithm:

        • If the target argument is null, look for a target attribute on the component. If there is no target attribute, set target to be the default value head

        • Call getComponentResources(javax.faces.context.FacesContext, java.lang.String) to obtain the child list for the given target.

        • If the component ID of componentResource matches the the ID of a resource that has allready been added, remove the old resource.

        • Add the component resource to the list.

        Parameters:
        context - FacesContext for the current request
        componentResource - The UIComponent representing a Resource instance
        target - The name of the facet for which the UIComponent will be added
        Since:
        2.0

      • getComponentResources

        public List<UIComponent> getComponentResources(FacesContext context,
                                      String target)

        Return an unmodifiable List of UIComponents for the provided target agrument. Each component in the List is assumed to represent a resource instance.

        The default implementation must use an algorithm equivalent to the the following.

        • Locate the facet for the component by calling getFacet() using target as the argument.
        • If the facet is not found, create the facet by calling context.getApplication().createComponent(). The argument to this method must refer to a component that extends UIPanel and overrides the encodeAll() method to take no action. This is necessary to prevent component resources from being inadvertently rendered.
          • Set the id of the facet to be a string created by prepending the literal string “javax_faces_location_” (without the quotes) to the value of the target argument
          • Add the facet to the facets Map using target as the key
        • return the children of the facet
        Parameters:
        target - The name of the facet for which the components will be returned.
        Returns:
        A List of UIComponent children of the facet with the name target. If no children are found for the facet, return Collections.emptyList().
        Throws:
        NullPointerException - if target or context is null
        Since:
        2.0

      • removeComponentResource

        public void removeComponentResource(FacesContext context,
                           UIComponent componentResource)

        Remove argument component, which is assumed to represent a resource instance, as a resource to this view.

        Parameters:
        context - FacesContext for the current request
        componentResource - The UIComponent representing a Resource instance
        Since:
        2.0

      • removeComponentResource

        public void removeComponentResource(FacesContext context,
                           UIComponent componentResource,
                           String target)

        Remove argument component, which is assumed to represent a resource instance, as a resource to this view. A resource instance is rendered by a resource Renderer, as described in the Standard HTML RenderKit.

        The component must be removed using the following algorithm:

        • If the target argument is null, look for a target attribute on the component.
          If there is no target attribute, set target to be the default value head
        • Call getComponentResources(javax.faces.context.FacesContext, java.lang.String) to obtain the child list for the given target.
        • Remove the component resource from the child list.

        Parameters:
        context - FacesContext for the current request
        componentResource - The UIComponent representing a Resource instance
        target - The name of the facet for which the UIComponent will be added
        Since:
        2.0

      • queueEvent

        public void queueEvent(FacesEvent event)

        Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) behavior to accumulate the queued events for later broadcasting.

        Overrides:
        queueEvent in class UIComponentBase
        Parameters:
        event - FacesEvent to be queued
        Throws:
        IllegalStateException - if this component is not a descendant of a UIViewRoot
        NullPointerException - if event is null

      • broadcastEvents

        public void broadcastEvents(FacesContext context,
                   PhaseId phaseId)

        Broadcast any events that have been queued. First broadcast events that have been queued for PhaseId.ANY_PHASE. Then broadcast ane events that have been queued for the current phase. In both cases, UIComponent.pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent) must be called before the event is broadcast, and UIComponent.popComponentFromEL(javax.faces.context.FacesContext) must be called after the return from the broadcast, even in the case of an exception.

        Parameters:
        context - FacesContext for the current request
        phaseId - PhaseId of the current phase
        Since:
        2.0

      • processRestoreState

        public void processRestoreState(FacesContext context,
                       Object state)

        The default implementation must call UIComponentBase.processRestoreState(javax.faces.context.FacesContext, java.lang.Object) from within a try block. The try block must have a finally block that ensures that no FacesEvents remain in the event queue.

        Overrides:
        processRestoreState in class UIComponentBase
        Parameters:
        context - the FacesContext for this requets
        state - the opaque state object obtained from the StateManager

      • processDecodes

        public void processDecodes(FacesContext context)

        Perform partial processing by calling PartialViewContext.processPartial(javax.faces.event.PhaseId) with PhaseId.APPLY_REQUEST_VALUES if:

        • PartialViewContext.isPartialRequest() returns true and we don't have a request to process all components in the view (PartialViewContext.isExecuteAll() returns false)
        Perform full processing by calling UIComponentBase.processDecodes(javax.faces.context.FacesContext) if one of the following conditions are met:
        • PartialViewContext.isPartialRequest() returns true and we have a request to process all components in the view (PartialViewContext.isExecuteAll() returns true)
        • PartialViewContext.isPartialRequest() returns false

        Override the default UIComponentBase.processDecodes(javax.faces.context.FacesContext) behavior to broadcast any queued events after the default processing or partial processing has been completed and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.

        Overrides:
        processDecodes in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • resetValues

        public void resetValues(FacesContext context,
               Collection<String> clientIds)

        Visit the clientIds and, if the component is an instance of EditableValueHolder, call its EditableValueHolder.resetValue() method. Use UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback) to do the visiting.

        Parameters:
        context - the FacesContext for the request we are processing.
        clientIds - The client ids to be visited, on which the described action will be taken.
        Since:
        2.2

      • encodeBegin

        public void encodeBegin(FacesContext context)
                 throws IOException

        Override the default UIComponentBase.encodeBegin(javax.faces.context.FacesContext) behavior. If getBeforePhaseListener() returns non-null, invoke it, passing a PhaseEvent for the PhaseId.RENDER_RESPONSE phase. If the internal list populated by calls to addPhaseListener(javax.faces.event.PhaseListener) is non-empty, any listeners in that list must have their PhaseListener.beforePhase(javax.faces.event.PhaseEvent) method called, passing the PhaseEvent. Any errors that occur during invocation of any of the the beforePhase listeners must be logged and swallowed. After listeners are invoked call superclass processing.

        Overrides:
        encodeBegin in class UIComponentBase
        Parameters:
        context - FacesContext for the response we are creating
        Throws:
        IOException - if an input/output error occurs while rendering

      • encodeChildren

        public void encodeChildren(FacesContext context)
                    throws IOException

        If PartialViewContext.isAjaxRequest() returns true, perform partial rendering by calling PartialViewContext.processPartial(javax.faces.event.PhaseId) with PhaseId.RENDER_RESPONSE. If PartialViewContext.isAjaxRequest() returns false, delegate to the parent UIComponentBase.encodeChildren(javax.faces.context.FacesContext) method.

        Overrides:
        encodeChildren in class UIComponentBase
        Parameters:
        context - FacesContext for the response we are creating
        Throws:
        IOException - if an input/output error occurs while rendering
        Since:
        2.0

      • encodeEnd

        public void encodeEnd(FacesContext context)
               throws IOException

        If getAfterPhaseListener() returns non-null, invoke it, passing a PhaseEvent for the PhaseId.RENDER_RESPONSE phase. Any errors that occur during invocation of the afterPhase listener must be logged and swallowed. If the current view has view parameters, as indicated by a non-empty and non-UnsupportedOperationException throwing return from ViewDeclarationLanguage.getViewMetadata(javax.faces.context.FacesContext, String), call UIViewParameter.encodeAll(javax.faces.context.FacesContext) on each parameter. If calling getViewParameters() causes UnsupportedOperationException to be thrown, the exception must be silently swallowed.

        Overrides:
        encodeEnd in class UIComponentBase
        Parameters:
        context - FacesContext for the response we are creating
        Throws:
        IOException - if an input/output error occurs while rendering

      • getRendersChildren

        public boolean getRendersChildren()

        Call UIComponentBase.getRendersChildren() If PartialViewContext.isAjaxRequest() returns true this method must return true.

        Overrides:
        getRendersChildren in class UIComponentBase
        Since:
        2.0

      • processValidators

        public void processValidators(FacesContext context)

        Perform partial processing by calling PartialViewContext.processPartial(javax.faces.event.PhaseId) with PhaseId.PROCESS_VALIDATIONS if:

        • PartialViewContext.isPartialRequest() returns true and we don't have a request to process all components in the view (PartialViewContext.isExecuteAll() returns false)
        Perform full processing by calling UIComponentBase.processValidators(javax.faces.context.FacesContext) if one of the following conditions are met:
        • PartialViewContext.isPartialRequest() returns true and we have a request to process all components in the view (PartialViewContext.isExecuteAll() returns true)
        • PartialViewContext.isPartialRequest() returns false

        Override the default UIComponentBase.processValidators(javax.faces.context.FacesContext) behavior to broadcast any queued events after the default processing or partial processing has been completed and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.

        Overrides:
        processValidators in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • processUpdates

        public void processUpdates(FacesContext context)

        Perform partial processing by calling PartialViewContext.processPartial(javax.faces.event.PhaseId) with PhaseId.UPDATE_MODEL_VALUES if:

        • PartialViewContext.isPartialRequest() returns true and we don't have a request to process all components in the view (PartialViewContext.isExecuteAll() returns false)
        Perform full processing by calling UIComponentBase.processUpdates(javax.faces.context.FacesContext) if one of the following conditions are met:
        • PartialViewContext.isPartialRequest() returns true and we have a request to process all components in the view (PartialViewContext.isExecuteAll() returns true)
        • PartialViewContext.isPartialRequest() returns false

        Override the default UIComponentBase behavior to broadcast any queued events after the default processing or partial processing has been completed and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.

        Overrides:
        processUpdates in class UIComponentBase
        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • processApplication

        public void processApplication(FacesContext context)

        Broadcast any events that have been queued for the Invoke Application phase of the request processing lifecycle and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.

        Parameters:
        context - FacesContext for the request we are processing
        Throws:
        NullPointerException - if context is null

      • createUniqueId

        public String createUniqueId()

        Generate an identifier for a component. The identifier will be prefixed with UNIQUE_ID_PREFIX, and will be unique within the non-NamingContainer child sub-trees of this UIViewRoot.

      • createUniqueId

        public String createUniqueId(FacesContext context,
                    String seed)

        Generate an identifier for a component. The identifier will be prefixed with UNIQUE_ID_PREFIX, and will be unique within this UIViewRoot. Optionally, a unique seed value can be supplied by component creators which should be included in the generated unique id.

        Specified by:
        createUniqueId in interface UniqueIdVendor
        Parameters:
        context - FacesContext
        seed - an optional seed value - e.g. based on the position of the component in the VDL-template
        Returns:
        a unique-id in this component-container

      • getLocale

        public Locale getLocale()

        Return the Locale to be used in localizing the response being created for this view.

        Algorithm:

        If we have a locale ivar, return it. If we have a value expression for "locale", get its value. If the value is null, return the result of calling ViewHandler.calculateLocale(javax.faces.context.FacesContext). If the value is an instance of java.util.Locale return it. If the value is a String, convert it to a java.util.Locale and return it. If there is no value expression for "locale", return the result of calling ViewHandler.calculateLocale(javax.faces.context.FacesContext).

        Returns:
        The current Locale obtained by executing the above algorithm.

      • setLocale

        public void setLocale(Locale locale)

        Set the Locale to be used in localizing the response being created for this view.

        Parameters:
        locale - The new localization Locale

      • getViewMap

        public Map<String,Object> getViewMap()

        This implementation simply calls through to getViewMap(boolean), passing true as the argument, and returns the result.

        Since:
        2.0

      • getViewMap

        public Map<String,Object> getViewMap(boolean create)

        Returns a Map that acts as the interface to the data store that is the "view scope", or, if this instance does not have such a Map and the create argument is true, creates one and returns it. This map must be instantiated lazily and cached for return from subsequent calls to this method on this UIViewRoot instance. Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) must be called, passing PostConstructViewMapEvent .class as the first argument and this UIViewRoot instance as the second argument.

        The returned Map must be implemented such that calling clear() on the Map causes Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) to be called, passing PreDestroyViewMapEvent .class as the first argument and this UIViewRoot instance as the second argument.

        Depending upon application configuration, objects stored in the view map may need to be Serializable. In general, it is a good idea to ensure that any objects stored in the view map are Serializable.

        For reasons made clear in ViewScoped, this map must ultimately be stored in the session. For this reason, a true value for the create argument will force the session to be created with a call to ExternalContext.getSession(boolean).

        See FacesContext.setViewRoot(javax.faces.component.UIViewRoot) for the specification of when the clear() method must be called.

Parameters:
create - true to create a new Map for this instance if necessary; false to return null if there's no current Map.
Since:
2.0

  • subscribeToViewEvent

    public void subscribeToViewEvent(Class<? extends SystemEvent> systemEvent,
                        SystemEventListener listener)

    Install the listener instance referenced by argument listener into the UIViewRoot as a listener for events of type systemEventClass.

    Note that installed listeners are not maintained as part of the UIViewRoot's state.

    Parameters:
    systemEvent - the Class of event for which listener must be fired.
    listener - the implementation of SystemEventListener whose SystemEventListener.processEvent(javax.faces.event.SystemEvent) method must be called when events of type systemEventClass are fired.
    Throws:
    NullPointerException - if systemEventClass or listener are null.
    Since:
    2.0

  • unsubscribeFromViewEvent

    public void unsubscribeFromViewEvent(Class<? extends SystemEvent> systemEvent,
                            SystemEventListener listener)

    Remove the listener instance referenced by argument listener from the UIViewRoot as a listener for events of type systemEventClass.

    Parameters:
    systemEvent - the Class of event for which listener must be fired.
    listener - the implementation of SystemEventListener whose SystemEventListener.processEvent(javax.faces.event.SystemEvent) method must be called when events of type systemEventClass are fired.
    Throws:
    NullPointerException - if systemEventClass or listener are null.
    Since:
    2.0

  • getViewListenersForEventClass

    public List<SystemEventListener> getViewListenersForEventClass(Class<? extends SystemEvent> systemEvent)

    Return the SystemEventListener instances registered on this UIComponent instance that are interested in events of type eventClass.

    Parameters:
    systemEvent - the Class of event for which the listeners must be returned.
    Throws:
    NullPointerException - if argument systemEvent is null.
    Since:
    2.0

  • restoreViewScopeState

    public void restoreViewScopeState(FacesContext context,
                         Object state)

    Restore ViewScope state. This is needed to allow the use of view scoped beans for EL-expressions in the template from which the component tree is built. For example: <ui:include src="#{viewScopedBean.includeFileName}"/>.

    Parameters:
    context - current FacesContext.
    state - the state object.

  • saveState

    public Object saveState(FacesContext context)
    Description copied from interface: StateHolder

    Gets the state of the instance as a Serializable Object.

    If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

    This method must not alter the state of the implementing object. In other words, after executing this code:

     Object state = component.saveState(facesContext);

    component should be the same as before executing it.

    The return from this method must be Serializable

    Specified by:
    saveState in interface StateHolder
    Overrides:
    saveState in class UIComponentBase

  • restoreState

    public void restoreState(FacesContext context,
                Object state)
    Description copied from interface: StateHolder

    Perform any processing required to restore the state from the entries in the state Object.

    If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

    If the state argument is null, take no action and return.

    Specified by:
    restoreState in interface StateHolder
    Overrides:
    restoreState in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UniqueIdVendor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface UniqueIdVendor

  • All Known Implementing Classes:
    HtmlDataTable, HtmlForm, UIData, UIForm, UINamingContainer, UIViewRoot

    public interface UniqueIdVendor

    UniqueIdVendor is an interface implemented by UIComponents that also implement NamingContainer so that they can provide unique ids based on their own clientId. This will reduce the amount of id generation variance between different renderings of the same view and is helpful for improved state saving.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String createUniqueId(FacesContext context, String seed)
      Generate an identifier for a component.

    • Method Detail

      • createUniqueId

        String createUniqueId(FacesContext context,
                    String seed)

        Generate an identifier for a component. The identifier will be prefixed with UNIQUE_ID_PREFIX, and will be unique within this component-container. Optionally, a unique seed value can be supplied by component creators which should be included in the generated unique id.

        Parameters:
        context - FacesContext
        seed - an optional seed value - e.g. based on the position of the component in the VDL-template
        Returns:
        a unique-id in this component-container
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UpdateModelException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Class UpdateModelException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.component.UpdateModelException
  • All Implemented Interfaces:
    Serializable

    public class UpdateModelException
extends FacesException

    This exception indicates a failure to update the model and is created to wrap any exception that occurs during UIInput.updateModel(javax.faces.context.FacesContext). The exception is then passed to ExceptionHandler.processEvent(javax.faces.event.SystemEvent), where the ExceptionHandler has an opportunity to handle it.

    Since:
    2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      UpdateModelException(FacesMessage facesMessage, Throwable cause)

      Store the argument facesMessage so it may be returned from getFacesMessage() and pass the argument cause to the super constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      FacesMessage getFacesMessage()

      Return the FacesMessage passed to the constructor.

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UpdateModelException

        public UpdateModelException(FacesMessage facesMessage,
                    Throwable cause)

        Store the argument facesMessage so it may be returned from getFacesMessage() and pass the argument cause to the super constructor.

        Parameters:
        facesMessage - the message for the exception
        cause - the cause of this exception
        Since:
        2.0

    • Method Detail

      • getFacesMessage

        public FacesMessage getFacesMessage()

        Return the FacesMessage passed to the constructor.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.component (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.component

  • Packages that use javax.faces.component
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.
    javax.faces.component.visit

    APIs for traversing a user interface component view.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.render
    Classes and interfaces defining the rendering model.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
  • Classes in javax.faces.component used by javax.faces.application
    Class and Description
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
    UIViewRoot
    UIViewRoot is the UIComponent that represents the root of the UIComponent tree.
  • Classes in javax.faces.component used by javax.faces.component
    Class and Description
    ActionSource
    ActionSource is an interface that may be implemented by any concrete UIComponent that wishes to be a source of ActionEvents, including the ability to invoke application actions via the default ActionListener mechanism.
    ActionSource2
    ActionSource2 extends ActionSource and provides a JavaBeans property analogous to the "action" property on ActionSource.
    ContextCallback
    A simple callback interace that enables taking action on a specific UIComponent (either facet or child) in the view while preserving any contextual state for that component instance in the view.
    EditableValueHolder
    EditableValueHolder is an extension of ValueHolder that describes additional features supported by editable components, including ValueChangeEvents and Validators.
    NamingContainer
    NamingContainer is an interface that must be implemented by any UIComponent that wants to be a naming container.
    PartialStateHolder

    Components that want to leverage the partial state saving feature must implement this interface instead of implementing StateHolder, from which this interface inherits.
    StateHelper

    Define a Map-like contract that makes it easier for components to implement PartialStateHolder.
    StateHolder
    This interface is implemented by classes that need to save their state between requests.
    TransientStateHelper

    Define a Map-like contract that makes it easier for components to implement TransientStateHolder.
    TransientStateHolder

    This interface is implemented by classes that need to save state that is expected to be available only within the scope of the current request.
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
    UIComponentBase
    UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
    UIInput
    UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
    UIOutput
    UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
    UIViewParameter

    UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
    UniqueIdVendor

    UniqueIdVendor is an interface implemented by UIComponents that also implement NamingContainer so that they can provide unique ids based on their own clientId.
    ValueHolder
    ValueHolder is an interface that may be implemented by any concrete UIComponent that wishes to support a local value, as well as access data in the model tier via a value expression, and support conversion between String and the model tier data's native data type.
  • Classes in javax.faces.component used by javax.faces.component.behavior
    Class and Description
    PartialStateHolder

    Components that want to leverage the partial state saving feature must implement this interface instead of implementing StateHolder, from which this interface inherits.
    StateHolder
    This interface is implemented by classes that need to save their state between requests.
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
  • Classes in javax.faces.component used by javax.faces.component.html
    Class and Description
    ActionSource
    ActionSource is an interface that may be implemented by any concrete UIComponent that wishes to be a source of ActionEvents, including the ability to invoke application actions via the default ActionListener mechanism.
    ActionSource2
    ActionSource2 extends ActionSource and provides a JavaBeans property analogous to the "action" property on ActionSource.
    EditableValueHolder
    EditableValueHolder is an extension of ValueHolder that describes additional features supported by editable components, including ValueChangeEvents and Validators.
    NamingContainer
    NamingContainer is an interface that must be implemented by any UIComponent that wants to be a naming container.
    PartialStateHolder

    Components that want to leverage the partial state saving feature must implement this interface instead of implementing StateHolder, from which this interface inherits.
    StateHolder
    This interface is implemented by classes that need to save their state between requests.
    TransientStateHolder

    This interface is implemented by classes that need to save state that is expected to be available only within the scope of the current request.
    UIColumn
    UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
    UICommand
    UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
    UIComponentBase
    UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
    UIData
    UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
    UIForm
    UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
    UIGraphic
    UIGraphic is a UIComponent that displays a graphical image to the user.
    UIInput
    UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
    UIMessage
    This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.
    UIMessages
    The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
    UIOutcomeTarget

    This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
    UIOutput
    UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
    UIPanel
    UIPanel is a UIComponent that manages the layout of its child components.
    UISelectBoolean
    UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
    UISelectMany
    UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
    UISelectOne
    UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
    UniqueIdVendor

    UniqueIdVendor is an interface implemented by UIComponents that also implement NamingContainer so that they can provide unique ids based on their own clientId.
    ValueHolder
    ValueHolder is an interface that may be implemented by any concrete UIComponent that wishes to support a local value, as well as access data in the model tier via a value expression, and support conversion between String and the model tier data's native data type.
  • Classes in javax.faces.component used by javax.faces.component.visit
    Class and Description
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
  • Classes in javax.faces.component used by javax.faces.context
    Class and Description
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
    UIViewRoot
    UIViewRoot is the UIComponent that represents the root of the UIComponent tree.
  • Classes in javax.faces.component used by javax.faces.convert
    Class and Description
    PartialStateHolder

    Components that want to leverage the partial state saving feature must implement this interface instead of implementing StateHolder, from which this interface inherits.
    StateHolder
    This interface is implemented by classes that need to save their state between requests.
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
  • Classes in javax.faces.component used by javax.faces.event
    Class and Description
    StateHolder
    This interface is implemented by classes that need to save their state between requests.
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
    UIViewRoot
    UIViewRoot is the UIComponent that represents the root of the UIComponent tree.
  • Classes in javax.faces.component used by javax.faces.render
    Class and Description
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
  • Classes in javax.faces.component used by javax.faces.validator
    Class and Description
    PartialStateHolder

    Components that want to leverage the partial state saving feature must implement this interface instead of implementing StateHolder, from which this interface inherits.
    StateHolder
    This interface is implemented by classes that need to save their state between requests.
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
  • Classes in javax.faces.component used by javax.faces.view
    Class and Description
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
    UIViewAction

    UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.
    UIViewParameter

    UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
    UIViewRoot
    UIViewRoot is the UIComponent that represents the root of the UIComponent tree.
  • Classes in javax.faces.component used by javax.faces.view.facelets
    Class and Description
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
  • Classes in javax.faces.component used by javax.faces.webapp
    Class and Description
    UIComponent
    UIComponent is the base class for all user interface components in JavaServer Faces.
    UIOutput
    UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValueHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component

Interface ValueHolder

  • All Known Subinterfaces:
    EditableValueHolder
    All Known Implementing Classes:
    HtmlBody, HtmlDoctype, HtmlHead, HtmlInputFile, HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlOutcomeTargetButton, HtmlOutcomeTargetLink, HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, UIInput, UIOutcomeTarget, UIOutput, UISelectBoolean, UISelectMany, UISelectOne, UIViewParameter

    public interface ValueHolder

    ValueHolder is an interface that may be implemented by any concrete UIComponent that wishes to support a local value, as well as access data in the model tier via a value expression, and support conversion between String and the model tier data's native data type.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Converter getConverter()
      Return the Converter (if any) that is registered for this UIComponent.
      Object getLocalValue()
      Return the local value of this UIComponent (if any), without evaluating any associated ValueExpression.
      Object getValue()
      Gets the value of this UIComponent.
      void setConverter(Converter converter)
      Set the Converter (if any) that is registered for this UIComponent.
      void setValue(Object value)
      Set the value of this UIComponent (if any).

    • Method Detail

      • getLocalValue

        Object getLocalValue()

        Return the local value of this UIComponent (if any), without evaluating any associated ValueExpression.

      • getValue

        Object getValue()

        Gets the value of this UIComponent. If validation failed, as indicated by FacesContext.isValidationFailed() returning true, always return the local value. Otherwise, first, consult the local value property of this component. If non-null return it. If null, see if we have a ValueExpression for the value property. If so, return the result of evaluating the property, otherwise return null. Note that because the specification for UIComponent.setValueBinding(java.lang.String, javax.faces.el.ValueBinding) requires a call through to UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression), legacy tags will continue to work.

      • setValue

        void setValue(Object value)

        Set the value of this UIComponent (if any).

        Parameters:
        value - The new local value

      • getConverter

        Converter getConverter()

        Return the Converter (if any) that is registered for this UIComponent.

      • setConverter

        void setConverter(Converter converter)

        Set the Converter (if any) that is registered for this UIComponent.

        Parameters:
        converter - New Converter (or null)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AjaxBehavior (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.behavior

Class AjaxBehavior

  • java.lang.Object
    • javax.faces.component.behavior.BehaviorBase
      • javax.faces.component.behavior.ClientBehaviorBase
        • javax.faces.component.behavior.AjaxBehavior
  • All Implemented Interfaces:
    Behavior, ClientBehavior, PartialStateHolder, StateHolder

    public class AjaxBehavior
extends ClientBehaviorBase

    An instance of this class is added as a ClientBehavior to a component using the ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior) contract that components implement. The presence of this ClientBehavior will cause the rendering of JavaScript that produces an Ajax request using the specification public JavaScript API when the component is rendered.

    If the component is an instance of EditableValueHolder, Where at all possible, the component must have the UI register the ajax event when the initial value is changed, not when focus is lost on the component.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String BEHAVIOR_ID

      The standard id for this behavior.

    • Constructor Summary

      Constructors
      Constructor and Description
      AjaxBehavior()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addAjaxBehaviorListener(AjaxBehaviorListener listener)

      Add the specified AjaxBehaviorListener to the set of listeners registered to receive event notifications from this AjaxBehavior.
      String getDelay()

      Returns the delay value, or null if no value was set.
      Collection<String> getExecute()

      Return a non-empty Collection<String> of component identifiers that will be used to identify components that should be processed during the execute phase of the request processing lifecycle.
      Set<ClientBehaviorHint> getHints()

      This method returns an unmodifiable Set containing the ClientBehaviorHint SUBMITTING.
      String getOnerror()

      Return the String of JavaScript function name that will be used to identify the client callback function that should be run in the event of an error.
      String getOnevent()

      Return the String of JavaScript function name that will be used to identify the client callback function that should be run on the occurance of a client-side event.
      Collection<String> getRender()

      Return a non-empty Collection<String> of component identifiers that will be used to identify components that should be processed during the render phase of the request processing lifecycle.
      String getRendererType()

      Returns the renderer type of the ClientBehaviorRenderer to use for the behavior.
      ValueExpression getValueExpression(String name)

      Returns the ValueExpression used to calculate the value for the specified property name, if any.
      boolean isDisabled()

      Return the disabled status of this behavior.
      boolean isImmediate()

      Return the immediate status of this behavior.
      boolean isImmediateSet()

      Tests whether the immediate attribute is specified.
      boolean isResetValues()

      Return the resetValues status of this behavior.
      boolean isResetValuesSet()

      Tests whether the resetValues attribute is specified.
      void removeAjaxBehaviorListener(AjaxBehaviorListener listener)

      Remove the specified AjaxBehaviorListener from the set of listeners registered to receive event notifications from this AjaxBehavior.
      void restoreState(FacesContext context, Object state)

      Implementation of StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object).
      Object saveState(FacesContext context)

      Implementation of StateHolder.saveState(javax.faces.context.FacesContext).
      void setDelay(String delay)

      If less than delay milliseconds elapses between calls to request() only the most recent one is sent and all other requests are discarded.
      void setDisabled(boolean disabled)

      Sets the disabled status of this behavior.
      void setExecute(Collection<String> execute)

      Sets the component identifiers that will be used to identify components that should be processed during the execute phase of the request processing lifecycle.
      void setImmediate(boolean immediate)

      Sets the immediate status of this behavior.
      void setOnerror(String onerror)

      Sets the JavaScript function name that will be used to identify the client callback function that should be run in the event of an error.
      void setOnevent(String onevent)

      Sets the JavaScript function name that will be used to identify the client callback function that should be run in response to event activity.
      void setRender(Collection<String> render)

      Sets the component identifiers that will be used to identify components that should be processed during the render phase of the request processing lifecycle.
      void setResetValues(boolean resetValues)

      Set the resetValues status of this behavior.
      void setValueExpression(String name, ValueExpression binding)

      Sets the ValueExpression used to calculate the value for the specified property name.

      • Methods inherited from class javax.faces.component.behavior.ClientBehaviorBase

        decode, getRenderer, getScript

      • Methods inherited from class javax.faces.component.behavior.BehaviorBase

        addBehaviorListener, broadcast, clearInitialState, initialStateMarked, isTransient, markInitialState, removeBehaviorListener, setTransient

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.Behavior

        broadcast

    • Field Detail

      • BEHAVIOR_ID

        public static final String BEHAVIOR_ID

        The standard id for this behavior.

        See Also:
        Constant Field Values

    • Constructor Detail

      • AjaxBehavior

        public AjaxBehavior()

    • Method Detail

      • getRendererType

        public String getRendererType()
        Description copied from class: ClientBehaviorBase

        Returns the renderer type of the ClientBehaviorRenderer to use for the behavior. The default implementation returns null. Subclasses should either override this method to return a string that identifies the type of ClientBehaviorRenderer to use, or should override ClientBehaviorBase.getScript(javax.faces.component.behavior.ClientBehaviorContext) and perform script rendering locally in the ClientBehavior implementation.

        Overrides:
        getRendererType in class ClientBehaviorBase
        Returns:
        the default renderer type, which is null.

      • getHints

        public Set<ClientBehaviorHint> getHints()

        This method returns an unmodifiable Set containing the ClientBehaviorHint SUBMITTING.

        Specified by:
        getHints in interface ClientBehavior
        Overrides:
        getHints in class ClientBehaviorBase
        Returns:
        unmodifiable set containing the hint ClientBehaviorHint SUBMITTING.
        Since:
        2.0

      • getOnerror

        public String getOnerror()

        Return the String of JavaScript function name that will be used to identify the client callback function that should be run in the event of an error.

        Since:
        2.0

      • setOnerror

        public void setOnerror(String onerror)

        Sets the JavaScript function name that will be used to identify the client callback function that should be run in the event of an error.

        Parameters:
        onerror - the error handling function name
        Since:
        2.0

      • getOnevent

        public String getOnevent()

        Return the String of JavaScript function name that will be used to identify the client callback function that should be run on the occurance of a client-side event.

        Since:
        2.0

      • setOnevent

        public void setOnevent(String onevent)

        Sets the JavaScript function name that will be used to identify the client callback function that should be run in response to event activity.

        Parameters:
        onevent - the event handling function name
        Since:
        2.0

      • getExecute

        public Collection<String> getExecute()

        Return a non-empty Collection<String> of component identifiers that will be used to identify components that should be processed during the execute phase of the request processing lifecycle.

        Note that the returned collection may be unmodifiable. Modifications should be performed by calling setExecute(java.util.Collection<java.lang.String>).

        Since:
        2.0

      • setExecute

        public void setExecute(Collection<String> execute)

        Sets the component identifiers that will be used to identify components that should be processed during the execute phase of the request processing lifecycle.

        Parameters:
        execute - the ids of components to execute
        Since:
        2.0

      • getDelay

        public String getDelay()

        Returns the delay value, or null if no value was set.

        Since:
        2.2

      • setDelay

        public void setDelay(String delay)

        If less than delay milliseconds elapses between calls to request() only the most recent one is sent and all other requests are discarded. The default value of this option is 300. If the value of delay is the literal string 'none' without the quotes, no delay is used.

        Parameters:
        delay - the ajax delay value
        Since:
        2.2

      • getRender

        public Collection<String> getRender()

        Return a non-empty Collection<String> of component identifiers that will be used to identify components that should be processed during the render phase of the request processing lifecycle.

        Note that the returned collection may be unmodifiable. Modifications should be performed by calling setRender(java.util.Collection<java.lang.String>).

        Since:
        2.0

      • setRender

        public void setRender(Collection<String> render)

        Sets the component identifiers that will be used to identify components that should be processed during the render phase of the request processing lifecycle.

        Parameters:
        render - the ids of components to render
        Since:
        2.0

      • isResetValues

        public boolean isResetValues()

        Return the resetValues status of this behavior.

        Since:
        2.2

      • setResetValues

        public void setResetValues(boolean resetValues)

        Set the resetValues status of this behavior.

        Since:
        2.2

      • isDisabled

        public boolean isDisabled()

        Return the disabled status of this behavior.

        Since:
        2.0

      • setDisabled

        public void setDisabled(boolean disabled)

        Sets the disabled status of this behavior.

        Since:
        2.0

      • isImmediate

        public boolean isImmediate()

        Return the immediate status of this behavior.

        Since:
        2.0

      • setImmediate

        public void setImmediate(boolean immediate)

        Sets the immediate status of this behavior.

        Since:
        2.0

      • isImmediateSet

        public boolean isImmediateSet()

        Tests whether the immediate attribute is specified. Returns true if the immediate attribute is specified, either as a locally set property or as a value expression. This information allows an associated client behavior renderer to fall back on the parent component's immediate status when immediate is not explicitly specified on the AjaxBehavior.

        Since:
        2.0

      • isResetValuesSet

        public boolean isResetValuesSet()

        Tests whether the resetValues attribute is specified. Returns true if the resetValues attribute is specified, either as a locally set property or as a value expression.

        Since:
        2.2

      • getValueExpression

        public ValueExpression getValueExpression(String name)

        Returns the ValueExpression used to calculate the value for the specified property name, if any.

        Parameters:
        name - Name of the property for which to retrieve a ValueExpression
        Throws:
        NullPointerException - if name is null

      • setValueExpression

        public void setValueExpression(String name,
                      ValueExpression binding)

        Sets the ValueExpression used to calculate the value for the specified property name.

        Parameters:
        name - Name of the property for which to set a ValueExpression
        binding - The ValueExpression to set, or null to remove any currently set ValueExpression
        Throws:
        NullPointerException - if name is null

      • addAjaxBehaviorListener

        public void addAjaxBehaviorListener(AjaxBehaviorListener listener)

        Add the specified AjaxBehaviorListener to the set of listeners registered to receive event notifications from this AjaxBehavior.

        Parameters:
        listener - The AjaxBehaviorListener to be registered
        Throws:
        NullPointerException - if listener is null
        Since:
        2.0

      • removeAjaxBehaviorListener

        public void removeAjaxBehaviorListener(AjaxBehaviorListener listener)

        Remove the specified AjaxBehaviorListener from the set of listeners registered to receive event notifications from this AjaxBehavior.

        Parameters:
        listener - The AjaxBehaviorListener to be removed
        Throws:
        NullPointerException - if listener is null
        Since:
        2.0

      • saveState

        public Object saveState(FacesContext context)
        Description copied from class: BehaviorBase

        Implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Specified by:
        saveState in interface StateHolder
        Overrides:
        saveState in class BehaviorBase

      • restoreState

        public void restoreState(FacesContext context,
                Object state)
        Description copied from class: BehaviorBase

        Implementation of StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object).

        Specified by:
        restoreState in interface StateHolder
        Overrides:
        restoreState in class BehaviorBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Behavior (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.behavior

Interface Behavior

  • All Known Subinterfaces:
    ClientBehavior
    All Known Implementing Classes:
    AjaxBehavior, BehaviorBase, ClientBehaviorBase

    public interface Behavior

    The Behavior interface is the root API of the component behavior model. Behaviors are objects that are attached to UIComponents in order to enhance components with functionality not explicitly defined by the component implementation itself. The component behavior API is intended to support different types of behavior contracts, and possibly different types of interactions between behaviors and components. The first such contract is the ClientBehavior, which defines a mechanism by which script-producing behaviors attach scripts to components for execution on the client. In the future other types of behavior contracts may be added.

    Like other attached objects (converters, validators) Behavior instances are created via the Application object. See Application.createBehavior(java.lang.String) for more details.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void broadcast(BehaviorEvent event)

      Broadcast the specified BehaviorEvent to all registered event listeners who have expressed an interest in events of this type.

    • Method Detail

      • broadcast

        void broadcast(BehaviorEvent event)

        Broadcast the specified BehaviorEvent to all registered event listeners who have expressed an interest in events of this type. Listeners are called in the order in which they were added.

        Parameters:
        event - The BehaviorEvent to be broadcast
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
        IllegalArgumentException - if the implementation class of this BehaviorEvent is not supported by this component
        NullPointerException - if event is null
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BehaviorBase (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.behavior

Class BehaviorBase

  • java.lang.Object
    • javax.faces.component.behavior.BehaviorBase
  • All Implemented Interfaces:
    Behavior, PartialStateHolder, StateHolder
    Direct Known Subclasses:
    ClientBehaviorBase

    public class BehaviorBase
extends Object
implements Behavior, PartialStateHolder

    BehaviorBase is a convenience base class that provides a default implementation of the Behavior contract. It also provides behavior listener registration and state saving support.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      BehaviorBase()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected void addBehaviorListener(BehaviorListener listener)

      Add the specified BehaviorListener to the set of listeners registered to receive event notifications from this Behavior.
      void broadcast(BehaviorEvent event)

      Default implementation of Behavior.broadcast(javax.faces.event.BehaviorEvent).
      void clearInitialState()

      Clears the initial state flag, causing the behavior to revert from partial to full state saving.
      boolean initialStateMarked()

      Implementation of PartialStateHolder.initialStateMarked().
      boolean isTransient()

      Implementation of StateHolder.isTransient().
      void markInitialState()

      Implementation of PartialStateHolder.markInitialState().
      protected void removeBehaviorListener(BehaviorListener listener)

      Remove the specified BehaviorListener from the set of listeners registered to receive event notifications from this Behavior.
      void restoreState(FacesContext context, Object state)

      Implementation of StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object).
      Object saveState(FacesContext context)

      Implementation of StateHolder.saveState(javax.faces.context.FacesContext).
      void setTransient(boolean transientFlag)

      Implementation of StateHolder.setTransient(boolean).

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BehaviorBase

        public BehaviorBase()

    • Method Detail

      • broadcast

        public void broadcast(BehaviorEvent event)
               throws AbortProcessingException

        Default implementation of Behavior.broadcast(javax.faces.event.BehaviorEvent). Delivers the specified BehaviorEvent to all registered BehaviorListener event listeners who have expressed an interest in events of this type. Listeners are called in the order in which they were registered (added).

        Specified by:
        broadcast in interface Behavior
        Parameters:
        event - The BehaviorEvent to be broadcast
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
        IllegalArgumentException - if the implementation class of this BehaviorEvent is not supported by this component
        NullPointerException - if event is null
        Since:
        2.0

      • isTransient

        public boolean isTransient()

        Implementation of StateHolder.isTransient().

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean transientFlag)

        Implementation of StateHolder.setTransient(boolean).

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        transientFlag - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.

      • saveState

        public Object saveState(FacesContext context)

        Implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)

        Implementation of StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object).

        Specified by:
        restoreState in interface StateHolder

      • markInitialState

        public void markInitialState()

        Implementation of PartialStateHolder.markInitialState().

        Specified by:
        markInitialState in interface PartialStateHolder

      • initialStateMarked

        public boolean initialStateMarked()

        Implementation of PartialStateHolder.initialStateMarked().

        Specified by:
        initialStateMarked in interface PartialStateHolder

      • clearInitialState

        public void clearInitialState()

        Clears the initial state flag, causing the behavior to revert from partial to full state saving.

        Specified by:
        clearInitialState in interface PartialStateHolder

      • addBehaviorListener

        protected void addBehaviorListener(BehaviorListener listener)

        Add the specified BehaviorListener to the set of listeners registered to receive event notifications from this Behavior. It is expected that Behavior classes acting as event sources will have corresponding typesafe APIs for registering listeners of the required type, and the implementation of those registration methods will delegate to this method. For example:

         public class AjaxBehaviorEvent extends BehaviorEvent { ... }

 public interface AjaxBehaviorListener extends BehaviorListener {
   public void processAjaxBehavior(FooEvent event);
 }

 public class AjaxBehavior extends ClientBehaviorBase {
   ...
   public void addAjaxBehaviorListener(AjaxBehaviorListener listener) {
     addBehaviorListener(listener);
   }
   public void removeAjaxBehaviorListener(AjaxBehaviorListener listener) {
     removeBehaviorListener(listener);
   }
   ...
 }
        Parameters:
        listener - The BehaviorListener to be registered
        Throws:
        NullPointerException - if listener is null
        Since:
        2.0

      • removeBehaviorListener

        protected void removeBehaviorListener(BehaviorListener listener)

        Remove the specified BehaviorListener from the set of listeners registered to receive event notifications from this Behavior.

        Parameters:
        listener - The BehaviorListener to be deregistered
        Throws:
        NullPointerException - if listener is null
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientBehavior (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.behavior

Interface ClientBehavior

  • All Superinterfaces:
    Behavior
    All Known Implementing Classes:
    AjaxBehavior, ClientBehaviorBase

    public interface ClientBehavior
extends Behavior

    ClientBehavior is the base contract for Behaviors that attach script content to client-side events exposed by ClientBehaviorHolder components. Instances of ClientBehavior may be attached to components that implement the ClientBehaviorHolder contract by calling ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior). Once a ClientBehavior has been attached to a ClientBehaviorHolder component, the component calls getScript(javax.faces.component.behavior.ClientBehaviorContext) to obtain the behavior's script and the component wires this up to the appropriate client-side event handler. Note that the script content returned by this method is always in-line script content. If the implementing class wants to invoke functions defined in other script resources, the implementing class must use the ResourceDependency or ResourceDependencies annotation.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void decode(FacesContext context, UIComponent component)

      Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.
      Set<ClientBehaviorHint> getHints()

      Returns hints that describe the behavior of the ClientBehavior implementation.
      String getScript(ClientBehaviorContext behaviorContext)

      Return the script that implements this ClientBehavior's client-side logic.

      • Methods inherited from interface javax.faces.component.behavior.Behavior

        broadcast

    • Method Detail

      • getScript

        String getScript(ClientBehaviorContext behaviorContext)

        Return the script that implements this ClientBehavior's client-side logic.

        ClientBehavior.getScript() implementations are allowed to return null to indicate that no script is required for this particular getScript() call. For example, a ClientBehavior implementation may return null if the Behavior is disabled.

        Parameters:
        behaviorContext - the ClientBehaviorContext that provides properties that might influence this getScript() call. Note that ClientBehaviorContext instances are short-lived objects that are only valid for the duration of the call to getScript(). ClientBehavior implementations must not hold onto references to ClientBehaviorContexts.
        Returns:
        script that provides the client-side behavior, or null if no script is required.
        Throws:
        NullPointerException - if behaviorContext is null
        Since:
        2.0

      • decode

        void decode(FacesContext context,
          UIComponent component)

        Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.

        During decoding, events may be enqueued for later processing (by event listeners who have registered an interest), by calling queueEvent(). Default implementation delegates decoding to ClientBehaviorRenderer.decode(FacesContext, UIComponent, ClientBehavior)

        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent the component associated with this Behavior
        Throws:
        NullPointerException - if context or component is null.
        Since:
        2.0

      • getHints

        Set<ClientBehaviorHint> getHints()

        Returns hints that describe the behavior of the ClientBehavior implementation. The hints may impact how Renderers behave in the presence of Behaviors. For example, when a Behavior that specifies ClientBehaviorHint.SUBMITTING is present, the Renderer may choose to alternate the scripts that it generates itself.

        Returns:
        a non-null, unmodifiable collection of ClientBehaviorHints.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientBehaviorBase (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.behavior

Class ClientBehaviorBase

  • java.lang.Object
    • javax.faces.component.behavior.BehaviorBase
      • javax.faces.component.behavior.ClientBehaviorBase
  • All Implemented Interfaces:
    Behavior, ClientBehavior, PartialStateHolder, StateHolder
    Direct Known Subclasses:
    AjaxBehavior

    public class ClientBehaviorBase
extends BehaviorBase
implements ClientBehavior

    ClientBehaviorBase is a convenience base class that implements the default concrete behavior of all methods defined by ClientBehavior.

    Subclasses should either override getRendererType() to identify the ClientBehaviorRenderer to delegate to, or they should override getScript() to locally generate the desired Behavior script, and decode().

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ClientBehaviorBase()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void decode(FacesContext context, UIComponent component)

      Default implementation of of ClientBehavior.decode(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
      Set<ClientBehaviorHint> getHints()

      Default implementation of ClientBehavior.getHints().
      protected ClientBehaviorRenderer getRenderer(FacesContext context)

      Convenience method to return the ClientBehaviorRenderer instance associated with this ClientBehavior, if any; otherwise, return null.
      String getRendererType()

      Returns the renderer type of the ClientBehaviorRenderer to use for the behavior.
      String getScript(ClientBehaviorContext behaviorContext)

      Default implementation of of ClientBehavior.getScript(javax.faces.component.behavior.ClientBehaviorContext).

      • Methods inherited from class javax.faces.component.behavior.BehaviorBase

        addBehaviorListener, broadcast, clearInitialState, initialStateMarked, isTransient, markInitialState, removeBehaviorListener, restoreState, saveState, setTransient

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.Behavior

        broadcast

    • Constructor Detail

      • ClientBehaviorBase

        public ClientBehaviorBase()

    • Method Detail

      • getScript

        public String getScript(ClientBehaviorContext behaviorContext)

        Default implementation of of ClientBehavior.getScript(javax.faces.component.behavior.ClientBehaviorContext). If a ClientBehaviorRenderer is available for the specified behavior renderer type, this method delegates to the ClientBehaviorRenderer.getScript(javax.faces.component.behavior.ClientBehaviorContext, javax.faces.component.behavior.ClientBehavior) method. Otherwise, this method returns null.

        Specified by:
        getScript in interface ClientBehavior
        Parameters:
        behaviorContext - the ClientBehaviorContext
        Returns:
        the script provided by the associated ClientBehaviorRenderer, or null if no ClientBehaviorRenderer is available.
        Throws:
        NullPointerException - if behaviorContext is null
        Since:
        2.0

      • decode

        public void decode(FacesContext context,
          UIComponent component)

        Default implementation of of ClientBehavior.decode(javax.faces.context.FacesContext, javax.faces.component.UIComponent). If a ClientBehaviorRenderer is available for the specified behavior renderer type, this method delegates to the ClientBehaviorRenderer's decode() method. Otherwise, no decoding is performed.

        Specified by:
        decode in interface ClientBehavior
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent the component associated with this ClientBehavior
        Throws:
        NullPointerException - if context or component is null.
        Since:
        2.0

      • getRendererType

        public String getRendererType()

        Returns the renderer type of the ClientBehaviorRenderer to use for the behavior. The default implementation returns null. Subclasses should either override this method to return a string that identifies the type of ClientBehaviorRenderer to use, or should override getScript(javax.faces.component.behavior.ClientBehaviorContext) and perform script rendering locally in the ClientBehavior implementation.

        Returns:
        the default renderer type, which is null.
        Since:
        2.0

      • getHints

        public Set<ClientBehaviorHint> getHints()

        Default implementation of ClientBehavior.getHints(). By default, no hints are specified, and this method returns an empty, umodifiable set.

        Specified by:
        getHints in interface ClientBehavior
        Returns:
        an empty, unmodifiable set of ClientBehaviorHints.
        Since:
        2.0

      • getRenderer

        protected ClientBehaviorRenderer getRenderer(FacesContext context)

        Convenience method to return the ClientBehaviorRenderer instance associated with this ClientBehavior, if any; otherwise, return null.

        Parameters:
        context - FacesContext for the request we are processing
        Returns:
        ClientBehaviorRenderer instance from the current RenderKit or null.
        Throws:
        NullPointerException - if context is null.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientBehaviorContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.behavior

Class ClientBehaviorContext

  • java.lang.Object
    • javax.faces.component.behavior.ClientBehaviorContext

  • public abstract class ClientBehaviorContext
extends Object

    ClientBehaviorContext provides context information that may be useful to ClientBehavior.getScript(javax.faces.component.behavior.ClientBehaviorContext) implementations.

    Since:
    2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  ClientBehaviorContext.Parameter

      Parameter instances represent name/value pairs that "submitting" ClientBehavior implementations should include when posting back into the Faces lifecycle.

    • Constructor Summary

      Constructors
      Constructor and Description
      ClientBehaviorContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ClientBehaviorContext createClientBehaviorContext(FacesContext context, UIComponent component, String eventName, String sourceId, Collection<ClientBehaviorContext.Parameter> parameters)

      Creates a ClientBehaviorContext instance.
      abstract UIComponent getComponent()

      Returns the UIComponent that is requesting the ClientBehavior script.
      abstract String getEventName()

      Returns the name of the behavior event for which the ClientBehavior script is being requested.
      abstract FacesContext getFacesContext()

      Returns the FacesContext for the current request.
      abstract Collection<ClientBehaviorContext.Parameter> getParameters()

      Returns parameters that "submitting" ClientBehavior implementations should include when posting back data into the Faces lifecycle.
      abstract String getSourceId()

      Returns an id for use as the ClientBehavior source.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ClientBehaviorContext

        public ClientBehaviorContext()

    • Method Detail

      • createClientBehaviorContext

        public static ClientBehaviorContext createClientBehaviorContext(FacesContext context,
                                                UIComponent component,
                                                String eventName,
                                                String sourceId,
                                                Collection<ClientBehaviorContext.Parameter> parameters)

        Creates a ClientBehaviorContext instance.

        Parameters:
        context - the FacesContext for the current request.
        component - the component instance to which the ClientBehavior is attached.
        eventName - the name of the behavior event to which the ClientBehavior is attached.
        sourceId - the id to use as the ClientBehavior's "source".
        parameters - the collection of parameters for submitting ClientBehaviors to include in the request.
        Returns:
        a ClientBehaviorContext instance configured with the provided values.
        Throws:
        NullPointerException - if context, component or eventName is null
        Since:
        2.0

      • getFacesContext

        public abstract FacesContext getFacesContext()

        Returns the FacesContext for the current request.

        Since:
        2.0

      • getComponent

        public abstract UIComponent getComponent()

        Returns the UIComponent that is requesting the ClientBehavior script.

        Since:
        2.0

      • getEventName

        public abstract String getEventName()

        Returns the name of the behavior event for which the ClientBehavior script is being requested.

        Since:
        2.0

      • getSourceId

        public abstract String getSourceId()

        Returns an id for use as the ClientBehavior source. ClientBehavior implementations that submit back to the Faces lifecycle are required to identify which component triggered the ClientBehavior-initiated request via the javax.faces.source request parameter. In most cases, th source id can be trivially derived from the element to which the behavior's client-side script is attached - ie. the source id is typically the id of this element. However, in components which produce more complex content, the behavior script may not be able to determine the correct id to use for the javax.faces.source value. The getSourceId() method allows the component to pass this information into the ClientBehavior.getScript(javax.faces.component.behavior.ClientBehaviorContext) implementation.

        Returns:
        the id for the behavior's script to use as the "source", or null if the Behavior's script can identify the source from the DOM.
        Since:
        2.0

      • getParameters

        public abstract Collection<ClientBehaviorContext.Parameter> getParameters()

        Returns parameters that "submitting" ClientBehavior implementations should include when posting back data into the Faces lifecycle. If no parameters are specified, this method returns an empty (non-null) collection.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientBehaviorContext.Parameter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.behavior

Class ClientBehaviorContext.Parameter

  • java.lang.Object
    • javax.faces.component.behavior.ClientBehaviorContext.Parameter
  • Enclosing class:
    ClientBehaviorContext

    public static class ClientBehaviorContext.Parameter
extends Object

    Parameter instances represent name/value pairs that "submitting" ClientBehavior implementations should include when posting back into the Faces lifecycle. ClientBehavior implementations can determine which Parameters to include by calling ClientBehaviorContext.getParameters().

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ClientBehaviorContext.Parameter(String name, Object value)

      Creates a Parameter instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()

      Returns the Parameter's name.
      Object getValue()

      Returns the Parameter's value.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ClientBehaviorContext.Parameter

        public ClientBehaviorContext.Parameter(String name,
                               Object value)

        Creates a Parameter instance.

        Parameters:
        name - the name of the parameter
        value - the value of the parameter
        Throws:
        NullPointerException - if name is null.
        Since:
        2.0

    • Method Detail

      • getName

        public String getName()

        Returns the Parameter's name.

        Since:
        2.0

      • getValue

        public Object getValue()

        Returns the Parameter's value.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientBehaviorHint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.behavior

Enum ClientBehaviorHint

  • java.lang.Object
    • java.lang.Enum<ClientBehaviorHint>
      • javax.faces.component.behavior.ClientBehaviorHint
  • All Implemented Interfaces:
    Serializable, Comparable<ClientBehaviorHint>

    public enum ClientBehaviorHint
extends Enum<ClientBehaviorHint>

    An enum that specifies hints that describes the behavior of ClientBehavior implementations.

    Since:
    2.0
    See Also:
    ClientBehavior.getHints()

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      SUBMITTING
      Hint that indicates that ClientBehavior implementation posts back to the server.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ClientBehaviorHint valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ClientBehaviorHint[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SUBMITTING

        public static final ClientBehaviorHint SUBMITTING
        Hint that indicates that ClientBehavior implementation posts back to the server. Renderers that normally attach postback-related scripts may choose to omit such scripts when a submitting ClientBehavior is present.

    • Method Detail

      • values

        public static ClientBehaviorHint[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ClientBehaviorHint c : ClientBehaviorHint.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ClientBehaviorHint valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ClientBehaviorHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.behavior

Interface ClientBehaviorHolder

  • All Known Implementing Classes:
    HtmlBody, HtmlCommandButton, HtmlCommandLink, HtmlDataTable, HtmlForm, HtmlGraphicImage, HtmlInputFile, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlOutcomeTargetButton, HtmlOutcomeTargetLink, HtmlOutputLabel, HtmlOutputLink, HtmlPanelGrid, HtmlPanelGroup, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio

    public interface ClientBehaviorHolder

    The ClientBehaviorHolder interface may be implemented by any concrete UIComponent that wishes to support client behaviors as defined by ClientBehavior.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addClientBehavior(String eventName, ClientBehavior behavior)

      Attaches a ClientBehavior to the component implementing this interface for the specified event.
      Map<String,List<ClientBehavior>> getClientBehaviors()

      Returns a non-null, unmodifiable Map that contains the the ClientBehaviors that have been attached to the component implementing this interface.
      String getDefaultEventName()

      Returns the default event name for this ClientBehaviorHolder implementation.
      Collection<String> getEventNames()

      Returns a non-null, unmodifiable Collection containing the names of the logical events supported by the component implementing this interface.

    • Method Detail

      • addClientBehavior

        void addClientBehavior(String eventName,
                     ClientBehavior behavior)

        Attaches a ClientBehavior to the component implementing this interface for the specified event. Valid event names for a UIComponent implementation are defined by ClientBehaviorHolder.getEventNames().

        Parameters:
        eventName - the logical name of the client-side event to attach the behavior to.
        behavior - the ClientBehavior instance to attach for the specified event name.
        Since:
        2.0

      • getEventNames

        Collection<String> getEventNames()

        Returns a non-null, unmodifiable Collection containing the names of the logical events supported by the component implementing this interface.

        Since:
        2.0

      • getClientBehaviors

        Map<String,List<ClientBehavior>> getClientBehaviors()

        Returns a non-null, unmodifiable Map that contains the the ClientBehaviors that have been attached to the component implementing this interface. The keys in this Map are event names defined by getEventNames().

        Since:
        2.0

      • getDefaultEventName

        String getDefaultEventName()

        Returns the default event name for this ClientBehaviorHolder implementation. This must be one of the event names returned by getEventNames() or null if the component does not have a default event.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesBehavior (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.component.behavior

Annotation Type FacesBehavior

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface FacesBehavior

    The presence of this annotation on a class automatically registers the class with the runtime as a Behavior. The value of this annotation attribute is taken to be the behavior-id with which instances of this class of behavior can be instantiated by calling Application.createBehavior(java.lang.String)

    Since:
    2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value

    • Element Detail

      • value

        public abstract String value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.faces.component.behavior (Java(TM) EE 7 Specification APIs)

javax.faces.component.behavior

Interfaces

  • Behavior
  • ClientBehavior
  • ClientBehaviorHolder

Classes

  • AjaxBehavior
  • BehaviorBase
  • ClientBehaviorBase
  • ClientBehaviorContext
  • ClientBehaviorContext.Parameter

Enums

  • ClientBehaviorHint

Annotation Types

  • FacesBehavior


javax.faces.component.behavior (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.component.behavior

APIs for attaching additional behavior to user interface components.

See: Description

  • Interface Summary
    Interface Description
    Behavior

    The Behavior interface is the root API of the component behavior model.
    ClientBehavior

    ClientBehavior is the base contract for Behaviors that attach script content to client-side events exposed by ClientBehaviorHolder components.
    ClientBehaviorHolder

    The ClientBehaviorHolder interface may be implemented by any concrete UIComponent that wishes to support client behaviors as defined by ClientBehavior.
  • Class Summary
    Class Description
    AjaxBehavior

    An instance of this class is added as a ClientBehavior to a component using the ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior) contract that components implement.
    BehaviorBase

    BehaviorBase is a convenience base class that provides a default implementation of the Behavior contract.
    ClientBehaviorBase

    ClientBehaviorBase is a convenience base class that implements the default concrete behavior of all methods defined by ClientBehavior.
    ClientBehaviorContext

    ClientBehaviorContext provides context information that may be useful to ClientBehavior.getScript(javax.faces.component.behavior.ClientBehaviorContext) implementations.
    ClientBehaviorContext.Parameter

    Parameter instances represent name/value pairs that "submitting" ClientBehavior implementations should include when posting back into the Faces lifecycle.
  • Enum Summary
    Enum Description
    ClientBehaviorHint

    An enum that specifies hints that describes the behavior of ClientBehavior implementations.
  • Annotation Types Summary
    Annotation Type Description
    FacesBehavior

    The presence of this annotation on a class automatically registers the class with the runtime as a Behavior.

Package javax.faces.component.behavior Description

APIs for attaching additional behavior to user interface components.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.component.behavior Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.component.behavior

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.component.behavior.BehaviorBase (implements javax.faces.component.behavior.Behavior, javax.faces.component.PartialStateHolder)
      • javax.faces.component.behavior.ClientBehaviorBase (implements javax.faces.component.behavior.ClientBehavior)
        • javax.faces.component.behavior.AjaxBehavior
    • javax.faces.component.behavior.ClientBehaviorContext
    • javax.faces.component.behavior.ClientBehaviorContext.Parameter

Interface Hierarchy

  • javax.faces.component.behavior.Behavior
    • javax.faces.component.behavior.ClientBehavior
  • javax.faces.component.behavior.ClientBehaviorHolder

Annotation Type Hierarchy

  • javax.faces.component.behavior.FacesBehavior (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.faces.component.behavior.ClientBehaviorHint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.faces.component.behavior (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.component.behavior

  • Packages that use javax.faces.component.behavior
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.render
    Classes and interfaces defining the rendering model.
  • Classes in javax.faces.component.behavior used by javax.faces.application
    Class and Description
    Behavior

    The Behavior interface is the root API of the component behavior model.
  • Classes in javax.faces.component.behavior used by javax.faces.component
    Class and Description
    ClientBehavior

    ClientBehavior is the base contract for Behaviors that attach script content to client-side events exposed by ClientBehaviorHolder components.
  • Classes in javax.faces.component.behavior used by javax.faces.component.behavior
    Class and Description
    Behavior

    The Behavior interface is the root API of the component behavior model.
    BehaviorBase

    BehaviorBase is a convenience base class that provides a default implementation of the Behavior contract.
    ClientBehavior

    ClientBehavior is the base contract for Behaviors that attach script content to client-side events exposed by ClientBehaviorHolder components.
    ClientBehaviorBase

    ClientBehaviorBase is a convenience base class that implements the default concrete behavior of all methods defined by ClientBehavior.
    ClientBehaviorContext

    ClientBehaviorContext provides context information that may be useful to ClientBehavior.getScript(javax.faces.component.behavior.ClientBehaviorContext) implementations.
    ClientBehaviorContext.Parameter

    Parameter instances represent name/value pairs that "submitting" ClientBehavior implementations should include when posting back into the Faces lifecycle.
    ClientBehaviorHint

    An enum that specifies hints that describes the behavior of ClientBehavior implementations.
  • Classes in javax.faces.component.behavior used by javax.faces.component.html
    Class and Description
    ClientBehaviorHolder

    The ClientBehaviorHolder interface may be implemented by any concrete UIComponent that wishes to support client behaviors as defined by ClientBehavior.
  • Classes in javax.faces.component.behavior used by javax.faces.event
    Class and Description
    Behavior

    The Behavior interface is the root API of the component behavior model.
  • Classes in javax.faces.component.behavior used by javax.faces.render
    Class and Description
    ClientBehavior

    ClientBehavior is the base contract for Behaviors that attach script content to client-side events exposed by ClientBehaviorHolder components.
    ClientBehaviorContext

    ClientBehaviorContext provides context information that may be useful to ClientBehavior.getScript(javax.faces.component.behavior.ClientBehaviorContext) implementations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.behavior.AjaxBehavior (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.behavior.AjaxBehavior

No usage of javax.faces.component.behavior.AjaxBehavior
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.behavior.BehaviorBase (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.behavior.BehaviorBase

  • Packages that use BehaviorBase
    Package Description
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.

    • Uses of BehaviorBase in javax.faces.component.behavior

      Subclasses of BehaviorBase in javax.faces.component.behavior
      Modifier and Type Class and Description
      class  AjaxBehavior

      An instance of this class is added as a ClientBehavior to a component using the ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior) contract that components implement.
      class  ClientBehaviorBase

      ClientBehaviorBase is a convenience base class that implements the default concrete behavior of all methods defined by ClientBehavior.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.behavior.ClientBehaviorBase (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.behavior.ClientBehaviorBase

  • Packages that use ClientBehaviorBase
    Package Description
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.

    • Uses of ClientBehaviorBase in javax.faces.component.behavior

      Subclasses of ClientBehaviorBase in javax.faces.component.behavior
      Modifier and Type Class and Description
      class  AjaxBehavior

      An instance of this class is added as a ClientBehavior to a component using the ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior) contract that components implement.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.behavior.ClientBehaviorContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.behavior.ClientBehaviorContext

  • Packages that use ClientBehaviorContext
    Package Description
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of ClientBehaviorContext in javax.faces.component.behavior

      Methods in javax.faces.component.behavior that return ClientBehaviorContext
      Modifier and Type Method and Description
      static ClientBehaviorContext ClientBehaviorContext.createClientBehaviorContext(FacesContext context, UIComponent component, String eventName, String sourceId, Collection<ClientBehaviorContext.Parameter> parameters)

      Creates a ClientBehaviorContext instance.
      Methods in javax.faces.component.behavior with parameters of type ClientBehaviorContext
      Modifier and Type Method and Description
      String ClientBehaviorBase.getScript(ClientBehaviorContext behaviorContext)

      Default implementation of of ClientBehavior.getScript(javax.faces.component.behavior.ClientBehaviorContext).
      String ClientBehavior.getScript(ClientBehaviorContext behaviorContext)

      Return the script that implements this ClientBehavior's client-side logic.

    • Uses of ClientBehaviorContext in javax.faces.render

      Methods in javax.faces.render with parameters of type ClientBehaviorContext
      Modifier and Type Method and Description
      String ClientBehaviorRenderer.getScript(ClientBehaviorContext behaviorContext, ClientBehavior behavior)

      Return the script that implements this ClientBehavior's client-side logic.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.behavior.ClientBehaviorContext.Parameter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.behavior.ClientBehaviorContext.Parameter

  • Packages that use ClientBehaviorContext.Parameter
    Package Description
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.

    • Uses of ClientBehaviorContext.Parameter in javax.faces.component.behavior

      Methods in javax.faces.component.behavior that return types with arguments of type ClientBehaviorContext.Parameter
      Modifier and Type Method and Description
      abstract Collection<ClientBehaviorContext.Parameter> ClientBehaviorContext.getParameters()

      Returns parameters that "submitting" ClientBehavior implementations should include when posting back data into the Faces lifecycle.
      Method parameters in javax.faces.component.behavior with type arguments of type ClientBehaviorContext.Parameter
      Modifier and Type Method and Description
      static ClientBehaviorContext ClientBehaviorContext.createClientBehaviorContext(FacesContext context, UIComponent component, String eventName, String sourceId, Collection<ClientBehaviorContext.Parameter> parameters)

      Creates a ClientBehaviorContext instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.behavior.ClientBehaviorHint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.behavior.ClientBehaviorHint

  • Packages that use ClientBehaviorHint
    Package Description
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.

    • Uses of ClientBehaviorHint in javax.faces.component.behavior

      Methods in javax.faces.component.behavior that return ClientBehaviorHint
      Modifier and Type Method and Description
      static ClientBehaviorHint ClientBehaviorHint.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ClientBehaviorHint[] ClientBehaviorHint.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.faces.component.behavior that return types with arguments of type ClientBehaviorHint
      Modifier and Type Method and Description
      Set<ClientBehaviorHint> ClientBehaviorBase.getHints()

      Default implementation of ClientBehavior.getHints().
      Set<ClientBehaviorHint> ClientBehavior.getHints()

      Returns hints that describe the behavior of the ClientBehavior implementation.
      Set<ClientBehaviorHint> AjaxBehavior.getHints()

      This method returns an unmodifiable Set containing the ClientBehaviorHint SUBMITTING.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.behavior.FacesBehavior (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.behavior.FacesBehavior

No usage of javax.faces.component.behavior.FacesBehavior
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.behavior.Behavior (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.behavior.Behavior

  • Packages that use Behavior
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of Behavior in javax.faces.application

      Methods in javax.faces.application that return Behavior
      Modifier and Type Method and Description
      Behavior ApplicationWrapper.createBehavior(String behaviorId)

      The default behavior of this method is to call Application.createBehavior(String) on the wrapped Application object.
      Behavior Application.createBehavior(String behaviorId)
      Instantiate and return a new Behavior instance of the class specified by a previous call to addBehavior() for the specified behavior id.

    • Uses of Behavior in javax.faces.component.behavior

      Subinterfaces of Behavior in javax.faces.component.behavior
      Modifier and Type Interface and Description
      interface  ClientBehavior

      ClientBehavior is the base contract for Behaviors that attach script content to client-side events exposed by ClientBehaviorHolder components.
      Classes in javax.faces.component.behavior that implement Behavior
      Modifier and Type Class and Description
      class  AjaxBehavior

      An instance of this class is added as a ClientBehavior to a component using the ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior) contract that components implement.
      class  BehaviorBase

      BehaviorBase is a convenience base class that provides a default implementation of the Behavior contract.
      class  ClientBehaviorBase

      ClientBehaviorBase is a convenience base class that implements the default concrete behavior of all methods defined by ClientBehavior.

    • Uses of Behavior in javax.faces.event

      Methods in javax.faces.event that return Behavior
      Modifier and Type Method and Description
      Behavior BehaviorEvent.getBehavior()

      Return the source Behavior that sent this event.
      Constructors in javax.faces.event with parameters of type Behavior
      Constructor and Description
      AjaxBehaviorEvent(UIComponent component, Behavior behavior)

      Construct a new event object from the specified source component and Ajax behavior.
      BehaviorEvent(UIComponent component, Behavior behavior)

      Construct a new event object from the specified source component and behavior.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.behavior.ClientBehavior (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.behavior.ClientBehavior

  • Packages that use ClientBehavior
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of ClientBehavior in javax.faces.component

      Methods in javax.faces.component that return types with arguments of type ClientBehavior
      Modifier and Type Method and Description
      Map<String,List<ClientBehavior>> UIComponentBase.getClientBehaviors()

      This is a default implementation of ClientBehaviorHolder.getClientBehaviors().
      Methods in javax.faces.component with parameters of type ClientBehavior
      Modifier and Type Method and Description
      void UIComponentBase.addClientBehavior(String eventName, ClientBehavior behavior)

      This is a default implementation of ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).

    • Uses of ClientBehavior in javax.faces.component.behavior

      Classes in javax.faces.component.behavior that implement ClientBehavior
      Modifier and Type Class and Description
      class  AjaxBehavior

      An instance of this class is added as a ClientBehavior to a component using the ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior) contract that components implement.
      class  ClientBehaviorBase

      ClientBehaviorBase is a convenience base class that implements the default concrete behavior of all methods defined by ClientBehavior.
      Methods in javax.faces.component.behavior that return types with arguments of type ClientBehavior
      Modifier and Type Method and Description
      Map<String,List<ClientBehavior>> ClientBehaviorHolder.getClientBehaviors()

      Returns a non-null, unmodifiable Map that contains the the ClientBehaviors that have been attached to the component implementing this interface.
      Methods in javax.faces.component.behavior with parameters of type ClientBehavior
      Modifier and Type Method and Description
      void ClientBehaviorHolder.addClientBehavior(String eventName, ClientBehavior behavior)

      Attaches a ClientBehavior to the component implementing this interface for the specified event.

    • Uses of ClientBehavior in javax.faces.render

      Methods in javax.faces.render with parameters of type ClientBehavior
      Modifier and Type Method and Description
      void ClientBehaviorRenderer.decode(FacesContext context, UIComponent component, ClientBehavior behavior)

      Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.
      String ClientBehaviorRenderer.getScript(ClientBehaviorContext behaviorContext, ClientBehavior behavior)

      Return the script that implements this ClientBehavior's client-side logic.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.behavior.ClientBehaviorHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.behavior.ClientBehaviorHolder

  • Packages that use ClientBehaviorHolder
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of ClientBehaviorHolder in javax.faces.component.html

      Classes in javax.faces.component.html that implement ClientBehaviorHolder
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlForm
      Represents an HTML form element.
      class  HtmlGraphicImage
      Represents an HTML img element, used to retrieve and render a graphical image.
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlPanelGrid
      Renders child components in a table, starting a new row after the specified number of columns.
      class  HtmlPanelGroup
      Causes all child components of this component to be rendered.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.FacesComponent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.FacesComponent

No usage of javax.faces.component.FacesComponent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIColumn (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIColumn

  • Packages that use UIColumn
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UIColumn in javax.faces.component.html

      Subclasses of UIColumn in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlColumn
      Represents a column that will be rendered in an HTML table element.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UICommand (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UICommand

  • Packages that use UICommand
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UICommand in javax.faces.component.html

      Subclasses of UICommand in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIComponent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIComponent

  • Packages that use UIComponent
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.
    javax.faces.component.visit

    APIs for traversing a user interface component view.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.render
    Classes and interfaces defining the rendering model.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of UIComponent in javax.faces.application

      Methods in javax.faces.application that return UIComponent
      Modifier and Type Method and Description
      UIComponent ApplicationWrapper.createComponent(FacesContext context, Resource componentResource)

      The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, Resource) on the wrapped Application object.
      UIComponent Application.createComponent(FacesContext context, Resource componentResource)

      Instantiate and return a new UIComponent instance from the argument Resource.
      UIComponent ApplicationWrapper.createComponent(FacesContext context, String componentType, String rendererType)

      The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, String, String) on the wrapped Application object.
      UIComponent Application.createComponent(FacesContext context, String componentType, String rendererType)

      Like Application.createComponent(String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in Application.createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method.
      UIComponent ApplicationWrapper.createComponent(String componentType)

      The default behavior of this method is to call Application.createComponent(String) on the wrapped Application object.
      abstract UIComponent Application.createComponent(String componentType)
      Instantiate and return a new UIComponent instance of the class specified by a previous call to addComponent() for the specified component type.
      UIComponent ApplicationWrapper.createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
      Deprecated.
      See superclass for alternative.
      abstract UIComponent Application.createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
      Deprecated.
      This has been replaced by Application.createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).
      UIComponent ApplicationWrapper.createComponent(ValueExpression componentExpression, FacesContext context, String componentType)

      The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String) on the wrapped Application object.
      UIComponent Application.createComponent(ValueExpression componentExpression, FacesContext context, String componentType)
      Call the getValue() method on the specified ValueExpression.
      UIComponent ApplicationWrapper.createComponent(ValueExpression componentExpression, FacesContext context, String componentType, String rendererType)

      The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String, String) on the wrapped Application object.
      UIComponent Application.createComponent(ValueExpression componentExpression, FacesContext context, String componentType, String rendererType)

      Like Application.createComponent(ValueExpression, FacesContext, String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in Application.createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method.

    • Uses of UIComponent in javax.faces.component

      Subclasses of UIComponent in javax.faces.component
      Modifier and Type Class and Description
      class  UIColumn
      UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
      class  UICommand
      UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
      class  UIComponentBase
      UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
      class  UIData
      UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
      class  UIForm
      UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
      class  UIGraphic
      UIGraphic is a UIComponent that displays a graphical image to the user.
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UIMessage
      This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.
      class  UIMessages
      The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
      class  UINamingContainer
      UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
      class  UIOutcomeTarget

      This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
      class  UIOutput
      UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
      class  UIPanel
      UIPanel is a UIComponent that manages the layout of its child components.
      class  UIParameter
      UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectItem
      UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.
      class  UISelectItems
      UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewAction

      UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
      class  UIViewRoot
      UIViewRoot is the UIComponent that represents the root of the UIComponent tree.
      Methods in javax.faces.component that return UIComponent
      Modifier and Type | Method and Description
      UIComponent | UIComponentBase.findComponent(String expr)
      abstract UIComponent UIComponent.findComponent(String expr)
      Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.
      static UIComponent UIComponent.getCompositeComponentParent(UIComponent component)
      Finds the nearest composite component parent of the specified component.
      static UIComponent UIComponent.getCurrentComponent(FacesContext context)

      Return the UIComponent instance that is currently processing.
      static UIComponent UIComponent.getCurrentCompositeComponent(FacesContext context)

      Return the closest ancestor component, relative to the component returned from getCurrentComponent(javax.faces.context.FacesContext), that is a composite component, or null if no such component exists.
      UIComponent | UIComponentBase.getFacet(String name)
      abstract UIComponent UIComponent.getFacet(String name)
      Convenience method to return the named facet, if it exists, or null otherwise.
      UIComponent UIData.getFooter()
      Return the footer facet of this component (if any).
      UIComponent UIColumn.getFooter()
      Return the footer facet of the column (if any).
      UIComponent UIData.getHeader()
      Return the header facet of this component (if any).
      UIComponent UIColumn.getHeader()
      Return the header facet of the column (if any).
      UIComponent UIComponent.getNamingContainer()

      Starting with "this", return the closest component in the ancestry that is a NamingContainer or null if none can be found.
      UIComponent | UIComponentBase.getParent()
      abstract UIComponent UIComponent.getParent()
      Return the parent UIComponent of this UIComponent, if any.
      Methods in javax.faces.component that return types with arguments of type UIComponent
      Modifier and Type | Method and Description
      List<UIComponent> | UIComponentBase.getChildren()
      abstract List<UIComponent> UIComponent.getChildren()
      Return a mutable List representing the child UIComponents associated with this component.
      List<UIComponent> UIViewRoot.getComponentResources(FacesContext context, String target)

      Return an unmodifiable List of UIComponents for the provided target agrument.
      Map<String,UIComponent> | UIComponentBase.getFacets()
      abstract Map<String,UIComponent> UIComponent.getFacets()
      Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String).
      Iterator<UIComponent> | UIComponentBase.getFacetsAndChildren()
      abstract Iterator<UIComponent> UIComponent.getFacetsAndChildren()
      Return an Iterator over the facet followed by child UIComponents of this UIComponent.
      Methods in javax.faces.component with parameters of type UIComponent
      Modifier and Type | Method and Description
      void UIViewRoot.addComponentResource(FacesContext context, UIComponent componentResource)

      Add argument component, which is assumed to represent a resource instance, as a resource to this view.
      void UIViewRoot.addComponentResource(FacesContext context, UIComponent componentResource, String target)

      Add argument component, which is assumed to represent a resource instance, as a resource to this view.
      static UIComponent UIComponent.getCompositeComponentParent(UIComponent component)
      Finds the nearest composite component parent of the specified component.
      void ContextCallback.invokeContextCallback(FacesContext context, UIComponent target)
      This method will be called by an implementation of invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) and must be passed the component with the clientId given as an argument to invokeOnComponent.
      static boolean UIComponent.isCompositeComponent(UIComponent component)

      Return true if component is a composite component, otherwise false.
      void UIComponent.pushComponentToEL(FacesContext context, UIComponent component)

      Push the current UIComponent this to the FacesContext attribute map using the key CURRENT_COMPONENT saving the previous UIComponent associated with CURRENT_COMPONENT for a subsequent call to popComponentFromEL(javax.faces.context.FacesContext).
      void UIViewRoot.removeComponentResource(FacesContext context, UIComponent componentResource)

      Remove argument component, which is assumed to represent a resource instance, as a resource to this view.
      void UIViewRoot.removeComponentResource(FacesContext context, UIComponent componentResource, String target)

      Remove argument component, which is assumed to represent a resource instance, as a resource to this view.
      void UIData.setFooter(UIComponent footer)
      Set the footer facet of this component.
      void UIColumn.setFooter(UIComponent footer)
      Set the footer facet of the column.
      void UIData.setHeader(UIComponent header)
      Set the header facet of this component.
      void UIColumn.setHeader(UIComponent header)
      Set the header facet of the column.
      void | UIComponentBase.setParent(UIComponent parent)
      abstract void UIComponent.setParent(UIComponent parent)

      Set the parent UIComponent of this UIComponent.

    • Uses of UIComponent in javax.faces.component.behavior

      Methods in javax.faces.component.behavior that return UIComponent
      Modifier and Type Method and Description
      abstract UIComponent ClientBehaviorContext.getComponent()

      Returns the UIComponent that is requesting the ClientBehavior script.
      Methods in javax.faces.component.behavior with parameters of type UIComponent
      Modifier and Type Method and Description
      static ClientBehaviorContext ClientBehaviorContext.createClientBehaviorContext(FacesContext context, UIComponent component, String eventName, String sourceId, Collection<ClientBehaviorContext.Parameter> parameters)

      Creates a ClientBehaviorContext instance.
      void ClientBehaviorBase.decode(FacesContext context, UIComponent component)

      Default implementation of of ClientBehavior.decode(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
      void ClientBehavior.decode(FacesContext context, UIComponent component)

      Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.

    • Uses of UIComponent in javax.faces.component.html

      Subclasses of UIComponent in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlColumn
      Represents a column that will be rendered in an HTML table element.
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlDoctype
      NONE
      class  HtmlForm
      Represents an HTML form element.
      class  HtmlGraphicImage
      Represents an HTML img element, used to retrieve and render a graphical image.
      class  HtmlHead
      NONE
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlMessage
      By default, the rendererType property must be set to "javax.faces.Message".
      class  HtmlMessages
      By default, the rendererType property must be set to "javax.faces.Messages".
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputFormat
      Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlOutputText
      Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
      class  HtmlPanelGrid
      Renders child components in a table, starting a new row after the specified number of columns.
      class  HtmlPanelGroup
      Causes all child components of this component to be rendered.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.

    • Uses of UIComponent in javax.faces.component.visit

      Methods in javax.faces.component.visit with parameters of type UIComponent
      Modifier and Type | Method and Description
      Collection<String> | VisitContextWrapper.getSubtreeIdsToVisit(UIComponent component)
      abstract Collection<String> VisitContext.getSubtreeIdsToVisit(UIComponent component)

      Given a NamingContainer component, returns the client ids of any components underneath the NamingContainer that should be visited.
      VisitResult | VisitContextWrapper.invokeVisitCallback(UIComponent component, VisitCallback callback)
      abstract VisitResult VisitContext.invokeVisitCallback(UIComponent component, VisitCallback callback)
      Called by UIComponent.visitTree() to visit a single component.
      VisitResult VisitCallback.visit(VisitContext context, UIComponent target)
      This method is called during component tree visits by VisitContext.invokeVisitCallback() to visit the specified component.

    • Uses of UIComponent in javax.faces.context

      Methods in javax.faces.context with parameters of type UIComponent
      Modifier and Type Method and Description
      void ResponseWriterWrapper.startElement(String name, UIComponent component)
      The default behavior of this method is to call ResponseWriter.startElement(String, javax.faces.component.UIComponent) on the wrapped ResponseWriter object.
      abstract void ResponseWriter.startElement(String name, UIComponent component)
      Write the start of an element, up to and including the element name.
      void ResponseWriterWrapper.writeText(Object text, UIComponent component, String property)
      The default behavior of this method is to call ResponseWriter.writeText(Object, UIComponent, String) on the wrapped ResponseWriter object.
      void ResponseWriter.writeText(Object text, UIComponent component, String property)
      Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.

    • Uses of UIComponent in javax.faces.convert

      Methods in javax.faces.convert with parameters of type UIComponent
      Modifier and Type | Method and Description
      Object | ShortConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | NumberConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | LongConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | IntegerConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | FloatConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object EnumConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Convert the value argument to one of the enum constants of the class provided in our constructor.
      Object | DoubleConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | DateTimeConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object Converter.getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      Object | CharacterConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | ByteConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | BooleanConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | BigIntegerConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | BigDecimalConverter.getAsObject(FacesContext context, UIComponent component, String value)
      String | ShortConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | NumberConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | LongConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | IntegerConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | FloatConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String EnumConverter.getAsString(FacesContext context, UIComponent component, Object value)
      Convert the enum constant given by the value argument into a String.
      String | DoubleConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | DateTimeConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String Converter.getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
      String | CharacterConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | ByteConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | BooleanConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | BigIntegerConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | BigDecimalConverter.getAsString(FacesContext context, UIComponent component, Object value)

    • Uses of UIComponent in javax.faces.event

      Methods in javax.faces.event that return UIComponent
      Modifier and Type Method and Description
      UIComponent FacesEvent.getComponent()
      Return the source UIComponent that sent this event.
      UIComponent ExceptionQueuedEventContext.getComponent()

      Return the UIComponent which was being processed when the exception was thrown.
      UIComponent ComponentSystemEvent.getComponent()

      the source UIComponent that sent this event.
      Methods in javax.faces.event with parameters of type UIComponent
      Modifier and Type | Method and Description
      void | PostRestoreStateEvent.setComponent(UIComponent newComponent)
      Constructors in javax.faces.event with parameters of type UIComponent
      Constructor and Description
      ActionEvent(UIComponent component)
      Construct a new event object from the specified source component and action command.
      AjaxBehaviorEvent(UIComponent component, Behavior behavior)

      Construct a new event object from the specified source component and Ajax behavior.
      BehaviorEvent(UIComponent component, Behavior behavior)

      Construct a new event object from the specified source component and behavior.
      ComponentSystemEvent(UIComponent component)

      Pass the argument component to the superclass constructor.
      ExceptionQueuedEventContext(FacesContext context, Throwable thrown, UIComponent component)

      Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component.
      ExceptionQueuedEventContext(FacesContext context, Throwable thrown, UIComponent component, PhaseId phaseId)

      Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component, during the lifecycle phase phaseId.
      FacesEvent(UIComponent component)
      Construct a new event object from the specified source component.
      PostAddToViewEvent(UIComponent component)

      Instantiate a new PostAddToViewEvent that indicates the argument component was just added to the view.
      PostRestoreStateEvent(UIComponent component)

      Instantiate a new PostRestoreStateEvent that indicates the argument component just had its state restored.
      PostValidateEvent(UIComponent component)

      PreRemoveFromViewEvent(UIComponent component)

      Instantiate a new BeforeRemoveFromView that indicates the argument component is about to be removed from the view.
      PreRenderComponentEvent(UIComponent component)

      Instantiate a new PreRenderComponentEvent that indicates the argument component is about to be rendered.
      PreValidateEvent(UIComponent component)

      ValueChangeEvent(UIComponent component, Object oldValue, Object newValue)
      Construct a new event object from the specified source component, old value, and new value.

    • Uses of UIComponent in javax.faces.render

      Methods in javax.faces.render with parameters of type UIComponent
      Modifier and Type | Method and Description
      void | RendererWrapper.decode(FacesContext context, UIComponent component)
      void Renderer.decode(FacesContext context, UIComponent component)
      Decode any new state of the specified UIComponent from the request contained in the specified FacesContext, and store that state on the UIComponent.
      void ClientBehaviorRenderer.decode(FacesContext context, UIComponent component, ClientBehavior behavior)

      Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.
      void | RendererWrapper.encodeBegin(FacesContext context, UIComponent component)
      void Renderer.encodeBegin(FacesContext context, UIComponent component)
      Render the beginning specified UIComponent to the output stream or writer associated with the response we are creating.
      void | RendererWrapper.encodeChildren(FacesContext context, UIComponent component)
      void Renderer.encodeChildren(FacesContext context, UIComponent component)
      Render the child components of this UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
      void | RendererWrapper.encodeEnd(FacesContext context, UIComponent component)
      void Renderer.encodeEnd(FacesContext context, UIComponent component)
      Render the ending of the current state of the specified UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
      Object | RendererWrapper.getConvertedValue(FacesContext context, UIComponent component, Object submittedValue)
      Object Renderer.getConvertedValue(FacesContext context, UIComponent component, Object submittedValue)
      Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one).

    • Uses of UIComponent in javax.faces.validator

      Methods in javax.faces.validator with parameters of type UIComponent
      Modifier and Type | Method and Description
      void Validator.validate(FacesContext context, UIComponent component, Object value)
      Perform the correctness checks implemented by this Validator against the specified UIComponent.
      void RequiredValidator.validate(FacesContext context, UIComponent component, Object value)
      Verify that the converted object value is not null.
      void RegexValidator.validate(FacesContext context, UIComponent component, Object value)
      Validate a String against a regular expression pattern.
      void | MethodExpressionValidator.validate(FacesContext context, UIComponent component, Object value)
      void | LongRangeValidator.validate(FacesContext context, UIComponent component, Object value)
      void | LengthValidator.validate(FacesContext context, UIComponent component, Object value)
      void | DoubleRangeValidator.validate(FacesContext context, UIComponent component, Object value)
      void BeanValidator.validate(FacesContext context, UIComponent component, Object value)

      Verify that the value is valid according to the Bean Validation constraints.

    • Uses of UIComponent in javax.faces.view

      Methods in javax.faces.view that return UIComponent
      Modifier and Type | Method and Description
      UIComponent | ViewDeclarationLanguageWrapper.createComponent(FacesContext context, String taglibURI, String tagName, Map<String,Object> attributes)
      UIComponent ViewDeclarationLanguage.createComponent(FacesContext context, String taglibURI, String tagName, Map<String,Object> attributes)

      Create a component given a ViewDeclarationLanguage specific tag library URI and tag name.
      Methods in javax.faces.view that return types with arguments of type UIComponent
      Modifier and Type Method and Description
      List<UIComponent> AttachedObjectTarget.getTargets(UIComponent topLevelComponent)

      Returns the List<UIComponent> that this AttachedObjectTarget exposes.
      Methods in javax.faces.view with parameters of type UIComponent
      Modifier and Type | Method and Description
      void AttachedObjectHandler.applyAttachedObject(FacesContext context, UIComponent parent)

      Take the argument parent and apply this attached object to it.
      List<UIComponent> AttachedObjectTarget.getTargets(UIComponent topLevelComponent)

      Returns the List<UIComponent> that this AttachedObjectTarget exposes.
      void | ViewDeclarationLanguageWrapper.retargetAttachedObjects(FacesContext context, UIComponent topLevelComponent, List<AttachedObjectHandler> handlers)
      void ViewDeclarationLanguage.retargetAttachedObjects(FacesContext context, UIComponent topLevelComponent, List<AttachedObjectHandler> handlers)

      Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting attached objects from the top level composite component to the individual AttachedObjectTarget instances inside the composite component.
      void | ViewDeclarationLanguageWrapper.retargetMethodExpressions(FacesContext context, UIComponent topLevelComponent)
      void ViewDeclarationLanguage.retargetMethodExpressions(FacesContext context, UIComponent topLevelComponent)

      Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting any method expressions from the top level component to the appropriate inner component.

    • Uses of UIComponent in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return UIComponent
      Modifier and Type Method and Description
      UIComponent ComponentHandler.createComponent(FaceletContext ctx)

      Subclasses that wish to take over the task of instantiating the UIComponent instance corresponding to this tag handler my override this method to do so.
      Methods in javax.faces.view.facelets with parameters of type UIComponent
      Modifier and Type Method and Description
      abstract void TagHandlerDelegate.apply(FaceletContext ctx, UIComponent comp)

      Called by classes that implement FaceletHandler in their implementation of apply().
      void FaceletHandler.apply(FaceletContext ctx, UIComponent parent)

      Process changes on a particular UIComponent
      void DelegatingMetaTagHandler.apply(FaceletContext ctx, UIComponent parent)

      The default implementation simply calls through to TagHandlerDelegate.apply(javax.faces.view.facelets.FaceletContext, javax.faces.component.UIComponent).
      void CompositeFaceletHandler.apply(FaceletContext ctx, UIComponent parent)

      Calls apply on any child handlers.
      abstract void Facelet.apply(FacesContext facesContext, UIComponent parent)
      The passed UIComponent parent will be populated/restored in accordance with the Facelets chapter in the spec prose document.
      void FaceletsAttachedObjectHandler.applyAttachedObject(FacesContext ctx, UIComponent parent)

      Take the necessary actions to apply the attached object represented by the tag for the concrete subclass of this class to the argument parent.
      void DelegatingMetaTagHandler.applyNextHandler(FaceletContext ctx, UIComponent c)

      Invoke the apply() method on this instance's TagHandler.nextHandler.
      abstract void FaceletContext.includeFacelet(UIComponent parent, String relativePath)

      Include another Facelet defined at some path, relative to the executing context, not the current Facelet (same as include directive in JSP)
      abstract void FaceletContext.includeFacelet(UIComponent parent, URL absolutePath)

      Include another Facelet defined at some path, absolute to this ClassLoader/OS
      static boolean ComponentHandler.isNew(UIComponent component)

      Determine if the passed component is not null and if it's new to the tree.
      void ComponentHandler.onComponentCreated(FaceletContext ctx, UIComponent c, UIComponent parent)

      This method is guaranteed to be called after the component has been created but before it has been populated with children.
      void ComponentHandler.onComponentPopulated(FaceletContext ctx, UIComponent c, UIComponent parent)

      This method is guaranteed to be called after the component has been populated with children.

    • Uses of UIComponent in javax.faces.webapp

      Methods in javax.faces.webapp that return UIComponent
      Modifier and Type Method and Description
      protected UIComponent UIComponentTag.createComponent(FacesContext context, String newId)
      Deprecated.
      Implement createComponent using Faces 1.1 EL API.
      protected UIComponent UIComponentELTag.createComponent(FacesContext context, String newId)
      Create and return a new child component of the type returned by calling getComponentType().
      protected abstract UIComponent UIComponentClassicTagBase.createComponent(FacesContext context, String newId)
      Create and return a new child component of the type returned by calling getComponentType().
      protected UIComponent UIComponentClassicTagBase.createVerbatimComponentFromBodyContent()
      Create a transient UIOutput component from the body content, of this tag instance or return null if there is no body content, the body content is whitespace, or the body content is a comment.
      protected UIComponent UIComponentClassicTagBase.findComponent(FacesContext context)
      Find and return the UIComponent, from the component tree, that corresponds to this tag handler instance.
      abstract UIComponent UIComponentTagBase.getComponentInstance()
      Return the UIComponent instance that is associated with this tag instance.
      UIComponent UIComponentClassicTagBase.getComponentInstance()
      Return the UIComponent instance that is associated with this tag instance.
      Methods in javax.faces.webapp with parameters of type UIComponent
      Modifier and Type | Method and Description
      protected abstract void UIComponentTagBase.addChild(UIComponent child)
      Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.
      protected void | UIComponentClassicTagBase.addChild(UIComponent child)
      protected void UIComponentClassicTagBase.addVerbatimAfterComponent(UIComponentClassicTagBase parentTag, UIComponent verbatim, UIComponent component)
      Add verbatim as a sibling of component in component in the parent's child list.
      protected void UIComponentClassicTagBase.addVerbatimBeforeComponent(UIComponentClassicTagBase parentTag, UIComponent verbatim, UIComponent component)
      Add verbatim as a sibling of component in component in the parent's child list.
      protected void UIComponentTag.setProperties(UIComponent component)
      Deprecated.
      protected void UIComponentELTag.setProperties(UIComponent component)
      Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set.
      protected abstract void UIComponentClassicTagBase.setProperties(UIComponent component)
      Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIComponentBase (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIComponentBase

  • Packages that use UIComponentBase
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UIComponentBase in javax.faces.component

      Subclasses of UIComponentBase in javax.faces.component
      Modifier and Type Class and Description
      class  UIColumn
      UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
      class  UICommand
      UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
      class  UIData
      UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
      class  UIForm
      UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
      class  UIGraphic
      UIGraphic is a UIComponent that displays a graphical image to the user.
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UIMessage
      This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.
      class  UIMessages
      The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
      class  UINamingContainer
      UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
      class  UIOutcomeTarget

      This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
      class  UIOutput
      UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
      class  UIPanel
      UIPanel is a UIComponent that manages the layout of its child components.
      class  UIParameter
      UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectItem
      UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.
      class  UISelectItems
      UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewAction

      UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
      class  UIViewRoot
      UIViewRoot is the UIComponent that represents the root of the UIComponent tree.

    • Uses of UIComponentBase in javax.faces.component.html

      Subclasses of UIComponentBase in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlColumn
      Represents a column that will be rendered in an HTML table element.
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlDoctype
      NONE
      class  HtmlForm
      Represents an HTML form element.
      class  HtmlGraphicImage
      Represents an HTML img element, used to retrieve and render a graphical image.
      class  HtmlHead
      NONE
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlMessage
      By default, the rendererType property must be set to "javax.faces.Message".
      class  HtmlMessages
      By default, the rendererType property must be set to "javax.faces.Messages".
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputFormat
      Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlOutputText
      Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
      class  HtmlPanelGrid
      Renders child components in a table, starting a new row after the specified number of columns.
      class  HtmlPanelGroup
      Causes all child components of this component to be rendered.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIData (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIData

  • Packages that use UIData
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UIData in javax.faces.component.html

      Subclasses of UIData in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIForm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIForm

  • Packages that use UIForm
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UIForm in javax.faces.component.html

      Subclasses of UIForm in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlForm
      Represents an HTML form element.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIGraphic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIGraphic

  • Packages that use UIGraphic
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UIGraphic in javax.faces.component.html

      Subclasses of UIGraphic in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlGraphicImage
      Represents an HTML img element, used to retrieve and render a graphical image.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIInput (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIInput

  • Packages that use UIInput
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UIInput in javax.faces.component

      Subclasses of UIInput in javax.faces.component
      Modifier and Type Class and Description
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.

    • Uses of UIInput in javax.faces.component.html

      Subclasses of UIInput in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIMessage

  • Packages that use UIMessage
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UIMessage in javax.faces.component.html

      Subclasses of UIMessage in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlMessage
      By default, the rendererType property must be set to "javax.faces.Message".
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIMessages (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIMessages

  • Packages that use UIMessages
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UIMessages in javax.faces.component.html

      Subclasses of UIMessages in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlMessages
      By default, the rendererType property must be set to "javax.faces.Messages".
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UINamingContainer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UINamingContainer

No usage of javax.faces.component.UINamingContainer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIOutcomeTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIOutcomeTarget

  • Packages that use UIOutcomeTarget
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UIOutcomeTarget in javax.faces.component.html

      Subclasses of UIOutcomeTarget in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIOutput (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIOutput

  • Packages that use UIOutput
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of UIOutput in javax.faces.component

      Subclasses of UIOutput in javax.faces.component
      Modifier and Type Class and Description
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UIOutcomeTarget

      This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.

    • Uses of UIOutput in javax.faces.component.html

      Subclasses of UIOutput in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlDoctype
      NONE
      class  HtmlHead
      NONE
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputFormat
      Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlOutputText
      Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.

    • Uses of UIOutput in javax.faces.webapp

      Methods in javax.faces.webapp that return UIOutput
      Modifier and Type Method and Description
      protected UIOutput UIComponentClassicTagBase.createVerbatimComponent()
      Use the Application instance to create a new component with the following characteristics.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIPanel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIPanel

  • Packages that use UIPanel
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UIPanel in javax.faces.component.html

      Subclasses of UIPanel in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlPanelGrid
      Renders child components in a table, starting a new row after the specified number of columns.
      class  HtmlPanelGroup
      Causes all child components of this component to be rendered.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIParameter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIParameter

No usage of javax.faces.component.UIParameter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UISelectBoolean (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UISelectBoolean

  • Packages that use UISelectBoolean
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UISelectBoolean in javax.faces.component.html

      Subclasses of UISelectBoolean in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UISelectItem (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UISelectItem

No usage of javax.faces.component.UISelectItem
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UISelectItems (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UISelectItems

No usage of javax.faces.component.UISelectItems
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UISelectMany (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UISelectMany

  • Packages that use UISelectMany
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UISelectMany in javax.faces.component.html

      Subclasses of UISelectMany in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UISelectOne (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UISelectOne

  • Packages that use UISelectOne
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UISelectOne in javax.faces.component.html

      Subclasses of UISelectOne in javax.faces.component.html
      Modifier and Type Class and Description
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIViewAction (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIViewAction

  • Packages that use UIViewAction
    Package Description
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

    • Uses of UIViewAction in javax.faces.view

      Methods in javax.faces.view that return types with arguments of type UIViewAction
      Modifier and Type Method and Description
      static Collection<UIViewAction> ViewMetadata.getViewActions(UIViewRoot root)

      Utility method to extract view metadata from the provided UIViewRoot.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIViewParameter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIViewParameter

  • Packages that use UIViewParameter
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

    • Uses of UIViewParameter in javax.faces.component

      Methods in javax.faces.component that return UIViewParameter
      Modifier and Type Method and Description
      UIViewParameter UIViewParameter.Reference.getUIViewParameter(FacesContext context)

      Return the UIViewParameter to which this instance refers.
      Constructors in javax.faces.component with parameters of type UIViewParameter
      Constructor and Description
      UIViewParameter.Reference(FacesContext context, UIViewParameter param, int indexInParent, String viewIdAtTimeOfConstruction)

      Construct a reference to a UIViewParameter.

    • Uses of UIViewParameter in javax.faces.view

      Methods in javax.faces.view that return types with arguments of type UIViewParameter
      Modifier and Type Method and Description
      static Collection<UIViewParameter> ViewMetadata.getViewParameters(UIViewRoot root)

      Utility method to extract view metadata from the provided UIViewRoot.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIViewParameter.Reference (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIViewParameter.Reference

No usage of javax.faces.component.UIViewParameter.Reference
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UIViewRoot (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UIViewRoot

  • Packages that use UIViewRoot
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

    • Uses of UIViewRoot in javax.faces.application

      Methods in javax.faces.application that return UIViewRoot
      Modifier and Type Method and Description
      UIViewRoot ViewHandlerWrapper.createView(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.createView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      abstract UIViewRoot ViewHandler.createView(FacesContext context, String viewId)
      Create and return a new UIViewRoot instance initialized with information from the argument FacesContext and viewId.
      protected UIViewRoot StateManagerWrapper.restoreTreeStructure(FacesContext context, String viewId, String renderKitId)
      The default behavior of this method is to call StateManager.restoreTreeStructure(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.
      protected UIViewRoot StateManager.restoreTreeStructure(FacesContext context, String viewId, String renderKitId)
      Deprecated.
      the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
      UIViewRoot ViewHandlerWrapper.restoreView(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.restoreView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      abstract UIViewRoot ViewHandler.restoreView(FacesContext context, String viewId)
      Perform whatever actions are required to restore the view associated with the specified FacesContext and viewId.
      UIViewRoot StateManagerWrapper.restoreView(FacesContext context, String viewId, String renderKitId)
      The default behavior of this method is to call StateManager.restoreView(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.
      abstract UIViewRoot StateManager.restoreView(FacesContext context, String viewId, String renderKitId)
      Deprecated.
      Methods in javax.faces.application with parameters of type UIViewRoot
      Modifier and Type Method and Description
      void ViewHandlerWrapper.renderView(FacesContext context, UIViewRoot viewToRender)
      The default behavior of this method is to call ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) on the wrapped ViewHandler object.
      abstract void ViewHandler.renderView(FacesContext context, UIViewRoot viewToRender)
      Perform whatever actions are required to render the response view to the response object associated with the current FacesContext.
      protected void StateManagerWrapper.restoreComponentState(FacesContext context, UIViewRoot viewRoot, String renderKitId)
      The default behavior of this method is to call StateManager.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, String) on the wrapped StateManager object.
      protected void StateManager.restoreComponentState(FacesContext context, UIViewRoot viewRoot, String renderKitId)
      Deprecated.
      the distinction between tree structure and component state is now an implementation detail. The default implementation does nothing.

    • Uses of UIViewRoot in javax.faces.context

      Methods in javax.faces.context that return UIViewRoot
      Modifier and Type Method and Description
      UIViewRoot FacesContextWrapper.getViewRoot()
      The default behavior of this method is to call FacesContext.getViewRoot() on the wrapped FacesContext object.
      abstract UIViewRoot FacesContext.getViewRoot()
      Return the root component that is associated with the this request.
      Methods in javax.faces.context with parameters of type UIViewRoot
      Modifier and Type Method and Description
      void FacesContextWrapper.setViewRoot(UIViewRoot root)
      The default behavior of this method is to call FacesContext.setViewRoot(UIViewRoot) on the wrapped FacesContext object.
      abstract void FacesContext.setViewRoot(UIViewRoot root)
      Set the root component that is associated with this request.

    • Uses of UIViewRoot in javax.faces.event

      Constructors in javax.faces.event with parameters of type UIViewRoot
      Constructor and Description
      PostConstructViewMapEvent(UIViewRoot root)

      Instantiate a new PostConstructViewMapEvent that indicates the argument root was just associated with its view map.
      PreDestroyViewMapEvent(UIViewRoot root)

      Instantiate a new ViewMapDestroydEvent that indicates the argument root just had its associated view map destroyed.
      PreRenderViewEvent(UIViewRoot root)

      Instantiate a new PreRenderViewEvent that indicates the argument root is about to be rendered.

    • Uses of UIViewRoot in javax.faces.view

      Methods in javax.faces.view that return UIViewRoot
      Modifier and Type | Method and Description
      abstract UIViewRoot ViewMetadata.createMetadataView(FacesContext context)

      Creates a new UIViewRoot containing only view parameter metadata.
      UIViewRoot | ViewDeclarationLanguageWrapper.createView(FacesContext context, String viewId)
      abstract UIViewRoot ViewDeclarationLanguage.createView(FacesContext context, String viewId)

      Create a UIViewRoot from the VDL contained in the artifact referenced by the argument viewId.
      UIViewRoot | ViewDeclarationLanguageWrapper.restoreView(FacesContext context, String viewId)
      abstract UIViewRoot ViewDeclarationLanguage.restoreView(FacesContext context, String viewId)

      Restore a UIViewRoot from a previously created view.
      abstract UIViewRoot StateManagementStrategy.restoreView(FacesContext context, String viewId, String renderKitId)

      Restore the state of the view with information in the request.
      Methods in javax.faces.view with parameters of type UIViewRoot
      Modifier and Type | Method and Description
      void | ViewDeclarationLanguageWrapper.buildView(FacesContext context, UIViewRoot root)
      abstract void ViewDeclarationLanguage.buildView(FacesContext context, UIViewRoot root)

      Take any actions specific to this VDL implementation to cause the argument UIViewRoot which must have been created via a call to ViewDeclarationLanguage.createView(javax.faces.context.FacesContext, java.lang.String), to be populated with children.
      static Collection<UIViewAction> ViewMetadata.getViewActions(UIViewRoot root)

      Utility method to extract view metadata from the provided UIViewRoot.
      static Collection<UIViewParameter> ViewMetadata.getViewParameters(UIViewRoot root)

      Utility method to extract view metadata from the provided UIViewRoot.
      static boolean ViewMetadata.hasMetadata(UIViewRoot root)

      Utility method to determine if the the provided UIViewRoot has metadata.
      void | ViewDeclarationLanguageWrapper.renderView(FacesContext context, UIViewRoot view)
      abstract void ViewDeclarationLanguage.renderView(FacesContext context, UIViewRoot view)

      Render a view rooted at argumentview.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.UpdateModelException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.UpdateModelException

No usage of javax.faces.component.UpdateModelException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.ActionSource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.ActionSource

  • Packages that use ActionSource
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of ActionSource in javax.faces.component

      Subinterfaces of ActionSource in javax.faces.component
      Modifier and Type Interface and Description
      interface  ActionSource2
      ActionSource2 extends ActionSource and provides a JavaBeans property analogous to the "action" property on ActionSource.
      Classes in javax.faces.component that implement ActionSource
      Modifier and Type Class and Description
      class  UICommand
      UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
      class  UIViewAction

      UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.

    • Uses of ActionSource in javax.faces.component.html

      Classes in javax.faces.component.html that implement ActionSource
      Modifier and Type Class and Description
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.ActionSource2 (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.ActionSource2

  • Packages that use ActionSource2
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of ActionSource2 in javax.faces.component

      Classes in javax.faces.component that implement ActionSource2
      Modifier and Type Class and Description
      class  UICommand
      UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
      class  UIViewAction

      UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.

    • Uses of ActionSource2 in javax.faces.component.html

      Classes in javax.faces.component.html that implement ActionSource2
      Modifier and Type Class and Description
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.ContextCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.ContextCallback

  • Packages that use ContextCallback
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.

    • Uses of ContextCallback in javax.faces.component

      Methods in javax.faces.component with parameters of type ContextCallback
      Modifier and Type Method and Description
      boolean UIData.invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Override behavior from UIComponentBase.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) to provide special care for positioning the data properly before finding the component and invoking the callback on it.
      boolean UIComponentBase.invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.
      boolean UIComponent.invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.EditableValueHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.EditableValueHolder

  • Packages that use EditableValueHolder
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of EditableValueHolder in javax.faces.component

      Classes in javax.faces.component that implement EditableValueHolder
      Modifier and Type Class and Description
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.

    • Uses of EditableValueHolder in javax.faces.component.html

      Classes in javax.faces.component.html that implement EditableValueHolder
      Modifier and Type Class and Description
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.NamingContainer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.NamingContainer

  • Packages that use NamingContainer
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of NamingContainer in javax.faces.component

      Classes in javax.faces.component that implement NamingContainer
      Modifier and Type Class and Description
      class  UIData
      UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
      class  UIForm
      UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
      class  UINamingContainer
      UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.

    • Uses of NamingContainer in javax.faces.component.html

      Classes in javax.faces.component.html that implement NamingContainer
      Modifier and Type Class and Description
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlForm
      Represents an HTML form element.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.PartialStateHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.PartialStateHolder

  • Packages that use PartialStateHolder
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.

    • Uses of PartialStateHolder in javax.faces.component

      Classes in javax.faces.component that implement PartialStateHolder
      Modifier and Type Class and Description
      class  UIColumn
      UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
      class  UICommand
      UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
      class  UIComponent
      UIComponent is the base class for all user interface components in JavaServer Faces.
      class  UIComponentBase
      UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
      class  UIData
      UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
      class  UIForm
      UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
      class  UIGraphic
      UIGraphic is a UIComponent that displays a graphical image to the user.
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UIMessage
      This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.
      class  UIMessages
      The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
      class  UINamingContainer
      UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
      class  UIOutcomeTarget

      This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
      class  UIOutput
      UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
      class  UIPanel
      UIPanel is a UIComponent that manages the layout of its child components.
      class  UIParameter
      UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectItem
      UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.
      class  UISelectItems
      UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewAction

      UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
      class  UIViewRoot
      UIViewRoot is the UIComponent that represents the root of the UIComponent tree.

    • Uses of PartialStateHolder in javax.faces.component.behavior

      Classes in javax.faces.component.behavior that implement PartialStateHolder
      Modifier and Type Class and Description
      class  AjaxBehavior

      An instance of this class is added as a ClientBehavior to a component using the ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior) contract that components implement.
      class  BehaviorBase

      BehaviorBase is a convenience base class that provides a default implementation of the Behavior contract.
      class  ClientBehaviorBase

      ClientBehaviorBase is a convenience base class that implements the default concrete behavior of all methods defined by ClientBehavior.

    • Uses of PartialStateHolder in javax.faces.component.html

      Classes in javax.faces.component.html that implement PartialStateHolder
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlColumn
      Represents a column that will be rendered in an HTML table element.
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlDoctype
      NONE
      class  HtmlForm
      Represents an HTML form element.
      class  HtmlGraphicImage
      Represents an HTML img element, used to retrieve and render a graphical image.
      class  HtmlHead
      NONE
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlMessage
      By default, the rendererType property must be set to "javax.faces.Message".
      class  HtmlMessages
      By default, the rendererType property must be set to "javax.faces.Messages".
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputFormat
      Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlOutputText
      Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
      class  HtmlPanelGrid
      Renders child components in a table, starting a new row after the specified number of columns.
      class  HtmlPanelGroup
      Causes all child components of this component to be rendered.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.

    • Uses of PartialStateHolder in javax.faces.convert

      Classes in javax.faces.convert that implement PartialStateHolder
      Modifier and Type Class and Description
      class  DateTimeConverter
      Converter implementation for java.util.Date values.
      class  EnumConverter
      Converter implementation for java.lang.Enum (and enum primitive) values.
      class  NumberConverter
      Converter implementation for java.lang.Number values.

    • Uses of PartialStateHolder in javax.faces.validator

      Classes in javax.faces.validator that implement PartialStateHolder
      Modifier and Type Class and Description
      class  BeanValidator

      A Validator that delegates validation of the bean property to the Bean Validation API.
      class  DoubleRangeValidator
      DoubleRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
      class  LengthValidator
      LengthValidator is a Validator that checks the number of characters in the String representation of the value of the associated component.
      class  LongRangeValidator
      LongRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
      class  RegexValidator

      A Validator that checks against a Regular Expression (which is the pattern property).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.StateHelper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.StateHelper

  • Packages that use StateHelper
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.

    • Uses of StateHelper in javax.faces.component

      Methods in javax.faces.component that return StateHelper
      Modifier and Type Method and Description
      protected StateHelper UIComponent.getStateHelper()

      Return the StateHelper instance used to help this component implement PartialStateHolder.
      protected StateHelper UIComponent.getStateHelper(boolean create)

      Like UIComponent.getStateHelper(), but only create a state helper instance if the argument creat is true.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.StateHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.StateHolder

  • Packages that use StateHolder
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.

    • Uses of StateHolder in javax.faces.component

      Subinterfaces of StateHolder in javax.faces.component
      Modifier and Type Interface and Description
      interface  PartialStateHolder

      Components that want to leverage the partial state saving feature must implement this interface instead of implementing StateHolder, from which this interface inherits.
      interface  StateHelper

      Define a Map-like contract that makes it easier for components to implement PartialStateHolder.
      Classes in javax.faces.component that implement StateHolder
      Modifier and Type Class and Description
      class  UIColumn
      UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
      class  UICommand
      UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
      class  UIComponent
      UIComponent is the base class for all user interface components in JavaServer Faces.
      class  UIComponentBase
      UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
      class  UIData
      UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
      class  UIForm
      UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
      class  UIGraphic
      UIGraphic is a UIComponent that displays a graphical image to the user.
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UIMessage
      This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.
      class  UIMessages
      The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
      class  UINamingContainer
      UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
      class  UIOutcomeTarget

      This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
      class  UIOutput
      UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
      class  UIPanel
      UIPanel is a UIComponent that manages the layout of its child components.
      class  UIParameter
      UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectItem
      UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.
      class  UISelectItems
      UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewAction

      UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
      class  UIViewRoot
      UIViewRoot is the UIComponent that represents the root of the UIComponent tree.

    • Uses of StateHolder in javax.faces.component.behavior

      Classes in javax.faces.component.behavior that implement StateHolder
      Modifier and Type Class and Description
      class  AjaxBehavior

      An instance of this class is added as a ClientBehavior to a component using the ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior) contract that components implement.
      class  BehaviorBase

      BehaviorBase is a convenience base class that provides a default implementation of the Behavior contract.
      class  ClientBehaviorBase

      ClientBehaviorBase is a convenience base class that implements the default concrete behavior of all methods defined by ClientBehavior.

    • Uses of StateHolder in javax.faces.component.html

      Classes in javax.faces.component.html that implement StateHolder
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlColumn
      Represents a column that will be rendered in an HTML table element.
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlDoctype
      NONE
      class  HtmlForm
      Represents an HTML form element.
      class  HtmlGraphicImage
      Represents an HTML img element, used to retrieve and render a graphical image.
      class  HtmlHead
      NONE
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlMessage
      By default, the rendererType property must be set to "javax.faces.Message".
      class  HtmlMessages
      By default, the rendererType property must be set to "javax.faces.Messages".
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputFormat
      Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlOutputText
      Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
      class  HtmlPanelGrid
      Renders child components in a table, starting a new row after the specified number of columns.
      class  HtmlPanelGroup
      Causes all child components of this component to be rendered.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.

    • Uses of StateHolder in javax.faces.convert

      Classes in javax.faces.convert that implement StateHolder
      Modifier and Type Class and Description
      class  DateTimeConverter
      Converter implementation for java.util.Date values.
      class  EnumConverter
      Converter implementation for java.lang.Enum (and enum primitive) values.
      class  NumberConverter
      Converter implementation for java.lang.Number values.

    • Uses of StateHolder in javax.faces.event

      Classes in javax.faces.event that implement StateHolder
      Modifier and Type Class and Description
      class  MethodExpressionActionListener
      MethodExpressionActionListener is an ActionListener that wraps a MethodExpression.
      class  MethodExpressionValueChangeListener
      MethodExpressionValueChangeListener is a ValueChangeListener that wraps a MethodExpression.

    • Uses of StateHolder in javax.faces.validator

      Classes in javax.faces.validator that implement StateHolder
      Modifier and Type Class and Description
      class  BeanValidator

      A Validator that delegates validation of the bean property to the Bean Validation API.
      class  DoubleRangeValidator
      DoubleRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
      class  LengthValidator
      LengthValidator is a Validator that checks the number of characters in the String representation of the value of the associated component.
      class  LongRangeValidator
      LongRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
      class  MethodExpressionValidator
      MethodExpressionValidator is a Validator that wraps a MethodExpression, and it performs validation by executing a method on an object identified by the MethodExpression.
      class  RegexValidator

      A Validator that checks against a Regular Expression (which is the pattern property).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.TransientStateHelper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.TransientStateHelper

  • Packages that use TransientStateHelper
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.

    • Uses of TransientStateHelper in javax.faces.component

      Methods in javax.faces.component that return TransientStateHelper
      Modifier and Type Method and Description
      TransientStateHelper UIComponent.getTransientStateHelper()

      Return the TransientStateHelper instance for this UIComponent instance.
      TransientStateHelper UIComponent.getTransientStateHelper(boolean create)

      Return the TransientStateHelper instance for this UIComponent instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.TransientStateHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.TransientStateHolder

  • Packages that use TransientStateHolder
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of TransientStateHolder in javax.faces.component

      Subinterfaces of TransientStateHolder in javax.faces.component
      Modifier and Type Interface and Description
      interface  TransientStateHelper

      Define a Map-like contract that makes it easier for components to implement TransientStateHolder.
      Classes in javax.faces.component that implement TransientStateHolder
      Modifier and Type Class and Description
      class  UIColumn
      UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
      class  UICommand
      UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
      class  UIComponent
      UIComponent is the base class for all user interface components in JavaServer Faces.
      class  UIComponentBase
      UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
      class  UIData
      UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
      class  UIForm
      UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
      class  UIGraphic
      UIGraphic is a UIComponent that displays a graphical image to the user.
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UIMessage
      This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.
      class  UIMessages
      The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
      class  UINamingContainer
      UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
      class  UIOutcomeTarget

      This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
      class  UIOutput
      UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
      class  UIPanel
      UIPanel is a UIComponent that manages the layout of its child components.
      class  UIParameter
      UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectItem
      UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.
      class  UISelectItems
      UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewAction

      UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
      class  UIViewRoot
      UIViewRoot is the UIComponent that represents the root of the UIComponent tree.

    • Uses of TransientStateHolder in javax.faces.component.html

      Classes in javax.faces.component.html that implement TransientStateHolder
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlColumn
      Represents a column that will be rendered in an HTML table element.
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlDoctype
      NONE
      class  HtmlForm
      Represents an HTML form element.
      class  HtmlGraphicImage
      Represents an HTML img element, used to retrieve and render a graphical image.
      class  HtmlHead
      NONE
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlMessage
      By default, the rendererType property must be set to "javax.faces.Message".
      class  HtmlMessages
      By default, the rendererType property must be set to "javax.faces.Messages".
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputFormat
      Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlOutputText
      Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
      class  HtmlPanelGrid
      Renders child components in a table, starting a new row after the specified number of columns.
      class  HtmlPanelGroup
      Causes all child components of this component to be rendered.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.UniqueIdVendor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.UniqueIdVendor

  • Packages that use UniqueIdVendor
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of UniqueIdVendor in javax.faces.component

      Classes in javax.faces.component that implement UniqueIdVendor
      Modifier and Type Class and Description
      class  UIData
      UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
      class  UIForm
      UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
      class  UINamingContainer
      UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
      class  UIViewRoot
      UIViewRoot is the UIComponent that represents the root of the UIComponent tree.

    • Uses of UniqueIdVendor in javax.faces.component.html

      Classes in javax.faces.component.html that implement UniqueIdVendor
      Modifier and Type Class and Description
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlForm
      Represents an HTML form element.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.ValueHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.ValueHolder

  • Packages that use ValueHolder
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of ValueHolder in javax.faces.component

      Subinterfaces of ValueHolder in javax.faces.component
      Modifier and Type Interface and Description
      interface  EditableValueHolder
      EditableValueHolder is an extension of ValueHolder that describes additional features supported by editable components, including ValueChangeEvents and Validators.
      Classes in javax.faces.component that implement ValueHolder
      Modifier and Type Class and Description
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UIOutcomeTarget

      This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
      class  UIOutput
      UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.

    • Uses of ValueHolder in javax.faces.component.html

      Classes in javax.faces.component.html that implement ValueHolder
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlDoctype
      NONE
      class  HtmlHead
      NONE
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputFormat
      Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlOutputText
      Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


HtmlBody (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlBody

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.html.HtmlBody
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlBody
extends UIOutput
implements ClientBehaviorHolder
    NONE

    By default, the rendererType property must be set to "javax.faces.Body". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlBody.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIOutput

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlBody()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLang()
      Return the value of the lang property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnload()
      Return the value of the onload property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnunload()
      Return the value of the onunload property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTitle()
      Return the value of the title property.
      String getXmlns()
      Return the value of the xmlns property.
      void setDir(String dir)
      Set the value of the dir property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnload(String onload)
      Set the value of the onload property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnunload(String onunload)
      Set the value of the onunload property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTitle(String title)
      Set the value of the title property.
      void setXmlns(String xmlns)
      Set the value of the xmlns property.

      • Methods inherited from class javax.faces.component.UIOutput

        clearInitialState, getConverter, getFamily, getLocalValue, getValue, markInitialState, resetValue, restoreState, saveState, setConverter, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlBody

        public HtmlBody()

    • Method Detail

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnload

        public String getOnload()

        Return the value of the onload property.

      • setOnload

        public void setOnload(String onload)

        Set the value of the onload property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnunload

        public String getOnunload()

        Return the value of the onunload property.

      • setOnunload

        public void setOnunload(String onunload)

        Set the value of the onunload property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getXmlns

        public String getXmlns()

        Return the value of the xmlns property.

        Contents:

        An XML Namespace to be passed through to the rendered element

      • setXmlns

        public void setXmlns(String xmlns)

        Set the value of the xmlns property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlBody.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlBody.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlBody.PropertyKeys>
      • javax.faces.component.html.HtmlBody.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlBody.PropertyKeys>
    Enclosing class:
    HtmlBody

    protected static enum HtmlBody.PropertyKeys
extends Enum<HtmlBody.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      dir
      lang
      onclick
      ondblclick
      onkeydown
      onkeypress
      onkeyup
      onload
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onunload
      role
      style
      styleClass
      title
      xmlns

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlBody.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlBody.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • dir

        public static final HtmlBody.PropertyKeys dir

      • lang

        public static final HtmlBody.PropertyKeys lang

      • onclick

        public static final HtmlBody.PropertyKeys onclick

      • ondblclick

        public static final HtmlBody.PropertyKeys ondblclick

      • onkeydown

        public static final HtmlBody.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlBody.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlBody.PropertyKeys onkeyup

      • onload

        public static final HtmlBody.PropertyKeys onload

      • onmousedown

        public static final HtmlBody.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlBody.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlBody.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlBody.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlBody.PropertyKeys onmouseup

      • onunload

        public static final HtmlBody.PropertyKeys onunload

      • role

        public static final HtmlBody.PropertyKeys role

      • style

        public static final HtmlBody.PropertyKeys style

      • styleClass

        public static final HtmlBody.PropertyKeys styleClass

      • title

        public static final HtmlBody.PropertyKeys title

      • xmlns

        public static final HtmlBody.PropertyKeys xmlns

    • Method Detail

      • values

        public static HtmlBody.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlBody.PropertyKeys c : HtmlBody.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlBody.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlBody.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlColumn (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlColumn

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIColumn
          • javax.faces.component.html.HtmlColumn
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlColumn
extends UIColumn

    Represents a column that will be rendered in an HTML table element.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlColumn.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIColumn

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlColumn()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFooterClass()
      Return the value of the footerClass property.
      String getHeaderClass()
      Return the value of the headerClass property.
      boolean isRowHeader()
      Return the value of the rowHeader property.
      void setFooterClass(String footerClass)
      Set the value of the footerClass property.
      void setHeaderClass(String headerClass)
      Set the value of the headerClass property.
      void setRowHeader(boolean rowHeader)
      Set the value of the rowHeader property.

      • Methods inherited from class javax.faces.component.UIColumn

        getFamily, getFooter, getHeader, setFooter, setHeader

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlColumn

        public HtmlColumn()

    • Method Detail

      • getFooterClass

        public String getFooterClass()

        Return the value of the footerClass property.

        Contents: Space-separated list of CSS style class(es) that will be applied to any footer generated for this column.

      • setFooterClass

        public void setFooterClass(String footerClass)

        Set the value of the footerClass property.

      • getHeaderClass

        public String getHeaderClass()

        Return the value of the headerClass property.

        Contents: Space-separated list of CSS style class(es) that will be applied to any header generated for this column.

      • setHeaderClass

        public void setHeaderClass(String headerClass)

        Set the value of the headerClass property.

      • isRowHeader

        public boolean isRowHeader()

        Return the value of the rowHeader property.

        Contents: Flag indicating that this column is a row header column and therefore cells in this column should be rendered with "th" instead of "td" and must have the 'scope="row"' attribute.

      • setRowHeader

        public void setRowHeader(boolean rowHeader)

        Set the value of the rowHeader property.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlColumn.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlColumn.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlColumn.PropertyKeys>
      • javax.faces.component.html.HtmlColumn.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlColumn.PropertyKeys>
    Enclosing class:
    HtmlColumn

    protected static enum HtmlColumn.PropertyKeys
extends Enum<HtmlColumn.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      footerClass
      headerClass
      rowHeader

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlColumn.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlColumn.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • footerClass

        public static final HtmlColumn.PropertyKeys footerClass

      • headerClass

        public static final HtmlColumn.PropertyKeys headerClass

      • rowHeader

        public static final HtmlColumn.PropertyKeys rowHeader

    • Method Detail

      • values

        public static HtmlColumn.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlColumn.PropertyKeys c : HtmlColumn.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlColumn.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlColumn.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlCommandButton (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlCommandButton

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UICommand
          • javax.faces.component.html.HtmlCommandButton
  • All Implemented Interfaces:
    EventListener, ActionSource, ActionSource2, ClientBehaviorHolder, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlCommandButton
extends UICommand
implements ClientBehaviorHolder

    Represents an HTML input element for a button of type submit or reset. The label text is specified by the component value.

    By default, the rendererType property must be set to "javax.faces.Button". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlCommandButton.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UICommand

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlCommandButton()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getAlt()
      Return the value of the alt property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getImage()
      Return the value of the image property.
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      String getType()
      Return the value of the type property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setAlt(String alt)
      Set the value of the alt property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setImage(String image)
      Set the value of the image property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.
      void setType(String type)
      Set the value of the type property.

      • Methods inherited from class javax.faces.component.UICommand

        addActionListener, broadcast, getAction, getActionExpression, getActionListener, getActionListeners, getFamily, getValue, isImmediate, queueEvent, removeActionListener, setAction, setActionExpression, setActionListener, setImmediate, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlCommandButton

        public HtmlCommandButton()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getAlt

        public String getAlt()

        Return the value of the alt property.

        Contents: Alternate textual description of the element rendered by this component.

      • setAlt

        public void setAlt(String alt)

        Set the value of the alt property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getImage

        public String getImage()

        Return the value of the image property.

        Contents:

        Absolute or relative URL of the image to be displayed for this button. If specified, this "input" element will be of type "image". Otherwise, it will be of the type specified by the "type" property with a label specified by the "value" property. Note that if the value of this attribute starts with "/", the rendered value for this attribute will be prefixed with the context-root for this application.

      • setImage

        public void setImage(String image)

        Set the value of the image property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getType

        public String getType()

        Return the value of the type property.

        Contents: Type of button to create. Valid values are "submit", "button", and "reset". If not specified, or not a valid value, the default value is "submit".

      • setType

        public void setType(String type)

        Set the value of the type property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlCommandButton.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlCommandButton.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlCommandButton.PropertyKeys>
      • javax.faces.component.html.HtmlCommandButton.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlCommandButton.PropertyKeys>
    Enclosing class:
    HtmlCommandButton

    protected static enum HtmlCommandButton.PropertyKeys
extends Enum<HtmlCommandButton.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      alt
      dir
      disabled
      image
      label
      lang
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      style
      styleClass
      tabindex
      title
      type

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlCommandButton.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlCommandButton.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlCommandButton.PropertyKeys accesskey

      • alt

        public static final HtmlCommandButton.PropertyKeys alt

      • dir

        public static final HtmlCommandButton.PropertyKeys dir

      • disabled

        public static final HtmlCommandButton.PropertyKeys disabled

      • image

        public static final HtmlCommandButton.PropertyKeys image

      • label

        public static final HtmlCommandButton.PropertyKeys label

      • lang

        public static final HtmlCommandButton.PropertyKeys lang

      • onblur

        public static final HtmlCommandButton.PropertyKeys onblur

      • onchange

        public static final HtmlCommandButton.PropertyKeys onchange

      • onclick

        public static final HtmlCommandButton.PropertyKeys onclick

      • ondblclick

        public static final HtmlCommandButton.PropertyKeys ondblclick

      • onfocus

        public static final HtmlCommandButton.PropertyKeys onfocus

      • onkeydown

        public static final HtmlCommandButton.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlCommandButton.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlCommandButton.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlCommandButton.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlCommandButton.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlCommandButton.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlCommandButton.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlCommandButton.PropertyKeys onmouseup

      • onselect

        public static final HtmlCommandButton.PropertyKeys onselect

      • readonly

        public static final HtmlCommandButton.PropertyKeys readonly

      • role

        public static final HtmlCommandButton.PropertyKeys role

      • style

        public static final HtmlCommandButton.PropertyKeys style

      • styleClass

        public static final HtmlCommandButton.PropertyKeys styleClass

      • tabindex

        public static final HtmlCommandButton.PropertyKeys tabindex

      • title

        public static final HtmlCommandButton.PropertyKeys title

      • type

        public static final HtmlCommandButton.PropertyKeys type

    • Method Detail

      • values

        public static HtmlCommandButton.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlCommandButton.PropertyKeys c : HtmlCommandButton.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlCommandButton.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlCommandButton.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlCommandLink (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlCommandLink

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UICommand
          • javax.faces.component.html.HtmlCommandLink
  • All Implemented Interfaces:
    EventListener, ActionSource, ActionSource2, ClientBehaviorHolder, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlCommandLink
extends UICommand
implements ClientBehaviorHolder

    Represents an HTML a element for a hyperlink that acts like a submit button. This component must be placed inside a form, and requires JavaScript to be enabled in the client.

    By default, the rendererType property must be set to "javax.faces.Link". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlCommandLink.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UICommand

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlCommandLink()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getCharset()
      Return the value of the charset property.
      String getCoords()
      Return the value of the coords property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getHreflang()
      Return the value of the hreflang property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getRel()
      Return the value of the rel property.
      String getRev()
      Return the value of the rev property.
      String getRole()
      Return the value of the role property.
      String getShape()
      Return the value of the shape property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTarget()
      Return the value of the target property.
      String getTitle()
      Return the value of the title property.
      String getType()
      Return the value of the type property.
      boolean isDisabled()
      Return the value of the disabled property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setCharset(String charset)
      Set the value of the charset property.
      void setCoords(String coords)
      Set the value of the coords property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setHreflang(String hreflang)
      Set the value of the hreflang property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setRel(String rel)
      Set the value of the rel property.
      void setRev(String rev)
      Set the value of the rev property.
      void setRole(String role)
      Set the value of the role property.
      void setShape(String shape)
      Set the value of the shape property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTarget(String target)
      Set the value of the target property.
      void setTitle(String title)
      Set the value of the title property.
      void setType(String type)
      Set the value of the type property.

      • Methods inherited from class javax.faces.component.UICommand

        addActionListener, broadcast, getAction, getActionExpression, getActionListener, getActionListeners, getFamily, getValue, isImmediate, queueEvent, removeActionListener, setAction, setActionExpression, setActionListener, setImmediate, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlCommandLink

        public HtmlCommandLink()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getCharset

        public String getCharset()

        Return the value of the charset property.

        Contents: The character encoding of the resource designated by this hyperlink.

      • setCharset

        public void setCharset(String charset)

        Set the value of the charset property.

      • getCoords

        public String getCoords()

        Return the value of the coords property.

        Contents: The position and shape of the hot spot on the screen (for use in client-side image maps).

      • setCoords

        public void setCoords(String coords)

        Set the value of the coords property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit.

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getHreflang

        public String getHreflang()

        Return the value of the hreflang property.

        Contents: The language code of the resource designated by this hyperlink.

      • setHreflang

        public void setHreflang(String hreflang)

        Set the value of the hreflang property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getRel

        public String getRel()

        Return the value of the rel property.

        Contents: The relationship from the current document to the anchor specified by this hyperlink. The value of this attribute is a space-separated list of link types.

      • setRel

        public void setRel(String rel)

        Set the value of the rel property.

      • getRev

        public String getRev()

        Return the value of the rev property.

        Contents: A reverse link from the anchor specified by this hyperlink to the current document. The value of this attribute is a space-separated list of link types.

      • setRev

        public void setRev(String rev)

        Set the value of the rev property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getShape

        public String getShape()

        Return the value of the shape property.

        Contents: The shape of the hot spot on the screen (for use in client-side image maps). Valid values are: default (entire region); rect (rectangular region); circle (circular region); and poly (polygonal region).

      • setShape

        public void setShape(String shape)

        Set the value of the shape property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTarget

        public String getTarget()

        Return the value of the target property.

        Contents: Name of a frame where the resource retrieved via this hyperlink is to be displayed.

      • setTarget

        public void setTarget(String target)

        Set the value of the target property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getType

        public String getType()

        Return the value of the type property.

        Contents: The content type of the resource designated by this hyperlink.

      • setType

        public void setType(String type)

        Set the value of the type property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlCommandLink.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlCommandLink.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlCommandLink.PropertyKeys>
      • javax.faces.component.html.HtmlCommandLink.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlCommandLink.PropertyKeys>
    Enclosing class:
    HtmlCommandLink

    protected static enum HtmlCommandLink.PropertyKeys
extends Enum<HtmlCommandLink.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      charset
      coords
      dir
      disabled
      hreflang
      lang
      onblur
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      rel
      rev
      role
      shape
      style
      styleClass
      tabindex
      target
      title
      type

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlCommandLink.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlCommandLink.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlCommandLink.PropertyKeys accesskey

      • charset

        public static final HtmlCommandLink.PropertyKeys charset

      • coords

        public static final HtmlCommandLink.PropertyKeys coords

      • dir

        public static final HtmlCommandLink.PropertyKeys dir

      • disabled

        public static final HtmlCommandLink.PropertyKeys disabled

      • hreflang

        public static final HtmlCommandLink.PropertyKeys hreflang

      • lang

        public static final HtmlCommandLink.PropertyKeys lang

      • onblur

        public static final HtmlCommandLink.PropertyKeys onblur

      • onclick

        public static final HtmlCommandLink.PropertyKeys onclick

      • ondblclick

        public static final HtmlCommandLink.PropertyKeys ondblclick

      • onfocus

        public static final HtmlCommandLink.PropertyKeys onfocus

      • onkeydown

        public static final HtmlCommandLink.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlCommandLink.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlCommandLink.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlCommandLink.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlCommandLink.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlCommandLink.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlCommandLink.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlCommandLink.PropertyKeys onmouseup

      • rel

        public static final HtmlCommandLink.PropertyKeys rel

      • rev

        public static final HtmlCommandLink.PropertyKeys rev

      • role

        public static final HtmlCommandLink.PropertyKeys role

      • shape

        public static final HtmlCommandLink.PropertyKeys shape

      • style

        public static final HtmlCommandLink.PropertyKeys style

      • styleClass

        public static final HtmlCommandLink.PropertyKeys styleClass

      • tabindex

        public static final HtmlCommandLink.PropertyKeys tabindex

      • target

        public static final HtmlCommandLink.PropertyKeys target

      • title

        public static final HtmlCommandLink.PropertyKeys title

      • type

        public static final HtmlCommandLink.PropertyKeys type

    • Method Detail

      • values

        public static HtmlCommandLink.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlCommandLink.PropertyKeys c : HtmlCommandLink.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlCommandLink.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlCommandLink.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlDataTable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlDataTable

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIData
          • javax.faces.component.html.HtmlDataTable
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, NamingContainer, PartialStateHolder, StateHolder, TransientStateHolder, UniqueIdVendor, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlDataTable
extends UIData
implements ClientBehaviorHolder

    Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.

    By default, the rendererType property must be set to "javax.faces.Table". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlDataTable.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIData

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

      • Fields inherited from interface javax.faces.component.NamingContainer

        SEPARATOR_CHAR

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlDataTable()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getBgcolor()
      Return the value of the bgcolor property.
      String getBodyrows()
      Return the value of the bodyrows property.
      int getBorder()
      Return the value of the border property.
      String getCaptionClass()
      Return the value of the captionClass property.
      String getCaptionStyle()
      Return the value of the captionStyle property.
      String getCellpadding()
      Return the value of the cellpadding property.
      String getCellspacing()
      Return the value of the cellspacing property.
      String getColumnClasses()
      Return the value of the columnClasses property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getFooterClass()
      Return the value of the footerClass property.
      String getFrame()
      Return the value of the frame property.
      String getHeaderClass()
      Return the value of the headerClass property.
      String getLang()
      Return the value of the lang property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getRole()
      Return the value of the role property.
      String getRowClasses()
      Return the value of the rowClasses property.
      String getRules()
      Return the value of the rules property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getSummary()
      Return the value of the summary property.
      String getTitle()
      Return the value of the title property.
      String getWidth()
      Return the value of the width property.
      void setBgcolor(String bgcolor)
      Set the value of the bgcolor property.
      void setBodyrows(String bodyrows)
      Set the value of the bodyrows property.
      void setBorder(int border)
      Set the value of the border property.
      void setCaptionClass(String captionClass)
      Set the value of the captionClass property.
      void setCaptionStyle(String captionStyle)
      Set the value of the captionStyle property.
      void setCellpadding(String cellpadding)
      Set the value of the cellpadding property.
      void setCellspacing(String cellspacing)
      Set the value of the cellspacing property.
      void setColumnClasses(String columnClasses)
      Set the value of the columnClasses property.
      void setDir(String dir)
      Set the value of the dir property.
      void setFooterClass(String footerClass)
      Set the value of the footerClass property.
      void setFrame(String frame)
      Set the value of the frame property.
      void setHeaderClass(String headerClass)
      Set the value of the headerClass property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setRole(String role)
      Set the value of the role property.
      void setRowClasses(String rowClasses)
      Set the value of the rowClasses property.
      void setRules(String rules)
      Set the value of the rules property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setSummary(String summary)
      Set the value of the summary property.
      void setTitle(String title)
      Set the value of the title property.
      void setWidth(String width)
      Set the value of the width property.

      • Methods inherited from class javax.faces.component.UIData

        broadcast, createUniqueId, encodeBegin, getClientId, getDataModel, getFamily, getFirst, getFooter, getHeader, getRowCount, getRowData, getRowIndex, getRows, getValue, getVar, invokeOnComponent, isRowAvailable, isRowStatePreserved, markInitialState, processDecodes, processUpdates, processValidators, queueEvent, restoreState, saveState, setDataModel, setFirst, setFooter, setHeader, setRowIndex, setRows, setRowStatePreserved, setValue, setValueBinding, setValueExpression, setVar, visitTree

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, clearInitialState, decode, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, isRendered, isTransient, processRestoreState, processSaveState, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlDataTable

        public HtmlDataTable()

    • Method Detail

      • getBgcolor

        public String getBgcolor()

        Return the value of the bgcolor property.

        Contents: Name or code of the background color for this table.

      • setBgcolor

        public void setBgcolor(String bgcolor)

        Set the value of the bgcolor property.

      • getBodyrows

        public String getBodyrows()

        Return the value of the bodyrows property.

        Contents: Comma separated list of row indices for which a new "tbody" element should be started (and any previously opened one should be ended).

      • setBodyrows

        public void setBodyrows(String bodyrows)

        Set the value of the bodyrows property.

      • getBorder

        public int getBorder()

        Return the value of the border property.

        Contents: Width (in pixels) of the border to be drawn around this table.

      • setBorder

        public void setBorder(int border)

        Set the value of the border property.

      • getCaptionClass

        public String getCaptionClass()

        Return the value of the captionClass property.

        Contents: Space-separated list of CSS style class(es) that will be applied to any caption generated for this table.

      • setCaptionClass

        public void setCaptionClass(String captionClass)

        Set the value of the captionClass property.

      • getCaptionStyle

        public String getCaptionStyle()

        Return the value of the captionStyle property.

        Contents: CSS style(s) to be applied when this caption is rendered.

      • setCaptionStyle

        public void setCaptionStyle(String captionStyle)

        Set the value of the captionStyle property.

      • getCellpadding

        public String getCellpadding()

        Return the value of the cellpadding property.

        Contents: Definition of how much space the user agent should leave between the border of each cell and its contents.

      • setCellpadding

        public void setCellpadding(String cellpadding)

        Set the value of the cellpadding property.

      • getCellspacing

        public String getCellspacing()

        Return the value of the cellspacing property.

        Contents: Definition of how much space the user agent should leave between the left side of the table and the leftmost column, the top of the table and the top of the top side of the topmost row, and so on for the right and bottom of the table. It also specifies the amount of space to leave between cells.

      • setCellspacing

        public void setCellspacing(String cellspacing)

        Set the value of the cellspacing property.

      • getColumnClasses

        public String getColumnClasses()

        Return the value of the columnClasses property.

        Contents: Comma-delimited list of CSS style classes that will be applied to the columns of this table. A space separated list of classes may also be specified for any individual column. If the number of elements in this list is less than the number of actual column children of the UIData, no "class" attribute is output for each column greater than the number of elements in the list. If the number of elements in the list is greater than the number of actual column children of the UIData, the elements at the posisiton in the list after the last column are ignored.

      • setColumnClasses

        public void setColumnClasses(String columnClasses)

        Set the value of the columnClasses property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • getFooterClass

        public String getFooterClass()

        Return the value of the footerClass property.

        Contents: Space-separated list of CSS style class(es) that will be applied to any footer generated for this table.

      • setFooterClass

        public void setFooterClass(String footerClass)

        Set the value of the footerClass property.

      • getFrame

        public String getFrame()

        Return the value of the frame property.

        Contents: Code specifying which sides of the frame surrounding this table will be visible. Valid values are: none (no sides, default value); above (top side only); below (bottom side only); hsides (top and bottom sides only); vsides (right and left sides only); lhs (left hand side only); rhs (right hand side only); box (all four sides); and border (all four sides).

      • setFrame

        public void setFrame(String frame)

        Set the value of the frame property.

      • getHeaderClass

        public String getHeaderClass()

        Return the value of the headerClass property.

        Contents: Space-separated list of CSS style class(es) that will be applied to any header generated for this table.

      • setHeaderClass

        public void setHeaderClass(String headerClass)

        Set the value of the headerClass property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getRowClasses

        public String getRowClasses()

        Return the value of the rowClasses property.

        Contents: Comma-delimited list of CSS style classes that will be applied to the rows of this table. A space separated list of classes may also be specified for any individual row. Thes styles are applied, in turn, to each row in the table. For example, if the list has two elements, the first style class in the list is applied to the first row, the second to the second row, the first to the third row, the second to the fourth row, etc. In other words, we keep iterating through the list until we reach the end, and then we start at the beginning again.

      • setRowClasses

        public void setRowClasses(String rowClasses)

        Set the value of the rowClasses property.

      • getRules

        public String getRules()

        Return the value of the rules property.

        Contents: Code specifying which rules will appear between cells within this table. Valid values are: none (no rules, default value); groups (between row groups); rows (between rows only); cols (between columns only); and all (between all rows and columns).

      • setRules

        public void setRules(String rules)

        Set the value of the rules property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getSummary

        public String getSummary()

        Return the value of the summary property.

        Contents: Summary of this table's purpose and structure, for user agents rendering to non-visual media such as speech and Braille.

      • setSummary

        public void setSummary(String summary)

        Set the value of the summary property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getWidth

        public String getWidth()

        Return the value of the width property.

        Contents: Width of the entire table, for visual user agents.

      • setWidth

        public void setWidth(String width)

        Set the value of the width property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlDataTable.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlDataTable.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlDataTable.PropertyKeys>
      • javax.faces.component.html.HtmlDataTable.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlDataTable.PropertyKeys>
    Enclosing class:
    HtmlDataTable

    protected static enum HtmlDataTable.PropertyKeys
extends Enum<HtmlDataTable.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      bgcolor
      bodyrows
      border
      captionClass
      captionStyle
      cellpadding
      cellspacing
      columnClasses
      dir
      footerClass
      frame
      headerClass
      lang
      onclick
      ondblclick
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      role
      rowClasses
      rules
      style
      styleClass
      summary
      title
      width

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlDataTable.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlDataTable.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • bgcolor

        public static final HtmlDataTable.PropertyKeys bgcolor

      • bodyrows

        public static final HtmlDataTable.PropertyKeys bodyrows

      • border

        public static final HtmlDataTable.PropertyKeys border

      • captionClass

        public static final HtmlDataTable.PropertyKeys captionClass

      • captionStyle

        public static final HtmlDataTable.PropertyKeys captionStyle

      • cellpadding

        public static final HtmlDataTable.PropertyKeys cellpadding

      • cellspacing

        public static final HtmlDataTable.PropertyKeys cellspacing

      • columnClasses

        public static final HtmlDataTable.PropertyKeys columnClasses

      • dir

        public static final HtmlDataTable.PropertyKeys dir

      • footerClass

        public static final HtmlDataTable.PropertyKeys footerClass

      • frame

        public static final HtmlDataTable.PropertyKeys frame

      • headerClass

        public static final HtmlDataTable.PropertyKeys headerClass

      • lang

        public static final HtmlDataTable.PropertyKeys lang

      • onclick

        public static final HtmlDataTable.PropertyKeys onclick

      • ondblclick

        public static final HtmlDataTable.PropertyKeys ondblclick

      • onkeydown

        public static final HtmlDataTable.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlDataTable.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlDataTable.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlDataTable.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlDataTable.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlDataTable.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlDataTable.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlDataTable.PropertyKeys onmouseup

      • role

        public static final HtmlDataTable.PropertyKeys role

      • rowClasses

        public static final HtmlDataTable.PropertyKeys rowClasses

      • rules

        public static final HtmlDataTable.PropertyKeys rules

      • style

        public static final HtmlDataTable.PropertyKeys style

      • styleClass

        public static final HtmlDataTable.PropertyKeys styleClass

      • summary

        public static final HtmlDataTable.PropertyKeys summary

      • title

        public static final HtmlDataTable.PropertyKeys title

      • width

        public static final HtmlDataTable.PropertyKeys width

    • Method Detail

      • values

        public static HtmlDataTable.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlDataTable.PropertyKeys c : HtmlDataTable.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlDataTable.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlDataTable.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlDoctype (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlDoctype

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.html.HtmlDoctype
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlDoctype
extends UIOutput
    NONE

    By default, the rendererType property must be set to "javax.faces.Doctype". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlDoctype.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIOutput

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlDoctype()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getPublic()
      Return the value of the public property.
      String getRootElement()
      Return the value of the rootElement property.
      String getSystem()
      Return the value of the system property.
      void setPublic(String _public)
      Set the value of the public property.
      void setRootElement(String rootElement)
      Set the value of the rootElement property.
      void setSystem(String system)
      Set the value of the system property.

      • Methods inherited from class javax.faces.component.UIOutput

        clearInitialState, getConverter, getFamily, getLocalValue, getValue, markInitialState, resetValue, restoreState, saveState, setConverter, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlDoctype

        public HtmlDoctype()

    • Method Detail

      • getPublic

        public String getPublic()

        Return the value of the public property.

        Contents:

        Will be output as the public part of the DOCTYPE

      • setPublic

        public void setPublic(String _public)

        Set the value of the public property.

      • getRootElement

        public String getRootElement()

        Return the value of the rootElement property.

        Contents:

        The root XML element

      • setRootElement

        public void setRootElement(String rootElement)

        Set the value of the rootElement property.

      • getSystem

        public String getSystem()

        Return the value of the system property.

        Contents:

        Will be output as the system part of the DOCTYPE

      • setSystem

        public void setSystem(String system)

        Set the value of the system property.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlDoctype.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlDoctype.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlDoctype.PropertyKeys>
      • javax.faces.component.html.HtmlDoctype.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlDoctype.PropertyKeys>
    Enclosing class:
    HtmlDoctype

    protected static enum HtmlDoctype.PropertyKeys
extends Enum<HtmlDoctype.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      publicVal
      rootElement
      system

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlDoctype.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlDoctype.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • publicVal

        public static final HtmlDoctype.PropertyKeys publicVal

      • rootElement

        public static final HtmlDoctype.PropertyKeys rootElement

      • system

        public static final HtmlDoctype.PropertyKeys system

    • Method Detail

      • values

        public static HtmlDoctype.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlDoctype.PropertyKeys c : HtmlDoctype.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlDoctype.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlDoctype.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlForm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlForm

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIForm
          • javax.faces.component.html.HtmlForm
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, NamingContainer, PartialStateHolder, StateHolder, TransientStateHolder, UniqueIdVendor, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlForm
extends UIForm
implements ClientBehaviorHolder

    Represents an HTML form element. Child input components will be submitted unless they have been disabled.

    By default, the rendererType property must be set to "javax.faces.Form". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlForm.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIForm

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

      • Fields inherited from interface javax.faces.component.NamingContainer

        SEPARATOR_CHAR

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlForm()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccept()
      Return the value of the accept property.
      String getAcceptcharset()
      Return the value of the acceptcharset property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      String getEnctype()
      Return the value of the enctype property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLang()
      Return the value of the lang property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnreset()
      Return the value of the onreset property.
      String getOnsubmit()
      Return the value of the onsubmit property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTarget()
      Return the value of the target property.
      String getTitle()
      Return the value of the title property.
      void setAccept(String accept)
      Set the value of the accept property.
      void setAcceptcharset(String acceptcharset)
      Set the value of the acceptcharset property.
      void setDir(String dir)
      Set the value of the dir property.
      void setEnctype(String enctype)
      Set the value of the enctype property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnreset(String onreset)
      Set the value of the onreset property.
      void setOnsubmit(String onsubmit)
      Set the value of the onsubmit property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTarget(String target)
      Set the value of the target property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UIForm

        createUniqueId, getContainerClientId, getFamily, isPrependId, isSubmitted, processDecodes, processUpdates, processValidators, setPrependId, setSubmitted, visitTree

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlForm

        public HtmlForm()

    • Method Detail

      • getAccept

        public String getAccept()

        Return the value of the accept property.

        Contents: List of content types that a server processing this form will handle correctly

      • setAccept

        public void setAccept(String accept)

        Set the value of the accept property.

      • getAcceptcharset

        public String getAcceptcharset()

        Return the value of the acceptcharset property.

        Contents: List of character encodings for input data that are accepted by the server processing this form.

      • setAcceptcharset

        public void setAcceptcharset(String acceptcharset)

        Set the value of the acceptcharset property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • getEnctype

        public String getEnctype()

        Return the value of the enctype property.

        Contents: Content type used to submit the form to the server. If not specified, the default value is "application/x-www-form-urlencoded".

      • setEnctype

        public void setEnctype(String enctype)

        Set the value of the enctype property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnreset

        public String getOnreset()

        Return the value of the onreset property.

        Contents: Javascript code executed when this form is reset.

      • setOnreset

        public void setOnreset(String onreset)

        Set the value of the onreset property.

      • getOnsubmit

        public String getOnsubmit()

        Return the value of the onsubmit property.

        Contents: Javascript code executed when this form is submitted.

      • setOnsubmit

        public void setOnsubmit(String onsubmit)

        Set the value of the onsubmit property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTarget

        public String getTarget()

        Return the value of the target property.

        Contents: Name of a frame where the response retrieved after this form submit is to be displayed.

      • setTarget

        public void setTarget(String target)

        Set the value of the target property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlForm.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlForm.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlForm.PropertyKeys>
      • javax.faces.component.html.HtmlForm.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlForm.PropertyKeys>
    Enclosing class:
    HtmlForm

    protected static enum HtmlForm.PropertyKeys
extends Enum<HtmlForm.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accept
      acceptcharset
      dir
      enctype
      lang
      onclick
      ondblclick
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onreset
      onsubmit
      role
      style
      styleClass
      target
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlForm.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlForm.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accept

        public static final HtmlForm.PropertyKeys accept

      • acceptcharset

        public static final HtmlForm.PropertyKeys acceptcharset

      • dir

        public static final HtmlForm.PropertyKeys dir

      • enctype

        public static final HtmlForm.PropertyKeys enctype

      • lang

        public static final HtmlForm.PropertyKeys lang

      • onclick

        public static final HtmlForm.PropertyKeys onclick

      • ondblclick

        public static final HtmlForm.PropertyKeys ondblclick

      • onkeydown

        public static final HtmlForm.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlForm.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlForm.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlForm.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlForm.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlForm.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlForm.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlForm.PropertyKeys onmouseup

      • onreset

        public static final HtmlForm.PropertyKeys onreset

      • onsubmit

        public static final HtmlForm.PropertyKeys onsubmit

      • role

        public static final HtmlForm.PropertyKeys role

      • style

        public static final HtmlForm.PropertyKeys style

      • styleClass

        public static final HtmlForm.PropertyKeys styleClass

      • target

        public static final HtmlForm.PropertyKeys target

      • title

        public static final HtmlForm.PropertyKeys title

    • Method Detail

      • values

        public static HtmlForm.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlForm.PropertyKeys c : HtmlForm.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlForm.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlForm.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlGraphicImage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlGraphicImage

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIGraphic
          • javax.faces.component.html.HtmlGraphicImage
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlGraphicImage
extends UIGraphic
implements ClientBehaviorHolder

    Represents an HTML img element, used to retrieve and render a graphical image.

    By default, the rendererType property must be set to "javax.faces.Image". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlGraphicImage.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIGraphic

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlGraphicImage()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAlt()
      Return the value of the alt property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getHeight()
      Return the value of the height property.
      String getLang()
      Return the value of the lang property.
      String getLongdesc()
      Return the value of the longdesc property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTitle()
      Return the value of the title property.
      String getUsemap()
      Return the value of the usemap property.
      String getWidth()
      Return the value of the width property.
      boolean isIsmap()
      Return the value of the ismap property.
      void setAlt(String alt)
      Set the value of the alt property.
      void setDir(String dir)
      Set the value of the dir property.
      void setHeight(String height)
      Set the value of the height property.
      void setIsmap(boolean ismap)
      Set the value of the ismap property.
      void setLang(String lang)
      Set the value of the lang property.
      void setLongdesc(String longdesc)
      Set the value of the longdesc property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTitle(String title)
      Set the value of the title property.
      void setUsemap(String usemap)
      Set the value of the usemap property.
      void setWidth(String width)
      Set the value of the width property.

      • Methods inherited from class javax.faces.component.UIGraphic

        getFamily, getUrl, getValue, getValueBinding, getValueExpression, setUrl, setValue, setValueBinding, setValueExpression

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlGraphicImage

        public HtmlGraphicImage()

    • Method Detail

      • getAlt

        public String getAlt()

        Return the value of the alt property.

        Contents: Alternate textual description of the element rendered by this component.

      • setAlt

        public void setAlt(String alt)

        Set the value of the alt property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • getHeight

        public String getHeight()

        Return the value of the height property.

        Contents: Override for the height of this image.

      • setHeight

        public void setHeight(String height)

        Set the value of the height property.

      • isIsmap

        public boolean isIsmap()

        Return the value of the ismap property.

        Contents: Flag indicating that this image is to be used as a server side image map. Such an image must be enclosed within a hyperlink ("a"). A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as ismap="ismap".

      • setIsmap

        public void setIsmap(boolean ismap)

        Set the value of the ismap property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getLongdesc

        public String getLongdesc()

        Return the value of the longdesc property.

        Contents: URI to a long description of the image represented by this element.

      • setLongdesc

        public void setLongdesc(String longdesc)

        Set the value of the longdesc property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getUsemap

        public String getUsemap()

        Return the value of the usemap property.

        Contents: The name of a client side image map (an HTML "map" element) for which this element provides the image.

      • setUsemap

        public void setUsemap(String usemap)

        Set the value of the usemap property.

      • getWidth

        public String getWidth()

        Return the value of the width property.

        Contents: Override for the width of this image.

      • setWidth

        public void setWidth(String width)

        Set the value of the width property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlGraphicImage.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlGraphicImage.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlGraphicImage.PropertyKeys>
      • javax.faces.component.html.HtmlGraphicImage.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlGraphicImage.PropertyKeys>
    Enclosing class:
    HtmlGraphicImage

    protected static enum HtmlGraphicImage.PropertyKeys
extends Enum<HtmlGraphicImage.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      alt
      dir
      height
      ismap
      lang
      longdesc
      onclick
      ondblclick
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      role
      style
      styleClass
      title
      usemap
      width

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlGraphicImage.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlGraphicImage.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • alt

        public static final HtmlGraphicImage.PropertyKeys alt

      • dir

        public static final HtmlGraphicImage.PropertyKeys dir

      • height

        public static final HtmlGraphicImage.PropertyKeys height

      • ismap

        public static final HtmlGraphicImage.PropertyKeys ismap

      • lang

        public static final HtmlGraphicImage.PropertyKeys lang

      • longdesc

        public static final HtmlGraphicImage.PropertyKeys longdesc

      • onclick

        public static final HtmlGraphicImage.PropertyKeys onclick

      • ondblclick

        public static final HtmlGraphicImage.PropertyKeys ondblclick

      • onkeydown

        public static final HtmlGraphicImage.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlGraphicImage.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlGraphicImage.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlGraphicImage.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlGraphicImage.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlGraphicImage.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlGraphicImage.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlGraphicImage.PropertyKeys onmouseup

      • role

        public static final HtmlGraphicImage.PropertyKeys role

      • style

        public static final HtmlGraphicImage.PropertyKeys style

      • styleClass

        public static final HtmlGraphicImage.PropertyKeys styleClass

      • title

        public static final HtmlGraphicImage.PropertyKeys title

      • usemap

        public static final HtmlGraphicImage.PropertyKeys usemap

      • width

        public static final HtmlGraphicImage.PropertyKeys width

    • Method Detail

      • values

        public static HtmlGraphicImage.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlGraphicImage.PropertyKeys c : HtmlGraphicImage.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlGraphicImage.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlGraphicImage.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlHead (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlHead

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.html.HtmlHead
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlHead
extends UIOutput
    NONE

    By default, the rendererType property must be set to "javax.faces.Head". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlHead.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIOutput

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlHead()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDir()
      Return the value of the dir property.
      String getLang()
      Return the value of the lang property.
      String getXmlns()
      Return the value of the xmlns property.
      void setDir(String dir)
      Set the value of the dir property.
      void setLang(String lang)
      Set the value of the lang property.
      void setXmlns(String xmlns)
      Set the value of the xmlns property.

      • Methods inherited from class javax.faces.component.UIOutput

        clearInitialState, getConverter, getFamily, getLocalValue, getValue, markInitialState, resetValue, restoreState, saveState, setConverter, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlHead

        public HtmlHead()

    • Method Detail

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getXmlns

        public String getXmlns()

        Return the value of the xmlns property.

        Contents:

        An XML Namespace to be passed through to the rendered element

      • setXmlns

        public void setXmlns(String xmlns)

        Set the value of the xmlns property.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlHead.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlHead.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlHead.PropertyKeys>
      • javax.faces.component.html.HtmlHead.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlHead.PropertyKeys>
    Enclosing class:
    HtmlHead

    protected static enum HtmlHead.PropertyKeys
extends Enum<HtmlHead.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      dir
      lang
      xmlns

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlHead.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlHead.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • dir

        public static final HtmlHead.PropertyKeys dir

      • lang

        public static final HtmlHead.PropertyKeys lang

      • xmlns

        public static final HtmlHead.PropertyKeys xmlns

    • Method Detail

      • values

        public static HtmlHead.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlHead.PropertyKeys c : HtmlHead.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlHead.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlHead.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlInputFile (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlInputFile

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.html.HtmlInputFile
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlInputFile
extends UIInput
implements ClientBehaviorHolder

    Represents an HTML input element of type file.

    By default, the rendererType property must be set to "javax.faces.File". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlInputFile.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIInput

        COMPONENT_FAMILY, CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlInputFile()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getAlt()
      Return the value of the alt property.
      String getAutocomplete()
      Return the value of the autocomplete property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      int getMaxlength()
      Return the value of the maxlength property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      int getSize()
      Return the value of the size property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setAlt(String alt)
      Set the value of the alt property.
      void setAutocomplete(String autocomplete)
      Set the value of the autocomplete property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setMaxlength(int maxlength)
      Set the value of the maxlength property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setSize(int size)
      Set the value of the size property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getFamily, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlInputFile

        public HtmlInputFile()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getAlt

        public String getAlt()

        Return the value of the alt property.

        Contents: Alternate textual description of the element rendered by this component.

      • setAlt

        public void setAlt(String alt)

        Set the value of the alt property.

      • getAutocomplete

        public String getAutocomplete()

        Return the value of the autocomplete property.

        Contents: If the value of this attribute is "off", render "off" as the value of the attribute. This indicates that the browser should disable its autocomplete feature for this component. This is useful for components that perform autocompletion and do not want the browser interfering. If this attribute is not set or the value is "on", render nothing.

      • setAutocomplete

        public void setAutocomplete(String autocomplete)

        Set the value of the autocomplete property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getMaxlength

        public int getMaxlength()

        Return the value of the maxlength property.

        Contents: The maximum number of characters that may be entered in this field.

      • setMaxlength

        public void setMaxlength(int maxlength)

        Set the value of the maxlength property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getSize

        public int getSize()

        Return the value of the size property.

        Contents: The number of characters used to determine the width of this field.

      • setSize

        public void setSize(int size)

        Set the value of the size property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlInputFile.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlInputFile.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlInputFile.PropertyKeys>
      • javax.faces.component.html.HtmlInputFile.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlInputFile.PropertyKeys>
    Enclosing class:
    HtmlInputFile

    protected static enum HtmlInputFile.PropertyKeys
extends Enum<HtmlInputFile.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      alt
      autocomplete
      dir
      disabled
      label
      lang
      maxlength
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      size
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlInputFile.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlInputFile.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlInputFile.PropertyKeys accesskey

      • alt

        public static final HtmlInputFile.PropertyKeys alt

      • autocomplete

        public static final HtmlInputFile.PropertyKeys autocomplete

      • dir

        public static final HtmlInputFile.PropertyKeys dir

      • disabled

        public static final HtmlInputFile.PropertyKeys disabled

      • label

        public static final HtmlInputFile.PropertyKeys label

      • lang

        public static final HtmlInputFile.PropertyKeys lang

      • maxlength

        public static final HtmlInputFile.PropertyKeys maxlength

      • onblur

        public static final HtmlInputFile.PropertyKeys onblur

      • onchange

        public static final HtmlInputFile.PropertyKeys onchange

      • onclick

        public static final HtmlInputFile.PropertyKeys onclick

      • ondblclick

        public static final HtmlInputFile.PropertyKeys ondblclick

      • onfocus

        public static final HtmlInputFile.PropertyKeys onfocus

      • onkeydown

        public static final HtmlInputFile.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlInputFile.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlInputFile.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlInputFile.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlInputFile.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlInputFile.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlInputFile.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlInputFile.PropertyKeys onmouseup

      • onselect

        public static final HtmlInputFile.PropertyKeys onselect

      • readonly

        public static final HtmlInputFile.PropertyKeys readonly

      • role

        public static final HtmlInputFile.PropertyKeys role

      • size

        public static final HtmlInputFile.PropertyKeys size

      • style

        public static final HtmlInputFile.PropertyKeys style

      • styleClass

        public static final HtmlInputFile.PropertyKeys styleClass

      • tabindex

        public static final HtmlInputFile.PropertyKeys tabindex

      • title

        public static final HtmlInputFile.PropertyKeys title

    • Method Detail

      • values

        public static HtmlInputFile.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlInputFile.PropertyKeys c : HtmlInputFile.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlInputFile.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlInputFile.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlInputHidden (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlInputHidden

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.html.HtmlInputHidden
  • All Implemented Interfaces:
    EventListener, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlInputHidden
extends UIInput

    Represents an HTML input element of type hidden.

    By default, the rendererType property must be set to "javax.faces.Hidden". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlInputHidden.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIInput

        COMPONENT_FAMILY, CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlInputHidden()

    • Method Summary

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getFamily, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlInputHidden

        public HtmlInputHidden()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlInputHidden.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlInputHidden.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlInputHidden.PropertyKeys>
      • javax.faces.component.html.HtmlInputHidden.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlInputHidden.PropertyKeys>
    Enclosing class:
    HtmlInputHidden

    protected static enum HtmlInputHidden.PropertyKeys
extends Enum<HtmlInputHidden.PropertyKeys>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlInputHidden.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlInputHidden.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Method Detail

      • values

        public static HtmlInputHidden.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlInputHidden.PropertyKeys c : HtmlInputHidden.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlInputHidden.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlInputHidden.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlInputSecret (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlInputSecret

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.html.HtmlInputSecret
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlInputSecret
extends UIInput
implements ClientBehaviorHolder

    Represents an HTML input element of type password. On a redisplay, any previously entered value will not be rendered (for security reasons) unless the redisplay property is set to true.

    By default, the rendererType property must be set to "javax.faces.Secret". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlInputSecret.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIInput

        COMPONENT_FAMILY, CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlInputSecret()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getAlt()
      Return the value of the alt property.
      String getAutocomplete()
      Return the value of the autocomplete property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      int getMaxlength()
      Return the value of the maxlength property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      int getSize()
      Return the value of the size property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      boolean isRedisplay()
      Return the value of the redisplay property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setAlt(String alt)
      Set the value of the alt property.
      void setAutocomplete(String autocomplete)
      Set the value of the autocomplete property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setMaxlength(int maxlength)
      Set the value of the maxlength property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRedisplay(boolean redisplay)
      Set the value of the redisplay property.
      void setRole(String role)
      Set the value of the role property.
      void setSize(int size)
      Set the value of the size property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getFamily, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlInputSecret

        public HtmlInputSecret()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getAlt

        public String getAlt()

        Return the value of the alt property.

        Contents: Alternate textual description of the element rendered by this component.

      • setAlt

        public void setAlt(String alt)

        Set the value of the alt property.

      • getAutocomplete

        public String getAutocomplete()

        Return the value of the autocomplete property.

        Contents: If the value of this attribute is "off", render "off" as the value of the attribute. This indicates that the browser should disable its autocomplete feature for this component. This is useful for components that perform autocompletion and do not want the browser interfering. If this attribute is not set or the value is "on", render nothing.

      • setAutocomplete

        public void setAutocomplete(String autocomplete)

        Set the value of the autocomplete property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getMaxlength

        public int getMaxlength()

        Return the value of the maxlength property.

        Contents: The maximum number of characters that may be entered in this field.

      • setMaxlength

        public void setMaxlength(int maxlength)

        Set the value of the maxlength property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • isRedisplay

        public boolean isRedisplay()

        Return the value of the redisplay property.

        Contents: Flag indicating that any existing value in this field should be rendered when the form is created. Because this is a potential security risk, password values are not displayed by default.

      • setRedisplay

        public void setRedisplay(boolean redisplay)

        Set the value of the redisplay property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getSize

        public int getSize()

        Return the value of the size property.

        Contents: The number of characters used to determine the width of this field.

      • setSize

        public void setSize(int size)

        Set the value of the size property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlInputSecret.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlInputSecret.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlInputSecret.PropertyKeys>
      • javax.faces.component.html.HtmlInputSecret.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlInputSecret.PropertyKeys>
    Enclosing class:
    HtmlInputSecret

    protected static enum HtmlInputSecret.PropertyKeys
extends Enum<HtmlInputSecret.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      alt
      autocomplete
      dir
      disabled
      label
      lang
      maxlength
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      redisplay
      role
      size
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlInputSecret.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlInputSecret.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlInputSecret.PropertyKeys accesskey

      • alt

        public static final HtmlInputSecret.PropertyKeys alt

      • autocomplete

        public static final HtmlInputSecret.PropertyKeys autocomplete

      • dir

        public static final HtmlInputSecret.PropertyKeys dir

      • disabled

        public static final HtmlInputSecret.PropertyKeys disabled

      • label

        public static final HtmlInputSecret.PropertyKeys label

      • lang

        public static final HtmlInputSecret.PropertyKeys lang

      • maxlength

        public static final HtmlInputSecret.PropertyKeys maxlength

      • onblur

        public static final HtmlInputSecret.PropertyKeys onblur

      • onchange

        public static final HtmlInputSecret.PropertyKeys onchange

      • onclick

        public static final HtmlInputSecret.PropertyKeys onclick

      • ondblclick

        public static final HtmlInputSecret.PropertyKeys ondblclick

      • onfocus

        public static final HtmlInputSecret.PropertyKeys onfocus

      • onkeydown

        public static final HtmlInputSecret.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlInputSecret.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlInputSecret.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlInputSecret.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlInputSecret.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlInputSecret.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlInputSecret.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlInputSecret.PropertyKeys onmouseup

      • onselect

        public static final HtmlInputSecret.PropertyKeys onselect

      • readonly

        public static final HtmlInputSecret.PropertyKeys readonly

      • redisplay

        public static final HtmlInputSecret.PropertyKeys redisplay

      • role

        public static final HtmlInputSecret.PropertyKeys role

      • size

        public static final HtmlInputSecret.PropertyKeys size

      • style

        public static final HtmlInputSecret.PropertyKeys style

      • styleClass

        public static final HtmlInputSecret.PropertyKeys styleClass

      • tabindex

        public static final HtmlInputSecret.PropertyKeys tabindex

      • title

        public static final HtmlInputSecret.PropertyKeys title

    • Method Detail

      • values

        public static HtmlInputSecret.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlInputSecret.PropertyKeys c : HtmlInputSecret.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlInputSecret.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlInputSecret.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlInputText (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlInputText

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.html.HtmlInputText
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlInputText
extends UIInput
implements ClientBehaviorHolder

    Represents an HTML input element of type text.

    By default, the rendererType property must be set to "javax.faces.Text". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlInputText.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIInput

        COMPONENT_FAMILY, CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlInputText()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getAlt()
      Return the value of the alt property.
      String getAutocomplete()
      Return the value of the autocomplete property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      int getMaxlength()
      Return the value of the maxlength property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      int getSize()
      Return the value of the size property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setAlt(String alt)
      Set the value of the alt property.
      void setAutocomplete(String autocomplete)
      Set the value of the autocomplete property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setMaxlength(int maxlength)
      Set the value of the maxlength property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setSize(int size)
      Set the value of the size property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getFamily, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlInputText

        public HtmlInputText()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getAlt

        public String getAlt()

        Return the value of the alt property.

        Contents: Alternate textual description of the element rendered by this component.

      • setAlt

        public void setAlt(String alt)

        Set the value of the alt property.

      • getAutocomplete

        public String getAutocomplete()

        Return the value of the autocomplete property.

        Contents: If the value of this attribute is "off", render "off" as the value of the attribute. This indicates that the browser should disable its autocomplete feature for this component. This is useful for components that perform autocompletion and do not want the browser interfering. If this attribute is not set or the value is "on", render nothing.

      • setAutocomplete

        public void setAutocomplete(String autocomplete)

        Set the value of the autocomplete property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getMaxlength

        public int getMaxlength()

        Return the value of the maxlength property.

        Contents: The maximum number of characters that may be entered in this field.

      • setMaxlength

        public void setMaxlength(int maxlength)

        Set the value of the maxlength property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getSize

        public int getSize()

        Return the value of the size property.

        Contents: The number of characters used to determine the width of this field.

      • setSize

        public void setSize(int size)

        Set the value of the size property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlInputText.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlInputText.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlInputText.PropertyKeys>
      • javax.faces.component.html.HtmlInputText.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlInputText.PropertyKeys>
    Enclosing class:
    HtmlInputText

    protected static enum HtmlInputText.PropertyKeys
extends Enum<HtmlInputText.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      alt
      autocomplete
      dir
      disabled
      label
      lang
      maxlength
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      size
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlInputText.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlInputText.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlInputText.PropertyKeys accesskey

      • alt

        public static final HtmlInputText.PropertyKeys alt

      • autocomplete

        public static final HtmlInputText.PropertyKeys autocomplete

      • dir

        public static final HtmlInputText.PropertyKeys dir

      • disabled

        public static final HtmlInputText.PropertyKeys disabled

      • label

        public static final HtmlInputText.PropertyKeys label

      • lang

        public static final HtmlInputText.PropertyKeys lang

      • maxlength

        public static final HtmlInputText.PropertyKeys maxlength

      • onblur

        public static final HtmlInputText.PropertyKeys onblur

      • onchange

        public static final HtmlInputText.PropertyKeys onchange

      • onclick

        public static final HtmlInputText.PropertyKeys onclick

      • ondblclick

        public static final HtmlInputText.PropertyKeys ondblclick

      • onfocus

        public static final HtmlInputText.PropertyKeys onfocus

      • onkeydown

        public static final HtmlInputText.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlInputText.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlInputText.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlInputText.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlInputText.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlInputText.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlInputText.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlInputText.PropertyKeys onmouseup

      • onselect

        public static final HtmlInputText.PropertyKeys onselect

      • readonly

        public static final HtmlInputText.PropertyKeys readonly

      • role

        public static final HtmlInputText.PropertyKeys role

      • size

        public static final HtmlInputText.PropertyKeys size

      • style

        public static final HtmlInputText.PropertyKeys style

      • styleClass

        public static final HtmlInputText.PropertyKeys styleClass

      • tabindex

        public static final HtmlInputText.PropertyKeys tabindex

      • title

        public static final HtmlInputText.PropertyKeys title

    • Method Detail

      • values

        public static HtmlInputText.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlInputText.PropertyKeys c : HtmlInputText.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlInputText.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlInputText.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlInputTextarea (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlInputTextarea

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.html.HtmlInputTextarea
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlInputTextarea
extends UIInput
implements ClientBehaviorHolder

    Represents an HTML textarea element.

    By default, the rendererType property must be set to "javax.faces.Textarea". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlInputTextarea.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIInput

        COMPONENT_FAMILY, CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlInputTextarea()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      int getCols()
      Return the value of the cols property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      int getRows()
      Return the value of the rows property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setCols(int cols)
      Set the value of the cols property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setRows(int rows)
      Set the value of the rows property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getFamily, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlInputTextarea

        public HtmlInputTextarea()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getCols

        public int getCols()

        Return the value of the cols property.

        Contents: The number of columns to be displayed.

      • setCols

        public void setCols(int cols)

        Set the value of the cols property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getRows

        public int getRows()

        Return the value of the rows property.

        Contents: The number of rows to be displayed.

      • setRows

        public void setRows(int rows)

        Set the value of the rows property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlInputTextarea.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlInputTextarea.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlInputTextarea.PropertyKeys>
      • javax.faces.component.html.HtmlInputTextarea.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlInputTextarea.PropertyKeys>
    Enclosing class:
    HtmlInputTextarea

    protected static enum HtmlInputTextarea.PropertyKeys
extends Enum<HtmlInputTextarea.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      cols
      dir
      disabled
      label
      lang
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      rows
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlInputTextarea.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlInputTextarea.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlInputTextarea.PropertyKeys accesskey

      • cols

        public static final HtmlInputTextarea.PropertyKeys cols

      • dir

        public static final HtmlInputTextarea.PropertyKeys dir

      • disabled

        public static final HtmlInputTextarea.PropertyKeys disabled

      • label

        public static final HtmlInputTextarea.PropertyKeys label

      • lang

        public static final HtmlInputTextarea.PropertyKeys lang

      • onblur

        public static final HtmlInputTextarea.PropertyKeys onblur

      • onchange

        public static final HtmlInputTextarea.PropertyKeys onchange

      • onclick

        public static final HtmlInputTextarea.PropertyKeys onclick

      • ondblclick

        public static final HtmlInputTextarea.PropertyKeys ondblclick

      • onfocus

        public static final HtmlInputTextarea.PropertyKeys onfocus

      • onkeydown

        public static final HtmlInputTextarea.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlInputTextarea.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlInputTextarea.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlInputTextarea.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlInputTextarea.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlInputTextarea.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlInputTextarea.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlInputTextarea.PropertyKeys onmouseup

      • onselect

        public static final HtmlInputTextarea.PropertyKeys onselect

      • readonly

        public static final HtmlInputTextarea.PropertyKeys readonly

      • role

        public static final HtmlInputTextarea.PropertyKeys role

      • rows

        public static final HtmlInputTextarea.PropertyKeys rows

      • style

        public static final HtmlInputTextarea.PropertyKeys style

      • styleClass

        public static final HtmlInputTextarea.PropertyKeys styleClass

      • tabindex

        public static final HtmlInputTextarea.PropertyKeys tabindex

      • title

        public static final HtmlInputTextarea.PropertyKeys title

    • Method Detail

      • values

        public static HtmlInputTextarea.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlInputTextarea.PropertyKeys c : HtmlInputTextarea.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlInputTextarea.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlInputTextarea.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlMessage

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIMessage
          • javax.faces.component.html.HtmlMessage
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlMessage
extends UIMessage

    By default, the rendererType property must be set to "javax.faces.Message". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlMessage.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIMessage

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlMessage()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDir()
      Return the value of the dir property.
      String getErrorClass()
      Return the value of the errorClass property.
      String getErrorStyle()
      Return the value of the errorStyle property.
      String getFatalClass()
      Return the value of the fatalClass property.
      String getFatalStyle()
      Return the value of the fatalStyle property.
      String getInfoClass()
      Return the value of the infoClass property.
      String getInfoStyle()
      Return the value of the infoStyle property.
      String getLang()
      Return the value of the lang property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTitle()
      Return the value of the title property.
      String getWarnClass()
      Return the value of the warnClass property.
      String getWarnStyle()
      Return the value of the warnStyle property.
      boolean isTooltip()
      Return the value of the tooltip property.
      void setDir(String dir)
      Set the value of the dir property.
      void setErrorClass(String errorClass)
      Set the value of the errorClass property.
      void setErrorStyle(String errorStyle)
      Set the value of the errorStyle property.
      void setFatalClass(String fatalClass)
      Set the value of the fatalClass property.
      void setFatalStyle(String fatalStyle)
      Set the value of the fatalStyle property.
      void setInfoClass(String infoClass)
      Set the value of the infoClass property.
      void setInfoStyle(String infoStyle)
      Set the value of the infoStyle property.
      void setLang(String lang)
      Set the value of the lang property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTitle(String title)
      Set the value of the title property.
      void setTooltip(boolean tooltip)
      Set the value of the tooltip property.
      void setWarnClass(String warnClass)
      Set the value of the warnClass property.
      void setWarnStyle(String warnStyle)
      Set the value of the warnStyle property.

      • Methods inherited from class javax.faces.component.UIMessage

        getFamily, getFor, isRedisplay, isShowDetail, isShowSummary, setFor, setRedisplay, setShowDetail, setShowSummary

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlMessage

        public HtmlMessage()

    • Method Detail

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • getErrorClass

        public String getErrorClass()

        Return the value of the errorClass property.

        Contents: CSS style class to apply to any message with a severity class of "ERROR".

      • setErrorClass

        public void setErrorClass(String errorClass)

        Set the value of the errorClass property.

      • getErrorStyle

        public String getErrorStyle()

        Return the value of the errorStyle property.

        Contents: CSS style(s) to apply to any message with a severity class of "ERROR".

      • setErrorStyle

        public void setErrorStyle(String errorStyle)

        Set the value of the errorStyle property.

      • getFatalClass

        public String getFatalClass()

        Return the value of the fatalClass property.

        Contents: CSS style class to apply to any message with a severity class of "FATAL".

      • setFatalClass

        public void setFatalClass(String fatalClass)

        Set the value of the fatalClass property.

      • getFatalStyle

        public String getFatalStyle()

        Return the value of the fatalStyle property.

        Contents: CSS style(s) to apply to any message with a severity class of "FATAL".

      • setFatalStyle

        public void setFatalStyle(String fatalStyle)

        Set the value of the fatalStyle property.

      • getInfoClass

        public String getInfoClass()

        Return the value of the infoClass property.

        Contents: CSS style class to apply to any message with a severity class of "INFO".

      • setInfoClass

        public void setInfoClass(String infoClass)

        Set the value of the infoClass property.

      • getInfoStyle

        public String getInfoStyle()

        Return the value of the infoStyle property.

        Contents: CSS style(s) to apply to any message with a severity class of "INFO".

      • setInfoStyle

        public void setInfoStyle(String infoStyle)

        Set the value of the infoStyle property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • isTooltip

        public boolean isTooltip()

        Return the value of the tooltip property.

        Contents: Flag indicating whether the detail portion of the message should be displayed as a tooltip.

      • setTooltip

        public void setTooltip(boolean tooltip)

        Set the value of the tooltip property.

      • getWarnClass

        public String getWarnClass()

        Return the value of the warnClass property.

        Contents: CSS style class to apply to any message with a severity class of "WARN".

      • setWarnClass

        public void setWarnClass(String warnClass)

        Set the value of the warnClass property.

      • getWarnStyle

        public String getWarnStyle()

        Return the value of the warnStyle property.

        Contents: CSS style(s) to apply to any message with a severity class of "WARN".

      • setWarnStyle

        public void setWarnStyle(String warnStyle)

        Set the value of the warnStyle property.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlMessage.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlMessage.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlMessage.PropertyKeys>
      • javax.faces.component.html.HtmlMessage.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlMessage.PropertyKeys>
    Enclosing class:
    HtmlMessage

    protected static enum HtmlMessage.PropertyKeys
extends Enum<HtmlMessage.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      dir
      errorClass
      errorStyle
      fatalClass
      fatalStyle
      infoClass
      infoStyle
      lang
      role
      style
      styleClass
      title
      tooltip
      warnClass
      warnStyle

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlMessage.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlMessage.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • dir

        public static final HtmlMessage.PropertyKeys dir

      • errorClass

        public static final HtmlMessage.PropertyKeys errorClass

      • errorStyle

        public static final HtmlMessage.PropertyKeys errorStyle

      • fatalClass

        public static final HtmlMessage.PropertyKeys fatalClass

      • fatalStyle

        public static final HtmlMessage.PropertyKeys fatalStyle

      • infoClass

        public static final HtmlMessage.PropertyKeys infoClass

      • infoStyle

        public static final HtmlMessage.PropertyKeys infoStyle

      • lang

        public static final HtmlMessage.PropertyKeys lang

      • role

        public static final HtmlMessage.PropertyKeys role

      • style

        public static final HtmlMessage.PropertyKeys style

      • styleClass

        public static final HtmlMessage.PropertyKeys styleClass

      • title

        public static final HtmlMessage.PropertyKeys title

      • tooltip

        public static final HtmlMessage.PropertyKeys tooltip

      • warnClass

        public static final HtmlMessage.PropertyKeys warnClass

      • warnStyle

        public static final HtmlMessage.PropertyKeys warnStyle

    • Method Detail

      • values

        public static HtmlMessage.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlMessage.PropertyKeys c : HtmlMessage.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlMessage.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlMessage.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlMessages (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlMessages

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIMessages
          • javax.faces.component.html.HtmlMessages
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlMessages
extends UIMessages

    By default, the rendererType property must be set to "javax.faces.Messages". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlMessages.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIMessages

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlMessages()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDir()
      Return the value of the dir property.
      String getErrorClass()
      Return the value of the errorClass property.
      String getErrorStyle()
      Return the value of the errorStyle property.
      String getFatalClass()
      Return the value of the fatalClass property.
      String getFatalStyle()
      Return the value of the fatalStyle property.
      String getInfoClass()
      Return the value of the infoClass property.
      String getInfoStyle()
      Return the value of the infoStyle property.
      String getLang()
      Return the value of the lang property.
      String getLayout()
      Return the value of the layout property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTitle()
      Return the value of the title property.
      String getWarnClass()
      Return the value of the warnClass property.
      String getWarnStyle()
      Return the value of the warnStyle property.
      boolean isTooltip()
      Return the value of the tooltip property.
      void setDir(String dir)
      Set the value of the dir property.
      void setErrorClass(String errorClass)
      Set the value of the errorClass property.
      void setErrorStyle(String errorStyle)
      Set the value of the errorStyle property.
      void setFatalClass(String fatalClass)
      Set the value of the fatalClass property.
      void setFatalStyle(String fatalStyle)
      Set the value of the fatalStyle property.
      void setInfoClass(String infoClass)
      Set the value of the infoClass property.
      void setInfoStyle(String infoStyle)
      Set the value of the infoStyle property.
      void setLang(String lang)
      Set the value of the lang property.
      void setLayout(String layout)
      Set the value of the layout property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTitle(String title)
      Set the value of the title property.
      void setTooltip(boolean tooltip)
      Set the value of the tooltip property.
      void setWarnClass(String warnClass)
      Set the value of the warnClass property.
      void setWarnStyle(String warnStyle)
      Set the value of the warnStyle property.

      • Methods inherited from class javax.faces.component.UIMessages

        getFamily, getFor, isGlobalOnly, isRedisplay, isShowDetail, isShowSummary, setFor, setGlobalOnly, setRedisplay, setShowDetail, setShowSummary

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlMessages

        public HtmlMessages()

    • Method Detail

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • getErrorClass

        public String getErrorClass()

        Return the value of the errorClass property.

        Contents: CSS style class to apply to any message with a severity class of "ERROR".

      • setErrorClass

        public void setErrorClass(String errorClass)

        Set the value of the errorClass property.

      • getErrorStyle

        public String getErrorStyle()

        Return the value of the errorStyle property.

        Contents: CSS style(s) to apply to any message with a severity class of "ERROR".

      • setErrorStyle

        public void setErrorStyle(String errorStyle)

        Set the value of the errorStyle property.

      • getFatalClass

        public String getFatalClass()

        Return the value of the fatalClass property.

        Contents: CSS style class to apply to any message with a severity class of "FATAL".

      • setFatalClass

        public void setFatalClass(String fatalClass)

        Set the value of the fatalClass property.

      • getFatalStyle

        public String getFatalStyle()

        Return the value of the fatalStyle property.

        Contents: CSS style(s) to apply to any message with a severity class of "FATAL".

      • setFatalStyle

        public void setFatalStyle(String fatalStyle)

        Set the value of the fatalStyle property.

      • getInfoClass

        public String getInfoClass()

        Return the value of the infoClass property.

        Contents: CSS style class to apply to any message with a severity class of "INFO".

      • setInfoClass

        public void setInfoClass(String infoClass)

        Set the value of the infoClass property.

      • getInfoStyle

        public String getInfoStyle()

        Return the value of the infoStyle property.

        Contents: CSS style(s) to apply to any message with a severity class of "INFO".

      • setInfoStyle

        public void setInfoStyle(String infoStyle)

        Set the value of the infoStyle property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getLayout

        public String getLayout()

        Return the value of the layout property.

        Contents: The type of layout markup to use when rendering error messages. Valid values are "table" (an HTML table) and "list" (an HTML list). If not specified, the default value is "list".

      • setLayout

        public void setLayout(String layout)

        Set the value of the layout property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • isTooltip

        public boolean isTooltip()

        Return the value of the tooltip property.

        Contents: Flag indicating whether the detail portion of the message should be displayed as a tooltip.

      • setTooltip

        public void setTooltip(boolean tooltip)

        Set the value of the tooltip property.

      • getWarnClass

        public String getWarnClass()

        Return the value of the warnClass property.

        Contents: CSS style class to apply to any message with a severity class of "WARN".

      • setWarnClass

        public void setWarnClass(String warnClass)

        Set the value of the warnClass property.

      • getWarnStyle

        public String getWarnStyle()

        Return the value of the warnStyle property.

        Contents: CSS style(s) to apply to any message with a severity class of "WARN".

      • setWarnStyle

        public void setWarnStyle(String warnStyle)

        Set the value of the warnStyle property.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlMessages.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlMessages.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlMessages.PropertyKeys>
      • javax.faces.component.html.HtmlMessages.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlMessages.PropertyKeys>
    Enclosing class:
    HtmlMessages

    protected static enum HtmlMessages.PropertyKeys
extends Enum<HtmlMessages.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      dir
      errorClass
      errorStyle
      fatalClass
      fatalStyle
      infoClass
      infoStyle
      lang
      layout
      role
      style
      styleClass
      title
      tooltip
      warnClass
      warnStyle

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlMessages.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlMessages.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • dir

        public static final HtmlMessages.PropertyKeys dir

      • errorClass

        public static final HtmlMessages.PropertyKeys errorClass

      • errorStyle

        public static final HtmlMessages.PropertyKeys errorStyle

      • fatalClass

        public static final HtmlMessages.PropertyKeys fatalClass

      • fatalStyle

        public static final HtmlMessages.PropertyKeys fatalStyle

      • infoClass

        public static final HtmlMessages.PropertyKeys infoClass

      • infoStyle

        public static final HtmlMessages.PropertyKeys infoStyle

      • lang

        public static final HtmlMessages.PropertyKeys lang

      • layout

        public static final HtmlMessages.PropertyKeys layout

      • role

        public static final HtmlMessages.PropertyKeys role

      • style

        public static final HtmlMessages.PropertyKeys style

      • styleClass

        public static final HtmlMessages.PropertyKeys styleClass

      • title

        public static final HtmlMessages.PropertyKeys title

      • tooltip

        public static final HtmlMessages.PropertyKeys tooltip

      • warnClass

        public static final HtmlMessages.PropertyKeys warnClass

      • warnStyle

        public static final HtmlMessages.PropertyKeys warnStyle

    • Method Detail

      • values

        public static HtmlMessages.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlMessages.PropertyKeys c : HtmlMessages.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlMessages.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlMessages.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlOutcomeTargetButton (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlOutcomeTargetButton

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIOutcomeTarget
            • javax.faces.component.html.HtmlOutcomeTargetButton
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlOutcomeTargetButton
extends UIOutcomeTarget
implements ClientBehaviorHolder

    Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property. The button behaves like a link, so the current form is not submitted when it is activated (the transitive of how the UICommandLink behaves like a submit button).

    By default, the rendererType property must be set to "javax.faces.Button". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlOutcomeTargetButton.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIOutcomeTarget

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlOutcomeTargetButton()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getAlt()
      Return the value of the alt property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getImage()
      Return the value of the image property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setAlt(String alt)
      Set the value of the alt property.
      void setDir(String dir)
      Set the value of the dir property.
      void setImage(String image)
      Set the value of the image property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UIOutcomeTarget

        getFamily, getOutcome, isDisableClientWindow, isIncludeViewParams, setDisableClientWindow, setIncludeViewParams, setOutcome

      • Methods inherited from class javax.faces.component.UIOutput

        clearInitialState, getConverter, getLocalValue, getValue, markInitialState, resetValue, restoreState, saveState, setConverter, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlOutcomeTargetButton

        public HtmlOutcomeTargetButton()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getAlt

        public String getAlt()

        Return the value of the alt property.

        Contents: Alternate textual description of the element rendered by this component.

      • setAlt

        public void setAlt(String alt)

        Set the value of the alt property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • getImage

        public String getImage()

        Return the value of the image property.

        Contents:

        Absolute or relative URL of the image to be displayed for this button. If specified, this "input" element will be of type "image". Otherwise, it will be of the type specified by the "type" property with a label specified by the "value" property. Note that if the value of this attribute starts with "/", the rendered value for this attribute will be prefixed with the context-root for this application.

      • setImage

        public void setImage(String image)

        Set the value of the image property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlOutcomeTargetButton.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlOutcomeTargetButton.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlOutcomeTargetButton.PropertyKeys>
      • javax.faces.component.html.HtmlOutcomeTargetButton.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlOutcomeTargetButton.PropertyKeys>
    Enclosing class:
    HtmlOutcomeTargetButton

    protected static enum HtmlOutcomeTargetButton.PropertyKeys
extends Enum<HtmlOutcomeTargetButton.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      alt
      dir
      image
      lang
      onblur
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      role
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlOutcomeTargetButton.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutcomeTargetButton.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlOutcomeTargetButton.PropertyKeys accesskey

      • alt

        public static final HtmlOutcomeTargetButton.PropertyKeys alt

      • dir

        public static final HtmlOutcomeTargetButton.PropertyKeys dir

      • image

        public static final HtmlOutcomeTargetButton.PropertyKeys image

      • lang

        public static final HtmlOutcomeTargetButton.PropertyKeys lang

      • onblur

        public static final HtmlOutcomeTargetButton.PropertyKeys onblur

      • onclick

        public static final HtmlOutcomeTargetButton.PropertyKeys onclick

      • ondblclick

        public static final HtmlOutcomeTargetButton.PropertyKeys ondblclick

      • onfocus

        public static final HtmlOutcomeTargetButton.PropertyKeys onfocus

      • onkeydown

        public static final HtmlOutcomeTargetButton.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlOutcomeTargetButton.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlOutcomeTargetButton.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlOutcomeTargetButton.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlOutcomeTargetButton.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlOutcomeTargetButton.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlOutcomeTargetButton.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlOutcomeTargetButton.PropertyKeys onmouseup

      • role

        public static final HtmlOutcomeTargetButton.PropertyKeys role

      • style

        public static final HtmlOutcomeTargetButton.PropertyKeys style

      • styleClass

        public static final HtmlOutcomeTargetButton.PropertyKeys styleClass

      • tabindex

        public static final HtmlOutcomeTargetButton.PropertyKeys tabindex

      • title

        public static final HtmlOutcomeTargetButton.PropertyKeys title

    • Method Detail

      • values

        public static HtmlOutcomeTargetButton.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlOutcomeTargetButton.PropertyKeys c : HtmlOutcomeTargetButton.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlOutcomeTargetButton.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlOutcomeTargetButton.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlOutcomeTargetLink (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlOutcomeTargetLink

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIOutcomeTarget
            • javax.faces.component.html.HtmlOutcomeTargetLink
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlOutcomeTargetLink
extends UIOutcomeTarget
implements ClientBehaviorHolder

    Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.

    By default, the rendererType property must be set to "javax.faces.Link". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlOutcomeTargetLink.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIOutcomeTarget

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlOutcomeTargetLink()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getCharset()
      Return the value of the charset property.
      String getCoords()
      Return the value of the coords property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getHreflang()
      Return the value of the hreflang property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getRel()
      Return the value of the rel property.
      String getRev()
      Return the value of the rev property.
      String getRole()
      Return the value of the role property.
      String getShape()
      Return the value of the shape property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTarget()
      Return the value of the target property.
      String getTitle()
      Return the value of the title property.
      String getType()
      Return the value of the type property.
      boolean isDisabled()
      Return the value of the disabled property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setCharset(String charset)
      Set the value of the charset property.
      void setCoords(String coords)
      Set the value of the coords property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setHreflang(String hreflang)
      Set the value of the hreflang property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setRel(String rel)
      Set the value of the rel property.
      void setRev(String rev)
      Set the value of the rev property.
      void setRole(String role)
      Set the value of the role property.
      void setShape(String shape)
      Set the value of the shape property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTarget(String target)
      Set the value of the target property.
      void setTitle(String title)
      Set the value of the title property.
      void setType(String type)
      Set the value of the type property.

      • Methods inherited from class javax.faces.component.UIOutcomeTarget

        getFamily, getOutcome, isDisableClientWindow, isIncludeViewParams, setDisableClientWindow, setIncludeViewParams, setOutcome

      • Methods inherited from class javax.faces.component.UIOutput

        clearInitialState, getConverter, getLocalValue, getValue, markInitialState, resetValue, restoreState, saveState, setConverter, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlOutcomeTargetLink

        public HtmlOutcomeTargetLink()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getCharset

        public String getCharset()

        Return the value of the charset property.

        Contents: The character encoding of the resource designated by this hyperlink.

      • setCharset

        public void setCharset(String charset)

        Set the value of the charset property.

      • getCoords

        public String getCoords()

        Return the value of the coords property.

        Contents: The position and shape of the hot spot on the screen (for use in client-side image maps).

      • setCoords

        public void setCoords(String coords)

        Set the value of the coords property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit.

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getHreflang

        public String getHreflang()

        Return the value of the hreflang property.

        Contents: The language code of the resource designated by this hyperlink.

      • setHreflang

        public void setHreflang(String hreflang)

        Set the value of the hreflang property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getRel

        public String getRel()

        Return the value of the rel property.

        Contents: The relationship from the current document to the anchor specified by this hyperlink. The value of this attribute is a space-separated list of link types.

      • setRel

        public void setRel(String rel)

        Set the value of the rel property.

      • getRev

        public String getRev()

        Return the value of the rev property.

        Contents: A reverse link from the anchor specified by this hyperlink to the current document. The value of this attribute is a space-separated list of link types.

      • setRev

        public void setRev(String rev)

        Set the value of the rev property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getShape

        public String getShape()

        Return the value of the shape property.

        Contents: The shape of the hot spot on the screen (for use in client-side image maps). Valid values are: default (entire region); rect (rectangular region); circle (circular region); and poly (polygonal region).

      • setShape

        public void setShape(String shape)

        Set the value of the shape property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTarget

        public String getTarget()

        Return the value of the target property.

        Contents: Name of a frame where the resource retrieved via this hyperlink is to be displayed.

      • setTarget

        public void setTarget(String target)

        Set the value of the target property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getType

        public String getType()

        Return the value of the type property.

        Contents: The content type of the resource designated by this hyperlink.

      • setType

        public void setType(String type)

        Set the value of the type property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlOutcomeTargetLink.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlOutcomeTargetLink.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlOutcomeTargetLink.PropertyKeys>
      • javax.faces.component.html.HtmlOutcomeTargetLink.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlOutcomeTargetLink.PropertyKeys>
    Enclosing class:
    HtmlOutcomeTargetLink

    protected static enum HtmlOutcomeTargetLink.PropertyKeys
extends Enum<HtmlOutcomeTargetLink.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      charset
      coords
      dir
      disabled
      hreflang
      lang
      onblur
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      rel
      rev
      role
      shape
      style
      styleClass
      tabindex
      target
      title
      type

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlOutcomeTargetLink.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutcomeTargetLink.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlOutcomeTargetLink.PropertyKeys accesskey

      • charset

        public static final HtmlOutcomeTargetLink.PropertyKeys charset

      • coords

        public static final HtmlOutcomeTargetLink.PropertyKeys coords

      • dir

        public static final HtmlOutcomeTargetLink.PropertyKeys dir

      • disabled

        public static final HtmlOutcomeTargetLink.PropertyKeys disabled

      • hreflang

        public static final HtmlOutcomeTargetLink.PropertyKeys hreflang

      • lang

        public static final HtmlOutcomeTargetLink.PropertyKeys lang

      • onblur

        public static final HtmlOutcomeTargetLink.PropertyKeys onblur

      • onclick

        public static final HtmlOutcomeTargetLink.PropertyKeys onclick

      • ondblclick

        public static final HtmlOutcomeTargetLink.PropertyKeys ondblclick

      • onfocus

        public static final HtmlOutcomeTargetLink.PropertyKeys onfocus

      • onkeydown

        public static final HtmlOutcomeTargetLink.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlOutcomeTargetLink.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlOutcomeTargetLink.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlOutcomeTargetLink.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlOutcomeTargetLink.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlOutcomeTargetLink.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlOutcomeTargetLink.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlOutcomeTargetLink.PropertyKeys onmouseup

      • rel

        public static final HtmlOutcomeTargetLink.PropertyKeys rel

      • rev

        public static final HtmlOutcomeTargetLink.PropertyKeys rev

      • role

        public static final HtmlOutcomeTargetLink.PropertyKeys role

      • shape

        public static final HtmlOutcomeTargetLink.PropertyKeys shape

      • style

        public static final HtmlOutcomeTargetLink.PropertyKeys style

      • styleClass

        public static final HtmlOutcomeTargetLink.PropertyKeys styleClass

      • tabindex

        public static final HtmlOutcomeTargetLink.PropertyKeys tabindex

      • target

        public static final HtmlOutcomeTargetLink.PropertyKeys target

      • title

        public static final HtmlOutcomeTargetLink.PropertyKeys title

      • type

        public static final HtmlOutcomeTargetLink.PropertyKeys type

    • Method Detail

      • values

        public static HtmlOutcomeTargetLink.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlOutcomeTargetLink.PropertyKeys c : HtmlOutcomeTargetLink.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlOutcomeTargetLink.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlOutcomeTargetLink.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlOutputFormat (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlOutputFormat

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.html.HtmlOutputFormat
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlOutputFormat
extends UIOutput

    Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result. If the "dir" or "lang" attributes are present, render a span element and pass them through as attributes on the span.

    By default, the rendererType property must be set to "javax.faces.Format". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlOutputFormat.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIOutput

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlOutputFormat()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDir()
      Return the value of the dir property.
      String getLang()
      Return the value of the lang property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTitle()
      Return the value of the title property.
      boolean isEscape()
      Return the value of the escape property.
      void setDir(String dir)
      Set the value of the dir property.
      void setEscape(boolean escape)
      Set the value of the escape property.
      void setLang(String lang)
      Set the value of the lang property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UIOutput

        clearInitialState, getConverter, getFamily, getLocalValue, getValue, markInitialState, resetValue, restoreState, saveState, setConverter, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlOutputFormat

        public HtmlOutputFormat()

    • Method Detail

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isEscape

        public boolean isEscape()

        Return the value of the escape property.

        Contents: Flag indicating that characters that are sensitive in HTML and XML markup must be escaped. This flag is set to "true" by default.

      • setEscape

        public void setEscape(boolean escape)

        Set the value of the escape property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlOutputFormat.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlOutputFormat.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlOutputFormat.PropertyKeys>
      • javax.faces.component.html.HtmlOutputFormat.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlOutputFormat.PropertyKeys>
    Enclosing class:
    HtmlOutputFormat

    protected static enum HtmlOutputFormat.PropertyKeys
extends Enum<HtmlOutputFormat.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      dir
      escape
      lang
      role
      style
      styleClass
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlOutputFormat.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutputFormat.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • dir

        public static final HtmlOutputFormat.PropertyKeys dir

      • escape

        public static final HtmlOutputFormat.PropertyKeys escape

      • lang

        public static final HtmlOutputFormat.PropertyKeys lang

      • role

        public static final HtmlOutputFormat.PropertyKeys role

      • style

        public static final HtmlOutputFormat.PropertyKeys style

      • styleClass

        public static final HtmlOutputFormat.PropertyKeys styleClass

      • title

        public static final HtmlOutputFormat.PropertyKeys title

    • Method Detail

      • values

        public static HtmlOutputFormat.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlOutputFormat.PropertyKeys c : HtmlOutputFormat.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlOutputFormat.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlOutputFormat.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlOutputLabel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlOutputLabel

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.html.HtmlOutputLabel
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlOutputLabel
extends UIOutput
implements ClientBehaviorHolder

    Represents an HTML label element, used to define an accessible label for a corresponding input element.

    By default, the rendererType property must be set to "javax.faces.Label". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlOutputLabel.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIOutput

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlOutputLabel()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getFor()
      Return the value of the for property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isEscape()
      Return the value of the escape property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setDir(String dir)
      Set the value of the dir property.
      void setEscape(boolean escape)
      Set the value of the escape property.
      void setFor(String _for)
      Set the value of the for property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UIOutput

        clearInitialState, getConverter, getFamily, getLocalValue, getValue, markInitialState, resetValue, restoreState, saveState, setConverter, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlOutputLabel

        public HtmlOutputLabel()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isEscape

        public boolean isEscape()

        Return the value of the escape property.

        Contents: Flag indicating that characters that are sensitive in HTML and XML markup must be escaped. If omitted, this flag is assumed to be "true".

      • setEscape

        public void setEscape(boolean escape)

        Set the value of the escape property.

      • getFor

        public String getFor()

        Return the value of the for property.

        Contents: Client identifier of the component for which this element is a label.

      • setFor

        public void setFor(String _for)

        Set the value of the for property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlOutputLabel.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlOutputLabel.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlOutputLabel.PropertyKeys>
      • javax.faces.component.html.HtmlOutputLabel.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlOutputLabel.PropertyKeys>
    Enclosing class:
    HtmlOutputLabel

    protected static enum HtmlOutputLabel.PropertyKeys
extends Enum<HtmlOutputLabel.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      dir
      escape
      forVal
      lang
      onblur
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      role
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlOutputLabel.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutputLabel.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlOutputLabel.PropertyKeys accesskey

      • dir

        public static final HtmlOutputLabel.PropertyKeys dir

      • escape

        public static final HtmlOutputLabel.PropertyKeys escape

      • forVal

        public static final HtmlOutputLabel.PropertyKeys forVal

      • lang

        public static final HtmlOutputLabel.PropertyKeys lang

      • onblur

        public static final HtmlOutputLabel.PropertyKeys onblur

      • onclick

        public static final HtmlOutputLabel.PropertyKeys onclick

      • ondblclick

        public static final HtmlOutputLabel.PropertyKeys ondblclick

      • onfocus

        public static final HtmlOutputLabel.PropertyKeys onfocus

      • onkeydown

        public static final HtmlOutputLabel.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlOutputLabel.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlOutputLabel.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlOutputLabel.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlOutputLabel.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlOutputLabel.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlOutputLabel.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlOutputLabel.PropertyKeys onmouseup

      • role

        public static final HtmlOutputLabel.PropertyKeys role

      • style

        public static final HtmlOutputLabel.PropertyKeys style

      • styleClass

        public static final HtmlOutputLabel.PropertyKeys styleClass

      • tabindex

        public static final HtmlOutputLabel.PropertyKeys tabindex

      • title

        public static final HtmlOutputLabel.PropertyKeys title

    • Method Detail

      • values

        public static HtmlOutputLabel.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlOutputLabel.PropertyKeys c : HtmlOutputLabel.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlOutputLabel.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlOutputLabel.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlOutputLink (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlOutputLink

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.html.HtmlOutputLink
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlOutputLink
extends UIOutput
implements ClientBehaviorHolder

    Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.

    By default, the rendererType property must be set to "javax.faces.Link". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlOutputLink.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIOutput

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlOutputLink()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getCharset()
      Return the value of the charset property.
      String getCoords()
      Return the value of the coords property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getFragment()
      Return the value of the fragment property.
      String getHreflang()
      Return the value of the hreflang property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getRel()
      Return the value of the rel property.
      String getRev()
      Return the value of the rev property.
      String getRole()
      Return the value of the role property.
      String getShape()
      Return the value of the shape property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTarget()
      Return the value of the target property.
      String getTitle()
      Return the value of the title property.
      String getType()
      Return the value of the type property.
      boolean isDisabled()
      Return the value of the disabled property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setCharset(String charset)
      Set the value of the charset property.
      void setCoords(String coords)
      Set the value of the coords property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setFragment(String fragment)
      Set the value of the fragment property.
      void setHreflang(String hreflang)
      Set the value of the hreflang property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setRel(String rel)
      Set the value of the rel property.
      void setRev(String rev)
      Set the value of the rev property.
      void setRole(String role)
      Set the value of the role property.
      void setShape(String shape)
      Set the value of the shape property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTarget(String target)
      Set the value of the target property.
      void setTitle(String title)
      Set the value of the title property.
      void setType(String type)
      Set the value of the type property.

      • Methods inherited from class javax.faces.component.UIOutput

        clearInitialState, getConverter, getFamily, getLocalValue, getValue, markInitialState, resetValue, restoreState, saveState, setConverter, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlOutputLink

        public HtmlOutputLink()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getCharset

        public String getCharset()

        Return the value of the charset property.

        Contents: The character encoding of the resource designated by this hyperlink.

      • setCharset

        public void setCharset(String charset)

        Set the value of the charset property.

      • getCoords

        public String getCoords()

        Return the value of the coords property.

        Contents: The position and shape of the hot spot on the screen (for use in client-side image maps).

      • setCoords

        public void setCoords(String coords)

        Set the value of the coords property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit.

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getFragment

        public String getFragment()

        Return the value of the fragment property.

        Contents: The identifier of the page fragment which should be brought into focus when the target page is rendered. The value of this attribute is appended to the end of target URL following a hash (#) mark. This notation is part of the standard URL syntax.

      • setFragment

        public void setFragment(String fragment)

        Set the value of the fragment property.

      • getHreflang

        public String getHreflang()

        Return the value of the hreflang property.

        Contents: The language code of the resource designated by this hyperlink.

      • setHreflang

        public void setHreflang(String hreflang)

        Set the value of the hreflang property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getRel

        public String getRel()

        Return the value of the rel property.

        Contents: The relationship from the current document to the anchor specified by this hyperlink. The value of this attribute is a space-separated list of link types.

      • setRel

        public void setRel(String rel)

        Set the value of the rel property.

      • getRev

        public String getRev()

        Return the value of the rev property.

        Contents: A reverse link from the anchor specified by this hyperlink to the current document. The value of this attribute is a space-separated list of link types.

      • setRev

        public void setRev(String rev)

        Set the value of the rev property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getShape

        public String getShape()

        Return the value of the shape property.

        Contents: The shape of the hot spot on the screen (for use in client-side image maps). Valid values are: default (entire region); rect (rectangular region); circle (circular region); and poly (polygonal region).

      • setShape

        public void setShape(String shape)

        Set the value of the shape property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTarget

        public String getTarget()

        Return the value of the target property.

        Contents: Name of a frame where the resource retrieved via this hyperlink is to be displayed.

      • setTarget

        public void setTarget(String target)

        Set the value of the target property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getType

        public String getType()

        Return the value of the type property.

        Contents: The content type of the resource designated by this hyperlink.

      • setType

        public void setType(String type)

        Set the value of the type property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlOutputLink.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlOutputLink.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlOutputLink.PropertyKeys>
      • javax.faces.component.html.HtmlOutputLink.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlOutputLink.PropertyKeys>
    Enclosing class:
    HtmlOutputLink

    protected static enum HtmlOutputLink.PropertyKeys
extends Enum<HtmlOutputLink.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      charset
      coords
      dir
      disabled
      fragment
      hreflang
      lang
      onblur
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      rel
      rev
      role
      shape
      style
      styleClass
      tabindex
      target
      title
      type

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlOutputLink.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutputLink.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlOutputLink.PropertyKeys accesskey

      • charset

        public static final HtmlOutputLink.PropertyKeys charset

      • coords

        public static final HtmlOutputLink.PropertyKeys coords

      • dir

        public static final HtmlOutputLink.PropertyKeys dir

      • disabled

        public static final HtmlOutputLink.PropertyKeys disabled

      • fragment

        public static final HtmlOutputLink.PropertyKeys fragment

      • hreflang

        public static final HtmlOutputLink.PropertyKeys hreflang

      • lang

        public static final HtmlOutputLink.PropertyKeys lang

      • onblur

        public static final HtmlOutputLink.PropertyKeys onblur

      • onclick

        public static final HtmlOutputLink.PropertyKeys onclick

      • ondblclick

        public static final HtmlOutputLink.PropertyKeys ondblclick

      • onfocus

        public static final HtmlOutputLink.PropertyKeys onfocus

      • onkeydown

        public static final HtmlOutputLink.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlOutputLink.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlOutputLink.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlOutputLink.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlOutputLink.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlOutputLink.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlOutputLink.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlOutputLink.PropertyKeys onmouseup

      • rel

        public static final HtmlOutputLink.PropertyKeys rel

      • rev

        public static final HtmlOutputLink.PropertyKeys rev

      • role

        public static final HtmlOutputLink.PropertyKeys role

      • shape

        public static final HtmlOutputLink.PropertyKeys shape

      • style

        public static final HtmlOutputLink.PropertyKeys style

      • styleClass

        public static final HtmlOutputLink.PropertyKeys styleClass

      • tabindex

        public static final HtmlOutputLink.PropertyKeys tabindex

      • target

        public static final HtmlOutputLink.PropertyKeys target

      • title

        public static final HtmlOutputLink.PropertyKeys title

      • type

        public static final HtmlOutputLink.PropertyKeys type

    • Method Detail

      • values

        public static HtmlOutputLink.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlOutputLink.PropertyKeys c : HtmlOutputLink.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlOutputLink.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlOutputLink.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlOutputText (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlOutputText

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.html.HtmlOutputText
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlOutputText
extends UIOutput

    Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.

    By default, the rendererType property must be set to "javax.faces.Text". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlOutputText.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIOutput

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlOutputText()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDir()
      Return the value of the dir property.
      String getLang()
      Return the value of the lang property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTitle()
      Return the value of the title property.
      boolean isEscape()
      Return the value of the escape property.
      void setDir(String dir)
      Set the value of the dir property.
      void setEscape(boolean escape)
      Set the value of the escape property.
      void setLang(String lang)
      Set the value of the lang property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UIOutput

        clearInitialState, getConverter, getFamily, getLocalValue, getValue, markInitialState, resetValue, restoreState, saveState, setConverter, setValue

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getDefaultEventName, getEventNames, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlOutputText

        public HtmlOutputText()

    • Method Detail

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isEscape

        public boolean isEscape()

        Return the value of the escape property.

        Contents: Flag indicating that characters that are sensitive in HTML and XML markup must be escaped. This flag is set to "true" by default.

      • setEscape

        public void setEscape(boolean escape)

        Set the value of the escape property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlOutputText.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlOutputText.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlOutputText.PropertyKeys>
      • javax.faces.component.html.HtmlOutputText.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlOutputText.PropertyKeys>
    Enclosing class:
    HtmlOutputText

    protected static enum HtmlOutputText.PropertyKeys
extends Enum<HtmlOutputText.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      dir
      escape
      lang
      role
      style
      styleClass
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlOutputText.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutputText.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • dir

        public static final HtmlOutputText.PropertyKeys dir

      • escape

        public static final HtmlOutputText.PropertyKeys escape

      • lang

        public static final HtmlOutputText.PropertyKeys lang

      • role

        public static final HtmlOutputText.PropertyKeys role

      • style

        public static final HtmlOutputText.PropertyKeys style

      • styleClass

        public static final HtmlOutputText.PropertyKeys styleClass

      • title

        public static final HtmlOutputText.PropertyKeys title

    • Method Detail

      • values

        public static HtmlOutputText.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlOutputText.PropertyKeys c : HtmlOutputText.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlOutputText.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlOutputText.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlPanelGrid (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlPanelGrid

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIPanel
          • javax.faces.component.html.HtmlPanelGrid
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlPanelGrid
extends UIPanel
implements ClientBehaviorHolder

    Renders child components in a table, starting a new row after the specified number of columns.

    By default, the rendererType property must be set to "javax.faces.Grid". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlPanelGrid.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIPanel

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlPanelGrid()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getBgcolor()
      Return the value of the bgcolor property.
      String getBodyrows()
      Return the value of the bodyrows property.
      int getBorder()
      Return the value of the border property.
      String getCaptionClass()
      Return the value of the captionClass property.
      String getCaptionStyle()
      Return the value of the captionStyle property.
      String getCellpadding()
      Return the value of the cellpadding property.
      String getCellspacing()
      Return the value of the cellspacing property.
      String getColumnClasses()
      Return the value of the columnClasses property.
      int getColumns()
      Return the value of the columns property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getFooterClass()
      Return the value of the footerClass property.
      String getFrame()
      Return the value of the frame property.
      String getHeaderClass()
      Return the value of the headerClass property.
      String getLang()
      Return the value of the lang property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getRole()
      Return the value of the role property.
      String getRowClasses()
      Return the value of the rowClasses property.
      String getRules()
      Return the value of the rules property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getSummary()
      Return the value of the summary property.
      String getTitle()
      Return the value of the title property.
      String getWidth()
      Return the value of the width property.
      void setBgcolor(String bgcolor)
      Set the value of the bgcolor property.
      void setBodyrows(String bodyrows)
      Set the value of the bodyrows property.
      void setBorder(int border)
      Set the value of the border property.
      void setCaptionClass(String captionClass)
      Set the value of the captionClass property.
      void setCaptionStyle(String captionStyle)
      Set the value of the captionStyle property.
      void setCellpadding(String cellpadding)
      Set the value of the cellpadding property.
      void setCellspacing(String cellspacing)
      Set the value of the cellspacing property.
      void setColumnClasses(String columnClasses)
      Set the value of the columnClasses property.
      void setColumns(int columns)
      Set the value of the columns property.
      void setDir(String dir)
      Set the value of the dir property.
      void setFooterClass(String footerClass)
      Set the value of the footerClass property.
      void setFrame(String frame)
      Set the value of the frame property.
      void setHeaderClass(String headerClass)
      Set the value of the headerClass property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setRole(String role)
      Set the value of the role property.
      void setRowClasses(String rowClasses)
      Set the value of the rowClasses property.
      void setRules(String rules)
      Set the value of the rules property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setSummary(String summary)
      Set the value of the summary property.
      void setTitle(String title)
      Set the value of the title property.
      void setWidth(String width)
      Set the value of the width property.

      • Methods inherited from class javax.faces.component.UIPanel

        getFamily

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlPanelGrid

        public HtmlPanelGrid()

    • Method Detail

      • getBgcolor

        public String getBgcolor()

        Return the value of the bgcolor property.

        Contents: Name or code of the background color for this table.

      • setBgcolor

        public void setBgcolor(String bgcolor)

        Set the value of the bgcolor property.

      • getBodyrows

        public String getBodyrows()

        Return the value of the bodyrows property.

        Contents: Comma separated list of row indices for which a new "tbody" element should be started (and any previously opened one should be ended).

      • setBodyrows

        public void setBodyrows(String bodyrows)

        Set the value of the bodyrows property.

      • getBorder

        public int getBorder()

        Return the value of the border property.

        Contents: Width (in pixels) of the border to be drawn around this table.

      • setBorder

        public void setBorder(int border)

        Set the value of the border property.

      • getCaptionClass

        public String getCaptionClass()

        Return the value of the captionClass property.

        Contents: Space-separated list of CSS style class(es) that will be applied to any caption generated for this table.

      • setCaptionClass

        public void setCaptionClass(String captionClass)

        Set the value of the captionClass property.

      • getCaptionStyle

        public String getCaptionStyle()

        Return the value of the captionStyle property.

        Contents: CSS style(s) to be applied when this caption is rendered.

      • setCaptionStyle

        public void setCaptionStyle(String captionStyle)

        Set the value of the captionStyle property.

      • getCellpadding

        public String getCellpadding()

        Return the value of the cellpadding property.

        Contents: Definition of how much space the user agent should leave between the border of each cell and its contents.

      • setCellpadding

        public void setCellpadding(String cellpadding)

        Set the value of the cellpadding property.

      • getCellspacing

        public String getCellspacing()

        Return the value of the cellspacing property.

        Contents: Definition of how much space the user agent should leave between the left side of the table and the leftmost column, the top of the table and the top of the top side of the topmost row, and so on for the right and bottom of the table. It also specifies the amount of space to leave between cells.

      • setCellspacing

        public void setCellspacing(String cellspacing)

        Set the value of the cellspacing property.

      • getColumnClasses

        public String getColumnClasses()

        Return the value of the columnClasses property.

        Contents: Comma-delimited list of CSS style classes that will be applied to the columns of this table. A space separated list of classes may also be specified for any individual column. If the number of elements in this list is less than the number of actual column children of the UIData, no "class" attribute is output for each column greater than the number of elements in the list. If the number of elements in the list is greater than the number of actual column children of the UIData, the elements at the posisiton in the list after the last column are ignored.

      • setColumnClasses

        public void setColumnClasses(String columnClasses)

        Set the value of the columnClasses property.

      • getColumns

        public int getColumns()

        Return the value of the columns property.

        Contents: The number of columns to render before starting a new row.

      • setColumns

        public void setColumns(int columns)

        Set the value of the columns property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • getFooterClass

        public String getFooterClass()

        Return the value of the footerClass property.

        Contents: Space-separated list of CSS style class(es) that will be applied to any footer generated for this table.

      • setFooterClass

        public void setFooterClass(String footerClass)

        Set the value of the footerClass property.

      • getFrame

        public String getFrame()

        Return the value of the frame property.

        Contents: Code specifying which sides of the frame surrounding this table will be visible. Valid values are: none (no sides, default value); above (top side only); below (bottom side only); hsides (top and bottom sides only); vsides (right and left sides only); lhs (left hand side only); rhs (right hand side only); box (all four sides); and border (all four sides).

      • setFrame

        public void setFrame(String frame)

        Set the value of the frame property.

      • getHeaderClass

        public String getHeaderClass()

        Return the value of the headerClass property.

        Contents: Space-separated list of CSS style class(es) that will be applied to any header generated for this table.

      • setHeaderClass

        public void setHeaderClass(String headerClass)

        Set the value of the headerClass property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getRowClasses

        public String getRowClasses()

        Return the value of the rowClasses property.

        Contents: Comma-delimited list of CSS style classes that will be applied to the rows of this table. A space separated list of classes may also be specified for any individual row. Thes styles are applied, in turn, to each row in the table. For example, if the list has two elements, the first style class in the list is applied to the first row, the second to the second row, the first to the third row, the second to the fourth row, etc. In other words, we keep iterating through the list until we reach the end, and then we start at the beginning again.

      • setRowClasses

        public void setRowClasses(String rowClasses)

        Set the value of the rowClasses property.

      • getRules

        public String getRules()

        Return the value of the rules property.

        Contents: Code specifying which rules will appear between cells within this table. Valid values are: none (no rules, default value); groups (between row groups); rows (between rows only); cols (between columns only); and all (between all rows and columns).

      • setRules

        public void setRules(String rules)

        Set the value of the rules property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getSummary

        public String getSummary()

        Return the value of the summary property.

        Contents: Summary of this table's purpose and structure, for user agents rendering to non-visual media such as speech and Braille.

      • setSummary

        public void setSummary(String summary)

        Set the value of the summary property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getWidth

        public String getWidth()

        Return the value of the width property.

        Contents: Width of the entire table, for visual user agents.

      • setWidth

        public void setWidth(String width)

        Set the value of the width property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlPanelGrid.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlPanelGrid.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlPanelGrid.PropertyKeys>
      • javax.faces.component.html.HtmlPanelGrid.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlPanelGrid.PropertyKeys>
    Enclosing class:
    HtmlPanelGrid

    protected static enum HtmlPanelGrid.PropertyKeys
extends Enum<HtmlPanelGrid.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      bgcolor
      bodyrows
      border
      captionClass
      captionStyle
      cellpadding
      cellspacing
      columnClasses
      columns
      dir
      footerClass
      frame
      headerClass
      lang
      onclick
      ondblclick
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      role
      rowClasses
      rules
      style
      styleClass
      summary
      title
      width

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlPanelGrid.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlPanelGrid.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • bgcolor

        public static final HtmlPanelGrid.PropertyKeys bgcolor

      • bodyrows

        public static final HtmlPanelGrid.PropertyKeys bodyrows

      • border

        public static final HtmlPanelGrid.PropertyKeys border

      • captionClass

        public static final HtmlPanelGrid.PropertyKeys captionClass

      • captionStyle

        public static final HtmlPanelGrid.PropertyKeys captionStyle

      • cellpadding

        public static final HtmlPanelGrid.PropertyKeys cellpadding

      • cellspacing

        public static final HtmlPanelGrid.PropertyKeys cellspacing

      • columnClasses

        public static final HtmlPanelGrid.PropertyKeys columnClasses

      • columns

        public static final HtmlPanelGrid.PropertyKeys columns

      • dir

        public static final HtmlPanelGrid.PropertyKeys dir

      • footerClass

        public static final HtmlPanelGrid.PropertyKeys footerClass

      • frame

        public static final HtmlPanelGrid.PropertyKeys frame

      • headerClass

        public static final HtmlPanelGrid.PropertyKeys headerClass

      • lang

        public static final HtmlPanelGrid.PropertyKeys lang

      • onclick

        public static final HtmlPanelGrid.PropertyKeys onclick

      • ondblclick

        public static final HtmlPanelGrid.PropertyKeys ondblclick

      • onkeydown

        public static final HtmlPanelGrid.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlPanelGrid.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlPanelGrid.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlPanelGrid.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlPanelGrid.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlPanelGrid.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlPanelGrid.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlPanelGrid.PropertyKeys onmouseup

      • role

        public static final HtmlPanelGrid.PropertyKeys role

      • rowClasses

        public static final HtmlPanelGrid.PropertyKeys rowClasses

      • rules

        public static final HtmlPanelGrid.PropertyKeys rules

      • style

        public static final HtmlPanelGrid.PropertyKeys style

      • styleClass

        public static final HtmlPanelGrid.PropertyKeys styleClass

      • summary

        public static final HtmlPanelGrid.PropertyKeys summary

      • title

        public static final HtmlPanelGrid.PropertyKeys title

      • width

        public static final HtmlPanelGrid.PropertyKeys width

    • Method Detail

      • values

        public static HtmlPanelGrid.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlPanelGrid.PropertyKeys c : HtmlPanelGrid.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlPanelGrid.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlPanelGrid.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlPanelGroup (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlPanelGroup

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIPanel
          • javax.faces.component.html.HtmlPanelGroup
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, PartialStateHolder, StateHolder, TransientStateHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlPanelGroup
extends UIPanel
implements ClientBehaviorHolder

    Causes all child components of this component to be rendered. This is useful in scenarios where a parent component is expecting a single component to be present, but the application wishes to render more than one.

    By default, the rendererType property must be set to "javax.faces.Group". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlPanelGroup.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UIPanel

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlPanelGroup()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLayout()
      Return the value of the layout property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      void setLayout(String layout)
      Set the value of the layout property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.

      • Methods inherited from class javax.faces.component.UIPanel

        getFamily

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, clearInitialState, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, markInitialState, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlPanelGroup

        public HtmlPanelGroup()

    • Method Detail

      • getLayout

        public String getLayout()

        Return the value of the layout property.

        Contents: The type of layout markup to use when rendering this group. If the value is "block" the renderer must produce an HTML "div" element. Otherwise HTML "span" element must be produced.

      • setLayout

        public void setLayout(String layout)

        Set the value of the layout property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" property on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlPanelGroup.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlPanelGroup.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlPanelGroup.PropertyKeys>
      • javax.faces.component.html.HtmlPanelGroup.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlPanelGroup.PropertyKeys>
    Enclosing class:
    HtmlPanelGroup

    protected static enum HtmlPanelGroup.PropertyKeys
extends Enum<HtmlPanelGroup.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      layout
      onclick
      ondblclick
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      style
      styleClass

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlPanelGroup.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlPanelGroup.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • layout

        public static final HtmlPanelGroup.PropertyKeys layout

      • onclick

        public static final HtmlPanelGroup.PropertyKeys onclick

      • ondblclick

        public static final HtmlPanelGroup.PropertyKeys ondblclick

      • onkeydown

        public static final HtmlPanelGroup.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlPanelGroup.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlPanelGroup.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlPanelGroup.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlPanelGroup.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlPanelGroup.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlPanelGroup.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlPanelGroup.PropertyKeys onmouseup

      • style

        public static final HtmlPanelGroup.PropertyKeys style

      • styleClass

        public static final HtmlPanelGroup.PropertyKeys styleClass

    • Method Detail

      • values

        public static HtmlPanelGroup.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlPanelGroup.PropertyKeys c : HtmlPanelGroup.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlPanelGroup.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlPanelGroup.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlSelectBooleanCheckbox (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlSelectBooleanCheckbox

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UISelectBoolean
              • javax.faces.component.html.HtmlSelectBooleanCheckbox
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlSelectBooleanCheckbox
extends UISelectBoolean
implements ClientBehaviorHolder

    Represents an HTML input element of type checkbox. The checkbox will be rendered as checked, or not, based on the value of the value property.

    By default, the rendererType property must be set to "javax.faces.Checkbox". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlSelectBooleanCheckbox.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UISelectBoolean

        COMPONENT_FAMILY

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlSelectBooleanCheckbox()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UISelectBoolean

        getFamily, getValueBinding, getValueExpression, isSelected, setSelected, setValueBinding, setValueExpression

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlSelectBooleanCheckbox

        public HtmlSelectBooleanCheckbox()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlSelectBooleanCheckbox.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlSelectBooleanCheckbox.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlSelectBooleanCheckbox.PropertyKeys>
      • javax.faces.component.html.HtmlSelectBooleanCheckbox.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlSelectBooleanCheckbox.PropertyKeys>
    Enclosing class:
    HtmlSelectBooleanCheckbox

    protected static enum HtmlSelectBooleanCheckbox.PropertyKeys
extends Enum<HtmlSelectBooleanCheckbox.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      dir
      disabled
      label
      lang
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlSelectBooleanCheckbox.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectBooleanCheckbox.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlSelectBooleanCheckbox.PropertyKeys accesskey

      • dir

        public static final HtmlSelectBooleanCheckbox.PropertyKeys dir

      • disabled

        public static final HtmlSelectBooleanCheckbox.PropertyKeys disabled

      • label

        public static final HtmlSelectBooleanCheckbox.PropertyKeys label

      • lang

        public static final HtmlSelectBooleanCheckbox.PropertyKeys lang

      • onblur

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onblur

      • onchange

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onchange

      • onclick

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onclick

      • ondblclick

        public static final HtmlSelectBooleanCheckbox.PropertyKeys ondblclick

      • onfocus

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onfocus

      • onkeydown

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onmouseup

      • onselect

        public static final HtmlSelectBooleanCheckbox.PropertyKeys onselect

      • readonly

        public static final HtmlSelectBooleanCheckbox.PropertyKeys readonly

      • role

        public static final HtmlSelectBooleanCheckbox.PropertyKeys role

      • style

        public static final HtmlSelectBooleanCheckbox.PropertyKeys style

      • styleClass

        public static final HtmlSelectBooleanCheckbox.PropertyKeys styleClass

      • tabindex

        public static final HtmlSelectBooleanCheckbox.PropertyKeys tabindex

      • title

        public static final HtmlSelectBooleanCheckbox.PropertyKeys title

    • Method Detail

      • values

        public static HtmlSelectBooleanCheckbox.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlSelectBooleanCheckbox.PropertyKeys c : HtmlSelectBooleanCheckbox.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlSelectBooleanCheckbox.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlSelectBooleanCheckbox.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlSelectManyCheckbox (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlSelectManyCheckbox

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UISelectMany
              • javax.faces.component.html.HtmlSelectManyCheckbox
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlSelectManyCheckbox
extends UISelectMany
implements ClientBehaviorHolder

    Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.

    By default, the rendererType property must be set to "javax.faces.Checkbox". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlSelectManyCheckbox.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UISelectMany

        COMPONENT_FAMILY, INVALID_MESSAGE_ID

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlSelectManyCheckbox()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      int getBorder()
      Return the value of the border property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      String getDisabledClass()
      Return the value of the disabledClass property.
      String getEnabledClass()
      Return the value of the enabledClass property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      String getLayout()
      Return the value of the layout property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      String getSelectedClass()
      Return the value of the selectedClass property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      String getUnselectedClass()
      Return the value of the unselectedClass property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setBorder(int border)
      Set the value of the border property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setDisabledClass(String disabledClass)
      Set the value of the disabledClass property.
      void setEnabledClass(String enabledClass)
      Set the value of the enabledClass property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setLayout(String layout)
      Set the value of the layout property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setSelectedClass(String selectedClass)
      Set the value of the selectedClass property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.
      void setUnselectedClass(String unselectedClass)
      Set the value of the unselectedClass property.

      • Methods inherited from class javax.faces.component.UISelectMany

        compareValues, getFamily, getSelectedValues, getValueBinding, getValueExpression, setSelectedValues, setValueBinding, setValueExpression, validateValue

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlSelectManyCheckbox

        public HtmlSelectManyCheckbox()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getBorder

        public int getBorder()

        Return the value of the border property.

        Contents: Width (in pixels) of the border to be drawn around the table containing the options list.

      • setBorder

        public void setBorder(int border)

        Set the value of the border property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getDisabledClass

        public String getDisabledClass()

        Return the value of the disabledClass property.

        Contents: CSS style class to apply to the rendered label on disabled options.

      • setDisabledClass

        public void setDisabledClass(String disabledClass)

        Set the value of the disabledClass property.

      • getEnabledClass

        public String getEnabledClass()

        Return the value of the enabledClass property.

        Contents: CSS style class to apply to the rendered label on enabled options.

      • setEnabledClass

        public void setEnabledClass(String enabledClass)

        Set the value of the enabledClass property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getLayout

        public String getLayout()

        Return the value of the layout property.

        Contents: Orientation of the options list to be created. Valid values are "pageDirection" (list is laid out vertically), or "lineDirection" (list is laid out horizontally). If not specified, the default value is "lineDirection".

      • setLayout

        public void setLayout(String layout)

        Set the value of the layout property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getSelectedClass

        public String getSelectedClass()

        Return the value of the selectedClass property.

        Contents: CSS style class to apply to the rendered label on selected options.

      • setSelectedClass

        public void setSelectedClass(String selectedClass)

        Set the value of the selectedClass property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getUnselectedClass

        public String getUnselectedClass()

        Return the value of the unselectedClass property.

        Contents: CSS style class to apply to the rendered label on unselected options.

      • setUnselectedClass

        public void setUnselectedClass(String unselectedClass)

        Set the value of the unselectedClass property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlSelectManyCheckbox.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlSelectManyCheckbox.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlSelectManyCheckbox.PropertyKeys>
      • javax.faces.component.html.HtmlSelectManyCheckbox.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlSelectManyCheckbox.PropertyKeys>
    Enclosing class:
    HtmlSelectManyCheckbox

    protected static enum HtmlSelectManyCheckbox.PropertyKeys
extends Enum<HtmlSelectManyCheckbox.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      border
      dir
      disabled
      disabledClass
      enabledClass
      label
      lang
      layout
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      selectedClass
      style
      styleClass
      tabindex
      title
      unselectedClass

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlSelectManyCheckbox.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectManyCheckbox.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlSelectManyCheckbox.PropertyKeys accesskey

      • border

        public static final HtmlSelectManyCheckbox.PropertyKeys border

      • dir

        public static final HtmlSelectManyCheckbox.PropertyKeys dir

      • disabled

        public static final HtmlSelectManyCheckbox.PropertyKeys disabled

      • disabledClass

        public static final HtmlSelectManyCheckbox.PropertyKeys disabledClass

      • enabledClass

        public static final HtmlSelectManyCheckbox.PropertyKeys enabledClass

      • label

        public static final HtmlSelectManyCheckbox.PropertyKeys label

      • lang

        public static final HtmlSelectManyCheckbox.PropertyKeys lang

      • layout

        public static final HtmlSelectManyCheckbox.PropertyKeys layout

      • onblur

        public static final HtmlSelectManyCheckbox.PropertyKeys onblur

      • onchange

        public static final HtmlSelectManyCheckbox.PropertyKeys onchange

      • onclick

        public static final HtmlSelectManyCheckbox.PropertyKeys onclick

      • ondblclick

        public static final HtmlSelectManyCheckbox.PropertyKeys ondblclick

      • onfocus

        public static final HtmlSelectManyCheckbox.PropertyKeys onfocus

      • onkeydown

        public static final HtmlSelectManyCheckbox.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlSelectManyCheckbox.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlSelectManyCheckbox.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlSelectManyCheckbox.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlSelectManyCheckbox.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlSelectManyCheckbox.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlSelectManyCheckbox.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlSelectManyCheckbox.PropertyKeys onmouseup

      • onselect

        public static final HtmlSelectManyCheckbox.PropertyKeys onselect

      • readonly

        public static final HtmlSelectManyCheckbox.PropertyKeys readonly

      • role

        public static final HtmlSelectManyCheckbox.PropertyKeys role

      • selectedClass

        public static final HtmlSelectManyCheckbox.PropertyKeys selectedClass

      • style

        public static final HtmlSelectManyCheckbox.PropertyKeys style

      • styleClass

        public static final HtmlSelectManyCheckbox.PropertyKeys styleClass

      • tabindex

        public static final HtmlSelectManyCheckbox.PropertyKeys tabindex

      • title

        public static final HtmlSelectManyCheckbox.PropertyKeys title

      • unselectedClass

        public static final HtmlSelectManyCheckbox.PropertyKeys unselectedClass

    • Method Detail

      • values

        public static HtmlSelectManyCheckbox.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlSelectManyCheckbox.PropertyKeys c : HtmlSelectManyCheckbox.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlSelectManyCheckbox.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlSelectManyCheckbox.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlSelectManyListbox (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlSelectManyListbox

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UISelectMany
              • javax.faces.component.html.HtmlSelectManyListbox
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlSelectManyListbox
extends UISelectMany
implements ClientBehaviorHolder

    Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.

    By default, the rendererType property must be set to "javax.faces.Listbox". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlSelectManyListbox.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UISelectMany

        COMPONENT_FAMILY, INVALID_MESSAGE_ID

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlSelectManyListbox()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      String getDisabledClass()
      Return the value of the disabledClass property.
      String getEnabledClass()
      Return the value of the enabledClass property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      int getSize()
      Return the value of the size property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setDisabledClass(String disabledClass)
      Set the value of the disabledClass property.
      void setEnabledClass(String enabledClass)
      Set the value of the enabledClass property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setSize(int size)
      Set the value of the size property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UISelectMany

        compareValues, getFamily, getSelectedValues, getValueBinding, getValueExpression, setSelectedValues, setValueBinding, setValueExpression, validateValue

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlSelectManyListbox

        public HtmlSelectManyListbox()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getDisabledClass

        public String getDisabledClass()

        Return the value of the disabledClass property.

        Contents: CSS style class to apply to the rendered label on disabled options.

      • setDisabledClass

        public void setDisabledClass(String disabledClass)

        Set the value of the disabledClass property.

      • getEnabledClass

        public String getEnabledClass()

        Return the value of the enabledClass property.

        Contents: CSS style class to apply to the rendered label on enabled options.

      • setEnabledClass

        public void setEnabledClass(String enabledClass)

        Set the value of the enabledClass property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getSize

        public int getSize()

        Return the value of the size property.

        Contents: Number of available options to be shown at all times. If not specified, all available options are shown.

      • setSize

        public void setSize(int size)

        Set the value of the size property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlSelectManyListbox.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlSelectManyListbox.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlSelectManyListbox.PropertyKeys>
      • javax.faces.component.html.HtmlSelectManyListbox.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlSelectManyListbox.PropertyKeys>
    Enclosing class:
    HtmlSelectManyListbox

    protected static enum HtmlSelectManyListbox.PropertyKeys
extends Enum<HtmlSelectManyListbox.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      dir
      disabled
      disabledClass
      enabledClass
      label
      lang
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      size
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlSelectManyListbox.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectManyListbox.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlSelectManyListbox.PropertyKeys accesskey

      • dir

        public static final HtmlSelectManyListbox.PropertyKeys dir

      • disabled

        public static final HtmlSelectManyListbox.PropertyKeys disabled

      • disabledClass

        public static final HtmlSelectManyListbox.PropertyKeys disabledClass

      • enabledClass

        public static final HtmlSelectManyListbox.PropertyKeys enabledClass

      • label

        public static final HtmlSelectManyListbox.PropertyKeys label

      • lang

        public static final HtmlSelectManyListbox.PropertyKeys lang

      • onblur

        public static final HtmlSelectManyListbox.PropertyKeys onblur

      • onchange

        public static final HtmlSelectManyListbox.PropertyKeys onchange

      • onclick

        public static final HtmlSelectManyListbox.PropertyKeys onclick

      • ondblclick

        public static final HtmlSelectManyListbox.PropertyKeys ondblclick

      • onfocus

        public static final HtmlSelectManyListbox.PropertyKeys onfocus

      • onkeydown

        public static final HtmlSelectManyListbox.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlSelectManyListbox.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlSelectManyListbox.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlSelectManyListbox.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlSelectManyListbox.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlSelectManyListbox.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlSelectManyListbox.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlSelectManyListbox.PropertyKeys onmouseup

      • onselect

        public static final HtmlSelectManyListbox.PropertyKeys onselect

      • readonly

        public static final HtmlSelectManyListbox.PropertyKeys readonly

      • role

        public static final HtmlSelectManyListbox.PropertyKeys role

      • size

        public static final HtmlSelectManyListbox.PropertyKeys size

      • style

        public static final HtmlSelectManyListbox.PropertyKeys style

      • styleClass

        public static final HtmlSelectManyListbox.PropertyKeys styleClass

      • tabindex

        public static final HtmlSelectManyListbox.PropertyKeys tabindex

      • title

        public static final HtmlSelectManyListbox.PropertyKeys title

    • Method Detail

      • values

        public static HtmlSelectManyListbox.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlSelectManyListbox.PropertyKeys c : HtmlSelectManyListbox.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlSelectManyListbox.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlSelectManyListbox.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlSelectManyMenu (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlSelectManyMenu

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UISelectMany
              • javax.faces.component.html.HtmlSelectManyMenu
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlSelectManyMenu
extends UISelectMany
implements ClientBehaviorHolder

    Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.

    By default, the rendererType property must be set to "javax.faces.Menu". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlSelectManyMenu.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UISelectMany

        COMPONENT_FAMILY, INVALID_MESSAGE_ID

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlSelectManyMenu()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      String getDisabledClass()
      Return the value of the disabledClass property.
      String getEnabledClass()
      Return the value of the enabledClass property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setDisabledClass(String disabledClass)
      Set the value of the disabledClass property.
      void setEnabledClass(String enabledClass)
      Set the value of the enabledClass property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UISelectMany

        compareValues, getFamily, getSelectedValues, getValueBinding, getValueExpression, setSelectedValues, setValueBinding, setValueExpression, validateValue

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlSelectManyMenu

        public HtmlSelectManyMenu()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getDisabledClass

        public String getDisabledClass()

        Return the value of the disabledClass property.

        Contents: CSS style class to apply to the rendered label on disabled options.

      • setDisabledClass

        public void setDisabledClass(String disabledClass)

        Set the value of the disabledClass property.

      • getEnabledClass

        public String getEnabledClass()

        Return the value of the enabledClass property.

        Contents: CSS style class to apply to the rendered label on enabled options.

      • setEnabledClass

        public void setEnabledClass(String enabledClass)

        Set the value of the enabledClass property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlSelectManyMenu.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlSelectManyMenu.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlSelectManyMenu.PropertyKeys>
      • javax.faces.component.html.HtmlSelectManyMenu.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlSelectManyMenu.PropertyKeys>
    Enclosing class:
    HtmlSelectManyMenu

    protected static enum HtmlSelectManyMenu.PropertyKeys
extends Enum<HtmlSelectManyMenu.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      dir
      disabled
      disabledClass
      enabledClass
      label
      lang
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlSelectManyMenu.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectManyMenu.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlSelectManyMenu.PropertyKeys accesskey

      • dir

        public static final HtmlSelectManyMenu.PropertyKeys dir

      • disabled

        public static final HtmlSelectManyMenu.PropertyKeys disabled

      • disabledClass

        public static final HtmlSelectManyMenu.PropertyKeys disabledClass

      • enabledClass

        public static final HtmlSelectManyMenu.PropertyKeys enabledClass

      • label

        public static final HtmlSelectManyMenu.PropertyKeys label

      • lang

        public static final HtmlSelectManyMenu.PropertyKeys lang

      • onblur

        public static final HtmlSelectManyMenu.PropertyKeys onblur

      • onchange

        public static final HtmlSelectManyMenu.PropertyKeys onchange

      • onclick

        public static final HtmlSelectManyMenu.PropertyKeys onclick

      • ondblclick

        public static final HtmlSelectManyMenu.PropertyKeys ondblclick

      • onfocus

        public static final HtmlSelectManyMenu.PropertyKeys onfocus

      • onkeydown

        public static final HtmlSelectManyMenu.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlSelectManyMenu.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlSelectManyMenu.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlSelectManyMenu.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlSelectManyMenu.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlSelectManyMenu.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlSelectManyMenu.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlSelectManyMenu.PropertyKeys onmouseup

      • onselect

        public static final HtmlSelectManyMenu.PropertyKeys onselect

      • readonly

        public static final HtmlSelectManyMenu.PropertyKeys readonly

      • role

        public static final HtmlSelectManyMenu.PropertyKeys role

      • style

        public static final HtmlSelectManyMenu.PropertyKeys style

      • styleClass

        public static final HtmlSelectManyMenu.PropertyKeys styleClass

      • tabindex

        public static final HtmlSelectManyMenu.PropertyKeys tabindex

      • title

        public static final HtmlSelectManyMenu.PropertyKeys title

    • Method Detail

      • values

        public static HtmlSelectManyMenu.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlSelectManyMenu.PropertyKeys c : HtmlSelectManyMenu.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlSelectManyMenu.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlSelectManyMenu.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlSelectOneListbox (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlSelectOneListbox

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UISelectOne
              • javax.faces.component.html.HtmlSelectOneListbox
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlSelectOneListbox
extends UISelectOne
implements ClientBehaviorHolder

    Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.

    By default, the rendererType property must be set to "javax.faces.Listbox". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlSelectOneListbox.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UISelectOne

        COMPONENT_FAMILY, INVALID_MESSAGE_ID

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlSelectOneListbox()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      String getDisabledClass()
      Return the value of the disabledClass property.
      String getEnabledClass()
      Return the value of the enabledClass property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      int getSize()
      Return the value of the size property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setDisabledClass(String disabledClass)
      Set the value of the disabledClass property.
      void setEnabledClass(String enabledClass)
      Set the value of the enabledClass property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setSize(int size)
      Set the value of the size property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UISelectOne

        getFamily, validateValue

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlSelectOneListbox

        public HtmlSelectOneListbox()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getDisabledClass

        public String getDisabledClass()

        Return the value of the disabledClass property.

        Contents: CSS style class to apply to the rendered label on disabled options.

      • setDisabledClass

        public void setDisabledClass(String disabledClass)

        Set the value of the disabledClass property.

      • getEnabledClass

        public String getEnabledClass()

        Return the value of the enabledClass property.

        Contents: CSS style class to apply to the rendered label on enabled options.

      • setEnabledClass

        public void setEnabledClass(String enabledClass)

        Set the value of the enabledClass property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getSize

        public int getSize()

        Return the value of the size property.

        Contents: Number of available options to be shown at all times. If not specified, all available options are shown.

      • setSize

        public void setSize(int size)

        Set the value of the size property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlSelectOneListbox.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlSelectOneListbox.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlSelectOneListbox.PropertyKeys>
      • javax.faces.component.html.HtmlSelectOneListbox.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlSelectOneListbox.PropertyKeys>
    Enclosing class:
    HtmlSelectOneListbox

    protected static enum HtmlSelectOneListbox.PropertyKeys
extends Enum<HtmlSelectOneListbox.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      dir
      disabled
      disabledClass
      enabledClass
      label
      lang
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      size
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlSelectOneListbox.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectOneListbox.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlSelectOneListbox.PropertyKeys accesskey

      • dir

        public static final HtmlSelectOneListbox.PropertyKeys dir

      • disabled

        public static final HtmlSelectOneListbox.PropertyKeys disabled

      • disabledClass

        public static final HtmlSelectOneListbox.PropertyKeys disabledClass

      • enabledClass

        public static final HtmlSelectOneListbox.PropertyKeys enabledClass

      • label

        public static final HtmlSelectOneListbox.PropertyKeys label

      • lang

        public static final HtmlSelectOneListbox.PropertyKeys lang

      • onblur

        public static final HtmlSelectOneListbox.PropertyKeys onblur

      • onchange

        public static final HtmlSelectOneListbox.PropertyKeys onchange

      • onclick

        public static final HtmlSelectOneListbox.PropertyKeys onclick

      • ondblclick

        public static final HtmlSelectOneListbox.PropertyKeys ondblclick

      • onfocus

        public static final HtmlSelectOneListbox.PropertyKeys onfocus

      • onkeydown

        public static final HtmlSelectOneListbox.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlSelectOneListbox.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlSelectOneListbox.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlSelectOneListbox.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlSelectOneListbox.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlSelectOneListbox.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlSelectOneListbox.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlSelectOneListbox.PropertyKeys onmouseup

      • onselect

        public static final HtmlSelectOneListbox.PropertyKeys onselect

      • readonly

        public static final HtmlSelectOneListbox.PropertyKeys readonly

      • role

        public static final HtmlSelectOneListbox.PropertyKeys role

      • size

        public static final HtmlSelectOneListbox.PropertyKeys size

      • style

        public static final HtmlSelectOneListbox.PropertyKeys style

      • styleClass

        public static final HtmlSelectOneListbox.PropertyKeys styleClass

      • tabindex

        public static final HtmlSelectOneListbox.PropertyKeys tabindex

      • title

        public static final HtmlSelectOneListbox.PropertyKeys title

    • Method Detail

      • values

        public static HtmlSelectOneListbox.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlSelectOneListbox.PropertyKeys c : HtmlSelectOneListbox.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlSelectOneListbox.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlSelectOneListbox.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlSelectOneMenu (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlSelectOneMenu

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UISelectOne
              • javax.faces.component.html.HtmlSelectOneMenu
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlSelectOneMenu
extends UISelectOne
implements ClientBehaviorHolder

    Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.

    By default, the rendererType property must be set to "javax.faces.Menu". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlSelectOneMenu.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UISelectOne

        COMPONENT_FAMILY, INVALID_MESSAGE_ID

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlSelectOneMenu()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      String getDisabledClass()
      Return the value of the disabledClass property.
      String getEnabledClass()
      Return the value of the enabledClass property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setDisabledClass(String disabledClass)
      Set the value of the disabledClass property.
      void setEnabledClass(String enabledClass)
      Set the value of the enabledClass property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UISelectOne

        getFamily, validateValue

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlSelectOneMenu

        public HtmlSelectOneMenu()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getDisabledClass

        public String getDisabledClass()

        Return the value of the disabledClass property.

        Contents: CSS style class to apply to the rendered label on disabled options.

      • setDisabledClass

        public void setDisabledClass(String disabledClass)

        Set the value of the disabledClass property.

      • getEnabledClass

        public String getEnabledClass()

        Return the value of the enabledClass property.

        Contents: CSS style class to apply to the rendered label on enabled options.

      • setEnabledClass

        public void setEnabledClass(String enabledClass)

        Set the value of the enabledClass property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlSelectOneMenu.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlSelectOneMenu.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlSelectOneMenu.PropertyKeys>
      • javax.faces.component.html.HtmlSelectOneMenu.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlSelectOneMenu.PropertyKeys>
    Enclosing class:
    HtmlSelectOneMenu

    protected static enum HtmlSelectOneMenu.PropertyKeys
extends Enum<HtmlSelectOneMenu.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      dir
      disabled
      disabledClass
      enabledClass
      label
      lang
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlSelectOneMenu.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectOneMenu.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlSelectOneMenu.PropertyKeys accesskey

      • dir

        public static final HtmlSelectOneMenu.PropertyKeys dir

      • disabled

        public static final HtmlSelectOneMenu.PropertyKeys disabled

      • disabledClass

        public static final HtmlSelectOneMenu.PropertyKeys disabledClass

      • enabledClass

        public static final HtmlSelectOneMenu.PropertyKeys enabledClass

      • label

        public static final HtmlSelectOneMenu.PropertyKeys label

      • lang

        public static final HtmlSelectOneMenu.PropertyKeys lang

      • onblur

        public static final HtmlSelectOneMenu.PropertyKeys onblur

      • onchange

        public static final HtmlSelectOneMenu.PropertyKeys onchange

      • onclick

        public static final HtmlSelectOneMenu.PropertyKeys onclick

      • ondblclick

        public static final HtmlSelectOneMenu.PropertyKeys ondblclick

      • onfocus

        public static final HtmlSelectOneMenu.PropertyKeys onfocus

      • onkeydown

        public static final HtmlSelectOneMenu.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlSelectOneMenu.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlSelectOneMenu.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlSelectOneMenu.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlSelectOneMenu.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlSelectOneMenu.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlSelectOneMenu.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlSelectOneMenu.PropertyKeys onmouseup

      • onselect

        public static final HtmlSelectOneMenu.PropertyKeys onselect

      • readonly

        public static final HtmlSelectOneMenu.PropertyKeys readonly

      • role

        public static final HtmlSelectOneMenu.PropertyKeys role

      • style

        public static final HtmlSelectOneMenu.PropertyKeys style

      • styleClass

        public static final HtmlSelectOneMenu.PropertyKeys styleClass

      • tabindex

        public static final HtmlSelectOneMenu.PropertyKeys tabindex

      • title

        public static final HtmlSelectOneMenu.PropertyKeys title

    • Method Detail

      • values

        public static HtmlSelectOneMenu.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlSelectOneMenu.PropertyKeys c : HtmlSelectOneMenu.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlSelectOneMenu.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlSelectOneMenu.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


HtmlSelectOneRadio (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.html

Class HtmlSelectOneRadio

  • java.lang.Object
    • javax.faces.component.UIComponent
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIOutput
          • javax.faces.component.UIInput
            • javax.faces.component.UISelectOne
              • javax.faces.component.html.HtmlSelectOneRadio
  • All Implemented Interfaces:
    EventListener, ClientBehaviorHolder, EditableValueHolder, PartialStateHolder, StateHolder, TransientStateHolder, ValueHolder, ComponentSystemEventListener, FacesListener, SystemEventListenerHolder

    public class HtmlSelectOneRadio
extends UISelectOne
implements ClientBehaviorHolder

    Represents a single-selection component that is rendered as a set of HTML input elements of type radio.

    By default, the rendererType property must be set to "javax.faces.Radio". This value can be changed by calling the setRendererType() method.

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class and Description
      protected static class  | HtmlSelectOneRadio.PropertyKeys

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String COMPONENT_TYPE
      The standard component type for this component.

      • Fields inherited from class javax.faces.component.UISelectOne

        COMPONENT_FAMILY, INVALID_MESSAGE_ID

      • Fields inherited from class javax.faces.component.UIInput

        CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID, VALIDATE_EMPTY_FIELDS_PARAM_NAME

      • Fields inherited from class javax.faces.component.UIComponent

        ATTRS_WITH_DECLARED_DEFAULT_VALUES, BEANINFO_KEY, bindings, COMPOSITE_COMPONENT_TYPE_KEY, COMPOSITE_FACET_NAME, CURRENT_COMPONENT, CURRENT_COMPOSITE_COMPONENT, FACETS_KEY, HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME, VIEW_LOCATION_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      HtmlSelectOneRadio()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAccesskey()
      Return the value of the accesskey property.
      int getBorder()
      Return the value of the border property.
      String getDefaultEventName()

      This is a default implementation of ClientBehaviorHolder.getDefaultEventName().
      String getDir()
      Return the value of the dir property.
      String getDisabledClass()
      Return the value of the disabledClass property.
      String getEnabledClass()
      Return the value of the enabledClass property.
      Collection<String> getEventNames()

      This is a default implementation of ClientBehaviorHolder.getEventNames().
      String getLabel()
      Return the value of the label property.
      String getLang()
      Return the value of the lang property.
      String getLayout()
      Return the value of the layout property.
      String getOnblur()
      Return the value of the onblur property.
      String getOnchange()
      Return the value of the onchange property.
      String getOnclick()
      Return the value of the onclick property.
      String getOndblclick()
      Return the value of the ondblclick property.
      String getOnfocus()
      Return the value of the onfocus property.
      String getOnkeydown()
      Return the value of the onkeydown property.
      String getOnkeypress()
      Return the value of the onkeypress property.
      String getOnkeyup()
      Return the value of the onkeyup property.
      String getOnmousedown()
      Return the value of the onmousedown property.
      String getOnmousemove()
      Return the value of the onmousemove property.
      String getOnmouseout()
      Return the value of the onmouseout property.
      String getOnmouseover()
      Return the value of the onmouseover property.
      String getOnmouseup()
      Return the value of the onmouseup property.
      String getOnselect()
      Return the value of the onselect property.
      String getRole()
      Return the value of the role property.
      String getStyle()
      Return the value of the style property.
      String getStyleClass()
      Return the value of the styleClass property.
      String getTabindex()
      Return the value of the tabindex property.
      String getTitle()
      Return the value of the title property.
      boolean isDisabled()
      Return the value of the disabled property.
      boolean isReadonly()
      Return the value of the readonly property.
      void setAccesskey(String accesskey)
      Set the value of the accesskey property.
      void setBorder(int border)
      Set the value of the border property.
      void setDir(String dir)
      Set the value of the dir property.
      void setDisabled(boolean disabled)
      Set the value of the disabled property.
      void setDisabledClass(String disabledClass)
      Set the value of the disabledClass property.
      void setEnabledClass(String enabledClass)
      Set the value of the enabledClass property.
      void setLabel(String label)
      Set the value of the label property.
      void setLang(String lang)
      Set the value of the lang property.
      void setLayout(String layout)
      Set the value of the layout property.
      void setOnblur(String onblur)
      Set the value of the onblur property.
      void setOnchange(String onchange)
      Set the value of the onchange property.
      void setOnclick(String onclick)
      Set the value of the onclick property.
      void setOndblclick(String ondblclick)
      Set the value of the ondblclick property.
      void setOnfocus(String onfocus)
      Set the value of the onfocus property.
      void setOnkeydown(String onkeydown)
      Set the value of the onkeydown property.
      void setOnkeypress(String onkeypress)
      Set the value of the onkeypress property.
      void setOnkeyup(String onkeyup)
      Set the value of the onkeyup property.
      void setOnmousedown(String onmousedown)
      Set the value of the onmousedown property.
      void setOnmousemove(String onmousemove)
      Set the value of the onmousemove property.
      void setOnmouseout(String onmouseout)
      Set the value of the onmouseout property.
      void setOnmouseover(String onmouseover)
      Set the value of the onmouseover property.
      void setOnmouseup(String onmouseup)
      Set the value of the onmouseup property.
      void setOnselect(String onselect)
      Set the value of the onselect property.
      void setReadonly(boolean readonly)
      Set the value of the readonly property.
      void setRole(String role)
      Set the value of the role property.
      void setStyle(String style)
      Set the value of the style property.
      void setStyleClass(String styleClass)
      Set the value of the styleClass property.
      void setTabindex(String tabindex)
      Set the value of the tabindex property.
      void setTitle(String title)
      Set the value of the title property.

      • Methods inherited from class javax.faces.component.UISelectOne

        getFamily, validateValue

      • Methods inherited from class javax.faces.component.UIInput

        addValidator, addValueChangeListener, clearInitialState, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValue, getValueChangeListener, getValueChangeListeners, isEmpty, isImmediate, isLocalValueSet, isRequired, isValid, markInitialState, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate

      • Methods inherited from class javax.faces.component.UIOutput

        getConverter, getLocalValue, setConverter

      • Methods inherited from class javax.faces.component.UIComponentBase

        addClientBehavior, addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientBehaviors, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getListenersForEventClass, getParent, getPassThroughAttributes, getRenderer, getRendererType, getRendersChildren, getValueBinding, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, subscribeToEvent, unsubscribeFromEvent

      • Methods inherited from class javax.faces.component.UIComponent

        encodeAll, getClientId, getCompositeComponentParent, getContainerClientId, getCurrentComponent, getCurrentCompositeComponent, getNamingContainer, getPassThroughAttributes, getResourceBundleMap, getStateHelper, getStateHelper, getTransientStateHelper, getTransientStateHelper, getValueExpression, initialStateMarked, isCompositeComponent, isInView, isVisitable, popComponentFromEL, processEvent, pushComponentToEL, restoreTransientState, saveTransientState, setInView, setValueExpression, visitTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.faces.component.behavior.ClientBehaviorHolder

        addClientBehavior, getClientBehaviors

      • Methods inherited from interface javax.faces.component.ValueHolder

        getConverter, getLocalValue, setConverter

    • Field Detail

      • COMPONENT_TYPE

        public static final String COMPONENT_TYPE

        The standard component type for this component.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HtmlSelectOneRadio

        public HtmlSelectOneRadio()

    • Method Detail

      • getAccesskey

        public String getAccesskey()

        Return the value of the accesskey property.

        Contents: Access key that, when pressed, transfers focus to this element.

      • setAccesskey

        public void setAccesskey(String accesskey)

        Set the value of the accesskey property.

      • getBorder

        public int getBorder()

        Return the value of the border property.

        Contents: Width (in pixels) of the border to be drawn around the table containing the options list.

      • setBorder

        public void setBorder(int border)

        Set the value of the border property.

      • getDir

        public String getDir()

        Return the value of the dir property.

        Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left). These attributes are case sensitive when rendering to XHTML, so care must be taken to have the correct case.

      • setDir

        public void setDir(String dir)

        Set the value of the dir property.

      • isDisabled

        public boolean isDisabled()

        Return the value of the disabled property.

        Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the value of the disabled property.

      • getDisabledClass

        public String getDisabledClass()

        Return the value of the disabledClass property.

        Contents: CSS style class to apply to the rendered label on disabled options.

      • setDisabledClass

        public void setDisabledClass(String disabledClass)

        Set the value of the disabledClass property.

      • getEnabledClass

        public String getEnabledClass()

        Return the value of the enabledClass property.

        Contents: CSS style class to apply to the rendered label on enabled options.

      • setEnabledClass

        public void setEnabledClass(String enabledClass)

        Set the value of the enabledClass property.

      • getLabel

        public String getLabel()

        Return the value of the label property.

        Contents: A localized user presentable name for this component.

      • setLabel

        public void setLabel(String label)

        Set the value of the label property.

      • getLang

        public String getLang()

        Return the value of the lang property.

        Contents: Code describing the language used in the generated markup for this component.

      • setLang

        public void setLang(String lang)

        Set the value of the lang property.

      • getLayout

        public String getLayout()

        Return the value of the layout property.

        Contents: Orientation of the options list to be created. Valid values are "pageDirection" (list is laid out vertically), or "lineDirection" (list is laid out horizontally). If not specified, the default value is "lineDirection".

      • setLayout

        public void setLayout(String layout)

        Set the value of the layout property.

      • getOnblur

        public String getOnblur()

        Return the value of the onblur property.

        Contents: Javascript code executed when this element loses focus.

      • setOnblur

        public void setOnblur(String onblur)

        Set the value of the onblur property.

      • getOnchange

        public String getOnchange()

        Return the value of the onchange property.

        Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

      • setOnchange

        public void setOnchange(String onchange)

        Set the value of the onchange property.

      • getOnclick

        public String getOnclick()

        Return the value of the onclick property.

        Contents: Javascript code executed when a pointer button is clicked over this element.

      • setOnclick

        public void setOnclick(String onclick)

        Set the value of the onclick property.

      • getOndblclick

        public String getOndblclick()

        Return the value of the ondblclick property.

        Contents: Javascript code executed when a pointer button is double clicked over this element.

      • setOndblclick

        public void setOndblclick(String ondblclick)

        Set the value of the ondblclick property.

      • getOnfocus

        public String getOnfocus()

        Return the value of the onfocus property.

        Contents: Javascript code executed when this element receives focus.

      • setOnfocus

        public void setOnfocus(String onfocus)

        Set the value of the onfocus property.

      • getOnkeydown

        public String getOnkeydown()

        Return the value of the onkeydown property.

        Contents: Javascript code executed when a key is pressed down over this element.

      • setOnkeydown

        public void setOnkeydown(String onkeydown)

        Set the value of the onkeydown property.

      • getOnkeypress

        public String getOnkeypress()

        Return the value of the onkeypress property.

        Contents: Javascript code executed when a key is pressed and released over this element.

      • setOnkeypress

        public void setOnkeypress(String onkeypress)

        Set the value of the onkeypress property.

      • getOnkeyup

        public String getOnkeyup()

        Return the value of the onkeyup property.

        Contents: Javascript code executed when a key is released over this element.

      • setOnkeyup

        public void setOnkeyup(String onkeyup)

        Set the value of the onkeyup property.

      • getOnmousedown

        public String getOnmousedown()

        Return the value of the onmousedown property.

        Contents: Javascript code executed when a pointer button is pressed down over this element.

      • setOnmousedown

        public void setOnmousedown(String onmousedown)

        Set the value of the onmousedown property.

      • getOnmousemove

        public String getOnmousemove()

        Return the value of the onmousemove property.

        Contents: Javascript code executed when a pointer button is moved within this element.

      • setOnmousemove

        public void setOnmousemove(String onmousemove)

        Set the value of the onmousemove property.

      • getOnmouseout

        public String getOnmouseout()

        Return the value of the onmouseout property.

        Contents: Javascript code executed when a pointer button is moved away from this element.

      • setOnmouseout

        public void setOnmouseout(String onmouseout)

        Set the value of the onmouseout property.

      • getOnmouseover

        public String getOnmouseover()

        Return the value of the onmouseover property.

        Contents: Javascript code executed when a pointer button is moved onto this element.

      • setOnmouseover

        public void setOnmouseover(String onmouseover)

        Set the value of the onmouseover property.

      • getOnmouseup

        public String getOnmouseup()

        Return the value of the onmouseup property.

        Contents: Javascript code executed when a pointer button is released over this element.

      • setOnmouseup

        public void setOnmouseup(String onmouseup)

        Set the value of the onmouseup property.

      • getOnselect

        public String getOnselect()

        Return the value of the onselect property.

        Contents: Javascript code executed when text within this element is selected by the user.

      • setOnselect

        public void setOnselect(String onselect)

        Set the value of the onselect property.

      • isReadonly

        public boolean isReadonly()

        Return the value of the readonly property.

        Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

      • setReadonly

        public void setReadonly(boolean readonly)

        Set the value of the readonly property.

      • getRole

        public String getRole()

        Return the value of the role property.

        Contents:

        Per the WAI-ARIA spec and its relationship to HTML5 (Section title ARIA Role Attriubute), every HTML element may have a "role" attribute whose value must be passed through unmodified on the element on which it is declared in the final rendered markup. The attribute, if specified, must have a value that is a string literal that is, or an EL Expression that evaluates to, a set of space-separated tokens representing the various WAI-ARIA roles that the element belongs to.

        It is the page author's responsibility to ensure that the user agent is capable of correctly interpreting the value of this attribute.

      • setRole

        public void setRole(String role)

        Set the value of the role property.

      • getStyle

        public String getStyle()

        Return the value of the style property.

        Contents: CSS style(s) to be applied when this component is rendered.

      • setStyle

        public void setStyle(String style)

        Set the value of the style property.

      • getStyleClass

        public String getStyleClass()

        Return the value of the styleClass property.

        Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

      • setStyleClass

        public void setStyleClass(String styleClass)

        Set the value of the styleClass property.

      • getTabindex

        public String getTabindex()

        Return the value of the tabindex property.

        Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

      • setTabindex

        public void setTabindex(String tabindex)

        Set the value of the tabindex property.

      • getTitle

        public String getTitle()

        Return the value of the title property.

        Contents: Advisory title information about markup elements generated for this component.

      • setTitle

        public void setTitle(String title)

        Set the value of the title property.

      • getEventNames

        public Collection<String> getEventNames()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getEventNames(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must override this method to return a non-Empty Collection of the client event names that the component supports.

        Specified by:
        getEventNames in interface ClientBehaviorHolder
        Overrides:
        getEventNames in class UIComponentBase

      • getDefaultEventName

        public String getDefaultEventName()
        Description copied from class: UIComponentBase

        This is a default implementation of ClientBehaviorHolder.getDefaultEventName(). UIComponent does not implement the ClientBehaviorHolder interface, but provides default implementations for the methods defined by ClientBehaviorHolder to simplify subclass implementations. Subclasses that wish to support the ClientBehaviorHolder contract must declare that the subclass implements ClientBehaviorHolder, and must provide an implementation of ClientBehaviorHolder.getEventNames().

        Specified by:
        getDefaultEventName in interface ClientBehaviorHolder
        Overrides:
        getDefaultEventName in class UIComponentBase
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HtmlSelectOneRadio.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.html

Enum HtmlSelectOneRadio.PropertyKeys

  • java.lang.Object
    • java.lang.Enum<HtmlSelectOneRadio.PropertyKeys>
      • javax.faces.component.html.HtmlSelectOneRadio.PropertyKeys
  • All Implemented Interfaces:
    Serializable, Comparable<HtmlSelectOneRadio.PropertyKeys>
    Enclosing class:
    HtmlSelectOneRadio

    protected static enum HtmlSelectOneRadio.PropertyKeys
extends Enum<HtmlSelectOneRadio.PropertyKeys>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      accesskey
      border
      dir
      disabled
      disabledClass
      enabledClass
      label
      lang
      layout
      onblur
      onchange
      onclick
      ondblclick
      onfocus
      onkeydown
      onkeypress
      onkeyup
      onmousedown
      onmousemove
      onmouseout
      onmouseover
      onmouseup
      onselect
      readonly
      role
      style
      styleClass
      tabindex
      title

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      static HtmlSelectOneRadio.PropertyKeys valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectOneRadio.PropertyKeys[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • accesskey

        public static final HtmlSelectOneRadio.PropertyKeys accesskey

      • border

        public static final HtmlSelectOneRadio.PropertyKeys border

      • dir

        public static final HtmlSelectOneRadio.PropertyKeys dir

      • disabled

        public static final HtmlSelectOneRadio.PropertyKeys disabled

      • disabledClass

        public static final HtmlSelectOneRadio.PropertyKeys disabledClass

      • enabledClass

        public static final HtmlSelectOneRadio.PropertyKeys enabledClass

      • label

        public static final HtmlSelectOneRadio.PropertyKeys label

      • lang

        public static final HtmlSelectOneRadio.PropertyKeys lang

      • layout

        public static final HtmlSelectOneRadio.PropertyKeys layout

      • onblur

        public static final HtmlSelectOneRadio.PropertyKeys onblur

      • onchange

        public static final HtmlSelectOneRadio.PropertyKeys onchange

      • onclick

        public static final HtmlSelectOneRadio.PropertyKeys onclick

      • ondblclick

        public static final HtmlSelectOneRadio.PropertyKeys ondblclick

      • onfocus

        public static final HtmlSelectOneRadio.PropertyKeys onfocus

      • onkeydown

        public static final HtmlSelectOneRadio.PropertyKeys onkeydown

      • onkeypress

        public static final HtmlSelectOneRadio.PropertyKeys onkeypress

      • onkeyup

        public static final HtmlSelectOneRadio.PropertyKeys onkeyup

      • onmousedown

        public static final HtmlSelectOneRadio.PropertyKeys onmousedown

      • onmousemove

        public static final HtmlSelectOneRadio.PropertyKeys onmousemove

      • onmouseout

        public static final HtmlSelectOneRadio.PropertyKeys onmouseout

      • onmouseover

        public static final HtmlSelectOneRadio.PropertyKeys onmouseover

      • onmouseup

        public static final HtmlSelectOneRadio.PropertyKeys onmouseup

      • onselect

        public static final HtmlSelectOneRadio.PropertyKeys onselect

      • readonly

        public static final HtmlSelectOneRadio.PropertyKeys readonly

      • role

        public static final HtmlSelectOneRadio.PropertyKeys role

      • style

        public static final HtmlSelectOneRadio.PropertyKeys style

      • styleClass

        public static final HtmlSelectOneRadio.PropertyKeys styleClass

      • tabindex

        public static final HtmlSelectOneRadio.PropertyKeys tabindex

      • title

        public static final HtmlSelectOneRadio.PropertyKeys title

    • Method Detail

      • values

        public static HtmlSelectOneRadio.PropertyKeys[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (HtmlSelectOneRadio.PropertyKeys c : HtmlSelectOneRadio.PropertyKeys.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static HtmlSelectOneRadio.PropertyKeys valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • toString

        public String toString()
        Overrides:
        toString in class Enum<HtmlSelectOneRadio.PropertyKeys>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


javax.faces.component.html (Java(TM) EE 7 Specification APIs)

javax.faces.component.html

Classes

  • HtmlBody
  • HtmlColumn
  • HtmlCommandButton
  • HtmlCommandLink
  • HtmlDataTable
  • HtmlDoctype
  • HtmlForm
  • HtmlGraphicImage
  • HtmlHead
  • HtmlInputFile
  • HtmlInputHidden
  • HtmlInputSecret
  • HtmlInputText
  • HtmlInputTextarea
  • HtmlMessage
  • HtmlMessages
  • HtmlOutcomeTargetButton
  • HtmlOutcomeTargetLink
  • HtmlOutputFormat
  • HtmlOutputLabel
  • HtmlOutputLink
  • HtmlOutputText
  • HtmlPanelGrid
  • HtmlPanelGroup
  • HtmlSelectBooleanCheckbox
  • HtmlSelectManyCheckbox
  • HtmlSelectManyListbox
  • HtmlSelectManyMenu
  • HtmlSelectOneListbox
  • HtmlSelectOneMenu
  • HtmlSelectOneRadio

Enums

  • HtmlBody.PropertyKeys
  • HtmlColumn.PropertyKeys
  • HtmlCommandButton.PropertyKeys
  • HtmlCommandLink.PropertyKeys
  • HtmlDataTable.PropertyKeys
  • HtmlDoctype.PropertyKeys
  • HtmlForm.PropertyKeys
  • HtmlGraphicImage.PropertyKeys
  • HtmlHead.PropertyKeys
  • HtmlInputFile.PropertyKeys
  • HtmlInputHidden.PropertyKeys
  • HtmlInputSecret.PropertyKeys
  • HtmlInputText.PropertyKeys
  • HtmlInputTextarea.PropertyKeys
  • HtmlMessage.PropertyKeys
  • HtmlMessages.PropertyKeys
  • HtmlOutcomeTargetButton.PropertyKeys
  • HtmlOutcomeTargetLink.PropertyKeys
  • HtmlOutputFormat.PropertyKeys
  • HtmlOutputLabel.PropertyKeys
  • HtmlOutputLink.PropertyKeys
  • HtmlOutputText.PropertyKeys
  • HtmlPanelGrid.PropertyKeys
  • HtmlPanelGroup.PropertyKeys
  • HtmlSelectBooleanCheckbox.PropertyKeys
  • HtmlSelectManyCheckbox.PropertyKeys
  • HtmlSelectManyListbox.PropertyKeys
  • HtmlSelectManyMenu.PropertyKeys
  • HtmlSelectOneListbox.PropertyKeys
  • HtmlSelectOneMenu.PropertyKeys
  • HtmlSelectOneRadio.PropertyKeys


javax.faces.component.html (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.component.html

Specialized user interface component classes for HTML.

See: Description

  • Class Summary
    Class Description
    HtmlBody
    NONE
    HtmlColumn
    Represents a column that will be rendered in an HTML table element.
    HtmlCommandButton
    Represents an HTML input element for a button of type submit or reset.
    HtmlCommandLink
    Represents an HTML a element for a hyperlink that acts like a submit button.
    HtmlDataTable
    Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
    HtmlDoctype
    NONE
    HtmlForm
    Represents an HTML form element.
    HtmlGraphicImage
    Represents an HTML img element, used to retrieve and render a graphical image.
    HtmlHead
    NONE
    HtmlInputFile
    Represents an HTML input element of type file.
    HtmlInputHidden
    Represents an HTML input element of type hidden.
    HtmlInputSecret
    Represents an HTML input element of type password.
    HtmlInputText
    Represents an HTML input element of type text.
    HtmlInputTextarea
    Represents an HTML textarea element.
    HtmlMessage
    By default, the rendererType property must be set to "javax.faces.Message".
    HtmlMessages
    By default, the rendererType property must be set to "javax.faces.Messages".
    HtmlOutcomeTargetButton
    Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
    HtmlOutcomeTargetLink
    Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
    HtmlOutputFormat
    Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
    HtmlOutputLabel
    Represents an HTML label element, used to define an accessible label for a corresponding input element.
    HtmlOutputLink
    Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
    HtmlOutputText
    Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
    HtmlPanelGrid
    Renders child components in a table, starting a new row after the specified number of columns.
    HtmlPanelGroup
    Causes all child components of this component to be rendered.
    HtmlSelectBooleanCheckbox
    Represents an HTML input element of type checkbox.
    HtmlSelectManyCheckbox
    Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
    HtmlSelectManyListbox
    Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
    HtmlSelectManyMenu
    Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
    HtmlSelectOneListbox
    Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
    HtmlSelectOneMenu
    Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
    HtmlSelectOneRadio
    Represents a single-selection component that is rendered as a set of HTML input elements of type radio.
  • Enum Summary
    Enum Description
    HtmlBody.PropertyKeys
    HtmlColumn.PropertyKeys
    HtmlCommandButton.PropertyKeys
    HtmlCommandLink.PropertyKeys
    HtmlDataTable.PropertyKeys
    HtmlDoctype.PropertyKeys
    HtmlForm.PropertyKeys
    HtmlGraphicImage.PropertyKeys
    HtmlHead.PropertyKeys
    HtmlInputFile.PropertyKeys
    HtmlInputHidden.PropertyKeys
    HtmlInputSecret.PropertyKeys
    HtmlInputText.PropertyKeys
    HtmlInputTextarea.PropertyKeys
    HtmlMessage.PropertyKeys
    HtmlMessages.PropertyKeys
    HtmlOutcomeTargetButton.PropertyKeys
    HtmlOutcomeTargetLink.PropertyKeys
    HtmlOutputFormat.PropertyKeys
    HtmlOutputLabel.PropertyKeys
    HtmlOutputLink.PropertyKeys
    HtmlOutputText.PropertyKeys
    HtmlPanelGrid.PropertyKeys
    HtmlPanelGroup.PropertyKeys
    HtmlSelectBooleanCheckbox.PropertyKeys
    HtmlSelectManyCheckbox.PropertyKeys
    HtmlSelectManyListbox.PropertyKeys
    HtmlSelectManyMenu.PropertyKeys
    HtmlSelectOneListbox.PropertyKeys
    HtmlSelectOneMenu.PropertyKeys
    HtmlSelectOneRadio.PropertyKeys

Package javax.faces.component.html Description

Specialized user interface component classes for HTML.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.component.html Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.component.html

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.component.UIComponent (implements javax.faces.event.ComponentSystemEventListener, javax.faces.component.PartialStateHolder, javax.faces.event.SystemEventListenerHolder, javax.faces.component.TransientStateHolder)
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIColumn
          • javax.faces.component.html.HtmlColumn
        • javax.faces.component.UICommand (implements javax.faces.component.ActionSource2)
          • javax.faces.component.html.HtmlCommandButton (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.html.HtmlCommandLink (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIData (implements javax.faces.component.NamingContainer, javax.faces.component.UniqueIdVendor)
          • javax.faces.component.html.HtmlDataTable (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIForm (implements javax.faces.component.NamingContainer, javax.faces.component.UniqueIdVendor)
          • javax.faces.component.html.HtmlForm (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIGraphic
          • javax.faces.component.html.HtmlGraphicImage (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIMessage
          • javax.faces.component.html.HtmlMessage
        • javax.faces.component.UIMessages
          • javax.faces.component.html.HtmlMessages
        • javax.faces.component.UIOutput (implements javax.faces.component.ValueHolder)
          • javax.faces.component.html.HtmlBody (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.html.HtmlDoctype
          • javax.faces.component.html.HtmlHead
          • javax.faces.component.html.HtmlOutputFormat
          • javax.faces.component.html.HtmlOutputLabel (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.html.HtmlOutputLink (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.html.HtmlOutputText
          • javax.faces.component.UIInput (implements javax.faces.component.EditableValueHolder)
            • javax.faces.component.html.HtmlInputFile (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.html.HtmlInputHidden
            • javax.faces.component.html.HtmlInputSecret (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.html.HtmlInputText (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.html.HtmlInputTextarea (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.UISelectBoolean
              • javax.faces.component.html.HtmlSelectBooleanCheckbox (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.UISelectMany
              • javax.faces.component.html.HtmlSelectManyCheckbox (implements javax.faces.component.behavior.ClientBehaviorHolder)
              • javax.faces.component.html.HtmlSelectManyListbox (implements javax.faces.component.behavior.ClientBehaviorHolder)
              • javax.faces.component.html.HtmlSelectManyMenu (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.UISelectOne
              • javax.faces.component.html.HtmlSelectOneListbox (implements javax.faces.component.behavior.ClientBehaviorHolder)
              • javax.faces.component.html.HtmlSelectOneMenu (implements javax.faces.component.behavior.ClientBehaviorHolder)
              • javax.faces.component.html.HtmlSelectOneRadio (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.UIOutcomeTarget
            • javax.faces.component.html.HtmlOutcomeTargetButton (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.html.HtmlOutcomeTargetLink (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIPanel
          • javax.faces.component.html.HtmlPanelGrid (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.html.HtmlPanelGroup (implements javax.faces.component.behavior.ClientBehaviorHolder)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.faces.component.html.HtmlSelectOneRadio.PropertyKeys
      • javax.faces.component.html.HtmlSelectOneMenu.PropertyKeys
      • javax.faces.component.html.HtmlSelectOneListbox.PropertyKeys
      • javax.faces.component.html.HtmlSelectManyMenu.PropertyKeys
      • javax.faces.component.html.HtmlSelectManyListbox.PropertyKeys
      • javax.faces.component.html.HtmlSelectManyCheckbox.PropertyKeys
      • javax.faces.component.html.HtmlSelectBooleanCheckbox.PropertyKeys
      • javax.faces.component.html.HtmlPanelGroup.PropertyKeys
      • javax.faces.component.html.HtmlPanelGrid.PropertyKeys
      • javax.faces.component.html.HtmlOutputText.PropertyKeys
      • javax.faces.component.html.HtmlOutputLink.PropertyKeys
      • javax.faces.component.html.HtmlOutputLabel.PropertyKeys
      • javax.faces.component.html.HtmlOutputFormat.PropertyKeys
      • javax.faces.component.html.HtmlOutcomeTargetLink.PropertyKeys
      • javax.faces.component.html.HtmlOutcomeTargetButton.PropertyKeys
      • javax.faces.component.html.HtmlMessages.PropertyKeys
      • javax.faces.component.html.HtmlMessage.PropertyKeys
      • javax.faces.component.html.HtmlInputTextarea.PropertyKeys
      • javax.faces.component.html.HtmlInputText.PropertyKeys
      • javax.faces.component.html.HtmlInputSecret.PropertyKeys
      • javax.faces.component.html.HtmlInputHidden.PropertyKeys
      • javax.faces.component.html.HtmlInputFile.PropertyKeys
      • javax.faces.component.html.HtmlHead.PropertyKeys
      • javax.faces.component.html.HtmlGraphicImage.PropertyKeys
      • javax.faces.component.html.HtmlForm.PropertyKeys
      • javax.faces.component.html.HtmlDoctype.PropertyKeys
      • javax.faces.component.html.HtmlDataTable.PropertyKeys
      • javax.faces.component.html.HtmlCommandLink.PropertyKeys
      • javax.faces.component.html.HtmlCommandButton.PropertyKeys
      • javax.faces.component.html.HtmlColumn.PropertyKeys
      • javax.faces.component.html.HtmlBody.PropertyKeys
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.faces.component.html (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.component.html

  • Packages that use javax.faces.component.html
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.
  • Classes in javax.faces.component.html used by javax.faces.component.html
    Class and Description
    HtmlBody.PropertyKeys
    HtmlColumn.PropertyKeys
    HtmlCommandButton.PropertyKeys
    HtmlCommandLink.PropertyKeys
    HtmlDataTable.PropertyKeys
    HtmlDoctype.PropertyKeys
    HtmlForm.PropertyKeys
    HtmlGraphicImage.PropertyKeys
    HtmlHead.PropertyKeys
    HtmlInputFile.PropertyKeys
    HtmlInputHidden.PropertyKeys
    HtmlInputSecret.PropertyKeys
    HtmlInputText.PropertyKeys
    HtmlInputTextarea.PropertyKeys
    HtmlMessage.PropertyKeys
    HtmlMessages.PropertyKeys
    HtmlOutcomeTargetButton.PropertyKeys
    HtmlOutcomeTargetLink.PropertyKeys
    HtmlOutputFormat.PropertyKeys
    HtmlOutputLabel.PropertyKeys
    HtmlOutputLink.PropertyKeys
    HtmlOutputText.PropertyKeys
    HtmlPanelGrid.PropertyKeys
    HtmlPanelGroup.PropertyKeys
    HtmlSelectBooleanCheckbox.PropertyKeys
    HtmlSelectManyCheckbox.PropertyKeys
    HtmlSelectManyListbox.PropertyKeys
    HtmlSelectManyMenu.PropertyKeys
    HtmlSelectOneListbox.PropertyKeys
    HtmlSelectOneMenu.PropertyKeys
    HtmlSelectOneRadio.PropertyKeys
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlBody (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlBody

No usage of javax.faces.component.html.HtmlBody
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlBody.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlBody.PropertyKeys

  • Packages that use HtmlBody.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlBody.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlBody.PropertyKeys
      Modifier and Type Method and Description
      static HtmlBody.PropertyKeys HtmlBody.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlBody.PropertyKeys[] HtmlBody.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlColumn (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlColumn

No usage of javax.faces.component.html.HtmlColumn
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlColumn.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlColumn.PropertyKeys

  • Packages that use HtmlColumn.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlColumn.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlColumn.PropertyKeys
      Modifier and Type Method and Description
      static HtmlColumn.PropertyKeys HtmlColumn.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlColumn.PropertyKeys[] HtmlColumn.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlCommandButton (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlCommandButton

No usage of javax.faces.component.html.HtmlCommandButton
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlCommandButton.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlCommandButton.PropertyKeys

  • Packages that use HtmlCommandButton.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlCommandButton.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlCommandButton.PropertyKeys
      Modifier and Type Method and Description
      static HtmlCommandButton.PropertyKeys HtmlCommandButton.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlCommandButton.PropertyKeys[] HtmlCommandButton.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlCommandLink (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlCommandLink

No usage of javax.faces.component.html.HtmlCommandLink
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlCommandLink.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlCommandLink.PropertyKeys

  • Packages that use HtmlCommandLink.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlCommandLink.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlCommandLink.PropertyKeys
      Modifier and Type Method and Description
      static HtmlCommandLink.PropertyKeys HtmlCommandLink.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlCommandLink.PropertyKeys[] HtmlCommandLink.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlDataTable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlDataTable

No usage of javax.faces.component.html.HtmlDataTable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlDataTable.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlDataTable.PropertyKeys

  • Packages that use HtmlDataTable.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlDataTable.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlDataTable.PropertyKeys
      Modifier and Type Method and Description
      static HtmlDataTable.PropertyKeys HtmlDataTable.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlDataTable.PropertyKeys[] HtmlDataTable.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlDoctype (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlDoctype

No usage of javax.faces.component.html.HtmlDoctype
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlDoctype.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlDoctype.PropertyKeys

  • Packages that use HtmlDoctype.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlDoctype.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlDoctype.PropertyKeys
      Modifier and Type Method and Description
      static HtmlDoctype.PropertyKeys HtmlDoctype.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlDoctype.PropertyKeys[] HtmlDoctype.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlForm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlForm

No usage of javax.faces.component.html.HtmlForm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlForm.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlForm.PropertyKeys

  • Packages that use HtmlForm.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlForm.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlForm.PropertyKeys
      Modifier and Type Method and Description
      static HtmlForm.PropertyKeys HtmlForm.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlForm.PropertyKeys[] HtmlForm.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlGraphicImage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlGraphicImage

No usage of javax.faces.component.html.HtmlGraphicImage
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlGraphicImage.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlGraphicImage.PropertyKeys

  • Packages that use HtmlGraphicImage.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlGraphicImage.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlGraphicImage.PropertyKeys
      Modifier and Type Method and Description
      static HtmlGraphicImage.PropertyKeys HtmlGraphicImage.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlGraphicImage.PropertyKeys[] HtmlGraphicImage.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlHead (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlHead

No usage of javax.faces.component.html.HtmlHead
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlHead.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlHead.PropertyKeys

  • Packages that use HtmlHead.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlHead.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlHead.PropertyKeys
      Modifier and Type Method and Description
      static HtmlHead.PropertyKeys HtmlHead.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlHead.PropertyKeys[] HtmlHead.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlInputFile (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlInputFile

No usage of javax.faces.component.html.HtmlInputFile
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlInputFile.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlInputFile.PropertyKeys

  • Packages that use HtmlInputFile.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlInputFile.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlInputFile.PropertyKeys
      Modifier and Type Method and Description
      static HtmlInputFile.PropertyKeys HtmlInputFile.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlInputFile.PropertyKeys[] HtmlInputFile.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlInputHidden (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlInputHidden

No usage of javax.faces.component.html.HtmlInputHidden
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlInputHidden.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlInputHidden.PropertyKeys

  • Packages that use HtmlInputHidden.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlInputHidden.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlInputHidden.PropertyKeys
      Modifier and Type Method and Description
      static HtmlInputHidden.PropertyKeys HtmlInputHidden.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlInputHidden.PropertyKeys[] HtmlInputHidden.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlInputSecret (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlInputSecret

No usage of javax.faces.component.html.HtmlInputSecret
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlInputSecret.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlInputSecret.PropertyKeys

  • Packages that use HtmlInputSecret.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlInputSecret.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlInputSecret.PropertyKeys
      Modifier and Type Method and Description
      static HtmlInputSecret.PropertyKeys HtmlInputSecret.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlInputSecret.PropertyKeys[] HtmlInputSecret.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlInputText (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlInputText

No usage of javax.faces.component.html.HtmlInputText
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlInputText.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlInputText.PropertyKeys

  • Packages that use HtmlInputText.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlInputText.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlInputText.PropertyKeys
      Modifier and Type Method and Description
      static HtmlInputText.PropertyKeys HtmlInputText.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlInputText.PropertyKeys[] HtmlInputText.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlInputTextarea (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlInputTextarea

No usage of javax.faces.component.html.HtmlInputTextarea
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlInputTextarea.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlInputTextarea.PropertyKeys

  • Packages that use HtmlInputTextarea.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlInputTextarea.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlInputTextarea.PropertyKeys
      Modifier and Type Method and Description
      static HtmlInputTextarea.PropertyKeys HtmlInputTextarea.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlInputTextarea.PropertyKeys[] HtmlInputTextarea.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlMessage

No usage of javax.faces.component.html.HtmlMessage
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlMessage.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlMessage.PropertyKeys

  • Packages that use HtmlMessage.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlMessage.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlMessage.PropertyKeys
      Modifier and Type Method and Description
      static HtmlMessage.PropertyKeys HtmlMessage.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlMessage.PropertyKeys[] HtmlMessage.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlMessages (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlMessages

No usage of javax.faces.component.html.HtmlMessages
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlMessages.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlMessages.PropertyKeys

  • Packages that use HtmlMessages.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlMessages.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlMessages.PropertyKeys
      Modifier and Type Method and Description
      static HtmlMessages.PropertyKeys HtmlMessages.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlMessages.PropertyKeys[] HtmlMessages.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutcomeTargetButton (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutcomeTargetButton

No usage of javax.faces.component.html.HtmlOutcomeTargetButton
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutcomeTargetButton.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutcomeTargetButton.PropertyKeys

  • Packages that use HtmlOutcomeTargetButton.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlOutcomeTargetButton.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlOutcomeTargetButton.PropertyKeys
      Modifier and Type Method and Description
      static HtmlOutcomeTargetButton.PropertyKeys HtmlOutcomeTargetButton.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutcomeTargetButton.PropertyKeys[] HtmlOutcomeTargetButton.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutcomeTargetLink (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutcomeTargetLink

No usage of javax.faces.component.html.HtmlOutcomeTargetLink
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutcomeTargetLink.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutcomeTargetLink.PropertyKeys

  • Packages that use HtmlOutcomeTargetLink.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlOutcomeTargetLink.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlOutcomeTargetLink.PropertyKeys
      Modifier and Type Method and Description
      static HtmlOutcomeTargetLink.PropertyKeys HtmlOutcomeTargetLink.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutcomeTargetLink.PropertyKeys[] HtmlOutcomeTargetLink.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutputFormat (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutputFormat

No usage of javax.faces.component.html.HtmlOutputFormat
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutputFormat.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutputFormat.PropertyKeys

  • Packages that use HtmlOutputFormat.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlOutputFormat.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlOutputFormat.PropertyKeys
      Modifier and Type Method and Description
      static HtmlOutputFormat.PropertyKeys HtmlOutputFormat.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutputFormat.PropertyKeys[] HtmlOutputFormat.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutputLabel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutputLabel

No usage of javax.faces.component.html.HtmlOutputLabel
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutputLabel.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutputLabel.PropertyKeys

  • Packages that use HtmlOutputLabel.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlOutputLabel.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlOutputLabel.PropertyKeys
      Modifier and Type Method and Description
      static HtmlOutputLabel.PropertyKeys HtmlOutputLabel.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutputLabel.PropertyKeys[] HtmlOutputLabel.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutputLink (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutputLink

No usage of javax.faces.component.html.HtmlOutputLink
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutputLink.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutputLink.PropertyKeys

  • Packages that use HtmlOutputLink.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlOutputLink.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlOutputLink.PropertyKeys
      Modifier and Type Method and Description
      static HtmlOutputLink.PropertyKeys HtmlOutputLink.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutputLink.PropertyKeys[] HtmlOutputLink.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutputText (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutputText

No usage of javax.faces.component.html.HtmlOutputText
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlOutputText.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlOutputText.PropertyKeys

  • Packages that use HtmlOutputText.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlOutputText.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlOutputText.PropertyKeys
      Modifier and Type Method and Description
      static HtmlOutputText.PropertyKeys HtmlOutputText.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlOutputText.PropertyKeys[] HtmlOutputText.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlPanelGrid (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlPanelGrid

No usage of javax.faces.component.html.HtmlPanelGrid
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlPanelGrid.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlPanelGrid.PropertyKeys

  • Packages that use HtmlPanelGrid.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlPanelGrid.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlPanelGrid.PropertyKeys
      Modifier and Type Method and Description
      static HtmlPanelGrid.PropertyKeys HtmlPanelGrid.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlPanelGrid.PropertyKeys[] HtmlPanelGrid.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlPanelGroup (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlPanelGroup

No usage of javax.faces.component.html.HtmlPanelGroup
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlPanelGroup.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlPanelGroup.PropertyKeys

  • Packages that use HtmlPanelGroup.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlPanelGroup.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlPanelGroup.PropertyKeys
      Modifier and Type Method and Description
      static HtmlPanelGroup.PropertyKeys HtmlPanelGroup.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlPanelGroup.PropertyKeys[] HtmlPanelGroup.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectBooleanCheckbox (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectBooleanCheckbox

No usage of javax.faces.component.html.HtmlSelectBooleanCheckbox
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectBooleanCheckbox.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectBooleanCheckbox.PropertyKeys

  • Packages that use HtmlSelectBooleanCheckbox.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlSelectBooleanCheckbox.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlSelectBooleanCheckbox.PropertyKeys
      Modifier and Type Method and Description
      static HtmlSelectBooleanCheckbox.PropertyKeys HtmlSelectBooleanCheckbox.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectBooleanCheckbox.PropertyKeys[] HtmlSelectBooleanCheckbox.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectManyCheckbox (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectManyCheckbox

No usage of javax.faces.component.html.HtmlSelectManyCheckbox
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectManyCheckbox.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectManyCheckbox.PropertyKeys

  • Packages that use HtmlSelectManyCheckbox.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlSelectManyCheckbox.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlSelectManyCheckbox.PropertyKeys
      Modifier and Type Method and Description
      static HtmlSelectManyCheckbox.PropertyKeys HtmlSelectManyCheckbox.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectManyCheckbox.PropertyKeys[] HtmlSelectManyCheckbox.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectManyListbox (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectManyListbox

No usage of javax.faces.component.html.HtmlSelectManyListbox
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectManyListbox.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectManyListbox.PropertyKeys

  • Packages that use HtmlSelectManyListbox.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlSelectManyListbox.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlSelectManyListbox.PropertyKeys
      Modifier and Type Method and Description
      static HtmlSelectManyListbox.PropertyKeys HtmlSelectManyListbox.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectManyListbox.PropertyKeys[] HtmlSelectManyListbox.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectManyMenu (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectManyMenu

No usage of javax.faces.component.html.HtmlSelectManyMenu
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectManyMenu.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectManyMenu.PropertyKeys

  • Packages that use HtmlSelectManyMenu.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlSelectManyMenu.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlSelectManyMenu.PropertyKeys
      Modifier and Type Method and Description
      static HtmlSelectManyMenu.PropertyKeys HtmlSelectManyMenu.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectManyMenu.PropertyKeys[] HtmlSelectManyMenu.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectOneListbox (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectOneListbox

No usage of javax.faces.component.html.HtmlSelectOneListbox
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectOneListbox.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectOneListbox.PropertyKeys

  • Packages that use HtmlSelectOneListbox.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlSelectOneListbox.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlSelectOneListbox.PropertyKeys
      Modifier and Type Method and Description
      static HtmlSelectOneListbox.PropertyKeys HtmlSelectOneListbox.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectOneListbox.PropertyKeys[] HtmlSelectOneListbox.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectOneMenu (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectOneMenu

No usage of javax.faces.component.html.HtmlSelectOneMenu
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectOneMenu.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectOneMenu.PropertyKeys

  • Packages that use HtmlSelectOneMenu.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlSelectOneMenu.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlSelectOneMenu.PropertyKeys
      Modifier and Type Method and Description
      static HtmlSelectOneMenu.PropertyKeys HtmlSelectOneMenu.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectOneMenu.PropertyKeys[] HtmlSelectOneMenu.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectOneRadio (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectOneRadio

No usage of javax.faces.component.html.HtmlSelectOneRadio
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.html.HtmlSelectOneRadio.PropertyKeys (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.html.HtmlSelectOneRadio.PropertyKeys

  • Packages that use HtmlSelectOneRadio.PropertyKeys
    Package Description
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of HtmlSelectOneRadio.PropertyKeys in javax.faces.component.html

      Methods in javax.faces.component.html that return HtmlSelectOneRadio.PropertyKeys
      Modifier and Type Method and Description
      static HtmlSelectOneRadio.PropertyKeys HtmlSelectOneRadio.PropertyKeys.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HtmlSelectOneRadio.PropertyKeys[] HtmlSelectOneRadio.PropertyKeys.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.faces.component.visit (Java(TM) EE 7 Specification APIs)

javax.faces.component.visit

Interfaces

  • VisitCallback

Classes

  • VisitContext
  • VisitContextFactory
  • VisitContextWrapper

Enums

  • VisitHint
  • VisitResult


javax.faces.component.visit (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.component.visit

APIs for traversing a user interface component view.

See: Description

  • Interface Summary
    Interface Description
    VisitCallback

    A simple callback interface that enables taking action on a specific UIComponent (either facet or child) during a component tree visit.
  • Class Summary
    Class Description
    VisitContext

    A context object that is used to hold state relating to performing a component tree visit.
    VisitContextFactory

    Provide for separation of interface and implementation for the VisitContext contract.
    VisitContextWrapper

    Provides a simple implementation of VisitContext that can be subclassed by developers wishing to provide specialized behavior to an existing VisitContext instance.
  • Enum Summary
    Enum Description
    VisitHint

    An enum that specifies hints that impact the behavior of a component tree visit.
    VisitResult

    An enum that specifies the possible results of a call to VisitCallback.visit(javax.faces.component.visit.VisitContext, javax.faces.component.UIComponent).

Package javax.faces.component.visit Description

APIs for traversing a user interface component view.

The following example visits all nodes in the view.

  1. UIViewRoot root = facesContext.getViewRoot();
  2. root.visitTree(VisitContext.createVisitContext(context),
  3.                new VisitCallback() {
  4.                    public VisitResult visit(VisitContext context,
  5.                                             UIComponent target) {
  6.                        // take some action on target
  7.                        return VisitResult.ACCEPT;
  8.                    }
  9.                });

The following example visits two subtrees within the component view.

  1. Set<String> toVisit = getSet("form1:optionsPanel", "form2:detailPanel");
  2. UIViewRoot root = facesContext.getViewRoot();
  3. root.visitTree(VisitContext.createVisitContext(context, toVisit, null),
  4.                new VisitCallback() {
  5.                    public VisitResult visit(VisitContext context,
  6.                                             UIComponent target) {
  7.                        // take some action on target
  8.                        return VisitResult.ACCEPT;
  9.                    }
  10.                });

Note that every child node of those two subtrees is visited.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.component.visit Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.component.visit

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.component.visit.VisitContext
      • javax.faces.component.visit.VisitContextWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.component.visit.VisitContextFactory (implements javax.faces.FacesWrapper<T>)

Interface Hierarchy

  • javax.faces.component.visit.VisitCallback

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.faces.component.visit.VisitResult
      • javax.faces.component.visit.VisitHint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.faces.component.visit (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.component.visit

  • Packages that use javax.faces.component.visit
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.visit

    APIs for traversing a user interface component view.
  • Classes in javax.faces.component.visit used by javax.faces.component
    Class and Description
    VisitCallback

    A simple callback interface that enables taking action on a specific UIComponent (either facet or child) during a component tree visit.
    VisitContext

    A context object that is used to hold state relating to performing a component tree visit.
  • Classes in javax.faces.component.visit used by javax.faces.component.visit
    Class and Description
    VisitCallback

    A simple callback interface that enables taking action on a specific UIComponent (either facet or child) during a component tree visit.
    VisitContext

    A context object that is used to hold state relating to performing a component tree visit.
    VisitContextFactory

    Provide for separation of interface and implementation for the VisitContext contract.
    VisitHint

    An enum that specifies hints that impact the behavior of a component tree visit.
    VisitResult

    An enum that specifies the possible results of a call to VisitCallback.visit(javax.faces.component.visit.VisitContext, javax.faces.component.UIComponent).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


VisitCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.visit

Interface VisitCallback

  • public interface VisitCallback

    A simple callback interface that enables taking action on a specific UIComponent (either facet or child) during a component tree visit.

    Since:
    2.0
    See Also:
    UIComponent.visitTree()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      VisitResult visit(VisitContext context, UIComponent target)
      This method is called during component tree visits by VisitContext.invokeVisitCallback() to visit the specified component.

    • Method Detail

      • visit

        VisitResult visit(VisitContext context,
                UIComponent target)

        This method is called during component tree visits by VisitContext.invokeVisitCallback() to visit the specified component. At the point in time when this method is called, the argument target is guaranteed to be in the proper state with respect to its ancestors in the View.

        Parameters:
        context - the VisitContext for this tree visit.
        target - the UIComponent to visit
        Returns:
        a VisitResult that indicates whether to continue visiting the component's subtree, skip visiting the component's subtree or end the visit.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


VisitContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.visit

Class VisitContext

  • java.lang.Object
    • javax.faces.component.visit.VisitContext
  • Direct Known Subclasses:
    VisitContextWrapper

    public abstract class VisitContext
extends Object

    A context object that is used to hold state relating to performing a component tree visit.

    Component tree visits are initiated by calling UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback), at which point both a VisitContext and a VisitCallback must be provided.

    Since:
    2.0
    See Also:
    UIComponent.visitTree(), VisitCallback

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static Collection<String> ALL_IDS

      This unmodifiable Collection is returned by getIdsToVisit() and getSubtreeIdsToVisit() in cases where all ids should be visited.

    • Constructor Summary

      Constructors
      Constructor and Description
      VisitContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static VisitContext createVisitContext(FacesContext context)
      Creates a VisitContext instance for use with UIComponent.visitTree().
      static VisitContext createVisitContext(FacesContext context, Collection<String> ids, Set<VisitHint> hints)
      Returns a VisitContext instance that is initialized with the specified ids and hintsfor use with UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback).
      abstract FacesContext getFacesContext()

      Returns the FacesContext for the current request.
      abstract Set<VisitHint> getHints()
      Returns hints that influence the behavior of the tree visit.
      abstract Collection<String> getIdsToVisit()

      Returns the ids of the components to visit.
      abstract Collection<String> getSubtreeIdsToVisit(UIComponent component)

      Given a NamingContainer component, returns the client ids of any components underneath the NamingContainer that should be visited.
      abstract VisitResult invokeVisitCallback(UIComponent component, VisitCallback callback)
      Called by UIComponent.visitTree() to visit a single component.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ALL_IDS

        public static final Collection<String> ALL_IDS

        This unmodifiable Collection is returned by getIdsToVisit() and getSubtreeIdsToVisit() in cases where all ids should be visited.

        To simplify logic for visitTree() implementations, this Collection always returns false for isEmpty. All other methods throw UnsupportedOperationException.

        Since:
        2.0

    • Constructor Detail

      • VisitContext

        public VisitContext()

    • Method Detail

      • getFacesContext

        public abstract FacesContext getFacesContext()

        Returns the FacesContext for the current request.

        Since:
        2.0

      • getIdsToVisit

        public abstract Collection<String> getIdsToVisit()

        Returns the ids of the components to visit.

        In the case of a full tree visit, this method returns the ALL_IDS collection. Otherwise, if a partial visit is beign performed, returns a modifiable collection containing the client ids of the components that should be visited.

      • getSubtreeIdsToVisit

        public abstract Collection<String> getSubtreeIdsToVisit(UIComponent component)

        Given a NamingContainer component, returns the client ids of any components underneath the NamingContainer that should be visited.

        This method is called by NamingContainer visitTree() implementations to determine whether the NamingContainer contains components to be visited. In the case where no such components exist, the NamingContainer can short-circuit the tree visit and avoid descending into child subtrees.

        In addition, iterating components such as UIData may be able to use the returned ids to determine which iterated states (ie. rows) need to be visited. This allows the visit traversal to be contstrained such only those rows that contain visit targets need to be traversed.

        Parameters:
        component - a NamingContainer component
        Returns:
        an unmodifiable Collection containing the client ids of any components underneath the NamingContainer that are known to be targets of the tree visit. If no such components exist, returns an empty Collection. If all components underneath the NamingContainer should be visited, returns the VisitContext.ALL_IDS collection.
        Throws:
        IllegalArgumentException - if component is not an instance of NamingContainer

      • invokeVisitCallback

        public abstract VisitResult invokeVisitCallback(UIComponent component,
                              VisitCallback callback)

        Called by UIComponent.visitTree() to visit a single component.

        Parameters:
        component - the component to visit
        callback - the VisitCallback to call
        Returns:
        a VisitResult value that indicates whether to continue visiting the component's subtree, skip visiting the component's subtree or abort the visit altogether.

      • getHints

        public abstract Set<VisitHint> getHints()

        Returns hints that influence the behavior of the tree visit.

        Interested parties, such as UIComponent.visitTree() implementations, may check to see whether a particular hint is present by calling VisitContext.getHints().contains(), passing in one of the hints defined by VisitHint.

        Returns:
        a non-empty, unmodifiable collection of VisitHints

      • createVisitContext

        public static VisitContext createVisitContext(FacesContext context,
                              Collection<String> ids,
                              Set<VisitHint> hints)

        Returns a VisitContext instance that is initialized with the specified ids and hintsfor use with UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback).

        Parameters:
        context - the FacesContext for the current request
        ids - the client ids of the components to visit. If null, all components will be visited.
        hints - the VisitHints to apply to the visit. If null, no hints are applied.
        Returns:
        a VisitContext instance that is initialized with the specified ids and hints.

      • createVisitContext

        public static VisitContext createVisitContext(FacesContext context)

        Creates a VisitContext instance for use with UIComponent.visitTree(). This method can be used to obtain a VisitContext instance when all components should be visited with the default visit hints.

        Parameters:
        context - the FacesContext for the current request
        Returns:
        a VisitContext instance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


VisitContextFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.visit

Class VisitContextFactory

  • java.lang.Object
    • javax.faces.component.visit.VisitContextFactory
  • All Implemented Interfaces:
    FacesWrapper<VisitContextFactory>

    public abstract class VisitContextFactory
extends Object
implements FacesWrapper<VisitContextFactory>

    Provide for separation of interface and implementation for the VisitContext contract.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      VisitContextFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract VisitContext getVisitContext(FacesContext context, Collection<String> ids, Set<VisitHint> hints)

      Return a new VisitContext instance.
      VisitContextFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • VisitContextFactory

        public VisitContextFactory()

    • Method Detail

      • getWrapped

        public VisitContextFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<VisitContextFactory>
        Since:
        2.0

      • getVisitContext

        public abstract VisitContext getVisitContext(FacesContext context,
                           Collection<String> ids,
                           Set<VisitHint> hints)

        Return a new VisitContext instance.

        Parameters:
        context - the FacesContext for this request.
        ids - a Collection of clientIds to visit. If null all components will be visited.
        hints - the VisitHints that apply to this visit.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


VisitContextWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.component.visit

Class VisitContextWrapper

  • java.lang.Object
    • javax.faces.component.visit.VisitContext
      • javax.faces.component.visit.VisitContextWrapper
  • All Implemented Interfaces:
    FacesWrapper<VisitContext>

    public abstract class VisitContextWrapper
extends VisitContext
implements FacesWrapper<VisitContext>

    Provides a simple implementation of VisitContext that can be subclassed by developers wishing to provide specialized behavior to an existing VisitContext instance. The default implementation of all methods is to call through to the wrapped VisitContext instance.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    2.0

    • Field Summary

      • Fields inherited from class javax.faces.component.visit.VisitContext

        ALL_IDS

    • Constructor Summary

      Constructors
      Constructor and Description
      VisitContextWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      FacesContext getFacesContext()

      Returns the FacesContext for the current request.
      Set<VisitHint> getHints()
      Returns hints that influence the behavior of the tree visit.
      Collection<String> getIdsToVisit()

      Returns the ids of the components to visit.
      Collection<String> getSubtreeIdsToVisit(UIComponent component)

      Given a NamingContainer component, returns the client ids of any components underneath the NamingContainer that should be visited.
      abstract VisitContext getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      VisitResult invokeVisitCallback(UIComponent component, VisitCallback callback)
      Called by UIComponent.visitTree() to visit a single component.

      • Methods inherited from class javax.faces.component.visit.VisitContext

        createVisitContext, createVisitContext

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • VisitContextWrapper

        public VisitContextWrapper()

    • Method Detail

      • getFacesContext

        public FacesContext getFacesContext()
        Description copied from class: VisitContext

        Returns the FacesContext for the current request.

        Specified by:
        getFacesContext in class VisitContext

      • getHints

        public Set<VisitHint> getHints()
        Description copied from class: VisitContext

        Returns hints that influence the behavior of the tree visit.

        Interested parties, such as UIComponent.visitTree() implementations, may check to see whether a particular hint is present by calling VisitContext.getHints().contains(), passing in one of the hints defined by VisitHint.

        Specified by:
        getHints in class VisitContext
        Returns:
        a non-empty, unmodifiable collection of VisitHints

      • getIdsToVisit

        public Collection<String> getIdsToVisit()
        Description copied from class: VisitContext

        Returns the ids of the components to visit.

        In the case of a full tree visit, this method returns the ALL_IDS collection. Otherwise, if a partial visit is beign performed, returns a modifiable collection containing the client ids of the components that should be visited.

        Specified by:
        getIdsToVisit in class VisitContext

      • getSubtreeIdsToVisit

        public Collection<String> getSubtreeIdsToVisit(UIComponent component)
        Description copied from class: VisitContext

        Given a NamingContainer component, returns the client ids of any components underneath the NamingContainer that should be visited.

        This method is called by NamingContainer visitTree() implementations to determine whether the NamingContainer contains components to be visited. In the case where no such components exist, the NamingContainer can short-circuit the tree visit and avoid descending into child subtrees.

        In addition, iterating components such as UIData may be able to use the returned ids to determine which iterated states (ie. rows) need to be visited. This allows the visit traversal to be contstrained such only those rows that contain visit targets need to be traversed.

        Specified by:
        getSubtreeIdsToVisit in class VisitContext
        Parameters:
        component - a NamingContainer component
        Returns:
        an unmodifiable Collection containing the client ids of any components underneath the NamingContainer that are known to be targets of the tree visit. If no such components exist, returns an empty Collection. If all components underneath the NamingContainer should be visited, returns the VisitContext.ALL_IDS collection.

      • invokeVisitCallback

        public VisitResult invokeVisitCallback(UIComponent component,
                              VisitCallback callback)
        Description copied from class: VisitContext

        Called by UIComponent.visitTree() to visit a single component.

        Specified by:
        invokeVisitCallback in class VisitContext
        Parameters:
        component - the component to visit
        callback - the VisitCallback to call
        Returns:
        a VisitResult value that indicates whether to continue visiting the component's subtree, skip visiting the component's subtree or abort the visit altogether.

      • getWrapped

        public abstract VisitContext getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<VisitContext>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


VisitHint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.visit

Enum VisitHint

  • java.lang.Object
    • java.lang.Enum<VisitHint>
      • javax.faces.component.visit.VisitHint
  • All Implemented Interfaces:
    Serializable, Comparable<VisitHint>

    public enum VisitHint
extends Enum<VisitHint>

    An enum that specifies hints that impact the behavior of a component tree visit.

    Since:
    2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      EXECUTE_LIFECYCLE

      Hint that indicates that the visit is being performed as part of lifecycle phase execution and as such phase-specific actions (initialization) may be taken.
      SKIP_ITERATION

      Hint that indicates that components that normally visit children multiple times (eg.
      SKIP_TRANSIENT

      Hint that indicates that only non-transient subtrees should be visited.
      SKIP_UNRENDERED

      Hint that indicates that only the rendered subtrees should be visited.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static VisitHint valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static VisitHint[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SKIP_UNRENDERED

        public static final VisitHint SKIP_UNRENDERED

        Hint that indicates that only the rendered subtrees should be visited.

        Since:
        2.0

      • SKIP_TRANSIENT

        public static final VisitHint SKIP_TRANSIENT

        Hint that indicates that only non-transient subtrees should be visited.

        Since:
        2.0

      • SKIP_ITERATION

        public static final VisitHint SKIP_ITERATION

        Hint that indicates that components that normally visit children multiple times (eg. UIData) in an iterative fashion should instead visit each child only one time.

        Since:
        2.1

      • EXECUTE_LIFECYCLE

        public static final VisitHint EXECUTE_LIFECYCLE

        Hint that indicates that the visit is being performed as part of lifecycle phase execution and as such phase-specific actions (initialization) may be taken.

        Since:
        2.0

    • Method Detail

      • values

        public static VisitHint[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (VisitHint c : VisitHint.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static VisitHint valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


VisitResult (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.faces.component.visit

Enum VisitResult

  • java.lang.Object
    • java.lang.Enum<VisitResult>
      • javax.faces.component.visit.VisitResult
  • All Implemented Interfaces:
    Serializable, Comparable<VisitResult>

    public enum VisitResult
extends Enum<VisitResult>

    An enum that specifies the possible results of a call to VisitCallback.visit(javax.faces.component.visit.VisitContext, javax.faces.component.UIComponent).

    Since:
    2.0
    See Also:
    VisitCallback.visit()

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ACCEPT

      This result indicates that the tree visit should descend into current component's subtree.
      COMPLETE

      This result indicates that the tree visit should be terminated.
      REJECT

      This result indicates that the tree visit should continue, but should skip the current component's subtree.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static VisitResult valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static VisitResult[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ACCEPT

        public static final VisitResult ACCEPT

        This result indicates that the tree visit should descend into current component's subtree.

        Since:
        2.0

      • REJECT

        public static final VisitResult REJECT

        This result indicates that the tree visit should continue, but should skip the current component's subtree.

      • COMPLETE

        public static final VisitResult COMPLETE

        This result indicates that the tree visit should be terminated.

    • Method Detail

      • values

        public static VisitResult[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (VisitResult c : VisitResult.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static VisitResult valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Uses of Class javax.faces.component.visit.VisitContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.visit.VisitContext

  • Packages that use VisitContext
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.visit

    APIs for traversing a user interface component view.

    • Uses of VisitContext in javax.faces.component

      Methods in javax.faces.component with parameters of type VisitContext
      Modifier and Type | Method and Description
      protected boolean UIComponent.isVisitable(VisitContext context)

      Return true if this component should be visited, false otherwise.
      boolean | UINamingContainer.visitTree(VisitContext context, VisitCallback callback)
      boolean | UIForm.visitTree(VisitContext context, VisitCallback callback)
      boolean UIData.visitTree(VisitContext context, VisitCallback callback)

      Override the behavior in UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback) to handle iteration correctly.
      boolean UIComponent.visitTree(VisitContext context, VisitCallback callback)

      Perform a tree visit starting at this node in the tree.

    • Uses of VisitContext in javax.faces.component.visit

      Subclasses of VisitContext in javax.faces.component.visit
      Modifier and Type Class and Description
      class  VisitContextWrapper

      Provides a simple implementation of VisitContext that can be subclassed by developers wishing to provide specialized behavior to an existing VisitContext instance.
      Methods in javax.faces.component.visit that return VisitContext
      Modifier and Type | Method and Description
      static VisitContext VisitContext.createVisitContext(FacesContext context)
      Creates a VisitContext instance for use with UIComponent.visitTree().
      static VisitContext VisitContext.createVisitContext(FacesContext context, Collection<String> ids, Set<VisitHint> hints)
      Returns a VisitContext instance that is initialized with the specified ids and hintsfor use with UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback).
      abstract VisitContext VisitContextFactory.getVisitContext(FacesContext context, Collection<String> ids, Set<VisitHint> hints)

      Return a new VisitContext instance.
      abstract VisitContext | VisitContextWrapper.getWrapped()
      Methods in javax.faces.component.visit with parameters of type VisitContext
      Modifier and Type Method and Description
      VisitResult VisitCallback.visit(VisitContext context, UIComponent target)
      This method is called during component tree visits by VisitContext.invokeVisitCallback() to visit the specified component.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.visit.VisitContextFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.visit.VisitContextFactory

  • Packages that use VisitContextFactory
    Package Description
    javax.faces.component.visit

    APIs for traversing a user interface component view.

    • Uses of VisitContextFactory in javax.faces.component.visit

      Methods in javax.faces.component.visit that return VisitContextFactory
      Modifier and Type Method and Description
      VisitContextFactory VisitContextFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.visit.VisitContextWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.visit.VisitContextWrapper

No usage of javax.faces.component.visit.VisitContextWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.visit.VisitHint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.visit.VisitHint

  • Packages that use VisitHint
    Package Description
    javax.faces.component.visit

    APIs for traversing a user interface component view.

    • Uses of VisitHint in javax.faces.component.visit

      Methods in javax.faces.component.visit that return VisitHint
      Modifier and Type Method and Description
      static VisitHint VisitHint.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static VisitHint[] VisitHint.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.faces.component.visit that return types with arguments of type VisitHint
      Modifier and Type | Method and Description
      Set<VisitHint> | VisitContextWrapper.getHints()
      abstract Set<VisitHint> VisitContext.getHints()
      Returns hints that influence the behavior of the tree visit.
      Method parameters in javax.faces.component.visit with type arguments of type VisitHint
      Modifier and Type Method and Description
      static VisitContext VisitContext.createVisitContext(FacesContext context, Collection<String> ids, Set<VisitHint> hints)
      Returns a VisitContext instance that is initialized with the specified ids and hintsfor use with UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback).
      abstract VisitContext VisitContextFactory.getVisitContext(FacesContext context, Collection<String> ids, Set<VisitHint> hints)

      Return a new VisitContext instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.component.visit.VisitResult (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.component.visit.VisitResult

  • Packages that use VisitResult
    Package Description
    javax.faces.component.visit

    APIs for traversing a user interface component view.

    • Uses of VisitResult in javax.faces.component.visit

      Methods in javax.faces.component.visit that return VisitResult
      Modifier and Type | Method and Description
      VisitResult | VisitContextWrapper.invokeVisitCallback(UIComponent component, VisitCallback callback)
      abstract VisitResult VisitContext.invokeVisitCallback(UIComponent component, VisitCallback callback)
      Called by UIComponent.visitTree() to visit a single component.
      static VisitResult VisitResult.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static VisitResult[] VisitResult.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      VisitResult VisitCallback.visit(VisitContext context, UIComponent target)
      This method is called during component tree visits by VisitContext.invokeVisitCallback() to visit the specified component.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.component.visit.VisitCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.component.visit.VisitCallback

  • Packages that use VisitCallback
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.visit

    APIs for traversing a user interface component view.

    • Uses of VisitCallback in javax.faces.component

      Methods in javax.faces.component with parameters of type VisitCallback
      Modifier and Type | Method and Description
      boolean | UINamingContainer.visitTree(VisitContext context, VisitCallback callback)
      boolean | UIForm.visitTree(VisitContext context, VisitCallback callback)
      boolean UIData.visitTree(VisitContext context, VisitCallback callback)

      Override the behavior in UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback) to handle iteration correctly.
      boolean UIComponent.visitTree(VisitContext context, VisitCallback callback)

      Perform a tree visit starting at this node in the tree.

    • Uses of VisitCallback in javax.faces.component.visit

      Methods in javax.faces.component.visit with parameters of type VisitCallback
      Modifier and Type | Method and Description
      VisitResult | VisitContextWrapper.invokeVisitCallback(UIComponent component, VisitCallback callback)
      abstract VisitResult VisitContext.invokeVisitCallback(UIComponent component, VisitCallback callback)
      Called by UIComponent.visitTree() to visit a single component.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ExceptionHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class ExceptionHandler

  • java.lang.Object
    • javax.faces.context.ExceptionHandler
  • All Implemented Interfaces:
    EventListener, FacesListener, SystemEventListener
    Direct Known Subclasses:
    ExceptionHandlerWrapper

    public abstract class ExceptionHandler
extends Object
implements SystemEventListener

    ExceptionHandler is the central point for handling unexpected Exceptions that are thrown during the Faces lifecycle. The ExceptionHandler must not be notified of any Exceptions that occur during application startup or shutdown.

    See the specification prose document for the requirements for the default implementation. Exceptions may be passed to the ExceptionHandler in one of two ways:

    • by ensuring that Exceptions are not caught, or are caught and re-thrown.

      This approach allows the ExceptionHandler facility specified in section JSF.6.2 to operate on the Exception.

    • By using the system event facility to publish an ExceptionQueuedEvent that wraps the Exception.

      This approach requires manually publishing the ExceptionQueuedEvent, but allows more information about the Exceptionto be stored in the event. The following code is an example of how to do this.

 //...
 } catch (Exception e) {
   FacesContext ctx = FacesContext.getCurrentInstance();
   ExceptionQueuedEventContext eventContext = new ExceptionQueuedEventContext(ctx, e);
   eventContext.getAttributes().put("key", "value");
   ctx.getApplication().publishEvent(ExceptionQueuedEvent.class, eventContext);
 }

      Because the Exception must not be re-thrown when using this approach, lifecycle processing may continue as normal, allowing more Exceptions to be published if necessary.

    With either approach, any ExceptionQueuedEvent instances that are published in this way are accessible to the handle() method, which is called at the end of each lifecycle phase, as specified in section JSF.6.2.

    Instances of this class are request scoped and are created by virtue of FacesContextFactory.getFacesContext(java.lang.Object, java.lang.Object, java.lang.Object, javax.faces.lifecycle.Lifecycle) calling ExceptionHandlerFactory.getExceptionHandler().

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ExceptionHandler()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ExceptionQueuedEvent getHandledExceptionQueuedEvent()

      Return the first ExceptionQueuedEvent handled by this handler.
      abstract Iterable<ExceptionQueuedEvent> getHandledExceptionQueuedEvents()

      The default implementation must return an Iterable over all ExceptionQueuedEvents that have been handled by the handle() method.
      abstract Throwable getRootCause(Throwable t)

      Unwrap the argument t until the unwrapping encounters an Object whose getClass() is not equal to FacesException.class or javax.el.ELException.class.
      abstract Iterable<ExceptionQueuedEvent> getUnhandledExceptionQueuedEvents()

      Return an Iterable over all ExceptionQueuedEvents that have not yet been handled by the handle() method.
      abstract void handle()

      Take action to handle the Exception instances residing inside the ExceptionQueuedEvent instances that have been queued by calls to Application().publishEvent(ExceptionQueuedEvent.class, eventContext).
      abstract boolean isListenerForSource(Object source)
      This method must return true if and only if this listener instance is interested in receiving events from the instance referenced by the source parameter.
      abstract void processEvent(SystemEvent exceptionQueuedEvent)
      When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ExceptionHandler

        public ExceptionHandler()

    • Method Detail

      • handle

        public abstract void handle()
                     throws FacesException

        Take action to handle the Exception instances residing inside the ExceptionQueuedEvent instances that have been queued by calls to Application().publishEvent(ExceptionQueuedEvent.class, eventContext). The requirements of the default implementation are detailed in section JSF.6.2.1.

        Throws:
        FacesException - if and only if a problem occurs while performing the algorithm to handle the Exception, not as a means of conveying a handled Exception itself.
        Since:
        2.0

      • getHandledExceptionQueuedEvent

        public abstract ExceptionQueuedEvent getHandledExceptionQueuedEvent()

        Return the first ExceptionQueuedEvent handled by this handler.

      • getUnhandledExceptionQueuedEvents

        public abstract Iterable<ExceptionQueuedEvent> getUnhandledExceptionQueuedEvents()

        Return an Iterable over all ExceptionQueuedEvents that have not yet been handled by the handle() method.

      • getHandledExceptionQueuedEvents

        public abstract Iterable<ExceptionQueuedEvent> getHandledExceptionQueuedEvents()

        The default implementation must return an Iterable over all ExceptionQueuedEvents that have been handled by the handle() method.

      • processEvent

        public abstract void processEvent(SystemEvent exceptionQueuedEvent)
                           throws AbortProcessingException

        When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

        Specified by:
        processEvent in interface SystemEventListener
        Parameters:
        exceptionQueuedEvent - the SystemEvent instance that is being processed.
        Throws:
        AbortProcessingException - if lifecycle processing should cease for this request.

      • isListenerForSource

        public abstract boolean isListenerForSource(Object source)

        This method must return true if and only if this listener instance is interested in receiving events from the instance referenced by the source parameter.

        Specified by:
        isListenerForSource in interface SystemEventListener
        Parameters:
        source - the source that is inquiring about the appropriateness of sending an event to this listener instance.

      • getRootCause

        public abstract Throwable getRootCause(Throwable t)

        Unwrap the argument t until the unwrapping encounters an Object whose getClass() is not equal to FacesException.class or javax.el.ELException.class. If there is no root cause, null is returned.

        Throws:
        NullPointerException - if argument t is null.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExceptionHandlerFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class ExceptionHandlerFactory

  • java.lang.Object
    • javax.faces.context.ExceptionHandlerFactory
  • All Implemented Interfaces:
    FacesWrapper<ExceptionHandlerFactory>
    Direct Known Subclasses:
    PreJsf2ExceptionHandlerFactory

    public abstract class ExceptionHandlerFactory
extends Object
implements FacesWrapper<ExceptionHandlerFactory>

    ExceptionHandlerFactory is a factory object that creates (if needed) and returns a new ExceptionHandler instance.

    There must be one ExceptionHandlerFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

   ExceptionHandlerFactory factory = (ExceptionHandlerFactory)
    FactoryFinder.getFactory(FactoryFinder.EXCEPTION_HANDLER_FACTORY);
    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ExceptionHandlerFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ExceptionHandler getExceptionHandler()

      Create and return a A new ExceptionHandler instance.
      ExceptionHandlerFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ExceptionHandlerFactory

        public ExceptionHandlerFactory()

    • Method Detail

      • getWrapped

        public ExceptionHandlerFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<ExceptionHandlerFactory>

      • getExceptionHandler

        public abstract ExceptionHandler getExceptionHandler()

        Create and return a A new ExceptionHandler instance. The implementation must return an ExceptionHandler instance suitable for the environment. For example, in some cases it may be desirable for an ExceptionHandler to write error information to the response instead of throwing exceptions as in the case of Ajax applications.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExceptionHandlerWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class ExceptionHandlerWrapper

  • java.lang.Object
    • javax.faces.context.ExceptionHandler
      • javax.faces.context.ExceptionHandlerWrapper
  • All Implemented Interfaces:
    EventListener, FacesListener, SystemEventListener, FacesWrapper<ExceptionHandler>

    public abstract class ExceptionHandlerWrapper
extends ExceptionHandler
implements FacesWrapper<ExceptionHandler>

    Provides a simple implementation of ExceptionHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ExceptionHandler instance. The default implementation of all methods is to call through to the wrapped ExceptionHandler instance.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ExceptionHandlerWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ExceptionQueuedEvent getHandledExceptionQueuedEvent()
      The default behavior of this method is to call ExceptionHandler.getHandledExceptionQueuedEvent() on the wrapped ExceptionHandler object.
      Iterable<ExceptionQueuedEvent> getHandledExceptionQueuedEvents()
      The default behavior of this method is to call ExceptionHandler.getHandledExceptionQueuedEvents() on the wrapped ExceptionHandler object.
      Throwable getRootCause(Throwable t)
      The default behavior of this method is to call ExceptionHandler.getRootCause(Throwable) on the wrapped ExceptionHandler object.
      Iterable<ExceptionQueuedEvent> getUnhandledExceptionQueuedEvents()
      The default behavior of this method is to call ExceptionHandler.getUnhandledExceptionQueuedEvents() on the wrapped ExceptionHandler object.
      abstract ExceptionHandler getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void handle()
      The default behavior of this method is to call ExceptionHandler.handle() on the wrapped ExceptionHandler object.
      boolean isListenerForSource(Object source)
      The default behavior of this method is to call ExceptionHandler.isListenerForSource(Object) on the wrapped ExceptionHandler object.
      void processEvent(SystemEvent event)
      The default behavior of this method is to call ExceptionHandler.processEvent(javax.faces.event.SystemEvent) on the wrapped ExceptionHandler object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ExceptionHandlerWrapper

        public ExceptionHandlerWrapper()

    • Method Detail

      • getWrapped

        public abstract ExceptionHandler getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<ExceptionHandler>
        Returns:
        the wrapped ExceptionHandler instance
        See Also:
        FacesWrapper.getWrapped()

      • getHandledExceptionQueuedEvent

        public ExceptionQueuedEvent getHandledExceptionQueuedEvent()

        The default behavior of this method is to call ExceptionHandler.getHandledExceptionQueuedEvent() on the wrapped ExceptionHandler object.

        Specified by:
        getHandledExceptionQueuedEvent in class ExceptionHandler
        See Also:
        ExceptionHandler.getHandledExceptionQueuedEvent()

      • handle

        public void handle()
            throws FacesException

        The default behavior of this method is to call ExceptionHandler.handle() on the wrapped ExceptionHandler object.

        Specified by:
        handle in class ExceptionHandler
        Throws:
        FacesException - if and only if a problem occurs while performing the algorithm to handle the Exception, not as a means of conveying a handled Exception itself.
        See Also:
        ExceptionHandler.handle()

      • isListenerForSource

        public boolean isListenerForSource(Object source)

        The default behavior of this method is to call ExceptionHandler.isListenerForSource(Object) on the wrapped ExceptionHandler object.

        Specified by:
        isListenerForSource in interface SystemEventListener
        Specified by:
        isListenerForSource in class ExceptionHandler
        Parameters:
        source - the source that is inquiring about the appropriateness of sending an event to this listener instance.
        See Also:
        ()

      • processEvent

        public void processEvent(SystemEvent event)
                  throws AbortProcessingException

        The default behavior of this method is to call ExceptionHandler.processEvent(javax.faces.event.SystemEvent) on the wrapped ExceptionHandler object.

        Specified by:
        processEvent in interface SystemEventListener
        Specified by:
        processEvent in class ExceptionHandler
        Parameters:
        event - the SystemEvent instance that is being processed.
        Throws:
        AbortProcessingException - if lifecycle processing should cease for this request.
        See Also:
        ExceptionHandler.processEvent(javax.faces.event.SystemEvent)

      • getRootCause

        public Throwable getRootCause(Throwable t)

        The default behavior of this method is to call ExceptionHandler.getRootCause(Throwable) on the wrapped ExceptionHandler object.

        Specified by:
        getRootCause in class ExceptionHandler
        See Also:
        ExceptionHandler.getRootCause(Throwable)

      • getHandledExceptionQueuedEvents

        public Iterable<ExceptionQueuedEvent> getHandledExceptionQueuedEvents()

        The default behavior of this method is to call ExceptionHandler.getHandledExceptionQueuedEvents() on the wrapped ExceptionHandler object.

        Specified by:
        getHandledExceptionQueuedEvents in class ExceptionHandler
        See Also:
        ExceptionHandler.getHandledExceptionQueuedEvents()

      • getUnhandledExceptionQueuedEvents

        public Iterable<ExceptionQueuedEvent> getUnhandledExceptionQueuedEvents()

        The default behavior of this method is to call ExceptionHandler.getUnhandledExceptionQueuedEvents() on the wrapped ExceptionHandler object.

        Specified by:
        getUnhandledExceptionQueuedEvents in class ExceptionHandler
        See Also:
        ExceptionHandler.getUnhandledExceptionQueuedEvents()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExternalContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class ExternalContext

  • java.lang.Object
    • javax.faces.context.ExternalContext
  • Direct Known Subclasses:
    ExternalContextWrapper

    public abstract class ExternalContext
extends Object

    This class allows the Faces API to be unaware of the nature of its containing application environment. In particular, this class allows JavaServer Faces based appications to run in either a Servlet or a Portlet environment.

    The documentation for this class only specifies the behavior for the Servlet implementation of ExternalContext. The Portlet implementation of ExternalContext is specified under the revision of the Portlet Bridge Specification for JavaServer Faces JSR that corresponds to this version of the JSF specification. See the Preface of the "prose document", linked from the javadocs, for a reference.

    If a reference to an ExternalContext is obtained during application startup or shutdown time, any method documented as "valid to call this method during application startup or shutdown" must be supported during application startup or shutdown time. The result of calling a method during application startup or shutdown time that does not have this designation is undefined.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String BASIC_AUTH
      String identifier for BASIC authentication.
      static String CLIENT_CERT_AUTH
      String identifier for CLIENT_CERT authentication.
      static String DIGEST_AUTH
      String identifier for DIGEST authentication.
      static String FORM_AUTH
      String identifier for FORM authentication.

    • Constructor Summary

      Constructors
      Constructor and Description
      ExternalContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addResponseCookie(String name, String value, Map<String,Object> properties)

      Adds the cookie represented by the arguments to the response.
      void addResponseHeader(String name, String value)

      Add the given name and value to the response header.
      abstract void dispatch(String path)
      Dispatch a request to the specified resource to create output for this response.
      abstract String encodeActionURL(String url)
      Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable action in the current application.
      String encodeBookmarkableURL(String baseUrl, Map<String,List<String>> parameters)

      The purpose of this method is to generate a query string from the collection of Parameter objects provided by the parameters argument and append that query string to the baseUrl.
      abstract String encodeNamespace(String name)
      Return the specified name, after prefixing it with a namespace that ensures that it will be unique within the context of a particular page.
      String encodePartialActionURL(String url)

      Return the input URL, after performing any rewriting needed to ensure that it can be used in a partial page submission (ajax request) to correctly identify an addressable action in the current application.
      String encodeRedirectURL(String baseUrl, Map<String,List<String>> parameters)
      The purpose of this method is to generate a query string from the collection of Parameter objects provided by the parameters argument and append that query string to the baseUrl.
      abstract String encodeResourceURL(String url)
      Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable resource in the current application.
      String getApplicationContextPath()

      Return the name of the container context for this application.
      abstract Map<String,Object> getApplicationMap()
      Return a mutable Map representing the application scope attributes for the current application.
      abstract String getAuthType()
      Return the name of the authentication scheme used to authenticate the current user, if any; otherwise, return null.
      ClientWindow getClientWindow()

      Return the ClientWindow set in a preceding call to setClientWindow(javax.faces.lifecycle.ClientWindow), or null if no such call has been made.
      abstract Object getContext()
      Return the application environment object instance for the current appication.
      String getContextName()

      Return the name of the container context for this application.
      Flash getFlash()

      Return the threadsafe Flash for this application.
      abstract String getInitParameter(String name)
      Return the value of the specified application initialization parameter (if any).
      abstract Map getInitParameterMap()
      Return an immutable Map whose keys are the set of application initialization parameter names configured for this application, and whose values are the corresponding parameter values.
      String getMimeType(String file)

      Returns the MIME type of the specified file or null if the MIME type is not known.
      String getRealPath(String path)

      Returns a String containing the real path for a given virtual path.
      abstract String getRemoteUser()
      Return the login name of the user making the current request if any; otherwise, return null.
      abstract Object getRequest()
      Return the environment-specific object instance for the current request.
      String getRequestCharacterEncoding()
      Return the character encoding currently being used to interpret this request.
      int getRequestContentLength()

      Return the result of calling getContentLenth() on the ServletRequest instance for this request.
      String getRequestContentType()
      Return the MIME Content-Type for this request.
      abstract String getRequestContextPath()
      Return the portion of the request URI that identifies the web application context for this request.
      abstract Map<String,Object> getRequestCookieMap()
      Return an immutable Map whose keys are the set of cookie names included in the current request, and whose values (of type javax.servlet.http.Cookie) are the first (or only) cookie for each cookie name returned by the underlying request.
      abstract Map<String,String> getRequestHeaderMap()
      Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String) are the first (or only) value for each header name returned by the underlying request.
      abstract Map<String,String[]> getRequestHeaderValuesMap()
      Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String[]) are all of the value for each header name returned by the underlying request.
      abstract Locale getRequestLocale()
      Return the preferred Locale in which the client will accept content.
      abstract Iterator<Locale> getRequestLocales()
      Return an Iterator over the preferred Locales specified in the request, in decreasing order of preference.
      abstract Map<String,Object> getRequestMap()
      Return a mutable Map representing the request scope attributes for the current application.
      abstract Map<String,String> getRequestParameterMap()
      Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String) are the first (or only) value for each parameter name returned by the underlying request.
      abstract Iterator<String> getRequestParameterNames()
      Return an Iterator over the names of all request parameters included in the current request.
      abstract Map<String,String[]> getRequestParameterValuesMap()
      Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String[]) are all of the values for each parameter name returned by the underlying request.
      abstract String getRequestPathInfo()
      Return the extra path information (if any) included in the request URI; otherwise, return null.
      String getRequestScheme()

      Returns the name of the scheme used to make this request, for example, http, https, or ftp.
      String getRequestServerName()

      Returns the host name of the server to which the request was sent.
      int getRequestServerPort()

      Returns the port number to which the request was sent.
      abstract String getRequestServletPath()
      Return the servlet path information (if any) included in the request URI; otherwise, return null.
      abstract URL getResource(String path)
      Return a URL for the application resource mapped to the specified path, if it exists; otherwise, return null.
      abstract InputStream getResourceAsStream(String path)
      Return an InputStream for an application resource mapped to the specified path, if it exists; otherwise, return null.
      abstract Set<String> getResourcePaths(String path)
      Return the Set of resource paths for all application resources whose resource path starts with the specified argument.
      abstract Object getResponse()
      Return the environment-specific object instance for the current response.
      int getResponseBufferSize()

      Return the buffer size for the current response.
      String getResponseCharacterEncoding()
      Returns the name of the character encoding (MIME charset) used for the body sent in this response.
      String getResponseContentType()
      Return the MIME Content-Type for this response.
      OutputStream getResponseOutputStream()

      Returns an OutputStream suitable for writing binary data to the user-agent.
      Writer getResponseOutputWriter()

      Returns a Writer suitable for writing character data to the user-agent.
      abstract Object getSession(boolean create)
      If the create parameter is true, create (if necessary) and return a session instance associated with the current request.
      String getSessionId(boolean create)

      Return the id of the current session or the empty string if no session has been created and the create parameter is false.
      abstract Map<String,Object> getSessionMap()
      Return a mutable Map representing the session scope attributes for the current application.
      int getSessionMaxInactiveInterval()

      Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses.
      abstract Principal getUserPrincipal()
      Return the Principal object containing the name of the current authenticated user, if any; otherwise, return null.
      void invalidateSession()

      Invalidates this session then unbinds any objects bound to it.
      boolean isResponseCommitted()

      Check if the current response has been committed.
      boolean isSecure()

      Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.
      abstract boolean isUserInRole(String role)
      Return true if the currently authenticated user is included in the specified role.
      abstract void log(String message)
      Log the specified message to the application object.
      abstract void log(String message, Throwable exception)
      Log the specified message and exception to the application object.
      abstract void redirect(String url)
      Redirect a request to the specified URL, and cause the responseComplete() method to be called on the FacesContext instance for the current request.
      void responseFlushBuffer()

      Flushes the buffered response content to the client.
      void responseReset()

      Resets the current response.
      void responseSendError(int statusCode, String message)

      Sends an HTTP status code with message.
      void setClientWindow(ClientWindow window)

      Associate this instance with a ClientWindow.
      void setRequest(Object request)
      Set the environment-specific request to be returned by subsequent calls to getRequest().
      void setRequestCharacterEncoding(String encoding)
      Overrides the name of the character encoding used in the body of this request.
      void setResponse(Object response)
      Set the environment-specific response to be returned by subsequent calls to getResponse().
      void setResponseBufferSize(int size)

      Set the buffer size for the current response.
      void setResponseCharacterEncoding(String encoding)
      Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8.
      void setResponseContentLength(int length)

      Set the content length of the response.
      void setResponseContentType(String contentType)

      Sets the content type of the response being sent to the client, if the response has not been committed yet.
      void setResponseHeader(String name, String value)

      Set the response header with the given name and value.
      void setResponseStatus(int statusCode)

      Sets the HTTP status code for the response.
      void setSessionMaxInactiveInterval(int interval)

      Specifies the time, in seconds, between client requests before the servlet container will invalidate this session.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • BASIC_AUTH

        public static final String BASIC_AUTH

        String identifier for BASIC authentication.

        See Also:
        Constant Field Values

      • CLIENT_CERT_AUTH

        public static final String CLIENT_CERT_AUTH

        String identifier for CLIENT_CERT authentication.

        See Also:
        Constant Field Values

      • DIGEST_AUTH

        public static final String DIGEST_AUTH

        String identifier for DIGEST authentication.

        See Also:
        Constant Field Values

      • FORM_AUTH

        public static final String FORM_AUTH

        String identifier for FORM authentication.

        See Also:
        Constant Field Values

    • Constructor Detail

      • ExternalContext

        public ExternalContext()

    • Method Detail

      • addResponseCookie

        public void addResponseCookie(String name,
                     String value,
                     Map<String,Object> properties)

        Adds the cookie represented by the arguments to the response.

        Servlet: This must be accomplished by calling the javax.servlet.http.HttpServletResponse method addCookie(). The Cookie argument must be constructed by passing the name and value parameters. If the properties arugument is non-null and not empty, the Cookie instance must be initialized as described below.

        Key in "values" Map | Expected type of value. | Name of setter method on Cookie instance to be set with the value from the Map.
        comment | String | setComment
        domain | String | setDomain
        maxAge | Integer | setMaxAge
        secure | Boolean | setSecure
        path | String | setPath
        httpOnly | Boolean | setHttpOnly

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Parameters:
        name - To be passed as the first argument to the Cookie constructor.
        value - To be passed as the second argument to the Cookie constructor.
        properties - A Map containg key/value pairs to be passed as arguments to the setter methods as described above.
        Throws:
        IllegalArgumentException - if the properties Map is not-null and not empty and contains any keys that are not one of the keys listed above.
        Since:
        2.0

      • dispatch

        public abstract void dispatch(String path)
                       throws IOException

        Dispatch a request to the specified resource to create output for this response.

        Servlet: This must be accomplished by calling the javax.servlet.ServletContext method getRequestDispatcher(path), and calling the forward() method on the resulting object.

        If the call to getRequestDisatcher(path) returns null, send aServletResponse SC_NOT_FOUND error code.

        Parameters:
        path - Context relative path to the specified resource, which must start with a slash ("/") character
        Throws:
        FacesException - thrown if a ServletException occurs
        IOException - if an input/output error occurs

      • encodeActionURL

        public abstract String encodeActionURL(String url)

        Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable action in the current application.

        Encoding the ClientWindow

          Call ClientWindow.isClientWindowRenderModeEnabled(javax.faces.context.FacesContext). If the result is false take no further action and return the rewritten URL. If the result is true, call getClientWindow(). If the result is non-null, call ClientWindow.getId() and append the id to the query string of the URL, making the necessary allowances for a pre-existing query string or no query-string.

          Call ClientWindow.getQueryURLParameters(javax.faces.context.FacesContext). If the result is non-null, for each parameter in the map, unconditionally add that parameter to the URL.

          The name of the query string parameter is given by the value of the constant ResponseStateManager.CLIENT_WINDOW_URL_PARAM.

        Servlet: This must be the value returned by the javax.servlet.http.HttpServletResponse method encodeURL(url).

        Parameters:
        url - The input URL to be encoded
        Throws:
        NullPointerException - if url is null

      • encodeNamespace

        public abstract String encodeNamespace(String name)

        Return the specified name, after prefixing it with a namespace that ensures that it will be unique within the context of a particular page.

        Servlet: The input value must be returned unchanged.

        Parameters:
        name - Name to be encoded

      • encodeResourceURL

        public abstract String encodeResourceURL(String url)

        Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable resource in the current application.

        Servlet: This must be the value returned by the javax.servlet.http.HttpServletResponse method encodeURL(url).

        Parameters:
        url - The input URL to be encoded
        Throws:
        NullPointerException - if url is null

      • getApplicationMap

        public abstract Map<String,Object> getApplicationMap()

        Return a mutable Map representing the application scope attributes for the current application. The returned Map must implement the entire contract for a modifiable map as described in the JavaDocs for java.util.Map. Modifications made in the Map must cause the corresponding changes in the set of application scope attributes. Particularly the clear(), remove(), put(), putAll(), and get() operations must take the appropriate action on the underlying data structure.

        For any of the Map methods that cause an element to be removed from the underlying data structure, the following action regarding managed-beans must be taken. If the element to be removed is a managed-bean, and it has one or more public no-argument void return methods annotated with javax.annotation.PreDestroy, each such method must be called before the element is removed from the underlying data structure. Elements that are not managed-beans, but do happen to have methods with that annotation must not have those methods called on removal. Any exception thrown by the PreDestroy annotated methods must by caught and not rethrown. The exception may be logged.

        It is valid to call this method during application startup or shutdown. If called at startup or shutdown time, this method returns a Map that is backed by the same container context instance (ServletContext or PortletContext) as the one returned by calling getApplicationMap() on the ExternalContext returned by the FacesContext during an actual request.

        Servlet: This must be the set of attributes available via the javax.servlet.ServletContext methods getAttribute(), getAttributeNames(), removeAttribute(), and setAttribute().

      • getAuthType

        public abstract String getAuthType()

        Return the name of the authentication scheme used to authenticate the current user, if any; otherwise, return null. For standard authentication schemes, the returned value will match one of the following constants: BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, or FORM_AUTH.

        Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getAuthType().

      • getFlash

        public Flash getFlash()

        Return the threadsafe Flash for this application. The default implementation will throw UnsupportedOperationException. Compliant JSF runtimes must provide an implementation of this method.

        Since:
        2.0

      • getMimeType

        public String getMimeType(String file)

        Returns the MIME type of the specified file or null if the MIME type is not known. The MIME type is determined by the container.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this method calls through to the getMimeType() method on the same container context instance (ServletContext or PortletContext) as the one used when calling getMimeType() on the ExternalContext returned by the FacesContext during an actual request.

        Servlet: This must be the value returned by the javax.servlet.ServletContext method getMimeType().

        Parameters:
        file - The file for which the mime type should be obtained.
        Since:
        2.0

      • getContext

        public abstract Object getContext()

        Return the application environment object instance for the current appication.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this returns the same container context instance (ServletContext or PortletContext) as the one returned when calling getContext() on the ExternalContext returned by the FacesContext during an actual request.

        Servlet: This must be the current application's javax.servlet.ServletContext instance.

      • getContextName

        public String getContextName()

        Return the name of the container context for this application.

        Return the result of calling getServletContextName() on the ServletContext instance for this application. It is valid to call this method during application startup or shutdown.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

      • getApplicationContextPath

        public String getApplicationContextPath()

        Return the name of the container context for this application.

        Servlet: Return the result of calling getContextPath() on the ServletContext instance for this application.

        It is valid to call this method during application startup or shutdown.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.2

      • getInitParameter

        public abstract String getInitParameter(String name)

        Return the value of the specified application initialization parameter (if any).

        Servlet: This must be the result of the javax.servlet.ServletContext method getInitParameter(name).

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this method calls through to the actual container context to return the init parameter value.

        Parameters:
        name - Name of the requested initialization parameter
        Throws:
        NullPointerException - if name is null

      • getInitParameterMap

        public abstract Map getInitParameterMap()

        Return an immutable Map whose keys are the set of application initialization parameter names configured for this application, and whose values are the corresponding parameter values. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this method returns a Map that is backed by the same container context instance (ServletContext or PortletContext) as the one returned by calling getInitParameterMap() on the ExternalContext returned by the FacesContext during an actual request.

        Servlet: This result must be as if it were synthesized by calling the javax.servlet.ServletContext method getInitParameterNames, and putting each configured parameter name/value pair into the result.

      • getRemoteUser

        public abstract String getRemoteUser()

        Return the login name of the user making the current request if any; otherwise, return null.

        Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getRemoteUser().

      • getRequest

        public abstract Object getRequest()

        Return the environment-specific object instance for the current request.

        Servlet: This must be the current request's javax.servlet.http.HttpServletRequest instance.

      • setRequest

        public void setRequest(Object request)

        Set the environment-specific request to be returned by subsequent calls to getRequest(). This may be used to install a wrapper for the request.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        1.2

      • getRequestScheme

        public String getRequestScheme()

        Returns the name of the scheme used to make this request, for example, http, https, or ftp.

        Servlet: This must be the value returned by the javax.servlet.ServletRequest method getScheme().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.0

      • getRequestServerName

        public String getRequestServerName()

        Returns the host name of the server to which the request was sent.

        Servlet: This must be the value returned by the javax.servlet.ServletRequest method getServerName().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.0

      • getRequestServerPort

        public int getRequestServerPort()

        Returns the port number to which the request was sent.

        Servlet: This must be the value returned by the javax.servlet.ServletRequest method getServerPort().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.0

      • setRequestCharacterEncoding

        public void setRequestCharacterEncoding(String encoding)
                                 throws UnsupportedEncodingException

        Overrides the name of the character encoding used in the body of this request.

        Calling this method after the request has been accessed will have no no effect, unless a Reader or Stream has been obtained from the request, in which case an IllegalStateException is thrown.

        Servlet: This must call through to the javax.servlet.ServletRequest method setCharacterEncoding().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Throws:
        UnsupportedEncodingException - if this is not a valid encoding
        Since:
        1.2

      • getRealPath

        public String getRealPath(String path)

        Returns a String containing the real path for a given virtual path.

        Servlet: This must be the value returned by the javax.servlet.ServletContext method getRealPath().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Parameters:
        path - The context of the requested initialization parameter
        Since:
        2.0

      • getRequestContextPath

        public abstract String getRequestContextPath()

        Return the portion of the request URI that identifies the web application context for this request.

        Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getContextPath().

      • getRequestCookieMap

        public abstract Map<String,Object> getRequestCookieMap()

        Return an immutable Map whose keys are the set of cookie names included in the current request, and whose values (of type javax.servlet.http.Cookie) are the first (or only) cookie for each cookie name returned by the underlying request. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map.

        Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getCookies(), unless null was returned, in which case this must be a zero-length array.

      • getRequestHeaderMap

        public abstract Map<String,String> getRequestHeaderMap()

        Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String) are the first (or only) value for each header name returned by the underlying request. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map. In addition, key comparisons must be performed in a case insensitive manner.

        Servlet: This must be the set of headers available via the javax.servlet.http.HttpServletRequest methods getHeader() and getHeaderNames().

      • getRequestHeaderValuesMap

        public abstract Map<String,String[]> getRequestHeaderValuesMap()

        Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String[]) are all of the value for each header name returned by the underlying request. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map. In addition, key comparisons must be performed in a case insensitive manner.

        Servlet: This must be the set of headers available via the javax.servlet.http.HttpServletRequest methods getHeaders() and getHeaderNames().

      • getRequestLocale

        public abstract Locale getRequestLocale()

        Return the preferred Locale in which the client will accept content.

        Servlet: This must be the value returned by the javax.servlet.ServletRequest method getLocale().

      • getRequestLocales

        public abstract Iterator<Locale> getRequestLocales()

        Return an Iterator over the preferred Locales specified in the request, in decreasing order of preference.

        Servlet: This must be an Iterator over the values returned by the javax.servlet.ServletRequest method getLocales().

      • getRequestMap

        public abstract Map<String,Object> getRequestMap()

        Return a mutable Map representing the request scope attributes for the current application. The returned Map must implement the entire contract for a modifiable map as described in the JavaDocs for java.util.Map. Modifications made in the Map must cause the corresponding changes in the set of request scope attributes. Particularly the clear(), remove(), put(), putAll(), and get() operations must take the appropriate action on the underlying data structure.

        For any of the Map methods that cause an element to be removed from the underlying data structure, the following action regarding managed-beans must be taken. If the element to be removed is a managed-bean, and it has one or more public no-argument void return methods annotated with javax.annotation.PreDestroy, each such method must be called before the element is removed from the underlying data structure. Elements that are not managed-beans, but do happen to have methods with that annotation must not have those methods called on removal. Any exception thrown by the PreDestroy annotated methods must by caught and not rethrown. The exception may be logged.

        Servlet: This must be the set of attributes available via the javax.servlet.ServletRequest methods getAttribute(), getAttributeNames(), removeAttribute(), and setAttribute().

      • getRequestParameterMap

        public abstract Map<String,String> getRequestParameterMap()

        Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String) are the first (or only) value for each parameter name returned by the underlying request. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map.

        Servlet: This must be the set of parameters available via the javax.servlet.ServletRequest methods getParameter() and getParameterNames().

      • getRequestParameterNames

        public abstract Iterator<String> getRequestParameterNames()

        Return an Iterator over the names of all request parameters included in the current request.

        Servlet: This must be an Iterator over the values returned by the javax.servlet.ServletRequest method getParameterNames().

      • getRequestParameterValuesMap

        public abstract Map<String,String[]> getRequestParameterValuesMap()

        Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String[]) are all of the values for each parameter name returned by the underlying request. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map.

        Servlet: This must be the set of parameters available via the javax.servlet.ServletRequest methods getParameterValues() and getParameterNames().

      • getRequestPathInfo

        public abstract String getRequestPathInfo()

        Return the extra path information (if any) included in the request URI; otherwise, return null.

        Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getPathInfo().

      • getRequestServletPath

        public abstract String getRequestServletPath()

        Return the servlet path information (if any) included in the request URI; otherwise, return null.

        Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getServletPath().

      • getRequestCharacterEncoding

        public String getRequestCharacterEncoding()

        Return the character encoding currently being used to interpret this request.

        Servlet: This must return the value returned by the javax.servlet.ServletRequest method getCharacterEncoding().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        1.2

      • getRequestContentType

        public String getRequestContentType()

        Return the MIME Content-Type for this request. If not available, return null.

        Servlet: This must return the value returned by the javax.servlet.ServletRequest method getContentType().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        1.2

      • getRequestContentLength

        public int getRequestContentLength()

        Return the result of calling getContentLenth() on the ServletRequest instance for this request.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.0

      • getResponseCharacterEncoding

        public String getResponseCharacterEncoding()

        Returns the name of the character encoding (MIME charset) used for the body sent in this response.

        Servlet: This must return the value returned by the javax.servlet.ServletResponse method getCharacterEncoding().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        1.2

      • getResponseContentType

        public String getResponseContentType()

        Return the MIME Content-Type for this response. If not available, return null.

        Servlet: This must return the value returned by the javax.servlet.ServletResponse method getContentType().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        1.2

      • getResource

        public abstract URL getResource(String path)
                         throws MalformedURLException

        Return a URL for the application resource mapped to the specified path, if it exists; otherwise, return null.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this method calls through to the getResource() method on the same container context instance (ServletContext or PortletContext) as the one used when calling getResource() on the ExternalContext returned by the FacesContext during an actual request.

        Servlet: This must be the value returned by the javax.servlet.ServletContext method getResource(path).

        Parameters:
        path - The path to the requested resource, which must start with a slash ("/" character
        Throws:
        MalformedURLException - if the specified path is not in the correct form
        NullPointerException - if path is null

      • getResourceAsStream

        public abstract InputStream getResourceAsStream(String path)

        Return an InputStream for an application resource mapped to the specified path, if it exists; otherwise, return null.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this method calls through to the getResourceAsStream() method on the same container context instance (ServletContext or PortletContext) as the one used when calling getResourceAsStream() on the ExternalContext returned by the FacesContext during an actual request.

        Servlet: This must be the value returned by the javax.servlet.ServletContext method getResourceAsStream(path).

        Parameters:
        path - The path to the requested resource, which must start with a slash ("/" character
        Throws:
        NullPointerException - if path is null

      • getResourcePaths

        public abstract Set<String> getResourcePaths(String path)

        Return the Set of resource paths for all application resources whose resource path starts with the specified argument.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this method calls through to the getResourcePaths() method on the same container context instance (ServletContext or PortletContext) as the one used when calling getResourcePaths() on the ExternalContext returned by the FacesContext during an actual request.

        Servlet: This must be the value returned by the javax.servlet.ServletContext method getResourcePaths(path).

        Parameters:
        path - Partial path used to match resources, which must start with a slash ("/") character
        Throws:
        NullPointerException - if path is null

      • getResponse

        public abstract Object getResponse()

        Return the environment-specific object instance for the current response.

        Servlet: This is the current request's javax.servlet.http.HttpServletResponse instance.

      • setResponse

        public void setResponse(Object response)

        Set the environment-specific response to be returned by subsequent calls to getResponse(). This may be used to install a wrapper for the response.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        1.2

      • getResponseOutputStream

        public OutputStream getResponseOutputStream()
                                     throws IOException

        Returns an OutputStream suitable for writing binary data to the user-agent.

        Servlet: This must return the value returned by the javax.servlet.ServletResponse method getOutputStream().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Throws:
        IOException
        Since:
        2.0

      • getResponseOutputWriter

        public Writer getResponseOutputWriter()
                               throws IOException

        Returns a Writer suitable for writing character data to the user-agent.

        Servlet: This must return the value returned by the ServletResponse.getWriter().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Throws:
        IOException
        Since:
        2.0

      • setResponseCharacterEncoding

        public void setResponseCharacterEncoding(String encoding)

        Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8.

        Servlet: This must call through to the javax.servlet.ServletResponse method setCharacterEncoding().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        1.2

      • setResponseContentType

        public void setResponseContentType(String contentType)

        Sets the content type of the response being sent to the client, if the response has not been committed yet.

        Servlet: This must call setContentType() on the underlying javax.servlet.ServletResponse instance.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Parameters:
        contentType - The content type to be set as the contentType of the response.
        Since:
        2.0

      • getSession

        public abstract Object getSession(boolean create)

        If the create parameter is true, create (if necessary) and return a session instance associated with the current request. If the create parameter is false return any existing session instance associated with the current request, or return null if there is no such session.

        Servlet: This must return the result of calling getSession(create) on the underlying javax.servlet.http.HttpServletRequest instance.

        Parameters:
        create - Flag indicating whether or not a new session should be created if there is no session associated with the current request

      • getSessionId

        public String getSessionId(boolean create)

        Return the id of the current session or the empty string if no session has been created and the create parameter is false.

        Servlet: If create is true, obtain a reference to the HttpSession for the current request (creating the session if necessary) and return its id. If create is false, obtain a reference to the current session, if one exists, and return its id. If no session exists, return the empty string.

        Parameters:
        create - Flag indicating whether or not a new session should be created if there is no session associated with the current request
        Since:
        2.2

      • getSessionMaxInactiveInterval

        public int getSessionMaxInactiveInterval()

        Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses. After this interval, the servlet container will invalidate the session. The maximum time interval can be set with the setSessionMaxInactiveInterval(int) method.

        A return value of zero or less indicates that the session will never timeout.

        Servlet: This must return the result of calling getMaxInactiveInterval on the underlying javax.servlet.http.HttpServletRequest instance.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.1

      • getSessionMap

        public abstract Map<String,Object> getSessionMap()

        Return a mutable Map representing the session scope attributes for the current application. The returned Map must implement the entire contract for a modifiable map as described in the JavaDocs for java.util.Map. Modifications made in the Map must cause the corresponding changes in the set of session scope attributes. Particularly the clear(), remove(), put(), and get() operations must take the appropriate action on the underlying data structure. Accessing attributes via this Map must cause the creation of a session associated with the current request, if such a session does not already exist.

        For any of the Map methods that cause an element to be removed from the underlying data structure, the following action regarding managed-beans must be taken. If the element to be removed is a managed-bean, and it has one or more public no-argument void return methods annotated with javax.annotation.PreDestroy, each such method must be called before the element is removed from the underlying data structure. Elements that are not managed-beans, but do happen to have methods with that annotation must not have those methods called on removal. Any exception thrown by the PreDestroy annotated methods must by caught and not rethrown. The exception may be logged.

        Servlet: This must be the set of attributes available via the javax.servlet.http.HttpSession methods getAttribute(), getAttributeNames(), removeAttribute(), and setAttribute().

      • getUserPrincipal

        public abstract Principal getUserPrincipal()

        Return the Principal object containing the name of the current authenticated user, if any; otherwise, return null.

        Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getUserPrincipal().

      • getClientWindow

        public ClientWindow getClientWindow()

        Return the ClientWindow set in a preceding call to setClientWindow(javax.faces.lifecycle.ClientWindow), or null if no such call has been made.

        Since:
        2.2

      • invalidateSession

        public void invalidateSession()

        Invalidates this session then unbinds any objects bound to it.

        Servlet: This must be the value returned by the javax.servlet.http.HttpSession method invalidate().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.0

      • isUserInRole

        public abstract boolean isUserInRole(String role)

        Return true if the currently authenticated user is included in the specified role. Otherwise, return false.

        Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method isUserInRole(role).

        Parameters:
        role - Logical role name to be checked
        Throws:
        NullPointerException - if role is null

      • log

        public abstract void log(String message)

        Log the specified message to the application object.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this calls the log() method on the same container context instance (ServletContext or PortletContext) as the one used during a call to log() on the ExternalContext returned by the FacesContext during an actual request.

        Servlet: This must be performed by calling the javax.servlet.ServletContext method log(String).

        Parameters:
        message - Message to be logged
        Throws:
        NullPointerException - if message is null

      • log

        public abstract void log(String message,
       Throwable exception)

        Log the specified message and exception to the application object.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this calls the log() method on the same container context instance (ServletContext or PortletContext) as the one used when calling log() on the ExternalContext returned by the FacesContext during an actual request.

        Servlet: This must be performed by calling the javax.servlet.ServletContext method log(String,Throwable).

        Parameters:
        message - Message to be logged
        exception - Exception to be logged
        Throws:
        NullPointerException - if message or exception is null

      • redirect

        public abstract void redirect(String url)
                       throws IOException

        Redirect a request to the specified URL, and cause the responseComplete() method to be called on the FacesContext instance for the current request.

        The implementation must determine if the request is an Ajax request by obtaining a PartialViewContext instance from the FacesContext and calling PartialViewContext.isAjaxRequest().

        Servlet: For non Ajax requests, this must be accomplished by calling the javax.servlet.http.HttpServletResponse method sendRedirect().

        For Ajax requests, the implementation must:
        • Get a PartialResponseWriter instance from the FacesContext.
        • Call setResponseContentType(java.lang.String) with text/xml
        • Call setResponseCharacterEncoding(java.lang.String) with UTF-8
        • Call addResponseHeader(java.lang.String, java.lang.String) with Cache-Control, no-cache
        • Call PartialResponseWriter.startDocument()
        • Call PartialResponseWriter.redirect(java.lang.String) with the url argument.
        • Call PartialResponseWriter.endDocument()

        Parameters:
        url - Absolute URL to which the client should be redirected
        Throws:
        IllegalArgumentException - if the specified url is relative
        IllegalStateException - if, in a portlet environment, the current response object is a RenderResponse instead of an ActionResponse
        IllegalStateException - if, in a servlet environment, the current response has already been committed
        IOException - if an input/output error occurs

      • setResponseHeader

        public void setResponseHeader(String name,
                     String value)

        Set the response header with the given name and value.

        Servlet:This must be performed by calling the javax.servlet.http.HttpServletResponse setHeader method.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Parameters:
        name - The name of the response header.
        value - The value of the response header.
        Since:
        2.0

      • addResponseHeader

        public void addResponseHeader(String name,
                     String value)

        Add the given name and value to the response header.

        Servlet:This must be performed by calling the javax.servlet.http.HttpServletResponse addHeader method.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Parameters:
        name - The name of the response header.
        value - The value of the response header.
        Since:
        2.0

      • setResponseBufferSize

        public void setResponseBufferSize(int size)

        Set the buffer size for the current response.

        Servlet: This must be performed by calling the javax.servlet.http.HttpServletResponse setBufferSize method.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Parameters:
        size - the new buffer size
        Since:
        2.0

      • getResponseBufferSize

        public int getResponseBufferSize()

        Return the buffer size for the current response.

        Servlet: This must be performed by calling the javax.servlet.http.HttpServletResponse getBufferSize method.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.0

      • isResponseCommitted

        public boolean isResponseCommitted()

        Check if the current response has been committed.

        Servlet: This must be performed by calling the javax.servlet.http.HttpServletResponse isCommitted method.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.0

      • responseReset

        public void responseReset()

        Resets the current response.

        Servlet: This must be performed by calling the javax.servlet.http.HttpServletResponse reset method.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.0

      • responseSendError

        public void responseSendError(int statusCode,
                     String message)
                       throws IOException

        Sends an HTTP status code with message.

        Servlet: This must be performed by calling the javax.servlet.http.HttpServletResponse sendError method.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Parameters:
        statusCode - an HTTP status code
        message - an option message to detail the cause of the code
        Throws:
        IOException
        Since:
        2.0

      • setResponseStatus

        public void setResponseStatus(int statusCode)

        Sets the HTTP status code for the response.

        Servlet: This must be performed by calling the javax.servlet.http.HttpServletResponse setStatus method.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Parameters:
        statusCode - an HTTP status code
        Since:
        2.0

      • setSessionMaxInactiveInterval

        public void setSessionMaxInactiveInterval(int interval)

        Specifies the time, in seconds, between client requests before the servlet container will invalidate this session.

        An interval value of zero or less indicates that the session should never timeout.

        Servlet: This must call setMaxInactiveInterval on the underlying javax.servlet.http.HttpServletRequest instance.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.1

      • setClientWindow

        public void setClientWindow(ClientWindow window)

        Associate this instance with a ClientWindow.

        Parameters:
        window - the window with which this instance is associated.
        Since:
        2.2

      • responseFlushBuffer

        public void responseFlushBuffer()
                         throws IOException

        Flushes the buffered response content to the client.

        Servlet: This must be performed by calling the javax.servlet.http.HttpServletResponse flushBuffer method.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Throws:
        IOException
        Since:
        2.0

      • setResponseContentLength

        public void setResponseContentLength(int length)

        Set the content length of the response.

        Servlet: This must be performed by calling the javax.servlet.http.HttpServletResponse setContentLength method.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.0

      • encodeBookmarkableURL

        public String encodeBookmarkableURL(String baseUrl,
                           Map<String,List<String>> parameters)

        The purpose of this method is to generate a query string from the collection of Parameter objects provided by the parameters argument and append that query string to the baseUrl. This method must be able to encode the parameters to a baseUrl that may or may not have existing query parameters. The parameter values should be encoded appropriately for the environment so that the resulting URL can be used as the target of a link (e.g., in an href attribute) in a JSF response. It's possible for an ExternalContext implementation to override this method in any way that would make the URL bookmarkable in that environment.

        See encodeActionURL(java.lang.String) for the required specification of how to encode the ClientWindow.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Parameters:
        baseUrl - The base URL onto which the query string generated by this method will be appended. The URL may contain query parameters.
        parameters - The collection of Parameter objects, representing name=value pairs that are used to produce a query string
        Since:
        2.0

      • encodeRedirectURL

        public String encodeRedirectURL(String baseUrl,
                       Map<String,List<String>> parameters)
        The purpose of this method is to generate a query string from the collection of Parameter objects provided by the parameters argument and append that query string to the baseUrl. This method must be able to encode the parameters to a baseUrl that may or may not have existing query parameters. The parameter values should be encoded appropriately for the environment so that the resulting URL can be used as the target of a redirect. It's possible for an ExternalContext implementation to override this method to accomodate the definition of redirect for that environment.

        See encodeActionURL(java.lang.String) for the required specification of how to encode the ClientWindow.

        Parameters:
        baseUrl - The base URL onto which the query string generated by this method will be appended. The URL may contain query parameters.
        parameters - The collection of Parameter objects, representing name=value pairs that are used to produce a query string
        Since:
        2.0

      • encodePartialActionURL

        public String encodePartialActionURL(String url)

        Return the input URL, after performing any rewriting needed to ensure that it can be used in a partial page submission (ajax request) to correctly identify an addressable action in the current application.

        See encodeActionURL(java.lang.String) for the required specification of how to encode the ClientWindow.

        Servlet:Returns the same encoded URL as the encodeActionURL(String url) method.

        Portlet:Returns an encoded URL that, upon HTTP POST, will invoke the RESOURCE_PHASE of the portlet lifecycle.

        Parameters:
        url - The input URL to be encoded
        Throws:
        NullPointerException - if url is null
        Since:
        2.0

      • isSecure

        public boolean isSecure()

        Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.

        Servlet: This must return the result of calling isSecure on the underlying javax.servlet.http.HttpServletRequest instance.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Since:
        2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExternalContextFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class ExternalContextFactory

  • java.lang.Object
    • javax.faces.context.ExternalContextFactory
  • All Implemented Interfaces:
    FacesWrapper<ExternalContextFactory>

    public abstract class ExternalContextFactory
extends Object
implements FacesWrapper<ExternalContextFactory>

    ExternalContextFactory is a factory object that creates (if needed) and returns new ExternalContext instances, initialized for the processing of the specified request and response objects.

    There must be one ExternalContextFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

       ExternalContextFactory factory = (ExternalContextFactory)
    FactoryFinder.getFactory(FactoryFinder.EXTERNAL_CONTEXT_FACTORY);

    • Constructor Summary

      Constructors
      Constructor and Description
      ExternalContextFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ExternalContext getExternalContext(Object context, Object request, Object response)
      Create (if needed) and return an ExternalContext instance that is initialized for the processing of the specified request and response objects, for this web application.
      ExternalContextFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ExternalContextFactory

        public ExternalContextFactory()

    • Method Detail

      • getWrapped

        public ExternalContextFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<ExternalContextFactory>
        Since:
        2.0

      • getExternalContext

        public abstract ExternalContext getExternalContext(Object context,
                                 Object request,
                                 Object response)
                                            throws FacesException

        Create (if needed) and return an ExternalContext instance that is initialized for the processing of the specified request and response objects, for this web application.

        Parameters:
        context - In servlet environments, the ServletContext that is associated with this web application
        request - In servlet environments, the ServletRequest that is to be processed
        response - In servlet environments, the ServletResponse that is to be processed
        Throws:
        FacesException - if a ExternalContext cannot be constructed for the specified parameters
        NullPointerException - if any of the parameters are null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExternalContextWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class ExternalContextWrapper

  • java.lang.Object
    • javax.faces.context.ExternalContext
      • javax.faces.context.ExternalContextWrapper
  • All Implemented Interfaces:
    FacesWrapper<ExternalContext>

    public abstract class ExternalContextWrapper
extends ExternalContext
implements FacesWrapper<ExternalContext>

    Provides a simple implementation of ExternalContext that can be subclassed by developers wishing to provide specialized behavior to an existing ExternalContext instance. The default implementation of all methods is to call through to the wrapped ExternalContext instance.

    Usage: extend this class and override getWrapped() to return the instance being wrapping.

    Since:
    2.0

    • Field Summary

      • Fields inherited from class javax.faces.context.ExternalContext

        BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH

    • Constructor Summary

      Constructors
      Constructor and Description
      ExternalContextWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addResponseCookie(String name, String value, Map<String,Object> properties)
      The default behavior of this method is to call ExternalContext.addResponseCookie(String, String, Map) on the wrapped ExternalContext object.
      void addResponseHeader(String name, String value)
      The default behavior of this method is to call ExternalContext.addResponseHeader(String,String) on the wrapped ExternalContext object.
      void dispatch(String path)
      The default behavior of this method is to call ExternalContext.dispatch(String) on the wrapped ExternalContext object.
      String encodeActionURL(String url)
      The default behavior of this method is to call ExternalContext.encodeActionURL(String) on the wrapped ExternalContext object.
      String encodeBookmarkableURL(String baseUrl, Map<String,List<String>> parameters)
      The default behavior of this method is to call ExternalContext.encodeBookmarkableURL(String, java.util.Map) on the wrapped ExternalContext object.
      String encodeNamespace(String name)
      The default behavior of this method is to call ExternalContext.encodeNamespace(String) on the wrapped ExternalContext object.
      String encodePartialActionURL(String url)
      The default behavior of this method is to call ExternalContext.encodePartialActionURL(String) on the wrapped ExternalContext object.
      String encodeRedirectURL(String baseUrl, Map<String,List<String>> parameters)
      The default behavior of this method is to call ExternalContext.encodeRedirectURL(String, java.util.Map) on the wrapped ExternalContext object.
      String encodeResourceURL(String url)
      The default behavior of this method is to call ExternalContext.encodeResourceURL(String) on the wrapped ExternalContext object.
      String getApplicationContextPath()

      The default behavior of this method is to call ExternalContext.getApplicationContextPath() on the wrapped ExternalContext object.
      Map<String,Object> getApplicationMap()
      The default behavior of this method is to call ExternalContext.getApplicationMap() on the wrapped ExternalContext object.
      String getAuthType()
      The default behavior of this method is to call ExternalContext.getAuthType() on the wrapped ExternalContext object.
      ClientWindow getClientWindow()

      The default behavior of this method is to call ExternalContext.getClientWindow() on the wrapped ExternalContext object.
      Object getContext()
      The default behavior of this method is to call ExternalContext.getContext() on the wrapped ExternalContext object.
      String getContextName()
      The default behavior of this method is to call ExternalContext.getContextName() on the wrapped ExternalContext object.
      Flash getFlash()
      The default behavior of this method is to call ExternalContext.getFlash() on the wrapped ExternalContext object.
      String getInitParameter(String name)
      The default behavior of this method is to call ExternalContext.getInitParameter(String) on the wrapped ExternalContext object.
      Map getInitParameterMap()
      The default behavior of this method is to call ExternalContext.getInitParameterMap() on the wrapped ExternalContext object.
      String getMimeType(String file)
      The default behavior of this method is to call ExternalContext.getMimeType(String) on the wrapped ExternalContext object.
      String getRealPath(String path)
      The default behavior of this method is to call ExternalContext.getRealPath(String) on the wrapped ExternalContext object.
      String getRemoteUser()
      The default behavior of this method is to call ExternalContext.getRemoteUser() on the wrapped ExternalContext object.
      Object getRequest()
      The default behavior of this method is to call ExternalContext.getRequest() on the wrapped ExternalContext object.
      String getRequestCharacterEncoding()
      The default behavior of this method is to call ExternalContext.getRequestCharacterEncoding() on the wrapped ExternalContext object.
      int getRequestContentLength()
      The default behavior of this method is to call ExternalContext.getRequestContentLength() on the wrapped ExternalContext object.
      String getRequestContentType()
      The default behavior of this method is to call ExternalContext.getRequestContentType() on the wrapped ExternalContext object.
      String getRequestContextPath()
      The default behavior of this method is to call ExternalContext.getRequestContextPath() on the wrapped ExternalContext object.
      Map<String,Object> getRequestCookieMap()
      The default behavior of this method is to call ExternalContext.getRequestCookieMap() on the wrapped ExternalContext object.
      Map<String,String> getRequestHeaderMap()
      The default behavior of this method is to call ExternalContext.getRequestHeaderMap() on the wrapped ExternalContext object.
      Map<String,String[]> getRequestHeaderValuesMap()
      The default behavior of this method is to call ExternalContext.getRequestHeaderValuesMap() on the wrapped ExternalContext object.
      Locale getRequestLocale()
      The default behavior of this method is to call ExternalContext.getRequestLocale() on the wrapped ExternalContext object.
      Iterator<Locale> getRequestLocales()
      The default behavior of this method is to call ExternalContext.getRequestLocales() on the wrapped ExternalContext object.
      Map<String,Object> getRequestMap()
      The default behavior of this method is to call ExternalContext.getRequestMap() on the wrapped ExternalContext object.
      Map<String,String> getRequestParameterMap()
      The default behavior of this method is to call ExternalContext.getRequestParameterMap() on the wrapped ExternalContext object.
      Iterator<String> getRequestParameterNames()
      The default behavior of this method is to call ExternalContext.getRequestParameterNames() on the wrapped ExternalContext object.
      Map<String,String[]> getRequestParameterValuesMap()
      The default behavior of this method is to call ExternalContext.getRequestParameterValuesMap() on the wrapped ExternalContext object.
      String getRequestPathInfo()
      The default behavior of this method is to call ExternalContext.getRequestPathInfo() on the wrapped ExternalContext object.
      String getRequestScheme()
      The default behavior of this method is to call ExternalContext.getRequestScheme() on the wrapped ExternalContext object.
      String getRequestServerName()
      The default behavior of this method is to call ExternalContext.getRequestServerName() on the wrapped ExternalContext object.
      int getRequestServerPort()
      The default behavior of this method is to call ExternalContext.getRequestServerPort() on the wrapped ExternalContext object.
      String getRequestServletPath()
      The default behavior of this method is to call ExternalContext.getRequestServletPath() on the wrapped ExternalContext object.
      URL getResource(String path)
      The default behavior of this method is to call ExternalContext.getResource(String) on the wrapped ExternalContext object.
      InputStream getResourceAsStream(String path)
      The default behavior of this method is to call ExternalContext.getResourceAsStream(String) on the wrapped ExternalContext object.
      Set<String> getResourcePaths(String path)
      The default behavior of this method is to call ExternalContext.getResourcePaths(String) on the wrapped ExternalContext object.
      Object getResponse()
      The default behavior of this method is to call ExternalContext.getResponse() on the wrapped ExternalContext object.
      int getResponseBufferSize()
      The default behavior of this method is to call ExternalContext.getResponseBufferSize() on the wrapped ExternalContext object.
      String getResponseCharacterEncoding()
      The default behavior of this method is to call ExternalContext.getResponseCharacterEncoding() on the wrapped ExternalContext object.
      String getResponseContentType()
      The default behavior of this method is to call ExternalContext.getResponseContentType() on the wrapped ExternalContext object.
      OutputStream getResponseOutputStream()
      The default behavior of this method is to call ExternalContext.getResponseOutputStream() on the wrapped ExternalContext object.
      Writer getResponseOutputWriter()
      The default behavior of this method is to call ExternalContext.getResponseOutputWriter() on the wrapped ExternalContext object.
      Object getSession(boolean create)
      The default behavior of this method is to call ExternalContext.getSession(boolean) on the wrapped ExternalContext object.
      String getSessionId(boolean create)

      The default behavior of this method is to call ExternalContext.getSessionId(boolean) on the wrapped ExternalContext object.
      Map<String,Object> getSessionMap()
      The default behavior of this method is to call ExternalContext.getSessionMap() on the wrapped ExternalContext object.
      int getSessionMaxInactiveInterval()

      The default behavior of this method is to call ExternalContext.getSessionMaxInactiveInterval() on the wrapped ExternalContext object.
      Principal getUserPrincipal()
      The default behavior of this method is to call ExternalContext.getUserPrincipal() on the wrapped ExternalContext object.
      abstract ExternalContext getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void invalidateSession()
      The default behavior of this method is to call ExternalContext.invalidateSession() on the wrapped ExternalContext object.
      boolean isResponseCommitted()
      The default behavior of this method is to call ExternalContext.isResponseCommitted() on the wrapped ExternalContext object.
      boolean isSecure()

      The default behavior of this method is to call ExternalContext.isSecure() on the wrapped ExternalContext object.
      boolean isUserInRole(String role)
      The default behavior of this method is to call ExternalContext.isUserInRole(String) on the wrapped ExternalContext object.
      void log(String message)
      The default behavior of this method is to call ExternalContext.log(String) on the wrapped ExternalContext object.
      void log(String message, Throwable exception)
      The default behavior of this method is to call ExternalContext.log(String, Throwable) on the wrapped ExternalContext object.
      void redirect(String url)
      The default behavior of this method is to call ExternalContext.redirect(String) on the wrapped ExternalContext object.
      void responseFlushBuffer()
      The default behavior of this method is to call ExternalContext.responseFlushBuffer() on the wrapped ExternalContext object.
      void responseReset()
      The default behavior of this method is to call ExternalContext.responseReset() on the wrapped ExternalContext object.
      void responseSendError(int statusCode, String message)
      The default behavior of this method is to call ExternalContext.responseSendError(int,String) on the wrapped ExternalContext object.
      void setClientWindow(ClientWindow window)

      The default behavior of this method is to call ExternalContext.setClientWindow(javax.faces.lifecycle.ClientWindow) on the wrapped ExternalContext object.
      void setRequest(Object request)
      The default behavior of this method is to call ExternalContext.setRequest(Object) on the wrapped ExternalContext object.
      void setRequestCharacterEncoding(String encoding)
      The default behavior of this method is to call ExternalContext.setRequestCharacterEncoding(String) on the wrapped ExternalContext object.
      void setResponse(Object response)
      The default behavior of this method is to call ExternalContext.setResponse(Object) on the wrapped ExternalContext object.
      void setResponseBufferSize(int size)
      The default behavior of this method is to call ExternalContext.setResponseBufferSize(int) on the wrapped ExternalContext object.
      void setResponseCharacterEncoding(String encoding)
      The default behavior of this method is to call ExternalContext.getResponseCharacterEncoding() on the wrapped ExternalContext object.
      void setResponseContentLength(int length)
      The default behavior of this method is to call ExternalContext.setResponseContentLength(int) on the wrapped ExternalContext object.
      void setResponseContentType(String contentType)
      The default behavior of this method is to call ExternalContext.setResponseContentType(String) on the wrapped ExternalContext object.
      void setResponseHeader(String name, String value)
      The default behavior of this method is to call ExternalContext.setResponseHeader(String,String) on the wrapped ExternalContext object.
      void setResponseStatus(int statusCode)
      The default behavior of this method is to call ExternalContext.setResponseStatus(int) on the wrapped ExternalContext object.
      void setSessionMaxInactiveInterval(int interval)

      The default behavior of this method is to call ExternalContext.setSessionMaxInactiveInterval(int) on the wrapped ExternalContext object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ExternalContextWrapper

        public ExternalContextWrapper()

    • Method Detail

      • getWrapped

        public abstract ExternalContext getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<ExternalContext>
        Returns:
        the wrapped ExternalContext instance
        See Also:
        FacesWrapper.getWrapped()

      • dispatch

        public void dispatch(String path)
              throws IOException

        The default behavior of this method is to call ExternalContext.dispatch(String) on the wrapped ExternalContext object.

        Specified by:
        dispatch in class ExternalContext
        Parameters:
        path - Context relative path to the specified resource, which must start with a slash ("/") character
        Throws:
        IOException - if an input/output error occurs
        See Also:
        ExternalContext.dispatch(String)

      • encodeActionURL

        public String encodeActionURL(String url)

        The default behavior of this method is to call ExternalContext.encodeActionURL(String) on the wrapped ExternalContext object.

        Specified by:
        encodeActionURL in class ExternalContext
        Parameters:
        url - The input URL to be encoded
        See Also:
        ExternalContext.encodeActionURL(String)

      • encodeNamespace

        public String encodeNamespace(String name)

        The default behavior of this method is to call ExternalContext.encodeNamespace(String) on the wrapped ExternalContext object.

        Specified by:
        encodeNamespace in class ExternalContext
        Parameters:
        name - Name to be encoded
        See Also:
        ExternalContext.encodeNamespace(String)

      • encodePartialActionURL

        public String encodePartialActionURL(String url)

        The default behavior of this method is to call ExternalContext.encodePartialActionURL(String) on the wrapped ExternalContext object.

        Overrides:
        encodePartialActionURL in class ExternalContext
        Parameters:
        url - The input URL to be encoded
        See Also:
        ExternalContext.encodePartialActionURL(String)

      • encodeResourceURL

        public String encodeResourceURL(String url)

        The default behavior of this method is to call ExternalContext.encodeResourceURL(String) on the wrapped ExternalContext object.

        Specified by:
        encodeResourceURL in class ExternalContext
        Parameters:
        url - The input URL to be encoded
        See Also:
        ExternalContext.encodeResourceURL(String)

      • getApplicationMap

        public Map<String,Object> getApplicationMap()

        The default behavior of this method is to call ExternalContext.getApplicationMap() on the wrapped ExternalContext object.

        Specified by:
        getApplicationMap in class ExternalContext
        See Also:
        ExternalContext.getApplicationMap()

      • getApplicationContextPath

        public String getApplicationContextPath()

        The default behavior of this method is to call ExternalContext.getApplicationContextPath() on the wrapped ExternalContext object.

        Overrides:
        getApplicationContextPath in class ExternalContext
        See Also:
        ExternalContext.getApplicationContextPath()

      • getAuthType

        public String getAuthType()

        The default behavior of this method is to call ExternalContext.getAuthType() on the wrapped ExternalContext object.

        Specified by:
        getAuthType in class ExternalContext
        See Also:
        ExternalContext.getAuthType()

      • getContext

        public Object getContext()

        The default behavior of this method is to call ExternalContext.getContext() on the wrapped ExternalContext object.

        Specified by:
        getContext in class ExternalContext
        See Also:
        ExternalContext.getContext()

      • getInitParameter

        public String getInitParameter(String name)

        The default behavior of this method is to call ExternalContext.getInitParameter(String) on the wrapped ExternalContext object.

        Specified by:
        getInitParameter in class ExternalContext
        Parameters:
        name - Name of the requested initialization parameter
        See Also:
        ExternalContext.getInitParameter(String)

      • getInitParameterMap

        public Map getInitParameterMap()

        The default behavior of this method is to call ExternalContext.getInitParameterMap() on the wrapped ExternalContext object.

        Specified by:
        getInitParameterMap in class ExternalContext
        See Also:
        ExternalContext.getInitParameterMap()

      • getRemoteUser

        public String getRemoteUser()

        The default behavior of this method is to call ExternalContext.getRemoteUser() on the wrapped ExternalContext object.

        Specified by:
        getRemoteUser in class ExternalContext
        See Also:
        ExternalContext.getRemoteUser()

      • getRequest

        public Object getRequest()

        The default behavior of this method is to call ExternalContext.getRequest() on the wrapped ExternalContext object.

        Specified by:
        getRequest in class ExternalContext
        See Also:
        ExternalContext.getRequest()

      • getRequestContextPath

        public String getRequestContextPath()

        The default behavior of this method is to call ExternalContext.getRequestContextPath() on the wrapped ExternalContext object.

        Specified by:
        getRequestContextPath in class ExternalContext
        See Also:
        ExternalContext.getRequestContextPath()

      • getRequestCookieMap

        public Map<String,Object> getRequestCookieMap()

        The default behavior of this method is to call ExternalContext.getRequestCookieMap() on the wrapped ExternalContext object.

        Specified by:
        getRequestCookieMap in class ExternalContext
        See Also:
        ExternalContext.getRequestCookieMap()

      • getRequestHeaderMap

        public Map<String,String> getRequestHeaderMap()

        The default behavior of this method is to call ExternalContext.getRequestHeaderMap() on the wrapped ExternalContext object.

        Specified by:
        getRequestHeaderMap in class ExternalContext
        See Also:
        ExternalContext.getRequestHeaderMap()

      • getRequestHeaderValuesMap

        public Map<String,String[]> getRequestHeaderValuesMap()

        The default behavior of this method is to call ExternalContext.getRequestHeaderValuesMap() on the wrapped ExternalContext object.

        Specified by:
        getRequestHeaderValuesMap in class ExternalContext
        See Also:
        ExternalContext.getRequestHeaderValuesMap()

      • getRequestLocale

        public Locale getRequestLocale()

        The default behavior of this method is to call ExternalContext.getRequestLocale() on the wrapped ExternalContext object.

        Specified by:
        getRequestLocale in class ExternalContext
        See Also:
        ExternalContext.getRequestLocale()

      • getRequestLocales

        public Iterator<Locale> getRequestLocales()

        The default behavior of this method is to call ExternalContext.getRequestLocales() on the wrapped ExternalContext object.

        Specified by:
        getRequestLocales in class ExternalContext
        See Also:
        ExternalContext.getRequestLocales()

      • getRequestMap

        public Map<String,Object> getRequestMap()

        The default behavior of this method is to call ExternalContext.getRequestMap() on the wrapped ExternalContext object.

        Specified by:
        getRequestMap in class ExternalContext
        See Also:
        ExternalContext.getRequestMap()

      • getRequestParameterMap

        public Map<String,String> getRequestParameterMap()

        The default behavior of this method is to call ExternalContext.getRequestParameterMap() on the wrapped ExternalContext object.

        Specified by:
        getRequestParameterMap in class ExternalContext
        See Also:
        ExternalContext.getRequestParameterMap()

      • getRequestParameterNames

        public Iterator<String> getRequestParameterNames()

        The default behavior of this method is to call ExternalContext.getRequestParameterNames() on the wrapped ExternalContext object.

        Specified by:
        getRequestParameterNames in class ExternalContext
        See Also:
        ExternalContext.getRequestParameterNames()

      • getRequestParameterValuesMap

        public Map<String,String[]> getRequestParameterValuesMap()

        The default behavior of this method is to call ExternalContext.getRequestParameterValuesMap() on the wrapped ExternalContext object.

        Specified by:
        getRequestParameterValuesMap in class ExternalContext
        See Also:
        ExternalContext.getRequestParameterValuesMap()

      • getRequestPathInfo

        public String getRequestPathInfo()

        The default behavior of this method is to call ExternalContext.getRequestPathInfo() on the wrapped ExternalContext object.

        Specified by:
        getRequestPathInfo in class ExternalContext
        See Also:
        ExternalContext.getRequestPathInfo()

      • getRequestServletPath

        public String getRequestServletPath()

        The default behavior of this method is to call ExternalContext.getRequestServletPath() on the wrapped ExternalContext object.

        Specified by:
        getRequestServletPath in class ExternalContext
        See Also:
        ExternalContext.getRequestServletPath()

      • getResource

        public URL getResource(String path)
                throws MalformedURLException

        The default behavior of this method is to call ExternalContext.getResource(String) on the wrapped ExternalContext object.

        Specified by:
        getResource in class ExternalContext
        Parameters:
        path - The path to the requested resource, which must start with a slash ("/" character
        Throws:
        MalformedURLException - if the specified path is not in the correct form
        See Also:
        ExternalContext.getResource(String)

      • getResourceAsStream

        public InputStream getResourceAsStream(String path)

        The default behavior of this method is to call ExternalContext.getResourceAsStream(String) on the wrapped ExternalContext object.

        Specified by:
        getResourceAsStream in class ExternalContext
        Parameters:
        path - The path to the requested resource, which must start with a slash ("/" character
        See Also:
        ExternalContext.getResourceAsStream(String)

      • getResourcePaths

        public Set<String> getResourcePaths(String path)

        The default behavior of this method is to call ExternalContext.getResourcePaths(String) on the wrapped ExternalContext object.

        Specified by:
        getResourcePaths in class ExternalContext
        Parameters:
        path - Partial path used to match resources, which must start with a slash ("/") character
        See Also:
        ExternalContext.getResourcePaths(String)

      • getResponse

        public Object getResponse()

        The default behavior of this method is to call ExternalContext.getResponse() on the wrapped ExternalContext object.

        Specified by:
        getResponse in class ExternalContext
        See Also:
        ExternalContext.getResponse()

      • getSession

        public Object getSession(boolean create)

        The default behavior of this method is to call ExternalContext.getSession(boolean) on the wrapped ExternalContext object.

        Specified by:
        getSession in class ExternalContext
        Parameters:
        create - Flag indicating whether or not a new session should be created if there is no session associated with the current request
        See Also:
        ExternalContext.getSession(boolean)

      • getSessionId

        public String getSessionId(boolean create)

        The default behavior of this method is to call ExternalContext.getSessionId(boolean) on the wrapped ExternalContext object.

        Overrides:
        getSessionId in class ExternalContext
        Parameters:
        create - Flag indicating whether or not a new session should be created if there is no session associated with the current request
        Since:
        2.2
        See Also:
        ExternalContext.getSessionId(boolean)

      • getSessionMap

        public Map<String,Object> getSessionMap()

        The default behavior of this method is to call ExternalContext.getSessionMap() on the wrapped ExternalContext object.

        Specified by:
        getSessionMap in class ExternalContext
        See Also:
        ExternalContext.getSessionMap()

      • getSessionMaxInactiveInterval

        public int getSessionMaxInactiveInterval()

        The default behavior of this method is to call ExternalContext.getSessionMaxInactiveInterval() on the wrapped ExternalContext object.

        Overrides:
        getSessionMaxInactiveInterval in class ExternalContext
        See Also:
        ExternalContext.getSessionMaxInactiveInterval()

      • setSessionMaxInactiveInterval

        public void setSessionMaxInactiveInterval(int interval)

        The default behavior of this method is to call ExternalContext.setSessionMaxInactiveInterval(int) on the wrapped ExternalContext object.

        Overrides:
        setSessionMaxInactiveInterval in class ExternalContext
        See Also:
        ExternalContext.setSessionMaxInactiveInterval(int)

      • setClientWindow

        public void setClientWindow(ClientWindow window)

        The default behavior of this method is to call ExternalContext.setClientWindow(javax.faces.lifecycle.ClientWindow) on the wrapped ExternalContext object.

        Overrides:
        setClientWindow in class ExternalContext
        Parameters:
        window - the window associated with this request.
        Since:
        2.2

      • getUserPrincipal

        public Principal getUserPrincipal()

        The default behavior of this method is to call ExternalContext.getUserPrincipal() on the wrapped ExternalContext object.

        Specified by:
        getUserPrincipal in class ExternalContext
        See Also:
        ExternalContext.getUserPrincipal()

      • getClientWindow

        public ClientWindow getClientWindow()

        The default behavior of this method is to call ExternalContext.getClientWindow() on the wrapped ExternalContext object.

        Overrides:
        getClientWindow in class ExternalContext
        Since:
        2.2
        See Also:
        ExternalContext.getClientWindow()

      • isUserInRole

        public boolean isUserInRole(String role)

        The default behavior of this method is to call ExternalContext.isUserInRole(String) on the wrapped ExternalContext object.

        Specified by:
        isUserInRole in class ExternalContext
        Parameters:
        role - Logical role name to be checked
        See Also:
        ExternalContext.isUserInRole(String)

      • log

        public void log(String message)

        The default behavior of this method is to call ExternalContext.log(String) on the wrapped ExternalContext object.

        Specified by:
        log in class ExternalContext
        Parameters:
        message - Message to be logged
        See Also:
        ExternalContext.log(String)

      • log

        public void log(String message,
       Throwable exception)

        The default behavior of this method is to call ExternalContext.log(String, Throwable) on the wrapped ExternalContext object.

        Specified by:
        log in class ExternalContext
        Parameters:
        message - Message to be logged
        exception - Exception to be logged
        See Also:
        ExternalContext.log(String, Throwable)

      • redirect

        public void redirect(String url)
              throws IOException

        The default behavior of this method is to call ExternalContext.redirect(String) on the wrapped ExternalContext object.

        Specified by:
        redirect in class ExternalContext
        Parameters:
        url - Absolute URL to which the client should be redirected
        Throws:
        IOException - if an input/output error occurs
        See Also:
        ExternalContext.redirect(String)

      • addResponseCookie

        public void addResponseCookie(String name,
                     String value,
                     Map<String,Object> properties)

        The default behavior of this method is to call ExternalContext.addResponseCookie(String, String, Map) on the wrapped ExternalContext object.

        Overrides:
        addResponseCookie in class ExternalContext
        Parameters:
        name - To be passed as the first argument to the Cookie constructor.
        value - To be passed as the second argument to the Cookie constructor.
        properties - A Map containg key/value pairs to be passed as arguments to the setter methods as described above.
        See Also:
        ExternalContext.addResponseCookie(String, String, Map)

      • getMimeType

        public String getMimeType(String file)

        The default behavior of this method is to call ExternalContext.getMimeType(String) on the wrapped ExternalContext object.

        Overrides:
        getMimeType in class ExternalContext
        Parameters:
        file - The file for which the mime type should be obtained.
        See Also:
        ExternalContext.getMimeType(String)

      • getContextName

        public String getContextName()

        The default behavior of this method is to call ExternalContext.getContextName() on the wrapped ExternalContext object.

        Overrides:
        getContextName in class ExternalContext
        See Also:
        ExternalContext.getContextName()

      • setRequest

        public void setRequest(Object request)

        The default behavior of this method is to call ExternalContext.setRequest(Object) on the wrapped ExternalContext object.

        Overrides:
        setRequest in class ExternalContext
        See Also:
        ExternalContext.setRequest(Object)

      • getRequestScheme

        public String getRequestScheme()

        The default behavior of this method is to call ExternalContext.getRequestScheme() on the wrapped ExternalContext object.

        Overrides:
        getRequestScheme in class ExternalContext
        See Also:
        ExternalContext.getRequestScheme()

      • getRequestServerName

        public String getRequestServerName()

        The default behavior of this method is to call ExternalContext.getRequestServerName() on the wrapped ExternalContext object.

        Overrides:
        getRequestServerName in class ExternalContext
        See Also:
        ExternalContext.getRequestServerName()

      • getRequestServerPort

        public int getRequestServerPort()

        The default behavior of this method is to call ExternalContext.getRequestServerPort() on the wrapped ExternalContext object.

        Overrides:
        getRequestServerPort in class ExternalContext
        See Also:
        ExternalContext.getRequestServerPort()

      • setRequestCharacterEncoding

        public void setRequestCharacterEncoding(String encoding)
                                 throws UnsupportedEncodingException

        The default behavior of this method is to call ExternalContext.setRequestCharacterEncoding(String) on the wrapped ExternalContext object.

        Overrides:
        setRequestCharacterEncoding in class ExternalContext
        Throws:
        UnsupportedEncodingException - if this is not a valid encoding
        See Also:
        ExternalContext.setRequestCharacterEncoding(String)

      • getRealPath

        public String getRealPath(String path)

        The default behavior of this method is to call ExternalContext.getRealPath(String) on the wrapped ExternalContext object.

        Overrides:
        getRealPath in class ExternalContext
        Parameters:
        path - The context of the requested initialization parameter
        See Also:
        ExternalContext.getRealPath(String)

      • getRequestCharacterEncoding

        public String getRequestCharacterEncoding()

        The default behavior of this method is to call ExternalContext.getRequestCharacterEncoding() on the wrapped ExternalContext object.

        Overrides:
        getRequestCharacterEncoding in class ExternalContext
        See Also:
        ExternalContext.getRequestCharacterEncoding()

      • getRequestContentType

        public String getRequestContentType()

        The default behavior of this method is to call ExternalContext.getRequestContentType() on the wrapped ExternalContext object.

        Overrides:
        getRequestContentType in class ExternalContext
        See Also:
        ExternalContext.getRequestContentType()

      • getRequestContentLength

        public int getRequestContentLength()

        The default behavior of this method is to call ExternalContext.getRequestContentLength() on the wrapped ExternalContext object.

        Overrides:
        getRequestContentLength in class ExternalContext
        See Also:
        ExternalContext.getRequestContentLength()

      • getResponseCharacterEncoding

        public String getResponseCharacterEncoding()

        The default behavior of this method is to call ExternalContext.getResponseCharacterEncoding() on the wrapped ExternalContext object.

        Overrides:
        getResponseCharacterEncoding in class ExternalContext
        See Also:
        ExternalContext.getResponseCharacterEncoding()

      • getResponseContentType

        public String getResponseContentType()

        The default behavior of this method is to call ExternalContext.getResponseContentType() on the wrapped ExternalContext object.

        Overrides:
        getResponseContentType in class ExternalContext
        See Also:
        ExternalContext.getResponseContentType()

      • setResponse

        public void setResponse(Object response)

        The default behavior of this method is to call ExternalContext.setResponse(Object) on the wrapped ExternalContext object.

        Overrides:
        setResponse in class ExternalContext
        See Also:
        ExternalContext.setResponse(Object)

      • getResponseOutputStream

        public OutputStream getResponseOutputStream()
                                     throws IOException

        The default behavior of this method is to call ExternalContext.getResponseOutputStream() on the wrapped ExternalContext object.

        Overrides:
        getResponseOutputStream in class ExternalContext
        Throws:
        IOException
        See Also:
        ExternalContext.getResponseOutputStream()

      • getResponseOutputWriter

        public Writer getResponseOutputWriter()
                               throws IOException

        The default behavior of this method is to call ExternalContext.getResponseOutputWriter() on the wrapped ExternalContext object.

        Overrides:
        getResponseOutputWriter in class ExternalContext
        Throws:
        IOException
        See Also:
        ExternalContext.getResponseOutputWriter()

      • setResponseCharacterEncoding

        public void setResponseCharacterEncoding(String encoding)

        The default behavior of this method is to call ExternalContext.getResponseCharacterEncoding() on the wrapped ExternalContext object.

        Overrides:
        setResponseCharacterEncoding in class ExternalContext
        See Also:
        ExternalContext.getResponseCharacterEncoding()

      • setResponseContentType

        public void setResponseContentType(String contentType)

        The default behavior of this method is to call ExternalContext.setResponseContentType(String) on the wrapped ExternalContext object.

        Overrides:
        setResponseContentType in class ExternalContext
        Parameters:
        contentType - The content type to be set as the contentType of the response.
        See Also:
        ExternalContext.setResponseContentType(String)

      • invalidateSession

        public void invalidateSession()

        The default behavior of this method is to call ExternalContext.invalidateSession() on the wrapped ExternalContext object.

        Overrides:
        invalidateSession in class ExternalContext
        See Also:
        ExternalContext.invalidateSession()

      • setResponseHeader

        public void setResponseHeader(String name,
                     String value)

        The default behavior of this method is to call ExternalContext.setResponseHeader(String,String) on the wrapped ExternalContext object.

        Overrides:
        setResponseHeader in class ExternalContext
        Parameters:
        name - The name of the response header.
        value - The value of the response header.
        See Also:
        ExternalContext.setResponseHeader(String,String)

      • addResponseHeader

        public void addResponseHeader(String name,
                     String value)

        The default behavior of this method is to call ExternalContext.addResponseHeader(String,String) on the wrapped ExternalContext object.

        Overrides:
        addResponseHeader in class ExternalContext
        Parameters:
        name - The name of the response header.
        value - The value of the response header.
        See Also:
        ExternalContext.addResponseHeader(String,String)

      • setResponseBufferSize

        public void setResponseBufferSize(int size)

        The default behavior of this method is to call ExternalContext.setResponseBufferSize(int) on the wrapped ExternalContext object.

        Overrides:
        setResponseBufferSize in class ExternalContext
        Parameters:
        size - the new buffer size
        See Also:
        ExternalContext.setResponseBufferSize(int)

      • getResponseBufferSize

        public int getResponseBufferSize()

        The default behavior of this method is to call ExternalContext.getResponseBufferSize() on the wrapped ExternalContext object.

        Overrides:
        getResponseBufferSize in class ExternalContext
        See Also:
        ExternalContext.getResponseBufferSize()

      • isResponseCommitted

        public boolean isResponseCommitted()

        The default behavior of this method is to call ExternalContext.isResponseCommitted() on the wrapped ExternalContext object.

        Overrides:
        isResponseCommitted in class ExternalContext
        See Also:
        ExternalContext.isResponseCommitted()

      • isSecure

        public boolean isSecure()

        The default behavior of this method is to call ExternalContext.isSecure() on the wrapped ExternalContext object.

        Overrides:
        isSecure in class ExternalContext

      • responseReset

        public void responseReset()

        The default behavior of this method is to call ExternalContext.responseReset() on the wrapped ExternalContext object.

        Overrides:
        responseReset in class ExternalContext
        See Also:
        ExternalContext.responseReset()

      • responseSendError

        public void responseSendError(int statusCode,
                     String message)
                       throws IOException

        The default behavior of this method is to call ExternalContext.responseSendError(int,String) on the wrapped ExternalContext object.

        Overrides:
        responseSendError in class ExternalContext
        Parameters:
        statusCode - an HTTP status code
        message - an option message to detail the cause of the code
        Throws:
        IOException
        See Also:
        ExternalContext.responseSendError(int,String)

      • setResponseStatus

        public void setResponseStatus(int statusCode)

        The default behavior of this method is to call ExternalContext.setResponseStatus(int) on the wrapped ExternalContext object.

        Overrides:
        setResponseStatus in class ExternalContext
        Parameters:
        statusCode - an HTTP status code
        See Also:
        ExternalContext.setResponseStatus(int)

      • responseFlushBuffer

        public void responseFlushBuffer()
                         throws IOException

        The default behavior of this method is to call ExternalContext.responseFlushBuffer() on the wrapped ExternalContext object.

        Overrides:
        responseFlushBuffer in class ExternalContext
        Throws:
        IOException
        See Also:
        ExternalContext.responseFlushBuffer()

      • setResponseContentLength

        public void setResponseContentLength(int length)

        The default behavior of this method is to call ExternalContext.setResponseContentLength(int) on the wrapped ExternalContext object.

        Overrides:
        setResponseContentLength in class ExternalContext
        See Also:
        ExternalContext.setResponseContentLength(int)

      • encodeBookmarkableURL

        public String encodeBookmarkableURL(String baseUrl,
                           Map<String,List<String>> parameters)

        The default behavior of this method is to call ExternalContext.encodeBookmarkableURL(String, java.util.Map) on the wrapped ExternalContext object.

        Overrides:
        encodeBookmarkableURL in class ExternalContext
        Parameters:
        baseUrl - The base URL onto which the query string generated by this method will be appended. The URL may contain query parameters.
        parameters - The collection of Parameter objects, representing name=value pairs that are used to produce a query string
        See Also:
        ExternalContext.encodeBookmarkableURL(String, java.util.Map)

      • encodeRedirectURL

        public String encodeRedirectURL(String baseUrl,
                       Map<String,List<String>> parameters)

        The default behavior of this method is to call ExternalContext.encodeRedirectURL(String, java.util.Map) on the wrapped ExternalContext object.

        Overrides:
        encodeRedirectURL in class ExternalContext
        Parameters:
        baseUrl - The base URL onto which the query string generated by this method will be appended. The URL may contain query parameters.
        parameters - The collection of Parameter objects, representing name=value pairs that are used to produce a query string
        See Also:
        ExternalContext.encodeRedirectURL(String, java.util.Map)

      • getFlash

        public Flash getFlash()

        The default behavior of this method is to call ExternalContext.getFlash() on the wrapped ExternalContext object.

        Overrides:
        getFlash in class ExternalContext
        See Also:
        ExternalContext.getFlash()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class FacesContext

  • java.lang.Object
    • javax.faces.context.FacesContext
  • Direct Known Subclasses:
    FacesContextWrapper

    public abstract class FacesContext
extends Object

    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response. It is passed to, and potentially modified by, each phase of the request processing lifecycle.

    A FacesContext instance is associated with a particular request at the beginning of request processing, by a call to the getFacesContext() method of the FacesContextFactory instance associated with the current web application. The instance remains active until its release() method is called, after which no further references to this instance are allowed. While a FacesContext instance is active, it must not be referenced from any thread other than the one upon which the servlet container executing this web application utilizes for the processing of this request.

    • Constructor Summary

      Constructors
      Constructor and Description
      FacesContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addMessage(String clientId, FacesMessage message)
      Append a FacesMessage to the set of messages associated with the specified client identifier, if clientId is not null.
      abstract Application getApplication()
      Return the Application instance associated with this web application.
      Map<Object,Object> getAttributes()

      Return a mutable Map representing the attributes associated wth this FacesContext instance.
      abstract Iterator<String> getClientIdsWithMessages()
      Return an Iterator over the client identifiers for which at least one FacesMessage has been queued.
      static FacesContext getCurrentInstance()

      Return the FacesContext instance for the request that is being processed by the current thread.
      PhaseId getCurrentPhaseId()

      Return the value last set on this FacesContext instance when setCurrentPhaseId(javax.faces.event.PhaseId) was called.
      ELContext getELContext()
      Return the ELContext instance for this FacesContext instance.
      ExceptionHandler getExceptionHandler()

      Return the ExceptionHandler for this request.
      abstract ExternalContext getExternalContext()
      Return the ExternalContext instance for this FacesContext instance.
      abstract FacesMessage.Severity getMaximumSeverity()
      Return the maximum severity level recorded on any FacesMessages that has been queued, whether or not they are associated with any specific UIComponent.
      List<FacesMessage> getMessageList()

      Like getMessages(), but returns a List<FacesMessage>, enabling use from EL expressions.
      List<FacesMessage> getMessageList(String clientId)

      Like getMessages(java.lang.String), but returns a List<FacesMessage> of messages for the component with client id matching argument clientId.
      abstract Iterator<FacesMessage> getMessages()
      Return an Iterator over the FacesMessages that have been queued, whether or not they are associated with any specific client identifier.
      abstract Iterator<FacesMessage> getMessages(String clientId)
      Return an Iterator over the FacesMessages that have been queued that are associated with the specified client identifier (if clientId is not null), or over the FacesMessages that have been queued that are not associated with any specific client identifier (if clientId is null).
      char getNamingContainerSeparatorChar()

      Return the result of calling UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext), passing this as the argument.
      PartialViewContext getPartialViewContext()

      Return the PartialViewContext for this request.
      abstract RenderKit getRenderKit()
      Return the RenderKit instance for the render kit identifier specified on our UIViewRoot, if there is one.
      abstract boolean getRenderResponse()
      Return true if the renderResponse() method has been called for the current request.
      List<String> getResourceLibraryContracts()

      Return the list of resource library contracts that have been calculated to be appropriate for use with this view, or an empty list if there are no such resource library contracts.
      abstract boolean getResponseComplete()
      Return true if the responseComplete() method has been called for the current request.
      abstract ResponseStream getResponseStream()
      Return the ResponseStream to which components should direct their binary output.
      abstract ResponseWriter getResponseWriter()
      Return the ResponseWriter to which components should direct their character-based output.
      abstract UIViewRoot getViewRoot()
      Return the root component that is associated with the this request.
      boolean isPostback()

      This utility method simply returns the result of ResponseStateManager.isPostback(FacesContext).
      boolean isProcessingEvents()

      Returns a flag indicating whether or not the runtime should publish events when asked to do so.
      boolean isProjectStage(ProjectStage stage)

      Return true if the current ProjectStage as returned by the Application instance is equal to stage, otherwise return false
      boolean isReleased()

      Return a flag indicating if the resources associated with this FacesContext instance have been released.
      boolean isValidationFailed()

      Return true if the validationFailed() method has been called for the current request.
      abstract void release()
      Release any resources associated with this FacesContext instance.
      abstract void renderResponse()
      Signal the JavaServer faces implementation that, as soon as the current phase of the request processing lifecycle has been completed, control should be passed to the Render Response phase, bypassing any phases that have not been executed yet.
      abstract void responseComplete()
      Signal the JavaServer Faces implementation that the HTTP response for this request has already been generated (such as an HTTP redirect), and that the request processing lifecycle should be terminated as soon as the current phase is completed.
      protected static void setCurrentInstance(FacesContext context)
      Set the FacesContext instance for the request that is being processed by the current thread.
      void setCurrentPhaseId(PhaseId currentPhaseId)

      The implementation must call this method at the earliest possble point in time after entering into a new phase in the request processing lifecycle.
      void setExceptionHandler(ExceptionHandler exceptionHandler)

      Set the ExceptionHandler for this request.
      void setProcessingEvents(boolean processingEvents)

      Allows control of wheter or not the runtime will publish events when Application.publishEvent(FacesContext, Class, Object) or Application.publishEvent(FacesContext, Class, Class, Object) is called.
      void setResourceLibraryContracts(List<String> contracts)

      Set the resource library contracts calculated as valid to use with this view.
      abstract void setResponseStream(ResponseStream responseStream)
      Set the ResponseStream to which components should direct their binary output.
      abstract void setResponseWriter(ResponseWriter responseWriter)
      Set the ResponseWriter to which components should direct their character-based output.
      abstract void setViewRoot(UIViewRoot root)
      Set the root component that is associated with this request.
      void validationFailed()

      Sets a flag which indicates that a conversion or validation error occurred while processing the inputs.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FacesContext

        public FacesContext()

    • Method Detail

      • getApplication

        public abstract Application getApplication()

        Return the Application instance associated with this web application.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, returns the correct current Application instance.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getAttributes

        public Map<Object,Object> getAttributes()

        Return a mutable Map representing the attributes associated wth this FacesContext instance. This Map is useful to store attributes that you want to go out of scope when the Faces lifecycle for the current request ends, which is not always the same as the request ending, especially in the case of Servlet filters that are invoked after the Faces lifecycle for this request completes. Accessing this Map does not cause any events to fire, as is the case with the other maps: for request, session, and application scope. When release() is invoked, the attributes must be cleared.

        The Map returned by this method is not associated with the request. If you would like to get or set request attributes, see ExternalContext.getRequestMap().

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • getPartialViewContext

        public PartialViewContext getPartialViewContext()

        Return the PartialViewContext for this request. The PartialViewContext is used to control the processing of specified components during the execute portion of the request processing lifecycle (known as partial processing) and the rendering of specified components (known as partial rendering). This method must return a new PartialViewContext if one does not already exist.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • getClientIdsWithMessages

        public abstract Iterator<String> getClientIdsWithMessages()

        Return an Iterator over the client identifiers for which at least one FacesMessage has been queued. If there are no such client identifiers, an empty Iterator is returned. If any messages have been queued that were not associated with any specific client identifier, a null value will be included in the iterated values. The elements in the Iterator must be returned in the order in which they were added with addMessage(java.lang.String, javax.faces.application.FacesMessage).

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getELContext

        public ELContext getELContext()

        Return the ELContext instance for this FacesContext instance. This ELContext instance has the same lifetime and scope as the FacesContext instance with which it is associated, and may be created lazily the first time this method is called for a given FacesContext instance. Upon creation of the ELContext instance, the implementation must take the following action:

        • Call the ELContext.putContext(java.lang.Class, java.lang.Object) method on the instance, passing in FacesContext.class and the this reference for the FacesContext instance itself.

        • If the Collection returned by Application.getELContextListeners() is non-empty, create an instance of ELContextEvent and pass it to each ELContextListener instance in the Collection by calling the ELContextListener.contextCreated(javax.el.ELContextEvent) method.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        1.2

      • getExceptionHandler

        public ExceptionHandler getExceptionHandler()

        Return the ExceptionHandler for this request.

      • setExceptionHandler

        public void setExceptionHandler(ExceptionHandler exceptionHandler)

        Set the ExceptionHandler for this request.

        Parameters:
        exceptionHandler - the ExceptionHandler for this request.

      • getExternalContext

        public abstract ExternalContext getExternalContext()

        Return the ExternalContext instance for this FacesContext instance.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this method returns an ExternalContext instance with the special behaviors indicated in the javadoc for that class. Methods document as being valid to call during application startup or shutdown must be supported.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getMaximumSeverity

        public abstract FacesMessage.Severity getMaximumSeverity()

        Return the maximum severity level recorded on any FacesMessages that has been queued, whether or not they are associated with any specific UIComponent. If no such messages have been queued, return null.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getMessages

        public abstract Iterator<FacesMessage> getMessages()

        Return an Iterator over the FacesMessages that have been queued, whether or not they are associated with any specific client identifier. If no such messages have been queued, return an empty Iterator. The elements of the Iterator must be returned in the order in which they were added with calls to addMessage(java.lang.String, javax.faces.application.FacesMessage).

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getMessageList

        public List<FacesMessage> getMessageList()

        Like getMessages(), but returns a List<FacesMessage>, enabling use from EL expressions.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Returns:
        an immutable List which is effectively a snapshot of the messages present at the time of invocation.
        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • getMessageList

        public List<FacesMessage> getMessageList(String clientId)

        Like getMessages(java.lang.String), but returns a List<FacesMessage> of messages for the component with client id matching argument clientId.

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Returns:
        an immutable List which is effectively a snapshot of the messages present at the time of invocation.
        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • getMessages

        public abstract Iterator<FacesMessage> getMessages(String clientId)

        Return an Iterator over the FacesMessages that have been queued that are associated with the specified client identifier (if clientId is not null), or over the FacesMessages that have been queued that are not associated with any specific client identifier (if clientId is null). If no such messages have been queued, return an empty Iterator. The elements of the Iterator must be returned in the order in which they were added with calls to addMessage(java.lang.String, javax.faces.application.FacesMessage).

        Parameters:
        clientId - The client identifier for which messages are requested, or null for messages not associated with any client identifier
        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getNamingContainerSeparatorChar

        public char getNamingContainerSeparatorChar()

        Return the result of calling UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext), passing this as the argument. Note that this enables accessing the value of this property from the EL expression #{facesContext.namingContainerSeparatorChar}.

      • getRenderKit

        public abstract RenderKit getRenderKit()

        Return the RenderKit instance for the render kit identifier specified on our UIViewRoot, if there is one. If there is no current UIViewRoot, if the UIViewRoot does not have a specified renderKitId, or if there is no RenderKit for the specified identifier, return null instead.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getRenderResponse

        public abstract boolean getRenderResponse()

        Return true if the renderResponse() method has been called for the current request.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getResponseComplete

        public abstract boolean getResponseComplete()

        Return true if the responseComplete() method has been called for the current request.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getResourceLibraryContracts

        public List<String> getResourceLibraryContracts()

        Return the list of resource library contracts that have been calculated to be appropriate for use with this view, or an empty list if there are no such resource library contracts. The list returned by this method must be immutable. For backward compatibility with implementations of the specification prior to when this method was introduced, an implementation is provided that returns an empty list. Implementations compliant with the version in which this method was introduced must implement this method as specified.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.2

      • setResourceLibraryContracts

        public void setResourceLibraryContracts(List<String> contracts)

        Set the resource library contracts calculated as valid to use with this view. The implementation must copy the contents of the incoming List into an immutable List for return from getResourceLibraryContracts(). If the argument is null or empty, the action taken is the same as if the argument is null: a subsequent call to getResourceLibraryContracts returns null. This method may only be called during the processing of ViewDeclarationLanguage.createView(javax.faces.context.FacesContext, java.lang.String) and during the VDL tag handler for the tag corresponding to an instance of UIViewRoot. For backward compatibility with implementations of the specification prior to when this method was introduced, an implementation is provided that takes no action. Implementations compliant with the version in which this method was introduced must implement this method as specified.

        Parameters:
        contracts - The new contracts to be returned, as an immutable List. from a subsequent call to getResourceLibraryContracts().
        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • isValidationFailed

        public boolean isValidationFailed()

        Return true if the validationFailed() method has been called for the current request.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getResponseStream

        public abstract ResponseStream getResponseStream()

        Return the ResponseStream to which components should direct their binary output. Within a given response, components can use either the ResponseStream or the ResponseWriter, but not both.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • setResponseStream

        public abstract void setResponseStream(ResponseStream responseStream)

        Set the ResponseStream to which components should direct their binary output.

        Parameters:
        responseStream - The new ResponseStream for this response
        Throws:
        NullPointerException - if responseStream is null
        IllegalStateException - if this method is called after this instance has been released

      • getResponseWriter

        public abstract ResponseWriter getResponseWriter()

        Return the ResponseWriter to which components should direct their character-based output. Within a given response, components can use either the ResponseStream or the ResponseWriter, but not both.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • setResponseWriter

        public abstract void setResponseWriter(ResponseWriter responseWriter)

        Set the ResponseWriter to which components should direct their character-based output.

        Parameters:
        responseWriter - The new ResponseWriter for this response
        Throws:
        IllegalStateException - if this method is called after this instance has been released
        NullPointerException - if responseWriter is null

      • getViewRoot

        public abstract UIViewRoot getViewRoot()

        Return the root component that is associated with the this request.

        It is valid to call this method during application startup or shutdown. If called during application startup or shutdown, this method returns a new UIViewRoot with its locale set to Locale.getDefault().

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • setViewRoot

        public abstract void setViewRoot(UIViewRoot root)

        Set the root component that is associated with this request.

        This method can be called by the application handler (or a class that the handler calls), during the Invoke Application phase of the request processing lifecycle and during the Restore View phase of the request processing lifecycle (especially when a new root component is created). In the present version of the specification, implementations are not required to enforce this restriction, though a future version of the specification may require enforcement.

        If the current UIViewRoot is non-null, and calling equals() on the argument root, passing the current UIViewRoot returns false, the clear method must be called on the Map returned from UIViewRoot.getViewMap().

        Parameters:
        root - The new component UIViewRoot component
        Throws:
        IllegalStateException - if this method is called after this instance has been released
        NullPointerException - if root is null

      • addMessage

        public abstract void addMessage(String clientId,
              FacesMessage message)

        Append a FacesMessage to the set of messages associated with the specified client identifier, if clientId is not null. If clientId is null, this FacesMessage is assumed to not be associated with any specific component instance.

        Parameters:
        clientId - The client identifier with which this message is associated (if any)
        message - The message to be appended
        Throws:
        IllegalStateException - if this method is called after this instance has been released
        NullPointerException - if message is null

      • isReleased

        public boolean isReleased()

        Return a flag indicating if the resources associated with this FacesContext instance have been released.

        Returns:
        true if the resources have been released.
        Since:
        2.1

      • release

        public abstract void release()

        Release any resources associated with this FacesContext instance. Faces implementations may choose to pool instances in the associated FacesContextFactory to avoid repeated object creation and garbage collection. After release() is called on a FacesContext instance (until the FacesContext instance has been recycled by the implementation for re-use), calling any other methods will cause an IllegalStateException to be thrown.

        If a call was made to getAttributes() during the processing for this request, the implementation must call clear() on the Map returned from getAttributes(), and then de-allocate the data-structure behind that Map.

        The implementation must call setCurrentInstance(javax.faces.context.FacesContext) passing null to remove the association between this thread and this dead FacesContext instance.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • renderResponse

        public abstract void renderResponse()

        Signal the JavaServer faces implementation that, as soon as the current phase of the request processing lifecycle has been completed, control should be passed to the Render Response phase, bypassing any phases that have not been executed yet.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • isPostback

        public boolean isPostback()

        This utility method simply returns the result of ResponseStateManager.isPostback(FacesContext).

        The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • responseComplete

        public abstract void responseComplete()

        Signal the JavaServer Faces implementation that the HTTP response for this request has already been generated (such as an HTTP redirect), and that the request processing lifecycle should be terminated as soon as the current phase is completed.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • validationFailed

        public void validationFailed()

        Sets a flag which indicates that a conversion or validation error occurred while processing the inputs. Inputs consist of either page parameters or form bindings. This flag can be read using isValidationFailed().

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • getCurrentPhaseId

        public PhaseId getCurrentPhaseId()

        Return the value last set on this FacesContext instance when setCurrentPhaseId(javax.faces.event.PhaseId) was called.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • setCurrentPhaseId

        public void setCurrentPhaseId(PhaseId currentPhaseId)

        The implementation must call this method at the earliest possble point in time after entering into a new phase in the request processing lifecycle.

        Parameters:
        currentPhaseId - The PhaseId for the current phase.
        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • setProcessingEvents

        public void setProcessingEvents(boolean processingEvents)

        Allows control of wheter or not the runtime will publish events when Application.publishEvent(FacesContext, Class, Object) or Application.publishEvent(FacesContext, Class, Class, Object) is called.

        Parameters:
        processingEvents - flag indicating events should be processed or not

      • isProcessingEvents

        public boolean isProcessingEvents()

        Returns a flag indicating whether or not the runtime should publish events when asked to do so.

        Returns:
        true if events should be published, otherwise false

      • isProjectStage

        public boolean isProjectStage(ProjectStage stage)

        Return true if the current ProjectStage as returned by the Application instance is equal to stage, otherwise return false

        Parameters:
        stage - the ProjectStage to check
        Throws:
        IllegalStateException - if this method is called after this instance has been released
        NullPointerException - if stage is null

      • getCurrentInstance

        public static FacesContext getCurrentInstance()

        Return the FacesContext instance for the request that is being processed by the current thread. If called during application initialization or shutdown, any method documented as "valid to call this method during application startup or shutdown" must be supported during application startup or shutdown time. The result of calling a method during application startup or shutdown time that does not have this designation is undefined.

      • setCurrentInstance

        protected static void setCurrentInstance(FacesContext context)

        Set the FacesContext instance for the request that is being processed by the current thread.

        Parameters:
        context - The FacesContext instance for the current thread, or null if this thread no longer has a FacesContext instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesContextFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class FacesContextFactory

  • java.lang.Object
    • javax.faces.context.FacesContextFactory
  • All Implemented Interfaces:
    FacesWrapper<FacesContextFactory>

    public abstract class FacesContextFactory
extends Object
implements FacesWrapper<FacesContextFactory>

    FacesContextFactory is a factory object that creates (if needed) and returns new FacesContext instances, initialized for the processing of the specified request and response objects. Implementations may take advantage of the calls to the release() method of the allocated FacesContext instances to pool and recycle them, rather than creating a new instance every time.

    There must be one FacesContextFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

       FacesContextFactory factory = (FacesContextFactory)
    FactoryFinder.getFactory(FactoryFinder.FACES_CONTEXT_FACTORY);

    • Constructor Summary

      Constructors
      Constructor and Description
      FacesContextFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract FacesContext getFacesContext(Object context, Object request, Object response, Lifecycle lifecycle)
      Create (if needed) and return a FacesContext instance that is initialized for the processing of the specified request and response objects, utilizing the specified Lifecycle instance, for this web application.
      FacesContextFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FacesContextFactory

        public FacesContextFactory()

    • Method Detail

      • getWrapped

        public FacesContextFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<FacesContextFactory>
        Since:
        2.0

      • getFacesContext

        public abstract FacesContext getFacesContext(Object context,
                           Object request,
                           Object response,
                           Lifecycle lifecycle)
                                      throws FacesException

        Create (if needed) and return a FacesContext instance that is initialized for the processing of the specified request and response objects, utilizing the specified Lifecycle instance, for this web application.

        The implementation of this method must ensure that calls to the getCurrentInstance() method of FacesContext, from the same thread that called this method, will return the same FacesContext instance until the release() method is called on that instance.

        The implementation must call ExternalContextFactory.getExternalContext(java.lang.Object, java.lang.Object, java.lang.Object) to produce the ExternalContext for the FacesContext instance.

        The default implementation must call ExceptionHandlerFactory.getExceptionHandler() and make it so the return from that method is what gets returned from a call to FacesContext.getExceptionHandler() on the returned FacesContext instance.

        The default implementation must call ClientWindowFactory.getClientWindow(javax.faces.context.FacesContext) and make it so the return from that method is what gets returned from a call to ExternalContext.getClientWindow() on the returned ExternalContext instance.

        Parameters:
        context - In servlet environments, the ServletContext that is associated with this web application
        request - In servlet environments, the ServletRequest that is to be processed
        response - In servlet environments, the ServletResponse that is to be processed
        lifecycle - The Lifecycle instance being used to process this request
        Throws:
        FacesException - if a FacesContext cannot be constructed for the specified parameters
        NullPointerException - if any of the parameters are null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesContextWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class FacesContextWrapper

  • java.lang.Object
    • javax.faces.context.FacesContext
      • javax.faces.context.FacesContextWrapper
  • All Implemented Interfaces:
    FacesWrapper<FacesContext>

    public abstract class FacesContextWrapper
extends FacesContext
implements FacesWrapper<FacesContext>

    Provides a simple implementation of FacesContext that can be subclassed by developers wishing to provide specialized behavior to an existing FacesContext instance. The default implementation of all methods is to call through to the wrapped FacesContext instance.

    Usage: extend this class and override getWrapped() to return the instance being wrapping.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      FacesContextWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addMessage(String clientId, FacesMessage message)
      The default behavior of this method is to call FacesContext.addMessage(String, FacesMessage) on the wrapped FacesContext object.
      Application getApplication()
      The default behavior of this method is to call FacesContext.getApplication() on the wrapped FacesContext object.
      Map<Object,Object> getAttributes()
      The default behavior of this method is to call FacesContext.getAttributes() on the wrapped FacesContext object.
      Iterator<String> getClientIdsWithMessages()
      The default behavior of this method is to call FacesContext.getClientIdsWithMessages() on the wrapped FacesContext object.
      PhaseId getCurrentPhaseId()
      The default behavior of this method is to call FacesContext.getCurrentPhaseId() on the wrapped FacesContext object.
      ELContext getELContext()
      The default behavior of this method is to call FacesContext.getELContext() on the wrapped FacesContext object.
      ExceptionHandler getExceptionHandler()
      The default behavior of this method is to call FacesContext.getExceptionHandler() on the wrapped FacesContext object.
      ExternalContext getExternalContext()
      The default behavior of this method is to call FacesContext.getExternalContext() on the wrapped FacesContext object.
      FacesMessage.Severity getMaximumSeverity()
      The default behavior of this method is to call FacesContext.getMaximumSeverity() on the wrapped FacesContext object.
      List<FacesMessage> getMessageList()
      The default behavior of this method is to call FacesContext.getMessageList() on the wrapped FacesContext object.
      List<FacesMessage> getMessageList(String clientId)
      The default behavior of this method is to call FacesContext.getMessageList(String) on the wrapped FacesContext object.
      Iterator<FacesMessage> getMessages()
      The default behavior of this method is to call FacesContext.getMessages() on the wrapped FacesContext object.
      Iterator<FacesMessage> getMessages(String clientId)
      The default behavior of this method is to call FacesContext.getMessages(String) on the wrapped FacesContext object.
      char getNamingContainerSeparatorChar()

      The default behavior of this method is to call FacesContext.getNamingContainerSeparatorChar() on the wrapped FacesContext object.
      PartialViewContext getPartialViewContext()
      The default behavior of this method is to call FacesContext.getPartialViewContext() ()} on the wrapped FacesContext object.
      RenderKit getRenderKit()
      The default behavior of this method is to call FacesContext.getRenderKit() on the wrapped FacesContext object.
      boolean getRenderResponse()
      The default behavior of this method is to call FacesContext.getRenderResponse() on the wrapped FacesContext object.
      List<String> getResourceLibraryContracts()
      The default behavior of this method is to call FacesContext.getResourceLibraryContracts() on the wrapped FacesContext object.
      boolean getResponseComplete()
      The default behavior of this method is to call FacesContext.getResponseComplete() on the wrapped FacesContext object.
      ResponseStream getResponseStream()
      The default behavior of this method is to call FacesContext.getResponseStream() on the wrapped FacesContext object.
      ResponseWriter getResponseWriter()
      The default behavior of this method is to call FacesContext.getResponseWriter() on the wrapped FacesContext object.
      UIViewRoot getViewRoot()
      The default behavior of this method is to call FacesContext.getViewRoot() on the wrapped FacesContext object.
      abstract FacesContext getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      boolean isPostback()
      The default behavior of this method is to call FacesContext.isPostback() on the wrapped FacesContext object.
      boolean isProcessingEvents()
      The default behavior of this method is to call FacesContext.isProcessingEvents() on the wrapped FacesContext object.
      boolean isProjectStage(ProjectStage stage)
      The default behavior of this method is to call FacesContext.isProjectStage(javax.faces.application.ProjectStage) on the wrapped FacesContext object.
      boolean isReleased()

      The default behavior of this method is to call FacesContext.isReleased() on the wrapped FacesContext object.
      boolean isValidationFailed()
      The default behavior of this method is to call FacesContext.isValidationFailed() on the wrapped FacesContext object.
      void release()
      The default behavior of this method is to call FacesContext.release() on the wrapped FacesContext object.
      void renderResponse()
      The default behavior of this method is to call FacesContext.renderResponse() on the wrapped FacesContext object.
      void responseComplete()
      The default behavior of this method is to call FacesContext.responseComplete() on the wrapped FacesContext object.
      void setCurrentPhaseId(PhaseId currentPhaseId)
      The default behavior of this method is to call FacesContext.setCurrentPhaseId(PhaseId) on the wrapped FacesContext object.
      void setExceptionHandler(ExceptionHandler exceptionHandler)
      The default behavior of this method is to call FacesContext.setExceptionHandler(ExceptionHandler) on the wrapped FacesContext object.
      void setProcessingEvents(boolean processingEvents)
      The default behavior of this method is to call FacesContext.setProcessingEvents(boolean) on the wrapped FacesContext object.
      void setResourceLibraryContracts(List<String> contracts)
      The default behavior of this method is to call FacesContext.setResourceLibraryContracts(java.util.List<java.lang.String>) on the wrapped FacesContext object.
      void setResponseStream(ResponseStream responseStream)
      The default behavior of this method is to call FacesContext.setResponseStream(ResponseStream) on the wrapped FacesContext object.
      void setResponseWriter(ResponseWriter responseWriter)
      The default behavior of this method is to call FacesContext.setResponseWriter(ResponseWriter) on the wrapped FacesContext object.
      void setViewRoot(UIViewRoot root)
      The default behavior of this method is to call FacesContext.setViewRoot(UIViewRoot) on the wrapped FacesContext object.
      void validationFailed()
      The default behavior of this method is to call FacesContext.validationFailed() on the wrapped FacesContext object.

      • Methods inherited from class javax.faces.context.FacesContext

        getCurrentInstance, setCurrentInstance

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FacesContextWrapper

        public FacesContextWrapper()

    • Method Detail

      • getWrapped

        public abstract FacesContext getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<FacesContext>
        Returns:
        the wrapped FacesContext instance
        See Also:
        FacesWrapper.getWrapped()

      • getApplication

        public Application getApplication()

        The default behavior of this method is to call FacesContext.getApplication() on the wrapped FacesContext object.

        Specified by:
        getApplication in class FacesContext
        See Also:
        FacesContext.getApplication()

      • getClientIdsWithMessages

        public Iterator<String> getClientIdsWithMessages()

        The default behavior of this method is to call FacesContext.getClientIdsWithMessages() on the wrapped FacesContext object.

        Specified by:
        getClientIdsWithMessages in class FacesContext
        See Also:
        FacesContext.getClientIdsWithMessages()

      • getExternalContext

        public ExternalContext getExternalContext()

        The default behavior of this method is to call FacesContext.getExternalContext() on the wrapped FacesContext object.

        Specified by:
        getExternalContext in class FacesContext
        See Also:
        FacesContext.getExternalContext()

      • getMaximumSeverity

        public FacesMessage.Severity getMaximumSeverity()

        The default behavior of this method is to call FacesContext.getMaximumSeverity() on the wrapped FacesContext object.

        Specified by:
        getMaximumSeverity in class FacesContext
        See Also:
        FacesContext.getMaximumSeverity()

      • getMessages

        public Iterator<FacesMessage> getMessages()

        The default behavior of this method is to call FacesContext.getMessages() on the wrapped FacesContext object.

        Specified by:
        getMessages in class FacesContext
        See Also:
        FacesContext.getMessages()

      • getMessages

        public Iterator<FacesMessage> getMessages(String clientId)

        The default behavior of this method is to call FacesContext.getMessages(String) on the wrapped FacesContext object.

        Specified by:
        getMessages in class FacesContext
        Parameters:
        clientId - The client identifier for which messages are requested, or null for messages not associated with any client identifier
        See Also:
        FacesContext.getMessages(String)

      • getRenderKit

        public RenderKit getRenderKit()

        The default behavior of this method is to call FacesContext.getRenderKit() on the wrapped FacesContext object.

        Specified by:
        getRenderKit in class FacesContext
        See Also:
        FacesContext.getRenderKit()

      • getRenderResponse

        public boolean getRenderResponse()

        The default behavior of this method is to call FacesContext.getRenderResponse() on the wrapped FacesContext object.

        Specified by:
        getRenderResponse in class FacesContext
        See Also:
        FacesContext.getRenderResponse()

      • getResourceLibraryContracts

        public List<String> getResourceLibraryContracts()

        The default behavior of this method is to call FacesContext.getResourceLibraryContracts() on the wrapped FacesContext object.

        Overrides:
        getResourceLibraryContracts in class FacesContext
        See Also:
        FacesContext.getResourceLibraryContracts()

      • setResourceLibraryContracts

        public void setResourceLibraryContracts(List<String> contracts)

        The default behavior of this method is to call FacesContext.setResourceLibraryContracts(java.util.List<java.lang.String>) on the wrapped FacesContext object.

        Overrides:
        setResourceLibraryContracts in class FacesContext
        Parameters:
        contracts - The new contracts to be returned, as an immutable List. from a subsequent call to FacesContext.getResourceLibraryContracts().
        See Also:
        FacesContext.setResourceLibraryContracts(java.util.List<java.lang.String>)

      • getResponseComplete

        public boolean getResponseComplete()

        The default behavior of this method is to call FacesContext.getResponseComplete() on the wrapped FacesContext object.

        Specified by:
        getResponseComplete in class FacesContext
        See Also:
        FacesContext.getResponseComplete()

      • getResponseStream

        public ResponseStream getResponseStream()

        The default behavior of this method is to call FacesContext.getResponseStream() on the wrapped FacesContext object.

        Specified by:
        getResponseStream in class FacesContext
        See Also:
        FacesContext.getResponseStream()

      • setResponseStream

        public void setResponseStream(ResponseStream responseStream)

        The default behavior of this method is to call FacesContext.setResponseStream(ResponseStream) on the wrapped FacesContext object.

        Specified by:
        setResponseStream in class FacesContext
        Parameters:
        responseStream - The new ResponseStream for this response
        See Also:
        FacesContext.setResponseStream(ResponseStream)

      • getResponseWriter

        public ResponseWriter getResponseWriter()

        The default behavior of this method is to call FacesContext.getResponseWriter() on the wrapped FacesContext object.

        Specified by:
        getResponseWriter in class FacesContext
        See Also:
        FacesContext.getResponseWriter()

      • setResponseWriter

        public void setResponseWriter(ResponseWriter responseWriter)

        The default behavior of this method is to call FacesContext.setResponseWriter(ResponseWriter) on the wrapped FacesContext object.

        Specified by:
        setResponseWriter in class FacesContext
        Parameters:
        responseWriter - The new ResponseWriter for this response
        See Also:
        FacesContext.setResponseWriter(ResponseWriter)

      • getViewRoot

        public UIViewRoot getViewRoot()

        The default behavior of this method is to call FacesContext.getViewRoot() on the wrapped FacesContext object.

        Specified by:
        getViewRoot in class FacesContext
        See Also:
        FacesContext.getViewRoot()

      • setViewRoot

        public void setViewRoot(UIViewRoot root)

        The default behavior of this method is to call FacesContext.setViewRoot(UIViewRoot) on the wrapped FacesContext object.

        Specified by:
        setViewRoot in class FacesContext
        Parameters:
        root - The new component UIViewRoot component
        See Also:
        FacesContext.setViewRoot(UIViewRoot)

      • addMessage

        public void addMessage(String clientId,
              FacesMessage message)

        The default behavior of this method is to call FacesContext.addMessage(String, FacesMessage) on the wrapped FacesContext object.

        Specified by:
        addMessage in class FacesContext
        Parameters:
        clientId - The client identifier with which this message is associated (if any)
        message - The message to be appended
        See Also:
        FacesContext.addMessage(String, FacesMessage)

      • isReleased

        public boolean isReleased()

        The default behavior of this method is to call FacesContext.isReleased() on the wrapped FacesContext object.

        Overrides:
        isReleased in class FacesContext
        Returns:
        true if the resources have been released.
        Since:
        2.1
        See Also:
        FacesContext.isReleased()

      • release

        public void release()

        The default behavior of this method is to call FacesContext.release() on the wrapped FacesContext object.

        Specified by:
        release in class FacesContext
        See Also:
        FacesContext.release()

      • renderResponse

        public void renderResponse()

        The default behavior of this method is to call FacesContext.renderResponse() on the wrapped FacesContext object.

        Specified by:
        renderResponse in class FacesContext
        See Also:
        FacesContext.renderResponse()

      • responseComplete

        public void responseComplete()

        The default behavior of this method is to call FacesContext.responseComplete() on the wrapped FacesContext object.

        Specified by:
        responseComplete in class FacesContext
        See Also:
        FacesContext.responseComplete()

      • getAttributes

        public Map<Object,Object> getAttributes()

        The default behavior of this method is to call FacesContext.getAttributes() on the wrapped FacesContext object.

        Overrides:
        getAttributes in class FacesContext
        See Also:
        FacesContext.getAttributes()

      • getNamingContainerSeparatorChar

        public char getNamingContainerSeparatorChar()

        The default behavior of this method is to call FacesContext.getNamingContainerSeparatorChar() on the wrapped FacesContext object.

        Overrides:
        getNamingContainerSeparatorChar in class FacesContext
        See Also:
        FacesContext.getNamingContainerSeparatorChar()

      • getPartialViewContext

        public PartialViewContext getPartialViewContext()

        The default behavior of this method is to call FacesContext.getPartialViewContext() ()} on the wrapped FacesContext object.

        Overrides:
        getPartialViewContext in class FacesContext
        See Also:
        FacesContext.getPartialViewContext()

      • getELContext

        public ELContext getELContext()

        The default behavior of this method is to call FacesContext.getELContext() on the wrapped FacesContext object.

        Overrides:
        getELContext in class FacesContext
        See Also:
        FacesContext.getELContext()

      • getExceptionHandler

        public ExceptionHandler getExceptionHandler()

        The default behavior of this method is to call FacesContext.getExceptionHandler() on the wrapped FacesContext object.

        Overrides:
        getExceptionHandler in class FacesContext
        See Also:
        FacesContext.getExceptionHandler()

      • setExceptionHandler

        public void setExceptionHandler(ExceptionHandler exceptionHandler)

        The default behavior of this method is to call FacesContext.setExceptionHandler(ExceptionHandler) on the wrapped FacesContext object.

        Overrides:
        setExceptionHandler in class FacesContext
        Parameters:
        exceptionHandler - the ExceptionHandler for this request.
        See Also:
        FacesContext.setExceptionHandler(ExceptionHandler)

      • getMessageList

        public List<FacesMessage> getMessageList()

        The default behavior of this method is to call FacesContext.getMessageList() on the wrapped FacesContext object.

        Overrides:
        getMessageList in class FacesContext
        Returns:
        an immutable List which is effectively a snapshot of the messages present at the time of invocation.
        See Also:
        FacesContext.getMessageList()

      • getMessageList

        public List<FacesMessage> getMessageList(String clientId)

        The default behavior of this method is to call FacesContext.getMessageList(String) on the wrapped FacesContext object.

        Overrides:
        getMessageList in class FacesContext
        Returns:
        an immutable List which is effectively a snapshot of the messages present at the time of invocation.
        See Also:
        FacesContext.getMessageList(String)

      • isPostback

        public boolean isPostback()

        The default behavior of this method is to call FacesContext.isPostback() on the wrapped FacesContext object.

        Overrides:
        isPostback in class FacesContext
        See Also:
        FacesContext.isPostback()

      • getCurrentPhaseId

        public PhaseId getCurrentPhaseId()

        The default behavior of this method is to call FacesContext.getCurrentPhaseId() on the wrapped FacesContext object.

        Overrides:
        getCurrentPhaseId in class FacesContext
        See Also:
        FacesContext.getCurrentPhaseId()

      • setCurrentPhaseId

        public void setCurrentPhaseId(PhaseId currentPhaseId)

        The default behavior of this method is to call FacesContext.setCurrentPhaseId(PhaseId) on the wrapped FacesContext object.

        Overrides:
        setCurrentPhaseId in class FacesContext
        Parameters:
        currentPhaseId - The PhaseId for the current phase.
        See Also:
        FacesContext.setCurrentPhaseId(PhaseId)

      • isValidationFailed

        public boolean isValidationFailed()

        The default behavior of this method is to call FacesContext.isValidationFailed() on the wrapped FacesContext object.

        Overrides:
        isValidationFailed in class FacesContext
        See Also:
        FacesContext.isValidationFailed()

      • validationFailed

        public void validationFailed()

        The default behavior of this method is to call FacesContext.validationFailed() on the wrapped FacesContext object.

        Overrides:
        validationFailed in class FacesContext
        See Also:
        FacesContext.validationFailed()

      • setProcessingEvents

        public void setProcessingEvents(boolean processingEvents)

        The default behavior of this method is to call FacesContext.setProcessingEvents(boolean) on the wrapped FacesContext object.

        Overrides:
        setProcessingEvents in class FacesContext
        Parameters:
        processingEvents - flag indicating events should be processed or not
        See Also:
        FacesContext.setProcessingEvents(boolean)

      • isProcessingEvents

        public boolean isProcessingEvents()

        The default behavior of this method is to call FacesContext.isProcessingEvents() on the wrapped FacesContext object.

        Overrides:
        isProcessingEvents in class FacesContext
        Returns:
        true if events should be published, otherwise false
        See Also:
        FacesContext.isProcessingEvents()

      • isProjectStage

        public boolean isProjectStage(ProjectStage stage)

        The default behavior of this method is to call FacesContext.isProjectStage(javax.faces.application.ProjectStage) on the wrapped FacesContext object.

        Overrides:
        isProjectStage in class FacesContext
        Parameters:
        stage - the ProjectStage to check
        See Also:
        FacesContext.isProjectStage(javax.faces.application.ProjectStage)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Flash (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class Flash

  • java.lang.Object
    • javax.faces.context.Flash
  • All Implemented Interfaces:
    Map<String,Object>
    Direct Known Subclasses:
    FlashWrapper

    public abstract class Flash
extends Object
implements Map<String,Object>

    The Flash concept is taken from Ruby on Rails and provides a way to pass temporary objects between the user views generated by the faces lifecycle. As in Rails, anything one places in the flash will be exposed to the next view encountered by the same user session and then cleared out. It is important to note that “next view” may have the same view id as the previous view.

    Implementation Requirements

    The flash is a session scoped object that must be thread safe.

    The implementation requirements will be described in terms of the runtime traversing the JSF lifecycle. The flash exposes a Map interface over two logical maps. The choice of which logical map is accessed depends on the current faces lifecycle phase. One logical map is for the current traversal and the other is for the next traversal. During the execute portion of the lifecycle, all flash accesses are sent to the current traversal map. During the render portion of the lifecycle, all flash accesses are sent to the next traversal map. On the next traversal through the lifecycle, the implementation must ensure that the current traversal map is the next traversal map of the previous traversal. Here is an example for illustration purposes only.

      Consider an initial request to the faces lifecycle

      Traversal N, execute phase: skipped on initial request.

      Traversal N, render phase: flash access goes to flash[N].

      Traversal N+1, execute phase: flash access goes to flash[N].

      Traversan N+1, render phase: flash access goes to flash[N+1].

    The implementation must ensure the proper behaviour of the flash is preserved even in the case of a <navigation-case> that contains a <redirect />. The implementation must ensure the proper behavior of the flash is preserved even in the case of adjacent GET requests on the same session. This allows Faces applications to fully utilize the “Post/Redirect/Get” design pattern.

    The implementation must allow the user to access the flash via the EL implicit object flash and also via ExternalContext.getFlash(). The implementation must ensure that the flash is usable from both JSP and from Facelets for JSF 2. In addition to exposing the Map interface, there are several features exposed as methods on the Flash itself. Each of these features may be accessed via the EL as well, as described in the javadocs.

    EL Usage Example

      First page

      <html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:c="http://xmlns.jcp.org/jsp/jstl/core">
<!-- extra code removed -->
  <c:set target="#{flash}" property="foo" value="fooValue" />

      Next page

      <html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:h="http://xmlns.jcp.org/jsf/html">
<!-- extra code removed -->
  <h:outputText value="#{flash.foo}" /> will be "fooValue"
  without the quotes.

    The same usage syntax must be available in JSP.

    Note that extra action must be taken when using the flash in concert with output components that cause the browser to issue a GET request when clicked, such as h:button and h:link. The following example illustrates one way to use the flash in such circumstances.

      First page

      <h:button id="nextButton" value="Next (button)" outcome="next.xhtml">
  <f:param name="foo" value="bar"/>
</h:button>

      Next page

      <html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:f="http://xmlns.jcp.org/jsf/core"
      xmlns:h="http://xmlns.jcp.org/jsf/html">
<f:metadata>
  <f:viewParam name="foo" id="foo" value="#{flash.now.foo}" />
</f:metadata>
<head /><body>
foo = #{flash.foo}
</body>
</html>

    Note that this example uses #{flash.now} on the second page. This is because the value doesn't actuall enter the flash until the server is processing the GET request sent by the browser due to the button being clicked.

    Since:
    2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String NULL_VALUE

      Because null values are not allowed as the source for subclasses of EventObject, such as PostKeepFlashValueEvent and PostPutFlashValueEvent, this value is substituted for null as the source in the case when a null value is put to or kept in the flash.

    • Constructor Summary

      Constructors
      Constructor and Description
      Flash()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void doPostPhaseActions(FacesContext ctx)

      Called after the execution of every lifecycle phase, this method allows implementations to take the necessary actions to provide the Flash scope contract as it applies to the request procesing lifecycle.
      abstract void doPrePhaseActions(FacesContext ctx)

      Called before the execution of every lifecycle phase, this method allows implementations to take the necessary actions to provide the Flash scope contract as it applies to the request procesing lifecycle.
      abstract boolean isKeepMessages()

      Return the value of this JavaBeans property for the flash for this session.
      abstract boolean isRedirect()

      Return the value of this property for the flash for this session.
      abstract void keep(String key)

      Causes a value stored with a previous call to putNow(java.lang.String, java.lang.Object), its EL equivalent, or to the request Map, to be promoted to the flash so that is available on the next traversal through the lifecycle on this session.
      abstract void putNow(String key, Object value)

      Puts a value in the flash so that it can be accessed on this traversal of the lifecycle, rather than on the next traversal.
      abstract void setKeepMessages(boolean newValue)

      Setter for keepMessages JavaBeans property.
      abstract void setRedirect(boolean newValue)

      Setting this property to true indicates that the next request on this session will be a redirect.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.util.Map

        clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

    • Field Detail

      • NULL_VALUE

        public static final String NULL_VALUE

        Because null values are not allowed as the source for subclasses of EventObject, such as PostKeepFlashValueEvent and PostPutFlashValueEvent, this value is substituted for null as the source in the case when a null value is put to or kept in the flash.

        See Also:
        Constant Field Values

    • Constructor Detail

      • Flash

        public Flash()

    • Method Detail

      • isKeepMessages

        public abstract boolean isKeepMessages()

        Return the value of this JavaBeans property for the flash for this session. This value determines whether or not any FacesMessage instances queued in the current FacesContext must be preserved so they are accessible on the next traversal of the lifecycle on this session, regardless of the request being a redirect after post, or a normal postback. Map accesses for the special key “keepMessages” must return the value of this JavaBeans property.

        EL Usage Example

          First page

          <html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:c="http://xmlns.jcp.org/jsp/jstl/core">
<!-- extra code removed -->
  <c:set target="#{flash}" property="keepMessages" value="true" />

          Next page

          <html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:h="http://xmlns.jcp.org/jsf/html">
<!-- extra code removed -->
  <h:messages /> Any messages present on the first page must be displayed on
  this page.
        Since:
        2.0

      • setKeepMessages

        public abstract void setKeepMessages(boolean newValue)

        Setter for keepMessages JavaBeans property. See isKeepMessages().

        Parameters:
        newValue - the new value for this property on this session.
        Since:
        2.0

      • isRedirect

        public abstract boolean isRedirect()

        Return the value of this property for the flash for this session. This must be false unless:

        • setRedirect(boolean) was called for the current lifecycle traversal with true as the argument.

        • The current lifecycle traversal for this session is in the “execute” phase and the previous traversal had setRedirect(boolean) called with true as the argument.

      • setRedirect

        public abstract void setRedirect(boolean newValue)

        Setting this property to true indicates that the next request on this session will be a redirect. Recall that on a redirect, the server sends a special response to the client instructing it to issue a new request to a specific URI. The implementation must insure that reading the value of this property on that request will return true.

        EL Usage Example

          <html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:c="http://xmlns.jcp.org/jsp/jstl/core">
<!-- extra code removed -->
  <c:set target="#{flash}" property="redirect" value="true" />
        Parameters:
        newValue - the new value for this property on this session.
        Since:
        2.0

      • putNow

        public abstract void putNow(String key,
          Object value)

        Puts a value in the flash so that it can be accessed on this traversal of the lifecycle, rather than on the next traversal. This is simply an alias for putting a value in the request map.

        EL Usage Example

          <html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:c="http://xmlns.jcp.org/jsp/jstl/core">
<!-- extra code removed -->
  <c:set target="#{flash.now}" property="bar" value="barValue" />

  <p>Value of \#{flash.now.bar}, should be barValue.</p>

  <h:outputText value="#{flash.now.bar}" />
        Parameters:
        key - the key for this entry
        value - the value for this entry
        Since:
        2.0

      • keep

        public abstract void keep(String key)

        Causes a value stored with a previous call to putNow(java.lang.String, java.lang.Object), its EL equivalent, or to the request Map, to be promoted to the flash so that is available on the next traversal through the lifecycle on this session.

        Parameters:
        key - if argument key is the name of an entry previously stored to the flash on this traversal through the lifecycle via a call to putNow(java.lang.String, java.lang.Object), or to a set to the EL expression #{flash.now.<key>}, or to the request Map, to be promoted to the flash as if a call to put() or a set to the expression #{flash.<key>} was being called.

      • doPrePhaseActions

        public abstract void doPrePhaseActions(FacesContext ctx)

        Called before the execution of every lifecycle phase, this method allows implementations to take the necessary actions to provide the Flash scope contract as it applies to the request procesing lifecycle.

        Parameters:
        ctx - the FacesContext for this request.

      • doPostPhaseActions

        public abstract void doPostPhaseActions(FacesContext ctx)

        Called after the execution of every lifecycle phase, this method allows implementations to take the necessary actions to provide the Flash scope contract as it applies to the request procesing lifecycle.

        Parameters:
        ctx - the FacesContext for this request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlashFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class FlashFactory

  • java.lang.Object
    • javax.faces.context.FlashFactory
  • All Implemented Interfaces:
    FacesWrapper<FlashFactory>

    public abstract class FlashFactory
extends Object
implements FacesWrapper<FlashFactory>

    FlashFactory is a factory object that creates (if needed) and returns Flash instances. Implementations of JavaServer Faces must provide at least a default implementation of Flash.

    There must be one FlashFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

       FlashFactory factory = (FlashFactory)
     FactoryFinder.getFactory(FactoryFinder.FLASH_FACTORY);

    The common way to access the flash instance from Java code is still via ExternalContext.getFlash(). The common way to access the flash from Faces views is the implicit EL object "flash". The runtime must ensure that the FlashFactory is used to instantiate the flash.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      FlashFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Flash getFlash(boolean create)

      Create (if needed) and return a Flash instance for this web application.
      FlashFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FlashFactory

        public FlashFactory()

    • Method Detail

      • getWrapped

        public FlashFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<FlashFactory>
        Since:
        2.2

      • getFlash

        public abstract Flash getFlash(boolean create)

        Create (if needed) and return a Flash instance for this web application.

        Parameters:
        create - true to create a new instance for this request if necessary; false to return null if there's no instance in the current session.
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlashWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class FlashWrapper

  • java.lang.Object
    • javax.faces.context.Flash
      • javax.faces.context.FlashWrapper
  • All Implemented Interfaces:
    Map<String,Object>, FacesWrapper<Flash>

    public abstract class FlashWrapper
extends Flash
implements FacesWrapper<Flash>

    Provides a simple implementation of Flash that can be subclassed by developers wishing to provide specialized behavior to an existing Flash instance. The default implementation of all methods is to call through to the wrapped Flash.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    2.2

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      • Fields inherited from class javax.faces.context.Flash

        NULL_VALUE

    • Constructor Summary

      Constructors
      Constructor and Description
      FlashWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clear()

      The default behavior of this method is to call Map.clear() on the wrapped Flash object.
      boolean containsKey(Object key)

      The default behavior of this method is to call Map.containsKey(Object) on the wrapped Flash object.
      boolean containsValue(Object value)

      The default behavior of this method is to call Map.containsValue(Object) on the wrapped Flash object.
      void doPostPhaseActions(FacesContext ctx)

      The default behavior of this method is to call Flash.doPostPhaseActions(FacesContext) on the wrapped Flash object.
      void doPrePhaseActions(FacesContext ctx)

      The default behavior of this method is to call Flash.doPrePhaseActions(FacesContext) on the wrapped Flash object.
      Set<Map.Entry<String,Object>> entrySet()

      The default behavior of this method is to call Map.entrySet() on the wrapped Flash object.
      Object get(Object key)

      The default behavior of this method is to call Map.get(Object) on the wrapped Flash object.
      abstract Flash getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      boolean isEmpty()

      The default behavior of this method is to call Map.isEmpty() on the wrapped Flash object.
      boolean isKeepMessages()

      The default behavior of this method is to call Flash.isKeepMessages() on the wrapped Flash object.
      boolean isRedirect()

      The default behavior of this method is to call Flash.isRedirect() on the wrapped Flash object.
      void keep(String key)

      The default behavior of this method is to call Flash.keep(String) on the wrapped Flash object.
      Set<String> keySet()

      The default behavior of this method is to call Map.keySet() on the wrapped Flash object.
      Object put(String key, Object value)

      The default behavior of this method is to call Map.put(K, V) on the wrapped Flash object.
      void putAll(Map<? extends String,? extends Object> m)

      The default behavior of this method is to call Map.putAll(Map) on the wrapped Flash object.
      void putNow(String key, Object value)

      The default behavior of this method is to call Flash.putNow(String, Object) on the wrapped Flash object.
      Object remove(Object key)

      The default behavior of this method is to call Map.remove(Object) on the wrapped Flash object.
      void setKeepMessages(boolean newValue)

      The default behavior of this method is to call Flash.setKeepMessages(boolean) on the wrapped Flash object.
      void setRedirect(boolean newValue)

      The default behavior of this method is to call Flash.setRedirect(boolean) on the wrapped Flash object.
      int size()

      The default behavior of this method is to call Map.size() on the wrapped Flash object.
      Collection<Object> values()

      The default behavior of this method is to call Map.values() on the wrapped Flash object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.util.Map

        equals, hashCode

    • Constructor Detail

      • FlashWrapper

        public FlashWrapper()

    • Method Detail

      • getWrapped

        public abstract Flash getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<Flash>

      • doPostPhaseActions

        public void doPostPhaseActions(FacesContext ctx)

        The default behavior of this method is to call Flash.doPostPhaseActions(FacesContext) on the wrapped Flash object.

        Specified by:
        doPostPhaseActions in class Flash
        Parameters:
        ctx - the FacesContext for this request.
        Since:
        2.2

      • doPrePhaseActions

        public void doPrePhaseActions(FacesContext ctx)

        The default behavior of this method is to call Flash.doPrePhaseActions(FacesContext) on the wrapped Flash object.

        Specified by:
        doPrePhaseActions in class Flash
        Parameters:
        ctx - the FacesContext for this request.
        Since:
        2.2

      • isKeepMessages

        public boolean isKeepMessages()

        The default behavior of this method is to call Flash.isKeepMessages() on the wrapped Flash object.

        Specified by:
        isKeepMessages in class Flash
        Since:
        2.2

      • isRedirect

        public boolean isRedirect()

        The default behavior of this method is to call Flash.isRedirect() on the wrapped Flash object.

        Specified by:
        isRedirect in class Flash
        Since:
        2.2

      • keep

        public void keep(String key)

        The default behavior of this method is to call Flash.keep(String) on the wrapped Flash object.

        Specified by:
        keep in class Flash
        Parameters:
        key - if argument key is the name of an entry previously stored to the flash on this traversal through the lifecycle via a call to Flash.putNow(java.lang.String, java.lang.Object), or to a set to the EL expression #{flash.now.<key>}, or to the request Map, to be promoted to the flash as if a call to put() or a set to the expression #{flash.<key>} was being called.
        Since:
        2.2

      • putNow

        public void putNow(String key,
          Object value)

        The default behavior of this method is to call Flash.putNow(String, Object) on the wrapped Flash object.

        Specified by:
        putNow in class Flash
        Parameters:
        key - the key for this entry
        value - the value for this entry
        Since:
        2.2

      • setKeepMessages

        public void setKeepMessages(boolean newValue)

        The default behavior of this method is to call Flash.setKeepMessages(boolean) on the wrapped Flash object.

        Specified by:
        setKeepMessages in class Flash
        Parameters:
        newValue - the new value for this property on this session.
        Since:
        2.2

      • setRedirect

        public void setRedirect(boolean newValue)

        The default behavior of this method is to call Flash.setRedirect(boolean) on the wrapped Flash object.

        Specified by:
        setRedirect in class Flash
        Parameters:
        newValue - the new value for this property on this session.
        Since:
        2.2

      • clear

        public void clear()

        The default behavior of this method is to call Map.clear() on the wrapped Flash object.

        Specified by:
        clear in interface Map<String,Object>
        Since:
        2.2

      • containsKey

        public boolean containsKey(Object key)

        The default behavior of this method is to call Map.containsKey(Object) on the wrapped Flash object.

        Specified by:
        containsKey in interface Map<String,Object>
        Since:
        2.2

      • containsValue

        public boolean containsValue(Object value)

        The default behavior of this method is to call Map.containsValue(Object) on the wrapped Flash object.

        Specified by:
        containsValue in interface Map<String,Object>
        Since:
        2.2

      • entrySet

        public Set<Map.Entry<String,Object>> entrySet()

        The default behavior of this method is to call Map.entrySet() on the wrapped Flash object.

        Specified by:
        entrySet in interface Map<String,Object>
        Since:
        2.2

      • get

        public Object get(Object key)

        The default behavior of this method is to call Map.get(Object) on the wrapped Flash object.

        Specified by:
        get in interface Map<String,Object>
        Since:
        2.2

      • isEmpty

        public boolean isEmpty()

        The default behavior of this method is to call Map.isEmpty() on the wrapped Flash object.

        Specified by:
        isEmpty in interface Map<String,Object>
        Since:
        2.2

      • keySet

        public Set<String> keySet()

        The default behavior of this method is to call Map.keySet() on the wrapped Flash object.

        Specified by:
        keySet in interface Map<String,Object>
        Since:
        2.2

      • put

        public Object put(String key,
         Object value)

        The default behavior of this method is to call Map.put(K, V) on the wrapped Flash object.

        Specified by:
        put in interface Map<String,Object>
        Since:
        2.2

      • putAll

        public void putAll(Map<? extends String,? extends Object> m)

        The default behavior of this method is to call Map.putAll(Map) on the wrapped Flash object.

        Specified by:
        putAll in interface Map<String,Object>
        Since:
        2.2

      • remove

        public Object remove(Object key)

        The default behavior of this method is to call Map.remove(Object) on the wrapped Flash object.

        Specified by:
        remove in interface Map<String,Object>
        Since:
        2.2

      • size

        public int size()

        The default behavior of this method is to call Map.size() on the wrapped Flash object.

        Specified by:
        size in interface Map<String,Object>
        Since:
        2.2

      • values

        public Collection<Object> values()

        The default behavior of this method is to call Map.values() on the wrapped Flash object.

        Specified by:
        values in interface Map<String,Object>
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces.context (Java(TM) EE 7 Specification APIs)

javax.faces.context

Classes

  • ExceptionHandler
  • ExceptionHandlerFactory
  • ExceptionHandlerWrapper
  • ExternalContext
  • ExternalContextFactory
  • ExternalContextWrapper
  • FacesContext
  • FacesContextFactory
  • FacesContextWrapper
  • Flash
  • FlashFactory
  • FlashWrapper
  • PartialResponseWriter
  • PartialViewContext
  • PartialViewContextFactory
  • PartialViewContextWrapper
  • ResponseStream
  • ResponseWriter
  • ResponseWriterWrapper


javax.faces.context (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.context

Classes and interfaces defining per-request state information.

See: Description

  • Class Summary
    Class Description
    ExceptionHandler

    ExceptionHandler is the central point for handling unexpected Exceptions that are thrown during the Faces lifecycle.
    ExceptionHandlerFactory

    ExceptionHandlerFactory is a factory object that creates (if needed) and returns a new ExceptionHandler instance.
    ExceptionHandlerWrapper
    Provides a simple implementation of ExceptionHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ExceptionHandler instance.
    ExternalContext
    This class allows the Faces API to be unaware of the nature of its containing application environment.
    ExternalContextFactory
    ExternalContextFactory is a factory object that creates (if needed) and returns new ExternalContext instances, initialized for the processing of the specified request and response objects.
    ExternalContextWrapper

    Provides a simple implementation of ExternalContext that can be subclassed by developers wishing to provide specialized behavior to an existing ExternalContext instance.
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
    FacesContextFactory
    FacesContextFactory is a factory object that creates (if needed) and returns new FacesContext instances, initialized for the processing of the specified request and response objects.
    FacesContextWrapper
    Provides a simple implementation of FacesContext that can be subclassed by developers wishing to provide specialized behavior to an existing FacesContext instance.
    Flash

    The Flash concept is taken from Ruby on Rails and provides a way to pass temporary objects between the user views generated by the faces lifecycle.
    FlashFactory
    FlashFactory is a factory object that creates (if needed) and returns Flash instances.
    FlashWrapper

    Provides a simple implementation of Flash that can be subclassed by developers wishing to provide specialized behavior to an existing Flash instance.
    PartialResponseWriter

    PartialResponseWriter decorates an existing ResponseWriter to support the generation of a partial response suitable for Ajax operations.
    PartialViewContext
    PartialViewContext contains methods and properties that pertain to partial request processing and partial response rendering on a view.
    PartialViewContextFactory

    PartialViewContextFactory is a factory object that creates (if needed) and returns new PartialViewContext instances.
    PartialViewContextWrapper

    Provides a simple implementation of PartialViewContext that can be subclassed by developers wishing to provide specialized behavior to an existing PartialViewContext instance.
    ResponseStream
    ResponseStream is an interface describing an adapter to an underlying output mechanism for binary output.
    ResponseWriter
    ResponseWriter is an abstract class describing an adapter to an underlying output mechanism for character-based output.
    ResponseWriterWrapper
    Provides a simple implementation of ResponseWriter that can be subclassed by developers wishing to provide specialized behavior to an existing ResponseWriter instance.

Package javax.faces.context Description

Classes and interfaces defining per-request state information. The main class in this package is FacesContext, which is the access point for all per-request information, as well as the gateway to several other helper classes.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.context Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.context

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.context.ExceptionHandler (implements javax.faces.event.SystemEventListener)
      • javax.faces.context.ExceptionHandlerWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.ExceptionHandlerFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.ExternalContext
      • javax.faces.context.ExternalContextWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.ExternalContextFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.FacesContext
      • javax.faces.context.FacesContextWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.FacesContextFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.Flash (implements java.util.Map<K,V>)
      • javax.faces.context.FlashWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.FlashFactory (implements javax.faces.FacesWrapper<T>)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • javax.faces.context.ResponseStream
    • javax.faces.context.PartialViewContext
      • javax.faces.context.PartialViewContextWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.PartialViewContextFactory (implements javax.faces.FacesWrapper<T>)
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • javax.faces.context.ResponseWriter
        • javax.faces.context.ResponseWriterWrapper (implements javax.faces.FacesWrapper<T>)
          • javax.faces.context.PartialResponseWriter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


PartialResponseWriter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class PartialResponseWriter

  • java.lang.Object
    • java.io.Writer
      • javax.faces.context.ResponseWriter
        • javax.faces.context.ResponseWriterWrapper
          • javax.faces.context.PartialResponseWriter
  • All Implemented Interfaces:
    Closeable, Flushable, Appendable, AutoCloseable, FacesWrapper<ResponseWriter>

    public class PartialResponseWriter
extends ResponseWriterWrapper

    PartialResponseWriter decorates an existing ResponseWriter to support the generation of a partial response suitable for Ajax operations. In addition to the markup generation methods inherited from javax.faces.context.ResponseWriter, this class provides methods for constructing the standard partial response elements.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String RENDER_ALL_MARKER

      Reserved ID value to indicate entire ViewRoot.
      static String VIEW_STATE_MARKER

      Reserved ID value to indicate serialized ViewState.

      • Fields inherited from class java.io.Writer

        lock

    • Constructor Summary

      Constructors
      Constructor and Description
      PartialResponseWriter(ResponseWriter writer)

      Create a PartialResponseWriter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void delete(String targetId)

      Write a delete operation.
      void endDocument()

      Write the end of a partial response.
      void endError()

      Write the end of an error.
      void endEval()

      Write the end of an eval operation.
      void endExtension()

      Write the end of an extension operation.
      void endInsert()

      Write the end of an insert operation.
      void endUpdate()

      Write the end of an update operation.
      ResponseWriter getWrapped()

      Return the wrapped ResponseWriter instance.
      void redirect(String url)

      Write a redirect operation.
      void startDocument()

      Write the start of a partial response.
      void startError(String errorName)

      Write the start of an error.
      void startEval()

      Write the start of an eval operation.
      void startExtension(Map<String,String> attributes)

      Write the start of an extension operation.
      void startInsertAfter(String targetId)

      Write the start of an insert operation where the contents will be inserted after the specified target node.
      void startInsertBefore(String targetId)

      Write the start of an insert operation where the contents will be inserted before the specified target node.
      void startUpdate(String targetId)

      Write the start of an update operation.
      void updateAttributes(String targetId, Map<String,String> attributes)

      Write an attribute update operation.

      • Methods inherited from class javax.faces.context.ResponseWriterWrapper

        cloneWithWriter, close, endCDATA, endElement, flush, getCharacterEncoding, getContentType, startCDATA, startElement, write, writeAttribute, writeComment, writeDoctype, writePreamble, writeText, writeText, writeText, writeURIAttribute

      • Methods inherited from class java.io.Writer

        append, append, append, write, write, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • RENDER_ALL_MARKER

        public static final String RENDER_ALL_MARKER

        Reserved ID value to indicate entire ViewRoot.

        Since:
        2.0
        See Also:
        Constant Field Values

      • VIEW_STATE_MARKER

        public static final String VIEW_STATE_MARKER

        Reserved ID value to indicate serialized ViewState.

        Since:
        2.0
        See Also:
        Constant Field Values

    • Constructor Detail

      • PartialResponseWriter

        public PartialResponseWriter(ResponseWriter writer)

        Create a PartialResponseWriter.

        Parameters:
        writer - The writer to wrap.
        Since:
        2.0

    • Method Detail

      • getWrapped

        public ResponseWriter getWrapped()

        Return the wrapped ResponseWriter instance.

        Specified by:
        getWrapped in interface FacesWrapper<ResponseWriter>
        Specified by:
        getWrapped in class ResponseWriterWrapper
        Since:
        2.0
        See Also:
        ResponseWriterWrapper.getWrapped()

      • startDocument

        public void startDocument()
                   throws IOException

        Write the start of a partial response.

        Overrides:
        startDocument in class ResponseWriterWrapper
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0
        See Also:
        ResponseWriter.startDocument()

      • endDocument

        public void endDocument()
                 throws IOException

        Write the end of a partial response.

        Overrides:
        endDocument in class ResponseWriterWrapper
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0
        See Also:
        ResponseWriter.endDocument()

      • startInsertBefore

        public void startInsertBefore(String targetId)
                       throws IOException

        Write the start of an insert operation where the contents will be inserted before the specified target node.

        Parameters:
        targetId - ID of the node insertion should occur before
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • startInsertAfter

        public void startInsertAfter(String targetId)
                      throws IOException

        Write the start of an insert operation where the contents will be inserted after the specified target node.

        Parameters:
        targetId - ID of the node insertion should occur after
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • endInsert

        public void endInsert()
               throws IOException

        Write the end of an insert operation.

        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • startUpdate

        public void startUpdate(String targetId)
                 throws IOException

        Write the start of an update operation.

        Parameters:
        targetId - ID of the node to be updated
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • endUpdate

        public void endUpdate()
               throws IOException

        Write the end of an update operation.

        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • updateAttributes

        public void updateAttributes(String targetId,
                    Map<String,String> attributes)
                      throws IOException

        Write an attribute update operation.

        Parameters:
        targetId - ID of the node to be updated
        attributes - Map of attribute name/value pairs to be updated
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • delete

        public void delete(String targetId)
            throws IOException

        Write a delete operation.

        Parameters:
        targetId - ID of the node to be deleted
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • redirect

        public void redirect(String url)
              throws IOException

        Write a redirect operation.

        Parameters:
        url - URL to redirect to
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • startEval

        public void startEval()
               throws IOException

        Write the start of an eval operation.

        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • endEval

        public void endEval()
             throws IOException

        Write the end of an eval operation.

        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • startExtension

        public void startExtension(Map<String,String> attributes)
                    throws IOException

        Write the start of an extension operation.

        Parameters:
        attributes - String name/value pairs for extension element attributes
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • endExtension

        public void endExtension()
                  throws IOException

        Write the end of an extension operation.

        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • startError

        public void startError(String errorName)
                throws IOException

        Write the start of an error.

        Parameters:
        errorName - Descriptive string for the error
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0

      • endError

        public void endError()
              throws IOException

        Write the end of an error.

        Throws:
        IOException - if an input/output error occurs
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PartialViewContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class PartialViewContext

  • java.lang.Object
    • javax.faces.context.PartialViewContext
  • Direct Known Subclasses:
    PartialViewContextWrapper

    public abstract class PartialViewContext
extends Object

    PartialViewContext contains methods and properties that pertain to partial request processing and partial response rendering on a view.

    The PartialViewContext instance is used to determine if the current request indicates the requirement to perform partial processing and/or partial rendering. Partial processing is the processing of selected components through the execute portion of the request processing lifecycle. Partial rendering is the rendering of specified components in the Render Response Phase of the request processing lifecycle.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ALL_PARTIAL_PHASE_CLIENT_IDS

      The value that when used with PARTIAL_EXECUTE_PARAM_NAME or PARTIAL_RENDER_PARAM_NAME indicates these phases must be skipped.
      static String PARTIAL_EXECUTE_PARAM_NAME

      The request parameter name whose request parameter value is a Collection of client identifiers identifying the components that must be processed during the Apply Request Values, Process Validations, and Update Model Values phases of the request processing lifecycle.
      static String PARTIAL_RENDER_PARAM_NAME

      The request parameter name whose request parameter value is a Collection of client identifiers identifying the components that must be processed during the Render Response phase of the request processing lifecycle.
      static String RESET_VALUES_PARAM_NAME

      If the request parameter named by the value of this constant has a parameter value of true, the implementation must return true from isResetValues().

    • Constructor Summary

      Constructors
      Constructor and Description
      PartialViewContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Collection<String> getExecuteIds()

      Return a Collection of client identifiers from the current request with the request parameter name PARTIAL_EXECUTE_PARAM_NAME.
      abstract PartialResponseWriter getPartialResponseWriter()

      Return the ResponseWriter to which components should direct their output for partial view rendering.
      abstract Collection<String> getRenderIds()

      Return a Collection of client identifiers from the current request with the request parameter name PARTIAL_RENDER_PARAM_NAME.
      abstract boolean isAjaxRequest()

      Return true if the request header Faces-Request is present with the value partial/ajax.
      abstract boolean isExecuteAll()

      Return true if isAjaxRequest() returns true and PARTIAL_EXECUTE_PARAM_NAME is present in the current request with the value ALL_PARTIAL_PHASE_CLIENT_IDS.
      abstract boolean isPartialRequest()

      Return true isAjaxRequest() returns true or if the request header Faces-Request is present with the value partial/process.
      abstract boolean isRenderAll()

      Return true if isAjaxRequest() returns true and PARTIAL_RENDER_PARAM_NAME is present in the current request with the value ALL_PARTIAL_PHASE_CLIENT_IDS.
      boolean isResetValues()

      Return true if the incoming request has a parameter named by the value of RESET_VALUES_PARAM_NAME and that value is true.
      abstract void processPartial(PhaseId phaseId)

      Perform lifecycle processing on components during the indicated phaseId.
      abstract void release()
      Release any resources associated with this PartialViewContext instance.
      abstract void setPartialRequest(boolean isPartialRequest)

      Dynamically indicate that this is a partial request.
      abstract void setRenderAll(boolean renderAll)

      Indicate the entire view must be rendered if renderAll is true.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • PARTIAL_RENDER_PARAM_NAME

        public static final String PARTIAL_RENDER_PARAM_NAME

        The request parameter name whose request parameter value is a Collection of client identifiers identifying the components that must be processed during the Render Response phase of the request processing lifecycle.

        Since:
        2.0
        See Also:
        Constant Field Values

      • PARTIAL_EXECUTE_PARAM_NAME

        public static final String PARTIAL_EXECUTE_PARAM_NAME

        The request parameter name whose request parameter value is a Collection of client identifiers identifying the components that must be processed during the Apply Request Values, Process Validations, and Update Model Values phases of the request processing lifecycle.

        Since:
        2.0
        See Also:
        Constant Field Values

      • RESET_VALUES_PARAM_NAME

        public static final String RESET_VALUES_PARAM_NAME

        If the request parameter named by the value of this constant has a parameter value of true, the implementation must return true from isResetValues().

        Since:
        2.2
        See Also:
        Constant Field Values

      • ALL_PARTIAL_PHASE_CLIENT_IDS

        public static final String ALL_PARTIAL_PHASE_CLIENT_IDS

        The value that when used with PARTIAL_EXECUTE_PARAM_NAME or PARTIAL_RENDER_PARAM_NAME indicates these phases must be skipped.

        Since:
        2.0
        See Also:
        Constant Field Values

    • Constructor Detail

      • PartialViewContext

        public PartialViewContext()

    • Method Detail

      • getExecuteIds

        public abstract Collection<String> getExecuteIds()

        Return a Collection of client identifiers from the current request with the request parameter name PARTIAL_EXECUTE_PARAM_NAME. If there is no such request parameter, return an empty Collection. These client identifiers are used to identify components that will be processed during the execute phase of the request processing lifecycle. The returned Collection is mutable.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • getRenderIds

        public abstract Collection<String> getRenderIds()

        Return a Collection of client identifiers from the current request with the request parameter name PARTIAL_RENDER_PARAM_NAME. If there is no such request parameter, return an empty Collection. These client identifiers are used to identify components that will be processed during the render phase of the request processing lifecycle. The returned Collection is mutable.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • getPartialResponseWriter

        public abstract PartialResponseWriter getPartialResponseWriter()

        Return the ResponseWriter to which components should direct their output for partial view rendering. Within a given response, components can use either the ResponseStream or the ResponseWriter, but not both.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • isAjaxRequest

        public abstract boolean isAjaxRequest()

        Return true if the request header Faces-Request is present with the value partial/ajax. Otherwise, return false.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • isPartialRequest

        public abstract boolean isPartialRequest()

        Return true isAjaxRequest() returns true or if the request header Faces-Request is present with the value partial/process. Otherwise, return false.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • isExecuteAll

        public abstract boolean isExecuteAll()

        Return true if isAjaxRequest() returns true and PARTIAL_EXECUTE_PARAM_NAME is present in the current request with the value ALL_PARTIAL_PHASE_CLIENT_IDS.

        Otherwise, return false.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • isRenderAll

        public abstract boolean isRenderAll()

        Return true if isAjaxRequest() returns true and PARTIAL_RENDER_PARAM_NAME is present in the current request with the value ALL_PARTIAL_PHASE_CLIENT_IDS.

        Otherwise, return false.

        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • isResetValues

        public boolean isResetValues()

        Return true if the incoming request has a parameter named by the value of RESET_VALUES_PARAM_NAME and that value is true. To preserve backward compatibility with custom implementations that may have extended from an earlier version of this class, an implementation is provided that returns false. A compliant implementation must override this method to take the specified action.

        Since:
        2.2

      • setRenderAll

        public abstract void setRenderAll(boolean renderAll)

        Indicate the entire view must be rendered if renderAll is true.

        Parameters:
        renderAll - the value true indicates the entire view must be rendered.
        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • setPartialRequest

        public abstract void setPartialRequest(boolean isPartialRequest)

        Dynamically indicate that this is a partial request.

        Parameters:
        isPartialRequest - the value true indicates this is a partial request.
        Throws:
        IllegalStateException - if this method is called after this instance has been released
        Since:
        2.0

      • release

        public abstract void release()

        Release any resources associated with this PartialViewContext instance.

        Throws:
        IllegalStateException - if this method is called after this instance has been released

      • processPartial

        public abstract void processPartial(PhaseId phaseId)

        Perform lifecycle processing on components during the indicated phaseId. Only those components with identifiers existing in the Collection returned from getExecuteIds() and getRenderIds() will be processed.

        Parameters:
        phaseId - the PhaseId that indicates the lifecycle phase the components will be processed in.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PartialViewContextFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class PartialViewContextFactory

  • java.lang.Object
    • javax.faces.context.PartialViewContextFactory
  • All Implemented Interfaces:
    FacesWrapper<PartialViewContextFactory>

    public abstract class PartialViewContextFactory
extends Object
implements FacesWrapper<PartialViewContextFactory>

    PartialViewContextFactory is a factory object that creates (if needed) and returns new PartialViewContext instances.

    There must be one PartialViewContextFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

       PartialViewContextFactory factory = (PartialViewContextFactory)
    FactoryFinder.getFactory(FactoryFinder.PARTIAL_VIEW_CONTEXT_FACTORY);
    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      PartialViewContextFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract PartialViewContext getPartialViewContext(FacesContext context)
      Create (if needed) and return a PartialViewContext instance that is initialized using the current FacesContext instance.
      PartialViewContextFactory getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PartialViewContextFactory

        public PartialViewContextFactory()

    • Method Detail

      • getWrapped

        public PartialViewContextFactory getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<PartialViewContextFactory>
        See Also:
        FacesWrapper.getWrapped()

      • getPartialViewContext

        public abstract PartialViewContext getPartialViewContext(FacesContext context)

        Create (if needed) and return a PartialViewContext instance that is initialized using the current FacesContext instance.

        Parameters:
        context - the FacesContext for the current request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PartialViewContextWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class PartialViewContextWrapper

  • java.lang.Object
    • javax.faces.context.PartialViewContext
      • javax.faces.context.PartialViewContextWrapper
  • All Implemented Interfaces:
    FacesWrapper<PartialViewContext>

    public abstract class PartialViewContextWrapper
extends PartialViewContext
implements FacesWrapper<PartialViewContext>

    Provides a simple implementation of PartialViewContext that can be subclassed by developers wishing to provide specialized behavior to an existing PartialViewContext instance. The default implementation of all methods is to call through to the wrapped ExternalContext instance.

    Usage: extend this class and override getWrapped() to return the instance being wrapping.

    Since:
    2.0

    • Field Summary

      • Fields inherited from class javax.faces.context.PartialViewContext

        ALL_PARTIAL_PHASE_CLIENT_IDS, PARTIAL_EXECUTE_PARAM_NAME, PARTIAL_RENDER_PARAM_NAME, RESET_VALUES_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      PartialViewContextWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Collection<String> getExecuteIds()
      The default behavior of this method is to call PartialViewContext.getExecuteIds() on the wrapped PartialViewContext object.
      PartialResponseWriter getPartialResponseWriter()
      The default behavior of this method is to call PartialViewContext.getPartialResponseWriter() on the wrapped PartialViewContext object.
      Collection<String> getRenderIds()
      The default behavior of this method is to call PartialViewContext.getRenderIds() on the wrapped PartialViewContext object.
      abstract PartialViewContext getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      boolean isAjaxRequest()
      The default behavior of this method is to call PartialViewContext.isAjaxRequest() on the wrapped PartialViewContext object.
      boolean isExecuteAll()
      The default behavior of this method is to call PartialViewContext.isExecuteAll() on the wrapped PartialViewContext object.
      boolean isPartialRequest()
      The default behavior of this method is to call PartialViewContext.isPartialRequest() on the wrapped PartialViewContext object.
      boolean isRenderAll()
      The default behavior of this method is to call PartialViewContext.isRenderAll() on the wrapped PartialViewContext object.
      boolean isResetValues()
      The default behavior of this method is to call PartialViewContext.isResetValues() on the wrapped PartialViewContext object.
      void processPartial(PhaseId phaseId)
      The default behavior of this method is to call PartialViewContext.processPartial(PhaseId) on the wrapped PartialViewContext object.
      void release()
      The default behavior of this method is to call PartialViewContext.release() on the wrapped PartialViewContext object.
      void setPartialRequest(boolean isPartialRequest)

      The default behavior of this method is to call PartialViewContext.setPartialRequest(boolean) on the wrapped PartialViewContext object.
      void setRenderAll(boolean renderAll)
      The default behavior of this method is to call PartialViewContext.setRenderAll(boolean) on the wrapped PartialViewContext object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PartialViewContextWrapper

        public PartialViewContextWrapper()

    • Method Detail

      • getWrapped

        public abstract PartialViewContext getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<PartialViewContext>
        Returns:
        the wrapped PartialViewContext instance
        See Also:
        FacesWrapper.getWrapped()

      • getExecuteIds

        public Collection<String> getExecuteIds()

        The default behavior of this method is to call PartialViewContext.getExecuteIds() on the wrapped PartialViewContext object.

        Specified by:
        getExecuteIds in class PartialViewContext
        See Also:
        PartialViewContext.getExecuteIds()

      • getRenderIds

        public Collection<String> getRenderIds()

        The default behavior of this method is to call PartialViewContext.getRenderIds() on the wrapped PartialViewContext object.

        Specified by:
        getRenderIds in class PartialViewContext
        See Also:
        PartialViewContext.getRenderIds()

      • getPartialResponseWriter

        public PartialResponseWriter getPartialResponseWriter()

        The default behavior of this method is to call PartialViewContext.getPartialResponseWriter() on the wrapped PartialViewContext object.

        Specified by:
        getPartialResponseWriter in class PartialViewContext
        See Also:
        PartialViewContext.getPartialResponseWriter()

      • setPartialRequest

        public void setPartialRequest(boolean isPartialRequest)

        The default behavior of this method is to call PartialViewContext.setPartialRequest(boolean) on the wrapped PartialViewContext object.

        Specified by:
        setPartialRequest in class PartialViewContext
        Parameters:
        isPartialRequest - the value true indicates this is a partial request.
        See Also:
        PartialViewContext.setPartialRequest(boolean)

      • isAjaxRequest

        public boolean isAjaxRequest()

        The default behavior of this method is to call PartialViewContext.isAjaxRequest() on the wrapped PartialViewContext object.

        Specified by:
        isAjaxRequest in class PartialViewContext
        See Also:
        PartialViewContext.isAjaxRequest()

      • isPartialRequest

        public boolean isPartialRequest()

        The default behavior of this method is to call PartialViewContext.isPartialRequest() on the wrapped PartialViewContext object.

        Specified by:
        isPartialRequest in class PartialViewContext
        See Also:
        PartialViewContext.isPartialRequest()

      • isExecuteAll

        public boolean isExecuteAll()

        The default behavior of this method is to call PartialViewContext.isExecuteAll() on the wrapped PartialViewContext object.

        Specified by:
        isExecuteAll in class PartialViewContext
        See Also:
        PartialViewContext.isExecuteAll()

      • isRenderAll

        public boolean isRenderAll()

        The default behavior of this method is to call PartialViewContext.isRenderAll() on the wrapped PartialViewContext object.

        Specified by:
        isRenderAll in class PartialViewContext
        See Also:
        PartialViewContext.isRenderAll()

      • isResetValues

        public boolean isResetValues()

        The default behavior of this method is to call PartialViewContext.isResetValues() on the wrapped PartialViewContext object.

        Overrides:
        isResetValues in class PartialViewContext
        See Also:
        PartialViewContext.isResetValues()

      • setRenderAll

        public void setRenderAll(boolean renderAll)

        The default behavior of this method is to call PartialViewContext.setRenderAll(boolean) on the wrapped PartialViewContext object.

        Specified by:
        setRenderAll in class PartialViewContext
        Parameters:
        renderAll - the value true indicates the entire view must be rendered.
        See Also:
        PartialViewContext.setRenderAll(boolean)

      • release

        public void release()

        The default behavior of this method is to call PartialViewContext.release() on the wrapped PartialViewContext object.

        Specified by:
        release in class PartialViewContext
        See Also:
        PartialViewContext.release()

      • processPartial

        public void processPartial(PhaseId phaseId)

        The default behavior of this method is to call PartialViewContext.processPartial(PhaseId) on the wrapped PartialViewContext object.

        Specified by:
        processPartial in class PartialViewContext
        Parameters:
        phaseId - the PhaseId that indicates the lifecycle phase the components will be processed in.
        See Also:
        PartialViewContext.processPartial(PhaseId)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResponseStream (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class ResponseStream

  • java.lang.Object
    • java.io.OutputStream
      • javax.faces.context.ResponseStream
  • All Implemented Interfaces:
    Closeable, Flushable, AutoCloseable

    public abstract class ResponseStream
extends OutputStream

    ResponseStream is an interface describing an adapter to an underlying output mechanism for binary output.

    • Constructor Summary

      Constructors
      Constructor and Description
      ResponseStream()

    • Method Summary

      • Methods inherited from class java.io.OutputStream

        close, flush, write, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ResponseStream

        public ResponseStream()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResponseWriter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class ResponseWriter

  • java.lang.Object
    • java.io.Writer
      • javax.faces.context.ResponseWriter
  • All Implemented Interfaces:
    Closeable, Flushable, Appendable, AutoCloseable
    Direct Known Subclasses:
    ResponseWriterWrapper

    public abstract class ResponseWriter
extends Writer

    ResponseWriter is an abstract class describing an adapter to an underlying output mechanism for character-based output. In addition to the low-level write() methods inherited from java.io.Writer, this class provides utility methods that are useful in producing elements and attributes for markup languages like HTML and XML.

    • Field Summary

      • Fields inherited from class java.io.Writer

        lock

    • Constructor Summary

      Constructors
      Constructor and Description
      ResponseWriter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ResponseWriter cloneWithWriter(Writer writer)
      Create and return a new instance of this ResponseWriter, using the specified Writer as the output destination.
      void endCDATA()

      Close an XML CDATA block.
      abstract void endDocument()
      Write whatever text should end a response.
      abstract void endElement(String name)
      Write the end of an element, after closing any open element created by a call to startElement().
      abstract void flush()
      Flush any ouput buffered by the output method to the underlying Writer or OutputStream.
      abstract String getCharacterEncoding()
      Return the character encoding (such as "ISO-8859-1") for this ResponseWriter.
      abstract String getContentType()
      Return the content type (such as "text/html") for this ResponseWriter.
      void startCDATA()

      Open an XML CDATA block.
      abstract void startDocument()
      Write whatever text should begin a response.
      abstract void startElement(String name, UIComponent component)
      Write the start of an element, up to and including the element name.
      abstract void writeAttribute(String name, Object value, String property)
      Write an attribute name and corresponding value, after converting that text to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.
      abstract void writeComment(Object comment)
      Write a comment containing the specified text, after converting that text to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.
      void writeDoctype(String doctype)

      Write a string containing the markup specific doctype.
      void writePreamble(String preamble)

      Write a string containing the markup specific preamble.
      abstract void writeText(char[] text, int off, int len)
      Write text from a character array, after any performing any escaping appropriate for the markup language being rendered.
      abstract void writeText(Object text, String property)
      Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.
      void writeText(Object text, UIComponent component, String property)
      Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.
      abstract void writeURIAttribute(String name, Object value, String property)
      Write a URI attribute name and corresponding value, after converting that text to a String (if necessary), and after performing any encoding or escaping appropriate to the markup language being rendered.

      • Methods inherited from class java.io.Writer

        append, append, append, close, write, write, write, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ResponseWriter

        public ResponseWriter()

    • Method Detail

      • getContentType

        public abstract String getContentType()

        Return the content type (such as "text/html") for this ResponseWriter. Note: this must not include the "charset=" suffix.

      • getCharacterEncoding

        public abstract String getCharacterEncoding()

        Return the character encoding (such as "ISO-8859-1") for this ResponseWriter. Please see the IANA for a list of character encodings.

      • flush

        public abstract void flush()
                    throws IOException

        Flush any ouput buffered by the output method to the underlying Writer or OutputStream. This method will not flush the underlying Writer or OutputStream; it simply clears any values buffered by this ResponseWriter.

        Specified by:
        flush in interface Flushable
        Specified by:
        flush in class Writer
        Throws:
        IOException

      • startDocument

        public abstract void startDocument()
                            throws IOException

        Write whatever text should begin a response.

        Throws:
        IOException - if an input/output error occurs

      • endDocument

        public abstract void endDocument()
                          throws IOException

        Write whatever text should end a response. If there is an open element that has been created by a call to startElement(), that element will be closed first.

        Throws:
        IOException - if an input/output error occurs

      • startElement

        public abstract void startElement(String name,
                UIComponent component)
                           throws IOException

        Write the start of an element, up to and including the element name. Once this method has been called, clients can call the writeAttribute() or writeURIAttribute() methods to add attributes and corresponding values. The starting element will be closed (that is, the trailing '>' character added) on any subsequent call to startElement(), writeComment(), writeText(), endElement(), endDocument(), close(), flush(), or write().

        If the argument component's pass through attributes includes an attribute of the name given by the value of the symbolic constant Renderer.PASSTHROUGH_RENDERER_LOCALNAME_KEY, use that as the element name, instead of the value passed as the first parameter to this method. Care must be taken so that this value is not also rendered when any other pass through attributes on this component are rendered.

        Parameters:
        name - Name of the element to be started
        component - The UIComponent (if any) to which this element corresponds. This component is inspected for its pass through attributes as described in the standard HTML_BASIC RenderKit specification.
        Throws:
        IOException - if an input/output error occurs
        NullPointerException - if name is null

      • endElement

        public abstract void endElement(String name)
                         throws IOException

        Write the end of an element, after closing any open element created by a call to startElement(). Elements must be closed in the inverse order from which they were opened; it is an error to do otherwise.

        If the argument component's pass through attributes includes an attribute of the name given by the value of the symbolic constant Renderer.PASSTHROUGH_RENDERER_LOCALNAME_KEY, use that as the element name, instead of the value passed as the first parameter to this method.

        Parameters:
        name - Name of the element to be ended
        Throws:
        IOException - if an input/output error occurs
        NullPointerException - if name is null

      • writeAttribute

        public abstract void writeAttribute(String name,
                  Object value,
                  String property)
                             throws IOException

        Write an attribute name and corresponding value, after converting that text to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered. This method may only be called after a call to startElement(), and before the opened element has been closed.

        Parameters:
        name - Attribute name to be added
        value - Attribute value to be added
        property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated attribute corresponds
        Throws:
        IllegalStateException - if this method is called when there is no currently open element
        IOException - if an input/output error occurs
        NullPointerException - if name is null

      • writeURIAttribute

        public abstract void writeURIAttribute(String name,
                     Object value,
                     String property)
                                throws IOException

        Write a URI attribute name and corresponding value, after converting that text to a String (if necessary), and after performing any encoding or escaping appropriate to the markup language being rendered. When rendering in a WWW environment, the escaping conventions established in the W3C URI spec document <http://www.w3.org/Addressing/URL/uri-spec.html> must be followed. In particular, spaces ' ' must be encoded as %20 and not the plus character '+'. This method may only be called after a call to startElement(), and before the opened element has been closed.

        Parameters:
        name - Attribute name to be added
        value - Attribute value to be added
        property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated attribute corresponds
        Throws:
        IllegalStateException - if this method is called when there is no currently open element
        IOException - if an input/output error occurs
        NullPointerException - if name is null

      • startCDATA

        public void startCDATA()
                throws IOException

        Open an XML CDATA block. Note that XML does not allow nested CDATA blocks, though this method does not enforce that constraint. The default implementation of this method takes no action when invoked.

        Throws:
        IOException - if input/output error occures

      • endCDATA

        public void endCDATA()
              throws IOException

        Close an XML CDATA block. The default implementation of this method takes no action when invoked.

        Throws:
        IOException - if input/output error occures

      • writeComment

        public abstract void writeComment(Object comment)
                           throws IOException

        Write a comment containing the specified text, after converting that text to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered. If there is an open element that has been created by a call to startElement(), that element will be closed first.

        Parameters:
        comment - Text content of the comment
        Throws:
        IOException - if an input/output error occurs
        NullPointerException - if comment is null

      • writePreamble

        public void writePreamble(String preamble)
                   throws IOException

        Write a string containing the markup specific preamble. No escaping is performed. The default implementation simply calls through to Writer.write(java.lang.String) .

        The implementation makes no checks if this is the correct place in the response to have a preamble, nor does it prevent the preamble from being written more than once.

        Parameters:
        preamble - Text content of the preamble
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.2

      • writeDoctype

        public void writeDoctype(String doctype)
                  throws IOException

        Write a string containing the markup specific doctype. No escaping is performed. The default implementation simply calls through to Writer.write(java.lang.String) .

        The implementation makes no checks if this is the correct place in the response to have a doctype, nor does it prevent the doctype from being written more than once.

        Parameters:
        doctype - Text content of the doctype
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.2

      • writeText

        public abstract void writeText(Object text,
             String property)
                        throws IOException

        Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered. If there is an open element that has been created by a call to startElement(), that element will be closed first.

        Parameters:
        text - Text to be written
        property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated text corresponds
        Throws:
        IOException - if an input/output error occurs
        NullPointerException - if text is null

      • writeText

        public void writeText(Object text,
             UIComponent component,
             String property)
               throws IOException

        Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered. This method is equivalent to writeText(java.lang.Object,java.lang.String) but adds a component property to allow custom ResponseWriter implementations to associate a component with an arbitrary portion of text.

        The default implementation simply ignores the component argument and calls through to writeText(java.lang.Object,java.lang.String)

        Parameters:
        text - Text to be written
        component - The UIComponent (if any) to which this element corresponds
        property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated text corresponds
        Throws:
        IOException - if an input/output error occurs
        NullPointerException - if text is null
        Since:
        1.2

      • writeText

        public abstract void writeText(char[] text,
             int off,
             int len)
                        throws IOException

        Write text from a character array, after any performing any escaping appropriate for the markup language being rendered. If there is an open element that has been created by a call to startElement(), that element will be closed first.

        Parameters:
        text - Text to be written
        off - Starting offset (zero-relative)
        len - Number of characters to be written
        Throws:
        IndexOutOfBoundsException - if the calculated starting or ending position is outside the bounds of the character array
        IOException - if an input/output error occurs
        NullPointerException - if text is null

      • cloneWithWriter

        public abstract ResponseWriter cloneWithWriter(Writer writer)

        Create and return a new instance of this ResponseWriter, using the specified Writer as the output destination.

        Parameters:
        writer - The Writer that is the output destination
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResponseWriterWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.context

Class ResponseWriterWrapper

  • java.lang.Object
    • java.io.Writer
      • javax.faces.context.ResponseWriter
        • javax.faces.context.ResponseWriterWrapper
  • All Implemented Interfaces:
    Closeable, Flushable, Appendable, AutoCloseable, FacesWrapper<ResponseWriter>
    Direct Known Subclasses:
    PartialResponseWriter

    public abstract class ResponseWriterWrapper
extends ResponseWriter
implements FacesWrapper<ResponseWriter>

    Provides a simple implementation of ResponseWriter that can be subclassed by developers wishing to provide specialized behavior to an existing ResponseWriter instance. The default implementation of all methods is to call through to the wrapped ResponseWriter.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    1.2

    • Field Summary

      • Fields inherited from class java.io.Writer

        lock

    • Constructor Summary

      Constructors
      Constructor and Description
      ResponseWriterWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ResponseWriter cloneWithWriter(Writer writer)
      The default behavior of this method is to call ResponseWriter.cloneWithWriter(java.io.Writer) on the wrapped ResponseWriter object.
      void close()
      The default behavior of this method is to call Writer.close() on the wrapped ResponseWriter object.
      void endCDATA()

      The default behavior of this method is to call ResponseWriter.endCDATA() on the wrapped ResponseWriter object.
      void endDocument()
      The default behavior of this method is to call ResponseWriter.endDocument() on the wrapped ResponseWriter object.
      void endElement(String name)
      The default behavior of this method is to call ResponseWriter.endElement(String) on the wrapped ResponseWriter object.
      void flush()
      The default behavior of this method is to call ResponseWriter.flush() on the wrapped ResponseWriter object.
      String getCharacterEncoding()
      The default behavior of this method is to call ResponseWriter.getCharacterEncoding() on the wrapped ResponseWriter object.
      String getContentType()
      The default behavior of this method is to call ResponseWriter.getContentType() on the wrapped ResponseWriter object.
      abstract ResponseWriter getWrapped()

      Return the instance that we are wrapping.
      void startCDATA()

      The default behavior of this method is to call ResponseWriter.startCDATA() on the wrapped ResponseWriter object.
      void startDocument()
      The default behavior of this method is to call ResponseWriter.startDocument() on the wrapped ResponseWriter object.
      void startElement(String name, UIComponent component)
      The default behavior of this method is to call ResponseWriter.startElement(String, javax.faces.component.UIComponent) on the wrapped ResponseWriter object.
      void write(char[] cbuf, int off, int len)
      The default behavior of this method is to call Writer.write(char[], int, int) on the wrapped ResponseWriter object.
      void writeAttribute(String name, Object value, String property)
      The default behavior of this method is to call ResponseWriter.writeAttribute(String, Object, String) on the wrapped ResponseWriter object.
      void writeComment(Object comment)
      The default behavior of this method is to call ResponseWriter.writeComment(Object) on the wrapped ResponseWriter object.
      void writeDoctype(String doctype)
      The default behavior of this method is to call ResponseWriter.writeDoctype(java.lang.String) on the wrapped ResponseWriter object.
      void writePreamble(String preamble)
      The default behavior of this method is to call ResponseWriter.writePreamble(java.lang.String) on the wrapped ResponseWriter object.
      void writeText(char[] text, int off, int len)
      The default behavior of this method is to call ResponseWriter.writeText(char[], int, int) on the wrapped ResponseWriter object.
      void writeText(Object text, String property)
      The default behavior of this method is to call ResponseWriter.writeText(Object, String) on the wrapped ResponseWriter object.
      void writeText(Object text, UIComponent component, String property)
      The default behavior of this method is to call ResponseWriter.writeText(Object, UIComponent, String) on the wrapped ResponseWriter object.
      void writeURIAttribute(String name, Object value, String property)
      The default behavior of this method is to call ResponseWriter.writeURIAttribute(String, Object, String) on the wrapped ResponseWriter object.

      • Methods inherited from class java.io.Writer

        append, append, append, write, write, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ResponseWriterWrapper

        public ResponseWriterWrapper()

    • Method Detail

      • getWrapped

        public abstract ResponseWriter getWrapped()

        Return the instance that we are wrapping. As of version 2, this method is public.

        Specified by:
        getWrapped in interface FacesWrapper<ResponseWriter>

      • getContentType

        public String getContentType()

        The default behavior of this method is to call ResponseWriter.getContentType() on the wrapped ResponseWriter object.

        Specified by:
        getContentType in class ResponseWriter
        Since:
        1.2
        See Also:
        ResponseWriter.getContentType()

      • getCharacterEncoding

        public String getCharacterEncoding()

        The default behavior of this method is to call ResponseWriter.getCharacterEncoding() on the wrapped ResponseWriter object.

        Specified by:
        getCharacterEncoding in class ResponseWriter
        Since:
        1.2
        See Also:
        ResponseWriter.getCharacterEncoding()

      • flush

        public void flush()
           throws IOException

        The default behavior of this method is to call ResponseWriter.flush() on the wrapped ResponseWriter object.

        Specified by:
        flush in interface Flushable
        Specified by:
        flush in class ResponseWriter
        Throws:
        IOException
        Since:
        1.2
        See Also:
        ResponseWriter.flush()

      • startDocument

        public void startDocument()
                   throws IOException

        The default behavior of this method is to call ResponseWriter.startDocument() on the wrapped ResponseWriter object.

        Specified by:
        startDocument in class ResponseWriter
        Throws:
        IOException - if an input/output error occurs
        Since:
        1.2
        See Also:
        ResponseWriter.startDocument()

      • endDocument

        public void endDocument()
                 throws IOException

        The default behavior of this method is to call ResponseWriter.endDocument() on the wrapped ResponseWriter object.

        Specified by:
        endDocument in class ResponseWriter
        Throws:
        IOException - if an input/output error occurs
        Since:
        1.2
        See Also:
        ResponseWriter.endDocument()

      • startElement

        public void startElement(String name,
                UIComponent component)
                  throws IOException

        The default behavior of this method is to call ResponseWriter.startElement(String, javax.faces.component.UIComponent) on the wrapped ResponseWriter object.

        Specified by:
        startElement in class ResponseWriter
        Parameters:
        name - Name of the element to be started
        component - The UIComponent (if any) to which this element corresponds. This component is inspected for its pass through attributes as described in the standard HTML_BASIC RenderKit specification.
        Throws:
        IOException - if an input/output error occurs
        Since:
        1.2
        See Also:
        ResponseWriter.startElement(String, javax.faces.component.UIComponent)

      • startCDATA

        public void startCDATA()
                throws IOException

        The default behavior of this method is to call ResponseWriter.startCDATA() on the wrapped ResponseWriter object.

        Overrides:
        startCDATA in class ResponseWriter
        Throws:
        IOException - on any read/write error
        Since:
        2.0

      • endCDATA

        public void endCDATA()
              throws IOException

        The default behavior of this method is to call ResponseWriter.endCDATA() on the wrapped ResponseWriter object.

        Overrides:
        endCDATA in class ResponseWriter
        Throws:
        IOException - on any read/write error
        Since:
        2.0

      • endElement

        public void endElement(String name)
                throws IOException

        The default behavior of this method is to call ResponseWriter.endElement(String) on the wrapped ResponseWriter object.

        Specified by:
        endElement in class ResponseWriter
        Parameters:
        name - Name of the element to be ended
        Throws:
        IOException - on any read/write error
        Since:
        1.2
        See Also:
        ResponseWriter.endElement(String)

      • writeAttribute

        public void writeAttribute(String name,
                  Object value,
                  String property)
                    throws IOException

        The default behavior of this method is to call ResponseWriter.writeAttribute(String, Object, String) on the wrapped ResponseWriter object.

        Specified by:
        writeAttribute in class ResponseWriter
        Parameters:
        name - Attribute name to be added
        value - Attribute value to be added
        property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated attribute corresponds
        Throws:
        IOException - if an input/output error occurs
        Since:
        1.2
        See Also:
        ResponseWriter.writeAttribute(String, Object, String)

      • writeURIAttribute

        public void writeURIAttribute(String name,
                     Object value,
                     String property)
                       throws IOException

        The default behavior of this method is to call ResponseWriter.writeURIAttribute(String, Object, String) on the wrapped ResponseWriter object.

        Specified by:
        writeURIAttribute in class ResponseWriter
        Parameters:
        name - Attribute name to be added
        value - Attribute value to be added
        property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated attribute corresponds
        Throws:
        IOException - if an input/output error occurs
        Since:
        1.2
        See Also:
        ResponseWriter.writeURIAttribute(String, Object, String)

      • writeComment

        public void writeComment(Object comment)
                  throws IOException

        The default behavior of this method is to call ResponseWriter.writeComment(Object) on the wrapped ResponseWriter object.

        Specified by:
        writeComment in class ResponseWriter
        Parameters:
        comment - Text content of the comment
        Throws:
        IOException - if an input/output error occurs
        Since:
        1.2
        See Also:
        ResponseWriter.writeComment(Object)

      • writeDoctype

        public void writeDoctype(String doctype)
                  throws IOException

        The default behavior of this method is to call ResponseWriter.writeDoctype(java.lang.String) on the wrapped ResponseWriter object.

        Overrides:
        writeDoctype in class ResponseWriter
        Parameters:
        doctype - Text content of the doctype
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.2
        See Also:
        ResponseWriter.writeDoctype(java.lang.String)

      • writePreamble

        public void writePreamble(String preamble)
                   throws IOException

        The default behavior of this method is to call ResponseWriter.writePreamble(java.lang.String) on the wrapped ResponseWriter object.

        Overrides:
        writePreamble in class ResponseWriter
        Parameters:
        preamble - Text content of the preamble
        Throws:
        IOException - if an input/output error occurs
        Since:
        2.2
        See Also:
        ResponseWriter.writePreamble(java.lang.String)

      • writeText

        public void writeText(Object text,
             String property)
               throws IOException

        The default behavior of this method is to call ResponseWriter.writeText(Object, String) on the wrapped ResponseWriter object.

        Specified by:
        writeText in class ResponseWriter
        Parameters:
        text - Text to be written
        property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated text corresponds
        Throws:
        IOException - if an input/output error occurs
        Since:
        1.2
        See Also:
        ResponseWriter.writeText(Object, String)

      • writeText

        public void writeText(Object text,
             UIComponent component,
             String property)
               throws IOException

        The default behavior of this method is to call ResponseWriter.writeText(Object, UIComponent, String) on the wrapped ResponseWriter object.

        Overrides:
        writeText in class ResponseWriter
        Parameters:
        text - Text to be written
        component - The UIComponent (if any) to which this element corresponds
        property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated text corresponds
        Throws:
        IOException - if an input/output error occurs
        Since:
        1.2
        See Also:
        ResponseWriter.writeText(Object, String)

      • writeText

        public void writeText(char[] text,
             int off,
             int len)
               throws IOException

        The default behavior of this method is to call ResponseWriter.writeText(char[], int, int) on the wrapped ResponseWriter object.

        Specified by:
        writeText in class ResponseWriter
        Parameters:
        text - Text to be written
        off - Starting offset (zero-relative)
        len - Number of characters to be written
        Throws:
        IOException - if an input/output error occurs
        Since:
        1.2
        See Also:
        ResponseWriter.writeText(char[], int, int)

      • cloneWithWriter

        public ResponseWriter cloneWithWriter(Writer writer)

        The default behavior of this method is to call ResponseWriter.cloneWithWriter(java.io.Writer) on the wrapped ResponseWriter object.

        Specified by:
        cloneWithWriter in class ResponseWriter
        Parameters:
        writer - The Writer that is the output destination
        Since:
        1.2
        See Also:
        ResponseWriter.cloneWithWriter(java.io.Writer)

      • close

        public void close()
           throws IOException

        The default behavior of this method is to call Writer.close() on the wrapped ResponseWriter object.

        Specified by:
        close in interface Closeable
        Specified by:
        close in interface AutoCloseable
        Specified by:
        close in class Writer
        Throws:
        IOException
        Since:
        1.2
        See Also:
        Writer.close()

      • write

        public void write(char[] cbuf,
         int off,
         int len)
           throws IOException

        The default behavior of this method is to call Writer.write(char[], int, int) on the wrapped ResponseWriter object.

        Specified by:
        write in class Writer
        Throws:
        IOException
        Since:
        1.2
        See Also:
        Writer.write(char[], int, int)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.context (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.context

  • Packages that use javax.faces.context
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.component.visit

    APIs for traversing a user interface component view.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.el
    DEPRECATED Classes and interfaces for evaluating and processing reference expressions.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.
    javax.faces.render
    Classes and interfaces defining the rendering model.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
  • Classes in javax.faces.context used by javax.faces.application
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.component
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.component.behavior
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.component.visit
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.context
    Class and Description
    ExceptionHandler

    ExceptionHandler is the central point for handling unexpected Exceptions that are thrown during the Faces lifecycle.
    ExceptionHandlerFactory

    ExceptionHandlerFactory is a factory object that creates (if needed) and returns a new ExceptionHandler instance.
    ExternalContext
    This class allows the Faces API to be unaware of the nature of its containing application environment.
    ExternalContextFactory
    ExternalContextFactory is a factory object that creates (if needed) and returns new ExternalContext instances, initialized for the processing of the specified request and response objects.
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
    FacesContextFactory
    FacesContextFactory is a factory object that creates (if needed) and returns new FacesContext instances, initialized for the processing of the specified request and response objects.
    Flash

    The Flash concept is taken from Ruby on Rails and provides a way to pass temporary objects between the user views generated by the faces lifecycle.
    FlashFactory
    FlashFactory is a factory object that creates (if needed) and returns Flash instances.
    PartialResponseWriter

    PartialResponseWriter decorates an existing ResponseWriter to support the generation of a partial response suitable for Ajax operations.
    PartialViewContext
    PartialViewContext contains methods and properties that pertain to partial request processing and partial response rendering on a view.
    PartialViewContextFactory

    PartialViewContextFactory is a factory object that creates (if needed) and returns new PartialViewContext instances.
    ResponseStream
    ResponseStream is an interface describing an adapter to an underlying output mechanism for binary output.
    ResponseWriter
    ResponseWriter is an abstract class describing an adapter to an underlying output mechanism for character-based output.
    ResponseWriterWrapper
    Provides a simple implementation of ResponseWriter that can be subclassed by developers wishing to provide specialized behavior to an existing ResponseWriter instance.
  • Classes in javax.faces.context used by javax.faces.convert
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.el
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.event
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.flow
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.lifecycle
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.render
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
    ResponseStream
    ResponseStream is an interface describing an adapter to an underlying output mechanism for binary output.
    ResponseWriter
    ResponseWriter is an abstract class describing an adapter to an underlying output mechanism for character-based output.
  • Classes in javax.faces.context used by javax.faces.validator
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.view
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.view.facelets
    Class and Description
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Classes in javax.faces.context used by javax.faces.webapp
    Class and Description
    ExceptionHandler

    ExceptionHandler is the central point for handling unexpected Exceptions that are thrown during the Faces lifecycle.
    ExceptionHandlerFactory

    ExceptionHandlerFactory is a factory object that creates (if needed) and returns a new ExceptionHandler instance.
    FacesContext
    FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.ExceptionHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.ExceptionHandler

  • Packages that use ExceptionHandler
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of ExceptionHandler in javax.faces.context

      Subclasses of ExceptionHandler in javax.faces.context
      Modifier and Type Class and Description
      class  ExceptionHandlerWrapper
      Provides a simple implementation of ExceptionHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ExceptionHandler instance.
      Methods in javax.faces.context that return ExceptionHandler
      Modifier and Type | Method and Description
      ExceptionHandler FacesContextWrapper.getExceptionHandler()
      The default behavior of this method is to call FacesContext.getExceptionHandler() on the wrapped FacesContext object.
      ExceptionHandler FacesContext.getExceptionHandler()

      Return the ExceptionHandler for this request.
      abstract ExceptionHandler ExceptionHandlerFactory.getExceptionHandler()

      Create and return a A new ExceptionHandler instance.
      abstract ExceptionHandler | ExceptionHandlerWrapper.getWrapped()
      Methods in javax.faces.context with parameters of type ExceptionHandler
      Modifier and Type Method and Description
      void FacesContextWrapper.setExceptionHandler(ExceptionHandler exceptionHandler)
      The default behavior of this method is to call FacesContext.setExceptionHandler(ExceptionHandler) on the wrapped FacesContext object.
      void FacesContext.setExceptionHandler(ExceptionHandler exceptionHandler)

      Set the ExceptionHandler for this request.

    • Uses of ExceptionHandler in javax.faces.webapp

      Methods in javax.faces.webapp that return ExceptionHandler
      Modifier and Type | Method and Description
      ExceptionHandler | PreJsf2ExceptionHandlerFactory.getExceptionHandler()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.ExceptionHandlerFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.ExceptionHandlerFactory

  • Packages that use ExceptionHandlerFactory
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of ExceptionHandlerFactory in javax.faces.context

      Methods in javax.faces.context that return ExceptionHandlerFactory
      Modifier and Type Method and Description
      ExceptionHandlerFactory ExceptionHandlerFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

    • Uses of ExceptionHandlerFactory in javax.faces.webapp

      Subclasses of ExceptionHandlerFactory in javax.faces.webapp
      Modifier and Type Class and Description
      class  PreJsf2ExceptionHandlerFactory

      This ExceptionHandlerFactory instance produces JSF 1.2 compatible ExceptionHandler instances.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.ExceptionHandlerWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.ExceptionHandlerWrapper

No usage of javax.faces.context.ExceptionHandlerWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.ExternalContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.ExternalContext

  • Packages that use ExternalContext
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of ExternalContext in javax.faces.context

      Subclasses of ExternalContext in javax.faces.context
      Modifier and Type Class and Description
      class  ExternalContextWrapper

      Provides a simple implementation of ExternalContext that can be subclassed by developers wishing to provide specialized behavior to an existing ExternalContext instance.
      Methods in javax.faces.context that return ExternalContext
      Modifier and Type | Method and Description
      ExternalContext FacesContextWrapper.getExternalContext()
      The default behavior of this method is to call FacesContext.getExternalContext() on the wrapped FacesContext object.
      abstract ExternalContext FacesContext.getExternalContext()
      Return the ExternalContext instance for this FacesContext instance.
      abstract ExternalContext ExternalContextFactory.getExternalContext(Object context, Object request, Object response)
      Create (if needed) and return an ExternalContext instance that is initialized for the processing of the specified request and response objects, for this web application.
      abstract ExternalContext | ExternalContextWrapper.getWrapped()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.ExternalContextFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.ExternalContextFactory

  • Packages that use ExternalContextFactory
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of ExternalContextFactory in javax.faces.context

      Methods in javax.faces.context that return ExternalContextFactory
      Modifier and Type Method and Description
      ExternalContextFactory ExternalContextFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.ExternalContextWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.ExternalContextWrapper

No usage of javax.faces.context.ExternalContextWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.FacesContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.FacesContext

  • Packages that use FacesContext
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.component.visit

    APIs for traversing a user interface component view.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.el
    DEPRECATED Classes and interfaces for evaluating and processing reference expressions.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.
    javax.faces.render
    Classes and interfaces defining the rendering model.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of FacesContext in javax.faces.application

      Methods in javax.faces.application with parameters of type FacesContext
      Modifier and Type | Method and Description
      String ViewHandlerWrapper.calculateCharacterEncoding(FacesContext context)
      The default behavior of this method is to call ViewHandler.calculateCharacterEncoding(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
      String ViewHandler.calculateCharacterEncoding(FacesContext context)
      Returns the correct character encoding to be used for this request.
      Locale ViewHandlerWrapper.calculateLocale(FacesContext context)
      The default behavior of this method is to call ViewHandler.calculateLocale(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
      abstract Locale ViewHandler.calculateLocale(FacesContext context)
      Returns an appropriate Locale to use for this and subsequent requests for the current client.
      String ViewHandlerWrapper.calculateRenderKitId(FacesContext context)
      The default behavior of this method is to call ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
      abstract String ViewHandler.calculateRenderKitId(FacesContext context)
      Return an appropriate renderKitId for this and subsequent requests from the current client.
      UIComponent ApplicationWrapper.createComponent(FacesContext context, Resource componentResource)

      The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, Resource) on the wrapped Application object.
      UIComponent Application.createComponent(FacesContext context, Resource componentResource)

      Instantiate and return a new UIComponent instance from the argument Resource.
      UIComponent ApplicationWrapper.createComponent(FacesContext context, String componentType, String rendererType)

      The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, String, String) on the wrapped Application object.
      UIComponent Application.createComponent(FacesContext context, String componentType, String rendererType)

      Like Application.createComponent(String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in Application.createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method.
      UIComponent ApplicationWrapper.createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
      Deprecated.
      See superclass for alternative.
      abstract UIComponent Application.createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
      Deprecated.
      This has been replaced by Application.createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).
      UIComponent ApplicationWrapper.createComponent(ValueExpression componentExpression, FacesContext context, String componentType)

      The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String) on the wrapped Application object.
      UIComponent Application.createComponent(ValueExpression componentExpression, FacesContext context, String componentType)
      Call the getValue() method on the specified ValueExpression.
      UIComponent ApplicationWrapper.createComponent(ValueExpression componentExpression, FacesContext context, String componentType, String rendererType)

      The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String, String) on the wrapped Application object.
      UIComponent Application.createComponent(ValueExpression componentExpression, FacesContext context, String componentType, String rendererType)

      Like Application.createComponent(ValueExpression, FacesContext, String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in Application.createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method.
      UIViewRoot ViewHandlerWrapper.createView(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.createView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      abstract UIViewRoot ViewHandler.createView(FacesContext context, String viewId)
      Create and return a new UIViewRoot instance initialized with information from the argument FacesContext and viewId.
      ViewResource ResourceHandlerWrapper.createViewResource(FacesContext context, String resourceName)

      The default behavior of this method is to call ResourceHandler.createViewResource(javax.faces.context.FacesContext, java.lang.String) on the wrapped ResourceHandler object.
      ViewResource ResourceHandler.createViewResource(FacesContext context, String resourceName)

      Create an instance of Resource given the argument resourceName, which may contain "/" characters.
      String ViewHandlerWrapper.deriveLogicalViewId(FacesContext context, String input)

      The default behavior of this method is to call ViewHandler.deriveLogicalViewId(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      String ViewHandler.deriveLogicalViewId(FacesContext context, String rawViewId)

      Derive and return the viewId from the current request, or the argument input by following the algorithm defined in specification section JSF.7.6.2.
      String ViewHandlerWrapper.deriveViewId(FacesContext context, String input)
      The default behavior of this method is to call ViewHandler.deriveViewId(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      String ViewHandler.deriveViewId(FacesContext context, String rawViewId)

      Derive and return the viewId from the current request, or the argument input by following the algorithm defined in specification section JSF.7.6.2.
      <T> T ApplicationWrapper.evaluateExpressionGet(FacesContext context, String expression, Class<? extends T> expectedType)
      Deprecated.
      See superclass for alternative.
      <T> T Application.evaluateExpressionGet(FacesContext context, String expression, Class<? extends T> expectedType)
      Get a value by evaluating an expression.
      URL | NavigationCaseWrapper.getActionURL(FacesContext context)
      URL NavigationCase.getActionURL(FacesContext context)

      Construct an absolute URL to this NavigationCase instance using ViewHandler.getActionURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.
      String ViewHandlerWrapper.getActionURL(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.getActionURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      abstract String ViewHandler.getActionURL(FacesContext context, String viewId)

      If the value returned from this method is used as the file argument to the four-argument constructor for java.net.URL (assuming appropriate values are used for the first three arguments), then a client making a request to the toExternalForm() of that URL will select the argument viewId for traversing the JSF lifecycle.
      URL | NavigationCaseWrapper.getBookmarkableURL(FacesContext context)
      URL NavigationCase.getBookmarkableURL(FacesContext context)

      Construct an absolute URL suitable for a bookmarkable link to this NavigationCase instance using ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url.
      String ViewHandlerWrapper.getBookmarkableURL(FacesContext context, String viewId, Map<String,List<String>> parameters, boolean includeViewParams)
      The default behavior of this method is to call ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, String, java.util.Map, boolean) on the wrapped ViewHandler object.
      String ViewHandler.getBookmarkableURL(FacesContext context, String viewId, Map<String,List<String>> parameters, boolean includeViewParams)

      Return a JSF action URL derived from the viewId argument that is suitable to be used as the target of a link in a JSF response.
      protected Object StateManagerWrapper.getComponentStateToSave(FacesContext context)
      The default behavior of this method is to call StateManager.getComponentStateToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.
      protected Object StateManager.getComponentStateToSave(FacesContext context)
      Deprecated.
      the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
      Boolean | NavigationCaseWrapper.getCondition(FacesContext context)
      Boolean NavigationCase.getCondition(FacesContext context)

      Evaluates the <if> for this <navigation-case>, if any.
      NavigationCase | ConfigurableNavigationHandlerWrapper.getNavigationCase(FacesContext context, String fromAction, String outcome)
      abstract NavigationCase ConfigurableNavigationHandler.getNavigationCase(FacesContext context, String fromAction, String outcome)

      Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.
      NavigationCase | ConfigurableNavigationHandlerWrapper.getNavigationCase(FacesContext context, String fromAction, String outcome, String toFlowDocumentId)
      NavigationCase ConfigurableNavigationHandler.getNavigationCase(FacesContext context, String fromAction, String outcome, String toFlowDocumentId)

      Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.
      URL | NavigationCaseWrapper.getRedirectURL(FacesContext context)
      URL NavigationCase.getRedirectURL(FacesContext context)

      Construct an absolute URL suitable for a "redirect" to this NavigationCase instance using ViewHandler.getRedirectURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url.
      String ViewHandlerWrapper.getRedirectURL(FacesContext context, String viewId, Map<String,List<String>> parameters, boolean includeViewParams)
      The default behavior of this method is to call ViewHandler.getRedirectURL(javax.faces.context.FacesContext, String, java.util.Map, boolean) on the wrapped ViewHandler object.
      String ViewHandler.getRedirectURL(FacesContext context, String viewId, Map<String,List<String>> parameters, boolean includeViewParams)

      Return a JSF action URL derived from the viewId argument that is suitable to be used by the NavigationHandler to issue a redirect request to the URL using a NonFaces request.
      ResourceBundle ApplicationWrapper.getResourceBundle(FacesContext ctx, String name)

      The default behavior of this method is to call Application.getResourceBundle(javax.faces.context.FacesContext, String) on the wrapped Application object.
      ResourceBundle Application.getResourceBundle(FacesContext ctx, String name)
      Find a ResourceBundle as defined in the application configuration resources under the specified name.
      URL | NavigationCaseWrapper.getResourceURL(FacesContext context)
      URL NavigationCase.getResourceURL(FacesContext context)

      Construct an absolute URL to this NavigationCase instance using ViewHandler.getResourceURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.
      String ViewHandlerWrapper.getResourceURL(FacesContext context, String path)
      The default behavior of this method is to call ViewHandler.getResourceURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      abstract String ViewHandler.getResourceURL(FacesContext context, String path)

      If the value returned from this method is used as the file argument to the four-argument constructor for java.net.URL (assuming appropriate values are used for the first three arguments), then a client making a request to the toExternalForm() of that URL will select the argument path for direct rendering.
      String | NavigationCaseWrapper.getToViewId(FacesContext context)
      String NavigationCase.getToViewId(FacesContext context)

      Evaluates the <to-view-id> for this <navigation-case>
      protected Object StateManagerWrapper.getTreeStructureToSave(FacesContext context)
      The default behavior of this method is to call StateManager.getTreeStructureToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.
      protected Object StateManager.getTreeStructureToSave(FacesContext context)
      Deprecated.
      the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
      ViewDeclarationLanguage ViewHandlerWrapper.getViewDeclarationLanguage(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.getViewDeclarationLanguage(javax.faces.context.FacesContext, java.lang.String) on the wrapped ViewHandler object.
      ViewDeclarationLanguage ViewHandler.getViewDeclarationLanguage(FacesContext context, String viewId)

      Return the ViewDeclarationLanguage instance used for this ViewHandler instance.
      String StateManagerWrapper.getViewState(FacesContext context)

      The default behavior of this method is to call StateManager.getViewState(javax.faces.context.FacesContext) on the wrapped StateManager object.
      String StateManager.getViewState(FacesContext context)

      Convenience method to return the view state as a String with no RenderKit specific markup.
      void | NavigationHandlerWrapper.handleNavigation(FacesContext context, String fromAction, String outcome)
      abstract void NavigationHandler.handleNavigation(FacesContext context, String fromAction, String outcome)
      Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.
      void | ConfigurableNavigationHandlerWrapper.handleNavigation(FacesContext context, String fromAction, String outcome)
      void | NavigationHandlerWrapper.handleNavigation(FacesContext context, String fromAction, String outcome, String toFlowDocumentId)
      void NavigationHandler.handleNavigation(FacesContext context, String fromAction, String outcome, String toFlowDocumentId)

      Overloaded variant of NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) that allows the caller to provide the defining document id for a flow to be entered by this navigation.
      void ResourceHandlerWrapper.handleResourceRequest(FacesContext context)

      The default behavior of this method is to call ResourceHandler.handleResourceRequest(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.
      abstract void ResourceHandler.handleResourceRequest(FacesContext context)

      This method specifies the contract for satisfying resource requests.
      void ViewHandlerWrapper.initView(FacesContext context)
      The default behavior of this method is to call ViewHandler.initView(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
      void ViewHandler.initView(FacesContext context)
      Initialize the view for the request processing lifecycle.
      void | ConfigurableNavigationHandlerWrapper.inspectFlow(FacesContext context, Flow flow)
      void ConfigurableNavigationHandler.inspectFlow(FacesContext context, Flow flow)

      Called by the flow system to cause the flow to be inspected for navigation rules.
      boolean ResourceHandlerWrapper.isResourceRequest(FacesContext context)

      The default behavior of this method is to call ResourceHandler.isResourceRequest(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.
      abstract boolean ResourceHandler.isResourceRequest(FacesContext context)

      Return true if the current request is a resource request.
      boolean StateManagerWrapper.isSavingStateInClient(FacesContext context)
      The default behavior of this method is to call StateManager.isSavingStateInClient(javax.faces.context.FacesContext) on the wrapped StateManager object.
      boolean | StateManager.isSavingStateInClient(FacesContext context)
      void ApplicationWrapper.publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Class<?> sourceBaseType, Object source)

      The default behavior of this method is to call Application.publishEvent(javax.faces.context.FacesContext, Class, Class, Object) on the wrapped Application object.
      void Application.publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Class<?> sourceBaseType, Object source)

      This method functions exactly like Application.publishEvent(FacesContext,Class,Object), except the run-time must use the argument sourceBaseType to find the matching listener instead of using the Class of the source argument.
      void ApplicationWrapper.publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Object source)

      The default behavior of this method is to call Application.publishEvent(javax.faces.context.FacesContext, Class, Object) on the wrapped Application object.
      void Application.publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Object source)

      If isProcessingEvents() is true and there are one or more listeners for events of the type represented by systemEventClass, call those listeners, passing source as the source of the event.
      void ViewHandlerWrapper.renderView(FacesContext context, UIViewRoot viewToRender)
      The default behavior of this method is to call ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) on the wrapped ViewHandler object.
      abstract void ViewHandler.renderView(FacesContext context, UIViewRoot viewToRender)
      Perform whatever actions are required to render the response view to the response object associated with the current FacesContext.
      protected void StateManagerWrapper.restoreComponentState(FacesContext context, UIViewRoot viewRoot, String renderKitId)
      The default behavior of this method is to call StateManager.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, String) on the wrapped StateManager object.
      protected void StateManager.restoreComponentState(FacesContext context, UIViewRoot viewRoot, String renderKitId)
      Deprecated.
      the distinction between tree structure and component state is now an implementation detail. The default implementation does nothing.
      protected UIViewRoot StateManagerWrapper.restoreTreeStructure(FacesContext context, String viewId, String renderKitId)
      The default behavior of this method is to call StateManager.restoreTreeStructure(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.
      protected UIViewRoot StateManager.restoreTreeStructure(FacesContext context, String viewId, String renderKitId)
      Deprecated.
      the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
      UIViewRoot ViewHandlerWrapper.restoreView(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.restoreView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
      abstract UIViewRoot ViewHandler.restoreView(FacesContext context, String viewId)
      Perform whatever actions are required to restore the view associated with the specified FacesContext and viewId.
      UIViewRoot StateManagerWrapper.restoreView(FacesContext context, String viewId, String renderKitId)
      The default behavior of this method is to call StateManager.restoreView(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.
      abstract UIViewRoot StateManager.restoreView(FacesContext context, String viewId, String renderKitId)
      Deprecated.
      StateManager.SerializedView StateManagerWrapper.saveSerializedView(FacesContext context)
      The default behavior of this method is to call StateManager.saveSerializedView(javax.faces.context.FacesContext) on the wrapped StateManager object.
      StateManager.SerializedView StateManager.saveSerializedView(FacesContext context)
      Deprecated.
      this has been replaced by StateManager.saveView(javax.faces.context.FacesContext). The default implementation calls saveView and inspects the return. If the return is an Object [], it casts the result to an Object [] wrapping the first and second elements in an instance of StateManager.SerializedView, which it then returns. Otherwise, it returns null
      Object StateManagerWrapper.saveView(FacesContext context)
      The default behavior of this method is to call StateManager.saveView(javax.faces.context.FacesContext) on the wrapped StateManager object.
      Object StateManager.saveView(FacesContext context)
      Deprecated.
      boolean ResourceWrapper.userAgentNeedsUpdate(FacesContext context)

      The default behavior of this method is to call Resource.userAgentNeedsUpdate(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.
      abstract boolean Resource.userAgentNeedsUpdate(FacesContext context)

      Return true if the user-agent requesting this resource needs an update.
      void ViewHandlerWrapper.writeState(FacesContext context)
      The default behavior of this method is to call ViewHandler.writeState(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
      abstract void ViewHandler.writeState(FacesContext context)
      Take any appropriate action to either immediately write out the current state information (by calling StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object), or noting where state information should later be written.
      void StateManagerWrapper.writeState(FacesContext context, Object state)
      The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object) on the wrapped StateManager object.
      void StateManager.writeState(FacesContext context, Object state)
      Save the state represented in the specified state Object instance, in an implementation dependent manner.
      void StateManagerWrapper.writeState(FacesContext context, StateManager.SerializedView state)
      The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView) on the wrapped StateManager object.
      void StateManager.writeState(FacesContext context, StateManager.SerializedView state)
      Deprecated.
      This method has been replaced by StateManager.writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation calls the non-deprecated variant of the method passing an Object [] as the second argument, where the first element of the array is the return from getStructure() and the second is the return from getState() on the argument state.

    • Uses of FacesContext in javax.faces.component

      Methods in javax.faces.component that return FacesContext
      Modifier and Type | Method and Description
      protected FacesContext | UIComponentBase.getFacesContext()
      protected abstract FacesContext UIComponent.getFacesContext()
      Convenience method to return the FacesContext instance for the current request.
      Methods in javax.faces.component with parameters of type FacesContext
      Modifier and Type | Method and Description
      void UIViewRoot.addComponentResource(FacesContext context, UIComponent componentResource)

      Add argument component, which is assumed to represent a resource instance, as a resource to this view.
      void UIViewRoot.addComponentResource(FacesContext context, UIComponent componentResource, String target)

      Add argument component, which is assumed to represent a resource instance, as a resource to this view.
      void UIViewRoot.broadcastEvents(FacesContext context, PhaseId phaseId)

      Broadcast any events that have been queued.
      String UniqueIdVendor.createUniqueId(FacesContext context, String seed)
      Generate an identifier for a component.
      String UIViewRoot.createUniqueId(FacesContext context, String seed)
      Generate an identifier for a component.
      String | UINamingContainer.createUniqueId(FacesContext context, String seed)
      String UIForm.createUniqueId(FacesContext context, String seed)

      Generate an identifier for a component.
      String | UIData.createUniqueId(FacesContext context, String seed)
      void UIViewParameter.decode(FacesContext context)

      Override behavior from superclass to pull a value from the incoming request parameter map under the name given by UIViewParameter.getName() and store it with a call to UIInput.setSubmittedValue(java.lang.Object).
      void UIViewAction.decode(FacesContext context)

      Override behavior from the superclass to queue an ActionEvent that may result in the invocation of the action or any actionListeners that may be associated with this instance.
      void | UIInput.decode(FacesContext context)
      void | UIComponentBase.decode(FacesContext context)
      abstract void UIComponent.decode(FacesContext context)
      Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.
      void UIViewParameter.encodeAll(FacesContext context)

      Called specially by UIViewRoot.encodeEnd(javax.faces.context.FacesContext), this method simply sets the submitted value to be the return from UIViewParameter.getStringValue(javax.faces.context.FacesContext).
      void UIComponent.encodeAll(FacesContext context)
      If this component returns true from UIComponent.isRendered(), take the following action.
      void UIViewRoot.encodeBegin(FacesContext context)
      Override the default UIComponentBase.encodeBegin(javax.faces.context.FacesContext) behavior.
      void UIData.encodeBegin(FacesContext context)
      In addition to the default behavior, ensure that any saved per-row state for our child input components is discarded unless it is needed to rerender the current page with errors.
      void | UIComponentBase.encodeBegin(FacesContext context)
      abstract void UIComponent.encodeBegin(FacesContext context)
      If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext.
      void UIViewRoot.encodeChildren(FacesContext context)

      If PartialViewContext.isAjaxRequest() returns true, perform partial rendering by calling PartialViewContext.processPartial(javax.faces.event.PhaseId) with PhaseId.RENDER_RESPONSE.
      void | UIComponentBase.encodeChildren(FacesContext context)
      abstract void UIComponent.encodeChildren(FacesContext context)
      If our rendered property is true, render the child UIComponents of this UIComponent.
      void UIViewRoot.encodeEnd(FacesContext context)

      If UIViewRoot.getAfterPhaseListener() returns non-null, invoke it, passing a PhaseEvent for the PhaseId.RENDER_RESPONSE phase.
      void | UIComponentBase.encodeEnd(FacesContext context)
      abstract void UIComponent.encodeEnd(FacesContext context)
      If our rendered property is true, render the ending of the current state of this UIComponent.
      String UIData.getClientId(FacesContext context)
      Return a client identifier for this component that includes the current value of the rowIndex property, if it is not set to -1.
      String | UIComponentBase.getClientId(FacesContext context)
      abstract String UIComponent.getClientId(FacesContext context)
      Return a client-side identifier for this component, generating one if necessary.
      List<UIComponent> UIViewRoot.getComponentResources(FacesContext context, String target)

      Return an unmodifiable List of UIComponents for the provided target agrument.
      String UIForm.getContainerClientId(FacesContext context)
      Override the UIComponent.getContainerClientId(javax.faces.context.FacesContext) to allow users to disable this form from prepending its clientId to its descendent's clientIds depending on the value of this form's UIForm.isPrependId() property.
      String UIComponent.getContainerClientId(FacesContext context)
      Allow components that implement NamingContainer to selectively disable prepending their clientId to their descendent's clientIds by breaking the prepending logic into a seperately callable method.
      protected Object UIViewParameter.getConvertedValue(FacesContext context, Object submittedValue)

      Because this class has no Renderer, leverage the one from the standard HTML_BASIC RenderKit with component-family: javax.faces.Input and renderer-type: javax.faces.Text and call its Renderer.getConvertedValue(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object) method.
      protected Object UIInput.getConvertedValue(FacesContext context, Object newSubmittedValue)
      Convert the submitted value into a "local value" of the appropriate data type, if necessary.
      static UIComponent UIComponent.getCurrentComponent(FacesContext context)

      Return the UIComponent instance that is currently processing.
      static UIComponent UIComponent.getCurrentCompositeComponent(FacesContext context)

      Return the closest ancestor component, relative to the component returned from UIComponent.getCurrentComponent(javax.faces.context.FacesContext), that is a composite component, or null if no such component exists.
      protected Renderer | UIComponentBase.getRenderer(FacesContext context)
      protected abstract Renderer UIComponent.getRenderer(FacesContext context)
      Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.
      static char UINamingContainer.getSeparatorChar(FacesContext context)

      Return the character used to separate segments of a clientId.
      String UIViewParameter.getStringValue(FacesContext context)

      If the value of this parameter comes from a ValueExpression return the value of the expression, otherwise, return the local value.
      String UIViewParameter.getStringValueFromModel(FacesContext context)

      Manually perform standard conversion steps to get a string value from the value expression.
      UIViewParameter UIViewParameter.Reference.getUIViewParameter(FacesContext context)

      Return the UIViewParameter to which this instance refers.
      void ContextCallback.invokeContextCallback(FacesContext context, UIComponent target)
      This method will be called by an implementation of UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) and must be passed the component with the clientId given as an argument to invokeOnComponent.
      boolean UIData.invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Override behavior from UIComponentBase.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) to provide special care for positioning the data properly before finding the component and invoking the callback on it.
      boolean UIComponentBase.invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.
      boolean UIComponent.invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
      Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.
      static boolean UIViewAction.isProcessingBroadcast(FacesContext context)

      Returns true if the current request processing lifecycle is in the midst of processing the broadcast of an event queued during a call to UIViewAction.decode(javax.faces.context.FacesContext).
      void UIComponent.popComponentFromEL(FacesContext context)

      Pop the current UIComponent from the FacesContext attributes map so that the previous UIComponent, if any, becomes the current component.
      void UIViewRoot.processApplication(FacesContext context)
      Broadcast any events that have been queued for the Invoke Application phase of the request processing lifecycle and to clear out any events for later phases if the event processing for this phase caused renderResponse() or responseComplete() to be called.
      void UIViewRoot.processDecodes(FacesContext context)
      void UIInput.processDecodes(FacesContext context)
      Specialized decode behavior on top of that provided by the superclass.
      void UIForm.processDecodes(FacesContext context)
      Override UIComponent.processDecodes(javax.faces.context.FacesContext) to ensure that the form is decoded before its children.
      void UIData.processDecodes(FacesContext context)
      Override the default UIComponentBase.processDecodes(javax.faces.context.FacesContext) processing to perform the following steps.
      void | UIComponentBase.processDecodes(FacesContext context)
      abstract void UIComponent.processDecodes(FacesContext context)
      Perform the component tree processing required by the Apply Request Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      void UIViewRoot.processRestoreState(FacesContext context, Object state)

      The default implementation must call UIComponentBase.processRestoreState(javax.faces.context.FacesContext, java.lang.Object) from within a try block.
      void | UIComponentBase.processRestoreState(FacesContext context, Object state)
      abstract void UIComponent.processRestoreState(FacesContext context, Object state)
      Perform the component tree processing required by the Restore View phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      Object | UIComponentBase.processSaveState(FacesContext context)
      abstract Object UIComponent.processSaveState(FacesContext context)
      Perform the component tree processing required by the state saving portion of the Render Response phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      void UIViewRoot.processUpdates(FacesContext context)
      void UIInput.processUpdates(FacesContext context)
      In addition to the standard processUpdates behavior inherited from UIComponentBase, calls updateModel().
      void UIForm.processUpdates(FacesContext context)
      Override UIComponent.processUpdates(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if UIForm.isSubmitted() returns true.
      void UIData.processUpdates(FacesContext context)
      Override the default UIComponentBase.processUpdates(javax.faces.context.FacesContext) processing to perform the following steps.
      void | UIComponentBase.processUpdates(FacesContext context)
      abstract void UIComponent.processUpdates(FacesContext context)
      Perform the component tree processing required by the Update Model Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      void UIViewRoot.processValidators(FacesContext context)
      void UIViewParameter.processValidators(FacesContext context)

      Specialize superclass behavior to treat null differently.
      void UIInput.processValidators(FacesContext context)
      In addition to the standard processValidators behavior inherited from UIComponentBase, calls validate() if the immediate property is false (which is the default); if the component is invalid afterwards, calls renderResponse().
      void UIForm.processValidators(FacesContext context)
      Override UIComponent.processValidators(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if UIForm.isSubmitted() returns true.
      void UIData.processValidators(FacesContext context)
      Override the default UIComponentBase.processValidators(javax.faces.context.FacesContext) processing to perform the following steps.
      void | UIComponentBase.processValidators(FacesContext context)
      abstract void UIComponent.processValidators(FacesContext context)
      Perform the component tree processing required by the Process Validations phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
      void UIComponent.pushComponentToEL(FacesContext context, UIComponent component)

      Push the current UIComponent this to the FacesContext attribute map using the key UIComponent.CURRENT_COMPONENT saving the previous UIComponent associated with UIComponent.CURRENT_COMPONENT for a subsequent call to UIComponent.popComponentFromEL(javax.faces.context.FacesContext).
      void UIViewRoot.removeComponentResource(FacesContext context, UIComponent componentResource)

      Remove argument component, which is assumed to represent a resource instance, as a resource to this view.
      void UIViewRoot.removeComponentResource(FacesContext context, UIComponent componentResource, String target)

      Remove argument component, which is assumed to represent a resource instance, as a resource to this view.
      void UIViewRoot.resetValues(FacesContext context, Collection<String> clientIds)

      Visit the clientIds and, if the component is an instance of EditableValueHolder, call its EditableValueHolder.resetValue() method.
      static Object UIComponentBase.restoreAttachedState(FacesContext context, Object stateObj)
      This method is called by UIComponent subclasses that need to restore the objects they saved using UIComponentBase.saveAttachedState(javax.faces.context.FacesContext, java.lang.Object).
      void | UIViewRoot.restoreState(FacesContext context, Object state)
      void | UIOutput.restoreState(FacesContext context, Object state)
      void | UIInput.restoreState(FacesContext context, Object state)
      void | UIData.restoreState(FacesContext context, Object state)
      void | UIComponentBase.restoreState(FacesContext context, Object state)
      void StateHolder.restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      void UIComponent.restoreTransientState(FacesContext context, Object state)

      For components that need to support the concept of transient state, this method will restore any state saved on a prior call to UIComponent.saveTransientState(javax.faces.context.FacesContext).
      void TransientStateHolder.restoreTransientState(FacesContext context, Object state)

      Restore the "transient state" using the object passed as state.
      void UIViewRoot.restoreViewScopeState(FacesContext context, Object state)

      Restore ViewScope state.
      static Object UIComponentBase.saveAttachedState(FacesContext context, Object attachedObject)

      This method is called by UIComponent subclasses that want to save one or more attached objects.
      Object | UIViewRoot.saveState(FacesContext context)
      Object | UIOutput.saveState(FacesContext context)
      Object | UIInput.saveState(FacesContext context)
      Object | UIData.saveState(FacesContext context)
      Object | UIComponentBase.saveState(FacesContext context)
      Object StateHolder.saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      Object UIComponent.saveTransientState(FacesContext context)

      For components that need to support the concept of transient state, this method will save any state that is known to be transient in nature.
      Object TransientStateHolder.saveTransientState(FacesContext context)

      Return the object containing related "transient states".
      void UIViewParameter.updateModel(FacesContext context)

      Call through to superclass UIInput.updateModel(javax.faces.context.FacesContext) then take the additional action of pushing the value into request scope if and only if the value is not a value expression, is valid, and the local value was set on this lifecycle execution.
      void UIInput.updateModel(FacesContext context)
      Perform the following algorithm to update the model data associated with this UIInput, if any, as appropriate.
      void UIInput.validate(FacesContext context)
      Perform the following algorithm to validate the local value of this UIInput.
      protected void UISelectOne.validateValue(FacesContext context, Object value)
      In addition to the standard validation behavior inherited from UIInput, ensure that any specified value is equal to one of the available options.
      protected void UISelectMany.validateValue(FacesContext context, Object value)
      In addition to the standard validation behavior inherited from UIInput, ensure that any specified values are equal to one of the available options.
      protected void UIInput.validateValue(FacesContext context, Object newValue)
      Set the "valid" property according to the below algorithm.
      Constructors in javax.faces.component with parameters of type FacesContext
      Constructor and Description
      UIViewParameter.Reference(FacesContext context, UIViewParameter param, int indexInParent, String viewIdAtTimeOfConstruction)

      Construct a reference to a UIViewParameter.

    • Uses of FacesContext in javax.faces.component.behavior

      Methods in javax.faces.component.behavior that return FacesContext
      Modifier and Type Method and Description
      abstract FacesContext ClientBehaviorContext.getFacesContext()

      Returns the FacesContext for the current request.
      Methods in javax.faces.component.behavior with parameters of type FacesContext
      Modifier and Type | Method and Description
      static ClientBehaviorContext ClientBehaviorContext.createClientBehaviorContext(FacesContext context, UIComponent component, String eventName, String sourceId, Collection<ClientBehaviorContext.Parameter> parameters)

      Creates a ClientBehaviorContext instance.
      void ClientBehaviorBase.decode(FacesContext context, UIComponent component)

      Default implementation of of ClientBehavior.decode(javax.faces.context.FacesContext, javax.faces.component.UIComponent).
      void ClientBehavior.decode(FacesContext context, UIComponent component)

      Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.
      protected ClientBehaviorRenderer ClientBehaviorBase.getRenderer(FacesContext context)

      Convenience method to return the ClientBehaviorRenderer instance associated with this ClientBehavior, if any; otherwise, return null.
      void BehaviorBase.restoreState(FacesContext context, Object state)

      Implementation of StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object).
      void | AjaxBehavior.restoreState(FacesContext context, Object state)
      Object BehaviorBase.saveState(FacesContext context)

      Implementation of StateHolder.saveState(javax.faces.context.FacesContext).
      Object | AjaxBehavior.saveState(FacesContext context)

    • Uses of FacesContext in javax.faces.component.visit

      Methods in javax.faces.component.visit that return FacesContext
      Modifier and Type | Method and Description
      FacesContext | VisitContextWrapper.getFacesContext()
      abstract FacesContext VisitContext.getFacesContext()

      Returns the FacesContext for the current request.
      Methods in javax.faces.component.visit with parameters of type FacesContext
      Modifier and Type Method and Description
      static VisitContext VisitContext.createVisitContext(FacesContext context)
      Creates a VisitContext instance for use with UIComponent.visitTree().
      static VisitContext VisitContext.createVisitContext(FacesContext context, Collection<String> ids, Set<VisitHint> hints)
      Returns a VisitContext instance that is initialized with the specified ids and hintsfor use with UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback).
      abstract VisitContext VisitContextFactory.getVisitContext(FacesContext context, Collection<String> ids, Set<VisitHint> hints)

      Return a new VisitContext instance.

    • Uses of FacesContext in javax.faces.context

      Subclasses of FacesContext in javax.faces.context
      Modifier and Type Class and Description
      class  FacesContextWrapper
      Provides a simple implementation of FacesContext that can be subclassed by developers wishing to provide specialized behavior to an existing FacesContext instance.
      Methods in javax.faces.context that return FacesContext
      Modifier and Type | Method and Description
      static FacesContext FacesContext.getCurrentInstance()

      Return the FacesContext instance for the request that is being processed by the current thread.
      abstract FacesContext FacesContextFactory.getFacesContext(Object context, Object request, Object response, Lifecycle lifecycle)
      Create (if needed) and return a FacesContext instance that is initialized for the processing of the specified request and response objects, utilizing the specified Lifecycle instance, for this web application.
      abstract FacesContext | FacesContextWrapper.getWrapped()
      Methods in javax.faces.context with parameters of type FacesContext
      Modifier and Type Method and Description
      void FlashWrapper.doPostPhaseActions(FacesContext ctx)

      The default behavior of this method is to call Flash.doPostPhaseActions(FacesContext) on the wrapped Flash object.
      abstract void Flash.doPostPhaseActions(FacesContext ctx)

      Called after the execution of every lifecycle phase, this method allows implementations to take the necessary actions to provide the Flash scope contract as it applies to the request procesing lifecycle.
      void FlashWrapper.doPrePhaseActions(FacesContext ctx)

      The default behavior of this method is to call Flash.doPrePhaseActions(FacesContext) on the wrapped Flash object.
      abstract void Flash.doPrePhaseActions(FacesContext ctx)

      Called before the execution of every lifecycle phase, this method allows implementations to take the necessary actions to provide the Flash scope contract as it applies to the request procesing lifecycle.
      abstract PartialViewContext PartialViewContextFactory.getPartialViewContext(FacesContext context)
      Create (if needed) and return a PartialViewContext instance that is initialized using the current FacesContext instance.
      protected static void FacesContext.setCurrentInstance(FacesContext context)
      Set the FacesContext instance for the request that is being processed by the current thread.

    • Uses of FacesContext in javax.faces.convert

      Methods in javax.faces.convert with parameters of type FacesContext
      Modifier and Type | Method and Description
      Object | ShortConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | NumberConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | LongConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | IntegerConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | FloatConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object EnumConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Convert the value argument to one of the enum constants of the class provided in our constructor.
      Object | DoubleConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | DateTimeConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object Converter.getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      Object | CharacterConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | ByteConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | BooleanConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | BigIntegerConverter.getAsObject(FacesContext context, UIComponent component, String value)
      Object | BigDecimalConverter.getAsObject(FacesContext context, UIComponent component, String value)
      String | ShortConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | NumberConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | LongConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | IntegerConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | FloatConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String EnumConverter.getAsString(FacesContext context, UIComponent component, Object value)
      Convert the enum constant given by the value argument into a String.
      String | DoubleConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | DateTimeConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String Converter.getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
      String | CharacterConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | ByteConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | BooleanConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | BigIntegerConverter.getAsString(FacesContext context, UIComponent component, Object value)
      String | BigDecimalConverter.getAsString(FacesContext context, UIComponent component, Object value)
      void | NumberConverter.restoreState(FacesContext context, Object state)
      void | EnumConverter.restoreState(FacesContext facesContext, Object object)
      void | DateTimeConverter.restoreState(FacesContext context, Object state)
      Object | NumberConverter.saveState(FacesContext context)
      Object | EnumConverter.saveState(FacesContext facesContext)
      Object | DateTimeConverter.saveState(FacesContext context)

    • Uses of FacesContext in javax.faces.el

      Methods in javax.faces.el with parameters of type FacesContext
      Modifier and Type Method and Description
      abstract Class ValueBinding.getType(FacesContext context)
      Deprecated.
      Return the type of the property represented by this ValueBinding, relative to the specified FacesContext.
      abstract Class MethodBinding.getType(FacesContext context)
      Deprecated.
      Return the Java class representing the return type from the method identified by this method binding expression.
      abstract Object ValueBinding.getValue(FacesContext context)
      Deprecated.
      Return the value of the property represented by this ValueBinding, relative to the specified FacesContext.
      abstract Object MethodBinding.invoke(FacesContext context, Object[] params)
      Deprecated.
      Return the return value (if any) resulting from a call to the method identified by this method binding expression, passing it the specified parameters, relative to the specified FacesContext.
      abstract boolean ValueBinding.isReadOnly(FacesContext context)
      Deprecated.
      Return true if the specified property of the specified property is known to be immutable; otherwise, return false.
      abstract Object VariableResolver.resolveVariable(FacesContext context, String name)
      Deprecated.
      Resolve the specified variable name, and return the corresponding object, if any; otherwise, return null.
      abstract void ValueBinding.setValue(FacesContext context, Object value)
      Deprecated.
      Set the value of the property represented by this ValueBinding, relative to the specified FacesContext.

    • Uses of FacesContext in javax.faces.event

      Methods in javax.faces.event that return FacesContext
      Modifier and Type Method and Description
      FacesContext ExceptionQueuedEventContext.getContext()

      FacesContext PhaseEvent.getFacesContext()
      Return the FacesContext for the request being processed.
      Methods in javax.faces.event with parameters of type FacesContext
      Modifier and Type Method and Description
      void MethodExpressionValueChangeListener.restoreState(FacesContext context, Object state)

      Both MethodExpression instances described in the constructor must be restored.
      void MethodExpressionActionListener.restoreState(FacesContext context, Object state)

      Both MethodExpression instances described in the constructor must be restored.
      Object MethodExpressionValueChangeListener.saveState(FacesContext context)

      Both MethodExpression instances described in the constructor must be saved.
      Object MethodExpressionActionListener.saveState(FacesContext context)

      Both MethodExpression instances described in the constructor must be saved.
      Constructors in javax.faces.event with parameters of type FacesContext
      Constructor and Description
      ExceptionQueuedEventContext(FacesContext context, Throwable thrown)

      Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred.
      ExceptionQueuedEventContext(FacesContext context, Throwable thrown, UIComponent component)

      Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component.
      ExceptionQueuedEventContext(FacesContext context, Throwable thrown, UIComponent component, PhaseId phaseId)

      Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component, during the lifecycle phase phaseId.
      PhaseEvent(FacesContext context, PhaseId phaseId, Lifecycle lifecycle)
      Construct a new event object from the specified parameters.

    • Uses of FacesContext in javax.faces.flow

      Methods in javax.faces.flow with parameters of type FacesContext
      Modifier and Type | Method and Description
      abstract void FlowHandler.addFlow(FacesContext context, Flow toAdd)

      Add the argument Flow to the collection of Flows known to the current application.
      abstract void FlowHandler.clientWindowTransition(FacesContext context)

      Allow for flow transitions in the case of components rendered by the renderers from component-family javax.faces.OutcomeTarget.
      FlowHandler | FlowHandlerFactoryWrapper.createFlowHandler(FacesContext context)
      abstract FlowHandler FlowHandlerFactory.createFlowHandler(FacesContext context)

      Create the singleton instance of FlowHandler.
      abstract String | FlowCallNode.getCalledFlowDocumentId(FacesContext context)
      abstract String | FlowCallNode.getCalledFlowId(FacesContext context)
      abstract Boolean SwitchCase.getCondition(FacesContext context)

      Return true if this case should be taken, false otherwise.
      abstract Flow FlowHandler.getCurrentFlow(FacesContext context)

      Return the currently active Flow for the argument FacesContext, or null if no flow is active.
      abstract String SwitchNode.getDefaultOutcome(FacesContext context)

      Return the default outcome in this switch.
      abstract Flow FlowHandler.getFlow(FacesContext context, String definingDocumentId, String id)

      Return the Flow whose id is equivalent to the argument id, within the scope of the argument definingDocument.
      abstract String ReturnNode.getFromOutcome(FacesContext context)

      Return the fromOutcome to be used when control passes to this return node.
      abstract String FlowHandler.getLastDisplayedViewId(FacesContext context)

      Return the last displayed viewId for the current flow, as returned by FlowHandler.getCurrentFlow(javax.faces.context.FacesContext), or null if there is no current flow.
      abstract boolean FlowHandler.isActive(FacesContext context, String definingDocument, String id)

      Return true if and only if the flow referenced by the argument definingDocument and id is currently active.
      abstract void FlowHandler.popReturnMode(FacesContext context)

      Enable the correct handling of navigation when processing a return node.
      abstract void FlowHandler.pushReturnMode(FacesContext context)

      Enable the correct handling of navigation when processing a return node.
      abstract void FlowHandler.transition(FacesContext context, Flow sourceFlow, Flow targetFlow, FlowCallNode outboundCallNode, String toViewId)

      Perform a transition in the flow graph for the current user's ClientWindow.

    • Uses of FacesContext in javax.faces.lifecycle

      Methods in javax.faces.lifecycle with parameters of type FacesContext
      Modifier and Type | Method and Description
      void | LifecycleWrapper.attachWindow(FacesContext context)
      void Lifecycle.attachWindow(FacesContext context)

      Create or restore the ClientWindow to be used to display the UIViewRoot for this run through the lifecycle.
      void | ClientWindowWrapper.decode(FacesContext context)
      abstract void ClientWindow.decode(FacesContext context)

      The implementation is responsible for examining the incoming request and extracting the value that must be returned from the ClientWindow.getId() method.
      void | ClientWindowWrapper.disableClientWindowRenderMode(FacesContext context)
      void ClientWindow.disableClientWindowRenderMode(FacesContext context)

      Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first before rendering those URLs.
      void | ClientWindowWrapper.enableClientWindowRenderMode(FacesContext context)
      void ClientWindow.enableClientWindowRenderMode(FacesContext context)

      Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first after rendering those URLs.
      void | LifecycleWrapper.execute(FacesContext context)
      abstract void Lifecycle.execute(FacesContext context)
      Execute all of the phases of the request processing lifecycle, up to but not including the Render Response phase, as described in the JavaServer Faces Specification, in the specified order.
      abstract ClientWindow ClientWindowFactory.getClientWindow(FacesContext context)

      The implementation is responsible for creating the ClientWindow instance for this request.
      Map<String,String> | ClientWindowWrapper.getQueryURLParameters(FacesContext context)
      abstract Map<String,String> ClientWindow.getQueryURLParameters(FacesContext context)

      This method will be called whenever a URL is generated by the runtime where client window related parameters need to be inserted into the URL.
      boolean | ClientWindowWrapper.isClientWindowRenderModeEnabled(FacesContext context)
      boolean ClientWindow.isClientWindowRenderModeEnabled(FacesContext context)

      Methods that append the ClientWindow to generated URLs must call this method to see if they are permitted to do so.
      void | LifecycleWrapper.render(FacesContext context)
      abstract void Lifecycle.render(FacesContext context)
      Execute the Render Response phase of the request processing lifecycle, unless the responseComplete() method has been called on the FacesContext instance associated with the current request.

    • Uses of FacesContext in javax.faces.render

      Methods in javax.faces.render with parameters of type FacesContext
      Modifier and Type | Method and Description
      String | RendererWrapper.convertClientId(FacesContext context, String clientId)
      String Renderer.convertClientId(FacesContext context, String clientId)
      Convert the component generated client id to a form suitable for transmission to the client.
      void | RendererWrapper.decode(FacesContext context, UIComponent component)
      void Renderer.decode(FacesContext context, UIComponent component)
      Decode any new state of the specified UIComponent from the request contained in the specified FacesContext, and store that state on the UIComponent.
      void ClientBehaviorRenderer.decode(FacesContext context, UIComponent component, ClientBehavior behavior)

      Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.
      void | RendererWrapper.encodeBegin(FacesContext context, UIComponent component)
      void Renderer.encodeBegin(FacesContext context, UIComponent component)
      Render the beginning specified UIComponent to the output stream or writer associated with the response we are creating.
      void | RendererWrapper.encodeChildren(FacesContext context, UIComponent component)
      void Renderer.encodeChildren(FacesContext context, UIComponent component)
      Render the child components of this UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
      void | RendererWrapper.encodeEnd(FacesContext context, UIComponent component)
      void Renderer.encodeEnd(FacesContext context, UIComponent component)
      Render the ending of the current state of the specified UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
      Object ResponseStateManager.getComponentStateToRestore(FacesContext context)
      Deprecated.
      This method has been replaced by ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
      Object | RendererWrapper.getConvertedValue(FacesContext context, UIComponent component, Object submittedValue)
      Object Renderer.getConvertedValue(FacesContext context, UIComponent component, Object submittedValue)
      Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one).
      String ResponseStateManager.getCryptographicallyStrongTokenFromSession(FacesContext context)

      Compliant implementations must return a cryptographically strong token for use to protect views in this application.
      abstract RenderKit RenderKitFactory.getRenderKit(FacesContext context, String renderKitId)
      Return a RenderKit instance for the specified render kit identifier, possibly customized based on dynamic characteristics of the specified FacesContext, if non-null.
      Object ResponseStateManager.getState(FacesContext context, String viewId)
      The implementation must inspect the current request and return an Object representing the tree structure and component state passed in to a previous invocation of ResponseStateManager.writeState(javax.faces.context.FacesContext,java.lang.Object).
      Object ResponseStateManager.getTreeStructureToRestore(FacesContext context, String viewId)
      Deprecated.
      This method has been replaced by ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
      String ResponseStateManager.getViewState(FacesContext context, Object state)
      Return the specified state as a String without any markup related to the rendering technology supported by this ResponseStateManager.
      boolean ResponseStateManager.isPostback(FacesContext context)
      Return true if the current request is a postback.
      boolean ResponseStateManager.isStateless(FacesContext context, String viewId)

      If the preceding call to ResponseStateManager.writeState(javax.faces.context.FacesContext, java.lang.Object) was stateless, return true.
      void ResponseStateManager.writeState(FacesContext context, Object state)
      Take the argument state and write it into the output using the current ResponseWriter, which must be correctly positioned already.
      void ResponseStateManager.writeState(FacesContext context, StateManager.SerializedView state)
      Deprecated.
      This method has been replaced by ResponseStateManager.writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation creates a two element Object array with the first element being the return from calling StateManager.SerializedView.getStructure(), and the second being the return from StateManager.SerializedView.getState(). It then passes this Object array to ResponseStateManager.writeState(javax.faces.context.FacesContext, java.lang.Object).

    • Uses of FacesContext in javax.faces.validator

      Methods in javax.faces.validator with parameters of type FacesContext
      Modifier and Type | Method and Description
      void | RegexValidator.restoreState(FacesContext context, Object state)
      void | MethodExpressionValidator.restoreState(FacesContext context, Object state)
      void | LongRangeValidator.restoreState(FacesContext context, Object state)
      void | LengthValidator.restoreState(FacesContext context, Object state)
      void | DoubleRangeValidator.restoreState(FacesContext context, Object state)
      void | BeanValidator.restoreState(FacesContext context, Object state)
      Object | RegexValidator.saveState(FacesContext context)
      Object | MethodExpressionValidator.saveState(FacesContext context)
      Object | LongRangeValidator.saveState(FacesContext context)
      Object | LengthValidator.saveState(FacesContext context)
      Object | DoubleRangeValidator.saveState(FacesContext context)
      Object | BeanValidator.saveState(FacesContext context)
      void Validator.validate(FacesContext context, UIComponent component, Object value)
      Perform the correctness checks implemented by this Validator against the specified UIComponent.
      void RequiredValidator.validate(FacesContext context, UIComponent component, Object value)
      Verify that the converted object value is not null.
      void RegexValidator.validate(FacesContext context, UIComponent component, Object value)
      Validate a String against a regular expression pattern.
      void | MethodExpressionValidator.validate(FacesContext context, UIComponent component, Object value)
      void | LongRangeValidator.validate(FacesContext context, UIComponent component, Object value)
      void | LengthValidator.validate(FacesContext context, UIComponent component, Object value)
      void | DoubleRangeValidator.validate(FacesContext context, UIComponent component, Object value)
      void BeanValidator.validate(FacesContext context, UIComponent component, Object value)

      Verify that the value is valid according to the Bean Validation constraints.

    • Uses of FacesContext in javax.faces.view

      Methods in javax.faces.view with parameters of type FacesContext
      Modifier and Type | Method and Description
      void AttachedObjectHandler.applyAttachedObject(FacesContext context, UIComponent parent)

      Take the argument parent and apply this attached object to it.
      void | ViewDeclarationLanguageWrapper.buildView(FacesContext context, UIViewRoot root)
      abstract void ViewDeclarationLanguage.buildView(FacesContext context, UIViewRoot root)

      Take any actions specific to this VDL implementation to cause the argument UIViewRoot which must have been created via a call to ViewDeclarationLanguage.createView(javax.faces.context.FacesContext, java.lang.String), to be populated with children.
      List<String> | ViewDeclarationLanguageWrapper.calculateResourceLibraryContracts(FacesContext context, String viewId)
      List<String> ViewDeclarationLanguage.calculateResourceLibraryContracts(FacesContext context, String viewId)

      Return the list of resource library contracts that will be made available for use in the view specified by the argument viewId.
      UIComponent | ViewDeclarationLanguageWrapper.createComponent(FacesContext context, String taglibURI, String tagName, Map<String,Object> attributes)
      UIComponent ViewDeclarationLanguage.createComponent(FacesContext context, String taglibURI, String tagName, Map<String,Object> attributes)

      Create a component given a ViewDeclarationLanguage specific tag library URI and tag name.
      abstract UIViewRoot ViewMetadata.createMetadataView(FacesContext context)

      Creates a new UIViewRoot containing only view parameter metadata.
      UIViewRoot | ViewDeclarationLanguageWrapper.createView(FacesContext context, String viewId)
      abstract UIViewRoot ViewDeclarationLanguage.createView(FacesContext context, String viewId)

      Create a UIViewRoot from the VDL contained in the artifact referenced by the argument viewId.
      BeanInfo | ViewDeclarationLanguageWrapper.getComponentMetadata(FacesContext context, Resource componentResource)
      abstract BeanInfo ViewDeclarationLanguage.getComponentMetadata(FacesContext context, Resource componentResource)

      Return a reference to the component metadata for the composite component represented by the argument componentResource, or null if the metadata cannot be found.
      Resource | ViewDeclarationLanguageWrapper.getScriptComponentResource(FacesContext context, Resource componentResource)
      abstract Resource ViewDeclarationLanguage.getScriptComponentResource(FacesContext context, Resource componentResource)

      Take implementation specific action to discover a Resource given the argument componentResource.
      StateManagementStrategy | ViewDeclarationLanguageWrapper.getStateManagementStrategy(FacesContext context, String viewId)
      abstract StateManagementStrategy ViewDeclarationLanguage.getStateManagementStrategy(FacesContext context, String viewId)

      For implementations that want to control the implementation of state saving and restoring, the StateManagementStrategy allows them to do so.
      ViewMetadata | ViewDeclarationLanguageWrapper.getViewMetadata(FacesContext context, String viewId)
      abstract ViewMetadata ViewDeclarationLanguage.getViewMetadata(FacesContext context, String viewId)

      Return a reference to the view metadata for the view represented by the argument viewId, or null if the metadata cannot be found.
      void | ViewDeclarationLanguageWrapper.renderView(FacesContext context, UIViewRoot view)
      abstract void ViewDeclarationLanguage.renderView(FacesContext context, UIViewRoot view)

      Render a view rooted at argumentview.
      UIViewRoot | ViewDeclarationLanguageWrapper.restoreView(FacesContext context, String viewId)
      abstract UIViewRoot ViewDeclarationLanguage.restoreView(FacesContext context, String viewId)

      Restore a UIViewRoot from a previously created view.
      abstract UIViewRoot StateManagementStrategy.restoreView(FacesContext context, String viewId, String renderKitId)

      Restore the state of the view with information in the request.
      void | ViewDeclarationLanguageWrapper.retargetAttachedObjects(FacesContext context, UIComponent topLevelComponent, List<AttachedObjectHandler> handlers)
      void ViewDeclarationLanguage.retargetAttachedObjects(FacesContext context, UIComponent topLevelComponent, List<AttachedObjectHandler> handlers)

      Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting attached objects from the top level composite component to the individual AttachedObjectTarget instances inside the composite component.
      void | ViewDeclarationLanguageWrapper.retargetMethodExpressions(FacesContext context, UIComponent topLevelComponent)
      void ViewDeclarationLanguage.retargetMethodExpressions(FacesContext context, UIComponent topLevelComponent)

      Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting any method expressions from the top level component to the appropriate inner component.
      abstract Object StateManagementStrategy.saveView(FacesContext context)

      Return the state of the current view in an Object that implements Serializable and can be passed to java.io.ObjectOutputStream.writeObject() without causing a java.io.NotSerializableException to be thrown. The default implementation must perform the following algorithm or its semantic equivalent, explicitly performing all the steps listed here.
      boolean | ViewDeclarationLanguageWrapper.viewExists(FacesContext context, String viewId)
      boolean ViewDeclarationLanguage.viewExists(FacesContext context, String viewId)

      Tests whether a physical resource corresponding to the specified viewId exists.

    • Uses of FacesContext in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return FacesContext
      Modifier and Type Method and Description
      abstract FacesContext FaceletContext.getFacesContext()

      The current FacesContext bound to this "request".
      Methods in javax.faces.view.facelets with parameters of type FacesContext
      Modifier and Type Method and Description
      abstract void Facelet.apply(FacesContext facesContext, UIComponent parent)
      The passed UIComponent parent will be populated/restored in accordance with the Facelets chapter in the spec prose document.
      void FaceletsAttachedObjectHandler.applyAttachedObject(FacesContext ctx, UIComponent parent)

      Take the necessary actions to apply the attached object represented by the tag for the concrete subclass of this class to the argument parent.

    • Uses of FacesContext in javax.faces.webapp

      Methods in javax.faces.webapp that return FacesContext
      Modifier and Type | Method and Description
      protected abstract FacesContext UIComponentTagBase.getFacesContext()
      Return the FacesContext instance for the current request.
      protected FacesContext | UIComponentClassicTagBase.getFacesContext()
      Methods in javax.faces.webapp with parameters of type FacesContext
      Modifier and Type Method and Description
      protected UIComponent UIComponentTag.createComponent(FacesContext context, String newId)
      Deprecated.
      Implement createComponent using Faces 1.1 EL API.
      protected UIComponent UIComponentELTag.createComponent(FacesContext context, String newId)
      Create and return a new child component of the type returned by calling getComponentType().
      protected abstract UIComponent UIComponentClassicTagBase.createComponent(FacesContext context, String newId)
      Create and return a new child component of the type returned by calling getComponentType().
      protected UIComponent UIComponentClassicTagBase.findComponent(FacesContext context)
      Find and return the UIComponent, from the component tree, that corresponds to this tag handler instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.FacesContextFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.FacesContextFactory

  • Packages that use FacesContextFactory
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of FacesContextFactory in javax.faces.context

      Methods in javax.faces.context that return FacesContextFactory
      Modifier and Type Method and Description
      FacesContextFactory FacesContextFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.FacesContextWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.FacesContextWrapper

No usage of javax.faces.context.FacesContextWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.Flash (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.Flash

  • Packages that use Flash
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of Flash in javax.faces.context

      Subclasses of Flash in javax.faces.context
      Modifier and Type Class and Description
      class  FlashWrapper

      Provides a simple implementation of Flash that can be subclassed by developers wishing to provide specialized behavior to an existing Flash instance.
      Methods in javax.faces.context that return Flash
      Modifier and Type | Method and Description
      Flash ExternalContextWrapper.getFlash()
      The default behavior of this method is to call ExternalContext.getFlash() on the wrapped ExternalContext object.
      Flash ExternalContext.getFlash()

      Return the threadsafe Flash for this application.
      abstract Flash FlashFactory.getFlash(boolean create)

      Create (if needed) and return a Flash instance for this web application.
      abstract Flash | FlashWrapper.getWrapped()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.FlashFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.FlashFactory

  • Packages that use FlashFactory
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of FlashFactory in javax.faces.context

      Methods in javax.faces.context that return FlashFactory
      Modifier and Type Method and Description
      FlashFactory FlashFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.FlashWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.FlashWrapper

No usage of javax.faces.context.FlashWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.PartialResponseWriter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.PartialResponseWriter

  • Packages that use PartialResponseWriter
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of PartialResponseWriter in javax.faces.context

      Methods in javax.faces.context that return PartialResponseWriter
      Modifier and Type Method and Description
      PartialResponseWriter PartialViewContextWrapper.getPartialResponseWriter()
      The default behavior of this method is to call PartialViewContext.getPartialResponseWriter() on the wrapped PartialViewContext object.
      abstract PartialResponseWriter PartialViewContext.getPartialResponseWriter()

      Return the ResponseWriter to which components should direct their output for partial view rendering.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.PartialViewContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.PartialViewContext

  • Packages that use PartialViewContext
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of PartialViewContext in javax.faces.context

      Subclasses of PartialViewContext in javax.faces.context
      Modifier and Type Class and Description
      class  PartialViewContextWrapper

      Provides a simple implementation of PartialViewContext that can be subclassed by developers wishing to provide specialized behavior to an existing PartialViewContext instance.
      Methods in javax.faces.context that return PartialViewContext
      Modifier and Type | Method and Description
      PartialViewContext FacesContextWrapper.getPartialViewContext()
      The default behavior of this method is to call FacesContext.getPartialViewContext() ()} on the wrapped FacesContext object.
      PartialViewContext FacesContext.getPartialViewContext()

      Return the PartialViewContext for this request.
      abstract PartialViewContext PartialViewContextFactory.getPartialViewContext(FacesContext context)
      Create (if needed) and return a PartialViewContext instance that is initialized using the current FacesContext instance.
      abstract PartialViewContext | PartialViewContextWrapper.getWrapped()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.PartialViewContextFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.PartialViewContextFactory

  • Packages that use PartialViewContextFactory
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of PartialViewContextFactory in javax.faces.context

      Methods in javax.faces.context that return PartialViewContextFactory
      Modifier and Type | Method and Description
      PartialViewContextFactory | PartialViewContextFactory.getWrapped()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.PartialViewContextWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.PartialViewContextWrapper

No usage of javax.faces.context.PartialViewContextWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.ResponseStream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.ResponseStream

  • Packages that use ResponseStream
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of ResponseStream in javax.faces.context

      Methods in javax.faces.context that return ResponseStream
      Modifier and Type Method and Description
      ResponseStream FacesContextWrapper.getResponseStream()
      The default behavior of this method is to call FacesContext.getResponseStream() on the wrapped FacesContext object.
      abstract ResponseStream FacesContext.getResponseStream()
      Return the ResponseStream to which components should direct their binary output.
      Methods in javax.faces.context with parameters of type ResponseStream
      Modifier and Type Method and Description
      void FacesContextWrapper.setResponseStream(ResponseStream responseStream)
      The default behavior of this method is to call FacesContext.setResponseStream(ResponseStream) on the wrapped FacesContext object.
      abstract void FacesContext.setResponseStream(ResponseStream responseStream)
      Set the ResponseStream to which components should direct their binary output.

    • Uses of ResponseStream in javax.faces.render

      Methods in javax.faces.render that return ResponseStream
      Modifier and Type Method and Description
      ResponseStream RenderKitWrapper.createResponseStream(OutputStream out)
      The default behavior of this method is to call RenderKit.createResponseStream(java.io.OutputStream) on the wrapped RenderKit object.
      abstract ResponseStream RenderKit.createResponseStream(OutputStream out)
      Use the provided OutputStream to create a new ResponseStream instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.ResponseWriter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.ResponseWriter

  • Packages that use ResponseWriter
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of ResponseWriter in javax.faces.context

      Subclasses of ResponseWriter in javax.faces.context
      Modifier and Type Class and Description
      class  PartialResponseWriter

      PartialResponseWriter decorates an existing ResponseWriter to support the generation of a partial response suitable for Ajax operations.
      class  ResponseWriterWrapper
      Provides a simple implementation of ResponseWriter that can be subclassed by developers wishing to provide specialized behavior to an existing ResponseWriter instance.
      Methods in javax.faces.context that return ResponseWriter
      Modifier and Type Method and Description
      ResponseWriter ResponseWriterWrapper.cloneWithWriter(Writer writer)
      The default behavior of this method is to call cloneWithWriter(java.io.Writer) on the wrapped ResponseWriter object.
      abstract ResponseWriter ResponseWriter.cloneWithWriter(Writer writer)
      Create and return a new instance of this ResponseWriter, using the specified Writer as the output destination.
      ResponseWriter FacesContextWrapper.getResponseWriter()
      The default behavior of this method is to call FacesContext.getResponseWriter() on the wrapped FacesContext object.
      abstract ResponseWriter FacesContext.getResponseWriter()
      Return the ResponseWriter to which components should direct their character-based output.
      abstract ResponseWriter ResponseWriterWrapper.getWrapped()

      Return the instance that we are wrapping.
      ResponseWriter PartialResponseWriter.getWrapped()

      Return the wrapped ResponseWriter instance.
      Methods in javax.faces.context with parameters of type ResponseWriter
      Modifier and Type Method and Description
      void FacesContextWrapper.setResponseWriter(ResponseWriter responseWriter)
      The default behavior of this method is to call FacesContext.setResponseWriter(ResponseWriter) on the wrapped FacesContext object.
      abstract void FacesContext.setResponseWriter(ResponseWriter responseWriter)
      Set the ResponseWriter to which components should direct their character-based output.
      Constructors in javax.faces.context with parameters of type ResponseWriter
      Constructor and Description
      PartialResponseWriter(ResponseWriter writer)

      Create a PartialResponseWriter.

    • Uses of ResponseWriter in javax.faces.render

      Methods in javax.faces.render that return ResponseWriter
      Modifier and Type Method and Description
      ResponseWriter RenderKitWrapper.createResponseWriter(Writer writer, String contentTypeList, String characterEncoding)
      The default behavior of this method is to call RenderKit.createResponseWriter(java.io.Writer, String, String) on the wrapped RenderKit object.
      abstract ResponseWriter RenderKit.createResponseWriter(Writer writer, String contentTypeList, String characterEncoding)
      Use the provided Writer to create a new ResponseWriter instance for the specified (optional) content type, and character encoding.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.context.ResponseWriterWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.context.ResponseWriterWrapper

  • Packages that use ResponseWriterWrapper
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of ResponseWriterWrapper in javax.faces.context

      Subclasses of ResponseWriterWrapper in javax.faces.context
      Modifier and Type Class and Description
      class  PartialResponseWriter

      PartialResponseWriter decorates an existing ResponseWriter to support the generation of a partial response suitable for Ajax operations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BigDecimalConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class BigDecimalConverter

  • java.lang.Object
    • javax.faces.convert.BigDecimalConverter
  • All Implemented Interfaces:
    Converter

    public class BigDecimalConverter
extends Object
implements Converter

    Converter implementation for java.math.BigDecimal values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String DECIMAL_ID
      The message identifier of the FacesMessage to be created if the conversion to BigDecimal fails.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the BigDecimal value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      BigDecimalConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • DECIMAL_ID

        public static final String DECIMAL_ID

        The message identifier of the FacesMessage to be created if the conversion to BigDecimal fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the BigDecimal value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • BigDecimalConverter

        public BigDecimalConverter()

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BigIntegerConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class BigIntegerConverter

  • java.lang.Object
    • javax.faces.convert.BigIntegerConverter
  • All Implemented Interfaces:
    Converter

    public class BigIntegerConverter
extends Object
implements Converter

    Converter implementation for java.math.BigInteger values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String BIGINTEGER_ID
      The message identifier of the FacesMessage to be created if the conversion to BigInteger fails.
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the BigInteger value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      BigIntegerConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • BIGINTEGER_ID

        public static final String BIGINTEGER_ID

        The message identifier of the FacesMessage to be created if the conversion to BigInteger fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the BigInteger value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • BigIntegerConverter

        public BigIntegerConverter()

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BooleanConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class BooleanConverter

  • java.lang.Object
    • javax.faces.convert.BooleanConverter
  • All Implemented Interfaces:
    Converter

    public class BooleanConverter
extends Object
implements Converter

    Converter implementation for java.lang.Boolean (and boolean primitive) values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String BOOLEAN_ID
      The message identifier of the FacesMessage to be created if the conversion to Boolean fails.
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the Boolean value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      BooleanConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • BOOLEAN_ID

        public static final String BOOLEAN_ID

        The message identifier of the FacesMessage to be created if the conversion to Boolean fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the Boolean value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • BooleanConverter

        public BooleanConverter()

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ByteConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class ByteConverter

  • java.lang.Object
    • javax.faces.convert.ByteConverter
  • All Implemented Interfaces:
    Converter

    public class ByteConverter
extends Object
implements Converter

    Converter implementation for java.lang.Byte (and byte primitive) values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String BYTE_ID
      The message identifier of the FacesMessage to be created if the conversion to Byte fails.
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the Byte value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      ByteConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • BYTE_ID

        public static final String BYTE_ID

        The message identifier of the FacesMessage to be created if the conversion to Byte fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the Byte value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • ByteConverter

        public ByteConverter()

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CharacterConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class CharacterConverter

  • java.lang.Object
    • javax.faces.convert.CharacterConverter
  • All Implemented Interfaces:
    Converter

    public class CharacterConverter
extends Object
implements Converter

    Converter implementation for java.lang.Character (and char primitive) values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CHARACTER_ID
      The message identifier of the FacesMessage to be created if the conversion to Character fails.
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the Character value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      CharacterConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • CHARACTER_ID

        public static final String CHARACTER_ID

        The message identifier of the FacesMessage to be created if the conversion to Character fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the Character value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • CharacterConverter

        public CharacterConverter()

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Converter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Interface Converter

  • All Known Implementing Classes:
    BigDecimalConverter, BigIntegerConverter, BooleanConverter, ByteConverter, CharacterConverter, DateTimeConverter, DoubleConverter, EnumConverter, FloatConverter, IntegerConverter, LongConverter, NumberConverter, ShortConverter

    public interface Converter

    Converter is an interface describing a Java class that can perform Object-to-String and String-to-Object conversions between model data objects and a String representation of those objects that is suitable for rendering.

    Converter implementations must have a zero-arguments public constructor. In addition, if the Converter class wishes to have configuration property values saved and restored with the component tree, the implementation must also implement StateHolder.

    Starting with version 1.2 of the specification, an exception to the above zero-arguments constructor requirement has been introduced. If a converter has a single argument constructor that takes a Class instance and the Class of the data to be converted is known at converter instantiation time, this constructor must be used to instantiate the converter instead of the zero-argument version. This enables the per-class conversion of Java enumerated types.

    If any Converter implementation requires a java.util.Locale to perform its job, it must obtain that Locale from the UIViewRoot of the current FacesContext, unless the Converter maintains its own Locale as part of its state.

    If the class implementing Converter has a ResourceDependency annotation, the action described in ResourceDependency must be taken when ValueHolder.setConverter(javax.faces.convert.Converter) is called. If the class implementing Converter has a ResourceDependencies annotation, the action described in ResourceDependencies must be taken when ValueHolder.setConverter(javax.faces.convert.Converter) is called.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

      If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, Application.createConverter() must guarantee that the default for the timezone of all javax.faces.convert.DateTimeConverter instances must be equal to TimeZone.getDefault() instead of "GMT".

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

    • Field Detail

      • DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

        static final String DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

        If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, Application.createConverter() must guarantee that the default for the timezone of all javax.faces.convert.DateTimeConverter instances must be equal to TimeZone.getDefault() instead of "GMT".

        Since:
        2.0
        See Also:
        Constant Field Values

    • Method Detail

      • getAsObject

        Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConverterException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class ConverterException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.convert.ConverterException
  • All Implemented Interfaces:
    Serializable

    public class ConverterException
extends FacesException

    ConverterException is an exception thrown by the getAsObject() or getAsText() method of a Converter, to indicate that the requested conversion cannot be performed.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ConverterException()
      Construct a new exception with no detail message or root cause.
      ConverterException(FacesMessage message)
      Construct a new exception with the specified detail message and no root cause.
      ConverterException(FacesMessage message, Throwable cause)
      Construct a new exception with the specified detail message and root cause.
      ConverterException(String message)
      Construct a new exception with the specified detail message and no root cause.
      ConverterException(String message, Throwable cause)
      Construct a new exception with the specified detail message and root cause.
      ConverterException(Throwable cause)
      Construct a new exception with the specified root cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      FacesMessage getFacesMessage()
      Returns the FacesMessage associated with this exception; this will only be available if the converter that thew this exception instance placed it there.

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ConverterException

        public ConverterException()

        Construct a new exception with no detail message or root cause.

      • ConverterException

        public ConverterException(String message)

        Construct a new exception with the specified detail message and no root cause.

        Parameters:
        message - The detail message for this exception

      • ConverterException

        public ConverterException(Throwable cause)

        Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

        Parameters:
        cause - The root cause for this exception

      • ConverterException

        public ConverterException(String message,
                  Throwable cause)

        Construct a new exception with the specified detail message and root cause.

        Parameters:
        message - The detail message for this exception
        cause - The root cause for this exception

      • ConverterException

        public ConverterException(FacesMessage message)

        Construct a new exception with the specified detail message and no root cause.

        Parameters:
        message - The detail message for this exception

      • ConverterException

        public ConverterException(FacesMessage message,
                  Throwable cause)

        Construct a new exception with the specified detail message and root cause.

        Parameters:
        message - The detail message for this exception
        cause - The root cause for this exception

    • Method Detail

      • getFacesMessage

        public FacesMessage getFacesMessage()

        Returns the FacesMessage associated with this exception; this will only be available if the converter that thew this exception instance placed it there.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DateTimeConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class DateTimeConverter

  • java.lang.Object
    • javax.faces.convert.DateTimeConverter
  • All Implemented Interfaces:
    PartialStateHolder, StateHolder, Converter

    public class DateTimeConverter
extends Object
implements Converter, PartialStateHolder

    Converter implementation for java.util.Date values.

    The getAsObject() method parses a String into a java.util.Date, according to the following algorithm:

    • If the specified String is null, return a null. Otherwise, trim leading and trailing whitespace before proceeding.
    • If the specified String - after trimming - has a zero length, return null.
    • If the locale property is not null, use that Locale for managing parsing. Otherwise, use the Locale from the UIViewRoot.
    • If a pattern has been specified, its syntax must conform the rules specified by java.text.SimpleDateFormat. Such a pattern will be used to parse, and the type, dateStyle, and timeStyle properties will be ignored.
    • If a pattern has not been specified, parsing will be based on the type property, which expects a date value, a time value, or both. Any date and time values included will be parsed in accordance to the styles specified by dateStyle and timeStyle, respectively.
    • If a timezone has been specified, it must be passed to the underlying DateFormat instance. Otherwise the "GMT" timezone is used.
    • In all cases, parsing must be non-lenient; the given string must strictly adhere to the parsing format.

    The getAsString() method expects a value of type java.util.Date (or a subclass), and creates a formatted String according to the following algorithm:

    • If the specified value is null, return a zero-length String.
    • If the specified value is a String, return it unmodified.
    • If the locale property is not null, use that Locale for managing formatting. Otherwise, use the Locale from the UIViewRoot.
    • If a timezone has been specified, it must be passed to the underlying DateFormat instance. Otherwise the "GMT" timezone is used.
    • If a pattern has been specified, its syntax must conform the rules specified by java.text.SimpleDateFormat. Such a pattern will be used to format, and the type, dateStyle, and timeStyle properties will be ignored.
    • If a pattern has not been specified, formatting will be based on the type property, which includes a date value, a time value, or both into the formatted String. Any date and time values included will be formatted in accordance to the styles specified by dateStyle and timeStyle, respectively.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String DATE_ID
      The message identifier of the FacesMessage to be created if the conversion to Date fails.
      static String DATETIME_ID
      The message identifier of the FacesMessage to be created if the conversion to DateTime fails.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the DateTime value to String fails.
      static String TIME_ID
      The message identifier of the FacesMessage to be created if the conversion to Time fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      DateTimeConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearInitialState()

      Reset the PartialStateHolder to a non-delta tracking state.
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
      String getDateStyle()
      Return the style to be used to format or parse dates.
      Locale getLocale()
      Return the Locale to be used when parsing or formatting dates and times.
      String getPattern()
      Return the format pattern to be used when formatting and parsing dates and times.
      String getTimeStyle()
      Return the style to be used to format or parse times.
      TimeZone getTimeZone()
      Return the TimeZone used to interpret a time value.
      String getType()
      Return the type of value to be formatted or parsed.
      boolean initialStateMarked()

      Return true if delta state changes are being tracked, otherwise false
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void markInitialState()

      The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setDateStyle(String dateStyle)
      Set the style to be used to format or parse dates.
      void setLocale(Locale locale)
      Set the Locale to be used when parsing or formatting dates and times.
      void setPattern(String pattern)
      Set the format pattern to be used when formatting and parsing dates and times.
      void setTimeStyle(String timeStyle)
      Set the style to be used to format or parse times.
      void setTimeZone(TimeZone timeZone)
      Set the TimeZone used to interpret a time value.
      void setTransient(boolean transientFlag)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
      void setType(String type)
      Set the type of value to be formatted or parsed.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • DATE_ID

        public static final String DATE_ID

        The message identifier of the FacesMessage to be created if the conversion to Date fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • TIME_ID

        public static final String TIME_ID

        The message identifier of the FacesMessage to be created if the conversion to Time fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • DATETIME_ID

        public static final String DATETIME_ID

        The message identifier of the FacesMessage to be created if the conversion to DateTime fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the DateTime value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • DateTimeConverter

        public DateTimeConverter()

    • Method Detail

      • getDateStyle

        public String getDateStyle()

        Return the style to be used to format or parse dates. If not set, the default value, default, is returned.

      • setDateStyle

        public void setDateStyle(String dateStyle)

        Set the style to be used to format or parse dates. Valid values are default, short, medium, long, and full. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

        Parameters:
        dateStyle - The new style code

      • getLocale

        public Locale getLocale()

        Return the Locale to be used when parsing or formatting dates and times. If not explicitly set, the Locale stored in the UIViewRoot for the current request is returned.

      • setLocale

        public void setLocale(Locale locale)

        Set the Locale to be used when parsing or formatting dates and times. If set to null, the Locale stored in the UIViewRoot for the current request will be utilized.

        Parameters:
        locale - The new Locale (or null)

      • getPattern

        public String getPattern()

        Return the format pattern to be used when formatting and parsing dates and times.

      • setPattern

        public void setPattern(String pattern)

        Set the format pattern to be used when formatting and parsing dates and times. Valid values are those supported by java.text.SimpleDateFormat. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

        Parameters:
        pattern - The new format pattern

      • getTimeStyle

        public String getTimeStyle()

        Return the style to be used to format or parse times. If not set, the default value, default, is returned.

      • setTimeStyle

        public void setTimeStyle(String timeStyle)

        Set the style to be used to format or parse times. Valid values are default, short, medium, long, and full. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

        Parameters:
        timeStyle - The new style code

      • getTimeZone

        public TimeZone getTimeZone()

        Return the TimeZone used to interpret a time value. If not explicitly set, the default time zone of GMT returned.

      • setTimeZone

        public void setTimeZone(TimeZone timeZone)

        Set the TimeZone used to interpret a time value.

        Parameters:
        timeZone - The new time zone

      • getType

        public String getType()

        Return the type of value to be formatted or parsed. If not explicitly set, the default type, date is returned.

      • setType

        public void setType(String type)

        Set the type of value to be formatted or parsed. Valid values are both, date, or time. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

        Parameters:
        type - The new date style

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • saveState

        public Object saveState(FacesContext context)
        Description copied from interface: StateHolder

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)
        Description copied from interface: StateHolder

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Specified by:
        restoreState in interface StateHolder

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean transientFlag)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        transientFlag - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.

      • markInitialState

        public void markInitialState()
        Description copied from interface: PartialStateHolder

        The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state. The implementor of the interface must ensure that PartialStateHolder.initialStateMarked() returns true from the time markInitialState() is called until PartialStateHolder.clearInitialState() is called, after which time initialStateMarked() must return false. Also, during the time that the instance returns true from initialStateMarked(), the implementation must return only the state that has changed in its implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Specified by:
        markInitialState in interface PartialStateHolder

      • initialStateMarked

        public boolean initialStateMarked()
        Description copied from interface: PartialStateHolder

        Return true if delta state changes are being tracked, otherwise false

        Specified by:
        initialStateMarked in interface PartialStateHolder

      • clearInitialState

        public void clearInitialState()
        Description copied from interface: PartialStateHolder

        Reset the PartialStateHolder to a non-delta tracking state.

        Specified by:
        clearInitialState in interface PartialStateHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DoubleConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class DoubleConverter

  • java.lang.Object
    • javax.faces.convert.DoubleConverter
  • All Implemented Interfaces:
    Converter

    public class DoubleConverter
extends Object
implements Converter

    Converter implementation for java.lang.Double (and double primitive) values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String DOUBLE_ID
      The message identifier of the FacesMessage to be created if the conversion to Double fails.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the Double value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      DoubleConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • DOUBLE_ID

        public static final String DOUBLE_ID

        The message identifier of the FacesMessage to be created if the conversion to Double fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the Double value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • DoubleConverter

        public DoubleConverter()

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EnumConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class EnumConverter

  • java.lang.Object
    • javax.faces.convert.EnumConverter
  • All Implemented Interfaces:
    PartialStateHolder, StateHolder, Converter

    public class EnumConverter
extends Object
implements Converter, PartialStateHolder

    Converter implementation for java.lang.Enum (and enum primitive) values.

    Since:
    1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String ENUM_ID
      The message identifier of the FacesMessage to be created if the conversion to Enum fails.
      static String ENUM_NO_CLASS_ID
      The message identifier of the FacesMessage to be created if the conversion to Enum fails and no target class has been provided.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      EnumConverter()
      EnumConverter(Class targetClass)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearInitialState()

      Reset the PartialStateHolder to a non-delta tracking state.
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the value argument to one of the enum constants of the class provided in our constructor.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the enum constant given by the value argument into a String.
      boolean initialStateMarked()

      Return true if delta state changes are being tracked, otherwise false
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void markInitialState()

      The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state.
      void restoreState(FacesContext facesContext, Object object)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext facesContext)
      Gets the state of the instance as a Serializable Object.
      void setTransient(boolean b)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • ENUM_ID

        public static final String ENUM_ID

        The message identifier of the FacesMessage to be created if the conversion to Enum fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by one of the enum constants or the empty string if none can be found.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • ENUM_NO_CLASS_ID

        public static final String ENUM_NO_CLASS_ID

        The message identifier of the FacesMessage to be created if the conversion to Enum fails and no target class has been provided. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • EnumConverter

        public EnumConverter()

      • EnumConverter

        public EnumConverter(Class targetClass)

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)

        Convert the value argument to one of the enum constants of the class provided in our constructor. If no target class argument has been provided to the constructor of this instance, throw a ConverterException containing the ENUM_NO_CLASS_ID message with proper parameters. If the value argument is null or it has a length of zero, return null. Otherwise, perform the equivalent of Enum.valueOf using target class and value and return the Object. If the conversion fails, throw a ConverterException containing the ENUM_ID message with proper parameters.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - the FacesContext for this request.
        component - the UIComponent to which this value will be applied.
        value - the String value to be converted to Object.
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)

        Convert the enum constant given by the value argument into a String. If no target class argument has been provided to the constructor of this instance, throw a ConverterException containing the ENUM_NO_CLASS_ID message with proper parameters. If the value argument is null, return null. If the value is an instance of the provided target class, return its string value by casting it to a java.lang.Enum and returning the result of calling the name() method. Otherwise, throw a ConverterException containing the ENUM_ID message with proper parameters.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • restoreState

        public void restoreState(FacesContext facesContext,
                Object object)
        Description copied from interface: StateHolder

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Specified by:
        restoreState in interface StateHolder

      • saveState

        public Object saveState(FacesContext facesContext)
        Description copied from interface: StateHolder

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Specified by:
        saveState in interface StateHolder

      • setTransient

        public void setTransient(boolean b)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        b - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • markInitialState

        public void markInitialState()
        Description copied from interface: PartialStateHolder

        The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state. The implementor of the interface must ensure that PartialStateHolder.initialStateMarked() returns true from the time markInitialState() is called until PartialStateHolder.clearInitialState() is called, after which time initialStateMarked() must return false. Also, during the time that the instance returns true from initialStateMarked(), the implementation must return only the state that has changed in its implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Specified by:
        markInitialState in interface PartialStateHolder

      • initialStateMarked

        public boolean initialStateMarked()
        Description copied from interface: PartialStateHolder

        Return true if delta state changes are being tracked, otherwise false

        Specified by:
        initialStateMarked in interface PartialStateHolder

      • clearInitialState

        public void clearInitialState()
        Description copied from interface: PartialStateHolder

        Reset the PartialStateHolder to a non-delta tracking state.

        Specified by:
        clearInitialState in interface PartialStateHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.convert

Annotation Type FacesConverter

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface FacesConverter

    The presence of this annotation on a class automatically registers the class with the runtime as a Converter. The value of the value() attribute is taken to be converter-id, the value of the forClass() attribute is taken to be converter-for-class and the fully qualified class name of the class to which this annotation is attached is taken to be the converter-class. The implementation must guarantee that for each class annotated with FacesConverter, found with the algorithm in section JSF.11.5, the proper variant of Application.addConverter() is called. If converter-id is not the empty string, Application.addConverter(java.lang.String,java.lang.String) is called, passing the derived converter-id as the first argument and the derived converter-class as the second argument. If converter-id is the empty string, Application.addConverter(java.lang.Class,java.lang.String) is called, passing the converter-for-class as the first argument and the derived converter-class as the second argument. The implementation must guarantee that all such calls to addConverter() happen during application startup time and before any requests are serviced.

    The preceding text contains an important subtlety which application users should understand. It is not possible to use a single @FacesConverter annotation to register a single Converter implementation both in the by-class and the by-converter-id data structures. One way to achieve this result is to put the actual converter logic in an abstract base class, without a @FacesConverter annotation, and derive two sub-classes, each with a @FacesConverter annotation. One sub-class has a value attribute but no forClass attribute, and the other sub-class has the converse.

    Please see the ViewDeclarationLanguage documentation for <h:selectManyListBox> for another important subtlety regarding converters and collections.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class forClass

      The value of this annotation attribute is taken to be the converter-for-class with which instances of this class of converter can be instantiated by calling Application.createConverter(java.lang.Class).
      String value

      The value of this annotation attribute is taken to be the converter-id with which instances of this class of converter can be instantiated by calling Application.createConverter(java.lang.String).

    • Element Detail

      • value

        public abstract String value

        The value of this annotation attribute is taken to be the converter-id with which instances of this class of converter can be instantiated by calling Application.createConverter(java.lang.String).

        Default:
        ""

      • forClass

        public abstract Class forClass

        The value of this annotation attribute is taken to be the converter-for-class with which instances of this class of converter can be instantiated by calling Application.createConverter(java.lang.Class).

        Default:
        java.lang.Object.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


FloatConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class FloatConverter

  • java.lang.Object
    • javax.faces.convert.FloatConverter
  • All Implemented Interfaces:
    Converter

    public class FloatConverter
extends Object
implements Converter

    Converter implementation for java.lang.Float (and float primitive) values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String FLOAT_ID
      The message identifier of the FacesMessage to be created if the conversion to Float fails.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the Float value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      FloatConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • FLOAT_ID

        public static final String FLOAT_ID

        The message identifier of the FacesMessage to be created if the conversion to Float fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the Float value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • FloatConverter

        public FloatConverter()

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IntegerConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class IntegerConverter

  • java.lang.Object
    • javax.faces.convert.IntegerConverter
  • All Implemented Interfaces:
    Converter

    public class IntegerConverter
extends Object
implements Converter

    Converter implementation for java.lang.Integer (and int primitive) values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String INTEGER_ID
      The message identifier of the FacesMessage to be created if the conversion to Integer fails.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the Integer value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      IntegerConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • INTEGER_ID

        public static final String INTEGER_ID

        The message identifier of the FacesMessage to be created if the conversion to Integer fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the Integer value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • IntegerConverter

        public IntegerConverter()

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces.convert (Java(TM) EE 7 Specification APIs)

javax.faces.convert

Interfaces

  • Converter

Classes

  • BigDecimalConverter
  • BigIntegerConverter
  • BooleanConverter
  • ByteConverter
  • CharacterConverter
  • DateTimeConverter
  • DoubleConverter
  • EnumConverter
  • FloatConverter
  • IntegerConverter
  • LongConverter
  • NumberConverter
  • ShortConverter

Exceptions

  • ConverterException

Annotation Types

  • FacesConverter


javax.faces.convert (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.convert

Contains classes and interfaces defining converters.

See: Description

  • Interface Summary
    Interface Description
    Converter
    Converter is an interface describing a Java class that can perform Object-to-String and String-to-Object conversions between model data objects and a String representation of those objects that is suitable for rendering.
  • Class Summary
    Class Description
    BigDecimalConverter
    Converter implementation for java.math.BigDecimal values.
    BigIntegerConverter
    Converter implementation for java.math.BigInteger values.
    BooleanConverter
    Converter implementation for java.lang.Boolean (and boolean primitive) values.
    ByteConverter
    Converter implementation for java.lang.Byte (and byte primitive) values.
    CharacterConverter
    Converter implementation for java.lang.Character (and char primitive) values.
    DateTimeConverter
    Converter implementation for java.util.Date values.
    DoubleConverter
    Converter implementation for java.lang.Double (and double primitive) values.
    EnumConverter
    Converter implementation for java.lang.Enum (and enum primitive) values.
    FloatConverter
    Converter implementation for java.lang.Float (and float primitive) values.
    IntegerConverter
    Converter implementation for java.lang.Integer (and int primitive) values.
    LongConverter
    Converter implementation for java.lang.Long (and long primitive) values.
    NumberConverter
    Converter implementation for java.lang.Number values.
    ShortConverter
    Converter implementation for java.lang.Short (and short primitive) values.
  • Exception Summary
    Exception Description
    ConverterException
    ConverterException is an exception thrown by the getAsObject() or getAsText() method of a Converter, to indicate that the requested conversion cannot be performed.
  • Annotation Types Summary
    Annotation Type Description
    FacesConverter

    The presence of this annotation on a class automatically registers the class with the runtime as a Converter.

Package javax.faces.convert Description

Contains classes and interfaces defining converters. The main class in this package is Converter.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.convert Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.convert

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.convert.BigDecimalConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.BigIntegerConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.BooleanConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.ByteConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.CharacterConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.DateTimeConverter (implements javax.faces.convert.Converter, javax.faces.component.PartialStateHolder)
    • javax.faces.convert.DoubleConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.EnumConverter (implements javax.faces.convert.Converter, javax.faces.component.PartialStateHolder)
    • javax.faces.convert.FloatConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.IntegerConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.LongConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.NumberConverter (implements javax.faces.convert.Converter, javax.faces.component.PartialStateHolder)
    • javax.faces.convert.ShortConverter (implements javax.faces.convert.Converter)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.convert.ConverterException

Interface Hierarchy

  • javax.faces.convert.Converter

Annotation Type Hierarchy

  • javax.faces.convert.FacesConverter (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LongConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class LongConverter

  • java.lang.Object
    • javax.faces.convert.LongConverter
  • All Implemented Interfaces:
    Converter

    public class LongConverter
extends Object
implements Converter

    Converter implementation for java.lang.Long (and long primitive) values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String LONG_ID
      The message identifier of the FacesMessage to be created if the conversion to Long fails.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the Long value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      LongConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • LONG_ID

        public static final String LONG_ID

        The message identifier of the FacesMessage to be created if the conversion to Long fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the Long value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • LongConverter

        public LongConverter()

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NumberConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class NumberConverter

  • java.lang.Object
    • javax.faces.convert.NumberConverter
  • All Implemented Interfaces:
    PartialStateHolder, StateHolder, Converter

    public class NumberConverter
extends Object
implements Converter, PartialStateHolder

    Converter implementation for java.lang.Number values.

    The getAsObject() method parses a String into an java.lang.Double or java.lang.Long, according to the following algorithm:

    • If the specified String is null, return a null. Otherwise, trim leading and trailing whitespace before proceeding.
    • If the specified String - after trimming - has a zero length, return null.
    • If the locale property is not null, use that Locale for managing parsing. Otherwise, use the Locale from the UIViewRoot.
    • If a pattern has been specified, its syntax must conform the rules specified by java.text.DecimalFormat. Such a pattern will be used to parse, and the type property will be ignored.
    • If a pattern has not been specified, parsing will be based on the type property, which expects a currency, a number, or a percent. The parse pattern for currencies, numbers, and percentages is determined by calling the getCurrencyInstance(), getNumberInstance(), or getPercentInstance() method of the java.text.NumberFormat class, passing in the selected Locale.
    • If the integerOnly property has been set to true, only the integer portion of the String will be parsed. See the JavaDocs for the setParseIntegerOnly() method of the java.text.NumberFormat class for more information.

    The getAsString() method expects a value of type java.lang.Number (or a subclass), and creates a formatted String according to the following algorithm:

    • If the specified value is null, return a zero-length String.
    • If the specified value is a String, return it unmodified.
    • If the locale property is not null, use that Locale for managing formatting. Otherwise, use the Locale from the FacesContext.
    • If a pattern has been specified, its syntax must conform the rules specified by java.text.DecimalFormat. Such a pattern will be used to format, and the type property (along with related formatting options described in the next paragraph) will be ignored.
    • If a pattern has not been specified, formatting will be based on the type property, which formats the value as a currency, a number, or a percent. The format pattern for currencies, numbers, and percentages is determined by calling the percentages is determined by calling the getCurrencyInstance(), getNumberInstance(), or getPercentInstance() method of the java.text.NumberFormat class, passing in the selected Locale. In addition, the following properties will be applied to the format pattern, if specified:
      • If the groupingUsed property is true, the setGroupingUsed(true) method on the corresponding NumberFormat instance will be called.
      • The minimum and maximum number of digits in the integer and fractional portions of the result will be configured based on any values set for the maxFractionDigits, maxIntegerDigits, minFractionDigits, and minIntegerDigits properties.
      • If the type is set to currency, it is also possible to configure the currency symbol to be used, using either the currencyCode or currencySymbol properties. If both are set, the value for currencyCode takes precedence on a JDK 1.4 (or later) JVM; otherwise, the value for currencySymbol takes precedence.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String CURRENCY_ID
      The message identifier of the FacesMessage to be created if the conversion to Number fails.
      static String NUMBER_ID
      The message identifier of the FacesMessage to be created if the conversion to Number fails.
      static String PATTERN_ID
      The message identifier of the FacesMessage to be created if the conversion to Number fails.
      static String PERCENT_ID
      The message identifier of the FacesMessage to be created if the conversion to Number fails.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the Number value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      NumberConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearInitialState()

      Reset the PartialStateHolder to a non-delta tracking state.
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
      String getCurrencyCode()
      Return the ISO 4217 currency code used by getAsString() with a type of currency.
      String getCurrencySymbol()
      Return the currency symbol used by getAsString() with a type of currency.
      Locale getLocale()
      Return the Locale to be used when parsing numbers.
      int getMaxFractionDigits()
      Return the maximum number of digits getAsString() should render in the fraction portion of the result.
      int getMaxIntegerDigits()
      Return the maximum number of digits getAsString() should render in the integer portion of the result.
      int getMinFractionDigits()
      Return the minimum number of digits getAsString() should render in the fraction portion of the result.
      int getMinIntegerDigits()
      Return the minimum number of digits getAsString() should render in the integer portion of the result.
      String getPattern()
      Return the format pattern to be used when formatting and parsing numbers.
      String getType()
      Return the number type to be used when formatting and parsing numbers.
      boolean initialStateMarked()

      Return true if delta state changes are being tracked, otherwise false
      boolean isGroupingUsed()
      Return true if getAsString should include grouping separators if necessary.
      boolean isIntegerOnly()
      Return true if only the integer portion of the given value should be returned from getAsObject().
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void markInitialState()

      The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setCurrencyCode(String currencyCode)
      Set the ISO 4217 currency code used by getAsString() with a type of currency.
      void setCurrencySymbol(String currencySymbol)
      Set the currency symbol used by getAsString() with a type of currency.
      void setGroupingUsed(boolean groupingUsed)
      Set the flag indicating whether getAsString() should include grouping separators if necessary.
      void setIntegerOnly(boolean integerOnly)
      Set to true if only the integer portion of the given value should be returned from getAsObject().
      void setLocale(Locale locale)
      Set the Locale to be used when parsing numbers.
      void setMaxFractionDigits(int maxFractionDigits)
      Set the maximum number of digits getAsString() should render in the fraction portion of the result.
      void setMaxIntegerDigits(int maxIntegerDigits)
      Set the maximum number of digits getAsString() should render in the integer portion of the result.
      void setMinFractionDigits(int minFractionDigits)
      Set the minimum number of digits getAsString() should render in the fraction portion of the result.
      void setMinIntegerDigits(int minIntegerDigits)
      Set the minimum number of digits getAsString() should render in the integer portion of the result.
      void setPattern(String pattern)
      Set the format pattern to be used when formatting and parsing numbers.
      void setTransient(boolean transientFlag)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
      void setType(String type)
      Set the number type to be used when formatting and parsing numbers.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • CURRENCY_ID

        public static final String CURRENCY_ID

        The message identifier of the FacesMessage to be created if the conversion to Number fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • NUMBER_ID

        public static final String NUMBER_ID

        The message identifier of the FacesMessage to be created if the conversion to Number fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
          • HA
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • PATTERN_ID

        public static final String PATTERN_ID

        The message identifier of the FacesMessage to be created if the conversion to Number fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • PERCENT_ID

        public static final String PERCENT_ID

        The message identifier of the FacesMessage to be created if the conversion to Number fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the Number value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • NumberConverter

        public NumberConverter()

    • Method Detail

      • getCurrencyCode

        public String getCurrencyCode()

        Return the ISO 4217 currency code used by getAsString() with a type of currency. If not set, the value used will be based on the formatting Locale.

      • setCurrencyCode

        public void setCurrencyCode(String currencyCode)

        Set the ISO 4217 currency code used by getAsString() with a type of currency.

        Parameters:
        currencyCode - The new currency code

      • getCurrencySymbol

        public String getCurrencySymbol()

        Return the currency symbol used by getAsString() with a type of currency. If not set, the value used will be based on the formatting Locale.

      • setCurrencySymbol

        public void setCurrencySymbol(String currencySymbol)

        Set the currency symbol used by getAsString() with a type of currency.

        Parameters:
        currencySymbol - The new currency symbol

      • isGroupingUsed

        public boolean isGroupingUsed()

        Return true if getAsString should include grouping separators if necessary. If not modified, the default value is true.

      • setGroupingUsed

        public void setGroupingUsed(boolean groupingUsed)

        Set the flag indicating whether getAsString() should include grouping separators if necessary.

        Parameters:
        groupingUsed - The new grouping used flag

      • isIntegerOnly

        public boolean isIntegerOnly()

        Return true if only the integer portion of the given value should be returned from getAsObject(). If not modified, the default value is false.

      • setIntegerOnly

        public void setIntegerOnly(boolean integerOnly)

        Set to true if only the integer portion of the given value should be returned from getAsObject().

        Parameters:
        integerOnly - The new integer-only flag

      • getMaxFractionDigits

        public int getMaxFractionDigits()

        Return the maximum number of digits getAsString() should render in the fraction portion of the result.

      • setMaxFractionDigits

        public void setMaxFractionDigits(int maxFractionDigits)

        Set the maximum number of digits getAsString() should render in the fraction portion of the result. If not set, the number of digits depends on the value being converted.

        Parameters:
        maxFractionDigits - The new limit

      • getMaxIntegerDigits

        public int getMaxIntegerDigits()

        Return the maximum number of digits getAsString() should render in the integer portion of the result.

      • setMaxIntegerDigits

        public void setMaxIntegerDigits(int maxIntegerDigits)

        Set the maximum number of digits getAsString() should render in the integer portion of the result. If not set, the number of digits depends on the value being converted.

        Parameters:
        maxIntegerDigits - The new limit

      • getMinFractionDigits

        public int getMinFractionDigits()

        Return the minimum number of digits getAsString() should render in the fraction portion of the result.

      • setMinFractionDigits

        public void setMinFractionDigits(int minFractionDigits)

        Set the minimum number of digits getAsString() should render in the fraction portion of the result. If not set, the number of digits depends on the value being converted.

        Parameters:
        minFractionDigits - The new limit

      • getMinIntegerDigits

        public int getMinIntegerDigits()

        Return the minimum number of digits getAsString() should render in the integer portion of the result.

      • setMinIntegerDigits

        public void setMinIntegerDigits(int minIntegerDigits)

        Set the minimum number of digits getAsString() should render in the integer portion of the result. If not set, the number of digits depends on the value being converted.

        Parameters:
        minIntegerDigits - The new limit

      • getLocale

        public Locale getLocale()

        Return the Locale to be used when parsing numbers. If this value is null, the Locale stored in the UIViewRoot for the current request will be utilized.

      • setLocale

        public void setLocale(Locale locale)

        Set the Locale to be used when parsing numbers. If set to null, the Locale stored in the UIViewRoot for the current request will be utilized.

        Parameters:
        locale - The new Locale (or null)

      • getPattern

        public String getPattern()

        Return the format pattern to be used when formatting and parsing numbers.

      • setPattern

        public void setPattern(String pattern)

        Set the format pattern to be used when formatting and parsing numbers. Valid values are those supported by java.text.DecimalFormat. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

        Parameters:
        pattern - The new format pattern

      • getType

        public String getType()

        Return the number type to be used when formatting and parsing numbers. If not modified, the default type is number.

      • setType

        public void setType(String type)

        Set the number type to be used when formatting and parsing numbers. Valid values are currency, number, or percent. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

        Parameters:
        type - The new number style

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • saveState

        public Object saveState(FacesContext context)
        Description copied from interface: StateHolder

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)
        Description copied from interface: StateHolder

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Specified by:
        restoreState in interface StateHolder

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean transientFlag)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        transientFlag - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.

      • markInitialState

        public void markInitialState()
        Description copied from interface: PartialStateHolder

        The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state. The implementor of the interface must ensure that PartialStateHolder.initialStateMarked() returns true from the time markInitialState() is called until PartialStateHolder.clearInitialState() is called, after which time initialStateMarked() must return false. Also, during the time that the instance returns true from initialStateMarked(), the implementation must return only the state that has changed in its implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Specified by:
        markInitialState in interface PartialStateHolder

      • initialStateMarked

        public boolean initialStateMarked()
        Description copied from interface: PartialStateHolder

        Return true if delta state changes are being tracked, otherwise false

        Specified by:
        initialStateMarked in interface PartialStateHolder

      • clearInitialState

        public void clearInitialState()
        Description copied from interface: PartialStateHolder

        Reset the PartialStateHolder to a non-delta tracking state.

        Specified by:
        clearInitialState in interface PartialStateHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ShortConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.convert

Class ShortConverter

  • java.lang.Object
    • javax.faces.convert.ShortConverter
  • All Implemented Interfaces:
    Converter

    public class ShortConverter
extends Object
implements Converter

    Converter implementation for java.lang.Short (and short primitive) values.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONVERTER_ID
      The standard converter id for this converter.
      static String SHORT_ID
      The message identifier of the FacesMessage to be created if the conversion to Short fails.
      static String STRING_ID
      The message identifier of the FacesMessage to be created if the conversion of the Short value to String fails.

      • Fields inherited from interface javax.faces.convert.Converter

        DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      ShortConverter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAsObject(FacesContext context, UIComponent component, String value)
      Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
      String getAsString(FacesContext context, UIComponent component, Object value)
      Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONVERTER_ID

        public static final String CONVERTER_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • SHORT_ID

        public static final String SHORT_ID

        The message identifier of the FacesMessage to be created if the conversion to Short fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the unconverted value.
        • {1} replaced by an example value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • STRING_ID

        public static final String STRING_ID

        The message identifier of the FacesMessage to be created if the conversion of the Short value to String fails. The message format string for this message may optionally include the following placeholders:

        • {0} relaced by the unconverted value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • ShortConverter

        public ShortConverter()

    • Method Detail

      • getAsObject

        public Object getAsObject(FacesContext context,
                 UIComponent component,
                 String value)
        Description copied from interface: Converter

        Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

        Specified by:
        getAsObject in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - String value to be converted (may be null)
        Returns:
        null if the value to convert is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null

      • getAsString

        public String getAsString(FacesContext context,
                 UIComponent component,
                 Object value)
        Description copied from interface: Converter

        Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

        Specified by:
        getAsString in interface Converter
        Parameters:
        context - FacesContext for the request being processed
        component - UIComponent with which this model object value is associated
        value - Model object value to be converted (may be null)
        Returns:
        a zero-length String if value is null, otherwise the result of the conversion
        Throws:
        ConverterException - if conversion cannot be successfully performed
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.convert (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.convert

  • Packages that use javax.faces.convert
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.render
    Classes and interfaces defining the rendering model.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
  • Classes in javax.faces.convert used by javax.faces.application
    Class and Description
    Converter
    Converter is an interface describing a Java class that can perform Object-to-String and String-to-Object conversions between model data objects and a String representation of those objects that is suitable for rendering.
  • Classes in javax.faces.convert used by javax.faces.component
    Class and Description
    Converter
    Converter is an interface describing a Java class that can perform Object-to-String and String-to-Object conversions between model data objects and a String representation of those objects that is suitable for rendering.
    ConverterException
    ConverterException is an exception thrown by the getAsObject() or getAsText() method of a Converter, to indicate that the requested conversion cannot be performed.
  • Classes in javax.faces.convert used by javax.faces.convert
    Class and Description
    Converter
    Converter is an interface describing a Java class that can perform Object-to-String and String-to-Object conversions between model data objects and a String representation of those objects that is suitable for rendering.
  • Classes in javax.faces.convert used by javax.faces.render
    Class and Description
    ConverterException
    ConverterException is an exception thrown by the getAsObject() or getAsText() method of a Converter, to indicate that the requested conversion cannot be performed.
  • Classes in javax.faces.convert used by javax.faces.webapp
    Class and Description
    Converter
    Converter is an interface describing a Java class that can perform Object-to-String and String-to-Object conversions between model data objects and a String representation of those objects that is suitable for rendering.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.BigDecimalConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.BigDecimalConverter

No usage of javax.faces.convert.BigDecimalConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.BigIntegerConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.BigIntegerConverter

No usage of javax.faces.convert.BigIntegerConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.BooleanConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.BooleanConverter

No usage of javax.faces.convert.BooleanConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.ByteConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.ByteConverter

No usage of javax.faces.convert.ByteConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.CharacterConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.CharacterConverter

No usage of javax.faces.convert.CharacterConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.ConverterException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.ConverterException

  • Packages that use ConverterException
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of ConverterException in javax.faces.component

      Methods in javax.faces.component that throw ConverterException
      Modifier and Type Method and Description
      protected Object UIViewParameter.getConvertedValue(FacesContext context, Object submittedValue)

      Because this class has no Renderer, leverage the one from the standard HTML_BASIC RenderKit with component-family: javax.faces.Input and renderer-type: javax.faces.Text and call its Renderer.getConvertedValue(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object) method.
      protected Object UIInput.getConvertedValue(FacesContext context, Object newSubmittedValue)
      Convert the submitted value into a "local value" of the appropriate data type, if necessary.
      String UIViewParameter.getStringValueFromModel(FacesContext context)

      Manually perform standard conversion steps to get a string value from the value expression.

    • Uses of ConverterException in javax.faces.render

      Methods in javax.faces.render that throw ConverterException
      Modifier and Type | Method and Description
      Object | RendererWrapper.getConvertedValue(FacesContext context, UIComponent component, Object submittedValue)
      Object Renderer.getConvertedValue(FacesContext context, UIComponent component, Object submittedValue)
      Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.DateTimeConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.DateTimeConverter

No usage of javax.faces.convert.DateTimeConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.DoubleConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.DoubleConverter

No usage of javax.faces.convert.DoubleConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.EnumConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.EnumConverter

No usage of javax.faces.convert.EnumConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.FacesConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.FacesConverter

No usage of javax.faces.convert.FacesConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.FloatConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.FloatConverter

No usage of javax.faces.convert.FloatConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.IntegerConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.IntegerConverter

No usage of javax.faces.convert.IntegerConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.LongConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.LongConverter

No usage of javax.faces.convert.LongConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.NumberConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.NumberConverter

No usage of javax.faces.convert.NumberConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.convert.ShortConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.convert.ShortConverter

No usage of javax.faces.convert.ShortConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.convert.Converter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.convert.Converter

  • Packages that use Converter
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.convert
    Contains classes and interfaces defining converters.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of Converter in javax.faces.application

      Methods in javax.faces.application that return Converter
      Modifier and Type Method and Description
      Converter ApplicationWrapper.createConverter(Class<?> targetClass)

      The default behavior of this method is to call Application.createConverter(Class) on the wrapped Application object.
      abstract Converter Application.createConverter(Class<?> targetClass)
      Instantiate and return a new Converter instance of the class that has registered itself as capable of performing conversions for objects of the specified type.
      Converter ApplicationWrapper.createConverter(String converterId)

      The default behavior of this method is to call Application.createConverter(String) on the wrapped Application object.
      abstract Converter Application.createConverter(String converterId)
      Instantiate and return a new Converter instance of the class specified by a previous call to addConverter() for the specified converter id.

    • Uses of Converter in javax.faces.component

      Methods in javax.faces.component that return Converter
      Modifier and Type | Method and Description
      Converter ValueHolder.getConverter()
      Return the Converter (if any) that is registered for this UIComponent.
      Converter | UIOutput.getConverter()
      Methods in javax.faces.component with parameters of type Converter
      Modifier and Type | Method and Description
      void ValueHolder.setConverter(Converter converter)
      Set the Converter (if any) that is registered for this UIComponent.
      void | UIOutput.setConverter(Converter converter)

    • Uses of Converter in javax.faces.convert

      Classes in javax.faces.convert that implement Converter
      Modifier and Type Class and Description
      class  BigDecimalConverter
      Converter implementation for java.math.BigDecimal values.
      class  BigIntegerConverter
      Converter implementation for java.math.BigInteger values.
      class  BooleanConverter
      Converter implementation for java.lang.Boolean (and boolean primitive) values.
      class  ByteConverter
      Converter implementation for java.lang.Byte (and byte primitive) values.
      class  CharacterConverter
      Converter implementation for java.lang.Character (and char primitive) values.
      class  DateTimeConverter
      Converter implementation for java.util.Date values.
      class  DoubleConverter
      Converter implementation for java.lang.Double (and double primitive) values.
      class  EnumConverter
      Converter implementation for java.lang.Enum (and enum primitive) values.
      class  FloatConverter
      Converter implementation for java.lang.Float (and float primitive) values.
      class  IntegerConverter
      Converter implementation for java.lang.Integer (and int primitive) values.
      class  LongConverter
      Converter implementation for java.lang.Long (and long primitive) values.
      class  NumberConverter
      Converter implementation for java.lang.Number values.
      class  ShortConverter
      Converter implementation for java.lang.Short (and short primitive) values.

    • Uses of Converter in javax.faces.webapp

      Methods in javax.faces.webapp that return Converter
      Modifier and Type Method and Description
      protected Converter ConverterTag.createConverter()
      Deprecated.
      Create and return a new Converter to be registered on our surrounding UIComponent.
      protected abstract Converter ConverterELTag.createConverter()
      Create and return a new Converter to be registered on our surrounding UIComponent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


CompositeComponentExpressionHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.el

Interface CompositeComponentExpressionHolder

  • public interface CompositeComponentExpressionHolder
    This interface must be implemented by the Map returned by the composite component ELResolver, described in section JSF.5.6.2.2 of the specification, when evaluating #{cc.attrs} epressions.
    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      ValueExpression | getExpression(String name)

    • Method Detail

      • getExpression

        ValueExpression getExpression(String name)
        Parameters:
        name - that attribute name which may be assocated with a ValueExpression
        Returns:
        the ValueExpression associated with name otherwise return null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EvaluationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.el

Class EvaluationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.el.EvaluationException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    MethodNotFoundException, PropertyNotFoundException, ReferenceSyntaxException
    Deprecated.
    This has been replaced by ELException.

    public class EvaluationException
extends FacesException

    An exception reporting an error that occurred during the evaluation of an expression in a MethodBinding or ValueBinding.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EvaluationException()
      Deprecated.
      Construct a new exception with no detail message or root cause.
      EvaluationException(String message)
      Deprecated.
      Construct a new exception with the specified detail message and no root cause.
      EvaluationException(String message, Throwable cause)
      Deprecated.
      Construct a new exception with the specified detail message and root cause.
      EvaluationException(Throwable cause)
      Deprecated.
      Construct a new exception with the specified root cause.

    • Method Summary

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EvaluationException

        public EvaluationException()
        Deprecated.

        Construct a new exception with no detail message or root cause.

      • EvaluationException

        public EvaluationException(String message)
        Deprecated.

        Construct a new exception with the specified detail message and no root cause.

        Parameters:
        message - The detail message for this exception

      • EvaluationException

        public EvaluationException(Throwable cause)
        Deprecated.

        Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

        Parameters:
        cause - The root cause for this exception

      • EvaluationException

        public EvaluationException(String message,
                   Throwable cause)
        Deprecated.

        Construct a new exception with the specified detail message and root cause.

        Parameters:
        message - The detail message for this exception
        cause - The root cause for this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces.el (Java(TM) EE 7 Specification APIs)

javax.faces.el

Interfaces

  • CompositeComponentExpressionHolder

Classes

  • MethodBinding
  • PropertyResolver
  • ValueBinding
  • VariableResolver

Exceptions

  • EvaluationException
  • MethodNotFoundException
  • PropertyNotFoundException
  • ReferenceSyntaxException


javax.faces.el (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.el

DEPRECATED Classes and interfaces for evaluating and processing reference expressions.

See: Description

  • Interface Summary
    Interface Description
    CompositeComponentExpressionHolder
    This interface must be implemented by the Map returned by the composite component ELResolver, described in section JSF.5.6.2.2 of the specification, when evaluating #{cc.attrs} epressions.
  • Class Summary
    Class Description
    MethodBinding Deprecated
    This has been replaced by MethodExpression.
    PropertyResolver Deprecated
    This has been replaced by ELResolver.
    ValueBinding Deprecated
    This has been replaced by ValueExpression.
    VariableResolver Deprecated
    This has been replaced by ELResolver when operating with a null base argument.
  • Exception Summary
    Exception Description
    EvaluationException Deprecated
    This has been replaced by ELException.
    MethodNotFoundException Deprecated
    This has been replaced by MethodNotFoundException.
    PropertyNotFoundException Deprecated
    This has been replaced by PropertyNotFoundException.
    ReferenceSyntaxException Deprecated
    This has been replaced by ELException.

Package javax.faces.el Description

DEPRECATED Classes and interfaces for evaluating and processing reference expressions. The main class in this package is ValueBinding, which is the runtime representation of a reference expression. ValueBinding provides methods to get and set the value of the expression.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.el Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.el

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.el.MethodBinding
    • javax.faces.el.PropertyResolver
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.el.EvaluationException
              • javax.faces.el.MethodNotFoundException
              • javax.faces.el.PropertyNotFoundException
              • javax.faces.el.ReferenceSyntaxException
    • javax.faces.el.ValueBinding
    • javax.faces.el.VariableResolver

Interface Hierarchy

  • javax.faces.el.CompositeComponentExpressionHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MethodBinding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.el

Class MethodBinding

  • java.lang.Object
    • javax.faces.el.MethodBinding
  • Deprecated.
    This has been replaced by MethodExpression.

    public abstract class MethodBinding
extends Object

    MethodBinding is an object that can be used to call an arbitrary public method, on an instance that is acquired by evaluatng the leading portion of a method binding expression via a ValueBinding. An immutable MethodBinding for a particular method binding expression can be acquired by calling the createMethodBinding() method of the Application instance for this web application.

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodBinding()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getExpressionString()
      Deprecated.
      Return the (possibly null) expression String, with leading and trailing delimiters, from which this MethodBinding was built.
      abstract Class getType(FacesContext context)
      Deprecated.
      Return the Java class representing the return type from the method identified by this method binding expression.
      abstract Object invoke(FacesContext context, Object[] params)
      Deprecated.
      Return the return value (if any) resulting from a call to the method identified by this method binding expression, passing it the specified parameters, relative to the specified FacesContext.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MethodBinding

        public MethodBinding()
        Deprecated.

    • Method Detail

      • invoke

        public abstract Object invoke(FacesContext context,
            Object[] params)
                       throws EvaluationException,
                              MethodNotFoundException
        Deprecated.

        Return the return value (if any) resulting from a call to the method identified by this method binding expression, passing it the specified parameters, relative to the specified FacesContext.

        Parameters:
        context - FacesContext for the current request
        params - Array of parameters to be passed to the called method, or null for no parameters
        Throws:
        EvaluationException - if an exception is thrown by the called method (the thrown exception must be included as the cause property of this exception)
        MethodNotFoundException - if no suitable method can be found
        NullPointerException - if context is null

      • getType

        public abstract Class getType(FacesContext context)
                       throws MethodNotFoundException
        Deprecated.

        Return the Java class representing the return type from the method identified by this method binding expression.

        Parameters:
        context - FacesContext for the current request
        Throws:
        MethodNotFoundException - if no suitable method can be found
        NullPointerException - if context is null

      • getExpressionString

        public String getExpressionString()
        Deprecated.

        Return the (possibly null) expression String, with leading and trailing delimiters, from which this MethodBinding was built. The default implementation returns null.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MethodNotFoundException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.el

Class MethodNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.el.EvaluationException
              • javax.faces.el.MethodNotFoundException
  • All Implemented Interfaces:
    Serializable
    Deprecated.
    This has been replaced by MethodNotFoundException.

    public class MethodNotFoundException
extends EvaluationException

    An exception caused by a method name that cannot be resolved against a base object.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodNotFoundException()
      Deprecated.
      Construct a new exception with no detail message or root cause.
      MethodNotFoundException(String message)
      Deprecated.
      Construct a new exception with the specified detail message and no root cause.
      MethodNotFoundException(String message, Throwable cause)
      Deprecated.
      Construct a new exception with the specified detail message and root cause.
      MethodNotFoundException(Throwable cause)
      Deprecated.
      Construct a new exception with the specified root cause.

    • Method Summary

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MethodNotFoundException

        public MethodNotFoundException()
        Deprecated.

        Construct a new exception with no detail message or root cause.

      • MethodNotFoundException

        public MethodNotFoundException(String message)
        Deprecated.

        Construct a new exception with the specified detail message and no root cause.

        Parameters:
        message - The detail message for this exception

      • MethodNotFoundException

        public MethodNotFoundException(Throwable cause)
        Deprecated.

        Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

        Parameters:
        cause - The root cause for this exception

      • MethodNotFoundException

        public MethodNotFoundException(String message,
                       Throwable cause)
        Deprecated.

        Construct a new exception with the specified detail message and root cause.

        Parameters:
        message - The detail message for this exception
        cause - The root cause for this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PropertyNotFoundException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.el

Class PropertyNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.el.EvaluationException
              • javax.faces.el.PropertyNotFoundException
  • All Implemented Interfaces:
    Serializable
    Deprecated.
    This has been replaced by PropertyNotFoundException.

    public class PropertyNotFoundException
extends EvaluationException

    An exception caused by a property name that cannot be resolved against a base object.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      PropertyNotFoundException()
      Deprecated.
      Construct a new exception with no detail message or root cause.
      PropertyNotFoundException(String message)
      Deprecated.
      Construct a new exception with the specified detail message and no root cause.
      PropertyNotFoundException(String message, Throwable cause)
      Deprecated.
      Construct a new exception with the specified detail message and root cause.
      PropertyNotFoundException(Throwable cause)
      Deprecated.
      Construct a new exception with the specified root cause.

    • Method Summary

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PropertyNotFoundException

        public PropertyNotFoundException()
        Deprecated.

        Construct a new exception with no detail message or root cause.

      • PropertyNotFoundException

        public PropertyNotFoundException(String message)
        Deprecated.

        Construct a new exception with the specified detail message and no root cause.

        Parameters:
        message - The detail message for this exception

      • PropertyNotFoundException

        public PropertyNotFoundException(Throwable cause)
        Deprecated.

        Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

        Parameters:
        cause - The root cause for this exception

      • PropertyNotFoundException

        public PropertyNotFoundException(String message,
                         Throwable cause)
        Deprecated.

        Construct a new exception with the specified detail message and root cause.

        Parameters:
        message - The detail message for this exception
        cause - The root cause for this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PropertyResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.el

Class PropertyResolver

  • java.lang.Object
    • javax.faces.el.PropertyResolver
  • Deprecated.
    This has been replaced by ELResolver.

    public abstract class PropertyResolver
extends Object

    PropertyResolver represents a pluggable mechanism for accessing a "property" of an underlying Java object instance. Different PropertyResolver implementations can support property resolution on instances of different Java classes (such as introspection-based access to properties of a JavaBeans component, or get() and put() calls on a java.util.Map instance).

    All implementations must respect the rules for JavaBeans component, java.util.Map, java.util.List and array instances defined for each method but are allowed to add custom semantics for other types.

    • Constructor Summary

      Constructors
      Constructor and Description
      PropertyResolver()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Class getType(Object base, int index)
      Deprecated.
      Return the java.lang.Class representing the type of the specified index.
      abstract Class getType(Object base, Object property)
      Deprecated.
      Return the java.lang.Class representing the type of the specified property.
      abstract Object getValue(Object base, int index)
      Deprecated.
      Return the value at the specified index of the specified base object.
      abstract Object getValue(Object base, Object property)
      Deprecated.
      Return the value of the specified property from the specified base object.
      abstract boolean isReadOnly(Object base, int index)
      Deprecated.
      Checks if the specified index is read-only.
      abstract boolean isReadOnly(Object base, Object property)
      Deprecated.
      Checks if the specified property is read-only.
      abstract void setValue(Object base, int index, Object value)
      Deprecated.
      Set the value at the specified index of the specified base object.
      abstract void setValue(Object base, Object property, Object value)
      Deprecated.
      Set the specified value of the specified property on the specified base object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PropertyResolver

        public PropertyResolver()
        Deprecated.

    • Method Detail

      • getValue

        public abstract Object getValue(Object base,
              Object property)
                         throws EvaluationException,
                                PropertyNotFoundException
        Deprecated.

        Return the value of the specified property from the specified base object.

        For a bean base object, the property is coerced to a String and used as the property name. For all other base object types (e.g., a Map), the property is used without any coercing.

        Parameters:
        base - The base object whose property value is to be returned
        property - The property to be returned
        Returns:
        The property value, or null if base or property is null, or if the property doesn't exist and the base object is a Map instance
        Throws:
        EvaluationException - if an exception is thrown while getting the property value (the thrown exception must be included as the cause property of this exception)
        PropertyNotFoundException - if the specified property for a bean base object does not exist or is not readable

      • getValue

        public abstract Object getValue(Object base,
              int index)
                         throws EvaluationException,
                                PropertyNotFoundException
        Deprecated.

        Return the value at the specified index of the specified base object.

        Parameters:
        base - The base object whose property value is to be returned
        index - The index of the value to return
        Returns:
        The property value, or null if base is null, or if the index is out of bounds for the base object
        Throws:
        EvaluationException - if an exception is thrown while getting the property value (the thrown exception must be included as the cause property of this exception)
        PropertyNotFoundException - if the index is out of bounds or if base is null

      • setValue

        public abstract void setValue(Object base,
            Object property,
            Object value)
                       throws EvaluationException,
                              PropertyNotFoundException
        Deprecated.

        Set the specified value of the specified property on the specified base object.

        For a bean base object, the property is coerced to a String and used as the property name. For all other base object types (e.g., a Map), the property is used without any coercing.

        Parameters:
        base - The base object whose property value is to be set
        property - The property to be set
        value - The value of the property to be set
        Throws:
        EvaluationException - if an exception is thrown while setting the property value (the thrown exception must be included as the cause property of this exception)
        PropertyNotFoundException - if the specified bean base object property does not exist or is not writeable, or if base or name is null

      • setValue

        public abstract void setValue(Object base,
            int index,
            Object value)
                       throws EvaluationException,
                              PropertyNotFoundException
        Deprecated.

        Set the value at the specified index of the specified base object.

        Parameters:
        base - The base object whose property value is to be set
        index - The index of the value to set
        value - The value to be set
        Throws:
        EvaluationException - if an exception is thrown while setting the property value (the thrown exception must be included as the cause property of this exception)
        PropertyNotFoundException - if the index is out of bounds or if base is null

      • isReadOnly

        public abstract boolean isReadOnly(Object base,
                 Object property)
                            throws EvaluationException,
                                   PropertyNotFoundException
        Deprecated.

        Checks if the specified property is read-only.

        For a bean base object, the property is coerced to a String and used as the property name. For all other base object types (e.g., a Map), the property is used without any coercing.

        Parameters:
        base - The base object whose property is to be analyzed
        property - The property to be analyzed
        Returns:
        true if the specified property of the specified base object is known to be immutable; otherwise false
        Throws:
        EvaluationException - if an exception is thrown while testing the property (the thrown exception must be included as the cause property of this exception)
        PropertyNotFoundException - if the specified bean base object property does not exist or if base or property is null

      • isReadOnly

        public abstract boolean isReadOnly(Object base,
                 int index)
                            throws EvaluationException,
                                   PropertyNotFoundException
        Deprecated.

        Checks if the specified index is read-only.

        Parameters:
        base - The base object whose property is to be analyzed
        index - The index of the value whose type is to be returned
        Returns:
        true if the value at the specified index of the specified base object is known to be immutable; otherwise, false
        Throws:
        EvaluationException - if an exception is thrown while testing the property (the thrown exception must be included as the cause property of this exception)
        PropertyNotFoundException - if the index is out of bounds or if base is null

      • getType

        public abstract Class getType(Object base,
            Object property)
                       throws EvaluationException,
                              PropertyNotFoundException
        Deprecated.

        Return the java.lang.Class representing the type of the specified property. An instance of any Object of that type my be set as the value of that property, as long as the property is not read-only. The actual value of the property, if non-null, is guaranteed to be an instance of this type, or an instance of a subclass of this type. This method is also useful for discovering the type of Objects that may be set as the value of the property.

        For a bean base object, the property is coerced to a String and used as the property name. For all other base object types (e.g., a Map), the property is used without any coercing.

        Parameters:
        base - The base object whose property is to be analyzed
        property - The property to be analyzed
        Returns:
        the java.lang.Class representing the type of the specified property of the specified base object, if it can be determined; otherwise null
        Throws:
        EvaluationException - if an exception is thrown while testing the property (the thrown exception must be included as the cause property of this exception)
        PropertyNotFoundException - if the specified bean base object property does not exist or if base or property is null

      • getType

        public abstract Class getType(Object base,
            int index)
                       throws EvaluationException,
                              PropertyNotFoundException
        Deprecated.

        Return the java.lang.Class representing the type of the specified index.

        Parameters:
        base - The base object whose property is to be analyzed
        index - The index of the value whose type is to be returned
        Returns:
        The java.lang.Class representing the type of value at the specified index of the specified base object, if it can be determined; otherwise null
        Throws:
        EvaluationException - if an exception is thrown while testing the property (the thrown exception must be included as the cause property of this exception)
        PropertyNotFoundException - if the index is out of bounds or if base is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ReferenceSyntaxException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.el

Class ReferenceSyntaxException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.el.EvaluationException
              • javax.faces.el.ReferenceSyntaxException
  • All Implemented Interfaces:
    Serializable
    Deprecated.
    This has been replaced by ELException.

    public class ReferenceSyntaxException
extends EvaluationException

    An exception reporting a syntax error in a method binding expression or value binding expression.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ReferenceSyntaxException()
      Deprecated.
      Construct a new exception with no detail message or root cause.
      ReferenceSyntaxException(String message)
      Deprecated.
      Construct a new exception with the specified detail message and no root cause.
      ReferenceSyntaxException(String message, Throwable cause)
      Deprecated.
      Construct a new exception with the specified detail message and root cause.
      ReferenceSyntaxException(Throwable cause)
      Deprecated.
      Construct a new exception with the specified root cause.

    • Method Summary

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ReferenceSyntaxException

        public ReferenceSyntaxException()
        Deprecated.

        Construct a new exception with no detail message or root cause.

      • ReferenceSyntaxException

        public ReferenceSyntaxException(String message)
        Deprecated.

        Construct a new exception with the specified detail message and no root cause.

        Parameters:
        message - The detail message for this exception

      • ReferenceSyntaxException

        public ReferenceSyntaxException(Throwable cause)
        Deprecated.

        Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

        Parameters:
        cause - The root cause for this exception

      • ReferenceSyntaxException

        public ReferenceSyntaxException(String message,
                        Throwable cause)
        Deprecated.

        Construct a new exception with the specified detail message and root cause.

        Parameters:
        message - The detail message for this exception
        cause - The root cause for this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.el (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.el

  • Packages that use javax.faces.el
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.el
    DEPRECATED Classes and interfaces for evaluating and processing reference expressions.
  • Classes in javax.faces.el used by javax.faces.application
    Class and Description
    MethodBinding
    Deprecated.
    This has been replaced by MethodExpression.
    PropertyResolver
    Deprecated.
    This has been replaced by ELResolver.
    ReferenceSyntaxException
    Deprecated.
    This has been replaced by ELException.
    ValueBinding
    Deprecated.
    This has been replaced by ValueExpression.
    VariableResolver
    Deprecated.
    This has been replaced by ELResolver when operating with a null base argument.
  • Classes in javax.faces.el used by javax.faces.component
    Class and Description
    MethodBinding
    Deprecated.
    This has been replaced by MethodExpression.
    ValueBinding
    Deprecated.
    This has been replaced by ValueExpression.
  • Classes in javax.faces.el used by javax.faces.el
    Class and Description
    EvaluationException
    Deprecated.
    This has been replaced by ELException.
    MethodNotFoundException
    Deprecated.
    This has been replaced by MethodNotFoundException.
    PropertyNotFoundException
    Deprecated.
    This has been replaced by PropertyNotFoundException.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValueBinding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.el

Class ValueBinding

  • java.lang.Object
    • javax.faces.el.ValueBinding
  • Deprecated.
    This has been replaced by ValueExpression.

    public abstract class ValueBinding
extends Object

    ValueBinding is an object that can be used to access the property represented by an action or value binding expression. An immutable ValueBinding for a particular value binding can be acquired by calling the createValueBinding() method of the Application instance for this web application.

    • Constructor Summary

      Constructors
      Constructor and Description
      ValueBinding()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getExpressionString()
      Deprecated.
      Return the (possibly null) expression String, including the delimiters, from which this ValueBinding was built.
      abstract Class getType(FacesContext context)
      Deprecated.
      Return the type of the property represented by this ValueBinding, relative to the specified FacesContext.
      abstract Object getValue(FacesContext context)
      Deprecated.
      Return the value of the property represented by this ValueBinding, relative to the specified FacesContext.
      abstract boolean isReadOnly(FacesContext context)
      Deprecated.
      Return true if the specified property of the specified property is known to be immutable; otherwise, return false.
      abstract void setValue(FacesContext context, Object value)
      Deprecated.
      Set the value of the property represented by this ValueBinding, relative to the specified FacesContext.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ValueBinding

        public ValueBinding()
        Deprecated.

    • Method Detail

      • getValue

        public abstract Object getValue(FacesContext context)
                         throws EvaluationException,
                                PropertyNotFoundException
        Deprecated.

        Return the value of the property represented by this ValueBinding, relative to the specified FacesContext.

        Parameters:
        context - FacesContext for the current request
        Throws:
        EvaluationException - if an exception is thrown while getting the value (the thrown exception must be included as the cause property of this exception)
        NullPointerException - if context is null
        PropertyNotFoundException - if a specified property name does not exist, or is not readable

      • setValue

        public abstract void setValue(FacesContext context,
            Object value)
                       throws EvaluationException,
                              PropertyNotFoundException
        Deprecated.

        Set the value of the property represented by this ValueBinding, relative to the specified FacesContext.

        Parameters:
        context - FacesContext for the current request
        value - The new value to be set
        Throws:
        EvaluationException - if an exception is thrown while setting the value (the thrown exception must be included as the cause property of this exception)
        NullPointerException - if context is null
        PropertyNotFoundException - if a specified property name does not exist, or is not writeable

      • isReadOnly

        public abstract boolean isReadOnly(FacesContext context)
                            throws EvaluationException,
                                   PropertyNotFoundException
        Deprecated.

        Return true if the specified property of the specified property is known to be immutable; otherwise, return false.

        Parameters:
        context - FacesContext for the current request
        Throws:
        EvaluationException - if an exception is thrown while getting the description of the property (the thrown exception must be included as the cause property of this exception)
        NullPointerException - if context is null
        PropertyNotFoundException - if a specified property name does not exist

      • getType

        public abstract Class getType(FacesContext context)
                       throws EvaluationException,
                              PropertyNotFoundException
        Deprecated.

        Return the type of the property represented by this ValueBinding, relative to the specified FacesContext.

        Parameters:
        context - FacesContext for the current request
        Throws:
        EvaluationException - if an exception is thrown while getting the description of the property (the thrown exception must be included as the cause property of this exception)
        NullPointerException - if context is null
        PropertyNotFoundException - if a specified property name does not exist

      • getExpressionString

        public String getExpressionString()
        Deprecated.

        Return the (possibly null) expression String, including the delimiters, from which this ValueBinding was built.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


VariableResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.el

Class VariableResolver

  • java.lang.Object
    • javax.faces.el.VariableResolver
  • Deprecated.
    This has been replaced by ELResolver when operating with a null base argument.

    public abstract class VariableResolver
extends Object

    VariableResolver represents a pluggable mechanism for resolving a top-level variable reference at evaluation time.

    • Constructor Summary

      Constructors
      Constructor and Description
      VariableResolver()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Object resolveVariable(FacesContext context, String name)
      Deprecated.
      Resolve the specified variable name, and return the corresponding object, if any; otherwise, return null.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • VariableResolver

        public VariableResolver()
        Deprecated.

    • Method Detail

      • resolveVariable

        public abstract Object resolveVariable(FacesContext context,
                     String name)
                                throws EvaluationException
        Deprecated.

        Resolve the specified variable name, and return the corresponding object, if any; otherwise, return null.

        Parameters:
        context - FacesContext against which to resolve this variable name
        name - Name of the variable to be resolved
        Throws:
        EvaluationException - if an exception is thrown while resolving the variable name (the thrown exception must be included as the cause property of this exception)
        NullPointerException - if context or name is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.faces.el.EvaluationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.el.EvaluationException

  • Packages that use EvaluationException
    Package Description
    javax.faces.el
    DEPRECATED Classes and interfaces for evaluating and processing reference expressions.

    • Uses of EvaluationException in javax.faces.el

      Subclasses of EvaluationException in javax.faces.el
      Modifier and Type Class and Description
      class  MethodNotFoundException
      Deprecated.
      This has been replaced by MethodNotFoundException.
      class  PropertyNotFoundException
      Deprecated.
      This has been replaced by PropertyNotFoundException.
      class  ReferenceSyntaxException
      Deprecated.
      This has been replaced by ELException.
      Methods in javax.faces.el that throw EvaluationException
      Modifier and Type Method and Description
      abstract Class ValueBinding.getType(FacesContext context)
      Deprecated.
      Return the type of the property represented by this ValueBinding, relative to the specified FacesContext.
      abstract Class PropertyResolver.getType(Object base, int index)
      Deprecated.
      Return the java.lang.Class representing the type of the specified index.
      abstract Class PropertyResolver.getType(Object base, Object property)
      Deprecated.
      Return the java.lang.Class representing the type of the specified property.
      abstract Object ValueBinding.getValue(FacesContext context)
      Deprecated.
      Return the value of the property represented by this ValueBinding, relative to the specified FacesContext.
      abstract Object PropertyResolver.getValue(Object base, int index)
      Deprecated.
      Return the value at the specified index of the specified base object.
      abstract Object PropertyResolver.getValue(Object base, Object property)
      Deprecated.
      Return the value of the specified property from the specified base object.
      abstract Object MethodBinding.invoke(FacesContext context, Object[] params)
      Deprecated.
      Return the return value (if any) resulting from a call to the method identified by this method binding expression, passing it the specified parameters, relative to the specified FacesContext.
      abstract boolean ValueBinding.isReadOnly(FacesContext context)
      Deprecated.
      Return true if the specified property of the specified property is known to be immutable; otherwise, return false.
      abstract boolean PropertyResolver.isReadOnly(Object base, int index)
      Deprecated.
      Checks if the specified index is read-only.
      abstract boolean PropertyResolver.isReadOnly(Object base, Object property)
      Deprecated.
      Checks if the specified property is read-only.
      abstract Object VariableResolver.resolveVariable(FacesContext context, String name)
      Deprecated.
      Resolve the specified variable name, and return the corresponding object, if any; otherwise, return null.
      abstract void ValueBinding.setValue(FacesContext context, Object value)
      Deprecated.
      Set the value of the property represented by this ValueBinding, relative to the specified FacesContext.
      abstract void PropertyResolver.setValue(Object base, int index, Object value)
      Deprecated.
      Set the value at the specified index of the specified base object.
      abstract void PropertyResolver.setValue(Object base, Object property, Object value)
      Deprecated.
      Set the specified value of the specified property on the specified base object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.el.MethodBinding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.el.MethodBinding

  • Packages that use MethodBinding
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.

    • Uses of MethodBinding in javax.faces.application

      Methods in javax.faces.application that return MethodBinding
      Modifier and Type Method and Description
      MethodBinding ApplicationWrapper.createMethodBinding(String ref, Class<?>[] params)
      Deprecated.
      See superclass for alternative.
      abstract MethodBinding Application.createMethodBinding(String ref, Class<?>[] params)
      Deprecated.
      This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>, java.lang.Class<?>[]).

    • Uses of MethodBinding in javax.faces.component

      Methods in javax.faces.component that return MethodBinding
      Modifier and Type | Method and Description
      MethodBinding UIViewAction.getAction()
      Deprecated.
      MethodBinding UICommand.getAction()
      Deprecated.
      This has been replaced by UICommand.getActionExpression().
      MethodBinding ActionSource.getAction()
      Deprecated.
      This has been replaced by ActionSource2.getActionExpression().
      MethodBinding UIViewAction.getActionListener()
      Deprecated.
      MethodBinding UICommand.getActionListener()
      Deprecated.
      Use UICommand.getActionListeners() instead.
      MethodBinding ActionSource.getActionListener()
      Deprecated.
      Use ActionSource.getActionListeners() instead.
      MethodBinding UIInput.getValidator()
      Deprecated.
      UIInput.getValidators() should be used instead.
      MethodBinding EditableValueHolder.getValidator()
      Deprecated.
      EditableValueHolder.getValidators() should be used instead.
      MethodBinding | UIInput.getValueChangeListener()
      MethodBinding EditableValueHolder.getValueChangeListener()
      Deprecated.
      Use EditableValueHolder.getValueChangeListeners() instead.
      Methods in javax.faces.component with parameters of type MethodBinding
      Modifier and Type Method and Description
      void UIViewAction.setAction(MethodBinding action)
      Deprecated.
      void UICommand.setAction(MethodBinding action)
      Deprecated.
      This has been replaced by UICommand.setActionExpression(javax.el.MethodExpression).
      void ActionSource.setAction(MethodBinding action)
      Deprecated.
      This has been replaced by ActionSource2.setActionExpression(javax.el.MethodExpression).
      void UIViewAction.setActionListener(MethodBinding actionListener)
      Deprecated.
      void UICommand.setActionListener(MethodBinding actionListener)
      Deprecated.
      This has been replaced by UICommand.addActionListener(javax.faces.event.ActionListener).
      void ActionSource.setActionListener(MethodBinding actionListener)
      Deprecated.
      This has been replaced by ActionSource.addActionListener(javax.faces.event.ActionListener).
      void UIInput.setValidator(MethodBinding validatorBinding)
      Deprecated.
      Use UIInput.addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.
      void EditableValueHolder.setValidator(MethodBinding validatorBinding)
      Deprecated.
      Use EditableValueHolder.addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.
      void UIInput.setValueChangeListener(MethodBinding valueChangeListener)
      Deprecated.
      Use UIInput.addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.
      void EditableValueHolder.setValueChangeListener(MethodBinding valueChangeMethod)
      Deprecated.
      Use EditableValueHolder.addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.el.MethodNotFoundException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.el.MethodNotFoundException

  • Packages that use MethodNotFoundException
    Package Description
    javax.faces.el
    DEPRECATED Classes and interfaces for evaluating and processing reference expressions.

    • Uses of MethodNotFoundException in javax.faces.el

      Methods in javax.faces.el that throw MethodNotFoundException
      Modifier and Type Method and Description
      abstract Class MethodBinding.getType(FacesContext context)
      Deprecated.
      Return the Java class representing the return type from the method identified by this method binding expression.
      abstract Object MethodBinding.invoke(FacesContext context, Object[] params)
      Deprecated.
      Return the return value (if any) resulting from a call to the method identified by this method binding expression, passing it the specified parameters, relative to the specified FacesContext.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.el.PropertyNotFoundException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.el.PropertyNotFoundException

  • Packages that use PropertyNotFoundException
    Package Description
    javax.faces.el
    DEPRECATED Classes and interfaces for evaluating and processing reference expressions.

    • Uses of PropertyNotFoundException in javax.faces.el

      Methods in javax.faces.el that throw PropertyNotFoundException
      Modifier and Type Method and Description
      abstract Class ValueBinding.getType(FacesContext context)
      Deprecated.
      Return the type of the property represented by this ValueBinding, relative to the specified FacesContext.
      abstract Class PropertyResolver.getType(Object base, int index)
      Deprecated.
      Return the java.lang.Class representing the type of the specified index.
      abstract Class PropertyResolver.getType(Object base, Object property)
      Deprecated.
      Return the java.lang.Class representing the type of the specified property.
      abstract Object ValueBinding.getValue(FacesContext context)
      Deprecated.
      Return the value of the property represented by this ValueBinding, relative to the specified FacesContext.
      abstract Object PropertyResolver.getValue(Object base, int index)
      Deprecated.
      Return the value at the specified index of the specified base object.
      abstract Object PropertyResolver.getValue(Object base, Object property)
      Deprecated.
      Return the value of the specified property from the specified base object.
      abstract boolean ValueBinding.isReadOnly(FacesContext context)
      Deprecated.
      Return true if the specified property of the specified property is known to be immutable; otherwise, return false.
      abstract boolean PropertyResolver.isReadOnly(Object base, int index)
      Deprecated.
      Checks if the specified index is read-only.
      abstract boolean PropertyResolver.isReadOnly(Object base, Object property)
      Deprecated.
      Checks if the specified property is read-only.
      abstract void ValueBinding.setValue(FacesContext context, Object value)
      Deprecated.
      Set the value of the property represented by this ValueBinding, relative to the specified FacesContext.
      abstract void PropertyResolver.setValue(Object base, int index, Object value)
      Deprecated.
      Set the value at the specified index of the specified base object.
      abstract void PropertyResolver.setValue(Object base, Object property, Object value)
      Deprecated.
      Set the specified value of the specified property on the specified base object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.el.PropertyResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.el.PropertyResolver

  • Packages that use PropertyResolver
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

    • Uses of PropertyResolver in javax.faces.application

      Methods in javax.faces.application that return PropertyResolver
      Modifier and Type Method and Description
      PropertyResolver ApplicationWrapper.getPropertyResolver()
      Deprecated.
      See superclass for alternative.
      abstract PropertyResolver Application.getPropertyResolver()
      Deprecated.
      This has been replaced by Application.getELResolver().
      Methods in javax.faces.application with parameters of type PropertyResolver
      Modifier and Type Method and Description
      void ApplicationWrapper.setPropertyResolver(PropertyResolver resolver)
      Deprecated.
      See superclass for alternative.
      abstract void Application.setPropertyResolver(PropertyResolver resolver)
      Deprecated.
      The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called Application.addELResolver(javax.el.ELResolver).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.el.ReferenceSyntaxException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.el.ReferenceSyntaxException

  • Packages that use ReferenceSyntaxException
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

    • Uses of ReferenceSyntaxException in javax.faces.application

      Methods in javax.faces.application that throw ReferenceSyntaxException
      Modifier and Type Method and Description
      MethodBinding ApplicationWrapper.createMethodBinding(String ref, Class<?>[] params)
      Deprecated.
      See superclass for alternative.
      abstract MethodBinding Application.createMethodBinding(String ref, Class<?>[] params)
      Deprecated.
      This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>, java.lang.Class<?>[]).
      ValueBinding ApplicationWrapper.createValueBinding(String ref)

      The default behavior of this method is to call Application.createValueBinding(String) on the wrapped Application object.
      abstract ValueBinding Application.createValueBinding(String ref)
      Deprecated.
      This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.el.ValueBinding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.el.ValueBinding

  • Packages that use ValueBinding
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.

    • Uses of ValueBinding in javax.faces.application

      Methods in javax.faces.application that return ValueBinding
      Modifier and Type Method and Description
      ValueBinding ApplicationWrapper.createValueBinding(String ref)

      The default behavior of this method is to call Application.createValueBinding(String) on the wrapped Application object.
      abstract ValueBinding Application.createValueBinding(String ref)
      Deprecated.
      This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>).
      Methods in javax.faces.application with parameters of type ValueBinding
      Modifier and Type Method and Description
      UIComponent ApplicationWrapper.createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
      Deprecated.
      See superclass for alternative.
      abstract UIComponent Application.createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
      Deprecated.
      This has been replaced by Application.createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).

    • Uses of ValueBinding in javax.faces.component

      Methods in javax.faces.component that return ValueBinding
      Modifier and Type Method and Description
      ValueBinding UISelectMany.getValueBinding(String name)
      Deprecated.
      this has been replaced by UISelectMany.getValueExpression(java.lang.String).
      ValueBinding UISelectBoolean.getValueBinding(String name)
      Deprecated.
      This has been replaced by UISelectBoolean.getValueExpression(java.lang.String).
      ValueBinding UIGraphic.getValueBinding(String name)
      Deprecated.
      This has been replaced by UIGraphic.getValueExpression(java.lang.String).
      ValueBinding UIComponentBase.getValueBinding(String name)
      Deprecated.
      This has been replaced by UIComponent.getValueExpression(java.lang.String).
      abstract ValueBinding UIComponent.getValueBinding(String name)
      Deprecated.
      This has been replaced by UIComponent.getValueExpression(java.lang.String).
      Methods in javax.faces.component with parameters of type ValueBinding
      Modifier and Type Method and Description
      void UISelectMany.setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by UISelectMany.setValueExpression(java.lang.String, javax.el.ValueExpression).
      void UISelectBoolean.setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by UISelectBoolean.setValueExpression(java.lang.String, javax.el.ValueExpression).
      void UIGraphic.setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by UIGraphic.setValueExpression(java.lang.String, javax.el.ValueExpression).
      void UIData.setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by UIData.setValueExpression(java.lang.String, javax.el.ValueExpression).
      void UIComponentBase.setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).
      abstract void UIComponent.setValueBinding(String name, ValueBinding binding)
      Deprecated.
      This has been replaced by UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.el.VariableResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.el.VariableResolver

  • Packages that use VariableResolver
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

    • Uses of VariableResolver in javax.faces.application

      Methods in javax.faces.application that return VariableResolver
      Modifier and Type Method and Description
      VariableResolver ApplicationWrapper.getVariableResolver()
      Deprecated.
      See superclass for alternative.
      abstract VariableResolver Application.getVariableResolver()
      Deprecated.
      This has been replaced by Application.getELResolver().
      Methods in javax.faces.application with parameters of type VariableResolver
      Modifier and Type Method and Description
      void ApplicationWrapper.setVariableResolver(VariableResolver resolver)
      Deprecated.
      See superclass for alternative.
      abstract void Application.setVariableResolver(VariableResolver resolver)
      Deprecated.
      The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called Application.addELResolver(javax.el.ELResolver).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.el.CompositeComponentExpressionHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.el.CompositeComponentExpressionHolder

No usage of javax.faces.el.CompositeComponentExpressionHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AbortProcessingException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class AbortProcessingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.event.AbortProcessingException
  • All Implemented Interfaces:
    Serializable

    public class AbortProcessingException
extends FacesException

    An exception that may be thrown by event listeners to terminate the processing of the current event.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      AbortProcessingException()
      Construct a new exception with no detail message or root cause.
      AbortProcessingException(String message)
      Construct a new exception with the specified detail message and no root cause.
      AbortProcessingException(String message, Throwable cause)
      Construct a new exception with the specified detail message and root cause.
      AbortProcessingException(Throwable cause)
      Construct a new exception with the specified root cause.

    • Method Summary

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AbortProcessingException

        public AbortProcessingException()

        Construct a new exception with no detail message or root cause.

      • AbortProcessingException

        public AbortProcessingException(String message)

        Construct a new exception with the specified detail message and no root cause.

        Parameters:
        message - The detail message for this exception

      • AbortProcessingException

        public AbortProcessingException(Throwable cause)

        Construct a new exception with the specified root cause.

        Parameters:
        cause - The root cause for this exception

      • AbortProcessingException

        public AbortProcessingException(String message,
                        Throwable cause)

        Construct a new exception with the specified detail message and root cause.

        Parameters:
        message - The detail message for this exception
        cause - The root cause for this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ActionEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class ActionEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.FacesEvent
        • javax.faces.event.ActionEvent
  • All Implemented Interfaces:
    Serializable

    public class ActionEvent
extends FacesEvent

    An ActionEvent represents the activation of a user interface component (such as a UICommand).

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ActionEvent(UIComponent component)
      Construct a new event object from the specified source component and action command.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isAppropriateListener(FacesListener listener)
      Return true if this FacesListener is an instance of a listener class that this event supports.
      void processListener(FacesListener listener)
      Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate.

      • Methods inherited from class javax.faces.event.FacesEvent

        getComponent, getPhaseId, queue, setPhaseId

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ActionEvent

        public ActionEvent(UIComponent component)

        Construct a new event object from the specified source component and action command.

        Parameters:
        component - Source UIComponent for this event
        Throws:
        IllegalArgumentException - if component is null

    • Method Detail

      • isAppropriateListener

        public boolean isAppropriateListener(FacesListener listener)
        Description copied from class: FacesEvent

        Return true if this FacesListener is an instance of a listener class that this event supports. Typically, this will be accomplished by an "instanceof" check on the listener class.

        Specified by:
        isAppropriateListener in class FacesEvent
        Parameters:
        listener - FacesListener to evaluate

      • processListener

        public void processListener(FacesListener listener)
        Description copied from class: FacesEvent

        Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate. Typically, this will be accomplished by calling an event processing method, and passing this FacesEvent as a paramter.

        Specified by:
        processListener in class FacesEvent
        Parameters:
        listener - FacesListener to send this FacesEvent to
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ActionListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Interface ActionListener

  • All Superinterfaces:
    EventListener, FacesListener
    All Known Implementing Classes:
    ActionListenerWrapper, MethodExpressionActionListener

    public interface ActionListener
extends FacesListener

    A listener interface for receiving ActionEvents. An implementation of this interface must be thread-safe. A class that is interested in receiving such events implements this interface, and then registers itself with the source UIComponent of interest, by calling addActionListener().

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String TO_FLOW_DOCUMENT_ID_ATTR_NAME

      The presence of this component attribute on an ActionSource component will cause the default ActionListener to interpret the value of the attribute as the toFlowDocumentId value to pass to NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String, java.lang.String).

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void processAction(ActionEvent event)
      Invoked when the action described by the specified ActionEvent occurs.

    • Field Detail

      • TO_FLOW_DOCUMENT_ID_ATTR_NAME

        static final String TO_FLOW_DOCUMENT_ID_ATTR_NAME

        The presence of this component attribute on an ActionSource component will cause the default ActionListener to interpret the value of the attribute as the toFlowDocumentId value to pass to NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String, java.lang.String).

        See Also:
        Constant Field Values

    • Method Detail

      • processAction

        void processAction(ActionEvent event)
                   throws AbortProcessingException

        Invoked when the action described by the specified ActionEvent occurs.

        Parameters:
        event - The ActionEvent that has occurred
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ActionListenerWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class ActionListenerWrapper

  • java.lang.Object
    • javax.faces.event.ActionListenerWrapper
  • All Implemented Interfaces:
    EventListener, ActionListener, FacesListener, FacesWrapper<ActionListener>

    public abstract class ActionListenerWrapper
extends Object
implements ActionListener, FacesWrapper<ActionListener>

    Provides a simple implementation of ActionListener that can be subclassed by developers wishing to provide specialized behavior to an existing ActionListener instance. The default implementation of all methods is to call through to the wrapped ActionListener.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    2.2

    • Field Summary

      • Fields inherited from interface javax.faces.event.ActionListener

        TO_FLOW_DOCUMENT_ID_ATTR_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      ActionListenerWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ActionListener getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void processAction(ActionEvent event)
      Invoked when the action described by the specified ActionEvent occurs.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ActionListenerWrapper

        public ActionListenerWrapper()

    • Method Detail

      • processAction

        public void processAction(ActionEvent event)
                   throws AbortProcessingException
        Description copied from interface: ActionListener

        Invoked when the action described by the specified ActionEvent occurs.

        Specified by:
        processAction in interface ActionListener
        Parameters:
        event - The ActionEvent that has occurred
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed

      • getWrapped

        public abstract ActionListener getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<ActionListener>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AjaxBehaviorEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class AjaxBehaviorEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.FacesEvent
        • javax.faces.event.BehaviorEvent
          • javax.faces.event.AjaxBehaviorEvent
  • All Implemented Interfaces:
    Serializable

    public class AjaxBehaviorEvent
extends BehaviorEvent

    AjaxBehaviorEvent represents the component behavior specific to Ajax).

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      AjaxBehaviorEvent(UIComponent component, Behavior behavior)

      Construct a new event object from the specified source component and Ajax behavior.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isAppropriateListener(FacesListener listener)

      Return true if this FacesListener is an instance of a the appropriate listener class that this event supports.
      void processListener(FacesListener listener)

      Broadcast this event instance to the specified FacesListener, by whatever mechanism is appropriate.

      • Methods inherited from class javax.faces.event.BehaviorEvent

        getBehavior

      • Methods inherited from class javax.faces.event.FacesEvent

        getComponent, getPhaseId, queue, setPhaseId

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AjaxBehaviorEvent

        public AjaxBehaviorEvent(UIComponent component,
                 Behavior behavior)

        Construct a new event object from the specified source component and Ajax behavior.

        Parameters:
        component - Source UIComponent for this event
        behavior - Behavior for this event
        Throws:
        IllegalArgumentException - if component or ajaxBehavior is null
        Since:
        2.0

    • Method Detail

      • isAppropriateListener

        public boolean isAppropriateListener(FacesListener listener)

        Return true if this FacesListener is an instance of a the appropriate listener class that this event supports.

        Specified by:
        isAppropriateListener in class FacesEvent
        Parameters:
        listener - FacesListener to evaluate
        Since:
        2.0

      • processListener

        public void processListener(FacesListener listener)

        Broadcast this event instance to the specified FacesListener, by whatever mechanism is appropriate. Typically, this will be accomplished by calling an event processing method, and passing this instance as a parameter.

        Specified by:
        processListener in class FacesEvent
        Parameters:
        listener - FacesListener to invoke
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AjaxBehaviorListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Interface AjaxBehaviorListener

  • All Superinterfaces:
    BehaviorListener, EventListener, FacesListener

    public interface AjaxBehaviorListener
extends BehaviorListener

    By implementing this class, an object indicates that it is a listener for one or more kinds of BehaviorEvents.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void processAjaxBehavior(AjaxBehaviorEvent event)

    • Method Detail

      • processAjaxBehavior

        void processAjaxBehavior(AjaxBehaviorEvent event)
                         throws AbortProcessingException

        Parameters:
        event - the AjaxBehaviorEvent instance that is being processed.
        Throws:
        AbortProcessingException - if lifecycle processing should cease for this request.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BehaviorEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class BehaviorEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.FacesEvent
        • javax.faces.event.BehaviorEvent
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    AjaxBehaviorEvent

    public abstract class BehaviorEvent
extends FacesEvent

    BehaviorEvent is the event that can be generated from component Behavior.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      BehaviorEvent(UIComponent component, Behavior behavior)

      Construct a new event object from the specified source component and behavior.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Behavior getBehavior()

      Return the source Behavior that sent this event.

      • Methods inherited from class javax.faces.event.FacesEvent

        getComponent, getPhaseId, isAppropriateListener, processListener, queue, setPhaseId

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BehaviorEvent

        public BehaviorEvent(UIComponent component,
             Behavior behavior)

        Construct a new event object from the specified source component and behavior.

        Parameters:
        component - Source UIComponent for this event
        behavior - Behavior that sent this event
        Throws:
        IllegalArgumentException - if component or behavior is null
        Since:
        2.0

    • Method Detail

      • getBehavior

        public Behavior getBehavior()

        Return the source Behavior that sent this event.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BehaviorListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Interface BehaviorListener

  • All Superinterfaces:
    EventListener, FacesListener
    All Known Subinterfaces:
    AjaxBehaviorListener

    public interface BehaviorListener
extends FacesListener

    A generic base interface for event listeners for various types of BehaviorEvents. All listener interfaces for specific BehaviorEvent event types must extend this interface.

    Implementations of this interface must have a zero-args public constructor. If the class that implements this interface has state that needs to be saved and restored between requests, the class must also implement StateHolder.

    Since:
    2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ComponentSystemEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class ComponentSystemEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    PostAddToViewEvent, PostConstructViewMapEvent, PostRestoreStateEvent, PostValidateEvent, PreDestroyViewMapEvent, PreRemoveFromViewEvent, PreRenderComponentEvent, PreRenderViewEvent, PreValidateEvent

    public abstract class ComponentSystemEvent
extends SystemEvent

    ComponentSystemEvent is the base class for SystemEvents that are specific to a UIComponent instance.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ComponentSystemEvent(UIComponent component)

      Pass the argument component to the superclass constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      UIComponent getComponent()

      the source UIComponent that sent this event.
      boolean isAppropriateListener(FacesListener listener)

      Return true if the argument FacesListener is an instance of the appropriate listener class that this event supports.
      void processListener(FacesListener listener)

      Broadcast this event instance to the specified FacesListener by calling the superclass's processListener() implementation.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ComponentSystemEvent

        public ComponentSystemEvent(UIComponent component)

        Pass the argument component to the superclass constructor.

        Parameters:
        component - the UIComponent reference to be passed to the superclass constructor.
        Throws:
        IllegalArgumentException - if the argument is null.
        Since:
        2.0

    • Method Detail

      • isAppropriateListener

        public boolean isAppropriateListener(FacesListener listener)

        Return true if the argument FacesListener is an instance of the appropriate listener class that this event supports. The default implementation returns true if the listener is a ComponentSystemEventListener or if super.isAppropriateListener() returns true.

        Overrides:
        isAppropriateListener in class SystemEvent
        Parameters:
        listener - FacesListener to evaluate
        Since:
        2.2

      • processListener

        public void processListener(FacesListener listener)

        Broadcast this event instance to the specified FacesListener by calling the superclass's processListener() implementation.

        Overrides:
        processListener in class SystemEvent
        Parameters:
        listener - FacesListener to evaluate
        Since:
        2.2

      • getComponent

        public UIComponent getComponent()

        the source UIComponent that sent this event.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ComponentSystemEventListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Interface ComponentSystemEventListener

  • All Superinterfaces:
    EventListener, FacesListener
    All Known Implementing Classes:
    HtmlBody, HtmlColumn, HtmlCommandButton, HtmlCommandLink, HtmlDataTable, HtmlDoctype, HtmlForm, HtmlGraphicImage, HtmlHead, HtmlInputFile, HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlMessage, HtmlMessages, HtmlOutcomeTargetButton, HtmlOutcomeTargetLink, HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, HtmlPanelGrid, HtmlPanelGroup, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, UIColumn, UICommand, UIComponent, UIComponentBase, UIData, UIForm, UIGraphic, UIInput, UIMessage, UIMessages, UINamingContainer, UIOutcomeTarget, UIOutput, UIPanel, UIParameter, UISelectBoolean, UISelectItem, UISelectItems, UISelectMany, UISelectOne, UIViewAction, UIViewParameter, UIViewRoot

    public interface ComponentSystemEventListener
extends FacesListener

    Implementors of this class do not need an isListenerForSource() method because they are only installed on specific component instances, therefore the isListenerForSource() method is implicit. Also, the processEvent(javax.faces.event.ComponentSystemEvent) method on this interface takes a ComponentSystemEvent because the event will always be associated with a UIComponent instance.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void processEvent(ComponentSystemEvent event)
      When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

    • Method Detail

      • processEvent

        void processEvent(ComponentSystemEvent event)
                  throws AbortProcessingException

        When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

        Parameters:
        event - the ComponentSystemEvent instance that is being processed.
        Throws:
        AbortProcessingException - if lifecycle processing should cease for this request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExceptionQueuedEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class ExceptionQueuedEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ExceptionQueuedEvent
  • All Implemented Interfaces:
    Serializable

    public class ExceptionQueuedEvent
extends SystemEvent

    The system event facility will create an instance of this class whenever Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) is called with ExceptionQueuedEvent.class as systemEventClass argument. In this case, an instance of ExceptionQueuedEventContext must be passed as the source argument. The specification for publishEvent(), requires the instantiation of the systemEventClass argument, passing the source argument to the constructor.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ExceptionQueuedEvent(ExceptionQueuedEventContext eventContext)

      Instantiate a new ExceptionQueuedEvent that indicates the argument ExceptionQueuedEventContext occurred.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ExceptionQueuedEventContext getContext()

      Return the ExceptionQueuedEventContext for this event instance.

      • Methods inherited from class javax.faces.event.SystemEvent

        isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ExceptionQueuedEvent

        public ExceptionQueuedEvent(ExceptionQueuedEventContext eventContext)

        Instantiate a new ExceptionQueuedEvent that indicates the argument ExceptionQueuedEventContext occurred.

        Parameters:
        eventContext - the ExceptionQueuedEventContext that contextualizes this ExceptionQueuedEvent.
        Since:
        2.0

    • Method Detail

      • getContext

        public ExceptionQueuedEventContext getContext()

        Return the ExceptionQueuedEventContext for this event instance.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExceptionQueuedEventContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class ExceptionQueuedEventContext

  • java.lang.Object
    • javax.faces.event.ExceptionQueuedEventContext
  • All Implemented Interfaces:
    SystemEventListenerHolder

    public class ExceptionQueuedEventContext
extends Object
implements SystemEventListenerHolder

    This helper class provides context to the ExceptionQueuedEvent regarding the state of the system at the point in time when the ExceptionQueuedEvent occurs and links the ExceptionQueuedEvent to the ExceptionHandler by virtue of implementing SystemEventListener.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String IN_AFTER_PHASE_KEY

      The presence of an entry under this key in the Map returned from getAttributes() indicates the event occurred during the “after phase” part of the current lifecycle phase.
      static String IN_BEFORE_PHASE_KEY

      The presence of an entry under this key in the Map returned from getAttributes() indicates the event occurred during the “before phase” part of the current lifecycle phase.

    • Constructor Summary

      Constructors
      Constructor and Description
      ExceptionQueuedEventContext(FacesContext context, Throwable thrown)

      Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred.
      ExceptionQueuedEventContext(FacesContext context, Throwable thrown, UIComponent component)

      Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component.
      ExceptionQueuedEventContext(FacesContext context, Throwable thrown, UIComponent component, PhaseId phaseId)

      Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component, during the lifecycle phase phaseId.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      Map<Object,Object> getAttributes()

      A Map of attributes relevant to the context of this ExceptionQueuedEvent.
      UIComponent getComponent()

      Return the UIComponent which was being processed when the exception was thrown.
      FacesContext getContext()

      Throwable getException()

      Return the exception property.
      List<SystemEventListener> getListenersForEventClass(Class<? extends SystemEvent> facesEventClass)

      Return a List that contains a single entry, the ExceptionHandler for the current request.
      PhaseId getPhaseId()

      Return the PhaseId which was being processed when the exception was thrown.
      boolean | inAfterPhase()
      boolean | inBeforePhase()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • IN_BEFORE_PHASE_KEY

        public static final String IN_BEFORE_PHASE_KEY

        The presence of an entry under this key in the Map returned from getAttributes() indicates the event occurred during the “before phase” part of the current lifecycle phase.

      • IN_AFTER_PHASE_KEY

        public static final String IN_AFTER_PHASE_KEY

        The presence of an entry under this key in the Map returned from getAttributes() indicates the event occurred during the “after phase” part of the current lifecycle phase.

    • Constructor Detail

      • ExceptionQueuedEventContext

        public ExceptionQueuedEventContext(FacesContext context,
                           Throwable thrown)

        Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred.

        Parameters:
        context - FacesContext for the current request
        thrown - the Throwable that is the context for this ExceptionQueuedEventContext instance.

      • ExceptionQueuedEventContext

        public ExceptionQueuedEventContext(FacesContext context,
                           Throwable thrown,
                           UIComponent component)

        Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component.

        Parameters:
        context - FacesContext for the current request
        thrown - the Throwable that is the context for this ExceptionQueuedEventContext instance.
        component - the UIComponent instance to which this ExceptionQueuedEventContext pertains

      • ExceptionQueuedEventContext

        public ExceptionQueuedEventContext(FacesContext context,
                           Throwable thrown,
                           UIComponent component,
                           PhaseId phaseId)

        Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component, during the lifecycle phase phaseId.

        Parameters:
        context - FacesContext for the current request
        thrown - the Throwable that is the context for this ExceptionQueuedEventContext instance.
        component - the UIComponent that is relevant to the context.
        phaseId - the PhaseId at the time this ExeceptionEventContext is created.

    • Method Detail

      • getContext

        public FacesContext getContext()

        Returns:
        the FacesContext used to create this ExceptionQueuedEventContext instance.

      • getException

        public Throwable getException()

        Return the exception property.

      • getComponent

        public UIComponent getComponent()

        Return the UIComponent which was being processed when the exception was thrown. If none or not available, this will be null.

      • getPhaseId

        public PhaseId getPhaseId()

        Return the PhaseId which was being processed when the exception was thrown. If none or not available, this will be null.

      • inBeforePhase

        public boolean inBeforePhase()
        Returns:
        true if the exception occurred during the before phase processing for a particular lifecycle phase

      • inAfterPhase

        public boolean inAfterPhase()
        Returns:
        true if the exception occurred during the after phase processing for a particular lifecycle phase

      • getAttributes

        public Map<Object,Object> getAttributes()

        A Map of attributes relevant to the context of this ExceptionQueuedEvent.

      • getListenersForEventClass

        public List<SystemEventListener> getListenersForEventClass(Class<? extends SystemEvent> facesEventClass)

        Return a List that contains a single entry, the ExceptionHandler for the current request.

        Specified by:
        getListenersForEventClass in interface SystemEventListenerHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class FacesEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.FacesEvent
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ActionEvent, BehaviorEvent, ValueChangeEvent

    public abstract class FacesEvent
extends EventObject

    FacesEvent is the base class for user interface and application events that can be fired by UIComponents. Concrete event classes must subclass FacesEvent in order to be supported by the request processing lifecycle.

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      FacesEvent(UIComponent component)
      Construct a new event object from the specified source component.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      UIComponent getComponent()
      Return the source UIComponent that sent this event.
      PhaseId getPhaseId()
      Return the identifier of the request processing phase during which this event should be delivered.
      abstract boolean isAppropriateListener(FacesListener listener)
      Return true if this FacesListener is an instance of a listener class that this event supports.
      abstract void processListener(FacesListener listener)
      Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate.
      void queue()
      Convenience method to queue this event for broadcast at the end of the current request processing lifecycle phase.
      void setPhaseId(PhaseId phaseId)
      Set the PhaseId during which this event will be delivered.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FacesEvent

        public FacesEvent(UIComponent component)

        Construct a new event object from the specified source component.

        Parameters:
        component - Source UIComponent for this event
        Throws:
        IllegalArgumentException - if component is null

    • Method Detail

      • getComponent

        public UIComponent getComponent()

        Return the source UIComponent that sent this event.

      • getPhaseId

        public PhaseId getPhaseId()

        Return the identifier of the request processing phase during which this event should be delivered. Legal values are the singleton instances defined by the PhaseId class, including PhaseId.ANY_PHASE, which is the default value.

      • setPhaseId

        public void setPhaseId(PhaseId phaseId)

        Set the PhaseId during which this event will be delivered.

        Throws:
        IllegalArgumentException - phaseId is null.

      • queue

        public void queue()

        Convenience method to queue this event for broadcast at the end of the current request processing lifecycle phase.

        Throws:
        IllegalStateException - if the source component for this event is not a descendant of a UIViewRoot

      • isAppropriateListener

        public abstract boolean isAppropriateListener(FacesListener listener)

        Return true if this FacesListener is an instance of a listener class that this event supports. Typically, this will be accomplished by an "instanceof" check on the listener class.

        Parameters:
        listener - FacesListener to evaluate

      • processListener

        public abstract void processListener(FacesListener listener)

        Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate. Typically, this will be accomplished by calling an event processing method, and passing this FacesEvent as a paramter.

        Parameters:
        listener - FacesListener to send this FacesEvent to
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Interface FacesListener

  • All Superinterfaces:
    EventListener
    All Known Subinterfaces:
    ActionListener, AjaxBehaviorListener, BehaviorListener, ComponentSystemEventListener, SystemEventListener, ValueChangeListener, ViewMapListener
    All Known Implementing Classes:
    ActionListenerWrapper, ExceptionHandler, ExceptionHandlerWrapper, HtmlBody, HtmlColumn, HtmlCommandButton, HtmlCommandLink, HtmlDataTable, HtmlDoctype, HtmlForm, HtmlGraphicImage, HtmlHead, HtmlInputFile, HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlMessage, HtmlMessages, HtmlOutcomeTargetButton, HtmlOutcomeTargetLink, HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, HtmlPanelGrid, HtmlPanelGroup, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, MethodExpressionActionListener, MethodExpressionValueChangeListener, UIColumn, UICommand, UIComponent, UIComponentBase, UIData, UIForm, UIGraphic, UIInput, UIMessage, UIMessages, UINamingContainer, UIOutcomeTarget, UIOutput, UIPanel, UIParameter, UISelectBoolean, UISelectItem, UISelectItems, UISelectMany, UISelectOne, UIViewAction, UIViewParameter, UIViewRoot

    public interface FacesListener
extends EventListener

    A generic base interface for event listeners for various types of FacesEvents. All listener interfaces for specific FacesEvent event types must extend this interface.

    Implementations of this interface must have a zero-args public constructor. If the class that implements this interface has state that needs to be saved and restored between requests, the class must also implement StateHolder.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces.event (Java(TM) EE 7 Specification APIs)

javax.faces.event

Interfaces

  • ActionListener
  • AjaxBehaviorListener
  • BehaviorListener
  • ComponentSystemEventListener
  • FacesListener
  • PhaseListener
  • SystemEventListener
  • SystemEventListenerHolder
  • ValueChangeListener
  • ViewMapListener

Classes

  • ActionEvent
  • ActionListenerWrapper
  • AjaxBehaviorEvent
  • BehaviorEvent
  • ComponentSystemEvent
  • ExceptionQueuedEvent
  • ExceptionQueuedEventContext
  • FacesEvent
  • MethodExpressionActionListener
  • MethodExpressionValueChangeListener
  • PhaseEvent
  • PhaseId
  • PostAddToViewEvent
  • PostConstructApplicationEvent
  • PostConstructCustomScopeEvent
  • PostConstructViewMapEvent
  • PostKeepFlashValueEvent
  • PostPutFlashValueEvent
  • PostRestoreStateEvent
  • PostValidateEvent
  • PreClearFlashEvent
  • PreDestroyApplicationEvent
  • PreDestroyCustomScopeEvent
  • PreDestroyViewMapEvent
  • PreRemoveFlashValueEvent
  • PreRemoveFromViewEvent
  • PreRenderComponentEvent
  • PreRenderViewEvent
  • PreValidateEvent
  • ScopeContext
  • SystemEvent
  • ValueChangeEvent

Exceptions

  • AbortProcessingException

Annotation Types

  • ListenerFor
  • ListenersFor
  • NamedEvent


javax.faces.event (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.event

Interfaces describing events and event listeners, and concrete event implementation classes.

See: Description

  • Interface Summary
    Interface Description
    ActionListener
    A listener interface for receiving ActionEvents.
    AjaxBehaviorListener

    By implementing this class, an object indicates that it is a listener for one or more kinds of BehaviorEvents.
    BehaviorListener

    A generic base interface for event listeners for various types of BehaviorEvents.
    ComponentSystemEventListener

    Implementors of this class do not need an isListenerForSource() method because they are only installed on specific component instances, therefore the isListenerForSource() method is implicit.
    FacesListener
    A generic base interface for event listeners for various types of FacesEvents.
    PhaseListener
    An interface implemented by objects that wish to be notified at the beginning and ending of processing for each standard phase of the request processing lifecycle.
    SystemEventListener

    By implementing this class, an object indicates that it is a listener for one or more kinds of SystemEvents.
    SystemEventListenerHolder

    Classes that implement this interface agree to maintain a list of SystemEventListener instances for each kind of SystemEvent they can generate.
    ValueChangeListener
    A listener interface for receiving ValueChangeEvents.
    ViewMapListener

    Marker interface for SystemEvents that indicate the view map has been created (PostConstructViewMapEvent, or destroyed (PreDestroyViewMapEvent).
  • Class Summary
    Class Description
    ActionEvent
    An ActionEvent represents the activation of a user interface component (such as a UICommand).
    ActionListenerWrapper

    Provides a simple implementation of ActionListener that can be subclassed by developers wishing to provide specialized behavior to an existing ActionListener instance.
    AjaxBehaviorEvent
    AjaxBehaviorEvent represents the component behavior specific to Ajax).
    BehaviorEvent
    BehaviorEvent is the event that can be generated from component Behavior.
    ComponentSystemEvent
    ComponentSystemEvent is the base class for SystemEvents that are specific to a UIComponent instance.
    ExceptionQueuedEvent

    The system event facility will create an instance of this class whenever Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) is called with ExceptionQueuedEvent.class as systemEventClass argument.
    ExceptionQueuedEventContext

    This helper class provides context to the ExceptionQueuedEvent regarding the state of the system at the point in time when the ExceptionQueuedEvent occurs and links the ExceptionQueuedEvent to the ExceptionHandler by virtue of implementing SystemEventListener.
    FacesEvent
    FacesEvent is the base class for user interface and application events that can be fired by UIComponents.
    MethodExpressionActionListener
    MethodExpressionActionListener is an ActionListener that wraps a MethodExpression.
    MethodExpressionValueChangeListener
    MethodExpressionValueChangeListener is a ValueChangeListener that wraps a MethodExpression.
    PhaseEvent
    PhaseEvent represents the beginning or ending of processing for a particular phase of the request processing lifecycle, for the request encapsulated by the specified FacesContext.
    PhaseId
    Typesafe enumeration of the legal values that may be returned by the getPhaseId() method of the FacesEvent interface.
    PostAddToViewEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is a UIComponent instance and that either that instance or an ancestor of that instance was just added to the view.
    PostConstructApplicationEvent

    This event must be published by the runtime after all configuration resources have been parsed and processed.
    PostConstructCustomScopeEvent

    This class is provided to allow custom scopes to publish a "post construct" event in the same way that other scopes do to let the application become aware of the beginning of the scope.
    PostConstructViewMapEvent

    This event must be published by a call to {javax.faces.application.Application#publishEvent} when the view map is first created.
    PostKeepFlashValueEvent

    This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is kept in the flash.
    PostPutFlashValueEvent

    This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is stored in the flash.
    PostRestoreStateEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is in a tree that has just had its state restored.
    PostValidateEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is that has just been validated.
    PreClearFlashEvent

    This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) before the flash is cleared.
    PreDestroyApplicationEvent

    This event must be published by the runtime before the factories associated with this Application are released.
    PreDestroyCustomScopeEvent

    This class is provided to allow custom scopes to publish a "pre construct" event in the same way that other scopes do to let the application become aware of the beginning of the scope.
    PreDestroyViewMapEvent

    This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when the clear method is called on the map returned from UIViewRoot.getViewMap().
    PreRemoveFlashValueEvent

    This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is removed from the flash.
    PreRemoveFromViewEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is a UIComponent instance that is about to be removed from the view.
    PreRenderComponentEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is about to be rendered and that it is safe to call UIComponent.getParent(), UIComponent.getClientId(), and other methods that depend upon the component instance being in the view.
    PreRenderViewEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIViewRoot instance that is about to be rendered.
    PreValidateEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is about to be validated.
    ScopeContext

    A structure that contains the name of the scope and the scope itself exposed as a Map<String, Object>.
    SystemEvent
    SystemEvent is the base class for non-application specific events that can be fired by arbitrary objects.
    ValueChangeEvent
    A ValueChangeEvent is a notification that the local value of the source component has been change as a result of user interface activity.
  • Exception Summary
    Exception Description
    AbortProcessingException
    An exception that may be thrown by event listeners to terminate the processing of the current event.
  • Annotation Types Summary
    Annotation Type Description
    ListenerFor

    Classes tagged with this annotation are installed as listeners using the method Application.subscribeToEvent(java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Class<?>, javax.faces.event.SystemEventListener) or UIComponent.subscribeToEvent(java.lang.Class<? extends javax.faces.event.SystemEvent>, javax.faces.event.ComponentSystemEventListener) (depending on the circumstances, described below).
    ListenersFor

    Container annotation to specify multiple ListenerFor annotations on a single class.
    NamedEvent

    The presence of this annotation on a class automatically registers the class with the runtime as a ComponentSystemEvent for use with the <f:event /> tag in a page.

Package javax.faces.event Description

Interfaces describing events and event listeners, and concrete event implementation classes. All events extend from FacesEvent and all listeners extend from FacesListener.

For your convenience here is a UML class diagram of the classes in this package.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.event Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.event

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.event.ActionListenerWrapper (implements javax.faces.event.ActionListener, javax.faces.FacesWrapper<T>)
    • java.util.EventObject (implements java.io.Serializable)
      • javax.faces.event.FacesEvent
        • javax.faces.event.ActionEvent
        • javax.faces.event.BehaviorEvent
          • javax.faces.event.AjaxBehaviorEvent
        • javax.faces.event.ValueChangeEvent
      • javax.faces.event.PhaseEvent
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PostAddToViewEvent
          • javax.faces.event.PostConstructViewMapEvent
          • javax.faces.event.PostRestoreStateEvent
          • javax.faces.event.PostValidateEvent
          • javax.faces.event.PreDestroyViewMapEvent
          • javax.faces.event.PreRemoveFromViewEvent
          • javax.faces.event.PreRenderComponentEvent
          • javax.faces.event.PreRenderViewEvent
          • javax.faces.event.PreValidateEvent
        • javax.faces.event.ExceptionQueuedEvent
        • javax.faces.event.PostConstructApplicationEvent
        • javax.faces.event.PostConstructCustomScopeEvent
        • javax.faces.event.PostKeepFlashValueEvent
        • javax.faces.event.PostPutFlashValueEvent
        • javax.faces.event.PreClearFlashEvent
        • javax.faces.event.PreDestroyApplicationEvent
        • javax.faces.event.PreDestroyCustomScopeEvent
        • javax.faces.event.PreRemoveFlashValueEvent
    • javax.faces.event.ExceptionQueuedEventContext (implements javax.faces.event.SystemEventListenerHolder)
    • javax.faces.event.MethodExpressionActionListener (implements javax.faces.event.ActionListener, javax.faces.component.StateHolder)
    • javax.faces.event.MethodExpressionValueChangeListener (implements javax.faces.component.StateHolder, javax.faces.event.ValueChangeListener)
    • javax.faces.event.PhaseId (implements java.lang.Comparable<T>)
    • javax.faces.event.ScopeContext
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.event.AbortProcessingException

Interface Hierarchy

  • java.util.EventListener
    • javax.faces.event.FacesListener
      • javax.faces.event.ActionListener
      • javax.faces.event.BehaviorListener
        • javax.faces.event.AjaxBehaviorListener
      • javax.faces.event.ComponentSystemEventListener
      • javax.faces.event.SystemEventListener
        • javax.faces.event.ViewMapListener
      • javax.faces.event.ValueChangeListener
    • javax.faces.event.PhaseListener (also extends java.io.Serializable)
  • java.io.Serializable
    • javax.faces.event.PhaseListener (also extends java.util.EventListener)
  • javax.faces.event.SystemEventListenerHolder

Annotation Type Hierarchy

  • javax.faces.event.NamedEvent (implements java.lang.annotation.Annotation)
  • javax.faces.event.ListenersFor (implements java.lang.annotation.Annotation)
  • javax.faces.event.ListenerFor (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ListenerFor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.event

Annotation Type ListenerFor

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface ListenerFor

    Classes tagged with this annotation are installed as listeners using the method Application.subscribeToEvent(java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Class<?>, javax.faces.event.SystemEventListener) or UIComponent.subscribeToEvent(java.lang.Class<? extends javax.faces.event.SystemEvent>, javax.faces.event.ComponentSystemEventListener) (depending on the circumstances, described below).

    The default implementation must support attaching this annotation to UIComponent or Renderer classes. In both cases, the annotation processing described herein must commence during the implementation of any variant of Application .createComponent() and must complete before the UIComponent instance is returned from createComponent(). The annotation processing must proceed according to an algorithm semantically equivalent to the following.

    • If this annotation is not present on the class in question, no action must be taken.

      • Determine the "target" on which to call subscribeToEvent.

      If the class to which this annotation is attached implements ComponentSystemEventListener and is a UIComponent instance, "target" is the UIComponent instance.

      If the class to which this annotation is attached implements ComponentSystemEventListener and is a Renderer instance, "target" is the UIComponent instance that is to be rendered by this Renderer instance.

      If the class to which this annotation is attached implements ComponentSystemEventListener and is neither an instance of Renderer nor UIComponent, the action taken is unspecified. This case must not trigger any kind of error.

      If the class to which this annotation is attached implements SystemEventListener and does not implement ComponentSystemEventListener, "target" is the Application instance.

    • Determine the variant of subscribeToEvent()to call and the parameters to pass to it.

      If "target" is a UIComponent call UIComponent.subscribeToEvent(Class, ComponentSystemEventListener), passing the systemEventClass() of the annotation as the first argument and the instance of the class to which this annotation is attached (which must implement ComponentSystemEventListener) as the second argument.

      If "target" is the Application instance, inspect the value of the sourceClass() annotation attribute value.

      If the value is Void.class, call Application.subscribeToEvent(Class, SystemEventListener), passing the value of systemEventClass() as the first argument and the instance of the class to which this annotation is attached (which must implement SystemEventListener) as the second argument.

      Otherwise, call Application.subscribeToEvent(Class, Class, SystemEventListener), passing the value of systemEventClass() as the first argument, the value of sourceClass() as the second argument, and the instance of the class to which this annotation is attached (which must implement SystemEventListener) as the third argument.

    Example: The standard renderer for javax.faces.resource.Stylesheet must have the following annotation declaration:

    @ListenerFor(systemEventClass=PostAddToViewEvent.class)

    This will cause the renderer to be added as a listener for the PostAddToViewEvent to all components that list it as their renderer.

    Since:
    2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<? extends SystemEvent> systemEventClass

      The kind of system event for which this class will be installed as a listener.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class sourceClass

      The kind of object that emits events of the type given by the value of the systemEventClass() attribute.

    • Element Detail

      • systemEventClass

        public abstract Class<? extends SystemEvent> systemEventClass

        The kind of system event for which this class will be installed as a listener. The implementation only supports exact matches on the Class and must not honor subclass relationships. It is valid to have EL Expressions in the value of this attribute, as long as the expression resolves to an instance of the expected type.

      • sourceClass

        public abstract Class sourceClass

        The kind of object that emits events of the type given by the value of the systemEventClass() attribute. It is valid to have EL Expressions in the value of this attribute, as long as the expression resolves to an instance of the expected type.

        Default:
        java.lang.Void.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ListenersFor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.event

Annotation Type ListenersFor

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface ListenersFor

    Container annotation to specify multiple ListenerFor annotations on a single class. Example:

    @ListenersFor({
        @ListenerFor(systemEventClass=PostAddToViewEvent.class),
        @ListenerFor(systemEventClass=BeforeRenderEvent.class,
                     sourceClass=CustomOutput.class)
    })

    The action described in ListenerFor must be taken for each @ListenerFor present in the container annotation.

    Since:
    2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      ListenerFor[] value

    • Element Detail

      • value

        public abstract ListenerFor[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MethodExpressionActionListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class MethodExpressionActionListener

  • java.lang.Object
    • javax.faces.event.MethodExpressionActionListener
  • All Implemented Interfaces:
    EventListener, StateHolder, ActionListener, FacesListener

    public class MethodExpressionActionListener
extends Object
implements ActionListener, StateHolder

    MethodExpressionActionListener is an ActionListener that wraps a MethodExpression. When it receives a ActionEvent, it executes a method on an object identified by the MethodExpression.

    • Field Summary

      • Fields inherited from interface javax.faces.event.ActionListener

        TO_FLOW_DOCUMENT_ID_ATTR_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodExpressionActionListener()
      MethodExpressionActionListener(MethodExpression methodExpressionOneArg)
      Construct a ValueChangeListener that contains a MethodExpression.
      MethodExpressionActionListener(MethodExpression methodExpressionOneArg, MethodExpression methodExpressionZeroArg)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void processAction(ActionEvent actionEvent)
      Call through to the MethodExpression passed in our constructor.
      void restoreState(FacesContext context, Object state)

      Both MethodExpression instances described in the constructor must be restored.
      Object saveState(FacesContext context)

      Both MethodExpression instances described in the constructor must be saved.
      void setTransient(boolean newTransientValue)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MethodExpressionActionListener

        public MethodExpressionActionListener()

      • MethodExpressionActionListener

        public MethodExpressionActionListener(MethodExpression methodExpressionOneArg)

        Construct a ValueChangeListener that contains a MethodExpression. To accomodate method expression targets that take no arguments instead of taking an ActionEvent argument, the implementation of this class must take the argument methodExpressionOneArg, extract its expression string, and create another MethodExpression whose expected param types match those of a zero argument method. The usage requirements for both of these MethodExpression instances are described in processAction(javax.faces.event.ActionEvent).

        Parameters:
        methodExpressionOneArg - a MethodExpression that points to a method that returns void and takes a single argument of type ActionEvent.

      • MethodExpressionActionListener

        public MethodExpressionActionListener(MethodExpression methodExpressionOneArg,
                              MethodExpression methodExpressionZeroArg)

    • Method Detail

      • processAction

        public void processAction(ActionEvent actionEvent)
                   throws AbortProcessingException

        Call through to the MethodExpression passed in our constructor. First, try to invoke the MethodExpression passed to the constructor of this instance, passing the argument ActionEvent as the argument. If a MethodNotFoundException is thrown, call to the zero argument MethodExpression derived from the MethodExpression passed to the constructor of this instance. If that fails for any reason, throw an AbortProcessingException, including the cause of the failure.

        Specified by:
        processAction in interface ActionListener
        Parameters:
        actionEvent - The ActionEvent that has occurred
        Throws:
        NullPointerException
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed

      • saveState

        public Object saveState(FacesContext context)

        Both MethodExpression instances described in the constructor must be saved.

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)

        Both MethodExpression instances described in the constructor must be restored.

        Specified by:
        restoreState in interface StateHolder

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean newTransientValue)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        newTransientValue - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MethodExpressionValueChangeListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class MethodExpressionValueChangeListener

  • java.lang.Object
    • javax.faces.event.MethodExpressionValueChangeListener
  • All Implemented Interfaces:
    EventListener, StateHolder, FacesListener, ValueChangeListener

    public class MethodExpressionValueChangeListener
extends Object
implements ValueChangeListener, StateHolder

    MethodExpressionValueChangeListener is a ValueChangeListener that wraps a MethodExpression. When it receives a ValueChangeEvent, it executes a method on an object identified by the MethodExpression.

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodExpressionValueChangeListener()
      MethodExpressionValueChangeListener(MethodExpression methodExpressionOneArg)
      Construct a ValueChangeListener that contains a MethodExpression.To accomodate method expression targets that take no arguments instead of taking a ValueChangeEvent argument, the implementation of this class must take the argument methodExpressionOneArg, extract its expression string, and create another MethodExpression whose expected param types match those of a zero argument method.
      MethodExpressionValueChangeListener(MethodExpression methodExpressionOneArg, MethodExpression methodExpressionZeroArg)
      Construct a ValueChangeListener that contains a MethodExpression.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void processValueChange(ValueChangeEvent valueChangeEvent)
      Call through to the MethodExpression passed in our constructor.
      void restoreState(FacesContext context, Object state)

      Both MethodExpression instances described in the constructor must be restored.
      Object saveState(FacesContext context)

      Both MethodExpression instances described in the constructor must be saved.
      void setTransient(boolean newTransientValue)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MethodExpressionValueChangeListener

        public MethodExpressionValueChangeListener()

      • MethodExpressionValueChangeListener

        public MethodExpressionValueChangeListener(MethodExpression methodExpressionOneArg)

        Construct a ValueChangeListener that contains a MethodExpression.To accomodate method expression targets that take no arguments instead of taking a ValueChangeEvent argument, the implementation of this class must take the argument methodExpressionOneArg, extract its expression string, and create another MethodExpression whose expected param types match those of a zero argument method. The usage requirements for both of these MethodExpression instances are described in processValueChange(javax.faces.event.ValueChangeEvent).

        Parameters:
        methodExpressionOneArg - a MethodExpression that points to a method that returns void and takes a single argument of type ValueChangeEvent.

      • MethodExpressionValueChangeListener

        public MethodExpressionValueChangeListener(MethodExpression methodExpressionOneArg,
                                   MethodExpression methodExpressionZeroArg)

        Construct a ValueChangeListener that contains a MethodExpression.

    • Method Detail

      • processValueChange

        public void processValueChange(ValueChangeEvent valueChangeEvent)
                        throws AbortProcessingException

        Call through to the MethodExpression passed in our constructor. First, try to invoke the MethodExpression passed to the constructor of this instance, passing the argument ValueChangeEvent as the argument. If a MethodNotFoundException is thrown, call to the zero argument MethodExpression derived from the MethodExpression passed to the constructor of this instance. If that fails for any reason, throw an AbortProcessingException, including the cause of the failure.

        Specified by:
        processValueChange in interface ValueChangeListener
        Parameters:
        valueChangeEvent - The ValueChangeEvent that has occurred
        Throws:
        NullPointerException - if the argument valueChangeEvent is null.
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed

      • saveState

        public Object saveState(FacesContext context)

        Both MethodExpression instances described in the constructor must be saved.

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)

        Both MethodExpression instances described in the constructor must be restored.

        Specified by:
        restoreState in interface StateHolder

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean newTransientValue)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        newTransientValue - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NamedEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.event

Annotation Type NamedEvent

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface NamedEvent

    The presence of this annotation on a class automatically registers the class with the runtime as a ComponentSystemEvent for use with the <f:event /> tag in a page. The value of the shortName() attribute is taken to be the short name for the ComponentSystemEvent. If the shortName has already been registered, the current class must be added to a List of of duplicate events for that name. If the event name is then referenced by an application, a FacesException must be thrown listing the shortName and the offending classes.

    Since:
    2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String shortName

      The value of this annotation attribute is taken to be the short name for the ComponentSystemEvent.

    • Element Detail

      • shortName

        public abstract String shortName

        The value of this annotation attribute is taken to be the short name for the ComponentSystemEvent. If the value of this attribute is ommitted, the following algorithm must be used by the code that processes this annotation to determine its value.

        1. Get the unqualified class name (e.g., UserLoginEvent)

        2. Strip off the trailing "Event", if present (e.g., UserLogin)

        3. Convert the first character to lower-case (e.g., userLogin)

        4. Prepend the package name to the lower-cased name.

        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PhaseEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PhaseEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.PhaseEvent
  • All Implemented Interfaces:
    Serializable

    public class PhaseEvent
extends EventObject

    PhaseEvent represents the beginning or ending of processing for a particular phase of the request processing lifecycle, for the request encapsulated by the specified FacesContext.

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PhaseEvent(FacesContext context, PhaseId phaseId, Lifecycle lifecycle)
      Construct a new event object from the specified parameters.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      FacesContext getFacesContext()
      Return the FacesContext for the request being processed.
      PhaseId getPhaseId()
      Return the PhaseId representing the current request processing lifecycle phase.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PhaseEvent

        public PhaseEvent(FacesContext context,
          PhaseId phaseId,
          Lifecycle lifecycle)

        Construct a new event object from the specified parameters. The specified Lifecycle will be the source of this event.

        Parameters:
        context - FacesContext for the current request
        phaseId - Identifier of the current request processing lifecycle phase
        lifecycle - Lifecycle instance
        Throws:
        NullPointerException - if context or phaseId or Lifecycleis null

    • Method Detail

      • getFacesContext

        public FacesContext getFacesContext()

        Return the FacesContext for the request being processed.

      • getPhaseId

        public PhaseId getPhaseId()

        Return the PhaseId representing the current request processing lifecycle phase.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PhaseId (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PhaseId

  • java.lang.Object
    • javax.faces.event.PhaseId
  • All Implemented Interfaces:
    Comparable

    public class PhaseId
extends Object
implements Comparable

    Typesafe enumeration of the legal values that may be returned by the getPhaseId() method of the FacesEvent interface.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static PhaseId ANY_PHASE
      Identifier that indicates an interest in events, no matter which request processing phase is being performed.
      static PhaseId APPLY_REQUEST_VALUES
      Identifier that indicates an interest in events queued for the Apply Request Values phase of the request processing lifecycle.
      static PhaseId INVOKE_APPLICATION
      Identifier that indicates an interest in events queued for the Invoke Application phase of the request processing lifecycle.
      static PhaseId PROCESS_VALIDATIONS
      Identifier that indicates an interest in events queued for the Process Validations phase of the request processing lifecycle.
      static PhaseId RENDER_RESPONSE
      Identifier for the Render Response phase of the request processing lifecycle.
      static PhaseId RESTORE_VIEW
      Identifier that indicates an interest in events queued for the Restore View phase of the request processing lifecycle.
      static PhaseId UPDATE_MODEL_VALUES
      Identifier that indicates an interest in events queued for the Update Model Values phase of the request processing lifecycle.
      static List<PhaseId> VALUES
      List of valid PhaseId instances, in ascending order of their ordinal value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int compareTo(Object other)
      Compare this PhaseId instance to the specified one.
      String getName()

      Return the name of this phase.
      int getOrdinal()
      Return the ordinal value of this PhaseId instance.
      static PhaseId phaseIdValueOf(String phase)

      Return a PhaseId representation of the arcument phase.
      String toString()
      Return a String representation of this PhaseId instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • ANY_PHASE

        public static final PhaseId ANY_PHASE

        Identifier that indicates an interest in events, no matter which request processing phase is being performed.

      • RESTORE_VIEW

        public static final PhaseId RESTORE_VIEW

        Identifier that indicates an interest in events queued for the Restore View phase of the request processing lifecycle.

      • APPLY_REQUEST_VALUES

        public static final PhaseId APPLY_REQUEST_VALUES

        Identifier that indicates an interest in events queued for the Apply Request Values phase of the request processing lifecycle.

      • PROCESS_VALIDATIONS

        public static final PhaseId PROCESS_VALIDATIONS

        Identifier that indicates an interest in events queued for the Process Validations phase of the request processing lifecycle.

      • UPDATE_MODEL_VALUES

        public static final PhaseId UPDATE_MODEL_VALUES

        Identifier that indicates an interest in events queued for the Update Model Values phase of the request processing lifecycle.

      • INVOKE_APPLICATION

        public static final PhaseId INVOKE_APPLICATION

        Identifier that indicates an interest in events queued for the Invoke Application phase of the request processing lifecycle.

      • RENDER_RESPONSE

        public static final PhaseId RENDER_RESPONSE

        Identifier for the Render Response phase of the request processing lifecycle.

      • VALUES

        public static final List<PhaseId> VALUES

        List of valid PhaseId instances, in ascending order of their ordinal value.

    • Method Detail

      • compareTo

        public int compareTo(Object other)

        Compare this PhaseId instance to the specified one. Returns a negative integer, zero, or a positive integer if this object is less than, equal to, or greater than the specified object.

        Specified by:
        compareTo in interface Comparable
        Parameters:
        other - The other object to be compared to

      • getOrdinal

        public int getOrdinal()

        Return the ordinal value of this PhaseId instance.

      • toString

        public String toString()

        Return a String representation of this PhaseId instance.

        Overrides:
        toString in class Object

      • getName

        public String getName()

        Return the name of this phase.

        Since:
        2.2

      • phaseIdValueOf

        public static PhaseId phaseIdValueOf(String phase)

        Return a PhaseId representation of the arcument phase.

        Parameters:
        phase - the String for which the corresponding PhaseId should be returned.
        Throws:
        NullPointerException - if argument phase is null.
        FacesException - if the PhaseId corresponding to the argument phase cannot be found.
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PhaseListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Interface PhaseListener

  • All Superinterfaces:
    EventListener, Serializable

    public interface PhaseListener
extends EventListener, Serializable

    An interface implemented by objects that wish to be notified at the beginning and ending of processing for each standard phase of the request processing lifecycle.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterPhase(PhaseEvent event)
      Handle a notification that the processing for a particular phase has just been completed.
      void beforePhase(PhaseEvent event)
      Handle a notification that the processing for a particular phase of the request processing lifecycle is about to begin.
      PhaseId getPhaseId()
      Return the identifier of the request processing phase during which this listener is interested in processing PhaseEvent events.

    • Method Detail

      • afterPhase

        void afterPhase(PhaseEvent event)

        Handle a notification that the processing for a particular phase has just been completed.

      • beforePhase

        void beforePhase(PhaseEvent event)

        Handle a notification that the processing for a particular phase of the request processing lifecycle is about to begin.

      • getPhaseId

        PhaseId getPhaseId()

        Return the identifier of the request processing phase during which this listener is interested in processing PhaseEvent events. Legal values are the singleton instances defined by the PhaseId class, including PhaseId.ANY_PHASE to indicate an interest in being notified for all standard phases.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PostAddToViewEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PostAddToViewEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PostAddToViewEvent
  • All Implemented Interfaces:
    Serializable

    public class PostAddToViewEvent
extends ComponentSystemEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is a UIComponent instance and that either that instance or an ancestor of that instance was just added to the view. Therefore, the implementation may assume it is safe to call UIComponent.getParent(), UIComponent.getClientId(), and other methods that depend upon the component instance being added into the view.

    The implementation must guarantee that Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) is called, immediately after any UIComponent instance is added to the view hierarchy except in the case where ResponseStateManager.isPostback(javax.faces.context.FacesContext) returns true at the same time as FacesContext.getCurrentPhaseId() returns PhaseId.RESTORE_VIEW. When both of those conditions are met, Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) must not be called.

    The implementation must guarantee that Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) is called in the following cases.

    • Upon the initial construction of the view, when each instance is added to the view.

    • On a non-initial rendering of the view, if a component is added to the view by the View Declaration Language implememtation as a result of changes in evaluation result of EL expressions referenced by VDL tags such as c:if, ui:include, and other tags that dynamically influence the assembly of the view.

    • If a component is programmatically added to the view using the Java API directly. For example, user code manually adds children using comp.getChildren().add(), where comp is a UIComponent.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PostAddToViewEvent(UIComponent component)

      Instantiate a new PostAddToViewEvent that indicates the argument component was just added to the view.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isAppropriateListener(FacesListener listener)

      Returns true if and only if the argument listener is an instance of SystemEventListener.

      • Methods inherited from class javax.faces.event.ComponentSystemEvent

        getComponent, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PostAddToViewEvent

        public PostAddToViewEvent(UIComponent component)

        Instantiate a new PostAddToViewEvent that indicates the argument component was just added to the view.

        Parameters:
        component - the UIComponent that has just been added to the view.
        Throws:
        IllegalArgumentException - if the argument is null.

    • Method Detail

      • isAppropriateListener

        public boolean isAppropriateListener(FacesListener listener)

        Returns true if and only if the argument listener is an instance of SystemEventListener.

        Overrides:
        isAppropriateListener in class ComponentSystemEvent
        Parameters:
        listener -
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PostConstructApplicationEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PostConstructApplicationEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.PostConstructApplicationEvent
  • All Implemented Interfaces:
    Serializable

    public class PostConstructApplicationEvent
extends SystemEvent

    This event must be published by the runtime after all configuration resources have been parsed and processed.

    This event is useful for listeners that need to perform custom post-configuration processing without having to rely on ServletContextListeners which may be invoked before the JavaServer Faces runtime has started it's configuration process.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PostConstructApplicationEvent(Application application)

      Constructs a new AppliationPostConstructEvent for this application.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Application getApplication()

      The source Application that sent this event.

      • Methods inherited from class javax.faces.event.SystemEvent

        isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PostConstructApplicationEvent

        public PostConstructApplicationEvent(Application application)

        Constructs a new AppliationPostConstructEvent for this application.

        Parameters:
        application - the application that has been configured
        Since:
        2.0

    • Method Detail

      • getApplication

        public Application getApplication()

        The source Application that sent this event.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PostConstructCustomScopeEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PostConstructCustomScopeEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.PostConstructCustomScopeEvent
  • All Implemented Interfaces:
    Serializable

    public class PostConstructCustomScopeEvent
extends SystemEvent

    This class is provided to allow custom scopes to publish a "post construct" event in the same way that other scopes do to let the application become aware of the beginning of the scope. The runtime must listen for this event and invoke any PostConstruct annotated methods on any of the beans in this scope as appropriate. The following code can be used as a template for publishing such an event.

Map<String, Object> myScope = getMyScope();
ScopeContext scopeContext = new ScopeContext("myScope", myScope);
applicationPublishEvent(PostConstructCustomScopeEvent.class, scopeContext);

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PostConstructCustomScopeEvent(ScopeContext scopeContext)

      An instance of this event indicates that the custom scope enclosed within the argument scopeContext was just created.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ScopeContext getContext()

      Return the ScopeContext for this event.

      • Methods inherited from class javax.faces.event.SystemEvent

        isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PostConstructCustomScopeEvent

        public PostConstructCustomScopeEvent(ScopeContext scopeContext)

        An instance of this event indicates that the custom scope enclosed within the argument scopeContext was just created.

        Parameters:
        scopeContext - A structure that contains the name of the scope and the scope itself exposed as a Map<String, Object>.

    • Method Detail

      • getContext

        public ScopeContext getContext()

        Return the ScopeContext for this event.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PostConstructViewMapEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PostConstructViewMapEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PostConstructViewMapEvent
  • All Implemented Interfaces:
    Serializable

    public class PostConstructViewMapEvent
extends ComponentSystemEvent

    This event must be published by a call to {javax.faces.application.Application#publishEvent} when the view map is first created. This must happen on the first time a call is made to UIViewRoot.getViewMap() on a UIViewRoot instance. The source for this event is the UIViewRoot.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PostConstructViewMapEvent(UIViewRoot root)

      Instantiate a new PostConstructViewMapEvent that indicates the argument root was just associated with its view map.

    • Method Summary

      • Methods inherited from class javax.faces.event.ComponentSystemEvent

        getComponent, isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PostConstructViewMapEvent

        public PostConstructViewMapEvent(UIViewRoot root)

        Instantiate a new PostConstructViewMapEvent that indicates the argument root was just associated with its view map.

        Parameters:
        root - the UIViewRoot for which a view map has just been created.
        Throws:
        IllegalArgumentException - if the argument is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PostKeepFlashValueEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PostKeepFlashValueEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.PostKeepFlashValueEvent
  • All Implemented Interfaces:
    Serializable

    public class PostKeepFlashValueEvent
extends SystemEvent

    This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is kept in the flash.

    Since:
    2.2
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PostKeepFlashValueEvent(String key)

      Instantiate a new PostKeepFlashValueEvent that indicates the argument key was just kept in the flash.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getKey()

      • Methods inherited from class javax.faces.event.SystemEvent

        isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PostKeepFlashValueEvent

        public PostKeepFlashValueEvent(String key)

        Instantiate a new PostKeepFlashValueEvent that indicates the argument key was just kept in the flash. If the argument is null, the literal Flash.NULL_VALUE must be passed to the superclass constructor.

        Parameters:
        key - the key in the flash that was just kept.

    • Method Detail

      • getKey

        public String getKey()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PostPutFlashValueEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PostPutFlashValueEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.PostPutFlashValueEvent
  • All Implemented Interfaces:
    Serializable

    public class PostPutFlashValueEvent
extends SystemEvent

    This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is stored in the flash.

    Since:
    2.2
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PostPutFlashValueEvent(String key)

      Instantiate a new PostPutFlashValueEvent that indicates the argument key was just put to the flash.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getKey()

      • Methods inherited from class javax.faces.event.SystemEvent

        isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PostPutFlashValueEvent

        public PostPutFlashValueEvent(String key)

        Instantiate a new PostPutFlashValueEvent that indicates the argument key was just put to the flash. If the argument is null, the literal Flash.NULL_VALUE must be passed to the superclass constructor.

        Parameters:
        key - the key in the flash that was just added.

    • Method Detail

      • getKey

        public String getKey()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PostRestoreStateEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PostRestoreStateEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PostRestoreStateEvent
  • All Implemented Interfaces:
    Serializable

    public class PostRestoreStateEvent
extends ComponentSystemEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is in a tree that has just had its state restored.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PostRestoreStateEvent(UIComponent component)

      Instantiate a new PostRestoreStateEvent that indicates the argument component just had its state restored.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void | setComponent(UIComponent newComponent)

      • Methods inherited from class javax.faces.event.ComponentSystemEvent

        getComponent, isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PostRestoreStateEvent

        public PostRestoreStateEvent(UIComponent component)

        Instantiate a new PostRestoreStateEvent that indicates the argument component just had its state restored.

        Parameters:
        component - the UIComponent whose state was just restored.
        Throws:
        IllegalArgumentException - if the argument is null.

    • Method Detail

      • setComponent

        public void setComponent(UIComponent newComponent)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PostValidateEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PostValidateEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PostValidateEvent
  • All Implemented Interfaces:
    Serializable

    public class PostValidateEvent
extends ComponentSystemEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is that has just been validated.

    Components with children must publish this event after processing their child nodes in UIComponent.processValidators(javax.faces.context.FacesContext). This is especially important for iterating components such as UIData, and form components, such as UIForm.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PostValidateEvent(UIComponent component)

    • Method Summary

      • Methods inherited from class javax.faces.event.ComponentSystemEvent

        getComponent, isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PostValidateEvent

        public PostValidateEvent(UIComponent component)

        Parameters:
        component - the UIComponent that is about to be validated.
        Throws:
        IllegalArgumentException - if the argument is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PreClearFlashEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PreClearFlashEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.PreClearFlashEvent
  • All Implemented Interfaces:
    Serializable

    public class PreClearFlashEvent
extends SystemEvent

    This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) before the flash is cleared.

    Since:
    2.2
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PreClearFlashEvent(Map<String,Object> source)

      Instantiate a new PreClearFlashEvent that indicates the argument key was just put to the flash.

    • Method Summary

      • Methods inherited from class javax.faces.event.SystemEvent

        isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PreClearFlashEvent

        public PreClearFlashEvent(Map<String,Object> source)

        Instantiate a new PreClearFlashEvent that indicates the argument key was just put to the flash.

        Parameters:
        source - Map containing the values about to be cleared This need not be the actual Flash instance.
        Throws:
        IllegalArgumentException - if the argument is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PreDestroyApplicationEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PreDestroyApplicationEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.PreDestroyApplicationEvent
  • All Implemented Interfaces:
    Serializable

    public class PreDestroyApplicationEvent
extends SystemEvent

    This event must be published by the runtime before the factories associated with this Application are released.

    This event is useful for listeners that need to perform custom shutdown processing without having to rely on ServletContextListeners which will be invoked after all of the application artifacts have been removed.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PreDestroyApplicationEvent(Application application)

      Constructs a new PreDestroyApplicationEvent for this application.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Application getApplication()

      The source Application that sent this event.

      • Methods inherited from class javax.faces.event.SystemEvent

        isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PreDestroyApplicationEvent

        public PreDestroyApplicationEvent(Application application)

        Constructs a new PreDestroyApplicationEvent for this application.

        Parameters:
        application - the application that has been configured
        Since:
        2.0

    • Method Detail

      • getApplication

        public Application getApplication()

        The source Application that sent this event.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PreDestroyCustomScopeEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PreDestroyCustomScopeEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.PreDestroyCustomScopeEvent
  • All Implemented Interfaces:
    Serializable

    public class PreDestroyCustomScopeEvent
extends SystemEvent

    This class is provided to allow custom scopes to publish a "pre construct" event in the same way that other scopes do to let the application become aware of the beginning of the scope. The runtime must listen for this event and invoke any PreDestroy annotated methods on any of the beans in this scope as appropriate. See the example code on PostConstructCustomScopeEvent for a usage example, replacing classes as appropriate to make sense for this class.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PreDestroyCustomScopeEvent(ScopeContext scopeContext)

      An instance of this event indicates that the custom scope enclosed within the argument scopeContext is about to end.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ScopeContext getContext()

      Return the ScopeContext for this event.

      • Methods inherited from class javax.faces.event.SystemEvent

        isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PreDestroyCustomScopeEvent

        public PreDestroyCustomScopeEvent(ScopeContext scopeContext)

        An instance of this event indicates that the custom scope enclosed within the argument scopeContext is about to end.

        Parameters:
        scopeContext - A structure that contains the name of the scope and the scope itself exposed as a Map<String, Object>.

    • Method Detail

      • getContext

        public ScopeContext getContext()

        Return the ScopeContext for this event.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PreDestroyViewMapEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PreDestroyViewMapEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PreDestroyViewMapEvent
  • All Implemented Interfaces:
    Serializable

    public class PreDestroyViewMapEvent
extends ComponentSystemEvent

    This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when the clear method is called on the map returned from UIViewRoot.getViewMap().

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PreDestroyViewMapEvent(UIViewRoot root)

      Instantiate a new ViewMapDestroydEvent that indicates the argument root just had its associated view map destroyed.

    • Method Summary

      • Methods inherited from class javax.faces.event.ComponentSystemEvent

        getComponent, isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PreDestroyViewMapEvent

        public PreDestroyViewMapEvent(UIViewRoot root)

        Instantiate a new ViewMapDestroydEvent that indicates the argument root just had its associated view map destroyed.

        Parameters:
        root - the UIViewRoot for which the view map has just been destroyed.
        Throws:
        IllegalArgumentException - if the argument is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PreRemoveFlashValueEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PreRemoveFlashValueEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.PreRemoveFlashValueEvent
  • All Implemented Interfaces:
    Serializable

    public class PreRemoveFlashValueEvent
extends SystemEvent

    This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is removed from the flash.

    Since:
    2.2
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PreRemoveFlashValueEvent(String key)

      Instantiate a new PreRemoveFlashValueEvent that indicates the argument key will be removed from the flash.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getKey()

      • Methods inherited from class javax.faces.event.SystemEvent

        isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PreRemoveFlashValueEvent

        public PreRemoveFlashValueEvent(String key)

        Instantiate a new PreRemoveFlashValueEvent that indicates the argument key will be removed from the flash. If the argument is null, the literal Flash.NULL_VALUE must be passed to the superclass constructor.

        Parameters:
        key - the key in the flash that was just added.

    • Method Detail

      • getKey

        public String getKey()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PreRemoveFromViewEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PreRemoveFromViewEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PreRemoveFromViewEvent
  • All Implemented Interfaces:
    Serializable

    public class PreRemoveFromViewEvent
extends ComponentSystemEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is a UIComponent instance that is about to be removed from the view. Therefore, the implementation may assume it is safe to call UIComponent.getParent(), UIComponent.getClientId(), and other methods that depend upon the component instance being added into the view.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PreRemoveFromViewEvent(UIComponent component)

      Instantiate a new BeforeRemoveFromView that indicates the argument component is about to be removed from the view.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isAppropriateListener(FacesListener listener)

      Returns true if and only if the argument listener is an instance of SystemEventListener.

      • Methods inherited from class javax.faces.event.ComponentSystemEvent

        getComponent, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PreRemoveFromViewEvent

        public PreRemoveFromViewEvent(UIComponent component)

        Instantiate a new BeforeRemoveFromView that indicates the argument component is about to be removed from the view.

        Parameters:
        component - the UIComponent that is about to be removed from the view.
        Throws:
        IllegalArgumentException - if component is null

    • Method Detail

      • isAppropriateListener

        public boolean isAppropriateListener(FacesListener listener)

        Returns true if and only if the argument listener is an instance of SystemEventListener.

        Overrides:
        isAppropriateListener in class ComponentSystemEvent
        Parameters:
        listener -
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PreRenderComponentEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PreRenderComponentEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PreRenderComponentEvent
  • All Implemented Interfaces:
    Serializable

    public class PreRenderComponentEvent
extends ComponentSystemEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is about to be rendered and that it is safe to call UIComponent.getParent(), UIComponent.getClientId(), and other methods that depend upon the component instance being in the view.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PreRenderComponentEvent(UIComponent component)

      Instantiate a new PreRenderComponentEvent that indicates the argument component is about to be rendered.

    • Method Summary

      • Methods inherited from class javax.faces.event.ComponentSystemEvent

        getComponent, isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PreRenderComponentEvent

        public PreRenderComponentEvent(UIComponent component)

        Instantiate a new PreRenderComponentEvent that indicates the argument component is about to be rendered.

        Parameters:
        component - the UIComponent that is about to be rendered.
        Throws:
        IllegalArgumentException - if the argument is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PreRenderViewEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PreRenderViewEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PreRenderViewEvent
  • All Implemented Interfaces:
    Serializable

    public class PreRenderViewEvent
extends ComponentSystemEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIViewRoot instance that is about to be rendered.

    It is valid for a listener for this event to change the UIViewRoot in the current FacesContext, but the listener must ensure that the new UIViewRoot was created with a call to ViewHandler.createView(javax.faces.context.FacesContext, java.lang.String), and that the view is fully populated with the children to be traversed during render. The listener implementation may call ViewDeclarationLanguage.buildView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) to populate the UIViewRoot.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PreRenderViewEvent(UIViewRoot root)

      Instantiate a new PreRenderViewEvent that indicates the argument root is about to be rendered.

    • Method Summary

      • Methods inherited from class javax.faces.event.ComponentSystemEvent

        getComponent, isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PreRenderViewEvent

        public PreRenderViewEvent(UIViewRoot root)

        Instantiate a new PreRenderViewEvent that indicates the argument root is about to be rendered.

        Parameters:
        root - the UIViewRoot that is about to be rendered.
        Throws:
        IllegalArgumentException - if the argument is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PreValidateEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class PreValidateEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PreValidateEvent
  • All Implemented Interfaces:
    Serializable

    public class PreValidateEvent
extends ComponentSystemEvent

    When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is about to be validated.

    Components with children must publish this event before processing their child nodes in UIComponent.processValidators(javax.faces.context.FacesContext). This is especially important for iterating components such as UIData, and form components, such as UIForm.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      PreValidateEvent(UIComponent component)

    • Method Summary

      • Methods inherited from class javax.faces.event.ComponentSystemEvent

        getComponent, isAppropriateListener, processListener

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PreValidateEvent

        public PreValidateEvent(UIComponent component)

        Parameters:
        component - the UIComponent that is about to be validated.
        Throws:
        IllegalArgumentException - if the argument is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ScopeContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class ScopeContext

  • java.lang.Object
    • javax.faces.event.ScopeContext

  • public class ScopeContext
extends Object

    A structure that contains the name of the scope and the scope itself exposed as a Map<String, Object>.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ScopeContext(String scopeName, Map<String,Object> scope)

      Construct this structure with the supplied arguments.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Map<String,Object> getScope()

      Return the scope itself, exposed as a Map.
      String getScopeName()

      Return the name of this custom scope.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ScopeContext

        public ScopeContext(String scopeName,
            Map<String,Object> scope)

        Construct this structure with the supplied arguments.

        Parameters:
        scopeName - the name of the scope
        scope - the scope itself

    • Method Detail

      • getScopeName

        public String getScopeName()

        Return the name of this custom scope.

      • getScope

        public Map<String,Object> getScope()

        Return the scope itself, exposed as a Map.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SystemEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class SystemEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.SystemEvent
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ComponentSystemEvent, ExceptionQueuedEvent, PostConstructApplicationEvent, PostConstructCustomScopeEvent, PostKeepFlashValueEvent, PostPutFlashValueEvent, PreClearFlashEvent, PreDestroyApplicationEvent, PreDestroyCustomScopeEvent, PreRemoveFlashValueEvent

    public abstract class SystemEvent
extends EventObject

    SystemEvent is the base class for non-application specific events that can be fired by arbitrary objects.

    Since:
    2.0
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      SystemEvent(Object source)

      Pass the argument source to the superclass constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isAppropriateListener(FacesListener listener)
      Return true if this FacesListener is an instance of a the appropriate listener class that this event supports.
      void processListener(FacesListener listener)
      Broadcast this event instance to the specified FacesListener, by whatever mechanism is appropriate.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SystemEvent

        public SystemEvent(Object source)

        Pass the argument source to the superclass constructor.

        Parameters:
        source - the source reference to be passed to the superclass constructor.
        Throws:
        IllegalArgumentException - if the argument is null.

    • Method Detail

      • isAppropriateListener

        public boolean isAppropriateListener(FacesListener listener)

        Return true if this FacesListener is an instance of a the appropriate listener class that this event supports. The default implementation returns true if the listener is a ComponentSystemEventListener.

        Parameters:
        listener - FacesListener to evaluate

      • processListener

        public void processListener(FacesListener listener)

        Broadcast this event instance to the specified FacesListener, by whatever mechanism is appropriate. Typically, this will be accomplished by calling an event processing method, and passing this instance as a paramter.

        Parameters:
        listener - FacesListener to send this FacesEvent to
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SystemEventListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Interface SystemEventListener

  • All Superinterfaces:
    EventListener, FacesListener
    All Known Subinterfaces:
    ViewMapListener
    All Known Implementing Classes:
    ExceptionHandler, ExceptionHandlerWrapper

    public interface SystemEventListener
extends FacesListener

    By implementing this class, an object indicates that it is a listener for one or more kinds of SystemEvents. The exact type of event that will cause the implementing class's processEvent(javax.faces.event.SystemEvent) method to be called is indicated by the facesEventClass argument passed when the listener is installed using Application.subscribeToEvent(java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Class<?>, javax.faces.event.SystemEventListener).

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isListenerForSource(Object source)
      This method must return true if and only if this listener instance is interested in receiving events from the instance referenced by the source parameter.
      void processEvent(SystemEvent event)
      When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

    • Method Detail

      • processEvent

        void processEvent(SystemEvent event)
                  throws AbortProcessingException

        When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

        Parameters:
        event - the SystemEvent instance that is being processed.
        Throws:
        AbortProcessingException - if lifecycle processing should cease for this request.

      • isListenerForSource

        boolean isListenerForSource(Object source)

        This method must return true if and only if this listener instance is interested in receiving events from the instance referenced by the source parameter.

        Parameters:
        source - the source that is inquiring about the appropriateness of sending an event to this listener instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SystemEventListenerHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Interface SystemEventListenerHolder

  • All Known Implementing Classes:
    ExceptionQueuedEventContext, HtmlBody, HtmlColumn, HtmlCommandButton, HtmlCommandLink, HtmlDataTable, HtmlDoctype, HtmlForm, HtmlGraphicImage, HtmlHead, HtmlInputFile, HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlMessage, HtmlMessages, HtmlOutcomeTargetButton, HtmlOutcomeTargetLink, HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, HtmlPanelGrid, HtmlPanelGroup, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, UIColumn, UICommand, UIComponent, UIComponentBase, UIData, UIForm, UIGraphic, UIInput, UIMessage, UIMessages, UINamingContainer, UIOutcomeTarget, UIOutput, UIPanel, UIParameter, UISelectBoolean, UISelectItem, UISelectItems, UISelectMany, UISelectOne, UIViewAction, UIViewParameter, UIViewRoot

    public interface SystemEventListenerHolder

    Classes that implement this interface agree to maintain a list of SystemEventListener instances for each kind of SystemEvent they can generate. This interface enables arbitrary Objects to act as the source for SystemEvent instances.

    If the implementing class is a UIComponent or is referenced by a UIComponent, care must be taken to ensure that the implementing class, and all the members of the list returned by getListenersForEventClass(java.lang.Class<? extends javax.faces.event.SystemEvent>) work correctly with the state management system. One way to ensure this is to have the class and the list members implement StateHolder or Serializable.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<SystemEventListener> getListenersForEventClass(Class<? extends SystemEvent> facesEventClass)

    • Method Detail

      • getListenersForEventClass

        List<SystemEventListener> getListenersForEventClass(Class<? extends SystemEvent> facesEventClass)

        Return a List of SystemEventListener instances that have been installed into the class implementing this interface.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.event (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.event

  • Packages that use javax.faces.event
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.
  • Classes in javax.faces.event used by javax.faces.application
    Class and Description
    ActionListener
    A listener interface for receiving ActionEvents.
    SystemEvent
    SystemEvent is the base class for non-application specific events that can be fired by arbitrary objects.
    SystemEventListener

    By implementing this class, an object indicates that it is a listener for one or more kinds of SystemEvents.
  • Classes in javax.faces.event used by javax.faces.component
    Class and Description
    AbortProcessingException
    An exception that may be thrown by event listeners to terminate the processing of the current event.
    ActionListener
    A listener interface for receiving ActionEvents.
    ComponentSystemEvent
    ComponentSystemEvent is the base class for SystemEvents that are specific to a UIComponent instance.
    ComponentSystemEventListener

    Implementors of this class do not need an isListenerForSource() method because they are only installed on specific component instances, therefore the isListenerForSource() method is implicit.
    FacesEvent
    FacesEvent is the base class for user interface and application events that can be fired by UIComponents.
    FacesListener
    A generic base interface for event listeners for various types of FacesEvents.
    PhaseId
    Typesafe enumeration of the legal values that may be returned by the getPhaseId() method of the FacesEvent interface.
    PhaseListener
    An interface implemented by objects that wish to be notified at the beginning and ending of processing for each standard phase of the request processing lifecycle.
    SystemEvent
    SystemEvent is the base class for non-application specific events that can be fired by arbitrary objects.
    SystemEventListener

    By implementing this class, an object indicates that it is a listener for one or more kinds of SystemEvents.
    SystemEventListenerHolder

    Classes that implement this interface agree to maintain a list of SystemEventListener instances for each kind of SystemEvent they can generate.
    ValueChangeListener
    A listener interface for receiving ValueChangeEvents.
  • Classes in javax.faces.event used by javax.faces.component.behavior
    Class and Description
    AbortProcessingException
    An exception that may be thrown by event listeners to terminate the processing of the current event.
    AjaxBehaviorListener

    By implementing this class, an object indicates that it is a listener for one or more kinds of BehaviorEvents.
    BehaviorEvent
    BehaviorEvent is the event that can be generated from component Behavior.
    BehaviorListener

    A generic base interface for event listeners for various types of BehaviorEvents.
  • Classes in javax.faces.event used by javax.faces.component.html
    Class and Description
    ComponentSystemEventListener

    Implementors of this class do not need an isListenerForSource() method because they are only installed on specific component instances, therefore the isListenerForSource() method is implicit.
    FacesListener
    A generic base interface for event listeners for various types of FacesEvents.
    SystemEventListenerHolder

    Classes that implement this interface agree to maintain a list of SystemEventListener instances for each kind of SystemEvent they can generate.
  • Classes in javax.faces.event used by javax.faces.context
    Class and Description
    AbortProcessingException
    An exception that may be thrown by event listeners to terminate the processing of the current event.
    ExceptionQueuedEvent

    The system event facility will create an instance of this class whenever Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) is called with ExceptionQueuedEvent.class as systemEventClass argument.
    FacesListener
    A generic base interface for event listeners for various types of FacesEvents.
    PhaseId
    Typesafe enumeration of the legal values that may be returned by the getPhaseId() method of the FacesEvent interface.
    SystemEvent
    SystemEvent is the base class for non-application specific events that can be fired by arbitrary objects.
    SystemEventListener

    By implementing this class, an object indicates that it is a listener for one or more kinds of SystemEvents.
  • Classes in javax.faces.event used by javax.faces.event
    Class and Description
    AbortProcessingException
    An exception that may be thrown by event listeners to terminate the processing of the current event.
    ActionEvent
    An ActionEvent represents the activation of a user interface component (such as a UICommand).
    ActionListener
    A listener interface for receiving ActionEvents.
    AjaxBehaviorEvent
    AjaxBehaviorEvent represents the component behavior specific to Ajax).
    BehaviorEvent
    BehaviorEvent is the event that can be generated from component Behavior.
    BehaviorListener

    A generic base interface for event listeners for various types of BehaviorEvents.
    ComponentSystemEvent
    ComponentSystemEvent is the base class for SystemEvents that are specific to a UIComponent instance.
    ExceptionQueuedEventContext

    This helper class provides context to the ExceptionQueuedEvent regarding the state of the system at the point in time when the ExceptionQueuedEvent occurs and links the ExceptionQueuedEvent to the ExceptionHandler by virtue of implementing SystemEventListener.
    FacesEvent
    FacesEvent is the base class for user interface and application events that can be fired by UIComponents.
    FacesListener
    A generic base interface for event listeners for various types of FacesEvents.
    PhaseEvent
    PhaseEvent represents the beginning or ending of processing for a particular phase of the request processing lifecycle, for the request encapsulated by the specified FacesContext.
    PhaseId
    Typesafe enumeration of the legal values that may be returned by the getPhaseId() method of the FacesEvent interface.
    ScopeContext

    A structure that contains the name of the scope and the scope itself exposed as a Map<String, Object>.
    SystemEvent
    SystemEvent is the base class for non-application specific events that can be fired by arbitrary objects.
    SystemEventListener

    By implementing this class, an object indicates that it is a listener for one or more kinds of SystemEvents.
    SystemEventListenerHolder

    Classes that implement this interface agree to maintain a list of SystemEventListener instances for each kind of SystemEvent they can generate.
    ValueChangeEvent
    A ValueChangeEvent is a notification that the local value of the source component has been change as a result of user interface activity.
    ValueChangeListener
    A listener interface for receiving ValueChangeEvents.
  • Classes in javax.faces.event used by javax.faces.lifecycle
    Class and Description
    PhaseListener
    An interface implemented by objects that wish to be notified at the beginning and ending of processing for each standard phase of the request processing lifecycle.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValueChangeEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Class ValueChangeEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.event.FacesEvent
        • javax.faces.event.ValueChangeEvent
  • All Implemented Interfaces:
    Serializable

    public class ValueChangeEvent
extends FacesEvent

    A ValueChangeEvent is a notification that the local value of the source component has been change as a result of user interface activity. It is not fired unless validation of the new value was completed successfully.

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ValueChangeEvent(UIComponent component, Object oldValue, Object newValue)
      Construct a new event object from the specified source component, old value, and new value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getNewValue()
      Return the current local value of the source UIComponent.
      Object getOldValue()
      Return the previous local value of the source UIComponent.
      boolean isAppropriateListener(FacesListener listener)
      Return true if this FacesListener is an instance of a listener class that this event supports.
      void processListener(FacesListener listener)
      Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate.

      • Methods inherited from class javax.faces.event.FacesEvent

        getComponent, getPhaseId, queue, setPhaseId

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ValueChangeEvent

        public ValueChangeEvent(UIComponent component,
                Object oldValue,
                Object newValue)

        Construct a new event object from the specified source component, old value, and new value.

        The default PhaseId for this event is PhaseId.ANY_PHASE.

        Parameters:
        component - Source UIComponent for this event
        oldValue - The previous local value of this UIComponent
        newValue - The new local value of thie UIComponent
        Throws:
        IllegalArgumentException - if component is null

    • Method Detail

      • getOldValue

        public Object getOldValue()

        Return the previous local value of the source UIComponent.

      • getNewValue

        public Object getNewValue()

        Return the current local value of the source UIComponent.

      • isAppropriateListener

        public boolean isAppropriateListener(FacesListener listener)
        Description copied from class: FacesEvent

        Return true if this FacesListener is an instance of a listener class that this event supports. Typically, this will be accomplished by an "instanceof" check on the listener class.

        Specified by:
        isAppropriateListener in class FacesEvent
        Parameters:
        listener - FacesListener to evaluate

      • processListener

        public void processListener(FacesListener listener)
        Description copied from class: FacesEvent

        Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate. Typically, this will be accomplished by calling an event processing method, and passing this FacesEvent as a paramter.

        Specified by:
        processListener in class FacesEvent
        Parameters:
        listener - FacesListener to send this FacesEvent to
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValueChangeListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Interface ValueChangeListener

  • All Superinterfaces:
    EventListener, FacesListener
    All Known Implementing Classes:
    MethodExpressionValueChangeListener

    public interface ValueChangeListener
extends FacesListener

    A listener interface for receiving ValueChangeEvents. A class that is interested in receiving such events implements this interface, and then registers itself with the source UIComponent of interest, by calling addValueChangeListener().

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void processValueChange(ValueChangeEvent event)
      Invoked when the value change described by the specified ValueChangeEvent occurs.

    • Method Detail

      • processValueChange

        void processValueChange(ValueChangeEvent event)
                        throws AbortProcessingException

        Invoked when the value change described by the specified ValueChangeEvent occurs.

        Parameters:
        event - The ValueChangeEvent that has occurred
        Throws:
        AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ViewMapListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.event

Interface ViewMapListener

  • All Superinterfaces:
    EventListener, FacesListener, SystemEventListener

    public interface ViewMapListener
extends SystemEventListener

    Marker interface for SystemEvents that indicate the view map has been created (PostConstructViewMapEvent, or destroyed (PreDestroyViewMapEvent).

    Since:
    2.0

    • Method Summary

      • Methods inherited from interface javax.faces.event.SystemEventListener

        isListenerForSource, processEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.faces.event.AbortProcessingException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.AbortProcessingException

  • Packages that use AbortProcessingException
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of AbortProcessingException in javax.faces.component

      Methods in javax.faces.component that throw AbortProcessingException
      Modifier and Type | Method and Description
      void UIViewAction.broadcast(FacesEvent event)

      Enable the method invocation specified by this component instance to return a value that performs navigation, similar in spirit to UICommand.broadcast(javax.faces.event.FacesEvent).
      void UIData.broadcast(FacesEvent event)
      Override the default UIComponentBase.broadcast(javax.faces.event.FacesEvent) processing to unwrap any wrapped FacesEvent and reset the current row index, before the event is actually broadcast.
      void | UIComponentBase.broadcast(FacesEvent event)
      abstract void UIComponent.broadcast(FacesEvent event)
      Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type.
      void UICommand.broadcast(FacesEvent event)
      In addition to to the default UIComponent.broadcast(javax.faces.event.FacesEvent) processing, pass the ActionEvent being broadcast to the method referenced by actionListener (if any), and to the default ActionListener registered on the Application.
      void UIComponent.processEvent(ComponentSystemEvent event)

      The default implementation performs the following action.

    • Uses of AbortProcessingException in javax.faces.component.behavior

      Methods in javax.faces.component.behavior that throw AbortProcessingException
      Modifier and Type Method and Description
      void BehaviorBase.broadcast(BehaviorEvent event)

      Default implementation of Behavior.broadcast(javax.faces.event.BehaviorEvent).

    • Uses of AbortProcessingException in javax.faces.context

      Methods in javax.faces.context that throw AbortProcessingException
      Modifier and Type Method and Description
      void ExceptionHandlerWrapper.processEvent(SystemEvent event)
      The default behavior of this method is to call ExceptionHandler.processEvent(javax.faces.event.SystemEvent) on the wrapped ExceptionHandler object.
      abstract void ExceptionHandler.processEvent(SystemEvent exceptionQueuedEvent)
      When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

    • Uses of AbortProcessingException in javax.faces.event

      Methods in javax.faces.event that throw AbortProcessingException
      Modifier and Type | Method and Description
      void MethodExpressionActionListener.processAction(ActionEvent actionEvent)
      Call through to the MethodExpression passed in our constructor.
      void | ActionListenerWrapper.processAction(ActionEvent event)
      void ActionListener.processAction(ActionEvent event)
      Invoked when the action described by the specified ActionEvent occurs.
      void AjaxBehaviorListener.processAjaxBehavior(AjaxBehaviorEvent event)

      void ComponentSystemEventListener.processEvent(ComponentSystemEvent event)
      When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.
      void SystemEventListener.processEvent(SystemEvent event)
      When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.
      void ValueChangeListener.processValueChange(ValueChangeEvent event)
      Invoked when the value change described by the specified ValueChangeEvent occurs.
      void MethodExpressionValueChangeListener.processValueChange(ValueChangeEvent valueChangeEvent)
      Call through to the MethodExpression passed in our constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.ActionEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.ActionEvent

  • Packages that use ActionEvent
    Package Description
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of ActionEvent in javax.faces.event

      Methods in javax.faces.event with parameters of type ActionEvent
      Modifier and Type | Method and Description
      void MethodExpressionActionListener.processAction(ActionEvent actionEvent)
      Call through to the MethodExpression passed in our constructor.
      void | ActionListenerWrapper.processAction(ActionEvent event)
      void ActionListener.processAction(ActionEvent event)
      Invoked when the action described by the specified ActionEvent occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.ActionListenerWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.ActionListenerWrapper

No usage of javax.faces.event.ActionListenerWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.AjaxBehaviorEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.AjaxBehaviorEvent

  • Packages that use AjaxBehaviorEvent
    Package Description
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of AjaxBehaviorEvent in javax.faces.event

      Methods in javax.faces.event with parameters of type AjaxBehaviorEvent
      Modifier and Type Method and Description
      void AjaxBehaviorListener.processAjaxBehavior(AjaxBehaviorEvent event)

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.BehaviorEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.BehaviorEvent

  • Packages that use BehaviorEvent
    Package Description
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of BehaviorEvent in javax.faces.component.behavior

      Methods in javax.faces.component.behavior with parameters of type BehaviorEvent
      Modifier and Type Method and Description
      void BehaviorBase.broadcast(BehaviorEvent event)

      Default implementation of Behavior.broadcast(javax.faces.event.BehaviorEvent).
      void Behavior.broadcast(BehaviorEvent event)

      Broadcast the specified BehaviorEvent to all registered event listeners who have expressed an interest in events of this type.

    • Uses of BehaviorEvent in javax.faces.event

      Subclasses of BehaviorEvent in javax.faces.event
      Modifier and Type Class and Description
      class  AjaxBehaviorEvent
      AjaxBehaviorEvent represents the component behavior specific to Ajax).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.ComponentSystemEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.ComponentSystemEvent

  • Packages that use ComponentSystemEvent
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of ComponentSystemEvent in javax.faces.component

      Methods in javax.faces.component with parameters of type ComponentSystemEvent
      Modifier and Type Method and Description
      void UIComponent.processEvent(ComponentSystemEvent event)

      The default implementation performs the following action.

    • Uses of ComponentSystemEvent in javax.faces.event

      Subclasses of ComponentSystemEvent in javax.faces.event
      Modifier and Type Class and Description
      class  PostAddToViewEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is a UIComponent instance and that either that instance or an ancestor of that instance was just added to the view.
      class  PostConstructViewMapEvent

      This event must be published by a call to {javax.faces.application.Application#publishEvent} when the view map is first created.
      class  PostRestoreStateEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is in a tree that has just had its state restored.
      class  PostValidateEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is that has just been validated.
      class  PreDestroyViewMapEvent

      This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when the clear method is called on the map returned from UIViewRoot.getViewMap().
      class  PreRemoveFromViewEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is a UIComponent instance that is about to be removed from the view.
      class  PreRenderComponentEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is about to be rendered and that it is safe to call UIComponent.getParent(), UIComponent.getClientId(), and other methods that depend upon the component instance being in the view.
      class  PreRenderViewEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIViewRoot instance that is about to be rendered.
      class  PreValidateEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is about to be validated.
      Methods in javax.faces.event with parameters of type ComponentSystemEvent
      Modifier and Type Method and Description
      void ComponentSystemEventListener.processEvent(ComponentSystemEvent event)
      When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.ExceptionQueuedEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.ExceptionQueuedEvent

  • Packages that use ExceptionQueuedEvent
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.

    • Uses of ExceptionQueuedEvent in javax.faces.context

      Methods in javax.faces.context that return ExceptionQueuedEvent
      Modifier and Type Method and Description
      ExceptionQueuedEvent ExceptionHandlerWrapper.getHandledExceptionQueuedEvent()
      The default behavior of this method is to call ExceptionHandler.getHandledExceptionQueuedEvent() on the wrapped ExceptionHandler object.
      abstract ExceptionQueuedEvent ExceptionHandler.getHandledExceptionQueuedEvent()

      Return the first ExceptionQueuedEvent handled by this handler.
      Methods in javax.faces.context that return types with arguments of type ExceptionQueuedEvent
      Modifier and Type Method and Description
      Iterable<ExceptionQueuedEvent> ExceptionHandlerWrapper.getHandledExceptionQueuedEvents()
      The default behavior of this method is to call ExceptionHandler.getHandledExceptionQueuedEvents() on the wrapped ExceptionHandler object.
      abstract Iterable<ExceptionQueuedEvent> ExceptionHandler.getHandledExceptionQueuedEvents()

      The default implementation must return an Iterable over all ExceptionQueuedEvents that have been handled by the ExceptionHandler.handle() method.
      Iterable<ExceptionQueuedEvent> ExceptionHandlerWrapper.getUnhandledExceptionQueuedEvents()
      The default behavior of this method is to call ExceptionHandler.getUnhandledExceptionQueuedEvents() on the wrapped ExceptionHandler object.
      abstract Iterable<ExceptionQueuedEvent> ExceptionHandler.getUnhandledExceptionQueuedEvents()

      Return an Iterable over all ExceptionQueuedEvents that have not yet been handled by the ExceptionHandler.handle() method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.ExceptionQueuedEventContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.ExceptionQueuedEventContext

  • Packages that use ExceptionQueuedEventContext
    Package Description
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of ExceptionQueuedEventContext in javax.faces.event

      Methods in javax.faces.event that return ExceptionQueuedEventContext
      Modifier and Type Method and Description
      ExceptionQueuedEventContext ExceptionQueuedEvent.getContext()

      Return the ExceptionQueuedEventContext for this event instance.
      Constructors in javax.faces.event with parameters of type ExceptionQueuedEventContext
      Constructor and Description
      ExceptionQueuedEvent(ExceptionQueuedEventContext eventContext)

      Instantiate a new ExceptionQueuedEvent that indicates the argument ExceptionQueuedEventContext occurred.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.FacesEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.FacesEvent

  • Packages that use FacesEvent
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of FacesEvent in javax.faces.component

      Methods in javax.faces.component with parameters of type FacesEvent
      Modifier and Type | Method and Description
      void UIViewAction.broadcast(FacesEvent event)

      Enable the method invocation specified by this component instance to return a value that performs navigation, similar in spirit to UICommand.broadcast(javax.faces.event.FacesEvent).
      void UIData.broadcast(FacesEvent event)
      Override the default UIComponentBase.broadcast(javax.faces.event.FacesEvent) processing to unwrap any wrapped FacesEvent and reset the current row index, before the event is actually broadcast.
      void | UIComponentBase.broadcast(FacesEvent event)
      abstract void UIComponent.broadcast(FacesEvent event)
      Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type.
      void UICommand.broadcast(FacesEvent event)
      In addition to to the default UIComponent.broadcast(javax.faces.event.FacesEvent) processing, pass the ActionEvent being broadcast to the method referenced by actionListener (if any), and to the default ActionListener registered on the Application.
      void UIViewRoot.queueEvent(FacesEvent event)
      Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) behavior to accumulate the queued events for later broadcasting.
      void UIData.queueEvent(FacesEvent event)
      Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) processing to wrap any queued events in a wrapper so that we can reset the current row index in broadcast().
      void | UIComponentBase.queueEvent(FacesEvent event)
      abstract void UIComponent.queueEvent(FacesEvent event)
      Queue an event for broadcast at the end of the current request processing lifecycle phase.
      void UICommand.queueEvent(FacesEvent e)
      Intercept queueEvent and take the following action.

    • Uses of FacesEvent in javax.faces.event

      Subclasses of FacesEvent in javax.faces.event
      Modifier and Type Class and Description
      class  ActionEvent
      An ActionEvent represents the activation of a user interface component (such as a UICommand).
      class  AjaxBehaviorEvent
      AjaxBehaviorEvent represents the component behavior specific to Ajax).
      class  BehaviorEvent
      BehaviorEvent is the event that can be generated from component Behavior.
      class  ValueChangeEvent
      A ValueChangeEvent is a notification that the local value of the source component has been change as a result of user interface activity.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.ListenerFor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.ListenerFor

No usage of javax.faces.event.ListenerFor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.ListenersFor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.ListenersFor

No usage of javax.faces.event.ListenersFor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.MethodExpressionActionListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.MethodExpressionActionListener

No usage of javax.faces.event.MethodExpressionActionListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.MethodExpressionValueChangeListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.MethodExpressionValueChangeListener

No usage of javax.faces.event.MethodExpressionValueChangeListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.NamedEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.NamedEvent

No usage of javax.faces.event.NamedEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PhaseEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PhaseEvent

  • Packages that use PhaseEvent
    Package Description
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of PhaseEvent in javax.faces.event

      Methods in javax.faces.event with parameters of type PhaseEvent
      Modifier and Type Method and Description
      void PhaseListener.afterPhase(PhaseEvent event)
      Handle a notification that the processing for a particular phase has just been completed.
      void PhaseListener.beforePhase(PhaseEvent event)
      Handle a notification that the processing for a particular phase of the request processing lifecycle is about to begin.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PhaseId (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PhaseId

  • Packages that use PhaseId
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of PhaseId in javax.faces.component

      Methods in javax.faces.component with parameters of type PhaseId
      Modifier and Type Method and Description
      void UIViewRoot.broadcastEvents(FacesContext context, PhaseId phaseId)

      Broadcast any events that have been queued.

    • Uses of PhaseId in javax.faces.context

      Methods in javax.faces.context that return PhaseId
      Modifier and Type Method and Description
      PhaseId FacesContextWrapper.getCurrentPhaseId()
      The default behavior of this method is to call FacesContext.getCurrentPhaseId() on the wrapped FacesContext object.
      PhaseId FacesContext.getCurrentPhaseId()

      Return the value last set on this FacesContext instance when FacesContext.setCurrentPhaseId(javax.faces.event.PhaseId) was called.
      Methods in javax.faces.context with parameters of type PhaseId
      Modifier and Type Method and Description
      void PartialViewContextWrapper.processPartial(PhaseId phaseId)
      The default behavior of this method is to call PartialViewContext.processPartial(PhaseId) on the wrapped PartialViewContext object.
      abstract void PartialViewContext.processPartial(PhaseId phaseId)

      Perform lifecycle processing on components during the indicated phaseId.
      void FacesContextWrapper.setCurrentPhaseId(PhaseId currentPhaseId)
      The default behavior of this method is to call FacesContext.setCurrentPhaseId(PhaseId) on the wrapped FacesContext object.
      void FacesContext.setCurrentPhaseId(PhaseId currentPhaseId)

      The implementation must call this method at the earliest possble point in time after entering into a new phase in the request processing lifecycle.

    • Uses of PhaseId in javax.faces.event

      Fields in javax.faces.event declared as PhaseId
      Modifier and Type Field and Description
      static PhaseId PhaseId.ANY_PHASE
      Identifier that indicates an interest in events, no matter which request processing phase is being performed.
      static PhaseId PhaseId.APPLY_REQUEST_VALUES
      Identifier that indicates an interest in events queued for the Apply Request Values phase of the request processing lifecycle.
      static PhaseId PhaseId.INVOKE_APPLICATION
      Identifier that indicates an interest in events queued for the Invoke Application phase of the request processing lifecycle.
      static PhaseId PhaseId.PROCESS_VALIDATIONS
      Identifier that indicates an interest in events queued for the Process Validations phase of the request processing lifecycle.
      static PhaseId PhaseId.RENDER_RESPONSE
      Identifier for the Render Response phase of the request processing lifecycle.
      static PhaseId PhaseId.RESTORE_VIEW
      Identifier that indicates an interest in events queued for the Restore View phase of the request processing lifecycle.
      static PhaseId PhaseId.UPDATE_MODEL_VALUES
      Identifier that indicates an interest in events queued for the Update Model Values phase of the request processing lifecycle.
      Fields in javax.faces.event with type parameters of type PhaseId
      Modifier and Type Field and Description
      static List<PhaseId> PhaseId.VALUES
      List of valid PhaseId instances, in ascending order of their ordinal value.
      Methods in javax.faces.event that return PhaseId
      Modifier and Type Method and Description
      PhaseId PhaseListener.getPhaseId()
      Return the identifier of the request processing phase during which this listener is interested in processing PhaseEvent events.
      PhaseId PhaseEvent.getPhaseId()
      Return the PhaseId representing the current request processing lifecycle phase.
      PhaseId FacesEvent.getPhaseId()
      Return the identifier of the request processing phase during which this event should be delivered.
      PhaseId ExceptionQueuedEventContext.getPhaseId()

      Return the PhaseId which was being processed when the exception was thrown.
      static PhaseId PhaseId.phaseIdValueOf(String phase)

      Return a PhaseId representation of the arcument phase.
      Methods in javax.faces.event with parameters of type PhaseId
      Modifier and Type Method and Description
      void FacesEvent.setPhaseId(PhaseId phaseId)
      Set the PhaseId during which this event will be delivered.
      Constructors in javax.faces.event with parameters of type PhaseId
      Constructor and Description
      ExceptionQueuedEventContext(FacesContext context, Throwable thrown, UIComponent component, PhaseId phaseId)

      Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component, during the lifecycle phase phaseId.
      PhaseEvent(FacesContext context, PhaseId phaseId, Lifecycle lifecycle)
      Construct a new event object from the specified parameters.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PostAddToViewEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PostAddToViewEvent

No usage of javax.faces.event.PostAddToViewEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PostConstructApplicationEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PostConstructApplicationEvent

No usage of javax.faces.event.PostConstructApplicationEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PostConstructCustomScopeEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PostConstructCustomScopeEvent

No usage of javax.faces.event.PostConstructCustomScopeEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PostConstructViewMapEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PostConstructViewMapEvent

No usage of javax.faces.event.PostConstructViewMapEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PostKeepFlashValueEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PostKeepFlashValueEvent

No usage of javax.faces.event.PostKeepFlashValueEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PostPutFlashValueEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PostPutFlashValueEvent

No usage of javax.faces.event.PostPutFlashValueEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PostRestoreStateEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PostRestoreStateEvent

No usage of javax.faces.event.PostRestoreStateEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PostValidateEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PostValidateEvent

No usage of javax.faces.event.PostValidateEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PreClearFlashEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PreClearFlashEvent

No usage of javax.faces.event.PreClearFlashEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PreDestroyApplicationEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PreDestroyApplicationEvent

No usage of javax.faces.event.PreDestroyApplicationEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PreDestroyCustomScopeEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PreDestroyCustomScopeEvent

No usage of javax.faces.event.PreDestroyCustomScopeEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PreDestroyViewMapEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PreDestroyViewMapEvent

No usage of javax.faces.event.PreDestroyViewMapEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PreRemoveFlashValueEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PreRemoveFlashValueEvent

No usage of javax.faces.event.PreRemoveFlashValueEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PreRemoveFromViewEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PreRemoveFromViewEvent

No usage of javax.faces.event.PreRemoveFromViewEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PreRenderComponentEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PreRenderComponentEvent

No usage of javax.faces.event.PreRenderComponentEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PreRenderViewEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PreRenderViewEvent

No usage of javax.faces.event.PreRenderViewEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.PreValidateEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.PreValidateEvent

No usage of javax.faces.event.PreValidateEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.ScopeContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.ScopeContext

  • Packages that use ScopeContext
    Package Description
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of ScopeContext in javax.faces.event

      Methods in javax.faces.event that return ScopeContext
      Modifier and Type Method and Description
      ScopeContext PreDestroyCustomScopeEvent.getContext()

      Return the ScopeContext for this event.
      ScopeContext PostConstructCustomScopeEvent.getContext()

      Return the ScopeContext for this event.
      Constructors in javax.faces.event with parameters of type ScopeContext
      Constructor and Description
      PostConstructCustomScopeEvent(ScopeContext scopeContext)

      An instance of this event indicates that the custom scope enclosed within the argument scopeContext was just created.
      PreDestroyCustomScopeEvent(ScopeContext scopeContext)

      An instance of this event indicates that the custom scope enclosed within the argument scopeContext is about to end.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.SystemEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.SystemEvent

  • Packages that use SystemEvent
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of SystemEvent in javax.faces.application

      Method parameters in javax.faces.application with type arguments of type SystemEvent
      Modifier and Type Method and Description
      void ApplicationWrapper.publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Class<?> sourceBaseType, Object source)

      The default behavior of this method is to call Application.publishEvent(javax.faces.context.FacesContext, Class, Class, Object) on the wrapped Application object.
      void Application.publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Class<?> sourceBaseType, Object source)

      This method functions exactly like Application.publishEvent(FacesContext,Class,Object), except the run-time must use the argument sourceBaseType to find the matching listener instead of using the Class of the source argument.
      void ApplicationWrapper.publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Object source)

      The default behavior of this method is to call Application.publishEvent(javax.faces.context.FacesContext, Class, Object) on the wrapped Application object.
      void Application.publishEvent(FacesContext context, Class<? extends SystemEvent> systemEventClass, Object source)

      If FacesContext.isProcessingEvents() is true and there are one or more listeners for events of the type represented by systemEventClass, call those listeners, passing source as the source of the event.
      void ApplicationWrapper.subscribeToEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      The default behavior of this method is to call Application.subscribeToEvent(Class, Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void Application.subscribeToEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      Install the listener instance referenced by argument listener into the application as a listener for events of type systemEventClass that originate from objects of type sourceClass.
      void ApplicationWrapper.subscribeToEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      The default behavior of this method is to call Application.subscribeToEvent(Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void Application.subscribeToEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      Install the listener instance referenced by argument listener into application as a listener for events of type systemEventClass.
      void ApplicationWrapper.unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      The default behavior of this method is to call Application.unsubscribeFromEvent(Class, Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void Application.unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      Remove the listener instance referenced by argument listener from the application as a listener for events of type systemEventClass that originate from objects of type sourceClass.
      void ApplicationWrapper.unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      The default behavior of this method is to call Application.unsubscribeFromEvent(Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void Application.unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      Remove the listener instance referenced by argument listener from the application as a listener for events of type systemEventClass.

    • Uses of SystemEvent in javax.faces.component

      Method parameters in javax.faces.component with type arguments of type SystemEvent
      Modifier and Type Method and Description
      List<SystemEventListener> UIComponentBase.getListenersForEventClass(Class<? extends SystemEvent> eventClass)

      Return the SystemEventListener instances registered on this UIComponent instance that are interested in events of type eventClass.
      List<SystemEventListener> UIComponent.getListenersForEventClass(Class<? extends SystemEvent> eventClass)

      This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.
      List<SystemEventListener> UIViewRoot.getViewListenersForEventClass(Class<? extends SystemEvent> systemEvent)

      Return the SystemEventListener instances registered on this UIComponent instance that are interested in events of type eventClass.
      void UIComponentBase.subscribeToEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      Install the listener instance referenced by argument componentListener as a listener for events of type eventClass originating from this specific instance of UIComponent.
      void UIComponent.subscribeToEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.
      void UIViewRoot.subscribeToViewEvent(Class<? extends SystemEvent> systemEvent, SystemEventListener listener)

      Install the listener instance referenced by argument listener into the UIViewRoot as a listener for events of type systemEventClass.
      void UIComponentBase.unsubscribeFromEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      Remove the listener instance referenced by argument componentListener as a listener for events of type eventClass originating from this specific instance of UIComponent.
      void UIComponent.unsubscribeFromEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.
      void UIViewRoot.unsubscribeFromViewEvent(Class<? extends SystemEvent> systemEvent, SystemEventListener listener)

      Remove the listener instance referenced by argument listener from the UIViewRoot as a listener for events of type systemEventClass.

    • Uses of SystemEvent in javax.faces.context

      Methods in javax.faces.context with parameters of type SystemEvent
      Modifier and Type Method and Description
      void ExceptionHandlerWrapper.processEvent(SystemEvent event)
      The default behavior of this method is to call ExceptionHandler.processEvent(javax.faces.event.SystemEvent) on the wrapped ExceptionHandler object.
      abstract void ExceptionHandler.processEvent(SystemEvent exceptionQueuedEvent)
      When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

    • Uses of SystemEvent in javax.faces.event

      Subclasses of SystemEvent in javax.faces.event
      Modifier and Type Class and Description
      class  ComponentSystemEvent
      ComponentSystemEvent is the base class for SystemEvents that are specific to a UIComponent instance.
      class  ExceptionQueuedEvent

      The system event facility will create an instance of this class whenever Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) is called with ExceptionQueuedEvent.class as systemEventClass argument.
      class  PostAddToViewEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is a UIComponent instance and that either that instance or an ancestor of that instance was just added to the view.
      class  PostConstructApplicationEvent

      This event must be published by the runtime after all configuration resources have been parsed and processed.
      class  PostConstructCustomScopeEvent

      This class is provided to allow custom scopes to publish a "post construct" event in the same way that other scopes do to let the application become aware of the beginning of the scope.
      class  PostConstructViewMapEvent

      This event must be published by a call to {javax.faces.application.Application#publishEvent} when the view map is first created.
      class  PostKeepFlashValueEvent

      This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is kept in the flash.
      class  PostPutFlashValueEvent

      This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is stored in the flash.
      class  PostRestoreStateEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is in a tree that has just had its state restored.
      class  PostValidateEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is that has just been validated.
      class  PreClearFlashEvent

      This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) before the flash is cleared.
      class  PreDestroyApplicationEvent

      This event must be published by the runtime before the factories associated with this Application are released.
      class  PreDestroyCustomScopeEvent

      This class is provided to allow custom scopes to publish a "pre construct" event in the same way that other scopes do to let the application become aware of the beginning of the scope.
      class  PreDestroyViewMapEvent

      This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when the clear method is called on the map returned from UIViewRoot.getViewMap().
      class  PreRemoveFlashValueEvent

      This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is removed from the flash.
      class  PreRemoveFromViewEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is a UIComponent instance that is about to be removed from the view.
      class  PreRenderComponentEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is about to be rendered and that it is safe to call UIComponent.getParent(), UIComponent.getClientId(), and other methods that depend upon the component instance being in the view.
      class  PreRenderViewEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIViewRoot instance that is about to be rendered.
      class  PreValidateEvent

      When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is about to be validated.
      Methods in javax.faces.event with parameters of type SystemEvent
      Modifier and Type Method and Description
      void SystemEventListener.processEvent(SystemEvent event)
      When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.
      Method parameters in javax.faces.event with type arguments of type SystemEvent
      Modifier and Type Method and Description
      List<SystemEventListener> SystemEventListenerHolder.getListenersForEventClass(Class<? extends SystemEvent> facesEventClass)
      List<SystemEventListener> ExceptionQueuedEventContext.getListenersForEventClass(Class<? extends SystemEvent> facesEventClass)

      Return a List that contains a single entry, the ExceptionHandler for the current request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.event.ValueChangeEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.event.ValueChangeEvent

  • Packages that use ValueChangeEvent
    Package Description
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of ValueChangeEvent in javax.faces.event

      Methods in javax.faces.event with parameters of type ValueChangeEvent
      Modifier and Type Method and Description
      void ValueChangeListener.processValueChange(ValueChangeEvent event)
      Invoked when the value change described by the specified ValueChangeEvent occurs.
      void MethodExpressionValueChangeListener.processValueChange(ValueChangeEvent valueChangeEvent)
      Call through to the MethodExpression passed in our constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.event.ActionListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.event.ActionListener

  • Packages that use ActionListener
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of ActionListener in javax.faces.application

      Methods in javax.faces.application that return ActionListener
      Modifier and Type Method and Description
      ActionListener ApplicationWrapper.getActionListener()

      The default behavior of this method is to call Application.getActionListener() on the wrapped Application object.
      abstract ActionListener Application.getActionListener()
      Return the default ActionListener to be registered for all ActionSource components in this application.
      Methods in javax.faces.application with parameters of type ActionListener
      Modifier and Type Method and Description
      void ApplicationWrapper.setActionListener(ActionListener listener)

      The default behavior of this method is to call Application.setActionListener(javax.faces.event.ActionListener) on the wrapped Application object.
      abstract void Application.setActionListener(ActionListener listener)
      Set the default ActionListener to be registered for all ActionSource components.

    • Uses of ActionListener in javax.faces.component

      Methods in javax.faces.component that return ActionListener
      Modifier and Type | Method and Description
      ActionListener[] UIViewAction.getActionListeners()
      Return the set of registered ActionListeners for this ActionSource instance.
      ActionListener[] | UICommand.getActionListeners()
      ActionListener[] ActionSource.getActionListeners()
      Return the set of registered ActionListeners for this ActionSource instance.
      Methods in javax.faces.component with parameters of type ActionListener
      Modifier and Type | Method and Description
      void UIViewAction.addActionListener(ActionListener listener)
      Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.
      void | UICommand.addActionListener(ActionListener listener)
      void ActionSource.addActionListener(ActionListener listener)
      Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.
      void UIViewAction.removeActionListener(ActionListener listener)
      Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.
      void | UICommand.removeActionListener(ActionListener listener)
      void ActionSource.removeActionListener(ActionListener listener)
      Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.

    • Uses of ActionListener in javax.faces.event

      Classes in javax.faces.event that implement ActionListener
      Modifier and Type Class and Description
      class  ActionListenerWrapper

      Provides a simple implementation of ActionListener that can be subclassed by developers wishing to provide specialized behavior to an existing ActionListener instance.
      class  MethodExpressionActionListener
      MethodExpressionActionListener is an ActionListener that wraps a MethodExpression.
      Methods in javax.faces.event that return ActionListener
      Modifier and Type | Method and Description
      abstract ActionListener | ActionListenerWrapper.getWrapped()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.event.AjaxBehaviorListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.event.AjaxBehaviorListener

  • Packages that use AjaxBehaviorListener
    Package Description
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.

    • Uses of AjaxBehaviorListener in javax.faces.component.behavior

      Methods in javax.faces.component.behavior with parameters of type AjaxBehaviorListener
      Modifier and Type Method and Description
      void AjaxBehavior.addAjaxBehaviorListener(AjaxBehaviorListener listener)

      Add the specified AjaxBehaviorListener to the set of listeners registered to receive event notifications from this AjaxBehavior.
      void AjaxBehavior.removeAjaxBehaviorListener(AjaxBehaviorListener listener)

      Remove the specified AjaxBehaviorListener from the set of listeners registered to receive event notifications from this AjaxBehavior.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.event.BehaviorListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.event.BehaviorListener

  • Packages that use BehaviorListener
    Package Description
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of BehaviorListener in javax.faces.component.behavior

      Methods in javax.faces.component.behavior with parameters of type BehaviorListener
      Modifier and Type Method and Description
      protected void BehaviorBase.addBehaviorListener(BehaviorListener listener)

      Add the specified BehaviorListener to the set of listeners registered to receive event notifications from this Behavior.
      protected void BehaviorBase.removeBehaviorListener(BehaviorListener listener)

      Remove the specified BehaviorListener from the set of listeners registered to receive event notifications from this Behavior.

    • Uses of BehaviorListener in javax.faces.event

      Subinterfaces of BehaviorListener in javax.faces.event
      Modifier and Type Interface and Description
      interface  AjaxBehaviorListener

      By implementing this class, an object indicates that it is a listener for one or more kinds of BehaviorEvents.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.event.ComponentSystemEventListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.event.ComponentSystemEventListener

  • Packages that use ComponentSystemEventListener
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.

    • Uses of ComponentSystemEventListener in javax.faces.component

      Classes in javax.faces.component that implement ComponentSystemEventListener
      Modifier and Type Class and Description
      class  UIColumn
      UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
      class  UICommand
      UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
      class  UIComponent
      UIComponent is the base class for all user interface components in JavaServer Faces.
      class  UIComponentBase
      UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
      class  UIData
      UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
      class  UIForm
      UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
      class  UIGraphic
      UIGraphic is a UIComponent that displays a graphical image to the user.
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UIMessage
      This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.
      class  UIMessages
      The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
      class  UINamingContainer
      UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
      class  UIOutcomeTarget

      This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
      class  UIOutput
      UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
      class  UIPanel
      UIPanel is a UIComponent that manages the layout of its child components.
      class  UIParameter
      UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectItem
      UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.
      class  UISelectItems
      UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewAction

      UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
      class  UIViewRoot
      UIViewRoot is the UIComponent that represents the root of the UIComponent tree.
      Methods in javax.faces.component with parameters of type ComponentSystemEventListener
      Modifier and Type Method and Description
      void UIComponentBase.subscribeToEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      Install the listener instance referenced by argument componentListener as a listener for events of type eventClass originating from this specific instance of UIComponent.
      void UIComponent.subscribeToEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.
      void UIComponentBase.unsubscribeFromEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      Remove the listener instance referenced by argument componentListener as a listener for events of type eventClass originating from this specific instance of UIComponent.
      void UIComponent.unsubscribeFromEvent(Class<? extends SystemEvent> eventClass, ComponentSystemEventListener componentListener)

      This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

    • Uses of ComponentSystemEventListener in javax.faces.component.html

      Classes in javax.faces.component.html that implement ComponentSystemEventListener
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlColumn
      Represents a column that will be rendered in an HTML table element.
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlDoctype
      NONE
      class  HtmlForm
      Represents an HTML form element.
      class  HtmlGraphicImage
      Represents an HTML img element, used to retrieve and render a graphical image.
      class  HtmlHead
      NONE
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlMessage
      By default, the rendererType property must be set to "javax.faces.Message".
      class  HtmlMessages
      By default, the rendererType property must be set to "javax.faces.Messages".
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputFormat
      Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlOutputText
      Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
      class  HtmlPanelGrid
      Renders child components in a table, starting a new row after the specified number of columns.
      class  HtmlPanelGroup
      Causes all child components of this component to be rendered.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.event.FacesListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.event.FacesListener

  • Packages that use FacesListener
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of FacesListener in javax.faces.component

      Classes in javax.faces.component that implement FacesListener
      Modifier and Type Class and Description
      class  UIColumn
      UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
      class  UICommand
      UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
      class  UIComponent
      UIComponent is the base class for all user interface components in JavaServer Faces.
      class  UIComponentBase
      UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
      class  UIData
      UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
      class  UIForm
      UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
      class  UIGraphic
      UIGraphic is a UIComponent that displays a graphical image to the user.
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UIMessage
      This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.
      class  UIMessages
      The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
      class  UINamingContainer
      UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
      class  UIOutcomeTarget

      This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
      class  UIOutput
      UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
      class  UIPanel
      UIPanel is a UIComponent that manages the layout of its child components.
      class  UIParameter
      UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectItem
      UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.
      class  UISelectItems
      UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewAction

      UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
      class  UIViewRoot
      UIViewRoot is the UIComponent that represents the root of the UIComponent tree.
      Methods in javax.faces.component that return FacesListener
      Modifier and Type | Method and Description
      protected FacesListener[] | UIComponentBase.getFacesListeners(Class clazz)
      protected abstract FacesListener[] UIComponent.getFacesListeners(Class clazz)
      Return an array of registered FacesListeners that are instances of the specified class.
      Methods in javax.faces.component with parameters of type FacesListener
      Modifier and Type Method and Description
      protected void UIComponentBase.addFacesListener(FacesListener listener)
      Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent.
      protected abstract void UIComponent.addFacesListener(FacesListener listener)
      Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent.
      protected void UIComponentBase.removeFacesListener(FacesListener listener)
      Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.
      protected abstract void UIComponent.removeFacesListener(FacesListener listener)
      Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.

    • Uses of FacesListener in javax.faces.component.html

      Classes in javax.faces.component.html that implement FacesListener
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlColumn
      Represents a column that will be rendered in an HTML table element.
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlDoctype
      NONE
      class  HtmlForm
      Represents an HTML form element.
      class  HtmlGraphicImage
      Represents an HTML img element, used to retrieve and render a graphical image.
      class  HtmlHead
      NONE
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlMessage
      By default, the rendererType property must be set to "javax.faces.Message".
      class  HtmlMessages
      By default, the rendererType property must be set to "javax.faces.Messages".
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputFormat
      Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlOutputText
      Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
      class  HtmlPanelGrid
      Renders child components in a table, starting a new row after the specified number of columns.
      class  HtmlPanelGroup
      Causes all child components of this component to be rendered.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.

    • Uses of FacesListener in javax.faces.context

      Classes in javax.faces.context that implement FacesListener
      Modifier and Type Class and Description
      class  ExceptionHandler

      ExceptionHandler is the central point for handling unexpected Exceptions that are thrown during the Faces lifecycle.
      class  ExceptionHandlerWrapper
      Provides a simple implementation of ExceptionHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ExceptionHandler instance.

    • Uses of FacesListener in javax.faces.event

      Subinterfaces of FacesListener in javax.faces.event
      Modifier and Type Interface and Description
      interface  ActionListener
      A listener interface for receiving ActionEvents.
      interface  AjaxBehaviorListener

      By implementing this class, an object indicates that it is a listener for one or more kinds of BehaviorEvents.
      interface  BehaviorListener

      A generic base interface for event listeners for various types of BehaviorEvents.
      interface  ComponentSystemEventListener

      Implementors of this class do not need an isListenerForSource() method because they are only installed on specific component instances, therefore the isListenerForSource() method is implicit.
      interface  SystemEventListener

      By implementing this class, an object indicates that it is a listener for one or more kinds of SystemEvents.
      interface  ValueChangeListener
      A listener interface for receiving ValueChangeEvents.
      interface  ViewMapListener

      Marker interface for SystemEvents that indicate the view map has been created (PostConstructViewMapEvent, or destroyed (PreDestroyViewMapEvent).
      Classes in javax.faces.event that implement FacesListener
      Modifier and Type Class and Description
      class  ActionListenerWrapper

      Provides a simple implementation of ActionListener that can be subclassed by developers wishing to provide specialized behavior to an existing ActionListener instance.
      class  MethodExpressionActionListener
      MethodExpressionActionListener is an ActionListener that wraps a MethodExpression.
      class  MethodExpressionValueChangeListener
      MethodExpressionValueChangeListener is a ValueChangeListener that wraps a MethodExpression.
      Methods in javax.faces.event with parameters of type FacesListener
      Modifier and Type | Method and Description
      boolean | ValueChangeEvent.isAppropriateListener(FacesListener listener)
      boolean SystemEvent.isAppropriateListener(FacesListener listener)
      Return true if this FacesListener is an instance of a the appropriate listener class that this event supports.
      boolean PreRemoveFromViewEvent.isAppropriateListener(FacesListener listener)

      Returns true if and only if the argument listener is an instance of SystemEventListener.
      boolean PostAddToViewEvent.isAppropriateListener(FacesListener listener)

      Returns true if and only if the argument listener is an instance of SystemEventListener.
      abstract boolean FacesEvent.isAppropriateListener(FacesListener listener)
      Return true if this FacesListener is an instance of a listener class that this event supports.
      boolean ComponentSystemEvent.isAppropriateListener(FacesListener listener)

      Return true if the argument FacesListener is an instance of the appropriate listener class that this event supports.
      boolean AjaxBehaviorEvent.isAppropriateListener(FacesListener listener)

      Return true if this FacesListener is an instance of a the appropriate listener class that this event supports.
      boolean | ActionEvent.isAppropriateListener(FacesListener listener)
      void | ValueChangeEvent.processListener(FacesListener listener)
      void SystemEvent.processListener(FacesListener listener)
      Broadcast this event instance to the specified FacesListener, by whatever mechanism is appropriate.
      abstract void FacesEvent.processListener(FacesListener listener)
      Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate.
      void ComponentSystemEvent.processListener(FacesListener listener)

      Broadcast this event instance to the specified FacesListener by calling the superclass's processListener() implementation.
      void AjaxBehaviorEvent.processListener(FacesListener listener)

      Broadcast this event instance to the specified FacesListener, by whatever mechanism is appropriate.
      void | ActionEvent.processListener(FacesListener listener)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.event.PhaseListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.event.PhaseListener

  • Packages that use PhaseListener
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.

    • Uses of PhaseListener in javax.faces.component

      Methods in javax.faces.component that return types with arguments of type PhaseListener
      Modifier and Type Method and Description
      List<PhaseListener> UIViewRoot.getPhaseListeners()

      Return an unmodifiable list of the PhaseListener instances attached to this UIViewRoot instance.
      Methods in javax.faces.component with parameters of type PhaseListener
      Modifier and Type Method and Description
      void UIViewRoot.addPhaseListener(PhaseListener newPhaseListener)
      Add the argument newPhaseListener to the list of PhaseListeners on this UIViewRoot.
      void UIViewRoot.removePhaseListener(PhaseListener toRemove)
      If the argument toRemove is in the list of PhaseListeners for this instance, it must be removed.

    • Uses of PhaseListener in javax.faces.lifecycle

      Methods in javax.faces.lifecycle that return PhaseListener
      Modifier and Type | Method and Description
      PhaseListener[] | LifecycleWrapper.getPhaseListeners()
      abstract PhaseListener[] Lifecycle.getPhaseListeners()
      Return the set of registered PhaseListeners for this Lifecycle instance.
      Methods in javax.faces.lifecycle with parameters of type PhaseListener
      Modifier and Type | Method and Description
      void | LifecycleWrapper.addPhaseListener(PhaseListener listener)
      abstract void Lifecycle.addPhaseListener(PhaseListener listener)
      Register a new PhaseListener instance that is interested in being notified before and after the processing for standard phases of the request processing lifecycle.
      void | LifecycleWrapper.removePhaseListener(PhaseListener listener)
      abstract void Lifecycle.removePhaseListener(PhaseListener listener)
      Deregister an existing PhaseListener instance that is no longer interested in being notified before and after the processing for standard phases of the request processing lifecycle.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.event.SystemEventListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.event.SystemEventListener

  • Packages that use SystemEventListener
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of SystemEventListener in javax.faces.application

      Methods in javax.faces.application with parameters of type SystemEventListener
      Modifier and Type Method and Description
      void ApplicationWrapper.subscribeToEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      The default behavior of this method is to call Application.subscribeToEvent(Class, Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void Application.subscribeToEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      Install the listener instance referenced by argument listener into the application as a listener for events of type systemEventClass that originate from objects of type sourceClass.
      void ApplicationWrapper.subscribeToEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      The default behavior of this method is to call Application.subscribeToEvent(Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void Application.subscribeToEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      Install the listener instance referenced by argument listener into application as a listener for events of type systemEventClass.
      void ApplicationWrapper.unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      The default behavior of this method is to call Application.unsubscribeFromEvent(Class, Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void Application.unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, Class<?> sourceClass, SystemEventListener listener)

      Remove the listener instance referenced by argument listener from the application as a listener for events of type systemEventClass that originate from objects of type sourceClass.
      void ApplicationWrapper.unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      The default behavior of this method is to call Application.unsubscribeFromEvent(Class, javax.faces.event.SystemEventListener) on the wrapped Application object.
      void Application.unsubscribeFromEvent(Class<? extends SystemEvent> systemEventClass, SystemEventListener listener)

      Remove the listener instance referenced by argument listener from the application as a listener for events of type systemEventClass.

    • Uses of SystemEventListener in javax.faces.component

      Methods in javax.faces.component that return types with arguments of type SystemEventListener
      Modifier and Type Method and Description
      List<SystemEventListener> UIComponentBase.getListenersForEventClass(Class<? extends SystemEvent> eventClass)

      Return the SystemEventListener instances registered on this UIComponent instance that are interested in events of type eventClass.
      List<SystemEventListener> UIComponent.getListenersForEventClass(Class<? extends SystemEvent> eventClass)

      This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.
      List<SystemEventListener> UIViewRoot.getViewListenersForEventClass(Class<? extends SystemEvent> systemEvent)

      Return the SystemEventListener instances registered on this UIComponent instance that are interested in events of type eventClass.
      Methods in javax.faces.component with parameters of type SystemEventListener
      Modifier and Type Method and Description
      void UIViewRoot.subscribeToViewEvent(Class<? extends SystemEvent> systemEvent, SystemEventListener listener)

      Install the listener instance referenced by argument listener into the UIViewRoot as a listener for events of type systemEventClass.
      void UIViewRoot.unsubscribeFromViewEvent(Class<? extends SystemEvent> systemEvent, SystemEventListener listener)

      Remove the listener instance referenced by argument listener from the UIViewRoot as a listener for events of type systemEventClass.

    • Uses of SystemEventListener in javax.faces.context

      Classes in javax.faces.context that implement SystemEventListener
      Modifier and Type Class and Description
      class  ExceptionHandler

      ExceptionHandler is the central point for handling unexpected Exceptions that are thrown during the Faces lifecycle.
      class  ExceptionHandlerWrapper
      Provides a simple implementation of ExceptionHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ExceptionHandler instance.

    • Uses of SystemEventListener in javax.faces.event

      Subinterfaces of SystemEventListener in javax.faces.event
      Modifier and Type Interface and Description
      interface  ViewMapListener

      Marker interface for SystemEvents that indicate the view map has been created (PostConstructViewMapEvent, or destroyed (PreDestroyViewMapEvent).
      Methods in javax.faces.event that return types with arguments of type SystemEventListener
      Modifier and Type Method and Description
      List<SystemEventListener> SystemEventListenerHolder.getListenersForEventClass(Class<? extends SystemEvent> facesEventClass)
      List<SystemEventListener> ExceptionQueuedEventContext.getListenersForEventClass(Class<? extends SystemEvent> facesEventClass)

      Return a List that contains a single entry, the ExceptionHandler for the current request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.event.SystemEventListenerHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.event.SystemEventListenerHolder

  • Packages that use SystemEventListenerHolder
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.html
    Specialized user interface component classes for HTML.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of SystemEventListenerHolder in javax.faces.component

      Classes in javax.faces.component that implement SystemEventListenerHolder
      Modifier and Type Class and Description
      class  UIColumn
      UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
      class  UICommand
      UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
      class  UIComponent
      UIComponent is the base class for all user interface components in JavaServer Faces.
      class  UIComponentBase
      UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
      class  UIData
      UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
      class  UIForm
      UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
      class  UIGraphic
      UIGraphic is a UIComponent that displays a graphical image to the user.
      class  UIInput
      UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
      class  UIMessage
      This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.
      class  UIMessages
      The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
      class  UINamingContainer
      UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
      class  UIOutcomeTarget

      This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.
      class  UIOutput
      UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
      class  UIPanel
      UIPanel is a UIComponent that manages the layout of its child components.
      class  UIParameter
      UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.
      class  UISelectBoolean
      UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
      class  UISelectItem
      UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.
      class  UISelectItems
      UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.
      class  UISelectMany
      UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
      class  UISelectOne
      UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
      class  UIViewAction

      UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.
      class  UIViewParameter

      UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.
      class  UIViewRoot
      UIViewRoot is the UIComponent that represents the root of the UIComponent tree.

    • Uses of SystemEventListenerHolder in javax.faces.component.html

      Classes in javax.faces.component.html that implement SystemEventListenerHolder
      Modifier and Type Class and Description
      class  HtmlBody
      NONE
      class  HtmlColumn
      Represents a column that will be rendered in an HTML table element.
      class  HtmlCommandButton
      Represents an HTML input element for a button of type submit or reset.
      class  HtmlCommandLink
      Represents an HTML a element for a hyperlink that acts like a submit button.
      class  HtmlDataTable
      Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
      class  HtmlDoctype
      NONE
      class  HtmlForm
      Represents an HTML form element.
      class  HtmlGraphicImage
      Represents an HTML img element, used to retrieve and render a graphical image.
      class  HtmlHead
      NONE
      class  HtmlInputFile
      Represents an HTML input element of type file.
      class  HtmlInputHidden
      Represents an HTML input element of type hidden.
      class  HtmlInputSecret
      Represents an HTML input element of type password.
      class  HtmlInputText
      Represents an HTML input element of type text.
      class  HtmlInputTextarea
      Represents an HTML textarea element.
      class  HtmlMessage
      By default, the rendererType property must be set to "javax.faces.Message".
      class  HtmlMessages
      By default, the rendererType property must be set to "javax.faces.Messages".
      class  HtmlOutcomeTargetButton
      Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutcomeTargetLink
      Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.
      class  HtmlOutputFormat
      Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
      class  HtmlOutputLabel
      Represents an HTML label element, used to define an accessible label for a corresponding input element.
      class  HtmlOutputLink
      Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
      class  HtmlOutputText
      Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
      class  HtmlPanelGrid
      Renders child components in a table, starting a new row after the specified number of columns.
      class  HtmlPanelGroup
      Causes all child components of this component to be rendered.
      class  HtmlSelectBooleanCheckbox
      Represents an HTML input element of type checkbox.
      class  HtmlSelectManyCheckbox
      Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
      class  HtmlSelectManyListbox
      Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectManyMenu
      Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneListbox
      Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
      class  HtmlSelectOneMenu
      Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
      class  HtmlSelectOneRadio
      Represents a single-selection component that is rendered as a set of HTML input elements of type radio.

    • Uses of SystemEventListenerHolder in javax.faces.event

      Classes in javax.faces.event that implement SystemEventListenerHolder
      Modifier and Type Class and Description
      class  ExceptionQueuedEventContext

      This helper class provides context to the ExceptionQueuedEvent regarding the state of the system at the point in time when the ExceptionQueuedEvent occurs and links the ExceptionQueuedEvent to the ExceptionHandler by virtue of implementing SystemEventListener.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.event.ValueChangeListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.event.ValueChangeListener

  • Packages that use ValueChangeListener
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.

    • Uses of ValueChangeListener in javax.faces.component

      Methods in javax.faces.component that return ValueChangeListener
      Modifier and Type Method and Description
      ValueChangeListener[] UIInput.getValueChangeListeners()
      Return the set of registered ValueChangeListeners for this UIInput instance.
      ValueChangeListener[] EditableValueHolder.getValueChangeListeners()
      Return the set of registered ValueChangeListeners for this component instance.
      Methods in javax.faces.component with parameters of type ValueChangeListener
      Modifier and Type Method and Description
      void UIInput.addValueChangeListener(ValueChangeListener listener)
      Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.
      void EditableValueHolder.addValueChangeListener(ValueChangeListener listener)
      Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.
      void UIInput.removeValueChangeListener(ValueChangeListener listener)
      Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.
      void EditableValueHolder.removeValueChangeListener(ValueChangeListener listener)
      Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.

    • Uses of ValueChangeListener in javax.faces.event

      Classes in javax.faces.event that implement ValueChangeListener
      Modifier and Type Class and Description
      class  MethodExpressionValueChangeListener
      MethodExpressionValueChangeListener is a ValueChangeListener that wraps a MethodExpression.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.event.ViewMapListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.event.ViewMapListener

No usage of javax.faces.event.ViewMapListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Flow (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class Flow

  • java.lang.Object
    • javax.faces.flow.Flow

  • public abstract class Flow
extends Object

    Flow is the runtime representation of a Faces Flow. Once placed into service by the runtime, an instance of this class is immutable. The implementation must be thread-safe because instances will be shared across all usages of the flow within the application.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      Flow()

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      abstract String getClientWindowFlowId(ClientWindow curWindow)

      Obtain the current ClientWindow from the ExternalContext.
      abstract String getDefiningDocumentId()

      Return the immutable application unique identifier for the document in which the argument flow is defined.
      abstract MethodExpression getFinalizer()

      Return the MethodExpression that must be called by the runtime as the last thing that happens before exiting this flow.
      abstract FlowCallNode getFlowCall(Flow targetFlow)

      Return the FlowCallNode that represents calling the targetFlow from this flow, or null if targetFlow cannot be reached from this flow.
      abstract Map<String,FlowCallNode> getFlowCalls()

      Return an immutable data structure containing all the flow call nodes declared for this flow.
      abstract String getId()

      Return the immutable id for this Flow.
      abstract Map<String,Parameter> getInboundParameters()

      Return an immutable data structure containing the inbound parameters that have been declared for this flow.
      abstract MethodExpression getInitializer()

      Return the MethodExpression that must be called by the runtime immediately after activating any FlowScoped beans declared for this flow.
      abstract List<MethodCallNode> getMethodCalls()

      Return an immutable data structure containing all the method call nodes declared for this flow.
      abstract Map<String,Set<NavigationCase>> | getNavigationCases()
      abstract FlowNode | getNode(String nodeId)
      abstract Map<String,ReturnNode> getReturns()

      Return an immutable data structure containing all of the return nodes declared for this flow.
      abstract String getStartNodeId()

      Return the immutable id for the default node that should be activated when this flow is entered.
      abstract Map<String,SwitchNode> getSwitches()

      Return an immutable data structure containing all of the switch nodes declared for this flow.
      abstract List<ViewNode> getViews()

      Return an immutable data structure containing all of the view nodes declared for this flow.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Flow

        public Flow()

    • Method Detail

      • getId

        public abstract String getId()

        Return the immutable id for this Flow. This must be unique within the defining document (such as an Application Configuration Resources file), but need not be unique within the entire application.

        Since:
        2.2

      • getDefiningDocumentId

        public abstract String getDefiningDocumentId()

        Return the immutable application unique identifier for the document in which the argument flow is defined.

        Since:
        2.2

      • getStartNodeId

        public abstract String getStartNodeId()

        Return the immutable id for the default node that should be activated when this flow is entered.

        Since:
        2.2

      • getFinalizer

        public abstract MethodExpression getFinalizer()

        Return the MethodExpression that must be called by the runtime as the last thing that happens before exiting this flow. Any FlowScoped beans declared for this flow must remain in scope until after control returns from the method referenced by this MethodExpression.

        Since:
        2.2

      • getInitializer

        public abstract MethodExpression getInitializer()

        Return the MethodExpression that must be called by the runtime immediately after activating any FlowScoped beans declared for this flow.

        Since:
        2.2

      • getInboundParameters

        public abstract Map<String,Parameter> getInboundParameters()

        Return an immutable data structure containing the inbound parameters that have been declared for this flow. See FlowHandler.transition(javax.faces.context.FacesContext, javax.faces.flow.Flow, javax.faces.flow.Flow, javax.faces.flow.FlowCallNode, java.lang.String) for the specification of how these parameters are used. Inbound parameters are associated with a specific flow instance, while outbound parameters are associated with a FlowCallNode that causes the transition to a new flow.

        Since:
        2.2

      • getViews

        public abstract List<ViewNode> getViews()

        Return an immutable data structure containing all of the view nodes declared for this flow.

        Since:
        2.2

      • getReturns

        public abstract Map<String,ReturnNode> getReturns()

        Return an immutable data structure containing all of the return nodes declared for this flow.

        Since:
        2.2

      • getSwitches

        public abstract Map<String,SwitchNode> getSwitches()

        Return an immutable data structure containing all of the switch nodes declared for this flow.

        Since:
        2.2

      • getFlowCalls

        public abstract Map<String,FlowCallNode> getFlowCalls()

        Return an immutable data structure containing all the flow call nodes declared for this flow.

        Since:
        2.2

      • getFlowCall

        public abstract FlowCallNode getFlowCall(Flow targetFlow)

        Return the FlowCallNode that represents calling the targetFlow from this flow, or null if targetFlow cannot be reached from this flow.

        Since:
        2.2

      • getMethodCalls

        public abstract List<MethodCallNode> getMethodCalls()

        Return an immutable data structure containing all the method call nodes declared for this flow.

        Since:
        2.2

      • getNode

        public abstract FlowNode getNode(String nodeId)

      • getNavigationCases

        public abstract Map<String,Set<NavigationCase>> getNavigationCases()

      • getClientWindowFlowId

        public abstract String getClientWindowFlowId(ClientWindow curWindow)

        Obtain the current ClientWindow from the ExternalContext. Get the window's id and append "_" and the return from getId(). Return the result.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlowCallNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class FlowCallNode

  • java.lang.Object
    • javax.faces.flow.FlowNode
      • javax.faces.flow.FlowCallNode

  • public abstract class FlowCallNode
extends FlowNode

    • Constructor Summary

      Constructors
      Constructor and Description
      FlowCallNode()

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      abstract String | getCalledFlowDocumentId(FacesContext context)
      abstract String | getCalledFlowId(FacesContext context)
      abstract Map<String,Parameter> | getOutboundParameters()

      • Methods inherited from class javax.faces.flow.FlowNode

        getId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FlowCallNode

        public FlowCallNode()

    • Method Detail

      • getOutboundParameters

        public abstract Map<String,Parameter> getOutboundParameters()

      • getCalledFlowDocumentId

        public abstract String getCalledFlowDocumentId(FacesContext context)

      • getCalledFlowId

        public abstract String getCalledFlowId(FacesContext context)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlowHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class FlowHandler

  • java.lang.Object
    • javax.faces.flow.FlowHandler

  • public abstract class FlowHandler
extends Object

    FlowHandler is the main entry point that enables the runtime to interact with the faces flows feature. NavigationHandler uses this class when it needs to make navigational decisions related to flows. The faces flow feature entirely depends on the ClientWindow feature and also on CDI.

    Defining Flows

    The implementation must support defining faces flows using the <flow-definition> element as specified in the Application Configuration Resources XML Schema Definition, or by using the FlowBuilder API. Additional means of defining flows may be provided by decorating the FlowHandlerFactory.

    Managing Flows

      The singleton instance of this class must be thread safe, and therefore must not store any per-user state. Flows are, however, traversed in a per-user manner, and must be associated with the current ClientWindow. Furthermore, Flows may be nested. These requirements strongly suggest managing the flows with a stack-like runtime data structure, stored in a per-user fashion and associated with the ClientWindow.

      The Flow Graph

      Prior versions of the specification defined a flow graph but the only kind of node in the graph was a VDL view. The Faces Flow feature currently defines the following node types.

      • View

        This is the regular JSF VDL View that has been in the specification since the beginning.

      • Switch

        This is a list of EL expressions. When control is passed to a switch node, each expression in the list is evaluated and the first one that returns true is used to define the id of the next node to which control must be passed. If none of the expressions evaluates to true, control passes to the specified default id.

      • Return

        This node type specifies an outcome that is returned to the calling flow.

      • Method Call

        This node type allows invocation of arbitrary application logic at any point in the executiong of the flow. An outcome can be specified that will cause a navigation case to be navigated to after the method has been invoked.

      • Faces Flow Call

        This node type allows one flow to call another flow. The calling flow remains active and is not exited until control returns from the called flow.

      Edges in the graph are defined by the existing JSF navigation rule system.

      Flows and Model Objects

        Managed beans annotated with the CDI annotation FlowScoped must be instantiated upon a user agent's entry into the named scope, and must be made available for garbage collection when the user agent leaves the flow.

        The flowScope EL implicit object is also available to store values in the "current" slope. Values stored in this scope must be made available for garbage collection when the user agent leaves the flow.

    Since:
    2.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FLOW_ID_REQUEST_PARAM_NAME

      Components that are rendered by Renderers of component-family javax.faces.OutcomeTarget must use this constant as the parameter name for a parameter representing the flow id of the flow that this component will cause to be entered.
      static String NULL_FLOW

      Components that are rendered by Renderers of component-family javax.faces.OutcomeTarget must use this constant as the value of the parameter named by TO_FLOW_DOCUMENT_ID_REQUEST_PARAM_NAME when returning from a flow (without entering another flow) using such a component.
      static String TO_FLOW_DOCUMENT_ID_REQUEST_PARAM_NAME

      Components that are rendered by Renderers of component-family javax.faces.OutcomeTarget must use this constant as the parameter name for a parameter representing the defining document id of the flow that this component will cause to be entered.

    • Constructor Summary

      Constructors
      Constructor and Description
      FlowHandler()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addFlow(FacesContext context, Flow toAdd)

      Add the argument Flow to the collection of Flows known to the current application.
      abstract void clientWindowTransition(FacesContext context)

      Allow for flow transitions in the case of components rendered by the renderers from component-family javax.faces.OutcomeTarget.
      Flow getCurrentFlow()

      Convenience overload that calls FacesContext.getCurrentInstance() and then calls through to getCurrentFlow(javax.faces.context.FacesContext).
      abstract Flow getCurrentFlow(FacesContext context)

      Return the currently active Flow for the argument FacesContext, or null if no flow is active.
      abstract Map<Object,Object> getCurrentFlowScope()

      Return the Map that backs the #{flowScope} EL implicit object or null if no flow is currently active.
      abstract Flow getFlow(FacesContext context, String definingDocumentId, String id)

      Return the Flow whose id is equivalent to the argument id, within the scope of the argument definingDocument.
      abstract String getLastDisplayedViewId(FacesContext context)

      Return the last displayed viewId for the current flow, as returned by getCurrentFlow(javax.faces.context.FacesContext), or null if there is no current flow.
      abstract boolean isActive(FacesContext context, String definingDocument, String id)

      Return true if and only if the flow referenced by the argument definingDocument and id is currently active.
      abstract void popReturnMode(FacesContext context)

      Enable the correct handling of navigation when processing a return node.
      abstract void pushReturnMode(FacesContext context)

      Enable the correct handling of navigation when processing a return node.
      abstract void transition(FacesContext context, Flow sourceFlow, Flow targetFlow, FlowCallNode outboundCallNode, String toViewId)

      Perform a transition in the flow graph for the current user's ClientWindow.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FLOW_ID_REQUEST_PARAM_NAME

        public static final String FLOW_ID_REQUEST_PARAM_NAME

        Components that are rendered by Renderers of component-family javax.faces.OutcomeTarget must use this constant as the parameter name for a parameter representing the flow id of the flow that this component will cause to be entered.

        Since:
        2.2
        See Also:
        Constant Field Values

      • TO_FLOW_DOCUMENT_ID_REQUEST_PARAM_NAME

        public static final String TO_FLOW_DOCUMENT_ID_REQUEST_PARAM_NAME

        Components that are rendered by Renderers of component-family javax.faces.OutcomeTarget must use this constant as the parameter name for a parameter representing the defining document id of the flow that this component will cause to be entered.

        Since:
        2.2
        See Also:
        Constant Field Values

      • NULL_FLOW

        public static final String NULL_FLOW

        Components that are rendered by Renderers of component-family javax.faces.OutcomeTarget must use this constant as the value of the parameter named by TO_FLOW_DOCUMENT_ID_REQUEST_PARAM_NAME when returning from a flow (without entering another flow) using such a component.

        Since:
        2.2
        See Also:
        Constant Field Values

    • Constructor Detail

      • FlowHandler

        public FlowHandler()

    • Method Detail

      • getCurrentFlowScope

        public abstract Map<Object,Object> getCurrentFlowScope()

        Return the Map that backs the #{flowScope} EL implicit object or null if no flow is currently active.

        Since:
        2.2

      • getFlow

        public abstract Flow getFlow(FacesContext context,
           String definingDocumentId,
           String id)

        Return the Flow whose id is equivalent to the argument id, within the scope of the argument definingDocument.

        Parameters:
        context - the FacesContext for the current request.
        definingDocumentId - An application unique identifier for the document in which the returned flow is defined.
        id - the id of a Flow, unique within the scope of the definingDocument.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • addFlow

        public abstract void addFlow(FacesContext context,
           Flow toAdd)

        Add the argument Flow to the collection of Flows known to the current application. The implementation must be thread safe.

        Parameters:
        context - the FacesContext for the current request.
        toAdd - the Flow to add.
        Throws:
        NullPointerException - if any of the parameters are null
        IllegalStateException - if there is already a flow with the same id as the argument Flow within the scope of the definingDocument.
        IllegalArgumentException - if the id of the flow to add is null or the empty string.
        IllegalArgumentException - if the definingDocumentId of the toAdd is null.
        Since:
        2.2

      • getCurrentFlow

        public abstract Flow getCurrentFlow(FacesContext context)

        Return the currently active Flow for the argument FacesContext, or null if no flow is active. A Flow must always be associated with exactly one ClientWindow, but a ClientWindow may have multiple Flows.

        If pushReturnMode(javax.faces.context.FacesContext) had been called with true as the argument before invoking this method, return the preceding flow on the stack instead of the actual current flow, or null if there is no preceding flow. Otherwise, return the current flow.

        Parameters:
        context - the FacesContext for the current request.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • getCurrentFlow

        public Flow getCurrentFlow()

        Convenience overload that calls FacesContext.getCurrentInstance() and then calls through to getCurrentFlow(javax.faces.context.FacesContext).

        Since:
        2.2

      • getLastDisplayedViewId

        public abstract String getLastDisplayedViewId(FacesContext context)

        Return the last displayed viewId for the current flow, as returned by getCurrentFlow(javax.faces.context.FacesContext), or null if there is no current flow.

        Parameters:
        context - the FacesContext for the current request.
        Throws:
        NullPointerException - if context is null
        Since:
        2.2

      • pushReturnMode

        public abstract void pushReturnMode(FacesContext context)

        Enable the correct handling of navigation when processing a return node. The default NavigationHandler specification requires calling this method before processing the navigation rules for the flow return, and calling popReturnMode(javax.faces.context.FacesContext), from a finally block, immediately afterward.

        Parameters:
        context - the FacesContext for the current request.
        Throws:
        NullPointerException - if context is null.
        Since:
        2.2

      • popReturnMode

        public abstract void popReturnMode(FacesContext context)

        Enable the correct handling of navigation when processing a return node. The default NavigationHandler specification requires calling this method from a finally block, immediately attempting to process the navigation rules in the context of a flow return.

        Parameters:
        context - the FacesContext for the current request.
        Throws:
        NullPointerException - if context is null.
        Since:
        2.2

      • transition

        public abstract void transition(FacesContext context,
              Flow sourceFlow,
              Flow targetFlow,
              FlowCallNode outboundCallNode,
              String toViewId)

        Perform a transition in the flow graph for the current user's ClientWindow. Obtain references to the Flow instances corresponding to the origin and destination arguments. If the origin Flow is equal to the destination Flow, take no action and return null. Otherwise, if the outboundCallNode argument is non-null save aside the outbound parameters. For discussion evaluatedParams is a data structure that stores the evaluated values of any outbound parameters. It is necessary to evaluate these values before popping any flow scopes because the values may refer to scoped instances that need to be passed to the target flow, but will not be available once the new scope is activated. Save aside the outbound parameters using the following algorithm.

          If the outboundParameters property of outboundCallNode is non-null and not empty, and the inboundParameters property of the target flow is non-null and not empty, for each entry in the outbound parameters whose name matches an entry in the inbound parameters, evaluate the value of the parameter, and put the evaluated value into evaluatedParams under the corresponding name. Otherwise, consider evaluatedParams to be empty.

        If the destination Flow is a sub-flow of the origin Flow push the destination Flow onto the flow data structure and return the destination Flow. Otherwise, pop the current Flow from the flow data structure. If the destination Flow is non-null, make the destination Flow the current flow, pushing it onto the data structure. If evaluatedParams is not empty, for each entry, find the corresponding parameter in the target flow's inbound parameters and call its setValue method, passing the value from evaluatedParams.

        Parameters:
        context - the FacesContext for the current request.
        sourceFlow - the current Flow, or null if there is no source flow.
        targetFlow - the destination Flow, or null if there is no destination flow.
        outboundCallNode - the flow call node causing this transition, or null if this transition is not caused by a flow call.
        toViewId - the viewId of the view being displayed as a result of this transition. This parameter makes it possible to implement getLastDisplayedViewId(javax.faces.context.FacesContext).
        Throws:
        NullPointerException - if context or toViewId is null.
        Since:
        2.2

      • clientWindowTransition

        public abstract void clientWindowTransition(FacesContext context)

        Allow for flow transitions in the case of components rendered by the renderers from component-family javax.faces.OutcomeTarget. These transitions must happen at the front of the request processing lifecycle due to the HTTP GET based nature of such components. Therefore, this method is called from the restore view phase of the lifecycle.

        Let flowId be the value in the request parameter map for the parameter whose name is given by the value of FLOW_ID_REQUEST_PARAM_NAME. Let toFlowDocumentId be the value in the request parameter map for the paramater whose name is given by the value of TO_FLOW_DOCUMENT_ID_REQUEST_PARAM_NAME. If toFlowDocumentId is null, take no action and return. Otherwise, let sourceFlow be the return from getCurrentFlow(javax.faces.context.FacesContext). A null value indicates there is no current flow, which will be the case if this navigation is trying to enter a flow. If flowId is not null and toFlowDocumentId is not equal to the value of NULL_FLOW, let targetFlow be the result of calling getFlow(javax.faces.context.FacesContext, java.lang.String, java.lang.String), passing toFlowDocumentId and flowId as the last two arguments, respectively. If the result is non-null, let flowCallNode be the return from calling Flow.getFlowCall(javax.faces.flow.Flow) on the sourceFlow, passing targetFlow as the argument. Otherwise, targetFlow and flowCallNode must remain null, indicating that this is a flow return. Call FacesContext.getViewRoot() and let toViewId be the the return from calling UIViewRoot.getViewId() on it.

        Call, transition(javax.faces.context.FacesContext, javax.faces.flow.Flow, javax.faces.flow.Flow, javax.faces.flow.FlowCallNode, java.lang.String), passing the arguments gathered in the preceding algorithm.

        Parameters:
        context - the FacesContext for the current request.
        Throws:
        NullPointerException - if context is null.
        Since:
        2.2

      • isActive

        public abstract boolean isActive(FacesContext context,
               String definingDocument,
               String id)

        Return true if and only if the flow referenced by the argument definingDocument and id is currently active.

        Parameters:
        context - the FacesContext for the current request.
        definingDocument - An application unique identifier for the document in which the returned flow is defined.
        id - the id of a Flow, unique within the scope of the definingDocument.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlowHandlerFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class FlowHandlerFactory

  • java.lang.Object
    • javax.faces.flow.FlowHandlerFactory
  • Direct Known Subclasses:
    FlowHandlerFactoryWrapper

    public abstract class FlowHandlerFactory
extends Object

    FlowHandlerFactory is used by the Application to create the singleton instance of FlowHandler.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      FlowHandlerFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract FlowHandler createFlowHandler(FacesContext context)

      Create the singleton instance of FlowHandler.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FlowHandlerFactory

        public FlowHandlerFactory()

    • Method Detail

      • createFlowHandler

        public abstract FlowHandler createFlowHandler(FacesContext context)

        Create the singleton instance of FlowHandler.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlowHandlerFactoryWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class FlowHandlerFactoryWrapper

  • java.lang.Object
    • javax.faces.flow.FlowHandlerFactory
      • javax.faces.flow.FlowHandlerFactoryWrapper
  • All Implemented Interfaces:
    FacesWrapper<FlowHandlerFactory>

    public abstract class FlowHandlerFactoryWrapper
extends FlowHandlerFactory
implements FacesWrapper<FlowHandlerFactory>

    FlowHandlerFactoryWrapper provides a simple implementation of FlowHandlerFactory that can be subclassed by developers wishing to provide specialized behavior to an existing FlowHandlerFactory instance. The default implementation of all methods is to call through to the wrapped FlowHandlerFactory instance.

    getWrapped() to return the instance being wrapping.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      FlowHandlerFactoryWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      FlowHandler createFlowHandler(FacesContext context)

      Create the singleton instance of FlowHandler.
      abstract FlowHandlerFactory getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FlowHandlerFactoryWrapper

        public FlowHandlerFactoryWrapper()

    • Method Detail

      • getWrapped

        public abstract FlowHandlerFactory getWrapped()

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<FlowHandlerFactory>
        Since:
        2.2

      • createFlowHandler

        public FlowHandler createFlowHandler(FacesContext context)
        Description copied from class: FlowHandlerFactory

        Create the singleton instance of FlowHandler.

        Specified by:
        createFlowHandler in class FlowHandlerFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlowNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class FlowNode

  • java.lang.Object
    • javax.faces.flow.FlowNode
  • Direct Known Subclasses:
    FlowCallNode, MethodCallNode, ReturnNode, SwitchNode, ViewNode

    public abstract class FlowNode
extends Object

    FlowNode is the base class for all nodes in a faces flow graph.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      FlowNode()

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      abstract String | getId()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FlowNode

        public FlowNode()

    • Method Detail

      • getId

        public abstract String getId()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlowScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.flow

Annotation Type FlowScoped

  • @NormalScope
@Inherited
@Documented
@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface FlowScoped

    FlowScoped is a CDI scope that causes the runtime to consider classes with this annotation to be in the scope of the specified Flow. The implementation must provide an implementation of javax.enterprise.inject.spi.Extension that implements the semantics such that beans with this annotation are created when the user enters into the specified Flow, and de-allocated when the user exits the specified Flow. See FlowHandler.transition(javax.faces.context.FacesContext, javax.faces.flow.Flow, javax.faces.flow.Flow, javax.faces.flow.FlowCallNode, java.lang.String) for the specification of flow entry and exit.

    Since:
    2.2

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value

      Must be equivalent to the Flow.getId() of a defined flow for this application.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String definingDocumentId

      If not empty, declare the defining document id within which the Flow referenced by value() is unique.

    • Element Detail

      • value

        public abstract String value

        Must be equivalent to the Flow.getId() of a defined flow for this application.

        Since:
        2.2

      • definingDocumentId

        public abstract String definingDocumentId

        If not empty, declare the defining document id within which the Flow referenced by value() is unique. If empty the, the runtime assumes that all flow ids are unique within the scope of the application.

        Since:
        2.2
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.faces.flow (Java(TM) EE 7 Specification APIs)

javax.faces.flow

Classes

  • Flow
  • FlowCallNode
  • FlowHandler
  • FlowHandlerFactory
  • FlowHandlerFactoryWrapper
  • FlowNode
  • MethodCallNode
  • Parameter
  • ReturnNode
  • SwitchCase
  • SwitchNode
  • ViewNode

Annotation Types

  • FlowScoped


javax.faces.flow (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.flow

The runtime API for Faces Flows.

See: Description

  • Class Summary
    Class Description
    Flow

    Flow is the runtime representation of a Faces Flow.
    FlowCallNode
    FlowHandler

    FlowHandler is the main entry point that enables the runtime to interact with the faces flows feature.
    FlowHandlerFactory

    FlowHandlerFactory is used by the Application to create the singleton instance of FlowHandler.
    FlowHandlerFactoryWrapper

    FlowHandlerFactoryWrapper provides a simple implementation of FlowHandlerFactory that can be subclassed by developers wishing to provide specialized behavior to an existing FlowHandlerFactory instance.
    FlowNode

    FlowNode is the base class for all nodes in a faces flow graph.
    MethodCallNode

    Represents a method call node in the flow graph.
    Parameter

    Represents a parameter in any of several places where parameters are needed when processing flows.
    ReturnNode

    Represents a return node in the flow graph.
    SwitchCase

    Represents a case within a switch node in the flow graph.
    SwitchNode

    Represents a switch node in the flow graph.
    ViewNode

    ViewNode is the class that represents a VDL view in a faces flow graph.
  • Annotation Types Summary
    Annotation Type Description
    FlowScoped

    FlowScoped is a CDI scope that causes the runtime to consider classes with this annotation to be in the scope of the specified Flow.

Package javax.faces.flow Description

The runtime API for Faces Flows. See FlowHandler and its helpers for the normative specification of this feature.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.flow Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.flow

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.flow.Flow
    • javax.faces.flow.FlowHandler
    • javax.faces.flow.FlowHandlerFactory
      • javax.faces.flow.FlowHandlerFactoryWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.flow.FlowNode
      • javax.faces.flow.FlowCallNode
      • javax.faces.flow.MethodCallNode
      • javax.faces.flow.ReturnNode
      • javax.faces.flow.SwitchNode
      • javax.faces.flow.ViewNode
    • javax.faces.flow.Parameter
    • javax.faces.flow.SwitchCase

Annotation Type Hierarchy

  • javax.faces.flow.FlowScoped (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MethodCallNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class MethodCallNode

  • java.lang.Object
    • javax.faces.flow.FlowNode
      • javax.faces.flow.MethodCallNode

  • public abstract class MethodCallNode
extends FlowNode

    Represents a method call node in the flow graph. When control passes to a method call node, its MethodExpression is invoked, passing any parameters. Let outcome be the value determined by the following algorithm. If there is a null return from the invocation, getOutcome() is called. If the result is non-null, its getValue() method is called and the value is considered to be outcome. If there is a non-null return, let it be outcome. Convert outcome to a String by calling its toString method. Use outcome to determine the next node in the flow graph.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodCallNode()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract MethodExpression getMethodExpression()

      Return the MethodExpression to be invoked to when control passes to this node.
      abstract ValueExpression getOutcome()

      Return the outcome to be used in the event of a null return from the method.
      abstract List<Parameter> getParameters()

      Return the parameters to be passed to the method.

      • Methods inherited from class javax.faces.flow.FlowNode

        getId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MethodCallNode

        public MethodCallNode()

    • Method Detail

      • getMethodExpression

        public abstract MethodExpression getMethodExpression()

        Return the MethodExpression to be invoked to when control passes to this node.

        Since:
        2.2

      • getOutcome

        public abstract ValueExpression getOutcome()

        Return the outcome to be used in the event of a null return from the method.

        Since:
        2.2

      • getParameters

        public abstract List<Parameter> getParameters()

        Return the parameters to be passed to the method.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Parameter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class Parameter

  • java.lang.Object
    • javax.faces.flow.Parameter

  • public abstract class Parameter
extends Object

    Represents a parameter in any of several places where parameters are needed when processing flows.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      Parameter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract String getName()

      Return the name of the parameter
      abstract ValueExpression getValue()

      Return a ValueExpression for the value of the parameter.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Parameter

        public Parameter()

    • Method Detail

      • getName

        public abstract String getName()

        Return the name of the parameter

        Since:
        2.2

      • getValue

        public abstract ValueExpression getValue()

        Return a ValueExpression for the value of the parameter. Depending on the context, this expression may only ever be evaluated in a "get" operation.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ReturnNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class ReturnNode

  • java.lang.Object
    • javax.faces.flow.FlowNode
      • javax.faces.flow.ReturnNode

  • public abstract class ReturnNode
extends FlowNode

    Represents a return node in the flow graph. When control passes to a return node, its getFromOutcome(javax.faces.context.FacesContext) is called to determine the next node in the flow graph.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      ReturnNode()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract String getFromOutcome(FacesContext context)

      Return the fromOutcome to be used when control passes to this return node.

      • Methods inherited from class javax.faces.flow.FlowNode

        getId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ReturnNode

        public ReturnNode()

    • Method Detail

      • getFromOutcome

        public abstract String getFromOutcome(FacesContext context)

        Return the fromOutcome to be used when control passes to this return node.

        Parameters:
        context - the FacesContext for this request.
        Throws:
        NullPointerException - if context is null.
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SwitchCase (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class SwitchCase

  • java.lang.Object
    • javax.faces.flow.SwitchCase

  • public abstract class SwitchCase
extends Object

    Represents a case within a switch node in the flow graph. See SwitchNode.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      SwitchCase()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Boolean getCondition(FacesContext context)

      Return true if this case should be taken, false otherwise.
      abstract String getFromOutcome()

      Return the outcome to be used if getCondition(javax.faces.context.FacesContext) return true.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SwitchCase

        public SwitchCase()

    • Method Detail

      • getFromOutcome

        public abstract String getFromOutcome()

        Return the outcome to be used if getCondition(javax.faces.context.FacesContext) return true.

        Since:
        2.2

      • getCondition

        public abstract Boolean getCondition(FacesContext context)

        Return true if this case should be taken, false otherwise.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SwitchNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class SwitchNode

  • java.lang.Object
    • javax.faces.flow.FlowNode
      • javax.faces.flow.SwitchNode

  • public abstract class SwitchNode
extends FlowNode

    Represents a switch node in the flow graph. When control passes to a switch node, for each of the SwitchCases returned from getCases(), call SwitchCase.getCondition(javax.faces.context.FacesContext). If the return is true, let the return from SwitchCase.getFromOutcome() be used to determine where to go next in the flow graph and terminate the traversal. If none of the cases returned true let getDefaultOutcome(javax.faces.context.FacesContext) be used to determine where to go next in the flow graph.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      SwitchNode()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract List<SwitchCase> getCases()

      Return the cases in this switch.
      abstract String getDefaultOutcome(FacesContext context)

      Return the default outcome in this switch.

      • Methods inherited from class javax.faces.flow.FlowNode

        getId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SwitchNode

        public SwitchNode()

    • Method Detail

      • getCases

        public abstract List<SwitchCase> getCases()

        Return the cases in this switch.

        Since:
        2.2

      • getDefaultOutcome

        public abstract String getDefaultOutcome(FacesContext context)

        Return the default outcome in this switch.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.flow (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.flow

  • Packages that use javax.faces.flow
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.
  • Classes in javax.faces.flow used by javax.faces.application
    Class and Description
    Flow

    Flow is the runtime representation of a Faces Flow.
    FlowHandler

    FlowHandler is the main entry point that enables the runtime to interact with the faces flows feature.
  • Classes in javax.faces.flow used by javax.faces.flow
    Class and Description
    Flow

    Flow is the runtime representation of a Faces Flow.
    FlowCallNode
    FlowHandler

    FlowHandler is the main entry point that enables the runtime to interact with the faces flows feature.
    FlowHandlerFactory

    FlowHandlerFactory is used by the Application to create the singleton instance of FlowHandler.
    FlowNode

    FlowNode is the base class for all nodes in a faces flow graph.
    MethodCallNode

    Represents a method call node in the flow graph.
    Parameter

    Represents a parameter in any of several places where parameters are needed when processing flows.
    ReturnNode

    Represents a return node in the flow graph.
    SwitchCase

    Represents a case within a switch node in the flow graph.
    SwitchNode

    Represents a switch node in the flow graph.
    ViewNode

    ViewNode is the class that represents a VDL view in a faces flow graph.
  • Classes in javax.faces.flow used by javax.faces.flow.builder
    Class and Description
    Flow

    Flow is the runtime representation of a Faces Flow.
    Parameter

    Represents a parameter in any of several places where parameters are needed when processing flows.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ViewNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow

Class ViewNode

  • java.lang.Object
    • javax.faces.flow.FlowNode
      • javax.faces.flow.ViewNode

  • public abstract class ViewNode
extends FlowNode

    ViewNode is the class that represents a VDL view in a faces flow graph.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      ViewNode()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract String getVdlDocumentId()

      Return the immutable VDL document id for this view node.

      • Methods inherited from class javax.faces.flow.FlowNode

        getId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ViewNode

        public ViewNode()

    • Method Detail

      • getVdlDocumentId

        public abstract String getVdlDocumentId()

        Return the immutable VDL document id for this view node. This is normally the path to the VDL page that defines this view node. This must be unique within the flow.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlowBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow.builder

Class FlowBuilder

  • java.lang.Object
    • javax.faces.flow.builder.FlowBuilder

  • public abstract class FlowBuilder
extends Object

    A Java language API for building Flows. This API is semantically identical to the <flow-definition> element in the Application Configuration Resources XML Schema Definition.

    Usage example:

    public class FlowA implements Serializable {

    @Produces FlowDefinition
    public Flow buildMyFlow(@FlowBuilderParameter FlowBuilder flowBuilder) {
        String flowId = "flow-a";
        flowBuilder.id("unique", flowId);
        flowBuilder.returnNode("taskFlowReturn1").
                fromOutcome("#{flow_a_Bean.returnValue}");
        flowBuilder.inboundParameter("param1FromFlowB", "#{flowScope.param1Value}");
        flowBuilder.inboundParameter("param2FromFlowB", "#{flowScope.param2Value}");
        flowBuilder.flowCallNode("callB").flowReference("", "flow-b").
                outboundParameter("param1FromFlowA", "param1Value").
                outboundParameter("param2FromFlowA", "param2Value");

        return flowBuilder.getFlow();
    }
}

    The runtime must discover all such methods at startup time and ensure that the returned flows are added to the FlowHandler using the FlowHandler.addFlow(javax.faces.context.FacesContext, javax.faces.flow.Flow) method.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      FlowBuilder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract FlowBuilder finalizer(MethodExpression methodExpression)

      A MethodExpression that will be invoked when the flow is exited.
      abstract FlowBuilder finalizer(String methodExpression)

      A MethodExpression that will be invoked when the flow is exited.
      abstract FlowCallBuilder flowCallNode(String flowCallNodeId)

      Define a flow call node.
      abstract Flow getFlow()

      Called as the last step in flow definition, this method must perform any implementation specific initialization and return the built Flow.
      abstract FlowBuilder id(String definingDocumentId, String id)

      Set the defining document id and flow id of this flow.
      abstract FlowBuilder inboundParameter(String name, String expression)

      A parameter that will be populated with the value from a correspondingly named outbound parameter from another flow when this flow is entered from that flow.
      abstract FlowBuilder inboundParameter(String name, ValueExpression expression)

      A parameter that will be populated with the value from a correspondingly named outbound parameter from another flow when this flow is entered from that flow.
      abstract FlowBuilder initializer(MethodExpression methodExpression)

      A MethodExpression that will be invoked when the flow is entered.
      abstract FlowBuilder initializer(String methodExpression)

      A MethodExpression that will be invoked when the flow is entered.
      abstract MethodCallBuilder methodCallNode(String methodCallNodeId)

      Define a method call node.
      abstract NavigationCaseBuilder navigationCase()

      Define a particular combination of conditions that must match for this case to be executed, and the view id of the component tree that should be selected next.
      abstract ReturnBuilder returnNode(String returnNodeId)

      Define a return node.
      abstract SwitchBuilder switchNode(String switchNodeId)

      Define a particular list of cases that will be inspected in the order they are defined to determine where to go next in the flow graph.
      abstract ViewBuilder viewNode(String viewNodeId, String vdlDocumentId)

      Define a view node in a flow graph.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FlowBuilder

        public FlowBuilder()

    • Method Detail

      • id

        public abstract FlowBuilder id(String definingDocumentId,
             String id)

        Set the defining document id and flow id of this flow.

        Parameters:
        definingDocumentId - The defining document id of this flow, or the empty string if this flow does not need a defining document id.
        id - the id of the flow
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • viewNode

        public abstract ViewBuilder viewNode(String viewNodeId,
                   String vdlDocumentId)

        Define a view node in a flow graph.

        Parameters:
        viewNodeId - Within the flow graph, the id of this view node. Must be unique among all nodes in this flow graph.
        vdlDocumentId - The fully qualified path to the view node within this flow.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • navigationCase

        public abstract NavigationCaseBuilder navigationCase()

        Define a particular combination of conditions that must match for this case to be executed, and the view id of the component tree that should be selected next.

        Since:
        2.2

      • switchNode

        public abstract SwitchBuilder switchNode(String switchNodeId)

        Define a particular list of cases that will be inspected in the order they are defined to determine where to go next in the flow graph. If none of the cases match, the outcome from the default case is chosen.

        Parameters:
        switchNodeId - Within the flow graph, the id of this switch node. Must be unique among all nodes in this flow graph.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • returnNode

        public abstract ReturnBuilder returnNode(String returnNodeId)

        Define a return node. This node will cause the specified outcome to be returned to the calling flow.

        Parameters:
        returnNodeId - Within the flow graph, the id of this return node. Must be unique among all nodes in this flow graph.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • methodCallNode

        public abstract MethodCallBuilder methodCallNode(String methodCallNodeId)

        Define a method call node. This node will cause the specified method to be invoked, passing parameters if necessary. The return from the method is used as the outcome for where to go next in the flow. If the method is a void method, the default outcome is used.

        Parameters:
        methodCallNodeId - Within the flow graph, the id of this method call node. Must be unique among all nodes in this flow graph.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • flowCallNode

        public abstract FlowCallBuilder flowCallNode(String flowCallNodeId)

        Define a flow call node. This node will cause the specified flow to be called, passing parameters if necessary.

        Parameters:
        flowCallNodeId - Within the flow graph, the id of this return node. Must be unique among all nodes in this flow graph.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • initializer

        public abstract FlowBuilder initializer(MethodExpression methodExpression)

        A MethodExpression that will be invoked when the flow is entered.

        Parameters:
        methodExpression - the expression to invoke, must reference a zero-argument method.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • initializer

        public abstract FlowBuilder initializer(String methodExpression)

        A MethodExpression that will be invoked when the flow is entered.

        Parameters:
        methodExpression - the expression to invoke, must reference a zero-argument method.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • finalizer

        public abstract FlowBuilder finalizer(MethodExpression methodExpression)

        A MethodExpression that will be invoked when the flow is exited.

        Parameters:
        methodExpression - the expression to invoke, must reference a zero-argument method.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • finalizer

        public abstract FlowBuilder finalizer(String methodExpression)

        A MethodExpression that will be invoked when the flow is exited.

        Parameters:
        methodExpression - the expression to invoke, must reference a zero-argument method.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • inboundParameter

        public abstract FlowBuilder inboundParameter(String name,
                           ValueExpression expression)

        A parameter that will be populated with the value from a correspondingly named outbound parameter from another flow when this flow is entered from that flow.

        Parameters:
        name - the parameter name
        expression - the ValueExpression to populate with the inbound value when the flow is called.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • inboundParameter

        public abstract FlowBuilder inboundParameter(String name,
                           String expression)

        A parameter that will be populated with the value from a correspondingly named outbound parameter from another flow when this flow is entered from that flow.

        Parameters:
        name - the parameter name
        expression - the ValueExpression String to populate with the inbound value when the flow is called.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • getFlow

        public abstract Flow getFlow()

        Called as the last step in flow definition, this method must perform any implementation specific initialization and return the built Flow. If called more than one time during a given flow building process, the second and subsequent invocations must take no action and return the built flow.

        Throws:
        IllegalStateException - if the id(java.lang.String, java.lang.String) method had not been called prior to this method being called.
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlowBuilderParameter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.flow.builder

Annotation Type FlowBuilderParameter

  • @Qualifier
@Target(value={TYPE,METHOD,PARAMETER,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface FlowBuilderParameter

    The presence of this annotation on a CDI producer method for the FlowDefinition annotation causes the FlowBuilder to be passed to that method. See FlowBuilder for a usage example.

    Since:
    2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


FlowCallBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow.builder

Class FlowCallBuilder

  • java.lang.Object
    • javax.faces.flow.builder.FlowCallBuilder
  • All Implemented Interfaces:
    NodeBuilder

    public abstract class FlowCallBuilder
extends Object
implements NodeBuilder

    Create a flow call node in the current Flow.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      FlowCallBuilder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract FlowCallBuilder flowReference(String flowDocumentId, String flowId)

      Define the flow reference of the called flow.
      abstract FlowCallBuilder markAsStartNode()

      Mark this node as the start node in the flow.
      abstract FlowCallBuilder outboundParameter(String name, String value)

      Define an outbound parameter for the flow call.
      abstract FlowCallBuilder outboundParameter(String name, ValueExpression value)

      Define an outbound parameter for the flow call.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FlowCallBuilder

        public FlowCallBuilder()

    • Method Detail

      • flowReference

        public abstract FlowCallBuilder flowReference(String flowDocumentId,
                            String flowId)

        Define the flow reference of the called flow.

        Parameters:
        flowDocumentId - the document id of the called flow. May not be null, but may be the empty string.
        flowId - the id of the called flow. May not be null
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • outboundParameter

        public abstract FlowCallBuilder outboundParameter(String name,
                                ValueExpression value)

        Define an outbound parameter for the flow call.

        Parameters:
        name - the name of the parameter
        value - the value of the parameter
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • outboundParameter

        public abstract FlowCallBuilder outboundParameter(String name,
                                String value)

        Define an outbound parameter for the flow call.

        Parameters:
        name - the name of the parameter
        value - the value of the parameter
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • markAsStartNode

        public abstract FlowCallBuilder markAsStartNode()
        Description copied from interface: NodeBuilder

        Mark this node as the start node in the flow. Any other node that had been marked as the start node will no longer be the start node.

        Specified by:
        markAsStartNode in interface NodeBuilder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlowDefinition (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.flow.builder

Annotation Type FlowDefinition

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
@Qualifier
public @interface FlowDefinition

    The presence of this annotation on a CDI producer method indicates that the method will produce a flow. See FlowBuilder for a usage example.

    Since:
    2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.faces.flow.builder (Java(TM) EE 7 Specification APIs)

javax.faces.flow.builder

Interfaces

  • NodeBuilder

Classes

  • FlowBuilder
  • FlowCallBuilder
  • MethodCallBuilder
  • NavigationCaseBuilder
  • ReturnBuilder
  • SwitchBuilder
  • SwitchCaseBuilder
  • ViewBuilder

Annotation Types

  • FlowBuilderParameter
  • FlowDefinition


javax.faces.flow.builder (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.flow.builder

Classes for declaring a Faces Flow.

See: Description

  • Interface Summary
    Interface Description
    NodeBuilder

    Base interface for building all kinds of flow nodes.
  • Class Summary
    Class Description
    FlowBuilder

    A Java language API for building Flows.
    FlowCallBuilder

    Create a flow call node in the current Flow.
    MethodCallBuilder

    Create a method call node in the current Flow.
    NavigationCaseBuilder

    Create a navigation case in the current Flow.
    ReturnBuilder

    Create a return node in the current Flow.
    SwitchBuilder

    Create a switch node in the current Flow.
    SwitchCaseBuilder

    Create a case in the current switch.
    ViewBuilder

    Create a view node in the current Flow.
  • Annotation Types Summary
    Annotation Type Description
    FlowBuilderParameter

    The presence of this annotation on a CDI producer method for the FlowDefinition annotation causes the FlowBuilder to be passed to that method.
    FlowDefinition

    The presence of this annotation on a CDI producer method indicates that the method will produce a flow.

Package javax.faces.flow.builder Description

Classes for declaring a Faces Flow. See FlowBuilder and its helpers for the normative specification of this feature.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.flow.builder Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.flow.builder

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.flow.builder.FlowBuilder
    • javax.faces.flow.builder.FlowCallBuilder (implements javax.faces.flow.builder.NodeBuilder)
    • javax.faces.flow.builder.MethodCallBuilder (implements javax.faces.flow.builder.NodeBuilder)
    • javax.faces.flow.builder.NavigationCaseBuilder
    • javax.faces.flow.builder.NavigationCaseBuilder.RedirectBuilder
    • javax.faces.flow.builder.ReturnBuilder (implements javax.faces.flow.builder.NodeBuilder)
    • javax.faces.flow.builder.SwitchBuilder (implements javax.faces.flow.builder.NodeBuilder)
    • javax.faces.flow.builder.SwitchCaseBuilder
    • javax.faces.flow.builder.ViewBuilder (implements javax.faces.flow.builder.NodeBuilder)

Interface Hierarchy

  • javax.faces.flow.builder.NodeBuilder

Annotation Type Hierarchy

  • javax.faces.flow.builder.FlowDefinition (implements java.lang.annotation.Annotation)
  • javax.faces.flow.builder.FlowBuilderParameter (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MethodCallBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow.builder

Class MethodCallBuilder

  • java.lang.Object
    • javax.faces.flow.builder.MethodCallBuilder
  • All Implemented Interfaces:
    NodeBuilder

    public abstract class MethodCallBuilder
extends Object
implements NodeBuilder

    Create a method call node in the current Flow.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodCallBuilder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract MethodCallBuilder defaultOutcome(String outcome)

      If the method is a void method, or the method returns null, this can be used to specify what value should be passed to runtime when the method returns.
      abstract MethodCallBuilder defaultOutcome(ValueExpression outcome)

      If the method is a void method, or the method returns null, this can be used to specify what value should be passed to runtime when the method returns.
      abstract MethodCallBuilder expression(MethodExpression methodExpression)

      Set the method expression of this method call node.
      abstract MethodCallBuilder expression(String methodExpression)

      Set the method expression of this method call node.
      abstract MethodCallBuilder expression(String methodExpression, Class[] paramTypes)

      Set the method expression of this method call node.
      abstract MethodCallBuilder markAsStartNode()

      Mark this node as the start node in the flow.
      abstract MethodCallBuilder parameters(List<Parameter> parameters)

      Set the parameters of the method call node.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MethodCallBuilder

        public MethodCallBuilder()

    • Method Detail

      • expression

        public abstract MethodCallBuilder expression(MethodExpression methodExpression)

        Set the method expression of this method call node. The method signature of the argument methodExpression must match the number and type of the parameters passed in the parameters(java.util.List<javax.faces.flow.Parameter>) method.

        Parameters:
        methodExpression - The MethodExpression to invoke.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • expression

        public abstract MethodCallBuilder expression(String methodExpression)

        Set the method expression of this method call node. The method signature of the argument methodExpression must match the number and type of the parameters passed in the parameters(java.util.List<javax.faces.flow.Parameter>) method.

        Parameters:
        methodExpression - The MethodExpression String to invoke.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • expression

        public abstract MethodCallBuilder expression(String methodExpression,
                           Class[] paramTypes)

        Set the method expression of this method call node. The method signature of the argument methodExpression must match the number and type of the parameters passed in the parameters(java.util.List<javax.faces.flow.Parameter>) method.

        Parameters:
        methodExpression - The MethodExpression to invoke.
        paramTypes - the types of the parameters to the method.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • parameters

        public abstract MethodCallBuilder parameters(List<Parameter> parameters)

        Set the parameters of the method call node.

        Parameters:
        parameters - the parameters to pass to the method when it is invoked.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • defaultOutcome

        public abstract MethodCallBuilder defaultOutcome(String outcome)

        If the method is a void method, or the method returns null, this can be used to specify what value should be passed to runtime when the method returns.

        Parameters:
        outcome - A ValueExpression String representing the default outcome, only used if the method is a void method or returns null.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • defaultOutcome

        public abstract MethodCallBuilder defaultOutcome(ValueExpression outcome)

        If the method is a void method, or the method returns null, this can be used to specify what value should be passed to runtime when the method returns.

        Parameters:
        outcome - A ValueExpression representing the default outcome, only used if the method is a void method or returns null.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • markAsStartNode

        public abstract MethodCallBuilder markAsStartNode()
        Description copied from interface: NodeBuilder

        Mark this node as the start node in the flow. Any other node that had been marked as the start node will no longer be the start node.

        Specified by:
        markAsStartNode in interface NodeBuilder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NavigationCaseBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow.builder

Class NavigationCaseBuilder

  • java.lang.Object
    • javax.faces.flow.builder.NavigationCaseBuilder

  • public abstract class NavigationCaseBuilder
extends Object

    Create a navigation case in the current Flow.

    Since:
    2.2

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      class  NavigationCaseBuilder.RedirectBuilder

      Allows populating the redirect with parameters and setting the includeViewParams option.

    • Constructor Summary

      Constructors
      Constructor and Description
      NavigationCaseBuilder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract NavigationCaseBuilder condition(String condition)

      Set the if of the current navigation case.
      abstract NavigationCaseBuilder condition(ValueExpression condition)

      Set the if of the current navigation case.
      abstract NavigationCaseBuilder fromAction(String fromAction)

      Set the from-action of the current navigation case.
      abstract NavigationCaseBuilder fromOutcome(String fromOutcome)

      Set the from-outcome of the current navigation case.
      abstract NavigationCaseBuilder fromViewId(String fromViewId)

      Set the from-view-id of the current navigation case.
      abstract NavigationCaseBuilder.RedirectBuilder redirect()

      Create a redirect within this navigation case.
      abstract NavigationCaseBuilder toFlowDocumentId(String toFlowDocumentId)

      Set the to-flow-document-id of the current navigation case.
      abstract NavigationCaseBuilder toViewId(String toViewId)

      Set the to-view-id of the current navigation case.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NavigationCaseBuilder

        public NavigationCaseBuilder()

    • Method Detail

      • fromViewId

        public abstract NavigationCaseBuilder fromViewId(String fromViewId)

        Set the from-view-id of the current navigation case.

        Parameters:
        fromViewId - the from-view-id
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • fromAction

        public abstract NavigationCaseBuilder fromAction(String fromAction)

        Set the from-action of the current navigation case.

        Parameters:
        fromAction - the from-action
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • fromOutcome

        public abstract NavigationCaseBuilder fromOutcome(String fromOutcome)

        Set the from-outcome of the current navigation case.

        Parameters:
        fromOutcome - the from-outcome
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • toViewId

        public abstract NavigationCaseBuilder toViewId(String toViewId)

        Set the to-view-id of the current navigation case.

        Parameters:
        toViewId - the to-view-id
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • toFlowDocumentId

        public abstract NavigationCaseBuilder toFlowDocumentId(String toFlowDocumentId)

        Set the to-flow-document-id of the current navigation case.

        Parameters:
        toFlowDocumentId - the to-flow-document-id
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • condition

        public abstract NavigationCaseBuilder condition(String condition)

        Set the if of the current navigation case.

        Parameters:
        condition - the
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • condition

        public abstract NavigationCaseBuilder condition(ValueExpression condition)

        Set the if of the current navigation case.

        Parameters:
        condition - the
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • redirect

        public abstract NavigationCaseBuilder.RedirectBuilder redirect()

        Create a redirect within this navigation case.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NavigationCaseBuilder.RedirectBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow.builder

Class NavigationCaseBuilder.RedirectBuilder

  • java.lang.Object
    • javax.faces.flow.builder.NavigationCaseBuilder.RedirectBuilder
  • Enclosing class:
    NavigationCaseBuilder

    public abstract class NavigationCaseBuilder.RedirectBuilder
extends Object

    Allows populating the redirect with parameters and setting the includeViewParams option.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      NavigationCaseBuilder.RedirectBuilder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract NavigationCaseBuilder.RedirectBuilder includeViewParams()

      Indicates the current redirect should include view parameters.
      abstract NavigationCaseBuilder.RedirectBuilder parameter(String name, String value)

      Add a parameter to the redirect.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NavigationCaseBuilder.RedirectBuilder

        public NavigationCaseBuilder.RedirectBuilder()

    • Method Detail

      • parameter

        public abstract NavigationCaseBuilder.RedirectBuilder parameter(String name,
                                              String value)

        Add a parameter to the redirect.

        Parameters:
        name - the name of the redirect parameter
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • includeViewParams

        public abstract NavigationCaseBuilder.RedirectBuilder includeViewParams()

        Indicates the current redirect should include view parameters.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NodeBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow.builder

Interface NodeBuilder

  • All Known Implementing Classes:
    FlowCallBuilder, MethodCallBuilder, ReturnBuilder, SwitchBuilder, ViewBuilder

    public interface NodeBuilder

    Base interface for building all kinds of flow nodes.

    Since:
    2.2

    • Method Summary

      Methods
      Modifier and Type Method and Description
      NodeBuilder markAsStartNode()

      Mark this node as the start node in the flow.

    • Method Detail

      • markAsStartNode

        NodeBuilder markAsStartNode()

        Mark this node as the start node in the flow. Any other node that had been marked as the start node will no longer be the start node.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ReturnBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow.builder

Class ReturnBuilder

  • java.lang.Object
    • javax.faces.flow.builder.ReturnBuilder
  • All Implemented Interfaces:
    NodeBuilder

    public abstract class ReturnBuilder
extends Object
implements NodeBuilder

    Create a return node in the current Flow.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      ReturnBuilder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ReturnBuilder fromOutcome(String outcome)

      Set the outcome of the current return node.
      abstract ReturnBuilder fromOutcome(ValueExpression outcome)

      Set the outcome of the current return node.
      abstract ReturnBuilder markAsStartNode()

      Mark this node as the start node in the flow.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ReturnBuilder

        public ReturnBuilder()

    • Method Detail

      • fromOutcome

        public abstract ReturnBuilder fromOutcome(String outcome)

        Set the outcome of the current return node.

        Parameters:
        outcome - A ValueExpression String String that will be the outcome of the return.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • fromOutcome

        public abstract ReturnBuilder fromOutcome(ValueExpression outcome)

        Set the outcome of the current return node.

        Parameters:
        outcome - A ValueExpression String that will be the outcome of the return.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • markAsStartNode

        public abstract ReturnBuilder markAsStartNode()
        Description copied from interface: NodeBuilder

        Mark this node as the start node in the flow. Any other node that had been marked as the start node will no longer be the start node.

        Specified by:
        markAsStartNode in interface NodeBuilder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SwitchBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow.builder

Class SwitchBuilder

  • java.lang.Object
    • javax.faces.flow.builder.SwitchBuilder
  • All Implemented Interfaces:
    NodeBuilder

    public abstract class SwitchBuilder
extends Object
implements NodeBuilder

    Create a switch node in the current Flow.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      SwitchBuilder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract SwitchCaseBuilder defaultOutcome(String outcome)

      Set the default outcome of the current switch.
      abstract SwitchCaseBuilder defaultOutcome(ValueExpression outcome)

      Set the default outcome of the current switch.
      abstract SwitchBuilder markAsStartNode()

      Mark this node as the start node in the flow.
      abstract SwitchCaseBuilder switchCase()

      Create a switch case in the current switch.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SwitchBuilder

        public SwitchBuilder()

    • Method Detail

      • switchCase

        public abstract SwitchCaseBuilder switchCase()

        Create a switch case in the current switch.

        Since:
        2.2

      • defaultOutcome

        public abstract SwitchCaseBuilder defaultOutcome(String outcome)

        Set the default outcome of the current switch.

        Parameters:
        outcome - A ValueExpression String that will be the default outcome of the switch.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • defaultOutcome

        public abstract SwitchCaseBuilder defaultOutcome(ValueExpression outcome)

        Set the default outcome of the current switch.

        Parameters:
        outcome - A ValueExpression that will be the default outcome of the switch.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • markAsStartNode

        public abstract SwitchBuilder markAsStartNode()
        Description copied from interface: NodeBuilder

        Mark this node as the start node in the flow. Any other node that had been marked as the start node will no longer be the start node.

        Specified by:
        markAsStartNode in interface NodeBuilder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SwitchCaseBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow.builder

Class SwitchCaseBuilder

  • java.lang.Object
    • javax.faces.flow.builder.SwitchCaseBuilder

  • public abstract class SwitchCaseBuilder
extends Object

    Create a case in the current switch.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      SwitchCaseBuilder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract SwitchCaseBuilder condition(String expression)

      Set the if in the previously created switch case.
      abstract SwitchCaseBuilder condition(ValueExpression expression)

      Set the if in the previously created switch case.
      abstract SwitchCaseBuilder fromOutcome(String outcome)

      Set the outcome in the previously created switch case.
      abstract SwitchCaseBuilder switchCase()

      Create a new case in the current switch.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SwitchCaseBuilder

        public SwitchCaseBuilder()

    • Method Detail

      • switchCase

        public abstract SwitchCaseBuilder switchCase()

        Create a new case in the current switch.

        Since:
        2.2

      • condition

        public abstract SwitchCaseBuilder condition(ValueExpression expression)

        Set the if in the previously created switch case.

        Parameters:
        expression - the ValueExpression to be evaluated to see if this case is chosen.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • condition

        public abstract SwitchCaseBuilder condition(String expression)

        Set the if in the previously created switch case.

        Parameters:
        expression - the ValueExpression String to be evaluated to see if this case is chosen.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2

      • fromOutcome

        public abstract SwitchCaseBuilder fromOutcome(String outcome)

        Set the outcome in the previously created switch case.

        Parameters:
        outcome - the outcome to be returned if the condition evaluates to true.
        Throws:
        NullPointerException - if any of the parameters are null
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.flow.builder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.flow.builder

  • Packages that use javax.faces.flow.builder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.
  • Classes in javax.faces.flow.builder used by javax.faces.flow.builder
    Class and Description
    FlowBuilder

    A Java language API for building Flows.
    FlowCallBuilder

    Create a flow call node in the current Flow.
    MethodCallBuilder

    Create a method call node in the current Flow.
    NavigationCaseBuilder

    Create a navigation case in the current Flow.
    NavigationCaseBuilder.RedirectBuilder

    Allows populating the redirect with parameters and setting the includeViewParams option.
    NodeBuilder

    Base interface for building all kinds of flow nodes.
    ReturnBuilder

    Create a return node in the current Flow.
    SwitchBuilder

    Create a switch node in the current Flow.
    SwitchCaseBuilder

    Create a case in the current switch.
    ViewBuilder

    Create a view node in the current Flow.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ViewBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.flow.builder

Class ViewBuilder

  • java.lang.Object
    • javax.faces.flow.builder.ViewBuilder
  • All Implemented Interfaces:
    NodeBuilder

    public abstract class ViewBuilder
extends Object
implements NodeBuilder

    Create a view node in the current Flow.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      ViewBuilder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ViewBuilder markAsStartNode()

      Mark this node as the start node in the flow.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ViewBuilder

        public ViewBuilder()

    • Method Detail

      • markAsStartNode

        public abstract ViewBuilder markAsStartNode()
        Description copied from interface: NodeBuilder

        Mark this node as the start node in the flow. Any other node that had been marked as the start node will no longer be the start node.

        Specified by:
        markAsStartNode in interface NodeBuilder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.faces.flow.builder.FlowBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.FlowBuilder

  • Packages that use FlowBuilder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of FlowBuilder in javax.faces.flow.builder

      Methods in javax.faces.flow.builder that return FlowBuilder
      Modifier and Type Method and Description
      abstract FlowBuilder FlowBuilder.finalizer(MethodExpression methodExpression)

      A MethodExpression that will be invoked when the flow is exited.
      abstract FlowBuilder FlowBuilder.finalizer(String methodExpression)

      A MethodExpression that will be invoked when the flow is exited.
      abstract FlowBuilder FlowBuilder.id(String definingDocumentId, String id)

      Set the defining document id and flow id of this flow.
      abstract FlowBuilder FlowBuilder.inboundParameter(String name, String expression)

      A parameter that will be populated with the value from a correspondingly named outbound parameter from another flow when this flow is entered from that flow.
      abstract FlowBuilder FlowBuilder.inboundParameter(String name, ValueExpression expression)

      A parameter that will be populated with the value from a correspondingly named outbound parameter from another flow when this flow is entered from that flow.
      abstract FlowBuilder FlowBuilder.initializer(MethodExpression methodExpression)

      A MethodExpression that will be invoked when the flow is entered.
      abstract FlowBuilder FlowBuilder.initializer(String methodExpression)

      A MethodExpression that will be invoked when the flow is entered.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.builder.FlowBuilderParameter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.FlowBuilderParameter

No usage of javax.faces.flow.builder.FlowBuilderParameter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.builder.FlowCallBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.FlowCallBuilder

  • Packages that use FlowCallBuilder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of FlowCallBuilder in javax.faces.flow.builder

      Methods in javax.faces.flow.builder that return FlowCallBuilder
      Modifier and Type | Method and Description
      abstract FlowCallBuilder FlowBuilder.flowCallNode(String flowCallNodeId)

      Define a flow call node.
      abstract FlowCallBuilder FlowCallBuilder.flowReference(String flowDocumentId, String flowId)

      Define the flow reference of the called flow.
      abstract FlowCallBuilder | FlowCallBuilder.markAsStartNode()
      abstract FlowCallBuilder FlowCallBuilder.outboundParameter(String name, String value)

      Define an outbound parameter for the flow call.
      abstract FlowCallBuilder FlowCallBuilder.outboundParameter(String name, ValueExpression value)

      Define an outbound parameter for the flow call.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.builder.FlowDefinition (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.FlowDefinition

No usage of javax.faces.flow.builder.FlowDefinition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.builder.MethodCallBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.MethodCallBuilder

  • Packages that use MethodCallBuilder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of MethodCallBuilder in javax.faces.flow.builder

      Methods in javax.faces.flow.builder that return MethodCallBuilder
      Modifier and Type | Method and Description
      abstract MethodCallBuilder MethodCallBuilder.defaultOutcome(String outcome)

      If the method is a void method, or the method returns null, this can be used to specify what value should be passed to runtime when the method returns.
      abstract MethodCallBuilder MethodCallBuilder.defaultOutcome(ValueExpression outcome)

      If the method is a void method, or the method returns null, this can be used to specify what value should be passed to runtime when the method returns.
      abstract MethodCallBuilder MethodCallBuilder.expression(MethodExpression methodExpression)

      Set the method expression of this method call node.
      abstract MethodCallBuilder MethodCallBuilder.expression(String methodExpression)

      Set the method expression of this method call node.
      abstract MethodCallBuilder MethodCallBuilder.expression(String methodExpression, Class[] paramTypes)

      Set the method expression of this method call node.
      abstract MethodCallBuilder | MethodCallBuilder.markAsStartNode()
      abstract MethodCallBuilder FlowBuilder.methodCallNode(String methodCallNodeId)

      Define a method call node.
      abstract MethodCallBuilder MethodCallBuilder.parameters(List<Parameter> parameters)

      Set the parameters of the method call node.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.builder.NavigationCaseBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.NavigationCaseBuilder

  • Packages that use NavigationCaseBuilder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of NavigationCaseBuilder in javax.faces.flow.builder

      Methods in javax.faces.flow.builder that return NavigationCaseBuilder
      Modifier and Type Method and Description
      abstract NavigationCaseBuilder NavigationCaseBuilder.condition(String condition)

      Set the if of the current navigation case.
      abstract NavigationCaseBuilder NavigationCaseBuilder.condition(ValueExpression condition)

      Set the if of the current navigation case.
      abstract NavigationCaseBuilder NavigationCaseBuilder.fromAction(String fromAction)

      Set the from-action of the current navigation case.
      abstract NavigationCaseBuilder NavigationCaseBuilder.fromOutcome(String fromOutcome)

      Set the from-outcome of the current navigation case.
      abstract NavigationCaseBuilder NavigationCaseBuilder.fromViewId(String fromViewId)

      Set the from-view-id of the current navigation case.
      abstract NavigationCaseBuilder FlowBuilder.navigationCase()

      Define a particular combination of conditions that must match for this case to be executed, and the view id of the component tree that should be selected next.
      abstract NavigationCaseBuilder NavigationCaseBuilder.toFlowDocumentId(String toFlowDocumentId)

      Set the to-flow-document-id of the current navigation case.
      abstract NavigationCaseBuilder NavigationCaseBuilder.toViewId(String toViewId)

      Set the to-view-id of the current navigation case.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.builder.NavigationCaseBuilder.RedirectBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.NavigationCaseBuilder.RedirectBuilder

  • Packages that use NavigationCaseBuilder.RedirectBuilder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of NavigationCaseBuilder.RedirectBuilder in javax.faces.flow.builder

      Methods in javax.faces.flow.builder that return NavigationCaseBuilder.RedirectBuilder
      Modifier and Type Method and Description
      abstract NavigationCaseBuilder.RedirectBuilder NavigationCaseBuilder.RedirectBuilder.includeViewParams()

      Indicates the current redirect should include view parameters.
      abstract NavigationCaseBuilder.RedirectBuilder NavigationCaseBuilder.RedirectBuilder.parameter(String name, String value)

      Add a parameter to the redirect.
      abstract NavigationCaseBuilder.RedirectBuilder NavigationCaseBuilder.redirect()

      Create a redirect within this navigation case.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.builder.ReturnBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.ReturnBuilder

  • Packages that use ReturnBuilder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of ReturnBuilder in javax.faces.flow.builder

      Methods in javax.faces.flow.builder that return ReturnBuilder
      Modifier and Type | Method and Description
      abstract ReturnBuilder ReturnBuilder.fromOutcome(String outcome)

      Set the outcome of the current return node.
      abstract ReturnBuilder ReturnBuilder.fromOutcome(ValueExpression outcome)

      Set the outcome of the current return node.
      abstract ReturnBuilder | ReturnBuilder.markAsStartNode()
      abstract ReturnBuilder FlowBuilder.returnNode(String returnNodeId)

      Define a return node.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.builder.SwitchBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.SwitchBuilder

  • Packages that use SwitchBuilder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of SwitchBuilder in javax.faces.flow.builder

      Methods in javax.faces.flow.builder that return SwitchBuilder
      Modifier and Type | Method and Description
      abstract SwitchBuilder | SwitchBuilder.markAsStartNode()
      abstract SwitchBuilder FlowBuilder.switchNode(String switchNodeId)

      Define a particular list of cases that will be inspected in the order they are defined to determine where to go next in the flow graph.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.builder.SwitchCaseBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.SwitchCaseBuilder

  • Packages that use SwitchCaseBuilder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of SwitchCaseBuilder in javax.faces.flow.builder

      Methods in javax.faces.flow.builder that return SwitchCaseBuilder
      Modifier and Type Method and Description
      abstract SwitchCaseBuilder SwitchCaseBuilder.condition(String expression)

      Set the if in the previously created switch case.
      abstract SwitchCaseBuilder SwitchCaseBuilder.condition(ValueExpression expression)

      Set the if in the previously created switch case.
      abstract SwitchCaseBuilder SwitchBuilder.defaultOutcome(String outcome)

      Set the default outcome of the current switch.
      abstract SwitchCaseBuilder SwitchBuilder.defaultOutcome(ValueExpression outcome)

      Set the default outcome of the current switch.
      abstract SwitchCaseBuilder SwitchCaseBuilder.fromOutcome(String outcome)

      Set the outcome in the previously created switch case.
      abstract SwitchCaseBuilder SwitchCaseBuilder.switchCase()

      Create a new case in the current switch.
      abstract SwitchCaseBuilder SwitchBuilder.switchCase()

      Create a switch case in the current switch.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.builder.ViewBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.builder.ViewBuilder

  • Packages that use ViewBuilder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of ViewBuilder in javax.faces.flow.builder

      Methods in javax.faces.flow.builder that return ViewBuilder
      Modifier and Type | Method and Description
      abstract ViewBuilder | ViewBuilder.markAsStartNode()
      abstract ViewBuilder FlowBuilder.viewNode(String viewNodeId, String vdlDocumentId)

      Define a view node in a flow graph.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.flow.builder.NodeBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.flow.builder.NodeBuilder

  • Packages that use NodeBuilder
    Package Description
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of NodeBuilder in javax.faces.flow.builder

      Classes in javax.faces.flow.builder that implement NodeBuilder
      Modifier and Type Class and Description
      class  FlowCallBuilder

      Create a flow call node in the current Flow.
      class  MethodCallBuilder

      Create a method call node in the current Flow.
      class  ReturnBuilder

      Create a return node in the current Flow.
      class  SwitchBuilder

      Create a switch node in the current Flow.
      class  ViewBuilder

      Create a view node in the current Flow.
      Methods in javax.faces.flow.builder that return NodeBuilder
      Modifier and Type Method and Description
      NodeBuilder NodeBuilder.markAsStartNode()

      Mark this node as the start node in the flow.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.Flow (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.Flow

  • Packages that use Flow
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of Flow in javax.faces.application

      Methods in javax.faces.application with parameters of type Flow
      Modifier and Type | Method and Description
      void | ConfigurableNavigationHandlerWrapper.inspectFlow(FacesContext context, Flow flow)
      void ConfigurableNavigationHandler.inspectFlow(FacesContext context, Flow flow)

      Called by the flow system to cause the flow to be inspected for navigation rules.

    • Uses of Flow in javax.faces.flow

      Methods in javax.faces.flow that return Flow
      Modifier and Type Method and Description
      Flow FlowHandler.getCurrentFlow()

      Convenience overload that calls FacesContext.getCurrentInstance() and then calls through to FlowHandler.getCurrentFlow(javax.faces.context.FacesContext).
      abstract Flow FlowHandler.getCurrentFlow(FacesContext context)

      Return the currently active Flow for the argument FacesContext, or null if no flow is active.
      abstract Flow FlowHandler.getFlow(FacesContext context, String definingDocumentId, String id)

      Return the Flow whose id is equivalent to the argument id, within the scope of the argument definingDocument.
      Methods in javax.faces.flow with parameters of type Flow
      Modifier and Type Method and Description
      abstract void FlowHandler.addFlow(FacesContext context, Flow toAdd)

      Add the argument Flow to the collection of Flows known to the current application.
      abstract FlowCallNode Flow.getFlowCall(Flow targetFlow)

      Return the FlowCallNode that represents calling the targetFlow from this flow, or null if targetFlow cannot be reached from this flow.
      abstract void FlowHandler.transition(FacesContext context, Flow sourceFlow, Flow targetFlow, FlowCallNode outboundCallNode, String toViewId)

      Perform a transition in the flow graph for the current user's ClientWindow.

    • Uses of Flow in javax.faces.flow.builder

      Methods in javax.faces.flow.builder that return Flow
      Modifier and Type Method and Description
      abstract Flow FlowBuilder.getFlow()

      Called as the last step in flow definition, this method must perform any implementation specific initialization and return the built Flow.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.FlowCallNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.FlowCallNode

  • Packages that use FlowCallNode
    Package Description
    javax.faces.flow

    The runtime API for Faces Flows.

    • Uses of FlowCallNode in javax.faces.flow

      Methods in javax.faces.flow that return FlowCallNode
      Modifier and Type Method and Description
      abstract FlowCallNode Flow.getFlowCall(Flow targetFlow)

      Return the FlowCallNode that represents calling the targetFlow from this flow, or null if targetFlow cannot be reached from this flow.
      Methods in javax.faces.flow that return types with arguments of type FlowCallNode
      Modifier and Type Method and Description
      abstract Map<String,FlowCallNode> Flow.getFlowCalls()

      Return an immutable data structure containing all the flow call nodes declared for this flow.
      Methods in javax.faces.flow with parameters of type FlowCallNode
      Modifier and Type Method and Description
      abstract void FlowHandler.transition(FacesContext context, Flow sourceFlow, Flow targetFlow, FlowCallNode outboundCallNode, String toViewId)

      Perform a transition in the flow graph for the current user's ClientWindow.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.FlowHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.FlowHandler

  • Packages that use FlowHandler
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.flow

    The runtime API for Faces Flows.

    • Uses of FlowHandler in javax.faces.application

      Methods in javax.faces.application that return FlowHandler
      Modifier and Type | Method and Description
      FlowHandler | ApplicationWrapper.getFlowHandler()
      FlowHandler Application.getFlowHandler()

      Return the thread-safe singleton FlowHandler for this application.
      Methods in javax.faces.application with parameters of type FlowHandler
      Modifier and Type | Method and Description
      void | ApplicationWrapper.setFlowHandler(FlowHandler newHandler)
      void Application.setFlowHandler(FlowHandler newHandler)

      Set the FlowHandler instance used by the NavigationHandler to satisfy the requirements of the faces flows feature.

    • Uses of FlowHandler in javax.faces.flow

      Methods in javax.faces.flow that return FlowHandler
      Modifier and Type | Method and Description
      FlowHandler | FlowHandlerFactoryWrapper.createFlowHandler(FacesContext context)
      abstract FlowHandler FlowHandlerFactory.createFlowHandler(FacesContext context)

      Create the singleton instance of FlowHandler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.FlowHandlerFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.FlowHandlerFactory

  • Packages that use FlowHandlerFactory
    Package Description
    javax.faces.flow

    The runtime API for Faces Flows.

    • Uses of FlowHandlerFactory in javax.faces.flow

      Subclasses of FlowHandlerFactory in javax.faces.flow
      Modifier and Type Class and Description
      class  FlowHandlerFactoryWrapper

      FlowHandlerFactoryWrapper provides a simple implementation of FlowHandlerFactory that can be subclassed by developers wishing to provide specialized behavior to an existing FlowHandlerFactory instance.
      Methods in javax.faces.flow that return FlowHandlerFactory
      Modifier and Type Method and Description
      abstract FlowHandlerFactory FlowHandlerFactoryWrapper.getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.FlowHandlerFactoryWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.FlowHandlerFactoryWrapper

No usage of javax.faces.flow.FlowHandlerFactoryWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.FlowNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.FlowNode

  • Packages that use FlowNode
    Package Description
    javax.faces.flow

    The runtime API for Faces Flows.

    • Uses of FlowNode in javax.faces.flow

      Subclasses of FlowNode in javax.faces.flow
      Modifier and Type | Class and Description
      class  | FlowCallNode
      class  MethodCallNode

      Represents a method call node in the flow graph.
      class  ReturnNode

      Represents a return node in the flow graph.
      class  SwitchNode

      Represents a switch node in the flow graph.
      class  ViewNode

      ViewNode is the class that represents a VDL view in a faces flow graph.
      Methods in javax.faces.flow that return FlowNode
      Modifier and Type | Method and Description
      abstract FlowNode | Flow.getNode(String nodeId)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.FlowScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.FlowScoped

No usage of javax.faces.flow.FlowScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.MethodCallNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.MethodCallNode

  • Packages that use MethodCallNode
    Package Description
    javax.faces.flow

    The runtime API for Faces Flows.

    • Uses of MethodCallNode in javax.faces.flow

      Methods in javax.faces.flow that return types with arguments of type MethodCallNode
      Modifier and Type Method and Description
      abstract List<MethodCallNode> Flow.getMethodCalls()

      Return an immutable data structure containing all the method call nodes declared for this flow.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.Parameter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.Parameter

  • Packages that use Parameter
    Package Description
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.

    • Uses of Parameter in javax.faces.flow

      Methods in javax.faces.flow that return types with arguments of type Parameter
      Modifier and Type | Method and Description
      abstract Map<String,Parameter> Flow.getInboundParameters()

      Return an immutable data structure containing the inbound parameters that have been declared for this flow.
      abstract Map<String,Parameter> | FlowCallNode.getOutboundParameters()
      abstract List<Parameter> MethodCallNode.getParameters()

      Return the parameters to be passed to the method.

    • Uses of Parameter in javax.faces.flow.builder

      Method parameters in javax.faces.flow.builder with type arguments of type Parameter
      Modifier and Type Method and Description
      abstract MethodCallBuilder MethodCallBuilder.parameters(List<Parameter> parameters)

      Set the parameters of the method call node.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.ReturnNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.ReturnNode

  • Packages that use ReturnNode
    Package Description
    javax.faces.flow

    The runtime API for Faces Flows.

    • Uses of ReturnNode in javax.faces.flow

      Methods in javax.faces.flow that return types with arguments of type ReturnNode
      Modifier and Type Method and Description
      abstract Map<String,ReturnNode> Flow.getReturns()

      Return an immutable data structure containing all of the return nodes declared for this flow.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.SwitchCase (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.SwitchCase

  • Packages that use SwitchCase
    Package Description
    javax.faces.flow

    The runtime API for Faces Flows.

    • Uses of SwitchCase in javax.faces.flow

      Methods in javax.faces.flow that return types with arguments of type SwitchCase
      Modifier and Type Method and Description
      abstract List<SwitchCase> SwitchNode.getCases()

      Return the cases in this switch.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.SwitchNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.SwitchNode

  • Packages that use SwitchNode
    Package Description
    javax.faces.flow

    The runtime API for Faces Flows.

    • Uses of SwitchNode in javax.faces.flow

      Methods in javax.faces.flow that return types with arguments of type SwitchNode
      Modifier and Type Method and Description
      abstract Map<String,SwitchNode> Flow.getSwitches()

      Return an immutable data structure containing all of the switch nodes declared for this flow.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.flow.ViewNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.flow.ViewNode

  • Packages that use ViewNode
    Package Description
    javax.faces.flow

    The runtime API for Faces Flows.

    • Uses of ViewNode in javax.faces.flow

      Methods in javax.faces.flow that return types with arguments of type ViewNode
      Modifier and Type Method and Description
      abstract List<ViewNode> Flow.getViews()

      Return an immutable data structure containing all of the view nodes declared for this flow.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ClientWindow (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.lifecycle

Class ClientWindow

  • java.lang.Object
    • javax.faces.lifecycle.ClientWindow
  • Direct Known Subclasses:
    ClientWindowWrapper

    public abstract class ClientWindow
extends Object

    This class represents a client window, which may be a browser tab, browser window, browser pop-up, portlet, or anything else that can display a UIComponent hierarchy rooted at a UIViewRoot.

    Modes of Operation

      none mode

      The generation of ClientWindow is controlled by the value of the context-param named by the value of CLIENT_WINDOW_MODE_PARAM_NAME. If this context-param is not specified, or its value is "none", no ClientWindow instances will be generated, and the entire feature is effectively disabled for the entire application.

      Other modes

      To accomadate the widest possible range of implementation choices to support this feature, explicit names for modes other than "none" and "url" are not specified. However, for all values of CLIENT_WINDOW_MODE_PARAM_NAME, the lifetime of a ClientWindow starts on the first request made by a particular client window (or tab, or pop-up, etc) to the JSF runtime and persists as long as that window remains open or the session expires, whichever comes first. A client window is always associated with exactly one UIViewRoot instance at a time, but may display many different UIViewRoots during its lifetime.

      The ClientWindow instance is associated with the incoming request during the Lifecycle.attachWindow(javax.faces.context.FacesContext) method. This method will cause a new instance of ClientWindow to be created, assigned an id, and passed to ExternalContext.setClientWindow(javax.faces.lifecycle.ClientWindow).

      During state saving, regardless of the window id mode, or state saving mode, for ajax and non-ajax requests, a hidden field must be written whose name, id and value are given as specified in ResponseStateManager.CLIENT_WINDOW_PARAM.

      In addition to the hidden field already described. The runtime must ensure that any component that renders a hyperlink that causes the user agent to send a GET request to the Faces server when it is clicked has a query parameter with a name and value specified in ResponseStateManager.CLIENT_WINDOW_URL_PARAM. This requirement is met by several of the "encode" methods on ExternalContext. See ExternalContext.encodeActionURL(java.lang.String) for details.

    Since:
    2.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CLIENT_WINDOW_MODE_PARAM_NAME

      The context-param that controls the operation of the ClientWindow feature.

    • Constructor Summary

      Constructors
      Constructor and Description
      ClientWindow()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void decode(FacesContext context)

      The implementation is responsible for examining the incoming request and extracting the value that must be returned from the getId() method.
      void disableClientWindowRenderMode(FacesContext context)

      Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first before rendering those URLs.
      void enableClientWindowRenderMode(FacesContext context)

      Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first after rendering those URLs.
      abstract String getId()

      Return a String value that uniquely identifies this ClientWindow within the scope of the current session.
      abstract Map<String,String> getQueryURLParameters(FacesContext context)

      This method will be called whenever a URL is generated by the runtime where client window related parameters need to be inserted into the URL.
      boolean isClientWindowRenderModeEnabled(FacesContext context)

      Methods that append the ClientWindow to generated URLs must call this method to see if they are permitted to do so.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CLIENT_WINDOW_MODE_PARAM_NAME

        public static final String CLIENT_WINDOW_MODE_PARAM_NAME

        The context-param that controls the operation of the ClientWindow feature. The runtime must support the values "none" and "url", without the quotes, but other values are possible. If not specified, or the value is not understood by the implementation, "none" is assumed.

        Since:
        2.2
        See Also:
        Constant Field Values

    • Constructor Detail

      • ClientWindow

        public ClientWindow()

    • Method Detail

      • getQueryURLParameters

        public abstract Map<String,String> getQueryURLParameters(FacesContext context)

        This method will be called whenever a URL is generated by the runtime where client window related parameters need to be inserted into the URL. This guarantees custom ClientWindow implementations that they will have the opportunity to insert any additional client window specific information in any case where a URL is generated, such as the rendering of hyperlinks. The returned map must be immutable. The default implementation of this method returns the empty map.

        Parameters:
        context - the FacesContext for this request.
        Returns:
        null or a map of parameters to insert into the URL query string.
        Since:
        2.2

      • getId

        public abstract String getId()

        Return a String value that uniquely identifies this ClientWindow within the scope of the current session. See decode(javax.faces.context.FacesContext) for the specification of how to derive this value.

        Since:
        2.2

      • decode

        public abstract void decode(FacesContext context)

        The implementation is responsible for examining the incoming request and extracting the value that must be returned from the getId() method. If CLIENT_WINDOW_MODE_PARAM_NAME is "none" this method must not be invoked. If CLIENT_WINDOW_MODE_PARAM_NAME is "url" the implementation must first look for a request parameter under the name given by the value of ResponseStateManager.CLIENT_WINDOW_PARAM. If no value is found, look for a request parameter under the name given by the value of ResponseStateManager.CLIENT_WINDOW_URL_PARAM. If no value is found, fabricate an id that uniquely identifies this ClientWindow within the scope of the current session. This value must be made available to return from the getId() method. The value must be suitable for inclusion as a hidden field or query parameter. If a value is found, decrypt it using the key from the session and make it available for return from getId().

        Parameters:
        context - the FacesContext for this request.
        Since:
        2.2

      • disableClientWindowRenderMode

        public void disableClientWindowRenderMode(FacesContext context)

        Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first before rendering those URLs. The caller must call enableClientWindowRenderMode(javax.faces.context.FacesContext) from a finally block after rendering the URL. If CLIENT_WINDOW_MODE_PARAM_NAME is "url" without the quotes, all generated URLs that cause a GET request must append the ClientWindow by default. This is specified as a static method because callsites need to access it without having access to an actual ClientWindow instance.

        Parameters:
        context - the FacesContext for this request.
        Since:
        2.2

      • enableClientWindowRenderMode

        public void enableClientWindowRenderMode(FacesContext context)

        Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first after rendering those URLs. If CLIENT_WINDOW_MODE_PARAM_NAME is "url" without the quotes, all generated URLs that cause a GET request must append the ClientWindow by default. This is specified as a static method because callsites need to access it without having access to an actual ClientWindow instance.

        Parameters:
        context - the FacesContext for this request.
        Since:
        2.2

      • isClientWindowRenderModeEnabled

        public boolean isClientWindowRenderModeEnabled(FacesContext context)

        Methods that append the ClientWindow to generated URLs must call this method to see if they are permitted to do so. If CLIENT_WINDOW_MODE_PARAM_NAME is "url" without the quotes, all generated URLs that cause a GET request must append the ClientWindow by default. This is specified as a static method because callsites need to access it without having access to an actual ClientWindow instance.

        Parameters:
        context - the FacesContext for this request.
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientWindowFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.lifecycle

Class ClientWindowFactory

  • java.lang.Object
    • javax.faces.lifecycle.ClientWindowFactory
  • All Implemented Interfaces:
    FacesWrapper<ClientWindowFactory>

    public abstract class ClientWindowFactory
extends Object
implements FacesWrapper<ClientWindowFactory>

    Create ClientWindow instances based on the incoming request.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      ClientWindowFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ClientWindow getClientWindow(FacesContext context)

      The implementation is responsible for creating the ClientWindow instance for this request.
      ClientWindowFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ClientWindowFactory

        public ClientWindowFactory()

    • Method Detail

      • getWrapped

        public ClientWindowFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<ClientWindowFactory>
        Since:
        2.2

      • getClientWindow

        public abstract ClientWindow getClientWindow(FacesContext context)

        The implementation is responsible for creating the ClientWindow instance for this request. If ClientWindow.CLIENT_WINDOW_MODE_PARAM_NAME is "none" or unspecified, this method must return null. If ClientWindow.CLIENT_WINDOW_MODE_PARAM_NAME is "url" the implementation must return a ClientWindow instance that implements the url-mode semantics described in ClientWindow.

        Parameters:
        context - the FacesContext for this request.
        Returns:
        the ClientWindow for this request, or null
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientWindowWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.lifecycle

Class ClientWindowWrapper

  • java.lang.Object
    • javax.faces.lifecycle.ClientWindow
      • javax.faces.lifecycle.ClientWindowWrapper
  • All Implemented Interfaces:
    FacesWrapper<ClientWindow>

    public abstract class ClientWindowWrapper
extends ClientWindow
implements FacesWrapper<ClientWindow>

    Wrapper for ClientWindow

    Since:
    2.2

    • Field Summary

      • Fields inherited from class javax.faces.lifecycle.ClientWindow

        CLIENT_WINDOW_MODE_PARAM_NAME

    • Constructor Summary

      Constructors
      Constructor and Description
      ClientWindowWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void decode(FacesContext context)

      The implementation is responsible for examining the incoming request and extracting the value that must be returned from the ClientWindow.getId() method.
      void disableClientWindowRenderMode(FacesContext context)

      Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first before rendering those URLs.
      void enableClientWindowRenderMode(FacesContext context)

      Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first after rendering those URLs.
      String getId()

      Return a String value that uniquely identifies this ClientWindow within the scope of the current session.
      Map<String,String> getQueryURLParameters(FacesContext context)

      This method will be called whenever a URL is generated by the runtime where client window related parameters need to be inserted into the URL.
      abstract ClientWindow getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      boolean isClientWindowRenderModeEnabled(FacesContext context)

      Methods that append the ClientWindow to generated URLs must call this method to see if they are permitted to do so.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ClientWindowWrapper

        public ClientWindowWrapper()

    • Method Detail

      • getWrapped

        public abstract ClientWindow getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<ClientWindow>

      • getId

        public String getId()
        Description copied from class: ClientWindow

        Return a String value that uniquely identifies this ClientWindow within the scope of the current session. See ClientWindow.decode(javax.faces.context.FacesContext) for the specification of how to derive this value.

        Specified by:
        getId in class ClientWindow

      • getQueryURLParameters

        public Map<String,String> getQueryURLParameters(FacesContext context)
        Description copied from class: ClientWindow

        This method will be called whenever a URL is generated by the runtime where client window related parameters need to be inserted into the URL. This guarantees custom ClientWindow implementations that they will have the opportunity to insert any additional client window specific information in any case where a URL is generated, such as the rendering of hyperlinks. The returned map must be immutable. The default implementation of this method returns the empty map.

        Specified by:
        getQueryURLParameters in class ClientWindow
        Parameters:
        context - the FacesContext for this request.
        Returns:
        null or a map of parameters to insert into the URL query string.

      • disableClientWindowRenderMode

        public void disableClientWindowRenderMode(FacesContext context)
        Description copied from class: ClientWindow

        Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first before rendering those URLs. The caller must call ClientWindow.enableClientWindowRenderMode(javax.faces.context.FacesContext) from a finally block after rendering the URL. If ClientWindow.CLIENT_WINDOW_MODE_PARAM_NAME is "url" without the quotes, all generated URLs that cause a GET request must append the ClientWindow by default. This is specified as a static method because callsites need to access it without having access to an actual ClientWindow instance.

        Overrides:
        disableClientWindowRenderMode in class ClientWindow
        Parameters:
        context - the FacesContext for this request.

      • enableClientWindowRenderMode

        public void enableClientWindowRenderMode(FacesContext context)
        Description copied from class: ClientWindow

        Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first after rendering those URLs. If ClientWindow.CLIENT_WINDOW_MODE_PARAM_NAME is "url" without the quotes, all generated URLs that cause a GET request must append the ClientWindow by default. This is specified as a static method because callsites need to access it without having access to an actual ClientWindow instance.

        Overrides:
        enableClientWindowRenderMode in class ClientWindow
        Parameters:
        context - the FacesContext for this request.

      • isClientWindowRenderModeEnabled

        public boolean isClientWindowRenderModeEnabled(FacesContext context)
        Description copied from class: ClientWindow

        Methods that append the ClientWindow to generated URLs must call this method to see if they are permitted to do so. If ClientWindow.CLIENT_WINDOW_MODE_PARAM_NAME is "url" without the quotes, all generated URLs that cause a GET request must append the ClientWindow by default. This is specified as a static method because callsites need to access it without having access to an actual ClientWindow instance.

        Overrides:
        isClientWindowRenderModeEnabled in class ClientWindow
        Parameters:
        context - the FacesContext for this request.

      • decode

        public void decode(FacesContext context)
        Description copied from class: ClientWindow

        The implementation is responsible for examining the incoming request and extracting the value that must be returned from the ClientWindow.getId() method. If ClientWindow.CLIENT_WINDOW_MODE_PARAM_NAME is "none" this method must not be invoked. If ClientWindow.CLIENT_WINDOW_MODE_PARAM_NAME is "url" the implementation must first look for a request parameter under the name given by the value of ResponseStateManager.CLIENT_WINDOW_PARAM. If no value is found, look for a request parameter under the name given by the value of ResponseStateManager.CLIENT_WINDOW_URL_PARAM. If no value is found, fabricate an id that uniquely identifies this ClientWindow within the scope of the current session. This value must be made available to return from the ClientWindow.getId() method. The value must be suitable for inclusion as a hidden field or query parameter. If a value is found, decrypt it using the key from the session and make it available for return from ClientWindow.getId().

        Specified by:
        decode in class ClientWindow
        Parameters:
        context - the FacesContext for this request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces.lifecycle (Java(TM) EE 7 Specification APIs)

javax.faces.lifecycle

Classes

  • ClientWindow
  • ClientWindowFactory
  • ClientWindowWrapper
  • Lifecycle
  • LifecycleFactory
  • LifecycleWrapper


javax.faces.lifecycle (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.lifecycle

Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.

See: Description

  • Class Summary
    Class Description
    ClientWindow

    This class represents a client window, which may be a browser tab, browser window, browser pop-up, portlet, or anything else that can display a UIComponent hierarchy rooted at a UIViewRoot.
    ClientWindowFactory

    Create ClientWindow instances based on the incoming request.
    ClientWindowWrapper

    Wrapper for ClientWindow
    Lifecycle
    Lifecycle manages the processing of the entire lifecycle of a particular JavaServer Faces request.
    LifecycleFactory
    LifecycleFactory is a factory object that creates (if needed) and returns Lifecycle instances.
    LifecycleWrapper

    Provides a simple implementation of Lifecycle that can be subclassed by developers wishing to provide specialized behavior to an existing Lifecycle instance.

Package javax.faces.lifecycle Description

Classes and interfaces defining lifecycle management for the JavaServer Faces implementation. The main class in this package is Lifecycle. Lifecycle is the gateway to executing the request processing lifecycle.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.lifecycle Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.lifecycle

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.lifecycle.ClientWindow
      • javax.faces.lifecycle.ClientWindowWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.lifecycle.ClientWindowFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.lifecycle.Lifecycle
      • javax.faces.lifecycle.LifecycleWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.lifecycle.LifecycleFactory (implements javax.faces.FacesWrapper<T>)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Lifecycle (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.lifecycle

Class Lifecycle

  • java.lang.Object
    • javax.faces.lifecycle.Lifecycle
  • Direct Known Subclasses:
    LifecycleWrapper

    public abstract class Lifecycle
extends Object

    Lifecycle manages the processing of the entire lifecycle of a particular JavaServer Faces request. It is responsible for executing all of the phases that have been defined by the JavaServer Faces Specification, in the specified order, unless otherwise directed by activities that occurred during the execution of each phase.

    An instance of Lifecycle is created by calling the getLifecycle() method of LifecycleFactory, for a specified lifecycle identifier. Because this instance is shared across multiple simultaneous requests, it must be implemented in a thread-safe manner.

    • Constructor Summary

      Constructors
      Constructor and Description
      Lifecycle()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addPhaseListener(PhaseListener listener)
      Register a new PhaseListener instance that is interested in being notified before and after the processing for standard phases of the request processing lifecycle.
      void attachWindow(FacesContext context)

      Create or restore the ClientWindow to be used to display the UIViewRoot for this run through the lifecycle.
      abstract void execute(FacesContext context)
      Execute all of the phases of the request processing lifecycle, up to but not including the Render Response phase, as described in the JavaServer Faces Specification, in the specified order.
      abstract PhaseListener[] getPhaseListeners()
      Return the set of registered PhaseListeners for this Lifecycle instance.
      abstract void removePhaseListener(PhaseListener listener)
      Deregister an existing PhaseListener instance that is no longer interested in being notified before and after the processing for standard phases of the request processing lifecycle.
      abstract void render(FacesContext context)
      Execute the Render Response phase of the request processing lifecycle, unless the responseComplete() method has been called on the FacesContext instance associated with the current request.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Lifecycle

        public Lifecycle()

    • Method Detail

      • addPhaseListener

        public abstract void addPhaseListener(PhaseListener listener)

        Register a new PhaseListener instance that is interested in being notified before and after the processing for standard phases of the request processing lifecycle.

        Parameters:
        listener - The PhaseListener to be registered
        Throws:
        NullPointerException - if listener is null

      • execute

        public abstract void execute(FacesContext context)
                      throws FacesException

        Execute all of the phases of the request processing lifecycle, up to but not including the Render Response phase, as described in the JavaServer Faces Specification, in the specified order. The processing flow can be affected (by the application, by components, or by event listeners) by calls to the renderResponse() or responseComplete() methods of the FacesContext instance associated with the current request.

        Parameters:
        context - FacesContext for the request to be processed
        Throws:
        FacesException - if thrown during the execution of the request processing lifecycle
        NullPointerException - if context is null

      • attachWindow

        public void attachWindow(FacesContext context)

        Create or restore the ClientWindow to be used to display the UIViewRoot for this run through the lifecycle. See the class documentation for ClientWindow for an overview of the feature. If ExternalContext.getClientWindow() returns null, create a new instance of ClientWindow using the ClientWindowFactory. If the result is non-null, call ClientWindow.decode(javax.faces.context.FacesContext) on it. Store the new ClientWindow by calling ExternalContext.setClientWindow(javax.faces.lifecycle.ClientWindow).

        Since:
        2.2

      • getPhaseListeners

        public abstract PhaseListener[] getPhaseListeners()

        Return the set of registered PhaseListeners for this Lifecycle instance. If there are no registered listeners, a zero-length array is returned.

      • removePhaseListener

        public abstract void removePhaseListener(PhaseListener listener)

        Deregister an existing PhaseListener instance that is no longer interested in being notified before and after the processing for standard phases of the request processing lifecycle. If no such listener instance has been registered, no action is taken.

        Parameters:
        listener - The PhaseListener to be deregistered
        Throws:
        NullPointerException - if listener is null

      • render

        public abstract void render(FacesContext context)
                     throws FacesException

        Execute the Render Response phase of the request processing lifecycle, unless the responseComplete() method has been called on the FacesContext instance associated with the current request.

        Parameters:
        context - FacesContext for the request being processed
        Throws:
        FacesException - if an exception is thrown during the execution of the request processing lifecycle
        NullPointerException - if context is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LifecycleFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.lifecycle

Class LifecycleFactory

  • java.lang.Object
    • javax.faces.lifecycle.LifecycleFactory
  • All Implemented Interfaces:
    FacesWrapper<LifecycleFactory>

    public abstract class LifecycleFactory
extends Object
implements FacesWrapper<LifecycleFactory>

    LifecycleFactory is a factory object that creates (if needed) and returns Lifecycle instances. Implementations of JavaServer Faces must provide at least a default implementation of Lifecycle. Advanced implementations (or external third party libraries) MAY provide additional Lifecycle implementations (keyed by lifecycle identifiers) for performing different types of request processing on a per-request basis.

    There must be one LifecycleFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

       LifecycleFactory factory = (LifecycleFactory)
    FactoryFinder.getFactory(FactoryFinder.LIFECYCLE_FACTORY);

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DEFAULT_LIFECYCLE
      The lifecycle identifier for the default Lifecycle instance for this JavaServer Faces implementation.

    • Constructor Summary

      Constructors
      Constructor and Description
      LifecycleFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addLifecycle(String lifecycleId, Lifecycle lifecycle)
      Register a new Lifecycle instance, associated with the specified lifecycleId, to be supported by this LifecycleFactory.
      abstract Lifecycle getLifecycle(String lifecycleId)
      Create (if needed) and return a Lifecycle instance for the specified lifecycle identifier.
      abstract Iterator<String> getLifecycleIds()
      Return an Iterator over the set of lifecycle identifiers supported by this factory.
      LifecycleFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • DEFAULT_LIFECYCLE

        public static final String DEFAULT_LIFECYCLE

        The lifecycle identifier for the default Lifecycle instance for this JavaServer Faces implementation.

        See Also:
        Constant Field Values

    • Constructor Detail

      • LifecycleFactory

        public LifecycleFactory()

    • Method Detail

      • getWrapped

        public LifecycleFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<LifecycleFactory>
        Since:
        2.0

      • addLifecycle

        public abstract void addLifecycle(String lifecycleId,
                Lifecycle lifecycle)

        Register a new Lifecycle instance, associated with the specified lifecycleId, to be supported by this LifecycleFactory. This method may be called at any time, and makes the corresponding Lifecycle instance available throughout the remaining lifetime of this web application.

        Parameters:
        lifecycleId - Identifier of the new Lifecycle
        lifecycle - Lifecycle instance that we are registering
        Throws:
        IllegalArgumentException - if a Lifecycle with the specified lifecycleId has already been registered
        NullPointerException - if lifecycleId or lifecycle is null

      • getLifecycle

        public abstract Lifecycle getLifecycle(String lifecycleId)

        Create (if needed) and return a Lifecycle instance for the specified lifecycle identifier. The set of available lifecycle identifiers is available via the getLifecycleIds() method.

        Each call to getLifecycle() for the same lifecycleId, from within the same web application, must return the same Lifecycle instance.

        Parameters:
        lifecycleId - Lifecycle identifier of the requested Lifecycle instance
        Throws:
        IllegalArgumentException - if no Lifecycle instance can be returned for the specified identifier
        NullPointerException - if lifecycleId is null

      • getLifecycleIds

        public abstract Iterator<String> getLifecycleIds()

        Return an Iterator over the set of lifecycle identifiers supported by this factory. This set must include the value specified by LifecycleFactory.DEFAULT_LIFECYCLE.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LifecycleWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.lifecycle

Class LifecycleWrapper

  • java.lang.Object
    • javax.faces.lifecycle.Lifecycle
      • javax.faces.lifecycle.LifecycleWrapper
  • All Implemented Interfaces:
    FacesWrapper<Lifecycle>

    public abstract class LifecycleWrapper
extends Lifecycle
implements FacesWrapper<Lifecycle>

    Provides a simple implementation of Lifecycle that can be subclassed by developers wishing to provide specialized behavior to an existing Lifecycle instance. The default implementation of all methods is to call through to the wrapped Lifecycle.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      LifecycleWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addPhaseListener(PhaseListener listener)
      Register a new PhaseListener instance that is interested in being notified before and after the processing for standard phases of the request processing lifecycle.
      void attachWindow(FacesContext context)

      Create or restore the ClientWindow to be used to display the UIViewRoot for this run through the lifecycle.
      void execute(FacesContext context)
      Execute all of the phases of the request processing lifecycle, up to but not including the Render Response phase, as described in the JavaServer Faces Specification, in the specified order.
      PhaseListener[] getPhaseListeners()
      Return the set of registered PhaseListeners for this Lifecycle instance.
      abstract Lifecycle getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void removePhaseListener(PhaseListener listener)
      Deregister an existing PhaseListener instance that is no longer interested in being notified before and after the processing for standard phases of the request processing lifecycle.
      void render(FacesContext context)
      Execute the Render Response phase of the request processing lifecycle, unless the responseComplete() method has been called on the FacesContext instance associated with the current request.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • LifecycleWrapper

        public LifecycleWrapper()

    • Method Detail

      • getWrapped

        public abstract Lifecycle getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<Lifecycle>

      • addPhaseListener

        public void addPhaseListener(PhaseListener listener)
        Description copied from class: Lifecycle

        Register a new PhaseListener instance that is interested in being notified before and after the processing for standard phases of the request processing lifecycle.

        Specified by:
        addPhaseListener in class Lifecycle
        Parameters:
        listener - The PhaseListener to be registered

      • execute

        public void execute(FacesContext context)
             throws FacesException
        Description copied from class: Lifecycle

        Execute all of the phases of the request processing lifecycle, up to but not including the Render Response phase, as described in the JavaServer Faces Specification, in the specified order. The processing flow can be affected (by the application, by components, or by event listeners) by calls to the renderResponse() or responseComplete() methods of the FacesContext instance associated with the current request.

        Specified by:
        execute in class Lifecycle
        Parameters:
        context - FacesContext for the request to be processed
        Throws:
        FacesException - if thrown during the execution of the request processing lifecycle

      • getPhaseListeners

        public PhaseListener[] getPhaseListeners()
        Description copied from class: Lifecycle

        Return the set of registered PhaseListeners for this Lifecycle instance. If there are no registered listeners, a zero-length array is returned.

        Specified by:
        getPhaseListeners in class Lifecycle

      • removePhaseListener

        public void removePhaseListener(PhaseListener listener)
        Description copied from class: Lifecycle

        Deregister an existing PhaseListener instance that is no longer interested in being notified before and after the processing for standard phases of the request processing lifecycle. If no such listener instance has been registered, no action is taken.

        Specified by:
        removePhaseListener in class Lifecycle
        Parameters:
        listener - The PhaseListener to be deregistered

      • render

        public void render(FacesContext context)
            throws FacesException
        Description copied from class: Lifecycle

        Execute the Render Response phase of the request processing lifecycle, unless the responseComplete() method has been called on the FacesContext instance associated with the current request.

        Specified by:
        render in class Lifecycle
        Parameters:
        context - FacesContext for the request being processed
        Throws:
        FacesException - if an exception is thrown during the execution of the request processing lifecycle

      • attachWindow

        public void attachWindow(FacesContext context)
        Description copied from class: Lifecycle

        Create or restore the ClientWindow to be used to display the UIViewRoot for this run through the lifecycle. See the class documentation for ClientWindow for an overview of the feature. If ExternalContext.getClientWindow() returns null, create a new instance of ClientWindow using the ClientWindowFactory. If the result is non-null, call ClientWindow.decode(javax.faces.context.FacesContext) on it. Store the new ClientWindow by calling ExternalContext.setClientWindow(javax.faces.lifecycle.ClientWindow).

        Overrides:
        attachWindow in class Lifecycle
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.lifecycle (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.lifecycle

  • Packages that use javax.faces.lifecycle
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.
  • Classes in javax.faces.lifecycle used by javax.faces.context
    Class and Description
    ClientWindow

    This class represents a client window, which may be a browser tab, browser window, browser pop-up, portlet, or anything else that can display a UIComponent hierarchy rooted at a UIViewRoot.
    Lifecycle
    Lifecycle manages the processing of the entire lifecycle of a particular JavaServer Faces request.
  • Classes in javax.faces.lifecycle used by javax.faces.event
    Class and Description
    Lifecycle
    Lifecycle manages the processing of the entire lifecycle of a particular JavaServer Faces request.
  • Classes in javax.faces.lifecycle used by javax.faces.flow
    Class and Description
    ClientWindow

    This class represents a client window, which may be a browser tab, browser window, browser pop-up, portlet, or anything else that can display a UIComponent hierarchy rooted at a UIViewRoot.
  • Classes in javax.faces.lifecycle used by javax.faces.lifecycle
    Class and Description
    ClientWindow

    This class represents a client window, which may be a browser tab, browser window, browser pop-up, portlet, or anything else that can display a UIComponent hierarchy rooted at a UIViewRoot.
    ClientWindowFactory

    Create ClientWindow instances based on the incoming request.
    Lifecycle
    Lifecycle manages the processing of the entire lifecycle of a particular JavaServer Faces request.
    LifecycleFactory
    LifecycleFactory is a factory object that creates (if needed) and returns Lifecycle instances.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.lifecycle.ClientWindow (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.lifecycle.ClientWindow

  • Packages that use ClientWindow
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.flow

    The runtime API for Faces Flows.
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.

    • Uses of ClientWindow in javax.faces.context

      Methods in javax.faces.context that return ClientWindow
      Modifier and Type Method and Description
      ClientWindow ExternalContextWrapper.getClientWindow()

      The default behavior of this method is to call ExternalContext.getClientWindow() on the wrapped ExternalContext object.
      ClientWindow ExternalContext.getClientWindow()

      Return the ClientWindow set in a preceding call to ExternalContext.setClientWindow(javax.faces.lifecycle.ClientWindow), or null if no such call has been made.
      Methods in javax.faces.context with parameters of type ClientWindow
      Modifier and Type Method and Description
      void ExternalContextWrapper.setClientWindow(ClientWindow window)

      The default behavior of this method is to call ExternalContext.setClientWindow(javax.faces.lifecycle.ClientWindow) on the wrapped ExternalContext object.
      void ExternalContext.setClientWindow(ClientWindow window)

      Associate this instance with a ClientWindow.

    • Uses of ClientWindow in javax.faces.flow

      Methods in javax.faces.flow with parameters of type ClientWindow
      Modifier and Type Method and Description
      abstract String Flow.getClientWindowFlowId(ClientWindow curWindow)

      Obtain the current ClientWindow from the ExternalContext.

    • Uses of ClientWindow in javax.faces.lifecycle

      Subclasses of ClientWindow in javax.faces.lifecycle
      Modifier and Type Class and Description
      class  ClientWindowWrapper

      Wrapper for ClientWindow
      Methods in javax.faces.lifecycle that return ClientWindow
      Modifier and Type | Method and Description
      abstract ClientWindow ClientWindowFactory.getClientWindow(FacesContext context)

      The implementation is responsible for creating the ClientWindow instance for this request.
      abstract ClientWindow | ClientWindowWrapper.getWrapped()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.lifecycle.ClientWindowFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.lifecycle.ClientWindowFactory

  • Packages that use ClientWindowFactory
    Package Description
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.

    • Uses of ClientWindowFactory in javax.faces.lifecycle

      Methods in javax.faces.lifecycle that return ClientWindowFactory
      Modifier and Type Method and Description
      ClientWindowFactory ClientWindowFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.lifecycle.ClientWindowWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.lifecycle.ClientWindowWrapper

No usage of javax.faces.lifecycle.ClientWindowWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.lifecycle.Lifecycle (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.lifecycle.Lifecycle

  • Packages that use Lifecycle
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.event
    Interfaces describing events and event listeners, and concrete event implementation classes.
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.

    • Uses of Lifecycle in javax.faces.context

      Methods in javax.faces.context with parameters of type Lifecycle
      Modifier and Type Method and Description
      abstract FacesContext FacesContextFactory.getFacesContext(Object context, Object request, Object response, Lifecycle lifecycle)
      Create (if needed) and return a FacesContext instance that is initialized for the processing of the specified request and response objects, utilizing the specified Lifecycle instance, for this web application.

    • Uses of Lifecycle in javax.faces.event

      Constructors in javax.faces.event with parameters of type Lifecycle
      Constructor and Description
      PhaseEvent(FacesContext context, PhaseId phaseId, Lifecycle lifecycle)
      Construct a new event object from the specified parameters.

    • Uses of Lifecycle in javax.faces.lifecycle

      Subclasses of Lifecycle in javax.faces.lifecycle
      Modifier and Type Class and Description
      class  LifecycleWrapper

      Provides a simple implementation of Lifecycle that can be subclassed by developers wishing to provide specialized behavior to an existing Lifecycle instance.
      Methods in javax.faces.lifecycle that return Lifecycle
      Modifier and Type | Method and Description
      abstract Lifecycle LifecycleFactory.getLifecycle(String lifecycleId)
      Create (if needed) and return a Lifecycle instance for the specified lifecycle identifier.
      abstract Lifecycle | LifecycleWrapper.getWrapped()
      Methods in javax.faces.lifecycle with parameters of type Lifecycle
      Modifier and Type Method and Description
      abstract void LifecycleFactory.addLifecycle(String lifecycleId, Lifecycle lifecycle)
      Register a new Lifecycle instance, associated with the specified lifecycleId, to be supported by this LifecycleFactory.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.lifecycle.LifecycleFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.lifecycle.LifecycleFactory

  • Packages that use LifecycleFactory
    Package Description
    javax.faces.lifecycle
    Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.

    • Uses of LifecycleFactory in javax.faces.lifecycle

      Methods in javax.faces.lifecycle that return LifecycleFactory
      Modifier and Type Method and Description
      LifecycleFactory LifecycleFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.lifecycle.LifecycleWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.lifecycle.LifecycleWrapper

No usage of javax.faces.lifecycle.LifecycleWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ArrayDataModel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Class ArrayDataModel<E>

  • java.lang.Object
    • javax.faces.model.DataModel<E>
      • javax.faces.model.ArrayDataModel<E>
  • All Implemented Interfaces:
    Iterable<E>

    public class ArrayDataModel<E>
extends DataModel<E>

    ArrayDataModel is a convenience implementation of DataModel that wraps an array of Java objects.

    • Constructor Summary

      Constructors
      Constructor and Description
      ArrayDataModel()
      Construct a new ArrayDataModel with no specified wrapped data.
      ArrayDataModel(E[] array)
      Construct a new ArrayDataModel wrapping the specified array.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getRowCount()
      If there is wrappedData available, return the length of the array.
      E getRowData()
      If row data is available, return the array element at the index specified by rowIndex.
      int getRowIndex()
      Return the zero-relative index of the currently selected row.
      Object getWrappedData()
      Return the object representing the data wrapped by this DataModel, if any.
      boolean isRowAvailable()
      Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array.
      void setRowIndex(int rowIndex)
      Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
      void setWrappedData(Object data)
      Set the object representing the data collection wrapped by this DataModel.

      • Methods inherited from class javax.faces.model.DataModel

        addDataModelListener, getDataModelListeners, iterator, removeDataModelListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ArrayDataModel

        public ArrayDataModel()

        Construct a new ArrayDataModel with no specified wrapped data.

      • ArrayDataModel

        public ArrayDataModel(E[] array)

        Construct a new ArrayDataModel wrapping the specified array.

        Parameters:
        array - Array to be wrapped (if any)

    • Method Detail

      • isRowAvailable

        public boolean isRowAvailable()

        Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array. Otherwise, return false.

        Specified by:
        isRowAvailable in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row availability

      • getRowCount

        public int getRowCount()

        If there is wrappedData available, return the length of the array. If no wrappedData is available, return -1.

        Specified by:
        getRowCount in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row count

      • getRowData

        public E getRowData()

        If row data is available, return the array element at the index specified by rowIndex. If no wrapped data is available, return null.

        Specified by:
        getRowData in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row data
        IllegalArgumentException - if now row data is available at the currently specified row index

      • getRowIndex

        public int getRowIndex()
        Description copied from class: DataModel

        Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

        Specified by:
        getRowIndex in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row index

      • setRowIndex

        public void setRowIndex(int rowIndex)
        Description copied from class: DataModel

        Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

        If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

        Specified by:
        setRowIndex in class DataModel<E>
        Parameters:
        rowIndex - The new zero-relative index (must be non-negative)
        Throws:
        FacesException - if an error occurs setting the row index
        IllegalArgumentException - if rowIndex is less than -1

      • getWrappedData

        public Object getWrappedData()
        Description copied from class: DataModel

        Return the object representing the data wrapped by this DataModel, if any.

        Specified by:
        getWrappedData in class DataModel<E>

      • setWrappedData

        public void setWrappedData(Object data)
        Description copied from class: DataModel

        Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

        If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

        Specified by:
        setWrappedData in class DataModel<E>
        Parameters:
        data - Data collection to be wrapped, or null to detach from any previous data collection
        Throws:
        ClassCastException - if data is non-null and is not an array of Java objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CollectionDataModel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Class CollectionDataModel<E>

  • java.lang.Object
    • javax.faces.model.DataModel<E>
      • javax.faces.model.CollectionDataModel<E>
  • All Implemented Interfaces:
    Iterable<E>

    public class CollectionDataModel<E>
extends DataModel<E>

    CollectionDataModel is a convenience implementation of DataModel that wraps an Collection of Java objects.

    • Constructor Summary

      Constructors
      Constructor and Description
      CollectionDataModel()
      Construct a new CollectionDataModel with no specified wrapped data.
      CollectionDataModel(Collection<E> collection)
      Construct a new CollectionDataModel wrapping the specified list.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getRowCount()
      If there is wrappedData available, return the length of the list.
      E getRowData()
      If row data is available, return the array element at the index specified by rowIndex.
      int getRowIndex()
      Return the zero-relative index of the currently selected row.
      Object getWrappedData()
      Return the object representing the data wrapped by this DataModel, if any.
      boolean isRowAvailable()
      Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the size of the list.
      void setRowIndex(int rowIndex)
      Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
      void setWrappedData(Object data)
      Set the wrapped data.

      • Methods inherited from class javax.faces.model.DataModel

        addDataModelListener, getDataModelListeners, iterator, removeDataModelListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CollectionDataModel

        public CollectionDataModel()

        Construct a new CollectionDataModel with no specified wrapped data.

      • CollectionDataModel

        public CollectionDataModel(Collection<E> collection)

        Construct a new CollectionDataModel wrapping the specified list.

        Parameters:
        collection - Collection to be wrapped.

    • Method Detail

      • isRowAvailable

        public boolean isRowAvailable()

        Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the size of the list. Otherwise, return false.

        Specified by:
        isRowAvailable in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row availability

      • getRowCount

        public int getRowCount()

        If there is wrappedData available, return the length of the list. If no wrappedData is available, return -1.

        Specified by:
        getRowCount in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row count

      • getRowData

        public E getRowData()

        If row data is available, return the array element at the index specified by rowIndex. If no wrapped data is available, return null.

        Specified by:
        getRowData in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row data
        IllegalArgumentException - if now row data is available at the currently specified row index

      • getRowIndex

        public int getRowIndex()
        Description copied from class: DataModel

        Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

        Specified by:
        getRowIndex in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row index

      • setRowIndex

        public void setRowIndex(int rowIndex)
        Description copied from class: DataModel

        Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

        If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

        Specified by:
        setRowIndex in class DataModel<E>
        Parameters:
        rowIndex - The new zero-relative index (must be non-negative)
        Throws:
        FacesException - if an error occurs setting the row index
        IllegalArgumentException - if rowIndex is less than -1

      • getWrappedData

        public Object getWrappedData()
        Description copied from class: DataModel

        Return the object representing the data wrapped by this DataModel, if any.

        Specified by:
        getWrappedData in class DataModel<E>

      • setWrappedData

        public void setWrappedData(Object data)
        Set the wrapped data.
        Specified by:
        setWrappedData in class DataModel<E>
        Parameters:
        data - the wrapped data.
        Throws:
        ClassCastException - if data is non-null and is not a Collection
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DataModel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Class DataModel<E>

  • java.lang.Object
    • javax.faces.model.DataModel<E>
  • All Implemented Interfaces:
    Iterable<E>
    Direct Known Subclasses:
    ArrayDataModel, CollectionDataModel, ListDataModel, ResultDataModel, ResultSetDataModel, ScalarDataModel

    public abstract class DataModel<E>
extends Object
implements Iterable<E>

    DataModel is an abstraction around arbitrary data binding technologies that can be used to adapt a variety of data sources for use by JavaServer Faces components that support per-row processing for their child components (such as UIData.

    The data collection underlying a DataModel instance is modeled as a collection of row objects that can be accessed by a zero-relative cursor (row index). The APIs provide mechanisms to position to a specified zero-relative row index, and to retrieve an object that represents the data that corresponds to the current row index.

    A concrete DataModel instance is attached to a particular collection of underlying data by calling the setWrappedData() method. It can be detached from that underlying data collection by passing a null parameter to this method.

    Concrete DataModel implementations must provide a public zero-arguments constructor that calls setWrappedData(null). A convenience constructor that takes a wrapped object of the appropriate type (and passes it on via a call to setWrappedData(), should also be provided.

    Event listeners may be registered to receive notifications of when a new row index is selected.

    • Constructor Summary

      Constructors
      Constructor and Description
      DataModel()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addDataModelListener(DataModelListener listener)
      Add a new DataModelListener to the set interested in notifications from this DataModel.
      DataModelListener[] getDataModelListeners()
      Return the set of DataModelListeners interested in notifications from this DataModel.
      abstract int getRowCount()
      Return the number of rows of data objects represented by this DataModel.
      abstract E getRowData()
      Return an object representing the data for the currenty selected row index.
      abstract int getRowIndex()
      Return the zero-relative index of the currently selected row.
      abstract Object getWrappedData()
      Return the object representing the data wrapped by this DataModel, if any.
      abstract boolean isRowAvailable()
      Return a flag indicating whether there is rowData available at the current rowIndex.
      Iterator<E> iterator()

      Return a read-only Iterator over the row data for this model.
      void removeDataModelListener(DataModelListener listener)
      Remove an existing DataModelListener from the set interested in notifications from this DataModel.
      abstract void setRowIndex(int rowIndex)
      Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
      abstract void setWrappedData(Object data)
      Set the object representing the data collection wrapped by this DataModel.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DataModel

        public DataModel()

    • Method Detail

      • isRowAvailable

        public abstract boolean isRowAvailable()

        Return a flag indicating whether there is rowData available at the current rowIndex. If no wrappedData is available, return false.

        Throws:
        FacesException - if an error occurs getting the row availability

      • getRowCount

        public abstract int getRowCount()

        Return the number of rows of data objects represented by this DataModel. If the number of rows is unknown, or no wrappedData is available, return -1.

        Throws:
        FacesException - if an error occurs getting the row count

      • getRowData

        public abstract E getRowData()

        Return an object representing the data for the currenty selected row index. If no wrappedData is available, return null.

        Throws:
        FacesException - if an error occurs getting the row data
        IllegalArgumentException - if now row data is available at the currently specified row index

      • getRowIndex

        public abstract int getRowIndex()

        Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

        Throws:
        FacesException - if an error occurs getting the row index

      • setRowIndex

        public abstract void setRowIndex(int rowIndex)

        Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

        If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

        Parameters:
        rowIndex - The new zero-relative index (must be non-negative)
        Throws:
        FacesException - if an error occurs setting the row index
        IllegalArgumentException - if rowIndex is less than -1

      • getWrappedData

        public abstract Object getWrappedData()

        Return the object representing the data wrapped by this DataModel, if any.

      • setWrappedData

        public abstract void setWrappedData(Object data)

        Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

        If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

        Parameters:
        data - Data collection to be wrapped, or null to detach from any previous data collection
        Throws:
        ClassCastException - if data is not of the appropriate type for this DataModel implementation

      • addDataModelListener

        public void addDataModelListener(DataModelListener listener)

        Add a new DataModelListener to the set interested in notifications from this DataModel.

        Parameters:
        listener - The new DataModelListener to be registered
        Throws:
        NullPointerException - if listener is null

      • getDataModelListeners

        public DataModelListener[] getDataModelListeners()

        Return the set of DataModelListeners interested in notifications from this DataModel. If there are no such listeners, an empty array is returned.

      • removeDataModelListener

        public void removeDataModelListener(DataModelListener listener)

        Remove an existing DataModelListener from the set interested in notifications from this DataModel.

        Parameters:
        listener - The old DataModelListener to be deregistered
        Throws:
        NullPointerException - if listener is null

      • iterator

        public Iterator<E> iterator()

        Return a read-only Iterator over the row data for this model.

        Specified by:
        iterator in interface Iterable<E>
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DataModelEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Class DataModelEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.faces.model.DataModelEvent
  • All Implemented Interfaces:
    Serializable

    public class DataModelEvent
extends EventObject

    DataModelEvent represents an event of interest to registered listeners that occurred on the specified DataModel.

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      DataModelEvent(DataModel model, int index, Object data)
      Construct an event object that is associated with the specified row index and associated data.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      DataModel getDataModel()
      Return the DataModel that fired this event.
      Object getRowData()
      Return the object representing the data for the specified row index, or null for no associated row data.
      int getRowIndex()
      Return the row index for this event, or -1 for no specific row.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DataModelEvent

        public DataModelEvent(DataModel model,
              int index,
              Object data)

        Construct an event object that is associated with the specified row index and associated data.

        Parameters:
        model - The DataModel on which this event occurred
        index - The zero relative row index for which this event occurred, or -1 for no specific row association
        data - Representation of the data for the row specified by index, or null for no particular row data

    • Method Detail

      • getDataModel

        public DataModel getDataModel()

        Return the DataModel that fired this event.

      • getRowData

        public Object getRowData()

        Return the object representing the data for the specified row index, or null for no associated row data.

      • getRowIndex

        public int getRowIndex()

        Return the row index for this event, or -1 for no specific row.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DataModelListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Interface DataModelListener

  • All Superinterfaces:
    EventListener

    public interface DataModelListener
extends EventListener

    DataModelListener represents an event listener that wishes to be notified of DataModelEvents occurring on a particular DataModel instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void rowSelected(DataModelEvent event)
      Notification that a particular row index, with the associated row data, has been selected for processing.

    • Method Detail

      • rowSelected

        void rowSelected(DataModelEvent event)

        Notification that a particular row index, with the associated row data, has been selected for processing.

        Parameters:
        event - The DataModelEvent we are processing
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces.model (Java(TM) EE 7 Specification APIs)

javax.faces.model

Interfaces

  • DataModelListener

Classes

  • ArrayDataModel
  • CollectionDataModel
  • DataModel
  • DataModelEvent
  • ListDataModel
  • ResultDataModel
  • ResultSetDataModel
  • ScalarDataModel
  • SelectItem
  • SelectItemGroup


javax.faces.model (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.model

Standard model data beans for JavaServer Faces.

See: Description

  • Interface Summary
    Interface Description
    DataModelListener
    DataModelListener represents an event listener that wishes to be notified of DataModelEvents occurring on a particular DataModel instance.
  • Class Summary
    Class Description
    ArrayDataModel<E>
    ArrayDataModel is a convenience implementation of DataModel that wraps an array of Java objects.
    CollectionDataModel<E>

    CollectionDataModel is a convenience implementation of DataModel that wraps an Collection of Java objects.
    DataModel<E>
    DataModel is an abstraction around arbitrary data binding technologies that can be used to adapt a variety of data sources for use by JavaServer Faces components that support per-row processing for their child components (such as UIData.
    DataModelEvent
    DataModelEvent represents an event of interest to registered listeners that occurred on the specified DataModel.
    ListDataModel<E>
    ListDataModel is a convenience implementation of DataModel that wraps an List of Java objects.
    ResultDataModel
    ResultDataModel is a convenience implementation of DataModel that wraps a JSTL Result object, typically representing the results of executing an SQL query via JSTL tags.
    ResultSetDataModel
    ResultSetDataModel is a convenience implementation of DataModel that wraps a ResultSet of Java objects.
    ScalarDataModel<E>
    ScalarDataModel is a convenience implementation of DataModel that wraps an individual Java object.
    SelectItem
    SelectItem represents a single item in the list of supported items associated with a UISelectMany or UISelectOne component.
    SelectItemGroup
    SelectItemGroup is a subclass of SelectItem that identifies a set of options that will be made available as a subordinate "submenu" or "options list", depending upon the requirements of the UISelectMany or UISelectOne renderer that is actually used.

Package javax.faces.model Description

Standard model data beans for JavaServer Faces.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.model Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.model

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.model.DataModel<E> (implements java.lang.Iterable<T>)
      • javax.faces.model.ArrayDataModel<E>
      • javax.faces.model.CollectionDataModel<E>
      • javax.faces.model.ListDataModel<E>
      • javax.faces.model.ResultDataModel
      • javax.faces.model.ResultSetDataModel
      • javax.faces.model.ScalarDataModel<E>
    • java.util.EventObject (implements java.io.Serializable)
      • javax.faces.model.DataModelEvent
    • javax.faces.model.SelectItem (implements java.io.Serializable)
      • javax.faces.model.SelectItemGroup

Interface Hierarchy

  • java.util.EventListener
    • javax.faces.model.DataModelListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ListDataModel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Class ListDataModel<E>

  • java.lang.Object
    • javax.faces.model.DataModel<E>
      • javax.faces.model.ListDataModel<E>
  • All Implemented Interfaces:
    Iterable<E>

    public class ListDataModel<E>
extends DataModel<E>

    ListDataModel is a convenience implementation of DataModel that wraps an List of Java objects.

    • Constructor Summary

      Constructors
      Constructor and Description
      ListDataModel()
      Construct a new ListDataModel with no specified wrapped data.
      ListDataModel(List<E> list)
      Construct a new ListDataModel wrapping the specified list.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getRowCount()
      If there is wrappedData available, return the length of the list.
      E getRowData()
      If row data is available, return the array element at the index specified by rowIndex.
      int getRowIndex()
      Return the zero-relative index of the currently selected row.
      Object getWrappedData()
      Return the object representing the data wrapped by this DataModel, if any.
      boolean isRowAvailable()
      Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the size of the list.
      void setRowIndex(int rowIndex)
      Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
      void setWrappedData(Object data)
      Set the object representing the data collection wrapped by this DataModel.

      • Methods inherited from class javax.faces.model.DataModel

        addDataModelListener, getDataModelListeners, iterator, removeDataModelListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ListDataModel

        public ListDataModel()

        Construct a new ListDataModel with no specified wrapped data.

      • ListDataModel

        public ListDataModel(List<E> list)

        Construct a new ListDataModel wrapping the specified list.

        Parameters:
        list - List to be wrapped (if any)

    • Method Detail

      • isRowAvailable

        public boolean isRowAvailable()

        Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the size of the list. Otherwise, return false.

        Specified by:
        isRowAvailable in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row availability

      • getRowCount

        public int getRowCount()

        If there is wrappedData available, return the length of the list. If no wrappedData is available, return -1.

        Specified by:
        getRowCount in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row count

      • getRowData

        public E getRowData()

        If row data is available, return the array element at the index specified by rowIndex. If no wrapped data is available, return null.

        Specified by:
        getRowData in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row data
        IllegalArgumentException - if now row data is available at the currently specified row index

      • getRowIndex

        public int getRowIndex()
        Description copied from class: DataModel

        Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

        Specified by:
        getRowIndex in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row index

      • setRowIndex

        public void setRowIndex(int rowIndex)
        Description copied from class: DataModel

        Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

        If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

        Specified by:
        setRowIndex in class DataModel<E>
        Parameters:
        rowIndex - The new zero-relative index (must be non-negative)
        Throws:
        FacesException - if an error occurs setting the row index
        IllegalArgumentException - if rowIndex is less than -1

      • getWrappedData

        public Object getWrappedData()
        Description copied from class: DataModel

        Return the object representing the data wrapped by this DataModel, if any.

        Specified by:
        getWrappedData in class DataModel<E>

      • setWrappedData

        public void setWrappedData(Object data)
        Description copied from class: DataModel

        Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

        If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

        Specified by:
        setWrappedData in class DataModel<E>
        Parameters:
        data - Data collection to be wrapped, or null to detach from any previous data collection
        Throws:
        ClassCastException - if data is non-null and is not a List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResultDataModel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Class ResultDataModel

  • java.lang.Object
    • javax.faces.model.DataModel<SortedMap<String,Object>>
      • javax.faces.model.ResultDataModel
  • All Implemented Interfaces:
    Iterable<SortedMap<String,Object>>

    public class ResultDataModel
extends DataModel<SortedMap<String,Object>>

    ResultDataModel is a convenience implementation of DataModel that wraps a JSTL Result object, typically representing the results of executing an SQL query via JSTL tags.

    • Constructor Summary

      Constructors
      Constructor and Description
      ResultDataModel()
      Construct a new ResultDataModel with no specified wrapped data.
      ResultDataModel(Result result)
      Construct a new ResultDataModel wrapping the specified Result.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getRowCount()
      If there is wrappedData available, return the length of the array returned by calling getRows() on the underlying Result.
      SortedMap<String,Object> getRowData()
      If row data is available, return the SortedMap array element at the index specified by rowIndex of the array returned by calling getRows() on the underlying Result.
      int getRowIndex()
      Return the zero-relative index of the currently selected row.
      Object getWrappedData()
      Return the object representing the data wrapped by this DataModel, if any.
      boolean isRowAvailable()
      Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array returned by calling getRows() on the underlying Result.
      void setRowIndex(int rowIndex)
      Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
      void setWrappedData(Object data)
      Set the object representing the data collection wrapped by this DataModel.

      • Methods inherited from class javax.faces.model.DataModel

        addDataModelListener, getDataModelListeners, iterator, removeDataModelListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ResultDataModel

        public ResultDataModel()

        Construct a new ResultDataModel with no specified wrapped data.

      • ResultDataModel

        public ResultDataModel(Result result)

        Construct a new ResultDataModel wrapping the specified Result.

        Parameters:
        result - Result to be wrapped (if any)

    • Method Detail

      • isRowAvailable

        public boolean isRowAvailable()

        Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array returned by calling getRows() on the underlying Result. Otherwise, return false.

        Specified by:
        isRowAvailable in class DataModel<SortedMap<String,Object>>
        Throws:
        FacesException - if an error occurs getting the row availability

      • getRowCount

        public int getRowCount()

        If there is wrappedData available, return the length of the array returned by calling getRows() on the underlying Result. If no wrappedData is available, return -1.

        Specified by:
        getRowCount in class DataModel<SortedMap<String,Object>>
        Throws:
        FacesException - if an error occurs getting the row count

      • getRowData

        public SortedMap<String,Object> getRowData()

        If row data is available, return the SortedMap array element at the index specified by rowIndex of the array returned by calling getRows() on the underlying Result. If no wrapped data is available, return null.

        Note that, if a non-null Map is returned by this method, it will contain the values of the columns for the current row, keyed by column name. Column name comparisons must be performed in a case-insensitive manner.

        Specified by:
        getRowData in class DataModel<SortedMap<String,Object>>
        Throws:
        FacesException - if an error occurs getting the row data
        IllegalArgumentException - if now row data is available at the currently specified row index

      • getRowIndex

        public int getRowIndex()
        Description copied from class: DataModel

        Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

        Specified by:
        getRowIndex in class DataModel<SortedMap<String,Object>>
        Throws:
        FacesException

      • setRowIndex

        public void setRowIndex(int rowIndex)
        Description copied from class: DataModel

        Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

        If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

        Specified by:
        setRowIndex in class DataModel<SortedMap<String,Object>>
        Parameters:
        rowIndex - The new zero-relative index (must be non-negative)
        Throws:
        FacesException
        IllegalArgumentException - if rowIndex is less than -1

      • getWrappedData

        public Object getWrappedData()
        Description copied from class: DataModel

        Return the object representing the data wrapped by this DataModel, if any.

        Specified by:
        getWrappedData in class DataModel<SortedMap<String,Object>>

      • setWrappedData

        public void setWrappedData(Object data)
        Description copied from class: DataModel

        Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

        If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

        Specified by:
        setWrappedData in class DataModel<SortedMap<String,Object>>
        Parameters:
        data - Data collection to be wrapped, or null to detach from any previous data collection
        Throws:
        ClassCastException - if data is non-null and is not a Result
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResultSetDataModel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Class ResultSetDataModel

  • java.lang.Object
    • javax.faces.model.DataModel<Map<String,Object>>
      • javax.faces.model.ResultSetDataModel
  • All Implemented Interfaces:
    Iterable<Map<String,Object>>

    public class ResultSetDataModel
extends DataModel<Map<String,Object>>

    ResultSetDataModel is a convenience implementation of DataModel that wraps a ResultSet of Java objects. Note that the specified ResultSet MUST be scrollable. In addition, if input components (that will be updating model values) reference this object in value binding expressions, the specified ResultSet MUST be updatable.

    • Constructor Summary

      Constructors
      Constructor and Description
      ResultSetDataModel()
      Construct a new ResultSetDataModel with no specified wrapped data.
      ResultSetDataModel(ResultSet resultSet)
      Construct a new ResultSetDataModel wrapping the specified ResultSet.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getRowCount()
      Return -1, since ResultSet does not provide a standard way to determine the number of available rows without scrolling through the entire ResultSet, and this can be very expensive if the number of rows is large.
      Map<String,Object> getRowData()
      If row data is available, return a Map representing the values of the columns for the row specified by rowIndex, keyed by the corresponding column names.
      int getRowIndex()
      Return the zero-relative index of the currently selected row.
      Object getWrappedData()
      Return the object representing the data wrapped by this DataModel, if any.
      boolean isRowAvailable()
      Return true if there is wrappedData available, and the result of calling absolute() on the underlying ResultSet, passing the current value of rowIndex plus one (to account for the fact that ResultSet uses one-relative indexing), returns true.
      void setRowIndex(int rowIndex)
      Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
      void setWrappedData(Object data)
      Set the object representing the data collection wrapped by this DataModel.

      • Methods inherited from class javax.faces.model.DataModel

        addDataModelListener, getDataModelListeners, iterator, removeDataModelListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ResultSetDataModel

        public ResultSetDataModel()

        Construct a new ResultSetDataModel with no specified wrapped data.

      • ResultSetDataModel

        public ResultSetDataModel(ResultSet resultSet)

        Construct a new ResultSetDataModel wrapping the specified ResultSet.

        Parameters:
        resultSet - ResultSet to be wrapped (if any)

    • Method Detail

      • isRowAvailable

        public boolean isRowAvailable()

        Return true if there is wrappedData available, and the result of calling absolute() on the underlying ResultSet, passing the current value of rowIndex plus one (to account for the fact that ResultSet uses one-relative indexing), returns true. Otherwise, return false.

        Specified by:
        isRowAvailable in class DataModel<Map<String,Object>>
        Throws:
        FacesException - if an error occurs getting the row availability

      • getRowCount

        public int getRowCount()

        Return -1, since ResultSet does not provide a standard way to determine the number of available rows without scrolling through the entire ResultSet, and this can be very expensive if the number of rows is large.

        Specified by:
        getRowCount in class DataModel<Map<String,Object>>
        Throws:
        FacesException - if an error occurs getting the row count

      • getRowData

        public Map<String,Object> getRowData()

        If row data is available, return a Map representing the values of the columns for the row specified by rowIndex, keyed by the corresponding column names. If no wrapped data is available, return null.

        If a non-null Map is returned, its behavior must correspond to the contract for a mutable Map as described in the JavaDocs for AbstractMap, with the following exceptions and specialized behavior:

        • The Map, and any supporting objects it returns, must perform all column name comparisons in a case-insensitive manner. This case-insensitivity must be implemented using a case-insensitive Comparator, such as String.CASE_INSENSITIVE_ORDER.
        • The following methods must throw UnsupportedOperationException: clear(), remove().
        • The entrySet() method must return a Set that has the following behavior:
          • Throw UnsupportedOperationException for any attempt to add or remove entries from the Set, either directly or indirectly through an Iterator returned by the Set.
          • Updates to the value of an entry in this set must write through to the corresponding column value in the underlying ResultSet.
        • The keySet() method must return a Set that throws UnsupportedOperationException on any attempt to add or remove keys, either directly or through an Iterator returned by the Set.
        • The put() method must throw IllegalArgumentException if a key value for which containsKey() returns false is specified. However, if a key already present in the Map is specified, the specified value must write through to the corresponding column value in the underlying ResultSet.
        • The values() method must return a Collection that throws UnsupportedOperationException on any attempt to add or remove values, either directly or through an Iterator returned by the Collection.
        Specified by:
        getRowData in class DataModel<Map<String,Object>>
        Throws:
        FacesException - if an error occurs getting the row data
        IllegalArgumentException - if now row data is available at the currently specified row index

      • getRowIndex

        public int getRowIndex()
        Description copied from class: DataModel

        Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

        Specified by:
        getRowIndex in class DataModel<Map<String,Object>>
        Throws:
        FacesException - if an error occurs getting the row index

      • setRowIndex

        public void setRowIndex(int rowIndex)
        Description copied from class: DataModel

        Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

        If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

        Specified by:
        setRowIndex in class DataModel<Map<String,Object>>
        Parameters:
        rowIndex - The new zero-relative index (must be non-negative)
        Throws:
        FacesException - if an error occurs setting the row index
        IllegalArgumentException - if rowIndex is less than -1

      • getWrappedData

        public Object getWrappedData()
        Description copied from class: DataModel

        Return the object representing the data wrapped by this DataModel, if any.

        Specified by:
        getWrappedData in class DataModel<Map<String,Object>>

      • setWrappedData

        public void setWrappedData(Object data)
        Description copied from class: DataModel

        Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

        If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

        Specified by:
        setWrappedData in class DataModel<Map<String,Object>>
        Parameters:
        data - Data collection to be wrapped, or null to detach from any previous data collection
        Throws:
        ClassCastException - if data is not of the appropriate type for this DataModel implementation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ScalarDataModel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Class ScalarDataModel<E>

  • java.lang.Object
    • javax.faces.model.DataModel<E>
      • javax.faces.model.ScalarDataModel<E>
  • All Implemented Interfaces:
    Iterable<E>

    public class ScalarDataModel<E>
extends DataModel<E>

    ScalarDataModel is a convenience implementation of DataModel that wraps an individual Java object.

    • Constructor Summary

      Constructors
      Constructor and Description
      ScalarDataModel()
      Construct a new ScalarDataModel with no specified wrapped data.
      ScalarDataModel(E scalar)
      Construct a new ScalarDataModel wrapping the specified scalar object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getRowCount()
      If there is wrappedData available, return 1.
      E getRowData()
      If wrapped data is available, return the wrapped data instance.
      int getRowIndex()
      Return the zero-relative index of the currently selected row.
      Object getWrappedData()
      Return the object representing the data wrapped by this DataModel, if any.
      boolean isRowAvailable()
      Return true if there is wrappedData available, and the current value of rowIndex is zero.
      void setRowIndex(int rowIndex)
      Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
      void setWrappedData(Object data)
      Set the object representing the data collection wrapped by this DataModel.

      • Methods inherited from class javax.faces.model.DataModel

        addDataModelListener, getDataModelListeners, iterator, removeDataModelListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ScalarDataModel

        public ScalarDataModel()

        Construct a new ScalarDataModel with no specified wrapped data.

      • ScalarDataModel

        public ScalarDataModel(E scalar)

        Construct a new ScalarDataModel wrapping the specified scalar object.

        Parameters:
        scalar - Scalar to be wrapped (if any)

    • Method Detail

      • isRowAvailable

        public boolean isRowAvailable()

        Return true if there is wrappedData available, and the current value of rowIndex is zero. Otherwise, return false.

        Specified by:
        isRowAvailable in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row availability

      • getRowCount

        public int getRowCount()

        If there is wrappedData available, return 1. If no wrappedData is available, return -1.

        Specified by:
        getRowCount in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row count

      • getRowData

        public E getRowData()

        If wrapped data is available, return the wrapped data instance. Otherwise, return null.

        Specified by:
        getRowData in class DataModel<E>
        Throws:
        FacesException - if an error occurs getting the row data
        IllegalArgumentException - if now row data is available at the currently specified row index

      • getRowIndex

        public int getRowIndex()
        Description copied from class: DataModel

        Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

        Specified by:
        getRowIndex in class DataModel<E>
        Throws:
        FacesException

      • setRowIndex

        public void setRowIndex(int rowIndex)
        Description copied from class: DataModel

        Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

        If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

        Specified by:
        setRowIndex in class DataModel<E>
        Parameters:
        rowIndex - The new zero-relative index (must be non-negative)
        Throws:
        FacesException
        IllegalArgumentException - if rowIndex is less than -1

      • getWrappedData

        public Object getWrappedData()
        Description copied from class: DataModel

        Return the object representing the data wrapped by this DataModel, if any.

        Specified by:
        getWrappedData in class DataModel<E>

      • setWrappedData

        public void setWrappedData(Object data)
        Description copied from class: DataModel

        Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

        If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

        Specified by:
        setWrappedData in class DataModel<E>
        Parameters:
        data - Data collection to be wrapped, or null to detach from any previous data collection
        Throws:
        ClassCastException - if data is not of the appropriate type for this DataModel implementation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SelectItem (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Class SelectItem

  • java.lang.Object
    • javax.faces.model.SelectItem
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    SelectItemGroup

    public class SelectItem
extends Object
implements Serializable

    SelectItem represents a single item in the list of supported items associated with a UISelectMany or UISelectOne component.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SelectItem()
      Construct a SelectItem with no initialized property values.
      SelectItem(Object value)
      Construct a SelectItem with the specified value.
      SelectItem(Object value, String label)
      Construct a SelectItem with the specified value and label.
      SelectItem(Object value, String label, String description)
      Construct a SelectItem instance with the specified value, label and description.
      SelectItem(Object value, String label, String description, boolean disabled)
      Construct a SelectItem instance with the specified property values.
      SelectItem(Object value, String label, String description, boolean disabled, boolean escape)
      Construct a SelectItem instance with the specified property values.
      SelectItem(Object value, String label, String description, boolean disabled, boolean escape, boolean noSelectionOption)
      Construct a SelectItem instance with the specified property values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDescription()
      Return a description of this item, for use in development tools.
      String getLabel()
      Return the label of this item, to be rendered visibly for the user.
      Object getValue()
      Return the value of this item, to be delivered to the model if this item is selected by the user.
      boolean isDisabled()
      Return the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.
      boolean isEscape()

      If and only if this returns true, the code that renders this select item must escape the label using escaping syntax appropriate to the content type being rendered.
      boolean isNoSelectionOption()

      Return the value of the noSelectionOption property.
      void setDescription(String description)
      Set the description of this item, for use in development tools.
      void setDisabled(boolean disabled)
      Set the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.
      void setEscape(boolean escape)

      Set the value of the escape property.
      void setLabel(String label)
      Set the label of this item, to be rendered visibly for the user.
      void setNoSelectionOption(boolean noSelectionOption)

      Set the value of the noSelectionOption property.
      void setValue(Object value)
      Set the value of this item, to be delivered to the model if this item is selected by this user.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SelectItem

        public SelectItem()

        Construct a SelectItem with no initialized property values.

      • SelectItem

        public SelectItem(Object value)

        Construct a SelectItem with the specified value. The label property will be set to the value (converted to a String, if necessary), the description property will be set to null, the disabled property will be set to false, and the escape property will be set to ( true.

        Parameters:
        value - Value to be delivered to the model if this item is selected by the user

      • SelectItem

        public SelectItem(Object value,
          String label)

        Construct a SelectItem with the specified value and label. The description property will be set to null, the disabled property will be set to false, and the escape property will be set to true.

        Parameters:
        value - Value to be delivered to the model if this item is selected by the user
        label - Label to be rendered for this item in the response

      • SelectItem

        public SelectItem(Object value,
          String label,
          String description)

        Construct a SelectItem instance with the specified value, label and description. This disabled property will be set to false, and the escape property will be set to true.

        Parameters:
        value - Value to be delivered to the model if this item is selected by the user
        label - Label to be rendered for this item in the response
        description - Description of this item, for use in tools

      • SelectItem

        public SelectItem(Object value,
          String label,
          String description,
          boolean disabled)

        Construct a SelectItem instance with the specified property values. The escape property will be set to true.

        Parameters:
        value - Value to be delivered to the model if this item is selected by the user
        label - Label to be rendered for this item in the response
        description - Description of this item, for use in tools
        disabled - Flag indicating that this option is disabled

      • SelectItem

        public SelectItem(Object value,
          String label,
          String description,
          boolean disabled,
          boolean escape)

        Construct a SelectItem instance with the specified property values.

        Parameters:
        value - Value to be delivered to the model if this item is selected by the user
        label - Label to be rendered for this item in the response
        description - Description of this item, for use in tools
        disabled - Flag indicating that this option is disabled
        escape - Flag indicating that the text of this option should be escaped when rendered.
        Since:
        1.2

      • SelectItem

        public SelectItem(Object value,
          String label,
          String description,
          boolean disabled,
          boolean escape,
          boolean noSelectionOption)

        Construct a SelectItem instance with the specified property values.

        Parameters:
        value - Value to be delivered to the model if this item is selected by the user
        label - Label to be rendered for this item in the response
        description - Description of this item, for use in tools
        disabled - Flag indicating that this option is disabled
        escape - Flag indicating that the text of this option should be escaped when rendered.
        noSelectionOption - Flag indicating that the current option is a "no selection" option
        Since:
        1.2

    • Method Detail

      • getDescription

        public String getDescription()

        Return a description of this item, for use in development tools.

      • setDescription

        public void setDescription(String description)

        Set the description of this item, for use in development tools.

        Parameters:
        description - The new description

      • isDisabled

        public boolean isDisabled()

        Return the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.

      • setDisabled

        public void setDisabled(boolean disabled)

        Set the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.

        Parameters:
        disabled - The new disabled flag

      • getLabel

        public String getLabel()

        Return the label of this item, to be rendered visibly for the user.

      • setLabel

        public void setLabel(String label)

        Set the label of this item, to be rendered visibly for the user.

        Parameters:
        label - The new label

      • getValue

        public Object getValue()

        Return the value of this item, to be delivered to the model if this item is selected by the user.

      • setValue

        public void setValue(Object value)

        Set the value of this item, to be delivered to the model if this item is selected by this user.

        Parameters:
        value - The new value

      • isEscape

        public boolean isEscape()

        If and only if this returns true, the code that renders this select item must escape the label using escaping syntax appropriate to the content type being rendered.

        Since:
        2.0

      • setEscape

        public void setEscape(boolean escape)

        Set the value of the escape property. See isEscape().

        Since:
        2.0

      • isNoSelectionOption

        public boolean isNoSelectionOption()

        Return the value of the noSelectionOption property. If the value of this property is true, the system interprets the option represented by this SelectItem instance as representing a "no selection" option. See UISelectOne.validateValue(javax.faces.context.FacesContext, java.lang.Object) and UISelectMany.validateValue(javax.faces.context.FacesContext, java.lang.Object) for usage.

        Since:
        2.0

      • setNoSelectionOption

        public void setNoSelectionOption(boolean noSelectionOption)

        Set the value of the noSelectionOption property.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SelectItemGroup (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.model

Class SelectItemGroup

  • java.lang.Object
    • javax.faces.model.SelectItem
      • javax.faces.model.SelectItemGroup
  • All Implemented Interfaces:
    Serializable

    public class SelectItemGroup
extends SelectItem

    SelectItemGroup is a subclass of SelectItem that identifies a set of options that will be made available as a subordinate "submenu" or "options list", depending upon the requirements of the UISelectMany or UISelectOne renderer that is actually used. In general, the value property of this instance will be ignored, and the label property of this instance will be used to label the submenu.

    Although it is feasible to incorporate SelectItemGroup instances in he selectItems property of this instance (thereby creating a data structure suitable for cascading submenus), some renderers may place restrictions on the level of nesting they support. For example, HTML based renderers that create an <select> element will typically render this instance as an <optgroup> element, but the HTML 4.01 Specification disallows nested option groups.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SelectItemGroup()
      Construct a SelectItemGroup with no initialized property values.
      SelectItemGroup(String label)
      Construct a SelectItemGroup with the specified label and no associated selectItems.
      SelectItemGroup(String label, String description, boolean disabled, SelectItem[] selectItems)
      Construct a SelectItemGroup with the specified properties.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      SelectItem[] getSelectItems()
      Return the set of subordinate SelectItems for this group.
      void setSelectItems(SelectItem[] selectItems)
      Set the set of subordinate SelectItems for this group.

      • Methods inherited from class javax.faces.model.SelectItem

        getDescription, getLabel, getValue, isDisabled, isEscape, isNoSelectionOption, setDescription, setDisabled, setEscape, setLabel, setNoSelectionOption, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SelectItemGroup

        public SelectItemGroup()

        Construct a SelectItemGroup with no initialized property values.

      • SelectItemGroup

        public SelectItemGroup(String label)

        Construct a SelectItemGroup with the specified label and no associated selectItems. The value property will be set to a zero-length String, the description property will be set to null, and the disabled property will be set to false.

        Parameters:
        label - Label to be rendered for this group in the response
        Throws:
        NullPointerException - if label is false

      • SelectItemGroup

        public SelectItemGroup(String label,
               String description,
               boolean disabled,
               SelectItem[] selectItems)

        Construct a SelectItemGroup with the specified properties. The value property will be set to a zero-length String.

        Parameters:
        label - Label to be rendered for this group in the response
        description - Description of this group, for use in tools
        disabled - Flag indicating that this group is disabled
        selectItems - Array of SelectItem describing the items available in this group
        Throws:
        NullPointerException - if label or selectItems is false

    • Method Detail

      • getSelectItems

        public SelectItem[] getSelectItems()

        Return the set of subordinate SelectItems for this group.

      • setSelectItems

        public void setSelectItems(SelectItem[] selectItems)

        Set the set of subordinate SelectItems for this group.

        Parameters:
        selectItems - The new set of subordinate items
        Throws:
        NullPointerException - if selectItems is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.model (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.model

  • Packages that use javax.faces.model
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.model
    Standard model data beans for JavaServer Faces.
  • Classes in javax.faces.model used by javax.faces.component
    Class and Description
    DataModel
    DataModel is an abstraction around arbitrary data binding technologies that can be used to adapt a variety of data sources for use by JavaServer Faces components that support per-row processing for their child components (such as UIData.
  • Classes in javax.faces.model used by javax.faces.model
    Class and Description
    DataModel
    DataModel is an abstraction around arbitrary data binding technologies that can be used to adapt a variety of data sources for use by JavaServer Faces components that support per-row processing for their child components (such as UIData.
    DataModelEvent
    DataModelEvent represents an event of interest to registered listeners that occurred on the specified DataModel.
    DataModelListener
    DataModelListener represents an event listener that wishes to be notified of DataModelEvents occurring on a particular DataModel instance.
    SelectItem
    SelectItem represents a single item in the list of supported items associated with a UISelectMany or UISelectOne component.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.model.ArrayDataModel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.model.ArrayDataModel

No usage of javax.faces.model.ArrayDataModel
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.model.CollectionDataModel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.model.CollectionDataModel

No usage of javax.faces.model.CollectionDataModel
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.model.DataModel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.model.DataModel

  • Packages that use DataModel
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.model
    Standard model data beans for JavaServer Faces.

    • Uses of DataModel in javax.faces.component

      Methods in javax.faces.component that return DataModel
      Modifier and Type Method and Description
      protected DataModel UIData.getDataModel()
      Return the internal DataModel object representing the data objects that we will iterate over in this component's rendering.
      Methods in javax.faces.component with parameters of type DataModel
      Modifier and Type Method and Description
      protected void UIData.setDataModel(DataModel dataModel)
      Set the internal DataModel.

    • Uses of DataModel in javax.faces.model

      Subclasses of DataModel in javax.faces.model
      Modifier and Type Class and Description
      class  ArrayDataModel<E>
      ArrayDataModel is a convenience implementation of DataModel that wraps an array of Java objects.
      class  CollectionDataModel<E>

      CollectionDataModel is a convenience implementation of DataModel that wraps an Collection of Java objects.
      class  ListDataModel<E>
      ListDataModel is a convenience implementation of DataModel that wraps an List of Java objects.
      class  ResultDataModel
      ResultDataModel is a convenience implementation of DataModel that wraps a JSTL Result object, typically representing the results of executing an SQL query via JSTL tags.
      class  ResultSetDataModel
      ResultSetDataModel is a convenience implementation of DataModel that wraps a ResultSet of Java objects.
      class  ScalarDataModel<E>
      ScalarDataModel is a convenience implementation of DataModel that wraps an individual Java object.
      Methods in javax.faces.model that return DataModel
      Modifier and Type Method and Description
      DataModel DataModelEvent.getDataModel()
      Return the DataModel that fired this event.
      Constructors in javax.faces.model with parameters of type DataModel
      Constructor and Description
      DataModelEvent(DataModel model, int index, Object data)
      Construct an event object that is associated with the specified row index and associated data.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.model.DataModelEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.model.DataModelEvent

  • Packages that use DataModelEvent
    Package Description
    javax.faces.model
    Standard model data beans for JavaServer Faces.

    • Uses of DataModelEvent in javax.faces.model

      Methods in javax.faces.model with parameters of type DataModelEvent
      Modifier and Type Method and Description
      void DataModelListener.rowSelected(DataModelEvent event)
      Notification that a particular row index, with the associated row data, has been selected for processing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.model.ListDataModel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.model.ListDataModel

No usage of javax.faces.model.ListDataModel
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.model.ResultDataModel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.model.ResultDataModel

No usage of javax.faces.model.ResultDataModel
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.model.ResultSetDataModel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.model.ResultSetDataModel

No usage of javax.faces.model.ResultSetDataModel
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.model.ScalarDataModel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.model.ScalarDataModel

No usage of javax.faces.model.ScalarDataModel
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.model.SelectItem (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.model.SelectItem

  • Packages that use SelectItem
    Package Description
    javax.faces.model
    Standard model data beans for JavaServer Faces.

    • Uses of SelectItem in javax.faces.model

      Subclasses of SelectItem in javax.faces.model
      Modifier and Type Class and Description
      class  SelectItemGroup
      SelectItemGroup is a subclass of SelectItem that identifies a set of options that will be made available as a subordinate "submenu" or "options list", depending upon the requirements of the UISelectMany or UISelectOne renderer that is actually used.
      Methods in javax.faces.model that return SelectItem
      Modifier and Type Method and Description
      SelectItem[] SelectItemGroup.getSelectItems()
      Return the set of subordinate SelectItems for this group.
      Methods in javax.faces.model with parameters of type SelectItem
      Modifier and Type Method and Description
      void SelectItemGroup.setSelectItems(SelectItem[] selectItems)
      Set the set of subordinate SelectItems for this group.
      Constructors in javax.faces.model with parameters of type SelectItem
      Constructor and Description
      SelectItemGroup(String label, String description, boolean disabled, SelectItem[] selectItems)
      Construct a SelectItemGroup with the specified properties.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.model.SelectItemGroup (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.model.SelectItemGroup

No usage of javax.faces.model.SelectItemGroup
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.model.DataModelListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.model.DataModelListener

  • Packages that use DataModelListener
    Package Description
    javax.faces.model
    Standard model data beans for JavaServer Faces.

    • Uses of DataModelListener in javax.faces.model

      Methods in javax.faces.model that return DataModelListener
      Modifier and Type Method and Description
      DataModelListener[] DataModel.getDataModelListeners()
      Return the set of DataModelListeners interested in notifications from this DataModel.
      Methods in javax.faces.model with parameters of type DataModelListener
      Modifier and Type Method and Description
      void DataModel.addDataModelListener(DataModelListener listener)
      Add a new DataModelListener to the set interested in notifications from this DataModel.
      void DataModel.removeDataModelListener(DataModelListener listener)
      Remove an existing DataModelListener from the set interested in notifications from this DataModel.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ClientBehaviorRenderer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.render

Class ClientBehaviorRenderer

  • java.lang.Object
    • javax.faces.render.ClientBehaviorRenderer

  • public abstract class ClientBehaviorRenderer
extends Object

    A ClientBehaviorRenderer produces the client-side script that implements a ClientBehavior's client-side logic. It can also enqueue server-side BehaviorEvents that may be processed later by event listeners that have registered an interest.

    Individual ClientBehaviorRenderer instances will be instantiated as requested during the rendering process, and will remain in existence for the remainder of the lifetime of a web application. Because each instance may be invoked from more than one request processing thread simultaneously, they MUST be programmed in a thread-safe manner.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ClientBehaviorRenderer()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void decode(FacesContext context, UIComponent component, ClientBehavior behavior)

      Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.
      String getScript(ClientBehaviorContext behaviorContext, ClientBehavior behavior)

      Return the script that implements this ClientBehavior's client-side logic.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ClientBehaviorRenderer

        public ClientBehaviorRenderer()

    • Method Detail

      • getScript

        public String getScript(ClientBehaviorContext behaviorContext,
               ClientBehavior behavior)

        Return the script that implements this ClientBehavior's client-side logic. The default implementation returns null.

        ClientBehaviorRenderer.getScript() implementations are allowed to return null to indicate that no script is required for this particular getScript() call. For example, a ClientBehaviorRenderer implementation may return null if the associated ClientBehavior is disabled.

        Parameters:
        behaviorContext - the ClientBehaviorContext that provides properties that might influence this getScript() call. Note that ClientBehaviorContext instances are short-lived objects that are only valid for the duration of the call to getScript(). ClientBehaviorRenderer implementations must not hold onto references to ClientBehaviorContexts.
        behavior - the ClientBehavior instance that generates script.
        Returns:
        script that provides the client-side behavior, or null if no script is required.
        Since:
        2.0

      • decode

        public void decode(FacesContext context,
          UIComponent component,
          ClientBehavior behavior)

        Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.

        During decoding, events may be enqueued for later processing (by event listeners who have registered an interest), by calling queueEvent().

        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent the component associated with this Behavior
        behavior - ClientBehavior the behavior instance
        Throws:
        NullPointerException - if context, component behavior is null
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesBehaviorRenderer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.render

Annotation Type FacesBehaviorRenderer

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface FacesBehaviorRenderer

    The presence of this annotation on a class automatically registers the class with the runtime as a ClientBehaviorRenderer. The value of the renderKitId() attribute is taken to be the render-kit-id to which an instance of this Renderer is to be added. There must be a public zero-argument constructor on any class where this annotation appears. The implementation must indicate a fatal error if such a constructor does not exist and the application must not be placed in service. Within that RenderKit, The value of the rendererType() attribute is taken to be the renderer-type The implementation must guarantee that for each class annotated with FacesBehaviorRenderer, found with the algorithm in section JSF.11.5, the following actions are taken.

    • Obtain a reference to the RenderKitFactory for this application.

    • See if a RenderKit exists for render-kit-id. If so, let that instance be renderKit for discussion. If not, the implementation must indicate a fatal error if such a RenderKit does not exist and the application must not be placed in service.

    • Create an instance of this class using the public zero-argument constructor.

    • Call RenderKit.addClientBehaviorRenderer(java.lang.String, javax.faces.render.ClientBehaviorRenderer) on renderKit, passing type as the first argument, and a ClientBehaviorRenderer instance as the second argument.

    Since:
    2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String rendererType

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String renderKitId

      The value of this annotation attribute is taken to be the render-kit-id in which an instance of this class of Renderer must be installed.

    • Element Detail

      • rendererType

        public abstract String rendererType

      • renderKitId

        public abstract String renderKitId

        The value of this annotation attribute is taken to be the render-kit-id in which an instance of this class of Renderer must be installed.

        Since:
        2.0
        Default:
        "HTML_BASIC"
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


FacesRenderer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.render

Annotation Type FacesRenderer

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface FacesRenderer

    The presence of this annotation on a class automatically registers the class with the runtime as a Renderer. The value of the renderKitId() attribute is taken to be the render-kit-id to which an instance of this Renderer is to be added. There must be a public zero-argument constructor on any class where this annotation appears. The implementation must indicate a fatal error if such a constructor does not exist and the application must not be placed in service. Within that RenderKit, The value of the rendererType() attribute is taken to be the renderer-type, and the value of the componentFamily() attribute is to be taken as the component-family. The implementation must guarantee that for each class annotated with FacesRenderer, found with the algorithm in section JSF.11.5, the following actions are taken.

    • Obtain a reference to the RenderKitFactory for this application.

    • See if a RenderKit exists for render-kit-id. If so, let that instance be renderKit for discussion. If not, the implementation must indicate a fatal error if such a RenderKit does not exist and the application must not be placed in service.

    • Create an instance of this class using the public zero-argument constructor.

    • Call RenderKit.addRenderer(java.lang.String, java.lang.String, javax.faces.render.Renderer) on renderKit, passing component-family as the first argument, renderer-type as the second, and the newly instantiated RenderKit instance as the third argument.

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String componentFamily

      The value of this annotation attribute is taken to be the component-family which, in combination with rendererType() can be used to obtain a reference to an instance of this Renderer by calling RenderKit.getRenderer(java.lang.String, java.lang.String).
      String rendererType

      The value of this annotation attribute is taken to be the renderer-type which, in combination with componentFamily() can be used to obtain a reference to an instance of this Renderer by calling RenderKit.getRenderer(java.lang.String, java.lang.String).

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String renderKitId

      The value of this annotation attribute is taken to be the render-kit-id in which an instance of this class of Renderer must be installed.

    • Element Detail

      • rendererType

        public abstract String rendererType

        The value of this annotation attribute is taken to be the renderer-type which, in combination with componentFamily() can be used to obtain a reference to an instance of this Renderer by calling RenderKit.getRenderer(java.lang.String, java.lang.String).

      • componentFamily

        public abstract String componentFamily

        The value of this annotation attribute is taken to be the component-family which, in combination with rendererType() can be used to obtain a reference to an instance of this Renderer by calling RenderKit.getRenderer(java.lang.String, java.lang.String).

      • renderKitId

        public abstract String renderKitId

        The value of this annotation attribute is taken to be the render-kit-id in which an instance of this class of Renderer must be installed.

        Default:
        "HTML_BASIC"
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.faces.render (Java(TM) EE 7 Specification APIs)

javax.faces.render

Classes

  • ClientBehaviorRenderer
  • Renderer
  • RendererWrapper
  • RenderKit
  • RenderKitFactory
  • RenderKitWrapper
  • ResponseStateManager

Annotation Types

  • FacesBehaviorRenderer
  • FacesRenderer


javax.faces.render (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.render

Classes and interfaces defining the rendering model.

See: Description

  • Class Summary
    Class Description
    ClientBehaviorRenderer
    A ClientBehaviorRenderer produces the client-side script that implements a ClientBehavior's client-side logic.
    Renderer
    A Renderer converts the internal representation of UIComponents into the output stream (or writer) associated with the response we are creating for a particular request.
    RendererWrapper

    Provides a simple implementation of Renderer that can be subclassed by developers wishing to provide specialized behavior to an existing Renderer instance.
    RenderKit
    RenderKit represents a collection of Renderer instances that, together, know how to render JavaServer Faces UIComponent instances for a specific client.
    RenderKitFactory
    RenderKitFactory is a factory object that registers and returns RenderKit instances.
    RenderKitWrapper

    Provides a simple implementation of RenderKit that can be subclassed by developers wishing to provide specialized behavior to an existing RenderKit instance.
    ResponseStateManager
    ResponseStateManager is the helper class to StateManager that knows the specific rendering technology being used to generate the response.
  • Annotation Types Summary
    Annotation Type Description
    FacesBehaviorRenderer

    The presence of this annotation on a class automatically registers the class with the runtime as a ClientBehaviorRenderer.
    FacesRenderer

    The presence of this annotation on a class automatically registers the class with the runtime as a Renderer.

Package javax.faces.render Description

Classes and interfaces defining the rendering model. The main class in this package is RenderKit. RenderKit vends a set of Renderer instances which provide rendering capability for a specific client device type.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.render Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.render

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.render.ClientBehaviorRenderer
    • javax.faces.render.Renderer
      • javax.faces.render.RendererWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.render.RenderKit
      • javax.faces.render.RenderKitWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.render.RenderKitFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.render.ResponseStateManager

Annotation Type Hierarchy

  • javax.faces.render.FacesRenderer (implements java.lang.annotation.Annotation)
  • javax.faces.render.FacesBehaviorRenderer (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Renderer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.render

Class Renderer

  • java.lang.Object
    • javax.faces.render.Renderer
  • Direct Known Subclasses:
    RendererWrapper

    public abstract class Renderer
extends Object

    A Renderer converts the internal representation of UIComponents into the output stream (or writer) associated with the response we are creating for a particular request. Each Renderer knows how to render one or more UIComponent types (or classes), and advertises a set of render-dependent attributes that it recognizes for each supported UIComponent.

    Families of Renderers are packaged as a RenderKit, and together support the rendering of all of the UIComponents in a view associated with a FacesContext. Within the set of Renderers for a particular RenderKit, each must be uniquely identified by the rendererType property.

    Individual Renderer instances will be instantiated as requested during the rendering process, and will remain in existence for the remainder of the lifetime of a web application. Because each instance may be invoked from more than one request processing thread simultaneously, they MUST be programmed in a thread-safe manner.

    If the ListenerFor annotation is attached to the class definition of a Renderer, that class must also implement ComponentSystemEventListener, and the action pertaining to the processing of ResourceDependency on a Renderer described in ListenerFor must be taken.

    If the ResourceDependency annotation is attached to the class definition of a Renderer, the action pertaining to the processing of ResourceDependency on a Renderer described in UIComponent.getChildren() must be taken.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String PASSTHROUGH_RENDERER_LOCALNAME_KEY

      The key in the component passthrough attributes Map for the localName of the element corresponding to the component.

    • Constructor Summary

      Constructors
      Constructor and Description
      Renderer()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String convertClientId(FacesContext context, String clientId)
      Convert the component generated client id to a form suitable for transmission to the client.
      void decode(FacesContext context, UIComponent component)
      Decode any new state of the specified UIComponent from the request contained in the specified FacesContext, and store that state on the UIComponent.
      void encodeBegin(FacesContext context, UIComponent component)
      Render the beginning specified UIComponent to the output stream or writer associated with the response we are creating.
      void encodeChildren(FacesContext context, UIComponent component)
      Render the child components of this UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
      void encodeEnd(FacesContext context, UIComponent component)
      Render the ending of the current state of the specified UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
      Object getConvertedValue(FacesContext context, UIComponent component, Object submittedValue)
      Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one).
      boolean getRendersChildren()
      Return a flag indicating whether this Renderer is responsible for rendering the children the component it is asked to render.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • PASSTHROUGH_RENDERER_LOCALNAME_KEY

        public static final String PASSTHROUGH_RENDERER_LOCALNAME_KEY

        The key in the component passthrough attributes Map for the localName of the element corresponding to the component.

        Since:
        2.2
        See Also:
        Constant Field Values

    • Constructor Detail

      • Renderer

        public Renderer()

    • Method Detail

      • decode

        public void decode(FacesContext context,
          UIComponent component)

        Decode any new state of the specified UIComponent from the request contained in the specified FacesContext, and store that state on the UIComponent.

        During decoding, events may be enqueued for later processing (by event listeners that have registered an interest), by calling queueEvent() on the associated UIComponent.

        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent to be decoded.
        Throws:
        NullPointerException - if context or component is null

      • encodeBegin

        public void encodeBegin(FacesContext context,
               UIComponent component)
                 throws IOException

        Render the beginning specified UIComponent to the output stream or writer associated with the response we are creating. If the conversion attempted in a previous call to getConvertedValue() for this component failed, the state information saved during execution of decode() should be used to reproduce the incorrect input.

        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent to be rendered
        Throws:
        IOException - if an input/output error occurs while rendering
        NullPointerException - if context or component is null

      • encodeChildren

        public void encodeChildren(FacesContext context,
                  UIComponent component)
                    throws IOException

        Render the child components of this UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered. This method will only be called if the rendersChildren property of this component is true.

        Parameters:
        context - FacesContext for the response we are creating
        component - UIComponent whose children are to be rendered
        Throws:
        IOException - if an input/output error occurs while rendering
        NullPointerException - if context or component is null

      • encodeEnd

        public void encodeEnd(FacesContext context,
             UIComponent component)
               throws IOException

        Render the ending of the current state of the specified UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.

        Parameters:
        context - FacesContext for the response we are creating
        component - UIComponent to be rendered
        Throws:
        IOException - if an input/output error occurs while rendering
        NullPointerException - if context or component is null

      • convertClientId

        public String convertClientId(FacesContext context,
                     String clientId)

        Convert the component generated client id to a form suitable for transmission to the client.

        The default implementation returns the argument clientId unchanged.

        Parameters:
        context - FacesContext for the current request
        clientId - the client identifier to be converted to client a specific format.
        Throws:
        NullPointerException - if context or clientId is null

      • getRendersChildren

        public boolean getRendersChildren()

        Return a flag indicating whether this Renderer is responsible for rendering the children the component it is asked to render. The default implementation returns false.

      • getConvertedValue

        public Object getConvertedValue(FacesContext context,
                       UIComponent component,
                       Object submittedValue)
                         throws ConverterException

        Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one). If conversion is successful, the new value should be returned from this method; if not, a ConverterException should be thrown.

        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent to be decoded.
        submittedValue - a value stored on the component during decode.
        Throws:
        ConverterException - if the submitted value cannot be converted successfully.
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RendererWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.render

Class RendererWrapper

  • java.lang.Object
    • javax.faces.render.Renderer
      • javax.faces.render.RendererWrapper
  • All Implemented Interfaces:
    FacesWrapper<Renderer>

    public abstract class RendererWrapper
extends Renderer
implements FacesWrapper<Renderer>

    Provides a simple implementation of Renderer that can be subclassed by developers wishing to provide specialized behavior to an existing Renderer instance. The default implementation of all methods is to call through to the wrapped Renderer instance.

    Usage: extend this class and override getWrapped() to return the instance being wrapping.

    Since:
    2.2

    • Field Summary

      • Fields inherited from class javax.faces.render.Renderer

        PASSTHROUGH_RENDERER_LOCALNAME_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      RendererWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String convertClientId(FacesContext context, String clientId)
      Convert the component generated client id to a form suitable for transmission to the client.
      void decode(FacesContext context, UIComponent component)
      Decode any new state of the specified UIComponent from the request contained in the specified FacesContext, and store that state on the UIComponent.
      void encodeBegin(FacesContext context, UIComponent component)
      Render the beginning specified UIComponent to the output stream or writer associated with the response we are creating.
      void encodeChildren(FacesContext context, UIComponent component)
      Render the child components of this UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
      void encodeEnd(FacesContext context, UIComponent component)
      Render the ending of the current state of the specified UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
      Object getConvertedValue(FacesContext context, UIComponent component, Object submittedValue)
      Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one).
      boolean getRendersChildren()
      Return a flag indicating whether this Renderer is responsible for rendering the children the component it is asked to render.
      abstract Renderer getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • RendererWrapper

        public RendererWrapper()

    • Method Detail

      • getWrapped

        public abstract Renderer getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<Renderer>
        Returns:
        the instance we are wrapping

      • convertClientId

        public String convertClientId(FacesContext context,
                     String clientId)
        Description copied from class: Renderer

        Convert the component generated client id to a form suitable for transmission to the client.

        The default implementation returns the argument clientId unchanged.

        Overrides:
        convertClientId in class Renderer
        Parameters:
        context - FacesContext for the current request
        clientId - the client identifier to be converted to client a specific format.

      • getConvertedValue

        public Object getConvertedValue(FacesContext context,
                       UIComponent component,
                       Object submittedValue)
                         throws ConverterException
        Description copied from class: Renderer

        Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one). If conversion is successful, the new value should be returned from this method; if not, a ConverterException should be thrown.

        Overrides:
        getConvertedValue in class Renderer
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent to be decoded.
        submittedValue - a value stored on the component during decode.
        Throws:
        ConverterException - if the submitted value cannot be converted successfully.

      • decode

        public void decode(FacesContext context,
          UIComponent component)
        Description copied from class: Renderer

        Decode any new state of the specified UIComponent from the request contained in the specified FacesContext, and store that state on the UIComponent.

        During decoding, events may be enqueued for later processing (by event listeners that have registered an interest), by calling queueEvent() on the associated UIComponent.

        Overrides:
        decode in class Renderer
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent to be decoded.

      • encodeBegin

        public void encodeBegin(FacesContext context,
               UIComponent component)
                 throws IOException
        Description copied from class: Renderer

        Render the beginning specified UIComponent to the output stream or writer associated with the response we are creating. If the conversion attempted in a previous call to getConvertedValue() for this component failed, the state information saved during execution of decode() should be used to reproduce the incorrect input.

        Overrides:
        encodeBegin in class Renderer
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent to be rendered
        Throws:
        IOException - if an input/output error occurs while rendering

      • encodeChildren

        public void encodeChildren(FacesContext context,
                  UIComponent component)
                    throws IOException
        Description copied from class: Renderer

        Render the child components of this UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered. This method will only be called if the rendersChildren property of this component is true.

        Overrides:
        encodeChildren in class Renderer
        Parameters:
        context - FacesContext for the response we are creating
        component - UIComponent whose children are to be rendered
        Throws:
        IOException - if an input/output error occurs while rendering

      • encodeEnd

        public void encodeEnd(FacesContext context,
             UIComponent component)
               throws IOException
        Description copied from class: Renderer

        Render the ending of the current state of the specified UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.

        Overrides:
        encodeEnd in class Renderer
        Parameters:
        context - FacesContext for the response we are creating
        component - UIComponent to be rendered
        Throws:
        IOException - if an input/output error occurs while rendering

      • getRendersChildren

        public boolean getRendersChildren()
        Description copied from class: Renderer

        Return a flag indicating whether this Renderer is responsible for rendering the children the component it is asked to render. The default implementation returns false.

        Overrides:
        getRendersChildren in class Renderer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RenderKit (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.render

Class RenderKit

  • java.lang.Object
    • javax.faces.render.RenderKit
  • Direct Known Subclasses:
    RenderKitWrapper

    public abstract class RenderKit
extends Object

    RenderKit represents a collection of Renderer instances that, together, know how to render JavaServer Faces UIComponent instances for a specific client. Typically, RenderKits are specialized for some combination of client device type, markup language, and/or user Locale. A RenderKit also acts as a Factory for associated Renderer instances, which perform the actual rendering process for each component.

    A typical JavaServer Faces implementation will configure one or more RenderKit instances at web application startup. They are made available through calls to the getRenderKit() methods of RenderKitFactory. Because RenderKit instances are shared, they must be implemented in a thread-safe manner. Due to limitations in the current specification having multiple RenderKit instances at play in the same application requires a custom ViewHandler instance that is aware of how to deal with this case. This limitation will be lifted in a future version of the spec.

    The RenderKit instance must also vend a ResponseStateManager instance, which is used in the process of saving and restoring tree structure and state.

    • Constructor Summary

      Constructors
      Constructor and Description
      RenderKit()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addClientBehaviorRenderer(String type, ClientBehaviorRenderer renderer)
      Register the specified ClientBehaviorRenderer instance, associated with the specified component type, to the set of ClientBehaviorRenderers registered with this RenderKit, replacing any previously registered ClientBehaviorRenderer for this type.
      abstract void addRenderer(String family, String rendererType, Renderer renderer)
      Register the specified Renderer instance, associated with the specified component family and rendererType, to the set of Renderers registered with this RenderKit, replacing any previously registered Renderer for this combination of identifiers.
      abstract ResponseStream createResponseStream(OutputStream out)
      Use the provided OutputStream to create a new ResponseStream instance.
      abstract ResponseWriter createResponseWriter(Writer writer, String contentTypeList, String characterEncoding)
      Use the provided Writer to create a new ResponseWriter instance for the specified (optional) content type, and character encoding.
      ClientBehaviorRenderer getClientBehaviorRenderer(String type)
      Return the ClientBehaviorRenderer instance most recently registered for the specified type, if any; otherwise, return null.
      Iterator<String> getClientBehaviorRendererTypes()

      Return an Iterator over the ClientBehaviorRenderer types.
      Iterator<String> getComponentFamilies()

      Return an Iterator over the component-family entries supported by this RenderKit instance.
      abstract Renderer getRenderer(String family, String rendererType)
      Return the Renderer instance most recently registered for the specified component family and rendererType, if any; otherwise, return null.
      Iterator<String> getRendererTypes(String componentFamily)

      Return an Iterator over the renderer-type entries for the given component-family.
      abstract ResponseStateManager getResponseStateManager()
      Return an instance of ResponseStateManager to handle rendering technology specific state management decisions.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • RenderKit

        public RenderKit()

    • Method Detail

      • addRenderer

        public abstract void addRenderer(String family,
               String rendererType,
               Renderer renderer)

        Register the specified Renderer instance, associated with the specified component family and rendererType, to the set of Renderers registered with this RenderKit, replacing any previously registered Renderer for this combination of identifiers.

        Parameters:
        family - Component family of the Renderer to register
        rendererType - Renderer type of the Renderer to register
        renderer - Renderer instance we are registering
        Throws:
        NullPointerException - if family or rendererType or renderer is null

      • getRenderer

        public abstract Renderer getRenderer(String family,
                   String rendererType)

        Return the Renderer instance most recently registered for the specified component family and rendererType, if any; otherwise, return null.

        Parameters:
        family - Component family of the requested Renderer instance
        rendererType - Renderer type of the requested Renderer instance
        Throws:
        NullPointerException - if family or rendererType is null

      • getResponseStateManager

        public abstract ResponseStateManager getResponseStateManager()

        Return an instance of ResponseStateManager to handle rendering technology specific state management decisions.

      • createResponseWriter

        public abstract ResponseWriter createResponseWriter(Writer writer,
                                  String contentTypeList,
                                  String characterEncoding)

        Use the provided Writer to create a new ResponseWriter instance for the specified (optional) content type, and character encoding.

        Implementors are advised to consult the getCharacterEncoding() method of class ServletResponse to get the required value for the characterEncoding for this method. Since the Writer for this response will already have been obtained (due to it ultimately being passed to this method), we know that the character encoding cannot change during the rendering of the response.

        Parameters:
        writer - the Writer around which this ResponseWriter must be built.
        contentTypeList - an "Accept header style" list of content types for this response, or null if the RenderKit should choose the best fit. As of the current version, the values accepted by the Standard render-kit for this parameter include any valid "Accept header style" String that includes the String text/html, application/xhtml+xml, application/xml or text/xml. This may change in a future version. The RenderKit must support a value for this argument that comes straight from the Accept HTTP header, and therefore requires parsing according to the specification of the Accept header. Please see Section 14.1 of RFC 2616 for the specification of the Accept header.
        characterEncoding - such as "ISO-8859-1" for this ResponseWriter, or null if the RenderKit should choose the best fit. Please see the IANA for a list of character encodings.
        Returns:
        a new ResponseWriter.
        Throws:
        IllegalArgumentException - if no matching content type can be found in contentTypeList, no appropriate content type can be found with the implementation dependent best fit algorithm, or no matching character encoding can be found for the argument characterEncoding.

      • createResponseStream

        public abstract ResponseStream createResponseStream(OutputStream out)

        Use the provided OutputStream to create a new ResponseStream instance.

      • getComponentFamilies

        public Iterator<String> getComponentFamilies()

        Return an Iterator over the component-family entries supported by this RenderKit instance.

        The default implementation of this method returns an empty Iterator

        Since:
        2.0

      • getRendererTypes

        public Iterator<String> getRendererTypes(String componentFamily)

        Return an Iterator over the renderer-type entries for the given component-family.

        If the specified componentFamily is not known to this RenderKit implementation, return an empty Iterator

        The default implementation of this method returns an empty Iterator

        Parameters:
        componentFamily - one of the members of the Iterator returned by getComponentFamilies().
        Since:
        2.0

      • addClientBehaviorRenderer

        public void addClientBehaviorRenderer(String type,
                             ClientBehaviorRenderer renderer)

        Register the specified ClientBehaviorRenderer instance, associated with the specified component type, to the set of ClientBehaviorRenderers registered with this RenderKit, replacing any previously registered ClientBehaviorRenderer for this type.

        Parameters:
        type - type of the ClientBehaviorRenderer to register
        renderer - ClientBehaviorRenderer instance we are registering
        Throws:
        NullPointerException - if type or renderer is null
        Since:
        2.0

      • getClientBehaviorRenderer

        public ClientBehaviorRenderer getClientBehaviorRenderer(String type)

        Return the ClientBehaviorRenderer instance most recently registered for the specified type, if any; otherwise, return null.

        Parameters:
        type - type of the requested ClientBehaviorRenderer instance
        Throws:
        NullPointerException - if type is null
        Since:
        2.0

      • getClientBehaviorRendererTypes

        public Iterator<String> getClientBehaviorRendererTypes()

        Return an Iterator over the ClientBehaviorRenderer types.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RenderKitFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.render

Class RenderKitFactory

  • java.lang.Object
    • javax.faces.render.RenderKitFactory
  • All Implemented Interfaces:
    FacesWrapper<RenderKitFactory>

    public abstract class RenderKitFactory
extends Object
implements FacesWrapper<RenderKitFactory>

    RenderKitFactory is a factory object that registers and returns RenderKit instances. Implementations of JavaServer Faces must provide at least a default implementation of RenderKit. Advanced implementations (or external third party libraries) may provide additional RenderKit implementations (keyed by render kit identifiers) for performing different types of rendering for the same components.

    There must be one RenderKitFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

       RenderKitFactory factory = (RenderKitFactory)
    FactoryFinder.getFactory(FactoryFinder.RENDER_KIT_FACTORY);

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String HTML_BASIC_RENDER_KIT
      The render kit identifier of the default RenderKit instance for this JavaServer Faces implementation.

    • Constructor Summary

      Constructors
      Constructor and Description
      RenderKitFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addRenderKit(String renderKitId, RenderKit renderKit)
      Register the specified RenderKit instance, associated with the specified renderKitId, to be supported by this RenderKitFactory, replacing any previously registered RenderKit for this identifier.
      abstract RenderKit getRenderKit(FacesContext context, String renderKitId)
      Return a RenderKit instance for the specified render kit identifier, possibly customized based on dynamic characteristics of the specified FacesContext, if non-null.
      abstract Iterator<String> getRenderKitIds()
      Return an Iterator over the set of render kit identifiers registered with this factory.
      RenderKitFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • HTML_BASIC_RENDER_KIT

        public static final String HTML_BASIC_RENDER_KIT

        The render kit identifier of the default RenderKit instance for this JavaServer Faces implementation.

        See Also:
        Constant Field Values

    • Constructor Detail

      • RenderKitFactory

        public RenderKitFactory()

    • Method Detail

      • getWrapped

        public RenderKitFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<RenderKitFactory>
        Since:
        2.0

      • addRenderKit

        public abstract void addRenderKit(String renderKitId,
                RenderKit renderKit)

        Register the specified RenderKit instance, associated with the specified renderKitId, to be supported by this RenderKitFactory, replacing any previously registered RenderKit for this identifier.

        Parameters:
        renderKitId - Identifier of the RenderKit to register
        renderKit - RenderKit instance that we are registering
        Throws:
        NullPointerException - if renderKitId or renderKit is null

      • getRenderKit

        public abstract RenderKit getRenderKit(FacesContext context,
                     String renderKitId)

        Return a RenderKit instance for the specified render kit identifier, possibly customized based on dynamic characteristics of the specified FacesContext, if non-null. If there is no registered RenderKit for the specified identifier, return null. The set of available render kit identifiers is available via the getRenderKitIds() method.

        Parameters:
        context - FacesContext for the request currently being processed, or null if none is available.
        renderKitId - Render kit identifier of the requested RenderKit instance
        Throws:
        IllegalArgumentException - if no RenderKit instance can be returned for the specified identifier
        NullPointerException - if renderKitId is null

      • getRenderKitIds

        public abstract Iterator<String> getRenderKitIds()

        Return an Iterator over the set of render kit identifiers registered with this factory. This set must include the value specified by RenderKitFactory.HTML_BASIC_RENDER_KIT.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RenderKitWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.render

Class RenderKitWrapper

  • java.lang.Object
    • javax.faces.render.RenderKit
      • javax.faces.render.RenderKitWrapper
  • All Implemented Interfaces:
    FacesWrapper<RenderKit>

    public abstract class RenderKitWrapper
extends RenderKit
implements FacesWrapper<RenderKit>

    Provides a simple implementation of RenderKit that can be subclassed by developers wishing to provide specialized behavior to an existing RenderKit instance. The default implementation of all methods is to call through to the wrapped RenderKit.

    Usage: extend this class and override getWrapped() to return the instance we are wrapping.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      RenderKitWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addClientBehaviorRenderer(String type, ClientBehaviorRenderer renderer)
      The default behavior of this method is to call RenderKit.addClientBehaviorRenderer(String, ClientBehaviorRenderer) on the wrapped RenderKit object.
      void addRenderer(String family, String rendererType, Renderer renderer)
      The default behavior of this method is to call RenderKit.addRenderer(String, String, Renderer) on the wrapped RenderKit object.
      ResponseStream createResponseStream(OutputStream out)
      The default behavior of this method is to call RenderKit.createResponseStream(java.io.OutputStream) on the wrapped RenderKit object.
      ResponseWriter createResponseWriter(Writer writer, String contentTypeList, String characterEncoding)
      The default behavior of this method is to call RenderKit.createResponseWriter(java.io.Writer, String, String) on the wrapped RenderKit object.
      ClientBehaviorRenderer getClientBehaviorRenderer(String type)
      The default behavior of this method is to call RenderKit.getClientBehaviorRenderer(String) on the wrapped RenderKit object.
      Iterator<String> getClientBehaviorRendererTypes()
      The default behavior of this method is to call RenderKit.getClientBehaviorRendererTypes() on the wrapped RenderKit object.
      Iterator<String> getComponentFamilies()
      The default behavior of this method is to call RenderKit.getComponentFamilies() on the wrapped RenderKit object.
      Renderer getRenderer(String family, String rendererType)
      The default behavior of this method is to call RenderKit.getRenderer(String, String) on the wrapped RenderKit object.
      Iterator<String> getRendererTypes(String componentFamily)
      The default behavior of this method is to call RenderKit.getRendererTypes(String) on the wrapped RenderKit object.
      ResponseStateManager getResponseStateManager()
      The default behavior of this method is to call RenderKit.getResponseStateManager() on the wrapped RenderKit object.
      abstract RenderKit getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • RenderKitWrapper

        public RenderKitWrapper()

    • Method Detail

      • getWrapped

        public abstract RenderKit getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<RenderKit>
        Returns:
        the wrapped RenderKit instance
        See Also:
        FacesWrapper.getWrapped()

      • addRenderer

        public void addRenderer(String family,
               String rendererType,
               Renderer renderer)

        The default behavior of this method is to call RenderKit.addRenderer(String, String, Renderer) on the wrapped RenderKit object.

        Specified by:
        addRenderer in class RenderKit
        Parameters:
        family - Component family of the Renderer to register
        rendererType - Renderer type of the Renderer to register
        renderer - Renderer instance we are registering
        See Also:
        RenderKit.addRenderer(String, String, Renderer)

      • createResponseStream

        public ResponseStream createResponseStream(OutputStream out)

        The default behavior of this method is to call RenderKit.createResponseStream(java.io.OutputStream) on the wrapped RenderKit object.

        Specified by:
        createResponseStream in class RenderKit
        See Also:
        RenderKit.createResponseStream(java.io.OutputStream)

      • createResponseWriter

        public ResponseWriter createResponseWriter(Writer writer,
                                  String contentTypeList,
                                  String characterEncoding)

        The default behavior of this method is to call RenderKit.createResponseWriter(java.io.Writer, String, String) on the wrapped RenderKit object.

        Specified by:
        createResponseWriter in class RenderKit
        Parameters:
        writer - the Writer around which this ResponseWriter must be built.
        contentTypeList - an "Accept header style" list of content types for this response, or null if the RenderKit should choose the best fit. As of the current version, the values accepted by the Standard render-kit for this parameter include any valid "Accept header style" String that includes the String text/html, application/xhtml+xml, application/xml or text/xml. This may change in a future version. The RenderKit must support a value for this argument that comes straight from the Accept HTTP header, and therefore requires parsing according to the specification of the Accept header. Please see Section 14.1 of RFC 2616 for the specification of the Accept header.
        characterEncoding - such as "ISO-8859-1" for this ResponseWriter, or null if the RenderKit should choose the best fit. Please see the IANA for a list of character encodings.
        Returns:
        a new ResponseWriter.
        See Also:
        RenderKit.createResponseWriter(java.io.Writer, String, String)

      • getRenderer

        public Renderer getRenderer(String family,
                   String rendererType)

        The default behavior of this method is to call RenderKit.getRenderer(String, String) on the wrapped RenderKit object.

        Specified by:
        getRenderer in class RenderKit
        Parameters:
        family - Component family of the requested Renderer instance
        rendererType - Renderer type of the requested Renderer instance
        See Also:
        RenderKit.getRenderer(String, String)

      • getResponseStateManager

        public ResponseStateManager getResponseStateManager()

        The default behavior of this method is to call RenderKit.getResponseStateManager() on the wrapped RenderKit object.

        Specified by:
        getResponseStateManager in class RenderKit
        See Also:
        RenderKit.getResponseStateManager()

      • getComponentFamilies

        public Iterator<String> getComponentFamilies()

        The default behavior of this method is to call RenderKit.getComponentFamilies() on the wrapped RenderKit object.

        Overrides:
        getComponentFamilies in class RenderKit
        See Also:
        RenderKit.getComponentFamilies()

      • getRendererTypes

        public Iterator<String> getRendererTypes(String componentFamily)

        The default behavior of this method is to call RenderKit.getRendererTypes(String) on the wrapped RenderKit object.

        Overrides:
        getRendererTypes in class RenderKit
        Parameters:
        componentFamily - one of the members of the Iterator returned by RenderKit.getComponentFamilies().
        See Also:
        RenderKit.getRendererTypes(String)

      • addClientBehaviorRenderer

        public void addClientBehaviorRenderer(String type,
                             ClientBehaviorRenderer renderer)

        The default behavior of this method is to call RenderKit.addClientBehaviorRenderer(String, ClientBehaviorRenderer) on the wrapped RenderKit object.

        Overrides:
        addClientBehaviorRenderer in class RenderKit
        Parameters:
        type - type of the ClientBehaviorRenderer to register
        renderer - ClientBehaviorRenderer instance we are registering
        See Also:
        RenderKit.addClientBehaviorRenderer(String, ClientBehaviorRenderer)

      • getClientBehaviorRenderer

        public ClientBehaviorRenderer getClientBehaviorRenderer(String type)

        The default behavior of this method is to call RenderKit.getClientBehaviorRenderer(String) on the wrapped RenderKit object.

        Overrides:
        getClientBehaviorRenderer in class RenderKit
        Parameters:
        type - type of the requested ClientBehaviorRenderer instance
        See Also:
        RenderKit.getClientBehaviorRenderer(String)

      • getClientBehaviorRendererTypes

        public Iterator<String> getClientBehaviorRendererTypes()

        The default behavior of this method is to call RenderKit.getClientBehaviorRendererTypes() on the wrapped RenderKit object.

        Overrides:
        getClientBehaviorRendererTypes in class RenderKit
        See Also:
        RenderKit.getClientBehaviorRendererTypes()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResponseStateManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.render

Class ResponseStateManager

  • java.lang.Object
    • javax.faces.render.ResponseStateManager

  • public abstract class ResponseStateManager
extends Object

    ResponseStateManager is the helper class to StateManager that knows the specific rendering technology being used to generate the response. It is a singleton abstract class, vended by the RenderKit. This class knows the mechanics of saving state, whether it be in hidden fields, session, or some combination of the two.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CLIENT_WINDOW_PARAM

      The name of the hidden field that refers to the encoded ClientWindow.
      static String CLIENT_WINDOW_URL_PARAM

      The name of the URL query parameter for transmitting the client window id.
      static String NON_POSTBACK_VIEW_TOKEN_PARAM

      The value of this constant is taken to be the name of a request parameter whose value is inspected to verify the safety of an incoming non-postback request with respect to the currently configured Set of protected views for this application.
      static String RENDER_KIT_ID_PARAM
      The name of the request parameter used by the default implementation of ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) to derive a RenderKit ID.
      static String VIEW_STATE_PARAM
      Implementations must use this constant field value as the name of the client parameter in which to save the state between requests.

    • Constructor Summary

      Constructors
      Constructor and Description
      ResponseStateManager()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getComponentStateToRestore(FacesContext context)
      Deprecated.
      This method has been replaced by getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
      String getCryptographicallyStrongTokenFromSession(FacesContext context)

      Compliant implementations must return a cryptographically strong token for use to protect views in this application.
      Object getState(FacesContext context, String viewId)
      The implementation must inspect the current request and return an Object representing the tree structure and component state passed in to a previous invocation of writeState(javax.faces.context.FacesContext,java.lang.Object).
      Object getTreeStructureToRestore(FacesContext context, String viewId)
      Deprecated.
      This method has been replaced by getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
      String getViewState(FacesContext context, Object state)
      Return the specified state as a String without any markup related to the rendering technology supported by this ResponseStateManager.
      boolean isPostback(FacesContext context)
      Return true if the current request is a postback.
      boolean isStateless(FacesContext context, String viewId)

      If the preceding call to writeState(javax.faces.context.FacesContext, java.lang.Object) was stateless, return true.
      void writeState(FacesContext context, Object state)
      Take the argument state and write it into the output using the current ResponseWriter, which must be correctly positioned already.
      void writeState(FacesContext context, StateManager.SerializedView state)
      Deprecated.
      This method has been replaced by writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation creates a two element Object array with the first element being the return from calling StateManager.SerializedView.getStructure(), and the second being the return from StateManager.SerializedView.getState(). It then passes this Object array to writeState(javax.faces.context.FacesContext, java.lang.Object).

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • RENDER_KIT_ID_PARAM

        public static final String RENDER_KIT_ID_PARAM

        The name of the request parameter used by the default implementation of ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) to derive a RenderKit ID.

        See Also:
        Constant Field Values

      • VIEW_STATE_PARAM

        public static final String VIEW_STATE_PARAM

        Implementations must use this constant field value as the name of the client parameter in which to save the state between requests. The id attribute must be a concatenation of the return from UIComponent.getContainerClientId(javax.faces.context.FacesContext), the return from UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext), this constant field value, the separator char, and a number that is guaranteed to be unique with respect to all the other instances of this kind of client parameter in the view.

        It is strongly recommend that implementations guard against cross site scripting attacks by at least making the value of this parameter difficult to predict.

        Since:
        1.2
        See Also:
        Constant Field Values

      • CLIENT_WINDOW_PARAM

        public static final String CLIENT_WINDOW_PARAM

        The name of the hidden field that refers to the encoded ClientWindow. This field is only used if ClientWindow.CLIENT_WINDOW_MODE_PARAM_NAME is not "none". The id attribute must be a concatenation of the return from UIComponent.getContainerClientId(javax.faces.context.FacesContext), the return from UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext), this constant field value, the separator char, and a number that is guaranteed to be unique with respect to all the other instances of this kind of client parameter in the view. The value of this parameter is the return from ClientWindow.getId().

        Since:
        2.2
        See Also:
        Constant Field Values

      • CLIENT_WINDOW_URL_PARAM

        public static final String CLIENT_WINDOW_URL_PARAM

        The name of the URL query parameter for transmitting the client window id. This parameter is only used if ClientWindow.CLIENT_WINDOW_MODE_PARAM_NAME is not "none". The name of the parameter is given by the constant value of this field. The value of this parameter is the return from ClientWindow.getId().

        Since:
        2.2
        See Also:
        Constant Field Values

      • NON_POSTBACK_VIEW_TOKEN_PARAM

        public static final String NON_POSTBACK_VIEW_TOKEN_PARAM

        The value of this constant is taken to be the name of a request parameter whose value is inspected to verify the safety of an incoming non-postback request with respect to the currently configured Set of protected views for this application.

        Since:
        2.2
        See Also:
        Constant Field Values

    • Constructor Detail

      • ResponseStateManager

        public ResponseStateManager()

    • Method Detail

      • writeState

        public void writeState(FacesContext context,
              Object state)
                throws IOException

        Take the argument state and write it into the output using the current ResponseWriter, which must be correctly positioned already.

        Call FacesContext.getViewRoot(). If StateHolder.isTransient() returns true, take implementation specific action so that the following call to isStateless(javax.faces.context.FacesContext, java.lang.String) returns true and return. Otherwise, proceed as follows.

        If the state is to be written out to hidden fields, the implementation must take care to make all necessary character replacements to make the Strings suitable for inclusion as an HTTP request paramater.

        If the state saving method for this application is StateManager.STATE_SAVING_METHOD_CLIENT, the implementation must encrypt the state to be saved to the client in a tamper evident manner.

        If the state saving method for this application is StateManager.STATE_SAVING_METHOD_SERVER, and the current request is an Ajax request PartialViewContext.isAjaxRequest() returns true), use the current view state identifier if it is available (do not generate a new identifier).

        Write out the render kit identifier associated with this ResponseStateManager implementation with the name as the value of the String constant ResponseStateManager.RENDER_KIT_ID_PARAM. The render kit identifier must not be written if:

        • it is the default render kit identifier as returned by Application.getDefaultRenderKitId() or
        • the render kit identfier is the value of javax.faces.render.RenderKitFactory.HTML_BASIC_RENDER_KIT and Application.getDefaultRenderKitId() returns null.

        For backwards compatability with existing ResponseStateManager implementations, the default implementation of this method checks if the argument is an instance of SerializedView. If so, it calls through to writeState(javax.faces.context.FacesContext,javax.faces.application.StateManager.SerializedView). If not, it expects the state to be a two element Object array. It creates an instance of SerializedView and stores the state as the treeStructure, and passes it to writeState(javax.faces.context.FacesContext,javax.faces.application.StateManager.SerializedView).

        The ClientWindow must be written using these steps. Call ExternalContext.getClientWindow(). If the result is null, take no further action regarding the ClientWindow. If the result is non-null, write a hidden field whose name is CLIENT_WINDOW_PARAM and whose id is <VIEW_ROOT_CONTAINER_CLIENT_ID><SEP>javax.faces.ClientWindow<SEP><UNIQUE_PER_VIEW_NUMBER> where <SEP> is the currently configured UINamingContainer.getSeparatorChar(). <VIEW_ROOT_CONTAINER_CLIENT_ID> is the return from UIViewRoot.getContainerClientId() on the view from whence this state originated. <UNIQUE_PER_VIEW_NUMBER> is a number that must be unique within this view, but must not be included in the view state. The value of the field is implementation dependent but must uniquely identify this window within the user's session.

        Parameters:
        context - The FacesContext instance for the current request
        state - The serialized state information previously saved
        Throws:
        IOException - if the state argument is not an array of length 2.
        Since:
        1.2

      • writeState

        public void writeState(FacesContext context,
              StateManager.SerializedView state)
                throws IOException
        Deprecated. This method has been replaced by writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation creates a two element Object array with the first element being the return from calling StateManager.SerializedView.getStructure(), and the second being the return from StateManager.SerializedView.getState(). It then passes this Object array to writeState(javax.faces.context.FacesContext, java.lang.Object).

        Take the argument state and write it into the output using the current ResponseWriter, which must be correctly positioned already.

        If the StateManager.SerializedView is to be written out to hidden fields, the implementation must take care to make all necessary character replacements to make the Strings suitable for inclusion as an HTTP request paramater.

        If the state saving method for this application is StateManager.STATE_SAVING_METHOD_CLIENT, the implementation may encrypt the state to be saved to the client. We recommend that the state be unreadable by the client, and also be tamper evident. The reference implementation follows these recommendations.

        Parameters:
        context - The FacesContext instance for the current request
        state - The serialized state information previously saved
        Throws:
        IOException

      • isStateless

        public boolean isStateless(FacesContext context,
                  String viewId)

        If the preceding call to writeState(javax.faces.context.FacesContext, java.lang.Object) was stateless, return true. If the preceding call to writeState() was stateful, return false. Otherwise throw IllegalStateException.

        To preserve backward compatibility with custom implementations that may have extended from an earlier version of this class, an implementation is provided that returns false. A compliant implementation must override this method to take the specified action.

        Parameters:
        context - The FacesContext instance for the current request
        viewId - View identifier of the view to be restored
        Throws:
        NullPointerException - if the argument context is null.
        IllegalStateException - if this method is invoked and the statefulness of the preceding call to writeState(javax.faces.context.FacesContext, java.lang.Object) cannot be determined.
        Since:
        2.2

      • getState

        public Object getState(FacesContext context,
              String viewId)

        The implementation must inspect the current request and return an Object representing the tree structure and component state passed in to a previous invocation of writeState(javax.faces.context.FacesContext,java.lang.Object).

        If the state saving method for this application is StateManager.STATE_SAVING_METHOD_CLIENT, writeState() will have encrypted the state in a tamper evident manner. If the state fails to decrypt, or decrypts but indicates evidence of tampering, a ProtectedViewException must be thrown.

        For backwards compatability with existing ResponseStateManager implementations, the default implementation of this method calls getTreeStructureToRestore(javax.faces.context.FacesContext, java.lang.String) and getComponentStateToRestore(javax.faces.context.FacesContext) and creates and returns a two element Object array with element zero containing the structure property and element one containing the state property of the SerializedView.

        Parameters:
        context - The FacesContext instance for the current request
        viewId - View identifier of the view to be restored
        Returns:
        the tree structure and component state Object passed in to writeState. If this is an initial request, this method returns null.
        Since:
        1.2

      • getTreeStructureToRestore

        public Object getTreeStructureToRestore(FacesContext context,
                               String viewId)
        Deprecated. This method has been replaced by getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.

        The implementation must inspect the current request and return the tree structure Object passed to it on a previous invocation of writeState().

        Parameters:
        context - The FacesContext instance for the current request
        viewId - View identifier of the view to be restored

      • getComponentStateToRestore

        public Object getComponentStateToRestore(FacesContext context)
        Deprecated. This method has been replaced by getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.

        The implementation must inspect the current request and return the component state Object passed to it on a previous invocation of writeState().

        Parameters:
        context - The FacesContext instance for the current request

      • isPostback

        public boolean isPostback(FacesContext context)

        Return true if the current request is a postback. This method is leveraged from the Restore View Phase to determine if ViewHandler.restoreView(javax.faces.context.FacesContext, java.lang.String) or ViewHandler.createView(javax.faces.context.FacesContext, java.lang.String) should be called. The default implementation must return true if this ResponseStateManager instance wrote out state on a previous request to which this request is a postback, false otherwise.

        The implementation of this method for the Standard HTML RenderKit must consult the ExternalContext's requestParameterMap and return true if and only if there is a key equal to the value of the symbolic constant VIEW_STATE_PARAM.

        For backwards compatability with implementations of ResponseStateManager prior to JSF 1.2, a default implementation is provided that consults the ExternalContext's requestParameterMap and return true if its size is greater than 0.

        Since:
        1.2

      • getViewState

        public String getViewState(FacesContext context,
                  Object state)

        Return the specified state as a String without any markup related to the rendering technology supported by this ResponseStateManager.

        Parameters:
        context - the FacesContext for the current request
        state - the state from which the String version will be generated from
        Returns:
        the view state for this request without any markup specifics
        Since:
        2.0

      • getCryptographicallyStrongTokenFromSession

        public String getCryptographicallyStrongTokenFromSession(FacesContext context)

        Compliant implementations must return a cryptographically strong token for use to protect views in this application. For backwards compatability with earlier revisions, a default implementation is provided that simply returns null.

        Parameters:
        context - the FacesContext for the current request
        Returns:
        a cryptographically strong value
        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.render (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.render

  • Packages that use javax.faces.render
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.render
    Classes and interfaces defining the rendering model.
  • Classes in javax.faces.render used by javax.faces.component
    Class and Description
    Renderer
    A Renderer converts the internal representation of UIComponents into the output stream (or writer) associated with the response we are creating for a particular request.
  • Classes in javax.faces.render used by javax.faces.component.behavior
    Class and Description
    ClientBehaviorRenderer
    A ClientBehaviorRenderer produces the client-side script that implements a ClientBehavior's client-side logic.
  • Classes in javax.faces.render used by javax.faces.context
    Class and Description
    RenderKit
    RenderKit represents a collection of Renderer instances that, together, know how to render JavaServer Faces UIComponent instances for a specific client.
  • Classes in javax.faces.render used by javax.faces.render
    Class and Description
    ClientBehaviorRenderer
    A ClientBehaviorRenderer produces the client-side script that implements a ClientBehavior's client-side logic.
    Renderer
    A Renderer converts the internal representation of UIComponents into the output stream (or writer) associated with the response we are creating for a particular request.
    RenderKit
    RenderKit represents a collection of Renderer instances that, together, know how to render JavaServer Faces UIComponent instances for a specific client.
    RenderKitFactory
    RenderKitFactory is a factory object that registers and returns RenderKit instances.
    ResponseStateManager
    ResponseStateManager is the helper class to StateManager that knows the specific rendering technology being used to generate the response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.render.ClientBehaviorRenderer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.render.ClientBehaviorRenderer

  • Packages that use ClientBehaviorRenderer
    Package Description
    javax.faces.component.behavior
    APIs for attaching additional behavior to user interface components.
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of ClientBehaviorRenderer in javax.faces.component.behavior

      Methods in javax.faces.component.behavior that return ClientBehaviorRenderer
      Modifier and Type Method and Description
      protected ClientBehaviorRenderer ClientBehaviorBase.getRenderer(FacesContext context)

      Convenience method to return the ClientBehaviorRenderer instance associated with this ClientBehavior, if any; otherwise, return null.

    • Uses of ClientBehaviorRenderer in javax.faces.render

      Methods in javax.faces.render that return ClientBehaviorRenderer
      Modifier and Type Method and Description
      ClientBehaviorRenderer RenderKitWrapper.getClientBehaviorRenderer(String type)
      The default behavior of this method is to call RenderKit.getClientBehaviorRenderer(String) on the wrapped RenderKit object.
      ClientBehaviorRenderer RenderKit.getClientBehaviorRenderer(String type)
      Return the ClientBehaviorRenderer instance most recently registered for the specified type, if any; otherwise, return null.
      Methods in javax.faces.render with parameters of type ClientBehaviorRenderer
      Modifier and Type Method and Description
      void RenderKitWrapper.addClientBehaviorRenderer(String type, ClientBehaviorRenderer renderer)
      The default behavior of this method is to call RenderKit.addClientBehaviorRenderer(String, ClientBehaviorRenderer) on the wrapped RenderKit object.
      void RenderKit.addClientBehaviorRenderer(String type, ClientBehaviorRenderer renderer)
      Register the specified ClientBehaviorRenderer instance, associated with the specified component type, to the set of ClientBehaviorRenderers registered with this RenderKit, replacing any previously registered ClientBehaviorRenderer for this type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.render.FacesBehaviorRenderer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.render.FacesBehaviorRenderer

No usage of javax.faces.render.FacesBehaviorRenderer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.render.FacesRenderer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.render.FacesRenderer

No usage of javax.faces.render.FacesRenderer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.render.Renderer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.render.Renderer

  • Packages that use Renderer
    Package Description
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of Renderer in javax.faces.component

      Methods in javax.faces.component that return Renderer
      Modifier and Type | Method and Description
      protected Renderer | UIComponentBase.getRenderer(FacesContext context)
      protected abstract Renderer UIComponent.getRenderer(FacesContext context)
      Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.

    • Uses of Renderer in javax.faces.render

      Subclasses of Renderer in javax.faces.render
      Modifier and Type Class and Description
      class  RendererWrapper

      Provides a simple implementation of Renderer that can be subclassed by developers wishing to provide specialized behavior to an existing Renderer instance.
      Methods in javax.faces.render that return Renderer
      Modifier and Type | Method and Description
      Renderer RenderKitWrapper.getRenderer(String family, String rendererType)
      The default behavior of this method is to call RenderKit.getRenderer(String, String) on the wrapped RenderKit object.
      abstract Renderer RenderKit.getRenderer(String family, String rendererType)
      Return the Renderer instance most recently registered for the specified component family and rendererType, if any; otherwise, return null.
      abstract Renderer | RendererWrapper.getWrapped()
      Methods in javax.faces.render with parameters of type Renderer
      Modifier and Type Method and Description
      void RenderKitWrapper.addRenderer(String family, String rendererType, Renderer renderer)
      The default behavior of this method is to call RenderKit.addRenderer(String, String, Renderer) on the wrapped RenderKit object.
      abstract void RenderKit.addRenderer(String family, String rendererType, Renderer renderer)
      Register the specified Renderer instance, associated with the specified component family and rendererType, to the set of Renderers registered with this RenderKit, replacing any previously registered Renderer for this combination of identifiers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.render.RendererWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.render.RendererWrapper

No usage of javax.faces.render.RendererWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.render.RenderKit (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.render.RenderKit

  • Packages that use RenderKit
    Package Description
    javax.faces.context
    Classes and interfaces defining per-request state information.
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of RenderKit in javax.faces.context

      Methods in javax.faces.context that return RenderKit
      Modifier and Type Method and Description
      RenderKit FacesContextWrapper.getRenderKit()
      The default behavior of this method is to call FacesContext.getRenderKit() on the wrapped FacesContext object.
      abstract RenderKit FacesContext.getRenderKit()
      Return the RenderKit instance for the render kit identifier specified on our UIViewRoot, if there is one.

    • Uses of RenderKit in javax.faces.render

      Subclasses of RenderKit in javax.faces.render
      Modifier and Type Class and Description
      class  RenderKitWrapper

      Provides a simple implementation of RenderKit that can be subclassed by developers wishing to provide specialized behavior to an existing RenderKit instance.
      Methods in javax.faces.render that return RenderKit
      Modifier and Type | Method and Description
      abstract RenderKit RenderKitFactory.getRenderKit(FacesContext context, String renderKitId)
      Return a RenderKit instance for the specified render kit identifier, possibly customized based on dynamic characteristics of the specified FacesContext, if non-null.
      abstract RenderKit | RenderKitWrapper.getWrapped()
      Methods in javax.faces.render with parameters of type RenderKit
      Modifier and Type Method and Description
      abstract void RenderKitFactory.addRenderKit(String renderKitId, RenderKit renderKit)
      Register the specified RenderKit instance, associated with the specified renderKitId, to be supported by this RenderKitFactory, replacing any previously registered RenderKit for this identifier.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.render.RenderKitFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.render.RenderKitFactory

  • Packages that use RenderKitFactory
    Package Description
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of RenderKitFactory in javax.faces.render

      Methods in javax.faces.render that return RenderKitFactory
      Modifier and Type Method and Description
      RenderKitFactory RenderKitFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.render.RenderKitWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.render.RenderKitWrapper

No usage of javax.faces.render.RenderKitWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.render.ResponseStateManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.render.ResponseStateManager

  • Packages that use ResponseStateManager
    Package Description
    javax.faces.render
    Classes and interfaces defining the rendering model.

    • Uses of ResponseStateManager in javax.faces.render

      Methods in javax.faces.render that return ResponseStateManager
      Modifier and Type Method and Description
      ResponseStateManager RenderKitWrapper.getResponseStateManager()
      The default behavior of this method is to call RenderKit.getResponseStateManager() on the wrapped RenderKit object.
      abstract ResponseStateManager RenderKit.getResponseStateManager()
      Return an instance of ResponseStateManager to handle rendering technology specific state management decisions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BeanValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.validator

Class BeanValidator

  • java.lang.Object
    • javax.faces.validator.BeanValidator
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, Validator

    public class BeanValidator
extends Object
implements Validator, PartialStateHolder

    A Validator that delegates validation of the bean property to the Bean Validation API.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DISABLE_DEFAULT_BEAN_VALIDATOR_PARAM_NAME

      If this param is defined, and calling toLowerCase().equals(“true”) on a String representation of its value returns true, the runtime must not automatically add the validator with validator-id equal to the value of the symbolic constant VALIDATOR_ID to the list of default validators.
      static String EMPTY_VALIDATION_GROUPS_PATTERN

      The regular expression pattern that identifies an empty list of validation groups.
      static String MESSAGE_ID
      The message identifier of the FacesMessage to be created if a constraint failure is found.
      static String VALIDATION_GROUPS_DELIMITER

      The delimiter that is used to separate the list of fully-qualified group names as strings.
      static String VALIDATOR_FACTORY_KEY

      The name of the servlet context attribute which holds the object used by JSF to obtain Validator instances.
      static String VALIDATOR_ID

      The standard validator id for this validator, as defined by the JSF specification.

      • Fields inherited from interface javax.faces.validator.Validator

        NOT_IN_RANGE_MESSAGE_ID

    • Constructor Summary

      Constructors
      Constructor and Description
      BeanValidator()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearInitialState()

      Reset the PartialStateHolder to a non-delta tracking state.
      String getValidationGroups()

      Return the validation groups passed to the Validation API when checking constraints.
      boolean initialStateMarked()

      Return true if delta state changes are being tracked, otherwise false
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void markInitialState()

      The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setTransient(boolean transientValue)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
      void setValidationGroups(String validationGroups)

      A comma-separated list of validation groups which are used to filter which validations get checked by this validator.
      void validate(FacesContext context, UIComponent component, Object value)

      Verify that the value is valid according to the Bean Validation constraints.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • VALIDATOR_ID

        public static final String VALIDATOR_ID

        The standard validator id for this validator, as defined by the JSF specification.

        See Also:
        Constant Field Values

      • MESSAGE_ID

        public static final String MESSAGE_ID

        The message identifier of the FacesMessage to be created if a constraint failure is found. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the interpolated message from Bean Validation.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        The message format string provided by the default implementation should be a the placeholder {0}, thus fully delegating the message handling to Bean Validation. A developer can override this message format string to make it conform to other JSF validator messages (i.e., by including the component label)

        See Also:
        Constant Field Values

      • VALIDATOR_FACTORY_KEY

        public static final String VALIDATOR_FACTORY_KEY

        The name of the servlet context attribute which holds the object used by JSF to obtain Validator instances. If the servlet context attribute is missing or contains a null value, JSF is free to use this servlet context attribute to store the ValidatorFactory bootstrapped by this validator.

        See Also:
        Constant Field Values

      • VALIDATION_GROUPS_DELIMITER

        public static final String VALIDATION_GROUPS_DELIMITER

        The delimiter that is used to separate the list of fully-qualified group names as strings.

        See Also:
        Constant Field Values

      • EMPTY_VALIDATION_GROUPS_PATTERN

        public static final String EMPTY_VALIDATION_GROUPS_PATTERN

        The regular expression pattern that identifies an empty list of validation groups.

        See Also:
        Constant Field Values

      • DISABLE_DEFAULT_BEAN_VALIDATOR_PARAM_NAME

        public static final String DISABLE_DEFAULT_BEAN_VALIDATOR_PARAM_NAME

        If this param is defined, and calling toLowerCase().equals(“true”) on a String representation of its value returns true, the runtime must not automatically add the validator with validator-id equal to the value of the symbolic constant VALIDATOR_ID to the list of default validators. Setting this parameter to true will have the effect of disabling the automatic installation of Bean Validation to every input component in every view in the application, though manual installation is still possible.

        See Also:
        Constant Field Values

    • Constructor Detail

      • BeanValidator

        public BeanValidator()

    • Method Detail

      • setValidationGroups

        public void setValidationGroups(String validationGroups)

        A comma-separated list of validation groups which are used to filter which validations get checked by this validator. If the validationGroupsArray attribute is omitted or is empty, the validation groups will be inherited from the branch defaults or, if there are no branch defaults, the Default group will be used.

        Parameters:
        validationGroups - comma-separated list of validation groups (string with only spaces and commas treated as null)

      • getValidationGroups

        public String getValidationGroups()

        Return the validation groups passed to the Validation API when checking constraints. If the validationGroupsArray attribute is omitted or empty, the validation groups will be inherited from the branch defaults, or if there are no branch defaults, the Default group will be used.

      • validate

        public void validate(FacesContext context,
            UIComponent component,
            Object value)

        Verify that the value is valid according to the Bean Validation constraints.

        Obtain a ValidatorFactory instance by calling Validation.buildDefaultValidatorFactory().

        Let validationGroupsArray be a Class [] representing validator groups set on the component by the tag handler for this validator. The first search component terminates the search for the validation groups value. If no such value is found use the class name of Default as the value of the validation groups.

        Let valueExpression be the return from calling UIComponent.getValueExpression(java.lang.String) on the argument component, passing the literal string “value” (without the quotes) as an argument. If this application is running in an environment with a Unified EL Implementation for Java EE6 or later, obtain the ValueReference from valueExpression and let valueBaseClase be the return from calling ValueReference.getBase() and valueProperty be the return from calling ValueReference.getProperty(). If an earlier version of the Unified EL is present, use the appropriate methods to inspect valueExpression and derive values for valueBaseClass and valueProperty.

        If no ValueReference can be obtained, take no action and return.

        If ValueReference.getBase() return null, take no action and return.

        Obtain the ValidatorContext from the ValidatorFactory.

        Decorate the MessageInterpolator returned from ValidatorFactory.getMessageInterpolator() with one that leverages the Locale returned from UIViewRoot.getLocale(), and store it in the ValidatorContext using ValidatorContext.messageInterpolator(javax.validation.MessageInterpolator).

        Obtain the Validator instance from the validatorContext.

        Obtain a javax.validation.BeanDescriptor from the javax.validation.Validator. If hasConstraints() on the BeanDescriptor returns false, take no action and return. Otherwise proceed.

        Call Validator.validateValue(java.lang.Class<T>, java.lang.String, java.lang.Object, java.lang.Class<?>...), passing valueBaseClass, valueProperty, the value argument, and validatorGroupsArray as arguments.

        If the returned Set<ConstraintViolation> is non-empty, for each element in the Set, create a FacesMessage where the summary and detail are the return from calling ConstraintViolation.getMessage(). Capture all such FacesMessage instances into a Collection and pass them to ValidatorException.ValidatorException(java.util.Collection), throwing the new exception.

        Specified by:
        validate in interface Validator
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent we are checking for correctness
        value - the value to validate
        Throws:
        ValidatorException - if validation fails

      • saveState

        public Object saveState(FacesContext context)
        Description copied from interface: StateHolder

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)
        Description copied from interface: StateHolder

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Specified by:
        restoreState in interface StateHolder

      • markInitialState

        public void markInitialState()
        Description copied from interface: PartialStateHolder

        The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state. The implementor of the interface must ensure that PartialStateHolder.initialStateMarked() returns true from the time markInitialState() is called until PartialStateHolder.clearInitialState() is called, after which time initialStateMarked() must return false. Also, during the time that the instance returns true from initialStateMarked(), the implementation must return only the state that has changed in its implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Specified by:
        markInitialState in interface PartialStateHolder

      • initialStateMarked

        public boolean initialStateMarked()
        Description copied from interface: PartialStateHolder

        Return true if delta state changes are being tracked, otherwise false

        Specified by:
        initialStateMarked in interface PartialStateHolder

      • clearInitialState

        public void clearInitialState()
        Description copied from interface: PartialStateHolder

        Reset the PartialStateHolder to a non-delta tracking state.

        Specified by:
        clearInitialState in interface PartialStateHolder

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean transientValue)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        transientValue - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DoubleRangeValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.validator

Class DoubleRangeValidator

  • java.lang.Object
    • javax.faces.validator.DoubleRangeValidator
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, Validator

    public class DoubleRangeValidator
extends Object
implements Validator, PartialStateHolder

    DoubleRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values. The following algorithm is implemented:

    • If the passed value is null, exit immediately.
    • If the current component value is not a floating point type, or a String that is convertible to double, throw a ValidatorException containing a TYPE_MESSAGE_ID message.
    • If both a maximum and minimum property has been configured on this Validator, check the component value against both limits. If the component value is not within this specified range, throw a ValidatorException containing a NOT_IN_RANGE_MESSAGE_ID message.
    • If a maximum property has been configured on this Validator, check the component value against this limit. If the component value is greater than the specified maximum, throw a ValidatorException containing a MAXIMUM_MESSAGE_ID message.
    • If a minimum property has been configured on this Validator, check the component value against this limit. If the component value is less than the specified minimum, throw a ValidatorException containing a MINIMUM_MESSAGE_ID message.

    For all of the above cases that cause a ValidatorException to be thrown, if there are parameters to the message that match up with validator parameters, the values of these parameters must be converted using the Converter registered in the application under the converter id javax.faces.Number. This allows the values to be localized according to the current Locale.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String MAXIMUM_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the maximum value check fails.
      static String MINIMUM_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the minimum value check fails.
      static String NOT_IN_RANGE_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set.
      static String TYPE_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the current value of this component is not of the correct type.
      static String VALIDATOR_ID
      The standard converter id for this converter.

    • Constructor Summary

      Constructors
      Constructor and Description
      DoubleRangeValidator()
      Construct a Validator with no preconfigured limits.
      DoubleRangeValidator(double maximum)
      Construct a Validator with the specified preconfigured limit.
      DoubleRangeValidator(double maximum, double minimum)
      Construct a Validator with the specified preconfigured limits.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void clearInitialState()

      Reset the PartialStateHolder to a non-delta tracking state.
      boolean | equals(Object otherObj)
      double getMaximum()
      Return the maximum value to be enforced by this Validator or Double.MAX_VALUE if it has not been set.
      double getMinimum()
      Return the minimum value to be enforced by this Validator, or Double.MIN_VALUE if it has not been set.
      int | hashCode()
      boolean initialStateMarked()

      Return true if delta state changes are being tracked, otherwise false
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void markInitialState()

      The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setMaximum(double maximum)
      Set the maximum value to be enforced by this Validator.
      void setMinimum(double minimum)
      Set the minimum value to be enforced by this Validator.
      void setTransient(boolean transientValue)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
      void validate(FacesContext context, UIComponent component, Object value)
      Perform the correctness checks implemented by this Validator against the specified UIComponent.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • VALIDATOR_ID

        public static final String VALIDATOR_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • MAXIMUM_MESSAGE_ID

        public static final String MAXIMUM_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the maximum value check fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the configured maximum value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • MINIMUM_MESSAGE_ID

        public static final String MINIMUM_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the minimum value check fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the configured minimum value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • NOT_IN_RANGE_MESSAGE_ID

        public static final String NOT_IN_RANGE_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the configured minimum value.
        • {1} replaced by the configured maximum value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • TYPE_MESSAGE_ID

        public static final String TYPE_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the current value of this component is not of the correct type. The message format string for this message may optionally include a {0} placeholder that will be replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • DoubleRangeValidator

        public DoubleRangeValidator()

        Construct a Validator with no preconfigured limits.

      • DoubleRangeValidator

        public DoubleRangeValidator(double maximum)

        Construct a Validator with the specified preconfigured limit.

        Parameters:
        maximum - Maximum value to allow

      • DoubleRangeValidator

        public DoubleRangeValidator(double maximum,
                    double minimum)

        Construct a Validator with the specified preconfigured limits.

        Parameters:
        maximum - Maximum value to allow
        minimum - Minimum value to allow

    • Method Detail

      • getMaximum

        public double getMaximum()

        Return the maximum value to be enforced by this Validator or Double.MAX_VALUE if it has not been set.

      • setMaximum

        public void setMaximum(double maximum)

        Set the maximum value to be enforced by this Validator.

        Parameters:
        maximum - The new maximum value

      • getMinimum

        public double getMinimum()

        Return the minimum value to be enforced by this Validator, or Double.MIN_VALUE if it has not been set.

      • setMinimum

        public void setMinimum(double minimum)

        Set the minimum value to be enforced by this Validator.

        Parameters:
        minimum - The new minimum value

      • validate

        public void validate(FacesContext context,
            UIComponent component,
            Object value)
              throws ValidatorException
        Description copied from interface: Validator

        Perform the correctness checks implemented by this Validator against the specified UIComponent. If any violations are found, a ValidatorException will be thrown containing the FacesMessage describing the failure.

        For a validator to be fully compliant with Version 2 and later of the specification, it must not fail validation on null or empty values unless it is specifically intended to address null or empty values. An application-wide <context-param> is provided to allow validators designed for JSF 1.2 to work with JSF 2 and later. The javax.faces.VALIDATE_EMPTY_FIELDS <context-param> must be set to false to enable this backwards compatibility behavior.

        Specified by:
        validate in interface Validator
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent we are checking for correctness
        value - the value to validate
        Throws:
        NullPointerException - if context or component is null
        ValidatorException - if validation fails

      • equals

        public boolean equals(Object otherObj)
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Overrides:
        hashCode in class Object

      • saveState

        public Object saveState(FacesContext context)
        Description copied from interface: StateHolder

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)
        Description copied from interface: StateHolder

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Specified by:
        restoreState in interface StateHolder

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean transientValue)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        transientValue - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.

      • markInitialState

        public void markInitialState()
        Description copied from interface: PartialStateHolder

        The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state. The implementor of the interface must ensure that PartialStateHolder.initialStateMarked() returns true from the time markInitialState() is called until PartialStateHolder.clearInitialState() is called, after which time initialStateMarked() must return false. Also, during the time that the instance returns true from initialStateMarked(), the implementation must return only the state that has changed in its implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Specified by:
        markInitialState in interface PartialStateHolder

      • initialStateMarked

        public boolean initialStateMarked()
        Description copied from interface: PartialStateHolder

        Return true if delta state changes are being tracked, otherwise false

        Specified by:
        initialStateMarked in interface PartialStateHolder

      • clearInitialState

        public void clearInitialState()
        Description copied from interface: PartialStateHolder

        Reset the PartialStateHolder to a non-delta tracking state.

        Specified by:
        clearInitialState in interface PartialStateHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.validator

Annotation Type FacesValidator

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface FacesValidator

    The presence of this annotation on a class automatically registers the class with the runtime as a Validator. The value of the value() attribute is taken to be the validator-id and the fully qualified class name of the class to which this annotation is attached is taken to be the validator-class. The implementation must guarantee that for each class annotated with FacesValidator, found with the algorithm in section JSF.11.5, Application.addValidator(java.lang.String,java.lang.String) is called, passing the derived validator-id as the first argument and the derived validator-class as the second argument. The implementation must guarantee that all such calls to addValidator() happen during application startup time and before any requests are serviced.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean isDefault

      If true, the validator id for this annotation is added to the list of default validators by a call to Application.addDefaultValidatorId(java.lang.String).
      String value

      The value of this annotation attribute is taken to be the validator-id with which instances of this class of component can be instantiated by calling Application.createValidator(java.lang.String).

    • Element Detail

      • value

        public abstract String value

        The value of this annotation attribute is taken to be the validator-id with which instances of this class of component can be instantiated by calling Application.createValidator(java.lang.String). If no value is specified, or the value is null, the value is taken to be the return of calling getSimpleName on the class to which this annotation is attached and lowercasing the first character. If more than one validator with this derived name is found, the results are undefined.

        Default:
        ""

      • isDefault

        public abstract boolean isDefault

        If true, the validator id for this annotation is added to the list of default validators by a call to Application.addDefaultValidatorId(java.lang.String).

        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.faces.validator (Java(TM) EE 7 Specification APIs)

javax.faces.validator

Interfaces

  • Validator

Classes

  • BeanValidator
  • DoubleRangeValidator
  • LengthValidator
  • LongRangeValidator
  • MethodExpressionValidator
  • RegexValidator
  • RequiredValidator

Exceptions

  • ValidatorException

Annotation Types

  • FacesValidator


javax.faces.validator (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.validator

Interface defining the validator model, and concrete validator implementation classes.

See: Description

  • Interface Summary
    Interface Description
    Validator
    A Validator implementation is a class that can perform validation (correctness checks) on a EditableValueHolder.
  • Class Summary
    Class Description
    BeanValidator

    A Validator that delegates validation of the bean property to the Bean Validation API.
    DoubleRangeValidator
    DoubleRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
    LengthValidator
    LengthValidator is a Validator that checks the number of characters in the String representation of the value of the associated component.
    LongRangeValidator
    LongRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
    MethodExpressionValidator
    MethodExpressionValidator is a Validator that wraps a MethodExpression, and it performs validation by executing a method on an object identified by the MethodExpression.
    RegexValidator

    A Validator that checks against a Regular Expression (which is the pattern property).
    RequiredValidator

    A Validator that checks for an empty value in the same way that UIInput checks for a value.
  • Exception Summary
    Exception Description
    ValidatorException
    A ValidatorException is an exception thrown by the validate() method of a Validator to indicate that validation failed.
  • Annotation Types Summary
    Annotation Type Description
    FacesValidator

    The presence of this annotation on a class automatically registers the class with the runtime as a Validator.

Package javax.faces.validator Description

Interface defining the validator model, and concrete validator implementation classes.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.validator Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.validator

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.validator.BeanValidator (implements javax.faces.component.PartialStateHolder, javax.faces.validator.Validator)
    • javax.faces.validator.DoubleRangeValidator (implements javax.faces.component.PartialStateHolder, javax.faces.validator.Validator)
    • javax.faces.validator.LengthValidator (implements javax.faces.component.PartialStateHolder, javax.faces.validator.Validator)
    • javax.faces.validator.LongRangeValidator (implements javax.faces.component.PartialStateHolder, javax.faces.validator.Validator)
    • javax.faces.validator.MethodExpressionValidator (implements javax.faces.component.StateHolder, javax.faces.validator.Validator)
    • javax.faces.validator.RegexValidator (implements javax.faces.component.PartialStateHolder, javax.faces.validator.Validator)
    • javax.faces.validator.RequiredValidator (implements javax.faces.validator.Validator)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.validator.ValidatorException

Interface Hierarchy

  • java.util.EventListener
    • javax.faces.validator.Validator

Annotation Type Hierarchy

  • javax.faces.validator.FacesValidator (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LengthValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.validator

Class LengthValidator

  • java.lang.Object
    • javax.faces.validator.LengthValidator
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, Validator

    public class LengthValidator
extends Object
implements Validator, PartialStateHolder

    LengthValidator is a Validator that checks the number of characters in the String representation of the value of the associated component. The following algorithm is implemented:

    • Convert the passed value to a String, if necessary, by calling its toString() method.
    • If a maximum property has been configured on this Validator, check the length of the converted String against this limit. If the String length is larger than the specified maximum, throw a ValidatorException containing a a MAXIMUM_MESSAGE_ID message.
    • If a minimum property has been configured on this Validator, check the length of the converted String against this limit. If the String length is less than the specified minimum, throw a ValidatorException containing a a MINIMUM_MESSAGE_ID message.

    For all of the above cases that cause a ValidatorException to be thrown, if there are parameters to the message that match up with validator parameters, the values of these parameters must be converted using the Converter registered in the application under the converter id javax.faces.Number. This allows the values to be localized according to the current Locale.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String MAXIMUM_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the maximum length check fails.
      static String MINIMUM_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the minimum length check fails.
      static String VALIDATOR_ID
      The standard validator id for this validator.

      • Fields inherited from interface javax.faces.validator.Validator

        NOT_IN_RANGE_MESSAGE_ID

    • Constructor Summary

      Constructors
      Constructor and Description
      LengthValidator()
      Construct a Validator with no preconfigured limits.
      LengthValidator(int maximum)
      Construct a Validator with the specified preconfigured limit.
      LengthValidator(int maximum, int minimum)
      Construct a Validator with the specified preconfigured limits.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void clearInitialState()

      Reset the PartialStateHolder to a non-delta tracking state.
      boolean | equals(Object otherObj)
      int getMaximum()
      Return the maximum length to be enforced by this Validator, or 0 if the maximum has not been set.
      int getMinimum()
      Return the minimum length to be enforced by this Validator, or 0 if the minimum has not been set.
      int | hashCode()
      boolean initialStateMarked()

      Return true if delta state changes are being tracked, otherwise false
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void markInitialState()

      The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setMaximum(int maximum)
      Set the maximum length to be enforced by this Validator.
      void setMinimum(int minimum)
      Set the minimum length to be enforced by this Validator.
      void setTransient(boolean transientValue)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
      void validate(FacesContext context, UIComponent component, Object value)
      Perform the correctness checks implemented by this Validator against the specified UIComponent.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • VALIDATOR_ID

        public static final String VALIDATOR_ID

        The standard validator id for this validator.

        See Also:
        Constant Field Values

      • MAXIMUM_MESSAGE_ID

        public static final String MAXIMUM_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the maximum length check fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the configured maximum length.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • MINIMUM_MESSAGE_ID

        public static final String MINIMUM_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the minimum length check fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the configured minimum length.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • LengthValidator

        public LengthValidator()

        Construct a Validator with no preconfigured limits.

      • LengthValidator

        public LengthValidator(int maximum)

        Construct a Validator with the specified preconfigured limit.

        Parameters:
        maximum - Maximum value to allow

      • LengthValidator

        public LengthValidator(int maximum,
               int minimum)

        Construct a Validator with the specified preconfigured limits.

        Parameters:
        maximum - Maximum value to allow
        minimum - Minimum value to allow

    • Method Detail

      • getMaximum

        public int getMaximum()

        Return the maximum length to be enforced by this Validator, or 0 if the maximum has not been set.

      • setMaximum

        public void setMaximum(int maximum)

        Set the maximum length to be enforced by this Validator.

        Parameters:
        maximum - The new maximum value

      • getMinimum

        public int getMinimum()

        Return the minimum length to be enforced by this Validator, or 0 if the minimum has not been set.

      • setMinimum

        public void setMinimum(int minimum)

        Set the minimum length to be enforced by this Validator.

        Parameters:
        minimum - The new minimum value

      • validate

        public void validate(FacesContext context,
            UIComponent component,
            Object value)
              throws ValidatorException
        Description copied from interface: Validator

        Perform the correctness checks implemented by this Validator against the specified UIComponent. If any violations are found, a ValidatorException will be thrown containing the FacesMessage describing the failure.

        For a validator to be fully compliant with Version 2 and later of the specification, it must not fail validation on null or empty values unless it is specifically intended to address null or empty values. An application-wide <context-param> is provided to allow validators designed for JSF 1.2 to work with JSF 2 and later. The javax.faces.VALIDATE_EMPTY_FIELDS <context-param> must be set to false to enable this backwards compatibility behavior.

        Specified by:
        validate in interface Validator
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent we are checking for correctness
        value - the value to validate
        Throws:
        NullPointerException - if context or component is null
        ValidatorException - if validation fails

      • equals

        public boolean equals(Object otherObj)
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Overrides:
        hashCode in class Object

      • saveState

        public Object saveState(FacesContext context)
        Description copied from interface: StateHolder

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)
        Description copied from interface: StateHolder

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Specified by:
        restoreState in interface StateHolder

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean transientValue)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        transientValue - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.

      • markInitialState

        public void markInitialState()
        Description copied from interface: PartialStateHolder

        The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state. The implementor of the interface must ensure that PartialStateHolder.initialStateMarked() returns true from the time markInitialState() is called until PartialStateHolder.clearInitialState() is called, after which time initialStateMarked() must return false. Also, during the time that the instance returns true from initialStateMarked(), the implementation must return only the state that has changed in its implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Specified by:
        markInitialState in interface PartialStateHolder

      • initialStateMarked

        public boolean initialStateMarked()
        Description copied from interface: PartialStateHolder

        Return true if delta state changes are being tracked, otherwise false

        Specified by:
        initialStateMarked in interface PartialStateHolder

      • clearInitialState

        public void clearInitialState()
        Description copied from interface: PartialStateHolder

        Reset the PartialStateHolder to a non-delta tracking state.

        Specified by:
        clearInitialState in interface PartialStateHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LongRangeValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.validator

Class LongRangeValidator

  • java.lang.Object
    • javax.faces.validator.LongRangeValidator
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, Validator

    public class LongRangeValidator
extends Object
implements Validator, PartialStateHolder

    LongRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values. The following algorithm is implemented:

    • If the passed value is null, exit immediately.
    • If the current component value is not a floating point type, or a String that is convertible to long, throw a ValidatorException containing a TYPE_MESSAGE_ID message.
    • If both a maximum and minimum property has been configured on this Validator, check the component value against both limits. If the component value is not within this specified range, throw a ValidatorException containing a NOT_IN_RANGE_MESSAGE_ID message.
    • If a maximum property has been configured on this Validator, check the component value against this limit. If the component value is greater than the specified maximum, throw a ValidatorException containing a MAXIMUM_MESSAGE_ID message.
    • If a minimum property has been configured on this Validator, check the component value against this limit. If the component value is less than the specified minimum, throw a ValidatorException containing a MINIMUM_MESSAGE_ID message.

    For all of the above cases that cause a ValidatorException to be thrown, if there are parameters to the message that match up with validator parameters, the values of these parameters must be converted using the Converter registered in the application under the converter id javax.faces.Number. This allows the values to be localized according to the current Locale.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String MAXIMUM_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the maximum value check fails.
      static String MINIMUM_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the minimum value check fails.
      static String NOT_IN_RANGE_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set.
      static String TYPE_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the current value of this component is not of the correct type.
      static String VALIDATOR_ID
      The standard converter id for this converter.

    • Constructor Summary

      Constructors
      Constructor and Description
      LongRangeValidator()
      Construct a Validator with no preconfigured limits.
      LongRangeValidator(long maximum)
      Construct a Validator with the specified preconfigured limit.
      LongRangeValidator(long maximum, long minimum)
      Construct a Validator with the specified preconfigured limits.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void clearInitialState()

      Reset the PartialStateHolder to a non-delta tracking state.
      boolean | equals(Object otherObj)
      long getMaximum()
      Return the maximum value to be enforced by this Validator.
      long getMinimum()
      Return the minimum value to be enforced by this Validator.
      int | hashCode()
      boolean initialStateMarked()

      Return true if delta state changes are being tracked, otherwise false
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void markInitialState()

      The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setMaximum(long maximum)
      Set the maximum value to be enforced by this Validator.
      void setMinimum(long minimum)
      Set the minimum value to be enforced by this Validator.
      void setTransient(boolean transientValue)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
      void validate(FacesContext context, UIComponent component, Object value)
      Perform the correctness checks implemented by this Validator against the specified UIComponent.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • VALIDATOR_ID

        public static final String VALIDATOR_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • MAXIMUM_MESSAGE_ID

        public static final String MAXIMUM_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the maximum value check fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the configured maximum value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • MINIMUM_MESSAGE_ID

        public static final String MINIMUM_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the minimum value check fails. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the configured minimum value.
        • {1} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • NOT_IN_RANGE_MESSAGE_ID

        public static final String NOT_IN_RANGE_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set. The message format string for this message may optionally include the following placeholders:

        • {0} replaced by the configured minimum value.
        • {1} replaced by the configured maximum value.
        • {2} replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

      • TYPE_MESSAGE_ID

        public static final String TYPE_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the current value of this component is not of the correct type. The message format string for this message may optionally include a {0} placeholder that will be replaced by a String whose value is the label of the input component that produced this message.

        See Also:
        Constant Field Values

    • Constructor Detail

      • LongRangeValidator

        public LongRangeValidator()

        Construct a Validator with no preconfigured limits.

      • LongRangeValidator

        public LongRangeValidator(long maximum)

        Construct a Validator with the specified preconfigured limit.

        Parameters:
        maximum - Maximum value to allow

      • LongRangeValidator

        public LongRangeValidator(long maximum,
                  long minimum)

        Construct a Validator with the specified preconfigured limits.

        Parameters:
        maximum - Maximum value to allow
        minimum - Minimum value to allow

    • Method Detail

      • getMaximum

        public long getMaximum()

        Return the maximum value to be enforced by this Validator.

      • setMaximum

        public void setMaximum(long maximum)

        Set the maximum value to be enforced by this Validator.

        Parameters:
        maximum - The new maximum value

      • getMinimum

        public long getMinimum()

        Return the minimum value to be enforced by this Validator.

      • setMinimum

        public void setMinimum(long minimum)

        Set the minimum value to be enforced by this Validator.

        Parameters:
        minimum - The new minimum value

      • validate

        public void validate(FacesContext context,
            UIComponent component,
            Object value)
              throws ValidatorException
        Description copied from interface: Validator

        Perform the correctness checks implemented by this Validator against the specified UIComponent. If any violations are found, a ValidatorException will be thrown containing the FacesMessage describing the failure.

        For a validator to be fully compliant with Version 2 and later of the specification, it must not fail validation on null or empty values unless it is specifically intended to address null or empty values. An application-wide <context-param> is provided to allow validators designed for JSF 1.2 to work with JSF 2 and later. The javax.faces.VALIDATE_EMPTY_FIELDS <context-param> must be set to false to enable this backwards compatibility behavior.

        Specified by:
        validate in interface Validator
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent we are checking for correctness
        value - the value to validate
        Throws:
        NullPointerException - if context or component is null
        ValidatorException - if validation fails

      • equals

        public boolean equals(Object otherObj)
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Overrides:
        hashCode in class Object

      • saveState

        public Object saveState(FacesContext context)
        Description copied from interface: StateHolder

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)
        Description copied from interface: StateHolder

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Specified by:
        restoreState in interface StateHolder

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean transientValue)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        transientValue - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.

      • markInitialState

        public void markInitialState()
        Description copied from interface: PartialStateHolder

        The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state. The implementor of the interface must ensure that PartialStateHolder.initialStateMarked() returns true from the time markInitialState() is called until PartialStateHolder.clearInitialState() is called, after which time initialStateMarked() must return false. Also, during the time that the instance returns true from initialStateMarked(), the implementation must return only the state that has changed in its implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Specified by:
        markInitialState in interface PartialStateHolder

      • initialStateMarked

        public boolean initialStateMarked()
        Description copied from interface: PartialStateHolder

        Return true if delta state changes are being tracked, otherwise false

        Specified by:
        initialStateMarked in interface PartialStateHolder

      • clearInitialState

        public void clearInitialState()
        Description copied from interface: PartialStateHolder

        Reset the PartialStateHolder to a non-delta tracking state.

        Specified by:
        clearInitialState in interface PartialStateHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MethodExpressionValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.validator

Class MethodExpressionValidator

  • java.lang.Object
    • javax.faces.validator.MethodExpressionValidator
  • All Implemented Interfaces:
    EventListener, StateHolder, Validator

    public class MethodExpressionValidator
extends Object
implements Validator, StateHolder

    MethodExpressionValidator is a Validator that wraps a MethodExpression, and it performs validation by executing a method on an object identified by the MethodExpression.

    • Field Summary

      • Fields inherited from interface javax.faces.validator.Validator

        NOT_IN_RANGE_MESSAGE_ID

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodExpressionValidator()
      MethodExpressionValidator(MethodExpression methodExpression)
      Construct a Validator that contains a MethodExpression.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setTransient(boolean transientValue)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
      void validate(FacesContext context, UIComponent component, Object value)
      Perform the correctness checks implemented by this Validator against the specified UIComponent.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MethodExpressionValidator

        public MethodExpressionValidator()

      • MethodExpressionValidator

        public MethodExpressionValidator(MethodExpression methodExpression)

        Construct a Validator that contains a MethodExpression.

    • Method Detail

      • validate

        public void validate(FacesContext context,
            UIComponent component,
            Object value)
              throws ValidatorException
        Description copied from interface: Validator

        Perform the correctness checks implemented by this Validator against the specified UIComponent. If any violations are found, a ValidatorException will be thrown containing the FacesMessage describing the failure.

        For a validator to be fully compliant with Version 2 and later of the specification, it must not fail validation on null or empty values unless it is specifically intended to address null or empty values. An application-wide <context-param> is provided to allow validators designed for JSF 1.2 to work with JSF 2 and later. The javax.faces.VALIDATE_EMPTY_FIELDS <context-param> must be set to false to enable this backwards compatibility behavior.

        Specified by:
        validate in interface Validator
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent we are checking for correctness
        value - the value to validate
        Throws:
        NullPointerException - if context or component is null
        ValidatorException - if validation fails

      • saveState

        public Object saveState(FacesContext context)
        Description copied from interface: StateHolder

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)
        Description copied from interface: StateHolder

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Specified by:
        restoreState in interface StateHolder

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean transientValue)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        transientValue - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RegexValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.validator

Class RegexValidator

  • java.lang.Object
    • javax.faces.validator.RegexValidator
  • All Implemented Interfaces:
    EventListener, PartialStateHolder, StateHolder, Validator

    public class RegexValidator
extends Object
implements Validator, PartialStateHolder

    A Validator that checks against a Regular Expression (which is the pattern property). The pattern must resolve to a String that follows the java.util.regex standards.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String MATCH_EXCEPTION_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the act of matching the value against the pattern returned from getPattern() fails because of a PatternSyntaxException.
      static String NOT_MATCHED_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the act of matching the value against the pattern returned from getPattern() fails because the value does not match the pattern.
      static String PATTERN_NOT_SET_MESSAGE_ID
      The message identifier of the FacesMessage to be created if the value returned from getPattern() is null or the empty String.
      static String VALIDATOR_ID
      The standard converter id for this converter.

      • Fields inherited from interface javax.faces.validator.Validator

        NOT_IN_RANGE_MESSAGE_ID

    • Constructor Summary

      Constructors
      Constructor and Description
      RegexValidator()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearInitialState()

      Reset the PartialStateHolder to a non-delta tracking state.
      String getPattern()
      Return the ValueExpression that yields the regular expression pattern when evaluated.
      boolean initialStateMarked()

      Return true if delta state changes are being tracked, otherwise false
      boolean isTransient()
      If true, the Object implementing this interface must not participate in state saving or restoring.
      void markInitialState()

      The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state.
      void restoreState(FacesContext context, Object state)
      Perform any processing required to restore the state from the entries in the state Object.
      Object saveState(FacesContext context)
      Gets the state of the instance as a Serializable Object.
      void setPattern(String pattern)
      The Regular Expression property to validate against.
      void setTransient(boolean transientValue)
      Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
      void validate(FacesContext context, UIComponent component, Object value)
      Validate a String against a regular expression pattern.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • VALIDATOR_ID

        public static final String VALIDATOR_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

      • PATTERN_NOT_SET_MESSAGE_ID

        public static final String PATTERN_NOT_SET_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the value returned from getPattern() is null or the empty String.

        See Also:
        Constant Field Values

      • NOT_MATCHED_MESSAGE_ID

        public static final String NOT_MATCHED_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the act of matching the value against the pattern returned from getPattern() fails because the value does not match the pattern.

        See Also:
        Constant Field Values

      • MATCH_EXCEPTION_MESSAGE_ID

        public static final String MATCH_EXCEPTION_MESSAGE_ID

        The message identifier of the FacesMessage to be created if the act of matching the value against the pattern returned from getPattern() fails because of a PatternSyntaxException.

        See Also:
        Constant Field Values

    • Constructor Detail

      • RegexValidator

        public RegexValidator()

    • Method Detail

      • setPattern

        public void setPattern(String pattern)

        The Regular Expression property to validate against.

        Parameters:
        pattern - a regular expression pattern

      • getPattern

        public String getPattern()

        Return the ValueExpression that yields the regular expression pattern when evaluated.

      • validate

        public void validate(FacesContext context,
            UIComponent component,
            Object value)

        Validate a String against a regular expression pattern. The full regex pattern must be matched in order to pass the validation.

        Specified by:
        validate in interface Validator
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent we are checking for correctness
        value - the value to validate
        Throws:
        NullPointerException - if context or component is null
        ValidatorException - if validation fails

      • saveState

        public Object saveState(FacesContext context)
        Description copied from interface: StateHolder

        Gets the state of the instance as a Serializable Object.

        If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

        This method must not alter the state of the implementing object. In other words, after executing this code:

         Object state = component.saveState(facesContext);

        component should be the same as before executing it.

        The return from this method must be Serializable

        Specified by:
        saveState in interface StateHolder

      • restoreState

        public void restoreState(FacesContext context,
                Object state)
        Description copied from interface: StateHolder

        Perform any processing required to restore the state from the entries in the state Object.

        If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

        If the state argument is null, take no action and return.

        Specified by:
        restoreState in interface StateHolder

      • isTransient

        public boolean isTransient()
        Description copied from interface: StateHolder

        If true, the Object implementing this interface must not participate in state saving or restoring.

        Specified by:
        isTransient in interface StateHolder

      • setTransient

        public void setTransient(boolean transientValue)
        Description copied from interface: StateHolder

        Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

        Specified by:
        setTransient in interface StateHolder
        Parameters:
        transientValue - boolean pass true if this Object will not participate in state saving or restoring, otherwise pass false.

      • markInitialState

        public void markInitialState()
        Description copied from interface: PartialStateHolder

        The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state. The implementor of the interface must ensure that PartialStateHolder.initialStateMarked() returns true from the time markInitialState() is called until PartialStateHolder.clearInitialState() is called, after which time initialStateMarked() must return false. Also, during the time that the instance returns true from initialStateMarked(), the implementation must return only the state that has changed in its implementation of StateHolder.saveState(javax.faces.context.FacesContext).

        Specified by:
        markInitialState in interface PartialStateHolder

      • initialStateMarked

        public boolean initialStateMarked()
        Description copied from interface: PartialStateHolder

        Return true if delta state changes are being tracked, otherwise false

        Specified by:
        initialStateMarked in interface PartialStateHolder

      • clearInitialState

        public void clearInitialState()
        Description copied from interface: PartialStateHolder

        Reset the PartialStateHolder to a non-delta tracking state.

        Specified by:
        clearInitialState in interface PartialStateHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RequiredValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.validator

Class RequiredValidator

  • java.lang.Object
    • javax.faces.validator.RequiredValidator
  • All Implemented Interfaces:
    EventListener, Validator

    public class RequiredValidator
extends Object
implements Validator

    A Validator that checks for an empty value in the same way that UIInput checks for a value. In fact, this validator is equivalent to setting the required attribute on the input component to true.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String VALIDATOR_ID
      The standard converter id for this converter.

      • Fields inherited from interface javax.faces.validator.Validator

        NOT_IN_RANGE_MESSAGE_ID

    • Constructor Summary

      Constructors
      Constructor and Description
      RequiredValidator()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void validate(FacesContext context, UIComponent component, Object value)
      Verify that the converted object value is not null.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • VALIDATOR_ID

        public static final String VALIDATOR_ID

        The standard converter id for this converter.

        See Also:
        Constant Field Values

    • Constructor Detail

      • RequiredValidator

        public RequiredValidator()

    • Method Detail

      • validate

        public void validate(FacesContext context,
            UIComponent component,
            Object value)

        Verify that the converted object value is not null.

        Specified by:
        validate in interface Validator
        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent we are checking for correctness
        value - the value to validate
        Throws:
        ValidatorException - if validation fails
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.validator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.validator

  • Packages that use javax.faces.validator
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
  • Classes in javax.faces.validator used by javax.faces.application
    Class and Description
    Validator
    A Validator implementation is a class that can perform validation (correctness checks) on a EditableValueHolder.
  • Classes in javax.faces.validator used by javax.faces.component
    Class and Description
    Validator
    A Validator implementation is a class that can perform validation (correctness checks) on a EditableValueHolder.
  • Classes in javax.faces.validator used by javax.faces.validator
    Class and Description
    Validator
    A Validator implementation is a class that can perform validation (correctness checks) on a EditableValueHolder.
    ValidatorException
    A ValidatorException is an exception thrown by the validate() method of a Validator to indicate that validation failed.
  • Classes in javax.faces.validator used by javax.faces.webapp
    Class and Description
    Validator
    A Validator implementation is a class that can perform validation (correctness checks) on a EditableValueHolder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Validator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.validator

Interface Validator

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    BeanValidator, DoubleRangeValidator, LengthValidator, LongRangeValidator, MethodExpressionValidator, RegexValidator, RequiredValidator

    public interface Validator
extends EventListener

    A Validator implementation is a class that can perform validation (correctness checks) on a EditableValueHolder. Zero or more Validators can be associated with each EditableValueHolder in the view, and are called during the Process Validations phase of the request processing lifecycle.

    Individual Validators should examine the value and component that they are passed, and throw a ValidatorException containing a FacesMessage, documenting any failures to conform to the required rules.

    For maximum generality, Validator instances may be configurable based on properties of the Validator implementation class. For example, a range check Validator might support configuration of the minimum and maximum values to be used.

    Validator implementations must have a zero-arguments public constructor. In addition, if the Validator class wishes to have configuration property values saved and restored with the view, the implementation must also implement StateHolder.

    If the class implementing Validator has a ResourceDependency annotation, the action described in ResourceDependency must be taken when EditableValueHolder.addValidator(javax.faces.validator.Validator) is called. If the class implementing Validator has a ResourceDependencies annotation, the action described in ResourceDependencies must be taken when EditableValueHolder.addValidator(javax.faces.validator.Validator) is called.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String NOT_IN_RANGE_MESSAGE_ID
      Deprecated.
      Use DoubleRangeValidator.NOT_IN_RANGE_MESSAGE_ID or LongRangeValidator.NOT_IN_RANGE_MESSAGE_ID instead.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void validate(FacesContext context, UIComponent component, Object value)
      Perform the correctness checks implemented by this Validator against the specified UIComponent.

    • Field Detail

      • NOT_IN_RANGE_MESSAGE_ID

        static final String NOT_IN_RANGE_MESSAGE_ID
        Deprecated. Use DoubleRangeValidator.NOT_IN_RANGE_MESSAGE_ID or LongRangeValidator.NOT_IN_RANGE_MESSAGE_ID instead.

        The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set. The message format string for this message may optionally include a {0} placeholder, which will be replaced by the configured minimum value, and a {1} placeholder, which will be replaced by the configured maximum value.

        See Also:
        Constant Field Values

    • Method Detail

      • validate

        void validate(FacesContext context,
            UIComponent component,
            Object value)
              throws ValidatorException

        Perform the correctness checks implemented by this Validator against the specified UIComponent. If any violations are found, a ValidatorException will be thrown containing the FacesMessage describing the failure.

        For a validator to be fully compliant with Version 2 and later of the specification, it must not fail validation on null or empty values unless it is specifically intended to address null or empty values. An application-wide <context-param> is provided to allow validators designed for JSF 1.2 to work with JSF 2 and later. The javax.faces.VALIDATE_EMPTY_FIELDS <context-param> must be set to false to enable this backwards compatibility behavior.

        Parameters:
        context - FacesContext for the request we are processing
        component - UIComponent we are checking for correctness
        value - the value to validate
        Throws:
        ValidatorException - if validation fails
        NullPointerException - if context or component is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidatorException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.validator

Class ValidatorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.validator.ValidatorException
  • All Implemented Interfaces:
    Serializable

    public class ValidatorException
extends FacesException

    A ValidatorException is an exception thrown by the validate() method of a Validator to indicate that validation failed.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidatorException(Collection<FacesMessage> messages)

      Allow this one exception to contain multiple messages.
      ValidatorException(Collection<FacesMessage> messages, Throwable cause)

      Allow this one exception to contain multiple messages, while passing on the root cause to the superclass
      ValidatorException(FacesMessage message)
      Construct a new exception with the specified message and no root cause.
      ValidatorException(FacesMessage message, Throwable cause)
      Construct a new exception with the specified detail message and root cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      FacesMessage getFacesMessage()

      Returns the FacesMessage associated with the exception.
      Collection<FacesMessage> getFacesMessages()

      If this instance was created with a constructor that takes Collection<FacesMessage>, this method returns the passed collection, otherwise this method returns null.

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ValidatorException

        public ValidatorException(FacesMessage message)

        Construct a new exception with the specified message and no root cause.

        Parameters:
        message - The message for this exception

      • ValidatorException

        public ValidatorException(Collection<FacesMessage> messages)

        Allow this one exception to contain multiple messages.

        Parameters:
        messages -
        Since:
        2.0

      • ValidatorException

        public ValidatorException(FacesMessage message,
                  Throwable cause)

        Construct a new exception with the specified detail message and root cause.

        Parameters:
        message - The detail message for this exception
        cause - The root cause for this exception

      • ValidatorException

        public ValidatorException(Collection<FacesMessage> messages,
                  Throwable cause)

        Allow this one exception to contain multiple messages, while passing on the root cause to the superclass

        Parameters:
        messages - the detail messages for this exception
        cause - the root cause for this exception
        Since:
        2.0

    • Method Detail

      • getFacesMessage

        public FacesMessage getFacesMessage()

        Returns the FacesMessage associated with the exception. If this instance was created with a constructor that takes Collection<FacesMessage>, this method returns the first message in the Collection

      • getFacesMessages

        public Collection<FacesMessage> getFacesMessages()

        If this instance was created with a constructor that takes Collection<FacesMessage>, this method returns the passed collection, otherwise this method returns null.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.faces.validator.BeanValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.validator.BeanValidator

No usage of javax.faces.validator.BeanValidator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.validator.DoubleRangeValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.validator.DoubleRangeValidator

No usage of javax.faces.validator.DoubleRangeValidator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.validator.FacesValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.validator.FacesValidator

No usage of javax.faces.validator.FacesValidator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.validator.LengthValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.validator.LengthValidator

No usage of javax.faces.validator.LengthValidator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.validator.LongRangeValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.validator.LongRangeValidator

No usage of javax.faces.validator.LongRangeValidator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.validator.MethodExpressionValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.validator.MethodExpressionValidator

No usage of javax.faces.validator.MethodExpressionValidator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.validator.RegexValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.validator.RegexValidator

No usage of javax.faces.validator.RegexValidator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.validator.RequiredValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.validator.RequiredValidator

No usage of javax.faces.validator.RequiredValidator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.validator.ValidatorException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.validator.ValidatorException

  • Packages that use ValidatorException
    Package Description
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.

    • Uses of ValidatorException in javax.faces.validator

      Methods in javax.faces.validator that throw ValidatorException
      Modifier and Type | Method and Description
      void Validator.validate(FacesContext context, UIComponent component, Object value)
      Perform the correctness checks implemented by this Validator against the specified UIComponent.
      void | MethodExpressionValidator.validate(FacesContext context, UIComponent component, Object value)
      void | LongRangeValidator.validate(FacesContext context, UIComponent component, Object value)
      void | LengthValidator.validate(FacesContext context, UIComponent component, Object value)
      void | DoubleRangeValidator.validate(FacesContext context, UIComponent component, Object value)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.validator.Validator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.validator.Validator

  • Packages that use Validator
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.component
    Fundamental APIs for user interface components.
    javax.faces.validator
    Interface defining the validator model, and concrete validator implementation classes.
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of Validator in javax.faces.application

      Methods in javax.faces.application that return Validator
      Modifier and Type Method and Description
      Validator ApplicationWrapper.createValidator(String validatorId)

      The default behavior of this method is to call Application.createValidator(String) on the wrapped Application object.
      abstract Validator Application.createValidator(String validatorId)
      Instantiate and return a new Validator instance of the class specified by a previous call to addValidator() for the specified validator id.

    • Uses of Validator in javax.faces.component

      Methods in javax.faces.component that return Validator
      Modifier and Type Method and Description
      Validator[] UIInput.getValidators()
      Return the set of registered Validators for this UIInput instance.
      Validator[] EditableValueHolder.getValidators()
      Return the set of registered Validators for this component instance.
      Methods in javax.faces.component with parameters of type Validator
      Modifier and Type Method and Description
      void UIInput.addValidator(Validator validator)
      Add a Validator instance to the set associated with this UIInput.
      void EditableValueHolder.addValidator(Validator validator)
      Add a Validator instance to the set associated with this component.
      void UIInput.removeValidator(Validator validator)
      Remove a Validator instance from the set associated with this UIInput, if it was previously associated.
      void EditableValueHolder.removeValidator(Validator validator)
      Remove a Validator instance from the set associated with this component, if it was previously associated.

    • Uses of Validator in javax.faces.validator

      Classes in javax.faces.validator that implement Validator
      Modifier and Type Class and Description
      class  BeanValidator

      A Validator that delegates validation of the bean property to the Bean Validation API.
      class  DoubleRangeValidator
      DoubleRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
      class  LengthValidator
      LengthValidator is a Validator that checks the number of characters in the String representation of the value of the associated component.
      class  LongRangeValidator
      LongRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
      class  MethodExpressionValidator
      MethodExpressionValidator is a Validator that wraps a MethodExpression, and it performs validation by executing a method on an object identified by the MethodExpression.
      class  RegexValidator

      A Validator that checks against a Regular Expression (which is the pattern property).
      class  RequiredValidator

      A Validator that checks for an empty value in the same way that UIInput checks for a value.

    • Uses of Validator in javax.faces.webapp

      Methods in javax.faces.webapp that return Validator
      Modifier and Type Method and Description
      protected Validator ValidatorTag.createValidator()
      Deprecated.
      Create and return a new Validator to be registered on our surrounding UIComponent.
      protected abstract Validator ValidatorELTag.createValidator()
      Create and return a new Validator to be registered on our surrounding UIComponent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ActionSource2AttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Interface ActionSource2AttachedObjectHandler

  • All Superinterfaces:
    AttachedObjectHandler

    public interface ActionSource2AttachedObjectHandler
extends AttachedObjectHandler

    A VDL handler that exposes ActionListener to a page author. The default implementation of Facelets must provide an implemention of this in the handler for the <f:actionListener> tag.

    Since:
    2.0

    • Method Summary

      • Methods inherited from interface javax.faces.view.AttachedObjectHandler

        applyAttachedObject, getFor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ActionSource2AttachedObjectTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Interface ActionSource2AttachedObjectTarget

  • All Superinterfaces:
    AttachedObjectTarget

    public interface ActionSource2AttachedObjectTarget
extends AttachedObjectTarget

    A marker interface for VDL tags that represent <composite:actionSource/> for use by the composite component page author.

    Since:
    2.0

    • Field Summary

      • Fields inherited from interface javax.faces.view.AttachedObjectTarget

        ATTACHED_OBJECT_TARGETS_KEY

    • Method Summary

      • Methods inherited from interface javax.faces.view.AttachedObjectTarget

        getName, getTargets
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Interface AttachedObjectHandler

  • All Known Subinterfaces:
    ActionSource2AttachedObjectHandler, BehaviorHolderAttachedObjectHandler, EditableValueHolderAttachedObjectHandler, ValueHolderAttachedObjectHandler
    All Known Implementing Classes:
    BehaviorHandler, ConverterHandler, FaceletsAttachedObjectHandler, ValidatorHandler

    public interface AttachedObjectHandler

    The abstract base interface for a handler representing an attached object in a VDL page. Subinterfaces are provided for the common attached objects that expose Behavior, Converters, Validators, ValueChangeListeners, and ActionListeners for use by page authors.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void applyAttachedObject(FacesContext context, UIComponent parent)

      Take the argument parent and apply this attached object to it.
      String getFor()

      Return the value of the "for" attribute specified by the page author on the tag for this AttachedObjectHandler.

    • Method Detail

      • applyAttachedObject

        void applyAttachedObject(FacesContext context,
                       UIComponent parent)

        Take the argument parent and apply this attached object to it. The action taken varies with class that implements one of the subinterfaces of this interface.

        Parameters:
        context - The FacesContext for this request
        parent - The UIComponent to which this particular attached object must be applied.

      • getFor

        String getFor()

        Return the value of the "for" attribute specified by the page author on the tag for this AttachedObjectHandler.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AttachedObjectTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Interface AttachedObjectTarget

  • All Known Subinterfaces:
    ActionSource2AttachedObjectTarget, BehaviorHolderAttachedObjectTarget, EditableValueHolderAttachedObjectTarget, ValueHolderAttachedObjectTarget

    public interface AttachedObjectTarget

    Within the declaration of a composite component, an AttachedObjectTarget allows the composite component author to expose the semantics of an inner component to the page author without exposing the rendering or implementation details of the inner component. See ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource) for the context in which implementations of this interface are used.

    The implementation must ensure that this instance is thread safe and may be shared among different component trees.

    Subinterfaces are provided for the common behavioral interfaces: Behavior, ValueHolder, EditableValueHolder and ActionSource2. The default VDL implementation must provide a corresponding Facelets tag handler for each of the subinterfaces of this interface.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ATTACHED_OBJECT_TARGETS_KEY

      The key in the value set of the composite component BeanDescriptor, the value for which is a List<AttachedObjectTarget>.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()

      Returns the name by which this attached object target is exposed to the page author.
      List<UIComponent> getTargets(UIComponent topLevelComponent)

      Returns the List<UIComponent> that this AttachedObjectTarget exposes.

    • Field Detail

      • ATTACHED_OBJECT_TARGETS_KEY

        static final String ATTACHED_OBJECT_TARGETS_KEY

        The key in the value set of the composite component BeanDescriptor, the value for which is a List<AttachedObjectTarget>.

        See Also:
        Constant Field Values

    • Method Detail

      • getTargets

        List<UIComponent> getTargets(UIComponent topLevelComponent)

        Returns the List<UIComponent> that this AttachedObjectTarget exposes. Each attached object exposed by the composite component author may point at multiple UIComponent instances within the composite component. This method is used by the ViewDeclarationLanguage.retargetAttachedObjects(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.util.List<javax.faces.view.AttachedObjectHandler>) method to take the appropriate action on the attached object.

      • getName

        String getName()

        Returns the name by which this attached object target is exposed to the page author.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BehaviorHolderAttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Interface BehaviorHolderAttachedObjectHandler

  • All Superinterfaces:
    AttachedObjectHandler
    All Known Implementing Classes:
    BehaviorHandler

    public interface BehaviorHolderAttachedObjectHandler
extends AttachedObjectHandler

    Represent an attached object that is a BehaviorHolder in a VDL page.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getEventName()

      Return the client event name to which this behavior applies.

      • Methods inherited from interface javax.faces.view.AttachedObjectHandler

        applyAttachedObject, getFor

    • Method Detail

      • getEventName

        String getEventName()

        Return the client event name to which this behavior applies.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BehaviorHolderAttachedObjectTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Interface BehaviorHolderAttachedObjectTarget

  • All Superinterfaces:
    AttachedObjectTarget

    public interface BehaviorHolderAttachedObjectTarget
extends AttachedObjectTarget

    Represent a BehaviorHolder attached object target in a VDL page.

    • Field Summary

      • Fields inherited from interface javax.faces.view.AttachedObjectTarget

        ATTACHED_OBJECT_TARGETS_KEY

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      boolean | isDefaultEvent()

      • Methods inherited from interface javax.faces.view.AttachedObjectTarget

        getName, getTargets

    • Method Detail

      • isDefaultEvent

        boolean isDefaultEvent()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EditableValueHolderAttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Interface EditableValueHolderAttachedObjectHandler

  • All Superinterfaces:
    AttachedObjectHandler, ValueHolderAttachedObjectHandler
    All Known Implementing Classes:
    ValidatorHandler

    public interface EditableValueHolderAttachedObjectHandler
extends ValueHolderAttachedObjectHandler

    A VDL handler that exposes Validator or ValueChangeListener to a page author. The default implementation of Facelets must provide an implemention of this in the handler for the <f:validator> (and any tags for any of the standard validators) and <f:valueChangeListener> tags.

    Since:
    2.0

    • Method Summary

      • Methods inherited from interface javax.faces.view.AttachedObjectHandler

        applyAttachedObject, getFor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EditableValueHolderAttachedObjectTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Interface EditableValueHolderAttachedObjectTarget

  • All Superinterfaces:
    AttachedObjectTarget, ValueHolderAttachedObjectTarget

    public interface EditableValueHolderAttachedObjectTarget
extends ValueHolderAttachedObjectTarget

    A marker interface for VDL tags that represent <composite:editableValueHolder/> for use by the composite component page author.

    Since:
    2.0

    • Field Summary

      • Fields inherited from interface javax.faces.view.AttachedObjectTarget

        ATTACHED_OBJECT_TARGETS_KEY

    • Method Summary

      • Methods inherited from interface javax.faces.view.AttachedObjectTarget

        getName, getTargets
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces.view (Java(TM) EE 7 Specification APIs)

javax.faces.view

Interfaces

  • ActionSource2AttachedObjectHandler
  • ActionSource2AttachedObjectTarget
  • AttachedObjectHandler
  • AttachedObjectTarget
  • BehaviorHolderAttachedObjectHandler
  • BehaviorHolderAttachedObjectTarget
  • EditableValueHolderAttachedObjectHandler
  • EditableValueHolderAttachedObjectTarget
  • ValueHolderAttachedObjectHandler
  • ValueHolderAttachedObjectTarget

Classes

  • Location
  • StateManagementStrategy
  • ViewDeclarationLanguage
  • ViewDeclarationLanguageFactory
  • ViewDeclarationLanguageWrapper
  • ViewMetadata

Annotation Types

  • ViewScoped


javax.faces.view (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.view

Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

See: Description

  • Interface Summary
    Interface Description
    ActionSource2AttachedObjectHandler

    A VDL handler that exposes ActionListener to a page author.
    ActionSource2AttachedObjectTarget

    A marker interface for VDL tags that represent <composite:actionSource/> for use by the composite component page author.
    AttachedObjectHandler

    The abstract base interface for a handler representing an attached object in a VDL page.
    AttachedObjectTarget

    Within the declaration of a composite component, an AttachedObjectTarget allows the composite component author to expose the semantics of an inner component to the page author without exposing the rendering or implementation details of the inner component.
    BehaviorHolderAttachedObjectHandler

    Represent an attached object that is a BehaviorHolder in a VDL page.
    BehaviorHolderAttachedObjectTarget

    Represent a BehaviorHolder attached object target in a VDL page.
    EditableValueHolderAttachedObjectHandler

    A VDL handler that exposes Validator or ValueChangeListener to a page author.
    EditableValueHolderAttachedObjectTarget

    A marker interface for VDL tags that represent <composite:editableValueHolder/> for use by the composite component page author.
    ValueHolderAttachedObjectHandler

    A VDL handler that exposes Converter to a page author.
    ValueHolderAttachedObjectTarget

    A marker interface for VDL tags that represent <composite:valueHolder/> for use by the composite component page author.
  • Class Summary
    Class Description
    Location

    An object that represents the Location of a tag or attribute of a tag in a View Declaration Language file.
    StateManagementStrategy

    Encapsulate the saving and restoring of the view to enable the VDL to take over the responsibility for handling this feature.
    ViewDeclarationLanguage

    The contract that a view declaration language must implement to interact with the JSF runtime.
    ViewDeclarationLanguageFactory

    ViewDeclarationLanguageFactory is a factory object that creates (if needed) and returns a new ViewDeclarationLanguage instance based on the VDL found in a specific view.
    ViewDeclarationLanguageWrapper

    Provides a simple implementation of ViewDeclarationLanguage that can be subclassed by developers wishing to provide specialized behavior to an existing ViewDeclarationLanguage instance.
    ViewMetadata

    ViewMetadata is reponsible for extracting and providing view parameter metadata from VDL views.
  • Annotation Types Summary
    Annotation Type Description
    ViewScoped

    When this annotation, along with javax.inject.Named is found on a class, the runtime must place the bean in a CDI scope such that it remains active as long as NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) does not cause a navigation to a view with a viewId that is different than the viewId of the current view.

Package javax.faces.view Description

Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces. The root class in this package is ViewDeclarationLanguageFactory. Interfaces and classes required for the Facelets for JSF 2 implementation are also defined in package javax.faces.view.facelets.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.view Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.view

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.view.Location (implements java.io.Serializable)
    • javax.faces.view.StateManagementStrategy
    • javax.faces.view.ViewDeclarationLanguage
      • javax.faces.view.ViewDeclarationLanguageWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.view.ViewDeclarationLanguageFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.view.ViewMetadata

Interface Hierarchy

  • javax.faces.view.AttachedObjectHandler
    • javax.faces.view.ActionSource2AttachedObjectHandler
    • javax.faces.view.BehaviorHolderAttachedObjectHandler
    • javax.faces.view.ValueHolderAttachedObjectHandler
      • javax.faces.view.EditableValueHolderAttachedObjectHandler
  • javax.faces.view.AttachedObjectTarget
    • javax.faces.view.ActionSource2AttachedObjectTarget
    • javax.faces.view.BehaviorHolderAttachedObjectTarget
    • javax.faces.view.ValueHolderAttachedObjectTarget
      • javax.faces.view.EditableValueHolderAttachedObjectTarget

Annotation Type Hierarchy

  • javax.faces.view.ViewScoped (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Location (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Class Location

  • java.lang.Object
    • javax.faces.view.Location
  • All Implemented Interfaces:
    Serializable

    public class Location
extends Object
implements Serializable

    An object that represents the Location of a tag or attribute of a tag in a View Declaration Language file.

    Since:
    2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      Location(String path, int line, int column)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getColumn()

      Return the estimated character column.
      int getLine()

      Return the line number in the page for this location.
      String getPath()

      Return the file path to the page represented by this location.
      String toString()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Location

        public Location(String path,
        int line,
        int column)

    • Method Detail

      • getColumn

        public int getColumn()

        Return the estimated character column.

      • getLine

        public int getLine()

        Return the line number in the page for this location.

      • getPath

        public String getPath()

        Return the file path to the page represented by this location.

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StateManagementStrategy (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Class StateManagementStrategy

  • java.lang.Object
    • javax.faces.view.StateManagementStrategy

  • public abstract class StateManagementStrategy
extends Object

    Encapsulate the saving and restoring of the view to enable the VDL to take over the responsibility for handling this feature. Because ViewDeclarationLanguage.getStateManagementStrategy(javax.faces.context.FacesContext, java.lang.String) is required to return null for JSP views and non-null for views authored in Facelets for JSF 2, this specification only applys to Facelets for JSF 2.

    Implementations must call UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback) on the UIViewRoot to perform the saving and restoring of the view in the saveView(javax.faces.context.FacesContext) and restoreView(javax.faces.context.FacesContext, java.lang.String, java.lang.String) methods, respectively.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      StateManagementStrategy()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract UIViewRoot restoreView(FacesContext context, String viewId, String renderKitId)

      Restore the state of the view with information in the request.
      abstract Object saveView(FacesContext context)

      Return the state of the current view in an Object that implements Serializable and can be passed to java.io.ObjectOutputStream.writeObject() without causing a java.io.NotSerializableException to be thrown. The default implementation must perform the following algorithm or its semantic equivalent, explicitly performing all the steps listed here.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • StateManagementStrategy

        public StateManagementStrategy()

    • Method Detail

      • saveView

        public abstract Object saveView(FacesContext context)

        Return the state of the current view in an Object that implements Serializable and can be passed to java.io.ObjectOutputStream.writeObject() without causing a java.io.NotSerializableException to be thrown. The default implementation must perform the following algorithm or its semantic equivalent, explicitly performing all the steps listed here.

        1. If the UIViewRoot of the current view is marked transient, return null immediately.

        2. Traverse the view and verify that each of the client ids are unique. Throw IllegalStateException if more than one client id are the same.

        3. Visit the tree using UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback). For each node, call StateHolder.saveState(javax.faces.context.FacesContext), saving the returned Object in a way such that it can be restored given only its client id. Special care must be taken to handle the case of components that were added or deleted programmatically during this lifecycle traversal, rather than by the VDL.

        The implementation must ensure that the StateHolder.saveState(javax.faces.context.FacesContext) method is called for each node in the tree.

        The data structure used to save the state obtained by executing the above algorithm must be Serializable, and all of the elements within the data structure must also be Serializable.

        Parameters:
        context - the FacesContext for this request.
        Since:
        2.0

      • restoreView

        public abstract UIViewRoot restoreView(FacesContext context,
                     String viewId,
                     String renderKitId)

        Restore the state of the view with information in the request. The default implementation must perform the following algorithm or its semantic equivalent.

        1. As in the case of restore view on an initial request, the view metadata must be restored and properly handled as well. Obtain the ViewMetadata for the current viewId, and from that call ViewMetadata.createMetadataView(javax.faces.context.FacesContext). Store the resultant UIViewRoot in the FacesContext. Obtain the state of the UIViewRoot from the state Object returned from ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String) and pass that to UIViewRoot.restoreViewScopeState(javax.faces.context.FacesContext, java.lang.Object).

          Build the view from the markup. For all components in the view that do not have an explicitly assigned id in the markup, the values of those ids must be the same as on an initial request for this view. This view will not contain any components programmatically added during the previous lifecycle run, and it will contain components that were programmatically deleted on the previous lifecycle run. Both of these cases must be handled.

        2. Call ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String) to obtain the data structure returned from the previous call to saveView(javax.faces.context.FacesContext).

        3. Visit the tree using UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback). For each node, call StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object), passing the state saved corresponding to the current client id.

        4. Ensure that any programmatically deleted components are removed.

        5. Ensure any programmatically added components are added.

        The implementation must ensure that the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method is called for each node in the tree, except for those that were programmatically deleted on the previous run through the lifecycle.

        Parameters:
        context - the FacesContext for this request
        viewId - the view identifier for which the state should be restored
        renderKitId - the render kit id for this state.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.view (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.view

  • Packages that use javax.faces.view
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
  • Classes in javax.faces.view used by javax.faces.application
    Class and Description
    ViewDeclarationLanguage

    The contract that a view declaration language must implement to interact with the JSF runtime.
  • Classes in javax.faces.view used by javax.faces.view
    Class and Description
    AttachedObjectHandler

    The abstract base interface for a handler representing an attached object in a VDL page.
    AttachedObjectTarget

    Within the declaration of a composite component, an AttachedObjectTarget allows the composite component author to expose the semantics of an inner component to the page author without exposing the rendering or implementation details of the inner component.
    StateManagementStrategy

    Encapsulate the saving and restoring of the view to enable the VDL to take over the responsibility for handling this feature.
    ValueHolderAttachedObjectHandler

    A VDL handler that exposes Converter to a page author.
    ValueHolderAttachedObjectTarget

    A marker interface for VDL tags that represent <composite:valueHolder/> for use by the composite component page author.
    ViewDeclarationLanguage

    The contract that a view declaration language must implement to interact with the JSF runtime.
    ViewDeclarationLanguageFactory

    ViewDeclarationLanguageFactory is a factory object that creates (if needed) and returns a new ViewDeclarationLanguage instance based on the VDL found in a specific view.
    ViewMetadata

    ViewMetadata is reponsible for extracting and providing view parameter metadata from VDL views.
  • Classes in javax.faces.view used by javax.faces.view.facelets
    Class and Description
    AttachedObjectHandler

    The abstract base interface for a handler representing an attached object in a VDL page.
    BehaviorHolderAttachedObjectHandler

    Represent an attached object that is a BehaviorHolder in a VDL page.
    EditableValueHolderAttachedObjectHandler

    A VDL handler that exposes Validator or ValueChangeListener to a page author.
    Location

    An object that represents the Location of a tag or attribute of a tag in a View Declaration Language file.
    ValueHolderAttachedObjectHandler

    A VDL handler that exposes Converter to a page author.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValueHolderAttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Interface ValueHolderAttachedObjectHandler

  • All Superinterfaces:
    AttachedObjectHandler
    All Known Subinterfaces:
    EditableValueHolderAttachedObjectHandler
    All Known Implementing Classes:
    ConverterHandler, ValidatorHandler

    public interface ValueHolderAttachedObjectHandler
extends AttachedObjectHandler

    A VDL handler that exposes Converter to a page author. The default implementation of Facelets must provide an implemention of this in the handler for the <f:converter> (and any tags for any of the standard converters) tags.

    Since:
    2.0

    • Method Summary

      • Methods inherited from interface javax.faces.view.AttachedObjectHandler

        applyAttachedObject, getFor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValueHolderAttachedObjectTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Interface ValueHolderAttachedObjectTarget

  • All Superinterfaces:
    AttachedObjectTarget
    All Known Subinterfaces:
    EditableValueHolderAttachedObjectTarget

    public interface ValueHolderAttachedObjectTarget
extends AttachedObjectTarget

    A marker interface for VDL tags that represent <composite:valueHolder/> for use by the composite component page author.

    Since:
    2.0

    • Field Summary

      • Fields inherited from interface javax.faces.view.AttachedObjectTarget

        ATTACHED_OBJECT_TARGETS_KEY

    • Method Summary

      • Methods inherited from interface javax.faces.view.AttachedObjectTarget

        getName, getTargets
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ViewDeclarationLanguage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Class ViewDeclarationLanguage

  • java.lang.Object
    • javax.faces.view.ViewDeclarationLanguage
  • Direct Known Subclasses:
    ViewDeclarationLanguageWrapper

    public abstract class ViewDeclarationLanguage
extends Object

    The contract that a view declaration language must implement to interact with the JSF runtime. An implementation of this class must be thread-safe.

    Instances of this class are application scoped and must be obtained from the ViewDeclarationLanguageFactory.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FACELETS_VIEW_DECLARATION_LANGUAGE_ID

      Identifier for the Facelets view declaration language.
      static String JSP_VIEW_DECLARATION_LANGUAGE_ID

      Identifier for the JSP view declaration language.

    • Constructor Summary

      Constructors
      Constructor and Description
      ViewDeclarationLanguage()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void buildView(FacesContext context, UIViewRoot root)

      Take any actions specific to this VDL implementation to cause the argument UIViewRoot which must have been created via a call to createView(javax.faces.context.FacesContext, java.lang.String), to be populated with children.
      List<String> calculateResourceLibraryContracts(FacesContext context, String viewId)

      Return the list of resource library contracts that will be made available for use in the view specified by the argument viewId.
      UIComponent createComponent(FacesContext context, String taglibURI, String tagName, Map<String,Object> attributes)

      Create a component given a ViewDeclarationLanguage specific tag library URI and tag name.
      abstract UIViewRoot createView(FacesContext context, String viewId)

      Create a UIViewRoot from the VDL contained in the artifact referenced by the argument viewId.
      abstract BeanInfo getComponentMetadata(FacesContext context, Resource componentResource)

      Return a reference to the component metadata for the composite component represented by the argument componentResource, or null if the metadata cannot be found.
      String getId()

      Returns a non-null String that can be used to identify this view declaration language.
      abstract Resource getScriptComponentResource(FacesContext context, Resource componentResource)

      Take implementation specific action to discover a Resource given the argument componentResource.
      abstract StateManagementStrategy getStateManagementStrategy(FacesContext context, String viewId)

      For implementations that want to control the implementation of state saving and restoring, the StateManagementStrategy allows them to do so.
      abstract ViewMetadata getViewMetadata(FacesContext context, String viewId)

      Return a reference to the view metadata for the view represented by the argument viewId, or null if the metadata cannot be found.
      abstract void renderView(FacesContext context, UIViewRoot view)

      Render a view rooted at argumentview.
      abstract UIViewRoot restoreView(FacesContext context, String viewId)

      Restore a UIViewRoot from a previously created view.
      void retargetAttachedObjects(FacesContext context, UIComponent topLevelComponent, List<AttachedObjectHandler> handlers)

      Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting attached objects from the top level composite component to the individual AttachedObjectTarget instances inside the composite component.
      void retargetMethodExpressions(FacesContext context, UIComponent topLevelComponent)

      Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting any method expressions from the top level component to the appropriate inner component.
      boolean viewExists(FacesContext context, String viewId)

      Tests whether a physical resource corresponding to the specified viewId exists.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • JSP_VIEW_DECLARATION_LANGUAGE_ID

        public static final String JSP_VIEW_DECLARATION_LANGUAGE_ID

        Identifier for the JSP view declaration language.

        Since:
        2.1
        See Also:
        Constant Field Values

      • FACELETS_VIEW_DECLARATION_LANGUAGE_ID

        public static final String FACELETS_VIEW_DECLARATION_LANGUAGE_ID

        Identifier for the Facelets view declaration language.

        Since:
        2.1
        See Also:
        Constant Field Values

    • Constructor Detail

      • ViewDeclarationLanguage

        public ViewDeclarationLanguage()

    • Method Detail

      • getComponentMetadata

        public abstract BeanInfo getComponentMetadata(FacesContext context,
                            Resource componentResource)

        Return a reference to the component metadata for the composite component represented by the argument componentResource, or null if the metadata cannot be found. See section JSF.7.7.2 for the specification of the default implementation. JSP implementations must throw UnsupportedOperationException.

        Parameters:
        context - The FacesContext for this request.
        componentResource - The Resource that represents the component.
        Throws:
        NullPointerException - if any of the arguments are null.
        FacesException - if there is an error in obtaining the metadata
        UnsupportedOperationException - if this is a JSP VDL implementation.
        Since:
        2.0

      • getViewMetadata

        public abstract ViewMetadata getViewMetadata(FacesContext context,
                           String viewId)

        Return a reference to the view metadata for the view represented by the argument viewId, or null if the metadata cannot be found. See section JSF.7.7.2 for the specification of the default implementation. Facelets for JSF 2 implementation must return non-null. JSP implementations must return null.

        Parameters:
        context - The FacesContext for this request.
        viewId - the view id from whith to extract the metadata
        Throws:
        NullPointerException - if any of the arguments are null.
        FacesException - if there is an error in obtaining the metadata
        Since:
        2.0

      • getScriptComponentResource

        public abstract Resource getScriptComponentResource(FacesContext context,
                                  Resource componentResource)

        Take implementation specific action to discover a Resource given the argument componentResource. See section JSF.7.7.2 for the specification of the default implementation. JSP implementations must throw UnsupportedOperationException.

        Parameters:
        context - The FacesContext for this request.
        componentResource - The Resource that represents the component.
        Throws:
        NullPointerException - if any of the arguments are null.
        FacesException - if there is an error in obtaining the script component resource
        UnsupportedOperationException - if this is a JSP VDL implementation.
        Since:
        2.0

      • createView

        public abstract UIViewRoot createView(FacesContext context,
                    String viewId)

        Create a UIViewRoot from the VDL contained in the artifact referenced by the argument viewId. See section JSF.7.7.2 for the specification of the default implementation.

        Parameters:
        context - the FacesContext for this request.
        viewId - the identifier of an artifact that contains the VDL syntax that describes this view.
        Throws:
        NullPointerException - if any of the arguments are null
        Since:
        2.0

      • createComponent

        public UIComponent createComponent(FacesContext context,
                          String taglibURI,
                          String tagName,
                          Map<String,Object> attributes)

        Create a component given a ViewDeclarationLanguage specific tag library URI and tag name. The runtime must support this method operating for the Facelets VDL. Other kinds of ViewDeclarationLanguage may be supported but are not required to be supported. For backward compatibility with decorated ViewDeclrationLanguage implementations that do not override this method, a default implementation is provided that returns null. However, any implementation that is compliant with the version of the specification in which this method was introduced must implement this method.

        Parameters:
        context - the FacesContext for this request
        taglibURI - the fully qualified tag library URI that contains the component
        tagName - the name of the tag within that library that exposes the component
        attributes - any name=value pairs that would otherwise have been given on the markup that would cause the creation of this component or null if no attributes need be given.
        Throws:
        NullPointerException - if context, taglibURI, or tagName are null
        Since:
        2.2

      • restoreView

        public abstract UIViewRoot restoreView(FacesContext context,
                     String viewId)

        Restore a UIViewRoot from a previously created view. See section JSF.7.7.2 for the specification of the default implementation.

        Parameters:
        context - the FacesContext for this request.
        viewId - the identifier for a previously rendered view.
        Throws:
        NullPointerException - if any of the arguments are null

      • retargetAttachedObjects

        public void retargetAttachedObjects(FacesContext context,
                           UIComponent topLevelComponent,
                           List<AttachedObjectHandler> handlers)

        Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting attached objects from the top level composite component to the individual AttachedObjectTarget instances inside the composite component. This method must be called by the ViewDeclarationLanguage implementation when creating the UIComponent tree when a composite component usage is encountered.

        An algorithm semantically equivalent to the following must be implemented.

        • Obtain the metadata for the composite component. Currently this entails getting the value of the UIComponent.BEANINFO_KEY component attribute, which will be an instance of BeanInfo. If the metadata cannot be found, log an error message and return.

        • Get the BeanDescriptor from the BeanInfo.

        • Get the value of the AttachedObjectTarget.ATTACHED_OBJECT_TARGETS_KEY from the BeanDescriptor's getValue() method. This will be a List<AttachedObjectTarget>. Let this be targetList.

        • For each curHandler entry in the argument handlers

          • Let forAttributeValue be the return from AttachedObjectHandler.getFor().

          • For each curTarget entry in targetList, the first of the following items that causes a match will take this action:

            For each UIComponent in the list returned from curTarget.getTargets(), call curHandler.applyAttachedObject(), passing the FacesContext and the UIComponent.

            and cause this inner loop to terminate.

            • If curHandler is an instance of ActionSource2AttachedObjectHandler and curTarget is an instance of ActionSource2AttachedObjectTarget, and curTarget.getName() is equal to curTargetName, consider it a match.

            • If curHandler is an instance of EditableValueHolderAttachedObjectHandler and curTarget is an instance of EditableValueHolderAttachedObjectTarget, and curTarget.getName() is equal to curTargetName, consider it a match.

            • If curHandler is an instance of ValueHolderAttachedObjectHandler and curTarget is an instance of ValueHolderAttachedObjectTarget, and curTarget.getName() is equal to curTargetName, consider it a match.

            • If curHandler is an instance of BehaviorHolderAttachedObjectHandler and curTarget is an instance of BehaviorHolderAttachedObjectTarget, and either of the following conditions are true,

              • curHandler.getEventName() is not null and is equal to curTargetName.
              • curHandler.getEventName() is null and curTarget.isDefaultEvent() is true.

              consider it a match.

        The implementation must support retargeting attached objects from the top level compsite component to targets that are composite and non-composite components.

        An implementation is provided that will throw UnsupportedOperationException. A Faces implementation compliant with version 2.0 and beyond of the specification must override this method.

        Parameters:
        context - the FacesContext for this request.
        topLevelComponent - The UIComponent in the view to which the attached objects must be attached. This UIComponent must have its component metadata already associated and available from via the JavaBeans API.
        Throws:
        NullPointerException - if any of the arguments are null.
        Since:
        2.0

      • retargetMethodExpressions

        public void retargetMethodExpressions(FacesContext context,
                             UIComponent topLevelComponent)

        Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting any method expressions from the top level component to the appropriate inner component. For each attribute that is a MethodExpression (as indicated by the presence of a "method-signature" attribute and the absence of a "type" attribute), the following action must be taken:

        • Get the value of the targets attribute. If the value is a ValueExpression evaluate it. If there is no targets attribute, let the name of the metadata element be the evaluated value of the targets attribute.

        • Interpret targets as a space (not tab) separated list of ids. For each entry in the list:

          • Find the inner component of the topLevelComponent with the id equal to the current list entry. For discussion, this component is called target. If not found, log and error and continue to the next attribute.

          • For discussion the declared name of the attribute is called name.

          • In the attributes map of the topLevelComponent, look up the entry under the key name. Assume the result is a ValueExpression. For discussion, this is attributeValueExpression. If not found, log an error and continue to the next attribute.

          • If name is equal to the string "action", or "actionListener" without the quotes, assume target is an ActionSource2.

          • If name is equal to the string "validator", or "valueChangeListener" without the quotes, assume target is an EditableValueHolder.

          • Call getExpressionString() on the attributeValueExpression and use that string to create a MethodExpression of the appropriate signature for name.

          • If name is not equal to any of the previously listed strings, call getExpressionString() on the attributeValueExpression and use that string to create a MethodExpression where the signature is created based on the value of the "method-signature" attribute of the <composite:attribute /> tag.

          • Let the resultant MethodExpression be called attributeMethodExpression for discussion.

          • If name is equal to the string "action" without the quotes, call ActionSource2.setActionExpression(javax.el.MethodExpression) on target, passing attributeMethodExpression.

          • If name is equal to the string "actionListener" without the quotes, call ActionSource.addActionListener(javax.faces.event.ActionListener) on target, passing attributeMethodExpression wrapped in a MethodExpressionActionListener.

          • If name is equal to the string "validator" without the quotes, call EditableValueHolder.addValidator(javax.faces.validator.Validator) on target, passing attributeMethodExpression wrapped in a MethodExpressionValidator.

          • If name is equal to the string "valueChangeListener" without the quotes, call EditableValueHolder.addValueChangeListener(javax.faces.event.ValueChangeListener) on target, passing attributeMethodExpression wrapped in a MethodExpressionValueChangeListener.

          • Otherwise, assume that the MethodExpression should be placed in the components attribute set. The runtme must create the MethodExpression instance based on the value of the "method-signature" attribute.

        An implementation is provided that will throw UnsupportedOperationException. A Faces implementation compliant with version 2.0 and beyond of the specification must override this method.

        Parameters:
        context - the FacesContext for this request.
        topLevelComponent - The UIComponent in the view to which the attached objects must be attached. This UIComponent must have its component metadata already associated and available from via the JavaBeans API.
        Throws:
        NullPointerException - if context or topLevelComponent is null.
        Since:
        2.0

      • calculateResourceLibraryContracts

        public List<String> calculateResourceLibraryContracts(FacesContext context,
                                             String viewId)

        Return the list of resource library contracts that will be made available for use in the view specified by the argument viewId. If no match is found, return an empty list. See section JSF.7.7.2 for the specification of the default implementation. For backward compatibility with prior implementations, an implementation is provided that returns null, but any implementation compliant with the version of the specification in which this method was introduced must implement it as specified in JSF.7.7.2.

        Parameters:
        context - the FacesContext for this request
        viewId - the view id for which the applicable resource library contracts should be calculated.
        Since:
        2.2

      • buildView

        public abstract void buildView(FacesContext context,
             UIViewRoot root)
                        throws IOException

        Take any actions specific to this VDL implementation to cause the argument UIViewRoot which must have been created via a call to createView(javax.faces.context.FacesContext, java.lang.String), to be populated with children.

        The Facelets implementation must insure that markup comprising the view must be executed, with the UIComponent instances in the view being encountered in the same depth-first order as in other lifecycle methods defined on UIComponent, and added to the view (but not rendered) during the traversal. The runtime must guarantee that the view must be fully populated before any of the following happen.

        • The PhaseListener.afterPhase(javax.faces.event.PhaseEvent) method of any PhaseListeners attached to the application is called

        • The UIViewRoot phase listener installed via UIViewRoot.setAfterPhaseListener(javax.el.MethodExpression) or UIViewRoot.addPhaseListener(javax.faces.event.PhaseListener) are called.

        If the root is already populated with children, the view must still be re-built, but care must be taken to ensure that the existing components are correctly paired up with their VDL counterparts in the VDL page. Also, any system events that would normally be generated during the adding or removing of components from the view must be temporarily disabled during the creation of the view and then re-enabled when the view has been built.

        Parameters:
        context - the FacesContext for this request
        root - the UIViewRoot to populate with children using techniques specific to this VDL implementation.
        Throws:
        IOException

      • renderView

        public abstract void renderView(FacesContext context,
              UIViewRoot view)
                         throws IOException

        Render a view rooted at argumentview. See section JSF.7.7.2 for the specification of the default implementation.

        Parameters:
        context - the FacesContext for this request.
        view - the UIViewRoot from an early call to createView(javax.faces.context.FacesContext, java.lang.String) or restoreView(javax.faces.context.FacesContext, java.lang.String).
        Throws:
        NullPointerException - if any of the arguments are null
        IOException

      • getStateManagementStrategy

        public abstract StateManagementStrategy getStateManagementStrategy(FacesContext context,
                                                 String viewId)

        For implementations that want to control the implementation of state saving and restoring, the StateManagementStrategy allows them to do so. Returning null indicates that the implementation wishes the runtime to handle the state saving and restoring. Implementations that provide the VDL for Facelets for JSF 2.0 and later must return non-null from this method.

        Since:
        2.0

      • viewExists

        public boolean viewExists(FacesContext context,
                 String viewId)

        Tests whether a physical resource corresponding to the specified viewId exists.

        The default implementation uses ResourceHandler.createViewResource(javax.faces.context.FacesContext, java.lang.String) to locate the physical resource.

        Parameters:
        context - The FacesContext for this request.
        viewId - the view id to test
        Since:
        2.1

      • getId

        public String getId()

        Returns a non-null String that can be used to identify this view declaration language.

        The default implementation returns the fully qualified class name of the view declaration language implementation. Subclasses may override to provide a more meaningful id.

        Since:
        2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ViewDeclarationLanguageFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Class ViewDeclarationLanguageFactory

  • java.lang.Object
    • javax.faces.view.ViewDeclarationLanguageFactory
  • All Implemented Interfaces:
    FacesWrapper<ViewDeclarationLanguageFactory>

    public abstract class ViewDeclarationLanguageFactory
extends Object
implements FacesWrapper<ViewDeclarationLanguageFactory>

    ViewDeclarationLanguageFactory is a factory object that creates (if needed) and returns a new ViewDeclarationLanguage instance based on the VDL found in a specific view.

    There must be one ViewDeclarationLanguageFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

   ViewDeclarationLanguageFactory factory = (ViewDeclarationLanguageFactory)
    FactoryFinder.getFactory(FactoryFinder.VIEW_DECLARATION_LANGUAGE_FACTORY);
    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ViewDeclarationLanguageFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ViewDeclarationLanguage getViewDeclarationLanguage(String viewId)

      Return the ViewDeclarationLanguage instance suitable for handling the VDL contained in the page referenced by the argument viewId.
      ViewDeclarationLanguageFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ViewDeclarationLanguageFactory

        public ViewDeclarationLanguageFactory()

    • Method Detail

      • getWrapped

        public ViewDeclarationLanguageFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<ViewDeclarationLanguageFactory>

      • getViewDeclarationLanguage

        public abstract ViewDeclarationLanguage getViewDeclarationLanguage(String viewId)

        Return the ViewDeclarationLanguage instance suitable for handling the VDL contained in the page referenced by the argument viewId. The default implementation must return a valid ViewDeclarationLanguage instance for views written in either JSP, Faces XML Views, or Facelets for JSF 2.

        Parameters:
        viewId - the viewId to be inspected for an appropriate ViewDeclarationLanguage implementation for the VDL used in the view.
        Throws:
        NullPointerException - if viewId is null.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ViewDeclarationLanguageWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Class ViewDeclarationLanguageWrapper

  • java.lang.Object
    • javax.faces.view.ViewDeclarationLanguage
      • javax.faces.view.ViewDeclarationLanguageWrapper
  • All Implemented Interfaces:
    FacesWrapper<ViewDeclarationLanguage>

    public abstract class ViewDeclarationLanguageWrapper
extends ViewDeclarationLanguage
implements FacesWrapper<ViewDeclarationLanguage>

    Provides a simple implementation of ViewDeclarationLanguage that can be subclassed by developers wishing to provide specialized behavior to an existing ViewDeclarationLanguage instance. The default implementation of all methods is to call through to the wrapped ViewDeclarationLanguage instance.

    Usage: extend this class and override getWrapped() to return the instance being wrapping.

    Since:
    2.2

    • Field Summary

      • Fields inherited from class javax.faces.view.ViewDeclarationLanguage

        FACELETS_VIEW_DECLARATION_LANGUAGE_ID, JSP_VIEW_DECLARATION_LANGUAGE_ID

    • Constructor Summary

      Constructors
      Constructor and Description
      ViewDeclarationLanguageWrapper()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void buildView(FacesContext context, UIViewRoot root)

      Take any actions specific to this VDL implementation to cause the argument UIViewRoot which must have been created via a call to ViewDeclarationLanguage.createView(javax.faces.context.FacesContext, java.lang.String), to be populated with children.
      List<String> calculateResourceLibraryContracts(FacesContext context, String viewId)

      Return the list of resource library contracts that will be made available for use in the view specified by the argument viewId.
      UIComponent createComponent(FacesContext context, String taglibURI, String tagName, Map<String,Object> attributes)

      Create a component given a ViewDeclarationLanguage specific tag library URI and tag name.
      UIViewRoot createView(FacesContext context, String viewId)

      Create a UIViewRoot from the VDL contained in the artifact referenced by the argument viewId.
      BeanInfo getComponentMetadata(FacesContext context, Resource componentResource)

      Return a reference to the component metadata for the composite component represented by the argument componentResource, or null if the metadata cannot be found.
      String getId()

      Returns a non-null String that can be used to identify this view declaration language.
      Resource getScriptComponentResource(FacesContext context, Resource componentResource)

      Take implementation specific action to discover a Resource given the argument componentResource.
      StateManagementStrategy getStateManagementStrategy(FacesContext context, String viewId)

      For implementations that want to control the implementation of state saving and restoring, the StateManagementStrategy allows them to do so.
      ViewMetadata getViewMetadata(FacesContext context, String viewId)

      Return a reference to the view metadata for the view represented by the argument viewId, or null if the metadata cannot be found.
      abstract ViewDeclarationLanguage getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.
      void renderView(FacesContext context, UIViewRoot view)

      Render a view rooted at argumentview.
      UIViewRoot restoreView(FacesContext context, String viewId)

      Restore a UIViewRoot from a previously created view.
      void retargetAttachedObjects(FacesContext context, UIComponent topLevelComponent, List<AttachedObjectHandler> handlers)

      Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting attached objects from the top level composite component to the individual AttachedObjectTarget instances inside the composite component.
      void retargetMethodExpressions(FacesContext context, UIComponent topLevelComponent)

      Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting any method expressions from the top level component to the appropriate inner component.
      boolean viewExists(FacesContext context, String viewId)

      Tests whether a physical resource corresponding to the specified viewId exists.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ViewDeclarationLanguageWrapper

        public ViewDeclarationLanguageWrapper()

    • Method Detail

      • getWrapped

        public abstract ViewDeclarationLanguage getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<ViewDeclarationLanguage>
        Returns:
        the wrapped ViewDeclarationLanguage instance
        See Also:
        FacesWrapper.getWrapped()

      • getId

        public String getId()
        Description copied from class: ViewDeclarationLanguage

        Returns a non-null String that can be used to identify this view declaration language.

        The default implementation returns the fully qualified class name of the view declaration language implementation. Subclasses may override to provide a more meaningful id.

        Overrides:
        getId in class ViewDeclarationLanguage

      • retargetAttachedObjects

        public void retargetAttachedObjects(FacesContext context,
                           UIComponent topLevelComponent,
                           List<AttachedObjectHandler> handlers)
        Description copied from class: ViewDeclarationLanguage

        Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting attached objects from the top level composite component to the individual AttachedObjectTarget instances inside the composite component. This method must be called by the ViewDeclarationLanguage implementation when creating the UIComponent tree when a composite component usage is encountered.

        An algorithm semantically equivalent to the following must be implemented.

        • Obtain the metadata for the composite component. Currently this entails getting the value of the UIComponent.BEANINFO_KEY component attribute, which will be an instance of BeanInfo. If the metadata cannot be found, log an error message and return.

        • Get the BeanDescriptor from the BeanInfo.

        • Get the value of the AttachedObjectTarget.ATTACHED_OBJECT_TARGETS_KEY from the BeanDescriptor's getValue() method. This will be a List<AttachedObjectTarget>. Let this be targetList.

        • For each curHandler entry in the argument handlers

          • Let forAttributeValue be the return from AttachedObjectHandler.getFor().

          • For each curTarget entry in targetList, the first of the following items that causes a match will take this action:

            For each UIComponent in the list returned from curTarget.getTargets(), call curHandler.applyAttachedObject(), passing the FacesContext and the UIComponent.

            and cause this inner loop to terminate.

            • If curHandler is an instance of ActionSource2AttachedObjectHandler and curTarget is an instance of ActionSource2AttachedObjectTarget, and curTarget.getName() is equal to curTargetName, consider it a match.

            • If curHandler is an instance of EditableValueHolderAttachedObjectHandler and curTarget is an instance of EditableValueHolderAttachedObjectTarget, and curTarget.getName() is equal to curTargetName, consider it a match.

            • If curHandler is an instance of ValueHolderAttachedObjectHandler and curTarget is an instance of ValueHolderAttachedObjectTarget, and curTarget.getName() is equal to curTargetName, consider it a match.

            • If curHandler is an instance of BehaviorHolderAttachedObjectHandler and curTarget is an instance of BehaviorHolderAttachedObjectTarget, and either of the following conditions are true,

              • curHandler.getEventName() is not null and is equal to curTargetName.
              • curHandler.getEventName() is null and curTarget.isDefaultEvent() is true.

              consider it a match.

        The implementation must support retargeting attached objects from the top level compsite component to targets that are composite and non-composite components.

        An implementation is provided that will throw UnsupportedOperationException. A Faces implementation compliant with version 2.0 and beyond of the specification must override this method.

        Overrides:
        retargetAttachedObjects in class ViewDeclarationLanguage
        Parameters:
        context - the FacesContext for this request.
        topLevelComponent - The UIComponent in the view to which the attached objects must be attached. This UIComponent must have its component metadata already associated and available from via the JavaBeans API.

      • retargetMethodExpressions

        public void retargetMethodExpressions(FacesContext context,
                             UIComponent topLevelComponent)
        Description copied from class: ViewDeclarationLanguage

        Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting any method expressions from the top level component to the appropriate inner component. For each attribute that is a MethodExpression (as indicated by the presence of a "method-signature" attribute and the absence of a "type" attribute), the following action must be taken:

        • Get the value of the targets attribute. If the value is a ValueExpression evaluate it. If there is no targets attribute, let the name of the metadata element be the evaluated value of the targets attribute.

        • Interpret targets as a space (not tab) separated list of ids. For each entry in the list:

          • Find the inner component of the topLevelComponent with the id equal to the current list entry. For discussion, this component is called target. If not found, log and error and continue to the next attribute.

          • For discussion the declared name of the attribute is called name.

          • In the attributes map of the topLevelComponent, look up the entry under the key name. Assume the result is a ValueExpression. For discussion, this is attributeValueExpression. If not found, log an error and continue to the next attribute.

          • If name is equal to the string "action", or "actionListener" without the quotes, assume target is an ActionSource2.

          • If name is equal to the string "validator", or "valueChangeListener" without the quotes, assume target is an EditableValueHolder.

          • Call getExpressionString() on the attributeValueExpression and use that string to create a MethodExpression of the appropriate signature for name.

          • If name is not equal to any of the previously listed strings, call getExpressionString() on the attributeValueExpression and use that string to create a MethodExpression where the signature is created based on the value of the "method-signature" attribute of the <composite:attribute /> tag.

          • Let the resultant MethodExpression be called attributeMethodExpression for discussion.

          • If name is equal to the string "action" without the quotes, call ActionSource2.setActionExpression(javax.el.MethodExpression) on target, passing attributeMethodExpression.

          • If name is equal to the string "actionListener" without the quotes, call ActionSource.addActionListener(javax.faces.event.ActionListener) on target, passing attributeMethodExpression wrapped in a MethodExpressionActionListener.

          • If name is equal to the string "validator" without the quotes, call EditableValueHolder.addValidator(javax.faces.validator.Validator) on target, passing attributeMethodExpression wrapped in a MethodExpressionValidator.

          • If name is equal to the string "valueChangeListener" without the quotes, call EditableValueHolder.addValueChangeListener(javax.faces.event.ValueChangeListener) on target, passing attributeMethodExpression wrapped in a MethodExpressionValueChangeListener.

          • Otherwise, assume that the MethodExpression should be placed in the components attribute set. The runtme must create the MethodExpression instance based on the value of the "method-signature" attribute.

        An implementation is provided that will throw UnsupportedOperationException. A Faces implementation compliant with version 2.0 and beyond of the specification must override this method.

        Overrides:
        retargetMethodExpressions in class ViewDeclarationLanguage
        Parameters:
        context - the FacesContext for this request.
        topLevelComponent - The UIComponent in the view to which the attached objects must be attached. This UIComponent must have its component metadata already associated and available from via the JavaBeans API.

      • viewExists

        public boolean viewExists(FacesContext context,
                 String viewId)
        Description copied from class: ViewDeclarationLanguage

        Tests whether a physical resource corresponding to the specified viewId exists.

        The default implementation uses ResourceHandler.createViewResource(javax.faces.context.FacesContext, java.lang.String) to locate the physical resource.

        Overrides:
        viewExists in class ViewDeclarationLanguage
        Parameters:
        context - The FacesContext for this request.
        viewId - the view id to test

      • buildView

        public void buildView(FacesContext context,
             UIViewRoot root)
               throws IOException
        Description copied from class: ViewDeclarationLanguage

        Take any actions specific to this VDL implementation to cause the argument UIViewRoot which must have been created via a call to ViewDeclarationLanguage.createView(javax.faces.context.FacesContext, java.lang.String), to be populated with children.

        The Facelets implementation must insure that markup comprising the view must be executed, with the UIComponent instances in the view being encountered in the same depth-first order as in other lifecycle methods defined on UIComponent, and added to the view (but not rendered) during the traversal. The runtime must guarantee that the view must be fully populated before any of the following happen.

        • The PhaseListener.afterPhase(javax.faces.event.PhaseEvent) method of any PhaseListeners attached to the application is called

        • The UIViewRoot phase listener installed via UIViewRoot.setAfterPhaseListener(javax.el.MethodExpression) or UIViewRoot.addPhaseListener(javax.faces.event.PhaseListener) are called.

        If the root is already populated with children, the view must still be re-built, but care must be taken to ensure that the existing components are correctly paired up with their VDL counterparts in the VDL page. Also, any system events that would normally be generated during the adding or removing of components from the view must be temporarily disabled during the creation of the view and then re-enabled when the view has been built.

        Specified by:
        buildView in class ViewDeclarationLanguage
        Parameters:
        context - the FacesContext for this request
        root - the UIViewRoot to populate with children using techniques specific to this VDL implementation.
        Throws:
        IOException

      • calculateResourceLibraryContracts

        public List<String> calculateResourceLibraryContracts(FacesContext context,
                                             String viewId)
        Description copied from class: ViewDeclarationLanguage

        Return the list of resource library contracts that will be made available for use in the view specified by the argument viewId. If no match is found, return an empty list. See section JSF.7.7.2 for the specification of the default implementation. For backward compatibility with prior implementations, an implementation is provided that returns null, but any implementation compliant with the version of the specification in which this method was introduced must implement it as specified in JSF.7.7.2.

        Overrides:
        calculateResourceLibraryContracts in class ViewDeclarationLanguage
        Parameters:
        context - the FacesContext for this request
        viewId - the view id for which the applicable resource library contracts should be calculated.

      • createView

        public UIViewRoot createView(FacesContext context,
                    String viewId)
        Description copied from class: ViewDeclarationLanguage

        Create a UIViewRoot from the VDL contained in the artifact referenced by the argument viewId. See section JSF.7.7.2 for the specification of the default implementation.

        Specified by:
        createView in class ViewDeclarationLanguage
        Parameters:
        context - the FacesContext for this request.
        viewId - the identifier of an artifact that contains the VDL syntax that describes this view.

      • createComponent

        public UIComponent createComponent(FacesContext context,
                          String taglibURI,
                          String tagName,
                          Map<String,Object> attributes)
        Description copied from class: ViewDeclarationLanguage

        Create a component given a ViewDeclarationLanguage specific tag library URI and tag name. The runtime must support this method operating for the Facelets VDL. Other kinds of ViewDeclarationLanguage may be supported but are not required to be supported. For backward compatibility with decorated ViewDeclrationLanguage implementations that do not override this method, a default implementation is provided that returns null. However, any implementation that is compliant with the version of the specification in which this method was introduced must implement this method.

        Overrides:
        createComponent in class ViewDeclarationLanguage
        Parameters:
        context - the FacesContext for this request
        taglibURI - the fully qualified tag library URI that contains the component
        tagName - the name of the tag within that library that exposes the component
        attributes - any name=value pairs that would otherwise have been given on the markup that would cause the creation of this component or null if no attributes need be given.

      • getComponentMetadata

        public BeanInfo getComponentMetadata(FacesContext context,
                            Resource componentResource)
        Description copied from class: ViewDeclarationLanguage

        Return a reference to the component metadata for the composite component represented by the argument componentResource, or null if the metadata cannot be found. See section JSF.7.7.2 for the specification of the default implementation. JSP implementations must throw UnsupportedOperationException.

        Specified by:
        getComponentMetadata in class ViewDeclarationLanguage
        Parameters:
        context - The FacesContext for this request.
        componentResource - The Resource that represents the component.

      • getScriptComponentResource

        public Resource getScriptComponentResource(FacesContext context,
                                  Resource componentResource)
        Description copied from class: ViewDeclarationLanguage

        Take implementation specific action to discover a Resource given the argument componentResource. See section JSF.7.7.2 for the specification of the default implementation. JSP implementations must throw UnsupportedOperationException.

        Specified by:
        getScriptComponentResource in class ViewDeclarationLanguage
        Parameters:
        context - The FacesContext for this request.
        componentResource - The Resource that represents the component.

      • getStateManagementStrategy

        public StateManagementStrategy getStateManagementStrategy(FacesContext context,
                                                 String viewId)
        Description copied from class: ViewDeclarationLanguage

        For implementations that want to control the implementation of state saving and restoring, the StateManagementStrategy allows them to do so. Returning null indicates that the implementation wishes the runtime to handle the state saving and restoring. Implementations that provide the VDL for Facelets for JSF 2.0 and later must return non-null from this method.

        Specified by:
        getStateManagementStrategy in class ViewDeclarationLanguage

      • getViewMetadata

        public ViewMetadata getViewMetadata(FacesContext context,
                           String viewId)
        Description copied from class: ViewDeclarationLanguage

        Return a reference to the view metadata for the view represented by the argument viewId, or null if the metadata cannot be found. See section JSF.7.7.2 for the specification of the default implementation. Facelets for JSF 2 implementation must return non-null. JSP implementations must return null.

        Specified by:
        getViewMetadata in class ViewDeclarationLanguage
        Parameters:
        context - The FacesContext for this request.
        viewId - the view id from whith to extract the metadata

      • renderView

        public void renderView(FacesContext context,
              UIViewRoot view)
                throws IOException
        Description copied from class: ViewDeclarationLanguage

        Render a view rooted at argumentview. See section JSF.7.7.2 for the specification of the default implementation.

        Specified by:
        renderView in class ViewDeclarationLanguage
        Parameters:
        context - the FacesContext for this request.
        view - the UIViewRoot from an early call to ViewDeclarationLanguage.createView(javax.faces.context.FacesContext, java.lang.String) or ViewDeclarationLanguage.restoreView(javax.faces.context.FacesContext, java.lang.String).
        Throws:
        IOException

      • restoreView

        public UIViewRoot restoreView(FacesContext context,
                     String viewId)
        Description copied from class: ViewDeclarationLanguage

        Restore a UIViewRoot from a previously created view. See section JSF.7.7.2 for the specification of the default implementation.

        Specified by:
        restoreView in class ViewDeclarationLanguage
        Parameters:
        context - the FacesContext for this request.
        viewId - the identifier for a previously rendered view.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ViewMetadata (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view

Class ViewMetadata

  • java.lang.Object
    • javax.faces.view.ViewMetadata

  • public abstract class ViewMetadata
extends Object

    ViewMetadata is reponsible for extracting and providing view parameter metadata from VDL views. Because ViewDeclarationLanguage.getViewMetadata(javax.faces.context.FacesContext, java.lang.String) is required to return null for JSP views and non-null for views authored in Facelets for JSF 2, this specification only applys to Facelets for JSF 2.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ViewMetadata()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract UIViewRoot createMetadataView(FacesContext context)

      Creates a new UIViewRoot containing only view parameter metadata.
      static Collection<UIViewAction> getViewActions(UIViewRoot root)

      Utility method to extract view metadata from the provided UIViewRoot.
      abstract String getViewId()

      static Collection<UIViewParameter> getViewParameters(UIViewRoot root)

      Utility method to extract view metadata from the provided UIViewRoot.
      static boolean hasMetadata(UIViewRoot root)

      Utility method to determine if the the provided UIViewRoot has metadata.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ViewMetadata

        public ViewMetadata()

    • Method Detail

      • getViewId

        public abstract String getViewId()

        Returns:
        the view ID for which this ViewMetadata instance was created

      • createMetadataView

        public abstract UIViewRoot createMetadataView(FacesContext context)

        Creates a new UIViewRoot containing only view parameter metadata. The processing of building this UIViewRoot with metadata should not cause any events to be published to the application. The implementation must call FacesContext.setProcessingEvents(boolean) passing false as the argument, at the beginning of the method, and pass true to the same method at the end. The implementation must ensure that this happens regardless of ant exceptions that may be thrown.

        Parameters:
        context - the FacesContext for the current request
        Returns:
        a UIViewRoot containing only view parameter metadata (if any)

      • getViewParameters

        public static Collection<UIViewParameter> getViewParameters(UIViewRoot root)

        Utility method to extract view metadata from the provided UIViewRoot.

        Parameters:
        root - the UIViewRoot from which the metadata will be extracted.
        Returns:
        a Collection of UIViewParameter instances. If the view has no metadata, the collection will be empty.

      • getViewActions

        public static Collection<UIViewAction> getViewActions(UIViewRoot root)

        Utility method to extract view metadata from the provided UIViewRoot.

        Parameters:
        root - the UIViewRoot from which the metadata will be extracted.
        Returns:
        a Collection of UIViewAction instances. If the view has no metadata, the collection will be empty.

      • hasMetadata

        public static boolean hasMetadata(UIViewRoot root)

        Utility method to determine if the the provided UIViewRoot has metadata. The default implementation will return true if the provided UIViewRoot has a facet named UIViewRoot.METADATA_FACET_NAME and that facet has children. It will return false otherwise.

        Parameters:
        root - the UIViewRoot from which the metadata will be extracted from
        Returns:
        true if the view has metadata, false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ViewScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.view

Annotation Type ViewScoped

  • @NormalScope
@Inherited
@Documented
@Target(value={TYPE,FIELD,METHOD})
@Retention(value=RUNTIME)
public @interface ViewScoped

    When this annotation, along with javax.inject.Named is found on a class, the runtime must place the bean in a CDI scope such that it remains active as long as NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) does not cause a navigation to a view with a viewId that is different than the viewId of the current view. Any injections and notifications required by CDI and the Java EE platform must occur as usual at the expected time.

    If ProjectStage is not ProjectStage.Production, verify that the current UIViewRoot does not have its transient property set to true. If so, add a FacesMessage for the current viewId to the FacesContext stating @ViewScoped beans cannot work if the view is marked as transient. Also log a Level.WARNING message to the log. If ProjectStage is ProjectStage.Production, do not do this verification.

    The bean must be stored in the map returned from UIViewRoot.getViewMap(boolean).

    Use of this annotation requires that any beans stored in view scope must be serializable and proxyable as defined in the CDI specification.

    The runtime must ensure that any methods on the bean annotated with PostConstruct or PreDestroy are called when the scope begins and ends, respectively. Two circumstances can cause the scope to end.

    • FacesContext.setViewRoot(javax.faces.component.UIViewRoot) is called with the new UIViewRoot being different than the current one.

    • The session, that happened to be active when the bean was created, expires. If no session existed when the bean was created, then this circumstance does not apply.

    In the session expiration case, the runtime must ensure that FacesContext.getCurrentInstance() returns a valid instance if it is called during the processing of the @PreDestroy annotated method. The set of methods on FacesContext that are valid to call in this circumstance is identical to those documented as "valid to call this method during application startup or shutdown". On the ExternalContext returned from that FacesContext, all of the methods documented as "valid to call this method during application startup or shutdown" are valid to call. In addition, the method ExternalContext.getSessionMap() is also valid to call.

    Since:
    2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.faces.view.Location (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.Location

  • Packages that use Location
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of Location in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return Location
      Modifier and Type Method and Description
      abstract Location TagAttribute.getLocation()
      The location of this attribute in the FaceletContext
      Location Tag.getLocation()

      Return the Location of this Tag instance in the Facelet view.
      Constructors in javax.faces.view.facelets with parameters of type Location
      Constructor and Description
      Tag(Location location, String namespace, String localName, String qName, TagAttributes attributes)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.StateManagementStrategy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.StateManagementStrategy

  • Packages that use StateManagementStrategy
    Package Description
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

    • Uses of StateManagementStrategy in javax.faces.view

      Methods in javax.faces.view that return StateManagementStrategy
      Modifier and Type | Method and Description
      StateManagementStrategy | ViewDeclarationLanguageWrapper.getStateManagementStrategy(FacesContext context, String viewId)
      abstract StateManagementStrategy ViewDeclarationLanguage.getStateManagementStrategy(FacesContext context, String viewId)

      For implementations that want to control the implementation of state saving and restoring, the StateManagementStrategy allows them to do so.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.ViewDeclarationLanguage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.ViewDeclarationLanguage

  • Packages that use ViewDeclarationLanguage
    Package Description
    javax.faces.application
    APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

    • Uses of ViewDeclarationLanguage in javax.faces.application

      Methods in javax.faces.application that return ViewDeclarationLanguage
      Modifier and Type Method and Description
      ViewDeclarationLanguage ViewHandlerWrapper.getViewDeclarationLanguage(FacesContext context, String viewId)
      The default behavior of this method is to call ViewHandler.getViewDeclarationLanguage(javax.faces.context.FacesContext, java.lang.String) on the wrapped ViewHandler object.
      ViewDeclarationLanguage ViewHandler.getViewDeclarationLanguage(FacesContext context, String viewId)

      Return the ViewDeclarationLanguage instance used for this ViewHandler instance.

    • Uses of ViewDeclarationLanguage in javax.faces.view

      Subclasses of ViewDeclarationLanguage in javax.faces.view
      Modifier and Type Class and Description
      class  ViewDeclarationLanguageWrapper

      Provides a simple implementation of ViewDeclarationLanguage that can be subclassed by developers wishing to provide specialized behavior to an existing ViewDeclarationLanguage instance.
      Methods in javax.faces.view that return ViewDeclarationLanguage
      Modifier and Type | Method and Description
      abstract ViewDeclarationLanguage ViewDeclarationLanguageFactory.getViewDeclarationLanguage(String viewId)

      Return the ViewDeclarationLanguage instance suitable for handling the VDL contained in the page referenced by the argument viewId.
      abstract ViewDeclarationLanguage | ViewDeclarationLanguageWrapper.getWrapped()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.ViewDeclarationLanguageFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.ViewDeclarationLanguageFactory

  • Packages that use ViewDeclarationLanguageFactory
    Package Description
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

    • Uses of ViewDeclarationLanguageFactory in javax.faces.view

      Methods in javax.faces.view that return ViewDeclarationLanguageFactory
      Modifier and Type Method and Description
      ViewDeclarationLanguageFactory ViewDeclarationLanguageFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.ViewDeclarationLanguageWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.ViewDeclarationLanguageWrapper

No usage of javax.faces.view.ViewDeclarationLanguageWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.ViewMetadata (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.ViewMetadata

  • Packages that use ViewMetadata
    Package Description
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

    • Uses of ViewMetadata in javax.faces.view

      Methods in javax.faces.view that return ViewMetadata
      Modifier and Type | Method and Description
      ViewMetadata | ViewDeclarationLanguageWrapper.getViewMetadata(FacesContext context, String viewId)
      abstract ViewMetadata ViewDeclarationLanguage.getViewMetadata(FacesContext context, String viewId)

      Return a reference to the view metadata for the view represented by the argument viewId, or null if the metadata cannot be found.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.ViewScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.ViewScoped

No usage of javax.faces.view.ViewScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.ActionSource2AttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.ActionSource2AttachedObjectHandler

No usage of javax.faces.view.ActionSource2AttachedObjectHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.ActionSource2AttachedObjectTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.ActionSource2AttachedObjectTarget

No usage of javax.faces.view.ActionSource2AttachedObjectTarget
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.AttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.AttachedObjectHandler

  • Packages that use AttachedObjectHandler
    Package Description
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of AttachedObjectHandler in javax.faces.view

      Subinterfaces of AttachedObjectHandler in javax.faces.view
      Modifier and Type Interface and Description
      interface  ActionSource2AttachedObjectHandler

      A VDL handler that exposes ActionListener to a page author.
      interface  BehaviorHolderAttachedObjectHandler

      Represent an attached object that is a BehaviorHolder in a VDL page.
      interface  EditableValueHolderAttachedObjectHandler

      A VDL handler that exposes Validator or ValueChangeListener to a page author.
      interface  ValueHolderAttachedObjectHandler

      A VDL handler that exposes Converter to a page author.
      Method parameters in javax.faces.view with type arguments of type AttachedObjectHandler
      Modifier and Type | Method and Description
      void | ViewDeclarationLanguageWrapper.retargetAttachedObjects(FacesContext context, UIComponent topLevelComponent, List<AttachedObjectHandler> handlers)
      void ViewDeclarationLanguage.retargetAttachedObjects(FacesContext context, UIComponent topLevelComponent, List<AttachedObjectHandler> handlers)

      Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting attached objects from the top level composite component to the individual AttachedObjectTarget instances inside the composite component.

    • Uses of AttachedObjectHandler in javax.faces.view.facelets

      Classes in javax.faces.view.facelets that implement AttachedObjectHandler
      Modifier and Type Class and Description
      class  BehaviorHandler

      The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).
      class  ConverterHandler

      Handles setting a Converter instance on a ValueHolder parent.
      class  FaceletsAttachedObjectHandler

      Root class for all tag handlers that represent attached objetcts in a Facelets page.
      class  ValidatorHandler

      Handles setting a Validator instance on an EditableValueHolder parent.
      Methods in javax.faces.view.facelets that return AttachedObjectHandler
      Modifier and Type Method and Description
      protected AttachedObjectHandler FaceletsAttachedObjectHandler.getAttachedObjectHandlerHelper()

      Return the underlying handler for this tag handler instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.AttachedObjectTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.AttachedObjectTarget

  • Packages that use AttachedObjectTarget
    Package Description
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

    • Uses of AttachedObjectTarget in javax.faces.view

      Subinterfaces of AttachedObjectTarget in javax.faces.view
      Modifier and Type Interface and Description
      interface  ActionSource2AttachedObjectTarget

      A marker interface for VDL tags that represent <composite:actionSource/> for use by the composite component page author.
      interface  BehaviorHolderAttachedObjectTarget

      Represent a BehaviorHolder attached object target in a VDL page.
      interface  EditableValueHolderAttachedObjectTarget

      A marker interface for VDL tags that represent <composite:editableValueHolder/> for use by the composite component page author.
      interface  ValueHolderAttachedObjectTarget

      A marker interface for VDL tags that represent <composite:valueHolder/> for use by the composite component page author.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.BehaviorHolderAttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.BehaviorHolderAttachedObjectHandler

  • Packages that use BehaviorHolderAttachedObjectHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of BehaviorHolderAttachedObjectHandler in javax.faces.view.facelets

      Classes in javax.faces.view.facelets that implement BehaviorHolderAttachedObjectHandler
      Modifier and Type Class and Description
      class  BehaviorHandler

      The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.BehaviorHolderAttachedObjectTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.BehaviorHolderAttachedObjectTarget

No usage of javax.faces.view.BehaviorHolderAttachedObjectTarget
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.EditableValueHolderAttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.EditableValueHolderAttachedObjectHandler

  • Packages that use EditableValueHolderAttachedObjectHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of EditableValueHolderAttachedObjectHandler in javax.faces.view.facelets

      Classes in javax.faces.view.facelets that implement EditableValueHolderAttachedObjectHandler
      Modifier and Type Class and Description
      class  ValidatorHandler

      Handles setting a Validator instance on an EditableValueHolder parent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.EditableValueHolderAttachedObjectTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.EditableValueHolderAttachedObjectTarget

No usage of javax.faces.view.EditableValueHolderAttachedObjectTarget
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.ValueHolderAttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.ValueHolderAttachedObjectHandler

  • Packages that use ValueHolderAttachedObjectHandler
    Package Description
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of ValueHolderAttachedObjectHandler in javax.faces.view

      Subinterfaces of ValueHolderAttachedObjectHandler in javax.faces.view
      Modifier and Type Interface and Description
      interface  EditableValueHolderAttachedObjectHandler

      A VDL handler that exposes Validator or ValueChangeListener to a page author.

    • Uses of ValueHolderAttachedObjectHandler in javax.faces.view.facelets

      Classes in javax.faces.view.facelets that implement ValueHolderAttachedObjectHandler
      Modifier and Type Class and Description
      class  ConverterHandler

      Handles setting a Converter instance on a ValueHolder parent.
      class  ValidatorHandler

      Handles setting a Validator instance on an EditableValueHolder parent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.ValueHolderAttachedObjectTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.ValueHolderAttachedObjectTarget

  • Packages that use ValueHolderAttachedObjectTarget
    Package Description
    javax.faces.view

    Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

    • Uses of ValueHolderAttachedObjectTarget in javax.faces.view

      Subinterfaces of ValueHolderAttachedObjectTarget in javax.faces.view
      Modifier and Type Interface and Description
      interface  EditableValueHolderAttachedObjectTarget

      A marker interface for VDL tags that represent <composite:editableValueHolder/> for use by the composite component page author.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AttributeHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface AttributeHandler

  • public interface AttributeHandler

    An interface that allows other code to identify FaceletHandlers that correspond to component attributes.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAttributeName(FaceletContext ctx)

      Returns the resolved literal String value of the attribute name after evaluating EL.

    • Method Detail

      • getAttributeName

        String getAttributeName(FaceletContext ctx)

        Returns the resolved literal String value of the attribute name after evaluating EL.

        Parameters:
        ctx - the FaceletContext for this view execution
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BehaviorConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface BehaviorConfig

  • All Superinterfaces:
    TagConfig

    public interface BehaviorConfig
extends TagConfig

    Convey the id of a behavior declared in a view.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getBehaviorId()
      Return the value of the behavior-id.

      • Methods inherited from interface javax.faces.view.facelets.TagConfig

        getNextHandler, getTag, getTagId

    • Method Detail

      • getBehaviorId

        String getBehaviorId()

        Return the value of the behavior-id.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BehaviorHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class BehaviorHandler

  • java.lang.Object
    • javax.faces.view.facelets.TagHandler
      • javax.faces.view.facelets.MetaTagHandler
        • javax.faces.view.facelets.DelegatingMetaTagHandler
          • javax.faces.view.facelets.FaceletsAttachedObjectHandler
            • javax.faces.view.facelets.BehaviorHandler
  • All Implemented Interfaces:
    AttachedObjectHandler, BehaviorHolderAttachedObjectHandler, FaceletHandler

    public class BehaviorHandler
extends FaceletsAttachedObjectHandler
implements BehaviorHolderAttachedObjectHandler

    The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior). The current specification defines one Facelet element for this sort of attached object, <f:ajax>.

    • Field Summary

      • Fields inherited from class javax.faces.view.facelets.DelegatingMetaTagHandler

        delegateFactory

      • Fields inherited from class javax.faces.view.facelets.TagHandler

        nextHandler, tag, tagId

    • Constructor Summary

      Constructors
      Constructor and Description
      BehaviorHandler(BehaviorConfig config)

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      String getBehaviorId()
      TagAttribute getEvent()
      String getEventName()

      Return the client event name to which this behavior applies.
      protected TagHandlerDelegate | getTagHandlerDelegate()

      • Methods inherited from class javax.faces.view.facelets.FaceletsAttachedObjectHandler

        applyAttachedObject, getAttachedObjectHandlerHelper, getFor

      • Methods inherited from class javax.faces.view.facelets.DelegatingMetaTagHandler

        apply, applyNextHandler, createMetaRuleset, getBinding, getTag, getTagAttribute, getTagId, isDisabled, setAttributes

      • Methods inherited from class javax.faces.view.facelets.TagHandler

        getAttribute, getRequiredAttribute, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.faces.view.AttachedObjectHandler

        applyAttachedObject, getFor

    • Constructor Detail

      • BehaviorHandler

        public BehaviorHandler(BehaviorConfig config)

    • Method Detail

      • getEvent

        public TagAttribute getEvent()

      • getEventName

        public String getEventName()
        Description copied from interface: BehaviorHolderAttachedObjectHandler

        Return the client event name to which this behavior applies.

        Specified by:
        getEventName in interface BehaviorHolderAttachedObjectHandler

      • getTagHandlerDelegate

        protected TagHandlerDelegate getTagHandlerDelegate()
        Specified by:
        getTagHandlerDelegate in class DelegatingMetaTagHandler

      • getBehaviorId

        public String getBehaviorId()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ComponentConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface ComponentConfig

  • All Superinterfaces:
    TagConfig

    public interface ComponentConfig
extends TagConfig

    Passed to the constructor of ComponentHandler. Represents a component-type/renderer-type pair.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getComponentType()

      ComponentType to pass to the Application.
      String getRendererType()

      RendererType to set on created UIComponent instances.

      • Methods inherited from interface javax.faces.view.facelets.TagConfig

        getNextHandler, getTag, getTagId

    • Method Detail

      • getComponentType

        String getComponentType()

        ComponentType to pass to the Application. Cannot be null.

        Since:
        2.0

      • getRendererType

        String getRendererType()

        RendererType to set on created UIComponent instances.

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ComponentHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class ComponentHandler

  • java.lang.Object
    • javax.faces.view.facelets.TagHandler
      • javax.faces.view.facelets.MetaTagHandler
        • javax.faces.view.facelets.DelegatingMetaTagHandler
          • javax.faces.view.facelets.ComponentHandler
  • All Implemented Interfaces:
    FaceletHandler

    public class ComponentHandler
extends DelegatingMetaTagHandler

    Public base class for markup element instances that map to UIComponent instances in the view.

    Instances of this class are created and passed to TagHandlerDelegateFactory.createComponentHandlerDelegate(javax.faces.view.facelets.ComponentHandler) when a tag corresponding to this particular component is encountered in a Facelet view. A custom tag handler for a component, converter, validator, or behavior must extend from this class. In this way, this instance acts as a delegate for the implementation private tag handler. Such a subclass may choose to override as many or as few methods from this base class as desired. If the subclass wants to completely override the action of the implementation specific tag for which this component is the delegate, it must override the apply() method and make it take the following actions, in this order. These actions must only happen the first time this facelet is applied for each user. Subsequent applications must take no action.

    1. The UIComponent represented by this element is created with the appropriate Application.createComponent() method.

    2. Each attribute specified in the markup is correctly applied to the component instance, as specified in the VDLDocs for this element.

    3. If project stage is ProjectStage.Development, Put the Location for this element into the component attribute Map under the key given by the value of the symbolic constant UIComponent.VIEW_LOCATION_KEY.

    4. Set the id of the component. If the id is specified manually by the page author, that value must be set as the id. Otherwise, the closest ancestor component that is an instance of UniqueIdVendor must be located and its UniqueIdVendor.createUniqueId(javax.faces.context.FacesContext, java.lang.String) method must be called to derive the id. If no such instance can be found, call UIViewRoot.createUniqueId() to derive the id.

    5. The rendererType property of the component is set properly.

    6. onComponentCreated(javax.faces.view.facelets.FaceletContext, javax.faces.component.UIComponent, javax.faces.component.UIComponent) is called.

    7. UIComponent.pushComponentToEL(javax.faces.context.FacesContext, javax.faces.component.UIComponent) is called on the newly created component.

    8. The next handler in the facelet chain is applied. This will cause the component to be populated with children.

    9. The component is added to its parent in the view.

    10. UIComponent.popComponentFromEL(javax.faces.context.FacesContext) is called on the newly created component.

    11. Call UIComponent.markInitialState().

    A common use case for extending this class is to gain access to the process by which the Facelets runtime creates component instances corresponding to markup in a Facelets view. These three methods are useful in such cases.

    • To control the instantiation of the UIComponent instance, subclasses may override createComponent(javax.faces.view.facelets.FaceletContext). If this method is not overridden, the tag handler for which this instance is the delegate will take the necessary action to instantiate the UIComponent.

    • To be notified of creation of the UIComponentinstance, subclasses may override onComponentCreated(javax.faces.view.facelets.FaceletContext, javax.faces.component.UIComponent, javax.faces.component.UIComponent).

    • To be notified that the freshly created UIComponent instance has been populated with children as a result of execution of child tag handlers, subclasses may override onComponentPopulated(javax.faces.view.facelets.FaceletContext, javax.faces.component.UIComponent, javax.faces.component.UIComponent).

    Since:
    2.0

    • Field Summary

      • Fields inherited from class javax.faces.view.facelets.DelegatingMetaTagHandler

        delegateFactory

      • Fields inherited from class javax.faces.view.facelets.TagHandler

        nextHandler, tag, tagId

    • Constructor Summary

      Constructors
      Constructor and Description
      ComponentHandler(ComponentConfig config)

      Leverage the TagHandlerDelegateFactory provided by the implementation to create an instance of TagHandlerDelegate designed for use with ComponentHandler.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      UIComponent createComponent(FaceletContext ctx)

      Subclasses that wish to take over the task of instantiating the UIComponent instance corresponding to this tag handler my override this method to do so.
      ComponentConfig getComponentConfig()
      protected TagHandlerDelegate | getTagHandlerDelegate()
      static boolean isNew(UIComponent component)

      Determine if the passed component is not null and if it's new to the tree.
      void onComponentCreated(FaceletContext ctx, UIComponent c, UIComponent parent)

      This method is guaranteed to be called after the component has been created but before it has been populated with children.
      void onComponentPopulated(FaceletContext ctx, UIComponent c, UIComponent parent)

      This method is guaranteed to be called after the component has been populated with children.

      • Methods inherited from class javax.faces.view.facelets.DelegatingMetaTagHandler

        apply, applyNextHandler, createMetaRuleset, getBinding, getTag, getTagAttribute, getTagId, isDisabled, setAttributes

      • Methods inherited from class javax.faces.view.facelets.TagHandler

        getAttribute, getRequiredAttribute, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ComponentHandler

        public ComponentHandler(ComponentConfig config)

        Leverage the TagHandlerDelegateFactory provided by the implementation to create an instance of TagHandlerDelegate designed for use with ComponentHandler.

        Since:
        2.0

    • Method Detail

      • getTagHandlerDelegate

        protected TagHandlerDelegate getTagHandlerDelegate()
        Specified by:
        getTagHandlerDelegate in class DelegatingMetaTagHandler

      • getComponentConfig

        public ComponentConfig getComponentConfig()

      • createComponent

        public UIComponent createComponent(FaceletContext ctx)

        Subclasses that wish to take over the task of instantiating the UIComponent instance corresponding to this tag handler my override this method to do so. A null return from this method will cause the TagHandlerDelegate for instance to create the component instead.

        Since:
        2.2

      • onComponentCreated

        public void onComponentCreated(FaceletContext ctx,
                      UIComponent c,
                      UIComponent parent)

        This method is guaranteed to be called after the component has been created but before it has been populated with children.

        Parameters:
        ctx - the FaceletContext for this view execution
        c - the UIComponent that has just been created.
        parent - the parent UIComponent of the component represented by this element instance.
        Since:
        2.0

      • onComponentPopulated

        public void onComponentPopulated(FaceletContext ctx,
                        UIComponent c,
                        UIComponent parent)

        This method is guaranteed to be called after the component has been populated with children.

        Parameters:
        ctx - the FaceletContext for this view execution
        c - the UIComponent that has just been populated with children.
        parent - the parent UIComponent of the component represented by this element instance.
        Since:
        2.0

      • isNew

        public static boolean isNew(UIComponent component)

        Determine if the passed component is not null and if it's new to the tree. This operation can be used for determining if attributes should be wired to the component.

        Parameters:
        component - the component you wish to modify
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CompositeFaceletHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class CompositeFaceletHandler

  • java.lang.Object
    • javax.faces.view.facelets.CompositeFaceletHandler
  • All Implemented Interfaces:
    FaceletHandler

    public final class CompositeFaceletHandler
extends Object
implements FaceletHandler

    A FaceletHandler that is derived of 1 or more, inner FaceletHandlers. This class would be found if the next FaceletHandler is structually, a body with multiple child elements as defined in XML. This class enables the Facelet runtime to traverse the tree of FaceletHandler instances built by the Facelets compiler.

    • Constructor Summary

      Constructors
      Constructor and Description
      CompositeFaceletHandler(FaceletHandler[] children)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void apply(FaceletContext ctx, UIComponent parent)

      Calls apply on any child handlers.
      FaceletHandler[] getHandlers()

      Returns the array of child handlers contained by this handler.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CompositeFaceletHandler

        public CompositeFaceletHandler(FaceletHandler[] children)

    • Method Detail

      • apply

        public void apply(FaceletContext ctx,
         UIComponent parent)
           throws IOException

        Calls apply on any child handlers.

        Specified by:
        apply in interface FaceletHandler
        Parameters:
        ctx - the FaceletContext for this view execution
        parent - the parent UIComponent of the component represented by this element instance.
        Throws:
        IOException - if unable to load relativePath
        Since:
        2.0

      • getHandlers

        public FaceletHandler[] getHandlers()

        Returns the array of child handlers contained by this handler.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConverterConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface ConverterConfig

  • All Superinterfaces:
    TagConfig

    public interface ConverterConfig
extends TagConfig

    A Facelet version of the JSP ConverterTag. All the attributes specified in the documentation for the converter tags are valid attributes.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getConverterId()

      Return the converter id to be used in instantiating this converter

      • Methods inherited from interface javax.faces.view.facelets.TagConfig

        getNextHandler, getTag, getTagId

    • Method Detail

      • getConverterId

        String getConverterId()

        Return the converter id to be used in instantiating this converter

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConverterHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class ConverterHandler

  • java.lang.Object
    • javax.faces.view.facelets.TagHandler
      • javax.faces.view.facelets.MetaTagHandler
        • javax.faces.view.facelets.DelegatingMetaTagHandler
          • javax.faces.view.facelets.FaceletsAttachedObjectHandler
            • javax.faces.view.facelets.ConverterHandler
  • All Implemented Interfaces:
    AttachedObjectHandler, FaceletHandler, ValueHolderAttachedObjectHandler

    public class ConverterHandler
extends FaceletsAttachedObjectHandler
implements ValueHolderAttachedObjectHandler

    Handles setting a Converter instance on a ValueHolder parent. Will wire all attributes set to the Converter instance created/fetched. Uses the "binding" attribute for grabbing instances to apply attributes to.

    Will only set/create Converter if the passed UIComponent's parent is null, signifying that it wasn't restored from an existing tree.

    • Field Summary

      • Fields inherited from class javax.faces.view.facelets.DelegatingMetaTagHandler

        delegateFactory

      • Fields inherited from class javax.faces.view.facelets.TagHandler

        nextHandler, tag, tagId

    • Constructor Summary

      Constructors
      Constructor and Description
      ConverterHandler(ConverterConfig config)

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      String | getConverterId(FaceletContext ctx)
      protected TagHandlerDelegate | getTagHandlerDelegate()

      • Methods inherited from class javax.faces.view.facelets.FaceletsAttachedObjectHandler

        applyAttachedObject, getAttachedObjectHandlerHelper, getFor

      • Methods inherited from class javax.faces.view.facelets.DelegatingMetaTagHandler

        apply, applyNextHandler, createMetaRuleset, getBinding, getTag, getTagAttribute, getTagId, isDisabled, setAttributes

      • Methods inherited from class javax.faces.view.facelets.TagHandler

        getAttribute, getRequiredAttribute, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.faces.view.AttachedObjectHandler

        applyAttachedObject, getFor

    • Constructor Detail

      • ConverterHandler

        public ConverterHandler(ConverterConfig config)

    • Method Detail

      • getTagHandlerDelegate

        protected TagHandlerDelegate getTagHandlerDelegate()
        Specified by:
        getTagHandlerDelegate in class DelegatingMetaTagHandler

      • getConverterId

        public String getConverterId(FaceletContext ctx)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DelegatingMetaTagHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class DelegatingMetaTagHandler

  • java.lang.Object
    • javax.faces.view.facelets.TagHandler
      • javax.faces.view.facelets.MetaTagHandler
        • javax.faces.view.facelets.DelegatingMetaTagHandler
  • All Implemented Interfaces:
    FaceletHandler
    Direct Known Subclasses:
    ComponentHandler, FaceletsAttachedObjectHandler

    public abstract class DelegatingMetaTagHandler
extends MetaTagHandler

    Enable the JSF implementation to provide the appropriate behavior for the kind of MetaTagHandler subclass for each kind of element in the view, while providing a base-class from which those wanting to make a Java language custom tag handler can inherit. The JSF runtime provides the implementation of getTagHandlerDelegate() for the appropriate subclass.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected TagHandlerDelegateFactory | delegateFactory

      • Fields inherited from class javax.faces.view.facelets.TagHandler

        nextHandler, tag, tagId

    • Constructor Summary

      Constructors
      Constructor and Description
      DelegatingMetaTagHandler(TagConfig config)

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void apply(FaceletContext ctx, UIComponent parent)

      The default implementation simply calls through to TagHandlerDelegate.apply(javax.faces.view.facelets.FaceletContext, javax.faces.component.UIComponent).
      void applyNextHandler(FaceletContext ctx, UIComponent c)

      Invoke the apply() method on this instance's TagHandler.nextHandler.
      protected MetaRuleset createMetaRuleset(Class type)

      The default implementation simply calls through to TagHandlerDelegate.createMetaRuleset(java.lang.Class) and returns the result.
      TagAttribute getBinding()
      Tag getTag()
      TagAttribute | getTagAttribute(String localName)
      protected abstract TagHandlerDelegate | getTagHandlerDelegate()
      String getTagId()
      boolean | isDisabled(FaceletContext ctx)
      void setAttributes(FaceletContext ctx, Object instance)
      Invoking/extending this method will cause the results of the created MetaRuleset to auto-wire state to the passed instance.

      • Methods inherited from class javax.faces.view.facelets.TagHandler

        getAttribute, getRequiredAttribute, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • delegateFactory

        protected TagHandlerDelegateFactory delegateFactory

    • Constructor Detail

      • DelegatingMetaTagHandler

        public DelegatingMetaTagHandler(TagConfig config)

    • Method Detail

      • getTagHandlerDelegate

        protected abstract TagHandlerDelegate getTagHandlerDelegate()

      • isDisabled

        public boolean isDisabled(FaceletContext ctx)

      • getBinding

        public TagAttribute getBinding()

      • getTag

        public Tag getTag()

      • getTagId

        public String getTagId()

      • getTagAttribute

        public TagAttribute getTagAttribute(String localName)

      • setAttributes

        public void setAttributes(FaceletContext ctx,
                 Object instance)
        Description copied from class: MetaTagHandler
        Invoking/extending this method will cause the results of the created MetaRuleset to auto-wire state to the passed instance.
        Overrides:
        setAttributes in class MetaTagHandler

      • apply

        public void apply(FaceletContext ctx,
         UIComponent parent)
           throws IOException

        The default implementation simply calls through to TagHandlerDelegate.apply(javax.faces.view.facelets.FaceletContext, javax.faces.component.UIComponent).

        Parameters:
        ctx - the FaceletContext for this view execution
        parent - the parent UIComponent of the component represented by this element instance.
        Throws:
        IOException - if unable to load relativePath
        Since:
        2.0

      • applyNextHandler

        public void applyNextHandler(FaceletContext ctx,
                    UIComponent c)
                      throws IOException,
                             FacesException,
                             ELException

        Invoke the apply() method on this instance's TagHandler.nextHandler.

        Parameters:
        ctx - the FaceletContext for this view execution
        c - the UIComponent of the component represented by this element instance.
        Throws:
        IOException
        FacesException
        ELException
        Since:
        2.0

      • createMetaRuleset

        protected MetaRuleset createMetaRuleset(Class type)

        The default implementation simply calls through to TagHandlerDelegate.createMetaRuleset(java.lang.Class) and returns the result.

        Specified by:
        createMetaRuleset in class MetaTagHandler
        Parameters:
        type - the Class for which the MetaRuleset must be created.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Facelet (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class Facelet

  • java.lang.Object
    • javax.faces.view.facelets.Facelet

  • public abstract class Facelet
extends Object

    The parent or root object in a FaceletHandler composition. The Facelet will take care of populating the passed UIComponent parent in relation to the create/restore lifecycle of JSF.

    Author:
    Jacob Hookom

    • Constructor Summary

      Constructors
      Constructor and Description
      Facelet()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void apply(FacesContext facesContext, UIComponent parent)
      The passed UIComponent parent will be populated/restored in accordance with the Facelets chapter in the spec prose document.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Facelet

        public Facelet()

    • Method Detail

      • apply

        public abstract void apply(FacesContext facesContext,
         UIComponent parent)
                    throws IOException

        The passed UIComponent parent will be populated/restored in accordance with the Facelets chapter in the spec prose document.

        Parameters:
        facesContext - The current FacesContext (Should be the same as FacesContext.getInstance())
        parent - The UIComponent to populate in a compositional fashion. In most cases a Facelet will be base a UIViewRoot.
        Throws:
        IOException
        FacesException
        FaceletException
        ELException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FaceletCache (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class FaceletCache<V>

  • java.lang.Object
    • javax.faces.view.facelets.FaceletCache<V>

  • public abstract class FaceletCache<V>
extends Object

    This API defines the facility by which the Facelets ViewDeclarationLanguage creates and caches instances of Facelets.

    The cache handles two different kinds of Facelets: View Facelets and View Metadata Facelets. The former is the usual Facelet that provides for the construction of a UIComponent tree. This kind of Facelet is accessed via the getFacelet(java.net.URL) and isFaceletCached(java.net.URL) methods. The latter is a special kind of Facelet that corresponds to ViewDeclarationLanguage.getViewMetadata(javax.faces.context.FacesContext, java.lang.String). This kind of Facelet is accessed via the getViewMetadataFacelet(java.net.URL) and isViewMetadataFaceletCached(java.net.URL) methods.

    Since:
    2.1

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static interface  FaceletCache.MemberFactory<V>

      Factory interface for creating Facelet or View Metadata Facelet instances.

    • Constructor Summary

      Constructors
      Constructor and Description
      FaceletCache()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract V getFacelet(URL url)

      Returns a cached Facelet instance.
      protected FaceletCache.MemberFactory<V> getMemberFactory()

      Returns the FaceletCache.MemberFactory passed to setMemberFactories(javax.faces.view.facelets.FaceletCache.MemberFactory<V>, javax.faces.view.facelets.FaceletCache.MemberFactory<V>) for the purpose of creating Facelet instance.
      protected FaceletCache.MemberFactory<V> getMetadataMemberFactory()

      Returns the FaceletCache.MemberFactory passed to setMemberFactories(javax.faces.view.facelets.FaceletCache.MemberFactory<V>, javax.faces.view.facelets.FaceletCache.MemberFactory<V>) for the purpose of creating View Metadata Facelet instance.
      abstract V getViewMetadataFacelet(URL url)

      Returns a cached View Metadata Facelet instance.
      abstract boolean isFaceletCached(URL url)

      Determines whether a cached Facelet instance exists for this URL.
      abstract boolean isViewMetadataFaceletCached(URL url)

      Determines whether a cached View Metadata Facelet instance exists for this URL.
      protected void setMemberFactories(FaceletCache.MemberFactory<V> faceletFactory, FaceletCache.MemberFactory<V> viewMetadataFaceletFactory)

      This must be called by the runtime at startup time, before any requests are serviced, and allows for the FaceletCache implementation to provide the FaceletCache.MemberFactory instances that will be used to create instances of Facelets and View Metadata Facelets.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FaceletCache

        public FaceletCache()

    • Method Detail

      • getFacelet

        public abstract V getFacelet(URL url)
                      throws IOException

        Returns a cached Facelet instance. If no instance is available, it will be created using the Facelet FaceletCache.MemberFactory and stored in the cache.

        Parameters:
        url - URL for the Facelet being retrieved
        Throws:
        NullPointerException - if argument url is null.
        IOException

      • isFaceletCached

        public abstract boolean isFaceletCached(URL url)

        Determines whether a cached Facelet instance exists for this URL. Returns true if a cached instance exists, false otherwise

        Parameters:
        url - URL for the Facelet
        Throws:
        NullPointerException - if argument url is null.

      • getViewMetadataFacelet

        public abstract V getViewMetadataFacelet(URL url)
                                  throws IOException

        Returns a cached View Metadata Facelet instance. If no instance is available, it will be created using the View Metadata Facelet FaceletCache.MemberFactory and stored in the cache.

        Parameters:
        url - URL for the View Metadata Facelet being retrieved
        Throws:
        NullPointerException - if argument url is null.
        IOException

      • isViewMetadataFaceletCached

        public abstract boolean isViewMetadataFaceletCached(URL url)

        Determines whether a cached View Metadata Facelet instance exists for this URL. Returns true if a cached instance exists, false otherwise

        Parameters:
        url - URL for the View Metadata Facelet
        Throws:
        NullPointerException - if argument url is null.

      • setMemberFactories

        protected void setMemberFactories(FaceletCache.MemberFactory<V> faceletFactory,
                      FaceletCache.MemberFactory<V> viewMetadataFaceletFactory)

        This must be called by the runtime at startup time, before any requests are serviced, and allows for the FaceletCache implementation to provide the FaceletCache.MemberFactory instances that will be used to create instances of Facelets and View Metadata Facelets.

        Parameters:
        faceletFactory - the FaceletCache.MemberFactory instance that will be used to create instances of Facelets.
        viewMetadataFaceletFactory - the FaceletCache.MemberFactory instance that will be used to create instances of metadata Facelets.
        Throws:
        NullPointerException - if either argument is null

      • getMemberFactory

        protected FaceletCache.MemberFactory<V> getMemberFactory()

        Returns the FaceletCache.MemberFactory passed to setMemberFactories(javax.faces.view.facelets.FaceletCache.MemberFactory<V>, javax.faces.view.facelets.FaceletCache.MemberFactory<V>) for the purpose of creating Facelet instance.

      • getMetadataMemberFactory

        protected FaceletCache.MemberFactory<V> getMetadataMemberFactory()

        Returns the FaceletCache.MemberFactory passed to setMemberFactories(javax.faces.view.facelets.FaceletCache.MemberFactory<V>, javax.faces.view.facelets.FaceletCache.MemberFactory<V>) for the purpose of creating View Metadata Facelet instance.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FaceletCache.MemberFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface FaceletCache.MemberFactory<V>

  • Enclosing class:
    FaceletCache<V>

    public static interface FaceletCache.MemberFactory<V>

    Factory interface for creating Facelet or View Metadata Facelet instances.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      V newInstance(URL key)

      Create a Facelet or View Metadata Facelet (depending on the type of factory this is) for the argument URL.

    • Method Detail

      • newInstance

        V newInstance(URL key)
              throws IOException

        Create a Facelet or View Metadata Facelet (depending on the type of factory this is) for the argument URL.

        Parameters:
        key - the URL that will be used as the key for the instance being created.
        Throws:
        NullPointerException - if argument key is null.
        IOException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FaceletCacheFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class FaceletCacheFactory

  • java.lang.Object
    • javax.faces.view.facelets.FaceletCacheFactory
  • All Implemented Interfaces:
    FacesWrapper<FaceletCacheFactory>

    public abstract class FaceletCacheFactory
extends Object
implements FacesWrapper<FaceletCacheFactory>

    Allows customization of the implementation of FaceletCache.

    Since:
    2.1

    • Constructor Summary

      Constructors
      Constructor and Description
      FaceletCacheFactory()

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      abstract FaceletCache | getFaceletCache()
      FaceletCacheFactory getWrapped()

      A class that implements this interface uses this method to return an instance of the class being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FaceletCacheFactory

        public FaceletCacheFactory()

    • Method Detail

      • getWrapped

        public FaceletCacheFactory getWrapped()
        Description copied from interface: FacesWrapper

        A class that implements this interface uses this method to return an instance of the class being wrapped.

        Specified by:
        getWrapped in interface FacesWrapper<FaceletCacheFactory>

      • getFaceletCache

        public abstract FaceletCache getFaceletCache()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FaceletContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class FaceletContext

  • java.lang.Object
    • javax.el.ELContext
      • javax.faces.view.facelets.FaceletContext

  • public abstract class FaceletContext
extends ELContext

    Context representative of a single request from a Facelet. This instance is passed to nearly every method call in this API.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static String | FACELET_CONTEXT_KEY

    • Constructor Summary

      Constructors
      Constructor and Description
      FaceletContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract String generateUniqueId(String base)

      Generate a unique ID for the passed String
      abstract Object getAttribute(String name)

      Return an attribute set by a previous call to setAttribute(java.lang.String, java.lang.Object).
      abstract ExpressionFactory getExpressionFactory()

      The ExpressionFactory to use within the Facelet this context is executing upon.
      abstract FacesContext getFacesContext()

      The current FacesContext bound to this "request".
      abstract void includeFacelet(UIComponent parent, String relativePath)

      Include another Facelet defined at some path, relative to the executing context, not the current Facelet (same as include directive in JSP)
      abstract void includeFacelet(UIComponent parent, URL absolutePath)

      Include another Facelet defined at some path, absolute to this ClassLoader/OS
      abstract void setAttribute(String name, Object value)

      Support method which is backed by the current VariableMapper.
      abstract void setFunctionMapper(FunctionMapper fnMapper)

      Set the FunctionMapper to use in EL evaluation/creation.
      abstract void setVariableMapper(VariableMapper varMapper)

      Set the VariableMapper to use in EL evaluation/creation.

      • Methods inherited from class javax.el.ELContext

        addEvaluationListener, convertToType, enterLambdaScope, exitLambdaScope, getContext, getELResolver, getEvaluationListeners, getFunctionMapper, getImportHandler, getLambdaArgument, getLocale, getVariableMapper, isLambdaArgument, isPropertyResolved, notifyAfterEvaluation, notifyBeforeEvaluation, notifyPropertyResolved, putContext, setLocale, setPropertyResolved, setPropertyResolved

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FACELET_CONTEXT_KEY

        public static final String FACELET_CONTEXT_KEY
        See Also:
        Constant Field Values

    • Constructor Detail

      • FaceletContext

        public FaceletContext()

    • Method Detail

      • getFacesContext

        public abstract FacesContext getFacesContext()

        The current FacesContext bound to this "request". Must not be null.

        Since:
        2.0

      • generateUniqueId

        public abstract String generateUniqueId(String base)

        Generate a unique ID for the passed String

        Parameters:
        base - the string from which to generate the ID.
        Since:
        2.0

      • getExpressionFactory

        public abstract ExpressionFactory getExpressionFactory()

        The ExpressionFactory to use within the Facelet this context is executing upon. Must not be null.

        Since:
        2.0

      • setVariableMapper

        public abstract void setVariableMapper(VariableMapper varMapper)

        Set the VariableMapper to use in EL evaluation/creation.

        Parameters:
        varMapper - the new VariableMapper
        Since:
        2.0

      • setFunctionMapper

        public abstract void setFunctionMapper(FunctionMapper fnMapper)

        Set the FunctionMapper to use in EL evaluation/creation.

        Parameters:
        fnMapper - the new FunctionMapper
        Since:
        2.0

      • setAttribute

        public abstract void setAttribute(String name,
                Object value)

        Support method which is backed by the current VariableMapper.

        Parameters:
        name - the name of the attribute
        value - the value of the attribute
        Since:
        2.0

      • getAttribute

        public abstract Object getAttribute(String name)

        Return an attribute set by a previous call to setAttribute(java.lang.String, java.lang.Object). Support method which is backed by the current VariableMapper

        Parameters:
        name - the name of the attribute to return.
        Since:
        2.0

      • includeFacelet

        public abstract void includeFacelet(UIComponent parent,
                  String relativePath)
                             throws IOException

        Include another Facelet defined at some path, relative to the executing context, not the current Facelet (same as include directive in JSP)

        Parameters:
        parent - the UIComponent that will be the parent of any components in the included facelet.
        relativePath - the path of the resource containing the facelet markup, relative to the current markup
        Throws:
        IOException - if unable to load relativePath
        FaceletException - if unable to parse the markup loaded from relativePath
        FacesException - if unable to create child UIComponent instances
        ELException - if any of the expressions in the markup loaded from relativePath fail
        Since:
        2.0

      • includeFacelet

        public abstract void includeFacelet(UIComponent parent,
                  URL absolutePath)
                             throws IOException

        Include another Facelet defined at some path, absolute to this ClassLoader/OS

        Parameters:
        parent - the UIComponent that will be the parent of any components in the included facelet.
        absolutePath - the absolute path to the resource containing the facelet markup
        Throws:
        IOException - if unable to load relativePath
        FaceletException - if unable to parse the markup loaded from relativePath
        FacesException - if unable to create child UIComponent instances
        ELException - if any of the expressions in the markup loaded from relativePath fail
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FaceletException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class FaceletException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.view.facelets.FaceletException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    TagAttributeException, TagException

    public class FaceletException
extends FacesException

    An Exception from the Facelet implementation

    Since:
    2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      FaceletException()

      Create an empty FaceletException.
      FaceletException(String message)

      Create a FaceletException with argument message as the message.
      FaceletException(String message, Throwable cause)

      Wrap argument cause in a FaceletException instance, with a message given by the argument message.
      FaceletException(Throwable cause)

      Wrap argument cause within this FaceletException instance.

    • Method Summary

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FaceletException

        public FaceletException()

        Create an empty FaceletException.

      • FaceletException

        public FaceletException(String message)

        Create a FaceletException with argument message as the message.

        Parameters:
        message - the textual message to display for the exception.

      • FaceletException

        public FaceletException(Throwable cause)

        Wrap argument cause within this FaceletException instance.

        Parameters:
        cause - the Throwable to wrap

      • FaceletException

        public FaceletException(String message,
                Throwable cause)

        Wrap argument cause in a FaceletException instance, with a message given by the argument message.

        Parameters:
        message - the message for the FacesException
        cause - the root cause
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FaceletHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface FaceletHandler

  • All Known Implementing Classes:
    BehaviorHandler, ComponentHandler, CompositeFaceletHandler, ConverterHandler, DelegatingMetaTagHandler, FaceletsAttachedObjectHandler, MetaTagHandler, TagHandler, ValidatorHandler

    public interface FaceletHandler

    This is the root class for markup elements in Facelets VDL. Facelets is XHTML, and XHTML is XML, and the root unit of abstraction in XML is the element. A FaceletHandler instance represents an XML element at runtime. Two direct implementations exist to embody the contract for more specific behavior.

    CompositeFaceletHandler
    A container for other FaceletHandlers
    TagHandler
    The foundation class for FaceletHandlers associated with markup in a Facelet document.
    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void apply(FaceletContext ctx, UIComponent parent)

      Process changes on a particular UIComponent

    • Method Detail

      • apply

        void apply(FaceletContext ctx,
         UIComponent parent)
           throws IOException

        Process changes on a particular UIComponent

        Parameters:
        ctx - the current FaceletContext instance for this execution
        parent - the parent UIComponent to operate upon
        Throws:
        IOException - if unable to load relativePath
        FaceletException - if unable to parse the markup loaded from relativePath
        FacesException - if unable to create child UIComponent instances
        ELException - if any of the expressions in the markup loaded from relativePath fail
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FaceletsAttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class FaceletsAttachedObjectHandler

  • java.lang.Object
    • javax.faces.view.facelets.TagHandler
      • javax.faces.view.facelets.MetaTagHandler
        • javax.faces.view.facelets.DelegatingMetaTagHandler
          • javax.faces.view.facelets.FaceletsAttachedObjectHandler
  • All Implemented Interfaces:
    AttachedObjectHandler, FaceletHandler
    Direct Known Subclasses:
    BehaviorHandler, ConverterHandler, ValidatorHandler

    public abstract class FaceletsAttachedObjectHandler
extends DelegatingMetaTagHandler
implements AttachedObjectHandler

    Root class for all tag handlers that represent attached objetcts in a Facelets page.

    • Field Summary

      • Fields inherited from class javax.faces.view.facelets.DelegatingMetaTagHandler

        delegateFactory

      • Fields inherited from class javax.faces.view.facelets.TagHandler

        nextHandler, tag, tagId

    • Constructor Summary

      Constructors
      Constructor and Description
      FaceletsAttachedObjectHandler(TagConfig config)
      Call through to super

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void applyAttachedObject(FacesContext ctx, UIComponent parent)

      Take the necessary actions to apply the attached object represented by the tag for the concrete subclass of this class to the argument parent.
      protected AttachedObjectHandler getAttachedObjectHandlerHelper()

      Return the underlying handler for this tag handler instance.
      String getFor()

      Return the value of the "for" attribute.

      • Methods inherited from class javax.faces.view.facelets.DelegatingMetaTagHandler

        apply, applyNextHandler, createMetaRuleset, getBinding, getTag, getTagAttribute, getTagHandlerDelegate, getTagId, isDisabled, setAttributes

      • Methods inherited from class javax.faces.view.facelets.TagHandler

        getAttribute, getRequiredAttribute, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FaceletsAttachedObjectHandler

        public FaceletsAttachedObjectHandler(TagConfig config)

        Call through to super

        Parameters:
        config - configure this handler instance

    • Method Detail

      • getAttachedObjectHandlerHelper

        protected final AttachedObjectHandler getAttachedObjectHandlerHelper()

        Return the underlying handler for this tag handler instance.

      • applyAttachedObject

        public final void applyAttachedObject(FacesContext ctx,
                       UIComponent parent)

        Take the necessary actions to apply the attached object represented by the tag for the concrete subclass of this class to the argument parent.

        Specified by:
        applyAttachedObject in interface AttachedObjectHandler
        Parameters:
        ctx - the FacesContext for this request
        parent - The UIComponent to which this attached object must be applied.

      • getFor

        public final String getFor()

        Return the value of the "for" attribute. This enables the runtime to know to which inner component this attached object should be retargeted.

        Specified by:
        getFor in interface AttachedObjectHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FaceletsResourceResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.faces.view.facelets

Annotation Type FaceletsResourceResolver

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Inherited
public @interface FaceletsResourceResolver

    The presence of this annotation on a class automatically registers the class with the runtime as a ResourceResolver.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


FacetHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface FacetHandler

  • public interface FacetHandler

    An interface that allows other code to identify FaceletHandlers that correspond to component facets.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFacetName(FaceletContext ctx)

      Returns the resolved literal String value of the facet name after evaluating EL.

    • Method Detail

      • getFacetName

        String getFacetName(FaceletContext ctx)

        Returns the resolved literal String value of the facet name after evaluating EL.

        Parameters:
        ctx - the FaceletContext for this view execution
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces.view.facelets (Java(TM) EE 7 Specification APIs)

javax.faces.view.facelets

Interfaces

  • AttributeHandler
  • BehaviorConfig
  • ComponentConfig
  • ConverterConfig
  • FaceletCache.MemberFactory
  • FaceletHandler
  • FacetHandler
  • TagConfig
  • TagDecorator
  • TextHandler
  • ValidatorConfig

Classes

  • BehaviorHandler
  • ComponentHandler
  • CompositeFaceletHandler
  • ConverterHandler
  • DelegatingMetaTagHandler
  • Facelet
  • FaceletCache
  • FaceletCacheFactory
  • FaceletContext
  • FaceletsAttachedObjectHandler
  • Metadata
  • MetadataTarget
  • MetaRule
  • MetaRuleset
  • MetaTagHandler
  • ResourceResolver
  • Tag
  • TagAttribute
  • TagAttributes
  • TagHandler
  • TagHandlerDelegate
  • TagHandlerDelegateFactory
  • ValidatorHandler

Exceptions

  • FaceletException
  • TagAttributeException
  • TagException

Annotation Types

  • FaceletsResourceResolver


javax.faces.view.facelets (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.view.facelets

This package contains public classes for the Java code API of Facelets.

See: Description

  • Interface Summary
    Interface Description
    AttributeHandler

    An interface that allows other code to identify FaceletHandlers that correspond to component attributes.
    BehaviorConfig

    Convey the id of a behavior declared in a view.
    ComponentConfig

    Passed to the constructor of ComponentHandler.
    ConverterConfig

    A Facelet version of the JSP ConverterTag.
    FaceletCache.MemberFactory<V>

    Factory interface for creating Facelet or View Metadata Facelet instances.
    FaceletHandler

    This is the root class for markup elements in Facelets VDL.
    FacetHandler

    An interface that allows other code to identify FaceletHandlers that correspond to component facets.
    TagConfig

    Passed to the constructor of TagHandler subclass, it defines the document definition of the handler we are instantiating.
    TagDecorator
    Provides the ability to completely change the Tag before it's processed for compiling with the associated TagHandler.
    TextHandler

    An interface that allows other code to identify FaceletHandlers that may provide text (String) content.
    ValidatorConfig

    Used in creating ValidatorHandler and all implementations.
  • Class Summary
    Class | Description
    BehaviorHandler

    The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).
    ComponentHandler

    Public base class for markup element instances that map to UIComponent instances in the view.
    CompositeFaceletHandler

    A FaceletHandler that is derived of 1 or more, inner FaceletHandlers.
    ConverterHandler

    Handles setting a Converter instance on a ValueHolder parent.
    DelegatingMetaTagHandler

    Enable the JSF implementation to provide the appropriate behavior for the kind of MetaTagHandler subclass for each kind of element in the view, while providing a base-class from which those wanting to make a Java language custom tag handler can inherit.
    Facelet
    The parent or root object in a FaceletHandler composition.
    FaceletCache<V>

    This API defines the facility by which the Facelets ViewDeclarationLanguage creates and caches instances of Facelets.
    FaceletCacheFactory

    Allows customization of the implementation of FaceletCache.
    FaceletContext

    Context representative of a single request from a Facelet.
    FaceletsAttachedObjectHandler

    Root class for all tag handlers that represent attached objetcts in a Facelets page.
    Metadata

    There are concrete subclasses within the implementation that map concepts in the Facelet VDL page to JSF Java API calls the appropriate instances.
    MetadataTarget

    Information used with MetaRule for determining how and what Metadata should be wired.
    MetaRule

    The root class of the abstraction that dictates how attributes on a markup element in a Facelets VDL page are wired to the JSF API object instance associated with that element.
    MetaRuleset

    A mutable set of rules to be used in auto-wiring state to a particular object instance.
    MetaTagHandler

    Every kind of markup element in Facelets VDL that has attributes that need to take action on a JSF Java API artifact is associated with an instance of this class.
    ResourceResolver | Deprecated
    Tag

    The runtime must create an instance of this class for each element in the Facelets XHTML view.
    TagAttribute

    Representation of an XML attribute name=value pair on an XML element in a Facelet file.
    TagAttributes

    A set of TagAttributes, usually representing all attributes on a Tag.
    TagHandler

    Foundation class for FaceletHandlers associated with a markup element in a Facelet document.
    TagHandlerDelegate

    Abstract class that defines methods relating to helping tag handler instances.
    TagHandlerDelegateFactory

    Abstract factory for creating instances of TagHandlerDelegate.
    ValidatorHandler

    Handles setting a Validator instance on an EditableValueHolder parent.
  • Exception Summary
    Exception Description
    FaceletException

    An Exception from the Facelet implementation
    TagAttributeException

    An Exception caused by a TagAttribute
    TagException

    An Exception caused by a Tag
  • Annotation Types Summary
    Annotation Type Description
    FaceletsResourceResolver

    The presence of this annotation on a class automatically registers the class with the runtime as a ResourceResolver.

Package javax.faces.view.facelets Description

This package contains public classes for the Java code API of Facelets. The vast majority of Facelets users have no need to access the Java API and can get all their work done using the tag-level API. These classes are provided for users that have a need for a Java API that allows participation in the execution of a Facelets View, which happens as a result of the runtime calling ViewDeclarationLanguage.buildView().

UML Class Diagram of classes in this package

The most common usecase for participating in the execution of a Facelets View is to provide a custom tag handler in those cases when the non-Java API methods for doing so is not sufficient. In such cases, Java classes may extend from ComponentHandler, BehaviorHandler, ConverterHandler, or ValidatorHandler depending upon the kind of JSF Java API artifact they want to represent in the Facelets VDL page.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.view.facelets Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.view.facelets

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.view.facelets.CompositeFaceletHandler (implements javax.faces.view.facelets.FaceletHandler)
    • javax.el.ELContext
      • javax.faces.view.facelets.FaceletContext
    • javax.faces.view.facelets.Facelet
    • javax.faces.view.facelets.FaceletCache<V>
    • javax.faces.view.facelets.FaceletCacheFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.view.facelets.Metadata
    • javax.faces.view.facelets.MetadataTarget
    • javax.faces.view.facelets.MetaRule
    • javax.faces.view.facelets.MetaRuleset
    • javax.faces.view.facelets.ResourceResolver
    • javax.faces.view.facelets.Tag
    • javax.faces.view.facelets.TagAttribute
    • javax.faces.view.facelets.TagAttributes
    • javax.faces.view.facelets.TagHandler (implements javax.faces.view.facelets.FaceletHandler)
      • javax.faces.view.facelets.MetaTagHandler
        • javax.faces.view.facelets.DelegatingMetaTagHandler
          • javax.faces.view.facelets.ComponentHandler
          • javax.faces.view.facelets.FaceletsAttachedObjectHandler (implements javax.faces.view.AttachedObjectHandler)
            • javax.faces.view.facelets.BehaviorHandler (implements javax.faces.view.BehaviorHolderAttachedObjectHandler)
            • javax.faces.view.facelets.ConverterHandler (implements javax.faces.view.ValueHolderAttachedObjectHandler)
            • javax.faces.view.facelets.ValidatorHandler (implements javax.faces.view.EditableValueHolderAttachedObjectHandler)
    • javax.faces.view.facelets.TagHandlerDelegate
    • javax.faces.view.facelets.TagHandlerDelegateFactory (implements javax.faces.FacesWrapper<T>)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.view.facelets.FaceletException
              • javax.faces.view.facelets.TagAttributeException
              • javax.faces.view.facelets.TagException

Interface Hierarchy

  • javax.faces.view.facelets.AttributeHandler
  • javax.faces.view.facelets.FaceletCache.MemberFactory<V>
  • javax.faces.view.facelets.FaceletHandler
  • javax.faces.view.facelets.FacetHandler
  • javax.faces.view.facelets.TagConfig
    • javax.faces.view.facelets.BehaviorConfig
    • javax.faces.view.facelets.ComponentConfig
    • javax.faces.view.facelets.ConverterConfig
    • javax.faces.view.facelets.ValidatorConfig
  • javax.faces.view.facelets.TagDecorator
  • javax.faces.view.facelets.TextHandler

Annotation Type Hierarchy

  • javax.faces.view.facelets.FaceletsResourceResolver (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Metadata (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class Metadata

  • java.lang.Object
    • javax.faces.view.facelets.Metadata

  • public abstract class Metadata
extends Object

    There are concrete subclasses within the implementation that map concepts in the Facelet VDL page to JSF Java API calls the appropriate instances. For example, the “validator” attribute on an input component is specified to point to a MethodExpression that references a method that performs the validation. There is a concrete subclass of Metadata to perform this action when that attribute appears in a Facelet VDL page.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      Metadata()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void applyMetadata(FaceletContext ctx, Object instance)

      Take the action prescribed in the JSF specification for this particular VDL element attribute.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Metadata

        public Metadata()

    • Method Detail

      • applyMetadata

        public abstract void applyMetadata(FaceletContext ctx,
                 Object instance)

        Take the action prescribed in the JSF specification for this particular VDL element attribute.

        Parameters:
        ctx - The FaceletContext for this request.
        instance - The instance from the JSF Java API on which the action should be taken. For example, an instance of EditableValueHolder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MetadataTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class MetadataTarget

  • java.lang.Object
    • javax.faces.view.facelets.MetadataTarget

  • public abstract class MetadataTarget
extends Object

    Information used with MetaRule for determining how and what Metadata should be wired.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      MetadataTarget()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract PropertyDescriptor getProperty(String name)

      Return a beans PropertyDescriptor for the property with name given by argument name.
      abstract Class getPropertyType(String name)

      Return a Class for the property with name given by argument name.
      abstract Method getReadMethod(String name)

      Return a Method for the getter of the property with name given by argument name.
      abstract Class getTargetClass()

      Return the Class of the metadata target.
      abstract Method getWriteMethod(String name)

      Return a Method for the setter of the property with name given by argument name.
      abstract boolean isTargetInstanceOf(Class type)

      Return true if the target for this metadata element is an instance of the argument type.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MetadataTarget

        public MetadataTarget()

    • Method Detail

      • getProperty

        public abstract PropertyDescriptor getProperty(String name)

        Return a beans PropertyDescriptor for the property with name given by argument name.

        Parameters:
        name - the name of the property for which the PropertyDescriptor must be returned.

      • isTargetInstanceOf

        public abstract boolean isTargetInstanceOf(Class type)

        Return true if the target for this metadata element is an instance of the argument type.

        Parameters:
        type - the Class to test for the instance of.

      • getTargetClass

        public abstract Class getTargetClass()

        Return the Class of the metadata target.

      • getPropertyType

        public abstract Class getPropertyType(String name)

        Return a Class for the property with name given by argument name.

        Parameters:
        name - the name of the property for which the Class must be returned.

      • getWriteMethod

        public abstract Method getWriteMethod(String name)

        Return a Method for the setter of the property with name given by argument name.

        Parameters:
        name - the name of the property for which the Method must be returned.

      • getReadMethod

        public abstract Method getReadMethod(String name)

        Return a Method for the getter of the property with name given by argument name.

        Parameters:
        name - the name of the property for which the Method must be returned.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MetaRule (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class MetaRule

  • java.lang.Object
    • javax.faces.view.facelets.MetaRule

  • public abstract class MetaRule
extends Object

    The root class of the abstraction that dictates how attributes on a markup element in a Facelets VDL page are wired to the JSF API object instance associated with that element. The single method on this interface, applyRule(java.lang.String, javax.faces.view.facelets.TagAttribute, javax.faces.view.facelets.MetadataTarget), returns an encapsulation of the behavior that actually does the work of handling the attribute and its value. There are implementations of specific concrete subclasses of this class for all the basic kinds of elements that appear in Facelets VDL pages: components, non-components, and attached objects.

    For example, consider this markup:

    <h:inputText value="#{user.userid}"
                valueChangeListener="#{user.newUserId}" />
     Two MetaRule instances are involved in this example.

    1. The first has an applyRule() method that returns a Metadata instance that, when its applyMetada() method is called, dictates how the "value" attribute is processed: calling UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression) on the UIComponent instance associated with the <h:inputText> element.

    2. The second has an applyRule() method that returns a Metadata instance that, when its applyMetadata() method is called, dictates how the "valueChangeListener" attribute is processed: calling EditableValueHolder.addValueChangeListener(javax.faces.event.ValueChangeListener).

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      MetaRule()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Metadata applyRule(String name, TagAttribute attribute, MetadataTarget meta)

      Return an abstraction that takes appropriate action given the kind of rule represented by the argument name, in the context of this particular concrete subclass of MetaRule.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MetaRule

        public MetaRule()

    • Method Detail

      • applyRule

        public abstract Metadata applyRule(String name,
                 TagAttribute attribute,
                 MetadataTarget meta)

        Return an abstraction that takes appropriate action given the kind of rule represented by the argument name, in the context of this particular concrete subclass of MetaRule. The abstraction must encapsulate the value from the argument attribute.

        Parameters:
        name - the name for this rule. This will generally be the name of a tag attribute in the VDL.
        attribute - the name/value pair for this attribute on this particular instance of an element in the page.
        meta - the MetadataTarged that can be used to discern what kind of action to encapsulate within the abstraction to be returned.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MetaRuleset (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class MetaRuleset

  • java.lang.Object
    • javax.faces.view.facelets.MetaRuleset

  • public abstract class MetaRuleset
extends Object

    A mutable set of rules to be used in auto-wiring state to a particular object instance. Rules assigned to this object will be composed into a single Metadata instance which will encapsulate the ruleset.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      MetaRuleset()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract MetaRuleset add(Metadata mapper)

      Add another Metadata to this ruleset, returning this.
      abstract MetaRuleset addRule(MetaRule rule)

      Add another MetaRule to this ruleset, returning this.
      abstract MetaRuleset alias(String attribute, String property)

      Customize this MetaRuleset by removing the attribute named by argument attribute and re-adding it under the name given by the argument property, returning this.
      abstract Metadata finish()

      Take actions to apply the rule.
      abstract MetaRuleset ignore(String attribute)

      Customize this MetaRuleset instance to advise it to ignore the attribute named by the attribute argument, returning this.
      abstract MetaRuleset ignoreAll()

      Customize this MetaRuleset instance to advise it to ignore all attributes, returning this.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MetaRuleset

        public MetaRuleset()

    • Method Detail

      • ignore

        public abstract MetaRuleset ignore(String attribute)

        Customize this MetaRuleset instance to advise it to ignore the attribute named by the attribute argument, returning this.

        Parameters:
        attribute - the name of the attribute to ignore.
        Since:
        2.0

      • ignoreAll

        public abstract MetaRuleset ignoreAll()

        Customize this MetaRuleset instance to advise it to ignore all attributes, returning this.

        Since:
        2.0

      • alias

        public abstract MetaRuleset alias(String attribute,
                String property)

        Customize this MetaRuleset by removing the attribute named by argument attribute and re-adding it under the name given by the argument property, returning this.

        Since:
        2.0

      • add

        public abstract MetaRuleset add(Metadata mapper)

        Add another Metadata to this ruleset, returning this.

        Since:
        2.0

      • addRule

        public abstract MetaRuleset addRule(MetaRule rule)

        Add another MetaRule to this ruleset, returning this.

        Since:
        2.0

      • finish

        public abstract Metadata finish()

        Take actions to apply the rule.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MetaTagHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class MetaTagHandler

  • java.lang.Object
    • javax.faces.view.facelets.TagHandler
      • javax.faces.view.facelets.MetaTagHandler
  • All Implemented Interfaces:
    FaceletHandler
    Direct Known Subclasses:
    DelegatingMetaTagHandler

    public abstract class MetaTagHandler
extends TagHandler

    Every kind of markup element in Facelets VDL that has attributes that need to take action on a JSF Java API artifact is associated with an instance of this class. This class is an abstraction to enable a rule based method for directing how different kinds of elements take different kinds of actions in the JSF Java API. For example, consider this markup:

    <h:inputText value="#{user.userid}"
                valueChangeListener="#{user.newUserId}" />

    This markup element corresponds to an instance of HtmlInputText in the view. HtmlImputText has a number of attributes that are to be exposed to the page author. HtmlInputText also implements EditableValueHolder, which extends ValueHolder. Each of these interfaces also expose a number of attributes to the page author.

    Facelets employes the strategy pattern to allow the manner in which all possible attributes are handled based on the nature of the JSF Java API artifact associated with the markup element.

    Subclasses override the createMetaRuleset(java.lang.Class) method to return a MetaRuleset instance encapsulating all the strategies for all the attributes that make sense for this particular markup element. The runtime calls the setAttributes(FaceletContext, Object) method to cause those rules to be executed and applied.

    Since:
    2.0

    • Field Summary

      • Fields inherited from class javax.faces.view.facelets.TagHandler

        nextHandler, tag, tagId

    • Constructor Summary

      Constructors
      Constructor and Description
      MetaTagHandler(TagConfig config)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected abstract MetaRuleset createMetaRuleset(Class type)
      Extend this method in order to add your own rules.
      protected void setAttributes(FaceletContext ctx, Object instance)
      Invoking/extending this method will cause the results of the created MetaRuleset to auto-wire state to the passed instance.

      • Methods inherited from class javax.faces.view.facelets.TagHandler

        getAttribute, getRequiredAttribute, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.faces.view.facelets.FaceletHandler

        apply

    • Constructor Detail

      • MetaTagHandler

        public MetaTagHandler(TagConfig config)

    • Method Detail

      • createMetaRuleset

        protected abstract MetaRuleset createMetaRuleset(Class type)
        Extend this method in order to add your own rules.
        Parameters:
        type -

      • setAttributes

        protected void setAttributes(FaceletContext ctx,
                 Object instance)
        Invoking/extending this method will cause the results of the created MetaRuleset to auto-wire state to the passed instance.
        Parameters:
        ctx -
        instance -
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class ResourceResolver

  • java.lang.Object
    • javax.faces.view.facelets.ResourceResolver
  • Deprecated.

    @Deprecated
public abstract class ResourceResolver
extends Object

    Deprecated as of JSF 2.2. The same functionality is more correctly provided by ResourceHandler. Provide a hook to decorate or override the way that Facelets loads template files. A default implementation must be provided that satisfies the requirements for loading templates as in Pre-JSF 2.0 Facelets.

    If a <context-param> with the param name equal to the value of FACELETS_RESOURCE_RESOLVER_PARAM_NAME exists, the runtime must interpret its value as a fully qualified classname of a java class that extends ResourceResolver and has a zero argument public constructor or a one argument public constructor where the type of the argument is ResourceResolver. If this param is set and its value does not conform to those requirements, the runtime must log a message and continue. If it does conform to these requirements and has a one-argument constructor, the default ResourceResolver must be passed to the constructor. If it has a zero argument constructor it is invoked directly. In either case, the new ResourceResolver replaces the old one.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FACELETS_RESOURCE_RESOLVER_PARAM_NAME
      Deprecated.

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceResolver()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract URL resolveUrl(String path)
      Deprecated.

      Returns the URL of a Facelet template file.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FACELETS_RESOURCE_RESOLVER_PARAM_NAME

        public static final String FACELETS_RESOURCE_RESOLVER_PARAM_NAME
        Deprecated.
        See Also:
        Constant Field Values

    • Constructor Detail

      • ResourceResolver

        public ResourceResolver()
        Deprecated.

    • Method Detail

      • resolveUrl

        public abstract URL resolveUrl(String path)
        Deprecated.

        Returns the URL of a Facelet template file. Called by the Facelets Runtime to load a template file referred to in a Facelets page.

        Parameters:
        path - the internal path to the template resource.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Tag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class Tag

  • java.lang.Object
    • javax.faces.view.facelets.Tag

  • public final class Tag
extends Object

    The runtime must create an instance of this class for each element in the Facelets XHTML view. A TagConfig subinterface instance is responsible for providing an instance of Tag to the TagHandler instance that is passed the TagConfig in its constructor.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      Tag(Location location, String namespace, String localName, String qName, TagAttributes attributes)
      Tag(Tag orig, TagAttributes attributes)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      TagAttributes getAttributes()

      Return an object encapsulating the TagAttributes specified on this element in the view.
      String getLocalName()

      Return the XML local name of the tag.
      Location getLocation()

      Return the Location of this Tag instance in the Facelet view.
      String getNamespace()

      Return the resolved XML Namespace for this tag in the Facelets view.
      String getQName()

      Return the XML qualified name for this tag.
      String toString()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Tag

        public Tag(Location location,
   String namespace,
   String localName,
   String qName,
   TagAttributes attributes)

      • Tag

        public Tag(Tag orig,
   TagAttributes attributes)

    • Method Detail

      • getAttributes

        public TagAttributes getAttributes()

        Return an object encapsulating the TagAttributes specified on this element in the view.

      • getLocalName

        public String getLocalName()

        Return the XML local name of the tag. For example, <my:tag /> would be "tag".

      • getLocation

        public Location getLocation()

        Return the Location of this Tag instance in the Facelet view.

      • getNamespace

        public String getNamespace()

        Return the resolved XML Namespace for this tag in the Facelets view.

      • getQName

        public String getQName()

        Return the XML qualified name for this tag. For example, <my:tag /> would be "my:tag".

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class TagAttribute

  • java.lang.Object
    • javax.faces.view.facelets.TagAttribute

  • public abstract class TagAttribute
extends Object

    Representation of an XML attribute name=value pair on an XML element in a Facelet file.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      TagAttribute()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract boolean getBoolean(FaceletContext ctx)
      If literal, return Boolean.getBoolean(java.lang.String) passing our value, otherwise call getObject(FaceletContext, Class).
      abstract int getInt(FaceletContext ctx)
      If literal, call Integer.parseInt(String), otherwise call getObject(FaceletContext, Class).
      abstract String getLocalName()
      Local name of this attribute
      abstract Location getLocation()
      The location of this attribute in the FaceletContext
      abstract MethodExpression getMethodExpression(FaceletContext ctx, Class type, Class[] paramTypes)
      Create a MethodExpression, using this attribute's value as the expression String.
      abstract String getNamespace()
      The resolved Namespace for this attribute
      abstract Object getObject(FaceletContext ctx)
      Delegates to getObject with Object.class as a param
      abstract Object getObject(FaceletContext ctx, Class type)
      If literal, simply coerce our String literal value using an ExpressionFactory, otherwise create a ValueExpression and evaluate it.
      abstract String getQName()
      The qualified name for this attribute
      Tag getTag()

      A reference to the Tag for which this class represents the attributes.
      abstract String getValue()
      Return the literal value of this attribute
      abstract String getValue(FaceletContext ctx)
      If literal, then return our value, otherwise delegate to getObject, passing String.class.
      abstract ValueExpression getValueExpression(FaceletContext ctx, Class type)
      Create a ValueExpression, using this attribute's literal value and the passed expected type.
      abstract boolean isLiteral()
      If this TagAttribute is literal (not #{..} or ${..})
      void setTag(Tag tag)

      Set a reference to the Tag for which this class represents the attributes.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TagAttribute

        public TagAttribute()

    • Method Detail

      • getBoolean

        public abstract boolean getBoolean(FaceletContext ctx)
        If literal, return Boolean.getBoolean(java.lang.String) passing our value, otherwise call getObject(FaceletContext, Class).
        Parameters:
        ctx - FaceletContext to use
        Returns:
        boolean value
        See Also:
        Boolean.getBoolean(java.lang.String), getObject(FaceletContext, Class)

      • getInt

        public abstract int getInt(FaceletContext ctx)
        If literal, call Integer.parseInt(String), otherwise call getObject(FaceletContext, Class).
        Parameters:
        ctx - FaceletContext to use
        Returns:
        int value
        See Also:
        Integer.parseInt(java.lang.String), getObject(FaceletContext, Class)

      • getLocalName

        public abstract String getLocalName()
        Local name of this attribute
        Returns:
        local name of this attribute

      • getLocation

        public abstract Location getLocation()
        The location of this attribute in the FaceletContext
        Returns:
        the TagAttribute's location

      • getMethodExpression

        public abstract MethodExpression getMethodExpression(FaceletContext ctx,
                                   Class type,
                                   Class[] paramTypes)
        Create a MethodExpression, using this attribute's value as the expression String.
        Parameters:
        ctx - FaceletContext to use
        type - expected return type
        paramTypes - parameter type
        Returns:
        a MethodExpression instance
        See Also:
        ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class, java.lang.Class[]), MethodExpression

      • getNamespace

        public abstract String getNamespace()
        The resolved Namespace for this attribute
        Returns:
        resolved Namespace

      • getObject

        public abstract Object getObject(FaceletContext ctx)
        Delegates to getObject with Object.class as a param
        Parameters:
        ctx - FaceletContext to use
        Returns:
        Object representation of this attribute's value
        See Also:
        getObject(FaceletContext, Class)

      • getQName

        public abstract String getQName()
        The qualified name for this attribute
        Returns:
        the qualified name for this attribute

      • getValue

        public abstract String getValue()
        Return the literal value of this attribute
        Returns:
        literal value

      • getValue

        public abstract String getValue(FaceletContext ctx)
        If literal, then return our value, otherwise delegate to getObject, passing String.class.
        Parameters:
        ctx - FaceletContext to use
        Returns:
        String value of this attribute
        See Also:
        getObject(FaceletContext, Class)

      • getObject

        public abstract Object getObject(FaceletContext ctx,
               Class type)
        If literal, simply coerce our String literal value using an ExpressionFactory, otherwise create a ValueExpression and evaluate it.
        Parameters:
        ctx - FaceletContext to use
        type - expected return type
        Returns:
        Object value of this attribute
        See Also:
        ExpressionFactory.coerceToType(java.lang.Object, java.lang.Class), ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class), ValueExpression

      • getValueExpression

        public abstract ValueExpression getValueExpression(FaceletContext ctx,
                                 Class type)
        Create a ValueExpression, using this attribute's literal value and the passed expected type.
        Parameters:
        ctx - FaceletContext to use
        type - expected return type
        Returns:
        ValueExpression instance
        See Also:
        ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class), ValueExpression

      • isLiteral

        public abstract boolean isLiteral()
        If this TagAttribute is literal (not #{..} or ${..})
        Returns:
        true if this attribute is literal

      • getTag

        public Tag getTag()

        A reference to the Tag for which this class represents the attributes. For compatibility with previous implementations, an implementation is provided that returns null.

        Returns:
        the Tag for which this class represents the attributes.
        Since:
        2.2

      • setTag

        public void setTag(Tag tag)

        Set a reference to the Tag for which this class represents the attributes. The VDL runtime must ensure that this method is called before any FaceletHandlers for this element are instantiated. For compatibility with previous implementations, a no-op implementation is provided.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagAttributeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class TagAttributeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.view.facelets.FaceletException
              • javax.faces.view.facelets.TagAttributeException
  • All Implemented Interfaces:
    Serializable

    public final class TagAttributeException
extends FaceletException

    An Exception caused by a TagAttribute

    Since:
    2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TagAttributeException(TagAttribute attr)
      TagAttributeException(TagAttribute attr, String message)
      TagAttributeException(TagAttribute attr, String message, Throwable cause)
      TagAttributeException(TagAttribute attr, Throwable cause)
      TagAttributeException(Tag tag, TagAttribute attr)
      TagAttributeException(Tag tag, TagAttribute attr, String message)
      TagAttributeException(Tag tag, TagAttribute attr, String message, Throwable cause)
      TagAttributeException(Tag tag, TagAttribute attr, Throwable cause)

    • Method Summary

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TagAttributeException

        public TagAttributeException(TagAttribute attr)

      • TagAttributeException

        public TagAttributeException(TagAttribute attr,
                     String message)

      • TagAttributeException

        public TagAttributeException(TagAttribute attr,
                     Throwable cause)

      • TagAttributeException

        public TagAttributeException(TagAttribute attr,
                     String message,
                     Throwable cause)

      • TagAttributeException

        public TagAttributeException(Tag tag,
                     TagAttribute attr)

      • TagAttributeException

        public TagAttributeException(Tag tag,
                     TagAttribute attr,
                     String message)
        Parameters:
        message -

      • TagAttributeException

        public TagAttributeException(Tag tag,
                     TagAttribute attr,
                     Throwable cause)
        Parameters:
        cause -

      • TagAttributeException

        public TagAttributeException(Tag tag,
                     TagAttribute attr,
                     String message,
                     Throwable cause)
        Parameters:
        message -
        cause -
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagAttributes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class TagAttributes

  • java.lang.Object
    • javax.faces.view.facelets.TagAttributes

  • public abstract class TagAttributes
extends Object

    A set of TagAttributes, usually representing all attributes on a Tag.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      TagAttributes()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract TagAttribute get(String localName)
      Using no namespace, find the TagAttribute
      abstract TagAttribute get(String ns, String localName)
      Find a TagAttribute that matches the passed namespace and local name.
      abstract TagAttribute[] getAll()
      Return an array of all TagAttributes in this set
      abstract TagAttribute[] getAll(String namespace)
      Get all TagAttributes for the passed namespace
      abstract String[] getNamespaces()
      A list of Namespaces found in this set
      Tag getTag()

      A reference to the Tag for which this class represents the attributes.
      void setTag(Tag tag)

      Set a reference to the Tag for which this class represents the attributes.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TagAttributes

        public TagAttributes()

    • Method Detail

      • getAll

        public abstract TagAttribute[] getAll()
        Return an array of all TagAttributes in this set
        Returns:
        a non-null array of TagAttributes

      • get

        public abstract TagAttribute get(String localName)
        Using no namespace, find the TagAttribute
        Parameters:
        localName - tag attribute name
        Returns:
        the TagAttribute found, otherwise null
        See Also:
        get(String, String)

      • get

        public abstract TagAttribute get(String ns,
               String localName)
        Find a TagAttribute that matches the passed namespace and local name.
        Parameters:
        ns - namespace of the desired attribute
        localName - local name of the attribute
        Returns:
        a TagAttribute found, otherwise null

      • getAll

        public abstract TagAttribute[] getAll(String namespace)
        Get all TagAttributes for the passed namespace
        Parameters:
        namespace - namespace to search
        Returns:
        a non-null array of TagAttributes

      • getNamespaces

        public abstract String[] getNamespaces()
        A list of Namespaces found in this set
        Returns:
        a list of Namespaces found in this set

      • getTag

        public Tag getTag()

        A reference to the Tag for which this class represents the attributes. For compatibility with previous implementations, an implementation is provided that returns null.

        Returns:
        the Tag for which this class represents the attributes.
        Since:
        2.2

      • setTag

        public void setTag(Tag tag)

        Set a reference to the Tag for which this class represents the attributes. The VDL runtime must ensure that this method is called before any FaceletHandlers for this element are instantiated. For compatibility with previous implementations, a no-op implementation is provided.

        Since:
        2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface TagConfig

  • All Known Subinterfaces:
    BehaviorConfig, ComponentConfig, ConverterConfig, ValidatorConfig

    public interface TagConfig

    Passed to the constructor of TagHandler subclass, it defines the document definition of the handler we are instantiating.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      FaceletHandler getNextHandler()

      The next FaceletHandler (child or children) to be applied.
      Tag getTag()

      Return the Tag representing this handler.
      String getTagId()

      A document-unique id, follows the convention "_tagId##"

    • Method Detail

      • getTag

        Tag getTag()

        Return the Tag representing this handler.

      • getNextHandler

        FaceletHandler getNextHandler()

        The next FaceletHandler (child or children) to be applied. This must never be null.

      • getTagId

        String getTagId()

        A document-unique id, follows the convention "_tagId##"

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagDecorator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface TagDecorator

  • public interface TagDecorator

    Provides the ability to completely change the Tag before it's processed for compiling with the associated TagHandler.

    The runtime must provide a default implementation of this interface that performs the following actions in its decorate(javax.faces.view.facelets.Tag) method.

    • Inspect the attributes of the tag argument. If none of the attributes are declared to be in the http://xmlns.jcp.org/jsf namespace, iterate through the list of TagDecorator instances created from the values in the ViewHandler.FACELETS_DECORATORS_PARAM_NAME context-param, if any. For each entry, call its decorate(javax.faces.view.facelets.Tag) method, passing the argument tag. The first such entry that returns non-null from its decorate(javax.faces.view.facelets.Tag) method must cause the iteration to stop.

    • If one or more of the attributes of the tag argument are in the http://xmlns.jcp.org/jsf namespace, obtain a reference to decoratedTag as described in the following steps and iterate through the list of TagDecorator instances as described in the preceding step, but pass decoratedTag to each call to decorate(javax.faces.view.facelets.Tag).

      • If the namespace of the tag is any namespace other than the empty string or http://www.w3.org/1999/xhtml, throw a FaceletException.

      • Let localName be the return from Tag.getLocalName(). Use localName to identify an entry in a data structure based on the following table. Once an entry has been identified, let targetTag be the value of the "target tag" column for that entry.

        localName | selector attribute | target tag
        a | jsf:action | h:commandLink
        a | jsf:actionListener | h:commandLink
        a | jsf:value | h:outputLink
        a | jsf:outcome | h:link
        body | h:body
        button | h:commandButton
        button | jsf:outcome | h:button
        form | h:form
        head | h:head
        img | h:graphicImage
        input | type="button" | h:commandButton
        input | type="checkbox" | h:selectBooleanCheckbox
        input | type="color" | h:inputText
        input | type="date"
        input | type="datetime"
        input | type="datetime-local"
        input | type="email"
        input | type="month"
        input | type="number"
        input | type="range"
        input | type="search"
        input | type="time"
        input | type="url"
        input | type="week"
        input | type="file" | h:inputFile
        input | type="hidden" | h:inputHidden
        input | type="password" | h:inputSecret
        input | type="reset" | h:commandButton
        input | type="submit" | h:commandButton
        input | type="*" | h:inputText
        label | h:outputLabel
        link | h:outputStylesheet
        script | h:outputScript
        select | multiple="*" | h:selectManyListbox
        select | h:selectOneListbox
        textarea | h:inputTextArea

        In the case where there are multiple rows with the same localName, find a matching entry by using the argument tag's attributes and the value from the "selector attribute" column in the table in the given order. A selector attribute value of * indicates any value. In the table, a selector attribute name prefixed with jsf: means the tag is treated as if it were in the http://xmlns.jcp.org/jsf namespace. In actual Facelet pages, the namespace is what matters, not the prefix.

        If no matching entry is found, let jsf:element be the value of targetTag

      • Convert all the attributes of the argument tag as follows. First, create a new instance of TagAttribute with the following characteristics: location: from the argument tag's location, namespace: http://xmlns.jcp.org/jsf/passthrough, local name: value of Renderer.PASSTHROUGH_RENDERER_LOCALNAME_KEY, qualified name: same as local name with the "p:" prefix, value: from the argument tag's local name. Let this TagAttribute be elementNameTagAttribute.

        For each of argument tag's attributes obtain a reference to a TagAttribute with the following characteristics. For discussion let such an attribute be convertedTagAttribute.

        • convertedTagAttribute's location: from the argument tag's location.

        • If the current attribute's namespace is http://xmlns.jcp.org/jsf, convertedTagAttribute's qualified name must be the current attribute's local name and convertedTagAttribute's namespace must be the empty string. This will have the effect of setting the current attribute as a proper property on the UIComponent instance represented by this markup.

        • If the current attribute's namespace is empty or different from the argument tag's namespace, let the current attribute be convertedTagAttribute. This will have the effect of setting the current attribute as an attribute on the attributes map of the UIComponent instance represented by this markup.

        • Otherwise, assume the current attribute's namespace is http://xmlns.jcp.org/jsf/passthrough. ConvertedTagAttribute's qualified name is the current attribute's local name prefixed by "p:". convertedTagAttribute's namespace must be http://xmlns.jcp.org/jsf/passthrough.

        Create a TagAttributes instance containing elementNameTagAttribute and all the convertedTagAttributes.

      • Create a new Tag instance with the following characteristics.

        location: from the argument tag's location.

        namespace: if targetTag's prefix is "h", http://xmlns.jcp.org/jsf/html; if targetTag's prefix is "jsf", http://xmlns.jcp.org/jsf.

        local name: the local name from the target tag column.

        attributes: the TagAttributes from the preceding step.

        Let this new Tag instance be convertedTag.

    The Tag instance returned from this decoration process must ultimately be passed to a FaceletHandler instance as described in the spec prose document section titled, "Specification of the ViewDeclarationLanguage Implementation for Facelets for JSF 2.0".

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Tag decorate(Tag tag)
      If handled, return a new Tag instance, otherwise return null

    • Method Detail

      • decorate

        Tag decorate(Tag tag)
        If handled, return a new Tag instance, otherwise return null
        Parameters:
        tag - tag to be decorated
        Returns:
        a decorated tag, otherwise null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class TagException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.view.facelets.FaceletException
              • javax.faces.view.facelets.TagException
  • All Implemented Interfaces:
    Serializable

    public final class TagException
extends FaceletException

    An Exception caused by a Tag

    Since:
    2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TagException(Tag tag)

      Wrap the argument tag so the exception can reference its information.
      TagException(Tag tag, String message)

      Wrap the argument tag so the exception can reference its information.
      TagException(Tag tag, String message, Throwable cause)

      Wrap the argument tag so the exception can reference its information.
      TagException(Tag tag, Throwable cause)

      Wrap the argument tag so the exception can reference its information.

    • Method Summary

      • Methods inherited from class javax.faces.FacesException

        getCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TagException

        public TagException(Tag tag)

        Wrap the argument tag so the exception can reference its information.

        Parameters:
        tag - the Tag that caused this exception.

      • TagException

        public TagException(Tag tag,
            String message)

        Wrap the argument tag so the exception can reference its information.

        Parameters:
        tag - the Tag that caused this exception.
        message - a message describing the exception

      • TagException

        public TagException(Tag tag,
            Throwable cause)

        Wrap the argument tag so the exception can reference its information.

        Parameters:
        tag - the Tag that caused this exception.
        cause - the root cause for this exception.

      • TagException

        public TagException(Tag tag,
            String message,
            Throwable cause)

        Wrap the argument tag so the exception can reference its information.

        Parameters:
        tag - the Tag that caused this exception.
        message - a message describing the exception
        cause - the root cause for this exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class TagHandler

  • java.lang.Object
    • javax.faces.view.facelets.TagHandler
  • All Implemented Interfaces:
    FaceletHandler
    Direct Known Subclasses:
    MetaTagHandler

    public abstract class TagHandler
extends Object
implements FaceletHandler

    Foundation class for FaceletHandlers associated with a markup element in a Facelet document. This class introduces the concept of XML attributes to Facelets. See the constructor documentation for more details.

    Since:
    2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected FaceletHandler nextHandler

      A reference to the FaceletHandler that represents the first nested child of this TagHandler instance.
      protected Tag tag

      A reference to the Tag instance corresponding to this TagHandler instance.
      protected String tagId

      See TagConfig.getTagId().

    • Constructor Summary

      Constructors
      Constructor and Description
      TagHandler(TagConfig config)

      Every TagHandler instance is associated with a Tag.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected TagAttribute getAttribute(String localName)
      Utility method for fetching the appropriate TagAttribute
      protected TagAttribute getRequiredAttribute(String localName)
      Utility method for fetching a required TagAttribute
      String toString()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.faces.view.facelets.FaceletHandler

        apply

    • Field Detail

      • tagId

        protected final String tagId

        See TagConfig.getTagId().

      • tag

        protected final Tag tag

        A reference to the Tag instance corresponding to this TagHandler instance.

      • nextHandler

        protected final FaceletHandler nextHandler

        A reference to the FaceletHandler that represents the first nested child of this TagHandler instance.

    • Constructor Detail

      • TagHandler

        public TagHandler(TagConfig config)

        Every TagHandler instance is associated with a Tag. Each Tag instance has a TagAttributes property, which is simply a collection of TagAttribute instances. Extract and save as protected instance variables the TagConfig.getTagId(), TagConfig.getTag() and TagConfig.getNextHandler() returns from the argument TagConfig. This constructor is only called when the Facelets View is compiled.

        Parameters:
        config - The structure that contains useful to the operation of this instance.

    • Method Detail

      • getAttribute

        protected final TagAttribute getAttribute(String localName)
        Utility method for fetching the appropriate TagAttribute
        Parameters:
        localName - name of attribute
        Returns:
        TagAttribute if found, otherwise null

      • getRequiredAttribute

        protected final TagAttribute getRequiredAttribute(String localName)
                                           throws TagException
        Utility method for fetching a required TagAttribute
        Parameters:
        localName - name of the attribute
        Returns:
        TagAttribute if found, otherwise error
        Throws:
        TagException - if the attribute was not found

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagHandlerDelegate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class TagHandlerDelegate

  • java.lang.Object
    • javax.faces.view.facelets.TagHandlerDelegate

  • public abstract class TagHandlerDelegate
extends Object

    Abstract class that defines methods relating to helping tag handler instances. This abstraction enables implementation details to be hidden by the JSF implementation while still allowing concrete classes to be defined for extension by users.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      TagHandlerDelegate()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void apply(FaceletContext ctx, UIComponent comp)

      Called by classes that implement FaceletHandler in their implementation of apply().
      abstract MetaRuleset createMetaRuleset(Class type)

      Return a MetaRuleset particular to this kind of tag handler.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TagHandlerDelegate

        public TagHandlerDelegate()

    • Method Detail

      • createMetaRuleset

        public abstract MetaRuleset createMetaRuleset(Class type)

        Return a MetaRuleset particular to this kind of tag handler. Called from classes that implement MetaTagHandler.

        Parameters:
        type - the Class for which the MetaRuleset must be created.
        Since:
        2.0

      • apply

        public abstract void apply(FaceletContext ctx,
         UIComponent comp)
                    throws IOException

        Called by classes that implement FaceletHandler in their implementation of apply().

        If the argument comp is new to the view, for each tag attribute declared to be in the pass through attribute namespace, set the name and value of the attribute into the pass through attributes map of the component. See UIComponent.getPassThroughAttributes(boolean). See the VDLDocs for the namespace URI of the pass through attribute namespace. Attributes whose value is a ValueExpression must remain un-evaluated and stored in the map as ValueExpression instances.

        Parameters:
        ctx - the FaceletContext for this request
        comp - the UIComponent that corresponds to this element.
        Throws:
        IOException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagHandlerDelegateFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class TagHandlerDelegateFactory

  • java.lang.Object
    • javax.faces.view.facelets.TagHandlerDelegateFactory
  • All Implemented Interfaces:
    FacesWrapper<TagHandlerDelegateFactory>

    public abstract class TagHandlerDelegateFactory
extends Object
implements FacesWrapper<TagHandlerDelegateFactory>

    Abstract factory for creating instances of TagHandlerDelegate.

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      TagHandlerDelegateFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract TagHandlerDelegate createBehaviorHandlerDelegate(BehaviorHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with BehaviorHandler.
      abstract TagHandlerDelegate createComponentHandlerDelegate(ComponentHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with ComponentHandler.
      abstract TagHandlerDelegate createConverterHandlerDelegate(ConverterHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with ConverterHandler.
      abstract TagHandlerDelegate createValidatorHandlerDelegate(ValidatorHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with ValidatorHandler.
      TagHandlerDelegateFactory getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TagHandlerDelegateFactory

        public TagHandlerDelegateFactory()

    • Method Detail

      • getWrapped

        public TagHandlerDelegateFactory getWrapped()

        If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped. A default implementation is provided that returns null.

        Specified by:
        getWrapped in interface FacesWrapper<TagHandlerDelegateFactory>
        Since:
        2.2

      • createComponentHandlerDelegate

        public abstract TagHandlerDelegate createComponentHandlerDelegate(ComponentHandler owner)

        Create and return a TagHandlerDelegate instance designed for use with ComponentHandler.

        Parameters:
        owner - the ComponentHandler instance being helped by this helper instance.
        Since:
        2.0

      • createValidatorHandlerDelegate

        public abstract TagHandlerDelegate createValidatorHandlerDelegate(ValidatorHandler owner)

        Create and return a TagHandlerDelegate instance designed for use with ValidatorHandler.

        Parameters:
        owner - the ValidatorHandler instance being helped by this helper instance.
        Since:
        2.0

      • createConverterHandlerDelegate

        public abstract TagHandlerDelegate createConverterHandlerDelegate(ConverterHandler owner)

        Create and return a TagHandlerDelegate instance designed for use with ConverterHandler.

        Parameters:
        owner - the ValidatorHandler instance being helped by this helper instance.
        Since:
        2.0

      • createBehaviorHandlerDelegate

        public abstract TagHandlerDelegate createBehaviorHandlerDelegate(BehaviorHandler owner)

        Create and return a TagHandlerDelegate instance designed for use with BehaviorHandler.

        Parameters:
        owner - the ValidatorHandler instance being helped by this helper instance.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TextHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface TextHandler

  • public interface TextHandler

    An interface that allows other code to identify FaceletHandlers that may provide text (String) content.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getText()

      Returns the literal String value of the contained text.
      String getText(FaceletContext ctx)

      Returns the resolved literal String value of the contained text after evaluating EL.

    • Method Detail

      • getText

        String getText()

        Returns the literal String value of the contained text.

      • getText

        String getText(FaceletContext ctx)

        Returns the resolved literal String value of the contained text after evaluating EL.

        Parameters:
        ctx - the FaceletContext for this view execution
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.view.facelets (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.view.facelets

  • Packages that use javax.faces.view.facelets
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.
  • Classes in javax.faces.view.facelets used by javax.faces.view.facelets
    Class and Description
    BehaviorConfig

    Convey the id of a behavior declared in a view.
    BehaviorHandler

    The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).
    ComponentConfig

    Passed to the constructor of ComponentHandler.
    ComponentHandler

    Public base class for markup element instances that map to UIComponent instances in the view.
    ConverterConfig

    A Facelet version of the JSP ConverterTag.
    ConverterHandler

    Handles setting a Converter instance on a ValueHolder parent.
    DelegatingMetaTagHandler

    Enable the JSF implementation to provide the appropriate behavior for the kind of MetaTagHandler subclass for each kind of element in the view, while providing a base-class from which those wanting to make a Java language custom tag handler can inherit.
    FaceletCache

    This API defines the facility by which the Facelets ViewDeclarationLanguage creates and caches instances of Facelets.
    FaceletCache.MemberFactory

    Factory interface for creating Facelet or View Metadata Facelet instances.
    FaceletCacheFactory

    Allows customization of the implementation of FaceletCache.
    FaceletContext

    Context representative of a single request from a Facelet.
    FaceletException

    An Exception from the Facelet implementation
    FaceletHandler

    This is the root class for markup elements in Facelets VDL.
    FaceletsAttachedObjectHandler

    Root class for all tag handlers that represent attached objetcts in a Facelets page.
    Metadata

    There are concrete subclasses within the implementation that map concepts in the Facelet VDL page to JSF Java API calls the appropriate instances.
    MetadataTarget

    Information used with MetaRule for determining how and what Metadata should be wired.
    MetaRule

    The root class of the abstraction that dictates how attributes on a markup element in a Facelets VDL page are wired to the JSF API object instance associated with that element.
    MetaRuleset

    A mutable set of rules to be used in auto-wiring state to a particular object instance.
    MetaTagHandler

    Every kind of markup element in Facelets VDL that has attributes that need to take action on a JSF Java API artifact is associated with an instance of this class.
    Tag

    The runtime must create an instance of this class for each element in the Facelets XHTML view.
    TagAttribute

    Representation of an XML attribute name=value pair on an XML element in a Facelet file.
    TagAttributes

    A set of TagAttributes, usually representing all attributes on a Tag.
    TagConfig

    Passed to the constructor of TagHandler subclass, it defines the document definition of the handler we are instantiating.
    TagException

    An Exception caused by a Tag
    TagHandler

    Foundation class for FaceletHandlers associated with a markup element in a Facelet document.
    TagHandlerDelegate

    Abstract class that defines methods relating to helping tag handler instances.
    TagHandlerDelegateFactory

    Abstract factory for creating instances of TagHandlerDelegate.
    ValidatorConfig

    Used in creating ValidatorHandler and all implementations.
    ValidatorHandler

    Handles setting a Validator instance on an EditableValueHolder parent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidatorConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Interface ValidatorConfig

  • All Superinterfaces:
    TagConfig

    public interface ValidatorConfig
extends TagConfig

    Used in creating ValidatorHandler and all implementations.

    Since:
    2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getValidatorId()

      Return the validator-id associated with a particular validator in your faces-config

      • Methods inherited from interface javax.faces.view.facelets.TagConfig

        getNextHandler, getTag, getTagId

    • Method Detail

      • getValidatorId

        String getValidatorId()

        Return the validator-id associated with a particular validator in your faces-config

        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidatorHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.view.facelets

Class ValidatorHandler

  • java.lang.Object
    • javax.faces.view.facelets.TagHandler
      • javax.faces.view.facelets.MetaTagHandler
        • javax.faces.view.facelets.DelegatingMetaTagHandler
          • javax.faces.view.facelets.FaceletsAttachedObjectHandler
            • javax.faces.view.facelets.ValidatorHandler
  • All Implemented Interfaces:
    AttachedObjectHandler, EditableValueHolderAttachedObjectHandler, FaceletHandler, ValueHolderAttachedObjectHandler

    public class ValidatorHandler
extends FaceletsAttachedObjectHandler
implements EditableValueHolderAttachedObjectHandler

    Handles setting a Validator instance on an EditableValueHolder parent. Will wire all attributes set to the Validator instance created/fetched. Uses the "binding" attribute for grabbing instances to apply attributes to.

    Will only set/create Validator is the passed UIComponent's parent is null, signifying that it wasn't restored from an existing tree.

    • Field Summary

      • Fields inherited from class javax.faces.view.facelets.DelegatingMetaTagHandler

        delegateFactory

      • Fields inherited from class javax.faces.view.facelets.TagHandler

        nextHandler, tag, tagId

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidatorHandler(ValidatorConfig config)

      Construct this instance around the configuration information in argument config

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected TagHandlerDelegate getTagHandlerDelegate()

      Return the implementation specific delegate instance that provides the bulk of the work for this handler instance.
      ValidatorConfig getValidatorConfig()

      Return the TagConfig subclass used to configure this handler instance.
      String getValidatorId(FaceletContext ctx)
      Retrieve the id of the validator that is to be created and added to the parent EditableValueHolder.

      • Methods inherited from class javax.faces.view.facelets.FaceletsAttachedObjectHandler

        applyAttachedObject, getAttachedObjectHandlerHelper, getFor

      • Methods inherited from class javax.faces.view.facelets.DelegatingMetaTagHandler

        apply, applyNextHandler, createMetaRuleset, getBinding, getTag, getTagAttribute, getTagId, isDisabled, setAttributes

      • Methods inherited from class javax.faces.view.facelets.TagHandler

        getAttribute, getRequiredAttribute, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.faces.view.AttachedObjectHandler

        applyAttachedObject, getFor

    • Constructor Detail

      • ValidatorHandler

        public ValidatorHandler(ValidatorConfig config)

        Construct this instance around the configuration information in argument config

        Parameters:
        config - the TagConfig subclass for this kind of attached object.

    • Method Detail

      • getTagHandlerDelegate

        protected TagHandlerDelegate getTagHandlerDelegate()

        Return the implementation specific delegate instance that provides the bulk of the work for this handler instance.

        Specified by:
        getTagHandlerDelegate in class DelegatingMetaTagHandler

      • getValidatorId

        public String getValidatorId(FaceletContext ctx)

        Retrieve the id of the validator that is to be created and added to the parent EditableValueHolder. All subclasses should override this method because it is important for Facelets to have a unique way of identifying the validators that are added to this EditableValueHolder and allows exclusions to work properly. An exclusion is a validator declaration that has the attribute "disabled" which resolves to false, instructing Facelets not to register a default validator with the same id.

      • getValidatorConfig

        public ValidatorConfig getValidatorConfig()

        Return the TagConfig subclass used to configure this handler instance.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.faces.view.facelets.BehaviorHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.BehaviorHandler

  • Packages that use BehaviorHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of BehaviorHandler in javax.faces.view.facelets

      Methods in javax.faces.view.facelets with parameters of type BehaviorHandler
      Modifier and Type Method and Description
      abstract TagHandlerDelegate TagHandlerDelegateFactory.createBehaviorHandlerDelegate(BehaviorHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with BehaviorHandler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.ComponentHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.ComponentHandler

  • Packages that use ComponentHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of ComponentHandler in javax.faces.view.facelets

      Methods in javax.faces.view.facelets with parameters of type ComponentHandler
      Modifier and Type Method and Description
      abstract TagHandlerDelegate TagHandlerDelegateFactory.createComponentHandlerDelegate(ComponentHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with ComponentHandler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.CompositeFaceletHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.CompositeFaceletHandler

No usage of javax.faces.view.facelets.CompositeFaceletHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.ConverterHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.ConverterHandler

  • Packages that use ConverterHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of ConverterHandler in javax.faces.view.facelets

      Methods in javax.faces.view.facelets with parameters of type ConverterHandler
      Modifier and Type Method and Description
      abstract TagHandlerDelegate TagHandlerDelegateFactory.createConverterHandlerDelegate(ConverterHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with ConverterHandler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.DelegatingMetaTagHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.DelegatingMetaTagHandler

  • Packages that use DelegatingMetaTagHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of DelegatingMetaTagHandler in javax.faces.view.facelets

      Subclasses of DelegatingMetaTagHandler in javax.faces.view.facelets
      Modifier and Type Class and Description
      class  BehaviorHandler

      The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).
      class  ComponentHandler

      Public base class for markup element instances that map to UIComponent instances in the view.
      class  ConverterHandler

      Handles setting a Converter instance on a ValueHolder parent.
      class  FaceletsAttachedObjectHandler

      Root class for all tag handlers that represent attached objetcts in a Facelets page.
      class  ValidatorHandler

      Handles setting a Validator instance on an EditableValueHolder parent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.Facelet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.Facelet

No usage of javax.faces.view.facelets.Facelet
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.FaceletCache (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.FaceletCache

  • Packages that use FaceletCache
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of FaceletCache in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return FaceletCache
      Modifier and Type | Method and Description
      abstract FaceletCache | FaceletCacheFactory.getFaceletCache()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.FaceletCacheFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.FaceletCacheFactory

  • Packages that use FaceletCacheFactory
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of FaceletCacheFactory in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return FaceletCacheFactory
      Modifier and Type | Method and Description
      FaceletCacheFactory | FaceletCacheFactory.getWrapped()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.FaceletContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.FaceletContext

  • Packages that use FaceletContext
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of FaceletContext in javax.faces.view.facelets

      Methods in javax.faces.view.facelets with parameters of type FaceletContext
      Modifier and Type | Method and Description
      abstract void TagHandlerDelegate.apply(FaceletContext ctx, UIComponent comp)

      Called by classes that implement FaceletHandler in their implementation of apply().
      void FaceletHandler.apply(FaceletContext ctx, UIComponent parent)

      Process changes on a particular UIComponent
      void DelegatingMetaTagHandler.apply(FaceletContext ctx, UIComponent parent)

      The default implementation simply calls through to TagHandlerDelegate.apply(javax.faces.view.facelets.FaceletContext, javax.faces.component.UIComponent).
      void CompositeFaceletHandler.apply(FaceletContext ctx, UIComponent parent)

      Calls apply on any child handlers.
      abstract void Metadata.applyMetadata(FaceletContext ctx, Object instance)

      Take the action prescribed in the JSF specification for this particular VDL element attribute.
      void DelegatingMetaTagHandler.applyNextHandler(FaceletContext ctx, UIComponent c)

      Invoke the apply() method on this instance's TagHandler.nextHandler.
      UIComponent ComponentHandler.createComponent(FaceletContext ctx)

      Subclasses that wish to take over the task of instantiating the UIComponent instance corresponding to this tag handler my override this method to do so.
      String AttributeHandler.getAttributeName(FaceletContext ctx)

      Returns the resolved literal String value of the attribute name after evaluating EL.
      abstract boolean TagAttribute.getBoolean(FaceletContext ctx)
      If literal, return Boolean.getBoolean(java.lang.String) passing our value, otherwise call getObject(FaceletContext, Class).
      String | ConverterHandler.getConverterId(FaceletContext ctx)
      String FacetHandler.getFacetName(FaceletContext ctx)

      Returns the resolved literal String value of the facet name after evaluating EL.
      abstract int TagAttribute.getInt(FaceletContext ctx)
      If literal, call Integer.parseInt(String), otherwise call getObject(FaceletContext, Class).
      abstract MethodExpression TagAttribute.getMethodExpression(FaceletContext ctx, Class type, Class[] paramTypes)
      Create a MethodExpression, using this attribute's value as the expression String.
      abstract Object TagAttribute.getObject(FaceletContext ctx)
      Delegates to getObject with Object.class as a param
      abstract Object TagAttribute.getObject(FaceletContext ctx, Class type)
      If literal, simply coerce our String literal value using an ExpressionFactory, otherwise create a ValueExpression and evaluate it.
      String TextHandler.getText(FaceletContext ctx)

      Returns the resolved literal String value of the contained text after evaluating EL.
      String ValidatorHandler.getValidatorId(FaceletContext ctx)
      Retrieve the id of the validator that is to be created and added to the parent EditableValueHolder.
      abstract String TagAttribute.getValue(FaceletContext ctx)
      If literal, then return our value, otherwise delegate to getObject, passing String.class.
      abstract ValueExpression TagAttribute.getValueExpression(FaceletContext ctx, Class type)
      Create a ValueExpression, using this attribute's literal value and the passed expected type.
      boolean | DelegatingMetaTagHandler.isDisabled(FaceletContext ctx)
      void ComponentHandler.onComponentCreated(FaceletContext ctx, UIComponent c, UIComponent parent)

      This method is guaranteed to be called after the component has been created but before it has been populated with children.
      void ComponentHandler.onComponentPopulated(FaceletContext ctx, UIComponent c, UIComponent parent)

      This method is guaranteed to be called after the component has been populated with children.
      protected void MetaTagHandler.setAttributes(FaceletContext ctx, Object instance)
      Invoking/extending this method will cause the results of the created MetaRuleset to auto-wire state to the passed instance.
      void | DelegatingMetaTagHandler.setAttributes(FaceletContext ctx, Object instance)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.FaceletException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.FaceletException

  • Packages that use FaceletException
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of FaceletException in javax.faces.view.facelets

      Subclasses of FaceletException in javax.faces.view.facelets
      Modifier and Type Class and Description
      class  TagAttributeException

      An Exception caused by a TagAttribute
      class  TagException

      An Exception caused by a Tag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.FaceletsAttachedObjectHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.FaceletsAttachedObjectHandler

  • Packages that use FaceletsAttachedObjectHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of FaceletsAttachedObjectHandler in javax.faces.view.facelets

      Subclasses of FaceletsAttachedObjectHandler in javax.faces.view.facelets
      Modifier and Type Class and Description
      class  BehaviorHandler

      The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).
      class  ConverterHandler

      Handles setting a Converter instance on a ValueHolder parent.
      class  ValidatorHandler

      Handles setting a Validator instance on an EditableValueHolder parent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.FaceletsResourceResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.FaceletsResourceResolver

No usage of javax.faces.view.facelets.FaceletsResourceResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.Metadata (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.Metadata

  • Packages that use Metadata
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of Metadata in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return Metadata
      Modifier and Type Method and Description
      abstract Metadata MetaRule.applyRule(String name, TagAttribute attribute, MetadataTarget meta)

      Return an abstraction that takes appropriate action given the kind of rule represented by the argument name, in the context of this particular concrete subclass of MetaRule.
      abstract Metadata MetaRuleset.finish()

      Take actions to apply the rule.
      Methods in javax.faces.view.facelets with parameters of type Metadata
      Modifier and Type Method and Description
      abstract MetaRuleset MetaRuleset.add(Metadata mapper)

      Add another Metadata to this ruleset, returning this.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.MetadataTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.MetadataTarget

  • Packages that use MetadataTarget
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of MetadataTarget in javax.faces.view.facelets

      Methods in javax.faces.view.facelets with parameters of type MetadataTarget
      Modifier and Type Method and Description
      abstract Metadata MetaRule.applyRule(String name, TagAttribute attribute, MetadataTarget meta)

      Return an abstraction that takes appropriate action given the kind of rule represented by the argument name, in the context of this particular concrete subclass of MetaRule.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.MetaRule (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.MetaRule

  • Packages that use MetaRule
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of MetaRule in javax.faces.view.facelets

      Methods in javax.faces.view.facelets with parameters of type MetaRule
      Modifier and Type Method and Description
      abstract MetaRuleset MetaRuleset.addRule(MetaRule rule)

      Add another MetaRule to this ruleset, returning this.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.MetaRuleset (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.MetaRuleset

  • Packages that use MetaRuleset
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of MetaRuleset in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return MetaRuleset
      Modifier and Type Method and Description
      abstract MetaRuleset MetaRuleset.add(Metadata mapper)

      Add another Metadata to this ruleset, returning this.
      abstract MetaRuleset MetaRuleset.addRule(MetaRule rule)

      Add another MetaRule to this ruleset, returning this.
      abstract MetaRuleset MetaRuleset.alias(String attribute, String property)

      Customize this MetaRuleset by removing the attribute named by argument attribute and re-adding it under the name given by the argument property, returning this.
      abstract MetaRuleset TagHandlerDelegate.createMetaRuleset(Class type)

      Return a MetaRuleset particular to this kind of tag handler.
      protected abstract MetaRuleset MetaTagHandler.createMetaRuleset(Class type)
      Extend this method in order to add your own rules.
      protected MetaRuleset DelegatingMetaTagHandler.createMetaRuleset(Class type)

      The default implementation simply calls through to TagHandlerDelegate.createMetaRuleset(java.lang.Class) and returns the result.
      abstract MetaRuleset MetaRuleset.ignore(String attribute)

      Customize this MetaRuleset instance to advise it to ignore the attribute named by the attribute argument, returning this.
      abstract MetaRuleset MetaRuleset.ignoreAll()

      Customize this MetaRuleset instance to advise it to ignore all attributes, returning this.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.MetaTagHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.MetaTagHandler

  • Packages that use MetaTagHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of MetaTagHandler in javax.faces.view.facelets

      Subclasses of MetaTagHandler in javax.faces.view.facelets
      Modifier and Type Class and Description
      class  BehaviorHandler

      The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).
      class  ComponentHandler

      Public base class for markup element instances that map to UIComponent instances in the view.
      class  ConverterHandler

      Handles setting a Converter instance on a ValueHolder parent.
      class  DelegatingMetaTagHandler

      Enable the JSF implementation to provide the appropriate behavior for the kind of MetaTagHandler subclass for each kind of element in the view, while providing a base-class from which those wanting to make a Java language custom tag handler can inherit.
      class  FaceletsAttachedObjectHandler

      Root class for all tag handlers that represent attached objetcts in a Facelets page.
      class  ValidatorHandler

      Handles setting a Validator instance on an EditableValueHolder parent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.ResourceResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.ResourceResolver

No usage of javax.faces.view.facelets.ResourceResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.Tag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.Tag

  • Packages that use Tag
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of Tag in javax.faces.view.facelets

      Fields in javax.faces.view.facelets declared as Tag
      Modifier and Type Field and Description
      protected Tag TagHandler.tag

      A reference to the Tag instance corresponding to this TagHandler instance.
      Methods in javax.faces.view.facelets that return Tag
      Modifier and Type | Method and Description
      Tag TagDecorator.decorate(Tag tag)
      If handled, return a new Tag instance, otherwise return null
      Tag TagConfig.getTag()

      Return the Tag representing this handler.
      Tag TagAttributes.getTag()

      A reference to the Tag for which this class represents the attributes.
      Tag TagAttribute.getTag()

      A reference to the Tag for which this class represents the attributes.
      Tag | DelegatingMetaTagHandler.getTag()
      Methods in javax.faces.view.facelets with parameters of type Tag
      Modifier and Type Method and Description
      Tag TagDecorator.decorate(Tag tag)
      If handled, return a new Tag instance, otherwise return null
      void TagAttributes.setTag(Tag tag)

      Set a reference to the Tag for which this class represents the attributes.
      void TagAttribute.setTag(Tag tag)

      Set a reference to the Tag for which this class represents the attributes.
      Constructors in javax.faces.view.facelets with parameters of type Tag
      Constructor and Description
      Tag(Tag orig, TagAttributes attributes)
      TagAttributeException(Tag tag, TagAttribute attr)
      TagAttributeException(Tag tag, TagAttribute attr, String message)
      TagAttributeException(Tag tag, TagAttribute attr, String message, Throwable cause)
      TagAttributeException(Tag tag, TagAttribute attr, Throwable cause)
      TagException(Tag tag)

      Wrap the argument tag so the exception can reference its information.
      TagException(Tag tag, String message)

      Wrap the argument tag so the exception can reference its information.
      TagException(Tag tag, String message, Throwable cause)

      Wrap the argument tag so the exception can reference its information.
      TagException(Tag tag, Throwable cause)

      Wrap the argument tag so the exception can reference its information.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.TagAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.TagAttribute

  • Packages that use TagAttribute
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of TagAttribute in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return TagAttribute
      Modifier and Type | Method and Description
      abstract TagAttribute TagAttributes.get(String localName)
      Using no namespace, find the TagAttribute
      abstract TagAttribute TagAttributes.get(String ns, String localName)
      Find a TagAttribute that matches the passed namespace and local name.
      abstract TagAttribute[] TagAttributes.getAll()
      Return an array of all TagAttributes in this set
      abstract TagAttribute[] TagAttributes.getAll(String namespace)
      Get all TagAttributes for the passed namespace
      protected TagAttribute TagHandler.getAttribute(String localName)
      Utility method for fetching the appropriate TagAttribute
      TagAttribute | DelegatingMetaTagHandler.getBinding()
      TagAttribute | BehaviorHandler.getEvent()
      protected TagAttribute TagHandler.getRequiredAttribute(String localName)
      Utility method for fetching a required TagAttribute
      TagAttribute | DelegatingMetaTagHandler.getTagAttribute(String localName)
      Methods in javax.faces.view.facelets with parameters of type TagAttribute
      Modifier and Type Method and Description
      abstract Metadata MetaRule.applyRule(String name, TagAttribute attribute, MetadataTarget meta)

      Return an abstraction that takes appropriate action given the kind of rule represented by the argument name, in the context of this particular concrete subclass of MetaRule.
      Constructors in javax.faces.view.facelets with parameters of type TagAttribute
      Constructor and Description
      TagAttributeException(TagAttribute attr)
      TagAttributeException(TagAttribute attr, String message)
      TagAttributeException(TagAttribute attr, String message, Throwable cause)
      TagAttributeException(TagAttribute attr, Throwable cause)
      TagAttributeException(Tag tag, TagAttribute attr)
      TagAttributeException(Tag tag, TagAttribute attr, String message)
      TagAttributeException(Tag tag, TagAttribute attr, String message, Throwable cause)
      TagAttributeException(Tag tag, TagAttribute attr, Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.TagAttributeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.TagAttributeException

No usage of javax.faces.view.facelets.TagAttributeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.TagAttributes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.TagAttributes

  • Packages that use TagAttributes
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of TagAttributes in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return TagAttributes
      Modifier and Type Method and Description
      TagAttributes Tag.getAttributes()

      Return an object encapsulating the TagAttributes specified on this element in the view.
      Constructors in javax.faces.view.facelets with parameters of type TagAttributes
      Constructor and Description
      Tag(Location location, String namespace, String localName, String qName, TagAttributes attributes)
      Tag(Tag orig, TagAttributes attributes)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.TagException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.TagException

  • Packages that use TagException
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of TagException in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that throw TagException
      Modifier and Type Method and Description
      protected TagAttribute TagHandler.getRequiredAttribute(String localName)
      Utility method for fetching a required TagAttribute
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.TagHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.TagHandler

  • Packages that use TagHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of TagHandler in javax.faces.view.facelets

      Subclasses of TagHandler in javax.faces.view.facelets
      Modifier and Type Class and Description
      class  BehaviorHandler

      The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).
      class  ComponentHandler

      Public base class for markup element instances that map to UIComponent instances in the view.
      class  ConverterHandler

      Handles setting a Converter instance on a ValueHolder parent.
      class  DelegatingMetaTagHandler

      Enable the JSF implementation to provide the appropriate behavior for the kind of MetaTagHandler subclass for each kind of element in the view, while providing a base-class from which those wanting to make a Java language custom tag handler can inherit.
      class  FaceletsAttachedObjectHandler

      Root class for all tag handlers that represent attached objetcts in a Facelets page.
      class  MetaTagHandler

      Every kind of markup element in Facelets VDL that has attributes that need to take action on a JSF Java API artifact is associated with an instance of this class.
      class  ValidatorHandler

      Handles setting a Validator instance on an EditableValueHolder parent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.TagHandlerDelegate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.TagHandlerDelegate

  • Packages that use TagHandlerDelegate
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of TagHandlerDelegate in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return TagHandlerDelegate
      Modifier and Type | Method and Description
      abstract TagHandlerDelegate TagHandlerDelegateFactory.createBehaviorHandlerDelegate(BehaviorHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with BehaviorHandler.
      abstract TagHandlerDelegate TagHandlerDelegateFactory.createComponentHandlerDelegate(ComponentHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with ComponentHandler.
      abstract TagHandlerDelegate TagHandlerDelegateFactory.createConverterHandlerDelegate(ConverterHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with ConverterHandler.
      abstract TagHandlerDelegate TagHandlerDelegateFactory.createValidatorHandlerDelegate(ValidatorHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with ValidatorHandler.
      protected TagHandlerDelegate ValidatorHandler.getTagHandlerDelegate()

      Return the implementation specific delegate instance that provides the bulk of the work for this handler instance.
      protected abstract TagHandlerDelegate | DelegatingMetaTagHandler.getTagHandlerDelegate()
      protected TagHandlerDelegate | ConverterHandler.getTagHandlerDelegate()
      protected TagHandlerDelegate | ComponentHandler.getTagHandlerDelegate()
      protected TagHandlerDelegate | BehaviorHandler.getTagHandlerDelegate()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.TagHandlerDelegateFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.TagHandlerDelegateFactory

  • Packages that use TagHandlerDelegateFactory
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of TagHandlerDelegateFactory in javax.faces.view.facelets

      Fields in javax.faces.view.facelets declared as TagHandlerDelegateFactory
      Modifier and Type | Field and Description
      protected TagHandlerDelegateFactory | DelegatingMetaTagHandler.delegateFactory
      Methods in javax.faces.view.facelets that return TagHandlerDelegateFactory
      Modifier and Type Method and Description
      TagHandlerDelegateFactory TagHandlerDelegateFactory.getWrapped()

      If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.view.facelets.ValidatorHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.view.facelets.ValidatorHandler

  • Packages that use ValidatorHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of ValidatorHandler in javax.faces.view.facelets

      Methods in javax.faces.view.facelets with parameters of type ValidatorHandler
      Modifier and Type Method and Description
      abstract TagHandlerDelegate TagHandlerDelegateFactory.createValidatorHandlerDelegate(ValidatorHandler owner)

      Create and return a TagHandlerDelegate instance designed for use with ValidatorHandler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.AttributeHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.AttributeHandler

No usage of javax.faces.view.facelets.AttributeHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.BehaviorConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.BehaviorConfig

  • Packages that use BehaviorConfig
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of BehaviorConfig in javax.faces.view.facelets

      Constructors in javax.faces.view.facelets with parameters of type BehaviorConfig
      Constructor and Description
      BehaviorHandler(BehaviorConfig config)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.ComponentConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.ComponentConfig

  • Packages that use ComponentConfig
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of ComponentConfig in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return ComponentConfig
      Modifier and Type | Method and Description
      ComponentConfig | ComponentHandler.getComponentConfig()
      Constructors in javax.faces.view.facelets with parameters of type ComponentConfig
      Constructor and Description
      ComponentHandler(ComponentConfig config)

      Leverage the TagHandlerDelegateFactory provided by the implementation to create an instance of TagHandlerDelegate designed for use with ComponentHandler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.ConverterConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.ConverterConfig

  • Packages that use ConverterConfig
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of ConverterConfig in javax.faces.view.facelets

      Constructors in javax.faces.view.facelets with parameters of type ConverterConfig
      Constructor and Description
      ConverterHandler(ConverterConfig config)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.FaceletCache.MemberFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.FaceletCache.MemberFactory

  • Packages that use FaceletCache.MemberFactory
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of FaceletCache.MemberFactory in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return FaceletCache.MemberFactory
      Modifier and Type Method and Description
      protected FaceletCache.MemberFactory<V> FaceletCache.getMemberFactory()

      Returns the FaceletCache.MemberFactory passed to FaceletCache.setMemberFactories(javax.faces.view.facelets.FaceletCache.MemberFactory<V>, javax.faces.view.facelets.FaceletCache.MemberFactory<V>) for the purpose of creating Facelet instance.
      protected FaceletCache.MemberFactory<V> FaceletCache.getMetadataMemberFactory()

      Returns the FaceletCache.MemberFactory passed to FaceletCache.setMemberFactories(javax.faces.view.facelets.FaceletCache.MemberFactory<V>, javax.faces.view.facelets.FaceletCache.MemberFactory<V>) for the purpose of creating View Metadata Facelet instance.
      Methods in javax.faces.view.facelets with parameters of type FaceletCache.MemberFactory
      Modifier and Type Method and Description
      protected void FaceletCache.setMemberFactories(FaceletCache.MemberFactory<V> faceletFactory, FaceletCache.MemberFactory<V> viewMetadataFaceletFactory)

      This must be called by the runtime at startup time, before any requests are serviced, and allows for the FaceletCache implementation to provide the FaceletCache.MemberFactory instances that will be used to create instances of Facelets and View Metadata Facelets.
      protected void FaceletCache.setMemberFactories(FaceletCache.MemberFactory<V> faceletFactory, FaceletCache.MemberFactory<V> viewMetadataFaceletFactory)

      This must be called by the runtime at startup time, before any requests are serviced, and allows for the FaceletCache implementation to provide the FaceletCache.MemberFactory instances that will be used to create instances of Facelets and View Metadata Facelets.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.FaceletHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.FaceletHandler

  • Packages that use FaceletHandler
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of FaceletHandler in javax.faces.view.facelets

      Classes in javax.faces.view.facelets that implement FaceletHandler
      Modifier and Type Class and Description
      class  BehaviorHandler

      The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).
      class  ComponentHandler

      Public base class for markup element instances that map to UIComponent instances in the view.
      class  CompositeFaceletHandler

      A FaceletHandler that is derived of 1 or more, inner FaceletHandlers.
      class  ConverterHandler

      Handles setting a Converter instance on a ValueHolder parent.
      class  DelegatingMetaTagHandler

      Enable the JSF implementation to provide the appropriate behavior for the kind of MetaTagHandler subclass for each kind of element in the view, while providing a base-class from which those wanting to make a Java language custom tag handler can inherit.
      class  FaceletsAttachedObjectHandler

      Root class for all tag handlers that represent attached objetcts in a Facelets page.
      class  MetaTagHandler

      Every kind of markup element in Facelets VDL that has attributes that need to take action on a JSF Java API artifact is associated with an instance of this class.
      class  TagHandler

      Foundation class for FaceletHandlers associated with a markup element in a Facelet document.
      class  ValidatorHandler

      Handles setting a Validator instance on an EditableValueHolder parent.
      Fields in javax.faces.view.facelets declared as FaceletHandler
      Modifier and Type Field and Description
      protected FaceletHandler TagHandler.nextHandler

      A reference to the FaceletHandler that represents the first nested child of this TagHandler instance.
      Methods in javax.faces.view.facelets that return FaceletHandler
      Modifier and Type Method and Description
      FaceletHandler[] CompositeFaceletHandler.getHandlers()

      Returns the array of child handlers contained by this handler.
      FaceletHandler TagConfig.getNextHandler()

      The next FaceletHandler (child or children) to be applied.
      Constructors in javax.faces.view.facelets with parameters of type FaceletHandler
      Constructor and Description
      CompositeFaceletHandler(FaceletHandler[] children)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.FacetHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.FacetHandler

No usage of javax.faces.view.facelets.FacetHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.TagConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.TagConfig

  • Packages that use TagConfig
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of TagConfig in javax.faces.view.facelets

      Subinterfaces of TagConfig in javax.faces.view.facelets
      Modifier and Type Interface and Description
      interface  BehaviorConfig

      Convey the id of a behavior declared in a view.
      interface  ComponentConfig

      Passed to the constructor of ComponentHandler.
      interface  ConverterConfig

      A Facelet version of the JSP ConverterTag.
      interface  ValidatorConfig

      Used in creating ValidatorHandler and all implementations.
      Constructors in javax.faces.view.facelets with parameters of type TagConfig
      Constructor and Description
      DelegatingMetaTagHandler(TagConfig config)
      FaceletsAttachedObjectHandler(TagConfig config)
      Call through to super
      MetaTagHandler(TagConfig config)
      TagHandler(TagConfig config)

      Every TagHandler instance is associated with a Tag.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.TagDecorator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.TagDecorator

No usage of javax.faces.view.facelets.TagDecorator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.TextHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.TextHandler

No usage of javax.faces.view.facelets.TextHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.faces.view.facelets.ValidatorConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.faces.view.facelets.ValidatorConfig

  • Packages that use ValidatorConfig
    Package Description
    javax.faces.view.facelets

    This package contains public classes for the Java code API of Facelets.

    • Uses of ValidatorConfig in javax.faces.view.facelets

      Methods in javax.faces.view.facelets that return ValidatorConfig
      Modifier and Type Method and Description
      ValidatorConfig ValidatorHandler.getValidatorConfig()

      Return the TagConfig subclass used to configure this handler instance.
      Constructors in javax.faces.view.facelets with parameters of type ValidatorConfig
      Constructor and Description
      ValidatorHandler(ValidatorConfig config)

      Construct this instance around the configuration information in argument config
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AttributeTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class AttributeTag

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport
      • javax.faces.webapp.AttributeTag
  • All Implemented Interfaces:
    Serializable, IterationTag, JspTag, Tag
    Deprecated.
    The Faces implementation must now provide the implementation for this class.

    public class AttributeTag
extends TagSupport

    Tag implementation that adds an attribute with a specified name and String value to the component whose tag it is nested inside, if the component does not already contain an attribute with the same name. This tag creates no output to the page currently being created.

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.servlet.jsp.tagext.TagSupport

        id, pageContext

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      AttributeTag()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int doEndTag()
      Deprecated.
      Default processing of the end tag returning EVAL_PAGE.
      int doStartTag()
      Deprecated.
      Register the specified attribute name and value with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if this UIComponent does not already have a value for the specified attribute name.
      void release()
      Deprecated.
      Release references to any acquired resources.
      void setName(String name)
      Deprecated.
      Set the attribute name.
      void setValue(String value)
      Deprecated.
      Set the attribute value.

      • Methods inherited from class javax.servlet.jsp.tagext.TagSupport

        doAfterBody, findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttributeTag

        public AttributeTag()
        Deprecated.

    • Method Detail

      • setName

        public void setName(String name)
        Deprecated.

        Set the attribute name.

        Parameters:
        name - The new attribute name

      • setValue

        public void setValue(String value)
        Deprecated.

        Set the attribute value.

        Parameters:
        value - The new attribute value

      • doStartTag

        public int doStartTag()
               throws JspException
        Deprecated.

        Register the specified attribute name and value with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if this UIComponent does not already have a value for the specified attribute name.

        Specified by:
        doStartTag in interface Tag
        Overrides:
        doStartTag in class TagSupport
        Returns:
        SKIP_BODY
        Throws:
        JspException - if a JSP error occurs
        See Also:
        Tag.doStartTag()

      • doEndTag

        public int doEndTag()
             throws JspException
        Deprecated.
        Description copied from class: TagSupport
        Default processing of the end tag returning EVAL_PAGE.
        Specified by:
        doEndTag in interface Tag
        Overrides:
        doEndTag in class TagSupport
        Returns:
        EVAL_PAGE
        Throws:
        JspException - if an error occurs while processing this tag
        See Also:
        Tag.doEndTag()

      • release

        public void release()
        Deprecated.

        Release references to any acquired resources.

        Specified by:
        release in interface Tag
        Overrides:
        release in class TagSupport
        See Also:
        Tag.release()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConverterELTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class ConverterELTag

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport
      • javax.faces.webapp.ConverterELTag
  • All Implemented Interfaces:
    Serializable, IterationTag, JspTag, Tag

    public abstract class ConverterELTag
extends TagSupport

    ConverterELTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentClassicTagBase. To avoid creating duplicate instances when a page is redisplayed, creation and registration of a Converter occurs only if the corresponding UIComponent was created (by the owning UIComponentTag) during the execution of the current page.

    This class may be used as a base class for tag instances that support specific Converter subclasses.

    Subclasses of this class must implement the createConverter() method, which creates and returns a Converter instance. Any configuration properties that specify behavior of this Converter must have been set by the createConverter() method. Generally, this occurs by copying corresponding attribute values on the tag instance.

    This tag creates no output to the page currently being created. It is used solely for the side effect of Converter creation.

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.servlet.jsp.tagext.TagSupport

        id, pageContext

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      ConverterELTag()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected abstract Converter createConverter()
      Create and return a new Converter to be registered on our surrounding UIComponent.
      int doStartTag()
      Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentClassicTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.

      • Methods inherited from class javax.servlet.jsp.tagext.TagSupport

        doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, release, removeValue, setId, setPageContext, setParent, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ConverterELTag

        public ConverterELTag()

    • Method Detail

      • doStartTag

        public int doStartTag()
               throws JspException

        Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentClassicTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page. If the localValue of the UIComponent is a String, attempt to convert it.

        Specified by:
        doStartTag in interface Tag
        Overrides:
        doStartTag in class TagSupport
        Returns:
        SKIP_BODY
        Throws:
        JspException - if a JSP error occurs
        See Also:
        Tag.doStartTag()

      • createConverter

        protected abstract Converter createConverter()
                                      throws JspException

        Create and return a new Converter to be registered on our surrounding UIComponent.

        Throws:
        JspException - if a new instance cannot be created
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConverterTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class ConverterTag

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport
      • javax.faces.webapp.ConverterTag
  • All Implemented Interfaces:
    Serializable, IterationTag, JspTag, Tag
    Deprecated.
    This has been partially replaced by ConverterELTag. The remainder of the functionality, namely, the binding facility and the implementation of the createConverter() method, is now an implementation detail.

    public class ConverterTag
extends TagSupport

    ConverterTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag. To avoid creating duplicate instances when a page is redisplayed, creation and registration of a Converter occurs only if the corresponding UIComponent was created (by the owning UIComponentTag) during the execution of the current page.

    This class may be used directly to implement a generic converter registration tag (based on the converter-id specified by the converterId attribute), or as a base class for tag instances that support specific Converter subclasses. This converterId attribute must refer to one of the well known converter-ids, or a custom converter-id as defined in a faces-config.xml file.

    Subclasses of this class must implement the createConverter() method, which creates and returns a Converter instance. Any configuration properties that specify behavior of this Converter must have been set by the createConverter() method. Generally, this occurs by copying corresponding attribute values on the tag instance.

    This tag creates no output to the page currently being created. It is used solely for the side effect of Converter creation.

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.servlet.jsp.tagext.TagSupport

        id, pageContext

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      ConverterTag()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected Converter createConverter()
      Deprecated.
      Create and return a new Converter to be registered on our surrounding UIComponent.
      int doStartTag()
      Deprecated.
      Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.
      void release()
      Deprecated.
      Release references to any acquired resources.
      void setBinding(String binding)
      Deprecated.
      Set the expression that will be used to create a ValueExpression that references a backing bean property of the Converter instance to be created.
      void setConverterId(String converterId)
      Deprecated.
      Set the identifer of the Converter instance to be created.

      • Methods inherited from class javax.servlet.jsp.tagext.TagSupport

        doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ConverterTag

        public ConverterTag()
        Deprecated.

    • Method Detail

      • setConverterId

        public void setConverterId(String converterId)
        Deprecated.

        Set the identifer of the Converter instance to be created.

        Parameters:
        converterId - The identifier of the converter instance to be created.

      • setBinding

        public void setBinding(String binding)
                throws JspException
        Deprecated.

        Set the expression that will be used to create a ValueExpression that references a backing bean property of the Converter instance to be created.

        Parameters:
        binding - The new expression
        Throws:
        JspException - if a JSP error occurs

      • doStartTag

        public int doStartTag()
               throws JspException
        Deprecated.

        Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page. If the localValue of the UIComponent is a String, attempt to convert it.

        Specified by:
        doStartTag in interface Tag
        Overrides:
        doStartTag in class TagSupport
        Returns:
        SKIP_BODY
        Throws:
        JspException - if a JSP error occurs
        See Also:
        Tag.doStartTag()

      • release

        public void release()
        Deprecated.

        Release references to any acquired resources.

        Specified by:
        release in interface Tag
        Overrides:
        release in class TagSupport
        See Also:
        Tag.release()

      • createConverter

        protected Converter createConverter()
                             throws JspException
        Deprecated.

        Create and return a new Converter to be registered on our surrounding UIComponent.

        Throws:
        JspException - if a new instance cannot be created
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacesServlet (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class FacesServlet

  • java.lang.Object
    • javax.faces.webapp.FacesServlet
  • All Implemented Interfaces:
    Servlet

    public final class FacesServlet
extends Object
implements Servlet

    FacesServlet is a servlet that manages the request processing lifecycle for web applications that are utilizing JavaServer Faces to construct the user interface.

    If the application is running in a Servlet 3.0 (and beyond) container, the runtime must provide an implementation of the ServletContainerInitializer interface that declares the following classes in its HandlesTypes annotation.

    • ResourceDependencies
    • ResourceDependency
    • javax.faces.bean.ManagedBean
    • FacesComponent
    • UIComponent
    • Converter
    • FacesConverter
    • ListenerFor
    • ListenersFor
    • FacesBehaviorRenderer
    • Renderer
    • FacesValidator
    • Validator

    This servlet must automatically be mapped if it is not explicitly mapped in web.xml or web-fragment.xml and one or more of the following conditions are true.

    • A faces-config.xml file is found in WEB-INF

    • A faces-config.xml file is found in the META-INF directory of a jar in the application's classpath.

    • A filename ending in .faces-config.xml is found in the META-INF directory of a jar in the application's classpath.

    • The javax.faces.CONFIG_FILES context param is declared in web.xml or web-fragment.xml.

    • The Set of classes passed to the onStartup() method of the ServletContainerInitializer implementation is not empty.

    If the runtime determines that the servlet must be automatically mapped, it must be mapped to the following <url-pattern> entries.

    • /faces
    • *.jsf
    • *.faces

    This class must be annotated with javax.servlet.annotation.MultipartConfig. This causes the Servlet container in which the JSF implementation is running to correctly handle multipart form data.

    Some security considerations relating to this class

    The topic of web application security is a cross-cutting concern and every aspect of the specification address it. However, as with any framework, the application developer needs to pay careful attention to security. Please consider these topics among the rest of the security concerns for the application. This is by no means a complete list of security concerns, and is no substitute for a thorough application level security review.

      Prefix mappings and the FacesServlet

      If the FacesServlet is mapped using a prefix <url-pattern>, such as <url-pattern>/faces/*</url-pattern>, something must be done to prevent access to the view source without its first being processed by the FacesServlet. One common approach is to apply a <security-constraint> to all facelet files and flow definition files. Please see the Deployment Descriptor chapter of the Java Servlet Specification for more information the use of <security-constraint>.

      Allowable HTTP Methods

      The JSF specification only requires the use of the GET and POST http methods. If your web application does not require any other http methods, such as PUT and DELETE, please consider restricting the allowable http methods using the <http-method> and <http-method-omission> elements. Please see the Security of the Java Servlet Specification for more information the use of these elements.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONFIG_FILES_ATTR
      Context initialization parameter name for a comma delimited list of context-relative resource paths (in addition to /WEB-INF/faces-config.xml which is loaded automatically if it exists) containing JavaServer Faces configuration information.
      static String LIFECYCLE_ID_ATTR
      Context initialization parameter name for the lifecycle identifier of the Lifecycle instance to be utilized.

    • Constructor Summary

      Constructors
      Constructor and Description
      FacesServlet()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      Release all resources acquired at startup time.
      ServletConfig getServletConfig()
      Return the ServletConfig instance for this servlet.
      String getServletInfo()
      Return information about this Servlet.
      void init(ServletConfig servletConfig)
      Acquire the factory instances we will require.
      void service(ServletRequest req, ServletResponse resp)

      Process an incoming request, and create the corresponding response according to the following specification.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CONFIG_FILES_ATTR

        public static final String CONFIG_FILES_ATTR

        Context initialization parameter name for a comma delimited list of context-relative resource paths (in addition to /WEB-INF/faces-config.xml which is loaded automatically if it exists) containing JavaServer Faces configuration information.

        See Also:
        Constant Field Values

      • LIFECYCLE_ID_ATTR

        public static final String LIFECYCLE_ID_ATTR

        Context initialization parameter name for the lifecycle identifier of the Lifecycle instance to be utilized.

        See Also:
        Constant Field Values

    • Constructor Detail

      • FacesServlet

        public FacesServlet()

    • Method Detail

      • destroy

        public void destroy()

        Release all resources acquired at startup time.

        Specified by:
        destroy in interface Servlet

      • getServletConfig

        public ServletConfig getServletConfig()

        Return the ServletConfig instance for this servlet.

        Specified by:
        getServletConfig in interface Servlet
        Returns:
        the ServletConfig object that initializes this servlet
        See Also:
        Servlet.init(javax.servlet.ServletConfig)

      • getServletInfo

        public String getServletInfo()

        Return information about this Servlet.

        Specified by:
        getServletInfo in interface Servlet
        Returns:
        a String containing servlet information

      • init

        public void init(ServletConfig servletConfig)
          throws ServletException

        Acquire the factory instances we will require.

        Specified by:
        init in interface Servlet
        Parameters:
        servletConfig - a ServletConfig object containing the servlet's configuration and initialization parameters
        Throws:
        ServletException - if, for any reason, the startup of this Faces application failed. This includes errors in the config file that is parsed before or during the processing of this init() method.
        See Also:
        UnavailableException, Servlet.getServletConfig()

      • service

        public void service(ServletRequest req,
           ServletResponse resp)
             throws IOException,
                    ServletException

        Process an incoming request, and create the corresponding response according to the following specification.

        If the request and response arguments to this method are not instances of HttpServletRequest and HttpServletResponse, respectively, the results of invoking this method are undefined.

        This method must respond to requests that contain the following strings by invoking the sendError method on the response argument (cast to HttpServletResponse), passing the code HttpServletResponse.SC_NOT_FOUND as the argument.

/WEB-INF/
/WEB-INF
/META-INF/
/META-INF

        If none of the cases described above in the specification for this method apply to the servicing of this request, the following action must be taken to service the request.

        Acquire a FacesContext instance for this request.

        Acquire the ResourceHandler for this request by calling Application.getResourceHandler(). Call ResourceHandler.isResourceRequest(javax.faces.context.FacesContext). If this returns true call ResourceHandler.handleResourceRequest(javax.faces.context.FacesContext). If this returns false, call Lifecycle.attachWindow(javax.faces.context.FacesContext) followed by Lifecycle.execute(javax.faces.context.FacesContext) followed by Lifecycle.render(javax.faces.context.FacesContext). If a FacesException is thrown in either case, extract the cause from the FacesException. If the cause is null extract the message from the FacesException, put it inside of a new ServletException instance, and pass the FacesException instance as the root cause, then rethrow the ServletException instance. If the cause is an instance of ServletException, rethrow the cause. If the cause is an instance of IOException, rethrow the cause. Otherwise, create a new ServletException instance, passing the message from the cause, as the first argument, and the cause itself as the second argument.

        The implementation must make it so FacesContext.release() is called within a finally block as late as possible in the processing for the JSF related portion of this request.

        Specified by:
        service in interface Servlet
        Parameters:
        req - The servlet request we are processing
        resp - The servlet response we are creating
        Throws:
        IOException - if an input/output error occurs during processing
        ServletException - if a servlet error occurs during processing
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FacetTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class FacetTag

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport
      • javax.faces.webapp.FacetTag
  • All Implemented Interfaces:
    Serializable, IterationTag, JspTag, Tag

    public class FacetTag
extends TagSupport

    FacetTag is the JSP mechanism for denoting a UIComponent is to be added as a facet to the component associated with its parent.

    A FacetTag must have one and only one child. This child must be a UIComponentTag instance representing a single UIComponent instance.

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.servlet.jsp.tagext.TagSupport

        id, pageContext

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      FacetTag()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int doStartTag()
      Return EVAL_BODY_INCLUDE to cause nested body content to be evaluated.
      String getName()
      Return the name to be assigned to this facet.
      void release()
      Release any resources allocated by this tag instance.
      void setName(String name)
      Set the name to be assigned to this facet.

      • Methods inherited from class javax.servlet.jsp.tagext.TagSupport

        doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FacetTag

        public FacetTag()

    • Method Detail

      • getName

        public String getName()

        Return the name to be assigned to this facet.

      • setName

        public void setName(String name)

        Set the name to be assigned to this facet.

        Parameters:
        name - The new facet name

      • release

        public void release()

        Release any resources allocated by this tag instance.

        Specified by:
        release in interface Tag
        Overrides:
        release in class TagSupport
        See Also:
        Tag.release()

      • doStartTag

        public int doStartTag()
               throws JspException

        Return EVAL_BODY_INCLUDE to cause nested body content to be evaluated.

        Specified by:
        doStartTag in interface Tag
        Overrides:
        doStartTag in class TagSupport
        Returns:
        SKIP_BODY
        Throws:
        JspException - if an error occurs while processing this tag
        See Also:
        Tag.doStartTag()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.faces.webapp (Java(TM) EE 7 Specification APIs)

javax.faces.webapp

Classes

  • AttributeTag
  • ConverterELTag
  • ConverterTag
  • FacesServlet
  • FacetTag
  • PreJsf2ExceptionHandlerFactory
  • UIComponentBodyTag
  • UIComponentClassicTagBase
  • UIComponentELTag
  • UIComponentTag
  • UIComponentTagBase
  • ValidatorELTag
  • ValidatorTag


javax.faces.webapp (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.faces.webapp

Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

See: Description

  • Class Summary
    Class Description
    AttributeTag Deprecated
    The Faces implementation must now provide the implementation for this class.
    ConverterELTag
    ConverterELTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentClassicTagBase.
    ConverterTag Deprecated
    This has been partially replaced by ConverterELTag.
    FacesServlet
    FacesServlet is a servlet that manages the request processing lifecycle for web applications that are utilizing JavaServer Faces to construct the user interface.
    FacetTag
    FacetTag is the JSP mechanism for denoting a UIComponent is to be added as a facet to the component associated with its parent.
    PreJsf2ExceptionHandlerFactory

    This ExceptionHandlerFactory instance produces JSF 1.2 compatible ExceptionHandler instances.
    UIComponentBodyTag Deprecated
    All component tags now implement BodyTag.
    UIComponentClassicTagBase
    UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view.
    UIComponentELTag
    UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.
    UIComponentTag Deprecated
    Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
    UIComponentTagBase
    UIComponentTagBase is the base class for all JSP tags that correspond to a UIComponent instance in the view.
    ValidatorELTag
    ValidatorELTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag.
    ValidatorTag Deprecated
    This has been partially replaced by ValidatorELTag.

Package javax.faces.webapp Description

Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.faces.webapp Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.faces.webapp

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.context.ExceptionHandlerFactory (implements javax.faces.FacesWrapper<T>)
      • javax.faces.webapp.PreJsf2ExceptionHandlerFactory
    • javax.faces.webapp.FacesServlet (implements javax.servlet.Servlet)
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.faces.webapp.AttributeTag
      • javax.faces.webapp.ConverterELTag
      • javax.faces.webapp.ConverterTag
      • javax.faces.webapp.FacetTag
      • javax.faces.webapp.ValidatorELTag
      • javax.faces.webapp.ValidatorTag
    • javax.faces.webapp.UIComponentTagBase (implements javax.servlet.jsp.tagext.JspTag)
      • javax.faces.webapp.UIComponentClassicTagBase (implements javax.servlet.jsp.tagext.BodyTag, javax.servlet.jsp.tagext.JspIdConsumer)
        • javax.faces.webapp.UIComponentELTag (implements javax.servlet.jsp.tagext.Tag)
        • javax.faces.webapp.UIComponentTag (implements javax.servlet.jsp.tagext.Tag)
          • javax.faces.webapp.UIComponentBodyTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


PreJsf2ExceptionHandlerFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class PreJsf2ExceptionHandlerFactory

  • java.lang.Object
    • javax.faces.context.ExceptionHandlerFactory
      • javax.faces.webapp.PreJsf2ExceptionHandlerFactory
  • All Implemented Interfaces:
    FacesWrapper<ExceptionHandlerFactory>

    public class PreJsf2ExceptionHandlerFactory
extends ExceptionHandlerFactory

    This ExceptionHandlerFactory instance produces JSF 1.2 compatible ExceptionHandler instances. The ExceptionHandler.handle() method of the ExceptionHandler produced by this factory must meet the following requirements

    • Any exceptions thrown before or after phase execution will be logged and swallowed.

    • The implementation must examine the Exception within each of the unhandled exception events. If the Exception is an instance of UpdateModelException, extract the FacesMessage from the UpdateModelException. Log a SEVERE message to the log and queue the FacesMessage on the FacesContext, using the clientId of the source component in a call to FacesContext.addMessage(java.lang.String, javax.faces.application.FacesMessage)

    Since:
    2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      PreJsf2ExceptionHandlerFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ExceptionHandler getExceptionHandler()

      Create and return a A new ExceptionHandler instance.

      • Methods inherited from class javax.faces.context.ExceptionHandlerFactory

        getWrapped

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PreJsf2ExceptionHandlerFactory

        public PreJsf2ExceptionHandlerFactory()

    • Method Detail

      • getExceptionHandler

        public ExceptionHandler getExceptionHandler()
        Description copied from class: ExceptionHandlerFactory

        Create and return a A new ExceptionHandler instance. The implementation must return an ExceptionHandler instance suitable for the environment. For example, in some cases it may be desirable for an ExceptionHandler to write error information to the response instead of throwing exceptions as in the case of Ajax applications.

        Specified by:
        getExceptionHandler in class ExceptionHandlerFactory
        Returns:
        a new ExceptionHandler that behaves in a fashion compatible with specifications prior to JavaServerFaces 1.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIComponentBodyTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class UIComponentBodyTag

  • java.lang.Object
    • javax.faces.webapp.UIComponentTagBase
      • javax.faces.webapp.UIComponentClassicTagBase
        • javax.faces.webapp.UIComponentTag
          • javax.faces.webapp.UIComponentBodyTag
  • All Implemented Interfaces:
    BodyTag, IterationTag, JspIdConsumer, JspTag, Tag
    Deprecated.
    All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.

    public abstract class UIComponentBodyTag
extends UIComponentTag

    UIComponentBodyTag is a base class for all JSP custom actions, related to a UIComponent, that need to process their tag bodies.

    • Field Summary

      • Fields inherited from class javax.faces.webapp.UIComponentClassicTagBase

        bodyContent, pageContext, UNIQUE_ID_PREFIX

      • Fields inherited from class javax.faces.webapp.UIComponentTagBase

        log

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

      • Fields inherited from interface javax.servlet.jsp.tagext.BodyTag

        EVAL_BODY_BUFFERED, EVAL_BODY_TAG

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

    • Constructor Summary

      Constructors
      Constructor and Description
      UIComponentBodyTag()
      Deprecated.

    • Method Summary

      • Methods inherited from class javax.faces.webapp.UIComponentTag

        createComponent, getParentUIComponentTag, hasBinding, isSuppressed, isValueReference, release, setBinding, setProperties, setRendered

      • Methods inherited from class javax.faces.webapp.UIComponentClassicTagBase

        addChild, addFacet, addVerbatimAfterComponent, addVerbatimBeforeComponent, createVerbatimComponent, createVerbatimComponentFromBodyContent, doAfterBody, doEndTag, doInitBody, doStartTag, encodeBegin, encodeChildren, encodeEnd, findComponent, getBodyContent, getComponentInstance, getCreated, getCreatedComponents, getDoAfterBodyValue, getDoEndValue, getDoStartValue, getFacesContext, getFacesJspId, getFacetName, getId, getIndexOfNextChildTag, getJspId, getParent, getParentUIComponentClassicTagBase, getPreviousOut, setBodyContent, setId, setJspId, setPageContext, setParent, setupResponseWriter

      • Methods inherited from class javax.faces.webapp.UIComponentTagBase

        getComponentType, getELContext, getRendererType

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.servlet.jsp.tagext.Tag

        doEndTag, doStartTag, getParent, setPageContext, setParent

    • Constructor Detail

      • UIComponentBodyTag

        public UIComponentBodyTag()
        Deprecated.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIComponentClassicTagBase (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class UIComponentClassicTagBase

  • java.lang.Object
    • javax.faces.webapp.UIComponentTagBase
      • javax.faces.webapp.UIComponentClassicTagBase
  • All Implemented Interfaces:
    BodyTag, IterationTag, JspIdConsumer, JspTag, Tag
    Direct Known Subclasses:
    UIComponentELTag, UIComponentTag

    public abstract class UIComponentClassicTagBase
extends UIComponentTagBase
implements JspIdConsumer, BodyTag

    UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view. In Faces 1.2, all component tags are BodyTag instances to allow for the execution of the page to build the component tree, but not render it. Rendering happens only after the component tree is completely built.

    UIComponentTag extends UIComponentClassicTagBase to add support for properties that conform to the Faces 1.1 EL.

    UIComponentELTag extends UIComponentClassicTagBase class to add support for properties that conform to the EL API.

    The default implementation allows the proper interweaving of template text, non-Faces JSP tag output, and Faces component tag output in the same page, as expected by the page author.

    The CASE markers in the following example will be cited in the method descriptions of this class.

    • CASE 1 describes template text and/or non-component custom tag output occurring as the child of a component tag, but before the first component tag child of that component tag.

    • CASE 2 describes template text and/or non-component custom tag output occurring between two sibling component tags.

    • CASE 3 describes template text and/or non-component custom tag output occurring as the child content of an <f:verbatim> tag at any point in the page.

    • CASE 4 describes template text and/or non-component custom tag output occurring between the last child component tag and its enclosing parent component tag's end tag.

 <h:panelGrid style="color:red" border="4" columns="2">
 CASE 1
 <h:outputText value="component 1"/>
 CASE 2
 <h:outputText value="component 2"/>
 <f:verbatim>CASE 3</f:verbatim>
 <c:out value="${pageScope.CASE4}" />
 </h:panelGrid>

    The preceding arrangement of faces component tags, must yield markup that will render identically to the following (assuming that ${pageScope.CASE4} evaluates to "CASE 4" without the quotes).

 <table border="4" style="color:red">

 <tbody>

 <tr><td>CASE 1</td></tr> <tr><td>component 1</td></tr>

 <tr><td>CASE 2</td> <tr><td>component 2</td></tr>

 <tr><td>CASE 3</td> <td>CASE 4</td></tr>

 </tbody>

 </table>

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected BodyContent bodyContent
      The bodyContent for this tag handler.
      protected PageContext pageContext
      The JSP PageContext for the page we are embedded in.
      protected static String UNIQUE_ID_PREFIX
      Used as the prefix for ids.

      • Fields inherited from class javax.faces.webapp.UIComponentTagBase

        log

      • Fields inherited from interface javax.servlet.jsp.tagext.BodyTag

        EVAL_BODY_BUFFERED, EVAL_BODY_TAG

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      UIComponentClassicTagBase()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected void addChild(UIComponent child)
      Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.
      protected void addFacet(String name)
      Add the facet name of the specified facet to the list of facet names created or located by nested UIComponentTags processing this request.
      protected void addVerbatimAfterComponent(UIComponentClassicTagBase parentTag, UIComponent verbatim, UIComponent component)
      Add verbatim as a sibling of component in component in the parent's child list.
      protected void addVerbatimBeforeComponent(UIComponentClassicTagBase parentTag, UIComponent verbatim, UIComponent component)
      Add verbatim as a sibling of component in component in the parent's child list.
      protected abstract UIComponent createComponent(FacesContext context, String newId)
      Create and return a new child component of the type returned by calling getComponentType().
      protected UIOutput createVerbatimComponent()
      Use the Application instance to create a new component with the following characteristics.
      protected UIComponent createVerbatimComponentFromBodyContent()
      Create a transient UIOutput component from the body content, of this tag instance or return null if there is no body content, the body content is whitespace, or the body content is a comment.
      int doAfterBody()
      Perform any processing necessary to handle the content implications of CASE 4 in the class description.
      int doEndTag()
      Perform any processing necessary to handle the content implications of CASE 3 in the class description.
      void doInitBody()
      Prepare for evaluation of the body.
      int doStartTag()
      Perform any processing necessary to find (or create) the UIComponent instance in the view corresponding to this tag instance in the page and, if and only if a component was created, insert it into the tree at the proper location as expected by the page author.
      protected void encodeBegin()
      Deprecated.
      No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
      protected void encodeChildren()
      Deprecated.
      No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
      protected void encodeEnd()
      Deprecated.
      No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
      protected UIComponent findComponent(FacesContext context)
      Find and return the UIComponent, from the component tree, that corresponds to this tag handler instance.
      BodyContent getBodyContent()
      UIComponent getComponentInstance()
      Return the UIComponent instance that is associated with this tag instance.
      boolean getCreated()
      Return true if we dynamically created a new component instance during execution of this tag.
      protected List<String> getCreatedComponents()
      Returns the List of UIComponent ids created or located by nested UIComponentTags while processing the current request.
      protected int getDoAfterBodyValue()
      Return the flag value that should be returned from the doAfterBody() method when it is called.
      protected int getDoEndValue()
      Return the flag value that should be returned from the doEnd() method when it is called.
      protected int getDoStartValue()
      Return the flag value that should be returned from the doStart() method when it is called.
      protected FacesContext getFacesContext()
      Return the FacesContext instance for the current request.
      protected String getFacesJspId()
      If this method has been called before on this tag's useful lifetime (before release() was called), return the previously returned value.
      protected String getFacetName()
      Return the facet name that we should be stored under, if any; otherwise, return null (indicating that we will be a child component).
      protected String getId()
      Return the id value assigned by the page author.
      protected int getIndexOfNextChildTag()
      Return the index of the next child to be added as a child of this tag.
      String getJspId()
      Tag getParent()
      Return the Tag that is the parent of this instance.
      static UIComponentClassicTagBase getParentUIComponentClassicTagBase(PageContext context)
      Locate and return the nearest enclosing UIComponentClassicTagBase if any; otherwise, return null.
      JspWriter getPreviousOut()
      Get the JspWriter from our BodyContent.
      protected abstract boolean hasBinding()
      Return true if this component has a non-null binding attribute.
      void release()
      Release any resources allocated during the execution of this tag handler.
      void setBodyContent(BodyContent bodyContent)
      Set the bodyContent for this tag handler.
      void setId(String id)
      Set the component identifier for our component.
      void setJspId(String id)
      Defined on JspIdConsumer.
      void setPageContext(PageContext pageContext)
      Set the PageContext of the page containing this tag instance.
      void setParent(Tag parent)
      Set the Tag that is the parent of this instance.
      protected abstract void setProperties(UIComponent component)
      Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set.
      protected void setupResponseWriter()
      Set up the ResponseWriter for the current response, if this has not been done already.

      • Methods inherited from class javax.faces.webapp.UIComponentTagBase

        getComponentType, getELContext, getRendererType

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • UNIQUE_ID_PREFIX

        protected static final String UNIQUE_ID_PREFIX
        Used as the prefix for ids. This is necessary to avoid uniqueness conflicts with the transient verbatim components.
        See Also:
        Constant Field Values

      • bodyContent

        protected BodyContent bodyContent

        The bodyContent for this tag handler.

      • pageContext

        protected PageContext pageContext

        The JSP PageContext for the page we are embedded in.

    • Constructor Detail

      • UIComponentClassicTagBase

        public UIComponentClassicTagBase()

    • Method Detail

      • getDoStartValue

        protected int getDoStartValue()
                       throws JspException

        Return the flag value that should be returned from the doStart() method when it is called. Subclasses may override this method to return the appropriate value.

        Throws:
        JspException - to cause doStart() to throw an exception

      • getDoEndValue

        protected int getDoEndValue()
                     throws JspException

        Return the flag value that should be returned from the doEnd() method when it is called. Subclasses may override this method to return the appropriate value.

        Throws:
        JspException - to cause doEnd() to throw an exception

      • encodeBegin

        protected void encodeBegin()
                    throws IOException
        Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.

        Delegate to the encodeBegin() method of our corresponding UIComponent. This method is called from doStartTag(). Normally, delegation occurs unconditionally; however, this method is abstracted out so that advanced tags can conditionally perform this call.

        Throws:
        IOException - if an input/output error occurs

      • encodeChildren

        protected void encodeChildren()
                       throws IOException
        Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.

        Delegate to the encodeChildren() method of our corresponding UIComponent. This method is called from doStartTag(). Normally, delegation occurs unconditionally; however, this method is abstracted out so that advanced tags can conditionally perform this call.

        Throws:
        IOException - if an input/output error occurs

      • encodeEnd

        protected void encodeEnd()
                  throws IOException
        Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.

        Delegate to the encodeEnd() method of our corresponding UIComponent. This method is called from doStartTag(). Normally, delegation occurs unconditionally; however, this method is abstracted out so that advanced tags can conditionally perform this call.

        Throws:
        IOException - if an input/output error occurs

      • setPageContext

        public void setPageContext(PageContext pageContext)

        Set the PageContext of the page containing this tag instance.

        Specified by:
        setPageContext in interface Tag
        Parameters:
        pageContext - The enclosing PageContext

      • getParent

        public Tag getParent()

        Return the Tag that is the parent of this instance.

        Specified by:
        getParent in interface Tag
        Returns:
        the current parent, or null if none.
        See Also:
        TagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.Tag, java.lang.Class)

      • setParent

        public void setParent(Tag parent)

        Set the Tag that is the parent of this instance.

        Specified by:
        setParent in interface Tag
        Parameters:
        parent - The new parent Tag

      • setupResponseWriter

        protected void setupResponseWriter()

        Set up the ResponseWriter for the current response, if this has not been done already.

        @deprecated. ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) is now responsible for setting up the response writer. This method is now a no-op.

      • findComponent

        protected UIComponent findComponent(FacesContext context)
                             throws JspException

        Find and return the UIComponent, from the component tree, that corresponds to this tag handler instance. If there is no such UIComponent, create one and add it as a child or facet of the UIComponent associated with our nearest enclosing UIComponentTag. The process for locating or creating the component is:

        1. If we have previously located this component, return it.
        2. Locate the parent component by looking for a parent UIComponentTag instance, and ask it for its component. If there is no parent UIComponentTag instance, this tag represents the root component, so get it from the current Tree and return it.
        3. If this UIComponentTag instance has the facetName attribute set, ask the parent UIComponent for a facet with this name. If not found, create one, call setProperties() with the new component as a parameter, and register it under this name. Return the found or created facet UIComponent.
        4. Determine the component id to be assigned to the new component, as follows: if this UIComponentTag has an id attribute set, use that value; otherwise, generate an identifier that is guaranteed to be the same for this UIComponent every time this page is processed (i.e. one based on the location of all UIComponentTag instances without an id attribute set).
        5. Ask the parent UIComponent for a child with this identifier. If not found, create one, call setProperties() with the new component as a parameter, and register it as a child with this identifier. Return the found or created child UIComponent.

        When creating a component, the process is:

        1. Retrieve the component type by calling UIComponentTagBase.getComponentType()
        2. If the component has a binding attribute, create an expression from it, and call Application.createComponent(java.lang.String) with that expression, the FacesContext, and the component type. Store the expression using the key "binding".
        3. Otherwise, call Application.createComponent(java.lang.String) with only the component type.
        4. Call setProperties().
        5. Add the new component as a child or facet of its parent
        Throws:
        JspException

      • getParentUIComponentClassicTagBase

        public static UIComponentClassicTagBase getParentUIComponentClassicTagBase(PageContext context)

        Locate and return the nearest enclosing UIComponentClassicTagBase if any; otherwise, return null.

        Parameters:
        context - PageContext for the current page

      • getIndexOfNextChildTag

        protected int getIndexOfNextChildTag()
        Description copied from class: UIComponentTagBase

        Return the index of the next child to be added as a child of this tag. The default implementation maintains a list of created components and returns the size of the list.

        Specified by:
        getIndexOfNextChildTag in class UIComponentTagBase

      • addChild

        protected void addChild(UIComponent child)
        Description copied from class: UIComponentTagBase

        Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.

        Specified by:
        addChild in class UIComponentTagBase
        Parameters:
        child - New child whose identifier should be added

      • addFacet

        protected void addFacet(String name)
        Description copied from class: UIComponentTagBase

        Add the facet name of the specified facet to the list of facet names created or located by nested UIComponentTags processing this request.

        Specified by:
        addFacet in class UIComponentTagBase
        Parameters:
        name - Facet name to be added

      • createVerbatimComponentFromBodyContent

        protected UIComponent createVerbatimComponentFromBodyContent()

        Create a transient UIOutput component from the body content, of this tag instance or return null if there is no body content, the body content is whitespace, or the body content is a comment.

      • createVerbatimComponent

        protected UIOutput createVerbatimComponent()

        Use the Application instance to create a new component with the following characteristics.

        componentType is javax.faces.HtmlOutputText.

        transient is true.

        escape is false.

        id is FacesContext.getViewRoot().createUniqueId()

      • addVerbatimBeforeComponent

        protected void addVerbatimBeforeComponent(UIComponentClassicTagBase parentTag,
                              UIComponent verbatim,
                              UIComponent component)

        Add verbatim as a sibling of component in component in the parent's child list. verbatim is added to the list at the position immediatly preceding component.

      • addVerbatimAfterComponent

        protected void addVerbatimAfterComponent(UIComponentClassicTagBase parentTag,
                             UIComponent verbatim,
                             UIComponent component)

        Add verbatim as a sibling of component in component in the parent's child list. verbatim is added to the list at the position immediatly following component.

      • doStartTag

        public int doStartTag()
               throws JspException

        Perform any processing necessary to find (or create) the UIComponent instance in the view corresponding to this tag instance in the page and, if and only if a component was created, insert it into the tree at the proper location as expected by the page author. Secondarily, cause a transient UIOutput component to be created and placed in the tree before the UIComponent instance for this tag. The value of this UIOutput component must include anything covered by CASE 1 or CASE 2 in the class description.

        The default implementation, which is intended to be sufficient for most components, implements this secondary requirement by calling getParentUIComponentClassicTagBase(javax.servlet.jsp.PageContext), and calling createVerbatimComponentFromBodyContent() on the result. It then adds the returned component to the tree before the actual component for this tag instance instance by calling addVerbatimBeforeComponent(javax.faces.webapp.UIComponentClassicTagBase, javax.faces.component.UIComponent, javax.faces.component.UIComponent).

        Before returning, the component is pushed onto the component stack for this response to enable the getParentUIComponentClassicTagBase(javax.servlet.jsp.PageContext) method to work properly.

        The flag value to be returned is acquired by calling the getDoStartValue() method, which tag subclasses may override if they do not want the default value.

        Specified by:
        doStartTag in interface Tag
        Returns:
        EVAL_BODY_INCLUDE if the tag wants to process body, SKIP_BODY if it does not want to process it.
        Throws:
        JspException - if an error occurs
        See Also:
        BodyTag

      • doEndTag

        public int doEndTag()
             throws JspException

        Perform any processing necessary to handle the content implications of CASE 3 in the class description.

        The default implementation, which is intended to be sufficient for most components, calls createVerbatimComponentFromBodyContent() on this instance and adds it as a child of the component for this tag's component at the end of the child list. In addition, the following housekeeping steps are taken.

        • Retrieve from the UIComponent the set of component ids of child components created by UIComponentTag instances the last time this page was processed (if any). Compare it to the list of children created during this page processing pass, and remove all children present in the old list but not the new. Save the new list as a component attribute so that it gets saved as part of the component's state.
        • Retrieve from the UIComponent the set of facet names of facets created by UIComponentTag instances the last time this page was processed (if any). Compare it to the list of facets created during this page processing pass, and remove all facets present in the old list but not the new. Save the new list as a component attribute so that it gets saved as part of the component's state.
        • Release all references to the component, and pop it from the component stack for this response, removing the stack if this was the outermost component.

        The flag value to be returned is acquired by calling the getDoEndValue() method, which tag subclasses may override if they do not want the default value.

        Specified by:
        doEndTag in interface Tag
        Returns:
        indication of whether to continue evaluating the JSP page.
        Throws:
        JspException - if an error occurs

      • release

        public void release()

        Release any resources allocated during the execution of this tag handler.

        Specified by:
        release in interface Tag

      • getDoAfterBodyValue

        protected int getDoAfterBodyValue()
                           throws JspException

        Return the flag value that should be returned from the doAfterBody() method when it is called. Subclasses may override this method to return the appropriate value.

        Throws:
        JspException

      • setBodyContent

        public void setBodyContent(BodyContent bodyContent)

        Set the bodyContent for this tag handler. This method is invoked by the JSP page implementation object at most once per action invocation, before doInitiBody(). This method will not be invoked for empty tags or for non-empty tags whose doStartTag() method returns SKIP_BODY or EVAL_BODY_INCLUDE.

        Specified by:
        setBodyContent in interface BodyTag
        Parameters:
        bodyContent - The new BodyContent for this tag
        See Also:
        BodyTag.doInitBody(), IterationTag.doAfterBody()

      • getPreviousOut

        public JspWriter getPreviousOut()

        Get the JspWriter from our BodyContent.

      • getBodyContent

        public BodyContent getBodyContent()

      • doInitBody

        public void doInitBody()
                throws JspException

        Prepare for evaluation of the body. This method is invoked by the JSP page implementation object after setBodyContent() and before the first time the body is to be evaluated. This method will not be invoked for empty tags or for non-empty tags whose doStartTag() method returns SKIP_BODY or EVAL_BODY_INCLUDE.

        Specified by:
        doInitBody in interface BodyTag
        Throws:
        JspException - if an error is encountered
        See Also:
        IterationTag.doAfterBody()

      • doAfterBody

        public int doAfterBody()
                throws JspException

        Perform any processing necessary to handle the content implications of CASE 4 in the class description.

        Return result from getDoAfterBodyValue()

        Specified by:
        doAfterBody in interface IterationTag
        Returns:
        whether additional evaluations of the body are desired
        Throws:
        JspException - if an error is encountered

      • setId

        public void setId(String id)

        Set the component identifier for our component. If the argument begins with UIViewRoot.UNIQUE_ID_PREFIX throw an IllegalArgumentException

        Specified by:
        setId in class UIComponentTagBase
        Parameters:
        id - The new component identifier. This may not start with UIViewRoot.UNIQUE_ID_PREFIX.
        Throws:
        IllegalArgumentException - if the argument is non-null and starts with UIViewRoot.UNIQUE_ID_PREFIX.

      • getId

        protected String getId()

        Return the id value assigned by the page author.

      • getFacesJspId

        protected String getFacesJspId()

        If this method has been called before on this tag's useful lifetime (before release() was called), return the previously returned value. Otherwise, if getJspId() returns non-null, prepend UNIQUE_ID_PREFIX to the jspId and return the result.

      • getCreatedComponents

        protected List<String> getCreatedComponents()
        Returns the List of UIComponent ids created or located by nested UIComponentTags while processing the current request.

      • setJspId

        public void setJspId(String id)

        Defined on JspIdConsumer. This method is called by the container before doStartTag(). The argument is guaranteed to be unique within the page.

        IMPLEMENTATION NOTE: This method will detect where we are in an include and assign a unique ID for each include in a particular 'logical page'. This allows us to avoid possible duplicate ID situations for included pages that have components without explicit IDs.

        Specified by:
        setJspId in interface JspIdConsumer
        Parameters:
        id - the container generated id for this tag, guaranteed to be unique within the page.

      • getJspId

        public String getJspId()

      • setProperties

        protected abstract void setProperties(UIComponent component)

        Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set. This method must be called ONLY if the specified UIComponent was in fact created during the execution of this tag handler instance, and this call will occur BEFORE the UIComponent is added to the view.

        Tag subclasses that want to support additional set properties must ensure that the base class setProperties() method is still called. A typical implementation that supports extra properties foo and bar would look something like this:

         protected void setProperties(UIComponent component) {
   super.setProperties(component);
   if (foo != null) {
     component.setAttribute("foo", foo);
   }
   if (bar != null) {
     component.setAttribute("bar", bar);
   }
 }

        The default implementation overrides the following properties:

        • rendered - Set if a value for the rendered property is specified for this tag handler instance.
        • rendererType - Set if the getRendererType() method returns a non-null value.
        Parameters:
        component - UIComponent whose properties are to be overridden

      • createComponent

        protected abstract UIComponent createComponent(FacesContext context,
                          String newId)
                                        throws JspException

        Create and return a new child component of the type returned by calling getComponentType(). If this UIComponentTag has a non-null binding attribute, this is done by call Application.createComponent(java.lang.String) with the expression created for the binding attribute, and the expression will be stored on the component. Otherwise, Application.createComponent(java.lang.String) is called with only the component type. Finally, initialize the components id and other properties.

        Parameters:
        context - FacesContext for the current request
        newId - id of the component
        Throws:
        JspException

      • hasBinding

        protected abstract boolean hasBinding()

        Return true if this component has a non-null binding attribute. This method is necessary to allow subclasses that expose the binding property as an Faces 1.1 style EL property as well as subclasses that expose it as an EL API property.

      • getComponentInstance

        public UIComponent getComponentInstance()

        Return the UIComponent instance that is associated with this tag instance. This method is designed to be used by tags nested within this tag, and only returns useful results between the execution of doStartTag() and doEndTag() on this tag instance.

        Specified by:
        getComponentInstance in class UIComponentTagBase

      • getCreated

        public boolean getCreated()

        Return true if we dynamically created a new component instance during execution of this tag. This method is designed to be used by tags nested within this tag, and only returns useful results between the execution of doStartTag() and doEndTag() on this tag instance.

        Specified by:
        getCreated in class UIComponentTagBase

      • getFacesContext

        protected FacesContext getFacesContext()
        Description copied from class: UIComponentTagBase

        Return the FacesContext instance for the current request. This value will be non-null only from the beginning of doStartTag() through the end of doEndTag() for each tag instance.

        Specified by:
        getFacesContext in class UIComponentTagBase

      • getFacetName

        protected String getFacetName()

        Return the facet name that we should be stored under, if any; otherwise, return null (indicating that we will be a child component).

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIComponentELTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class UIComponentELTag

  • java.lang.Object
    • javax.faces.webapp.UIComponentTagBase
      • javax.faces.webapp.UIComponentClassicTagBase
        • javax.faces.webapp.UIComponentELTag
  • All Implemented Interfaces:
    BodyTag, IterationTag, JspIdConsumer, JspTag, Tag

    public abstract class UIComponentELTag
extends UIComponentClassicTagBase
implements Tag

    UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.

    This tag is designed for use with Faces version 1.2 and JSP version 2.1 containers.

    • Field Summary

      • Fields inherited from class javax.faces.webapp.UIComponentClassicTagBase

        bodyContent, pageContext, UNIQUE_ID_PREFIX

      • Fields inherited from class javax.faces.webapp.UIComponentTagBase

        log

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

      • Fields inherited from interface javax.servlet.jsp.tagext.BodyTag

        EVAL_BODY_BUFFERED, EVAL_BODY_TAG

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

    • Constructor Summary

      Constructors
      Constructor and Description
      UIComponentELTag()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected UIComponent createComponent(FacesContext context, String newId)
      Create and return a new child component of the type returned by calling getComponentType().
      protected ELContext getELContext()
      Return the ELContext for the FacesContext for this request.
      protected boolean hasBinding()
      Return true if this component has a non-null binding attribute.
      void release()
      Release any resources allocated during the execution of this tag handler.
      void setBinding(ValueExpression binding)
      Set the value expression for our component.
      protected void setProperties(UIComponent component)
      Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set.
      void setRendered(ValueExpression rendered)
      Set an override for the rendered attribute.

      • Methods inherited from class javax.faces.webapp.UIComponentClassicTagBase

        addChild, addFacet, addVerbatimAfterComponent, addVerbatimBeforeComponent, createVerbatimComponent, createVerbatimComponentFromBodyContent, doAfterBody, doEndTag, doInitBody, doStartTag, encodeBegin, encodeChildren, encodeEnd, findComponent, getBodyContent, getComponentInstance, getCreated, getCreatedComponents, getDoAfterBodyValue, getDoEndValue, getDoStartValue, getFacesContext, getFacesJspId, getFacetName, getId, getIndexOfNextChildTag, getJspId, getParent, getParentUIComponentClassicTagBase, getPreviousOut, setBodyContent, setId, setJspId, setPageContext, setParent, setupResponseWriter

      • Methods inherited from class javax.faces.webapp.UIComponentTagBase

        getComponentType, getRendererType

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.servlet.jsp.tagext.Tag

        doEndTag, doStartTag, getParent, setPageContext, setParent

    • Constructor Detail

      • UIComponentELTag

        public UIComponentELTag()

    • Method Detail

      • setBinding

        public void setBinding(ValueExpression binding)
                throws JspException

        Set the value expression for our component.

        Parameters:
        binding - The new value expression
        Throws:
        JspException - if an error occurs

      • hasBinding

        protected boolean hasBinding()
        Description copied from class: UIComponentClassicTagBase

        Return true if this component has a non-null binding attribute. This method is necessary to allow subclasses that expose the binding property as an Faces 1.1 style EL property as well as subclasses that expose it as an EL API property.

        Specified by:
        hasBinding in class UIComponentClassicTagBase

      • setRendered

        public void setRendered(ValueExpression rendered)

        Set an override for the rendered attribute.

        Parameters:
        rendered - The new value for rendered attribute

      • getELContext

        protected ELContext getELContext()

        Return the ELContext for the FacesContext for this request.

        This is a convenience for getFacesContext().getELContext().

        Overrides:
        getELContext in class UIComponentTagBase

      • release

        public void release()

        Release any resources allocated during the execution of this tag handler.

        Specified by:
        release in interface Tag
        Overrides:
        release in class UIComponentClassicTagBase

      • setProperties

        protected void setProperties(UIComponent component)

        Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set. This method must be called ONLY if the specified UIComponent was in fact created during the execution of this tag handler instance, and this call will occur BEFORE the UIComponent is added to the view.

        Tag subclasses that want to support additional set properties must ensure that the base class setProperties() method is still called. A typical implementation that supports extra properties foo and bar would look something like this:

         protected void setProperties(UIComponent component) {
   super.setProperties(component);
   if (foo != null) {
     component.setAttribute("foo", foo);
   }
   if (bar != null) {
     component.setAttribute("bar", bar);
   }
 }

        The default implementation overrides the following properties:

        • rendered - Set if a value for the rendered property is specified for this tag handler instance.
        • rendererType - Set if the getRendererType() method returns a non-null value.
        Specified by:
        setProperties in class UIComponentClassicTagBase
        Parameters:
        component - UIComponent whose properties are to be overridden

      • createComponent

        protected UIComponent createComponent(FacesContext context,
                          String newId)
                               throws JspException

        Create and return a new child component of the type returned by calling getComponentType(). If this UIComponentELTag has a non-null binding attribute, this is done by call Application.createComponent(java.lang.String) with the ValueExpression created for the binding attribute, and the ValueExpression will be stored on the component. Otherwise, Application.createComponent(java.lang.String) is called with only the component type. Finally, initialize the components id and other properties.

        Specified by:
        createComponent in class UIComponentClassicTagBase
        Parameters:
        context - FacesContext for the current request
        newId - id of the component
        Throws:
        JspException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIComponentTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class UIComponentTag

  • java.lang.Object
    • javax.faces.webapp.UIComponentTagBase
      • javax.faces.webapp.UIComponentClassicTagBase
        • javax.faces.webapp.UIComponentTag
  • All Implemented Interfaces:
    BodyTag, IterationTag, JspIdConsumer, JspTag, Tag
    Direct Known Subclasses:
    UIComponentBodyTag
    Deprecated.
    Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.

    public abstract class UIComponentTag
extends UIComponentClassicTagBase
implements Tag

    UIComponentTag is the base class for all JSP custom actions that correspond to user interface components in a page that is rendered by JavaServer Faces.

    In this version of the specification, UIComponentTag extends UIComponentClassicTagBase to add properties that use the Faces 1.1 Expression Language.

    • Field Summary

      • Fields inherited from class javax.faces.webapp.UIComponentClassicTagBase

        bodyContent, pageContext, UNIQUE_ID_PREFIX

      • Fields inherited from class javax.faces.webapp.UIComponentTagBase

        log

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

      • Fields inherited from interface javax.servlet.jsp.tagext.BodyTag

        EVAL_BODY_BUFFERED, EVAL_BODY_TAG

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

    • Constructor Summary

      Constructors
      Constructor and Description
      UIComponentTag()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected UIComponent createComponent(FacesContext context, String newId)
      Deprecated.
      Implement createComponent using Faces 1.1 EL API.
      static UIComponentTag getParentUIComponentTag(PageContext context)
      Deprecated.
      Locate and return the nearest enclosing UIComponentTag if any; otherwise, return null.
      protected boolean hasBinding()
      Deprecated.
      Return true if this component has a non-null binding attribute.
      protected boolean isSuppressed()
      Deprecated.
      static boolean isValueReference(String value)
      Deprecated.
      Return true if the specified value conforms to the syntax requirements of a value binding expression.
      void release()
      Deprecated.
      Release any resources allocated during the execution of this tag handler.
      void setBinding(String binding)
      Deprecated.
      Set the value binding expression for our component.
      protected void setProperties(UIComponent component)
      Deprecated.
      Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set.
      void setRendered(String rendered)
      Deprecated.
      Set an override for the rendered attribute.

      • Methods inherited from class javax.faces.webapp.UIComponentClassicTagBase

        addChild, addFacet, addVerbatimAfterComponent, addVerbatimBeforeComponent, createVerbatimComponent, createVerbatimComponentFromBodyContent, doAfterBody, doEndTag, doInitBody, doStartTag, encodeBegin, encodeChildren, encodeEnd, findComponent, getBodyContent, getComponentInstance, getCreated, getCreatedComponents, getDoAfterBodyValue, getDoEndValue, getDoStartValue, getFacesContext, getFacesJspId, getFacetName, getId, getIndexOfNextChildTag, getJspId, getParent, getParentUIComponentClassicTagBase, getPreviousOut, setBodyContent, setId, setJspId, setPageContext, setParent, setupResponseWriter

      • Methods inherited from class javax.faces.webapp.UIComponentTagBase

        getComponentType, getELContext, getRendererType

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.servlet.jsp.tagext.Tag

        doEndTag, doStartTag, getParent, setPageContext, setParent

    • Constructor Detail

      • UIComponentTag

        public UIComponentTag()
        Deprecated.

    • Method Detail

      • setBinding

        public void setBinding(String binding)
                throws JspException
        Deprecated.

        Set the value binding expression for our component.

        Parameters:
        binding - The new value binding expression
        Throws:
        IllegalArgumentException - if the specified binding is not a valid value binding expression.
        JspException

      • hasBinding

        protected boolean hasBinding()
        Deprecated.
        Description copied from class: UIComponentClassicTagBase

        Return true if this component has a non-null binding attribute. This method is necessary to allow subclasses that expose the binding property as an Faces 1.1 style EL property as well as subclasses that expose it as an EL API property.

        Specified by:
        hasBinding in class UIComponentClassicTagBase

      • setRendered

        public void setRendered(String rendered)
        Deprecated.

        Set an override for the rendered attribute.

        Parameters:
        rendered - The new value for rendered attribute

      • isSuppressed

        protected boolean isSuppressed()
        Deprecated.

      • isValueReference

        public static boolean isValueReference(String value)
        Deprecated.

        Return true if the specified value conforms to the syntax requirements of a value binding expression. Such expressions ` * may be used on most component tag attributes to signal a desire for deferred evaluation of the attribute or property value to be set on the underlying UIComponent.

        Parameters:
        value - The value to evaluate
        Throws:
        NullPointerException - if value is null

      • release

        public void release()
        Deprecated.

        Release any resources allocated during the execution of this tag handler.

        Specified by:
        release in interface Tag
        Overrides:
        release in class UIComponentClassicTagBase

      • setProperties

        protected void setProperties(UIComponent component)
        Deprecated.
        Description copied from class: UIComponentClassicTagBase

        Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set. This method must be called ONLY if the specified UIComponent was in fact created during the execution of this tag handler instance, and this call will occur BEFORE the UIComponent is added to the view.

        Tag subclasses that want to support additional set properties must ensure that the base class setProperties() method is still called. A typical implementation that supports extra properties foo and bar would look something like this:

         protected void setProperties(UIComponent component) {
   super.setProperties(component);
   if (foo != null) {
     component.setAttribute("foo", foo);
   }
   if (bar != null) {
     component.setAttribute("bar", bar);
   }
 }

        The default implementation overrides the following properties:

        • rendered - Set if a value for the rendered property is specified for this tag handler instance.
        • rendererType - Set if the getRendererType() method returns a non-null value.
        Specified by:
        setProperties in class UIComponentClassicTagBase
        Parameters:
        component - UIComponent whose properties are to be overridden

      • createComponent

        protected UIComponent createComponent(FacesContext context,
                          String newId)
        Deprecated.

        Implement createComponent using Faces 1.1 EL API.

        Specified by:
        createComponent in class UIComponentClassicTagBase
        Parameters:
        context - FacesContext for the current request
        newId - id of the component

      • getParentUIComponentTag

        public static UIComponentTag getParentUIComponentTag(PageContext context)
        Deprecated.

        Locate and return the nearest enclosing UIComponentTag if any; otherwise, return null.

        Parameters:
        context - PageContext for the current page
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIComponentTagBase (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class UIComponentTagBase

  • java.lang.Object
    • javax.faces.webapp.UIComponentTagBase
  • All Implemented Interfaces:
    JspTag
    Direct Known Subclasses:
    UIComponentClassicTagBase

    public abstract class UIComponentTagBase
extends Object
implements JspTag

    UIComponentTagBase is the base class for all JSP tags that correspond to a UIComponent instance in the view. This base class allows a single view to be described in a JSP page consisting of both UIComponentELTag and UIComponentTag instances.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected static Logger | log

    • Constructor Summary

      Constructors
      Constructor and Description
      UIComponentTagBase()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected abstract void addChild(UIComponent child)
      Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.
      protected abstract void addFacet(String name)
      Add the facet name of the specified facet to the list of facet names created or located by nested UIComponentTags processing this request.
      abstract UIComponent getComponentInstance()
      Return the UIComponent instance that is associated with this tag instance.
      abstract String getComponentType()
      Return the component type for the component that is or will be bound to this tag.
      abstract boolean getCreated()
      Return true if we dynamically created a new component instance during execution of this tag.
      protected ELContext getELContext()
      Return the ELContext for the FacesContext for this request.
      protected abstract FacesContext getFacesContext()
      Return the FacesContext instance for the current request.
      protected abstract int getIndexOfNextChildTag()
      Return the index of the next child to be added as a child of this tag.
      abstract String getRendererType()
      Return the rendererType property that selects the Renderer to be used for encoding this component, or null to ask the component to render itself directly.
      abstract void setId(String id)
      Set the component identifier for the component corresponding to this tag instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • log

        protected static final Logger log

    • Constructor Detail

      • UIComponentTagBase

        public UIComponentTagBase()

    • Method Detail

      • getFacesContext

        protected abstract FacesContext getFacesContext()

        Return the FacesContext instance for the current request. This value will be non-null only from the beginning of doStartTag() through the end of doEndTag() for each tag instance.

      • getELContext

        protected ELContext getELContext()

        Return the ELContext for the FacesContext for this request.

        This is a convenience for getFacesContext().getELContext().

      • addChild

        protected abstract void addChild(UIComponent child)

        Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.

        Parameters:
        child - New child whose identifier should be added

      • addFacet

        protected abstract void addFacet(String name)

        Add the facet name of the specified facet to the list of facet names created or located by nested UIComponentTags processing this request.

        Parameters:
        name - Facet name to be added

      • setId

        public abstract void setId(String id)

        Set the component identifier for the component corresponding to this tag instance. If the argument begins with UIViewRoot.UNIQUE_ID_PREFIX throw an IllegalArgumentException

        Parameters:
        id - The new component identifier. This may not start with UIViewRoot.UNIQUE_ID_PREFIX.
        Throws:
        IllegalArgumentException - if the argument is non-null and starts with UIViewRoot.UNIQUE_ID_PREFIX.

      • getComponentType

        public abstract String getComponentType()

        Return the component type for the component that is or will be bound to this tag. This value can be passed to Application.createComponent(java.lang.String) to create the UIComponent instance for this tag. Subclasses must override this method to return the appropriate value.

      • getRendererType

        public abstract String getRendererType()

        Return the rendererType property that selects the Renderer to be used for encoding this component, or null to ask the component to render itself directly. Subclasses must override this method to return the appropriate value.

      • getComponentInstance

        public abstract UIComponent getComponentInstance()

        Return the UIComponent instance that is associated with this tag instance. This method is designed to be used by tags nested within this tag, and only returns useful results between the execution of doStartTag() and doEndTag() on this tag instance.

      • getCreated

        public abstract boolean getCreated()

        Return true if we dynamically created a new component instance during execution of this tag. This method is designed to be used by tags nested within this tag, and only returns useful results between the execution of doStartTag() and doEndTag() on this tag instance.

      • getIndexOfNextChildTag

        protected abstract int getIndexOfNextChildTag()

        Return the index of the next child to be added as a child of this tag. The default implementation maintains a list of created components and returns the size of the list.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.faces.webapp (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.faces.webapp

  • Packages that use javax.faces.webapp
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
  • Classes in javax.faces.webapp used by javax.faces.webapp
    Class and Description
    UIComponentClassicTagBase
    UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view.
    UIComponentTag
    Deprecated.
    Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
    UIComponentTagBase
    UIComponentTagBase is the base class for all JSP tags that correspond to a UIComponent instance in the view.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidatorELTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class ValidatorELTag

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport
      • javax.faces.webapp.ValidatorELTag
  • All Implemented Interfaces:
    Serializable, IterationTag, JspTag, Tag

    public abstract class ValidatorELTag
extends TagSupport

    ValidatorELTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag. To avoid creating duplicate instances when a page is redisplayed, creation and registration of a Validator occurs only if the corresponding UIComponent was created (by the owning UIComponentTagBase) during the execution of the current page.

    This class must be used as a base class for tag instances that support specific Validator subclasses.

    Subclasses of this class must implement the createValidator() method, which creates and returns a Validator instance. Any configuration properties that specify the limits to be enforced by this Validator must have been set by the createValidator() method. Generally, this occurs by copying corresponding attribute values on the tag instance.

    This tag creates no output to the page currently being created. It is used solely for the side effect of Validator creation.

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.servlet.jsp.tagext.TagSupport

        id, pageContext

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidatorELTag()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected abstract Validator createValidator()
      Create and return a new Validator to be registered on our surrounding UIComponent.
      int doStartTag()
      Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.

      • Methods inherited from class javax.servlet.jsp.tagext.TagSupport

        doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, release, removeValue, setId, setPageContext, setParent, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ValidatorELTag

        public ValidatorELTag()

    • Method Detail

      • doStartTag

        public int doStartTag()
               throws JspException

        Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.

        Specified by:
        doStartTag in interface Tag
        Overrides:
        doStartTag in class TagSupport
        Returns:
        SKIP_BODY
        Throws:
        JspException - if a JSP error occurs
        See Also:
        Tag.doStartTag()

      • createValidator

        protected abstract Validator createValidator()
                                      throws JspException

        Create and return a new Validator to be registered on our surrounding UIComponent.

        Throws:
        JspException - if a new instance cannot be created
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidatorTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.faces.webapp

Class ValidatorTag

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport
      • javax.faces.webapp.ValidatorTag
  • All Implemented Interfaces:
    Serializable, IterationTag, JspTag, Tag
    Deprecated.
    This has been partially replaced by ValidatorELTag. The remainder of the functionality, namely, the binding facility and the implementation of the createValidator() method, is now an implementation detail.

    public class ValidatorTag
extends TagSupport

    ValidatorTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag. To avoid creating duplicate instances when a page is redisplayed, creation and registration of a Validator occurs only if the corresponding UIComponent was created (by the owning UIComponentTag) during the execution of the current page.

    This class may be used directly to implement a generic validator registration tag (based on the validator-id specified by the id attribute), or as a base class for tag instances that support specific Validator subclasses. This id attribute must refer to one of the well known validator-ids, or a custom validator-id as defined in a faces-config.xml file.

    Subclasses of this class must implement the createValidator() method, which creates and returns a Validator instance. Any configuration properties that specify the limits to be enforced by this Validator must have been set by the createValidator() method. Generally, this occurs by copying corresponding attribute values on the tag instance.

    This tag creates no output to the page currently being created. It is used solely for the side effect of Validator creation.

    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.servlet.jsp.tagext.TagSupport

        id, pageContext

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidatorTag()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected Validator createValidator()
      Deprecated.
      Create and return a new Validator to be registered on our surrounding UIComponent.
      int doStartTag()
      Deprecated.
      Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.
      void release()
      Deprecated.
      Release references to any acquired resources.
      void setBinding(String binding)
      Deprecated.
      Set the expression that will be used to create a ValueExpression that references a backing bean property of the Validator instance to be created.
      void setValidatorId(String validatorId)
      Deprecated.
      Set the identifer of the Validator instance to be created.

      • Methods inherited from class javax.servlet.jsp.tagext.TagSupport

        doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ValidatorTag

        public ValidatorTag()
        Deprecated.

    • Method Detail

      • setValidatorId

        public void setValidatorId(String validatorId)
        Deprecated.

        Set the identifer of the Validator instance to be created.

        Parameters:
        validatorId - The new identifier of the validator instance to be created.

      • setBinding

        public void setBinding(String binding)
                throws JspException
        Deprecated.

        Set the expression that will be used to create a ValueExpression that references a backing bean property of the Validator instance to be created.

        Parameters:
        binding - The new expression
        Throws:
        JspException - if a JSP error occurs

      • doStartTag

        public int doStartTag()
               throws JspException
        Deprecated.

        Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.

        Specified by:
        doStartTag in interface Tag
        Overrides:
        doStartTag in class TagSupport
        Returns:
        SKIP_BODY
        Throws:
        JspException - if a JSP error occurs
        See Also:
        Tag.doStartTag()

      • release

        public void release()
        Deprecated.

        Release references to any acquired resources.

        Specified by:
        release in interface Tag
        Overrides:
        release in class TagSupport
        See Also:
        Tag.release()

      • createValidator

        protected Validator createValidator()
                             throws JspException
        Deprecated.

        Create and return a new Validator to be registered on our surrounding UIComponent.

        Throws:
        JspException - if a new instance cannot be created
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.faces.webapp.AttributeTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.AttributeTag

No usage of javax.faces.webapp.AttributeTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.ConverterELTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.ConverterELTag

No usage of javax.faces.webapp.ConverterELTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.ConverterTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.ConverterTag

No usage of javax.faces.webapp.ConverterTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.FacesServlet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.FacesServlet

No usage of javax.faces.webapp.FacesServlet
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.FacetTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.FacetTag

No usage of javax.faces.webapp.FacetTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.PreJsf2ExceptionHandlerFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.PreJsf2ExceptionHandlerFactory

No usage of javax.faces.webapp.PreJsf2ExceptionHandlerFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.UIComponentBodyTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.UIComponentBodyTag

No usage of javax.faces.webapp.UIComponentBodyTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.UIComponentClassicTagBase (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.UIComponentClassicTagBase

  • Packages that use UIComponentClassicTagBase
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of UIComponentClassicTagBase in javax.faces.webapp

      Subclasses of UIComponentClassicTagBase in javax.faces.webapp
      Modifier and Type Class and Description
      class  UIComponentBodyTag
      Deprecated.
      All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.
      class  UIComponentELTag
      UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.
      class  UIComponentTag
      Deprecated.
      Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
      Methods in javax.faces.webapp that return UIComponentClassicTagBase
      Modifier and Type Method and Description
      static UIComponentClassicTagBase UIComponentClassicTagBase.getParentUIComponentClassicTagBase(PageContext context)
      Locate and return the nearest enclosing UIComponentClassicTagBase if any; otherwise, return null.
      Methods in javax.faces.webapp with parameters of type UIComponentClassicTagBase
      Modifier and Type Method and Description
      protected void UIComponentClassicTagBase.addVerbatimAfterComponent(UIComponentClassicTagBase parentTag, UIComponent verbatim, UIComponent component)
      Add verbatim as a sibling of component in component in the parent's child list.
      protected void UIComponentClassicTagBase.addVerbatimBeforeComponent(UIComponentClassicTagBase parentTag, UIComponent verbatim, UIComponent component)
      Add verbatim as a sibling of component in component in the parent's child list.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.UIComponentELTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.UIComponentELTag

No usage of javax.faces.webapp.UIComponentELTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.UIComponentTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.UIComponentTag

  • Packages that use UIComponentTag
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of UIComponentTag in javax.faces.webapp

      Subclasses of UIComponentTag in javax.faces.webapp
      Modifier and Type Class and Description
      class  UIComponentBodyTag
      Deprecated.
      All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.
      Methods in javax.faces.webapp that return UIComponentTag
      Modifier and Type Method and Description
      static UIComponentTag UIComponentTag.getParentUIComponentTag(PageContext context)
      Deprecated.
      Locate and return the nearest enclosing UIComponentTag if any; otherwise, return null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.UIComponentTagBase (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.UIComponentTagBase

  • Packages that use UIComponentTagBase
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of UIComponentTagBase in javax.faces.webapp

      Subclasses of UIComponentTagBase in javax.faces.webapp
      Modifier and Type Class and Description
      class  UIComponentBodyTag
      Deprecated.
      All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.
      class  UIComponentClassicTagBase
      UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view.
      class  UIComponentELTag
      UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.
      class  UIComponentTag
      Deprecated.
      Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.ValidatorELTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.ValidatorELTag

No usage of javax.faces.webapp.ValidatorELTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.faces.webapp.ValidatorTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.faces.webapp.ValidatorTag

No usage of javax.faces.webapp.ValidatorTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Inject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.inject

Annotation Type Inject

  • @Target(value={METHOD,CONSTRUCTOR,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface Inject
    Identifies injectable constructors, methods, and fields. May apply to static as well as instance members. An injectable member may have any access modifier (private, package-private, protected, public). Constructors are injected first, followed by fields, and then methods. Fields and methods in superclasses are injected before those in subclasses. Ordering of injection among fields and among methods in the same class is not specified.

    Injectable constructors are annotated with @Inject and accept zero or more dependencies as arguments. @Inject can apply to at most one constructor per class.

    @Inject ConstructorModifiersopt SimpleTypeName(FormalParameterListopt) Throwsopt ConstructorBody

    @Inject is optional for public, no-argument constructors when no other constructors are present. This enables injectors to invoke default constructors.

    @Injectopt Annotationsopt public SimpleTypeName() Throwsopt ConstructorBody

    Injectable fields:

    • are annotated with @Inject.
    • are not final.
    • may have any otherwise valid name.

    @Inject FieldModifiersopt Type VariableDeclarators;

    Injectable methods:

    • are annotated with @Inject.
    • are not abstract.
    • do not declare type parameters of their own.
    • may return a result
    • may have any otherwise valid name.
    • accept zero or more dependencies as arguments.

    @Inject MethodModifiersopt ResultType Identifier(FormalParameterListopt) Throwsopt MethodBody

    The injector ignores the result of an injected method, but non-void return types are allowed to support use of the method in other contexts (builder-style method chaining, for example).

    Examples:

       public class Car {
     // Injectable constructor
     @Inject public Car(Engine engine) { ... }

     // Injectable field
     @Inject private Provider<Seat> seatProvider;

     // Injectable package-private method
     @Inject void install(Windshield windshield, Trunk trunk) { ... }
   }

    A method annotated with @Inject that overrides another method annotated with @Inject will only be injected once per injection request per instance. A method with no @Inject annotation that overrides a method annotated with @Inject will not be injected.

    Injection of members annotated with @Inject is required. While an injectable member may use any accessibility modifier (including private), platform or injector limitations (like security restrictions or lack of reflection support) might preclude injection of non-public members.

    Qualifiers

    A qualifier may annotate an injectable field or parameter and, combined with the type, identify the implementation to inject. Qualifiers are optional, and when used with @Inject in injector-independent classes, no more than one qualifier should annotate a single field or parameter. The qualifiers are bold in the following example:

       public class Car {
     @Inject private @Leather Provider<Seat> seatProvider;

     @Inject void install(@Tinted Windshield windshield,
         @Big Trunk trunk) { ... }
   }

    If one injectable method overrides another, the overriding method's parameters do not automatically inherit qualifiers from the overridden method's parameters.

    Injectable Values

    For a given type T and optional qualifier, an injector must be able to inject a user-specified class that:

    1. is assignment compatible with T and
    2. has an injectable constructor.

    For example, the user might use external configuration to pick an implementation of T. Beyond that, which values are injected depend upon the injector implementation and its configuration.

    Circular Dependencies

    Detecting and resolving circular dependencies is left as an exercise for the injector implementation. Circular dependencies between two constructors is an obvious problem, but you can also have a circular dependency between injectable fields or methods:

       class A {
     @Inject B b;
   }
   class B {
     @Inject A a;
   }

    When constructing an instance of A, a naive injector implementation might go into an infinite loop constructing an instance of B to set on A, a second instance of A to set on B, a second instance of B to set on the second instance of A, and so on.

    A conservative injector might detect the circular dependency at build time and generate an error, at which point the programmer could break the circular dependency by injecting Provider<A> or Provider<B> instead of A or B respectively. Calling get() on the provider directly from the constructor or method it was injected into defeats the provider's ability to break up circular dependencies. In the case of method or field injection, scoping one of the dependencies (using singleton scope, for example) may also enable a valid circular relationship.

    See Also:
    @Qualifier, Provider
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.inject (Java(TM) EE 7 Specification APIs)

javax.inject

Interfaces

  • Provider

Annotation Types

  • Inject
  • Named
  • Qualifier
  • Scope
  • Singleton


javax.inject (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.inject

This package specifies a means for obtaining objects in such a way as to maximize reusability, testability and maintainability compared to traditional approaches such as constructors, factories, and service locators (e.g., JNDI). This process, known as dependency injection, is beneficial to most nontrivial applications.

See: Description

  • Interface Summary
    Interface Description
    Provider<T>
    Provides instances of T.
  • Annotation Types Summary
    Annotation Type Description
    Inject
    Identifies injectable constructors, methods, and fields.
    Named
    String-based qualifier.
    Qualifier
    Identifies qualifier annotations.
    Scope
    Identifies scope annotations.
    Singleton
    Identifies a type that the injector only instantiates once.

Package javax.inject Description

This package specifies a means for obtaining objects in such a way as to maximize reusability, testability and maintainability compared to traditional approaches such as constructors, factories, and service locators (e.g., JNDI). This process, known as dependency injection, is beneficial to most nontrivial applications.

Many types depend on other types. For example, a Stopwatch might depend on a TimeSource. The types on which a type depends are known as its dependencies. The process of finding an instance of a dependency to use at run time is known as resolving the dependency. If no such instance can be found, the dependency is said to be unsatisfied, and the application is broken.

In the absence of dependency injection, an object can resolve its dependencies in a few ways. It can invoke a constructor, hard-wiring an object directly to its dependency's implementation and life cycle:

   class Stopwatch {
     final TimeSource timeSource;
     Stopwatch () {
       timeSource = new AtomicClock(...);
     }
     void start() { ... }
     long stop() { ... }
   }

If more flexibility is needed, the object can call out to a factory or service locator:

   class Stopwatch {
     final TimeSource timeSource;
     Stopwatch () {
       timeSource = DefaultTimeSource.getInstance();
     }
     void start() { ... }
     long stop() { ... }
   }

In deciding between these traditional approaches to dependency resolution, a programmer must make trade-offs. Constructors are more concise but restrictive. Factories decouple the client and implementation to some extent but require boilerplate code. Service locators decouple even further but reduce compile time type safety. All three approaches inhibit unit testing. For example, if the programmer uses a factory, each test against code that depends on the factory will have to mock out the factory and remember to clean up after itself or else risk side effects:

   void testStopwatch() {
     TimeSource original = DefaultTimeSource.getInstance();
     DefaultTimeSource.setInstance(new MockTimeSource());
     try {
       // Now, we can actually test Stopwatch.
       Stopwatch sw = new Stopwatch();
       ...
     } finally {
       DefaultTimeSource.setInstance(original);
     }
   }

In practice, supporting this ability to mock out a factory results in even more boilerplate code. Tests that mock out and clean up after multiple dependencies quickly get out of hand. To make matters worse, a programmer must predict accurately how much flexibility will be needed in the future or else suffer the consequences. If a programmer initially elects to use a constructor but later decides that more flexibility is required, the programmer must replace every call to the constructor. If the programmer errs on the side of caution and write factories up front, it may result in a lot of unnecessary boilerplate code, adding noise, complexity, and error-proneness.

Dependency injection addresses all of these issues. Instead of the programmer calling a constructor or factory, a tool called a dependency injector passes dependencies to objects:

   class Stopwatch {
     final TimeSource timeSource;
     @Inject Stopwatch(TimeSource TimeSource) {
       this.TimeSource = TimeSource;
     }
     void start() { ... }
     long stop() { ... }
   }

The injector further passes dependencies to other dependencies until it constructs the entire object graph. For example, suppose the programmer asked an injector to create a StopwatchWidget instance:

   /** GUI for a Stopwatch */
   class StopwatchWidget {
     @Inject StopwatchWidget(Stopwatch sw) { ... }
     ...
   }

The injector might:

  1. Find a TimeSource
  2. Construct a Stopwatch with the TimeSource
  3. Construct a StopwatchWidget with the Stopwatch

This leaves the programmer's code clean, flexible, and relatively free of dependency-related infrastructure.

In unit tests, the programmer can now construct objects directly (without an injector) and pass in mock dependencies. The programmer no longer needs to set up and tear down factories or service locators in each test. This greatly simplifies our unit test:

   void testStopwatch() {
     Stopwatch sw = new Stopwatch(new MockTimeSource());
     ...
   }

The total decrease in unit-test complexity is proportional to the product of the number of unit tests and the number of dependencies.

This package provides dependency injection annotations that enable portable classes, but it leaves external dependency configuration up to the injector implementation. Programmers annotate constructors, methods, and fields to advertise their injectability (constructor injection is demonstrated in the examples above). A dependency injector identifies a class's dependencies by inspecting these annotations, and injects the dependencies at run time. Moreover, the injector can verify that all dependencies have been satisfied at build time. A service locator, by contrast, cannot detect unsatisfied dependencies until run time.

Injector implementations can take many forms. An injector could configure itself using XML, annotations, a DSL (domain-specific language), or even plain Java code. An injector could rely on reflection or code generation. An injector that uses compile-time code generation may not even have its own run time representation. Other injectors may not be able to generate code at all, neither at compile nor run time. A "container", for some definition, can be an injector, but this package specification aims to minimize restrictions on injector implementations.

See Also:
@Inject
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.inject Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.inject

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.inject.Provider<T>

Annotation Type Hierarchy

  • javax.inject.Singleton (implements java.lang.annotation.Annotation)
  • javax.inject.Scope (implements java.lang.annotation.Annotation)
  • javax.inject.Qualifier (implements java.lang.annotation.Annotation)
  • javax.inject.Named (implements java.lang.annotation.Annotation)
  • javax.inject.Inject (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Named (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.inject

Annotation Type Named

  • @Qualifier
@Documented
@Retention(value=RUNTIME)
public @interface Named
    String-based qualifier.

    Example usage:

       public class Car {
     @Inject @Named("driver") Seat driverSeat;
     @Inject @Named("passenger") Seat passengerSeat;
     ...
   }

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String value
      The name.

    • Element Detail

      • value

        public abstract String value
        The name.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Provider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.inject

Interface Provider<T>

  • All Known Subinterfaces:
    Instance<T>
    All Known Implementing Classes:
    CDI

    public interface Provider<T>
    Provides instances of T. Typically implemented by an injector. For any type T that can be injected, you can also inject Provider<T>. Compared to injecting T directly, injecting Provider<T> enables:
    • retrieving multiple instances.
    • lazy or optional retrieval of an instance.
    • breaking circular dependencies.
    • abstracting scope so you can look up an instance in a smaller scope from an instance in a containing scope.

    For example:

       class Car {
     @Inject Car(Provider<Seat> seatProvider) {
       Seat driver = seatProvider.get();
       Seat passenger = seatProvider.get();
       ...
     }
   }

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T get()
      Provides a fully-constructed and injected instance of T.

    • Method Detail

      • get

        T get()
        Provides a fully-constructed and injected instance of T.
        Throws:
        RuntimeException - if the injector encounters an error while providing an instance. For example, if an injectable member on T throws an exception, the injector may wrap the exception and throw it to the caller of get(). Callers should not try to handle such exceptions as the behavior may vary across injector implementations and even different configurations of the same injector.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Qualifier (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.inject

Annotation Type Qualifier

  • @Target(value=ANNOTATION_TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface Qualifier
    Identifies qualifier annotations. Anyone can define a new qualifier. A qualifier annotation:
    • is annotated with @Qualifier, @Retention(RUNTIME), and typically @Documented.
    • can have attributes.
    • may be part of the public API, much like the dependency type, but unlike implementation types which needn't be part of the public API.
    • may have restricted usage if annotated with @Target. While this specification covers applying qualifiers to fields and parameters only, some injector configurations might use qualifier annotations in other places (on methods or classes for example).

    For example:

       @java.lang.annotation.Documented
   @java.lang.annotation.Retention(RUNTIME)
   @javax.inject.Qualifier
   public @interface Leather {
     Color color() default Color.TAN;
     public enum Color { RED, BLACK, TAN }
   }
    See Also:
    @Named
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Scope (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.inject

Annotation Type Scope

  • @Target(value=ANNOTATION_TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface Scope
    Identifies scope annotations. A scope annotation applies to a class containing an injectable constructor and governs how the injector reuses instances of the type. By default, if no scope annotation is present, the injector creates an instance (by injecting the type's constructor), uses the instance for one injection, and then forgets it. If a scope annotation is present, the injector may retain the instance for possible reuse in a later injection. If multiple threads can access a scoped instance, its implementation should be thread safe. The implementation of the scope itself is left up to the injector.

    In the following example, the scope annotation @Singleton ensures that we only have one Log instance:

       @Singleton
   class Log {
     void log(String message) { ... }
   }

    The injector generates an error if it encounters more than one scope annotation on the same class or a scope annotation it doesn't support.

    A scope annotation:

    • is annotated with @Scope, @Retention(RUNTIME), and typically @Documented.
    • should not have attributes.
    • is typically not @Inherited, so scoping is orthogonal to implementation inheritance.
    • may have restricted usage if annotated with @Target. While this specification covers applying scopes to classes only, some injector configurations might use scope annotations in other places (on factory method results for example).

    For example:

       @java.lang.annotation.Documented
   @java.lang.annotation.Retention(RUNTIME)
   @javax.inject.Scope
   public @interface RequestScoped {}

    Annotating scope annotations with @Scope helps the injector detect the case where a programmer used the scope annotation on a class but forgot to configure the scope in the injector. A conservative injector would generate an error rather than not apply a scope.

    See Also:
    @Singleton
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Singleton (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.inject

Annotation Type Singleton

  • @Scope
@Documented
@Retention(value=RUNTIME)
public @interface Singleton
    Identifies a type that the injector only instantiates once. Not inherited.
    See Also:
    @Scope
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.inject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.inject

  • Packages that use javax.inject
    Package Description
    javax.batch.api
    Provides APIs used by Batch artifacts.
    javax.enterprise.context
    Annotations and interfaces relating to scopes and contexts.
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.
    javax.enterprise.inject.spi
    The portable extension integration SPI.
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.
    javax.inject
    This package specifies a means for obtaining objects in such a way as to maximize reusability, testability and maintainability compared to traditional approaches such as constructors, factories, and service locators (e.g., JNDI). This process, known as dependency injection, is beneficial to most nontrivial applications.
  • Classes in javax.inject used by javax.batch.api
    Class and Description
    Qualifier
    Identifies qualifier annotations.
  • Classes in javax.inject used by javax.enterprise.context
    Class and Description
    Qualifier
    Identifies qualifier annotations.
    Scope
    Identifies scope annotations.
  • Classes in javax.inject used by javax.enterprise.inject
    Class and Description
    Named
    String-based qualifier.
    Provider
    Provides instances of T.
    Qualifier
    Identifies qualifier annotations.
  • Classes in javax.inject used by javax.enterprise.inject.spi
    Class and Description
    Provider
    Provides instances of T.
  • Classes in javax.inject used by javax.faces.flow.builder
    Class and Description
    Qualifier
    Identifies qualifier annotations.
  • Classes in javax.inject used by javax.inject
    Class and Description
    Qualifier
    Identifies qualifier annotations.
    Scope
    Identifies scope annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.inject.Inject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.inject.Inject

No usage of javax.inject.Inject
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.inject.Named (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.inject.Named

  • Packages that use Named
    Package Description
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.

    • Uses of Named in javax.enterprise.inject

      Classes in javax.enterprise.inject with annotations of type Named
      Modifier and Type Class and Description
      interface  Model
      The built-in stereotype intended for use with beans that define the model layer of an MVC web application architecture such as JSF.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.inject.Qualifier (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.inject.Qualifier

  • Packages that use Qualifier
    Package Description
    javax.batch.api
    Provides APIs used by Batch artifacts.
    javax.enterprise.context
    Annotations and interfaces relating to scopes and contexts.
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.
    javax.faces.flow.builder

    Classes for declaring a Faces Flow.
    javax.inject
    This package specifies a means for obtaining objects in such a way as to maximize reusability, testability and maintainability compared to traditional approaches such as constructors, factories, and service locators (e.g., JNDI). This process, known as dependency injection, is beneficial to most nontrivial applications.

    • Uses of Qualifier in javax.batch.api

      Classes in javax.batch.api with annotations of type Qualifier
      Modifier and Type | Class and Description
      interface  | BatchProperty

    • Uses of Qualifier in javax.enterprise.context

      Classes in javax.enterprise.context with annotations of type Qualifier
      Modifier and Type Class and Description
      interface  Destroyed
      The @Destroyed qualifier.
      interface  Initialized
      The @Initialized qualifier.

    • Uses of Qualifier in javax.enterprise.inject

      Classes in javax.enterprise.inject with annotations of type Qualifier
      Modifier and Type Class and Description
      interface  Any
      The built-in qualifier type.
      interface  Decorated
      A decorator may inject metadata about the bean it is decorating
      interface  Default
      The default qualifier type.
      interface  Intercepted
      An interceptor may inject metadata about the bean it is intercepting.
      interface  New
      The New qualifier was deprecated in CDI 1.1.

    • Uses of Qualifier in javax.faces.flow.builder

      Classes in javax.faces.flow.builder with annotations of type Qualifier
      Modifier and Type Class and Description
      interface  FlowBuilderParameter

      The presence of this annotation on a CDI producer method for the FlowDefinition annotation causes the FlowBuilder to be passed to that method.
      interface  FlowDefinition

      The presence of this annotation on a CDI producer method indicates that the method will produce a flow.

    • Uses of Qualifier in javax.inject

      Classes in javax.inject with annotations of type Qualifier
      Modifier and Type Class and Description
      interface  Named
      String-based qualifier.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.inject.Scope (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.inject.Scope

  • Packages that use Scope
    Package Description
    javax.enterprise.context
    Annotations and interfaces relating to scopes and contexts.
    javax.inject
    This package specifies a means for obtaining objects in such a way as to maximize reusability, testability and maintainability compared to traditional approaches such as constructors, factories, and service locators (e.g., JNDI). This process, known as dependency injection, is beneficial to most nontrivial applications.

    • Uses of Scope in javax.enterprise.context

      Classes in javax.enterprise.context with annotations of type Scope
      Modifier and Type Class and Description
      interface  Dependent
      Specifies that a bean belongs to the dependent pseudo-scope.

    • Uses of Scope in javax.inject

      Classes in javax.inject with annotations of type Scope
      Modifier and Type Class and Description
      interface  Singleton
      Identifies a type that the injector only instantiates once.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.inject.Singleton (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.inject.Singleton

No usage of javax.inject.Singleton
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.inject.Provider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.inject.Provider

  • Packages that use Provider
    Package Description
    javax.enterprise.inject
    Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of Provider in javax.enterprise.inject

      Subinterfaces of Provider in javax.enterprise.inject
      Modifier and Type Interface and Description
      interface  Instance<T>
      Allows the application to dynamically obtain instances of beans with a specified combination of required type and qualifiers.

    • Uses of Provider in javax.enterprise.inject.spi

      Classes in javax.enterprise.inject.spi that implement Provider
      Modifier and Type Class and Description
      class  CDI<T>
      Provides access to the current container.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AroundConstruct (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.interceptor

Annotation Type AroundConstruct

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface AroundConstruct

    Designates an interceptor method that receives a callback when the target class constructor is invoked.

    The method to which this annotation is applied must have one of the following signatures.

     @AroundConstruct
 public void <METHOD>(InvocationContext ctx) { ... }

     @AroundConstruct
 public Object <METHOD>(InvocationContext ctx) throws Exception { ... }

    An AroundConstruct interceptor method may be only declared on an interceptor class.

    An interceptor class must not declare more than one AroundConstruct method.

    AroundConstruct methods may throw runtime exceptions, but not checked exceptions.

    The target instance is created and its constructor injection is performed, if applicable, when the last interceptor method in the AroundConstruct interceptor chain invokes the InvocationContext.proceed() method.

    An AroundConstruct interceptor method should exercise caution accessing the instance which constructor it interposes on.

    Since:
    Interceptors 1.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AroundInvoke (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.interceptor

Annotation Type AroundInvoke

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface AroundInvoke

    Defines an interceptor method that interposes on business methods. May be applied to any non-final, non-static method with a single parameter of type InvocationContext and return type Object of the target class (or superclass) or of any interceptor class.

     @AroundInvoke
 public Object intercept(InvocationContext ctx) throws Exception { ... }

    A class must not declare more than one AroundInvoke method.

    An AroundInvoke method can invoke any component or resource that the method it is intercepting can invoke.

    AroundInvoke method invocations occur within the same transaction and security context as the method on which they are interposing.

    AroundInvoke methods may throw any exceptions that are allowed by the throws clause of the method on which they are interposing. They may catch and suppress exceptions and recover by calling InvocationContext.proceed().

    Since:
    Interceptors 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AroundTimeout (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.interceptor

Annotation Type AroundTimeout

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface AroundTimeout

    Defines an interceptor method that interposes on timeout methods. May be applied to any non-final, non-static method with a single parameter of type InvocationContext and return type Object of the target class (or superclass) or of any interceptor class.

     @AroundTimeout
 public Object interceptTimeout(InvocationContext ctx) throws Exception { ... }

    A class must not declare more than one AroundTimeout method.

    An AroundTimeout method can invoke any component or resource that its corresponding timeout method can invoke.

    InvocationContext.getTimer() allows any AroundTimeout method to retrieve the timer object associated with the timeout.

    AroundTimeout method invocations occur within the same transaction and security context as the timeout method on which they are interposing.

    AroundTimeout methods may throw any exceptions that are allowed by the throws clause of the timeout method on which they are interposing. They may catch and suppress exceptions and recover by calling InvocationContext.proceed().

    Since:
    Interceptors 1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ExcludeClassInterceptors (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.interceptor

Annotation Type ExcludeClassInterceptors

  • @Target(value={METHOD,CONSTRUCTOR})
@Retention(value=RUNTIME)
public @interface ExcludeClassInterceptors

    Used to exclude class-level interceptors for a lifecycle callback, business, or timeout method of a target class, or a constructor of a target class.

     @ExcludeClassInterceptors
 public void updateOrder(Order order) { ... }
    Since:
    Interceptors 1.0
    See Also:
    ExcludeClassInterceptors
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ExcludeDefaultInterceptors (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.interceptor

Annotation Type ExcludeDefaultInterceptors

  • @Target(value={TYPE,METHOD,CONSTRUCTOR})
@Retention(value=RUNTIME)
public @interface ExcludeDefaultInterceptors

    Used to exclude default interceptors for a target class or a lifecycle callback, business, or timeout method of a target class, or a constructor of a target class.

     @ExcludeDefaultInterceptors
 @Interceptors(ValidationInterceptor.class)
 public class Order { ... }

     @ExcludeDefaultInterceptors
 public void updateOrder(Order order) { ... }
    Since:
    Interceptors 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Interceptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.interceptor

Annotation Type Interceptor

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
@Documented
public @interface Interceptor

    Specifies that a class is an interceptor.

     @Interceptor
 public class ValidationInterceptor { ... }

    This annotation is optional if the Interceptors annotation or the EJB deployment descriptor are used to associate the interceptor with the target class. It is required when an interceptor binding is used.

    Since:
    Interceptors 1.1
    See Also:
    Interceptors
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Interceptor.Priority (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.interceptor

Class Interceptor.Priority

  • java.lang.Object
    • javax.interceptor.Interceptor.Priority
  • Enclosing class:
    Interceptor

    public static class Interceptor.Priority
extends Object

    Priorities that define the order in which interceptors are invoked. These values should be used with the Priority annotation.

    • Interceptors defined by platform specifications should have priority values in the range PLATFORM_BEFORE up until LIBRARY_BEFORE, or starting at PLATFORM_AFTER.
    • Interceptors defined by extension libraries should have priority values in the range LIBRARY_BEFORE up until APPLICATION, or LIBRARY_AFTER up until PLATFORM_AFTER.
    • Interceptors defined by applications should have priority values in the range APPLICATION up until LIBRARY_AFTER.

    An interceptor that must be invoked before or after another defined interceptor can choose any appropriate value.

    Interceptors with smaller priority values are called first. If more than one interceptor has the same priority, the relative order of these interceptor is undefined.

    For example, an extension library might define an interceptor like this:

     @Priority(Interceptor.Priority.LIBRARY_BEFORE+10)
 @Interceptor
 public class ValidationInterceptor { ... }
    Since:
    Interceptors 1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int APPLICATION
      Start of range for interceptors defined by applications.
      static int LIBRARY_AFTER
      Start of range for late interceptors defined by extension libraries.
      static int LIBRARY_BEFORE
      Start of range for early interceptors defined by extension libraries.
      static int PLATFORM_AFTER
      Start of range for late interceptors defined by platform specifications.
      static int PLATFORM_BEFORE
      Start of range for early interceptors defined by platform specifications.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • PLATFORM_BEFORE

        public static final int PLATFORM_BEFORE
        Start of range for early interceptors defined by platform specifications.
        See Also:
        Constant Field Values

      • LIBRARY_BEFORE

        public static final int LIBRARY_BEFORE
        Start of range for early interceptors defined by extension libraries.
        See Also:
        Constant Field Values

      • APPLICATION

        public static final int APPLICATION
        Start of range for interceptors defined by applications.
        See Also:
        Constant Field Values

      • LIBRARY_AFTER

        public static final int LIBRARY_AFTER
        Start of range for late interceptors defined by extension libraries.
        See Also:
        Constant Field Values

      • PLATFORM_AFTER

        public static final int PLATFORM_AFTER
        Start of range for late interceptors defined by platform specifications.
        See Also:
        Constant Field Values
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InterceptorBinding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.interceptor

Annotation Type InterceptorBinding

  • @Target(value=ANNOTATION_TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface InterceptorBinding

    Specifies that an annotation type is an interceptor binding type.

     @Inherited
 @InterceptorBinding
 @Target({TYPE, METHOD, CONSTRUCTOR})
 @Retention(RUNTIME)
 public @interface Valid {}

    Interceptor bindings are intermediate annotations that may be used to associate interceptors with target beans.

    The interceptor bindings of an interceptor are specified by annotating the interceptor class with the binding types and the Interceptor annotation.

     @Valid @Interceptor
 public class ValidationInterceptor { ... }

    An interceptor may specify multiple interceptor bindings.

    An interceptor binding of a bean may be declared by annotating the bean class, a method of the bean class, or a constructor of the bean class with the interceptor binding type.

     @Valid
 public class Order { ... }

     @Valid @Secure
 public void updateOrder(Order order) { ... }

     @Valid
 public Order(...) { ... }

    A bean class or method of a bean class may declare multiple interceptor bindings.

    An interceptor binding type may declare other interceptor bindings.

     @Inherited
 @InterceptorBinding
 @Target({TYPE, METHOD})
 @Retention(RUNTIME)
 @Valid
 public @interface Secure {}

    Interceptor bindings are transitive—an interceptor binding declared by an interceptor binding type is inherited by all beans and other interceptor binding types that declare that interceptor binding type.

    Since:
    Interceptors 1.1
    See Also:
    Interceptor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Interceptors (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.interceptor

Annotation Type Interceptors

  • @Target(value={TYPE,METHOD,CONSTRUCTOR})
@Retention(value=RUNTIME)
public @interface Interceptors

    Declares an ordered list of interceptors for a target class, a method or a constructor of a target class.

     @Interceptors(ValidationInterceptor.class)
 public class Order { ... }

     @Interceptors({ValidationInterceptor.class, SecurityInterceptor.class})
 public void updateOrder(Order order) { ... }

    Only business method interception or timeout method interception may be specified by a method-level Interceptors declaration.

    Constructor interception may be specified by a constructor-level Interceptors declaration.

    Since:
    Interceptors 1.0
    See Also:
    ExcludeClassInterceptors, ExcludeDefaultInterceptors

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class[] value
      An ordered list of interceptors.

    • Element Detail

      • value

        public abstract Class[] value
        An ordered list of interceptors.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


InvocationContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.interceptor

Interface InvocationContext

  • public interface InvocationContext

    Exposes context information about the intercepted invocation and operations that enable interceptor methods to control the behavior of the invocation chain.

    @AroundInvoke
    public Object logInvocation(InvocationContext ctx) throws Exception {
       String class = ctx.getMethod().getDeclaringClass().getName();
       String method = ctx.getMethod().getName();
       Logger.global.entering(class, method, ctx.getParameters());
       try {
          Object result = ctx.proceed();
          Logger.global.exiting(class, method, result);
          return result;
       }
       catch (Exception e) {
          Logger.global.throwing(class, method, e);
          throw e;
       }

    }
    Since:
    Interceptors 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Constructor<?> getConstructor()
      Returns the constructor of the target class for which the interceptor was invoked.
      Map<String,Object> getContextData()
      Enables an interceptor to retrieve or update the data associated with the invocation by another interceptor, business method,and/or webservices context in the invocation chain.
      Method getMethod()
      Returns the method of the target class for which the interceptor was invoked.
      Object[] getParameters()
      Returns the parameter values that will be passed to the method or constructor of the target class.
      Object getTarget()
      Returns the target instance.
      Object getTimer()
      Returns the timer object associated with a timeout method invocation on the target class, or a null value for method and lifecycle callback interceptor methods.
      Object proceed()
      Proceed to the next interceptor in the interceptor chain.
      void setParameters(Object[] params)
      Sets the parameter values that will be passed to the method or constructor of the target class.

    • Method Detail

      • getTarget

        Object getTarget()
        Returns the target instance. For the AroundConstruct lifecycle callback interceptor method, the getTarget returns null if called before the proceed() method.
        Returns:
        the target instance

      • getTimer

        Object getTimer()
        Returns the timer object associated with a timeout method invocation on the target class, or a null value for method and lifecycle callback interceptor methods. For example, when associated with an EJB component timeout, this method returns Timer
        Returns:
        the timer object or a null value
        Since:
        Interceptors 1.1

      • getMethod

        Method getMethod()
        Returns the method of the target class for which the interceptor was invoked. In a lifecycle callback interceptor for which there is no corresponding lifecycle callback method on the target class or in the AroundConstruct lifecycle callback interceptor method, getMethod returns null.
        Returns:
        the method, or a null value

      • getConstructor

        Constructor<?> getConstructor()
        Returns the constructor of the target class for which the interceptor was invoked. For AroundConstruct interceptor, the constructor of the target class is returned. For all other interceptors, a null value is returned.
        Returns:
        the constructor, or a null value

      • getParameters

        Object[] getParameters()
        Returns the parameter values that will be passed to the method or constructor of the target class. If setParameters(java.lang.Object[]) has been called, getParameters returns the values to which the parameters have been set.
        Returns:
        the parameter values, as an array
        Throws:
        IllegalStateException - if invoked within a lifecycle callback method which is not an AroundConstruct callback.

      • setParameters

        void setParameters(Object[] params)
        Sets the parameter values that will be passed to the method or constructor of the target class.
        Parameters:
        params - the parameter values, as an array
        Throws:
        IllegalStateException - if invoked within a lifecycle callback method which is not an AroundConstruct callback.
        IllegalArgumentException - if the types of the given parameter values do not match the types of the method or constructor parameters, or if the number of parameters supplied does not equal the number of method or constructor parameters (if the last parameter is a vararg parameter of type T, it is considered to be equivalent to a parameter of type T[]).

      • getContextData

        Map<String,Object> getContextData()
        Enables an interceptor to retrieve or update the data associated with the invocation by another interceptor, business method,and/or webservices context in the invocation chain. If interceptors are invoked as a result of the invocation on a web service endpoint, the returned value will be an instance of javax.xml.rpc.handler.MessageContext
        Returns:
        the context data associated with this invocation or lifecycle callback. If there is no context data, an empty Map<String,Object> object will be returned.

      • proceed

        Object proceed()
               throws Exception
        Proceed to the next interceptor in the interceptor chain. For the around-invoke or around-timeout interceptor methods, the invocation of the last interceptor method in the chain causes the invocation of the target class method. For AroundConstruct lifecycle callback interceptor methods, the invocation of the last interceptor method in the chain causes the target instance to be created. For all other lifecycle callback interceptor methods, if there is no callback method defined on the target class, the invocation of proceed in the last interceptor method in the chain is a no-op

        Return the result of the next method invoked, or a null value if the method has return type void.

        Returns:
        the return value of the next method in the chain
        Throws:
        Exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.interceptor (Java(TM) EE 7 Specification APIs)

javax.interceptor

Interfaces

  • InvocationContext

Classes

  • Interceptor.Priority

Annotation Types

  • AroundConstruct
  • AroundInvoke
  • AroundTimeout
  • ExcludeClassInterceptors
  • ExcludeDefaultInterceptors
  • Interceptor
  • InterceptorBinding
  • Interceptors


javax.interceptor (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.interceptor

Contains annotations and interfaces for defining interceptor methods, interceptor classes and for binding interceptor classes to target classes.

See: Description

  • Interface Summary
    Interface Description
    InvocationContext
    Exposes context information about the intercepted invocation and operations that enable interceptor methods to control the behavior of the invocation chain.
  • Class Summary
    Class Description
    Interceptor.Priority
    Priorities that define the order in which interceptors are invoked.
  • Annotation Types Summary
    Annotation Type Description
    AroundConstruct
    Designates an interceptor method that receives a callback when the target class constructor is invoked.
    AroundInvoke
    Defines an interceptor method that interposes on business methods.
    AroundTimeout
    Defines an interceptor method that interposes on timeout methods.
    ExcludeClassInterceptors
    Used to exclude class-level interceptors for a lifecycle callback, business, or timeout method of a target class, or a constructor of a target class.
    ExcludeDefaultInterceptors
    Used to exclude default interceptors for a target class or a lifecycle callback, business, or timeout method of a target class, or a constructor of a target class.
    Interceptor
    Specifies that a class is an interceptor.
    InterceptorBinding
    Specifies that an annotation type is an interceptor binding type.
    Interceptors
    Declares an ordered list of interceptors for a target class, a method or a constructor of a target class.

Package javax.interceptor Description

Contains annotations and interfaces for defining interceptor methods, interceptor classes and for binding interceptor classes to target classes.

Interceptor methods

An interceptor method may be defined on a target class itself or on an interceptor class associated with the target class. AroundConstruct interceptor may be defined only on an interceptor class.

There are three kinds of interceptor method:

  • around-invoke interceptor methods for business methods of the target class
  • around-timeout interceptor methods for timeout methods of the target class
  • lifecycle callback interceptor methods, such as AroundConstruct, PostConstruct and PreDestroy

An interceptor method may be defined using annotations or, optionally, by means of a deployment descriptor. Interceptor methods may not be declared static or final.

An interceptor class or target class may have multiple interceptor methods. However, an interceptor class or target class may have no more than one interceptor method for a certain type of interception: AroundInvoke, AroundTimeout, PostConstruct, PreDestroy, AroundConstruct.

Interceptor classes

An interceptor class is a class (distinct from the target class) whose methods are invoked in response to invocations and/or lifecycle events on the target class. Any number of interceptor classes may be associated with a target class.

An interceptor class must have a public constructor with no parameters.

Interceptor methods and interceptor classes may be defined for a class by means of metadata annotations or, optionally, by means of a deployment descriptor.

Associating an interceptor class with the target class

An interceptor class may be associated with the target class or a method of the target class in several ways:

  • By annotating both the interceptor class and the target class with an interceptor binding. The set of interceptor bindings for the interceptor are specified by annotating the interceptor class with the binding types and the Interceptor annotation.
  • By using the Interceptors annotation to denote interceptor classes and associate one or more interceptor classes with a target class and/or one or more of its methods.
  • If a deployment descriptor is supported, it can be used to associate interceptor classes with the target class and/or methods of the target class and specify the order of interceptor invocation or override metadata specified by annotations.

Any interceptor class may be defined to apply to a target class at the class level. In the case of around-invoke method interceptors, the interceptor applies to all business methods of the target class. In the case of timeout method interceptors, the interceptor applies to all timeout methods of the target class.

ExcludeClassInterceptors annotation or, if supported, a deployment descriptor may be used to exclude the invocation of class level interceptors for a method of a target class.

An around-invoke interceptor may be defined to apply only to a specific method of the target class. Likewise, an around-timeout interceptor may be defined to apply only to a specific timeout method of the target class. However, if an interceptor class that defines lifecycle callback interceptor methods is defined to apply to a target class at the method level, the lifecycle callback interceptor methods are not invoked.

Default Interceptors

Default interceptors are interceptors that apply to a set of target classes. If a deployment descriptor is supported, it may be used to define default interceptors and their relative ordering.

ExcludeDefaultInterceptors annotation may be used to exclude the invocation of default interceptors for a target class or method of a target class.

Interceptor lifecycle

The lifecycle of an interceptor instance is the same as that of the target class instance with which it is associated. Except for the AroundConstruct lifecycle callback interceptors, when the target instance is created, a corresponding interceptor instance is created for each associated interceptor class. These interceptor instances are destroyed when the target instance fails to be created or when it is removed.

An interceptor class shares the enterprise naming context of its associated target class. Annotations and/or XML deployment descriptor elements for dependency injection or for direct JNDI lookup refer to this shared naming context.

An interceptor instance may hold state. An interceptor instance may be the target of dependency injection. Dependency injection is performed when the interceptor instance is created, using the naming context of the associated target class. With the exception of AroundConstruct lifecycle callback interceptors, all interceptor methods, including PostConstruct interceptor callback method are invoked after this dependency injection has taken place on both the interceptor instances and the target instance.

PreDestroy interceptor callback method, if any, is invoked before the target instance and all interceptor instances associated with it are destroyed.

When a AroundConstruct lifecycle callback interceptor is used, the following rules apply:

  • The AroundConstruct lifecycle callback is invoked after the dependency injection has been completed on instances of all interceptor classes associated with the target class. Injection of the target component into interceptor instances that are invoked during the AroundConstruct lifecycle callback is not supported.
  • The target instance is created and its constructor injection is performed, if applicable, when the last interceptor method in the AroundConstruct interceptor chain invokes the InvocationContext.proceed() method. If the InvocationContext.proceed() method is not invoked by an interceptor method, the target instance will not be created.
  • The AroundConstruct interceptor method can access the constructed instance using the InvocationContext.getTarget() method after the InvocationContext.proceed() completes.
  • Dependency injection on the target instance is not completed until after invocation of all interceptor methods in the AroundConstruct interceptor chain complete successfully.
  • The PostConstruct lifecycle callback chain for the target instance, if any, will be invoked after the dependency injection has been completed on the target instance.
  • An AroundConstruct lifecycle callback interceptor method should exercise caution when invoking methods of the target instance since its dependency injection may not have been completed.

Interceptors for lifecycle callbacks

A lifecycle callback interceptor method is a non-final, non-static method. A lifecycle callback interceptor method declared by the target class (or superclass) must have no parameters. A lifecycle callback interceptor method declared by an interceptor class must have a single parameter of type InvocationContext.

@PostConstruct
public void interceptPostConstruct(InvocationContext ctx) { ... }

A single lifecycle callback interceptor method may be used to interpose on multiple callback events.

@PostConstruct @PreDestroy
public void interceptLifecycle(InvocationContext ctx) { ... }

A class may not declare more than one lifecycle callback interceptor method for a particular lifecycle event.

Lifecycle callback interceptor methods are invoked in an unspecified security context. Lifecycle callback interceptor methods are invoked in a transaction context determined by their target class and/or method. The transaction context may be also changed by transactional interceptors in the invocation chain.

Lifecycle callback interceptor methods may throw runtime exceptions but not checked exceptions.

See Also:
AroundConstruct, AroundInvoke, AroundTimeout, Interceptors, InvocationContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.interceptor Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.interceptor

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.interceptor.Interceptor.Priority

Interface Hierarchy

  • javax.interceptor.InvocationContext

Annotation Type Hierarchy

  • javax.interceptor.Interceptors (implements java.lang.annotation.Annotation)
  • javax.interceptor.InterceptorBinding (implements java.lang.annotation.Annotation)
  • javax.interceptor.Interceptor (implements java.lang.annotation.Annotation)
  • javax.interceptor.ExcludeDefaultInterceptors (implements java.lang.annotation.Annotation)
  • javax.interceptor.ExcludeClassInterceptors (implements java.lang.annotation.Annotation)
  • javax.interceptor.AroundTimeout (implements java.lang.annotation.Annotation)
  • javax.interceptor.AroundInvoke (implements java.lang.annotation.Annotation)
  • javax.interceptor.AroundConstruct (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.interceptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.interceptor

  • Packages that use javax.interceptor
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.
  • Classes in javax.interceptor used by javax.enterprise.inject.spi
    Class and Description
    InvocationContext
    Exposes context information about the intercepted invocation and operations that enable interceptor methods to control the behavior of the invocation chain.
  • Classes in javax.interceptor used by javax.transaction
    Class and Description
    InterceptorBinding
    Specifies that an annotation type is an interceptor binding type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.interceptor.AroundConstruct (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.interceptor.AroundConstruct

No usage of javax.interceptor.AroundConstruct
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.interceptor.AroundInvoke (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.interceptor.AroundInvoke

No usage of javax.interceptor.AroundInvoke
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.interceptor.AroundTimeout (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.interceptor.AroundTimeout

No usage of javax.interceptor.AroundTimeout
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.interceptor.ExcludeClassInterceptors (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.interceptor.ExcludeClassInterceptors

No usage of javax.interceptor.ExcludeClassInterceptors
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.interceptor.ExcludeDefaultInterceptors (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.interceptor.ExcludeDefaultInterceptors

No usage of javax.interceptor.ExcludeDefaultInterceptors
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.interceptor.Interceptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.interceptor.Interceptor

No usage of javax.interceptor.Interceptor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.interceptor.Interceptor.Priority (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.interceptor.Interceptor.Priority

No usage of javax.interceptor.Interceptor.Priority
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.interceptor.InterceptorBinding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.interceptor.InterceptorBinding

  • Packages that use InterceptorBinding
    Package Description
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of InterceptorBinding in javax.transaction

      Classes in javax.transaction with annotations of type InterceptorBinding
      Modifier and Type Class and Description
      interface  Transactional
      The javax.transaction.Transactional annotation provides the application the ability to declaratively control transaction boundaries on CDI managed beans, as well as classes defined as managed beans by the Java EE specification, at both the class and method level where method level annotations override those at the class level.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.interceptor.Interceptors (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.interceptor.Interceptors

No usage of javax.interceptor.Interceptors
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.interceptor.InvocationContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.interceptor.InvocationContext

  • Packages that use InvocationContext
    Package Description
    javax.enterprise.inject.spi
    The portable extension integration SPI.

    • Uses of InvocationContext in javax.enterprise.inject.spi

      Methods in javax.enterprise.inject.spi with parameters of type InvocationContext
      Modifier and Type Method and Description
      Object Interceptor.intercept(InterceptionType type, T instance, InvocationContext ctx)
      Invokes the specified kind of lifecycle callback or method invocation interception upon the given interceptor instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BytesMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface BytesMessage

  • All Superinterfaces:
    Message

    public interface BytesMessage
extends Message
    A BytesMessage object is used to send a message containing a stream of uninterpreted bytes. It inherits from the Message interface and adds a bytes message body. The receiver of the message supplies the interpretation of the bytes.

    The BytesMessage methods are based largely on those found in java.io.DataInputStream and java.io.DataOutputStream.

    This message type is for client encoding of existing message formats. If possible, one of the other self-defining message types should be used instead.

    Although the JMS API allows the use of message properties with byte messages, they are typically not used, since the inclusion of properties may affect the format.

    The primitive types can be written explicitly using methods for each type. They may also be written generically as objects. For instance, a call to BytesMessage.writeInt(6) is equivalent to BytesMessage.writeObject(new Integer(6)). Both forms are provided, because the explicit form is convenient for static programming, and the object form is needed when types are not known at compile time.

    When the message is first created, and when clearBody is called, the body of the message is in write-only mode. After the first call to reset has been made, the message body is in read-only mode. After a message has been sent, the client that sent it can retain and modify it without affecting the message that has been sent. The same message object can be sent multiple times. When a message has been received, the provider has called reset so that the message body is in read-only mode for the client.

    If clearBody is called on a message in read-only mode, the message body is cleared and the message is in write-only mode.

    If a client attempts to read a message in write-only mode, a MessageNotReadableException is thrown.

    If a client attempts to write a message in read-only mode, a MessageNotWriteableException is thrown.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createBytesMessage(), MapMessage, Message, ObjectMessage, StreamMessage, TextMessage

    • Field Summary

      • Fields inherited from interface javax.jms.Message

        DEFAULT_DELIVERY_DELAY, DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getBodyLength()
      Gets the number of bytes of the message body when the message is in read-only mode.
      boolean readBoolean()
      Reads a boolean from the bytes message stream.
      byte readByte()
      Reads a signed 8-bit value from the bytes message stream.
      int readBytes(byte[] value)
      Reads a byte array from the bytes message stream.
      int readBytes(byte[] value, int length)
      Reads a portion of the bytes message stream.
      char readChar()
      Reads a Unicode character value from the bytes message stream.
      double readDouble()
      Reads a double from the bytes message stream.
      float readFloat()
      Reads a float from the bytes message stream.
      int readInt()
      Reads a signed 32-bit integer from the bytes message stream.
      long readLong()
      Reads a signed 64-bit integer from the bytes message stream.
      short readShort()
      Reads a signed 16-bit number from the bytes message stream.
      int readUnsignedByte()
      Reads an unsigned 8-bit number from the bytes message stream.
      int readUnsignedShort()
      Reads an unsigned 16-bit number from the bytes message stream.
      String readUTF()
      Reads a string that has been encoded using a modified UTF-8 format from the bytes message stream.
      void reset()
      Puts the message body in read-only mode and repositions the stream of bytes to the beginning.
      void writeBoolean(boolean value)
      Writes a boolean to the bytes message stream as a 1-byte value.
      void writeByte(byte value)
      Writes a byte to the bytes message stream as a 1-byte value.
      void writeBytes(byte[] value)
      Writes a byte array to the bytes message stream.
      void writeBytes(byte[] value, int offset, int length)
      Writes a portion of a byte array to the bytes message stream.
      void writeChar(char value)
      Writes a char to the bytes message stream as a 2-byte value, high byte first.
      void writeDouble(double value)
      Converts the double argument to a long using the doubleToLongBits method in class Double, and then writes that long value to the bytes message stream as an 8-byte quantity, high byte first.
      void writeFloat(float value)
      Converts the float argument to an int using the floatToIntBits method in class Float, and then writes that int value to the bytes message stream as a 4-byte quantity, high byte first.
      void writeInt(int value)
      Writes an int to the bytes message stream as four bytes, high byte first.
      void writeLong(long value)
      Writes a long to the bytes message stream as eight bytes, high byte first.
      void writeObject(Object value)
      Writes an object to the bytes message stream.
      void writeShort(short value)
      Writes a short to the bytes message stream as two bytes, high byte first.
      void writeUTF(String value)
      Writes a string to the bytes message stream using UTF-8 encoding in a machine-independent manner.

      • Methods inherited from interface javax.jms.Message

        acknowledge, clearBody, clearProperties, getBody, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDeliveryTime, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, isBodyAssignableTo, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDeliveryTime, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

    • Method Detail

      • getBodyLength

        long getBodyLength()
                   throws JMSException
        Gets the number of bytes of the message body when the message is in read-only mode. The value returned can be used to allocate a byte array. The value returned is the entire length of the message body, regardless of where the pointer for reading the message is currently located.
        Returns:
        number of bytes in the message
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageNotReadableException - if the message is in write-only mode.
        Since:
        JMS 1.1

      • readBoolean

        boolean readBoolean()
                    throws JMSException
        Reads a boolean from the bytes message stream.
        Returns:
        the boolean value read
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readByte

        byte readByte()
              throws JMSException
        Reads a signed 8-bit value from the bytes message stream.
        Returns:
        the next byte from the bytes message stream as a signed 8-bit byte
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readUnsignedByte

        int readUnsignedByte()
                     throws JMSException
        Reads an unsigned 8-bit number from the bytes message stream.
        Returns:
        the next byte from the bytes message stream, interpreted as an unsigned 8-bit number
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readShort

        short readShort()
                throws JMSException
        Reads a signed 16-bit number from the bytes message stream.
        Returns:
        the next two bytes from the bytes message stream, interpreted as a signed 16-bit number
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readUnsignedShort

        int readUnsignedShort()
                      throws JMSException
        Reads an unsigned 16-bit number from the bytes message stream.
        Returns:
        the next two bytes from the bytes message stream, interpreted as an unsigned 16-bit integer
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readChar

        char readChar()
              throws JMSException
        Reads a Unicode character value from the bytes message stream.
        Returns:
        the next two bytes from the bytes message stream as a Unicode character
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readInt

        int readInt()
            throws JMSException
        Reads a signed 32-bit integer from the bytes message stream.
        Returns:
        the next four bytes from the bytes message stream, interpreted as an int
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readLong

        long readLong()
              throws JMSException
        Reads a signed 64-bit integer from the bytes message stream.
        Returns:
        the next eight bytes from the bytes message stream, interpreted as a long
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readFloat

        float readFloat()
                throws JMSException
        Reads a float from the bytes message stream.
        Returns:
        the next four bytes from the bytes message stream, interpreted as a float
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readDouble

        double readDouble()
                  throws JMSException
        Reads a double from the bytes message stream.
        Returns:
        the next eight bytes from the bytes message stream, interpreted as a double
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readUTF

        String readUTF()
               throws JMSException
        Reads a string that has been encoded using a modified UTF-8 format from the bytes message stream.

        For more information on the UTF-8 format, see "File System Safe UCS Transformation Format (FSS_UTF)", X/Open Preliminary Specification, X/Open Company Ltd., Document Number: P316. This information also appears in ISO/IEC 10646, Annex P.

        Returns:
        a Unicode string from the bytes message stream
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of bytes stream has been reached.
        MessageNotReadableException - if the message is in write-only mode.

      • readBytes

        int readBytes(byte[] value)
              throws JMSException
        Reads a byte array from the bytes message stream.

        If the length of array value is less than the number of bytes remaining to be read from the stream, the array should be filled. A subsequent call reads the next increment, and so on.

        If the number of bytes remaining in the stream is less than the length of array value, the bytes should be read into the array. The return value of the total number of bytes read will be less than the length of the array, indicating that there are no more bytes left to be read from the stream. The next read of the stream returns -1.

        Parameters:
        value - the buffer into which the data is read
        Returns:
        the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageNotReadableException - if the message is in write-only mode.

      • readBytes

        int readBytes(byte[] value,
            int length)
              throws JMSException
        Reads a portion of the bytes message stream.

        If the length of array value is less than the number of bytes remaining to be read from the stream, the array should be filled. A subsequent call reads the next increment, and so on.

        If the number of bytes remaining in the stream is less than the length of array value, the bytes should be read into the array. The return value of the total number of bytes read will be less than the length of the array, indicating that there are no more bytes left to be read from the stream. The next read of the stream returns -1.

        If length is negative, or length is greater than the length of the array value, then an IndexOutOfBoundsException is thrown. No bytes will be read from the stream for this exception case.

        Parameters:
        value - the buffer into which the data is read
        length - the number of bytes to read; must be less than or equal to value.length
        Returns:
        the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageNotReadableException - if the message is in write-only mode.

      • writeBoolean

        void writeBoolean(boolean value)
                  throws JMSException
        Writes a boolean to the bytes message stream as a 1-byte value. The value true is written as the value (byte)1; the value false is written as the value (byte)0.
        Parameters:
        value - the boolean value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeByte

        void writeByte(byte value)
               throws JMSException
        Writes a byte to the bytes message stream as a 1-byte value.
        Parameters:
        value - the byte value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeShort

        void writeShort(short value)
                throws JMSException
        Writes a short to the bytes message stream as two bytes, high byte first.
        Parameters:
        value - the short to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeChar

        void writeChar(char value)
               throws JMSException
        Writes a char to the bytes message stream as a 2-byte value, high byte first.
        Parameters:
        value - the char value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeInt

        void writeInt(int value)
              throws JMSException
        Writes an int to the bytes message stream as four bytes, high byte first.
        Parameters:
        value - the int to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeLong

        void writeLong(long value)
               throws JMSException
        Writes a long to the bytes message stream as eight bytes, high byte first.
        Parameters:
        value - the long to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeFloat

        void writeFloat(float value)
                throws JMSException
        Converts the float argument to an int using the floatToIntBits method in class Float, and then writes that int value to the bytes message stream as a 4-byte quantity, high byte first.
        Parameters:
        value - the float value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeDouble

        void writeDouble(double value)
                 throws JMSException
        Converts the double argument to a long using the doubleToLongBits method in class Double, and then writes that long value to the bytes message stream as an 8-byte quantity, high byte first.
        Parameters:
        value - the double value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeUTF

        void writeUTF(String value)
              throws JMSException
        Writes a string to the bytes message stream using UTF-8 encoding in a machine-independent manner.

        For more information on the UTF-8 format, see "File System Safe UCS Transformation Format (FSS_UTF)", X/Open Preliminary Specification, X/Open Company Ltd., Document Number: P316. This information also appears in ISO/IEC 10646, Annex P.

        Parameters:
        value - the String value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeBytes

        void writeBytes(byte[] value)
                throws JMSException
        Writes a byte array to the bytes message stream.
        Parameters:
        value - the byte array to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeBytes

        void writeBytes(byte[] value,
              int offset,
              int length)
                throws JMSException
        Writes a portion of a byte array to the bytes message stream.
        Parameters:
        value - the byte array value to be written
        offset - the initial offset within the byte array
        length - the number of bytes to use
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeObject

        void writeObject(Object value)
                 throws JMSException
        Writes an object to the bytes message stream.

        This method works only for the objectified primitive object types (Integer, Double, Long ...), String objects, and byte arrays.

        Parameters:
        value - the object in the Java programming language ("Java object") to be written; it must not be null
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageFormatException - if the object is of an invalid type.
        MessageNotWriteableException - if the message is in read-only mode.
        NullPointerException - if the parameter value is null.

      • reset

        void reset()
           throws JMSException
        Puts the message body in read-only mode and repositions the stream of bytes to the beginning.
        Throws:
        JMSException - if the JMS provider fails to reset the message due to some internal error.
        MessageFormatException - if the message has an invalid format.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CompletionListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface CompletionListener

  • public interface CompletionListener
    A CompletionListener is implemented by the application and may be specified when a message is sent asynchronously.

    When the sending of the message is complete, the JMS provider notifies the application by calling the onCompletion(Message) method of the specified completion listener. If the sending if the message fails for any reason, and an exception cannot be thrown by the send method, then the JMS provider calls the onException(Exception) method of the specified completion listener.

    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    MessageProducer.send(javax.jms.Message,int,int,long,javax.jms.CompletionListener),
MessageProducer.send(javax.jms.Destination,javax.jms.Message,javax.jms.CompletionListener),
MessageProducer.send(javax.jms.Destination,javax.jms.Message,int,int,long,javax.jms.CompletionListener),
JMSProducer.setAsync(javax.jms.CompletionListener),
JMSProducer.getAsync()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onCompletion(Message message)
      Notifies the application that the message has been successfully sent
      void onException(Message message, Exception exception)
      Notifies user that the specified exception was thrown while attempting to send the specified message.

    • Method Detail

      • onCompletion

        void onCompletion(Message message)
        Notifies the application that the message has been successfully sent
        Parameters:
        message - the message that was sent.

      • onException

        void onException(Message message,
               Exception exception)
        Notifies user that the specified exception was thrown while attempting to send the specified message. If an exception occurs it is undefined whether or not the message was successfully sent.
        Parameters:
        message - the message that was sent.
        exception - the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Connection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface Connection

  • All Superinterfaces:
    AutoCloseable
    All Known Subinterfaces:
    QueueConnection, TopicConnection, XAConnection, XAQueueConnection, XATopicConnection

    public interface Connection
extends AutoCloseable
    A Connection object is a client's active connection to its JMS provider. It typically allocates provider resources outside the Java virtual machine (JVM).

    Connections support concurrent use.

    A connection serves several purposes:

    • It encapsulates an open connection with a JMS provider. It typically represents an open TCP/IP socket between a client and the service provider software.
    • Its creation is where client authentication takes place.
    • It can specify a unique client identifier.
    • It provides a ConnectionMetaData object.
    • It supports an optional ExceptionListener object.

    Because the creation of a connection involves setting up authentication and communication, a connection is a relatively heavyweight object. Most clients will do all their messaging with a single connection. Other more advanced applications may use several connections. The JMS API does not architect a reason for using multiple connections; however, there may be operational reasons for doing so.

    A JMS client typically creates a connection, one or more sessions, and a number of message producers and consumers. When a connection is created, it is in stopped mode. That means that no messages are being delivered.

    It is typical to leave the connection in stopped mode until setup is complete (that is, until all message consumers have been created). At that point, the client calls the connection's start method, and messages begin arriving at the connection's consumers. This setup convention minimizes any client confusion that may result from asynchronous message delivery while the client is still in the process of setting itself up.

    A connection can be started immediately, and the setup can be done afterwards. Clients that do this must be prepared to handle asynchronous message delivery while they are still in the process of setting up.

    A message producer can send messages while a connection is stopped.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    ConnectionFactory, QueueConnection, TopicConnection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes the connection.
      ConnectionConsumer createConnectionConsumer(Destination destination, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific destination.
      ConnectionConsumer createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using an unshared durable subscription with the specified name.
      Session createSession()
      Creates a Session object, specifying no arguments.
      Session createSession(boolean transacted, int acknowledgeMode)
      Creates a Session object, specifying transacted and acknowledgeMode.
      Session createSession(int sessionMode)
      Creates a Session object, specifying sessionMode.
      ConnectionConsumer createSharedConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using a shared non-durable subscription with the specified name.
      ConnectionConsumer createSharedDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using a shared durable subscription with the specified name.
      String getClientID()
      Gets the client identifier for this connection.
      ExceptionListener getExceptionListener()
      Gets the ExceptionListener object for this connection.
      ConnectionMetaData getMetaData()
      Gets the metadata for this connection.
      void setClientID(String clientID)
      Sets the client identifier for this connection.
      void setExceptionListener(ExceptionListener listener)
      Sets an exception listener for this connection.
      void start()
      Starts (or restarts) a connection's delivery of incoming messages.
      void stop()
      Temporarily stops a connection's delivery of incoming messages.

    • Method Detail

      • createSession

        Session createSession(boolean transacted,
                    int acknowledgeMode)
                      throws JMSException
        Creates a Session object, specifying transacted and acknowledgeMode.

        This method has been superseded by the method createSession(int sessionMode) which specifies the same information using a single argument, and by the method createSession() which is for use in a Java EE JTA transaction. Applications should consider using those methods instead of this one.

        The effect of setting the transacted and acknowledgeMode arguments depends on whether this method is called in a Java SE environment, in the Java EE application client container, or in the Java EE web or EJB container. If this method is called in the Java EE web or EJB container then the effect of setting the transacted} and acknowledgeMode arguments also depends on whether or not there is an active JTA transaction in progress.

        In a Java SE environment or in the Java EE application client container:

        • If transacted is set to true then the session will use a local transaction which may subsequently be committed or rolled back by calling the session's commit or rollback methods. The argument acknowledgeMode is ignored.
        • If transacted is set to false then the session will be non-transacted. In this case the argument acknowledgeMode is used to specify how messages received by this session will be acknowledged. The permitted values are Session.CLIENT_ACKNOWLEDGE, Session.AUTO_ACKNOWLEDGE and Session.DUPS_OK_ACKNOWLEDGE. For a definition of the meaning of these acknowledgement modes see the links below.

        In a Java EE web or EJB container, when there is an active JTA transaction in progress:

        • Both arguments transacted and acknowledgeMode are ignored. The session will participate in the JTA transaction and will be committed or rolled back when that transaction is committed or rolled back, not by calling the session's commit or rollback methods. Since both arguments are ignored, developers are recommended to use createSession(), which has no arguments, instead of this method.

        In the Java EE web or EJB container, when there is no active JTA transaction in progress:

        • The argument transacted is ignored. The session will always be non-transacted, using one of the two acknowledgement modes AUTO_ACKNOWLEDGE and DUPS_OK_ACKNOWLEDGE.
        • The argument acknowledgeMode is used to specify how messages received by this session will be acknowledged. The only permitted values in this case are Session.AUTO_ACKNOWLEDGE and Session.DUPS_OK_ACKNOWLEDGE. The value Session.CLIENT_ACKNOWLEDGE may not be used. For a definition of the meaning of these acknowledgement modes see the links below.

        Applications running in the Java EE web and EJB containers must not attempt to create more than one active (not closed) Session object per connection. If this method is called in a Java EE web or EJB container when an active Session object already exists for this connection then a JMSException will be thrown.

        Parameters:
        transacted - indicates whether the session will use a local transaction. If this method is called in the Java EE web or EJB container then this argument is ignored.
        acknowledgeMode - indicates how messages received by the session will be acknowledged.
        • If this method is called in a Java SE environment or in the Java EE application client container, the permitted values are Session.CLIENT_ACKNOWLEDGE, Session.AUTO_ACKNOWLEDGE and Session.DUPS_OK_ACKNOWLEDGE.
        • If this method is called in the Java EE web or EJB container when there is an active JTA transaction in progress then this argument is ignored.
        • If this method is called in the Java EE web or EJB container when there is no active JTA transaction in progress, the permitted values are Session.AUTO_ACKNOWLEDGE and Session.DUPS_OK_ACKNOWLEDGE. In this case Session.CLIENT_ACKNOWLEDGE is not permitted.
        Returns:
        a newly created session
        Throws:
        JMSException - if the Connection object fails to create a session due to
        • some internal error,
        • lack of support for the specific transaction and acknowledgement mode, or
        • because this method is being called in a Java EE web or EJB application and an active session already exists for this connection.
        Since:
        JMS 1.1
        See Also:
        Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE, createSession(int), createSession()

      • createSession

        Session createSession(int sessionMode)
                      throws JMSException
        Creates a Session object, specifying sessionMode.

        The effect of setting the sessionMode argument depends on whether this method is called in a Java SE environment, in the Java EE application client container, or in the Java EE web or EJB container. If this method is called in the Java EE web or EJB container then the effect of setting the sessionMode argument also depends on whether or not there is an active JTA transaction in progress.

        In a Java SE environment or in the Java EE application client container:

        • If sessionMode is set to Session.SESSION_TRANSACTED then the session will use a local transaction which may subsequently be committed or rolled back by calling the session's commit or rollback methods.
        • If sessionMode is set to any of Session.CLIENT_ACKNOWLEDGE, Session.AUTO_ACKNOWLEDGE or Session.DUPS_OK_ACKNOWLEDGE. then the session will be non-transacted and messages received by this session will be acknowledged according to the value of sessionMode. For a definition of the meaning of these acknowledgement modes see the links below.

        In a Java EE web or EJB container, when there is an active JTA transaction in progress:

        • The argument sessionMode is ignored. The session will participate in the JTA transaction and will be committed or rolled back when that transaction is committed or rolled back, not by calling the session's commit or rollback methods. Since the argument is ignored, developers are recommended to use createSession(), which has no arguments, instead of this method.

        In the Java EE web or EJB container, when there is no active JTA transaction in progress:

        • The argument acknowledgeMode must be set to either of Session.AUTO_ACKNOWLEDGE or Session.DUPS_OK_ACKNOWLEDGE. The session will be non-transacted and messages received by this session will be acknowledged automatically according to the value of acknowledgeMode. For a definition of the meaning of these acknowledgement modes see the links below. The values Session.SESSION_TRANSACTED and Session.CLIENT_ACKNOWLEDGE may not be used.

        Applications running in the Java EE web and EJB containers must not attempt to create more than one active (not closed) Session object per connection. If this method is called in a Java EE web or EJB container when an active Session object already exists for this connection then a JMSException will be thrown.

        Parameters:
        sessionMode - indicates which of four possible session modes will be used.
        • If this method is called in a Java SE environment or in the Java EE application client container, the permitted values are Session.SESSION_TRANSACTED, Session.CLIENT_ACKNOWLEDGE, Session.AUTO_ACKNOWLEDGE and Session.DUPS_OK_ACKNOWLEDGE.
        • If this method is called in the Java EE web or EJB container when there is an active JTA transaction in progress then this argument is ignored.
        • If this method is called in the Java EE web or EJB container when there is no active JTA transaction in progress, the permitted values are Session.AUTO_ACKNOWLEDGE and Session.DUPS_OK_ACKNOWLEDGE. In this case the values Session.TRANSACTED and Session.CLIENT_ACKNOWLEDGE are not permitted.
        Returns:
        a newly created session
        Throws:
        JMSException - if the Connection object fails to create a session due to
        • some internal error,
        • lack of support for the specific transaction and acknowledgement mode, or
        • because this method is being called in a Java EE web or EJB application and an active session already exists for this connection.
        Since:
        JMS 2.0
        See Also:
        Session.SESSION_TRANSACTED, Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE, createSession(boolean, int), createSession()

      • createSession

        Session createSession()
                      throws JMSException
        Creates a Session object, specifying no arguments.

        The behaviour of the session that is created depends on whether this method is called in a Java SE environment, in the Java EE application client container, or in the Java EE web or EJB container. If this method is called in the Java EE web or EJB container then the behaviour of the session also depends on whether or not there is an active JTA transaction in progress.

        In a Java SE environment or in the Java EE application client container:

        • The session will be non-transacted and received messages will be acknowledged automatically using an acknowledgement mode of Session.AUTO_ACKNOWLEDGE For a definition of the meaning of this acknowledgement mode see the link below.

        In a Java EE web or EJB container, when there is an active JTA transaction in progress:

        • The session will participate in the JTA transaction and will be committed or rolled back when that transaction is committed or rolled back, not by calling the session's commit or rollback methods.

        In the Java EE web or EJB container, when there is no active JTA transaction in progress:

        • The session will be non-transacted and received messages will be acknowledged automatically using an acknowledgement mode of Session.AUTO_ACKNOWLEDGE For a definition of the meaning of this acknowledgement mode see the link below.

        Applications running in the Java EE web and EJB containers must not attempt to create more than one active (not closed) Session object per connection. If this method is called in a Java EE web or EJB container when an active Session object already exists for this connection then a JMSException will be thrown.

        Returns:
        a newly created session
        Throws:
        JMSException - if the Connection object fails to create a session due to
        • some internal error or
        • because this method is being called in a Java EE web or EJB application and an active session already exists for this connection.
        Since:
        JMS 2.0
        See Also:
        Session.AUTO_ACKNOWLEDGE, createSession(boolean, int), createSession(int)

      • getClientID

        String getClientID()
                   throws JMSException
        Gets the client identifier for this connection.

        This value is specific to the JMS provider. It is either preconfigured by an administrator in a ConnectionFactory object or assigned dynamically by the application by calling the setClientID method.

        Returns:
        the unique client identifier
        Throws:
        JMSException - if the JMS provider fails to return the client ID for this connection due to some internal error.

      • setClientID

        void setClientID(String clientID)
                 throws JMSException
        Sets the client identifier for this connection.

        The preferred way to assign a JMS client's client identifier is for it to be configured in a client-specific ConnectionFactory object and transparently assigned to the Connection object it creates.

        Alternatively, a client can set a connection's client identifier using a provider-specific value. The facility to set a connection's client identifier explicitly is not a mechanism for overriding the identifier that has been administratively configured. It is provided for the case where no administratively specified identifier exists. If one does exist, an attempt to change it by setting it must throw an IllegalStateException. If a client sets the client identifier explicitly, it must do so immediately after it creates the connection and before any other action on the connection is taken. After this point, setting the client identifier is a programming error that should throw an IllegalStateException.

        The purpose of the client identifier is to associate a connection and its objects with a state maintained on behalf of the client by a provider. The only such state identified by the JMS API is that required to support durable subscriptions.

        If another connection with the same clientID is already running when this method is called, the JMS provider should detect the duplicate ID and throw an InvalidClientIDException.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Parameters:
        clientID - the unique client identifier
        Throws:
        JMSException - if the JMS provider fails to set the client ID for the the connection for one of the following reasons:
        • an internal error has occurred or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        InvalidClientIDException - if the JMS client specifies an invalid or duplicate client ID.
        IllegalStateException - if the JMS client attempts to set a connection's client ID at the wrong time or when it has been administratively configured.

      • getMetaData

        ConnectionMetaData getMetaData()
                               throws JMSException
        Gets the metadata for this connection.
        Returns:
        the connection metadata
        Throws:
        JMSException - if the JMS provider fails to get the connection metadata for this connection.
        See Also:
        ConnectionMetaData

      • getExceptionListener

        ExceptionListener getExceptionListener()
                                       throws JMSException
        Gets the ExceptionListener object for this connection. Not every Connection has an ExceptionListener associated with it.
        Returns:
        the ExceptionListener for this connection, or null. if no ExceptionListener is associated with this connection.
        Throws:
        JMSException - if the JMS provider fails to get the ExceptionListener for this connection.
        See Also:
        setExceptionListener(javax.jms.ExceptionListener)

      • setExceptionListener

        void setExceptionListener(ExceptionListener listener)
                          throws JMSException
        Sets an exception listener for this connection.

        If a JMS provider detects a serious problem with a connection, it informs the connection's ExceptionListener, if one has been registered. It does this by calling the listener's onException method, passing it a JMSException object describing the problem.

        An exception listener allows a client to be notified of a problem asynchronously. Some connections only consume messages, so they would have no other way to learn their connection has failed.

        A connection serializes execution of its ExceptionListener.

        A JMS provider should attempt to resolve connection problems itself before it notifies the client of them.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Parameters:
        listener - the exception listener
        Throws:
        JMSException - if the JMS provider fails to set the exception listener for one of the following reasons:
        • an internal error has occurred or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)

      • start

        void start()
           throws JMSException
        Starts (or restarts) a connection's delivery of incoming messages. A call to start on a connection that has already been started is ignored.
        Throws:
        JMSException - if the JMS provider fails to start message delivery due to some internal error.
        See Also:
        stop()

      • stop

        void stop()
          throws JMSException
        Temporarily stops a connection's delivery of incoming messages. Delivery can be restarted using the connection's start method. When the connection is stopped, delivery to all the connection's message consumers is inhibited: synchronous receives block, and messages are not delivered to message listeners.

        This call blocks until receives and/or message listeners in progress have completed.

        Stopping a connection has no effect on its ability to send messages. A call to stop on a connection that has already been stopped is ignored.

        A call to stop must not return until delivery of messages has paused. This means that a client can rely on the fact that none of its message listeners will be called and that all threads of control waiting for receive calls to return will not return with a message until the connection is restarted. The receive timers for a stopped connection continue to advance, so receives may time out while the connection is stopped.

        If message listeners are running when stop is invoked, the stop call must wait until all of them have returned before it may return. While these message listeners are completing, they must have the full services of the connection available to them.

        A message listener must not attempt to stop its own connection as this would lead to deadlock. The JMS provider must detect this and throw a IllegalStateException.

        For the avoidance of doubt, if an exception listener for this connection is running when stop is invoked, there is no requirement for the stop call to wait until the exception listener has returned before it may return.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Throws:
        IllegalStateException - this method has been called by a MessageListener on its own Connection
        JMSException - if the JMS provider fails to stop message delivery for one of the following reasons:
        • an internal error has occurred or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        See Also:
        start()

      • close

        void close()
           throws JMSException
        Closes the connection.

        Since a provider typically allocates significant resources outside the JVM on behalf of a connection, clients should close these resources when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

        There is no need to close the sessions, producers, and consumers of a closed connection.

        Closing a connection causes all temporary destinations to be deleted.

        When this method is invoked, it should not return until message processing has been shut down in an orderly fashion. This means that all message listeners that may have been running have returned, and that all pending receives have returned. A close terminates all pending message receives on the connection's sessions' consumers. The receives may return with a message or with null, depending on whether there was a message available at the time of the close. If one or more of the connection's sessions' message listeners is processing a message at the time when connection close is invoked, all the facilities of the connection and its sessions must remain available to those listeners until they return control to the JMS provider.

        This method must not return until any incomplete asynchronous send operations for this Connection have been completed and any CompletionListener callbacks have returned. Incomplete sends should be allowed to complete normally unless an error occurs.

        For the avoidance of doubt, if an exception listener for this connection is running when close is invoked, there is no requirement for the close call to wait until the exception listener has returned before it may return.

        Closing a connection causes any of its sessions' transactions in progress to be rolled back. In the case where a session's work is coordinated by an external transaction manager, a session's commit and rollback methods are not used and the result of a closed session's work is determined later by the transaction manager. Closing a connection does NOT force an acknowledgment of client-acknowledged sessions.

        A message listener must not attempt to close its own connection as this would lead to deadlock. The JMS provider must detect this and throw a IllegalStateException.

        A CompletionListener callback method must not call close on its own Connection. Doing so will cause an IllegalStateException to be thrown.

        Invoking the acknowledge method of a received message from a closed connection's session must throw an IllegalStateException. Closing a closed connection must NOT throw an exception.

        Specified by:
        close in interface AutoCloseable
        Throws:
        IllegalStateException -
        • this method has been called by a MessageListener on its own Connection
        • this method has been called by a CompletionListener callback method on its own Connection
        JMSException - if the JMS provider fails to close the connection due to some internal error. For example, a failure to release resources or to close a socket connection can cause this exception to be thrown.

      • createConnectionConsumer

        ConnectionConsumer createConnectionConsumer(Destination destination,
                                          String messageSelector,
                                          ServerSessionPool sessionPool,
                                          int maxMessages)
                                            throws JMSException
        Creates a connection consumer for this connection (optional operation) on the specific destination.

        This is an expert facility not used by ordinary JMS clients.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Parameters:
        destination - the destination to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        sessionPool - the server session pool to associate with this connection consumer
        maxMessages - the maximum number of messages that can be assigned to a server session at one time
        Returns:
        the connection consumer
        Throws:
        InvalidDestinationException - if an invalid destination is specified.
        InvalidSelectorException - if the message selector is invalid.
        JMSException - if the Connection object fails to create a connection consumer for one of the following reasons:
        • an internal error has occurred
        • invalid arguments for sessionPool and messageSelector or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        Since:
        JMS 1.1
        See Also:
        ConnectionConsumer

      • createSharedConnectionConsumer

        ConnectionConsumer createSharedConnectionConsumer(Topic topic,
                                                String subscriptionName,
                                                String messageSelector,
                                                ServerSessionPool sessionPool,
                                                int maxMessages)
                                                  throws JMSException
        Creates a connection consumer for this connection (optional operation) on the specific topic using a shared non-durable subscription with the specified name.

        This is an expert facility not used by ordinary JMS clients.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Parameters:
        topic - the topic to access
        subscriptionName - the name used to identify the shared non-durable subscription
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        sessionPool - the server session pool to associate with this connection consumer
        maxMessages - the maximum number of messages that can be assigned to a server session at one time
        Returns:
        the connection consumer
        Throws:
        IllegalStateException - if called on a QueueConnection
        InvalidDestinationException - if an invalid destination is specified.
        InvalidSelectorException - if the message selector is invalid.
        JMSException - if the Connection object fails to create a connection consumer for one of the following reasons:
        • an internal error has occurred
        • invalid arguments for sessionPool and messageSelector or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        Since:
        JMS 2.0
        See Also:
        ConnectionConsumer

      • createDurableConnectionConsumer

        ConnectionConsumer createDurableConnectionConsumer(Topic topic,
                                                 String subscriptionName,
                                                 String messageSelector,
                                                 ServerSessionPool sessionPool,
                                                 int maxMessages)
                                                   throws JMSException
        Creates a connection consumer for this connection (optional operation) on the specific topic using an unshared durable subscription with the specified name.

        This is an expert facility not used by ordinary JMS clients.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Parameters:
        topic - topic to access
        subscriptionName - the name used to identify the unshared durable subscription
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        sessionPool - the server session pool to associate with this durable connection consumer
        maxMessages - the maximum number of messages that can be assigned to a server session at one time
        Returns:
        the durable connection consumer
        Throws:
        IllegalStateException - if called on a QueueConnection
        InvalidDestinationException - if an invalid destination is specified.
        InvalidSelectorException - if the message selector is invalid.
        JMSException - if the Connection object fails to create a connection consumer for one of the following reasons:
        • an internal error has occurred
        • invalid arguments for sessionPool and messageSelector or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        Since:
        JMS 1.1
        See Also:
        ConnectionConsumer

      • createSharedDurableConnectionConsumer

        ConnectionConsumer createSharedDurableConnectionConsumer(Topic topic,
                                                       String subscriptionName,
                                                       String messageSelector,
                                                       ServerSessionPool sessionPool,
                                                       int maxMessages)
                                                         throws JMSException
        Creates a connection consumer for this connection (optional operation) on the specific topic using a shared durable subscription with the specified name.

        This is an expert facility not used by ordinary JMS clients.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Parameters:
        topic - topic to access
        subscriptionName - the name used to identify the shared durable subscription
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        sessionPool - the server session pool to associate with this durable connection consumer
        maxMessages - the maximum number of messages that can be assigned to a server session at one time
        Returns:
        the durable connection consumer
        Throws:
        IllegalStateException - if called on a QueueConnection
        InvalidDestinationException - if an invalid destination is specified.
        InvalidSelectorException - if the message selector is invalid.
        JMSException - if the Connection object fails to create a connection consumer for one of the following reasons:
        • an internal error has occurred
        • invalid arguments for sessionPool and messageSelector or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        Since:
        JMS 2.0
        See Also:
        ConnectionConsumer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionConsumer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface ConnectionConsumer

  • public interface ConnectionConsumer
    For application servers, Connection objects provide a special facility for creating a ConnectionConsumer (optional). The messages it is to consume are specified by a Destination and a message selector. In addition, a ConnectionConsumer must be given a ServerSessionPool to use for processing its messages.

    Normally, when traffic is light, a ConnectionConsumer gets a ServerSession from its pool, loads it with a single message, and starts it. As traffic picks up, messages can back up. If this happens, a ConnectionConsumer can load each ServerSession with more than one message. This reduces the thread context switches and minimizes resource use at the expense of some serialization of message processing.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Connection.createConnectionConsumer(javax.jms.Destination, java.lang.String, javax.jms.ServerSessionPool, int),
Connection.createDurableConnectionConsumer(javax.jms.Topic, java.lang.String, java.lang.String, javax.jms.ServerSessionPool, int),
QueueConnection.createConnectionConsumer(javax.jms.Queue, java.lang.String, javax.jms.ServerSessionPool, int),
TopicConnection.createConnectionConsumer(javax.jms.Topic, java.lang.String, javax.jms.ServerSessionPool, int),
TopicConnection.createDurableConnectionConsumer(javax.jms.Topic, java.lang.String, java.lang.String, javax.jms.ServerSessionPool, int)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes the connection consumer.
      ServerSessionPool getServerSessionPool()
      Gets the server session pool associated with this connection consumer.

    • Method Detail

      • getServerSessionPool

        ServerSessionPool getServerSessionPool()
                                       throws JMSException
        Gets the server session pool associated with this connection consumer.
        Returns:
        the server session pool used by this connection consumer
        Throws:
        JMSException - if the JMS provider fails to get the server session pool associated with this consumer due to some internal error.

      • close

        void close()
           throws JMSException
        Closes the connection consumer.

        Since a provider may allocate some resources on behalf of a connection consumer outside the Java virtual machine, clients should close these resources when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

        Throws:
        JMSException - if the JMS provider fails to release resources on behalf of the connection consumer or fails to close the connection consumer.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface ConnectionFactory

  • All Known Subinterfaces:
    QueueConnectionFactory, TopicConnectionFactory, XAQueueConnectionFactory, XATopicConnectionFactory

    public interface ConnectionFactory
    A ConnectionFactory object encapsulates a set of connection configuration parameters that has been defined by an administrator. A client uses it to create a connection with a JMS provider.

    A ConnectionFactory object is a JMS administered object and supports concurrent use.

    JMS administered objects are objects containing configuration information that are created by an administrator and later used by JMS clients. They make it practical to administer the JMS API in the enterprise.

    Although the interfaces for administered objects do not explicitly depend on the Java Naming and Directory Interface (JNDI) API, the JMS API establishes the convention that JMS clients find administered objects by looking them up in a JNDI namespace.

    An administrator can place an administered object anywhere in a namespace. The JMS API does not define a naming policy.

    It is expected that JMS providers will provide the tools an administrator needs to create and configure administered objects in a JNDI namespace. JMS provider implementations of administered objects should be both javax.jndi.Referenceable and java.io.Serializable so that they can be stored in all JNDI naming contexts. In addition, it is recommended that these implementations follow the JavaBeansTM design patterns.

    This strategy provides several benefits:

    • It hides provider-specific details from JMS clients.
    • It abstracts administrative information into objects in the Java programming language ("Java objects") that are easily organized and administered from a common management console.
    • Since there will be JNDI providers for all popular naming services, this means that JMS providers can deliver one implementation of administered objects that will run everywhere.

    An administered object should not hold on to any remote resources. Its lookup should not use remote resources other than those used by the JNDI API itself.

    Clients should think of administered objects as local Java objects. Looking them up should not have any hidden side effects or use surprising amounts of local resources.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Connection, QueueConnectionFactory, TopicConnectionFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Connection createConnection()
      Creates a connection with the default user identity.
      Connection createConnection(String userName, String password)
      Creates a connection with the specified user identity.
      JMSContext createContext()
      Creates a JMSContext with the default user identity and an unspecified sessionMode.
      JMSContext createContext(int sessionMode)
      Creates a JMSContext with the default user identity and the specified session mode.
      JMSContext createContext(String userName, String password)
      Creates a JMSContext with the specified user identity and an unspecified sessionMode.
      JMSContext createContext(String userName, String password, int sessionMode)
      Creates a JMSContext with the specified user identity and the specified session mode.

    • Method Detail

      • createConnection

        Connection createConnection()
                            throws JMSException
        Creates a connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Returns:
        a newly created connection
        Throws:
        JMSException - if the JMS provider fails to create the connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.
        Since:
        JMS 1.1

      • createConnection

        Connection createConnection(String userName,
                          String password)
                            throws JMSException
        Creates a connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Parameters:
        userName - the caller's user name
        password - the caller's password
        Returns:
        a newly created connection
        Throws:
        JMSException - if the JMS provider fails to create the connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.
        Since:
        JMS 1.1

      • createContext

        JMSContext createContext()
        Creates a JMSContext with the default user identity and an unspecified sessionMode.

        A connection and session are created for use by the new JMSContext. The connection is created in stopped mode but will be automatically started when a JMSConsumer is created.

        The behaviour of the session that is created depends on whether this method is called in a Java SE environment, in the Java EE application client container, or in the Java EE web or EJB container. If this method is called in the Java EE web or EJB container then the behaviour of the session also depends on whether or not there is an active JTA transaction in progress.

        In a Java SE environment or in the Java EE application client container:

        • The session will be non-transacted and received messages will be acknowledged automatically using an acknowledgement mode of JMSContext.AUTO_ACKNOWLEDGE For a definition of the meaning of this acknowledgement mode see the link below.

        In a Java EE web or EJB container, when there is an active JTA transaction in progress:

        • The session will participate in the JTA transaction and will be committed or rolled back when that transaction is committed or rolled back, not by calling the JMSContext's commit or rollback methods.

        In the Java EE web or EJB container, when there is no active JTA transaction in progress:

        • The session will be non-transacted and received messages will be acknowledged automatically using an acknowledgement mode of JMSContext.AUTO_ACKNOWLEDGE For a definition of the meaning of this acknowledgement mode see the link below.
        Returns:
        a newly created JMSContext
        Throws:
        JMSRuntimeException - if the JMS provider fails to create the JMSContext due to some internal error.
        JMSSecurityRuntimeException - if client authentication fails due to an invalid user name or password.
        Since:
        JMS 2.0
        See Also:
        JMSContext.AUTO_ACKNOWLEDGE,
createContext(int),
createContext(java.lang.String, java.lang.String),
createContext(java.lang.String, java.lang.String, int),
JMSContext.createContext(int)

      • createContext

        JMSContext createContext(String userName,
                       String password)
        Creates a JMSContext with the specified user identity and an unspecified sessionMode.

        A connection and session are created for use by the new JMSContext. The connection is created in stopped mode but will be automatically started when a JMSConsumer.

        The behaviour of the session that is created depends on whether this method is called in a Java SE environment, in the Java EE application client container, or in the Java EE web or EJB container. If this method is called in the Java EE web or EJB container then the behaviour of the session also depends on whether or not there is an active JTA transaction in progress.

        In a Java SE environment or in the Java EE application client container:

        • The session will be non-transacted and received messages will be acknowledged automatically using an acknowledgement mode of JMSContext.AUTO_ACKNOWLEDGE For a definition of the meaning of this acknowledgement mode see the link below.

        In a Java EE web or EJB container, when there is an active JTA transaction in progress:

        • The session will participate in the JTA transaction and will be committed or rolled back when that transaction is committed or rolled back, not by calling the JMSContext's commit or rollback methods.

        In the Java EE web or EJB container, when there is no active JTA transaction in progress:

        • The session will be non-transacted and received messages will be acknowledged automatically using an acknowledgement mode of JMSContext.AUTO_ACKNOWLEDGE For a definition of the meaning of this acknowledgement mode see the link below.
        Parameters:
        userName - the caller's user name
        password - the caller's password
        Returns:
        a newly created JMSContext
        Throws:
        JMSRuntimeException - if the JMS provider fails to create the JMSContext due to some internal error.
        JMSSecurityRuntimeException - if client authentication fails due to an invalid user name or password.
        Since:
        JMS 2.0
        See Also:
        JMSContext.AUTO_ACKNOWLEDGE, createContext(), createContext(int), createContext(java.lang.String, java.lang.String, int), JMSContext.createContext(int)

      • createContext

        JMSContext createContext(String userName,
                       String password,
                       int sessionMode)
        Creates a JMSContext with the specified user identity and the specified session mode.

        A connection and session are created for use by the new JMSContext. The JMSContext is created in stopped mode but will be automatically started when a JMSConsumer is created.

        The effect of setting the sessionMode argument depends on whether this method is called in a Java SE environment, in the Java EE application client container, or in the Java EE web or EJB container. If this method is called in the Java EE web or EJB container then the effect of setting the sessionMode argument also depends on whether or not there is an active JTA transaction in progress.

        In a Java SE environment or in the Java EE application client container:

        • If sessionMode is set to JMSContext.SESSION_TRANSACTED then the session will use a local transaction which may subsequently be committed or rolled back by calling the JMSContext's commit or rollback methods.
        • If sessionMode is set to any of JMSContext.CLIENT_ACKNOWLEDGE, JMSContext.AUTO_ACKNOWLEDGE or JMSContext.DUPS_OK_ACKNOWLEDGE. then the session will be non-transacted and messages received by this session will be acknowledged according to the value of sessionMode. For a definition of the meaning of these acknowledgement modes see the links below.

        In a Java EE web or EJB container, when there is an active JTA transaction in progress:

        • The argument sessionMode is ignored. The session will participate in the JTA transaction and will be committed or rolled back when that transaction is committed or rolled back, not by calling the JMSContext's commit or rollback methods. Since the argument is ignored, developers are recommended to use createSession(), which has no arguments, instead of this method.

        In the Java EE web or EJB container, when there is no active JTA transaction in progress:

        • The argument acknowledgeMode must be set to either of JMSContext.AUTO_ACKNOWLEDGE or JMSContext.DUPS_OK_ACKNOWLEDGE. The session will be non-transacted and messages received by this session will be acknowledged automatically according to the value of acknowledgeMode. For a definition of the meaning of these acknowledgement modes see the links below. The values JMSContext.SESSION_TRANSACTED and JMSContext.CLIENT_ACKNOWLEDGE may not be used.
        Parameters:
        userName - the caller's user name
        password - the caller's password
        sessionMode - indicates which of four possible session modes will be used.
        • If this method is called in a Java SE environment or in the Java EE application client container, the permitted values are JMSContext.SESSION_TRANSACTED, JMSContext.CLIENT_ACKNOWLEDGE, JMSContext.AUTO_ACKNOWLEDGE and JMSContext.DUPS_OK_ACKNOWLEDGE.
        • If this method is called in the Java EE web or EJB container when there is an active JTA transaction in progress then this argument is ignored.
        • If this method is called in the Java EE web or EJB container when there is no active JTA transaction in progress, the permitted values are JMSContext.AUTO_ACKNOWLEDGE and JMSContext.DUPS_OK_ACKNOWLEDGE. In this case the values JMSContext.TRANSACTED and JMSContext.CLIENT_ACKNOWLEDGE are not permitted.
        Returns:
        a newly created JMSContext
        Throws:
        JMSRuntimeException - if the JMS provider fails to create the JMSContext due to some internal error.
        JMSSecurityRuntimeException - if client authentication fails due to an invalid user name or password.
        Since:
        JMS 2.0
        See Also:
        JMSContext.SESSION_TRANSACTED, JMSContext.CLIENT_ACKNOWLEDGE, JMSContext.AUTO_ACKNOWLEDGE, JMSContext.DUPS_OK_ACKNOWLEDGE, createContext(), createContext(int), createContext(java.lang.String, java.lang.String), JMSContext.createContext(int)

      • createContext

        JMSContext createContext(int sessionMode)
        Creates a JMSContext with the default user identity and the specified session mode.

        A connection and session are created for use by the new JMSContext. The JMSContext is created in stopped mode but will be automatically started when a JMSConsumer is created.

        The effect of setting the sessionMode argument depends on whether this method is called in a Java SE environment, in the Java EE application client container, or in the Java EE web or EJB container. If this method is called in the Java EE web or EJB container then the effect of setting the sessionMode argument also depends on whether or not there is an active JTA transaction in progress.

        In a Java SE environment or in the Java EE application client container:

        • If sessionMode is set to JMSContext.SESSION_TRANSACTED then the session will use a local transaction which may subsequently be committed or rolled back by calling the JMSContext's commit or rollback methods.
        • If sessionMode is set to any of JMSContext.CLIENT_ACKNOWLEDGE, JMSContext.AUTO_ACKNOWLEDGE or JMSContext.DUPS_OK_ACKNOWLEDGE. then the session will be non-transacted and messages received by this session will be acknowledged according to the value of sessionMode. For a definition of the meaning of these acknowledgement modes see the links below.

        In a Java EE web or EJB container, when there is an active JTA transaction in progress:

        • The argument sessionMode is ignored. The session will participate in the JTA transaction and will be committed or rolled back when that transaction is committed or rolled back, not by calling the JMSContext's commit or rollback methods. Since the argument is ignored, developers are recommended to use createSession(), which has no arguments, instead of this method.

        In the Java EE web or EJB container, when there is no active JTA transaction in progress:

        • The argument acknowledgeMode must be set to either of JMSContext.AUTO_ACKNOWLEDGE or JMSContext.DUPS_OK_ACKNOWLEDGE. The session will be non-transacted and messages received by this session will be acknowledged automatically according to the value of acknowledgeMode. For a definition of the meaning of these acknowledgement modes see the links below. The values JMSContext.SESSION_TRANSACTED and JMSContext.CLIENT_ACKNOWLEDGE may not be used.
        Parameters:
        sessionMode - indicates which of four possible session modes will be used.
        • If this method is called in a Java SE environment or in the Java EE application client container, the permitted values are JMSContext.SESSION_TRANSACTED, JMSContext.CLIENT_ACKNOWLEDGE, JMSContext.AUTO_ACKNOWLEDGE and JMSContext.DUPS_OK_ACKNOWLEDGE.
        • If this method is called in the Java EE web or EJB container when there is an active JTA transaction in progress then this argument is ignored.
        • If this method is called in the Java EE web or EJB container when there is no active JTA transaction in progress, the permitted values are JMSContext.AUTO_ACKNOWLEDGE and JMSContext.DUPS_OK_ACKNOWLEDGE. In this case the values JMSContext.TRANSACTED and JMSContext.CLIENT_ACKNOWLEDGE are not permitted.
        Returns:
        a newly created JMSContext
        Throws:
        JMSRuntimeException - if the JMS provider fails to create the JMSContext due to some internal error.
        JMSSecurityRuntimeException - if client authentication fails due to an invalid user name or password.
        Since:
        JMS 2.0
        See Also:
        JMSContext.SESSION_TRANSACTED, JMSContext.CLIENT_ACKNOWLEDGE, JMSContext.AUTO_ACKNOWLEDGE, JMSContext.DUPS_OK_ACKNOWLEDGE, createContext(), createContext(java.lang.String, java.lang.String), createContext(java.lang.String, java.lang.String, int), JMSContext.createContext(int)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionMetaData (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface ConnectionMetaData

  • public interface ConnectionMetaData
    A ConnectionMetaData object provides information describing the Connection object.
    Since:
    JMS 1.0
    Version:
    JMS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getJMSMajorVersion()
      Gets the JMS major version number.
      int getJMSMinorVersion()
      Gets the JMS minor version number.
      String getJMSProviderName()
      Gets the JMS provider name.
      String getJMSVersion()
      Gets the JMS API version.
      Enumeration getJMSXPropertyNames()
      Gets an enumeration of the JMSX property names.
      int getProviderMajorVersion()
      Gets the JMS provider major version number.
      int getProviderMinorVersion()
      Gets the JMS provider minor version number.
      String getProviderVersion()
      Gets the JMS provider version.

    • Method Detail

      • getJMSVersion

        String getJMSVersion()
                     throws JMSException
        Gets the JMS API version.
        Returns:
        the JMS API version
        Throws:
        JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

      • getJMSMajorVersion

        int getJMSMajorVersion()
                       throws JMSException
        Gets the JMS major version number.
        Returns:
        the JMS API major version number
        Throws:
        JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

      • getJMSMinorVersion

        int getJMSMinorVersion()
                       throws JMSException
        Gets the JMS minor version number.
        Returns:
        the JMS API minor version number
        Throws:
        JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

      • getJMSProviderName

        String getJMSProviderName()
                          throws JMSException
        Gets the JMS provider name.
        Returns:
        the JMS provider name
        Throws:
        JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

      • getProviderVersion

        String getProviderVersion()
                          throws JMSException
        Gets the JMS provider version.
        Returns:
        the JMS provider version
        Throws:
        JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

      • getProviderMajorVersion

        int getProviderMajorVersion()
                            throws JMSException
        Gets the JMS provider major version number.
        Returns:
        the JMS provider major version number
        Throws:
        JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

      • getProviderMinorVersion

        int getProviderMinorVersion()
                            throws JMSException
        Gets the JMS provider minor version number.
        Returns:
        the JMS provider minor version number
        Throws:
        JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

      • getJMSXPropertyNames

        Enumeration getJMSXPropertyNames()
                                 throws JMSException
        Gets an enumeration of the JMSX property names.
        Returns:
        an Enumeration of JMSX property names
        Throws:
        JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeliveryMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface DeliveryMode

  • public interface DeliveryMode
    The delivery modes supported by the JMS API are PERSISTENT and NON_PERSISTENT.

    A client marks a message as persistent if it feels that the application will have problems if the message is lost in transit. A client marks a message as non-persistent if an occasional lost message is tolerable. Clients use delivery mode to tell a JMS provider how to balance message transport reliability with throughput.

    Delivery mode covers only the transport of the message to its destination. Retention of a message at the destination until its receipt is acknowledged is not guaranteed by a PERSISTENT delivery mode. Clients should assume that message retention policies are set administratively. Message retention policy governs the reliability of message delivery from destination to message consumer. For example, if a client's message storage space is exhausted, some messages may be dropped in accordance with a site-specific message retention policy.

    A message is guaranteed to be delivered once and only once by a JMS provider if the delivery mode of the message is PERSISTENT and if the destination has a sufficient message retention policy.

    Since:
    JMS 1.0
    Version:
    JMS 2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int NON_PERSISTENT
      This is the lowest-overhead delivery mode because it does not require that the message be logged to stable storage.
      static int PERSISTENT
      This delivery mode instructs the JMS provider to log the message to stable storage as part of the client's send operation.

    • Field Detail

      • NON_PERSISTENT

        static final int NON_PERSISTENT
        This is the lowest-overhead delivery mode because it does not require that the message be logged to stable storage. The level of JMS provider failure that causes a NON_PERSISTENT message to be lost is not defined.

        A JMS provider must deliver a NON_PERSISTENT message with an at-most-once guarantee. This means that it may lose the message, but it must not deliver it twice.

        See Also:
        Constant Field Values

      • PERSISTENT

        static final int PERSISTENT
        This delivery mode instructs the JMS provider to log the message to stable storage as part of the client's send operation. Only a hard media failure should cause a PERSISTENT message to be lost.
        See Also:
        Constant Field Values
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Destination (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface Destination

  • All Known Subinterfaces:
    Queue, TemporaryQueue, TemporaryTopic, Topic

    public interface Destination
    A Destination object encapsulates a provider-specific address. The JMS API does not define a standard address syntax. Although a standard address syntax was considered, it was decided that the differences in address semantics between existing message-oriented middleware (MOM) products were too wide to bridge with a single syntax.

    Since Destination is an administered object, it may contain provider-specific configuration information in addition to its address.

    The JMS API also supports a client's use of provider-specific address names.

    Destination objects support concurrent use.

    A Destination object is a JMS administered object.

    JMS administered objects are objects containing configuration information that are created by an administrator and later used by JMS clients. They make it practical to administer the JMS API in the enterprise.

    Although the interfaces for administered objects do not explicitly depend on the Java Naming and Directory Interface (JNDI) API, the JMS API establishes the convention that JMS clients find administered objects by looking them up in a JNDI namespace.

    An administrator can place an administered object anywhere in a namespace. The JMS API does not define a naming policy.

    It is expected that JMS providers will provide the tools an administrator needs to create and configure administered objects in a JNDI namespace. JMS provider implementations of administered objects should implement the javax.naming.Referenceable and java.io.Serializable interfaces so that they can be stored in all JNDI naming contexts. In addition, it is recommended that these implementations follow the JavaBeansTM design patterns.

    This strategy provides several benefits:

    • It hides provider-specific details from JMS clients.
    • It abstracts JMS administrative information into objects in the Java programming language ("Java objects") that are easily organized and administered from a common management console.
    • Since there will be JNDI providers for all popular naming services, JMS providers can deliver one implementation of administered objects that will run everywhere.

    An administered object should not hold on to any remote resources. Its lookup should not use remote resources other than those used by the JNDI API itself.

    Clients should think of administered objects as local Java objects. Looking them up should not have any hidden side effects or use surprising amounts of local resources.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Queue, Topic
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExceptionListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface ExceptionListener

  • public interface ExceptionListener
    If a JMS provider detects a serious problem with a Connection object, it informs the Connection object's ExceptionListener, if one has been registered. It does this by calling the listener's onException method, passing it a JMSException argument describing the problem.

    An exception listener allows a client to be notified of a problem asynchronously. Some connections only consume messages, so they would have no other way to learn that their connection has failed.

    A JMS provider should attempt to resolve connection problems itself before it notifies the client of them.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Connection.setExceptionListener(ExceptionListener)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onException(JMSException exception)
      Notifies user of a JMS exception.

    • Method Detail

      • onException

        void onException(JMSException exception)
        Notifies user of a JMS exception.
        Parameters:
        exception - the JMS exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IllegalStateException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class IllegalStateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.IllegalStateException
  • All Implemented Interfaces:
    Serializable

    public class IllegalStateException
extends JMSException

    This exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation. For example, this exception must be thrown if Session.commit is called on a non-transacted session. This exception is also called when a domain inappropriate method is called, such as calling TopicSession.CreateQueueBrowser.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      IllegalStateException(String reason)
      Constructs an IllegalStateException with the specified reason.
      IllegalStateException(String reason, String errorCode)
      Constructs an IllegalStateException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • IllegalStateException

        public IllegalStateException(String reason,
                     String errorCode)
        Constructs an IllegalStateException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • IllegalStateException

        public IllegalStateException(String reason)
        Constructs an IllegalStateException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IllegalStateRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class IllegalStateRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.IllegalStateRuntimeException
  • All Implemented Interfaces:
    Serializable

    public class IllegalStateRuntimeException
extends JMSRuntimeException
    This unchecked exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation, and the method signature does not permit a IllegalStateRuntimeException to be thrown. For example, this exception must be thrown if JMSContext.commit is called on a non-transacted session.
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      IllegalStateRuntimeException(String detailMessage)
      Constructs a IllegalStateRuntimeException with the specified detail message
      IllegalStateRuntimeException(String detailMessage, String errorCode)
      Constructs a IllegalStateRuntimeException with the specified detail message and error code.
      IllegalStateRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a IllegalStateRuntimeException with the specified detail message, error code and cause

    • Method Summary

      • Methods inherited from class javax.jms.JMSRuntimeException

        getErrorCode

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • IllegalStateRuntimeException

        public IllegalStateRuntimeException(String detailMessage)
        Constructs a IllegalStateRuntimeException with the specified detail message
        Parameters:
        detailMessage - a description of the exception

      • IllegalStateRuntimeException

        public IllegalStateRuntimeException(String detailMessage,
                            String errorCode)
        Constructs a IllegalStateRuntimeException with the specified detail message and error code.
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code

      • IllegalStateRuntimeException

        public IllegalStateRuntimeException(String detailMessage,
                            String errorCode,
                            Throwable cause)
        Constructs a IllegalStateRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidClientIDException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class InvalidClientIDException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.InvalidClientIDException
  • All Implemented Interfaces:
    Serializable

    public class InvalidClientIDException
extends JMSException

    This exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidClientIDException(String reason)
      Constructs an InvalidClientIDException with the specified reason.
      InvalidClientIDException(String reason, String errorCode)
      Constructs an InvalidClientIDException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidClientIDException

        public InvalidClientIDException(String reason,
                        String errorCode)
        Constructs an InvalidClientIDException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • InvalidClientIDException

        public InvalidClientIDException(String reason)
        Constructs an InvalidClientIDException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidClientIDRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class InvalidClientIDRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.InvalidClientIDRuntimeException
  • All Implemented Interfaces:
    Serializable

    public class InvalidClientIDRuntimeException
extends JMSRuntimeException
    This unchecked exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider, and the method signature does not permit a InvalidClientIDException to be thrown.
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidClientIDRuntimeException(String detailMessage)
      Constructs a InvalidClientIDRuntimeException with the specified detail message
      InvalidClientIDRuntimeException(String detailMessage, String errorCode)
      Constructs a InvalidClientIDRuntimeException with the specified detail message and error code.
      InvalidClientIDRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a InvalidClientIDRuntimeException with the specified detail message, error code and cause

    • Method Summary

      • Methods inherited from class javax.jms.JMSRuntimeException

        getErrorCode

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidClientIDRuntimeException

        public InvalidClientIDRuntimeException(String detailMessage)
        Constructs a InvalidClientIDRuntimeException with the specified detail message
        Parameters:
        detailMessage - a description of the exception

      • InvalidClientIDRuntimeException

        public InvalidClientIDRuntimeException(String detailMessage,
                               String errorCode)
        Constructs a InvalidClientIDRuntimeException with the specified detail message and error code.
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code

      • InvalidClientIDRuntimeException

        public InvalidClientIDRuntimeException(String detailMessage,
                               String errorCode,
                               Throwable cause)
        Constructs a InvalidClientIDRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidDestinationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class InvalidDestinationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.InvalidDestinationException
  • All Implemented Interfaces:
    Serializable

    public class InvalidDestinationException
extends JMSException

    This exception must be thrown when a destination either is not understood by a provider or is no longer valid.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidDestinationException(String reason)
      Constructs an InvalidDestinationException with the specified reason.
      InvalidDestinationException(String reason, String errorCode)
      Constructs an InvalidDestinationException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidDestinationException

        public InvalidDestinationException(String reason,
                           String errorCode)
        Constructs an InvalidDestinationException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • InvalidDestinationException

        public InvalidDestinationException(String reason)
        Constructs an InvalidDestinationException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidDestinationRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class InvalidDestinationRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.InvalidDestinationRuntimeException
  • All Implemented Interfaces:
    Serializable

    public class InvalidDestinationRuntimeException
extends JMSRuntimeException
    This unchecked exception must be thrown when a destination either is not understood by a provider or is no longer valid, and the method signature does not permit a InvalidDestinationException to be thrown.
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidDestinationRuntimeException(String detailMessage)
      Constructs a InvalidDestinationRuntimeException with the specified detail message
      InvalidDestinationRuntimeException(String detailMessage, String errorCode)
      Constructs a InvalidDestinationRuntimeException with the specified detail message and error code.
      InvalidDestinationRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a InvalidDestinationRuntimeException with the specified detail message, error code and cause

    • Method Summary

      • Methods inherited from class javax.jms.JMSRuntimeException

        getErrorCode

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidDestinationRuntimeException

        public InvalidDestinationRuntimeException(String detailMessage)
        Constructs a InvalidDestinationRuntimeException with the specified detail message
        Parameters:
        detailMessage - a description of the exception

      • InvalidDestinationRuntimeException

        public InvalidDestinationRuntimeException(String detailMessage,
                                  String errorCode)
        Constructs a InvalidDestinationRuntimeException with the specified detail message and error code.
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code

      • InvalidDestinationRuntimeException

        public InvalidDestinationRuntimeException(String detailMessage,
                                  String errorCode,
                                  Throwable cause)
        Constructs a InvalidDestinationRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidSelectorException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class InvalidSelectorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.InvalidSelectorException
  • All Implemented Interfaces:
    Serializable

    public class InvalidSelectorException
extends JMSException

    This exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidSelectorException(String reason)
      Constructs an InvalidSelectorException with the specified reason.
      InvalidSelectorException(String reason, String errorCode)
      Constructs an InvalidSelectorException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidSelectorException

        public InvalidSelectorException(String reason,
                        String errorCode)
        Constructs an InvalidSelectorException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • InvalidSelectorException

        public InvalidSelectorException(String reason)
        Constructs an InvalidSelectorException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidSelectorRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class InvalidSelectorRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.InvalidSelectorRuntimeException
  • All Implemented Interfaces:
    Serializable

    public class InvalidSelectorRuntimeException
extends JMSRuntimeException
    This unchecked exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax, and the method signature does not permit a InvalidSelectorException to be thrown.
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidSelectorRuntimeException(String detailMessage)
      Constructs a InvalidSelectorRuntimeException with the specified detail message
      InvalidSelectorRuntimeException(String detailMessage, String errorCode)
      Constructs a InvalidSelectorRuntimeException with the specified detail message and error code.
      InvalidSelectorRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a InvalidSelectorRuntimeException with the specified detail message, error code and cause

    • Method Summary

      • Methods inherited from class javax.jms.JMSRuntimeException

        getErrorCode

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidSelectorRuntimeException

        public InvalidSelectorRuntimeException(String detailMessage)
        Constructs a InvalidSelectorRuntimeException with the specified detail message
        Parameters:
        detailMessage - a description of the exception

      • InvalidSelectorRuntimeException

        public InvalidSelectorRuntimeException(String detailMessage,
                               String errorCode)
        Constructs a InvalidSelectorRuntimeException with the specified detail message and error code.
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code

      • InvalidSelectorRuntimeException

        public InvalidSelectorRuntimeException(String detailMessage,
                               String errorCode,
                               Throwable cause)
        Constructs a InvalidSelectorRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.jms (Java(TM) EE 7 Specification APIs)

javax.jms

Interfaces

  • BytesMessage
  • CompletionListener
  • Connection
  • ConnectionConsumer
  • ConnectionFactory
  • ConnectionMetaData
  • DeliveryMode
  • Destination
  • ExceptionListener
  • JMSConsumer
  • JMSContext
  • JMSProducer
  • MapMessage
  • Message
  • MessageConsumer
  • MessageListener
  • MessageProducer
  • ObjectMessage
  • Queue
  • QueueBrowser
  • QueueConnection
  • QueueConnectionFactory
  • QueueReceiver
  • QueueSender
  • QueueSession
  • ServerSession
  • ServerSessionPool
  • Session
  • StreamMessage
  • TemporaryQueue
  • TemporaryTopic
  • TextMessage
  • Topic
  • TopicConnection
  • TopicConnectionFactory
  • TopicPublisher
  • TopicSession
  • TopicSubscriber
  • XAConnection
  • XAConnectionFactory
  • XAJMSContext
  • XAQueueConnection
  • XAQueueConnectionFactory
  • XAQueueSession
  • XASession
  • XATopicConnection
  • XATopicConnectionFactory
  • XATopicSession

Classes

  • QueueRequestor
  • TopicRequestor

Exceptions

  • IllegalStateException
  • IllegalStateRuntimeException
  • InvalidClientIDException
  • InvalidClientIDRuntimeException
  • InvalidDestinationException
  • InvalidDestinationRuntimeException
  • InvalidSelectorException
  • InvalidSelectorRuntimeException
  • JMSException
  • JMSRuntimeException
  • JMSSecurityException
  • JMSSecurityRuntimeException
  • MessageEOFException
  • MessageFormatException
  • MessageFormatRuntimeException
  • MessageNotReadableException
  • MessageNotWriteableException
  • MessageNotWriteableRuntimeException
  • ResourceAllocationException
  • ResourceAllocationRuntimeException
  • TransactionInProgressException
  • TransactionInProgressRuntimeException
  • TransactionRolledBackException
  • TransactionRolledBackRuntimeException

Annotation Types

  • JMSConnectionFactory
  • JMSConnectionFactoryDefinition
  • JMSConnectionFactoryDefinitions
  • JMSDestinationDefinition
  • JMSDestinationDefinitions
  • JMSPasswordCredential
  • JMSSessionMode


javax.jms (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.jms

The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

See: Description

  • Interface Summary
    Interface Description
    BytesMessage
    A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.
    CompletionListener
    A CompletionListener is implemented by the application and may be specified when a message is sent asynchronously.
    Connection
    A Connection object is a client's active connection to its JMS provider.
    ConnectionConsumer
    For application servers, Connection objects provide a special facility for creating a ConnectionConsumer (optional).
    ConnectionFactory
    A ConnectionFactory object encapsulates a set of connection configuration parameters that has been defined by an administrator.
    ConnectionMetaData
    A ConnectionMetaData object provides information describing the Connection object.
    DeliveryMode
    The delivery modes supported by the JMS API are PERSISTENT and NON_PERSISTENT.
    Destination
    A Destination object encapsulates a provider-specific address.
    ExceptionListener
    If a JMS provider detects a serious problem with a Connection object, it informs the Connection object's ExceptionListener, if one has been registered.
    JMSConsumer
    A client using the simplified JMS API introduced for JMS 2.0 uses a JMSConsumer object to receive messages from a queue or topic.
    JMSContext
    A JMSContext is the main interface in the simplified JMS API introduced for JMS 2.0.
    JMSProducer
    A JMSProducer is a simple object used to send messages on behalf of a JMSContext.
    MapMessage
    A MapMessage object is used to send a set of name-value pairs.
    Message
    The Message interface is the root interface of all JMS messages.
    MessageConsumer
    A client uses a MessageConsumer object to receive messages from a destination.
    MessageListener
    A MessageListener object is used to receive asynchronously delivered messages.
    MessageProducer
    A client uses a MessageProducer object to send messages to a destination.
    ObjectMessage
    An ObjectMessage object is used to send a message that contains a serializable object in the Java programming language ("Java object").
    Queue
    A Queue object encapsulates a provider-specific queue name.
    QueueBrowser
    A client uses a QueueBrowser object to look at messages on a queue without removing them.
    QueueConnection
    A QueueConnection object is an active connection to a point-to-point JMS provider.
    QueueConnectionFactory
    A client uses a QueueConnectionFactory object to create QueueConnection objects with a point-to-point JMS provider.
    QueueReceiver
    A client uses a QueueReceiver object to receive messages that have been delivered to a queue.
    QueueSender
    A client uses a QueueSender object to send messages to a queue.
    QueueSession
    A QueueSession object provides methods for creating QueueReceiver, QueueSender, QueueBrowser, and TemporaryQueue objects.
    ServerSession
    A ServerSession object is an application server object that is used by a server to associate a thread with a JMS session (optional).
    ServerSessionPool
    A ServerSessionPool object is an object implemented by an application server to provide a pool of ServerSession objects for processing the messages of a ConnectionConsumer (optional).
    Session
    A Session object is a single-threaded context for producing and consuming messages.
    StreamMessage
    A StreamMessage object is used to send a stream of primitive types in the Java programming language.
    TemporaryQueue
    A TemporaryQueue object is a unique Queue object created for the duration of a Connection.
    TemporaryTopic
    A TemporaryTopic object is a unique Topic object created for the duration of a Connection.
    TextMessage
    A TextMessage object is used to send a message containing a java.lang.String.
    Topic
    A Topic object encapsulates a provider-specific topic name.
    TopicConnection
    A TopicConnection object is an active connection to a publish/subscribe JMS provider.
    TopicConnectionFactory
    A client uses a TopicConnectionFactory object to create TopicConnection objects with a publish/subscribe JMS provider.
    TopicPublisher
    A client uses a TopicPublisher object to publish messages on a topic.
    TopicSession
    A TopicSession object provides methods for creating TopicPublisher, TopicSubscriber, and TemporaryTopic objects.
    TopicSubscriber
    A client uses a TopicSubscriber object to receive messages that have been published to a topic.
    XAConnection
    The XAConnection interface extends the capability of Connection by providing an XASession (optional).
    XAConnectionFactory
    The XAConnectionFactory interface is a base interface for the XAQueueConnectionFactory and XATopicConnectionFactory interfaces.
    XAJMSContext
    The XAJMSContext interface extends the capability of JMSContext by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional).
    XAQueueConnection
    An XAQueueConnection provides the same create options as QueueConnection (optional).
    XAQueueConnectionFactory
    An XAQueueConnectionFactory provides the same create options as a QueueConnectionFactory (optional).
    XAQueueSession
    An XAQueueSession provides a regular QueueSession, which can be used to create QueueReceiver, QueueSender, and QueueBrowser objects (optional).
    XASession
    The XASession interface extends the capability of Session by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional).
    XATopicConnection
    An XATopicConnection provides the same create options as TopicConnection (optional).
    XATopicConnectionFactory
    An XATopicConnectionFactory provides the same create options as a TopicConnectionFactory (optional).
    XATopicSession
    An XATopicSession provides a regular TopicSession.
  • Class Summary
    Class Description
    QueueRequestor
    The QueueRequestor helper class simplifies making service requests.
    TopicRequestor
    The TopicRequestor helper class simplifies making service requests.
  • Exception Summary
    Exception Description
    IllegalStateException
    This exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation.
    IllegalStateRuntimeException
    This unchecked exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation, and the method signature does not permit a IllegalStateRuntimeException to be thrown.
    InvalidClientIDException
    This exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider.
    InvalidClientIDRuntimeException
    This unchecked exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider, and the method signature does not permit a InvalidClientIDException to be thrown.
    InvalidDestinationException
    This exception must be thrown when a destination either is not understood by a provider or is no longer valid.
    InvalidDestinationRuntimeException
    This unchecked exception must be thrown when a destination either is not understood by a provider or is no longer valid, and the method signature does not permit a InvalidDestinationException to be thrown.
    InvalidSelectorException
    This exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax.
    InvalidSelectorRuntimeException
    This unchecked exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax, and the method signature does not permit a InvalidSelectorException to be thrown.
    JMSException
    This is the root class of all checked exceptions in the JMS API.
    JMSRuntimeException
    This is the root class of all unchecked exceptions in the JMS API.
    JMSSecurityException
    This exception must be thrown when a provider rejects a user name/password submitted by a client.
    JMSSecurityRuntimeException
    This unchecked exception must be thrown when a provider rejects a user name/password submitted by a client, or for any case where a security restriction prevents a method from completing, and the method signature does not permit a JMSSecurityException to be thrown.
    MessageEOFException
    This exception must be thrown when an unexpected end of stream has been reached when a StreamMessage or BytesMessage is being read.
    MessageFormatException
    This exception must be thrown when a JMS client attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type.
    MessageFormatRuntimeException
    This unchecked exception must be thrown when a JMS application attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type, and the method signature does not permit a MessageFormatException to be thrown.
    MessageNotReadableException
    This exception must be thrown when a JMS client attempts to read a write-only message.
    MessageNotWriteableException
    This exception must be thrown when a JMS client attempts to write to a read-only message.
    MessageNotWriteableRuntimeException
    This unchecked exception must be thrown when a JMS client attempts to write to a read-only message.
    ResourceAllocationException
    This exception is thrown when a provider is unable to allocate the resources required by a method.
    ResourceAllocationRuntimeException
    This unchecked exception is thrown when a provider is unable to allocate the resources required by a method.
    TransactionInProgressException
    This exception is thrown when an operation is invalid because a transaction is in progress.
    TransactionInProgressRuntimeException
    This unchecked exception is thrown when an operation is invalid because a transaction is in progress.
    TransactionRolledBackException
    This exception must be thrown when a call to Session.commit results in a rollback of the current transaction.
    TransactionRolledBackRuntimeException
    This unchecked exception must be thrown when a call to JMSContext.commit results in a rollback of the current transaction.
  • Annotation Types Summary
    Annotation Type Description
    JMSConnectionFactory
    This annotation may be used to specify the JNDI lookup name of a javax.jms.ConnectionFactory to be used when injecting a javax.jms.JMSContext object.
    JMSConnectionFactoryDefinition
    An application may use this annotation to specify a JMS ConnectionFactory resource that it requires in its operational environment.
    JMSConnectionFactoryDefinitions
    Specifies one or more JMSConnectionFactoryDefinition annotations.
    JMSDestinationDefinition
    An application may use this annotation to specify a JMS Destination resource that it requires in its operational environment.
    JMSDestinationDefinitions
    Specifies one or more JMSDestinationDefinition annotations.
    JMSPasswordCredential
    This annotation may be used to specify the userName and password to be used when injecting a javax.jms.JMSContext object.
    JMSSessionMode
    This annotation may be used to specify the session mode to be used when injecting a javax.jms.JMSContext object.

Package javax.jms Description

The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

JMS Applications

A JMS application is composed of the following parts:

  • JMS provider - a messaging system that implements the JMS API in addition to the other administrative and control functionality required of a full-featured messaging product
  • JMS clients - the Java language programs that send and receive messages
  • Messages - objects that are used to communicate information between the clients of an application
  • Administered objects - provider-specific objects that clients look up and use to interact portably with a JMS provider
  • Non-JMS clients - clients that use a message system's native client API instead of the JMS API. If the application predated the availability of the JMS API, it is likely that it will include both JMS clients and non-JMS clients.

Administration

JMS providers differ significantly in their implementations of underlying messaging technology. There are also major differences in how a JMS provider's system is installed and administered.

For JMS clients to be portable, they must be isolated from these proprietary aspects of a provider. This is done by defining JMS administered objects that are created and customised by a provider's administrator and later used by clients. The client uses them through JMS interfaces that are portable. The administrator creates them using provider-specific facilities.

There are two types of JMS administered objects:

  • ConnectionFactory - the object a client uses to create a connection with a JMS provider
  • Destination - the object a client uses to specify the destination of messages it is sending and the source of messages it receives

Administered objects are placed by an administrator in a JNDI (Java Naming and Directory Interface) namespace. A JMS client typically notes in its documentation the JMS administered objects it requires and how the JNDI names of these objects should be provided to it.

Two Messaging Styles

JMS supports two styles of messaging:

  • point-to-point (PTP) messaging using queues
  • publish-and-subscribe (pub/sub)messaging using topics

These two styles represent two of the dominant approaches to messaging currently in use.

JMS APIs

For historical reasons JMS offers four alternative sets of interfaces for sending and receiving messages:

  • JMS 1.0 defined two domain-specific APIs, one for point-to-point messaging (queues) and one for pub/sub (topics). Although these remain part of JMS for reasons of backwards compatibility they should be considered to be completely superseded by the later APIs.
  • JMS 1.1 introduced a new unified API which offered a single set of interfaces that could be used for both point-to-point and pub/sub messaging. This is referred to here as the classic API.
  • JMS 2.0 introduces a simplified API which offers all the features of the classic API but which requires fewer interfaces and is simpler to use.

Each API offers a different set of interfaces for connecting to a JMS provider and for sending and receiving messages. However they all share a common set of interfaces for representing messages and message destinations and to provide various utility features.

All interfaces are in the javax.jms package.

Interfaces common to multiple APIs

The main interfaces common to multiple APIs are as follows:

  • Message, BytesMessage, MapMessage, ObjectMessage, StreamMessage and TextMessage - a message sent to or received from a JMS provider.
  • Queue - an administered object that encapsulates the identity of a message destination for point-to-point messaging
  • Topic - an administered object that encapsulates the identity of a message destination for pub/sub messaging.
  • Destination - the common supertype of Queue and Topic

Classic API interfaces

The main interfaces provided by the classic API are as follows:
  • ConnectionFactory - an administered object used by a client to create a Connection. This interface is also used by the simplified API.
  • Connection - an active connection to a JMS provider
  • Session - a single-threaded context for sending and receiving messages
  • MessageProducer - an object created by a Session that is used for sending messages to a queue or topic
  • MessageConsumer - an object created by a Session that is used for receiving messages sent to a queue or topic

Simplified API interfaces

The simplified API provides the same messaging functionality as the classic API but requires fewer interfaces and is simpler to use. The main interfaces provided by the simplified API are as follows:
  • ConnectionFactory - an administered object used by a client to create a JMSContext. This interface is also used by the classic API.
  • JMSContext - an active connection to a JMS provider and a single-threaded context for sending and receiving messages
  • JMSProducer - an object created by a JMSContext that is used for sending messages to a queue or topic
  • JMSConsumer - an object created by a JMSContext that is used for receiving messages sent to a queue or topic

Legacy domain-specific API interfaces

Although the domain-specific API remains part of JMS for reasons of backwards compatibility it should be considered to be completely superseded by the classic and simplified APIs.

The main interfaces provided by the domain-specific API for point-to-point messaging are as follows:

  • QueueConnectionFactory - an administered object used by a client to create a QueueConnection.
  • QueueConnection - an active connection to a JMS provider
  • QueueSession - a single-threaded context for sending and receiving messages
  • QueueSender - an object created by a QueueSession that is used for sending messages to a queue
  • QueueReceiver - an object created by a QueueSession that is used for receiving messages sent to a queue
The main interfaces provided by the domain-specific API for pub/sub messaging are as follows:
  • TopicConnectionFactory - an administered object used by a client to create a TopicConnection.
  • TopicConnection - an active connection to a JMS provider
  • TopicSession - a single-threaded context for sending and receiving messages
  • TopicPublisher - an object created by a TopicSession that is used for sending messages to a topic
  • TopicSubscriber - an object created by a TopicSession that is used for receiving messages sent to a topic

Terminology for sending and receiving messages

The term consume is used in this document to mean the receipt of a message by a JMS client; that is, a JMS provider has received a message and has given it to its client. Since JMS supports both synchronous and asynchronous receipt of messages, the term consume is used when there is no need to make a distinction between them.

The term produce is used as the most general term for sending a message. It means giving a message to a JMS provider for delivery to a destination.

Developing a JMS Application

Broadly speaking, a JMS application is one or more JMS clients that exchange messages. The application may also involve non-JMS clients; however, these clients use the JMS provider's native API in place of the JMS API.

A JMS application can be architected and deployed as a unit. In many cases, JMS clients are added incrementally to an existing application.

The message definitions used by an application may originate with JMS, or they may have been defined by the non-JMS part of the application.

Developing a JMS Client

A typical JMS client using the classic API executes the following JMS setup procedure:

  • Use JNDI to find a ConnectionFactory object
  • Use JNDI to find one or more Destination objects
  • Use the ConnectionFactory to create a JMS Connection object with message delivery inhibited
  • Use the Connection to create one or more JMS Session objects
  • Use a Session and the Destinations to create the MessageProducer and MessageConsumer objects needed
  • Tell the Connection to start delivery of messages

In contrast, a typical JMS client using the simplified API does the following:

  • Use JNDI to find a ConnectionFactory object
  • Use JNDI to find one or more Destination objects
  • Use the ConnectionFactory to create a JMSContext object
  • Use the JMSContext to create the JMSProducer and JMSConsumer objects needed.
  • Delivery of message is started automatically

At this point a client has the basic JMS setup needed to produce and consume messages.

Package Specification

Java Message Service 2.0 specification

Related Documentation

Java Platform, Enterprise Edition (Java EE) Technical Documentation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.jms Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.jms

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.jms.QueueRequestor
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.IllegalStateException
          • javax.jms.InvalidClientIDException
          • javax.jms.InvalidDestinationException
          • javax.jms.InvalidSelectorException
          • javax.jms.JMSSecurityException
          • javax.jms.MessageEOFException
          • javax.jms.MessageFormatException
          • javax.jms.MessageNotReadableException
          • javax.jms.MessageNotWriteableException
          • javax.jms.ResourceAllocationException
          • javax.jms.TransactionInProgressException
          • javax.jms.TransactionRolledBackException
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.IllegalStateRuntimeException
            • javax.jms.InvalidClientIDRuntimeException
            • javax.jms.InvalidDestinationRuntimeException
            • javax.jms.InvalidSelectorRuntimeException
            • javax.jms.JMSSecurityRuntimeException
            • javax.jms.MessageFormatRuntimeException
            • javax.jms.MessageNotWriteableRuntimeException
            • javax.jms.ResourceAllocationRuntimeException
            • javax.jms.TransactionInProgressRuntimeException
            • javax.jms.TransactionRolledBackRuntimeException
    • javax.jms.TopicRequestor

Interface Hierarchy

  • java.lang.AutoCloseable
    • javax.jms.Connection
      • javax.jms.QueueConnection
        • javax.jms.XAQueueConnection (also extends javax.jms.XAConnection)
      • javax.jms.TopicConnection
        • javax.jms.XATopicConnection (also extends javax.jms.XAConnection)
      • javax.jms.XAConnection
        • javax.jms.XAQueueConnection (also extends javax.jms.QueueConnection)
        • javax.jms.XATopicConnection (also extends javax.jms.TopicConnection)
    • javax.jms.JMSConsumer
    • javax.jms.JMSContext
      • javax.jms.XAJMSContext
    • javax.jms.MessageConsumer
      • javax.jms.QueueReceiver
      • javax.jms.TopicSubscriber
    • javax.jms.MessageProducer
      • javax.jms.QueueSender
      • javax.jms.TopicPublisher
    • javax.jms.QueueBrowser
    • javax.jms.Session (also extends java.lang.Runnable)
      • javax.jms.QueueSession
      • javax.jms.TopicSession
      • javax.jms.XASession
        • javax.jms.XAQueueSession
        • javax.jms.XATopicSession
  • javax.jms.CompletionListener
  • javax.jms.ConnectionConsumer
  • javax.jms.ConnectionFactory
    • javax.jms.QueueConnectionFactory
      • javax.jms.XAQueueConnectionFactory (also extends javax.jms.XAConnectionFactory)
    • javax.jms.TopicConnectionFactory
      • javax.jms.XATopicConnectionFactory (also extends javax.jms.XAConnectionFactory)
  • javax.jms.ConnectionMetaData
  • javax.jms.DeliveryMode
  • javax.jms.Destination
    • javax.jms.Queue
      • javax.jms.TemporaryQueue
    • javax.jms.Topic
      • javax.jms.TemporaryTopic
  • javax.jms.ExceptionListener
  • javax.jms.JMSProducer
  • javax.jms.Message
    • javax.jms.BytesMessage
    • javax.jms.MapMessage
    • javax.jms.ObjectMessage
    • javax.jms.StreamMessage
    • javax.jms.TextMessage
  • javax.jms.MessageListener
  • java.lang.Runnable
    • javax.jms.Session (also extends java.lang.AutoCloseable)
      • javax.jms.QueueSession
      • javax.jms.TopicSession
      • javax.jms.XASession
        • javax.jms.XAQueueSession
        • javax.jms.XATopicSession
  • javax.jms.ServerSession
  • javax.jms.ServerSessionPool
  • javax.jms.XAConnectionFactory
    • javax.jms.XAQueueConnectionFactory (also extends javax.jms.QueueConnectionFactory)
    • javax.jms.XATopicConnectionFactory (also extends javax.jms.TopicConnectionFactory)

Annotation Type Hierarchy

  • javax.jms.JMSSessionMode (implements java.lang.annotation.Annotation)
  • javax.jms.JMSPasswordCredential (implements java.lang.annotation.Annotation)
  • javax.jms.JMSDestinationDefinitions (implements java.lang.annotation.Annotation)
  • javax.jms.JMSDestinationDefinition (implements java.lang.annotation.Annotation)
  • javax.jms.JMSConnectionFactoryDefinitions (implements java.lang.annotation.Annotation)
  • javax.jms.JMSConnectionFactoryDefinition (implements java.lang.annotation.Annotation)
  • javax.jms.JMSConnectionFactory (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JMSConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jms

Annotation Type JMSConnectionFactory

  • @Retention(value=RUNTIME)
@Target(value={METHOD,FIELD,PARAMETER,TYPE})
public @interface JMSConnectionFactory
    This annotation may be used to specify the JNDI lookup name of a javax.jms.ConnectionFactory to be used when injecting a javax.jms.JMSContext object.
    Since:
    JMS 2.0
    Version:
    JMS 2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Specifies the JNDI lookup name of a javax.jms.ConnectionFactory to be used when injecting a javax.jms.JMSContext object.

    • Element Detail

      • value

        public abstract String value
        Specifies the JNDI lookup name of a javax.jms.ConnectionFactory to be used when injecting a javax.jms.JMSContext object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


JMSConnectionFactoryDefinition (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jms

Annotation Type JMSConnectionFactoryDefinition

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface JMSConnectionFactoryDefinition
    An application may use this annotation to specify a JMS ConnectionFactory resource that it requires in its operational environment. This provides information that can be used at the application's deployment to provision the required resource and allows an application to be deployed into a Java EE environment with more minimal administrative configuration.

    The ConnectionFactory resource may be configured by setting the annotation elements for commonly used properties. Additional properties may be specified using the properties element. Once defined, a ConnectionFactory resource may be referenced by a component in the same way as any other ConnectionFactory resource, for example by using the lookup element of the Resource annotation.

    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Resource

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      JNDI name of the JMS connection factory being defined.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String className
      Fully-qualified name of the JMS connection factory implementation class.
      String clientId
      Client id to use for connection.
      String description
      Description of this JMS connection factory.
      String interfaceName
      Fully qualified name of the JMS connection factory interface.
      int maxPoolSize
      Maximum number of connections that should be concurrently allocated for a connection pool.
      int minPoolSize
      Minimum number of connections that should be concurrently allocated for a connection pool.
      String password
      Password to use for connection authentication.
      String[] properties
      JMS connection factory property.
      String resourceAdapter
      Resource adapter name.
      boolean transactional
      Set to false if connections should not participate in transactions.
      String user
      User name to use for connection authentication.

    • Element Detail

      • name

        public abstract String name
        JNDI name of the JMS connection factory being defined.

      • description

        public abstract String description
        Description of this JMS connection factory.
        Default:
        ""

      • interfaceName

        public abstract String interfaceName
        Fully qualified name of the JMS connection factory interface. Permitted values are javax.jms.ConnectionFactory or javax.jms.QueueConnectionFactory or javax.jms.TopicConnectionFactory. If not specified then javax.jms.ConnectionFactory will be used.
        Default:
        "javax.jms.ConnectionFactory"

      • className

        public abstract String className
        Fully-qualified name of the JMS connection factory implementation class. Ignored if a resource adapter is used.
        Default:
        ""

      • resourceAdapter

        public abstract String resourceAdapter
        Resource adapter name. If not specified then the application server will define the default behaviour, which may or may not involve the use of a resource adapter.
        Default:
        ""

      • user

        public abstract String user
        User name to use for connection authentication.
        Default:
        ""

      • password

        public abstract String password
        Password to use for connection authentication.
        Default:
        ""

      • clientId

        public abstract String clientId
        Client id to use for connection.
        Default:
        ""

      • properties

        public abstract String[] properties
        JMS connection factory property. This may be a vendor-specific property or a less commonly used ConnectionFactory property.

        Properties are specified using the format: propertyName=propertyValue with one property per array element.

        Default:
        {}

      • transactional

        public abstract boolean transactional
        Set to false if connections should not participate in transactions.

        Default is to enlist in a transaction when one is active or becomes active.

        Default:
        true

      • maxPoolSize

        public abstract int maxPoolSize
        Maximum number of connections that should be concurrently allocated for a connection pool.

        Default is vendor-specific.

        Default:
        -1

      • minPoolSize

        public abstract int minPoolSize
        Minimum number of connections that should be concurrently allocated for a connection pool.

        Default is vendor-specific.

        Default:
        -1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


JMSConnectionFactoryDefinitions (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jms

Annotation Type JMSConnectionFactoryDefinitions

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface JMSConnectionFactoryDefinitions
    Specifies one or more JMSConnectionFactoryDefinition annotations.
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    JMSConnectionFactoryDefinition

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      JMSConnectionFactoryDefinition[] value

    • Element Detail

      • value

        public abstract JMSConnectionFactoryDefinition[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


JMSConsumer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface JMSConsumer

  • All Superinterfaces:
    AutoCloseable

    public interface JMSConsumer
extends AutoCloseable
    A client using the simplified JMS API introduced for JMS 2.0 uses a JMSConsumer object to receive messages from a queue or topic. A JMSConsumer object may be created either created by passing a Queue or Topic object to one of the createConsumer methods on a JMSContext. or by passing a Topic object to one of the createSharedConsumer or createDurableConsumer methods on a JMSContext.

    A JMSConsumer can be created with a message selector. A message selector allows the client to restrict the messages delivered to the JMSConsumer to those that match the selector.

    A client may either synchronously receive a JMSConsumer's messages or have the JMSConsumer asynchronously deliver them as they arrive.

    For synchronous receipt, a client can request the next message from a JMSConsumer using one of its receive methods. There are several variations of receive that allow a client to poll or wait for the next message.

    For asynchronous delivery, a client can register a MessageListener object with a JMSConsumer. As messages arrive at the JMSConsumer, it delivers them by calling the MessageListener 's onMessage method.

    It is a client programming error for a MessageListener to throw an exception.

    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    JMSContext

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes the JMSConsumer.
      MessageListener getMessageListener()
      Gets the JMSConsumer's MessageListener.
      String getMessageSelector()
      Gets this JMSConsumer's message selector expression.
      Message receive()
      Receives the next message produced for this JMSConsumer.
      Message receive(long timeout)
      Receives the next message that arrives within the specified timeout interval.
      <T> T receiveBody(Class<T> c)
      Receives the next message produced for this JMSConsumer and returns its body as an object of the specified type.
      <T> T receiveBody(Class<T> c, long timeout)
      Receives the next message produced for this JMSConsumer that arrives within the specified timeout period and returns its body as an object of the specified type.
      <T> T receiveBodyNoWait(Class<T> c)
      Receives the next message produced for this JMSConsumer if one is immediately available and returns its body as an object of the specified type.
      Message receiveNoWait()
      Receives the next message if one is immediately available.
      void setMessageListener(MessageListener listener)
      Sets the JMSConsumer's MessageListener.

    • Method Detail

      • getMessageSelector

        String getMessageSelector()
        Gets this JMSConsumer's message selector expression.
        Returns:
        this JMSConsumer's message selector, or null if no message selector exists for the JMSConsumer (that is, if the message selector was not set or was set to null or the empty string)
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the message selector due to some internal error.

      • getMessageListener

        MessageListener getMessageListener()
                                   throws JMSRuntimeException
        Gets the JMSConsumer's MessageListener.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSRuntimeException to be thrown though this is not guaranteed.

        Returns:
        the JMSConsumer's MessageListener, or null if one was not set
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the MessageListener for one of the following reasons:
        • an internal error has occurred or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        See Also:
        setMessageListener(javax.jms.MessageListener)

      • setMessageListener

        void setMessageListener(MessageListener listener)
                        throws JMSRuntimeException
        Sets the JMSConsumer's MessageListener.

        Setting the MessageListener to null is the equivalent of unsetting the MessageListener for the JMSConsumer.

        The effect of calling this method while messages are being consumed by an existing listener or the JMSConsumer is being used to consume messages synchronously is undefined.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSRuntimeException to be thrown though this is not guaranteed.

        Parameters:
        listener - the listener to which the messages are to be delivered
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the JMSConsumer's MessageListener for one of the following reasons:
        • an internal error has occurred or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        See Also:
        getMessageListener()

      • receive

        Message receive()
        Receives the next message produced for this JMSConsumer.

        This call blocks indefinitely until a message is produced or until this JMSConsumer is closed.

        If this receive is done within a transaction, the JMSConsumer retains the message until the transaction commits.

        Returns:
        the next message produced for this JMSConsumer, or null if this JMSConsumer is concurrently closed
        Throws:
        JMSRuntimeException - if the JMS provider fails to receive the next message due to some internal error.

      • receive

        Message receive(long timeout)
        Receives the next message that arrives within the specified timeout interval.

        This call blocks until a message arrives, the timeout expires, or this JMSConsumer is closed. A timeout of zero never expires, and the call blocks indefinitely.

        Parameters:
        timeout - the timeout value (in milliseconds)
        Returns:
        the next message produced for this JMSConsumer, or null if the timeout expires or this JMSConsumer is concurrently closed
        Throws:
        JMSRuntimeException - if the JMS provider fails to receive the next message due to some internal error.

      • receiveNoWait

        Message receiveNoWait()
        Receives the next message if one is immediately available.
        Returns:
        the next message produced for this JMSConsumer, or null if one is not available
        Throws:
        JMSRuntimeException - if the JMS provider fails to receive the next message due to some internal error.

      • close

        void close()
        Closes the JMSConsumer.

        Since a provider may allocate some resources on behalf of a JMSConsumer outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

        This call will block until a receive call in progress on this consumer has completed. A blocked receive call returns null when this consumer is closed.

        If this method is called whilst a message listener is in progress in another thread then it will block until the message listener has completed.

        This method may be called from a message listener's onMessage method on its own consumer. After this method returns the onMessage method will be allowed to complete normally.

        This method is the only JMSConsumer method that can be called concurrently.

        Specified by:
        close in interface AutoCloseable
        Throws:
        JMSRuntimeException - if the JMS provider fails to close the consumer due to some internal error.

      • receiveBody

        <T> T receiveBody(Class<T> c)
        Receives the next message produced for this JMSConsumer and returns its body as an object of the specified type. This method may be used to receive any type of message except for StreamMessage and Message, so long as the message has a body which is capable of being assigned to the specified type. This means that the specified class or interface must either be the same as, or a superclass or superinterface of, the class of the message body. If the message is not one of the supported types, or its body cannot be assigned to the specified type, or it has no body, then a MessageFormatRuntimeException is thrown.

        This method does not give access to the message headers or properties (such as the JMSRedelivered message header field or the JMSXDeliveryCount message property) and should only be used if the application has no need to access them.

        This call blocks indefinitely until a message is produced or until this JMSConsumer is closed.

        If this method is called within a transaction, the JMSConsumer retains the message until the transaction commits.

        The result of this method throwing a MessageFormatRuntimeException depends on the session mode:

        • AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE: The JMS provider will behave as if the unsuccessful call to receiveBody had not occurred. The message will be delivered again before any subsequent messages.

          This is not considered to be redelivery and does not cause the JMSRedelivered message header field to be set or the JMSXDeliveryCount message property to be incremented.

        • CLIENT_ACKNOWLEDGE: The JMS provider will behave as if the call to receiveBody had been successful and will not deliver the message again.

          As with any message that is delivered with a session mode of CLIENT_ACKNOWLEDGE, the message will not be acknowledged until acknowledge is called on the JMSContext. If an application wishes to have the failed message redelivered, it must call recover on the JMSContext. The redelivered message's JMSRedelivered message header field will be set and its JMSXDeliveryCount message property will be incremented.

        • Transacted session: The JMS provider will behave as if the call to receiveBody had been successful and will not deliver the message again.

          As with any message that is delivered in a transacted session, the transaction will remain uncommitted until the transaction is committed or rolled back by the application. If an application wishes to have the failed message redelivered, it must roll back the transaction. The redelivered message's JMSRedelivered message header field will be set and its JMSXDeliveryCount message property will be incremented.

        Parameters:
        c - The type to which the body of the next message should be assigned.
        If the next message is expected to be a TextMessage then this should be set to String.class or another class to which a String is assignable.
        If the next message is expected to be a ObjectMessage then this should be set to java.io.Serializable.class or another class to which the body is assignable.
        If the next message is expected to be a MapMessage then this should be set to java.util.Map.class (or java.lang.Object.class).
        If the next message is expected to be a BytesMessage then this should be set to byte[].class (or java.lang.Object.class).
        Returns:
        the body of the next message produced for this JMSConsumer, or null if this JMSConsumer is concurrently closed
        Throws:
        MessageFormatRuntimeException -
        • if the message is not one of the supported types listed above
        • if the message body cannot be assigned to the specified type
        • if the message has no body
        • if the message is an ObjectMessage and object deserialization fails.
        JMSRuntimeException - if the JMS provider fails to receive the next message due to some internal error

      • receiveBody

        <T> T receiveBody(Class<T> c,
                long timeout)
        Receives the next message produced for this JMSConsumer that arrives within the specified timeout period and returns its body as an object of the specified type. This method may be used to receive any type of message except for StreamMessage and Message, so long as the message has a body which is capable of being assigned to the specified type. This means that the specified class or interface must either be the same as, or a superclass or superinterface of, the class of the message body. If the message is not one of the supported types, or its body cannot be assigned to the specified type, or it has no body, then a MessageFormatRuntimeException is thrown.

        This method does not give access to the message headers or properties (such as the JMSRedelivered message header field or the JMSXDeliveryCount message property) and should only be used if the application has no need to access them.

        This call blocks until a message arrives, the timeout expires, or this JMSConsumer is closed. A timeout of zero never expires, and the call blocks indefinitely.

        If this method is called within a transaction, the JMSConsumer retains the message until the transaction commits.

        The result of this method throwing a MessageFormatRuntimeException depends on the session mode:

        • AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE: The JMS provider will behave as if the unsuccessful call to receiveBody had not occurred. The message will be delivered again before any subsequent messages.

          This is not considered to be redelivery and does not cause the JMSRedelivered message header field to be set or the JMSXDeliveryCount message property to be incremented.

        • CLIENT_ACKNOWLEDGE: The JMS provider will behave as if the call to receiveBody had been successful and will not deliver the message again.

          As with any message that is delivered with a session mode of CLIENT_ACKNOWLEDGE, the message will not be acknowledged until acknowledge is called on the JMSContext. If an application wishes to have the failed message redelivered, it must call recover on the JMSContext. The redelivered message's JMSRedelivered message header field will be set and its JMSXDeliveryCount message property will be incremented.

        • Transacted session: The JMS provider will behave as if the call to receiveBody had been successful and will not deliver the message again.

          As with any message that is delivered in a transacted session, the transaction will remain uncommitted until the transaction is committed or rolled back by the application. If an application wishes to have the failed message redelivered, it must roll back the transaction. The redelivered message's JMSRedelivered message header field will be set and its JMSXDeliveryCount message property will be incremented.

        Parameters:
        c - The type to which the body of the next message should be assigned.
        If the next message is expected to be a TextMessage then this should be set to String.class or another class to which a String is assignable.
        If the next message is expected to be a ObjectMessage then this should be set to java.io.Serializable.class or another class to which the body is assignable.
        If the next message is expected to be a MapMessage then this should be set to java.util.Map.class (or java.lang.Object.class).
        If the next message is expected to be a BytesMessage then this should be set to byte[].class (or java.lang.Object.class).
        Returns:
        the body of the next message produced for this JMSConsumer, or null if the timeout expires or this JMSConsumer is concurrently closed
        Throws:
        MessageFormatRuntimeException -
        • if the message is not one of the supported types listed above
        • if the message body cannot be assigned to the specified type
        • if the message has no body
        • if the message is an ObjectMessage and object deserialization fails.
        JMSRuntimeException - if the JMS provider fails to receive the next message due to some internal error

      • receiveBodyNoWait

        <T> T receiveBodyNoWait(Class<T> c)
        Receives the next message produced for this JMSConsumer if one is immediately available and returns its body as an object of the specified type. This method may be used to receive any type of message except for StreamMessage and Message, so long as the message has a body which is capable of being assigned to the specified type. This means that the specified class or interface must either be the same as, or a superclass or superinterface of, the class of the message body. If the message is not one of the supported types, or its body cannot be assigned to the specified type, or it has no body, then a MessageFormatRuntimeException is thrown.

        This method does not give access to the message headers or properties (such as the JMSRedelivered message header field or the JMSXDeliveryCount message property) and should only be used if the application has no need to access them.

        If a message is not immediately available null is returned.

        If this method is called within a transaction, the JMSConsumer retains the message until the transaction commits.

        The result of this method throwing a MessageFormatRuntimeException depends on the session mode:

        • AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE: The JMS provider will behave as if the unsuccessful call to receiveBodyNoWait had not occurred. The message will be delivered again before any subsequent messages.

          This is not considered to be redelivery and does not cause the JMSRedelivered message header field to be set or the JMSXDeliveryCount message property to be incremented.

        • CLIENT_ACKNOWLEDGE: The JMS provider will behave as if the call to receiveBodyNoWait had been successful and will not deliver the message again.

          As with any message that is delivered with a session mode of CLIENT_ACKNOWLEDGE, the message will not be acknowledged until acknowledge is called on the JMSContext. If an application wishes to have the failed message redelivered, it must call recover on the JMSContext. The redelivered message's JMSRedelivered message header field will be set and its JMSXDeliveryCount message property will be incremented.

        • Transacted session: The JMS provider will behave as if the call to receiveBodyNoWait had been successful and will not deliver the message again.

          As with any message that is delivered in a transacted session, the transaction will remain uncommitted until the transaction is committed or rolled back by the application. If an application wishes to have the failed message redelivered, it must roll back the transaction. The redelivered message's JMSRedelivered message header field will be set and its JMSXDeliveryCount message property will be incremented.

        Parameters:
        c - The type to which the body of the next message should be assigned.
        If the next message is expected to be a TextMessage then this should be set to String.class or another class to which a String is assignable.
        If the next message is expected to be a ObjectMessage then this should be set to java.io.Serializable.class or another class to which the body is assignable.
        If the next message is expected to be a MapMessage then this should be set to java.util.Map.class (or java.lang.Object.class).
        If the next message is expected to be a BytesMessage then this should be set to byte[].class (or java.lang.Object.class).
        Returns:
        the body of the next message produced for this JMSConsumer, or null if one is not immediately available or this JMSConsumer is concurrently closed
        Throws:
        MessageFormatRuntimeException -
        • if the message is not one of the supported types listed above
        • if the message body cannot be assigned to the specified type
        • if the message has no body
        • if the message is an ObjectMessage and object deserialization fails.
        JMSRuntimeException - if the JMS provider fails to receive the next message due to some internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface JMSContext

  • All Superinterfaces:
    AutoCloseable
    All Known Subinterfaces:
    XAJMSContext

    public interface JMSContext
extends AutoCloseable
    A JMSContext is the main interface in the simplified JMS API introduced for JMS 2.0. This combines in a single object the functionality of two separate objects from the JMS 1.1 API: a Connection and a Session.

    When an application needs to send messages it use the createProducer method to create a JMSProducer which provides methods to configure and send messages. Messages may be sent either synchronously or asynchronously.

    When an application needs to receive messages it uses one of several createConsumer or createDurableConsumer methods to create a JMSConsumer . A JMSConsumer provides methods to receive messages either synchronously or asynchronously.

    In terms of the JMS 1.1 API a JMSContext should be thought of as representing both a Connection and a Session. Although the simplified API removes the need for applications to use those objects, the concepts of connection and session remain important. A connection represents a physical link to the JMS server and a session represents a single-threaded context for sending and receiving messages.

    A JMSContext may be created by calling one of several createContext methods on a ConnectionFactory. A JMSContext that is created in this way is described as being application-managed. An application-managed JMSContext must be closed when no longer needed by calling its close method.

    Applications running in the Java EE web and EJB containers may alternatively inject a JMSContext into their application using the @Inject annotation. A JMSContext that is created in this way is described as being container-managed. A container-managed JMSContext will be closed automatically by the container.

    Applications running in the Java EE web and EJB containers are not permitted to create more than one active session on a connection so combining them in a single object takes advantage of this restriction to offer a simpler API.

    However applications running in a Java SE environment or in the Java EE application client container are permitted to create multiple active sessions on the same connection. This allows the same physical connection to be used in multiple threads simultaneously. Such applications which require multiple sessions to be created on the same connection should use one of the createContext methods on the ConnectionFactory to create the first JMSContext and then use the createContext method on JMSContext to create additional JMSContext objects that use the same connection. All these JMSContext objects are application-managed and must be closed when no longer needed by calling their close method.

    Since:
    JMS 2.0
    Version:
    JMS 2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int AUTO_ACKNOWLEDGE
      With this session mode, the JMSContext's session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.
      static int CLIENT_ACKNOWLEDGE
      With this session mode, the client acknowledges a consumed message by calling the message's acknowledge method.
      static int DUPS_OK_ACKNOWLEDGE
      This session mode instructs the JMSContext's session to lazily acknowledge the delivery of messages.
      static int SESSION_TRANSACTED
      This session mode instructs the JMSContext's session to deliver and consume messages in a local transaction which will be subsequently committed by calling commit or rolled back by calling rollback.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void acknowledge()
      Acknowledges all messages consumed by the JMSContext's session.
      void close()
      Closes the JMSContext
      void commit()
      Commits all messages done in this transaction and releases any locks currently held.
      QueueBrowser createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
      BytesMessage createBytesMessage()
      Creates a BytesMessage object.
      JMSConsumer createConsumer(Destination destination)
      Creates a JMSConsumer for the specified destination.
      JMSConsumer createConsumer(Destination destination, String messageSelector)
      Creates a JMSConsumer for the specified destination, using a message selector.
      JMSConsumer createConsumer(Destination destination, String messageSelector, boolean noLocal)
      Creates a JMSConsumer for the specified destination, specifying a message selector and the noLocal parameter.
      JMSContext createContext(int sessionMode)
      Creates a new JMSContext with the specified session mode using the same connection as this JMSContext and creating a new session.
      JMSConsumer createDurableConsumer(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      JMSConsumer createDurableConsumer(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      MapMessage createMapMessage()
      Creates a MapMessage object.
      Message createMessage()
      Creates a Message object.
      ObjectMessage createObjectMessage()
      Creates an ObjectMessage object.
      ObjectMessage createObjectMessage(Serializable object)
      Creates an initialized ObjectMessage object.
      JMSProducer createProducer()
      Creates a new JMSProducer object which can be used to configure and send messages
      Queue createQueue(String queueName)
      Creates a Queue object which encapsulates a specified provider-specific queue name.
      JMSConsumer createSharedConsumer(Topic topic, String sharedSubscriptionName)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription.
      JMSConsumer createSharedConsumer(Topic topic, String sharedSubscriptionName, String messageSelector)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.
      JMSConsumer createSharedDurableConsumer(Topic topic, String name)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.
      JMSConsumer createSharedDurableConsumer(Topic topic, String name, String messageSelector)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.
      StreamMessage createStreamMessage()
      Creates a StreamMessage object.
      TemporaryQueue createTemporaryQueue()
      Creates a TemporaryQueue object.
      TemporaryTopic createTemporaryTopic()
      Creates a TemporaryTopic object.
      TextMessage createTextMessage()
      Creates a TextMessage object.
      TextMessage createTextMessage(String text)
      Creates an initialized TextMessage object.
      Topic createTopic(String topicName)
      Creates a Topic object which encapsulates a specified provider-specific topic name.
      boolean getAutoStart()
      Returns whether the underlying connection used by this JMSContext will be started automatically when a consumer is created.
      String getClientID()
      Gets the client identifier for the JMSContext's connection.
      ExceptionListener getExceptionListener()
      Gets the ExceptionListener object for the JMSContext's connection.
      ConnectionMetaData getMetaData()
      Gets the connection metadata for the JMSContext's connection.
      int getSessionMode()
      Returns the session mode of the JMSContext's session.
      boolean getTransacted()
      Indicates whether the JMSContext's session is in transacted mode.
      void recover()
      Stops message delivery in the JMSContext's session, and restarts message delivery with the oldest unacknowledged message.
      void rollback()
      Rolls back any messages done in this transaction and releases any locks currently held.
      void setAutoStart(boolean autoStart)
      Specifies whether the underlying connection used by this JMSContext will be started automatically when a consumer is created.
      void setClientID(String clientID)
      Sets the client identifier for the JMSContext's connection.
      void setExceptionListener(ExceptionListener listener)
      Sets an exception listener for the JMSContext's connection.
      void start()
      Starts (or restarts) delivery of incoming messages by the JMSContext's connection.
      void stop()
      Temporarily stops the delivery of incoming messages by the JMSContext's connection.
      void unsubscribe(String name)
      Unsubscribes a durable subscription that has been created by a client.

    • Field Detail

      • AUTO_ACKNOWLEDGE

        static final int AUTO_ACKNOWLEDGE
        With this session mode, the JMSContext's session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.
        See Also:
        Constant Field Values

      • CLIENT_ACKNOWLEDGE

        static final int CLIENT_ACKNOWLEDGE
        With this session mode, the client acknowledges a consumed message by calling the message's acknowledge method. Acknowledging a consumed message acknowledges all messages that the session has consumed.

        When this session mode is used, a client may build up a large number of unacknowledged messages while attempting to process them. A JMS provider should provide administrators with a way to limit client overrun so that clients are not driven to resource exhaustion and ensuing failure when some resource they are using is temporarily blocked.

        See Also:
        Message.acknowledge(), Constant Field Values

      • DUPS_OK_ACKNOWLEDGE

        static final int DUPS_OK_ACKNOWLEDGE
        This session mode instructs the JMSContext's session to lazily acknowledge the delivery of messages. This is likely to result in the delivery of some duplicate messages if the JMS provider fails, so it should only be used by consumers that can tolerate duplicate messages. Use of this mode can reduce session overhead by minimizing the work the session does to prevent duplicates.
        See Also:
        Constant Field Values

      • SESSION_TRANSACTED

        static final int SESSION_TRANSACTED
        This session mode instructs the JMSContext's session to deliver and consume messages in a local transaction which will be subsequently committed by calling commit or rolled back by calling rollback.
        See Also:
        Constant Field Values

    • Method Detail

      • createContext

        JMSContext createContext(int sessionMode)
        Creates a new JMSContext with the specified session mode using the same connection as this JMSContext and creating a new session.

        This method does not start the connection. If the connection has not already been started then it will be automatically started when a JMSConsumer is created on any of the JMSContext objects for that connection.

        • If sessionMode is set to JMSContext.SESSION_TRANSACTED then the session will use a local transaction which may subsequently be committed or rolled back by calling the JMSContext's commit or rollback methods.
        • If sessionMode is set to any of JMSContext.CLIENT_ACKNOWLEDGE, JMSContext.AUTO_ACKNOWLEDGE or JMSContext.DUPS_OK_ACKNOWLEDGE. then the session will be non-transacted and messages received by this session will be acknowledged according to the value of sessionMode. For a definition of the meaning of these acknowledgement modes see the links below.

        This method must not be used by applications running in the Java EE web or EJB containers because doing so would violate the restriction that such an application must not attempt to create more than one active (not closed) Session object per connection. If this method is called in a Java EE web or EJB container then a JMSRuntimeException will be thrown.

        Parameters:
        sessionMode - indicates which of four possible session modes will be used. The permitted values are JMSContext.SESSION_TRANSACTED, JMSContext.CLIENT_ACKNOWLEDGE, JMSContext.AUTO_ACKNOWLEDGE and JMSContext.DUPS_OK_ACKNOWLEDGE.
        Returns:
        a newly created JMSContext
        Throws:
        JMSRuntimeException - if the JMS provider fails to create the JMSContext due to
        • some internal error or
        • because this method is being called in a Java EE web or EJB application.
        Since:
        JMS 2.0
        See Also:
        SESSION_TRANSACTED, CLIENT_ACKNOWLEDGE, AUTO_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, ConnectionFactory.createContext(), ConnectionFactory.createContext(int), ConnectionFactory.createContext(java.lang.String, java.lang.String), ConnectionFactory.createContext(java.lang.String, java.lang.String, int), createContext(int)

      • createProducer

        JMSProducer createProducer()
        Creates a new JMSProducer object which can be used to configure and send messages
        Returns:
        A new JMSProducer object
        See Also:
        JMSProducer

      • getClientID

        String getClientID()
        Gets the client identifier for the JMSContext's connection.

        This value is specific to the JMS provider. It is either preconfigured by an administrator in a ConnectionFactory object or assigned dynamically by the application by calling the setClientID method.

        Returns:
        the unique client identifier
        Throws:
        JMSRuntimeException - if the JMS provider fails to return the client ID for the JMSContext's connection due to some internal error.

      • setClientID

        void setClientID(String clientID)
        Sets the client identifier for the JMSContext's connection.

        The preferred way to assign a JMS client's client identifier is for it to be configured in a client-specific ConnectionFactory object and transparently assigned to the Connection object it creates.

        Alternatively, a client can set the client identifier for the MessageContext's connection using a provider-specific value. The facility to set its client identifier explicitly is not a mechanism for overriding the identifier that has been administratively configured. It is provided for the case where no administratively specified identifier exists. If one does exist, an attempt to change it by setting it must throw an IllegalStateRuntimeException. If a client sets the client identifier explicitly, it must do so immediately after it creates the JMSContext and before any other action on the JMSContext is taken. After this point, setting the client identifier is a programming error that should throw an IllegalStateRuntimeException.

        The purpose of the client identifier is to associate the JMSContext's connection and its objects with a state maintained on behalf of the client by a provider. The only such state identified by the JMS API is that required to support durable subscriptions.

        If another connection with the same clientID is already running when this method is called, the JMS provider should detect the duplicate ID and throw an InvalidClientIDException.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSRuntimeException to be thrown though this is not guaranteed.

        This method must not be used if the JMSContext is container-managed (injected). Doing so will cause a IllegalStateRuntimeException to be thrown.

        Parameters:
        clientID - the unique client identifier
        Throws:
        InvalidClientIDRuntimeException - if the JMS client specifies an invalid or duplicate client ID.
        IllegalStateRuntimeException -
        • if the JMS client attempts to set the client ID for the JMSContext's connection at the wrong time or
        • if the client ID has been administratively configured or
        • if the JMSContext is container-managed (injected).
        JMSRuntimeException - if the JMS provider fails to set the client ID for the the JMSContext's connection for one of the following reasons:
        • an internal error has occurred or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)

      • getMetaData

        ConnectionMetaData getMetaData()
        Gets the connection metadata for the JMSContext's connection.
        Returns:
        the connection metadata
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the connection metadata
        See Also:
        ConnectionMetaData

      • getExceptionListener

        ExceptionListener getExceptionListener()
        Gets the ExceptionListener object for the JMSContext's connection. Not every Connection has an ExceptionListener associated with it.
        Returns:
        the ExceptionListener for the JMSContext's connection, or null if no ExceptionListener is associated with that connection.
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the ExceptionListener for the JMSContext's connection.
        See Also:
        Connection.setExceptionListener(javax.jms.ExceptionListener)

      • setExceptionListener

        void setExceptionListener(ExceptionListener listener)
        Sets an exception listener for the JMSContext's connection.

        If a JMS provider detects a serious problem with a connection, it informs the connection's ExceptionListener, if one has been registered. It does this by calling the listener's onException method, passing it a JMSRuntimeException object describing the problem.

        An exception listener allows a client to be notified of a problem asynchronously. Some connections only consume messages, so they would have no other way to learn their connection has failed.

        A connection serializes execution of its ExceptionListener.

        A JMS provider should attempt to resolve connection problems itself before it notifies the client of them.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSRuntimeException to be thrown though this is not guaranteed.

        This method must not be used if the JMSContext is container-managed (injected). Doing so will cause a IllegalStateRuntimeException to be thrown.

        Parameters:
        listener - the exception listener
        Throws:
        IllegalStateRuntimeException - if the JMSContext is container-managed (injected).
        JMSRuntimeException - if the JMS provider fails to set the exception listener for one of the following reasons:
        • an internal error has occurred or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)

      • start

        void start()
        Starts (or restarts) delivery of incoming messages by the JMSContext's connection. A call to start on a connection that has already been started is ignored.

        This method must not be used if the JMSContext is container-managed (injected). Doing so will cause a IllegalStateRuntimeException to be thrown.

        Throws:
        IllegalStateRuntimeException - if the JMSContext is container-managed (injected).
        JMSRuntimeException - if the JMS provider fails to start message delivery due to some internal error.
        See Also:
        stop()

      • stop

        void stop()
        Temporarily stops the delivery of incoming messages by the JMSContext's connection. Delivery can be restarted using the start method. When the connection is stopped, delivery to all the connection's message consumers is inhibited: synchronous receives block, and messages are not delivered to message listeners.

        This call blocks until receives and/or message listeners in progress have completed.

        Stopping a connection has no effect on its ability to send messages. A call to stop on a connection that has already been stopped is ignored.

        A call to stop must not return until delivery of messages has paused. This means that a client can rely on the fact that none of its message listeners will be called and that all threads of control waiting for receive calls to return will not return with a message until the connection is restarted. The receive timers for a stopped connection continue to advance, so receives may time out while the connection is stopped.

        If message listeners are running when stop is invoked, the stop call must wait until all of them have returned before it may return. While these message listeners are completing, they must have the full services of the connection available to them.

        A message listener must not attempt to stop its own JMSContext as this would lead to deadlock. The JMS provider must detect this and throw a IllegalStateRuntimeException

        For the avoidance of doubt, if an exception listener for the JMSContext's connection is running when stop is invoked, there is no requirement for the stop call to wait until the exception listener has returned before it may return.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSRuntimeException to be thrown though this is not guaranteed.

        This method must not be used if the JMSContext is container-managed (injected). Doing so will cause a IllegalStateRuntimeException to be thrown.

        Throws:
        IllegalStateRuntimeException -
        • if this method has been called by a MessageListener on its own JMSContext
        • if the JMSContext is container-managed (injected).
        JMSRuntimeException - if the JMS provider fails to stop message delivery for one of the following reasons:
        • an internal error has occurred or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        See Also:
        start()

      • setAutoStart

        void setAutoStart(boolean autoStart)
        Specifies whether the underlying connection used by this JMSContext will be started automatically when a consumer is created. This is the default behaviour, and it may be disabled by calling this method with a value of false.

        This method does not itself either start or stop the connection.

        This method must not be used if the JMSContext is container-managed (injected). Doing so will cause a IllegalStateRuntimeException to be thrown.

        Parameters:
        autoStart - Whether the underlying connection used by this JMSContext will be automatically started when a consumer is created.
        Throws:
        IllegalStateRuntimeException - if the JMSContext is container-managed (injected)
        See Also:
        getAutoStart()

      • getAutoStart

        boolean getAutoStart()
        Returns whether the underlying connection used by this JMSContext will be started automatically when a consumer is created.
        Returns:
        whether the underlying connection used by this JMSContext will be started automatically when a consumer is created.
        See Also:
        setAutoStart(boolean)

      • close

        void close()
        Closes the JMSContext

        This closes the underlying session and any underlying producers and consumers. If there are no other active (not closed) JMSContext objects using the underlying connection then this method also closes the underlying connection.

        Since a provider typically allocates significant resources outside the JVM on behalf of a connection, clients should close these resources when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

        Closing a connection causes all temporary destinations to be deleted.

        When this method is invoked, it should not return until message processing has been shut down in an orderly fashion. This means that all message listeners that may have been running have returned, and that all pending receives have returned. A close terminates all pending message receives on the connection's sessions' consumers. The receives may return with a message or with null, depending on whether there was a message available at the time of the close. If one or more of the connection's sessions' message listeners is processing a message at the time when connection close is invoked, all the facilities of the connection and its sessions must remain available to those listeners until they return control to the JMS provider.

        This method must not return until any incomplete asynchronous send operations for this JMSContext have been completed and any CompletionListener callbacks have returned. Incomplete sends should be allowed to complete normally unless an error occurs.

        For the avoidance of doubt, if an exception listener for the JMSContext's connection is running when close is invoked, there is no requirement for the close call to wait until the exception listener has returned before it may return.

        Closing a connection causes any of its sessions' transactions in progress to be rolled back. In the case where a session's work is coordinated by an external transaction manager, a session's commit and rollback methods are not used and the result of a closed session's work is determined later by the transaction manager.

        Closing a connection does NOT force an acknowledgment of client-acknowledged sessions.

        Invoking the acknowledge method of a received message from a closed connection's session must throw an IllegalStateRuntimeException. Closing a closed connection must NOT throw an exception.

        A MessageListener must not attempt to close its own JMSContext as this would lead to deadlock. The JMS provider must detect this and throw a IllegalStateRuntimeException.

        A CompletionListener callback method must not call close on its own JMSContext. Doing so will cause an IllegalStateRuntimeException to be thrown.

        This method must not be used if the JMSContext is container-managed (injected). Doing so will cause a IllegalStateRuntimeException to be thrown.

        Specified by:
        close in interface AutoCloseable
        Throws:
        IllegalStateRuntimeException -
        • if this method has been called by a MessageListener on its own JMSContext
        • if this method has been called by a CompletionListener callback method on its own JMSContext
        • if the JMSContext is container-managed (injected)
        JMSRuntimeException - if the JMS provider fails to close the JMSContext due to some internal error. For example, a failure to release resources or to close a socket connection can cause this exception to be thrown.

      • createBytesMessage

        BytesMessage createBytesMessage()
        Creates a BytesMessage object. A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.
        Throws:
        JMSRuntimeException - if the JMS provider fails to create this message due to some internal error.

      • createMapMessage

        MapMessage createMapMessage()
        Creates a MapMessage object. A MapMessage object is used to send a self-defining set of name-value pairs, where names are String objects and values are primitive values in the Java programming language.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSRuntimeException - if the JMS provider fails to create this message due to some internal error.

      • createMessage

        Message createMessage()
        Creates a Message object. The Message interface is the root interface of all JMS messages. A Message object holds all the standard message header information. It can be sent when a message containing only header information is sufficient.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSRuntimeException - if the JMS provider fails to create this message due to some internal error.

      • createObjectMessage

        ObjectMessage createObjectMessage()
        Creates an ObjectMessage object. An ObjectMessage object is used to send a message that contains a serializable Java object.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSRuntimeException - if the JMS provider fails to create this message due to some internal error.

      • createObjectMessage

        ObjectMessage createObjectMessage(Serializable object)
        Creates an initialized ObjectMessage object. An ObjectMessage object is used to send a message that contains a serializable Java object.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Parameters:
        object - the object to use to initialize this message
        Throws:
        JMSRuntimeException - if the JMS provider fails to create this message due to some internal error.

      • createStreamMessage

        StreamMessage createStreamMessage()
        Creates a StreamMessage object. A StreamMessage object is used to send a self-defining stream of primitive values in the Java programming language.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSRuntimeException - if the JMS provider fails to create this message due to some internal error.

      • createTextMessage

        TextMessage createTextMessage()
        Creates a TextMessage object. A TextMessage object is used to send a message containing a String object.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSRuntimeException - if the JMS provider fails to create this message due to some internal error.

      • createTextMessage

        TextMessage createTextMessage(String text)
        Creates an initialized TextMessage object. A TextMessage object is used to send a message containing a String.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Parameters:
        text - the string used to initialize this message
        Throws:
        JMSRuntimeException - if the JMS provider fails to create this message due to some internal error.

      • getTransacted

        boolean getTransacted()
        Indicates whether the JMSContext's session is in transacted mode.
        Returns:
        true if the session is in transacted mode
        Throws:
        JMSRuntimeException - if the JMS provider fails to return the transaction mode due to some internal error.

      • getSessionMode

        int getSessionMode()
        Returns the session mode of the JMSContext's session. This can be set at the time that the JMSContext is created. Possible values are JMSContext.SESSION_TRANSACTED, JMSContext.AUTO_ACKNOWLEDGE, JMSContext.CLIENT_ACKNOWLEDGE and JMSContext.DUPS_OK_ACKNOWLEDGE

        If a session mode was not specified when the JMSContext was created a value of JMSContext.AUTO_ACKNOWLEDGE will be returned.

        Returns:
        the session mode of the JMSContext's session
        Throws:
        JMSRuntimeException - if the JMS provider fails to return the acknowledgment mode due to some internal error.
        Since:
        JMS 2.0
        See Also:
        Connection.createSession(boolean, int)

      • commit

        void commit()
        Commits all messages done in this transaction and releases any locks currently held.

        This method must not return until any incomplete asynchronous send operations for this JMSContext have been completed and any CompletionListener callbacks have returned. Incomplete sends should be allowed to complete normally unless an error occurs.

        A CompletionListener callback method must not call commit on its own JMSContext. Doing so will cause an IllegalStateRuntimeException to be thrown.

        This method must not be used if the JMSContext is container-managed (injected). Doing so will cause a IllegalStateRuntimeException to be thrown.

        Throws:
        IllegalStateRuntimeException -
        • if the JMSContext's session is not using a local transaction
        • if this method has been called by a CompletionListener callback method on its own JMSContext
        • if the JMSContext is container-managed (injected)
        TransactionRolledBackRuntimeException - if the transaction is rolled back due to some internal error during commit.
        JMSRuntimeException - if the JMS provider fails to commit the transaction due to some internal error

      • rollback

        void rollback()
        Rolls back any messages done in this transaction and releases any locks currently held.

        This method must not return until any incomplete asynchronous send operations for this JMSContext have been completed and any CompletionListener callbacks have returned. Incomplete sends should be allowed to complete normally unless an error occurs.

        A CompletionListener callback method must not call rollback on its own JMSContext. Doing so will cause an IllegalStateRuntimeException to be thrown.

        This method must not be used if the JMSContext is container-managed (injected). Doing so will cause a IllegalStateRuntimeException to be thrown.

        Throws:
        IllegalStateRuntimeException -
        • if the JMSContext's session is not using a local transaction
        • if this method has been called by a CompletionListener callback method on its own JMSContext
        • if the JMSContext is container-managed (injected)
        JMSRuntimeException - if the JMS provider fails to roll back the transaction due to some internal error

      • recover

        void recover()
        Stops message delivery in the JMSContext's session, and restarts message delivery with the oldest unacknowledged message.

        All consumers deliver messages in a serial order. Acknowledging a received message automatically acknowledges all messages that have been delivered to the client.

        Restarting a session causes it to take the following actions:

        • Stop message delivery
        • Mark all messages that might have been delivered but not acknowledged as "redelivered"
        • Restart the delivery sequence including all unacknowledged messages that had been previously delivered. Redelivered messages do not have to be delivered in exactly their original delivery order.

        This method must not be used if the JMSContext is container-managed (injected). Doing so will cause a IllegalStateRuntimeException to be thrown.

        Throws:
        IllegalStateRuntimeException -
        • if the JMSContext's session is using a transaction
        • if the JMSContext is container-managed (injected)
        JMSRuntimeException - if the JMS provider fails to stop and restart message delivery due to some internal error

      • createConsumer

        JMSConsumer createConsumer(Destination destination)
        Creates a JMSConsumer for the specified destination.

        A client uses a JMSConsumer object to receive messages that have been sent to a destination.

        Parameters:
        destination - the Destination to access.
        Throws:
        JMSRuntimeException - if the session fails to create a JMSConsumer due to some internal error.
        InvalidDestinationRuntimeException - if an invalid destination is specified.

      • createConsumer

        JMSConsumer createConsumer(Destination destination,
                         String messageSelector)
        Creates a JMSConsumer for the specified destination, using a message selector.

        A client uses a JMSConsumer object to receive messages that have been sent to a destination.

        Parameters:
        destination - the Destination to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the JMSConsumer.
        Throws:
        JMSRuntimeException - if the session fails to create a JMSConsumer due to some internal error.
        InvalidDestinationRuntimeException - if an invalid destination is specified.
        InvalidSelectorRuntimeException - if the message selector is invalid.

      • createConsumer

        JMSConsumer createConsumer(Destination destination,
                         String messageSelector,
                         boolean noLocal)
        Creates a JMSConsumer for the specified destination, specifying a message selector and the noLocal parameter.

        A client uses a JMSConsumer object to receive messages that have been sent to a destination.

        The noLocal argument is for use when the destination is a topic and the JMSContext's connection is also being used to publish messages to that topic. If noLocal is set to true then the JMSConsumer will not receive messages published to the topic by its own connection. The default value of this argument is false. If the destination is a queue then the effect of setting noLocal to true is not specified.

        Parameters:
        destination - the Destination to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the JMSConsumer.
        noLocal - if true, and the destination is a topic, then the JMSConsumer will not receive messages published to the topic by its own connection
        Throws:
        JMSRuntimeException - if the session fails to create a JMSConsumer due to some internal error.
        InvalidDestinationRuntimeException - if an invalid destination is specified.
        InvalidSelectorRuntimeException - if the message selector is invalid.

      • createQueue

        Queue createQueue(String queueName)
        Creates a Queue object which encapsulates a specified provider-specific queue name.

        The use of provider-specific queue names in an application may render the application non-portable. Portable applications are recommended to not use this method but instead look up an administratively-defined Queue object using JNDI.

        Note that this method simply creates an object that encapsulates the name of a queue. It does not create the physical queue in the JMS provider. JMS does not provide a method to create the physical queue, since this would be specific to a given JMS provider. Creating a physical queue is provider-specific and is typically an administrative task performed by an administrator, though some providers may create them automatically when needed. The one exception to this is the creation of a temporary queue, which is done using the createTemporaryQueue method.

        Parameters:
        queueName - A provider-specific queue name
        Returns:
        a Queue object which encapsulates the specified name
        Throws:
        JMSRuntimeException - if a Queue object cannot be created due to some internal error

      • createTopic

        Topic createTopic(String topicName)
        Creates a Topic object which encapsulates a specified provider-specific topic name.

        The use of provider-specific topic names in an application may render the application non-portable. Portable applications are recommended to not use this method but instead look up an administratively-defined Topic object using JNDI.

        Note that this method simply creates an object that encapsulates the name of a topic. It does not create the physical topic in the JMS provider. JMS does not provide a method to create the physical topic, since this would be specific to a given JMS provider. Creating a physical topic is provider-specific and is typically an administrative task performed by an administrator, though some providers may create them automatically when needed. The one exception to this is the creation of a temporary topic, which is done using the createTemporaryTopic method.

        Parameters:
        topicName - A provider-specific topic name
        Returns:
        a Topic object which encapsulates the specified name
        Throws:
        JMSRuntimeException - if a Topic object cannot be created due to some internal error

      • createDurableConsumer

        JMSConsumer createDurableConsumer(Topic topic,
                                String name)
        Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription. This method creates the durable subscription without a message selector and with a noLocal value of false.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with unshared durable subscriptions. Any durable subscription created using this method will be unshared. This means that only one active (i.e. not closed) consumer on the subscription may exist at a time. The term "consumer" here means a TopicSubscriber, MessageConsumer or JMSConsumer object in any client.

        An unshared durable subscription is identified by a name specified by the client and by the client identifier, which must be set. An application which subsequently wishes to create a consumer on that unshared durable subscription must use the same client identifier.

        If an unshared durable subscription already exists with the same name and client identifier, and the same topic, message selector and noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this method creates a JMSConsumer on the existing durable subscription.

        If an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active (i.e. not closed) on the durable subscription, then a JMSRuntimeException will be thrown.

        If an unshared durable subscription already exists with the same name and client identifier but a different topic, message selector or noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this is equivalent to unsubscribing (deleting) the old one and creating a new one.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier. If a shared durable subscription already exists with the same name and client identifier then a JMSRuntimeException is thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId. Such subscriptions would be completely separate.

        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        Throws:
        InvalidDestinationRuntimeException - if an invalid topic is specified.
        IllegalStateRuntimeException - if the client identifier is unset
        JMSRuntimeException -
        • if the session fails to create the non-shared durable subscription and JMSConsumer due to some internal error
        • if an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active
        • if a shared durable subscription already exists with the same name and client identifier
        Since:
        JMS 2.0

      • createDurableConsumer

        JMSConsumer createDurableConsumer(Topic topic,
                                String name,
                                String messageSelector,
                                boolean noLocal)
        Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with unshared durable subscriptions. Any durable subscription created using this method will be unshared. This means that only one active (i.e. not closed) consumer on the subscription may exist at a time. The term "consumer" here means a TopicSubscriber, MessageConsumer or JMSConsumer object in any client.

        An unshared durable subscription is identified by a name specified by the client and by the client identifier, which must be set. An application which subsequently wishes to create a consumer on that unshared durable subscription must use the same client identifier.

        If an unshared durable subscription already exists with the same name and client identifier, and the same topic, message selector and noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this method creates a JMSConsumer on the existing durable subscription.

        If an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active (i.e. not closed) on the durable subscription, then a JMSRuntimeException will be thrown.

        If an unshared durable subscription already exists with the same name and client identifier but a different topic, message selector or noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this is equivalent to unsubscribing (deleting) the old one and creating a new one.

        If noLocal is set to true then any messages published to the topic using this JMSContext's connection, or any other connection with the same client identifier, will not be added to the durable subscription.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier. If a shared durable subscription already exists with the same name and client identifier then a JMSRuntimeException is thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId. Such subscriptions would be completely separate.

        This method is identical to the corresponding createDurableSubscriber method except that it returns a MessageConsumer rather than a TopicSubscriber to represent the consumer.

        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        messageSelector - only messages with properties matching the message selector expression are added to the durable subscription. A value of null or an empty string indicates that there is no message selector for the durable subscription.
        noLocal - if true then any messages published to the topic using this session's connection, or any other connection with the same client identifier, will not be added to the durable subscription.
        Throws:
        InvalidDestinationRuntimeException - if an invalid topic is specified.
        InvalidSelectorRuntimeException - if the message selector is invalid.
        IllegalStateRuntimeException - if the client identifier is unset
        JMSRuntimeException -
        • if the session fails to create the non-shared durable subscription and JMSConsumer due to some internal error
        • if an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active
        • if a shared durable subscription already exists with the same name and client identifier
        Since:
        JMS 2.0

      • createSharedDurableConsumer

        JMSConsumer createSharedDurableConsumer(Topic topic,
                                      String name)
        Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription. This method creates the durable subscription without a message selector.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with shared durable subscriptions. Any durable subscription created using this method will be shared. This means that multiple active (i.e. not closed) consumers on the subscription may exist at the same time. The term "consumer" here means a MessageConsumer or JMSConsumer object in any client.

        A shared durable subscription is identified by a name specified by the client and by the client identifier (which may be unset). An application which subsequently wishes to create a consumer on that shared durable subscription must use the same client identifier.

        If a shared durable subscription already exists with the same name and client identifier (if set), and the same topic and message selector has been specified, then this method creates a JMSConsumer on the existing shared durable subscription.

        If a shared durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this is equivalent to unsubscribing (deleting) the old one and creating a new one.

        If a shared durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector has been specified, and there is a consumer already active (i.e. not closed) on the durable subscription, then a JMSRuntimeException will be thrown.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier (if set). If an unshared durable subscription already exists with the same name and client identifier (if set) then a JMSRuntimeException is thrown.

        If a message selector is specified then only messages with properties matching the message selector expression will be added to the subscription.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId (which may be unset). Such subscriptions would be completely separate.

        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        Throws:
        InvalidDestinationRuntimeException - if an invalid topic is specified.
        JMSRuntimeException -
        • if the session fails to create the shared durable subscription and MessageConsumer due to some internal error
        • if a shared durable subscription already exists with the same name and client identifier, but a different topic, or message selector, and there is a consumer already active
        • if an unshared durable subscription already exists with the same name and client identifier
        Since:
        JMS 2.0

      • createSharedDurableConsumer

        JMSConsumer createSharedDurableConsumer(Topic topic,
                                      String name,
                                      String messageSelector)
        Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with shared durable subscriptions. Any durable subscription created using this method will be shared. This means that multiple active (i.e. not closed) consumers on the subscription may exist at the same time. The term "consumer" here means a MessageConsumer or JMSConsumer object in any client.

        A shared durable subscription is identified by a name specified by the client and by the client identifier (which may be unset). An application which subsequently wishes to create a consumer on that shared durable subscription must use the same client identifier.

        If a shared durable subscription already exists with the same name and client identifier (if set), and the same topic and message selector have been specified, then this method creates a JMSConsumer on the existing shared durable subscription.

        If a shared durable subscription already exists with the same name and client identifier (if set), but a different topic or message selector has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this is equivalent to unsubscribing (deleting) the old one and creating a new one.

        If a shared durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector has been specified, and there is a consumer already active (i.e. not closed) on the durable subscription, then a JMSRuntimeException will be thrown.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier (if set). If an unshared durable subscription already exists with the same name and client identifier (if set) then a JMSRuntimeException is thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId (which may be unset). Such subscriptions would be completely separate.

        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        messageSelector - only messages with properties matching the message selector expression are added to the durable subscription. A value of null or an empty string indicates that there is no message selector for the durable subscription.
        Throws:
        InvalidDestinationRuntimeException - if an invalid topic is specified.
        InvalidSelectorRuntimeException - if the message selector is invalid.
        JMSRuntimeException -
        • if the session fails to create the shared durable subscription and JMSConsumer due to some internal error
        • if a shared durable subscription already exists with the same name and client identifier, but a different topic, or message selector, and there is a consumer already active
        • if an unshared durable subscription already exists with the same name and client identifier
        Since:
        JMS 2.0

      • createSharedConsumer

        JMSConsumer createSharedConsumer(Topic topic,
                               String sharedSubscriptionName)
        Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription. This method creates the non-durable subscription without a message selector.

        If a shared non-durable subscription already exists with the same name and client identifier (if set), and the same topic and message selector has been specified, then this method creates a JMSConsumer on the existing subscription.

        A non-durable shared subscription is used by a client which needs to be able to share the work of receiving messages from a topic subscription amongst multiple consumers. A non-durable shared subscription may therefore have more than one consumer. Each message from the subscription will be delivered to only one of the consumers on that subscription. Such a subscription is not persisted and will be deleted (together with any undelivered messages associated with it) when there are no consumers on it. The term "consumer" here means a MessageConsumer or JMSConsumer object in any client.

        A shared non-durable subscription is identified by a name specified by the client and by the client identifier (which may be unset). An application which subsequently wishes to create a consumer on that shared non-durable subscription must use the same client identifier.

        If a shared non-durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector value has been specified, and there is a consumer already active (i.e. not closed) on the subscription, then a JMSRuntimeException will be thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId (which may be unset). Such subscriptions would be completely separate.

        Parameters:
        topic - the Topic to subscribe to
        sharedSubscriptionName - the name used to identify the shared non-durable subscription
        Throws:
        JMSRuntimeException - if the session fails to create the shared non-durable subscription and JMSContext due to some internal error.
        InvalidDestinationRuntimeException - if an invalid topic is specified.
        InvalidSelectorRuntimeException - if the message selector is invalid.

      • createSharedConsumer

        JMSConsumer createSharedConsumer(Topic topic,
                               String sharedSubscriptionName,
                               String messageSelector)
        Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.

        If a shared non-durable subscription already exists with the same name and client identifier (if set), and the same topic and message selector has been specified, then this method creates a JMSConsumer on the existing subscription.

        A non-durable shared subscription is used by a client which needs to be able to share the work of receiving messages from a topic subscription amongst multiple consumers. A non-durable shared subscription may therefore have more than one consumer. Each message from the subscription will be delivered to only one of the consumers on that subscription. Such a subscription is not persisted and will be deleted (together with any undelivered messages associated with it) when there are no consumers on it. The term "consumer" here means a MessageConsumer or JMSConsumer object in any client.

        A shared non-durable subscription is identified by a name specified by the client and by the client identifier (which may be unset). An application which subsequently wishes to create a consumer on that shared non-durable subscription must use the same client identifier.

        If a shared non-durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector has been specified, and there is a consumer already active (i.e. not closed) on the subscription, then a JMSRuntimeException will be thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId (which may be unset). Such subscriptions would be completely separate.

        Parameters:
        topic - the Topic to subscribe to
        sharedSubscriptionName - the name used to identify the shared non-durable subscription
        messageSelector - only messages with properties matching the message selector expression are added to the shared non-durable subscription. A value of null or an empty string indicates that there is no message selector for the shared non-durable subscription.
        Throws:
        JMSRuntimeException - if the session fails to create the shared non-durable subscription and JMSConsumer due to some internal error.
        InvalidDestinationRuntimeException - if an invalid topic is specified.
        InvalidSelectorRuntimeException - if the message selector is invalid.

      • createBrowser

        QueueBrowser createBrowser(Queue queue)
        Creates a QueueBrowser object to peek at the messages on the specified queue.
        Parameters:
        queue - the queue to access
        Throws:
        JMSRuntimeException - if the session fails to create a browser due to some internal error.
        InvalidRuntimeDestinationException - if an invalid destination is specified

      • createBrowser

        QueueBrowser createBrowser(Queue queue,
                         String messageSelector)
        Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
        Parameters:
        queue - the queue to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        Throws:
        JMSRuntimeException - if the session fails to create a browser due to some internal error.
        InvalidRuntimeDestinationException - if an invalid destination is specified
        InvalidRuntimeSelectorException - if the message selector is invalid.

      • createTemporaryQueue

        TemporaryQueue createTemporaryQueue()
        Creates a TemporaryQueue object. Its lifetime will be that of the JMSContext's Connection unless it is deleted earlier.
        Returns:
        a temporary queue identity
        Throws:
        JMSRuntimeException - if the session fails to create a temporary queue due to some internal error.

      • createTemporaryTopic

        TemporaryTopic createTemporaryTopic()
        Creates a TemporaryTopic object. Its lifetime will be that of the JMSContext's Connection unless it is deleted earlier.
        Returns:
        a temporary topic identity
        Throws:
        JMSRuntimeException - if the session fails to create a temporary topic due to some internal error.

      • unsubscribe

        void unsubscribe(String name)
        Unsubscribes a durable subscription that has been created by a client.

        This method deletes the state being maintained on behalf of the subscriber by its provider.

        A durable subscription is identified by a name specified by the client and by the client identifier if set. If the client identifier was set when the durable subscription was created then a client which subsequently wishes to use this method to delete a durable subscription must use the same client identifier.

        It is erroneous for a client to delete a durable subscription while there is an active (not closed) consumer on that subscription, or while a consumed message is part of a pending transaction or has not been acknowledged in the session.

        If the active consumer is represented by a JMSConsumer then calling close on either that object or the JMSContext used to create it will render the consumer inactive and allow the subscription to be deleted.

        If the active consumer was created by calling setMessageListener on the JMSContext then calling close on the JMSContext will render the consumer inactive and allow the subscription to be deleted.

        If the active consumer is represented by a MessageConsumer or TopicSubscriber then calling close on that object or on the Session or Connection used to create it will render the consumer inactive and allow the subscription to be deleted.

        Parameters:
        name - the name used to identify this subscription
        Throws:
        JMSRuntimeException - if the session fails to unsubscribe to the durable subscription due to some internal error.
        InvalidDestinationRuntimeException - if an invalid subscription name is specified.

      • acknowledge

        void acknowledge()
        Acknowledges all messages consumed by the JMSContext's session.

        This method is for use when the session has an acknowledgement mode of CLIENT_ACKNOWLEDGE. If the session is transacted or has an acknowledgement mode of AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE calling this method has no effect.

        This method has identical behaviour to the acknowledge method on Message. A client may individually acknowledge each message as it is consumed, or it may choose to acknowledge messages as an application-defined group. In both cases it makes no difference which of these two methods is used.

        Messages that have been received but not acknowledged may be redelivered.

        This method must not be used if the JMSContext is container-managed (injected). Doing so will cause a IllegalStateRuntimeException to be thrown.

        Throws:
        IllegalStateRuntimeException -
        • if the JMSContext is closed.
        • if the JMSContext is container-managed (injected)
        JMSRuntimeException - if the JMS provider fails to acknowledge the messages due to some internal error
        See Also:
        Session.CLIENT_ACKNOWLEDGE, Message.acknowledge()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSDestinationDefinition (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jms

Annotation Type JMSDestinationDefinition

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface JMSDestinationDefinition
    An application may use this annotation to specify a JMS Destination resource that it requires in its operational environment. This provides information that can be used at the application's deployment to provision the required resource and allows an application to be deployed into a Java EE environment with more minimal administrative configuration.

    The Destination resource may be configured by setting the annotation elements for commonly used properties. Additional properties may be specified using the properties element. Once defined, a Destination resource may be referenced by a component in the same way as any other Destination resource, for example by using the lookup element of the Resource annotation.

    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Resource

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String interfaceName
      Fully qualified name of the JMS destination interface.
      String name
      JNDI name of the destination resource being defined.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String className
      Fully-qualified name of the JMS destination implementation class.
      String description
      Description of this JMS destination.
      String destinationName
      Name of the queue or topic.
      String[] properties
      JMS destination property.
      String resourceAdapter
      Resource adapter name.

    • Element Detail

      • name

        public abstract String name
        JNDI name of the destination resource being defined.

      • interfaceName

        public abstract String interfaceName
        Fully qualified name of the JMS destination interface. Permitted values are javax.jms.Queue or javax.jms.Topic.

      • description

        public abstract String description
        Description of this JMS destination.
        Default:
        ""

      • className

        public abstract String className
        Fully-qualified name of the JMS destination implementation class. Ignored if a resource adapter is used unless the resource adapter defines more than one JMS destination implementation class for the specified interface
        Default:
        ""

      • resourceAdapter

        public abstract String resourceAdapter
        Resource adapter name. If not specified then the application server will define the default behaviour, which may or may not involve the use of a resource adapter.
        Default:
        ""

      • destinationName

        public abstract String destinationName
        Name of the queue or topic.
        Default:
        ""

      • properties

        public abstract String[] properties
        JMS destination property. This may be a vendor-specific property or a less commonly used ConnectionFactory property.

        Properties are specified using the format: propertyName=propertyValue with one property per array element.

        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


JMSDestinationDefinitions (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jms

Annotation Type JMSDestinationDefinitions

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface JMSDestinationDefinitions
    Specifies one or more JMSDestinationDefinition annotations.
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    JMSDestinationDefinition

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      JMSDestinationDefinition[] value

    • Element Detail

      • value

        public abstract JMSDestinationDefinition[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


JMSException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class JMSException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    IllegalStateException, InvalidClientIDException, InvalidDestinationException, InvalidSelectorException, JMSSecurityException, MessageEOFException, MessageFormatException, MessageNotReadableException, MessageNotWriteableException, ResourceAllocationException, TransactionInProgressException, TransactionRolledBackException

    public class JMSException
extends Exception

    This is the root class of all checked exceptions in the JMS API.

    It provides the following information:

    • A provider-specific string describing the error. This string is the standard exception message and is available via the getMessage method.
    • A provider-specific string error code
    • A reference to another exception. Often a JMS API exception will be the result of a lower-level problem. If appropriate, this lower-level exception can be linked to the JMS API exception.
    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JMSException(String reason)
      Constructs a JMSException with the specified reason and with the error code defaulting to null.
      JMSException(String reason, String errorCode)
      Constructs a JMSException with the specified reason and error code.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getErrorCode()
      Gets the vendor-specific error code.
      Exception getLinkedException()
      Gets the exception linked to this one.
      void setLinkedException(Exception ex)
      Adds a linked Exception.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JMSException

        public JMSException(String reason,
            String errorCode)
        Constructs a JMSException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • JMSException

        public JMSException(String reason)
        Constructs a JMSException with the specified reason and with the error code defaulting to null.
        Parameters:
        reason - a description of the exception

    • Method Detail

      • getErrorCode

        public String getErrorCode()
        Gets the vendor-specific error code.
        Returns:
        a string specifying the vendor-specific error code

      • getLinkedException

        public Exception getLinkedException()
        Gets the exception linked to this one.
        Returns:
        the linked Exception, null if none

      • setLinkedException

        public void setLinkedException(Exception ex)
        Adds a linked Exception.
        Parameters:
        ex - the linked Exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSPasswordCredential (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jms

Annotation Type JMSPasswordCredential

  • @Retention(value=RUNTIME)
@Target(value={METHOD,FIELD,PARAMETER,TYPE})
public @interface JMSPasswordCredential
    This annotation may be used to specify the userName and password to be used when injecting a javax.jms.JMSContext object.
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    ConnectionFactory.createContext(java.lang.String, java.lang.String)

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String password
      Specifies the password to be used when injecting a javax.jms.JMSContext object
      String userName
      Specifies the userName to be used when injecting a javax.jms.JMSContext object

    • Element Detail

      • userName

        public abstract String userName
        Specifies the userName to be used when injecting a javax.jms.JMSContext object

      • password

        public abstract String password
        Specifies the password to be used when injecting a javax.jms.JMSContext object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


JMSProducer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface JMSProducer

  • public interface JMSProducer
    A JMSProducer is a simple object used to send messages on behalf of a JMSContext. An instance of JMSProducer is created by calling the createProducer method on a JMSContext. It provides various send methods to send a message to a specified destination. It also provides methods to allow message send options, message properties and message headers to be specified prior to sending a message or set of messages.

    Message send options may be specified using one or more of the following methods: setDeliveryMode, setPriority, setTimeToLive, setDeliveryDelay, setDisableMessageTimestamp, setDisableMessageID and setAsync.

    Message properties may be may be specified using one or more of nine setProperty methods. Any message properties set using these methods will override any message properties that have been set directly on the message.

    Message headers may be specified using one or more of the following methods: setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSType or setJMSReplyTo. Any message headers set using these methods will override any message headers that have been set directly on the message.

    All the above methods return the JMSProducer to allow method calls to be chained together, allowing a fluid programming style. For example:

    context.createProducer().setDeliveryMode(DeliveryMode.NON_PERSISTENT).setTimeToLive(1000).send(destination, message);

    Instances of JMSProducer are intended to be lightweight objects which can be created freely and which do not consume significant resources. This interface therefore does not provide a close method.

    Since:
    JMS 2.0
    Version:
    JMS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JMSProducer clearProperties()
      Clears any message properties set on this JMSProducer
      CompletionListener getAsync()
      If subsequent calls to send on this JMSProducer object have been configured to be asynchronous then this method returns the CompletionListener that has previously been configured.
      boolean getBooleanProperty(String name)
      Returns the message property with the specified name that has been set on this JMSProducer, converted to a boolean.
      byte getByteProperty(String name)
      Returns the message property with the specified name that has been set on this JMSProducer, converted to a String.
      long getDeliveryDelay()
      Gets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.
      int getDeliveryMode()
      Returns the delivery mode of messages that are sent using this JMSProducer
      boolean getDisableMessageID()
      Gets an indication of whether message IDs are disabled.
      boolean getDisableMessageTimestamp()
      Gets an indication of whether message timestamps are disabled.
      double getDoubleProperty(String name)
      Returns the message property with the specified name that has been set on this JMSProducer, converted to a double.
      float getFloatProperty(String name)
      Returns the message property with the specified name that has been set on this JMSProducer, converted to a float.
      int getIntProperty(String name)
      Returns the message property with the specified name that has been set on this JMSProducer, converted to a int.
      String getJMSCorrelationID()
      Returns the JMSCorrelationID header value that has been set on this JMSProducer, as a String.
      byte[] getJMSCorrelationIDAsBytes()
      Returns the JMSCorrelationID header value that has been set on this JMSProducer, as an array of bytes.
      Destination getJMSReplyTo()
      Returns the JMSReplyTo header value that has been set on this JMSProducer.
      String getJMSType()
      Returns the JMSType header value that has been set on this JMSProducer.
      long getLongProperty(String name)
      Returns the message property with the specified name that has been set on this JMSProducer, converted to a long.
      Object getObjectProperty(String name)
      Returns the message property with the specified name that has been set on this JMSProducer, converted to objectified format.
      int getPriority()
      Return the priority of messages that are sent using this JMSProducer
      Set<String> getPropertyNames()
      Returns an unmodifiable Set view of the names of all the message properties that have been set on this JMSProducer.
      short getShortProperty(String name)
      Returns the message property with the specified name that has been set on this JMSProducer, converted to a short.
      String getStringProperty(String name)
      Returns the message property with the specified name that has been set on this JMSProducer, converted to a String.
      long getTimeToLive()
      Returns the time to live of messages that are sent using this JMSProducer.
      boolean propertyExists(String name)
      Indicates whether a message property with the specified name has been set on this JMSProducer
      JMSProducer send(Destination destination, byte[] body)
      Send a BytesMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer send(Destination destination, Map<String,Object> body)
      Send a MapMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer send(Destination destination, Message message)
      Sends a message to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer send(Destination destination, Serializable body)
      Send an ObjectMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer send(Destination destination, String body)
      Send a TextMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer setAsync(CompletionListener completionListener)
      Specifies whether subsequent calls to send on this JMSProducer object should be synchronous or asynchronous.
      JMSProducer setDeliveryDelay(long deliveryDelay)
      Sets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.
      JMSProducer setDeliveryMode(int deliveryMode)
      Specifies the delivery mode of messages that are sent using this JMSProducer
      JMSProducer setDisableMessageID(boolean value)
      Specifies whether message IDs may be disabled for messages that are sent using this JMSProducer
      JMSProducer setDisableMessageTimestamp(boolean value)
      Specifies whether message timestamps may be disabled for messages that are sent using this JMSProducer.
      JMSProducer setJMSCorrelationID(String correlationID)
      Specifies that messages sent using this JMSProducer will have their JMSCorrelationID header value set to the specified correlation ID, where correlation ID is specified as a String.
      JMSProducer setJMSCorrelationIDAsBytes(byte[] correlationID)
      Specifies that messages sent using this JMSProducer will have their JMSCorrelationID header value set to the specified correlation ID, where correlation ID is specified as an array of bytes.
      JMSProducer setJMSReplyTo(Destination replyTo)
      Specifies that messages sent using this JMSProducer will have their JMSReplyTo header value set to the specified Destination object.
      JMSProducer setJMSType(String type)
      Specifies that messages sent using this JMSProducer will have their JMSType header value set to the specified message type.
      JMSProducer setPriority(int priority)
      Specifies the priority of messages that are sent using this JMSProducer
      JMSProducer setProperty(String name, boolean value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified boolean value.
      JMSProducer setProperty(String name, byte value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified byte value.
      JMSProducer setProperty(String name, double value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified double value.
      JMSProducer setProperty(String name, float value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified float value.
      JMSProducer setProperty(String name, int value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified int value.
      JMSProducer setProperty(String name, long value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified long value.
      JMSProducer setProperty(String name, Object value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified Java object value.
      JMSProducer setProperty(String name, short value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified short value.
      JMSProducer setProperty(String name, String value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified String value.
      JMSProducer setTimeToLive(long timeToLive)
      Specifies the time to live of messages that are sent using this JMSProducer.

    • Method Detail

      • send

        JMSProducer send(Destination destination,
               Message message)
        Sends a message to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
        Parameters:
        destination - the destination to send this message to
        message - the message to send
        Returns:
        this JMSProducer
        Throws:
        MessageFormatRuntimeException - if an invalid message is specified.
        InvalidDestinationRuntimeException - if a client uses this method with an invalid destination.
        MessageNotWriteableRuntimeException - if this JMSProducer has been configured to set a message property, but the message's properties are read-only
        JMSRuntimeException - if the JMS provider fails to send the message due to some internal error.

      • send

        JMSProducer send(Destination destination,
               String body)
        Send a TextMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
        Parameters:
        destination - the destination to send this message to
        body - the body of the TextMessage that will be sent. If a null value is specified then a TextMessage with no body will be sent.
        Returns:
        this JMSProducer
        Throws:
        MessageFormatRuntimeException - if an invalid message is specified.
        InvalidDestinationRuntimeException - if a client uses this method with an invalid destination.
        JMSRuntimeException - if the JMS provider fails to send the message due to some internal error.

      • send

        JMSProducer send(Destination destination,
               Map<String,Object> body)
        Send a MapMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
        Parameters:
        destination - the destination to send this message to
        body - the body of the MapMessage that will be sent. If a null value is specified then a MapMessage with no map entries will be sent.
        Returns:
        this JMSProducer
        Throws:
        MessageFormatRuntimeException - if an invalid message is specified.
        InvalidDestinationRuntimeException - if a client uses this method with an invalid destination.
        JMSRuntimeException - if the JMS provider fails to send the message due to some internal error.

      • send

        JMSProducer send(Destination destination,
               byte[] body)
        Send a BytesMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
        Parameters:
        destination - the destination to send this message to
        body - the body of the BytesMessage that will be sent. If a null value is specified then a BytesMessage with no body will be sent.
        Returns:
        this JMSProducer
        Throws:
        MessageFormatRuntimeException - if an invalid message is specified.
        InvalidDestinationRuntimeException - if a client uses this method with an invalid destination.
        JMSRuntimeException - if the JMS provider fails to send the message due to some internal error.

      • send

        JMSProducer send(Destination destination,
               Serializable body)
        Send an ObjectMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
        Parameters:
        destination - the destination to send this message to
        body - the body of the ObjectMessage that will be sent. If a null value is specified then an ObjectMessage with no body will be sent.
        Returns:
        this JMSProducer
        Throws:
        MessageFormatRuntimeException - if an invalid message is specified.
        InvalidDestinationRuntimeException - if a client uses this method with an invalid destination.
        JMSRuntimeException - if JMS provider fails to send the message due to some internal error.

      • setDisableMessageID

        JMSProducer setDisableMessageID(boolean value)
        Specifies whether message IDs may be disabled for messages that are sent using this JMSProducer

        Since message IDs take some effort to create and increase a message's size, some JMS providers may be able to optimise message overhead if they are given a hint that the message ID is not used by an application. By calling this method, a JMS application enables this potential optimisation for all messages sent using this JMSProducer. If the JMS provider accepts this hint, these messages must have the message ID set to null; if the provider ignores the hint, the message ID must be set to its normal unique value.

        Message IDs are enabled by default.

        Parameters:
        value - indicates whether message IDs may be disabled
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set message ID to disabled due to some internal error.
        See Also:
        getDisableMessageID()

      • getDisableMessageID

        boolean getDisableMessageID()
        Gets an indication of whether message IDs are disabled.
        Returns:
        an indication of whether message IDs are disabled
        Throws:
        JMSRuntimeException - if the JMS provider fails to determine if message IDs are disabled due to some internal error.
        See Also:
        setDisableMessageID(boolean)

      • setDisableMessageTimestamp

        JMSProducer setDisableMessageTimestamp(boolean value)
        Specifies whether message timestamps may be disabled for messages that are sent using this JMSProducer. Since timestamps take some effort to create and increase a message's size, some JMS providers may be able to optimise message overhead if they are given a hint that the timestamp is not used by an application. By calling this method, a JMS application enables this potential optimisation for all messages sent using this JMSProducer. If the JMS provider accepts this hint, these messages must have the timestamp set to zero; if the provider ignores the hint, the timestamp must be set to its normal value.

        Message timestamps are enabled by default.

        Parameters:
        value - indicates whether message timestamps may be disabled
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set timestamps to disabled due to some internal error.
        See Also:
        getDisableMessageTimestamp()

      • getDisableMessageTimestamp

        boolean getDisableMessageTimestamp()
        Gets an indication of whether message timestamps are disabled.
        Returns:
        an indication of whether message timestamps are disabled
        Throws:
        JMSRuntimeException - if the JMS provider fails to determine if timestamps are disabled due to some internal error.
        See Also:
        setDisableMessageTimestamp(boolean)

      • setDeliveryMode

        JMSProducer setDeliveryMode(int deliveryMode)
        Specifies the delivery mode of messages that are sent using this JMSProducer

        Delivery mode is set to PERSISTENT by default.

        Parameters:
        deliveryMode - the message delivery mode to be used; legal values are DeliveryMode.NON_PERSISTENT and DeliveryMode.PERSISTENT
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the delivery mode due to some internal error.
        See Also:
        getDeliveryMode(), DeliveryMode.NON_PERSISTENT, DeliveryMode.PERSISTENT, Message.DEFAULT_DELIVERY_MODE

      • getDeliveryMode

        int getDeliveryMode()
        Returns the delivery mode of messages that are sent using this JMSProducer
        Returns:
        the message delivery mode
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the delivery mode due to some internal error.
        See Also:
        setDeliveryMode(int)

      • setPriority

        JMSProducer setPriority(int priority)
        Specifies the priority of messages that are sent using this JMSProducer

        The JMS API defines ten levels of priority value, with 0 as the lowest priority and 9 as the highest. Clients should consider priorities 0-4 as gradations of normal priority and priorities 5-9 as gradations of expedited priority. Priority is set to 4 by default.

        Parameters:
        priority - the message priority to be used; must be a value between 0 and 9
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the priority due to some internal error.
        See Also:
        getPriority(), Message.DEFAULT_PRIORITY

      • getPriority

        int getPriority()
        Return the priority of messages that are sent using this JMSProducer

        Returns:
        the message priority
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the priority due to some internal error.
        See Also:
        setPriority(int)

      • setTimeToLive

        JMSProducer setTimeToLive(long timeToLive)
        Specifies the time to live of messages that are sent using this JMSProducer. This is used to determine the expiration time of a message.

        The expiration time of a message is the sum of the message's time to live and the time it is sent. For transacted sends, this is the time the client sends the message, not the time the transaction is committed.

        Clients should not receive messages that have expired; however, JMS does not guarantee that this will not happen.

        A JMS provider should do its best to accurately expire messages; however, JMS does not define the accuracy provided. It is not acceptable to simply ignore time-to-live.

        Time to live is set to zero by default, which means a message never expires.

        Parameters:
        timeToLive - the message time to live to be used, in milliseconds; a value of zero means that a message never expires.
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the time to live due to some internal error.
        See Also:
        getTimeToLive(), Message.DEFAULT_TIME_TO_LIVE

      • getTimeToLive

        long getTimeToLive()
        Returns the time to live of messages that are sent using this JMSProducer.
        Returns:
        the message time to live in milliseconds; a value of zero means that a message never expires.
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the time to live due to some internal error.
        See Also:
        setTimeToLive(long)

      • setDeliveryDelay

        JMSProducer setDeliveryDelay(long deliveryDelay)
        Sets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.

        For transacted sends, this time starts when the client sends the message, not when the transaction is committed.

        deliveryDelay is set to zero by default.

        Parameters:
        deliveryDelay - the delivery delay in milliseconds.
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the delivery delay due to some internal error.
        See Also:
        getDeliveryDelay(), Message.DEFAULT_DELIVERY_DELAY

      • getDeliveryDelay

        long getDeliveryDelay()
        Gets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.
        Returns:
        the delivery delay in milliseconds.
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the delivery delay due to some internal error.
        See Also:
        setDeliveryDelay(long)

      • setAsync

        JMSProducer setAsync(CompletionListener completionListener)
        Specifies whether subsequent calls to send on this JMSProducer object should be synchronous or asynchronous. If the specified CompletionListener is not null then subsequent calls to send will be asynchronous. If the specified CompletionListener is null then subsequent calls to send will be synchronous. Calls to send are synchronous by default.

        If a call to send is asynchronous then part of the work involved in sending the message will be performed in a separate thread and the specified CompletionListener will be notified when the operation has completed.

        When the message has been successfully sent the JMS provider invokes the callback method onCompletion on the CompletionListener object. Only when that callback has been invoked can the application be sure that the message has been successfully sent with the same degree of confidence as if the send had been synchronous. An application which requires this degree of confidence must therefore wait for the callback to be invoked before continuing.

        The following information is intended to give an indication of how an asynchronous send would typically be implemented.

        In some JMS providers, a normal synchronous send involves sending the message to a remote JMS server and then waiting for an acknowledgement to be received before returning. It is expected that such a provider would implement an asynchronous send by sending the message to the remote JMS server and then returning without waiting for an acknowledgement. When the acknowledgement is received, the JMS provider would notify the application by invoking the onCompletion method on the application-specified CompletionListener object. If for some reason the acknowledgement is not received the JMS provider would notify the application by invoking the CompletionListener's onException method.

        In those cases where the JMS specification permits a lower level of reliability, a normal synchronous send might not wait for an acknowledgement. In that case it is expected that an asynchronous send would be similar to a synchronous send: the JMS provider would send the message to the remote JMS server and then return without waiting for an acknowledgement. However the JMS provider would still notify the application that the send had completed by invoking the onCompletion method on the application-specified CompletionListener object.

        It is up to the JMS provider to decide exactly what is performed in the calling thread and what, if anything, is performed asynchronously, so long as it satisfies the requirements given below:

        Quality of service: After the send operation has completed successfully, which means that the message has been successfully sent with the same degree of confidence as if a normal synchronous send had been performed, the JMS provider must invoke the CompletionListener's onCompletion method. The CompletionListener must not be invoked earlier than this.

        Exceptions: If an exception is encountered during the call to the send method then an appropriate exception should be thrown in the thread that is calling the send method. In this case the JMS provider must not invoke the CompletionListener's onCompletion or onException method. If an exception is encountered which cannot be thrown in the thread that is calling the send method then the JMS provider must call the CompletionListener's onException method. In both cases if an exception occurs it is undefined whether or not the message was successfully sent.

        Message order: If the same JMSContext is used to send multiple messages then JMS message ordering requirements must be satisfied. This applies even if a combination of synchronous and asynchronous sends has been performed. The application is not required to wait for an asynchronous send to complete before sending the next message.

        Close, commit or rollback: If the close method is called on the JMSContext then the JMS provider must block until any incomplete send operations have been completed and all CompletionListener callbacks have returned before closing the object and returning. If the session is transacted (uses a local transaction) then when the JMSContext's commit or rollback method is called the JMS provider must block until any incomplete send operations have been completed and all CompletionListener callbacks have returned before performing the commit or rollback. Incomplete sends should be allowed to complete normally unless an error occurs.

        A CompletionListener callback method must not call close, commit or rollback on its own JMSContext. Doing so will cause the close, commit or rollback to throw an IllegalStateRuntimeException.

        Restrictions on usage in Java EE This method must not be used in a Java EE EJB or web container. Doing so may cause a JMSRuntimeException to be thrown though this is not guaranteed.

        Message headers JMS defines a number of message header fields and message properties which must be set by the "JMS provider on send". If the send is asynchronous these fields and properties may be accessed on the sending client only after the CompletionListener has been invoked. If the CompletionListener's onException method is called then the state of these message header fields and properties is undefined.

        Restrictions on threading: Applications that perform an asynchronous send must confirm to the threading restrictions defined in JMS. This means that the session may be used by only one thread at a time.

        Setting a CompletionListener does not cause the session to be dedicated to the thread of control which calls the CompletionListener. The application thread may therefore continue to use the session after performing an asynchronous send. However the CompletionListener's callback methods must not use the session if an application thread might be using the session at the same time.

        Use of the CompletionListener by the JMS provider: A session will only invoke one CompletionListener callback method at a time. For a given JMSContext, callbacks (both onCompletion and onException) will be performed in the same order as the corresponding calls to the send method. A JMS provider must not invoke the CompletionListener from the thread that is calling the send method.

        Restrictions on the use of the Message object: Applications which perform an asynchronous send must take account of the restriction that a Message object is designed to be accessed by one logical thread of control at a time and does not support concurrent use.

        After the send method has returned, the application must not attempt to read the headers, properties or body of the Message object until the CompletionListener's onCompletion or onException method has been called. This is because the JMS provider may be modifying the Message object in another thread during this time. The JMS provider may throw an JMSException if the application attempts to access or modify the Message object after the send method has returned and before the CompletionListener has been invoked. If the JMS provider does not throw an exception then the behaviour is undefined.

        Parameters:
        completionListener - If asynchronous send behaviour is required, this should be set to a CompletionListener to be notified when the send has completed. If synchronous send behaviour is required, this should be set to null.
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if an internal error occurs
        See Also:
        getAsync(), CompletionListener

      • getAsync

        CompletionListener getAsync()
        If subsequent calls to send on this JMSProducer object have been configured to be asynchronous then this method returns the CompletionListener that has previously been configured. If subsequent calls to send have been configured to be synchronous then this method returns null.
        Returns:
        the CompletionListener or null
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the required information due to some internal error.
        See Also:
        setAsync(javax.jms.CompletionListener)

      • setProperty

        JMSProducer setProperty(String name,
                      boolean value)
        Specifies that messages sent using this JMSProducer will have the specified property set to the specified boolean value.

        This will replace any property of the same name that is already set on the message being sent.

        Parameters:
        name - the name of the property
        value - the boolean value to set
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        See Also:
        getBooleanProperty(java.lang.String)

      • setProperty

        JMSProducer setProperty(String name,
                      byte value)
        Specifies that messages sent using this JMSProducer will have the specified property set to the specified byte value.

        This will replace any property of the same name that is already set on the message being sent.

        Parameters:
        name - the name of the property
        value - the byte value to set
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        See Also:
        getByteProperty(java.lang.String)

      • setProperty

        JMSProducer setProperty(String name,
                      short value)
        Specifies that messages sent using this JMSProducer will have the specified property set to the specified short value.

        This will replace any property of the same name that is already set on the message being sent.

        Parameters:
        name - the name of the property
        value - the short property value to set
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        See Also:
        getShortProperty(java.lang.String)

      • setProperty

        JMSProducer setProperty(String name,
                      int value)
        Specifies that messages sent using this JMSProducer will have the specified property set to the specified int value.

        This will replace any property of the same name that is already set on the message being sent.

        Parameters:
        name - the name of the property
        value - the int property value to set
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        See Also:
        getIntProperty(java.lang.String)

      • setProperty

        JMSProducer setProperty(String name,
                      long value)
        Specifies that messages sent using this JMSProducer will have the specified property set to the specified long value.

        This will replace any property of the same name that is already set on the message being sent.

        Parameters:
        name - the name of the property
        value - the long property value to set
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        See Also:
        getLongProperty(java.lang.String)

      • setProperty

        JMSProducer setProperty(String name,
                      float value)
        Specifies that messages sent using this JMSProducer will have the specified property set to the specified float value.

        This will replace any property of the same name that is already set on the message being sent.

        Parameters:
        name - the name of the property
        value - the float property value to set
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        See Also:
        getFloatProperty(java.lang.String)

      • setProperty

        JMSProducer setProperty(String name,
                      double value)
        Specifies that messages sent using this JMSProducer will have the specified property set to the specified double value.

        This will replace any property of the same name that is already set on the message being sent.

        Parameters:
        name - the name of the property
        value - the double property value to set
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        See Also:
        getDoubleProperty(java.lang.String)

      • setProperty

        JMSProducer setProperty(String name,
                      String value)
        Specifies that messages sent using this JMSProducer will have the specified property set to the specified String value.

        This will replace any property of the same name that is already set on the message being sent.

        Parameters:
        name - the name of the property
        value - the String property value to set
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        See Also:
        getStringProperty(java.lang.String)

      • setProperty

        JMSProducer setProperty(String name,
                      Object value)
        Specifies that messages sent using this JMSProducer will have the specified property set to the specified Java object value.

        Note that this method works only for the objectified primitive object types (Integer, Double, Long ...) and String objects.

        This will replace any property of the same name that is already set on the message being sent.

        Parameters:
        name - the name of the property
        value - the Java object property value to set
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageFormatRuntimeException - if the object is invalid
        See Also:
        getObjectProperty(java.lang.String)

      • clearProperties

        JMSProducer clearProperties()
        Clears any message properties set on this JMSProducer
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to clear the message properties due to some internal error.

      • propertyExists

        boolean propertyExists(String name)
        Indicates whether a message property with the specified name has been set on this JMSProducer
        Parameters:
        name - the name of the property
        Returns:
        true whether the property exists
        Throws:
        JMSRuntimeException - if the JMS provider fails to determine whether the property exists due to some internal error.

      • getBooleanProperty

        boolean getBooleanProperty(String name)
        Returns the message property with the specified name that has been set on this JMSProducer, converted to a boolean.
        Parameters:
        name - the name of the property
        Returns:
        the property value, converted to a boolean
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatRuntimeException - if this type conversion is invalid.
        See Also:
        setProperty(java.lang.String,boolean)

      • getByteProperty

        byte getByteProperty(String name)
        Returns the message property with the specified name that has been set on this JMSProducer, converted to a String.
        Parameters:
        name - the name of the property
        Returns:
        the property value, converted to a byte
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatRuntimeException - if this type conversion is invalid.
        See Also:
        setProperty(java.lang.String,byte)

      • getShortProperty

        short getShortProperty(String name)
        Returns the message property with the specified name that has been set on this JMSProducer, converted to a short.
        Parameters:
        name - the name of the property
        Returns:
        the property value, converted to a short
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatRuntimeException - if this type conversion is invalid.
        See Also:
        setProperty(java.lang.String,short)

      • getIntProperty

        int getIntProperty(String name)
        Returns the message property with the specified name that has been set on this JMSProducer, converted to a int.
        Parameters:
        name - the name of the property
        Returns:
        the property value, converted to a int
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatRuntimeException - if this type conversion is invalid.
        See Also:
        setProperty(java.lang.String,int)

      • getLongProperty

        long getLongProperty(String name)
        Returns the message property with the specified name that has been set on this JMSProducer, converted to a long.
        Parameters:
        name - the name of the property
        Returns:
        the property value, converted to a long
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatRuntimeException - if this type conversion is invalid.
        See Also:
        setProperty(java.lang.String,long)

      • getFloatProperty

        float getFloatProperty(String name)
        Returns the message property with the specified name that has been set on this JMSProducer, converted to a float.
        Parameters:
        name - the name of the property
        Returns:
        the property value, converted to a float
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatRuntimeException - if this type conversion is invalid.
        See Also:
        setProperty(java.lang.String,float)

      • getDoubleProperty

        double getDoubleProperty(String name)
        Returns the message property with the specified name that has been set on this JMSProducer, converted to a double.
        Parameters:
        name - the name of the property
        Returns:
        the property value, converted to a double
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatRuntimeException - if this type conversion is invalid.
        See Also:
        setProperty(java.lang.String,double)

      • getStringProperty

        String getStringProperty(String name)
        Returns the message property with the specified name that has been set on this JMSProducer, converted to a String.
        Parameters:
        name - the name of the property
        Returns:
        the property value, converted to a boolean; if there is no property by this name, a null value is returned
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatRuntimeException - if this type conversion is invalid.
        See Also:
        setProperty(java.lang.String,String)

      • getObjectProperty

        Object getObjectProperty(String name)
        Returns the message property with the specified name that has been set on this JMSProducer, converted to objectified format.

        This method can be used to return, in objectified format, an object that has been stored as a property in the message with the equivalent setObjectProperty method call, or its equivalent primitive set<I>type</I>Property method.

        Parameters:
        name - the name of the property
        Returns:
        the Java object property value with the specified name, in objectified format (for example, if the property was set as an int, an Integer is returned); if there is no property by this name, a null value is returned
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the property value due to some internal error.
        See Also:
        setProperty(java.lang.String,java.lang.Object)

      • getPropertyNames

        Set<String> getPropertyNames()
        Returns an unmodifiable Set view of the names of all the message properties that have been set on this JMSProducer.

        Note that JMS standard header fields are not considered properties and are not returned in this Set.

        The set is backed by the JMSProducer, so changes to the map are reflected in the set. However the set may not be modified. Attempts to modify the returned collection, whether directly or via its iterator, will result in an java.lang.UnsupportedOperationException. Its behaviour matches that defined in the java.util.Collections method unmodifiableSet.

        Returns:
        a Set containing the names of all the message properties that have been set on this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the property names due to some internal error.
        See Also:
        Collections.unmodifiableSet(java.util.Set<? extends T>)

      • setJMSCorrelationIDAsBytes

        JMSProducer setJMSCorrelationIDAsBytes(byte[] correlationID)
        Specifies that messages sent using this JMSProducer will have their JMSCorrelationID header value set to the specified correlation ID, where correlation ID is specified as an array of bytes.

        This will override any JMSCorrelationID header value that is already set on the message being sent.

        The array is copied before the method returns, so future modifications to the array will not alter the value in this JMSProducer.

        If a provider supports the native concept of correlation ID, a JMS client may need to assign specific JMSCorrelationID values to match those expected by native messaging clients. JMS providers without native correlation ID values are not required to support this method and its corresponding get method; their implementation may throw a java.lang.UnsupportedOperationException.

        The use of a byte[] value for JMSCorrelationID is non-portable.

        Parameters:
        correlationID - the correlation ID value as an array of bytes
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the correlation ID due to some internal error.
        See Also:
        setJMSCorrelationID(String), getJMSCorrelationID(), getJMSCorrelationIDAsBytes()

      • getJMSCorrelationIDAsBytes

        byte[] getJMSCorrelationIDAsBytes()
        Returns the JMSCorrelationID header value that has been set on this JMSProducer, as an array of bytes.

        The use of a byte[] value for JMSCorrelationID is non-portable.

        Returns:
        the correlation ID as an array of bytes
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the correlation ID due to some internal error.
        See Also:
        setJMSCorrelationID(String), getJMSCorrelationID(), setJMSCorrelationIDAsBytes(byte[])

      • setJMSCorrelationID

        JMSProducer setJMSCorrelationID(String correlationID)
        Specifies that messages sent using this JMSProducer will have their JMSCorrelationID header value set to the specified correlation ID, where correlation ID is specified as a String.

        This will override any JMSCorrelationID header value that is already set on the message being sent.

        A client can use the JMSCorrelationID header field to link one message with another. A typical use is to link a response message with its request message.

        JMSCorrelationID can hold one of the following:

        • A provider-specific message ID
        • An application-specific String
        • A provider-native byte[] value

        Since each message sent by a JMS provider is assigned a message ID value, it is convenient to link messages via message ID. All message ID values must start with the 'ID:' prefix.

        In some cases, an application (made up of several clients) needs to use an application-specific value for linking messages. For instance, an application may use JMSCorrelationID to hold a value referencing some external information. Application-specified values must not start with the 'ID:' prefix; this is reserved for provider-generated message ID values.

        If a provider supports the native concept of correlation ID, a JMS client may need to assign specific JMSCorrelationID values to match those expected by clients that do not use the JMS API. A byte[] value is used for this purpose. JMS providers without native correlation ID values are not required to support byte[] values. The use of a byte[] value for JMSCorrelationID is non-portable.

        Parameters:
        correlationID - the message ID of a message being referred to
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the correlation ID due to some internal error.
        See Also:
        getJMSCorrelationID(),
getJMSCorrelationIDAsBytes(),
setJMSCorrelationIDAsBytes(byte[])

      • getJMSCorrelationID

        String getJMSCorrelationID()
        Returns the JMSCorrelationID header value that has been set on this JMSProducer, as a String.

        This method is used to return correlation ID values that are either provider-specific message IDs or application-specific String values.

        Returns:
        the correlation ID of a message as a String
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the correlation ID due to some internal error.
        See Also:
        setJMSCorrelationID(String), getJMSCorrelationIDAsBytes(), setJMSCorrelationIDAsBytes(byte[])

      • setJMSType

        JMSProducer setJMSType(String type)
        Specifies that messages sent using this JMSProducer will have their JMSType header value set to the specified message type.

        This will override any JMSType header value that is already set on the message being sent.

        Some JMS providers use a message repository that contains the definitions of messages sent by applications. The JMSType header field may reference a message's definition in the provider's repository.

        The JMS API does not define a standard message definition repository, nor does it define a naming policy for the definitions it contains.

        Some messaging systems require that a message type definition for each application message be created and that each message specify its type. In order to work with such JMS providers, JMS clients should assign a value to JMSType, whether the application makes use of it or not. This ensures that the field is properly set for those providers that require it.

        To ensure portability, JMS clients should use symbolic values for JMSType that can be configured at installation time to the values defined in the current provider's message repository. If string literals are used, they may not be valid type names for some JMS providers.

        Parameters:
        type - the message type
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the message type due to some internal error.
        See Also:
        getJMSType()

      • getJMSType

        String getJMSType()
        Returns the JMSType header value that has been set on this JMSProducer.
        Returns:
        the message type
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the message type due to some internal error.
        See Also:
        setJMSType(String)

      • setJMSReplyTo

        JMSProducer setJMSReplyTo(Destination replyTo)
        Specifies that messages sent using this JMSProducer will have their JMSReplyTo header value set to the specified Destination object.

        This will override any JMSReplyTo header value that is already set on the message being sent.

        The JMSReplyTo header field contains the destination where a reply to the current message should be sent. If it is null, no reply is expected. The destination may be either a Queue object or a Topic object.

        Messages sent with a null JMSReplyTo value may be a notification of some event, or they may just be some data the sender thinks is of interest.

        Messages with a JMSReplyTo value typically expect a response. A response is optional; it is up to the client to decide. These messages are called requests. A message sent in response to a request is called a reply.

        In some cases a client may wish to match a request it sent earlier with a reply it has just received. The client can use the JMSCorrelationID header field for this purpose.

        Parameters:
        replyTo - Destination to which to send a response to this message
        Returns:
        this JMSProducer
        Throws:
        JMSRuntimeException - if the JMS provider fails to set the JMSReplyTo destination due to some internal error.
        See Also:
        getJMSReplyTo()

      • getJMSReplyTo

        Destination getJMSReplyTo()
        Returns the JMSReplyTo header value that has been set on this JMSProducer.

        Returns:
        Destination the JMSReplyTo header value
        Throws:
        JMSRuntimeException - if the JMS provider fails to get the JMSReplyTo destination due to some internal error.
        See Also:
        setJMSReplyTo(Destination)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class JMSRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    IllegalStateRuntimeException, InvalidClientIDRuntimeException, InvalidDestinationRuntimeException, InvalidSelectorRuntimeException, JMSSecurityRuntimeException, MessageFormatRuntimeException, MessageNotWriteableRuntimeException, ResourceAllocationRuntimeException, TransactionInProgressRuntimeException, TransactionRolledBackRuntimeException

    public class JMSRuntimeException
extends RuntimeException
    This is the root class of all unchecked exceptions in the JMS API.

    In additional to the detailMessage and cause fields inherited from Throwable, this class also allows a provider-specific errorCode to be set.

    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JMSRuntimeException(String detailMessage)
      Constructs a JMSRuntimeException with the specified detail message
      JMSRuntimeException(String detailMessage, String errorCode)
      Constructs a JMSRuntimeException with the specified detail message and error code.
      JMSRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a JMSRuntimeException with the specified detail message, error code and cause

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getErrorCode()
      Returns the vendor-specific error code.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JMSRuntimeException

        public JMSRuntimeException(String detailMessage,
                   String errorCode)
        Constructs a JMSRuntimeException with the specified detail message and error code.
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code

      • JMSRuntimeException

        public JMSRuntimeException(String detailMessage)
        Constructs a JMSRuntimeException with the specified detail message
        Parameters:
        detailMessage - a description of the exception

      • JMSRuntimeException

        public JMSRuntimeException(String detailMessage,
                   String errorCode,
                   Throwable cause)
        Constructs a JMSRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception

    • Method Detail

      • getErrorCode

        public String getErrorCode()
        Returns the vendor-specific error code.
        Returns:
        the provider-specific error code
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSSecurityException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class JMSSecurityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.JMSSecurityException
  • All Implemented Interfaces:
    Serializable

    public class JMSSecurityException
extends JMSException

    This exception must be thrown when a provider rejects a user name/password submitted by a client. It may also be thrown for any case where a security restriction prevents a method from completing.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JMSSecurityException(String reason)
      Constructs a JMSSecurityException with the specified reason.
      JMSSecurityException(String reason, String errorCode)
      Constructs a JMSSecurityException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JMSSecurityException

        public JMSSecurityException(String reason,
                    String errorCode)
        Constructs a JMSSecurityException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • JMSSecurityException

        public JMSSecurityException(String reason)
        Constructs a JMSSecurityException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSSecurityRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class JMSSecurityRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.JMSSecurityRuntimeException
  • All Implemented Interfaces:
    Serializable

    public class JMSSecurityRuntimeException
extends JMSRuntimeException
    This unchecked exception must be thrown when a provider rejects a user name/password submitted by a client, or for any case where a security restriction prevents a method from completing, and the method signature does not permit a JMSSecurityException to be thrown.
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JMSSecurityRuntimeException(String detailMessage)
      Constructs a JMSSecurityRuntimeException with the specified detail message
      JMSSecurityRuntimeException(String detailMessage, String errorCode)
      Constructs a JMSSecurityRuntimeException with the specified detail message and error code.
      JMSSecurityRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a JMSSecurityRuntimeException with the specified detail message, error code and cause

    • Method Summary

      • Methods inherited from class javax.jms.JMSRuntimeException

        getErrorCode

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JMSSecurityRuntimeException

        public JMSSecurityRuntimeException(String detailMessage)
        Constructs a JMSSecurityRuntimeException with the specified detail message
        Parameters:
        detailMessage - a description of the exception

      • JMSSecurityRuntimeException

        public JMSSecurityRuntimeException(String detailMessage,
                           String errorCode)
        Constructs a JMSSecurityRuntimeException with the specified detail message and error code.
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code

      • JMSSecurityRuntimeException

        public JMSSecurityRuntimeException(String detailMessage,
                           String errorCode,
                           Throwable cause)
        Constructs a JMSSecurityRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSSessionMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jms

Annotation Type JMSSessionMode

  • @Retention(value=RUNTIME)
@Target(value={METHOD,FIELD,PARAMETER,TYPE})
public @interface JMSSessionMode
    This annotation may be used to specify the session mode to be used when injecting a javax.jms.JMSContext object. The meaning and possible values of session mode are the same as for the ConnectionFactory method createContext(int sessionMode).
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    JMSContext.createContext(int)

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      int value
      Specifies the session mode used when injecting a javax.jms.JMSContext object.

    • Element Detail

      • value

        public abstract int value
        Specifies the session mode used when injecting a javax.jms.JMSContext object.
        Default:
        1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MapMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface MapMessage

  • All Superinterfaces:
    Message

    public interface MapMessage
extends Message
    A MapMessage object is used to send a set of name-value pairs. The names are String objects, and the values are primitive data types in the Java programming language. The names must have a value that is not null, and not an empty string. The entries can be accessed sequentially or randomly by name. The order of the entries is undefined. MapMessage inherits from the Message interface and adds a message body that contains a Map.

    The primitive types can be read or written explicitly using methods for each type. They may also be read or written generically as objects. For instance, a call to MapMessage.setInt("foo", 6) is equivalent to MapMessage.setObject("foo", new Integer(6)). Both forms are provided, because the explicit form is convenient for static programming, and the object form is needed when types are not known at compile time.

    When a client receives a MapMessage, it is in read-only mode. If a client attempts to write to the message at this point, a MessageNotWriteableException is thrown. If clearBody is called, the message can now be both read from and written to.

    MapMessage objects support the following conversion table. The marked cases must be supported. The unmarked cases must throw a JMSException. The String-to-primitive conversions may throw a runtime exception if the primitive's valueOf() method does not accept it as a valid String representation of the primitive.

    A value written as the row type can be read as the column type.

     |        | boolean byte short char int long float double String byte[]
 |----------------------------------------------------------------------
 |boolean |    X                                            X
 |byte    |          X     X         X   X                  X
 |short   |                X         X   X                  X
 |char    |                     X                           X
 |int     |                          X   X                  X
 |long    |                              X                  X
 |float   |                                    X     X      X
 |double  |                                          X      X
 |String  |    X     X     X         X   X     X     X      X
 |byte[]  |                                                        X
 |----------------------------------------------------------------------

    Attempting to read a null value as a primitive type must be treated as calling the primitive's corresponding valueOf(String) conversion method with a null value. Since char does not support a String conversion, attempting to read a null value as a char must throw a NullPointerException.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createMapMessage(), BytesMessage, Message, ObjectMessage, StreamMessage, TextMessage

    • Field Summary

      • Fields inherited from interface javax.jms.Message

        DEFAULT_DELIVERY_DELAY, DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean getBoolean(String name)
      Returns the boolean value with the specified name.
      byte getByte(String name)
      Returns the byte value with the specified name.
      byte[] getBytes(String name)
      Returns the byte array value with the specified name.
      char getChar(String name)
      Returns the Unicode character value with the specified name.
      double getDouble(String name)
      Returns the double value with the specified name.
      float getFloat(String name)
      Returns the float value with the specified name.
      int getInt(String name)
      Returns the int value with the specified name.
      long getLong(String name)
      Returns the long value with the specified name.
      Enumeration getMapNames()
      Returns an Enumeration of all the names in the MapMessage object.
      Object getObject(String name)
      Returns the value of the object with the specified name.
      short getShort(String name)
      Returns the short value with the specified name.
      String getString(String name)
      Returns the String value with the specified name.
      boolean itemExists(String name)
      Indicates whether an item exists in this MapMessage object.
      void setBoolean(String name, boolean value)
      Sets a boolean value with the specified name into the Map.
      void setByte(String name, byte value)
      Sets a byte value with the specified name into the Map.
      void setBytes(String name, byte[] value)
      Sets a byte array value with the specified name into the Map.
      void setBytes(String name, byte[] value, int offset, int length)
      Sets a portion of the byte array value with the specified name into the Map.
      void setChar(String name, char value)
      Sets a Unicode character value with the specified name into the Map.
      void setDouble(String name, double value)
      Sets a double value with the specified name into the Map.
      void setFloat(String name, float value)
      Sets a float value with the specified name into the Map.
      void setInt(String name, int value)
      Sets an int value with the specified name into the Map.
      void setLong(String name, long value)
      Sets a long value with the specified name into the Map.
      void setObject(String name, Object value)
      Sets an object value with the specified name into the Map.
      void setShort(String name, short value)
      Sets a short value with the specified name into the Map.
      void setString(String name, String value)
      Sets a String value with the specified name into the Map.

      • Methods inherited from interface javax.jms.Message

        acknowledge, clearBody, clearProperties, getBody, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDeliveryTime, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, isBodyAssignableTo, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDeliveryTime, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

    • Method Detail

      • getBoolean

        boolean getBoolean(String name)
                   throws JMSException
        Returns the boolean value with the specified name.
        Parameters:
        name - the name of the boolean
        Returns:
        the boolean value with the specified name
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getByte

        byte getByte(String name)
             throws JMSException
        Returns the byte value with the specified name.
        Parameters:
        name - the name of the byte
        Returns:
        the byte value with the specified name
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getShort

        short getShort(String name)
               throws JMSException
        Returns the short value with the specified name.
        Parameters:
        name - the name of the short
        Returns:
        the short value with the specified name
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getChar

        char getChar(String name)
             throws JMSException
        Returns the Unicode character value with the specified name.
        Parameters:
        name - the name of the Unicode character
        Returns:
        the Unicode character value with the specified name
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getInt

        int getInt(String name)
           throws JMSException
        Returns the int value with the specified name.
        Parameters:
        name - the name of the int
        Returns:
        the int value with the specified name
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getLong

        long getLong(String name)
             throws JMSException
        Returns the long value with the specified name.
        Parameters:
        name - the name of the long
        Returns:
        the long value with the specified name
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getFloat

        float getFloat(String name)
               throws JMSException
        Returns the float value with the specified name.
        Parameters:
        name - the name of the float
        Returns:
        the float value with the specified name
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getDouble

        double getDouble(String name)
                 throws JMSException
        Returns the double value with the specified name.
        Parameters:
        name - the name of the double
        Returns:
        the double value with the specified name
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getString

        String getString(String name)
                 throws JMSException
        Returns the String value with the specified name.
        Parameters:
        name - the name of the String
        Returns:
        the String value with the specified name; if there is no item by this name, a null value is returned
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getBytes

        byte[] getBytes(String name)
                throws JMSException
        Returns the byte array value with the specified name.
        Parameters:
        name - the name of the byte array
        Returns:
        a copy of the byte array value with the specified name; if there is no item by this name, a null value is returned.
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getObject

        Object getObject(String name)
                 throws JMSException
        Returns the value of the object with the specified name.

        This method can be used to return, in objectified format, an object in the Java programming language ("Java object") that had been stored in the Map with the equivalent setObject method call, or its equivalent primitive set<I>type</I> method.

        Note that byte values are returned as byte[], not Byte[].

        Parameters:
        name - the name of the Java object
        Returns:
        a copy of the Java object value with the specified name, in objectified format (for example, if the object was set as an int, an Integer is returned); if there is no item by this name, a null value is returned
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.

      • getMapNames

        Enumeration getMapNames()
                        throws JMSException
        Returns an Enumeration of all the names in the MapMessage object.
        Returns:
        an enumeration of all the names in this MapMessage
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.

      • setBoolean

        void setBoolean(String name,
              boolean value)
                throws JMSException
        Sets a boolean value with the specified name into the Map.
        Parameters:
        name - the name of the boolean
        value - the boolean value to set in the Map
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setByte

        void setByte(String name,
           byte value)
             throws JMSException
        Sets a byte value with the specified name into the Map.
        Parameters:
        name - the name of the byte
        value - the byte value to set in the Map
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setShort

        void setShort(String name,
            short value)
              throws JMSException
        Sets a short value with the specified name into the Map.
        Parameters:
        name - the name of the short
        value - the short value to set in the Map
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setChar

        void setChar(String name,
           char value)
             throws JMSException
        Sets a Unicode character value with the specified name into the Map.
        Parameters:
        name - the name of the Unicode character
        value - the Unicode character value to set in the Map
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setInt

        void setInt(String name,
          int value)
            throws JMSException
        Sets an int value with the specified name into the Map.
        Parameters:
        name - the name of the int
        value - the int value to set in the Map
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setLong

        void setLong(String name,
           long value)
             throws JMSException
        Sets a long value with the specified name into the Map.
        Parameters:
        name - the name of the long
        value - the long value to set in the Map
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setFloat

        void setFloat(String name,
            float value)
              throws JMSException
        Sets a float value with the specified name into the Map.
        Parameters:
        name - the name of the float
        value - the float value to set in the Map
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setDouble

        void setDouble(String name,
             double value)
               throws JMSException
        Sets a double value with the specified name into the Map.
        Parameters:
        name - the name of the double
        value - the double value to set in the Map
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setString

        void setString(String name,
             String value)
               throws JMSException
        Sets a String value with the specified name into the Map.
        Parameters:
        name - the name of the String
        value - the String value to set in the Map
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setBytes

        void setBytes(String name,
            byte[] value)
              throws JMSException
        Sets a byte array value with the specified name into the Map.
        Parameters:
        name - the name of the byte array
        value - the byte array value to set in the Map; the array is copied so that the value for name will not be altered by future modifications
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null, or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setBytes

        void setBytes(String name,
            byte[] value,
            int offset,
            int length)
              throws JMSException
        Sets a portion of the byte array value with the specified name into the Map.
        Parameters:
        name - the name of the byte array
        value - the byte array value to set in the Map
        offset - the initial offset within the byte array
        length - the number of bytes to use
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if the message is in read-only mode.

      • setObject

        void setObject(String name,
             Object value)
               throws JMSException
        Sets an object value with the specified name into the Map.

        This method works only for the objectified primitive object types (Integer, Double, Long ...), String objects, and byte arrays.

        Parameters:
        name - the name of the Java object
        value - the Java object value to set in the Map
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageFormatException - if the object is invalid.
        MessageNotWriteableException - if the message is in read-only mode.

      • itemExists

        boolean itemExists(String name)
                   throws JMSException
        Indicates whether an item exists in this MapMessage object.
        Parameters:
        name - the name of the item to test
        Returns:
        true if the item exists
        Throws:
        JMSException - if the JMS provider fails to determine if the item exists due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Message (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface Message

  • All Known Subinterfaces:
    BytesMessage, MapMessage, ObjectMessage, StreamMessage, TextMessage

    public interface Message
    The Message interface is the root interface of all JMS messages. It defines the message header and the acknowledge method used for all messages.

    Most message-oriented middleware (MOM) products treat messages as lightweight entities that consist of a header and a body. The header contains fields used for message routing and identification; the body contains the application data being sent.

    Within this general form, the definition of a message varies significantly across products. It would be quite difficult for the JMS API to support all of these message models.

    With this in mind, the JMS message model has the following goals:

    • Provide a single, unified message API
    • Provide an API suitable for creating messages that match the format used by provider-native messaging applications
    • Support the development of heterogeneous applications that span operating systems, machine architectures, and computer languages
    • Support messages containing objects in the Java programming language ("Java objects")
    • Support messages containing Extensible Markup Language (XML) pages

    JMS messages are composed of the following parts:

    • Header - All messages support the same set of header fields. Header fields contain values used by both clients and providers to identify and route messages.
    • Properties - Each message contains a built-in facility for supporting application-defined property values. Properties provide an efficient mechanism for supporting application-defined message filtering.
    • Body - The JMS API defines several types of message body, which cover the majority of messaging styles currently in use.

    Message Bodies

    The JMS API defines five types of message body:

    • Stream - A StreamMessage object's message body contains a stream of primitive values in the Java programming language ("Java primitives"). It is filled and read sequentially.
    • Map - A MapMessage object's message body contains a set of name-value pairs, where names are String objects, and values are Java primitives. The entries can be accessed sequentially or randomly by name. The order of the entries is undefined.
    • Text - A TextMessage object's message body contains a java.lang.String object. This message type can be used to transport plain-text messages, and XML messages.
    • Object - An ObjectMessage object's message body contains a Serializable Java object.
    • Bytes - A BytesMessage object's message body contains a stream of uninterpreted bytes. This message type is for literally encoding a body to match an existing message format. In many cases, it is possible to use one of the other body types, which are easier to use. Although the JMS API allows the use of message properties with byte messages, they are typically not used, since the inclusion of properties may affect the format.

    Message Headers

    The JMSCorrelationID header field is used for linking one message with another. It typically links a reply message with its requesting message.

    JMSCorrelationID can hold a provider-specific message ID, an application-specific String object, or a provider-native byte[] value.

    Message Properties

    A Message object contains a built-in facility for supporting application-defined property values. In effect, this provides a mechanism for adding application-specific header fields to a message.

    Properties allow an application, via message selectors, to have a JMS provider select, or filter, messages on its behalf using application-specific criteria.

    Property names must obey the rules for a message selector identifier. Property names must not be null, and must not be empty strings. If a property name is set and it is either null or an empty string, an IllegalArgumentException must be thrown.

    Property values can be boolean, byte, short, int, long, float, double, and String.

    Property values are set prior to sending a message. When a client receives a message, its properties are in read-only mode. If a client attempts to set properties at this point, a MessageNotWriteableException is thrown. If clearProperties is called, the properties can now be both read from and written to. Note that header fields are distinct from properties. Header fields are never in read-only mode.

    A property value may duplicate a value in a message's body, or it may not. Although JMS does not define a policy for what should or should not be made a property, application developers should note that JMS providers will likely handle data in a message's body more efficiently than data in a message's properties. For best performance, applications should use message properties only when they need to customize a message's header. The primary reason for doing this is to support customized message selection.

    Message properties support the following conversion table. The marked cases must be supported. The unmarked cases must throw a JMSException. The String-to-primitive conversions may throw a runtime exception if the primitive's valueOf method does not accept the String as a valid representation of the primitive.

    A value written as the row type can be read as the column type.

     |        | boolean byte short int long float double String
 |----------------------------------------------------------
 |boolean |    X                                       X
 |byte    |          X     X    X   X                  X
 |short   |                X    X   X                  X
 |int     |                     X   X                  X
 |long    |                         X                  X
 |float   |                               X     X      X
 |double  |                                     X      X
 |String  |    X     X     X    X   X     X     X      X
 |----------------------------------------------------------

    In addition to the type-specific set/get methods for properties, JMS provides the setObjectProperty and getObjectProperty methods. These support the same set of property types using the objectified primitive values. Their purpose is to allow the decision of property type to made at execution time rather than at compile time. They support the same property value conversions.

    The setObjectProperty method accepts values of class Boolean, Byte, Short, Integer, Long, Float, Double, and String. An attempt to use any other class must throw a JMSException.

    The getObjectProperty method only returns values of class Boolean, Byte, Short, Integer, Long, Float, Double, and String.

    The order of property values is not defined. To iterate through a message's property values, use getPropertyNames to retrieve a property name enumeration and then use the various property get methods to retrieve their values.

    A message's properties are deleted by the clearProperties method. This leaves the message with an empty set of properties.

    Getting a property value for a name which has not been set returns a null value. Only the getStringProperty and getObjectProperty methods can return a null value. Attempting to read a null value as a primitive type must be treated as calling the primitive's corresponding valueOf(String) conversion method with a null value.

    The JMS API reserves the JMSX property name prefix for JMS defined properties. The full set of these properties is defined in the Java Message Service specification. The specification also defines whether support for each property is mandatory or optional. New JMS defined properties may be added in later versions of the JMS API. The String[] ConnectionMetaData.getJMSXPropertyNames method returns the names of the JMSX properties supported by a connection.

    JMSX properties may be referenced in message selectors whether or not they are supported by a connection. If they are not present in a message, they are treated like any other absent property. The effect of setting a message selector on a property which is set by the provider on receive is undefined.

    JMSX properties defined in the specification as "set by provider on send" are available to both the producer and the consumers of the message. JMSX properties defined in the specification as "set by provider on receive" are available only to the consumers.

    JMSXGroupID and JMSXGroupSeq are standard properties that clients should use if they want to group messages. All providers must support them. Unless specifically noted, the values and semantics of the JMSX properties are undefined.

    The JMS API reserves the JMS_<I>vendor_name</I> property name prefix for provider-specific properties. Each provider defines its own value for <I>vendor_name</I>. This is the mechanism a JMS provider uses to make its special per-message services available to a JMS client.

    The purpose of provider-specific properties is to provide special features needed to integrate JMS clients with provider-native clients in a single JMS application. They should not be used for messaging between JMS clients.

    Provider Implementations of JMS Message Interfaces

    The JMS API provides a set of message interfaces that define the JMS message model. It does not provide implementations of these interfaces.

    Each JMS provider supplies a set of message factories with its Session object for creating instances of messages. This allows a provider to use message implementations tailored to its specific needs.

    A provider must be prepared to accept message implementations that are not its own. They may not be handled as efficiently as its own implementation; however, they must be handled.

    Note the following exception case when a provider is handling a foreign message implementation. If the foreign message implementation contains a JMSReplyTo header field that is set to a foreign destination implementation, the provider is not required to handle or preserve the value of this header field.

    Message Selectors

    A JMS message selector allows a client to specify, by header field references and property references, the messages it is interested in. Only messages whose header and property values match the selector are delivered. What it means for a message not to be delivered depends on the MessageConsumer being used (see QueueReceiver and TopicSubscriber).

    Message selectors cannot reference message body values.

    A message selector matches a message if the selector evaluates to true when the message's header field values and property values are substituted for their corresponding identifiers in the selector.

    A message selector is a String whose syntax is based on a subset of the SQL92 conditional expression syntax. If the value of a message selector is an empty string, the value is treated as a null and indicates that there is no message selector for the message consumer.

    The order of evaluation of a message selector is from left to right within precedence level. Parentheses can be used to change this order.

    Predefined selector literals and operator names are shown here in uppercase; however, they are case insensitive.

    A selector can contain:

    • Literals:
      • A string literal is enclosed in single quotes, with a single quote represented by doubled single quote; for example, 'literal' and 'literal''s'. Like string literals in the Java programming language, these use the Unicode character encoding.
      • An exact numeric literal is a numeric value without a decimal point, such as 57, -957, and +62; numbers in the range of long are supported. Exact numeric literals use the integer literal syntax of the Java programming language.
      • An approximate numeric literal is a numeric value in scientific notation, such as 7E3 and -57.9E2, or a numeric value with a decimal, such as 7., -95.7, and +6.2; numbers in the range of double are supported. Approximate literals use the floating-point literal syntax of the Java programming language.
      • The boolean literals TRUE and FALSE.
    • Identifiers:
      • An identifier is an unlimited-length sequence of letters and digits, the first of which must be a letter. A letter is any character for which the method Character.isJavaLetter returns true. This includes '_' and '$'. A letter or digit is any character for which the method Character.isJavaLetterOrDigit returns true.
      • Identifiers cannot be the names NULL, TRUE, and FALSE.
      • Identifiers cannot be NOT, AND, OR, BETWEEN, LIKE, IN, IS, or ESCAPE.
      • Identifiers are either header field references or property references. The type of a property value in a message selector corresponds to the type used to set the property. If a property that does not exist in a message is referenced, its value is NULL.
      • The conversions that apply to the get methods for properties do not apply when a property is used in a message selector expression. For example, suppose you set a property as a string value, as in the following:
        myMessage.setStringProperty("NumberOfOrders", "2");
        The following expression in a message selector would evaluate to false, because a string cannot be used in an arithmetic expression:
        "NumberOfOrders > 1"
      • Identifiers are case-sensitive.
      • Message header field references are restricted to JMSDeliveryMode, JMSPriority, JMSMessageID, JMSTimestamp, JMSCorrelationID, and JMSType. JMSMessageID, JMSCorrelationID, and JMSType values may be null and if so are treated as a NULL value.
      • Any name beginning with 'JMSX' is a JMS defined property name.
      • Any name beginning with 'JMS_' is a provider-specific property name.
      • Any name that does not begin with 'JMS' is an application-specific property name.
    • White space is the same as that defined for the Java programming language: space, horizontal tab, form feed, and line terminator.
    • Expressions:
      • A selector is a conditional expression; a selector that evaluates to true matches; a selector that evaluates to false or unknown does not match.
      • Arithmetic expressions are composed of themselves, arithmetic operations, identifiers (whose value is treated as a numeric literal), and numeric literals.
      • Conditional expressions are composed of themselves, comparison operations, and logical operations.
    • Standard bracketing () for ordering expression evaluation is supported.
    • Logical operators in precedence order: NOT, AND, OR
    • Comparison operators: =, >, >=, <, <=, <> (not equal)
      • Only like type values can be compared. One exception is that it is valid to compare exact numeric values and approximate numeric values; the type conversion required is defined by the rules of numeric promotion in the Java programming language. If the comparison of non-like type values is attempted, the value of the operation is false. If either of the type values evaluates to NULL, the value of the expression is unknown.
      • String and boolean comparison is restricted to = and <>. Two strings are equal if and only if they contain the same sequence of characters.
    • Arithmetic operators in precedence order:
      • +, - (unary)
      • *, / (multiplication and division)
      • +, - (addition and subtraction)
      • Arithmetic operations must use numeric promotion in the Java programming language.
    • <I>arithmetic-expr1</I> [NOT] BETWEEN <I>arithmetic-expr2</I> AND <I>arithmetic-expr3</I> (comparison operator)
      • "age&nbsp;BETWEEN&nbsp;15&nbsp;AND&nbsp;19" is equivalent to "age&nbsp;>=&nbsp;15&nbsp;AND&nbsp;age&nbsp;<=&nbsp;19"
      • "age&nbsp;NOT&nbsp;BETWEEN&nbsp;15&nbsp;AND&nbsp;19" is equivalent to "age&nbsp;<&nbsp;15&nbsp;OR&nbsp;age&nbsp;>&nbsp;19"
    • <I>identifier</I> [NOT] IN (<I>string-literal1</I>, <I>string-literal2</I>,...) (comparison operator where <I>identifier</I> has a String or NULL value)
      • "Country&nbsp;IN&nbsp;('&nbsp;UK',&nbsp;'US',&nbsp;'France')" is true for 'UK' and false for 'Peru'; it is equivalent to the expression "(Country&nbsp;=&nbsp;'&nbsp;UK')&nbsp;OR&nbsp;(Country&nbsp;=&nbsp;'&nbsp;US')&nbsp;OR&nbsp;(Country&nbsp;=&nbsp;'&nbsp;France')"
      • "Country&nbsp;NOT&nbsp;IN&nbsp;('&nbsp;UK',&nbsp;'US',&nbsp;'France')" is false for 'UK' and true for 'Peru'; it is equivalent to the expression "NOT&nbsp;((Country&nbsp;=&nbsp;'&nbsp;UK')&nbsp;OR&nbsp;(Country&nbsp;=&nbsp;'&nbsp;US')&nbsp;OR&nbsp;(Country&nbsp;=&nbsp;'&nbsp;France'))"
      • If identifier of an IN or NOT IN operation is NULL, the value of the operation is unknown.
    • <I>identifier</I> [NOT] LIKE <I>pattern-value</I> [ESCAPE <I>escape-character</I>] (comparison operator, where <I>identifier</I> has a String value; <I>pattern-value</I> is a string literal where '_' stands for any single character; '%' stands for any sequence of characters, including the empty sequence; and all other characters stand for themselves. The optional <I>escape-character</I> is a single-character string literal whose character is used to escape the special meaning of the '_' and '%' in <I>pattern-value</I>.)
      • "phone&nbsp;LIKE&nbsp;'12%3'" is true for '123' or '12993' and false for '1234'
      • "word&nbsp;LIKE&nbsp;'l_se'" is true for 'lose' and false for 'loose'
      • "underscored&nbsp;LIKE&nbsp;'\_%'&nbsp;ESCAPE&nbsp;'\'" is true for '_foo' and false for 'bar'
      • "phone&nbsp;NOT&nbsp;LIKE&nbsp;'12%3'" is false for '123' or '12993' and true for '1234'
      • If <I>identifier</I> of a LIKE or NOT LIKE operation is NULL, the value of the operation is unknown.
    • <I>identifier</I> IS NULL (comparison operator that tests for a null header field value or a missing property value)
      • "prop_name&nbsp;IS&nbsp;NULL"
    • <I>identifier</I> IS NOT NULL (comparison operator that tests for the existence of a non-null header field value or a property value)
      • "prop_name&nbsp;IS&nbsp;NOT&nbsp;NULL"

      JMS providers are required to verify the syntactic correctness of a message selector at the time it is presented. A method that provides a syntactically incorrect selector must result in a JMSException. JMS providers may also optionally provide some semantic checking at the time the selector is presented. Not all semantic checking can be performed at the time a message selector is presented, because property types are not known.

      The following message selector selects messages with a message type of car and color of blue and weight greater than 2500 pounds:

      "JMSType = 'car' AND color = 'blue' AND weight > 2500"

      Null Values

      As noted above, property values may be NULL. The evaluation of selector expressions containing NULL values is defined by SQL92 NULL semantics. A brief description of these semantics is provided here.

      SQL treats a NULL value as unknown. Comparison or arithmetic with an unknown value always yields an unknown value.

      The IS NULL and IS NOT NULL operators convert an unknown value into the respective TRUE and FALSE values.

      The boolean operators use three-valued logic as defined by the following tables:

      The definition of the AND operator

       | AND  |   T   |   F   |   U
 +------+-------+-------+-------
 |  T   |   T   |   F   |   U
 |  F   |   F   |   F   |   F
 |  U   |   U   |   F   |   U
 +------+-------+-------+-------

      The definition of the OR operator

       | OR   |   T   |   F   |   U
 +------+-------+-------+--------
 |  T   |   T   |   T   |   T
 |  F   |   T   |   F   |   U
 |  U   |   T   |   U   |   U
 +------+-------+-------+-------

      The definition of the NOT operator

       | NOT
 +------+------
 |  T   |   F
 |  F   |   T
 |  U   |   U
 +------+-------

      Special Notes

      When used in a message selector, the JMSDeliveryMode header field is treated as having the values 'PERSISTENT' and 'NON_PERSISTENT'.

      Date and time values should use the standard long millisecond value. When a date or time literal is included in a message selector, it should be an integer literal for a millisecond value. The standard way to produce millisecond values is to use java.util.Calendar.

      Although SQL supports fixed decimal comparison and arithmetic, JMS message selectors do not. This is the reason for restricting exact numeric literals to those without a decimal (and the addition of numerics with a decimal as an alternate representation for approximate numeric values).

      SQL comments are not supported.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    MessageConsumer.receive(), MessageConsumer.receive(long), MessageConsumer.receiveNoWait(), MessageListener.onMessage(Message), BytesMessage, MapMessage, ObjectMessage, StreamMessage, TextMessage

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static long DEFAULT_DELIVERY_DELAY
      The message producer's default delivery delay is zero.
      static int DEFAULT_DELIVERY_MODE
      The message producer's default delivery mode is PERSISTENT.
      static int DEFAULT_PRIORITY
      The message producer's default priority is 4.
      static long DEFAULT_TIME_TO_LIVE
      The message producer's default time to live is unlimited; the message never expires.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void acknowledge()
      Acknowledges all consumed messages of the session of this consumed message.
      void clearBody()
      Clears out the message body.
      void clearProperties()
      Clears a message's properties.
      <T> T getBody(Class<T> c)
      Returns the message body as an object of the specified type.
      boolean getBooleanProperty(String name)
      Returns the value of the boolean property with the specified name.
      byte getByteProperty(String name)
      Returns the value of the byte property with the specified name.
      double getDoubleProperty(String name)
      Returns the value of the double property with the specified name.
      float getFloatProperty(String name)
      Returns the value of the float property with the specified name.
      int getIntProperty(String name)
      Returns the value of the int property with the specified name.
      String getJMSCorrelationID()
      Gets the correlation ID for the message.
      byte[] getJMSCorrelationIDAsBytes()
      Gets the correlation ID as an array of bytes for the message.
      int getJMSDeliveryMode()
      Gets the DeliveryMode value specified for this message.
      long getJMSDeliveryTime()
      Gets the message's delivery time value.
      Destination getJMSDestination()
      Gets the Destination object for this message.
      long getJMSExpiration()
      Gets the message's expiration time.
      String getJMSMessageID()
      Gets the message ID.
      int getJMSPriority()
      Gets the message priority level.
      boolean getJMSRedelivered()
      Gets an indication of whether this message is being redelivered.
      Destination getJMSReplyTo()
      Gets the Destination object to which a reply to this message should be sent.
      long getJMSTimestamp()
      Gets the message timestamp.
      String getJMSType()
      Gets the message type identifier supplied by the client when the message was sent.
      long getLongProperty(String name)
      Returns the value of the long property with the specified name.
      Object getObjectProperty(String name)
      Returns the value of the Java object property with the specified name.
      Enumeration getPropertyNames()
      Returns an Enumeration of all the property names.
      short getShortProperty(String name)
      Returns the value of the short property with the specified name.
      String getStringProperty(String name)
      Returns the value of the String property with the specified name.
      boolean isBodyAssignableTo(Class c)
      Returns whether the message body is capable of being assigned to the specified type.
      boolean propertyExists(String name)
      Indicates whether a property value exists.
      void setBooleanProperty(String name, boolean value)
      Sets a boolean property value with the specified name into the message.
      void setByteProperty(String name, byte value)
      Sets a byte property value with the specified name into the message.
      void setDoubleProperty(String name, double value)
      Sets a double property value with the specified name into the message.
      void setFloatProperty(String name, float value)
      Sets a float property value with the specified name into the message.
      void setIntProperty(String name, int value)
      Sets an int property value with the specified name into the message.
      void setJMSCorrelationID(String correlationID)
      Sets the correlation ID for the message.
      void setJMSCorrelationIDAsBytes(byte[] correlationID)
      Sets the correlation ID as an array of bytes for the message.
      void setJMSDeliveryMode(int deliveryMode)
      Sets the DeliveryMode value for this message.
      void setJMSDeliveryTime(long deliveryTime)
      Sets the message's delivery time value.
      void setJMSDestination(Destination destination)
      Sets the Destination object for this message.
      void setJMSExpiration(long expiration)
      Sets the message's expiration value.
      void setJMSMessageID(String id)
      Sets the message ID.
      void setJMSPriority(int priority)
      Sets the priority level for this message.
      void setJMSRedelivered(boolean redelivered)
      Specifies whether this message is being redelivered.
      void setJMSReplyTo(Destination replyTo)
      Sets the Destination object to which a reply to this message should be sent.
      void setJMSTimestamp(long timestamp)
      Sets the message timestamp.
      void setJMSType(String type)
      Sets the message type.
      void setLongProperty(String name, long value)
      Sets a long property value with the specified name into the message.
      void setObjectProperty(String name, Object value)
      Sets a Java object property value with the specified name into the message.
      void setShortProperty(String name, short value)
      Sets a short property value with the specified name into the message.
      void setStringProperty(String name, String value)
      Sets a String property value with the specified name into the message.

    • Field Detail

      • DEFAULT_DELIVERY_MODE

        static final int DEFAULT_DELIVERY_MODE
        The message producer's default delivery mode is PERSISTENT.
        See Also:
        DeliveryMode.PERSISTENT, Constant Field Values

      • DEFAULT_PRIORITY

        static final int DEFAULT_PRIORITY
        The message producer's default priority is 4.
        See Also:
        Constant Field Values

      • DEFAULT_TIME_TO_LIVE

        static final long DEFAULT_TIME_TO_LIVE
        The message producer's default time to live is unlimited; the message never expires.
        See Also:
        Constant Field Values

      • DEFAULT_DELIVERY_DELAY

        static final long DEFAULT_DELIVERY_DELAY
        The message producer's default delivery delay is zero.
        Since:
        JMS 2.0
        See Also:
        Constant Field Values

    • Method Detail

      • getJMSMessageID

        String getJMSMessageID()
                       throws JMSException
        Gets the message ID.

        The JMSMessageID header field contains a value that uniquely identifies each message sent by a provider.

        When a message is sent, JMSMessageID can be ignored. When the send or publish method returns, it contains a provider-assigned value.

        A JMSMessageID is a String value that should function as a unique key for identifying messages in a historical repository. The exact scope of uniqueness is provider-defined. It should at least cover all messages for a specific installation of a provider, where an installation is some connected set of message routers.

        All JMSMessageID values must start with the prefix 'ID:'. Uniqueness of message ID values across different providers is not required.

        Since message IDs take some effort to create and increase a message's size, some JMS providers may be able to optimize message overhead if they are given a hint that the message ID is not used by an application. By calling the MessageProducer.setDisableMessageID method, a JMS client enables this potential optimization for all messages sent by that message producer. If the JMS provider accepts this hint, these messages must have the message ID set to null; if the provider ignores the hint, the message ID must be set to its normal unique value.

        Returns:
        the message ID
        Throws:
        JMSException - if the JMS provider fails to get the message ID due to some internal error.
        See Also:
        setJMSMessageID(String), MessageProducer.setDisableMessageID(boolean)

      • setJMSMessageID

        void setJMSMessageID(String id)
                     throws JMSException
        Sets the message ID.

        This method is for use by JMS providers only to set this field when a message is sent. This message cannot be used by clients to configure the message ID. This method is public to allow a JMS provider to set this field when sending a message whose implementation is not its own.

        Parameters:
        id - the ID of the message
        Throws:
        JMSException - if the JMS provider fails to set the message ID due to some internal error.
        See Also:
        getJMSMessageID()

      • getJMSTimestamp

        long getJMSTimestamp()
                     throws JMSException
        Gets the message timestamp.

        The JMSTimestamp header field contains the time a message was handed off to a provider to be sent. It is not the time the message was actually transmitted, because the actual send may occur later due to transactions or other client-side queueing of messages.

        When a message is sent, JMSTimestamp is ignored. When the send or publish method returns, it contains a time value somewhere in the interval between the call and the return. The value is in the format of a normal millis time value in the Java programming language.

        Since timestamps take some effort to create and increase a message's size, some JMS providers may be able to optimize message overhead if they are given a hint that the timestamp is not used by an application. By calling the MessageProducer.setDisableMessageTimestamp method, a JMS client enables this potential optimization for all messages sent by that message producer. If the JMS provider accepts this hint, these messages must have the timestamp set to zero; if the provider ignores the hint, the timestamp must be set to its normal value.

        Returns:
        the message timestamp
        Throws:
        JMSException - if the JMS provider fails to get the timestamp due to some internal error.
        See Also:
        setJMSTimestamp(long), MessageProducer.setDisableMessageTimestamp(boolean)

      • setJMSTimestamp

        void setJMSTimestamp(long timestamp)
                     throws JMSException
        Sets the message timestamp.

        This method is for use by JMS providers only to set this field when a message is sent. This message cannot be used by clients to configure the message timestamp. This method is public to allow a JMS provider to set this field when sending a message whose implementation is not its own.

        Parameters:
        timestamp - the timestamp for this message
        Throws:
        JMSException - if the JMS provider fails to set the timestamp due to some internal error.
        See Also:
        getJMSTimestamp()

      • getJMSCorrelationIDAsBytes

        byte[] getJMSCorrelationIDAsBytes()
                                  throws JMSException
        Gets the correlation ID as an array of bytes for the message.

        The use of a byte[] value for JMSCorrelationID is non-portable.

        Returns:
        the correlation ID of a message as an array of bytes
        Throws:
        JMSException - if the JMS provider fails to get the correlation ID due to some internal error.
        See Also:
        setJMSCorrelationID(String), getJMSCorrelationID(), setJMSCorrelationIDAsBytes(byte[])

      • setJMSCorrelationIDAsBytes

        void setJMSCorrelationIDAsBytes(byte[] correlationID)
                                throws JMSException
        Sets the correlation ID as an array of bytes for the message.

        The array is copied before the method returns, so future modifications to the array will not alter this message header.

        If a provider supports the native concept of correlation ID, a JMS client may need to assign specific JMSCorrelationID values to match those expected by native messaging clients. JMS providers without native correlation ID values are not required to support this method and its corresponding get method; their implementation may throw a java.lang.UnsupportedOperationException.

        The use of a byte[] value for JMSCorrelationID is non-portable.

        Parameters:
        correlationID - the correlation ID value as an array of bytes
        Throws:
        JMSException - if the JMS provider fails to set the correlation ID due to some internal error.
        See Also:
        setJMSCorrelationID(String), getJMSCorrelationID(), getJMSCorrelationIDAsBytes()

      • setJMSCorrelationID

        void setJMSCorrelationID(String correlationID)
                         throws JMSException
        Sets the correlation ID for the message.

        A client can use the JMSCorrelationID header field to link one message with another. A typical use is to link a response message with its request message.

        JMSCorrelationID can hold one of the following:

        • A provider-specific message ID
        • An application-specific String
        • A provider-native byte[] value

        Since each message sent by a JMS provider is assigned a message ID value, it is convenient to link messages via message ID. All message ID values must start with the 'ID:' prefix.

        In some cases, an application (made up of several clients) needs to use an application-specific value for linking messages. For instance, an application may use JMSCorrelationID to hold a value referencing some external information. Application-specified values must not start with the 'ID:' prefix; this is reserved for provider-generated message ID values.

        If a provider supports the native concept of correlation ID, a JMS client may need to assign specific JMSCorrelationID values to match those expected by clients that do not use the JMS API. A byte[] value is used for this purpose. JMS providers without native correlation ID values are not required to support byte[] values. The use of a byte[] value for JMSCorrelationID is non-portable.

        Parameters:
        correlationID - the message ID of a message being referred to
        Throws:
        JMSException - if the JMS provider fails to set the correlation ID due to some internal error.
        See Also:
        getJMSCorrelationID(),
getJMSCorrelationIDAsBytes(),
setJMSCorrelationIDAsBytes(byte[])

      • getJMSCorrelationID

        String getJMSCorrelationID()
                           throws JMSException
        Gets the correlation ID for the message.

        This method is used to return correlation ID values that are either provider-specific message IDs or application-specific String values.

        Returns:
        the correlation ID of a message as a String
        Throws:
        JMSException - if the JMS provider fails to get the correlation ID due to some internal error.
        See Also:
        setJMSCorrelationID(String), getJMSCorrelationIDAsBytes(), setJMSCorrelationIDAsBytes(byte[])

      • getJMSReplyTo

        Destination getJMSReplyTo()
                          throws JMSException
        Gets the Destination object to which a reply to this message should be sent.
        Returns:
        Destination to which to send a response to this message
        Throws:
        JMSException - if the JMS provider fails to get the JMSReplyTo destination due to some internal error.
        See Also:
        setJMSReplyTo(Destination)

      • setJMSReplyTo

        void setJMSReplyTo(Destination replyTo)
                   throws JMSException
        Sets the Destination object to which a reply to this message should be sent.

        The JMSReplyTo header field contains the destination where a reply to the current message should be sent. If it is null, no reply is expected. The destination may be either a Queue object or a Topic object.

        Messages sent with a null JMSReplyTo value may be a notification of some event, or they may just be some data the sender thinks is of interest.

        Messages with a JMSReplyTo value typically expect a response. A response is optional; it is up to the client to decide. These messages are called requests. A message sent in response to a request is called a reply.

        In some cases a client may wish to match a request it sent earlier with a reply it has just received. The client can use the JMSCorrelationID header field for this purpose.

        Parameters:
        replyTo - Destination to which to send a response to this message
        Throws:
        JMSException - if the JMS provider fails to set the JMSReplyTo destination due to some internal error.
        See Also:
        getJMSReplyTo()

      • getJMSDestination

        Destination getJMSDestination()
                              throws JMSException
        Gets the Destination object for this message.

        The JMSDestination header field contains the destination to which the message is being sent.

        When a message is sent, this field is ignored. After completion of the send or publish method, the field holds the destination specified by the method.

        When a message is received, its JMSDestination value must be equivalent to the value assigned when it was sent.

        Returns:
        the destination of this message
        Throws:
        JMSException - if the JMS provider fails to get the destination due to some internal error.
        See Also:
        setJMSDestination(Destination)

      • setJMSDestination

        void setJMSDestination(Destination destination)
                       throws JMSException
        Sets the Destination object for this message.

        This method is for use by JMS providers only to set this field when a message is sent. This message cannot be used by clients to configure the destination of the message. This method is public to allow a JMS provider to set this field when sending a message whose implementation is not its own.

        Parameters:
        destination - the destination for this message
        Throws:
        JMSException - if the JMS provider fails to set the destination due to some internal error.
        See Also:
        getJMSDestination()

      • getJMSDeliveryMode

        int getJMSDeliveryMode()
                       throws JMSException
        Gets the DeliveryMode value specified for this message.
        Returns:
        the delivery mode for this message
        Throws:
        JMSException - if the JMS provider fails to get the delivery mode due to some internal error.
        See Also:
        setJMSDeliveryMode(int), DeliveryMode

      • setJMSDeliveryMode

        void setJMSDeliveryMode(int deliveryMode)
                        throws JMSException
        Sets the DeliveryMode value for this message.

        This method is for use by JMS providers only to set this field when a message is sent. This message cannot be used by clients to configure the delivery mode of the message. This method is public to allow a JMS provider to set this field when sending a message whose implementation is not its own.

        Parameters:
        deliveryMode - the delivery mode for this message
        Throws:
        JMSException - if the JMS provider fails to set the delivery mode due to some internal error.
        See Also:
        getJMSDeliveryMode(), DeliveryMode

      • getJMSRedelivered

        boolean getJMSRedelivered()
                          throws JMSException
        Gets an indication of whether this message is being redelivered.

        If a client receives a message with the JMSRedelivered field set, it is likely, but not guaranteed, that this message was delivered earlier but that its receipt was not acknowledged at that time.

        Returns:
        true if this message is being redelivered
        Throws:
        JMSException - if the JMS provider fails to get the redelivered state due to some internal error.
        See Also:
        setJMSRedelivered(boolean)

      • setJMSRedelivered

        void setJMSRedelivered(boolean redelivered)
                       throws JMSException
        Specifies whether this message is being redelivered.

        This method is for use by JMS providers only to set this field when a message is delivered. This message cannot be used by clients to configure the redelivered status of the message. This method is public to allow a JMS provider to set this field when sending a message whose implementation is not its own.

        Parameters:
        redelivered - an indication of whether this message is being redelivered
        Throws:
        JMSException - if the JMS provider fails to set the redelivered state due to some internal error.
        See Also:
        getJMSRedelivered()

      • getJMSType

        String getJMSType()
                  throws JMSException
        Gets the message type identifier supplied by the client when the message was sent.
        Returns:
        the message type
        Throws:
        JMSException - if the JMS provider fails to get the message type due to some internal error.
        See Also:
        setJMSType(String)

      • setJMSType

        void setJMSType(String type)
                throws JMSException
        Sets the message type.

        Some JMS providers use a message repository that contains the definitions of messages sent by applications. The JMSType header field may reference a message's definition in the provider's repository.

        The JMS API does not define a standard message definition repository, nor does it define a naming policy for the definitions it contains.

        Some messaging systems require that a message type definition for each application message be created and that each message specify its type. In order to work with such JMS providers, JMS clients should assign a value to JMSType, whether the application makes use of it or not. This ensures that the field is properly set for those providers that require it.

        To ensure portability, JMS clients should use symbolic values for JMSType that can be configured at installation time to the values defined in the current provider's message repository. If string literals are used, they may not be valid type names for some JMS providers.

        Parameters:
        type - the message type
        Throws:
        JMSException - if the JMS provider fails to set the message type due to some internal error.
        See Also:
        getJMSType()

      • getJMSExpiration

        long getJMSExpiration()
                      throws JMSException
        Gets the message's expiration time.

        When a message is sent, the JMSExpiration header field is left unassigned. After completion of the send or publish method, it holds the expiration time of the message. This is the the difference, measured in milliseconds, between the expiration time and midnight, January 1, 1970 UTC.

        If the time-to-live is specified as zero, JMSExpiration is set to zero to indicate that the message does not expire.

        When a message's expiration time is reached, a provider should discard it. The JMS API does not define any form of notification of message expiration.

        Clients should not receive messages that have expired; however, the JMS API does not guarantee that this will not happen.

        Returns:
        the message's expiration time value
        Throws:
        JMSException - if the JMS provider fails to get the message expiration due to some internal error.
        See Also:
        setJMSExpiration(long)

      • setJMSExpiration

        void setJMSExpiration(long expiration)
                      throws JMSException
        Sets the message's expiration value.

        This method is for use by JMS providers only to set this field when a message is sent. This message cannot be used by clients to configure the expiration time of the message. This method is public to allow a JMS provider to set this field when sending a message whose implementation is not its own.

        Parameters:
        expiration - the message's expiration time
        Throws:
        JMSException - if the JMS provider fails to set the message expiration due to some internal error.
        See Also:
        getJMSExpiration()

      • getJMSDeliveryTime

        long getJMSDeliveryTime()
                        throws JMSException
        Gets the message's delivery time value.

        When a message is sent, the JMSDeliveryTime header field is left unassigned. After completion of the send or publish method, it holds the delivery time of the message. This is the the difference, measured in milliseconds, between the delivery time and midnight, January 1, 1970 UTC.

        A message's delivery time is the earliest time when a JMS provider may deliver the message to a consumer. The provider must not deliver messages before the delivery time has been reached.

        Returns:
        the message's delivery time value
        Throws:
        JMSException - if the JMS provider fails to get the delivery time due to some internal error.
        Since:
        JMS 2.0
        See Also:
        setJMSDeliveryTime(long)

      • setJMSDeliveryTime

        void setJMSDeliveryTime(long deliveryTime)
                        throws JMSException
        Sets the message's delivery time value.

        This method is for use by JMS providers only to set this field when a message is sent. This message cannot be used by clients to configure the delivery time of the message. This method is public to allow a JMS provider to set this field when sending a message whose implementation is not its own.

        Parameters:
        deliveryTime - the message's delivery time value
        Throws:
        JMSException - if the JMS provider fails to set the delivery time due to some internal error.
        Since:
        JMS 2.0
        See Also:
        getJMSDeliveryTime()

      • getJMSPriority

        int getJMSPriority()
                   throws JMSException
        Gets the message priority level.

        The JMS API defines ten levels of priority value, with 0 as the lowest priority and 9 as the highest. In addition, clients should consider priorities 0-4 as gradations of normal priority and priorities 5-9 as gradations of expedited priority.

        The JMS API does not require that a provider strictly implement priority ordering of messages; however, it should do its best to deliver expedited messages ahead of normal messages.

        Returns:
        the default message priority
        Throws:
        JMSException - if the JMS provider fails to get the message priority due to some internal error.
        See Also:
        setJMSPriority(int)

      • setJMSPriority

        void setJMSPriority(int priority)
                    throws JMSException
        Sets the priority level for this message.

        This method is for use by JMS providers only to set this field when a message is sent. This message cannot be used by clients to configure the priority level of the message. This method is public to allow a JMS provider to set this field when sending a message whose implementation is not its own.

        Parameters:
        priority - the priority of this message
        Throws:
        JMSException - if the JMS provider fails to set the message priority due to some internal error.
        See Also:
        getJMSPriority()

      • clearProperties

        void clearProperties()
                     throws JMSException
        Clears a message's properties.

        The message's header fields and body are not cleared.

        Throws:
        JMSException - if the JMS provider fails to clear the message properties due to some internal error.

      • propertyExists

        boolean propertyExists(String name)
                       throws JMSException
        Indicates whether a property value exists.
        Parameters:
        name - the name of the property to test
        Returns:
        true if the property exists
        Throws:
        JMSException - if the JMS provider fails to determine if the property exists due to some internal error.

      • getBooleanProperty

        boolean getBooleanProperty(String name)
                           throws JMSException
        Returns the value of the boolean property with the specified name.
        Parameters:
        name - the name of the boolean property
        Returns:
        the boolean property value for the specified name
        Throws:
        JMSException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getByteProperty

        byte getByteProperty(String name)
                     throws JMSException
        Returns the value of the byte property with the specified name.
        Parameters:
        name - the name of the byte property
        Returns:
        the byte property value for the specified name
        Throws:
        JMSException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getShortProperty

        short getShortProperty(String name)
                       throws JMSException
        Returns the value of the short property with the specified name.
        Parameters:
        name - the name of the short property
        Returns:
        the short property value for the specified name
        Throws:
        JMSException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getIntProperty

        int getIntProperty(String name)
                   throws JMSException
        Returns the value of the int property with the specified name.
        Parameters:
        name - the name of the int property
        Returns:
        the int property value for the specified name
        Throws:
        JMSException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getLongProperty

        long getLongProperty(String name)
                     throws JMSException
        Returns the value of the long property with the specified name.
        Parameters:
        name - the name of the long property
        Returns:
        the long property value for the specified name
        Throws:
        JMSException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getFloatProperty

        float getFloatProperty(String name)
                       throws JMSException
        Returns the value of the float property with the specified name.
        Parameters:
        name - the name of the float property
        Returns:
        the float property value for the specified name
        Throws:
        JMSException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getDoubleProperty

        double getDoubleProperty(String name)
                         throws JMSException
        Returns the value of the double property with the specified name.
        Parameters:
        name - the name of the double property
        Returns:
        the double property value for the specified name
        Throws:
        JMSException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getStringProperty

        String getStringProperty(String name)
                         throws JMSException
        Returns the value of the String property with the specified name.
        Parameters:
        name - the name of the String property
        Returns:
        the String property value for the specified name; if there is no property by this name, a null value is returned
        Throws:
        JMSException - if the JMS provider fails to get the property value due to some internal error.
        MessageFormatException - if this type conversion is invalid.

      • getObjectProperty

        Object getObjectProperty(String name)
                         throws JMSException
        Returns the value of the Java object property with the specified name.

        This method can be used to return, in objectified format, an object that has been stored as a property in the message with the equivalent setObjectProperty method call, or its equivalent primitive set<I>type</I>Property method.

        Parameters:
        name - the name of the Java object property
        Returns:
        the Java object property value with the specified name, in objectified format (for example, if the property was set as an int, an Integer is returned); if there is no property by this name, a null value is returned
        Throws:
        JMSException - if the JMS provider fails to get the property value due to some internal error.

      • getPropertyNames

        Enumeration getPropertyNames()
                             throws JMSException
        Returns an Enumeration of all the property names.

        Note that JMS standard header fields are not considered properties and are not returned in this enumeration.

        Returns:
        an enumeration of all the names of property values
        Throws:
        JMSException - if the JMS provider fails to get the property names due to some internal error.

      • setBooleanProperty

        void setBooleanProperty(String name,
                      boolean value)
                        throws JMSException
        Sets a boolean property value with the specified name into the message.
        Parameters:
        name - the name of the boolean property
        value - the boolean property value to set
        Throws:
        JMSException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if properties are read-only

      • setByteProperty

        void setByteProperty(String name,
                   byte value)
                     throws JMSException
        Sets a byte property value with the specified name into the message.
        Parameters:
        name - the name of the byte property
        value - the byte property value to set
        Throws:
        JMSException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if properties are read-only

      • setShortProperty

        void setShortProperty(String name,
                    short value)
                      throws JMSException
        Sets a short property value with the specified name into the message.
        Parameters:
        name - the name of the short property
        value - the short property value to set
        Throws:
        JMSException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if properties are read-only

      • setIntProperty

        void setIntProperty(String name,
                  int value)
                    throws JMSException
        Sets an int property value with the specified name into the message.
        Parameters:
        name - the name of the int property
        value - the int property value to set
        Throws:
        JMSException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if properties are read-only

      • setLongProperty

        void setLongProperty(String name,
                   long value)
                     throws JMSException
        Sets a long property value with the specified name into the message.
        Parameters:
        name - the name of the long property
        value - the long property value to set
        Throws:
        JMSException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if properties are read-only

      • setFloatProperty

        void setFloatProperty(String name,
                    float value)
                      throws JMSException
        Sets a float property value with the specified name into the message.
        Parameters:
        name - the name of the float property
        value - the float property value to set
        Throws:
        JMSException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if properties are read-only

      • setDoubleProperty

        void setDoubleProperty(String name,
                     double value)
                       throws JMSException
        Sets a double property value with the specified name into the message.
        Parameters:
        name - the name of the double property
        value - the double property value to set
        Throws:
        JMSException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if properties are read-only

      • setStringProperty

        void setStringProperty(String name,
                     String value)
                       throws JMSException
        Sets a String property value with the specified name into the message.
        Parameters:
        name - the name of the String property
        value - the String property value to set
        Throws:
        JMSException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageNotWriteableException - if properties are read-only

      • setObjectProperty

        void setObjectProperty(String name,
                     Object value)
                       throws JMSException
        Sets a Java object property value with the specified name into the message.

        Note that this method works only for the objectified primitive object types (Integer, Double, Long ...) and String objects.

        Parameters:
        name - the name of the Java object property
        value - the Java object property value to set
        Throws:
        JMSException - if the JMS provider fails to set the property due to some internal error.
        IllegalArgumentException - if the name is null or if the name is an empty string.
        MessageFormatException - if the object is invalid
        MessageNotWriteableException - if properties are read-only

      • acknowledge

        void acknowledge()
                 throws JMSException
        Acknowledges all consumed messages of the session of this consumed message.

        All consumed JMS messages support the acknowledge method for use when a client has specified that its JMS session's consumed messages are to be explicitly acknowledged. By invoking acknowledge on a consumed message, a client acknowledges all messages consumed by the session that the message was delivered to.

        Calls to acknowledge are ignored for both transacted sessions and sessions specified to use implicit acknowledgement modes.

        A client may individually acknowledge each message as it is consumed, or it may choose to acknowledge messages as an application-defined group (which is done by calling acknowledge on the last received message of the group, thereby acknowledging all messages consumed by the session.)

        Messages that have been received but not acknowledged may be redelivered.

        Throws:
        JMSException - if the JMS provider fails to acknowledge the messages due to some internal error.
        IllegalStateException - if this method is called on a closed session.
        See Also:
        Session.CLIENT_ACKNOWLEDGE

      • clearBody

        void clearBody()
               throws JMSException
        Clears out the message body. Clearing a message's body does not clear its header values or property entries.

        If this message body was read-only, calling this method leaves the message body in the same state as an empty body in a newly created message.

        Throws:
        JMSException - if the JMS provider fails to clear the message body due to some internal error.

      • getBody

        <T> T getBody(Class<T> c)
          throws JMSException
        Returns the message body as an object of the specified type. This method may be called on any type of message except for StreamMessage. The message body must be capable of being assigned to the specified type. This means that the specified class or interface must be either the same as, or a superclass or superinterface of, the class of the message body. If the message has no body then any type may be specified and null is returned.

        Parameters:
        c - The type to which the message body will be assigned.
        If the message is a TextMessage then this parameter must be set to String.class or another type to which a String is assignable.
        If the message is a ObjectMessage then parameter must must be set to java.io.Serializable.class or another type to which the body is assignable.
        If the message is a MapMessage then this parameter must be set to java.util.Map.class (or java.lang.Object.class).
        If the message is a BytesMessage then this parameter must be set to byte[].class (or java.lang.Object.class). This method will reset the BytesMessage before and after use.
        If the message is a TextMessage, ObjectMessage, MapMessage or BytesMessage and the message has no body, then the above does not apply and this parameter may be set to any type; the returned value will always be null.
        If the message is a Message (but not one of its subtypes) then this parameter may be set to any type; the returned value will always be null.
        Returns:
        the message body
        Throws:
        MessageFormatException -
        • if the message is a StreamMessage
        • if the message body cannot be assigned to the specified type
        • if the message is an ObjectMessage and object deserialization fails.
        JMSException - if the JMS provider fails to get the message body due to some internal error.
        Since:
        JMS 2.0

      • isBodyAssignableTo

        boolean isBodyAssignableTo(Class c)
                           throws JMSException
        Returns whether the message body is capable of being assigned to the specified type. If this method returns true then a subsequent call to the method getBody on the same message with the same type argument would not throw a MessageFormatException.

        If the message is a StreamMessage then false is always returned. If the message is a ObjectMessage and object deserialization fails then false is returned. If the message has no body then any type may be specified and true is returned.

        Parameters:
        c - The specified type
        If the message is a TextMessage then this method will only return true if this parameter is set to String.class or another type to which a String is assignable.
        If the message is a ObjectMessage then this method will only return true if this parameter is set to java.io.Serializable.class or another class to which the body is assignable.
        If the message is a MapMessage then this method will only return true if this parameter is set to java.util.Map.class (or java.lang.Object.class).
        If the message is a BytesMessage then this this method will only return true if this parameter is set to byte[].class (or java.lang.Object.class).
        If the message is a TextMessage, ObjectMessage, MapMessage or BytesMessage and the message has no body, then the above does not apply and this method will return true irrespective of the value of this parameter.
        If the message is a Message (but not one of its subtypes) then this method will return true irrespective of the value of this parameter.
        Returns:
        whether the message body is capable of being assigned to the specified type
        Throws:
        JMSException - if the JMS provider fails to return a value due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageConsumer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface MessageConsumer

  • All Superinterfaces:
    AutoCloseable
    All Known Subinterfaces:
    QueueReceiver, TopicSubscriber

    public interface MessageConsumer
extends AutoCloseable
    A client uses a MessageConsumer object to receive messages from a destination. A MessageConsumer object is created by passing a Destination object to a message-consumer creation method supplied by a session.

    MessageConsumer is the parent interface for all message consumers.

    A MessageConsumer can be created with a message selector. A message selector allows the client to restrict the messages delivered to the message consumer to those that match the selector.

    A client may either synchronously receive a MessageConsumer's messages or have the MessageConsumer asynchronously deliver them as they arrive.

    For synchronous receipt, a client can request the next message from a MessageConsumer using one of its receive methods. There are several variations of receive that allow a client to poll or wait for the next message.

    For asynchronous delivery, a client can register a MessageListener object with a MessageConsumer. As messages arrive at the MessageConsumer, it delivers them by calling the MessageListener's onMessage method.

    It is a client programming error for a MessageListener to throw an exception.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    QueueReceiver, TopicSubscriber, Session

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes the message consumer.
      MessageListener getMessageListener()
      Gets the MessageConsumer's MessageListener.
      String getMessageSelector()
      Gets this message consumer's message selector expression.
      Message receive()
      Receives the next message produced for this message consumer.
      Message receive(long timeout)
      Receives the next message that arrives within the specified timeout interval.
      Message receiveNoWait()
      Receives the next message if one is immediately available.
      void setMessageListener(MessageListener listener)
      Sets the MessageConsumer's MessageListener.

    • Method Detail

      • getMessageSelector

        String getMessageSelector()
                          throws JMSException
        Gets this message consumer's message selector expression.
        Returns:
        this message consumer's message selector, or null if no message selector exists for the message consumer (that is, if the message selector was not set or was set to null or the empty string)
        Throws:
        JMSException - if the JMS provider fails to get the message selector due to some internal error.

      • getMessageListener

        MessageListener getMessageListener()
                                   throws JMSException
        Gets the MessageConsumer's MessageListener.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Returns:
        the MessageConsumer's MessageListener, or null if one was not set
        Throws:
        JMSException - if the JMS provider fails to get the MessageListener for one of the following reasons:
        • an internal error has occurred or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        See Also:
        setMessageListener(javax.jms.MessageListener)

      • setMessageListener

        void setMessageListener(MessageListener listener)
                        throws JMSException
        Sets the MessageConsumer's MessageListener.

        Setting the the MessageListener to null is the equivalent of unsetting the MessageListener for the MessageConsumer.

        The effect of calling this method while messages are being consumed by an existing listener or the MessageConsumer is being used to consume messages synchronously is undefined.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Parameters:
        listener - the listener to which the messages are to be delivered
        Throws:
        JMSException - if the JMS provider fails to set the MessageConsumer's MessageListener for one of the following reasons:
        • an internal error has occurred or
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        See Also:
        getMessageListener()

      • receive

        Message receive()
                throws JMSException
        Receives the next message produced for this message consumer.

        This call blocks indefinitely until a message is produced or until this message consumer is closed.

        If this receive is done within a transaction, the consumer retains the message until the transaction commits.

        Returns:
        the next message produced for this message consumer, or null if this message consumer is concurrently closed
        Throws:
        JMSException - if the JMS provider fails to receive the next message due to some internal error.

      • receive

        Message receive(long timeout)
                throws JMSException
        Receives the next message that arrives within the specified timeout interval.

        This call blocks until a message arrives, the timeout expires, or this message consumer is closed. A timeout of zero never expires, and the call blocks indefinitely.

        Parameters:
        timeout - the timeout value (in milliseconds)
        Returns:
        the next message produced for this message consumer, or null if the timeout expires or this message consumer is concurrently closed
        Throws:
        JMSException - if the JMS provider fails to receive the next message due to some internal error.

      • receiveNoWait

        Message receiveNoWait()
                      throws JMSException
        Receives the next message if one is immediately available.
        Returns:
        the next message produced for this message consumer, or null if one is not available
        Throws:
        JMSException - if the JMS provider fails to receive the next message due to some internal error.

      • close

        void close()
           throws JMSException
        Closes the message consumer.

        Since a provider may allocate some resources on behalf of a MessageConsumer outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

        This call will block until a receive call in progress on this consumer has completed. A blocked receive call returns null when this message consumer is closed.

        If this method is called whilst a message listener is in progress in another thread then it will block until the message listener has completed.

        This method may be called from a message listener's onMessage method on its own consumer. After this method returns the onMessage method will be allowed to complete normally.

        This method is the only MessageConsumer method that can be called concurrently.

        Specified by:
        close in interface AutoCloseable
        Throws:
        JMSException - if the JMS provider fails to close the consumer due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageEOFException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class MessageEOFException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.MessageEOFException
  • All Implemented Interfaces:
    Serializable

    public class MessageEOFException
extends JMSException

    This exception must be thrown when an unexpected end of stream has been reached when a StreamMessage or BytesMessage is being read.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageEOFException(String reason)
      Constructs a MessageEOFException with the specified reason.
      MessageEOFException(String reason, String errorCode)
      Constructs a MessageEOFException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MessageEOFException

        public MessageEOFException(String reason,
                   String errorCode)
        Constructs a MessageEOFException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • MessageEOFException

        public MessageEOFException(String reason)
        Constructs a MessageEOFException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageFormatException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class MessageFormatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.MessageFormatException
  • All Implemented Interfaces:
    Serializable

    public class MessageFormatException
extends JMSException

    This exception must be thrown when a JMS client attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type. It must also be thrown when equivalent type errors are made with message property values. For example, this exception must be thrown if StreamMessage.writeObject is given an unsupported class or if StreamMessage.readShort is used to read a boolean value. Note that the special case of a failure caused by an attempt to read improperly formatted String data as numeric values must throw the java.lang.NumberFormatException.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageFormatException(String reason)
      Constructs a MessageFormatException with the specified reason.
      MessageFormatException(String reason, String errorCode)
      Constructs a MessageFormatException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MessageFormatException

        public MessageFormatException(String reason,
                      String errorCode)
        Constructs a MessageFormatException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • MessageFormatException

        public MessageFormatException(String reason)
        Constructs a MessageFormatException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageFormatRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class MessageFormatRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.MessageFormatRuntimeException
  • All Implemented Interfaces:
    Serializable

    public class MessageFormatRuntimeException
extends JMSRuntimeException
    This unchecked exception must be thrown when a JMS application attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type, and the method signature does not permit a MessageFormatException to be thrown. It must also be thrown when equivalent type errors are made with message property values. Note that the special case of a failure caused by an attempt to read improperly formatted String data as numeric values must throw the java.lang.NumberFormatException.
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageFormatRuntimeException(String detailMessage)
      Constructs a MessageFormatRuntimeException with the specified detail message
      MessageFormatRuntimeException(String detailMessage, String errorCode)
      Constructs a MessageFormatRuntimeException with the specified detail message and error code.
      MessageFormatRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a MessageFormatRuntimeException with the specified detail message, error code and cause

    • Method Summary

      • Methods inherited from class javax.jms.JMSRuntimeException

        getErrorCode

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MessageFormatRuntimeException

        public MessageFormatRuntimeException(String detailMessage)
        Constructs a MessageFormatRuntimeException with the specified detail message
        Parameters:
        detailMessage - a description of the exception

      • MessageFormatRuntimeException

        public MessageFormatRuntimeException(String detailMessage,
                             String errorCode)
        Constructs a MessageFormatRuntimeException with the specified detail message and error code.
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code

      • MessageFormatRuntimeException

        public MessageFormatRuntimeException(String detailMessage,
                             String errorCode,
                             Throwable cause)
        Constructs a MessageFormatRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface MessageListener

  • public interface MessageListener
    A MessageListener object is used to receive asynchronously delivered messages.

    Each session must ensure that it passes messages serially to the listener. This means that a listener assigned to one or more consumers of the same session can assume that the onMessage method is not called with the next message until the session has completed the last call.

    Since:
    JMS 1.0
    Version:
    JMS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onMessage(Message message)
      Passes a message to the listener.

    • Method Detail

      • onMessage

        void onMessage(Message message)
        Passes a message to the listener.
        Parameters:
        message - the message passed to the listener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageNotReadableException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class MessageNotReadableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.MessageNotReadableException
  • All Implemented Interfaces:
    Serializable

    public class MessageNotReadableException
extends JMSException

    This exception must be thrown when a JMS client attempts to read a write-only message.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageNotReadableException(String reason)
      Constructs a MessageNotReadableException with the specified reason.
      MessageNotReadableException(String reason, String errorCode)
      Constructs a MessageNotReadableException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MessageNotReadableException

        public MessageNotReadableException(String reason,
                           String errorCode)
        Constructs a MessageNotReadableException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • MessageNotReadableException

        public MessageNotReadableException(String reason)
        Constructs a MessageNotReadableException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageNotWriteableException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class MessageNotWriteableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.MessageNotWriteableException
  • All Implemented Interfaces:
    Serializable

    public class MessageNotWriteableException
extends JMSException

    This exception must be thrown when a JMS client attempts to write to a read-only message.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageNotWriteableException(String reason)
      Constructs a MessageNotWriteableException with the specified reason.
      MessageNotWriteableException(String reason, String errorCode)
      Constructs a MessageNotWriteableException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MessageNotWriteableException

        public MessageNotWriteableException(String reason,
                            String errorCode)
        Constructs a MessageNotWriteableException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • MessageNotWriteableException

        public MessageNotWriteableException(String reason)
        Constructs a MessageNotWriteableException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageNotWriteableRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class MessageNotWriteableRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.MessageNotWriteableRuntimeException
  • All Implemented Interfaces:
    Serializable

    public class MessageNotWriteableRuntimeException
extends JMSRuntimeException

    This unchecked exception must be thrown when a JMS client attempts to write to a read-only message.

    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageNotWriteableRuntimeException(String reason)
      Constructs a MessageNotWriteableRuntimeException with the specified reason.
      MessageNotWriteableRuntimeException(String reason, String errorCode)
      Constructs a MessageNotWriteableRuntimeException with the specified reason and error code.
      MessageNotWriteableRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a MessageNotWriteableRuntimeException with the specified detail message, error code and cause

    • Method Summary

      • Methods inherited from class javax.jms.JMSRuntimeException

        getErrorCode

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MessageNotWriteableRuntimeException

        public MessageNotWriteableRuntimeException(String reason,
                                   String errorCode)
        Constructs a MessageNotWriteableRuntimeException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • MessageNotWriteableRuntimeException

        public MessageNotWriteableRuntimeException(String reason)
        Constructs a MessageNotWriteableRuntimeException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception

      • MessageNotWriteableRuntimeException

        public MessageNotWriteableRuntimeException(String detailMessage,
                                   String errorCode,
                                   Throwable cause)
        Constructs a MessageNotWriteableRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageProducer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface MessageProducer

  • All Superinterfaces:
    AutoCloseable
    All Known Subinterfaces:
    QueueSender, TopicPublisher

    public interface MessageProducer
extends AutoCloseable
    A client uses a MessageProducer object to send messages to a destination. A MessageProducer object is created by passing a Destination object to a message-producer creation method supplied by a session.

    MessageProducer is the parent interface for all message producers.

    A client also has the option of creating a message producer without supplying a destination. In this case, a destination must be provided with every send operation. A typical use for this kind of message producer is to send replies to requests using the request's JMSReplyTo destination.

    A client can specify a default delivery mode, priority, time to live and delivery delay for messages sent by a message producer. It can also specify the delivery mode, priority, and time to live for an individual message.

    A client can specify a time-to-live value in milliseconds for each message it sends. This value defines a message expiration time that is the sum of the message's time-to-live and the GMT when it is sent (for transacted sends, this is the time the client sends the message, not the time the transaction is committed).

    A JMS provider should do its best to expire messages accurately; however, the JMS API does not define the accuracy provided.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    TopicPublisher, QueueSender, Session.createProducer(javax.jms.Destination)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes the message producer.
      long getDeliveryDelay()
      Gets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.
      int getDeliveryMode()
      Gets the producer's default delivery mode.
      Destination getDestination()
      Gets the destination associated with this MessageProducer.
      boolean getDisableMessageID()
      Gets an indication of whether message IDs are disabled.
      boolean getDisableMessageTimestamp()
      Gets an indication of whether message timestamps are disabled.
      int getPriority()
      Gets the producer's default priority.
      long getTimeToLive()
      Gets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.
      void send(Destination destination, Message message)
      Sends a message to a destination for an unidentified message producer using the MessageProducer's default delivery mode, priority, and time to live.
      void send(Destination destination, Message message, CompletionListener completionListener)
      Sends a message to a destination for an unidentified message producer, using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live.
      void send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive, CompletionListener completionListener)
      Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void send(Message message)
      Sends a message using the MessageProducer's default delivery mode, priority, and time to live.
      void send(Message message, CompletionListener completionListener)
      Sends a message using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void send(Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message, specifying delivery mode, priority, and time to live.
      void send(Message message, int deliveryMode, int priority, long timeToLive, CompletionListener completionListener)
      Sends a message, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void setDeliveryDelay(long deliveryDelay)
      Sets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.
      void setDeliveryMode(int deliveryMode)
      Sets the producer's default delivery mode.
      void setDisableMessageID(boolean value)
      Specify whether message IDs may be disabled.
      void setDisableMessageTimestamp(boolean value)
      Specify whether message timestamps may be disabled.
      void setPriority(int defaultPriority)
      Sets the producer's default priority.
      void setTimeToLive(long timeToLive)
      Sets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.

    • Method Detail

      • setDisableMessageID

        void setDisableMessageID(boolean value)
                         throws JMSException
        Specify whether message IDs may be disabled.

        Since message IDs take some effort to create and increase a message's size, some JMS providers may be able to optimise message overhead if they are given a hint that the message ID is not used by an application. By calling this method, a JMS application enables this potential optimisation for all messages sent using this MessageProducer. If the JMS provider accepts this hint, these messages must have the message ID set to null; if the provider ignores the hint, the message ID must be set to its normal unique value.

        Message IDs are enabled by default.

        Parameters:
        value - indicates if message IDs may be disabled
        Throws:
        JMSException - if the JMS provider fails to set message ID to disabled due to some internal error.

      • getDisableMessageID

        boolean getDisableMessageID()
                            throws JMSException
        Gets an indication of whether message IDs are disabled.
        Returns:
        an indication of whether message IDs are disabled
        Throws:
        JMSException - if the JMS provider fails to determine if message IDs are disabled due to some internal error.

      • setDisableMessageTimestamp

        void setDisableMessageTimestamp(boolean value)
                                throws JMSException
        Specify whether message timestamps may be disabled.

        Since timestamps take some effort to create and increase a message's size, some JMS providers may be able to optimise message overhead if they are given a hint that the timestamp is not used by an application. By calling this method, a JMS application enables this potential optimisation for all messages sent using this MessageProducer. If the JMS provider accepts this hint, these messages must have the timestamp set to zero; if the provider ignores the hint, the timestamp must be set to its normal value.

        Message timestamps are enabled by default.

        Parameters:
        value - indicates whether message timestamps may be disabled
        Throws:
        JMSException - if the JMS provider fails to set timestamps to disabled due to some internal error.

      • getDisableMessageTimestamp

        boolean getDisableMessageTimestamp()
                                   throws JMSException
        Gets an indication of whether message timestamps are disabled.
        Returns:
        an indication of whether message timestamps are disabled
        Throws:
        JMSException - if the JMS provider fails to determine if timestamps are disabled due to some internal error.

      • setDeliveryMode

        void setDeliveryMode(int deliveryMode)
                     throws JMSException
        Sets the producer's default delivery mode.

        Delivery mode is set to PERSISTENT by default.

        Parameters:
        deliveryMode - the message delivery mode for this message producer; legal values are DeliveryMode.NON_PERSISTENT and DeliveryMode.PERSISTENT
        Throws:
        JMSException - if the JMS provider fails to set the delivery mode due to some internal error.
        See Also:
        getDeliveryMode(), DeliveryMode.NON_PERSISTENT, DeliveryMode.PERSISTENT, Message.DEFAULT_DELIVERY_MODE

      • getDeliveryMode

        int getDeliveryMode()
                    throws JMSException
        Gets the producer's default delivery mode.
        Returns:
        the message delivery mode for this message producer
        Throws:
        JMSException - if the JMS provider fails to get the delivery mode due to some internal error.
        See Also:
        setDeliveryMode(int)

      • setPriority

        void setPriority(int defaultPriority)
                 throws JMSException
        Sets the producer's default priority.

        The JMS API defines ten levels of priority value, with 0 as the lowest priority and 9 as the highest. Clients should consider priorities 0-4 as gradations of normal priority and priorities 5-9 as gradations of expedited priority. Priority is set to 4 by default.

        Parameters:
        defaultPriority - the message priority for this message producer; must be a value between 0 and 9
        Throws:
        JMSException - if the JMS provider fails to set the priority due to some internal error.
        See Also:
        getPriority(), Message.DEFAULT_PRIORITY

      • getPriority

        int getPriority()
                throws JMSException
        Gets the producer's default priority.
        Returns:
        the message priority for this message producer
        Throws:
        JMSException - if the JMS provider fails to get the priority due to some internal error.
        See Also:
        setPriority(int)

      • setTimeToLive

        void setTimeToLive(long timeToLive)
                   throws JMSException
        Sets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.

        Time to live is set to zero by default.

        Parameters:
        timeToLive - the message time to live in milliseconds; zero is unlimited
        Throws:
        JMSException - if the JMS provider fails to set the time to live due to some internal error.
        See Also:
        getTimeToLive(), Message.DEFAULT_TIME_TO_LIVE

      • getTimeToLive

        long getTimeToLive()
                   throws JMSException
        Gets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.
        Returns:
        the message time to live in milliseconds; zero is unlimited
        Throws:
        JMSException - if the JMS provider fails to get the time to live due to some internal error.
        See Also:
        setTimeToLive(long)

      • setDeliveryDelay

        void setDeliveryDelay(long deliveryDelay)
                      throws JMSException
        Sets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.

        For transacted sends, this time starts when the client sends the message, not when the transaction is committed.

        deliveryDelay is set to zero by default.

        Parameters:
        deliveryDelay - the delivery delay in milliseconds.
        Throws:
        JMSException - if the JMS provider fails to set the delivery delay due to some internal error.
        Since:
        JMS 2.0
        See Also:
        getDeliveryDelay(), Message.DEFAULT_DELIVERY_DELAY

      • getDeliveryDelay

        long getDeliveryDelay()
                      throws JMSException
        Gets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.
        Returns:
        the delivery delay in milliseconds.
        Throws:
        JMSException - if the JMS provider fails to get the delivery delay due to some internal error.
        Since:
        JMS 2.0
        See Also:
        setDeliveryDelay(long)

      • getDestination

        Destination getDestination()
                           throws JMSException
        Gets the destination associated with this MessageProducer.
        Returns:
        this producer's Destination
        Throws:
        JMSException - if the JMS provider fails to get the destination for this MessageProducer due to some internal error.
        Since:
        JMS 1.1

      • close

        void close()
           throws JMSException
        Closes the message producer.

        Since a provider may allocate some resources on behalf of a MessageProducer outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

        This method must not return until any incomplete asynchronous send operations for this MessageProducer have been completed and any CompletionListener callbacks have returned. Incomplete sends should be allowed to complete normally unless an error occurs.

        A CompletionListener callback method must not call close on its own MessageProducer. Doing so will cause an IllegalStateException to be thrown.

        Specified by:
        close in interface AutoCloseable
        Throws:
        IllegalStateException - this method has been called by a CompletionListener callback method on its own MessageProducer
        JMSException - if the JMS provider fails to close the producer due to some internal error.

      • send

        void send(Message message)
          throws JMSException
        Sends a message using the MessageProducer's default delivery mode, priority, and time to live.
        Parameters:
        message - the message to send
        Throws:
        JMSException - if the JMS provider fails to send the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with a MessageProducer with an invalid destination.
        UnsupportedOperationException - if a client uses this method with a MessageProducer that did not specify a destination at creation time.
        Since:
        JMS 1.1
        See Also:
        Session.createProducer(javax.jms.Destination)

      • send

        void send(Message message,
        int deliveryMode,
        int priority,
        long timeToLive)
          throws JMSException
        Sends a message, specifying delivery mode, priority, and time to live.
        Parameters:
        message - the message to send
        deliveryMode - the delivery mode to use
        priority - the priority for this message
        timeToLive - the message's lifetime (in milliseconds)
        Throws:
        JMSException - if the JMS provider fails to send the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with a MessageProducer with an invalid destination.
        UnsupportedOperationException - if a client uses this method with a MessageProducer that did not specify a destination at creation time.
        Since:
        JMS 1.1
        See Also:
        Session.createProducer(javax.jms.Destination)

      • send

        void send(Destination destination,
        Message message)
          throws JMSException
        Sends a message to a destination for an unidentified message producer using the MessageProducer's default delivery mode, priority, and time to live.

        Typically, a message producer is assigned a destination at creation time; however, the JMS API also supports unidentified message producers, which require that the destination be supplied every time a message is sent.

        Parameters:
        destination - the destination to send this message to
        message - the message to send
        Throws:
        JMSException - if the JMS provider fails to send the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with an invalid destination.
        UnsupportedOperationException - if a client uses this method with a MessageProducer that specified a destination at creation time.
        Since:
        JMS 1.1
        See Also:
        Session.createProducer(javax.jms.Destination)

      • send

        void send(Destination destination,
        Message message,
        int deliveryMode,
        int priority,
        long timeToLive)
          throws JMSException
        Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live.

        Typically, a message producer is assigned a destination at creation time; however, the JMS API also supports unidentified message producers, which require that the destination be supplied every time a message is sent.

        Parameters:
        destination - the destination to send this message to
        message - the message to send
        deliveryMode - the delivery mode to use
        priority - the priority for this message
        timeToLive - the message's lifetime (in milliseconds)
        Throws:
        JMSException - if the JMS provider fails to send the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with an invalid destination.
        UnsupportedOperationException - if a client uses this method with a MessageProducer that specified a destination at creation time.
        Since:
        JMS 1.1
        See Also:
        Session.createProducer(javax.jms.Destination)

      • send

        void send(Message message,
        CompletionListener completionListener)
          throws JMSException
        Sends a message using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed. JMS refers to this as an "asynchronous send".

        When the message has been successfully sent the JMS provider invokes the callback method onCompletion on an application-specified CompletionListener object. Only when that callback has been invoked can the application be sure that the message has been successfully sent with the same degree of confidence as if a normal synchronous send had been performed. An application which requires this degree of confidence must therefore wait for the callback to be invoked before continuing.

        The following information is intended to give an indication of how an asynchronous send would typically be implemented.

        In some JMS providers, a normal synchronous send involves sending the message to a remote JMS server and then waiting for an acknowledgement to be received before returning. It is expected that such a provider would implement an asynchronous send by sending the message to the remote JMS server and then returning without waiting for an acknowledgement. When the acknowledgement is received, the JMS provider would notify the application by invoking the onCompletion method on the application-specified CompletionListener object. If for some reason the acknowledgement is not received the JMS provider would notify the application by invoking the CompletionListener's onException method.

        In those cases where the JMS specification permits a lower level of reliability, a normal synchronous send might not wait for an acknowledgement. In that case it is expected that an asynchronous send would be similar to a synchronous send: the JMS provider would send the message to the remote JMS server and then return without waiting for an acknowledgement. However the JMS provider would still notify the application that the send had completed by invoking the onCompletion method on the application-specified CompletionListener object.

        It is up to the JMS provider to decide exactly what is performed in the calling thread and what, if anything, is performed asynchronously, so long as it satisfies the requirements given below:

        Quality of service: After the send operation has completed successfully, which means that the message has been successfully sent with the same degree of confidence as if a normal synchronous send had been performed, the JMS provider must invoke the CompletionListener's onCompletion method. The CompletionListener must not be invoked earlier than this.

        Exceptions: If an exception is encountered during the call to the send method then an appropriate exception should be thrown in the thread that is calling the send method. In this case the JMS provider must not invoke the CompletionListener's onCompletion or onException method. If an exception is encountered which cannot be thrown in the thread that is calling the send method then the JMS provider must call the CompletionListener's onException method. In both cases if an exception occurs it is undefined whether or not the message was successfully sent.

        Message order: If the same MessageProducer is used to send multiple messages then JMS message ordering requirements must be satisfied. This applies even if a combination of synchronous and asynchronous sends has been performed. The application is not required to wait for an asynchronous send to complete before sending the next message.

        Close, commit or rollback: If the close method is called on the MessageProducer or its Session or Connection then the JMS provider must block until any incomplete send operations have been completed and all CompletionListener callbacks have returned before closing the object and returning. If the session is transacted (uses a local transaction) then when the Session's commit or rollback method is called the JMS provider must block until any incomplete send operations have been completed and all CompletionListener callbacks have returned before performing the commit or rollback. Incomplete sends should be allowed to complete normally unless an error occurs.

        A CompletionListener callback method must not call close on its own Connection, Session or MessageProducer or call commit or rollback on its own Session. Doing so will cause the close, commit or rollback to throw an IllegalStateException.

        Restrictions on usage in Java EE This method must not be used in a Java EE EJB or web container. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Message headers JMS defines a number of message header fields and message properties which must be set by the "JMS provider on send". If the send is asynchronous these fields and properties may be accessed on the sending client only after the CompletionListener has been invoked. If the CompletionListener's onException method is called then the state of these message header fields and properties is undefined.

        Restrictions on threading: Applications that perform an asynchronous send must confirm to the threading restrictions defined in JMS. This means that the session may be used by only one thread at a time.

        Setting a CompletionListener does not cause the session to be dedicated to the thread of control which calls the CompletionListener. The application thread may therefore continue to use the session after performing an asynchronous send. However the CompletionListener's callback methods must not use the session if an application thread might be using the session at the same time.

        Use of the CompletionListener by the JMS provider: A session will only invoke one CompletionListener callback method at a time. For a given MessageProducer, callbacks (both onCompletion and onException) will be performed in the same order as the corresponding calls to the asynchronous send method. A JMS provider must not invoke the CompletionListener from the thread that is calling the asynchronous send method.

        Restrictions on the use of the Message object: Applications which perform an asynchronous send must take account of the restriction that a Message object is designed to be accessed by one logical thread of control at a time and does not support concurrent use.

        After the send method has returned, the application must not attempt to read the headers, properties or body of the Message object until the CompletionListener's onCompletion or onException method has been called. This is because the JMS provider may be modifying the Message object in another thread during this time. The JMS provider may throw an JMSException if the application attempts to access or modify the Message object after the send method has returned and before the CompletionListener has been invoked. If the JMS provider does not throw an exception then the behaviour is undefined.

        Parameters:
        message - the message to send
        completionListener - a CompletionListener to be notified when the send has completed
        Throws:
        JMSException - if an internal error occurs
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with a MessageProducer with an invalid destination.
        IllegalArgumentException - if the specified CompletionListener is null
        UnsupportedOperationException - if a client uses this method with a MessageProducer that did not specify a destination at creation time.
        Since:
        JMS 2.0
        See Also:
        Session.createProducer(javax.jms.Destination), CompletionListener

      • send

        void send(Message message,
        int deliveryMode,
        int priority,
        long timeToLive,
        CompletionListener completionListener)
          throws JMSException
        Sends a message, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed. JMS refers to this as an "asynchronous send".

        When the message has been successfully sent the JMS provider invokes the callback method onCompletion on an application-specified CompletionListener object. Only when that callback has been invoked can the application be sure that the message has been successfully sent with the same degree of confidence as if a normal synchronous send had been performed. An application which requires this degree of confidence must therefore wait for the callback to be invoked before continuing.

        The following information is intended to give an indication of how an asynchronous send would typically be implemented.

        In some JMS providers, a normal synchronous send involves sending the message to a remote JMS server and then waiting for an acknowledgement to be received before returning. It is expected that such a provider would implement an asynchronous send by sending the message to the remote JMS server and then returning without waiting for an acknowledgement. When the acknowledgement is received, the JMS provider would notify the application by invoking the onCompletion method on the application-specified CompletionListener object. If for some reason the acknowledgement is not received the JMS provider would notify the application by invoking the CompletionListener's onException method.

        In those cases where the JMS specification permits a lower level of reliability, a normal synchronous send might not wait for an acknowledgement. In that case it is expected that an asynchronous send would be similar to a synchronous send: the JMS provider would send the message to the remote JMS server and then return without waiting for an acknowledgement. However the JMS provider would still notify the application that the send had completed by invoking the onCompletion method on the application-specified CompletionListener object.

        It is up to the JMS provider to decide exactly what is performed in the calling thread and what, if anything, is performed asynchronously, so long as it satisfies the requirements given below:

        Quality of service: After the send operation has completed successfully, which means that the message has been successfully sent with the same degree of confidence as if a normal synchronous send had been performed, the JMS provider must invoke the CompletionListener's onCompletion method. The CompletionListener must not be invoked earlier than this.

        Exceptions: If an exception is encountered during the call to the send method then an appropriate exception should be thrown in the thread that is calling the send method. In this case the JMS provider must not invoke the CompletionListener's onCompletion or onException method. If an exception is encountered which cannot be thrown in the thread that is calling the send method then the JMS provider must call the CompletionListener's onException method. In both cases if an exception occurs it is undefined whether or not the message was successfully sent.

        Message order: If the same MessageProducer is used to send multiple messages then JMS message ordering requirements must be satisfied. This applies even if a combination of synchronous and asynchronous sends has been performed. The application is not required to wait for an asynchronous send to complete before sending the next message.

        Close, commit or rollback: If the close method is called on the MessageProducer or its Session or Connection then the JMS provider must block until any incomplete send operations have been completed and all CompletionListener callbacks have returned before closing the object and returning. If the session is transacted (uses a local transaction) then when the Session's commit or rollback method is called the JMS provider must block until any incomplete send operations have been completed and all CompletionListener callbacks have returned before performing the commit or rollback. Incomplete sends should be allowed to complete normally unless an error occurs.

        A CompletionListener callback method must not call close on its own Connection, Session or MessageProducer or call commit or rollback on its own Session. Doing so will cause the close, commit or rollback to throw an IllegalStateException.

        Restrictions on usage in Java EE This method must not be used in a Java EE EJB or web container. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Message headers JMS defines a number of message header fields and message properties which must be set by the "JMS provider on send". If the send is asynchronous these fields and properties may be accessed on the sending client only after the CompletionListener has been invoked. If the CompletionListener's onException method is called then the state of these message header fields and properties is undefined.

        Restrictions on threading: Applications that perform an asynchronous send must confirm to the threading restrictions defined in JMS. This means that the session may be used by only one thread at a time.

        Setting a CompletionListener does not cause the session to be dedicated to the thread of control which calls the CompletionListener. The application thread may therefore continue to use the session after performing an asynchronous send. However the CompletionListener's callback methods must not use the session if an application thread might be using the session at the same time.

        Use of the CompletionListener by the JMS provider: A session will only invoke one CompletionListener callback method at a time. For a given MessageProducer, callbacks (both onCompletion and onException) will be performed in the same order as the corresponding calls to the asynchronous send method. A JMS provider must not invoke the CompletionListener from the thread that is calling the asynchronous send method.

        Restrictions on the use of the Message object: Applications which perform an asynchronous send must take account of the restriction that a Message object is designed to be accessed by one logical thread of control at a time and does not support concurrent use.

        After the send method has returned, the application must not attempt to read the headers, properties or body of the Message object until the CompletionListener's onCompletion or onException method has been called. This is because the JMS provider may be modifying the Message object in another thread during this time. The JMS provider may throw an JMSException if the application attempts to access or modify the Message object after the send method has returned and before the CompletionListener has been invoked. If the JMS provider does not throw an exception then the behaviour is undefined.

        Parameters:
        message - the message to send
        deliveryMode - the delivery mode to use
        priority - the priority for this message
        timeToLive - the message's lifetime (in milliseconds)
        completionListener - a CompletionListener to be notified when the send has completed
        Throws:
        JMSException - if an internal error occurs
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with a MessageProducer with an invalid destination.
        IllegalArgumentException - if the specified CompletionListener is null
        UnsupportedOperationException - if a client uses this method with a MessageProducer that did not specify a destination at creation time.
        Since:
        JMS 2.0
        See Also:
        Session.createProducer(javax.jms.Destination), CompletionListener

      • send

        void send(Destination destination,
        Message message,
        CompletionListener completionListener)
          throws JMSException
        Sends a message to a destination for an unidentified message producer, using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed. JMS refers to this as an "asynchronous send".

        Typically, a message producer is assigned a destination at creation time; however, the JMS API also supports unidentified message producers, which require that the destination be supplied every time a message is sent.

        When the message has been successfully sent the JMS provider invokes the callback method onCompletion on an application-specified CompletionListener object. Only when that callback has been invoked can the application be sure that the message has been successfully sent with the same degree of confidence as if a normal synchronous send had been performed. An application which requires this degree of confidence must therefore wait for the callback to be invoked before continuing.

        The following information is intended to give an indication of how an asynchronous send would typically be implemented.

        In some JMS providers, a normal synchronous send involves sending the message to a remote JMS server and then waiting for an acknowledgement to be received before returning. It is expected that such a provider would implement an asynchronous send by sending the message to the remote JMS server and then returning without waiting for an acknowledgement. When the acknowledgement is received, the JMS provider would notify the application by invoking the onCompletion method on the application-specified CompletionListener object. If for some reason the acknowledgement is not received the JMS provider would notify the application by invoking the CompletionListener's onException method.

        In those cases where the JMS specification permits a lower level of reliability, a normal synchronous send might not wait for an acknowledgement. In that case it is expected that an asynchronous send would be similar to a synchronous send: the JMS provider would send the message to the remote JMS server and then return without waiting for an acknowledgement. However the JMS provider would still notify the application that the send had completed by invoking the onCompletion method on the application-specified CompletionListener object.

        It is up to the JMS provider to decide exactly what is performed in the calling thread and what, if anything, is performed asynchronously, so long as it satisfies the requirements given below:

        Quality of service: After the send operation has completed successfully, which means that the message has been successfully sent with the same degree of confidence as if a normal synchronous send had been performed, the JMS provider must invoke the CompletionListener's onCompletion method. The CompletionListener must not be invoked earlier than this.

        Exceptions: If an exception is encountered during the call to the send method then an appropriate exception should be thrown in the thread that is calling the send method. In this case the JMS provider must not invoke the CompletionListener's onCompletion or onException method. If an exception is encountered which cannot be thrown in the thread that is calling the send method then the JMS provider must call the CompletionListener's onException method. In both cases if an exception occurs it is undefined whether or not the message was successfully sent.

        Message order: If the same MessageProducer is used to send multiple messages then JMS message ordering requirements must be satisfied. This applies even if a combination of synchronous and asynchronous sends has been performed. The application is not required to wait for an asynchronous send to complete before sending the next message.

        Close, commit or rollback: If the close method is called on the MessageProducer or its Session or Connection then the JMS provider must block until any incomplete send operations have been completed and all CompletionListener callbacks have returned before closing the object and returning. If the session is transacted (uses a local transaction) then when the Session's commit or rollback method is called the JMS provider must block until any incomplete send operations have been completed and all CompletionListener callbacks have returned before performing the commit or rollback. Incomplete sends should be allowed to complete normally unless an error occurs.

        A CompletionListener callback method must not call close on its own Connection, Session or MessageProducer or call commit or rollback on its own Session. Doing so will cause the close, commit or rollback to throw an IllegalStateException.

        Restrictions on usage in Java EE This method must not be used in a Java EE EJB or web container. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Message headers JMS defines a number of message header fields and message properties which must be set by the "JMS provider on send". If the send is asynchronous these fields and properties may be accessed on the sending client only after the CompletionListener has been invoked. If the CompletionListener's onException method is called then the state of these message header fields and properties is undefined.

        Restrictions on threading: Applications that perform an asynchronous send must confirm to the threading restrictions defined in JMS. This means that the session may be used by only one thread at a time.

        Setting a CompletionListener does not cause the session to be dedicated to the thread of control which calls the CompletionListener. The application thread may therefore continue to use the session after performing an asynchronous send. However the CompletionListener's callback methods must not use the session if an application thread might be using the session at the same time.

        Use of the CompletionListener by the JMS provider: A session will only invoke one CompletionListener callback method at a time. For a given MessageProducer, callbacks (both onCompletion and onException) will be performed in the same order as the corresponding calls to the asynchronous send method. A JMS provider must not invoke the CompletionListener from the thread that is calling the asynchronous send method.

        Restrictions on the use of the Message object: Applications which perform an asynchronous send must take account of the restriction that a Message object is designed to be accessed by one logical thread of control at a time and does not support concurrent use.

        After the send method has returned, the application must not attempt to read the headers, properties or body of the Message object until the CompletionListener's onCompletion or onException method has been called. This is because the JMS provider may be modifying the Message object in another thread during this time. The JMS provider may throw an JMSException if the application attempts to access or modify the Message object after the send method has returned and before the CompletionListener has been invoked. If the JMS provider does not throw an exception then the behaviour is undefined.

        Parameters:
        destination - the destination to send this message to
        message - the message to send
        completionListener - a CompletionListener to be notified when the send has completed
        Throws:
        JMSException - if an internal error occurs
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with an invalid destination
        IllegalArgumentException - if the specified CompletionListener is null
        UnsupportedOperationException - if a client uses this method with a MessageProducer that specified a destination at creation time.
        Since:
        JMS 2.0
        See Also:
        Session.createProducer(javax.jms.Destination), CompletionListener

      • send

        void send(Destination destination,
        Message message,
        int deliveryMode,
        int priority,
        long timeToLive,
        CompletionListener completionListener)
          throws JMSException
        Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed. JMS refers to this as an "asynchronous send".

        Typically, a message producer is assigned a destination at creation time; however, the JMS API also supports unidentified message producers, which require that the destination be supplied every time a message is sent.

        When the message has been successfully sent the JMS provider invokes the callback method onCompletion on an application-specified CompletionListener object. Only when that callback has been invoked can the application be sure that the message has been successfully sent with the same degree of confidence as if a normal synchronous send had been performed. An application which requires this degree of confidence must therefore wait for the callback to be invoked before continuing.

        The following information is intended to give an indication of how an asynchronous send would typically be implemented.

        In some JMS providers, a normal synchronous send involves sending the message to a remote JMS server and then waiting for an acknowledgement to be received before returning. It is expected that such a provider would implement an asynchronous send by sending the message to the remote JMS server and then returning without waiting for an acknowledgement. When the acknowledgement is received, the JMS provider would notify the application by invoking the onCompletion method on the application-specified CompletionListener object. If for some reason the acknowledgement is not received the JMS provider would notify the application by invoking the CompletionListener's onException method.

        In those cases where the JMS specification permits a lower level of reliability, a normal synchronous send might not wait for an acknowledgement. In that case it is expected that an asynchronous send would be similar to a synchronous send: the JMS provider would send the message to the remote JMS server and then return without waiting for an acknowledgement. However the JMS provider would still notify the application that the send had completed by invoking the onCompletion method on the application-specified CompletionListener object.

        It is up to the JMS provider to decide exactly what is performed in the calling thread and what, if anything, is performed asynchronously, so long as it satisfies the requirements given below:

        Quality of service: After the send operation has completed successfully, which means that the message has been successfully sent with the same degree of confidence as if a normal synchronous send had been performed, the JMS provider must invoke the CompletionListener's onCompletion method. The CompletionListener must not be invoked earlier than this.

        Exceptions: If an exception is encountered during the call to the send method then an appropriate exception should be thrown in the thread that is calling the send method. In this case the JMS provider must not invoke the CompletionListener's onCompletion or onException method. If an exception is encountered which cannot be thrown in the thread that is calling the send method then the JMS provider must call the CompletionListener's onException method. In both cases if an exception occurs it is undefined whether or not the message was successfully sent.

        Message order: If the same MessageProducer is used to send multiple messages then JMS message ordering requirements must be satisfied. This applies even if a combination of synchronous and asynchronous sends has been performed. The application is not required to wait for an asynchronous send to complete before sending the next message.

        Close, commit or rollback: If the close method is called on the MessageProducer or its Session or Connection then the JMS provider must block until any incomplete send operations have been completed and all CompletionListener callbacks have returned before closing the object and returning. If the session is transacted (uses a local transaction) then when the Session's commit or rollback method is called the JMS provider must block until any incomplete send operations have been completed and all CompletionListener callbacks have returned before performing the commit or rollback. Incomplete sends should be allowed to complete normally unless an error occurs.

        A CompletionListener callback method must not call close on its own Connection, Session or MessageProducer or call commit or rollback on its own Session. Doing so will cause the close, commit or rollback to throw an IllegalStateException.

        Restrictions on usage in Java EE This method must not be used in a Java EE EJB or web container. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Message headers JMS defines a number of message header fields and message properties which must be set by the "JMS provider on send". If the send is asynchronous these fields and properties may be accessed on the sending client only after the CompletionListener has been invoked. If the CompletionListener's onException method is called then the state of these message header fields and properties is undefined.

        Restrictions on threading: Applications that perform an asynchronous send must confirm to the threading restrictions defined in JMS. This means that the session may be used by only one thread at a time.

        Setting a CompletionListener does not cause the session to be dedicated to the thread of control which calls the CompletionListener. The application thread may therefore continue to use the session after performing an asynchronous send. However the CompletionListener's callback methods must not use the session if an application thread might be using the session at the same time.

        Use of the CompletionListener by the JMS provider: A session will only invoke one CompletionListener callback method at a time. For a given MessageProducer, callbacks (both onCompletion and onException) will be performed in the same order as the corresponding calls to the asynchronous send method. A JMS provider must not invoke the CompletionListener from the thread that is calling the asynchronous send method.

        Restrictions on the use of the Message object: Applications which perform an asynchronous send must take account of the restriction that a Message object is designed to be accessed by one logical thread of control at a time and does not support concurrent use.

        After the send method has returned, the application must not attempt to read the headers, properties or body of the Message object until the CompletionListener's onCompletion or onException method has been called. This is because the JMS provider may be modifying the Message object in another thread during this time. The JMS provider may throw an JMSException if the application attempts to access or modify the Message object after the send method has returned and before the CompletionListener has been invoked. If the JMS provider does not throw an exception then the behaviour is undefined.

        Parameters:
        destination - the destination to send this message to
        message - the message to send
        deliveryMode - the delivery mode to use
        priority - the priority for this message
        timeToLive - the message's lifetime (in milliseconds)
        completionListener - a CompletionListener to be notified when the send has completed
        Throws:
        JMSException - if an internal error occurs
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with an invalid destination.
        IllegalArgumentException - if the specified CompletionListener is null
        UnsupportedOperationException - if a client uses this method with a MessageProducer that specified a destination at creation time.
        Since:
        JMS 2.0
        See Also:
        Session.createProducer(javax.jms.Destination), CompletionListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface ObjectMessage

  • All Superinterfaces:
    Message

    public interface ObjectMessage
extends Message
    An ObjectMessage object is used to send a message that contains a serializable object in the Java programming language ("Java object"). It inherits from the Message interface and adds a body containing a single reference to an object. Only Serializable Java objects can be used.

    If a collection of Java objects must be sent, one of the Collection classes provided since JDK 1.2 can be used.

    When a client receives an ObjectMessage, it is in read-only mode. If a client attempts to write to the message at this point, a MessageNotWriteableException is thrown. If clearBody is called, the message can now be both read from and written to.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createObjectMessage(), Session.createObjectMessage(Serializable), BytesMessage, MapMessage, Message, StreamMessage, TextMessage

    • Field Summary

      • Fields inherited from interface javax.jms.Message

        DEFAULT_DELIVERY_DELAY, DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Serializable getObject()
      Gets the serializable object containing this message's data.
      void setObject(Serializable object)
      Sets the serializable object containing this message's data.

      • Methods inherited from interface javax.jms.Message

        acknowledge, clearBody, clearProperties, getBody, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDeliveryTime, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, isBodyAssignableTo, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDeliveryTime, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

    • Method Detail

      • setObject

        void setObject(Serializable object)
               throws JMSException
        Sets the serializable object containing this message's data. It is important to note that an ObjectMessage contains a snapshot of the object at the time setObject() is called; subsequent modifications of the object will have no effect on the ObjectMessage body.
        Parameters:
        object - the message's data
        Throws:
        JMSException - if the JMS provider fails to set the object due to some internal error.
        MessageFormatException - if object serialization fails.
        MessageNotWriteableException - if the message is in read-only mode.

      • getObject

        Serializable getObject()
                       throws JMSException
        Gets the serializable object containing this message's data. The default value is null.
        Returns:
        the serializable object containing this message's data
        Throws:
        JMSException - if the JMS provider fails to get the object due to some internal error.
        MessageFormatException - if object deserialization fails.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Queue (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface Queue

  • All Superinterfaces:
    Destination
    All Known Subinterfaces:
    TemporaryQueue

    public interface Queue
extends Destination
    A Queue object encapsulates a provider-specific queue name. It is the way a client specifies the identity of a queue to JMS API methods. For those methods that use a Destination as a parameter, a Queue object used as an argument. For example, a queue can be used to create a MessageConsumer and a MessageProducer by calling:
    • Session.CreateConsumer(Destination destination)
    • Session.CreateProducer(Destination destination)

    The actual length of time messages are held by a queue and the consequences of resource overflow are not defined by the JMS API.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createConsumer(Destination),
Session.createProducer(Destination),
Session.createQueue(String),
QueueSession.createQueue(String)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getQueueName()
      Gets the name of this queue.
      String toString()
      Returns a string representation of this object.

    • Method Detail

      • getQueueName

        String getQueueName()
                    throws JMSException
        Gets the name of this queue.

        Clients that depend upon the name are not portable.

        Returns:
        the queue name
        Throws:
        JMSException - if the JMS provider implementation of Queue fails to return the queue name due to some internal error.

      • toString

        String toString()
        Returns a string representation of this object.
        Overrides:
        toString in class Object
        Returns:
        the provider-specific identity values for this queue
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QueueBrowser (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface QueueBrowser

  • All Superinterfaces:
    AutoCloseable

    public interface QueueBrowser
extends AutoCloseable
    A client uses a QueueBrowser object to look at messages on a queue without removing them.

    The getEnumeration method returns a java.util.Enumeration that is used to scan the queue's messages. It may be an enumeration of the entire content of a queue, or it may contain only the messages matching a message selector.

    Messages may be arriving and expiring while the scan is done. The JMS API does not require the content of an enumeration to be a static snapshot of queue content. Whether these changes are visible or not depends on the JMS provider.

    A message must not be returned by a QueueBrowser before its delivery time has been reached.

    A QueueBrowser can be created from either a Session or a QueueSession.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createBrowser(javax.jms.Queue), QueueSession.createBrowser(javax.jms.Queue), QueueReceiver

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes the QueueBrowser.
      Enumeration getEnumeration()
      Gets an enumeration for browsing the current queue messages in the order they would be received.
      String getMessageSelector()
      Gets this queue browser's message selector expression.
      Queue getQueue()
      Gets the queue associated with this queue browser.

    • Method Detail

      • getQueue

        Queue getQueue()
               throws JMSException
        Gets the queue associated with this queue browser.
        Returns:
        the queue
        Throws:
        JMSException - if the JMS provider fails to get the queue associated with this browser due to some internal error.

      • getMessageSelector

        String getMessageSelector()
                          throws JMSException
        Gets this queue browser's message selector expression.
        Returns:
        this queue browser's message selector, or null if no message selector exists for the message consumer (that is, if the message selector was not set or was set to null or the empty string)
        Throws:
        JMSException - if the JMS provider fails to get the message selector for this browser due to some internal error.

      • getEnumeration

        Enumeration getEnumeration()
                           throws JMSException
        Gets an enumeration for browsing the current queue messages in the order they would be received.
        Returns:
        an enumeration for browsing the messages
        Throws:
        JMSException - if the JMS provider fails to get the enumeration for this browser due to some internal error.

      • close

        void close()
           throws JMSException
        Closes the QueueBrowser.

        Since a provider may allocate some resources on behalf of a QueueBrowser outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

        Specified by:
        close in interface AutoCloseable
        Throws:
        JMSException - if the JMS provider fails to close this browser due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QueueConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface QueueConnection

  • All Superinterfaces:
    AutoCloseable, Connection
    All Known Subinterfaces:
    XAQueueConnection

    public interface QueueConnection
extends Connection
    A QueueConnection object is an active connection to a point-to-point JMS provider. A client uses a QueueConnection object to create one or more QueueSession objects for producing and consuming messages.

    A QueueConnection can be used to create a QueueSession, from which specialized queue-related objects can be created. A more general, and recommended, approach is to use the Connection object.

    The QueueConnection object should be used to support existing code that has already used it.

    A QueueConnection cannot be used to create objects specific to the publish/subscribe domain. The createDurableConnectionConsumer method inherits from Connection, but must throw an IllegalStateException if used from QueueConnection.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Connection, ConnectionFactory, QueueConnectionFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConnectionConsumer createConnectionConsumer(Queue queue, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation).
      QueueSession createQueueSession(boolean transacted, int acknowledgeMode)
      Creates a QueueSession object.

      • Methods inherited from interface javax.jms.Connection

        close, createConnectionConsumer, createDurableConnectionConsumer, createSession, createSession, createSession, createSharedConnectionConsumer, createSharedDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

    • Method Detail

      • createQueueSession

        QueueSession createQueueSession(boolean transacted,
                              int acknowledgeMode)
                                throws JMSException
        Creates a QueueSession object.
        Parameters:
        transacted - indicates whether the session is transacted
        acknowledgeMode - indicates whether the consumer or the client will acknowledge any messages it receives; ignored if the session is transacted. Legal values are Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, and Session.DUPS_OK_ACKNOWLEDGE.
        Returns:
        a newly created queue session
        Throws:
        JMSException - if the QueueConnection object fails to create a session due to some internal error or lack of support for the specific transaction and acknowledgement mode.
        See Also:
        Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE

      • createConnectionConsumer

        ConnectionConsumer createConnectionConsumer(Queue queue,
                                          String messageSelector,
                                          ServerSessionPool sessionPool,
                                          int maxMessages)
                                            throws JMSException
        Creates a connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.
        Parameters:
        queue - the queue to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        sessionPool - the server session pool to associate with this connection consumer
        maxMessages - the maximum number of messages that can be assigned to a server session at one time
        Returns:
        the connection consumer
        Throws:
        JMSException - if the QueueConnection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
        InvalidDestinationException - if an invalid queue is specified.
        InvalidSelectorException - if the message selector is invalid.
        See Also:
        ConnectionConsumer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QueueConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface QueueConnectionFactory

  • All Superinterfaces:
    ConnectionFactory
    All Known Subinterfaces:
    XAQueueConnectionFactory

    public interface QueueConnectionFactory
extends ConnectionFactory
    A client uses a QueueConnectionFactory object to create QueueConnection objects with a point-to-point JMS provider.

    QueueConnectionFactory can be used to create a QueueConnection, from which specialized queue-related objects can be created. A more general, and recommended, approach is to use the ConnectionFactory object.

    The QueueConnectionFactory object can be used to support existing code that already uses it.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    ConnectionFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      QueueConnection createQueueConnection()
      Creates a queue connection with the default user identity.
      QueueConnection createQueueConnection(String userName, String password)
      Creates a queue connection with the specified user identity.

      • Methods inherited from interface javax.jms.ConnectionFactory

        createConnection, createConnection, createContext, createContext, createContext, createContext

    • Method Detail

      • createQueueConnection

        QueueConnection createQueueConnection()
                                      throws JMSException
        Creates a queue connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called. .
        Returns:
        a newly created queue connection
        Throws:
        JMSException - if the JMS provider fails to create the queue connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.

      • createQueueConnection

        QueueConnection createQueueConnection(String userName,
                                    String password)
                                      throws JMSException
        Creates a queue connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Parameters:
        userName - the caller's user name
        password - the caller's password
        Returns:
        a newly created queue connection
        Throws:
        JMSException - if the JMS provider fails to create the queue connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QueueReceiver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface QueueReceiver

  • All Superinterfaces:
    AutoCloseable, MessageConsumer

    public interface QueueReceiver
extends MessageConsumer
    A client uses a QueueReceiver object to receive messages that have been delivered to a queue.

    Although it is possible to have multiple QueueReceivers for the same queue, the JMS API does not define how messages are distributed between the QueueReceivers.

    If a QueueReceiver specifies a message selector, the messages that are not selected remain on the queue. By definition, a message selector allows a QueueReceiver to skip messages. This means that when the skipped messages are eventually read, the total ordering of the reads does not retain the partial order defined by each message producer. Only QueueReceivers without a message selector will read messages in message producer order.

    Creating a MessageConsumer provides the same features as creating a QueueReceiver. A MessageConsumer object is recommended for creating new code. The QueueReceiver is provided to support existing code.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createConsumer(Destination, String),
Session.createConsumer(Destination),
QueueSession.createReceiver(Queue, String),
QueueSession.createReceiver(Queue),
MessageConsumer

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Queue getQueue()
      Gets the Queue associated with this queue receiver.

      • Methods inherited from interface javax.jms.MessageConsumer

        close, getMessageListener, getMessageSelector, receive, receive, receiveNoWait, setMessageListener

    • Method Detail

      • getQueue

        Queue getQueue()
               throws JMSException
        Gets the Queue associated with this queue receiver.
        Returns:
        this receiver's Queue
        Throws:
        JMSException - if the JMS provider fails to get the queue for this queue receiver due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QueueRequestor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class QueueRequestor

  • java.lang.Object
    • javax.jms.QueueRequestor

  • public class QueueRequestor
extends Object
    The QueueRequestor helper class simplifies making service requests.

    The QueueRequestor constructor is given a non-transacted QueueSession and a destination Queue. It creates a TemporaryQueue for the responses and provides a request method that sends the request message and waits for its reply.

    This is a very basic request/reply abstraction which assumes the session is non-transacted with a delivery mode of either AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE. It is expected that most applications will create less basic implementations.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    TopicRequestor

    • Constructor Summary

      Constructors
      Constructor and Description
      QueueRequestor(QueueSession session, Queue queue)
      Constructor for the QueueRequestor class.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes the QueueRequestor and its session.
      Message request(Message message)
      Sends a request and waits for a reply.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • QueueRequestor

        public QueueRequestor(QueueSession session,
              Queue queue)
               throws JMSException
        Constructor for the QueueRequestor class.

        This implementation assumes the session parameter to be non-transacted, with a delivery mode of either AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE.

        Parameters:
        session - the QueueSession the queue belongs to
        queue - the queue to perform the request/reply call on
        Throws:
        JMSException - if the JMS provider fails to create the QueueRequestor due to some internal error.
        InvalidDestinationException - if an invalid queue is specified.

    • Method Detail

      • request

        public Message request(Message message)
                throws JMSException
        Sends a request and waits for a reply. The temporary queue is used for the JMSReplyTo destination, and only one reply per request is expected.
        Parameters:
        message - the message to send
        Returns:
        the reply message
        Throws:
        JMSException - if the JMS provider fails to complete the request due to some internal error.

      • close

        public void close()
           throws JMSException
        Closes the QueueRequestor and its session.

        Since a provider may allocate some resources on behalf of a QueueRequestor outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

        Note that this method closes the QueueSession object passed to the QueueRequestor constructor.

        Throws:
        JMSException - if the JMS provider fails to close the QueueRequestor due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QueueSender (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface QueueSender

  • All Superinterfaces:
    AutoCloseable, MessageProducer

    public interface QueueSender
extends MessageProducer
    A client uses a QueueSender object to send messages to a queue.

    Normally, the Queue is specified when a QueueSender is created. In this case, an attempt to use the send methods for an unidentified QueueSender will throw a java.lang.UnsupportedOperationException.

    If the QueueSender is created with an unidentified Queue, an attempt to use the send methods that assume that the Queue has been identified will throw a java.lang.UnsupportedOperationException.

    During the execution of its send method, a message must not be changed by other threads within the client. If the message is modified, the result of the send is undefined.

    After sending a message, a client may retain and modify it without affecting the message that has been sent. The same message object may be sent multiple times.

    The following message headers are set as part of sending a message: JMSDestination, JMSDeliveryMode, JMSExpiration, JMSPriority, JMSMessageID and JMSTimeStamp. When the message is sent, the values of these headers are ignored. After the completion of the send, the headers hold the values specified by the method sending the message. It is possible for the send method not to set JMSMessageID and JMSTimeStamp if the setting of these headers is explicitly disabled by the MessageProducer.setDisableMessageID or MessageProducer.setDisableMessageTimestamp method.

    Creating a MessageProducer provides the same features as creating a QueueSender. A MessageProducer object is recommended when creating new code. The QueueSender is provided to support existing code.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    MessageProducer, Session.createProducer(Destination), QueueSession.createSender(Queue)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Queue getQueue()
      Gets the queue associated with this QueueSender.
      void send(Message message)
      Sends a message to the queue.
      void send(Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to the queue, specifying delivery mode, priority, and time to live.
      void send(Queue queue, Message message)
      Sends a message to a queue for an unidentified message producer.
      void send(Queue queue, Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to a queue for an unidentified message producer, specifying delivery mode, priority and time to live.

      • Methods inherited from interface javax.jms.MessageProducer

        close, getDeliveryDelay, getDeliveryMode, getDestination, getDisableMessageID, getDisableMessageTimestamp, getPriority, getTimeToLive, send, send, send, send, send, send, setDeliveryDelay, setDeliveryMode, setDisableMessageID, setDisableMessageTimestamp, setPriority, setTimeToLive

    • Method Detail

      • getQueue

        Queue getQueue()
               throws JMSException
        Gets the queue associated with this QueueSender.
        Returns:
        this sender's queue
        Throws:
        JMSException - if the JMS provider fails to get the queue for this QueueSender due to some internal error.

      • send

        void send(Message message)
          throws JMSException
        Sends a message to the queue. Uses the QueueSender's default delivery mode, priority, and time to live.
        Specified by:
        send in interface MessageProducer
        Parameters:
        message - the message to send
        Throws:
        JMSException - if the JMS provider fails to send the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with a QueueSender with an invalid queue.
        UnsupportedOperationException - if a client uses this method with a QueueSender that did not specify a queue at creation time.
        See Also:
        MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

      • send

        void send(Message message,
        int deliveryMode,
        int priority,
        long timeToLive)
          throws JMSException
        Sends a message to the queue, specifying delivery mode, priority, and time to live.
        Specified by:
        send in interface MessageProducer
        Parameters:
        message - the message to send
        deliveryMode - the delivery mode to use
        priority - the priority for this message
        timeToLive - the message's lifetime (in milliseconds)
        Throws:
        JMSException - if the JMS provider fails to send the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with a QueueSender with an invalid queue.
        UnsupportedOperationException - if a client uses this method with a QueueSender that did not specify a queue at creation time.
        See Also:
        Session.createProducer(javax.jms.Destination)

      • send

        void send(Queue queue,
        Message message)
          throws JMSException
        Sends a message to a queue for an unidentified message producer. Uses the QueueSender's default delivery mode, priority, and time to live.

        Typically, a message producer is assigned a queue at creation time; however, the JMS API also supports unidentified message producers, which require that the queue be supplied every time a message is sent.

        Parameters:
        queue - the queue to send this message to
        message - the message to send
        Throws:
        JMSException - if the JMS provider fails to send the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with an invalid queue.
        See Also:
        MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

      • send

        void send(Queue queue,
        Message message,
        int deliveryMode,
        int priority,
        long timeToLive)
          throws JMSException
        Sends a message to a queue for an unidentified message producer, specifying delivery mode, priority and time to live.

        Typically, a message producer is assigned a queue at creation time; however, the JMS API also supports unidentified message producers, which require that the queue be supplied every time a message is sent.

        Parameters:
        queue - the queue to send this message to
        message - the message to send
        deliveryMode - the delivery mode to use
        priority - the priority for this message
        timeToLive - the message's lifetime (in milliseconds)
        Throws:
        JMSException - if the JMS provider fails to send the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with an invalid queue.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QueueSession (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface QueueSession

  • All Superinterfaces:
    AutoCloseable, Runnable, Session

    public interface QueueSession
extends Session
    A QueueSession object provides methods for creating QueueReceiver, QueueSender, QueueBrowser, and TemporaryQueue objects.

    If there are messages that have been received but not acknowledged when a QueueSession terminates, these messages will be retained and redelivered when a consumer next accesses the queue.

    A QueueSession is used for creating Point-to-Point specific objects. In general, use the Session object. The QueueSession is used to support existing code. Using the Session object simplifies the programming model, and allows transactions to be used across the two messaging domains.

    A QueueSession cannot be used to create objects specific to the publish/subscribe domain. The following methods inherit from Session, but must throw an IllegalStateException if they are used from QueueSession:

    • createDurableSubscriber
    • createDurableConsumer
    • createSharedConsumer
    • createSharedDurableConsumer
    • createTemporaryTopic
    • createTopic
    • unsubscribe
    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session, QueueConnection.createQueueSession(boolean, int), XAQueueSession.getQueueSession()

    • Field Summary

      • Fields inherited from interface javax.jms.Session

        AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED

    • Method Summary

      Methods
      Modifier and Type Method and Description
      QueueBrowser createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
      Queue createQueue(String queueName)
      Creates a queue identity given a Queue name.
      QueueReceiver createReceiver(Queue queue)
      Creates a QueueReceiver object to receive messages from the specified queue.
      QueueReceiver createReceiver(Queue queue, String messageSelector)
      Creates a QueueReceiver object to receive messages from the specified queue using a message selector.
      QueueSender createSender(Queue queue)
      Creates a QueueSender object to send messages to the specified queue.
      TemporaryQueue createTemporaryQueue()
      Creates a TemporaryQueue object.

      • Methods inherited from interface javax.jms.Session

        close, commit, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableConsumer, createDurableConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createSharedConsumer, createSharedConsumer, createSharedDurableConsumer, createSharedDurableConsumer, createStreamMessage, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, getTransacted, recover, rollback, run, setMessageListener, unsubscribe

    • Method Detail

      • createQueue

        Queue createQueue(String queueName)
                  throws JMSException
        Creates a queue identity given a Queue name.

        This facility is provided for the rare cases where clients need to dynamically manipulate queue identity. It allows the creation of a queue identity with a provider-specific name. Clients that depend on this ability are not portable.

        Note that this method is not for creating the physical queue. The physical creation of queues is an administrative task and is not to be initiated by the JMS API. The one exception is the creation of temporary queues, which is accomplished with the createTemporaryQueue method.

        Specified by:
        createQueue in interface Session
        Parameters:
        queueName - the name of this Queue
        Returns:
        a Queue with the given name
        Throws:
        JMSException - if the session fails to create a queue due to some internal error.

      • createReceiver

        QueueReceiver createReceiver(Queue queue)
                             throws JMSException
        Creates a QueueReceiver object to receive messages from the specified queue.
        Parameters:
        queue - the Queue to access
        Throws:
        JMSException - if the session fails to create a receiver due to some internal error.
        InvalidDestinationException - if an invalid queue is specified.

      • createReceiver

        QueueReceiver createReceiver(Queue queue,
                           String messageSelector)
                             throws JMSException
        Creates a QueueReceiver object to receive messages from the specified queue using a message selector.
        Parameters:
        queue - the Queue to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        Throws:
        JMSException - if the session fails to create a receiver due to some internal error.
        InvalidDestinationException - if an invalid queue is specified.
        InvalidSelectorException - if the message selector is invalid.

      • createSender

        QueueSender createSender(Queue queue)
                         throws JMSException
        Creates a QueueSender object to send messages to the specified queue.
        Parameters:
        queue - the Queue to access, or null if this is an unidentified producer
        Throws:
        JMSException - if the session fails to create a sender due to some internal error.
        InvalidDestinationException - if an invalid queue is specified.

      • createBrowser

        QueueBrowser createBrowser(Queue queue)
                           throws JMSException
        Creates a QueueBrowser object to peek at the messages on the specified queue.
        Specified by:
        createBrowser in interface Session
        Parameters:
        queue - the Queue to access
        Throws:
        JMSException - if the session fails to create a browser due to some internal error.
        InvalidDestinationException - if an invalid queue is specified.

      • createBrowser

        QueueBrowser createBrowser(Queue queue,
                         String messageSelector)
                           throws JMSException
        Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
        Specified by:
        createBrowser in interface Session
        Parameters:
        queue - the Queue to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        Throws:
        JMSException - if the session fails to create a browser due to some internal error.
        InvalidDestinationException - if an invalid queue is specified.
        InvalidSelectorException - if the message selector is invalid.

      • createTemporaryQueue

        TemporaryQueue createTemporaryQueue()
                                    throws JMSException
        Creates a TemporaryQueue object. Its lifetime will be that of the QueueConnection unless it is deleted earlier.
        Specified by:
        createTemporaryQueue in interface Session
        Returns:
        a temporary queue identity
        Throws:
        JMSException - if the session fails to create a temporary queue due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceAllocationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class ResourceAllocationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.ResourceAllocationException
  • All Implemented Interfaces:
    Serializable

    public class ResourceAllocationException
extends JMSException

    This exception is thrown when a provider is unable to allocate the resources required by a method. For example, this exception should be thrown when a call to TopicConnectionFactory.createTopicConnection fails due to a lack of JMS provider resources.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceAllocationException(String reason)
      Constructs a ResourceAllocationException with the specified reason.
      ResourceAllocationException(String reason, String errorCode)
      Constructs a ResourceAllocationException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ResourceAllocationException

        public ResourceAllocationException(String reason,
                           String errorCode)
        Constructs a ResourceAllocationException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • ResourceAllocationException

        public ResourceAllocationException(String reason)
        Constructs a ResourceAllocationException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceAllocationRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class ResourceAllocationRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.ResourceAllocationRuntimeException
  • All Implemented Interfaces:
    Serializable

    public class ResourceAllocationRuntimeException
extends JMSRuntimeException

    This unchecked exception is thrown when a provider is unable to allocate the resources required by a method. For example, this exception should be thrown when a call to ConnectionFactory.createContext fails due to a lack of JMS provider resources.

    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceAllocationRuntimeException(String reason)
      Constructs a ResourceAllocationRuntimeException with the specified reason.
      ResourceAllocationRuntimeException(String reason, String errorCode)
      Constructs a ResourceAllocationRuntimeException with the specified reason and error code.
      ResourceAllocationRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a ResourceAllocationRuntimeException with the specified detail message, error code and cause

    • Method Summary

      • Methods inherited from class javax.jms.JMSRuntimeException

        getErrorCode

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ResourceAllocationRuntimeException

        public ResourceAllocationRuntimeException(String reason,
                                  String errorCode)
        Constructs a ResourceAllocationRuntimeException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • ResourceAllocationRuntimeException

        public ResourceAllocationRuntimeException(String reason)
        Constructs a ResourceAllocationRuntimeException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception

      • ResourceAllocationRuntimeException

        public ResourceAllocationRuntimeException(String detailMessage,
                                  String errorCode,
                                  Throwable cause)
        Constructs a ResourceAllocationRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerSession (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface ServerSession

  • public interface ServerSession
    A ServerSession object is an application server object that is used by a server to associate a thread with a JMS session (optional).

    A ServerSession implements two methods:

    • getSession - returns the ServerSession's JMS session.
    • start - starts the execution of the ServerSession thread and results in the execution of the JMS session's run method.

    A ConnectionConsumer implemented by a JMS provider uses a ServerSession to process one or more messages that have arrived. It does this by getting a ServerSession from the ConnectionConsumer's ServerSessionPool; getting the ServerSession's JMS session; loading it with the messages; and then starting the ServerSession.

    In most cases the ServerSession will register some object it provides as the ServerSession's thread run object. The ServerSession's start method will call the thread's start method, which will start the new thread, and from it, call the run method of the ServerSession's run object. This object will do some housekeeping and then call the Session's run method. When run returns, the ServerSession's run object can return the ServerSession to the ServerSessionPool, and the cycle starts again.

    Note that the JMS API does not architect how the ConnectionConsumer loads the Session with messages. Since both the ConnectionConsumer and Session are implemented by the same JMS provider, they can accomplish the load using a private mechanism.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    ServerSessionPool, ConnectionConsumer

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Session getSession()
      Return the ServerSession's Session.
      void start()
      Cause the Session's run method to be called to process messages that were just assigned to it.

    • Method Detail

      • getSession

        Session getSession()
                   throws JMSException
        Return the ServerSession's Session. This must be a Session created by the same Connection that will be dispatching messages to it. The provider will assign one or more messages to the Session and then call start on the ServerSession.
        Returns:
        the server session's session
        Throws:
        JMSException - if the JMS provider fails to get the associated session for this ServerSession due to some internal error.

      • start

        void start()
           throws JMSException
        Cause the Session's run method to be called to process messages that were just assigned to it.
        Throws:
        JMSException - if the JMS provider fails to start the server session to process messages due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerSessionPool (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface ServerSessionPool

  • public interface ServerSessionPool
    A ServerSessionPool object is an object implemented by an application server to provide a pool of ServerSession objects for processing the messages of a ConnectionConsumer (optional).

    Its only method is getServerSession. The JMS API does not architect how the pool is implemented. It could be a static pool of ServerSession objects, or it could use a sophisticated algorithm to dynamically create ServerSession objects as needed.

    If the ServerSessionPool is out of ServerSession objects, the getServerSession call may block. If a ConnectionConsumer is blocked, it cannot deliver new messages until a ServerSession is eventually returned.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    ServerSession

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ServerSession getServerSession()
      Return a server session from the pool.

    • Method Detail

      • getServerSession

        ServerSession getServerSession()
                               throws JMSException
        Return a server session from the pool.
        Returns:
        a server session from the pool
        Throws:
        JMSException - if an application server fails to return a ServerSession out of its server session pool.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Session (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface Session

  • All Superinterfaces:
    AutoCloseable, Runnable
    All Known Subinterfaces:
    QueueSession, TopicSession, XAQueueSession, XASession, XATopicSession

    public interface Session
extends Runnable, AutoCloseable

    A Session object is a single-threaded context for producing and consuming messages. Although it may allocate provider resources outside the Java virtual machine (JVM), it is considered a lightweight JMS object.

    A session serves several purposes:

    • It is a factory for its message producers and consumers.
    • It supplies provider-optimized message factories.
    • It is a factory for TemporaryTopics and TemporaryQueues.
    • It provides a way to create Queue or Topic objects for those clients that need to dynamically manipulate provider-specific destination names.
    • It supports a single series of transactions that combine work spanning its producers and consumers into atomic units.
    • It defines a serial order for the messages it consumes and the messages it produces.
    • It retains messages it consumes until they have been acknowledged.
    • It serializes execution of message listeners registered with its message consumers.
    • It is a factory for QueueBrowsers.

    A session can create and service multiple message producers and consumers.

    One typical use is to have a thread block on a synchronous MessageConsumer until a message arrives. The thread may then use one or more of the Session's MessageProducers.

    If a client desires to have one thread produce messages while others consume them, the client should use a separate session for its producing thread.

    Once a connection has been started, any session with one or more registered message listeners is dedicated to the thread of control that delivers messages to it. It is erroneous for client code to use this session or any of its constituent objects from another thread of control. The only exception to this rule is the use of the session or connection close method.

    It should be easy for most clients to partition their work naturally into sessions. This model allows clients to start simply and incrementally add message processing complexity as their need for concurrency grows.

    The close method is the only session method that can be called while some other session method is being executed in another thread.

    A session may be specified as transacted. Each transacted session supports a single series of transactions. Each transaction groups a set of message sends and a set of message receives into an atomic unit of work. In effect, transactions organize a session's input message stream and output message stream into series of atomic units. When a transaction commits, its atomic unit of input is acknowledged and its associated atomic unit of output is sent. If a transaction rollback is done, the transaction's sent messages are destroyed and the session's input is automatically recovered.

    The content of a transaction's input and output units is simply those messages that have been produced and consumed within the session's current transaction.

    A transaction is completed using either its session's commit method or its session's rollback method. The completion of a session's current transaction automatically begins the next. The result is that a transacted session always has a current transaction within which its work is done.

    The Java Transaction Service (JTS) or some other transaction monitor may be used to combine a session's transaction with transactions on other resources (databases, other JMS sessions, etc.). Since Java distributed transactions are controlled via the Java Transaction API (JTA), use of the session's commit and rollback methods in this context is prohibited.

    The JMS API does not require support for JTA; however, it does define how a provider supplies this support.

    Although it is also possible for a JMS client to handle distributed transactions directly, it is unlikely that many JMS clients will do this. Support for JTA in the JMS API is targeted at systems vendors who will be integrating the JMS API into their application server products.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    QueueSession, TopicSession, XASession

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int AUTO_ACKNOWLEDGE
      With this acknowledgment mode, the session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.
      static int CLIENT_ACKNOWLEDGE
      With this acknowledgment mode, the client acknowledges a consumed message by calling the message's acknowledge method.
      static int DUPS_OK_ACKNOWLEDGE
      This acknowledgment mode instructs the session to lazily acknowledge the delivery of messages.
      static int SESSION_TRANSACTED
      This value may be passed as the argument to the method createSession(int sessionMode) on the Connection object to specify that the session should use a local transaction.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes the session.
      void commit()
      Commits all messages done in this transaction and releases any locks currently held.
      QueueBrowser createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
      BytesMessage createBytesMessage()
      Creates a BytesMessage object.
      MessageConsumer createConsumer(Destination destination)
      Creates a MessageConsumer for the specified destination.
      MessageConsumer createConsumer(Destination destination, String messageSelector)
      Creates a MessageConsumer for the specified destination, using a message selector.
      MessageConsumer createConsumer(Destination destination, String messageSelector, boolean noLocal)
      Creates a MessageConsumer for the specified destination, specifying a message selector and the noLocal parameter.
      MessageConsumer createDurableConsumer(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      MessageConsumer createDurableConsumer(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      TopicSubscriber createDurableSubscriber(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      TopicSubscriber createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      MapMessage createMapMessage()
      Creates a MapMessage object.
      Message createMessage()
      Creates a Message object.
      ObjectMessage createObjectMessage()
      Creates an ObjectMessage object.
      ObjectMessage createObjectMessage(Serializable object)
      Creates an initialized ObjectMessage object.
      MessageProducer createProducer(Destination destination)
      Creates a MessageProducer to send messages to the specified destination.
      Queue createQueue(String queueName)
      Creates a Queue object which encapsulates a specified provider-specific queue name.
      MessageConsumer createSharedConsumer(Topic topic, String sharedSubscriptionName)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription.
      MessageConsumer createSharedConsumer(Topic topic, String sharedSubscriptionName, String messageSelector)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.
      MessageConsumer createSharedDurableConsumer(Topic topic, String name)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      MessageConsumer createSharedDurableConsumer(Topic topic, String name, String messageSelector)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.
      StreamMessage createStreamMessage()
      Creates a StreamMessage object.
      TemporaryQueue createTemporaryQueue()
      Creates a TemporaryQueue object.
      TemporaryTopic createTemporaryTopic()
      Creates a TemporaryTopic object.
      TextMessage createTextMessage()
      Creates a TextMessage object.
      TextMessage createTextMessage(String text)
      Creates an initialized TextMessage object.
      Topic createTopic(String topicName)
      Creates a Topic object which encapsulates a specified provider-specific topic name.
      int getAcknowledgeMode()
      Returns the acknowledgement mode of the session.
      MessageListener getMessageListener()
      Returns the session's distinguished message listener (optional).
      boolean getTransacted()
      Indicates whether the session is in transacted mode.
      void recover()
      Stops message delivery in this session, and restarts message delivery with the oldest unacknowledged message.
      void rollback()
      Rolls back any messages done in this transaction and releases any locks currently held.
      void run()
      Optional operation, intended to be used only by Application Servers, not by ordinary JMS clients.
      void setMessageListener(MessageListener listener)
      Sets the session's distinguished message listener (optional).
      void unsubscribe(String name)
      Unsubscribes a durable subscription that has been created by a client.

    • Field Detail

      • AUTO_ACKNOWLEDGE

        static final int AUTO_ACKNOWLEDGE
        With this acknowledgment mode, the session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.
        See Also:
        Constant Field Values

      • CLIENT_ACKNOWLEDGE

        static final int CLIENT_ACKNOWLEDGE
        With this acknowledgment mode, the client acknowledges a consumed message by calling the message's acknowledge method. Acknowledging a consumed message acknowledges all messages that the session has consumed.

        When client acknowledgment mode is used, a client may build up a large number of unacknowledged messages while attempting to process them. A JMS provider should provide administrators with a way to limit client overrun so that clients are not driven to resource exhaustion and ensuing failure when some resource they are using is temporarily blocked.

        See Also:
        Message.acknowledge(), Constant Field Values

      • DUPS_OK_ACKNOWLEDGE

        static final int DUPS_OK_ACKNOWLEDGE
        This acknowledgment mode instructs the session to lazily acknowledge the delivery of messages. This is likely to result in the delivery of some duplicate messages if the JMS provider fails, so it should only be used by consumers that can tolerate duplicate messages. Use of this mode can reduce session overhead by minimizing the work the session does to prevent duplicates.
        See Also:
        Constant Field Values

      • SESSION_TRANSACTED

        static final int SESSION_TRANSACTED
        This value may be passed as the argument to the method createSession(int sessionMode) on the Connection object to specify that the session should use a local transaction.

        This value is returned from the method getAcknowledgeMode if the session is using a local transaction, irrespective of whether the session was created by calling the method createSession(int sessionMode) or the method createSession(boolean transacted, int acknowledgeMode).

        Since:
        JMS 1.1
        See Also:
        Constant Field Values

    • Method Detail

      • createBytesMessage

        BytesMessage createBytesMessage()
                                throws JMSException
        Creates a BytesMessage object. A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSException - if the JMS provider fails to create this message due to some internal error.

      • createMapMessage

        MapMessage createMapMessage()
                            throws JMSException
        Creates a MapMessage object. A MapMessage object is used to send a self-defining set of name-value pairs, where names are String objects and values are primitive values in the Java programming language.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSException - if the JMS provider fails to create this message due to some internal error.

      • createMessage

        Message createMessage()
                      throws JMSException
        Creates a Message object. The Message interface is the root interface of all JMS messages. A Message object holds all the standard message header information. It can be sent when a message containing only header information is sufficient.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSException - if the JMS provider fails to create this message due to some internal error.

      • createObjectMessage

        ObjectMessage createObjectMessage()
                                  throws JMSException
        Creates an ObjectMessage object. An ObjectMessage object is used to send a message that contains a serializable Java object.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSException - if the JMS provider fails to create this message due to some internal error.

      • createObjectMessage

        ObjectMessage createObjectMessage(Serializable object)
                                  throws JMSException
        Creates an initialized ObjectMessage object. An ObjectMessage object is used to send a message that contains a serializable Java object.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Parameters:
        object - the object to use to initialize this message
        Throws:
        JMSException - if the JMS provider fails to create this message due to some internal error.

      • createStreamMessage

        StreamMessage createStreamMessage()
                                  throws JMSException
        Creates a StreamMessage object. A StreamMessage object is used to send a self-defining stream of primitive values in the Java programming language.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSException - if the JMS provider fails to create this message due to some internal error.

      • createTextMessage

        TextMessage createTextMessage()
                              throws JMSException
        Creates a TextMessage object. A TextMessage object is used to send a message containing a String object.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Throws:
        JMSException - if the JMS provider fails to create this message due to some internal error.

      • createTextMessage

        TextMessage createTextMessage(String text)
                              throws JMSException
        Creates an initialized TextMessage object. A TextMessage object is used to send a message containing a String.

        The message object returned may be sent using any Session or JMSContext. It is not restricted to being sent using the JMSContext used to create it.

        The message object returned may be optimised for use with the JMS provider used to create it. However it can be sent using any JMS provider, not just the JMS provider used to create it.

        Parameters:
        text - the string used to initialize this message
        Throws:
        JMSException - if the JMS provider fails to create this message due to some internal error.

      • getTransacted

        boolean getTransacted()
                      throws JMSException
        Indicates whether the session is in transacted mode.
        Returns:
        true if the session is in transacted mode
        Throws:
        JMSException - if the JMS provider fails to return the transaction mode due to some internal error.

      • getAcknowledgeMode

        int getAcknowledgeMode()
                       throws JMSException
        Returns the acknowledgement mode of the session. The acknowledgement mode is set at the time that the session is created. If the session is transacted, the acknowledgement mode is ignored.
        Returns:
        If the session is not transacted, returns the current acknowledgement mode for the session. If the session is transacted, returns SESSION_TRANSACTED.
        Throws:
        JMSException - if the JMS provider fails to return the acknowledgment mode due to some internal error.
        Since:
        JMS 1.1
        See Also:
        Connection.createSession(boolean, int)

      • commit

        void commit()
            throws JMSException
        Commits all messages done in this transaction and releases any locks currently held.

        This method must not return until any incomplete asynchronous send operations for this Session have been completed and any CompletionListener callbacks have returned. Incomplete sends should be allowed to complete normally unless an error occurs.

        A CompletionListener callback method must not call commit on its own Session. Doing so will cause an IllegalStateException to be thrown.

        Throws:
        IllegalStateException -
        • the session is not using a local transaction
        • this method has been called by a CompletionListener callback method on its own Session
        JMSException - if the JMS provider fails to commit the transaction due to some internal error.
        TransactionRolledBackException - if the transaction is rolled back due to some internal error during commit.

      • rollback

        void rollback()
              throws JMSException
        Rolls back any messages done in this transaction and releases any locks currently held.

        This method must not return until any incomplete asynchronous send operations for this Session have been completed and any CompletionListener callbacks have returned. Incomplete sends should be allowed to complete normally unless an error occurs.

        A CompletionListener callback method must not call commit on its own Session. Doing so will cause an IllegalStateException to be thrown.

        Throws:
        IllegalStateException -
        • the session is not using a local transaction
        • this method has been called by a CompletionListener callback method on its own Session
        JMSException - if the JMS provider fails to roll back the transaction due to some internal error.

      • close

        void close()
           throws JMSException
        Closes the session.

        Since a provider may allocate some resources on behalf of a session outside the JVM, clients should close the resources when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

        There is no need to close the producers and consumers of a closed session.

        This call will block until a receive call or message listener in progress has completed. A blocked message consumer receive call returns null when this session is closed.

        This method must not return until any incomplete asynchronous send operations for this Session have been completed and any CompletionListener callbacks have returned. Incomplete sends should be allowed to complete normally unless an error occurs.

        For the avoidance of doubt, if an exception listener for this session's connection is running when close is invoked, there is no requirement for the close call to wait until the exception listener has returned before it may return.

        Closing a transacted session must roll back the transaction in progress.

        This method is the only Session method that can be called concurrently.

        A MessageListener must not attempt to close its own Session as this would lead to deadlock. The JMS provider must detect this and throw a IllegalStateException.

        A CompletionListener callback method must not call close on its own Session. Doing so will cause an IllegalStateException to be thrown.

        Invoking any other Session method on a closed session must throw a IllegalStateException. Closing a closed session must not throw an exception.

        Specified by:
        close in interface AutoCloseable
        Throws:
        IllegalStateException -
        • this method has been called by a MessageListener on its own Session
        • this method has been called by a CompletionListener callback method on its own Session
        JMSException - if the JMS provider fails to close the session due to some internal error.

      • recover

        void recover()
             throws JMSException
        Stops message delivery in this session, and restarts message delivery with the oldest unacknowledged message.

        All consumers deliver messages in a serial order. Acknowledging a received message automatically acknowledges all messages that have been delivered to the client.

        Restarting a session causes it to take the following actions:

        • Stop message delivery
        • Mark all messages that might have been delivered but not acknowledged as "redelivered"
        • Restart the delivery sequence including all unacknowledged messages that had been previously delivered. Redelivered messages do not have to be delivered in exactly their original delivery order.
        Throws:
        JMSException - if the JMS provider fails to stop and restart message delivery due to some internal error.
        IllegalStateException - if the method is called by a transacted session.

      • getMessageListener

        MessageListener getMessageListener()
                                   throws JMSException
        Returns the session's distinguished message listener (optional).

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Returns:
        the distinguished message listener associated with this session
        Throws:
        JMSException - if the JMS provider fails to get the session's distinguished message listener for one of the following reasons:
        • an internal error has occurred
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        See Also:
        setMessageListener(javax.jms.MessageListener), ServerSessionPool, ServerSession

      • setMessageListener

        void setMessageListener(MessageListener listener)
                        throws JMSException
        Sets the session's distinguished message listener (optional).

        When the distinguished message listener is set, no other form of message receipt in the session can be used; however, all forms of sending messages are still supported.

        This is an expert facility not used by ordinary JMS clients.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSException to be thrown though this is not guaranteed.

        Parameters:
        listener - the message listener to associate with this session
        Throws:
        JMSException - if the JMS provider fails to set the session's distinguished message listener for one of the following reasons:
        • an internal error has occurred
        • this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        See Also:
        getMessageListener(), ServerSessionPool, ServerSession

      • run

        void run()
        Optional operation, intended to be used only by Application Servers, not by ordinary JMS clients.

        This method must not be used in a Java EE web or EJB application. Doing so may cause a JMSRuntimeException to be thrown though this is not guaranteed.

        Specified by:
        run in interface Runnable
        Throws:
        JMSRuntimeException - if this method has been called in a Java EE web or EJB application (though it is not guaranteed that an exception is thrown in this case)
        See Also:
        ServerSession

      • createProducer

        MessageProducer createProducer(Destination destination)
                               throws JMSException
        Creates a MessageProducer to send messages to the specified destination.

        A client uses a MessageProducer object to send messages to a destination. Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageProducer object.

        Parameters:
        destination - the Destination to send to, or null if this is a producer which does not have a specified destination.
        Throws:
        JMSException - if the session fails to create a MessageProducer due to some internal error.
        InvalidDestinationException - if an invalid destination is specified.
        Since:
        JMS 1.1

      • createConsumer

        MessageConsumer createConsumer(Destination destination)
                               throws JMSException
        Creates a MessageConsumer for the specified destination. Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageConsumer.
        Parameters:
        destination - the Destination to access.
        Throws:
        JMSException - if the session fails to create a consumer due to some internal error.
        InvalidDestinationException - if an invalid destination is specified.
        Since:
        JMS 1.1

      • createConsumer

        MessageConsumer createConsumer(Destination destination,
                             String messageSelector)
                               throws JMSException
        Creates a MessageConsumer for the specified destination, using a message selector. Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageConsumer.

        A client uses a MessageConsumer object to receive messages that have been sent to a destination.

        Parameters:
        destination - the Destination to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        Throws:
        JMSException - if the session fails to create a MessageConsumer due to some internal error.
        InvalidDestinationException - if an invalid destination is specified.
        InvalidSelectorException - if the message selector is invalid.
        Since:
        JMS 1.1

      • createConsumer

        MessageConsumer createConsumer(Destination destination,
                             String messageSelector,
                             boolean noLocal)
                               throws JMSException
        Creates a MessageConsumer for the specified destination, specifying a message selector and the noLocal parameter.

        Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageConsumer.

        A client uses a MessageConsumer object to receive messages that have been published to a destination.

        The noLocal argument is for use when the destination is a topic and the session's connection is also being used to publish messages to that topic. If noLocal is set to true then the MessageConsumer will not receive messages published to the topic by its own connection. The default value of this argument is false. If the destination is a queue then the effect of setting noLocal to true is not specified.

        Parameters:
        destination - the Destination to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        noLocal - - if true, and the destination is a topic, then the MessageConsumer will not receive messages published to the topic by its own connection.
        Throws:
        JMSException - if the session fails to create a MessageConsumer due to some internal error.
        InvalidDestinationException - if an invalid destination is specified.
        InvalidSelectorException - if the message selector is invalid.
        Since:
        JMS 1.1

      • createSharedConsumer

        MessageConsumer createSharedConsumer(Topic topic,
                                   String sharedSubscriptionName)
                                     throws JMSException
        Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription. This method creates the non-durable subscription without a message selector.

        If a shared non-durable subscription already exists with the same name and client identifier (if set), and the same topic and message selector value has been specified, then this method creates a MessageConsumer on the existing subscription.

        A non-durable shared subscription is used by a client which needs to be able to share the work of receiving messages from a topic subscription amongst multiple consumers. A non-durable shared subscription may therefore have more than one consumer. Each message from the subscription will be delivered to only one of the consumers on that subscription. Such a subscription is not persisted and will be deleted (together with any undelivered messages associated with it) when there are no consumers on it. The term "consumer" here means a MessageConsumer or JMSConsumer object in any client.

        A shared non-durable subscription is identified by a name specified by the client and by the client identifier (which may be unset). An application which subsequently wishes to create a consumer on that shared non-durable subscription must use the same client identifier.

        If a shared non-durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector has been specified, and there is a consumer already active (i.e. not closed) on the subscription, then a JMSException will be thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId (which may be unset). Such subscriptions would be completely separate.

        Parameters:
        topic - the Topic to subscribe to
        sharedSubscriptionName - the name used to identify the shared non-durable subscription
        Throws:
        JMSException - if the session fails to create the shared non-durable subscription and MessageConsumer due to some internal error.
        InvalidDestinationException - if an invalid topic is specified.
        InvalidSelectorException - if the message selector is invalid.
        Since:
        JMS 2.0

      • createSharedConsumer

        MessageConsumer createSharedConsumer(Topic topic,
                                   String sharedSubscriptionName,
                                   String messageSelector)
                                     throws JMSException
        Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.

        If a shared non-durable subscription already exists with the same name and client identifier (if set), and the same topic and message selector has been specified, then this method creates a MessageConsumer on the existing subscription.

        A non-durable shared subscription is used by a client which needs to be able to share the work of receiving messages from a topic subscription amongst multiple consumers. A non-durable shared subscription may therefore have more than one consumer. Each message from the subscription will be delivered to only one of the consumers on that subscription. Such a subscription is not persisted and will be deleted (together with any undelivered messages associated with it) when there are no consumers on it. The term "consumer" here means a MessageConsumer or JMSConsumer object in any client.

        A shared non-durable subscription is identified by a name specified by the client and by the client identifier (which may be unset). An application which subsequently wishes to create a consumer on that shared non-durable subscription must use the same client identifier.

        If a shared non-durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector has been specified, and there is a consumer already active (i.e. not closed) on the subscription, then a JMSException will be thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId (which may be unset). Such subscriptions would be completely separate.

        Parameters:
        topic - the Topic to subscribe to
        sharedSubscriptionName - the name used to identify the shared non-durable subscription
        messageSelector - only messages with properties matching the message selector expression are added to the shared non-durable subscription. A value of null or an empty string indicates that there is no message selector for the shared non-durable subscription.
        Throws:
        JMSException - if the session fails to create the shared non-durable subscription and MessageConsumer due to some internal error.
        InvalidDestinationException - if an invalid topic is specified.
        InvalidSelectorException - if the message selector is invalid.
        Since:
        JMS 2.0

      • createQueue

        Queue createQueue(String queueName)
                  throws JMSException
        Creates a Queue object which encapsulates a specified provider-specific queue name.

        The use of provider-specific queue names in an application may render the application non-portable. Portable applications are recommended to not use this method but instead look up an administratively-defined Queue object using JNDI.

        Note that this method simply creates an object that encapsulates the name of a queue. It does not create the physical queue in the JMS provider. JMS does not provide a method to create the physical queue, since this would be specific to a given JMS provider. Creating a physical queue is provider-specific and is typically an administrative task performed by an administrator, though some providers may create them automatically when needed. The one exception to this is the creation of a temporary queue, which is done using the createTemporaryQueue method.

        Parameters:
        queueName - A provider-specific queue name
        Returns:
        a Queue object which encapsulates the specified name
        Throws:
        JMSException - if a Queue object cannot be created due to some internal error

      • createTopic

        Topic createTopic(String topicName)
                  throws JMSException
        Creates a Topic object which encapsulates a specified provider-specific topic name.

        The use of provider-specific topic names in an application may render the application non-portable. Portable applications are recommended to not use this method but instead look up an administratively-defined Topic object using JNDI.

        Note that this method simply creates an object that encapsulates the name of a topic. It does not create the physical topic in the JMS provider. JMS does not provide a method to create the physical topic, since this would be specific to a given JMS provider. Creating a physical topic is provider-specific and is typically an administrative task performed by an administrator, though some providers may create them automatically when needed. The one exception to this is the creation of a temporary topic, which is done using the createTemporaryTopic method.

        Parameters:
        topicName - A provider-specific topic name
        Returns:
        a Topic object which encapsulates the specified name
        Throws:
        JMSException - if a Topic object cannot be created due to some internal error

      • createDurableSubscriber

        TopicSubscriber createDurableSubscriber(Topic topic,
                                      String name)
                                        throws JMSException
        Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription. This method creates the durable subscription without a message selector and with a noLocal value of false.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with unshared durable subscriptions. Any durable subscription created using this method will be unshared. This means that only one active (i.e. not closed) consumer on the subscription may exist at a time. The term "consumer" here means a TopicSubscriber, MessageConsumer or JMSConsumer object in any client.

        An unshared durable subscription is identified by a name specified by the client and by the client identifier, which must be set. An application which subsequently wishes to create a consumer on that unshared durable subscription must use the same client identifier.

        If an unshared durable subscription already exists with the same name and client identifier, and the same topic, message selector and noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this method creates a TopicSubscriber on the existing durable subscription.

        If an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active (i.e. not closed) on the durable subscription, then a JMSException will be thrown.

        If an unshared durable subscription already exists with the same name and client identifier but a different topic, message selector or noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this is equivalent to unsubscribing (deleting) the old one and creating a new one.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier. If a shared durable subscription already exists with the same name and client identifier then a JMSException is thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId. Such subscriptions would be completely separate.

        This method is identical to the corresponding createDurableConsumer method except that it returns a TopicSubscriber rather than a MessageConsumer to represent the consumer.

        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        Throws:
        InvalidDestinationException - if an invalid topic is specified.
        IllegalStateException - if the client identifier is unset
        JMSException -
        • if the session fails to create the unshared durable subscription and TopicSubscriber due to some internal error
        • if an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active
        • if a shared durable subscription already exists with the same name and client identifier
        Since:
        JMS 1.1

      • createDurableSubscriber

        TopicSubscriber createDurableSubscriber(Topic topic,
                                      String name,
                                      String messageSelector,
                                      boolean noLocal)
                                        throws JMSException
        Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with unshared durable subscriptions. Any durable subscription created using this method will be unshared. This means that only one active (i.e. not closed) consumer on the subscription may exist at a time. The term "consumer" here means a TopicSubscriber, MessageConsumer or JMSConsumer object in any client.

        An unshared durable subscription is identified by a name specified by the client and by the client identifier, which must be set. An application which subsequently wishes to create a consumer on that unshared durable subscription must use the same client identifier.

        If an unshared durable subscription already exists with the same name and client identifier, and the same topic, message selector and noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this method creates a TopicSubscriber on the existing durable subscription.

        If an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active (i.e. not closed) on the durable subscription, then a JMSException will be thrown.

        If an unshared durable subscription already exists with the same name and client identifier but a different topic, message selector or noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this is equivalent to unsubscribing (deleting) the old one and creating a new one.

        If noLocal is set to true then any messages published to the topic using this session's connection, or any other connection with the same client identifier, will not be added to the durable subscription.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier. If a shared durable subscription already exists with the same name and client identifier then a JMSException is thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId. Such subscriptions would be completely separate.

        This method is identical to the corresponding createDurableConsumer method except that it returns a TopicSubscriber rather than a MessageConsumer to represent the consumer.

        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        messageSelector - only messages with properties matching the message selector expression are added to the durable subscription. A value of null or an empty string indicates that there is no message selector for the durable subscription.
        noLocal - if true then any messages published to the topic using this session's connection, or any other connection with the same client identifier, will not be added to the durable subscription.
        Throws:
        InvalidDestinationException - if an invalid topic is specified.
        InvalidSelectorException - if the message selector is invalid.
        IllegalStateException - if the client identifier is unset
        JMSException -
        • if the session fails to create the unshared durable subscription and TopicSubscriber due to some internal error
        • if an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active
        • if a shared durable subscription already exists with the same name and client identifier
        Since:
        JMS 1.1

      • createDurableConsumer

        MessageConsumer createDurableConsumer(Topic topic,
                                    String name)
                                      throws JMSException
        Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription. This method creates the durable subscription without a message selector and with a noLocal value of false.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with unshared durable subscriptions. Any durable subscription created using this method will be unshared. This means that only one active (i.e. not closed) consumer on the subscription may exist at a time. The term "consumer" here means a TopicSubscriber, MessageConsumer or JMSConsumer object in any client.

        An unshared durable subscription is identified by a name specified by the client and by the client identifier, which must be set. An application which subsequently wishes to create a consumer on that unshared durable subscription must use the same client identifier.

        If an unshared durable subscription already exists with the same name and client identifier, and the same topic, message selector and noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this method creates a MessageConsumer on the existing durable subscription.

        If an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active (i.e. not closed) on the durable subscription, then a JMSException will be thrown.

        If an unshared durable subscription already exists with the same name and client identifier but a different topic, message selector or noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this is equivalent to unsubscribing (deleting) the old one and creating a new one.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier. If a shared durable subscription already exists with the same name and client identifier then a JMSException is thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId. Such subscriptions would be completely separate.

        This method is identical to the corresponding createDurableSubscriber method except that it returns a MessageConsumer rather than a TopicSubscriber to represent the consumer.

        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        Throws:
        InvalidDestinationException - if an invalid topic is specified.
        IllegalStateException - if the client identifier is unset
        JMSException -
        • if the session fails to create the unshared durable subscription and MessageConsumer due to some internal error
        • if an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active
        • if a shared durable subscription already exists with the same name and client identifier
        Since:
        JMS 2.0

      • createDurableConsumer

        MessageConsumer createDurableConsumer(Topic topic,
                                    String name,
                                    String messageSelector,
                                    boolean noLocal)
                                      throws JMSException
        Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with unshared durable subscriptions. Any durable subscription created using this method will be unshared. This means that only one active (i.e. not closed) consumer on the subscription may exist at a time. The term "consumer" here means a TopicSubscriber, MessageConsumer or JMSConsumer object in any client.

        An unshared durable subscription is identified by a name specified by the client and by the client identifier, which must be set. An application which subsequently wishes to create a consumer on that unshared durable subscription must use the same client identifier.

        If an unshared durable subscription already exists with the same name and client identifier, and the same topic, message selector and noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this method creates a MessageConsumer on the existing durable subscription.

        If an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active (i.e. not closed) on the durable subscription, then a JMSException will be thrown.

        If an unshared durable subscription already exists with the same name and client identifier but a different topic, message selector or noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this is equivalent to unsubscribing (deleting) the old one and creating a new one.

        If noLocal is set to true then any messages published to the topic using this session's connection, or any other connection with the same client identifier, will not be added to the durable subscription.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier. If a shared durable subscription already exists with the same name and client identifier then a JMSException is thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId. Such subscriptions would be completely separate.

        This method is identical to the corresponding createDurableSubscriber method except that it returns a MessageConsumer rather than a TopicSubscriber to represent the consumer.

        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        messageSelector - only messages with properties matching the message selector expression are added to the durable subscription. A value of null or an empty string indicates that there is no message selector for the durable subscription.
        noLocal - if true then any messages published to the topic using this session's connection, or any other connection with the same client identifier, will not be added to the durable subscription.
        Throws:
        InvalidDestinationException - if an invalid topic is specified.
        InvalidSelectorException - if the message selector is invalid.
        IllegalStateException - if the client identifier is unset
        JMSException -
        • if the session fails to create the unshared durable subscription and MessageConsumer due to some internal error
        • if an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active
        • if a shared durable subscription already exists with the same name and client identifier
        Since:
        JMS 2.0

      • createSharedDurableConsumer

        MessageConsumer createSharedDurableConsumer(Topic topic,
                                          String name)
                                            throws JMSException
        Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription. This method creates the durable subscription without a message selector.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with shared durable subscriptions. Any durable subscription created using this method will be shared. This means that multiple active (i.e. not closed) consumers on the subscription may exist at the same time. The term "consumer" here means a MessageConsumer or JMSConsumer object in any client.

        A shared durable subscription is identified by a name specified by the client and by the client identifier (which may be unset). An application which subsequently wishes to create a consumer on that shared durable subscription must use the same client identifier.

        If a shared durable subscription already exists with the same name and client identifier (if set), and the same topic and message selector has been specified, then this method creates a MessageConsumer on the existing shared durable subscription.

        If a shared durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this is equivalent to unsubscribing (deleting) the old one and creating a new one.

        If a shared durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector has been specified, and there is a consumer already active (i.e. not closed) on the durable subscription, then a JMSException will be thrown.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier (if set). If an unshared durable subscription already exists with the same name and client identifier (if set) then a JMSException is thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId (which may be unset). Such subscriptions would be completely separate.

        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        Throws:
        JMSException -
        • if the session fails to create the shared durable subscription and MessageConsumer due to some internal error
        • if a shared durable subscription already exists with the same name and client identifier, but a different topic or message selector, and there is a consumer already active
        • if an unshared durable subscription already exists with the same name and client identifier
        InvalidDestinationException - if an invalid topic is specified.
        Since:
        JMS 2.0

      • createSharedDurableConsumer

        MessageConsumer createSharedDurableConsumer(Topic topic,
                                          String name,
                                          String messageSelector)
                                            throws JMSException
        Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with shared durable subscriptions. Any durable subscription created using this method will be shared. This means that multiple active (i.e. not closed) consumers on the subscription may exist at the same time. The term "consumer" here means a MessageConsumer or JMSConsumer object in any client.

        A shared durable subscription is identified by a name specified by the client and by the client identifier (which may be unset). An application which subsequently wishes to create a consumer on that shared durable subscription must use the same client identifier.

        If a shared durable subscription already exists with the same name and client identifier (if set), and the same topic and message selector has been specified, then this method creates a MessageConsumer on the existing shared durable subscription.

        If a shared durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription then this is equivalent to unsubscribing (deleting) the old one and creating a new one.

        If a shared durable subscription already exists with the same name and client identifier (if set) but a different topic or message selector has been specified, and there is a consumer already active (i.e. not closed) on the durable subscription, then a JMSException will be thrown.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier (if set). If an unshared durable subscription already exists with the same name and client identifier (if set) then a JMSException is thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId (which may be unset). Such subscriptions would be completely separate.

        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        messageSelector - only messages with properties matching the message selector expression are added to the durable subscription. A value of null or an empty string indicates that there is no message selector for the durable subscription.
        Throws:
        JMSException -
        • if the session fails to create the shared durable subscription and MessageConsumer due to some internal error
        • if a shared durable subscription already exists with the same name and client identifier, but a different topic or message selector, and there is a consumer already active
        • if an unshared durable subscription already exists with the same name and client identifier
        InvalidDestinationException - if an invalid topic is specified.
        InvalidSelectorException - if the message selector is invalid.
        Since:
        JMS 2.0

      • createBrowser

        QueueBrowser createBrowser(Queue queue)
                           throws JMSException
        Creates a QueueBrowser object to peek at the messages on the specified queue.
        Parameters:
        queue - the queue to access
        Throws:
        JMSException - if the session fails to create a browser due to some internal error.
        InvalidDestinationException - if an invalid destination is specified
        Since:
        JMS 1.1

      • createBrowser

        QueueBrowser createBrowser(Queue queue,
                         String messageSelector)
                           throws JMSException
        Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
        Parameters:
        queue - the queue to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        Throws:
        JMSException - if the session fails to create a browser due to some internal error.
        InvalidDestinationException - if an invalid destination is specified
        InvalidSelectorException - if the message selector is invalid.
        Since:
        JMS 1.1

      • createTemporaryQueue

        TemporaryQueue createTemporaryQueue()
                                    throws JMSException
        Creates a TemporaryQueue object. Its lifetime will be that of the Connection unless it is deleted earlier.
        Returns:
        a temporary queue identity
        Throws:
        JMSException - if the session fails to create a temporary queue due to some internal error.
        Since:
        JMS 1.1

      • createTemporaryTopic

        TemporaryTopic createTemporaryTopic()
                                    throws JMSException
        Creates a TemporaryTopic object. Its lifetime will be that of the Connection unless it is deleted earlier.
        Returns:
        a temporary topic identity
        Throws:
        JMSException - if the session fails to create a temporary topic due to some internal error.
        Since:
        JMS 1.1

      • unsubscribe

        void unsubscribe(String name)
                 throws JMSException
        Unsubscribes a durable subscription that has been created by a client.

        This method deletes the state being maintained on behalf of the subscriber by its provider.

        A durable subscription is identified by a name specified by the client and by the client identifier if set. If the client identifier was set when the durable subscription was created then a client which subsequently wishes to use this method to delete a durable subscription must use the same client identifier.

        It is erroneous for a client to delete a durable subscription while there is an active (not closed) consumer for the subscription, or while a consumed message is part of a pending transaction or has not been acknowledged in the session.

        Parameters:
        name - the name used to identify this subscription
        Throws:
        JMSException - if the session fails to unsubscribe to the durable subscription due to some internal error.
        InvalidDestinationException - if an invalid subscription name is specified.
        Since:
        JMS 1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StreamMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface StreamMessage

  • All Superinterfaces:
    Message

    public interface StreamMessage
extends Message
    A StreamMessage object is used to send a stream of primitive types in the Java programming language. It is filled and read sequentially. It inherits from the Message interface and adds a stream message body. Its methods are based largely on those found in java.io.DataInputStream and java.io.DataOutputStream.

    The primitive types can be read or written explicitly using methods for each type. They may also be read or written generically as objects. For instance, a call to StreamMessage.writeInt(6) is equivalent to StreamMessage.writeObject(new Integer(6)). Both forms are provided, because the explicit form is convenient for static programming, and the object form is needed when types are not known at compile time.

    When the message is first created, and when clearBody is called, the body of the message is in write-only mode. After the first call to reset has been made, the message body is in read-only mode. After a message has been sent, the client that sent it can retain and modify it without affecting the message that has been sent. The same message object can be sent multiple times. When a message has been received, the provider has called reset so that the message body is in read-only mode for the client.

    If clearBody is called on a message in read-only mode, the message body is cleared and the message body is in write-only mode.

    If a client attempts to read a message in write-only mode, a MessageNotReadableException is thrown.

    If a client attempts to write a message in read-only mode, a MessageNotWriteableException is thrown.

    StreamMessage objects support the following conversion table. The marked cases must be supported. The unmarked cases must throw a JMSException. The String-to-primitive conversions may throw a runtime exception if the primitive's valueOf() method does not accept it as a valid String representation of the primitive.

    A value written as the row type can be read as the column type.

     |        | boolean byte short char int long float double String byte[]
 |----------------------------------------------------------------------
 |boolean |    X                                            X
 |byte    |          X     X         X   X                  X
 |short   |                X         X   X                  X
 |char    |                     X                           X
 |int     |                          X   X                  X
 |long    |                              X                  X
 |float   |                                    X     X      X
 |double  |                                          X      X
 |String  |    X     X     X         X   X     X     X      X
 |byte[]  |                                                        X
 |----------------------------------------------------------------------

    Attempting to read a null value as a primitive type must be treated as calling the primitive's corresponding valueOf(String) conversion method with a null value. Since char does not support a String conversion, attempting to read a null value as a char must throw a NullPointerException.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createStreamMessage(), BytesMessage, MapMessage, Message, ObjectMessage, TextMessage

    • Field Summary

      • Fields inherited from interface javax.jms.Message

        DEFAULT_DELIVERY_DELAY, DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean readBoolean()
      Reads a boolean from the stream message.
      byte readByte()
      Reads a byte value from the stream message.
      int readBytes(byte[] value)
      Reads a byte array field from the stream message into the specified byte[] object (the read buffer).
      char readChar()
      Reads a Unicode character value from the stream message.
      double readDouble()
      Reads a double from the stream message.
      float readFloat()
      Reads a float from the stream message.
      int readInt()
      Reads a 32-bit integer from the stream message.
      long readLong()
      Reads a 64-bit integer from the stream message.
      Object readObject()
      Reads an object from the stream message.
      short readShort()
      Reads a 16-bit integer from the stream message.
      String readString()
      Reads a String from the stream message.
      void reset()
      Puts the message body in read-only mode and repositions the stream to the beginning.
      void writeBoolean(boolean value)
      Writes a boolean to the stream message.
      void writeByte(byte value)
      Writes a byte to the stream message.
      void writeBytes(byte[] value)
      Writes a byte array field to the stream message.
      void writeBytes(byte[] value, int offset, int length)
      Writes a portion of a byte array as a byte array field to the stream message.
      void writeChar(char value)
      Writes a char to the stream message.
      void writeDouble(double value)
      Writes a double to the stream message.
      void writeFloat(float value)
      Writes a float to the stream message.
      void writeInt(int value)
      Writes an int to the stream message.
      void writeLong(long value)
      Writes a long to the stream message.
      void writeObject(Object value)
      Writes an object to the stream message.
      void writeShort(short value)
      Writes a short to the stream message.
      void writeString(String value)
      Writes a String to the stream message.

      • Methods inherited from interface javax.jms.Message

        acknowledge, clearBody, clearProperties, getBody, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDeliveryTime, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, isBodyAssignableTo, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDeliveryTime, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

    • Method Detail

      • readBoolean

        boolean readBoolean()
                    throws JMSException
        Reads a boolean from the stream message.
        Returns:
        the boolean value read
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid.
        MessageNotReadableException - if the message is in write-only mode.

      • readByte

        byte readByte()
              throws JMSException
        Reads a byte value from the stream message.
        Returns:
        the next byte from the stream message as a 8-bit byte
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid.
        MessageNotReadableException - if the message is in write-only mode.

      • readShort

        short readShort()
                throws JMSException
        Reads a 16-bit integer from the stream message.
        Returns:
        a 16-bit integer from the stream message
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid.
        MessageNotReadableException - if the message is in write-only mode.

      • readChar

        char readChar()
              throws JMSException
        Reads a Unicode character value from the stream message.
        Returns:
        a Unicode character from the stream message
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid
        MessageNotReadableException - if the message is in write-only mode.

      • readInt

        int readInt()
            throws JMSException
        Reads a 32-bit integer from the stream message.
        Returns:
        a 32-bit integer value from the stream message, interpreted as an int
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid.
        MessageNotReadableException - if the message is in write-only mode.

      • readLong

        long readLong()
              throws JMSException
        Reads a 64-bit integer from the stream message.
        Returns:
        a 64-bit integer value from the stream message, interpreted as a long
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid.
        MessageNotReadableException - if the message is in write-only mode.

      • readFloat

        float readFloat()
                throws JMSException
        Reads a float from the stream message.
        Returns:
        a float value from the stream message
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid.
        MessageNotReadableException - if the message is in write-only mode.

      • readDouble

        double readDouble()
                  throws JMSException
        Reads a double from the stream message.
        Returns:
        a double value from the stream message
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid.
        MessageNotReadableException - if the message is in write-only mode.

      • readString

        String readString()
                  throws JMSException
        Reads a String from the stream message.
        Returns:
        a Unicode string from the stream message
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid.
        MessageNotReadableException - if the message is in write-only mode.

      • readBytes

        int readBytes(byte[] value)
              throws JMSException
        Reads a byte array field from the stream message into the specified byte[] object (the read buffer).

        To read the field value, readBytes should be successively called until it returns a value less than the length of the read buffer. The value of the bytes in the buffer following the last byte read is undefined.

        If readBytes returns a value equal to the length of the buffer, a subsequent readBytes call must be made. If there are no more bytes to be read, this call returns -1.

        If the byte array field value is null, readBytes returns -1.

        If the byte array field value is empty, readBytes returns 0.

        Once the first readBytes call on a byte[] field value has been made, the full value of the field must be read before it is valid to read the next field. An attempt to read the next field before that has been done will throw a MessageFormatException.

        To read the byte field value into a new byte[] object, use the readObject method.

        Parameters:
        value - the buffer into which the data is read
        Returns:
        the total number of bytes read into the buffer, or -1 if there is no more data because the end of the byte field has been reached
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid.
        MessageNotReadableException - if the message is in write-only mode.
        See Also:
        readObject()

      • readObject

        Object readObject()
                  throws JMSException
        Reads an object from the stream message.

        This method can be used to return, in objectified format, an object in the Java programming language ("Java object") that has been written to the stream with the equivalent writeObject method call, or its equivalent primitive write<I>type</I> method.

        Note that byte values are returned as byte[], not Byte[].

        An attempt to call readObject to read a byte field value into a new byte[] object before the full value of the byte field has been read will throw a MessageFormatException.

        Returns:
        a Java object from the stream message, in objectified format (for example, if the object was written as an int, an Integer is returned)
        Throws:
        JMSException - if the JMS provider fails to read the message due to some internal error.
        MessageEOFException - if unexpected end of message stream has been reached.
        MessageFormatException - if this type conversion is invalid.
        MessageNotReadableException - if the message is in write-only mode.
        See Also:
        readBytes(byte[] value)

      • writeBoolean

        void writeBoolean(boolean value)
                  throws JMSException
        Writes a boolean to the stream message. The value true is written as the value (byte)1; the value false is written as the value (byte)0.
        Parameters:
        value - the boolean value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeByte

        void writeByte(byte value)
               throws JMSException
        Writes a byte to the stream message.
        Parameters:
        value - the byte value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeShort

        void writeShort(short value)
                throws JMSException
        Writes a short to the stream message.
        Parameters:
        value - the short value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeChar

        void writeChar(char value)
               throws JMSException
        Writes a char to the stream message.
        Parameters:
        value - the char value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeInt

        void writeInt(int value)
              throws JMSException
        Writes an int to the stream message.
        Parameters:
        value - the int value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeLong

        void writeLong(long value)
               throws JMSException
        Writes a long to the stream message.
        Parameters:
        value - the long value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeFloat

        void writeFloat(float value)
                throws JMSException
        Writes a float to the stream message.
        Parameters:
        value - the float value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeDouble

        void writeDouble(double value)
                 throws JMSException
        Writes a double to the stream message.
        Parameters:
        value - the double value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeString

        void writeString(String value)
                 throws JMSException
        Writes a String to the stream message.
        Parameters:
        value - the String value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeBytes

        void writeBytes(byte[] value)
                throws JMSException
        Writes a byte array field to the stream message.

        The byte array value is written to the message as a byte array field. Consecutively written byte array fields are treated as two distinct fields when the fields are read.

        Parameters:
        value - the byte array value to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeBytes

        void writeBytes(byte[] value,
              int offset,
              int length)
                throws JMSException
        Writes a portion of a byte array as a byte array field to the stream message.

        The a portion of the byte array value is written to the message as a byte array field. Consecutively written byte array fields are treated as two distinct fields when the fields are read.

        Parameters:
        value - the byte array value to be written
        offset - the initial offset within the byte array
        length - the number of bytes to use
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • writeObject

        void writeObject(Object value)
                 throws JMSException
        Writes an object to the stream message.

        This method works only for the objectified primitive object types (Integer, Double, Long ...), String objects, and byte arrays.

        Parameters:
        value - the Java object to be written
        Throws:
        JMSException - if the JMS provider fails to write the message due to some internal error.
        MessageFormatException - if the object is invalid.
        MessageNotWriteableException - if the message is in read-only mode.

      • reset

        void reset()
           throws JMSException
        Puts the message body in read-only mode and repositions the stream to the beginning.
        Throws:
        JMSException - if the JMS provider fails to reset the message due to some internal error.
        MessageFormatException - if the message has an invalid format.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TemporaryQueue (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface TemporaryQueue

  • All Superinterfaces:
    Destination, Queue

    public interface TemporaryQueue
extends Queue
    A TemporaryQueue object is a unique Queue object created for the duration of a Connection. It is a system-defined queue that can be consumed only by the Connection that created it.

    A TemporaryQueue object can be created at either the Session or QueueSession level. Creating it at the Session level allows to the TemporaryQueue to participate in transactions with objects from the Pub/Sub domain. If it is created at the QueueSession, it will only be able participate in transactions with objects from the PTP domain.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createTemporaryQueue(), QueueSession.createTemporaryQueue()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void delete()
      Deletes this temporary queue.

      • Methods inherited from interface javax.jms.Queue

        getQueueName, toString

    • Method Detail

      • delete

        void delete()
            throws JMSException
        Deletes this temporary queue. If there are existing receivers still using it, a JMSException will be thrown.
        Throws:
        JMSException - if the JMS provider fails to delete the temporary queue due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TemporaryTopic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface TemporaryTopic

  • All Superinterfaces:
    Destination, Topic

    public interface TemporaryTopic
extends Topic
    A TemporaryTopic object is a unique Topic object created for the duration of a Connection. It is a system-defined topic that can be consumed only by the Connection that created it.

    A TemporaryTopic object can be created either at the Session or TopicSession level. Creating it at the Session level allows the TemporaryTopic to participate in the same transaction with objects from the PTP domain. If a TemporaryTopic is created at the TopicSession, it will only be able participate in transactions with objects from the Pub/Sub domain.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createTemporaryTopic(), TopicSession.createTemporaryTopic()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void delete()
      Deletes this temporary topic.

      • Methods inherited from interface javax.jms.Topic

        getTopicName, toString

    • Method Detail

      • delete

        void delete()
            throws JMSException
        Deletes this temporary topic. If there are existing subscribers still using it, a JMSException will be thrown.
        Throws:
        JMSException - if the JMS provider fails to delete the temporary topic due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TextMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface TextMessage

  • All Superinterfaces:
    Message

    public interface TextMessage
extends Message
    A TextMessage object is used to send a message containing a java.lang.String. It inherits from the Message interface and adds a text message body.

    This message type can be used to transport text-based messages, including those with XML content.

    When a client receives a TextMessage, it is in read-only mode. If a client attempts to write to the message at this point, a MessageNotWriteableException is thrown. If clearBody is called, the message can now be both read from and written to.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createTextMessage(), Session.createTextMessage(String), BytesMessage, MapMessage, Message, ObjectMessage, StreamMessage, String

    • Field Summary

      • Fields inherited from interface javax.jms.Message

        DEFAULT_DELIVERY_DELAY, DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getText()
      Gets the string containing this message's data.
      void setText(String string)
      Sets the string containing this message's data.

      • Methods inherited from interface javax.jms.Message

        acknowledge, clearBody, clearProperties, getBody, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDeliveryTime, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, isBodyAssignableTo, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDeliveryTime, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

    • Method Detail

      • setText

        void setText(String string)
             throws JMSException
        Sets the string containing this message's data.
        Parameters:
        string - the String containing the message's data
        Throws:
        JMSException - if the JMS provider fails to set the text due to some internal error.
        MessageNotWriteableException - if the message is in read-only mode.

      • getText

        String getText()
               throws JMSException
        Gets the string containing this message's data. The default value is null.
        Returns:
        the String containing the message's data
        Throws:
        JMSException - if the JMS provider fails to get the text due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Topic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface Topic

  • All Superinterfaces:
    Destination
    All Known Subinterfaces:
    TemporaryTopic

    public interface Topic
extends Destination
    A Topic object encapsulates a provider-specific topic name. It is the way a client specifies the identity of a topic to JMS API methods. For those methods that use a Destination as a parameter, a Topic object may used as an argument . For example, a Topic can be used to create a MessageConsumer and a MessageProducer by calling:
    • Session.CreateConsumer(Destination destination)
    • Session.CreateProducer(Destination destination)

    Many publish/subscribe (pub/sub) providers group topics into hierarchies and provide various options for subscribing to parts of the hierarchy. The JMS API places no restriction on what a Topic object represents. It may be a leaf in a topic hierarchy, or it may be a larger part of the hierarchy.

    The organization of topics and the granularity of subscriptions to them is an important part of a pub/sub application's architecture. The JMS API does not specify a policy for how this should be done. If an application takes advantage of a provider-specific topic-grouping mechanism, it should document this. If the application is installed using a different provider, it is the job of the administrator to construct an equivalent topic architecture and create equivalent Topic objects.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createConsumer(Destination),
Session.createProducer(Destination),
TopicSession.createTopic(String)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getTopicName()
      Gets the name of this topic.
      String toString()
      Returns a string representation of this object.

    • Method Detail

      • getTopicName

        String getTopicName()
                    throws JMSException
        Gets the name of this topic.

        Clients that depend upon the name are not portable.

        Returns:
        the topic name
        Throws:
        JMSException - if the JMS provider implementation of Topic fails to return the topic name due to some internal error.

      • toString

        String toString()
        Returns a string representation of this object.
        Overrides:
        toString in class Object
        Returns:
        the provider-specific identity values for this topic
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TopicConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface TopicConnection

  • All Superinterfaces:
    AutoCloseable, Connection
    All Known Subinterfaces:
    XATopicConnection

    public interface TopicConnection
extends Connection
    A TopicConnection object is an active connection to a publish/subscribe JMS provider. A client uses a TopicConnection object to create one or more TopicSession objects for producing and consuming messages.

    A TopicConnection can be used to create a TopicSession, from which specialized topic-related objects can be created. A more general, and recommended approach is to use the Connection object.

    The TopicConnection object should be used to support existing code.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Connection, ConnectionFactory, TopicConnectionFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConnectionConsumer createConnectionConsumer(Topic topic, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation).
      ConnectionConsumer createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Create a durable connection consumer for this connection (optional operation).
      TopicSession createTopicSession(boolean transacted, int acknowledgeMode)
      Creates a TopicSession object.

      • Methods inherited from interface javax.jms.Connection

        close, createConnectionConsumer, createSession, createSession, createSession, createSharedConnectionConsumer, createSharedDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

    • Method Detail

      • createTopicSession

        TopicSession createTopicSession(boolean transacted,
                              int acknowledgeMode)
                                throws JMSException
        Creates a TopicSession object.
        Parameters:
        transacted - indicates whether the session is transacted
        acknowledgeMode - indicates whether the consumer or the client will acknowledge any messages it receives; ignored if the session is transacted. Legal values are Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, and Session.DUPS_OK_ACKNOWLEDGE.
        Returns:
        a newly created topic session
        Throws:
        JMSException - if the TopicConnection object fails to create a session due to some internal error or lack of support for the specific transaction and acknowledgement mode.
        See Also:
        Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE

      • createConnectionConsumer

        ConnectionConsumer createConnectionConsumer(Topic topic,
                                          String messageSelector,
                                          ServerSessionPool sessionPool,
                                          int maxMessages)
                                            throws JMSException
        Creates a connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.
        Parameters:
        topic - the topic to access
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        sessionPool - the server session pool to associate with this connection consumer
        maxMessages - the maximum number of messages that can be assigned to a server session at one time
        Returns:
        the connection consumer
        Throws:
        JMSException - if the TopicConnection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
        InvalidDestinationException - if an invalid topic is specified.
        InvalidSelectorException - if the message selector is invalid.
        See Also:
        ConnectionConsumer

      • createDurableConnectionConsumer

        ConnectionConsumer createDurableConnectionConsumer(Topic topic,
                                                 String subscriptionName,
                                                 String messageSelector,
                                                 ServerSessionPool sessionPool,
                                                 int maxMessages)
                                                   throws JMSException
        Create a durable connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.
        Specified by:
        createDurableConnectionConsumer in interface Connection
        Parameters:
        topic - the topic to access
        subscriptionName - durable subscription name
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        sessionPool - the server session pool to associate with this durable connection consumer
        maxMessages - the maximum number of messages that can be assigned to a server session at one time
        Returns:
        the durable connection consumer
        Throws:
        JMSException - if the TopicConnection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
        InvalidDestinationException - if an invalid topic is specified.
        InvalidSelectorException - if the message selector is invalid.
        See Also:
        ConnectionConsumer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TopicConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface TopicConnectionFactory

  • All Superinterfaces:
    ConnectionFactory
    All Known Subinterfaces:
    XATopicConnectionFactory

    public interface TopicConnectionFactory
extends ConnectionFactory
    A client uses a TopicConnectionFactory object to create TopicConnection objects with a publish/subscribe JMS provider.

    ATopicConnectionFactory can be used to create a TopicConnection, from which specialized topic-related objects can be created. A more general, and recommended approach is to use the ConnectionFactory object.

    The TopicConnectionFactory object should be used to support existing code.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    ConnectionFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      TopicConnection createTopicConnection()
      Creates a topic connection with the default user identity.
      TopicConnection createTopicConnection(String userName, String password)
      Creates a topic connection with the specified user identity.

      • Methods inherited from interface javax.jms.ConnectionFactory

        createConnection, createConnection, createContext, createContext, createContext, createContext

    • Method Detail

      • createTopicConnection

        TopicConnection createTopicConnection()
                                      throws JMSException
        Creates a topic connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Returns:
        a newly created topic connection
        Throws:
        JMSException - if the JMS provider fails to create a topic connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.

      • createTopicConnection

        TopicConnection createTopicConnection(String userName,
                                    String password)
                                      throws JMSException
        Creates a topic connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Parameters:
        userName - the caller's user name
        password - the caller's password
        Returns:
        a newly created topic connection
        Throws:
        JMSException - if the JMS provider fails to create a topic connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TopicPublisher (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface TopicPublisher

  • All Superinterfaces:
    AutoCloseable, MessageProducer

    public interface TopicPublisher
extends MessageProducer
    A client uses a TopicPublisher object to publish messages on a topic. A TopicPublisher object is the publish-subscribe form of a message producer.

    Normally, the Topic is specified when a TopicPublisher is created. In this case, an attempt to use the publish methods for an unidentified TopicPublisher will throw a java.lang.UnsupportedOperationException.

    If the TopicPublisher is created with an unidentified Topic, an attempt to use the publish methods that assume that the Topic has been identified will throw a java.lang.UnsupportedOperationException.

    During the execution of its publish method, a message must not be changed by other threads within the client. If the message is modified, the result of the publish is undefined.

    After publishing a message, a client may retain and modify it without affecting the message that has been published. The same message object may be published multiple times.

    The following message headers are set as part of publishing a message: JMSDestination, JMSDeliveryMode, JMSExpiration, JMSPriority, JMSMessageID and JMSTimeStamp. When the message is published, the values of these headers are ignored. After completion of the publish, the headers hold the values specified by the method publishing the message. It is possible for the publish method not to set JMSMessageID and JMSTimeStamp if the setting of these headers is explicitly disabled by the MessageProducer.setDisableMessageID or MessageProducer.setDisableMessageTimestamp method.

    Creating a MessageProducer provides the same features as creating a TopicPublisher. A MessageProducer object is recommended when creating new code. The TopicPublisher is provided to support existing code.

    Because TopicPublisher inherits from MessageProducer, it inherits the send methods that are a part of the MessageProducer interface. Using the send methods will have the same effect as using the publish methods: they are functionally the same.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createProducer(Destination), TopicSession.createPublisher(Topic)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Topic getTopic()
      Gets the topic associated with this TopicPublisher.
      void publish(Message message)
      Publishes a message to the topic.
      void publish(Message message, int deliveryMode, int priority, long timeToLive)
      Publishes a message to the topic, specifying delivery mode, priority, and time to live.
      void publish(Topic topic, Message message)
      Publishes a message to a topic for an unidentified message producer.
      void publish(Topic topic, Message message, int deliveryMode, int priority, long timeToLive)
      Publishes a message to a topic for an unidentified message producer, specifying delivery mode, priority and time to live.

      • Methods inherited from interface javax.jms.MessageProducer

        close, getDeliveryDelay, getDeliveryMode, getDestination, getDisableMessageID, getDisableMessageTimestamp, getPriority, getTimeToLive, send, send, send, send, send, send, send, send, setDeliveryDelay, setDeliveryMode, setDisableMessageID, setDisableMessageTimestamp, setPriority, setTimeToLive

    • Method Detail

      • getTopic

        Topic getTopic()
               throws JMSException
        Gets the topic associated with this TopicPublisher.
        Returns:
        this publisher's topic
        Throws:
        JMSException - if the JMS provider fails to get the topic for this TopicPublisher due to some internal error.

      • publish

        void publish(Message message)
             throws JMSException
        Publishes a message to the topic. Uses the TopicPublisher's default delivery mode, priority, and time to live.
        Parameters:
        message - the message to publish
        Throws:
        JMSException - if the JMS provider fails to publish the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with a TopicPublisher with an invalid topic.
        UnsupportedOperationException - if a client uses this method with a TopicPublisher that did not specify a topic at creation time.
        See Also:
        MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

      • publish

        void publish(Message message,
           int deliveryMode,
           int priority,
           long timeToLive)
             throws JMSException
        Publishes a message to the topic, specifying delivery mode, priority, and time to live.
        Parameters:
        message - the message to publish
        deliveryMode - the delivery mode to use
        priority - the priority for this message
        timeToLive - the message's lifetime (in milliseconds)
        Throws:
        JMSException - if the JMS provider fails to publish the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with a TopicPublisher with an invalid topic.
        UnsupportedOperationException - if a client uses this method with a TopicPublisher that did not specify a topic at creation time.

      • publish

        void publish(Topic topic,
           Message message)
             throws JMSException
        Publishes a message to a topic for an unidentified message producer. Uses the TopicPublisher's default delivery mode, priority, and time to live.

        Typically, a message producer is assigned a topic at creation time; however, the JMS API also supports unidentified message producers, which require that the topic be supplied every time a message is published.

        Parameters:
        topic - the topic to publish this message to
        message - the message to publish
        Throws:
        JMSException - if the JMS provider fails to publish the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with an invalid topic.
        See Also:
        MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

      • publish

        void publish(Topic topic,
           Message message,
           int deliveryMode,
           int priority,
           long timeToLive)
             throws JMSException
        Publishes a message to a topic for an unidentified message producer, specifying delivery mode, priority and time to live.

        Typically, a message producer is assigned a topic at creation time; however, the JMS API also supports unidentified message producers, which require that the topic be supplied every time a message is published.

        Parameters:
        topic - the topic to publish this message to
        message - the message to publish
        deliveryMode - the delivery mode to use
        priority - the priority for this message
        timeToLive - the message's lifetime (in milliseconds)
        Throws:
        JMSException - if the JMS provider fails to publish the message due to some internal error.
        MessageFormatException - if an invalid message is specified.
        InvalidDestinationException - if a client uses this method with an invalid topic.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TopicRequestor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class TopicRequestor

  • java.lang.Object
    • javax.jms.TopicRequestor

  • public class TopicRequestor
extends Object
    The TopicRequestor helper class simplifies making service requests.

    The TopicRequestor constructor is given a non-transacted TopicSession and a destination Topic. It creates a TemporaryTopic for the responses and provides a request method that sends the request message and waits for its reply.

    This is a very basic request/reply abstraction which assumes the session is non-transacted with a delivery mode of either AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE. It is expected that most applications will create less basic implementations.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    QueueRequestor

    • Constructor Summary

      Constructors
      Constructor and Description
      TopicRequestor(TopicSession session, Topic topic)
      Constructor for the TopicRequestor class.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes the TopicRequestor and its session.
      Message request(Message message)
      Sends a request and waits for a reply.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TopicRequestor

        public TopicRequestor(TopicSession session,
              Topic topic)
               throws JMSException
        Constructor for the TopicRequestor class.

        This implementation assumes the session parameter to be non-transacted, with a delivery mode of either AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE.

        Parameters:
        session - the TopicSession the topic belongs to
        topic - the topic to perform the request/reply call on
        Throws:
        JMSException - if the JMS provider fails to create the TopicRequestor due to some internal error.
        InvalidDestinationException - if an invalid topic is specified.

    • Method Detail

      • request

        public Message request(Message message)
                throws JMSException
        Sends a request and waits for a reply. The temporary topic is used for the JMSReplyTo destination; the first reply is returned, and any following replies are discarded.
        Parameters:
        message - the message to send
        Returns:
        the reply message
        Throws:
        JMSException - if the JMS provider fails to complete the request due to some internal error.

      • close

        public void close()
           throws JMSException
        Closes the TopicRequestor and its session.

        Since a provider may allocate some resources on behalf of a TopicRequestor outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

        Note that this method closes the TopicSession object passed to the TopicRequestor constructor.

        Throws:
        JMSException - if the JMS provider fails to close the TopicRequestor due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TopicSession (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface TopicSession

  • All Superinterfaces:
    AutoCloseable, Runnable, Session

    public interface TopicSession
extends Session
    A TopicSession object provides methods for creating TopicPublisher, TopicSubscriber, and TemporaryTopic objects. It also provides a method for deleting its client's durable subscribers.

    A TopicSession is used for creating Pub/Sub specific objects. In general, use the Session object, and use TopicSession only to support existing code. Using the Session object simplifies the programming model, and allows transactions to be used across the two messaging domains.

    A TopicSession cannot be used to create objects specific to the point-to-point domain. The following methods inherit from Session, but must throw an IllegalStateException if used from TopicSession:

    • createBrowser
    • createQueue
    • createTemporaryQueue
    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session,
Connection.createSession(boolean, int),
TopicConnection.createTopicSession(boolean, int),
XATopicSession.getTopicSession()

    • Field Summary

      • Fields inherited from interface javax.jms.Session

        AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED

    • Method Summary

      Methods
      Modifier and Type Method and Description
      TopicSubscriber createDurableSubscriber(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      TopicSubscriber createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      TopicPublisher createPublisher(Topic topic)
      Creates a publisher for the specified topic.
      TopicSubscriber createSubscriber(Topic topic)
      Creates a nondurable subscriber to the specified topic.
      TopicSubscriber createSubscriber(Topic topic, String messageSelector, boolean noLocal)
      Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
      TemporaryTopic createTemporaryTopic()
      Creates a TemporaryTopic object.
      Topic createTopic(String topicName)
      Creates a topic identity given a Topic name.
      void unsubscribe(String name)
      Unsubscribes a durable subscription that has been created by a client.

      • Methods inherited from interface javax.jms.Session

        close, commit, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableConsumer, createDurableConsumer, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createSharedConsumer, createSharedConsumer, createSharedDurableConsumer, createSharedDurableConsumer, createStreamMessage, createTemporaryQueue, createTextMessage, createTextMessage, getAcknowledgeMode, getMessageListener, getTransacted, recover, rollback, run, setMessageListener

    • Method Detail

      • createTopic

        Topic createTopic(String topicName)
                  throws JMSException
        Creates a topic identity given a Topic name.

        This facility is provided for the rare cases where clients need to dynamically manipulate topic identity. This allows the creation of a topic identity with a provider-specific name. Clients that depend on this ability are not portable.

        Note that this method is not for creating the physical topic. The physical creation of topics is an administrative task and is not to be initiated by the JMS API. The one exception is the creation of temporary topics, which is accomplished with the createTemporaryTopic method.

        Specified by:
        createTopic in interface Session
        Parameters:
        topicName - the name of this Topic
        Returns:
        a Topic with the given name
        Throws:
        JMSException - if the session fails to create a topic due to some internal error.

      • createSubscriber

        TopicSubscriber createSubscriber(Topic topic)
                                 throws JMSException
        Creates a nondurable subscriber to the specified topic.

        A client uses a TopicSubscriber object to receive messages that have been published to a topic.

        Regular TopicSubscriber objects are not durable. They receive only messages that are published while they are active.

        In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection. The default value for this attribute is false.

        Parameters:
        topic - the Topic to subscribe to
        Throws:
        JMSException - if the session fails to create a subscriber due to some internal error.
        InvalidDestinationException - if an invalid topic is specified.

      • createSubscriber

        TopicSubscriber createSubscriber(Topic topic,
                               String messageSelector,
                               boolean noLocal)
                                 throws JMSException
        Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.

        A client uses a TopicSubscriber object to receive messages that have been published to a topic.

        Regular TopicSubscriber objects are not durable. They receive only messages that are published while they are active.

        Messages filtered out by a subscriber's message selector will never be delivered to the subscriber. From the subscriber's perspective, they do not exist.

        In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection. The default value for this attribute is false.

        Parameters:
        topic - the Topic to subscribe to
        messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
        noLocal - if set, inhibits the delivery of messages published by its own connection
        Throws:
        JMSException - if the session fails to create a subscriber due to some internal error.
        InvalidDestinationException - if an invalid topic is specified.
        InvalidSelectorException - if the message selector is invalid.

      • createDurableSubscriber

        TopicSubscriber createDurableSubscriber(Topic topic,
                                      String name)
                                        throws JMSException
        Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription. This method creates the durable subscription without a message selector and with a noLocal value of false.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with non-shared durable subscriptions. Any durable subscription created using this method will be non-shared. This means that only one active (i.e. not closed) consumer on the subscription may exist at a time. The term "consumer" here means a TopicSubscriber, MessageConsumer or JMSConsumer object in any client.

        An unshared durable subscription is identified by a name specified by the client and by the client identifier, which must be set. An application which subsequently wishes to create a consumer on that non-shared durable subscription must use the same client identifier.

        If an unshared durable subscription already exists with the same name and client identifier and the same topic and message selector, and there is no consumer already active (i.e. not closed) on the durable subscription, and no consumed messages from that subscription are still part of a pending transaction or are not yet acknowledged in the session, then this method creates a TopicSubscriber on the existing durable subscription.

        If an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active (i.e. not closed) on the durable subscription, or consumed messages from that subscription are still part of a pending transaction or are not yet acknowledged in the session, then a JMSException will be thrown.

        If an unshared durable subscription already exists with the same name and client identifier but a different topic, message selector or noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription, and no consumed messages from that subscription are still part of a pending transaction or are not yet acknowledged in the session, then the durable subscription will be deleted and a new one created.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier. If a shared durable subscription already exists with the same name and client identifier then a JMSException is thrown.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId. Such subscriptions would be completely separate.

        This method is identical to the corresponding createDurableConsumer method except that it returns a TopicSubscriber rather than a MessageConsumer to represent the consumer.

        Specified by:
        createDurableSubscriber in interface Session
        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        Throws:
        InvalidDestinationException - if an invalid topic is specified.
        JMSException -
        • if the session fails to create the non-shared durable subscription and TopicSubscriber due to some internal error
        • if the client identifier is unset
        • if an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active
        • if a shared durable subscription already exists with the same name and client identifier

      • createDurableSubscriber

        TopicSubscriber createDurableSubscriber(Topic topic,
                                      String name,
                                      String messageSelector,
                                      boolean noLocal)
                                        throws JMSException
        Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.

        A durable subscription is used by an application which needs to receive all the messages published on a topic, including the ones published when there is no active consumer associated with it. The JMS provider retains a record of this durable subscription and ensures that all messages from the topic's publishers are retained until they are delivered to, and acknowledged by, a consumer on this durable subscription or until they have expired.

        A durable subscription will continue to accumulate messages until it is deleted using the unsubscribe method.

        This method may only be used with non-shared durable subscriptions. Any durable subscription created using this method will be non-shared. This means that only one active (i.e. not closed) consumer on the subscription may exist at a time. The term "consumer" here means a TopicSubscriber, MessageConsumer or JMSConsumer object in any client.

        An unshared durable subscription is identified by a name specified by the client and by the client identifier, which must be set. An application which subsequently wishes to create a consumer on that non-shared durable subscription must use the same client identifier.

        If an unshared durable subscription already exists with the same name and client identifier and the same topic and message selector, and there is no consumer already active (i.e. not closed) on the durable subscription, and no consumed messages from that subscription are still part of a pending transaction or are not yet acknowledged in the session, then this method creates a TopicSubscriber on the existing durable subscription.

        If an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active (i.e. not closed) on the durable subscription, or consumed messages from that subscription are still part of a pending transaction or are not yet acknowledged in the session, then a JMSException will be thrown.

        If an unshared durable subscription already exists with the same name and client identifier but a different topic, message selector or noLocal value has been specified, and there is no consumer already active (i.e. not closed) on the durable subscription, and no consumed messages from that subscription are still part of a pending transaction or are not yet acknowledged in the session, then the durable subscription will be deleted and a new one created.

        A shared durable subscription and an unshared durable subscription may not have the same name and client identifier. If a shared durable subscription already exists with the same name and client identifier then a JMSException is thrown.

        If noLocal is set to true then any messages published to the topic using this session's connection, or any other connection with the same client identifier, will not be added to the durable subscription.

        There is no restriction on durable subscriptions and shared non-durable subscriptions having the same name and clientId. Such subscriptions would be completely separate.

        This method is identical to the corresponding createDurableConsumer method except that it returns a TopicSubscriber rather than a MessageConsumer to represent the consumer.

        Specified by:
        createDurableSubscriber in interface Session
        Parameters:
        topic - the non-temporary Topic to subscribe to
        name - the name used to identify this subscription
        messageSelector - only messages with properties matching the message selector expression are added to the durable subscription. A value of null or an empty string indicates that there is no message selector for the durable subscription.
        noLocal - if true then any messages published to the topic using this session's connection, or any other connection with the same client identifier, will not be added to the durable subscription.
        Throws:
        InvalidDestinationException - if an invalid topic is specified.
        InvalidSelectorException - if the message selector is invalid.
        JMSException -
        • if the session fails to create the non-shared durable subscription and TopicSubscriber due to some internal error
        • if the client identifier is unset
        • if an unshared durable subscription already exists with the same name and client identifier, and there is a consumer already active
        • if a shared durable subscription already exists with the same name and client identifier

      • createPublisher

        TopicPublisher createPublisher(Topic topic)
                               throws JMSException
        Creates a publisher for the specified topic.

        A client uses a TopicPublisher object to publish messages on a topic. Each time a client creates a TopicPublisher on a topic, it defines a new sequence of messages that have no ordering relationship with the messages it has previously sent.

        Parameters:
        topic - the Topic to publish to, or null if this is an unidentified producer
        Throws:
        JMSException - if the session fails to create a publisher due to some internal error.
        InvalidDestinationException - if an invalid topic is specified.

      • createTemporaryTopic

        TemporaryTopic createTemporaryTopic()
                                    throws JMSException
        Creates a TemporaryTopic object. Its lifetime will be that of the TopicConnection unless it is deleted earlier.
        Specified by:
        createTemporaryTopic in interface Session
        Returns:
        a temporary topic identity
        Throws:
        JMSException - if the session fails to create a temporary topic due to some internal error.

      • unsubscribe

        void unsubscribe(String name)
                 throws JMSException
        Unsubscribes a durable subscription that has been created by a client.

        This method deletes the state being maintained on behalf of the subscriber by its provider.

        It is erroneous for a client to delete a durable subscription while there is an active TopicSubscriber for the subscription, or while a consumed message is part of a pending transaction or has not been acknowledged in the session.

        Specified by:
        unsubscribe in interface Session
        Parameters:
        name - the name used to identify this subscription
        Throws:
        JMSException - if the session fails to unsubscribe to the durable subscription due to some internal error.
        InvalidDestinationException - if an invalid subscription name is specified.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TopicSubscriber (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface TopicSubscriber

  • All Superinterfaces:
    AutoCloseable, MessageConsumer

    public interface TopicSubscriber
extends MessageConsumer
    A client uses a TopicSubscriber object to receive messages that have been published to a topic. A TopicSubscriber object is the publish/subscribe form of a message consumer. A MessageConsumer can be created by using Session.createConsumer.

    A TopicSession allows the creation of multiple TopicSubscriber objects per topic. It will deliver each message for a topic to each subscriber eligible to receive it. Each copy of the message is treated as a completely separate message. Work done on one copy has no effect on the others; acknowledging one does not acknowledge the others; one message may be delivered immediately, while another waits for its subscriber to process messages ahead of it.

    Regular TopicSubscriber objects are not durable. They receive only messages that are published while they are active.

    Messages filtered out by a subscriber's message selector will never be delivered to the subscriber. From the subscriber's perspective, they do not exist.

    In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection.

    If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

    Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name that uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription.

    A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscription is equivalent to unsubscribing (deleting) the old one and creating a new one.

    The unsubscribe method is used to delete a durable subscription. The unsubscribe method can be used at the Session or TopicSession level. This method deletes the state being maintained on behalf of the subscriber by its provider.

    Creating a MessageConsumer provides the same features as creating a TopicSubscriber. To create a durable subscriber, use of Session.CreateDurableSubscriber is recommended. The TopicSubscriber is provided to support existing code.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session.createConsumer(javax.jms.Destination), Session.createDurableSubscriber(javax.jms.Topic, java.lang.String), TopicSession, TopicSession.createSubscriber(javax.jms.Topic), MessageConsumer

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean getNoLocal()
      Gets the NoLocal attribute for this subscriber.
      Topic getTopic()
      Gets the Topic associated with this subscriber.

      • Methods inherited from interface javax.jms.MessageConsumer

        close, getMessageListener, getMessageSelector, receive, receive, receiveNoWait, setMessageListener

    • Method Detail

      • getTopic

        Topic getTopic()
               throws JMSException
        Gets the Topic associated with this subscriber.
        Returns:
        this subscriber's Topic
        Throws:
        JMSException - if the JMS provider fails to get the topic for this topic subscriber due to some internal error.

      • getNoLocal

        boolean getNoLocal()
                   throws JMSException
        Gets the NoLocal attribute for this subscriber. The default value for this attribute is false.
        Returns:
        true if locally published messages are being inhibited
        Throws:
        JMSException - if the JMS provider fails to get the NoLocal attribute for this topic subscriber due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionInProgressException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class TransactionInProgressException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.TransactionInProgressException
  • All Implemented Interfaces:
    Serializable

    public class TransactionInProgressException
extends JMSException

    This exception is thrown when an operation is invalid because a transaction is in progress. For instance, an attempt to call Session.commit when a session is part of a distributed transaction should throw a TransactionInProgressException.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionInProgressException(String reason)
      Constructs a TransactionInProgressException with the specified reason.
      TransactionInProgressException(String reason, String errorCode)
      Constructs a TransactionInProgressException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionInProgressException

        public TransactionInProgressException(String reason,
                              String errorCode)
        Constructs a TransactionInProgressException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • TransactionInProgressException

        public TransactionInProgressException(String reason)
        Constructs a TransactionInProgressException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionInProgressRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class TransactionInProgressRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.TransactionInProgressRuntimeException
  • All Implemented Interfaces:
    Serializable

    public class TransactionInProgressRuntimeException
extends JMSRuntimeException

    This unchecked exception is thrown when an operation is invalid because a transaction is in progress. For instance, an attempt to call JMSContext.commit when the context is part of a distributed transaction should throw a TransactionInProgressRuntimeException.

    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionInProgressRuntimeException(String detailMessage)
      Constructs a TransactionInProgressRuntimeException with the specified detail message
      TransactionInProgressRuntimeException(String detailMessage, String errorCode)
      Constructs a TransactionInProgressRuntimeException with the specified detail message and error code.
      TransactionInProgressRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a TransactionInProgressRuntimeException with the specified detail message, error code and cause

    • Method Summary

      • Methods inherited from class javax.jms.JMSRuntimeException

        getErrorCode

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionInProgressRuntimeException

        public TransactionInProgressRuntimeException(String detailMessage)
        Constructs a TransactionInProgressRuntimeException with the specified detail message
        Parameters:
        detailMessage - a description of the exception

      • TransactionInProgressRuntimeException

        public TransactionInProgressRuntimeException(String detailMessage,
                                     String errorCode)
        Constructs a TransactionInProgressRuntimeException with the specified detail message and error code.
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code

      • TransactionInProgressRuntimeException

        public TransactionInProgressRuntimeException(String detailMessage,
                                     String errorCode,
                                     Throwable cause)
        Constructs a TransactionInProgressRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionRolledBackException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class TransactionRolledBackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.TransactionRolledBackException
  • All Implemented Interfaces:
    Serializable

    public class TransactionRolledBackException
extends JMSException

    This exception must be thrown when a call to Session.commit results in a rollback of the current transaction.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionRolledBackException(String reason)
      Constructs a TransactionRolledBackException with the specified reason.
      TransactionRolledBackException(String reason, String errorCode)
      Constructs a TransactionRolledBackException with the specified reason and error code.

    • Method Summary

      • Methods inherited from class javax.jms.JMSException

        getErrorCode, getLinkedException, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionRolledBackException

        public TransactionRolledBackException(String reason,
                              String errorCode)
        Constructs a TransactionRolledBackException with the specified reason and error code.
        Parameters:
        reason - a description of the exception
        errorCode - a string specifying the vendor-specific error code

      • TransactionRolledBackException

        public TransactionRolledBackException(String reason)
        Constructs a TransactionRolledBackException with the specified reason. The error code defaults to null.
        Parameters:
        reason - a description of the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionRolledBackRuntimeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Class TransactionRolledBackRuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.jms.JMSRuntimeException
            • javax.jms.TransactionRolledBackRuntimeException
  • All Implemented Interfaces:
    Serializable

    public class TransactionRolledBackRuntimeException
extends JMSRuntimeException
    This unchecked exception must be thrown when a call to JMSContext.commit results in a rollback of the current transaction.
    Since:
    JMS 2.0
    Version:
    JMS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionRolledBackRuntimeException(String detailMessage)
      Constructs a TransactionRolledBackRuntimeException with the specified detail message
      TransactionRolledBackRuntimeException(String detailMessage, String errorCode)
      Constructs a TransactionRolledBackRuntimeException with the specified detail message and error code.
      TransactionRolledBackRuntimeException(String detailMessage, String errorCode, Throwable cause)
      Constructs a TransactionRolledBackRuntimeException with the specified detail message, error code and cause

    • Method Summary

      • Methods inherited from class javax.jms.JMSRuntimeException

        getErrorCode

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionRolledBackRuntimeException

        public TransactionRolledBackRuntimeException(String detailMessage)
        Constructs a TransactionRolledBackRuntimeException with the specified detail message
        Parameters:
        detailMessage - a description of the exception

      • TransactionRolledBackRuntimeException

        public TransactionRolledBackRuntimeException(String detailMessage,
                                     String errorCode)
        Constructs a TransactionRolledBackRuntimeException with the specified detail message and error code.
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code

      • TransactionRolledBackRuntimeException

        public TransactionRolledBackRuntimeException(String detailMessage,
                                     String errorCode,
                                     Throwable cause)
        Constructs a TransactionRolledBackRuntimeException with the specified detail message, error code and cause
        Parameters:
        detailMessage - a description of the exception
        errorCode - a provider-specific error code
        cause - the underlying cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.jms (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.jms

  • Packages that use javax.jms
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.
  • Classes in javax.jms used by javax.jms
    Class and Description
    BytesMessage
    A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.
    CompletionListener
    A CompletionListener is implemented by the application and may be specified when a message is sent asynchronously.
    Connection
    A Connection object is a client's active connection to its JMS provider.
    ConnectionConsumer
    For application servers, Connection objects provide a special facility for creating a ConnectionConsumer (optional).
    ConnectionFactory
    A ConnectionFactory object encapsulates a set of connection configuration parameters that has been defined by an administrator.
    ConnectionMetaData
    A ConnectionMetaData object provides information describing the Connection object.
    Destination
    A Destination object encapsulates a provider-specific address.
    ExceptionListener
    If a JMS provider detects a serious problem with a Connection object, it informs the Connection object's ExceptionListener, if one has been registered.
    JMSConsumer
    A client using the simplified JMS API introduced for JMS 2.0 uses a JMSConsumer object to receive messages from a queue or topic.
    JMSContext
    A JMSContext is the main interface in the simplified JMS API introduced for JMS 2.0.
    JMSException
    This is the root class of all checked exceptions in the JMS API.
    JMSProducer
    A JMSProducer is a simple object used to send messages on behalf of a JMSContext.
    JMSRuntimeException
    This is the root class of all unchecked exceptions in the JMS API.
    MapMessage
    A MapMessage object is used to send a set of name-value pairs.
    Message
    The Message interface is the root interface of all JMS messages.
    MessageConsumer
    A client uses a MessageConsumer object to receive messages from a destination.
    MessageListener
    A MessageListener object is used to receive asynchronously delivered messages.
    MessageProducer
    A client uses a MessageProducer object to send messages to a destination.
    ObjectMessage
    An ObjectMessage object is used to send a message that contains a serializable object in the Java programming language ("Java object").
    Queue
    A Queue object encapsulates a provider-specific queue name.
    QueueBrowser
    A client uses a QueueBrowser object to look at messages on a queue without removing them.
    QueueConnection
    A QueueConnection object is an active connection to a point-to-point JMS provider.
    QueueConnectionFactory
    A client uses a QueueConnectionFactory object to create QueueConnection objects with a point-to-point JMS provider.
    QueueReceiver
    A client uses a QueueReceiver object to receive messages that have been delivered to a queue.
    QueueSender
    A client uses a QueueSender object to send messages to a queue.
    QueueSession
    A QueueSession object provides methods for creating QueueReceiver, QueueSender, QueueBrowser, and TemporaryQueue objects.
    ServerSession
    A ServerSession object is an application server object that is used by a server to associate a thread with a JMS session (optional).
    ServerSessionPool
    A ServerSessionPool object is an object implemented by an application server to provide a pool of ServerSession objects for processing the messages of a ConnectionConsumer (optional).
    Session
    A Session object is a single-threaded context for producing and consuming messages.
    StreamMessage
    A StreamMessage object is used to send a stream of primitive types in the Java programming language.
    TemporaryQueue
    A TemporaryQueue object is a unique Queue object created for the duration of a Connection.
    TemporaryTopic
    A TemporaryTopic object is a unique Topic object created for the duration of a Connection.
    TextMessage
    A TextMessage object is used to send a message containing a java.lang.String.
    Topic
    A Topic object encapsulates a provider-specific topic name.
    TopicConnection
    A TopicConnection object is an active connection to a publish/subscribe JMS provider.
    TopicConnectionFactory
    A client uses a TopicConnectionFactory object to create TopicConnection objects with a publish/subscribe JMS provider.
    TopicPublisher
    A client uses a TopicPublisher object to publish messages on a topic.
    TopicSession
    A TopicSession object provides methods for creating TopicPublisher, TopicSubscriber, and TemporaryTopic objects.
    TopicSubscriber
    A client uses a TopicSubscriber object to receive messages that have been published to a topic.
    XAConnection
    The XAConnection interface extends the capability of Connection by providing an XASession (optional).
    XAConnectionFactory
    The XAConnectionFactory interface is a base interface for the XAQueueConnectionFactory and XATopicConnectionFactory interfaces.
    XAJMSContext
    The XAJMSContext interface extends the capability of JMSContext by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional).
    XAQueueConnection
    An XAQueueConnection provides the same create options as QueueConnection (optional).
    XAQueueSession
    An XAQueueSession provides a regular QueueSession, which can be used to create QueueReceiver, QueueSender, and QueueBrowser objects (optional).
    XASession
    The XASession interface extends the capability of Session by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional).
    XATopicConnection
    An XATopicConnection provides the same create options as TopicConnection (optional).
    XATopicSession
    An XATopicSession provides a regular TopicSession.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


XAConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface XAConnection

  • All Superinterfaces:
    AutoCloseable, Connection
    All Known Subinterfaces:
    XAQueueConnection, XATopicConnection

    public interface XAConnection
extends Connection
    The XAConnection interface extends the capability of Connection by providing an XASession (optional).

    The XAConnection interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    XAQueueConnection, XATopicConnection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Session createSession(boolean transacted, int acknowledgeMode)
      Creates an Session object.
      XASession createXASession()
      Creates an XASession object.

      • Methods inherited from interface javax.jms.Connection

        close, createConnectionConsumer, createDurableConnectionConsumer, createSession, createSession, createSharedConnectionConsumer, createSharedDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

    • Method Detail

      • createXASession

        XASession createXASession()
                          throws JMSException
        Creates an XASession object.
        Returns:
        a newly created XASession
        Throws:
        JMSException - if the XAConnection object fails to create an XASession due to some internal error.
        Since:
        JMS 1.1

      • createSession

        Session createSession(boolean transacted,
                    int acknowledgeMode)
                      throws JMSException
        Creates an Session object.
        Specified by:
        createSession in interface Connection
        Parameters:
        transacted - usage undefined
        acknowledgeMode - usage undefined
        Returns:
        a newly created Session
        Throws:
        JMSException - if the XAConnection object fails to create a Session due to some internal error.
        Since:
        JMS 1.1
        See Also:
        Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE, Connection.createSession(int), Connection.createSession()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XAConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface XAConnectionFactory

  • All Known Subinterfaces:
    XAQueueConnectionFactory, XATopicConnectionFactory

    public interface XAConnectionFactory
    The XAConnectionFactory interface is a base interface for the XAQueueConnectionFactory and XATopicConnectionFactory interfaces.

    Some application servers provide support for grouping JTA capable resource use into a distributed transaction (optional). To include JMS API transactions in a JTA transaction, an application server requires a JTA aware JMS provider. A JMS provider exposes its JTA support using an XAConnectionFactory object, which an application server uses to create XAConnection objects.

    XAConnectionFactory objects are JMS administered objects, just like ConnectionFactory objects. It is expected that application servers will find them using the Java Naming and Directory Interface (JNDI) API.

    The XAConnectionFactory interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

    Since:
    JMS 1.0
    Version:
    JMS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      XAConnection createXAConnection()
      Creates an XAConnection with the default user identity.
      XAConnection createXAConnection(String userName, String password)
      Creates an XAConnection with the specified user identity.
      XAJMSContext createXAContext()
      Creates a XAJMSContext with the default user identity
      XAJMSContext createXAContext(String userName, String password)
      Creates a JMSContext with the specified user identity

    • Method Detail

      • createXAConnection

        XAConnection createXAConnection()
                                throws JMSException
        Creates an XAConnection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Returns:
        a newly created XAConnection
        Throws:
        JMSException - if the JMS provider fails to create an XA connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.
        Since:
        JMS 1.1

      • createXAConnection

        XAConnection createXAConnection(String userName,
                              String password)
                                throws JMSException
        Creates an XAConnection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Parameters:
        userName - the caller's user name
        password - the caller's password
        Returns:
        a newly created XAConnection
        Throws:
        JMSException - if the JMS provider fails to create an XA connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.
        Since:
        JMS 1.1

      • createXAContext

        XAJMSContext createXAContext()
        Creates a XAJMSContext with the default user identity

        A connection and session are created for use by the new XAJMSContext. The connection is created in stopped mode but will be automatically started when a JMSConsumer is created.

        Returns:
        a newly created XAJMSContext
        Throws:
        JMSRuntimeException - if the JMS provider fails to create the XAJMSContext due to some internal error.
        JMSSecurityRuntimeException - if client authentication fails due to an invalid user name or password.
        Since:
        JMS 2.0

      • createXAContext

        XAJMSContext createXAContext(String userName,
                           String password)
        Creates a JMSContext with the specified user identity

        A connection and session are created for use by the new XAJMSContext. The connection is created in stopped mode but will be automatically started when a JMSConsumer is created.

        Parameters:
        userName - the caller's user name
        password - the caller's password
        Returns:
        a newly created JMSContext
        Throws:
        JMSRuntimeException - if the JMS provider fails to create the JMSContext due to some internal error.
        JMSSecurityRuntimeException - if client authentication fails due to an invalid user name or password.
        Since:
        JMS 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XAJMSContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface XAJMSContext

  • All Superinterfaces:
    AutoCloseable, JMSContext

    public interface XAJMSContext
extends JMSContext
    The XAJMSContext interface extends the capability of JMSContext by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional). This support takes the form of a javax.transaction.xa.XAResource object. The functionality of this object closely resembles that defined by the standard X/Open XA Resource interface.

    An application server controls the transactional assignment of an XASession by obtaining its XAResource. It uses the XAResource to assign the session to a transaction, prepare and commit work on the transaction, and so on.

    An XAResource provides some fairly sophisticated facilities for interleaving work on multiple transactions, recovering a list of transactions in progress, and so on. A JTA aware JMS provider must fully implement this functionality. This could be done by using the services of a database that supports XA, or a JMS provider may choose to implement this functionality from scratch.

    A client of the application server is given what it thinks is an ordinary JMSContext. Behind the scenes, the application server controls the transaction management of the underlying XAJMSContext.

    The XAJMSContext interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

    Since:
    JMS 2.0
    Version:
    JMS 2.0

    • Field Summary

      • Fields inherited from interface javax.jms.JMSContext

        AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void commit()
      Throws a TransactionInProgressRuntimeException, since it should not be called for an XAJMSContext object.
      JMSContext getContext()
      Returns the JMSContext object associated with this XAJMSContext.
      boolean getTransacted()
      Returns whether the session is in transacted mode; this method always returns true.
      XAResource getXAResource()
      Returns an XAResource to the caller.
      void rollback()
      Throws a TransactionInProgressRuntimeException, since it should not be called for an XAJMSContext object.

      • Methods inherited from interface javax.jms.JMSContext

        acknowledge, close, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createContext, createDurableConsumer, createDurableConsumer, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createSharedConsumer, createSharedConsumer, createSharedDurableConsumer, createSharedDurableConsumer, createStreamMessage, createTemporaryQueue, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAutoStart, getClientID, getExceptionListener, getMetaData, getSessionMode, recover, setAutoStart, setClientID, setExceptionListener, start, stop, unsubscribe

    • Method Detail

      • getContext

        JMSContext getContext()
        Returns the JMSContext object associated with this XAJMSContext.
        Returns:
        the JMSContext object associated with this XAJMSContext

      • getXAResource

        XAResource getXAResource()
        Returns an XAResource to the caller.
        Returns:
        an XAResource

      • getTransacted

        boolean getTransacted()
        Returns whether the session is in transacted mode; this method always returns true.
        Specified by:
        getTransacted in interface JMSContext
        Returns:
        true

      • commit

        void commit()
        Throws a TransactionInProgressRuntimeException, since it should not be called for an XAJMSContext object.
        Specified by:
        commit in interface JMSContext
        Throws:
        TransactionInProgressRuntimeException - if the method is called on an XAJMSContext.

      • rollback

        void rollback()
        Throws a TransactionInProgressRuntimeException, since it should not be called for an XAJMSContext object.
        Specified by:
        rollback in interface JMSContext
        Throws:
        TransactionInProgressRuntimeException - if the method is called on an XAJMSContext.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XAQueueConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface XAQueueConnection

  • All Superinterfaces:
    AutoCloseable, Connection, QueueConnection, XAConnection

    public interface XAQueueConnection
extends XAConnection, QueueConnection
    An XAQueueConnection provides the same create options as QueueConnection (optional). The only difference is that an XAConnection is by definition transacted.

    The XAQueueConnection interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    XAConnection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      QueueSession createQueueSession(boolean transacted, int acknowledgeMode)
      Creates a QueueSession object.
      XAQueueSession createXAQueueSession()
      Creates an XAQueueSession object.

      • Methods inherited from interface javax.jms.XAConnection

        createSession, createXASession

      • Methods inherited from interface javax.jms.QueueConnection

        createConnectionConsumer

      • Methods inherited from interface javax.jms.Connection

        close, createConnectionConsumer, createDurableConnectionConsumer, createSession, createSession, createSharedConnectionConsumer, createSharedDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

    • Method Detail

      • createXAQueueSession

        XAQueueSession createXAQueueSession()
                                    throws JMSException
        Creates an XAQueueSession object.
        Returns:
        a newly created XAQueueSession
        Throws:
        JMSException - if the XAQueueConnection object fails to create an XAQueueSession due to some internal error.

      • createQueueSession

        QueueSession createQueueSession(boolean transacted,
                              int acknowledgeMode)
                                throws JMSException
        Creates a QueueSession object.
        Specified by:
        createQueueSession in interface QueueConnection
        Parameters:
        transacted - usage undefined
        acknowledgeMode - usage undefined
        Returns:
        a newly created QueueSession
        Throws:
        JMSException - if the XAQueueConnection object fails to create a QueueSession due to some internal error.
        See Also:
        Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XAQueueConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface XAQueueConnectionFactory

  • All Superinterfaces:
    ConnectionFactory, QueueConnectionFactory, XAConnectionFactory

    public interface XAQueueConnectionFactory
extends XAConnectionFactory, QueueConnectionFactory
    An XAQueueConnectionFactory provides the same create options as a QueueConnectionFactory (optional).

    The XATopicConnectionFactory interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    QueueConnectionFactory, XAConnectionFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      XAQueueConnection createXAQueueConnection()
      Creates an XA queue connection with the default user identity.
      XAQueueConnection createXAQueueConnection(String userName, String password)
      Creates an XA queue connection with the specified user identity.

      • Methods inherited from interface javax.jms.XAConnectionFactory

        createXAConnection, createXAConnection, createXAContext, createXAContext

      • Methods inherited from interface javax.jms.QueueConnectionFactory

        createQueueConnection, createQueueConnection

      • Methods inherited from interface javax.jms.ConnectionFactory

        createConnection, createConnection, createContext, createContext, createContext, createContext

    • Method Detail

      • createXAQueueConnection

        XAQueueConnection createXAQueueConnection()
                                          throws JMSException
        Creates an XA queue connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Returns:
        a newly created XA queue connection
        Throws:
        JMSException - if the JMS provider fails to create an XA queue connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.

      • createXAQueueConnection

        XAQueueConnection createXAQueueConnection(String userName,
                                        String password)
                                          throws JMSException
        Creates an XA queue connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Parameters:
        userName - the caller's user name
        password - the caller's password
        Returns:
        a newly created XA queue connection
        Throws:
        JMSException - if the JMS provider fails to create an XA queue connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XAQueueSession (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface XAQueueSession

  • All Superinterfaces:
    AutoCloseable, Runnable, Session, XASession

    public interface XAQueueSession
extends XASession
    An XAQueueSession provides a regular QueueSession, which can be used to create QueueReceiver, QueueSender, and QueueBrowser objects (optional).

    The XAQueueSession interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    XASession

    • Field Summary

      • Fields inherited from interface javax.jms.Session

        AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED

    • Method Summary

      Methods
      Modifier and Type Method and Description
      QueueSession getQueueSession()
      Gets the queue session associated with this XAQueueSession.

      • Methods inherited from interface javax.jms.XASession

        commit, getSession, getTransacted, getXAResource, rollback

      • Methods inherited from interface javax.jms.Session

        close, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableConsumer, createDurableConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createSharedConsumer, createSharedConsumer, createSharedDurableConsumer, createSharedDurableConsumer, createStreamMessage, createTemporaryQueue, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, recover, run, setMessageListener, unsubscribe

    • Method Detail

      • getQueueSession

        QueueSession getQueueSession()
                             throws JMSException
        Gets the queue session associated with this XAQueueSession.
        Returns:
        the queue session object
        Throws:
        JMSException - if an internal error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XASession (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface XASession

  • All Superinterfaces:
    AutoCloseable, Runnable, Session
    All Known Subinterfaces:
    XAQueueSession, XATopicSession

    public interface XASession
extends Session
    The XASession interface extends the capability of Session by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional). This support takes the form of a javax.transaction.xa.XAResource object. The functionality of this object closely resembles that defined by the standard X/Open XA Resource interface.

    An application server controls the transactional assignment of an XASession by obtaining its XAResource. It uses the XAResource to assign the session to a transaction, prepare and commit work on the transaction, and so on.

    An XAResource provides some fairly sophisticated facilities for interleaving work on multiple transactions, recovering a list of transactions in progress, and so on. A JTA aware JMS provider must fully implement this functionality. This could be done by using the services of a database that supports XA, or a JMS provider may choose to implement this functionality from scratch.

    A client of the application server is given what it thinks is a regular JMS Session. Behind the scenes, the application server controls the transaction management of the underlying XASession.

    The XASession interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    Session

    • Field Summary

      • Fields inherited from interface javax.jms.Session

        AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void commit()
      Throws a TransactionInProgressException, since it should not be called for an XASession object.
      Session getSession()
      Gets the session associated with this XASession.
      boolean getTransacted()
      Indicates whether the session is in transacted mode.
      XAResource getXAResource()
      Returns an XA resource to the caller.
      void rollback()
      Throws a TransactionInProgressException, since it should not be called for an XASession object.

      • Methods inherited from interface javax.jms.Session

        close, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableConsumer, createDurableConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createSharedConsumer, createSharedConsumer, createSharedDurableConsumer, createSharedDurableConsumer, createStreamMessage, createTemporaryQueue, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, recover, run, setMessageListener, unsubscribe

    • Method Detail

      • getSession

        Session getSession()
                   throws JMSException
        Gets the session associated with this XASession.
        Returns:
        the session object
        Throws:
        JMSException - if an internal error occurs.
        Since:
        JMS 1.1

      • getXAResource

        XAResource getXAResource()
        Returns an XA resource to the caller.
        Returns:
        an XA resource to the caller

      • getTransacted

        boolean getTransacted()
                      throws JMSException
        Indicates whether the session is in transacted mode.
        Specified by:
        getTransacted in interface Session
        Returns:
        true
        Throws:
        JMSException - if the JMS provider fails to return the transaction mode due to some internal error.

      • commit

        void commit()
            throws JMSException
        Throws a TransactionInProgressException, since it should not be called for an XASession object.
        Specified by:
        commit in interface Session
        Throws:
        TransactionInProgressException - if the method is called on an XASession.
        IllegalStateException -
        • the session is not using a local transaction
        • this method has been called by a CompletionListener callback method on its own Session
        JMSException - if the JMS provider fails to commit the transaction due to some internal error.
        TransactionRolledBackException - if the transaction is rolled back due to some internal error during commit.

      • rollback

        void rollback()
              throws JMSException
        Throws a TransactionInProgressException, since it should not be called for an XASession object.
        Specified by:
        rollback in interface Session
        Throws:
        TransactionInProgressException - if the method is called on an XASession.
        IllegalStateException -
        • the session is not using a local transaction
        • this method has been called by a CompletionListener callback method on its own Session
        JMSException - if the JMS provider fails to roll back the transaction due to some internal error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XATopicConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface XATopicConnection

  • All Superinterfaces:
    AutoCloseable, Connection, TopicConnection, XAConnection

    public interface XATopicConnection
extends XAConnection, TopicConnection
    An XATopicConnection provides the same create options as TopicConnection (optional). The Topic connections created are transactional.

    The XATopicConnection interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    XAConnection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      TopicSession createTopicSession(boolean transacted, int acknowledgeMode)
      Creates a TopicSession object.
      XATopicSession createXATopicSession()
      Creates an XATopicSession object.

      • Methods inherited from interface javax.jms.XAConnection

        createSession, createXASession

      • Methods inherited from interface javax.jms.TopicConnection

        createConnectionConsumer, createDurableConnectionConsumer

      • Methods inherited from interface javax.jms.Connection

        close, createConnectionConsumer, createSession, createSession, createSharedConnectionConsumer, createSharedDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

    • Method Detail

      • createXATopicSession

        XATopicSession createXATopicSession()
                                    throws JMSException
        Creates an XATopicSession object.
        Returns:
        a newly created XATopicSession
        Throws:
        JMSException - if the XATopicConnection object fails to create an XATopicSession due to some internal error.

      • createTopicSession

        TopicSession createTopicSession(boolean transacted,
                              int acknowledgeMode)
                                throws JMSException
        Creates a TopicSession object.
        Specified by:
        createTopicSession in interface TopicConnection
        Parameters:
        transacted - usage undefined
        acknowledgeMode - usage undefined
        Returns:
        a newly created TopicSession
        Throws:
        JMSException - if the XATopicConnection object fails to create a TopicSession due to some internal error.
        See Also:
        Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XATopicConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface XATopicConnectionFactory

  • All Superinterfaces:
    ConnectionFactory, TopicConnectionFactory, XAConnectionFactory

    public interface XATopicConnectionFactory
extends XAConnectionFactory, TopicConnectionFactory
    An XATopicConnectionFactory provides the same create options as a TopicConnectionFactory (optional).

    The XATopicConnectionFactory interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    TopicConnectionFactory, XAConnectionFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      XATopicConnection createXATopicConnection()
      Creates an XA topic connection with the default user identity.
      XATopicConnection createXATopicConnection(String userName, String password)
      Creates an XA topic connection with the specified user identity.

      • Methods inherited from interface javax.jms.XAConnectionFactory

        createXAConnection, createXAConnection, createXAContext, createXAContext

      • Methods inherited from interface javax.jms.TopicConnectionFactory

        createTopicConnection, createTopicConnection

      • Methods inherited from interface javax.jms.ConnectionFactory

        createConnection, createConnection, createContext, createContext, createContext, createContext

    • Method Detail

      • createXATopicConnection

        XATopicConnection createXATopicConnection()
                                          throws JMSException
        Creates an XA topic connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Returns:
        a newly created XA topic connection
        Throws:
        JMSException - if the JMS provider fails to create an XA topic connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.

      • createXATopicConnection

        XATopicConnection createXATopicConnection(String userName,
                                        String password)
                                          throws JMSException
        Creates an XA topic connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.
        Parameters:
        userName - the caller's user name
        password - the caller's password
        Returns:
        a newly created XA topic connection
        Throws:
        JMSException - if the JMS provider fails to create an XA topic connection due to some internal error.
        JMSSecurityException - if client authentication fails due to an invalid user name or password.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XATopicSession (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jms

Interface XATopicSession

  • All Superinterfaces:
    AutoCloseable, Runnable, Session, XASession

    public interface XATopicSession
extends XASession
    An XATopicSession provides a regular TopicSession. which can be used to create TopicSubscriber and TopicPublisher objects (optional).

    The XATopicSession interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than using these XA interfaces directly.

    Since:
    JMS 1.0
    Version:
    JMS 2.0
    See Also:
    XASession, TopicSession

    • Field Summary

      • Fields inherited from interface javax.jms.Session

        AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED

    • Method Summary

      Methods
      Modifier and Type Method and Description
      TopicSession getTopicSession()
      Gets the topic session associated with this XATopicSession.

      • Methods inherited from interface javax.jms.XASession

        commit, getSession, getTransacted, getXAResource, rollback

      • Methods inherited from interface javax.jms.Session

        close, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableConsumer, createDurableConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createSharedConsumer, createSharedConsumer, createSharedDurableConsumer, createSharedDurableConsumer, createStreamMessage, createTemporaryQueue, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, recover, run, setMessageListener, unsubscribe

    • Method Detail

      • getTopicSession

        TopicSession getTopicSession()
                             throws JMSException
        Gets the topic session associated with this XATopicSession.
        Returns:
        the topic session object
        Throws:
        JMSException - if an internal error occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.jms.IllegalStateException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.IllegalStateException

No usage of javax.jms.IllegalStateException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.IllegalStateRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.IllegalStateRuntimeException

No usage of javax.jms.IllegalStateRuntimeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.InvalidClientIDException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.InvalidClientIDException

No usage of javax.jms.InvalidClientIDException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.InvalidClientIDRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.InvalidClientIDRuntimeException

No usage of javax.jms.InvalidClientIDRuntimeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.InvalidDestinationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.InvalidDestinationException

No usage of javax.jms.InvalidDestinationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.InvalidDestinationRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.InvalidDestinationRuntimeException

No usage of javax.jms.InvalidDestinationRuntimeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.InvalidSelectorException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.InvalidSelectorException

No usage of javax.jms.InvalidSelectorException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.InvalidSelectorRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.InvalidSelectorRuntimeException

No usage of javax.jms.InvalidSelectorRuntimeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSConnectionFactory

No usage of javax.jms.JMSConnectionFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSConnectionFactoryDefinition (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSConnectionFactoryDefinition

No usage of javax.jms.JMSConnectionFactoryDefinition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSConnectionFactoryDefinitions (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSConnectionFactoryDefinitions

No usage of javax.jms.JMSConnectionFactoryDefinitions
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSDestinationDefinition (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSDestinationDefinition

No usage of javax.jms.JMSDestinationDefinition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSDestinationDefinitions (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSDestinationDefinitions

No usage of javax.jms.JMSDestinationDefinitions
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSException

  • Packages that use JMSException
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of JMSException in javax.jms

      Subclasses of JMSException in javax.jms
      Modifier and Type Class and Description
      class  IllegalStateException
      This exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation.
      class  InvalidClientIDException
      This exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider.
      class  InvalidDestinationException
      This exception must be thrown when a destination either is not understood by a provider or is no longer valid.
      class  InvalidSelectorException
      This exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax.
      class  JMSSecurityException
      This exception must be thrown when a provider rejects a user name/password submitted by a client.
      class  MessageEOFException
      This exception must be thrown when an unexpected end of stream has been reached when a StreamMessage or BytesMessage is being read.
      class  MessageFormatException
      This exception must be thrown when a JMS client attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type.
      class  MessageNotReadableException
      This exception must be thrown when a JMS client attempts to read a write-only message.
      class  MessageNotWriteableException
      This exception must be thrown when a JMS client attempts to write to a read-only message.
      class  ResourceAllocationException
      This exception is thrown when a provider is unable to allocate the resources required by a method.
      class  TransactionInProgressException
      This exception is thrown when an operation is invalid because a transaction is in progress.
      class  TransactionRolledBackException
      This exception must be thrown when a call to Session.commit results in a rollback of the current transaction.
      Methods in javax.jms with parameters of type JMSException
      Modifier and Type Method and Description
      void ExceptionListener.onException(JMSException exception)
      Notifies user of a JMS exception.
      Methods in javax.jms that throw JMSException
      Modifier and Type Method and Description
      void Message.acknowledge()
      Acknowledges all consumed messages of the session of this consumed message.
      void Message.clearBody()
      Clears out the message body.
      void Message.clearProperties()
      Clears a message's properties.
      void TopicRequestor.close()
      Closes the TopicRequestor and its session.
      void Session.close()
      Closes the session.
      void QueueRequestor.close()
      Closes the QueueRequestor and its session.
      void QueueBrowser.close()
      Closes the QueueBrowser.
      void MessageProducer.close()
      Closes the message producer.
      void MessageConsumer.close()
      Closes the message consumer.
      void ConnectionConsumer.close()
      Closes the connection consumer.
      void Connection.close()
      Closes the connection.
      void XASession.commit()
      Throws a TransactionInProgressException, since it should not be called for an XASession object.
      void Session.commit()
      Commits all messages done in this transaction and releases any locks currently held.
      QueueBrowser Session.createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser QueueSession.createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser Session.createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
      QueueBrowser QueueSession.createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
      BytesMessage Session.createBytesMessage()
      Creates a BytesMessage object.
      Connection ConnectionFactory.createConnection()
      Creates a connection with the default user identity.
      Connection ConnectionFactory.createConnection(String userName, String password)
      Creates a connection with the specified user identity.
      ConnectionConsumer Connection.createConnectionConsumer(Destination destination, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific destination.
      ConnectionConsumer QueueConnection.createConnectionConsumer(Queue queue, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation).
      ConnectionConsumer TopicConnection.createConnectionConsumer(Topic topic, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation).
      MessageConsumer Session.createConsumer(Destination destination)
      Creates a MessageConsumer for the specified destination.
      MessageConsumer Session.createConsumer(Destination destination, String messageSelector)
      Creates a MessageConsumer for the specified destination, using a message selector.
      MessageConsumer Session.createConsumer(Destination destination, String messageSelector, boolean noLocal)
      Creates a MessageConsumer for the specified destination, specifying a message selector and the noLocal parameter.
      ConnectionConsumer TopicConnection.createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Create a durable connection consumer for this connection (optional operation).
      ConnectionConsumer Connection.createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using an unshared durable subscription with the specified name.
      MessageConsumer Session.createDurableConsumer(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      MessageConsumer Session.createDurableConsumer(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      TopicSubscriber TopicSession.createDurableSubscriber(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      TopicSubscriber Session.createDurableSubscriber(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      TopicSubscriber TopicSession.createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      TopicSubscriber Session.createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      MapMessage Session.createMapMessage()
      Creates a MapMessage object.
      Message Session.createMessage()
      Creates a Message object.
      ObjectMessage Session.createObjectMessage()
      Creates an ObjectMessage object.
      ObjectMessage Session.createObjectMessage(Serializable object)
      Creates an initialized ObjectMessage object.
      MessageProducer Session.createProducer(Destination destination)
      Creates a MessageProducer to send messages to the specified destination.
      TopicPublisher TopicSession.createPublisher(Topic topic)
      Creates a publisher for the specified topic.
      Queue Session.createQueue(String queueName)
      Creates a Queue object which encapsulates a specified provider-specific queue name.
      Queue QueueSession.createQueue(String queueName)
      Creates a queue identity given a Queue name.
      QueueConnection QueueConnectionFactory.createQueueConnection()
      Creates a queue connection with the default user identity.
      QueueConnection QueueConnectionFactory.createQueueConnection(String userName, String password)
      Creates a queue connection with the specified user identity.
      QueueSession XAQueueConnection.createQueueSession(boolean transacted, int acknowledgeMode)
      Creates a QueueSession object.
      QueueSession QueueConnection.createQueueSession(boolean transacted, int acknowledgeMode)
      Creates a QueueSession object.
      QueueReceiver QueueSession.createReceiver(Queue queue)
      Creates a QueueReceiver object to receive messages from the specified queue.
      QueueReceiver QueueSession.createReceiver(Queue queue, String messageSelector)
      Creates a QueueReceiver object to receive messages from the specified queue using a message selector.
      QueueSender QueueSession.createSender(Queue queue)
      Creates a QueueSender object to send messages to the specified queue.
      Session Connection.createSession()
      Creates a Session object, specifying no arguments.
      Session XAConnection.createSession(boolean transacted, int acknowledgeMode)
      Creates an Session object.
      Session Connection.createSession(boolean transacted, int acknowledgeMode)
      Creates a Session object, specifying transacted and acknowledgeMode.
      Session Connection.createSession(int sessionMode)
      Creates a Session object, specifying sessionMode.
      ConnectionConsumer Connection.createSharedConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using a shared non-durable subscription with the specified name.
      MessageConsumer Session.createSharedConsumer(Topic topic, String sharedSubscriptionName)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription.
      MessageConsumer Session.createSharedConsumer(Topic topic, String sharedSubscriptionName, String messageSelector)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.
      ConnectionConsumer Connection.createSharedDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using a shared durable subscription with the specified name.
      MessageConsumer Session.createSharedDurableConsumer(Topic topic, String name)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      MessageConsumer Session.createSharedDurableConsumer(Topic topic, String name, String messageSelector)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.
      StreamMessage Session.createStreamMessage()
      Creates a StreamMessage object.
      TopicSubscriber TopicSession.createSubscriber(Topic topic)
      Creates a nondurable subscriber to the specified topic.
      TopicSubscriber TopicSession.createSubscriber(Topic topic, String messageSelector, boolean noLocal)
      Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
      TemporaryQueue Session.createTemporaryQueue()
      Creates a TemporaryQueue object.
      TemporaryQueue QueueSession.createTemporaryQueue()
      Creates a TemporaryQueue object.
      TemporaryTopic TopicSession.createTemporaryTopic()
      Creates a TemporaryTopic object.
      TemporaryTopic Session.createTemporaryTopic()
      Creates a TemporaryTopic object.
      TextMessage Session.createTextMessage()
      Creates a TextMessage object.
      TextMessage Session.createTextMessage(String text)
      Creates an initialized TextMessage object.
      Topic TopicSession.createTopic(String topicName)
      Creates a topic identity given a Topic name.
      Topic Session.createTopic(String topicName)
      Creates a Topic object which encapsulates a specified provider-specific topic name.
      TopicConnection TopicConnectionFactory.createTopicConnection()
      Creates a topic connection with the default user identity.
      TopicConnection TopicConnectionFactory.createTopicConnection(String userName, String password)
      Creates a topic connection with the specified user identity.
      TopicSession XATopicConnection.createTopicSession(boolean transacted, int acknowledgeMode)
      Creates a TopicSession object.
      TopicSession TopicConnection.createTopicSession(boolean transacted, int acknowledgeMode)
      Creates a TopicSession object.
      XAConnection XAConnectionFactory.createXAConnection()
      Creates an XAConnection with the default user identity.
      XAConnection XAConnectionFactory.createXAConnection(String userName, String password)
      Creates an XAConnection with the specified user identity.
      XAQueueConnection XAQueueConnectionFactory.createXAQueueConnection()
      Creates an XA queue connection with the default user identity.
      XAQueueConnection XAQueueConnectionFactory.createXAQueueConnection(String userName, String password)
      Creates an XA queue connection with the specified user identity.
      XAQueueSession XAQueueConnection.createXAQueueSession()
      Creates an XAQueueSession object.
      XASession XAConnection.createXASession()
      Creates an XASession object.
      XATopicConnection XATopicConnectionFactory.createXATopicConnection()
      Creates an XA topic connection with the default user identity.
      XATopicConnection XATopicConnectionFactory.createXATopicConnection(String userName, String password)
      Creates an XA topic connection with the specified user identity.
      XATopicSession XATopicConnection.createXATopicSession()
      Creates an XATopicSession object.
      void TemporaryTopic.delete()
      Deletes this temporary topic.
      void TemporaryQueue.delete()
      Deletes this temporary queue.
      int Session.getAcknowledgeMode()
      Returns the acknowledgement mode of the session.
      <T> T Message.getBody(Class<T> c)
      Returns the message body as an object of the specified type.
      long BytesMessage.getBodyLength()
      Gets the number of bytes of the message body when the message is in read-only mode.
      boolean MapMessage.getBoolean(String name)
      Returns the boolean value with the specified name.
      boolean Message.getBooleanProperty(String name)
      Returns the value of the boolean property with the specified name.
      byte MapMessage.getByte(String name)
      Returns the byte value with the specified name.
      byte Message.getByteProperty(String name)
      Returns the value of the byte property with the specified name.
      byte[] MapMessage.getBytes(String name)
      Returns the byte array value with the specified name.
      char MapMessage.getChar(String name)
      Returns the Unicode character value with the specified name.
      String Connection.getClientID()
      Gets the client identifier for this connection.
      long MessageProducer.getDeliveryDelay()
      Gets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.
      int MessageProducer.getDeliveryMode()
      Gets the producer's default delivery mode.
      Destination MessageProducer.getDestination()
      Gets the destination associated with this MessageProducer.
      boolean MessageProducer.getDisableMessageID()
      Gets an indication of whether message IDs are disabled.
      boolean MessageProducer.getDisableMessageTimestamp()
      Gets an indication of whether message timestamps are disabled.
      double MapMessage.getDouble(String name)
      Returns the double value with the specified name.
      double Message.getDoubleProperty(String name)
      Returns the value of the double property with the specified name.
      Enumeration QueueBrowser.getEnumeration()
      Gets an enumeration for browsing the current queue messages in the order they would be received.
      ExceptionListener Connection.getExceptionListener()
      Gets the ExceptionListener object for this connection.
      float MapMessage.getFloat(String name)
      Returns the float value with the specified name.
      float Message.getFloatProperty(String name)
      Returns the value of the float property with the specified name.
      int MapMessage.getInt(String name)
      Returns the int value with the specified name.
      int Message.getIntProperty(String name)
      Returns the value of the int property with the specified name.
      String Message.getJMSCorrelationID()
      Gets the correlation ID for the message.
      byte[] Message.getJMSCorrelationIDAsBytes()
      Gets the correlation ID as an array of bytes for the message.
      int Message.getJMSDeliveryMode()
      Gets the DeliveryMode value specified for this message.
      long Message.getJMSDeliveryTime()
      Gets the message's delivery time value.
      Destination Message.getJMSDestination()
      Gets the Destination object for this message.
      long Message.getJMSExpiration()
      Gets the message's expiration time.
      int ConnectionMetaData.getJMSMajorVersion()
      Gets the JMS major version number.
      String Message.getJMSMessageID()
      Gets the message ID.
      int ConnectionMetaData.getJMSMinorVersion()
      Gets the JMS minor version number.
      int Message.getJMSPriority()
      Gets the message priority level.
      String ConnectionMetaData.getJMSProviderName()
      Gets the JMS provider name.
      boolean Message.getJMSRedelivered()
      Gets an indication of whether this message is being redelivered.
      Destination Message.getJMSReplyTo()
      Gets the Destination object to which a reply to this message should be sent.
      long Message.getJMSTimestamp()
      Gets the message timestamp.
      String Message.getJMSType()
      Gets the message type identifier supplied by the client when the message was sent.
      String ConnectionMetaData.getJMSVersion()
      Gets the JMS API version.
      Enumeration ConnectionMetaData.getJMSXPropertyNames()
      Gets an enumeration of the JMSX property names.
      long MapMessage.getLong(String name)
      Returns the long value with the specified name.
      long Message.getLongProperty(String name)
      Returns the value of the long property with the specified name.
      Enumeration MapMessage.getMapNames()
      Returns an Enumeration of all the names in the MapMessage object.
      MessageListener Session.getMessageListener()
      Returns the session's distinguished message listener (optional).
      MessageListener MessageConsumer.getMessageListener()
      Gets the MessageConsumer's MessageListener.
      String QueueBrowser.getMessageSelector()
      Gets this queue browser's message selector expression.
      String MessageConsumer.getMessageSelector()
      Gets this message consumer's message selector expression.
      ConnectionMetaData Connection.getMetaData()
      Gets the metadata for this connection.
      boolean TopicSubscriber.getNoLocal()
      Gets the NoLocal attribute for this subscriber.
      Serializable ObjectMessage.getObject()
      Gets the serializable object containing this message's data.
      Object MapMessage.getObject(String name)
      Returns the value of the object with the specified name.
      Object Message.getObjectProperty(String name)
      Returns the value of the Java object property with the specified name.
      int MessageProducer.getPriority()
      Gets the producer's default priority.
      Enumeration Message.getPropertyNames()
      Returns an Enumeration of all the property names.
      int ConnectionMetaData.getProviderMajorVersion()
      Gets the JMS provider major version number.
      int ConnectionMetaData.getProviderMinorVersion()
      Gets the JMS provider minor version number.
      String ConnectionMetaData.getProviderVersion()
      Gets the JMS provider version.
      Queue QueueSender.getQueue()
      Gets the queue associated with this QueueSender.
      Queue QueueReceiver.getQueue()
      Gets the Queue associated with this queue receiver.
      Queue QueueBrowser.getQueue()
      Gets the queue associated with this queue browser.
      String Queue.getQueueName()
      Gets the name of this queue.
      QueueSession XAQueueSession.getQueueSession()
      Gets the queue session associated with this XAQueueSession.
      ServerSession ServerSessionPool.getServerSession()
      Return a server session from the pool.
      ServerSessionPool ConnectionConsumer.getServerSessionPool()
      Gets the server session pool associated with this connection consumer.
      Session XASession.getSession()
      Gets the session associated with this XASession.
      Session ServerSession.getSession()
      Return the ServerSession's Session.
      short MapMessage.getShort(String name)
      Returns the short value with the specified name.
      short Message.getShortProperty(String name)
      Returns the value of the short property with the specified name.
      String MapMessage.getString(String name)
      Returns the String value with the specified name.
      String Message.getStringProperty(String name)
      Returns the value of the String property with the specified name.
      String TextMessage.getText()
      Gets the string containing this message's data.
      long MessageProducer.getTimeToLive()
      Gets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.
      Topic TopicSubscriber.getTopic()
      Gets the Topic associated with this subscriber.
      Topic TopicPublisher.getTopic()
      Gets the topic associated with this TopicPublisher.
      String Topic.getTopicName()
      Gets the name of this topic.
      TopicSession XATopicSession.getTopicSession()
      Gets the topic session associated with this XATopicSession.
      boolean XASession.getTransacted()
      Indicates whether the session is in transacted mode.
      boolean Session.getTransacted()
      Indicates whether the session is in transacted mode.
      boolean Message.isBodyAssignableTo(Class c)
      Returns whether the message body is capable of being assigned to the specified type.
      boolean MapMessage.itemExists(String name)
      Indicates whether an item exists in this MapMessage object.
      boolean Message.propertyExists(String name)
      Indicates whether a property value exists.
      void TopicPublisher.publish(Message message)
      Publishes a message to the topic.
      void TopicPublisher.publish(Message message, int deliveryMode, int priority, long timeToLive)
      Publishes a message to the topic, specifying delivery mode, priority, and time to live.
      void TopicPublisher.publish(Topic topic, Message message)
      Publishes a message to a topic for an unidentified message producer.
      void TopicPublisher.publish(Topic topic, Message message, int deliveryMode, int priority, long timeToLive)
      Publishes a message to a topic for an unidentified message producer, specifying delivery mode, priority and time to live.
      boolean StreamMessage.readBoolean()
      Reads a boolean from the stream message.
      boolean BytesMessage.readBoolean()
      Reads a boolean from the bytes message stream.
      byte StreamMessage.readByte()
      Reads a byte value from the stream message.
      byte BytesMessage.readByte()
      Reads a signed 8-bit value from the bytes message stream.
      int StreamMessage.readBytes(byte[] value)
      Reads a byte array field from the stream message into the specified byte[] object (the read buffer).
      int BytesMessage.readBytes(byte[] value)
      Reads a byte array from the bytes message stream.
      int BytesMessage.readBytes(byte[] value, int length)
      Reads a portion of the bytes message stream.
      char StreamMessage.readChar()
      Reads a Unicode character value from the stream message.
      char BytesMessage.readChar()
      Reads a Unicode character value from the bytes message stream.
      double StreamMessage.readDouble()
      Reads a double from the stream message.
      double BytesMessage.readDouble()
      Reads a double from the bytes message stream.
      float StreamMessage.readFloat()
      Reads a float from the stream message.
      float BytesMessage.readFloat()
      Reads a float from the bytes message stream.
      int StreamMessage.readInt()
      Reads a 32-bit integer from the stream message.
      int BytesMessage.readInt()
      Reads a signed 32-bit integer from the bytes message stream.
      long StreamMessage.readLong()
      Reads a 64-bit integer from the stream message.
      long BytesMessage.readLong()
      Reads a signed 64-bit integer from the bytes message stream.
      Object StreamMessage.readObject()
      Reads an object from the stream message.
      short StreamMessage.readShort()
      Reads a 16-bit integer from the stream message.
      short BytesMessage.readShort()
      Reads a signed 16-bit number from the bytes message stream.
      String StreamMessage.readString()
      Reads a String from the stream message.
      int BytesMessage.readUnsignedByte()
      Reads an unsigned 8-bit number from the bytes message stream.
      int BytesMessage.readUnsignedShort()
      Reads an unsigned 16-bit number from the bytes message stream.
      String BytesMessage.readUTF()
      Reads a string that has been encoded using a modified UTF-8 format from the bytes message stream.
      Message MessageConsumer.receive()
      Receives the next message produced for this message consumer.
      Message MessageConsumer.receive(long timeout)
      Receives the next message that arrives within the specified timeout interval.
      Message MessageConsumer.receiveNoWait()
      Receives the next message if one is immediately available.
      void Session.recover()
      Stops message delivery in this session, and restarts message delivery with the oldest unacknowledged message.
      Message TopicRequestor.request(Message message)
      Sends a request and waits for a reply.
      Message QueueRequestor.request(Message message)
      Sends a request and waits for a reply.
      void StreamMessage.reset()
      Puts the message body in read-only mode and repositions the stream to the beginning.
      void BytesMessage.reset()
      Puts the message body in read-only mode and repositions the stream of bytes to the beginning.
      void XASession.rollback()
      Throws a TransactionInProgressException, since it should not be called for an XASession object.
      void Session.rollback()
      Rolls back any messages done in this transaction and releases any locks currently held.
      void MessageProducer.send(Destination destination, Message message)
      Sends a message to a destination for an unidentified message producer using the MessageProducer's default delivery mode, priority, and time to live.
      void MessageProducer.send(Destination destination, Message message, CompletionListener completionListener)
      Sends a message to a destination for an unidentified message producer, using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void MessageProducer.send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live.
      void MessageProducer.send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive, CompletionListener completionListener)
      Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void QueueSender.send(Message message)
      Sends a message to the queue.
      void MessageProducer.send(Message message)
      Sends a message using the MessageProducer's default delivery mode, priority, and time to live.
      void MessageProducer.send(Message message, CompletionListener completionListener)
      Sends a message using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void QueueSender.send(Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to the queue, specifying delivery mode, priority, and time to live.
      void MessageProducer.send(Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message, specifying delivery mode, priority, and time to live.
      void MessageProducer.send(Message message, int deliveryMode, int priority, long timeToLive, CompletionListener completionListener)
      Sends a message, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void QueueSender.send(Queue queue, Message message)
      Sends a message to a queue for an unidentified message producer.
      void QueueSender.send(Queue queue, Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to a queue for an unidentified message producer, specifying delivery mode, priority and time to live.
      void MapMessage.setBoolean(String name, boolean value)
      Sets a boolean value with the specified name into the Map.
      void Message.setBooleanProperty(String name, boolean value)
      Sets a boolean property value with the specified name into the message.
      void MapMessage.setByte(String name, byte value)
      Sets a byte value with the specified name into the Map.
      void Message.setByteProperty(String name, byte value)
      Sets a byte property value with the specified name into the message.
      void MapMessage.setBytes(String name, byte[] value)
      Sets a byte array value with the specified name into the Map.
      void MapMessage.setBytes(String name, byte[] value, int offset, int length)
      Sets a portion of the byte array value with the specified name into the Map.
      void MapMessage.setChar(String name, char value)
      Sets a Unicode character value with the specified name into the Map.
      void Connection.setClientID(String clientID)
      Sets the client identifier for this connection.
      void MessageProducer.setDeliveryDelay(long deliveryDelay)
      Sets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.
      void MessageProducer.setDeliveryMode(int deliveryMode)
      Sets the producer's default delivery mode.
      void MessageProducer.setDisableMessageID(boolean value)
      Specify whether message IDs may be disabled.
      void MessageProducer.setDisableMessageTimestamp(boolean value)
      Specify whether message timestamps may be disabled.
      void MapMessage.setDouble(String name, double value)
      Sets a double value with the specified name into the Map.
      void Message.setDoubleProperty(String name, double value)
      Sets a double property value with the specified name into the message.
      void Connection.setExceptionListener(ExceptionListener listener)
      Sets an exception listener for this connection.
      void MapMessage.setFloat(String name, float value)
      Sets a float value with the specified name into the Map.
      void Message.setFloatProperty(String name, float value)
      Sets a float property value with the specified name into the message.
      void MapMessage.setInt(String name, int value)
      Sets an int value with the specified name into the Map.
      void Message.setIntProperty(String name, int value)
      Sets an int property value with the specified name into the message.
      void Message.setJMSCorrelationID(String correlationID)
      Sets the correlation ID for the message.
      void Message.setJMSCorrelationIDAsBytes(byte[] correlationID)
      Sets the correlation ID as an array of bytes for the message.
      void Message.setJMSDeliveryMode(int deliveryMode)
      Sets the DeliveryMode value for this message.
      void Message.setJMSDeliveryTime(long deliveryTime)
      Sets the message's delivery time value.
      void Message.setJMSDestination(Destination destination)
      Sets the Destination object for this message.
      void Message.setJMSExpiration(long expiration)
      Sets the message's expiration value.
      void Message.setJMSMessageID(String id)
      Sets the message ID.
      void Message.setJMSPriority(int priority)
      Sets the priority level for this message.
      void Message.setJMSRedelivered(boolean redelivered)
      Specifies whether this message is being redelivered.
      void Message.setJMSReplyTo(Destination replyTo)
      Sets the Destination object to which a reply to this message should be sent.
      void Message.setJMSTimestamp(long timestamp)
      Sets the message timestamp.
      void Message.setJMSType(String type)
      Sets the message type.
      void MapMessage.setLong(String name, long value)
      Sets a long value with the specified name into the Map.
      void Message.setLongProperty(String name, long value)
      Sets a long property value with the specified name into the message.
      void Session.setMessageListener(MessageListener listener)
      Sets the session's distinguished message listener (optional).
      void MessageConsumer.setMessageListener(MessageListener listener)
      Sets the MessageConsumer's MessageListener.
      void ObjectMessage.setObject(Serializable object)
      Sets the serializable object containing this message's data.
      void MapMessage.setObject(String name, Object value)
      Sets an object value with the specified name into the Map.
      void Message.setObjectProperty(String name, Object value)
      Sets a Java object property value with the specified name into the message.
      void MessageProducer.setPriority(int defaultPriority)
      Sets the producer's default priority.
      void MapMessage.setShort(String name, short value)
      Sets a short value with the specified name into the Map.
      void Message.setShortProperty(String name, short value)
      Sets a short property value with the specified name into the message.
      void MapMessage.setString(String name, String value)
      Sets a String value with the specified name into the Map.
      void Message.setStringProperty(String name, String value)
      Sets a String property value with the specified name into the message.
      void TextMessage.setText(String string)
      Sets the string containing this message's data.
      void MessageProducer.setTimeToLive(long timeToLive)
      Sets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.
      void ServerSession.start()
      Cause the Session's run method to be called to process messages that were just assigned to it.
      void Connection.start()
      Starts (or restarts) a connection's delivery of incoming messages.
      void Connection.stop()
      Temporarily stops a connection's delivery of incoming messages.
      void TopicSession.unsubscribe(String name)
      Unsubscribes a durable subscription that has been created by a client.
      void Session.unsubscribe(String name)
      Unsubscribes a durable subscription that has been created by a client.
      void StreamMessage.writeBoolean(boolean value)
      Writes a boolean to the stream message.
      void BytesMessage.writeBoolean(boolean value)
      Writes a boolean to the bytes message stream as a 1-byte value.
      void StreamMessage.writeByte(byte value)
      Writes a byte to the stream message.
      void BytesMessage.writeByte(byte value)
      Writes a byte to the bytes message stream as a 1-byte value.
      void StreamMessage.writeBytes(byte[] value)
      Writes a byte array field to the stream message.
      void BytesMessage.writeBytes(byte[] value)
      Writes a byte array to the bytes message stream.
      void StreamMessage.writeBytes(byte[] value, int offset, int length)
      Writes a portion of a byte array as a byte array field to the stream message.
      void BytesMessage.writeBytes(byte[] value, int offset, int length)
      Writes a portion of a byte array to the bytes message stream.
      void StreamMessage.writeChar(char value)
      Writes a char to the stream message.
      void BytesMessage.writeChar(char value)
      Writes a char to the bytes message stream as a 2-byte value, high byte first.
      void StreamMessage.writeDouble(double value)
      Writes a double to the stream message.
      void BytesMessage.writeDouble(double value)
      Converts the double argument to a long using the doubleToLongBits method in class Double, and then writes that long value to the bytes message stream as an 8-byte quantity, high byte first.
      void StreamMessage.writeFloat(float value)
      Writes a float to the stream message.
      void BytesMessage.writeFloat(float value)
      Converts the float argument to an int using the floatToIntBits method in class Float, and then writes that int value to the bytes message stream as a 4-byte quantity, high byte first.
      void StreamMessage.writeInt(int value)
      Writes an int to the stream message.
      void BytesMessage.writeInt(int value)
      Writes an int to the bytes message stream as four bytes, high byte first.
      void StreamMessage.writeLong(long value)
      Writes a long to the stream message.
      void BytesMessage.writeLong(long value)
      Writes a long to the bytes message stream as eight bytes, high byte first.
      void StreamMessage.writeObject(Object value)
      Writes an object to the stream message.
      void BytesMessage.writeObject(Object value)
      Writes an object to the bytes message stream.
      void StreamMessage.writeShort(short value)
      Writes a short to the stream message.
      void BytesMessage.writeShort(short value)
      Writes a short to the bytes message stream as two bytes, high byte first.
      void StreamMessage.writeString(String value)
      Writes a String to the stream message.
      void BytesMessage.writeUTF(String value)
      Writes a string to the bytes message stream using UTF-8 encoding in a machine-independent manner.
      Constructors in javax.jms that throw JMSException
      Constructor and Description
      QueueRequestor(QueueSession session, Queue queue)
      Constructor for the QueueRequestor class.
      TopicRequestor(TopicSession session, Topic topic)
      Constructor for the TopicRequestor class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSPasswordCredential (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSPasswordCredential

No usage of javax.jms.JMSPasswordCredential
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSRuntimeException

  • Packages that use JMSRuntimeException
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of JMSRuntimeException in javax.jms

      Subclasses of JMSRuntimeException in javax.jms
      Modifier and Type Class and Description
      class  IllegalStateRuntimeException
      This unchecked exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation, and the method signature does not permit a IllegalStateRuntimeException to be thrown.
      class  InvalidClientIDRuntimeException
      This unchecked exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider, and the method signature does not permit a InvalidClientIDException to be thrown.
      class  InvalidDestinationRuntimeException
      This unchecked exception must be thrown when a destination either is not understood by a provider or is no longer valid, and the method signature does not permit a InvalidDestinationException to be thrown.
      class  InvalidSelectorRuntimeException
      This unchecked exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax, and the method signature does not permit a InvalidSelectorException to be thrown.
      class  JMSSecurityRuntimeException
      This unchecked exception must be thrown when a provider rejects a user name/password submitted by a client, or for any case where a security restriction prevents a method from completing, and the method signature does not permit a JMSSecurityException to be thrown.
      class  MessageFormatRuntimeException
      This unchecked exception must be thrown when a JMS application attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type, and the method signature does not permit a MessageFormatException to be thrown.
      class  MessageNotWriteableRuntimeException
      This unchecked exception must be thrown when a JMS client attempts to write to a read-only message.
      class  ResourceAllocationRuntimeException
      This unchecked exception is thrown when a provider is unable to allocate the resources required by a method.
      class  TransactionInProgressRuntimeException
      This unchecked exception is thrown when an operation is invalid because a transaction is in progress.
      class  TransactionRolledBackRuntimeException
      This unchecked exception must be thrown when a call to JMSContext.commit results in a rollback of the current transaction.
      Methods in javax.jms that throw JMSRuntimeException
      Modifier and Type Method and Description
      MessageListener JMSConsumer.getMessageListener()
      Gets the JMSConsumer's MessageListener.
      void JMSConsumer.setMessageListener(MessageListener listener)
      Sets the JMSConsumer's MessageListener.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSSecurityException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSSecurityException

No usage of javax.jms.JMSSecurityException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSSecurityRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSSecurityRuntimeException

No usage of javax.jms.JMSSecurityRuntimeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.JMSSessionMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.JMSSessionMode

No usage of javax.jms.JMSSessionMode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.MessageEOFException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.MessageEOFException

No usage of javax.jms.MessageEOFException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.MessageFormatException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.MessageFormatException

No usage of javax.jms.MessageFormatException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.MessageFormatRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.MessageFormatRuntimeException

No usage of javax.jms.MessageFormatRuntimeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.MessageNotReadableException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.MessageNotReadableException

No usage of javax.jms.MessageNotReadableException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.MessageNotWriteableException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.MessageNotWriteableException

No usage of javax.jms.MessageNotWriteableException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.MessageNotWriteableRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.MessageNotWriteableRuntimeException

No usage of javax.jms.MessageNotWriteableRuntimeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.QueueRequestor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.QueueRequestor

No usage of javax.jms.QueueRequestor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.ResourceAllocationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.ResourceAllocationException

No usage of javax.jms.ResourceAllocationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.ResourceAllocationRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.ResourceAllocationRuntimeException

No usage of javax.jms.ResourceAllocationRuntimeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.TopicRequestor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.TopicRequestor

No usage of javax.jms.TopicRequestor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.TransactionInProgressException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.TransactionInProgressException

No usage of javax.jms.TransactionInProgressException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.TransactionInProgressRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.TransactionInProgressRuntimeException

No usage of javax.jms.TransactionInProgressRuntimeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.TransactionRolledBackException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.TransactionRolledBackException

No usage of javax.jms.TransactionRolledBackException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jms.TransactionRolledBackRuntimeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jms.TransactionRolledBackRuntimeException

No usage of javax.jms.TransactionRolledBackRuntimeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.BytesMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.BytesMessage

  • Packages that use BytesMessage
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of BytesMessage in javax.jms

      Methods in javax.jms that return BytesMessage
      Modifier and Type Method and Description
      BytesMessage Session.createBytesMessage()
      Creates a BytesMessage object.
      BytesMessage JMSContext.createBytesMessage()
      Creates a BytesMessage object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.CompletionListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.CompletionListener

  • Packages that use CompletionListener
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of CompletionListener in javax.jms

      Methods in javax.jms that return CompletionListener
      Modifier and Type Method and Description
      CompletionListener JMSProducer.getAsync()
      If subsequent calls to send on this JMSProducer object have been configured to be asynchronous then this method returns the CompletionListener that has previously been configured.
      Methods in javax.jms with parameters of type CompletionListener
      Modifier and Type Method and Description
      void MessageProducer.send(Destination destination, Message message, CompletionListener completionListener)
      Sends a message to a destination for an unidentified message producer, using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void MessageProducer.send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive, CompletionListener completionListener)
      Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void MessageProducer.send(Message message, CompletionListener completionListener)
      Sends a message using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void MessageProducer.send(Message message, int deliveryMode, int priority, long timeToLive, CompletionListener completionListener)
      Sends a message, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      JMSProducer JMSProducer.setAsync(CompletionListener completionListener)
      Specifies whether subsequent calls to send on this JMSProducer object should be synchronous or asynchronous.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.Connection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.Connection

  • Packages that use Connection
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of Connection in javax.jms

      Subinterfaces of Connection in javax.jms
      Modifier and Type Interface and Description
      interface  QueueConnection
      A QueueConnection object is an active connection to a point-to-point JMS provider.
      interface  TopicConnection
      A TopicConnection object is an active connection to a publish/subscribe JMS provider.
      interface  XAConnection
      The XAConnection interface extends the capability of Connection by providing an XASession (optional).
      interface  XAQueueConnection
      An XAQueueConnection provides the same create options as QueueConnection (optional).
      interface  XATopicConnection
      An XATopicConnection provides the same create options as TopicConnection (optional).
      Methods in javax.jms that return Connection
      Modifier and Type Method and Description
      Connection ConnectionFactory.createConnection()
      Creates a connection with the default user identity.
      Connection ConnectionFactory.createConnection(String userName, String password)
      Creates a connection with the specified user identity.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.ConnectionConsumer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.ConnectionConsumer

  • Packages that use ConnectionConsumer
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of ConnectionConsumer in javax.jms

      Methods in javax.jms that return ConnectionConsumer
      Modifier and Type Method and Description
      ConnectionConsumer Connection.createConnectionConsumer(Destination destination, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific destination.
      ConnectionConsumer QueueConnection.createConnectionConsumer(Queue queue, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation).
      ConnectionConsumer TopicConnection.createConnectionConsumer(Topic topic, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation).
      ConnectionConsumer TopicConnection.createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Create a durable connection consumer for this connection (optional operation).
      ConnectionConsumer Connection.createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using an unshared durable subscription with the specified name.
      ConnectionConsumer Connection.createSharedConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using a shared non-durable subscription with the specified name.
      ConnectionConsumer Connection.createSharedDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using a shared durable subscription with the specified name.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.ConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.ConnectionFactory

  • Packages that use ConnectionFactory
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of ConnectionFactory in javax.jms

      Subinterfaces of ConnectionFactory in javax.jms
      Modifier and Type Interface and Description
      interface  QueueConnectionFactory
      A client uses a QueueConnectionFactory object to create QueueConnection objects with a point-to-point JMS provider.
      interface  TopicConnectionFactory
      A client uses a TopicConnectionFactory object to create TopicConnection objects with a publish/subscribe JMS provider.
      interface  XAQueueConnectionFactory
      An XAQueueConnectionFactory provides the same create options as a QueueConnectionFactory (optional).
      interface  XATopicConnectionFactory
      An XATopicConnectionFactory provides the same create options as a TopicConnectionFactory (optional).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.ConnectionMetaData (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.ConnectionMetaData

  • Packages that use ConnectionMetaData
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of ConnectionMetaData in javax.jms

      Methods in javax.jms that return ConnectionMetaData
      Modifier and Type Method and Description
      ConnectionMetaData JMSContext.getMetaData()
      Gets the connection metadata for the JMSContext's connection.
      ConnectionMetaData Connection.getMetaData()
      Gets the metadata for this connection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.DeliveryMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.DeliveryMode

No usage of javax.jms.DeliveryMode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.Destination (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.Destination

  • Packages that use Destination
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of Destination in javax.jms

      Subinterfaces of Destination in javax.jms
      Modifier and Type Interface and Description
      interface  Queue
      A Queue object encapsulates a provider-specific queue name.
      interface  TemporaryQueue
      A TemporaryQueue object is a unique Queue object created for the duration of a Connection.
      interface  TemporaryTopic
      A TemporaryTopic object is a unique Topic object created for the duration of a Connection.
      interface  Topic
      A Topic object encapsulates a provider-specific topic name.
      Methods in javax.jms that return Destination
      Modifier and Type Method and Description
      Destination MessageProducer.getDestination()
      Gets the destination associated with this MessageProducer.
      Destination Message.getJMSDestination()
      Gets the Destination object for this message.
      Destination Message.getJMSReplyTo()
      Gets the Destination object to which a reply to this message should be sent.
      Destination JMSProducer.getJMSReplyTo()
      Returns the JMSReplyTo header value that has been set on this JMSProducer.
      Methods in javax.jms with parameters of type Destination
      Modifier and Type Method and Description
      ConnectionConsumer Connection.createConnectionConsumer(Destination destination, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific destination.
      MessageConsumer Session.createConsumer(Destination destination)
      Creates a MessageConsumer for the specified destination.
      JMSConsumer JMSContext.createConsumer(Destination destination)
      Creates a JMSConsumer for the specified destination.
      MessageConsumer Session.createConsumer(Destination destination, String messageSelector)
      Creates a MessageConsumer for the specified destination, using a message selector.
      JMSConsumer JMSContext.createConsumer(Destination destination, String messageSelector)
      Creates a JMSConsumer for the specified destination, using a message selector.
      MessageConsumer Session.createConsumer(Destination destination, String messageSelector, boolean noLocal)
      Creates a MessageConsumer for the specified destination, specifying a message selector and the noLocal parameter.
      JMSConsumer JMSContext.createConsumer(Destination destination, String messageSelector, boolean noLocal)
      Creates a JMSConsumer for the specified destination, specifying a message selector and the noLocal parameter.
      MessageProducer Session.createProducer(Destination destination)
      Creates a MessageProducer to send messages to the specified destination.
      JMSProducer JMSProducer.send(Destination destination, byte[] body)
      Send a BytesMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer JMSProducer.send(Destination destination, Map<String,Object> body)
      Send a MapMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      void MessageProducer.send(Destination destination, Message message)
      Sends a message to a destination for an unidentified message producer using the MessageProducer's default delivery mode, priority, and time to live.
      JMSProducer JMSProducer.send(Destination destination, Message message)
      Sends a message to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      void MessageProducer.send(Destination destination, Message message, CompletionListener completionListener)
      Sends a message to a destination for an unidentified message producer, using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void MessageProducer.send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live.
      void MessageProducer.send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive, CompletionListener completionListener)
      Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      JMSProducer JMSProducer.send(Destination destination, Serializable body)
      Send an ObjectMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer JMSProducer.send(Destination destination, String body)
      Send a TextMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      void Message.setJMSDestination(Destination destination)
      Sets the Destination object for this message.
      void Message.setJMSReplyTo(Destination replyTo)
      Sets the Destination object to which a reply to this message should be sent.
      JMSProducer JMSProducer.setJMSReplyTo(Destination replyTo)
      Specifies that messages sent using this JMSProducer will have their JMSReplyTo header value set to the specified Destination object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.ExceptionListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.ExceptionListener

  • Packages that use ExceptionListener
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of ExceptionListener in javax.jms

      Methods in javax.jms that return ExceptionListener
      Modifier and Type Method and Description
      ExceptionListener JMSContext.getExceptionListener()
      Gets the ExceptionListener object for the JMSContext's connection.
      ExceptionListener Connection.getExceptionListener()
      Gets the ExceptionListener object for this connection.
      Methods in javax.jms with parameters of type ExceptionListener
      Modifier and Type Method and Description
      void JMSContext.setExceptionListener(ExceptionListener listener)
      Sets an exception listener for the JMSContext's connection.
      void Connection.setExceptionListener(ExceptionListener listener)
      Sets an exception listener for this connection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.JMSConsumer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.JMSConsumer

  • Packages that use JMSConsumer
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of JMSConsumer in javax.jms

      Methods in javax.jms that return JMSConsumer
      Modifier and Type Method and Description
      JMSConsumer JMSContext.createConsumer(Destination destination)
      Creates a JMSConsumer for the specified destination.
      JMSConsumer JMSContext.createConsumer(Destination destination, String messageSelector)
      Creates a JMSConsumer for the specified destination, using a message selector.
      JMSConsumer JMSContext.createConsumer(Destination destination, String messageSelector, boolean noLocal)
      Creates a JMSConsumer for the specified destination, specifying a message selector and the noLocal parameter.
      JMSConsumer JMSContext.createDurableConsumer(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      JMSConsumer JMSContext.createDurableConsumer(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      JMSConsumer JMSContext.createSharedConsumer(Topic topic, String sharedSubscriptionName)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription.
      JMSConsumer JMSContext.createSharedConsumer(Topic topic, String sharedSubscriptionName, String messageSelector)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.
      JMSConsumer JMSContext.createSharedDurableConsumer(Topic topic, String name)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.
      JMSConsumer JMSContext.createSharedDurableConsumer(Topic topic, String name, String messageSelector)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.JMSContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.JMSContext

  • Packages that use JMSContext
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of JMSContext in javax.jms

      Subinterfaces of JMSContext in javax.jms
      Modifier and Type Interface and Description
      interface  XAJMSContext
      The XAJMSContext interface extends the capability of JMSContext by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional).
      Methods in javax.jms that return JMSContext
      Modifier and Type Method and Description
      JMSContext ConnectionFactory.createContext()
      Creates a JMSContext with the default user identity and an unspecified sessionMode.
      JMSContext JMSContext.createContext(int sessionMode)
      Creates a new JMSContext with the specified session mode using the same connection as this JMSContext and creating a new session.
      JMSContext ConnectionFactory.createContext(int sessionMode)
      Creates a JMSContext with the default user identity and the specified session mode.
      JMSContext ConnectionFactory.createContext(String userName, String password)
      Creates a JMSContext with the specified user identity and an unspecified sessionMode.
      JMSContext ConnectionFactory.createContext(String userName, String password, int sessionMode)
      Creates a JMSContext with the specified user identity and the specified session mode.
      JMSContext XAJMSContext.getContext()
      Returns the JMSContext object associated with this XAJMSContext.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.JMSProducer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.JMSProducer

  • Packages that use JMSProducer
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of JMSProducer in javax.jms

      Methods in javax.jms that return JMSProducer
      Modifier and Type Method and Description
      JMSProducer JMSProducer.clearProperties()
      Clears any message properties set on this JMSProducer
      JMSProducer JMSContext.createProducer()
      Creates a new JMSProducer object which can be used to configure and send messages
      JMSProducer JMSProducer.send(Destination destination, byte[] body)
      Send a BytesMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer JMSProducer.send(Destination destination, Map<String,Object> body)
      Send a MapMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer JMSProducer.send(Destination destination, Message message)
      Sends a message to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer JMSProducer.send(Destination destination, Serializable body)
      Send an ObjectMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer JMSProducer.send(Destination destination, String body)
      Send a TextMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      JMSProducer JMSProducer.setAsync(CompletionListener completionListener)
      Specifies whether subsequent calls to send on this JMSProducer object should be synchronous or asynchronous.
      JMSProducer JMSProducer.setDeliveryDelay(long deliveryDelay)
      Sets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.
      JMSProducer JMSProducer.setDeliveryMode(int deliveryMode)
      Specifies the delivery mode of messages that are sent using this JMSProducer
      JMSProducer JMSProducer.setDisableMessageID(boolean value)
      Specifies whether message IDs may be disabled for messages that are sent using this JMSProducer
      JMSProducer JMSProducer.setDisableMessageTimestamp(boolean value)
      Specifies whether message timestamps may be disabled for messages that are sent using this JMSProducer.
      JMSProducer JMSProducer.setJMSCorrelationID(String correlationID)
      Specifies that messages sent using this JMSProducer will have their JMSCorrelationID header value set to the specified correlation ID, where correlation ID is specified as a String.
      JMSProducer JMSProducer.setJMSCorrelationIDAsBytes(byte[] correlationID)
      Specifies that messages sent using this JMSProducer will have their JMSCorrelationID header value set to the specified correlation ID, where correlation ID is specified as an array of bytes.
      JMSProducer JMSProducer.setJMSReplyTo(Destination replyTo)
      Specifies that messages sent using this JMSProducer will have their JMSReplyTo header value set to the specified Destination object.
      JMSProducer JMSProducer.setJMSType(String type)
      Specifies that messages sent using this JMSProducer will have their JMSType header value set to the specified message type.
      JMSProducer JMSProducer.setPriority(int priority)
      Specifies the priority of messages that are sent using this JMSProducer
      JMSProducer JMSProducer.setProperty(String name, boolean value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified boolean value.
      JMSProducer JMSProducer.setProperty(String name, byte value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified byte value.
      JMSProducer JMSProducer.setProperty(String name, double value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified double value.
      JMSProducer JMSProducer.setProperty(String name, float value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified float value.
      JMSProducer JMSProducer.setProperty(String name, int value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified int value.
      JMSProducer JMSProducer.setProperty(String name, long value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified long value.
      JMSProducer JMSProducer.setProperty(String name, Object value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified Java object value.
      JMSProducer JMSProducer.setProperty(String name, short value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified short value.
      JMSProducer JMSProducer.setProperty(String name, String value)
      Specifies that messages sent using this JMSProducer will have the specified property set to the specified String value.
      JMSProducer JMSProducer.setTimeToLive(long timeToLive)
      Specifies the time to live of messages that are sent using this JMSProducer.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.MapMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.MapMessage

  • Packages that use MapMessage
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of MapMessage in javax.jms

      Methods in javax.jms that return MapMessage
      Modifier and Type Method and Description
      MapMessage Session.createMapMessage()
      Creates a MapMessage object.
      MapMessage JMSContext.createMapMessage()
      Creates a MapMessage object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.Message (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.Message

  • Packages that use Message
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of Message in javax.jms

      Subinterfaces of Message in javax.jms
      Modifier and Type Interface and Description
      interface  BytesMessage
      A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.
      interface  MapMessage
      A MapMessage object is used to send a set of name-value pairs.
      interface  ObjectMessage
      An ObjectMessage object is used to send a message that contains a serializable object in the Java programming language ("Java object").
      interface  StreamMessage
      A StreamMessage object is used to send a stream of primitive types in the Java programming language.
      interface  TextMessage
      A TextMessage object is used to send a message containing a java.lang.String.
      Methods in javax.jms that return Message
      Modifier and Type Method and Description
      Message Session.createMessage()
      Creates a Message object.
      Message JMSContext.createMessage()
      Creates a Message object.
      Message MessageConsumer.receive()
      Receives the next message produced for this message consumer.
      Message JMSConsumer.receive()
      Receives the next message produced for this JMSConsumer.
      Message MessageConsumer.receive(long timeout)
      Receives the next message that arrives within the specified timeout interval.
      Message JMSConsumer.receive(long timeout)
      Receives the next message that arrives within the specified timeout interval.
      Message MessageConsumer.receiveNoWait()
      Receives the next message if one is immediately available.
      Message JMSConsumer.receiveNoWait()
      Receives the next message if one is immediately available.
      Message TopicRequestor.request(Message message)
      Sends a request and waits for a reply.
      Message QueueRequestor.request(Message message)
      Sends a request and waits for a reply.
      Methods in javax.jms with parameters of type Message
      Modifier and Type Method and Description
      void CompletionListener.onCompletion(Message message)
      Notifies the application that the message has been successfully sent
      void CompletionListener.onException(Message message, Exception exception)
      Notifies user that the specified exception was thrown while attempting to send the specified message.
      void MessageListener.onMessage(Message message)
      Passes a message to the listener.
      void TopicPublisher.publish(Message message)
      Publishes a message to the topic.
      void TopicPublisher.publish(Message message, int deliveryMode, int priority, long timeToLive)
      Publishes a message to the topic, specifying delivery mode, priority, and time to live.
      void TopicPublisher.publish(Topic topic, Message message)
      Publishes a message to a topic for an unidentified message producer.
      void TopicPublisher.publish(Topic topic, Message message, int deliveryMode, int priority, long timeToLive)
      Publishes a message to a topic for an unidentified message producer, specifying delivery mode, priority and time to live.
      Message TopicRequestor.request(Message message)
      Sends a request and waits for a reply.
      Message QueueRequestor.request(Message message)
      Sends a request and waits for a reply.
      void MessageProducer.send(Destination destination, Message message)
      Sends a message to a destination for an unidentified message producer using the MessageProducer's default delivery mode, priority, and time to live.
      JMSProducer JMSProducer.send(Destination destination, Message message)
      Sends a message to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.
      void MessageProducer.send(Destination destination, Message message, CompletionListener completionListener)
      Sends a message to a destination for an unidentified message producer, using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void MessageProducer.send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live.
      void MessageProducer.send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive, CompletionListener completionListener)
      Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void QueueSender.send(Message message)
      Sends a message to the queue.
      void MessageProducer.send(Message message)
      Sends a message using the MessageProducer's default delivery mode, priority, and time to live.
      void MessageProducer.send(Message message, CompletionListener completionListener)
      Sends a message using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void QueueSender.send(Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to the queue, specifying delivery mode, priority, and time to live.
      void MessageProducer.send(Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message, specifying delivery mode, priority, and time to live.
      void MessageProducer.send(Message message, int deliveryMode, int priority, long timeToLive, CompletionListener completionListener)
      Sends a message, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.
      void QueueSender.send(Queue queue, Message message)
      Sends a message to a queue for an unidentified message producer.
      void QueueSender.send(Queue queue, Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to a queue for an unidentified message producer, specifying delivery mode, priority and time to live.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.MessageConsumer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.MessageConsumer

  • Packages that use MessageConsumer
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of MessageConsumer in javax.jms

      Subinterfaces of MessageConsumer in javax.jms
      Modifier and Type Interface and Description
      interface  QueueReceiver
      A client uses a QueueReceiver object to receive messages that have been delivered to a queue.
      interface  TopicSubscriber
      A client uses a TopicSubscriber object to receive messages that have been published to a topic.
      Methods in javax.jms that return MessageConsumer
      Modifier and Type Method and Description
      MessageConsumer Session.createConsumer(Destination destination)
      Creates a MessageConsumer for the specified destination.
      MessageConsumer Session.createConsumer(Destination destination, String messageSelector)
      Creates a MessageConsumer for the specified destination, using a message selector.
      MessageConsumer Session.createConsumer(Destination destination, String messageSelector, boolean noLocal)
      Creates a MessageConsumer for the specified destination, specifying a message selector and the noLocal parameter.
      MessageConsumer Session.createDurableConsumer(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      MessageConsumer Session.createDurableConsumer(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      MessageConsumer Session.createSharedConsumer(Topic topic, String sharedSubscriptionName)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription.
      MessageConsumer Session.createSharedConsumer(Topic topic, String sharedSubscriptionName, String messageSelector)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.
      MessageConsumer Session.createSharedDurableConsumer(Topic topic, String name)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      MessageConsumer Session.createSharedDurableConsumer(Topic topic, String name, String messageSelector)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.MessageListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.MessageListener

  • Packages that use MessageListener
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of MessageListener in javax.jms

      Methods in javax.jms that return MessageListener
      Modifier and Type Method and Description
      MessageListener Session.getMessageListener()
      Returns the session's distinguished message listener (optional).
      MessageListener MessageConsumer.getMessageListener()
      Gets the MessageConsumer's MessageListener.
      MessageListener JMSConsumer.getMessageListener()
      Gets the JMSConsumer's MessageListener.
      Methods in javax.jms with parameters of type MessageListener
      Modifier and Type Method and Description
      void Session.setMessageListener(MessageListener listener)
      Sets the session's distinguished message listener (optional).
      void MessageConsumer.setMessageListener(MessageListener listener)
      Sets the MessageConsumer's MessageListener.
      void JMSConsumer.setMessageListener(MessageListener listener)
      Sets the JMSConsumer's MessageListener.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.MessageProducer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.MessageProducer

  • Packages that use MessageProducer
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of MessageProducer in javax.jms

      Subinterfaces of MessageProducer in javax.jms
      Modifier and Type Interface and Description
      interface  QueueSender
      A client uses a QueueSender object to send messages to a queue.
      interface  TopicPublisher
      A client uses a TopicPublisher object to publish messages on a topic.
      Methods in javax.jms that return MessageProducer
      Modifier and Type Method and Description
      MessageProducer Session.createProducer(Destination destination)
      Creates a MessageProducer to send messages to the specified destination.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.ObjectMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.ObjectMessage

  • Packages that use ObjectMessage
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of ObjectMessage in javax.jms

      Methods in javax.jms that return ObjectMessage
      Modifier and Type Method and Description
      ObjectMessage Session.createObjectMessage()
      Creates an ObjectMessage object.
      ObjectMessage JMSContext.createObjectMessage()
      Creates an ObjectMessage object.
      ObjectMessage Session.createObjectMessage(Serializable object)
      Creates an initialized ObjectMessage object.
      ObjectMessage JMSContext.createObjectMessage(Serializable object)
      Creates an initialized ObjectMessage object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.Queue (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.Queue

  • Packages that use Queue
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of Queue in javax.jms

      Subinterfaces of Queue in javax.jms
      Modifier and Type Interface and Description
      interface  TemporaryQueue
      A TemporaryQueue object is a unique Queue object created for the duration of a Connection.
      Methods in javax.jms that return Queue
      Modifier and Type Method and Description
      Queue Session.createQueue(String queueName)
      Creates a Queue object which encapsulates a specified provider-specific queue name.
      Queue QueueSession.createQueue(String queueName)
      Creates a queue identity given a Queue name.
      Queue JMSContext.createQueue(String queueName)
      Creates a Queue object which encapsulates a specified provider-specific queue name.
      Queue QueueSender.getQueue()
      Gets the queue associated with this QueueSender.
      Queue QueueReceiver.getQueue()
      Gets the Queue associated with this queue receiver.
      Queue QueueBrowser.getQueue()
      Gets the queue associated with this queue browser.
      Methods in javax.jms with parameters of type Queue
      Modifier and Type Method and Description
      QueueBrowser Session.createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser QueueSession.createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser JMSContext.createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser Session.createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
      QueueBrowser QueueSession.createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
      QueueBrowser JMSContext.createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
      ConnectionConsumer QueueConnection.createConnectionConsumer(Queue queue, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation).
      QueueReceiver QueueSession.createReceiver(Queue queue)
      Creates a QueueReceiver object to receive messages from the specified queue.
      QueueReceiver QueueSession.createReceiver(Queue queue, String messageSelector)
      Creates a QueueReceiver object to receive messages from the specified queue using a message selector.
      QueueSender QueueSession.createSender(Queue queue)
      Creates a QueueSender object to send messages to the specified queue.
      void QueueSender.send(Queue queue, Message message)
      Sends a message to a queue for an unidentified message producer.
      void QueueSender.send(Queue queue, Message message, int deliveryMode, int priority, long timeToLive)
      Sends a message to a queue for an unidentified message producer, specifying delivery mode, priority and time to live.
      Constructors in javax.jms with parameters of type Queue
      Constructor and Description
      QueueRequestor(QueueSession session, Queue queue)
      Constructor for the QueueRequestor class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.QueueBrowser (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.QueueBrowser

  • Packages that use QueueBrowser
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of QueueBrowser in javax.jms

      Methods in javax.jms that return QueueBrowser
      Modifier and Type Method and Description
      QueueBrowser Session.createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser QueueSession.createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser JMSContext.createBrowser(Queue queue)
      Creates a QueueBrowser object to peek at the messages on the specified queue.
      QueueBrowser Session.createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
      QueueBrowser QueueSession.createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
      QueueBrowser JMSContext.createBrowser(Queue queue, String messageSelector)
      Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.QueueConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.QueueConnection

  • Packages that use QueueConnection
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of QueueConnection in javax.jms

      Subinterfaces of QueueConnection in javax.jms
      Modifier and Type Interface and Description
      interface  XAQueueConnection
      An XAQueueConnection provides the same create options as QueueConnection (optional).
      Methods in javax.jms that return QueueConnection
      Modifier and Type Method and Description
      QueueConnection QueueConnectionFactory.createQueueConnection()
      Creates a queue connection with the default user identity.
      QueueConnection QueueConnectionFactory.createQueueConnection(String userName, String password)
      Creates a queue connection with the specified user identity.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.QueueConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.QueueConnectionFactory

  • Packages that use QueueConnectionFactory
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of QueueConnectionFactory in javax.jms

      Subinterfaces of QueueConnectionFactory in javax.jms
      Modifier and Type Interface and Description
      interface  XAQueueConnectionFactory
      An XAQueueConnectionFactory provides the same create options as a QueueConnectionFactory (optional).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.QueueReceiver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.QueueReceiver

  • Packages that use QueueReceiver
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of QueueReceiver in javax.jms

      Methods in javax.jms that return QueueReceiver
      Modifier and Type Method and Description
      QueueReceiver QueueSession.createReceiver(Queue queue)
      Creates a QueueReceiver object to receive messages from the specified queue.
      QueueReceiver QueueSession.createReceiver(Queue queue, String messageSelector)
      Creates a QueueReceiver object to receive messages from the specified queue using a message selector.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.QueueSender (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.QueueSender

  • Packages that use QueueSender
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of QueueSender in javax.jms

      Methods in javax.jms that return QueueSender
      Modifier and Type Method and Description
      QueueSender QueueSession.createSender(Queue queue)
      Creates a QueueSender object to send messages to the specified queue.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.QueueSession (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.QueueSession

  • Packages that use QueueSession
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of QueueSession in javax.jms

      Methods in javax.jms that return QueueSession
      Modifier and Type Method and Description
      QueueSession XAQueueConnection.createQueueSession(boolean transacted, int acknowledgeMode)
      Creates a QueueSession object.
      QueueSession QueueConnection.createQueueSession(boolean transacted, int acknowledgeMode)
      Creates a QueueSession object.
      QueueSession XAQueueSession.getQueueSession()
      Gets the queue session associated with this XAQueueSession.
      Constructors in javax.jms with parameters of type QueueSession
      Constructor and Description
      QueueRequestor(QueueSession session, Queue queue)
      Constructor for the QueueRequestor class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.ServerSession (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.ServerSession

  • Packages that use ServerSession
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of ServerSession in javax.jms

      Methods in javax.jms that return ServerSession
      Modifier and Type Method and Description
      ServerSession ServerSessionPool.getServerSession()
      Return a server session from the pool.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.ServerSessionPool (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.ServerSessionPool

  • Packages that use ServerSessionPool
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of ServerSessionPool in javax.jms

      Methods in javax.jms that return ServerSessionPool
      Modifier and Type Method and Description
      ServerSessionPool ConnectionConsumer.getServerSessionPool()
      Gets the server session pool associated with this connection consumer.
      Methods in javax.jms with parameters of type ServerSessionPool
      Modifier and Type Method and Description
      ConnectionConsumer Connection.createConnectionConsumer(Destination destination, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific destination.
      ConnectionConsumer QueueConnection.createConnectionConsumer(Queue queue, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation).
      ConnectionConsumer TopicConnection.createConnectionConsumer(Topic topic, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation).
      ConnectionConsumer TopicConnection.createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Create a durable connection consumer for this connection (optional operation).
      ConnectionConsumer Connection.createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using an unshared durable subscription with the specified name.
      ConnectionConsumer Connection.createSharedConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using a shared non-durable subscription with the specified name.
      ConnectionConsumer Connection.createSharedDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using a shared durable subscription with the specified name.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.Session (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.Session

  • Packages that use Session
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of Session in javax.jms

      Subinterfaces of Session in javax.jms
      Modifier and Type Interface and Description
      interface  QueueSession
      A QueueSession object provides methods for creating QueueReceiver, QueueSender, QueueBrowser, and TemporaryQueue objects.
      interface  TopicSession
      A TopicSession object provides methods for creating TopicPublisher, TopicSubscriber, and TemporaryTopic objects.
      interface  XAQueueSession
      An XAQueueSession provides a regular QueueSession, which can be used to create QueueReceiver, QueueSender, and QueueBrowser objects (optional).
      interface  XASession
      The XASession interface extends the capability of Session by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional).
      interface  XATopicSession
      An XATopicSession provides a regular TopicSession.
      Methods in javax.jms that return Session
      Modifier and Type Method and Description
      Session Connection.createSession()
      Creates a Session object, specifying no arguments.
      Session XAConnection.createSession(boolean transacted, int acknowledgeMode)
      Creates an Session object.
      Session Connection.createSession(boolean transacted, int acknowledgeMode)
      Creates a Session object, specifying transacted and acknowledgeMode.
      Session Connection.createSession(int sessionMode)
      Creates a Session object, specifying sessionMode.
      Session XASession.getSession()
      Gets the session associated with this XASession.
      Session ServerSession.getSession()
      Return the ServerSession's Session.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.StreamMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.StreamMessage

  • Packages that use StreamMessage
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of StreamMessage in javax.jms

      Methods in javax.jms that return StreamMessage
      Modifier and Type Method and Description
      StreamMessage Session.createStreamMessage()
      Creates a StreamMessage object.
      StreamMessage JMSContext.createStreamMessage()
      Creates a StreamMessage object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.TemporaryQueue (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.TemporaryQueue

  • Packages that use TemporaryQueue
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of TemporaryQueue in javax.jms

      Methods in javax.jms that return TemporaryQueue
      Modifier and Type Method and Description
      TemporaryQueue Session.createTemporaryQueue()
      Creates a TemporaryQueue object.
      TemporaryQueue QueueSession.createTemporaryQueue()
      Creates a TemporaryQueue object.
      TemporaryQueue JMSContext.createTemporaryQueue()
      Creates a TemporaryQueue object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.TemporaryTopic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.TemporaryTopic

  • Packages that use TemporaryTopic
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of TemporaryTopic in javax.jms

      Methods in javax.jms that return TemporaryTopic
      Modifier and Type Method and Description
      TemporaryTopic TopicSession.createTemporaryTopic()
      Creates a TemporaryTopic object.
      TemporaryTopic Session.createTemporaryTopic()
      Creates a TemporaryTopic object.
      TemporaryTopic JMSContext.createTemporaryTopic()
      Creates a TemporaryTopic object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.TextMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.TextMessage

  • Packages that use TextMessage
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of TextMessage in javax.jms

      Methods in javax.jms that return TextMessage
      Modifier and Type Method and Description
      TextMessage Session.createTextMessage()
      Creates a TextMessage object.
      TextMessage JMSContext.createTextMessage()
      Creates a TextMessage object.
      TextMessage Session.createTextMessage(String text)
      Creates an initialized TextMessage object.
      TextMessage JMSContext.createTextMessage(String text)
      Creates an initialized TextMessage object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.Topic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.Topic

  • Packages that use Topic
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of Topic in javax.jms

      Subinterfaces of Topic in javax.jms
      Modifier and Type Interface and Description
      interface  TemporaryTopic
      A TemporaryTopic object is a unique Topic object created for the duration of a Connection.
      Methods in javax.jms that return Topic
      Modifier and Type Method and Description
      Topic TopicSession.createTopic(String topicName)
      Creates a topic identity given a Topic name.
      Topic Session.createTopic(String topicName)
      Creates a Topic object which encapsulates a specified provider-specific topic name.
      Topic JMSContext.createTopic(String topicName)
      Creates a Topic object which encapsulates a specified provider-specific topic name.
      Topic TopicSubscriber.getTopic()
      Gets the Topic associated with this subscriber.
      Topic TopicPublisher.getTopic()
      Gets the topic associated with this TopicPublisher.
      Methods in javax.jms with parameters of type Topic
      Modifier and Type Method and Description
      ConnectionConsumer TopicConnection.createConnectionConsumer(Topic topic, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation).
      ConnectionConsumer TopicConnection.createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Create a durable connection consumer for this connection (optional operation).
      ConnectionConsumer Connection.createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using an unshared durable subscription with the specified name.
      MessageConsumer Session.createDurableConsumer(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      JMSConsumer JMSContext.createDurableConsumer(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      MessageConsumer Session.createDurableConsumer(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      JMSConsumer JMSContext.createDurableConsumer(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      TopicSubscriber TopicSession.createDurableSubscriber(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      TopicSubscriber Session.createDurableSubscriber(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      TopicSubscriber TopicSession.createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      TopicSubscriber Session.createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      TopicPublisher TopicSession.createPublisher(Topic topic)
      Creates a publisher for the specified topic.
      ConnectionConsumer Connection.createSharedConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using a shared non-durable subscription with the specified name.
      MessageConsumer Session.createSharedConsumer(Topic topic, String sharedSubscriptionName)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription.
      JMSConsumer JMSContext.createSharedConsumer(Topic topic, String sharedSubscriptionName)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription.
      MessageConsumer Session.createSharedConsumer(Topic topic, String sharedSubscriptionName, String messageSelector)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.
      JMSConsumer JMSContext.createSharedConsumer(Topic topic, String sharedSubscriptionName, String messageSelector)
      Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.
      ConnectionConsumer Connection.createSharedDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages)
      Creates a connection consumer for this connection (optional operation) on the specific topic using a shared durable subscription with the specified name.
      MessageConsumer Session.createSharedDurableConsumer(Topic topic, String name)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      JMSConsumer JMSContext.createSharedDurableConsumer(Topic topic, String name)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.
      MessageConsumer Session.createSharedDurableConsumer(Topic topic, String name, String messageSelector)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.
      JMSConsumer JMSContext.createSharedDurableConsumer(Topic topic, String name, String messageSelector)
      Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.
      TopicSubscriber TopicSession.createSubscriber(Topic topic)
      Creates a nondurable subscriber to the specified topic.
      TopicSubscriber TopicSession.createSubscriber(Topic topic, String messageSelector, boolean noLocal)
      Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
      void TopicPublisher.publish(Topic topic, Message message)
      Publishes a message to a topic for an unidentified message producer.
      void TopicPublisher.publish(Topic topic, Message message, int deliveryMode, int priority, long timeToLive)
      Publishes a message to a topic for an unidentified message producer, specifying delivery mode, priority and time to live.
      Constructors in javax.jms with parameters of type Topic
      Constructor and Description
      TopicRequestor(TopicSession session, Topic topic)
      Constructor for the TopicRequestor class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.TopicConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.TopicConnection

  • Packages that use TopicConnection
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of TopicConnection in javax.jms

      Subinterfaces of TopicConnection in javax.jms
      Modifier and Type Interface and Description
      interface  XATopicConnection
      An XATopicConnection provides the same create options as TopicConnection (optional).
      Methods in javax.jms that return TopicConnection
      Modifier and Type Method and Description
      TopicConnection TopicConnectionFactory.createTopicConnection()
      Creates a topic connection with the default user identity.
      TopicConnection TopicConnectionFactory.createTopicConnection(String userName, String password)
      Creates a topic connection with the specified user identity.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.TopicConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.TopicConnectionFactory

  • Packages that use TopicConnectionFactory
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of TopicConnectionFactory in javax.jms

      Subinterfaces of TopicConnectionFactory in javax.jms
      Modifier and Type Interface and Description
      interface  XATopicConnectionFactory
      An XATopicConnectionFactory provides the same create options as a TopicConnectionFactory (optional).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.TopicPublisher (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.TopicPublisher

  • Packages that use TopicPublisher
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of TopicPublisher in javax.jms

      Methods in javax.jms that return TopicPublisher
      Modifier and Type Method and Description
      TopicPublisher TopicSession.createPublisher(Topic topic)
      Creates a publisher for the specified topic.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.TopicSession (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.TopicSession

  • Packages that use TopicSession
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of TopicSession in javax.jms

      Methods in javax.jms that return TopicSession
      Modifier and Type Method and Description
      TopicSession XATopicConnection.createTopicSession(boolean transacted, int acknowledgeMode)
      Creates a TopicSession object.
      TopicSession TopicConnection.createTopicSession(boolean transacted, int acknowledgeMode)
      Creates a TopicSession object.
      TopicSession XATopicSession.getTopicSession()
      Gets the topic session associated with this XATopicSession.
      Constructors in javax.jms with parameters of type TopicSession
      Constructor and Description
      TopicRequestor(TopicSession session, Topic topic)
      Constructor for the TopicRequestor class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.TopicSubscriber (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.TopicSubscriber

  • Packages that use TopicSubscriber
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of TopicSubscriber in javax.jms

      Methods in javax.jms that return TopicSubscriber
      Modifier and Type Method and Description
      TopicSubscriber TopicSession.createDurableSubscriber(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      TopicSubscriber Session.createDurableSubscriber(Topic topic, String name)
      Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.
      TopicSubscriber TopicSession.createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      TopicSubscriber Session.createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal)
      Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.
      TopicSubscriber TopicSession.createSubscriber(Topic topic)
      Creates a nondurable subscriber to the specified topic.
      TopicSubscriber TopicSession.createSubscriber(Topic topic, String messageSelector, boolean noLocal)
      Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.XAConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.XAConnection

  • Packages that use XAConnection
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of XAConnection in javax.jms

      Subinterfaces of XAConnection in javax.jms
      Modifier and Type Interface and Description
      interface  XAQueueConnection
      An XAQueueConnection provides the same create options as QueueConnection (optional).
      interface  XATopicConnection
      An XATopicConnection provides the same create options as TopicConnection (optional).
      Methods in javax.jms that return XAConnection
      Modifier and Type Method and Description
      XAConnection XAConnectionFactory.createXAConnection()
      Creates an XAConnection with the default user identity.
      XAConnection XAConnectionFactory.createXAConnection(String userName, String password)
      Creates an XAConnection with the specified user identity.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.XAConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.XAConnectionFactory

  • Packages that use XAConnectionFactory
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of XAConnectionFactory in javax.jms

      Subinterfaces of XAConnectionFactory in javax.jms
      Modifier and Type Interface and Description
      interface  XAQueueConnectionFactory
      An XAQueueConnectionFactory provides the same create options as a QueueConnectionFactory (optional).
      interface  XATopicConnectionFactory
      An XATopicConnectionFactory provides the same create options as a TopicConnectionFactory (optional).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.XAJMSContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.XAJMSContext

  • Packages that use XAJMSContext
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of XAJMSContext in javax.jms

      Methods in javax.jms that return XAJMSContext
      Modifier and Type Method and Description
      XAJMSContext XAConnectionFactory.createXAContext()
      Creates a XAJMSContext with the default user identity
      XAJMSContext XAConnectionFactory.createXAContext(String userName, String password)
      Creates a JMSContext with the specified user identity
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.XAQueueConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.XAQueueConnection

  • Packages that use XAQueueConnection
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of XAQueueConnection in javax.jms

      Methods in javax.jms that return XAQueueConnection
      Modifier and Type Method and Description
      XAQueueConnection XAQueueConnectionFactory.createXAQueueConnection()
      Creates an XA queue connection with the default user identity.
      XAQueueConnection XAQueueConnectionFactory.createXAQueueConnection(String userName, String password)
      Creates an XA queue connection with the specified user identity.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.XAQueueConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.XAQueueConnectionFactory

No usage of javax.jms.XAQueueConnectionFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.XAQueueSession (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.XAQueueSession

  • Packages that use XAQueueSession
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of XAQueueSession in javax.jms

      Methods in javax.jms that return XAQueueSession
      Modifier and Type Method and Description
      XAQueueSession XAQueueConnection.createXAQueueSession()
      Creates an XAQueueSession object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.XASession (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.XASession

  • Packages that use XASession
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of XASession in javax.jms

      Subinterfaces of XASession in javax.jms
      Modifier and Type Interface and Description
      interface  XAQueueSession
      An XAQueueSession provides a regular QueueSession, which can be used to create QueueReceiver, QueueSender, and QueueBrowser objects (optional).
      interface  XATopicSession
      An XATopicSession provides a regular TopicSession.
      Methods in javax.jms that return XASession
      Modifier and Type Method and Description
      XASession XAConnection.createXASession()
      Creates an XASession object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.XATopicConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.XATopicConnection

  • Packages that use XATopicConnection
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of XATopicConnection in javax.jms

      Methods in javax.jms that return XATopicConnection
      Modifier and Type Method and Description
      XATopicConnection XATopicConnectionFactory.createXATopicConnection()
      Creates an XA topic connection with the default user identity.
      XATopicConnection XATopicConnectionFactory.createXATopicConnection(String userName, String password)
      Creates an XA topic connection with the specified user identity.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.XATopicConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.XATopicConnectionFactory

No usage of javax.jms.XATopicConnectionFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.jms.XATopicSession (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.jms.XATopicSession

  • Packages that use XATopicSession
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

    • Uses of XATopicSession in javax.jms

      Methods in javax.jms that return XATopicSession
      Modifier and Type Method and Description
      XATopicSession XATopicConnection.createXATopicSession()
      Creates an XATopicSession object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Specification License

 Specification: JSR-343 Java Message Service ("Specification")
Version: 2.0
Status: Final Release
Specification Lead: Oracle America, Inc. ("Specification Lead")
Release: 20 March 2013

Copyright © 2011-2013 Oracle America, Inc.
All rights reserved.

LIMITED LICENSE GRANTS
1. License for Evaluation Purposes. Specification Lead hereby grants you a fully-paid, non-exclusive, non-transferable, worldwide, limited license (without the right to sublicense), under Specification Lead's applicable intellectual property rights to view, download, use and reproduce the Specification only for the purpose of internal evaluation. This includes (i) developing applications intended to run on an implementation of the Specification, provided that such applications do not themselves implement any portion(s) of the Specification, and (ii) discussing the Specification with any third party; and (iii) excerpting brief portions of the Specification in oral or written communications which discuss the Specification provided that such excerpts do not in the aggregate constitute a significant portion of the Specification.

2. License for the Distribution of Compliant Implementations. Specification Lead also grants you a perpetual, non-exclusive, non-transferable, worldwide, fully paid-up, royalty free, limited license (without the right to sublicense) under any applicable copyrights or, subject to the provisions of subsection 4 below, patent rights it may have covering the Specification to create and/or distribute an Independent Implementation of the Specification that: (a) fully implements the Specification including all its required interfaces and functionality; (b) does not modify, subset, superset or otherwise extend the Licensor Name Space, or include any public or protected packages, classes, Java interfaces, fields or methods within the Licensor Name Space other than those required/authorized by the Specification or Specifications being implemented; and (c) passes the Technology Compatibility Kit (including satisfying the requirements of the applicable TCK Users Guide) for such Specification ("Compliant Implementation"). In addition, the foregoing license is expressly conditioned on your not acting outside its scope. No license is granted hereunder for any other purpose (including, for example, modifying the Specification, other than to the extent of your fair use rights, or distributing the Specification to third parties). Also, no right, title, or interest in or to any trademarks, service marks, or trade names of Specification Lead or Specification Lead's licensors is granted hereunder. Java, and Java-related logos, marks and names are trademarks or registered trademarks of Oracle America, Inc. in the U.S. and other countries.

3. Pass-through Conditions. You need not include limitations (a)-(c) from the previous paragraph or any other particular "pass through" requirements in any license You grant concerning the use of your Independent Implementation or products derived from it. However, except with respect to Independent Implementations (and products derived from them) that satisfy limitations (a)-(c) from the previous paragraph, You may neither: (a) grant or otherwise pass through to your licensees any licenses under Specification Lead's applicable intellectual property rights; nor (b) authorize your licensees to make any claims concerning their implementation's compliance with the Specification in question.

4. Reciprocity Concerning Patent Licenses.
a. With respect to any patent claims covered by the license granted under subparagraph 2 above that would be infringed by all technically feasible implementations of the Specification, such license is conditioned upon your offering on fair, reasonable and non-discriminatory terms, to any party seeking it from You, a perpetual, non-exclusive, non-transferable, worldwide license under Your patent rights which are or would be infringed by all technically feasible implementations of the Specification to develop, distribute and use a Compliant Implementation.
b. With respect to any patent claims owned by Specification Lead and covered by the license granted under subparagraph 2, whether or not their infringement can be avoided in a technically feasible manner when implementing the Specification, such license shall terminate with respect to such claims if You initiate a claim against Specification Lead that it has, in the course of performing its responsibilities as the Specification Lead, induced any other entity to infringe Your patent rights.
c. Also with respect to any patent claims owned by Specification Lead and covered by the license granted under subparagraph 2 above, where the infringement of such claims can be avoided in a technically feasible manner when implementing the Specification such license, with respect to such claims, shall terminate if You initiate a claim against Specification Lead that its making, having made, using, offering to sell, selling or importing a Compliant Implementation infringes Your patent rights.

5. Definitions. For the purposes of this Agreement: "Independent Implementation" shall mean an implementation of the Specification that neither derives from any of Specification Lead's source code or binary code materials nor, except with an appropriate and separate license from Specification Lead, includes any of Specification Lead's source code or binary code materials; "Licensor Name Space" shall mean the public class or interface declarations whose names begin with "java", "javax", "com.<Specification Lead>" or their equivalents in any subsequent naming convention adopted by Oracle through the Java Community Process, or any recognized successors or replacements thereof; and "Technology Compatibility Kit" or "TCK" shall mean the test suite and accompanying TCK User's Guide provided by Specification Lead which corresponds to the Specification and that was available either (i) from Specification Lead's 120 days before the first release of Your Independent Implementation that allows its use for commercial purposes, or (ii) more recently than 120 days from such release but against which You elect to test Your implementation of the Specification.

This Agreement will terminate immediately without notice from Specification Lead if you breach the Agreement or act outside the scope of the licenses granted above.

DISCLAIMER OF WARRANTIES
THE SPECIFICATION IS PROVIDED "AS IS". SPECIFICATION LEAD MAKES NO REPRESENTATIONS OR WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO, WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT (INCLUDING AS A CONSEQUENCE OF ANY PRACTICE OR IMPLEMENTATION OF THE SPECIFICATION), OR THAT THE CONTENTS OF THE SPECIFICATION ARE SUITABLE FOR ANY PURPOSE. This document does not represent any commitment to release or implement any portion of the Specification in any product. In addition, the Specification could include technical inaccuracies or typographical errors.

LIMITATION OF LIABILITY
TO THE EXTENT NOT PROHIBITED BY LAW, IN NO EVENT WILL SPECIFICATION LEAD OR ITS LICENSORS BE LIABLE FOR ANY DAMAGES, INCLUDING WITHOUT LIMITATION, LOST REVENUE, PROFITS OR DATA, OR FOR SPECIAL, INDIRECT, CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF OR RELATED IN ANY WAY TO YOUR HAVING, IMPELEMENTING OR OTHERWISE USING USING THE SPECIFICATION, EVEN IF SPECIFICATION LEAD AND/OR ITS LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You will indemnify, hold harmless, and defend Specification Lead and its licensors from any claims arising or resulting from: (i) your use of the Specification; (ii) the use or distribution of your Java application, applet and/or implementation; and/or (iii) any claims that later versions or releases of any Specification furnished to you are incompatible with the Specification provided to you under this license.

RESTRICTED RIGHTS LEGEND
U.S. Government: If this Specification is being acquired by or on behalf of the U.S. Government or by a U.S. Government prime contractor or subcontractor (at any tier), then the Government's rights in the Software and accompanying documentation shall be only as set forth in this license; this is in accordance with 48 C.F.R. 227.7201 through 227.7202-4 (for Department of Defense (DoD) acquisitions) and with 48 C.F.R. 2.101 and 12.212 (for non-DoD acquisitions).

REPORT
If you provide Specification Lead with any comments or suggestions concerning the Specification ("Feedback"), you hereby: (i) agree that such Feedback is provided on a non-proprietary and non-confidential basis, and (ii) grant Specification Lead a perpetual, non-exclusive, worldwide, fully paid-up, irrevocable license, with the right to sublicense through multiple levels of sublicensees, to incorporate, disclose, and use without limitation the Feedback for any purpose.

GENERAL TERMS
Any action related to this Agreement will be governed by California law and controlling U.S. federal law. The U.N. Convention for the International Sale of Goods and the choice of law rules of any jurisdiction will not apply.

The Specification is subject to U.S. export control laws and may be subject to export or import regulations in other countries. Licensee agrees to comply strictly with all such laws and regulations and acknowledges that it has the responsibility to obtain such licenses to export, re-export or import as may be required after delivery to Licensee.

This Agreement is the parties' entire agreement relating to its subject matter. It supersedes all prior or contemporaneous oral or written communications, proposals, conditions, representations and warranties and prevails over any conflicting or additional terms of any quote, order, acknowledgment, or other communication between the parties relating to its subject matter during the term of this Agreement. No modification to this Agreement will be binding, unless in writing and signed by an authorized representative of each party.

Rev. April, 2006


javax.json (Java(TM) EE 7 Specification APIs)

javax.json

Interfaces

  • JsonArray
  • JsonArrayBuilder
  • JsonBuilderFactory
  • JsonNumber
  • JsonObject
  • JsonObjectBuilder
  • JsonReader
  • JsonReaderFactory
  • JsonString
  • JsonStructure
  • JsonValue
  • JsonWriter
  • JsonWriterFactory

Classes

  • Json

Enums

  • JsonValue.ValueType

Exceptions

  • JsonException


javax.json (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.json

Provides an object model API to process JSON.

See: Description

  • Interface Summary
    Interface Description
    JsonArray
    JsonArray represents an immutable JSON array (an ordered sequence of zero or more values).
    JsonArrayBuilder
    A builder for creating JsonArray models from scratch.
    JsonBuilderFactory
    Factory to create JsonObjectBuilder and JsonArrayBuilder instances.
    JsonNumber
    An immutable JSON number value.
    JsonObject
    JsonObject class represents an immutable JSON object value (an unordered collection of zero or more name/value pairs).
    JsonObjectBuilder
    A builder for creating JsonObject models from scratch.
    JsonReader
    Reads a JSON object or an array structure from an input source.
    JsonReaderFactory
    Factory to create JsonReader instances.
    JsonString
    An immutable JSON string value.
    JsonStructure
    Super type for the two structured types in JSON (objects and arrays).
    JsonValue
    JsonValue represents an immutable JSON value.
    JsonWriter
    Writes a JSON object or array structure to an output source.
    JsonWriterFactory
    Factory to create JsonWriter instances.
  • Class Summary
    Class Description
    Json
    Factory class for creating JSON processing objects.
  • Enum Summary
    Enum Description
    JsonValue.ValueType
    Indicates the type of a JsonValue object.
  • Exception Summary
    Exception Description
    JsonException
    JsonException indicates that some exception happened during JSON processing.

Package javax.json Description

Provides an object model API to process JSON.

The object model API is a high-level API that provides immutable object models for JSON object and array structures. These JSON structures are represented as object models using the Java types JsonObject and JsonArray. The interface javax.json.JsonObject provides a Map view to access the unordered collection of zero or more name/value pairs from the model. Similarly, the interface JsonArray provides a List view to access the ordered sequence of zero or more values from the model.

The object model API uses builder patterns to create these object models. The classes JsonObjectBuilder and JsonArrayBuilder provide methods to create models of type JsonObject and JsonArray respectively.

These object models can also be created from an input source using the class JsonReader. Similarly, these object models can be written to an output source using the class JsonWriter.

Since:
JSON Processing 1.0
Author:
Jitendra Kotamraju
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.json Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.json

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.json.Json
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.json.JsonException

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • javax.json.JsonReader
      • javax.json.JsonWriter
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.List<E>
        • javax.json.JsonArray (also extends javax.json.JsonStructure)
  • javax.json.JsonArrayBuilder
  • javax.json.JsonBuilderFactory
  • javax.json.JsonObjectBuilder
  • javax.json.JsonReaderFactory
  • javax.json.JsonValue
    • javax.json.JsonNumber
    • javax.json.JsonString
    • javax.json.JsonStructure
      • javax.json.JsonArray (also extends java.util.List<E>)
      • javax.json.JsonObject (also extends java.util.Map<K,V>)
  • javax.json.JsonWriterFactory
  • java.util.Map<K,V>
    • javax.json.JsonObject (also extends javax.json.JsonStructure)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.json.JsonValue.ValueType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Json (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Class Json

  • java.lang.Object
    • javax.json.Json

  • public class Json
extends Object
    Factory class for creating JSON processing objects. This class provides the most commonly used methods for creating these objects and their corresponding factories. The factory classes provide all the various ways to create these objects.

    The methods in this class locate a provider instance using the method JsonProvider.provider(). This class uses the provider instance to create JSON processing objects.

    The following example shows how to create a JSON parser to parse an empty array:

 StringReader reader = new StringReader("[]");
 JsonParser parser = Json.createParser(reader);

    All the methods in this class are safe for use by multiple concurrent threads.

    Author:
    Jitendra Kotamraju

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static JsonArrayBuilder createArrayBuilder()
      Creates a JSON array builder
      static JsonBuilderFactory createBuilderFactory(Map<String,?> config)
      Creates a builder factory for creating JsonArrayBuilder and JsonObjectBuilder objects.
      static JsonGenerator createGenerator(OutputStream out)
      Creates a JSON generator for writing JSON to a byte stream.
      static JsonGenerator createGenerator(Writer writer)
      Creates a JSON generator for writing JSON to a character stream.
      static JsonGeneratorFactory createGeneratorFactory(Map<String,?> config)
      Creates a generator factory for creating JsonGenerator objects.
      static JsonObjectBuilder createObjectBuilder()
      Creates a JSON object builder
      static JsonParser createParser(InputStream in)
      Creates a JSON parser from a byte stream.
      static JsonParser createParser(Reader reader)
      Creates a JSON parser from a character stream.
      static JsonParserFactory createParserFactory(Map<String,?> config)
      Creates a parser factory for creating JsonParser objects.
      static JsonReader createReader(InputStream in)
      Creates a JSON reader from a byte stream.
      static JsonReader createReader(Reader reader)
      Creates a JSON reader from a character stream.
      static JsonReaderFactory createReaderFactory(Map<String,?> config)
      Creates a reader factory for creating JsonReader objects.
      static JsonWriter createWriter(OutputStream out)
      Creates a JSON writer to write a JSON object or array structure to the specified byte stream.
      static JsonWriter createWriter(Writer writer)
      Creates a JSON writer to write a JSON object or array structure to the specified character stream.
      static JsonWriterFactory createWriterFactory(Map<String,?> config)
      Creates a writer factory for creating JsonWriter objects.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • createParser

        public static JsonParser createParser(Reader reader)
        Creates a JSON parser from a character stream.
        Parameters:
        reader - i/o reader from which JSON is to be read
        Returns:
        a JSON parser

      • createParser

        public static JsonParser createParser(InputStream in)
        Creates a JSON parser from a byte stream. The character encoding of the stream is determined as specified in RFC 4627.
        Parameters:
        in - i/o stream from which JSON is to be read
        Returns:
        a JSON parser
        Throws:
        JsonException - if encoding cannot be determined or i/o error (IOException would be cause of JsonException)

      • createGenerator

        public static JsonGenerator createGenerator(Writer writer)
        Creates a JSON generator for writing JSON to a character stream.
        Parameters:
        writer - a i/o writer to which JSON is written
        Returns:
        a JSON generator

      • createGenerator

        public static JsonGenerator createGenerator(OutputStream out)
        Creates a JSON generator for writing JSON to a byte stream.
        Parameters:
        out - i/o stream to which JSON is written
        Returns:
        a JSON generator

      • createParserFactory

        public static JsonParserFactory createParserFactory(Map<String,?> config)
        Creates a parser factory for creating JsonParser objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.
        Parameters:
        config - a map of provider specific properties to configure the JSON parsers. The map may be empty or null
        Returns:
        JSON parser factory

      • createGeneratorFactory

        public static JsonGeneratorFactory createGeneratorFactory(Map<String,?> config)
        Creates a generator factory for creating JsonGenerator objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.
        Parameters:
        config - a map of provider specific properties to configure the JSON generators. The map may be empty or null
        Returns:
        JSON generator factory

      • createWriter

        public static JsonWriter createWriter(Writer writer)
        Creates a JSON writer to write a JSON object or array structure to the specified character stream.
        Parameters:
        writer - to which JSON object or array is written
        Returns:
        a JSON writer

      • createWriter

        public static JsonWriter createWriter(OutputStream out)
        Creates a JSON writer to write a JSON object or array structure to the specified byte stream. Characters written to the stream are encoded into bytes using UTF-8 encoding.
        Parameters:
        out - to which JSON object or array is written
        Returns:
        a JSON writer

      • createReader

        public static JsonReader createReader(Reader reader)
        Creates a JSON reader from a character stream.
        Parameters:
        reader - a reader from which JSON is to be read
        Returns:
        a JSON reader

      • createReader

        public static JsonReader createReader(InputStream in)
        Creates a JSON reader from a byte stream. The character encoding of the stream is determined as described in RFC 4627.
        Parameters:
        in - a byte stream from which JSON is to be read
        Returns:
        a JSON reader

      • createReaderFactory

        public static JsonReaderFactory createReaderFactory(Map<String,?> config)
        Creates a reader factory for creating JsonReader objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.
        Parameters:
        config - a map of provider specific properties to configure the JSON readers. The map may be empty or null
        Returns:
        a JSON reader factory

      • createWriterFactory

        public static JsonWriterFactory createWriterFactory(Map<String,?> config)
        Creates a writer factory for creating JsonWriter objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.
        Parameters:
        config - a map of provider specific properties to configure the JSON writers. The map may be empty or null
        Returns:
        a JSON writer factory

      • createArrayBuilder

        public static JsonArrayBuilder createArrayBuilder()
        Creates a JSON array builder
        Returns:
        a JSON array builder

      • createObjectBuilder

        public static JsonObjectBuilder createObjectBuilder()
        Creates a JSON object builder
        Returns:
        a JSON object builder

      • createBuilderFactory

        public static JsonBuilderFactory createBuilderFactory(Map<String,?> config)
        Creates a builder factory for creating JsonArrayBuilder and JsonObjectBuilder objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.
        Parameters:
        config - a map of provider specific properties to configure the JSON builders. The map may be empty or null
        Returns:
        a JSON builder factory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonArray (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonArray

  • All Superinterfaces:
    Collection<JsonValue>, Iterable<JsonValue>, JsonStructure, JsonValue, List<JsonValue>

    public interface JsonArray
extends JsonStructure, List<JsonValue>
    JsonArray represents an immutable JSON array (an ordered sequence of zero or more values). It also provides an unmodifiable list view of the values in the array.

    A JsonArray object can be created by reading JSON data from an input source or it can be built from scratch using an array builder object.

    The following example demonstrates how to create a JsonArray object from an input source using the method JsonReader.readArray():

 JsonReader jsonReader = Json.createReader(...);
 JsonArray array = jsonReader.readArray();
 jsonReader.close();

    The following example demonstrates how to build an empty JSON array using the class JsonArrayBuilder:

 JsonArray array = Json.createArrayBuilder().build();

    The example code below demonstrates how to create the following JSON array:

 [
     { "type": "home", "number": "212 555-1234" },
     { "type": "fax", "number": "646 555-4567" }
 ]

 JsonArray value = Json.createArrayBuilder()
     .add(Json.createObjectBuilder()
         .add("type", "home")
         .add("number", "212 555-1234"))
     .add(Json.createObjectBuilder()
         .add("type", "fax")
         .add("number", "646 555-4567"))
     .build();

    The following example demonstrates how to write a JsonArray object as JSON data:

 JsonArray arr = ...;
 JsonWriter writer = Json.createWriter(...)
 writer.writeArray(arr);
 writer.close();

    The values in a JsonArray can be of the following types: JsonObject, JsonArray, JsonString, JsonNumber, JsonValue.TRUE, JsonValue.FALSE, and JsonValue.NULL. JsonArray provides various accessor methods to access the values in an array.

    The following example shows how to obtain the home phone number "212 555-1234" from the array built in the previous example:

 JsonObject home = array.getJsonObject(0);
 String number = home.getString("number");

    JsonArray instances are list objects that provide read-only access to the values in the JSON array. Any attempt to modify the list, whether directly or using its collection views, results in an UnsupportedOperationException.

    Author:
    Jitendra Kotamraju

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.json.JsonValue

        JsonValue.ValueType

    • Field Summary

      • Fields inherited from interface javax.json.JsonValue

        FALSE, NULL, TRUE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean getBoolean(int index)
      Returns the boolean value at the specified position.
      boolean getBoolean(int index, boolean defaultValue)
      Returns the boolean value at the specified position.
      int getInt(int index)
      A convenience method for getJsonNumber(index).intValue().
      int getInt(int index, int defaultValue)
      Returns the int value of the JsonNumber at the specified position.
      JsonArray getJsonArray(int index)
      Returns the array value at the specified position in this array.
      JsonNumber getJsonNumber(int index)
      Returns the number value at the specified position in this array.
      JsonObject getJsonObject(int index)
      Returns the object value at the specified position in this array.
      JsonString getJsonString(int index)
      Returns the string value at ths specified position in this array.
      String getString(int index)
      A convenience method for getJsonString(index).getString().
      String getString(int index, String defaultValue)
      Returns the String value of JsonString at the specified position in this JSON array values.
      <T extends JsonValue>
      List<T>             		getValuesAs(Class<T> clazz)
      Returns a list a view of the specified type for the array.
      boolean isNull(int index)
      Returns true if the value at the specified location in this array is JsonValue.NULL.

      • Methods inherited from interface javax.json.JsonValue

        getValueType, toString

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, remove, remove, removeAll, retainAll, set, size, subList, toArray, toArray

    • Method Detail

      • getJsonObject

        JsonObject getJsonObject(int index)
        Returns the object value at the specified position in this array. This is a convenience method for (JsonObject)get(index).
        Parameters:
        index - index of the value to be returned
        Returns:
        the value at the specified position in this array
        Throws:
        IndexOutOfBoundsException - if the index is out of range
        ClassCastException - if the value at the specified position is not assignable to the JsonObject type

      • getJsonArray

        JsonArray getJsonArray(int index)
        Returns the array value at the specified position in this array. This is a convenience method for (JsonArray)get(index).
        Parameters:
        index - index of the value to be returned
        Returns:
        the value at the specified position in this array
        Throws:
        IndexOutOfBoundsException - if the index is out of range
        ClassCastException - if the value at the specified position is not assignable to the JsonArray type

      • getJsonNumber

        JsonNumber getJsonNumber(int index)
        Returns the number value at the specified position in this array. This is a convenience method for (JsonNumber)get(index).
        Parameters:
        index - index of the value to be returned
        Returns:
        the value at the specified position in this array
        Throws:
        IndexOutOfBoundsException - if the index is out of range
        ClassCastException - if the value at the specified position is not assignable to the JsonNumber type

      • getJsonString

        JsonString getJsonString(int index)
        Returns the string value at ths specified position in this array. This is a convenience method for (JsonString)get(index).
        Parameters:
        index - index of the value to be returned
        Returns:
        the value at the specified position in this array
        Throws:
        IndexOutOfBoundsException - if the index is out of range
        ClassCastException - if the value at the specified position is not assignable to the JsonString type

      • getValuesAs

        <T extends JsonValue> List<T> getValuesAs(Class<T> clazz)
        Returns a list a view of the specified type for the array. This method does not verify if there is a value of wrong type in the array. Providing this typesafe view dynamically may cause a program fail with a ClassCastException, if there is a value of wrong type in this array. Unfortunately, the exception can occur at any time after this method returns.
        Parameters:
        clazz - a JsonValue type
        Returns:
        a list view of the specified type

      • getString

        String getString(int index)
        A convenience method for getJsonString(index).getString().
        Parameters:
        index - index of the JsonString value
        Returns:
        the String value at the specified position
        Throws:
        IndexOutOfBoundsException - if the index is out of range
        ClassCastException - if the value at the specified position is not assignable to JsonString

      • getString

        String getString(int index,
               String defaultValue)
        Returns the String value of JsonString at the specified position in this JSON array values. If JsonString is found, its JsonString.getString() is returned. Otherwise, the specified default value is returned.
        Parameters:
        index - index of the JsonString value
        Returns:
        the String value at the specified position in this array, or the specified default value

      • getInt

        int getInt(int index)
        A convenience method for getJsonNumber(index).intValue().
        Parameters:
        index - index of the JsonNumber value
        Returns:
        the int value at the specified position
        Throws:
        IndexOutOfBoundsException - if the index is out of range
        ClassCastException - if the value at the specified position is not assignable to JsonNumber

      • getInt

        int getInt(int index,
         int defaultValue)
        Returns the int value of the JsonNumber at the specified position. If the value at that position is a JsonNumber, this method returns JsonNumber.intValue(). Otherwise this method returns the specified default value.
        Parameters:
        index - index of the JsonNumber value
        Returns:
        the int value at the specified position in this array, or the specified default value

      • getBoolean

        boolean getBoolean(int index)
        Returns the boolean value at the specified position. If the value at the specified position is JsonValue.TRUE this method returns true. If the value at the specified position is JsonValue.FALSE this method returns false.
        Parameters:
        index - index of the JSON boolean value
        Returns:
        the boolean value at the specified position
        Throws:
        IndexOutOfBoundsException - if the index is out of range
        ClassCastException - if the value at the specified position is not assignable to JsonValue.TRUE or JsonValue.FALSE

      • getBoolean

        boolean getBoolean(int index,
                 boolean defaultValue)
        Returns the boolean value at the specified position. If the value at the specified position is JsonValue.TRUE this method returns true. If the value at the specified position is JsonValue.FALSE this method returns false. Otherwise this method returns the specified default value.
        Parameters:
        index - index of the JSON boolean value
        Returns:
        the boolean value at the specified position, or the specified default value

      • isNull

        boolean isNull(int index)
        Returns true if the value at the specified location in this array is JsonValue.NULL.
        Parameters:
        index - index of the JSON null value
        Returns:
        return true if the value at the specified location is JsonValue.NUL, otherwise false
        Throws:
        IndexOutOfBoundsException - if the index is out of range
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonArrayBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonArrayBuilder

  • public interface JsonArrayBuilder
    A builder for creating JsonArray models from scratch. This interface initializes an empty JSON array model and provides methods to add values to the array model and to return the resulting array. The methods in this class can be chained to add multiple values to the array.

    The class Json contains methods to create the builder object. The example code below shows how to build an empty JsonArray instance.

 JsonArray array = Json.createArrayBuilder().build();

    The class JsonBuilderFactory also contains methods to create JsonArrayBuilder instances. A factory instance can be used to create multiple builder instances with the same configuration. This the preferred way to create multiple instances. The example code below shows how to build a JsonArray object that represents the following JSON array:

 [
     { "type": "home", "number": "212 555-1234" },
     { "type": "fax", "number": "646 555-4567" }
 ]

    The following code creates the JSON array above:

 JsonBuilderFactory factory = Json.createBuilderFactory(config);
 JsonArray value = factory.createArrayBuilder()
     .add(factory.createObjectBuilder()
         .add("type", "home")
         .add("number", "212 555-1234"))
     .add(factory.createObjectBuilder()
         .add("type", "fax")
         .add("number", "646 555-4567"))
     .build();

    This class does not allow null to be used as a value while building the JSON array

    See Also:
    JsonObjectBuilder

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JsonArrayBuilder add(BigDecimal value)
      Adds a value to the array as a JsonNumber.
      JsonArrayBuilder add(BigInteger value)
      Adds a value to the array as a JsonNumber.
      JsonArrayBuilder add(boolean value)
      Adds a JsonValue.TRUE or JsonValue.FALSE value to the array.
      JsonArrayBuilder add(double value)
      Adds a value to the array as a JsonNumber.
      JsonArrayBuilder add(int value)
      Adds a value to the array as a JsonNumber.
      JsonArrayBuilder add(JsonArrayBuilder builder)
      Adds a JsonArray from an array builder to the array.
      JsonArrayBuilder add(JsonObjectBuilder builder)
      Adds a JsonObject from an object builder to the array.
      JsonArrayBuilder add(JsonValue value)
      Adds a value to the array.
      JsonArrayBuilder add(long value)
      Adds a value to the array as a JsonNumber.
      JsonArrayBuilder add(String value)
      Adds a value to the array as a JsonString.
      JsonArrayBuilder addNull()
      Adds a JsonValue.NULL value to the array.
      JsonArray build()
      Returns the current array.

    • Method Detail

      • add

        JsonArrayBuilder add(JsonValue value)
        Adds a value to the array.
        Parameters:
        value - the JSON value
        Returns:
        this array builder
        Throws:
        NullPointerException - if the specified value is null

      • add

        JsonArrayBuilder add(String value)
        Adds a value to the array as a JsonString.
        Parameters:
        value - the string value
        Returns:
        this array builder
        Throws:
        NullPointerException - if the specified value is null

      • add

        JsonArrayBuilder add(BigDecimal value)
        Adds a value to the array as a JsonNumber.
        Parameters:
        value - the number value
        Returns:
        this array builder
        Throws:
        NullPointerException - if the specified value is null
        See Also:
        JsonNumber

      • add

        JsonArrayBuilder add(BigInteger value)
        Adds a value to the array as a JsonNumber.
        Parameters:
        value - the number value
        Returns:
        this array builder
        Throws:
        NullPointerException - if the specified value is null
        See Also:
        JsonNumber

      • add

        JsonArrayBuilder add(int value)
        Adds a value to the array as a JsonNumber.
        Parameters:
        value - the number value
        Returns:
        this array builder
        See Also:
        JsonNumber

      • add

        JsonArrayBuilder add(long value)
        Adds a value to the array as a JsonNumber.
        Parameters:
        value - the number value
        Returns:
        this array builder
        See Also:
        JsonNumber

      • add

        JsonArrayBuilder add(double value)
        Adds a value to the array as a JsonNumber.
        Parameters:
        value - the number value
        Returns:
        this array builder
        Throws:
        NumberFormatException - if the value is Not-a-Number(NaN) or infinity
        See Also:
        JsonNumber

      • add

        JsonArrayBuilder add(boolean value)
        Adds a JsonValue.TRUE or JsonValue.FALSE value to the array.
        Parameters:
        value - the boolean value
        Returns:
        this array builder

      • addNull

        JsonArrayBuilder addNull()
        Adds a JsonValue.NULL value to the array.
        Returns:
        this array builder

      • add

        JsonArrayBuilder add(JsonObjectBuilder builder)
        Adds a JsonObject from an object builder to the array.
        Parameters:
        builder - the object builder
        Returns:
        this array builder
        Throws:
        NullPointerException - if the specified builder is null

      • add

        JsonArrayBuilder add(JsonArrayBuilder builder)
        Adds a JsonArray from an array builder to the array.
        Parameters:
        builder - the array builder
        Returns:
        this array builder
        Throws:
        NullPointerException - if the specified builder is null

      • build

        JsonArray build()
        Returns the current array.
        Returns:
        the current JSON array
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonBuilderFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonBuilderFactory

  • public interface JsonBuilderFactory
    Factory to create JsonObjectBuilder and JsonArrayBuilder instances. If a factory instance is configured with some configuration, that would be used to configure the created builder instances.

    JsonObjectBuilder and JsonArrayBuilder can also be created using Json's methods. If multiple builder instances are created, then creating them using a builder factory is preferred.

    For example:

 JsonBuilderFactory factory = Json.createBuilderFactory(...);
 JsonArray value = factory.createArrayBuilder()
     .add(factory.createObjectBuilder()
         .add("type", "home")
         .add("number", "212 555-1234"))
     .add(factory.createObjectBuilder()
         .add("type", "fax")
         .add("number", "646 555-4567"))
     .build();

    All the methods in this class are safe for use by multiple concurrent threads.

    Author:
    Jitendra Kotamraju

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JsonArrayBuilder createArrayBuilder()
      Creates a JsonArrayBuilder instance that is used to build JsonArray
      JsonObjectBuilder createObjectBuilder()
      Creates a JsonObjectBuilder instance that is used to build JsonObject.
      Map<String,?> getConfigInUse()
      Returns read-only map of supported provider specific configuration properties that are used to configure the created JSON builders.

    • Method Detail

      • createObjectBuilder

        JsonObjectBuilder createObjectBuilder()
        Creates a JsonObjectBuilder instance that is used to build JsonObject.
        Returns:
        a JSON object builder

      • createArrayBuilder

        JsonArrayBuilder createArrayBuilder()
        Creates a JsonArrayBuilder instance that is used to build JsonArray
        Returns:
        a JSON array builder

      • getConfigInUse

        Map<String,?> getConfigInUse()
        Returns read-only map of supported provider specific configuration properties that are used to configure the created JSON builders. If there are any specified configuration properties that are not supported by the provider, they won't be part of the returned map.
        Returns:
        a map of supported provider specific properties that are used to configure the builders. The map be empty but not null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Class JsonException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.json.JsonException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    JsonGenerationException, JsonParsingException

    public class JsonException
extends RuntimeException
    JsonException indicates that some exception happened during JSON processing.
    Author:
    Jitendra Kotamraju
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JsonException(String message)
      Constructs a new runtime exception with the specified detail message.
      JsonException(String message, Throwable cause)
      Constructs a new runtime exception with the specified detail message and cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JsonException

        public JsonException(String message)
        Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).
        Parameters:
        message - the detail message. The detail message is saved for later retrieval by the Throwable.getMessage() method.

      • JsonException

        public JsonException(String message,
             Throwable cause)
        Constructs a new runtime exception with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.

        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonNumber (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonNumber

  • All Superinterfaces:
    JsonValue

    public interface JsonNumber
extends JsonValue
    An immutable JSON number value.

    Implementations may use a BigDecimal object to store the numeric value internally. The BigDecimal object can be constructed from the following types: int, long, BigInteger, double, and String. Some of the method semantics in this class are defined using the BigDecimal semantics.

    Author:
    Jitendra Kotamraju

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.json.JsonValue

        JsonValue.ValueType

    • Field Summary

      • Fields inherited from interface javax.json.JsonValue

        FALSE, NULL, TRUE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      BigDecimal bigDecimalValue()
      Returns this JSON number as a BigDecimal object.
      BigInteger bigIntegerValue()
      Returns this JSON number as a BigInteger object.
      BigInteger bigIntegerValueExact()
      Returns this JSON number as a BigDecimal object.
      double doubleValue()
      Returns this JSON number as a double.
      boolean equals(Object obj)
      Compares the specified object with this JsonNumber object for equality.
      int hashCode()
      Returns the hash code value for this JsonNumber object.
      int intValue()
      Returns this JSON number as an int.
      int intValueExact()
      Returns this JSON number as an int.
      boolean isIntegral()
      Returns true if this JSON number is a integral number.
      long longValue()
      Returns this JSON number as a long.
      long longValueExact()
      Returns this JSON number as a long.
      String toString()
      Returns a JSON text representation of the JSON number.

      • Methods inherited from interface javax.json.JsonValue

        getValueType

    • Method Detail

      • isIntegral

        boolean isIntegral()
        Returns true if this JSON number is a integral number. This method semantics are defined using bigDecimalValue().scale(). If the scale is zero, then it is considered integral type. This integral type information can be used to invoke an appropriate accessor method to obtain a numeric value as in the following example:

 JsonNumber num = ...
 if (num.isIntegral()) {
     num.longValue();     // or other methods to get integral value
 } else {
     num.doubleValue();   // or other methods to get decimal number value
 }
        Returns:
        true if this number is a integral number, otherwise false

      • intValue

        int intValue()
        Returns this JSON number as an int. Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign.
        Returns:
        an int representation of the JSON number
        See Also:
        BigDecimal.intValue()

      • intValueExact

        int intValueExact()
        Returns this JSON number as an int.
        Returns:
        an int representation of the JSON number
        Throws:
        ArithmeticException - if the number has a nonzero fractional part or if it does not fit in an int
        See Also:
        BigDecimal.intValueExact()

      • longValue

        long longValue()
        Returns this JSON number as a long. Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign.
        Returns:
        a long representation of the JSON number.
        See Also:
        BigDecimal.longValue()

      • longValueExact

        long longValueExact()
        Returns this JSON number as a long.
        Returns:
        a long representation of the JSON number
        Throws:
        ArithmeticException - if the number has a non-zero fractional part or if it does not fit in a long
        See Also:
        BigDecimal.longValueExact()

      • bigIntegerValue

        BigInteger bigIntegerValue()
        Returns this JSON number as a BigInteger object. This is a a convenience method for bigDecimalValue().toBigInteger(). Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign.
        Returns:
        a BigInteger representation of the JSON number.
        See Also:
        BigDecimal.toBigInteger()

      • bigIntegerValueExact

        BigInteger bigIntegerValueExact()
        Returns this JSON number as a BigDecimal object. This is a convenience method for bigDecimalValue().toBigIntegerExact().
        Returns:
        a BigInteger representation of the JSON number
        Throws:
        ArithmeticException - if the number has a nonzero fractional part
        See Also:
        BigDecimal.toBigIntegerExact()

      • doubleValue

        double doubleValue()
        Returns this JSON number as a double. This is a a convenience method for bigDecimalValue().doubleValue(). Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign.
        Returns:
        a double representation of the JSON number
        See Also:
        BigDecimal.doubleValue()

      • bigDecimalValue

        BigDecimal bigDecimalValue()
        Returns this JSON number as a BigDecimal object.
        Returns:
        a BigDecimal representation of the JSON number

      • toString

        String toString()
        Returns a JSON text representation of the JSON number. The representation is equivalent to BigDecimal.toString().
        Specified by:
        toString in interface JsonValue
        Overrides:
        toString in class Object
        Returns:
        JSON text representation of the number

      • equals

        boolean equals(Object obj)
        Compares the specified object with this JsonNumber object for equality. Returns true if and only if the type of the specified object is also JsonNumber and their bigDecimalValue() objects are equal
        Overrides:
        equals in class Object
        Parameters:
        obj - the object to be compared for equality with this JsonNumber
        Returns:
        true if the specified object is equal to this JsonNumber

      • hashCode

        int hashCode()
        Returns the hash code value for this JsonNumber object. The hash code of a JsonNumber object is defined as the hash code of its bigDecimalValue() object.
        Overrides:
        hashCode in class Object
        Returns:
        the hash code value for this JsonNumber object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonObject

  • All Superinterfaces:
    JsonStructure, JsonValue, Map<String,JsonValue>

    public interface JsonObject
extends JsonStructure, Map<String,JsonValue>
    JsonObject class represents an immutable JSON object value (an unordered collection of zero or more name/value pairs). It also provides unmodifiable map view to the JSON object name/value mappings.

    A JsonObject instance can be created from an input source using JsonReader.readObject(). For example:

 JsonReader jsonReader = Json.createReader(...);
 JsonObject object = jsonReader.readObject();
 jsonReader.close();
    It can also be built from scratch using a JsonObjectBuilder.

    For example 1: An empty JSON object can be built as follows:

 JsonObject object = Json.createObjectBuilder().build();
    For example 2: The following JSON

 {
     "firstName": "John", "lastName": "Smith", "age": 25,
     "address" : {
         "streetAddress": "21 2nd Street",
         "city": "New York",
         "state": "NY",
         "postalCode": "10021"
     },
     "phoneNumber": [
         { "type": "home", "number": "212 555-1234" },
         { "type": "fax", "number": "646 555-4567" }
     ]
 }
    can be built using :

 JsonObject value = Json.createObjectBuilder()
     .add("firstName", "John")
     .add("lastName", "Smith")
     .add("age", 25)
     .add("address", Json.createObjectBuilder()
         .add("streetAddress", "21 2nd Street")
         .add("city", "New York")
         .add("state", "NY")
         .add("postalCode", "10021"))
     .add("phoneNumber", Json.createArrayBuilder()
         .add(Json.createObjectBuilder()
             .add("type", "home")
             .add("number", "212 555-1234"))
         .add(Json.createObjectBuilder()
             .add("type", "fax")
             .add("number", "646 555-4567")))
     .build();
    JsonObject can be written to JSON as follows:

 JsonWriter writer = ...
 JsonObject obj = ...;
 writer.writeObject(obj);
    JsonObject values can be JsonObject, JsonArray, JsonString, JsonNumber, JsonValue.TRUE, JsonValue.FALSE, JsonValue.NULL. These values can be accessed using various accessor methods.

    In the above example 2, "John" can be got using

 String firstName = object.getString("firstName");
    This map object provides read-only access to the JSON object data, and attempts to modify the map, whether direct or via its collection views, result in an UnsupportedOperationException.

    The map object's iteration ordering is based on the order in which name/value pairs are added to the corresponding builder or the order in which name/value pairs appear in the corresponding stream.

    Author:
    Jitendra Kotamraju

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.json.JsonValue

        JsonValue.ValueType

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      • Fields inherited from interface javax.json.JsonValue

        FALSE, NULL, TRUE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean getBoolean(String name)
      Returns the boolean value of the associated mapping for the specified name.
      boolean getBoolean(String name, boolean defaultValue)
      Returns the boolean value of the associated mapping for the specified name.
      int getInt(String name)
      A convenience method for getJsonNumber(name).intValue()
      int getInt(String name, int defaultValue)
      Returns the int value of the associated JsonNumber mapping for the specified name.
      JsonArray getJsonArray(String name)
      Returns the array value to which the specified name is mapped.
      JsonNumber getJsonNumber(String name)
      Returns the number value to which the specified name is mapped.
      JsonObject getJsonObject(String name)
      Returns the object value to which the specified name is mapped.
      JsonString getJsonString(String name)
      Returns the string value to which the specified name is mapped.
      String getString(String name)
      A convenience method for getJsonString(name).getString()
      String getString(String name, String defaultValue)
      Returns the string value of the associated JsonString mapping for the specified name.
      boolean isNull(String name)
      Returns true if the associated value for the specified name is JsonValue.NULL.

      • Methods inherited from interface javax.json.JsonValue

        getValueType, toString

      • Methods inherited from interface java.util.Map

        clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

    • Method Detail

      • getJsonArray

        JsonArray getJsonArray(String name)
        Returns the array value to which the specified name is mapped. This is a convenience method for (JsonArray)get(name) to get the value.
        Parameters:
        name - the name whose associated value is to be returned
        Returns:
        the array value to which the specified name is mapped, or null if this object contains no mapping for the name
        Throws:
        ClassCastException - if the value to which the specified name is mapped is not assignable to JsonArray type

      • getJsonObject

        JsonObject getJsonObject(String name)
        Returns the object value to which the specified name is mapped. This is a convenience method for (JsonObject)get(name) to get the value.
        Parameters:
        name - the name whose associated value is to be returned
        Returns:
        the object value to which the specified name is mapped, or null if this object contains no mapping for the name
        Throws:
        ClassCastException - if the value to which the specified name is mapped is not assignable to JsonObject type

      • getJsonNumber

        JsonNumber getJsonNumber(String name)
        Returns the number value to which the specified name is mapped. This is a convenience method for (JsonNumber)get(name) to get the value.
        Parameters:
        name - the name whose associated value is to be returned
        Returns:
        the number value to which the specified name is mapped, or null if this object contains no mapping for the name
        Throws:
        ClassCastException - if the value to which the specified name is mapped is not assignable to JsonNumber type

      • getJsonString

        JsonString getJsonString(String name)
        Returns the string value to which the specified name is mapped. This is a convenience method for (JsonString)get(name) to get the value.
        Parameters:
        name - the name whose associated value is to be returned
        Returns:
        the string value to which the specified name is mapped, or null if this object contains no mapping for the name
        Throws:
        ClassCastException - if the value to which the specified name is mapped is not assignable to JsonString type

      • getString

        String getString(String name)
        A convenience method for getJsonString(name).getString()
        Parameters:
        name - whose associated value is to be returned as String
        Returns:
        the String value to which the specified name is mapped
        Throws:
        NullPointerException - if the specified name doesn't have any mapping
        ClassCastException - if the value for specified name mapping is not assignable to JsonString

      • getString

        String getString(String name,
               String defaultValue)
        Returns the string value of the associated JsonString mapping for the specified name. If JsonString is found, then its JsonString.getString() is returned. Otherwise, the specified default value is returned.
        Parameters:
        name - whose associated value is to be returned as String
        defaultValue - a default value to be returned
        Returns:
        the string value of the associated mapping for the name, or the default value

      • getInt

        int getInt(String name)
        A convenience method for getJsonNumber(name).intValue()
        Parameters:
        name - whose associated value is to be returned as int
        Returns:
        the int value to which the specified name is mapped
        Throws:
        NullPointerException - if the specified name doesn't have any mapping
        ClassCastException - if the value for specified name mapping is not assignable to JsonNumber

      • getInt

        int getInt(String name,
         int defaultValue)
        Returns the int value of the associated JsonNumber mapping for the specified name. If JsonNumber is found, then its JsonNumber.intValue() is returned. Otherwise, the specified default value is returned.
        Parameters:
        name - whose associated value is to be returned as int
        defaultValue - a default value to be returned
        Returns:
        the int value of the associated mapping for the name, or the default value

      • getBoolean

        boolean getBoolean(String name)
        Returns the boolean value of the associated mapping for the specified name. If the associated mapping is JsonValue.TRUE, then returns true. If the associated mapping is JsonValue.FALSE, then returns false.
        Parameters:
        name - whose associated value is to be returned as boolean
        Returns:
        the boolean value to which the specified name is mapped
        Throws:
        NullPointerException - if the specified name doesn't have any mapping
        ClassCastException - if the value for specified name mapping is not assignable to JsonValue.TRUE or JsonValue.FALSE

      • getBoolean

        boolean getBoolean(String name,
                 boolean defaultValue)
        Returns the boolean value of the associated mapping for the specified name. If the associated mapping is JsonValue.TRUE, then returns true. If the associated mapping is JsonValue.FALSE, then returns false. Otherwise, the specified default value is returned.
        Parameters:
        name - whose associated value is to be returned as int
        defaultValue - a default value to be returned
        Returns:
        the boolean value of the associated mapping for the name, or the default value

      • isNull

        boolean isNull(String name)
        Returns true if the associated value for the specified name is JsonValue.NULL.
        Parameters:
        name - name whose associated value is checked
        Returns:
        return true if the associated value is JsonValue.NUL, otherwise false
        Throws:
        NullPointerException - if the specified name doesn't have any mapping
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonObjectBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonObjectBuilder

  • public interface JsonObjectBuilder
    A builder for creating JsonObject models from scratch. This interface initializes an empty JSON object model and provides methods to add name/value pairs to the object model and to return the resulting object. The methods in this class can be chained to add multiple name/value pairs to the object.

    The class Json contains methods to create the builder object. The example code below shows how to build an empty JsonObject instance.

 JsonObject object = Json.createObjectBuilder().build();

    The class JsonBuilderFactory also contains methods to create JsonObjectBuilder instances. A factory instance can be used to create multiple builder instances with the same configuration. This the preferred way to create multiple instances. The example code below shows how to build a JsonObject model that represents the following JSON object:

 {
     "firstName": "John", "lastName": "Smith", "age": 25,
     "address" : {
         "streetAddress": "21 2nd Street",
         "city": "New York",
         "state": "NY",
         "postalCode": "10021"
     },
     "phoneNumber": [
         { "type": "home", "number": "212 555-1234" },
         { "type": "fax", "number": "646 555-4567" }
     ]
 }

    The code to create the object shown above is the following:

 JsonBuilderFactory factory = Json.createBuilderFactory(config);
 JsonObject value = factory.createObjectBuilder()
     .add("firstName", "John")
     .add("lastName", "Smith")
     .add("age", 25)
     .add("address", factory.createObjectBuilder()
         .add("streetAddress", "21 2nd Street")
         .add("city", "New York")
         .add("state", "NY")
         .add("postalCode", "10021"))
     .add("phoneNumber", factory.createArrayBuilder()
         .add(factory.createObjectBuilder()
             .add("type", "home")
             .add("number", "212 555-1234"))
         .add(factory.createObjectBuilder()
             .add("type", "fax")
             .add("number", "646 555-4567")))
     .build();

    This class does not allow null to be used as a name or value while building the JSON object

    See Also:
    JsonArrayBuilder

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JsonObjectBuilder add(String name, BigDecimal value)
      Adds a name/JsonNumber pair to the JSON object associated with this object builder.
      JsonObjectBuilder add(String name, BigInteger value)
      Adds a name/JsonNumber pair to the JSON object associated with this object builder.
      JsonObjectBuilder add(String name, boolean value)
      Adds a name/JsonValue#TRUE or name/JsonValue#FALSE pair to the JSON object associated with this object builder.
      JsonObjectBuilder add(String name, double value)
      Adds a name/JsonNumber pair to the JSON object associated with this object builder.
      JsonObjectBuilder add(String name, int value)
      Adds a name/JsonNumber pair to the JSON object associated with this object builder.
      JsonObjectBuilder add(String name, JsonArrayBuilder builder)
      Adds a name/JsonArray pair to the JSON object associated with this object builder.
      JsonObjectBuilder add(String name, JsonObjectBuilder builder)
      Adds a name/JsonObject pair to the JSON object associated with this object builder.
      JsonObjectBuilder add(String name, JsonValue value)
      Adds a name/JsonValue pair to the JSON object associated with this object builder.
      JsonObjectBuilder add(String name, long value)
      Adds a name/JsonNumber pair to the JSON object associated with this object builder.
      JsonObjectBuilder add(String name, String value)
      Adds a name/JsonString pair to the JSON object associated with this object builder.
      JsonObjectBuilder addNull(String name)
      Adds a name/JsonValue#NULL pair to the JSON object associated with this object builder where the value is null.
      JsonObject build()
      Returns the JSON object associated with this object builder.

    • Method Detail

      • add

        JsonObjectBuilder add(String name,
                    JsonValue value)
        Adds a name/JsonValue pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.
        Parameters:
        name - name in the name/value pair
        value - value in the name/value pair
        Returns:
        this object builder
        Throws:
        NullPointerException - if the specified name or value is null

      • add

        JsonObjectBuilder add(String name,
                    String value)
        Adds a name/JsonString pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.
        Parameters:
        name - name in the name/value pair
        value - value in the name/value pair
        Returns:
        this object builder
        Throws:
        NullPointerException - if the specified name or value is null

      • add

        JsonObjectBuilder add(String name,
                    BigInteger value)
        Adds a name/JsonNumber pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.
        Parameters:
        name - name in the name/value pair
        value - value in the name/value pair
        Returns:
        this object builder
        Throws:
        NullPointerException - if the specified name or value is null
        See Also:
        JsonNumber

      • add

        JsonObjectBuilder add(String name,
                    BigDecimal value)
        Adds a name/JsonNumber pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.
        Parameters:
        name - name in the name/value pair
        value - value in the name/value pair
        Returns:
        this object builder
        Throws:
        NullPointerException - if the specified name or value is null
        See Also:
        JsonNumber

      • add

        JsonObjectBuilder add(String name,
                    int value)
        Adds a name/JsonNumber pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.
        Parameters:
        name - name in the name/value pair
        value - value in the name/value pair
        Returns:
        this object builder
        Throws:
        NullPointerException - if the specified name is null
        See Also:
        JsonNumber

      • add

        JsonObjectBuilder add(String name,
                    long value)
        Adds a name/JsonNumber pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.
        Parameters:
        name - name in the name/value pair
        value - value in the name/value pair
        Returns:
        this object builder
        Throws:
        NullPointerException - if the specified name is null
        See Also:
        JsonNumber

      • add

        JsonObjectBuilder add(String name,
                    double value)
        Adds a name/JsonNumber pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.
        Parameters:
        name - name in the name/value pair
        value - value in the name/value pair
        Returns:
        this object builder
        Throws:
        NumberFormatException - if the value is Not-a-Number(NaN) or infinity
        NullPointerException - if the specified name is null
        See Also:
        JsonNumber

      • add

        JsonObjectBuilder add(String name,
                    boolean value)
        Adds a name/JsonValue#TRUE or name/JsonValue#FALSE pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.
        Parameters:
        name - name in the name/value pair
        value - value in the name/value pair
        Returns:
        this object builder
        Throws:
        NullPointerException - if the specified name is null

      • addNull

        JsonObjectBuilder addNull(String name)
        Adds a name/JsonValue#NULL pair to the JSON object associated with this object builder where the value is null. If the object contains a mapping for the specified name, this method replaces the old value with null.
        Parameters:
        name - name in the name/value pair
        Returns:
        this object builder
        Throws:
        NullPointerException - if the specified name is null

      • add

        JsonObjectBuilder add(String name,
                    JsonObjectBuilder builder)
        Adds a name/JsonObject pair to the JSON object associated with this object builder. The value JsonObject is built from the specified object builder. If the object contains a mapping for the specified name, this method replaces the old value with the JsonObject from the specified object builder.
        Parameters:
        name - name in the name/value pair
        builder - the value is the object associated with this builder
        Returns:
        this object builder
        Throws:
        NullPointerException - if the specified name or builder is null

      • add

        JsonObjectBuilder add(String name,
                    JsonArrayBuilder builder)
        Adds a name/JsonArray pair to the JSON object associated with this object builder. The value JsonArray is built from the specified array builder. If the object contains a mapping for the specified name, this method replaces the old value with the JsonArray from the specified array builder.
        Parameters:
        name - the name in the name/value pair
        builder - the value is the object array with this builder
        Returns:
        this object builder
        Throws:
        NullPointerException - if the specified name or builder is null

      • build

        JsonObject build()
        Returns the JSON object associated with this object builder. The iteration order for the JsonObject is based on the order in which name/value pairs are added to the object using this builder.
        Returns:
        JSON object that is being built
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonReader (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonReader

  • All Superinterfaces:
    AutoCloseable, Closeable

    public interface JsonReader
extends Closeable
    Reads a JSON object or an array structure from an input source.

    The class Json contains methods to create readers from input sources (InputStream and Reader).

    The following example demonstrates how to read an empty JSON array from a string:

 JsonReader jsonReader = Json.createReader(new StringReader("[]"));
 JsonArray array = jsonReader.readArray();
 jsonReader.close();

    The class JsonReaderFactory also contains methods to create JsonReader instances. A factory instance can be used to create multiple reader instances with the same configuration. This the preferred way to create multiple instances. A sample usage is shown in the following example:

 JsonReaderFactory factory = Json.createReaderFactory(config);
 JsonReader reader1 = factory.createReader(...);
 JsonReader reader2 = factory.createReader(...);
    Author:
    Jitendra Kotamraju

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes this reader and frees any resources associated with the reader.
      JsonStructure read()
      Returns a JSON array or object that is represented in the input source.
      JsonArray readArray()
      Returns a JSON array that is represented in the input source.
      JsonObject readObject()
      Returns a JSON object that is represented in the input source.

    • Method Detail

      • read

        JsonStructure read()
        Returns a JSON array or object that is represented in the input source. This method needs to be called only once for a reader instance.
        Returns:
        a JSON object or array
        Throws:
        JsonException - if a JSON object or array cannot be created due to i/o error (IOException would be cause of JsonException)
        JsonParsingException - if a JSON object or array cannot be created due to incorrect representation
        IllegalStateException - if read, readObject, readArray or close method is already called

      • readObject

        JsonObject readObject()
        Returns a JSON object that is represented in the input source. This method needs to be called only once for a reader instance.
        Returns:
        a JSON object
        Throws:
        JsonException - if a JSON object cannot be created due to i/o error (IOException would be cause of JsonException)
        JsonParsingException - if a JSON object cannot be created due to incorrect representation
        IllegalStateException - if read, readObject, readArray or close method is already called

      • readArray

        JsonArray readArray()
        Returns a JSON array that is represented in the input source. This method needs to be called only once for a reader instance.
        Returns:
        a JSON array
        Throws:
        JsonException - if a JSON array cannot be created due to i/o error (IOException would be cause of JsonException)
        JsonParsingException - if a JSON array cannot be created due to incorrect representation
        IllegalStateException - if read, readObject, readArray or close method is already called

      • close

        void close()
        Closes this reader and frees any resources associated with the reader. This method closes the underlying input source.
        Specified by:
        close in interface AutoCloseable
        Specified by:
        close in interface Closeable
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonReaderFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonReaderFactory

  • public interface JsonReaderFactory
    Factory to create JsonReader instances. If a factory instance is configured with some configuration, that would be used to configure the created reader instances.

    JsonReader can also be created using Json's createReader methods. If multiple reader instances are created, then creating them using a reader factory is preferred.

    For example:

 JsonReaderFactory factory = Json.createReaderFactory(...);
 JsonReader reader1 = factory.createReader(...);
 JsonReader reader2 = factory.createReader(...);

    All the methods in this class are safe for use by multiple concurrent threads.

    Author:
    Jitendra Kotamraju

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JsonReader createReader(InputStream in)
      Creates a JSON reader from a byte stream.
      JsonReader createReader(InputStream in, Charset charset)
      Creates a JSON reader from a byte stream.
      JsonReader createReader(Reader reader)
      Creates a JSON reader from a character stream.
      Map<String,?> getConfigInUse()
      Returns read-only map of supported provider specific configuration properties that are used to configure the created JSON readers.

    • Method Detail

      • createReader

        JsonReader createReader(Reader reader)
        Creates a JSON reader from a character stream. The reader is configured with the factory configuration.
        Parameters:
        reader - a reader from which JSON is to be read
        Returns:
        a JSON reader

      • createReader

        JsonReader createReader(InputStream in)
        Creates a JSON reader from a byte stream. The character encoding of the stream is determined as described in RFC 4627. The reader is configured with the factory configuration.
        Parameters:
        in - a byte stream from which JSON is to be read
        Returns:
        a JSON reader

      • createReader

        JsonReader createReader(InputStream in,
                      Charset charset)
        Creates a JSON reader from a byte stream. The bytes of the stream are decoded to characters using the specified charset. The reader is configured with the factory configuration.
        Parameters:
        in - a byte stream from which JSON is to be read
        charset - a charset
        Returns:
        a JSON reader

      • getConfigInUse

        Map<String,?> getConfigInUse()
        Returns read-only map of supported provider specific configuration properties that are used to configure the created JSON readers. If there are any specified configuration properties that are not supported by the provider, they won't be part of the returned map.
        Returns:
        a map of supported provider specific properties that are used to configure the readers. The map be empty but not null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonString (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonString

  • All Superinterfaces:
    JsonValue

    public interface JsonString
extends JsonValue
    An immutable JSON string value.
    Author:
    Jitendra Kotamraju

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.json.JsonValue

        JsonValue.ValueType

    • Field Summary

      • Fields inherited from interface javax.json.JsonValue

        FALSE, NULL, TRUE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Compares the specified object with this JsonString for equality.
      CharSequence getChars()
      Returns the char sequence for the JSON String value
      String getString()
      Returns the JSON string value.
      int hashCode()
      Returns the hash code value for this JsonString object.

      • Methods inherited from interface javax.json.JsonValue

        getValueType, toString

    • Method Detail

      • getString

        String getString()
        Returns the JSON string value.
        Returns:
        a JSON string value

      • getChars

        CharSequence getChars()
        Returns the char sequence for the JSON String value
        Returns:
        a char sequence for the JSON String value

      • equals

        boolean equals(Object obj)
        Compares the specified object with this JsonString for equality. Returns true if and only if the specified object is also a JsonString, and their getString() objects are equal.
        Overrides:
        equals in class Object
        Parameters:
        obj - the object to be compared for equality with this JsonString
        Returns:
        true if the specified object is equal to this JsonString

      • hashCode

        int hashCode()
        Returns the hash code value for this JsonString object. The hash code of a JsonString object is defined to be its getString() object's hash code.
        Overrides:
        hashCode in class Object
        Returns:
        the hash code value for this JsonString object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonStructure (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonStructure

  • All Superinterfaces:
    JsonValue
    All Known Subinterfaces:
    JsonArray, JsonObject

    public interface JsonStructure
extends JsonValue
    Super type for the two structured types in JSON (objects and arrays).
    Author:
    Jitendra Kotamraju

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.json.JsonValue

        JsonValue.ValueType

    • Field Summary

      • Fields inherited from interface javax.json.JsonValue

        FALSE, NULL, TRUE

    • Method Summary

      • Methods inherited from interface javax.json.JsonValue

        getValueType, toString
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonValue (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonValue

  • All Known Subinterfaces:
    JsonArray, JsonNumber, JsonObject, JsonString, JsonStructure

    public interface JsonValue
    JsonValue represents an immutable JSON value.

    A JSON value is one of the following: an object (JsonObject), an array (JsonArray), a number (JsonNumber), a string (JsonString), true (JsonValue.TRUE), false (JsonValue.FALSE), or null (JsonValue.NULL).

    Author:
    Jitendra Kotamraju

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  JsonValue.ValueType
      Indicates the type of a JsonValue object.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static JsonValue FALSE
      JSON false value
      static JsonValue NULL
      JSON null value.
      static JsonValue TRUE
      JSON true value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JsonValue.ValueType getValueType()
      Returns the value type of this JSON value.
      String toString()
      Returns JSON text for this JSON value.

    • Field Detail

      • NULL

        static final JsonValue NULL
        JSON null value.

      • TRUE

        static final JsonValue TRUE
        JSON true value.

      • FALSE

        static final JsonValue FALSE
        JSON false value

    • Method Detail

      • getValueType

        JsonValue.ValueType getValueType()
        Returns the value type of this JSON value.
        Returns:
        JSON value type

      • toString

        String toString()
        Returns JSON text for this JSON value.
        Overrides:
        toString in class Object
        Returns:
        JSON text
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonValue.ValueType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.json

Enum JsonValue.ValueType

  • java.lang.Object
    • java.lang.Enum<JsonValue.ValueType>
      • javax.json.JsonValue.ValueType
  • All Implemented Interfaces:
    Serializable, Comparable<JsonValue.ValueType>
    Enclosing interface:
    JsonValue

    public static enum JsonValue.ValueType
extends Enum<JsonValue.ValueType>
    Indicates the type of a JsonValue object.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ARRAY
      JSON array.
      FALSE
      JSON false.
      NULL
      JSON null.
      NUMBER
      JSON number.
      OBJECT
      JSON object.
      STRING
      JSON string.
      TRUE
      JSON true.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static JsonValue.ValueType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JsonValue.ValueType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ARRAY

        public static final JsonValue.ValueType ARRAY
        JSON array.

      • OBJECT

        public static final JsonValue.ValueType OBJECT
        JSON object.

      • STRING

        public static final JsonValue.ValueType STRING
        JSON string.

      • NUMBER

        public static final JsonValue.ValueType NUMBER
        JSON number.

      • TRUE

        public static final JsonValue.ValueType TRUE
        JSON true.

      • FALSE

        public static final JsonValue.ValueType FALSE
        JSON false.

      • NULL

        public static final JsonValue.ValueType NULL
        JSON null.

    • Method Detail

      • values

        public static JsonValue.ValueType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (JsonValue.ValueType c : JsonValue.ValueType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static JsonValue.ValueType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


JsonWriter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonWriter

  • All Superinterfaces:
    AutoCloseable, Closeable

    public interface JsonWriter
extends Closeable
    Writes a JSON object or array structure to an output source.

    The class Json contains methods to create writers from output sources (OutputStream and Writer).

    The following example demonstrates how write an empty JSON object:

 JsonWriter jsonWriter = Json.createWriter(...);
 jsonWriter.writeObject(Json.createObjectBuilder().build());
 jsonWriter.close();

    The class JsonWriterFactory also contains methods to create JsonWriter instances. A factory instance can be used to create multiple writer instances with the same configuration. This the preferred way to create multiple instances. A sample usage is shown in the following example:

 JsonWriterFactory factory = Json.createWriterFactory(config);
 JsonWriter writer1 = factory.createWriter(...);
 JsonWriter writer2 = factory.createWriter(...);
    Author:
    Jitendra Kotamraju

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes this JSON writer and frees any resources associated with the writer.
      void write(JsonStructure value)
      Writes the specified JSON object or array to the output source.
      void writeArray(JsonArray array)
      Writes the specified JSON array to the output source.
      void writeObject(JsonObject object)
      Writes the specified JSON object to the output source.

    • Method Detail

      • writeArray

        void writeArray(JsonArray array)
        Writes the specified JSON array to the output source. This method needs to be called only once for a writer instance.
        Parameters:
        array - JSON array that is to be written to the output source
        Throws:
        JsonException - if the specified JSON object cannot be written due to i/o error (IOException would be cause of JsonException)
        IllegalStateException - if writeArray, writeObject, write or close method is already called

      • writeObject

        void writeObject(JsonObject object)
        Writes the specified JSON object to the output source. This method needs to be called only once for a writer instance.
        Parameters:
        object - JSON object that is to be written to the output source
        Throws:
        JsonException - if the specified JSON object cannot be written due to i/o error (IOException would be cause of JsonException)
        IllegalStateException - if writeArray, writeObject, write or close method is already called

      • write

        void write(JsonStructure value)
        Writes the specified JSON object or array to the output source. This method needs to be called only once for a writer instance.
        Parameters:
        value - JSON array or object that is to be written to the output source
        Throws:
        JsonException - if the specified JSON object cannot be written due to i/o error (IOException would be cause of JsonException)
        IllegalStateException - if writeArray, writeObject, write or close method is already called

      • close

        void close()
        Closes this JSON writer and frees any resources associated with the writer. This method closes the underlying output source.
        Specified by:
        close in interface AutoCloseable
        Specified by:
        close in interface Closeable
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonWriterFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json

Interface JsonWriterFactory

  • public interface JsonWriterFactory
    Factory to create JsonWriter instances. If a factory instance is configured with some configuration, that would be used to configure the created writer instances.

    JsonWriter can also be created using Json's createWriter methods. If multiple writer instances are created, then creating them using a writer factory is preferred.

    For example:

 JsonWriterFactory factory = Json.createWriterFactory(...);
 JsonWriter writer1 = factory.createWriter(...);
 JsonWriter writer2 = factory.createWriter(...);

    All the methods in this class are safe for use by multiple concurrent threads.

    Author:
    Jitendra Kotamraju

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JsonWriter createWriter(OutputStream out)
      Creates a JSON writer to write a JSON object or array structure to the specified byte stream.
      JsonWriter createWriter(OutputStream out, Charset charset)
      Creates a JSON writer to write a JSON object or array structure to the specified byte stream.
      JsonWriter createWriter(Writer writer)
      Creates a JSON writer to write a JSON object or array structure to the specified character stream.
      Map<String,?> getConfigInUse()
      Returns read-only map of supported provider specific configuration properties that are used to configure the created JSON writer objects.

    • Method Detail

      • createWriter

        JsonWriter createWriter(Writer writer)
        Creates a JSON writer to write a JSON object or array structure to the specified character stream. The writer is configured with the factory configuration.
        Parameters:
        writer - to which JSON object or array is written
        Returns:
        a JSON writer

      • createWriter

        JsonWriter createWriter(OutputStream out)
        Creates a JSON writer to write a JSON object or array structure to the specified byte stream. Characters written to the stream are encoded into bytes using UTF-8 encoding. The writer is configured with the factory configuration.
        Parameters:
        out - to which JSON object or array is written
        Returns:
        a JSON writer

      • createWriter

        JsonWriter createWriter(OutputStream out,
                      Charset charset)
        Creates a JSON writer to write a JSON object or array structure to the specified byte stream. Characters written to the stream are encoded into bytes using the specified charset. The writer is configured with the factory configuration.
        Parameters:
        out - to which JSON object or array is written
        charset - a charset
        Returns:
        a JSON writer

      • getConfigInUse

        Map<String,?> getConfigInUse()
        Returns read-only map of supported provider specific configuration properties that are used to configure the created JSON writer objects. If there are any specified configuration properties that are not supported by the provider, they won't be part of the returned map.
        Returns:
        a map of supported provider specific properties that are used to configure the created writers. The map may be empty but not null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.json (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.json

  • Packages that use javax.json
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.
    javax.json.stream
    Provides a streaming API to parse and generate JSON.
  • Classes in javax.json used by javax.json
    Class and Description
    JsonArray
    JsonArray represents an immutable JSON array (an ordered sequence of zero or more values).
    JsonArrayBuilder
    A builder for creating JsonArray models from scratch.
    JsonBuilderFactory
    Factory to create JsonObjectBuilder and JsonArrayBuilder instances.
    JsonNumber
    An immutable JSON number value.
    JsonObject
    JsonObject class represents an immutable JSON object value (an unordered collection of zero or more name/value pairs).
    JsonObjectBuilder
    A builder for creating JsonObject models from scratch.
    JsonReader
    Reads a JSON object or an array structure from an input source.
    JsonReaderFactory
    Factory to create JsonReader instances.
    JsonString
    An immutable JSON string value.
    JsonStructure
    Super type for the two structured types in JSON (objects and arrays).
    JsonValue
    JsonValue represents an immutable JSON value.
    JsonValue.ValueType
    Indicates the type of a JsonValue object.
    JsonWriter
    Writes a JSON object or array structure to an output source.
    JsonWriterFactory
    Factory to create JsonWriter instances.
  • Classes in javax.json used by javax.json.spi
    Class and Description
    JsonArrayBuilder
    A builder for creating JsonArray models from scratch.
    JsonBuilderFactory
    Factory to create JsonObjectBuilder and JsonArrayBuilder instances.
    JsonObjectBuilder
    A builder for creating JsonObject models from scratch.
    JsonReader
    Reads a JSON object or an array structure from an input source.
    JsonReaderFactory
    Factory to create JsonReader instances.
    JsonWriter
    Writes a JSON object or array structure to an output source.
    JsonWriterFactory
    Factory to create JsonWriter instances.
  • Classes in javax.json used by javax.json.stream
    Class and Description
    JsonArray
    JsonArray represents an immutable JSON array (an ordered sequence of zero or more values).
    JsonException
    JsonException indicates that some exception happened during JSON processing.
    JsonObject
    JsonObject class represents an immutable JSON object value (an unordered collection of zero or more name/value pairs).
    JsonValue
    JsonValue represents an immutable JSON value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.json.Json (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.json.Json

No usage of javax.json.Json
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.json.JsonException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.json.JsonException

  • Packages that use JsonException
    Package Description
    javax.json.stream
    Provides a streaming API to parse and generate JSON.

    • Uses of JsonException in javax.json.stream

      Subclasses of JsonException in javax.json.stream
      Modifier and Type Class and Description
      class  JsonGenerationException
      JsonGenerationException indicates an incorrect JSON is being generated.
      class  JsonParsingException
      JsonParsingException is used when an incorrect JSON is being parsed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.json.JsonValue.ValueType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.json.JsonValue.ValueType

  • Packages that use JsonValue.ValueType
    Package Description
    javax.json
    Provides an object model API to process JSON.

    • Uses of JsonValue.ValueType in javax.json

      Methods in javax.json that return JsonValue.ValueType
      Modifier and Type Method and Description
      JsonValue.ValueType JsonValue.getValueType()
      Returns the value type of this JSON value.
      static JsonValue.ValueType JsonValue.ValueType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JsonValue.ValueType[] JsonValue.ValueType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonArray (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonArray

  • Packages that use JsonArray
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.stream
    Provides a streaming API to parse and generate JSON.

    • Uses of JsonArray in javax.json

      Methods in javax.json that return JsonArray
      Modifier and Type Method and Description
      JsonArray JsonArrayBuilder.build()
      Returns the current array.
      JsonArray JsonArray.getJsonArray(int index)
      Returns the array value at the specified position in this array.
      JsonArray JsonObject.getJsonArray(String name)
      Returns the array value to which the specified name is mapped.
      JsonArray JsonReader.readArray()
      Returns a JSON array that is represented in the input source.
      Methods in javax.json with parameters of type JsonArray
      Modifier and Type Method and Description
      void JsonWriter.writeArray(JsonArray array)
      Writes the specified JSON array to the output source.

    • Uses of JsonArray in javax.json.stream

      Methods in javax.json.stream with parameters of type JsonArray
      Modifier and Type Method and Description
      JsonParser JsonParserFactory.createParser(JsonArray array)
      Creates a JSON parser from the specified JSON array.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonArrayBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonArrayBuilder

  • Packages that use JsonArrayBuilder
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

    • Uses of JsonArrayBuilder in javax.json

      Methods in javax.json that return JsonArrayBuilder
      Modifier and Type Method and Description
      JsonArrayBuilder JsonArrayBuilder.add(BigDecimal value)
      Adds a value to the array as a JsonNumber.
      JsonArrayBuilder JsonArrayBuilder.add(BigInteger value)
      Adds a value to the array as a JsonNumber.
      JsonArrayBuilder JsonArrayBuilder.add(boolean value)
      Adds a JsonValue.TRUE or JsonValue.FALSE value to the array.
      JsonArrayBuilder JsonArrayBuilder.add(double value)
      Adds a value to the array as a JsonNumber.
      JsonArrayBuilder JsonArrayBuilder.add(int value)
      Adds a value to the array as a JsonNumber.
      JsonArrayBuilder JsonArrayBuilder.add(JsonArrayBuilder builder)
      Adds a JsonArray from an array builder to the array.
      JsonArrayBuilder JsonArrayBuilder.add(JsonObjectBuilder builder)
      Adds a JsonObject from an object builder to the array.
      JsonArrayBuilder JsonArrayBuilder.add(JsonValue value)
      Adds a value to the array.
      JsonArrayBuilder JsonArrayBuilder.add(long value)
      Adds a value to the array as a JsonNumber.
      JsonArrayBuilder JsonArrayBuilder.add(String value)
      Adds a value to the array as a JsonString.
      JsonArrayBuilder JsonArrayBuilder.addNull()
      Adds a JsonValue.NULL value to the array.
      JsonArrayBuilder JsonBuilderFactory.createArrayBuilder()
      Creates a JsonArrayBuilder instance that is used to build JsonArray
      static JsonArrayBuilder Json.createArrayBuilder()
      Creates a JSON array builder
      Methods in javax.json with parameters of type JsonArrayBuilder
      Modifier and Type Method and Description
      JsonArrayBuilder JsonArrayBuilder.add(JsonArrayBuilder builder)
      Adds a JsonArray from an array builder to the array.
      JsonObjectBuilder JsonObjectBuilder.add(String name, JsonArrayBuilder builder)
      Adds a name/JsonArray pair to the JSON object associated with this object builder.

    • Uses of JsonArrayBuilder in javax.json.spi

      Methods in javax.json.spi that return JsonArrayBuilder
      Modifier and Type Method and Description
      abstract JsonArrayBuilder JsonProvider.createArrayBuilder()
      Creates a JSON array builder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonBuilderFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonBuilderFactory

  • Packages that use JsonBuilderFactory
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

    • Uses of JsonBuilderFactory in javax.json

      Methods in javax.json that return JsonBuilderFactory
      Modifier and Type Method and Description
      static JsonBuilderFactory Json.createBuilderFactory(Map<String,?> config)
      Creates a builder factory for creating JsonArrayBuilder and JsonObjectBuilder objects.

    • Uses of JsonBuilderFactory in javax.json.spi

      Methods in javax.json.spi that return JsonBuilderFactory
      Modifier and Type Method and Description
      abstract JsonBuilderFactory JsonProvider.createBuilderFactory(Map<String,?> config)
      Creates a builder factory for creating JsonArrayBuilder and JsonObjectBuilder objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonNumber (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonNumber

  • Packages that use JsonNumber
    Package Description
    javax.json
    Provides an object model API to process JSON.

    • Uses of JsonNumber in javax.json

      Methods in javax.json that return JsonNumber
      Modifier and Type Method and Description
      JsonNumber JsonArray.getJsonNumber(int index)
      Returns the number value at the specified position in this array.
      JsonNumber JsonObject.getJsonNumber(String name)
      Returns the number value to which the specified name is mapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonObject

  • Packages that use JsonObject
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.stream
    Provides a streaming API to parse and generate JSON.

    • Uses of JsonObject in javax.json

      Methods in javax.json that return JsonObject
      Modifier and Type Method and Description
      JsonObject JsonObjectBuilder.build()
      Returns the JSON object associated with this object builder.
      JsonObject JsonArray.getJsonObject(int index)
      Returns the object value at the specified position in this array.
      JsonObject JsonObject.getJsonObject(String name)
      Returns the object value to which the specified name is mapped.
      JsonObject JsonReader.readObject()
      Returns a JSON object that is represented in the input source.
      Methods in javax.json with parameters of type JsonObject
      Modifier and Type Method and Description
      void JsonWriter.writeObject(JsonObject object)
      Writes the specified JSON object to the output source.

    • Uses of JsonObject in javax.json.stream

      Methods in javax.json.stream with parameters of type JsonObject
      Modifier and Type Method and Description
      JsonParser JsonParserFactory.createParser(JsonObject obj)
      Creates a JSON parser from the specified JSON object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonObjectBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonObjectBuilder

  • Packages that use JsonObjectBuilder
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

    • Uses of JsonObjectBuilder in javax.json

      Methods in javax.json that return JsonObjectBuilder
      Modifier and Type Method and Description
      JsonObjectBuilder JsonObjectBuilder.add(String name, BigDecimal value)
      Adds a name/JsonNumber pair to the JSON object associated with this object builder.
      JsonObjectBuilder JsonObjectBuilder.add(String name, BigInteger value)
      Adds a name/JsonNumber pair to the JSON object associated with this object builder.
      JsonObjectBuilder JsonObjectBuilder.add(String name, boolean value)
      Adds a name/JsonValue#TRUE or name/JsonValue#FALSE pair to the JSON object associated with this object builder.
      JsonObjectBuilder JsonObjectBuilder.add(String name, double value)
      Adds a name/JsonNumber pair to the JSON object associated with this object builder.
      JsonObjectBuilder JsonObjectBuilder.add(String name, int value)
      Adds a name/JsonNumber pair to the JSON object associated with this object builder.
      JsonObjectBuilder JsonObjectBuilder.add(String name, JsonArrayBuilder builder)
      Adds a name/JsonArray pair to the JSON object associated with this object builder.
      JsonObjectBuilder JsonObjectBuilder.add(String name, JsonObjectBuilder builder)
      Adds a name/JsonObject pair to the JSON object associated with this object builder.
      JsonObjectBuilder JsonObjectBuilder.add(String name, JsonValue value)
      Adds a name/JsonValue pair to the JSON object associated with this object builder.
      JsonObjectBuilder JsonObjectBuilder.add(String name, long value)
      Adds a name/JsonNumber pair to the JSON object associated with this object builder.
      JsonObjectBuilder JsonObjectBuilder.add(String name, String value)
      Adds a name/JsonString pair to the JSON object associated with this object builder.
      JsonObjectBuilder JsonObjectBuilder.addNull(String name)
      Adds a name/JsonValue#NULL pair to the JSON object associated with this object builder where the value is null.
      JsonObjectBuilder JsonBuilderFactory.createObjectBuilder()
      Creates a JsonObjectBuilder instance that is used to build JsonObject.
      static JsonObjectBuilder Json.createObjectBuilder()
      Creates a JSON object builder
      Methods in javax.json with parameters of type JsonObjectBuilder
      Modifier and Type Method and Description
      JsonArrayBuilder JsonArrayBuilder.add(JsonObjectBuilder builder)
      Adds a JsonObject from an object builder to the array.
      JsonObjectBuilder JsonObjectBuilder.add(String name, JsonObjectBuilder builder)
      Adds a name/JsonObject pair to the JSON object associated with this object builder.

    • Uses of JsonObjectBuilder in javax.json.spi

      Methods in javax.json.spi that return JsonObjectBuilder
      Modifier and Type Method and Description
      abstract JsonObjectBuilder JsonProvider.createObjectBuilder()
      Creates a JSON object builder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonReader (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonReader

  • Packages that use JsonReader
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

    • Uses of JsonReader in javax.json

      Methods in javax.json that return JsonReader
      Modifier and Type Method and Description
      JsonReader JsonReaderFactory.createReader(InputStream in)
      Creates a JSON reader from a byte stream.
      static JsonReader Json.createReader(InputStream in)
      Creates a JSON reader from a byte stream.
      JsonReader JsonReaderFactory.createReader(InputStream in, Charset charset)
      Creates a JSON reader from a byte stream.
      JsonReader JsonReaderFactory.createReader(Reader reader)
      Creates a JSON reader from a character stream.
      static JsonReader Json.createReader(Reader reader)
      Creates a JSON reader from a character stream.

    • Uses of JsonReader in javax.json.spi

      Methods in javax.json.spi that return JsonReader
      Modifier and Type Method and Description
      abstract JsonReader JsonProvider.createReader(InputStream in)
      Creates a JSON reader from a byte stream.
      abstract JsonReader JsonProvider.createReader(Reader reader)
      Creates a JSON reader from a character stream.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonReaderFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonReaderFactory

  • Packages that use JsonReaderFactory
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

    • Uses of JsonReaderFactory in javax.json

      Methods in javax.json that return JsonReaderFactory
      Modifier and Type Method and Description
      static JsonReaderFactory Json.createReaderFactory(Map<String,?> config)
      Creates a reader factory for creating JsonReader objects.

    • Uses of JsonReaderFactory in javax.json.spi

      Methods in javax.json.spi that return JsonReaderFactory
      Modifier and Type Method and Description
      abstract JsonReaderFactory JsonProvider.createReaderFactory(Map<String,?> config)
      Creates a reader factory for creating JsonReader objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonString (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonString

  • Packages that use JsonString
    Package Description
    javax.json
    Provides an object model API to process JSON.

    • Uses of JsonString in javax.json

      Methods in javax.json that return JsonString
      Modifier and Type Method and Description
      JsonString JsonArray.getJsonString(int index)
      Returns the string value at ths specified position in this array.
      JsonString JsonObject.getJsonString(String name)
      Returns the string value to which the specified name is mapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonStructure (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonStructure

  • Packages that use JsonStructure
    Package Description
    javax.json
    Provides an object model API to process JSON.

    • Uses of JsonStructure in javax.json

      Subinterfaces of JsonStructure in javax.json
      Modifier and Type Interface and Description
      interface  JsonArray
      JsonArray represents an immutable JSON array (an ordered sequence of zero or more values).
      interface  JsonObject
      JsonObject class represents an immutable JSON object value (an unordered collection of zero or more name/value pairs).
      Methods in javax.json that return JsonStructure
      Modifier and Type Method and Description
      JsonStructure JsonReader.read()
      Returns a JSON array or object that is represented in the input source.
      Methods in javax.json with parameters of type JsonStructure
      Modifier and Type Method and Description
      void JsonWriter.write(JsonStructure value)
      Writes the specified JSON object or array to the output source.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonValue (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonValue

  • Packages that use JsonValue
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.stream
    Provides a streaming API to parse and generate JSON.

    • Uses of JsonValue in javax.json

      Subinterfaces of JsonValue in javax.json
      Modifier and Type Interface and Description
      interface  JsonArray
      JsonArray represents an immutable JSON array (an ordered sequence of zero or more values).
      interface  JsonNumber
      An immutable JSON number value.
      interface  JsonObject
      JsonObject class represents an immutable JSON object value (an unordered collection of zero or more name/value pairs).
      interface  JsonString
      An immutable JSON string value.
      interface  JsonStructure
      Super type for the two structured types in JSON (objects and arrays).
      Fields in javax.json declared as JsonValue
      Modifier and Type Field and Description
      static JsonValue JsonValue.FALSE
      JSON false value
      static JsonValue JsonValue.NULL
      JSON null value.
      static JsonValue JsonValue.TRUE
      JSON true value.
      Methods in javax.json with type parameters of type JsonValue
      Modifier and Type Method and Description
      <T extends JsonValue>
      List<T>             		JsonArray.getValuesAs(Class<T> clazz)
      Returns a list a view of the specified type for the array.
      Methods in javax.json with parameters of type JsonValue
      Modifier and Type Method and Description
      JsonArrayBuilder JsonArrayBuilder.add(JsonValue value)
      Adds a value to the array.
      JsonObjectBuilder JsonObjectBuilder.add(String name, JsonValue value)
      Adds a name/JsonValue pair to the JSON object associated with this object builder.

    • Uses of JsonValue in javax.json.stream

      Methods in javax.json.stream with parameters of type JsonValue
      Modifier and Type Method and Description
      JsonGenerator JsonGenerator.write(JsonValue value)
      Writes the specified value as a JSON value within the current array context.
      JsonGenerator JsonGenerator.write(String name, JsonValue value)
      Writes a JSON name/value pair in the current object context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonWriter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonWriter

  • Packages that use JsonWriter
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

    • Uses of JsonWriter in javax.json

      Methods in javax.json that return JsonWriter
      Modifier and Type Method and Description
      JsonWriter JsonWriterFactory.createWriter(OutputStream out)
      Creates a JSON writer to write a JSON object or array structure to the specified byte stream.
      static JsonWriter Json.createWriter(OutputStream out)
      Creates a JSON writer to write a JSON object or array structure to the specified byte stream.
      JsonWriter JsonWriterFactory.createWriter(OutputStream out, Charset charset)
      Creates a JSON writer to write a JSON object or array structure to the specified byte stream.
      JsonWriter JsonWriterFactory.createWriter(Writer writer)
      Creates a JSON writer to write a JSON object or array structure to the specified character stream.
      static JsonWriter Json.createWriter(Writer writer)
      Creates a JSON writer to write a JSON object or array structure to the specified character stream.

    • Uses of JsonWriter in javax.json.spi

      Methods in javax.json.spi that return JsonWriter
      Modifier and Type Method and Description
      abstract JsonWriter JsonProvider.createWriter(OutputStream out)
      Creates a JSON writer to write a JSON object or array structure to the specified byte stream.
      abstract JsonWriter JsonProvider.createWriter(Writer writer)
      Creates a JSON writer to write a JSON object or array structure to the specified character stream.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.JsonWriterFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.JsonWriterFactory

  • Packages that use JsonWriterFactory
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

    • Uses of JsonWriterFactory in javax.json

      Methods in javax.json that return JsonWriterFactory
      Modifier and Type Method and Description
      static JsonWriterFactory Json.createWriterFactory(Map<String,?> config)
      Creates a writer factory for creating JsonWriter objects.

    • Uses of JsonWriterFactory in javax.json.spi

      Methods in javax.json.spi that return JsonWriterFactory
      Modifier and Type Method and Description
      abstract JsonWriterFactory JsonProvider.createWriterFactory(Map<String,?> config)
      Creates a writer factory for creating JsonWriter objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.json.spi (Java(TM) EE 7 Specification APIs)

javax.json.spi

Classes

  • JsonProvider


javax.json.spi (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.json.spi

Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

See: Description

  • Class Summary
    Class Description
    JsonProvider
    Service provider for JSON processing objects.

Package javax.json.spi Description

Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

JsonProvider is an abstract class that provides a service for creating JSON processing instances. A service provider for JsonProvider provides an specific implementation by subclassing and implementing the methods in JsonProvider. This enables using custom, efficient JSON processing implementations (for e.g. parser and generator) other than the default ones.

The API locates and loads providers using ServiceLoader.

Since:
JSON Processing 1.0
Author:
Jitendra Kotamraju
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.json.spi Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.json.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.json.spi.JsonProvider
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JsonProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json.spi

Class JsonProvider

  • java.lang.Object
    • javax.json.spi.JsonProvider

  • public abstract class JsonProvider
extends Object
    Service provider for JSON processing objects.

    All the methods in this class are safe for use by multiple concurrent threads.

    Author:
    Jitendra Kotamraju
    See Also:
    ServiceLoader

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | JsonProvider()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract JsonArrayBuilder createArrayBuilder()
      Creates a JSON array builder
      abstract JsonBuilderFactory createBuilderFactory(Map<String,?> config)
      Creates a builder factory for creating JsonArrayBuilder and JsonObjectBuilder objects.
      abstract JsonGenerator createGenerator(OutputStream out)
      Creates a JSON generator for writing JSON text to a byte stream.
      abstract JsonGenerator createGenerator(Writer writer)
      Creates a JSON generator for writing JSON text to a character stream.
      abstract JsonGeneratorFactory createGeneratorFactory(Map<String,?> config)
      Creates a generator factory for creating JsonGenerator instances.
      abstract JsonObjectBuilder createObjectBuilder()
      Creates a JSON object builder
      abstract JsonParser createParser(InputStream in)
      Creates a JSON parser from the specified byte stream.
      abstract JsonParser createParser(Reader reader)
      Creates a JSON parser from a character stream.
      abstract JsonParserFactory createParserFactory(Map<String,?> config)
      Creates a parser factory for creating JsonParser instances.
      abstract JsonReader createReader(InputStream in)
      Creates a JSON reader from a byte stream.
      abstract JsonReader createReader(Reader reader)
      Creates a JSON reader from a character stream.
      abstract JsonReaderFactory createReaderFactory(Map<String,?> config)
      Creates a reader factory for creating JsonReader objects.
      abstract JsonWriter createWriter(OutputStream out)
      Creates a JSON writer to write a JSON object or array structure to the specified byte stream.
      abstract JsonWriter createWriter(Writer writer)
      Creates a JSON writer to write a JSON object or array structure to the specified character stream.
      abstract JsonWriterFactory createWriterFactory(Map<String,?> config)
      Creates a writer factory for creating JsonWriter objects.
      static JsonProvider provider()
      Creates a JSON provider object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JsonProvider

        protected JsonProvider()

    • Method Detail

      • provider

        public static JsonProvider provider()
        Creates a JSON provider object. The provider is loaded using the ServiceLoader.load(Class) method. If there are no available service providers, this method returns the default service provider.
        Returns:
        a JSON provider
        See Also:
        ServiceLoader

      • createParser

        public abstract JsonParser createParser(Reader reader)
        Creates a JSON parser from a character stream.
        Parameters:
        reader - i/o reader from which JSON is to be read
        Returns:
        a JSON parser

      • createParser

        public abstract JsonParser createParser(InputStream in)
        Creates a JSON parser from the specified byte stream. The character encoding of the stream is determined as defined in RFC 4627 .
        Parameters:
        in - i/o stream from which JSON is to be read
        Returns:
        a JSON parser
        Throws:
        JsonException - if encoding cannot be determined or i/o error (IOException would be cause of JsonException)

      • createParserFactory

        public abstract JsonParserFactory createParserFactory(Map<String,?> config)
        Creates a parser factory for creating JsonParser instances. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.
        Parameters:
        config - a map of provider specific properties to configure the JSON parsers. The map may be empty or null
        Returns:
        a JSON parser factory

      • createGenerator

        public abstract JsonGenerator createGenerator(Writer writer)
        Creates a JSON generator for writing JSON text to a character stream.
        Parameters:
        writer - a i/o writer to which JSON is written
        Returns:
        a JSON generator

      • createGenerator

        public abstract JsonGenerator createGenerator(OutputStream out)
        Creates a JSON generator for writing JSON text to a byte stream.
        Parameters:
        out - i/o stream to which JSON is written
        Returns:
        a JSON generator

      • createGeneratorFactory

        public abstract JsonGeneratorFactory createGeneratorFactory(Map<String,?> config)
        Creates a generator factory for creating JsonGenerator instances. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.
        Parameters:
        config - a map of provider specific properties to configure the JSON generators. The map may be empty or null
        Returns:
        a JSON generator factory

      • createReader

        public abstract JsonReader createReader(Reader reader)
        Creates a JSON reader from a character stream.
        Parameters:
        reader - a reader from which JSON is to be read
        Returns:
        a JSON reader

      • createReader

        public abstract JsonReader createReader(InputStream in)
        Creates a JSON reader from a byte stream. The character encoding of the stream is determined as described in RFC 4627.
        Parameters:
        in - a byte stream from which JSON is to be read
        Returns:
        a JSON reader

      • createWriter

        public abstract JsonWriter createWriter(Writer writer)
        Creates a JSON writer to write a JSON object or array structure to the specified character stream.
        Parameters:
        writer - to which JSON object or array is written
        Returns:
        a JSON writer

      • createWriter

        public abstract JsonWriter createWriter(OutputStream out)
        Creates a JSON writer to write a JSON object or array structure to the specified byte stream. Characters written to the stream are encoded into bytes using UTF-8 encoding.
        Parameters:
        out - to which JSON object or array is written
        Returns:
        a JSON writer

      • createWriterFactory

        public abstract JsonWriterFactory createWriterFactory(Map<String,?> config)
        Creates a writer factory for creating JsonWriter objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.
        Parameters:
        config - a map of provider specific properties to configure the JSON writers. The map may be empty or null
        Returns:
        a JSON writer factory

      • createReaderFactory

        public abstract JsonReaderFactory createReaderFactory(Map<String,?> config)
        Creates a reader factory for creating JsonReader objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.
        Parameters:
        config - a map of provider specific properties to configure the JSON readers. The map may be empty or null
        Returns:
        a JSON reader factory

      • createObjectBuilder

        public abstract JsonObjectBuilder createObjectBuilder()
        Creates a JSON object builder
        Returns:
        a JSON object builder

      • createArrayBuilder

        public abstract JsonArrayBuilder createArrayBuilder()
        Creates a JSON array builder
        Returns:
        a JSON array builder

      • createBuilderFactory

        public abstract JsonBuilderFactory createBuilderFactory(Map<String,?> config)
        Creates a builder factory for creating JsonArrayBuilder and JsonObjectBuilder objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.
        Parameters:
        config - a map of provider specific properties to configure the JSON builders. The map may be empty or null
        Returns:
        a JSON builder factory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.json.spi (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.json.spi

  • Packages that use javax.json.spi
    Package Description
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.
  • Classes in javax.json.spi used by javax.json.spi
    Class and Description
    JsonProvider
    Service provider for JSON processing objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.json.spi.JsonProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.json.spi.JsonProvider

  • Packages that use JsonProvider
    Package Description
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

    • Uses of JsonProvider in javax.json.spi

      Methods in javax.json.spi that return JsonProvider
      Modifier and Type Method and Description
      static JsonProvider JsonProvider.provider()
      Creates a JSON provider object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.json.stream (Java(TM) EE 7 Specification APIs)

javax.json.stream

Interfaces

  • JsonGenerator
  • JsonGeneratorFactory
  • JsonLocation
  • JsonParser
  • JsonParserFactory

Enums

  • JsonParser.Event

Exceptions

  • JsonGenerationException
  • JsonParsingException


javax.json.stream (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.json.stream

Provides a streaming API to parse and generate JSON.

See: Description

  • Interface Summary
    Interface Description
    JsonGenerator
    Writes JSON data to an output source in a streaming way.
    JsonGeneratorFactory
    Factory to create JsonGenerator instances.
    JsonLocation
    Provides the location information of a JSON event in an input source.
    JsonParser
    Provides forward, read-only access to JSON data in a streaming way.
    JsonParserFactory
    Factory for creating JsonParser instances.
  • Enum Summary
    Enum Description
    JsonParser.Event
    An event from JsonParser.
  • Exception Summary
    Exception Description
    JsonGenerationException
    JsonGenerationException indicates an incorrect JSON is being generated.
    JsonParsingException
    JsonParsingException is used when an incorrect JSON is being parsed.

Package javax.json.stream Description

Provides a streaming API to parse and generate JSON.

The streaming API consists of the interfaces JsonParser and JsonGenerator. The interface JsonParser contains methods to parse JSON in a streaming way. The interface JsonGenerator contains methods to write JSON to an output source in a streaming way.

JsonParser provides forward, read-only access to JSON data using the pull parsing programming model. In this model the application code controls the thread and calls methods in the parser interface to move the parser forward or to obtain JSON data from the current state of the parser.

JsonGenerator provides methods to write JSON to an output source. The generator writes name/value pairs in JSON objects and values in JSON arrays.

The streaming API is a low-level API designed to process large amounts of JSON data efficiently. Other JSON frameworks (such as JSON binding) can be implemented using this API.

Since:
JSON Processing 1.0
Author:
Jitendra Kotamraju
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.json.stream Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.json.stream

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.json.JsonException
            • javax.json.stream.JsonGenerationException
            • javax.json.stream.JsonParsingException

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • javax.json.stream.JsonGenerator (also extends java.io.Flushable)
      • javax.json.stream.JsonParser
  • java.io.Flushable
    • javax.json.stream.JsonGenerator (also extends java.io.Closeable)
  • javax.json.stream.JsonGeneratorFactory
  • javax.json.stream.JsonLocation
  • javax.json.stream.JsonParserFactory

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.json.stream.JsonParser.Event
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JsonGenerationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json.stream

Class JsonGenerationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.json.JsonException
            • javax.json.stream.JsonGenerationException
  • All Implemented Interfaces:
    Serializable

    public class JsonGenerationException
extends JsonException
    JsonGenerationException indicates an incorrect JSON is being generated.
    Author:
    Jitendra Kotamraju
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JsonGenerationException(String message)
      Constructs a new runtime exception with the specified detail message.
      JsonGenerationException(String message, Throwable cause)
      Constructs a new runtime exception with the specified detail message and cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JsonGenerationException

        public JsonGenerationException(String message)
        Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).
        Parameters:
        message - the detail message. The detail message is saved for later retrieval by the Throwable.getMessage() method.

      • JsonGenerationException

        public JsonGenerationException(String message,
                       Throwable cause)
        Constructs a new runtime exception with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.

        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonGenerator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json.stream

Interface JsonGenerator

  • All Superinterfaces:
    AutoCloseable, Closeable, Flushable

    public interface JsonGenerator
extends Flushable, Closeable
    Writes JSON data to an output source in a streaming way. The class Json contains methods to create generators for character or output streams (Writer and OutputStream).

    The following example shows how to create a JSON generator:

 JsonGenerator generator = Json.createGenerator(...);

    The class JsonGeneratorFactory also contains methods to create JsonGenerator instances. JsonGeneratorFactory should be used when creating multiple generator instances, as in the following example:

 JsonGeneratorFactory factory = Json.createGeneratorFactory();
 JsonGenerator generator1 = factory.createGenerator(...);
 JsonGenerator generator2 = factory.createGenerator(...);

    JSON objects can be created using JsonGenerator by calling the writeStartObject() method and then adding name/value pairs with the write method.

    The following example shows how to generate an empty JSON object:

 JsonGenerator generator = ...;
 generator.writeStartObject().writeEnd().close();
    JSON arrays can be created using JsonGenerator by calling the writeStartArray() method and then adding values with the write method.

    The following example shows how to generate an empty JSON array:

 JsonGenerator generator = ...;
 generator.writeStartArray().writeEnd().close();
    JsonGenerator methods can be chained as in the following example:

 generator
     .writeStartObject()
         .write("firstName", "John")
         .write("lastName", "Smith")
         .write("age", 25)
         .writeStartObject("address")
             .write("streetAddress", "21 2nd Street")
             .write("city", "New York")
             .write("state", "NY")
             .write("postalCode", "10021")
         .writeEnd()
         .writeStartArray("phoneNumber")
             .writeStartObject()
                 .write("type", "home")
                 .write("number", "212 555-1234")
             .writeEnd()
             .writeStartObject()
                 .write("type", "fax")
                 .write("number", "646 555-4567")
             .writeEnd()
         .writeEnd()
     .writeEnd();
 generator.close();
    The example code above generates the following JSON (or equivalent):

 {
   "firstName": "John", "lastName": "Smith", "age": 25,
   "address" : {
       "streetAddress": "21 2nd Street",
       "city": "New York",
       "state": "NY",
       "postalCode": "10021"
   },
   "phoneNumber": [
       {"type": "home", "number": "212 555-1234"},
       {"type": "fax", "number": "646 555-4567"}
    ]
 }
    The generated JSON text must strictly conform to the grammar defined in     RFC 4627.
    Author:
    Jitendra Kotamraju
    See Also:
    Json, JsonGeneratorFactory

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String PRETTY_PRINTING
      Configuration property to generate JSON prettily.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes this generator and frees any resources associated with it.
      void flush()
      Flushes the underlying output source.
      JsonGenerator write(BigDecimal value)
      Writes the specified value as a JSON number value within the current array context.
      JsonGenerator write(BigInteger value)
      Writes the specified value as a JSON number value within the current array context.
      JsonGenerator write(boolean value)
      Writes a JSON true or false value within the current array context.
      JsonGenerator write(double value)
      Writes the specified value as a JSON number value within the current array context.
      JsonGenerator write(int value)
      Writes the specified value as a JSON number value within the current array context.
      JsonGenerator write(JsonValue value)
      Writes the specified value as a JSON value within the current array context.
      JsonGenerator write(long value)
      Writes the specified value as a JSON number value within the current array context.
      JsonGenerator write(String value)
      Writes the specified value as a JSON string value within the current array context.
      JsonGenerator write(String name, BigDecimal value)
      Writes a JSON name/number value pair in the current object context.
      JsonGenerator write(String name, BigInteger value)
      Writes a JSON name/number value pair in the current object context.
      JsonGenerator write(String name, boolean value)
      Writes a JSON name/boolean value pair in the current object context.
      JsonGenerator write(String name, double value)
      Writes a JSON name/number value pair in the current object context.
      JsonGenerator write(String name, int value)
      Writes a JSON name/number value pair in the current object context.
      JsonGenerator write(String name, JsonValue value)
      Writes a JSON name/value pair in the current object context.
      JsonGenerator write(String name, long value)
      Writes a JSON name/number value pair in the current object context.
      JsonGenerator write(String name, String value)
      Writes a JSON name/string value pair in the current object context.
      JsonGenerator writeEnd()
      Writes the end of the current context.
      JsonGenerator writeNull()
      Writes a JSON null value within the current array context.
      JsonGenerator writeNull(String name)
      Writes a JSON name/null value pair in an current object context.
      JsonGenerator writeStartArray()
      Writes the JSON start array character.
      JsonGenerator writeStartArray(String name)
      Writes the JSON name/start array character pair with in the current object context.
      JsonGenerator writeStartObject()
      Writes the JSON start object character.
      JsonGenerator writeStartObject(String name)
      Writes the JSON name/start object character pair in the current object context.

    • Field Detail

      • PRETTY_PRINTING

        static final String PRETTY_PRINTING
        Configuration property to generate JSON prettily. All providers must support this property. The value of the property could be be anything.
        See Also:
        Constant Field Values

    • Method Detail

      • writeStartObject

        JsonGenerator writeStartObject()
        Writes the JSON start object character. It starts a new child object context within which JSON name/value pairs can be written to the object. This method is valid only in an array context or in no context (when a context is not yet started). This method can only be called once in no context.
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is called within an object context or if it is called more than once in no context.

      • writeStartObject

        JsonGenerator writeStartObject(String name)
        Writes the JSON name/start object character pair in the current object context. It starts a new child object context within which JSON name/value pairs can be written to the object.
        Parameters:
        name - a name within the JSON name/object pair to be written
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an object context

      • writeStartArray

        JsonGenerator writeStartArray()
        Writes the JSON start array character. It starts a new child array context within which JSON values can be written to the array. This method is valid only in an array context or in no context (when a context is not yet started). This method can only be called once in no context.
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is called within an object context or if called more than once in no context

      • writeStartArray

        JsonGenerator writeStartArray(String name)
        Writes the JSON name/start array character pair with in the current object context. It starts a new child array context within which JSON values can be written to the array.
        Parameters:
        name - a name within the JSON name/array pair to be written
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an object context

      • write

        JsonGenerator write(String name,
                  JsonValue value)
        Writes a JSON name/value pair in the current object context.
        Parameters:
        name - a name in the JSON name/value pair to be written in current JSON object
        value - a value in the JSON name/value pair to be written in current JSON object
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an object context

      • write

        JsonGenerator write(String name,
                  String value)
        Writes a JSON name/string value pair in the current object context. The specified value is written as JSON string value.
        Parameters:
        name - a name in the JSON name/string pair to be written in current JSON object
        value - a value in the JSON name/string pair to be written in current JSON object
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an object context

      • write

        JsonGenerator write(String name,
                  BigInteger value)
        Writes a JSON name/number value pair in the current object context. The specified value is written as a JSON number value. The string new BigDecimal(value).toString() is used as the text value for writing.
        Parameters:
        name - a name in the JSON name/number pair to be written in current JSON object
        value - a value in the JSON name/number pair to be written in current JSON object
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an object context.

      • write

        JsonGenerator write(String name,
                  BigDecimal value)
        Writes a JSON name/number value pair in the current object context. The specified value is written as a JSON number value. The specified value's toString() is used as the text value for writing.
        Parameters:
        name - a name in the JSON name/number pair to be written in current JSON object
        value - a value in the JSON name/number pair to be written in current JSON object
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an object context.

      • write

        JsonGenerator write(String name,
                  int value)
        Writes a JSON name/number value pair in the current object context. The specified value is written as a JSON number value. The string new BigDecimal(value).toString() is used as the text value for writing.
        Parameters:
        name - a name in the JSON name/number pair to be written in current JSON object
        value - a value in the JSON name/number pair to be written in current JSON object
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an object context.

      • write

        JsonGenerator write(String name,
                  long value)
        Writes a JSON name/number value pair in the current object context. The specified value is written as a JSON number value. The string new BigDecimal(value).toString() is used as the text value for writing.
        Parameters:
        name - a name in the JSON name/number pair to be written in current JSON object
        value - a value in the JSON name/number pair to be written in current JSON object
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an object context.

      • write

        JsonGenerator write(String name,
                  double value)
        Writes a JSON name/number value pair in the current object context. The specified value is written as a JSON number value. The string BigDecimal.valueOf(double).toString() is used as the text value for writing.
        Parameters:
        name - a name in the JSON name/number pair to be written in current JSON object
        value - a value in the JSON name/number pair to be written in current JSON object
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        NumberFormatException - if the value is Not-a-Number(NaN) or infinity.
        JsonGenerationException - if this method is not called within an object context

      • write

        JsonGenerator write(String name,
                  boolean value)
        Writes a JSON name/boolean value pair in the current object context. If value is true, it writes the JSON true value, otherwise it writes the JSON false value.
        Parameters:
        name - a name in the JSON name/boolean pair to be written in current JSON object
        value - a value in the JSON name/boolean pair to be written in current JSON object
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an object context.

      • writeNull

        JsonGenerator writeNull(String name)
        Writes a JSON name/null value pair in an current object context.
        Parameters:
        name - a name in the JSON name/null pair to be written in current JSON object
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an object context

      • writeEnd

        JsonGenerator writeEnd()
        Writes the end of the current context. If the current context is an array context, this method writes the end-of-array character (']'). If the current context is an object context, this method writes the end-of-object character ('}'). After writing the end of the current context, the parent context becomes the new current context.
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is called in no context.

      • write

        JsonGenerator write(JsonValue value)
        Writes the specified value as a JSON value within the current array context.
        Parameters:
        value - a value to be written in current JSON array
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an array context.

      • write

        JsonGenerator write(String value)
        Writes the specified value as a JSON string value within the current array context.
        Parameters:
        value - a value to be written in current JSON array
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an array context

      • write

        JsonGenerator write(BigDecimal value)
        Writes the specified value as a JSON number value within the current array context. The specified value's toString() is used as the the text value for writing.
        Parameters:
        value - a value to be written in current JSON array
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an array context
        See Also:
        JsonNumber

      • write

        JsonGenerator write(BigInteger value)
        Writes the specified value as a JSON number value within the current array context. The string new BigDecimal(value).toString() is used as the text value for writing.
        Parameters:
        value - a value to be written in current JSON array
        Returns:
        this generator.
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an array context
        See Also:
        JsonNumber

      • write

        JsonGenerator write(int value)
        Writes the specified value as a JSON number value within the current array context. The string new BigDecimal(value).toString() is used as the text value for writing.
        Parameters:
        value - a value to be written in current JSON array
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an array context

      • write

        JsonGenerator write(long value)
        Writes the specified value as a JSON number value within the current array context. The string new BigDecimal(value).toString() is used as the text value for writing.
        Parameters:
        value - a value to be written in current JSON array
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an array context

      • write

        JsonGenerator write(double value)
        Writes the specified value as a JSON number value within the current array context. The string BigDecimal.valueOf(value).toString() is used as the text value for writing.
        Parameters:
        value - a value to be written in current JSON array
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an array context
        NumberFormatException - if the value is Not-a-Number(NaN) or infinity.

      • write

        JsonGenerator write(boolean value)
        Writes a JSON true or false value within the current array context. If value is true, this method writes the JSON true value, otherwise it writes the JSON false value.
        Parameters:
        value - a boolean value
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an array context.

      • writeNull

        JsonGenerator writeNull()
        Writes a JSON null value within the current array context.
        Returns:
        this generator
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if this method is not called within an array context

      • close

        void close()
        Closes this generator and frees any resources associated with it. This method closes the underlying output source.
        Specified by:
        close in interface AutoCloseable
        Specified by:
        close in interface Closeable
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonGenerationException - if an incomplete JSON is generated

      • flush

        void flush()
        Flushes the underlying output source. If the generator has saved any characters in a buffer, writes them immediately to the underlying output source before flushing it.
        Specified by:
        flush in interface Flushable
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonGeneratorFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json.stream

Interface JsonGeneratorFactory

  • public interface JsonGeneratorFactory
    Factory to create JsonGenerator instances. If a factory instance is configured with some configuration, the configuration applies to all generator instances created using that factory instance.

    The class Json also provides methods to create JsonGenerator instances, but using JsonGeneratorFactory is preferred when creating multiple generator instances as shown in the following example:

 JsonGeneratorFactory factory = Json.createGeneratorFactory();
 JsonGenerator generator1 = factory.createGenerator(...);
 JsonGenerator generator2 = factory.createGenerator(...);

    All the methods in this class are safe for use by multiple concurrent threads.

    Author:
    Jitendra Kotamraju

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JsonGenerator createGenerator(OutputStream out)
      Creates a JSON generator to write JSON text to a byte stream.
      JsonGenerator createGenerator(OutputStream out, Charset charset)
      Creates a JSON generator to write JSON text to a byte stream.
      JsonGenerator createGenerator(Writer writer)
      Creates a JSON generator to write JSON text to a character stream.
      Map<String,?> getConfigInUse()
      Returns a read-only map of supported provider specific configuration properties that are used to configure the JSON generators.

    • Method Detail

      • createGenerator

        JsonGenerator createGenerator(Writer writer)
        Creates a JSON generator to write JSON text to a character stream. The generator is configured with the factory configuration.
        Parameters:
        writer - i/o writer to which JSON is written

      • createGenerator

        JsonGenerator createGenerator(OutputStream out)
        Creates a JSON generator to write JSON text to a byte stream. Characters written to the stream are encoded into bytes using UTF-8 encoding. The generator is configured with the factory's configuration.
        Parameters:
        out - i/o stream to which JSON is written

      • createGenerator

        JsonGenerator createGenerator(OutputStream out,
                            Charset charset)
        Creates a JSON generator to write JSON text to a byte stream. Characters written to the stream are encoded into bytes using the specified charset. The generator is configured with the factory's configuration.
        Parameters:
        out - i/o stream to which JSON is written
        charset - a charset

      • getConfigInUse

        Map<String,?> getConfigInUse()
        Returns a read-only map of supported provider specific configuration properties that are used to configure the JSON generators. If there are any specified configuration properties that are not supported by the provider, they won't be part of the returned map.
        Returns:
        a map of supported provider specific properties that are used to configure the created generators. The map may be empty but not null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonLocation (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json.stream

Interface JsonLocation

  • public interface JsonLocation
    Provides the location information of a JSON event in an input source. The JsonLocation information can be used to identify incorrect JSON or can be used by higher frameworks to know about the processing location.

    All the information provided by a JsonLocation is optional. For example, a provider may only report line numbers. Also, there may not be any location information for an input source. For example, if a JsonParser is created using JsonArray input source, all the methods in this class return -1.

    Author:
    Jitendra Kotamraju
    See Also:
    JsonParser, JsonParsingException

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getColumnNumber()
      Return the column number for the current JSON event in the input source.
      long getLineNumber()
      Return the line number for the current JSON event in the input source.
      long getStreamOffset()
      Return the stream offset into the input source this location is pointing to.

    • Method Detail

      • getLineNumber

        long getLineNumber()
        Return the line number for the current JSON event in the input source.
        Returns:
        the line number or -1 if none is available

      • getColumnNumber

        long getColumnNumber()
        Return the column number for the current JSON event in the input source.
        Returns:
        the column number or -1 if none is available

      • getStreamOffset

        long getStreamOffset()
        Return the stream offset into the input source this location is pointing to. If the input source is a file or a byte stream then this is the byte offset into that stream, but if the input source is a character media then the offset is the character offset. Returns -1 if there is no offset available.
        Returns:
        the offset of input source stream, or -1 if there is no offset available
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonParser (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json.stream

Interface JsonParser

  • All Superinterfaces:
    AutoCloseable, Closeable

    public interface JsonParser
extends Closeable
    Provides forward, read-only access to JSON data in a streaming way. This is the most efficient way for reading JSON data. The class Json contains methods to create parsers from input sources (InputStream and Reader).

    The following example demonstrates how to create a parser from a string that contains an empty JSON array:

 JsonParser parser = Json.createParser(new StringReader("[]"));

    The class JsonParserFactory also contains methods to create JsonParser instances. JsonParserFactory is preferred when creating multiple parser instances. A sample usage is shown in the following example:

 JsonParserFactory factory = Json.createParserFactory();
 JsonParser parser1 = factory.createParser(...);
 JsonParser parser2 = factory.createParser(...);

    JsonParser parses JSON using the pull parsing programming model. In this model the client code controls the thread and calls the method next() to advance the parser to the next state after processing each element. The parser can generate the following events: START_OBJECT, END_OBJECT, START_ARRAY, END_ARRAY, KEY_NAME, VALUE_STRING, VALUE_NUMBER, VALUE_TRUE, VALUE_FALSE, and VALUE_NULL.

    For example, for an empty JSON object ({ }), the parser generates the event START_OBJECT with the first call to the method next() and the event END_OBJECT with the second call to the method next(). The following code demonstrates how to access these events:

 Event event = parser.next(); // START_OBJECT
 event = parser.next();       // END_OBJECT

    For example, for the following JSON:

     {
   "firstName": "John", "lastName": "Smith", "age": 25,
   "phoneNumber": [
       { "type": "home", "number": "212 555-1234" },
       { "type": "fax", "number": "646 555-4567" }
    ]
 }

    calls to the method next() result in parse events at the specified locations below (marked in bold):

     {START_OBJECT
   "firstName"KEY_NAME: "John"VALUE_STRING, "lastName"KEY_NAME: "Smith"VALUE_STRING, "age"KEY_NAME: 25VALUE_NUMBER,
   "phoneNumber"KEY_NAME : [START_ARRAY
       {START_OBJECT "type"KEY_NAME: "home"VALUE_STRING, "number"KEY_NAME: "212 555-1234"VALUE_STRING }END_OBJECT,
       {START_OBJECT "type"KEY_NAME: "fax"VALUE_STRING, "number"KEY_NAME: "646 555-4567"VALUE_STRING }END_OBJECT
    ]END_ARRAY
 }END_OBJECT

    The methods next() and hasNext() enable iteration over parser events to process JSON data. JsonParser provides get methods to obtain the value at the current state of the parser. For example, the following code shows how to obtain the value "John" from the JSON above:

 Event event = parser.next(); // START_OBJECT
 event = parser.next();       // KEY_NAME
 event = parser.next();       // VALUE_STRING
 parser.getString();          // "John"
    Author:
    Jitendra Kotamraju
    See Also:
    Json, JsonParserFactory

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  JsonParser.Event
      An event from JsonParser.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes this parser and frees any resources associated with the parser.
      BigDecimal getBigDecimal()
      Returns a JSON number as a BigDecimal.
      int getInt()
      Returns a JSON number as an integer.
      JsonLocation getLocation()
      Return the location that corresponds to the parser's current state in the JSON input source.
      long getLong()
      Returns a JSON number as a long.
      String getString()
      Returns a String for the name in a name/value pair, for a string value or a number value.
      boolean hasNext()
      Returns true if there are more parsing states.
      boolean isIntegralNumber()
      Returns true if the JSON number at the current parser state is a integral number.
      JsonParser.Event next()
      Returns the event for the next parsing state.

    • Method Detail

      • hasNext

        boolean hasNext()
        Returns true if there are more parsing states. This method returns false if the parser reaches the end of the JSON text.
        Returns:
        true if there are more parsing states.
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonParsingException - if the parser encounters invalid JSON when advancing to next state.

      • next

        JsonParser.Event next()
        Returns the event for the next parsing state.
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
        JsonParsingException - if the parser encounters invalid JSON when advancing to next state.
        NoSuchElementException - if there are no more parsing states.

      • getString

        String getString()
        Returns a String for the name in a name/value pair, for a string value or a number value. This method should only be called when the parser state is JsonParser.Event.KEY_NAME, JsonParser.Event.VALUE_STRING, or JsonParser.Event.VALUE_NUMBER.
        Returns:
        a name when the parser state is JsonParser.Event.KEY_NAME a string value when the parser state is JsonParser.Event.VALUE_STRING a number value when the parser state is JsonParser.Event.VALUE_NUMBER
        Throws:
        IllegalStateException - when the parser state is not KEY_NAME, VALUE_STRING, or VALUE_NUMBER

      • isIntegralNumber

        boolean isIntegralNumber()
        Returns true if the JSON number at the current parser state is a integral number. A BigDecimal may be used to store the value internally and this method semantics are defined using its scale(). If the scale is zero, then it is considered integral type. This integral type information can be used to invoke an appropriate accessor method to obtain a numeric value as in the following example:

 JsonParser parser = ...
 if (parser.isIntegralNumber()) {
     parser.getInt();     // or other methods to get integral value
 } else {
     parser.getBigDecimal();
 }
        Returns:
        true if this number is a integral number, otherwise false
        Throws:
        IllegalStateException - when the parser state is not VALUE_NUMBER

      • getInt

        int getInt()
        Returns a JSON number as an integer. The returned value is equal to new BigDecimal(getString()).intValue(). Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign. This method should only be called when the parser state is JsonParser.Event.VALUE_NUMBER.
        Returns:
        an integer for a JSON number
        Throws:
        IllegalStateException - when the parser state is not VALUE_NUMBER
        See Also:
        BigDecimal.intValue()

      • getLong

        long getLong()
        Returns a JSON number as a long. The returned value is equal to new BigDecimal(getString()).longValue(). Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign. This method is only called when the parser state is JsonParser.Event.VALUE_NUMBER.
        Returns:
        a long for a JSON number
        Throws:
        IllegalStateException - when the parser state is not VALUE_NUMBER
        See Also:
        BigDecimal.longValue()

      • getBigDecimal

        BigDecimal getBigDecimal()
        Returns a JSON number as a BigDecimal. The BigDecimal is created using new BigDecimal(getString()). This method should only called when the parser state is JsonParser.Event.VALUE_NUMBER.
        Returns:
        a BigDecimal for a JSON number
        Throws:
        IllegalStateException - when the parser state is not VALUE_NUMBER

      • getLocation

        JsonLocation getLocation()
        Return the location that corresponds to the parser's current state in the JSON input source. The location information is only valid in the current parser state (or until the parser is advanced to a next state).
        Returns:
        a non-null location corresponding to the current parser state in JSON input source

      • close

        void close()
        Closes this parser and frees any resources associated with the parser. This method closes the underlying input source.
        Specified by:
        close in interface AutoCloseable
        Specified by:
        close in interface Closeable
        Throws:
        JsonException - if an i/o error occurs (IOException would be cause of JsonException)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonParser.Event (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.json.stream

Enum JsonParser.Event

  • java.lang.Object
    • java.lang.Enum<JsonParser.Event>
      • javax.json.stream.JsonParser.Event
  • All Implemented Interfaces:
    Serializable, Comparable<JsonParser.Event>
    Enclosing interface:
    JsonParser

    public static enum JsonParser.Event
extends Enum<JsonParser.Event>
    An event from JsonParser.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      END_ARRAY
      End of a JSON array.
      END_OBJECT
      End of a JSON object.
      KEY_NAME
      Name in a name/value pair of a JSON object.
      START_ARRAY
      Start of a JSON array.
      START_OBJECT
      Start of a JSON object.
      VALUE_FALSE
      false value in a JSON array or object.
      VALUE_NULL
      null value in a JSON array or object.
      VALUE_NUMBER
      Number value in a JSON array or object.
      VALUE_STRING
      String value in a JSON array or object.
      VALUE_TRUE
      true value in a JSON array or object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static JsonParser.Event valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JsonParser.Event[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • START_ARRAY

        public static final JsonParser.Event START_ARRAY
        Start of a JSON array. The position of the parser is after '['.

      • START_OBJECT

        public static final JsonParser.Event START_OBJECT
        Start of a JSON object. The position of the parser is after '{'.

      • KEY_NAME

        public static final JsonParser.Event KEY_NAME
        Name in a name/value pair of a JSON object. The position of the parser is after the key name. The method JsonParser.getString() returns the key name.

      • VALUE_STRING

        public static final JsonParser.Event VALUE_STRING
        String value in a JSON array or object. The position of the parser is after the string value. The method JsonParser.getString() returns the string value.

      • VALUE_NUMBER

        public static final JsonParser.Event VALUE_NUMBER
        Number value in a JSON array or object. The position of the parser is after the number value. JsonParser provides the following methods to access the number value: JsonParser.getInt(), JsonParser.getLong(), and JsonParser.getBigDecimal().

      • VALUE_TRUE

        public static final JsonParser.Event VALUE_TRUE
        true value in a JSON array or object. The position of the parser is after the true value.

      • VALUE_FALSE

        public static final JsonParser.Event VALUE_FALSE
        false value in a JSON array or object. The position of the parser is after the false value.

      • VALUE_NULL

        public static final JsonParser.Event VALUE_NULL
        null value in a JSON array or object. The position of the parser is after the null value.

      • END_OBJECT

        public static final JsonParser.Event END_OBJECT
        End of a JSON object. The position of the parser is after '}'.

      • END_ARRAY

        public static final JsonParser.Event END_ARRAY
        End of a JSON array. The position of the parser is after ']'.

    • Method Detail

      • values

        public static JsonParser.Event[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (JsonParser.Event c : JsonParser.Event.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static JsonParser.Event valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


JsonParserFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json.stream

Interface JsonParserFactory

  • public interface JsonParserFactory
    Factory for creating JsonParser instances. If a factory instance is configured with a configuration, the configuration applies to all parser instances created using that factory instance.

    The class Json also provides methods to create JsonParser instances, but using JsonParserFactory is preferred when creating multiple parser instances as shown in the following example:

 JsonParserFactory factory = Json.createParserFactory();
 JsonParser parser1 = factory.createParser(...);
 JsonParser parser2 = factory.createParser(...);

    All the methods in this class are safe for use by multiple concurrent threads.

    Author:
    Jitendra Kotamraju

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JsonParser createParser(InputStream in)
      Creates a JSON parser from the specified byte stream.
      JsonParser createParser(InputStream in, Charset charset)
      Creates a JSON parser from the specified byte stream.
      JsonParser createParser(JsonArray array)
      Creates a JSON parser from the specified JSON array.
      JsonParser createParser(JsonObject obj)
      Creates a JSON parser from the specified JSON object.
      JsonParser createParser(Reader reader)
      Creates a JSON parser from a character stream.
      Map<String,?> getConfigInUse()
      Returns a read-only map of supported provider specific configuration properties that are used to configure the JSON parsers.

    • Method Detail

      • createParser

        JsonParser createParser(Reader reader)
        Creates a JSON parser from a character stream.
        Parameters:
        reader - a i/o reader from which JSON is to be read

      • createParser

        JsonParser createParser(InputStream in)
        Creates a JSON parser from the specified byte stream. The character encoding of the stream is determined as specified in RFC 4627.
        Parameters:
        in - i/o stream from which JSON is to be read
        Throws:
        JsonException - if encoding cannot be determined or i/o error (IOException would be cause of JsonException)

      • createParser

        JsonParser createParser(InputStream in,
                      Charset charset)
        Creates a JSON parser from the specified byte stream. The bytes of the stream are decoded to characters using the specified charset.
        Parameters:
        in - i/o stream from which JSON is to be read
        charset - a charset

      • createParser

        JsonParser createParser(JsonObject obj)
        Creates a JSON parser from the specified JSON object.
        Parameters:
        obj - a JSON object

      • createParser

        JsonParser createParser(JsonArray array)
        Creates a JSON parser from the specified JSON array.
        Parameters:
        array - a JSON array

      • getConfigInUse

        Map<String,?> getConfigInUse()
        Returns a read-only map of supported provider specific configuration properties that are used to configure the JSON parsers. If there are any specified configuration properties that are not supported by the provider, they won't be part of the returned map.
        Returns:
        a map of supported provider specific properties that are used to configure the created parsers. The map may be empty but not null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JsonParsingException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.json.stream

Class JsonParsingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.json.JsonException
            • javax.json.stream.JsonParsingException
  • All Implemented Interfaces:
    Serializable

    public class JsonParsingException
extends JsonException
    JsonParsingException is used when an incorrect JSON is being parsed.
    Author:
    Jitendra Kotamraju
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JsonParsingException(String message, JsonLocation location)
      Constructs a new runtime exception with the specified detail message.
      JsonParsingException(String message, Throwable cause, JsonLocation location)
      Constructs a new runtime exception with the specified detail message and cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JsonLocation getLocation()
      Return the location of the incorrect JSON.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JsonParsingException

        public JsonParsingException(String message,
                    JsonLocation location)
        Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).
        Parameters:
        message - the detail message. The detail message is saved for later retrieval by the Throwable.getMessage() method.
        location - the location of the incorrect JSON

      • JsonParsingException

        public JsonParsingException(String message,
                    Throwable cause,
                    JsonLocation location)
        Constructs a new runtime exception with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.

        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
        location - the location of the incorrect JSON

    • Method Detail

      • getLocation

        public JsonLocation getLocation()
        Return the location of the incorrect JSON.
        Returns:
        the non-null location of the incorrect JSON
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.json.stream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.json.stream

  • Packages that use javax.json.stream
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.
    javax.json.stream
    Provides a streaming API to parse and generate JSON.
  • Classes in javax.json.stream used by javax.json
    Class and Description
    JsonGenerator
    Writes JSON data to an output source in a streaming way.
    JsonGeneratorFactory
    Factory to create JsonGenerator instances.
    JsonParser
    Provides forward, read-only access to JSON data in a streaming way.
    JsonParserFactory
    Factory for creating JsonParser instances.
  • Classes in javax.json.stream used by javax.json.spi
    Class and Description
    JsonGenerator
    Writes JSON data to an output source in a streaming way.
    JsonGeneratorFactory
    Factory to create JsonGenerator instances.
    JsonParser
    Provides forward, read-only access to JSON data in a streaming way.
    JsonParserFactory
    Factory for creating JsonParser instances.
  • Classes in javax.json.stream used by javax.json.stream
    Class and Description
    JsonGenerator
    Writes JSON data to an output source in a streaming way.
    JsonLocation
    Provides the location information of a JSON event in an input source.
    JsonParser
    Provides forward, read-only access to JSON data in a streaming way.
    JsonParser.Event
    An event from JsonParser.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.json.stream.JsonGenerationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.json.stream.JsonGenerationException

No usage of javax.json.stream.JsonGenerationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.json.stream.JsonParser.Event (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.json.stream.JsonParser.Event

  • Packages that use JsonParser.Event
    Package Description
    javax.json.stream
    Provides a streaming API to parse and generate JSON.

    • Uses of JsonParser.Event in javax.json.stream

      Methods in javax.json.stream that return JsonParser.Event
      Modifier and Type Method and Description
      JsonParser.Event JsonParser.next()
      Returns the event for the next parsing state.
      static JsonParser.Event JsonParser.Event.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JsonParser.Event[] JsonParser.Event.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.json.stream.JsonParsingException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.json.stream.JsonParsingException

No usage of javax.json.stream.JsonParsingException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.stream.JsonGenerator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.stream.JsonGenerator

  • Packages that use JsonGenerator
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.
    javax.json.stream
    Provides a streaming API to parse and generate JSON.

    • Uses of JsonGenerator in javax.json

      Methods in javax.json that return JsonGenerator
      Modifier and Type Method and Description
      static JsonGenerator Json.createGenerator(OutputStream out)
      Creates a JSON generator for writing JSON to a byte stream.
      static JsonGenerator Json.createGenerator(Writer writer)
      Creates a JSON generator for writing JSON to a character stream.

    • Uses of JsonGenerator in javax.json.spi

      Methods in javax.json.spi that return JsonGenerator
      Modifier and Type Method and Description
      abstract JsonGenerator JsonProvider.createGenerator(OutputStream out)
      Creates a JSON generator for writing JSON text to a byte stream.
      abstract JsonGenerator JsonProvider.createGenerator(Writer writer)
      Creates a JSON generator for writing JSON text to a character stream.

    • Uses of JsonGenerator in javax.json.stream

      Methods in javax.json.stream that return JsonGenerator
      Modifier and Type Method and Description
      JsonGenerator JsonGeneratorFactory.createGenerator(OutputStream out)
      Creates a JSON generator to write JSON text to a byte stream.
      JsonGenerator JsonGeneratorFactory.createGenerator(OutputStream out, Charset charset)
      Creates a JSON generator to write JSON text to a byte stream.
      JsonGenerator JsonGeneratorFactory.createGenerator(Writer writer)
      Creates a JSON generator to write JSON text to a character stream.
      JsonGenerator JsonGenerator.write(BigDecimal value)
      Writes the specified value as a JSON number value within the current array context.
      JsonGenerator JsonGenerator.write(BigInteger value)
      Writes the specified value as a JSON number value within the current array context.
      JsonGenerator JsonGenerator.write(boolean value)
      Writes a JSON true or false value within the current array context.
      JsonGenerator JsonGenerator.write(double value)
      Writes the specified value as a JSON number value within the current array context.
      JsonGenerator JsonGenerator.write(int value)
      Writes the specified value as a JSON number value within the current array context.
      JsonGenerator JsonGenerator.write(JsonValue value)
      Writes the specified value as a JSON value within the current array context.
      JsonGenerator JsonGenerator.write(long value)
      Writes the specified value as a JSON number value within the current array context.
      JsonGenerator JsonGenerator.write(String value)
      Writes the specified value as a JSON string value within the current array context.
      JsonGenerator JsonGenerator.write(String name, BigDecimal value)
      Writes a JSON name/number value pair in the current object context.
      JsonGenerator JsonGenerator.write(String name, BigInteger value)
      Writes a JSON name/number value pair in the current object context.
      JsonGenerator JsonGenerator.write(String name, boolean value)
      Writes a JSON name/boolean value pair in the current object context.
      JsonGenerator JsonGenerator.write(String name, double value)
      Writes a JSON name/number value pair in the current object context.
      JsonGenerator JsonGenerator.write(String name, int value)
      Writes a JSON name/number value pair in the current object context.
      JsonGenerator JsonGenerator.write(String name, JsonValue value)
      Writes a JSON name/value pair in the current object context.
      JsonGenerator JsonGenerator.write(String name, long value)
      Writes a JSON name/number value pair in the current object context.
      JsonGenerator JsonGenerator.write(String name, String value)
      Writes a JSON name/string value pair in the current object context.
      JsonGenerator JsonGenerator.writeEnd()
      Writes the end of the current context.
      JsonGenerator JsonGenerator.writeNull()
      Writes a JSON null value within the current array context.
      JsonGenerator JsonGenerator.writeNull(String name)
      Writes a JSON name/null value pair in an current object context.
      JsonGenerator JsonGenerator.writeStartArray()
      Writes the JSON start array character.
      JsonGenerator JsonGenerator.writeStartArray(String name)
      Writes the JSON name/start array character pair with in the current object context.
      JsonGenerator JsonGenerator.writeStartObject()
      Writes the JSON start object character.
      JsonGenerator JsonGenerator.writeStartObject(String name)
      Writes the JSON name/start object character pair in the current object context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.stream.JsonGeneratorFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.stream.JsonGeneratorFactory

  • Packages that use JsonGeneratorFactory
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

    • Uses of JsonGeneratorFactory in javax.json

      Methods in javax.json that return JsonGeneratorFactory
      Modifier and Type Method and Description
      static JsonGeneratorFactory Json.createGeneratorFactory(Map<String,?> config)
      Creates a generator factory for creating JsonGenerator objects.

    • Uses of JsonGeneratorFactory in javax.json.spi

      Methods in javax.json.spi that return JsonGeneratorFactory
      Modifier and Type Method and Description
      abstract JsonGeneratorFactory JsonProvider.createGeneratorFactory(Map<String,?> config)
      Creates a generator factory for creating JsonGenerator instances.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.stream.JsonLocation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.stream.JsonLocation

  • Packages that use JsonLocation
    Package Description
    javax.json.stream
    Provides a streaming API to parse and generate JSON.

    • Uses of JsonLocation in javax.json.stream

      Methods in javax.json.stream that return JsonLocation
      Modifier and Type Method and Description
      JsonLocation JsonParsingException.getLocation()
      Return the location of the incorrect JSON.
      JsonLocation JsonParser.getLocation()
      Return the location that corresponds to the parser's current state in the JSON input source.
      Constructors in javax.json.stream with parameters of type JsonLocation
      Constructor and Description
      JsonParsingException(String message, JsonLocation location)
      Constructs a new runtime exception with the specified detail message.
      JsonParsingException(String message, Throwable cause, JsonLocation location)
      Constructs a new runtime exception with the specified detail message and cause.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.stream.JsonParser (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.stream.JsonParser

  • Packages that use JsonParser
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.
    javax.json.stream
    Provides a streaming API to parse and generate JSON.

    • Uses of JsonParser in javax.json

      Methods in javax.json that return JsonParser
      Modifier and Type Method and Description
      static JsonParser Json.createParser(InputStream in)
      Creates a JSON parser from a byte stream.
      static JsonParser Json.createParser(Reader reader)
      Creates a JSON parser from a character stream.

    • Uses of JsonParser in javax.json.spi

      Methods in javax.json.spi that return JsonParser
      Modifier and Type Method and Description
      abstract JsonParser JsonProvider.createParser(InputStream in)
      Creates a JSON parser from the specified byte stream.
      abstract JsonParser JsonProvider.createParser(Reader reader)
      Creates a JSON parser from a character stream.

    • Uses of JsonParser in javax.json.stream

      Methods in javax.json.stream that return JsonParser
      Modifier and Type Method and Description
      JsonParser JsonParserFactory.createParser(InputStream in)
      Creates a JSON parser from the specified byte stream.
      JsonParser JsonParserFactory.createParser(InputStream in, Charset charset)
      Creates a JSON parser from the specified byte stream.
      JsonParser JsonParserFactory.createParser(JsonArray array)
      Creates a JSON parser from the specified JSON array.
      JsonParser JsonParserFactory.createParser(JsonObject obj)
      Creates a JSON parser from the specified JSON object.
      JsonParser JsonParserFactory.createParser(Reader reader)
      Creates a JSON parser from a character stream.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.json.stream.JsonParserFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.json.stream.JsonParserFactory

  • Packages that use JsonParserFactory
    Package Description
    javax.json
    Provides an object model API to process JSON.
    javax.json.spi
    Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

    • Uses of JsonParserFactory in javax.json

      Methods in javax.json that return JsonParserFactory
      Modifier and Type Method and Description
      static JsonParserFactory Json.createParserFactory(Map<String,?> config)
      Creates a parser factory for creating JsonParser objects.

    • Uses of JsonParserFactory in javax.json.spi

      Methods in javax.json.spi that return JsonParserFactory
      Modifier and Type Method and Description
      abstract JsonParserFactory JsonProvider.createParserFactory(Map<String,?> config)
      Creates a parser factory for creating JsonParser instances.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


HandlerChain (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jws

Annotation Type HandlerChain

  • @Retention(value=RUNTIME)
@Target(value={TYPE,METHOD,FIELD})
public @interface HandlerChain

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String file

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      Deprecated.

    • Element Detail

      • file

        public abstract String file

      • name

        @Deprecated
public abstract String name
        Deprecated.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.jws (Java(TM) EE 7 Specification APIs)

javax.jws

Enums

  • WebParam.Mode

Annotation Types

  • HandlerChain
  • Oneway
  • WebMethod
  • WebParam
  • WebResult
  • WebService


javax.jws (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.jws

  • Enum Summary
    Enum Description
    WebParam.Mode
  • Annotation Types Summary
    Annotation Type Description
    HandlerChain
    Oneway
    WebMethod
    WebParam
    WebResult
    WebService
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.jws Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.jws

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.jws.WebService (implements java.lang.annotation.Annotation)
  • javax.jws.WebResult (implements java.lang.annotation.Annotation)
  • javax.jws.WebParam (implements java.lang.annotation.Annotation)
  • javax.jws.WebMethod (implements java.lang.annotation.Annotation)
  • javax.jws.Oneway (implements java.lang.annotation.Annotation)
  • javax.jws.HandlerChain (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.jws.WebParam.Mode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Oneway (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jws

Annotation Type Oneway

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface Oneway
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.jws (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.jws

  • Packages that use javax.jws
    Package Description
    javax.jws
  • Classes in javax.jws used by javax.jws
    Class and Description
    WebParam.Mode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WebMethod (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jws

Annotation Type WebMethod

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface WebMethod

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      String action
      boolean | exclude
      String operationName

    • Element Detail

      • operationName

        public abstract String operationName
        Default:
        ""

      • action

        public abstract String action
        Default:
        ""

      • exclude

        public abstract boolean exclude
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jws

Annotation Type WebParam

  • @Retention(value=RUNTIME)
@Target(value=PARAMETER)
public @interface WebParam

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      boolean | header
      WebParam.Mode mode
      String name
      String partName
      String targetNamespace

    • Element Detail

      • name

        public abstract String name
        Default:
        ""

      • partName

        public abstract String partName
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Default:
        ""

      • mode

        public abstract WebParam.Mode mode
        Default:
        javax.jws.WebParam.Mode.IN

      • header

        public abstract boolean header
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebParam.Mode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.jws

Enum WebParam.Mode

  • java.lang.Object
    • java.lang.Enum<WebParam.Mode>
      • javax.jws.WebParam.Mode
  • All Implemented Interfaces:
    Serializable, Comparable<WebParam.Mode>
    Enclosing class:
    WebParam

    public static enum WebParam.Mode
extends Enum<WebParam.Mode>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      IN
      INOUT
      OUT

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static WebParam.Mode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static WebParam.Mode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • IN

        public static final WebParam.Mode IN

      • OUT

        public static final WebParam.Mode OUT

      • INOUT

        public static final WebParam.Mode INOUT

    • Method Detail

      • values

        public static WebParam.Mode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (WebParam.Mode c : WebParam.Mode.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static WebParam.Mode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


WebResult (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jws

Annotation Type WebResult

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface WebResult

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      boolean | header
      String name
      String partName
      String targetNamespace

    • Element Detail

      • name

        public abstract String name
        Default:
        ""

      • partName

        public abstract String partName
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Default:
        ""

      • header

        public abstract boolean header
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebService (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jws

Annotation Type WebService

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface WebService

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String endpointInterface
      String name
      String portName
      String serviceName
      String targetNamespace
      String wsdlLocation

    • Element Detail

      • name

        public abstract String name
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Default:
        ""

      • serviceName

        public abstract String serviceName
        Default:
        ""

      • portName

        public abstract String portName
        Default:
        ""

      • wsdlLocation

        public abstract String wsdlLocation
        Default:
        ""

      • endpointInterface

        public abstract String endpointInterface
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.jws.HandlerChain (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.HandlerChain

No usage of javax.jws.HandlerChain
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.Oneway (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.Oneway

No usage of javax.jws.Oneway
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.WebMethod (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.WebMethod

No usage of javax.jws.WebMethod
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.WebParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.WebParam

No usage of javax.jws.WebParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.WebParam.Mode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.WebParam.Mode

  • Packages that use WebParam.Mode
    Package Description
    javax.jws

    • Uses of WebParam.Mode in javax.jws

      Methods in javax.jws that return WebParam.Mode
      Modifier and Type Method and Description
      static WebParam.Mode WebParam.Mode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static WebParam.Mode[] WebParam.Mode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.WebResult (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.WebResult

No usage of javax.jws.WebResult
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.WebService (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.WebService

No usage of javax.jws.WebService
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


InitParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jws.soap

Annotation Type InitParam

  • Deprecated.

    @Deprecated
public @interface InitParam

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      Deprecated.
      String value
      Deprecated.

    • Element Detail

      • name

        public abstract String name
        Deprecated.

      • value

        public abstract String value
        Deprecated.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.jws.soap (Java(TM) EE 7 Specification APIs)

javax.jws.soap

Enums

  • SOAPBinding.ParameterStyle
  • SOAPBinding.Style
  • SOAPBinding.Use

Annotation Types

  • InitParam
  • SOAPBinding
  • SOAPMessageHandler
  • SOAPMessageHandlers


javax.jws.soap (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.jws.soap

  • Enum Summary
    Enum Description
    SOAPBinding.ParameterStyle
    SOAPBinding.Style
    SOAPBinding.Use
  • Annotation Types Summary
    Annotation Type | Description
    InitParam | Deprecated
    SOAPBinding
    SOAPMessageHandler | Deprecated
    SOAPMessageHandlers | Deprecated
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.jws.soap Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.jws.soap

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.jws.soap.SOAPMessageHandlers (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandler (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPBinding (implements java.lang.annotation.Annotation)
  • javax.jws.soap.InitParam (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.jws.soap.SOAPBinding.Style
      • javax.jws.soap.SOAPBinding.Use
      • javax.jws.soap.SOAPBinding.ParameterStyle
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


SOAPBinding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jws.soap

Annotation Type SOAPBinding

  • @Retention(value=RUNTIME)
@Target(value={TYPE,METHOD})
public @interface SOAPBinding

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      SOAPBinding.ParameterStyle parameterStyle
      SOAPBinding.Style style
      SOAPBinding.Use use

    • Element Detail

      • style

        public abstract SOAPBinding.Style style
        Default:
        javax.jws.soap.SOAPBinding.Style.DOCUMENT

      • use

        public abstract SOAPBinding.Use use
        Default:
        javax.jws.soap.SOAPBinding.Use.LITERAL

      • parameterStyle

        public abstract SOAPBinding.ParameterStyle parameterStyle
        Default:
        javax.jws.soap.SOAPBinding.ParameterStyle.WRAPPED
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


SOAPBinding.ParameterStyle (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.jws.soap

Enum SOAPBinding.ParameterStyle

  • java.lang.Object
    • java.lang.Enum<SOAPBinding.ParameterStyle>
      • javax.jws.soap.SOAPBinding.ParameterStyle
  • All Implemented Interfaces:
    Serializable, Comparable<SOAPBinding.ParameterStyle>
    Enclosing class:
    SOAPBinding

    public static enum SOAPBinding.ParameterStyle
extends Enum<SOAPBinding.ParameterStyle>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BARE
      WRAPPED

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static SOAPBinding.ParameterStyle valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SOAPBinding.ParameterStyle[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BARE

        public static final SOAPBinding.ParameterStyle BARE

      • WRAPPED

        public static final SOAPBinding.ParameterStyle WRAPPED

    • Method Detail

      • values

        public static SOAPBinding.ParameterStyle[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SOAPBinding.ParameterStyle c : SOAPBinding.ParameterStyle.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SOAPBinding.ParameterStyle valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


SOAPBinding.Style (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.jws.soap

Enum SOAPBinding.Style

  • java.lang.Object
    • java.lang.Enum<SOAPBinding.Style>
      • javax.jws.soap.SOAPBinding.Style
  • All Implemented Interfaces:
    Serializable, Comparable<SOAPBinding.Style>
    Enclosing class:
    SOAPBinding

    public static enum SOAPBinding.Style
extends Enum<SOAPBinding.Style>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      DOCUMENT
      RPC

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static SOAPBinding.Style valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SOAPBinding.Style[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DOCUMENT

        public static final SOAPBinding.Style DOCUMENT

      • RPC

        public static final SOAPBinding.Style RPC

    • Method Detail

      • values

        public static SOAPBinding.Style[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SOAPBinding.Style c : SOAPBinding.Style.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SOAPBinding.Style valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


SOAPBinding.Use (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.jws.soap

Enum SOAPBinding.Use

  • java.lang.Object
    • java.lang.Enum<SOAPBinding.Use>
      • javax.jws.soap.SOAPBinding.Use
  • All Implemented Interfaces:
    Serializable, Comparable<SOAPBinding.Use>
    Enclosing class:
    SOAPBinding

    public static enum SOAPBinding.Use
extends Enum<SOAPBinding.Use>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ENCODED
      LITERAL

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static SOAPBinding.Use valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SOAPBinding.Use[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LITERAL

        public static final SOAPBinding.Use LITERAL

      • ENCODED

        public static final SOAPBinding.Use ENCODED

    • Method Detail

      • values

        public static SOAPBinding.Use[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SOAPBinding.Use c : SOAPBinding.Use.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SOAPBinding.Use valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


SOAPMessageHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jws.soap

Annotation Type SOAPMessageHandler

  • Deprecated.

    @Deprecated
public @interface SOAPMessageHandler

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String className
      Deprecated.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String[] headers
      Deprecated.
      InitParam[] initParams
      Deprecated.
      String name
      Deprecated.
      String[] roles
      Deprecated.

    • Element Detail

      • className

        public abstract String className
        Deprecated.

      • name

        public abstract String name
        Deprecated.
        Default:
        ""

      • initParams

        public abstract InitParam[] initParams
        Deprecated.
        Default:
        {}

      • roles

        public abstract String[] roles
        Deprecated.
        Default:
        {}

      • headers

        public abstract String[] headers
        Deprecated.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


SOAPMessageHandlers (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.jws.soap

Annotation Type SOAPMessageHandlers

  • Deprecated.

    @Retention(value=RUNTIME)
@Target(value=TYPE)
@Deprecated
public @interface SOAPMessageHandlers

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      SOAPMessageHandler[] value
      Deprecated.

    • Element Detail

      • value

        public abstract SOAPMessageHandler[] value
        Deprecated.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.jws.soap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.jws.soap

  • Packages that use javax.jws.soap
    Package Description
    javax.jws.soap
  • Classes in javax.jws.soap used by javax.jws.soap
    Class and Description
    SOAPBinding.ParameterStyle
    SOAPBinding.Style
    SOAPBinding.Use
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.soap.InitParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.soap.InitParam

No usage of javax.jws.soap.InitParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.soap.SOAPBinding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.soap.SOAPBinding

No usage of javax.jws.soap.SOAPBinding
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.soap.SOAPBinding.ParameterStyle (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.soap.SOAPBinding.ParameterStyle

  • Packages that use SOAPBinding.ParameterStyle
    Package Description
    javax.jws.soap

    • Uses of SOAPBinding.ParameterStyle in javax.jws.soap

      Methods in javax.jws.soap that return SOAPBinding.ParameterStyle
      Modifier and Type Method and Description
      static SOAPBinding.ParameterStyle SOAPBinding.ParameterStyle.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SOAPBinding.ParameterStyle[] SOAPBinding.ParameterStyle.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.soap.SOAPBinding.Style (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.soap.SOAPBinding.Style

  • Packages that use SOAPBinding.Style
    Package Description
    javax.jws.soap

    • Uses of SOAPBinding.Style in javax.jws.soap

      Methods in javax.jws.soap that return SOAPBinding.Style
      Modifier and Type Method and Description
      static SOAPBinding.Style SOAPBinding.Style.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SOAPBinding.Style[] SOAPBinding.Style.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.soap.SOAPBinding.Use (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.soap.SOAPBinding.Use

  • Packages that use SOAPBinding.Use
    Package Description
    javax.jws.soap

    • Uses of SOAPBinding.Use in javax.jws.soap

      Methods in javax.jws.soap that return SOAPBinding.Use
      Modifier and Type Method and Description
      static SOAPBinding.Use SOAPBinding.Use.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SOAPBinding.Use[] SOAPBinding.Use.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.soap.SOAPMessageHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.soap.SOAPMessageHandler

No usage of javax.jws.soap.SOAPMessageHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.jws.soap.SOAPMessageHandlers (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.jws.soap.SOAPMessageHandlers

No usage of javax.jws.soap.SOAPMessageHandlers
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Address (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Address

  • java.lang.Object
    • javax.mail.Address
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    InternetAddress, NewsAddress

    public abstract class Address
extends Object
implements Serializable
    This abstract class models the addresses in a message. Subclasses provide specific implementations. Subclasses will typically be serializable so that (for example) the use of Address objects in search terms can be serialized along with the search terms.
    Author:
    John Mani, Bill Shannon
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      Address()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract boolean equals(Object address)
      The equality operator.
      abstract String getType()
      Return a type string that identifies this address type.
      abstract String toString()
      Return a String representation of this address object.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Address

        public Address()

    • Method Detail

      • getType

        public abstract String getType()
        Return a type string that identifies this address type.
        Returns:
        address type
        See Also:
        InternetAddress

      • toString

        public abstract String toString()
        Return a String representation of this address object.
        Overrides:
        toString in class Object
        Returns:
        string representation of this address

      • equals

        public abstract boolean equals(Object address)
        The equality operator. Subclasses should provide an implementation of this method that supports value equality (do the two Address objects represent the same destination?), not object reference equality. A subclass must also provide a corresponding implementation of the hashCode method that preserves the general contract of equals and hashCode - objects that compare as equal must have the same hashCode.
        Overrides:
        equals in class Object
        Parameters:
        address - Address object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AuthenticationFailedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class AuthenticationFailedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.AuthenticationFailedException
  • All Implemented Interfaces:
    Serializable

    public class AuthenticationFailedException
extends MessagingException
    This exception is thrown when the connect method on a Store or Transport object fails due to an authentication failure (e.g., bad user name or password).
    Author:
    Bill Shannon
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      AuthenticationFailedException()
      Constructs an AuthenticationFailedException.
      AuthenticationFailedException(String message)
      Constructs an AuthenticationFailedException with the specified detail message.
      AuthenticationFailedException(String message, Exception e)
      Constructs an AuthenticationFailedException with the specified detail message and embedded exception.

    • Method Summary

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AuthenticationFailedException

        public AuthenticationFailedException()
        Constructs an AuthenticationFailedException.

      • AuthenticationFailedException

        public AuthenticationFailedException(String message)
        Constructs an AuthenticationFailedException with the specified detail message.
        Parameters:
        message - The detailed error message

      • AuthenticationFailedException

        public AuthenticationFailedException(String message,
                             Exception e)
        Constructs an AuthenticationFailedException with the specified detail message and embedded exception. The exception is chained to this exception.
        Parameters:
        message - The detailed error message
        e - The embedded exception
        Since:
        JavaMail 1.5
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Authenticator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Authenticator

  • java.lang.Object
    • javax.mail.Authenticator

  • public abstract class Authenticator
extends Object
    The class Authenticator represents an object that knows how to obtain authentication for a network connection. Usually, it will do this by prompting the user for information.

    Applications use this class by creating a subclass, and registering an instance of that subclass with the session when it is created. When authentication is required, the system will invoke a method on the subclass (like getPasswordAuthentication). The subclass's method can query about the authentication being requested with a number of inherited methods (getRequestingXXX()), and form an appropriate message for the user.

    All methods that request authentication have a default implementation that fails.

    Author:
    Bill Foote, Bill Shannon
    See Also:
    Authenticator, Session.getInstance(java.util.Properties, javax.mail.Authenticator), Session.getDefaultInstance(java.util.Properties, javax.mail.Authenticator), Session.requestPasswordAuthentication(java.net.InetAddress, int, java.lang.String, java.lang.String, java.lang.String), PasswordAuthentication

    • Constructor Summary

      Constructors
      Constructor and Description
      Authenticator()

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      protected String | getDefaultUserName()
      protected PasswordAuthentication getPasswordAuthentication()
      Called when password authentication is needed.
      protected int | getRequestingPort()
      protected String | getRequestingPrompt()
      protected String getRequestingProtocol()
      Give the protocol that's requesting the connection.
      protected InetAddress | getRequestingSite()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Authenticator

        public Authenticator()

    • Method Detail

      • getRequestingSite

        protected final InetAddress getRequestingSite()
        Returns:
        the InetAddress of the site requesting authorization, or null if it's not available.

      • getRequestingPort

        protected final int getRequestingPort()
        Returns:
        the port for the requested connection

      • getRequestingProtocol

        protected final String getRequestingProtocol()
        Give the protocol that's requesting the connection. Often this will be based on a URLName.
        Returns:
        the protcol
        See Also:
        URLName.getProtocol()

      • getRequestingPrompt

        protected final String getRequestingPrompt()
        Returns:
        the prompt string given by the requestor

      • getDefaultUserName

        protected final String getDefaultUserName()
        Returns:
        the default user name given by the requestor

      • getPasswordAuthentication

        protected PasswordAuthentication getPasswordAuthentication()
        Called when password authentication is needed. Subclasses should override the default implementation, which returns null.

        Note that if this method uses a dialog to prompt the user for this information, the dialog needs to block until the user supplies the information. This method can not simply return after showing the dialog.

        Returns:
        The PasswordAuthentication collected from the user, or null if none is provided.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BodyPart (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class BodyPart

  • java.lang.Object
    • javax.mail.BodyPart
  • All Implemented Interfaces:
    Part
    Direct Known Subclasses:
    MimeBodyPart

    public abstract class BodyPart
extends Object
implements Part
    This class models a Part that is contained within a Multipart. This is an abstract class. Subclasses provide actual implementations.

    BodyPart implements the Part interface. Thus, it contains a set of attributes and a "content".

    Author:
    John Mani, Bill Shannon

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Multipart parent
      The Multipart object containing this BodyPart, if known.

      • Fields inherited from interface javax.mail.Part

        ATTACHMENT, INLINE

    • Constructor Summary

      Constructors
      Constructor and Description
      BodyPart()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Multipart getParent()
      Return the containing Multipart object, or null if not known.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.mail.Part

        addHeader, getAllHeaders, getContent, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getInputStream, getLineCount, getMatchingHeaders, getNonMatchingHeaders, getSize, isMimeType, removeHeader, setContent, setContent, setDataHandler, setDescription, setDisposition, setFileName, setHeader, setText, writeTo

    • Field Detail

      • parent

        protected Multipart parent
        The Multipart object containing this BodyPart, if known.
        Since:
        JavaMail 1.1

    • Constructor Detail

      • BodyPart

        public BodyPart()

    • Method Detail

      • getParent

        public Multipart getParent()
        Return the containing Multipart object, or null if not known.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EncodingAware (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Interface EncodingAware

  • public interface EncodingAware
    A DataSource that also implements EncodingAware may specify the Content-Transfer-Encoding to use for its data. Valid Content-Transfer-Encoding values specified by RFC 2045 are "7bit", "8bit", "quoted-printable", "base64", and "binary".

    For example, a FileDataSource could be created that forces all files to be base64 encoded:

      public class Base64FileDataSource extends FileDataSource
                                        implements EncodingAware {
        public Base64FileDataSource(File file) {
            super(file);
        }

        // implements EncodingAware.getEncoding()
        public String getEncoding() {
            return "base64";
        }
  }

    Since:
    JavaMail 1.5
    Author:
    Bill Shannon

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getEncoding()
      Return the MIME Content-Transfer-Encoding to use for this data, or null to indicate that an appropriate value should be chosen by the caller.

    • Method Detail

      • getEncoding

        String getEncoding()
        Return the MIME Content-Transfer-Encoding to use for this data, or null to indicate that an appropriate value should be chosen by the caller.
        Returns:
        the Content-Transfer-Encoding value, or null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FetchProfile (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class FetchProfile

  • java.lang.Object
    • javax.mail.FetchProfile

  • public class FetchProfile
extends Object
    Clients use a FetchProfile to list the Message attributes that it wishes to prefetch from the server for a range of messages.

    Messages obtained from a Folder are light-weight objects that typically start off as empty references to the actual messages. Such a Message object is filled in "on-demand" when the appropriate get*() methods are invoked on that particular Message. Certain server-based message access protocols (Ex: IMAP) allow batch fetching of message attributes for a range of messages in a single request. Clients that want to use message attributes for a range of Messages (Example: to display the top-level headers in a headerlist) might want to use the optimization provided by such servers. The FetchProfile allows the client to indicate this desire to the server.

    Note that implementations are not obligated to support FetchProfiles, since there might be cases where the backend service does not allow easy, efficient fetching of such profiles.

    Sample code that illustrates the use of a FetchProfile is given below:

  Message[] msgs = folder.getMessages();

  FetchProfile fp = new FetchProfile();
  fp.add(FetchProfile.Item.ENVELOPE);
  fp.add("X-mailer");
  folder.fetch(msgs, fp);

    Author:
    John Mani, Bill Shannon
    See Also:
    Folder.fetch(javax.mail.Message[], javax.mail.FetchProfile)

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  FetchProfile.Item
      This inner class is the base class of all items that can be requested in a FetchProfile.

    • Constructor Summary

      Constructors
      Constructor and Description
      FetchProfile()
      Create an empty FetchProfile.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void add(FetchProfile.Item item)
      Add the given special item as one of the attributes to be prefetched.
      void add(String headerName)
      Add the specified header-field to the list of attributes to be prefetched.
      boolean contains(FetchProfile.Item item)
      Returns true if the fetch profile contains given special item.
      boolean contains(String headerName)
      Returns true if the fetch profile contains given header name.
      String[] getHeaderNames()
      Get the names of the header-fields set in this profile.
      FetchProfile.Item[] getItems()
      Get the items set in this profile.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FetchProfile

        public FetchProfile()
        Create an empty FetchProfile.

    • Method Detail

      • add

        public void add(FetchProfile.Item item)
        Add the given special item as one of the attributes to be prefetched.
        Parameters:
        item - the special item to be fetched
        See Also:
        FetchProfile.Item.ENVELOPE, FetchProfile.Item.CONTENT_INFO, FetchProfile.Item.FLAGS

      • add

        public void add(String headerName)
        Add the specified header-field to the list of attributes to be prefetched.
        Parameters:
        headerName - header to be prefetched

      • contains

        public boolean contains(FetchProfile.Item item)
        Returns true if the fetch profile contains given special item.

      • contains

        public boolean contains(String headerName)
        Returns true if the fetch profile contains given header name.

      • getItems

        public FetchProfile.Item[] getItems()
        Get the items set in this profile.
        Returns:
        items set in this profile

      • getHeaderNames

        public String[] getHeaderNames()
        Get the names of the header-fields set in this profile.
        Returns:
        headers set in this profile
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FetchProfile.Item (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class FetchProfile.Item

  • java.lang.Object
    • javax.mail.FetchProfile.Item
  • Direct Known Subclasses:
    UIDFolder.FetchProfileItem
    Enclosing class:
    FetchProfile

    public static class FetchProfile.Item
extends Object
    This inner class is the base class of all items that can be requested in a FetchProfile. The items currently defined here are ENVELOPE, CONTENT_INFO and FLAGS. The UIDFolder interface defines the UID Item as well.

    Note that this class only has a protected constructor, therby restricting new Item types to either this class or subclasses. This effectively implements a enumeration of allowed Item types.

    See Also:
    UIDFolder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static FetchProfile.Item CONTENT_INFO
      This item is for fetching information about the content of the message.
      static FetchProfile.Item ENVELOPE
      This is the Envelope item.
      static FetchProfile.Item FLAGS
      This is the Flags item.
      static FetchProfile.Item SIZE
      SIZE is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected FetchProfile.Item(String name)
      Constructor for an item.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      Include the name in the toString return value for debugging.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • ENVELOPE

        public static final FetchProfile.Item ENVELOPE
        This is the Envelope item.

        The Envelope is an aggregration of the common attributes of a Message. Implementations should include the following attributes: From, To, Cc, Bcc, ReplyTo, Subject and Date. More items may be included as well.

        For implementations of the IMAP4 protocol (RFC 2060), the Envelope should include the ENVELOPE data item. More items may be included too.

      • CONTENT_INFO

        public static final FetchProfile.Item CONTENT_INFO
        This item is for fetching information about the content of the message.

        This includes all the attributes that describe the content of the message. Implementations should include the following attributes: ContentType, ContentDisposition, ContentDescription, Size and LineCount. Other items may be included as well.

      • SIZE

        public static final FetchProfile.Item SIZE
        SIZE is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder. This item indicates that the sizes of the messages in the specified range should be prefetched.

        Since:
        JavaMail 1.5

      • FLAGS

        public static final FetchProfile.Item FLAGS
        This is the Flags item.

    • Constructor Detail

      • FetchProfile.Item

        protected FetchProfile.Item(String name)
        Constructor for an item. The name is used only for debugging.

    • Method Detail

      • toString

        public String toString()
        Include the name in the toString return value for debugging.
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Flags (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Flags

  • java.lang.Object
    • javax.mail.Flags
  • All Implemented Interfaces:
    Serializable, Cloneable

    public class Flags
extends Object
implements Cloneable, Serializable
    The Flags class represents the set of flags on a Message. Flags are composed of predefined system flags, and user defined flags.

    A System flag is represented by the Flags.Flag inner class. A User defined flag is represented as a String. User flags are case-independent.

    A set of standard system flags are predefined. Most folder implementations are expected to support these flags. Some implementations may also support arbitrary user-defined flags. The getPermanentFlags method on a Folder returns a Flags object that holds all the flags that are supported by that folder implementation.

    A Flags object is serializable so that (for example) the use of Flags objects in search terms can be serialized along with the search terms.

    Warning: Serialized objects of this class may not be compatible with future JavaMail API releases. The current serialization support is appropriate for short term storage.

    The below code sample illustrates how to set, examine, and get the flags for a message.

 Message m = folder.getMessage(1);
 m.setFlag(Flags.Flag.DELETED, true); // set the DELETED flag

 // Check if DELETED flag is set on this message
 if (m.isSet(Flags.Flag.DELETED))
        System.out.println("DELETED message");

 // Examine ALL system flags for this message
 Flags flags = m.getFlags();
 Flags.Flag[] sf = flags.getSystemFlags();
 for (int i = 0; i < sf.length; i++) {
        if (sf[i] == Flags.Flag.DELETED)
            System.out.println("DELETED message");
        else if (sf[i] == Flags.Flag.SEEN)
            System.out.println("SEEN message");
      ......
      ......
 }

    Author:
    John Mani, Bill Shannon
    See Also:
    Folder.getPermanentFlags(), Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  Flags.Flag
      This inner class represents an individual system flag.

    • Constructor Summary

      Constructors
      Constructor and Description
      Flags()
      Construct an empty Flags object.
      Flags(Flags.Flag flag)
      Construct a Flags object initialized with the given system flag.
      Flags(Flags flags)
      Construct a Flags object initialized with the given flags.
      Flags(String flag)
      Construct a Flags object initialized with the given user flag.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void add(Flags.Flag flag)
      Add the specified system flag to this Flags object.
      void add(Flags f)
      Add all the flags in the given Flags object to this Flags object.
      void add(String flag)
      Add the specified user flag to this Flags object.
      Object clone()
      Returns a clone of this Flags object.
      boolean contains(Flags.Flag flag)
      Check whether the specified system flag is present in this Flags object.
      boolean contains(Flags f)
      Check whether all the flags in the specified Flags object are present in this Flags object.
      boolean contains(String flag)
      Check whether the specified user flag is present in this Flags object.
      boolean equals(Object obj)
      Check whether the two Flags objects are equal.
      Flags.Flag[] getSystemFlags()
      Return all the system flags in this Flags object.
      String[] getUserFlags()
      Return all the user flags in this Flags object.
      int hashCode()
      Compute a hash code for this Flags object.
      void remove(Flags.Flag flag)
      Remove the specified system flag from this Flags object.
      void remove(Flags f)
      Remove all flags in the given Flags object from this Flags object.
      void remove(String flag)
      Remove the specified user flag from this Flags object.

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Flags

        public Flags()
        Construct an empty Flags object.

      • Flags

        public Flags(Flags flags)
        Construct a Flags object initialized with the given flags.
        Parameters:
        flags - the flags for initialization

      • Flags

        public Flags(Flags.Flag flag)
        Construct a Flags object initialized with the given system flag.
        Parameters:
        flag - the flag for initialization

      • Flags

        public Flags(String flag)
        Construct a Flags object initialized with the given user flag.
        Parameters:
        flag - the flag for initialization

    • Method Detail

      • add

        public void add(Flags.Flag flag)
        Add the specified system flag to this Flags object.
        Parameters:
        flag - the flag to add

      • add

        public void add(String flag)
        Add the specified user flag to this Flags object.
        Parameters:
        flag - the flag to add

      • add

        public void add(Flags f)
        Add all the flags in the given Flags object to this Flags object.
        Parameters:
        f - Flags object

      • remove

        public void remove(Flags.Flag flag)
        Remove the specified system flag from this Flags object.
        Parameters:
        flag - the flag to be removed

      • remove

        public void remove(String flag)
        Remove the specified user flag from this Flags object.
        Parameters:
        flag - the flag to be removed

      • remove

        public void remove(Flags f)
        Remove all flags in the given Flags object from this Flags object.
        Parameters:
        f - the flag to be removed

      • contains

        public boolean contains(Flags.Flag flag)
        Check whether the specified system flag is present in this Flags object.
        Returns:
        true of the given flag is present, otherwise false.

      • contains

        public boolean contains(String flag)
        Check whether the specified user flag is present in this Flags object.
        Returns:
        true of the given flag is present, otherwise false.

      • contains

        public boolean contains(Flags f)
        Check whether all the flags in the specified Flags object are present in this Flags object.
        Returns:
        true if all flags in the given Flags object are present, otherwise false.

      • equals

        public boolean equals(Object obj)
        Check whether the two Flags objects are equal.
        Overrides:
        equals in class Object
        Returns:
        true if they're equal

      • hashCode

        public int hashCode()
        Compute a hash code for this Flags object.
        Overrides:
        hashCode in class Object
        Returns:
        the hash code

      • getSystemFlags

        public Flags.Flag[] getSystemFlags()
        Return all the system flags in this Flags object. Returns an array of size zero if no flags are set.
        Returns:
        array of Flags.Flag objects representing system flags

      • getUserFlags

        public String[] getUserFlags()
        Return all the user flags in this Flags object. Returns an array of size zero if no flags are set.
        Returns:
        array of Strings, each String represents a flag.

      • clone

        public Object clone()
        Returns a clone of this Flags object.
        Overrides:
        clone in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Flags.Flag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Flags.Flag

  • java.lang.Object
    • javax.mail.Flags.Flag
  • Enclosing class:
    Flags

    public static final class Flags.Flag
extends Object
    This inner class represents an individual system flag. A set of standard system flag objects are predefined here.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static Flags.Flag ANSWERED
      This message has been answered.
      static Flags.Flag DELETED
      This message is marked deleted.
      static Flags.Flag DRAFT
      This message is a draft.
      static Flags.Flag FLAGGED
      This message is flagged.
      static Flags.Flag RECENT
      This message is recent.
      static Flags.Flag SEEN
      This message is seen.
      static Flags.Flag USER
      A special flag that indicates that this folder supports user defined flags.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ANSWERED

        public static final Flags.Flag ANSWERED
        This message has been answered. This flag is set by clients to indicate that this message has been answered to.

      • DELETED

        public static final Flags.Flag DELETED
        This message is marked deleted. Clients set this flag to mark a message as deleted. The expunge operation on a folder removes all messages in that folder that are marked for deletion.

      • DRAFT

        public static final Flags.Flag DRAFT
        This message is a draft. This flag is set by clients to indicate that the message is a draft message.

      • FLAGGED

        public static final Flags.Flag FLAGGED
        This message is flagged. No semantic is defined for this flag. Clients alter this flag.

      • RECENT

        public static final Flags.Flag RECENT
        This message is recent. Folder implementations set this flag to indicate that this message is new to this folder, that is, it has arrived since the last time this folder was opened.

        Clients cannot alter this flag.

      • SEEN

        public static final Flags.Flag SEEN
        This message is seen. This flag is implicitly set by the implementation when the this Message's content is returned to the client in some form. The getInputStream and getContent methods on Message cause this flag to be set.

        Clients can alter this flag.

      • USER

        public static final Flags.Flag USER
        A special flag that indicates that this folder supports user defined flags.

        The implementation sets this flag. Clients cannot alter this flag but can use it to determine if a folder supports user defined flags by using folder.getPermanentFlags().contains(Flags.Flag.USER).

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Folder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Folder

  • java.lang.Object
    • javax.mail.Folder

  • public abstract class Folder
extends Object
    Folder is an abstract class that represents a folder for mail messages. Subclasses implement protocol specific Folders.

    Folders can contain Messages, other Folders or both, thus providing a tree-like hierarchy rooted at the Store's default folder. (Note that some Folder implementations may not allow both Messages and other Folders in the same Folder).

    The interpretation of folder names is implementation dependent. The different levels of hierarchy in a folder's full name are separated from each other by the hierarchy delimiter character.

    The case-insensitive full folder name (that is, the full name relative to the default folder for a Store) INBOX is reserved to mean the "primary folder for this user on this server". Not all Stores will provide an INBOX folder, and not all users will have an INBOX folder at all times. The name INBOX is reserved to refer to this folder, when it exists, in Stores that provide it.

    A Folder object obtained from a Store need not actually exist in the backend store. The exists method tests whether the folder exists or not. The create method creates a Folder.

    A Folder is initially in the closed state. Certain methods are valid in this state; the documentation for those methods note this. A Folder is opened by calling its 'open' method. All Folder methods, except open, delete and renameTo, are valid in this state.

    The only way to get a Folder is by invoking the getFolder method on Store, Folder, or Session, or by invoking the list or listSubscribed methods on Folder. Folder objects returned by the above methods are not cached by the Store. Thus, invoking the getFolder method with the same folder name multiple times will return distinct Folder objects. Likewise for the list and listSubscribed methods.

    The Message objects within the Folder are cached by the Folder. Thus, invoking getMessage(msgno) on the same message number multiple times will return the same Message object, until an expunge is done on this Folder.

    Message objects from a Folder are only valid while a Folder is open and should not be accessed after the Folder is closed, even if the Folder is subsequently reopened. Instead, new Message objects must be fetched from the Folder after the Folder is reopened.

    Note that a Message's message number can change within a session if the containing Folder is expunged using the expunge method. Clients that use message numbers as references to messages should be aware of this and should be prepared to deal with situation (probably by flushing out existing message number references and reloading them). Because of this complexity, it is better for clients to use Message objects as references to messages, rather than message numbers. Expunged Message objects still have to be pruned, but other Message objects in that folder are not affected by the expunge.

    Author:
    John Mani, Bill Shannon

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int HOLDS_FOLDERS
      This folder can contain other folders
      static int HOLDS_MESSAGES
      This folder can contain messages
      protected int mode
      The open mode of this folder.
      static int READ_ONLY
      The Folder is read only.
      static int READ_WRITE
      The state and contents of this folder can be modified.
      protected Store store
      The parent store.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Folder(Store store)
      Constructor that takes a Store object.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void addConnectionListener(ConnectionListener l)
      Add a listener for Connection events on this Folder.
      void addFolderListener(FolderListener l)
      Add a listener for Folder events on this Folder.
      void addMessageChangedListener(MessageChangedListener l)
      Add a listener for MessageChanged events on this Folder.
      void addMessageCountListener(MessageCountListener l)
      Add a listener for MessageCount events on this Folder.
      abstract void appendMessages(Message[] msgs)
      Append given Messages to this folder.
      abstract void close(boolean expunge)
      Close this Folder.
      void copyMessages(Message[] msgs, Folder folder)
      Copy the specified Messages from this Folder into another Folder.
      abstract boolean create(int type)
      Create this folder on the Store.
      abstract boolean delete(boolean recurse)
      Delete this Folder.
      abstract boolean exists()
      Tests if this folder physically exists on the Store.
      abstract Message[] expunge()
      Expunge (permanently remove) messages marked DELETED.
      void fetch(Message[] msgs, FetchProfile fp)
      Prefetch the items specified in the FetchProfile for the given Messages.
      protected void | finalize()
      int getDeletedMessageCount()
      Get the number of deleted messages in this Folder.
      abstract Folder getFolder(String name)
      Return the Folder object corresponding to the given name.
      abstract String getFullName()
      Returns the full name of this Folder.
      abstract Message getMessage(int msgnum)
      Get the Message object corresponding to the given message number.
      abstract int getMessageCount()
      Get total number of messages in this Folder.
      Message[] getMessages()
      Get all Message objects from this Folder.
      Message[] getMessages(int[] msgnums)
      Get the Message objects for message numbers specified in the array.
      Message[] getMessages(int start, int end)
      Get the Message objects for message numbers ranging from start through end, both start and end inclusive.
      int getMode()
      Return the open mode of this folder.
      abstract String getName()
      Returns the name of this Folder.
      int getNewMessageCount()
      Get the number of new messages in this Folder.
      abstract Folder getParent()
      Returns the parent folder of this folder.
      abstract Flags getPermanentFlags()
      Get the permanent flags supported by this Folder.
      abstract char getSeparator()
      Return the delimiter character that separates this Folder's pathname from the names of immediate subfolders.
      Store getStore()
      Returns the Store that owns this Folder object.
      abstract int getType()
      Returns the type of this Folder, that is, whether this folder can hold messages or subfolders or both.
      int getUnreadMessageCount()
      Get the total number of unread messages in this Folder.
      URLName getURLName()
      Return a URLName representing this folder.
      abstract boolean hasNewMessages()
      Returns true if this Folder has new messages since the last time this indication was reset.
      abstract boolean isOpen()
      Indicates whether this Folder is in the 'open' state.
      boolean isSubscribed()
      Returns true if this Folder is subscribed.
      Folder[] list()
      Convenience method that returns the list of folders under this Folder.
      abstract Folder[] list(String pattern)
      Returns a list of Folders belonging to this Folder's namespace that match the specified pattern.
      Folder[] listSubscribed()
      Convenience method that returns the list of subscribed folders under this Folder.
      Folder[] listSubscribed(String pattern)
      Returns a list of subscribed Folders belonging to this Folder's namespace that match the specified pattern.
      protected void notifyConnectionListeners(int type)
      Notify all ConnectionListeners.
      protected void notifyFolderListeners(int type)
      Notify all FolderListeners registered on this Folder and this folder's Store.
      protected void notifyFolderRenamedListeners(Folder folder)
      Notify all FolderListeners registered on this Folder and this folder's Store about the renaming of this folder.
      protected void notifyMessageAddedListeners(Message[] msgs)
      Notify all MessageCountListeners about the addition of messages into this folder.
      protected void notifyMessageChangedListeners(int type, Message msg)
      Notify all MessageChangedListeners.
      protected void notifyMessageRemovedListeners(boolean removed, Message[] msgs)
      Notify all MessageCountListeners about the removal of messages from this Folder.
      abstract void open(int mode)
      Open this Folder.
      void removeConnectionListener(ConnectionListener l)
      Remove a Connection event listener.
      void removeFolderListener(FolderListener l)
      Remove a Folder event listener.
      void removeMessageChangedListener(MessageChangedListener l)
      Remove a MessageChanged listener.
      void removeMessageCountListener(MessageCountListener l)
      Remove a MessageCount listener.
      abstract boolean renameTo(Folder f)
      Rename this Folder.
      Message[] search(SearchTerm term)
      Search this Folder for messages matching the specified search criterion.
      Message[] search(SearchTerm term, Message[] msgs)
      Search the given array of messages for those that match the specified search criterion.
      void setFlags(int[] msgnums, Flags flag, boolean value)
      Set the specified flags on the messages whose message numbers are in the array.
      void setFlags(int start, int end, Flags flag, boolean value)
      Set the specified flags on the messages numbered from start through end, both start and end inclusive.
      void setFlags(Message[] msgs, Flags flag, boolean value)
      Set the specified flags on the messages specified in the array.
      void setSubscribed(boolean subscribe)
      Subscribe or unsubscribe this Folder.
      String toString()
      override the default toString(), it will return the String from Folder.getFullName() or if that is null, it will use the default toString() behavior.

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • store

        protected Store store
        The parent store.

      • mode

        protected int mode
        The open mode of this folder. The open mode is Folder.READ_ONLY, Folder.READ_WRITE, or -1 if not known.
        Since:
        JavaMail 1.1

      • HOLDS_MESSAGES

        public static final int HOLDS_MESSAGES
        This folder can contain messages
        See Also:
        Constant Field Values

      • HOLDS_FOLDERS

        public static final int HOLDS_FOLDERS
        This folder can contain other folders
        See Also:
        Constant Field Values

      • READ_ONLY

        public static final int READ_ONLY
        The Folder is read only. The state and contents of this folder cannot be modified.
        See Also:
        Constant Field Values

      • READ_WRITE

        public static final int READ_WRITE
        The state and contents of this folder can be modified.
        See Also:
        Constant Field Values

    • Constructor Detail

      • Folder

        protected Folder(Store store)
        Constructor that takes a Store object.
        Parameters:
        store - the Store that holds this folder

    • Method Detail

      • getName

        public abstract String getName()
        Returns the name of this Folder.

        This method can be invoked on a closed Folder.

        Returns:
        name of the Folder

      • getFullName

        public abstract String getFullName()
        Returns the full name of this Folder. If the folder resides under the root hierarchy of this Store, the returned name is relative to the root. Otherwise an absolute name, starting with the hierarchy delimiter, is returned.

        This method can be invoked on a closed Folder.

        Returns:
        full name of the Folder

      • getURLName

        public URLName getURLName()
                   throws MessagingException
        Return a URLName representing this folder. The returned URLName does not include the password used to access the store.
        Returns:
        the URLName representing this folder
        Throws:
        MessagingException
        Since:
        JavaMail 1.1
        See Also:
        URLName

      • getStore

        public Store getStore()
        Returns the Store that owns this Folder object. This method can be invoked on a closed Folder.
        Returns:
        the Store

      • getParent

        public abstract Folder getParent()
                          throws MessagingException
        Returns the parent folder of this folder. This method can be invoked on a closed Folder. If this folder is the top of a folder hierarchy, this method returns null.

        Note that since Folder objects are not cached, invoking this method returns a new distinct Folder object.

        Returns:
        Parent folder
        Throws:
        MessagingException

      • exists

        public abstract boolean exists()
                        throws MessagingException
        Tests if this folder physically exists on the Store. This method can be invoked on a closed Folder.
        Returns:
        true if the folder exists, otherwise false
        Throws:
        MessagingException - typically if the connection to the server is lost.
        See Also:
        create(int)

      • list

        public abstract Folder[] list(String pattern)
                       throws MessagingException
        Returns a list of Folders belonging to this Folder's namespace that match the specified pattern. Patterns may contain the wildcard characters "%", which matches any character except hierarchy delimiters, and "*", which matches any character.

        As an example, given the folder hierarchy:

            Personal/
       Finance/
          Stocks
          Bonus
          StockOptions
       Jokes
        list("*") on "Personal" will return the whole hierarchy.
        list("%") on "Personal" will return "Finance" and "Jokes".
        list("Jokes") on "Personal" will return "Jokes".
        list("Stock*") on "Finance" will return "Stocks" and "StockOptions".

        Folder objects are not cached by the Store, so invoking this method on the same pattern multiple times will return that many distinct Folder objects.

        This method can be invoked on a closed Folder.

        Parameters:
        pattern - the match pattern
        Returns:
        array of matching Folder objects. An empty array is returned if no matching Folders exist.
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException
        See Also:
        listSubscribed(java.lang.String)

      • listSubscribed

        public Folder[] listSubscribed(String pattern)
                        throws MessagingException
        Returns a list of subscribed Folders belonging to this Folder's namespace that match the specified pattern. If the folder does not support subscription, this method should resolve to list. (The default implementation provided here, does just this). The pattern can contain wildcards as for list.

        Note that, at a given level of the folder hierarchy, a particular folder may not be subscribed, but folders underneath that folder in the folder hierarchy may be subscribed. In order to allow walking the folder hierarchy, such unsubscribed folders may be returned, indicating that a folder lower in the hierarchy is subscribed. The isSubscribed method on a folder will tell whether any particular folder is actually subscribed.

        Folder objects are not cached by the Store, so invoking this method on the same pattern multiple times will return that many distinct Folder objects.

        This method can be invoked on a closed Folder.

        Parameters:
        pattern - the match pattern
        Returns:
        array of matching subscribed Folder objects. An empty array is returned if no matching subscribed folders exist.
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException
        See Also:
        list(java.lang.String)

      • list

        public Folder[] list()
              throws MessagingException
        Convenience method that returns the list of folders under this Folder. This method just calls the list(String pattern) method with "%" as the match pattern. This method can be invoked on a closed Folder.
        Returns:
        array of Folder objects under this Folder. An empty array is returned if no subfolders exist.
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException
        See Also:
        list(java.lang.String)

      • listSubscribed

        public Folder[] listSubscribed()
                        throws MessagingException
        Convenience method that returns the list of subscribed folders under this Folder. This method just calls the listSubscribed(String pattern) method with "%" as the match pattern. This method can be invoked on a closed Folder.
        Returns:
        array of subscribed Folder objects under this Folder. An empty array is returned if no subscribed subfolders exist.
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException
        See Also:
        listSubscribed(java.lang.String)

      • getSeparator

        public abstract char getSeparator()
                           throws MessagingException
        Return the delimiter character that separates this Folder's pathname from the names of immediate subfolders. This method can be invoked on a closed Folder.
        Returns:
        Hierarchy separator character
        Throws:
        FolderNotFoundException - if the implementation requires the folder to exist, but it does not
        MessagingException

      • getType

        public abstract int getType()
                     throws MessagingException
        Returns the type of this Folder, that is, whether this folder can hold messages or subfolders or both. The returned value is an integer bitfield with the appropriate bits set. This method can be invoked on a closed folder.
        Returns:
        integer with appropriate bits set
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException
        See Also:
        HOLDS_FOLDERS, HOLDS_MESSAGES

      • create

        public abstract boolean create(int type)
                        throws MessagingException
        Create this folder on the Store. When this folder is created, any folders in its path that do not exist are also created.

        If the creation is successful, a CREATED FolderEvent is delivered to any FolderListeners registered on this Folder and this Store.

        Parameters:
        type - The type of this folder.
        Returns:
        true if the creation succeeds, else false.
        Throws:
        MessagingException
        See Also:
        HOLDS_FOLDERS, HOLDS_MESSAGES, FolderEvent

      • isSubscribed

        public boolean isSubscribed()
        Returns true if this Folder is subscribed.

        This method can be invoked on a closed Folder.

        The default implementation provided here just returns true.

        Returns:
        true if this Folder is subscribed

      • setSubscribed

        public void setSubscribed(boolean subscribe)
                   throws MessagingException
        Subscribe or unsubscribe this Folder. Not all Stores support subscription.

        This method can be invoked on a closed Folder.

        The implementation provided here just throws the MethodNotSupportedException.

        Parameters:
        subscribe - true to subscribe, false to unsubscribe
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MethodNotSupportedException - if this store does not support subscription
        MessagingException

      • hasNewMessages

        public abstract boolean hasNewMessages()
                                throws MessagingException
        Returns true if this Folder has new messages since the last time this indication was reset. When this indication is set or reset depends on the Folder implementation (and in the case of IMAP, depends on the server). This method can be used to implement a lightweight "check for new mail" operation on a Folder without opening it. (For example, a thread that monitors a mailbox and flags when it has new mail.) This method should indicate whether any messages in the Folder have the RECENT flag set.

        Note that this is not an incremental check for new mail, i.e., it cannot be used to determine whether any new messages have arrived since the last time this method was invoked. To implement incremental checks, the Folder needs to be opened.

        This method can be invoked on a closed Folder that can contain Messages.

        Returns:
        true if the Store has new Messages
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException

      • getFolder

        public abstract Folder getFolder(String name)
                          throws MessagingException
        Return the Folder object corresponding to the given name. Note that this folder does not physically have to exist in the Store. The exists() method on a Folder indicates whether it really exists on the Store.

        In some Stores, name can be an absolute path if it starts with the hierarchy delimiter. Otherwise, it is interpreted relative to this Folder.

        Folder objects are not cached by the Store, so invoking this method on the same name multiple times will return that many distinct Folder objects.

        This method can be invoked on a closed Folder.

        Parameters:
        name - name of the Folder
        Returns:
        Folder object
        Throws:
        MessagingException

      • delete

        public abstract boolean delete(boolean recurse)
                        throws MessagingException
        Delete this Folder. This method will succeed only on a closed Folder.

        The recurse flag controls whether the deletion affects subfolders or not. If true, all subfolders are deleted, then this folder itself is deleted. If false, the behaviour is dependent on the folder type and is elaborated below:

        • The folder can contain only messages: (type == HOLDS_MESSAGES).
          All messages within the folder are removed. The folder itself is then removed. An appropriate FolderEvent is generated by the Store and this folder.

        • The folder can contain only subfolders: (type == HOLDS_FOLDERS).
          If this folder is empty (does not contain any subfolders at all), it is removed. An appropriate FolderEvent is generated by the Store and this folder.
          If this folder contains any subfolders, the delete fails and returns false.

        • The folder can contain subfolders as well as messages:
          If the folder is empty (no messages or subfolders), it is removed. If the folder contains no subfolders, but only messages, then all messages are removed. The folder itself is then removed. In both the above cases, an appropriate FolderEvent is generated by the Store and this folder.

          If the folder contains subfolders there are 3 possible choices an implementation is free to do:

          1. The operation fails, irrespective of whether this folder contains messages or not. Some implementations might elect to go with this simple approach. The delete() method returns false.
          2. Any messages within the folder are removed. Subfolders are not removed. The folder itself is not removed or affected in any manner. The delete() method returns true. And the exists() method on this folder will return true indicating that this folder still exists.
            An appropriate FolderEvent is generated by the Store and this folder.
          3. Any messages within the folder are removed. Subfolders are not removed. The folder itself changes its type from HOLDS_FOLDERS | HOLDS_MESSAGES to HOLDS_FOLDERS. Thus new messages cannot be added to this folder, but new subfolders can be created underneath. The delete() method returns true indicating success. The exists() method on this folder will return true indicating that this folder still exists.
            An appropriate FolderEvent is generated by the Store and this folder.
        Returns:
        true if the Folder is deleted successfully
        Throws:
        FolderNotFoundException - if this folder does not exist
        IllegalStateException - if this folder is not in the closed state.
        MessagingException
        See Also:
        FolderEvent

      • renameTo

        public abstract boolean renameTo(Folder f)
                          throws MessagingException
        Rename this Folder. This method will succeed only on a closed Folder.

        If the rename is successful, a RENAMED FolderEvent is delivered to FolderListeners registered on this folder and its containing Store.

        Parameters:
        f - a folder representing the new name for this Folder
        Returns:
        true if the Folder is renamed successfully
        Throws:
        FolderNotFoundException - if this folder does not exist
        IllegalStateException - if this folder is not in the closed state.
        MessagingException
        See Also:
        FolderEvent

      • open

        public abstract void open(int mode)
                   throws MessagingException
        Open this Folder. This method is valid only on Folders that can contain Messages and that are closed.

        If this folder is opened successfully, an OPENED ConnectionEvent is delivered to any ConnectionListeners registered on this Folder.

        The effect of opening multiple connections to the same folder on a specifc Store is implementation dependent. Some implementations allow multiple readers, but only one writer. Others allow multiple writers as well as readers.

        Parameters:
        mode - open the Folder READ_ONLY or READ_WRITE
        Throws:
        FolderNotFoundException - if this folder does not exist.
        IllegalStateException - if this folder is not in the closed state.
        MessagingException
        See Also:
        READ_ONLY, READ_WRITE, getType(), ConnectionEvent

      • close

        public abstract void close(boolean expunge)
                    throws MessagingException
        Close this Folder. This method is valid only on open Folders.

        A CLOSED ConnectionEvent is delivered to any ConnectionListeners registered on this Folder. Note that the folder is closed even if this method terminates abnormally by throwing a MessagingException.

        Parameters:
        expunge - expunges all deleted messages if this flag is true
        Throws:
        IllegalStateException - if this folder is not opened
        MessagingException
        See Also:
        ConnectionEvent

      • isOpen

        public abstract boolean isOpen()
        Indicates whether this Folder is in the 'open' state.
        Returns:
        true if this Folder is in the 'open' state.

      • getMode

        public int getMode()
        Return the open mode of this folder. Returns Folder.READ_ONLY, Folder.READ_WRITE, or -1 if the open mode is not known (usually only because an older Folder provider has not been updated to use this new method).
        Returns:
        the open mode of this folder
        Throws:
        IllegalStateException - if this folder is not opened
        Since:
        JavaMail 1.1

      • getPermanentFlags

        public abstract Flags getPermanentFlags()
        Get the permanent flags supported by this Folder. Returns a Flags object that contains all the flags supported.

        The special flag Flags.Flag.USER indicates that this Folder supports arbitrary user-defined flags.

        The supported permanent flags for a folder may not be available until the folder is opened.

        Returns:
        permanent flags, or null if not known

      • getMessageCount

        public abstract int getMessageCount()
                             throws MessagingException
        Get total number of messages in this Folder.

        This method can be invoked on a closed folder. However, note that for some folder implementations, getting the total message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

        Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

        Returns:
        total number of messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException

      • getNewMessageCount

        public int getNewMessageCount()
                       throws MessagingException
        Get the number of new messages in this Folder.

        This method can be invoked on a closed folder. However, note that for some folder implementations, getting the new message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

        Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

        This implementation returns -1 if this folder is closed. Else this implementation gets each Message in the folder using getMessage(int) and checks whether its RECENT flag is set. The total number of messages that have this flag set is returned.

        Returns:
        number of new messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException

      • getUnreadMessageCount

        public int getUnreadMessageCount()
                          throws MessagingException
        Get the total number of unread messages in this Folder.

        This method can be invoked on a closed folder. However, note that for some folder implementations, getting the unread message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

        Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

        This implementation returns -1 if this folder is closed. Else this implementation gets each Message in the folder using getMessage(int) and checks whether its SEEN flag is set. The total number of messages that do not have this flag set is returned.

        Returns:
        total number of unread messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException

      • getDeletedMessageCount

        public int getDeletedMessageCount()
                           throws MessagingException
        Get the number of deleted messages in this Folder.

        This method can be invoked on a closed folder. However, note that for some folder implementations, getting the deleted message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

        Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

        This implementation returns -1 if this folder is closed. Else this implementation gets each Message in the folder using getMessage(int) and checks whether its DELETED flag is set. The total number of messages that have this flag set is returned.

        Returns:
        number of deleted messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException
        Since:
        JavaMail 1.3

      • getMessage

        public abstract Message getMessage(int msgnum)
                            throws MessagingException
        Get the Message object corresponding to the given message number. A Message object's message number is the relative position of this Message in its Folder. Messages are numbered starting at 1 through the total number of message in the folder. Note that the message number for a particular Message can change during a session if other messages in the Folder are deleted and the Folder is expunged.

        Message objects are light-weight references to the actual message that get filled up on demand. Hence Folder implementations are expected to provide light-weight Message objects.

        Unlike Folder objects, repeated calls to getMessage with the same message number will return the same Message object, as long as no messages in this folder have been expunged.

        Since message numbers can change within a session if the folder is expunged , clients are advised not to use message numbers as references to messages. Use Message objects instead.

        Parameters:
        msgnum - the message number
        Returns:
        the Message object
        Throws:
        FolderNotFoundException - if this folder does not exist.
        IllegalStateException - if this folder is not opened
        IndexOutOfBoundsException - if the message number is out of range.
        MessagingException
        See Also:
        getMessageCount(), fetch(javax.mail.Message[], javax.mail.FetchProfile)

      • getMessages

        public Message[] getMessages(int start,
                    int end)
                      throws MessagingException
        Get the Message objects for message numbers ranging from start through end, both start and end inclusive. Note that message numbers start at 1, not 0.

        Message objects are light-weight references to the actual message that get filled up on demand. Hence Folder implementations are expected to provide light-weight Message objects.

        This implementation uses getMessage(index) to obtain the required Message objects. Note that the returned array must contain (end-start+1) Message objects.

        Parameters:
        start - the number of the first message
        end - the number of the last message
        Returns:
        the Message objects
        Throws:
        FolderNotFoundException - if this folder does not exist.
        IllegalStateException - if this folder is not opened.
        IndexOutOfBoundsException - if the start or end message numbers are out of range.
        MessagingException
        See Also:
        fetch(javax.mail.Message[], javax.mail.FetchProfile)

      • getMessages

        public Message[] getMessages(int[] msgnums)
                      throws MessagingException
        Get the Message objects for message numbers specified in the array.

        Message objects are light-weight references to the actual message that get filled up on demand. Hence Folder implementations are expected to provide light-weight Message objects.

        This implementation uses getMessage(index) to obtain the required Message objects. Note that the returned array must contain msgnums.length Message objects

        Parameters:
        msgnums - the array of message numbers
        Returns:
        the array of Message objects.
        Throws:
        FolderNotFoundException - if this folder does not exist.
        IllegalStateException - if this folder is not opened.
        IndexOutOfBoundsException - if any message number in the given array is out of range.
        MessagingException
        See Also:
        fetch(javax.mail.Message[], javax.mail.FetchProfile)

      • getMessages

        public Message[] getMessages()
                      throws MessagingException
        Get all Message objects from this Folder. Returns an empty array if the folder is empty. Clients can use Message objects (instead of sequence numbers) as references to the messages within a folder; this method supplies the Message objects to the client. Folder implementations are expected to provide light-weight Message objects, which get filled on demand.

        This implementation invokes getMessageCount() to get the current message count and then uses getMessage() to get Message objects from 1 till the message count.

        Returns:
        array of Message objects, empty array if folder is empty.
        Throws:
        FolderNotFoundException - if this folder does not exist.
        IllegalStateException - if this folder is not opened.
        MessagingException
        See Also:
        fetch(javax.mail.Message[], javax.mail.FetchProfile)

      • appendMessages

        public abstract void appendMessages(Message[] msgs)
                             throws MessagingException
        Append given Messages to this folder. This method can be invoked on a closed Folder. An appropriate MessageCountEvent is delivered to any MessageCountListener registered on this folder when the messages arrive in the folder.

        Folder implementations must not abort this operation if a Message in the given message array turns out to be an expunged Message.

        Parameters:
        msgs - array of Messages to be appended
        Throws:
        FolderNotFoundException - if this folder does not exist.
        MessagingException - if the append failed.

      • fetch

        public void fetch(Message[] msgs,
         FetchProfile fp)
           throws MessagingException
        Prefetch the items specified in the FetchProfile for the given Messages.

        Clients use this method to indicate that the specified items are needed en-masse for the given message range. Implementations are expected to retrieve these items for the given message range in a efficient manner. Note that this method is just a hint to the implementation to prefetch the desired items.

        An example is a client filling its header-view window with the Subject, From and X-mailer headers for all messages in the folder.

  Message[] msgs = folder.getMessages();

  FetchProfile fp = new FetchProfile();
  fp.add(FetchProfile.Item.ENVELOPE);
  fp.add("X-mailer");
  folder.fetch(msgs, fp);

  for (int i = 0; i < folder.getMessageCount(); i++) {
      display(msg[i].getFrom());
      display(msg[i].getSubject());
      display(msg[i].getHeader("X-mailer"));
  }

        The implementation provided here just returns without doing anything useful. Providers wanting to provide a real implementation for this method should override this method.

        Parameters:
        msgs - fetch items for these messages
        fp - the FetchProfile
        Throws:
        IllegalStateException - if this folder is not opened
        MessagingException.
        MessagingException

      • setFlags

        public void setFlags(Message[] msgs,
            Flags flag,
            boolean value)
              throws MessagingException
        Set the specified flags on the messages specified in the array. This will result in appropriate MessageChangedEvents being delivered to any MessageChangedListener registered on this Message's containing folder.

        Note that the specified Message objects must belong to this folder. Certain Folder implementations can optimize the operation of setting Flags for a group of messages, so clients might want to use this method, rather than invoking Message.setFlags for each Message.

        This implementation degenerates to invoking setFlags() on each Message object. Specific Folder implementations that can optimize this case should do so. Also, an implementation must not abort the operation if a Message in the array turns out to be an expunged Message.

        Parameters:
        msgs - the array of message objects
        flag - Flags object containing the flags to be set
        value - set the flags to this boolean value
        Throws:
        IllegalStateException - if this folder is not opened or if it has been opened READ_ONLY.
        MessagingException
        See Also:
        Message.setFlags(javax.mail.Flags, boolean), MessageChangedEvent

      • setFlags

        public void setFlags(int start,
            int end,
            Flags flag,
            boolean value)
              throws MessagingException
        Set the specified flags on the messages numbered from start through end, both start and end inclusive. Note that message numbers start at 1, not 0. This will result in appropriate MessageChangedEvents being delivered to any MessageChangedListener registered on this Message's containing folder.

        Certain Folder implementations can optimize the operation of setting Flags for a group of messages, so clients might want to use this method, rather than invoking Message.setFlags for each Message.

        The default implementation uses getMessage(int) to get each Message object and then invokes setFlags on that object to set the flags. Specific Folder implementations that can optimize this case should do so. Also, an implementation must not abort the operation if a message number refers to an expunged message.

        Parameters:
        start - the number of the first message
        end - the number of the last message
        flag - Flags object containing the flags to be set
        value - set the flags to this boolean value
        Throws:
        IllegalStateException - if this folder is not opened or if it has been opened READ_ONLY.
        IndexOutOfBoundsException - if the start or end message numbers are out of range.
        MessagingException
        See Also:
        Message.setFlags(javax.mail.Flags, boolean), MessageChangedEvent

      • setFlags

        public void setFlags(int[] msgnums,
            Flags flag,
            boolean value)
              throws MessagingException
        Set the specified flags on the messages whose message numbers are in the array. This will result in appropriate MessageChangedEvents being delivered to any MessageChangedListener registered on this Message's containing folder.

        Certain Folder implementations can optimize the operation of setting Flags for a group of messages, so clients might want to use this method, rather than invoking Message.setFlags for each Message.

        The default implementation uses getMessage(int) to get each Message object and then invokes setFlags on that object to set the flags. Specific Folder implementations that can optimize this case should do so. Also, an implementation must not abort the operation if a message number refers to an expunged message.

        Parameters:
        msgnums - the array of message numbers
        flag - Flags object containing the flags to be set
        value - set the flags to this boolean value
        Throws:
        IllegalStateException - if this folder is not opened or if it has been opened READ_ONLY.
        IndexOutOfBoundsException - if any message number in the given array is out of range.
        MessagingException
        See Also:
        Message.setFlags(javax.mail.Flags, boolean), MessageChangedEvent

      • copyMessages

        public void copyMessages(Message[] msgs,
                Folder folder)
                  throws MessagingException
        Copy the specified Messages from this Folder into another Folder. This operation appends these Messages to the destination Folder. The destination Folder does not have to be opened. An appropriate MessageCountEvent is delivered to any MessageCountListener registered on the destination folder when the messages arrive in the folder.

        Note that the specified Message objects must belong to this folder. Folder implementations might be able to optimize this method by doing server-side copies.

        This implementation just invokes appendMessages() on the destination folder to append the given Messages. Specific folder implementations that support server-side copies should do so, if the destination folder's Store is the same as this folder's Store. Also, an implementation must not abort the operation if a Message in the array turns out to be an expunged Message.

        Parameters:
        msgs - the array of message objects
        folder - the folder to copy the messages to
        Throws:
        FolderNotFoundException - if the destination folder does not exist.
        IllegalStateException - if this folder is not opened.
        MessagingException
        See Also:
        appendMessages(javax.mail.Message[])

      • expunge

        public abstract Message[] expunge()
                           throws MessagingException
        Expunge (permanently remove) messages marked DELETED. Returns an array containing the expunged message objects. The getMessageNumber method on each of these message objects returns that Message's original (that is, prior to the expunge) sequence number. A MessageCountEvent containing the expunged messages is delivered to any MessageCountListeners registered on the folder.

        Expunge causes the renumbering of Message objects subsequent to the expunged messages. Clients that use message numbers as references to messages should be aware of this and should be prepared to deal with the situation (probably by flushing out existing message number caches and reloading them). Because of this complexity, it is better for clients to use Message objects as references to messages, rather than message numbers. Any expunged Messages objects still have to be pruned, but other Messages in that folder are not affected by the expunge.

        After a message is expunged, only the isExpunged and getMessageNumber methods are still valid on the corresponding Message object; other methods may throw MessageRemovedException

        Returns:
        array of expunged Message objects
        Throws:
        FolderNotFoundException - if this folder does not exist
        IllegalStateException - if this folder is not opened.
        MessagingException
        See Also:
        Message.isExpunged(), MessageCountEvent

      • search

        public Message[] search(SearchTerm term)
                 throws MessagingException
        Search this Folder for messages matching the specified search criterion. Returns an array containing the matching messages . Returns an empty array if no matches were found.

        This implementation invokes search(term, getMessages()), to apply the search over all the messages in this folder. Providers that can implement server-side searching might want to override this method to provide a more efficient implementation.

        Parameters:
        term - the search criterion
        Returns:
        array of matching messages
        Throws:
        SearchException - if the search term is too complex for the implementation to handle.
        FolderNotFoundException - if this folder does not exist.
        IllegalStateException - if this folder is not opened.
        MessagingException
        See Also:
        SearchTerm

      • search

        public Message[] search(SearchTerm term,
               Message[] msgs)
                 throws MessagingException
        Search the given array of messages for those that match the specified search criterion. Returns an array containing the matching messages. Returns an empty array if no matches were found.

        Note that the specified Message objects must belong to this folder.

        This implementation iterates through the given array of messages, and applies the search criterion on each message by calling its match() method with the given term. The messages that succeed in the match are returned. Providers that can implement server-side searching might want to override this method to provide a more efficient implementation. If the search term is too complex or contains user-defined terms that cannot be executed on the server, providers may elect to either throw a SearchException or degenerate to client-side searching by calling super.search() to invoke this implementation.

        Parameters:
        term - the search criterion
        msgs - the messages to be searched
        Returns:
        array of matching messages
        Throws:
        SearchException - if the search term is too complex for the implementation to handle.
        IllegalStateException - if this folder is not opened
        MessagingException
        See Also:
        SearchTerm

      • addConnectionListener

        public void addConnectionListener(ConnectionListener l)
        Add a listener for Connection events on this Folder.

        The implementation provided here adds this listener to an internal list of ConnectionListeners.

        Parameters:
        l - the Listener for Connection events
        See Also:
        ConnectionEvent

      • removeConnectionListener

        public void removeConnectionListener(ConnectionListener l)
        Remove a Connection event listener.

        The implementation provided here removes this listener from the internal list of ConnectionListeners.

        Parameters:
        l - the listener
        See Also:
        addConnectionListener(javax.mail.event.ConnectionListener)

      • notifyConnectionListeners

        protected void notifyConnectionListeners(int type)
        Notify all ConnectionListeners. Folder implementations are expected to use this method to broadcast connection events.

        The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered ConnectionListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

        Parameters:
        type - the ConnectionEvent type
        See Also:
        ConnectionEvent

      • addFolderListener

        public void addFolderListener(FolderListener l)
        Add a listener for Folder events on this Folder.

        The implementation provided here adds this listener to an internal list of FolderListeners.

        Parameters:
        l - the Listener for Folder events
        See Also:
        FolderEvent

      • removeFolderListener

        public void removeFolderListener(FolderListener l)
        Remove a Folder event listener.

        The implementation provided here removes this listener from the internal list of FolderListeners.

        Parameters:
        l - the listener
        See Also:
        addFolderListener(javax.mail.event.FolderListener)

      • notifyFolderListeners

        protected void notifyFolderListeners(int type)
        Notify all FolderListeners registered on this Folder and this folder's Store. Folder implementations are expected to use this method to broadcast Folder events.

        The implementation provided here queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the FolderListeners registered on this folder. The implementation also invokes notifyFolderListeners on this folder's Store to notify any FolderListeners registered on the store.

        Parameters:
        type - type of FolderEvent
        See Also:
        notifyFolderRenamedListeners(javax.mail.Folder)

      • notifyFolderRenamedListeners

        protected void notifyFolderRenamedListeners(Folder folder)
        Notify all FolderListeners registered on this Folder and this folder's Store about the renaming of this folder. Folder implementations are expected to use this method to broadcast Folder events indicating the renaming of folders.

        The implementation provided here queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the FolderListeners registered on this folder. The implementation also invokes notifyFolderRenamedListeners on this folder's Store to notify any FolderListeners registered on the store.

        Parameters:
        folder - Folder representing the new name.
        Since:
        JavaMail 1.1
        See Also:
        notifyFolderListeners(int)

      • addMessageCountListener

        public void addMessageCountListener(MessageCountListener l)
        Add a listener for MessageCount events on this Folder.

        The implementation provided here adds this listener to an internal list of MessageCountListeners.

        Parameters:
        l - the Listener for MessageCount events
        See Also:
        MessageCountEvent

      • removeMessageCountListener

        public void removeMessageCountListener(MessageCountListener l)
        Remove a MessageCount listener.

        The implementation provided here removes this listener from the internal list of MessageCountListeners.

        Parameters:
        l - the listener
        See Also:
        addMessageCountListener(javax.mail.event.MessageCountListener)

      • notifyMessageAddedListeners

        protected void notifyMessageAddedListeners(Message[] msgs)
        Notify all MessageCountListeners about the addition of messages into this folder. Folder implementations are expected to use this method to broadcast MessageCount events for indicating arrival of new messages.

        The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered MessageCountListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

      • notifyMessageRemovedListeners

        protected void notifyMessageRemovedListeners(boolean removed,
                                 Message[] msgs)
        Notify all MessageCountListeners about the removal of messages from this Folder. Folder implementations are expected to use this method to broadcast MessageCount events indicating removal of messages.

        The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered MessageCountListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

      • addMessageChangedListener

        public void addMessageChangedListener(MessageChangedListener l)
        Add a listener for MessageChanged events on this Folder.

        The implementation provided here adds this listener to an internal list of MessageChangedListeners.

        Parameters:
        l - the Listener for MessageChanged events
        See Also:
        MessageChangedEvent

      • removeMessageChangedListener

        public void removeMessageChangedListener(MessageChangedListener l)
        Remove a MessageChanged listener.

        The implementation provided here removes this listener from the internal list of MessageChangedListeners.

        Parameters:
        l - the listener
        See Also:
        addMessageChangedListener(javax.mail.event.MessageChangedListener)

      • notifyMessageChangedListeners

        protected void notifyMessageChangedListeners(int type,
                                 Message msg)
        Notify all MessageChangedListeners. Folder implementations are expected to use this method to broadcast MessageChanged events.

        The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to registered MessageChangedListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

      • finalize

        protected void finalize()
                 throws Throwable
        Overrides:
        finalize in class Object
        Throws:
        Throwable

      • toString

        public String toString()
        override the default toString(), it will return the String from Folder.getFullName() or if that is null, it will use the default toString() behavior.
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FolderClosedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class FolderClosedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.FolderClosedException
  • All Implemented Interfaces:
    Serializable

    public class FolderClosedException
extends MessagingException
    This exception is thrown when a method is invoked on a Messaging object and the Folder that owns that object has died due to some reason.

    Following the exception, the Folder is reset to the "closed" state. All messaging objects owned by the Folder should be considered invalid. The Folder can be reopened using the "open" method to reestablish the lost connection.

    The getMessage() method returns more detailed information about the error that caused this exception.

    Author:
    John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      FolderClosedException(Folder folder)
      Constructs a FolderClosedException.
      FolderClosedException(Folder folder, String message)
      Constructs a FolderClosedException with the specified detail message.
      FolderClosedException(Folder folder, String message, Exception e)
      Constructs a FolderClosedException with the specified detail message and embedded exception.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Folder getFolder()
      Returns the dead Folder object

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FolderClosedException

        public FolderClosedException(Folder folder)
        Constructs a FolderClosedException.
        Parameters:
        folder - The Folder

      • FolderClosedException

        public FolderClosedException(Folder folder,
                     String message)
        Constructs a FolderClosedException with the specified detail message.
        Parameters:
        folder - The Folder
        message - The detailed error message

      • FolderClosedException

        public FolderClosedException(Folder folder,
                     String message,
                     Exception e)
        Constructs a FolderClosedException with the specified detail message and embedded exception. The exception is chained to this exception.
        Parameters:
        folder - The Folder
        message - The detailed error message
        e - The embedded exception
        Since:
        JavaMail 1.5

    • Method Detail

      • getFolder

        public Folder getFolder()
        Returns the dead Folder object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FolderNotFoundException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class FolderNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.FolderNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class FolderNotFoundException
extends MessagingException
    This exception is thrown by Folder methods, when those methods are invoked on a non existent folder.
    Author:
    John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      FolderNotFoundException()
      Constructs a FolderNotFoundException with no detail message.
      FolderNotFoundException(Folder folder)
      Constructs a FolderNotFoundException.
      FolderNotFoundException(Folder folder, String s)
      Constructs a FolderNotFoundException with the specified detail message.
      FolderNotFoundException(Folder folder, String s, Exception e)
      Constructs a FolderNotFoundException with the specified detail message and embedded exception.
      FolderNotFoundException(String s, Folder folder)
      Constructs a FolderNotFoundException with the specified detail message and the specified folder.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Folder getFolder()
      Returns the offending Folder object.

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FolderNotFoundException

        public FolderNotFoundException()
        Constructs a FolderNotFoundException with no detail message.

      • FolderNotFoundException

        public FolderNotFoundException(Folder folder)
        Constructs a FolderNotFoundException.
        Parameters:
        folder - The Folder
        Since:
        JavaMail 1.2

      • FolderNotFoundException

        public FolderNotFoundException(Folder folder,
                       String s)
        Constructs a FolderNotFoundException with the specified detail message.
        Parameters:
        folder - The Folder
        s - The detailed error message
        Since:
        JavaMail 1.2

      • FolderNotFoundException

        public FolderNotFoundException(Folder folder,
                       String s,
                       Exception e)
        Constructs a FolderNotFoundException with the specified detail message and embedded exception. The exception is chained to this exception.
        Parameters:
        folder - The Folder
        s - The detailed error message
        e - The embedded exception
        Since:
        JavaMail 1.5

      • FolderNotFoundException

        public FolderNotFoundException(String s,
                       Folder folder)
        Constructs a FolderNotFoundException with the specified detail message and the specified folder.
        Parameters:
        s - The detail message
        folder - The Folder

    • Method Detail

      • getFolder

        public Folder getFolder()
        Returns the offending Folder object.
        Returns:
        the Folder object. Note that the returned value can be null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Header (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Header

  • java.lang.Object
    • javax.mail.Header
  • Direct Known Subclasses:
    InternetHeaders.InternetHeader

    public class Header
extends Object
    The Header class stores a name/value pair to represent headers.
    Author:
    John Mani

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected String name
      The name of the header.
      protected String value
      The value of the header.

    • Constructor Summary

      Constructors
      Constructor and Description
      Header(String name, String value)
      Construct a Header object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Returns the name of this header.
      String getValue()
      Returns the value of this header.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • name

        protected String name
        The name of the header.
        Since:
        JavaMail 1.4

      • value

        protected String value
        The value of the header.
        Since:
        JavaMail 1.4

    • Constructor Detail

      • Header

        public Header(String name,
      String value)
        Construct a Header object.
        Parameters:
        name - name of the header
        value - value of the header

    • Method Detail

      • getName

        public String getName()
        Returns the name of this header.
        Returns:
        name of the header

      • getValue

        public String getValue()
        Returns the value of this header.
        Returns:
        value of the header
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IllegalWriteException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class IllegalWriteException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.IllegalWriteException
  • All Implemented Interfaces:
    Serializable

    public class IllegalWriteException
extends MessagingException
    The exception thrown when a write is attempted on a read-only attribute of any Messaging object.
    Author:
    John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      IllegalWriteException()
      Constructs an IllegalWriteException with no detail message.
      IllegalWriteException(String s)
      Constructs an IllegalWriteException with the specified detail message.
      IllegalWriteException(String s, Exception e)
      Constructs an IllegalWriteException with the specified detail message and embedded exception.

    • Method Summary

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • IllegalWriteException

        public IllegalWriteException()
        Constructs an IllegalWriteException with no detail message.

      • IllegalWriteException

        public IllegalWriteException(String s)
        Constructs an IllegalWriteException with the specified detail message.
        Parameters:
        s - The detailed error message

      • IllegalWriteException

        public IllegalWriteException(String s,
                     Exception e)
        Constructs an IllegalWriteException with the specified detail message and embedded exception. The exception is chained to this exception.
        Parameters:
        s - The detailed error message
        e - The embedded exception
        Since:
        JavaMail 1.5
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.mail (Java(TM) EE 7 Specification APIs)

javax.mail

Interfaces

  • EncodingAware
  • MessageAware
  • MultipartDataSource
  • Part
  • QuotaAwareStore
  • UIDFolder

Classes

  • Address
  • Authenticator
  • BodyPart
  • FetchProfile
  • FetchProfile.Item
  • Flags
  • Flags.Flag
  • Folder
  • Header
  • Message
  • Message.RecipientType
  • MessageContext
  • Multipart
  • PasswordAuthentication
  • Provider
  • Provider.Type
  • Quota
  • Quota.Resource
  • Service
  • Session
  • Store
  • Transport
  • UIDFolder.FetchProfileItem
  • URLName

Exceptions

  • AuthenticationFailedException
  • FolderClosedException
  • FolderNotFoundException
  • IllegalWriteException
  • MessageRemovedException
  • MessagingException
  • MethodNotSupportedException
  • NoSuchProviderException
  • ReadOnlyFolderException
  • SendFailedException
  • StoreClosedException

Annotation Types

  • MailSessionDefinition
  • MailSessionDefinitions


javax.mail (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.mail

The JavaMailTM API provides classes that model a mail system.

See: Description

  • Interface Summary
    Interface Description
    EncodingAware
    A DataSource that also implements EncodingAware may specify the Content-Transfer-Encoding to use for its data.
    MessageAware
    An interface optionally implemented by DataSources to supply information to a DataContentHandler about the message context in which the data content object is operating.
    MultipartDataSource
    MultipartDataSource is a DataSource that contains body parts.
    Part
    The Part interface is the common base interface for Messages and BodyParts.
    QuotaAwareStore
    An interface implemented by Stores that support quotas.
    UIDFolder
    The UIDFolder interface is implemented by Folders that can support the "disconnected" mode of operation, by providing unique-ids for messages in the folder.
  • Class Summary
    Class Description
    Address
    This abstract class models the addresses in a message.
    Authenticator
    The class Authenticator represents an object that knows how to obtain authentication for a network connection.
    BodyPart
    This class models a Part that is contained within a Multipart.
    FetchProfile
    Clients use a FetchProfile to list the Message attributes that it wishes to prefetch from the server for a range of messages.
    FetchProfile.Item
    This inner class is the base class of all items that can be requested in a FetchProfile.
    Flags
    The Flags class represents the set of flags on a Message.
    Flags.Flag
    This inner class represents an individual system flag.
    Folder
    Folder is an abstract class that represents a folder for mail messages.
    Header
    The Header class stores a name/value pair to represent headers.
    Message
    This class models an email message.
    Message.RecipientType
    This inner class defines the types of recipients allowed by the Message class.
    MessageContext
    The context in which a piece of Message content is contained.
    Multipart
    Multipart is a container that holds multiple body parts.
    PasswordAuthentication
    The class PasswordAuthentication is a data holder that is used by Authenticator.
    Provider
    The Provider is a class that describes a protocol implementation.
    Provider.Type
    This inner class defines the Provider type.
    Quota
    This class represents a set of quotas for a given quota root.
    Quota.Resource
    An individual resource in a quota root.
    Service
    An abstract class that contains the functionality common to messaging services, such as stores and transports.
    Session
    The Session class represents a mail session and is not subclassed.
    Store
    An abstract class that models a message store and its access protocol, for storing and retrieving messages.
    Transport
    An abstract class that models a message transport.
    UIDFolder.FetchProfileItem
    A fetch profile item for fetching UIDs.
    URLName
    The name of a URL.
  • Exception Summary
    Exception Description
    AuthenticationFailedException
    This exception is thrown when the connect method on a Store or Transport object fails due to an authentication failure (e.g., bad user name or password).
    FolderClosedException
    This exception is thrown when a method is invoked on a Messaging object and the Folder that owns that object has died due to some reason.
    FolderNotFoundException
    This exception is thrown by Folder methods, when those methods are invoked on a non existent folder.
    IllegalWriteException
    The exception thrown when a write is attempted on a read-only attribute of any Messaging object.
    MessageRemovedException
    The exception thrown when an invalid method is invoked on an expunged Message.
    MessagingException
    The base class for all exceptions thrown by the Messaging classes
    MethodNotSupportedException
    The exception thrown when a method is not supported by the implementation
    NoSuchProviderException
    This exception is thrown when Session attempts to instantiate a Provider that doesn't exist.
    ReadOnlyFolderException
    This exception is thrown when an attempt is made to open a folder read-write access when the folder is marked read-only.
    SendFailedException
    This exception is thrown when the message cannot be sent.
    StoreClosedException
    This exception is thrown when a method is invoked on a Messaging object and the Store that owns that object has died due to some reason.
  • Annotation Types Summary
    Annotation Type Description
    MailSessionDefinition
    Annotation used by Java EE applications to define a MailSession to be registered with JNDI.
    MailSessionDefinitions
    Declares one or more MailSessionDefinition annotations.

Package javax.mail Description

The JavaMailTM API provides classes that model a mail system. The javax.mail package defines classes that are common to all mail systems. The javax.mail.internet package defines classes that are specific to mail systems based on internet standards such as MIME, SMTP, POP3, and IMAP. The JavaMail API includes the javax.mail package and subpackages.

For an overview of the JavaMail API, read the JavaMail specification included in the download bundle or available on the JavaMail web site.

The code to send a plain text message can be as simple as the following:

    Properties props = new Properties();
    props.put("mail.smtp.host", "my-mail-server");
    Session session = Session.getInstance(props, null);

    try {
        MimeMessage msg = new MimeMessage(session);
        msg.setFrom("me@example.com");
        msg.setRecipients(Message.RecipientType.TO,
                          "you@example.com");
        msg.setSubject("JavaMail hello world example");
        msg.setSentDate(new Date());
        msg.setText("Hello, world!\n");
        Transport.send(msg, "me@example.com", "my-password");
    } catch (MessagingException mex) {
        System.out.println("send failed, exception: " + mex);
    }
The JavaMail download bundle contains many more complete examples in the "demo" directory.

Don't forget to see the JavaMail API FAQ for answers to the most common questions. The JavaMail web site contains many additional resources.

The JavaMail API supports the following standard properties, which may be set in the Session object, or in the Properties object used to create the Session object. The properties are always set as strings; the Type column describes how the string is interpreted. For example, use

        props.put("mail.debug", "true");
to set the mail.debug property, which is of type boolean.

Name | Type | Description
mail.debug | boolean | The initial debug mode. Default is false.
mail.from | String | The return email address of the current user, used by the InternetAddress method getLocalAddress.
mail.mime.address.strict | boolean | The MimeMessage class uses the InternetAddress method parseHeader to parse headers in messages. This property controls the strict flag passed to the parseHeader method. The default is true.
mail.host | String | The default host name of the mail server for both Stores and Transports. Used if the mail.protocol.host property isn't set.
mail.store.protocol | String | Specifies the default message access protocol. The Session method getStore() returns a Store object that implements this protocol. By default the first Store provider in the configuration files is returned.
mail.transport.protocol | String | Specifies the default message transport protocol. The Session method getTransport() returns a Transport object that implements this protocol. By default the first Transport provider in the configuration files is returned.
mail.user | String | The default user name to use when connecting to the mail server. Used if the mail.protocol.user property isn't set.
mail.protocol.class | String | Specifies the fully qualified class name of the provider for the specified protocol. Used in cases where more than one provider for a given protocol exists; this property can be used to specify which provider to use by default. The provider must still be listed in a configuration file.
mail.protocol.host | String | The host name of the mail server for the specified protocol. Overrides the mail.host property.
mail.protocol.port | int | The port number of the mail server for the specified protocol. If not specified the protocol's default port number is used.
mail.protocol.user | String | The user name to use when connecting to mail servers using the specified protocol. Overrides the mail.user property.

The following properties are supported by Sun's implementation of JavaMail, but are not currently a required part of the specification. The names, types, defaults, and semantics of these properties may change in future releases.

Name | Type | Description
mail.debug.auth | boolean | Include protocol authentication commands (including usernames and passwords) in the debug output. Default is false.
mail.transport.protocol.address-type | String | Specifies the default message transport protocol for the specified address type. The Session method getTransport(Address) returns a Transport object that implements this protocol when the address is of the specified type (e.g., "rfc822" for standard internet addresses). By default the first Transport configured for that address type is used. This property can be used to override the behavior of the send method of the Transport class so that (for example) the "smtps" protocol is used instead of the "smtp" protocol by setting the property mail.transport.protocol.rfc822 to "smtps".

The JavaMail API also supports several System properties; see the javax.mail.internet package documentation for details.

The JavaMail reference implementation from Sun includes protocol providers in subpackages of com.sun.mail. Note that the APIs to these protocol providers are not part of the standard JavaMail API. Portable programs will not use these APIs.

Nonportable programs may use the APIs of the Sun protocol providers by (for example) casting a returned Folder object to a com.sun.mail.imap.IMAPFolder object. Similarly for Store and Message objects returned from the standard JavaMail APIs.

The Sun protocol providers also support properties that are specific to those providers. The package documentation for the IMAP, POP3, and SMTP packages provide details.

In addition to printing debugging output as controlled by the Session configuration, the current implementation of classes in this package log the same information using Logger as described in the following table:

Logger Name | Logging Level | Purpose
javax.mail | CONFIG | Configuration of the Session
javax.mail | FINE | General debugging output
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.mail Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.mail

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.mail.Address (implements java.io.Serializable)
    • javax.mail.Authenticator
    • javax.mail.BodyPart (implements javax.mail.Part)
    • javax.mail.FetchProfile
    • javax.mail.FetchProfile.Item
      • javax.mail.UIDFolder.FetchProfileItem
    • javax.mail.Flags (implements java.lang.Cloneable, java.io.Serializable)
    • javax.mail.Flags.Flag
    • javax.mail.Folder
    • javax.mail.Header
    • javax.mail.Message (implements javax.mail.Part)
    • javax.mail.Message.RecipientType (implements java.io.Serializable)
    • javax.mail.MessageContext
    • javax.mail.Multipart
    • javax.mail.PasswordAuthentication
    • javax.mail.Provider
    • javax.mail.Provider.Type
    • javax.mail.Quota
    • javax.mail.Quota.Resource
    • javax.mail.Service
      • javax.mail.Store
      • javax.mail.Transport
    • javax.mail.Session
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.AuthenticationFailedException
          • javax.mail.FolderClosedException
          • javax.mail.FolderNotFoundException
          • javax.mail.IllegalWriteException
          • javax.mail.MessageRemovedException
          • javax.mail.MethodNotSupportedException
          • javax.mail.NoSuchProviderException
          • javax.mail.ReadOnlyFolderException
          • javax.mail.SendFailedException
          • javax.mail.StoreClosedException
    • javax.mail.URLName

Interface Hierarchy

  • javax.activation.DataSource
    • javax.mail.MultipartDataSource
  • javax.mail.EncodingAware
  • javax.mail.MessageAware
  • javax.mail.Part
  • javax.mail.QuotaAwareStore
  • javax.mail.UIDFolder

Annotation Type Hierarchy

  • javax.mail.MailSessionDefinitions (implements java.lang.annotation.Annotation)
  • javax.mail.MailSessionDefinition (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MailSessionDefinition (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.mail

Annotation Type MailSessionDefinition

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface MailSessionDefinition
    Annotation used by Java EE applications to define a MailSession to be registered with JNDI. The MailSession may be configured by setting the annotation elements for commonly used Session properties. Additional standard and vendor-specific properties may be specified using the properties element.

    The session will be registered under the name specified in the name element. It may be defined to be in any valid Java EE namespace, and will determine the accessibility of the session from other components.

    Since:
    JavaMail 1.5

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      JNDI name by which the mail session will be registered.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String description
      Description of this mail session.
      String from
      From address for the user.
      String host
      Host name for the mail server.
      String password
      Password to use for authentication.
      String[] properties
      Properties to include in the Session.
      String storeProtocol
      Store protocol name.
      String transportProtocol
      Transport protocol name.
      String user
      User name to use for authentication.

    • Element Detail

      • name

        public abstract String name
        JNDI name by which the mail session will be registered.

      • description

        public abstract String description
        Description of this mail session.
        Default:
        ""

      • storeProtocol

        public abstract String storeProtocol
        Store protocol name.
        Default:
        ""

      • transportProtocol

        public abstract String transportProtocol
        Transport protocol name.
        Default:
        ""

      • host

        public abstract String host
        Host name for the mail server.
        Default:
        ""

      • user

        public abstract String user
        User name to use for authentication.
        Default:
        ""

      • password

        public abstract String password
        Password to use for authentication.
        Default:
        ""

      • from

        public abstract String from
        From address for the user.
        Default:
        ""

      • properties

        public abstract String[] properties
        Properties to include in the Session. Properties are specified using the format: propertyName=propertyValue with one property per array element.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MailSessionDefinitions (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.mail

Annotation Type MailSessionDefinitions

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface MailSessionDefinitions
    Declares one or more MailSessionDefinition annotations.
    Since:
    JavaMail 1.5
    See Also:
    MailSessionDefinition

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      MailSessionDefinition[] value

    • Element Detail

      • value

        public abstract MailSessionDefinition[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Message (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Message

  • java.lang.Object
    • javax.mail.Message
  • All Implemented Interfaces:
    Part
    Direct Known Subclasses:
    MimeMessage

    public abstract class Message
extends Object
implements Part
    This class models an email message. This is an abstract class. Subclasses provide actual implementations.

    Message implements the Part interface. Message contains a set of attributes and a "content". Messages within a folder also have a set of flags that describe its state within the folder.

    Message defines some new attributes in addition to those defined in the Part interface. These attributes specify meta-data for the message - i.e., addressing and descriptive information about the message.

    Message objects are obtained either from a Folder or by constructing a new Message object of the appropriate subclass. Messages that have been received are normally retrieved from a folder named "INBOX".

    A Message object obtained from a folder is just a lightweight reference to the actual message. The Message is 'lazily' filled up (on demand) when each item is requested from the message. Note that certain folder implementations may return Message objects that are pre-filled with certain user-specified items. To send a message, an appropriate subclass of Message (e.g., MimeMessage) is instantiated, the attributes and content are filled in, and the message is sent using the Transport.send method.

    Author:
    John Mani, Bill Shannon, Max Spivak
    See Also:
    Part

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  Message.RecipientType
      This inner class defines the types of recipients allowed by the Message class.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean expunged
      True if this message has been expunged.
      protected Folder folder
      The containing folder, if this message is obtained from a folder
      protected int msgnum
      The number of this message within its folder, or zero if the message was not retrieved from a folder.
      protected Session session
      The Session object for this Message

      • Fields inherited from interface javax.mail.Part

        ATTACHMENT, INLINE

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Message()
      No-arg version of the constructor.
      protected Message(Folder folder, int msgnum)
      Constructor that takes a Folder and a message number.
      protected Message(Session session)
      Constructor that takes a Session.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addFrom(Address[] addresses)
      Add these addresses to the existing "From" attribute
      void addRecipient(Message.RecipientType type, Address address)
      Add this recipient address to the existing ones of the given type.
      abstract void addRecipients(Message.RecipientType type, Address[] addresses)
      Add these recipient addresses to the existing ones of the given type.
      Address[] getAllRecipients()
      Get all the recipient addresses for the message.
      abstract Flags getFlags()
      Returns a Flags object containing the flags for this message.
      Folder getFolder()
      Get the folder from which this message was obtained.
      abstract Address[] getFrom()
      Returns the "From" attribute.
      int getMessageNumber()
      Get the Message number for this Message.
      abstract Date getReceivedDate()
      Get the date this message was received.
      abstract Address[] getRecipients(Message.RecipientType type)
      Get all the recipient addresses of the given type.
      Address[] getReplyTo()
      Get the addresses to which replies should be directed.
      abstract Date getSentDate()
      Get the date this message was sent.
      Session getSession()
      Return the Session used when this message was created.
      abstract String getSubject()
      Get the subject of this message.
      boolean isExpunged()
      Checks whether this message is expunged.
      boolean isSet(Flags.Flag flag)
      Check whether the flag specified in the flag argument is set in this message.
      boolean match(SearchTerm term)
      Apply the specified Search criterion to this message.
      abstract Message reply(boolean replyToAll)
      Get a new Message suitable for a reply to this message.
      abstract void saveChanges()
      Save any changes made to this message into the message-store when the containing folder is closed, if the message is contained in a folder.
      protected void setExpunged(boolean expunged)
      Sets the expunged flag for this Message.
      void setFlag(Flags.Flag flag, boolean set)
      Set the specified flag on this message to the specified value.
      abstract void setFlags(Flags flag, boolean set)
      Set the specified flags on this message to the specified value.
      abstract void setFrom()
      Set the "From" attribute in this Message.
      abstract void setFrom(Address address)
      Set the "From" attribute in this Message.
      protected void setMessageNumber(int msgnum)
      Set the Message number for this Message.
      void setRecipient(Message.RecipientType type, Address address)
      Set the recipient address.
      abstract void setRecipients(Message.RecipientType type, Address[] addresses)
      Set the recipient addresses.
      void setReplyTo(Address[] addresses)
      Set the addresses to which replies should be directed.
      abstract void setSentDate(Date date)
      Set the sent date of this message.
      abstract void setSubject(String subject)
      Set the subject of this message.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.mail.Part

        addHeader, getAllHeaders, getContent, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getInputStream, getLineCount, getMatchingHeaders, getNonMatchingHeaders, getSize, isMimeType, removeHeader, setContent, setContent, setDataHandler, setDescription, setDisposition, setFileName, setHeader, setText, writeTo

    • Field Detail

      • msgnum

        protected int msgnum
        The number of this message within its folder, or zero if the message was not retrieved from a folder.

      • expunged

        protected boolean expunged
        True if this message has been expunged.

      • folder

        protected Folder folder
        The containing folder, if this message is obtained from a folder

      • session

        protected Session session
        The Session object for this Message

    • Constructor Detail

      • Message

        protected Message()
        No-arg version of the constructor.

      • Message

        protected Message(Folder folder,
       int msgnum)
        Constructor that takes a Folder and a message number. Used by Folder implementations.
        Parameters:
        folder - containing folder
        msgnum - this message's sequence number within this folder

      • Message

        protected Message(Session session)
        Constructor that takes a Session. Used for client created Message objects.
        Parameters:
        session - A Session object

    • Method Detail

      • getSession

        public Session getSession()
        Return the Session used when this message was created.
        Returns:
        the message's Session
        Since:
        JavaMail 1.5

      • getFrom

        public abstract Address[] getFrom()
                           throws MessagingException
        Returns the "From" attribute. The "From" attribute contains the identity of the person(s) who wished this message to be sent.

        In certain implementations, this may be different from the entity that actually sent the message.

        This method returns null if this attribute is not present in this message. Returns an empty array if this attribute is present, but contains no addresses.

        Returns:
        array of Address objects
        Throws:
        MessagingException

      • setFrom

        public abstract void setFrom()
                      throws MessagingException
        Set the "From" attribute in this Message. The value of this attribute is obtained from the property "mail.user". If this property is absent, the system property "user.name" is used.
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.

      • setFrom

        public abstract void setFrom(Address address)
                      throws MessagingException
        Set the "From" attribute in this Message.
        Parameters:
        address - the sender
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.

      • addFrom

        public abstract void addFrom(Address[] addresses)
                      throws MessagingException
        Add these addresses to the existing "From" attribute
        Parameters:
        addresses - the senders
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • getRecipients

        public abstract Address[] getRecipients(Message.RecipientType type)
                                 throws MessagingException
        Get all the recipient addresses of the given type.

        This method returns null if no recipients of the given type are present in this message. It may return an empty array if the header is present, but contains no addresses.

        Parameters:
        type - the recipient type
        Returns:
        array of Address objects
        Throws:
        MessagingException
        See Also:
        Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC

      • getAllRecipients

        public Address[] getAllRecipients()
                           throws MessagingException
        Get all the recipient addresses for the message. The default implementation extracts the TO, CC, and BCC recipients using the getRecipients method.

        This method returns null if none of the recipient headers are present in this message. It may Return an empty array if any recipient header is present, but contains no addresses.

        Returns:
        array of Address objects
        Throws:
        MessagingException
        See Also:
        Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC, getRecipients(javax.mail.Message.RecipientType)

      • setRecipients

        public abstract void setRecipients(Message.RecipientType type,
                 Address[] addresses)
                            throws MessagingException
        Set the recipient addresses. All addresses of the specified type are replaced by the addresses parameter.
        Parameters:
        type - the recipient type
        addresses - the addresses
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.

      • setRecipient

        public void setRecipient(Message.RecipientType type,
                Address address)
                  throws MessagingException
        Set the recipient address. All addresses of the specified type are replaced by the address parameter.

        The default implementation uses the setRecipients method.

        Parameters:
        type - the recipient type
        address - the address
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • addRecipients

        public abstract void addRecipients(Message.RecipientType type,
                 Address[] addresses)
                            throws MessagingException
        Add these recipient addresses to the existing ones of the given type.
        Parameters:
        type - the recipient type
        addresses - the addresses
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.

      • addRecipient

        public void addRecipient(Message.RecipientType type,
                Address address)
                  throws MessagingException
        Add this recipient address to the existing ones of the given type.

        The default implementation uses the addRecipients method.

        Parameters:
        type - the recipient type
        address - the address
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • getReplyTo

        public Address[] getReplyTo()
                     throws MessagingException
        Get the addresses to which replies should be directed. This will usually be the sender of the message, but some messages may direct replies to a different address.

        The default implementation simply calls the getFrom method.

        This method returns null if the corresponding header is not present. Returns an empty array if the header is present, but contains no addresses.

        Returns:
        addresses to which replies should be directed
        Throws:
        MessagingException
        See Also:
        getFrom()

      • setReplyTo

        public void setReplyTo(Address[] addresses)
                throws MessagingException
        Set the addresses to which replies should be directed. (Normally only a single address will be specified.) Not all message types allow this to be specified separately from the sender of the message.

        The default implementation provided here just throws the MethodNotSupportedException.

        Parameters:
        addresses - addresses to which replies should be directed
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MethodNotSupportedException - if the underlying implementation does not support setting this attribute

      • getSubject

        public abstract String getSubject()
                           throws MessagingException
        Get the subject of this message.
        Returns:
        the subject
        Throws:
        MessagingException

      • setSubject

        public abstract void setSubject(String subject)
                         throws MessagingException
        Set the subject of this message.
        Parameters:
        subject - the subject
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.

      • getSentDate

        public abstract Date getSentDate()
                          throws MessagingException
        Get the date this message was sent.
        Returns:
        the date this message was sent
        Throws:
        MessagingException

      • setSentDate

        public abstract void setSentDate(Date date)
                          throws MessagingException
        Set the sent date of this message.
        Parameters:
        date - the sent date of this message
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.

      • getReceivedDate

        public abstract Date getReceivedDate()
                              throws MessagingException
        Get the date this message was received.
        Returns:
        the date this message was received
        Throws:
        MessagingException

      • getFlags

        public abstract Flags getFlags()
                        throws MessagingException
        Returns a Flags object containing the flags for this message.

        Modifying any of the flags in this returned Flags object will not affect the flags of this message. Use setFlags() to do that.

        Returns:
        Flags object containing the flags for this message
        Throws:
        MessagingException
        See Also:
        Flags, setFlags(javax.mail.Flags, boolean)

      • isSet

        public boolean isSet(Flags.Flag flag)
              throws MessagingException
        Check whether the flag specified in the flag argument is set in this message.

        The default implementation uses getFlags.

        Parameters:
        flag - the flag
        Returns:
        value of the specified flag for this message
        Throws:
        MessagingException
        See Also:
        Flags.Flag, Flags.Flag.ANSWERED, Flags.Flag.DELETED, Flags.Flag.DRAFT, Flags.Flag.FLAGGED, Flags.Flag.RECENT, Flags.Flag.SEEN

      • setFlags

        public abstract void setFlags(Flags flag,
            boolean set)
                       throws MessagingException
        Set the specified flags on this message to the specified value. Note that any flags in this message that are not specified in the given Flags object are unaffected.

        This will result in a MessageChangedEvent being delivered to any MessageChangedListener registered on this Message's containing folder.

        Parameters:
        flag - Flags object containing the flags to be set
        set - the value to be set
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values.
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        See Also:
        MessageChangedEvent

      • setFlag

        public void setFlag(Flags.Flag flag,
           boolean set)
             throws MessagingException
        Set the specified flag on this message to the specified value. This will result in a MessageChangedEvent being delivered to any MessageChangedListener registered on this Message's containing folder.

        The default implementation uses the setFlags method.

        Parameters:
        flag - Flags.Flag object containing the flag to be set
        set - the value to be set
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values.
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        See Also:
        MessageChangedEvent

      • getMessageNumber

        public int getMessageNumber()
        Get the Message number for this Message. A Message object's message number is the relative position of this Message in its Folder. Note that the message number for a particular Message can change during a session if other messages in the Folder are deleted and expunged.

        Valid message numbers start at 1. Messages that do not belong to any folder (like newly composed or derived messages) have 0 as their message number.

        Returns:
        the message number

      • setMessageNumber

        protected void setMessageNumber(int msgnum)
        Set the Message number for this Message. This method is invoked only by the implementation classes.

      • getFolder

        public Folder getFolder()
        Get the folder from which this message was obtained. If this is a new message or nested message, this method returns null.
        Returns:
        the containing folder

      • isExpunged

        public boolean isExpunged()
        Checks whether this message is expunged. All other methods except getMessageNumber() are invalid on an expunged Message object.

        Messages that are expunged due to an explict expunge() request on the containing Folder are removed from the Folder immediately. Messages that are externally expunged by another source are marked "expunged" and return true for the isExpunged() method, but they are not removed from the Folder until an explicit expunge() is done on the Folder.

        See the description of expunge() for more details on expunge handling.

        See Also:
        Folder.expunge()

      • setExpunged

        protected void setExpunged(boolean expunged)
        Sets the expunged flag for this Message. This method is to be used only by the implementation classes.
        Parameters:
        expunged - the expunged flag

      • reply

        public abstract Message reply(boolean replyToAll)
                       throws MessagingException
        Get a new Message suitable for a reply to this message. The new Message will have its attributes and headers set up appropriately. Note that this new message object will be empty, that is, it will not have a "content". These will have to be suitably filled in by the client.

        If replyToAll is set, the new Message will be addressed to all recipients of this message. Otherwise, the reply will be addressed to only the sender of this message (using the value of the getReplyTo method).

        The "Subject" field is filled in with the original subject prefixed with "Re:" (unless it already starts with "Re:").

        The reply message will use the same session as this message.

        Parameters:
        replyToAll - reply should be sent to all recipients of this message
        Returns:
        the reply Message
        Throws:
        MessagingException

      • saveChanges

        public abstract void saveChanges()
                          throws MessagingException
        Save any changes made to this message into the message-store when the containing folder is closed, if the message is contained in a folder. (Some implementations may save the changes immediately.) Update any header fields to be consistent with the changed message contents. If any part of a message's headers or contents are changed, saveChanges must be called to ensure that those changes are permanent. If saveChanges is not called, any such modifications may or may not be saved, depending on the message store and folder implementation.

        Messages obtained from folders opened READ_ONLY should not be modified and saveChanges should not be called on such messages.

        Throws:
        MessagingException
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        IllegalWriteException - if the underlying implementation does not support modification of existing values.

      • match

        public boolean match(SearchTerm term)
              throws MessagingException
        Apply the specified Search criterion to this message.
        Parameters:
        term - the Search criterion
        Returns:
        true if the Message matches this search criterion, false otherwise.
        Throws:
        MessagingException
        See Also:
        SearchTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Message.RecipientType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Message.RecipientType

  • java.lang.Object
    • javax.mail.Message.RecipientType
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    MimeMessage.RecipientType
    Enclosing class:
    Message

    public static class Message.RecipientType
extends Object
implements Serializable
    This inner class defines the types of recipients allowed by the Message class. The currently defined types are TO, CC and BCC. Note that this class only has a protected constructor, thereby restricting new Recipient types to either this class or subclasses. This effectively implements an enumeration of the allowed Recipient types. The following code sample shows how to use this class to obtain the "TO" recipients from a message.

 Message msg = folder.getMessages(1);
 Address[] a = m.getRecipients(Message.RecipientType.TO);

    See Also:
    Message.getRecipients(javax.mail.Message.RecipientType),
Message.setRecipients(javax.mail.Message.RecipientType, javax.mail.Address[]),
Message.addRecipients(javax.mail.Message.RecipientType, javax.mail.Address[]),
Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static Message.RecipientType BCC
      The "Bcc" (blind carbon copy) recipients.
      static Message.RecipientType CC
      The "Cc" (carbon copy) recipients.
      static Message.RecipientType TO
      The "To" (primary) recipients.
      protected String type
      The type of recipient, usually the name of a corresponding Internet standard header.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Message.RecipientType(String type)
      Constructor for use by subclasses.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected Object readResolve()
      When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class.
      String toString()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • TO

        public static final Message.RecipientType TO
        The "To" (primary) recipients.

      • CC

        public static final Message.RecipientType CC
        The "Cc" (carbon copy) recipients.

      • BCC

        public static final Message.RecipientType BCC
        The "Bcc" (blind carbon copy) recipients.

      • type

        protected String type
        The type of recipient, usually the name of a corresponding Internet standard header.

    • Constructor Detail

      • Message.RecipientType

        protected Message.RecipientType(String type)
        Constructor for use by subclasses.

    • Method Detail

      • readResolve

        protected Object readResolve()
                      throws ObjectStreamException
        When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class. Subclasses must implement their own readResolve method that checks for their known instances before calling this super method.
        Throws:
        ObjectStreamException

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageAware (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Interface MessageAware

  • All Known Implementing Classes:
    MimePartDataSource

    public interface MessageAware
    An interface optionally implemented by DataSources to supply information to a DataContentHandler about the message context in which the data content object is operating.
    Since:
    JavaMail 1.1
    See Also:
    MessageContext, DataSource, DataContentHandler

    • Method Summary

      Methods
      Modifier and Type Method and Description
      MessageContext getMessageContext()
      Return the message context.

    • Method Detail

      • getMessageContext

        MessageContext getMessageContext()
        Return the message context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class MessageContext

  • java.lang.Object
    • javax.mail.MessageContext

  • public class MessageContext
extends Object
    The context in which a piece of Message content is contained. A MessageContext object is returned by the getMessageContext method of the MessageAware interface. MessageAware is typically implemented by DataSources to allow a DataContentHandler to pass on information about the context in which a data content object is operating.
    Since:
    JavaMail 1.1
    See Also:
    MessageAware, DataSource, DataContentHandler

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageContext(Part part)
      Create a MessageContext object describing the context of the given Part.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Message getMessage()
      Return the Message that contains the content.
      Part getPart()
      Return the Part that contains the content.
      Session getSession()
      Return the Session we're operating in.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MessageContext

        public MessageContext(Part part)
        Create a MessageContext object describing the context of the given Part.

    • Method Detail

      • getPart

        public Part getPart()
        Return the Part that contains the content.
        Returns:
        the containing Part, or null if not known

      • getMessage

        public Message getMessage()
        Return the Message that contains the content. Follows the parent chain up through containing Multipart objects until it comes to a Message object, or null.
        Returns:
        the containing Message, or null if not known

      • getSession

        public Session getSession()
        Return the Session we're operating in.
        Returns:
        the Session, or null if not known
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageRemovedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class MessageRemovedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.MessageRemovedException
  • All Implemented Interfaces:
    Serializable

    public class MessageRemovedException
extends MessagingException
    The exception thrown when an invalid method is invoked on an expunged Message. The only valid methods on an expunged Message are isExpunged() and getMessageNumber().
    Author:
    John Mani
    See Also:
    Message.isExpunged(), Message.getMessageNumber(), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageRemovedException()
      Constructs a MessageRemovedException with no detail message.
      MessageRemovedException(String s)
      Constructs a MessageRemovedException with the specified detail message.
      MessageRemovedException(String s, Exception e)
      Constructs a MessageRemovedException with the specified detail message and embedded exception.

    • Method Summary

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MessageRemovedException

        public MessageRemovedException()
        Constructs a MessageRemovedException with no detail message.

      • MessageRemovedException

        public MessageRemovedException(String s)
        Constructs a MessageRemovedException with the specified detail message.
        Parameters:
        s - The detailed error message

      • MessageRemovedException

        public MessageRemovedException(String s,
                       Exception e)
        Constructs a MessageRemovedException with the specified detail message and embedded exception. The exception is chained to this exception.
        Parameters:
        s - The detailed error message
        e - The embedded exception
        Since:
        JavaMail 1.5
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessagingException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class MessagingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    AuthenticationFailedException, FolderClosedException, FolderNotFoundException, IllegalWriteException, MessageRemovedException, MethodNotSupportedException, NoSuchProviderException, ParseException, ReadOnlyFolderException, SearchException, SendFailedException, StoreClosedException

    public class MessagingException
extends Exception
    The base class for all exceptions thrown by the Messaging classes
    Author:
    John Mani, Bill Shannon
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MessagingException()
      Constructs a MessagingException with no detail message.
      MessagingException(String s)
      Constructs a MessagingException with the specified detail message.
      MessagingException(String s, Exception e)
      Constructs a MessagingException with the specified Exception and detail message.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Overrides the getCause method of Throwable to return the next exception in the chain of nested exceptions.
      Exception getNextException()
      Get the next exception chained to this one.
      boolean setNextException(Exception ex)
      Add an exception to the end of the chain.
      String toString()
      Override toString method to provide information on nested exceptions.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MessagingException

        public MessagingException()
        Constructs a MessagingException with no detail message.

      • MessagingException

        public MessagingException(String s)
        Constructs a MessagingException with the specified detail message.
        Parameters:
        s - the detail message

      • MessagingException

        public MessagingException(String s,
                  Exception e)
        Constructs a MessagingException with the specified Exception and detail message. The specified exception is chained to this exception.
        Parameters:
        s - the detail message
        e - the embedded exception
        See Also:
        getNextException(),
setNextException(java.lang.Exception),
getCause()

    • Method Detail

      • getNextException

        public Exception getNextException()
        Get the next exception chained to this one. If the next exception is a MessagingException, the chain may extend further.
        Returns:
        next Exception, null if none.

      • getCause

        public Throwable getCause()
        Overrides the getCause method of Throwable to return the next exception in the chain of nested exceptions.
        Overrides:
        getCause in class Throwable
        Returns:
        next Exception, null if none.

      • setNextException

        public boolean setNextException(Exception ex)
        Add an exception to the end of the chain. If the end is not a MessagingException, this exception cannot be added to the end.
        Parameters:
        ex - the new end of the Exception chain
        Returns:
        true if this Exception was added, false otherwise.

      • toString

        public String toString()
        Override toString method to provide information on nested exceptions.
        Overrides:
        toString in class Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MethodNotSupportedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class MethodNotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.MethodNotSupportedException
  • All Implemented Interfaces:
    Serializable

    public class MethodNotSupportedException
extends MessagingException
    The exception thrown when a method is not supported by the implementation
    Author:
    John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MethodNotSupportedException()
      Constructs a MethodNotSupportedException with no detail message.
      MethodNotSupportedException(String s)
      Constructs a MethodNotSupportedException with the specified detail message.
      MethodNotSupportedException(String s, Exception e)
      Constructs a MethodNotSupportedException with the specified detail message and embedded exception.

    • Method Summary

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MethodNotSupportedException

        public MethodNotSupportedException()
        Constructs a MethodNotSupportedException with no detail message.

      • MethodNotSupportedException

        public MethodNotSupportedException(String s)
        Constructs a MethodNotSupportedException with the specified detail message.
        Parameters:
        s - The detailed error message

      • MethodNotSupportedException

        public MethodNotSupportedException(String s,
                           Exception e)
        Constructs a MethodNotSupportedException with the specified detail message and embedded exception. The exception is chained to this exception.
        Parameters:
        s - The detailed error message
        e - The embedded exception
        Since:
        JavaMail 1.5
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Multipart (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Multipart

  • java.lang.Object
    • javax.mail.Multipart
  • Direct Known Subclasses:
    MimeMultipart

    public abstract class Multipart
extends Object
    Multipart is a container that holds multiple body parts. Multipart provides methods to retrieve and set its subparts.

    Multipart also acts as the base class for the content object returned by most Multipart DataContentHandlers. For example, invoking getContent() on a DataHandler whose source is a "multipart/signed" data source may return an appropriate subclass of Multipart.

    Some messaging systems provide different subtypes of Multiparts. For example, MIME specifies a set of subtypes that include "alternative", "mixed", "related", "parallel", "signed", etc.

    Multipart is an abstract class. Subclasses provide actual implementations.

    Author:
    John Mani

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected String contentType
      This field specifies the content-type of this multipart object.
      protected Part parent
      The Part containing this Multipart, if known.
      protected Vector parts
      Vector of BodyPart objects.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Multipart()
      Default constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addBodyPart(BodyPart part)
      Adds a Part to the multipart.
      void addBodyPart(BodyPart part, int index)
      Adds a BodyPart at position index.
      BodyPart getBodyPart(int index)
      Get the specified Part.
      String getContentType()
      Return the content-type of this Multipart.
      int getCount()
      Return the number of enclosed BodyPart objects.
      Part getParent()
      Return the Part that contains this Multipart object, or null if not known.
      boolean removeBodyPart(BodyPart part)
      Remove the specified part from the multipart message.
      void removeBodyPart(int index)
      Remove the part at specified location (starting from 0).
      protected void setMultipartDataSource(MultipartDataSource mp)
      Setup this Multipart object from the given MultipartDataSource.
      void setParent(Part parent)
      Set the parent of this Multipart to be the specified Part.
      abstract void writeTo(OutputStream os)
      Output an appropriately encoded bytestream to the given OutputStream.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • parts

        protected Vector parts
        Vector of BodyPart objects.

      • contentType

        protected String contentType
        This field specifies the content-type of this multipart object. It defaults to "multipart/mixed".

      • parent

        protected Part parent
        The Part containing this Multipart, if known.
        Since:
        JavaMail 1.1

    • Constructor Detail

      • Multipart

        protected Multipart()
        Default constructor. An empty Multipart object is created.

    • Method Detail

      • setMultipartDataSource

        protected void setMultipartDataSource(MultipartDataSource mp)
                               throws MessagingException
        Setup this Multipart object from the given MultipartDataSource.

        The method adds the MultipartDataSource's BodyPart objects into this Multipart. This Multipart's contentType is set to that of the MultipartDataSource.

        This method is typically used in those cases where one has a multipart data source that has already been pre-parsed into the individual body parts (for example, an IMAP datasource), but needs to create an appropriate Multipart subclass that represents a specific multipart subtype.

        Parameters:
        mp - Multipart datasource
        Throws:
        MessagingException

      • getContentType

        public String getContentType()
        Return the content-type of this Multipart.

        This implementation just returns the value of the contentType field.

        Returns:
        content-type
        See Also:
        contentType

      • getCount

        public int getCount()
             throws MessagingException
        Return the number of enclosed BodyPart objects.

        Returns:
        number of parts
        Throws:
        MessagingException
        See Also:
        parts

      • getBodyPart

        public BodyPart getBodyPart(int index)
                     throws MessagingException
        Get the specified Part. Parts are numbered starting at 0.
        Parameters:
        index - the index of the desired Part
        Returns:
        the Part
        Throws:
        IndexOutOfBoundsException - if the given index is out of range.
        MessagingException

      • removeBodyPart

        public boolean removeBodyPart(BodyPart part)
                       throws MessagingException
        Remove the specified part from the multipart message. Shifts all the parts after the removed part down one.
        Parameters:
        part - The part to remove
        Returns:
        true if part removed, false otherwise
        Throws:
        MessagingException - if no such Part exists
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • removeBodyPart

        public void removeBodyPart(int index)
                    throws MessagingException
        Remove the part at specified location (starting from 0). Shifts all the parts after the removed part down one.
        Parameters:
        index - Index of the part to remove
        Throws:
        MessagingException
        IndexOutOfBoundsException - if the given index is out of range.
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • addBodyPart

        public void addBodyPart(BodyPart part)
                 throws MessagingException
        Adds a Part to the multipart. The BodyPart is appended to the list of existing Parts.
        Parameters:
        part - The Part to be appended
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • addBodyPart

        public void addBodyPart(BodyPart part,
               int index)
                 throws MessagingException
        Adds a BodyPart at position index. If index is not the last one in the list, the subsequent parts are shifted up. If index is larger than the number of parts present, the BodyPart is appended to the end.
        Parameters:
        part - The BodyPart to be inserted
        index - Location where to insert the part
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • writeTo

        public abstract void writeTo(OutputStream os)
                      throws IOException,
                             MessagingException
        Output an appropriately encoded bytestream to the given OutputStream. The implementation subclass decides the appropriate encoding algorithm to be used. The bytestream is typically used for sending.
        Throws:
        IOException - if an IO related exception occurs
        MessagingException

      • getParent

        public Part getParent()
        Return the Part that contains this Multipart object, or null if not known.
        Since:
        JavaMail 1.1

      • setParent

        public void setParent(Part parent)
        Set the parent of this Multipart to be the specified Part. Normally called by the Message or BodyPart setContent(Multipart) method. parent may be null if the Multipart is being removed from its containing Part.
        Since:
        JavaMail 1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MultipartDataSource (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Interface MultipartDataSource

  • All Superinterfaces:
    DataSource

    public interface MultipartDataSource
extends DataSource
    MultipartDataSource is a DataSource that contains body parts. This allows "mail aware" DataContentHandlers to be implemented more efficiently by being aware of such DataSources and using the appropriate methods to access BodyParts.

    Note that the data of a MultipartDataSource is also available as an input stream.

    This interface will typically be implemented by providers that preparse multipart bodies, for example an IMAP provider.

    Author:
    John Mani
    See Also:
    DataSource

    • Method Summary

      Methods
      Modifier and Type Method and Description
      BodyPart getBodyPart(int index)
      Get the specified Part.
      int getCount()
      Return the number of enclosed BodyPart objects.

      • Methods inherited from interface javax.activation.DataSource

        getContentType, getInputStream, getName, getOutputStream

    • Method Detail

      • getCount

        int getCount()
        Return the number of enclosed BodyPart objects.
        Returns:
        number of parts

      • getBodyPart

        BodyPart getBodyPart(int index)
                     throws MessagingException
        Get the specified Part. Parts are numbered starting at 0.
        Parameters:
        index - the index of the desired Part
        Returns:
        the Part
        Throws:
        IndexOutOfBoundsException - if the given index is out of range.
        MessagingException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoSuchProviderException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class NoSuchProviderException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.NoSuchProviderException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchProviderException
extends MessagingException
    This exception is thrown when Session attempts to instantiate a Provider that doesn't exist.
    Author:
    Max Spivak
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoSuchProviderException()
      Constructs a NoSuchProviderException with no detail message.
      NoSuchProviderException(String message)
      Constructs a NoSuchProviderException with the specified detail message.
      NoSuchProviderException(String message, Exception e)
      Constructs a NoSuchProviderException with the specified detail message and embedded exception.

    • Method Summary

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoSuchProviderException

        public NoSuchProviderException()
        Constructs a NoSuchProviderException with no detail message.

      • NoSuchProviderException

        public NoSuchProviderException(String message)
        Constructs a NoSuchProviderException with the specified detail message.
        Parameters:
        message - The detailed error message

      • NoSuchProviderException

        public NoSuchProviderException(String message,
                       Exception e)
        Constructs a NoSuchProviderException with the specified detail message and embedded exception. The exception is chained to this exception.
        Parameters:
        message - The detailed error message
        e - The embedded exception
        Since:
        JavaMail 1.5
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Part (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Interface Part

  • All Known Subinterfaces:
    MimePart
    All Known Implementing Classes:
    BodyPart, Message, MimeBodyPart, MimeMessage, PreencodedMimeBodyPart

    public interface Part
    The Part interface is the common base interface for Messages and BodyParts.

    Part consists of a set of attributes and a "Content".

    Attributes:

    The JavaMail API defines a set of standard Part attributes that are considered to be common to most existing Mail systems. These attributes have their own settor and gettor methods. Mail systems may support other Part attributes as well, these are represented as name-value pairs where both the name and value are Strings.

    Content:

    The data type of the "content" is returned by the getContentType() method. The MIME typing system is used to name data types.

    The "content" of a Part is available in various formats:

    • As a DataHandler - using the getDataHandler() method. The "content" of a Part is also available through a javax.activation.DataHandler object. The DataHandler object allows clients to discover the operations available on the content, and to instantiate the appropriate component to perform those operations.
    • As an input stream - using the getInputStream() method. Any mail-specific encodings are decoded before this stream is returned.
    • As a Java object - using the getContent() method. This method returns the "content" as a Java object. The returned object is of course dependent on the content itself. In particular, a "multipart" Part's content is always a Multipart or subclass thereof. That is, getContent() on a "multipart" type Part will always return a Multipart (or subclass) object.
    Part provides the writeTo() method that streams out its bytestream in mail-safe form suitable for transmission. This bytestream is typically an aggregation of the Part attributes and its content's bytestream.

    Message and BodyPart implement the Part interface. Note that in MIME parlance, Part models an Entity (RFC 2045, Section 2.4).

    Author:
    John Mani

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ATTACHMENT
      This part should be presented as an attachment.
      static String INLINE
      This part should be presented inline.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addHeader(String header_name, String header_value)
      Add this value to the existing values for this header_name.
      Enumeration getAllHeaders()
      Return all the headers from this part as an Enumeration of Header objects.
      Object getContent()
      Return the content as a Java object.
      String getContentType()
      Returns the Content-Type of the content of this part.
      DataHandler getDataHandler()
      Return a DataHandler for the content within this part.
      String getDescription()
      Return a description String for this part.
      String getDisposition()
      Return the disposition of this part.
      String getFileName()
      Get the filename associated with this part, if possible.
      String[] getHeader(String header_name)
      Get all the headers for this header name.
      InputStream getInputStream()
      Return an input stream for this part's "content".
      int getLineCount()
      Return the number of lines in the content of this part.
      Enumeration getMatchingHeaders(String[] header_names)
      Return matching headers from this part as an Enumeration of Header objects.
      Enumeration getNonMatchingHeaders(String[] header_names)
      Return non-matching headers from this envelope as an Enumeration of Header objects.
      int getSize()
      Return the size of the content of this part in bytes.
      boolean isMimeType(String mimeType)
      Is this Part of the specified MIME type? This method compares only the primaryType and subType.
      void removeHeader(String header_name)
      Remove all headers with this name.
      void setContent(Multipart mp)
      This method sets the given Multipart object as this message's content.
      void setContent(Object obj, String type)
      A convenience method for setting this part's content.
      void setDataHandler(DataHandler dh)
      This method provides the mechanism to set this part's content.
      void setDescription(String description)
      Set a description String for this part.
      void setDisposition(String disposition)
      Set the disposition of this part.
      void setFileName(String filename)
      Set the filename associated with this part, if possible.
      void setHeader(String header_name, String header_value)
      Set the value for this header_name.
      void setText(String text)
      A convenience method that sets the given String as this part's content with a MIME type of "text/plain".
      void writeTo(OutputStream os)
      Output a bytestream for this Part.

    • Field Detail

      • ATTACHMENT

        static final String ATTACHMENT
        This part should be presented as an attachment.
        See Also:
        getDisposition(), setDisposition(java.lang.String), Constant Field Values

      • INLINE

        static final String INLINE
        This part should be presented inline.
        See Also:
        getDisposition(), setDisposition(java.lang.String), Constant Field Values

    • Method Detail

      • getSize

        int getSize()
            throws MessagingException
        Return the size of the content of this part in bytes. Return -1 if the size cannot be determined.

        Note that the size may not be an exact measure of the content size and may or may not account for any transfer encoding of the content. The size is appropriate for display in a user interface to give the user a rough idea of the size of this part.

        Returns:
        size of content in bytes
        Throws:
        MessagingException

      • getLineCount

        int getLineCount()
                 throws MessagingException
        Return the number of lines in the content of this part. Return -1 if the number cannot be determined. Note that this number may not be an exact measure of the content length and may or may not account for any transfer encoding of the content.
        Returns:
        number of lines in the content.
        Throws:
        MessagingException

      • getContentType

        String getContentType()
                      throws MessagingException
        Returns the Content-Type of the content of this part. Returns null if the Content-Type could not be determined.

        The MIME typing system is used to name Content-types.

        Returns:
        The ContentType of this part
        Throws:
        MessagingException
        See Also:
        DataHandler

      • isMimeType

        boolean isMimeType(String mimeType)
                   throws MessagingException
        Is this Part of the specified MIME type? This method compares only the primaryType and subType. The parameters of the content types are ignored.

        For example, this method will return true when comparing a Part of content type "text/plain" with "text/plain; charset=foobar".

        If the subType of mimeType is the special character '*', then the subtype is ignored during the comparison.

        Throws:
        MessagingException

      • getDisposition

        String getDisposition()
                      throws MessagingException
        Return the disposition of this part. The disposition describes how the part should be presented to the user. (See RFC 2183.) The return value should be considered without regard to case. For example:

         String disp = part.getDisposition();
 if (disp == null || disp.equalsIgnoreCase(Part.ATTACHMENT))
        // treat as attachment if not first part
        Returns:
        disposition of this part, or null if unknown
        Throws:
        MessagingException
        See Also:
        ATTACHMENT, INLINE, getFileName()

      • setDisposition

        void setDisposition(String disposition)
                    throws MessagingException
        Set the disposition of this part.
        Parameters:
        disposition - disposition of this part
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of this header
        IllegalStateException - if this Part is obtained from a READ_ONLY folder
        See Also:
        ATTACHMENT, INLINE, setFileName(java.lang.String)

      • getDescription

        String getDescription()
                      throws MessagingException
        Return a description String for this part. This typically associates some descriptive information with this part. Returns null if none is available.
        Returns:
        description of this part
        Throws:
        MessagingException

      • setDescription

        void setDescription(String description)
                    throws MessagingException
        Set a description String for this part. This typically associates some descriptive information with this part.
        Parameters:
        description - description of this part
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of this header
        IllegalStateException - if this Part is obtained from a READ_ONLY folder

      • getFileName

        String getFileName()
                   throws MessagingException
        Get the filename associated with this part, if possible. Useful if this part represents an "attachment" that was loaded from a file. The filename will usually be a simple name, not including directory components.
        Returns:
        Filename to associate with this part
        Throws:
        MessagingException

      • setFileName

        void setFileName(String filename)
                 throws MessagingException
        Set the filename associated with this part, if possible. Useful if this part represents an "attachment" that was loaded from a file. The filename will usually be a simple name, not including directory components.
        Parameters:
        filename - Filename to associate with this part
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of this header
        IllegalStateException - if this Part is obtained from a READ_ONLY folder
        MessagingException

      • getInputStream

        InputStream getInputStream()
                           throws IOException,
                                  MessagingException
        Return an input stream for this part's "content". Any mail-specific transfer encodings will be decoded before the input stream is provided.

        This is typically a convenience method that just invokes the DataHandler's getInputStream() method.

        Returns:
        an InputStream
        Throws:
        IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
        MessagingException
        See Also:
        getDataHandler(), DataHandler.getInputStream()

      • getDataHandler

        DataHandler getDataHandler()
                           throws MessagingException
        Return a DataHandler for the content within this part. The DataHandler allows clients to operate on as well as retrieve the content.
        Returns:
        DataHandler for the content
        Throws:
        MessagingException

      • getContent

        Object getContent()
                  throws IOException,
                         MessagingException
        Return the content as a Java object. The type of the returned object is of course dependent on the content itself. For example, the object returned for "text/plain" content is usually a String object. The object returned for a "multipart" content is always a Multipart subclass. For content-types that are unknown to the DataHandler system, an input stream is returned as the content

        This is a convenience method that just invokes the DataHandler's getContent() method

        Returns:
        Object
        Throws:
        MessagingException
        IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
        See Also:
        DataHandler.getContent()

      • setDataHandler

        void setDataHandler(DataHandler dh)
                    throws MessagingException
        This method provides the mechanism to set this part's content. The DataHandler wraps around the actual content.
        Parameters:
        dh - The DataHandler for the content.
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this Part is obtained from a READ_ONLY folder

      • setContent

        void setContent(Object obj,
              String type)
                throws MessagingException
        A convenience method for setting this part's content. The part internally wraps the content in a DataHandler.

        Note that a DataContentHandler class for the specified type should be available to the JavaMail implementation for this to work right. i.e., to do setContent(foobar, "application/x-foobar"), a DataContentHandler for "application/x-foobar" should be installed. Refer to the Java Activation Framework for more information.

        Parameters:
        obj - A java object.
        type - MIME type of this object.
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this Part is obtained from a READ_ONLY folder
        MessagingException

      • setText

        void setText(String text)
             throws MessagingException
        A convenience method that sets the given String as this part's content with a MIME type of "text/plain".
        Parameters:
        text - The text that is the Message's content.
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this Part is obtained from a READ_ONLY folder
        MessagingException

      • setContent

        void setContent(Multipart mp)
                throws MessagingException
        This method sets the given Multipart object as this message's content.
        Parameters:
        mp - The multipart object that is the Message's content
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this Part is obtained from a READ_ONLY folder
        MessagingException

      • writeTo

        void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
        Output a bytestream for this Part. This bytestream is typically an aggregration of the Part attributes and an appropriately encoded bytestream from its 'content'.

        Classes that implement the Part interface decide on the appropriate encoding algorithm to be used.

        The bytestream is typically used for sending.

        Throws:
        IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
        MessagingException - if an error occurs fetching the data to be written
        See Also:
        DataHandler.writeTo(java.io.OutputStream)

      • getHeader

        String[] getHeader(String header_name)
                   throws MessagingException
        Get all the headers for this header name. Returns null if no headers for this header name are available.
        Parameters:
        header_name - the name of this header
        Returns:
        the value fields for all headers with this name
        Throws:
        MessagingException

      • setHeader

        void setHeader(String header_name,
             String header_value)
               throws MessagingException
        Set the value for this header_name. Replaces all existing header values with this new value.
        Parameters:
        header_name - the name of this header
        header_value - the value for this header
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this Part is obtained from a READ_ONLY folder

      • addHeader

        void addHeader(String header_name,
             String header_value)
               throws MessagingException
        Add this value to the existing values for this header_name.
        Parameters:
        header_name - the name of this header
        header_value - the value for this header
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this Part is obtained from a READ_ONLY folder

      • removeHeader

        void removeHeader(String header_name)
                  throws MessagingException
        Remove all headers with this name.
        Parameters:
        header_name - the name of this header
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this Part is obtained from a READ_ONLY folder

      • getAllHeaders

        Enumeration getAllHeaders()
                          throws MessagingException
        Return all the headers from this part as an Enumeration of Header objects.
        Returns:
        enumeration of Header objects
        Throws:
        MessagingException

      • getMatchingHeaders

        Enumeration getMatchingHeaders(String[] header_names)
                               throws MessagingException
        Return matching headers from this part as an Enumeration of Header objects.
        Returns:
        enumeration of Header objects
        Throws:
        MessagingException

      • getNonMatchingHeaders

        Enumeration getNonMatchingHeaders(String[] header_names)
                                  throws MessagingException
        Return non-matching headers from this envelope as an Enumeration of Header objects.
        Returns:
        enumeration of Header objects
        Throws:
        MessagingException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PasswordAuthentication (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class PasswordAuthentication

  • java.lang.Object
    • javax.mail.PasswordAuthentication

  • public final class PasswordAuthentication
extends Object
    The class PasswordAuthentication is a data holder that is used by Authenticator. It is simply a repository for a user name and a password.
    Author:
    Bill Foote
    See Also:
    PasswordAuthentication, Authenticator, Authenticator.getPasswordAuthentication()

    • Constructor Summary

      Constructors
      Constructor and Description
      PasswordAuthentication(String userName, String password)
      Initialize a new PasswordAuthentication

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getPassword()
      String getUserName()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PasswordAuthentication

        public PasswordAuthentication(String userName,
                      String password)
        Initialize a new PasswordAuthentication
        Parameters:
        userName - the user name
        password - The user's password

    • Method Detail

      • getUserName

        public String getUserName()
        Returns:
        the user name

      • getPassword

        public String getPassword()
        Returns:
        the password
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Provider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Provider

  • java.lang.Object
    • javax.mail.Provider

  • public class Provider
extends Object
    The Provider is a class that describes a protocol implementation. The values typically come from the javamail.providers and javamail.default.providers resource files. An application may also create and register a Provider object to dynamically add support for a new provider.
    Author:
    Max Spivak, Bill Shannon

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  Provider.Type
      This inner class defines the Provider type.

    • Constructor Summary

      Constructors
      Constructor and Description
      Provider(Provider.Type type, String protocol, String classname, String vendor, String version)
      Create a new provider of the specified type for the specified protocol.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getClassName()
      Returns name of the class that implements the protocol
      String getProtocol()
      Returns the protocol supported by this Provider
      Provider.Type getType()
      Returns the type of this Provider
      String getVendor()
      Returns name of vendor associated with this implementation or null
      String getVersion()
      Returns version of this implementation or null if no version
      String toString()
      Overrides Object.toString()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Provider

        public Provider(Provider.Type type,
        String protocol,
        String classname,
        String vendor,
        String version)
        Create a new provider of the specified type for the specified protocol. The specified class implements the provider.
        Parameters:
        type - Type.STORE or Type.TRANSPORT
        protocol - valid protocol for the type
        classname - class name that implements this protocol
        vendor - optional string identifying the vendor (may be null)
        version - optional implementation version string (may be null)
        Since:
        JavaMail 1.4

    • Method Detail

      • getType

        public Provider.Type getType()
        Returns the type of this Provider

      • getProtocol

        public String getProtocol()
        Returns the protocol supported by this Provider

      • getClassName

        public String getClassName()
        Returns name of the class that implements the protocol

      • getVendor

        public String getVendor()
        Returns name of vendor associated with this implementation or null

      • getVersion

        public String getVersion()
        Returns version of this implementation or null if no version

      • toString

        public String toString()
        Overrides Object.toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Provider.Type (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Provider.Type

  • java.lang.Object
    • javax.mail.Provider.Type
  • Enclosing class:
    Provider

    public static class Provider.Type
extends Object
    This inner class defines the Provider type. Currently, STORE and TRANSPORT are the only two provider types supported.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Provider.Type | STORE
      static Provider.Type | TRANSPORT

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • STORE

        public static final Provider.Type STORE

      • TRANSPORT

        public static final Provider.Type TRANSPORT

    • Method Detail

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Quota (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Quota

  • java.lang.Object
    • javax.mail.Quota

  • public class Quota
extends Object
    This class represents a set of quotas for a given quota root. Each quota root has a set of resources, represented by the Quota.Resource class. Each resource has a name (for example, "STORAGE"), a current usage, and a usage limit. See RFC 2087.
    Since:
    JavaMail 1.4
    Author:
    Bill Shannon

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  Quota.Resource
      An individual resource in a quota root.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String quotaRoot
      The name of the quota root.
      Quota.Resource[] resources
      The set of resources associated with this quota root.

    • Constructor Summary

      Constructors
      Constructor and Description
      Quota(String quotaRoot)
      Create a Quota object for the named quotaroot with no associated resources.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void setResourceLimit(String name, long limit)
      Set a resource limit for this quota root.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • quotaRoot

        public String quotaRoot
        The name of the quota root.

      • resources

        public Quota.Resource[] resources
        The set of resources associated with this quota root.

    • Constructor Detail

      • Quota

        public Quota(String quotaRoot)
        Create a Quota object for the named quotaroot with no associated resources.
        Parameters:
        quotaRoot - the name of the quota root

    • Method Detail

      • setResourceLimit

        public void setResourceLimit(String name,
                    long limit)
        Set a resource limit for this quota root.
        Parameters:
        name - the name of the resource
        limit - the resource limit
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Quota.Resource (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Quota.Resource

  • java.lang.Object
    • javax.mail.Quota.Resource
  • Enclosing class:
    Quota

    public static class Quota.Resource
extends Object
    An individual resource in a quota root.
    Since:
    JavaMail 1.4

    • Field Summary

      Fields
      Modifier and Type Field and Description
      long limit
      The usage limit for the resource.
      String name
      The name of the resource.
      long usage
      The current usage of the resource.

    • Constructor Summary

      Constructors
      Constructor and Description
      Quota.Resource(String name, long usage, long limit)
      Construct a Resource object with the given name, usage, and limit.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • name

        public String name
        The name of the resource.

      • usage

        public long usage
        The current usage of the resource.

      • limit

        public long limit
        The usage limit for the resource.

    • Constructor Detail

      • Quota.Resource

        public Quota.Resource(String name,
              long usage,
              long limit)
        Construct a Resource object with the given name, usage, and limit.
        Parameters:
        name - the resource name
        usage - the current usage of the resource
        limit - the usage limit for the resource
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QuotaAwareStore (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Interface QuotaAwareStore

  • public interface QuotaAwareStore
    An interface implemented by Stores that support quotas. The getQuota and setQuota methods support the quota model defined by the IMAP QUOTA extension. Refer to RFC 2087 for more information.

    Since:
    JavaMail 1.4

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Quota[] getQuota(String folder)
      Get the quotas for the named folder.
      void setQuota(Quota quota)
      Set the quotas for the quota root specified in the quota argument.

    • Method Detail

      • getQuota

        Quota[] getQuota(String folder)
                 throws MessagingException
        Get the quotas for the named folder. Quotas are controlled on the basis of a quota root, not (necessarily) a folder. The relationship between folders and quota roots depends on the server. Some servers might implement a single quota root for all folders owned by a user. Other servers might implement a separate quota root for each folder. A single folder can even have multiple quota roots, perhaps controlling quotas for different resources.
        Parameters:
        folder - the name of the folder
        Returns:
        array of Quota objects
        Throws:
        MessagingException - if the server doesn't support the QUOTA extension

      • setQuota

        void setQuota(Quota quota)
              throws MessagingException
        Set the quotas for the quota root specified in the quota argument. Typically this will be one of the quota roots obtained from the getQuota method, but it need not be.
        Parameters:
        quota - the quota to set
        Throws:
        MessagingException - if the server doesn't support the QUOTA extension
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ReadOnlyFolderException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class ReadOnlyFolderException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.ReadOnlyFolderException
  • All Implemented Interfaces:
    Serializable

    public class ReadOnlyFolderException
extends MessagingException
    This exception is thrown when an attempt is made to open a folder read-write access when the folder is marked read-only.

    The getMessage() method returns more detailed information about the error that caused this exception.

    Author:
    Jim Glennon
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ReadOnlyFolderException(Folder folder)
      Constructs a ReadOnlyFolderException with the specified folder and no detail message.
      ReadOnlyFolderException(Folder folder, String message)
      Constructs a ReadOnlyFolderException with the specified detail message.
      ReadOnlyFolderException(Folder folder, String message, Exception e)
      Constructs a ReadOnlyFolderException with the specified detail message and embedded exception.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Folder getFolder()
      Returns the dead Folder object.

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ReadOnlyFolderException

        public ReadOnlyFolderException(Folder folder)
        Constructs a ReadOnlyFolderException with the specified folder and no detail message.
        Parameters:
        folder - the Folder
        Since:
        JavaMail 1.2

      • ReadOnlyFolderException

        public ReadOnlyFolderException(Folder folder,
                       String message)
        Constructs a ReadOnlyFolderException with the specified detail message.
        Parameters:
        folder - The Folder
        message - The detailed error message
        Since:
        JavaMail 1.2

      • ReadOnlyFolderException

        public ReadOnlyFolderException(Folder folder,
                       String message,
                       Exception e)
        Constructs a ReadOnlyFolderException with the specified detail message and embedded exception. The exception is chained to this exception.
        Parameters:
        folder - The Folder
        message - The detailed error message
        e - The embedded exception
        Since:
        JavaMail 1.5

    • Method Detail

      • getFolder

        public Folder getFolder()
        Returns the dead Folder object.
        Since:
        JavaMail 1.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SendFailedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class SendFailedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.SendFailedException
  • All Implemented Interfaces:
    Serializable

    public class SendFailedException
extends MessagingException
    This exception is thrown when the message cannot be sent.

    The exception includes those addresses to which the message could not be sent as well as the valid addresses to which the message was sent and valid addresses to which the message was not sent.

    Author:
    John Mani, Max Spivak
    See Also:
    Transport.send(javax.mail.Message), Transport.sendMessage(javax.mail.Message, javax.mail.Address[]), TransportEvent, Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected Address[] | invalid
      protected Address[] | validSent
      protected Address[] | validUnsent

    • Constructor Summary

      Constructors
      Constructor and Description
      SendFailedException()
      Constructs a SendFailedException with no detail message.
      SendFailedException(String s)
      Constructs a SendFailedException with the specified detail message.
      SendFailedException(String s, Exception e)
      Constructs a SendFailedException with the specified Exception and detail message.
      SendFailedException(String msg, Exception ex, Address[] validSent, Address[] validUnsent, Address[] invalid)
      Constructs a SendFailedException with the specified string and the specified address objects.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Address[] getInvalidAddresses()
      Return the addresses to which this message could not be sent.
      Address[] getValidSentAddresses()
      Return the addresses to which this message was sent succesfully.
      Address[] getValidUnsentAddresses()
      Return the addresses that are valid but to which this message was not sent.

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • invalid

        protected transient Address[] invalid

      • validSent

        protected transient Address[] validSent

      • validUnsent

        protected transient Address[] validUnsent

    • Constructor Detail

      • SendFailedException

        public SendFailedException()
        Constructs a SendFailedException with no detail message.

      • SendFailedException

        public SendFailedException(String s)
        Constructs a SendFailedException with the specified detail message.
        Parameters:
        s - the detail message

      • SendFailedException

        public SendFailedException(String s,
                   Exception e)
        Constructs a SendFailedException with the specified Exception and detail message. The specified exception is chained to this exception.
        Parameters:
        s - the detail message
        e - the embedded exception
        See Also:
        MessagingException.getNextException(), MessagingException.setNextException(java.lang.Exception)

      • SendFailedException

        public SendFailedException(String msg,
                   Exception ex,
                   Address[] validSent,
                   Address[] validUnsent,
                   Address[] invalid)
        Constructs a SendFailedException with the specified string and the specified address objects.
        Parameters:
        msg - the detail message
        ex - the embedded exception
        validSent - valid addresses to which message was sent
        validUnsent - valid addresses to which message was not sent
        invalid - the invalid addresses
        See Also:
        MessagingException.getNextException(), MessagingException.setNextException(java.lang.Exception)

    • Method Detail

      • getValidSentAddresses

        public Address[] getValidSentAddresses()
        Return the addresses to which this message was sent succesfully.
        Returns:
        Addresses to which the message was sent successfully or null

      • getValidUnsentAddresses

        public Address[] getValidUnsentAddresses()
        Return the addresses that are valid but to which this message was not sent.
        Returns:
        Addresses that are valid but to which the message was not sent successfully or null

      • getInvalidAddresses

        public Address[] getInvalidAddresses()
        Return the addresses to which this message could not be sent.
        Returns:
        Addresses to which the message sending failed or null;
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Service (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Service

  • java.lang.Object
    • javax.mail.Service
  • Direct Known Subclasses:
    Store, Transport

    public abstract class Service
extends Object
    An abstract class that contains the functionality common to messaging services, such as stores and transports.

    A messaging service is created from a Session and is named using a URLName. A service must be connected before it can be used. Connection events are sent to reflect its connection status.

    Author:
    Christopher Cotton, Bill Shannon, Kanwar Oberoi

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean debug
      Debug flag for this service.
      protected Session session
      The session from which this service was created.
      protected URLName url
      The URLName of this service.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Service(Session session, URLName urlname)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addConnectionListener(ConnectionListener l)
      Add a listener for Connection events on this service.
      void close()
      Close this service and terminate its connection.
      void connect()
      A generic connect method that takes no parameters.
      void connect(String host, int port, String user, String password)
      Similar to connect(host, user, password) except a specific port can be specified.
      void connect(String user, String password)
      Connect to the current host using the specified username and password.
      void connect(String host, String user, String password)
      Connect to the specified address.
      protected void finalize()
      Stop the event dispatcher thread so the queue can be garbage collected.
      URLName getURLName()
      Return a URLName representing this service.
      boolean isConnected()
      Is this service currently connected?
      protected void notifyConnectionListeners(int type)
      Notify all ConnectionListeners.
      protected boolean protocolConnect(String host, int port, String user, String password)
      The service implementation should override this method to perform the actual protocol-specific connection attempt.
      protected void queueEvent(MailEvent event, Vector vector)
      Add the event and vector of listeners to the queue to be delivered.
      void removeConnectionListener(ConnectionListener l)
      Remove a Connection event listener.
      protected void setConnected(boolean connected)
      Set the connection state of this service.
      protected void setURLName(URLName url)
      Set the URLName representing this service.
      String toString()
      Return getURLName.toString() if this service has a URLName, otherwise it will return the default toString.

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • session

        protected Session session
        The session from which this service was created.

      • url

        protected URLName url
        The URLName of this service.

      • debug

        protected boolean debug
        Debug flag for this service. Set from the session's debug flag when this service is created.

    • Constructor Detail

      • Service

        protected Service(Session session,
       URLName urlname)
        Constructor.
        Parameters:
        session - Session object for this service
        urlname - URLName object to be used for this service

    • Method Detail

      • connect

        public void connect()
             throws MessagingException
        A generic connect method that takes no parameters. Subclasses can implement the appropriate authentication schemes. Subclasses that need additional information might want to use some properties or might get it interactively using a popup window.

        If the connection is successful, an "open" ConnectionEvent is delivered to any ConnectionListeners on this service.

        Most clients should just call this method to connect to the service.

        It is an error to connect to an already connected service.

        The implementation provided here simply calls the following connect(String, String, String) method with nulls.

        Throws:
        AuthenticationFailedException - for authentication failures
        MessagingException - for other failures
        IllegalStateException - if the service is already connected
        See Also:
        ConnectionEvent

      • connect

        public void connect(String host,
           String user,
           String password)
             throws MessagingException
        Connect to the specified address. This method provides a simple authentication scheme that requires a username and password.

        If the connection is successful, an "open" ConnectionEvent is delivered to any ConnectionListeners on this service.

        It is an error to connect to an already connected service.

        The implementation in the Service class will collect defaults for the host, user, and password from the session, from the URLName for this service, and from the supplied parameters and then call the protocolConnect method. If the protocolConnect method returns false, the user will be prompted for any missing information and the protocolConnect method will be called again. The subclass should override the protocolConnect method. The subclass should also implement the getURLName method, or use the implementation in this class.

        On a successful connection, the setURLName method is called with a URLName that includes the information used to make the connection, including the password.

        If the username passed in is null, a default value will be chosen as described above. If the password passed in is null and this is the first successful connection to this service, the user name and the password collected from the user will be saved as defaults for subsequent connection attempts to this same service when using other Service object instances (the connection information is typically always saved within a particular Service object instance). The password is saved using the Session method setPasswordAuthentication. If the password passed in is not null, it is not saved, on the assumption that the application is managing passwords explicitly.

        Parameters:
        host - the host to connect to
        user - the user name
        password - this user's password
        Throws:
        AuthenticationFailedException - for authentication failures
        MessagingException - for other failures
        IllegalStateException - if the service is already connected
        See Also:
        ConnectionEvent, Session.setPasswordAuthentication(javax.mail.URLName, javax.mail.PasswordAuthentication)

      • connect

        public void connect(String user,
           String password)
             throws MessagingException
        Connect to the current host using the specified username and password. This method is equivalent to calling the connect(host, user, password) method with null for the host name.
        Parameters:
        user - the user name
        password - this user's password
        Throws:
        AuthenticationFailedException - for authentication failures
        MessagingException - for other failures
        IllegalStateException - if the service is already connected
        Since:
        JavaMail 1.4
        See Also:
        ConnectionEvent, Session.setPasswordAuthentication(javax.mail.URLName, javax.mail.PasswordAuthentication), connect(java.lang.String, java.lang.String, java.lang.String)

      • connect

        public void connect(String host,
           int port,
           String user,
           String password)
             throws MessagingException
        Similar to connect(host, user, password) except a specific port can be specified.
        Parameters:
        host - the host to connect to
        port - the port to connect to (-1 means the default port)
        user - the user name
        password - this user's password
        Throws:
        AuthenticationFailedException - for authentication failures
        MessagingException - for other failures
        IllegalStateException - if the service is already connected
        See Also:
        connect(java.lang.String, java.lang.String, java.lang.String), ConnectionEvent

      • protocolConnect

        protected boolean protocolConnect(String host,
                      int port,
                      String user,
                      String password)
                           throws MessagingException
        The service implementation should override this method to perform the actual protocol-specific connection attempt. The default implementation of the connect method calls this method as needed.

        The protocolConnect method should return false if a user name or password is required for authentication but the corresponding parameter is null; the connect method will prompt the user when needed to supply missing information. This method may also return false if authentication fails for the supplied user name or password. Alternatively, this method may throw an AuthenticationFailedException when authentication fails. This exception may include a String message with more detail about the failure.

        The protocolConnect method should throw an exception to report failures not related to authentication, such as an invalid host name or port number, loss of a connection during the authentication process, unavailability of the server, etc.

        Parameters:
        host - the name of the host to connect to
        port - the port to use (-1 means use default port)
        user - the name of the user to login as
        password - the user's password
        Returns:
        true if connection successful, false if authentication failed
        Throws:
        AuthenticationFailedException - for authentication failures
        MessagingException - for non-authentication failures

      • isConnected

        public boolean isConnected()
        Is this service currently connected?

        This implementation uses a private boolean field to store the connection state. This method returns the value of that field.

        Subclasses may want to override this method to verify that any connection to the message store is still alive.

        Returns:
        true if the service is connected, false if it is not connected

      • setConnected

        protected void setConnected(boolean connected)
        Set the connection state of this service. The connection state will automatically be set by the service implementation during the connect and close methods. Subclasses will need to call this method to set the state if the service was automatically disconnected.

        The implementation in this class merely sets the private field returned by the isConnected method.

        Parameters:
        connected - true if the service is connected, false if it is not connected

      • close

        public void close()
           throws MessagingException
        Close this service and terminate its connection. A close ConnectionEvent is delivered to any ConnectionListeners. Any Messaging components (Folders, Messages, etc.) belonging to this service are invalid after this service is closed. Note that the service is closed even if this method terminates abnormally by throwing a MessagingException.

        This implementation uses setConnected(false) to set this service's connected state to false. It will then send a close ConnectionEvent to any registered ConnectionListeners. Subclasses overriding this method to do implementation specific cleanup should call this method as a last step to insure event notification, probably by including a call to super.close() in a finally clause.

        Throws:
        MessagingException - for errors while closing
        See Also:
        ConnectionEvent

      • getURLName

        public URLName getURLName()
        Return a URLName representing this service. The returned URLName does not include the password field.

        Subclasses should only override this method if their URLName does not follow the standard format.

        The implementation in the Service class returns (usually a copy of) the url field with the password and file information stripped out.

        Returns:
        the URLName representing this service
        See Also:
        URLName

      • setURLName

        protected void setURLName(URLName url)
        Set the URLName representing this service. Normally used to update the url field after a service has successfully connected.

        Subclasses should only override this method if their URL does not follow the standard format. In particular, subclasses should override this method if their URL does not require all the possible fields supported by URLName; a new URLName should be constructed with any unneeded fields removed.

        The implementation in the Service class simply sets the url field.

        See Also:
        URLName

      • addConnectionListener

        public void addConnectionListener(ConnectionListener l)
        Add a listener for Connection events on this service.

        The default implementation provided here adds this listener to an internal list of ConnectionListeners.

        Parameters:
        l - the Listener for Connection events
        See Also:
        ConnectionEvent

      • removeConnectionListener

        public void removeConnectionListener(ConnectionListener l)
        Remove a Connection event listener.

        The default implementation provided here removes this listener from the internal list of ConnectionListeners.

        Parameters:
        l - the listener
        See Also:
        addConnectionListener(javax.mail.event.ConnectionListener)

      • notifyConnectionListeners

        protected void notifyConnectionListeners(int type)
        Notify all ConnectionListeners. Service implementations are expected to use this method to broadcast connection events.

        The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered ConnectionListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

      • toString

        public String toString()
        Return getURLName.toString() if this service has a URLName, otherwise it will return the default toString.
        Overrides:
        toString in class Object

      • queueEvent

        protected void queueEvent(MailEvent event,
              Vector vector)
        Add the event and vector of listeners to the queue to be delivered.

      • finalize

        protected void finalize()
                 throws Throwable
        Stop the event dispatcher thread so the queue can be garbage collected.
        Overrides:
        finalize in class Object
        Throws:
        Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Session (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Session

  • java.lang.Object
    • javax.mail.Session

  • public final class Session
extends Object
    The Session class represents a mail session and is not subclassed. It collects together properties and defaults used by the mail API's. A single default session can be shared by multiple applications on the desktop. Unshared sessions can also be created.

    The Session class provides access to the protocol providers that implement the Store, Transport, and related classes. The protocol providers are configured using the following files:

    • javamail.providers and javamail.default.providers
    • javamail.address.map and javamail.default.address.map

    Each javamail.X resource file is searched for using three methods in the following order:

    1. java.home/lib/javamail.X
    2. META-INF/javamail.X
    3. META-INF/javamail.default.X

    The first method allows the user to include their own version of the resource file by placing it in the lib directory where the java.home property points. The second method allows an application that uses the JavaMail APIs to include their own resource files in their application's or jar file's META-INF directory. The javamail.default.X default files are part of the JavaMail mail.jar file.

    File location depends upon how the ClassLoader method getResource is implemented. Usually, the getResource method searches through CLASSPATH until it finds the requested file and then stops. JDK 1.1 has a limitation that the number of files of each name that will be found in the CLASSPATH is limited to one. However, this only affects method two, above; method one is loaded from a specific location (if allowed by the SecurityManager) and method three uses a different name to ensure that the default resource file is always loaded successfully. J2SE 1.2 and later are not limited to one file of a given name.

    The ordering of entries in the resource files matters. If multiple entries exist, the first entries take precedence over the later entries. For example, the first IMAP provider found will be set as the default IMAP implementation until explicitly changed by the application. The user- or system-supplied resource files augment, they do not override, the default files included with the JavaMail APIs. This means that all entries in all files loaded will be available.

    javamail.providers and javamail.default.providers

    These resource files specify the stores and transports that are available on the system, allowing an application to "discover" what store and transport implementations are available. The protocol implementations are listed one per line. The file format defines four attributes that describe a protocol implementation. Each attribute is an "="-separated name-value pair with the name in lowercase. Each name-value pair is semi-colon (";") separated. The following names are defined.

    Attribute Names in Providers Files
    Name | Description
    protocol | Name assigned to protocol. For example, smtp for Transport.
    type | Valid entries are store and transport.
    class | Class name that implements this protocol.
    vendor | Optional string identifying the vendor.
    version | Optional string identifying the version.

    Here's an example of META-INF/javamail.default.providers file contents:

     protocol=imap; type=store; class=com.sun.mail.imap.IMAPStore; vendor=Sun Microsystems, Inc.;
 protocol=smtp; type=transport; class=com.sun.mail.smtp.SMTPTransport; vendor=Sun Microsystems, Inc.;

    javamail.address.map and javamail.default.address.map

    These resource files map transport address types to the transport protocol. The getType method of javax.mail.Address returns the address type. The javamail.address.map file maps the transport type to the protocol. The file format is a series of name-value pairs. Each key name should correspond to an address type that is currently installed on the system; there should also be an entry for each javax.mail.Address implementation that is present if it is to be used. For example, the javax.mail.internet.InternetAddress method getType returns "rfc822". Each referenced protocol should be installed on the system. For the case of news, below, the client should install a Transport provider supporting the nntp protocol.

    Here are the typical contents of a javamail.address.map file:

     rfc822=smtp
 news=nntp
    Author:
    John Mani, Bill Shannon, Max Spivak

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addProvider(Provider provider)
      Add a provider to the session.
      boolean getDebug()
      Get the debug setting for this Session.
      PrintStream getDebugOut()
      Returns the stream to be used for debugging output.
      static Session getDefaultInstance(Properties props)
      Get the default Session object.
      static Session getDefaultInstance(Properties props, Authenticator authenticator)
      Get the default Session object.
      Folder getFolder(URLName url)
      Get a closed Folder object for the given URLName.
      static Session getInstance(Properties props)
      Get a new Session object.
      static Session getInstance(Properties props, Authenticator authenticator)
      Get a new Session object.
      PasswordAuthentication getPasswordAuthentication(URLName url)
      Return any saved PasswordAuthentication for this (store or transport) URLName.
      Properties getProperties()
      Returns the Properties object associated with this Session
      String getProperty(String name)
      Returns the value of the specified property.
      Provider getProvider(String protocol)
      Returns the default Provider for the protocol specified.
      Provider[] getProviders()
      This method returns an array of all the implementations installed via the javamail.[default.]providers files that can be loaded using the ClassLoader available to this application.
      Store getStore()
      Get a Store object that implements this user's desired Store protocol.
      Store getStore(Provider provider)
      Get an instance of the store specified by Provider.
      Store getStore(String protocol)
      Get a Store object that implements the specified protocol.
      Store getStore(URLName url)
      Get a Store object for the given URLName.
      Transport getTransport()
      Get a Transport object that implements this user's desired Transport protcol.
      Transport getTransport(Address address)
      Get a Transport object that can transport a Message of the specified address type.
      Transport getTransport(Provider provider)
      Get an instance of the transport specified in the Provider.
      Transport getTransport(String protocol)
      Get a Transport object that implements the specified protocol.
      Transport getTransport(URLName url)
      Get a Transport object for the given URLName.
      PasswordAuthentication requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String defaultUserName)
      Call back to the application to get the needed user name and password.
      void setDebug(boolean debug)
      Set the debug setting for this Session.
      void setDebugOut(PrintStream out)
      Set the stream to be used for debugging output for this session.
      void setPasswordAuthentication(URLName url, PasswordAuthentication pw)
      Save a PasswordAuthentication for this (store or transport) URLName.
      void setProtocolForAddress(String addresstype, String protocol)
      Set the default transport protocol to use for addresses of the specified type.
      void setProvider(Provider provider)
      Set the passed Provider to be the default implementation for the protocol in Provider.protocol overriding any previous values.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • getInstance

        public static Session getInstance(Properties props,
                  Authenticator authenticator)
        Get a new Session object.
        Parameters:
        props - Properties object that hold relevant properties.
        It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
        authenticator - Authenticator object used to call back to the application when a user name and password is needed.
        Returns:
        a new Session object
        See Also:
        Authenticator

      • getInstance

        public static Session getInstance(Properties props)
        Get a new Session object.
        Parameters:
        props - Properties object that hold relevant properties.
        It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
        Returns:
        a new Session object
        Since:
        JavaMail 1.2

      • getDefaultInstance

        public static Session getDefaultInstance(Properties props,
                         Authenticator authenticator)
        Get the default Session object. If a default has not yet been setup, a new Session object is created and installed as the default.

        Since the default session is potentially available to all code executing in the same Java virtual machine, and the session can contain security sensitive information such as user names and passwords, access to the default session is restricted. The Authenticator object, which must be created by the caller, is used indirectly to check access permission. The Authenticator object passed in when the session is created is compared with the Authenticator object passed in to subsequent requests to get the default session. If both objects are the same, or are from the same ClassLoader, the request is allowed. Otherwise, it is denied.

        Note that if the Authenticator object used to create the session is null, anyone can get the default session by passing in null.

        Note also that the Properties object is used only the first time this method is called, when a new Session object is created. Subsequent calls return the Session object that was created by the first call, and ignore the passed Properties object. Use the getInstance method to get a new Session object every time the method is called.

        In JDK 1.2, additional security Permission objects may be used to control access to the default session.

        Parameters:
        props - Properties object. Used only if a new Session object is created.
        It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
        authenticator - Authenticator object. Used only if a new Session object is created. Otherwise, it must match the Authenticator used to create the Session.
        Returns:
        the default Session object

      • getDefaultInstance

        public static Session getDefaultInstance(Properties props)
        Get the default Session object. If a default has not yet been setup, a new Session object is created and installed as the default.

        Note that a default session created with no Authenticator is available to all code executing in the same Java virtual machine, and the session can contain security sensitive information such as user names and passwords.

        Parameters:
        props - Properties object. Used only if a new Session object is created.
        It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
        Returns:
        the default Session object
        Since:
        JavaMail 1.2

      • setDebug

        public void setDebug(boolean debug)
        Set the debug setting for this Session.

        Since the debug setting can be turned on only after the Session has been created, to turn on debugging in the Session constructor, set the property mail.debug in the Properties object passed in to the constructor to true. The value of the mail.debug property is used to initialize the per-Session debugging flag. Subsequent calls to the setDebug method manipulate the per-Session debugging flag and have no affect on the mail.debug property.

        Parameters:
        debug - Debug setting

      • getDebug

        public boolean getDebug()
        Get the debug setting for this Session.
        Returns:
        current debug setting

      • setDebugOut

        public void setDebugOut(PrintStream out)
        Set the stream to be used for debugging output for this session. If out is null, System.out will be used. Note that debugging output that occurs before any session is created, as a result of setting the mail.debug system property, will always be sent to System.out.
        Parameters:
        out - the PrintStream to use for debugging output
        Since:
        JavaMail 1.3

      • getDebugOut

        public PrintStream getDebugOut()
        Returns the stream to be used for debugging output. If no stream has been set, System.out is returned.
        Returns:
        the PrintStream to use for debugging output
        Since:
        JavaMail 1.3

      • getProviders

        public Provider[] getProviders()
        This method returns an array of all the implementations installed via the javamail.[default.]providers files that can be loaded using the ClassLoader available to this application.
        Returns:
        Array of configured providers

      • getProvider

        public Provider getProvider(String protocol)
                     throws NoSuchProviderException
        Returns the default Provider for the protocol specified. Checks mail.<protocol>.class property first and if it exists, returns the Provider associated with this implementation. If it doesn't exist, returns the Provider that appeared first in the configuration files. If an implementation for the protocol isn't found, throws NoSuchProviderException
        Parameters:
        protocol - Configured protocol (i.e. smtp, imap, etc)
        Returns:
        Currently configured Provider for the specified protocol
        Throws:
        NoSuchProviderException - If a provider for the given protocol is not found.

      • setProvider

        public void setProvider(Provider provider)
                 throws NoSuchProviderException
        Set the passed Provider to be the default implementation for the protocol in Provider.protocol overriding any previous values.
        Parameters:
        provider - Currently configured Provider which will be set as the default for the protocol
        Throws:
        NoSuchProviderException - If the provider passed in is invalid.

      • getStore

        public Store getStore()
               throws NoSuchProviderException
        Get a Store object that implements this user's desired Store protocol. The mail.store.protocol property specifies the desired protocol. If an appropriate Store object is not obtained, NoSuchProviderException is thrown
        Returns:
        a Store object
        Throws:
        NoSuchProviderException - If a provider for the given protocol is not found.

      • getStore

        public Store getStore(String protocol)
               throws NoSuchProviderException
        Get a Store object that implements the specified protocol. If an appropriate Store object cannot be obtained, NoSuchProviderException is thrown.
        Parameters:
        protocol -
        Returns:
        a Store object
        Throws:
        NoSuchProviderException - If a provider for the given protocol is not found.

      • getStore

        public Store getStore(URLName url)
               throws NoSuchProviderException
        Get a Store object for the given URLName. If the requested Store object cannot be obtained, NoSuchProviderException is thrown. The "scheme" part of the URL string (Refer RFC 1738) is used to locate the Store protocol.

        Parameters:
        url - URLName that represents the desired Store
        Returns:
        a closed Store object
        Throws:
        NoSuchProviderException - If a provider for the given URLName is not found.
        See Also:
        getFolder(URLName), URLName

      • getStore

        public Store getStore(Provider provider)
               throws NoSuchProviderException
        Get an instance of the store specified by Provider. Instantiates the store and returns it.
        Parameters:
        provider - Store Provider that will be instantiated
        Returns:
        Instantiated Store
        Throws:
        NoSuchProviderException - If a provider for the given Provider is not found.

      • getFolder

        public Folder getFolder(URLName url)
                 throws MessagingException
        Get a closed Folder object for the given URLName. If the requested Folder object cannot be obtained, null is returned.

        The "scheme" part of the URL string (Refer RFC 1738) is used to locate the Store protocol. The rest of the URL string (that is, the "schemepart", as per RFC 1738) is used by that Store in a protocol dependent manner to locate and instantiate the appropriate Folder object.

        Note that RFC 1738 also specifies the syntax for the "schemepart" for IP-based protocols (IMAP4, POP3, etc.). Providers of IP-based mail Stores should implement that syntax for referring to Folders.

        Parameters:
        url - URLName that represents the desired folder
        Returns:
        Folder
        Throws:
        NoSuchProviderException - If a provider for the given URLName is not found.
        MessagingException - if the Folder could not be located or created.
        See Also:
        getStore(URLName), URLName

      • getTransport

        public Transport getTransport()
                       throws NoSuchProviderException
        Get a Transport object that implements this user's desired Transport protcol. The mail.transport.protocol property specifies the desired protocol. If an appropriate Transport object cannot be obtained, MessagingException is thrown.
        Returns:
        a Transport object
        Throws:
        NoSuchProviderException - If the provider is not found.

      • getTransport

        public Transport getTransport(String protocol)
                       throws NoSuchProviderException
        Get a Transport object that implements the specified protocol. If an appropriate Transport object cannot be obtained, null is returned.
        Returns:
        a Transport object
        Throws:
        NoSuchProviderException - If provider for the given protocol is not found.

      • getTransport

        public Transport getTransport(URLName url)
                       throws NoSuchProviderException
        Get a Transport object for the given URLName. If the requested Transport object cannot be obtained, NoSuchProviderException is thrown. The "scheme" part of the URL string (Refer RFC 1738) is used to locate the Transport protocol.

        Parameters:
        url - URLName that represents the desired Transport
        Returns:
        a closed Transport object
        Throws:
        NoSuchProviderException - If a provider for the given URLName is not found.
        See Also:
        URLName

      • getTransport

        public Transport getTransport(Provider provider)
                       throws NoSuchProviderException
        Get an instance of the transport specified in the Provider. Instantiates the transport and returns it.
        Parameters:
        provider - Transport Provider that will be instantiated
        Returns:
        Instantiated Transport
        Throws:
        NoSuchProviderException - If provider for the given provider is not found.

      • getTransport

        public Transport getTransport(Address address)
                       throws NoSuchProviderException
        Get a Transport object that can transport a Message of the specified address type.
        Parameters:
        address -
        Returns:
        A Transport object
        Throws:
        NoSuchProviderException - If provider for the Address type is not found
        See Also:
        Address

      • setPasswordAuthentication

        public void setPasswordAuthentication(URLName url,
                             PasswordAuthentication pw)
        Save a PasswordAuthentication for this (store or transport) URLName. If pw is null the entry corresponding to the URLName is removed.

        This is normally used only by the store or transport implementations to allow authentication information to be shared among multiple uses of a session.

      • getPasswordAuthentication

        public PasswordAuthentication getPasswordAuthentication(URLName url)
        Return any saved PasswordAuthentication for this (store or transport) URLName. Normally used only by store or transport implementations.
        Returns:
        the PasswordAuthentication corresponding to the URLName

      • requestPasswordAuthentication

        public PasswordAuthentication requestPasswordAuthentication(InetAddress addr,
                                                   int port,
                                                   String protocol,
                                                   String prompt,
                                                   String defaultUserName)
        Call back to the application to get the needed user name and password. The application should put up a dialog something like:

         Connecting to <protocol> mail service on host <addr>, port <port>.
 <prompt>

 User Name: <defaultUserName>
 Password:
        Parameters:
        addr - InetAddress of the host. may be null.
        protocol - protocol scheme (e.g. imap, pop3, etc.)
        prompt - any additional String to show as part of the prompt; may be null.
        defaultUserName - the default username. may be null.
        Returns:
        the authentication which was collected by the authenticator; may be null.

      • getProperties

        public Properties getProperties()
        Returns the Properties object associated with this Session
        Returns:
        Properties object

      • getProperty

        public String getProperty(String name)
        Returns the value of the specified property. Returns null if this property does not exist.
        Returns:
        String that is the property value

      • addProvider

        public void addProvider(Provider provider)
        Add a provider to the session.
        Parameters:
        provider - the provider to add
        Since:
        JavaMail 1.4

      • setProtocolForAddress

        public void setProtocolForAddress(String addresstype,
                         String protocol)
        Set the default transport protocol to use for addresses of the specified type. Normally the default is set by the javamail.default.address.map or javamail.address.map files or resources.
        Parameters:
        addresstype - type of address
        protocol - name of protocol
        Since:
        JavaMail 1.4
        See Also:
        getTransport(Address)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Store (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Store

  • java.lang.Object
    • javax.mail.Service
      • javax.mail.Store

  • public abstract class Store
extends Service
    An abstract class that models a message store and its access protocol, for storing and retrieving messages. Subclasses provide actual implementations.

    Note that Store extends the Service class, which provides many common methods for naming stores, connecting to stores, and listening to connection events.

    Author:
    John Mani, Bill Shannon
    See Also:
    Service, ConnectionEvent, StoreEvent

    • Field Summary

      • Fields inherited from class javax.mail.Service

        debug, session, url

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Store(Session session, URLName urlname)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addFolderListener(FolderListener l)
      Add a listener for Folder events on any Folder object obtained from this Store.
      void addStoreListener(StoreListener l)
      Add a listener for StoreEvents on this Store.
      abstract Folder getDefaultFolder()
      Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.
      abstract Folder getFolder(String name)
      Return the Folder object corresponding to the given name.
      abstract Folder getFolder(URLName url)
      Return a closed Folder object, corresponding to the given URLName.
      Folder[] getPersonalNamespaces()
      Return a set of folders representing the personal namespaces for the current user.
      Folder[] getSharedNamespaces()
      Return a set of folders representing the shared namespaces.
      Folder[] getUserNamespaces(String user)
      Return a set of folders representing the namespaces for user.
      protected void notifyFolderListeners(int type, Folder folder)
      Notify all FolderListeners.
      protected void notifyFolderRenamedListeners(Folder oldF, Folder newF)
      Notify all FolderListeners about the renaming of a folder.
      protected void notifyStoreListeners(int type, String message)
      Notify all StoreListeners.
      void removeFolderListener(FolderListener l)
      Remove a listener for Folder events.
      void removeStoreListener(StoreListener l)
      Remove a listener for Store events.

      • Methods inherited from class javax.mail.Service

        addConnectionListener, close, connect, connect, connect, connect, finalize, getURLName, isConnected, notifyConnectionListeners, protocolConnect, queueEvent, removeConnectionListener, setConnected, setURLName, toString

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Store

        protected Store(Session session,
     URLName urlname)
        Constructor.
        Parameters:
        session - Session object for this Store.
        urlname - URLName object to be used for this Store

    • Method Detail

      • getDefaultFolder

        public abstract Folder getDefaultFolder()
                                 throws MessagingException
        Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.
        Returns:
        the root Folder
        Throws:
        IllegalStateException - if this Store is not connected.
        MessagingException

      • getFolder

        public abstract Folder getFolder(String name)
                          throws MessagingException
        Return the Folder object corresponding to the given name. Note that a Folder object is returned even if the named folder does not physically exist on the Store. The exists() method on the folder object indicates whether this folder really exists.

        Folder objects are not cached by the Store, so invoking this method on the same name multiple times will return that many distinct Folder objects.

        Parameters:
        name - The name of the Folder. In some Stores, name can be an absolute path if it starts with the hierarchy delimiter. Else it is interpreted relative to the 'root' of this namespace.
        Returns:
        Folder object
        Throws:
        IllegalStateException - if this Store is not connected.
        MessagingException
        See Also:
        Folder.exists(), Folder.create(int)

      • getFolder

        public abstract Folder getFolder(URLName url)
                          throws MessagingException
        Return a closed Folder object, corresponding to the given URLName. The store specified in the given URLName should refer to this Store object.

        Implementations of this method may obtain the name of the actual folder using the getFile() method on URLName, and use that name to create the folder.

        Parameters:
        url - URLName that denotes a folder
        Returns:
        Folder object
        Throws:
        IllegalStateException - if this Store is not connected.
        MessagingException
        See Also:
        URLName

      • getPersonalNamespaces

        public Folder[] getPersonalNamespaces()
                               throws MessagingException
        Return a set of folders representing the personal namespaces for the current user. A personal namespace is a set of names that is considered within the personal scope of the authenticated user. Typically, only the authenticated user has access to mail folders in their personal namespace. If an INBOX exists for a user, it must appear within the user's personal namespace. In the typical case, there should be only one personal namespace for each user in each Store.

        This implementation returns an array with a single entry containing the return value of the getDefaultFolder method. Subclasses should override this method to return appropriate information.

        Returns:
        array of Folder objects
        Throws:
        IllegalStateException - if this Store is not connected.
        MessagingException
        Since:
        JavaMail 1.2

      • getUserNamespaces

        public Folder[] getUserNamespaces(String user)
                           throws MessagingException
        Return a set of folders representing the namespaces for user. The namespaces returned represent the personal namespaces for the user. To access mail folders in the other user's namespace, the currently authenticated user must be explicitly granted access rights. For example, it is common for a manager to grant to their secretary access rights to their mail folders.

        This implementation returns an empty array. Subclasses should override this method to return appropriate information.

        Returns:
        array of Folder objects
        Throws:
        IllegalStateException - if this Store is not connected.
        MessagingException
        Since:
        JavaMail 1.2

      • getSharedNamespaces

        public Folder[] getSharedNamespaces()
                             throws MessagingException
        Return a set of folders representing the shared namespaces. A shared namespace is a namespace that consists of mail folders that are intended to be shared amongst users and do not exist within a user's personal namespace.

        This implementation returns an empty array. Subclasses should override this method to return appropriate information.

        Returns:
        array of Folder objects
        Throws:
        IllegalStateException - if this Store is not connected.
        MessagingException
        Since:
        JavaMail 1.2

      • addStoreListener

        public void addStoreListener(StoreListener l)
        Add a listener for StoreEvents on this Store.

        The default implementation provided here adds this listener to an internal list of StoreListeners.

        Parameters:
        l - the Listener for Store events
        See Also:
        StoreEvent

      • removeStoreListener

        public void removeStoreListener(StoreListener l)
        Remove a listener for Store events.

        The default implementation provided here removes this listener from the internal list of StoreListeners.

        Parameters:
        l - the listener
        See Also:
        addStoreListener(javax.mail.event.StoreListener)

      • notifyStoreListeners

        protected void notifyStoreListeners(int type,
                        String message)
        Notify all StoreListeners. Store implementations are expected to use this method to broadcast StoreEvents.

        The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered StoreListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

      • addFolderListener

        public void addFolderListener(FolderListener l)
        Add a listener for Folder events on any Folder object obtained from this Store. FolderEvents are delivered to FolderListeners on the affected Folder as well as to FolderListeners on the containing Store.

        The default implementation provided here adds this listener to an internal list of FolderListeners.

        Parameters:
        l - the Listener for Folder events
        See Also:
        FolderEvent

      • removeFolderListener

        public void removeFolderListener(FolderListener l)
        Remove a listener for Folder events.

        The default implementation provided here removes this listener from the internal list of FolderListeners.

        Parameters:
        l - the listener
        See Also:
        addFolderListener(javax.mail.event.FolderListener)

      • notifyFolderListeners

        protected void notifyFolderListeners(int type,
                         Folder folder)
        Notify all FolderListeners. Store implementations are expected to use this method to broadcast Folder events.

        The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered FolderListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

        Parameters:
        type - type of FolderEvent
        folder - affected Folder
        See Also:
        notifyFolderRenamedListeners(javax.mail.Folder, javax.mail.Folder)

      • notifyFolderRenamedListeners

        protected void notifyFolderRenamedListeners(Folder oldF,
                                Folder newF)
        Notify all FolderListeners about the renaming of a folder. Store implementations are expected to use this method to broadcast Folder events indicating the renaming of folders.

        The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered FolderListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

        Parameters:
        oldF - the folder being renamed
        newF - the folder representing the new name.
        Since:
        JavaMail 1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StoreClosedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class StoreClosedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.StoreClosedException
  • All Implemented Interfaces:
    Serializable

    public class StoreClosedException
extends MessagingException
    This exception is thrown when a method is invoked on a Messaging object and the Store that owns that object has died due to some reason. This exception should be treated as a fatal error; in particular any messaging object belonging to that Store must be considered invalid.

    The connect method may be invoked on the dead Store object to revive it.

    The getMessage() method returns more detailed information about the error that caused this exception.

    Author:
    John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      StoreClosedException(Store store)
      Constructs a StoreClosedException with no detail message.
      StoreClosedException(Store store, String message)
      Constructs a StoreClosedException with the specified detail message.
      StoreClosedException(Store store, String message, Exception e)
      Constructs a StoreClosedException with the specified detail message and embedded exception.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Store getStore()
      Returns the dead Store object

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • StoreClosedException

        public StoreClosedException(Store store)
        Constructs a StoreClosedException with no detail message.
        Parameters:
        store - The dead Store object

      • StoreClosedException

        public StoreClosedException(Store store,
                    String message)
        Constructs a StoreClosedException with the specified detail message.
        Parameters:
        store - The dead Store object
        message - The detailed error message

      • StoreClosedException

        public StoreClosedException(Store store,
                    String message,
                    Exception e)
        Constructs a StoreClosedException with the specified detail message and embedded exception. The exception is chained to this exception.
        Parameters:
        store - The dead Store object
        message - The detailed error message
        e - The embedded exception
        Since:
        JavaMail 1.5

    • Method Detail

      • getStore

        public Store getStore()
        Returns the dead Store object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Transport (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class Transport

  • java.lang.Object
    • javax.mail.Service
      • javax.mail.Transport

  • public abstract class Transport
extends Service
    An abstract class that models a message transport. Subclasses provide actual implementations.

    Note that Transport extends the Service class, which provides many common methods for naming transports, connecting to transports, and listening to connection events.

    Author:
    John Mani, Max Spivak, Bill Shannon
    See Also:
    Service, ConnectionEvent, TransportEvent

    • Field Summary

      • Fields inherited from class javax.mail.Service

        debug, session, url

    • Constructor Summary

      Constructors
      Constructor and Description
      Transport(Session session, URLName urlname)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addTransportListener(TransportListener l)
      Add a listener for Transport events.
      protected void notifyTransportListeners(int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Notify all TransportListeners.
      void removeTransportListener(TransportListener l)
      Remove a listener for Transport events.
      static void send(Message msg)
      Send a message.
      static void send(Message msg, Address[] addresses)
      Send the message to the specified addresses, ignoring any recipients specified in the message itself.
      static void send(Message msg, Address[] addresses, String user, String password)
      Send the message to the specified addresses, ignoring any recipients specified in the message itself.
      static void send(Message msg, String user, String password)
      Send a message.
      abstract void sendMessage(Message msg, Address[] addresses)
      Send the Message to the specified list of addresses.

      • Methods inherited from class javax.mail.Service

        addConnectionListener, close, connect, connect, connect, connect, finalize, getURLName, isConnected, notifyConnectionListeners, protocolConnect, queueEvent, removeConnectionListener, setConnected, setURLName, toString

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Transport

        public Transport(Session session,
         URLName urlname)
        Constructor.
        Parameters:
        session - Session object for this Transport.
        urlname - URLName object to be used for this Transport

    • Method Detail

      • send

        public static void send(Message msg)
                 throws MessagingException
        Send a message. The message will be sent to all recipient addresses specified in the message (as returned from the Message method getAllRecipients), using message transports appropriate to each address. The send method calls the saveChanges method on the message before sending it.

        If any of the recipient addresses is detected to be invalid by the Transport during message submission, a SendFailedException is thrown. Clients can get more detail about the failure by examining the exception. Whether or not the message is still sent successfully to any valid addresses depends on the Transport implementation. See SendFailedException for more details. Note also that success does not imply that the message was delivered to the ultimate recipient, as failures may occur in later stages of delivery. Once a Transport accepts a message for delivery to a recipient, failures that occur later should be reported to the user via another mechanism, such as returning the undeliverable message.

        In typical usage, a SendFailedException reflects an error detected by the server. The details of the SendFailedException will usually contain the error message from the server (such as an SMTP error message). An address may be detected as invalid for a variety of reasons - the address may not exist, the address may have invalid syntax, the address may have exceeded its quota, etc.

        Note that send is a static method that creates and manages its own connection. Any connection associated with any Transport instance used to invoke this method is ignored and not used. This method should only be invoked using the form Transport.send(msg);, and should never be invoked using an instance variable.

        Parameters:
        msg - the message to send
        Throws:
        SendFailedException - if the message could not be sent to some or any of the recipients.
        MessagingException
        See Also:
        Message.saveChanges(),
Message.getAllRecipients(),
send(Message, Address[]),
SendFailedException

      • send

        public static void send(Message msg,
        Address[] addresses)
                 throws MessagingException
        Send the message to the specified addresses, ignoring any recipients specified in the message itself. The send method calls the saveChanges method on the message before sending it.

        Parameters:
        msg - the message to send
        addresses - the addresses to which to send the message
        Throws:
        SendFailedException - if the message could not be sent to some or any of the recipients.
        MessagingException
        See Also:
        Message.saveChanges(), send(Message), SendFailedException

      • send

        public static void send(Message msg,
        String user,
        String password)
                 throws MessagingException
        Send a message. The message will be sent to all recipient addresses specified in the message (as returned from the Message method getAllRecipients). The send method calls the saveChanges method on the message before sending it.

        Use the specified user name and password to authenticate to the mail server.

        Parameters:
        msg - the message to send
        user - the user name
        password - this user's password
        Throws:
        SendFailedException - if the message could not be sent to some or any of the recipients.
        MessagingException
        Since:
        JavaMail 1.5
        See Also:
        Message.saveChanges(), send(Message), SendFailedException

      • send

        public static void send(Message msg,
        Address[] addresses,
        String user,
        String password)
                 throws MessagingException
        Send the message to the specified addresses, ignoring any recipients specified in the message itself. The send method calls the saveChanges method on the message before sending it.

        Use the specified user name and password to authenticate to the mail server.

        Parameters:
        msg - the message to send
        addresses - the addresses to which to send the message
        user - the user name
        password - this user's password
        Throws:
        SendFailedException - if the message could not be sent to some or any of the recipients.
        MessagingException
        Since:
        JavaMail 1.5
        See Also:
        Message.saveChanges(), send(Message), SendFailedException

      • sendMessage

        public abstract void sendMessage(Message msg,
               Address[] addresses)
                          throws MessagingException
        Send the Message to the specified list of addresses. An appropriate TransportEvent indicating the delivery status is delivered to any TransportListener registered on this Transport. Also, if any of the addresses is invalid, a SendFailedException is thrown. Whether or not the message is still sent succesfully to any valid addresses depends on the Transport implementation.

        Unlike the static send method, the sendMessage method does not call the saveChanges method on the message; the caller should do so.

        Parameters:
        msg - The Message to be sent
        addresses - array of addresses to send this message to
        Throws:
        SendFailedException - if the send failed because of invalid addresses.
        MessagingException - if the connection is dead or not in the connected state
        See Also:
        TransportEvent

      • addTransportListener

        public void addTransportListener(TransportListener l)
        Add a listener for Transport events.

        The default implementation provided here adds this listener to an internal list of TransportListeners.

        Parameters:
        l - the Listener for Transport events
        See Also:
        TransportEvent

      • removeTransportListener

        public void removeTransportListener(TransportListener l)
        Remove a listener for Transport events.

        The default implementation provided here removes this listener from the internal list of TransportListeners.

        Parameters:
        l - the listener
        See Also:
        addTransportListener(javax.mail.event.TransportListener)

      • notifyTransportListeners

        protected void notifyTransportListeners(int type,
                            Address[] validSent,
                            Address[] validUnsent,
                            Address[] invalid,
                            Message msg)
        Notify all TransportListeners. Transport implementations are expected to use this method to broadcast TransportEvents.

        The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered TransportListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIDFolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Interface UIDFolder

  • public interface UIDFolder
    The UIDFolder interface is implemented by Folders that can support the "disconnected" mode of operation, by providing unique-ids for messages in the folder. This interface is based on the IMAP model for supporting disconnected operation.

    A Unique identifier (UID) is a positive long value, assigned to each message in a specific folder. Unique identifiers are assigned in a strictly ascending fashion in the mailbox. That is, as each message is added to the mailbox it is assigned a higher UID than the message(s) which were added previously. Unique identifiers persist across sessions. This permits a client to resynchronize its state from a previous session with the server.

    Associated with every mailbox is a unique identifier validity value. If unique identifiers from an earlier session fail to persist to this session, the unique identifier validity value must be greater than the one used in the earlier session.

    Refer to RFC 2060 for more information. All the Folder objects returned by the default IMAP provider implement the UIDFolder interface. Use it as follows:

        Folder f = store.getFolder("whatever");
        UIDFolder uf = (UIDFolder)f;
        long uid = uf.getUID(msg);

    Author:
    John Mani

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  UIDFolder.FetchProfileItem
      A fetch profile item for fetching UIDs.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static long LASTUID
      This is a special value that can be used as the end parameter in getMessagesByUID(start, end), to denote the UID of the last message in the folder.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Message getMessageByUID(long uid)
      Get the Message corresponding to the given UID.
      Message[] getMessagesByUID(long[] uids)
      Get the Messages specified by the given array of UIDs.
      Message[] getMessagesByUID(long start, long end)
      Get the Messages specified by the given range.
      long getUID(Message message)
      Get the UID for the specified message.
      long getUIDValidity()
      Returns the UIDValidity value associated with this folder.

    • Field Detail

      • LASTUID

        static final long LASTUID
        This is a special value that can be used as the end parameter in getMessagesByUID(start, end), to denote the UID of the last message in the folder.
        See Also:
        getMessagesByUID(long, long), Constant Field Values

    • Method Detail

      • getUIDValidity

        long getUIDValidity()
                    throws MessagingException
        Returns the UIDValidity value associated with this folder.

        Clients typically compare this value against a UIDValidity value saved from a previous session to insure that any cached UIDs are not stale.

        Returns:
        UIDValidity
        Throws:
        MessagingException

      • getMessageByUID

        Message getMessageByUID(long uid)
                        throws MessagingException
        Get the Message corresponding to the given UID. If no such message exists, null is returned.
        Parameters:
        uid - UID for the desired message
        Returns:
        the Message object. null is returned if no message corresponding to this UID is obtained.
        Throws:
        MessagingException

      • getMessagesByUID

        Message[] getMessagesByUID(long start,
                         long end)
                           throws MessagingException
        Get the Messages specified by the given range. The special value LASTUID can be used for the end parameter to indicate the UID of the last message in the folder.

        Note that end need not be greater than start; the order of the range doesn't matter. Note also that, unless the folder is empty, use of LASTUID ensures that at least one message will be returned - the last message in the folder.

        Parameters:
        start - start UID
        end - end UID
        Returns:
        array of Message objects
        Throws:
        MessagingException
        See Also:
        LASTUID

      • getMessagesByUID

        Message[] getMessagesByUID(long[] uids)
                           throws MessagingException
        Get the Messages specified by the given array of UIDs. If any UID is invalid, null is returned for that entry.

        Note that the returned array will be of the same size as the specified array of UIDs, and null entries may be present in the array to indicate invalid UIDs.

        Parameters:
        uids - array of UIDs
        Returns:
        array of Message objects
        Throws:
        MessagingException

      • getUID

        long getUID(Message message)
            throws MessagingException
        Get the UID for the specified message. Note that the message must belong to this folder. Otherwise java.util.NoSuchElementException is thrown.
        Parameters:
        message - Message from this folder
        Returns:
        UID for this message
        Throws:
        NoSuchElementException - if the given Message is not in this Folder.
        MessagingException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UIDFolder.FetchProfileItem (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class UIDFolder.FetchProfileItem

  • java.lang.Object
    • javax.mail.FetchProfile.Item
      • javax.mail.UIDFolder.FetchProfileItem
  • Enclosing interface:
    UIDFolder

    public static class UIDFolder.FetchProfileItem
extends FetchProfile.Item
    A fetch profile item for fetching UIDs. This inner class extends the FetchProfile.Item class to add new FetchProfile item types, specific to UIDFolders. The only item currently defined here is the UID item.
    See Also:
    FetchProfile

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static UIDFolder.FetchProfileItem UID
      UID is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder.

      • Fields inherited from class javax.mail.FetchProfile.Item

        CONTENT_INFO, ENVELOPE, FLAGS, SIZE

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | UIDFolder.FetchProfileItem(String name)

    • Method Summary

      • Methods inherited from class javax.mail.FetchProfile.Item

        toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • UID

        public static final UIDFolder.FetchProfileItem UID
        UID is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder. This item indicates that the UIDs for messages in the specified range are desired to be prefetched.

        An example of how a client uses this is below:

        FetchProfile fp = new FetchProfile();
        fp.add(UIDFolder.FetchProfileItem.UID);
        folder.fetch(msgs, fp);

    • Constructor Detail

      • UIDFolder.FetchProfileItem

        protected UIDFolder.FetchProfileItem(String name)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


URLName (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail

Class URLName

  • java.lang.Object
    • javax.mail.URLName

  • public class URLName
extends Object
    The name of a URL. This class represents a URL name and also provides the basic parsing functionality to parse most internet standard URL schemes.

    Note that this class differs from java.net.URL in that this class just represents the name of a URL, it does not model the connection to a URL.

    Author:
    Christopher Cotton, Bill Shannon

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected String fullURL
      The full version of the URL

    • Constructor Summary

      Constructors
      Constructor and Description
      URLName(String url)
      Construct a URLName from the string.
      URLName(String protocol, String host, int port, String file, String username, String password)
      Creates a URLName object from the specified protocol, host, port number, file, username, and password.
      URLName(URL url)
      Construct a URLName from a java.net.URL object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Compares two URLNames.
      String getFile()
      Returns the file name of this URLName.
      String getHost()
      Returns the host of this URLName.
      String getPassword()
      Returns the password of this URLName.
      int getPort()
      Returns the port number of this URLName.
      String getProtocol()
      Returns the protocol of this URLName.
      String getRef()
      Returns the reference of this URLName.
      URL getURL()
      Constructs a URL from the URLName.
      String getUsername()
      Returns the user name of this URLName.
      int hashCode()
      Compute the hash code for this URLName.
      protected void parseString(String url)
      Method which does all of the work of parsing the string.
      String toString()
      Constructs a string representation of this URLName.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Field Detail

      • fullURL

        protected String fullURL
        The full version of the URL

    • Constructor Detail

      • URLName

        public URLName(String protocol,
       String host,
       int port,
       String file,
       String username,
       String password)
        Creates a URLName object from the specified protocol, host, port number, file, username, and password. Specifying a port number of -1 indicates that the URL should use the default port for the protocol.

      • URLName

        public URLName(URL url)
        Construct a URLName from a java.net.URL object.

      • URLName

        public URLName(String url)
        Construct a URLName from the string. Parses out all the possible information (protocol, host, port, file, username, password).

    • Method Detail

      • toString

        public String toString()
        Constructs a string representation of this URLName.
        Overrides:
        toString in class Object

      • parseString

        protected void parseString(String url)
        Method which does all of the work of parsing the string.

      • getPort

        public int getPort()
        Returns the port number of this URLName. Returns -1 if the port is not set.

      • getProtocol

        public String getProtocol()
        Returns the protocol of this URLName. Returns null if this URLName has no protocol.

      • getFile

        public String getFile()
        Returns the file name of this URLName. Returns null if this URLName has no file name.

      • getRef

        public String getRef()
        Returns the reference of this URLName. Returns null if this URLName has no reference.

      • getHost

        public String getHost()
        Returns the host of this URLName. Returns null if this URLName has no host.

      • getUsername

        public String getUsername()
        Returns the user name of this URLName. Returns null if this URLName has no user name.

      • getPassword

        public String getPassword()
        Returns the password of this URLName. Returns null if this URLName has no password.

      • getURL

        public URL getURL()
           throws MalformedURLException
        Constructs a URL from the URLName.
        Throws:
        MalformedURLException

      • equals

        public boolean equals(Object obj)
        Compares two URLNames. The result is true if and only if the argument is not null and is a URLName object that represents the same URLName as this object. Two URLName objects are equal if they have the same protocol and the same host, the same port number on the host, the same username, and the same file on the host. The fields (host, username, file) are also considered the same if they are both null.

        Hosts are considered equal if the names are equal (case independent) or if host name lookups for them both succeed and they both reference the same IP address.

        Note that URLName has no knowledge of default port numbers for particular protocols, so "imap://host" and "imap://host:143" would not compare as equal.

        Note also that the password field is not included in the comparison, nor is any reference field appended to the filename.

        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Compute the hash code for this URLName.
        Overrides:
        hashCode in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.mail (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.mail

  • Packages that use javax.mail
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.
    javax.mail.internet
    Classes specific to Internet mail systems.
    javax.mail.search
    Message search terms for the JavaMail API.
  • Classes in javax.mail used by javax.mail
    Class and Description
    Address
    This abstract class models the addresses in a message.
    Authenticator
    The class Authenticator represents an object that knows how to obtain authentication for a network connection.
    BodyPart
    This class models a Part that is contained within a Multipart.
    FetchProfile
    Clients use a FetchProfile to list the Message attributes that it wishes to prefetch from the server for a range of messages.
    FetchProfile.Item
    This inner class is the base class of all items that can be requested in a FetchProfile.
    Flags
    The Flags class represents the set of flags on a Message.
    Flags.Flag
    This inner class represents an individual system flag.
    Folder
    Folder is an abstract class that represents a folder for mail messages.
    Message
    This class models an email message.
    Message.RecipientType
    This inner class defines the types of recipients allowed by the Message class.
    MessageContext
    The context in which a piece of Message content is contained.
    MessagingException
    The base class for all exceptions thrown by the Messaging classes
    Multipart
    Multipart is a container that holds multiple body parts.
    MultipartDataSource
    MultipartDataSource is a DataSource that contains body parts.
    NoSuchProviderException
    This exception is thrown when Session attempts to instantiate a Provider that doesn't exist.
    Part
    The Part interface is the common base interface for Messages and BodyParts.
    PasswordAuthentication
    The class PasswordAuthentication is a data holder that is used by Authenticator.
    Provider
    The Provider is a class that describes a protocol implementation.
    Provider.Type
    This inner class defines the Provider type.
    Quota
    This class represents a set of quotas for a given quota root.
    Quota.Resource
    An individual resource in a quota root.
    Service
    An abstract class that contains the functionality common to messaging services, such as stores and transports.
    Session
    The Session class represents a mail session and is not subclassed.
    Store
    An abstract class that models a message store and its access protocol, for storing and retrieving messages.
    Transport
    An abstract class that models a message transport.
    UIDFolder.FetchProfileItem
    A fetch profile item for fetching UIDs.
    URLName
    The name of a URL.
  • Classes in javax.mail used by javax.mail.event
    Class and Description
    Address
    This abstract class models the addresses in a message.
    Folder
    Folder is an abstract class that represents a folder for mail messages.
    Message
    This class models an email message.
    Store
    An abstract class that models a message store and its access protocol, for storing and retrieving messages.
    Transport
    An abstract class that models a message transport.
  • Classes in javax.mail used by javax.mail.internet
    Class and Description
    Address
    This abstract class models the addresses in a message.
    BodyPart
    This class models a Part that is contained within a Multipart.
    Flags
    The Flags class represents the set of flags on a Message.
    Flags.Flag
    This inner class represents an individual system flag.
    Folder
    Folder is an abstract class that represents a folder for mail messages.
    Header
    The Header class stores a name/value pair to represent headers.
    Message
    This class models an email message.
    Message.RecipientType
    This inner class defines the types of recipients allowed by the Message class.
    MessageAware
    An interface optionally implemented by DataSources to supply information to a DataContentHandler about the message context in which the data content object is operating.
    MessageContext
    The context in which a piece of Message content is contained.
    MessagingException
    The base class for all exceptions thrown by the Messaging classes
    Multipart
    Multipart is a container that holds multiple body parts.
    Part
    The Part interface is the common base interface for Messages and BodyParts.
    Session
    The Session class represents a mail session and is not subclassed.
  • Classes in javax.mail used by javax.mail.search
    Class and Description
    Address
    This abstract class models the addresses in a message.
    Flags
    The Flags class represents the set of flags on a Message.
    Message
    This class models an email message.
    Message.RecipientType
    This inner class defines the types of recipients allowed by the Message class.
    MessagingException
    The base class for all exceptions thrown by the Messaging classes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Address (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Address

  • Packages that use Address
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.
    javax.mail.internet
    Classes specific to Internet mail systems.
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of Address in javax.mail

      Fields in javax.mail declared as Address
      Modifier and Type | Field and Description
      protected Address[] | SendFailedException.invalid
      protected Address[] | SendFailedException.validSent
      protected Address[] | SendFailedException.validUnsent
      Methods in javax.mail that return Address
      Modifier and Type Method and Description
      Address[] Message.getAllRecipients()
      Get all the recipient addresses for the message.
      abstract Address[] Message.getFrom()
      Returns the "From" attribute.
      Address[] SendFailedException.getInvalidAddresses()
      Return the addresses to which this message could not be sent.
      abstract Address[] Message.getRecipients(Message.RecipientType type)
      Get all the recipient addresses of the given type.
      Address[] Message.getReplyTo()
      Get the addresses to which replies should be directed.
      Address[] SendFailedException.getValidSentAddresses()
      Return the addresses to which this message was sent succesfully.
      Address[] SendFailedException.getValidUnsentAddresses()
      Return the addresses that are valid but to which this message was not sent.
      Methods in javax.mail with parameters of type Address
      Modifier and Type Method and Description
      abstract void Message.addFrom(Address[] addresses)
      Add these addresses to the existing "From" attribute
      void Message.addRecipient(Message.RecipientType type, Address address)
      Add this recipient address to the existing ones of the given type.
      abstract void Message.addRecipients(Message.RecipientType type, Address[] addresses)
      Add these recipient addresses to the existing ones of the given type.
      Transport Session.getTransport(Address address)
      Get a Transport object that can transport a Message of the specified address type.
      protected void Transport.notifyTransportListeners(int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Notify all TransportListeners.
      protected void Transport.notifyTransportListeners(int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Notify all TransportListeners.
      protected void Transport.notifyTransportListeners(int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Notify all TransportListeners.
      static void Transport.send(Message msg, Address[] addresses)
      Send the message to the specified addresses, ignoring any recipients specified in the message itself.
      static void Transport.send(Message msg, Address[] addresses, String user, String password)
      Send the message to the specified addresses, ignoring any recipients specified in the message itself.
      abstract void Transport.sendMessage(Message msg, Address[] addresses)
      Send the Message to the specified list of addresses.
      abstract void Message.setFrom(Address address)
      Set the "From" attribute in this Message.
      void Message.setRecipient(Message.RecipientType type, Address address)
      Set the recipient address.
      abstract void Message.setRecipients(Message.RecipientType type, Address[] addresses)
      Set the recipient addresses.
      void Message.setReplyTo(Address[] addresses)
      Set the addresses to which replies should be directed.
      Constructors in javax.mail with parameters of type Address
      Constructor and Description
      SendFailedException(String msg, Exception ex, Address[] validSent, Address[] validUnsent, Address[] invalid)
      Constructs a SendFailedException with the specified string and the specified address objects.
      SendFailedException(String msg, Exception ex, Address[] validSent, Address[] validUnsent, Address[] invalid)
      Constructs a SendFailedException with the specified string and the specified address objects.
      SendFailedException(String msg, Exception ex, Address[] validSent, Address[] validUnsent, Address[] invalid)
      Constructs a SendFailedException with the specified string and the specified address objects.

    • Uses of Address in javax.mail.event

      Fields in javax.mail.event declared as Address
      Modifier and Type | Field and Description
      protected Address[] | TransportEvent.invalid
      protected Address[] | TransportEvent.validSent
      protected Address[] | TransportEvent.validUnsent
      Methods in javax.mail.event that return Address
      Modifier and Type Method and Description
      Address[] TransportEvent.getInvalidAddresses()
      Return the addresses to which this message could not be sent.
      Address[] TransportEvent.getValidSentAddresses()
      Return the addresses to which this message was sent succesfully.
      Address[] TransportEvent.getValidUnsentAddresses()
      Return the addresses that are valid but to which this message was not sent.
      Constructors in javax.mail.event with parameters of type Address
      Constructor and Description
      TransportEvent(Transport transport, int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Constructor.
      TransportEvent(Transport transport, int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Constructor.
      TransportEvent(Transport transport, int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Constructor.

    • Uses of Address in javax.mail.internet

      Subclasses of Address in javax.mail.internet
      Modifier and Type Class and Description
      class  InternetAddress
      This class represents an Internet email address using the syntax of RFC822.
      class  NewsAddress
      This class models an RFC1036 newsgroup address.
      Methods in javax.mail.internet that return Address
      Modifier and Type Method and Description
      Address[] MimeMessage.getAllRecipients()
      Get all the recipient addresses for the message.
      Address[] MimeMessage.getFrom()
      Returns the value of the RFC 822 "From" header fields.
      Address[] MimeMessage.getRecipients(Message.RecipientType type)
      Returns the recepients specified by the type.
      Address[] MimeMessage.getReplyTo()
      Return the value of the RFC 822 "Reply-To" header field.
      Address MimeMessage.getSender()
      Returns the value of the RFC 822 "Sender" header field.
      Methods in javax.mail.internet with parameters of type Address
      Modifier and Type Method and Description
      void MimeMessage.addFrom(Address[] addresses)
      Add the specified addresses to the existing "From" field.
      void MimeMessage.addRecipients(Message.RecipientType type, Address[] addresses)
      Add the given addresses to the specified recipient type.
      void MimeMessage.setFrom(Address address)
      Set the RFC 822 "From" header field.
      void MimeMessage.setRecipients(Message.RecipientType type, Address[] addresses)
      Set the specified recipient type to the given addresses.
      void MimeMessage.setReplyTo(Address[] addresses)
      Set the RFC 822 "Reply-To" header field.
      void MimeMessage.setSender(Address address)
      Set the RFC 822 "Sender" header field.
      static String NewsAddress.toString(Address[] addresses)
      Convert the given array of NewsAddress objects into a comma separated sequence of address strings.
      static String InternetAddress.toString(Address[] addresses)
      Convert the given array of InternetAddress objects into a comma separated sequence of address strings.
      static String InternetAddress.toString(Address[] addresses, int used)
      Convert the given array of InternetAddress objects into a comma separated sequence of address strings.

    • Uses of Address in javax.mail.search

      Fields in javax.mail.search declared as Address
      Modifier and Type Field and Description
      protected Address AddressTerm.address
      The address.
      Methods in javax.mail.search that return Address
      Modifier and Type Method and Description
      Address AddressTerm.getAddress()
      Return the address to match with.
      Methods in javax.mail.search with parameters of type Address
      Modifier and Type Method and Description
      protected boolean AddressTerm.match(Address a)
      Match against the argument Address.
      protected boolean AddressStringTerm.match(Address a)
      Check whether the address pattern specified in the constructor is a substring of the string representation of the given Address object.
      Constructors in javax.mail.search with parameters of type Address
      Constructor and Description
      AddressTerm(Address address)
      FromTerm(Address address)
      Constructor
      RecipientTerm(Message.RecipientType type, Address address)
      Constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.AuthenticationFailedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.AuthenticationFailedException

No usage of javax.mail.AuthenticationFailedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Authenticator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Authenticator

  • Packages that use Authenticator
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of Authenticator in javax.mail

      Methods in javax.mail with parameters of type Authenticator
      Modifier and Type Method and Description
      static Session Session.getDefaultInstance(Properties props, Authenticator authenticator)
      Get the default Session object.
      static Session Session.getInstance(Properties props, Authenticator authenticator)
      Get a new Session object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.BodyPart (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.BodyPart

  • Packages that use BodyPart
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of BodyPart in javax.mail

      Methods in javax.mail that return BodyPart
      Modifier and Type Method and Description
      BodyPart MultipartDataSource.getBodyPart(int index)
      Get the specified Part.
      BodyPart Multipart.getBodyPart(int index)
      Get the specified Part.
      Methods in javax.mail with parameters of type BodyPart
      Modifier and Type Method and Description
      void Multipart.addBodyPart(BodyPart part)
      Adds a Part to the multipart.
      void Multipart.addBodyPart(BodyPart part, int index)
      Adds a BodyPart at position index.
      boolean Multipart.removeBodyPart(BodyPart part)
      Remove the specified part from the multipart message.

    • Uses of BodyPart in javax.mail.internet

      Subclasses of BodyPart in javax.mail.internet
      Modifier and Type Class and Description
      class  MimeBodyPart
      This class represents a MIME body part.
      class  PreencodedMimeBodyPart
      A MimeBodyPart that handles data that has already been encoded.
      Methods in javax.mail.internet that return BodyPart
      Modifier and Type Method and Description
      BodyPart MimeMultipart.getBodyPart(int index)
      Get the specified BodyPart.
      BodyPart MimeMultipart.getBodyPart(String CID)
      Get the MimeBodyPart referred to by the given ContentID (CID).
      Methods in javax.mail.internet with parameters of type BodyPart
      Modifier and Type Method and Description
      void MimeMultipart.addBodyPart(BodyPart part)
      Adds a Part to the multipart.
      void MimeMultipart.addBodyPart(BodyPart part, int index)
      Adds a BodyPart at position index.
      boolean MimeMultipart.removeBodyPart(BodyPart part)
      Remove the specified part from the multipart message.
      Constructors in javax.mail.internet with parameters of type BodyPart
      Constructor and Description
      MimeMultipart(BodyPart... parts)
      Construct a MimeMultipart object of the default "mixed" subtype, and with the given body parts.
      MimeMultipart(String subtype, BodyPart... parts)
      Construct a MimeMultipart object of the given subtype and with the given body parts.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.FetchProfile (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.FetchProfile

  • Packages that use FetchProfile
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of FetchProfile in javax.mail

      Methods in javax.mail with parameters of type FetchProfile
      Modifier and Type Method and Description
      void Folder.fetch(Message[] msgs, FetchProfile fp)
      Prefetch the items specified in the FetchProfile for the given Messages.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.FetchProfile.Item (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.FetchProfile.Item

  • Packages that use FetchProfile.Item
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of FetchProfile.Item in javax.mail

      Subclasses of FetchProfile.Item in javax.mail
      Modifier and Type Class and Description
      static class  UIDFolder.FetchProfileItem
      A fetch profile item for fetching UIDs.
      Fields in javax.mail declared as FetchProfile.Item
      Modifier and Type Field and Description
      static FetchProfile.Item FetchProfile.Item.CONTENT_INFO
      This item is for fetching information about the content of the message.
      static FetchProfile.Item FetchProfile.Item.ENVELOPE
      This is the Envelope item.
      static FetchProfile.Item FetchProfile.Item.FLAGS
      This is the Flags item.
      static FetchProfile.Item FetchProfile.Item.SIZE
      SIZE is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder.
      Methods in javax.mail that return FetchProfile.Item
      Modifier and Type Method and Description
      FetchProfile.Item[] FetchProfile.getItems()
      Get the items set in this profile.
      Methods in javax.mail with parameters of type FetchProfile.Item
      Modifier and Type Method and Description
      void FetchProfile.add(FetchProfile.Item item)
      Add the given special item as one of the attributes to be prefetched.
      boolean FetchProfile.contains(FetchProfile.Item item)
      Returns true if the fetch profile contains given special item.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Flags (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Flags

  • Packages that use Flags
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.internet
    Classes specific to Internet mail systems.
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of Flags in javax.mail

      Methods in javax.mail that return Flags
      Modifier and Type Method and Description
      abstract Flags Message.getFlags()
      Returns a Flags object containing the flags for this message.
      abstract Flags Folder.getPermanentFlags()
      Get the permanent flags supported by this Folder.
      Methods in javax.mail with parameters of type Flags
      Modifier and Type Method and Description
      void Flags.add(Flags f)
      Add all the flags in the given Flags object to this Flags object.
      boolean Flags.contains(Flags f)
      Check whether all the flags in the specified Flags object are present in this Flags object.
      void Flags.remove(Flags f)
      Remove all flags in the given Flags object from this Flags object.
      abstract void Message.setFlags(Flags flag, boolean set)
      Set the specified flags on this message to the specified value.
      void Folder.setFlags(int[] msgnums, Flags flag, boolean value)
      Set the specified flags on the messages whose message numbers are in the array.
      void Folder.setFlags(int start, int end, Flags flag, boolean value)
      Set the specified flags on the messages numbered from start through end, both start and end inclusive.
      void Folder.setFlags(Message[] msgs, Flags flag, boolean value)
      Set the specified flags on the messages specified in the array.
      Constructors in javax.mail with parameters of type Flags
      Constructor and Description
      Flags(Flags flags)
      Construct a Flags object initialized with the given flags.

    • Uses of Flags in javax.mail.internet

      Fields in javax.mail.internet declared as Flags
      Modifier and Type Field and Description
      protected Flags MimeMessage.flags
      The Flags for this message.
      Methods in javax.mail.internet that return Flags
      Modifier and Type Method and Description
      Flags MimeMessage.getFlags()
      Return a Flags object containing the flags for this message.
      Methods in javax.mail.internet with parameters of type Flags
      Modifier and Type Method and Description
      void MimeMessage.setFlags(Flags flag, boolean set)
      Set the flags for this message.

    • Uses of Flags in javax.mail.search

      Methods in javax.mail.search that return Flags
      Modifier and Type Method and Description
      Flags FlagTerm.getFlags()
      Return the Flags to test.
      Constructors in javax.mail.search with parameters of type Flags
      Constructor and Description
      FlagTerm(Flags flags, boolean set)
      Constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Flags.Flag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Flags.Flag

  • Packages that use Flags.Flag
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of Flags.Flag in javax.mail

      Fields in javax.mail declared as Flags.Flag
      Modifier and Type Field and Description
      static Flags.Flag Flags.Flag.ANSWERED
      This message has been answered.
      static Flags.Flag Flags.Flag.DELETED
      This message is marked deleted.
      static Flags.Flag Flags.Flag.DRAFT
      This message is a draft.
      static Flags.Flag Flags.Flag.FLAGGED
      This message is flagged.
      static Flags.Flag Flags.Flag.RECENT
      This message is recent.
      static Flags.Flag Flags.Flag.SEEN
      This message is seen.
      static Flags.Flag Flags.Flag.USER
      A special flag that indicates that this folder supports user defined flags.
      Methods in javax.mail that return Flags.Flag
      Modifier and Type Method and Description
      Flags.Flag[] Flags.getSystemFlags()
      Return all the system flags in this Flags object.
      Methods in javax.mail with parameters of type Flags.Flag
      Modifier and Type Method and Description
      void Flags.add(Flags.Flag flag)
      Add the specified system flag to this Flags object.
      boolean Flags.contains(Flags.Flag flag)
      Check whether the specified system flag is present in this Flags object.
      boolean Message.isSet(Flags.Flag flag)
      Check whether the flag specified in the flag argument is set in this message.
      void Flags.remove(Flags.Flag flag)
      Remove the specified system flag from this Flags object.
      void Message.setFlag(Flags.Flag flag, boolean set)
      Set the specified flag on this message to the specified value.
      Constructors in javax.mail with parameters of type Flags.Flag
      Constructor and Description
      Flags(Flags.Flag flag)
      Construct a Flags object initialized with the given system flag.

    • Uses of Flags.Flag in javax.mail.internet

      Methods in javax.mail.internet with parameters of type Flags.Flag
      Modifier and Type Method and Description
      boolean MimeMessage.isSet(Flags.Flag flag)
      Check whether the flag specified in the flag argument is set in this message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Folder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Folder

  • Packages that use Folder
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of Folder in javax.mail

      Fields in javax.mail declared as Folder
      Modifier and Type Field and Description
      protected Folder Message.folder
      The containing folder, if this message is obtained from a folder
      Methods in javax.mail that return Folder
      Modifier and Type Method and Description
      abstract Folder Store.getDefaultFolder()
      Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.
      Folder ReadOnlyFolderException.getFolder()
      Returns the dead Folder object.
      Folder Message.getFolder()
      Get the folder from which this message was obtained.
      Folder FolderNotFoundException.getFolder()
      Returns the offending Folder object.
      Folder FolderClosedException.getFolder()
      Returns the dead Folder object
      abstract Folder Store.getFolder(String name)
      Return the Folder object corresponding to the given name.
      abstract Folder Folder.getFolder(String name)
      Return the Folder object corresponding to the given name.
      abstract Folder Store.getFolder(URLName url)
      Return a closed Folder object, corresponding to the given URLName.
      Folder Session.getFolder(URLName url)
      Get a closed Folder object for the given URLName.
      abstract Folder Folder.getParent()
      Returns the parent folder of this folder.
      Folder[] Store.getPersonalNamespaces()
      Return a set of folders representing the personal namespaces for the current user.
      Folder[] Store.getSharedNamespaces()
      Return a set of folders representing the shared namespaces.
      Folder[] Store.getUserNamespaces(String user)
      Return a set of folders representing the namespaces for user.
      Folder[] Folder.list()
      Convenience method that returns the list of folders under this Folder.
      abstract Folder[] Folder.list(String pattern)
      Returns a list of Folders belonging to this Folder's namespace that match the specified pattern.
      Folder[] Folder.listSubscribed()
      Convenience method that returns the list of subscribed folders under this Folder.
      Folder[] Folder.listSubscribed(String pattern)
      Returns a list of subscribed Folders belonging to this Folder's namespace that match the specified pattern.
      Methods in javax.mail with parameters of type Folder
      Modifier and Type Method and Description
      void Folder.copyMessages(Message[] msgs, Folder folder)
      Copy the specified Messages from this Folder into another Folder.
      protected void Store.notifyFolderListeners(int type, Folder folder)
      Notify all FolderListeners.
      protected void Folder.notifyFolderRenamedListeners(Folder folder)
      Notify all FolderListeners registered on this Folder and this folder's Store about the renaming of this folder.
      protected void Store.notifyFolderRenamedListeners(Folder oldF, Folder newF)
      Notify all FolderListeners about the renaming of a folder.
      abstract boolean Folder.renameTo(Folder f)
      Rename this Folder.
      Constructors in javax.mail with parameters of type Folder
      Constructor and Description
      FolderClosedException(Folder folder)
      Constructs a FolderClosedException.
      FolderClosedException(Folder folder, String message)
      Constructs a FolderClosedException with the specified detail message.
      FolderClosedException(Folder folder, String message, Exception e)
      Constructs a FolderClosedException with the specified detail message and embedded exception.
      FolderNotFoundException(Folder folder)
      Constructs a FolderNotFoundException.
      FolderNotFoundException(Folder folder, String s)
      Constructs a FolderNotFoundException with the specified detail message.
      FolderNotFoundException(Folder folder, String s, Exception e)
      Constructs a FolderNotFoundException with the specified detail message and embedded exception.
      FolderNotFoundException(String s, Folder folder)
      Constructs a FolderNotFoundException with the specified detail message and the specified folder.
      Message(Folder folder, int msgnum)
      Constructor that takes a Folder and a message number.
      ReadOnlyFolderException(Folder folder)
      Constructs a ReadOnlyFolderException with the specified folder and no detail message.
      ReadOnlyFolderException(Folder folder, String message)
      Constructs a ReadOnlyFolderException with the specified detail message.
      ReadOnlyFolderException(Folder folder, String message, Exception e)
      Constructs a ReadOnlyFolderException with the specified detail message and embedded exception.

    • Uses of Folder in javax.mail.event

      Fields in javax.mail.event declared as Folder
      Modifier and Type Field and Description
      protected Folder FolderEvent.folder
      The folder the event occurred on.
      protected Folder FolderEvent.newFolder
      The folder that represents the new name, in case of a RENAMED event.
      Methods in javax.mail.event that return Folder
      Modifier and Type Method and Description
      Folder FolderEvent.getFolder()
      Return the affected folder.
      Folder FolderEvent.getNewFolder()
      If this event indicates that a folder is renamed, (i.e, the event type is RENAMED), then this method returns the Folder object representing the new name.
      Constructors in javax.mail.event with parameters of type Folder
      Constructor and Description
      FolderEvent(Object source, Folder oldFolder, Folder newFolder, int type)
      Constructor.
      FolderEvent(Object source, Folder folder, int type)
      Constructor.
      MessageCountEvent(Folder folder, int type, boolean removed, Message[] msgs)
      Constructor.

    • Uses of Folder in javax.mail.internet

      Constructors in javax.mail.internet with parameters of type Folder
      Constructor and Description
      MimeMessage(Folder folder, InputStream is, int msgnum)
      Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.
      MimeMessage(Folder folder, int msgnum)
      Constructs an empty MimeMessage object with the given Folder and message number.
      MimeMessage(Folder folder, InternetHeaders headers, byte[] content, int msgnum)
      Constructs a MimeMessage from the given InternetHeaders object and content.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.FolderClosedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.FolderClosedException

No usage of javax.mail.FolderClosedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.FolderNotFoundException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.FolderNotFoundException

No usage of javax.mail.FolderNotFoundException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Header (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Header

  • Packages that use Header
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of Header in javax.mail.internet

      Subclasses of Header in javax.mail.internet
      Modifier and Type Class and Description
      protected static class  InternetHeaders.InternetHeader
      An individual internet header.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.IllegalWriteException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.IllegalWriteException

No usage of javax.mail.IllegalWriteException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.MailSessionDefinition (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.MailSessionDefinition

No usage of javax.mail.MailSessionDefinition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.MailSessionDefinitions (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.MailSessionDefinitions

No usage of javax.mail.MailSessionDefinitions
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Message (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Message

  • Packages that use Message
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.
    javax.mail.internet
    Classes specific to Internet mail systems.
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of Message in javax.mail

      Methods in javax.mail that return Message
      Modifier and Type Method and Description
      abstract Message[] Folder.expunge()
      Expunge (permanently remove) messages marked DELETED.
      Message MessageContext.getMessage()
      Return the Message that contains the content.
      abstract Message Folder.getMessage(int msgnum)
      Get the Message object corresponding to the given message number.
      Message UIDFolder.getMessageByUID(long uid)
      Get the Message corresponding to the given UID.
      Message[] Folder.getMessages()
      Get all Message objects from this Folder.
      Message[] Folder.getMessages(int[] msgnums)
      Get the Message objects for message numbers specified in the array.
      Message[] Folder.getMessages(int start, int end)
      Get the Message objects for message numbers ranging from start through end, both start and end inclusive.
      Message[] UIDFolder.getMessagesByUID(long[] uids)
      Get the Messages specified by the given array of UIDs.
      Message[] UIDFolder.getMessagesByUID(long start, long end)
      Get the Messages specified by the given range.
      abstract Message Message.reply(boolean replyToAll)
      Get a new Message suitable for a reply to this message.
      Message[] Folder.search(SearchTerm term)
      Search this Folder for messages matching the specified search criterion.
      Message[] Folder.search(SearchTerm term, Message[] msgs)
      Search the given array of messages for those that match the specified search criterion.
      Methods in javax.mail with parameters of type Message
      Modifier and Type Method and Description
      abstract void Folder.appendMessages(Message[] msgs)
      Append given Messages to this folder.
      void Folder.copyMessages(Message[] msgs, Folder folder)
      Copy the specified Messages from this Folder into another Folder.
      void Folder.fetch(Message[] msgs, FetchProfile fp)
      Prefetch the items specified in the FetchProfile for the given Messages.
      long UIDFolder.getUID(Message message)
      Get the UID for the specified message.
      protected void Folder.notifyMessageAddedListeners(Message[] msgs)
      Notify all MessageCountListeners about the addition of messages into this folder.
      protected void Folder.notifyMessageChangedListeners(int type, Message msg)
      Notify all MessageChangedListeners.
      protected void Folder.notifyMessageRemovedListeners(boolean removed, Message[] msgs)
      Notify all MessageCountListeners about the removal of messages from this Folder.
      protected void Transport.notifyTransportListeners(int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Notify all TransportListeners.
      Message[] Folder.search(SearchTerm term, Message[] msgs)
      Search the given array of messages for those that match the specified search criterion.
      static void Transport.send(Message msg)
      Send a message.
      static void Transport.send(Message msg, Address[] addresses)
      Send the message to the specified addresses, ignoring any recipients specified in the message itself.
      static void Transport.send(Message msg, Address[] addresses, String user, String password)
      Send the message to the specified addresses, ignoring any recipients specified in the message itself.
      static void Transport.send(Message msg, String user, String password)
      Send a message.
      abstract void Transport.sendMessage(Message msg, Address[] addresses)
      Send the Message to the specified list of addresses.
      void Folder.setFlags(Message[] msgs, Flags flag, boolean value)
      Set the specified flags on the messages specified in the array.

    • Uses of Message in javax.mail.event

      Fields in javax.mail.event declared as Message
      Modifier and Type | Field and Description
      protected Message | TransportEvent.msg
      protected Message MessageChangedEvent.msg
      The message that changed.
      protected Message[] MessageCountEvent.msgs
      The messages.
      Methods in javax.mail.event that return Message
      Modifier and Type Method and Description
      Message TransportEvent.getMessage()
      Get the Message object associated with this Transport Event.
      Message MessageChangedEvent.getMessage()
      Return the changed Message.
      Message[] MessageCountEvent.getMessages()
      Return the array of messages added or removed.
      Constructors in javax.mail.event with parameters of type Message
      Constructor and Description
      MessageChangedEvent(Object source, int type, Message msg)
      Constructor.
      MessageCountEvent(Folder folder, int type, boolean removed, Message[] msgs)
      Constructor.
      TransportEvent(Transport transport, int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Constructor.

    • Uses of Message in javax.mail.internet

      Subclasses of Message in javax.mail.internet
      Modifier and Type Class and Description
      class  MimeMessage
      This class represents a MIME style email message.
      Methods in javax.mail.internet that return Message
      Modifier and Type Method and Description
      Message MimeMessage.reply(boolean replyToAll)
      Get a new Message suitable for a reply to this message.
      Message MimeMessage.reply(boolean replyToAll, boolean setAnswered)
      Get a new Message suitable for a reply to this message.

    • Uses of Message in javax.mail.search

      Methods in javax.mail.search with parameters of type Message
      Modifier and Type | Method and Description
      boolean SubjectTerm.match(Message msg)
      The match method.
      boolean SizeTerm.match(Message msg)
      The match method.
      boolean SentDateTerm.match(Message msg)
      The match method.
      abstract boolean SearchTerm.match(Message msg)
      This method applies a specific match criterion to the given message and returns the result.
      boolean RecipientTerm.match(Message msg)
      The match method.
      boolean RecipientStringTerm.match(Message msg)
      Check whether the address specified in the constructor is a substring of the recipient address of this Message.
      boolean ReceivedDateTerm.match(Message msg)
      The match method.
      boolean OrTerm.match(Message msg)
      The OR operation.
      boolean | NotTerm.match(Message msg)
      boolean MessageNumberTerm.match(Message msg)
      The match method.
      boolean MessageIDTerm.match(Message msg)
      The match method.
      boolean HeaderTerm.match(Message msg)
      The header match method.
      boolean FromTerm.match(Message msg)
      The address comparator.
      boolean FromStringTerm.match(Message msg)
      Check whether the address string specified in the constructor is a substring of the From address of this Message.
      boolean FlagTerm.match(Message msg)
      The comparison method.
      boolean BodyTerm.match(Message msg)
      The match method.
      boolean AndTerm.match(Message msg)
      The AND operation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Message.RecipientType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Message.RecipientType

  • Packages that use Message.RecipientType
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.internet
    Classes specific to Internet mail systems.
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of Message.RecipientType in javax.mail

      Fields in javax.mail declared as Message.RecipientType
      Modifier and Type Field and Description
      static Message.RecipientType Message.RecipientType.BCC
      The "Bcc" (blind carbon copy) recipients.
      static Message.RecipientType Message.RecipientType.CC
      The "Cc" (carbon copy) recipients.
      static Message.RecipientType Message.RecipientType.TO
      The "To" (primary) recipients.
      Methods in javax.mail with parameters of type Message.RecipientType
      Modifier and Type Method and Description
      void Message.addRecipient(Message.RecipientType type, Address address)
      Add this recipient address to the existing ones of the given type.
      abstract void Message.addRecipients(Message.RecipientType type, Address[] addresses)
      Add these recipient addresses to the existing ones of the given type.
      abstract Address[] Message.getRecipients(Message.RecipientType type)
      Get all the recipient addresses of the given type.
      void Message.setRecipient(Message.RecipientType type, Address address)
      Set the recipient address.
      abstract void Message.setRecipients(Message.RecipientType type, Address[] addresses)
      Set the recipient addresses.

    • Uses of Message.RecipientType in javax.mail.internet

      Subclasses of Message.RecipientType in javax.mail.internet
      Modifier and Type Class and Description
      static class  MimeMessage.RecipientType
      This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes.
      Methods in javax.mail.internet with parameters of type Message.RecipientType
      Modifier and Type Method and Description
      void MimeMessage.addRecipients(Message.RecipientType type, Address[] addresses)
      Add the given addresses to the specified recipient type.
      void MimeMessage.addRecipients(Message.RecipientType type, String addresses)
      Add the given addresses to the specified recipient type.
      Address[] MimeMessage.getRecipients(Message.RecipientType type)
      Returns the recepients specified by the type.
      void MimeMessage.setRecipients(Message.RecipientType type, Address[] addresses)
      Set the specified recipient type to the given addresses.
      void MimeMessage.setRecipients(Message.RecipientType type, String addresses)
      Set the specified recipient type to the given addresses.

    • Uses of Message.RecipientType in javax.mail.search

      Methods in javax.mail.search that return Message.RecipientType
      Modifier and Type Method and Description
      Message.RecipientType RecipientTerm.getRecipientType()
      Return the type of recipient to match with.
      Message.RecipientType RecipientStringTerm.getRecipientType()
      Return the type of recipient to match with.
      Constructors in javax.mail.search with parameters of type Message.RecipientType
      Constructor and Description
      RecipientStringTerm(Message.RecipientType type, String pattern)
      Constructor.
      RecipientTerm(Message.RecipientType type, Address address)
      Constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.MessageContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.MessageContext

  • Packages that use MessageContext
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of MessageContext in javax.mail

      Methods in javax.mail that return MessageContext
      Modifier and Type Method and Description
      MessageContext MessageAware.getMessageContext()
      Return the message context.

    • Uses of MessageContext in javax.mail.internet

      Methods in javax.mail.internet that return MessageContext
      Modifier and Type Method and Description
      MessageContext MimePartDataSource.getMessageContext()
      Return the MessageContext for the current part.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.MessageRemovedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.MessageRemovedException

No usage of javax.mail.MessageRemovedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.MessagingException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.MessagingException

  • Packages that use MessagingException
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.internet
    Classes specific to Internet mail systems.
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of MessagingException in javax.mail

      Subclasses of MessagingException in javax.mail
      Modifier and Type Class and Description
      class  AuthenticationFailedException
      This exception is thrown when the connect method on a Store or Transport object fails due to an authentication failure (e.g., bad user name or password).
      class  FolderClosedException
      This exception is thrown when a method is invoked on a Messaging object and the Folder that owns that object has died due to some reason.
      class  FolderNotFoundException
      This exception is thrown by Folder methods, when those methods are invoked on a non existent folder.
      class  IllegalWriteException
      The exception thrown when a write is attempted on a read-only attribute of any Messaging object.
      class  MessageRemovedException
      The exception thrown when an invalid method is invoked on an expunged Message.
      class  MethodNotSupportedException
      The exception thrown when a method is not supported by the implementation
      class  NoSuchProviderException
      This exception is thrown when Session attempts to instantiate a Provider that doesn't exist.
      class  ReadOnlyFolderException
      This exception is thrown when an attempt is made to open a folder read-write access when the folder is marked read-only.
      class  SendFailedException
      This exception is thrown when the message cannot be sent.
      class  StoreClosedException
      This exception is thrown when a method is invoked on a Messaging object and the Store that owns that object has died due to some reason.
      Methods in javax.mail that throw MessagingException
      Modifier and Type Method and Description
      void Multipart.addBodyPart(BodyPart part)
      Adds a Part to the multipart.
      void Multipart.addBodyPart(BodyPart part, int index)
      Adds a BodyPart at position index.
      abstract void Message.addFrom(Address[] addresses)
      Add these addresses to the existing "From" attribute
      void Part.addHeader(String header_name, String header_value)
      Add this value to the existing values for this header_name.
      void Message.addRecipient(Message.RecipientType type, Address address)
      Add this recipient address to the existing ones of the given type.
      abstract void Message.addRecipients(Message.RecipientType type, Address[] addresses)
      Add these recipient addresses to the existing ones of the given type.
      abstract void Folder.appendMessages(Message[] msgs)
      Append given Messages to this folder.
      void Service.close()
      Close this service and terminate its connection.
      abstract void Folder.close(boolean expunge)
      Close this Folder.
      void Service.connect()
      A generic connect method that takes no parameters.
      void Service.connect(String host, int port, String user, String password)
      Similar to connect(host, user, password) except a specific port can be specified.
      void Service.connect(String user, String password)
      Connect to the current host using the specified username and password.
      void Service.connect(String host, String user, String password)
      Connect to the specified address.
      void Folder.copyMessages(Message[] msgs, Folder folder)
      Copy the specified Messages from this Folder into another Folder.
      abstract boolean Folder.create(int type)
      Create this folder on the Store.
      abstract boolean Folder.delete(boolean recurse)
      Delete this Folder.
      abstract boolean Folder.exists()
      Tests if this folder physically exists on the Store.
      abstract Message[] Folder.expunge()
      Expunge (permanently remove) messages marked DELETED.
      void Folder.fetch(Message[] msgs, FetchProfile fp)
      Prefetch the items specified in the FetchProfile for the given Messages.
      Enumeration Part.getAllHeaders()
      Return all the headers from this part as an Enumeration of Header objects.
      Address[] Message.getAllRecipients()
      Get all the recipient addresses for the message.
      BodyPart MultipartDataSource.getBodyPart(int index)
      Get the specified Part.
      BodyPart Multipart.getBodyPart(int index)
      Get the specified Part.
      Object Part.getContent()
      Return the content as a Java object.
      String Part.getContentType()
      Returns the Content-Type of the content of this part.
      int Multipart.getCount()
      Return the number of enclosed BodyPart objects.
      DataHandler Part.getDataHandler()
      Return a DataHandler for the content within this part.
      abstract Folder Store.getDefaultFolder()
      Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.
      int Folder.getDeletedMessageCount()
      Get the number of deleted messages in this Folder.
      String Part.getDescription()
      Return a description String for this part.
      String Part.getDisposition()
      Return the disposition of this part.
      String Part.getFileName()
      Get the filename associated with this part, if possible.
      abstract Flags Message.getFlags()
      Returns a Flags object containing the flags for this message.
      abstract Folder Store.getFolder(String name)
      Return the Folder object corresponding to the given name.
      abstract Folder Folder.getFolder(String name)
      Return the Folder object corresponding to the given name.
      abstract Folder Store.getFolder(URLName url)
      Return a closed Folder object, corresponding to the given URLName.
      Folder Session.getFolder(URLName url)
      Get a closed Folder object for the given URLName.
      abstract Address[] Message.getFrom()
      Returns the "From" attribute.
      String[] Part.getHeader(String header_name)
      Get all the headers for this header name.
      InputStream Part.getInputStream()
      Return an input stream for this part's "content".
      int Part.getLineCount()
      Return the number of lines in the content of this part.
      Enumeration Part.getMatchingHeaders(String[] header_names)
      Return matching headers from this part as an Enumeration of Header objects.
      abstract Message Folder.getMessage(int msgnum)
      Get the Message object corresponding to the given message number.
      Message UIDFolder.getMessageByUID(long uid)
      Get the Message corresponding to the given UID.
      abstract int Folder.getMessageCount()
      Get total number of messages in this Folder.
      Message[] Folder.getMessages()
      Get all Message objects from this Folder.
      Message[] Folder.getMessages(int[] msgnums)
      Get the Message objects for message numbers specified in the array.
      Message[] Folder.getMessages(int start, int end)
      Get the Message objects for message numbers ranging from start through end, both start and end inclusive.
      Message[] UIDFolder.getMessagesByUID(long[] uids)
      Get the Messages specified by the given array of UIDs.
      Message[] UIDFolder.getMessagesByUID(long start, long end)
      Get the Messages specified by the given range.
      int Folder.getNewMessageCount()
      Get the number of new messages in this Folder.
      Enumeration Part.getNonMatchingHeaders(String[] header_names)
      Return non-matching headers from this envelope as an Enumeration of Header objects.
      abstract Folder Folder.getParent()
      Returns the parent folder of this folder.
      Folder[] Store.getPersonalNamespaces()
      Return a set of folders representing the personal namespaces for the current user.
      Quota[] QuotaAwareStore.getQuota(String folder)
      Get the quotas for the named folder.
      abstract Date Message.getReceivedDate()
      Get the date this message was received.
      abstract Address[] Message.getRecipients(Message.RecipientType type)
      Get all the recipient addresses of the given type.
      Address[] Message.getReplyTo()
      Get the addresses to which replies should be directed.
      abstract Date Message.getSentDate()
      Get the date this message was sent.
      abstract char Folder.getSeparator()
      Return the delimiter character that separates this Folder's pathname from the names of immediate subfolders.
      Folder[] Store.getSharedNamespaces()
      Return a set of folders representing the shared namespaces.
      int Part.getSize()
      Return the size of the content of this part in bytes.
      abstract String Message.getSubject()
      Get the subject of this message.
      abstract int Folder.getType()
      Returns the type of this Folder, that is, whether this folder can hold messages or subfolders or both.
      long UIDFolder.getUID(Message message)
      Get the UID for the specified message.
      long UIDFolder.getUIDValidity()
      Returns the UIDValidity value associated with this folder.
      int Folder.getUnreadMessageCount()
      Get the total number of unread messages in this Folder.
      URLName Folder.getURLName()
      Return a URLName representing this folder.
      Folder[] Store.getUserNamespaces(String user)
      Return a set of folders representing the namespaces for user.
      abstract boolean Folder.hasNewMessages()
      Returns true if this Folder has new messages since the last time this indication was reset.
      boolean Part.isMimeType(String mimeType)
      Is this Part of the specified MIME type? This method compares only the primaryType and subType.
      boolean Message.isSet(Flags.Flag flag)
      Check whether the flag specified in the flag argument is set in this message.
      Folder[] Folder.list()
      Convenience method that returns the list of folders under this Folder.
      abstract Folder[] Folder.list(String pattern)
      Returns a list of Folders belonging to this Folder's namespace that match the specified pattern.
      Folder[] Folder.listSubscribed()
      Convenience method that returns the list of subscribed folders under this Folder.
      Folder[] Folder.listSubscribed(String pattern)
      Returns a list of subscribed Folders belonging to this Folder's namespace that match the specified pattern.
      boolean Message.match(SearchTerm term)
      Apply the specified Search criterion to this message.
      abstract void Folder.open(int mode)
      Open this Folder.
      protected boolean Service.protocolConnect(String host, int port, String user, String password)
      The service implementation should override this method to perform the actual protocol-specific connection attempt.
      boolean Multipart.removeBodyPart(BodyPart part)
      Remove the specified part from the multipart message.
      void Multipart.removeBodyPart(int index)
      Remove the part at specified location (starting from 0).
      void Part.removeHeader(String header_name)
      Remove all headers with this name.
      abstract boolean Folder.renameTo(Folder f)
      Rename this Folder.
      abstract Message Message.reply(boolean replyToAll)
      Get a new Message suitable for a reply to this message.
      abstract void Message.saveChanges()
      Save any changes made to this message into the message-store when the containing folder is closed, if the message is contained in a folder.
      Message[] Folder.search(SearchTerm term)
      Search this Folder for messages matching the specified search criterion.
      Message[] Folder.search(SearchTerm term, Message[] msgs)
      Search the given array of messages for those that match the specified search criterion.
      static void Transport.send(Message msg)
      Send a message.
      static void Transport.send(Message msg, Address[] addresses)
      Send the message to the specified addresses, ignoring any recipients specified in the message itself.
      static void Transport.send(Message msg, Address[] addresses, String user, String password)
      Send the message to the specified addresses, ignoring any recipients specified in the message itself.
      static void Transport.send(Message msg, String user, String password)
      Send a message.
      abstract void Transport.sendMessage(Message msg, Address[] addresses)
      Send the Message to the specified list of addresses.
      void Part.setContent(Multipart mp)
      This method sets the given Multipart object as this message's content.
      void Part.setContent(Object obj, String type)
      A convenience method for setting this part's content.
      void Part.setDataHandler(DataHandler dh)
      This method provides the mechanism to set this part's content.
      void Part.setDescription(String description)
      Set a description String for this part.
      void Part.setDisposition(String disposition)
      Set the disposition of this part.
      void Part.setFileName(String filename)
      Set the filename associated with this part, if possible.
      void Message.setFlag(Flags.Flag flag, boolean set)
      Set the specified flag on this message to the specified value.
      abstract void Message.setFlags(Flags flag, boolean set)
      Set the specified flags on this message to the specified value.
      void Folder.setFlags(int[] msgnums, Flags flag, boolean value)
      Set the specified flags on the messages whose message numbers are in the array.
      void Folder.setFlags(int start, int end, Flags flag, boolean value)
      Set the specified flags on the messages numbered from start through end, both start and end inclusive.
      void Folder.setFlags(Message[] msgs, Flags flag, boolean value)
      Set the specified flags on the messages specified in the array.
      abstract void Message.setFrom()
      Set the "From" attribute in this Message.
      abstract void Message.setFrom(Address address)
      Set the "From" attribute in this Message.
      void Part.setHeader(String header_name, String header_value)
      Set the value for this header_name.
      protected void Multipart.setMultipartDataSource(MultipartDataSource mp)
      Setup this Multipart object from the given MultipartDataSource.
      void QuotaAwareStore.setQuota(Quota quota)
      Set the quotas for the quota root specified in the quota argument.
      void Message.setRecipient(Message.RecipientType type, Address address)
      Set the recipient address.
      abstract void Message.setRecipients(Message.RecipientType type, Address[] addresses)
      Set the recipient addresses.
      void Message.setReplyTo(Address[] addresses)
      Set the addresses to which replies should be directed.
      abstract void Message.setSentDate(Date date)
      Set the sent date of this message.
      abstract void Message.setSubject(String subject)
      Set the subject of this message.
      void Folder.setSubscribed(boolean subscribe)
      Subscribe or unsubscribe this Folder.
      void Part.setText(String text)
      A convenience method that sets the given String as this part's content with a MIME type of "text/plain".
      void Part.writeTo(OutputStream os)
      Output a bytestream for this Part.
      abstract void Multipart.writeTo(OutputStream os)
      Output an appropriately encoded bytestream to the given OutputStream.

    • Uses of MessagingException in javax.mail.internet

      Subclasses of MessagingException in javax.mail.internet
      Modifier and Type Class and Description
      class  AddressException
      The exception thrown when a wrongly formatted address is encountered.
      class  ParseException
      The exception thrown due to an error in parsing RFC822 or MIME headers
      Methods in javax.mail.internet that throw MessagingException
      Modifier and Type Method and Description
      void MimeMultipart.addBodyPart(BodyPart part)
      Adds a Part to the multipart.
      void MimeMultipart.addBodyPart(BodyPart part, int index)
      Adds a BodyPart at position index.
      void MimeMessage.addFrom(Address[] addresses)
      Add the specified addresses to the existing "From" field.
      void MimeMessage.addHeader(String name, String value)
      Add this value to the existing values for this header_name.
      void MimeBodyPart.addHeader(String name, String value)
      Add this value to the existing values for this header_name.
      void MimePart.addHeaderLine(String line)
      Add a raw RFC822 header-line.
      void MimeMessage.addHeaderLine(String line)
      Add a raw RFC 822 header-line.
      void MimeBodyPart.addHeaderLine(String line)
      Add a header line to this body part
      void MimeMessage.addRecipients(Message.RecipientType type, Address[] addresses)
      Add the given addresses to the specified recipient type.
      void MimeMessage.addRecipients(Message.RecipientType type, String addresses)
      Add the given addresses to the specified recipient type.
      void MimeBodyPart.attachFile(File file)
      Use the specified file to provide the data for this part.
      void MimeBodyPart.attachFile(File file, String contentType, String encoding)
      Use the specified file with the specified Content-Type and Content-Transfer-Encoding to provide the data for this part.
      void MimeBodyPart.attachFile(String file)
      Use the specified file to provide the data for this part.
      void MimeBodyPart.attachFile(String file, String contentType, String encoding)
      Use the specified file with the specified Content-Type and Content-Transfer-Encoding to provide the data for this part.
      protected InternetHeaders MimeMultipart.createInternetHeaders(InputStream is)
      Create and return an InternetHeaders object that loads the headers from the given InputStream.
      protected InternetHeaders MimeMessage.createInternetHeaders(InputStream is)
      Create and return an InternetHeaders object that loads the headers from the given InputStream.
      protected MimeBodyPart MimeMultipart.createMimeBodyPart(InputStream is)
      Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
      protected MimeBodyPart MimeMultipart.createMimeBodyPart(InternetHeaders headers, byte[] content)
      Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
      protected MimeMessage MimeMessage.createMimeMessage(Session session)
      Create and return a MimeMessage object.
      static InputStream MimeUtility.decode(InputStream is, String encoding)
      Decode the given input stream.
      static OutputStream MimeUtility.encode(OutputStream os, String encoding)
      Wrap an encoder around the given output stream.
      static OutputStream MimeUtility.encode(OutputStream os, String encoding, String filename)
      Wrap an encoder around the given output stream.
      Enumeration MimePart.getAllHeaderLines()
      Get all header lines as an Enumeration of Strings.
      Enumeration MimeMessage.getAllHeaderLines()
      Get all header lines as an Enumeration of Strings.
      Enumeration MimeBodyPart.getAllHeaderLines()
      Get all header lines as an Enumeration of Strings.
      Enumeration MimeMessage.getAllHeaders()
      Return all the headers from this Message as an enumeration of Header objects.
      Enumeration MimeBodyPart.getAllHeaders()
      Return all the headers from this Message as an Enumeration of Header objects.
      Address[] MimeMessage.getAllRecipients()
      Get all the recipient addresses for the message.
      BodyPart MimeMultipart.getBodyPart(int index)
      Get the specified BodyPart.
      BodyPart MimeMultipart.getBodyPart(String CID)
      Get the MimeBodyPart referred to by the given ContentID (CID).
      Object MimeMessage.getContent()
      Return the content as a Java object.
      Object MimeBodyPart.getContent()
      Return the content as a Java object.
      String MimePart.getContentID()
      Get the Content-ID of this part.
      String MimeMessage.getContentID()
      Returns the value of the "Content-ID" header field.
      String MimeBodyPart.getContentID()
      Returns the value of the "Content-ID" header field.
      String[] MimePart.getContentLanguage()
      Get the language tags specified in the Content-Language header of this MimePart.
      String[] MimeMessage.getContentLanguage()
      Get the languages specified in the "Content-Language" header field of this message.
      String[] MimeBodyPart.getContentLanguage()
      Get the languages specified in the Content-Language header of this MimePart.
      String MimePart.getContentMD5()
      Get the Content-MD5 digest of this part.
      String MimeMessage.getContentMD5()
      Return the value of the "Content-MD5" header field.
      String MimeBodyPart.getContentMD5()
      Return the value of the "Content-MD5" header field.
      protected InputStream MimeMessage.getContentStream()
      Produce the raw bytes of the content.
      protected InputStream MimeBodyPart.getContentStream()
      Produce the raw bytes of the content.
      String MimeMessage.getContentType()
      Returns the value of the RFC 822 "Content-Type" header field.
      String MimeBodyPart.getContentType()
      Returns the value of the RFC 822 "Content-Type" header field.
      int MimeMultipart.getCount()
      Return the number of enclosed BodyPart objects.
      DataHandler MimeMessage.getDataHandler()
      Return a DataHandler for this Message's content.
      DataHandler MimeBodyPart.getDataHandler()
      Return a DataHandler for this body part's content.
      String MimeMessage.getDescription()
      Returns the "Content-Description" header field of this Message.
      String MimeBodyPart.getDescription()
      Returns the "Content-Description" header field of this body part.
      String MimeMessage.getDisposition()
      Returns the value of the "Content-Disposition" header field.
      String MimeBodyPart.getDisposition()
      Returns the value of the "Content-Disposition" header field.
      String PreencodedMimeBodyPart.getEncoding()
      Returns the content transfer encoding specified when this object was created.
      String MimePart.getEncoding()
      Get the transfer encoding of this part.
      String MimeMessage.getEncoding()
      Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
      String MimeBodyPart.getEncoding()
      Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
      String MimeMessage.getFileName()
      Get the filename associated with this Message.
      String MimeBodyPart.getFileName()
      Get the filename associated with this body part.
      Flags MimeMessage.getFlags()
      Return a Flags object containing the flags for this message.
      Address[] MimeMessage.getFrom()
      Returns the value of the RFC 822 "From" header fields.
      String[] MimeMessage.getHeader(String name)
      Get all the headers for this header_name.
      String[] MimeBodyPart.getHeader(String name)
      Get all the headers for this header_name.
      String MimePart.getHeader(String name, String delimiter)
      Get the values of all header fields available for this header, returned as a single String, with the values separated by the delimiter.
      String MimeMessage.getHeader(String name, String delimiter)
      Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
      String MimeBodyPart.getHeader(String name, String delimiter)
      Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
      InputStream MimeMessage.getInputStream()
      Return a decoded input stream for this Message's "content".
      InputStream MimeBodyPart.getInputStream()
      Return a decoded input stream for this body part's "content".
      int MimeMessage.getLineCount()
      Return the number of lines for the content of this message.
      int MimeBodyPart.getLineCount()
      Return the number of lines for the content of this Part.
      Enumeration MimePart.getMatchingHeaderLines(String[] names)
      Get matching header lines as an Enumeration of Strings.
      Enumeration MimeMessage.getMatchingHeaderLines(String[] names)
      Get matching header lines as an Enumeration of Strings.
      Enumeration MimeBodyPart.getMatchingHeaderLines(String[] names)
      Get matching header lines as an Enumeration of Strings.
      Enumeration MimeMessage.getMatchingHeaders(String[] names)
      Return matching headers from this Message as an Enumeration of Header objects.
      Enumeration MimeBodyPart.getMatchingHeaders(String[] names)
      Return matching headers from this Message as an Enumeration of Header objects.
      String MimeMessage.getMessageID()
      Returns the value of the "Message-ID" header field.
      Enumeration MimePart.getNonMatchingHeaderLines(String[] names)
      Get non-matching header lines as an Enumeration of Strings.
      Enumeration MimeMessage.getNonMatchingHeaderLines(String[] names)
      Get non-matching header lines as an Enumeration of Strings.
      Enumeration MimeBodyPart.getNonMatchingHeaderLines(String[] names)
      Get non-matching header lines as an Enumeration of Strings.
      Enumeration MimeMessage.getNonMatchingHeaders(String[] names)
      Return non-matching headers from this Message as an Enumeration of Header objects.
      Enumeration MimeBodyPart.getNonMatchingHeaders(String[] names)
      Return non-matching headers from this Message as an Enumeration of Header objects.
      String MimeMultipart.getPreamble()
      Get the preamble text, if any, that appears before the first body part of this multipart.
      InputStream MimeMessage.getRawInputStream()
      Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
      InputStream MimeBodyPart.getRawInputStream()
      Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
      Date MimeMessage.getReceivedDate()
      Returns the Date on this message was received.
      Address[] MimeMessage.getRecipients(Message.RecipientType type)
      Returns the recepients specified by the type.
      Address[] MimeMessage.getReplyTo()
      Return the value of the RFC 822 "Reply-To" header field.
      Address MimeMessage.getSender()
      Returns the value of the RFC 822 "Sender" header field.
      Date MimeMessage.getSentDate()
      Returns the value of the RFC 822 "Date" field.
      int MimeMessage.getSize()
      Return the size of the content of this message in bytes.
      int MimeBodyPart.getSize()
      Return the size of the content of this body part in bytes.
      String MimeMessage.getSubject()
      Returns the value of the "Subject" header field.
      boolean MimeMultipart.isComplete()
      Return true if the final boundary line for this multipart was seen.
      boolean MimeMessage.isMimeType(String mimeType)
      Is this Part of the specified MIME type? This method compares only the primaryType and subType.
      boolean MimeBodyPart.isMimeType(String mimeType)
      Is this Part of the specified MIME type? This method compares only the primaryType and subType.
      boolean MimeMessage.isSet(Flags.Flag flag)
      Check whether the flag specified in the flag argument is set in this message.
      void InternetHeaders.load(InputStream is)
      Read and parse the given RFC822 message stream till the blank line separating the header from the body.
      protected void MimeMultipart.parse()
      Parse the InputStream from our DataSource, constructing the appropriate MimeBodyParts.
      protected void MimeMessage.parse(InputStream is)
      Parse the InputStream setting the headers and content fields appropriately.
      boolean MimeMultipart.removeBodyPart(BodyPart part)
      Remove the specified part from the multipart message.
      void MimeMultipart.removeBodyPart(int index)
      Remove the part at specified location (starting from 0).
      void MimeMessage.removeHeader(String name)
      Remove all headers with this name.
      void MimeBodyPart.removeHeader(String name)
      Remove all headers with this name.
      Message MimeMessage.reply(boolean replyToAll)
      Get a new Message suitable for a reply to this message.
      Message MimeMessage.reply(boolean replyToAll, boolean setAnswered)
      Get a new Message suitable for a reply to this message.
      void MimeMessage.saveChanges()
      Updates the appropriate header fields of this message to be consistent with the message's contents.
      void MimeBodyPart.saveFile(File file)
      Save the contents of this part in the specified file.
      void MimeBodyPart.saveFile(String file)
      Save the contents of this part in the specified file.
      void MimeMessage.setContent(Multipart mp)
      This method sets the Message's content to a Multipart object.
      void MimeBodyPart.setContent(Multipart mp)
      This method sets the body part's content to a Multipart object.
      void MimeMessage.setContent(Object o, String type)
      A convenience method for setting this Message's content.
      void MimeBodyPart.setContent(Object o, String type)
      A convenience method for setting this body part's content.
      void MimeMessage.setContentID(String cid)
      Set the "Content-ID" header field of this Message.
      void MimeBodyPart.setContentID(String cid)
      Set the "Content-ID" header field of this body part.
      void MimePart.setContentLanguage(String[] languages)
      Set the Content-Language header of this MimePart.
      void MimeMessage.setContentLanguage(String[] languages)
      Set the "Content-Language" header of this MimePart.
      void MimeBodyPart.setContentLanguage(String[] languages)
      Set the Content-Language header of this MimePart.
      void MimePart.setContentMD5(String md5)
      Set the Content-MD5 of this part.
      void MimeMessage.setContentMD5(String md5)
      Set the "Content-MD5" header field of this Message.
      void MimeBodyPart.setContentMD5(String md5)
      Set the "Content-MD5" header field of this body part.
      void MimeMessage.setDataHandler(DataHandler dh)
      This method provides the mechanism to set this part's content.
      void MimeBodyPart.setDataHandler(DataHandler dh)
      This method provides the mechanism to set this body part's content.
      void MimeMessage.setDescription(String description)
      Set the "Content-Description" header field for this Message.
      void MimeBodyPart.setDescription(String description)
      Set the "Content-Description" header field for this body part.
      void MimeMessage.setDescription(String description, String charset)
      Set the "Content-Description" header field for this Message.
      void MimeBodyPart.setDescription(String description, String charset)
      Set the "Content-Description" header field for this body part.
      void MimeMessage.setDisposition(String disposition)
      Set the "Content-Disposition" header field of this Message.
      void MimeBodyPart.setDisposition(String disposition)
      Set the "Content-Disposition" header field of this body part.
      void MimeMessage.setFileName(String filename)
      Set the filename associated with this part, if possible.
      void MimeBodyPart.setFileName(String filename)
      Set the filename associated with this body part, if possible.
      void MimeMessage.setFlags(Flags flag, boolean set)
      Set the flags for this message.
      void MimeMessage.setFrom()
      Set the RFC 822 "From" header field using the value of the InternetAddress.getLocalAddress method.
      void MimeMessage.setFrom(Address address)
      Set the RFC 822 "From" header field.
      void MimeMessage.setFrom(String address)
      Set the RFC 822 "From" header field.
      void MimeMessage.setHeader(String name, String value)
      Set the value for this header_name.
      void MimeBodyPart.setHeader(String name, String value)
      Set the value for this header_name.
      void MimeMultipart.setPreamble(String preamble)
      Set the preamble text to be included before the first body part.
      void MimeMessage.setRecipients(Message.RecipientType type, Address[] addresses)
      Set the specified recipient type to the given addresses.
      void MimeMessage.setRecipients(Message.RecipientType type, String addresses)
      Set the specified recipient type to the given addresses.
      void MimeMessage.setReplyTo(Address[] addresses)
      Set the RFC 822 "Reply-To" header field.
      void MimeMessage.setSender(Address address)
      Set the RFC 822 "Sender" header field.
      void MimeMessage.setSentDate(Date d)
      Set the RFC 822 "Date" header field.
      void MimeMessage.setSubject(String subject)
      Set the "Subject" header field.
      void MimeMessage.setSubject(String subject, String charset)
      Set the "Subject" header field.
      void MimeMultipart.setSubType(String subtype)
      Set the subtype.
      void MimePart.setText(String text)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
      void MimeMessage.setText(String text)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
      void MimeBodyPart.setText(String text)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
      void MimePart.setText(String text, String charset)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
      void MimeMessage.setText(String text, String charset)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
      void MimeBodyPart.setText(String text, String charset)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
      void MimePart.setText(String text, String charset, String subtype)
      Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.
      void MimeMessage.setText(String text, String charset, String subtype)
      Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.
      void MimeBodyPart.setText(String text, String charset, String subtype)
      Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.
      protected void PreencodedMimeBodyPart.updateHeaders()
      Force the Content-Transfer-Encoding header to use the encoding that was specified when this object was created.
      protected void MimeMultipart.updateHeaders()
      Update headers.
      protected void MimeMessage.updateHeaders()
      Called by the saveChanges method to actually update the MIME headers.
      protected void MimeBodyPart.updateHeaders()
      Examine the content of this body part and update the appropriate MIME headers.
      protected void MimeMessage.updateMessageID()
      Update the Message-ID header.
      void PreencodedMimeBodyPart.writeTo(OutputStream os)
      Output the body part as an RFC 822 format stream.
      void MimeMultipart.writeTo(OutputStream os)
      Iterates through all the parts and outputs each MIME part separated by a boundary.
      void MimeMessage.writeTo(OutputStream os)
      Output the message as an RFC 822 format stream.
      void MimeBodyPart.writeTo(OutputStream os)
      Output the body part as an RFC 822 format stream.
      void MimeMessage.writeTo(OutputStream os, String[] ignoreList)
      Output the message as an RFC 822 format stream, without specified headers.
      Constructors in javax.mail.internet that throw MessagingException
      Constructor and Description
      InternetHeaders(InputStream is)
      Read and parse the given RFC822 message stream till the blank line separating the header from the body.
      MimeBodyPart(InputStream is)
      Constructs a MimeBodyPart by reading and parsing the data from the specified input stream.
      MimeBodyPart(InternetHeaders headers, byte[] content)
      Constructs a MimeBodyPart using the given header and content bytes.
      MimeMessage(Folder folder, InputStream is, int msgnum)
      Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.
      MimeMessage(Folder folder, InternetHeaders headers, byte[] content, int msgnum)
      Constructs a MimeMessage from the given InternetHeaders object and content.
      MimeMessage(MimeMessage source)
      Constructs a new MimeMessage with content initialized from the source MimeMessage.
      MimeMessage(Session session, InputStream is)
      Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.
      MimeMultipart(BodyPart... parts)
      Construct a MimeMultipart object of the default "mixed" subtype, and with the given body parts.
      MimeMultipart(DataSource ds)
      Constructs a MimeMultipart object and its bodyparts from the given DataSource.
      MimeMultipart(String subtype, BodyPart... parts)
      Construct a MimeMultipart object of the given subtype and with the given body parts.

    • Uses of MessagingException in javax.mail.search

      Subclasses of MessagingException in javax.mail.search
      Modifier and Type Class and Description
      class  SearchException
      The exception thrown when a Search expression could not be handled.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.MethodNotSupportedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.MethodNotSupportedException

No usage of javax.mail.MethodNotSupportedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Multipart (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Multipart

  • Packages that use Multipart
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of Multipart in javax.mail

      Fields in javax.mail declared as Multipart
      Modifier and Type Field and Description
      protected Multipart BodyPart.parent
      The Multipart object containing this BodyPart, if known.
      Methods in javax.mail that return Multipart
      Modifier and Type Method and Description
      Multipart BodyPart.getParent()
      Return the containing Multipart object, or null if not known.
      Methods in javax.mail with parameters of type Multipart
      Modifier and Type Method and Description
      void Part.setContent(Multipart mp)
      This method sets the given Multipart object as this message's content.

    • Uses of Multipart in javax.mail.internet

      Subclasses of Multipart in javax.mail.internet
      Modifier and Type Class and Description
      class  MimeMultipart
      The MimeMultipart class is an implementation of the abstract Multipart class that uses MIME conventions for the multipart data.
      Methods in javax.mail.internet with parameters of type Multipart
      Modifier and Type Method and Description
      void MimeMessage.setContent(Multipart mp)
      This method sets the Message's content to a Multipart object.
      void MimeBodyPart.setContent(Multipart mp)
      This method sets the body part's content to a Multipart object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.NoSuchProviderException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.NoSuchProviderException

  • Packages that use NoSuchProviderException
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of NoSuchProviderException in javax.mail

      Methods in javax.mail that throw NoSuchProviderException
      Modifier and Type Method and Description
      Provider Session.getProvider(String protocol)
      Returns the default Provider for the protocol specified.
      Store Session.getStore()
      Get a Store object that implements this user's desired Store protocol.
      Store Session.getStore(Provider provider)
      Get an instance of the store specified by Provider.
      Store Session.getStore(String protocol)
      Get a Store object that implements the specified protocol.
      Store Session.getStore(URLName url)
      Get a Store object for the given URLName.
      Transport Session.getTransport()
      Get a Transport object that implements this user's desired Transport protcol.
      Transport Session.getTransport(Address address)
      Get a Transport object that can transport a Message of the specified address type.
      Transport Session.getTransport(Provider provider)
      Get an instance of the transport specified in the Provider.
      Transport Session.getTransport(String protocol)
      Get a Transport object that implements the specified protocol.
      Transport Session.getTransport(URLName url)
      Get a Transport object for the given URLName.
      void Session.setProvider(Provider provider)
      Set the passed Provider to be the default implementation for the protocol in Provider.protocol overriding any previous values.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.PasswordAuthentication (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.PasswordAuthentication

  • Packages that use PasswordAuthentication
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of PasswordAuthentication in javax.mail

      Methods in javax.mail that return PasswordAuthentication
      Modifier and Type Method and Description
      protected PasswordAuthentication Authenticator.getPasswordAuthentication()
      Called when password authentication is needed.
      PasswordAuthentication Session.getPasswordAuthentication(URLName url)
      Return any saved PasswordAuthentication for this (store or transport) URLName.
      PasswordAuthentication Session.requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String defaultUserName)
      Call back to the application to get the needed user name and password.
      Methods in javax.mail with parameters of type PasswordAuthentication
      Modifier and Type Method and Description
      void Session.setPasswordAuthentication(URLName url, PasswordAuthentication pw)
      Save a PasswordAuthentication for this (store or transport) URLName.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Provider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Provider

  • Packages that use Provider
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of Provider in javax.mail

      Methods in javax.mail that return Provider
      Modifier and Type Method and Description
      Provider Session.getProvider(String protocol)
      Returns the default Provider for the protocol specified.
      Provider[] Session.getProviders()
      This method returns an array of all the implementations installed via the javamail.[default.]providers files that can be loaded using the ClassLoader available to this application.
      Methods in javax.mail with parameters of type Provider
      Modifier and Type Method and Description
      void Session.addProvider(Provider provider)
      Add a provider to the session.
      Store Session.getStore(Provider provider)
      Get an instance of the store specified by Provider.
      Transport Session.getTransport(Provider provider)
      Get an instance of the transport specified in the Provider.
      void Session.setProvider(Provider provider)
      Set the passed Provider to be the default implementation for the protocol in Provider.protocol overriding any previous values.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Provider.Type (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Provider.Type

  • Packages that use Provider.Type
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of Provider.Type in javax.mail

      Fields in javax.mail declared as Provider.Type
      Modifier and Type | Field and Description
      static Provider.Type | Provider.Type.STORE
      static Provider.Type | Provider.Type.TRANSPORT
      Methods in javax.mail that return Provider.Type
      Modifier and Type Method and Description
      Provider.Type Provider.getType()
      Returns the type of this Provider
      Constructors in javax.mail with parameters of type Provider.Type
      Constructor and Description
      Provider(Provider.Type type, String protocol, String classname, String vendor, String version)
      Create a new provider of the specified type for the specified protocol.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Quota (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Quota

  • Packages that use Quota
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of Quota in javax.mail

      Methods in javax.mail that return Quota
      Modifier and Type Method and Description
      Quota[] QuotaAwareStore.getQuota(String folder)
      Get the quotas for the named folder.
      Methods in javax.mail with parameters of type Quota
      Modifier and Type Method and Description
      void QuotaAwareStore.setQuota(Quota quota)
      Set the quotas for the quota root specified in the quota argument.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Quota.Resource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Quota.Resource

  • Packages that use Quota.Resource
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of Quota.Resource in javax.mail

      Fields in javax.mail declared as Quota.Resource
      Modifier and Type Field and Description
      Quota.Resource[] Quota.resources
      The set of resources associated with this quota root.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.ReadOnlyFolderException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.ReadOnlyFolderException

No usage of javax.mail.ReadOnlyFolderException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.SendFailedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.SendFailedException

No usage of javax.mail.SendFailedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Service (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Service

  • Packages that use Service
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of Service in javax.mail

      Subclasses of Service in javax.mail
      Modifier and Type Class and Description
      class  Store
      An abstract class that models a message store and its access protocol, for storing and retrieving messages.
      class  Transport
      An abstract class that models a message transport.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Session (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Session

  • Packages that use Session
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of Session in javax.mail

      Fields in javax.mail declared as Session
      Modifier and Type Field and Description
      protected Session Service.session
      The session from which this service was created.
      protected Session Message.session
      The Session object for this Message
      Methods in javax.mail that return Session
      Modifier and Type Method and Description
      static Session Session.getDefaultInstance(Properties props)
      Get the default Session object.
      static Session Session.getDefaultInstance(Properties props, Authenticator authenticator)
      Get the default Session object.
      static Session Session.getInstance(Properties props)
      Get a new Session object.
      static Session Session.getInstance(Properties props, Authenticator authenticator)
      Get a new Session object.
      Session MessageContext.getSession()
      Return the Session we're operating in.
      Session Message.getSession()
      Return the Session used when this message was created.
      Constructors in javax.mail with parameters of type Session
      Constructor and Description
      Message(Session session)
      Constructor that takes a Session.
      Service(Session session, URLName urlname)
      Constructor.
      Store(Session session, URLName urlname)
      Constructor.
      Transport(Session session, URLName urlname)
      Constructor.

    • Uses of Session in javax.mail.internet

      Methods in javax.mail.internet with parameters of type Session
      Modifier and Type Method and Description
      protected MimeMessage MimeMessage.createMimeMessage(Session session)
      Create and return a MimeMessage object.
      static InternetAddress InternetAddress.getLocalAddress(Session session)
      Return an InternetAddress object representing the current user.
      Constructors in javax.mail.internet with parameters of type Session
      Constructor and Description
      MimeMessage(Session session)
      Default constructor.
      MimeMessage(Session session, InputStream is)
      Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Store (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Store

  • Packages that use Store
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of Store in javax.mail

      Fields in javax.mail declared as Store
      Modifier and Type Field and Description
      protected Store Folder.store
      The parent store.
      Methods in javax.mail that return Store
      Modifier and Type Method and Description
      Store StoreClosedException.getStore()
      Returns the dead Store object
      Store Session.getStore()
      Get a Store object that implements this user's desired Store protocol.
      Store Folder.getStore()
      Returns the Store that owns this Folder object.
      Store Session.getStore(Provider provider)
      Get an instance of the store specified by Provider.
      Store Session.getStore(String protocol)
      Get a Store object that implements the specified protocol.
      Store Session.getStore(URLName url)
      Get a Store object for the given URLName.
      Constructors in javax.mail with parameters of type Store
      Constructor and Description
      Folder(Store store)
      Constructor that takes a Store object.
      StoreClosedException(Store store)
      Constructs a StoreClosedException with no detail message.
      StoreClosedException(Store store, String message)
      Constructs a StoreClosedException with the specified detail message.
      StoreClosedException(Store store, String message, Exception e)
      Constructs a StoreClosedException with the specified detail message and embedded exception.

    • Uses of Store in javax.mail.event

      Constructors in javax.mail.event with parameters of type Store
      Constructor and Description
      StoreEvent(Store store, int type, String message)
      Constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.StoreClosedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.StoreClosedException

No usage of javax.mail.StoreClosedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.Transport (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.Transport

  • Packages that use Transport
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of Transport in javax.mail

      Methods in javax.mail that return Transport
      Modifier and Type Method and Description
      Transport Session.getTransport()
      Get a Transport object that implements this user's desired Transport protcol.
      Transport Session.getTransport(Address address)
      Get a Transport object that can transport a Message of the specified address type.
      Transport Session.getTransport(Provider provider)
      Get an instance of the transport specified in the Provider.
      Transport Session.getTransport(String protocol)
      Get a Transport object that implements the specified protocol.
      Transport Session.getTransport(URLName url)
      Get a Transport object for the given URLName.

    • Uses of Transport in javax.mail.event

      Constructors in javax.mail.event with parameters of type Transport
      Constructor and Description
      TransportEvent(Transport transport, int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.UIDFolder.FetchProfileItem (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.UIDFolder.FetchProfileItem

  • Packages that use UIDFolder.FetchProfileItem
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of UIDFolder.FetchProfileItem in javax.mail

      Fields in javax.mail declared as UIDFolder.FetchProfileItem
      Modifier and Type Field and Description
      static UIDFolder.FetchProfileItem UIDFolder.FetchProfileItem.UID
      UID is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.URLName (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.URLName

  • Packages that use URLName
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of URLName in javax.mail

      Fields in javax.mail declared as URLName
      Modifier and Type Field and Description
      protected URLName Service.url
      The URLName of this service.
      Methods in javax.mail that return URLName
      Modifier and Type Method and Description
      URLName Service.getURLName()
      Return a URLName representing this service.
      URLName Folder.getURLName()
      Return a URLName representing this folder.
      Methods in javax.mail with parameters of type URLName
      Modifier and Type Method and Description
      abstract Folder Store.getFolder(URLName url)
      Return a closed Folder object, corresponding to the given URLName.
      Folder Session.getFolder(URLName url)
      Get a closed Folder object for the given URLName.
      PasswordAuthentication Session.getPasswordAuthentication(URLName url)
      Return any saved PasswordAuthentication for this (store or transport) URLName.
      Store Session.getStore(URLName url)
      Get a Store object for the given URLName.
      Transport Session.getTransport(URLName url)
      Get a Transport object for the given URLName.
      void Session.setPasswordAuthentication(URLName url, PasswordAuthentication pw)
      Save a PasswordAuthentication for this (store or transport) URLName.
      protected void Service.setURLName(URLName url)
      Set the URLName representing this service.
      Constructors in javax.mail with parameters of type URLName
      Constructor and Description
      Service(Session session, URLName urlname)
      Constructor.
      Store(Session session, URLName urlname)
      Constructor.
      Transport(Session session, URLName urlname)
      Constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.EncodingAware (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.EncodingAware

No usage of javax.mail.EncodingAware
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.MessageAware (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.MessageAware

  • Packages that use MessageAware
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of MessageAware in javax.mail.internet

      Classes in javax.mail.internet that implement MessageAware
      Modifier and Type Class and Description
      class  MimePartDataSource
      A utility class that implements a DataSource out of a MimePart.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.MultipartDataSource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.MultipartDataSource

  • Packages that use MultipartDataSource
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of MultipartDataSource in javax.mail

      Methods in javax.mail with parameters of type MultipartDataSource
      Modifier and Type Method and Description
      protected void Multipart.setMultipartDataSource(MultipartDataSource mp)
      Setup this Multipart object from the given MultipartDataSource.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.Part (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.Part

  • Packages that use Part
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of Part in javax.mail

      Classes in javax.mail that implement Part
      Modifier and Type Class and Description
      class  BodyPart
      This class models a Part that is contained within a Multipart.
      class  Message
      This class models an email message.
      Fields in javax.mail declared as Part
      Modifier and Type Field and Description
      protected Part Multipart.parent
      The Part containing this Multipart, if known.
      Methods in javax.mail that return Part
      Modifier and Type Method and Description
      Part Multipart.getParent()
      Return the Part that contains this Multipart object, or null if not known.
      Part MessageContext.getPart()
      Return the Part that contains the content.
      Methods in javax.mail with parameters of type Part
      Modifier and Type Method and Description
      void Multipart.setParent(Part parent)
      Set the parent of this Multipart to be the specified Part.
      Constructors in javax.mail with parameters of type Part
      Constructor and Description
      MessageContext(Part part)
      Create a MessageContext object describing the context of the given Part.

    • Uses of Part in javax.mail.internet

      Subinterfaces of Part in javax.mail.internet
      Modifier and Type Interface and Description
      interface  MimePart
      The MimePart interface models an Entity as defined by MIME (RFC2045, Section 2.4).
      Classes in javax.mail.internet that implement Part
      Modifier and Type Class and Description
      class  MimeBodyPart
      This class represents a MIME body part.
      class  MimeMessage
      This class represents a MIME style email message.
      class  PreencodedMimeBodyPart
      A MimeBodyPart that handles data that has already been encoded.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.QuotaAwareStore (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.QuotaAwareStore

No usage of javax.mail.QuotaAwareStore
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.UIDFolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.UIDFolder

No usage of javax.mail.UIDFolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ConnectionAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class ConnectionAdapter

  • java.lang.Object
    • javax.mail.event.ConnectionAdapter
  • All Implemented Interfaces:
    EventListener, ConnectionListener

    public abstract class ConnectionAdapter
extends Object
implements ConnectionListener
    The adapter which receives connection events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.
    Author:
    John Mani

    • Constructor Summary

      Constructors
      Constructor and Description
      ConnectionAdapter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void closed(ConnectionEvent e)
      Invoked when a Store/Folder/Transport is closed.
      void disconnected(ConnectionEvent e)
      Invoked when a Store is disconnected.
      void opened(ConnectionEvent e)
      Invoked when a Store/Folder/Transport is opened.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ConnectionAdapter

        public ConnectionAdapter()

    • Method Detail

      • opened

        public void opened(ConnectionEvent e)
        Description copied from interface: ConnectionListener
        Invoked when a Store/Folder/Transport is opened.
        Specified by:
        opened in interface ConnectionListener

      • disconnected

        public void disconnected(ConnectionEvent e)
        Description copied from interface: ConnectionListener
        Invoked when a Store is disconnected. Note that a folder cannot be disconnected, so a folder will not fire this event
        Specified by:
        disconnected in interface ConnectionListener

      • closed

        public void closed(ConnectionEvent e)
        Description copied from interface: ConnectionListener
        Invoked when a Store/Folder/Transport is closed.
        Specified by:
        closed in interface ConnectionListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class ConnectionEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.mail.event.MailEvent
        • javax.mail.event.ConnectionEvent
  • All Implemented Interfaces:
    Serializable

    public class ConnectionEvent
extends MailEvent
    This class models Connection events.
    Author:
    John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int CLOSED
      A connection was closed.
      static int DISCONNECTED
      A connection was disconnected (not currently used).
      static int OPENED
      A connection was opened.
      protected int type
      The event type.

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ConnectionEvent(Object source, int type)
      Constructor

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void dispatch(Object listener)
      Invokes the appropriate ConnectionListener method
      int getType()
      Return the type of this event

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • OPENED

        public static final int OPENED
        A connection was opened.
        See Also:
        Constant Field Values

      • DISCONNECTED

        public static final int DISCONNECTED
        A connection was disconnected (not currently used).
        See Also:
        Constant Field Values

      • CLOSED

        public static final int CLOSED
        A connection was closed.
        See Also:
        Constant Field Values

      • type

        protected int type
        The event type.

    • Constructor Detail

      • ConnectionEvent

        public ConnectionEvent(Object source,
               int type)
        Constructor
        Parameters:
        source - The source object

    • Method Detail

      • getType

        public int getType()
        Return the type of this event
        Returns:
        type

      • dispatch

        public void dispatch(Object listener)
        Invokes the appropriate ConnectionListener method
        Specified by:
        dispatch in class MailEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Interface ConnectionListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    ConnectionAdapter

    public interface ConnectionListener
extends EventListener
    This is the Listener interface for Connection events.
    Author:
    John Mani

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void closed(ConnectionEvent e)
      Invoked when a Store/Folder/Transport is closed.
      void disconnected(ConnectionEvent e)
      Invoked when a Store is disconnected.
      void opened(ConnectionEvent e)
      Invoked when a Store/Folder/Transport is opened.

    • Method Detail

      • opened

        void opened(ConnectionEvent e)
        Invoked when a Store/Folder/Transport is opened.

      • disconnected

        void disconnected(ConnectionEvent e)
        Invoked when a Store is disconnected. Note that a folder cannot be disconnected, so a folder will not fire this event

      • closed

        void closed(ConnectionEvent e)
        Invoked when a Store/Folder/Transport is closed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FolderAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class FolderAdapter

  • java.lang.Object
    • javax.mail.event.FolderAdapter
  • All Implemented Interfaces:
    EventListener, FolderListener

    public abstract class FolderAdapter
extends Object
implements FolderListener
    The adapter which receives Folder events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.
    Author:
    John Mani

    • Constructor Summary

      Constructors
      Constructor and Description
      FolderAdapter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void folderCreated(FolderEvent e)
      Invoked when a Folder is created.
      void folderDeleted(FolderEvent e)
      Invoked when a folder is deleted.
      void folderRenamed(FolderEvent e)
      Invoked when a folder is renamed.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FolderAdapter

        public FolderAdapter()

    • Method Detail

      • folderCreated

        public void folderCreated(FolderEvent e)
        Description copied from interface: FolderListener
        Invoked when a Folder is created.
        Specified by:
        folderCreated in interface FolderListener

      • folderRenamed

        public void folderRenamed(FolderEvent e)
        Description copied from interface: FolderListener
        Invoked when a folder is renamed.
        Specified by:
        folderRenamed in interface FolderListener

      • folderDeleted

        public void folderDeleted(FolderEvent e)
        Description copied from interface: FolderListener
        Invoked when a folder is deleted.
        Specified by:
        folderDeleted in interface FolderListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FolderEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class FolderEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.mail.event.MailEvent
        • javax.mail.event.FolderEvent
  • All Implemented Interfaces:
    Serializable

    public class FolderEvent
extends MailEvent
    This class models Folder existence events. FolderEvents are delivered to FolderListeners registered on the affected Folder as well as the containing Store.

    Service providers vary widely in their ability to notify clients of these events. At a minimum, service providers must notify listeners registered on the same Store or Folder object on which the operation occurs. Service providers may also notify listeners when changes are made through operations on other objects in the same virtual machine, or by other clients in the same or other hosts. Such notifications are not required and are typically not supported by mail protocols (including IMAP).

    Author:
    John Mani, Bill Shannon
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int CREATED
      The folder was created.
      static int DELETED
      The folder was deleted.
      protected Folder folder
      The folder the event occurred on.
      protected Folder newFolder
      The folder that represents the new name, in case of a RENAMED event.
      static int RENAMED
      The folder was renamed.
      protected int type
      The event type.

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      FolderEvent(Object source, Folder oldFolder, Folder newFolder, int type)
      Constructor.
      FolderEvent(Object source, Folder folder, int type)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void dispatch(Object listener)
      Invokes the appropriate FolderListener method
      Folder getFolder()
      Return the affected folder.
      Folder getNewFolder()
      If this event indicates that a folder is renamed, (i.e, the event type is RENAMED), then this method returns the Folder object representing the new name.
      int getType()
      Return the type of this event.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • CREATED

        public static final int CREATED
        The folder was created.
        See Also:
        Constant Field Values

      • DELETED

        public static final int DELETED
        The folder was deleted.
        See Also:
        Constant Field Values

      • RENAMED

        public static final int RENAMED
        The folder was renamed.
        See Also:
        Constant Field Values

      • type

        protected int type
        The event type.

      • folder

        protected transient Folder folder
        The folder the event occurred on.

      • newFolder

        protected transient Folder newFolder
        The folder that represents the new name, in case of a RENAMED event.
        Since:
        JavaMail 1.1

    • Constructor Detail

      • FolderEvent

        public FolderEvent(Object source,
           Folder folder,
           int type)
        Constructor.

        Parameters:
        source - The source of the event
        folder - The affected folder
        type - The event type

      • FolderEvent

        public FolderEvent(Object source,
           Folder oldFolder,
           Folder newFolder,
           int type)
        Constructor. Use for RENAMED events.
        Parameters:
        source - The source of the event
        oldFolder - The folder that is renamed
        newFolder - The folder that represents the new name
        type - The event type
        Since:
        JavaMail 1.1

    • Method Detail

      • getType

        public int getType()
        Return the type of this event.
        Returns:
        type

      • getFolder

        public Folder getFolder()
        Return the affected folder.
        Returns:
        the affected folder
        See Also:
        getNewFolder()

      • getNewFolder

        public Folder getNewFolder()
        If this event indicates that a folder is renamed, (i.e, the event type is RENAMED), then this method returns the Folder object representing the new name.

        The getFolder() method returns the folder that is renamed.

        Returns:
        Folder representing the new name.
        Since:
        JavaMail 1.1
        See Also:
        getFolder()

      • dispatch

        public void dispatch(Object listener)
        Invokes the appropriate FolderListener method
        Specified by:
        dispatch in class MailEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FolderListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Interface FolderListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    FolderAdapter

    public interface FolderListener
extends EventListener
    This is the Listener interface for Folder events.
    Author:
    John Mani

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void folderCreated(FolderEvent e)
      Invoked when a Folder is created.
      void folderDeleted(FolderEvent e)
      Invoked when a folder is deleted.
      void folderRenamed(FolderEvent e)
      Invoked when a folder is renamed.

    • Method Detail

      • folderCreated

        void folderCreated(FolderEvent e)
        Invoked when a Folder is created.

      • folderDeleted

        void folderDeleted(FolderEvent e)
        Invoked when a folder is deleted.

      • folderRenamed

        void folderRenamed(FolderEvent e)
        Invoked when a folder is renamed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.mail.event (Java(TM) EE 7 Specification APIs)

javax.mail.event

Interfaces

  • ConnectionListener
  • FolderListener
  • MessageChangedListener
  • MessageCountListener
  • StoreListener
  • TransportListener

Classes

  • ConnectionAdapter
  • ConnectionEvent
  • FolderAdapter
  • FolderEvent
  • MailEvent
  • MessageChangedEvent
  • MessageCountAdapter
  • MessageCountEvent
  • StoreEvent
  • TransportAdapter
  • TransportEvent


javax.mail.event (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.mail.event

Listeners and events for the JavaMail API.

See: Description

  • Interface Summary
    Interface Description
    ConnectionListener
    This is the Listener interface for Connection events.
    FolderListener
    This is the Listener interface for Folder events.
    MessageChangedListener
    This is the Listener interface for MessageChanged events
    MessageCountListener
    This is the Listener interface for MessageCount events.
    StoreListener
    This is the Listener interface for Store Notifications.
    TransportListener
    This is the Listener interface for Transport events
  • Class Summary
    Class Description
    ConnectionAdapter
    The adapter which receives connection events.
    ConnectionEvent
    This class models Connection events.
    FolderAdapter
    The adapter which receives Folder events.
    FolderEvent
    This class models Folder existence events.
    MailEvent
    Common base class for mail events, defining the dispatch method.
    MessageChangedEvent
    This class models Message change events.
    MessageCountAdapter
    The adapter which receives MessageCount events.
    MessageCountEvent
    This class notifies changes in the number of messages in a folder.
    StoreEvent
    This class models notifications from the Store connection.
    TransportAdapter
    The adapter which receives Transport events.
    TransportEvent
    This class models Transport events.

Package javax.mail.event Description

Listeners and events for the JavaMail API. This package defines listener classes and event classes used by the classes defined in the javax.mail package.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.mail.event Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.mail.event

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.mail.event.ConnectionAdapter (implements javax.mail.event.ConnectionListener)
    • java.util.EventObject (implements java.io.Serializable)
      • javax.mail.event.MailEvent
        • javax.mail.event.ConnectionEvent
        • javax.mail.event.FolderEvent
        • javax.mail.event.MessageChangedEvent
        • javax.mail.event.MessageCountEvent
        • javax.mail.event.StoreEvent
        • javax.mail.event.TransportEvent
    • javax.mail.event.FolderAdapter (implements javax.mail.event.FolderListener)
    • javax.mail.event.MessageCountAdapter (implements javax.mail.event.MessageCountListener)
    • javax.mail.event.TransportAdapter (implements javax.mail.event.TransportListener)

Interface Hierarchy

  • java.util.EventListener
    • javax.mail.event.ConnectionListener
    • javax.mail.event.FolderListener
    • javax.mail.event.MessageChangedListener
    • javax.mail.event.MessageCountListener
    • javax.mail.event.StoreListener
    • javax.mail.event.TransportListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MailEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class MailEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.mail.event.MailEvent
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ConnectionEvent, FolderEvent, MessageChangedEvent, MessageCountEvent, StoreEvent, TransportEvent

    public abstract class MailEvent
extends EventObject
    Common base class for mail events, defining the dispatch method.
    Author:
    Bill Shannon
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      MailEvent(Object source)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void dispatch(Object listener)
      This method invokes the appropriate method on a listener for this event.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MailEvent

        public MailEvent(Object source)

    • Method Detail

      • dispatch

        public abstract void dispatch(Object listener)
        This method invokes the appropriate method on a listener for this event. Subclasses provide the implementation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageChangedEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class MessageChangedEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.mail.event.MailEvent
        • javax.mail.event.MessageChangedEvent
  • All Implemented Interfaces:
    Serializable

    public class MessageChangedEvent
extends MailEvent
    This class models Message change events.
    Author:
    John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int ENVELOPE_CHANGED
      The message's envelope (headers, but not body) changed.
      static int FLAGS_CHANGED
      The message's flags changed.
      protected Message msg
      The message that changed.
      protected int type
      The event type.

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageChangedEvent(Object source, int type, Message msg)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void dispatch(Object listener)
      Invokes the appropriate MessageChangedListener method.
      Message getMessage()
      Return the changed Message.
      int getMessageChangeType()
      Return the type of this event.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • FLAGS_CHANGED

        public static final int FLAGS_CHANGED
        The message's flags changed.
        See Also:
        Constant Field Values

      • ENVELOPE_CHANGED

        public static final int ENVELOPE_CHANGED
        The message's envelope (headers, but not body) changed.
        See Also:
        Constant Field Values

      • type

        protected int type
        The event type.

      • msg

        protected transient Message msg
        The message that changed.

    • Constructor Detail

      • MessageChangedEvent

        public MessageChangedEvent(Object source,
                   int type,
                   Message msg)
        Constructor.
        Parameters:
        source - The folder that owns the message
        type - The change type
        msg - The changed message

    • Method Detail

      • getMessageChangeType

        public int getMessageChangeType()
        Return the type of this event.
        Returns:
        type

      • getMessage

        public Message getMessage()
        Return the changed Message.
        Returns:
        the message

      • dispatch

        public void dispatch(Object listener)
        Invokes the appropriate MessageChangedListener method.
        Specified by:
        dispatch in class MailEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageChangedListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Interface MessageChangedListener

  • All Superinterfaces:
    EventListener

    public interface MessageChangedListener
extends EventListener
    This is the Listener interface for MessageChanged events
    Author:
    John Mani

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void messageChanged(MessageChangedEvent e)
      Invoked when a message is changed.

    • Method Detail

      • messageChanged

        void messageChanged(MessageChangedEvent e)
        Invoked when a message is changed. The change-type specifies what changed.
        See Also:
        MessageChangedEvent.FLAGS_CHANGED, MessageChangedEvent.ENVELOPE_CHANGED
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageCountAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class MessageCountAdapter

  • java.lang.Object
    • javax.mail.event.MessageCountAdapter
  • All Implemented Interfaces:
    EventListener, MessageCountListener

    public abstract class MessageCountAdapter
extends Object
implements MessageCountListener
    The adapter which receives MessageCount events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.
    Author:
    John Mani

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageCountAdapter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void messagesAdded(MessageCountEvent e)
      Invoked when messages are added into a folder.
      void messagesRemoved(MessageCountEvent e)
      Invoked when messages are removed (expunged) from a folder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MessageCountAdapter

        public MessageCountAdapter()

    • Method Detail

      • messagesAdded

        public void messagesAdded(MessageCountEvent e)
        Description copied from interface: MessageCountListener
        Invoked when messages are added into a folder.
        Specified by:
        messagesAdded in interface MessageCountListener

      • messagesRemoved

        public void messagesRemoved(MessageCountEvent e)
        Description copied from interface: MessageCountListener
        Invoked when messages are removed (expunged) from a folder.
        Specified by:
        messagesRemoved in interface MessageCountListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageCountEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class MessageCountEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.mail.event.MailEvent
        • javax.mail.event.MessageCountEvent
  • All Implemented Interfaces:
    Serializable

    public class MessageCountEvent
extends MailEvent
    This class notifies changes in the number of messages in a folder.

    Note that some folder types may only deliver MessageCountEvents at certain times or after certain operations. IMAP in particular will only notify the client of MessageCountEvents when a client issues a new command. Refer to RFC 2060 http://www.ietf.org/rfc/rfc2060.txt for details. A client may want "poll" the folder by occasionally calling the getMessageCount or isConnected methods to solicit any such notifications.

    Author:
    John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int ADDED
      The messages were added to their folder
      protected Message[] msgs
      The messages.
      protected boolean removed
      If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this.
      static int REMOVED
      The messages were removed from their folder
      protected int type
      The event type.

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageCountEvent(Folder folder, int type, boolean removed, Message[] msgs)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void dispatch(Object listener)
      Invokes the appropriate MessageCountListener method.
      Message[] getMessages()
      Return the array of messages added or removed.
      int getType()
      Return the type of this event.
      boolean isRemoved()
      Indicates whether this event is the result of an explicit expunge by this client, or due to an expunge from external sources.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • ADDED

        public static final int ADDED
        The messages were added to their folder
        See Also:
        Constant Field Values

      • REMOVED

        public static final int REMOVED
        The messages were removed from their folder
        See Also:
        Constant Field Values

      • type

        protected int type
        The event type.

      • removed

        protected boolean removed
        If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this. If false, this event is the result of an expunge by external sources.

      • msgs

        protected transient Message[] msgs
        The messages.

    • Constructor Detail

      • MessageCountEvent

        public MessageCountEvent(Folder folder,
                 int type,
                 boolean removed,
                 Message[] msgs)
        Constructor.
        Parameters:
        folder - The containing folder
        type - The event type
        removed - If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this. If false, this event is the result of an expunge by external sources.
        msgs - The messages added/removed

    • Method Detail

      • getType

        public int getType()
        Return the type of this event.
        Returns:
        type

      • isRemoved

        public boolean isRemoved()
        Indicates whether this event is the result of an explicit expunge by this client, or due to an expunge from external sources. If true, this event is due to an explicit expunge and hence all remaining messages in this folder have been renumbered. If false, this event is due to an external expunge.

        Note that this method is valid only if the type of this event is REMOVED

      • getMessages

        public Message[] getMessages()
        Return the array of messages added or removed.
        Returns:
        array of messages

      • dispatch

        public void dispatch(Object listener)
        Invokes the appropriate MessageCountListener method.
        Specified by:
        dispatch in class MailEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageCountListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Interface MessageCountListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    MessageCountAdapter

    public interface MessageCountListener
extends EventListener
    This is the Listener interface for MessageCount events.
    Author:
    John Mani

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void messagesAdded(MessageCountEvent e)
      Invoked when messages are added into a folder.
      void messagesRemoved(MessageCountEvent e)
      Invoked when messages are removed (expunged) from a folder.

    • Method Detail

      • messagesAdded

        void messagesAdded(MessageCountEvent e)
        Invoked when messages are added into a folder.

      • messagesRemoved

        void messagesRemoved(MessageCountEvent e)
        Invoked when messages are removed (expunged) from a folder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StoreEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class StoreEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.mail.event.MailEvent
        • javax.mail.event.StoreEvent
  • All Implemented Interfaces:
    Serializable

    public class StoreEvent
extends MailEvent
    This class models notifications from the Store connection. These notifications can be ALERTS or NOTICES. ALERTS must be presented to the user in a fashion that calls the user's attention to the message.
    Author:
    John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int ALERT
      Indicates that this message is an ALERT.
      protected String message
      The message text to be presented to the user.
      static int NOTICE
      Indicates that this message is a NOTICE.
      protected int type
      The event type.

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      StoreEvent(Store store, int type, String message)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void dispatch(Object listener)
      Invokes the appropriate StoreListener method.
      String getMessage()
      Get the message from the Store.
      int getMessageType()
      Return the type of this event.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • ALERT

        public static final int ALERT
        Indicates that this message is an ALERT.
        See Also:
        Constant Field Values

      • NOTICE

        public static final int NOTICE
        Indicates that this message is a NOTICE.
        See Also:
        Constant Field Values

      • type

        protected int type
        The event type.

      • message

        protected String message
        The message text to be presented to the user.

    • Constructor Detail

      • StoreEvent

        public StoreEvent(Store store,
          int type,
          String message)
        Constructor.
        Parameters:
        store - The source Store

    • Method Detail

      • getMessageType

        public int getMessageType()
        Return the type of this event.
        Returns:
        type
        See Also:
        ALERT, NOTICE

      • getMessage

        public String getMessage()
        Get the message from the Store.
        Returns:
        message from the Store

      • dispatch

        public void dispatch(Object listener)
        Invokes the appropriate StoreListener method.
        Specified by:
        dispatch in class MailEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StoreListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Interface StoreListener

  • All Superinterfaces:
    EventListener

    public interface StoreListener
extends EventListener
    This is the Listener interface for Store Notifications.
    Author:
    John Mani

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void notification(StoreEvent e)
      Invoked when the Store generates a notification event.

    • Method Detail

      • notification

        void notification(StoreEvent e)
        Invoked when the Store generates a notification event.
        See Also:
        StoreEvent.ALERT, StoreEvent.NOTICE
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransportAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class TransportAdapter

  • java.lang.Object
    • javax.mail.event.TransportAdapter
  • All Implemented Interfaces:
    EventListener, TransportListener

    public abstract class TransportAdapter
extends Object
implements TransportListener
    The adapter which receives Transport events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.
    Author:
    John Mani

    • Constructor Summary

      Constructors
      Constructor and Description
      TransportAdapter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void messageDelivered(TransportEvent e)
      Invoked when a Message is succesfully delivered.
      void messageNotDelivered(TransportEvent e)
      Invoked when a Message is not delivered.
      void messagePartiallyDelivered(TransportEvent e)
      Invoked when a Message is partially delivered.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TransportAdapter

        public TransportAdapter()

    • Method Detail

      • messageDelivered

        public void messageDelivered(TransportEvent e)
        Description copied from interface: TransportListener
        Invoked when a Message is succesfully delivered.
        Specified by:
        messageDelivered in interface TransportListener
        Parameters:
        e - TransportEvent

      • messageNotDelivered

        public void messageNotDelivered(TransportEvent e)
        Description copied from interface: TransportListener
        Invoked when a Message is not delivered.
        Specified by:
        messageNotDelivered in interface TransportListener
        Parameters:
        e - TransportEvent
        See Also:
        TransportEvent

      • messagePartiallyDelivered

        public void messagePartiallyDelivered(TransportEvent e)
        Description copied from interface: TransportListener
        Invoked when a Message is partially delivered.
        Specified by:
        messagePartiallyDelivered in interface TransportListener
        Parameters:
        e - TransportEvent
        See Also:
        TransportEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransportEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Class TransportEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.mail.event.MailEvent
        • javax.mail.event.TransportEvent
  • All Implemented Interfaces:
    Serializable

    public class TransportEvent
extends MailEvent
    This class models Transport events.
    Author:
    John Mani, Max Spivak
    See Also:
    Transport, TransportListener, Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected Address[] | invalid
      static int MESSAGE_DELIVERED
      Message has been successfully delivered to all recipients by the transport firing this event.
      static int MESSAGE_NOT_DELIVERED
      Message was not sent for some reason.
      static int MESSAGE_PARTIALLY_DELIVERED
      Message was successfully sent to some recipients but not to all.
      protected Message | msg
      protected int type
      The event type.
      protected Address[] | validSent
      protected Address[] | validUnsent

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      TransportEvent(Transport transport, int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void dispatch(Object listener)
      Invokes the appropriate TransportListener method.
      Address[] getInvalidAddresses()
      Return the addresses to which this message could not be sent.
      Message getMessage()
      Get the Message object associated with this Transport Event.
      int getType()
      Return the type of this event.
      Address[] getValidSentAddresses()
      Return the addresses to which this message was sent succesfully.
      Address[] getValidUnsentAddresses()
      Return the addresses that are valid but to which this message was not sent.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • MESSAGE_DELIVERED

        public static final int MESSAGE_DELIVERED
        Message has been successfully delivered to all recipients by the transport firing this event. validSent[] contains all the addresses this transport sent to successfully. validUnsent[] and invalid[] should be null,
        See Also:
        Constant Field Values

      • MESSAGE_NOT_DELIVERED

        public static final int MESSAGE_NOT_DELIVERED
        Message was not sent for some reason. validSent[] should be null. validUnsent[] may have addresses that are valid (but the message wasn't sent to them). invalid[] should likely contain invalid addresses.
        See Also:
        Constant Field Values

      • MESSAGE_PARTIALLY_DELIVERED

        public static final int MESSAGE_PARTIALLY_DELIVERED
        Message was successfully sent to some recipients but not to all. validSent[] holds addresses of recipients to whom the message was sent. validUnsent[] holds valid addresses to which the message was not sent. invalid[] holds invalid addresses, if any.
        See Also:
        Constant Field Values

      • type

        protected int type
        The event type.

      • validSent

        protected transient Address[] validSent

      • validUnsent

        protected transient Address[] validUnsent

      • invalid

        protected transient Address[] invalid

      • msg

        protected transient Message msg

    • Constructor Detail

      • TransportEvent

        public TransportEvent(Transport transport,
              int type,
              Address[] validSent,
              Address[] validUnsent,
              Address[] invalid,
              Message msg)
        Constructor.
        Parameters:
        transport - The Transport object

    • Method Detail

      • getType

        public int getType()
        Return the type of this event.
        Returns:
        type

      • getValidSentAddresses

        public Address[] getValidSentAddresses()
        Return the addresses to which this message was sent succesfully.
        Returns:
        Addresses to which the message was sent successfully or null

      • getValidUnsentAddresses

        public Address[] getValidUnsentAddresses()
        Return the addresses that are valid but to which this message was not sent.
        Returns:
        Addresses that are valid but to which the message was not sent successfully or null

      • getInvalidAddresses

        public Address[] getInvalidAddresses()
        Return the addresses to which this message could not be sent.
        Returns:
        Addresses to which the message sending failed or null

      • getMessage

        public Message getMessage()
        Get the Message object associated with this Transport Event.
        Returns:
        the Message object
        Since:
        JavaMail 1.2

      • dispatch

        public void dispatch(Object listener)
        Invokes the appropriate TransportListener method.
        Specified by:
        dispatch in class MailEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransportListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.event

Interface TransportListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    TransportAdapter

    public interface TransportListener
extends EventListener
    This is the Listener interface for Transport events
    Author:
    John Mani, Max Spivak
    See Also:
    Transport, TransportEvent

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void messageDelivered(TransportEvent e)
      Invoked when a Message is succesfully delivered.
      void messageNotDelivered(TransportEvent e)
      Invoked when a Message is not delivered.
      void messagePartiallyDelivered(TransportEvent e)
      Invoked when a Message is partially delivered.

    • Method Detail

      • messageDelivered

        void messageDelivered(TransportEvent e)
        Invoked when a Message is succesfully delivered.
        Parameters:
        e - TransportEvent

      • messageNotDelivered

        void messageNotDelivered(TransportEvent e)
        Invoked when a Message is not delivered.
        Parameters:
        e - TransportEvent
        See Also:
        TransportEvent

      • messagePartiallyDelivered

        void messagePartiallyDelivered(TransportEvent e)
        Invoked when a Message is partially delivered.
        Parameters:
        e - TransportEvent
        See Also:
        TransportEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.mail.event (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.mail.event

  • Packages that use javax.mail.event
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.
  • Classes in javax.mail.event used by javax.mail
    Class and Description
    ConnectionListener
    This is the Listener interface for Connection events.
    FolderListener
    This is the Listener interface for Folder events.
    MailEvent
    Common base class for mail events, defining the dispatch method.
    MessageChangedListener
    This is the Listener interface for MessageChanged events
    MessageCountListener
    This is the Listener interface for MessageCount events.
    StoreListener
    This is the Listener interface for Store Notifications.
    TransportListener
    This is the Listener interface for Transport events
  • Classes in javax.mail.event used by javax.mail.event
    Class and Description
    ConnectionEvent
    This class models Connection events.
    ConnectionListener
    This is the Listener interface for Connection events.
    FolderEvent
    This class models Folder existence events.
    FolderListener
    This is the Listener interface for Folder events.
    MailEvent
    Common base class for mail events, defining the dispatch method.
    MessageChangedEvent
    This class models Message change events.
    MessageCountEvent
    This class notifies changes in the number of messages in a folder.
    MessageCountListener
    This is the Listener interface for MessageCount events.
    StoreEvent
    This class models notifications from the Store connection.
    TransportEvent
    This class models Transport events.
    TransportListener
    This is the Listener interface for Transport events
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.ConnectionAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.ConnectionAdapter

No usage of javax.mail.event.ConnectionAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.ConnectionEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.ConnectionEvent

  • Packages that use ConnectionEvent
    Package Description
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of ConnectionEvent in javax.mail.event

      Methods in javax.mail.event with parameters of type ConnectionEvent
      Modifier and Type | Method and Description
      void ConnectionListener.closed(ConnectionEvent e)
      Invoked when a Store/Folder/Transport is closed.
      void | ConnectionAdapter.closed(ConnectionEvent e)
      void ConnectionListener.disconnected(ConnectionEvent e)
      Invoked when a Store is disconnected.
      void | ConnectionAdapter.disconnected(ConnectionEvent e)
      void ConnectionListener.opened(ConnectionEvent e)
      Invoked when a Store/Folder/Transport is opened.
      void | ConnectionAdapter.opened(ConnectionEvent e)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.FolderAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.FolderAdapter

No usage of javax.mail.event.FolderAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.FolderEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.FolderEvent

  • Packages that use FolderEvent
    Package Description
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of FolderEvent in javax.mail.event

      Methods in javax.mail.event with parameters of type FolderEvent
      Modifier and Type | Method and Description
      void FolderListener.folderCreated(FolderEvent e)
      Invoked when a Folder is created.
      void | FolderAdapter.folderCreated(FolderEvent e)
      void FolderListener.folderDeleted(FolderEvent e)
      Invoked when a folder is deleted.
      void | FolderAdapter.folderDeleted(FolderEvent e)
      void FolderListener.folderRenamed(FolderEvent e)
      Invoked when a folder is renamed.
      void | FolderAdapter.folderRenamed(FolderEvent e)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.MailEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.MailEvent

  • Packages that use MailEvent
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of MailEvent in javax.mail

      Methods in javax.mail with parameters of type MailEvent
      Modifier and Type Method and Description
      protected void Service.queueEvent(MailEvent event, Vector vector)
      Add the event and vector of listeners to the queue to be delivered.

    • Uses of MailEvent in javax.mail.event

      Subclasses of MailEvent in javax.mail.event
      Modifier and Type Class and Description
      class  ConnectionEvent
      This class models Connection events.
      class  FolderEvent
      This class models Folder existence events.
      class  MessageChangedEvent
      This class models Message change events.
      class  MessageCountEvent
      This class notifies changes in the number of messages in a folder.
      class  StoreEvent
      This class models notifications from the Store connection.
      class  TransportEvent
      This class models Transport events.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.MessageChangedEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.MessageChangedEvent

  • Packages that use MessageChangedEvent
    Package Description
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of MessageChangedEvent in javax.mail.event

      Methods in javax.mail.event with parameters of type MessageChangedEvent
      Modifier and Type Method and Description
      void MessageChangedListener.messageChanged(MessageChangedEvent e)
      Invoked when a message is changed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.MessageCountAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.MessageCountAdapter

No usage of javax.mail.event.MessageCountAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.MessageCountEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.MessageCountEvent

  • Packages that use MessageCountEvent
    Package Description
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of MessageCountEvent in javax.mail.event

      Methods in javax.mail.event with parameters of type MessageCountEvent
      Modifier and Type | Method and Description
      void MessageCountListener.messagesAdded(MessageCountEvent e)
      Invoked when messages are added into a folder.
      void | MessageCountAdapter.messagesAdded(MessageCountEvent e)
      void MessageCountListener.messagesRemoved(MessageCountEvent e)
      Invoked when messages are removed (expunged) from a folder.
      void | MessageCountAdapter.messagesRemoved(MessageCountEvent e)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.StoreEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.StoreEvent

  • Packages that use StoreEvent
    Package Description
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of StoreEvent in javax.mail.event

      Methods in javax.mail.event with parameters of type StoreEvent
      Modifier and Type Method and Description
      void StoreListener.notification(StoreEvent e)
      Invoked when the Store generates a notification event.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.TransportAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.TransportAdapter

No usage of javax.mail.event.TransportAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.event.TransportEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.event.TransportEvent

  • Packages that use TransportEvent
    Package Description
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of TransportEvent in javax.mail.event

      Methods in javax.mail.event with parameters of type TransportEvent
      Modifier and Type | Method and Description
      void TransportListener.messageDelivered(TransportEvent e)
      Invoked when a Message is succesfully delivered.
      void | TransportAdapter.messageDelivered(TransportEvent e)
      void TransportListener.messageNotDelivered(TransportEvent e)
      Invoked when a Message is not delivered.
      void | TransportAdapter.messageNotDelivered(TransportEvent e)
      void TransportListener.messagePartiallyDelivered(TransportEvent e)
      Invoked when a Message is partially delivered.
      void | TransportAdapter.messagePartiallyDelivered(TransportEvent e)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.event.ConnectionListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.event.ConnectionListener

  • Packages that use ConnectionListener
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of ConnectionListener in javax.mail

      Methods in javax.mail with parameters of type ConnectionListener
      Modifier and Type Method and Description
      void Service.addConnectionListener(ConnectionListener l)
      Add a listener for Connection events on this service.
      void Folder.addConnectionListener(ConnectionListener l)
      Add a listener for Connection events on this Folder.
      void Service.removeConnectionListener(ConnectionListener l)
      Remove a Connection event listener.
      void Folder.removeConnectionListener(ConnectionListener l)
      Remove a Connection event listener.

    • Uses of ConnectionListener in javax.mail.event

      Classes in javax.mail.event that implement ConnectionListener
      Modifier and Type Class and Description
      class  ConnectionAdapter
      The adapter which receives connection events.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.event.FolderListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.event.FolderListener

  • Packages that use FolderListener
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of FolderListener in javax.mail

      Methods in javax.mail with parameters of type FolderListener
      Modifier and Type Method and Description
      void Store.addFolderListener(FolderListener l)
      Add a listener for Folder events on any Folder object obtained from this Store.
      void Folder.addFolderListener(FolderListener l)
      Add a listener for Folder events on this Folder.
      void Store.removeFolderListener(FolderListener l)
      Remove a listener for Folder events.
      void Folder.removeFolderListener(FolderListener l)
      Remove a Folder event listener.

    • Uses of FolderListener in javax.mail.event

      Classes in javax.mail.event that implement FolderListener
      Modifier and Type Class and Description
      class  FolderAdapter
      The adapter which receives Folder events.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.event.MessageChangedListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.event.MessageChangedListener

  • Packages that use MessageChangedListener
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of MessageChangedListener in javax.mail

      Methods in javax.mail with parameters of type MessageChangedListener
      Modifier and Type Method and Description
      void Folder.addMessageChangedListener(MessageChangedListener l)
      Add a listener for MessageChanged events on this Folder.
      void Folder.removeMessageChangedListener(MessageChangedListener l)
      Remove a MessageChanged listener.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.event.MessageCountListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.event.MessageCountListener

  • Packages that use MessageCountListener
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of MessageCountListener in javax.mail

      Methods in javax.mail with parameters of type MessageCountListener
      Modifier and Type Method and Description
      void Folder.addMessageCountListener(MessageCountListener l)
      Add a listener for MessageCount events on this Folder.
      void Folder.removeMessageCountListener(MessageCountListener l)
      Remove a MessageCount listener.

    • Uses of MessageCountListener in javax.mail.event

      Classes in javax.mail.event that implement MessageCountListener
      Modifier and Type Class and Description
      class  MessageCountAdapter
      The adapter which receives MessageCount events.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.event.StoreListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.event.StoreListener

  • Packages that use StoreListener
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.

    • Uses of StoreListener in javax.mail

      Methods in javax.mail with parameters of type StoreListener
      Modifier and Type Method and Description
      void Store.addStoreListener(StoreListener l)
      Add a listener for StoreEvents on this Store.
      void Store.removeStoreListener(StoreListener l)
      Remove a listener for Store events.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.event.TransportListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.event.TransportListener

  • Packages that use TransportListener
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.event
    Listeners and events for the JavaMail API.

    • Uses of TransportListener in javax.mail

      Methods in javax.mail with parameters of type TransportListener
      Modifier and Type Method and Description
      void Transport.addTransportListener(TransportListener l)
      Add a listener for Transport events.
      void Transport.removeTransportListener(TransportListener l)
      Remove a listener for Transport events.

    • Uses of TransportListener in javax.mail.event

      Classes in javax.mail.event that implement TransportListener
      Modifier and Type Class and Description
      class  TransportAdapter
      The adapter which receives Transport events.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AddressException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class AddressException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.internet.ParseException
            • javax.mail.internet.AddressException
  • All Implemented Interfaces:
    Serializable

    public class AddressException
extends ParseException
    The exception thrown when a wrongly formatted address is encountered.
    Author:
    Bill Shannon, Max Spivak
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected int pos
      The index in the string where the error occurred, or -1 if not known.
      protected String ref
      The string being parsed.

    • Constructor Summary

      Constructors
      Constructor and Description
      AddressException()
      Constructs an AddressException with no detail message.
      AddressException(String s)
      Constructs an AddressException with the specified detail message.
      AddressException(String s, String ref)
      Constructs an AddressException with the specified detail message and reference info.
      AddressException(String s, String ref, int pos)
      Constructs an AddressException with the specified detail message and reference info.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getPos()
      Get the position with the reference string where the error was detected (-1 if not relevant).
      String getRef()
      Get the string that was being parsed when the error was detected (null if not relevant).
      String toString()
      Override toString method to provide information on nested exceptions.

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • ref

        protected String ref
        The string being parsed.

      • pos

        protected int pos
        The index in the string where the error occurred, or -1 if not known.

    • Constructor Detail

      • AddressException

        public AddressException()
        Constructs an AddressException with no detail message.

      • AddressException

        public AddressException(String s)
        Constructs an AddressException with the specified detail message.
        Parameters:
        s - the detail message

      • AddressException

        public AddressException(String s,
                String ref)
        Constructs an AddressException with the specified detail message and reference info.
        Parameters:
        s - the detail message

      • AddressException

        public AddressException(String s,
                String ref,
                int pos)
        Constructs an AddressException with the specified detail message and reference info.
        Parameters:
        s - the detail message

    • Method Detail

      • getRef

        public String getRef()
        Get the string that was being parsed when the error was detected (null if not relevant).

      • getPos

        public int getPos()
        Get the position with the reference string where the error was detected (-1 if not relevant).

      • toString

        public String toString()
        Description copied from class: MessagingException
        Override toString method to provide information on nested exceptions.
        Overrides:
        toString in class MessagingException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ContentDisposition (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class ContentDisposition

  • java.lang.Object
    • javax.mail.internet.ContentDisposition

  • public class ContentDisposition
extends Object
    This class represents a MIME ContentDisposition value. It provides methods to parse a ContentDisposition string into individual components and to generate a MIME style ContentDisposition string.
    Author:
    John Mani

    • Constructor Summary

      Constructors
      Constructor and Description
      ContentDisposition()
      No-arg Constructor.
      ContentDisposition(String s)
      Constructor that takes a ContentDisposition string.
      ContentDisposition(String disposition, ParameterList list)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDisposition()
      Return the disposition value.
      String getParameter(String name)
      Return the specified parameter value.
      ParameterList getParameterList()
      Return a ParameterList object that holds all the available parameters.
      void setDisposition(String disposition)
      Set the disposition.
      void setParameter(String name, String value)
      Set the specified parameter.
      void setParameterList(ParameterList list)
      Set a new ParameterList.
      String toString()
      Retrieve a RFC2045 style string representation of this ContentDisposition.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ContentDisposition

        public ContentDisposition()
        No-arg Constructor.

      • ContentDisposition

        public ContentDisposition(String disposition,
                  ParameterList list)
        Constructor.
        Parameters:
        disposition - disposition
        list - ParameterList
        Since:
        JavaMail 1.2

      • ContentDisposition

        public ContentDisposition(String s)
                   throws ParseException
        Constructor that takes a ContentDisposition string. The String is parsed into its constituents: dispostion and parameters. A ParseException is thrown if the parse fails.
        Parameters:
        s - the ContentDisposition string.
        Throws:
        ParseException - if the parse fails.
        Since:
        JavaMail 1.2

    • Method Detail

      • getDisposition

        public String getDisposition()
        Return the disposition value.
        Returns:
        the disposition
        Since:
        JavaMail 1.2

      • getParameter

        public String getParameter(String name)
        Return the specified parameter value. Returns null if this parameter is absent.
        Returns:
        parameter value
        Since:
        JavaMail 1.2

      • getParameterList

        public ParameterList getParameterList()
        Return a ParameterList object that holds all the available parameters. Returns null if no parameters are available.
        Returns:
        ParameterList
        Since:
        JavaMail 1.2

      • setDisposition

        public void setDisposition(String disposition)
        Set the disposition. Replaces the existing disposition.
        Parameters:
        disposition - the disposition
        Since:
        JavaMail 1.2

      • setParameter

        public void setParameter(String name,
                String value)
        Set the specified parameter. If this parameter already exists, it is replaced by this new value.
        Parameters:
        name - parameter name
        value - parameter value
        Since:
        JavaMail 1.2

      • setParameterList

        public void setParameterList(ParameterList list)
        Set a new ParameterList.
        Parameters:
        list - ParameterList
        Since:
        JavaMail 1.2

      • toString

        public String toString()
        Retrieve a RFC2045 style string representation of this ContentDisposition. Returns an empty string if the conversion failed.
        Overrides:
        toString in class Object
        Returns:
        RFC2045 style string
        Since:
        JavaMail 1.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ContentType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class ContentType

  • java.lang.Object
    • javax.mail.internet.ContentType

  • public class ContentType
extends Object
    This class represents a MIME Content-Type value. It provides methods to parse a Content-Type string into individual components and to generate a MIME style Content-Type string.
    Author:
    John Mani

    • Constructor Summary

      Constructors
      Constructor and Description
      ContentType()
      No-arg Constructor.
      ContentType(String s)
      Constructor that takes a Content-Type string.
      ContentType(String primaryType, String subType, ParameterList list)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getBaseType()
      Return the MIME type string, without the parameters.
      String getParameter(String name)
      Return the specified parameter value.
      ParameterList getParameterList()
      Return a ParameterList object that holds all the available parameters.
      String getPrimaryType()
      Return the primary type.
      String getSubType()
      Return the subType.
      boolean match(ContentType cType)
      Match with the specified ContentType object.
      boolean match(String s)
      Match with the specified content-type string.
      void setParameter(String name, String value)
      Set the specified parameter.
      void setParameterList(ParameterList list)
      Set a new ParameterList.
      void setPrimaryType(String primaryType)
      Set the primary type.
      void setSubType(String subType)
      Set the subType.
      String toString()
      Retrieve a RFC2045 style string representation of this Content-Type.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ContentType

        public ContentType()
        No-arg Constructor.

      • ContentType

        public ContentType(String primaryType,
           String subType,
           ParameterList list)
        Constructor.
        Parameters:
        primaryType - primary type
        subType - subType
        list - ParameterList

      • ContentType

        public ContentType(String s)
            throws ParseException
        Constructor that takes a Content-Type string. The String is parsed into its constituents: primaryType, subType and parameters. A ParseException is thrown if the parse fails.
        Parameters:
        s - the Content-Type string.
        Throws:
        ParseException - if the parse fails.

    • Method Detail

      • getPrimaryType

        public String getPrimaryType()
        Return the primary type.
        Returns:
        the primary type

      • getSubType

        public String getSubType()
        Return the subType.
        Returns:
        the subType

      • getBaseType

        public String getBaseType()
        Return the MIME type string, without the parameters. The returned value is basically the concatenation of the primaryType, the '/' character and the secondaryType.
        Returns:
        the type

      • getParameter

        public String getParameter(String name)
        Return the specified parameter value. Returns null if this parameter is absent.
        Returns:
        parameter value

      • getParameterList

        public ParameterList getParameterList()
        Return a ParameterList object that holds all the available parameters. Returns null if no parameters are available.
        Returns:
        ParameterList

      • setPrimaryType

        public void setPrimaryType(String primaryType)
        Set the primary type. Overrides existing primary type.
        Parameters:
        primaryType - primary type

      • setSubType

        public void setSubType(String subType)
        Set the subType. Replaces the existing subType.
        Parameters:
        subType - the subType

      • setParameter

        public void setParameter(String name,
                String value)
        Set the specified parameter. If this parameter already exists, it is replaced by this new value.
        Parameters:
        name - parameter name
        value - parameter value

      • setParameterList

        public void setParameterList(ParameterList list)
        Set a new ParameterList.
        Parameters:
        list - ParameterList

      • toString

        public String toString()
        Retrieve a RFC2045 style string representation of this Content-Type. Returns an empty string if the conversion failed.
        Overrides:
        toString in class Object
        Returns:
        RFC2045 style string

      • match

        public boolean match(ContentType cType)
        Match with the specified ContentType object. This method compares only the primaryType and subType . The parameters of both operands are ignored.

        For example, this method will return true when comparing the ContentTypes for "text/plain" and "text/plain; charset=foobar". If the subType of either operand is the special character '*', then the subtype is ignored during the match. For example, this method will return true when comparing the ContentTypes for "text/plain" and "text/*"

        Parameters:
        cType - ContentType to compare this against

      • match

        public boolean match(String s)
        Match with the specified content-type string. This method compares only the primaryType and subType . The parameters of both operands are ignored.

        For example, this method will return true when comparing the ContentType for "text/plain" with "text/plain; charset=foobar". If the subType of either operand is the special character '*', then the subtype is ignored during the match. For example, this method will return true when comparing the ContentType for "text/plain" with "text/*"

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HeaderTokenizer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class HeaderTokenizer

  • java.lang.Object
    • javax.mail.internet.HeaderTokenizer

  • public class HeaderTokenizer
extends Object
    This class tokenizes RFC822 and MIME headers into the basic symbols specified by RFC822 and MIME.

    This class handles folded headers (ie headers with embedded CRLF SPACE sequences). The folds are removed in the returned tokens.

    Author:
    John Mani, Bill Shannon

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  HeaderTokenizer.Token
      The Token class represents tokens returned by the HeaderTokenizer.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String MIME
      MIME specials
      static String RFC822
      RFC822 specials

    • Constructor Summary

      Constructors
      Constructor and Description
      HeaderTokenizer(String header)
      Constructor.
      HeaderTokenizer(String header, String delimiters)
      Constructor.
      HeaderTokenizer(String header, String delimiters, boolean skipComments)
      Constructor that takes a rfc822 style header.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getRemainder()
      Return the rest of the Header.
      HeaderTokenizer.Token next()
      Parses the next token from this String.
      HeaderTokenizer.Token next(char endOfAtom)
      Parses the next token from this String.
      HeaderTokenizer.Token next(char endOfAtom, boolean keepEscapes)
      Parses the next token from this String.
      HeaderTokenizer.Token peek()
      Peek at the next token, without actually removing the token from the parse stream.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • RFC822

        public static final String RFC822
        RFC822 specials
        See Also:
        Constant Field Values

      • MIME

        public static final String MIME
        MIME specials
        See Also:
        Constant Field Values

    • Constructor Detail

      • HeaderTokenizer

        public HeaderTokenizer(String header,
               String delimiters,
               boolean skipComments)
        Constructor that takes a rfc822 style header.
        Parameters:
        header - The rfc822 header to be tokenized
        delimiters - Set of delimiter characters to be used to delimit ATOMS. These are usually RFC822 or MIME
        skipComments - If true, comments are skipped and not returned as tokens

      • HeaderTokenizer

        public HeaderTokenizer(String header,
               String delimiters)
        Constructor. Comments are ignored and not returned as tokens
        Parameters:
        header - The header that is tokenized
        delimiters - The delimiters to be used

      • HeaderTokenizer

        public HeaderTokenizer(String header)
        Constructor. The RFC822 defined delimiters - RFC822 - are used to delimit ATOMS. Also comments are skipped and not returned as tokens

    • Method Detail

      • next

        public HeaderTokenizer.Token next()
                           throws ParseException
        Parses the next token from this String.

        Clients sit in a loop calling next() to parse successive tokens until an EOF Token is returned.

        Returns:
        the next Token
        Throws:
        ParseException - if the parse fails

      • next

        public HeaderTokenizer.Token next(char endOfAtom)
                           throws ParseException
        Parses the next token from this String. If endOfAtom is not NUL, the token extends until the endOfAtom character is seen, or to the end of the header. This method is useful when parsing headers that don't obey the MIME specification, e.g., by failing to quote parameter values that contain spaces.
        Parameters:
        endOfAtom - if not NUL, character marking end of token
        Returns:
        the next Token
        Throws:
        ParseException - if the parse fails
        Since:
        JavaMail 1.5

      • next

        public HeaderTokenizer.Token next(char endOfAtom,
                         boolean keepEscapes)
                           throws ParseException
        Parses the next token from this String. endOfAtom is handled as above. If keepEscapes is true, any backslash escapes are preserved in the returned string. This method is useful when parsing headers that don't obey the MIME specification, e.g., by failing to escape backslashes in the filename parameter.
        Parameters:
        endOfAtom - if not NUL, character marking end of token
        keepEscapes - keep all backslashes in returned string?
        Returns:
        the next Token
        Throws:
        ParseException - if the parse fails
        Since:
        JavaMail 1.5

      • peek

        public HeaderTokenizer.Token peek()
                           throws ParseException
        Peek at the next token, without actually removing the token from the parse stream. Invoking this method multiple times will return successive tokens, until next() is called.

        Returns:
        the next Token
        Throws:
        ParseException - if the parse fails

      • getRemainder

        public String getRemainder()
        Return the rest of the Header.
        Returns:
        String rest of header. null is returned if we are already at end of header
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HeaderTokenizer.Token (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class HeaderTokenizer.Token

  • java.lang.Object
    • javax.mail.internet.HeaderTokenizer.Token
  • Enclosing class:
    HeaderTokenizer

    public static class HeaderTokenizer.Token
extends Object
    The Token class represents tokens returned by the HeaderTokenizer.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int ATOM
      Token type indicating an ATOM.
      static int COMMENT
      Token type indicating a comment.
      static int EOF
      Token type indicating end of input.
      static int QUOTEDSTRING
      Token type indicating a quoted string.

    • Constructor Summary

      Constructors
      Constructor and Description
      HeaderTokenizer.Token(int type, String value)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getType()
      Return the type of the token.
      String getValue()
      Returns the value of the token just read.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ATOM

        public static final int ATOM
        Token type indicating an ATOM.
        See Also:
        Constant Field Values

      • QUOTEDSTRING

        public static final int QUOTEDSTRING
        Token type indicating a quoted string. The value field contains the string without the quotes.
        See Also:
        Constant Field Values

      • COMMENT

        public static final int COMMENT
        Token type indicating a comment. The value field contains the comment string without the comment start and end symbols.
        See Also:
        Constant Field Values

      • EOF

        public static final int EOF
        Token type indicating end of input.
        See Also:
        Constant Field Values

    • Constructor Detail

      • HeaderTokenizer.Token

        public HeaderTokenizer.Token(int type,
                     String value)
        Constructor.
        Parameters:
        type - Token type
        value - Token value

    • Method Detail

      • getType

        public int getType()
        Return the type of the token. If the token represents a delimiter or a control character, the type is that character itself, converted to an integer. Otherwise, it's value is one of the following:
        • ATOM A sequence of ASCII characters delimited by either SPACE, CTL, "(", <"> or the specified SPECIALS
        • QUOTEDSTRING A sequence of ASCII characters within quotes
        • COMMENT A sequence of ASCII characters within "(" and ")".
        • EOF End of header

      • getValue

        public String getValue()
        Returns the value of the token just read. When the current token is a quoted string, this field contains the body of the string, without the quotes. When the current token is a comment, this field contains the body of the comment.
        Returns:
        token value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InternetAddress (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class InternetAddress

  • java.lang.Object
    • javax.mail.Address
      • javax.mail.internet.InternetAddress
  • All Implemented Interfaces:
    Serializable, Cloneable

    public class InternetAddress
extends Address
implements Cloneable
    This class represents an Internet email address using the syntax of RFC822. Typical address syntax is of the form "user@host.domain" or "Personal Name <user@host.domain>".
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected String | address
      protected String encodedPersonal
      The RFC 2047 encoded version of the personal name.
      protected String personal
      The personal name.

    • Constructor Summary

      Constructors
      Constructor and Description
      InternetAddress()
      Default constructor.
      InternetAddress(String address)
      Constructor.
      InternetAddress(String address, boolean strict)
      Parse the given string and create an InternetAddress.
      InternetAddress(String address, String personal)
      Construct an InternetAddress given the address and personal name.
      InternetAddress(String address, String personal, String charset)
      Construct an InternetAddress given the address and personal name.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object clone()
      Return a copy of this InternetAddress object.
      boolean equals(Object a)
      The equality operator.
      String getAddress()
      Get the email address.
      InternetAddress[] getGroup(boolean strict)
      Return the members of a group address.
      static InternetAddress getLocalAddress(Session session)
      Return an InternetAddress object representing the current user.
      String getPersonal()
      Get the personal name.
      String getType()
      Return the type of this address.
      int hashCode()
      Compute a hash code for the address.
      boolean isGroup()
      Indicates whether this address is an RFC 822 group address.
      static InternetAddress[] parse(String addresslist)
      Parse the given comma separated sequence of addresses into InternetAddress objects.
      static InternetAddress[] parse(String addresslist, boolean strict)
      Parse the given sequence of addresses into InternetAddress objects.
      static InternetAddress[] parseHeader(String addresslist, boolean strict)
      Parse the given sequence of addresses into InternetAddress objects.
      void setAddress(String address)
      Set the email address.
      void setPersonal(String name)
      Set the personal name.
      void setPersonal(String name, String charset)
      Set the personal name.
      String toString()
      Convert this address into a RFC 822 / RFC 2047 encoded address.
      static String toString(Address[] addresses)
      Convert the given array of InternetAddress objects into a comma separated sequence of address strings.
      static String toString(Address[] addresses, int used)
      Convert the given array of InternetAddress objects into a comma separated sequence of address strings.
      String toUnicodeString()
      Returns a properly formatted address (RFC 822 syntax) of Unicode characters.
      void validate()
      Validate that this address conforms to the syntax rules of RFC 822.

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • Field Detail

      • address

        protected String address

      • personal

        protected String personal
        The personal name.

      • encodedPersonal

        protected String encodedPersonal
        The RFC 2047 encoded version of the personal name.

        This field and the personal field track each other, so if a subclass sets one of these fields directly, it should set the other to null, so that it is suitably recomputed.

    • Constructor Detail

      • InternetAddress

        public InternetAddress()
        Default constructor.

      • InternetAddress

        public InternetAddress(String address)
                throws AddressException
        Constructor.

        Parse the given string and create an InternetAddress. See the parse method for details of the parsing. The address is parsed using "strict" parsing. This constructor does not perform the additional syntax checks that the InternetAddress(String address, boolean strict) constructor does when strict is true. This constructor is equivalent to InternetAddress(address, false).

        Parameters:
        address - the address in RFC822 format
        Throws:
        AddressException - if the parse failed

      • InternetAddress

        public InternetAddress(String address,
               boolean strict)
                throws AddressException
        Parse the given string and create an InternetAddress. If strict is false, the detailed syntax of the address isn't checked.
        Parameters:
        address - the address in RFC822 format
        strict - enforce RFC822 syntax
        Throws:
        AddressException - if the parse failed
        Since:
        JavaMail 1.3

      • InternetAddress

        public InternetAddress(String address,
               String personal)
                throws UnsupportedEncodingException
        Construct an InternetAddress given the address and personal name. The address is assumed to be a syntactically valid RFC822 address.
        Parameters:
        address - the address in RFC822 format
        personal - the personal name
        Throws:
        UnsupportedEncodingException

      • InternetAddress

        public InternetAddress(String address,
               String personal,
               String charset)
                throws UnsupportedEncodingException
        Construct an InternetAddress given the address and personal name. The address is assumed to be a syntactically valid RFC822 address.
        Parameters:
        address - the address in RFC822 format
        personal - the personal name
        charset - the MIME charset for the name
        Throws:
        UnsupportedEncodingException

    • Method Detail

      • clone

        public Object clone()
        Return a copy of this InternetAddress object.
        Overrides:
        clone in class Object
        Since:
        JavaMail 1.2

      • getType

        public String getType()
        Return the type of this address. The type of an InternetAddress is "rfc822".
        Specified by:
        getType in class Address
        Returns:
        address type
        See Also:
        InternetAddress

      • setAddress

        public void setAddress(String address)
        Set the email address.
        Parameters:
        address - email address

      • setPersonal

        public void setPersonal(String name,
               String charset)
                 throws UnsupportedEncodingException
        Set the personal name. If the name contains non US-ASCII characters, then the name will be encoded using the specified charset as per RFC 2047. If the name contains only US-ASCII characters, no encoding is done and the name is used as is.

        Parameters:
        name - personal name
        charset - MIME charset to be used to encode the name as per RFC 2047
        Throws:
        UnsupportedEncodingException - if the charset encoding fails.
        See Also:
        setPersonal(String)

      • setPersonal

        public void setPersonal(String name)
                 throws UnsupportedEncodingException
        Set the personal name. If the name contains non US-ASCII characters, then the name will be encoded using the platform's default charset. If the name contains only US-ASCII characters, no encoding is done and the name is used as is.

        Parameters:
        name - personal name
        Throws:
        UnsupportedEncodingException - if the charset encoding fails.
        See Also:
        setPersonal(String name, String charset)

      • getAddress

        public String getAddress()
        Get the email address.
        Returns:
        email address

      • getPersonal

        public String getPersonal()
        Get the personal name. If the name is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as is.
        Returns:
        personal name

      • toString

        public String toString()
        Convert this address into a RFC 822 / RFC 2047 encoded address. The resulting string contains only US-ASCII characters, and hence is mail-safe.
        Specified by:
        toString in class Address
        Returns:
        possibly encoded address string

      • toUnicodeString

        public String toUnicodeString()
        Returns a properly formatted address (RFC 822 syntax) of Unicode characters.
        Returns:
        Unicode address string
        Since:
        JavaMail 1.2

      • equals

        public boolean equals(Object a)
        The equality operator.
        Specified by:
        equals in class Address
        Parameters:
        a - Address object

      • hashCode

        public int hashCode()
        Compute a hash code for the address.
        Overrides:
        hashCode in class Object

      • toString

        public static String toString(Address[] addresses)
        Convert the given array of InternetAddress objects into a comma separated sequence of address strings. The resulting string contains only US-ASCII characters, and hence is mail-safe.

        Parameters:
        addresses - array of InternetAddress objects
        Returns:
        comma separated string of addresses
        Throws:
        ClassCastException, - if any address object in the given array is not an InternetAddress object. Note that this is a RuntimeException.

      • toString

        public static String toString(Address[] addresses,
              int used)
        Convert the given array of InternetAddress objects into a comma separated sequence of address strings. The resulting string contains only US-ASCII characters, and hence is mail-safe.

        The 'used' parameter specifies the number of character positions already taken up in the field into which the resulting address sequence string is to be inserted. It is used to determine the line-break positions in the resulting address sequence string.

        Parameters:
        addresses - array of InternetAddress objects
        used - number of character positions already used, in the field into which the address string is to be inserted.
        Returns:
        comma separated string of addresses
        Throws:
        ClassCastException, - if any address object in the given array is not an InternetAddress object. Note that this is a RuntimeException.

      • getLocalAddress

        public static InternetAddress getLocalAddress(Session session)
        Return an InternetAddress object representing the current user. The entire email address may be specified in the "mail.from" property. If not set, the "mail.user" and "mail.host" properties are tried. If those are not set, the "user.name" property and InetAddress.getLocalHost method are tried. Security exceptions that may occur while accessing this information are ignored. If it is not possible to determine an email address, null is returned.
        Parameters:
        session - Session object used for property lookup
        Returns:
        current user's email address

      • parse

        public static InternetAddress[] parse(String addresslist)
                               throws AddressException
        Parse the given comma separated sequence of addresses into InternetAddress objects. Addresses must follow RFC822 syntax.
        Parameters:
        addresslist - comma separated address strings
        Returns:
        array of InternetAddress objects
        Throws:
        AddressException - if the parse failed

      • parse

        public static InternetAddress[] parse(String addresslist,
                      boolean strict)
                               throws AddressException
        Parse the given sequence of addresses into InternetAddress objects. If strict is false, simple email addresses separated by spaces are also allowed. If strict is true, many (but not all) of the RFC822 syntax rules are enforced. In particular, even if strict is true, addresses composed of simple names (with no "@domain" part) are allowed. Such "illegal" addresses are not uncommon in real messages.

        Non-strict parsing is typically used when parsing a list of mail addresses entered by a human. Strict parsing is typically used when parsing address headers in mail messages.

        Parameters:
        addresslist - comma separated address strings
        strict - enforce RFC822 syntax
        Returns:
        array of InternetAddress objects
        Throws:
        AddressException - if the parse failed

      • parseHeader

        public static InternetAddress[] parseHeader(String addresslist,
                            boolean strict)
                                     throws AddressException
        Parse the given sequence of addresses into InternetAddress objects. If strict is false, the full syntax rules for individual addresses are not enforced. If strict is true, many (but not all) of the RFC822 syntax rules are enforced.

        To better support the range of "invalid" addresses seen in real messages, this method enforces fewer syntax rules than the parse method when the strict flag is false and enforces more rules when the strict flag is true. If the strict flag is false and the parse is successful in separating out an email address or addresses, the syntax of the addresses themselves is not checked.

        Parameters:
        addresslist - comma separated address strings
        strict - enforce RFC822 syntax
        Returns:
        array of InternetAddress objects
        Throws:
        AddressException - if the parse failed
        Since:
        JavaMail 1.3

      • validate

        public void validate()
              throws AddressException
        Validate that this address conforms to the syntax rules of RFC 822. The current implementation checks many, but not all, syntax rules. Note that even though the syntax of the address may be correct, there's no guarantee that a mailbox of that name exists.
        Throws:
        AddressException - if the address isn't valid.
        Since:
        JavaMail 1.3

      • isGroup

        public boolean isGroup()
        Indicates whether this address is an RFC 822 group address. Note that a group address is different than the mailing list addresses supported by most mail servers. Group addresses are rarely used; see RFC 822 for details.
        Returns:
        true if this address represents a group
        Since:
        JavaMail 1.3

      • getGroup

        public InternetAddress[] getGroup(boolean strict)
                           throws AddressException
        Return the members of a group address. A group may have zero, one, or more members. If this address is not a group, null is returned. The strict parameter controls whether the group list is parsed using strict RFC 822 rules or not. The parsing is done using the parseHeader method.
        Returns:
        array of InternetAddress objects, or null
        Throws:
        AddressException - if the group list can't be parsed
        Since:
        JavaMail 1.3
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InternetHeaders (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class InternetHeaders

  • java.lang.Object
    • javax.mail.internet.InternetHeaders

  • public class InternetHeaders
extends Object
    InternetHeaders is a utility class that manages RFC822 style headers. Given an RFC822 format message stream, it reads lines until the blank line that indicates end of header. The input stream is positioned at the start of the body. The lines are stored within the object and can be extracted as either Strings or Header objects.

    This class is mostly intended for service providers. MimeMessage and MimeBody use this class for holding their headers.

    A note on RFC822 and MIME headers

    RFC822 and MIME header fields must contain only US-ASCII characters. If a header contains non US-ASCII characters, it must be encoded as per the rules in RFC 2047. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

    The current implementation supports the System property mail.mime.ignorewhitespacelines, which if set to true will cause a line containing only whitespace to be considered a blank line terminating the header.

    Author:
    John Mani, Bill Shannon
    See Also:
    MimeUtility

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      protected static class  InternetHeaders.InternetHeader
      An individual internet header.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected List headers
      The actual list of Headers, including placeholder entries.

    • Constructor Summary

      Constructors
      Constructor and Description
      InternetHeaders()
      Create an empty InternetHeaders object.
      InternetHeaders(InputStream is)
      Read and parse the given RFC822 message stream till the blank line separating the header from the body.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addHeader(String name, String value)
      Add a header with the specified name and value to the header list.
      void addHeaderLine(String line)
      Add an RFC822 header line to the header store.
      Enumeration getAllHeaderLines()
      Return all the header lines as an Enumeration of Strings.
      Enumeration getAllHeaders()
      Return all the headers as an Enumeration of Header objects.
      String[] getHeader(String name)
      Return all the values for the specified header.
      String getHeader(String name, String delimiter)
      Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
      Enumeration getMatchingHeaderLines(String[] names)
      Return all matching header lines as an Enumeration of Strings.
      Enumeration getMatchingHeaders(String[] names)
      Return all matching Header objects.
      Enumeration getNonMatchingHeaderLines(String[] names)
      Return all non-matching header lines
      Enumeration getNonMatchingHeaders(String[] names)
      Return all non-matching Header objects.
      void load(InputStream is)
      Read and parse the given RFC822 message stream till the blank line separating the header from the body.
      void removeHeader(String name)
      Remove all header entries that match the given name
      void setHeader(String name, String value)
      Change the first header line that matches name to have value, adding a new header if no existing header matches.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • headers

        protected List headers
        The actual list of Headers, including placeholder entries. Placeholder entries are Headers with a null value and are never seen by clients of the InternetHeaders class. Placeholder entries are used to keep track of the preferred order of headers. Headers are never actually removed from the list, they're converted into placeholder entries. New headers are added after existing headers of the same name (or before in the case of Received and Return-Path headers). If no existing header or placeholder for the header is found, new headers are added after the special placeholder with the name ":".
        Since:
        JavaMail 1.4

    • Constructor Detail

      • InternetHeaders

        public InternetHeaders()
        Create an empty InternetHeaders object. Placeholder entries are inserted to indicate the preferred order of headers.

      • InternetHeaders

        public InternetHeaders(InputStream is)
                throws MessagingException
        Read and parse the given RFC822 message stream till the blank line separating the header from the body. The input stream is left positioned at the start of the body. The header lines are stored internally.

        For efficiency, wrap a BufferedInputStream around the actual input stream and pass it as the parameter.

        No placeholder entries are inserted; the original order of the headers is preserved.

        Parameters:
        is - RFC822 input stream
        Throws:
        MessagingException

    • Method Detail

      • load

        public void load(InputStream is)
          throws MessagingException
        Read and parse the given RFC822 message stream till the blank line separating the header from the body. Store the header lines inside this InternetHeaders object. The order of header lines is preserved.

        Note that the header lines are added into this InternetHeaders object, so any existing headers in this object will not be affected. Headers are added to the end of the existing list of headers, in order.

        Parameters:
        is - RFC822 input stream
        Throws:
        MessagingException

      • getHeader

        public String[] getHeader(String name)
        Return all the values for the specified header. The values are String objects. Returns null if no headers with the specified name exist.
        Parameters:
        name - header name
        Returns:
        array of header values, or null if none

      • getHeader

        public String getHeader(String name,
               String delimiter)
        Get all the headers for this header name, returned as a single String, with headers separated by the delimiter. If the delimiter is null, only the first header is returned. Returns null if no headers with the specified name exist.
        Parameters:
        name - header name
        delimiter - delimiter
        Returns:
        the value fields for all headers with this name, or null if none

      • setHeader

        public void setHeader(String name,
             String value)
        Change the first header line that matches name to have value, adding a new header if no existing header matches. Remove all matching headers but the first.

        Note that RFC822 headers can only contain US-ASCII characters

        Parameters:
        name - header name
        value - header value

      • addHeader

        public void addHeader(String name,
             String value)
        Add a header with the specified name and value to the header list.

        The current implementation knows about the preferred order of most well-known headers and will insert headers in that order. In addition, it knows that Received headers should be inserted in reverse order (newest before oldest), and that they should appear at the beginning of the headers, preceeded only by a possible Return-Path header.

        Note that RFC822 headers can only contain US-ASCII characters.

        Parameters:
        name - header name
        value - header value

      • removeHeader

        public void removeHeader(String name)
        Remove all header entries that match the given name
        Parameters:
        name - header name

      • getAllHeaders

        public Enumeration getAllHeaders()
        Return all the headers as an Enumeration of Header objects.
        Returns:
        Header objects

      • getMatchingHeaders

        public Enumeration getMatchingHeaders(String[] names)
        Return all matching Header objects.
        Returns:
        matching Header objects

      • getNonMatchingHeaders

        public Enumeration getNonMatchingHeaders(String[] names)
        Return all non-matching Header objects.
        Returns:
        non-matching Header objects

      • addHeaderLine

        public void addHeaderLine(String line)
        Add an RFC822 header line to the header store. If the line starts with a space or tab (a continuation line), add it to the last header line in the list. Otherwise, append the new header line to the list.

        Note that RFC822 headers can only contain US-ASCII characters

        Parameters:
        line - raw RFC822 header line

      • getAllHeaderLines

        public Enumeration getAllHeaderLines()
        Return all the header lines as an Enumeration of Strings.

      • getMatchingHeaderLines

        public Enumeration getMatchingHeaderLines(String[] names)
        Return all matching header lines as an Enumeration of Strings.

      • getNonMatchingHeaderLines

        public Enumeration getNonMatchingHeaderLines(String[] names)
        Return all non-matching header lines
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InternetHeaders.InternetHeader (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class InternetHeaders.InternetHeader

  • java.lang.Object
    • javax.mail.Header
      • javax.mail.internet.InternetHeaders.InternetHeader
  • Enclosing class:
    InternetHeaders

    protected static final class InternetHeaders.InternetHeader
extends Header
    An individual internet header. This class is only used by subclasses of InternetHeaders.

    An InternetHeader object with a null value is used as a placeholder for headers of that name, to preserve the order of headers. A placeholder InternetHeader object with a name of ":" marks the location in the list of headers where new headers are added by default.

    Since:
    JavaMail 1.4

    • Field Summary

      • Fields inherited from class javax.mail.Header

        name, value

    • Constructor Summary

      Constructors
      Constructor and Description
      InternetHeaders.InternetHeader(String l)
      Constructor that takes a line and splits out the header name.
      InternetHeaders.InternetHeader(String n, String v)
      Constructor that takes a header name and value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getValue()
      Return the "value" part of the header line.

      • Methods inherited from class javax.mail.Header

        getName

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InternetHeaders.InternetHeader

        public InternetHeaders.InternetHeader(String l)
        Constructor that takes a line and splits out the header name.

      • InternetHeaders.InternetHeader

        public InternetHeaders.InternetHeader(String n,
                              String v)
        Constructor that takes a header name and value.

    • Method Detail

      • getValue

        public String getValue()
        Return the "value" part of the header line.
        Overrides:
        getValue in class Header
        Returns:
        value of the header
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.mail.internet (Java(TM) EE 7 Specification APIs)

javax.mail.internet

Interfaces

  • MimePart
  • SharedInputStream

Classes

  • ContentDisposition
  • ContentType
  • HeaderTokenizer
  • HeaderTokenizer.Token
  • InternetAddress
  • InternetHeaders
  • InternetHeaders.InternetHeader
  • MailDateFormat
  • MimeBodyPart
  • MimeMessage
  • MimeMessage.RecipientType
  • MimeMultipart
  • MimePartDataSource
  • MimeUtility
  • NewsAddress
  • ParameterList
  • PreencodedMimeBodyPart

Exceptions

  • AddressException
  • ParseException


javax.mail.internet (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.mail.internet

Classes specific to Internet mail systems.

See: Description

  • Interface Summary
    Interface Description
    MimePart
    The MimePart interface models an Entity as defined by MIME (RFC2045, Section 2.4).
    SharedInputStream
    An InputStream that is backed by data that can be shared by multiple readers may implement this interface.
  • Class Summary
    Class Description
    ContentDisposition
    This class represents a MIME ContentDisposition value.
    ContentType
    This class represents a MIME Content-Type value.
    HeaderTokenizer
    This class tokenizes RFC822 and MIME headers into the basic symbols specified by RFC822 and MIME.
    HeaderTokenizer.Token
    The Token class represents tokens returned by the HeaderTokenizer.
    InternetAddress
    This class represents an Internet email address using the syntax of RFC822.
    InternetHeaders
    InternetHeaders is a utility class that manages RFC822 style headers.
    InternetHeaders.InternetHeader
    An individual internet header.
    MailDateFormat
    Formats and parses date specification based on the draft-ietf-drums-msg-fmt-08 dated January 26, 2000.
    MimeBodyPart
    This class represents a MIME body part.
    MimeMessage
    This class represents a MIME style email message.
    MimeMessage.RecipientType
    This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes.
    MimeMultipart
    The MimeMultipart class is an implementation of the abstract Multipart class that uses MIME conventions for the multipart data.
    MimePartDataSource
    A utility class that implements a DataSource out of a MimePart.
    MimeUtility
    This is a utility class that provides various MIME related functionality.
    NewsAddress
    This class models an RFC1036 newsgroup address.
    ParameterList
    This class holds MIME parameters (attribute-value pairs).
    PreencodedMimeBodyPart
    A MimeBodyPart that handles data that has already been encoded.
  • Exception Summary
    Exception Description
    AddressException
    The exception thrown when a wrongly formatted address is encountered.
    ParseException
    The exception thrown due to an error in parsing RFC822 or MIME headers

Package javax.mail.internet Description

Classes specific to Internet mail systems. This package supports features that are specific to Internet mail systems based on the MIME standard (RFC 2045, RFC 2046, and RFC 2047). The IMAP, SMTP, and POP3 protocols use MimeMessages.

The JavaMail API specification requires support for the following properties, which must be set in the System properties. The properties are always set as strings; the Type column describes how the string is interpreted. For example, use (in J2SE 1.2 and newer)

        System.setProperty("mail.mime.address.strict", "false");
to set the mail.mime.address.strict property, which is of type boolean.

Name | Type | Description
mail.mime.address.strict | boolean | The mail.mime.address.strict session property controls the parsing of address headers. By default, strict parsing of address headers is done. If this property is set to "false", strict parsing is not done and many illegal addresses that sometimes occur in real messages are allowed. See the InternetAddress class for details.
mail.mime.charset | String | The mail.mime.charset System property can be used to specify the default MIME charset to use for encoded words and text parts that don't otherwise specify a charset. Normally, the default MIME charset is derived from the default Java charset, as specified in the file.encoding System property. Most applications will have no need to explicitly set the default MIME charset. In cases where the default MIME charset to be used for mail messages is different than the charset used for files stored on the system, this property should be set.
mail.mime.decodetext.strict | boolean | The mail.mime.decodetext.strict property controls decoding of MIME encoded words. The MIME spec requires that encoded words start at the beginning of a whitespace separated word. Some mailers incorrectly include encoded words in the middle of a word. If the mail.mime.decodetext.strict System property is set to "false", an attempt will be made to decode these illegal encoded words. The default is true.
mail.mime.encodeeol.strict | boolean | The mail.mime.encodeeol.strict property controls the choice of Content-Transfer-Encoding for MIME parts that are not of type "text". Often such parts will contain textual data for which an encoding that allows normal end of line conventions is appropriate. In rare cases, such a part will appear to contain entirely textual data, but will require an encoding that preserves CR and LF characters without change. If the mail.mime.encodeeol.strict System property is set to "true", such an encoding will be used when necessary. The default is false.
mail.mime.decodefilename | boolean | If set to "true", the getFileName method uses the MimeUtility method decodeText to decode any non-ASCII characters in the filename. Note that this decoding violates the MIME specification, but is useful for interoperating with some mail clients that use this convention. The default is false.
mail.mime.encodefilename | boolean | If set to "true", the setFileName method uses the MimeUtility method encodeText to encode any non-ASCII characters in the filename. Note that this encoding violates the MIME specification, but is useful for interoperating with some mail clients that use this convention. The default is false.
mail.mime.decodeparameters | boolean | If set to "false", non-ASCII parameters in a ParameterList, e.g., in a Content-Type header, will not be decoded as specified by RFC 2231. The default is true.
mail.mime.encodeparameters | boolean | If set to "false", non-ASCII parameters in a ParameterList, e.g., in a Content-Type header, will not be encoded as specified by RFC 2231. The default is true.
mail.mime.multipart. ignoremissingendboundary | boolean | Normally, when parsing a multipart MIME message, a message that is missing the final end boundary line is not considered an error. The data simply ends at the end of the input. Note that messages of this form violate the MIME specification. If the property mail.mime.multipart.ignoremissingendboundary is set to false, such messages are considered an error and a MesagingException will be thrown when parsing such a message.
mail.mime.multipart. ignoremissingboundaryparameter | boolean | If the Content-Type header for a multipart content does not have a boundary parameter, the multipart parsing code will look for the first line in the content that looks like a boundary line and extract the boundary parameter from the line. If this property is set to "false", a MessagingException will be thrown if the Content-Type header doesn't specify a boundary parameter. The default is true.
mail.mime.multipart. ignoreexistingboundaryparameter | boolean | Normally the boundary parameter in the Content-Type header of a multipart body part is used to specify the separator between parts of the multipart body. This System property may be set to "true" to cause the parser to look for a line in the multipart body that looks like a boundary line and use that value as the separator between subsequent parts. This may be useful in cases where a broken anti-virus product has rewritten the message incorrectly such that the boundary parameter and the actual boundary value no longer match. The default value of this property is false.
mail.mime.multipart. allowempty | boolean | Normally, when writing out a MimeMultipart that contains no body parts, or when trying to parse a multipart message with no body parts, a MessagingException is thrown. The MIME spec does not allow multipart content with no body parts. This System property may be set to "true" to override this behavior. When writing out such a MimeMultipart, a single empty part will be included. When reading such a multipart, a MimeMultipart will be created with no body parts. The default value of this property is false.

The following properties are supported by Sun's implementation of JavaMail, but are not currently a required part of the specification. As above, these must be set as System properties. The names, types, defaults, and semantics of these properties may change in future releases.

Name | Type | Description
mail.mime.base64.ignoreerrors | boolean | If set to "true", the BASE64 decoder will ignore errors in the encoded data, returning EOF. This may be useful when dealing with improperly encoded messages that contain extraneous data at the end of the encoded stream. Note however that errors anywhere in the stream will cause the decoder to stop decoding so this should be used with extreme caution. The default is false.
mail.mime.foldtext | boolean | If set to "true", header fields containing just text such as the Subject and Content-Description header fields, and long parameter values in structured headers such as Content-Type will be folded (broken into 76 character lines) when set and unfolded when read. The default is true.
mail.mime.setcontenttypefilename | boolean | If set to "true", the setFileName method will also set the name parameter on the Content-Type header to the specified filename. This supports interoperability with some old mail clients. The default is true.
mail.mime.setdefaulttextcharset | boolean | When updating the headers of a message, a body part with a text content type but no charset parameter will have a charset parameter added to it if this property is set to "true". The default is true.
mail.mime.parameters.strict | boolean | If set to false, when reading a message, parameter values in header fields such as Content-Type and Content-Disposition are allowed to contain whitespace and other special characters without being quoted; the parameter value ends at the next semicolon. If set to true (the default), parameter values are required to conform to the MIME specification and must be quoted if they contain whitespace or special characters.
mail.mime.applefilenames | boolean | Apple Mail incorrectly encodes filenames that contain spaces, forgetting to quote the parameter value. If this property is set to "true", JavaMail will try to detect this situation when parsing parameters and work around it. The default is false. Note that this property handles a subset of the cases handled by setting the mail.mime.parameters.strict property to false. This property will likely be removed in a future release.
mail.mime.windowsfilenames | boolean | Internet Explorer 6 incorrectly includes a complete pathname in the filename parameter of the Content-Disposition header for uploaded files, and fails to properly escape the backslashes in the pathname. If this property is set to "true", JavaMail will preserve all backslashes in the "filename" and "name" parameters of any MIME header. The default is false. Note that this is a violation of the MIME specification but may be useful when using JavaMail to parse HTTP messages for uploaded files sent by IE6.
mail.mime. ignoreunknownencoding | boolean | If set to "true", an unknown value in the Content-Transfer-Encoding header will be ignored when reading a message and an encoding of "8bit" will be assumed. If set to "false", an exception is thrown for an unknown encoding value. The default is false.
mail.mime.uudecode. ignoreerrors | boolean | If set to "true", errors in the encoded format of a uuencoded document will be ignored when reading a message part. If set to "false", an exception is thrown for an incorrectly encoded message part. The default is false.
mail.mime.uudecode. ignoremissingbeginend | boolean | If set to "true", a missing "being" or "end" line in a uuencoded document will be ignored when reading a message part. If set to "false", an exception is thrown for a uuencoded message part without the required "begin" and "end" lines. The default is false.
mail.mime. ignorewhitespacelines | boolean | Normally the header of a MIME part is separated from the body by an empty line. This System property may be set to "true" to cause the parser to consider a line containing only whitespace to be an empty line. The default value of this property is false.
mail.mime. ignoremultipartencoding | boolean | The MIME spec does not allow body parts of type multipart/* to be encoded. The Content-Transfer-Encoding header is ignored in this case. Setting this System property to "false" will cause the Content-Transfer-Encoding header to be honored for multipart content. The default value of this property is true.
mail.mime.allowencodedmessages | boolean | The MIME spec does not allow body parts of type message/* to be encoded. The Content-Transfer-Encoding header is ignored in this case. Some versions of Microsoft Outlook will incorrectly encode message attachments. Setting this System property to "true" will cause the Content-Transfer-Encoding header to be honored for message attachments. The default value of this property is false.
mail.mime.contenttypehandler | String | In some cases JavaMail is unable to process messages with an invalid Content-Type header. The header may have incorrect syntax or other problems. This property specifies the name of a class that will be used to clean up the Content-Type header value before JavaMail uses it. The class must have a method with this signature: public static String cleanContentType(MimePart mp, String contentType) Whenever JavaMail accesses the Content-Type header of a message, it will pass the value to this method and use the returned value instead. The value may be null if the Content-Type header isn't present. Returning null will cause the default Content-Type to be used. The MimePart may be used to access other headers of the message part to determine how to correct the Content-Type. Note that the Content-Type handler doesn't affect the getHeader method, which still returns the raw header value. Note also that the handler doesn't affect the IMAP provider; the IMAP server is responsible for returning pre-parsed, syntactically correct Content-Type information.
mail.alternates | String | A string containing other email addresses that the current user is known by. The MimeMessage reply method will eliminate any of these addresses from the recipient list in the message it constructs, to avoid sending the reply back to the sender.
mail.replyallcc | boolean | If set to "true", the MimeMessage reply method will put all recipients except the original sender in the Cc list of the newly constructed message. Normally, recipients in the To header of the original message will also appear in the To list of the newly constructed message.

The current implementation of classes in this package log debugging information using Logger as described in the following table:

Logger Name | Logging Level | Purpose
javax.mail.internet | FINE | General debugging output
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.mail.internet Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.mail.internet

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.mail.Address (implements java.io.Serializable)
      • javax.mail.internet.InternetAddress (implements java.lang.Cloneable)
      • javax.mail.internet.NewsAddress
    • javax.mail.BodyPart (implements javax.mail.Part)
      • javax.mail.internet.MimeBodyPart (implements javax.mail.internet.MimePart)
        • javax.mail.internet.PreencodedMimeBodyPart
    • javax.mail.internet.ContentDisposition
    • javax.mail.internet.ContentType
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
          • javax.mail.internet.MailDateFormat
    • javax.mail.Header
      • javax.mail.internet.InternetHeaders.InternetHeader
    • javax.mail.internet.HeaderTokenizer
    • javax.mail.internet.HeaderTokenizer.Token
    • javax.mail.internet.InternetHeaders
    • javax.mail.Message (implements javax.mail.Part)
      • javax.mail.internet.MimeMessage (implements javax.mail.internet.MimePart)
    • javax.mail.Message.RecipientType (implements java.io.Serializable)
      • javax.mail.internet.MimeMessage.RecipientType
    • javax.mail.internet.MimePartDataSource (implements javax.activation.DataSource, javax.mail.MessageAware)
    • javax.mail.internet.MimeUtility
    • javax.mail.Multipart
      • javax.mail.internet.MimeMultipart
    • javax.mail.internet.ParameterList
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.internet.ParseException
            • javax.mail.internet.AddressException

Interface Hierarchy

  • javax.mail.Part
    • javax.mail.internet.MimePart
  • javax.mail.internet.SharedInputStream
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MailDateFormat (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class MailDateFormat

  • java.lang.Object
    • java.text.Format
      • java.text.DateFormat
        • java.text.SimpleDateFormat
          • javax.mail.internet.MailDateFormat
  • All Implemented Interfaces:
    Serializable, Cloneable

    public class MailDateFormat
extends SimpleDateFormat
    Formats and parses date specification based on the draft-ietf-drums-msg-fmt-08 dated January 26, 2000. This is a followup spec to RFC822.

    This class does not take pattern strings. It always formats the date based on the specification below.

    3.3 Date and Time Specification

    Date and time occur in several header fields of a message. This section specifies the syntax for a full date and time specification. Though folding whitespace is permitted throughout the date-time specification, it is recommended that only a single space be used where FWS is required and no space be used where FWS is optional in the date-time specification; some older implementations may not interpret other occurrences of folding whitespace correctly.

    date-time = [ day-of-week "," ] date FWS time [CFWS]

    day-of-week = ([FWS] day-name) / obs-day-of-week

    day-name = "Mon" / "Tue" / "Wed" / "Thu" / "Fri" / "Sat" / "Sun"

    date = day month year

    year = 4*DIGIT / obs-year

    month = (FWS month-name FWS) / obs-month

    month-name = "Jan" / "Feb" / "Mar" / "Apr" /
             "May" / "Jun" / "Jul" / "Aug" /
             "Sep" / "Oct" / "Nov" / "Dec"

    day = ([FWS] 1*2DIGIT) / obs-day

    time = time-of-day FWS zone

    time-of-day = hour ":" minute [ ":" second ]

    hour = 2DIGIT / obs-hour

    minute = 2DIGIT / obs-minute

    second = 2DIGIT / obs-second

    zone = (( "+" / "-" ) 4DIGIT) / obs-zone

    The day is the numeric day of the month. The year is any numeric year in the common era.

    The time-of-day specifies the number of hours, minutes, and optionally seconds since midnight of the date indicated.

    The date and time-of-day SHOULD express local time.

    The zone specifies the offset from Coordinated Universal Time (UTC, formerly referred to as "Greenwich Mean Time") that the date and time-of-day represent. The "+" or "-" indicates whether the time-of-day is ahead of or behind Universal Time. The first two digits indicate the number of hours difference from Universal Time, and the last two digits indicate the number of minutes difference from Universal Time. (Hence, +hhmm means +(hh * 60 + mm) minutes, and -hhmm means -(hh * 60 + mm) minutes). The form "+0000" SHOULD be used to indicate a time zone at Universal Time. Though "-0000" also indicates Universal Time, it is used to indicate that the time was generated on a system that may be in a local time zone other than Universal Time.

    A date-time specification MUST be semantically valid. That is, the day-of-the week (if included) MUST be the day implied by the date, the numeric day-of-month MUST be between 1 and the number of days allowed for the specified month (in the specified year), the time-of-day MUST be in the range 00:00:00 through 23:59:60 (the number of seconds allowing for a leap second; see [STD-12]), and the zone MUST be within the range -9959 through +9959.

    Since:
    JavaMail 1.2
    Author:
    Max Spivak
    See Also:
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.text.DateFormat

        DateFormat.Field

    • Field Summary

      • Fields inherited from class java.text.DateFormat

        AM_PM_FIELD, calendar, DATE_FIELD, DAY_OF_WEEK_FIELD, DAY_OF_WEEK_IN_MONTH_FIELD, DAY_OF_YEAR_FIELD, DEFAULT, ERA_FIELD, FULL, HOUR_OF_DAY0_FIELD, HOUR_OF_DAY1_FIELD, HOUR0_FIELD, HOUR1_FIELD, LONG, MEDIUM, MILLISECOND_FIELD, MINUTE_FIELD, MONTH_FIELD, numberFormat, SECOND_FIELD, SHORT, TIMEZONE_FIELD, WEEK_OF_MONTH_FIELD, WEEK_OF_YEAR_FIELD, YEAR_FIELD

    • Constructor Summary

      Constructors
      Constructor and Description
      MailDateFormat()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      StringBuffer format(Date date, StringBuffer dateStrBuf, FieldPosition fieldPosition)
      Formats the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.
      Date parse(String text, ParsePosition pos)
      Parses the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.
      void setCalendar(Calendar newCalendar)
      Don't allow setting the calendar
      void setNumberFormat(NumberFormat newNumberFormat)
      Don't allow setting the NumberFormat

      • Methods inherited from class java.text.SimpleDateFormat

        applyLocalizedPattern, applyPattern, clone, equals, formatToCharacterIterator, get2DigitYearStart, getDateFormatSymbols, hashCode, set2DigitYearStart, setDateFormatSymbols, toLocalizedPattern, toPattern

      • Methods inherited from class java.text.DateFormat

        format, format, getAvailableLocales, getCalendar, getDateInstance, getDateInstance, getDateInstance, getDateTimeInstance, getDateTimeInstance, getDateTimeInstance, getInstance, getNumberFormat, getTimeInstance, getTimeInstance, getTimeInstance, getTimeZone, isLenient, parse, parseObject, setLenient, setTimeZone

      • Methods inherited from class java.text.Format

        format, parseObject

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MailDateFormat

        public MailDateFormat()

    • Method Detail

      • format

        public StringBuffer format(Date date,
                  StringBuffer dateStrBuf,
                  FieldPosition fieldPosition)
        Formats the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.
        Overrides:
        format in class SimpleDateFormat
        Parameters:
        date - the Date object
        dateStrBuf - the formatted string
        fieldPosition - the current field position
        Returns:
        StringBuffer the formatted String
        Since:
        JavaMail 1.2

      • parse

        public Date parse(String text,
         ParsePosition pos)
        Parses the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.
        Overrides:
        parse in class SimpleDateFormat
        Parameters:
        text - the formatted date to be parsed
        pos - the current parse position
        Returns:
        Date the parsed date in a Date object
        Since:
        JavaMail 1.2

      • setCalendar

        public void setCalendar(Calendar newCalendar)
        Don't allow setting the calendar
        Overrides:
        setCalendar in class DateFormat

      • setNumberFormat

        public void setNumberFormat(NumberFormat newNumberFormat)
        Don't allow setting the NumberFormat
        Overrides:
        setNumberFormat in class DateFormat
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MimeBodyPart (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class MimeBodyPart

  • java.lang.Object
    • javax.mail.BodyPart
      • javax.mail.internet.MimeBodyPart
  • All Implemented Interfaces:
    MimePart, Part
    Direct Known Subclasses:
    PreencodedMimeBodyPart

    public class MimeBodyPart
extends BodyPart
implements MimePart
    This class represents a MIME body part. It implements the BodyPart abstract class and the MimePart interface. MimeBodyParts are contained in MimeMultipart objects.

    MimeBodyPart uses the InternetHeaders class to parse and store the headers of that body part.

    A note on RFC 822 and MIME headers

    RFC 822 header fields must contain only US-ASCII characters. MIME allows non ASCII characters to be present in certain portions of certain headers, by encoding those characters. RFC 2047 specifies the rules for doing this. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

    Author:
    John Mani, Bill Shannon, Kanwar Oberoi
    See Also:
    Part, MimePart, MimeUtility

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Object cachedContent
      If our content is a Multipart of Message object, we save it the first time it's created by parsing a stream so that changes to the contained objects will not be lost.
      protected byte[] content
      Byte array that holds the bytes of the content of this Part.
      protected InputStream contentStream
      If the data for this body part was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this body part.
      protected DataHandler dh
      The DataHandler object representing this Part's content.
      protected InternetHeaders headers
      The InternetHeaders object that stores all the headers of this body part.

      • Fields inherited from class javax.mail.BodyPart

        parent

      • Fields inherited from interface javax.mail.Part

        ATTACHMENT, INLINE

    • Constructor Summary

      Constructors
      Constructor and Description
      MimeBodyPart()
      An empty MimeBodyPart object is created.
      MimeBodyPart(InputStream is)
      Constructs a MimeBodyPart by reading and parsing the data from the specified input stream.
      MimeBodyPart(InternetHeaders headers, byte[] content)
      Constructs a MimeBodyPart using the given header and content bytes.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addHeader(String name, String value)
      Add this value to the existing values for this header_name.
      void addHeaderLine(String line)
      Add a header line to this body part
      void attachFile(File file)
      Use the specified file to provide the data for this part.
      void attachFile(File file, String contentType, String encoding)
      Use the specified file with the specified Content-Type and Content-Transfer-Encoding to provide the data for this part.
      void attachFile(String file)
      Use the specified file to provide the data for this part.
      void attachFile(String file, String contentType, String encoding)
      Use the specified file with the specified Content-Type and Content-Transfer-Encoding to provide the data for this part.
      Enumeration getAllHeaderLines()
      Get all header lines as an Enumeration of Strings.
      Enumeration getAllHeaders()
      Return all the headers from this Message as an Enumeration of Header objects.
      Object getContent()
      Return the content as a Java object.
      String getContentID()
      Returns the value of the "Content-ID" header field.
      String[] getContentLanguage()
      Get the languages specified in the Content-Language header of this MimePart.
      String getContentMD5()
      Return the value of the "Content-MD5" header field.
      protected InputStream getContentStream()
      Produce the raw bytes of the content.
      String getContentType()
      Returns the value of the RFC 822 "Content-Type" header field.
      DataHandler getDataHandler()
      Return a DataHandler for this body part's content.
      String getDescription()
      Returns the "Content-Description" header field of this body part.
      String getDisposition()
      Returns the value of the "Content-Disposition" header field.
      String getEncoding()
      Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
      String getFileName()
      Get the filename associated with this body part.
      String[] getHeader(String name)
      Get all the headers for this header_name.
      String getHeader(String name, String delimiter)
      Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
      InputStream getInputStream()
      Return a decoded input stream for this body part's "content".
      int getLineCount()
      Return the number of lines for the content of this Part.
      Enumeration getMatchingHeaderLines(String[] names)
      Get matching header lines as an Enumeration of Strings.
      Enumeration getMatchingHeaders(String[] names)
      Return matching headers from this Message as an Enumeration of Header objects.
      Enumeration getNonMatchingHeaderLines(String[] names)
      Get non-matching header lines as an Enumeration of Strings.
      Enumeration getNonMatchingHeaders(String[] names)
      Return non-matching headers from this Message as an Enumeration of Header objects.
      InputStream getRawInputStream()
      Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
      int getSize()
      Return the size of the content of this body part in bytes.
      boolean isMimeType(String mimeType)
      Is this Part of the specified MIME type? This method compares only the primaryType and subType.
      void removeHeader(String name)
      Remove all headers with this name.
      void saveFile(File file)
      Save the contents of this part in the specified file.
      void saveFile(String file)
      Save the contents of this part in the specified file.
      void setContent(Multipart mp)
      This method sets the body part's content to a Multipart object.
      void setContent(Object o, String type)
      A convenience method for setting this body part's content.
      void setContentID(String cid)
      Set the "Content-ID" header field of this body part.
      void setContentLanguage(String[] languages)
      Set the Content-Language header of this MimePart.
      void setContentMD5(String md5)
      Set the "Content-MD5" header field of this body part.
      void setDataHandler(DataHandler dh)
      This method provides the mechanism to set this body part's content.
      void setDescription(String description)
      Set the "Content-Description" header field for this body part.
      void setDescription(String description, String charset)
      Set the "Content-Description" header field for this body part.
      void setDisposition(String disposition)
      Set the "Content-Disposition" header field of this body part.
      void setFileName(String filename)
      Set the filename associated with this body part, if possible.
      void setHeader(String name, String value)
      Set the value for this header_name.
      void setText(String text)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
      void setText(String text, String charset)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
      void setText(String text, String charset, String subtype)
      Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.
      protected void updateHeaders()
      Examine the content of this body part and update the appropriate MIME headers.
      void writeTo(OutputStream os)
      Output the body part as an RFC 822 format stream.

      • Methods inherited from class javax.mail.BodyPart

        getParent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • dh

        protected DataHandler dh
        The DataHandler object representing this Part's content.

      • content

        protected byte[] content
        Byte array that holds the bytes of the content of this Part.

      • contentStream

        protected InputStream contentStream
        If the data for this body part was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this body part. In this case, content will be null.
        Since:
        JavaMail 1.2

      • headers

        protected InternetHeaders headers
        The InternetHeaders object that stores all the headers of this body part.

      • cachedContent

        protected Object cachedContent
        If our content is a Multipart of Message object, we save it the first time it's created by parsing a stream so that changes to the contained objects will not be lost. If this field is not null, it's return by the getContent() method. The getContent() method sets this field if it would return a Multipart or MimeMessage object. This field is is cleared by the setDataHandler(javax.activation.DataHandler) method.
        Since:
        JavaMail 1.5

    • Constructor Detail

      • MimeBodyPart

        public MimeBodyPart()
        An empty MimeBodyPart object is created. This body part maybe filled in by a client constructing a multipart message.

      • MimeBodyPart

        public MimeBodyPart(InputStream is)
             throws MessagingException
        Constructs a MimeBodyPart by reading and parsing the data from the specified input stream. The parser consumes data till the end of the given input stream. The input stream must start at the beginning of a valid MIME body part and must terminate at the end of that body part.

        Note that the "boundary" string that delimits body parts must not be included in the input stream. The intention is that the MimeMultipart parser will extract each body part's bytes from a multipart stream and feed them into this constructor, without the delimiter strings.

        Parameters:
        is - the body part Input Stream
        Throws:
        MessagingException

      • MimeBodyPart

        public MimeBodyPart(InternetHeaders headers,
            byte[] content)
             throws MessagingException
        Constructs a MimeBodyPart using the given header and content bytes.

        Used by providers.

        Parameters:
        headers - The header of this part
        content - bytes representing the body of this part.
        Throws:
        MessagingException

    • Method Detail

      • getSize

        public int getSize()
            throws MessagingException
        Return the size of the content of this body part in bytes. Return -1 if the size cannot be determined.

        Note that this number may not be an exact measure of the content size and may or may not account for any transfer encoding of the content.

        This implementation returns the size of the content array (if not null), or, if contentStream is not null, and the available method returns a positive number, it returns that number as the size. Otherwise, it returns -1.

        Specified by:
        getSize in interface Part
        Returns:
        size in bytes, or -1 if not known
        Throws:
        MessagingException

      • getLineCount

        public int getLineCount()
                 throws MessagingException
        Return the number of lines for the content of this Part. Return -1 if this number cannot be determined.

        Note that this number may not be an exact measure of the content length and may or may not account for any transfer encoding of the content.

        This implementation returns -1.

        Specified by:
        getLineCount in interface Part
        Returns:
        number of lines, or -1 if not known
        Throws:
        MessagingException

      • getContentType

        public String getContentType()
                      throws MessagingException
        Returns the value of the RFC 822 "Content-Type" header field. This represents the content type of the content of this body part. This value must not be null. If this field is unavailable, "text/plain" should be returned.

        This implementation uses getHeader(name) to obtain the requisite header field.

        Specified by:
        getContentType in interface Part
        Returns:
        Content-Type of this body part
        Throws:
        MessagingException
        See Also:
        DataHandler

      • isMimeType

        public boolean isMimeType(String mimeType)
                   throws MessagingException
        Is this Part of the specified MIME type? This method compares only the primaryType and subType. The parameters of the content types are ignored.

        For example, this method will return true when comparing a Part of content type "text/plain" with "text/plain; charset=foobar".

        If the subType of mimeType is the special character '*', then the subtype is ignored during the comparison.

        Specified by:
        isMimeType in interface Part
        Throws:
        MessagingException

      • getDisposition

        public String getDisposition()
                      throws MessagingException
        Returns the value of the "Content-Disposition" header field. This represents the disposition of this part. The disposition describes how the part should be presented to the user.

        If the Content-Disposition field is unavailable, null is returned.

        This implementation uses getHeader(name) to obtain the requisite header field.

        Specified by:
        getDisposition in interface Part
        Returns:
        disposition of this part, or null if unknown
        Throws:
        MessagingException
        See Also:
        headers

      • setDisposition

        public void setDisposition(String disposition)
                    throws MessagingException
        Set the "Content-Disposition" header field of this body part. If the disposition is null, any existing "Content-Disposition" header field is removed.
        Specified by:
        setDisposition in interface Part
        Parameters:
        disposition - disposition of this part
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this body part is obtained from a READ_ONLY folder.
        MessagingException
        See Also:
        Part.ATTACHMENT, Part.INLINE, Part.setFileName(java.lang.String)

      • getEncoding

        public String getEncoding()
                   throws MessagingException
        Returns the content transfer encoding from the "Content-Transfer-Encoding" header field. Returns null if the header is unavailable or its value is absent.

        This implementation uses getHeader(name) to obtain the requisite header field.

        Specified by:
        getEncoding in interface MimePart
        Returns:
        content-transfer-encoding
        Throws:
        MessagingException
        See Also:
        headers

      • getContentID

        public String getContentID()
                    throws MessagingException
        Returns the value of the "Content-ID" header field. Returns null if the field is unavailable or its value is absent.

        This implementation uses getHeader(name) to obtain the requisite header field.

        Specified by:
        getContentID in interface MimePart
        Returns:
        content-ID
        Throws:
        MessagingException

      • setContentID

        public void setContentID(String cid)
                  throws MessagingException
        Set the "Content-ID" header field of this body part. If the cid parameter is null, any existing "Content-ID" is removed.
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this body part is obtained from a READ_ONLY folder.
        MessagingException
        Since:
        JavaMail 1.3

      • getContentMD5

        public String getContentMD5()
                     throws MessagingException
        Return the value of the "Content-MD5" header field. Returns null if this field is unavailable or its value is absent.

        This implementation uses getHeader(name) to obtain the requisite header field.

        Specified by:
        getContentMD5 in interface MimePart
        Returns:
        content-MD5
        Throws:
        MessagingException

      • setContentMD5

        public void setContentMD5(String md5)
                   throws MessagingException
        Set the "Content-MD5" header field of this body part.
        Specified by:
        setContentMD5 in interface MimePart
        Parameters:
        md5 - the MD5 value
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this body part is obtained from a READ_ONLY folder.
        MessagingException

      • getContentLanguage

        public String[] getContentLanguage()
                            throws MessagingException
        Get the languages specified in the Content-Language header of this MimePart. The Content-Language header is defined by RFC 1766. Returns null if this header is not available or its value is absent.

        This implementation uses getHeader(name) to obtain the requisite header field.

        Specified by:
        getContentLanguage in interface MimePart
        Throws:
        MessagingException

      • setContentLanguage

        public void setContentLanguage(String[] languages)
                        throws MessagingException
        Set the Content-Language header of this MimePart. The Content-Language header is defined by RFC 1766.
        Specified by:
        setContentLanguage in interface MimePart
        Parameters:
        languages - array of language tags
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        MessagingException

      • getDescription

        public String getDescription()
                      throws MessagingException
        Returns the "Content-Description" header field of this body part. This typically associates some descriptive information with this part. Returns null if this field is unavailable or its value is absent.

        If the Content-Description field is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as is.

        This implementation uses getHeader(name) to obtain the requisite header field.

        Specified by:
        getDescription in interface Part
        Returns:
        content description
        Throws:
        MessagingException

      • setDescription

        public void setDescription(String description)
                    throws MessagingException
        Set the "Content-Description" header field for this body part. If the description parameter is null, then any existing "Content-Description" fields are removed.

        If the description contains non US-ASCII characters, it will be encoded using the platform's default charset. If the description contains only US-ASCII characters, no encoding is done and it is used as is.

        Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

        Specified by:
        setDescription in interface Part
        Parameters:
        description - content description
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this body part is obtained from a READ_ONLY folder.
        MessagingException - otherwise; an UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.

      • setDescription

        public void setDescription(String description,
                  String charset)
                    throws MessagingException
        Set the "Content-Description" header field for this body part. If the description parameter is null, then any existing "Content-Description" fields are removed.

        If the description contains non US-ASCII characters, it will be encoded using the specified charset. If the description contains only US-ASCII characters, no encoding is done and it is used as is.

        Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

        Parameters:
        description - Description
        charset - Charset for encoding
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this body part is obtained from a READ_ONLY folder.
        MessagingException - otherwise; an UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.

      • getFileName

        public String getFileName()
                   throws MessagingException
        Get the filename associated with this body part.

        Returns the value of the "filename" parameter from the "Content-Disposition" header field of this body part. If its not available, returns the value of the "name" parameter from the "Content-Type" header field of this body part. Returns null if both are absent.

        If the mail.mime.decodefilename System property is set to true, the MimeUtility.decodeText method will be used to decode the filename. While such encoding is not supported by the MIME spec, many mailers use this technique to support non-ASCII characters in filenames. The default value of this property is false.

        Specified by:
        getFileName in interface Part
        Returns:
        filename
        Throws:
        MessagingException

      • setFileName

        public void setFileName(String filename)
                 throws MessagingException
        Set the filename associated with this body part, if possible.

        Sets the "filename" parameter of the "Content-Disposition" header field of this body part. For compatibility with older mailers, the "name" parameter of the "Content-Type" header is also set.

        If the mail.mime.encodefilename System property is set to true, the MimeUtility.encodeText method will be used to encode the filename. While such encoding is not supported by the MIME spec, many mailers use this technique to support non-ASCII characters in filenames. The default value of this property is false.

        Specified by:
        setFileName in interface Part
        Parameters:
        filename - Filename to associate with this part
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this body part is obtained from a READ_ONLY folder.
        MessagingException

      • getInputStream

        public InputStream getInputStream()
                           throws IOException,
                                  MessagingException
        Return a decoded input stream for this body part's "content".

        This implementation obtains the input stream from the DataHandler. That is, it invokes getDataHandler().getInputStream();

        Specified by:
        getInputStream in interface Part
        Returns:
        an InputStream
        Throws:
        MessagingException
        IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
        See Also:
        getContentStream(), DataHandler.getInputStream()

      • getContentStream

        protected InputStream getContentStream()
                                throws MessagingException
        Produce the raw bytes of the content. This method is used when creating a DataHandler object for the content. Subclasses that can provide a separate input stream for just the Part content might want to override this method.

        Throws:
        MessagingException
        See Also:
        content, MimeMessage.getContentStream()

      • getRawInputStream

        public InputStream getRawInputStream()
                              throws MessagingException
        Return an InputStream to the raw data with any Content-Transfer-Encoding intact. This method is useful if the "Content-Transfer-Encoding" header is incorrect or corrupt, which would prevent the getInputStream method or getContent method from returning the correct data. In such a case the application may use this method and attempt to decode the raw data itself.

        This implementation simply calls the getContentStream method.

        Throws:
        MessagingException
        Since:
        JavaMail 1.2
        See Also:
        getInputStream(), getContentStream()

      • getDataHandler

        public DataHandler getDataHandler()
                           throws MessagingException
        Return a DataHandler for this body part's content.

        The implementation provided here works just like the the implementation in MimeMessage.

        Specified by:
        getDataHandler in interface Part
        Returns:
        DataHandler for the content
        Throws:
        MessagingException
        See Also:
        MimeMessage.getDataHandler()

      • getContent

        public Object getContent()
                  throws IOException,
                         MessagingException
        Return the content as a Java object. The type of the object returned is of course dependent on the content itself. For example, the native format of a text/plain content is usually a String object. The native format for a "multipart" content is always a Multipart subclass. For content types that are unknown to the DataHandler system, an input stream is returned as the content.

        This implementation obtains the content from the DataHandler. That is, it invokes getDataHandler().getContent(); If the content is a Multipart or Message object and was created by parsing a stream, the object is cached and returned in subsequent calls so that modifications to the content will not be lost.

        Specified by:
        getContent in interface Part
        Returns:
        Object
        Throws:
        MessagingException
        IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
        See Also:
        DataHandler.getContent()

      • setDataHandler

        public void setDataHandler(DataHandler dh)
                    throws MessagingException
        This method provides the mechanism to set this body part's content. The given DataHandler object should wrap the actual content.
        Specified by:
        setDataHandler in interface Part
        Parameters:
        dh - The DataHandler for the content
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this body part is obtained from a READ_ONLY folder.
        MessagingException

      • setContent

        public void setContent(Object o,
              String type)
                throws MessagingException
        A convenience method for setting this body part's content.

        The content is wrapped in a DataHandler object. Note that a DataContentHandler class for the specified type should be available to the JavaMail implementation for this to work right. That is, to do setContent(foobar, "application/x-foobar"), a DataContentHandler for "application/x-foobar" should be installed. Refer to the Java Activation Framework for more information.

        Specified by:
        setContent in interface Part
        Parameters:
        o - the content object
        type - Mime type of the object
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this body part is obtained from a READ_ONLY folder.
        MessagingException

      • setText

        public void setText(String text)
             throws MessagingException
        Convenience method that sets the given String as this part's content, with a MIME type of "text/plain". If the string contains non US-ASCII characters, it will be encoded using the platform's default charset. The charset is also used to set the "charset" parameter.

        Note that there may be a performance penalty if text is large, since this method may have to scan all the characters to determine what charset to use.

        If the charset is already known, use the setText method that takes the charset parameter.

        Specified by:
        setText in interface MimePart
        Specified by:
        setText in interface Part
        Parameters:
        text - the text content to set
        Throws:
        MessagingException - if an error occurs
        See Also:
        setText(String text, String charset)

      • setText

        public void setText(String text,
           String charset)
             throws MessagingException
        Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.
        Specified by:
        setText in interface MimePart
        Parameters:
        text - the text content to set
        charset - the charset to use for the text
        Throws:
        MessagingException - if an error occurs

      • setText

        public void setText(String text,
           String charset,
           String subtype)
             throws MessagingException
        Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.
        Specified by:
        setText in interface MimePart
        Parameters:
        text - the text content to set
        charset - the charset to use for the text
        subtype - the MIME subtype to use (e.g., "html")
        Throws:
        MessagingException - if an error occurs
        Since:
        JavaMail 1.4

      • setContent

        public void setContent(Multipart mp)
                throws MessagingException
        This method sets the body part's content to a Multipart object.
        Specified by:
        setContent in interface Part
        Parameters:
        mp - The multipart object that is the Message's content
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values.
        IllegalStateException - if this body part is obtained from a READ_ONLY folder.
        MessagingException

      • attachFile

        public void attachFile(File file)
                throws IOException,
                       MessagingException
        Use the specified file to provide the data for this part. The simple file name is used as the file name for this part and the data in the file is used as the data for this part. The encoding will be chosen appropriately for the file data. The disposition of this part is set to Part.ATTACHMENT.
        Parameters:
        file - the File object to attach
        Throws:
        IOException - errors related to accessing the file
        MessagingException - message related errors
        Since:
        JavaMail 1.4

      • attachFile

        public void attachFile(String file)
                throws IOException,
                       MessagingException
        Use the specified file to provide the data for this part. The simple file name is used as the file name for this part and the data in the file is used as the data for this part. The encoding will be chosen appropriately for the file data.
        Parameters:
        file - the name of the file to attach
        Throws:
        IOException - errors related to accessing the file
        MessagingException - message related errors
        Since:
        JavaMail 1.4

      • attachFile

        public void attachFile(File file,
              String contentType,
              String encoding)
                throws IOException,
                       MessagingException
        Use the specified file with the specified Content-Type and Content-Transfer-Encoding to provide the data for this part. If contentType or encoding are null, appropriate values will be chosen. The simple file name is used as the file name for this part and the data in the file is used as the data for this part. The disposition of this part is set to Part.ATTACHMENT.
        Parameters:
        file - the File object to attach
        contentType - the Content-Type, or null
        encoding - the Content-Transfer-Encoding, or null
        Throws:
        IOException - errors related to accessing the file
        MessagingException - message related errors
        Since:
        JavaMail 1.5

      • attachFile

        public void attachFile(String file,
              String contentType,
              String encoding)
                throws IOException,
                       MessagingException
        Use the specified file with the specified Content-Type and Content-Transfer-Encoding to provide the data for this part. If contentType or encoding are null, appropriate values will be chosen. The simple file name is used as the file name for this part and the data in the file is used as the data for this part. The disposition of this part is set to Part.ATTACHMENT.
        Parameters:
        file - the name of the file
        contentType - the Content-Type, or null
        encoding - the Content-Transfer-Encoding, or null
        Throws:
        IOException - errors related to accessing the file
        MessagingException - message related errors
        Since:
        JavaMail 1.5

      • saveFile

        public void saveFile(File file)
              throws IOException,
                     MessagingException
        Save the contents of this part in the specified file. The content is decoded and saved, without any of the MIME headers.
        Parameters:
        file - the File object to write to
        Throws:
        IOException - errors related to accessing the file
        MessagingException - message related errors
        Since:
        JavaMail 1.4

      • saveFile

        public void saveFile(String file)
              throws IOException,
                     MessagingException
        Save the contents of this part in the specified file. The content is decoded and saved, without any of the MIME headers.
        Parameters:
        file - the name of the file to write to
        Throws:
        IOException - errors related to accessing the file
        MessagingException - message related errors
        Since:
        JavaMail 1.4

      • writeTo

        public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
        Output the body part as an RFC 822 format stream.
        Specified by:
        writeTo in interface Part
        Throws:
        MessagingException
        IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
        See Also:
        DataHandler.writeTo(java.io.OutputStream)

      • getHeader

        public String[] getHeader(String name)
                   throws MessagingException
        Get all the headers for this header_name. Note that certain headers may be encoded as per RFC 2047 if they contain non US-ASCII characters and these should be decoded.
        Specified by:
        getHeader in interface Part
        Parameters:
        name - name of header
        Returns:
        array of headers
        Throws:
        MessagingException
        See Also:
        MimeUtility

      • getHeader

        public String getHeader(String name,
               String delimiter)
                 throws MessagingException
        Get all the headers for this header name, returned as a single String, with headers separated by the delimiter. If the delimiter is null, only the first header is returned.
        Specified by:
        getHeader in interface MimePart
        Parameters:
        name - the name of this header
        delimiter - delimiter between fields in returned string
        Returns:
        the value fields for all headers with this name
        Throws:
        MessagingException

      • setHeader

        public void setHeader(String name,
             String value)
               throws MessagingException
        Set the value for this header_name. Replaces all existing header values with this new value. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must be encoded as per the rules of RFC 2047.
        Specified by:
        setHeader in interface Part
        Parameters:
        name - header name
        value - header value
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        See Also:
        MimeUtility

      • addHeader

        public void addHeader(String name,
             String value)
               throws MessagingException
        Add this value to the existing values for this header_name. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must be encoded as per the rules of RFC 2047.
        Specified by:
        addHeader in interface Part
        Parameters:
        name - header name
        value - header value
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        See Also:
        MimeUtility

      • removeHeader

        public void removeHeader(String name)
                  throws MessagingException
        Remove all headers with this name.
        Specified by:
        removeHeader in interface Part
        Parameters:
        name - the name of this header
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • getAllHeaders

        public Enumeration getAllHeaders()
                          throws MessagingException
        Return all the headers from this Message as an Enumeration of Header objects.
        Specified by:
        getAllHeaders in interface Part
        Returns:
        enumeration of Header objects
        Throws:
        MessagingException

      • getMatchingHeaders

        public Enumeration getMatchingHeaders(String[] names)
                               throws MessagingException
        Return matching headers from this Message as an Enumeration of Header objects.

        Specified by:
        getMatchingHeaders in interface Part
        Returns:
        enumeration of Header objects
        Throws:
        MessagingException

      • getNonMatchingHeaders

        public Enumeration getNonMatchingHeaders(String[] names)
                                  throws MessagingException
        Return non-matching headers from this Message as an Enumeration of Header objects.
        Specified by:
        getNonMatchingHeaders in interface Part
        Returns:
        enumeration of Header objects
        Throws:
        MessagingException

      • addHeaderLine

        public void addHeaderLine(String line)
                   throws MessagingException
        Add a header line to this body part
        Specified by:
        addHeaderLine in interface MimePart
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        MessagingException

      • getAllHeaderLines

        public Enumeration getAllHeaderLines()
                              throws MessagingException
        Get all header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header line, containing both the "name" and "value" field.
        Specified by:
        getAllHeaderLines in interface MimePart
        Throws:
        MessagingException

      • getMatchingHeaderLines

        public Enumeration getMatchingHeaderLines(String[] names)
                                   throws MessagingException
        Get matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header line, containing both the "name" and "value" field.
        Specified by:
        getMatchingHeaderLines in interface MimePart
        Throws:
        MessagingException

      • getNonMatchingHeaderLines

        public Enumeration getNonMatchingHeaderLines(String[] names)
                                      throws MessagingException
        Get non-matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header line, containing both the "name" and "value" field.
        Specified by:
        getNonMatchingHeaderLines in interface MimePart
        Throws:
        MessagingException

      • updateHeaders

        protected void updateHeaders()
                      throws MessagingException
        Examine the content of this body part and update the appropriate MIME headers. Typical headers that get set here are Content-Type and Content-Transfer-Encoding. Headers might need to be updated in two cases:
        - A message being crafted by a mail application will certainly need to activate this method at some point to fill up its internal headers.
        - A message read in from a Store will have obtained all its headers from the store, and so doesn't need this. However, if this message is editable and if any edits have been made to either the content or message structure, we might need to resync our headers.
        In both cases this method is typically called by the Message.saveChanges method.

        If the cachedContent field is not null (that is, it references a Multipart or Message object), then that object is used to set a new DataHandler, any stream data used to create this object is discarded, and the cachedContent field is cleared.

        Throws:
        MessagingException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MimeMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class MimeMessage

  • java.lang.Object
    • javax.mail.Message
      • javax.mail.internet.MimeMessage
  • All Implemented Interfaces:
    MimePart, Part

    public class MimeMessage
extends Message
implements MimePart
    This class represents a MIME style email message. It implements the Message abstract class and the MimePart interface.

    Clients wanting to create new MIME style messages will instantiate an empty MimeMessage object and then fill it with appropriate attributes and content.

    Service providers that implement MIME compliant backend stores may want to subclass MimeMessage and override certain methods to provide specific implementations. The simplest case is probably a provider that generates a MIME style input stream and leaves the parsing of the stream to this class.

    MimeMessage uses the InternetHeaders class to parse and store the top level RFC 822 headers of a message.

    The mail.mime.address.strict session property controls the parsing of address headers. By default, strict parsing of address headers is done. If this property is set to "false", strict parsing is not done and many illegal addresses that sometimes occur in real messages are allowed. See the InternetAddress class for details.

    A note on RFC 822 and MIME headers

    RFC 822 header fields must contain only US-ASCII characters. MIME allows non ASCII characters to be present in certain portions of certain headers, by encoding those characters. RFC 2047 specifies the rules for doing this. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

    Author:
    John Mani, Bill Shannon, Max Spivak, Kanwar Oberoi
    See Also:
    MimeUtility, Part, Message, MimePart, InternetAddress

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  MimeMessage.RecipientType
      This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Object cachedContent
      If our content is a Multipart or Message object, we save it the first time it's created by parsing a stream so that changes to the contained objects will not be lost.
      protected byte[] content
      Byte array that holds the bytes of this Message's content.
      protected InputStream contentStream
      If the data for this message was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this message.
      protected DataHandler dh
      The DataHandler object representing this Message's content.
      protected Flags flags
      The Flags for this message.
      protected InternetHeaders headers
      The InternetHeaders object that stores the header of this message.
      protected boolean modified
      A flag indicating whether the message has been modified.
      protected boolean saved
      Does the saveChanges method need to be called on this message? This flag is set to false by the public constructor and set to true by the saveChanges method.

      • Fields inherited from class javax.mail.Message

        expunged, folder, msgnum, session

      • Fields inherited from interface javax.mail.Part

        ATTACHMENT, INLINE

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected MimeMessage(Folder folder, InputStream is, int msgnum)
      Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.
      protected MimeMessage(Folder folder, int msgnum)
      Constructs an empty MimeMessage object with the given Folder and message number.
      protected MimeMessage(Folder folder, InternetHeaders headers, byte[] content, int msgnum)
      Constructs a MimeMessage from the given InternetHeaders object and content.
        MimeMessage(MimeMessage source)
      Constructs a new MimeMessage with content initialized from the source MimeMessage.
        MimeMessage(Session session)
      Default constructor.
        MimeMessage(Session session, InputStream is)
      Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addFrom(Address[] addresses)
      Add the specified addresses to the existing "From" field.
      void addHeader(String name, String value)
      Add this value to the existing values for this header_name.
      void addHeaderLine(String line)
      Add a raw RFC 822 header-line.
      void addRecipients(Message.RecipientType type, Address[] addresses)
      Add the given addresses to the specified recipient type.
      void addRecipients(Message.RecipientType type, String addresses)
      Add the given addresses to the specified recipient type.
      protected InternetHeaders createInternetHeaders(InputStream is)
      Create and return an InternetHeaders object that loads the headers from the given InputStream.
      protected MimeMessage createMimeMessage(Session session)
      Create and return a MimeMessage object.
      Enumeration getAllHeaderLines()
      Get all header lines as an Enumeration of Strings.
      Enumeration getAllHeaders()
      Return all the headers from this Message as an enumeration of Header objects.
      Address[] getAllRecipients()
      Get all the recipient addresses for the message.
      Object getContent()
      Return the content as a Java object.
      String getContentID()
      Returns the value of the "Content-ID" header field.
      String[] getContentLanguage()
      Get the languages specified in the "Content-Language" header field of this message.
      String getContentMD5()
      Return the value of the "Content-MD5" header field.
      protected InputStream getContentStream()
      Produce the raw bytes of the content.
      String getContentType()
      Returns the value of the RFC 822 "Content-Type" header field.
      DataHandler getDataHandler()
      Return a DataHandler for this Message's content.
      String getDescription()
      Returns the "Content-Description" header field of this Message.
      String getDisposition()
      Returns the value of the "Content-Disposition" header field.
      String getEncoding()
      Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
      String getFileName()
      Get the filename associated with this Message.
      Flags getFlags()
      Return a Flags object containing the flags for this message.
      Address[] getFrom()
      Returns the value of the RFC 822 "From" header fields.
      String[] getHeader(String name)
      Get all the headers for this header_name.
      String getHeader(String name, String delimiter)
      Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
      InputStream getInputStream()
      Return a decoded input stream for this Message's "content".
      int getLineCount()
      Return the number of lines for the content of this message.
      Enumeration getMatchingHeaderLines(String[] names)
      Get matching header lines as an Enumeration of Strings.
      Enumeration getMatchingHeaders(String[] names)
      Return matching headers from this Message as an Enumeration of Header objects.
      String getMessageID()
      Returns the value of the "Message-ID" header field.
      Enumeration getNonMatchingHeaderLines(String[] names)
      Get non-matching header lines as an Enumeration of Strings.
      Enumeration getNonMatchingHeaders(String[] names)
      Return non-matching headers from this Message as an Enumeration of Header objects.
      InputStream getRawInputStream()
      Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
      Date getReceivedDate()
      Returns the Date on this message was received.
      Address[] getRecipients(Message.RecipientType type)
      Returns the recepients specified by the type.
      Address[] getReplyTo()
      Return the value of the RFC 822 "Reply-To" header field.
      Address getSender()
      Returns the value of the RFC 822 "Sender" header field.
      Date getSentDate()
      Returns the value of the RFC 822 "Date" field.
      int getSize()
      Return the size of the content of this message in bytes.
      String getSubject()
      Returns the value of the "Subject" header field.
      boolean isMimeType(String mimeType)
      Is this Part of the specified MIME type? This method compares only the primaryType and subType.
      boolean isSet(Flags.Flag flag)
      Check whether the flag specified in the flag argument is set in this message.
      protected void parse(InputStream is)
      Parse the InputStream setting the headers and content fields appropriately.
      void removeHeader(String name)
      Remove all headers with this name.
      Message reply(boolean replyToAll)
      Get a new Message suitable for a reply to this message.
      Message reply(boolean replyToAll, boolean setAnswered)
      Get a new Message suitable for a reply to this message.
      void saveChanges()
      Updates the appropriate header fields of this message to be consistent with the message's contents.
      void setContent(Multipart mp)
      This method sets the Message's content to a Multipart object.
      void setContent(Object o, String type)
      A convenience method for setting this Message's content.
      void setContentID(String cid)
      Set the "Content-ID" header field of this Message.
      void setContentLanguage(String[] languages)
      Set the "Content-Language" header of this MimePart.
      void setContentMD5(String md5)
      Set the "Content-MD5" header field of this Message.
      void setDataHandler(DataHandler dh)
      This method provides the mechanism to set this part's content.
      void setDescription(String description)
      Set the "Content-Description" header field for this Message.
      void setDescription(String description, String charset)
      Set the "Content-Description" header field for this Message.
      void setDisposition(String disposition)
      Set the "Content-Disposition" header field of this Message.
      void setFileName(String filename)
      Set the filename associated with this part, if possible.
      void setFlags(Flags flag, boolean set)
      Set the flags for this message.
      void setFrom()
      Set the RFC 822 "From" header field using the value of the InternetAddress.getLocalAddress method.
      void setFrom(Address address)
      Set the RFC 822 "From" header field.
      void setFrom(String address)
      Set the RFC 822 "From" header field.
      void setHeader(String name, String value)
      Set the value for this header_name.
      void setRecipients(Message.RecipientType type, Address[] addresses)
      Set the specified recipient type to the given addresses.
      void setRecipients(Message.RecipientType type, String addresses)
      Set the specified recipient type to the given addresses.
      void setReplyTo(Address[] addresses)
      Set the RFC 822 "Reply-To" header field.
      void setSender(Address address)
      Set the RFC 822 "Sender" header field.
      void setSentDate(Date d)
      Set the RFC 822 "Date" header field.
      void setSubject(String subject)
      Set the "Subject" header field.
      void setSubject(String subject, String charset)
      Set the "Subject" header field.
      void setText(String text)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
      void setText(String text, String charset)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
      void setText(String text, String charset, String subtype)
      Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.
      protected void updateHeaders()
      Called by the saveChanges method to actually update the MIME headers.
      protected void updateMessageID()
      Update the Message-ID header.
      void writeTo(OutputStream os)
      Output the message as an RFC 822 format stream.
      void writeTo(OutputStream os, String[] ignoreList)
      Output the message as an RFC 822 format stream, without specified headers.

      • Methods inherited from class javax.mail.Message

        addRecipient, getFolder, getMessageNumber, getSession, isExpunged, match, setExpunged, setFlag, setMessageNumber, setRecipient

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • dh

        protected DataHandler dh
        The DataHandler object representing this Message's content.

      • content

        protected byte[] content
        Byte array that holds the bytes of this Message's content.

      • contentStream

        protected InputStream contentStream
        If the data for this message was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this message. In this case, content will be null.
        Since:
        JavaMail 1.2

      • headers

        protected InternetHeaders headers
        The InternetHeaders object that stores the header of this message.

      • flags

        protected Flags flags
        The Flags for this message.

      • modified

        protected boolean modified
        A flag indicating whether the message has been modified. If the message has not been modified, any data in the content array is assumed to be valid and is used directly in the writeTo method. This flag is set to true when an empty message is created or when the saveChanges method is called.
        Since:
        JavaMail 1.2

      • saved

        protected boolean saved
        Does the saveChanges method need to be called on this message? This flag is set to false by the public constructor and set to true by the saveChanges method. The writeTo method checks this flag and calls the saveChanges method as necessary. This avoids the common mistake of forgetting to call the saveChanges method on a newly constructed message.
        Since:
        JavaMail 1.2

      • cachedContent

        protected Object cachedContent
        If our content is a Multipart or Message object, we save it the first time it's created by parsing a stream so that changes to the contained objects will not be lost.

        If this field is not null, it's return by the getContent() method. The getContent() method sets this field if it would return a Multipart or MimeMessage object. This field is is cleared by the setDataHandler(javax.activation.DataHandler) method.

        Since:
        JavaMail 1.5

    • Constructor Detail

      • MimeMessage

        public MimeMessage(Session session)
        Default constructor. An empty message object is created. The headers field is set to an empty InternetHeaders object. The flags field is set to an empty Flags object. The modified flag is set to true.

      • MimeMessage

        public MimeMessage(Session session,
           InputStream is)
            throws MessagingException
        Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream. The InputStream will be left positioned at the end of the data for the message. Note that the input stream parse is done within this constructor itself.

        The input stream contains an entire MIME formatted message with headers and data.

        Parameters:
        session - Session object for this message
        is - the message input stream
        Throws:
        MessagingException

      • MimeMessage

        public MimeMessage(MimeMessage source)
            throws MessagingException
        Constructs a new MimeMessage with content initialized from the source MimeMessage. The new message is independent of the original.

        Note: The current implementation is rather inefficient, copying the data more times than strictly necessary.

        Parameters:
        source - the message to copy content from
        Throws:
        MessagingException
        Since:
        JavaMail 1.2

      • MimeMessage

        protected MimeMessage(Folder folder,
           int msgnum)
        Constructs an empty MimeMessage object with the given Folder and message number.

        This method is for providers subclassing MimeMessage.

      • MimeMessage

        protected MimeMessage(Folder folder,
           InputStream is,
           int msgnum)
               throws MessagingException
        Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream. The InputStream will be left positioned at the end of the data for the message. Note that the input stream parse is done within this constructor itself.

        This method is for providers subclassing MimeMessage.

        Parameters:
        folder - The containing folder.
        is - the message input stream
        msgnum - Message number of this message within its folder
        Throws:
        MessagingException

      • MimeMessage

        protected MimeMessage(Folder folder,
           InternetHeaders headers,
           byte[] content,
           int msgnum)
               throws MessagingException
        Constructs a MimeMessage from the given InternetHeaders object and content. This method is for providers subclassing MimeMessage.
        Parameters:
        folder - The containing folder.
        headers - The headers
        content - The message content
        msgnum - Message number of this message within its folder
        Throws:
        MessagingException

    • Method Detail

      • parse

        protected void parse(InputStream is)
              throws MessagingException
        Parse the InputStream setting the headers and content fields appropriately. Also resets the modified flag.

        This method is intended for use by subclasses that need to control when the InputStream is parsed.

        Parameters:
        is - The message input stream
        Throws:
        MessagingException

      • getFrom

        public Address[] getFrom()
                  throws MessagingException
        Returns the value of the RFC 822 "From" header fields. If this header field is absent, the "Sender" header field is used. If the "Sender" header field is also absent, null is returned.

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getFrom in class Message
        Returns:
        Address object
        Throws:
        MessagingException
        See Also:
        headers

      • setFrom

        public void setFrom(Address address)
             throws MessagingException
        Set the RFC 822 "From" header field. Any existing values are replaced with the given address. If address is null, this header is removed.
        Specified by:
        setFrom in class Message
        Parameters:
        address - the sender of this message
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • setFrom

        public void setFrom(String address)
             throws MessagingException
        Set the RFC 822 "From" header field. Any existing values are replaced with the given addresses. If address is null, this header is removed.
        Parameters:
        address - the sender(s) of this message
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException
        Since:
        JvaMail 1.5

      • setFrom

        public void setFrom()
             throws MessagingException
        Set the RFC 822 "From" header field using the value of the InternetAddress.getLocalAddress method.
        Specified by:
        setFrom in class Message
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • addFrom

        public void addFrom(Address[] addresses)
             throws MessagingException
        Add the specified addresses to the existing "From" field. If the "From" field does not already exist, it is created.
        Specified by:
        addFrom in class Message
        Parameters:
        addresses - the senders of this message
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • getSender

        public Address getSender()
                  throws MessagingException
        Returns the value of the RFC 822 "Sender" header field. If the "Sender" header field is absent, null is returned.

        This implementation uses the getHeader method to obtain the requisite header field.

        Returns:
        Address object
        Throws:
        MessagingException
        Since:
        JavaMail 1.3
        See Also:
        headers

      • setSender

        public void setSender(Address address)
               throws MessagingException
        Set the RFC 822 "Sender" header field. Any existing values are replaced with the given address. If address is null, this header is removed.
        Parameters:
        address - the sender of this message
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException
        Since:
        JavaMail 1.3

      • getRecipients

        public Address[] getRecipients(Message.RecipientType type)
                        throws MessagingException
        Returns the recepients specified by the type. The mapping between the type and the corresponding RFC 822 header is as follows:
                        Message.RecipientType.TO                "To"
                Message.RecipientType.CC                "Cc"
                Message.RecipientType.BCC               "Bcc"
                MimeMessage.RecipientType.NEWSGROUPS    "Newsgroups"

        Returns null if the header specified by the type is not found or if its value is empty.

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getRecipients in class Message
        Parameters:
        type - Type of recepient
        Returns:
        array of Address objects
        Throws:
        MessagingException - if header could not be retrieved
        AddressException - if the header is misformatted
        See Also:
        headers, Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC, MimeMessage.RecipientType.NEWSGROUPS

      • getAllRecipients

        public Address[] getAllRecipients()
                           throws MessagingException
        Get all the recipient addresses for the message. Extracts the TO, CC, BCC, and NEWSGROUPS recipients.
        Overrides:
        getAllRecipients in class Message
        Returns:
        array of Address objects
        Throws:
        MessagingException
        See Also:
        Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC, MimeMessage.RecipientType.NEWSGROUPS

      • setRecipients

        public void setRecipients(Message.RecipientType type,
                 Address[] addresses)
                   throws MessagingException
        Set the specified recipient type to the given addresses. If the address parameter is null, the corresponding recipient field is removed.
        Specified by:
        setRecipients in class Message
        Parameters:
        type - Recipient type
        addresses - Addresses
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException
        See Also:
        getRecipients(javax.mail.Message.RecipientType)

      • setRecipients

        public void setRecipients(Message.RecipientType type,
                 String addresses)
                   throws MessagingException
        Set the specified recipient type to the given addresses. If the address parameter is null, the corresponding recipient field is removed.
        Parameters:
        type - Recipient type
        addresses - Addresses
        Throws:
        AddressException - if the attempt to parse the addresses String fails
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException
        Since:
        JavaMail 1.2
        See Also:
        getRecipients(javax.mail.Message.RecipientType)

      • addRecipients

        public void addRecipients(Message.RecipientType type,
                 Address[] addresses)
                   throws MessagingException
        Add the given addresses to the specified recipient type.
        Specified by:
        addRecipients in class Message
        Parameters:
        type - Recipient type
        addresses - Addresses
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • addRecipients

        public void addRecipients(Message.RecipientType type,
                 String addresses)
                   throws MessagingException
        Add the given addresses to the specified recipient type.
        Parameters:
        type - Recipient type
        addresses - Addresses
        Throws:
        AddressException - if the attempt to parse the addresses String fails
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException
        Since:
        JavaMail 1.2

      • getReplyTo

        public Address[] getReplyTo()
                     throws MessagingException
        Return the value of the RFC 822 "Reply-To" header field. If this header is unavailable or its value is absent, then the getFrom method is called and its value is returned. This implementation uses the getHeader method to obtain the requisite header field.
        Overrides:
        getReplyTo in class Message
        Returns:
        addresses to which replies should be directed
        Throws:
        MessagingException
        See Also:
        headers

      • setReplyTo

        public void setReplyTo(Address[] addresses)
                throws MessagingException
        Set the RFC 822 "Reply-To" header field. If the address parameter is null, this header is removed.
        Overrides:
        setReplyTo in class Message
        Parameters:
        addresses - addresses to which replies should be directed
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException
        MethodNotSupportedException - if the underlying implementation does not support setting this attribute

      • getSubject

        public String getSubject()
                  throws MessagingException
        Returns the value of the "Subject" header field. Returns null if the subject field is unavailable or its value is absent.

        If the subject is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as is.

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getSubject in class Message
        Returns:
        Subject
        Throws:
        MessagingException
        See Also:
        headers

      • setSubject

        public void setSubject(String subject)
                throws MessagingException
        Set the "Subject" header field. If the subject contains non US-ASCII characters, it will be encoded using the platform's default charset. If the subject contains only US-ASCII characters, no encoding is done and it is used as-is. If the subject is null, the existing "Subject" field is removed.

        The application must ensure that the subject does not contain any line breaks.

        Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

        Specified by:
        setSubject in class Message
        Parameters:
        subject - The subject
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
        MessagingException

      • setSubject

        public void setSubject(String subject,
              String charset)
                throws MessagingException
        Set the "Subject" header field. If the subject contains non US-ASCII characters, it will be encoded using the specified charset. If the subject contains only US-ASCII characters, no encoding is done and it is used as-is. If the subject is null, the existing "Subject" header field is removed.

        The application must ensure that the subject does not contain any line breaks.

        Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

        Parameters:
        subject - The subject
        charset - The charset
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
        MessagingException

      • getSentDate

        public Date getSentDate()
                 throws MessagingException
        Returns the value of the RFC 822 "Date" field. This is the date on which this message was sent. Returns null if this field is unavailable or its value is absent.

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getSentDate in class Message
        Returns:
        The sent Date
        Throws:
        MessagingException

      • setSentDate

        public void setSentDate(Date d)
                 throws MessagingException
        Set the RFC 822 "Date" header field. This is the date on which the creator of the message indicates that the message is complete and ready for delivery. If the date parameter is null, the existing "Date" field is removed.
        Specified by:
        setSentDate in class Message
        Parameters:
        d - the sent date of this message
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • getReceivedDate

        public Date getReceivedDate()
                     throws MessagingException
        Returns the Date on this message was received. Returns null if this date cannot be obtained.

        Note that RFC 822 does not define a field for the received date. Hence only implementations that can provide this date need return a valid value.

        This implementation returns null.

        Specified by:
        getReceivedDate in class Message
        Returns:
        the date this message was received
        Throws:
        MessagingException

      • getSize

        public int getSize()
            throws MessagingException
        Return the size of the content of this message in bytes. Return -1 if the size cannot be determined.

        Note that this number may not be an exact measure of the content size and may or may not account for any transfer encoding of the content.

        This implementation returns the size of the content array (if not null), or, if contentStream is not null, and the available method returns a positive number, it returns that number as the size. Otherwise, it returns -1.

        Specified by:
        getSize in interface Part
        Returns:
        size of content in bytes
        Throws:
        MessagingException

      • getLineCount

        public int getLineCount()
                 throws MessagingException
        Return the number of lines for the content of this message. Return -1 if this number cannot be determined.

        Note that this number may not be an exact measure of the content length and may or may not account for any transfer encoding of the content.

        This implementation returns -1.

        Specified by:
        getLineCount in interface Part
        Returns:
        number of lines in the content.
        Throws:
        MessagingException

      • getContentType

        public String getContentType()
                      throws MessagingException
        Returns the value of the RFC 822 "Content-Type" header field. This represents the content-type of the content of this message. This value must not be null. If this field is unavailable, "text/plain" should be returned.

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getContentType in interface Part
        Returns:
        The ContentType of this part
        Throws:
        MessagingException
        See Also:
        DataHandler

      • isMimeType

        public boolean isMimeType(String mimeType)
                   throws MessagingException
        Is this Part of the specified MIME type? This method compares only the primaryType and subType. The parameters of the content types are ignored.

        For example, this method will return true when comparing a Part of content type "text/plain" with "text/plain; charset=foobar".

        If the subType of mimeType is the special character '*', then the subtype is ignored during the comparison.

        Specified by:
        isMimeType in interface Part
        Throws:
        MessagingException

      • getDisposition

        public String getDisposition()
                      throws MessagingException
        Returns the value of the "Content-Disposition" header field. This represents the disposition of this part. The disposition describes how the part should be presented to the user.

        If the Content-Disposition field is unavailable, null is returned.

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getDisposition in interface Part
        Returns:
        disposition of this part, or null if unknown
        Throws:
        MessagingException
        See Also:
        Part.ATTACHMENT, Part.INLINE, Part.getFileName()

      • setDisposition

        public void setDisposition(String disposition)
                    throws MessagingException
        Set the "Content-Disposition" header field of this Message. If disposition is null, any existing "Content-Disposition" header field is removed.
        Specified by:
        setDisposition in interface Part
        Parameters:
        disposition - disposition of this part
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException
        See Also:
        Part.ATTACHMENT, Part.INLINE, Part.setFileName(java.lang.String)

      • getEncoding

        public String getEncoding()
                   throws MessagingException
        Returns the content transfer encoding from the "Content-Transfer-Encoding" header field. Returns null if the header is unavailable or its value is absent.

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getEncoding in interface MimePart
        Returns:
        content-transfer-encoding
        Throws:
        MessagingException

      • getContentID

        public String getContentID()
                    throws MessagingException
        Returns the value of the "Content-ID" header field. Returns null if the field is unavailable or its value is absent.

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getContentID in interface MimePart
        Returns:
        content-ID
        Throws:
        MessagingException

      • setContentID

        public void setContentID(String cid)
                  throws MessagingException
        Set the "Content-ID" header field of this Message. If the cid parameter is null, any existing "Content-ID" is removed.
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • getContentMD5

        public String getContentMD5()
                     throws MessagingException
        Return the value of the "Content-MD5" header field. Returns null if this field is unavailable or its value is absent.

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getContentMD5 in interface MimePart
        Returns:
        content-MD5
        Throws:
        MessagingException

      • setContentMD5

        public void setContentMD5(String md5)
                   throws MessagingException
        Set the "Content-MD5" header field of this Message.
        Specified by:
        setContentMD5 in interface MimePart
        Parameters:
        md5 - the MD5 value
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • getDescription

        public String getDescription()
                      throws MessagingException
        Returns the "Content-Description" header field of this Message. This typically associates some descriptive information with this part. Returns null if this field is unavailable or its value is absent.

        If the Content-Description field is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as-is

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getDescription in interface Part
        Returns:
        content-description
        Throws:
        MessagingException

      • setDescription

        public void setDescription(String description)
                    throws MessagingException
        Set the "Content-Description" header field for this Message. If the description parameter is null, then any existing "Content-Description" fields are removed.

        If the description contains non US-ASCII characters, it will be encoded using the platform's default charset. If the description contains only US-ASCII characters, no encoding is done and it is used as-is.

        Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

        Specified by:
        setDescription in interface Part
        Parameters:
        description - content-description
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
        MessagingException

      • setDescription

        public void setDescription(String description,
                  String charset)
                    throws MessagingException
        Set the "Content-Description" header field for this Message. If the description parameter is null, then any existing "Content-Description" fields are removed.

        If the description contains non US-ASCII characters, it will be encoded using the specified charset. If the description contains only US-ASCII characters, no encoding is done and it is used as-is.

        Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

        Parameters:
        description - Description
        charset - Charset for encoding
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
        MessagingException

      • getContentLanguage

        public String[] getContentLanguage()
                            throws MessagingException
        Get the languages specified in the "Content-Language" header field of this message. The Content-Language header is defined by RFC 1766. Returns null if this field is unavailable or its value is absent.

        This implementation uses the getHeader method to obtain the requisite header field.

        Specified by:
        getContentLanguage in interface MimePart
        Returns:
        value of content-language header.
        Throws:
        MessagingException

      • setContentLanguage

        public void setContentLanguage(String[] languages)
                        throws MessagingException
        Set the "Content-Language" header of this MimePart. The Content-Language header is defined by RFC 1766.
        Specified by:
        setContentLanguage in interface MimePart
        Parameters:
        languages - array of language tags
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • getMessageID

        public String getMessageID()
                    throws MessagingException
        Returns the value of the "Message-ID" header field. Returns null if this field is unavailable or its value is absent.

        The default implementation provided here uses the getHeader method to return the value of the "Message-ID" field.

        Returns:
        Message-ID
        Throws:
        MessagingException - if the retrieval of this field causes any exception.
        Since:
        JavaMail 1.1
        See Also:
        MessageIDTerm

      • getFileName

        public String getFileName()
                   throws MessagingException
        Get the filename associated with this Message.

        Returns the value of the "filename" parameter from the "Content-Disposition" header field of this message. If it's not available, returns the value of the "name" parameter from the "Content-Type" header field of this BodyPart. Returns null if both are absent.

        If the mail.mime.encodefilename System property is set to true, the MimeUtility.decodeText method will be used to decode the filename. While such encoding is not supported by the MIME spec, many mailers use this technique to support non-ASCII characters in filenames. The default value of this property is false.

        Specified by:
        getFileName in interface Part
        Returns:
        filename
        Throws:
        MessagingException

      • setFileName

        public void setFileName(String filename)
                 throws MessagingException
        Set the filename associated with this part, if possible.

        Sets the "filename" parameter of the "Content-Disposition" header field of this message.

        If the mail.mime.encodefilename System property is set to true, the MimeUtility.encodeText method will be used to encode the filename. While such encoding is not supported by the MIME spec, many mailers use this technique to support non-ASCII characters in filenames. The default value of this property is false.

        Specified by:
        setFileName in interface Part
        Parameters:
        filename - Filename to associate with this part
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • getInputStream

        public InputStream getInputStream()
                           throws IOException,
                                  MessagingException
        Return a decoded input stream for this Message's "content".

        This implementation obtains the input stream from the DataHandler, that is, it invokes getDataHandler().getInputStream().

        Specified by:
        getInputStream in interface Part
        Returns:
        an InputStream
        Throws:
        MessagingException
        IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
        See Also:
        getContentStream(), DataHandler.getInputStream()

      • getContentStream

        protected InputStream getContentStream()
                                throws MessagingException
        Produce the raw bytes of the content. This method is used during parsing, to create a DataHandler object for the content. Subclasses that can provide a separate input stream for just the message content might want to override this method.

        This implementation returns a SharedInputStream, if contentStream is not null. Otherwise, it returns a ByteArrayInputStream constructed out of the content byte array.

        Throws:
        MessagingException
        See Also:
        content

      • getRawInputStream

        public InputStream getRawInputStream()
                              throws MessagingException
        Return an InputStream to the raw data with any Content-Transfer-Encoding intact. This method is useful if the "Content-Transfer-Encoding" header is incorrect or corrupt, which would prevent the getInputStream method or getContent method from returning the correct data. In such a case the application may use this method and attempt to decode the raw data itself.

        This implementation simply calls the getContentStream method.

        Throws:
        MessagingException
        Since:
        JavaMail 1.2
        See Also:
        getInputStream(), getContentStream()

      • getDataHandler

        public DataHandler getDataHandler()
                           throws MessagingException
        Return a DataHandler for this Message's content.

        The implementation provided here works as follows. Note the use of the getContentStream method to generate the byte stream for the content. Also note that any transfer-decoding is done automatically within this method.

          getDataHandler() {
      if (dh == null) {
          dh = new DataHandler(new MimePartDataSource(this));
      }
      return dh;
  }

  class MimePartDataSource implements DataSource {
      public getInputStream() {
          return MimeUtility.decode(
                     getContentStream(), getEncoding());
      }

                ....
  }

        Specified by:
        getDataHandler in interface Part
        Returns:
        DataHandler for the content
        Throws:
        MessagingException

      • getContent

        public Object getContent()
                  throws IOException,
                         MessagingException
        Return the content as a Java object. The type of this object is dependent on the content itself. For example, the native format of a "text/plain" content is usually a String object. The native format for a "multipart" message is always a Multipart subclass. For content types that are unknown to the DataHandler system, an input stream is returned as the content.

        This implementation obtains the content from the DataHandler, that is, it invokes getDataHandler().getContent(). If the content is a Multipart or Message object and was created by parsing a stream, the object is cached and returned in subsequent calls so that modifications to the content will not be lost.

        Specified by:
        getContent in interface Part
        Returns:
        Object
        Throws:
        MessagingException
        IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
        See Also:
        Part, DataHandler.getContent()

      • setDataHandler

        public void setDataHandler(DataHandler dh)
                    throws MessagingException
        This method provides the mechanism to set this part's content. The given DataHandler object should wrap the actual content.
        Specified by:
        setDataHandler in interface Part
        Parameters:
        dh - The DataHandler for the content.
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • setContent

        public void setContent(Object o,
              String type)
                throws MessagingException
        A convenience method for setting this Message's content.

        The content is wrapped in a DataHandler object. Note that a DataContentHandler class for the specified type should be available to the JavaMail implementation for this to work right. i.e., to do setContent(foobar, "application/x-foobar"), a DataContentHandler for "application/x-foobar" should be installed. Refer to the Java Activation Framework for more information.

        Specified by:
        setContent in interface Part
        Parameters:
        o - the content object
        type - Mime type of the object
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • setText

        public void setText(String text)
             throws MessagingException
        Convenience method that sets the given String as this part's content, with a MIME type of "text/plain". If the string contains non US-ASCII characters. it will be encoded using the platform's default charset. The charset is also used to set the "charset" parameter.

        Note that there may be a performance penalty if text is large, since this method may have to scan all the characters to determine what charset to use.

        If the charset is already known, use the setText method that takes the charset parameter.

        Specified by:
        setText in interface MimePart
        Specified by:
        setText in interface Part
        Parameters:
        text - the text content to set
        Throws:
        MessagingException - if an error occurs
        See Also:
        setText(String text, String charset)

      • setText

        public void setText(String text,
           String charset)
             throws MessagingException
        Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.
        Specified by:
        setText in interface MimePart
        Parameters:
        text - the text content to set
        charset - the charset to use for the text
        Throws:
        MessagingException - if an error occurs

      • setText

        public void setText(String text,
           String charset,
           String subtype)
             throws MessagingException
        Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.
        Specified by:
        setText in interface MimePart
        Parameters:
        text - the text content to set
        charset - the charset to use for the text
        subtype - the MIME subtype to use (e.g., "html")
        Throws:
        MessagingException - if an error occurs
        Since:
        JavaMail 1.4

      • setContent

        public void setContent(Multipart mp)
                throws MessagingException
        This method sets the Message's content to a Multipart object.
        Specified by:
        setContent in interface Part
        Parameters:
        mp - The multipart object that is the Message's content
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification of existing values
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • reply

        public Message reply(boolean replyToAll)
              throws MessagingException
        Get a new Message suitable for a reply to this message. The new Message will have its attributes and headers set up appropriately. Note that this new message object will be empty, i.e., it will not have a "content". These will have to be suitably filled in by the client.

        If replyToAll is set, the new Message will be addressed to all recipients of this message. Otherwise, the reply will be addressed to only the sender of this message (using the value of the getReplyTo method).

        The "Subject" field is filled in with the original subject prefixed with "Re:" (unless it already starts with "Re:"). The "In-Reply-To" header is set in the new message if this message has a "Message-Id" header. The ANSWERED flag is set in this message. The current implementation also sets the "References" header in the new message to include the contents of the "References" header (or, if missing, the "In-Reply-To" header) in this message, plus the contents of the "Message-Id" header of this message, as described in RFC 2822.

        Specified by:
        reply in class Message
        Parameters:
        replyToAll - reply should be sent to all recipients of this message
        Returns:
        the reply Message
        Throws:
        MessagingException

      • reply

        public Message reply(boolean replyToAll,
            boolean setAnswered)
              throws MessagingException
        Get a new Message suitable for a reply to this message. The new Message will have its attributes and headers set up appropriately. Note that this new message object will be empty, i.e., it will not have a "content". These will have to be suitably filled in by the client.

        If replyToAll is set, the new Message will be addressed to all recipients of this message. Otherwise, the reply will be addressed to only the sender of this message (using the value of the getReplyTo method).

        If setAnswered is set, the ANSWERED flag is set in this message.

        The "Subject" field is filled in with the original subject prefixed with "Re:" (unless it already starts with "Re:"). The "In-Reply-To" header is set in the new message if this message has a "Message-Id" header. The current implementation also sets the "References" header in the new message to include the contents of the "References" header (or, if missing, the "In-Reply-To" header) in this message, plus the contents of the "Message-Id" header of this message, as described in RFC 2822.

        Parameters:
        replyToAll - reply should be sent to all recipients of this message
        setAnswered - set the ANSWERED flag in this message?
        Returns:
        the reply Message
        Throws:
        MessagingException
        Since:
        JavaMail 1.5

      • writeTo

        public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
        Output the message as an RFC 822 format stream.

        Note that, depending on how the messag was constructed, it may use a variety of line termination conventions. Generally the output should be sent through an appropriate FilterOutputStream that converts the line terminators to the desired form, either CRLF for MIME compatibility and for use in Internet protocols, or the local platform's line terminator for storage in a local text file.

        This implementation calls the writeTo(OutputStream, String[]) method with a null ignore list.

        Specified by:
        writeTo in interface Part
        Throws:
        IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
        MessagingException
        See Also:
        DataHandler.writeTo(java.io.OutputStream)

      • writeTo

        public void writeTo(OutputStream os,
           String[] ignoreList)
             throws IOException,
                    MessagingException
        Output the message as an RFC 822 format stream, without specified headers. If the saved flag is not set, the saveChanges method is called. If the modified flag is not set and the content array is not null, the content array is written directly, after writing the appropriate message headers.
        Throws:
        MessagingException
        IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
        See Also:
        DataHandler.writeTo(java.io.OutputStream)

      • getHeader

        public String[] getHeader(String name)
                   throws MessagingException
        Get all the headers for this header_name. Note that certain headers may be encoded as per RFC 2047 if they contain non US-ASCII characters and these should be decoded.

        This implementation obtains the headers from the headers InternetHeaders object.

        Specified by:
        getHeader in interface Part
        Parameters:
        name - name of header
        Returns:
        array of headers
        Throws:
        MessagingException
        See Also:
        MimeUtility

      • getHeader

        public String getHeader(String name,
               String delimiter)
                 throws MessagingException
        Get all the headers for this header name, returned as a single String, with headers separated by the delimiter. If the delimiter is null, only the first header is returned.
        Specified by:
        getHeader in interface MimePart
        Parameters:
        name - the name of this header
        delimiter - separator between values
        Returns:
        the value fields for all headers with this name
        Throws:
        MessagingException

      • setHeader

        public void setHeader(String name,
             String value)
               throws MessagingException
        Set the value for this header_name. Replaces all existing header values with this new value. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must have been encoded by the caller as per the rules of RFC 2047.
        Specified by:
        setHeader in interface Part
        Parameters:
        name - header name
        value - header value
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException
        See Also:
        MimeUtility

      • addHeader

        public void addHeader(String name,
             String value)
               throws MessagingException
        Add this value to the existing values for this header_name. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must have been encoded as per the rules of RFC 2047.
        Specified by:
        addHeader in interface Part
        Parameters:
        name - header name
        value - header value
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException
        See Also:
        MimeUtility

      • removeHeader

        public void removeHeader(String name)
                  throws MessagingException
        Remove all headers with this name.
        Specified by:
        removeHeader in interface Part
        Parameters:
        name - the name of this header
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • getAllHeaders

        public Enumeration getAllHeaders()
                          throws MessagingException
        Return all the headers from this Message as an enumeration of Header objects.

        Note that certain headers may be encoded as per RFC 2047 if they contain non US-ASCII characters and these should be decoded.

        This implementation obtains the headers from the headers InternetHeaders object.

        Specified by:
        getAllHeaders in interface Part
        Returns:
        array of header objects
        Throws:
        MessagingException
        See Also:
        MimeUtility

      • getMatchingHeaders

        public Enumeration getMatchingHeaders(String[] names)
                               throws MessagingException
        Return matching headers from this Message as an Enumeration of Header objects. This implementation obtains the headers from the headers InternetHeaders object.
        Specified by:
        getMatchingHeaders in interface Part
        Returns:
        enumeration of Header objects
        Throws:
        MessagingException

      • getNonMatchingHeaders

        public Enumeration getNonMatchingHeaders(String[] names)
                                  throws MessagingException
        Return non-matching headers from this Message as an Enumeration of Header objects. This implementation obtains the header from the headers InternetHeaders object.
        Specified by:
        getNonMatchingHeaders in interface Part
        Returns:
        enumeration of Header objects
        Throws:
        MessagingException

      • addHeaderLine

        public void addHeaderLine(String line)
                   throws MessagingException
        Add a raw RFC 822 header-line.
        Specified by:
        addHeaderLine in interface MimePart
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • getAllHeaderLines

        public Enumeration getAllHeaderLines()
                              throws MessagingException
        Get all header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header-line, containing both the "name" and "value" field.
        Specified by:
        getAllHeaderLines in interface MimePart
        Throws:
        MessagingException

      • getMatchingHeaderLines

        public Enumeration getMatchingHeaderLines(String[] names)
                                   throws MessagingException
        Get matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header-line, containing both the "name" and "value" field.
        Specified by:
        getMatchingHeaderLines in interface MimePart
        Throws:
        MessagingException

      • getNonMatchingHeaderLines

        public Enumeration getNonMatchingHeaderLines(String[] names)
                                      throws MessagingException
        Get non-matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header-line, containing both the "name" and "value" field.
        Specified by:
        getNonMatchingHeaderLines in interface MimePart
        Throws:
        MessagingException

      • getFlags

        public Flags getFlags()
               throws MessagingException
        Return a Flags object containing the flags for this message.

        Note that a clone of the internal Flags object is returned, so modifying the returned Flags object will not affect the flags of this message.

        Specified by:
        getFlags in class Message
        Returns:
        Flags object containing the flags for this message
        Throws:
        MessagingException
        See Also:
        Flags

      • isSet

        public boolean isSet(Flags.Flag flag)
              throws MessagingException
        Check whether the flag specified in the flag argument is set in this message.

        This implementation checks this message's internal flags object.

        Overrides:
        isSet in class Message
        Parameters:
        flag - the flag
        Returns:
        value of the specified flag for this message
        Throws:
        MessagingException
        See Also:
        Flags.Flag, Flags.Flag.ANSWERED, Flags.Flag.DELETED, Flags.Flag.DRAFT, Flags.Flag.FLAGGED, Flags.Flag.RECENT, Flags.Flag.SEEN

      • setFlags

        public void setFlags(Flags flag,
            boolean set)
              throws MessagingException
        Set the flags for this message.

        This implementation modifies the flags field.

        Specified by:
        setFlags in class Message
        Parameters:
        flag - Flags object containing the flags to be set
        set - the value to be set
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException
        See Also:
        MessageChangedEvent

      • saveChanges

        public void saveChanges()
                 throws MessagingException
        Updates the appropriate header fields of this message to be consistent with the message's contents. If this message is contained in a Folder, any changes made to this message are committed to the containing folder.

        If any part of a message's headers or contents are changed, saveChanges must be called to ensure that those changes are permanent. Otherwise, any such modifications may or may not be saved, depending on the folder implementation.

        Messages obtained from folders opened READ_ONLY should not be modified and saveChanges should not be called on such messages.

        This method sets the modified flag to true, the save flag to true, and then calls the updateHeaders method.

        Specified by:
        saveChanges in class Message
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • updateMessageID

        protected void updateMessageID()
                        throws MessagingException
        Update the Message-ID header. This method is called by the updateHeaders and allows a subclass to override only the algorithm for choosing a Message-ID.
        Throws:
        MessagingException
        Since:
        JavaMail 1.4

      • updateHeaders

        protected void updateHeaders()
                      throws MessagingException
        Called by the saveChanges method to actually update the MIME headers. The implementation here sets the Content-Transfer-Encoding header (if needed and not already set), the MIME-Version header and the Message-ID header. Also, if the content of this message is a MimeMultipart, its updateHeaders method is called.

        If the cachedContent field is not null (that is, it references a Multipart or Message object), then that object is used to set a new DataHandler, any stream data used to create this object is discarded, and the cachedContent field is cleared.

        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this message is obtained from a READ_ONLY folder.
        MessagingException

      • createInternetHeaders

        protected InternetHeaders createInternetHeaders(InputStream is)
                                         throws MessagingException
        Create and return an InternetHeaders object that loads the headers from the given InputStream. Subclasses can override this method to return a subclass of InternetHeaders, if necessary. This implementation simply constructs and returns an InternetHeaders object.
        Parameters:
        is - the InputStream to read the headers from
        Throws:
        MessagingException
        Since:
        JavaMail 1.2

      • createMimeMessage

        protected MimeMessage createMimeMessage(Session session)
                                 throws MessagingException
        Create and return a MimeMessage object. The reply method uses this method to create the MimeMessage object that it will return. Subclasses can override this method to return a subclass of MimeMessage. This implementation simply constructs and returns a MimeMessage object using the supplied Session.
        Parameters:
        session - the Session to use for the new message
        Returns:
        the new MimeMessage object
        Throws:
        MessagingException
        Since:
        JavaMail 1.4
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MimeMessage.RecipientType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class MimeMessage.RecipientType

  • java.lang.Object
    • javax.mail.Message.RecipientType
      • javax.mail.internet.MimeMessage.RecipientType
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    MimeMessage

    public static class MimeMessage.RecipientType
extends Message.RecipientType
    This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes. The one additional RecipientType currently defined here is NEWSGROUPS.
    See Also:
    Message.RecipientType, Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static MimeMessage.RecipientType NEWSGROUPS
      The "Newsgroup" (Usenet news) recipients.

      • Fields inherited from class javax.mail.Message.RecipientType

        BCC, CC, TO, type

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | MimeMessage.RecipientType(String type)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected Object readResolve()
      When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class.

      • Methods inherited from class javax.mail.Message.RecipientType

        toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • NEWSGROUPS

        public static final MimeMessage.RecipientType NEWSGROUPS
        The "Newsgroup" (Usenet news) recipients.

    • Constructor Detail

      • MimeMessage.RecipientType

        protected MimeMessage.RecipientType(String type)

    • Method Detail

      • readResolve

        protected Object readResolve()
                      throws ObjectStreamException
        Description copied from class: Message.RecipientType
        When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class. Subclasses must implement their own readResolve method that checks for their known instances before calling this super method.
        Overrides:
        readResolve in class Message.RecipientType
        Throws:
        ObjectStreamException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MimeMultipart (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class MimeMultipart

  • java.lang.Object
    • javax.mail.Multipart
      • javax.mail.internet.MimeMultipart

  • public class MimeMultipart
extends Multipart
    The MimeMultipart class is an implementation of the abstract Multipart class that uses MIME conventions for the multipart data.

    A MimeMultipart is obtained from a MimePart whose primary type is "multipart" (by invoking the part's getContent() method) or it can be created by a client as part of creating a new MimeMessage.

    The default multipart subtype is "mixed". The other multipart subtypes, such as "alternative", "related", and so on, can be implemented as subclasses of MimeMultipart with additional methods to implement the additional semantics of that type of multipart content. The intent is that service providers, mail JavaBean writers and mail clients will write many such subclasses and their Command Beans, and will install them into the JavaBeans Activation Framework, so that any JavaMail implementation and its clients can transparently find and use these classes. Thus, a MIME multipart handler is treated just like any other type handler, thereby decoupling the process of providing multipart handlers from the JavaMail API. Lacking these additional MimeMultipart subclasses, all subtypes of MIME multipart data appear as MimeMultipart objects.

    An application can directly construct a MIME multipart object of any subtype by using the MimeMultipart(String subtype) constructor. For example, to create a "multipart/alternative" object, use new MimeMultipart("alternative").

    The mail.mime.multipart.ignoremissingendboundary property may be set to false to cause a MessagingException to be thrown if the multipart data does not end with the required end boundary line. If this property is set to true or not set, missing end boundaries are not considered an error and the final body part ends at the end of the data.

    The mail.mime.multipart.ignoremissingboundaryparameter System property may be set to false to cause a MessagingException to be thrown if the Content-Type of the MimeMultipart does not include a boundary parameter. If this property is set to true or not set, the multipart parsing code will look for a line that looks like a bounary line and use that as the boundary separating the parts.

    The mail.mime.multipart.ignoreexistingboundaryparameter System property may be set to true to cause any boundary to be ignored and instead search for a boundary line in the message as with mail.mime.multipart.ignoremissingboundaryparameter.

    Normally, when writing out a MimeMultipart that contains no body parts, or when trying to parse a multipart message with no body parts, a MessagingException is thrown. The MIME spec does not allow multipart content with no body parts. The mail.mime.multipart.allowempty System property may be set to true to override this behavior. When writing out such a MimeMultipart, a single empty part will be included. When reading such a multipart, a MimeMultipart will be created with no body parts.

    Author:
    John Mani, Bill Shannon, Max Spivak

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean allowEmpty
      Flag corresponding to the "mail.mime.multipart.allowempty" property, set in the initializeProperties() method called from constructors and the parse method.
      protected boolean complete
      Have we seen the final bounary line?
      protected DataSource ds
      The DataSource supplying our InputStream.
      protected boolean ignoreExistingBoundaryParameter
      Flag corresponding to the "mail.mime.multipart.ignoreexistingboundaryparameter" property, set in the initializeProperties() method called from constructors and the parse method.
      protected boolean ignoreMissingBoundaryParameter
      Flag corresponding to the "mail.mime.multipart.ignoremissingboundaryparameter" property, set in the initializeProperties() method called from constructors and the parse method.
      protected boolean ignoreMissingEndBoundary
      Flag corresponding to the "mail.mime.multipart.ignoremissingendboundary" property, set in the initializeProperties() method called from constructors and the parse method.
      protected boolean parsed
      Have we parsed the data from our InputStream yet? Defaults to true; set to false when our constructor is given a DataSource with an InputStream that we need to parse.
      protected String preamble
      The MIME multipart preamble text, the text that occurs before the first boundary line.

      • Fields inherited from class javax.mail.Multipart

        contentType, parent, parts

    • Constructor Summary

      Constructors
      Constructor and Description
      MimeMultipart()
      Default constructor.
      MimeMultipart(BodyPart... parts)
      Construct a MimeMultipart object of the default "mixed" subtype, and with the given body parts.
      MimeMultipart(DataSource ds)
      Constructs a MimeMultipart object and its bodyparts from the given DataSource.
      MimeMultipart(String subtype)
      Construct a MimeMultipart object of the given subtype.
      MimeMultipart(String subtype, BodyPart... parts)
      Construct a MimeMultipart object of the given subtype and with the given body parts.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addBodyPart(BodyPart part)
      Adds a Part to the multipart.
      void addBodyPart(BodyPart part, int index)
      Adds a BodyPart at position index.
      protected InternetHeaders createInternetHeaders(InputStream is)
      Create and return an InternetHeaders object that loads the headers from the given InputStream.
      protected MimeBodyPart createMimeBodyPart(InputStream is)
      Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
      protected MimeBodyPart createMimeBodyPart(InternetHeaders headers, byte[] content)
      Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
      BodyPart getBodyPart(int index)
      Get the specified BodyPart.
      BodyPart getBodyPart(String CID)
      Get the MimeBodyPart referred to by the given ContentID (CID).
      int getCount()
      Return the number of enclosed BodyPart objects.
      String getPreamble()
      Get the preamble text, if any, that appears before the first body part of this multipart.
      protected void initializeProperties()
      Initialize flags that control parsing behavior, based on System properties described above in the class documentation.
      boolean isComplete()
      Return true if the final boundary line for this multipart was seen.
      protected void parse()
      Parse the InputStream from our DataSource, constructing the appropriate MimeBodyParts.
      boolean removeBodyPart(BodyPart part)
      Remove the specified part from the multipart message.
      void removeBodyPart(int index)
      Remove the part at specified location (starting from 0).
      void setPreamble(String preamble)
      Set the preamble text to be included before the first body part.
      void setSubType(String subtype)
      Set the subtype.
      protected void updateHeaders()
      Update headers.
      void writeTo(OutputStream os)
      Iterates through all the parts and outputs each MIME part separated by a boundary.

      • Methods inherited from class javax.mail.Multipart

        getContentType, getParent, setMultipartDataSource, setParent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ds

        protected DataSource ds
        The DataSource supplying our InputStream.

      • parsed

        protected boolean parsed
        Have we parsed the data from our InputStream yet? Defaults to true; set to false when our constructor is given a DataSource with an InputStream that we need to parse.

      • complete

        protected boolean complete
        Have we seen the final bounary line?
        Since:
        JavaMail 1.5

      • preamble

        protected String preamble
        The MIME multipart preamble text, the text that occurs before the first boundary line.
        Since:
        JavaMail 1.5

      • ignoreMissingEndBoundary

        protected boolean ignoreMissingEndBoundary
        Flag corresponding to the "mail.mime.multipart.ignoremissingendboundary" property, set in the initializeProperties() method called from constructors and the parse method.
        Since:
        JavaMail 1.5

      • ignoreMissingBoundaryParameter

        protected boolean ignoreMissingBoundaryParameter
        Flag corresponding to the "mail.mime.multipart.ignoremissingboundaryparameter" property, set in the initializeProperties() method called from constructors and the parse method.
        Since:
        JavaMail 1.5

      • ignoreExistingBoundaryParameter

        protected boolean ignoreExistingBoundaryParameter
        Flag corresponding to the "mail.mime.multipart.ignoreexistingboundaryparameter" property, set in the initializeProperties() method called from constructors and the parse method.
        Since:
        JavaMail 1.5

      • allowEmpty

        protected boolean allowEmpty
        Flag corresponding to the "mail.mime.multipart.allowempty" property, set in the initializeProperties() method called from constructors and the parse method.
        Since:
        JavaMail 1.5

    • Constructor Detail

      • MimeMultipart

        public MimeMultipart()
        Default constructor. An empty MimeMultipart object is created. Its content type is set to "multipart/mixed". A unique boundary string is generated and this string is setup as the "boundary" parameter for the contentType field.

        MimeBodyParts may be added later.

      • MimeMultipart

        public MimeMultipart(String subtype)
        Construct a MimeMultipart object of the given subtype. A unique boundary string is generated and this string is setup as the "boundary" parameter for the contentType field. Calls the initializeProperties() method.

        MimeBodyParts may be added later.

      • MimeMultipart

        public MimeMultipart(BodyPart... parts)
              throws MessagingException
        Construct a MimeMultipart object of the default "mixed" subtype, and with the given body parts. More body parts may be added later.
        Throws:
        MessagingException
        Since:
        JavaMail 1.5

      • MimeMultipart

        public MimeMultipart(String subtype,
             BodyPart... parts)
              throws MessagingException
        Construct a MimeMultipart object of the given subtype and with the given body parts. More body parts may be added later.
        Throws:
        MessagingException
        Since:
        JavaMail 1.5

      • MimeMultipart

        public MimeMultipart(DataSource ds)
              throws MessagingException
        Constructs a MimeMultipart object and its bodyparts from the given DataSource.

        This constructor handles as a special case the situation where the given DataSource is a MultipartDataSource object. In this case, this method just invokes the superclass (i.e., Multipart) constructor that takes a MultipartDataSource object.

        Otherwise, the DataSource is assumed to provide a MIME multipart byte stream. The parsed flag is set to false. When the data for the body parts are needed, the parser extracts the "boundary" parameter from the content type of this DataSource, skips the 'preamble' and reads bytes till the terminating boundary and creates MimeBodyParts for each part of the stream.

        Parameters:
        ds - DataSource, can be a MultipartDataSource
        Throws:
        MessagingException

    • Method Detail

      • initializeProperties

        protected void initializeProperties()
        Initialize flags that control parsing behavior, based on System properties described above in the class documentation.
        Since:
        JavaMail 1.5

      • setSubType

        public void setSubType(String subtype)
                throws MessagingException
        Set the subtype. This method should be invoked only on a new MimeMultipart object created by the client. The default subtype of such a multipart object is "mixed".

        Parameters:
        subtype - Subtype
        Throws:
        MessagingException

      • getCount

        public int getCount()
             throws MessagingException
        Return the number of enclosed BodyPart objects.
        Overrides:
        getCount in class Multipart
        Returns:
        number of parts
        Throws:
        MessagingException
        See Also:
        Multipart.parts

      • getBodyPart

        public BodyPart getBodyPart(int index)
                     throws MessagingException
        Get the specified BodyPart. BodyParts are numbered starting at 0.
        Overrides:
        getBodyPart in class Multipart
        Parameters:
        index - the index of the desired BodyPart
        Returns:
        the Part
        Throws:
        MessagingException - if no such BodyPart exists

      • getBodyPart

        public BodyPart getBodyPart(String CID)
                     throws MessagingException
        Get the MimeBodyPart referred to by the given ContentID (CID). Returns null if the part is not found.
        Parameters:
        CID - the ContentID of the desired part
        Returns:
        the Part
        Throws:
        MessagingException

      • removeBodyPart

        public boolean removeBodyPart(BodyPart part)
                       throws MessagingException
        Remove the specified part from the multipart message. Shifts all the parts after the removed part down one.
        Overrides:
        removeBodyPart in class Multipart
        Parameters:
        part - The part to remove
        Returns:
        true if part removed, false otherwise
        Throws:
        MessagingException - if no such Part exists
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • removeBodyPart

        public void removeBodyPart(int index)
                    throws MessagingException
        Remove the part at specified location (starting from 0). Shifts all the parts after the removed part down one.
        Overrides:
        removeBodyPart in class Multipart
        Parameters:
        index - Index of the part to remove
        Throws:
        MessagingException
        IndexOutOfBoundsException - if the given index is out of range.
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • addBodyPart

        public void addBodyPart(BodyPart part)
                 throws MessagingException
        Adds a Part to the multipart. The BodyPart is appended to the list of existing Parts.
        Overrides:
        addBodyPart in class Multipart
        Parameters:
        part - The Part to be appended
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • addBodyPart

        public void addBodyPart(BodyPart part,
               int index)
                 throws MessagingException
        Adds a BodyPart at position index. If index is not the last one in the list, the subsequent parts are shifted up. If index is larger than the number of parts present, the BodyPart is appended to the end.
        Overrides:
        addBodyPart in class Multipart
        Parameters:
        part - The BodyPart to be inserted
        index - Location where to insert the part
        Throws:
        MessagingException
        IllegalWriteException - if the underlying implementation does not support modification of existing values

      • isComplete

        public boolean isComplete()
                   throws MessagingException
        Return true if the final boundary line for this multipart was seen. When parsing multipart content, this class will (by default) terminate parsing with no error if the end of input is reached before seeing the final multipart boundary line. In such a case, this method will return false. (If the System property "mail.mime.multipart.ignoremissingendboundary" is set to false, parsing such a message will instead throw a MessagingException.)
        Returns:
        true if the final boundary line was seen
        Throws:
        MessagingException
        Since:
        JavaMail 1.4

      • getPreamble

        public String getPreamble()
                   throws MessagingException
        Get the preamble text, if any, that appears before the first body part of this multipart. Some protocols, such as IMAP, will not allow access to the preamble text.
        Returns:
        the preamble text, or null if no preamble
        Throws:
        MessagingException
        Since:
        JavaMail 1.4

      • setPreamble

        public void setPreamble(String preamble)
                 throws MessagingException
        Set the preamble text to be included before the first body part. Applications should generally not include any preamble text. In some cases it may be helpful to include preamble text with instructions for users of pre-MIME software. The preamble text should be complete lines, including newlines.
        Parameters:
        preamble - the preamble text
        Throws:
        MessagingException
        Since:
        JavaMail 1.4

      • updateHeaders

        protected void updateHeaders()
                      throws MessagingException
        Update headers. The default implementation here just calls the updateHeaders method on each of its children BodyParts.

        Note that the boundary parameter is already set up when a new and empty MimeMultipart object is created.

        This method is called when the saveChanges method is invoked on the Message object containing this Multipart. This is typically done as part of the Message send process, however note that a client is free to call it any number of times. So if the header updating process is expensive for a specific MimeMultipart subclass, then it might itself want to track whether its internal state actually did change, and do the header updating only if necessary.

        Throws:
        MessagingException

      • writeTo

        public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
        Iterates through all the parts and outputs each MIME part separated by a boundary.
        Specified by:
        writeTo in class Multipart
        Throws:
        IOException - if an IO related exception occurs
        MessagingException

      • parse

        protected void parse()
              throws MessagingException
        Parse the InputStream from our DataSource, constructing the appropriate MimeBodyParts. The parsed flag is set to true, and if true on entry nothing is done. This method is called by all other methods that need data for the body parts, to make sure the data has been parsed. The initializeProperties() method is called before parsing the data.
        Throws:
        MessagingException
        Since:
        JavaMail 1.2

      • createInternetHeaders

        protected InternetHeaders createInternetHeaders(InputStream is)
                                         throws MessagingException
        Create and return an InternetHeaders object that loads the headers from the given InputStream. Subclasses can override this method to return a subclass of InternetHeaders, if necessary. This implementation simply constructs and returns an InternetHeaders object.
        Parameters:
        is - the InputStream to read the headers from
        Throws:
        MessagingException
        Since:
        JavaMail 1.2

      • createMimeBodyPart

        protected MimeBodyPart createMimeBodyPart(InternetHeaders headers,
                              byte[] content)
                                   throws MessagingException
        Create and return a MimeBodyPart object to represent a body part parsed from the InputStream. Subclasses can override this method to return a subclass of MimeBodyPart, if necessary. This implementation simply constructs and returns a MimeBodyPart object.
        Parameters:
        headers - the headers for the body part
        content - the content of the body part
        Throws:
        MessagingException
        Since:
        JavaMail 1.2

      • createMimeBodyPart

        protected MimeBodyPart createMimeBodyPart(InputStream is)
                                   throws MessagingException
        Create and return a MimeBodyPart object to represent a body part parsed from the InputStream. Subclasses can override this method to return a subclass of MimeBodyPart, if necessary. This implementation simply constructs and returns a MimeBodyPart object.
        Parameters:
        is - InputStream containing the body part
        Throws:
        MessagingException
        Since:
        JavaMail 1.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MimePart (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Interface MimePart

  • All Superinterfaces:
    Part
    All Known Implementing Classes:
    MimeBodyPart, MimeMessage, PreencodedMimeBodyPart

    public interface MimePart
extends Part
    The MimePart interface models an Entity as defined by MIME (RFC2045, Section 2.4).

    MimePart extends the Part interface to add additional RFC822 and MIME specific semantics and attributes. It provides the base interface for the MimeMessage and MimeBodyPart classes

    A note on RFC822 and MIME headers

    RFC822 and MIME header fields must contain only US-ASCII characters. If a header contains non US-ASCII characters, it must be encoded as per the rules in RFC 2047. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

    Author:
    John Mani
    See Also:
    MimeUtility, Part

    • Field Summary

      • Fields inherited from interface javax.mail.Part

        ATTACHMENT, INLINE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addHeaderLine(String line)
      Add a raw RFC822 header-line.
      Enumeration getAllHeaderLines()
      Get all header lines as an Enumeration of Strings.
      String getContentID()
      Get the Content-ID of this part.
      String[] getContentLanguage()
      Get the language tags specified in the Content-Language header of this MimePart.
      String getContentMD5()
      Get the Content-MD5 digest of this part.
      String getEncoding()
      Get the transfer encoding of this part.
      String getHeader(String name, String delimiter)
      Get the values of all header fields available for this header, returned as a single String, with the values separated by the delimiter.
      Enumeration getMatchingHeaderLines(String[] names)
      Get matching header lines as an Enumeration of Strings.
      Enumeration getNonMatchingHeaderLines(String[] names)
      Get non-matching header lines as an Enumeration of Strings.
      void setContentLanguage(String[] languages)
      Set the Content-Language header of this MimePart.
      void setContentMD5(String md5)
      Set the Content-MD5 of this part.
      void setText(String text)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
      void setText(String text, String charset)
      Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
      void setText(String text, String charset, String subtype)
      Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.

      • Methods inherited from interface javax.mail.Part

        addHeader, getAllHeaders, getContent, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getInputStream, getLineCount, getMatchingHeaders, getNonMatchingHeaders, getSize, isMimeType, removeHeader, setContent, setContent, setDataHandler, setDescription, setDisposition, setFileName, setHeader, writeTo

    • Method Detail

      • getHeader

        String getHeader(String name,
               String delimiter)
                 throws MessagingException
        Get the values of all header fields available for this header, returned as a single String, with the values separated by the delimiter. If the delimiter is null, only the first value is returned.
        Parameters:
        name - the name of this header
        delimiter - delimiter between fields in returned string
        Returns:
        the value fields for all headers with this name
        Throws:
        MessagingException

      • addHeaderLine

        void addHeaderLine(String line)
                   throws MessagingException
        Add a raw RFC822 header-line.
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this Part is obtained from a READ_ONLY folder
        MessagingException

      • getAllHeaderLines

        Enumeration getAllHeaderLines()
                              throws MessagingException
        Get all header lines as an Enumeration of Strings. A Header line is a raw RFC822 header-line, containing both the "name" and "value" field.
        Throws:
        MessagingException

      • getMatchingHeaderLines

        Enumeration getMatchingHeaderLines(String[] names)
                                   throws MessagingException
        Get matching header lines as an Enumeration of Strings. A Header line is a raw RFC822 header-line, containing both the "name" and "value" field.
        Throws:
        MessagingException

      • getNonMatchingHeaderLines

        Enumeration getNonMatchingHeaderLines(String[] names)
                                      throws MessagingException
        Get non-matching header lines as an Enumeration of Strings. A Header line is a raw RFC822 header-line, containing both the "name" and "value" field.
        Throws:
        MessagingException

      • getEncoding

        String getEncoding()
                   throws MessagingException
        Get the transfer encoding of this part.
        Returns:
        content-transfer-encoding
        Throws:
        MessagingException

      • getContentID

        String getContentID()
                    throws MessagingException
        Get the Content-ID of this part. Returns null if none present.
        Returns:
        content-ID
        Throws:
        MessagingException

      • getContentMD5

        String getContentMD5()
                     throws MessagingException
        Get the Content-MD5 digest of this part. Returns null if none present.
        Returns:
        content-MD5
        Throws:
        MessagingException

      • setContentMD5

        void setContentMD5(String md5)
                   throws MessagingException
        Set the Content-MD5 of this part.
        Parameters:
        md5 - the MD5 value
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this Part is obtained from a READ_ONLY folder
        MessagingException

      • getContentLanguage

        String[] getContentLanguage()
                            throws MessagingException
        Get the language tags specified in the Content-Language header of this MimePart. The Content-Language header is defined by RFC 1766. Returns null if this header is not available.
        Throws:
        MessagingException

      • setContentLanguage

        void setContentLanguage(String[] languages)
                        throws MessagingException
        Set the Content-Language header of this MimePart. The Content-Language header is defined by RFC1766.
        Parameters:
        languages - array of language tags
        Throws:
        IllegalWriteException - if the underlying implementation does not support modification
        IllegalStateException - if this Part is obtained from a READ_ONLY folder
        MessagingException

      • setText

        void setText(String text)
             throws MessagingException
        Convenience method that sets the given String as this part's content, with a MIME type of "text/plain". If the string contains non US-ASCII characters. it will be encoded using the platform's default charset. The charset is also used to set the "charset" parameter.

        Note that there may be a performance penalty if text is large, since this method may have to scan all the characters to determine what charset to use.

        If the charset is already known, use the setText method that takes the charset parameter.

        Specified by:
        setText in interface Part
        Parameters:
        text - the text content to set
        Throws:
        MessagingException - if an error occurs
        See Also:
        setText(String text, String charset)

      • setText

        void setText(String text,
           String charset)
             throws MessagingException
        Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set "charset" parameter.
        Parameters:
        text - the text content to set
        charset - the charset to use for the text
        Throws:
        MessagingException - if an error occurs

      • setText

        void setText(String text,
           String charset,
           String subtype)
             throws MessagingException
        Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.
        Parameters:
        text - the text content to set
        charset - the charset to use for the text
        subtype - the MIME subtype to use (e.g., "html")
        Throws:
        MessagingException - if an error occurs
        Since:
        JavaMail 1.4
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MimePartDataSource (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class MimePartDataSource

  • java.lang.Object
    • javax.mail.internet.MimePartDataSource
  • All Implemented Interfaces:
    DataSource, MessageAware

    public class MimePartDataSource
extends Object
implements DataSource, MessageAware
    A utility class that implements a DataSource out of a MimePart. This class is primarily meant for service providers.
    Author:
    John Mani
    See Also:
    MimePart, DataSource

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected MimePart part
      The MimePart that provides the data for this DataSource.

    • Constructor Summary

      Constructors
      Constructor and Description
      MimePartDataSource(MimePart part)
      Constructor, that constructs a DataSource from a MimePart.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getContentType()
      Returns the content-type of this DataSource.
      InputStream getInputStream()
      Returns an input stream from this MimePart.
      MessageContext getMessageContext()
      Return the MessageContext for the current part.
      String getName()
      DataSource method to return a name.
      OutputStream getOutputStream()
      DataSource method to return an output stream.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • part

        protected MimePart part
        The MimePart that provides the data for this DataSource.
        Since:
        JavaMail 1.4

    • Constructor Detail

      • MimePartDataSource

        public MimePartDataSource(MimePart part)
        Constructor, that constructs a DataSource from a MimePart.

    • Method Detail

      • getInputStream

        public InputStream getInputStream()
                           throws IOException
        Returns an input stream from this MimePart.

        This method applies the appropriate transfer-decoding, based on the Content-Transfer-Encoding attribute of this MimePart. Thus the returned input stream is a decoded stream of bytes.

        This implementation obtains the raw content from the Part using the getContentStream() method and decodes it using the MimeUtility.decode() method.

        Specified by:
        getInputStream in interface DataSource
        Returns:
        decoded input stream
        Throws:
        IOException
        See Also:
        MimeMessage.getContentStream(),
MimeBodyPart.getContentStream(),
MimeUtility.decode(java.io.InputStream, java.lang.String)

      • getOutputStream

        public OutputStream getOutputStream()
                             throws IOException
        DataSource method to return an output stream.

        This implementation throws the UnknownServiceException.

        Specified by:
        getOutputStream in interface DataSource
        Throws:
        IOException

      • getContentType

        public String getContentType()
        Returns the content-type of this DataSource.

        This implementation just invokes the getContentType method on the MimePart.

        Specified by:
        getContentType in interface DataSource

      • getName

        public String getName()
        DataSource method to return a name.

        This implementation just returns an empty string.

        Specified by:
        getName in interface DataSource

      • getMessageContext

        public MessageContext getMessageContext()
        Return the MessageContext for the current part.
        Specified by:
        getMessageContext in interface MessageAware
        Since:
        JavaMail 1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MimeUtility (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class MimeUtility

  • java.lang.Object
    • javax.mail.internet.MimeUtility

  • public class MimeUtility
extends Object
    This is a utility class that provides various MIME related functionality.

    There are a set of methods to encode and decode MIME headers as per RFC 2047. Note that, in general, these methods are not needed when using methods such as setSubject and setRecipients; JavaMail will automatically encode and decode data when using these "higher level" methods. The methods below are only needed when maniuplating raw MIME headers using setHeader and getHeader methods. A brief description on handling such headers is given below:

    RFC 822 mail headers must contain only US-ASCII characters. Headers that contain non US-ASCII characters must be encoded so that they contain only US-ASCII characters. Basically, this process involves using either BASE64 or QP to encode certain characters. RFC 2047 describes this in detail.

    In Java, Strings contain (16 bit) Unicode characters. ASCII is a subset of Unicode (and occupies the range 0 - 127). A String that contains only ASCII characters is already mail-safe. If the String contains non US-ASCII characters, it must be encoded. An additional complexity in this step is that since Unicode is not yet a widely used charset, one might want to first charset-encode the String into another charset and then do the transfer-encoding.

    Note that to get the actual bytes of a mail-safe String (say, for sending over SMTP), one must do

        byte[] bytes = string.getBytes("iso-8859-1");

    The setHeader and addHeader methods on MimeMessage and MimeBodyPart assume that the given header values are Unicode strings that contain only US-ASCII characters. Hence the callers of those methods must insure that the values they pass do not contain non US-ASCII characters. The methods in this class help do this.

    The getHeader family of methods on MimeMessage and MimeBodyPart return the raw header value. These might be encoded as per RFC 2047, and if so, must be decoded into Unicode Strings. The methods in this class help to do this.

    Several System properties control strict conformance to the MIME spec. Note that these are not session properties but must be set globally as System properties.

    The mail.mime.decodetext.strict property controls decoding of MIME encoded words. The MIME spec requires that encoded words start at the beginning of a whitespace separated word. Some mailers incorrectly include encoded words in the middle of a word. If the mail.mime.decodetext.strict System property is set to "false", an attempt will be made to decode these illegal encoded words. The default is true.

    The mail.mime.encodeeol.strict property controls the choice of Content-Transfer-Encoding for MIME parts that are not of type "text". Often such parts will contain textual data for which an encoding that allows normal end of line conventions is appropriate. In rare cases, such a part will appear to contain entirely textual data, but will require an encoding that preserves CR and LF characters without change. If the mail.mime.encodeeol.strict System property is set to "true", such an encoding will be used when necessary. The default is false.

    In addition, the mail.mime.charset System property can be used to specify the default MIME charset to use for encoded words and text parts that don't otherwise specify a charset. Normally, the default MIME charset is derived from the default Java charset, as specified in the file.encoding System property. Most applications will have no need to explicitly set the default MIME charset. In cases where the default MIME charset to be used for mail messages is different than the charset used for files stored on the system, this property should be set.

    The current implementation also supports the following System property.

    The mail.mime.ignoreunknownencoding property controls whether unknown values in the Content-Transfer-Encoding header, as passed to the decode method, cause an exception. If set to "true", unknown values are ignored and 8bit encoding is assumed. Otherwise, unknown values cause a MessagingException to be thrown.

    Author:
    John Mani, Bill Shannon

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | ALL

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static InputStream decode(InputStream is, String encoding)
      Decode the given input stream.
      static String decodeText(String etext)
      Decode "unstructured" headers, that is, headers that are defined as '*text' as per RFC 822.
      static String decodeWord(String eword)
      The string is parsed using the rules in RFC 2047 and RFC 2231 for parsing an "encoded-word".
      static OutputStream encode(OutputStream os, String encoding)
      Wrap an encoder around the given output stream.
      static OutputStream encode(OutputStream os, String encoding, String filename)
      Wrap an encoder around the given output stream.
      static String encodeText(String text)
      Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.
      static String encodeText(String text, String charset, String encoding)
      Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.
      static String encodeWord(String word)
      Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.
      static String encodeWord(String word, String charset, String encoding)
      Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.
      static String fold(int used, String s)
      Fold a string at linear whitespace so that each line is no longer than 76 characters, if possible.
      static String getDefaultJavaCharset()
      Get the default charset corresponding to the system's current default locale.
      static String getEncoding(DataHandler dh)
      Same as getEncoding(DataSource) except that instead of reading the data from an InputStream it uses the writeTo method to examine the data.
      static String getEncoding(DataSource ds)
      Get the Content-Transfer-Encoding that should be applied to the input stream of this DataSource, to make it mail-safe.
      static String javaCharset(String charset)
      Convert a MIME charset name into a valid Java charset name.
      static String mimeCharset(String charset)
      Convert a java charset into its MIME charset name.
      static String quote(String word, String specials)
      A utility method to quote a word, if the word contains any characters from the specified 'specials' list.
      static String unfold(String s)
      Unfold a folded header.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ALL

        public static final int ALL
        See Also:
        Constant Field Values

    • Method Detail

      • getEncoding

        public static String getEncoding(DataSource ds)
        Get the Content-Transfer-Encoding that should be applied to the input stream of this DataSource, to make it mail-safe.

        The algorithm used here is:

        • If the DataSource implements EncodingAware, ask it what encoding to use. If it returns non-null, return that value.
        • If the primary type of this datasource is "text" and if all the bytes in its input stream are US-ASCII, then the encoding is "7bit". If more than half of the bytes are non-US-ASCII, then the encoding is "base64". If less than half of the bytes are non-US-ASCII, then the encoding is "quoted-printable".
        • If the primary type of this datasource is not "text", then if all the bytes of its input stream are US-ASCII, the encoding is "7bit". If there is even one non-US-ASCII character, the encoding is "base64".
        Parameters:
        ds - the DataSource
        Returns:
        the encoding. This is either "7bit", "quoted-printable" or "base64"

      • getEncoding

        public static String getEncoding(DataHandler dh)
        Same as getEncoding(DataSource) except that instead of reading the data from an InputStream it uses the writeTo method to examine the data. This is more efficient in the common case of a DataHandler created with an object and a MIME type (for example, a "text/plain" String) because all the I/O is done in this thread. In the case requiring an InputStream the DataHandler uses a thread, a pair of pipe streams, and the writeTo method to produce the data.

        Since:
        JavaMail 1.2

      • decode

        public static InputStream decode(InputStream is,
                 String encoding)
                          throws MessagingException
        Decode the given input stream. The Input stream returned is the decoded input stream. All the encodings defined in RFC 2045 are supported here. They include "base64", "quoted-printable", "7bit", "8bit", and "binary". In addition, "uuencode" is also supported.

        In the current implementation, if the mail.mime.ignoreunknownencoding system property is set to "true", unknown encoding values are ignored and the original InputStream is returned.

        Parameters:
        is - input stream
        encoding - the encoding of the stream.
        Returns:
        decoded input stream.
        Throws:
        MessagingException - if the encoding is unknown

      • encode

        public static OutputStream encode(OutputStream os,
                  String encoding)
                           throws MessagingException
        Wrap an encoder around the given output stream. All the encodings defined in RFC 2045 are supported here. They include "base64", "quoted-printable", "7bit", "8bit" and "binary". In addition, "uuencode" is also supported.
        Parameters:
        os - output stream
        encoding - the encoding of the stream.
        Returns:
        output stream that applies the specified encoding.
        Throws:
        MessagingException - if the encoding is unknown

      • encode

        public static OutputStream encode(OutputStream os,
                  String encoding,
                  String filename)
                           throws MessagingException
        Wrap an encoder around the given output stream. All the encodings defined in RFC 2045 are supported here. They include "base64", "quoted-printable", "7bit", "8bit" and "binary". In addition, "uuencode" is also supported. The filename parameter is used with the "uuencode" encoding and is included in the encoded output.
        Parameters:
        os - output stream
        encoding - the encoding of the stream.
        filename - name for the file being encoded (only used with uuencode)
        Returns:
        output stream that applies the specified encoding.
        Throws:
        MessagingException
        Since:
        JavaMail 1.2

      • encodeText

        public static String encodeText(String text)
                         throws UnsupportedEncodingException
        Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.

        The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the platform's default charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

        Note that this method should be used to encode only "unstructured" RFC 822 headers.

        Example of usage:

  MimePart part = ...
  String rawvalue = "FooBar Mailer, Japanese version 1.1"
  try {
    // If we know for sure that rawvalue contains only US-ASCII
    // characters, we can skip the encoding part
    part.setHeader("X-mailer", MimeUtility.encodeText(rawvalue));
  } catch (UnsupportedEncodingException e) {
    // encoding failure
  } catch (MessagingException me) {
   // setHeader() failure
  }

        Parameters:
        text - Unicode string
        Returns:
        Unicode string containing only US-ASCII characters
        Throws:
        UnsupportedEncodingException - if the encoding fails

      • encodeText

        public static String encodeText(String text,
                String charset,
                String encoding)
                         throws UnsupportedEncodingException
        Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.

        The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the specified charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

        Note that this method should be used to encode only "unstructured" RFC 822 headers.

        Parameters:
        text - the header value
        charset - the charset. If this parameter is null, the platform's default chatset is used.
        encoding - the encoding to be used. Currently supported values are "B" and "Q". If this parameter is null, then the "Q" encoding is used if most of characters to be encoded are in the ASCII charset, otherwise "B" encoding is used.
        Returns:
        Unicode string containing only US-ASCII characters
        Throws:
        UnsupportedEncodingException

      • decodeText

        public static String decodeText(String etext)
                         throws UnsupportedEncodingException
        Decode "unstructured" headers, that is, headers that are defined as '*text' as per RFC 822.

        The string is decoded using the algorithm specified in RFC 2047, Section 6.1. If the charset-conversion fails for any sequence, an UnsupportedEncodingException is thrown. If the String is not an RFC 2047 style encoded header, it is returned as-is

        Example of usage:

  MimePart part = ...
  String rawvalue = null;
  String  value = null;
  try {
    if ((rawvalue = part.getHeader("X-mailer")[0]) != null)
      value = MimeUtility.decodeText(rawvalue);
  } catch (UnsupportedEncodingException e) {
      // Don't care
      value = rawvalue;
  } catch (MessagingException me) { }

  return value;

        Parameters:
        etext - the possibly encoded value
        Throws:
        UnsupportedEncodingException - if the charset conversion failed.

      • encodeWord

        public static String encodeWord(String word)
                         throws UnsupportedEncodingException
        Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.

        The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the platform's default charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

        This method is meant to be used when creating RFC 822 "phrases". The InternetAddress class, for example, uses this to encode it's 'phrase' component.

        Parameters:
        word - Unicode string
        Returns:
        Array of Unicode strings containing only US-ASCII characters.
        Throws:
        UnsupportedEncodingException - if the encoding fails

      • encodeWord

        public static String encodeWord(String word,
                String charset,
                String encoding)
                         throws UnsupportedEncodingException
        Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.

        The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the specified charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

        Parameters:
        word - Unicode string
        charset - the MIME charset
        encoding - the encoding to be used. Currently supported values are "B" and "Q". If this parameter is null, then the "Q" encoding is used if most of characters to be encoded are in the ASCII charset, otherwise "B" encoding is used.
        Returns:
        Unicode string containing only US-ASCII characters
        Throws:
        UnsupportedEncodingException - if the encoding fails

      • decodeWord

        public static String decodeWord(String eword)
                         throws ParseException,
                                UnsupportedEncodingException
        The string is parsed using the rules in RFC 2047 and RFC 2231 for parsing an "encoded-word". If the parse fails, a ParseException is thrown. Otherwise, it is transfer-decoded, and then charset-converted into Unicode. If the charset-conversion fails, an UnsupportedEncodingException is thrown.

        Parameters:
        eword - the encoded value
        Throws:
        ParseException - if the string is not an encoded-word as per RFC 2047 and RFC 2231.
        UnsupportedEncodingException - if the charset conversion failed.

      • quote

        public static String quote(String word,
           String specials)
        A utility method to quote a word, if the word contains any characters from the specified 'specials' list.

        The HeaderTokenizer class defines two special sets of delimiters - MIME and RFC 822.

        This method is typically used during the generation of RFC 822 and MIME header fields.

        Parameters:
        word - word to be quoted
        specials - the set of special characters
        Returns:
        the possibly quoted word
        See Also:
        HeaderTokenizer.MIME, HeaderTokenizer.RFC822

      • fold

        public static String fold(int used,
          String s)
        Fold a string at linear whitespace so that each line is no longer than 76 characters, if possible. If there are more than 76 non-whitespace characters consecutively, the string is folded at the first whitespace after that sequence. The parameter used indicates how many characters have been used in the current line; it is usually the length of the header name.

        Note that line breaks in the string aren't escaped; they probably should be.

        Parameters:
        used - characters used in line so far
        s - the string to fold
        Returns:
        the folded string
        Since:
        JavaMail 1.4

      • unfold

        public static String unfold(String s)
        Unfold a folded header. Any line breaks that aren't escaped and are followed by whitespace are removed.
        Parameters:
        s - the string to unfold
        Returns:
        the unfolded string
        Since:
        JavaMail 1.4

      • javaCharset

        public static String javaCharset(String charset)
        Convert a MIME charset name into a valid Java charset name.

        Parameters:
        charset - the MIME charset name
        Returns:
        the Java charset equivalent. If a suitable mapping is not available, the passed in charset is itself returned.

      • mimeCharset

        public static String mimeCharset(String charset)
        Convert a java charset into its MIME charset name.

        Note that a future version of JDK (post 1.2) might provide this functionality, in which case, we may deprecate this method then.

        Parameters:
        charset - the JDK charset
        Returns:
        the MIME/IANA equivalent. If a mapping is not possible, the passed in charset itself is returned.
        Since:
        JavaMail 1.1

      • getDefaultJavaCharset

        public static String getDefaultJavaCharset()
        Get the default charset corresponding to the system's current default locale. If the System property mail.mime.charset is set, a system charset corresponding to this MIME charset will be returned.

        Returns:
        the default charset of the system's default locale, as a Java charset. (NOT a MIME charset)
        Since:
        JavaMail 1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NewsAddress (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class NewsAddress

  • java.lang.Object
    • javax.mail.Address
      • javax.mail.internet.NewsAddress
  • All Implemented Interfaces:
    Serializable

    public class NewsAddress
extends Address
    This class models an RFC1036 newsgroup address.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected String | host
      protected String | newsgroup

    • Constructor Summary

      Constructors
      Constructor and Description
      NewsAddress()
      Default constructor.
      NewsAddress(String newsgroup)
      Construct a NewsAddress with the given newsgroup.
      NewsAddress(String newsgroup, String host)
      Construct a NewsAddress with the given newsgroup and host.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object a)
      The equality operator.
      String getHost()
      Get the host.
      String getNewsgroup()
      Get the newsgroup.
      String getType()
      Return the type of this address.
      int hashCode()
      Compute a hash code for the address.
      static NewsAddress[] parse(String newsgroups)
      Parse the given comma separated sequence of newsgroup into NewsAddress objects.
      void setHost(String host)
      Set the host.
      void setNewsgroup(String newsgroup)
      Set the newsgroup.
      String toString()
      Convert this address into a RFC 1036 address.
      static String toString(Address[] addresses)
      Convert the given array of NewsAddress objects into a comma separated sequence of address strings.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Field Detail

      • newsgroup

        protected String newsgroup

      • host

        protected String host

    • Constructor Detail

      • NewsAddress

        public NewsAddress()
        Default constructor.

      • NewsAddress

        public NewsAddress(String newsgroup)
        Construct a NewsAddress with the given newsgroup.
        Parameters:
        newsgroup - the newsgroup

      • NewsAddress

        public NewsAddress(String newsgroup,
           String host)
        Construct a NewsAddress with the given newsgroup and host.
        Parameters:
        newsgroup - the newsgroup
        host - the host

    • Method Detail

      • getType

        public String getType()
        Return the type of this address. The type of a NewsAddress is "news".
        Specified by:
        getType in class Address
        Returns:
        address type
        See Also:
        InternetAddress

      • setNewsgroup

        public void setNewsgroup(String newsgroup)
        Set the newsgroup.
        Parameters:
        newsgroup - the newsgroup

      • getNewsgroup

        public String getNewsgroup()
        Get the newsgroup.
        Returns:
        newsgroup

      • setHost

        public void setHost(String host)
        Set the host.
        Parameters:
        host - the host

      • getHost

        public String getHost()
        Get the host.
        Returns:
        host

      • toString

        public String toString()
        Convert this address into a RFC 1036 address.
        Specified by:
        toString in class Address
        Returns:
        newsgroup

      • equals

        public boolean equals(Object a)
        The equality operator.
        Specified by:
        equals in class Address
        Parameters:
        a - Address object

      • hashCode

        public int hashCode()
        Compute a hash code for the address.
        Overrides:
        hashCode in class Object

      • toString

        public static String toString(Address[] addresses)
        Convert the given array of NewsAddress objects into a comma separated sequence of address strings. The resulting string contains only US-ASCII characters, and hence is mail-safe.
        Parameters:
        addresses - array of NewsAddress objects
        Returns:
        comma separated address strings
        Throws:
        ClassCastException, - if any address object in the given array is not a NewsAddress objects. Note that this is a RuntimeException.

      • parse

        public static NewsAddress[] parse(String newsgroups)
                           throws AddressException
        Parse the given comma separated sequence of newsgroup into NewsAddress objects.
        Parameters:
        newsgroups - comma separated newsgroup string
        Returns:
        array of NewsAddress objects
        Throws:
        AddressException - if the parse failed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ParameterList (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class ParameterList

  • java.lang.Object
    • javax.mail.internet.ParameterList

  • public class ParameterList
extends Object
    This class holds MIME parameters (attribute-value pairs). The mail.mime.encodeparameters and mail.mime.decodeparameters System properties control whether encoded parameters, as specified by RFC 2231, are supported. By default, such encoded parameters are supported.

    Also, in the current implementation, setting the System property mail.mime.decodeparameters.strict to "true" will cause a ParseException to be thrown for errors detected while decoding encoded parameters. By default, if any decoding errors occur, the original (undecoded) string is used.

    The current implementation supports the System property mail.mime.parameters.strict, which if set to false when parsing a parameter list allows parameter values to contain whitespace and other special characters without being quoted; the parameter value ends at the next semicolon. If set to true (the default), parameter values are required to conform to the MIME specification and must be quoted if they contain whitespace or special characters.

    Author:
    John Mani, Bill Shannon

    • Constructor Summary

      Constructors
      Constructor and Description
      ParameterList()
      No-arg Constructor.
      ParameterList(String s)
      Constructor that takes a parameter-list string.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void combineSegments()
      Normal users of this class will use simple parameter names.
      String get(String name)
      Returns the value of the specified parameter.
      Enumeration getNames()
      Return an enumeration of the names of all parameters in this list.
      void remove(String name)
      Removes the specified parameter from this ParameterList.
      void set(String name, String value)
      Set a parameter.
      void set(String name, String value, String charset)
      Set a parameter.
      int size()
      Return the number of parameters in this list.
      String toString()
      Convert this ParameterList into a MIME String.
      String toString(int used)
      Convert this ParameterList into a MIME String.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ParameterList

        public ParameterList()
        No-arg Constructor.

      • ParameterList

        public ParameterList(String s)
              throws ParseException
        Constructor that takes a parameter-list string. The String is parsed and the parameters are collected and stored internally. A ParseException is thrown if the parse fails. Note that an empty parameter-list string is valid and will be parsed into an empty ParameterList.
        Parameters:
        s - the parameter-list string.
        Throws:
        ParseException - if the parse fails.

    • Method Detail

      • combineSegments

        public void combineSegments()
        Normal users of this class will use simple parameter names. In some cases, for example, when processing IMAP protocol messages, individual segments of a multi-segment name (specified by RFC 2231) will be encountered and passed to the set(java.lang.String, java.lang.String) method. After all these segments are added to this ParameterList, they need to be combined to represent the logical parameter name and value. This method will combine all segments of multi-segment names.

        Normal users should never need to call this method.

        Since:
        JavaMail 1.5

      • size

        public int size()
        Return the number of parameters in this list.
        Returns:
        number of parameters.

      • get

        public String get(String name)
        Returns the value of the specified parameter. Note that parameter names are case-insensitive.
        Parameters:
        name - parameter name.
        Returns:
        Value of the parameter. Returns null if the parameter is not present.

      • set

        public void set(String name,
       String value)
        Set a parameter. If this parameter already exists, it is replaced by this new value.
        Parameters:
        name - name of the parameter.
        value - value of the parameter.

      • set

        public void set(String name,
       String value,
       String charset)
        Set a parameter. If this parameter already exists, it is replaced by this new value. If the mail.mime.encodeparameters System property is true, and the parameter value is non-ASCII, it will be encoded with the specified charset, as specified by RFC 2231.
        Parameters:
        name - name of the parameter.
        value - value of the parameter.
        charset - charset of the parameter value.
        Since:
        JavaMail 1.4

      • remove

        public void remove(String name)
        Removes the specified parameter from this ParameterList. This method does nothing if the parameter is not present.
        Parameters:
        name - name of the parameter.

      • getNames

        public Enumeration getNames()
        Return an enumeration of the names of all parameters in this list.
        Returns:
        Enumeration of all parameter names in this list.

      • toString

        public String toString()
        Convert this ParameterList into a MIME String. If this is an empty list, an empty string is returned.
        Overrides:
        toString in class Object
        Returns:
        String

      • toString

        public String toString(int used)
        Convert this ParameterList into a MIME String. If this is an empty list, an empty string is returned. The 'used' parameter specifies the number of character positions already taken up in the field into which the resulting parameter list is to be inserted. It's used to determine where to fold the resulting parameter list.
        Parameters:
        used - number of character positions already used, in the field into which the parameter list is to be inserted.
        Returns:
        String
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ParseException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class ParseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.internet.ParseException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    AddressException

    public class ParseException
extends MessagingException
    The exception thrown due to an error in parsing RFC822 or MIME headers
    Author:
    John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ParseException()
      Constructs a ParseException with no detail message.
      ParseException(String s)
      Constructs a ParseException with the specified detail message.

    • Method Summary

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ParseException

        public ParseException()
        Constructs a ParseException with no detail message.

      • ParseException

        public ParseException(String s)
        Constructs a ParseException with the specified detail message.
        Parameters:
        s - the detail message
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PreencodedMimeBodyPart (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Class PreencodedMimeBodyPart

  • java.lang.Object
    • javax.mail.BodyPart
      • javax.mail.internet.MimeBodyPart
        • javax.mail.internet.PreencodedMimeBodyPart
  • All Implemented Interfaces:
    MimePart, Part

    public class PreencodedMimeBodyPart
extends MimeBodyPart
    A MimeBodyPart that handles data that has already been encoded. This class is useful when constructing a message and attaching data that has already been encoded (for example, using base64 encoding). The data may have been encoded by the application, or may have been stored in a file or database in encoded form. The encoding is supplied when this object is created. The data is attached to this object in the usual fashion, by using the setText, setContent, or setDataHandler methods.
    Since:
    JavaMail 1.4

    • Field Summary

      • Fields inherited from class javax.mail.internet.MimeBodyPart

        cachedContent, content, contentStream, dh, headers

      • Fields inherited from class javax.mail.BodyPart

        parent

      • Fields inherited from interface javax.mail.Part

        ATTACHMENT, INLINE

    • Constructor Summary

      Constructors
      Constructor and Description
      PreencodedMimeBodyPart(String encoding)
      Create a PreencodedMimeBodyPart that assumes the data is encoded using the specified encoding.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getEncoding()
      Returns the content transfer encoding specified when this object was created.
      protected void updateHeaders()
      Force the Content-Transfer-Encoding header to use the encoding that was specified when this object was created.
      void writeTo(OutputStream os)
      Output the body part as an RFC 822 format stream.

      • Methods inherited from class javax.mail.internet.MimeBodyPart

        addHeader, addHeaderLine, attachFile, attachFile, attachFile, attachFile, getAllHeaderLines, getAllHeaders, getContent, getContentID, getContentLanguage, getContentMD5, getContentStream, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getHeader, getInputStream, getLineCount, getMatchingHeaderLines, getMatchingHeaders, getNonMatchingHeaderLines, getNonMatchingHeaders, getRawInputStream, getSize, isMimeType, removeHeader, saveFile, saveFile, setContent, setContent, setContentID, setContentLanguage, setContentMD5, setDataHandler, setDescription, setDescription, setDisposition, setFileName, setHeader, setText, setText, setText

      • Methods inherited from class javax.mail.BodyPart

        getParent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PreencodedMimeBodyPart

        public PreencodedMimeBodyPart(String encoding)
        Create a PreencodedMimeBodyPart that assumes the data is encoded using the specified encoding. The encoding must be a MIME supported Content-Transfer-Encoding.

    • Method Detail

      • getEncoding

        public String getEncoding()
                   throws MessagingException
        Returns the content transfer encoding specified when this object was created.
        Specified by:
        getEncoding in interface MimePart
        Overrides:
        getEncoding in class MimeBodyPart
        Returns:
        content-transfer-encoding
        Throws:
        MessagingException
        See Also:
        MimeBodyPart.headers

      • writeTo

        public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
        Output the body part as an RFC 822 format stream.
        Specified by:
        writeTo in interface Part
        Overrides:
        writeTo in class MimeBodyPart
        Throws:
        MessagingException
        IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
        See Also:
        DataHandler.writeTo(java.io.OutputStream)

      • updateHeaders

        protected void updateHeaders()
                      throws MessagingException
        Force the Content-Transfer-Encoding header to use the encoding that was specified when this object was created.
        Overrides:
        updateHeaders in class MimeBodyPart
        Throws:
        MessagingException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SharedInputStream (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.internet

Interface SharedInputStream

  • All Known Implementing Classes:
    SharedByteArrayInputStream, SharedFileInputStream

    public interface SharedInputStream
    An InputStream that is backed by data that can be shared by multiple readers may implement this interface. This allows users of such an InputStream to determine the current position in the InputStream, and to create new InputStreams representing a subset of the data in the original InputStream. The new InputStream will access the same underlying data as the original, without copying the data.

    Note that implementations of this interface must ensure that the close method does not close any underlying stream that might be shared by multiple instances of SharedInputStream until all shared instances have been closed.

    Since:
    JavaMail 1.2
    Author:
    Bill Shannon

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getPosition()
      Return the current position in the InputStream, as an offset from the beginning of the InputStream.
      InputStream newStream(long start, long end)
      Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive).

    • Method Detail

      • getPosition

        long getPosition()
        Return the current position in the InputStream, as an offset from the beginning of the InputStream.
        Returns:
        the current position

      • newStream

        InputStream newStream(long start,
                    long end)
        Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive). start must be non-negative. If end is -1, the new stream ends at the same place as this stream. The returned InputStream will also implement the SharedInputStream interface.
        Parameters:
        start - the starting position
        end - the ending position + 1
        Returns:
        the new stream
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.mail.internet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.mail.internet

  • Packages that use javax.mail.internet
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.
    javax.mail.util
    JavaMail API utility classes.
  • Classes in javax.mail.internet used by javax.mail.internet
    Class and Description
    AddressException
    The exception thrown when a wrongly formatted address is encountered.
    ContentType
    This class represents a MIME Content-Type value.
    HeaderTokenizer.Token
    The Token class represents tokens returned by the HeaderTokenizer.
    InternetAddress
    This class represents an Internet email address using the syntax of RFC822.
    InternetHeaders
    InternetHeaders is a utility class that manages RFC822 style headers.
    MimeBodyPart
    This class represents a MIME body part.
    MimeMessage
    This class represents a MIME style email message.
    MimeMessage.RecipientType
    This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes.
    MimePart
    The MimePart interface models an Entity as defined by MIME (RFC2045, Section 2.4).
    NewsAddress
    This class models an RFC1036 newsgroup address.
    ParameterList
    This class holds MIME parameters (attribute-value pairs).
    ParseException
    The exception thrown due to an error in parsing RFC822 or MIME headers
  • Classes in javax.mail.internet used by javax.mail.util
    Class and Description
    SharedInputStream
    An InputStream that is backed by data that can be shared by multiple readers may implement this interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.AddressException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.AddressException

  • Packages that use AddressException
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of AddressException in javax.mail.internet

      Methods in javax.mail.internet that throw AddressException
      Modifier and Type Method and Description
      InternetAddress[] InternetAddress.getGroup(boolean strict)
      Return the members of a group address.
      static NewsAddress[] NewsAddress.parse(String newsgroups)
      Parse the given comma separated sequence of newsgroup into NewsAddress objects.
      static InternetAddress[] InternetAddress.parse(String addresslist)
      Parse the given comma separated sequence of addresses into InternetAddress objects.
      static InternetAddress[] InternetAddress.parse(String addresslist, boolean strict)
      Parse the given sequence of addresses into InternetAddress objects.
      static InternetAddress[] InternetAddress.parseHeader(String addresslist, boolean strict)
      Parse the given sequence of addresses into InternetAddress objects.
      void InternetAddress.validate()
      Validate that this address conforms to the syntax rules of RFC 822.
      Constructors in javax.mail.internet that throw AddressException
      Constructor and Description
      InternetAddress(String address)
      Constructor.
      InternetAddress(String address, boolean strict)
      Parse the given string and create an InternetAddress.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.ContentDisposition (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.ContentDisposition

No usage of javax.mail.internet.ContentDisposition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.ContentType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.ContentType

  • Packages that use ContentType
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of ContentType in javax.mail.internet

      Methods in javax.mail.internet with parameters of type ContentType
      Modifier and Type Method and Description
      boolean ContentType.match(ContentType cType)
      Match with the specified ContentType object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.HeaderTokenizer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.HeaderTokenizer

No usage of javax.mail.internet.HeaderTokenizer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.HeaderTokenizer.Token (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.HeaderTokenizer.Token

  • Packages that use HeaderTokenizer.Token
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of HeaderTokenizer.Token in javax.mail.internet

      Methods in javax.mail.internet that return HeaderTokenizer.Token
      Modifier and Type Method and Description
      HeaderTokenizer.Token HeaderTokenizer.next()
      Parses the next token from this String.
      HeaderTokenizer.Token HeaderTokenizer.next(char endOfAtom)
      Parses the next token from this String.
      HeaderTokenizer.Token HeaderTokenizer.next(char endOfAtom, boolean keepEscapes)
      Parses the next token from this String.
      HeaderTokenizer.Token HeaderTokenizer.peek()
      Peek at the next token, without actually removing the token from the parse stream.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.InternetAddress (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.InternetAddress

  • Packages that use InternetAddress
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of InternetAddress in javax.mail.internet

      Methods in javax.mail.internet that return InternetAddress
      Modifier and Type Method and Description
      InternetAddress[] InternetAddress.getGroup(boolean strict)
      Return the members of a group address.
      static InternetAddress InternetAddress.getLocalAddress(Session session)
      Return an InternetAddress object representing the current user.
      static InternetAddress[] InternetAddress.parse(String addresslist)
      Parse the given comma separated sequence of addresses into InternetAddress objects.
      static InternetAddress[] InternetAddress.parse(String addresslist, boolean strict)
      Parse the given sequence of addresses into InternetAddress objects.
      static InternetAddress[] InternetAddress.parseHeader(String addresslist, boolean strict)
      Parse the given sequence of addresses into InternetAddress objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.InternetHeaders (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.InternetHeaders

  • Packages that use InternetHeaders
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of InternetHeaders in javax.mail.internet

      Fields in javax.mail.internet declared as InternetHeaders
      Modifier and Type Field and Description
      protected InternetHeaders MimeMessage.headers
      The InternetHeaders object that stores the header of this message.
      protected InternetHeaders MimeBodyPart.headers
      The InternetHeaders object that stores all the headers of this body part.
      Methods in javax.mail.internet that return InternetHeaders
      Modifier and Type Method and Description
      protected InternetHeaders MimeMultipart.createInternetHeaders(InputStream is)
      Create and return an InternetHeaders object that loads the headers from the given InputStream.
      protected InternetHeaders MimeMessage.createInternetHeaders(InputStream is)
      Create and return an InternetHeaders object that loads the headers from the given InputStream.
      Methods in javax.mail.internet with parameters of type InternetHeaders
      Modifier and Type Method and Description
      protected MimeBodyPart MimeMultipart.createMimeBodyPart(InternetHeaders headers, byte[] content)
      Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
      Constructors in javax.mail.internet with parameters of type InternetHeaders
      Constructor and Description
      MimeBodyPart(InternetHeaders headers, byte[] content)
      Constructs a MimeBodyPart using the given header and content bytes.
      MimeMessage(Folder folder, InternetHeaders headers, byte[] content, int msgnum)
      Constructs a MimeMessage from the given InternetHeaders object and content.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.InternetHeaders.InternetHeader (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.InternetHeaders.InternetHeader

No usage of javax.mail.internet.InternetHeaders.InternetHeader
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.MailDateFormat (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.MailDateFormat

No usage of javax.mail.internet.MailDateFormat
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.MimeBodyPart (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.MimeBodyPart

  • Packages that use MimeBodyPart
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of MimeBodyPart in javax.mail.internet

      Subclasses of MimeBodyPart in javax.mail.internet
      Modifier and Type Class and Description
      class  PreencodedMimeBodyPart
      A MimeBodyPart that handles data that has already been encoded.
      Methods in javax.mail.internet that return MimeBodyPart
      Modifier and Type Method and Description
      protected MimeBodyPart MimeMultipart.createMimeBodyPart(InputStream is)
      Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
      protected MimeBodyPart MimeMultipart.createMimeBodyPart(InternetHeaders headers, byte[] content)
      Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.MimeMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.MimeMessage

  • Packages that use MimeMessage
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of MimeMessage in javax.mail.internet

      Methods in javax.mail.internet that return MimeMessage
      Modifier and Type Method and Description
      protected MimeMessage MimeMessage.createMimeMessage(Session session)
      Create and return a MimeMessage object.
      Constructors in javax.mail.internet with parameters of type MimeMessage
      Constructor and Description
      MimeMessage(MimeMessage source)
      Constructs a new MimeMessage with content initialized from the source MimeMessage.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.MimeMessage.RecipientType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.MimeMessage.RecipientType

  • Packages that use MimeMessage.RecipientType
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of MimeMessage.RecipientType in javax.mail.internet

      Fields in javax.mail.internet declared as MimeMessage.RecipientType
      Modifier and Type Field and Description
      static MimeMessage.RecipientType MimeMessage.RecipientType.NEWSGROUPS
      The "Newsgroup" (Usenet news) recipients.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.MimeMultipart (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.MimeMultipart

No usage of javax.mail.internet.MimeMultipart
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.MimePartDataSource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.MimePartDataSource

No usage of javax.mail.internet.MimePartDataSource
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.MimeUtility (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.MimeUtility

No usage of javax.mail.internet.MimeUtility
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.NewsAddress (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.NewsAddress

  • Packages that use NewsAddress
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of NewsAddress in javax.mail.internet

      Methods in javax.mail.internet that return NewsAddress
      Modifier and Type Method and Description
      static NewsAddress[] NewsAddress.parse(String newsgroups)
      Parse the given comma separated sequence of newsgroup into NewsAddress objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.ParameterList (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.ParameterList

  • Packages that use ParameterList
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of ParameterList in javax.mail.internet

      Methods in javax.mail.internet that return ParameterList
      Modifier and Type Method and Description
      ParameterList ContentType.getParameterList()
      Return a ParameterList object that holds all the available parameters.
      ParameterList ContentDisposition.getParameterList()
      Return a ParameterList object that holds all the available parameters.
      Methods in javax.mail.internet with parameters of type ParameterList
      Modifier and Type Method and Description
      void ContentType.setParameterList(ParameterList list)
      Set a new ParameterList.
      void ContentDisposition.setParameterList(ParameterList list)
      Set a new ParameterList.
      Constructors in javax.mail.internet with parameters of type ParameterList
      Constructor and Description
      ContentDisposition(String disposition, ParameterList list)
      Constructor.
      ContentType(String primaryType, String subType, ParameterList list)
      Constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.ParseException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.ParseException

  • Packages that use ParseException
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of ParseException in javax.mail.internet

      Subclasses of ParseException in javax.mail.internet
      Modifier and Type Class and Description
      class  AddressException
      The exception thrown when a wrongly formatted address is encountered.
      Methods in javax.mail.internet that throw ParseException
      Modifier and Type Method and Description
      static String MimeUtility.decodeWord(String eword)
      The string is parsed using the rules in RFC 2047 and RFC 2231 for parsing an "encoded-word".
      HeaderTokenizer.Token HeaderTokenizer.next()
      Parses the next token from this String.
      HeaderTokenizer.Token HeaderTokenizer.next(char endOfAtom)
      Parses the next token from this String.
      HeaderTokenizer.Token HeaderTokenizer.next(char endOfAtom, boolean keepEscapes)
      Parses the next token from this String.
      HeaderTokenizer.Token HeaderTokenizer.peek()
      Peek at the next token, without actually removing the token from the parse stream.
      Constructors in javax.mail.internet that throw ParseException
      Constructor and Description
      ContentDisposition(String s)
      Constructor that takes a ContentDisposition string.
      ContentType(String s)
      Constructor that takes a Content-Type string.
      ParameterList(String s)
      Constructor that takes a parameter-list string.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.internet.PreencodedMimeBodyPart (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.internet.PreencodedMimeBodyPart

No usage of javax.mail.internet.PreencodedMimeBodyPart
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.internet.MimePart (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.internet.MimePart

  • Packages that use MimePart
    Package Description
    javax.mail.internet
    Classes specific to Internet mail systems.

    • Uses of MimePart in javax.mail.internet

      Classes in javax.mail.internet that implement MimePart
      Modifier and Type Class and Description
      class  MimeBodyPart
      This class represents a MIME body part.
      class  MimeMessage
      This class represents a MIME style email message.
      class  PreencodedMimeBodyPart
      A MimeBodyPart that handles data that has already been encoded.
      Fields in javax.mail.internet declared as MimePart
      Modifier and Type Field and Description
      protected MimePart MimePartDataSource.part
      The MimePart that provides the data for this DataSource.
      Constructors in javax.mail.internet with parameters of type MimePart
      Constructor and Description
      MimePartDataSource(MimePart part)
      Constructor, that constructs a DataSource from a MimePart.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.mail.internet.SharedInputStream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.mail.internet.SharedInputStream

  • Packages that use SharedInputStream
    Package Description
    javax.mail.util
    JavaMail API utility classes.

    • Uses of SharedInputStream in javax.mail.util

      Classes in javax.mail.util that implement SharedInputStream
      Modifier and Type Class and Description
      class  SharedByteArrayInputStream
      A ByteArrayInputStream that implements the SharedInputStream interface, allowing the underlying byte array to be shared between multiple readers.
      class  SharedFileInputStream
      A SharedFileInputStream is a BufferedInputStream that buffers data from the file and supports the mark and reset methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AddressStringTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class AddressStringTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.AddressStringTerm
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    FromStringTerm, RecipientStringTerm

    public abstract class AddressStringTerm
extends StringTerm
    This abstract class implements string comparisons for Message addresses.

    Note that this class differs from the AddressTerm class in that this class does comparisons on address strings rather than Address objects.

    Since:
    JavaMail 1.1
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.StringTerm

        ignoreCase, pattern

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected AddressStringTerm(String pattern)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      protected boolean match(Address a)
      Check whether the address pattern specified in the constructor is a substring of the string representation of the given Address object.

      • Methods inherited from class javax.mail.search.StringTerm

        getIgnoreCase, getPattern, hashCode, match

      • Methods inherited from class javax.mail.search.SearchTerm

        match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AddressStringTerm

        protected AddressStringTerm(String pattern)
        Constructor.
        Parameters:
        pattern - the address pattern to be compared.

    • Method Detail

      • match

        protected boolean match(Address a)
        Check whether the address pattern specified in the constructor is a substring of the string representation of the given Address object.

        Note that if the string representation of the given Address object contains charset or transfer encodings, the encodings must be accounted for, during the match process.

        Parameters:
        a - The comparison is applied to this Address object.
        Returns:
        true if the match succeeds, otherwise false.

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class StringTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AddressTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class AddressTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.AddressTerm
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    FromTerm, RecipientTerm

    public abstract class AddressTerm
extends SearchTerm
    This class implements Message Address comparisons.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Address address
      The address.

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | AddressTerm(Address address)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      Address getAddress()
      Return the address to match with.
      int hashCode()
      Compute a hashCode for this object.
      protected boolean match(Address a)
      Match against the argument Address.

      • Methods inherited from class javax.mail.search.SearchTerm

        match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • address

        protected Address address
        The address.

    • Constructor Detail

      • AddressTerm

        protected AddressTerm(Address address)

    • Method Detail

      • getAddress

        public Address getAddress()
        Return the address to match with.

      • match

        protected boolean match(Address a)
        Match against the argument Address.

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AndTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class AndTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.AndTerm
  • All Implemented Interfaces:
    Serializable

    public final class AndTerm
extends SearchTerm
    This class implements the logical AND operator on individual SearchTerms.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      AndTerm(SearchTerm[] t)
      Constructor that takes an array of SearchTerms.
      AndTerm(SearchTerm t1, SearchTerm t2)
      Constructor that takes two terms.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      SearchTerm[] getTerms()
      Return the search terms.
      int hashCode()
      Compute a hashCode for this object.
      boolean match(Message msg)
      The AND operation.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AndTerm

        public AndTerm(SearchTerm t1,
       SearchTerm t2)
        Constructor that takes two terms.
        Parameters:
        t1 - first term
        t2 - second term

      • AndTerm

        public AndTerm(SearchTerm[] t)
        Constructor that takes an array of SearchTerms.
        Parameters:
        t - array of terms

    • Method Detail

      • getTerms

        public SearchTerm[] getTerms()
        Return the search terms.

      • match

        public boolean match(Message msg)
        The AND operation.

        The terms specified in the constructor are applied to the given object and the AND operator is applied to their results.

        Specified by:
        match in class SearchTerm
        Parameters:
        msg - The specified SearchTerms are applied to this Message and the AND operator is applied to their results.
        Returns:
        true if the AND succeds, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BodyTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class BodyTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.BodyTerm
  • All Implemented Interfaces:
    Serializable

    public final class BodyTerm
extends StringTerm
    This class implements searches on a message body. All parts of the message that are of MIME type "text/*" are searched. The pattern is a simple string that must appear as a substring in the message body.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.StringTerm

        ignoreCase, pattern

    • Constructor Summary

      Constructors
      Constructor and Description
      BodyTerm(String pattern)
      Constructor

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      boolean match(Message msg)
      The match method.

      • Methods inherited from class javax.mail.search.StringTerm

        getIgnoreCase, getPattern, hashCode, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BodyTerm

        public BodyTerm(String pattern)
        Constructor
        Parameters:
        pattern - The String to search for

    • Method Detail

      • match

        public boolean match(Message msg)
        The match method.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - The pattern search is applied on this Message's body
        Returns:
        true if the pattern is found; otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class StringTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ComparisonTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class ComparisonTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.ComparisonTerm
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    DateTerm, IntegerComparisonTerm

    public abstract class ComparisonTerm
extends SearchTerm
    This class models the comparison operator. This is an abstract class; subclasses implement comparisons for different datatypes.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected int comparison
      The comparison.
      static int | EQ
      static int | GE
      static int | GT
      static int | LE
      static int | LT
      static int | NE

    • Constructor Summary

      Constructors
      Constructor and Description
      ComparisonTerm()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      int hashCode()
      Compute a hashCode for this object.

      • Methods inherited from class javax.mail.search.SearchTerm

        match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • LE

        public static final int LE
        See Also:
        Constant Field Values

      • LT

        public static final int LT
        See Also:
        Constant Field Values

      • EQ

        public static final int EQ
        See Also:
        Constant Field Values

      • NE

        public static final int NE
        See Also:
        Constant Field Values

      • GT

        public static final int GT
        See Also:
        Constant Field Values

      • GE

        public static final int GE
        See Also:
        Constant Field Values

      • comparison

        protected int comparison
        The comparison.

    • Constructor Detail

      • ComparisonTerm

        public ComparisonTerm()

    • Method Detail

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DateTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class DateTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.ComparisonTerm
        • javax.mail.search.DateTerm
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ReceivedDateTerm, SentDateTerm

    public abstract class DateTerm
extends ComparisonTerm
    This class implements comparisons for Dates
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Date date
      The date.

      • Fields inherited from class javax.mail.search.ComparisonTerm

        comparison, EQ, GE, GT, LE, LT, NE

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected DateTerm(int comparison, Date date)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      int getComparison()
      Return the type of comparison.
      Date getDate()
      Return the Date to compare with.
      int hashCode()
      Compute a hashCode for this object.
      protected boolean match(Date d)
      The date comparison method.

      • Methods inherited from class javax.mail.search.SearchTerm

        match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • date

        protected Date date
        The date.

    • Constructor Detail

      • DateTerm

        protected DateTerm(int comparison,
        Date date)
        Constructor.
        Parameters:
        comparison - the comparison type
        date - The Date to be compared against

    • Method Detail

      • getDate

        public Date getDate()
        Return the Date to compare with.

      • getComparison

        public int getComparison()
        Return the type of comparison.

      • match

        protected boolean match(Date d)
        The date comparison method.
        Parameters:
        d - the date in the constructor is compared with this date
        Returns:
        true if the dates match, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class ComparisonTerm

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class ComparisonTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FlagTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class FlagTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.FlagTerm
  • All Implemented Interfaces:
    Serializable

    public final class FlagTerm
extends SearchTerm
    This class implements comparisons for Message Flags.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      FlagTerm(Flags flags, boolean set)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      Flags getFlags()
      Return the Flags to test.
      boolean getTestSet()
      Return true if testing whether the flags are set.
      int hashCode()
      Compute a hashCode for this object.
      boolean match(Message msg)
      The comparison method.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FlagTerm

        public FlagTerm(Flags flags,
        boolean set)
        Constructor.
        Parameters:
        flags - Flags object containing the flags to check for
        set - the flag setting to check for

    • Method Detail

      • getFlags

        public Flags getFlags()
        Return the Flags to test.

      • getTestSet

        public boolean getTestSet()
        Return true if testing whether the flags are set.

      • match

        public boolean match(Message msg)
        The comparison method.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - The flag comparison is applied to this Message
        Returns:
        true if the comparson succeeds, otherwise false.

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FromStringTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class FromStringTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.AddressStringTerm
          • javax.mail.search.FromStringTerm
  • All Implemented Interfaces:
    Serializable

    public final class FromStringTerm
extends AddressStringTerm
    This class implements string comparisons for the From Address header.

    Note that this class differs from the FromTerm class in that this class does comparisons on address strings rather than Address objects. The string comparisons are case-insensitive.

    Since:
    JavaMail 1.1
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.StringTerm

        ignoreCase, pattern

    • Constructor Summary

      Constructors
      Constructor and Description
      FromStringTerm(String pattern)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      boolean match(Message msg)
      Check whether the address string specified in the constructor is a substring of the From address of this Message.

      • Methods inherited from class javax.mail.search.AddressStringTerm

        match

      • Methods inherited from class javax.mail.search.StringTerm

        getIgnoreCase, getPattern, hashCode, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FromStringTerm

        public FromStringTerm(String pattern)
        Constructor.
        Parameters:
        pattern - the address pattern to be compared.

    • Method Detail

      • match

        public boolean match(Message msg)
        Check whether the address string specified in the constructor is a substring of the From address of this Message.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - The comparison is applied to this Message's From address.
        Returns:
        true if the match succeeds, otherwise false.

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class AddressStringTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FromTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class FromTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.AddressTerm
        • javax.mail.search.FromTerm
  • All Implemented Interfaces:
    Serializable

    public final class FromTerm
extends AddressTerm
    This class implements comparisons for the From Address header.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.AddressTerm

        address

    • Constructor Summary

      Constructors
      Constructor and Description
      FromTerm(Address address)
      Constructor

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      boolean match(Message msg)
      The address comparator.

      • Methods inherited from class javax.mail.search.AddressTerm

        getAddress, hashCode, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FromTerm

        public FromTerm(Address address)
        Constructor
        Parameters:
        address - The Address to be compared

    • Method Detail

      • match

        public boolean match(Message msg)
        The address comparator.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - The address comparison is applied to this Message
        Returns:
        true if the comparison succeeds, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class AddressTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HeaderTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class HeaderTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.HeaderTerm
  • All Implemented Interfaces:
    Serializable

    public final class HeaderTerm
extends StringTerm
    This class implements comparisons for Message headers. The comparison is case-insensitive.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.StringTerm

        ignoreCase, pattern

    • Constructor Summary

      Constructors
      Constructor and Description
      HeaderTerm(String headerName, String pattern)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      String getHeaderName()
      Return the name of the header to compare with.
      int hashCode()
      Compute a hashCode for this object.
      boolean match(Message msg)
      The header match method.

      • Methods inherited from class javax.mail.search.StringTerm

        getIgnoreCase, getPattern, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HeaderTerm

        public HeaderTerm(String headerName,
          String pattern)
        Constructor.
        Parameters:
        headerName - The name of the header
        pattern - The pattern to search for

    • Method Detail

      • getHeaderName

        public String getHeaderName()
        Return the name of the header to compare with.

      • match

        public boolean match(Message msg)
        The header match method.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - The match is applied to this Message's header
        Returns:
        true if the match succeeds, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class StringTerm

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class StringTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IntegerComparisonTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class IntegerComparisonTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.ComparisonTerm
        • javax.mail.search.IntegerComparisonTerm
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    MessageNumberTerm, SizeTerm

    public abstract class IntegerComparisonTerm
extends ComparisonTerm
    This class implements comparisons for integers.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected int number
      The number.

      • Fields inherited from class javax.mail.search.ComparisonTerm

        comparison, EQ, GE, GT, LE, LT, NE

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | IntegerComparisonTerm(int comparison, int number)

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      boolean equals(Object obj)
      Equality comparison.
      int getComparison()
      Return the type of comparison.
      int getNumber()
      Return the number to compare with.
      int hashCode()
      Compute a hashCode for this object.
      protected boolean | match(int i)

      • Methods inherited from class javax.mail.search.SearchTerm

        match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • number

        protected int number
        The number.

    • Constructor Detail

      • IntegerComparisonTerm

        protected IntegerComparisonTerm(int comparison,
                     int number)

    • Method Detail

      • getNumber

        public int getNumber()
        Return the number to compare with.

      • getComparison

        public int getComparison()
        Return the type of comparison.

      • match

        protected boolean match(int i)

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class ComparisonTerm

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class ComparisonTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.mail.search (Java(TM) EE 7 Specification APIs)

javax.mail.search

Classes

  • AddressStringTerm
  • AddressTerm
  • AndTerm
  • BodyTerm
  • ComparisonTerm
  • DateTerm
  • FlagTerm
  • FromStringTerm
  • FromTerm
  • HeaderTerm
  • IntegerComparisonTerm
  • MessageIDTerm
  • MessageNumberTerm
  • NotTerm
  • OrTerm
  • ReceivedDateTerm
  • RecipientStringTerm
  • RecipientTerm
  • SearchTerm
  • SentDateTerm
  • SizeTerm
  • StringTerm
  • SubjectTerm

Exceptions

  • SearchException


javax.mail.search (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.mail.search

Message search terms for the JavaMail API.

See: Description

  • Class Summary
    Class Description
    AddressStringTerm
    This abstract class implements string comparisons for Message addresses.
    AddressTerm
    This class implements Message Address comparisons.
    AndTerm
    This class implements the logical AND operator on individual SearchTerms.
    BodyTerm
    This class implements searches on a message body.
    ComparisonTerm
    This class models the comparison operator.
    DateTerm
    This class implements comparisons for Dates
    FlagTerm
    This class implements comparisons for Message Flags.
    FromStringTerm
    This class implements string comparisons for the From Address header.
    FromTerm
    This class implements comparisons for the From Address header.
    HeaderTerm
    This class implements comparisons for Message headers.
    IntegerComparisonTerm
    This class implements comparisons for integers.
    MessageIDTerm
    This term models the RFC822 "MessageId" - a message-id for Internet messages that is supposed to be unique per message.
    MessageNumberTerm
    This class implements comparisons for Message numbers.
    NotTerm
    This class implements the logical NEGATION operator.
    OrTerm
    This class implements the logical OR operator on individual SearchTerms.
    ReceivedDateTerm
    This class implements comparisons for the Message Received date
    RecipientStringTerm
    This class implements string comparisons for the Recipient Address headers.
    RecipientTerm
    This class implements comparisons for the Recipient Address headers.
    SearchTerm
    Search criteria are expressed as a tree of search-terms, forming a parse-tree for the search expression.
    SentDateTerm
    This class implements comparisons for the Message SentDate.
    SizeTerm
    This class implements comparisons for Message sizes.
    StringTerm
    This class implements the match method for Strings.
    SubjectTerm
    This class implements comparisons for the message Subject header.
  • Exception Summary
    Exception Description
    SearchException
    The exception thrown when a Search expression could not be handled.

Package javax.mail.search Description

Message search terms for the JavaMail API. This package defines classes that can be used to construct a search expression to search a folder for messages matching the expression; see the search method on javax.mail.Folder. See SearchTerm.

Note that the exact search capabilities depend on the protocol, provider, and server in use. For the POP3 protocol, all searching is done on the client side using the JavaMail classes. For IMAP, all searching is done on the server side and is limited by the search capabilities of the IMAP protocol and the IMAP server being used. For example, IMAP date based searches have only day granularity.

In general, all of the string patterns supported by search terms are just simple strings; no regular expressions are supported.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.mail.search Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.mail.search

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.mail.search.SearchTerm (implements java.io.Serializable)
      • javax.mail.search.AddressTerm
        • javax.mail.search.FromTerm
        • javax.mail.search.RecipientTerm
      • javax.mail.search.AndTerm
      • javax.mail.search.ComparisonTerm
        • javax.mail.search.DateTerm
          • javax.mail.search.ReceivedDateTerm
          • javax.mail.search.SentDateTerm
        • javax.mail.search.IntegerComparisonTerm
          • javax.mail.search.MessageNumberTerm
          • javax.mail.search.SizeTerm
      • javax.mail.search.FlagTerm
      • javax.mail.search.NotTerm
      • javax.mail.search.OrTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.AddressStringTerm
          • javax.mail.search.FromStringTerm
          • javax.mail.search.RecipientStringTerm
        • javax.mail.search.BodyTerm
        • javax.mail.search.HeaderTerm
        • javax.mail.search.MessageIDTerm
        • javax.mail.search.SubjectTerm
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.search.SearchException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MessageIDTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class MessageIDTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.MessageIDTerm
  • All Implemented Interfaces:
    Serializable

    public final class MessageIDTerm
extends StringTerm
    This term models the RFC822 "MessageId" - a message-id for Internet messages that is supposed to be unique per message. Clients can use this term to search a folder for a message given its MessageId.

    The MessageId is represented as a String.

    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.StringTerm

        ignoreCase, pattern

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageIDTerm(String msgid)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      boolean match(Message msg)
      The match method.

      • Methods inherited from class javax.mail.search.StringTerm

        getIgnoreCase, getPattern, hashCode, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MessageIDTerm

        public MessageIDTerm(String msgid)
        Constructor.
        Parameters:
        msgid - the msgid to search for

    • Method Detail

      • match

        public boolean match(Message msg)
        The match method.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - the match is applied to this Message's Message-ID header
        Returns:
        true if the match succeeds, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class StringTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageNumberTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class MessageNumberTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.ComparisonTerm
        • javax.mail.search.IntegerComparisonTerm
          • javax.mail.search.MessageNumberTerm
  • All Implemented Interfaces:
    Serializable

    public final class MessageNumberTerm
extends IntegerComparisonTerm
    This class implements comparisons for Message numbers.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.IntegerComparisonTerm

        number

      • Fields inherited from class javax.mail.search.ComparisonTerm

        comparison, EQ, GE, GT, LE, LT, NE

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageNumberTerm(int number)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      boolean match(Message msg)
      The match method.

      • Methods inherited from class javax.mail.search.IntegerComparisonTerm

        getComparison, getNumber, hashCode, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MessageNumberTerm

        public MessageNumberTerm(int number)
        Constructor.
        Parameters:
        number - the Message number

    • Method Detail

      • match

        public boolean match(Message msg)
        The match method.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - the Message number is matched with this Message
        Returns:
        true if the match succeeds, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class IntegerComparisonTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NotTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class NotTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.NotTerm
  • All Implemented Interfaces:
    Serializable

    public final class NotTerm
extends SearchTerm
    This class implements the logical NEGATION operator.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NotTerm(SearchTerm t)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      SearchTerm getTerm()
      Return the term to negate.
      int hashCode()
      Compute a hashCode for this object.
      boolean match(Message msg)
      This method applies a specific match criterion to the given message and returns the result.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NotTerm

        public NotTerm(SearchTerm t)

    • Method Detail

      • getTerm

        public SearchTerm getTerm()
        Return the term to negate.

      • match

        public boolean match(Message msg)
        Description copied from class: SearchTerm
        This method applies a specific match criterion to the given message and returns the result.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - The match criterion is applied on this message
        Returns:
        true, it the match succeeds, false if the match fails

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


OrTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class OrTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.OrTerm
  • All Implemented Interfaces:
    Serializable

    public final class OrTerm
extends SearchTerm
    This class implements the logical OR operator on individual SearchTerms.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      OrTerm(SearchTerm[] t)
      Constructor that takes an array of SearchTerms.
      OrTerm(SearchTerm t1, SearchTerm t2)
      Constructor that takes two operands.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      SearchTerm[] getTerms()
      Return the search terms.
      int hashCode()
      Compute a hashCode for this object.
      boolean match(Message msg)
      The OR operation.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • OrTerm

        public OrTerm(SearchTerm t1,
      SearchTerm t2)
        Constructor that takes two operands.
        Parameters:
        t1 - first term
        t2 - second term

      • OrTerm

        public OrTerm(SearchTerm[] t)
        Constructor that takes an array of SearchTerms.
        Parameters:
        t - array of search terms

    • Method Detail

      • getTerms

        public SearchTerm[] getTerms()
        Return the search terms.

      • match

        public boolean match(Message msg)
        The OR operation.

        The terms specified in the constructor are applied to the given object and the OR operator is applied to their results.

        Specified by:
        match in class SearchTerm
        Parameters:
        msg - The specified SearchTerms are applied to this Message and the OR operator is applied to their results.
        Returns:
        true if the OR succeds, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ReceivedDateTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class ReceivedDateTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.ComparisonTerm
        • javax.mail.search.DateTerm
          • javax.mail.search.ReceivedDateTerm
  • All Implemented Interfaces:
    Serializable

    public final class ReceivedDateTerm
extends DateTerm
    This class implements comparisons for the Message Received date
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.DateTerm

        date

      • Fields inherited from class javax.mail.search.ComparisonTerm

        comparison, EQ, GE, GT, LE, LT, NE

    • Constructor Summary

      Constructors
      Constructor and Description
      ReceivedDateTerm(int comparison, Date date)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      boolean match(Message msg)
      The match method.

      • Methods inherited from class javax.mail.search.DateTerm

        getComparison, getDate, hashCode, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ReceivedDateTerm

        public ReceivedDateTerm(int comparison,
                Date date)
        Constructor.
        Parameters:
        comparison - the Comparison type
        date - the date to be compared

    • Method Detail

      • match

        public boolean match(Message msg)
        The match method.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - the date comparator is applied to this Message's sent date
        Returns:
        true if the comparison succeeds, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class DateTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RecipientStringTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class RecipientStringTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.AddressStringTerm
          • javax.mail.search.RecipientStringTerm
  • All Implemented Interfaces:
    Serializable

    public final class RecipientStringTerm
extends AddressStringTerm
    This class implements string comparisons for the Recipient Address headers.

    Note that this class differs from the RecipientTerm class in that this class does comparisons on address strings rather than Address objects. The string comparisons are case-insensitive.

    Since:
    JavaMail 1.1
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.StringTerm

        ignoreCase, pattern

    • Constructor Summary

      Constructors
      Constructor and Description
      RecipientStringTerm(Message.RecipientType type, String pattern)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      Message.RecipientType getRecipientType()
      Return the type of recipient to match with.
      int hashCode()
      Compute a hashCode for this object.
      boolean match(Message msg)
      Check whether the address specified in the constructor is a substring of the recipient address of this Message.

      • Methods inherited from class javax.mail.search.AddressStringTerm

        match

      • Methods inherited from class javax.mail.search.StringTerm

        getIgnoreCase, getPattern, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • RecipientStringTerm

        public RecipientStringTerm(Message.RecipientType type,
                   String pattern)
        Constructor.
        Parameters:
        type - the recipient type
        pattern - the address pattern to be compared.

    • Method Detail

      • getRecipientType

        public Message.RecipientType getRecipientType()
        Return the type of recipient to match with.

      • match

        public boolean match(Message msg)
        Check whether the address specified in the constructor is a substring of the recipient address of this Message.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - The comparison is applied to this Message's recipient address.
        Returns:
        true if the match succeeds, otherwise false.

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class AddressStringTerm

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class StringTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RecipientTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class RecipientTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.AddressTerm
        • javax.mail.search.RecipientTerm
  • All Implemented Interfaces:
    Serializable

    public final class RecipientTerm
extends AddressTerm
    This class implements comparisons for the Recipient Address headers.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.AddressTerm

        address

    • Constructor Summary

      Constructors
      Constructor and Description
      RecipientTerm(Message.RecipientType type, Address address)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      Message.RecipientType getRecipientType()
      Return the type of recipient to match with.
      int hashCode()
      Compute a hashCode for this object.
      boolean match(Message msg)
      The match method.

      • Methods inherited from class javax.mail.search.AddressTerm

        getAddress, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • RecipientTerm

        public RecipientTerm(Message.RecipientType type,
             Address address)
        Constructor.
        Parameters:
        type - the recipient type
        address - the address to match for

    • Method Detail

      • getRecipientType

        public Message.RecipientType getRecipientType()
        Return the type of recipient to match with.

      • match

        public boolean match(Message msg)
        The match method.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - The address match is applied to this Message's recepient address
        Returns:
        true if the match succeeds, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class AddressTerm

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class AddressTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SearchException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class SearchException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.search.SearchException
  • All Implemented Interfaces:
    Serializable

    public class SearchException
extends MessagingException
    The exception thrown when a Search expression could not be handled.
    Author:
    John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SearchException()
      Constructs a SearchException with no detail message.
      SearchException(String s)
      Constructs a SearchException with the specified detail message.

    • Method Summary

      • Methods inherited from class javax.mail.MessagingException

        getCause, getNextException, setNextException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SearchException

        public SearchException()
        Constructs a SearchException with no detail message.

      • SearchException

        public SearchException(String s)
        Constructs a SearchException with the specified detail message.
        Parameters:
        s - the detail message
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SearchTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class SearchTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    AddressTerm, AndTerm, ComparisonTerm, FlagTerm, NotTerm, OrTerm, StringTerm

    public abstract class SearchTerm
extends Object
implements Serializable
    Search criteria are expressed as a tree of search-terms, forming a parse-tree for the search expression.

    Search-terms are represented by this class. This is an abstract class; subclasses implement specific match methods.

    Search terms are serializable, which allows storing a search term between sessions. Warning: Serialized objects of this class may not be compatible with future JavaMail API releases. The current serialization support is appropriate for short term storage.

    Warning: Search terms that include references to objects of type Message.RecipientType will not be deserialized correctly on JDK 1.1 systems. While these objects will be deserialized without throwing any exceptions, the resulting objects violate the type-safe enum contract of the Message.RecipientType class. Proper deserialization of these objects depends on support for the readReplace method, added in JDK 1.2.

    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SearchTerm()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract boolean match(Message msg)
      This method applies a specific match criterion to the given message and returns the result.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SearchTerm

        public SearchTerm()

    • Method Detail

      • match

        public abstract boolean match(Message msg)
        This method applies a specific match criterion to the given message and returns the result.
        Parameters:
        msg - The match criterion is applied on this message
        Returns:
        true, it the match succeeds, false if the match fails
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SentDateTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class SentDateTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.ComparisonTerm
        • javax.mail.search.DateTerm
          • javax.mail.search.SentDateTerm
  • All Implemented Interfaces:
    Serializable

    public final class SentDateTerm
extends DateTerm
    This class implements comparisons for the Message SentDate.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.DateTerm

        date

      • Fields inherited from class javax.mail.search.ComparisonTerm

        comparison, EQ, GE, GT, LE, LT, NE

    • Constructor Summary

      Constructors
      Constructor and Description
      SentDateTerm(int comparison, Date date)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      boolean match(Message msg)
      The match method.

      • Methods inherited from class javax.mail.search.DateTerm

        getComparison, getDate, hashCode, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SentDateTerm

        public SentDateTerm(int comparison,
            Date date)
        Constructor.
        Parameters:
        comparison - the Comparison type
        date - the date to be compared

    • Method Detail

      • match

        public boolean match(Message msg)
        The match method.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - the date comparator is applied to this Message's sent date
        Returns:
        true if the comparison succeeds, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class DateTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SizeTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class SizeTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.ComparisonTerm
        • javax.mail.search.IntegerComparisonTerm
          • javax.mail.search.SizeTerm
  • All Implemented Interfaces:
    Serializable

    public final class SizeTerm
extends IntegerComparisonTerm
    This class implements comparisons for Message sizes.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.IntegerComparisonTerm

        number

      • Fields inherited from class javax.mail.search.ComparisonTerm

        comparison, EQ, GE, GT, LE, LT, NE

    • Constructor Summary

      Constructors
      Constructor and Description
      SizeTerm(int comparison, int size)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      boolean match(Message msg)
      The match method.

      • Methods inherited from class javax.mail.search.IntegerComparisonTerm

        getComparison, getNumber, hashCode, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SizeTerm

        public SizeTerm(int comparison,
        int size)
        Constructor.
        Parameters:
        comparison - the Comparison type
        size - the size

    • Method Detail

      • match

        public boolean match(Message msg)
        The match method.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - the size comparator is applied to this Message's size
        Returns:
        true if the size is equal, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class IntegerComparisonTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StringTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class StringTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.StringTerm
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    AddressStringTerm, BodyTerm, HeaderTerm, MessageIDTerm, SubjectTerm

    public abstract class StringTerm
extends SearchTerm
    This class implements the match method for Strings. The current implementation provides only for substring matching. We could add comparisons (like strcmp ...).
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean ignoreCase
      Ignore case when comparing?
      protected String pattern
      The pattern.

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | StringTerm(String pattern)
      protected | StringTerm(String pattern, boolean ignoreCase)

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      boolean equals(Object obj)
      Equality comparison.
      boolean getIgnoreCase()
      Return true if we should ignore case when matching.
      String getPattern()
      Return the string to match with.
      int hashCode()
      Compute a hashCode for this object.
      protected boolean | match(String s)

      • Methods inherited from class javax.mail.search.SearchTerm

        match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • pattern

        protected String pattern
        The pattern.

      • ignoreCase

        protected boolean ignoreCase
        Ignore case when comparing?

    • Constructor Detail

      • StringTerm

        protected StringTerm(String pattern)

      • StringTerm

        protected StringTerm(String pattern,
          boolean ignoreCase)

    • Method Detail

      • getPattern

        public String getPattern()
        Return the string to match with.

      • getIgnoreCase

        public boolean getIgnoreCase()
        Return true if we should ignore case when matching.

      • match

        protected boolean match(String s)

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Compute a hashCode for this object.
        Overrides:
        hashCode in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SubjectTerm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.search

Class SubjectTerm

  • java.lang.Object
    • javax.mail.search.SearchTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.SubjectTerm
  • All Implemented Interfaces:
    Serializable

    public final class SubjectTerm
extends StringTerm
    This class implements comparisons for the message Subject header. The comparison is case-insensitive. The pattern is a simple string that must appear as a substring in the Subject.
    Author:
    Bill Shannon, John Mani
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.mail.search.StringTerm

        ignoreCase, pattern

    • Constructor Summary

      Constructors
      Constructor and Description
      SubjectTerm(String pattern)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Equality comparison.
      boolean match(Message msg)
      The match method.

      • Methods inherited from class javax.mail.search.StringTerm

        getIgnoreCase, getPattern, hashCode, match

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SubjectTerm

        public SubjectTerm(String pattern)
        Constructor.
        Parameters:
        pattern - the pattern to search for

    • Method Detail

      • match

        public boolean match(Message msg)
        The match method.
        Specified by:
        match in class SearchTerm
        Parameters:
        msg - the pattern match is applied to this Message's subject header
        Returns:
        true if the pattern match succeeds, otherwise false

      • equals

        public boolean equals(Object obj)
        Equality comparison.
        Overrides:
        equals in class StringTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.mail.search (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.mail.search

  • Packages that use javax.mail.search
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.search
    Message search terms for the JavaMail API.
  • Classes in javax.mail.search used by javax.mail
    Class and Description
    SearchTerm
    Search criteria are expressed as a tree of search-terms, forming a parse-tree for the search expression.
  • Classes in javax.mail.search used by javax.mail.search
    Class and Description
    AddressStringTerm
    This abstract class implements string comparisons for Message addresses.
    AddressTerm
    This class implements Message Address comparisons.
    ComparisonTerm
    This class models the comparison operator.
    DateTerm
    This class implements comparisons for Dates
    IntegerComparisonTerm
    This class implements comparisons for integers.
    SearchTerm
    Search criteria are expressed as a tree of search-terms, forming a parse-tree for the search expression.
    StringTerm
    This class implements the match method for Strings.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.AddressStringTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.AddressStringTerm

  • Packages that use AddressStringTerm
    Package Description
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of AddressStringTerm in javax.mail.search

      Subclasses of AddressStringTerm in javax.mail.search
      Modifier and Type Class and Description
      class  FromStringTerm
      This class implements string comparisons for the From Address header.
      class  RecipientStringTerm
      This class implements string comparisons for the Recipient Address headers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.AddressTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.AddressTerm

  • Packages that use AddressTerm
    Package Description
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of AddressTerm in javax.mail.search

      Subclasses of AddressTerm in javax.mail.search
      Modifier and Type Class and Description
      class  FromTerm
      This class implements comparisons for the From Address header.
      class  RecipientTerm
      This class implements comparisons for the Recipient Address headers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.AndTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.AndTerm

No usage of javax.mail.search.AndTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.BodyTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.BodyTerm

No usage of javax.mail.search.BodyTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.ComparisonTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.ComparisonTerm

  • Packages that use ComparisonTerm
    Package Description
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of ComparisonTerm in javax.mail.search

      Subclasses of ComparisonTerm in javax.mail.search
      Modifier and Type Class and Description
      class  DateTerm
      This class implements comparisons for Dates
      class  IntegerComparisonTerm
      This class implements comparisons for integers.
      class  MessageNumberTerm
      This class implements comparisons for Message numbers.
      class  ReceivedDateTerm
      This class implements comparisons for the Message Received date
      class  SentDateTerm
      This class implements comparisons for the Message SentDate.
      class  SizeTerm
      This class implements comparisons for Message sizes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.DateTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.DateTerm

  • Packages that use DateTerm
    Package Description
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of DateTerm in javax.mail.search

      Subclasses of DateTerm in javax.mail.search
      Modifier and Type Class and Description
      class  ReceivedDateTerm
      This class implements comparisons for the Message Received date
      class  SentDateTerm
      This class implements comparisons for the Message SentDate.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.FlagTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.FlagTerm

No usage of javax.mail.search.FlagTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.FromStringTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.FromStringTerm

No usage of javax.mail.search.FromStringTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.FromTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.FromTerm

No usage of javax.mail.search.FromTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.HeaderTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.HeaderTerm

No usage of javax.mail.search.HeaderTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.IntegerComparisonTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.IntegerComparisonTerm

  • Packages that use IntegerComparisonTerm
    Package Description
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of IntegerComparisonTerm in javax.mail.search

      Subclasses of IntegerComparisonTerm in javax.mail.search
      Modifier and Type Class and Description
      class  MessageNumberTerm
      This class implements comparisons for Message numbers.
      class  SizeTerm
      This class implements comparisons for Message sizes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.MessageIDTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.MessageIDTerm

No usage of javax.mail.search.MessageIDTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.MessageNumberTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.MessageNumberTerm

No usage of javax.mail.search.MessageNumberTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.NotTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.NotTerm

No usage of javax.mail.search.NotTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.OrTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.OrTerm

No usage of javax.mail.search.OrTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.ReceivedDateTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.ReceivedDateTerm

No usage of javax.mail.search.ReceivedDateTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.RecipientStringTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.RecipientStringTerm

No usage of javax.mail.search.RecipientStringTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.RecipientTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.RecipientTerm

No usage of javax.mail.search.RecipientTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.SearchException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.SearchException

No usage of javax.mail.search.SearchException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.SearchTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.SearchTerm

  • Packages that use SearchTerm
    Package Description
    javax.mail
    The JavaMailTM API provides classes that model a mail system.
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of SearchTerm in javax.mail

      Methods in javax.mail with parameters of type SearchTerm
      Modifier and Type Method and Description
      boolean Message.match(SearchTerm term)
      Apply the specified Search criterion to this message.
      Message[] Folder.search(SearchTerm term)
      Search this Folder for messages matching the specified search criterion.
      Message[] Folder.search(SearchTerm term, Message[] msgs)
      Search the given array of messages for those that match the specified search criterion.

    • Uses of SearchTerm in javax.mail.search

      Subclasses of SearchTerm in javax.mail.search
      Modifier and Type Class and Description
      class  AddressStringTerm
      This abstract class implements string comparisons for Message addresses.
      class  AddressTerm
      This class implements Message Address comparisons.
      class  AndTerm
      This class implements the logical AND operator on individual SearchTerms.
      class  BodyTerm
      This class implements searches on a message body.
      class  ComparisonTerm
      This class models the comparison operator.
      class  DateTerm
      This class implements comparisons for Dates
      class  FlagTerm
      This class implements comparisons for Message Flags.
      class  FromStringTerm
      This class implements string comparisons for the From Address header.
      class  FromTerm
      This class implements comparisons for the From Address header.
      class  HeaderTerm
      This class implements comparisons for Message headers.
      class  IntegerComparisonTerm
      This class implements comparisons for integers.
      class  MessageIDTerm
      This term models the RFC822 "MessageId" - a message-id for Internet messages that is supposed to be unique per message.
      class  MessageNumberTerm
      This class implements comparisons for Message numbers.
      class  NotTerm
      This class implements the logical NEGATION operator.
      class  OrTerm
      This class implements the logical OR operator on individual SearchTerms.
      class  ReceivedDateTerm
      This class implements comparisons for the Message Received date
      class  RecipientStringTerm
      This class implements string comparisons for the Recipient Address headers.
      class  RecipientTerm
      This class implements comparisons for the Recipient Address headers.
      class  SentDateTerm
      This class implements comparisons for the Message SentDate.
      class  SizeTerm
      This class implements comparisons for Message sizes.
      class  StringTerm
      This class implements the match method for Strings.
      class  SubjectTerm
      This class implements comparisons for the message Subject header.
      Methods in javax.mail.search that return SearchTerm
      Modifier and Type Method and Description
      SearchTerm NotTerm.getTerm()
      Return the term to negate.
      SearchTerm[] OrTerm.getTerms()
      Return the search terms.
      SearchTerm[] AndTerm.getTerms()
      Return the search terms.
      Constructors in javax.mail.search with parameters of type SearchTerm
      Constructor and Description
      AndTerm(SearchTerm[] t)
      Constructor that takes an array of SearchTerms.
      AndTerm(SearchTerm t1, SearchTerm t2)
      Constructor that takes two terms.
      NotTerm(SearchTerm t)
      OrTerm(SearchTerm[] t)
      Constructor that takes an array of SearchTerms.
      OrTerm(SearchTerm t1, SearchTerm t2)
      Constructor that takes two operands.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.SentDateTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.SentDateTerm

No usage of javax.mail.search.SentDateTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.SizeTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.SizeTerm

No usage of javax.mail.search.SizeTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.StringTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.StringTerm

  • Packages that use StringTerm
    Package Description
    javax.mail.search
    Message search terms for the JavaMail API.

    • Uses of StringTerm in javax.mail.search

      Subclasses of StringTerm in javax.mail.search
      Modifier and Type Class and Description
      class  AddressStringTerm
      This abstract class implements string comparisons for Message addresses.
      class  BodyTerm
      This class implements searches on a message body.
      class  FromStringTerm
      This class implements string comparisons for the From Address header.
      class  HeaderTerm
      This class implements comparisons for Message headers.
      class  MessageIDTerm
      This term models the RFC822 "MessageId" - a message-id for Internet messages that is supposed to be unique per message.
      class  RecipientStringTerm
      This class implements string comparisons for the Recipient Address headers.
      class  SubjectTerm
      This class implements comparisons for the message Subject header.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.search.SubjectTerm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.search.SubjectTerm

No usage of javax.mail.search.SubjectTerm
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ByteArrayDataSource (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.util

Class ByteArrayDataSource

  • java.lang.Object
    • javax.mail.util.ByteArrayDataSource
  • All Implemented Interfaces:
    DataSource

    public class ByteArrayDataSource
extends Object
implements DataSource
    A DataSource backed by a byte array. The byte array may be passed in directly, or may be initialized from an InputStream or a String.
    Since:
    JavaMail 1.4
    Author:
    John Mani, Bill Shannon, Max Spivak

    • Constructor Summary

      Constructors
      Constructor and Description
      ByteArrayDataSource(byte[] data, String type)
      Create a ByteArrayDataSource with data from the specified byte array and with the specified MIME type.
      ByteArrayDataSource(InputStream is, String type)
      Create a ByteArrayDataSource with data from the specified InputStream and with the specified MIME type.
      ByteArrayDataSource(String data, String type)
      Create a ByteArrayDataSource with data from the specified String and with the specified MIME type.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getContentType()
      Get the MIME content type of the data.
      InputStream getInputStream()
      Return an InputStream for the data.
      String getName()
      Get the name of the data.
      OutputStream getOutputStream()
      Return an OutputStream for the data.
      void setName(String name)
      Set the name of the data.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ByteArrayDataSource

        public ByteArrayDataSource(InputStream is,
                   String type)
                    throws IOException
        Create a ByteArrayDataSource with data from the specified InputStream and with the specified MIME type. The InputStream is read completely and the data is stored in a byte array.
        Parameters:
        is - the InputStream
        type - the MIME type
        Throws:
        IOException - errors reading the stream

      • ByteArrayDataSource

        public ByteArrayDataSource(byte[] data,
                   String type)
        Create a ByteArrayDataSource with data from the specified byte array and with the specified MIME type.
        Parameters:
        data - the data
        type - the MIME type

      • ByteArrayDataSource

        public ByteArrayDataSource(String data,
                   String type)
                    throws IOException
        Create a ByteArrayDataSource with data from the specified String and with the specified MIME type. The MIME type should include a charset parameter specifying the charset to be used for the string. If the parameter is not included, the default charset is used.
        Parameters:
        data - the String
        type - the MIME type
        Throws:
        IOException - errors reading the String

    • Method Detail

      • getInputStream

        public InputStream getInputStream()
                           throws IOException
        Return an InputStream for the data. Note that a new stream is returned each time this method is called.
        Specified by:
        getInputStream in interface DataSource
        Returns:
        the InputStream
        Throws:
        IOException - if no data has been set

      • getOutputStream

        public OutputStream getOutputStream()
                             throws IOException
        Return an OutputStream for the data. Writing the data is not supported; an IOException is always thrown.
        Specified by:
        getOutputStream in interface DataSource
        Throws:
        IOException - always

      • getContentType

        public String getContentType()
        Get the MIME content type of the data.
        Specified by:
        getContentType in interface DataSource
        Returns:
        the MIME type

      • getName

        public String getName()
        Get the name of the data. By default, an empty string ("") is returned.
        Specified by:
        getName in interface DataSource
        Returns:
        the name of this data

      • setName

        public void setName(String name)
        Set the name of the data.
        Parameters:
        name - the name of this data
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.mail.util (Java(TM) EE 7 Specification APIs)

javax.mail.util

Classes

  • ByteArrayDataSource
  • SharedByteArrayInputStream
  • SharedFileInputStream


javax.mail.util (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.mail.util

JavaMail API utility classes.

See: Description

  • Class Summary
    Class Description
    ByteArrayDataSource
    A DataSource backed by a byte array.
    SharedByteArrayInputStream
    A ByteArrayInputStream that implements the SharedInputStream interface, allowing the underlying byte array to be shared between multiple readers.
    SharedFileInputStream
    A SharedFileInputStream is a BufferedInputStream that buffers data from the file and supports the mark and reset methods.

Package javax.mail.util Description

JavaMail API utility classes. This package specifies utility classes that are useful with other JavaMail APIs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.mail.util Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.mail.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.mail.util.ByteArrayDataSource (implements javax.activation.DataSource)
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.ByteArrayInputStream
        • javax.mail.util.SharedByteArrayInputStream (implements javax.mail.internet.SharedInputStream)
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
          • javax.mail.util.SharedFileInputStream (implements javax.mail.internet.SharedInputStream)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


SharedByteArrayInputStream (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.util

Class SharedByteArrayInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.ByteArrayInputStream
        • javax.mail.util.SharedByteArrayInputStream
  • All Implemented Interfaces:
    Closeable, AutoCloseable, SharedInputStream

    public class SharedByteArrayInputStream
extends ByteArrayInputStream
implements SharedInputStream
    A ByteArrayInputStream that implements the SharedInputStream interface, allowing the underlying byte array to be shared between multiple readers.
    Since:
    JavaMail 1.4
    Author:
    Bill Shannon

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected int start
      Position within shared buffer that this stream starts at.

      • Fields inherited from class java.io.ByteArrayInputStream

        buf, count, mark, pos

    • Constructor Summary

      Constructors
      Constructor and Description
      SharedByteArrayInputStream(byte[] buf)
      Create a SharedByteArrayInputStream representing the entire byte array.
      SharedByteArrayInputStream(byte[] buf, int offset, int length)
      Create a SharedByteArrayInputStream representing the part of the byte array from offset for length bytes.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getPosition()
      Return the current position in the InputStream, as an offset from the beginning of the InputStream.
      InputStream newStream(long start, long end)
      Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive).

      • Methods inherited from class java.io.ByteArrayInputStream

        available, close, mark, markSupported, read, read, reset, skip

      • Methods inherited from class java.io.InputStream

        read

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • start

        protected int start
        Position within shared buffer that this stream starts at.

    • Constructor Detail

      • SharedByteArrayInputStream

        public SharedByteArrayInputStream(byte[] buf)
        Create a SharedByteArrayInputStream representing the entire byte array.
        Parameters:
        buf - the byte array

      • SharedByteArrayInputStream

        public SharedByteArrayInputStream(byte[] buf,
                          int offset,
                          int length)
        Create a SharedByteArrayInputStream representing the part of the byte array from offset for length bytes.
        Parameters:
        buf - the byte array
        offset - offset in byte array to first byte to include
        length - number of bytes to include

    • Method Detail

      • getPosition

        public long getPosition()
        Return the current position in the InputStream, as an offset from the beginning of the InputStream.
        Specified by:
        getPosition in interface SharedInputStream
        Returns:
        the current position

      • newStream

        public InputStream newStream(long start,
                    long end)
        Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive). start must be non-negative. If end is -1, the new stream ends at the same place as this stream. The returned InputStream will also implement the SharedInputStream interface.
        Specified by:
        newStream in interface SharedInputStream
        Parameters:
        start - the starting position
        end - the ending position + 1
        Returns:
        the new stream
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SharedFileInputStream (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.mail.util

Class SharedFileInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
          • javax.mail.util.SharedFileInputStream
  • All Implemented Interfaces:
    Closeable, AutoCloseable, SharedInputStream

    public class SharedFileInputStream
extends BufferedInputStream
implements SharedInputStream
    A SharedFileInputStream is a BufferedInputStream that buffers data from the file and supports the mark and reset methods. It also supports the newStream method that allows you to create other streams that represent subsets of the file. A RandomAccessFile object is used to access the file data.

    Note that when the SharedFileInputStream is closed, all streams created with the newStream method are also closed. This allows the creator of the SharedFileInputStream object to control access to the underlying file and ensure that it is closed when needed, to avoid leaking file descriptors. Note also that this behavior contradicts the requirements of SharedInputStream and may change in a future release.

    Since:
    JavaMail 1.4
    Author:
    Bill Shannon

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected long bufpos
      The file offset that corresponds to the first byte in the read buffer.
      protected int bufsize
      The normal size of the read buffer.
      protected long datalen
      The amount of data in this subset of the file.
      protected RandomAccessFile in
      The file containing the data.
      protected long start
      The file offset of the start of data in this subset of the file.

      • Fields inherited from class java.io.BufferedInputStream

        buf, count, marklimit, markpos, pos

    • Constructor Summary

      Constructors
      Constructor and Description
      SharedFileInputStream(File file)
      Creates a SharedFileInputStream for the file.
      SharedFileInputStream(File file, int size)
      Creates a SharedFileInputStream with the specified buffer size.
      SharedFileInputStream(String file)
      Creates a SharedFileInputStream for the named file
      SharedFileInputStream(String file, int size)
      Creates a SharedFileInputStream with the specified buffer size.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int available()
      Returns the number of bytes that can be read from this input stream without blocking.
      void close()
      Closes this input stream and releases any system resources associated with the stream.
      protected void finalize()
      Force this stream to close.
      long getPosition()
      Return the current position in the InputStream, as an offset from the beginning of the InputStream.
      void mark(int readlimit)
      See the general contract of the mark method of InputStream.
      boolean markSupported()
      Tests if this input stream supports the mark and reset methods.
      InputStream newStream(long start, long end)
      Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive).
      int read()
      See the general contract of the read method of InputStream.
      int read(byte[] b, int off, int len)
      Reads bytes from this stream into the specified byte array, starting at the given offset.
      void reset()
      See the general contract of the reset method of InputStream.
      long skip(long n)
      See the general contract of the skip method of InputStream.

      • Methods inherited from class java.io.FilterInputStream

        read

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • in

        protected RandomAccessFile in
        The file containing the data. Shared by all related SharedFileInputStreams.

      • bufsize

        protected int bufsize
        The normal size of the read buffer.

      • bufpos

        protected long bufpos
        The file offset that corresponds to the first byte in the read buffer.

      • start

        protected long start
        The file offset of the start of data in this subset of the file.

      • datalen

        protected long datalen
        The amount of data in this subset of the file.

    • Constructor Detail

      • SharedFileInputStream

        public SharedFileInputStream(File file)
                      throws IOException
        Creates a SharedFileInputStream for the file.
        Parameters:
        file - the file
        Throws:
        IOException

      • SharedFileInputStream

        public SharedFileInputStream(String file)
                      throws IOException
        Creates a SharedFileInputStream for the named file
        Parameters:
        file - the file
        Throws:
        IOException

      • SharedFileInputStream

        public SharedFileInputStream(File file,
                     int size)
                      throws IOException
        Creates a SharedFileInputStream with the specified buffer size.
        Parameters:
        file - the file
        size - the buffer size.
        Throws:
        IllegalArgumentException - if size <= 0.
        IOException

      • SharedFileInputStream

        public SharedFileInputStream(String file,
                     int size)
                      throws IOException
        Creates a SharedFileInputStream with the specified buffer size.
        Parameters:
        file - the file
        size - the buffer size.
        Throws:
        IllegalArgumentException - if size <= 0.
        IOException

    • Method Detail

      • read

        public int read()
         throws IOException
        See the general contract of the read method of InputStream.
        Overrides:
        read in class BufferedInputStream
        Returns:
        the next byte of data, or -1 if the end of the stream is reached.
        Throws:
        IOException - if an I/O error occurs.

      • read

        public int read(byte[] b,
       int off,
       int len)
         throws IOException
        Reads bytes from this stream into the specified byte array, starting at the given offset.

        This method implements the general contract of the corresponding read method of the InputStream class.

        Overrides:
        read in class BufferedInputStream
        Parameters:
        b - destination buffer.
        off - offset at which to start storing bytes.
        len - maximum number of bytes to read.
        Returns:
        the number of bytes read, or -1 if the end of the stream has been reached.
        Throws:
        IOException - if an I/O error occurs.

      • skip

        public long skip(long n)
          throws IOException
        See the general contract of the skip method of InputStream.
        Overrides:
        skip in class BufferedInputStream
        Parameters:
        n - the number of bytes to be skipped.
        Returns:
        the actual number of bytes skipped.
        Throws:
        IOException - if an I/O error occurs.

      • available

        public int available()
              throws IOException
        Returns the number of bytes that can be read from this input stream without blocking.
        Overrides:
        available in class BufferedInputStream
        Returns:
        the number of bytes that can be read from this input stream without blocking.
        Throws:
        IOException - if an I/O error occurs.

      • mark

        public void mark(int readlimit)
        See the general contract of the mark method of InputStream.
        Overrides:
        mark in class BufferedInputStream
        Parameters:
        readlimit - the maximum limit of bytes that can be read before the mark position becomes invalid.
        See Also:
        reset()

      • reset

        public void reset()
           throws IOException
        See the general contract of the reset method of InputStream.

        If markpos is -1 (no mark has been set or the mark has been invalidated), an IOException is thrown. Otherwise, pos is set equal to markpos.

        Overrides:
        reset in class BufferedInputStream
        Throws:
        IOException - if this stream has not been marked or if the mark has been invalidated.
        See Also:
        mark(int)

      • markSupported

        public boolean markSupported()
        Tests if this input stream supports the mark and reset methods. The markSupported method of SharedFileInputStream returns true.
        Overrides:
        markSupported in class BufferedInputStream
        Returns:
        a boolean indicating if this stream type supports the mark and reset methods.
        See Also:
        InputStream.mark(int), InputStream.reset()

      • close

        public void close()
           throws IOException
        Closes this input stream and releases any system resources associated with the stream.
        Specified by:
        close in interface Closeable
        Specified by:
        close in interface AutoCloseable
        Overrides:
        close in class BufferedInputStream
        Throws:
        IOException - if an I/O error occurs.

      • getPosition

        public long getPosition()
        Return the current position in the InputStream, as an offset from the beginning of the InputStream.
        Specified by:
        getPosition in interface SharedInputStream
        Returns:
        the current position

      • newStream

        public InputStream newStream(long start,
                    long end)
        Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive). start must be non-negative. If end is -1, the new stream ends at the same place as this stream. The returned InputStream will also implement the SharedInputStream interface.
        Specified by:
        newStream in interface SharedInputStream
        Parameters:
        start - the starting position
        end - the ending position + 1
        Returns:
        the new stream

      • finalize

        protected void finalize()
                 throws Throwable
        Force this stream to close.
        Overrides:
        finalize in class Object
        Throws:
        Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.mail.util (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.mail.util

No usage of javax.mail.util
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.util.ByteArrayDataSource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.util.ByteArrayDataSource

No usage of javax.mail.util.ByteArrayDataSource
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.util.SharedByteArrayInputStream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.util.SharedByteArrayInputStream

No usage of javax.mail.util.SharedByteArrayInputStream
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.mail.util.SharedFileInputStream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.mail.util.SharedFileInputStream

No usage of javax.mail.util.SharedFileInputStream
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.management.j2ee (Java(TM) EE 7 Specification APIs)

javax.management.j2ee

Interfaces

  • ListenerRegistration
  • Management
  • ManagementHome


javax.management.j2ee (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.management.j2ee

Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

See: Description

  • Interface Summary
    Interface Description
    ListenerRegistration
    ListenerRegistration defines the methods which clients of the MEJB use to add and remove event listeners.
    Management
    The Management interface provides the APIs to navigate and manipulate managed objects.
    ManagementHome
    The required home interface for the J2EE Management EJB component (MEJB).

Package javax.management.j2ee Description

Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

Package Specification

  • JSR 77, J2EE Management

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.management.j2ee Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.management.j2ee

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • java.rmi.Remote
    • javax.ejb.EJBHome
      • javax.management.j2ee.ManagementHome
    • javax.ejb.EJBObject
      • javax.management.j2ee.Management
  • java.io.Serializable
    • javax.management.j2ee.ListenerRegistration
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ListenerRegistration (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee

Interface ListenerRegistration

  • All Superinterfaces:
    Serializable

    public interface ListenerRegistration
extends Serializable
    ListenerRegistration defines the methods which clients of the MEJB use to add and remove event listeners.
    Author:
    Hans Hrasna

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      Add a listener to a registered managed object.
      void removeNotificationListener(ObjectName name, NotificationListener listener)
      Remove a listener from a registered managed object.

    • Method Detail

      • addNotificationListener

        void addNotificationListener(ObjectName name,
                           NotificationListener listener,
                           NotificationFilter filter,
                           Object handback)
                             throws InstanceNotFoundException,
                                    RemoteException
        Add a listener to a registered managed object.
        Parameters:
        name - The name of the managed object on which the listener should be added.
        listener - The listener object which will handle the notifications emitted by the registered managed object.
        filter - The filter object. If filter is null, no filtering will be performed before handling notifications.
        handback - The context to be sent to the listener when a notification is emitted.
        Throws:
        InstanceNotFoundException - The managed object name provided does not match any of the registered managed objects.
        RemoteException - A communication exception occurred during the execution of a remote method call

      • removeNotificationListener

        void removeNotificationListener(ObjectName name,
                              NotificationListener listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       RemoteException
        Remove a listener from a registered managed object.
        Parameters:
        name - The name of the managed object on which the listener should be removed.
        listener - The listener object which will handle the notifications emitted by the registered managed object. This method will remove all the information related to this listener.
        Throws:
        InstanceNotFoundException - The managed object name provided does not match any of the registered managed objects.
        ListenerNotFoundException - The listener is not registered in the managed object.
        RemoteException - A communication exception occurred during the execution of a remote method call
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Management (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee

Interface Management

  • All Superinterfaces:
    EJBObject, Remote

    public interface Management
extends EJBObject
    The Management interface provides the APIs to navigate and manipulate managed objects. The J2EE Management EJB component (MEJB) must implement this as its remote interface.
    Author:
    Hans Hrasna

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAttribute(ObjectName name, String attribute)
      Gets the value of a specific attribute of a named managed object.
      AttributeList getAttributes(ObjectName name, String[] attributes)
      Enables the values of several attributes of a named managed object.
      String getDefaultDomain()
      Returns the default domain name of this MEJB.
      ListenerRegistration getListenerRegistry()
      Returns the listener registry implementation for this MEJB.
      Integer getMBeanCount()
      Returns the number of managed objects registered in the MEJB.
      MBeanInfo getMBeanInfo(ObjectName name)
      This method discovers the attributes and operations that a managed object exposes for management.
      Object invoke(ObjectName name, String operationName, Object[] params, String[] signature)
      Invokes an operation on a managed object.
      boolean isRegistered(ObjectName name)
      Checks whether a managed object, identified by its object name, is already registered with the MEJB.
      Set queryNames(ObjectName name, QueryExp query)
      Gets the names of managed objects controlled by the MEJB.
      void setAttribute(ObjectName name, Attribute attribute)
      Sets the value of a specific attribute of a named managed object.
      AttributeList setAttributes(ObjectName name, AttributeList attributes)
      Sets the values of several attributes of a named managed object.

      • Methods inherited from interface javax.ejb.EJBObject

        getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

    • Method Detail

      • queryNames

        Set queryNames(ObjectName name,
             QueryExp query)
               throws RemoteException
        Gets the names of managed objects controlled by the MEJB. This method enables any of the following to be obtained: The names of all managed objects, the names of a set of managed objects specified by pattern matching on the ObjectName, a specific managed object name (equivalent to testing whether a managed object is registered). When the object name is null or no domain and key properties are specified, all objects are selected. It returns the set of J2EEObjectNames for the managed objects selected.
        Parameters:
        name - The object name pattern identifying the managed objects to be retrieved. If null or no domain and key properties are specified, all the managed objects registered will be retrieved.
        Returns:
        A set containing the ObjectNames for the managed objects selected. If no managed object satisfies the query, an empty set is returned.
        Throws:
        RemoteException - A communication exception occurred during the execution of a remote method call

      • isRegistered

        boolean isRegistered(ObjectName name)
                     throws RemoteException
        Checks whether a managed object, identified by its object name, is already registered with the MEJB.
        Parameters:
        name - The object name of the managed object to be checked.
        Returns:
        True if the managed object is already registered in the MEJB, false otherwise.
        Throws:
        RemoteException - A communication exception occurred during the execution of a remote method call

      • getMBeanCount

        Integer getMBeanCount()
                      throws RemoteException
        Returns the number of managed objects registered in the MEJB.
        Throws:
        RemoteException - A communication exception occurred during the execution of a remote method call

      • getMBeanInfo

        MBeanInfo getMBeanInfo(ObjectName name)
                       throws IntrospectionException,
                              InstanceNotFoundException,
                              ReflectionException,
                              RemoteException
        This method discovers the attributes and operations that a managed object exposes for management.
        Parameters:
        name - The name of the managed object to analyze
        Returns:
        An instance of MBeanInfo allowing the retrieval of all attributes and operations of this managed object.
        Throws:
        IntrospectionException - An exception occurs during introspection.
        InstanceNotFoundException - The managed object specified is not found.
        ReflectionException - An exception occurred when trying to perform reflection on a managed object
        RemoteException - A communication exception occurred during the execution of a remote method call

      • getAttribute

        Object getAttribute(ObjectName name,
                  String attribute)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException,
                           RemoteException
        Gets the value of a specific attribute of a named managed object. The managed object is identified by its object name.
        Parameters:
        name - The object name of the managed object from which the attribute is to be retrieved.
        attribute - A String specifying the name of the attribute to be retrieved.
        Returns:
        The value of the retrieved attribute.
        Throws:
        AttributeNotFoundException - The attribute specified is not accessible in the managed object.
        MBeanException - Wraps an exception thrown by the managed object's getter.
        InstanceNotFoundException - The managed object specified is not registered in the MEJB.
        ReflectionException - An exception occurred when trying to invoke the getAttribute method of a Dynamic MBean
        RemoteException - A communication exception occurred during the execution of a remote method call

      • getAttributes

        AttributeList getAttributes(ObjectName name,
                          String[] attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   RemoteException
        Enables the values of several attributes of a named managed object. The managed object is identified by its object name.
        Parameters:
        name - The object name of the managed object from which the attributes are retrieved.
        attributes - A list of the attributes to be retrieved.
        Returns:
        The list of the retrieved attributes.
        Throws:
        InstanceNotFoundException - The managed object specified is not registered in the MEJB.
        ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
        RemoteException - A communication exception occurred during the execution of a remote method call

      • setAttribute

        void setAttribute(ObjectName name,
                Attribute attribute)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException,
                         RemoteException
        Sets the value of a specific attribute of a named managed object. The managed object is identified by its object name.
        Parameters:
        name - The name of the managed object within which the attribute is to be set.
        attribute - The identification of the attribute to be set and the value it is to be set to.
        Throws:
        InstanceNotFoundException - The managed object specified is not registered in the MEJB.
        AttributeNotFoundException - The attribute specified is not accessible in the managed object.
        InvalidAttributeValueException - The value specified for the attribute is not valid.
        MBeanException - Wraps an exception thrown by the managed object's setter.
        ReflectionException - An exception occurred when trying to invoke the setAttribute method of a Dynamic MBean.
        RemoteException - A communication exception occurred during the execution of a remote method call

      • setAttributes

        AttributeList setAttributes(ObjectName name,
                          AttributeList attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   RemoteException
        Sets the values of several attributes of a named managed object. The managed object is identified by its object name.
        Parameters:
        name - The object name of the managed object within which the attributes are to be set.
        attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to.
        Returns:
        The list of attributes that were set, with their new values.
        Throws:
        InstanceNotFoundException - The managed object specified is not registered in the MEJB.
        ReflectionException - An exception occurred when trying to invoke the setAttributes method of a Dynamic MBean.
        RemoteException - A communication exception occurred during the execution of a remote method call

      • invoke

        Object invoke(ObjectName name,
            String operationName,
            Object[] params,
            String[] signature)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException,
                     RemoteException
        Invokes an operation on a managed object.
        Parameters:
        name - The object name of the managed object on which the method is to be invoked.
        operationName - The name of the operation to be invoked.
        params - An array containing the parameters to be set when the operation is invoked
        signature - An array containing the signature of the operation. The class objects will be loaded using the same class loader as the one used for loading the managed object on which the operation was invoked.
        Returns:
        The object returned by the operation, which represents the result of invoking the operation on the managed object specified.
        Throws:
        InstanceNotFoundException - The managed object specified is not registered in the MEJB.
        MBeanException - Wraps an exception thrown by the managed object's invoked method.
        ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the method.
        RemoteException - A communication exception occurred during the execution of a remote method call

      • getDefaultDomain

        String getDefaultDomain()
                        throws RemoteException
        Returns the default domain name of this MEJB.
        Throws:
        RemoteException - A communication exception occurred during the execution of a remote method call

      • getListenerRegistry

        ListenerRegistration getListenerRegistry()
                                         throws RemoteException
        Returns the listener registry implementation for this MEJB. The listener registry implements the methods that enable clints to add and remove event notification listeners managed objects
        Returns:
        An implementation of javax.management.j2ee.ListenerRegistration
        Throws:
        RemoteException - A communication exception occurred during the execution of a remote method call
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagementHome (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee

Interface ManagementHome

  • All Superinterfaces:
    EJBHome, Remote

    public interface ManagementHome
extends EJBHome
    The required home interface for the J2EE Management EJB component (MEJB). A J2EE client must be able to create a compliant session object using the specified create() method.
    Author:
    Hans Hrasna

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Management create()
      Creates an MEJB session object which provides access to the J2EE Management Model

      • Methods inherited from interface javax.ejb.EJBHome

        getEJBMetaData, getHomeHandle, remove, remove

    • Method Detail

      • create

        Management create()
                  throws CreateException,
                         RemoteException
        Creates an MEJB session object which provides access to the J2EE Management Model
        Returns:
        An MEJB session object which implements javax.management.j2ee.Management
        Throws:
        CreateExceotion - Indicates a failure to create the EJB object
        RemoteException - A communication exception occurred during the execution of a remote method call
        CreateException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.management.j2ee (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.management.j2ee

  • Packages that use javax.management.j2ee
    Package Description
    javax.management.j2ee
    Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.
  • Classes in javax.management.j2ee used by javax.management.j2ee
    Class and Description
    ListenerRegistration
    ListenerRegistration defines the methods which clients of the MEJB use to add and remove event listeners.
    Management
    The Management interface provides the APIs to navigate and manipulate managed objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.ListenerRegistration (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.ListenerRegistration

  • Packages that use ListenerRegistration
    Package Description
    javax.management.j2ee
    Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

    • Uses of ListenerRegistration in javax.management.j2ee

      Methods in javax.management.j2ee that return ListenerRegistration
      Modifier and Type Method and Description
      ListenerRegistration Management.getListenerRegistry()
      Returns the listener registry implementation for this MEJB.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.Management (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.Management

  • Packages that use Management
    Package Description
    javax.management.j2ee
    Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

    • Uses of Management in javax.management.j2ee

      Methods in javax.management.j2ee that return Management
      Modifier and Type Method and Description
      Management ManagementHome.create()
      Creates an MEJB session object which provides access to the J2EE Management Model
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.ManagementHome (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.ManagementHome

No usage of javax.management.j2ee.ManagementHome
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BoundaryStatistic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface BoundaryStatistic

  • All Superinterfaces:
    Statistic
    All Known Subinterfaces:
    BoundedRangeStatistic

    public interface BoundaryStatistic
extends Statistic
    Specifies standard measurements of the upper and lower limits of the value of an attribute.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getLowerBound()
      The lower limit of the value of this attribute.The upper limit of the value of this attribute.
      long getUpperBound()
      The upper limit of the value of this attribute.

      • Methods inherited from interface javax.management.j2ee.statistics.Statistic

        getDescription, getLastSampleTime, getName, getStartTime, getUnit

    • Method Detail

      • getUpperBound

        long getUpperBound()
        The upper limit of the value of this attribute.

      • getLowerBound

        long getLowerBound()
        The lower limit of the value of this attribute.The upper limit of the value of this attribute.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BoundedRangeStatistic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface BoundedRangeStatistic

  • All Superinterfaces:
    BoundaryStatistic, RangeStatistic, Statistic

    public interface BoundedRangeStatistic
extends BoundaryStatistic, RangeStatistic
    The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.

    • Method Summary

      • Methods inherited from interface javax.management.j2ee.statistics.BoundaryStatistic

        getLowerBound, getUpperBound

      • Methods inherited from interface javax.management.j2ee.statistics.RangeStatistic

        getCurrent, getHighWaterMark, getLowWaterMark

      • Methods inherited from interface javax.management.j2ee.statistics.Statistic

        getDescription, getLastSampleTime, getName, getStartTime, getUnit
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CountStatistic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface CountStatistic

  • All Superinterfaces:
    Statistic

    public interface CountStatistic
extends Statistic
    Specifies standard count measurements.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getCount()
      The count since the last reset.

      • Methods inherited from interface javax.management.j2ee.statistics.Statistic

        getDescription, getLastSampleTime, getName, getStartTime, getUnit

    • Method Detail

      • getCount

        long getCount()
        The count since the last reset.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface EJBStats

  • All Superinterfaces:
    Stats
    All Known Subinterfaces:
    EntityBeanStats, MessageDrivenBeanStats, SessionBeanStats, StatefulSessionBeanStats, StatelessSessionBeanStats

    public interface EJBStats
extends Stats
    Specifies statistics provided by all EJB component types.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CountStatistic getCreateCount()
      Number of times create was called.
      CountStatistic getRemoveCount()
      Number of times remove was called.

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getCreateCount

        CountStatistic getCreateCount()
        Number of times create was called.

      • getRemoveCount

        CountStatistic getRemoveCount()
        Number of times remove was called.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityBeanStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface EntityBeanStats

  • All Superinterfaces:
    EJBStats, Stats

    public interface EntityBeanStats
extends EJBStats
    Specifies statistics provided by entity beans.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      RangeStatistic getPooledCount()
      Number of beans in the pooled state.
      RangeStatistic getReadyCount()
      Number of beans in the ready state.

      • Methods inherited from interface javax.management.j2ee.statistics.EJBStats

        getCreateCount, getRemoveCount

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getReadyCount

        RangeStatistic getReadyCount()
        Number of beans in the ready state.

      • getPooledCount

        RangeStatistic getPooledCount()
        Number of beans in the pooled state.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JavaMailStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JavaMailStats

  • public interface JavaMailStats
    Specifies the statistics provided by a JavaMail resource.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CountStatistic getSentMailCount()
      The number of mail messages sent.

    • Method Detail

      • getSentMailCount

        CountStatistic getSentMailCount()
        The number of mail messages sent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.management.j2ee.statistics (Java(TM) EE 7 Specification APIs)

javax.management.j2ee.statistics

Interfaces

  • BoundaryStatistic
  • BoundedRangeStatistic
  • CountStatistic
  • EJBStats
  • EntityBeanStats
  • JavaMailStats
  • JCAConnectionPoolStats
  • JCAConnectionStats
  • JCAStats
  • JDBCConnectionPoolStats
  • JDBCConnectionStats
  • JDBCStats
  • JMSConnectionStats
  • JMSConsumerStats
  • JMSEndpointStats
  • JMSProducerStats
  • JMSSessionStats
  • JMSStats
  • JTAStats
  • JVMStats
  • MessageDrivenBeanStats
  • RangeStatistic
  • ServletStats
  • SessionBeanStats
  • StatefulSessionBeanStats
  • StatelessSessionBeanStats
  • Statistic
  • Stats
  • TimeStatistic
  • URLStats


javax.management.j2ee.statistics (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.management.j2ee.statistics

Provides the standard interfaces for accessing performance data from J2EE managed objects

See: Description

  • Interface Summary
    Interface Description
    BoundaryStatistic
    Specifies standard measurements of the upper and lower limits of the value of an attribute.
    BoundedRangeStatistic
    The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.
    CountStatistic
    Specifies standard count measurements.
    EJBStats
    Specifies statistics provided by all EJB component types.
    EntityBeanStats
    Specifies statistics provided by entity beans.
    JavaMailStats
    Specifies the statistics provided by a JavaMail resource.
    JCAConnectionPoolStats
    Specifies the statistics provided by a JCA Connection Pool
    JCAConnectionStats
    Specifies the statistics provided by a JCA connection
    JCAStats
    Specifies statistics provided by a JCA resource
    JDBCConnectionPoolStats
    Specifies the statistics provided by a JDBC connection pool.
    JDBCConnectionStats
    Specifies the statistics provided by all (pooled and non-pooled) JDBC connections.
    JDBCStats
    Statistics provided by a JDBC resource
    JMSConnectionStats
    Specifies the statistics provided by a JMS connection
    JMSConsumerStats
    Specifies the statistics provided by a JMS message consumer
    JMSEndpointStats
    Specifies the statistics provided by a JMS message producer or a JMS message consumer.
    JMSProducerStats
    Specifies the statistics provided by a JMS message producer
    JMSSessionStats
    Specifies the statistics provided by a JMS session.
    JMSStats
    Specifies the statistics provided by a JMS Resource
    JTAStats
    Specifies the statistics provided by a JTA resource.
    JVMStats
    Specifies the statistics provided by a Java VM.
    MessageDrivenBeanStats
    Specifies the statistics provided by a message driven bean.
    RangeStatistic
    Specifies standard measurements of the lowest and highest values an attribute has held as well as its current value.
    ServletStats
    Specifies the statistics provided by a Servlet.
    SessionBeanStats
    Specifies the statistics provided by session beans of both stateful and stateless types.
    StatefulSessionBeanStats
    Specifies the statistics provided by a stateful session bean.
    StatelessSessionBeanStats
    Specifies the statistics provided by a stateless session bean.
    Statistic
    The Statistic model and its sub-models specify the data models which are requried to be used to provide the performance data described by the specific attributes in the Stats models.
    Stats
    The Stats model and its submodels specify performance data attributes for each of the specific managed object types.
    TimeStatistic
    Specifies standard timing measurements.
    URLStats
    Specifies the statistics provided by a URL resource.

Package javax.management.j2ee.statistics Description

Provides the standard interfaces for accessing performance data from J2EE managed objects

Package Specification

  • JSR 77, J2EE Management

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.management.j2ee.statistics Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.management.j2ee.statistics

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.management.j2ee.statistics.JavaMailStats
  • javax.management.j2ee.statistics.Statistic
    • javax.management.j2ee.statistics.BoundaryStatistic
      • javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.RangeStatistic)
    • javax.management.j2ee.statistics.CountStatistic
    • javax.management.j2ee.statistics.RangeStatistic
      • javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.BoundaryStatistic)
    • javax.management.j2ee.statistics.TimeStatistic
  • javax.management.j2ee.statistics.Stats
    • javax.management.j2ee.statistics.EJBStats
      • javax.management.j2ee.statistics.EntityBeanStats
      • javax.management.j2ee.statistics.MessageDrivenBeanStats
      • javax.management.j2ee.statistics.SessionBeanStats
        • javax.management.j2ee.statistics.StatefulSessionBeanStats
        • javax.management.j2ee.statistics.StatelessSessionBeanStats
    • javax.management.j2ee.statistics.JCAConnectionStats
      • javax.management.j2ee.statistics.JCAConnectionPoolStats
    • javax.management.j2ee.statistics.JCAStats
    • javax.management.j2ee.statistics.JDBCConnectionStats
      • javax.management.j2ee.statistics.JDBCConnectionPoolStats
    • javax.management.j2ee.statistics.JDBCStats
    • javax.management.j2ee.statistics.JMSConnectionStats
    • javax.management.j2ee.statistics.JMSEndpointStats
      • javax.management.j2ee.statistics.JMSConsumerStats
      • javax.management.j2ee.statistics.JMSProducerStats
    • javax.management.j2ee.statistics.JMSSessionStats
    • javax.management.j2ee.statistics.JMSStats
    • javax.management.j2ee.statistics.JTAStats
    • javax.management.j2ee.statistics.JVMStats
    • javax.management.j2ee.statistics.ServletStats
    • javax.management.j2ee.statistics.URLStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JCAConnectionPoolStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JCAConnectionPoolStats

  • All Superinterfaces:
    JCAConnectionStats, Stats

    public interface JCAConnectionPoolStats
extends JCAConnectionStats
    Specifies the statistics provided by a JCA Connection Pool

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CountStatistic getCloseCount()
      The number of connections closed
      CountStatistic getCreateCount()
      The number of connections created
      BoundedRangeStatistic getFreePoolSize()
      The number of free connections in the pool
      BoundedRangeStatistic getPoolSize()
      The size of the connection pool
      RangeStatistic getWaitingThreadCount()
      The number of threads waiting for a connection

      • Methods inherited from interface javax.management.j2ee.statistics.JCAConnectionStats

        getConnectionFactory, getManagedConnectionFactory, getUseTime, getWaitTime

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getCloseCount

        CountStatistic getCloseCount()
        The number of connections closed
        Returns:
        CountStatistic

      • getCreateCount

        CountStatistic getCreateCount()
        The number of connections created
        Returns:
        CountStatistic

      • getFreePoolSize

        BoundedRangeStatistic getFreePoolSize()
        The number of free connections in the pool
        Returns:
        BoundedRangeStatistic

      • getPoolSize

        BoundedRangeStatistic getPoolSize()
        The size of the connection pool
        Returns:
        BoundedRangeStatistic

      • getWaitingThreadCount

        RangeStatistic getWaitingThreadCount()
        The number of threads waiting for a connection
        Returns:
        BoundedRangeStatistic
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JCAConnectionStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JCAConnectionStats

  • All Superinterfaces:
    Stats
    All Known Subinterfaces:
    JCAConnectionPoolStats

    public interface JCAConnectionStats
extends Stats
    Specifies the statistics provided by a JCA connection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getConnectionFactory()
      Returns the associated JCAConnectionFactory OBJECT_NAME
      String getManagedConnectionFactory()
      Returns the associated JCAManagedConnectionFactory OBJECT_NAME
      TimeStatistic getUseTime()
      Returns the time spent using a connection
      TimeStatistic getWaitTime()
      Returns the time spent waiting for a connection to be available

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getConnectionFactory

        String getConnectionFactory()
        Returns the associated JCAConnectionFactory OBJECT_NAME
        Returns:
        String the OBJECT_NAME of the managed object that identifies the connection factory for this connection

      • getManagedConnectionFactory

        String getManagedConnectionFactory()
        Returns the associated JCAManagedConnectionFactory OBJECT_NAME
        Returns:
        String the OBJECT_NAME of the managed object that identifies the managed connection factory for this connection

      • getWaitTime

        TimeStatistic getWaitTime()
        Returns the time spent waiting for a connection to be available
        Returns:
        TimeStatistic

      • getUseTime

        TimeStatistic getUseTime()
        Returns the time spent using a connection
        Returns:
        TimeStatistic
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JCAStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JCAStats

  • All Superinterfaces:
    Stats

    public interface JCAStats
extends Stats
    Specifies statistics provided by a JCA resource

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JCAConnectionPoolStats[] getConnectionPools()
      Returns an array of JCAConnectionPool Stats that provide statistics about the connection pools associated with the referencing JCA resource statistics
      JCAConnectionStats[] getConnections()
      Returns an array of JCAConnectionStats that provide statistics about the non-pooled connections associated with the referencing JCA resource statistics

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getConnections

        JCAConnectionStats[] getConnections()
        Returns an array of JCAConnectionStats that provide statistics about the non-pooled connections associated with the referencing JCA resource statistics
        Returns:
        JCAConnectionStats []

      • getConnectionPools

        JCAConnectionPoolStats[] getConnectionPools()
        Returns an array of JCAConnectionPool Stats that provide statistics about the connection pools associated with the referencing JCA resource statistics
        Returns:
        JCAConnectionPoolStats []
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JDBCConnectionPoolStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JDBCConnectionPoolStats

  • All Superinterfaces:
    JDBCConnectionStats, Stats

    public interface JDBCConnectionPoolStats
extends JDBCConnectionStats
    Specifies the statistics provided by a JDBC connection pool.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CountStatistic getCloseCount()
      Number of connections closed.
      CountStatistic getCreateCount()
      Number of connections created.
      BoundedRangeStatistic getFreePoolSize()
      Number of free connections in the pool.
      BoundedRangeStatistic getPoolSize()
      Size of the connection pool.
      RangeStatistic getWaitingThreadCount()
      Number of threads waiting for a connection.

      • Methods inherited from interface javax.management.j2ee.statistics.JDBCConnectionStats

        getJdbcDataSource, getUseTime, getWaitTime

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getCreateCount

        CountStatistic getCreateCount()
        Number of connections created.

      • getCloseCount

        CountStatistic getCloseCount()
        Number of connections closed.

      • getPoolSize

        BoundedRangeStatistic getPoolSize()
        Size of the connection pool.

      • getFreePoolSize

        BoundedRangeStatistic getFreePoolSize()
        Number of free connections in the pool.

      • getWaitingThreadCount

        RangeStatistic getWaitingThreadCount()
        Number of threads waiting for a connection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JDBCConnectionStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JDBCConnectionStats

  • All Superinterfaces:
    Stats
    All Known Subinterfaces:
    JDBCConnectionPoolStats

    public interface JDBCConnectionStats
extends Stats
    Specifies the statistics provided by all (pooled and non-pooled) JDBC connections.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getJdbcDataSource()
      Identifies the JDBC driver for the corresponding JDBCConnection.
      TimeStatistic getUseTime()
      Time spent using a connection.
      TimeStatistic getWaitTime()
      Time spent waiting for a connection to be available.

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getJdbcDataSource

        String getJdbcDataSource()
        Identifies the JDBC driver for the corresponding JDBCConnection.

      • getWaitTime

        TimeStatistic getWaitTime()
        Time spent waiting for a connection to be available.

      • getUseTime

        TimeStatistic getUseTime()
        Time spent using a connection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JDBCStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JDBCStats

  • All Superinterfaces:
    Stats

    public interface JDBCStats
extends Stats
    Statistics provided by a JDBC resource
    Author:
    Hans Hrasna

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JDBCConnectionPoolStats[] getConnectionPools()
      JDBCConnectionStats[] getConnections()

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getConnections

        JDBCConnectionStats[] getConnections()

      • getConnectionPools

        JDBCConnectionPoolStats[] getConnectionPools()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSConnectionStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JMSConnectionStats

  • All Superinterfaces:
    Stats

    public interface JMSConnectionStats
extends Stats
    Specifies the statistics provided by a JMS connection
    Author:
    Hans Hrasna

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JMSSessionStats[] getSessions()
      Returns an array of JMSSessionStats that provide statistics about the sessions associated with the referencing JMSConnectionStats.
      boolean isTransactional()
      Returns the transactional state of this JMS connection.

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getSessions

        JMSSessionStats[] getSessions()
        Returns an array of JMSSessionStats that provide statistics about the sessions associated with the referencing JMSConnectionStats.

      • isTransactional

        boolean isTransactional()
        Returns the transactional state of this JMS connection. If true, indicates that this JMS connection is transactional.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSConsumerStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JMSConsumerStats

  • All Superinterfaces:
    JMSEndpointStats, Stats

    public interface JMSConsumerStats
extends JMSEndpointStats
    Specifies the statistics provided by a JMS message consumer
    Author:
    Hans Hrasna

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getOrigin()
      Returns a string that encapsulates the identity of a message origin

      • Methods inherited from interface javax.management.j2ee.statistics.JMSEndpointStats

        getExpiredMessageCount, getMessageCount, getMessageWaitTime, getPendingMessageCount

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getOrigin

        String getOrigin()
        Returns a string that encapsulates the identity of a message origin
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSEndpointStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JMSEndpointStats

  • All Superinterfaces:
    Stats
    All Known Subinterfaces:
    JMSConsumerStats, JMSProducerStats

    public interface JMSEndpointStats
extends Stats
    Specifies the statistics provided by a JMS message producer or a JMS message consumer.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CountStatistic getExpiredMessageCount()
      Number of messages that expired before delivery.
      CountStatistic getMessageCount()
      Number of messages sent or received.
      TimeStatistic getMessageWaitTime()
      Time spent by a message before being delivered.
      CountStatistic getPendingMessageCount()
      Number of pending messages.

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getMessageCount

        CountStatistic getMessageCount()
        Number of messages sent or received.

      • getPendingMessageCount

        CountStatistic getPendingMessageCount()
        Number of pending messages.

      • getExpiredMessageCount

        CountStatistic getExpiredMessageCount()
        Number of messages that expired before delivery.

      • getMessageWaitTime

        TimeStatistic getMessageWaitTime()
        Time spent by a message before being delivered.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSProducerStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JMSProducerStats

  • All Superinterfaces:
    JMSEndpointStats, Stats

    public interface JMSProducerStats
extends JMSEndpointStats
    Specifies the statistics provided by a JMS message producer
    Author:
    Hans Hrasna

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDestination()
      Returns a string that encapsulates the identity of the message destination

      • Methods inherited from interface javax.management.j2ee.statistics.JMSEndpointStats

        getExpiredMessageCount, getMessageCount, getMessageWaitTime, getPendingMessageCount

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getDestination

        String getDestination()
        Returns a string that encapsulates the identity of the message destination
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSSessionStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JMSSessionStats

  • All Superinterfaces:
    Stats

    public interface JMSSessionStats
extends Stats
    Specifies the statistics provided by a JMS session.
    Author:
    Hans Hrasna

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JMSConsumerStats[] getConsumers()
      Returns an array of JMSConsumerStats that provide statistics about the message consumers associated with the referencing JMS session statistics.
      CountStatistic getDurableSubscriptionCount()
      Number of durable subscriptions.
      CountStatistic getExpiredMessageCount()
      Number of expired messages.
      CountStatistic getMessageCount()
      Number of messages exchanged.
      TimeStatistic getMessageWaitTime()
      Time spent by a message before being delivered.
      CountStatistic getPendingMessageCount()
      Number of pending messages.
      JMSProducerStats[] getProducers()
      Returns an array of JMSProducerStats that provide statistics about the message producers associated with the referencing JMS session statistics.

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getProducers

        JMSProducerStats[] getProducers()
        Returns an array of JMSProducerStats that provide statistics about the message producers associated with the referencing JMS session statistics.

      • getConsumers

        JMSConsumerStats[] getConsumers()
        Returns an array of JMSConsumerStats that provide statistics about the message consumers associated with the referencing JMS session statistics.

      • getMessageCount

        CountStatistic getMessageCount()
        Number of messages exchanged.

      • getPendingMessageCount

        CountStatistic getPendingMessageCount()
        Number of pending messages.

      • getExpiredMessageCount

        CountStatistic getExpiredMessageCount()
        Number of expired messages.

      • getMessageWaitTime

        TimeStatistic getMessageWaitTime()
        Time spent by a message before being delivered.

      • getDurableSubscriptionCount

        CountStatistic getDurableSubscriptionCount()
        Number of durable subscriptions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JMSStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JMSStats

  • All Superinterfaces:
    Stats

    public interface JMSStats
extends Stats
    Specifies the statistics provided by a JMS Resource
    Author:
    Hans Hrasna

    • Method Summary

      Methods
      Modifier and Type Method and Description
      JMSConnectionStats[] getConnections()
      Returns an array of JMSConnectionStats that provide statistics about the connections associated with the referencing JMS resource.

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getConnections

        JMSConnectionStats[] getConnections()
        Returns an array of JMSConnectionStats that provide statistics about the connections associated with the referencing JMS resource.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JTAStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JTAStats

  • All Superinterfaces:
    Stats

    public interface JTAStats
extends Stats
    Specifies the statistics provided by a JTA resource.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CountStatistic getActiveCount()
      Number of active transactions.
      CountStatistic getCommittedCount()
      Number of committed transactions.
      CountStatistic getRolledbackCount()
      Number of rolled-back transactions.

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getActiveCount

        CountStatistic getActiveCount()
        Number of active transactions.

      • getCommittedCount

        CountStatistic getCommittedCount()
        Number of committed transactions.

      • getRolledbackCount

        CountStatistic getRolledbackCount()
        Number of rolled-back transactions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JVMStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface JVMStats

  • All Superinterfaces:
    Stats

    public interface JVMStats
extends Stats
    Specifies the statistics provided by a Java VM.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      BoundedRangeStatistic getHeapSize()
      Size of the JVM's heap.
      CountStatistic getUpTime()
      Amount of time the JVM has been running.

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getUpTime

        CountStatistic getUpTime()
        Amount of time the JVM has been running.

      • getHeapSize

        BoundedRangeStatistic getHeapSize()
        Size of the JVM's heap.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageDrivenBeanStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface MessageDrivenBeanStats

  • All Superinterfaces:
    EJBStats, Stats

    public interface MessageDrivenBeanStats
extends EJBStats
    Specifies the statistics provided by a message driven bean.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CountStatistic getMessageCount()
      Number of messages received.

      • Methods inherited from interface javax.management.j2ee.statistics.EJBStats

        getCreateCount, getRemoveCount

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getMessageCount

        CountStatistic getMessageCount()
        Number of messages received.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RangeStatistic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface RangeStatistic

  • All Superinterfaces:
    Statistic
    All Known Subinterfaces:
    BoundedRangeStatistic

    public interface RangeStatistic
extends Statistic
    Specifies standard measurements of the lowest and highest values an attribute has held as well as its current value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getCurrent()
      The current value of this attribute.
      long getHighWaterMark()
      The highest value this attribute has held since the beginning of the measurement.
      long getLowWaterMark()
      The lowest value this attribute has held since the beginning of the measurement.

      • Methods inherited from interface javax.management.j2ee.statistics.Statistic

        getDescription, getLastSampleTime, getName, getStartTime, getUnit

    • Method Detail

      • getHighWaterMark

        long getHighWaterMark()
        The highest value this attribute has held since the beginning of the measurement.

      • getLowWaterMark

        long getLowWaterMark()
        The lowest value this attribute has held since the beginning of the measurement.

      • getCurrent

        long getCurrent()
        The current value of this attribute.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface ServletStats

  • All Superinterfaces:
    Stats

    public interface ServletStats
extends Stats
    Specifies the statistics provided by a Servlet.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      TimeStatistic getServiceTime()
      Execution times for the methods.

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getServiceTime

        TimeStatistic getServiceTime()
        Execution times for the methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SessionBeanStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface SessionBeanStats

  • All Superinterfaces:
    EJBStats, Stats
    All Known Subinterfaces:
    StatefulSessionBeanStats, StatelessSessionBeanStats

    public interface SessionBeanStats
extends EJBStats
    Specifies the statistics provided by session beans of both stateful and stateless types.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      RangeStatistic getMethodReadyCount()
      Number of beans in the method-ready state.

      • Methods inherited from interface javax.management.j2ee.statistics.EJBStats

        getCreateCount, getRemoveCount

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getMethodReadyCount

        RangeStatistic getMethodReadyCount()
        Number of beans in the method-ready state.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StatefulSessionBeanStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface StatefulSessionBeanStats

  • All Superinterfaces:
    EJBStats, SessionBeanStats, Stats

    public interface StatefulSessionBeanStats
extends SessionBeanStats
    Specifies the statistics provided by a stateful session bean.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      RangeStatistic getPassiveCount()
      Number of beans that are in the passive state.

      • Methods inherited from interface javax.management.j2ee.statistics.SessionBeanStats

        getMethodReadyCount

      • Methods inherited from interface javax.management.j2ee.statistics.EJBStats

        getCreateCount, getRemoveCount

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics

    • Method Detail

      • getPassiveCount

        RangeStatistic getPassiveCount()
        Number of beans that are in the passive state.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StatelessSessionBeanStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface StatelessSessionBeanStats

  • All Superinterfaces:
    EJBStats, SessionBeanStats, Stats

    public interface StatelessSessionBeanStats
extends SessionBeanStats
    Specifies the statistics provided by a stateless session bean.

    • Method Summary

      • Methods inherited from interface javax.management.j2ee.statistics.SessionBeanStats

        getMethodReadyCount

      • Methods inherited from interface javax.management.j2ee.statistics.EJBStats

        getCreateCount, getRemoveCount

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Statistic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface Statistic

  • All Known Subinterfaces:
    BoundaryStatistic, BoundedRangeStatistic, CountStatistic, RangeStatistic, TimeStatistic

    public interface Statistic
    The Statistic model and its sub-models specify the data models which are requried to be used to provide the performance data described by the specific attributes in the Stats models.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDescription()
      A human-readable description of the Statistic.
      long getLastSampleTime()
      The time of the last measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
      String getName()
      The name of this Statistic.
      long getStartTime()
      The time of the first measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
      String getUnit()
      The unit of measurement for this Statistic.

    • Method Detail

      • getName

        String getName()
        The name of this Statistic.

      • getUnit

        String getUnit()
        The unit of measurement for this Statistic. Valid values for TimeStatistic measurements are "HOUR", "MINUTE", "SECOND", "MILLISECOND", "MICROSECOND" and "NANOSECOND".

      • getDescription

        String getDescription()
        A human-readable description of the Statistic.

      • getStartTime

        long getStartTime()
        The time of the first measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.

      • getLastSampleTime

        long getLastSampleTime()
        The time of the last measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Stats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface Stats

  • All Known Subinterfaces:
    EJBStats, EntityBeanStats, JCAConnectionPoolStats, JCAConnectionStats, JCAStats, JDBCConnectionPoolStats, JDBCConnectionStats, JDBCStats, JMSConnectionStats, JMSConsumerStats, JMSEndpointStats, JMSProducerStats, JMSSessionStats, JMSStats, JTAStats, JVMStats, MessageDrivenBeanStats, ServletStats, SessionBeanStats, StatefulSessionBeanStats, StatelessSessionBeanStats, URLStats

    public interface Stats
    The Stats model and its submodels specify performance data attributes for each of the specific managed object types.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Statistic getStatistic(String statisticName)
      Get a Statistic by name.
      String[] getStatisticNames()
      Returns an array of Strings which are the names of the attributes from the specific Stats submodel that this object supports.
      Statistic[] getStatistics()
      Returns an array containing all of the Statistic objects supported by this Stats object.

    • Method Detail

      • getStatistic

        Statistic getStatistic(String statisticName)
        Get a Statistic by name.

      • getStatisticNames

        String[] getStatisticNames()
        Returns an array of Strings which are the names of the attributes from the specific Stats submodel that this object supports. Attributes named in the list must correspond to attributes that will return a Statistic object of the appropriate type which contains valid performance data. The return value of attributes in the Stats submodel that are not included in the statisticNames list must be null. For each name in the statisticNames list there must be one Statistic with the same name in the statistics list.

      • getStatistics

        Statistic[] getStatistics()
        Returns an array containing all of the Statistic objects supported by this Stats object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TimeStatistic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface TimeStatistic

  • All Superinterfaces:
    Statistic

    public interface TimeStatistic
extends Statistic
    Specifies standard timing measurements.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getCount()
      Number of times the operation was invoked since the beginning of this measurement.
      long getMaxTime()
      The maximum amount of time taken to complete one invocation of this operation since the beginning of this measurement.
      long getMinTime()
      The minimum amount of time taken to complete one invocation of this operation since the beginning of this measurement.
      long getTotalTime()
      This is the sum total of time taken to complete every invocation of this operation since the beginning of this measurement.

      • Methods inherited from interface javax.management.j2ee.statistics.Statistic

        getDescription, getLastSampleTime, getName, getStartTime, getUnit

    • Method Detail

      • getCount

        long getCount()
        Number of times the operation was invoked since the beginning of this measurement.

      • getMaxTime

        long getMaxTime()
        The maximum amount of time taken to complete one invocation of this operation since the beginning of this measurement.

      • getMinTime

        long getMinTime()
        The minimum amount of time taken to complete one invocation of this operation since the beginning of this measurement.

      • getTotalTime

        long getTotalTime()
        This is the sum total of time taken to complete every invocation of this operation since the beginning of this measurement. Dividing totalTime by count will give you the average execution time for this operation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


URLStats (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.management.j2ee.statistics

Interface URLStats

  • All Superinterfaces:
    Stats

    public interface URLStats
extends Stats
    Specifies the statistics provided by a URL resource.

    • Method Summary

      • Methods inherited from interface javax.management.j2ee.statistics.Stats

        getStatistic, getStatisticNames, getStatistics
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.management.j2ee.statistics (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.management.j2ee.statistics

  • Packages that use javax.management.j2ee.statistics
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects
  • Classes in javax.management.j2ee.statistics used by javax.management.j2ee.statistics
    Class and Description
    BoundaryStatistic
    Specifies standard measurements of the upper and lower limits of the value of an attribute.
    BoundedRangeStatistic
    The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.
    CountStatistic
    Specifies standard count measurements.
    EJBStats
    Specifies statistics provided by all EJB component types.
    JCAConnectionPoolStats
    Specifies the statistics provided by a JCA Connection Pool
    JCAConnectionStats
    Specifies the statistics provided by a JCA connection
    JDBCConnectionPoolStats
    Specifies the statistics provided by a JDBC connection pool.
    JDBCConnectionStats
    Specifies the statistics provided by all (pooled and non-pooled) JDBC connections.
    JMSConnectionStats
    Specifies the statistics provided by a JMS connection
    JMSConsumerStats
    Specifies the statistics provided by a JMS message consumer
    JMSEndpointStats
    Specifies the statistics provided by a JMS message producer or a JMS message consumer.
    JMSProducerStats
    Specifies the statistics provided by a JMS message producer
    JMSSessionStats
    Specifies the statistics provided by a JMS session.
    RangeStatistic
    Specifies standard measurements of the lowest and highest values an attribute has held as well as its current value.
    SessionBeanStats
    Specifies the statistics provided by session beans of both stateful and stateless types.
    Statistic
    The Statistic model and its sub-models specify the data models which are requried to be used to provide the performance data described by the specific attributes in the Stats models.
    Stats
    The Stats model and its submodels specify performance data attributes for each of the specific managed object types.
    TimeStatistic
    Specifies standard timing measurements.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.BoundaryStatistic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.BoundaryStatistic

  • Packages that use BoundaryStatistic
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of BoundaryStatistic in javax.management.j2ee.statistics

      Subinterfaces of BoundaryStatistic in javax.management.j2ee.statistics
      Modifier and Type Interface and Description
      interface  BoundedRangeStatistic
      The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.BoundedRangeStatistic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.BoundedRangeStatistic

  • Packages that use BoundedRangeStatistic
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of BoundedRangeStatistic in javax.management.j2ee.statistics

      Methods in javax.management.j2ee.statistics that return BoundedRangeStatistic
      Modifier and Type Method and Description
      BoundedRangeStatistic JDBCConnectionPoolStats.getFreePoolSize()
      Number of free connections in the pool.
      BoundedRangeStatistic JCAConnectionPoolStats.getFreePoolSize()
      The number of free connections in the pool
      BoundedRangeStatistic JVMStats.getHeapSize()
      Size of the JVM's heap.
      BoundedRangeStatistic JDBCConnectionPoolStats.getPoolSize()
      Size of the connection pool.
      BoundedRangeStatistic JCAConnectionPoolStats.getPoolSize()
      The size of the connection pool
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.CountStatistic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.CountStatistic

  • Packages that use CountStatistic
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of CountStatistic in javax.management.j2ee.statistics

      Methods in javax.management.j2ee.statistics that return CountStatistic
      Modifier and Type Method and Description
      CountStatistic JTAStats.getActiveCount()
      Number of active transactions.
      CountStatistic JDBCConnectionPoolStats.getCloseCount()
      Number of connections closed.
      CountStatistic JCAConnectionPoolStats.getCloseCount()
      The number of connections closed
      CountStatistic JTAStats.getCommittedCount()
      Number of committed transactions.
      CountStatistic JDBCConnectionPoolStats.getCreateCount()
      Number of connections created.
      CountStatistic JCAConnectionPoolStats.getCreateCount()
      The number of connections created
      CountStatistic EJBStats.getCreateCount()
      Number of times create was called.
      CountStatistic JMSSessionStats.getDurableSubscriptionCount()
      Number of durable subscriptions.
      CountStatistic JMSSessionStats.getExpiredMessageCount()
      Number of expired messages.
      CountStatistic JMSEndpointStats.getExpiredMessageCount()
      Number of messages that expired before delivery.
      CountStatistic MessageDrivenBeanStats.getMessageCount()
      Number of messages received.
      CountStatistic JMSSessionStats.getMessageCount()
      Number of messages exchanged.
      CountStatistic JMSEndpointStats.getMessageCount()
      Number of messages sent or received.
      CountStatistic JMSSessionStats.getPendingMessageCount()
      Number of pending messages.
      CountStatistic JMSEndpointStats.getPendingMessageCount()
      Number of pending messages.
      CountStatistic EJBStats.getRemoveCount()
      Number of times remove was called.
      CountStatistic JTAStats.getRolledbackCount()
      Number of rolled-back transactions.
      CountStatistic JavaMailStats.getSentMailCount()
      The number of mail messages sent.
      CountStatistic JVMStats.getUpTime()
      Amount of time the JVM has been running.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.EJBStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.EJBStats

  • Packages that use EJBStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of EJBStats in javax.management.j2ee.statistics

      Subinterfaces of EJBStats in javax.management.j2ee.statistics
      Modifier and Type Interface and Description
      interface  EntityBeanStats
      Specifies statistics provided by entity beans.
      interface  MessageDrivenBeanStats
      Specifies the statistics provided by a message driven bean.
      interface  SessionBeanStats
      Specifies the statistics provided by session beans of both stateful and stateless types.
      interface  StatefulSessionBeanStats
      Specifies the statistics provided by a stateful session bean.
      interface  StatelessSessionBeanStats
      Specifies the statistics provided by a stateless session bean.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.EntityBeanStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.EntityBeanStats

No usage of javax.management.j2ee.statistics.EntityBeanStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JavaMailStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JavaMailStats

No usage of javax.management.j2ee.statistics.JavaMailStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JCAConnectionPoolStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JCAConnectionPoolStats

  • Packages that use JCAConnectionPoolStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of JCAConnectionPoolStats in javax.management.j2ee.statistics

      Methods in javax.management.j2ee.statistics that return JCAConnectionPoolStats
      Modifier and Type Method and Description
      JCAConnectionPoolStats[] JCAStats.getConnectionPools()
      Returns an array of JCAConnectionPool Stats that provide statistics about the connection pools associated with the referencing JCA resource statistics
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JCAConnectionStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JCAConnectionStats

  • Packages that use JCAConnectionStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of JCAConnectionStats in javax.management.j2ee.statistics

      Subinterfaces of JCAConnectionStats in javax.management.j2ee.statistics
      Modifier and Type Interface and Description
      interface  JCAConnectionPoolStats
      Specifies the statistics provided by a JCA Connection Pool
      Methods in javax.management.j2ee.statistics that return JCAConnectionStats
      Modifier and Type Method and Description
      JCAConnectionStats[] JCAStats.getConnections()
      Returns an array of JCAConnectionStats that provide statistics about the non-pooled connections associated with the referencing JCA resource statistics
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JCAStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JCAStats

No usage of javax.management.j2ee.statistics.JCAStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JDBCConnectionPoolStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JDBCConnectionPoolStats

  • Packages that use JDBCConnectionPoolStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of JDBCConnectionPoolStats in javax.management.j2ee.statistics

      Methods in javax.management.j2ee.statistics that return JDBCConnectionPoolStats
      Modifier and Type | Method and Description
      JDBCConnectionPoolStats[] | JDBCStats.getConnectionPools()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JDBCConnectionStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JDBCConnectionStats

  • Packages that use JDBCConnectionStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of JDBCConnectionStats in javax.management.j2ee.statistics

      Subinterfaces of JDBCConnectionStats in javax.management.j2ee.statistics
      Modifier and Type Interface and Description
      interface  JDBCConnectionPoolStats
      Specifies the statistics provided by a JDBC connection pool.
      Methods in javax.management.j2ee.statistics that return JDBCConnectionStats
      Modifier and Type | Method and Description
      JDBCConnectionStats[] | JDBCStats.getConnections()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JDBCStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JDBCStats

No usage of javax.management.j2ee.statistics.JDBCStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JMSConnectionStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JMSConnectionStats

  • Packages that use JMSConnectionStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of JMSConnectionStats in javax.management.j2ee.statistics

      Methods in javax.management.j2ee.statistics that return JMSConnectionStats
      Modifier and Type Method and Description
      JMSConnectionStats[] JMSStats.getConnections()
      Returns an array of JMSConnectionStats that provide statistics about the connections associated with the referencing JMS resource.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JMSConsumerStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JMSConsumerStats

  • Packages that use JMSConsumerStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of JMSConsumerStats in javax.management.j2ee.statistics

      Methods in javax.management.j2ee.statistics that return JMSConsumerStats
      Modifier and Type Method and Description
      JMSConsumerStats[] JMSSessionStats.getConsumers()
      Returns an array of JMSConsumerStats that provide statistics about the message consumers associated with the referencing JMS session statistics.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JMSEndpointStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JMSEndpointStats

  • Packages that use JMSEndpointStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of JMSEndpointStats in javax.management.j2ee.statistics

      Subinterfaces of JMSEndpointStats in javax.management.j2ee.statistics
      Modifier and Type Interface and Description
      interface  JMSConsumerStats
      Specifies the statistics provided by a JMS message consumer
      interface  JMSProducerStats
      Specifies the statistics provided by a JMS message producer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JMSProducerStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JMSProducerStats

  • Packages that use JMSProducerStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of JMSProducerStats in javax.management.j2ee.statistics

      Methods in javax.management.j2ee.statistics that return JMSProducerStats
      Modifier and Type Method and Description
      JMSProducerStats[] JMSSessionStats.getProducers()
      Returns an array of JMSProducerStats that provide statistics about the message producers associated with the referencing JMS session statistics.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JMSSessionStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JMSSessionStats

  • Packages that use JMSSessionStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of JMSSessionStats in javax.management.j2ee.statistics

      Methods in javax.management.j2ee.statistics that return JMSSessionStats
      Modifier and Type Method and Description
      JMSSessionStats[] JMSConnectionStats.getSessions()
      Returns an array of JMSSessionStats that provide statistics about the sessions associated with the referencing JMSConnectionStats.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JMSStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JMSStats

No usage of javax.management.j2ee.statistics.JMSStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JTAStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JTAStats

No usage of javax.management.j2ee.statistics.JTAStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.JVMStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.JVMStats

No usage of javax.management.j2ee.statistics.JVMStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.MessageDrivenBeanStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.MessageDrivenBeanStats

No usage of javax.management.j2ee.statistics.MessageDrivenBeanStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.RangeStatistic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.RangeStatistic

  • Packages that use RangeStatistic
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of RangeStatistic in javax.management.j2ee.statistics

      Subinterfaces of RangeStatistic in javax.management.j2ee.statistics
      Modifier and Type Interface and Description
      interface  BoundedRangeStatistic
      The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.
      Methods in javax.management.j2ee.statistics that return RangeStatistic
      Modifier and Type Method and Description
      RangeStatistic SessionBeanStats.getMethodReadyCount()
      Number of beans in the method-ready state.
      RangeStatistic StatefulSessionBeanStats.getPassiveCount()
      Number of beans that are in the passive state.
      RangeStatistic EntityBeanStats.getPooledCount()
      Number of beans in the pooled state.
      RangeStatistic EntityBeanStats.getReadyCount()
      Number of beans in the ready state.
      RangeStatistic JDBCConnectionPoolStats.getWaitingThreadCount()
      Number of threads waiting for a connection.
      RangeStatistic JCAConnectionPoolStats.getWaitingThreadCount()
      The number of threads waiting for a connection
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.ServletStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.ServletStats

No usage of javax.management.j2ee.statistics.ServletStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.SessionBeanStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.SessionBeanStats

  • Packages that use SessionBeanStats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of SessionBeanStats in javax.management.j2ee.statistics

      Subinterfaces of SessionBeanStats in javax.management.j2ee.statistics
      Modifier and Type Interface and Description
      interface  StatefulSessionBeanStats
      Specifies the statistics provided by a stateful session bean.
      interface  StatelessSessionBeanStats
      Specifies the statistics provided by a stateless session bean.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.StatefulSessionBeanStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.StatefulSessionBeanStats

No usage of javax.management.j2ee.statistics.StatefulSessionBeanStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.StatelessSessionBeanStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.StatelessSessionBeanStats

No usage of javax.management.j2ee.statistics.StatelessSessionBeanStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.Statistic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.Statistic

  • Packages that use Statistic
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of Statistic in javax.management.j2ee.statistics

      Subinterfaces of Statistic in javax.management.j2ee.statistics
      Modifier and Type Interface and Description
      interface  BoundaryStatistic
      Specifies standard measurements of the upper and lower limits of the value of an attribute.
      interface  BoundedRangeStatistic
      The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.
      interface  CountStatistic
      Specifies standard count measurements.
      interface  RangeStatistic
      Specifies standard measurements of the lowest and highest values an attribute has held as well as its current value.
      interface  TimeStatistic
      Specifies standard timing measurements.
      Methods in javax.management.j2ee.statistics that return Statistic
      Modifier and Type Method and Description
      Statistic Stats.getStatistic(String statisticName)
      Get a Statistic by name.
      Statistic[] Stats.getStatistics()
      Returns an array containing all of the Statistic objects supported by this Stats object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.Stats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.Stats

  • Packages that use Stats
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of Stats in javax.management.j2ee.statistics

      Subinterfaces of Stats in javax.management.j2ee.statistics
      Modifier and Type Interface and Description
      interface  EJBStats
      Specifies statistics provided by all EJB component types.
      interface  EntityBeanStats
      Specifies statistics provided by entity beans.
      interface  JCAConnectionPoolStats
      Specifies the statistics provided by a JCA Connection Pool
      interface  JCAConnectionStats
      Specifies the statistics provided by a JCA connection
      interface  JCAStats
      Specifies statistics provided by a JCA resource
      interface  JDBCConnectionPoolStats
      Specifies the statistics provided by a JDBC connection pool.
      interface  JDBCConnectionStats
      Specifies the statistics provided by all (pooled and non-pooled) JDBC connections.
      interface  JDBCStats
      Statistics provided by a JDBC resource
      interface  JMSConnectionStats
      Specifies the statistics provided by a JMS connection
      interface  JMSConsumerStats
      Specifies the statistics provided by a JMS message consumer
      interface  JMSEndpointStats
      Specifies the statistics provided by a JMS message producer or a JMS message consumer.
      interface  JMSProducerStats
      Specifies the statistics provided by a JMS message producer
      interface  JMSSessionStats
      Specifies the statistics provided by a JMS session.
      interface  JMSStats
      Specifies the statistics provided by a JMS Resource
      interface  JTAStats
      Specifies the statistics provided by a JTA resource.
      interface  JVMStats
      Specifies the statistics provided by a Java VM.
      interface  MessageDrivenBeanStats
      Specifies the statistics provided by a message driven bean.
      interface  ServletStats
      Specifies the statistics provided by a Servlet.
      interface  SessionBeanStats
      Specifies the statistics provided by session beans of both stateful and stateless types.
      interface  StatefulSessionBeanStats
      Specifies the statistics provided by a stateful session bean.
      interface  StatelessSessionBeanStats
      Specifies the statistics provided by a stateless session bean.
      interface  URLStats
      Specifies the statistics provided by a URL resource.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.TimeStatistic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.TimeStatistic

  • Packages that use TimeStatistic
    Package Description
    javax.management.j2ee.statistics
    Provides the standard interfaces for accessing performance data from J2EE managed objects

    • Uses of TimeStatistic in javax.management.j2ee.statistics

      Methods in javax.management.j2ee.statistics that return TimeStatistic
      Modifier and Type Method and Description
      TimeStatistic JMSSessionStats.getMessageWaitTime()
      Time spent by a message before being delivered.
      TimeStatistic JMSEndpointStats.getMessageWaitTime()
      Time spent by a message before being delivered.
      TimeStatistic ServletStats.getServiceTime()
      Execution times for the methods.
      TimeStatistic JDBCConnectionStats.getUseTime()
      Time spent using a connection.
      TimeStatistic JCAConnectionStats.getUseTime()
      Returns the time spent using a connection
      TimeStatistic JDBCConnectionStats.getWaitTime()
      Time spent waiting for a connection to be available.
      TimeStatistic JCAConnectionStats.getWaitTime()
      Returns the time spent waiting for a connection to be available
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.management.j2ee.statistics.URLStats (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.management.j2ee.statistics.URLStats

No usage of javax.management.j2ee.statistics.URLStats
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Access (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Access

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Access
    Used to specify an access type to be applied to an entity class, mapped superclass, or embeddable class, or to a specific attribute of such a class.
    Since:
    Java Persistence 2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      AccessType value
      (Required) Specification of field- or property-based access.

    • Element Detail

      • value

        public abstract AccessType value
        (Required) Specification of field- or property-based access.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AccessType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum AccessType

  • java.lang.Object
    • java.lang.Enum<AccessType>
      • javax.persistence.AccessType
  • All Implemented Interfaces:
    Serializable, Comparable<AccessType>

    public enum AccessType
extends Enum<AccessType>
    Used with the Access annotation to specify an access type to be applied to an entity class, mapped superclass, or embeddable class, or to a specific attribute of such a class.
    Since:
    Java Persistence 2.0
    See Also:
    Access

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      FIELD
      Field-based access is used.
      PROPERTY
      Property-based access is used.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static AccessType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AccessType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • FIELD

        public static final AccessType FIELD
        Field-based access is used.

      • PROPERTY

        public static final AccessType PROPERTY
        Property-based access is used.

    • Method Detail

      • values

        public static AccessType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (AccessType c : AccessType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static AccessType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


AssociationOverride (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type AssociationOverride

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface AssociationOverride
    Used to override a mapping for an entity relationship.

    May be applied to an entity that extends a mapped superclass to override a relationship mapping defined by the mapped superclass. If not specified, the association is mapped the same as in the original mapping. When used to override a mapping defined by a mapped superclass, AssociationOverride is applied to the entity class.

    May be used to override a relationship mapping from an embeddable within an entity to another entity when the embeddable is on the owning side of the relationship. When used to override a relationship mapping defined by an embeddable class (including an embeddable class embedded within another embeddable class), AssociationOverride is applied to the field or property containing the embeddable.

    When AssociationOverride is used to override a relationship mapping from an embeddable class, the name element specifies the referencing relationship field or property within the embeddable class. To override mappings at multiple levels of embedding, a dot (".") notation syntax must be used in the name element to indicate an attribute within an embedded attribute. The value of each identifier used with the dot notation is the name of the respective embedded field or property.

    When AssociationOverride is applied to override the mappings of an embeddable class used as a map value, "value." must be used to prefix the name of the attribute within the embeddable class that is being overridden in order to specify it as part of the map value.

    If the relationship mapping is a foreign key mapping, the joinColumns element is used. If the relationship mapping uses a join table, the joinTable element must be specified to override the mapping of the join table and/or its join columns.

        Example 1: Overriding the mapping of a relationship defined by a mapped superclass

    @MappedSuperclass
    public class Employee {
        ...
        @ManyToOne
        protected Address address;
        ...
    }

    @Entity
        @AssociationOverride(name="address",
                             joinColumns=@JoinColumn(name="ADDR_ID"))
        // address field mapping overridden to ADDR_ID foreign key
    public class PartTimeEmployee extends Employee {
        ...
    }

        Example 2: Overriding the mapping for phoneNumbers defined in the ContactInfo class

    @Entity
    public class Employee {
        @Id int id;
        @AssociationOverride(
          name="phoneNumbers",
          joinTable=@JoinTable(
             name="EMPPHONES",
             joinColumns=@JoinColumn(name="EMP"),
             inverseJoinColumns=@JoinColumn(name="PHONE")
          )
        )
        @Embedded ContactInfo contactInfo;
       ...
    }

    @Embeddable
    public class ContactInfo {
        @ManyToOne Address address; // Unidirectional
        @ManyToMany(targetEntity=PhoneNumber.class) List phoneNumbers;
    }

    @Entity
    public class PhoneNumber {
        @Id int number;
        @ManyToMany(mappedBy="contactInfo.phoneNumbers")
        Collection<Employee> employees;
     }
    Since:
    Java Persistence 1.0
    See Also:
    Embedded, Embeddable, MappedSuperclass, AttributeOverride

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      (Required) The name of the relationship property whose mapping is being overridden if property-based access is being used, or the name of the relationship field if field-based access is used.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      ForeignKey foreignKey
      (Optional) Used to specify or control the generation of a foreign key constraint for the columns corresponding to the joinColumns element when table generation is in effect.
      JoinColumn[] joinColumns
      The join column(s) being mapped to the persistent attribute(s).
      JoinTable joinTable
      The join table that maps the relationship.

    • Element Detail

      • name

        public abstract String name
        (Required) The name of the relationship property whose mapping is being overridden if property-based access is being used, or the name of the relationship field if field-based access is used.

      • joinColumns

        public abstract JoinColumn[] joinColumns
        The join column(s) being mapped to the persistent attribute(s). The joinColumns elements must be specified if a foreign key mapping is used in the overriding of the mapping of the relationship. The joinColumns element must not be specified if a join table is used in the overriding of the mapping of the relationship.
        Default:
        {}

      • foreignKey

        public abstract ForeignKey foreignKey
        (Optional) Used to specify or control the generation of a foreign key constraint for the columns corresponding to the joinColumns element when table generation is in effect. If both this element and the foreignKey element of any of the joinColumns elements are specified, the behavior is undefined. If no foreign key annotation element is specified in either location, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)

      • joinTable

        public abstract JoinTable joinTable
        The join table that maps the relationship. The joinTable element must be specified if a join table is used in the overriding of the mapping of the relationship. The joinTable element must not be specified if a foreign key mapping is used in the overriding of the relationship.
        Since:
        Java Persistence 2.0
        Default:
        @javax.persistence.JoinTable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AssociationOverrides (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type AssociationOverrides

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface AssociationOverrides
    Used to override mappings of multiple relationship properties or fields.

    Example:

    @MappedSuperclass
    public class Employee {

        @Id protected Integer id;
        @Version protected Integer version;
        @ManyToOne protected Address address;
        @OneToOne protected Locker locker;

        public Integer getId() { ... }
        public void setId(Integer id) { ... }
        public Address getAddress() { ... }
        public void setAddress(Address address) { ... }
        public Locker getLocker() { ... }
        public void setLocker(Locker locker) { ... }
        ...
    }

    @Entity
    @AssociationOverrides({
        @AssociationOverride(
                   name="address",
                   joinColumns=@JoinColumn("ADDR_ID")),
        @AttributeOverride(
                   name="locker",
                   joinColumns=@JoinColumn("LCKR_ID"))
        })
    public PartTimeEmployee { ... }
    Since:
    Java Persistence 1.0
    See Also:
    AssociationOverride

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      AssociationOverride[] value
      (Required) The association override mappings that are to be applied to the relationship field or property .

    • Element Detail

      • value

        public abstract AssociationOverride[] value
        (Required) The association override mappings that are to be applied to the relationship field or property .
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AttributeConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface AttributeConverter<X,Y>

  • Type Parameters:
    X - the type of the entity attribute
    Y - the type of the database column

    public interface AttributeConverter<X,Y>
    A class that implements this interface can be used to convert entity attribute state into database column representation and back again. Note that the X and Y types may be the same Java type.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Y convertToDatabaseColumn(X attribute)
      Converts the value stored in the entity attribute into the data representation to be stored in the database.
      X convertToEntityAttribute(Y dbData)
      Converts the data stored in the database column into the value to be stored in the entity attribute.

    • Method Detail

      • convertToDatabaseColumn

        Y convertToDatabaseColumn(X attribute)
        Converts the value stored in the entity attribute into the data representation to be stored in the database.
        Parameters:
        attribute - the entity attribute value to be converted
        Returns:
        the converted data to be stored in the database column

      • convertToEntityAttribute

        X convertToEntityAttribute(Y dbData)
        Converts the data stored in the database column into the value to be stored in the entity attribute. Note that it is the responsibility of the converter writer to specify the correct dbData type for the corresponding column for use by the JDBC driver: i.e., persistence providers are not expected to do such type conversion.
        Parameters:
        dbData - the data from the database column to be converted
        Returns:
        the converted value to be stored in the entity attribute
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AttributeNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface AttributeNode<T>

  • Type Parameters:
    T - The type of the attribute.

    public interface AttributeNode<T>
    Represents an attribute node of an entity graph.
    Since:
    Java Persistence 2.1
    See Also:
    EntityGraph, Subgraph, NamedAttributeNode

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAttributeName()
      Return the name of the attribute corresponding to the attribute node.
      Map<Class,Subgraph> getKeySubgraphs()
      Return the Map<Class, Subgraph> of subgraphs associated with this attribute node's map key.
      Map<Class,Subgraph> getSubgraphs()
      Return the Map<Class, Subgraph> of subgraphs associated with this attribute node.

    • Method Detail

      • getAttributeName

        String getAttributeName()
        Return the name of the attribute corresponding to the attribute node.
        Returns:
        name of the attribute

      • getSubgraphs

        Map<Class,Subgraph> getSubgraphs()
        Return the Map<Class, Subgraph> of subgraphs associated with this attribute node.
        Returns:
        Map of subgraphs associated with this attribute node or empty Map if none have been defined

      • getKeySubgraphs

        Map<Class,Subgraph> getKeySubgraphs()
        Return the Map<Class, Subgraph> of subgraphs associated with this attribute node's map key.
        Returns:
        Map of subgraphs associated with this attribute node's map key or empty Map if none have been defined
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AttributeOverride (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type AttributeOverride

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface AttributeOverride
    Used to override the mapping of a Basic (whether explicit or default) property or field or Id property or field.

    May be applied to an entity that extends a mapped superclass or to an embedded field or property to override a basic mapping or id mapping defined by the mapped superclass or embeddable class (or embeddable class of one of its attributes).

    May be applied to an element collection containing instances of an embeddable class or to a map collection whose key and/or value is an embeddable class. When AttributeOverride is applied to a map, "key." or "value." must be used to prefix the name of the attribute that is being overridden in order to specify it as part of the map key or map value.

    To override mappings at multiple levels of embedding, a dot (".") notation form must be used in the name element to indicate an attribute within an embedded attribute. The value of each identifier used with the dot notation is the name of the respective embedded field or property.

    If AttributeOverride is not specified, the column is mapped the same as in the original mapping.

        Example 1:

    @MappedSuperclass
    public class Employee {
        @Id protected Integer id;
        @Version protected Integer version;
        protected String address;
        public Integer getId() { ... }
        public void setId(Integer id) { ... }
        public String getAddress() { ... }
        public void setAddress(String address) { ... }
    }

    @Entity
    @AttributeOverride(name="address", column=@Column(name="ADDR"))
    public class PartTimeEmployee extends Employee {
        // address field mapping overridden to ADDR
        protected Float wage();
        public Float getHourlyWage() { ... }
        public void setHourlyWage(Float wage) { ... }
    }

    Example 2:

    @Embeddable public class Address {
        protected String street;
        protected String city;
        protected String state;
        @Embedded protected Zipcode zipcode;
    }

    @Embeddable public class Zipcode {
        protected String zip;
        protected String plusFour;
    }

    @Entity public class Customer {
        @Id protected Integer id;
        protected String name;
        @AttributeOverrides({
            @AttributeOverride(name="state",
                               column=@Column(name="ADDR_STATE")),
            @AttributeOverride(name="zipcode.zip",
                               column=@Column(name="ADDR_ZIP"))
        })
        @Embedded protected Address address;
        ...
    }

    Example 3:

    @Entity public class PropertyRecord {
        @EmbeddedId PropertyOwner owner;
        @AttributeOverrides({
            @AttributeOverride(name="key.street",
                               column=@Column(name="STREET_NAME")),
            @AttributeOverride(name="value.size",
                               column=@Column(name="SQUARE_FEET")),
            @AttributeOverride(name="value.tax",
                               column=@Column(name="ASSESSMENT"))
        })
       @ElementCollection
       Map<Address, PropertyInfo> parcels;
    }

   @Embeddable public class PropertyInfo {
       Integer parcelNumber;
       Integer size;
       BigDecimal tax;
   }
    Since:
    Java Persistence 1.0
    See Also:
    Embedded, Embeddable, MappedSuperclass, AssociationOverride

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Column column
      (Required) The column that is being mapped to the persistent attribute.
      String name
      (Required) The name of the property whose mapping is being overridden if property-based access is being used, or the name of the field if field-based access is used.

    • Element Detail

      • name

        public abstract String name
        (Required) The name of the property whose mapping is being overridden if property-based access is being used, or the name of the field if field-based access is used.

      • column

        public abstract Column column
        (Required) The column that is being mapped to the persistent attribute. The mapping type will remain the same as is defined in the embeddable class or mapped superclass.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AttributeOverrides (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type AttributeOverrides

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface AttributeOverrides
    Used to override mappings of multiple properties or fields.

    Example:

    @Embedded
    @AttributeOverrides({
            @AttributeOverride(name="startDate",
                               column=@Column("EMP_START")),
            @AttributeOverride(name="endDate",
                               column=@Column("EMP_END"))
    })
    public EmploymentPeriod getEmploymentPeriod() { ... }
    Since:
    Java Persistence 1.0
    See Also:
    AttributeOverride

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      AttributeOverride[] value
      (Required) One or more field or property mapping overrides.

    • Element Detail

      • value

        public abstract AttributeOverride[] value
        (Required) One or more field or property mapping overrides.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Basic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Basic

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Basic
    The simplest type of mapping to a database column. The Basic annotation can be applied to a persistent property or instance variable of any of the following types: Java primitive types, wrappers of the primitive types, String, java.math.BigInteger, java.math.BigDecimal, java.util.Date, java.util.Calendar, java.sql.Date, java.sql.Time, java.sql.Timestamp, byte[], Byte[], char[], Character[], enums, and any other type that implements java.io.Serializable.

    The use of the Basic annotation is optional for persistent fields and properties of these types. If the Basic annotation is not specified for such a field or property, the default values of the Basic annotation will apply.

        Example 1:

    @Basic
    protected String name;

    Example 2:

    @Basic(fetch=LAZY)
    protected String getName() { return name; }
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      FetchType fetch
      (Optional) Defines whether the value of the field or property should be lazily loaded or must be eagerly fetched.
      boolean optional
      (Optional) Defines whether the value of the field or property may be null.

    • Element Detail

      • fetch

        public abstract FetchType fetch
        (Optional) Defines whether the value of the field or property should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistence provider runtime that the value must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime. If not specified, defaults to EAGER.
        Default:
        javax.persistence.FetchType.EAGER

      • optional

        public abstract boolean optional
        (Optional) Defines whether the value of the field or property may be null. This is a hint and is disregarded for primitive types; it may be used in schema generation. If not specified, defaults to true.
        Default:
        true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Cache (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface Cache

  • public interface Cache
    Interface used to interact with the second-level cache. If a cache is not in use, the methods of this interface have no effect, except for contains, which returns false.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean contains(Class cls, Object primaryKey)
      Whether the cache contains data for the given entity.
      void evict(Class cls)
      Remove the data for entities of the specified class (and its subclasses) from the cache.
      void evict(Class cls, Object primaryKey)
      Remove the data for the given entity from the cache.
      void evictAll()
      Clear the cache.
      <T> T unwrap(Class<T> cls)
      Return an object of the specified type to allow access to the provider-specific API.

    • Method Detail

      • contains

        boolean contains(Class cls,
               Object primaryKey)
        Whether the cache contains data for the given entity.
        Parameters:
        cls - entity class
        primaryKey - primary key
        Returns:
        boolean indicating whether the entity is in the cache

      • evict

        void evict(Class cls,
         Object primaryKey)
        Remove the data for the given entity from the cache.
        Parameters:
        cls - entity class
        primaryKey - primary key

      • evict

        void evict(Class cls)
        Remove the data for entities of the specified class (and its subclasses) from the cache.
        Parameters:
        cls - entity class

      • evictAll

        void evictAll()
        Clear the cache.

      • unwrap

        <T> T unwrap(Class<T> cls)
        Return an object of the specified type to allow access to the provider-specific API. If the provider's Cache implementation does not support the specified class, the PersistenceException is thrown.
        Parameters:
        cls - the class of the object to be returned. This is normally either the underlying Cache implementation class or an interface that it implements.
        Returns:
        an instance of the specified class
        Throws:
        PersistenceException - if the provider does not support the call
        Since:
        Java Persistence 2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Cacheable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Cacheable

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Cacheable
    Specifies whether an entity should be cached if caching is enabled when the value of the persistence.xml caching element is ENABLE_SELECTIVE or DISABLE_SELECTIVE. The value of the Cacheable annotation is inherited by subclasses; it can be overridden by specifying Cacheable on a subclass.

    Cacheable(false) means that the entity and its state must not be cached by the provider.

    Since:
    Java Persistence 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean value
      (Optional) Whether or not the entity should be cached.

    • Element Detail

      • value

        public abstract boolean value
        (Optional) Whether or not the entity should be cached.
        Default:
        true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


CacheRetrieveMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum CacheRetrieveMode

  • java.lang.Object
    • java.lang.Enum<CacheRetrieveMode>
      • javax.persistence.CacheRetrieveMode
  • All Implemented Interfaces:
    Serializable, Comparable<CacheRetrieveMode>

    public enum CacheRetrieveMode
extends Enum<CacheRetrieveMode>
    Used as the value of the javax.persistence.cache.retrieveMode property to specify the behavior when data is retrieved by the find methods and by queries.
    Since:
    Java Persistence 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BYPASS
      Bypass the cache: get data directly from the database.
      USE
      Read entity data from the cache: this is the default behavior.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static CacheRetrieveMode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CacheRetrieveMode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • USE

        public static final CacheRetrieveMode USE
        Read entity data from the cache: this is the default behavior.

      • BYPASS

        public static final CacheRetrieveMode BYPASS
        Bypass the cache: get data directly from the database.

    • Method Detail

      • values

        public static CacheRetrieveMode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (CacheRetrieveMode c : CacheRetrieveMode.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static CacheRetrieveMode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


CacheStoreMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum CacheStoreMode

  • java.lang.Object
    • java.lang.Enum<CacheStoreMode>
      • javax.persistence.CacheStoreMode
  • All Implemented Interfaces:
    Serializable, Comparable<CacheStoreMode>

    public enum CacheStoreMode
extends Enum<CacheStoreMode>
    Used as the value of the javax.persistence.cache.storeMode property to specify the behavior when data is read from the database and when data is committed into the database.
    Since:
    Java Persistence 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BYPASS
      Don't insert into cache.
      REFRESH
      Insert/update entity data into cache when read from database and when committed into database.
      USE
      Insert entity data into cache when read from database and insert/update entity data when committed into database: this is the default behavior.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static CacheStoreMode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CacheStoreMode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • USE

        public static final CacheStoreMode USE
        Insert entity data into cache when read from database and insert/update entity data when committed into database: this is the default behavior. Does not force refresh of already cached items when reading from database.

      • BYPASS

        public static final CacheStoreMode BYPASS
        Don't insert into cache.

      • REFRESH

        public static final CacheStoreMode REFRESH
        Insert/update entity data into cache when read from database and when committed into database. Forces refresh of cache for items read from database.

    • Method Detail

      • values

        public static CacheStoreMode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (CacheStoreMode c : CacheStoreMode.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static CacheStoreMode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


CascadeType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum CascadeType

  • java.lang.Object
    • java.lang.Enum<CascadeType>
      • javax.persistence.CascadeType
  • All Implemented Interfaces:
    Serializable, Comparable<CascadeType>

    public enum CascadeType
extends Enum<CascadeType>
    Defines the set of cascadable operations that are propagated to the associated entity. The value cascade=ALL is equivalent to cascade={PERSIST, MERGE, REMOVE, REFRESH, DETACH}.
    Since:
    Java Persistence 1.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ALL
      Cascade all operations
      DETACH
      Cascade detach operation
      MERGE
      Cascade merge operation
      PERSIST
      Cascade persist operation
      REFRESH
      Cascade refresh operation
      REMOVE
      Cascade remove operation

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static CascadeType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CascadeType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ALL

        public static final CascadeType ALL
        Cascade all operations

      • PERSIST

        public static final CascadeType PERSIST
        Cascade persist operation

      • MERGE

        public static final CascadeType MERGE
        Cascade merge operation

      • REMOVE

        public static final CascadeType REMOVE
        Cascade remove operation

      • REFRESH

        public static final CascadeType REFRESH
        Cascade refresh operation

      • DETACH

        public static final CascadeType DETACH
        Cascade detach operation
        Since:
        Java Persistence 2.0

    • Method Detail

      • values

        public static CascadeType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (CascadeType c : CascadeType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static CascadeType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


CollectionTable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type CollectionTable

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface CollectionTable
    Specifies the table that is used for the mapping of collections of basic or embeddable types. Applied to the collection-valued field or property.

    By default, the columns of the collection table that correspond to the embeddable class or basic type are derived from the attributes of the embeddable class or from the basic type according to the default values of the Column annotation. In the case of a basic type, the column name is derived from the name of the collection-valued field or property. In the case of an embeddable class, the column names are derived from the field or property names of the embeddable class.

    • To override the default properties of the column used for a basic type, the Column annotation is used on the collection-valued attribute in addition to the ElementCollection annotation.
    • To override these defaults for an embeddable class, the AttributeOverride and/or AttributeOverrides annotations can be used in addition to the ElementCollection annotation. If the embeddable class contains references to other entities, the default values for the columns corresponding to those references may be overridden by means of the AssociationOverride and/or AssociationOverrides annotations.

    If the CollectionTable annotation is missing, the default values of the CollectionTable annotation elements apply.

        Example:

    @Embeddable public class Address {
       protected String street;
       protected String city;
       protected String state;
       ...
     }

    @Entity public class Person {
       @Id protected String ssn;
       protected String name;
       protected Address home;
       ...
       @ElementCollection  // use default table (PERSON_NICKNAMES)
       @Column(name="name", length=50)
       protected Set<String> nickNames = new HashSet();
       ...
    }

    @Entity public class WealthyPerson extends Person {
       @ElementCollection
       @CollectionTable(name="HOMES") // use default join column name
       @AttributeOverrides({
          @AttributeOverride(name="street",
                             column=@Column(name="HOME_STREET")),
          @AttributeOverride(name="city",
                             column=@Column(name="HOME_CITY")),
          @AttributeOverride(name="state",
                             column=@Column(name="HOME_STATE"))
        })
       protected Set<Address> vacationHomes = new HashSet();
       ...
    }
    Since:
    Java Persistence 2.0
    See Also:
    ElementCollection, AttributeOverride, AssociationOverride, Column

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String catalog
      (Optional) The catalog of the table.
      ForeignKey foreignKey
      (Optional) Used to specify or control the generation of a foreign key constraint for the columns corresponding to the joinColumns element when table generation is in effect.
      Index[] indexes
      (Optional) Indexes for the table.
      JoinColumn[] joinColumns
      (Optional) The foreign key columns of the collection table which reference the primary table of the entity.
      String name
      (Optional) The name of the collection table.
      String schema
      (Optional) The schema of the table.
      UniqueConstraint[] uniqueConstraints
      (Optional) Unique constraints that are to be placed on the table.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the collection table. If not specified, it defaults to the concatenation of the name of the containing entity and the name of the collection attribute, separated by an underscore.
        Default:
        ""

      • catalog

        public abstract String catalog
        (Optional) The catalog of the table. If not specified, the default catalog is used.
        Default:
        ""

      • schema

        public abstract String schema
        (Optional) The schema of the table. If not specified, the default schema for the user is used.
        Default:
        ""

      • joinColumns

        public abstract JoinColumn[] joinColumns
        (Optional) The foreign key columns of the collection table which reference the primary table of the entity. The default only applies if a single join column is used. The default is the same as for JoinColumn (i.e., the concatenation of the following: the name of the entity; "_"; the name of the referenced primary key column.) However, if there is more than one join column, a JoinColumn annotation must be specified for each join column using the JoinColumns annotation. In this case, both the name and the referencedColumnName elements must be specified in each such JoinColumn annotation.
        Default:
        {}

      • foreignKey

        public abstract ForeignKey foreignKey
        (Optional) Used to specify or control the generation of a foreign key constraint for the columns corresponding to the joinColumns element when table generation is in effect. If both this element and the foreignKey element of any of the joinColumns elements are specified, the behavior is undefined. If no foreign key annotation element is specified in either location, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)

      • uniqueConstraints

        public abstract UniqueConstraint[] uniqueConstraints
        (Optional) Unique constraints that are to be placed on the table. These are only used if table generation is in effect.
        Default:
        {}

      • indexes

        public abstract Index[] indexes
        (Optional) Indexes for the table. These are only used if table generation is in effect.
        Since:
        Java Persistence 2.1
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Column (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Column

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Column
    Specifies the mapped column for a persistent property or field. If no Column annotation is specified, the default values apply.
        Example 1:

    @Column(name="DESC", nullable=false, length=512)
    public String getDescription() { return description; }

    Example 2:

    @Column(name="DESC",
            columnDefinition="CLOB NOT NULL",
            table="EMP_DETAIL")
    @Lob
    public String getDescription() { return description; }

    Example 3:

    @Column(name="ORDER_COST", updatable=false, precision=12, scale=2)
    public BigDecimal getCost() { return cost; }
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String columnDefinition
      (Optional) The SQL fragment that is used when generating the DDL for the column.
      boolean insertable
      (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
      int length
      (Optional) The column length.
      String name
      (Optional) The name of the column.
      boolean nullable
      (Optional) Whether the database column is nullable.
      int precision
      (Optional) The precision for a decimal (exact numeric) column.
      int scale
      (Optional) The scale for a decimal (exact numeric) column.
      String table
      (Optional) The name of the table that contains the column.
      boolean unique
      (Optional) Whether the column is a unique key.
      boolean updatable
      (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the column. Defaults to the property or field name.
        Default:
        ""

      • unique

        public abstract boolean unique
        (Optional) Whether the column is a unique key. This is a shortcut for the UniqueConstraint annotation at the table level and is useful for when the unique key constraint corresponds to only a single column. This constraint applies in addition to any constraint entailed by primary key mapping and to constraints specified at the table level.
        Default:
        false

      • nullable

        public abstract boolean nullable
        (Optional) Whether the database column is nullable.
        Default:
        true

      • insertable

        public abstract boolean insertable
        (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
        Default:
        true

      • updatable

        public abstract boolean updatable
        (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.
        Default:
        true

      • columnDefinition

        public abstract String columnDefinition
        (Optional) The SQL fragment that is used when generating the DDL for the column.

        Defaults to the generated SQL to create a column of the inferred type.

        Default:
        ""

      • table

        public abstract String table
        (Optional) The name of the table that contains the column. If absent the column is assumed to be in the primary table.
        Default:
        ""

      • length

        public abstract int length
        (Optional) The column length. (Applies only if a string-valued column is used.)
        Default:
        255

      • precision

        public abstract int precision
        (Optional) The precision for a decimal (exact numeric) column. (Applies only if a decimal column is used.) Value must be set by developer if used when generating the DDL for the column.
        Default:
        0

      • scale

        public abstract int scale
        (Optional) The scale for a decimal (exact numeric) column. (Applies only if a decimal column is used.)
        Default:
        0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ColumnResult (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type ColumnResult

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface ColumnResult
    Used in conjunction with the SqlResultSetMapping annotation or ConstructorResult annotation to map a column of the SELECT list of a SQL query.

    The name element references the name of a column in the SELECT list — i.e., column alias, if applicable. Scalar result types can be included in the query result by specifying this annotation in the metadata.

 Example:
   Query q = em.createNativeQuery(
       "SELECT o.id AS order_id, " +
           "o.quantity AS order_quantity, " +
           "o.item AS order_item, " +
           "i.name AS item_name, " +
         "FROM Order o, Item i " +
         "WHERE (order_quantity > 25) AND (order_item = i.id)",
       "OrderResults");

   @SqlResultSetMapping(name="OrderResults",
       entities={
           @EntityResult(entityClass=com.acme.Order.class, fields={
               @FieldResult(name="id", column="order_id"),
               @FieldResult(name="quantity", column="order_quantity"),
               @FieldResult(name="item", column="order_item")})},
       columns={
           @ColumnResult(name="item_name")}
       )
    Since:
    Java Persistence 1.0
    See Also:
    SqlResultSetMapping

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      (Required) The name of a column in the SELECT clause of a SQL query

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class type
      (Optional) The Java type to which the column type is to be mapped.

    • Element Detail

      • name

        public abstract String name
        (Required) The name of a column in the SELECT clause of a SQL query

      • type

        public abstract Class type
        (Optional) The Java type to which the column type is to be mapped. If the type element is not specified, the default JDBC type mapping for the column will be used.
        Since:
        Java Persistence 2.1
        Default:
        void.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ConstraintMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum ConstraintMode

  • java.lang.Object
    • java.lang.Enum<ConstraintMode>
      • javax.persistence.ConstraintMode
  • All Implemented Interfaces:
    Serializable, Comparable<ConstraintMode>

    public enum ConstraintMode
extends Enum<ConstraintMode>
    Used to control the application of a constraint.
    Since:
    Java Persistence 2.1

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      CONSTRAINT
      Apply the constraint.
      NO_CONSTRAINT
      Do not apply the constraint.
      PROVIDER_DEFAULT
      Use the provider-defined default behavior.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ConstraintMode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ConstraintMode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CONSTRAINT

        public static final ConstraintMode CONSTRAINT
        Apply the constraint.

      • NO_CONSTRAINT

        public static final ConstraintMode NO_CONSTRAINT
        Do not apply the constraint.

      • PROVIDER_DEFAULT

        public static final ConstraintMode PROVIDER_DEFAULT
        Use the provider-defined default behavior.

    • Method Detail

      • values

        public static ConstraintMode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ConstraintMode c : ConstraintMode.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ConstraintMode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ConstructorResult (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type ConstructorResult

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface ConstructorResult
    Used in conjunction with the SqlResultSetMapping annotation to map the SELECT clause of a SQL query to a constructor.

    Applies a constructor for the target class, passing in as arguments values from the specified columns. All columns corresponding to arguments of the intended constructor must be specified using the columns element of the ConstructorResult annotation in the same order as that of the argument list of the constructor. Any entities returned as constructor results will be in either the new or detached state, depending on whether a primary key is retrieved for the constructed object.

 Example:

   Query q = em.createNativeQuery(
      "SELECT c.id, c.name, COUNT(o) as orderCount, AVG(o.price) AS avgOrder " +
      "FROM Customer c, Orders o " +
      "WHERE o.cid = c.id " +
      "GROUP BY c.id, c.name",
      "CustomerDetailsResult");

   @SqlResultSetMapping(
       name="CustomerDetailsResult",
       classes={
          @ConstructorResult(
               targetClass=com.acme.CustomerDetails.class,
                 columns={
                    @ColumnResult(name="id"),
                    @ColumnResult(name="name"),
                    @ColumnResult(name="orderCount"),
                    @ColumnResult(name="avgOrder", type=Double.class)
                    }
          )
       }
      )
    Since:
    Java Persistence 2.1
    See Also:
    SqlResultSetMapping, ColumnResult

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      ColumnResult[] columns
      (Required) The mapping of columns in the SELECT list to the arguments of the intended constructor, in order.
      Class targetClass
      (Required) The class whose constructor is to be invoked.

    • Element Detail

      • targetClass

        public abstract Class targetClass
        (Required) The class whose constructor is to be invoked.

      • columns

        public abstract ColumnResult[] columns
        (Required) The mapping of columns in the SELECT list to the arguments of the intended constructor, in order.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Convert (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Convert

  • @Target(value={METHOD,FIELD,TYPE})
@Retention(value=RUNTIME)
public @interface Convert
    Specifies the conversion of a Basic field or property. It is not necessary to use the Basic annotation or corresponding XML element to specify the Basic type.

    The Convert annotation should not be used to specify conversion of the following: Id attributes, version attributes, relationship attributes, and attributes explicitly denoted as Enumerated or Temporal. Applications that specify such conversions will not be portable.

    The Convert annotation may be applied to a basic attribute or to an element collection of basic type (in which case the converter is applied to the elements of the collection). In these cases, the attributeName element must not be specified.

    The Convert annotation may be applied to an embedded attribute or to a map collection attribute whose key or value is of embeddable type (in which case the converter is applied to the specified attribute of the embeddable instances contained in the collection). In these cases, the attributeName element must be specified.

    To override conversion mappings at multiple levels of embedding, a dot (".") notation form must be used in the attributeName element to indicate an attribute within an embedded attribute. The value of each identifier used with the dot notation is the name of the respective embedded field or property.

    When the Convert annotation is applied to a map containing instances of embeddable classes, the attributeName element must be specified, and "key." or "value." must be used to prefix the name of the attribute that is to be converted in order to specify it as part of the map key or map value.

    When the Convert annotation is applied to a map to specify conversion of a map key of basic type, "key" must be used as the value of the attributeName element to specify that it is the map key that is to be converted.

    The Convert annotation may be applied to an entity class that extends a mapped superclass to specify or override a conversion mapping for an inherited basic or embedded attribute.

         Example 1:  Convert a basic attribute

     @Converter
     public class BooleanToIntegerConverter
        implements AttributeConverter<Boolean, Integer> {  ... }

     @Entity
     public class Employee {
         @Id long id;

         @Convert(BooleanToIntegerConverter.class)
          boolean fullTime;
          ...
     }

     Example 2:  Auto-apply conversion of a basic attribute

     @Converter(autoApply=true)
     public class EmployeeDateConverter
        implements AttributeConverter<com.acme.EmployeeDate, java.sql.Date> {  ... }

     @Entity
     public class Employee {
         @Id long id;
         ...
         // EmployeeDateConverter is applied automatically
         EmployeeDate startDate;
     }

     Example 3:  Disable conversion in the presence of an autoapply converter

     @Convert(disableConversion=true)
     EmployeeDate lastReview;

     Example 4:  Apply a converter to an element collection of basic type

     @ElementCollection
     // applies to each element in the collection
     @Convert(NameConverter.class)
     List<String> names;

     Example 5:  Apply a converter to an element collection that is a map or basic values.
                 The converter is applied to the map value.

     @ElementCollection
     @Convert(EmployeeNameConverter.class)
     Map<String, String> responsibilities;

     Example 6:  Apply a converter to a map key of basic type

     @OneToMany
     @Convert(converter=ResponsibilityCodeConverter.class,
              attributeName="key")
     Map<String, Employee> responsibilities;

     Example 7:  Apply a converter to an embeddable attribute

     @Embedded
     @Convert(converter=CountryConverter.class,
              attributeName="country")
     Address address;

     Example 8:  Apply a converter to a nested embeddable attribute

     @Embedded
     @Convert(converter=CityConverter.class,
              attributeName="region.city")
     Address address;

     Example 9:  Apply a converter to a nested attribute of an embeddable that is a map key
                 of an element collection

     @Entity public class PropertyRecord {
          ...
         @Convert(name="key.region.city",
                  converter=CityConverter.class)
         @ElementCollection
         Map<Address, PropertyInfo> parcels;
     }

     Example 10: Apply a converter to an embeddable that is a map key for a relationship

     @OneToMany
     @Convert(attributeName="key.jobType",
              converter=ResponsibilityTypeConverter.class)
     Map<Responsibility, Employee> responsibilities;

     Example 11: Override conversion mappings for attributes inherited from a mapped superclass

     @Entity
         @Converts({
            @Convert(attributeName="startDate",
                     converter=DateConverter.class),
            @Convert(attributeName="endDate",
                     converter=DateConverter.class)})
     public class FullTimeEmployee extends GenericEmployee { ... }
    Since:
    Java Persistence 2.1
    See Also:
    Converter, Converts, Basic

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String attributeName
      The attributeName element must be specified unless the Convert annotation is on an attribute of basic type or on an element collection of basic type.
      Class converter
      Specifies the converter to be applied.
      boolean disableConversion
      Used to disable an auto-apply or inherited converter.

    • Element Detail

      • converter

        public abstract Class converter
        Specifies the converter to be applied. A value for this element must be specified if multiple converters would otherwise apply.
        Default:
        void.class

      • attributeName

        public abstract String attributeName
        The attributeName element must be specified unless the Convert annotation is on an attribute of basic type or on an element collection of basic type. In these cases, the attributeName element must not be specified.
        Default:
        ""

      • disableConversion

        public abstract boolean disableConversion
        Used to disable an auto-apply or inherited converter. If disableConversion is true, the converter element should not be specified.
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Converter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Converter

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Converter
    Specifies that the annotated class is a converter and defines its scope. A converter class must be annotated with the Converter annotation or defined in the object/relational mapping descriptor as a converter.

    If the autoApply element is specified as true, the persistence provider must automatically apply the converter to all mapped attributes of the specified target type for all entities in the persistence unit except for attributes for which conversion is overridden by means of the Convert annotation (or XML equivalent).

    In determining whether a converter is applicable to an attribute, the provider must treat primitive types and wrapper types as equivalent.

    Note that Id attributes, version attributes, relationship attributes, and attributes explicitly annotated as Enumerated or Temporal (or designated as such via XML) will not be converted.

    Note that if autoApply is true, the Convert annotation may be used to override or disable auto-apply conversion on a per-attribute basis.

    If autoApply is false, only those attributes of the target type for which the Convert annotation (or corresponding XML element) has been specified will be converted.

    If there is more than one converter defined for the same target type, the Convert annotation should be used to explicitly specify which converter to use.

    Since:
    Java Persistence 2.1
    See Also:
    AttributeConverter, Convert

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      boolean | autoApply

    • Element Detail

      • autoApply

        public abstract boolean autoApply
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Converts (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Converts

  • @Target(value={METHOD,FIELD,TYPE})
@Retention(value=RUNTIME)
public @interface Converts
    Used to group Convert annotations. Multiple converters must not be applied to the same basic attribute.
    Since:
    Java Persistence 2.1
    See Also:
    Convert

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Convert[] value
      The Convert mappings that are to be applied.

    • Element Detail

      • value

        public abstract Convert[] value
        The Convert mappings that are to be applied.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DiscriminatorColumn (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type DiscriminatorColumn

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface DiscriminatorColumn
    Specifies the discriminator column for the SINGLE_TABLE and JOINED Inheritance mapping strategies.

    The strategy and the discriminator column are only specified in the root of an entity class hierarchy or subhierarchy in which a different inheritance strategy is applied

    If the DiscriminatorColumn annotation is missing, and a discriminator column is required, the name of the discriminator column defaults to "DTYPE" and the discriminator type to DiscriminatorType.STRING.

         Example:

     @Entity
     @Table(name="CUST")
     @Inheritance(strategy=SINGLE_TABLE)
     @DiscriminatorColumn(name="DISC", discriminatorType=STRING, length=20)
     public class Customer { ... }

     @Entity
     public class ValuedCustomer extends Customer { ... }
    Since:
    Java Persistence 1.0
    See Also:
    DiscriminatorValue

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String columnDefinition
      (Optional) The SQL fragment that is used when generating the DDL for the discriminator column.
      DiscriminatorType discriminatorType
      (Optional) The type of object/column to use as a class discriminator.
      int length
      (Optional) The column length for String-based discriminator types.
      String name
      (Optional) The name of column to be used for the discriminator.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of column to be used for the discriminator.
        Default:
        "DTYPE"

      • discriminatorType

        public abstract DiscriminatorType discriminatorType
        (Optional) The type of object/column to use as a class discriminator. Defaults to DiscriminatorType.STRING.
        Default:
        javax.persistence.DiscriminatorType.STRING

      • columnDefinition

        public abstract String columnDefinition
        (Optional) The SQL fragment that is used when generating the DDL for the discriminator column.

        Defaults to the provider-generated SQL to create a column of the specified discriminator type.

        Default:
        ""

      • length

        public abstract int length
        (Optional) The column length for String-based discriminator types. Ignored for other discriminator types.
        Default:
        31
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DiscriminatorType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum DiscriminatorType

  • java.lang.Object
    • java.lang.Enum<DiscriminatorType>
      • javax.persistence.DiscriminatorType
  • All Implemented Interfaces:
    Serializable, Comparable<DiscriminatorType>

    public enum DiscriminatorType
extends Enum<DiscriminatorType>
    Defines supported types of the discriminator column.
    Since:
    Java Persistence 1.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      CHAR
      Single character as the discriminator type.
      INTEGER
      Integer as the discriminator type.
      STRING
      String as the discriminator type.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static DiscriminatorType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static DiscriminatorType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • STRING

        public static final DiscriminatorType STRING
        String as the discriminator type.

      • CHAR

        public static final DiscriminatorType CHAR
        Single character as the discriminator type.

      • INTEGER

        public static final DiscriminatorType INTEGER
        Integer as the discriminator type.

    • Method Detail

      • values

        public static DiscriminatorType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (DiscriminatorType c : DiscriminatorType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static DiscriminatorType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


DiscriminatorValue (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type DiscriminatorValue

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface DiscriminatorValue
    Specifies the value of the discriminator column for entities of the given type.

    The DiscriminatorValue annotation can only be specified on a concrete entity class.

    If the DiscriminatorValue annotation is not specified and a discriminator column is used, a provider-specific function will be used to generate a value representing the entity type. If the DiscriminatorType is STRING, the discriminator value default is the entity name.

    The inheritance strategy and the discriminator column are only specified in the root of an entity class hierarchy or subhierarchy in which a different inheritance strategy is applied. The discriminator value, if not defaulted, should be specified for each entity class in the hierarchy.

    Example:

    @Entity
    @Table(name="CUST")
    @Inheritance(strategy=SINGLE_TABLE)
    @DiscriminatorColumn(name="DISC", discriminatorType=STRING, length=20)
    @DiscriminatorValue("CUSTOMER")
    public class Customer { ... }

    @Entity
    @DiscriminatorValue("VCUSTOMER")
    public class ValuedCustomer extends Customer { ... }
    Since:
    Java Persistence 1.0
    See Also:
    DiscriminatorColumn

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      (Optional) The value that indicates that the row is an entity of the annotated entity type.

    • Element Detail

      • value

        public abstract String value
        (Optional) The value that indicates that the row is an entity of the annotated entity type.

        If the DiscriminatorValue annotation is not specified and a discriminator column is used, a provider-specific function will be used to generate a value representing the entity type. If the DiscriminatorType is STRING, the discriminator value default is the entity name.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ElementCollection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type ElementCollection

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface ElementCollection
    Specifies a collection of instances of a basic type or embeddable class. Must be specified if the collection is to be mapped by means of a collection table.
        Example:

    @Entity public class Person {
       @Id protected String ssn;
       protected String name;
       ...
       @ElementCollection
       protected Set<String> nickNames = new HashSet();
         ...
    }
    Since:
    Java Persistence 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      FetchType fetch
      (Optional) Whether the collection should be lazily loaded or must be eagerly fetched.
      Class targetClass
      (Optional) The basic or embeddable class that is the element type of the collection.

    • Element Detail

      • targetClass

        public abstract Class targetClass
        (Optional) The basic or embeddable class that is the element type of the collection. This element is optional only if the collection field or property is defined using Java generics, and must be specified otherwise. It defaults to the paramterized type of the collection when defined using generics.
        Default:
        void.class

      • fetch

        public abstract FetchType fetch
        (Optional) Whether the collection should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistence provider runtime that the collection elements must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime.
        Default:
        javax.persistence.FetchType.LAZY
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Embeddable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Embeddable

  • @Documented
@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Embeddable
    Specifies a class whose instances are stored as an intrinsic part of an owning entity and share the identity of the entity. Each of the persistent properties or fields of the embedded object is mapped to the database table for the entity.

    Note that the Transient annotation may be used to designate the non-persistent state of an embeddable class.

    Example 1:

    @Embeddable public class EmploymentPeriod {
       @Temporal(DATE) java.util.Date startDate;
       @Temporal(DATE) java.util.Date endDate;
      ...
    }

    Example 2:

    @Embeddable public class PhoneNumber {
        protected String areaCode;
        protected String localNumber;
        @ManyToOne PhoneServiceProvider provider;
        ...
     }

    @Entity public class PhoneServiceProvider {
        @Id protected String name;
         ...
     }

    Example 3:

    @Embeddable public class Address {
       protected String street;
       protected String city;
       protected String state;
       @Embedded protected Zipcode zipcode;
    }

    @Embeddable public class Zipcode {
       protected String zip;
       protected String plusFour;
     }
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Embedded (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Embedded

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Embedded
    Specifies a persistent field or property of an entity whose value is an instance of an embeddable class. The embeddable class must be annotated as Embeddable.

    The AttributeOverride, AttributeOverrides, AssociationOverride, and AssociationOverrides annotations may be used to override mappings declared or defaulted by the embeddable class.

       Example:

   @Embedded
   @AttributeOverrides({
       @AttributeOverride(name="startDate", column=@Column("EMP_START")),
       @AttributeOverride(name="endDate", column=@Column("EMP_END"))
   })
   public EmploymentPeriod getEmploymentPeriod() { ... }
    Since:
    Java Persistence 1.0
    See Also:
    Embeddable, AttributeOverride, AttributeOverrides, AssociationOverride, AssociationOverrides
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


EmbeddedId (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type EmbeddedId

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface EmbeddedId
    Applied to a persistent field or property of an entity class or mapped superclass to denote a composite primary key that is an embeddable class. The embeddable class must be annotated as Embeddable.

    There must be only one EmbeddedId annotation and no Id annotation when the EmbeddedId annotation is used.

    The AttributeOverride annotation may be used to override the column mappings declared within the embeddable class.

    The MapsId annotation may be used in conjunction with the EmbeddedId annotation to specify a derived primary key.

    If the entity has a derived primary key, the AttributeOverride annotation may only be used to override those attributes of the embedded id that do not correspond to the relationship to the parent entity.

    Relationship mappings defined within an embedded id class are not supported.

        Example 1:

    @EmbeddedId
    protected EmployeePK empPK;

    Example 2:

    @Embeddable
    public class DependentId {
       String name;
       EmployeeId empPK;   // corresponds to primary key type of Employee
    }

    @Entity
    public class Dependent {
       // default column name for "name" attribute is overridden
       @AttributeOverride(name="name", @Column(name="dep_name"))
       @EmbeddedId DependentId id;
       ...
       @MapsId("empPK")
       @ManyToOne Employee emp;
    }
    Since:
    Java Persistence 1.0
    See Also:
    Embeddable, MapsId
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Entity (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Entity

  • @Documented
@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Entity
    Specifies that the class is an entity. This annotation is applied to the entity class.
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      (Optional) The entity name.

    • Element Detail

      • name

        public abstract String name
        (Optional) The entity name. Defaults to the unqualified name of the entity class. This name is used to refer to the entity in queries. The name must not be a reserved literal in the Java Persistence query language.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


EntityExistsException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class EntityExistsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.EntityExistsException
  • All Implemented Interfaces:
    Serializable

    public class EntityExistsException
extends PersistenceException
    Thrown by the persistence provider when EntityManager.persist(Object) is called and the entity already exists. The current transaction, if one is active, will be marked for rollback.

    If the entity already exists, the EntityExistsException may be thrown when the persist operation is invoked, or the EntityExistsException or another PersistenceException may be thrown at flush or commit time.

    The current transaction, if one is active and the persistence context has been joined to it, will be marked for rollback.

    Since:
    Java Persistence 1.0
    See Also:
    EntityManager.persist(Object), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EntityExistsException()
      Constructs a new EntityExistsException exception with null as its detail message.
      EntityExistsException(String message)
      Constructs a new EntityExistsException exception with the specified detail message.
      EntityExistsException(String message, Throwable cause)
      Constructs a new EntityExistsException exception with the specified detail message and cause.
      EntityExistsException(Throwable cause)
      Constructs a new EntityExistsException exception with the specified cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EntityExistsException

        public EntityExistsException()
        Constructs a new EntityExistsException exception with null as its detail message.

      • EntityExistsException

        public EntityExistsException(String message)
        Constructs a new EntityExistsException exception with the specified detail message.
        Parameters:
        message - the detail message.

      • EntityExistsException

        public EntityExistsException(String message,
                     Throwable cause)
        Constructs a new EntityExistsException exception with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - the cause.

      • EntityExistsException

        public EntityExistsException(Throwable cause)
        Constructs a new EntityExistsException exception with the specified cause.
        Parameters:
        cause - the cause.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityGraph (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface EntityGraph<T>

  • Type Parameters:
    T - The type of the root entity.

    public interface EntityGraph<T>
    This type represents the root of an entity graph that will be used as a template to define the attribute nodes and boundaries of a graph of entities and entity relationships. The root must be an entity type.

    The methods to add subgraphs implicitly create the corresponding attribute nodes as well; such attribute nodes should not be redundantly specified.

    Since:
    Java Persistence 2.1
    See Also:
    AttributeNode, Subgraph, NamedEntityGraph

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addAttributeNodes(Attribute<T,?>... attribute)
      Add one or more attribute nodes to the entity graph.
      void addAttributeNodes(String... attributeName)
      Add one or more attribute nodes to the entity graph.
      <X> Subgraph<X> addKeySubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a map key that is a managed type.
      <X> Subgraph<? extends X> addKeySubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a map key that is a managed type with inheritance.
      <X> Subgraph<X> addKeySubgraph(String attributeName)
      Add a node to the graph that corresponds to a map key that is a managed type.
      <X> Subgraph<X> addKeySubgraph(String attributeName, Class<X> type)
      Add a node to the graph that corresponds to a map key that is a managed type with inheritance.
      <T> Subgraph<? extends T> addSubclassSubgraph(Class<? extends T> type)
      Add additional attributes to this entity graph that correspond to attributes of subclasses of this EntityGraph's entity type.
      <X> Subgraph<X> addSubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a managed type.
      <X> Subgraph<? extends X> addSubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a managed type with inheritance.
      <X> Subgraph<X> addSubgraph(String attributeName)
      Add a node to the graph that corresponds to a managed type.
      <X> Subgraph<X> addSubgraph(String attributeName, Class<X> type)
      Add a node to the graph that corresponds to a managed type with inheritance.
      List<AttributeNode<?>> getAttributeNodes()
      Return the attribute nodes of this entity that are included in the entity graph.
      String getName()
      Return the name of a named EntityGraph (an entity graph defined by means of the NamedEntityGraph annotation, XML descriptor element, or added by means of the addNamedEntityGraph method.

    • Method Detail

      • getName

        String getName()
        Return the name of a named EntityGraph (an entity graph defined by means of the NamedEntityGraph annotation, XML descriptor element, or added by means of the addNamedEntityGraph method. Returns null if the EntityGraph is not a named EntityGraph.

      • addAttributeNodes

        void addAttributeNodes(String... attributeName)
        Add one or more attribute nodes to the entity graph.
        Parameters:
        attributeName - name of the attribute
        Throws:
        IllegalArgumentException - if the attribute is not an attribute of this entity.
        IllegalStateException - if the EntityGraph has been statically defined

      • addAttributeNodes

        void addAttributeNodes(Attribute<T,?>... attribute)
        Add one or more attribute nodes to the entity graph.
        Parameters:
        attribute - attribute
        Throws:
        IllegalStateException - if the EntityGraph has been statically defined

      • addSubgraph

        <X> Subgraph<X> addSubgraph(Attribute<T,X> attribute)
        Add a node to the graph that corresponds to a managed type. This allows for construction of multi-node entity graphs that include related managed types.
        Parameters:
        attribute - attribute
        Returns:
        subgraph for the attribute
        Throws:
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if the EntityGraph has been statically defined

      • addSubgraph

        <X> Subgraph<? extends X> addSubgraph(Attribute<T,X> attribute,
                                    Class<? extends X> type)
        Add a node to the graph that corresponds to a managed type with inheritance. This allows for multiple subclass subgraphs to be defined for this node of the entity graph. Subclass subgraphs will automatically include the specified attributes of superclass subgraphs.
        Parameters:
        attribute - attribute
        type - entity subclass
        Returns:
        subgraph for the attribute
        Throws:
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if the EntityGraph has been statically defined

      • addSubgraph

        <X> Subgraph<X> addSubgraph(String attributeName)
        Add a node to the graph that corresponds to a managed type. This allows for construction of multi-node entity graphs that include related managed types.
        Parameters:
        attributeName - name of the attribute
        Returns:
        subgraph for the attribute
        Throws:
        IllegalArgumentException - if the attribute is not an attribute of this entity.
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if the EntityGraph has been statically defined

      • addSubgraph

        <X> Subgraph<X> addSubgraph(String attributeName,
                          Class<X> type)
        Add a node to the graph that corresponds to a managed type with inheritance. This allows for multiple subclass subgraphs to be defined for this node of the entity graph. Subclass subgraphs will automatically include the specified attributes of superclass subgraphs.
        Parameters:
        attributeName - name of the attribute
        type - entity subclass
        Returns:
        subgraph for the attribute
        Throws:
        IllegalArgumentException - if the attribute is not an attribute of this managed type.
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if this EntityGraph has been statically defined

      • addKeySubgraph

        <X> Subgraph<X> addKeySubgraph(Attribute<T,X> attribute)
        Add a node to the graph that corresponds to a map key that is a managed type. This allows for construction of multi-node entity graphs that include related managed types.
        Parameters:
        attribute - attribute
        Returns:
        subgraph for the key attribute
        Throws:
        IllegalArgumentException - if the attribute's target type is not an entity
        IllegalStateException - if this EntityGraph has been statically defined

      • addKeySubgraph

        <X> Subgraph<? extends X> addKeySubgraph(Attribute<T,X> attribute,
                                       Class<? extends X> type)
        Add a node to the graph that corresponds to a map key that is a managed type with inheritance. This allows for construction of multi-node entity graphs that include related managed types. Subclass subgraphs will include the specified attributes of superclass subgraphs.
        Parameters:
        attribute - attribute
        type - entity subclass
        Returns:
        subgraph for the key attribute
        Throws:
        IllegalArgumentException - if the attribute's target type is not an entity
        IllegalStateException - if this EntityGraph has been statically defined

      • addKeySubgraph

        <X> Subgraph<X> addKeySubgraph(String attributeName)
        Add a node to the graph that corresponds to a map key that is a managed type. This allows for construction of multi-node entity graphs that include related managed types.
        Parameters:
        attributeName - name of the attribute
        Returns:
        subgraph for the key attribute
        Throws:
        IllegalArgumentException - if the attribute is not an attribute of this entity.
        IllegalArgumentException - if the attribute's target type is not an entity
        IllegalStateException - if this EntityGraph has been statically defined

      • addKeySubgraph

        <X> Subgraph<X> addKeySubgraph(String attributeName,
                             Class<X> type)
        Add a node to the graph that corresponds to a map key that is a managed type with inheritance. This allows for construction of multi-node entity graphs that include related managed types. Subclass subgraphs will automatically include the specified attributes of superclass subgraphs
        Parameters:
        attributeName - name of the attribute
        type - entity subclass
        Returns:
        subgraph for the key attribute
        Throws:
        IllegalArgumentException - if the attribute is not an attribute of this entity.
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if this EntityGraph has been statically defined

      • addSubclassSubgraph

        <T> Subgraph<? extends T> addSubclassSubgraph(Class<? extends T> type)
        Add additional attributes to this entity graph that correspond to attributes of subclasses of this EntityGraph's entity type. Subclass subgraphs will automatically include the specified attributes of superclass subgraphs.
        Parameters:
        type - entity subclass
        Returns:
        subgraph for the subclass
        Throws:
        IllegalArgumentException - if the type is not an entity type
        IllegalStateException - if the EntityGraph has been statically defined

      • getAttributeNodes

        List<AttributeNode<?>> getAttributeNodes()
        Return the attribute nodes of this entity that are included in the entity graph.
        Returns:
        attribute nodes for the annotated entity type or empty list if none have been defined
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityListeners (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type EntityListeners

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface EntityListeners
    Specifies the callback listener classes to be used for an entity or mapped superclass. This annotation may be applied to an entity class or mapped superclass.
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class[] value
      The callback listener classes

    • Element Detail

      • value

        public abstract Class[] value
        The callback listener classes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


EntityManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface EntityManager

  • public interface EntityManager
    Interface used to interact with the persistence context.

    An EntityManager instance is associated with a persistence context. A persistence context is a set of entity instances in which for any persistent entity identity there is a unique entity instance. Within the persistence context, the entity instances and their lifecycle are managed. The EntityManager API is used to create and remove persistent entity instances, to find entities by their primary key, and to query over entities.

    The set of entities that can be managed by a given EntityManager instance is defined by a persistence unit. A persistence unit defines the set of all classes that are related or grouped by the application, and which must be colocated in their mapping to a single database.

    Since:
    Java Persistence 1.0
    See Also:
    Query, TypedQuery, CriteriaQuery, PersistenceContext, StoredProcedureQuery

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clear()
      Clear the persistence context, causing all managed entities to become detached.
      void close()
      Close an application-managed entity manager.
      boolean contains(Object entity)
      Check if the instance is a managed entity instance belonging to the current persistence context.
      <T> EntityGraph<T> createEntityGraph(Class<T> rootType)
      Return a mutable EntityGraph that can be used to dynamically create an EntityGraph.
      EntityGraph<?> createEntityGraph(String graphName)
      Return a mutable copy of the named EntityGraph.
      Query createNamedQuery(String name)
      Create an instance of Query for executing a named query (in the Java Persistence query language or in native SQL).
      <T> TypedQuery<T> createNamedQuery(String name, Class<T> resultClass)
      Create an instance of TypedQuery for executing a Java Persistence query language named query.
      StoredProcedureQuery createNamedStoredProcedureQuery(String name)
      Create an instance of StoredProcedureQuery for executing a stored procedure in the database.
      Query createNativeQuery(String sqlString)
      Create an instance of Query for executing a native SQL statement, e.g., for update or delete.
      Query createNativeQuery(String sqlString, Class resultClass)
      Create an instance of Query for executing a native SQL query.
      Query createNativeQuery(String sqlString, String resultSetMapping)
      Create an instance of Query for executing a native SQL query.
      Query createQuery(CriteriaDelete deleteQuery)
      Create an instance of Query for executing a criteria delete query.
      <T> TypedQuery<T> createQuery(CriteriaQuery<T> criteriaQuery)
      Create an instance of TypedQuery for executing a criteria query.
      Query createQuery(CriteriaUpdate updateQuery)
      Create an instance of Query for executing a criteria update query.
      Query createQuery(String qlString)
      Create an instance of Query for executing a Java Persistence query language statement.
      <T> TypedQuery<T> createQuery(String qlString, Class<T> resultClass)
      Create an instance of TypedQuery for executing a Java Persistence query language statement.
      StoredProcedureQuery createStoredProcedureQuery(String procedureName)
      Create an instance of StoredProcedureQuery for executing a stored procedure in the database.
      StoredProcedureQuery createStoredProcedureQuery(String procedureName, Class... resultClasses)
      Create an instance of StoredProcedureQuery for executing a stored procedure in the database.
      StoredProcedureQuery createStoredProcedureQuery(String procedureName, String... resultSetMappings)
      Create an instance of StoredProcedureQuery for executing a stored procedure in the database.
      void detach(Object entity)
      Remove the given entity from the persistence context, causing a managed entity to become detached.
      <T> T find(Class<T> entityClass, Object primaryKey)
      Find by primary key.
      <T> T find(Class<T> entityClass, Object primaryKey, LockModeType lockMode)
      Find by primary key and lock.
      <T> T find(Class<T> entityClass, Object primaryKey, LockModeType lockMode, Map<String,Object> properties)
      Find by primary key and lock, using the specified properties.
      <T> T find(Class<T> entityClass, Object primaryKey, Map<String,Object> properties)
      Find by primary key, using the specified properties.
      void flush()
      Synchronize the persistence context to the underlying database.
      CriteriaBuilder getCriteriaBuilder()
      Return an instance of CriteriaBuilder for the creation of CriteriaQuery objects.
      Object getDelegate()
      Return the underlying provider object for the EntityManager, if available.
      EntityGraph<?> getEntityGraph(String graphName)
      Return a named EntityGraph.
      <T> List<EntityGraph<? super T>> getEntityGraphs(Class<T> entityClass)
      Return all named EntityGraphs that have been defined for the provided class type.
      EntityManagerFactory getEntityManagerFactory()
      Return the entity manager factory for the entity manager.
      FlushModeType getFlushMode()
      Get the flush mode that applies to all objects contained in the persistence context.
      LockModeType getLockMode(Object entity)
      Get the current lock mode for the entity instance.
      Metamodel getMetamodel()
      Return an instance of Metamodel interface for access to the metamodel of the persistence unit.
      Map<String,Object> getProperties()
      Get the properties and hints and associated values that are in effect for the entity manager.
      <T> T getReference(Class<T> entityClass, Object primaryKey)
      Get an instance, whose state may be lazily fetched.
      EntityTransaction getTransaction()
      Return the resource-level EntityTransaction object.
      boolean isJoinedToTransaction()
      Determine whether the entity manager is joined to the current transaction.
      boolean isOpen()
      Determine whether the entity manager is open.
      void joinTransaction()
      Indicate to the entity manager that a JTA transaction is active and join the persistence context to it.
      void lock(Object entity, LockModeType lockMode)
      Lock an entity instance that is contained in the persistence context with the specified lock mode type.
      void lock(Object entity, LockModeType lockMode, Map<String,Object> properties)
      Lock an entity instance that is contained in the persistence context with the specified lock mode type and with specified properties.
      <T> T merge(T entity)
      Merge the state of the given entity into the current persistence context.
      void persist(Object entity)
      Make an instance managed and persistent.
      void refresh(Object entity)
      Refresh the state of the instance from the database, overwriting changes made to the entity, if any.
      void refresh(Object entity, LockModeType lockMode)
      Refresh the state of the instance from the database, overwriting changes made to the entity, if any, and lock it with respect to given lock mode type.
      void refresh(Object entity, LockModeType lockMode, Map<String,Object> properties)
      Refresh the state of the instance from the database, overwriting changes made to the entity, if any, and lock it with respect to given lock mode type and with specified properties.
      void refresh(Object entity, Map<String,Object> properties)
      Refresh the state of the instance from the database, using the specified properties, and overwriting changes made to the entity, if any.
      void remove(Object entity)
      Remove the entity instance.
      void setFlushMode(FlushModeType flushMode)
      Set the flush mode that applies to all objects contained in the persistence context.
      void setProperty(String propertyName, Object value)
      Set an entity manager property or hint.
      <T> T unwrap(Class<T> cls)
      Return an object of the specified type to allow access to the provider-specific API.

    • Method Detail

      • persist

        void persist(Object entity)
        Make an instance managed and persistent.
        Parameters:
        entity - entity instance
        Throws:
        EntityExistsException - if the entity already exists. (If the entity already exists, the EntityExistsException may be thrown when the persist operation is invoked, or the EntityExistsException or another PersistenceException may be thrown at flush or commit time.)
        IllegalArgumentException - if the instance is not an entity
        TransactionRequiredException - if there is no transaction when invoked on a container-managed entity manager of that is of type PersistenceContextType.TRANSACTION

      • merge

        <T> T merge(T entity)
        Merge the state of the given entity into the current persistence context.
        Parameters:
        entity - entity instance
        Returns:
        the managed instance that the state was merged to
        Throws:
        IllegalArgumentException - if instance is not an entity or is a removed entity
        TransactionRequiredException - if there is no transaction when invoked on a container-managed entity manager of that is of type PersistenceContextType.TRANSACTION

      • remove

        void remove(Object entity)
        Remove the entity instance.
        Parameters:
        entity - entity instance
        Throws:
        IllegalArgumentException - if the instance is not an entity or is a detached entity
        TransactionRequiredException - if invoked on a container-managed entity manager of type PersistenceContextType.TRANSACTION and there is no transaction

      • find

        <T> T find(Class<T> entityClass,
         Object primaryKey)
        Find by primary key. Search for an entity of the specified class and primary key. If the entity instance is contained in the persistence context, it is returned from there.
        Parameters:
        entityClass - entity class
        primaryKey - primary key
        Returns:
        the found entity instance or null if the entity does not exist
        Throws:
        IllegalArgumentException - if the first argument does not denote an entity type or the second argument is is not a valid type for that entity's primary key or is null

      • find

        <T> T find(Class<T> entityClass,
         Object primaryKey,
         Map<String,Object> properties)
        Find by primary key, using the specified properties. Search for an entity of the specified class and primary key. If the entity instance is contained in the persistence context, it is returned from there. If a vendor-specific property or hint is not recognized, it is silently ignored.
        Parameters:
        entityClass - entity class
        primaryKey - primary key
        properties - standard and vendor-specific properties and hints
        Returns:
        the found entity instance or null if the entity does not exist
        Throws:
        IllegalArgumentException - if the first argument does not denote an entity type or the second argument is is not a valid type for that entity's primary key or is null
        Since:
        Java Persistence 2.0

      • find

        <T> T find(Class<T> entityClass,
         Object primaryKey,
         LockModeType lockMode)
        Find by primary key and lock. Search for an entity of the specified class and primary key and lock it with respect to the specified lock type. If the entity instance is contained in the persistence context, it is returned from there, and the effect of this method is the same as if the lock method had been called on the entity.

        If the entity is found within the persistence context and the lock mode type is pessimistic and the entity has a version attribute, the persistence provider must perform optimistic version checks when obtaining the database lock. If these checks fail, the OptimisticLockException will be thrown.

        If the lock mode type is pessimistic and the entity instance is found but cannot be locked:

        • the PessimisticLockException will be thrown if the database locking failure causes transaction-level rollback
        • the LockTimeoutException will be thrown if the database locking failure causes only statement-level rollback
        Parameters:
        entityClass - entity class
        primaryKey - primary key
        lockMode - lock mode
        Returns:
        the found entity instance or null if the entity does not exist
        Throws:
        IllegalArgumentException - if the first argument does not denote an entity type or the second argument is not a valid type for that entity's primary key or is null
        TransactionRequiredException - if there is no transaction and a lock mode other than NONE is specified or if invoked on an entity manager which has not been joined to the current transaction and a lock mode other than NONE is specified
        OptimisticLockException - if the optimistic version check fails
        PessimisticLockException - if pessimistic locking fails and the transaction is rolled back
        LockTimeoutException - if pessimistic locking fails and only the statement is rolled back
        PersistenceException - if an unsupported lock call is made
        Since:
        Java Persistence 2.0

      • find

        <T> T find(Class<T> entityClass,
         Object primaryKey,
         LockModeType lockMode,
         Map<String,Object> properties)
        Find by primary key and lock, using the specified properties. Search for an entity of the specified class and primary key and lock it with respect to the specified lock type. If the entity instance is contained in the persistence context, it is returned from there.

        If the entity is found within the persistence context and the lock mode type is pessimistic and the entity has a version attribute, the persistence provider must perform optimistic version checks when obtaining the database lock. If these checks fail, the OptimisticLockException will be thrown.

        If the lock mode type is pessimistic and the entity instance is found but cannot be locked:

        • the PessimisticLockException will be thrown if the database locking failure causes transaction-level rollback
        • the LockTimeoutException will be thrown if the database locking failure causes only statement-level rollback

        If a vendor-specific property or hint is not recognized, it is silently ignored.

        Portable applications should not rely on the standard timeout hint. Depending on the database in use and the locking mechanisms used by the provider, the hint may or may not be observed.

        Parameters:
        entityClass - entity class
        primaryKey - primary key
        lockMode - lock mode
        properties - standard and vendor-specific properties and hints
        Returns:
        the found entity instance or null if the entity does not exist
        Throws:
        IllegalArgumentException - if the first argument does not denote an entity type or the second argument is not a valid type for that entity's primary key or is null
        TransactionRequiredException - if there is no transaction and a lock mode other than NONE is specified or if invoked on an entity manager which has not been joined to the current transaction and a lock mode other than NONE is specified
        OptimisticLockException - if the optimistic version check fails
        PessimisticLockException - if pessimistic locking fails and the transaction is rolled back
        LockTimeoutException - if pessimistic locking fails and only the statement is rolled back
        PersistenceException - if an unsupported lock call is made
        Since:
        Java Persistence 2.0

      • getReference

        <T> T getReference(Class<T> entityClass,
                 Object primaryKey)
        Get an instance, whose state may be lazily fetched. If the requested instance does not exist in the database, the EntityNotFoundException is thrown when the instance state is first accessed. (The persistence provider runtime is permitted to throw the EntityNotFoundException when getReference is called.) The application should not expect that the instance state will be available upon detachment, unless it was accessed by the application while the entity manager was open.
        Parameters:
        entityClass - entity class
        primaryKey - primary key
        Returns:
        the found entity instance
        Throws:
        IllegalArgumentException - if the first argument does not denote an entity type or the second argument is not a valid type for that entity's primary key or is null
        EntityNotFoundException - if the entity state cannot be accessed

      • flush

        void flush()
        Synchronize the persistence context to the underlying database.
        Throws:
        TransactionRequiredException - if there is no transaction or if the entity manager has not been joined to the current transaction
        PersistenceException - if the flush fails

      • setFlushMode

        void setFlushMode(FlushModeType flushMode)
        Set the flush mode that applies to all objects contained in the persistence context.
        Parameters:
        flushMode - flush mode

      • getFlushMode

        FlushModeType getFlushMode()
        Get the flush mode that applies to all objects contained in the persistence context.
        Returns:
        flushMode

      • lock

        void lock(Object entity,
        LockModeType lockMode)
        Lock an entity instance that is contained in the persistence context with the specified lock mode type.

        If a pessimistic lock mode type is specified and the entity contains a version attribute, the persistence provider must also perform optimistic version checks when obtaining the database lock. If these checks fail, the OptimisticLockException will be thrown.

        If the lock mode type is pessimistic and the entity instance is found but cannot be locked:

        • the PessimisticLockException will be thrown if the database locking failure causes transaction-level rollback
        • the LockTimeoutException will be thrown if the database locking failure causes only statement-level rollback
        Parameters:
        entity - entity instance
        lockMode - lock mode
        Throws:
        IllegalArgumentException - if the instance is not an entity or is a detached entity
        TransactionRequiredException - if there is no transaction or if invoked on an entity manager which has not been joined to the current transaction
        EntityNotFoundException - if the entity does not exist in the database when pessimistic locking is performed
        OptimisticLockException - if the optimistic version check fails
        PessimisticLockException - if pessimistic locking fails and the transaction is rolled back
        LockTimeoutException - if pessimistic locking fails and only the statement is rolled back
        PersistenceException - if an unsupported lock call is made

      • lock

        void lock(Object entity,
        LockModeType lockMode,
        Map<String,Object> properties)
        Lock an entity instance that is contained in the persistence context with the specified lock mode type and with specified properties.

        If a pessimistic lock mode type is specified and the entity contains a version attribute, the persistence provider must also perform optimistic version checks when obtaining the database lock. If these checks fail, the OptimisticLockException will be thrown.

        If the lock mode type is pessimistic and the entity instance is found but cannot be locked:

        • the PessimisticLockException will be thrown if the database locking failure causes transaction-level rollback
        • the LockTimeoutException will be thrown if the database locking failure causes only statement-level rollback

        If a vendor-specific property or hint is not recognized, it is silently ignored.

        Portable applications should not rely on the standard timeout hint. Depending on the database in use and the locking mechanisms used by the provider, the hint may or may not be observed.

        Parameters:
        entity - entity instance
        lockMode - lock mode
        properties - standard and vendor-specific properties and hints
        Throws:
        IllegalArgumentException - if the instance is not an entity or is a detached entity
        TransactionRequiredException - if there is no transaction or if invoked on an entity manager which has not been joined to the current transaction
        EntityNotFoundException - if the entity does not exist in the database when pessimistic locking is performed
        OptimisticLockException - if the optimistic version check fails
        PessimisticLockException - if pessimistic locking fails and the transaction is rolled back
        LockTimeoutException - if pessimistic locking fails and only the statement is rolled back
        PersistenceException - if an unsupported lock call is made
        Since:
        Java Persistence 2.0

      • refresh

        void refresh(Object entity)
        Refresh the state of the instance from the database, overwriting changes made to the entity, if any.
        Parameters:
        entity - entity instance
        Throws:
        IllegalArgumentException - if the instance is not an entity or the entity is not managed
        TransactionRequiredException - if there is no transaction when invoked on a container-managed entity manager of type PersistenceContextType.TRANSACTION
        EntityNotFoundException - if the entity no longer exists in the database

      • refresh

        void refresh(Object entity,
           Map<String,Object> properties)
        Refresh the state of the instance from the database, using the specified properties, and overwriting changes made to the entity, if any.

        If a vendor-specific property or hint is not recognized, it is silently ignored.

        Parameters:
        entity - entity instance
        properties - standard and vendor-specific properties and hints
        Throws:
        IllegalArgumentException - if the instance is not an entity or the entity is not managed
        TransactionRequiredException - if there is no transaction when invoked on a container-managed entity manager of type PersistenceContextType.TRANSACTION
        EntityNotFoundException - if the entity no longer exists in the database
        Since:
        Java Persistence 2.0

      • refresh

        void refresh(Object entity,
           LockModeType lockMode)
        Refresh the state of the instance from the database, overwriting changes made to the entity, if any, and lock it with respect to given lock mode type.

        If the lock mode type is pessimistic and the entity instance is found but cannot be locked:

        • the PessimisticLockException will be thrown if the database locking failure causes transaction-level rollback
        • the LockTimeoutException will be thrown if the database locking failure causes only statement-level rollback.
        Parameters:
        entity - entity instance
        lockMode - lock mode
        Throws:
        IllegalArgumentException - if the instance is not an entity or the entity is not managed
        TransactionRequiredException - if invoked on a container-managed entity manager of type PersistenceContextType.TRANSACTION when there is no transaction; if invoked on an extended entity manager when there is no transaction and a lock mode other than NONE has been specified; or if invoked on an extended entity manager that has not been joined to the current transaction and a lock mode other than NONE has been specified
        EntityNotFoundException - if the entity no longer exists in the database
        PessimisticLockException - if pessimistic locking fails and the transaction is rolled back
        LockTimeoutException - if pessimistic locking fails and only the statement is rolled back
        PersistenceException - if an unsupported lock call is made
        Since:
        Java Persistence 2.0

      • refresh

        void refresh(Object entity,
           LockModeType lockMode,
           Map<String,Object> properties)
        Refresh the state of the instance from the database, overwriting changes made to the entity, if any, and lock it with respect to given lock mode type and with specified properties.

        If the lock mode type is pessimistic and the entity instance is found but cannot be locked:

        • the PessimisticLockException will be thrown if the database locking failure causes transaction-level rollback
        • the LockTimeoutException will be thrown if the database locking failure causes only statement-level rollback

        If a vendor-specific property or hint is not recognized, it is silently ignored.

        Portable applications should not rely on the standard timeout hint. Depending on the database in use and the locking mechanisms used by the provider, the hint may or may not be observed.

        Parameters:
        entity - entity instance
        lockMode - lock mode
        properties - standard and vendor-specific properties and hints
        Throws:
        IllegalArgumentException - if the instance is not an entity or the entity is not managed
        TransactionRequiredException - if invoked on a container-managed entity manager of type PersistenceContextType.TRANSACTION when there is no transaction; if invoked on an extended entity manager when there is no transaction and a lock mode other than NONE has been specified; or if invoked on an extended entity manager that has not been joined to the current transaction and a lock mode other than NONE has been specified
        EntityNotFoundException - if the entity no longer exists in the database
        PessimisticLockException - if pessimistic locking fails and the transaction is rolled back
        LockTimeoutException - if pessimistic locking fails and only the statement is rolled back
        PersistenceException - if an unsupported lock call is made
        Since:
        Java Persistence 2.0

      • clear

        void clear()
        Clear the persistence context, causing all managed entities to become detached. Changes made to entities that have not been flushed to the database will not be persisted.

      • detach

        void detach(Object entity)
        Remove the given entity from the persistence context, causing a managed entity to become detached. Unflushed changes made to the entity if any (including removal of the entity), will not be synchronized to the database. Entities which previously referenced the detached entity will continue to reference it.
        Parameters:
        entity - entity instance
        Throws:
        IllegalArgumentException - if the instance is not an entity
        Since:
        Java Persistence 2.0

      • contains

        boolean contains(Object entity)
        Check if the instance is a managed entity instance belonging to the current persistence context.
        Parameters:
        entity - entity instance
        Returns:
        boolean indicating if entity is in persistence context
        Throws:
        IllegalArgumentException - if not an entity

      • getLockMode

        LockModeType getLockMode(Object entity)
        Get the current lock mode for the entity instance.
        Parameters:
        entity - entity instance
        Returns:
        lock mode
        Throws:
        TransactionRequiredException - if there is no transaction or if the entity manager has not been joined to the current transaction
        IllegalArgumentException - if the instance is not a managed entity and a transaction is active
        Since:
        Java Persistence 2.0

      • setProperty

        void setProperty(String propertyName,
               Object value)
        Set an entity manager property or hint. If a vendor-specific property or hint is not recognized, it is silently ignored.
        Parameters:
        propertyName - name of property or hint
        value - value for property or hint
        Throws:
        IllegalArgumentException - if the second argument is not valid for the implementation
        Since:
        Java Persistence 2.0

      • getProperties

        Map<String,Object> getProperties()
        Get the properties and hints and associated values that are in effect for the entity manager. Changing the contents of the map does not change the configuration in effect.
        Returns:
        map of properties and hints in effect for entity manager
        Since:
        Java Persistence 2.0

      • createQuery

        Query createQuery(String qlString)
        Create an instance of Query for executing a Java Persistence query language statement.
        Parameters:
        qlString - a Java Persistence query string
        Returns:
        the new query instance
        Throws:
        IllegalArgumentException - if the query string is found to be invalid

      • createQuery

        <T> TypedQuery<T> createQuery(CriteriaQuery<T> criteriaQuery)
        Create an instance of TypedQuery for executing a criteria query.
        Parameters:
        criteriaQuery - a criteria query object
        Returns:
        the new query instance
        Throws:
        IllegalArgumentException - if the criteria query is found to be invalid
        Since:
        Java Persistence 2.0

      • createQuery

        Query createQuery(CriteriaUpdate updateQuery)
        Create an instance of Query for executing a criteria update query.
        Parameters:
        updateQuery - a criteria update query object
        Returns:
        the new query instance
        Throws:
        IllegalArgumentException - if the update query is found to be invalid
        Since:
        Java Persistence 2.1

      • createQuery

        Query createQuery(CriteriaDelete deleteQuery)
        Create an instance of Query for executing a criteria delete query.
        Parameters:
        deleteQuery - a criteria delete query object
        Returns:
        the new query instance
        Throws:
        IllegalArgumentException - if the delete query is found to be invalid
        Since:
        Java Persistence 2.1

      • createQuery

        <T> TypedQuery<T> createQuery(String qlString,
                            Class<T> resultClass)
        Create an instance of TypedQuery for executing a Java Persistence query language statement. The select list of the query must contain only a single item, which must be assignable to the type specified by the resultClass argument.
        Parameters:
        qlString - a Java Persistence query string
        resultClass - the type of the query result
        Returns:
        the new query instance
        Throws:
        IllegalArgumentException - if the query string is found to be invalid or if the query result is found to not be assignable to the specified type
        Since:
        Java Persistence 2.0

      • createNamedQuery

        Query createNamedQuery(String name)
        Create an instance of Query for executing a named query (in the Java Persistence query language or in native SQL).
        Parameters:
        name - the name of a query defined in metadata
        Returns:
        the new query instance
        Throws:
        IllegalArgumentException - if a query has not been defined with the given name or if the query string is found to be invalid

      • createNamedQuery

        <T> TypedQuery<T> createNamedQuery(String name,
                                 Class<T> resultClass)
        Create an instance of TypedQuery for executing a Java Persistence query language named query. The select list of the query must contain only a single item, which must be assignable to the type specified by the resultClass argument.
        Parameters:
        name - the name of a query defined in metadata
        resultClass - the type of the query result
        Returns:
        the new query instance
        Throws:
        IllegalArgumentException - if a query has not been defined with the given name or if the query string is found to be invalid or if the query result is found to not be assignable to the specified type
        Since:
        Java Persistence 2.0

      • createNativeQuery

        Query createNativeQuery(String sqlString)
        Create an instance of Query for executing a native SQL statement, e.g., for update or delete. If the query is not an update or delete query, query execution will result in each row of the SQL result being returned as a result of type Object[] (or a result of type Object if there is only one column in the select list.) Column values are returned in the order of their appearance in the select list and default JDBC type mappings are applied.
        Parameters:
        sqlString - a native SQL query string
        Returns:
        the new query instance

      • createNativeQuery

        Query createNativeQuery(String sqlString,
                      Class resultClass)
        Create an instance of Query for executing a native SQL query.
        Parameters:
        sqlString - a native SQL query string
        resultClass - the class of the resulting instance(s)
        Returns:
        the new query instance

      • createNativeQuery

        Query createNativeQuery(String sqlString,
                      String resultSetMapping)
        Create an instance of Query for executing a native SQL query.
        Parameters:
        sqlString - a native SQL query string
        resultSetMapping - the name of the result set mapping
        Returns:
        the new query instance

      • createNamedStoredProcedureQuery

        StoredProcedureQuery createNamedStoredProcedureQuery(String name)
        Create an instance of StoredProcedureQuery for executing a stored procedure in the database.

        Parameters must be registered before the stored procedure can be executed.

        If the stored procedure returns one or more result sets, any result set will be returned as a list of type Object[].

        Parameters:
        name - name assigned to the stored procedure query in metadata
        Returns:
        the new stored procedure query instance
        Throws:
        IllegalArgumentException - if a query has not been defined with the given name
        Since:
        Java Persistence 2.1

      • createStoredProcedureQuery

        StoredProcedureQuery createStoredProcedureQuery(String procedureName)
        Create an instance of StoredProcedureQuery for executing a stored procedure in the database.

        Parameters must be registered before the stored procedure can be executed.

        If the stored procedure returns one or more result sets, any result set will be returned as a list of type Object[].

        Parameters:
        procedureName - name of the stored procedure in the database
        Returns:
        the new stored procedure query instance
        Throws:
        IllegalArgumentException - if a stored procedure of the given name does not exist (or the query execution will fail)
        Since:
        Java Persistence 2.1

      • createStoredProcedureQuery

        StoredProcedureQuery createStoredProcedureQuery(String procedureName,
                                              Class... resultClasses)
        Create an instance of StoredProcedureQuery for executing a stored procedure in the database.

        Parameters must be registered before the stored procedure can be executed.

        The resultClass arguments must be specified in the order in which the result sets will be returned by the stored procedure invocation.

        Parameters:
        procedureName - name of the stored procedure in the database
        resultClasses - classes to which the result sets produced by the stored procedure are to be mapped
        Returns:
        the new stored procedure query instance
        Throws:
        IllegalArgumentException - if a stored procedure of the given name does not exist (or the query execution will fail)
        Since:
        Java Persistence 2.1

      • createStoredProcedureQuery

        StoredProcedureQuery createStoredProcedureQuery(String procedureName,
                                              String... resultSetMappings)
        Create an instance of StoredProcedureQuery for executing a stored procedure in the database.

        Parameters must be registered before the stored procedure can be executed.

        The resultSetMapping arguments must be specified in the order in which the result sets will be returned by the stored procedure invocation.

        Parameters:
        procedureName - name of the stored procedure in the database
        resultSetMappings - the names of the result set mappings to be used in mapping result sets returned by the stored procedure
        Returns:
        the new stored procedure query instance
        Throws:
        IllegalArgumentException - if a stored procedure or result set mapping of the given name does not exist (or the query execution will fail)

      • joinTransaction

        void joinTransaction()
        Indicate to the entity manager that a JTA transaction is active and join the persistence context to it.

        This method should be called on a JTA application managed entity manager that was created outside the scope of the active transaction or on an entity manager of type SynchronizationType.UNSYNCHRONIZED to associate it with the current JTA transaction.

        Throws:
        TransactionRequiredException - if there is no transaction

      • isJoinedToTransaction

        boolean isJoinedToTransaction()
        Determine whether the entity manager is joined to the current transaction. Returns false if the entity manager is not joined to the current transaction or if no transaction is active
        Returns:
        boolean
        Since:
        Java Persistence 2.1

      • unwrap

        <T> T unwrap(Class<T> cls)
        Return an object of the specified type to allow access to the provider-specific API. If the provider's EntityManager implementation does not support the specified class, the PersistenceException is thrown.
        Parameters:
        cls - the class of the object to be returned. This is normally either the underlying EntityManager implementation class or an interface that it implements.
        Returns:
        an instance of the specified class
        Throws:
        PersistenceException - if the provider does not support the call
        Since:
        Java Persistence 2.0

      • getDelegate

        Object getDelegate()
        Return the underlying provider object for the EntityManager, if available. The result of this method is implementation specific.

        The unwrap method is to be preferred for new applications.

        Returns:
        underlying provider object for EntityManager

      • close

        void close()
        Close an application-managed entity manager. After the close method has been invoked, all methods on the EntityManager instance and any Query, TypedQuery, and StoredProcedureQuery objects obtained from it will throw the IllegalStateException except for getProperties, getTransaction, and isOpen (which will return false). If this method is called when the entity manager is joined to an active transaction, the persistence context remains managed until the transaction completes.
        Throws:
        IllegalStateException - if the entity manager is container-managed

      • isOpen

        boolean isOpen()
        Determine whether the entity manager is open.
        Returns:
        true until the entity manager has been closed

      • getTransaction

        EntityTransaction getTransaction()
        Return the resource-level EntityTransaction object. The EntityTransaction instance may be used serially to begin and commit multiple transactions.
        Returns:
        EntityTransaction instance
        Throws:
        IllegalStateException - if invoked on a JTA entity manager

      • getEntityManagerFactory

        EntityManagerFactory getEntityManagerFactory()
        Return the entity manager factory for the entity manager.
        Returns:
        EntityManagerFactory instance
        Throws:
        IllegalStateException - if the entity manager has been closed
        Since:
        Java Persistence 2.0

      • getCriteriaBuilder

        CriteriaBuilder getCriteriaBuilder()
        Return an instance of CriteriaBuilder for the creation of CriteriaQuery objects.
        Returns:
        CriteriaBuilder instance
        Throws:
        IllegalStateException - if the entity manager has been closed
        Since:
        Java Persistence 2.0

      • getMetamodel

        Metamodel getMetamodel()
        Return an instance of Metamodel interface for access to the metamodel of the persistence unit.
        Returns:
        Metamodel instance
        Throws:
        IllegalStateException - if the entity manager has been closed
        Since:
        Java Persistence 2.0

      • createEntityGraph

        <T> EntityGraph<T> createEntityGraph(Class<T> rootType)
        Return a mutable EntityGraph that can be used to dynamically create an EntityGraph.
        Parameters:
        rootType - class of entity graph
        Returns:
        entity graph
        Since:
        Java Persistence 2.1

      • createEntityGraph

        EntityGraph<?> createEntityGraph(String graphName)
        Return a mutable copy of the named EntityGraph. If there is no entity graph with the specified name, null is returned.
        Parameters:
        graphName - name of an entity graph
        Returns:
        entity graph
        Since:
        Java Persistence 2.1

      • getEntityGraph

        EntityGraph<?> getEntityGraph(String graphName)
        Return a named EntityGraph. The returned EntityGraph should be considered immutable.
        Parameters:
        graphName - name of an existing entity graph
        Returns:
        named entity graph
        Throws:
        IllegalArgumentException - if there is no EntityGraph of the given name
        Since:
        Java Persistence 2.1

      • getEntityGraphs

        <T> List<EntityGraph<? super T>> getEntityGraphs(Class<T> entityClass)
        Return all named EntityGraphs that have been defined for the provided class type.
        Parameters:
        entityClass - entity class
        Returns:
        list of all entity graphs defined for the entity
        Throws:
        IllegalArgumentException - if the class is not an entity
        Since:
        Java Persistence 2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityManagerFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface EntityManagerFactory

  • public interface EntityManagerFactory
    Interface used to interact with the entity manager factory for the persistence unit.

    When the application has finished using the entity manager factory, and/or at application shutdown, the application should close the entity manager factory. Once an EntityManagerFactory has been closed, all its entity managers are considered to be in the closed state.

    Since:
    Java Persistence 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T> void addNamedEntityGraph(String graphName, EntityGraph<T> entityGraph)
      Add a named copy of the EntityGraph to the EntityManagerFactory.
      void addNamedQuery(String name, Query query)
      Define the query, typed query, or stored procedure query as a named query such that future query objects can be created from it using the createNamedQuery or createNamedStoredProcedureQuery method.
      void close()
      Close the factory, releasing any resources that it holds.
      EntityManager createEntityManager()
      Create a new application-managed EntityManager.
      EntityManager createEntityManager(Map map)
      Create a new application-managed EntityManager with the specified Map of properties.
      EntityManager createEntityManager(SynchronizationType synchronizationType)
      Create a new JTA application-managed EntityManager with the specified synchronization type.
      EntityManager createEntityManager(SynchronizationType synchronizationType, Map map)
      Create a new JTA application-managed EntityManager with the specified synchronization type and map of properties.
      Cache getCache()
      Access the cache that is associated with the entity manager factory (the "second level cache").
      CriteriaBuilder getCriteriaBuilder()
      Return an instance of CriteriaBuilder for the creation of CriteriaQuery objects.
      Metamodel getMetamodel()
      Return an instance of Metamodel interface for access to the metamodel of the persistence unit.
      PersistenceUnitUtil getPersistenceUnitUtil()
      Return interface providing access to utility methods for the persistence unit.
      Map<String,Object> getProperties()
      Get the properties and associated values that are in effect for the entity manager factory.
      boolean isOpen()
      Indicates whether the factory is open.
      <T> T unwrap(Class<T> cls)
      Return an object of the specified type to allow access to the provider-specific API.

    • Method Detail

      • createEntityManager

        EntityManager createEntityManager()
        Create a new application-managed EntityManager. This method returns a new EntityManager instance each time it is invoked. The isOpen method will return true on the returned instance.
        Returns:
        entity manager instance
        Throws:
        IllegalStateException - if the entity manager factory has been closed

      • createEntityManager

        EntityManager createEntityManager(Map map)
        Create a new application-managed EntityManager with the specified Map of properties. This method returns a new EntityManager instance each time it is invoked. The isOpen method will return true on the returned instance.
        Parameters:
        map - properties for entity manager
        Returns:
        entity manager instance
        Throws:
        IllegalStateException - if the entity manager factory has been closed

      • createEntityManager

        EntityManager createEntityManager(SynchronizationType synchronizationType)
        Create a new JTA application-managed EntityManager with the specified synchronization type. This method returns a new EntityManager instance each time it is invoked. The isOpen method will return true on the returned instance.
        Parameters:
        synchronizationType - how and when the entity manager should be synchronized with the current JTA transaction
        Returns:
        entity manager instance
        Throws:
        IllegalStateException - if the entity manager factory has been configured for resource-local entity managers or is closed
        Since:
        Java Persistence 2.1

      • createEntityManager

        EntityManager createEntityManager(SynchronizationType synchronizationType,
                                Map map)
        Create a new JTA application-managed EntityManager with the specified synchronization type and map of properties. This method returns a new EntityManager instance each time it is invoked. The isOpen method will return true on the returned instance.
        Parameters:
        synchronizationType - how and when the entity manager should be synchronized with the current JTA transaction
        map - properties for entity manager
        Returns:
        entity manager instance
        Throws:
        IllegalStateException - if the entity manager factory has been configured for resource-local entity managers or is closed
        Since:
        Java Persistence 2.1

      • getCriteriaBuilder

        CriteriaBuilder getCriteriaBuilder()
        Return an instance of CriteriaBuilder for the creation of CriteriaQuery objects.
        Returns:
        CriteriaBuilder instance
        Throws:
        IllegalStateException - if the entity manager factory has been closed
        Since:
        Java Persistence 2.0

      • getMetamodel

        Metamodel getMetamodel()
        Return an instance of Metamodel interface for access to the metamodel of the persistence unit.
        Returns:
        Metamodel instance
        Throws:
        IllegalStateException - if the entity manager factory has been closed
        Since:
        Java Persistence 2.0

      • isOpen

        boolean isOpen()
        Indicates whether the factory is open. Returns true until the factory has been closed.
        Returns:
        boolean indicating whether the factory is open

      • close

        void close()
        Close the factory, releasing any resources that it holds. After a factory instance has been closed, all methods invoked on it will throw the IllegalStateException, except for isOpen, which will return false. Once an EntityManagerFactory has been closed, all its entity managers are considered to be in the closed state.
        Throws:
        IllegalStateException - if the entity manager factory has been closed

      • getProperties

        Map<String,Object> getProperties()
        Get the properties and associated values that are in effect for the entity manager factory. Changing the contents of the map does not change the configuration in effect.
        Returns:
        properties
        Throws:
        IllegalStateException - if the entity manager factory has been closed
        Since:
        Java Persistence 2.0

      • getCache

        Cache getCache()
        Access the cache that is associated with the entity manager factory (the "second level cache").
        Returns:
        instance of the Cache interface or null if no cache is in use
        Throws:
        IllegalStateException - if the entity manager factory has been closed
        Since:
        Java Persistence 2.0

      • getPersistenceUnitUtil

        PersistenceUnitUtil getPersistenceUnitUtil()
        Return interface providing access to utility methods for the persistence unit.
        Returns:
        PersistenceUnitUtil interface
        Throws:
        IllegalStateException - if the entity manager factory has been closed
        Since:
        Java Persistence 2.0

      • addNamedQuery

        void addNamedQuery(String name,
                 Query query)
        Define the query, typed query, or stored procedure query as a named query such that future query objects can be created from it using the createNamedQuery or createNamedStoredProcedureQuery method.

        Any configuration of the query object (except for actual parameter binding) in effect when the named query is added is retained as part of the named query definition. This includes configuration information such as max results, hints, flush mode, lock mode, result set mapping information, and information about stored procedure parameters.

        When the query is executed, information that can be set by means of the query APIs can be overridden. Information that is overridden does not affect the named query as registered with the entity manager factory, and thus does not affect subsequent query objects created from it by means of the createNamedQuery or createNamedStoredProcedureQuery method.

        If a named query of the same name has been previously defined, either statically via metadata or via this method, that query definition is replaced.

        Parameters:
        name - name for the query
        query - Query, TypedQuery, or StoredProcedureQuery object
        Since:
        Java Persistence 2.1

      • unwrap

        <T> T unwrap(Class<T> cls)
        Return an object of the specified type to allow access to the provider-specific API. If the provider's EntityManagerFactory implementation does not support the specified class, the PersistenceException is thrown.
        Parameters:
        cls - the class of the object to be returned. This is normally either the underlying EntityManagerFactory implementation class or an interface that it implements.
        Returns:
        an instance of the specified class
        Throws:
        PersistenceException - if the provider does not support the call
        Since:
        Java Persistence 2.1

      • addNamedEntityGraph

        <T> void addNamedEntityGraph(String graphName,
                           EntityGraph<T> entityGraph)
        Add a named copy of the EntityGraph to the EntityManagerFactory. If an entity graph with the same name already exists, it is replaced.
        Parameters:
        graphName - name for the entity graph
        entityGraph - entity graph
        Since:
        Java Persistence 2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityNotFoundException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class EntityNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.EntityNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class EntityNotFoundException
extends PersistenceException
    Thrown by the persistence provider when an entity reference obtained by EntityManager.getReference is accessed but the entity does not exist. Thrown when EntityManager.refresh is called and the object no longer exists in the database. Thrown when EntityManager.lock is used with pessimistic locking is used and the entity no longer exists in the database.

    The current transaction, if one is active and the persistence context has been joined to it, will be marked for rollback.

    Since:
    Java Persistence 1.0
    See Also:
    EntityManager.getReference(Class,Object),
EntityManager.refresh(Object),
EntityManager.refresh(Object, LockModeType),
EntityManager.refresh(Object, java.util.Map),
EntityManager.refresh(Object, LockModeType, java.util.Map),
EntityManager.lock(Object, LockModeType),
EntityManager.lock(Object, LockModeType, java.util.Map),
Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EntityNotFoundException()
      Constructs a new EntityNotFoundException exception with null as its detail message.
      EntityNotFoundException(String message)
      Constructs a new EntityNotFoundException exception with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EntityNotFoundException

        public EntityNotFoundException()
        Constructs a new EntityNotFoundException exception with null as its detail message.

      • EntityNotFoundException

        public EntityNotFoundException(String message)
        Constructs a new EntityNotFoundException exception with the specified detail message.
        Parameters:
        message - the detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityResult (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type EntityResult

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface EntityResult
    Used in conjunction with the SqlResultSetMapping annotation to map the SELECT clause of a SQL query to an entity result.

    If this annotation is used, the SQL statement should select all of the columns that are mapped to the entity object. This should include foreign key columns to related entities. The results obtained when insufficient data is available are undefined.

       Example:

   Query q = em.createNativeQuery(
       "SELECT o.id, o.quantity, o.item, i.id, i.name, i.description "+
           "FROM Order o, Item i " +
           "WHERE (o.quantity > 25) AND (o.item = i.id)",
       "OrderItemResults");
   @SqlResultSetMapping(name="OrderItemResults",
       entities={
           @EntityResult(entityClass=com.acme.Order.class),
           @EntityResult(entityClass=com.acme.Item.class)
   })
    Since:
    Java Persistence 1.0
    See Also:
    SqlResultSetMapping

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class entityClass
      The class of the result.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String discriminatorColumn
      Specifies the column name (or alias) of the column in the SELECT list that is used to determine the type of the entity instance.
      FieldResult[] fields
      Maps the columns specified in the SELECT list of the query to the properties or fields of the entity class.

    • Element Detail

      • entityClass

        public abstract Class entityClass
        The class of the result.

      • fields

        public abstract FieldResult[] fields
        Maps the columns specified in the SELECT list of the query to the properties or fields of the entity class.
        Default:
        {}

      • discriminatorColumn

        public abstract String discriminatorColumn
        Specifies the column name (or alias) of the column in the SELECT list that is used to determine the type of the entity instance.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


EntityTransaction (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface EntityTransaction

  • public interface EntityTransaction
    Interface used to control transactions on resource-local entity managers. The EntityManager.getTransaction() method returns the EntityTransaction interface.
    Since:
    Java Persistence 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void begin()
      Start a resource transaction.
      void commit()
      Commit the current resource transaction, writing any unflushed changes to the database.
      boolean getRollbackOnly()
      Determine whether the current resource transaction has been marked for rollback.
      boolean isActive()
      Indicate whether a resource transaction is in progress.
      void rollback()
      Roll back the current resource transaction.
      void setRollbackOnly()
      Mark the current resource transaction so that the only possible outcome of the transaction is for the transaction to be rolled back.

    • Method Detail

      • begin

        void begin()
        Start a resource transaction.
        Throws:
        IllegalStateException - if isActive() is true

      • commit

        void commit()
        Commit the current resource transaction, writing any unflushed changes to the database.
        Throws:
        IllegalStateException - if isActive() is false
        RollbackException - if the commit fails

      • rollback

        void rollback()
        Roll back the current resource transaction.
        Throws:
        IllegalStateException - if isActive() is false
        PersistenceException - if an unexpected error condition is encountered

      • setRollbackOnly

        void setRollbackOnly()
        Mark the current resource transaction so that the only possible outcome of the transaction is for the transaction to be rolled back.
        Throws:
        IllegalStateException - if isActive() is false

      • getRollbackOnly

        boolean getRollbackOnly()
        Determine whether the current resource transaction has been marked for rollback.
        Returns:
        boolean indicating whether the transaction has been marked for rollback
        Throws:
        IllegalStateException - if isActive() is false

      • isActive

        boolean isActive()
        Indicate whether a resource transaction is in progress.
        Returns:
        boolean indicating whether transaction is in progress
        Throws:
        PersistenceException - if an unexpected error condition is encountered
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Enumerated (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Enumerated

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Enumerated
    Specifies that a persistent property or field should be persisted as a enumerated type. The Enumerated annotation may be used in conjunction with the Basic annotation, or in conjunction with the ElementCollection annotation when the element collection value is of basic type. If the enumerated type is not specified or the Enumerated annotation is not used, the EnumType value is assumed to be ORDINAL.
       Example:

   public enum EmployeeStatus {FULL_TIME, PART_TIME, CONTRACT}

   public enum SalaryRate {JUNIOR, SENIOR, MANAGER, EXECUTIVE}

   @Entity public class Employee {
       public EmployeeStatus getStatus() {...}
       ...
       @Enumerated(STRING)
       public SalaryRate getPayScale() {...}
       ...
   }
    Since:
    Java Persistence 1.0
    See Also:
    Basic, ElementCollection

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      EnumType value
      (Optional) The type used in mapping an enum type.

    • Element Detail

      • value

        public abstract EnumType value
        (Optional) The type used in mapping an enum type.
        Default:
        javax.persistence.EnumType.ORDINAL
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


EnumType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum EnumType

  • java.lang.Object
    • java.lang.Enum<EnumType>
      • javax.persistence.EnumType
  • All Implemented Interfaces:
    Serializable, Comparable<EnumType>

    public enum EnumType
extends Enum<EnumType>
    Defines mapping for enumerated types. The constants of this enumerated type specify how a persistent property or field of an enumerated type should be persisted.
    Since:
    Java Persistence 1.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ORDINAL
      Persist enumerated type property or field as an integer.
      STRING
      Persist enumerated type property or field as a string.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static EnumType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static EnumType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ORDINAL

        public static final EnumType ORDINAL
        Persist enumerated type property or field as an integer.

      • STRING

        public static final EnumType STRING
        Persist enumerated type property or field as a string.

    • Method Detail

      • values

        public static EnumType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (EnumType c : EnumType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static EnumType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ExcludeDefaultListeners (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type ExcludeDefaultListeners

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface ExcludeDefaultListeners
    Specifies that the invocation of default listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ExcludeSuperclassListeners (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type ExcludeSuperclassListeners

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface ExcludeSuperclassListeners
    Specifies that the invocation of superclass listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


FetchType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum FetchType

  • java.lang.Object
    • java.lang.Enum<FetchType>
      • javax.persistence.FetchType
  • All Implemented Interfaces:
    Serializable, Comparable<FetchType>

    public enum FetchType
extends Enum<FetchType>
    Defines strategies for fetching data from the database. The EAGER strategy is a requirement on the persistence provider runtime that data must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime that data should be fetched lazily when it is first accessed. The implementation is permitted to eagerly fetch data for which the LAZY strategy hint has been specified.
       Example:
   @Basic(fetch=LAZY)
   protected String getName() { return name; }
    Since:
    Java Persistence 1.0
    See Also:
    Basic, ElementCollection, ManyToMany, OneToMany, ManyToOne, OneToOne

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      EAGER
      Defines that data must be eagerly fetched.
      LAZY
      Defines that data can be lazily fetched.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static FetchType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static FetchType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LAZY

        public static final FetchType LAZY
        Defines that data can be lazily fetched.

      • EAGER

        public static final FetchType EAGER
        Defines that data must be eagerly fetched.

    • Method Detail

      • values

        public static FetchType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (FetchType c : FetchType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static FetchType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


FieldResult (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type FieldResult

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface FieldResult
    Used in conjunction with the EntityResult annotation to map columns specified in the SELECT list of a SQL query to the properties or fields of an entity class.

 Example:
   Query q = em.createNativeQuery(
       "SELECT o.id AS order_id, " +
           "o.quantity AS order_quantity, " +
           "o.item AS order_item, " +
         "FROM Order o, Item i " +
         "WHERE (order_quantity > 25) AND (order_item = i.id)",
       "OrderResults");

   @SqlResultSetMapping(name="OrderResults",
       entities={
           @EntityResult(entityClass=com.acme.Order.class, fields={
               @FieldResult(name="id", column="order_id"),
               @FieldResult(name="quantity", column="order_quantity"),
               @FieldResult(name="item", column="order_item")})
       })
    Since:
    Java Persistence 1.0
    See Also:
    EntityResult, SqlResultSetMapping

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String column
      Name of the column in the SELECT clause - i.e., column aliases, if applicable.
      String name
      Name of the persistent field or property of the class.

    • Element Detail

      • name

        public abstract String name
        Name of the persistent field or property of the class.

      • column

        public abstract String column
        Name of the column in the SELECT clause - i.e., column aliases, if applicable.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


FlushModeType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum FlushModeType

  • java.lang.Object
    • java.lang.Enum<FlushModeType>
      • javax.persistence.FlushModeType
  • All Implemented Interfaces:
    Serializable, Comparable<FlushModeType>

    public enum FlushModeType
extends Enum<FlushModeType>
    Flush mode setting.

    When queries are executed within a transaction, if FlushModeType.AUTO is set on the Query or TypedQuery object, or if the flush mode setting for the persistence context is AUTO (the default) and a flush mode setting has not been specified for the Query or TypedQuery object, the persistence provider is responsible for ensuring that all updates to the state of all entities in the persistence context which could potentially affect the result of the query are visible to the processing of the query. The persistence provider implementation may achieve this by flushing those entities to the database or by some other means.

    If FlushModeType.COMMIT is set, the effect of updates made to entities in the persistence context upon queries is unspecified.

    If there is no transaction active or the persistence context is not joined to the current transaction, the persistence provider must not flush to the database.

    Since:
    Java Persistence 1.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      AUTO
      (Default) Flushing to occur at query execution.
      COMMIT
      Flushing to occur at transaction commit.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static FlushModeType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static FlushModeType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • COMMIT

        public static final FlushModeType COMMIT
        Flushing to occur at transaction commit. The provider may flush at other times, but is not required to.

      • AUTO

        public static final FlushModeType AUTO
        (Default) Flushing to occur at query execution.

    • Method Detail

      • values

        public static FlushModeType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (FlushModeType c : FlushModeType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static FlushModeType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ForeignKey (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type ForeignKey

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface ForeignKey
    Used to specify the handling of foreign key constraints when schema generation is in effect. If this annotation is not specified, the persistence provider's default foreign key strategy will be used.

    The ConstraintMode value is used to specify whether foreign key constraints should be generated.

    The syntax used in the foreignKeyDefinition element should follow the SQL syntax used by the target database for foreign key constraints. For example, this may be similar the following:

     FOREIGN KEY ( <COLUMN expression> {, <COLUMN expression>}... )
 REFERENCES <TABLE identifier> [
     (<COLUMN expression> {, <COLUMN expression>}... ) ]
 [ ON UPDATE <referential action> ]
 [ ON DELETE <referential action> ]
    When the ConstraintMode value is CONSTRAINT, but the foreignKeyDefinition element is not specified, the provider will generate foreign key constraints whose update and delete actions it determines most appropriate for the join column(s) to which the foreign key annotation is applied.
    Since:
    Java Persistence 2.1
    See Also:
    JoinColumn, JoinColumns, MapKeyJoinColumn, MapKeyJoinColumns, PrimaryKeyJoinColumn, JoinTable, CollectionTable, SecondaryTable, AssociationOverride

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String foreignKeyDefinition
      (Optional) The foreign key constraint definition.
      String name
      (Optional) The name of the foreign key constraint.
      ConstraintMode value
      (Optional) Used to specify whether a foreign key constraint should be generated when schema generation is in effect.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the foreign key constraint. If this is not specified, it defaults to a provider-generated name.
        Default:
        ""

      • value

        public abstract ConstraintMode value
        (Optional) Used to specify whether a foreign key constraint should be generated when schema generation is in effect.

        A value of CONSTRAINT will cause the persistence provider to generate a foreign key constraint. If the foreignKeyDefinition element is not specified, the provider will generate a constraint whose update and delete actions it determines most appropriate for the join column(s) to which the foreign key annotation is applied.

        A value of NO_CONSTRAINT will result in no constraint being generated.

        A value of PROVIDER_DEFAULT will result in the provider's default behavior (which may or may not result in the generation of a constraint for the given join column(s).

        Default:
        javax.persistence.ConstraintMode.CONSTRAINT

      • foreignKeyDefinition

        public abstract String foreignKeyDefinition
        (Optional) The foreign key constraint definition.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


GeneratedValue (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type GeneratedValue

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface GeneratedValue
    Provides for the specification of generation strategies for the values of primary keys.

    The GeneratedValue annotation may be applied to a primary key property or field of an entity or mapped superclass in conjunction with the Id annotation. The use of the GeneratedValue annotation is only required to be supported for simple primary keys. Use of the GeneratedValue annotation is not supported for derived primary keys.

     Example 1:

     @Id
     @GeneratedValue(strategy=SEQUENCE, generator="CUST_SEQ")
     @Column(name="CUST_ID")
     public Long getId() { return id; }

     Example 2:

     @Id
     @GeneratedValue(strategy=TABLE, generator="CUST_GEN")
     @Column(name="CUST_ID")
     Long id;
    Since:
    Java Persistence 1.0
    See Also:
    Id, TableGenerator, SequenceGenerator

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String generator
      (Optional) The name of the primary key generator to use as specified in the SequenceGenerator or TableGenerator annotation.
      GenerationType strategy
      (Optional) The primary key generation strategy that the persistence provider must use to generate the annotated entity primary key.

    • Element Detail

      • strategy

        public abstract GenerationType strategy
        (Optional) The primary key generation strategy that the persistence provider must use to generate the annotated entity primary key.
        Default:
        javax.persistence.GenerationType.AUTO

      • generator

        public abstract String generator
        (Optional) The name of the primary key generator to use as specified in the SequenceGenerator or TableGenerator annotation.

        Defaults to the id generator supplied by persistence provider.

        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


GenerationType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum GenerationType

  • java.lang.Object
    • java.lang.Enum<GenerationType>
      • javax.persistence.GenerationType
  • All Implemented Interfaces:
    Serializable, Comparable<GenerationType>

    public enum GenerationType
extends Enum<GenerationType>
    Defines the types of primary key generation strategies.
    Since:
    Java Persistence 1.0
    See Also:
    GeneratedValue

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      AUTO
      Indicates that the persistence provider should pick an appropriate strategy for the particular database.
      IDENTITY
      Indicates that the persistence provider must assign primary keys for the entity using a database identity column.
      SEQUENCE
      Indicates that the persistence provider must assign primary keys for the entity using a database sequence.
      TABLE
      Indicates that the persistence provider must assign primary keys for the entity using an underlying database table to ensure uniqueness.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static GenerationType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static GenerationType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • TABLE

        public static final GenerationType TABLE
        Indicates that the persistence provider must assign primary keys for the entity using an underlying database table to ensure uniqueness.

      • SEQUENCE

        public static final GenerationType SEQUENCE
        Indicates that the persistence provider must assign primary keys for the entity using a database sequence.

      • IDENTITY

        public static final GenerationType IDENTITY
        Indicates that the persistence provider must assign primary keys for the entity using a database identity column.

      • AUTO

        public static final GenerationType AUTO
        Indicates that the persistence provider should pick an appropriate strategy for the particular database. The AUTO generation strategy may expect a database resource to exist, or it may attempt to create one. A vendor may provide documentation on how to create such resources in the event that it does not support schema generation or cannot create the schema resource at runtime.

    • Method Detail

      • values

        public static GenerationType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (GenerationType c : GenerationType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static GenerationType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Id (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Id

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Id
    Specifies the primary key of an entity. The field or property to which the Id annotation is applied should be one of the following types: any Java primitive type; any primitive wrapper type; String; java.util.Date; java.sql.Date; java.math.BigDecimal; java.math.BigInteger.

    The mapped column for the primary key of the entity is assumed to be the primary key of the primary table. If no Column annotation is specified, the primary key column name is assumed to be the name of the primary key property or field.

       Example:

   @Id
   public Long getId() { return id; }
    Since:
    Java Persistence 1.0
    See Also:
    Column, GeneratedValue
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


IdClass (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type IdClass

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface IdClass
    Specifies a composite primary key class that is mapped to multiple fields or properties of the entity.

    The names of the fields or properties in the primary key class and the primary key fields or properties of the entity must correspond and their types must be the same.

   Example:

   @IdClass(com.acme.EmployeePK.class)
   @Entity
   public class Employee {
      @Id String empName;
      @Id Date birthDay;
      ...
   }
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class value
      Primary key class

    • Element Detail

      • value

        public abstract Class value
        Primary key class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Index (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Index

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface Index
    Used in schema generation to specify creation of an index.

    Note that it is not necessary to specify an index for a primary key, as the primary key index will be created automatically.

    The syntax of the columnList element is a column_list, as follows:

        column::= index_column [,index_column]*
    index_column::= column_name [ASC | DESC]

    If ASC or DESC is not specified, ASC (ascending order) is assumed.

    Since:
    Java Persistence 2.1
    See Also:
    Table, SecondaryTable, CollectionTable, JoinTable, TableGenerator

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String columnList
      (Required) The names of the columns to be included in the index, in order.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      (Optional) The name of the index; defaults to a provider-generated name.
      boolean unique
      (Optional) Whether the index is unique.

    • Element Detail

      • columnList

        public abstract String columnList
        (Required) The names of the columns to be included in the index, in order.

      • name

        public abstract String name
        (Optional) The name of the index; defaults to a provider-generated name.
        Default:
        ""

      • unique

        public abstract boolean unique
        (Optional) Whether the index is unique.
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Inheritance (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Inheritance

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Inheritance
    Specifies the inheritance strategy to be used for an entity class hierarchy. It is specified on the entity class that is the root of the entity class hierarchy. If the Inheritance annotation is not specified or if no inheritance type is specified for an entity class hierarchy, the SINGLE_TABLE mapping strategy is used.

   Example:

   @Entity
   @Inheritance(strategy=JOINED)
   public class Customer { ... }

   @Entity
   public class ValuedCustomer extends Customer { ... }
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      InheritanceType strategy
      The strategy to be used for the entity inheritance hierarchy.

    • Element Detail

      • strategy

        public abstract InheritanceType strategy
        The strategy to be used for the entity inheritance hierarchy.
        Default:
        javax.persistence.InheritanceType.SINGLE_TABLE
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


InheritanceType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum InheritanceType

  • java.lang.Object
    • java.lang.Enum<InheritanceType>
      • javax.persistence.InheritanceType
  • All Implemented Interfaces:
    Serializable, Comparable<InheritanceType>

    public enum InheritanceType
extends Enum<InheritanceType>
    Defines inheritance strategy options.
    Since:
    Java Persistence 1.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      JOINED
      A strategy in which fields that are specific to a subclass are mapped to a separate table than the fields that are common to the parent class, and a join is performed to instantiate the subclass.
      SINGLE_TABLE
      A single table per class hierarchy.
      TABLE_PER_CLASS
      A table per concrete entity class.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static InheritanceType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static InheritanceType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SINGLE_TABLE

        public static final InheritanceType SINGLE_TABLE
        A single table per class hierarchy.

      • TABLE_PER_CLASS

        public static final InheritanceType TABLE_PER_CLASS
        A table per concrete entity class.

      • JOINED

        public static final InheritanceType JOINED
        A strategy in which fields that are specific to a subclass are mapped to a separate table than the fields that are common to the parent class, and a join is performed to instantiate the subclass.

    • Method Detail

      • values

        public static InheritanceType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (InheritanceType c : InheritanceType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static InheritanceType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


javax.persistence (Java(TM) EE 7 Specification APIs)

javax.persistence

Interfaces

  • AttributeConverter
  • AttributeNode
  • Cache
  • EntityGraph
  • EntityManager
  • EntityManagerFactory
  • EntityTransaction
  • Parameter
  • PersistenceUnitUtil
  • PersistenceUtil
  • Query
  • StoredProcedureQuery
  • Subgraph
  • Tuple
  • TupleElement
  • TypedQuery

Classes

  • Persistence

Enums

  • AccessType
  • CacheRetrieveMode
  • CacheStoreMode
  • CascadeType
  • ConstraintMode
  • DiscriminatorType
  • EnumType
  • FetchType
  • FlushModeType
  • GenerationType
  • InheritanceType
  • LockModeType
  • ParameterMode
  • PersistenceContextType
  • PessimisticLockScope
  • SharedCacheMode
  • SynchronizationType
  • TemporalType
  • ValidationMode

Exceptions

  • EntityExistsException
  • EntityNotFoundException
  • LockTimeoutException
  • NonUniqueResultException
  • NoResultException
  • OptimisticLockException
  • PersistenceException
  • PessimisticLockException
  • QueryTimeoutException
  • RollbackException
  • TransactionRequiredException

Annotation Types

  • Access
  • AssociationOverride
  • AssociationOverrides
  • AttributeOverride
  • AttributeOverrides
  • Basic
  • Cacheable
  • CollectionTable
  • Column
  • ColumnResult
  • ConstructorResult
  • Convert
  • Converter
  • Converts
  • DiscriminatorColumn
  • DiscriminatorValue
  • ElementCollection
  • Embeddable
  • Embedded
  • EmbeddedId
  • Entity
  • EntityListeners
  • EntityResult
  • Enumerated
  • ExcludeDefaultListeners
  • ExcludeSuperclassListeners
  • FieldResult
  • ForeignKey
  • GeneratedValue
  • Id
  • IdClass
  • Index
  • Inheritance
  • JoinColumn
  • JoinColumns
  • JoinTable
  • Lob
  • ManyToMany
  • ManyToOne
  • MapKey
  • MapKeyClass
  • MapKeyColumn
  • MapKeyEnumerated
  • MapKeyJoinColumn
  • MapKeyJoinColumns
  • MapKeyTemporal
  • MappedSuperclass
  • MapsId
  • NamedAttributeNode
  • NamedEntityGraph
  • NamedEntityGraphs
  • NamedNativeQueries
  • NamedNativeQuery
  • NamedQueries
  • NamedQuery
  • NamedStoredProcedureQueries
  • NamedStoredProcedureQuery
  • NamedSubgraph
  • OneToMany
  • OneToOne
  • OrderBy
  • OrderColumn
  • PersistenceContext
  • PersistenceContexts
  • PersistenceProperty
  • PersistenceUnit
  • PersistenceUnits
  • PostLoad
  • PostPersist
  • PostRemove
  • PostUpdate
  • PrePersist
  • PreRemove
  • PreUpdate
  • PrimaryKeyJoinColumn
  • PrimaryKeyJoinColumns
  • QueryHint
  • SecondaryTable
  • SecondaryTables
  • SequenceGenerator
  • SqlResultSetMapping
  • SqlResultSetMappings
  • StoredProcedureParameter
  • Table
  • TableGenerator
  • Temporal
  • Transient
  • UniqueConstraint
  • Version


javax.persistence (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.persistence

Java Persistence is the API for the management for persistence and object/relational mapping.

See: Description

  • Interface Summary
    Interface Description
    AttributeConverter<X,Y>
    A class that implements this interface can be used to convert entity attribute state into database column representation and back again.
    AttributeNode<T>
    Represents an attribute node of an entity graph.
    Cache
    Interface used to interact with the second-level cache.
    EntityGraph<T>
    This type represents the root of an entity graph that will be used as a template to define the attribute nodes and boundaries of a graph of entities and entity relationships.
    EntityManager
    Interface used to interact with the persistence context.
    EntityManagerFactory
    Interface used to interact with the entity manager factory for the persistence unit.
    EntityTransaction
    Interface used to control transactions on resource-local entity managers.
    Parameter<T>
    Type for query parameter objects.
    PersistenceUnitUtil
    Utility interface between the application and the persistence provider managing the persistence unit.
    PersistenceUtil
    Utility interface between the application and the persistence provider(s).
    Query
    Interface used to control query execution.
    StoredProcedureQuery
    Interface used to control stored procedure query execution.
    Subgraph<T>
    This type represents a subgraph for an attribute node that corresponds to a Managed Type.
    Tuple
    Interface for extracting the elements of a query result tuple.
    TupleElement<X>
    The TupleElement interface defines an element that is returned in a query result tuple.
    TypedQuery<X>
    Interface used to control the execution of typed queries.
  • Class Summary
    Class Description
    Persistence
    Bootstrap class that is used to obtain an EntityManagerFactory in Java SE environments.
  • Enum Summary
    Enum Description
    AccessType
    Used with the Access annotation to specify an access type to be applied to an entity class, mapped superclass, or embeddable class, or to a specific attribute of such a class.
    CacheRetrieveMode
    Used as the value of the javax.persistence.cache.retrieveMode property to specify the behavior when data is retrieved by the find methods and by queries.
    CacheStoreMode
    Used as the value of the javax.persistence.cache.storeMode property to specify the behavior when data is read from the database and when data is committed into the database.
    CascadeType
    Defines the set of cascadable operations that are propagated to the associated entity.
    ConstraintMode
    Used to control the application of a constraint.
    DiscriminatorType
    Defines supported types of the discriminator column.
    EnumType
    Defines mapping for enumerated types.
    FetchType
    Defines strategies for fetching data from the database.
    FlushModeType
    Flush mode setting.
    GenerationType
    Defines the types of primary key generation strategies.
    InheritanceType
    Defines inheritance strategy options.
    LockModeType
    Lock modes can be specified by means of passing a LockModeType argument to one of the EntityManager methods that take locks (lock, find, or refresh) or to the Query.setLockMode() or TypedQuery.setLockMode() method.
    ParameterMode
    Specifies the mode of a parameter of a stored procedure query.
    PersistenceContextType
    Specifies whether a transaction-scoped or extended persistence context is to be used in PersistenceContext.
    PessimisticLockScope
    Defines the values of the javax.persistence.lock.scope property for pessimistic locking.
    SharedCacheMode
    Specifies how the provider must use a second-level cache for the persistence unit.
    SynchronizationType
    Specifies whether the persistence context is always automatically synchronized with the current transaction or whether the persistence context must be explicitly joined to the current transaction by means of the EntityManager.joinTransaction() method.
    TemporalType
    Type used to indicate a specific mapping of java.util.Date or java.util.Calendar.
    ValidationMode
    The validation mode to be used by the provider for the persistence unit.
  • Exception Summary
    Exception Description
    EntityExistsException
    Thrown by the persistence provider when EntityManager.persist(Object) is called and the entity already exists.
    EntityNotFoundException
    Thrown by the persistence provider when an entity reference obtained by EntityManager.getReference is accessed but the entity does not exist.
    LockTimeoutException
    Thrown by the persistence provider when an pessimistic locking conflict occurs that does not result in transaction rollback.
    NonUniqueResultException
    Thrown by the persistence provider when Query.getSingleResult() or TypedQuery.getSingleResult() is executed on a query and there is more than one result from the query.
    NoResultException
    Thrown by the persistence provider when Query.getSingleResult() or TypedQuery.getSingleResult()is executed on a query and there is no result to return.
    OptimisticLockException
    Thrown by the persistence provider when an optimistic locking conflict occurs.
    PersistenceException
    Thrown by the persistence provider when a problem occurs.
    PessimisticLockException
    Thrown by the persistence provider when an pessimistic locking conflict occurs.
    QueryTimeoutException
    Thrown by the persistence provider when a query times out and only the statement is rolled back.
    RollbackException
    Thrown by the persistence provider when EntityTransaction.commit() fails.
    TransactionRequiredException
    Thrown by the persistence provider when a transaction is required but is not active.
  • Annotation Types Summary
    Annotation Type Description
    Access
    Used to specify an access type to be applied to an entity class, mapped superclass, or embeddable class, or to a specific attribute of such a class.
    AssociationOverride
    Used to override a mapping for an entity relationship.
    AssociationOverrides
    Used to override mappings of multiple relationship properties or fields.
    AttributeOverride
    Used to override the mapping of a Basic (whether explicit or default) property or field or Id property or field.
    AttributeOverrides
    Used to override mappings of multiple properties or fields.
    Basic
    The simplest type of mapping to a database column.
    Cacheable
    Specifies whether an entity should be cached if caching is enabled when the value of the persistence.xml caching element is ENABLE_SELECTIVE or DISABLE_SELECTIVE.
    CollectionTable
    Specifies the table that is used for the mapping of collections of basic or embeddable types.
    Column
    Specifies the mapped column for a persistent property or field.
    ColumnResult
    Used in conjunction with the SqlResultSetMapping annotation or ConstructorResult annotation to map a column of the SELECT list of a SQL query.
    ConstructorResult
    Used in conjunction with the SqlResultSetMapping annotation to map the SELECT clause of a SQL query to a constructor.
    Convert
    Specifies the conversion of a Basic field or property.
    Converter
    Specifies that the annotated class is a converter and defines its scope.
    Converts
    Used to group Convert annotations.
    DiscriminatorColumn
    Specifies the discriminator column for the SINGLE_TABLE and JOINED Inheritance mapping strategies.
    DiscriminatorValue
    Specifies the value of the discriminator column for entities of the given type.
    ElementCollection
    Specifies a collection of instances of a basic type or embeddable class.
    Embeddable
    Specifies a class whose instances are stored as an intrinsic part of an owning entity and share the identity of the entity.
    Embedded
    Specifies a persistent field or property of an entity whose value is an instance of an embeddable class.
    EmbeddedId
    Applied to a persistent field or property of an entity class or mapped superclass to denote a composite primary key that is an embeddable class.
    Entity
    Specifies that the class is an entity.
    EntityListeners
    Specifies the callback listener classes to be used for an entity or mapped superclass.
    EntityResult
    Used in conjunction with the SqlResultSetMapping annotation to map the SELECT clause of a SQL query to an entity result.
    Enumerated
    Specifies that a persistent property or field should be persisted as a enumerated type.
    ExcludeDefaultListeners
    Specifies that the invocation of default listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.
    ExcludeSuperclassListeners
    Specifies that the invocation of superclass listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.
    FieldResult
    Used in conjunction with the EntityResult annotation to map columns specified in the SELECT list of a SQL query to the properties or fields of an entity class.
    ForeignKey
    Used to specify the handling of foreign key constraints when schema generation is in effect.
    GeneratedValue
    Provides for the specification of generation strategies for the values of primary keys.
    Id
    Specifies the primary key of an entity.
    IdClass
    Specifies a composite primary key class that is mapped to multiple fields or properties of the entity.
    Index
    Used in schema generation to specify creation of an index.
    Inheritance
    Specifies the inheritance strategy to be used for an entity class hierarchy.
    JoinColumn
    Specifies a column for joining an entity association or element collection.
    JoinColumns
    Specifies the mapping for composite foreign keys.
    JoinTable
    Specifies the mapping of associations.
    Lob
    Specifies that a persistent property or field should be persisted as a large object to a database-supported large object type.
    ManyToMany
    Specifies a many-valued association with many-to-many multiplicity.
    ManyToOne
    Specifies a single-valued association to another entity class that has many-to-one multiplicity.
    MapKey
    Specifies the map key for associations of type java.util.Map when the map key is itself the primary key or a persistent field or property of the entity that is the value of the map.
    MapKeyClass
    Specifies the type of the map key for associations of type java.util.Map.
    MapKeyColumn
    Specifies the mapping for the key column of a map whose map key is a basic type.
    MapKeyEnumerated
    Specifies the enum type for a map key whose basic type is an enumerated type.
    MapKeyJoinColumn
    Specifies a mapping to an entity that is a map key.
    MapKeyJoinColumns
    Supports composite map keys that reference entities.
    MapKeyTemporal
    This annotation must be specified for persistent map keys of type Date and Calendar.
    MappedSuperclass
    Designates a class whose mapping information is applied to the entities that inherit from it.
    MapsId
    Designates a ManyToOne or OneToOne relationship attribute that provides the mapping for an EmbeddedId primary key, an attribute within an EmbeddedId primary key, or a simple primary key of the parent entity.
    NamedAttributeNode
    A NamedAttributeNode is a member element of a NamedEntityGraph.
    NamedEntityGraph
    Used to specify the path and boundaries for a find operation or query.
    NamedEntityGraphs
    Used to group NamedEntityGraph annotations.
    NamedNativeQueries
    Specifies multiple native SQL named queries.
    NamedNativeQuery
    Specifies a named native SQL query.
    NamedQueries
    Specifies multiple named Java Persistence query language queries.
    NamedQuery
    Specifies a static, named query in the Java Persistence query language.
    NamedStoredProcedureQueries
    Specifies multiple named stored procedure queries.
    NamedStoredProcedureQuery
    Specifies and names a stored procedure, its parameters, and its result type.
    NamedSubgraph
    A NamedSubgraph is a member element of a NamedEntityGraph.
    OneToMany
    Specifies a many-valued association with one-to-many multiplicity.
    OneToOne
    Specifies a single-valued association to another entity that has one-to-one multiplicity.
    OrderBy
    Specifies the ordering of the elements of a collection valued association or element collection at the point when the association or collection is retrieved.
    OrderColumn
    Specifies a column that is used to maintain the persistent order of a list.
    PersistenceContext
    Expresses a dependency on a container-managed EntityManager and its associated persistence context.
    PersistenceContexts
    Declares one or more PersistenceContext annotations.
    PersistenceProperty
    Describes a single container or persistence provider property.
    PersistenceUnit
    Expresses a dependency on an EntityManagerFactory and its associated persistence unit.
    PersistenceUnits
    Declares one or more PersistenceUnit annotations.
    PostLoad
    Specifies a callback method for the corresponding lifecycle event.
    PostPersist
    Specifies a callback method for the corresponding lifecycle event.
    PostRemove
    Specifies a callback method for the corresponding lifecycle event.
    PostUpdate
    Specifies a callback method for the corresponding lifecycle event.
    PrePersist
    Specifies a callback method for the corresponding lifecycle event.
    PreRemove
    Specifies a callback method for the corresponding lifecycle event.
    PreUpdate
    Specifies a callback method for the corresponding lifecycle event.
    PrimaryKeyJoinColumn
    Specifies a primary key column that is used as a foreign key to join to another table.
    PrimaryKeyJoinColumns
    Groups PrimaryKeyJoinColumn annotations.
    QueryHint
    Used to supply a query property or hint to the NamedQuery or NamedNativeQuery annotation.
    SecondaryTable
    Specifies a secondary table for the annotated entity class.
    SecondaryTables
    Specifies multiple secondary tables for an entity.
    SequenceGenerator
    Defines a primary key generator that may be referenced by name when a generator element is specified for the GeneratedValue annotation.
    SqlResultSetMapping
    Specifies the mapping of the result of a native SQL query or stored procedure.
    SqlResultSetMappings
    Is used to define one or more SqlResultSetMapping annotations.
    StoredProcedureParameter
    Specifies a parameter of a named stored procedure query.
    Table
    Specifies the primary table for the annotated entity.
    TableGenerator
    Defines a primary key generator that may be referenced by name when a generator element is specified for the GeneratedValue annotation.
    Temporal
    This annotation must be specified for persistent fields or properties of type java.util.Date and java.util.Calendar.
    Transient
    Specifies that the property or field is not persistent.
    UniqueConstraint
    Specifies that a unique constraint is to be included in the generated DDL for a primary or secondary table.
    Version
    Specifies the version field or property of an entity class that serves as its optimistic lock value.

Package javax.persistence Description

Java Persistence is the API for the management for persistence and object/relational mapping.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.persistence Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.persistence

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.persistence.Persistence
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.EntityExistsException
            • javax.persistence.EntityNotFoundException
            • javax.persistence.LockTimeoutException
            • javax.persistence.NonUniqueResultException
            • javax.persistence.NoResultException
            • javax.persistence.OptimisticLockException
            • javax.persistence.PessimisticLockException
            • javax.persistence.QueryTimeoutException
            • javax.persistence.RollbackException
            • javax.persistence.TransactionRequiredException

Interface Hierarchy

  • javax.persistence.AttributeConverter<X,Y>
  • javax.persistence.AttributeNode<T>
  • javax.persistence.Cache
  • javax.persistence.EntityGraph<T>
  • javax.persistence.EntityManager
  • javax.persistence.EntityManagerFactory
  • javax.persistence.EntityTransaction
  • javax.persistence.Parameter<T>
  • javax.persistence.PersistenceUtil
    • javax.persistence.PersistenceUnitUtil
  • javax.persistence.Query
    • javax.persistence.StoredProcedureQuery
    • javax.persistence.TypedQuery<X>
  • javax.persistence.Subgraph<T>
  • javax.persistence.Tuple
  • javax.persistence.TupleElement<X>

Annotation Type Hierarchy

  • javax.persistence.Version (implements java.lang.annotation.Annotation)
  • javax.persistence.UniqueConstraint (implements java.lang.annotation.Annotation)
  • javax.persistence.Transient (implements java.lang.annotation.Annotation)
  • javax.persistence.Temporal (implements java.lang.annotation.Annotation)
  • javax.persistence.TableGenerator (implements java.lang.annotation.Annotation)
  • javax.persistence.Table (implements java.lang.annotation.Annotation)
  • javax.persistence.StoredProcedureParameter (implements java.lang.annotation.Annotation)
  • javax.persistence.SqlResultSetMappings (implements java.lang.annotation.Annotation)
  • javax.persistence.SqlResultSetMapping (implements java.lang.annotation.Annotation)
  • javax.persistence.SequenceGenerator (implements java.lang.annotation.Annotation)
  • javax.persistence.SecondaryTables (implements java.lang.annotation.Annotation)
  • javax.persistence.SecondaryTable (implements java.lang.annotation.Annotation)
  • javax.persistence.QueryHint (implements java.lang.annotation.Annotation)
  • javax.persistence.PrimaryKeyJoinColumns (implements java.lang.annotation.Annotation)
  • javax.persistence.PrimaryKeyJoinColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.PreUpdate (implements java.lang.annotation.Annotation)
  • javax.persistence.PreRemove (implements java.lang.annotation.Annotation)
  • javax.persistence.PrePersist (implements java.lang.annotation.Annotation)
  • javax.persistence.PostUpdate (implements java.lang.annotation.Annotation)
  • javax.persistence.PostRemove (implements java.lang.annotation.Annotation)
  • javax.persistence.PostPersist (implements java.lang.annotation.Annotation)
  • javax.persistence.PostLoad (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceUnits (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceUnit (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceProperty (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceContexts (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceContext (implements java.lang.annotation.Annotation)
  • javax.persistence.OrderColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.OrderBy (implements java.lang.annotation.Annotation)
  • javax.persistence.OneToOne (implements java.lang.annotation.Annotation)
  • javax.persistence.OneToMany (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedSubgraph (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedStoredProcedureQuery (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedStoredProcedureQueries (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedQuery (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedQueries (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedNativeQuery (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedNativeQueries (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedEntityGraphs (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedEntityGraph (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedAttributeNode (implements java.lang.annotation.Annotation)
  • javax.persistence.MapsId (implements java.lang.annotation.Annotation)
  • javax.persistence.MappedSuperclass (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyTemporal (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyJoinColumns (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyJoinColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyEnumerated (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyClass (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKey (implements java.lang.annotation.Annotation)
  • javax.persistence.ManyToOne (implements java.lang.annotation.Annotation)
  • javax.persistence.ManyToMany (implements java.lang.annotation.Annotation)
  • javax.persistence.Lob (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinTable (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinColumns (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.Inheritance (implements java.lang.annotation.Annotation)
  • javax.persistence.Index (implements java.lang.annotation.Annotation)
  • javax.persistence.IdClass (implements java.lang.annotation.Annotation)
  • javax.persistence.Id (implements java.lang.annotation.Annotation)
  • javax.persistence.GeneratedValue (implements java.lang.annotation.Annotation)
  • javax.persistence.ForeignKey (implements java.lang.annotation.Annotation)
  • javax.persistence.FieldResult (implements java.lang.annotation.Annotation)
  • javax.persistence.ExcludeSuperclassListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.ExcludeDefaultListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.Enumerated (implements java.lang.annotation.Annotation)
  • javax.persistence.EntityResult (implements java.lang.annotation.Annotation)
  • javax.persistence.EntityListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.Entity (implements java.lang.annotation.Annotation)
  • javax.persistence.EmbeddedId (implements java.lang.annotation.Annotation)
  • javax.persistence.Embedded (implements java.lang.annotation.Annotation)
  • javax.persistence.Embeddable (implements java.lang.annotation.Annotation)
  • javax.persistence.ElementCollection (implements java.lang.annotation.Annotation)
  • javax.persistence.DiscriminatorValue (implements java.lang.annotation.Annotation)
  • javax.persistence.DiscriminatorColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.Converts (implements java.lang.annotation.Annotation)
  • javax.persistence.Converter (implements java.lang.annotation.Annotation)
  • javax.persistence.Convert (implements java.lang.annotation.Annotation)
  • javax.persistence.ConstructorResult (implements java.lang.annotation.Annotation)
  • javax.persistence.ColumnResult (implements java.lang.annotation.Annotation)
  • javax.persistence.Column (implements java.lang.annotation.Annotation)
  • javax.persistence.CollectionTable (implements java.lang.annotation.Annotation)
  • javax.persistence.Cacheable (implements java.lang.annotation.Annotation)
  • javax.persistence.Basic (implements java.lang.annotation.Annotation)
  • javax.persistence.AttributeOverrides (implements java.lang.annotation.Annotation)
  • javax.persistence.AttributeOverride (implements java.lang.annotation.Annotation)
  • javax.persistence.AssociationOverrides (implements java.lang.annotation.Annotation)
  • javax.persistence.AssociationOverride (implements java.lang.annotation.Annotation)
  • javax.persistence.Access (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.persistence.ValidationMode
      • javax.persistence.TemporalType
      • javax.persistence.SynchronizationType
      • javax.persistence.SharedCacheMode
      • javax.persistence.PessimisticLockScope
      • javax.persistence.PersistenceContextType
      • javax.persistence.ParameterMode
      • javax.persistence.LockModeType
      • javax.persistence.InheritanceType
      • javax.persistence.GenerationType
      • javax.persistence.FlushModeType
      • javax.persistence.FetchType
      • javax.persistence.EnumType
      • javax.persistence.DiscriminatorType
      • javax.persistence.ConstraintMode
      • javax.persistence.CascadeType
      • javax.persistence.CacheStoreMode
      • javax.persistence.CacheRetrieveMode
      • javax.persistence.AccessType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JoinColumn (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type JoinColumn

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface JoinColumn
    Specifies a column for joining an entity association or element collection. If the JoinColumn annotation itself is defaulted, a single join column is assumed and the default values apply.
       Example:

   @ManyToOne
   @JoinColumn(name="ADDR_ID")
   public Address getAddress() { return address; }

   Example: unidirectional one-to-many association using a foreign key mapping

   // In Customer class
   @OneToMany
   @JoinColumn(name="CUST_ID") // join column is in table for Order
   public Set<Order> getOrders() {return orders;}
    Since:
    Java Persistence 1.0
    See Also:
    ManyToOne, OneToMany, OneToOne, JoinTable, CollectionTable, ForeignKey

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String columnDefinition
      (Optional) The SQL fragment that is used when generating the DDL for the column.
      ForeignKey foreignKey
      (Optional) Used to specify or control the generation of a foreign key constraint when table generation is in effect.
      boolean insertable
      (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
      String name
      (Optional) The name of the foreign key column.
      boolean nullable
      (Optional) Whether the foreign key column is nullable.
      String referencedColumnName
      (Optional) The name of the column referenced by this foreign key column.
      String table
      (Optional) The name of the table that contains the column.
      boolean unique
      (Optional) Whether the property is a unique key.
      boolean updatable
      (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the foreign key column. The table in which it is found depends upon the context.
        • If the join is for a OneToOne or ManyToOne mapping using a foreign key mapping strategy, the foreign key column is in the table of the source entity or embeddable.
        • If the join is for a unidirectional OneToMany mapping using a foreign key mapping strategy, the foreign key is in the table of the target entity.
        • If the join is for a ManyToMany mapping or for a OneToOne or bidirectional ManyToOne/OneToMany mapping using a join table, the foreign key is in a join table.
        • If the join is for an element collection, the foreign key is in a collection table.

        Default (only applies if a single join column is used): The concatenation of the following: the name of the referencing relationship property or field of the referencing entity or embeddable class; "_"; the name of the referenced primary key column. If there is no such referencing relationship property or field in the entity, or if the join is for an element collection, the join column name is formed as the concatenation of the following: the name of the entity; "_"; the name of the referenced primary key column.

        Default:
        ""

      • referencedColumnName

        public abstract String referencedColumnName
        (Optional) The name of the column referenced by this foreign key column.
        • When used with entity relationship mappings other than the cases described here, the referenced column is in the table of the target entity.
        • When used with a unidirectional OneToMany foreign key mapping, the referenced column is in the table of the source entity.
        • When used inside a JoinTable annotation, the referenced key column is in the entity table of the owning entity, or inverse entity if the join is part of the inverse join definition.
        • When used in a CollectionTable mapping, the referenced column is in the table of the entity containing the collection.

        Default (only applies if single join column is being used): The same name as the primary key column of the referenced table.

        Default:
        ""

      • unique

        public abstract boolean unique
        (Optional) Whether the property is a unique key. This is a shortcut for the UniqueConstraint annotation at the table level and is useful for when the unique key constraint is only a single field. It is not necessary to explicitly specify this for a join column that corresponds to a primary key that is part of a foreign key.
        Default:
        false

      • nullable

        public abstract boolean nullable
        (Optional) Whether the foreign key column is nullable.
        Default:
        true

      • insertable

        public abstract boolean insertable
        (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
        Default:
        true

      • updatable

        public abstract boolean updatable
        (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.
        Default:
        true

      • columnDefinition

        public abstract String columnDefinition
        (Optional) The SQL fragment that is used when generating the DDL for the column.

        Defaults to the generated SQL for the column.

        Default:
        ""

      • table

        public abstract String table
        (Optional) The name of the table that contains the column. If a table is not specified, the column is assumed to be in the primary table of the applicable entity.

        Default:

        • If the join is for a OneToOne or ManyToOne mapping using a foreign key mapping strategy, the name of the table of the source entity or embeddable.
        • If the join is for a unidirectional OneToMany mapping using a foreign key mapping strategy, the name of the table of the target entity.
        • If the join is for a ManyToMany mapping or for a OneToOne or bidirectional ManyToOne/OneToMany mapping using a join table, the name of the join table.
        • If the join is for an element collection, the name of the collection table.
        Default:
        ""

      • foreignKey

        public abstract ForeignKey foreignKey
        (Optional) Used to specify or control the generation of a foreign key constraint when table generation is in effect. If this element is not specified, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


JoinColumns (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type JoinColumns

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface JoinColumns
    Specifies the mapping for composite foreign keys. This annotation groups JoinColumn annotations for the same relationship.

    When the JoinColumns annotation is used, both the name and the referencedColumnName elements must be specified in each such JoinColumn annotation.

    Example:
    @ManyToOne
    @JoinColumns({
        @JoinColumn(name="ADDR_ID", referencedColumnName="ID"),
        @JoinColumn(name="ADDR_ZIP", referencedColumnName="ZIP")
    })
    public Address getAddress() { return address; }
    Since:
    Java Persistence 1.0
    See Also:
    JoinColumn, ForeignKey

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      JoinColumn[] value
      The join columns that map the relationship.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      ForeignKey foreignKey
      (Optional) Used to specify or control the generation of a foreign key constraint when table generation is in effect.

    • Element Detail

      • value

        public abstract JoinColumn[] value
        The join columns that map the relationship.

      • foreignKey

        public abstract ForeignKey foreignKey
        (Optional) Used to specify or control the generation of a foreign key constraint when table generation is in effect. If both this element and the foreignKey element of any of the JoinColumn elements are specified, the behavior is undefined. If no foreign key annotation element is specified in either location, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


JoinTable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type JoinTable

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface JoinTable
    Specifies the mapping of associations. It is applied to the owning side of an association.

    A join table is typically used in the mapping of many-to-many and unidirectional one-to-many associations. It may also be used to map bidirectional many-to-one/one-to-many associations, unidirectional many-to-one relationships, and one-to-one associations (both bidirectional and unidirectional).

    When a join table is used in mapping a relationship with an embeddable class on the owning side of the relationship, the containing entity rather than the embeddable class is considered the owner of the relationship.

    If the JoinTable annotation is missing, the default values of the annotation elements apply. The name of the join table is assumed to be the table names of the associated primary tables concatenated together (owning side first) using an underscore.

    Example:

    @JoinTable(
        name="CUST_PHONE",
        joinColumns=
            @JoinColumn(name="CUST_ID", referencedColumnName="ID"),
        inverseJoinColumns=
            @JoinColumn(name="PHONE_ID", referencedColumnName="ID")
    )
    Since:
    Java Persistence 1.0
    See Also:
    JoinColumn, JoinColumns

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String catalog
      (Optional) The catalog of the table.
      ForeignKey foreignKey
      (Optional) Used to specify or control the generation of a foreign key constraint for the columns corresponding to the joinColumns element when table generation is in effect.
      Index[] indexes
      (Optional) Indexes for the table.
      ForeignKey inverseForeignKey
      (Optional) Used to specify or control the generation of a foreign key constraint for the columns corresponding to the inverseJoinColumns element when table generation is in effect.
      JoinColumn[] inverseJoinColumns
      (Optional) The foreign key columns of the join table which reference the primary table of the entity that does not own the association.
      JoinColumn[] joinColumns
      (Optional) The foreign key columns of the join table which reference the primary table of the entity owning the association.
      String name
      (Optional) The name of the join table.
      String schema
      (Optional) The schema of the table.
      UniqueConstraint[] uniqueConstraints
      (Optional) Unique constraints that are to be placed on the table.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the join table.

        Defaults to the concatenated names of the two associated primary entity tables, separated by an underscore.

        Default:
        ""

      • catalog

        public abstract String catalog
        (Optional) The catalog of the table.

        Defaults to the default catalog.

        Default:
        ""

      • schema

        public abstract String schema
        (Optional) The schema of the table.

        Defaults to the default schema for user.

        Default:
        ""

      • joinColumns

        public abstract JoinColumn[] joinColumns
        (Optional) The foreign key columns of the join table which reference the primary table of the entity owning the association. (I.e. the owning side of the association).

        Uses the same defaults as for JoinColumn.

        Default:
        {}

      • inverseJoinColumns

        public abstract JoinColumn[] inverseJoinColumns
        (Optional) The foreign key columns of the join table which reference the primary table of the entity that does not own the association. (I.e. the inverse side of the association).

        Uses the same defaults as for JoinColumn.

        Default:
        {}

      • foreignKey

        public abstract ForeignKey foreignKey
        (Optional) Used to specify or control the generation of a foreign key constraint for the columns corresponding to the joinColumns element when table generation is in effect. If both this element and the foreignKey element of any of the joinColumns elements are specified, the behavior is undefined. If no foreign key annotation element is specified in either location, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)

      • inverseForeignKey

        public abstract ForeignKey inverseForeignKey
        (Optional) Used to specify or control the generation of a foreign key constraint for the columns corresponding to the inverseJoinColumns element when table generation is in effect. If both this element and the foreignKey element of any of the inverseJoinColumns elements are specified, the behavior is undefined. If no foreign key annotation element is specified in either location, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)

      • uniqueConstraints

        public abstract UniqueConstraint[] uniqueConstraints
        (Optional) Unique constraints that are to be placed on the table. These are only used if table generation is in effect.

        Defaults to no additional constraints.

        Default:
        {}

      • indexes

        public abstract Index[] indexes
        (Optional) Indexes for the table. These are only used if table generation is in effect.
        Since:
        Java Persistence 2.1
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Lob (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Lob

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Lob
    Specifies that a persistent property or field should be persisted as a large object to a database-supported large object type.

    Portable applications should use the Lob annotation when mapping to a database Lob type. The Lob annotation may be used in conjunction with the Basic annotation or the ElementCollection annotation when the element collection value is of basic type. A Lob may be either a binary or character type.

    The Lob type is inferred from the type of the persistent field or property, and except for string and character-based types defaults to Blob.

   Example 1:

   @Lob @Basic(fetch=LAZY)
   @Column(name="REPORT")
   protected String report;

   Example 2:

   @Lob @Basic(fetch=LAZY)
   @Column(name="EMP_PIC", columnDefinition="BLOB NOT NULL")
   protected byte[] pic;
    Since:
    Java Persistence 1.0
    See Also:
    Basic, ElementCollection
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


LockModeType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum LockModeType

  • java.lang.Object
    • java.lang.Enum<LockModeType>
      • javax.persistence.LockModeType
  • All Implemented Interfaces:
    Serializable, Comparable<LockModeType>

    public enum LockModeType
extends Enum<LockModeType>
    Lock modes can be specified by means of passing a LockModeType argument to one of the EntityManager methods that take locks (lock, find, or refresh) or to the Query.setLockMode() or TypedQuery.setLockMode() method.

    Lock modes can be used to specify either optimistic or pessimistic locks.

    Optimistic locks are specified using LockModeType.OPTIMISTIC and LockModeType.OPTIMISTIC_FORCE_INCREMENT. The lock mode type values LockModeType.READ and LockModeType.WRITE are synonyms of OPTIMISTIC and OPTIMISTIC_FORCE_INCREMENT respectively. The latter are to be preferred for new applications.

    The semantics of requesting locks of type LockModeType.OPTIMISTIC and LockModeType.OPTIMISTIC_FORCE_INCREMENT are the following.

    If transaction T1 calls for a lock of type LockModeType.OPTIMISTIC on a versioned object, the entity manager must ensure that neither of the following phenomena can occur:

    • P1 (Dirty read): Transaction T1 modifies a row. Another transaction T2 then reads that row and obtains the modified value, before T1 has committed or rolled back. Transaction T2 eventually commits successfully; it does not matter whether T1 commits or rolls back and whether it does so before or after T2 commits.
      • P2 (Non-repeatable read): Transaction T1 reads a row. Another transaction T2 then modifies or deletes that row, before T1 has committed. Both transactions eventually commit successfully.

    Lock modes must always prevent the phenomena P1 and P2.

    In addition, calling a lock of type LockModeType.OPTIMISTIC_FORCE_INCREMENT on a versioned object, will also force an update (increment) to the entity's version column.

    The persistence implementation is not required to support the use of optimistic lock modes on non-versioned objects. When it cannot support a such lock call, it must throw the PersistenceException.

    The lock modes LockModeType.PESSIMISTIC_READ, LockModeType.PESSIMISTIC_WRITE, and LockModeType.PESSIMISTIC_FORCE_INCREMENT are used to immediately obtain long-term database locks.

    The semantics of requesting locks of type LockModeType.PESSIMISTIC_READ, LockModeType.PESSIMISTIC_WRITE, and LockModeType.PESSIMISTIC_FORCE_INCREMENT are the following.

    If transaction T1 calls for a lock of type LockModeType.PESSIMISTIC_READ or LockModeType.PESSIMISTIC_WRITE on an object, the entity manager must ensure that neither of the following phenomena can occur:

    • P1 (Dirty read): Transaction T1 modifies a row. Another transaction T2 then reads that row and obtains the modified value, before T1 has committed or rolled back.
    • P2 (Non-repeatable read): Transaction T1 reads a row. Another transaction T2 then modifies or deletes that row, before T1 has committed or rolled back.

    A lock with LockModeType.PESSIMISTIC_WRITE can be obtained on an entity instance to force serialization among transactions attempting to update the entity data. A lock with LockModeType.PESSIMISTIC_READ can be used to query data using repeatable-read semantics without the need to reread the data at the end of the transaction to obtain a lock, and without blocking other transactions reading the data. A lock with LockModeType.PESSIMISTIC_WRITE can be used when querying data and there is a high likelihood of deadlock or update failure among concurrent updating transactions.

    The persistence implementation must support use of locks of type LockModeType.PESSIMISTIC_READ LockModeType.PESSIMISTIC_WRITE on a non-versioned entity as well as on a versioned entity.

    When the lock cannot be obtained, and the database locking failure results in transaction-level rollback, the provider must throw the PessimisticLockException and ensure that the JTA transaction or EntityTransaction has been marked for rollback.

    When the lock cannot be obtained, and the database locking failure results in only statement-level rollback, the provider must throw the LockTimeoutException (and must not mark the transaction for rollback).

    Since:
    Java Persistence 1.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      NONE
      No lock.
      OPTIMISTIC
      Optimistic lock.
      OPTIMISTIC_FORCE_INCREMENT
      Optimistic lock, with version update.
      PESSIMISTIC_FORCE_INCREMENT
      Pessimistic write lock, with version update.
      PESSIMISTIC_READ
      Pessimistic read lock.
      PESSIMISTIC_WRITE
      Pessimistic write lock.
      READ
      Synonymous with OPTIMISTIC.
      WRITE
      Synonymous with OPTIMISTIC_FORCE_INCREMENT.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static LockModeType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static LockModeType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • READ

        public static final LockModeType READ
        Synonymous with OPTIMISTIC. OPTIMISTIC is to be preferred for new applications.

      • WRITE

        public static final LockModeType WRITE
        Synonymous with OPTIMISTIC_FORCE_INCREMENT. OPTIMISTIC_FORCE_IMCREMENT is to be preferred for new applications.

      • OPTIMISTIC

        public static final LockModeType OPTIMISTIC
        Optimistic lock.
        Since:
        Java Persistence 2.0

      • OPTIMISTIC_FORCE_INCREMENT

        public static final LockModeType OPTIMISTIC_FORCE_INCREMENT
        Optimistic lock, with version update.
        Since:
        Java Persistence 2.0

      • PESSIMISTIC_READ

        public static final LockModeType PESSIMISTIC_READ
        Pessimistic read lock.
        Since:
        Java Persistence 2.0

      • PESSIMISTIC_WRITE

        public static final LockModeType PESSIMISTIC_WRITE
        Pessimistic write lock.
        Since:
        Java Persistence 2.0

      • PESSIMISTIC_FORCE_INCREMENT

        public static final LockModeType PESSIMISTIC_FORCE_INCREMENT
        Pessimistic write lock, with version update.
        Since:
        Java Persistence 2.0

      • NONE

        public static final LockModeType NONE
        No lock.
        Since:
        Java Persistence 2.0

    • Method Detail

      • values

        public static LockModeType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (LockModeType c : LockModeType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static LockModeType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


LockTimeoutException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class LockTimeoutException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.LockTimeoutException
  • All Implemented Interfaces:
    Serializable

    public class LockTimeoutException
extends PersistenceException
    Thrown by the persistence provider when an pessimistic locking conflict occurs that does not result in transaction rollback. This exception may be thrown as part of an API call, at, flush or at commit time. The current transaction, if one is active, will be not be marked for rollback.
    Since:
    Java Persistence 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      LockTimeoutException()
      Constructs a new LockTimeoutException exception with null as its detail message.
      LockTimeoutException(Object entity)
      Constructs a new LockTimeoutException exception with the specified object.
      LockTimeoutException(String message)
      Constructs a new LockTimeoutException exception with the specified detail message.
      LockTimeoutException(String message, Throwable cause)
      Constructs a new LockTimeoutException exception with the specified detail message and cause.
      LockTimeoutException(String message, Throwable cause, Object entity)
      Constructs a new LockTimeoutException exception with the specified detail message, cause, and entity.
      LockTimeoutException(Throwable cause)
      Constructs a new LockTimeoutException exception with the specified cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getObject()
      Returns the object that caused this exception.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • LockTimeoutException

        public LockTimeoutException()
        Constructs a new LockTimeoutException exception with null as its detail message.

      • LockTimeoutException

        public LockTimeoutException(String message)
        Constructs a new LockTimeoutException exception with the specified detail message.
        Parameters:
        message - the detail message.

      • LockTimeoutException

        public LockTimeoutException(String message,
                    Throwable cause)
        Constructs a new LockTimeoutException exception with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - the cause.

      • LockTimeoutException

        public LockTimeoutException(Throwable cause)
        Constructs a new LockTimeoutException exception with the specified cause.
        Parameters:
        cause - the cause.

      • LockTimeoutException

        public LockTimeoutException(Object entity)
        Constructs a new LockTimeoutException exception with the specified object.
        Parameters:
        entity - the entity.

      • LockTimeoutException

        public LockTimeoutException(String message,
                    Throwable cause,
                    Object entity)
        Constructs a new LockTimeoutException exception with the specified detail message, cause, and entity.
        Parameters:
        message - the detail message.
        cause - the cause.
        entity - the entity.

    • Method Detail

      • getObject

        public Object getObject()
        Returns the object that caused this exception.
        Returns:
        the entity
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManyToMany (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type ManyToMany

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface ManyToMany
    Specifies a many-valued association with many-to-many multiplicity.

    Every many-to-many association has two sides, the owning side and the non-owning, or inverse, side. The join table is specified on the owning side. If the association is bidirectional, either side may be designated as the owning side. If the relationship is bidirectional, the non-owning side must use the mappedBy element of the ManyToMany annotation to specify the relationship field or property of the owning side.

    The join table for the relationship, if not defaulted, is specified on the owning side.

    The ManyToMany annotation may be used within an embeddable class contained within an entity class to specify a relationship to a collection of entities. If the relationship is bidirectional and the entity containing the embeddable class is the owner of the relationship, the non-owning side must use the mappedBy element of the ManyToMany annotation to specify the relationship field or property of the embeddable class. The dot (".") notation syntax must be used in the mappedBy element to indicate the relationship attribute within the embedded attribute. The value of each identifier used with the dot notation is the name of the respective embedded field or property.

    Example 1:

    // In Customer class:

    @ManyToMany
    @JoinTable(name="CUST_PHONES")
    public Set<PhoneNumber> getPhones() { return phones; }

    // In PhoneNumber class:

    @ManyToMany(mappedBy="phones")
    public Set<Customer> getCustomers() { return customers; }

    Example 2:

    // In Customer class:

    @ManyToMany(targetEntity=com.acme.PhoneNumber.class)
    public Set getPhones() { return phones; }

    // In PhoneNumber class:

    @ManyToMany(targetEntity=com.acme.Customer.class, mappedBy="phones")
    public Set getCustomers() { return customers; }

    Example 3:

    // In Customer class:

    @ManyToMany
    @JoinTable(name="CUST_PHONE",
        joinColumns=
            @JoinColumn(name="CUST_ID", referencedColumnName="ID"),
        inverseJoinColumns=
            @JoinColumn(name="PHONE_ID", referencedColumnName="ID")
        )
    public Set<PhoneNumber> getPhones() { return phones; }

    // In PhoneNumberClass:

    @ManyToMany(mappedBy="phones")
    public Set<Customer> getCustomers() { return customers; }
    Since:
    Java Persistence 1.0
    See Also:
    JoinTable

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      CascadeType[] cascade
      (Optional) The operations that must be cascaded to the target of the association.
      FetchType fetch
      (Optional) Whether the association should be lazily loaded or must be eagerly fetched.
      String mappedBy
      The field that owns the relationship.
      Class targetEntity
      (Optional) The entity class that is the target of the association.

    • Element Detail

      • targetEntity

        public abstract Class targetEntity
        (Optional) The entity class that is the target of the association. Optional only if the collection-valued relationship property is defined using Java generics. Must be specified otherwise.

        Defaults to the parameterized type of the collection when defined using generics.

        Default:
        void.class

      • cascade

        public abstract CascadeType[] cascade
        (Optional) The operations that must be cascaded to the target of the association.

        When the target collection is a java.util.Map, the cascade element applies to the map value.

        Defaults to no operations being cascaded.

        Default:
        {}

      • fetch

        public abstract FetchType fetch
        (Optional) Whether the association should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistence provider runtime that the associated entities must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime.
        Default:
        javax.persistence.FetchType.LAZY

      • mappedBy

        public abstract String mappedBy
        The field that owns the relationship. Required unless the relationship is unidirectional.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ManyToOne (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type ManyToOne

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface ManyToOne
    Specifies a single-valued association to another entity class that has many-to-one multiplicity. It is not normally necessary to specify the target entity explicitly since it can usually be inferred from the type of the object being referenced. If the relationship is bidirectional, the non-owning OneToMany entity side must used the mappedBy element to specify the relationship field or property of the entity that is the owner of the relationship.

    The ManyToOne annotation may be used within an embeddable class to specify a relationship from the embeddable class to an entity class. If the relationship is bidirectional, the non-owning OneToMany entity side must use the mappedBy element of the OneToMany annotation to specify the relationship field or property of the embeddable field or property on the owning side of the relationship. The dot (".") notation syntax must be used in the mappedBy element to indicate the relationship attribute within the embedded attribute. The value of each identifier used with the dot notation is the name of the respective embedded field or property.

     Example 1:

     @ManyToOne(optional=false)
     @JoinColumn(name="CUST_ID", nullable=false, updatable=false)
     public Customer getCustomer() { return customer; }

     Example 2:

     @Entity
        public class Employee {
        @Id int id;
        @Embedded JobInfo jobInfo;
        ...
     }

     @Embeddable
        public class JobInfo {
        String jobDescription;
        @ManyToOne ProgramManager pm; // Bidirectional
     }

     @Entity
        public class ProgramManager {
        @Id int id;
        @OneToMany(mappedBy="jobInfo.pm")
        Collection<Employee> manages;
     }
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      CascadeType[] cascade
      (Optional) The operations that must be cascaded to the target of the association.
      FetchType fetch
      (Optional) Whether the association should be lazily loaded or must be eagerly fetched.
      boolean optional
      (Optional) Whether the association is optional.
      Class targetEntity
      (Optional) The entity class that is the target of the association.

    • Element Detail

      • targetEntity

        public abstract Class targetEntity
        (Optional) The entity class that is the target of the association.

        Defaults to the type of the field or property that stores the association.

        Default:
        void.class

      • cascade

        public abstract CascadeType[] cascade
        (Optional) The operations that must be cascaded to the target of the association.

        By default no operations are cascaded.

        Default:
        {}

      • fetch

        public abstract FetchType fetch
        (Optional) Whether the association should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistence provider runtime that the associated entity must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime.
        Default:
        javax.persistence.FetchType.EAGER

      • optional

        public abstract boolean optional
        (Optional) Whether the association is optional. If set to false then a non-null relationship must always exist.
        Default:
        true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MapKey (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type MapKey

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface MapKey
    Specifies the map key for associations of type java.util.Map when the map key is itself the primary key or a persistent field or property of the entity that is the value of the map.

    If a persistent field or property other than the primary key is used as a map key then it is expected to have a uniqueness constraint associated with it.

    The MapKeyClass annotation is not used when MapKey is specified and vice versa.

    Example 1:

    @Entity
    public class Department {
        ...
        @OneToMany(mappedBy="department")
        @MapKey  // map key is primary key
        public Map<Integer, Employee> getEmployees() {... }
        ...
    }

    @Entity
    public class Employee {
        ...
        @Id Integer getEmpId() { ... }
        @ManyToOne
        @JoinColumn(name="dept_id")
        public Department getDepartment() { ... }
        ...
    }

    Example 2:

    @Entity
        public class Department {
        ...
        @OneToMany(mappedBy="department")
        @MapKey(name="name")
        public Map<String, Employee> getEmployees() {... }
        ...
    }

    @Entity
        public class Employee {
        @Id public Integer getEmpId() { ... }
        ...
        @ManyToOne
        @JoinColumn(name="dept_id")
        public Department getDepartment() { ... }
        ...
    }
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      (Optional) The name of the persistent field or property of the associated entity that is used as the map key.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the persistent field or property of the associated entity that is used as the map key.

        Default: If the name element is not specified, the primary key of the associated entity is used as the map key. If the primary key is a composite primary key and is mapped as IdClass, an instance of the primary key class is used as the key.

        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MapKeyClass (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type MapKeyClass

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface MapKeyClass
    Specifies the type of the map key for associations of type java.util.Map. The map key can be a basic type, an embeddable class, or an entity. If the map is specified using Java generics, the MapKeyClass annotation and associated type need not be specified; otherwise they must be specified.

    The MapKeyClass annotation is used in conjunction with ElementCollection or one of the collection-valued relationship annotations (OneToMany or ManyToMany). The MapKey annotation is not used when MapKeyClass is specified and vice versa.

    Example 1:

    @Entity
    public class Item {
       @Id int id;
       ...
       @ElementCollection(targetClass=String.class)
       @MapKeyClass(String.class)
       Map images;  // map from image name to image filename
       ...
    }

    Example 2:

    // MapKeyClass and target type of relationship can be defaulted

    @Entity
    public class Item {
       @Id int id;
       ...
       @ElementCollection
       Map<String, String> images;
        ...
     }

     Example 3:

     @Entity
     public class Company {
        @Id int id;
        ...
        @OneToMany(targetEntity=com.example.VicePresident.class)
        @MapKeyClass(com.example.Division.class)
        Map organization;
     }

     Example 4:

     // MapKeyClass and target type of relationship are defaulted

     @Entity
     public class Company {
        @Id int id;
        ...
        @OneToMany
        Map<Division, VicePresident> organization;
     }
    Since:
    Java Persistence 2.0
    See Also:
    ElementCollection, OneToMany, ManyToMany

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class value
      (Required) The type of the map key.

    • Element Detail

      • value

        public abstract Class value
        (Required) The type of the map key.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MapKeyColumn (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type MapKeyColumn

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface MapKeyColumn
    Specifies the mapping for the key column of a map whose map key is a basic type. If the name element is not specified, it defaults to the concatenation of the following: the name of the referencing relationship field or property; "_"; "KEY".
        Example:

    @Entity
    public class Item {
       @Id int id;
       ...
       @ElementCollection
       @MapKeyColumn(name="IMAGE_NAME")
       @Column(name="IMAGE_FILENAME")
       @CollectionTable(name="IMAGE_MAPPING")
       Map<String, String> images;  // map from image name to filename
       ...
    }
    Since:
    Java Persistence 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String columnDefinition
      (Optional) The SQL fragment that is used when generating the DDL for the column.
      boolean insertable
      (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
      int length
      (Optional) The column length.
      String name
      (Optional) The name of the map key column.
      boolean nullable
      (Optional) Whether the database column is nullable.
      int precision
      (Optional) The precision for a decimal (exact numeric) column.
      int scale
      (Optional) The scale for a decimal (exact numeric) column.
      String table
      (Optional) The name of the table that contains the column.
      boolean unique
      (Optional) Whether the column is a unique key.
      boolean updatable
      (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the map key column. The table in which it is found depends upon the context. If the map key is for an element collection, the map key column is in the collection table for the map value. If the map key is for a ManyToMany entity relationship or for a OneToMany entity relationship using a join table, the map key column is in a join table. If the map key is for a OneToMany entity relationship using a foreign key mapping strategy, the map key column is in the table of the entity that is the value of the map.

        Defaults to the concatenation of the following: the name of the referencing relationship field or property; "_"; "KEY".

        Default:
        ""

      • unique

        public abstract boolean unique
        (Optional) Whether the column is a unique key. This is a shortcut for the UniqueConstraint annotation at the table level and is useful for when the unique key constraint corresponds to only a single column. This constraint applies in addition to any constraint entailed by primary key mapping and to constraints specified at the table level.
        Default:
        false

      • nullable

        public abstract boolean nullable
        (Optional) Whether the database column is nullable.
        Default:
        false

      • insertable

        public abstract boolean insertable
        (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
        Default:
        true

      • updatable

        public abstract boolean updatable
        (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.
        Default:
        true

      • columnDefinition

        public abstract String columnDefinition
        (Optional) The SQL fragment that is used when generating the DDL for the column.

        Defaults to the generated SQL to create a column of the inferred type.

        Default:
        ""

      • table

        public abstract String table
        (Optional) The name of the table that contains the column.

        Defaults: If the map key is for an element collection, the name of the collection table for the map value. If the map key is for a OneToMany or ManyToMany entity relationship using a join table, the name of the join table for the map. If the map key is for a OneToMany entity relationship using a foreign key mapping strategy, the name of the primary table of the entity that is the value of the map.

        Default:
        ""

      • length

        public abstract int length
        (Optional) The column length. (Applies only if a string-valued column is used.)
        Default:
        255

      • precision

        public abstract int precision
        (Optional) The precision for a decimal (exact numeric) column. (Applies only if a decimal column is used.)

        Default: 0. (The value must be set by the developer.)

        Default:
        0

      • scale

        public abstract int scale
        (Optional) The scale for a decimal (exact numeric) column. (Applies only if a decimal column is used.)
        Default:
        0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MapKeyEnumerated (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type MapKeyEnumerated

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface MapKeyEnumerated
    Specifies the enum type for a map key whose basic type is an enumerated type. The MapKeyEnumerated annotation can be applied to an element collection or relationship of type java.util.Map, in conjunction with the ElementCollection, OneToMany, or ManyToMany annotation. If the enumerated type is not specified or the MapKeyEnumerated annotation is not used, the enumerated type is assumed to be ORDINAL.
       Example:

   public enum ProjectStatus {COMPLETE, DELAYED, CANCELLED, IN_PROGRESS}

   public enum SalaryRate {JUNIOR, SENIOR, MANAGER, EXECUTIVE}

   @Entity public class Employee {
       @ManyToMany
       public Projects<ProjectStatus, Project> getProjects() {...}

       @OneToMany
       @MapKeyEnumerated(STRING)
       public Map<SalaryRate, Employee> getEmployees() {...}
       ...
   }
    Since:
    Java Persistence 2.0
    See Also:
    ElementCollection, OneToMany, ManyToMany

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      EnumType value
      (Optional) The type used in mapping a map key enum type.

    • Element Detail

      • value

        public abstract EnumType value
        (Optional) The type used in mapping a map key enum type.
        Default:
        javax.persistence.EnumType.ORDINAL
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MapKeyJoinColumn (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type MapKeyJoinColumn

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface MapKeyJoinColumn
    Specifies a mapping to an entity that is a map key. The map key join column is in the collection table, join table, or table of the target entity that is used to represent the map. If no MapKeyJoinColumn annotation is specified, a single join column is assumed and the default values apply.

    Example 1:

    @Entity
    public class Company {
       @Id int id;
       ...
       @OneToMany   // unidirectional
       @JoinTable(name="COMPANY_ORGANIZATION",
                  joinColumns=@JoinColumn(name="COMPANY"),
                  inverseJoinColumns=@JoinColumn(name="VICEPRESIDENT"))
       @MapKeyJoinColumn(name="DIVISION")
       Map<Division, VicePresident> organization;
    }

    Example 2:

    @Entity
    public class VideoStore {
       @Id int id;
       String name;
       Address location;
       ...
       @ElementCollection
       @CollectionTable(name="INVENTORY",
                        joinColumns=@JoinColumn(name="STORE"))
       @Column(name="COPIES_IN_STOCK")
       @MapKeyJoinColumn(name="MOVIE", referencedColumnName="ID")
       Map<Movie, Integer> videoInventory;
       ...
     }

     @Entity
     public class Movie {
        @Id long id;
        String title;
        ...
     }

     Example 3:

     @Entity
     public class Student {
        @Id int studentId;
        ...
        @ManyToMany  // students and courses are also many-many
        @JoinTable(name="ENROLLMENTS",
                   joinColumns=@JoinColumn(name="STUDENT"),
                   inverseJoinColumns=@JoinColumn(name="SEMESTER"))
        @MapKeyJoinColumn(name="COURSE")
        Map<Course, Semester>  enrollment;
        ...
     }
    Since:
    Java Persistence 2.0
    See Also:
    ForeignKey

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String columnDefinition
      (Optional) The SQL fragment that is used when generating the DDL for the column.
      ForeignKey foreignKey
      (Optional) Used to specify or control the generation of a foreign key constraint when table generation is in effect.
      boolean insertable
      (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
      String name
      (Optional) The name of the foreign key column for the map key.
      boolean nullable
      (Optional) Whether the foreign key column is nullable.
      String referencedColumnName
      (Optional) The name of the column referenced by this foreign key column.
      String table
      (Optional) The name of the table that contains the foreign key column.
      boolean unique
      (Optional) Whether the property is a unique key.
      boolean updatable
      (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the foreign key column for the map key. The table in which it is found depends upon the context.
        • If the join is for a map key for an element collection, the foreign key column is in the collection table for the map value.
        • If the join is for a map key for a ManyToMany entity relationship or for a OneToMany entity relationship using a join table, the foreign key column is in a join table.
        • If the join is for a OneToMany entity relationship using a foreign key mapping strategy, the foreign key column for the map key is in the table of the entity that is the value of the map.

        Default (only applies if a single join column is used.) The concatenation of the following: the name of the referencing relationship property or field of the referencing entity or embeddable class; "_"; "KEY".

        Default:
        ""

      • referencedColumnName

        public abstract String referencedColumnName
        (Optional) The name of the column referenced by this foreign key column. The referenced column is in the table of the target entity.

        Default (only applies if single join column is being used.) The same name as the primary key column of the referenced table

        Default:
        ""

      • unique

        public abstract boolean unique
        (Optional) Whether the property is a unique key. This is a shortcut for the UniqueConstraint annotation at the table level and is useful for when the unique key constraint is only a single field.
        Default:
        false

      • nullable

        public abstract boolean nullable
        (Optional) Whether the foreign key column is nullable.
        Default:
        false

      • insertable

        public abstract boolean insertable
        (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
        Default:
        true

      • updatable

        public abstract boolean updatable
        (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.
        Default:
        true

      • columnDefinition

        public abstract String columnDefinition
        (Optional) The SQL fragment that is used when generating the DDL for the column. Defaults to SQL generated by the provider for the column.
        Default:
        ""

      • table

        public abstract String table
        (Optional) The name of the table that contains the foreign key column.
        • If the join is for a map key for an element collection, the foreign key column is in the collection table for the map value.
        • If the join is for a map key for a ManyToMany entity relationship or for a OneToMany entity relationship using a join table, the foreign key column is in a join table.
        • If the join is for a OneToMany entity relationship using a foreign key mapping strategy, the foreign key column for the map key is in the table of the entity that is the value of the map.

        Default:

        • If the map is for an element collection, the name of the collection table for the map value.
        • If the map is for a OneToMany or ManyToMany entity relationship using a join table, the name of the join table for the map.
        • If the map is for a OneToMany entity relationship using a foreign key mapping strategy, the name of the primary table of the entity that is the value of the map.
        Default:
        ""

      • foreignKey

        public abstract ForeignKey foreignKey
        (Optional) Used to specify or control the generation of a foreign key constraint when table generation is in effect. If this element is not specified, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MapKeyJoinColumns (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type MapKeyJoinColumns

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface MapKeyJoinColumns
    Supports composite map keys that reference entities.

    The MapKeyJoinColumns annotation groups MapKeyJoinColumn annotations. When the MapKeyJoinColumns annotation is used, both the name and the referencedColumnName elements must be specified in each of the grouped MapKeyJoinColumn annotations.

    Since:
    Java Persistence 2.0
    See Also:
    MapKeyJoinColumn, ForeignKey

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      MapKeyJoinColumn[] value
      (Required) The map key join columns that are used to map to the entity that is the map key.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      ForeignKey foreignKey
      (Optional) Used to specify or control the generation of a foreign key constraint when table generation is in effect.

    • Element Detail

      • value

        public abstract MapKeyJoinColumn[] value
        (Required) The map key join columns that are used to map to the entity that is the map key.

      • foreignKey

        public abstract ForeignKey foreignKey
        (Optional) Used to specify or control the generation of a foreign key constraint when table generation is in effect. If both this element and the foreignKey element of any of the MapKeyJoinColumn elements are specified, the behavior is undefined. If no foreign key annotation element is specified in either location, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MapKeyTemporal (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type MapKeyTemporal

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface MapKeyTemporal
    This annotation must be specified for persistent map keys of type Date and Calendar. It may only be specified for map keys of these types.

    The MapKeyTemporal annotation can be applied to an element collection or relationship of type java.util.Map in conjunction with the ElementCollection, OneToMany, or ManyToMany annotation.

         Example:

     @OneToMany
     @MapKeyTemporal(DATE)
     protected java.util.Map<java.util.Date, Employee> employees;
    Since:
    Java Persistence 2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      TemporalType value
      (Required) The type used in mapping java.util.Date or java.util.Calendar.

    • Element Detail

      • value

        public abstract TemporalType value
        (Required) The type used in mapping java.util.Date or java.util.Calendar.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MappedSuperclass (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type MappedSuperclass

  • @Documented
@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface MappedSuperclass
    Designates a class whose mapping information is applied to the entities that inherit from it. A mapped superclass has no separate table defined for it.

    A class designated with the MappedSuperclass annotation can be mapped in the same way as an entity except that the mappings will apply only to its subclasses since no table exists for the mapped superclass itself. When applied to the subclasses the inherited mappings will apply in the context of the subclass tables. Mapping information may be overridden in such subclasses by using the AttributeOverride and AssociationOverride annotations or corresponding XML elements.

        Example: Concrete class as a mapped superclass

    @MappedSuperclass
    public class Employee {

        @Id protected Integer empId;
        @Version protected Integer version;
        @ManyToOne @JoinColumn(name="ADDR")
        protected Address address;

        public Integer getEmpId() { ... }
        public void setEmpId(Integer id) { ... }
        public Address getAddress() { ... }
        public void setAddress(Address addr) { ... }
    }

    // Default table is FTEMPLOYEE table
    @Entity
    public class FTEmployee extends Employee {

        // Inherited empId field mapped to FTEMPLOYEE.EMPID
        // Inherited version field mapped to FTEMPLOYEE.VERSION
        // Inherited address field mapped to FTEMPLOYEE.ADDR fk

        // Defaults to FTEMPLOYEE.SALARY
        protected Integer salary;

        public FTEmployee() {}

        public Integer getSalary() { ... }

        public void setSalary(Integer salary) { ... }
    }

    @Entity @Table(name="PT_EMP")
    @AssociationOverride(
        name="address",
        joincolumns=@JoinColumn(name="ADDR_ID"))
    public class PartTimeEmployee extends Employee {

        // Inherited empId field mapped to PT_EMP.EMPID
        // Inherited version field mapped to PT_EMP.VERSION
        // address field mapping overridden to PT_EMP.ADDR_ID fk
        @Column(name="WAGE")
        protected Float hourlyWage;

        public PartTimeEmployee() {}

        public Float getHourlyWage() { ... }
        public void setHourlyWage(Float wage) { ... }
    }
    Since:
    Java Persistence 1.0
    See Also:
    AttributeOverride, AssociationOverride
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MapsId (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type MapsId

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface MapsId
    Designates a ManyToOne or OneToOne relationship attribute that provides the mapping for an EmbeddedId primary key, an attribute within an EmbeddedId primary key, or a simple primary key of the parent entity. The value element specifies the attribute within a composite key to which the relationship attribute corresponds. If the entity's primary key is of the same Java type as the primary key of the entity referenced by the relationship, the value attribute is not specified.
        Example:

    // parent entity has simple primary key

    @Entity
    public class Employee {
       @Id long empId;
       String name;
       ...
    }

    // dependent entity uses EmbeddedId for composite key

    @Embeddable
    public class DependentId {
       String name;
       long empid;   // corresponds to primary key type of Employee
    }

    @Entity
    public class Dependent {
       @EmbeddedId DependentId id;
        ...
       @MapsId("empid")  //  maps the empid attribute of embedded id
       @ManyToOne Employee emp;
    }
    Since:
    Java Persistence 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String value
      (Optional) The name of the attribute within the composite key to which the relationship attribute corresponds.

    • Element Detail

      • value

        public abstract String value
        (Optional) The name of the attribute within the composite key to which the relationship attribute corresponds. If not supplied, the relationship maps the entity's primary key.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NamedAttributeNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type NamedAttributeNode

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface NamedAttributeNode
    A NamedAttributeNode is a member element of a NamedEntityGraph.
    Since:
    Java Persistence 2.1
    See Also:
    NamedEntityGraph, NamedSubgraph

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      (Required) The name of the attribute that must be included in the graph.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String keySubgraph
      (Optional) If the attribute references a Map type, this element can be used to specify a subgraph for the Key in the case of an Entity key type.
      String subgraph
      (Optional) If the attribute references a managed type that has its own AttributeNodes, this element is used to refer to that NamedSubgraph definition.

    • Element Detail

      • value

        public abstract String value
        (Required) The name of the attribute that must be included in the graph.

      • subgraph

        public abstract String subgraph
        (Optional) If the attribute references a managed type that has its own AttributeNodes, this element is used to refer to that NamedSubgraph definition. If the target type has inheritance, multiple subgraphs can be specified. These additional subgraphs are intended to add subclass-specific attributes. Superclass subgraph entries will be merged into subclass subgraphs.

        The value of this element is the name of the subgraph as specified by the name element of the corresponding NamedSubgraph element. If multiple subgraphs are specified due to inheritance, they are referenced by this name.

        Default:
        ""

      • keySubgraph

        public abstract String keySubgraph
        (Optional) If the attribute references a Map type, this element can be used to specify a subgraph for the Key in the case of an Entity key type. A keySubgraph can not be specified without the Map attribute also being specified. If the target type has inheritance, multiple subgraphs can be specified. These additional subgraphs are intended to add subclass-specific attributes. Superclass subgraph entries will be merged into subclass subgraphs.

        The value of this element is the name of the key subgraph as specified by the name element of the corresponding NamedSubgraph element. If multiple key subgraphs are specified due to inheritance, they are referenced by this name.

        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NamedEntityGraph (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type NamedEntityGraph

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedEntityGraph
    Used to specify the path and boundaries for a find operation or query.
    Since:
    Java Persistence 2.1

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      NamedAttributeNode[] attributeNodes
      (Optional) A list of attributes of the entity that are included in this graph.
      boolean includeAllAttributes
      (Optional) Includes all of the attributes of the annotated entity class as attribute nodes in the NamedEntityGraph without the need to explicitly list them.
      String name
      (Optional) The name of the entity graph.
      NamedSubgraph[] subclassSubgraphs
      (Optional) A list of subgraphs that will add additional attributes for subclasses of the annotated entity class to the entity graph.
      NamedSubgraph[] subgraphs
      (Optional) A list of subgraphs that are included in the entity graph.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the entity graph. Defaults to the entity name of the root entity.
        Default:
        ""

      • attributeNodes

        public abstract NamedAttributeNode[] attributeNodes
        (Optional) A list of attributes of the entity that are included in this graph.
        Default:
        {}

      • includeAllAttributes

        public abstract boolean includeAllAttributes
        (Optional) Includes all of the attributes of the annotated entity class as attribute nodes in the NamedEntityGraph without the need to explicitly list them. Included attributes can still be fully specified by an attribute node referencing a subgraph.
        Default:
        false

      • subgraphs

        public abstract NamedSubgraph[] subgraphs
        (Optional) A list of subgraphs that are included in the entity graph. These are referenced by name from NamedAttributeNode definitions.
        Default:
        {}

      • subclassSubgraphs

        public abstract NamedSubgraph[] subclassSubgraphs
        (Optional) A list of subgraphs that will add additional attributes for subclasses of the annotated entity class to the entity graph. Specified attributes from superclasses are included in subclasses.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NamedEntityGraphs (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type NamedEntityGraphs

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedEntityGraphs
    Used to group NamedEntityGraph annotations.
    Since:
    Java Persistence 2.1
    See Also:
    NamedEntityGraph

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      NamedEntityGraph[] value

    • Element Detail

      • value

        public abstract NamedEntityGraph[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NamedNativeQueries (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type NamedNativeQueries

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedNativeQueries
    Specifies multiple native SQL named queries. Query names are scoped to the persistence unit. The NamedNativeQueries annotation can be applied to an entity or mapped superclass.
    Since:
    Java Persistence 1.0
    See Also:
    NamedNativeQuery

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      NamedNativeQuery[] value
      (Required) Array of NamedNativeQuery annotations.

    • Element Detail

      • value

        public abstract NamedNativeQuery[] value
        (Required) Array of NamedNativeQuery annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NamedNativeQuery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type NamedNativeQuery

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedNativeQuery
    Specifies a named native SQL query. Query names are scoped to the persistence unit. The NamedNativeQuery annotation can be applied to an entity or mapped superclass.
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      The name used to refer to the query with the EntityManager methods that create query objects.
      String query
      The SQL query string.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      QueryHint[] hints
      Query properties and hints.
      Class resultClass
      The class of the result.
      String resultSetMapping
      The name of a SqlResultSetMapping, as defined in metadata.

    • Element Detail

      • name

        public abstract String name
        The name used to refer to the query with the EntityManager methods that create query objects.

      • query

        public abstract String query
        The SQL query string.

      • hints

        public abstract QueryHint[] hints
        Query properties and hints. (May include vendor-specific query hints.)
        Default:
        {}

      • resultClass

        public abstract Class resultClass
        The class of the result.
        Default:
        void.class

      • resultSetMapping

        public abstract String resultSetMapping
        The name of a SqlResultSetMapping, as defined in metadata.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NamedQueries (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type NamedQueries

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedQueries
    Specifies multiple named Java Persistence query language queries. Query names are scoped to the persistence unit. The NamedQueries annotation can be applied to an entity or mapped superclass.
    Since:
    Java Persistence 1.0
    See Also:
    NamedQuery

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      NamedQuery[] value
      (Required) An array of NamedQuery annotations.

    • Element Detail

      • value

        public abstract NamedQuery[] value
        (Required) An array of NamedQuery annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NamedQuery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type NamedQuery

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedQuery
    Specifies a static, named query in the Java Persistence query language. Query names are scoped to the persistence unit. The NamedQuery annotation can be applied to an entity or mapped superclass.

    The following is an example of the definition of a named query in the Java Persistence query language:

        @NamedQuery(
            name="findAllCustomersWithName",
            query="SELECT c FROM Customer c WHERE c.name LIKE :custName"
    )

    The following is an example of the use of a named query:

        @PersistenceContext
    public EntityManager em;
    ...
    customers = em.createNamedQuery("findAllCustomersWithName")
            .setParameter("custName", "Smith")
            .getResultList();
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      (Required) The name used to refer to the query with the EntityManager methods that create query objects.
      String query
      (Required) The query string in the Java Persistence query language.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      QueryHint[] hints
      (Optional) Query properties and hints.
      LockModeType lockMode
      (Optional) The lock mode type to use in query execution.

    • Element Detail

      • name

        public abstract String name
        (Required) The name used to refer to the query with the EntityManager methods that create query objects.

      • query

        public abstract String query
        (Required) The query string in the Java Persistence query language.

      • lockMode

        public abstract LockModeType lockMode
        (Optional) The lock mode type to use in query execution. If a lockMode other than LockModeType.NONE is specified, the query must be executed in a transaction and the persistence context joined to the transaction.
        Since:
        Java Persistence 2.0
        Default:
        javax.persistence.LockModeType.NONE

      • hints

        public abstract QueryHint[] hints
        (Optional) Query properties and hints. May include vendor-specific query hints.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NamedStoredProcedureQueries (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type NamedStoredProcedureQueries

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedStoredProcedureQueries
    Specifies multiple named stored procedure queries. Query names are scoped to the persistence unit. The NamedStoredProcedureQueries annotation can be applied to an entity or mapped superclass.
    Since:
    Java Persistence 2.1
    See Also:
    NamedStoredProcedureQuery

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      NamedStoredProcedureQuery[] value
      (Required) Array of NamedStoredProcedureQuery annotations.

    • Element Detail

      • value

        public abstract NamedStoredProcedureQuery[] value
        (Required) Array of NamedStoredProcedureQuery annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NamedStoredProcedureQuery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type NamedStoredProcedureQuery

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedStoredProcedureQuery
    Specifies and names a stored procedure, its parameters, and its result type.

    The NamedStoredProcedureQuery annotation can be applied to an entity or mapped superclass.

    The name element is the name that is passed as an argument to the EntityManager.createNamedStoredProcedureQuery(java.lang.String) method to create an executable StoredProcedureQuery object. Names are scoped to the persistence unit.

    The procedureName element is the name of the stored procedure in the database.

    The parameters of the stored procedure are specified by the parameters element. All parameters must be specified in the order in which they occur in the parameter list of the stored procedure.

    The resultClasses element refers to the class (or classes) that are used to map the results. The resultSetMappings element names one or more result set mappings, as defined by the SqlResultSetMapping annotation.

    If there are multiple result sets, it is assumed that they will be mapped using the same mechanism — e.g., either all via a set of result class mappings or all via a set of result set mappings. The order of the specification of these mappings must be the same as the order in which the result sets will be returned by the stored procedure invocation. If the stored procedure returns one or more result sets and no resultClasses or resultSetMappings element is specified, any result set will be returned as a list of type Object[]. The combining of different strategies for the mapping of stored procedure result sets is undefined.

    The hints element may be used to specify query properties and hints. Properties defined by this specification must be observed by the provider. Vendor-specific hints that are not recognized by a provider must be ignored.

    All parameters of a named stored procedure query must be specified using the StoredProcedureParameter annotation.

    Since:
    Java Persistence 2.1
    See Also:
    StoredProcedureQuery, StoredProcedureParameter

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      The name used to refer to the query with the EntityManager methods that create stored procedure query objects.
      String procedureName
      The name of the stored procedure in the database.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      QueryHint[] hints
      Query properties and hints.
      StoredProcedureParameter[] parameters
      Information about all parameters of the stored procedure.
      Class[] resultClasses
      The class or classes that are used to map the results.
      String[] resultSetMappings
      The names of one or more result set mappings, as defined in metadata.

    • Element Detail

      • name

        public abstract String name
        The name used to refer to the query with the EntityManager methods that create stored procedure query objects.

      • procedureName

        public abstract String procedureName
        The name of the stored procedure in the database.

      • parameters

        public abstract StoredProcedureParameter[] parameters
        Information about all parameters of the stored procedure. All parameters must be specified in the order in which they occur in the parameter list of the stored procedure.
        Default:
        {}

      • resultClasses

        public abstract Class[] resultClasses
        The class or classes that are used to map the results.
        Default:
        {}

      • resultSetMappings

        public abstract String[] resultSetMappings
        The names of one or more result set mappings, as defined in metadata.
        Default:
        {}

      • hints

        public abstract QueryHint[] hints
        Query properties and hints. (May include vendor-specific query hints.)
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NamedSubgraph (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type NamedSubgraph

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface NamedSubgraph
    A NamedSubgraph is a member element of a NamedEntityGraph. The NamedSubgraph is only referenced from within a NamedEntityGraph and can not be referenced independently. It is referenced by its name from a NamedAttributeNode element of the NamedEntityGraph.
    Since:
    Java Persistence 2.1
    See Also:
    NamedEntityGraph, NamedAttributeNode

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      NamedAttributeNode[] attributeNodes
      (Required) The list of the attributes of the class that must be included.
      String name
      (Required) The name of the subgraph as referenced from a NamedAttributeNode element.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class type
      (Optional) The type represented by this subgraph.

    • Element Detail

      • name

        public abstract String name
        (Required) The name of the subgraph as referenced from a NamedAttributeNode element.

      • attributeNodes

        public abstract NamedAttributeNode[] attributeNodes
        (Required) The list of the attributes of the class that must be included. If the named subgraph corresponds to a subclass of the class referenced by the corresponding attribute node, then only subclass-specific attributes are listed.

      • type

        public abstract Class type
        (Optional) The type represented by this subgraph. The element must be specified when this subgraph is extending a definition on behalf of a subclass.
        Default:
        void.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NonUniqueResultException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class NonUniqueResultException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.NonUniqueResultException
  • All Implemented Interfaces:
    Serializable

    public class NonUniqueResultException
extends PersistenceException
    Thrown by the persistence provider when Query.getSingleResult() or TypedQuery.getSingleResult() is executed on a query and there is more than one result from the query. This exception will not cause the current transaction, if one is active, to be marked for rollback.
    Since:
    Java Persistence 1.0
    See Also:
    Query.getSingleResult(), TypedQuery.getSingleResult(), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NonUniqueResultException()
      Constructs a new NonUniqueResultException exception with null as its detail message.
      NonUniqueResultException(String message)
      Constructs a new NonUniqueResultException exception with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NonUniqueResultException

        public NonUniqueResultException()
        Constructs a new NonUniqueResultException exception with null as its detail message.

      • NonUniqueResultException

        public NonUniqueResultException(String message)
        Constructs a new NonUniqueResultException exception with the specified detail message.
        Parameters:
        message - the detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoResultException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class NoResultException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.NoResultException
  • All Implemented Interfaces:
    Serializable

    public class NoResultException
extends PersistenceException
    Thrown by the persistence provider when Query.getSingleResult() or TypedQuery.getSingleResult()is executed on a query and there is no result to return. This exception will not cause the current transaction, if one is active, to be marked for rollback.
    Since:
    Java Persistence 1.0
    See Also:
    Query.getSingleResult(), TypedQuery.getSingleResult(), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoResultException()
      Constructs a new NoResultException exception with null as its detail message.
      NoResultException(String message)
      Constructs a new NoResultException exception with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoResultException

        public NoResultException()
        Constructs a new NoResultException exception with null as its detail message.

      • NoResultException

        public NoResultException(String message)
        Constructs a new NoResultException exception with the specified detail message.
        Parameters:
        message - the detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


OneToMany (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type OneToMany

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface OneToMany
    Specifies a many-valued association with one-to-many multiplicity.

    If the collection is defined using generics to specify the element type, the associated target entity type need not be specified; otherwise the target entity class must be specified. If the relationship is bidirectional, the mappedBy element must be used to specify the relationship field or property of the entity that is the owner of the relationship.

    The OneToMany annotation may be used within an embeddable class contained within an entity class to specify a relationship to a collection of entities. If the relationship is bidirectional, the mappedBy element must be used to specify the relationship field or property of the entity that is the owner of the relationship. When the collection is a java.util.Map, the cascade element and the orphanRemoval element apply to the map value.

    Example 1: One-to-Many association using generics

    // In Customer class:

    @OneToMany(cascade=ALL, mappedBy="customer")
    public Set<Order> getOrders() { return orders; }

    In Order class:

    @ManyToOne
    @JoinColumn(name="CUST_ID", nullable=false)
    public Customer getCustomer() { return customer; }

    Example 2: One-to-Many association without using generics

    // In Customer class:

    @OneToMany(targetEntity=com.acme.Order.class, cascade=ALL,
                mappedBy="customer")
    public Set getOrders() { return orders; }

    // In Order class:

    @ManyToOne
    @JoinColumn(name="CUST_ID", nullable=false)
    public Customer getCustomer() { return customer; }

    Example 3: Unidirectional One-to-Many association using a foreign key mapping

    // In Customer class:

    @OneToMany(orphanRemoval=true)
    @JoinColumn(name="CUST_ID") // join column is in table for Order
    public Set<Order> getOrders() {return orders;}
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      CascadeType[] cascade
      (Optional) The operations that must be cascaded to the target of the association.
      FetchType fetch
      (Optional) Whether the association should be lazily loaded or must be eagerly fetched.
      String mappedBy
      The field that owns the relationship.
      boolean orphanRemoval
      (Optional) Whether to apply the remove operation to entities that have been removed from the relationship and to cascade the remove operation to those entities.
      Class targetEntity
      (Optional) The entity class that is the target of the association.

    • Element Detail

      • targetEntity

        public abstract Class targetEntity
        (Optional) The entity class that is the target of the association. Optional only if the collection property is defined using Java generics. Must be specified otherwise.

        Defaults to the parameterized type of the collection when defined using generics.

        Default:
        void.class

      • cascade

        public abstract CascadeType[] cascade
        (Optional) The operations that must be cascaded to the target of the association.

        Defaults to no operations being cascaded.

        When the target collection is a java.util.Map, the cascade element applies to the map value.

        Default:
        {}

      • fetch

        public abstract FetchType fetch
        (Optional) Whether the association should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistence provider runtime that the associated entities must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime.
        Default:
        javax.persistence.FetchType.LAZY

      • mappedBy

        public abstract String mappedBy
        The field that owns the relationship. Required unless the relationship is unidirectional.
        Default:
        ""

      • orphanRemoval

        public abstract boolean orphanRemoval
        (Optional) Whether to apply the remove operation to entities that have been removed from the relationship and to cascade the remove operation to those entities.
        Since:
        Java Persistence 2.0
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


OneToOne (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type OneToOne

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface OneToOne
    Specifies a single-valued association to another entity that has one-to-one multiplicity. It is not normally necessary to specify the associated target entity explicitly since it can usually be inferred from the type of the object being referenced. If the relationship is bidirectional, the non-owning side must use the mappedBy element of the OneToOne annotation to specify the relationship field or property of the owning side.

    The OneToOne annotation may be used within an embeddable class to specify a relationship from the embeddable class to an entity class. If the relationship is bidirectional and the entity containing the embeddable class is on the owning side of the relationship, the non-owning side must use the mappedBy element of the OneToOne annotation to specify the relationship field or property of the embeddable class. The dot (".") notation syntax must be used in the mappedBy element to indicate the relationship attribute within the embedded attribute. The value of each identifier used with the dot notation is the name of the respective embedded field or property.

        Example 1: One-to-one association that maps a foreign key column

    // On Customer class:

    @OneToOne(optional=false)
    @JoinColumn(
        name="CUSTREC_ID", unique=true, nullable=false, updatable=false)
    public CustomerRecord getCustomerRecord() { return customerRecord; }

    // On CustomerRecord class:

    @OneToOne(optional=false, mappedBy="customerRecord")
    public Customer getCustomer() { return customer; }

    Example 2: One-to-one association that assumes both the source and target share the same primary key values.

    // On Employee class:

    @Entity
    public class Employee {
        @Id Integer id;

        @OneToOne @MapsId
        EmployeeInfo info;
        ...
    }

    // On EmployeeInfo class:

    @Entity
    public class EmployeeInfo {
        @Id Integer id;
        ...
    }

    Example 3: One-to-one association from an embeddable class to another entity.

    @Entity
    public class Employee {
       @Id int id;
       @Embedded LocationDetails location;
       ...
    }

    @Embeddable
    public class LocationDetails {
       int officeNumber;
       @OneToOne ParkingSpot parkingSpot;
       ...
    }

    @Entity
    public class ParkingSpot {
       @Id int id;
       String garage;
       @OneToOne(mappedBy="location.parkingSpot") Employee assignedTo;
        ...
    }
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      CascadeType[] cascade
      (Optional) The operations that must be cascaded to the target of the association.
      FetchType fetch
      (Optional) Whether the association should be lazily loaded or must be eagerly fetched.
      String mappedBy
      (Optional) The field that owns the relationship.
      boolean optional
      (Optional) Whether the association is optional.
      boolean orphanRemoval
      (Optional) Whether to apply the remove operation to entities that have been removed from the relationship and to cascade the remove operation to those entities.
      Class targetEntity
      (Optional) The entity class that is the target of the association.

    • Element Detail

      • targetEntity

        public abstract Class targetEntity
        (Optional) The entity class that is the target of the association.

        Defaults to the type of the field or property that stores the association.

        Default:
        void.class

      • cascade

        public abstract CascadeType[] cascade
        (Optional) The operations that must be cascaded to the target of the association.

        By default no operations are cascaded.

        Default:
        {}

      • fetch

        public abstract FetchType fetch
        (Optional) Whether the association should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistence provider runtime that the associated entity must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime.
        Default:
        javax.persistence.FetchType.EAGER

      • optional

        public abstract boolean optional
        (Optional) Whether the association is optional. If set to false then a non-null relationship must always exist.
        Default:
        true

      • mappedBy

        public abstract String mappedBy
        (Optional) The field that owns the relationship. This element is only specified on the inverse (non-owning) side of the association.
        Default:
        ""

      • orphanRemoval

        public abstract boolean orphanRemoval
        (Optional) Whether to apply the remove operation to entities that have been removed from the relationship and to cascade the remove operation to those entities.
        Since:
        Java Persistence 2.0
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


OptimisticLockException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class OptimisticLockException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.OptimisticLockException
  • All Implemented Interfaces:
    Serializable

    public class OptimisticLockException
extends PersistenceException
    Thrown by the persistence provider when an optimistic locking conflict occurs. This exception may be thrown as part of an API call, a flush or at commit time. The current transaction, if one is active, will be marked for rollback.
    Since:
    Java Persistence 1.0
    See Also:
    EntityManager.find(Class, Object, LockModeType),
EntityManager.find(Class, Object, LockModeType, java.util.Map),
EntityManager.lock(Object, LockModeType),
EntityManager.lock(Object, LockModeType, java.util.Map),
Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      OptimisticLockException()
      Constructs a new OptimisticLockException exception with null as its detail message.
      OptimisticLockException(Object entity)
      Constructs a new OptimisticLockException exception with the specified entity.
      OptimisticLockException(String message)
      Constructs a new OptimisticLockException exception with the specified detail message.
      OptimisticLockException(String message, Throwable cause)
      Constructs a new OptimisticLockException exception with the specified detail message and cause.
      OptimisticLockException(String message, Throwable cause, Object entity)
      Constructs a new OptimisticLockException exception with the specified detail message, cause, and entity.
      OptimisticLockException(Throwable cause)
      Constructs a new OptimisticLockException exception with the specified cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getEntity()
      Returns the entity that caused this exception.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • OptimisticLockException

        public OptimisticLockException()
        Constructs a new OptimisticLockException exception with null as its detail message.

      • OptimisticLockException

        public OptimisticLockException(String message)
        Constructs a new OptimisticLockException exception with the specified detail message.
        Parameters:
        message - the detail message.

      • OptimisticLockException

        public OptimisticLockException(String message,
                       Throwable cause)
        Constructs a new OptimisticLockException exception with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - the cause.

      • OptimisticLockException

        public OptimisticLockException(Throwable cause)
        Constructs a new OptimisticLockException exception with the specified cause.
        Parameters:
        cause - the cause.

      • OptimisticLockException

        public OptimisticLockException(Object entity)
        Constructs a new OptimisticLockException exception with the specified entity.
        Parameters:
        entity - the entity.

      • OptimisticLockException

        public OptimisticLockException(String message,
                       Throwable cause,
                       Object entity)
        Constructs a new OptimisticLockException exception with the specified detail message, cause, and entity.
        Parameters:
        message - the detail message.
        cause - the cause.
        entity - the entity.

    • Method Detail

      • getEntity

        public Object getEntity()
        Returns the entity that caused this exception.
        Returns:
        the entity.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


OrderBy (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type OrderBy

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface OrderBy
    Specifies the ordering of the elements of a collection valued association or element collection at the point when the association or collection is retrieved.

    The syntax of the value ordering element is an orderby_list, as follows:

        orderby_list::= orderby_item [,orderby_item]*
    orderby_item::= [property_or_field_name] [ASC | DESC]

    If ASC or DESC is not specified, ASC (ascending order) is assumed.

    If the ordering element is not specified for an entity association, ordering by the primary key of the associated entity is assumed.

    The property or field name must correspond to that of a persistent property or field of the associated class or embedded class within it. The properties or fields used in the ordering must correspond to columns for which comparison operators are supported.

    The dot (".") notation is used to refer to an attribute within an embedded attribute. The value of each identifier used with the dot notation is the name of the respective embedded field or property.

    The OrderBy annotation may be applied to an element collection. When OrderBy is applied to an element collection of basic type, the ordering will be by value of the basic objects and the property or field name is not used. When specifying an ordering over an element collection of embeddable type, the dot notation must be used to specify the attribute or attributes that determine the ordering.

    The OrderBy annotation is not used when an order column is specified.

        Example 1:

    @Entity
    public class Course {
       ...
       @ManyToMany
       @OrderBy("lastname ASC")
       public List<Student> getStudents() {...};
       ...
    }

    Example 2:

    @Entity
    public class Student {
       ...
       @ManyToMany(mappedBy="students")
       @OrderBy // ordering by primary key is assumed
       public List<Course> getCourses() {...};
       ...
    }

    Example 3:

    @Entity
    public class Person {
         ...
       @ElementCollection
       @OrderBy("zipcode.zip, zipcode.plusFour")
       public Set<Address> getResidences() {...};
       ...
    }

    @Embeddable
    public class Address {
       protected String street;
       protected String city;
       protected String state;
       @Embedded protected Zipcode zipcode;
    }

    @Embeddable
    public class Zipcode {
       protected String zip;
       protected String plusFour;
    }
    Since:
    Java Persistence 1.0
    See Also:
    OrderColumn

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String value
      An orderby_list.

    • Element Detail

      • value

        public abstract String value
        An orderby_list. Specified as follows:
            orderby_list::= orderby_item [,orderby_item]*
    orderby_item::= [property_or_field_name] [ASC | DESC]

        If ASC or DESC is not specified, ASC (ascending order) is assumed.

        If the ordering element is not specified, ordering by the primary key of the associated entity is assumed.

        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


OrderColumn (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type OrderColumn

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface OrderColumn
    Specifies a column that is used to maintain the persistent order of a list. The persistence provider is responsible for maintaining the order upon retrieval and in the database. The persistence provider is responsible for updating the ordering upon flushing to the database to reflect any insertion, deletion, or reordering affecting the list.

    The OrderColumn annotation is specified on a OneToMany or ManyToMany relationship or on an element collection. The OrderColumn annotation is specified on the side of the relationship that references the collection that is to be ordered. The order column is not visible as part of the state of the entity or embeddable class.

    The OrderBy annotation should be used for ordering that is visible as persistent state and maintained by the application. The OrderBy annotation is not used when OrderColumn is specified.

    The order column must be of integral type. The persistence provider maintains a contiguous (non-sparse) ordering of the values of the order column when updating the association or element collection. The order column value for the first element is 0.

    Example:

    @Entity
    public class CreditCard {

       @Id long ccNumber;

       @OneToMany  // unidirectional
       @OrderColumn
       List<CardTransaction> transactionHistory;
       ...
    }
    Since:
    Java Persistence 2.0
    See Also:
    OrderBy

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String columnDefinition
      (Optional) The SQL fragment that is used when generating the DDL for the column.
      boolean insertable
      (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
      String name
      (Optional) The name of the ordering column.
      boolean nullable
      (Optional) Whether the database column is nullable.
      boolean updatable
      (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the ordering column. Defaults to the concatenation of the name of the referencing property or field; "_"; "ORDER".
        Default:
        ""

      • nullable

        public abstract boolean nullable
        (Optional) Whether the database column is nullable.
        Default:
        true

      • insertable

        public abstract boolean insertable
        (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
        Default:
        true

      • updatable

        public abstract boolean updatable
        (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.
        Default:
        true

      • columnDefinition

        public abstract String columnDefinition
        (Optional) The SQL fragment that is used when generating the DDL for the column. Defaults to generated SQL to create a column of the inferred type.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Parameter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface Parameter<T>

  • Type Parameters:
    T - the type of the parameter
    All Known Subinterfaces:
    ParameterExpression<T>

    public interface Parameter<T>
    Type for query parameter objects.
    Since:
    Java Persistence 2.0
    See Also:
    Query, TypedQuery

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Return the parameter name, or null if the parameter is not a named parameter or no name has been assigned.
      Class<T> getParameterType()
      Return the Java type of the parameter.
      Integer getPosition()
      Return the parameter position, or null if the parameter is not a positional parameter.

    • Method Detail

      • getName

        String getName()
        Return the parameter name, or null if the parameter is not a named parameter or no name has been assigned.
        Returns:
        parameter name

      • getPosition

        Integer getPosition()
        Return the parameter position, or null if the parameter is not a positional parameter.
        Returns:
        position of parameter

      • getParameterType

        Class<T> getParameterType()
        Return the Java type of the parameter. Values bound to the parameter must be assignable to this type. This method is required to be supported for criteria queries only. Applications that use this method for Java Persistence query language queries and native queries will not be portable.
        Returns:
        the Java type of the parameter
        Throws:
        IllegalStateException - if invoked on a parameter obtained from a Java persistence query language query or native query when the implementation does not support this use
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ParameterMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum ParameterMode

  • java.lang.Object
    • java.lang.Enum<ParameterMode>
      • javax.persistence.ParameterMode
  • All Implemented Interfaces:
    Serializable, Comparable<ParameterMode>

    public enum ParameterMode
extends Enum<ParameterMode>
    Specifies the mode of a parameter of a stored procedure query.
    Since:
    Java Persistence 2.1
    See Also:
    StoredProcedureQuery, StoredProcedureParameter

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      IN
      Stored procedure input parameter
      INOUT
      Stored procedure input/output parameter
      OUT
      Stored procedure output parameter
      REF_CURSOR
      Stored procedure reference cursor parameter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ParameterMode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ParameterMode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • IN

        public static final ParameterMode IN
        Stored procedure input parameter

      • INOUT

        public static final ParameterMode INOUT
        Stored procedure input/output parameter

      • OUT

        public static final ParameterMode OUT
        Stored procedure output parameter

      • REF_CURSOR

        public static final ParameterMode REF_CURSOR
        Stored procedure reference cursor parameter. Some databases use REF_CURSOR parameters to return result sets from stored procedures.

    • Method Detail

      • values

        public static ParameterMode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ParameterMode c : ParameterMode.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ParameterMode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Persistence (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class Persistence

  • java.lang.Object
    • javax.persistence.Persistence

  • public class Persistence
extends Object
    Bootstrap class that is used to obtain an EntityManagerFactory in Java SE environments. It may also be used to cause schema generation to occur.

    The Persistence class is available in a Java EE container environment as well; however, support for the Java SE bootstrapping APIs is not required in container environments.

    The Persistence class is used to obtain a PersistenceUtil instance in both Java EE and Java SE environments.

    Since:
    Java Persistence 1.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String PERSISTENCE_PROVIDER
      Deprecated.
      protected static Set<PersistenceProvider> providers
      Deprecated.

    • Constructor Summary

      Constructors
      Constructor and Description
      Persistence()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static EntityManagerFactory createEntityManagerFactory(String persistenceUnitName)
      Create and return an EntityManagerFactory for the named persistence unit.
      static EntityManagerFactory createEntityManagerFactory(String persistenceUnitName, Map properties)
      Create and return an EntityManagerFactory for the named persistence unit using the given properties.
      static void generateSchema(String persistenceUnitName, Map map)
      Create database schemas and/or tables and/or create DDL scripts as determined by the supplied properties.
      static PersistenceUtil getPersistenceUtil()
      Return the PersistenceUtil instance

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • PERSISTENCE_PROVIDER

        @Deprecated
public static final String PERSISTENCE_PROVIDER
        Deprecated.
        This final String is deprecated and should be removed and is only here for TCK backward compatibility
        Since:
        Java Persistence 1.0
        See Also:
        Constant Field Values

      • providers

        @Deprecated
protected static final Set<PersistenceProvider> providers
        Deprecated.
        This instance variable is deprecated and should be removed and is only here for TCK backward compatibility
        Since:
        Java Persistence 1.0

    • Constructor Detail

      • Persistence

        public Persistence()

    • Method Detail

      • createEntityManagerFactory

        public static EntityManagerFactory createEntityManagerFactory(String persistenceUnitName)
        Create and return an EntityManagerFactory for the named persistence unit.
        Parameters:
        persistenceUnitName - the name of the persistence unit
        Returns:
        the factory that creates EntityManagers configured according to the specified persistence unit

      • createEntityManagerFactory

        public static EntityManagerFactory createEntityManagerFactory(String persistenceUnitName,
                                              Map properties)
        Create and return an EntityManagerFactory for the named persistence unit using the given properties.
        Parameters:
        persistenceUnitName - the name of the persistence unit
        properties - Additional properties to use when creating the factory. These properties may include properties to control schema generation. The values of these properties override any values that may have been configured elsewhere.
        Returns:
        the factory that creates EntityManagers configured according to the specified persistence unit.

      • generateSchema

        public static void generateSchema(String persistenceUnitName,
                  Map map)
        Create database schemas and/or tables and/or create DDL scripts as determined by the supplied properties.

        Called when schema generation is to occur as a separate phase from creation of the entity manager factory.

        Parameters:
        persistenceUnitName - the name of the persistence unit
        map - properties for schema generation; these may also contain provider-specific properties. The value of these properties override any values that may have been configured elsewhere..
        Throws:
        PersistenceException - if insufficient or inconsistent configuration information is provided or if schema generation otherwise fails.
        Since:
        Java Persistence 2.1

      • getPersistenceUtil

        public static PersistenceUtil getPersistenceUtil()
        Return the PersistenceUtil instance
        Returns:
        PersistenceUtil instance
        Since:
        Java Persistence 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PersistenceContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PersistenceContext

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface PersistenceContext
    Expresses a dependency on a container-managed EntityManager and its associated persistence context.
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      (Optional) The name by which the entity manager is to be accessed in the environment referencing context; not needed when dependency injection is used.
      PersistenceProperty[] properties
      (Optional) Properties for the container or persistence provider.
      SynchronizationType synchronization
      (Optional) Specifies whether the persistence context is always automatically synchronized with the current transaction or whether the persistence context must be explicitly joined to the current transaction by means of the EntityManager joinTransaction method.
      PersistenceContextType type
      (Optional) Specifies whether a transaction-scoped persistence context or an extended persistence context is to be used.
      String unitName
      (Optional) The name of the persistence unit as defined in the persistence.xml file.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name by which the entity manager is to be accessed in the environment referencing context; not needed when dependency injection is used.
        Default:
        ""

      • unitName

        public abstract String unitName
        (Optional) The name of the persistence unit as defined in the persistence.xml file. If the unitName element is specified, the persistence unit for the entity manager that is accessible in JNDI must have the same name.
        Default:
        ""

      • type

        public abstract PersistenceContextType type
        (Optional) Specifies whether a transaction-scoped persistence context or an extended persistence context is to be used.
        Default:
        javax.persistence.PersistenceContextType.TRANSACTION

      • synchronization

        public abstract SynchronizationType synchronization
        (Optional) Specifies whether the persistence context is always automatically synchronized with the current transaction or whether the persistence context must be explicitly joined to the current transaction by means of the EntityManager joinTransaction method.
        Since:
        Java Persistence 2.1
        Default:
        javax.persistence.SynchronizationType.SYNCHRONIZED

      • properties

        public abstract PersistenceProperty[] properties
        (Optional) Properties for the container or persistence provider. Vendor specific properties may be included in this set of properties. Properties that are not recognized by a vendor are ignored.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PersistenceContexts (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PersistenceContexts

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface PersistenceContexts
    Declares one or more PersistenceContext annotations. It is used to express a dependency on container-managed entity manager persistence contexts.
    Since:
    Java Persistence 1.0
    See Also:
    PersistenceContext

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      PersistenceContext[] value
      (Required) One or more PersistenceContext annotations.

    • Element Detail

      • value

        public abstract PersistenceContext[] value
        (Required) One or more PersistenceContext annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PersistenceContextType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum PersistenceContextType

  • java.lang.Object
    • java.lang.Enum<PersistenceContextType>
      • javax.persistence.PersistenceContextType
  • All Implemented Interfaces:
    Serializable, Comparable<PersistenceContextType>

    public enum PersistenceContextType
extends Enum<PersistenceContextType>
    Specifies whether a transaction-scoped or extended persistence context is to be used in PersistenceContext. If not specified, a transaction-scoped persistence context is used.
    Since:
    Java Persistence 1.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      EXTENDED
      Extended persistence context
      TRANSACTION
      Transaction-scoped persistence context

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static PersistenceContextType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static PersistenceContextType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • TRANSACTION

        public static final PersistenceContextType TRANSACTION
        Transaction-scoped persistence context

      • EXTENDED

        public static final PersistenceContextType EXTENDED
        Extended persistence context

    • Method Detail

      • values

        public static PersistenceContextType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (PersistenceContextType c : PersistenceContextType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static PersistenceContextType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


PersistenceException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class PersistenceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    EntityExistsException, EntityNotFoundException, LockTimeoutException, NonUniqueResultException, NoResultException, OptimisticLockException, PessimisticLockException, QueryTimeoutException, RollbackException, TransactionRequiredException

    public class PersistenceException
extends RuntimeException
    Thrown by the persistence provider when a problem occurs. All instances of PersistenceException except for instances of NoResultException, NonUniqueResultException, LockTimeoutException, and QueryTimeoutException will cause the current transaction, if one is active and the persistence context has been joined to it, to be marked for rollback.
    Since:
    Java Persistence 1.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      PersistenceException()
      Constructs a new PersistenceException exception with null as its detail message.
      PersistenceException(String message)
      Constructs a new PersistenceException exception with the specified detail message.
      PersistenceException(String message, Throwable cause)
      Constructs a new PersistenceException exception with the specified detail message and cause.
      PersistenceException(Throwable cause)
      Constructs a new PersistenceException exception with the specified cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PersistenceException

        public PersistenceException()
        Constructs a new PersistenceException exception with null as its detail message.

      • PersistenceException

        public PersistenceException(String message)
        Constructs a new PersistenceException exception with the specified detail message.
        Parameters:
        message - the detail message.

      • PersistenceException

        public PersistenceException(String message,
                    Throwable cause)
        Constructs a new PersistenceException exception with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - the cause.

      • PersistenceException

        public PersistenceException(Throwable cause)
        Constructs a new PersistenceException exception with the specified cause.
        Parameters:
        cause - the cause.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PersistenceProperty (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PersistenceProperty

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface PersistenceProperty
    Describes a single container or persistence provider property. Used in PersistenceContext.

    Vendor specific properties may be included in the set of properties, and are passed to the persistence provider by the container when the entity manager is created. Properties that are not recognized by a vendor will be ignored.

    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      The name of the property
      String value
      The value of the property

    • Element Detail

      • name

        public abstract String name
        The name of the property

      • value

        public abstract String value
        The value of the property
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PersistenceUnit (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PersistenceUnit

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface PersistenceUnit
    Expresses a dependency on an EntityManagerFactory and its associated persistence unit.
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      (Optional) The name by which the entity manager factory is to be accessed in the environment referencing context; not needed when dependency injection is used.
      String unitName
      (Optional) The name of the persistence unit as defined in the persistence.xml file.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name by which the entity manager factory is to be accessed in the environment referencing context; not needed when dependency injection is used.
        Default:
        ""

      • unitName

        public abstract String unitName
        (Optional) The name of the persistence unit as defined in the persistence.xml file. If specified, the persistence unit for the entity manager factory that is accessible in JNDI must have the same name.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PersistenceUnits (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PersistenceUnits

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface PersistenceUnits
    Declares one or more PersistenceUnit annotations.
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      PersistenceUnit[] value
      (Required) One or more PersistenceUnit annotations.

    • Element Detail

      • value

        public abstract PersistenceUnit[] value
        (Required) One or more PersistenceUnit annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PersistenceUnitUtil (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface PersistenceUnitUtil

  • All Superinterfaces:
    PersistenceUtil

    public interface PersistenceUnitUtil
extends PersistenceUtil
    Utility interface between the application and the persistence provider managing the persistence unit.

    The methods of this interface should only be invoked on entity instances obtained from or managed by entity managers for this persistence unit or on new entity instances.

    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getIdentifier(Object entity)
      Return the id of the entity.
      boolean isLoaded(Object entity)
      Determine the load state of an entity belonging to the persistence unit.
      boolean isLoaded(Object entity, String attributeName)
      Determine the load state of a given persistent attribute of an entity belonging to the persistence unit.

    • Method Detail

      • isLoaded

        boolean isLoaded(Object entity,
               String attributeName)
        Determine the load state of a given persistent attribute of an entity belonging to the persistence unit.
        Specified by:
        isLoaded in interface PersistenceUtil
        Parameters:
        entity - entity instance containing the attribute
        attributeName - name of attribute whose load state is to be determined
        Returns:
        false if entity's state has not been loaded or if the attribute state has not been loaded, else true

      • isLoaded

        boolean isLoaded(Object entity)
        Determine the load state of an entity belonging to the persistence unit. This method can be used to determine the load state of an entity passed as a reference. An entity is considered loaded if all attributes for which FetchType.EAGER has been specified have been loaded.

        The isLoaded(Object, String) method should be used to determine the load state of an attribute. Not doing so might lead to unintended loading of state.

        Specified by:
        isLoaded in interface PersistenceUtil
        Parameters:
        entity - entity instance whose load state is to be determined
        Returns:
        false if the entity has not been loaded, else true

      • getIdentifier

        Object getIdentifier(Object entity)
        Return the id of the entity. A generated id is not guaranteed to be available until after the database insert has occurred. Returns null if the entity does not yet have an id.
        Parameters:
        entity - entity instance
        Returns:
        id of the entity
        Throws:
        IllegalArgumentException - if the object is found not to be an entity
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PersistenceUtil (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface PersistenceUtil

  • All Known Subinterfaces:
    PersistenceUnitUtil

    public interface PersistenceUtil
    Utility interface between the application and the persistence provider(s).

    The PersistenceUtil interface instance obtained from the Persistence class is used to determine the load state of an entity or entity attribute regardless of which persistence provider in the environment created the entity.

    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isLoaded(Object entity)
      Determine the load state of an entity.
      boolean isLoaded(Object entity, String attributeName)
      Determine the load state of a given persistent attribute.

    • Method Detail

      • isLoaded

        boolean isLoaded(Object entity,
               String attributeName)
        Determine the load state of a given persistent attribute.
        Parameters:
        entity - entity containing the attribute
        attributeName - name of attribute whose load state is to be determined
        Returns:
        false if entity's state has not been loaded or if the attribute state has not been loaded, else true

      • isLoaded

        boolean isLoaded(Object entity)
        Determine the load state of an entity. This method can be used to determine the load state of an entity passed as a reference. An entity is considered loaded if all attributes for which FetchType.EAGER has been specified have been loaded.

        The isLoaded(Object, String) method should be used to determine the load state of an attribute. Not doing so might lead to unintended loading of state.

        Parameters:
        entity - whose load state is to be determined
        Returns:
        false if the entity has not been loaded, else true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PessimisticLockException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class PessimisticLockException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.PessimisticLockException
  • All Implemented Interfaces:
    Serializable

    public class PessimisticLockException
extends PersistenceException
    Thrown by the persistence provider when an pessimistic locking conflict occurs. This exception may be thrown as part of an API call, a flush or at commit time. The current transaction, if one is active, will be marked for rollback.
    Since:
    Java Persistence 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      PessimisticLockException()
      Constructs a new PessimisticLockException exception with null as its detail message.
      PessimisticLockException(Object entity)
      Constructs a new PessimisticLockException exception with the specified entity.
      PessimisticLockException(String message)
      Constructs a new PessimisticLockException exception with the specified detail message.
      PessimisticLockException(String message, Throwable cause)
      Constructs a new PessimisticLockException exception with the specified detail message and cause.
      PessimisticLockException(String message, Throwable cause, Object entity)
      Constructs a new PessimisticLockException exception with the specified detail message, cause, and entity.
      PessimisticLockException(Throwable cause)
      Constructs a new PessimisticLockException exception with the specified cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getEntity()
      Returns the entity that caused this exception.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PessimisticLockException

        public PessimisticLockException()
        Constructs a new PessimisticLockException exception with null as its detail message.

      • PessimisticLockException

        public PessimisticLockException(String message)
        Constructs a new PessimisticLockException exception with the specified detail message.
        Parameters:
        message - the detail message.

      • PessimisticLockException

        public PessimisticLockException(String message,
                        Throwable cause)
        Constructs a new PessimisticLockException exception with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - the cause.

      • PessimisticLockException

        public PessimisticLockException(Throwable cause)
        Constructs a new PessimisticLockException exception with the specified cause.
        Parameters:
        cause - the cause.

      • PessimisticLockException

        public PessimisticLockException(Object entity)
        Constructs a new PessimisticLockException exception with the specified entity.
        Parameters:
        entity - the entity.

      • PessimisticLockException

        public PessimisticLockException(String message,
                        Throwable cause,
                        Object entity)
        Constructs a new PessimisticLockException exception with the specified detail message, cause, and entity.
        Parameters:
        message - the detail message.
        cause - the cause.
        entity - the entity.

    • Method Detail

      • getEntity

        public Object getEntity()
        Returns the entity that caused this exception.
        Returns:
        the entity.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PessimisticLockScope (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum PessimisticLockScope

  • java.lang.Object
    • java.lang.Enum<PessimisticLockScope>
      • javax.persistence.PessimisticLockScope
  • All Implemented Interfaces:
    Serializable, Comparable<PessimisticLockScope>

    public enum PessimisticLockScope
extends Enum<PessimisticLockScope>
    Defines the values of the javax.persistence.lock.scope property for pessimistic locking. This property may be passed as an argument to the methods of the EntityManager, Query, and TypedQuery interfaces that allow lock modes to be specified or used with the NamedQuery annotation.
    Since:
    Java Persistence 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      EXTENDED
      In addition to the behavior for PessimisticLockScope.NORMAL, element collections and relationships owned by the entity that are contained in join tables will be locked if the javax.persistence.lock.scope property is specified with a value of PessimisticLockScope.EXTENDED.
      NORMAL
      This value defines the default behavior for pessimistic locking.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static PessimisticLockScope valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static PessimisticLockScope[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NORMAL

        public static final PessimisticLockScope NORMAL
        This value defines the default behavior for pessimistic locking.

        The persistence provider must lock the database row(s) that correspond to the non-collection-valued persistent state of that instance. If a joined inheritance strategy is used, or if the entity is otherwise mapped to a secondary table, this entails locking the row(s) for the entity instance in the additional table(s). Entity relationships for which the locked entity contains the foreign key will also be locked, but not the state of the referenced entities (unless those entities are explicitly locked). Element collections and relationships for which the entity does not contain the foreign key (such as relationships that are mapped to join tables or unidirectional one-to-many relationships for which the target entity contains the foreign key) will not be locked by default.

      • EXTENDED

        public static final PessimisticLockScope EXTENDED
        In addition to the behavior for PessimisticLockScope.NORMAL, element collections and relationships owned by the entity that are contained in join tables will be locked if the javax.persistence.lock.scope property is specified with a value of PessimisticLockScope.EXTENDED. The state of entities referenced by such relationships will not be locked (unless those entities are explicitly locked). Locking such a relationship or element collection generally locks only the rows in the join table or collection table for that relationship or collection. This means that phantoms will be possible.

    • Method Detail

      • values

        public static PessimisticLockScope[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (PessimisticLockScope c : PessimisticLockScope.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static PessimisticLockScope valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


PostLoad (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PostLoad

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PostLoad
    Specifies a callback method for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PostPersist (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PostPersist

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PostPersist
    Specifies a callback method for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PostRemove (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PostRemove

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PostRemove
    Specifies a callback method for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PostUpdate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PostUpdate

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PostUpdate
    Specifies a callback method for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PrePersist (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PrePersist

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PrePersist
    Specifies a callback method for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PreRemove (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PreRemove

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PreRemove
    Specifies a callback method for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PreUpdate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PreUpdate

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PreUpdate
    Specifies a callback method for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PrimaryKeyJoinColumn (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PrimaryKeyJoinColumn

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface PrimaryKeyJoinColumn
    Specifies a primary key column that is used as a foreign key to join to another table.

    It is used to join the primary table of an entity subclass in the JOINED mapping strategy to the primary table of its superclass; it is used within a SecondaryTable annotation to join a secondary table to a primary table; and it may be used in a OneToOne mapping in which the primary key of the referencing entity is used as a foreign key to the referenced entity.

    If no PrimaryKeyJoinColumn annotation is specified for a subclass in the JOINED mapping strategy, the foreign key columns are assumed to have the same names as the primary key columns of the primary table of the superclass.

    Example: Customer and ValuedCustomer subclass

    @Entity
    @Table(name="CUST")
    @Inheritance(strategy=JOINED)
    @DiscriminatorValue("CUST")
    public class Customer { ... }

    @Entity
    @Table(name="VCUST")
    @DiscriminatorValue("VCUST")
    @PrimaryKeyJoinColumn(name="CUST_ID")
    public class ValuedCustomer extends Customer { ... }
    Since:
    Java Persistence 1.0
    See Also:
    SecondaryTable, Inheritance, OneToOne, ForeignKey

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String columnDefinition
      (Optional) The SQL fragment that is used when generating the DDL for the column.
      ForeignKey foreignKey
      (Optional) Used to specify or control the generation of a foreign key constraint for the primary key join column when table generation is in effect.
      String name
      (Optional) The name of the primary key column of the current table.
      String referencedColumnName
      (Optional) The name of the primary key column of the table being joined to.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the primary key column of the current table.

        Defaults to the same name as the primary key column of the primary table of the superclass (JOINED mapping strategy); the same name as the primary key column of the primary table (SecondaryTable mapping); or the same name as the primary key column for the table for the referencing entity (OneToOne mapping).

        Default:
        ""

      • referencedColumnName

        public abstract String referencedColumnName
        (Optional) The name of the primary key column of the table being joined to.

        Defaults to the same name as the primary key column of the primary table of the superclass (JOINED mapping strategy); the same name as the primary key column of the primary table (SecondaryTable mapping); or the same name as the primary key column for the table for the referencing entity (OneToOne mapping).

        Default:
        ""

      • columnDefinition

        public abstract String columnDefinition
        (Optional) The SQL fragment that is used when generating the DDL for the column. This should not be specified for a OneToOne primary key association.

        Defaults to the generated SQL to create a column of the inferred type.

        Default:
        ""

      • foreignKey

        public abstract ForeignKey foreignKey
        (Optional) Used to specify or control the generation of a foreign key constraint for the primary key join column when table generation is in effect. If this element is not specified, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PrimaryKeyJoinColumns (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type PrimaryKeyJoinColumns

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface PrimaryKeyJoinColumns
    Groups PrimaryKeyJoinColumn annotations. It is used to map composite foreign keys.
        Example: ValuedCustomer subclass

    @Entity
    @Table(name="VCUST")
    @DiscriminatorValue("VCUST")
    @PrimaryKeyJoinColumns({
        @PrimaryKeyJoinColumn(name="CUST_ID",
            referencedColumnName="ID"),
        @PrimaryKeyJoinColumn(name="CUST_TYPE",
            referencedColumnName="TYPE")
    })
    public class ValuedCustomer extends Customer { ... }
    Since:
    Java Persistence 1.0
    See Also:
    ForeignKey

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      PrimaryKeyJoinColumn[] value
      One or more PrimaryKeyJoinColumn annotations.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      ForeignKey foreignKey
      (Optional) Used to specify or control the generation of a foreign key constraint when table generation is in effect.

    • Element Detail

      • value

        public abstract PrimaryKeyJoinColumn[] value
        One or more PrimaryKeyJoinColumn annotations.

      • foreignKey

        public abstract ForeignKey foreignKey
        (Optional) Used to specify or control the generation of a foreign key constraint when table generation is in effect. If both this element and the foreignKey element of any of the PrimaryKeyJoinColumn elements are specified, the behavior is undefined. If no foreign key annotation element is specified in either location, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Query (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface Query

  • All Known Subinterfaces:
    StoredProcedureQuery, TypedQuery<X>

    public interface Query
    Interface used to control query execution.
    Since:
    Java Persistence 1.0
    See Also:
    TypedQuery, StoredProcedureQuery, Parameter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int executeUpdate()
      Execute an update or delete statement.
      int getFirstResult()
      The position of the first result the query object was set to retrieve.
      FlushModeType getFlushMode()
      Get the flush mode in effect for the query execution.
      Map<String,Object> getHints()
      Get the properties and hints and associated values that are in effect for the query instance.
      LockModeType getLockMode()
      Get the current lock mode for the query.
      int getMaxResults()
      The maximum number of results the query object was set to retrieve.
      Parameter<?> getParameter(int position)
      Get the parameter object corresponding to the declared positional parameter with the given position.
      <T> Parameter<T> getParameter(int position, Class<T> type)
      Get the parameter object corresponding to the declared positional parameter with the given position and type.
      Parameter<?> getParameter(String name)
      Get the parameter object corresponding to the declared parameter of the given name.
      <T> Parameter<T> getParameter(String name, Class<T> type)
      Get the parameter object corresponding to the declared parameter of the given name and type.
      Set<Parameter<?>> getParameters()
      Get the parameter objects corresponding to the declared parameters of the query.
      Object getParameterValue(int position)
      Return the input value bound to the positional parameter.
      <T> T getParameterValue(Parameter<T> param)
      Return the input value bound to the parameter.
      Object getParameterValue(String name)
      Return the input value bound to the named parameter.
      List getResultList()
      Execute a SELECT query and return the query results as an untyped List.
      Object getSingleResult()
      Execute a SELECT query that returns a single untyped result.
      boolean isBound(Parameter<?> param)
      Return a boolean indicating whether a value has been bound to the parameter.
      Query setFirstResult(int startPosition)
      Set the position of the first result to retrieve.
      Query setFlushMode(FlushModeType flushMode)
      Set the flush mode type to be used for the query execution.
      Query setHint(String hintName, Object value)
      Set a query property or hint.
      Query setLockMode(LockModeType lockMode)
      Set the lock mode type to be used for the query execution.
      Query setMaxResults(int maxResult)
      Set the maximum number of results to retrieve.
      Query setParameter(int position, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a positional parameter.
      Query setParameter(int position, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a positional parameter.
      Query setParameter(int position, Object value)
      Bind an argument value to a positional parameter.
      Query setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      Query setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      <T> Query setParameter(Parameter<T> param, T value)
      Bind the value of a Parameter object.
      Query setParameter(String name, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a named parameter.
      Query setParameter(String name, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a named parameter.
      Query setParameter(String name, Object value)
      Bind an argument value to a named parameter.
      <T> T unwrap(Class<T> cls)
      Return an object of the specified type to allow access to the provider-specific API.

    • Method Detail

      • getResultList

        List getResultList()
        Execute a SELECT query and return the query results as an untyped List.
        Returns:
        a list of the results
        Throws:
        IllegalStateException - if called for a Java Persistence query language UPDATE or DELETE statement
        QueryTimeoutException - if the query execution exceeds the query timeout value set and only the statement is rolled back
        TransactionRequiredException - if a lock mode other than NONE has been set and there is no transaction or the persistence context has not been joined to the transaction
        PessimisticLockException - if pessimistic locking fails and the transaction is rolled back
        LockTimeoutException - if pessimistic locking fails and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back

      • getSingleResult

        Object getSingleResult()
        Execute a SELECT query that returns a single untyped result.
        Returns:
        the result
        Throws:
        NoResultException - if there is no result
        NonUniqueResultException - if more than one result
        IllegalStateException - if called for a Java Persistence query language UPDATE or DELETE statement
        QueryTimeoutException - if the query execution exceeds the query timeout value set and only the statement is rolled back
        TransactionRequiredException - if a lock mode other than NONE has been set and there is no transaction or the persistence context has not been joined to the transaction
        PessimisticLockException - if pessimistic locking fails and the transaction is rolled back
        LockTimeoutException - if pessimistic locking fails and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back

      • executeUpdate

        int executeUpdate()
        Execute an update or delete statement.
        Returns:
        the number of entities updated or deleted
        Throws:
        IllegalStateException - if called for a Java Persistence query language SELECT statement or for a criteria query
        TransactionRequiredException - if there is no transaction or the persistence context has not been joined to the transaction
        QueryTimeoutException - if the statement execution exceeds the query timeout value set and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back

      • setMaxResults

        Query setMaxResults(int maxResult)
        Set the maximum number of results to retrieve.
        Parameters:
        maxResult - maximum number of results to retrieve
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the argument is negative

      • getMaxResults

        int getMaxResults()
        The maximum number of results the query object was set to retrieve. Returns Integer.MAX_VALUE if setMaxResults was not applied to the query object.
        Returns:
        maximum number of results
        Since:
        Java Persistence 2.0

      • setFirstResult

        Query setFirstResult(int startPosition)
        Set the position of the first result to retrieve.
        Parameters:
        startPosition - position of the first result, numbered from 0
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the argument is negative

      • getFirstResult

        int getFirstResult()
        The position of the first result the query object was set to retrieve. Returns 0 if setFirstResult was not applied to the query object.
        Returns:
        position of the first result
        Since:
        Java Persistence 2.0

      • setHint

        Query setHint(String hintName,
            Object value)
        Set a query property or hint. The hints elements may be used to specify query properties and hints. Properties defined by this specification must be observed by the provider. Vendor-specific hints that are not recognized by a provider must be silently ignored. Portable applications should not rely on the standard timeout hint. Depending on the database in use and the locking mechanisms used by the provider, this hint may or may not be observed.
        Parameters:
        hintName - name of the property or hint
        value - value for the property or hint
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the second argument is not valid for the implementation

      • getHints

        Map<String,Object> getHints()
        Get the properties and hints and associated values that are in effect for the query instance.
        Returns:
        query properties and hints
        Since:
        Java Persistence 2.0

      • setParameter

        <T> Query setParameter(Parameter<T> param,
                     T value)
        Bind the value of a Parameter object.
        Parameters:
        param - parameter object
        value - parameter value
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter does not correspond to a parameter of the query
        Since:
        Java Persistence 2.0

      • setParameter

        Query setParameter(Parameter<Calendar> param,
                 Calendar value,
                 TemporalType temporalType)
        Bind an instance of java.util.Calendar to a Parameter object.
        Parameters:
        param - parameter object
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter does not correspond to a parameter of the query
        Since:
        Java Persistence 2.0

      • setParameter

        Query setParameter(Parameter<Date> param,
                 Date value,
                 TemporalType temporalType)
        Bind an instance of java.util.Date to a Parameter object.
        Parameters:
        param - parameter object
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter does not correspond to a parameter of the query
        Since:
        Java Persistence 2.0

      • setParameter

        Query setParameter(String name,
                 Object value)
        Bind an argument value to a named parameter.
        Parameters:
        name - parameter name
        value - parameter value
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter name does not correspond to a parameter of the query or if the argument is of incorrect type

      • setParameter

        Query setParameter(String name,
                 Calendar value,
                 TemporalType temporalType)
        Bind an instance of java.util.Calendar to a named parameter.
        Parameters:
        name - parameter name
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter name does not correspond to a parameter of the query or if the value argument is of incorrect type

      • setParameter

        Query setParameter(String name,
                 Date value,
                 TemporalType temporalType)
        Bind an instance of java.util.Date to a named parameter.
        Parameters:
        name - parameter name
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter name does not correspond to a parameter of the query or if the value argument is of incorrect type

      • setParameter

        Query setParameter(int position,
                 Object value)
        Bind an argument value to a positional parameter.
        Parameters:
        position - position
        value - parameter value
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if position does not correspond to a positional parameter of the query or if the argument is of incorrect type

      • setParameter

        Query setParameter(int position,
                 Calendar value,
                 TemporalType temporalType)
        Bind an instance of java.util.Calendar to a positional parameter.
        Parameters:
        position - position
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if position does not correspond to a positional parameter of the query or if the value argument is of incorrect type

      • setParameter

        Query setParameter(int position,
                 Date value,
                 TemporalType temporalType)
        Bind an instance of java.util.Date to a positional parameter.
        Parameters:
        position - position
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if position does not correspond to a positional parameter of the query or if the value argument is of incorrect type

      • getParameters

        Set<Parameter<?>> getParameters()
        Get the parameter objects corresponding to the declared parameters of the query. Returns empty set if the query has no parameters. This method is not required to be supported for native queries.
        Returns:
        set of the parameter objects
        Throws:
        IllegalStateException - if invoked on a native query when the implementation does not support this use
        Since:
        Java Persistence 2.0

      • getParameter

        Parameter<?> getParameter(String name)
        Get the parameter object corresponding to the declared parameter of the given name. This method is not required to be supported for native queries.
        Parameters:
        name - parameter name
        Returns:
        parameter object
        Throws:
        IllegalArgumentException - if the parameter of the specified name does not exist
        IllegalStateException - if invoked on a native query when the implementation does not support this use
        Since:
        Java Persistence 2.0

      • getParameter

        <T> Parameter<T> getParameter(String name,
                            Class<T> type)
        Get the parameter object corresponding to the declared parameter of the given name and type. This method is required to be supported for criteria queries only.
        Parameters:
        name - parameter name
        type - type
        Returns:
        parameter object
        Throws:
        IllegalArgumentException - if the parameter of the specified name does not exist or is not assignable to the type
        IllegalStateException - if invoked on a native query or Java Persistence query language query when the implementation does not support this use
        Since:
        Java Persistence 2.0

      • getParameter

        Parameter<?> getParameter(int position)
        Get the parameter object corresponding to the declared positional parameter with the given position. This method is not required to be supported for native queries.
        Parameters:
        position - position
        Returns:
        parameter object
        Throws:
        IllegalArgumentException - if the parameter with the specified position does not exist
        IllegalStateException - if invoked on a native query when the implementation does not support this use
        Since:
        Java Persistence 2.0

      • getParameter

        <T> Parameter<T> getParameter(int position,
                            Class<T> type)
        Get the parameter object corresponding to the declared positional parameter with the given position and type. This method is not required to be supported by the provider.
        Parameters:
        position - position
        type - type
        Returns:
        parameter object
        Throws:
        IllegalArgumentException - if the parameter with the specified position does not exist or is not assignable to the type
        IllegalStateException - if invoked on a native query or Java Persistence query language query when the implementation does not support this use
        Since:
        Java Persistence 2.0

      • isBound

        boolean isBound(Parameter<?> param)
        Return a boolean indicating whether a value has been bound to the parameter.
        Parameters:
        param - parameter object
        Returns:
        boolean indicating whether parameter has been bound
        Since:
        Java Persistence 2.0

      • getParameterValue

        <T> T getParameterValue(Parameter<T> param)
        Return the input value bound to the parameter. (Note that OUT parameters are unbound.)
        Parameters:
        param - parameter object
        Returns:
        parameter value
        Throws:
        IllegalArgumentException - if the parameter is not a parameter of the query
        IllegalStateException - if the parameter has not been been bound
        Since:
        Java Persistence 2.0

      • getParameterValue

        Object getParameterValue(String name)
        Return the input value bound to the named parameter. (Note that OUT parameters are unbound.)
        Parameters:
        name - parameter name
        Returns:
        parameter value
        Throws:
        IllegalStateException - if the parameter has not been been bound
        IllegalArgumentException - if the parameter of the specified name does not exist
        Since:
        Java Persistence 2.0

      • getParameterValue

        Object getParameterValue(int position)
        Return the input value bound to the positional parameter. (Note that OUT parameters are unbound.)
        Parameters:
        position - position
        Returns:
        parameter value
        Throws:
        IllegalStateException - if the parameter has not been been bound
        IllegalArgumentException - if the parameter with the specified position does not exist
        Since:
        Java Persistence 2.0

      • setFlushMode

        Query setFlushMode(FlushModeType flushMode)
        Set the flush mode type to be used for the query execution. The flush mode type applies to the query regardless of the flush mode type in use for the entity manager.
        Parameters:
        flushMode - flush mode
        Returns:
        the same query instance

      • getFlushMode

        FlushModeType getFlushMode()
        Get the flush mode in effect for the query execution. If a flush mode has not been set for the query object, returns the flush mode in effect for the entity manager.
        Returns:
        flush mode
        Since:
        Java Persistence 2.0

      • setLockMode

        Query setLockMode(LockModeType lockMode)
        Set the lock mode type to be used for the query execution.
        Parameters:
        lockMode - lock mode
        Returns:
        the same query instance
        Throws:
        IllegalStateException - if the query is found not to be a Java Persistence query language SELECT query or a CriteriaQuery query
        Since:
        Java Persistence 2.0

      • getLockMode

        LockModeType getLockMode()
        Get the current lock mode for the query. Returns null if a lock mode has not been set on the query object.
        Returns:
        lock mode
        Throws:
        IllegalStateException - if the query is found not to be a Java Persistence query language SELECT query or a Criteria API query
        Since:
        Java Persistence 2.0

      • unwrap

        <T> T unwrap(Class<T> cls)
        Return an object of the specified type to allow access to the provider-specific API. If the provider's query implementation does not support the specified class, the PersistenceException is thrown.
        Parameters:
        cls - the class of the object to be returned. This is normally either the underlying query implementation class or an interface that it implements.
        Returns:
        an instance of the specified class
        Throws:
        PersistenceException - if the provider does not support the call
        Since:
        Java Persistence 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QueryHint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type QueryHint

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface QueryHint
    Used to supply a query property or hint to the NamedQuery or NamedNativeQuery annotation.

    Vendor-specific hints that are not recognized by a provider are ignored.

    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      Name of the hint.
      String value
      Value of the hint.

    • Element Detail

      • name

        public abstract String name
        Name of the hint.

      • value

        public abstract String value
        Value of the hint.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


QueryTimeoutException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class QueryTimeoutException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.QueryTimeoutException
  • All Implemented Interfaces:
    Serializable

    public class QueryTimeoutException
extends PersistenceException
    Thrown by the persistence provider when a query times out and only the statement is rolled back. The current transaction, if one is active, will be not be marked for rollback.
    Since:
    Java Persistence 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      QueryTimeoutException()
      Constructs a new QueryTimeoutException exception with null as its detail message.
      QueryTimeoutException(Query query)
      Constructs a new QueryTimeoutException exception with the specified query.
      QueryTimeoutException(String message)
      Constructs a new QueryTimeoutException exception with the specified detail message.
      QueryTimeoutException(String message, Throwable cause)
      Constructs a new QueryTimeoutException exception with the specified detail message and cause.
      QueryTimeoutException(String message, Throwable cause, Query query)
      Constructs a new QueryTimeoutException exception with the specified detail message, cause, and query.
      QueryTimeoutException(Throwable cause)
      Constructs a new QueryTimeoutException exception with the specified cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Query getQuery()
      Returns the query that caused this exception.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • QueryTimeoutException

        public QueryTimeoutException()
        Constructs a new QueryTimeoutException exception with null as its detail message.

      • QueryTimeoutException

        public QueryTimeoutException(String message)
        Constructs a new QueryTimeoutException exception with the specified detail message.
        Parameters:
        message - the detail message.

      • QueryTimeoutException

        public QueryTimeoutException(String message,
                     Throwable cause)
        Constructs a new QueryTimeoutException exception with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - the cause.

      • QueryTimeoutException

        public QueryTimeoutException(Throwable cause)
        Constructs a new QueryTimeoutException exception with the specified cause.
        Parameters:
        cause - the cause.

      • QueryTimeoutException

        public QueryTimeoutException(Query query)
        Constructs a new QueryTimeoutException exception with the specified query.
        Parameters:
        query - the query.

      • QueryTimeoutException

        public QueryTimeoutException(String message,
                     Throwable cause,
                     Query query)
        Constructs a new QueryTimeoutException exception with the specified detail message, cause, and query.
        Parameters:
        message - the detail message.
        cause - the cause.
        query - the query.

    • Method Detail

      • getQuery

        public Query getQuery()
        Returns the query that caused this exception.
        Returns:
        the query.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RollbackException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class RollbackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.RollbackException
  • All Implemented Interfaces:
    Serializable

    public class RollbackException
extends PersistenceException
    Thrown by the persistence provider when EntityTransaction.commit() fails.
    Since:
    Java Persistence 1.0
    See Also:
    EntityTransaction.commit(), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      RollbackException()
      Constructs a new RollbackException exception with null as its detail message.
      RollbackException(String message)
      Constructs a new RollbackException exception with the specified detail message.
      RollbackException(String message, Throwable cause)
      Constructs a new RollbackException exception with the specified detail message and cause.
      RollbackException(Throwable cause)
      Constructs a new RollbackException exception with the specified cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • RollbackException

        public RollbackException()
        Constructs a new RollbackException exception with null as its detail message.

      • RollbackException

        public RollbackException(String message)
        Constructs a new RollbackException exception with the specified detail message.
        Parameters:
        message - the detail message.

      • RollbackException

        public RollbackException(String message,
                 Throwable cause)
        Constructs a new RollbackException exception with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - the cause.

      • RollbackException

        public RollbackException(Throwable cause)
        Constructs a new RollbackException exception with the specified cause.
        Parameters:
        cause - the cause.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SecondaryTable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type SecondaryTable

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SecondaryTable
    Specifies a secondary table for the annotated entity class. Specifying one or more secondary tables indicates that the data for the entity class is stored across multiple tables.

    If no SecondaryTable annotation is specified, it is assumed that all persistent fields or properties of the entity are mapped to the primary table. If no primary key join columns are specified, the join columns are assumed to reference the primary key columns of the primary table, and have the same names and types as the referenced primary key columns of the primary table.

        Example 1: Single secondary table with a single primary key column.

    @Entity
    @Table(name="CUSTOMER")
    @SecondaryTable(name="CUST_DETAIL",
        pkJoinColumns=@PrimaryKeyJoinColumn(name="CUST_ID"))
    public class Customer { ... }

    Example 2: Single secondary table with multiple primary key columns.

    @Entity
    @Table(name="CUSTOMER")
    @SecondaryTable(name="CUST_DETAIL",
        pkJoinColumns={
            @PrimaryKeyJoinColumn(name="CUST_ID"),
            @PrimaryKeyJoinColumn(name="CUST_TYPE")})
    public class Customer { ... }
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      (Required) The name of the table.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String catalog
      (Optional) The catalog of the table.
      ForeignKey foreignKey
      (Optional) Used to specify or control the generation of a foreign key constraint for the columns corresponding to the pkJoinColumns element when table generation is in effect.
      Index[] indexes
      (Optional) Indexes for the table.
      PrimaryKeyJoinColumn[] pkJoinColumns
      (Optional) The columns that are used to join with the primary table.
      String schema
      (Optional) The schema of the table.
      UniqueConstraint[] uniqueConstraints
      (Optional) Unique constraints that are to be placed on the table.

    • Element Detail

      • name

        public abstract String name
        (Required) The name of the table.

      • catalog

        public abstract String catalog
        (Optional) The catalog of the table.

        Defaults to the default catalog.

        Default:
        ""

      • schema

        public abstract String schema
        (Optional) The schema of the table.

        Defaults to the default schema for user.

        Default:
        ""

      • pkJoinColumns

        public abstract PrimaryKeyJoinColumn[] pkJoinColumns
        (Optional) The columns that are used to join with the primary table.

        Defaults to the column(s) of the same name(s) as the primary key column(s) in the primary table.

        Default:
        {}

      • foreignKey

        public abstract ForeignKey foreignKey
        (Optional) Used to specify or control the generation of a foreign key constraint for the columns corresponding to the pkJoinColumns element when table generation is in effect. If both this element and the foreignKey element of any of the pkJoinColumns elements are specified, the behavior is undefined. If no foreign key annotation element is specified in either location, the persistence provider's default foreign key strategy will apply.
        Since:
        Java Persistence 2.1
        Default:
        @javax.persistence.ForeignKey(javax.persistence.ConstraintMode.PROVIDER_DEFAULT)

      • uniqueConstraints

        public abstract UniqueConstraint[] uniqueConstraints
        (Optional) Unique constraints that are to be placed on the table. These are typically only used if table generation is in effect. These constraints apply in addition to any constraints specified by the Column and JoinColumn annotations and constraints entailed by primary key mappings.

        Defaults to no additional constraints.

        Default:
        {}

      • indexes

        public abstract Index[] indexes
        (Optional) Indexes for the table. These are only used if table generation is in effect.
        Since:
        Java Persistence 2.1
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


SecondaryTables (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type SecondaryTables

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SecondaryTables
    Specifies multiple secondary tables for an entity.
        Example 1: Multiple secondary tables assuming primary key columns are named the same in all tables.

    @Entity
    @Table(name="EMPLOYEE")
    @SecondaryTables({
        @SecondaryTable(name="EMP_DETAIL"),
        @SecondaryTable(name="EMP_HIST")
    })
    public class Employee { ... }

    Example 2: Multiple secondary tables with differently named primary key columns.

    @Entity
    @Table(name="EMPLOYEE")
    @SecondaryTables({
        @SecondaryTable(name="EMP_DETAIL",
            pkJoinColumns=@PrimaryKeyJoinColumn(name="EMPL_ID")),
        @SecondaryTable(name="EMP_HIST",
            pkJoinColumns=@PrimaryKeyJoinColumn(name="EMPLOYEE_ID"))
    })
    public class Employee { ... }
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      SecondaryTable[] value
      (Required) The secondary tables for an entity.

    • Element Detail

      • value

        public abstract SecondaryTable[] value
        (Required) The secondary tables for an entity.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


SequenceGenerator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type SequenceGenerator

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface SequenceGenerator
    Defines a primary key generator that may be referenced by name when a generator element is specified for the GeneratedValue annotation. A sequence generator may be specified on the entity class or on the primary key field or property. The scope of the generator name is global to the persistence unit (across all generator types).
       Example:

   @SequenceGenerator(name="EMP_SEQ", allocationSize=25)
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      (Required) A unique generator name that can be referenced by one or more classes to be the generator for primary key values.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      int allocationSize
      (Optional) The amount to increment by when allocating sequence numbers from the sequence.
      String catalog
      (Optional) The catalog of the sequence generator.
      int initialValue
      (Optional) The value from which the sequence object is to start generating.
      String schema
      (Optional) The schema of the sequence generator.
      String sequenceName
      (Optional) The name of the database sequence object from which to obtain primary key values.

    • Element Detail

      • name

        public abstract String name
        (Required) A unique generator name that can be referenced by one or more classes to be the generator for primary key values.

      • sequenceName

        public abstract String sequenceName
        (Optional) The name of the database sequence object from which to obtain primary key values.

        Defaults to a provider-chosen value.

        Default:
        ""

      • catalog

        public abstract String catalog
        (Optional) The catalog of the sequence generator.
        Since:
        Java Persistence 2.0
        Default:
        ""

      • schema

        public abstract String schema
        (Optional) The schema of the sequence generator.
        Since:
        Java Persistence 2.0
        Default:
        ""

      • initialValue

        public abstract int initialValue
        (Optional) The value from which the sequence object is to start generating.
        Default:
        1

      • allocationSize

        public abstract int allocationSize
        (Optional) The amount to increment by when allocating sequence numbers from the sequence.
        Default:
        50
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


SharedCacheMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum SharedCacheMode

  • java.lang.Object
    • java.lang.Enum<SharedCacheMode>
      • javax.persistence.SharedCacheMode
  • All Implemented Interfaces:
    Serializable, Comparable<SharedCacheMode>

    public enum SharedCacheMode
extends Enum<SharedCacheMode>
    Specifies how the provider must use a second-level cache for the persistence unit. Corresponds to the value of the persistence.xml shared-cache-mode element, and returned as the result of PersistenceUnitInfo.getSharedCacheMode().
    Since:
    Java Persistence 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ALL
      All entities and entity-related state and data are cached.
      DISABLE_SELECTIVE
      Caching is enabled for all entities except those for which Cacheable(false) is specified.
      ENABLE_SELECTIVE
      Caching is enabled for all entities for Cacheable(true) is specified.
      NONE
      Caching is disabled for the persistence unit.
      UNSPECIFIED
      Caching behavior is undefined: provider-specific defaults may apply.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static SharedCacheMode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SharedCacheMode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ALL

        public static final SharedCacheMode ALL
        All entities and entity-related state and data are cached.

      • NONE

        public static final SharedCacheMode NONE
        Caching is disabled for the persistence unit.

      • ENABLE_SELECTIVE

        public static final SharedCacheMode ENABLE_SELECTIVE
        Caching is enabled for all entities for Cacheable(true) is specified. All other entities are not cached.

      • DISABLE_SELECTIVE

        public static final SharedCacheMode DISABLE_SELECTIVE
        Caching is enabled for all entities except those for which Cacheable(false) is specified. Entities for which Cacheable(false) is specified are not cached.

      • UNSPECIFIED

        public static final SharedCacheMode UNSPECIFIED
        Caching behavior is undefined: provider-specific defaults may apply.

    • Method Detail

      • values

        public static SharedCacheMode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SharedCacheMode c : SharedCacheMode.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SharedCacheMode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


SqlResultSetMapping (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type SqlResultSetMapping

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SqlResultSetMapping
    Specifies the mapping of the result of a native SQL query or stored procedure.
        Example:

    Query q = em.createNativeQuery(
        "SELECT o.id AS order_id, " +
            "o.quantity AS order_quantity, " +
            "o.item AS order_item, " +
            "i.name AS item_name, " +
        "FROM Order o, Item i " +
        "WHERE (order_quantity > 25) AND (order_item = i.id)",
    "OrderResults");

    @SqlResultSetMapping(name="OrderResults",
        entities={
            @EntityResult(entityClass=com.acme.Order.class, fields={
                @FieldResult(name="id", column="order_id"),
                @FieldResult(name="quantity", column="order_quantity"),
                @FieldResult(name="item", column="order_item")})},
        columns={
            @ColumnResult(name="item_name")}
    )
    Since:
    Java Persistence 1.0
    See Also:
    Query, StoredProcedureQuery, NamedNativeQuery, NamedStoredProcedureQuery

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      The name given to the result set mapping, and used to refer to it in the methods of the Query and StoredProcedureQuery APIs.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      ConstructorResult[] classes
      Specifies the result set mapping to constructors.
      ColumnResult[] columns
      Specifies the result set mapping to scalar values.
      EntityResult[] entities
      Specifies the result set mapping to entities.

    • Element Detail

      • name

        public abstract String name
        The name given to the result set mapping, and used to refer to it in the methods of the Query and StoredProcedureQuery APIs.

      • entities

        public abstract EntityResult[] entities
        Specifies the result set mapping to entities.
        Default:
        {}

      • classes

        public abstract ConstructorResult[] classes
        Specifies the result set mapping to constructors.
        Since:
        Java Persistence 2.1
        Default:
        {}

      • columns

        public abstract ColumnResult[] columns
        Specifies the result set mapping to scalar values.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


SqlResultSetMappings (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type SqlResultSetMappings

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SqlResultSetMappings
    Is used to define one or more SqlResultSetMapping annotations.
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      SqlResultSetMapping[] value
      One or more SqlResultSetMapping annotations.

    • Element Detail

      • value

        public abstract SqlResultSetMapping[] value
        One or more SqlResultSetMapping annotations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


StoredProcedureParameter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type StoredProcedureParameter

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface StoredProcedureParameter
    Specifies a parameter of a named stored procedure query. All parameters of a named stored procedure query must be specified.
    Since:
    Java Persistence 2.1
    See Also:
    NamedStoredProcedureQuery, ParameterMode

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class type
      JDBC type of the paramter.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      ParameterMode mode
      Specifies whether the parameter is an IN, INOUT, OUT, or REF_CURSOR parameter.
      String name
      The name of the parameter as defined by the stored procedure in the database.

    • Element Detail

      • type

        public abstract Class type
        JDBC type of the paramter.

      • name

        public abstract String name
        The name of the parameter as defined by the stored procedure in the database. If a name is not specified, it is assumed that the stored procedure uses positional parameters.
        Default:
        ""

      • mode

        public abstract ParameterMode mode
        Specifies whether the parameter is an IN, INOUT, OUT, or REF_CURSOR parameter. REF_CURSOR parameters are used by some databases to return result sets from a stored procedure.
        Default:
        javax.persistence.ParameterMode.IN
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


StoredProcedureQuery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface StoredProcedureQuery

  • All Superinterfaces:
    Query

    public interface StoredProcedureQuery
extends Query
    Interface used to control stored procedure query execution.

    Stored procedure query execution may be controlled in accordance with the following:

    • The setParameter methods are used to set the values of all required IN and INOUT parameters. It is not required to set the values of stored procedure parameters for which default values have been defined by the stored procedure.
    • When getResultList and getSingleResult are called on a StoredProcedureQuery object, the provider will call execute on an unexecuted stored procedure query before processing getResultList or getSingleResult.
    • When executeUpdate is called on a StoredProcedureQuery object, the provider will call execute on an unexecuted stored procedure query followed by getUpdateCount. The results of executeUpdate will be those of getUpdateCount.
    • The execute method supports both the simple case where scalar results are passed back only via INOUT and OUT parameters as well as the most general case (multiple result sets and/or update counts, possibly also in combination with output parameter values).
    • The execute method returns true if the first result is a result set, and false if it is an update count or there are no results other than through INOUT and OUT parameters, if any.
    • If the execute method returns true, the pending result set can be obtained by calling getResultList or getSingleResult.
    • The hasMoreResults method can then be used to test for further results.
    • If execute or hasMoreResults returns false, the getUpdateCount method can be called to obtain the pending result if it is an update count. The getUpdateCount method will return either the update count (zero or greater) or -1 if there is no update count (i.e., either the next result is a result set or there is no next update count).
    • For portability, results that correspond to JDBC result sets and update counts need to be processed before the values of any INOUT or OUT parameters are extracted.
    • After results returned through getResultList and getUpdateCount have been exhausted, results returned through INOUT and OUT parameters can be retrieved.
    • The getOutputParameterValue methods are used to retrieve the values passed back from the procedure through INOUT and OUT parameters.
    • When using REF_CURSOR parameters for result sets the update counts should be exhausted before calling getResultList to retrieve the result set. Alternatively, the REF_CURSOR result set can be retrieved through getOutputParameterValue. Result set mappings will be applied to results corresponding to REF_CURSOR parameters in the order the REF_CURSOR parameters were registered with the query.
    • In the simplest case, where results are returned only via INOUT and OUT parameters, execute can be followed immediately by calls to getOutputParameterValue.
    Since:
    Java Persistence 2.1
    See Also:
    Query, Parameter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean execute()
      Return true if the first result corresponds to a result set, and false if it is an update count or if there are no results other than through INOUT and OUT parameters, if any.
      int executeUpdate()
      Return the update count of -1 if there is no pending result or if the first result is not an update count.
      Object getOutputParameterValue(int position)
      Retrieve a value passed back from the procedure through an INOUT or OUT parameter.
      Object getOutputParameterValue(String parameterName)
      Retrieve a value passed back from the procedure through an INOUT or OUT parameter.
      List getResultList()
      Retrieve the list of results from the next result set.
      Object getSingleResult()
      Retrieve a single result from the next result set.
      int getUpdateCount()
      Return the update count or -1 if there is no pending result or if the next result is not an update count.
      boolean hasMoreResults()
      Return true if the next result corresponds to a result set, and false if it is an update count or if there are no results other than through INOUT and OUT parameters, if any.
      StoredProcedureQuery registerStoredProcedureParameter(int position, Class type, ParameterMode mode)
      Register a positional parameter.
      StoredProcedureQuery registerStoredProcedureParameter(String parameterName, Class type, ParameterMode mode)
      Register a named parameter.
      StoredProcedureQuery setFlushMode(FlushModeType flushMode)
      Set the flush mode type to be used for the query execution.
      StoredProcedureQuery setHint(String hintName, Object value)
      Set a query property or hint.
      StoredProcedureQuery setParameter(int position, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a positional parameter.
      StoredProcedureQuery setParameter(int position, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a positional parameter.
      StoredProcedureQuery setParameter(int position, Object value)
      Bind an argument value to a positional parameter.
      StoredProcedureQuery setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      StoredProcedureQuery setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      <T> StoredProcedureQuery setParameter(Parameter<T> param, T value)
      Bind the value of a Parameter object.
      StoredProcedureQuery setParameter(String name, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a named parameter.
      StoredProcedureQuery setParameter(String name, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a named parameter.
      StoredProcedureQuery setParameter(String name, Object value)
      Bind an argument value to a named parameter.

      • Methods inherited from interface javax.persistence.Query

        getFirstResult, getFlushMode, getHints, getLockMode, getMaxResults, getParameter, getParameter, getParameter, getParameter, getParameters, getParameterValue, getParameterValue, getParameterValue, isBound, setFirstResult, setLockMode, setMaxResults, unwrap

    • Method Detail

      • setHint

        StoredProcedureQuery setHint(String hintName,
                           Object value)
        Set a query property or hint. The hints elements may be used to specify query properties and hints. Properties defined by this specification must be observed by the provider. Vendor-specific hints that are not recognized by a provider must be silently ignored. Portable applications should not rely on the standard timeout hint. Depending on the database in use, this hint may or may not be observed.
        Specified by:
        setHint in interface Query
        Parameters:
        hintName - name of the property or hint
        value - value for the property or hint
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the second argument is not valid for the implementation

      • setParameter

        <T> StoredProcedureQuery setParameter(Parameter<T> param,
                                    T value)
        Bind the value of a Parameter object.
        Specified by:
        setParameter in interface Query
        Parameters:
        param - parameter object
        value - parameter value
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter does not correspond to a parameter of the query

      • setParameter

        StoredProcedureQuery setParameter(Parameter<Calendar> param,
                                Calendar value,
                                TemporalType temporalType)
        Bind an instance of java.util.Calendar to a Parameter object.
        Specified by:
        setParameter in interface Query
        Parameters:
        param - parameter object
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter does not correspond to a parameter of the query

      • setParameter

        StoredProcedureQuery setParameter(Parameter<Date> param,
                                Date value,
                                TemporalType temporalType)
        Bind an instance of java.util.Date to a Parameter object.
        Specified by:
        setParameter in interface Query
        Parameters:
        param - parameter object
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter does not correspond to a parameter of the query

      • setParameter

        StoredProcedureQuery setParameter(String name,
                                Object value)
        Bind an argument value to a named parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        name - parameter name
        value - parameter value
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter name does not correspond to a parameter of the query or if the argument is of incorrect type

      • setParameter

        StoredProcedureQuery setParameter(String name,
                                Calendar value,
                                TemporalType temporalType)
        Bind an instance of java.util.Calendar to a named parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        name - parameter name
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter name does not correspond to a parameter of the query or if the value argument is of incorrect type

      • setParameter

        StoredProcedureQuery setParameter(String name,
                                Date value,
                                TemporalType temporalType)
        Bind an instance of java.util.Date to a named parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        name - parameter name
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter name does not correspond to a parameter of the query or if the value argument is of incorrect type

      • setParameter

        StoredProcedureQuery setParameter(int position,
                                Object value)
        Bind an argument value to a positional parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        position - position
        value - parameter value
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if position does not correspond to a positional parameter of the query or if the argument is of incorrect type

      • setParameter

        StoredProcedureQuery setParameter(int position,
                                Calendar value,
                                TemporalType temporalType)
        Bind an instance of java.util.Calendar to a positional parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        position - position
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if position does not correspond to a positional parameter of the query or if the value argument is of incorrect type

      • setParameter

        StoredProcedureQuery setParameter(int position,
                                Date value,
                                TemporalType temporalType)
        Bind an instance of java.util.Date to a positional parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        position - position
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if position does not correspond to a positional parameter of the query or if the value argument is of incorrect type

      • setFlushMode

        StoredProcedureQuery setFlushMode(FlushModeType flushMode)
        Set the flush mode type to be used for the query execution. The flush mode type applies to the query regardless of the flush mode type in use for the entity manager.
        Specified by:
        setFlushMode in interface Query
        Parameters:
        flushMode - flush mode
        Returns:
        the same query instance

      • registerStoredProcedureParameter

        StoredProcedureQuery registerStoredProcedureParameter(int position,
                                                    Class type,
                                                    ParameterMode mode)
        Register a positional parameter. All parameters must be registered.
        Parameters:
        position - parameter position
        type - type of the parameter
        mode - parameter mode
        Returns:
        the same query instance

      • registerStoredProcedureParameter

        StoredProcedureQuery registerStoredProcedureParameter(String parameterName,
                                                    Class type,
                                                    ParameterMode mode)
        Register a named parameter.
        Parameters:
        parameterName - name of the parameter as registered or specified in metadata
        type - type of the parameter
        mode - parameter mode
        Returns:
        the same query instance

      • getOutputParameterValue

        Object getOutputParameterValue(int position)
        Retrieve a value passed back from the procedure through an INOUT or OUT parameter. For portability, all results corresponding to result sets and update counts must be retrieved before the values of output parameters.
        Parameters:
        position - parameter position
        Returns:
        the result that is passed back through the parameter
        Throws:
        IllegalArgumentException - if the position does not correspond to a parameter of the query or is not an INOUT or OUT parameter

      • getOutputParameterValue

        Object getOutputParameterValue(String parameterName)
        Retrieve a value passed back from the procedure through an INOUT or OUT parameter. For portability, all results corresponding to result sets and update counts must be retrieved before the values of output parameters.
        Parameters:
        parameterName - name of the parameter as registered or specified in metadata
        Returns:
        the result that is passed back through the parameter
        Throws:
        IllegalArgumentException - if the parameter name does not correspond to a parameter of the query or is not an INOUT or OUT parameter

      • execute

        boolean execute()
        Return true if the first result corresponds to a result set, and false if it is an update count or if there are no results other than through INOUT and OUT parameters, if any.
        Returns:
        true if first result corresponds to result set
        Throws:
        QueryTimeoutException - if the query execution exceeds the query timeout value set and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back

      • executeUpdate

        int executeUpdate()
        Return the update count of -1 if there is no pending result or if the first result is not an update count. The provider will call execute on the query if needed.
        Specified by:
        executeUpdate in interface Query
        Returns:
        the update count or -1 if there is no pending result or if the next result is not an update count.
        Throws:
        TransactionRequiredException - if there is no transaction or the persistence context has not been joined to the transaction
        QueryTimeoutException - if the statement execution exceeds the query timeout value set and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back

      • getResultList

        List getResultList()
        Retrieve the list of results from the next result set. The provider will call execute on the query if needed. A REF_CURSOR result set, if any, will be retrieved in the order the REF_CURSOR parameter was registered with the query.
        Specified by:
        getResultList in interface Query
        Returns:
        a list of the results or null is the next item is not a result set
        Throws:
        QueryTimeoutException - if the query execution exceeds the query timeout value set and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back

      • getSingleResult

        Object getSingleResult()
        Retrieve a single result from the next result set. The provider will call execute on the query if needed. A REF_CURSOR result set, if any, will be retrieved in the order the REF_CURSOR parameter was registered with the query.
        Specified by:
        getSingleResult in interface Query
        Returns:
        the result or null if the next item is not a result set
        Throws:
        NoResultException - if there is no result in the next result set
        NonUniqueResultException - if more than one result
        QueryTimeoutException - if the query execution exceeds the query timeout value set and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back

      • hasMoreResults

        boolean hasMoreResults()
        Return true if the next result corresponds to a result set, and false if it is an update count or if there are no results other than through INOUT and OUT parameters, if any.
        Returns:
        true if next result corresponds to result set
        Throws:
        QueryTimeoutException - if the query execution exceeds the query timeout value set and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back

      • getUpdateCount

        int getUpdateCount()
        Return the update count or -1 if there is no pending result or if the next result is not an update count.
        Returns:
        update count or -1 if there is no pending result or if the next result is not an update count
        Throws:
        QueryTimeoutException - if the query execution exceeds the query timeout value set and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Subgraph (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface Subgraph<T>

  • Type Parameters:
    T - The type of the attribute.

    public interface Subgraph<T>
    This type represents a subgraph for an attribute node that corresponds to a Managed Type. Using this class, an entity subgraph can be embedded within an EntityGraph.
    Since:
    Java Persistence 2.1
    See Also:
    EntityGraph, AttributeNode, NamedSubgraph

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addAttributeNodes(Attribute<T,?>... attribute)
      Add one or more attribute nodes to the entity graph.
      void addAttributeNodes(String... attributeName)
      Add one or more attribute nodes to the entity graph.
      <X> Subgraph<X> addKeySubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a map key that is a managed type.
      <X> Subgraph<? extends X> addKeySubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a map key that is a managed type with inheritance.
      <X> Subgraph<X> addKeySubgraph(String attributeName)
      Add a node to the graph that corresponds to a map key that is a managed type.
      <X> Subgraph<X> addKeySubgraph(String attributeName, Class<X> type)
      Add a node to the graph that corresponds to a map key that is a managed type with inheritance.
      <X> Subgraph<X> addSubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a managed type.
      <X> Subgraph<? extends X> addSubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a managed type with inheritance.
      <X> Subgraph<X> addSubgraph(String attributeName)
      Add a node to the graph that corresponds to a managed type.
      <X> Subgraph<X> addSubgraph(String attributeName, Class<X> type)
      Add a node to the graph that corresponds to a managed type with inheritance.
      List<AttributeNode<?>> getAttributeNodes()
      Return the attribute nodes corresponding to the attributes of this managed type that are included in the subgraph.
      Class<T> getClassType()
      Return the type for which this subgraph was defined.

    • Method Detail

      • addAttributeNodes

        void addAttributeNodes(String... attributeName)
        Add one or more attribute nodes to the entity graph.
        Parameters:
        attributeName - name of the attribute
        Throws:
        IllegalArgumentException - if the attribute is not an attribute of this managed type.
        IllegalStateException - if the EntityGraph has been statically defined

      • addAttributeNodes

        void addAttributeNodes(Attribute<T,?>... attribute)
        Add one or more attribute nodes to the entity graph.
        Parameters:
        attribute - attribute
        Throws:
        IllegalStateException - if this EntityGraph has been statically defined

      • addSubgraph

        <X> Subgraph<X> addSubgraph(Attribute<T,X> attribute)
        Add a node to the graph that corresponds to a managed type. This allows for construction of multi-node entity graphs that include related managed types.
        Parameters:
        attribute - attribute
        Returns:
        subgraph for the attribute
        Throws:
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if the EntityGraph has been statically defined

      • addSubgraph

        <X> Subgraph<? extends X> addSubgraph(Attribute<T,X> attribute,
                                    Class<? extends X> type)
        Add a node to the graph that corresponds to a managed type with inheritance. This allows for multiple subclass subgraphs to be defined for this node of the entity graph. Subclass subgraphs will automatically include the specified attributes of superclass subgraphs
        Parameters:
        attribute - attribute
        type - entity subclass
        Returns:
        subgraph for the attribute
        Throws:
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if this EntityGraph has been statically defined

      • addSubgraph

        <X> Subgraph<X> addSubgraph(String attributeName)
        Add a node to the graph that corresponds to a managed type. This allows for construction of multi-node entity graphs that include related managed types.
        Parameters:
        attributeName - name of the attribute
        Returns:
        subgraph for the attribute
        Throws:
        IllegalArgumentException - if the attribute is not an attribute of this managed type.
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if this EntityGraph has been statically defined

      • addSubgraph

        <X> Subgraph<X> addSubgraph(String attributeName,
                          Class<X> type)
        Add a node to the graph that corresponds to a managed type with inheritance. This allows for multiple subclass subgraphs to be defined for this node of the entity graph. Subclass subgraphs will automatically include the specified attributes of superclass subgraphs
        Parameters:
        attributeName - name of the attribute
        type - entity subclass
        Returns:
        subgraph for the attribute
        Throws:
        IllegalArgumentException - if the attribute is not an attribute of this managed type.
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if this EntityGraph has been statically defined

      • addKeySubgraph

        <X> Subgraph<X> addKeySubgraph(Attribute<T,X> attribute)
        Add a node to the graph that corresponds to a map key that is a managed type. This allows for construction of multinode entity graphs that include related managed types.
        Parameters:
        attribute - attribute
        Returns:
        subgraph for the key attribute
        Throws:
        IllegalArgumentException - if the attribute's target type is not a managed type entity
        IllegalStateException - if this EntityGraph has been statically defined

      • addKeySubgraph

        <X> Subgraph<? extends X> addKeySubgraph(Attribute<T,X> attribute,
                                       Class<? extends X> type)
        Add a node to the graph that corresponds to a map key that is a managed type with inheritance. This allows for construction of multi-node entity graphs that include related managed types. Subclass subgraphs will automatically include the specified attributes of superclass subgraphs
        Parameters:
        attribute - attribute
        type - entity subclass
        Returns:
        subgraph for the attribute
        Throws:
        IllegalArgumentException - if the attribute's target type is not a managed type entity
        IllegalStateException - if this EntityGraph has been statically defined

      • addKeySubgraph

        <X> Subgraph<X> addKeySubgraph(String attributeName)
        Add a node to the graph that corresponds to a map key that is a managed type. This allows for construction of multi-node entity graphs that include related managed types.
        Parameters:
        attributeName - name of the attribute
        Returns:
        subgraph for the key attribute
        Throws:
        IllegalArgumentException - if the attribute is not an attribute of this entity.
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if this EntityGraph has been statically defined

      • addKeySubgraph

        <X> Subgraph<X> addKeySubgraph(String attributeName,
                             Class<X> type)
        Add a node to the graph that corresponds to a map key that is a managed type with inheritance. This allows for construction of multi-node entity graphs that include related managed types. Subclass subgraphs will include the specified attributes of superclass subgraphs
        Parameters:
        attributeName - name of the attribute
        type - entity subclass
        Returns:
        subgraph for the attribute
        Throws:
        IllegalArgumentException - if the attribute is not an attribute of this entity.
        IllegalArgumentException - if the attribute's target type is not a managed type
        IllegalStateException - if this EntityGraph has been statically defined

      • getAttributeNodes

        List<AttributeNode<?>> getAttributeNodes()
        Return the attribute nodes corresponding to the attributes of this managed type that are included in the subgraph.
        Returns:
        list of attribute nodes included in the subgraph or empty List if none have been defined

      • getClassType

        Class<T> getClassType()
        Return the type for which this subgraph was defined.
        Returns:
        managed type referenced by the subgraph
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SynchronizationType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum SynchronizationType

  • java.lang.Object
    • java.lang.Enum<SynchronizationType>
      • javax.persistence.SynchronizationType
  • All Implemented Interfaces:
    Serializable, Comparable<SynchronizationType>

    public enum SynchronizationType
extends Enum<SynchronizationType>
    Specifies whether the persistence context is always automatically synchronized with the current transaction or whether the persistence context must be explicitly joined to the current transaction by means of the EntityManager.joinTransaction() method.
    Since:
    Java Persistence 2.1

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      SYNCHRONIZED
      Persistence context is automatically synchronized with the current transaction
      UNSYNCHRONIZED
      Persistence context must be explicitly joined to the current transaction

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static SynchronizationType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SynchronizationType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SYNCHRONIZED

        public static final SynchronizationType SYNCHRONIZED
        Persistence context is automatically synchronized with the current transaction

      • UNSYNCHRONIZED

        public static final SynchronizationType UNSYNCHRONIZED
        Persistence context must be explicitly joined to the current transaction

    • Method Detail

      • values

        public static SynchronizationType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SynchronizationType c : SynchronizationType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SynchronizationType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Table (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Table

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Table
    Specifies the primary table for the annotated entity. Additional tables may be specified using SecondaryTable or SecondaryTables annotation.

    If no Table annotation is specified for an entity class, the default values apply.

        Example:

    @Entity
    @Table(name="CUST", schema="RECORDS")
    public class Customer { ... }
    Since:
    Java Persistence 1.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String catalog
      (Optional) The catalog of the table.
      Index[] indexes
      (Optional) Indexes for the table.
      String name
      (Optional) The name of the table.
      String schema
      (Optional) The schema of the table.
      UniqueConstraint[] uniqueConstraints
      (Optional) Unique constraints that are to be placed on the table.

    • Element Detail

      • name

        public abstract String name
        (Optional) The name of the table.

        Defaults to the entity name.

        Default:
        ""

      • catalog

        public abstract String catalog
        (Optional) The catalog of the table.

        Defaults to the default catalog.

        Default:
        ""

      • schema

        public abstract String schema
        (Optional) The schema of the table.

        Defaults to the default schema for user.

        Default:
        ""

      • uniqueConstraints

        public abstract UniqueConstraint[] uniqueConstraints
        (Optional) Unique constraints that are to be placed on the table. These are only used if table generation is in effect. These constraints apply in addition to any constraints specified by the Column and JoinColumn annotations and constraints entailed by primary key mappings.

        Defaults to no additional constraints.

        Default:
        {}

      • indexes

        public abstract Index[] indexes
        (Optional) Indexes for the table. These are only used if table generation is in effect. Note that it is not necessary to specify an index for a primary key, as the primary key index will be created automatically.
        Since:
        Java Persistence 2.1
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


TableGenerator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type TableGenerator

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface TableGenerator
    Defines a primary key generator that may be referenced by name when a generator element is specified for the GeneratedValue annotation. A table generator may be specified on the entity class or on the primary key field or property. The scope of the generator name is global to the persistence unit (across all generator types).
        Example 1:

    @Entity public class Employee {
        ...
        @TableGenerator(
            name="empGen",
            table="ID_GEN",
            pkColumnName="GEN_KEY",
            valueColumnName="GEN_VALUE",
            pkColumnValue="EMP_ID",
            allocationSize=1)
        @Id
        @GeneratedValue(strategy=TABLE, generator="empGen")
        int id;
        ...
    }

    Example 2:

    @Entity public class Address {
        ...
        @TableGenerator(
            name="addressGen",
            table="ID_GEN",
            pkColumnName="GEN_KEY",
            valueColumnName="GEN_VALUE",
            pkColumnValue="ADDR_ID")
        @Id
        @GeneratedValue(strategy=TABLE, generator="addressGen")
        int id;
        ...
    }
    Since:
    Java Persistence 1.0
    See Also:
    GeneratedValue

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      (Required) A unique generator name that can be referenced by one or more classes to be the generator for id values.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      int allocationSize
      (Optional) The amount to increment by when allocating id numbers from the generator.
      String catalog
      (Optional) The catalog of the table.
      Index[] indexes
      (Optional) Indexes for the table.
      int initialValue
      (Optional) The initial value to be used to initialize the column that stores the last value generated.
      String pkColumnName
      (Optional) Name of the primary key column in the table.
      String pkColumnValue
      (Optional) The primary key value in the generator table that distinguishes this set of generated values from others that may be stored in the table.
      String schema
      (Optional) The schema of the table.
      String table
      (Optional) Name of table that stores the generated id values.
      UniqueConstraint[] uniqueConstraints
      (Optional) Unique constraints that are to be placed on the table.
      String valueColumnName
      (Optional) Name of the column that stores the last value generated.

    • Element Detail

      • name

        public abstract String name
        (Required) A unique generator name that can be referenced by one or more classes to be the generator for id values.

      • table

        public abstract String table
        (Optional) Name of table that stores the generated id values.

        Defaults to a name chosen by persistence provider.

        Default:
        ""

      • catalog

        public abstract String catalog
        (Optional) The catalog of the table.

        Defaults to the default catalog.

        Default:
        ""

      • schema

        public abstract String schema
        (Optional) The schema of the table.

        Defaults to the default schema for user.

        Default:
        ""

      • pkColumnName

        public abstract String pkColumnName
        (Optional) Name of the primary key column in the table.

        Defaults to a provider-chosen name.

        Default:
        ""

      • valueColumnName

        public abstract String valueColumnName
        (Optional) Name of the column that stores the last value generated.

        Defaults to a provider-chosen name.

        Default:
        ""

      • pkColumnValue

        public abstract String pkColumnValue
        (Optional) The primary key value in the generator table that distinguishes this set of generated values from others that may be stored in the table.

        Defaults to a provider-chosen value to store in the primary key column of the generator table

        Default:
        ""

      • initialValue

        public abstract int initialValue
        (Optional) The initial value to be used to initialize the column that stores the last value generated.
        Default:
        0

      • allocationSize

        public abstract int allocationSize
        (Optional) The amount to increment by when allocating id numbers from the generator.
        Default:
        50

      • uniqueConstraints

        public abstract UniqueConstraint[] uniqueConstraints
        (Optional) Unique constraints that are to be placed on the table. These are only used if table generation is in effect. These constraints apply in addition to primary key constraints.

        Defaults to no additional constraints.

        Default:
        {}

      • indexes

        public abstract Index[] indexes
        (Optional) Indexes for the table. These are only used if table generation is in effect. Note that it is not necessary to specify an index for a primary key, as the primary key index will be created automatically.
        Since:
        Java Persistence 2.1
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Temporal (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Temporal

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Temporal
    This annotation must be specified for persistent fields or properties of type java.util.Date and java.util.Calendar. It may only be specified for fields or properties of these types.

    The Temporal annotation may be used in conjunction with the Basic annotation, the Id annotation, or the ElementCollection annotation (when the element collection value is of such a temporal type.

         Example:

     @Temporal(DATE)
     protected java.util.Date endDate;
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      TemporalType value
      The type used in mapping java.util.Date or java.util.Calendar.

    • Element Detail

      • value

        public abstract TemporalType value
        The type used in mapping java.util.Date or java.util.Calendar.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


TemporalType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum TemporalType

  • java.lang.Object
    • java.lang.Enum<TemporalType>
      • javax.persistence.TemporalType
  • All Implemented Interfaces:
    Serializable, Comparable<TemporalType>

    public enum TemporalType
extends Enum<TemporalType>
    Type used to indicate a specific mapping of java.util.Date or java.util.Calendar.
    Since:
    Java Persistence 1.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      DATE
      Map as java.sql.Date
      TIME
      Map as java.sql.Time
      TIMESTAMP
      Map as java.sql.Timestamp

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static TemporalType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static TemporalType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DATE

        public static final TemporalType DATE
        Map as java.sql.Date

      • TIME

        public static final TemporalType TIME
        Map as java.sql.Time

      • TIMESTAMP

        public static final TemporalType TIMESTAMP
        Map as java.sql.Timestamp

    • Method Detail

      • values

        public static TemporalType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (TemporalType c : TemporalType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static TemporalType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


TransactionRequiredException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Class TransactionRequiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.TransactionRequiredException
  • All Implemented Interfaces:
    Serializable

    public class TransactionRequiredException
extends PersistenceException
    Thrown by the persistence provider when a transaction is required but is not active.
    Since:
    Java Persistence 1.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionRequiredException()
      Constructs a new TransactionRequiredException exception with null as its detail message.
      TransactionRequiredException(String message)
      Constructs a new TransactionRequiredException exception with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionRequiredException

        public TransactionRequiredException()
        Constructs a new TransactionRequiredException exception with null as its detail message.

      • TransactionRequiredException

        public TransactionRequiredException(String message)
        Constructs a new TransactionRequiredException exception with the specified detail message.
        Parameters:
        message - the detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Transient (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Transient

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Transient
    Specifies that the property or field is not persistent. It is used to annotate a property or field of an entity class, mapped superclass, or embeddable class.
        Example:

    @Entity
    public class Employee {
        @Id int id;
        @Transient User currentUser;
        ...
    }
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Tuple (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface Tuple

  • public interface Tuple
    Interface for extracting the elements of a query result tuple.
    Since:
    Java Persistence 2.0
    See Also:
    TupleElement

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object get(int i)
      Get the value of the element at the specified position in the result tuple.
      <X> X get(int i, Class<X> type)
      Get the value of the element at the specified position in the result tuple.
      Object get(String alias)
      Get the value of the tuple element to which the specified alias has been assigned.
      <X> X get(String alias, Class<X> type)
      Get the value of the tuple element to which the specified alias has been assigned.
      <X> X get(TupleElement<X> tupleElement)
      Get the value of the specified tuple element.
      List<TupleElement<?>> getElements()
      Return the tuple elements.
      Object[] toArray()
      Return the values of the result tuple elements as an array.

    • Method Detail

      • get

        <X> X get(TupleElement<X> tupleElement)
        Get the value of the specified tuple element.
        Parameters:
        tupleElement - tuple element
        Returns:
        value of tuple element
        Throws:
        IllegalArgumentException - if tuple element does not correspond to an element in the query result tuple

      • get

        <X> X get(String alias,
        Class<X> type)
        Get the value of the tuple element to which the specified alias has been assigned.
        Parameters:
        alias - alias assigned to tuple element
        type - of the tuple element
        Returns:
        value of the tuple element
        Throws:
        IllegalArgumentException - if alias does not correspond to an element in the query result tuple or element cannot be assigned to the specified type

      • get

        Object get(String alias)
        Get the value of the tuple element to which the specified alias has been assigned.
        Parameters:
        alias - alias assigned to tuple element
        Returns:
        value of the tuple element
        Throws:
        IllegalArgumentException - if alias does not correspond to an element in the query result tuple

      • get

        <X> X get(int i,
        Class<X> type)
        Get the value of the element at the specified position in the result tuple. The first position is 0.
        Parameters:
        i - position in result tuple
        type - type of the tuple element
        Returns:
        value of the tuple element
        Throws:
        IllegalArgumentException - if i exceeds length of result tuple or element cannot be assigned to the specified type

      • get

        Object get(int i)
        Get the value of the element at the specified position in the result tuple. The first position is 0.
        Parameters:
        i - position in result tuple
        Returns:
        value of the tuple element
        Throws:
        IllegalArgumentException - if i exceeds length of result tuple

      • toArray

        Object[] toArray()
        Return the values of the result tuple elements as an array.
        Returns:
        tuple element values

      • getElements

        List<TupleElement<?>> getElements()
        Return the tuple elements.
        Returns:
        tuple elements
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TupleElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface TupleElement<X>

  • Type Parameters:
    X - the type of the element
    All Known Subinterfaces:
    CollectionJoin<Z,E>, CompoundSelection<X>, CriteriaBuilder.Case<R>, CriteriaBuilder.Coalesce<T>, CriteriaBuilder.In<T>, CriteriaBuilder.SimpleCase<C,R>, Expression<T>, From<Z,X>, Join<Z,X>, ListJoin<Z,E>, MapJoin<Z,K,V>, ParameterExpression<T>, Path<X>, PluralJoin<Z,C,E>, Predicate, Root<X>, Selection<X>, SetJoin<Z,E>, Subquery<T>

    public interface TupleElement<X>
    The TupleElement interface defines an element that is returned in a query result tuple.
    Since:
    Java Persistence 2.0
    See Also:
    Tuple

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAlias()
      Return the alias assigned to the tuple element or null, if no alias has been assigned.
      Class<? extends X> getJavaType()
      Return the Java type of the tuple element.

    • Method Detail

      • getJavaType

        Class<? extends X> getJavaType()
        Return the Java type of the tuple element.
        Returns:
        the Java type of the tuple element

      • getAlias

        String getAlias()
        Return the alias assigned to the tuple element or null, if no alias has been assigned.
        Returns:
        alias
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TypedQuery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence

Interface TypedQuery<X>

  • Type Parameters:
    X - query result type
    All Superinterfaces:
    Query

    public interface TypedQuery<X>
extends Query
    Interface used to control the execution of typed queries.
    Since:
    Java Persistence 2.0
    See Also:
    Query, Parameter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<X> getResultList()
      Execute a SELECT query and return the query results as a typed List.
      X getSingleResult()
      Execute a SELECT query that returns a single result.
      TypedQuery<X> setFirstResult(int startPosition)
      Set the position of the first result to retrieve.
      TypedQuery<X> setFlushMode(FlushModeType flushMode)
      Set the flush mode type to be used for the query execution.
      TypedQuery<X> setHint(String hintName, Object value)
      Set a query property or hint.
      TypedQuery<X> setLockMode(LockModeType lockMode)
      Set the lock mode type to be used for the query execution.
      TypedQuery<X> setMaxResults(int maxResult)
      Set the maximum number of results to retrieve.
      TypedQuery<X> setParameter(int position, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a positional parameter.
      TypedQuery<X> setParameter(int position, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a positional parameter.
      TypedQuery<X> setParameter(int position, Object value)
      Bind an argument value to a positional parameter.
      TypedQuery<X> setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      TypedQuery<X> setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      <T> TypedQuery<X> setParameter(Parameter<T> param, T value)
      Bind the value of a Parameter object.
      TypedQuery<X> setParameter(String name, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a named parameter.
      TypedQuery<X> setParameter(String name, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a named parameter.
      TypedQuery<X> setParameter(String name, Object value)
      Bind an argument value to a named parameter.

      • Methods inherited from interface javax.persistence.Query

        executeUpdate, getFirstResult, getFlushMode, getHints, getLockMode, getMaxResults, getParameter, getParameter, getParameter, getParameter, getParameters, getParameterValue, getParameterValue, getParameterValue, isBound, unwrap

    • Method Detail

      • getResultList

        List<X> getResultList()
        Execute a SELECT query and return the query results as a typed List.
        Specified by:
        getResultList in interface Query
        Returns:
        a list of the results
        Throws:
        IllegalStateException - if called for a Java Persistence query language UPDATE or DELETE statement
        QueryTimeoutException - if the query execution exceeds the query timeout value set and only the statement is rolled back
        TransactionRequiredException - if a lock mode other than NONE has been set and there is no transaction or the persistence context has not been joined to the transaction
        PessimisticLockException - if pessimistic locking fails and the transaction is rolled back
        LockTimeoutException - if pessimistic locking fails and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back

      • getSingleResult

        X getSingleResult()
        Execute a SELECT query that returns a single result.
        Specified by:
        getSingleResult in interface Query
        Returns:
        the result
        Throws:
        NoResultException - if there is no result
        NonUniqueResultException - if more than one result
        IllegalStateException - if called for a Java Persistence query language UPDATE or DELETE statement
        QueryTimeoutException - if the query execution exceeds the query timeout value set and only the statement is rolled back
        TransactionRequiredException - if a lock mode other than NONE has been set and there is no transaction or the persistence context has not been joined to the transaction
        PessimisticLockException - if pessimistic locking fails and the transaction is rolled back
        LockTimeoutException - if pessimistic locking fails and only the statement is rolled back
        PersistenceException - if the query execution exceeds the query timeout value set and the transaction is rolled back

      • setMaxResults

        TypedQuery<X> setMaxResults(int maxResult)
        Set the maximum number of results to retrieve.
        Specified by:
        setMaxResults in interface Query
        Parameters:
        maxResult - maximum number of results to retrieve
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the argument is negative

      • setFirstResult

        TypedQuery<X> setFirstResult(int startPosition)
        Set the position of the first result to retrieve.
        Specified by:
        setFirstResult in interface Query
        Parameters:
        startPosition - position of the first result, numbered from 0
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the argument is negative

      • setHint

        TypedQuery<X> setHint(String hintName,
                    Object value)
        Set a query property or hint. The hints elements may be used to specify query properties and hints. Properties defined by this specification must be observed by the provider. Vendor-specific hints that are not recognized by a provider must be silently ignored. Portable applications should not rely on the standard timeout hint. Depending on the database in use and the locking mechanisms used by the provider, this hint may or may not be observed.
        Specified by:
        setHint in interface Query
        Parameters:
        hintName - name of property or hint
        value - value for the property or hint
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the second argument is not valid for the implementation

      • setParameter

        <T> TypedQuery<X> setParameter(Parameter<T> param,
                             T value)
        Bind the value of a Parameter object.
        Specified by:
        setParameter in interface Query
        Parameters:
        param - parameter object
        value - parameter value
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter does not correspond to a parameter of the query

      • setParameter

        TypedQuery<X> setParameter(Parameter<Calendar> param,
                         Calendar value,
                         TemporalType temporalType)
        Bind an instance of java.util.Calendar to a Parameter object.
        Specified by:
        setParameter in interface Query
        Parameters:
        param - parameter object
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter does not correspond to a parameter of the query

      • setParameter

        TypedQuery<X> setParameter(Parameter<Date> param,
                         Date value,
                         TemporalType temporalType)
        Bind an instance of java.util.Date to a Parameter object.
        Specified by:
        setParameter in interface Query
        Parameters:
        param - parameter object
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter does not correspond to a parameter of the query

      • setParameter

        TypedQuery<X> setParameter(String name,
                         Object value)
        Bind an argument value to a named parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        name - parameter name
        value - parameter value
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter name does not correspond to a parameter of the query or if the argument is of incorrect type

      • setParameter

        TypedQuery<X> setParameter(String name,
                         Calendar value,
                         TemporalType temporalType)
        Bind an instance of java.util.Calendar to a named parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        name - parameter name
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter name does not correspond to a parameter of the query or if the value argument is of incorrect type

      • setParameter

        TypedQuery<X> setParameter(String name,
                         Date value,
                         TemporalType temporalType)
        Bind an instance of java.util.Date to a named parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        name - parameter name
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if the parameter name does not correspond to a parameter of the query or if the value argument is of incorrect type

      • setParameter

        TypedQuery<X> setParameter(int position,
                         Object value)
        Bind an argument value to a positional parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        position - position
        value - parameter value
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if position does not correspond to a positional parameter of the query or if the argument is of incorrect type

      • setParameter

        TypedQuery<X> setParameter(int position,
                         Calendar value,
                         TemporalType temporalType)
        Bind an instance of java.util.Calendar to a positional parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        position - position
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if position does not correspond to a positional parameter of the query or if the value argument is of incorrect type

      • setParameter

        TypedQuery<X> setParameter(int position,
                         Date value,
                         TemporalType temporalType)
        Bind an instance of java.util.Date to a positional parameter.
        Specified by:
        setParameter in interface Query
        Parameters:
        position - position
        value - parameter value
        temporalType - temporal type
        Returns:
        the same query instance
        Throws:
        IllegalArgumentException - if position does not correspond to a positional parameter of the query or if the value argument is of incorrect type

      • setFlushMode

        TypedQuery<X> setFlushMode(FlushModeType flushMode)
        Set the flush mode type to be used for the query execution. The flush mode type applies to the query regardless of the flush mode type in use for the entity manager.
        Specified by:
        setFlushMode in interface Query
        Parameters:
        flushMode - flush mode
        Returns:
        the same query instance

      • setLockMode

        TypedQuery<X> setLockMode(LockModeType lockMode)
        Set the lock mode type to be used for the query execution.
        Specified by:
        setLockMode in interface Query
        Parameters:
        lockMode - lock mode
        Returns:
        the same query instance
        Throws:
        IllegalStateException - if the query is found not to be a Java Persistence query language SELECT query or a CriteriaQuery query
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UniqueConstraint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type UniqueConstraint

  • @Target(value={})
@Retention(value=RUNTIME)
public @interface UniqueConstraint
    Specifies that a unique constraint is to be included in the generated DDL for a primary or secondary table.
        Example:
    @Entity
    @Table(
        name="EMPLOYEE",
        uniqueConstraints=
            @UniqueConstraint(columnNames={"EMP_ID", "EMP_NAME"})
    )
    public class Employee { ... }
    Since:
    Java Persistence 1.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String[] columnNames
      (Required) An array of the column names that make up the constraint.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      (Optional) Constraint name.

    • Element Detail

      • columnNames

        public abstract String[] columnNames
        (Required) An array of the column names that make up the constraint.

      • name

        public abstract String name
        (Optional) Constraint name. A provider-chosen name will be chosen if a name is not specified.
        Since:
        Java Persistence 2.0
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.persistence (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.persistence

  • Packages that use javax.persistence
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.spi
    SPI for Java Persistence providers
  • Classes in javax.persistence used by javax.persistence
    Class and Description
    AccessType
    Used with the Access annotation to specify an access type to be applied to an entity class, mapped superclass, or embeddable class, or to a specific attribute of such a class.
    AttributeNode
    Represents an attribute node of an entity graph.
    Cache
    Interface used to interact with the second-level cache.
    CacheRetrieveMode
    Used as the value of the javax.persistence.cache.retrieveMode property to specify the behavior when data is retrieved by the find methods and by queries.
    CacheStoreMode
    Used as the value of the javax.persistence.cache.storeMode property to specify the behavior when data is read from the database and when data is committed into the database.
    CascadeType
    Defines the set of cascadable operations that are propagated to the associated entity.
    ConstraintMode
    Used to control the application of a constraint.
    DiscriminatorType
    Defines supported types of the discriminator column.
    EntityGraph
    This type represents the root of an entity graph that will be used as a template to define the attribute nodes and boundaries of a graph of entities and entity relationships.
    EntityManager
    Interface used to interact with the persistence context.
    EntityManagerFactory
    Interface used to interact with the entity manager factory for the persistence unit.
    EntityTransaction
    Interface used to control transactions on resource-local entity managers.
    EnumType
    Defines mapping for enumerated types.
    FetchType
    Defines strategies for fetching data from the database.
    FlushModeType
    Flush mode setting.
    GenerationType
    Defines the types of primary key generation strategies.
    InheritanceType
    Defines inheritance strategy options.
    LockModeType
    Lock modes can be specified by means of passing a LockModeType argument to one of the EntityManager methods that take locks (lock, find, or refresh) or to the Query.setLockMode() or TypedQuery.setLockMode() method.
    Parameter
    Type for query parameter objects.
    ParameterMode
    Specifies the mode of a parameter of a stored procedure query.
    PersistenceContextType
    Specifies whether a transaction-scoped or extended persistence context is to be used in PersistenceContext.
    PersistenceException
    Thrown by the persistence provider when a problem occurs.
    PersistenceUnitUtil
    Utility interface between the application and the persistence provider managing the persistence unit.
    PersistenceUtil
    Utility interface between the application and the persistence provider(s).
    PessimisticLockScope
    Defines the values of the javax.persistence.lock.scope property for pessimistic locking.
    Query
    Interface used to control query execution.
    SharedCacheMode
    Specifies how the provider must use a second-level cache for the persistence unit.
    StoredProcedureQuery
    Interface used to control stored procedure query execution.
    Subgraph
    This type represents a subgraph for an attribute node that corresponds to a Managed Type.
    SynchronizationType
    Specifies whether the persistence context is always automatically synchronized with the current transaction or whether the persistence context must be explicitly joined to the current transaction by means of the EntityManager.joinTransaction() method.
    TemporalType
    Type used to indicate a specific mapping of java.util.Date or java.util.Calendar.
    TupleElement
    The TupleElement interface defines an element that is returned in a query result tuple.
    TypedQuery
    Interface used to control the execution of typed queries.
    ValidationMode
    The validation mode to be used by the provider for the persistence unit.
  • Classes in javax.persistence used by javax.persistence.criteria
    Class and Description
    Parameter
    Type for query parameter objects.
    Tuple
    Interface for extracting the elements of a query result tuple.
    TupleElement
    The TupleElement interface defines an element that is returned in a query result tuple.
  • Classes in javax.persistence used by javax.persistence.spi
    Class and Description
    EntityManagerFactory
    Interface used to interact with the entity manager factory for the persistence unit.
    SharedCacheMode
    Specifies how the provider must use a second-level cache for the persistence unit.
    ValidationMode
    The validation mode to be used by the provider for the persistence unit.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidationMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence

Enum ValidationMode

  • java.lang.Object
    • java.lang.Enum<ValidationMode>
      • javax.persistence.ValidationMode
  • All Implemented Interfaces:
    Serializable, Comparable<ValidationMode>

    public enum ValidationMode
extends Enum<ValidationMode>
    The validation mode to be used by the provider for the persistence unit.
    Since:
    Java Persistence 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      AUTO
      If a Bean Validation provider is present in the environment, the persistence provider must perform the automatic validation of entities.
      CALLBACK
      The persistence provider must perform the lifecycle event validation.
      NONE
      The persistence provider must not perform lifecycle event validation.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ValidationMode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ValidationMode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • AUTO

        public static final ValidationMode AUTO
        If a Bean Validation provider is present in the environment, the persistence provider must perform the automatic validation of entities. If no Bean Validation provider is present in the environment, no lifecycle event validation takes place. This is the default behavior.

      • CALLBACK

        public static final ValidationMode CALLBACK
        The persistence provider must perform the lifecycle event validation. It is an error if there is no Bean Validation provider present in the environment.

      • NONE

        public static final ValidationMode NONE
        The persistence provider must not perform lifecycle event validation.

    • Method Detail

      • values

        public static ValidationMode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ValidationMode c : ValidationMode.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ValidationMode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Version (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence

Annotation Type Version

  • @Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Version
    Specifies the version field or property of an entity class that serves as its optimistic lock value. The version is used to ensure integrity when performing the merge operation and for optimistic concurrency control.

    Only a single Version property or field should be used per class; applications that use more than one Version property or field will not be portable.

    The Version property should be mapped to the primary table for the entity class; applications that map the Version property to a table other than the primary table will not be portable.

    The following types are supported for version properties: int, Integer, short, Short, long, Long, java.sql.Timestamp.

        Example:

    @Version
    @Column(name="OPTLOCK")
    protected int getVersionNum() { return versionNum; }
    Since:
    Java Persistence 1.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.persistence.Access (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Access

No usage of javax.persistence.Access
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.AccessType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.AccessType

  • Packages that use AccessType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of AccessType in javax.persistence

      Methods in javax.persistence that return AccessType
      Modifier and Type Method and Description
      static AccessType AccessType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AccessType[] AccessType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.AssociationOverride (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.AssociationOverride

No usage of javax.persistence.AssociationOverride
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.AssociationOverrides (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.AssociationOverrides

No usage of javax.persistence.AssociationOverrides
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.AttributeOverride (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.AttributeOverride

No usage of javax.persistence.AttributeOverride
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.AttributeOverrides (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.AttributeOverrides

No usage of javax.persistence.AttributeOverrides
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Basic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Basic

No usage of javax.persistence.Basic
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Cacheable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Cacheable

No usage of javax.persistence.Cacheable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.CacheRetrieveMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.CacheRetrieveMode

  • Packages that use CacheRetrieveMode
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of CacheRetrieveMode in javax.persistence

      Methods in javax.persistence that return CacheRetrieveMode
      Modifier and Type Method and Description
      static CacheRetrieveMode CacheRetrieveMode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CacheRetrieveMode[] CacheRetrieveMode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.CacheStoreMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.CacheStoreMode

  • Packages that use CacheStoreMode
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of CacheStoreMode in javax.persistence

      Methods in javax.persistence that return CacheStoreMode
      Modifier and Type Method and Description
      static CacheStoreMode CacheStoreMode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CacheStoreMode[] CacheStoreMode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.CascadeType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.CascadeType

  • Packages that use CascadeType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of CascadeType in javax.persistence

      Methods in javax.persistence that return CascadeType
      Modifier and Type Method and Description
      static CascadeType CascadeType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CascadeType[] CascadeType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.CollectionTable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.CollectionTable

No usage of javax.persistence.CollectionTable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Column (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Column

No usage of javax.persistence.Column
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ColumnResult (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ColumnResult

No usage of javax.persistence.ColumnResult
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ConstraintMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ConstraintMode

  • Packages that use ConstraintMode
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of ConstraintMode in javax.persistence

      Methods in javax.persistence that return ConstraintMode
      Modifier and Type Method and Description
      static ConstraintMode ConstraintMode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ConstraintMode[] ConstraintMode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ConstructorResult (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ConstructorResult

No usage of javax.persistence.ConstructorResult
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Convert (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Convert

No usage of javax.persistence.Convert
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Converter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Converter

No usage of javax.persistence.Converter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Converts (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Converts

No usage of javax.persistence.Converts
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.DiscriminatorColumn (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.DiscriminatorColumn

No usage of javax.persistence.DiscriminatorColumn
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.DiscriminatorType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.DiscriminatorType

  • Packages that use DiscriminatorType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of DiscriminatorType in javax.persistence

      Methods in javax.persistence that return DiscriminatorType
      Modifier and Type Method and Description
      static DiscriminatorType DiscriminatorType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static DiscriminatorType[] DiscriminatorType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.DiscriminatorValue (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.DiscriminatorValue

No usage of javax.persistence.DiscriminatorValue
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ElementCollection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ElementCollection

No usage of javax.persistence.ElementCollection
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Embeddable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Embeddable

No usage of javax.persistence.Embeddable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Embedded (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Embedded

No usage of javax.persistence.Embedded
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.EmbeddedId (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.EmbeddedId

No usage of javax.persistence.EmbeddedId
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Entity (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Entity

No usage of javax.persistence.Entity
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.EntityExistsException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.EntityExistsException

No usage of javax.persistence.EntityExistsException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.EntityListeners (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.EntityListeners

No usage of javax.persistence.EntityListeners
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.EntityNotFoundException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.EntityNotFoundException

No usage of javax.persistence.EntityNotFoundException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.EntityResult (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.EntityResult

No usage of javax.persistence.EntityResult
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Enumerated (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Enumerated

No usage of javax.persistence.Enumerated
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.EnumType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.EnumType

  • Packages that use EnumType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of EnumType in javax.persistence

      Methods in javax.persistence that return EnumType
      Modifier and Type Method and Description
      static EnumType EnumType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static EnumType[] EnumType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ExcludeDefaultListeners (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ExcludeDefaultListeners

No usage of javax.persistence.ExcludeDefaultListeners
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ExcludeSuperclassListeners (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ExcludeSuperclassListeners

No usage of javax.persistence.ExcludeSuperclassListeners
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.FetchType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.FetchType

  • Packages that use FetchType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of FetchType in javax.persistence

      Methods in javax.persistence that return FetchType
      Modifier and Type Method and Description
      static FetchType FetchType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static FetchType[] FetchType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.FieldResult (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.FieldResult

No usage of javax.persistence.FieldResult
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.FlushModeType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.FlushModeType

  • Packages that use FlushModeType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of FlushModeType in javax.persistence

      Methods in javax.persistence that return FlushModeType
      Modifier and Type Method and Description
      FlushModeType Query.getFlushMode()
      Get the flush mode in effect for the query execution.
      FlushModeType EntityManager.getFlushMode()
      Get the flush mode that applies to all objects contained in the persistence context.
      static FlushModeType FlushModeType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static FlushModeType[] FlushModeType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.persistence with parameters of type FlushModeType
      Modifier and Type Method and Description
      TypedQuery<X> TypedQuery.setFlushMode(FlushModeType flushMode)
      Set the flush mode type to be used for the query execution.
      StoredProcedureQuery StoredProcedureQuery.setFlushMode(FlushModeType flushMode)
      Set the flush mode type to be used for the query execution.
      Query Query.setFlushMode(FlushModeType flushMode)
      Set the flush mode type to be used for the query execution.
      void EntityManager.setFlushMode(FlushModeType flushMode)
      Set the flush mode that applies to all objects contained in the persistence context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ForeignKey (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ForeignKey

No usage of javax.persistence.ForeignKey
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.GeneratedValue (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.GeneratedValue

No usage of javax.persistence.GeneratedValue
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.GenerationType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.GenerationType

  • Packages that use GenerationType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of GenerationType in javax.persistence

      Methods in javax.persistence that return GenerationType
      Modifier and Type Method and Description
      static GenerationType GenerationType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static GenerationType[] GenerationType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Id (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Id

No usage of javax.persistence.Id
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.IdClass (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.IdClass

No usage of javax.persistence.IdClass
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Index (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Index

No usage of javax.persistence.Index
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Inheritance (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Inheritance

No usage of javax.persistence.Inheritance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.InheritanceType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.InheritanceType

  • Packages that use InheritanceType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of InheritanceType in javax.persistence

      Methods in javax.persistence that return InheritanceType
      Modifier and Type Method and Description
      static InheritanceType InheritanceType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static InheritanceType[] InheritanceType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.JoinColumn (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.JoinColumn

No usage of javax.persistence.JoinColumn
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.JoinColumns (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.JoinColumns

No usage of javax.persistence.JoinColumns
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.JoinTable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.JoinTable

No usage of javax.persistence.JoinTable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Lob (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Lob

No usage of javax.persistence.Lob
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.LockModeType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.LockModeType

  • Packages that use LockModeType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of LockModeType in javax.persistence

      Methods in javax.persistence that return LockModeType
      Modifier and Type Method and Description
      LockModeType Query.getLockMode()
      Get the current lock mode for the query.
      LockModeType EntityManager.getLockMode(Object entity)
      Get the current lock mode for the entity instance.
      static LockModeType LockModeType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static LockModeType[] LockModeType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.persistence with parameters of type LockModeType
      Modifier and Type Method and Description
      <T> T EntityManager.find(Class<T> entityClass, Object primaryKey, LockModeType lockMode)
      Find by primary key and lock.
      <T> T EntityManager.find(Class<T> entityClass, Object primaryKey, LockModeType lockMode, Map<String,Object> properties)
      Find by primary key and lock, using the specified properties.
      void EntityManager.lock(Object entity, LockModeType lockMode)
      Lock an entity instance that is contained in the persistence context with the specified lock mode type.
      void EntityManager.lock(Object entity, LockModeType lockMode, Map<String,Object> properties)
      Lock an entity instance that is contained in the persistence context with the specified lock mode type and with specified properties.
      void EntityManager.refresh(Object entity, LockModeType lockMode)
      Refresh the state of the instance from the database, overwriting changes made to the entity, if any, and lock it with respect to given lock mode type.
      void EntityManager.refresh(Object entity, LockModeType lockMode, Map<String,Object> properties)
      Refresh the state of the instance from the database, overwriting changes made to the entity, if any, and lock it with respect to given lock mode type and with specified properties.
      TypedQuery<X> TypedQuery.setLockMode(LockModeType lockMode)
      Set the lock mode type to be used for the query execution.
      Query Query.setLockMode(LockModeType lockMode)
      Set the lock mode type to be used for the query execution.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.LockTimeoutException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.LockTimeoutException

No usage of javax.persistence.LockTimeoutException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ManyToMany (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ManyToMany

No usage of javax.persistence.ManyToMany
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ManyToOne (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ManyToOne

No usage of javax.persistence.ManyToOne
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.MapKey (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.MapKey

No usage of javax.persistence.MapKey
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.MapKeyClass (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.MapKeyClass

No usage of javax.persistence.MapKeyClass
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.MapKeyColumn (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.MapKeyColumn

No usage of javax.persistence.MapKeyColumn
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.MapKeyEnumerated (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.MapKeyEnumerated

No usage of javax.persistence.MapKeyEnumerated
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.MapKeyJoinColumn (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.MapKeyJoinColumn

No usage of javax.persistence.MapKeyJoinColumn
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.MapKeyJoinColumns (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.MapKeyJoinColumns

No usage of javax.persistence.MapKeyJoinColumns
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.MapKeyTemporal (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.MapKeyTemporal

No usage of javax.persistence.MapKeyTemporal
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.MappedSuperclass (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.MappedSuperclass

No usage of javax.persistence.MappedSuperclass
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.MapsId (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.MapsId

No usage of javax.persistence.MapsId
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NamedAttributeNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NamedAttributeNode

No usage of javax.persistence.NamedAttributeNode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NamedEntityGraph (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NamedEntityGraph

No usage of javax.persistence.NamedEntityGraph
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NamedEntityGraphs (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NamedEntityGraphs

No usage of javax.persistence.NamedEntityGraphs
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NamedNativeQueries (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NamedNativeQueries

No usage of javax.persistence.NamedNativeQueries
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NamedNativeQuery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NamedNativeQuery

No usage of javax.persistence.NamedNativeQuery
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NamedQueries (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NamedQueries

No usage of javax.persistence.NamedQueries
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NamedQuery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NamedQuery

No usage of javax.persistence.NamedQuery
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NamedStoredProcedureQueries (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NamedStoredProcedureQueries

No usage of javax.persistence.NamedStoredProcedureQueries
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NamedStoredProcedureQuery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NamedStoredProcedureQuery

No usage of javax.persistence.NamedStoredProcedureQuery
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NamedSubgraph (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NamedSubgraph

No usage of javax.persistence.NamedSubgraph
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NonUniqueResultException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NonUniqueResultException

No usage of javax.persistence.NonUniqueResultException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.NoResultException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.NoResultException

No usage of javax.persistence.NoResultException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.OneToMany (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.OneToMany

No usage of javax.persistence.OneToMany
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.OneToOne (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.OneToOne

No usage of javax.persistence.OneToOne
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.OptimisticLockException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.OptimisticLockException

No usage of javax.persistence.OptimisticLockException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.OrderBy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.OrderBy

No usage of javax.persistence.OrderBy
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.OrderColumn (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.OrderColumn

No usage of javax.persistence.OrderColumn
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ParameterMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ParameterMode

  • Packages that use ParameterMode
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of ParameterMode in javax.persistence

      Methods in javax.persistence that return ParameterMode
      Modifier and Type Method and Description
      static ParameterMode ParameterMode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ParameterMode[] ParameterMode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.persistence with parameters of type ParameterMode
      Modifier and Type Method and Description
      StoredProcedureQuery StoredProcedureQuery.registerStoredProcedureParameter(int position, Class type, ParameterMode mode)
      Register a positional parameter.
      StoredProcedureQuery StoredProcedureQuery.registerStoredProcedureParameter(String parameterName, Class type, ParameterMode mode)
      Register a named parameter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Persistence (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Persistence

No usage of javax.persistence.Persistence
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PersistenceContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PersistenceContext

No usage of javax.persistence.PersistenceContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PersistenceContexts (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PersistenceContexts

No usage of javax.persistence.PersistenceContexts
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PersistenceContextType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PersistenceContextType

  • Packages that use PersistenceContextType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of PersistenceContextType in javax.persistence

      Methods in javax.persistence that return PersistenceContextType
      Modifier and Type Method and Description
      static PersistenceContextType PersistenceContextType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static PersistenceContextType[] PersistenceContextType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PersistenceException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PersistenceException

  • Packages that use PersistenceException
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of PersistenceException in javax.persistence

      Subclasses of PersistenceException in javax.persistence
      Modifier and Type Class and Description
      class  EntityExistsException
      Thrown by the persistence provider when EntityManager.persist(Object) is called and the entity already exists.
      class  EntityNotFoundException
      Thrown by the persistence provider when an entity reference obtained by EntityManager.getReference is accessed but the entity does not exist.
      class  LockTimeoutException
      Thrown by the persistence provider when an pessimistic locking conflict occurs that does not result in transaction rollback.
      class  NonUniqueResultException
      Thrown by the persistence provider when Query.getSingleResult() or TypedQuery.getSingleResult() is executed on a query and there is more than one result from the query.
      class  NoResultException
      Thrown by the persistence provider when Query.getSingleResult() or TypedQuery.getSingleResult()is executed on a query and there is no result to return.
      class  OptimisticLockException
      Thrown by the persistence provider when an optimistic locking conflict occurs.
      class  PessimisticLockException
      Thrown by the persistence provider when an pessimistic locking conflict occurs.
      class  QueryTimeoutException
      Thrown by the persistence provider when a query times out and only the statement is rolled back.
      class  RollbackException
      Thrown by the persistence provider when EntityTransaction.commit() fails.
      class  TransactionRequiredException
      Thrown by the persistence provider when a transaction is required but is not active.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PersistenceProperty (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PersistenceProperty

No usage of javax.persistence.PersistenceProperty
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PersistenceUnit (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PersistenceUnit

No usage of javax.persistence.PersistenceUnit
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PersistenceUnits (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PersistenceUnits

No usage of javax.persistence.PersistenceUnits
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PessimisticLockException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PessimisticLockException

No usage of javax.persistence.PessimisticLockException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PessimisticLockScope (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PessimisticLockScope

  • Packages that use PessimisticLockScope
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of PessimisticLockScope in javax.persistence

      Methods in javax.persistence that return PessimisticLockScope
      Modifier and Type Method and Description
      static PessimisticLockScope PessimisticLockScope.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static PessimisticLockScope[] PessimisticLockScope.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PostLoad (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PostLoad

No usage of javax.persistence.PostLoad
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PostPersist (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PostPersist

No usage of javax.persistence.PostPersist
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PostRemove (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PostRemove

No usage of javax.persistence.PostRemove
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PostUpdate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PostUpdate

No usage of javax.persistence.PostUpdate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PrePersist (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PrePersist

No usage of javax.persistence.PrePersist
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PreRemove (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PreRemove

No usage of javax.persistence.PreRemove
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PreUpdate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PreUpdate

No usage of javax.persistence.PreUpdate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PrimaryKeyJoinColumn (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PrimaryKeyJoinColumn

No usage of javax.persistence.PrimaryKeyJoinColumn
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.PrimaryKeyJoinColumns (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.PrimaryKeyJoinColumns

No usage of javax.persistence.PrimaryKeyJoinColumns
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.QueryHint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.QueryHint

No usage of javax.persistence.QueryHint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.QueryTimeoutException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.QueryTimeoutException

No usage of javax.persistence.QueryTimeoutException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.RollbackException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.RollbackException

No usage of javax.persistence.RollbackException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.SecondaryTable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.SecondaryTable

No usage of javax.persistence.SecondaryTable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.SecondaryTables (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.SecondaryTables

No usage of javax.persistence.SecondaryTables
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.SequenceGenerator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.SequenceGenerator

No usage of javax.persistence.SequenceGenerator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.SharedCacheMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.SharedCacheMode

  • Packages that use SharedCacheMode
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.spi
    SPI for Java Persistence providers

    • Uses of SharedCacheMode in javax.persistence

      Methods in javax.persistence that return SharedCacheMode
      Modifier and Type Method and Description
      static SharedCacheMode SharedCacheMode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SharedCacheMode[] SharedCacheMode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.

    • Uses of SharedCacheMode in javax.persistence.spi

      Methods in javax.persistence.spi that return SharedCacheMode
      Modifier and Type Method and Description
      SharedCacheMode PersistenceUnitInfo.getSharedCacheMode()
      Returns the specification of how the provider must use a second-level cache for the persistence unit.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.SqlResultSetMapping (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.SqlResultSetMapping

No usage of javax.persistence.SqlResultSetMapping
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.SqlResultSetMappings (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.SqlResultSetMappings

No usage of javax.persistence.SqlResultSetMappings
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.StoredProcedureParameter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.StoredProcedureParameter

No usage of javax.persistence.StoredProcedureParameter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.SynchronizationType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.SynchronizationType

  • Packages that use SynchronizationType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of SynchronizationType in javax.persistence

      Methods in javax.persistence that return SynchronizationType
      Modifier and Type Method and Description
      static SynchronizationType SynchronizationType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SynchronizationType[] SynchronizationType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.persistence with parameters of type SynchronizationType
      Modifier and Type Method and Description
      EntityManager EntityManagerFactory.createEntityManager(SynchronizationType synchronizationType)
      Create a new JTA application-managed EntityManager with the specified synchronization type.
      EntityManager EntityManagerFactory.createEntityManager(SynchronizationType synchronizationType, Map map)
      Create a new JTA application-managed EntityManager with the specified synchronization type and map of properties.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Table (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Table

No usage of javax.persistence.Table
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.TableGenerator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.TableGenerator

No usage of javax.persistence.TableGenerator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Temporal (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Temporal

No usage of javax.persistence.Temporal
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.TemporalType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.TemporalType

  • Packages that use TemporalType
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of TemporalType in javax.persistence

      Methods in javax.persistence that return TemporalType
      Modifier and Type Method and Description
      static TemporalType TemporalType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static TemporalType[] TemporalType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.persistence with parameters of type TemporalType
      Modifier and Type Method and Description
      TypedQuery<X> TypedQuery.setParameter(int position, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a positional parameter.
      StoredProcedureQuery StoredProcedureQuery.setParameter(int position, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a positional parameter.
      Query Query.setParameter(int position, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a positional parameter.
      TypedQuery<X> TypedQuery.setParameter(int position, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a positional parameter.
      StoredProcedureQuery StoredProcedureQuery.setParameter(int position, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a positional parameter.
      Query Query.setParameter(int position, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a positional parameter.
      TypedQuery<X> TypedQuery.setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      StoredProcedureQuery StoredProcedureQuery.setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      Query Query.setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      TypedQuery<X> TypedQuery.setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      StoredProcedureQuery StoredProcedureQuery.setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      Query Query.setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      TypedQuery<X> TypedQuery.setParameter(String name, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a named parameter.
      StoredProcedureQuery StoredProcedureQuery.setParameter(String name, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a named parameter.
      Query Query.setParameter(String name, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a named parameter.
      TypedQuery<X> TypedQuery.setParameter(String name, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a named parameter.
      StoredProcedureQuery StoredProcedureQuery.setParameter(String name, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a named parameter.
      Query Query.setParameter(String name, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a named parameter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.TransactionRequiredException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.TransactionRequiredException

No usage of javax.persistence.TransactionRequiredException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Transient (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Transient

No usage of javax.persistence.Transient
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.UniqueConstraint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.UniqueConstraint

No usage of javax.persistence.UniqueConstraint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.ValidationMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.ValidationMode

  • Packages that use ValidationMode
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.spi
    SPI for Java Persistence providers

    • Uses of ValidationMode in javax.persistence

      Methods in javax.persistence that return ValidationMode
      Modifier and Type Method and Description
      static ValidationMode ValidationMode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ValidationMode[] ValidationMode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.

    • Uses of ValidationMode in javax.persistence.spi

      Methods in javax.persistence.spi that return ValidationMode
      Modifier and Type Method and Description
      ValidationMode PersistenceUnitInfo.getValidationMode()
      Returns the validation mode to be used by the persistence provider for the persistence unit.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.Version (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.Version

No usage of javax.persistence.Version
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.AttributeConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.AttributeConverter

No usage of javax.persistence.AttributeConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.AttributeNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.AttributeNode

  • Packages that use AttributeNode
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of AttributeNode in javax.persistence

      Methods in javax.persistence that return types with arguments of type AttributeNode
      Modifier and Type Method and Description
      List<AttributeNode<?>> Subgraph.getAttributeNodes()
      Return the attribute nodes corresponding to the attributes of this managed type that are included in the subgraph.
      List<AttributeNode<?>> EntityGraph.getAttributeNodes()
      Return the attribute nodes of this entity that are included in the entity graph.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.Cache (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.Cache

  • Packages that use Cache
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of Cache in javax.persistence

      Methods in javax.persistence that return Cache
      Modifier and Type Method and Description
      Cache EntityManagerFactory.getCache()
      Access the cache that is associated with the entity manager factory (the "second level cache").
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.EntityGraph (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.EntityGraph

  • Packages that use EntityGraph
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of EntityGraph in javax.persistence

      Methods in javax.persistence that return EntityGraph
      Modifier and Type Method and Description
      <T> EntityGraph<T> EntityManager.createEntityGraph(Class<T> rootType)
      Return a mutable EntityGraph that can be used to dynamically create an EntityGraph.
      EntityGraph<?> EntityManager.createEntityGraph(String graphName)
      Return a mutable copy of the named EntityGraph.
      EntityGraph<?> EntityManager.getEntityGraph(String graphName)
      Return a named EntityGraph.
      Methods in javax.persistence that return types with arguments of type EntityGraph
      Modifier and Type Method and Description
      <T> List<EntityGraph<? super T>> EntityManager.getEntityGraphs(Class<T> entityClass)
      Return all named EntityGraphs that have been defined for the provided class type.
      Methods in javax.persistence with parameters of type EntityGraph
      Modifier and Type Method and Description
      <T> void EntityManagerFactory.addNamedEntityGraph(String graphName, EntityGraph<T> entityGraph)
      Add a named copy of the EntityGraph to the EntityManagerFactory.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.EntityManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.EntityManager

  • Packages that use EntityManager
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of EntityManager in javax.persistence

      Methods in javax.persistence that return EntityManager
      Modifier and Type Method and Description
      EntityManager EntityManagerFactory.createEntityManager()
      Create a new application-managed EntityManager.
      EntityManager EntityManagerFactory.createEntityManager(Map map)
      Create a new application-managed EntityManager with the specified Map of properties.
      EntityManager EntityManagerFactory.createEntityManager(SynchronizationType synchronizationType)
      Create a new JTA application-managed EntityManager with the specified synchronization type.
      EntityManager EntityManagerFactory.createEntityManager(SynchronizationType synchronizationType, Map map)
      Create a new JTA application-managed EntityManager with the specified synchronization type and map of properties.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.EntityManagerFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.EntityManagerFactory

  • Packages that use EntityManagerFactory
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.spi
    SPI for Java Persistence providers

    • Uses of EntityManagerFactory in javax.persistence

      Methods in javax.persistence that return EntityManagerFactory
      Modifier and Type Method and Description
      static EntityManagerFactory Persistence.createEntityManagerFactory(String persistenceUnitName)
      Create and return an EntityManagerFactory for the named persistence unit.
      static EntityManagerFactory Persistence.createEntityManagerFactory(String persistenceUnitName, Map properties)
      Create and return an EntityManagerFactory for the named persistence unit using the given properties.
      EntityManagerFactory EntityManager.getEntityManagerFactory()
      Return the entity manager factory for the entity manager.

    • Uses of EntityManagerFactory in javax.persistence.spi

      Methods in javax.persistence.spi that return EntityManagerFactory
      Modifier and Type Method and Description
      EntityManagerFactory PersistenceProvider.createContainerEntityManagerFactory(PersistenceUnitInfo info, Map map)
      Called by the container when an EntityManagerFactory is to be created.
      EntityManagerFactory PersistenceProvider.createEntityManagerFactory(String emName, Map map)
      Called by Persistence class when an EntityManagerFactory is to be created.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.EntityTransaction (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.EntityTransaction

  • Packages that use EntityTransaction
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of EntityTransaction in javax.persistence

      Methods in javax.persistence that return EntityTransaction
      Modifier and Type Method and Description
      EntityTransaction EntityManager.getTransaction()
      Return the resource-level EntityTransaction object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.Parameter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.Parameter

  • Packages that use Parameter
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Parameter in javax.persistence

      Methods in javax.persistence that return Parameter
      Modifier and Type Method and Description
      Parameter<?> Query.getParameter(int position)
      Get the parameter object corresponding to the declared positional parameter with the given position.
      <T> Parameter<T> Query.getParameter(int position, Class<T> type)
      Get the parameter object corresponding to the declared positional parameter with the given position and type.
      Parameter<?> Query.getParameter(String name)
      Get the parameter object corresponding to the declared parameter of the given name.
      <T> Parameter<T> Query.getParameter(String name, Class<T> type)
      Get the parameter object corresponding to the declared parameter of the given name and type.
      Methods in javax.persistence that return types with arguments of type Parameter
      Modifier and Type Method and Description
      Set<Parameter<?>> Query.getParameters()
      Get the parameter objects corresponding to the declared parameters of the query.
      Methods in javax.persistence with parameters of type Parameter
      Modifier and Type Method and Description
      <T> T Query.getParameterValue(Parameter<T> param)
      Return the input value bound to the parameter.
      boolean Query.isBound(Parameter<?> param)
      Return a boolean indicating whether a value has been bound to the parameter.
      TypedQuery<X> TypedQuery.setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      StoredProcedureQuery StoredProcedureQuery.setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      Query Query.setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      TypedQuery<X> TypedQuery.setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      StoredProcedureQuery StoredProcedureQuery.setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      Query Query.setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      <T> TypedQuery<X> TypedQuery.setParameter(Parameter<T> param, T value)
      Bind the value of a Parameter object.
      <T> StoredProcedureQuery StoredProcedureQuery.setParameter(Parameter<T> param, T value)
      Bind the value of a Parameter object.
      <T> Query Query.setParameter(Parameter<T> param, T value)
      Bind the value of a Parameter object.

    • Uses of Parameter in javax.persistence.criteria

      Subinterfaces of Parameter in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  ParameterExpression<T>
      Type of criteria query parameter expressions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.PersistenceUnitUtil (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.PersistenceUnitUtil

  • Packages that use PersistenceUnitUtil
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of PersistenceUnitUtil in javax.persistence

      Methods in javax.persistence that return PersistenceUnitUtil
      Modifier and Type Method and Description
      PersistenceUnitUtil EntityManagerFactory.getPersistenceUnitUtil()
      Return interface providing access to utility methods for the persistence unit.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.PersistenceUtil (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.PersistenceUtil

  • Packages that use PersistenceUtil
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of PersistenceUtil in javax.persistence

      Subinterfaces of PersistenceUtil in javax.persistence
      Modifier and Type Interface and Description
      interface  PersistenceUnitUtil
      Utility interface between the application and the persistence provider managing the persistence unit.
      Methods in javax.persistence that return PersistenceUtil
      Modifier and Type Method and Description
      static PersistenceUtil Persistence.getPersistenceUtil()
      Return the PersistenceUtil instance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.Query (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.Query

  • Packages that use Query
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of Query in javax.persistence

      Subinterfaces of Query in javax.persistence
      Modifier and Type Interface and Description
      interface  StoredProcedureQuery
      Interface used to control stored procedure query execution.
      interface  TypedQuery<X>
      Interface used to control the execution of typed queries.
      Methods in javax.persistence that return Query
      Modifier and Type Method and Description
      Query EntityManager.createNamedQuery(String name)
      Create an instance of Query for executing a named query (in the Java Persistence query language or in native SQL).
      Query EntityManager.createNativeQuery(String sqlString)
      Create an instance of Query for executing a native SQL statement, e.g., for update or delete.
      Query EntityManager.createNativeQuery(String sqlString, Class resultClass)
      Create an instance of Query for executing a native SQL query.
      Query EntityManager.createNativeQuery(String sqlString, String resultSetMapping)
      Create an instance of Query for executing a native SQL query.
      Query EntityManager.createQuery(CriteriaDelete deleteQuery)
      Create an instance of Query for executing a criteria delete query.
      Query EntityManager.createQuery(CriteriaUpdate updateQuery)
      Create an instance of Query for executing a criteria update query.
      Query EntityManager.createQuery(String qlString)
      Create an instance of Query for executing a Java Persistence query language statement.
      Query QueryTimeoutException.getQuery()
      Returns the query that caused this exception.
      Query Query.setFirstResult(int startPosition)
      Set the position of the first result to retrieve.
      Query Query.setFlushMode(FlushModeType flushMode)
      Set the flush mode type to be used for the query execution.
      Query Query.setHint(String hintName, Object value)
      Set a query property or hint.
      Query Query.setLockMode(LockModeType lockMode)
      Set the lock mode type to be used for the query execution.
      Query Query.setMaxResults(int maxResult)
      Set the maximum number of results to retrieve.
      Query Query.setParameter(int position, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a positional parameter.
      Query Query.setParameter(int position, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a positional parameter.
      Query Query.setParameter(int position, Object value)
      Bind an argument value to a positional parameter.
      Query Query.setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      Query Query.setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      <T> Query Query.setParameter(Parameter<T> param, T value)
      Bind the value of a Parameter object.
      Query Query.setParameter(String name, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a named parameter.
      Query Query.setParameter(String name, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a named parameter.
      Query Query.setParameter(String name, Object value)
      Bind an argument value to a named parameter.
      Methods in javax.persistence with parameters of type Query
      Modifier and Type Method and Description
      void EntityManagerFactory.addNamedQuery(String name, Query query)
      Define the query, typed query, or stored procedure query as a named query such that future query objects can be created from it using the createNamedQuery or createNamedStoredProcedureQuery method.
      Constructors in javax.persistence with parameters of type Query
      Constructor and Description
      QueryTimeoutException(Query query)
      Constructs a new QueryTimeoutException exception with the specified query.
      QueryTimeoutException(String message, Throwable cause, Query query)
      Constructs a new QueryTimeoutException exception with the specified detail message, cause, and query.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.StoredProcedureQuery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.StoredProcedureQuery

  • Packages that use StoredProcedureQuery
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of StoredProcedureQuery in javax.persistence

      Methods in javax.persistence that return StoredProcedureQuery
      Modifier and Type Method and Description
      StoredProcedureQuery EntityManager.createNamedStoredProcedureQuery(String name)
      Create an instance of StoredProcedureQuery for executing a stored procedure in the database.
      StoredProcedureQuery EntityManager.createStoredProcedureQuery(String procedureName)
      Create an instance of StoredProcedureQuery for executing a stored procedure in the database.
      StoredProcedureQuery EntityManager.createStoredProcedureQuery(String procedureName, Class... resultClasses)
      Create an instance of StoredProcedureQuery for executing a stored procedure in the database.
      StoredProcedureQuery EntityManager.createStoredProcedureQuery(String procedureName, String... resultSetMappings)
      Create an instance of StoredProcedureQuery for executing a stored procedure in the database.
      StoredProcedureQuery StoredProcedureQuery.registerStoredProcedureParameter(int position, Class type, ParameterMode mode)
      Register a positional parameter.
      StoredProcedureQuery StoredProcedureQuery.registerStoredProcedureParameter(String parameterName, Class type, ParameterMode mode)
      Register a named parameter.
      StoredProcedureQuery StoredProcedureQuery.setFlushMode(FlushModeType flushMode)
      Set the flush mode type to be used for the query execution.
      StoredProcedureQuery StoredProcedureQuery.setHint(String hintName, Object value)
      Set a query property or hint.
      StoredProcedureQuery StoredProcedureQuery.setParameter(int position, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a positional parameter.
      StoredProcedureQuery StoredProcedureQuery.setParameter(int position, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a positional parameter.
      StoredProcedureQuery StoredProcedureQuery.setParameter(int position, Object value)
      Bind an argument value to a positional parameter.
      StoredProcedureQuery StoredProcedureQuery.setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      StoredProcedureQuery StoredProcedureQuery.setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      <T> StoredProcedureQuery StoredProcedureQuery.setParameter(Parameter<T> param, T value)
      Bind the value of a Parameter object.
      StoredProcedureQuery StoredProcedureQuery.setParameter(String name, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a named parameter.
      StoredProcedureQuery StoredProcedureQuery.setParameter(String name, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a named parameter.
      StoredProcedureQuery StoredProcedureQuery.setParameter(String name, Object value)
      Bind an argument value to a named parameter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.Subgraph (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.Subgraph

  • Packages that use Subgraph
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of Subgraph in javax.persistence

      Methods in javax.persistence that return Subgraph
      Modifier and Type Method and Description
      <X> Subgraph<X> Subgraph.addKeySubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a map key that is a managed type.
      <X> Subgraph<X> EntityGraph.addKeySubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a map key that is a managed type.
      <X> Subgraph<? extends X> Subgraph.addKeySubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a map key that is a managed type with inheritance.
      <X> Subgraph<? extends X> EntityGraph.addKeySubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a map key that is a managed type with inheritance.
      <X> Subgraph<X> Subgraph.addKeySubgraph(String attributeName)
      Add a node to the graph that corresponds to a map key that is a managed type.
      <X> Subgraph<X> EntityGraph.addKeySubgraph(String attributeName)
      Add a node to the graph that corresponds to a map key that is a managed type.
      <X> Subgraph<X> Subgraph.addKeySubgraph(String attributeName, Class<X> type)
      Add a node to the graph that corresponds to a map key that is a managed type with inheritance.
      <X> Subgraph<X> EntityGraph.addKeySubgraph(String attributeName, Class<X> type)
      Add a node to the graph that corresponds to a map key that is a managed type with inheritance.
      <T> Subgraph<? extends T> EntityGraph.addSubclassSubgraph(Class<? extends T> type)
      Add additional attributes to this entity graph that correspond to attributes of subclasses of this EntityGraph's entity type.
      <X> Subgraph<X> Subgraph.addSubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a managed type.
      <X> Subgraph<X> EntityGraph.addSubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a managed type.
      <X> Subgraph<? extends X> Subgraph.addSubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a managed type with inheritance.
      <X> Subgraph<? extends X> EntityGraph.addSubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a managed type with inheritance.
      <X> Subgraph<X> Subgraph.addSubgraph(String attributeName)
      Add a node to the graph that corresponds to a managed type.
      <X> Subgraph<X> EntityGraph.addSubgraph(String attributeName)
      Add a node to the graph that corresponds to a managed type.
      <X> Subgraph<X> Subgraph.addSubgraph(String attributeName, Class<X> type)
      Add a node to the graph that corresponds to a managed type with inheritance.
      <X> Subgraph<X> EntityGraph.addSubgraph(String attributeName, Class<X> type)
      Add a node to the graph that corresponds to a managed type with inheritance.
      Methods in javax.persistence that return types with arguments of type Subgraph
      Modifier and Type Method and Description
      Map<Class,Subgraph> AttributeNode.getKeySubgraphs()
      Return the Map<Class, Subgraph> of subgraphs associated with this attribute node's map key.
      Map<Class,Subgraph> AttributeNode.getSubgraphs()
      Return the Map<Class, Subgraph> of subgraphs associated with this attribute node.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.Tuple (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.Tuple

  • Packages that use Tuple
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Tuple in javax.persistence.criteria

      Methods in javax.persistence.criteria that return types with arguments of type Tuple
      Modifier and Type Method and Description
      CriteriaQuery<Tuple> CriteriaBuilder.createTupleQuery()
      Create a CriteriaQuery object that returns a tuple of objects as its result.
      CompoundSelection<Tuple> CriteriaBuilder.tuple(Selection<?>... selections)
      Create a tuple-valued selection item.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.TupleElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.TupleElement

  • Packages that use TupleElement
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of TupleElement in javax.persistence

      Methods in javax.persistence that return types with arguments of type TupleElement
      Modifier and Type Method and Description
      List<TupleElement<?>> Tuple.getElements()
      Return the tuple elements.
      Methods in javax.persistence with parameters of type TupleElement
      Modifier and Type Method and Description
      <X> X Tuple.get(TupleElement<X> tupleElement)
      Get the value of the specified tuple element.

    • Uses of TupleElement in javax.persistence.criteria

      Subinterfaces of TupleElement in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  CollectionJoin<Z,E>
      The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
      interface  CompoundSelection<X>
      The CompoundSelection interface defines a compound selection item (tuple, array, or result of constructor).
      static interface  CriteriaBuilder.Case<R>
      Interface used to build general case expressions.
      static interface  CriteriaBuilder.Coalesce<T>
      Interface used to build coalesce expressions.
      static interface  CriteriaBuilder.In<T>
      Interface used to build in predicates.
      static interface  CriteriaBuilder.SimpleCase<C,R>
      Interface used to build simple case expressions.
      interface  Expression<T>
      Type for query expressions.
      interface  From<Z,X>
      Represents a bound type, usually an entity that appears in the from clause, but may also be an embeddable belonging to an entity in the from clause.
      interface  Join<Z,X>
      A join to an entity, embeddable, or basic type.
      interface  ListJoin<Z,E>
      The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
      interface  MapJoin<Z,K,V>
      The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
      interface  ParameterExpression<T>
      Type of criteria query parameter expressions.
      interface  Path<X>
      Represents a simple or compound attribute path from a bound type or collection, and is a "primitive" expression.
      interface  PluralJoin<Z,C,E>
      The PluralJoin interface defines functionality that is common to joins to all collection types.
      interface  Predicate
      The type of a simple or compound predicate: a conjunction or disjunction of restrictions.
      interface  Root<X>
      A root type in the from clause.
      interface  Selection<X>
      The Selection interface defines an item that is to be returned in a query result.
      interface  SetJoin<Z,E>
      The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
      interface  Subquery<T>
      The Subquery interface defines functionality that is specific to subqueries.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.TypedQuery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.TypedQuery

  • Packages that use TypedQuery
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of TypedQuery in javax.persistence

      Methods in javax.persistence that return TypedQuery
      Modifier and Type Method and Description
      <T> TypedQuery<T> EntityManager.createNamedQuery(String name, Class<T> resultClass)
      Create an instance of TypedQuery for executing a Java Persistence query language named query.
      <T> TypedQuery<T> EntityManager.createQuery(CriteriaQuery<T> criteriaQuery)
      Create an instance of TypedQuery for executing a criteria query.
      <T> TypedQuery<T> EntityManager.createQuery(String qlString, Class<T> resultClass)
      Create an instance of TypedQuery for executing a Java Persistence query language statement.
      TypedQuery<X> TypedQuery.setFirstResult(int startPosition)
      Set the position of the first result to retrieve.
      TypedQuery<X> TypedQuery.setFlushMode(FlushModeType flushMode)
      Set the flush mode type to be used for the query execution.
      TypedQuery<X> TypedQuery.setHint(String hintName, Object value)
      Set a query property or hint.
      TypedQuery<X> TypedQuery.setLockMode(LockModeType lockMode)
      Set the lock mode type to be used for the query execution.
      TypedQuery<X> TypedQuery.setMaxResults(int maxResult)
      Set the maximum number of results to retrieve.
      TypedQuery<X> TypedQuery.setParameter(int position, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a positional parameter.
      TypedQuery<X> TypedQuery.setParameter(int position, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a positional parameter.
      TypedQuery<X> TypedQuery.setParameter(int position, Object value)
      Bind an argument value to a positional parameter.
      TypedQuery<X> TypedQuery.setParameter(Parameter<Calendar> param, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a Parameter object.
      TypedQuery<X> TypedQuery.setParameter(Parameter<Date> param, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a Parameter object.
      <T> TypedQuery<X> TypedQuery.setParameter(Parameter<T> param, T value)
      Bind the value of a Parameter object.
      TypedQuery<X> TypedQuery.setParameter(String name, Calendar value, TemporalType temporalType)
      Bind an instance of java.util.Calendar to a named parameter.
      TypedQuery<X> TypedQuery.setParameter(String name, Date value, TemporalType temporalType)
      Bind an instance of java.util.Date to a named parameter.
      TypedQuery<X> TypedQuery.setParameter(String name, Object value)
      Bind an argument value to a named parameter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AbstractQuery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface AbstractQuery<T>

  • Type Parameters:
    T - the type of the result
    All Superinterfaces:
    CommonAbstractCriteria
    All Known Subinterfaces:
    CriteriaQuery<T>, Subquery<T>

    public interface AbstractQuery<T>
extends CommonAbstractCriteria
    The AbstractQuery interface defines functionality that is common to both top-level queries and subqueries. It is not intended to be used directly in query construction.

    All queries must have: a set of root entities (which may in turn own joins).

    All queries may have: a conjunction of restrictions.

    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      AbstractQuery<T> distinct(boolean distinct)
      Specify whether duplicate query results will be eliminated.
      <X> Root<X> from(Class<X> entityClass)
      Create and add a query root corresponding to the given entity, forming a cartesian product with any existing roots.
      <X> Root<X> from(EntityType<X> entity)
      Create and add a query root corresponding to the given entity, forming a cartesian product with any existing roots.
      List<Expression<?>> getGroupList()
      Return a list of the grouping expressions.
      Predicate getGroupRestriction()
      Return the predicate that corresponds to the restriction(s) over the grouping items, or null if no restrictions have been specified.
      Class<T> getResultType()
      Return the result type of the query or subquery.
      Set<Root<?>> getRoots()
      Return the query roots.
      Selection<T> getSelection()
      Return the selection of the query, or null if no selection has been set.
      AbstractQuery<T> groupBy(Expression<?>... grouping)
      Specify the expressions that are used to form groups over the query results.
      AbstractQuery<T> groupBy(List<Expression<?>> grouping)
      Specify the expressions that are used to form groups over the query results.
      AbstractQuery<T> having(Expression<Boolean> restriction)
      Specify a restriction over the groups of the query.
      AbstractQuery<T> having(Predicate... restrictions)
      Specify restrictions over the groups of the query according the conjunction of the specified restriction predicates.
      boolean isDistinct()
      Return whether duplicate query results must be eliminated or retained.
      AbstractQuery<T> where(Expression<Boolean> restriction)
      Modify the query to restrict the query results according to the specified boolean expression.
      AbstractQuery<T> where(Predicate... restrictions)
      Modify the query to restrict the query results according to the conjunction of the specified restriction predicates.

      • Methods inherited from interface javax.persistence.criteria.CommonAbstractCriteria

        getRestriction, subquery

    • Method Detail

      • from

        <X> Root<X> from(Class<X> entityClass)
        Create and add a query root corresponding to the given entity, forming a cartesian product with any existing roots.
        Parameters:
        entityClass - the entity class
        Returns:
        query root corresponding to the given entity

      • from

        <X> Root<X> from(EntityType<X> entity)
        Create and add a query root corresponding to the given entity, forming a cartesian product with any existing roots.
        Parameters:
        entity - metamodel entity representing the entity of type X
        Returns:
        query root corresponding to the given entity

      • where

        AbstractQuery<T> where(Expression<Boolean> restriction)
        Modify the query to restrict the query results according to the specified boolean expression. Replaces the previously added restriction(s), if any.
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified query

      • where

        AbstractQuery<T> where(Predicate... restrictions)
        Modify the query to restrict the query results according to the conjunction of the specified restriction predicates. Replaces the previously added restriction(s), if any. If no restrictions are specified, any previously added restrictions are simply removed.
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified query

      • groupBy

        AbstractQuery<T> groupBy(Expression<?>... grouping)
        Specify the expressions that are used to form groups over the query results. Replaces the previous specified grouping expressions, if any. If no grouping expressions are specified, any previously added grouping expressions are simply removed.
        Parameters:
        grouping - zero or more grouping expressions
        Returns:
        the modified query

      • groupBy

        AbstractQuery<T> groupBy(List<Expression<?>> grouping)
        Specify the expressions that are used to form groups over the query results. Replaces the previous specified grouping expressions, if any. If no grouping expressions are specified, any previously added grouping expressions are simply removed.
        Parameters:
        grouping - list of zero or more grouping expressions
        Returns:
        the modified query

      • having

        AbstractQuery<T> having(Expression<Boolean> restriction)
        Specify a restriction over the groups of the query. Replaces the previous having restriction(s), if any.
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified query

      • having

        AbstractQuery<T> having(Predicate... restrictions)
        Specify restrictions over the groups of the query according the conjunction of the specified restriction predicates. Replaces the previously having added restriction(s), if any. If no restrictions are specified, any previously added restrictions are simply removed.
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified query

      • distinct

        AbstractQuery<T> distinct(boolean distinct)
        Specify whether duplicate query results will be eliminated. A true value will cause duplicates to be eliminated. A false value will cause duplicates to be retained. If distinct has not been specified, duplicate results must be retained.
        Parameters:
        distinct - boolean value specifying whether duplicate results must be eliminated from the query result or whether they must be retained
        Returns:
        the modified query

      • getRoots

        Set<Root<?>> getRoots()
        Return the query roots. These are the roots that have been defined for the CriteriaQuery or Subquery itself, including any subquery roots defined as a result of correlation. Returns empty set if no roots have been defined. Modifications to the set do not affect the query.
        Returns:
        the set of query roots

      • getSelection

        Selection<T> getSelection()
        Return the selection of the query, or null if no selection has been set.
        Returns:
        selection item

      • getGroupList

        List<Expression<?>> getGroupList()
        Return a list of the grouping expressions. Returns empty list if no grouping expressions have been specified. Modifications to the list do not affect the query.
        Returns:
        the list of grouping expressions

      • getGroupRestriction

        Predicate getGroupRestriction()
        Return the predicate that corresponds to the restriction(s) over the grouping items, or null if no restrictions have been specified.
        Returns:
        having clause predicate

      • isDistinct

        boolean isDistinct()
        Return whether duplicate query results must be eliminated or retained.
        Returns:
        boolean indicating whether duplicate query results must be eliminated

      • getResultType

        Class<T> getResultType()
        Return the result type of the query or subquery. If a result type was specified as an argument to the createQuery or subquery method, that type will be returned. If the query was created using the createTupleQuery method, the result type is Tuple. Otherwise, the result type is Object.
        Returns:
        result type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CollectionJoin (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CollectionJoin<Z,E>

  • Type Parameters:
    Z - the source type of the join
    E - the element type of the target Collection
    All Superinterfaces:
    Expression<E>, FetchParent<Z,E>, From<Z,E>, Join<Z,E>, Path<E>, PluralJoin<Z,Collection<E>,E>, Selection<E>, TupleElement<E>

    public interface CollectionJoin<Z,E>
extends PluralJoin<Z,Collection<E>,E>
    The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CollectionAttribute<? super Z,E> getModel()
      Return the metamodel representation for the collection attribute.
      CollectionJoin<Z,E> on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      CollectionJoin<Z,E> on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.

      • Methods inherited from interface javax.persistence.criteria.Join

        getAttribute, getJoinType, getOn, getParent

      • Methods inherited from interface javax.persistence.criteria.From

        getCorrelationParent, getJoins, isCorrelated, join, join, join, join, join, join, join, join, join, join, join, join, joinCollection, joinCollection, joinList, joinList, joinMap, joinMap, joinSet, joinSet

      • Methods inherited from interface javax.persistence.criteria.Path

        get, get, get, get, getParentPath, type

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

      • Methods inherited from interface javax.persistence.criteria.FetchParent

        fetch, fetch, fetch, fetch, fetch, fetch, getFetches

    • Method Detail

      • on

        CollectionJoin<Z,E> on(Expression<Boolean> restriction)
        Modify the join to restrict the result according to the specified ON condition and return the join object. Replaces the previous ON condition, if any.
        Specified by:
        on in interface Join<Z,E>
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified join object
        Since:
        Java Persistence 2.1

      • on

        CollectionJoin<Z,E> on(Predicate... restrictions)
        Modify the join to restrict the result according to the specified ON condition and return the join object. Replaces the previous ON condition, if any.
        Specified by:
        on in interface Join<Z,E>
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified join object
        Since:
        Java Persistence 2.1

      • getModel

        CollectionAttribute<? super Z,E> getModel()
        Return the metamodel representation for the collection attribute.
        Specified by:
        getModel in interface Path<E>
        Specified by:
        getModel in interface PluralJoin<Z,Collection<E>,E>
        Returns:
        metamodel type representing the Collection that is the target of the join
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CommonAbstractCriteria (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CommonAbstractCriteria

  • All Known Subinterfaces:
    AbstractQuery<T>, CriteriaDelete<T>, CriteriaQuery<T>, CriteriaUpdate<T>, Subquery<T>

    public interface CommonAbstractCriteria
    The CommonAbstractCriteria interface defines functionality that is common to both top-level criteria queries and subqueries as well as to update and delete criteria operations. It is not intended to be used directly in query construction.

    Note that criteria queries and criteria update and delete operations are typed differently. Criteria queries are typed according to the query result type. Update and delete operations are typed according to the target of the update or delete.

    Since:
    Java Persistence 2.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Predicate getRestriction()
      Return the predicate that corresponds to the where clause restriction(s), or null if no restrictions have been specified.
      <U> Subquery<U> subquery(Class<U> type)
      Create a subquery of the query.

    • Method Detail

      • subquery

        <U> Subquery<U> subquery(Class<U> type)
        Create a subquery of the query.
        Parameters:
        type - the subquery result type
        Returns:
        subquery

      • getRestriction

        Predicate getRestriction()
        Return the predicate that corresponds to the where clause restriction(s), or null if no restrictions have been specified.
        Returns:
        where clause predicate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CompoundSelection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CompoundSelection<X>

  • Type Parameters:
    X - the type of the selection item
    All Superinterfaces:
    Selection<X>, TupleElement<X>

    public interface CompoundSelection<X>
extends Selection<X>
    The CompoundSelection interface defines a compound selection item (tuple, array, or result of constructor).
    Since:
    Java Persistence 2.0

    • Method Summary

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CriteriaBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CriteriaBuilder

  • public interface CriteriaBuilder
    Used to construct criteria queries, compound selections, expressions, predicates, orderings.

    Note that Predicate is used instead of Expression<Boolean> in this API in order to work around the fact that Java generics are not compatible with varags.

    Since:
    Java Persistence 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  CriteriaBuilder.Case<R>
      Interface used to build general case expressions.
      static interface  CriteriaBuilder.Coalesce<T>
      Interface used to build coalesce expressions.
      static interface  CriteriaBuilder.In<T>
      Interface used to build in predicates.
      static interface  CriteriaBuilder.SimpleCase<C,R>
      Interface used to build simple case expressions.
      static class  CriteriaBuilder.Trimspec
      Used to specify how strings are trimmed.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <N extends Number>
      Expression<N>             		abs(Expression<N> x)
      Create an expression that returns the absolute value of its argument.
      <Y> Expression<Y> all(Subquery<Y> subquery)
      Create an all expression over the subquery results.
      Predicate and(Expression<Boolean> x, Expression<Boolean> y)
      Create a conjunction of the given boolean expressions.
      Predicate and(Predicate... restrictions)
      Create a conjunction of the given restriction predicates.
      <Y> Expression<Y> any(Subquery<Y> subquery)
      Create an any expression over the subquery results.
      CompoundSelection<Object[]> array(Selection<?>... selections)
      Create an array-valued selection item.
      Order asc(Expression<?> x)
      Create an ordering by the ascending value of the expression.
      <N extends Number>
      Expression<Double>             		avg(Expression<N> x)
      Create an aggregate expression applying the avg operation.
      <Y extends Comparable<? super Y>>
      Predicate             		between(Expression<? extends Y> v, Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is between the second and third arguments in value.
      <Y extends Comparable<? super Y>>
      Predicate             		between(Expression<? extends Y> v, Y x, Y y)
      Create a predicate for testing whether the first argument is between the second and third arguments in value.
      <T> CriteriaBuilder.Coalesce<T> coalesce()
      Create a coalesce expression.
      <Y> Expression<Y> coalesce(Expression<? extends Y> x, Expression<? extends Y> y)
      Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.
      <Y> Expression<Y> coalesce(Expression<? extends Y> x, Y y)
      Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.
      Expression<String> concat(Expression<String> x, Expression<String> y)
      Create an expression for string concatenation.
      Expression<String> concat(Expression<String> x, String y)
      Create an expression for string concatenation.
      Expression<String> concat(String x, Expression<String> y)
      Create an expression for string concatenation.
      Predicate conjunction()
      Create a conjunction (with zero conjuncts).
      <Y> CompoundSelection<Y> construct(Class<Y> resultClass, Selection<?>... selections)
      Create a selection item corresponding to a constructor.
      Expression<Long> count(Expression<?> x)
      Create an aggregate expression applying the count operation.
      Expression<Long> countDistinct(Expression<?> x)
      Create an aggregate expression applying the count distinct operation.
      <T> CriteriaDelete<T> createCriteriaDelete(Class<T> targetEntity)
      Create a CriteriaDelete query object to perform a bulk delete operation.
      <T> CriteriaUpdate<T> createCriteriaUpdate(Class<T> targetEntity)
      Create a CriteriaUpdate query object to perform a bulk update operation.
      CriteriaQuery<Object> createQuery()
      Create a CriteriaQuery object.
      <T> CriteriaQuery<T> createQuery(Class<T> resultClass)
      Create a CriteriaQuery object with the specified result type.
      CriteriaQuery<Tuple> createTupleQuery()
      Create a CriteriaQuery object that returns a tuple of objects as its result.
      Expression<Date> currentDate()
      Create expression to return current date.
      Expression<Time> currentTime()
      Create expression to return current time.
      Expression<Timestamp> currentTimestamp()
      Create expression to return current timestamp.
      Order desc(Expression<?> x)
      Create an ordering by the descending value of the expression.
      <N extends Number>
      Expression<N>             		diff(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the difference between its arguments.
      <N extends Number>
      Expression<N>             		diff(Expression<? extends N> x, N y)
      Create an expression that returns the difference between its arguments.
      <N extends Number>
      Expression<N>             		diff(N x, Expression<? extends N> y)
      Create an expression that returns the difference between its arguments.
      Predicate disjunction()
      Create a disjunction (with zero disjuncts).
      Predicate equal(Expression<?> x, Expression<?> y)
      Create a predicate for testing the arguments for equality.
      Predicate equal(Expression<?> x, Object y)
      Create a predicate for testing the arguments for equality.
      Predicate exists(Subquery<?> subquery)
      Create a predicate testing the existence of a subquery result.
      <T> Expression<T> function(String name, Class<T> type, Expression<?>... args)
      Create an expression for the execution of a database function.
      Predicate ge(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      Predicate ge(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		greaterThan(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is greater than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		greaterThan(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is greater than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		greaterThanOrEqualTo(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		greaterThanOrEqualTo(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      <X extends Comparable<? super X>>
      Expression<X>             		greatest(Expression<X> x)
      Create an aggregate expression for finding the greatest of the values (strings, dates, etc).
      Predicate gt(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is greater than the second.
      Predicate gt(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is greater than the second.
      <T> CriteriaBuilder.In<T> in(Expression<? extends T> expression)
      Create predicate to test whether given expression is contained in a list of values.
      <C extends Collection<?>>
      Predicate             		isEmpty(Expression<C> collection)
      Create a predicate that tests whether a collection is empty.
      Predicate isFalse(Expression<Boolean> x)
      Create a predicate testing for a false value.
      <E,C extends Collection<E>>
      Predicate             		isMember(E elem, Expression<C> collection)
      Create a predicate that tests whether an element is a member of a collection.
      <E,C extends Collection<E>>
      Predicate             		isMember(Expression<E> elem, Expression<C> collection)
      Create a predicate that tests whether an element is a member of a collection.
      <C extends Collection<?>>
      Predicate             		isNotEmpty(Expression<C> collection)
      Create a predicate that tests whether a collection is not empty.
      <E,C extends Collection<E>>
      Predicate             		isNotMember(E elem, Expression<C> collection)
      Create a predicate that tests whether an element is not a member of a collection.
      <E,C extends Collection<E>>
      Predicate             		isNotMember(Expression<E> elem, Expression<C> collection)
      Create a predicate that tests whether an element is not a member of a collection.
      Predicate isNotNull(Expression<?> x)
      Create a predicate to test whether the expression is not null.
      Predicate isNull(Expression<?> x)
      Create a predicate to test whether the expression is null.
      Predicate isTrue(Expression<Boolean> x)
      Create a predicate testing for a true value.
      <K,M extends Map<K,?>>
      Expression<Set<K>>             		keys(M map)
      Create an expression that returns the keys of a map.
      Predicate le(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      Predicate le(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      <X extends Comparable<? super X>>
      Expression<X>             		least(Expression<X> x)
      Create an aggregate expression for finding the least of the values (strings, dates, etc).
      Expression<Integer> length(Expression<String> x)
      Create expression to return length of a string.
      <Y extends Comparable<? super Y>>
      Predicate             		lessThan(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is less than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		lessThan(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is less than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		lessThanOrEqualTo(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		lessThanOrEqualTo(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      Predicate like(Expression<String> x, Expression<String> pattern)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate like(Expression<String> x, Expression<String> pattern, char escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate like(Expression<String> x, Expression<String> pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate like(Expression<String> x, String pattern)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate like(Expression<String> x, String pattern, char escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate like(Expression<String> x, String pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      <T> Expression<T> literal(T value)
      Create an expression for a literal.
      Expression<Integer> locate(Expression<String> x, Expression<String> pattern)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> locate(Expression<String> x, Expression<String> pattern, Expression<Integer> from)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> locate(Expression<String> x, String pattern)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> locate(Expression<String> x, String pattern, int from)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<String> lower(Expression<String> x)
      Create expression for converting a string to lowercase.
      Predicate lt(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is less than the second.
      Predicate lt(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is less than the second.
      <N extends Number>
      Expression<N>             		max(Expression<N> x)
      Create an aggregate expression applying the numerical max operation.
      <N extends Number>
      Expression<N>             		min(Expression<N> x)
      Create an aggregate expression applying the numerical min operation.
      Expression<Integer> mod(Expression<Integer> x, Expression<Integer> y)
      Create an expression that returns the modulus of its arguments.
      Expression<Integer> mod(Expression<Integer> x, Integer y)
      Create an expression that returns the modulus of its arguments.
      Expression<Integer> mod(Integer x, Expression<Integer> y)
      Create an expression that returns the modulus of its arguments.
      <N extends Number>
      Expression<N>             		neg(Expression<N> x)
      Create an expression that returns the arithmetic negation of its argument.
      Predicate not(Expression<Boolean> restriction)
      Create a negation of the given restriction.
      Predicate notEqual(Expression<?> x, Expression<?> y)
      Create a predicate for testing the arguments for inequality.
      Predicate notEqual(Expression<?> x, Object y)
      Create a predicate for testing the arguments for inequality.
      Predicate notLike(Expression<String> x, Expression<String> pattern)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate notLike(Expression<String> x, Expression<String> pattern, char escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate notLike(Expression<String> x, Expression<String> pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate notLike(Expression<String> x, String pattern)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate notLike(Expression<String> x, String pattern, char escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate notLike(Expression<String> x, String pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      <Y> Expression<Y> nullif(Expression<Y> x, Expression<?> y)
      Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.
      <Y> Expression<Y> nullif(Expression<Y> x, Y y)
      Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.
      <T> Expression<T> nullLiteral(Class<T> resultClass)
      Create an expression for a null literal with the given type.
      Predicate or(Expression<Boolean> x, Expression<Boolean> y)
      Create a disjunction of the given boolean expressions.
      Predicate or(Predicate... restrictions)
      Create a disjunction of the given restriction predicates.
      <T> ParameterExpression<T> parameter(Class<T> paramClass)
      Create a parameter expression.
      <T> ParameterExpression<T> parameter(Class<T> paramClass, String name)
      Create a parameter expression with the given name.
      <N extends Number>
      Expression<N>             		prod(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the product of its arguments.
      <N extends Number>
      Expression<N>             		prod(Expression<? extends N> x, N y)
      Create an expression that returns the product of its arguments.
      <N extends Number>
      Expression<N>             		prod(N x, Expression<? extends N> y)
      Create an expression that returns the product of its arguments.
      Expression<Number> quot(Expression<? extends Number> x, Expression<? extends Number> y)
      Create an expression that returns the quotient of its arguments.
      Expression<Number> quot(Expression<? extends Number> x, Number y)
      Create an expression that returns the quotient of its arguments.
      Expression<Number> quot(Number x, Expression<? extends Number> y)
      Create an expression that returns the quotient of its arguments.
      <R> CriteriaBuilder.Case<R> selectCase()
      Create a general case expression.
      <C,R> CriteriaBuilder.SimpleCase<C,R> selectCase(Expression<? extends C> expression)
      Create a simple case expression.
      <C extends Collection<?>>
      Expression<Integer>             		size(C collection)
      Create an expression that tests the size of a collection.
      <C extends Collection<?>>
      Expression<Integer>             		size(Expression<C> collection)
      Create an expression that tests the size of a collection.
      <Y> Expression<Y> some(Subquery<Y> subquery)
      Create a some expression over the subquery results.
      Expression<Double> sqrt(Expression<? extends Number> x)
      Create an expression that returns the square root of its argument.
      Expression<String> substring(Expression<String> x, Expression<Integer> from)
      Create an expression for substring extraction.
      Expression<String> substring(Expression<String> x, Expression<Integer> from, Expression<Integer> len)
      Create an expression for substring extraction.
      Expression<String> substring(Expression<String> x, int from)
      Create an expression for substring extraction.
      Expression<String> substring(Expression<String> x, int from, int len)
      Create an expression for substring extraction.
      <N extends Number>
      Expression<N>             		sum(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the sum of its arguments.
      <N extends Number>
      Expression<N>             		sum(Expression<? extends N> x, N y)
      Create an expression that returns the sum of its arguments.
      <N extends Number>
      Expression<N>             		sum(Expression<N> x)
      Create an aggregate expression applying the sum operation.
      <N extends Number>
      Expression<N>             		sum(N x, Expression<? extends N> y)
      Create an expression that returns the sum of its arguments.
      Expression<Double> sumAsDouble(Expression<Float> x)
      Create an aggregate expression applying the sum operation to a Float-valued expression, returning a Double result.
      Expression<Long> sumAsLong(Expression<Integer> x)
      Create an aggregate expression applying the sum operation to an Integer-valued expression, returning a Long result.
      Expression<BigDecimal> toBigDecimal(Expression<? extends Number> number)
      Typecast.
      Expression<BigInteger> toBigInteger(Expression<? extends Number> number)
      Typecast.
      Expression<Double> toDouble(Expression<? extends Number> number)
      Typecast.
      Expression<Float> toFloat(Expression<? extends Number> number)
      Typecast.
      Expression<Integer> toInteger(Expression<? extends Number> number)
      Typecast.
      Expression<Long> toLong(Expression<? extends Number> number)
      Typecast.
      Expression<String> toString(Expression<Character> character)
      Typecast.
      <X,T,E extends T>
      CollectionJoin<X,E>             		treat(CollectionJoin<X,T> join, Class<E> type)
      Downcast CollectionJoin object to the specified type.
      <X,T,V extends T>
      Join<X,V>             		treat(Join<X,T> join, Class<V> type)
      Downcast Join object to the specified type.
      <X,T,E extends T>
      ListJoin<X,E>             		treat(ListJoin<X,T> join, Class<E> type)
      Downcast ListJoin object to the specified type.
      <X,K,T,V extends T>
      MapJoin<X,K,V>             		treat(MapJoin<X,K,T> join, Class<V> type)
      Downcast MapJoin object to the specified type.
      <X,T extends X>
      Path<T>             		treat(Path<X> path, Class<T> type)
      Downcast Path object to the specified type.
      <X,T extends X>
      Root<T>             		treat(Root<X> root, Class<T> type)
      Downcast Root object to the specified type.
      <X,T,E extends T>
      SetJoin<X,E>             		treat(SetJoin<X,T> join, Class<E> type)
      Downcast SetJoin object to the specified type.
      Expression<String> trim(char t, Expression<String> x)
      Create expression to trim character from both ends of a string.
      Expression<String> trim(CriteriaBuilder.Trimspec ts, char t, Expression<String> x)
      Create expression to trim character from a string.
      Expression<String> trim(CriteriaBuilder.Trimspec ts, Expression<Character> t, Expression<String> x)
      Create expression to trim character from a string.
      Expression<String> trim(CriteriaBuilder.Trimspec ts, Expression<String> x)
      Create expression to trim blanks from a string.
      Expression<String> trim(Expression<Character> t, Expression<String> x)
      Create expression to trim character from both ends of a string.
      Expression<String> trim(Expression<String> x)
      Create expression to trim blanks from both ends of a string.
      CompoundSelection<Tuple> tuple(Selection<?>... selections)
      Create a tuple-valued selection item.
      Expression<String> upper(Expression<String> x)
      Create expression for converting a string to uppercase.
      <V,M extends Map<?,V>>
      Expression<Collection<V>>             		values(M map)
      Create an expression that returns the values of a map.

    • Method Detail

      • createQuery

        CriteriaQuery<Object> createQuery()
        Create a CriteriaQuery object.
        Returns:
        criteria query object

      • createQuery

        <T> CriteriaQuery<T> createQuery(Class<T> resultClass)
        Create a CriteriaQuery object with the specified result type.
        Parameters:
        resultClass - type of the query result
        Returns:
        criteria query object

      • createTupleQuery

        CriteriaQuery<Tuple> createTupleQuery()
        Create a CriteriaQuery object that returns a tuple of objects as its result.
        Returns:
        criteria query object

      • createCriteriaUpdate

        <T> CriteriaUpdate<T> createCriteriaUpdate(Class<T> targetEntity)
        Create a CriteriaUpdate query object to perform a bulk update operation.
        Parameters:
        targetEntity - target type for update operation
        Returns:
        the query object
        Since:
        Java Persistence 2.1

      • createCriteriaDelete

        <T> CriteriaDelete<T> createCriteriaDelete(Class<T> targetEntity)
        Create a CriteriaDelete query object to perform a bulk delete operation.
        Parameters:
        targetEntity - target type for delete operation
        Returns:
        the query object
        Since:
        Java Persistence 2.1

      • construct

        <Y> CompoundSelection<Y> construct(Class<Y> resultClass,
                                 Selection<?>... selections)
        Create a selection item corresponding to a constructor. This method is used to specify a constructor that will be applied to the results of the query execution. If the constructor is for an entity class, the resulting entities will be in the new state after the query is executed.
        Parameters:
        resultClass - class whose instance is to be constructed
        selections - arguments to the constructor
        Returns:
        compound selection item
        Throws:
        IllegalArgumentException - if an argument is a tuple- or array-valued selection item

      • tuple

        CompoundSelection<Tuple> tuple(Selection<?>... selections)
        Create a tuple-valued selection item.
        Parameters:
        selections - selection items
        Returns:
        tuple-valued compound selection
        Throws:
        IllegalArgumentException - if an argument is a tuple- or array-valued selection item

      • array

        CompoundSelection<Object[]> array(Selection<?>... selections)
        Create an array-valued selection item.
        Parameters:
        selections - selection items
        Returns:
        array-valued compound selection
        Throws:
        IllegalArgumentException - if an argument is a tuple- or array-valued selection item

      • asc

        Order asc(Expression<?> x)
        Create an ordering by the ascending value of the expression.
        Parameters:
        x - expression used to define the ordering
        Returns:
        ascending ordering corresponding to the expression

      • desc

        Order desc(Expression<?> x)
        Create an ordering by the descending value of the expression.
        Parameters:
        x - expression used to define the ordering
        Returns:
        descending ordering corresponding to the expression

      • avg

        <N extends Number> Expression<Double> avg(Expression<N> x)
        Create an aggregate expression applying the avg operation.
        Parameters:
        x - expression representing input value to avg operation
        Returns:
        avg expression

      • sum

        <N extends Number> Expression<N> sum(Expression<N> x)
        Create an aggregate expression applying the sum operation.
        Parameters:
        x - expression representing input value to sum operation
        Returns:
        sum expression

      • sumAsLong

        Expression<Long> sumAsLong(Expression<Integer> x)
        Create an aggregate expression applying the sum operation to an Integer-valued expression, returning a Long result.
        Parameters:
        x - expression representing input value to sum operation
        Returns:
        sum expression

      • sumAsDouble

        Expression<Double> sumAsDouble(Expression<Float> x)
        Create an aggregate expression applying the sum operation to a Float-valued expression, returning a Double result.
        Parameters:
        x - expression representing input value to sum operation
        Returns:
        sum expression

      • max

        <N extends Number> Expression<N> max(Expression<N> x)
        Create an aggregate expression applying the numerical max operation.
        Parameters:
        x - expression representing input value to max operation
        Returns:
        max expression

      • min

        <N extends Number> Expression<N> min(Expression<N> x)
        Create an aggregate expression applying the numerical min operation.
        Parameters:
        x - expression representing input value to min operation
        Returns:
        min expression

      • greatest

        <X extends Comparable<? super X>> Expression<X> greatest(Expression<X> x)
        Create an aggregate expression for finding the greatest of the values (strings, dates, etc).
        Parameters:
        x - expression representing input value to greatest operation
        Returns:
        greatest expression

      • least

        <X extends Comparable<? super X>> Expression<X> least(Expression<X> x)
        Create an aggregate expression for finding the least of the values (strings, dates, etc).
        Parameters:
        x - expression representing input value to least operation
        Returns:
        least expression

      • count

        Expression<Long> count(Expression<?> x)
        Create an aggregate expression applying the count operation.
        Parameters:
        x - expression representing input value to count operation
        Returns:
        count expression

      • countDistinct

        Expression<Long> countDistinct(Expression<?> x)
        Create an aggregate expression applying the count distinct operation.
        Parameters:
        x - expression representing input value to count distinct operation
        Returns:
        count distinct expression

      • exists

        Predicate exists(Subquery<?> subquery)
        Create a predicate testing the existence of a subquery result.
        Parameters:
        subquery - subquery whose result is to be tested
        Returns:
        exists predicate

      • all

        <Y> Expression<Y> all(Subquery<Y> subquery)
        Create an all expression over the subquery results.
        Parameters:
        subquery - subquery
        Returns:
        all expression

      • some

        <Y> Expression<Y> some(Subquery<Y> subquery)
        Create a some expression over the subquery results. This expression is equivalent to an any expression.
        Parameters:
        subquery - subquery
        Returns:
        some expression

      • any

        <Y> Expression<Y> any(Subquery<Y> subquery)
        Create an any expression over the subquery results. This expression is equivalent to a some expression.
        Parameters:
        subquery - subquery
        Returns:
        any expression

      • and

        Predicate and(Expression<Boolean> x,
            Expression<Boolean> y)
        Create a conjunction of the given boolean expressions.
        Parameters:
        x - boolean expression
        y - boolean expression
        Returns:
        and predicate

      • and

        Predicate and(Predicate... restrictions)
        Create a conjunction of the given restriction predicates. A conjunction of zero predicates is true.
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        and predicate

      • or

        Predicate or(Expression<Boolean> x,
           Expression<Boolean> y)
        Create a disjunction of the given boolean expressions.
        Parameters:
        x - boolean expression
        y - boolean expression
        Returns:
        or predicate

      • or

        Predicate or(Predicate... restrictions)
        Create a disjunction of the given restriction predicates. A disjunction of zero predicates is false.
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        or predicate

      • not

        Predicate not(Expression<Boolean> restriction)
        Create a negation of the given restriction.
        Parameters:
        restriction - restriction expression
        Returns:
        not predicate

      • conjunction

        Predicate conjunction()
        Create a conjunction (with zero conjuncts). A conjunction with zero conjuncts is true.
        Returns:
        and predicate

      • disjunction

        Predicate disjunction()
        Create a disjunction (with zero disjuncts). A disjunction with zero disjuncts is false.
        Returns:
        or predicate

      • isTrue

        Predicate isTrue(Expression<Boolean> x)
        Create a predicate testing for a true value.
        Parameters:
        x - expression to be tested
        Returns:
        predicate

      • isFalse

        Predicate isFalse(Expression<Boolean> x)
        Create a predicate testing for a false value.
        Parameters:
        x - expression to be tested
        Returns:
        predicate

      • isNull

        Predicate isNull(Expression<?> x)
        Create a predicate to test whether the expression is null.
        Parameters:
        x - expression
        Returns:
        is-null predicate

      • isNotNull

        Predicate isNotNull(Expression<?> x)
        Create a predicate to test whether the expression is not null.
        Parameters:
        x - expression
        Returns:
        is-not-null predicate

      • equal

        Predicate equal(Expression<?> x,
              Expression<?> y)
        Create a predicate for testing the arguments for equality.
        Parameters:
        x - expression
        y - expression
        Returns:
        equality predicate

      • equal

        Predicate equal(Expression<?> x,
              Object y)
        Create a predicate for testing the arguments for equality.
        Parameters:
        x - expression
        y - object
        Returns:
        equality predicate

      • notEqual

        Predicate notEqual(Expression<?> x,
                 Expression<?> y)
        Create a predicate for testing the arguments for inequality.
        Parameters:
        x - expression
        y - expression
        Returns:
        inequality predicate

      • notEqual

        Predicate notEqual(Expression<?> x,
                 Object y)
        Create a predicate for testing the arguments for inequality.
        Parameters:
        x - expression
        y - object
        Returns:
        inequality predicate

      • greaterThan

        <Y extends Comparable<? super Y>> Predicate greaterThan(Expression<? extends Y> x,
                                                      Expression<? extends Y> y)
        Create a predicate for testing whether the first argument is greater than the second.
        Parameters:
        x - expression
        y - expression
        Returns:
        greater-than predicate

      • greaterThan

        <Y extends Comparable<? super Y>> Predicate greaterThan(Expression<? extends Y> x,
                                                      Y y)
        Create a predicate for testing whether the first argument is greater than the second.
        Parameters:
        x - expression
        y - value
        Returns:
        greater-than predicate

      • greaterThanOrEqualTo

        <Y extends Comparable<? super Y>> Predicate greaterThanOrEqualTo(Expression<? extends Y> x,
                                                               Expression<? extends Y> y)
        Create a predicate for testing whether the first argument is greater than or equal to the second.
        Parameters:
        x - expression
        y - expression
        Returns:
        greater-than-or-equal predicate

      • greaterThanOrEqualTo

        <Y extends Comparable<? super Y>> Predicate greaterThanOrEqualTo(Expression<? extends Y> x,
                                                               Y y)
        Create a predicate for testing whether the first argument is greater than or equal to the second.
        Parameters:
        x - expression
        y - value
        Returns:
        greater-than-or-equal predicate

      • lessThan

        <Y extends Comparable<? super Y>> Predicate lessThan(Expression<? extends Y> x,
                                                   Expression<? extends Y> y)
        Create a predicate for testing whether the first argument is less than the second.
        Parameters:
        x - expression
        y - expression
        Returns:
        less-than predicate

      • lessThan

        <Y extends Comparable<? super Y>> Predicate lessThan(Expression<? extends Y> x,
                                                   Y y)
        Create a predicate for testing whether the first argument is less than the second.
        Parameters:
        x - expression
        y - value
        Returns:
        less-than predicate

      • lessThanOrEqualTo

        <Y extends Comparable<? super Y>> Predicate lessThanOrEqualTo(Expression<? extends Y> x,
                                                            Expression<? extends Y> y)
        Create a predicate for testing whether the first argument is less than or equal to the second.
        Parameters:
        x - expression
        y - expression
        Returns:
        less-than-or-equal predicate

      • lessThanOrEqualTo

        <Y extends Comparable<? super Y>> Predicate lessThanOrEqualTo(Expression<? extends Y> x,
                                                            Y y)
        Create a predicate for testing whether the first argument is less than or equal to the second.
        Parameters:
        x - expression
        y - value
        Returns:
        less-than-or-equal predicate

      • between

        <Y extends Comparable<? super Y>> Predicate between(Expression<? extends Y> v,
                                                  Expression<? extends Y> x,
                                                  Expression<? extends Y> y)
        Create a predicate for testing whether the first argument is between the second and third arguments in value.
        Parameters:
        v - expression
        x - expression
        y - expression
        Returns:
        between predicate

      • between

        <Y extends Comparable<? super Y>> Predicate between(Expression<? extends Y> v,
                                                  Y x,
                                                  Y y)
        Create a predicate for testing whether the first argument is between the second and third arguments in value.
        Parameters:
        v - expression
        x - value
        y - value
        Returns:
        between predicate

      • gt

        Predicate gt(Expression<? extends Number> x,
           Expression<? extends Number> y)
        Create a predicate for testing whether the first argument is greater than the second.
        Parameters:
        x - expression
        y - expression
        Returns:
        greater-than predicate

      • gt

        Predicate gt(Expression<? extends Number> x,
           Number y)
        Create a predicate for testing whether the first argument is greater than the second.
        Parameters:
        x - expression
        y - value
        Returns:
        greater-than predicate

      • ge

        Predicate ge(Expression<? extends Number> x,
           Expression<? extends Number> y)
        Create a predicate for testing whether the first argument is greater than or equal to the second.
        Parameters:
        x - expression
        y - expression
        Returns:
        greater-than-or-equal predicate

      • ge

        Predicate ge(Expression<? extends Number> x,
           Number y)
        Create a predicate for testing whether the first argument is greater than or equal to the second.
        Parameters:
        x - expression
        y - value
        Returns:
        greater-than-or-equal predicate

      • lt

        Predicate lt(Expression<? extends Number> x,
           Expression<? extends Number> y)
        Create a predicate for testing whether the first argument is less than the second.
        Parameters:
        x - expression
        y - expression
        Returns:
        less-than predicate

      • lt

        Predicate lt(Expression<? extends Number> x,
           Number y)
        Create a predicate for testing whether the first argument is less than the second.
        Parameters:
        x - expression
        y - value
        Returns:
        less-than predicate

      • le

        Predicate le(Expression<? extends Number> x,
           Expression<? extends Number> y)
        Create a predicate for testing whether the first argument is less than or equal to the second.
        Parameters:
        x - expression
        y - expression
        Returns:
        less-than-or-equal predicate

      • le

        Predicate le(Expression<? extends Number> x,
           Number y)
        Create a predicate for testing whether the first argument is less than or equal to the second.
        Parameters:
        x - expression
        y - value
        Returns:
        less-than-or-equal predicate

      • neg

        <N extends Number> Expression<N> neg(Expression<N> x)
        Create an expression that returns the arithmetic negation of its argument.
        Parameters:
        x - expression
        Returns:
        arithmetic negation

      • abs

        <N extends Number> Expression<N> abs(Expression<N> x)
        Create an expression that returns the absolute value of its argument.
        Parameters:
        x - expression
        Returns:
        absolute value

      • sum

        <N extends Number> Expression<N> sum(Expression<? extends N> x,
                                   Expression<? extends N> y)
        Create an expression that returns the sum of its arguments.
        Parameters:
        x - expression
        y - expression
        Returns:
        sum

      • sum

        <N extends Number> Expression<N> sum(Expression<? extends N> x,
                                   N y)
        Create an expression that returns the sum of its arguments.
        Parameters:
        x - expression
        y - value
        Returns:
        sum

      • sum

        <N extends Number> Expression<N> sum(N x,
                                   Expression<? extends N> y)
        Create an expression that returns the sum of its arguments.
        Parameters:
        x - value
        y - expression
        Returns:
        sum

      • prod

        <N extends Number> Expression<N> prod(Expression<? extends N> x,
                                    Expression<? extends N> y)
        Create an expression that returns the product of its arguments.
        Parameters:
        x - expression
        y - expression
        Returns:
        product

      • prod

        <N extends Number> Expression<N> prod(Expression<? extends N> x,
                                    N y)
        Create an expression that returns the product of its arguments.
        Parameters:
        x - expression
        y - value
        Returns:
        product

      • prod

        <N extends Number> Expression<N> prod(N x,
                                    Expression<? extends N> y)
        Create an expression that returns the product of its arguments.
        Parameters:
        x - value
        y - expression
        Returns:
        product

      • diff

        <N extends Number> Expression<N> diff(Expression<? extends N> x,
                                    Expression<? extends N> y)
        Create an expression that returns the difference between its arguments.
        Parameters:
        x - expression
        y - expression
        Returns:
        difference

      • diff

        <N extends Number> Expression<N> diff(Expression<? extends N> x,
                                    N y)
        Create an expression that returns the difference between its arguments.
        Parameters:
        x - expression
        y - value
        Returns:
        difference

      • diff

        <N extends Number> Expression<N> diff(N x,
                                    Expression<? extends N> y)
        Create an expression that returns the difference between its arguments.
        Parameters:
        x - value
        y - expression
        Returns:
        difference

      • quot

        Expression<Number> quot(Expression<? extends Number> x,
                      Expression<? extends Number> y)
        Create an expression that returns the quotient of its arguments.
        Parameters:
        x - expression
        y - expression
        Returns:
        quotient

      • quot

        Expression<Number> quot(Expression<? extends Number> x,
                      Number y)
        Create an expression that returns the quotient of its arguments.
        Parameters:
        x - expression
        y - value
        Returns:
        quotient

      • quot

        Expression<Number> quot(Number x,
                      Expression<? extends Number> y)
        Create an expression that returns the quotient of its arguments.
        Parameters:
        x - value
        y - expression
        Returns:
        quotient

      • mod

        Expression<Integer> mod(Expression<Integer> x,
                      Expression<Integer> y)
        Create an expression that returns the modulus of its arguments.
        Parameters:
        x - expression
        y - expression
        Returns:
        modulus

      • mod

        Expression<Integer> mod(Expression<Integer> x,
                      Integer y)
        Create an expression that returns the modulus of its arguments.
        Parameters:
        x - expression
        y - value
        Returns:
        modulus

      • mod

        Expression<Integer> mod(Integer x,
                      Expression<Integer> y)
        Create an expression that returns the modulus of its arguments.
        Parameters:
        x - value
        y - expression
        Returns:
        modulus

      • sqrt

        Expression<Double> sqrt(Expression<? extends Number> x)
        Create an expression that returns the square root of its argument.
        Parameters:
        x - expression
        Returns:
        square root

      • toLong

        Expression<Long> toLong(Expression<? extends Number> number)
        Typecast. Returns same expression object.
        Parameters:
        number - numeric expression
        Returns:
        Expression<Long>

      • toInteger

        Expression<Integer> toInteger(Expression<? extends Number> number)
        Typecast. Returns same expression object.
        Parameters:
        number - numeric expression
        Returns:
        Expression<Integer>

      • toFloat

        Expression<Float> toFloat(Expression<? extends Number> number)
        Typecast. Returns same expression object.
        Parameters:
        number - numeric expression
        Returns:
        Expression<Float>

      • toDouble

        Expression<Double> toDouble(Expression<? extends Number> number)
        Typecast. Returns same expression object.
        Parameters:
        number - numeric expression
        Returns:
        Expression<Double>

      • toBigDecimal

        Expression<BigDecimal> toBigDecimal(Expression<? extends Number> number)
        Typecast. Returns same expression object.
        Parameters:
        number - numeric expression
        Returns:
        Expression<BigDecimal>

      • toBigInteger

        Expression<BigInteger> toBigInteger(Expression<? extends Number> number)
        Typecast. Returns same expression object.
        Parameters:
        number - numeric expression
        Returns:
        Expression<BigInteger>

      • toString

        Expression<String> toString(Expression<Character> character)
        Typecast. Returns same expression object.
        Parameters:
        character - expression
        Returns:
        Expression<String>

      • literal

        <T> Expression<T> literal(T value)
        Create an expression for a literal.
        Parameters:
        value - value represented by the expression
        Returns:
        expression literal
        Throws:
        IllegalArgumentException - if value is null

      • nullLiteral

        <T> Expression<T> nullLiteral(Class<T> resultClass)
        Create an expression for a null literal with the given type.
        Parameters:
        resultClass - type of the null literal
        Returns:
        null expression literal

      • parameter

        <T> ParameterExpression<T> parameter(Class<T> paramClass)
        Create a parameter expression.
        Parameters:
        paramClass - parameter class
        Returns:
        parameter expression

      • parameter

        <T> ParameterExpression<T> parameter(Class<T> paramClass,
                                   String name)
        Create a parameter expression with the given name.
        Parameters:
        paramClass - parameter class
        name - name that can be used to refer to the parameter
        Returns:
        parameter expression

      • isEmpty

        <C extends Collection<?>> Predicate isEmpty(Expression<C> collection)
        Create a predicate that tests whether a collection is empty.
        Parameters:
        collection - expression
        Returns:
        is-empty predicate

      • isNotEmpty

        <C extends Collection<?>> Predicate isNotEmpty(Expression<C> collection)
        Create a predicate that tests whether a collection is not empty.
        Parameters:
        collection - expression
        Returns:
        is-not-empty predicate

      • size

        <C extends Collection<?>> Expression<Integer> size(Expression<C> collection)
        Create an expression that tests the size of a collection.
        Parameters:
        collection - expression
        Returns:
        size expression

      • size

        <C extends Collection<?>> Expression<Integer> size(C collection)
        Create an expression that tests the size of a collection.
        Parameters:
        collection - collection
        Returns:
        size expression

      • isMember

        <E,C extends Collection<E>> Predicate isMember(Expression<E> elem,
                                             Expression<C> collection)
        Create a predicate that tests whether an element is a member of a collection. If the collection is empty, the predicate will be false.
        Parameters:
        elem - element expression
        collection - expression
        Returns:
        is-member predicate

      • isMember

        <E,C extends Collection<E>> Predicate isMember(E elem,
                                             Expression<C> collection)
        Create a predicate that tests whether an element is a member of a collection. If the collection is empty, the predicate will be false.
        Parameters:
        elem - element
        collection - expression
        Returns:
        is-member predicate

      • isNotMember

        <E,C extends Collection<E>> Predicate isNotMember(Expression<E> elem,
                                                Expression<C> collection)
        Create a predicate that tests whether an element is not a member of a collection. If the collection is empty, the predicate will be true.
        Parameters:
        elem - element expression
        collection - expression
        Returns:
        is-not-member predicate

      • isNotMember

        <E,C extends Collection<E>> Predicate isNotMember(E elem,
                                                Expression<C> collection)
        Create a predicate that tests whether an element is not a member of a collection. If the collection is empty, the predicate will be true.
        Parameters:
        elem - element
        collection - expression
        Returns:
        is-not-member predicate

      • values

        <V,M extends Map<?,V>> Expression<Collection<V>> values(M map)
        Create an expression that returns the values of a map.
        Parameters:
        map - map
        Returns:
        collection expression

      • keys

        <K,M extends Map<K,?>> Expression<Set<K>> keys(M map)
        Create an expression that returns the keys of a map.
        Parameters:
        map - map
        Returns:
        set expression

      • like

        Predicate like(Expression<String> x,
             Expression<String> pattern)
        Create a predicate for testing whether the expression satisfies the given pattern.
        Parameters:
        x - string expression
        pattern - string expression
        Returns:
        like predicate

      • like

        Predicate like(Expression<String> x,
             String pattern)
        Create a predicate for testing whether the expression satisfies the given pattern.
        Parameters:
        x - string expression
        pattern - string
        Returns:
        like predicate

      • like

        Predicate like(Expression<String> x,
             Expression<String> pattern,
             Expression<Character> escapeChar)
        Create a predicate for testing whether the expression satisfies the given pattern.
        Parameters:
        x - string expression
        pattern - string expression
        escapeChar - escape character expression
        Returns:
        like predicate

      • like

        Predicate like(Expression<String> x,
             Expression<String> pattern,
             char escapeChar)
        Create a predicate for testing whether the expression satisfies the given pattern.
        Parameters:
        x - string expression
        pattern - string expression
        escapeChar - escape character
        Returns:
        like predicate

      • like

        Predicate like(Expression<String> x,
             String pattern,
             Expression<Character> escapeChar)
        Create a predicate for testing whether the expression satisfies the given pattern.
        Parameters:
        x - string expression
        pattern - string
        escapeChar - escape character expression
        Returns:
        like predicate

      • like

        Predicate like(Expression<String> x,
             String pattern,
             char escapeChar)
        Create a predicate for testing whether the expression satisfies the given pattern.
        Parameters:
        x - string expression
        pattern - string
        escapeChar - escape character
        Returns:
        like predicate

      • notLike

        Predicate notLike(Expression<String> x,
                Expression<String> pattern)
        Create a predicate for testing whether the expression does not satisfy the given pattern.
        Parameters:
        x - string expression
        pattern - string expression
        Returns:
        not-like predicate

      • notLike

        Predicate notLike(Expression<String> x,
                String pattern)
        Create a predicate for testing whether the expression does not satisfy the given pattern.
        Parameters:
        x - string expression
        pattern - string
        Returns:
        not-like predicate

      • notLike

        Predicate notLike(Expression<String> x,
                Expression<String> pattern,
                Expression<Character> escapeChar)
        Create a predicate for testing whether the expression does not satisfy the given pattern.
        Parameters:
        x - string expression
        pattern - string expression
        escapeChar - escape character expression
        Returns:
        not-like predicate

      • notLike

        Predicate notLike(Expression<String> x,
                Expression<String> pattern,
                char escapeChar)
        Create a predicate for testing whether the expression does not satisfy the given pattern.
        Parameters:
        x - string expression
        pattern - string expression
        escapeChar - escape character
        Returns:
        not-like predicate

      • notLike

        Predicate notLike(Expression<String> x,
                String pattern,
                Expression<Character> escapeChar)
        Create a predicate for testing whether the expression does not satisfy the given pattern.
        Parameters:
        x - string expression
        pattern - string
        escapeChar - escape character expression
        Returns:
        not-like predicate

      • notLike

        Predicate notLike(Expression<String> x,
                String pattern,
                char escapeChar)
        Create a predicate for testing whether the expression does not satisfy the given pattern.
        Parameters:
        x - string expression
        pattern - string
        escapeChar - escape character
        Returns:
        not-like predicate

      • concat

        Expression<String> concat(Expression<String> x,
                        Expression<String> y)
        Create an expression for string concatenation.
        Parameters:
        x - string expression
        y - string expression
        Returns:
        expression corresponding to concatenation

      • concat

        Expression<String> concat(Expression<String> x,
                        String y)
        Create an expression for string concatenation.
        Parameters:
        x - string expression
        y - string
        Returns:
        expression corresponding to concatenation

      • concat

        Expression<String> concat(String x,
                        Expression<String> y)
        Create an expression for string concatenation.
        Parameters:
        x - string
        y - string expression
        Returns:
        expression corresponding to concatenation

      • substring

        Expression<String> substring(Expression<String> x,
                           Expression<Integer> from)
        Create an expression for substring extraction. Extracts a substring starting at the specified position through to end of the string. First position is 1.
        Parameters:
        x - string expression
        from - start position expression
        Returns:
        expression corresponding to substring extraction

      • substring

        Expression<String> substring(Expression<String> x,
                           int from)
        Create an expression for substring extraction. Extracts a substring starting at the specified position through to end of the string. First position is 1.
        Parameters:
        x - string expression
        from - start position
        Returns:
        expression corresponding to substring extraction

      • substring

        Expression<String> substring(Expression<String> x,
                           Expression<Integer> from,
                           Expression<Integer> len)
        Create an expression for substring extraction. Extracts a substring of given length starting at the specified position. First position is 1.
        Parameters:
        x - string expression
        from - start position expression
        len - length expression
        Returns:
        expression corresponding to substring extraction

      • substring

        Expression<String> substring(Expression<String> x,
                           int from,
                           int len)
        Create an expression for substring extraction. Extracts a substring of given length starting at the specified position. First position is 1.
        Parameters:
        x - string expression
        from - start position
        len - length
        Returns:
        expression corresponding to substring extraction

      • trim

        Expression<String> trim(Expression<String> x)
        Create expression to trim blanks from both ends of a string.
        Parameters:
        x - expression for string to trim
        Returns:
        trim expression

      • trim

        Expression<String> trim(CriteriaBuilder.Trimspec ts,
                      Expression<String> x)
        Create expression to trim blanks from a string.
        Parameters:
        ts - trim specification
        x - expression for string to trim
        Returns:
        trim expression

      • trim

        Expression<String> trim(Expression<Character> t,
                      Expression<String> x)
        Create expression to trim character from both ends of a string.
        Parameters:
        t - expression for character to be trimmed
        x - expression for string to trim
        Returns:
        trim expression

      • trim

        Expression<String> trim(CriteriaBuilder.Trimspec ts,
                      Expression<Character> t,
                      Expression<String> x)
        Create expression to trim character from a string.
        Parameters:
        ts - trim specification
        t - expression for character to be trimmed
        x - expression for string to trim
        Returns:
        trim expression

      • trim

        Expression<String> trim(char t,
                      Expression<String> x)
        Create expression to trim character from both ends of a string.
        Parameters:
        t - character to be trimmed
        x - expression for string to trim
        Returns:
        trim expression

      • trim

        Expression<String> trim(CriteriaBuilder.Trimspec ts,
                      char t,
                      Expression<String> x)
        Create expression to trim character from a string.
        Parameters:
        ts - trim specification
        t - character to be trimmed
        x - expression for string to trim
        Returns:
        trim expression

      • lower

        Expression<String> lower(Expression<String> x)
        Create expression for converting a string to lowercase.
        Parameters:
        x - string expression
        Returns:
        expression to convert to lowercase

      • upper

        Expression<String> upper(Expression<String> x)
        Create expression for converting a string to uppercase.
        Parameters:
        x - string expression
        Returns:
        expression to convert to uppercase

      • length

        Expression<Integer> length(Expression<String> x)
        Create expression to return length of a string.
        Parameters:
        x - string expression
        Returns:
        length expression

      • locate

        Expression<Integer> locate(Expression<String> x,
                         Expression<String> pattern)
        Create expression to locate the position of one string within another, returning position of first character if found. The first position in a string is denoted by 1. If the string to be located is not found, 0 is returned.
        Parameters:
        x - expression for string to be searched
        pattern - expression for string to be located
        Returns:
        expression corresponding to position

      • locate

        Expression<Integer> locate(Expression<String> x,
                         String pattern)
        Create expression to locate the position of one string within another, returning position of first character if found. The first position in a string is denoted by 1. If the string to be located is not found, 0 is returned.
        Parameters:
        x - expression for string to be searched
        pattern - string to be located
        Returns:
        expression corresponding to position

      • locate

        Expression<Integer> locate(Expression<String> x,
                         Expression<String> pattern,
                         Expression<Integer> from)
        Create expression to locate the position of one string within another, returning position of first character if found. The first position in a string is denoted by 1. If the string to be located is not found, 0 is returned.
        Parameters:
        x - expression for string to be searched
        pattern - expression for string to be located
        from - expression for position at which to start search
        Returns:
        expression corresponding to position

      • locate

        Expression<Integer> locate(Expression<String> x,
                         String pattern,
                         int from)
        Create expression to locate the position of one string within another, returning position of first character if found. The first position in a string is denoted by 1. If the string to be located is not found, 0 is returned.
        Parameters:
        x - expression for string to be searched
        pattern - string to be located
        from - position at which to start search
        Returns:
        expression corresponding to position

      • currentDate

        Expression<Date> currentDate()
        Create expression to return current date.
        Returns:
        expression for current date

      • currentTimestamp

        Expression<Timestamp> currentTimestamp()
        Create expression to return current timestamp.
        Returns:
        expression for current timestamp

      • currentTime

        Expression<Time> currentTime()
        Create expression to return current time.
        Returns:
        expression for current time

      • in

        <T> CriteriaBuilder.In<T> in(Expression<? extends T> expression)
        Create predicate to test whether given expression is contained in a list of values.
        Parameters:
        expression - to be tested against list of values
        Returns:
        in predicate

      • coalesce

        <Y> Expression<Y> coalesce(Expression<? extends Y> x,
                         Expression<? extends Y> y)
        Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.
        Parameters:
        x - expression
        y - expression
        Returns:
        coalesce expression

      • coalesce

        <Y> Expression<Y> coalesce(Expression<? extends Y> x,
                         Y y)
        Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.
        Parameters:
        x - expression
        y - value
        Returns:
        coalesce expression

      • nullif

        <Y> Expression<Y> nullif(Expression<Y> x,
                       Expression<?> y)
        Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.
        Parameters:
        x - expression
        y - expression
        Returns:
        nullif expression

      • nullif

        <Y> Expression<Y> nullif(Expression<Y> x,
                       Y y)
        Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.
        Parameters:
        x - expression
        y - value
        Returns:
        nullif expression

      • coalesce

        <T> CriteriaBuilder.Coalesce<T> coalesce()
        Create a coalesce expression.
        Returns:
        coalesce expression

      • selectCase

        <C,R> CriteriaBuilder.SimpleCase<C,R> selectCase(Expression<? extends C> expression)
        Create a simple case expression.
        Parameters:
        expression - to be tested against the case conditions
        Returns:
        simple case expression

      • selectCase

        <R> CriteriaBuilder.Case<R> selectCase()
        Create a general case expression.
        Returns:
        general case expression

      • function

        <T> Expression<T> function(String name,
                         Class<T> type,
                         Expression<?>... args)
        Create an expression for the execution of a database function.
        Parameters:
        name - function name
        type - expected result type
        args - function arguments
        Returns:
        expression

      • treat

        <X,T,V extends T> Join<X,V> treat(Join<X,T> join,
                                Class<V> type)
        Downcast Join object to the specified type.
        Parameters:
        join - Join object
        type - type to be downcast to
        Returns:
        Join object of the specified type
        Since:
        Java Persistence 2.1

      • treat

        <X,T,E extends T> CollectionJoin<X,E> treat(CollectionJoin<X,T> join,
                                          Class<E> type)
        Downcast CollectionJoin object to the specified type.
        Parameters:
        join - CollectionJoin object
        type - type to be downcast to
        Returns:
        CollectionJoin object of the specified type
        Since:
        Java Persistence 2.1

      • treat

        <X,T,E extends T> SetJoin<X,E> treat(SetJoin<X,T> join,
                                   Class<E> type)
        Downcast SetJoin object to the specified type.
        Parameters:
        join - SetJoin object
        type - type to be downcast to
        Returns:
        SetJoin object of the specified type
        Since:
        Java Persistence 2.1

      • treat

        <X,T,E extends T> ListJoin<X,E> treat(ListJoin<X,T> join,
                                    Class<E> type)
        Downcast ListJoin object to the specified type.
        Parameters:
        join - ListJoin object
        type - type to be downcast to
        Returns:
        ListJoin object of the specified type
        Since:
        Java Persistence 2.1

      • treat

        <X,K,T,V extends T> MapJoin<X,K,V> treat(MapJoin<X,K,T> join,
                                       Class<V> type)
        Downcast MapJoin object to the specified type.
        Parameters:
        join - MapJoin object
        type - type to be downcast to
        Returns:
        MapJoin object of the specified type
        Since:
        Java Persistence 2.1

      • treat

        <X,T extends X> Path<T> treat(Path<X> path,
                            Class<T> type)
        Downcast Path object to the specified type.
        Parameters:
        path - path
        type - type to be downcast to
        Returns:
        Path object of the specified type
        Since:
        Java Persistence 2.1

      • treat

        <X,T extends X> Root<T> treat(Root<X> root,
                            Class<T> type)
        Downcast Root object to the specified type.
        Parameters:
        root - root
        type - type to be downcast to
        Returns:
        Root object of the specified type
        Since:
        Java Persistence 2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CriteriaBuilder.Case (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CriteriaBuilder.Case<R>

  • All Superinterfaces:
    Expression<R>, Selection<R>, TupleElement<R>
    Enclosing interface:
    CriteriaBuilder

    public static interface CriteriaBuilder.Case<R>
extends Expression<R>
    Interface used to build general case expressions. Case conditions are evaluated in the order in which they are specified.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Expression<R> otherwise(Expression<? extends R> result)
      Add an "else" clause to the case expression.
      Expression<R> otherwise(R result)
      Add an "else" clause to the case expression.
      CriteriaBuilder.Case<R> when(Expression<Boolean> condition, Expression<? extends R> result)
      Add a when/then clause to the case expression.
      CriteriaBuilder.Case<R> when(Expression<Boolean> condition, R result)
      Add a when/then clause to the case expression.

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

    • Method Detail

      • when

        CriteriaBuilder.Case<R> when(Expression<Boolean> condition,
                           R result)
        Add a when/then clause to the case expression.
        Parameters:
        condition - "when" condition
        result - "then" result value
        Returns:
        general case expression

      • when

        CriteriaBuilder.Case<R> when(Expression<Boolean> condition,
                           Expression<? extends R> result)
        Add a when/then clause to the case expression.
        Parameters:
        condition - "when" condition
        result - "then" result expression
        Returns:
        general case expression

      • otherwise

        Expression<R> otherwise(R result)
        Add an "else" clause to the case expression.
        Parameters:
        result - "else" result
        Returns:
        expression

      • otherwise

        Expression<R> otherwise(Expression<? extends R> result)
        Add an "else" clause to the case expression.
        Parameters:
        result - "else" result expression
        Returns:
        expression
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CriteriaBuilder.Coalesce (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CriteriaBuilder.Coalesce<T>

  • All Superinterfaces:
    Expression<T>, Selection<T>, TupleElement<T>
    Enclosing interface:
    CriteriaBuilder

    public static interface CriteriaBuilder.Coalesce<T>
extends Expression<T>
    Interface used to build coalesce expressions. A coalesce expression is equivalent to a case expression that returns null if all its arguments evaluate to null, and the value of its first non-null argument otherwise.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CriteriaBuilder.Coalesce<T> value(Expression<? extends T> value)
      Add an argument to the coalesce expression.
      CriteriaBuilder.Coalesce<T> value(T value)
      Add an argument to the coalesce expression.

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

    • Method Detail

      • value

        CriteriaBuilder.Coalesce<T> value(T value)
        Add an argument to the coalesce expression.
        Parameters:
        value - value
        Returns:
        coalesce expression

      • value

        CriteriaBuilder.Coalesce<T> value(Expression<? extends T> value)
        Add an argument to the coalesce expression.
        Parameters:
        value - expression
        Returns:
        coalesce expression
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CriteriaBuilder.In (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CriteriaBuilder.In<T>

  • All Superinterfaces:
    Expression<Boolean>, Predicate, Selection<Boolean>, TupleElement<Boolean>
    Enclosing interface:
    CriteriaBuilder

    public static interface CriteriaBuilder.In<T>
extends Predicate
    Interface used to build in predicates.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.criteria.Predicate

        Predicate.BooleanOperator

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Expression<T> getExpression()
      Return the expression to be tested against the list of values.
      CriteriaBuilder.In<T> value(Expression<? extends T> value)
      Add to list of values to be tested against.
      CriteriaBuilder.In<T> value(T value)
      Add to list of values to be tested against.

      • Methods inherited from interface javax.persistence.criteria.Predicate

        getExpressions, getOperator, isNegated, not

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

    • Method Detail

      • getExpression

        Expression<T> getExpression()
        Return the expression to be tested against the list of values.
        Returns:
        expression

      • value

        CriteriaBuilder.In<T> value(T value)
        Add to list of values to be tested against.
        Parameters:
        value - value
        Returns:
        in predicate

      • value

        CriteriaBuilder.In<T> value(Expression<? extends T> value)
        Add to list of values to be tested against.
        Parameters:
        value - expression
        Returns:
        in predicate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CriteriaBuilder.SimpleCase (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CriteriaBuilder.SimpleCase<C,R>

  • All Superinterfaces:
    Expression<R>, Selection<R>, TupleElement<R>
    Enclosing interface:
    CriteriaBuilder

    public static interface CriteriaBuilder.SimpleCase<C,R>
extends Expression<R>
    Interface used to build simple case expressions. Case conditions are evaluated in the order in which they are specified.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Expression<C> getExpression()
      Return the expression to be tested against the conditions.
      Expression<R> otherwise(Expression<? extends R> result)
      Add an "else" clause to the case expression.
      Expression<R> otherwise(R result)
      Add an "else" clause to the case expression.
      CriteriaBuilder.SimpleCase<C,R> when(C condition, Expression<? extends R> result)
      Add a when/then clause to the case expression.
      CriteriaBuilder.SimpleCase<C,R> when(C condition, R result)
      Add a when/then clause to the case expression.

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

    • Method Detail

      • getExpression

        Expression<C> getExpression()
        Return the expression to be tested against the conditions.
        Returns:
        expression

      • when

        CriteriaBuilder.SimpleCase<C,R> when(C condition,
                                   R result)
        Add a when/then clause to the case expression.
        Parameters:
        condition - "when" condition
        result - "then" result value
        Returns:
        simple case expression

      • when

        CriteriaBuilder.SimpleCase<C,R> when(C condition,
                                   Expression<? extends R> result)
        Add a when/then clause to the case expression.
        Parameters:
        condition - "when" condition
        result - "then" result expression
        Returns:
        simple case expression

      • otherwise

        Expression<R> otherwise(R result)
        Add an "else" clause to the case expression.
        Parameters:
        result - "else" result
        Returns:
        expression

      • otherwise

        Expression<R> otherwise(Expression<? extends R> result)
        Add an "else" clause to the case expression.
        Parameters:
        result - "else" result expression
        Returns:
        expression
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CriteriaBuilder.Trimspec (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence.criteria

Enum CriteriaBuilder.Trimspec

  • java.lang.Object
    • java.lang.Enum<CriteriaBuilder.Trimspec>
      • javax.persistence.criteria.CriteriaBuilder.Trimspec
  • All Implemented Interfaces:
    Serializable, Comparable<CriteriaBuilder.Trimspec>
    Enclosing interface:
    CriteriaBuilder

    public static enum CriteriaBuilder.Trimspec
extends Enum<CriteriaBuilder.Trimspec>
    Used to specify how strings are trimmed.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BOTH
      Trim from both ends.
      LEADING
      Trim from leading end.
      TRAILING
      Trim from trailing end.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static CriteriaBuilder.Trimspec valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CriteriaBuilder.Trimspec[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LEADING

        public static final CriteriaBuilder.Trimspec LEADING
        Trim from leading end.

      • TRAILING

        public static final CriteriaBuilder.Trimspec TRAILING
        Trim from trailing end.

      • BOTH

        public static final CriteriaBuilder.Trimspec BOTH
        Trim from both ends.

    • Method Detail

      • values

        public static CriteriaBuilder.Trimspec[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (CriteriaBuilder.Trimspec c : CriteriaBuilder.Trimspec.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static CriteriaBuilder.Trimspec valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


CriteriaDelete (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CriteriaDelete<T>

  • Type Parameters:
    T - the entity type that is the target of the delete
    All Superinterfaces:
    CommonAbstractCriteria

    public interface CriteriaDelete<T>
extends CommonAbstractCriteria
    The CriteriaDelete interface defines functionality for performing bulk delete operations using the Criteria API

    Criteria API bulk delete operations map directly to database delete operations. The persistence context is not synchronized with the result of the bulk delete.

    A CriteriaDelete object must have a single root.

    Since:
    Java Persistence 2.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Root<T> from(Class<T> entityClass)
      Create and add a query root corresponding to the entity that is the target of the delete.
      Root<T> from(EntityType<T> entity)
      Create and add a query root corresponding to the entity that is the target of the delete.
      Root<T> getRoot()
      Return the query root.
      CriteriaDelete<T> where(Expression<Boolean> restriction)
      Modify the delete query to restrict the target of the deletion according to the specified boolean expression.
      CriteriaDelete<T> where(Predicate... restrictions)
      Modify the delete query to restrict the target of the deletion according to the conjunction of the specified restriction predicates.

      • Methods inherited from interface javax.persistence.criteria.CommonAbstractCriteria

        getRestriction, subquery

    • Method Detail

      • from

        Root<T> from(Class<T> entityClass)
        Create and add a query root corresponding to the entity that is the target of the delete. A CriteriaDelete object has a single root, the entity that is being deleted.
        Parameters:
        entityClass - the entity class
        Returns:
        query root corresponding to the given entity

      • from

        Root<T> from(EntityType<T> entity)
        Create and add a query root corresponding to the entity that is the target of the delete. A CriteriaDelete object has a single root, the entity that is being deleted.
        Parameters:
        entity - metamodel entity representing the entity of type X
        Returns:
        query root corresponding to the given entity

      • getRoot

        Root<T> getRoot()
        Return the query root.
        Returns:
        the query root

      • where

        CriteriaDelete<T> where(Expression<Boolean> restriction)
        Modify the delete query to restrict the target of the deletion according to the specified boolean expression. Replaces the previously added restriction(s), if any.
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified delete query

      • where

        CriteriaDelete<T> where(Predicate... restrictions)
        Modify the delete query to restrict the target of the deletion according to the conjunction of the specified restriction predicates. Replaces the previously added restriction(s), if any. If no restrictions are specified, any previously added restrictions are simply removed.
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified delete query
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CriteriaQuery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CriteriaQuery<T>

  • Type Parameters:
    T - the type of the defined result
    All Superinterfaces:
    AbstractQuery<T>, CommonAbstractCriteria

    public interface CriteriaQuery<T>
extends AbstractQuery<T>
    The CriteriaQuery interface defines functionality that is specific to top-level queries.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CriteriaQuery<T> distinct(boolean distinct)
      Specify whether duplicate query results will be eliminated.
      List<Order> getOrderList()
      Return the ordering expressions in order of precedence.
      Set<ParameterExpression<?>> getParameters()
      Return the parameters of the query.
      CriteriaQuery<T> groupBy(Expression<?>... grouping)
      Specify the expressions that are used to form groups over the query results.
      CriteriaQuery<T> groupBy(List<Expression<?>> grouping)
      Specify the expressions that are used to form groups over the query results.
      CriteriaQuery<T> having(Expression<Boolean> restriction)
      Specify a restriction over the groups of the query.
      CriteriaQuery<T> having(Predicate... restrictions)
      Specify restrictions over the groups of the query according the conjunction of the specified restriction predicates.
      CriteriaQuery<T> multiselect(List<Selection<?>> selectionList)
      Specify the selection items that are to be returned in the query result.
      CriteriaQuery<T> multiselect(Selection<?>... selections)
      Specify the selection items that are to be returned in the query result.
      CriteriaQuery<T> orderBy(List<Order> o)
      Specify the ordering expressions that are used to order the query results.
      CriteriaQuery<T> orderBy(Order... o)
      Specify the ordering expressions that are used to order the query results.
      CriteriaQuery<T> select(Selection<? extends T> selection)
      Specify the item that is to be returned in the query result.
      CriteriaQuery<T> where(Expression<Boolean> restriction)
      Modify the query to restrict the query result according to the specified boolean expression.
      CriteriaQuery<T> where(Predicate... restrictions)
      Modify the query to restrict the query result according to the conjunction of the specified restriction predicates.

      • Methods inherited from interface javax.persistence.criteria.AbstractQuery

        from, from, getGroupList, getGroupRestriction, getResultType, getRoots, getSelection, isDistinct

      • Methods inherited from interface javax.persistence.criteria.CommonAbstractCriteria

        getRestriction, subquery

    • Method Detail

      • select

        CriteriaQuery<T> select(Selection<? extends T> selection)
        Specify the item that is to be returned in the query result. Replaces the previously specified selection(s), if any.

        Note: Applications using the string-based API may need to specify the type of the select item when it results from a get or join operation and the query result type is specified.

             For example:

     CriteriaQuery<String> q = cb.createQuery(String.class);
     Root<Order> order = q.from(Order.class);
     q.select(order.get("shippingAddress").<String>get("state"));

     CriteriaQuery<Product> q2 = cb.createQuery(Product.class);
     q2.select(q2.from(Order.class)
                 .join("items")
                 .<Item,Product>join("product"));
        Parameters:
        selection - selection specifying the item that is to be returned in the query result
        Returns:
        the modified query
        Throws:
        IllegalArgumentException - if the selection is a compound selection and more than one selection item has the same assigned alias

      • multiselect

        CriteriaQuery<T> multiselect(Selection<?>... selections)
        Specify the selection items that are to be returned in the query result. Replaces the previously specified selection(s), if any. The type of the result of the query execution depends on the specification of the type of the criteria query object created as well as the arguments to the multiselect method.

        An argument to the multiselect method must not be a tuple- or array-valued compound selection item.

        The semantics of this method are as follows:

        • If the type of the criteria query is CriteriaQuery<Tuple> (i.e., a criteria query object created by either the createTupleQuery method or by passing a Tuple class argument to the createQuery method), a Tuple object corresponding to the arguments of the multiselect method, in the specified order, will be instantiated and returned for each row that results from the query execution.
        • If the type of the criteria query is CriteriaQuery<X> for some user-defined class X (i.e., a criteria query object created by passing a X class argument to the createQuery method), the arguments to the multiselect method will be passed to the X constructor and an instance of type X will be returned for each row.
        • If the type of the criteria query is CriteriaQuery<X[]> for some class X, an instance of type X[] will be returned for each row. The elements of the array will correspond to the arguments of the multiselect method, in the specified order.
        • If the type of the criteria query is CriteriaQuery<Object> or if the criteria query was created without specifying a type, and only a single argument is passed to the multiselect method, an instance of type Object will be returned for each row.
        • If the type of the criteria query is CriteriaQuery<Object> or if the criteria query was created without specifying a type, and more than one argument is passed to the multiselect method, an instance of type Object[] will be instantiated and returned for each row. The elements of the array will correspond to the arguments to the multiselect method, in the specified order.
        Parameters:
        selections - selection items corresponding to the results to be returned by the query
        Returns:
        the modified query
        Throws:
        IllegalArgumentException - if a selection item is not valid or if more than one selection item has the same assigned alias

      • multiselect

        CriteriaQuery<T> multiselect(List<Selection<?>> selectionList)
        Specify the selection items that are to be returned in the query result. Replaces the previously specified selection(s), if any.

        The type of the result of the query execution depends on the specification of the type of the criteria query object created as well as the argument to the multiselect method. An element of the list passed to the multiselect method must not be a tuple- or array-valued compound selection item.

        The semantics of this method are as follows:

        • If the type of the criteria query is CriteriaQuery<Tuple> (i.e., a criteria query object created by either the createTupleQuery method or by passing a Tuple class argument to the createQuery method), a Tuple object corresponding to the elements of the list passed to the multiselect method, in the specified order, will be instantiated and returned for each row that results from the query execution.
        • If the type of the criteria query is CriteriaQuery<X> for some user-defined class X (i.e., a criteria query object created by passing a X class argument to the createQuery method), the elements of the list passed to the multiselect method will be passed to the X constructor and an instance of type X will be returned for each row.
        • If the type of the criteria query is CriteriaQuery<X[]> for some class X, an instance of type X[] will be returned for each row. The elements of the array will correspond to the elements of the list passed to the multiselect method, in the specified order.
        • If the type of the criteria query is CriteriaQuery<Object> or if the criteria query was created without specifying a type, and the list passed to the multiselect method contains only a single element, an instance of type Object will be returned for each row.
        • If the type of the criteria query is CriteriaQuery<Object> or if the criteria query was created without specifying a type, and the list passed to the multiselect method contains more than one element, an instance of type Object[] will be instantiated and returned for each row. The elements of the array will correspond to the elements of the list passed to the multiselect method, in the specified order.
        Parameters:
        selectionList - list of selection items corresponding to the results to be returned by the query
        Returns:
        the modified query
        Throws:
        IllegalArgumentException - if a selection item is not valid or if more than one selection item has the same assigned alias

      • where

        CriteriaQuery<T> where(Expression<Boolean> restriction)
        Modify the query to restrict the query result according to the specified boolean expression. Replaces the previously added restriction(s), if any. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        where in interface AbstractQuery<T>
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified query

      • where

        CriteriaQuery<T> where(Predicate... restrictions)
        Modify the query to restrict the query result according to the conjunction of the specified restriction predicates. Replaces the previously added restriction(s), if any. If no restrictions are specified, any previously added restrictions are simply removed. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        where in interface AbstractQuery<T>
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified query

      • groupBy

        CriteriaQuery<T> groupBy(Expression<?>... grouping)
        Specify the expressions that are used to form groups over the query results. Replaces the previous specified grouping expressions, if any. If no grouping expressions are specified, any previously added grouping expressions are simply removed. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        groupBy in interface AbstractQuery<T>
        Parameters:
        grouping - zero or more grouping expressions
        Returns:
        the modified query

      • groupBy

        CriteriaQuery<T> groupBy(List<Expression<?>> grouping)
        Specify the expressions that are used to form groups over the query results. Replaces the previous specified grouping expressions, if any. If no grouping expressions are specified, any previously added grouping expressions are simply removed. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        groupBy in interface AbstractQuery<T>
        Parameters:
        grouping - list of zero or more grouping expressions
        Returns:
        the modified query

      • having

        CriteriaQuery<T> having(Expression<Boolean> restriction)
        Specify a restriction over the groups of the query. Replaces the previous having restriction(s), if any. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        having in interface AbstractQuery<T>
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified query

      • having

        CriteriaQuery<T> having(Predicate... restrictions)
        Specify restrictions over the groups of the query according the conjunction of the specified restriction predicates. Replaces the previously added having restriction(s), if any. If no restrictions are specified, any previously added restrictions are simply removed. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        having in interface AbstractQuery<T>
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified query

      • orderBy

        CriteriaQuery<T> orderBy(Order... o)
        Specify the ordering expressions that are used to order the query results. Replaces the previous ordering expressions, if any. If no ordering expressions are specified, the previous ordering, if any, is simply removed, and results will be returned in no particular order. The left-to-right sequence of the ordering expressions determines the precedence, whereby the leftmost has highest precedence.
        Parameters:
        o - zero or more ordering expressions
        Returns:
        the modified query

      • orderBy

        CriteriaQuery<T> orderBy(List<Order> o)
        Specify the ordering expressions that are used to order the query results. Replaces the previous ordering expressions, if any. If no ordering expressions are specified, the previous ordering, if any, is simply removed, and results will be returned in no particular order. The order of the ordering expressions in the list determines the precedence, whereby the first element in the list has highest precedence.
        Parameters:
        o - list of zero or more ordering expressions
        Returns:
        the modified query

      • distinct

        CriteriaQuery<T> distinct(boolean distinct)
        Specify whether duplicate query results will be eliminated. A true value will cause duplicates to be eliminated. A false value will cause duplicates to be retained. If distinct has not been specified, duplicate results must be retained. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        distinct in interface AbstractQuery<T>
        Parameters:
        distinct - boolean value specifying whether duplicate results must be eliminated from the query result or whether they must be retained
        Returns:
        the modified query.

      • getOrderList

        List<Order> getOrderList()
        Return the ordering expressions in order of precedence. Returns empty list if no ordering expressions have been specified. Modifications to the list do not affect the query.
        Returns:
        the list of ordering expressions

      • getParameters

        Set<ParameterExpression<?>> getParameters()
        Return the parameters of the query. Returns empty set if there are no parameters. Modifications to the set do not affect the query.
        Returns:
        the query parameters
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CriteriaUpdate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface CriteriaUpdate<T>

  • Type Parameters:
    T - the entity type that is the target of the update
    All Superinterfaces:
    CommonAbstractCriteria

    public interface CriteriaUpdate<T>
extends CommonAbstractCriteria
    The CriteriaUpdate interface defines functionality for performing bulk update operations using the Criteria API.

    Criteria API bulk update operations map directly to database update operations, bypassing any optimistic locking checks. Portable applications using bulk update operations must manually update the value of the version column, if desired, and/or manually validate the value of the version column. The persistence context is not synchronized with the result of the bulk update.

    A CriteriaUpdate object must have a single root.

    Since:
    Java Persistence 2.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Root<T> from(Class<T> entityClass)
      Create and add a query root corresponding to the entity that is the target of the update.
      Root<T> from(EntityType<T> entity)
      Create and add a query root corresponding to the entity that is the target of the update.
      Root<T> getRoot()
      Return the query root.
      <Y> CriteriaUpdate<T> set(Path<Y> attribute, Expression<? extends Y> value)
      Update the value of the specified attribute.
      <Y,X extends Y>
      CriteriaUpdate<T>             		set(Path<Y> attribute, X value)
      Update the value of the specified attribute.
      <Y> CriteriaUpdate<T> set(SingularAttribute<? super T,Y> attribute, Expression<? extends Y> value)
      Update the value of the specified attribute.
      <Y,X extends Y>
      CriteriaUpdate<T>             		set(SingularAttribute<? super T,Y> attribute, X value)
      Update the value of the specified attribute.
      CriteriaUpdate<T> set(String attributeName, Object value)
      Update the value of the specified attribute.
      CriteriaUpdate<T> where(Expression<Boolean> restriction)
      Modify the update query to restrict the target of the update according to the specified boolean expression.
      CriteriaUpdate<T> where(Predicate... restrictions)
      Modify the update query to restrict the target of the update according to the conjunction of the specified restriction predicates.

      • Methods inherited from interface javax.persistence.criteria.CommonAbstractCriteria

        getRestriction, subquery

    • Method Detail

      • from

        Root<T> from(Class<T> entityClass)
        Create and add a query root corresponding to the entity that is the target of the update. A CriteriaUpdate object has a single root, the entity that is being updated.
        Parameters:
        entityClass - the entity class
        Returns:
        query root corresponding to the given entity

      • from

        Root<T> from(EntityType<T> entity)
        Create and add a query root corresponding to the entity that is the target of the update. A CriteriaUpdate object has a single root, the entity that is being updated.
        Parameters:
        entity - metamodel entity representing the entity of type X
        Returns:
        query root corresponding to the given entity

      • getRoot

        Root<T> getRoot()
        Return the query root.
        Returns:
        the query root

      • set

        <Y,X extends Y> CriteriaUpdate<T> set(SingularAttribute<? super T,Y> attribute,
                                    X value)
        Update the value of the specified attribute.
        Parameters:
        attribute - attribute to be updated
        value - new value
        Returns:
        the modified update query

      • set

        <Y> CriteriaUpdate<T> set(SingularAttribute<? super T,Y> attribute,
                        Expression<? extends Y> value)
        Update the value of the specified attribute.
        Parameters:
        attribute - attribute to be updated
        value - new value
        Returns:
        the modified update query

      • set

        <Y,X extends Y> CriteriaUpdate<T> set(Path<Y> attribute,
                                    X value)
        Update the value of the specified attribute.
        Parameters:
        attribute - attribute to be updated
        value - new value
        Returns:
        the modified update query

      • set

        <Y> CriteriaUpdate<T> set(Path<Y> attribute,
                        Expression<? extends Y> value)
        Update the value of the specified attribute.
        Parameters:
        attribute - attribute to be updated
        value - new value
        Returns:
        the modified update query

      • set

        CriteriaUpdate<T> set(String attributeName,
                    Object value)
        Update the value of the specified attribute.
        Parameters:
        attributeName - name of the attribute to be updated
        value - new value
        Returns:
        the modified update query

      • where

        CriteriaUpdate<T> where(Expression<Boolean> restriction)
        Modify the update query to restrict the target of the update according to the specified boolean expression. Replaces the previously added restriction(s), if any.
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified update query

      • where

        CriteriaUpdate<T> where(Predicate... restrictions)
        Modify the update query to restrict the target of the update according to the conjunction of the specified restriction predicates. Replaces the previously added restriction(s), if any. If no restrictions are specified, any previously added restrictions are simply removed.
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified update query
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Expression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface Expression<T>

  • Type Parameters:
    T - the type of the expression
    All Superinterfaces:
    Selection<T>, TupleElement<T>
    All Known Subinterfaces:
    CollectionJoin<Z,E>, CriteriaBuilder.Case<R>, CriteriaBuilder.Coalesce<T>, CriteriaBuilder.In<T>, CriteriaBuilder.SimpleCase<C,R>, From<Z,X>, Join<Z,X>, ListJoin<Z,E>, MapJoin<Z,K,V>, ParameterExpression<T>, Path<X>, PluralJoin<Z,C,E>, Predicate, Root<X>, SetJoin<Z,E>, Subquery<T>

    public interface Expression<T>
extends Selection<T>
    Type for query expressions.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <X> Expression<X> as(Class<X> type)
      Perform a typecast upon the expression, returning a new expression object.
      Predicate in(Collection<?> values)
      Create a predicate to test whether the expression is a member of the collection.
      Predicate in(Expression<?>... values)
      Create a predicate to test whether the expression is a member of the argument list.
      Predicate in(Expression<Collection<?>> values)
      Create a predicate to test whether the expression is a member of the collection.
      Predicate in(Object... values)
      Create a predicate to test whether the expression is a member of the argument list.
      Predicate isNotNull()
      Create a predicate to test whether the expression is not null.
      Predicate isNull()
      Create a predicate to test whether the expression is null.

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

    • Method Detail

      • isNull

        Predicate isNull()
        Create a predicate to test whether the expression is null.
        Returns:
        predicate testing whether the expression is null

      • isNotNull

        Predicate isNotNull()
        Create a predicate to test whether the expression is not null.
        Returns:
        predicate testing whether the expression is not null

      • in

        Predicate in(Object... values)
        Create a predicate to test whether the expression is a member of the argument list.
        Parameters:
        values - values to be tested against
        Returns:
        predicate testing for membership

      • in

        Predicate in(Expression<?>... values)
        Create a predicate to test whether the expression is a member of the argument list.
        Parameters:
        values - expressions to be tested against
        Returns:
        predicate testing for membership

      • in

        Predicate in(Collection<?> values)
        Create a predicate to test whether the expression is a member of the collection.
        Parameters:
        values - collection of values to be tested against
        Returns:
        predicate testing for membership

      • in

        Predicate in(Expression<Collection<?>> values)
        Create a predicate to test whether the expression is a member of the collection.
        Parameters:
        values - expression corresponding to collection to be tested against
        Returns:
        predicate testing for membership

      • as

        <X> Expression<X> as(Class<X> type)
        Perform a typecast upon the expression, returning a new expression object. This method does not cause type conversion: the runtime type is not changed. Warning: may result in a runtime failure.
        Parameters:
        type - intended type of the expression
        Returns:
        new expression of the given type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Fetch (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface Fetch<Z,X>

  • Type Parameters:
    Z - the source type of the fetch
    X - the target type of the fetch
    All Superinterfaces:
    FetchParent<Z,X>

    public interface Fetch<Z,X>
extends FetchParent<Z,X>
    Represents a join-fetched association or attribute.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Attribute<? super Z,?> getAttribute()
      Return the metamodel attribute corresponding to the fetch join.
      JoinType getJoinType()
      Return the join type used in the fetch join.
      FetchParent<?,Z> getParent()
      Return the parent of the fetched item.

      • Methods inherited from interface javax.persistence.criteria.FetchParent

        fetch, fetch, fetch, fetch, fetch, fetch, getFetches

    • Method Detail

      • getAttribute

        Attribute<? super Z,?> getAttribute()
        Return the metamodel attribute corresponding to the fetch join.
        Returns:
        metamodel attribute for the join

      • getParent

        FetchParent<?,Z> getParent()
        Return the parent of the fetched item.
        Returns:
        fetch parent

      • getJoinType

        JoinType getJoinType()
        Return the join type used in the fetch join.
        Returns:
        join type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FetchParent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface FetchParent<Z,X>

  • Type Parameters:
    Z - the source type
    X - the target type
    All Known Subinterfaces:
    CollectionJoin<Z,E>, Fetch<Z,X>, From<Z,X>, Join<Z,X>, ListJoin<Z,E>, MapJoin<Z,K,V>, PluralJoin<Z,C,E>, Root<X>, SetJoin<Z,E>

    public interface FetchParent<Z,X>
    Represents an element of the from clause which may function as the parent of Fetches.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <Y> Fetch<X,Y> fetch(PluralAttribute<? super X,?,Y> attribute)
      Create a fetch join to the specified collection-valued attribute using an inner join.
      <Y> Fetch<X,Y> fetch(PluralAttribute<? super X,?,Y> attribute, JoinType jt)
      Create a fetch join to the specified collection-valued attribute using the given join type.
      <Y> Fetch<X,Y> fetch(SingularAttribute<? super X,Y> attribute)
      Create a fetch join to the specified single-valued attribute using an inner join.
      <Y> Fetch<X,Y> fetch(SingularAttribute<? super X,Y> attribute, JoinType jt)
      Create a fetch join to the specified single-valued attribute using the given join type.
      <X,Y> Fetch<X,Y> fetch(String attributeName)
      Create a fetch join to the specified attribute using an inner join.
      <X,Y> Fetch<X,Y> fetch(String attributeName, JoinType jt)
      Create a fetch join to the specified attribute using the given join type.
      Set<Fetch<X,?>> getFetches()
      Return the fetch joins that have been made from this type.

    • Method Detail

      • getFetches

        Set<Fetch<X,?>> getFetches()
        Return the fetch joins that have been made from this type. Returns empty set if no fetch joins have been made from this type. Modifications to the set do not affect the query.
        Returns:
        fetch joins made from this type

      • fetch

        <Y> Fetch<X,Y> fetch(SingularAttribute<? super X,Y> attribute)
        Create a fetch join to the specified single-valued attribute using an inner join.
        Parameters:
        attribute - target of the join
        Returns:
        the resulting fetch join

      • fetch

        <Y> Fetch<X,Y> fetch(SingularAttribute<? super X,Y> attribute,
                   JoinType jt)
        Create a fetch join to the specified single-valued attribute using the given join type.
        Parameters:
        attribute - target of the join
        jt - join type
        Returns:
        the resulting fetch join

      • fetch

        <Y> Fetch<X,Y> fetch(PluralAttribute<? super X,?,Y> attribute)
        Create a fetch join to the specified collection-valued attribute using an inner join.
        Parameters:
        attribute - target of the join
        Returns:
        the resulting join

      • fetch

        <Y> Fetch<X,Y> fetch(PluralAttribute<? super X,?,Y> attribute,
                   JoinType jt)
        Create a fetch join to the specified collection-valued attribute using the given join type.
        Parameters:
        attribute - target of the join
        jt - join type
        Returns:
        the resulting join

      • fetch

        <X,Y> Fetch<X,Y> fetch(String attributeName)
        Create a fetch join to the specified attribute using an inner join.
        Parameters:
        attributeName - name of the attribute for the target of the join
        Returns:
        the resulting fetch join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist

      • fetch

        <X,Y> Fetch<X,Y> fetch(String attributeName,
                     JoinType jt)
        Create a fetch join to the specified attribute using the given join type.
        Parameters:
        attributeName - name of the attribute for the target of the join
        jt - join type
        Returns:
        the resulting fetch join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


From (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface From<Z,X>

  • Type Parameters:
    Z - the source type
    X - the target type
    All Superinterfaces:
    Expression<X>, FetchParent<Z,X>, Path<X>, Selection<X>, TupleElement<X>
    All Known Subinterfaces:
    CollectionJoin<Z,E>, Join<Z,X>, ListJoin<Z,E>, MapJoin<Z,K,V>, PluralJoin<Z,C,E>, Root<X>, SetJoin<Z,E>

    public interface From<Z,X>
extends Path<X>, FetchParent<Z,X>
    Represents a bound type, usually an entity that appears in the from clause, but may also be an embeddable belonging to an entity in the from clause.

    Serves as a factory for Joins of associations, embeddables, and collections belonging to the type, and for Paths of attributes belonging to the type.

    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      From<Z,X> getCorrelationParent()
      Returns the parent From object from which the correlated From object has been obtained through correlation (use of a Subquery correlate method).
      Set<Join<X,?>> getJoins()
      Return the joins that have been made from this bound type.
      boolean isCorrelated()
      Whether the From object has been obtained as a result of correlation (use of a Subquery correlate method).
      <Y> CollectionJoin<X,Y> join(CollectionAttribute<? super X,Y> collection)
      Create an inner join to the specified Collection-valued attribute.
      <Y> CollectionJoin<X,Y> join(CollectionAttribute<? super X,Y> collection, JoinType jt)
      Create a join to the specified Collection-valued attribute using the given join type.
      <Y> ListJoin<X,Y> join(ListAttribute<? super X,Y> list)
      Create an inner join to the specified List-valued attribute.
      <Y> ListJoin<X,Y> join(ListAttribute<? super X,Y> list, JoinType jt)
      Create a join to the specified List-valued attribute using the given join type.
      <K,V> MapJoin<X,K,V> join(MapAttribute<? super X,K,V> map)
      Create an inner join to the specified Map-valued attribute.
      <K,V> MapJoin<X,K,V> join(MapAttribute<? super X,K,V> map, JoinType jt)
      Create a join to the specified Map-valued attribute using the given join type.
      <Y> SetJoin<X,Y> join(SetAttribute<? super X,Y> set)
      Create an inner join to the specified Set-valued attribute.
      <Y> SetJoin<X,Y> join(SetAttribute<? super X,Y> set, JoinType jt)
      Create a join to the specified Set-valued attribute using the given join type.
      <Y> Join<X,Y> join(SingularAttribute<? super X,Y> attribute)
      Create an inner join to the specified single-valued attribute.
      <Y> Join<X,Y> join(SingularAttribute<? super X,Y> attribute, JoinType jt)
      Create a join to the specified single-valued attribute using the given join type.
      <X,Y> Join<X,Y> join(String attributeName)
      Create an inner join to the specified attribute.
      <X,Y> Join<X,Y> join(String attributeName, JoinType jt)
      Create a join to the specified attribute using the given join type.
      <X,Y> CollectionJoin<X,Y> joinCollection(String attributeName)
      Create an inner join to the specified Collection-valued attribute.
      <X,Y> CollectionJoin<X,Y> joinCollection(String attributeName, JoinType jt)
      Create a join to the specified Collection-valued attribute using the given join type.
      <X,Y> ListJoin<X,Y> joinList(String attributeName)
      Create an inner join to the specified List-valued attribute.
      <X,Y> ListJoin<X,Y> joinList(String attributeName, JoinType jt)
      Create a join to the specified List-valued attribute using the given join type.
      <X,K,V> MapJoin<X,K,V> joinMap(String attributeName)
      Create an inner join to the specified Map-valued attribute.
      <X,K,V> MapJoin<X,K,V> joinMap(String attributeName, JoinType jt)
      Create a join to the specified Map-valued attribute using the given join type.
      <X,Y> SetJoin<X,Y> joinSet(String attributeName)
      Create an inner join to the specified Set-valued attribute.
      <X,Y> SetJoin<X,Y> joinSet(String attributeName, JoinType jt)
      Create a join to the specified Set-valued attribute using the given join type.

      • Methods inherited from interface javax.persistence.criteria.Path

        get, get, get, get, getModel, getParentPath, type

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

      • Methods inherited from interface javax.persistence.criteria.FetchParent

        fetch, fetch, fetch, fetch, fetch, fetch, getFetches

    • Method Detail

      • getJoins

        Set<Join<X,?>> getJoins()
        Return the joins that have been made from this bound type. Returns empty set if no joins have been made from this bound type. Modifications to the set do not affect the query.
        Returns:
        joins made from this type

      • isCorrelated

        boolean isCorrelated()
        Whether the From object has been obtained as a result of correlation (use of a Subquery correlate method).
        Returns:
        boolean indicating whether the object has been obtained through correlation

      • getCorrelationParent

        From<Z,X> getCorrelationParent()
        Returns the parent From object from which the correlated From object has been obtained through correlation (use of a Subquery correlate method).
        Returns:
        the parent of the correlated From object
        Throws:
        IllegalStateException - if the From object has not been obtained through correlation

      • join

        <Y> Join<X,Y> join(SingularAttribute<? super X,Y> attribute)
        Create an inner join to the specified single-valued attribute.
        Parameters:
        attribute - target of the join
        Returns:
        the resulting join

      • join

        <Y> Join<X,Y> join(SingularAttribute<? super X,Y> attribute,
                 JoinType jt)
        Create a join to the specified single-valued attribute using the given join type.
        Parameters:
        attribute - target of the join
        jt - join type
        Returns:
        the resulting join

      • join

        <Y> CollectionJoin<X,Y> join(CollectionAttribute<? super X,Y> collection)
        Create an inner join to the specified Collection-valued attribute.
        Parameters:
        collection - target of the join
        Returns:
        the resulting join

      • join

        <Y> SetJoin<X,Y> join(SetAttribute<? super X,Y> set)
        Create an inner join to the specified Set-valued attribute.
        Parameters:
        set - target of the join
        Returns:
        the resulting join

      • join

        <Y> ListJoin<X,Y> join(ListAttribute<? super X,Y> list)
        Create an inner join to the specified List-valued attribute.
        Parameters:
        list - target of the join
        Returns:
        the resulting join

      • join

        <K,V> MapJoin<X,K,V> join(MapAttribute<? super X,K,V> map)
        Create an inner join to the specified Map-valued attribute.
        Parameters:
        map - target of the join
        Returns:
        the resulting join

      • join

        <Y> CollectionJoin<X,Y> join(CollectionAttribute<? super X,Y> collection,
                           JoinType jt)
        Create a join to the specified Collection-valued attribute using the given join type.
        Parameters:
        collection - target of the join
        jt - join type
        Returns:
        the resulting join

      • join

        <Y> SetJoin<X,Y> join(SetAttribute<? super X,Y> set,
                    JoinType jt)
        Create a join to the specified Set-valued attribute using the given join type.
        Parameters:
        set - target of the join
        jt - join type
        Returns:
        the resulting join

      • join

        <Y> ListJoin<X,Y> join(ListAttribute<? super X,Y> list,
                     JoinType jt)
        Create a join to the specified List-valued attribute using the given join type.
        Parameters:
        list - target of the join
        jt - join type
        Returns:
        the resulting join

      • join

        <K,V> MapJoin<X,K,V> join(MapAttribute<? super X,K,V> map,
                        JoinType jt)
        Create a join to the specified Map-valued attribute using the given join type.
        Parameters:
        map - target of the join
        jt - join type
        Returns:
        the resulting join

      • join

        <X,Y> Join<X,Y> join(String attributeName)
        Create an inner join to the specified attribute.
        Parameters:
        attributeName - name of the attribute for the target of the join
        Returns:
        the resulting join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist

      • joinCollection

        <X,Y> CollectionJoin<X,Y> joinCollection(String attributeName)
        Create an inner join to the specified Collection-valued attribute.
        Parameters:
        attributeName - name of the attribute for the target of the join
        Returns:
        the resulting join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist

      • joinSet

        <X,Y> SetJoin<X,Y> joinSet(String attributeName)
        Create an inner join to the specified Set-valued attribute.
        Parameters:
        attributeName - name of the attribute for the target of the join
        Returns:
        the resulting join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist

      • joinList

        <X,Y> ListJoin<X,Y> joinList(String attributeName)
        Create an inner join to the specified List-valued attribute.
        Parameters:
        attributeName - name of the attribute for the target of the join
        Returns:
        the resulting join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist

      • joinMap

        <X,K,V> MapJoin<X,K,V> joinMap(String attributeName)
        Create an inner join to the specified Map-valued attribute.
        Parameters:
        attributeName - name of the attribute for the target of the join
        Returns:
        the resulting join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist

      • join

        <X,Y> Join<X,Y> join(String attributeName,
                   JoinType jt)
        Create a join to the specified attribute using the given join type.
        Parameters:
        attributeName - name of the attribute for the target of the join
        jt - join type
        Returns:
        the resulting join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist

      • joinCollection

        <X,Y> CollectionJoin<X,Y> joinCollection(String attributeName,
                                       JoinType jt)
        Create a join to the specified Collection-valued attribute using the given join type.
        Parameters:
        attributeName - name of the attribute for the target of the join
        jt - join type
        Returns:
        the resulting join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist

      • joinSet

        <X,Y> SetJoin<X,Y> joinSet(String attributeName,
                         JoinType jt)
        Create a join to the specified Set-valued attribute using the given join type.
        Parameters:
        attributeName - name of the attribute for the target of the join
        jt - join type
        Returns:
        the resulting join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist

      • joinList

        <X,Y> ListJoin<X,Y> joinList(String attributeName,
                           JoinType jt)
        Create a join to the specified List-valued attribute using the given join type.
        Parameters:
        attributeName - name of the attribute for the target of the join
        jt - join type
        Returns:
        the resulting join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist

      • joinMap

        <X,K,V> MapJoin<X,K,V> joinMap(String attributeName,
                             JoinType jt)
        Create a join to the specified Map-valued attribute using the given join type.
        Parameters:
        attributeName - name of the attribute for the target of the join
        jt - join type
        Returns:
        the resulting join
        Throws:
        IllegalArgumentException - if attribute of the given name does not exist
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.persistence.criteria (Java(TM) EE 7 Specification APIs)

javax.persistence.criteria

Interfaces

  • AbstractQuery
  • CollectionJoin
  • CommonAbstractCriteria
  • CompoundSelection
  • CriteriaBuilder
  • CriteriaBuilder.Case
  • CriteriaBuilder.Coalesce
  • CriteriaBuilder.In
  • CriteriaBuilder.SimpleCase
  • CriteriaDelete
  • CriteriaQuery
  • CriteriaUpdate
  • Expression
  • Fetch
  • FetchParent
  • From
  • Join
  • ListJoin
  • MapJoin
  • Order
  • ParameterExpression
  • Path
  • PluralJoin
  • Predicate
  • Root
  • Selection
  • SetJoin
  • Subquery

Enums

  • CriteriaBuilder.Trimspec
  • JoinType
  • Predicate.BooleanOperator


javax.persistence.criteria (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.persistence.criteria

Java Persistence Criteria API

See: Description

  • Interface Summary
    Interface Description
    AbstractQuery<T>
    The AbstractQuery interface defines functionality that is common to both top-level queries and subqueries.
    CollectionJoin<Z,E>
    The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
    CommonAbstractCriteria
    The CommonAbstractCriteria interface defines functionality that is common to both top-level criteria queries and subqueries as well as to update and delete criteria operations.
    CompoundSelection<X>
    The CompoundSelection interface defines a compound selection item (tuple, array, or result of constructor).
    CriteriaBuilder
    Used to construct criteria queries, compound selections, expressions, predicates, orderings.
    CriteriaBuilder.Case<R>
    Interface used to build general case expressions.
    CriteriaBuilder.Coalesce<T>
    Interface used to build coalesce expressions.
    CriteriaBuilder.In<T>
    Interface used to build in predicates.
    CriteriaBuilder.SimpleCase<C,R>
    Interface used to build simple case expressions.
    CriteriaDelete<T>
    The CriteriaDelete interface defines functionality for performing bulk delete operations using the Criteria API
    CriteriaQuery<T>
    The CriteriaQuery interface defines functionality that is specific to top-level queries.
    CriteriaUpdate<T>
    The CriteriaUpdate interface defines functionality for performing bulk update operations using the Criteria API.
    Expression<T>
    Type for query expressions.
    Fetch<Z,X>
    Represents a join-fetched association or attribute.
    FetchParent<Z,X>
    Represents an element of the from clause which may function as the parent of Fetches.
    From<Z,X>
    Represents a bound type, usually an entity that appears in the from clause, but may also be an embeddable belonging to an entity in the from clause.
    Join<Z,X>
    A join to an entity, embeddable, or basic type.
    ListJoin<Z,E>
    The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
    MapJoin<Z,K,V>
    The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
    Order
    An object that defines an ordering over the query results.
    ParameterExpression<T>
    Type of criteria query parameter expressions.
    Path<X>
    Represents a simple or compound attribute path from a bound type or collection, and is a "primitive" expression.
    PluralJoin<Z,C,E>
    The PluralJoin interface defines functionality that is common to joins to all collection types.
    Predicate
    The type of a simple or compound predicate: a conjunction or disjunction of restrictions.
    Root<X>
    A root type in the from clause.
    Selection<X>
    The Selection interface defines an item that is to be returned in a query result.
    SetJoin<Z,E>
    The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
    Subquery<T>
    The Subquery interface defines functionality that is specific to subqueries.
  • Enum Summary
    Enum Description
    CriteriaBuilder.Trimspec
    Used to specify how strings are trimmed.
    JoinType
    Defines the three types of joins.
    Predicate.BooleanOperator

Package javax.persistence.criteria Description

Java Persistence Criteria API
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.persistence.criteria Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.persistence.criteria

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.persistence.criteria.CommonAbstractCriteria
    • javax.persistence.criteria.AbstractQuery<T>
      • javax.persistence.criteria.CriteriaQuery<T>
      • javax.persistence.criteria.Subquery<T> (also extends javax.persistence.criteria.Expression<T>)
    • javax.persistence.criteria.CriteriaDelete<T>
    • javax.persistence.criteria.CriteriaUpdate<T>
  • javax.persistence.criteria.CriteriaBuilder
  • javax.persistence.criteria.FetchParent<Z,X>
    • javax.persistence.criteria.Fetch<Z,X>
    • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.Path<X>)
      • javax.persistence.criteria.Join<Z,X>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Root<X>
  • javax.persistence.criteria.Order
  • javax.persistence.Parameter<T>
    • javax.persistence.criteria.ParameterExpression<T> (also extends javax.persistence.criteria.Expression<T>)
  • javax.persistence.TupleElement<X>
    • javax.persistence.criteria.Selection<X>
      • javax.persistence.criteria.CompoundSelection<X>
      • javax.persistence.criteria.Expression<T>
        • javax.persistence.criteria.CriteriaBuilder.Case<R>
        • javax.persistence.criteria.CriteriaBuilder.Coalesce<T>
        • javax.persistence.criteria.CriteriaBuilder.SimpleCase<C,R>
        • javax.persistence.criteria.ParameterExpression<T> (also extends javax.persistence.Parameter<T>)
        • javax.persistence.criteria.Path<X>
          • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.FetchParent<Z,X>)
            • javax.persistence.criteria.Join<Z,X>
              • javax.persistence.criteria.PluralJoin<Z,C,E>
                • javax.persistence.criteria.CollectionJoin<Z,E>
                • javax.persistence.criteria.ListJoin<Z,E>
                • javax.persistence.criteria.MapJoin<Z,K,V>
                • javax.persistence.criteria.SetJoin<Z,E>
            • javax.persistence.criteria.Root<X>
        • javax.persistence.criteria.Predicate
          • javax.persistence.criteria.CriteriaBuilder.In<T>
        • javax.persistence.criteria.Subquery<T> (also extends javax.persistence.criteria.AbstractQuery<T>)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.persistence.criteria.Predicate.BooleanOperator
      • javax.persistence.criteria.JoinType
      • javax.persistence.criteria.CriteriaBuilder.Trimspec
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Join (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface Join<Z,X>

  • Type Parameters:
    Z - the source type of the join
    X - the target type of the join
    All Superinterfaces:
    Expression<X>, FetchParent<Z,X>, From<Z,X>, Path<X>, Selection<X>, TupleElement<X>
    All Known Subinterfaces:
    CollectionJoin<Z,E>, ListJoin<Z,E>, MapJoin<Z,K,V>, PluralJoin<Z,C,E>, SetJoin<Z,E>

    public interface Join<Z,X>
extends From<Z,X>
    A join to an entity, embeddable, or basic type.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Attribute<? super Z,?> getAttribute()
      Return the metamodel attribute corresponding to the join.
      JoinType getJoinType()
      Return the join type.
      Predicate getOn()
      Return the predicate that corresponds to the ON restriction(s) on the join, or null if no ON condition has been specified.
      From<?,Z> getParent()
      Return the parent of the join.
      Join<Z,X> on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      Join<Z,X> on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.

      • Methods inherited from interface javax.persistence.criteria.From

        getCorrelationParent, getJoins, isCorrelated, join, join, join, join, join, join, join, join, join, join, join, join, joinCollection, joinCollection, joinList, joinList, joinMap, joinMap, joinSet, joinSet

      • Methods inherited from interface javax.persistence.criteria.Path

        get, get, get, get, getModel, getParentPath, type

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

      • Methods inherited from interface javax.persistence.criteria.FetchParent

        fetch, fetch, fetch, fetch, fetch, fetch, getFetches

    • Method Detail

      • on

        Join<Z,X> on(Expression<Boolean> restriction)
        Modify the join to restrict the result according to the specified ON condition and return the join object. Replaces the previous ON condition, if any.
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified join object
        Since:
        Java Persistence 2.1

      • on

        Join<Z,X> on(Predicate... restrictions)
        Modify the join to restrict the result according to the specified ON condition and return the join object. Replaces the previous ON condition, if any.
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified join object
        Since:
        Java Persistence 2.1

      • getOn

        Predicate getOn()
        Return the predicate that corresponds to the ON restriction(s) on the join, or null if no ON condition has been specified.
        Returns:
        the ON restriction predicate
        Since:
        Java Persistence 2.1

      • getAttribute

        Attribute<? super Z,?> getAttribute()
        Return the metamodel attribute corresponding to the join.
        Returns:
        metamodel attribute corresponding to the join

      • getParent

        From<?,Z> getParent()
        Return the parent of the join.
        Returns:
        join parent

      • getJoinType

        JoinType getJoinType()
        Return the join type.
        Returns:
        join type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JoinType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence.criteria

Enum JoinType

  • java.lang.Object
    • java.lang.Enum<JoinType>
      • javax.persistence.criteria.JoinType
  • All Implemented Interfaces:
    Serializable, Comparable<JoinType>

    public enum JoinType
extends Enum<JoinType>
    Defines the three types of joins. Right outer joins and right outer fetch joins are not required to be supported in Java Persistence 2.1. Applications that use RIGHT join types will not be portable.
    Since:
    Java Persistence 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      INNER
      Inner join.
      LEFT
      Left outer join.
      RIGHT
      Right outer join.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static JoinType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JoinType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • INNER

        public static final JoinType INNER
        Inner join.

      • LEFT

        public static final JoinType LEFT
        Left outer join.

      • RIGHT

        public static final JoinType RIGHT
        Right outer join.

    • Method Detail

      • values

        public static JoinType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (JoinType c : JoinType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static JoinType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ListJoin (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface ListJoin<Z,E>

  • Type Parameters:
    Z - the source type of the join
    E - the element type of the target List
    All Superinterfaces:
    Expression<E>, FetchParent<Z,E>, From<Z,E>, Join<Z,E>, Path<E>, PluralJoin<Z,List<E>,E>, Selection<E>, TupleElement<E>

    public interface ListJoin<Z,E>
extends PluralJoin<Z,List<E>,E>
    The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ListAttribute<? super Z,E> getModel()
      Return the metamodel representation for the list attribute.
      Expression<Integer> index()
      Create an expression that corresponds to the index of the object in the referenced association or element collection.
      ListJoin<Z,E> on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      ListJoin<Z,E> on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.

      • Methods inherited from interface javax.persistence.criteria.Join

        getAttribute, getJoinType, getOn, getParent

      • Methods inherited from interface javax.persistence.criteria.From

        getCorrelationParent, getJoins, isCorrelated, join, join, join, join, join, join, join, join, join, join, join, join, joinCollection, joinCollection, joinList, joinList, joinMap, joinMap, joinSet, joinSet

      • Methods inherited from interface javax.persistence.criteria.Path

        get, get, get, get, getParentPath, type

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

      • Methods inherited from interface javax.persistence.criteria.FetchParent

        fetch, fetch, fetch, fetch, fetch, fetch, getFetches

    • Method Detail

      • on

        ListJoin<Z,E> on(Expression<Boolean> restriction)
        Modify the join to restrict the result according to the specified ON condition and return the join object. Replaces the previous ON condition, if any.
        Specified by:
        on in interface Join<Z,E>
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified join object
        Since:
        Java Persistence 2.1

      • on

        ListJoin<Z,E> on(Predicate... restrictions)
        Modify the join to restrict the result according to the specified ON condition and return the join object. Replaces the previous ON condition, if any.
        Specified by:
        on in interface Join<Z,E>
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified join object
        Since:
        Java Persistence 2.1

      • getModel

        ListAttribute<? super Z,E> getModel()
        Return the metamodel representation for the list attribute.
        Specified by:
        getModel in interface Path<E>
        Specified by:
        getModel in interface PluralJoin<Z,List<E>,E>
        Returns:
        metamodel type representing the List that is the target of the join

      • index

        Expression<Integer> index()
        Create an expression that corresponds to the index of the object in the referenced association or element collection. This method must only be invoked upon an object that represents an association or element collection for which an order column has been defined.
        Returns:
        expression denoting the index
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MapJoin (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface MapJoin<Z,K,V>

  • Type Parameters:
    Z - the source type of the join
    K - the type of the target Map key
    V - the type of the target Map value
    All Superinterfaces:
    Expression<V>, FetchParent<Z,V>, From<Z,V>, Join<Z,V>, Path<V>, PluralJoin<Z,Map<K,V>,V>, Selection<V>, TupleElement<V>

    public interface MapJoin<Z,K,V>
extends PluralJoin<Z,Map<K,V>,V>
    The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Expression<Map.Entry<K,V>> entry()
      Create an expression that corresponds to the map entry.
      MapAttribute<? super Z,K,V> getModel()
      Return the metamodel representation for the map attribute.
      Path<K> key()
      Create a path expression that corresponds to the map key.
      MapJoin<Z,K,V> on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      MapJoin<Z,K,V> on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      Path<V> value()
      Create a path expression that corresponds to the map value.

      • Methods inherited from interface javax.persistence.criteria.Join

        getAttribute, getJoinType, getOn, getParent

      • Methods inherited from interface javax.persistence.criteria.From

        getCorrelationParent, getJoins, isCorrelated, join, join, join, join, join, join, join, join, join, join, join, join, joinCollection, joinCollection, joinList, joinList, joinMap, joinMap, joinSet, joinSet

      • Methods inherited from interface javax.persistence.criteria.Path

        get, get, get, get, getParentPath, type

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

      • Methods inherited from interface javax.persistence.criteria.FetchParent

        fetch, fetch, fetch, fetch, fetch, fetch, getFetches

    • Method Detail

      • on

        MapJoin<Z,K,V> on(Expression<Boolean> restriction)
        Modify the join to restrict the result according to the specified ON condition and return the join object. Replaces the previous ON condition, if any.
        Specified by:
        on in interface Join<Z,V>
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified join object
        Since:
        Java Persistence 2.1

      • on

        MapJoin<Z,K,V> on(Predicate... restrictions)
        Modify the join to restrict the result according to the specified ON condition and return the join object. Replaces the previous ON condition, if any.
        Specified by:
        on in interface Join<Z,V>
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified join object
        Since:
        Java Persistence 2.1

      • getModel

        MapAttribute<? super Z,K,V> getModel()
        Return the metamodel representation for the map attribute.
        Specified by:
        getModel in interface Path<V>
        Specified by:
        getModel in interface PluralJoin<Z,Map<K,V>,V>
        Returns:
        metamodel type representing the Map that is the target of the join

      • key

        Path<K> key()
        Create a path expression that corresponds to the map key.
        Returns:
        path corresponding to map key

      • value

        Path<V> value()
        Create a path expression that corresponds to the map value. This method is for stylistic use only: it just returns this.
        Returns:
        path corresponding to the map value

      • entry

        Expression<Map.Entry<K,V>> entry()
        Create an expression that corresponds to the map entry.
        Returns:
        expression corresponding to the map entry
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Order (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface Order

  • public interface Order
    An object that defines an ordering over the query results.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Expression<?> getExpression()
      Return the expression that is used for ordering.
      boolean isAscending()
      Whether ascending ordering is in effect.
      Order reverse()
      Switch the ordering.

    • Method Detail

      • reverse

        Order reverse()
        Switch the ordering.
        Returns:
        a new Order instance with the reversed ordering

      • isAscending

        boolean isAscending()
        Whether ascending ordering is in effect.
        Returns:
        boolean indicating whether ordering is ascending

      • getExpression

        Expression<?> getExpression()
        Return the expression that is used for ordering.
        Returns:
        expression used for ordering
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ParameterExpression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface ParameterExpression<T>

  • Type Parameters:
    T - the type of the parameter expression
    All Superinterfaces:
    Expression<T>, Parameter<T>, Selection<T>, TupleElement<T>

    public interface ParameterExpression<T>
extends Parameter<T>, Expression<T>
    Type of criteria query parameter expressions.
    Since:
    Java Persistence 2.0

    • Method Summary

      • Methods inherited from interface javax.persistence.Parameter

        getName, getParameterType, getPosition

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Path (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface Path<X>

  • Type Parameters:
    X - the type referenced by the path
    All Superinterfaces:
    Expression<X>, Selection<X>, TupleElement<X>
    All Known Subinterfaces:
    CollectionJoin<Z,E>, From<Z,X>, Join<Z,X>, ListJoin<Z,E>, MapJoin<Z,K,V>, PluralJoin<Z,C,E>, Root<X>, SetJoin<Z,E>

    public interface Path<X>
extends Expression<X>
    Represents a simple or compound attribute path from a bound type or collection, and is a "primitive" expression.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <K,V,M extends Map<K,V>>
      Expression<M>             		get(MapAttribute<X,K,V> map)
      Create a path corresponding to the referenced map-valued attribute.
      <E,C extends Collection<E>>
      Expression<C>             		get(PluralAttribute<X,C,E> collection)
      Create a path corresponding to the referenced collection-valued attribute.
      <Y> Path<Y> get(SingularAttribute<? super X,Y> attribute)
      Create a path corresponding to the referenced single-valued attribute.
      <Y> Path<Y> get(String attributeName)
      Create a path corresponding to the referenced attribute.
      Bindable<X> getModel()
      Return the bindable object that corresponds to the path expression.
      Path<?> getParentPath()
      Return the parent "node" in the path or null if no parent.
      Expression<Class<? extends X>> type()
      Create an expression corresponding to the type of the path.

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

    • Method Detail

      • getModel

        Bindable<X> getModel()
        Return the bindable object that corresponds to the path expression.
        Returns:
        bindable object corresponding to the path

      • getParentPath

        Path<?> getParentPath()
        Return the parent "node" in the path or null if no parent.
        Returns:
        parent

      • get

        <Y> Path<Y> get(SingularAttribute<? super X,Y> attribute)
        Create a path corresponding to the referenced single-valued attribute.
        Parameters:
        attribute - single-valued attribute
        Returns:
        path corresponding to the referenced attribute

      • get

        <E,C extends Collection<E>> Expression<C> get(PluralAttribute<X,C,E> collection)
        Create a path corresponding to the referenced collection-valued attribute.
        Parameters:
        collection - collection-valued attribute
        Returns:
        expression corresponding to the referenced attribute

      • get

        <K,V,M extends Map<K,V>> Expression<M> get(MapAttribute<X,K,V> map)
        Create a path corresponding to the referenced map-valued attribute.
        Parameters:
        map - map-valued attribute
        Returns:
        expression corresponding to the referenced attribute

      • type

        Expression<Class<? extends X>> type()
        Create an expression corresponding to the type of the path.
        Returns:
        expression corresponding to the type of the path

      • get

        <Y> Path<Y> get(String attributeName)
        Create a path corresponding to the referenced attribute.

        Note: Applications using the string-based API may need to specify the type resulting from the get operation in order to avoid the use of Path variables.

             For example:

     CriteriaQuery<Person> q = cb.createQuery(Person.class);
     Root<Person> p = q.from(Person.class);
     q.select(p)
      .where(cb.isMember("joe",
                         p.<Set<String>>get("nicknames")));

     rather than:

     CriteriaQuery<Person> q = cb.createQuery(Person.class);
     Root<Person> p = q.from(Person.class);
     Path<Set<String>> nicknames = p.get("nicknames");
     q.select(p)
      .where(cb.isMember("joe", nicknames));
        Parameters:
        attributeName - name of the attribute
        Returns:
        path corresponding to the referenced attribute
        Throws:
        IllegalStateException - if invoked on a path that corresponds to a basic type
        IllegalArgumentException - if attribute of the given name does not otherwise exist
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PluralJoin (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface PluralJoin<Z,C,E>

  • Type Parameters:
    Z - the source type
    C - the collection type
    E - the element type of the collection
    All Superinterfaces:
    Expression<E>, FetchParent<Z,E>, From<Z,E>, Join<Z,E>, Path<E>, Selection<E>, TupleElement<E>
    All Known Subinterfaces:
    CollectionJoin<Z,E>, ListJoin<Z,E>, MapJoin<Z,K,V>, SetJoin<Z,E>

    public interface PluralJoin<Z,C,E>
extends Join<Z,E>
    The PluralJoin interface defines functionality that is common to joins to all collection types. It is not intended to be used directly in query construction.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      PluralAttribute<? super Z,C,E> getModel()
      Return the metamodel representation for the collection-valued attribute corresponding to the join.

      • Methods inherited from interface javax.persistence.criteria.Join

        getAttribute, getJoinType, getOn, getParent, on, on

      • Methods inherited from interface javax.persistence.criteria.From

        getCorrelationParent, getJoins, isCorrelated, join, join, join, join, join, join, join, join, join, join, join, join, joinCollection, joinCollection, joinList, joinList, joinMap, joinMap, joinSet, joinSet

      • Methods inherited from interface javax.persistence.criteria.Path

        get, get, get, get, getParentPath, type

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

      • Methods inherited from interface javax.persistence.criteria.FetchParent

        fetch, fetch, fetch, fetch, fetch, fetch, getFetches

    • Method Detail

      • getModel

        PluralAttribute<? super Z,C,E> getModel()
        Return the metamodel representation for the collection-valued attribute corresponding to the join.
        Specified by:
        getModel in interface Path<E>
        Returns:
        metamodel collection-valued attribute corresponding to the target of the join
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Predicate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface Predicate

  • All Superinterfaces:
    Expression<Boolean>, Selection<Boolean>, TupleElement<Boolean>
    All Known Subinterfaces:
    CriteriaBuilder.In<T>

    public interface Predicate
extends Expression<Boolean>
    The type of a simple or compound predicate: a conjunction or disjunction of restrictions. A simple predicate is considered to be a conjunction with a single conjunct.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Interface and Description
      static class  | Predicate.BooleanOperator

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<Expression<Boolean>> getExpressions()
      Return the top-level conjuncts or disjuncts of the predicate.
      Predicate.BooleanOperator getOperator()
      Return the boolean operator for the predicate.
      boolean isNegated()
      Whether the predicate has been created from another predicate by applying the Predicate.not() method or the CriteriaBuilder.not() method.
      Predicate not()
      Create a negation of the predicate.

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

    • Method Detail

      • getOperator

        Predicate.BooleanOperator getOperator()
        Return the boolean operator for the predicate. If the predicate is simple, this is AND.
        Returns:
        boolean operator for the predicate

      • isNegated

        boolean isNegated()
        Whether the predicate has been created from another predicate by applying the Predicate.not() method or the CriteriaBuilder.not() method.
        Returns:
        boolean indicating if the predicate is a negated predicate

      • getExpressions

        List<Expression<Boolean>> getExpressions()
        Return the top-level conjuncts or disjuncts of the predicate. Returns empty list if there are no top-level conjuncts or disjuncts of the predicate. Modifications to the list do not affect the query.
        Returns:
        list of boolean expressions forming the predicate

      • not

        Predicate not()
        Create a negation of the predicate.
        Returns:
        negated predicate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Predicate.BooleanOperator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence.criteria

Enum Predicate.BooleanOperator

  • java.lang.Object
    • java.lang.Enum<Predicate.BooleanOperator>
      • javax.persistence.criteria.Predicate.BooleanOperator
  • All Implemented Interfaces:
    Serializable, Comparable<Predicate.BooleanOperator>
    Enclosing interface:
    Predicate

    public static enum Predicate.BooleanOperator
extends Enum<Predicate.BooleanOperator>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      AND
      OR

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Predicate.BooleanOperator valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Predicate.BooleanOperator[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • AND

        public static final Predicate.BooleanOperator AND

      • OR

        public static final Predicate.BooleanOperator OR

    • Method Detail

      • values

        public static Predicate.BooleanOperator[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Predicate.BooleanOperator c : Predicate.BooleanOperator.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Predicate.BooleanOperator valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Root (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface Root<X>

  • Type Parameters:
    X - the entity type referenced by the root
    All Superinterfaces:
    Expression<X>, FetchParent<X,X>, From<X,X>, Path<X>, Selection<X>, TupleElement<X>

    public interface Root<X>
extends From<X,X>
    A root type in the from clause. Query roots always reference entities.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EntityType<X> getModel()
      Return the metamodel entity corresponding to the root.

      • Methods inherited from interface javax.persistence.criteria.From

        getCorrelationParent, getJoins, isCorrelated, join, join, join, join, join, join, join, join, join, join, join, join, joinCollection, joinCollection, joinList, joinList, joinMap, joinMap, joinSet, joinSet

      • Methods inherited from interface javax.persistence.criteria.Path

        get, get, get, get, getParentPath, type

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

      • Methods inherited from interface javax.persistence.criteria.FetchParent

        fetch, fetch, fetch, fetch, fetch, fetch, getFetches

    • Method Detail

      • getModel

        EntityType<X> getModel()
        Return the metamodel entity corresponding to the root.
        Specified by:
        getModel in interface Path<X>
        Returns:
        metamodel entity corresponding to the root
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Selection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface Selection<X>

  • Type Parameters:
    X - the type of the selection item
    All Superinterfaces:
    TupleElement<X>
    All Known Subinterfaces:
    CollectionJoin<Z,E>, CompoundSelection<X>, CriteriaBuilder.Case<R>, CriteriaBuilder.Coalesce<T>, CriteriaBuilder.In<T>, CriteriaBuilder.SimpleCase<C,R>, Expression<T>, From<Z,X>, Join<Z,X>, ListJoin<Z,E>, MapJoin<Z,K,V>, ParameterExpression<T>, Path<X>, PluralJoin<Z,C,E>, Predicate, Root<X>, SetJoin<Z,E>, Subquery<T>

    public interface Selection<X>
extends TupleElement<X>
    The Selection interface defines an item that is to be returned in a query result.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Selection<X> alias(String name)
      Assigns an alias to the selection item.
      List<Selection<?>> getCompoundSelectionItems()
      Return the selection items composing a compound selection.
      boolean isCompoundSelection()
      Whether the selection item is a compound selection.

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

    • Method Detail

      • alias

        Selection<X> alias(String name)
        Assigns an alias to the selection item. Once assigned, an alias cannot be changed or reassigned. Returns the same selection item.
        Parameters:
        name - alias
        Returns:
        selection item

      • isCompoundSelection

        boolean isCompoundSelection()
        Whether the selection item is a compound selection.
        Returns:
        boolean indicating whether the selection is a compound selection

      • getCompoundSelectionItems

        List<Selection<?>> getCompoundSelectionItems()
        Return the selection items composing a compound selection. Modifications to the list do not affect the query.
        Returns:
        list of selection items
        Throws:
        IllegalStateException - if selection is not a compound selection
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SetJoin (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface SetJoin<Z,E>

  • Type Parameters:
    Z - the source type of the join
    E - the element type of the target Set
    All Superinterfaces:
    Expression<E>, FetchParent<Z,E>, From<Z,E>, Join<Z,E>, Path<E>, PluralJoin<Z,Set<E>,E>, Selection<E>, TupleElement<E>

    public interface SetJoin<Z,E>
extends PluralJoin<Z,Set<E>,E>
    The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      SetAttribute<? super Z,E> getModel()
      Return the metamodel representation for the set attribute.
      SetJoin<Z,E> on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      SetJoin<Z,E> on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.

      • Methods inherited from interface javax.persistence.criteria.Join

        getAttribute, getJoinType, getOn, getParent

      • Methods inherited from interface javax.persistence.criteria.From

        getCorrelationParent, getJoins, isCorrelated, join, join, join, join, join, join, join, join, join, join, join, join, joinCollection, joinCollection, joinList, joinList, joinMap, joinMap, joinSet, joinSet

      • Methods inherited from interface javax.persistence.criteria.Path

        get, get, get, get, getParentPath, type

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

      • Methods inherited from interface javax.persistence.criteria.FetchParent

        fetch, fetch, fetch, fetch, fetch, fetch, getFetches

    • Method Detail

      • on

        SetJoin<Z,E> on(Expression<Boolean> restriction)
        Modify the join to restrict the result according to the specified ON condition and return the join object. Replaces the previous ON condition, if any.
        Specified by:
        on in interface Join<Z,E>
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified join object
        Since:
        Java Persistence 2.1

      • on

        SetJoin<Z,E> on(Predicate... restrictions)
        Modify the join to restrict the result according to the specified ON condition and return the join object. Replaces the previous ON condition, if any.
        Specified by:
        on in interface Join<Z,E>
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified join object
        Since:
        Java Persistence 2.1

      • getModel

        SetAttribute<? super Z,E> getModel()
        Return the metamodel representation for the set attribute.
        Specified by:
        getModel in interface Path<E>
        Specified by:
        getModel in interface PluralJoin<Z,Set<E>,E>
        Returns:
        metamodel type representing the Set that is the target of the join
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Subquery (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.criteria

Interface Subquery<T>

  • Type Parameters:
    T - the type of the selection item.
    All Superinterfaces:
    AbstractQuery<T>, CommonAbstractCriteria, Expression<T>, Selection<T>, TupleElement<T>

    public interface Subquery<T>
extends AbstractQuery<T>, Expression<T>
    The Subquery interface defines functionality that is specific to subqueries. A subquery has an expression as its selection item.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <X,Y> CollectionJoin<X,Y> correlate(CollectionJoin<X,Y> parentCollection)
      Create a subquery collection join object correlated to a collection join object of the enclosing query.
      <X,Y> Join<X,Y> correlate(Join<X,Y> parentJoin)
      Create a subquery join object correlated to a join object of the enclosing query.
      <X,Y> ListJoin<X,Y> correlate(ListJoin<X,Y> parentList)
      Create a subquery list join object correlated to a list join object of the enclosing query.
      <X,K,V> MapJoin<X,K,V> correlate(MapJoin<X,K,V> parentMap)
      Create a subquery map join object correlated to a map join object of the enclosing query.
      <Y> Root<Y> correlate(Root<Y> parentRoot)
      Create a subquery root correlated to a root of the enclosing query.
      <X,Y> SetJoin<X,Y> correlate(SetJoin<X,Y> parentSet)
      Create a subquery set join object correlated to a set join object of the enclosing query.
      Subquery<T> distinct(boolean distinct)
      Specify whether duplicate query results will be eliminated.
      CommonAbstractCriteria getContainingQuery()
      Return the query of which this is a subquery.
      Set<Join<?,?>> getCorrelatedJoins()
      Return the correlated joins of the subquery.
      AbstractQuery<?> getParent()
      Return the query of which this is a subquery.
      Expression<T> getSelection()
      Return the selection expression.
      Subquery<T> groupBy(Expression<?>... grouping)
      Specify the expressions that are used to form groups over the subquery results.
      Subquery<T> groupBy(List<Expression<?>> grouping)
      Specify the expressions that are used to form groups over the subquery results.
      Subquery<T> having(Expression<Boolean> restriction)
      Specify a restriction over the groups of the subquery.
      Subquery<T> having(Predicate... restrictions)
      Specify restrictions over the groups of the subquery according the conjunction of the specified restriction predicates.
      Subquery<T> select(Expression<T> expression)
      Specify the item that is to be returned as the subquery result.
      Subquery<T> where(Expression<Boolean> restriction)
      Modify the subquery to restrict the result according to the specified boolean expression.
      Subquery<T> where(Predicate... restrictions)
      Modify the subquery to restrict the result according to the conjunction of the specified restriction predicates.

      • Methods inherited from interface javax.persistence.criteria.AbstractQuery

        from, from, getGroupList, getGroupRestriction, getResultType, getRoots, isDistinct

      • Methods inherited from interface javax.persistence.criteria.CommonAbstractCriteria

        getRestriction, subquery

      • Methods inherited from interface javax.persistence.criteria.Expression

        as, in, in, in, in, isNotNull, isNull

      • Methods inherited from interface javax.persistence.criteria.Selection

        alias, getCompoundSelectionItems, isCompoundSelection

      • Methods inherited from interface javax.persistence.TupleElement

        getAlias, getJavaType

    • Method Detail

      • select

        Subquery<T> select(Expression<T> expression)
        Specify the item that is to be returned as the subquery result. Replaces the previously specified selection, if any.
        Parameters:
        expression - expression specifying the item that is to be returned as the subquery result
        Returns:
        the modified subquery

      • where

        Subquery<T> where(Expression<Boolean> restriction)
        Modify the subquery to restrict the result according to the specified boolean expression. Replaces the previously added restriction(s), if any. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        where in interface AbstractQuery<T>
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified subquery

      • where

        Subquery<T> where(Predicate... restrictions)
        Modify the subquery to restrict the result according to the conjunction of the specified restriction predicates. Replaces the previously added restriction(s), if any. If no restrictions are specified, any previously added restrictions are simply removed. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        where in interface AbstractQuery<T>
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified subquery

      • groupBy

        Subquery<T> groupBy(Expression<?>... grouping)
        Specify the expressions that are used to form groups over the subquery results. Replaces the previous specified grouping expressions, if any. If no grouping expressions are specified, any previously added grouping expressions are simply removed. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        groupBy in interface AbstractQuery<T>
        Parameters:
        grouping - zero or more grouping expressions
        Returns:
        the modified subquery

      • groupBy

        Subquery<T> groupBy(List<Expression<?>> grouping)
        Specify the expressions that are used to form groups over the subquery results. Replaces the previous specified grouping expressions, if any. If no grouping expressions are specified, any previously added grouping expressions are simply removed. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        groupBy in interface AbstractQuery<T>
        Parameters:
        grouping - list of zero or more grouping expressions
        Returns:
        the modified subquery

      • having

        Subquery<T> having(Expression<Boolean> restriction)
        Specify a restriction over the groups of the subquery. Replaces the previous having restriction(s), if any. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        having in interface AbstractQuery<T>
        Parameters:
        restriction - a simple or compound boolean expression
        Returns:
        the modified subquery

      • having

        Subquery<T> having(Predicate... restrictions)
        Specify restrictions over the groups of the subquery according the conjunction of the specified restriction predicates. Replaces the previously added having restriction(s), if any. If no restrictions are specified, any previously added restrictions are simply removed. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        having in interface AbstractQuery<T>
        Parameters:
        restrictions - zero or more restriction predicates
        Returns:
        the modified subquery

      • distinct

        Subquery<T> distinct(boolean distinct)
        Specify whether duplicate query results will be eliminated. A true value will cause duplicates to be eliminated. A false value will cause duplicates to be retained. If distinct has not been specified, duplicate results must be retained. This method only overrides the return type of the corresponding AbstractQuery method.
        Specified by:
        distinct in interface AbstractQuery<T>
        Parameters:
        distinct - boolean value specifying whether duplicate results must be eliminated from the subquery result or whether they must be retained
        Returns:
        the modified subquery.

      • correlate

        <Y> Root<Y> correlate(Root<Y> parentRoot)
        Create a subquery root correlated to a root of the enclosing query.
        Parameters:
        parentRoot - a root of the containing query
        Returns:
        subquery root

      • correlate

        <X,Y> Join<X,Y> correlate(Join<X,Y> parentJoin)
        Create a subquery join object correlated to a join object of the enclosing query.
        Parameters:
        parentJoin - join object of the containing query
        Returns:
        subquery join

      • correlate

        <X,Y> CollectionJoin<X,Y> correlate(CollectionJoin<X,Y> parentCollection)
        Create a subquery collection join object correlated to a collection join object of the enclosing query.
        Parameters:
        parentCollection - join object of the containing query
        Returns:
        subquery join

      • correlate

        <X,Y> SetJoin<X,Y> correlate(SetJoin<X,Y> parentSet)
        Create a subquery set join object correlated to a set join object of the enclosing query.
        Parameters:
        parentSet - join object of the containing query
        Returns:
        subquery join

      • correlate

        <X,Y> ListJoin<X,Y> correlate(ListJoin<X,Y> parentList)
        Create a subquery list join object correlated to a list join object of the enclosing query.
        Parameters:
        parentList - join object of the containing query
        Returns:
        subquery join

      • correlate

        <X,K,V> MapJoin<X,K,V> correlate(MapJoin<X,K,V> parentMap)
        Create a subquery map join object correlated to a map join object of the enclosing query.
        Parameters:
        parentMap - join object of the containing query
        Returns:
        subquery join

      • getParent

        AbstractQuery<?> getParent()
        Return the query of which this is a subquery. This must be a CriteriaQuery or a Subquery.
        Returns:
        the enclosing query or subquery

      • getContainingQuery

        CommonAbstractCriteria getContainingQuery()
        Return the query of which this is a subquery. This may be a CriteriaQuery, CriteriaUpdate, CriteriaDelete, or a Subquery.
        Returns:
        the enclosing query or subquery
        Since:
        Java Persistence 2.1

      • getSelection

        Expression<T> getSelection()
        Return the selection expression.
        Specified by:
        getSelection in interface AbstractQuery<T>
        Returns:
        the item to be returned in the subquery result

      • getCorrelatedJoins

        Set<Join<?,?>> getCorrelatedJoins()
        Return the correlated joins of the subquery. Returns empty set if the subquery has no correlated joins. Modifications to the set do not affect the query.
        Returns:
        the correlated joins of the subquery
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.persistence.criteria (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.persistence.criteria

  • Packages that use javax.persistence.criteria
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.criteria
    Java Persistence Criteria API
  • Classes in javax.persistence.criteria used by javax.persistence
    Class and Description
    CriteriaBuilder
    Used to construct criteria queries, compound selections, expressions, predicates, orderings.
    CriteriaDelete
    The CriteriaDelete interface defines functionality for performing bulk delete operations using the Criteria API
    CriteriaQuery
    The CriteriaQuery interface defines functionality that is specific to top-level queries.
    CriteriaUpdate
    The CriteriaUpdate interface defines functionality for performing bulk update operations using the Criteria API.
  • Classes in javax.persistence.criteria used by javax.persistence.criteria
    Class and Description
    AbstractQuery
    The AbstractQuery interface defines functionality that is common to both top-level queries and subqueries.
    CollectionJoin
    The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
    CommonAbstractCriteria
    The CommonAbstractCriteria interface defines functionality that is common to both top-level criteria queries and subqueries as well as to update and delete criteria operations.
    CompoundSelection
    The CompoundSelection interface defines a compound selection item (tuple, array, or result of constructor).
    CriteriaBuilder.Case
    Interface used to build general case expressions.
    CriteriaBuilder.Coalesce
    Interface used to build coalesce expressions.
    CriteriaBuilder.In
    Interface used to build in predicates.
    CriteriaBuilder.SimpleCase
    Interface used to build simple case expressions.
    CriteriaBuilder.Trimspec
    Used to specify how strings are trimmed.
    CriteriaDelete
    The CriteriaDelete interface defines functionality for performing bulk delete operations using the Criteria API
    CriteriaQuery
    The CriteriaQuery interface defines functionality that is specific to top-level queries.
    CriteriaUpdate
    The CriteriaUpdate interface defines functionality for performing bulk update operations using the Criteria API.
    Expression
    Type for query expressions.
    Fetch
    Represents a join-fetched association or attribute.
    FetchParent
    Represents an element of the from clause which may function as the parent of Fetches.
    From
    Represents a bound type, usually an entity that appears in the from clause, but may also be an embeddable belonging to an entity in the from clause.
    Join
    A join to an entity, embeddable, or basic type.
    JoinType
    Defines the three types of joins.
    ListJoin
    The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
    MapJoin
    The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
    Order
    An object that defines an ordering over the query results.
    ParameterExpression
    Type of criteria query parameter expressions.
    Path
    Represents a simple or compound attribute path from a bound type or collection, and is a "primitive" expression.
    PluralJoin
    The PluralJoin interface defines functionality that is common to joins to all collection types.
    Predicate
    The type of a simple or compound predicate: a conjunction or disjunction of restrictions.
    Predicate.BooleanOperator
    Root
    A root type in the from clause.
    Selection
    The Selection interface defines an item that is to be returned in a query result.
    SetJoin
    The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
    Subquery
    The Subquery interface defines functionality that is specific to subqueries.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.criteria.CriteriaBuilder.Trimspec (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.criteria.CriteriaBuilder.Trimspec

  • Packages that use CriteriaBuilder.Trimspec
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CriteriaBuilder.Trimspec in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CriteriaBuilder.Trimspec
      Modifier and Type Method and Description
      static CriteriaBuilder.Trimspec CriteriaBuilder.Trimspec.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CriteriaBuilder.Trimspec[] CriteriaBuilder.Trimspec.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.persistence.criteria with parameters of type CriteriaBuilder.Trimspec
      Modifier and Type Method and Description
      Expression<String> CriteriaBuilder.trim(CriteriaBuilder.Trimspec ts, char t, Expression<String> x)
      Create expression to trim character from a string.
      Expression<String> CriteriaBuilder.trim(CriteriaBuilder.Trimspec ts, Expression<Character> t, Expression<String> x)
      Create expression to trim character from a string.
      Expression<String> CriteriaBuilder.trim(CriteriaBuilder.Trimspec ts, Expression<String> x)
      Create expression to trim blanks from a string.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.criteria.JoinType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.criteria.JoinType

  • Packages that use JoinType
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of JoinType in javax.persistence.criteria

      Methods in javax.persistence.criteria that return JoinType
      Modifier and Type Method and Description
      JoinType Join.getJoinType()
      Return the join type.
      JoinType Fetch.getJoinType()
      Return the join type used in the fetch join.
      static JoinType JoinType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JoinType[] JoinType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.persistence.criteria with parameters of type JoinType
      Modifier and Type Method and Description
      <Y> Fetch<X,Y> FetchParent.fetch(PluralAttribute<? super X,?,Y> attribute, JoinType jt)
      Create a fetch join to the specified collection-valued attribute using the given join type.
      <Y> Fetch<X,Y> FetchParent.fetch(SingularAttribute<? super X,Y> attribute, JoinType jt)
      Create a fetch join to the specified single-valued attribute using the given join type.
      <X,Y> Fetch<X,Y> FetchParent.fetch(String attributeName, JoinType jt)
      Create a fetch join to the specified attribute using the given join type.
      <Y> CollectionJoin<X,Y> From.join(CollectionAttribute<? super X,Y> collection, JoinType jt)
      Create a join to the specified Collection-valued attribute using the given join type.
      <Y> ListJoin<X,Y> From.join(ListAttribute<? super X,Y> list, JoinType jt)
      Create a join to the specified List-valued attribute using the given join type.
      <K,V> MapJoin<X,K,V> From.join(MapAttribute<? super X,K,V> map, JoinType jt)
      Create a join to the specified Map-valued attribute using the given join type.
      <Y> SetJoin<X,Y> From.join(SetAttribute<? super X,Y> set, JoinType jt)
      Create a join to the specified Set-valued attribute using the given join type.
      <Y> Join<X,Y> From.join(SingularAttribute<? super X,Y> attribute, JoinType jt)
      Create a join to the specified single-valued attribute using the given join type.
      <X,Y> Join<X,Y> From.join(String attributeName, JoinType jt)
      Create a join to the specified attribute using the given join type.
      <X,Y> CollectionJoin<X,Y> From.joinCollection(String attributeName, JoinType jt)
      Create a join to the specified Collection-valued attribute using the given join type.
      <X,Y> ListJoin<X,Y> From.joinList(String attributeName, JoinType jt)
      Create a join to the specified List-valued attribute using the given join type.
      <X,K,V> MapJoin<X,K,V> From.joinMap(String attributeName, JoinType jt)
      Create a join to the specified Map-valued attribute using the given join type.
      <X,Y> SetJoin<X,Y> From.joinSet(String attributeName, JoinType jt)
      Create a join to the specified Set-valued attribute using the given join type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.criteria.Predicate.BooleanOperator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.criteria.Predicate.BooleanOperator

  • Packages that use Predicate.BooleanOperator
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Predicate.BooleanOperator in javax.persistence.criteria

      Methods in javax.persistence.criteria that return Predicate.BooleanOperator
      Modifier and Type Method and Description
      Predicate.BooleanOperator Predicate.getOperator()
      Return the boolean operator for the predicate.
      static Predicate.BooleanOperator Predicate.BooleanOperator.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Predicate.BooleanOperator[] Predicate.BooleanOperator.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.AbstractQuery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.AbstractQuery

  • Packages that use AbstractQuery
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of AbstractQuery in javax.persistence.criteria

      Subinterfaces of AbstractQuery in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  CriteriaQuery<T>
      The CriteriaQuery interface defines functionality that is specific to top-level queries.
      interface  Subquery<T>
      The Subquery interface defines functionality that is specific to subqueries.
      Methods in javax.persistence.criteria that return AbstractQuery
      Modifier and Type Method and Description
      AbstractQuery<T> AbstractQuery.distinct(boolean distinct)
      Specify whether duplicate query results will be eliminated.
      AbstractQuery<?> Subquery.getParent()
      Return the query of which this is a subquery.
      AbstractQuery<T> AbstractQuery.groupBy(Expression<?>... grouping)
      Specify the expressions that are used to form groups over the query results.
      AbstractQuery<T> AbstractQuery.groupBy(List<Expression<?>> grouping)
      Specify the expressions that are used to form groups over the query results.
      AbstractQuery<T> AbstractQuery.having(Expression<Boolean> restriction)
      Specify a restriction over the groups of the query.
      AbstractQuery<T> AbstractQuery.having(Predicate... restrictions)
      Specify restrictions over the groups of the query according the conjunction of the specified restriction predicates.
      AbstractQuery<T> AbstractQuery.where(Expression<Boolean> restriction)
      Modify the query to restrict the query results according to the specified boolean expression.
      AbstractQuery<T> AbstractQuery.where(Predicate... restrictions)
      Modify the query to restrict the query results according to the conjunction of the specified restriction predicates.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CollectionJoin (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CollectionJoin

  • Packages that use CollectionJoin
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CollectionJoin in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CollectionJoin
      Modifier and Type Method and Description
      <X,Y> CollectionJoin<X,Y> Subquery.correlate(CollectionJoin<X,Y> parentCollection)
      Create a subquery collection join object correlated to a collection join object of the enclosing query.
      <Y> CollectionJoin<X,Y> From.join(CollectionAttribute<? super X,Y> collection)
      Create an inner join to the specified Collection-valued attribute.
      <Y> CollectionJoin<X,Y> From.join(CollectionAttribute<? super X,Y> collection, JoinType jt)
      Create a join to the specified Collection-valued attribute using the given join type.
      <X,Y> CollectionJoin<X,Y> From.joinCollection(String attributeName)
      Create an inner join to the specified Collection-valued attribute.
      <X,Y> CollectionJoin<X,Y> From.joinCollection(String attributeName, JoinType jt)
      Create a join to the specified Collection-valued attribute using the given join type.
      CollectionJoin<Z,E> CollectionJoin.on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      CollectionJoin<Z,E> CollectionJoin.on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      <X,T,E extends T>
      CollectionJoin<X,E>             		CriteriaBuilder.treat(CollectionJoin<X,T> join, Class<E> type)
      Downcast CollectionJoin object to the specified type.
      Methods in javax.persistence.criteria with parameters of type CollectionJoin
      Modifier and Type Method and Description
      <X,Y> CollectionJoin<X,Y> Subquery.correlate(CollectionJoin<X,Y> parentCollection)
      Create a subquery collection join object correlated to a collection join object of the enclosing query.
      <X,T,E extends T>
      CollectionJoin<X,E>             		CriteriaBuilder.treat(CollectionJoin<X,T> join, Class<E> type)
      Downcast CollectionJoin object to the specified type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CommonAbstractCriteria (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CommonAbstractCriteria

  • Packages that use CommonAbstractCriteria
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CommonAbstractCriteria in javax.persistence.criteria

      Subinterfaces of CommonAbstractCriteria in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  AbstractQuery<T>
      The AbstractQuery interface defines functionality that is common to both top-level queries and subqueries.
      interface  CriteriaDelete<T>
      The CriteriaDelete interface defines functionality for performing bulk delete operations using the Criteria API
      interface  CriteriaQuery<T>
      The CriteriaQuery interface defines functionality that is specific to top-level queries.
      interface  CriteriaUpdate<T>
      The CriteriaUpdate interface defines functionality for performing bulk update operations using the Criteria API.
      interface  Subquery<T>
      The Subquery interface defines functionality that is specific to subqueries.
      Methods in javax.persistence.criteria that return CommonAbstractCriteria
      Modifier and Type Method and Description
      CommonAbstractCriteria Subquery.getContainingQuery()
      Return the query of which this is a subquery.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CompoundSelection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CompoundSelection

  • Packages that use CompoundSelection
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CompoundSelection in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CompoundSelection
      Modifier and Type Method and Description
      CompoundSelection<Object[]> CriteriaBuilder.array(Selection<?>... selections)
      Create an array-valued selection item.
      <Y> CompoundSelection<Y> CriteriaBuilder.construct(Class<Y> resultClass, Selection<?>... selections)
      Create a selection item corresponding to a constructor.
      CompoundSelection<Tuple> CriteriaBuilder.tuple(Selection<?>... selections)
      Create a tuple-valued selection item.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CriteriaBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CriteriaBuilder

  • Packages that use CriteriaBuilder
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of CriteriaBuilder in javax.persistence

      Methods in javax.persistence that return CriteriaBuilder
      Modifier and Type Method and Description
      CriteriaBuilder EntityManagerFactory.getCriteriaBuilder()
      Return an instance of CriteriaBuilder for the creation of CriteriaQuery objects.
      CriteriaBuilder EntityManager.getCriteriaBuilder()
      Return an instance of CriteriaBuilder for the creation of CriteriaQuery objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CriteriaBuilder.Case (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CriteriaBuilder.Case

  • Packages that use CriteriaBuilder.Case
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CriteriaBuilder.Case in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CriteriaBuilder.Case
      Modifier and Type Method and Description
      <R> CriteriaBuilder.Case<R> CriteriaBuilder.selectCase()
      Create a general case expression.
      CriteriaBuilder.Case<R> CriteriaBuilder.Case.when(Expression<Boolean> condition, Expression<? extends R> result)
      Add a when/then clause to the case expression.
      CriteriaBuilder.Case<R> CriteriaBuilder.Case.when(Expression<Boolean> condition, R result)
      Add a when/then clause to the case expression.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CriteriaBuilder.Coalesce (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CriteriaBuilder.Coalesce

  • Packages that use CriteriaBuilder.Coalesce
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CriteriaBuilder.Coalesce in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CriteriaBuilder.Coalesce
      Modifier and Type Method and Description
      <T> CriteriaBuilder.Coalesce<T> CriteriaBuilder.coalesce()
      Create a coalesce expression.
      CriteriaBuilder.Coalesce<T> CriteriaBuilder.Coalesce.value(Expression<? extends T> value)
      Add an argument to the coalesce expression.
      CriteriaBuilder.Coalesce<T> CriteriaBuilder.Coalesce.value(T value)
      Add an argument to the coalesce expression.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CriteriaBuilder.In (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CriteriaBuilder.In

  • Packages that use CriteriaBuilder.In
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CriteriaBuilder.In in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CriteriaBuilder.In
      Modifier and Type Method and Description
      <T> CriteriaBuilder.In<T> CriteriaBuilder.in(Expression<? extends T> expression)
      Create predicate to test whether given expression is contained in a list of values.
      CriteriaBuilder.In<T> CriteriaBuilder.In.value(Expression<? extends T> value)
      Add to list of values to be tested against.
      CriteriaBuilder.In<T> CriteriaBuilder.In.value(T value)
      Add to list of values to be tested against.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CriteriaBuilder.SimpleCase (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CriteriaBuilder.SimpleCase

  • Packages that use CriteriaBuilder.SimpleCase
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CriteriaBuilder.SimpleCase in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CriteriaBuilder.SimpleCase
      Modifier and Type Method and Description
      <C,R> CriteriaBuilder.SimpleCase<C,R> CriteriaBuilder.selectCase(Expression<? extends C> expression)
      Create a simple case expression.
      CriteriaBuilder.SimpleCase<C,R> CriteriaBuilder.SimpleCase.when(C condition, Expression<? extends R> result)
      Add a when/then clause to the case expression.
      CriteriaBuilder.SimpleCase<C,R> CriteriaBuilder.SimpleCase.when(C condition, R result)
      Add a when/then clause to the case expression.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CriteriaDelete (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CriteriaDelete

  • Packages that use CriteriaDelete
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CriteriaDelete in javax.persistence

      Methods in javax.persistence with parameters of type CriteriaDelete
      Modifier and Type Method and Description
      Query EntityManager.createQuery(CriteriaDelete deleteQuery)
      Create an instance of Query for executing a criteria delete query.

    • Uses of CriteriaDelete in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CriteriaDelete
      Modifier and Type Method and Description
      <T> CriteriaDelete<T> CriteriaBuilder.createCriteriaDelete(Class<T> targetEntity)
      Create a CriteriaDelete query object to perform a bulk delete operation.
      CriteriaDelete<T> CriteriaDelete.where(Expression<Boolean> restriction)
      Modify the delete query to restrict the target of the deletion according to the specified boolean expression.
      CriteriaDelete<T> CriteriaDelete.where(Predicate... restrictions)
      Modify the delete query to restrict the target of the deletion according to the conjunction of the specified restriction predicates.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CriteriaQuery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CriteriaQuery

  • Packages that use CriteriaQuery
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CriteriaQuery in javax.persistence

      Methods in javax.persistence with parameters of type CriteriaQuery
      Modifier and Type Method and Description
      <T> TypedQuery<T> EntityManager.createQuery(CriteriaQuery<T> criteriaQuery)
      Create an instance of TypedQuery for executing a criteria query.

    • Uses of CriteriaQuery in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CriteriaQuery
      Modifier and Type Method and Description
      CriteriaQuery<Object> CriteriaBuilder.createQuery()
      Create a CriteriaQuery object.
      <T> CriteriaQuery<T> CriteriaBuilder.createQuery(Class<T> resultClass)
      Create a CriteriaQuery object with the specified result type.
      CriteriaQuery<Tuple> CriteriaBuilder.createTupleQuery()
      Create a CriteriaQuery object that returns a tuple of objects as its result.
      CriteriaQuery<T> CriteriaQuery.distinct(boolean distinct)
      Specify whether duplicate query results will be eliminated.
      CriteriaQuery<T> CriteriaQuery.groupBy(Expression<?>... grouping)
      Specify the expressions that are used to form groups over the query results.
      CriteriaQuery<T> CriteriaQuery.groupBy(List<Expression<?>> grouping)
      Specify the expressions that are used to form groups over the query results.
      CriteriaQuery<T> CriteriaQuery.having(Expression<Boolean> restriction)
      Specify a restriction over the groups of the query.
      CriteriaQuery<T> CriteriaQuery.having(Predicate... restrictions)
      Specify restrictions over the groups of the query according the conjunction of the specified restriction predicates.
      CriteriaQuery<T> CriteriaQuery.multiselect(List<Selection<?>> selectionList)
      Specify the selection items that are to be returned in the query result.
      CriteriaQuery<T> CriteriaQuery.multiselect(Selection<?>... selections)
      Specify the selection items that are to be returned in the query result.
      CriteriaQuery<T> CriteriaQuery.orderBy(List<Order> o)
      Specify the ordering expressions that are used to order the query results.
      CriteriaQuery<T> CriteriaQuery.orderBy(Order... o)
      Specify the ordering expressions that are used to order the query results.
      CriteriaQuery<T> CriteriaQuery.select(Selection<? extends T> selection)
      Specify the item that is to be returned in the query result.
      CriteriaQuery<T> CriteriaQuery.where(Expression<Boolean> restriction)
      Modify the query to restrict the query result according to the specified boolean expression.
      CriteriaQuery<T> CriteriaQuery.where(Predicate... restrictions)
      Modify the query to restrict the query result according to the conjunction of the specified restriction predicates.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.CriteriaUpdate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.CriteriaUpdate

  • Packages that use CriteriaUpdate
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of CriteriaUpdate in javax.persistence

      Methods in javax.persistence with parameters of type CriteriaUpdate
      Modifier and Type Method and Description
      Query EntityManager.createQuery(CriteriaUpdate updateQuery)
      Create an instance of Query for executing a criteria update query.

    • Uses of CriteriaUpdate in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CriteriaUpdate
      Modifier and Type Method and Description
      <T> CriteriaUpdate<T> CriteriaBuilder.createCriteriaUpdate(Class<T> targetEntity)
      Create a CriteriaUpdate query object to perform a bulk update operation.
      <Y> CriteriaUpdate<T> CriteriaUpdate.set(Path<Y> attribute, Expression<? extends Y> value)
      Update the value of the specified attribute.
      <Y,X extends Y>
      CriteriaUpdate<T>             		CriteriaUpdate.set(Path<Y> attribute, X value)
      Update the value of the specified attribute.
      <Y> CriteriaUpdate<T> CriteriaUpdate.set(SingularAttribute<? super T,Y> attribute, Expression<? extends Y> value)
      Update the value of the specified attribute.
      <Y,X extends Y>
      CriteriaUpdate<T>             		CriteriaUpdate.set(SingularAttribute<? super T,Y> attribute, X value)
      Update the value of the specified attribute.
      CriteriaUpdate<T> CriteriaUpdate.set(String attributeName, Object value)
      Update the value of the specified attribute.
      CriteriaUpdate<T> CriteriaUpdate.where(Expression<Boolean> restriction)
      Modify the update query to restrict the target of the update according to the specified boolean expression.
      CriteriaUpdate<T> CriteriaUpdate.where(Predicate... restrictions)
      Modify the update query to restrict the target of the update according to the conjunction of the specified restriction predicates.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.Expression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.Expression

  • Packages that use Expression
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Expression in javax.persistence.criteria

      Subinterfaces of Expression in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  CollectionJoin<Z,E>
      The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
      static interface  CriteriaBuilder.Case<R>
      Interface used to build general case expressions.
      static interface  CriteriaBuilder.Coalesce<T>
      Interface used to build coalesce expressions.
      static interface  CriteriaBuilder.In<T>
      Interface used to build in predicates.
      static interface  CriteriaBuilder.SimpleCase<C,R>
      Interface used to build simple case expressions.
      interface  From<Z,X>
      Represents a bound type, usually an entity that appears in the from clause, but may also be an embeddable belonging to an entity in the from clause.
      interface  Join<Z,X>
      A join to an entity, embeddable, or basic type.
      interface  ListJoin<Z,E>
      The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
      interface  MapJoin<Z,K,V>
      The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
      interface  ParameterExpression<T>
      Type of criteria query parameter expressions.
      interface  Path<X>
      Represents a simple or compound attribute path from a bound type or collection, and is a "primitive" expression.
      interface  PluralJoin<Z,C,E>
      The PluralJoin interface defines functionality that is common to joins to all collection types.
      interface  Predicate
      The type of a simple or compound predicate: a conjunction or disjunction of restrictions.
      interface  Root<X>
      A root type in the from clause.
      interface  SetJoin<Z,E>
      The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
      interface  Subquery<T>
      The Subquery interface defines functionality that is specific to subqueries.
      Methods in javax.persistence.criteria that return Expression
      Modifier and Type Method and Description
      <N extends Number>
      Expression<N>             		CriteriaBuilder.abs(Expression<N> x)
      Create an expression that returns the absolute value of its argument.
      <Y> Expression<Y> CriteriaBuilder.all(Subquery<Y> subquery)
      Create an all expression over the subquery results.
      <Y> Expression<Y> CriteriaBuilder.any(Subquery<Y> subquery)
      Create an any expression over the subquery results.
      <X> Expression<X> Expression.as(Class<X> type)
      Perform a typecast upon the expression, returning a new expression object.
      <N extends Number>
      Expression<Double>             		CriteriaBuilder.avg(Expression<N> x)
      Create an aggregate expression applying the avg operation.
      <Y> Expression<Y> CriteriaBuilder.coalesce(Expression<? extends Y> x, Expression<? extends Y> y)
      Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.
      <Y> Expression<Y> CriteriaBuilder.coalesce(Expression<? extends Y> x, Y y)
      Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.
      Expression<String> CriteriaBuilder.concat(Expression<String> x, Expression<String> y)
      Create an expression for string concatenation.
      Expression<String> CriteriaBuilder.concat(Expression<String> x, String y)
      Create an expression for string concatenation.
      Expression<String> CriteriaBuilder.concat(String x, Expression<String> y)
      Create an expression for string concatenation.
      Expression<Long> CriteriaBuilder.count(Expression<?> x)
      Create an aggregate expression applying the count operation.
      Expression<Long> CriteriaBuilder.countDistinct(Expression<?> x)
      Create an aggregate expression applying the count distinct operation.
      Expression<Date> CriteriaBuilder.currentDate()
      Create expression to return current date.
      Expression<Time> CriteriaBuilder.currentTime()
      Create expression to return current time.
      Expression<Timestamp> CriteriaBuilder.currentTimestamp()
      Create expression to return current timestamp.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.diff(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the difference between its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.diff(Expression<? extends N> x, N y)
      Create an expression that returns the difference between its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.diff(N x, Expression<? extends N> y)
      Create an expression that returns the difference between its arguments.
      Expression<Map.Entry<K,V>> MapJoin.entry()
      Create an expression that corresponds to the map entry.
      <T> Expression<T> CriteriaBuilder.function(String name, Class<T> type, Expression<?>... args)
      Create an expression for the execution of a database function.
      <K,V,M extends Map<K,V>>
      Expression<M>             		Path.get(MapAttribute<X,K,V> map)
      Create a path corresponding to the referenced map-valued attribute.
      <E,C extends Collection<E>>
      Expression<C>             		Path.get(PluralAttribute<X,C,E> collection)
      Create a path corresponding to the referenced collection-valued attribute.
      Expression<?> Order.getExpression()
      Return the expression that is used for ordering.
      Expression<T> CriteriaBuilder.In.getExpression()
      Return the expression to be tested against the list of values.
      Expression<C> CriteriaBuilder.SimpleCase.getExpression()
      Return the expression to be tested against the conditions.
      Expression<T> Subquery.getSelection()
      Return the selection expression.
      <X extends Comparable<? super X>>
      Expression<X>             		CriteriaBuilder.greatest(Expression<X> x)
      Create an aggregate expression for finding the greatest of the values (strings, dates, etc).
      Expression<Integer> ListJoin.index()
      Create an expression that corresponds to the index of the object in the referenced association or element collection.
      <K,M extends Map<K,?>>
      Expression<Set<K>>             		CriteriaBuilder.keys(M map)
      Create an expression that returns the keys of a map.
      <X extends Comparable<? super X>>
      Expression<X>             		CriteriaBuilder.least(Expression<X> x)
      Create an aggregate expression for finding the least of the values (strings, dates, etc).
      Expression<Integer> CriteriaBuilder.length(Expression<String> x)
      Create expression to return length of a string.
      <T> Expression<T> CriteriaBuilder.literal(T value)
      Create an expression for a literal.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, Expression<String> pattern)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, Expression<String> pattern, Expression<Integer> from)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, String pattern)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, String pattern, int from)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<String> CriteriaBuilder.lower(Expression<String> x)
      Create expression for converting a string to lowercase.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.max(Expression<N> x)
      Create an aggregate expression applying the numerical max operation.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.min(Expression<N> x)
      Create an aggregate expression applying the numerical min operation.
      Expression<Integer> CriteriaBuilder.mod(Expression<Integer> x, Expression<Integer> y)
      Create an expression that returns the modulus of its arguments.
      Expression<Integer> CriteriaBuilder.mod(Expression<Integer> x, Integer y)
      Create an expression that returns the modulus of its arguments.
      Expression<Integer> CriteriaBuilder.mod(Integer x, Expression<Integer> y)
      Create an expression that returns the modulus of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.neg(Expression<N> x)
      Create an expression that returns the arithmetic negation of its argument.
      <Y> Expression<Y> CriteriaBuilder.nullif(Expression<Y> x, Expression<?> y)
      Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.
      <Y> Expression<Y> CriteriaBuilder.nullif(Expression<Y> x, Y y)
      Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.
      <T> Expression<T> CriteriaBuilder.nullLiteral(Class<T> resultClass)
      Create an expression for a null literal with the given type.
      Expression<R> CriteriaBuilder.SimpleCase.otherwise(Expression<? extends R> result)
      Add an "else" clause to the case expression.
      Expression<R> CriteriaBuilder.Case.otherwise(Expression<? extends R> result)
      Add an "else" clause to the case expression.
      Expression<R> CriteriaBuilder.SimpleCase.otherwise(R result)
      Add an "else" clause to the case expression.
      Expression<R> CriteriaBuilder.Case.otherwise(R result)
      Add an "else" clause to the case expression.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.prod(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the product of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.prod(Expression<? extends N> x, N y)
      Create an expression that returns the product of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.prod(N x, Expression<? extends N> y)
      Create an expression that returns the product of its arguments.
      Expression<Number> CriteriaBuilder.quot(Expression<? extends Number> x, Expression<? extends Number> y)
      Create an expression that returns the quotient of its arguments.
      Expression<Number> CriteriaBuilder.quot(Expression<? extends Number> x, Number y)
      Create an expression that returns the quotient of its arguments.
      Expression<Number> CriteriaBuilder.quot(Number x, Expression<? extends Number> y)
      Create an expression that returns the quotient of its arguments.
      <C extends Collection<?>>
      Expression<Integer>             		CriteriaBuilder.size(C collection)
      Create an expression that tests the size of a collection.
      <C extends Collection<?>>
      Expression<Integer>             		CriteriaBuilder.size(Expression<C> collection)
      Create an expression that tests the size of a collection.
      <Y> Expression<Y> CriteriaBuilder.some(Subquery<Y> subquery)
      Create a some expression over the subquery results.
      Expression<Double> CriteriaBuilder.sqrt(Expression<? extends Number> x)
      Create an expression that returns the square root of its argument.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, Expression<Integer> from)
      Create an expression for substring extraction.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, Expression<Integer> from, Expression<Integer> len)
      Create an expression for substring extraction.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, int from)
      Create an expression for substring extraction.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, int from, int len)
      Create an expression for substring extraction.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.sum(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the sum of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.sum(Expression<? extends N> x, N y)
      Create an expression that returns the sum of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.sum(Expression<N> x)
      Create an aggregate expression applying the sum operation.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.sum(N x, Expression<? extends N> y)
      Create an expression that returns the sum of its arguments.
      Expression<Double> CriteriaBuilder.sumAsDouble(Expression<Float> x)
      Create an aggregate expression applying the sum operation to a Float-valued expression, returning a Double result.
      Expression<Long> CriteriaBuilder.sumAsLong(Expression<Integer> x)
      Create an aggregate expression applying the sum operation to an Integer-valued expression, returning a Long result.
      Expression<BigDecimal> CriteriaBuilder.toBigDecimal(Expression<? extends Number> number)
      Typecast.
      Expression<BigInteger> CriteriaBuilder.toBigInteger(Expression<? extends Number> number)
      Typecast.
      Expression<Double> CriteriaBuilder.toDouble(Expression<? extends Number> number)
      Typecast.
      Expression<Float> CriteriaBuilder.toFloat(Expression<? extends Number> number)
      Typecast.
      Expression<Integer> CriteriaBuilder.toInteger(Expression<? extends Number> number)
      Typecast.
      Expression<Long> CriteriaBuilder.toLong(Expression<? extends Number> number)
      Typecast.
      Expression<String> CriteriaBuilder.toString(Expression<Character> character)
      Typecast.
      Expression<String> CriteriaBuilder.trim(char t, Expression<String> x)
      Create expression to trim character from both ends of a string.
      Expression<String> CriteriaBuilder.trim(CriteriaBuilder.Trimspec ts, char t, Expression<String> x)
      Create expression to trim character from a string.
      Expression<String> CriteriaBuilder.trim(CriteriaBuilder.Trimspec ts, Expression<Character> t, Expression<String> x)
      Create expression to trim character from a string.
      Expression<String> CriteriaBuilder.trim(CriteriaBuilder.Trimspec ts, Expression<String> x)
      Create expression to trim blanks from a string.
      Expression<String> CriteriaBuilder.trim(Expression<Character> t, Expression<String> x)
      Create expression to trim character from both ends of a string.
      Expression<String> CriteriaBuilder.trim(Expression<String> x)
      Create expression to trim blanks from both ends of a string.
      Expression<Class<? extends X>> Path.type()
      Create an expression corresponding to the type of the path.
      Expression<String> CriteriaBuilder.upper(Expression<String> x)
      Create expression for converting a string to uppercase.
      <V,M extends Map<?,V>>
      Expression<Collection<V>>             		CriteriaBuilder.values(M map)
      Create an expression that returns the values of a map.
      Methods in javax.persistence.criteria that return types with arguments of type Expression
      Modifier and Type Method and Description
      List<Expression<Boolean>> Predicate.getExpressions()
      Return the top-level conjuncts or disjuncts of the predicate.
      List<Expression<?>> AbstractQuery.getGroupList()
      Return a list of the grouping expressions.
      Methods in javax.persistence.criteria with parameters of type Expression
      Modifier and Type Method and Description
      <N extends Number>
      Expression<N>             		CriteriaBuilder.abs(Expression<N> x)
      Create an expression that returns the absolute value of its argument.
      Predicate CriteriaBuilder.and(Expression<Boolean> x, Expression<Boolean> y)
      Create a conjunction of the given boolean expressions.
      Predicate CriteriaBuilder.and(Expression<Boolean> x, Expression<Boolean> y)
      Create a conjunction of the given boolean expressions.
      Order CriteriaBuilder.asc(Expression<?> x)
      Create an ordering by the ascending value of the expression.
      <N extends Number>
      Expression<Double>             		CriteriaBuilder.avg(Expression<N> x)
      Create an aggregate expression applying the avg operation.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.between(Expression<? extends Y> v, Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is between the second and third arguments in value.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.between(Expression<? extends Y> v, Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is between the second and third arguments in value.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.between(Expression<? extends Y> v, Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is between the second and third arguments in value.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.between(Expression<? extends Y> v, Y x, Y y)
      Create a predicate for testing whether the first argument is between the second and third arguments in value.
      <Y> Expression<Y> CriteriaBuilder.coalesce(Expression<? extends Y> x, Expression<? extends Y> y)
      Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.
      <Y> Expression<Y> CriteriaBuilder.coalesce(Expression<? extends Y> x, Expression<? extends Y> y)
      Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.
      <Y> Expression<Y> CriteriaBuilder.coalesce(Expression<? extends Y> x, Y y)
      Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.
      Expression<String> CriteriaBuilder.concat(Expression<String> x, Expression<String> y)
      Create an expression for string concatenation.
      Expression<String> CriteriaBuilder.concat(Expression<String> x, Expression<String> y)
      Create an expression for string concatenation.
      Expression<String> CriteriaBuilder.concat(Expression<String> x, String y)
      Create an expression for string concatenation.
      Expression<String> CriteriaBuilder.concat(String x, Expression<String> y)
      Create an expression for string concatenation.
      Expression<Long> CriteriaBuilder.count(Expression<?> x)
      Create an aggregate expression applying the count operation.
      Expression<Long> CriteriaBuilder.countDistinct(Expression<?> x)
      Create an aggregate expression applying the count distinct operation.
      Order CriteriaBuilder.desc(Expression<?> x)
      Create an ordering by the descending value of the expression.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.diff(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the difference between its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.diff(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the difference between its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.diff(Expression<? extends N> x, N y)
      Create an expression that returns the difference between its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.diff(N x, Expression<? extends N> y)
      Create an expression that returns the difference between its arguments.
      Predicate CriteriaBuilder.equal(Expression<?> x, Expression<?> y)
      Create a predicate for testing the arguments for equality.
      Predicate CriteriaBuilder.equal(Expression<?> x, Expression<?> y)
      Create a predicate for testing the arguments for equality.
      Predicate CriteriaBuilder.equal(Expression<?> x, Object y)
      Create a predicate for testing the arguments for equality.
      <T> Expression<T> CriteriaBuilder.function(String name, Class<T> type, Expression<?>... args)
      Create an expression for the execution of a database function.
      Predicate CriteriaBuilder.ge(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      Predicate CriteriaBuilder.ge(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      Predicate CriteriaBuilder.ge(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.greaterThan(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is greater than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.greaterThan(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is greater than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.greaterThan(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is greater than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.greaterThanOrEqualTo(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.greaterThanOrEqualTo(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.greaterThanOrEqualTo(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      <X extends Comparable<? super X>>
      Expression<X>             		CriteriaBuilder.greatest(Expression<X> x)
      Create an aggregate expression for finding the greatest of the values (strings, dates, etc).
      Subquery<T> Subquery.groupBy(Expression<?>... grouping)
      Specify the expressions that are used to form groups over the subquery results.
      CriteriaQuery<T> CriteriaQuery.groupBy(Expression<?>... grouping)
      Specify the expressions that are used to form groups over the query results.
      AbstractQuery<T> AbstractQuery.groupBy(Expression<?>... grouping)
      Specify the expressions that are used to form groups over the query results.
      Predicate CriteriaBuilder.gt(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is greater than the second.
      Predicate CriteriaBuilder.gt(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is greater than the second.
      Predicate CriteriaBuilder.gt(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is greater than the second.
      Subquery<T> Subquery.having(Expression<Boolean> restriction)
      Specify a restriction over the groups of the subquery.
      CriteriaQuery<T> CriteriaQuery.having(Expression<Boolean> restriction)
      Specify a restriction over the groups of the query.
      AbstractQuery<T> AbstractQuery.having(Expression<Boolean> restriction)
      Specify a restriction over the groups of the query.
      Predicate Expression.in(Expression<?>... values)
      Create a predicate to test whether the expression is a member of the argument list.
      <T> CriteriaBuilder.In<T> CriteriaBuilder.in(Expression<? extends T> expression)
      Create predicate to test whether given expression is contained in a list of values.
      Predicate Expression.in(Expression<Collection<?>> values)
      Create a predicate to test whether the expression is a member of the collection.
      <C extends Collection<?>>
      Predicate             		CriteriaBuilder.isEmpty(Expression<C> collection)
      Create a predicate that tests whether a collection is empty.
      Predicate CriteriaBuilder.isFalse(Expression<Boolean> x)
      Create a predicate testing for a false value.
      <E,C extends Collection<E>>
      Predicate             		CriteriaBuilder.isMember(E elem, Expression<C> collection)
      Create a predicate that tests whether an element is a member of a collection.
      <E,C extends Collection<E>>
      Predicate             		CriteriaBuilder.isMember(Expression<E> elem, Expression<C> collection)
      Create a predicate that tests whether an element is a member of a collection.
      <E,C extends Collection<E>>
      Predicate             		CriteriaBuilder.isMember(Expression<E> elem, Expression<C> collection)
      Create a predicate that tests whether an element is a member of a collection.
      <C extends Collection<?>>
      Predicate             		CriteriaBuilder.isNotEmpty(Expression<C> collection)
      Create a predicate that tests whether a collection is not empty.
      <E,C extends Collection<E>>
      Predicate             		CriteriaBuilder.isNotMember(E elem, Expression<C> collection)
      Create a predicate that tests whether an element is not a member of a collection.
      <E,C extends Collection<E>>
      Predicate             		CriteriaBuilder.isNotMember(Expression<E> elem, Expression<C> collection)
      Create a predicate that tests whether an element is not a member of a collection.
      <E,C extends Collection<E>>
      Predicate             		CriteriaBuilder.isNotMember(Expression<E> elem, Expression<C> collection)
      Create a predicate that tests whether an element is not a member of a collection.
      Predicate CriteriaBuilder.isNotNull(Expression<?> x)
      Create a predicate to test whether the expression is not null.
      Predicate CriteriaBuilder.isNull(Expression<?> x)
      Create a predicate to test whether the expression is null.
      Predicate CriteriaBuilder.isTrue(Expression<Boolean> x)
      Create a predicate testing for a true value.
      Predicate CriteriaBuilder.le(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      Predicate CriteriaBuilder.le(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      Predicate CriteriaBuilder.le(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      <X extends Comparable<? super X>>
      Expression<X>             		CriteriaBuilder.least(Expression<X> x)
      Create an aggregate expression for finding the least of the values (strings, dates, etc).
      Expression<Integer> CriteriaBuilder.length(Expression<String> x)
      Create expression to return length of a string.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.lessThan(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is less than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.lessThan(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is less than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.lessThan(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is less than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.lessThanOrEqualTo(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.lessThanOrEqualTo(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.lessThanOrEqualTo(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      Predicate CriteriaBuilder.like(Expression<String> x, Expression<String> pattern)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, Expression<String> pattern)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, Expression<String> pattern, char escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, Expression<String> pattern, char escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, Expression<String> pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, Expression<String> pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, Expression<String> pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, String pattern)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, String pattern, char escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, String pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, String pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, Expression<String> pattern)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, Expression<String> pattern)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, Expression<String> pattern, Expression<Integer> from)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, Expression<String> pattern, Expression<Integer> from)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, Expression<String> pattern, Expression<Integer> from)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, String pattern)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<Integer> CriteriaBuilder.locate(Expression<String> x, String pattern, int from)
      Create expression to locate the position of one string within another, returning position of first character if found.
      Expression<String> CriteriaBuilder.lower(Expression<String> x)
      Create expression for converting a string to lowercase.
      Predicate CriteriaBuilder.lt(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is less than the second.
      Predicate CriteriaBuilder.lt(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is less than the second.
      Predicate CriteriaBuilder.lt(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is less than the second.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.max(Expression<N> x)
      Create an aggregate expression applying the numerical max operation.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.min(Expression<N> x)
      Create an aggregate expression applying the numerical min operation.
      Expression<Integer> CriteriaBuilder.mod(Expression<Integer> x, Expression<Integer> y)
      Create an expression that returns the modulus of its arguments.
      Expression<Integer> CriteriaBuilder.mod(Expression<Integer> x, Expression<Integer> y)
      Create an expression that returns the modulus of its arguments.
      Expression<Integer> CriteriaBuilder.mod(Expression<Integer> x, Integer y)
      Create an expression that returns the modulus of its arguments.
      Expression<Integer> CriteriaBuilder.mod(Integer x, Expression<Integer> y)
      Create an expression that returns the modulus of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.neg(Expression<N> x)
      Create an expression that returns the arithmetic negation of its argument.
      Predicate CriteriaBuilder.not(Expression<Boolean> restriction)
      Create a negation of the given restriction.
      Predicate CriteriaBuilder.notEqual(Expression<?> x, Expression<?> y)
      Create a predicate for testing the arguments for inequality.
      Predicate CriteriaBuilder.notEqual(Expression<?> x, Expression<?> y)
      Create a predicate for testing the arguments for inequality.
      Predicate CriteriaBuilder.notEqual(Expression<?> x, Object y)
      Create a predicate for testing the arguments for inequality.
      Predicate CriteriaBuilder.notLike(Expression<String> x, Expression<String> pattern)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, Expression<String> pattern)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, Expression<String> pattern, char escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, Expression<String> pattern, char escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, Expression<String> pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, Expression<String> pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, Expression<String> pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, String pattern)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, String pattern, char escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, String pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, String pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      <Y> Expression<Y> CriteriaBuilder.nullif(Expression<Y> x, Expression<?> y)
      Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.
      <Y> Expression<Y> CriteriaBuilder.nullif(Expression<Y> x, Expression<?> y)
      Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.
      <Y> Expression<Y> CriteriaBuilder.nullif(Expression<Y> x, Y y)
      Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.
      SetJoin<Z,E> SetJoin.on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      MapJoin<Z,K,V> MapJoin.on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      ListJoin<Z,E> ListJoin.on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      Join<Z,X> Join.on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      CollectionJoin<Z,E> CollectionJoin.on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      Predicate CriteriaBuilder.or(Expression<Boolean> x, Expression<Boolean> y)
      Create a disjunction of the given boolean expressions.
      Predicate CriteriaBuilder.or(Expression<Boolean> x, Expression<Boolean> y)
      Create a disjunction of the given boolean expressions.
      Expression<R> CriteriaBuilder.SimpleCase.otherwise(Expression<? extends R> result)
      Add an "else" clause to the case expression.
      Expression<R> CriteriaBuilder.Case.otherwise(Expression<? extends R> result)
      Add an "else" clause to the case expression.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.prod(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the product of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.prod(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the product of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.prod(Expression<? extends N> x, N y)
      Create an expression that returns the product of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.prod(N x, Expression<? extends N> y)
      Create an expression that returns the product of its arguments.
      Expression<Number> CriteriaBuilder.quot(Expression<? extends Number> x, Expression<? extends Number> y)
      Create an expression that returns the quotient of its arguments.
      Expression<Number> CriteriaBuilder.quot(Expression<? extends Number> x, Expression<? extends Number> y)
      Create an expression that returns the quotient of its arguments.
      Expression<Number> CriteriaBuilder.quot(Expression<? extends Number> x, Number y)
      Create an expression that returns the quotient of its arguments.
      Expression<Number> CriteriaBuilder.quot(Number x, Expression<? extends Number> y)
      Create an expression that returns the quotient of its arguments.
      Subquery<T> Subquery.select(Expression<T> expression)
      Specify the item that is to be returned as the subquery result.
      <C,R> CriteriaBuilder.SimpleCase<C,R> CriteriaBuilder.selectCase(Expression<? extends C> expression)
      Create a simple case expression.
      <Y> CriteriaUpdate<T> CriteriaUpdate.set(Path<Y> attribute, Expression<? extends Y> value)
      Update the value of the specified attribute.
      <Y> CriteriaUpdate<T> CriteriaUpdate.set(SingularAttribute<? super T,Y> attribute, Expression<? extends Y> value)
      Update the value of the specified attribute.
      <C extends Collection<?>>
      Expression<Integer>             		CriteriaBuilder.size(Expression<C> collection)
      Create an expression that tests the size of a collection.
      Expression<Double> CriteriaBuilder.sqrt(Expression<? extends Number> x)
      Create an expression that returns the square root of its argument.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, Expression<Integer> from)
      Create an expression for substring extraction.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, Expression<Integer> from)
      Create an expression for substring extraction.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, Expression<Integer> from, Expression<Integer> len)
      Create an expression for substring extraction.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, Expression<Integer> from, Expression<Integer> len)
      Create an expression for substring extraction.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, Expression<Integer> from, Expression<Integer> len)
      Create an expression for substring extraction.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, int from)
      Create an expression for substring extraction.
      Expression<String> CriteriaBuilder.substring(Expression<String> x, int from, int len)
      Create an expression for substring extraction.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.sum(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the sum of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.sum(Expression<? extends N> x, Expression<? extends N> y)
      Create an expression that returns the sum of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.sum(Expression<? extends N> x, N y)
      Create an expression that returns the sum of its arguments.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.sum(Expression<N> x)
      Create an aggregate expression applying the sum operation.
      <N extends Number>
      Expression<N>             		CriteriaBuilder.sum(N x, Expression<? extends N> y)
      Create an expression that returns the sum of its arguments.
      Expression<Double> CriteriaBuilder.sumAsDouble(Expression<Float> x)
      Create an aggregate expression applying the sum operation to a Float-valued expression, returning a Double result.
      Expression<Long> CriteriaBuilder.sumAsLong(Expression<Integer> x)
      Create an aggregate expression applying the sum operation to an Integer-valued expression, returning a Long result.
      Expression<BigDecimal> CriteriaBuilder.toBigDecimal(Expression<? extends Number> number)
      Typecast.
      Expression<BigInteger> CriteriaBuilder.toBigInteger(Expression<? extends Number> number)
      Typecast.
      Expression<Double> CriteriaBuilder.toDouble(Expression<? extends Number> number)
      Typecast.
      Expression<Float> CriteriaBuilder.toFloat(Expression<? extends Number> number)
      Typecast.
      Expression<Integer> CriteriaBuilder.toInteger(Expression<? extends Number> number)
      Typecast.
      Expression<Long> CriteriaBuilder.toLong(Expression<? extends Number> number)
      Typecast.
      Expression<String> CriteriaBuilder.toString(Expression<Character> character)
      Typecast.
      Expression<String> CriteriaBuilder.trim(char t, Expression<String> x)
      Create expression to trim character from both ends of a string.
      Expression<String> CriteriaBuilder.trim(CriteriaBuilder.Trimspec ts, char t, Expression<String> x)
      Create expression to trim character from a string.
      Expression<String> CriteriaBuilder.trim(CriteriaBuilder.Trimspec ts, Expression<Character> t, Expression<String> x)
      Create expression to trim character from a string.
      Expression<String> CriteriaBuilder.trim(CriteriaBuilder.Trimspec ts, Expression<Character> t, Expression<String> x)
      Create expression to trim character from a string.
      Expression<String> CriteriaBuilder.trim(CriteriaBuilder.Trimspec ts, Expression<String> x)
      Create expression to trim blanks from a string.
      Expression<String> CriteriaBuilder.trim(Expression<Character> t, Expression<String> x)
      Create expression to trim character from both ends of a string.
      Expression<String> CriteriaBuilder.trim(Expression<Character> t, Expression<String> x)
      Create expression to trim character from both ends of a string.
      Expression<String> CriteriaBuilder.trim(Expression<String> x)
      Create expression to trim blanks from both ends of a string.
      Expression<String> CriteriaBuilder.upper(Expression<String> x)
      Create expression for converting a string to uppercase.
      CriteriaBuilder.In<T> CriteriaBuilder.In.value(Expression<? extends T> value)
      Add to list of values to be tested against.
      CriteriaBuilder.Coalesce<T> CriteriaBuilder.Coalesce.value(Expression<? extends T> value)
      Add an argument to the coalesce expression.
      CriteriaBuilder.SimpleCase<C,R> CriteriaBuilder.SimpleCase.when(C condition, Expression<? extends R> result)
      Add a when/then clause to the case expression.
      CriteriaBuilder.Case<R> CriteriaBuilder.Case.when(Expression<Boolean> condition, Expression<? extends R> result)
      Add a when/then clause to the case expression.
      CriteriaBuilder.Case<R> CriteriaBuilder.Case.when(Expression<Boolean> condition, Expression<? extends R> result)
      Add a when/then clause to the case expression.
      CriteriaBuilder.Case<R> CriteriaBuilder.Case.when(Expression<Boolean> condition, R result)
      Add a when/then clause to the case expression.
      Subquery<T> Subquery.where(Expression<Boolean> restriction)
      Modify the subquery to restrict the result according to the specified boolean expression.
      CriteriaUpdate<T> CriteriaUpdate.where(Expression<Boolean> restriction)
      Modify the update query to restrict the target of the update according to the specified boolean expression.
      CriteriaQuery<T> CriteriaQuery.where(Expression<Boolean> restriction)
      Modify the query to restrict the query result according to the specified boolean expression.
      CriteriaDelete<T> CriteriaDelete.where(Expression<Boolean> restriction)
      Modify the delete query to restrict the target of the deletion according to the specified boolean expression.
      AbstractQuery<T> AbstractQuery.where(Expression<Boolean> restriction)
      Modify the query to restrict the query results according to the specified boolean expression.
      Method parameters in javax.persistence.criteria with type arguments of type Expression
      Modifier and Type Method and Description
      Subquery<T> Subquery.groupBy(List<Expression<?>> grouping)
      Specify the expressions that are used to form groups over the subquery results.
      CriteriaQuery<T> CriteriaQuery.groupBy(List<Expression<?>> grouping)
      Specify the expressions that are used to form groups over the query results.
      AbstractQuery<T> AbstractQuery.groupBy(List<Expression<?>> grouping)
      Specify the expressions that are used to form groups over the query results.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.Fetch (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.Fetch

  • Packages that use Fetch
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Fetch in javax.persistence.criteria

      Methods in javax.persistence.criteria that return Fetch
      Modifier and Type Method and Description
      <Y> Fetch<X,Y> FetchParent.fetch(PluralAttribute<? super X,?,Y> attribute)
      Create a fetch join to the specified collection-valued attribute using an inner join.
      <Y> Fetch<X,Y> FetchParent.fetch(PluralAttribute<? super X,?,Y> attribute, JoinType jt)
      Create a fetch join to the specified collection-valued attribute using the given join type.
      <Y> Fetch<X,Y> FetchParent.fetch(SingularAttribute<? super X,Y> attribute)
      Create a fetch join to the specified single-valued attribute using an inner join.
      <Y> Fetch<X,Y> FetchParent.fetch(SingularAttribute<? super X,Y> attribute, JoinType jt)
      Create a fetch join to the specified single-valued attribute using the given join type.
      <X,Y> Fetch<X,Y> FetchParent.fetch(String attributeName)
      Create a fetch join to the specified attribute using an inner join.
      <X,Y> Fetch<X,Y> FetchParent.fetch(String attributeName, JoinType jt)
      Create a fetch join to the specified attribute using the given join type.
      Methods in javax.persistence.criteria that return types with arguments of type Fetch
      Modifier and Type Method and Description
      Set<Fetch<X,?>> FetchParent.getFetches()
      Return the fetch joins that have been made from this type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.FetchParent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.FetchParent

  • Packages that use FetchParent
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of FetchParent in javax.persistence.criteria

      Subinterfaces of FetchParent in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  CollectionJoin<Z,E>
      The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
      interface  Fetch<Z,X>
      Represents a join-fetched association or attribute.
      interface  From<Z,X>
      Represents a bound type, usually an entity that appears in the from clause, but may also be an embeddable belonging to an entity in the from clause.
      interface  Join<Z,X>
      A join to an entity, embeddable, or basic type.
      interface  ListJoin<Z,E>
      The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
      interface  MapJoin<Z,K,V>
      The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
      interface  PluralJoin<Z,C,E>
      The PluralJoin interface defines functionality that is common to joins to all collection types.
      interface  Root<X>
      A root type in the from clause.
      interface  SetJoin<Z,E>
      The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
      Methods in javax.persistence.criteria that return FetchParent
      Modifier and Type Method and Description
      FetchParent<?,Z> Fetch.getParent()
      Return the parent of the fetched item.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.From (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.From

  • Packages that use From
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of From in javax.persistence.criteria

      Subinterfaces of From in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  CollectionJoin<Z,E>
      The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
      interface  Join<Z,X>
      A join to an entity, embeddable, or basic type.
      interface  ListJoin<Z,E>
      The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
      interface  MapJoin<Z,K,V>
      The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
      interface  PluralJoin<Z,C,E>
      The PluralJoin interface defines functionality that is common to joins to all collection types.
      interface  Root<X>
      A root type in the from clause.
      interface  SetJoin<Z,E>
      The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
      Methods in javax.persistence.criteria that return From
      Modifier and Type Method and Description
      From<Z,X> From.getCorrelationParent()
      Returns the parent From object from which the correlated From object has been obtained through correlation (use of a Subquery correlate method).
      From<?,Z> Join.getParent()
      Return the parent of the join.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.Join (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.Join

  • Packages that use Join
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Join in javax.persistence.criteria

      Subinterfaces of Join in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  CollectionJoin<Z,E>
      The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
      interface  ListJoin<Z,E>
      The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
      interface  MapJoin<Z,K,V>
      The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
      interface  PluralJoin<Z,C,E>
      The PluralJoin interface defines functionality that is common to joins to all collection types.
      interface  SetJoin<Z,E>
      The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
      Methods in javax.persistence.criteria that return Join
      Modifier and Type Method and Description
      <X,Y> Join<X,Y> Subquery.correlate(Join<X,Y> parentJoin)
      Create a subquery join object correlated to a join object of the enclosing query.
      <Y> Join<X,Y> From.join(SingularAttribute<? super X,Y> attribute)
      Create an inner join to the specified single-valued attribute.
      <Y> Join<X,Y> From.join(SingularAttribute<? super X,Y> attribute, JoinType jt)
      Create a join to the specified single-valued attribute using the given join type.
      <X,Y> Join<X,Y> From.join(String attributeName)
      Create an inner join to the specified attribute.
      <X,Y> Join<X,Y> From.join(String attributeName, JoinType jt)
      Create a join to the specified attribute using the given join type.
      Join<Z,X> Join.on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      Join<Z,X> Join.on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      <X,T,V extends T>
      Join<X,V>             		CriteriaBuilder.treat(Join<X,T> join, Class<V> type)
      Downcast Join object to the specified type.
      Methods in javax.persistence.criteria that return types with arguments of type Join
      Modifier and Type Method and Description
      Set<Join<?,?>> Subquery.getCorrelatedJoins()
      Return the correlated joins of the subquery.
      Set<Join<X,?>> From.getJoins()
      Return the joins that have been made from this bound type.
      Methods in javax.persistence.criteria with parameters of type Join
      Modifier and Type Method and Description
      <X,Y> Join<X,Y> Subquery.correlate(Join<X,Y> parentJoin)
      Create a subquery join object correlated to a join object of the enclosing query.
      <X,T,V extends T>
      Join<X,V>             		CriteriaBuilder.treat(Join<X,T> join, Class<V> type)
      Downcast Join object to the specified type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.ListJoin (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.ListJoin

  • Packages that use ListJoin
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of ListJoin in javax.persistence.criteria

      Methods in javax.persistence.criteria that return ListJoin
      Modifier and Type Method and Description
      <X,Y> ListJoin<X,Y> Subquery.correlate(ListJoin<X,Y> parentList)
      Create a subquery list join object correlated to a list join object of the enclosing query.
      <Y> ListJoin<X,Y> From.join(ListAttribute<? super X,Y> list)
      Create an inner join to the specified List-valued attribute.
      <Y> ListJoin<X,Y> From.join(ListAttribute<? super X,Y> list, JoinType jt)
      Create a join to the specified List-valued attribute using the given join type.
      <X,Y> ListJoin<X,Y> From.joinList(String attributeName)
      Create an inner join to the specified List-valued attribute.
      <X,Y> ListJoin<X,Y> From.joinList(String attributeName, JoinType jt)
      Create a join to the specified List-valued attribute using the given join type.
      ListJoin<Z,E> ListJoin.on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      ListJoin<Z,E> ListJoin.on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      <X,T,E extends T>
      ListJoin<X,E>             		CriteriaBuilder.treat(ListJoin<X,T> join, Class<E> type)
      Downcast ListJoin object to the specified type.
      Methods in javax.persistence.criteria with parameters of type ListJoin
      Modifier and Type Method and Description
      <X,Y> ListJoin<X,Y> Subquery.correlate(ListJoin<X,Y> parentList)
      Create a subquery list join object correlated to a list join object of the enclosing query.
      <X,T,E extends T>
      ListJoin<X,E>             		CriteriaBuilder.treat(ListJoin<X,T> join, Class<E> type)
      Downcast ListJoin object to the specified type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.MapJoin (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.MapJoin

  • Packages that use MapJoin
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of MapJoin in javax.persistence.criteria

      Methods in javax.persistence.criteria that return MapJoin
      Modifier and Type Method and Description
      <X,K,V> MapJoin<X,K,V> Subquery.correlate(MapJoin<X,K,V> parentMap)
      Create a subquery map join object correlated to a map join object of the enclosing query.
      <K,V> MapJoin<X,K,V> From.join(MapAttribute<? super X,K,V> map)
      Create an inner join to the specified Map-valued attribute.
      <K,V> MapJoin<X,K,V> From.join(MapAttribute<? super X,K,V> map, JoinType jt)
      Create a join to the specified Map-valued attribute using the given join type.
      <X,K,V> MapJoin<X,K,V> From.joinMap(String attributeName)
      Create an inner join to the specified Map-valued attribute.
      <X,K,V> MapJoin<X,K,V> From.joinMap(String attributeName, JoinType jt)
      Create a join to the specified Map-valued attribute using the given join type.
      MapJoin<Z,K,V> MapJoin.on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      MapJoin<Z,K,V> MapJoin.on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      <X,K,T,V extends T>
      MapJoin<X,K,V>             		CriteriaBuilder.treat(MapJoin<X,K,T> join, Class<V> type)
      Downcast MapJoin object to the specified type.
      Methods in javax.persistence.criteria with parameters of type MapJoin
      Modifier and Type Method and Description
      <X,K,V> MapJoin<X,K,V> Subquery.correlate(MapJoin<X,K,V> parentMap)
      Create a subquery map join object correlated to a map join object of the enclosing query.
      <X,K,T,V extends T>
      MapJoin<X,K,V>             		CriteriaBuilder.treat(MapJoin<X,K,T> join, Class<V> type)
      Downcast MapJoin object to the specified type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.Order (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.Order

  • Packages that use Order
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Order in javax.persistence.criteria

      Methods in javax.persistence.criteria that return Order
      Modifier and Type Method and Description
      Order CriteriaBuilder.asc(Expression<?> x)
      Create an ordering by the ascending value of the expression.
      Order CriteriaBuilder.desc(Expression<?> x)
      Create an ordering by the descending value of the expression.
      Order Order.reverse()
      Switch the ordering.
      Methods in javax.persistence.criteria that return types with arguments of type Order
      Modifier and Type Method and Description
      List<Order> CriteriaQuery.getOrderList()
      Return the ordering expressions in order of precedence.
      Methods in javax.persistence.criteria with parameters of type Order
      Modifier and Type Method and Description
      CriteriaQuery<T> CriteriaQuery.orderBy(Order... o)
      Specify the ordering expressions that are used to order the query results.
      Method parameters in javax.persistence.criteria with type arguments of type Order
      Modifier and Type Method and Description
      CriteriaQuery<T> CriteriaQuery.orderBy(List<Order> o)
      Specify the ordering expressions that are used to order the query results.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.ParameterExpression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.ParameterExpression

  • Packages that use ParameterExpression
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of ParameterExpression in javax.persistence.criteria

      Methods in javax.persistence.criteria that return ParameterExpression
      Modifier and Type Method and Description
      <T> ParameterExpression<T> CriteriaBuilder.parameter(Class<T> paramClass)
      Create a parameter expression.
      <T> ParameterExpression<T> CriteriaBuilder.parameter(Class<T> paramClass, String name)
      Create a parameter expression with the given name.
      Methods in javax.persistence.criteria that return types with arguments of type ParameterExpression
      Modifier and Type Method and Description
      Set<ParameterExpression<?>> CriteriaQuery.getParameters()
      Return the parameters of the query.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.Path (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.Path

  • Packages that use Path
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Path in javax.persistence.criteria

      Subinterfaces of Path in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  CollectionJoin<Z,E>
      The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
      interface  From<Z,X>
      Represents a bound type, usually an entity that appears in the from clause, but may also be an embeddable belonging to an entity in the from clause.
      interface  Join<Z,X>
      A join to an entity, embeddable, or basic type.
      interface  ListJoin<Z,E>
      The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
      interface  MapJoin<Z,K,V>
      The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
      interface  PluralJoin<Z,C,E>
      The PluralJoin interface defines functionality that is common to joins to all collection types.
      interface  Root<X>
      A root type in the from clause.
      interface  SetJoin<Z,E>
      The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
      Methods in javax.persistence.criteria that return Path
      Modifier and Type Method and Description
      <Y> Path<Y> Path.get(SingularAttribute<? super X,Y> attribute)
      Create a path corresponding to the referenced single-valued attribute.
      <Y> Path<Y> Path.get(String attributeName)
      Create a path corresponding to the referenced attribute.
      Path<?> Path.getParentPath()
      Return the parent "node" in the path or null if no parent.
      Path<K> MapJoin.key()
      Create a path expression that corresponds to the map key.
      <X,T extends X>
      Path<T>             		CriteriaBuilder.treat(Path<X> path, Class<T> type)
      Downcast Path object to the specified type.
      Path<V> MapJoin.value()
      Create a path expression that corresponds to the map value.
      Methods in javax.persistence.criteria with parameters of type Path
      Modifier and Type Method and Description
      <Y> CriteriaUpdate<T> CriteriaUpdate.set(Path<Y> attribute, Expression<? extends Y> value)
      Update the value of the specified attribute.
      <Y,X extends Y>
      CriteriaUpdate<T>             		CriteriaUpdate.set(Path<Y> attribute, X value)
      Update the value of the specified attribute.
      <X,T extends X>
      Path<T>             		CriteriaBuilder.treat(Path<X> path, Class<T> type)
      Downcast Path object to the specified type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.PluralJoin (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.PluralJoin

  • Packages that use PluralJoin
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of PluralJoin in javax.persistence.criteria

      Subinterfaces of PluralJoin in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  CollectionJoin<Z,E>
      The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
      interface  ListJoin<Z,E>
      The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
      interface  MapJoin<Z,K,V>
      The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
      interface  SetJoin<Z,E>
      The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.Predicate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.Predicate

  • Packages that use Predicate
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Predicate in javax.persistence.criteria

      Subinterfaces of Predicate in javax.persistence.criteria
      Modifier and Type Interface and Description
      static interface  CriteriaBuilder.In<T>
      Interface used to build in predicates.
      Methods in javax.persistence.criteria that return Predicate
      Modifier and Type Method and Description
      Predicate CriteriaBuilder.and(Expression<Boolean> x, Expression<Boolean> y)
      Create a conjunction of the given boolean expressions.
      Predicate CriteriaBuilder.and(Predicate... restrictions)
      Create a conjunction of the given restriction predicates.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.between(Expression<? extends Y> v, Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is between the second and third arguments in value.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.between(Expression<? extends Y> v, Y x, Y y)
      Create a predicate for testing whether the first argument is between the second and third arguments in value.
      Predicate CriteriaBuilder.conjunction()
      Create a conjunction (with zero conjuncts).
      Predicate CriteriaBuilder.disjunction()
      Create a disjunction (with zero disjuncts).
      Predicate CriteriaBuilder.equal(Expression<?> x, Expression<?> y)
      Create a predicate for testing the arguments for equality.
      Predicate CriteriaBuilder.equal(Expression<?> x, Object y)
      Create a predicate for testing the arguments for equality.
      Predicate CriteriaBuilder.exists(Subquery<?> subquery)
      Create a predicate testing the existence of a subquery result.
      Predicate CriteriaBuilder.ge(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      Predicate CriteriaBuilder.ge(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      Predicate AbstractQuery.getGroupRestriction()
      Return the predicate that corresponds to the restriction(s) over the grouping items, or null if no restrictions have been specified.
      Predicate Join.getOn()
      Return the predicate that corresponds to the ON restriction(s) on the join, or null if no ON condition has been specified.
      Predicate CommonAbstractCriteria.getRestriction()
      Return the predicate that corresponds to the where clause restriction(s), or null if no restrictions have been specified.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.greaterThan(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is greater than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.greaterThan(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is greater than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.greaterThanOrEqualTo(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.greaterThanOrEqualTo(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is greater than or equal to the second.
      Predicate CriteriaBuilder.gt(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is greater than the second.
      Predicate CriteriaBuilder.gt(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is greater than the second.
      Predicate Expression.in(Collection<?> values)
      Create a predicate to test whether the expression is a member of the collection.
      Predicate Expression.in(Expression<?>... values)
      Create a predicate to test whether the expression is a member of the argument list.
      Predicate Expression.in(Expression<Collection<?>> values)
      Create a predicate to test whether the expression is a member of the collection.
      Predicate Expression.in(Object... values)
      Create a predicate to test whether the expression is a member of the argument list.
      <C extends Collection<?>>
      Predicate             		CriteriaBuilder.isEmpty(Expression<C> collection)
      Create a predicate that tests whether a collection is empty.
      Predicate CriteriaBuilder.isFalse(Expression<Boolean> x)
      Create a predicate testing for a false value.
      <E,C extends Collection<E>>
      Predicate             		CriteriaBuilder.isMember(E elem, Expression<C> collection)
      Create a predicate that tests whether an element is a member of a collection.
      <E,C extends Collection<E>>
      Predicate             		CriteriaBuilder.isMember(Expression<E> elem, Expression<C> collection)
      Create a predicate that tests whether an element is a member of a collection.
      <C extends Collection<?>>
      Predicate             		CriteriaBuilder.isNotEmpty(Expression<C> collection)
      Create a predicate that tests whether a collection is not empty.
      <E,C extends Collection<E>>
      Predicate             		CriteriaBuilder.isNotMember(E elem, Expression<C> collection)
      Create a predicate that tests whether an element is not a member of a collection.
      <E,C extends Collection<E>>
      Predicate             		CriteriaBuilder.isNotMember(Expression<E> elem, Expression<C> collection)
      Create a predicate that tests whether an element is not a member of a collection.
      Predicate Expression.isNotNull()
      Create a predicate to test whether the expression is not null.
      Predicate CriteriaBuilder.isNotNull(Expression<?> x)
      Create a predicate to test whether the expression is not null.
      Predicate Expression.isNull()
      Create a predicate to test whether the expression is null.
      Predicate CriteriaBuilder.isNull(Expression<?> x)
      Create a predicate to test whether the expression is null.
      Predicate CriteriaBuilder.isTrue(Expression<Boolean> x)
      Create a predicate testing for a true value.
      Predicate CriteriaBuilder.le(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      Predicate CriteriaBuilder.le(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.lessThan(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is less than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.lessThan(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is less than the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.lessThanOrEqualTo(Expression<? extends Y> x, Expression<? extends Y> y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      <Y extends Comparable<? super Y>>
      Predicate             		CriteriaBuilder.lessThanOrEqualTo(Expression<? extends Y> x, Y y)
      Create a predicate for testing whether the first argument is less than or equal to the second.
      Predicate CriteriaBuilder.like(Expression<String> x, Expression<String> pattern)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, Expression<String> pattern, char escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, Expression<String> pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, String pattern)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, String pattern, char escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.like(Expression<String> x, String pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression satisfies the given pattern.
      Predicate CriteriaBuilder.lt(Expression<? extends Number> x, Expression<? extends Number> y)
      Create a predicate for testing whether the first argument is less than the second.
      Predicate CriteriaBuilder.lt(Expression<? extends Number> x, Number y)
      Create a predicate for testing whether the first argument is less than the second.
      Predicate Predicate.not()
      Create a negation of the predicate.
      Predicate CriteriaBuilder.not(Expression<Boolean> restriction)
      Create a negation of the given restriction.
      Predicate CriteriaBuilder.notEqual(Expression<?> x, Expression<?> y)
      Create a predicate for testing the arguments for inequality.
      Predicate CriteriaBuilder.notEqual(Expression<?> x, Object y)
      Create a predicate for testing the arguments for inequality.
      Predicate CriteriaBuilder.notLike(Expression<String> x, Expression<String> pattern)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, Expression<String> pattern, char escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, Expression<String> pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, String pattern)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, String pattern, char escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.notLike(Expression<String> x, String pattern, Expression<Character> escapeChar)
      Create a predicate for testing whether the expression does not satisfy the given pattern.
      Predicate CriteriaBuilder.or(Expression<Boolean> x, Expression<Boolean> y)
      Create a disjunction of the given boolean expressions.
      Predicate CriteriaBuilder.or(Predicate... restrictions)
      Create a disjunction of the given restriction predicates.
      Methods in javax.persistence.criteria with parameters of type Predicate
      Modifier and Type Method and Description
      Predicate CriteriaBuilder.and(Predicate... restrictions)
      Create a conjunction of the given restriction predicates.
      Subquery<T> Subquery.having(Predicate... restrictions)
      Specify restrictions over the groups of the subquery according the conjunction of the specified restriction predicates.
      CriteriaQuery<T> CriteriaQuery.having(Predicate... restrictions)
      Specify restrictions over the groups of the query according the conjunction of the specified restriction predicates.
      AbstractQuery<T> AbstractQuery.having(Predicate... restrictions)
      Specify restrictions over the groups of the query according the conjunction of the specified restriction predicates.
      SetJoin<Z,E> SetJoin.on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      MapJoin<Z,K,V> MapJoin.on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      ListJoin<Z,E> ListJoin.on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      Join<Z,X> Join.on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      CollectionJoin<Z,E> CollectionJoin.on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      Predicate CriteriaBuilder.or(Predicate... restrictions)
      Create a disjunction of the given restriction predicates.
      Subquery<T> Subquery.where(Predicate... restrictions)
      Modify the subquery to restrict the result according to the conjunction of the specified restriction predicates.
      CriteriaUpdate<T> CriteriaUpdate.where(Predicate... restrictions)
      Modify the update query to restrict the target of the update according to the conjunction of the specified restriction predicates.
      CriteriaQuery<T> CriteriaQuery.where(Predicate... restrictions)
      Modify the query to restrict the query result according to the conjunction of the specified restriction predicates.
      CriteriaDelete<T> CriteriaDelete.where(Predicate... restrictions)
      Modify the delete query to restrict the target of the deletion according to the conjunction of the specified restriction predicates.
      AbstractQuery<T> AbstractQuery.where(Predicate... restrictions)
      Modify the query to restrict the query results according to the conjunction of the specified restriction predicates.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.Root (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.Root

  • Packages that use Root
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Root in javax.persistence.criteria

      Methods in javax.persistence.criteria that return Root
      Modifier and Type Method and Description
      <Y> Root<Y> Subquery.correlate(Root<Y> parentRoot)
      Create a subquery root correlated to a root of the enclosing query.
      Root<T> CriteriaUpdate.from(Class<T> entityClass)
      Create and add a query root corresponding to the entity that is the target of the update.
      Root<T> CriteriaDelete.from(Class<T> entityClass)
      Create and add a query root corresponding to the entity that is the target of the delete.
      <X> Root<X> AbstractQuery.from(Class<X> entityClass)
      Create and add a query root corresponding to the given entity, forming a cartesian product with any existing roots.
      Root<T> CriteriaUpdate.from(EntityType<T> entity)
      Create and add a query root corresponding to the entity that is the target of the update.
      Root<T> CriteriaDelete.from(EntityType<T> entity)
      Create and add a query root corresponding to the entity that is the target of the delete.
      <X> Root<X> AbstractQuery.from(EntityType<X> entity)
      Create and add a query root corresponding to the given entity, forming a cartesian product with any existing roots.
      Root<T> CriteriaUpdate.getRoot()
      Return the query root.
      Root<T> CriteriaDelete.getRoot()
      Return the query root.
      <X,T extends X>
      Root<T>             		CriteriaBuilder.treat(Root<X> root, Class<T> type)
      Downcast Root object to the specified type.
      Methods in javax.persistence.criteria that return types with arguments of type Root
      Modifier and Type Method and Description
      Set<Root<?>> AbstractQuery.getRoots()
      Return the query roots.
      Methods in javax.persistence.criteria with parameters of type Root
      Modifier and Type Method and Description
      <Y> Root<Y> Subquery.correlate(Root<Y> parentRoot)
      Create a subquery root correlated to a root of the enclosing query.
      <X,T extends X>
      Root<T>             		CriteriaBuilder.treat(Root<X> root, Class<T> type)
      Downcast Root object to the specified type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.Selection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.Selection

  • Packages that use Selection
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Selection in javax.persistence.criteria

      Subinterfaces of Selection in javax.persistence.criteria
      Modifier and Type Interface and Description
      interface  CollectionJoin<Z,E>
      The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.
      interface  CompoundSelection<X>
      The CompoundSelection interface defines a compound selection item (tuple, array, or result of constructor).
      static interface  CriteriaBuilder.Case<R>
      Interface used to build general case expressions.
      static interface  CriteriaBuilder.Coalesce<T>
      Interface used to build coalesce expressions.
      static interface  CriteriaBuilder.In<T>
      Interface used to build in predicates.
      static interface  CriteriaBuilder.SimpleCase<C,R>
      Interface used to build simple case expressions.
      interface  Expression<T>
      Type for query expressions.
      interface  From<Z,X>
      Represents a bound type, usually an entity that appears in the from clause, but may also be an embeddable belonging to an entity in the from clause.
      interface  Join<Z,X>
      A join to an entity, embeddable, or basic type.
      interface  ListJoin<Z,E>
      The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.
      interface  MapJoin<Z,K,V>
      The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.
      interface  ParameterExpression<T>
      Type of criteria query parameter expressions.
      interface  Path<X>
      Represents a simple or compound attribute path from a bound type or collection, and is a "primitive" expression.
      interface  PluralJoin<Z,C,E>
      The PluralJoin interface defines functionality that is common to joins to all collection types.
      interface  Predicate
      The type of a simple or compound predicate: a conjunction or disjunction of restrictions.
      interface  Root<X>
      A root type in the from clause.
      interface  SetJoin<Z,E>
      The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.
      interface  Subquery<T>
      The Subquery interface defines functionality that is specific to subqueries.
      Methods in javax.persistence.criteria that return Selection
      Modifier and Type Method and Description
      Selection<X> Selection.alias(String name)
      Assigns an alias to the selection item.
      Selection<T> AbstractQuery.getSelection()
      Return the selection of the query, or null if no selection has been set.
      Methods in javax.persistence.criteria that return types with arguments of type Selection
      Modifier and Type Method and Description
      List<Selection<?>> Selection.getCompoundSelectionItems()
      Return the selection items composing a compound selection.
      Methods in javax.persistence.criteria with parameters of type Selection
      Modifier and Type Method and Description
      CompoundSelection<Object[]> CriteriaBuilder.array(Selection<?>... selections)
      Create an array-valued selection item.
      <Y> CompoundSelection<Y> CriteriaBuilder.construct(Class<Y> resultClass, Selection<?>... selections)
      Create a selection item corresponding to a constructor.
      CriteriaQuery<T> CriteriaQuery.multiselect(Selection<?>... selections)
      Specify the selection items that are to be returned in the query result.
      CriteriaQuery<T> CriteriaQuery.select(Selection<? extends T> selection)
      Specify the item that is to be returned in the query result.
      CompoundSelection<Tuple> CriteriaBuilder.tuple(Selection<?>... selections)
      Create a tuple-valued selection item.
      Method parameters in javax.persistence.criteria with type arguments of type Selection
      Modifier and Type Method and Description
      CriteriaQuery<T> CriteriaQuery.multiselect(List<Selection<?>> selectionList)
      Specify the selection items that are to be returned in the query result.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.SetJoin (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.SetJoin

  • Packages that use SetJoin
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of SetJoin in javax.persistence.criteria

      Methods in javax.persistence.criteria that return SetJoin
      Modifier and Type Method and Description
      <X,Y> SetJoin<X,Y> Subquery.correlate(SetJoin<X,Y> parentSet)
      Create a subquery set join object correlated to a set join object of the enclosing query.
      <Y> SetJoin<X,Y> From.join(SetAttribute<? super X,Y> set)
      Create an inner join to the specified Set-valued attribute.
      <Y> SetJoin<X,Y> From.join(SetAttribute<? super X,Y> set, JoinType jt)
      Create a join to the specified Set-valued attribute using the given join type.
      <X,Y> SetJoin<X,Y> From.joinSet(String attributeName)
      Create an inner join to the specified Set-valued attribute.
      <X,Y> SetJoin<X,Y> From.joinSet(String attributeName, JoinType jt)
      Create a join to the specified Set-valued attribute using the given join type.
      SetJoin<Z,E> SetJoin.on(Expression<Boolean> restriction)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      SetJoin<Z,E> SetJoin.on(Predicate... restrictions)
      Modify the join to restrict the result according to the specified ON condition and return the join object.
      <X,T,E extends T>
      SetJoin<X,E>             		CriteriaBuilder.treat(SetJoin<X,T> join, Class<E> type)
      Downcast SetJoin object to the specified type.
      Methods in javax.persistence.criteria with parameters of type SetJoin
      Modifier and Type Method and Description
      <X,Y> SetJoin<X,Y> Subquery.correlate(SetJoin<X,Y> parentSet)
      Create a subquery set join object correlated to a set join object of the enclosing query.
      <X,T,E extends T>
      SetJoin<X,E>             		CriteriaBuilder.treat(SetJoin<X,T> join, Class<E> type)
      Downcast SetJoin object to the specified type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.criteria.Subquery (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.criteria.Subquery

  • Packages that use Subquery
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API

    • Uses of Subquery in javax.persistence.criteria

      Methods in javax.persistence.criteria that return Subquery
      Modifier and Type Method and Description
      Subquery<T> Subquery.distinct(boolean distinct)
      Specify whether duplicate query results will be eliminated.
      Subquery<T> Subquery.groupBy(Expression<?>... grouping)
      Specify the expressions that are used to form groups over the subquery results.
      Subquery<T> Subquery.groupBy(List<Expression<?>> grouping)
      Specify the expressions that are used to form groups over the subquery results.
      Subquery<T> Subquery.having(Expression<Boolean> restriction)
      Specify a restriction over the groups of the subquery.
      Subquery<T> Subquery.having(Predicate... restrictions)
      Specify restrictions over the groups of the subquery according the conjunction of the specified restriction predicates.
      Subquery<T> Subquery.select(Expression<T> expression)
      Specify the item that is to be returned as the subquery result.
      <U> Subquery<U> CommonAbstractCriteria.subquery(Class<U> type)
      Create a subquery of the query.
      Subquery<T> Subquery.where(Expression<Boolean> restriction)
      Modify the subquery to restrict the result according to the specified boolean expression.
      Subquery<T> Subquery.where(Predicate... restrictions)
      Modify the subquery to restrict the result according to the conjunction of the specified restriction predicates.
      Methods in javax.persistence.criteria with parameters of type Subquery
      Modifier and Type Method and Description
      <Y> Expression<Y> CriteriaBuilder.all(Subquery<Y> subquery)
      Create an all expression over the subquery results.
      <Y> Expression<Y> CriteriaBuilder.any(Subquery<Y> subquery)
      Create an any expression over the subquery results.
      Predicate CriteriaBuilder.exists(Subquery<?> subquery)
      Create a predicate testing the existence of a subquery result.
      <Y> Expression<Y> CriteriaBuilder.some(Subquery<Y> subquery)
      Create a some expression over the subquery results.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Attribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface Attribute<X,Y>

  • Type Parameters:
    X - The represented type that contains the attribute
    Y - The type of the represented attribute
    All Known Subinterfaces:
    CollectionAttribute<X,E>, ListAttribute<X,E>, MapAttribute<X,K,V>, PluralAttribute<X,C,E>, SetAttribute<X,E>, SingularAttribute<X,T>

    public interface Attribute<X,Y>
    Represents an attribute of a Java type.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Interface and Description
      static class  | Attribute.PersistentAttributeType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ManagedType<X> getDeclaringType()
      Return the managed type representing the type in which the attribute was declared.
      Member getJavaMember()
      Return the java.lang.reflect.Member for the represented attribute.
      Class<Y> getJavaType()
      Return the Java type of the represented attribute.
      String getName()
      Return the name of the attribute.
      Attribute.PersistentAttributeType getPersistentAttributeType()
      Return the persistent attribute type for the attribute.
      boolean isAssociation()
      Is the attribute an association.
      boolean isCollection()
      Is the attribute collection-valued (represents a Collection, Set, List, or Map).

    • Method Detail

      • getName

        String getName()
        Return the name of the attribute.
        Returns:
        name

      • getPersistentAttributeType

        Attribute.PersistentAttributeType getPersistentAttributeType()
        Return the persistent attribute type for the attribute.
        Returns:
        persistent attribute type

      • getDeclaringType

        ManagedType<X> getDeclaringType()
        Return the managed type representing the type in which the attribute was declared.
        Returns:
        declaring type

      • getJavaType

        Class<Y> getJavaType()
        Return the Java type of the represented attribute.
        Returns:
        Java type

      • getJavaMember

        Member getJavaMember()
        Return the java.lang.reflect.Member for the represented attribute.
        Returns:
        corresponding java.lang.reflect.Member

      • isAssociation

        boolean isAssociation()
        Is the attribute an association.
        Returns:
        boolean indicating whether the attribute corresponds to an association

      • isCollection

        boolean isCollection()
        Is the attribute collection-valued (represents a Collection, Set, List, or Map).
        Returns:
        boolean indicating whether the attribute is collection-valued
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Attribute.PersistentAttributeType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence.metamodel

Enum Attribute.PersistentAttributeType

  • java.lang.Object
    • java.lang.Enum<Attribute.PersistentAttributeType>
      • javax.persistence.metamodel.Attribute.PersistentAttributeType
  • All Implemented Interfaces:
    Serializable, Comparable<Attribute.PersistentAttributeType>
    Enclosing interface:
    Attribute<X,Y>

    public static enum Attribute.PersistentAttributeType
extends Enum<Attribute.PersistentAttributeType>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BASIC
      Basic attribute
      ELEMENT_COLLECTION
      Element collection
      EMBEDDED
      Embeddable class attribute
      MANY_TO_MANY
      Many-to-many association
      MANY_TO_ONE
      Many-to-one association
      ONE_TO_MANY
      One-to-many association
      ONE_TO_ONE
      One-to-one association

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Attribute.PersistentAttributeType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Attribute.PersistentAttributeType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MANY_TO_ONE

        public static final Attribute.PersistentAttributeType MANY_TO_ONE
        Many-to-one association

      • ONE_TO_ONE

        public static final Attribute.PersistentAttributeType ONE_TO_ONE
        One-to-one association

      • BASIC

        public static final Attribute.PersistentAttributeType BASIC
        Basic attribute

      • EMBEDDED

        public static final Attribute.PersistentAttributeType EMBEDDED
        Embeddable class attribute

      • MANY_TO_MANY

        public static final Attribute.PersistentAttributeType MANY_TO_MANY
        Many-to-many association

      • ONE_TO_MANY

        public static final Attribute.PersistentAttributeType ONE_TO_MANY
        One-to-many association

      • ELEMENT_COLLECTION

        public static final Attribute.PersistentAttributeType ELEMENT_COLLECTION
        Element collection

    • Method Detail

      • values

        public static Attribute.PersistentAttributeType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Attribute.PersistentAttributeType c : Attribute.PersistentAttributeType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Attribute.PersistentAttributeType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


BasicType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface BasicType<X>

  • Type Parameters:
    X - The type of the represented basic type
    All Superinterfaces:
    Type<X>

    public interface BasicType<X>
extends Type<X>
    Instances of the type BasicType represent basic types (including temporal and enumerated types).
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Type

        Type.PersistenceType

    • Method Summary

      • Methods inherited from interface javax.persistence.metamodel.Type

        getJavaType, getPersistenceType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Bindable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface Bindable<T>

  • Type Parameters:
    T - The type of the represented object or attribute
    All Known Subinterfaces:
    CollectionAttribute<X,E>, EntityType<X>, ListAttribute<X,E>, MapAttribute<X,K,V>, PluralAttribute<X,C,E>, SetAttribute<X,E>, SingularAttribute<X,T>

    public interface Bindable<T>
    Instances of the type Bindable represent object or attribute types that can be bound into a Path.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Interface and Description
      static class  | Bindable.BindableType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<T> getBindableJavaType()
      Return the Java type of the represented object.
      Bindable.BindableType getBindableType()
      Return the bindable type of the represented object.

    • Method Detail

      • getBindableType

        Bindable.BindableType getBindableType()
        Return the bindable type of the represented object.
        Returns:
        bindable type

      • getBindableJavaType

        Class<T> getBindableJavaType()
        Return the Java type of the represented object. If the bindable type of the object is PLURAL_ATTRIBUTE, the Java element type is returned. If the bindable type is SINGULAR_ATTRIBUTE or ENTITY_TYPE, the Java type of the represented entity or attribute is returned.
        Returns:
        Java type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Bindable.BindableType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence.metamodel

Enum Bindable.BindableType

  • java.lang.Object
    • java.lang.Enum<Bindable.BindableType>
      • javax.persistence.metamodel.Bindable.BindableType
  • All Implemented Interfaces:
    Serializable, Comparable<Bindable.BindableType>
    Enclosing interface:
    Bindable<T>

    public static enum Bindable.BindableType
extends Enum<Bindable.BindableType>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ENTITY_TYPE
      Entity type
      PLURAL_ATTRIBUTE
      Multi-valued attribute type
      SINGULAR_ATTRIBUTE
      Single-valued attribute type

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Bindable.BindableType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Bindable.BindableType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SINGULAR_ATTRIBUTE

        public static final Bindable.BindableType SINGULAR_ATTRIBUTE
        Single-valued attribute type

      • PLURAL_ATTRIBUTE

        public static final Bindable.BindableType PLURAL_ATTRIBUTE
        Multi-valued attribute type

      • ENTITY_TYPE

        public static final Bindable.BindableType ENTITY_TYPE
        Entity type

    • Method Detail

      • values

        public static Bindable.BindableType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Bindable.BindableType c : Bindable.BindableType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Bindable.BindableType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


CollectionAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface CollectionAttribute<X,E>

  • Type Parameters:
    X - The type the represented Collection belongs to
    E - The element type of the represented Collection
    All Superinterfaces:
    Attribute<X,Collection<E>>, Bindable<E>, PluralAttribute<X,Collection<E>,E>

    public interface CollectionAttribute<X,E>
extends PluralAttribute<X,Collection<E>,E>
    Instances of the type CollectionAttribute represent persistent java.util.Collection-valued attributes.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.PluralAttribute

        PluralAttribute.CollectionType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Attribute

        Attribute.PersistentAttributeType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Bindable

        Bindable.BindableType

    • Method Summary

      • Methods inherited from interface javax.persistence.metamodel.PluralAttribute

        getCollectionType, getElementType

      • Methods inherited from interface javax.persistence.metamodel.Attribute

        getDeclaringType, getJavaMember, getJavaType, getName, getPersistentAttributeType, isAssociation, isCollection

      • Methods inherited from interface javax.persistence.metamodel.Bindable

        getBindableJavaType, getBindableType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EmbeddableType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface EmbeddableType<X>

  • Type Parameters:
    X - The represented type.
    All Superinterfaces:
    ManagedType<X>, Type<X>

    public interface EmbeddableType<X>
extends ManagedType<X>
    Instances of the type EmbeddableType represent embeddable types.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Type

        Type.PersistenceType

    • Method Summary

      • Methods inherited from interface javax.persistence.metamodel.ManagedType

        getAttribute, getAttributes, getCollection, getCollection, getDeclaredAttribute, getDeclaredAttributes, getDeclaredCollection, getDeclaredCollection, getDeclaredList, getDeclaredList, getDeclaredMap, getDeclaredMap, getDeclaredPluralAttributes, getDeclaredSet, getDeclaredSet, getDeclaredSingularAttribute, getDeclaredSingularAttribute, getDeclaredSingularAttributes, getList, getList, getMap, getMap, getPluralAttributes, getSet, getSet, getSingularAttribute, getSingularAttribute, getSingularAttributes

      • Methods inherited from interface javax.persistence.metamodel.Type

        getJavaType, getPersistenceType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface EntityType<X>

  • Type Parameters:
    X - The represented entity type.
    All Superinterfaces:
    Bindable<X>, IdentifiableType<X>, ManagedType<X>, Type<X>

    public interface EntityType<X>
extends IdentifiableType<X>, Bindable<X>
    Instances of the type EntityType represent entity types.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Type

        Type.PersistenceType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Bindable

        Bindable.BindableType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Return the entity name.

      • Methods inherited from interface javax.persistence.metamodel.IdentifiableType

        getDeclaredId, getDeclaredVersion, getId, getIdClassAttributes, getIdType, getSupertype, getVersion, hasSingleIdAttribute, hasVersionAttribute

      • Methods inherited from interface javax.persistence.metamodel.ManagedType

        getAttribute, getAttributes, getCollection, getCollection, getDeclaredAttribute, getDeclaredAttributes, getDeclaredCollection, getDeclaredCollection, getDeclaredList, getDeclaredList, getDeclaredMap, getDeclaredMap, getDeclaredPluralAttributes, getDeclaredSet, getDeclaredSet, getDeclaredSingularAttribute, getDeclaredSingularAttribute, getDeclaredSingularAttributes, getList, getList, getMap, getMap, getPluralAttributes, getSet, getSet, getSingularAttribute, getSingularAttribute, getSingularAttributes

      • Methods inherited from interface javax.persistence.metamodel.Type

        getJavaType, getPersistenceType

      • Methods inherited from interface javax.persistence.metamodel.Bindable

        getBindableJavaType, getBindableType

    • Method Detail

      • getName

        String getName()
        Return the entity name.
        Returns:
        entity name
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IdentifiableType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface IdentifiableType<X>

  • Type Parameters:
    X - The represented entity or mapped superclass type.
    All Superinterfaces:
    ManagedType<X>, Type<X>
    All Known Subinterfaces:
    EntityType<X>, MappedSuperclassType<X>

    public interface IdentifiableType<X>
extends ManagedType<X>
    Instances of the type IdentifiableType represent entity or mapped superclass types.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Type

        Type.PersistenceType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <Y> SingularAttribute<X,Y> getDeclaredId(Class<Y> type)
      Return the attribute that corresponds to the id attribute declared by the entity or mapped superclass.
      <Y> SingularAttribute<X,Y> getDeclaredVersion(Class<Y> type)
      Return the attribute that corresponds to the version attribute declared by the entity or mapped superclass.
      <Y> SingularAttribute<? super X,Y> getId(Class<Y> type)
      Return the attribute that corresponds to the id attribute of the entity or mapped superclass.
      Set<SingularAttribute<? super X,?>> getIdClassAttributes()
      Return the attributes corresponding to the id class of the identifiable type.
      Type<?> getIdType()
      Return the type that represents the type of the id.
      IdentifiableType<? super X> getSupertype()
      Return the identifiable type that corresponds to the most specific mapped superclass or entity extended by the entity or mapped superclass.
      <Y> SingularAttribute<? super X,Y> getVersion(Class<Y> type)
      Return the attribute that corresponds to the version attribute of the entity or mapped superclass.
      boolean hasSingleIdAttribute()
      Whether the identifiable type has a single id attribute.
      boolean hasVersionAttribute()
      Whether the identifiable type has a version attribute.

      • Methods inherited from interface javax.persistence.metamodel.ManagedType

        getAttribute, getAttributes, getCollection, getCollection, getDeclaredAttribute, getDeclaredAttributes, getDeclaredCollection, getDeclaredCollection, getDeclaredList, getDeclaredList, getDeclaredMap, getDeclaredMap, getDeclaredPluralAttributes, getDeclaredSet, getDeclaredSet, getDeclaredSingularAttribute, getDeclaredSingularAttribute, getDeclaredSingularAttributes, getList, getList, getMap, getMap, getPluralAttributes, getSet, getSet, getSingularAttribute, getSingularAttribute, getSingularAttributes

      • Methods inherited from interface javax.persistence.metamodel.Type

        getJavaType, getPersistenceType

    • Method Detail

      • getId

        <Y> SingularAttribute<? super X,Y> getId(Class<Y> type)
        Return the attribute that corresponds to the id attribute of the entity or mapped superclass.
        Parameters:
        type - the type of the represented id attribute
        Returns:
        id attribute
        Throws:
        IllegalArgumentException - if id attribute of the given type is not present in the identifiable type or if the identifiable type has an id class

      • getDeclaredId

        <Y> SingularAttribute<X,Y> getDeclaredId(Class<Y> type)
        Return the attribute that corresponds to the id attribute declared by the entity or mapped superclass.
        Parameters:
        type - the type of the represented declared id attribute
        Returns:
        declared id attribute
        Throws:
        IllegalArgumentException - if id attribute of the given type is not declared in the identifiable type or if the identifiable type has an id class

      • getVersion

        <Y> SingularAttribute<? super X,Y> getVersion(Class<Y> type)
        Return the attribute that corresponds to the version attribute of the entity or mapped superclass.
        Parameters:
        type - the type of the represented version attribute
        Returns:
        version attribute
        Throws:
        IllegalArgumentException - if version attribute of the given type is not present in the identifiable type

      • getDeclaredVersion

        <Y> SingularAttribute<X,Y> getDeclaredVersion(Class<Y> type)
        Return the attribute that corresponds to the version attribute declared by the entity or mapped superclass.
        Parameters:
        type - the type of the represented declared version attribute
        Returns:
        declared version attribute
        Throws:
        IllegalArgumentException - if version attribute of the type is not declared in the identifiable type

      • getSupertype

        IdentifiableType<? super X> getSupertype()
        Return the identifiable type that corresponds to the most specific mapped superclass or entity extended by the entity or mapped superclass.
        Returns:
        supertype of identifiable type or null if no such supertype

      • hasSingleIdAttribute

        boolean hasSingleIdAttribute()
        Whether the identifiable type has a single id attribute. Returns true for a simple id or embedded id; returns false for an idclass.
        Returns:
        boolean indicating whether the identifiable type has a single id attribute

      • hasVersionAttribute

        boolean hasVersionAttribute()
        Whether the identifiable type has a version attribute.
        Returns:
        boolean indicating whether the identifiable type has a version attribute

      • getIdClassAttributes

        Set<SingularAttribute<? super X,?>> getIdClassAttributes()
        Return the attributes corresponding to the id class of the identifiable type.
        Returns:
        id attributes
        Throws:
        IllegalArgumentException - if the identifiable type does not have an id class

      • getIdType

        Type<?> getIdType()
        Return the type that represents the type of the id.
        Returns:
        type of id
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.persistence.metamodel (Java(TM) EE 7 Specification APIs)

javax.persistence.metamodel

Interfaces

  • Attribute
  • BasicType
  • Bindable
  • CollectionAttribute
  • EmbeddableType
  • EntityType
  • IdentifiableType
  • ListAttribute
  • ManagedType
  • MapAttribute
  • MappedSuperclassType
  • Metamodel
  • PluralAttribute
  • SetAttribute
  • SingularAttribute
  • Type

Enums

  • Attribute.PersistentAttributeType
  • Bindable.BindableType
  • PluralAttribute.CollectionType
  • Type.PersistenceType

Annotation Types

  • StaticMetamodel


javax.persistence.metamodel (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.persistence.metamodel

Java Persistence Metamodel API

See: Description

  • Interface Summary
    Interface Description
    Attribute<X,Y>
    Represents an attribute of a Java type.
    BasicType<X>
    Instances of the type BasicType represent basic types (including temporal and enumerated types).
    Bindable<T>
    Instances of the type Bindable represent object or attribute types that can be bound into a Path.
    CollectionAttribute<X,E>
    Instances of the type CollectionAttribute represent persistent java.util.Collection-valued attributes.
    EmbeddableType<X>
    Instances of the type EmbeddableType represent embeddable types.
    EntityType<X>
    Instances of the type EntityType represent entity types.
    IdentifiableType<X>
    Instances of the type IdentifiableType represent entity or mapped superclass types.
    ListAttribute<X,E>
    Instances of the type ListAttribute represent persistent javax.util.List-valued attributes.
    ManagedType<X>
    Instances of the type ManagedType represent entity, mapped superclass, and embeddable types.
    MapAttribute<X,K,V>
    Instances of the type MapAttribute represent persistent java.util.Map-valued attributes.
    MappedSuperclassType<X>
    Instances of the type MappedSuperclassType represent mapped superclass types.
    Metamodel
    Provides access to the metamodel of persistent entities in the persistence unit.
    PluralAttribute<X,C,E>
    Instances of the type PluralAttribute represent persistent collection-valued attributes.
    SetAttribute<X,E>
    Instances of the type SetAttribute represent persistent java.util.Set-valued attributes.
    SingularAttribute<X,T>
    Instances of the type SingularAttribute represents persistent single-valued properties or fields.
    Type<X>
    Instances of the type Type represent persistent object or attribute types.
  • Enum Summary
    Enum Description
    Attribute.PersistentAttributeType
    Bindable.BindableType
    PluralAttribute.CollectionType
    Type.PersistenceType
  • Annotation Types Summary
    Annotation Type Description
    StaticMetamodel
    The StaticMetamodel annotation specifies that the class is a metamodel class that represents the entity, mapped superclass, or embeddable class designated by the value element.

Package javax.persistence.metamodel Description

Java Persistence Metamodel API
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.persistence.metamodel Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.persistence.metamodel

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.persistence.metamodel.Attribute<X,Y>
    • javax.persistence.metamodel.PluralAttribute<X,C,E> (also extends javax.persistence.metamodel.Bindable<T>)
      • javax.persistence.metamodel.CollectionAttribute<X,E>
      • javax.persistence.metamodel.ListAttribute<X,E>
      • javax.persistence.metamodel.MapAttribute<X,K,V>
      • javax.persistence.metamodel.SetAttribute<X,E>
    • javax.persistence.metamodel.SingularAttribute<X,T> (also extends javax.persistence.metamodel.Bindable<T>)
  • javax.persistence.metamodel.Bindable<T>
    • javax.persistence.metamodel.EntityType<X> (also extends javax.persistence.metamodel.IdentifiableType<X>)
    • javax.persistence.metamodel.PluralAttribute<X,C,E> (also extends javax.persistence.metamodel.Attribute<X,Y>)
      • javax.persistence.metamodel.CollectionAttribute<X,E>
      • javax.persistence.metamodel.ListAttribute<X,E>
      • javax.persistence.metamodel.MapAttribute<X,K,V>
      • javax.persistence.metamodel.SetAttribute<X,E>
    • javax.persistence.metamodel.SingularAttribute<X,T> (also extends javax.persistence.metamodel.Attribute<X,Y>)
  • javax.persistence.metamodel.Metamodel
  • javax.persistence.metamodel.Type<X>
    • javax.persistence.metamodel.BasicType<X>
    • javax.persistence.metamodel.ManagedType<X>
      • javax.persistence.metamodel.EmbeddableType<X>
      • javax.persistence.metamodel.IdentifiableType<X>
        • javax.persistence.metamodel.EntityType<X> (also extends javax.persistence.metamodel.Bindable<T>)
        • javax.persistence.metamodel.MappedSuperclassType<X>

Annotation Type Hierarchy

  • javax.persistence.metamodel.StaticMetamodel (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.persistence.metamodel.Type.PersistenceType
      • javax.persistence.metamodel.PluralAttribute.CollectionType
      • javax.persistence.metamodel.Bindable.BindableType
      • javax.persistence.metamodel.Attribute.PersistentAttributeType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ListAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface ListAttribute<X,E>

  • Type Parameters:
    X - The type the represented List belongs to
    E - The element type of the represented List
    All Superinterfaces:
    Attribute<X,List<E>>, Bindable<E>, PluralAttribute<X,List<E>,E>

    public interface ListAttribute<X,E>
extends PluralAttribute<X,List<E>,E>
    Instances of the type ListAttribute represent persistent javax.util.List-valued attributes.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.PluralAttribute

        PluralAttribute.CollectionType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Attribute

        Attribute.PersistentAttributeType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Bindable

        Bindable.BindableType

    • Method Summary

      • Methods inherited from interface javax.persistence.metamodel.PluralAttribute

        getCollectionType, getElementType

      • Methods inherited from interface javax.persistence.metamodel.Attribute

        getDeclaringType, getJavaMember, getJavaType, getName, getPersistentAttributeType, isAssociation, isCollection

      • Methods inherited from interface javax.persistence.metamodel.Bindable

        getBindableJavaType, getBindableType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagedType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface ManagedType<X>

  • Type Parameters:
    X - The represented type.
    All Superinterfaces:
    Type<X>
    All Known Subinterfaces:
    EmbeddableType<X>, EntityType<X>, IdentifiableType<X>, MappedSuperclassType<X>

    public interface ManagedType<X>
extends Type<X>
    Instances of the type ManagedType represent entity, mapped superclass, and embeddable types.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Type

        Type.PersistenceType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Attribute<? super X,?> getAttribute(String name)
      Return the attribute of the managed type that corresponds to the specified name.
      Set<Attribute<? super X,?>> getAttributes()
      Return the attributes of the managed type.
      CollectionAttribute<? super X,?> getCollection(String name)
      Return the Collection-valued attribute of the managed type that corresponds to the specified name.
      <E> CollectionAttribute<? super X,E> getCollection(String name, Class<E> elementType)
      Return the Collection-valued attribute of the managed type that corresponds to the specified name and Java element type.
      Attribute<X,?> getDeclaredAttribute(String name)
      Return the attribute declared by the managed type that corresponds to the specified name.
      Set<Attribute<X,?>> getDeclaredAttributes()
      Return the attributes declared by the managed type.
      CollectionAttribute<X,?> getDeclaredCollection(String name)
      Return the Collection-valued attribute declared by the managed type that corresponds to the specified name.
      <E> CollectionAttribute<X,E> getDeclaredCollection(String name, Class<E> elementType)
      Return the Collection-valued attribute declared by the managed type that corresponds to the specified name and Java element type.
      ListAttribute<X,?> getDeclaredList(String name)
      Return the List-valued attribute declared by the managed type that corresponds to the specified name.
      <E> ListAttribute<X,E> getDeclaredList(String name, Class<E> elementType)
      Return the List-valued attribute declared by the managed type that corresponds to the specified name and Java element type.
      MapAttribute<X,?,?> getDeclaredMap(String name)
      Return the Map-valued attribute declared by the managed type that corresponds to the specified name.
      <K,V> MapAttribute<X,K,V> getDeclaredMap(String name, Class<K> keyType, Class<V> valueType)
      Return the Map-valued attribute declared by the managed type that corresponds to the specified name and Java key and value types.
      Set<PluralAttribute<X,?,?>> getDeclaredPluralAttributes()
      Return all multi-valued attributes (Collection-, Set-, List-, and Map-valued attributes) declared by the managed type.
      SetAttribute<X,?> getDeclaredSet(String name)
      Return the Set-valued attribute declared by the managed type that corresponds to the specified name.
      <E> SetAttribute<X,E> getDeclaredSet(String name, Class<E> elementType)
      Return the Set-valued attribute declared by the managed type that corresponds to the specified name and Java element type.
      SingularAttribute<X,?> getDeclaredSingularAttribute(String name)
      Return the single-valued attribute declared by the managed type that corresponds to the specified name.
      <Y> SingularAttribute<X,Y> getDeclaredSingularAttribute(String name, Class<Y> type)
      Return the single-valued attribute declared by the managed type that corresponds to the specified name and Java type.
      Set<SingularAttribute<X,?>> getDeclaredSingularAttributes()
      Return the single-valued attributes declared by the managed type.
      ListAttribute<? super X,?> getList(String name)
      Return the List-valued attribute of the managed type that corresponds to the specified name.
      <E> ListAttribute<? super X,E> getList(String name, Class<E> elementType)
      Return the List-valued attribute of the managed type that corresponds to the specified name and Java element type.
      MapAttribute<? super X,?,?> getMap(String name)
      Return the Map-valued attribute of the managed type that corresponds to the specified name.
      <K,V> MapAttribute<? super X,K,V> getMap(String name, Class<K> keyType, Class<V> valueType)
      Return the Map-valued attribute of the managed type that corresponds to the specified name and Java key and value types.
      Set<PluralAttribute<? super X,?,?>> getPluralAttributes()
      Return all multi-valued attributes (Collection-, Set-, List-, and Map-valued attributes) of the managed type.
      SetAttribute<? super X,?> getSet(String name)
      Return the Set-valued attribute of the managed type that corresponds to the specified name.
      <E> SetAttribute<? super X,E> getSet(String name, Class<E> elementType)
      Return the Set-valued attribute of the managed type that corresponds to the specified name and Java element type.
      SingularAttribute<? super X,?> getSingularAttribute(String name)
      Return the single-valued attribute of the managed type that corresponds to the specified name.
      <Y> SingularAttribute<? super X,Y> getSingularAttribute(String name, Class<Y> type)
      Return the single-valued attribute of the managed type that corresponds to the specified name and Java type.
      Set<SingularAttribute<? super X,?>> getSingularAttributes()
      Return the single-valued attributes of the managed type.

      • Methods inherited from interface javax.persistence.metamodel.Type

        getJavaType, getPersistenceType

    • Method Detail

      • getAttributes

        Set<Attribute<? super X,?>> getAttributes()
        Return the attributes of the managed type.
        Returns:
        attributes of the managed type

      • getDeclaredAttributes

        Set<Attribute<X,?>> getDeclaredAttributes()
        Return the attributes declared by the managed type. Returns empty set if the managed type has no declared attributes.
        Returns:
        declared attributes of the managed type

      • getSingularAttribute

        <Y> SingularAttribute<? super X,Y> getSingularAttribute(String name,
                                                      Class<Y> type)
        Return the single-valued attribute of the managed type that corresponds to the specified name and Java type.
        Parameters:
        name - the name of the represented attribute
        type - the type of the represented attribute
        Returns:
        single-valued attribute with given name and type
        Throws:
        IllegalArgumentException - if attribute of the given name and type is not present in the managed type

      • getDeclaredSingularAttribute

        <Y> SingularAttribute<X,Y> getDeclaredSingularAttribute(String name,
                                                      Class<Y> type)
        Return the single-valued attribute declared by the managed type that corresponds to the specified name and Java type.
        Parameters:
        name - the name of the represented attribute
        type - the type of the represented attribute
        Returns:
        declared single-valued attribute of the given name and type
        Throws:
        IllegalArgumentException - if attribute of the given name and type is not declared in the managed type

      • getSingularAttributes

        Set<SingularAttribute<? super X,?>> getSingularAttributes()
        Return the single-valued attributes of the managed type. Returns empty set if the managed type has no single-valued attributes.
        Returns:
        single-valued attributes

      • getDeclaredSingularAttributes

        Set<SingularAttribute<X,?>> getDeclaredSingularAttributes()
        Return the single-valued attributes declared by the managed type. Returns empty set if the managed type has no declared single-valued attributes.
        Returns:
        declared single-valued attributes

      • getCollection

        <E> CollectionAttribute<? super X,E> getCollection(String name,
                                                 Class<E> elementType)
        Return the Collection-valued attribute of the managed type that corresponds to the specified name and Java element type.
        Parameters:
        name - the name of the represented attribute
        elementType - the element type of the represented attribute
        Returns:
        CollectionAttribute of the given name and element type
        Throws:
        IllegalArgumentException - if attribute of the given name and type is not present in the managed type

      • getDeclaredCollection

        <E> CollectionAttribute<X,E> getDeclaredCollection(String name,
                                                 Class<E> elementType)
        Return the Collection-valued attribute declared by the managed type that corresponds to the specified name and Java element type.
        Parameters:
        name - the name of the represented attribute
        elementType - the element type of the represented attribute
        Returns:
        declared CollectionAttribute of the given name and element type
        Throws:
        IllegalArgumentException - if attribute of the given name and type is not declared in the managed type

      • getSet

        <E> SetAttribute<? super X,E> getSet(String name,
                                   Class<E> elementType)
        Return the Set-valued attribute of the managed type that corresponds to the specified name and Java element type.
        Parameters:
        name - the name of the represented attribute
        elementType - the element type of the represented attribute
        Returns:
        SetAttribute of the given name and element type
        Throws:
        IllegalArgumentException - if attribute of the given name and type is not present in the managed type

      • getDeclaredSet

        <E> SetAttribute<X,E> getDeclaredSet(String name,
                                   Class<E> elementType)
        Return the Set-valued attribute declared by the managed type that corresponds to the specified name and Java element type.
        Parameters:
        name - the name of the represented attribute
        elementType - the element type of the represented attribute
        Returns:
        declared SetAttribute of the given name and element type
        Throws:
        IllegalArgumentException - if attribute of the given name and type is not declared in the managed type

      • getList

        <E> ListAttribute<? super X,E> getList(String name,
                                     Class<E> elementType)
        Return the List-valued attribute of the managed type that corresponds to the specified name and Java element type.
        Parameters:
        name - the name of the represented attribute
        elementType - the element type of the represented attribute
        Returns:
        ListAttribute of the given name and element type
        Throws:
        IllegalArgumentException - if attribute of the given name and type is not present in the managed type

      • getDeclaredList

        <E> ListAttribute<X,E> getDeclaredList(String name,
                                     Class<E> elementType)
        Return the List-valued attribute declared by the managed type that corresponds to the specified name and Java element type.
        Parameters:
        name - the name of the represented attribute
        elementType - the element type of the represented attribute
        Returns:
        declared ListAttribute of the given name and element type
        Throws:
        IllegalArgumentException - if attribute of the given name and type is not declared in the managed type

      • getMap

        <K,V> MapAttribute<? super X,K,V> getMap(String name,
                                       Class<K> keyType,
                                       Class<V> valueType)
        Return the Map-valued attribute of the managed type that corresponds to the specified name and Java key and value types.
        Parameters:
        name - the name of the represented attribute
        keyType - the key type of the represented attribute
        valueType - the value type of the represented attribute
        Returns:
        MapAttribute of the given name and key and value types
        Throws:
        IllegalArgumentException - if attribute of the given name and type is not present in the managed type

      • getDeclaredMap

        <K,V> MapAttribute<X,K,V> getDeclaredMap(String name,
                                       Class<K> keyType,
                                       Class<V> valueType)
        Return the Map-valued attribute declared by the managed type that corresponds to the specified name and Java key and value types.
        Parameters:
        name - the name of the represented attribute
        keyType - the key type of the represented attribute
        valueType - the value type of the represented attribute
        Returns:
        declared MapAttribute of the given name and key and value types
        Throws:
        IllegalArgumentException - if attribute of the given name and type is not declared in the managed type

      • getPluralAttributes

        Set<PluralAttribute<? super X,?,?>> getPluralAttributes()
        Return all multi-valued attributes (Collection-, Set-, List-, and Map-valued attributes) of the managed type. Returns empty set if the managed type has no multi-valued attributes.
        Returns:
        Collection-, Set-, List-, and Map-valued attributes

      • getDeclaredPluralAttributes

        Set<PluralAttribute<X,?,?>> getDeclaredPluralAttributes()
        Return all multi-valued attributes (Collection-, Set-, List-, and Map-valued attributes) declared by the managed type. Returns empty set if the managed type has no declared multi-valued attributes.
        Returns:
        declared Collection-, Set-, List-, and Map-valued attributes

      • getAttribute

        Attribute<? super X,?> getAttribute(String name)
        Return the attribute of the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        attribute with given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not present in the managed type

      • getDeclaredAttribute

        Attribute<X,?> getDeclaredAttribute(String name)
        Return the attribute declared by the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        attribute with given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not declared in the managed type

      • getSingularAttribute

        SingularAttribute<? super X,?> getSingularAttribute(String name)
        Return the single-valued attribute of the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        single-valued attribute with the given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not present in the managed type

      • getDeclaredSingularAttribute

        SingularAttribute<X,?> getDeclaredSingularAttribute(String name)
        Return the single-valued attribute declared by the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        declared single-valued attribute of the given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not declared in the managed type

      • getCollection

        CollectionAttribute<? super X,?> getCollection(String name)
        Return the Collection-valued attribute of the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        CollectionAttribute of the given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not present in the managed type

      • getDeclaredCollection

        CollectionAttribute<X,?> getDeclaredCollection(String name)
        Return the Collection-valued attribute declared by the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        declared CollectionAttribute of the given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not declared in the managed type

      • getSet

        SetAttribute<? super X,?> getSet(String name)
        Return the Set-valued attribute of the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        SetAttribute of the given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not present in the managed type

      • getDeclaredSet

        SetAttribute<X,?> getDeclaredSet(String name)
        Return the Set-valued attribute declared by the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        declared SetAttribute of the given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not declared in the managed type

      • getList

        ListAttribute<? super X,?> getList(String name)
        Return the List-valued attribute of the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        ListAttribute of the given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not present in the managed type

      • getDeclaredList

        ListAttribute<X,?> getDeclaredList(String name)
        Return the List-valued attribute declared by the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        declared ListAttribute of the given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not declared in the managed type

      • getMap

        MapAttribute<? super X,?,?> getMap(String name)
        Return the Map-valued attribute of the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        MapAttribute of the given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not present in the managed type

      • getDeclaredMap

        MapAttribute<X,?,?> getDeclaredMap(String name)
        Return the Map-valued attribute declared by the managed type that corresponds to the specified name.
        Parameters:
        name - the name of the represented attribute
        Returns:
        declared MapAttribute of the given name
        Throws:
        IllegalArgumentException - if attribute of the given name is not declared in the managed type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MapAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface MapAttribute<X,K,V>

  • Type Parameters:
    X - The type the represented Map belongs to
    K - The type of the key of the represented Map
    V - The type of the value of the represented Map
    All Superinterfaces:
    Attribute<X,Map<K,V>>, Bindable<V>, PluralAttribute<X,Map<K,V>,V>

    public interface MapAttribute<X,K,V>
extends PluralAttribute<X,Map<K,V>,V>
    Instances of the type MapAttribute represent persistent java.util.Map-valued attributes.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.PluralAttribute

        PluralAttribute.CollectionType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Attribute

        Attribute.PersistentAttributeType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Bindable

        Bindable.BindableType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<K> getKeyJavaType()
      Return the Java type of the map key.
      Type<K> getKeyType()
      Return the type representing the key type of the map.

      • Methods inherited from interface javax.persistence.metamodel.PluralAttribute

        getCollectionType, getElementType

      • Methods inherited from interface javax.persistence.metamodel.Attribute

        getDeclaringType, getJavaMember, getJavaType, getName, getPersistentAttributeType, isAssociation, isCollection

      • Methods inherited from interface javax.persistence.metamodel.Bindable

        getBindableJavaType, getBindableType

    • Method Detail

      • getKeyJavaType

        Class<K> getKeyJavaType()
        Return the Java type of the map key.
        Returns:
        Java key type

      • getKeyType

        Type<K> getKeyType()
        Return the type representing the key type of the map.
        Returns:
        type representing key type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MappedSuperclassType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface MappedSuperclassType<X>

  • Type Parameters:
    X - The represented entity type
    All Superinterfaces:
    IdentifiableType<X>, ManagedType<X>, Type<X>

    public interface MappedSuperclassType<X>
extends IdentifiableType<X>
    Instances of the type MappedSuperclassType represent mapped superclass types.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Type

        Type.PersistenceType

    • Method Summary

      • Methods inherited from interface javax.persistence.metamodel.IdentifiableType

        getDeclaredId, getDeclaredVersion, getId, getIdClassAttributes, getIdType, getSupertype, getVersion, hasSingleIdAttribute, hasVersionAttribute

      • Methods inherited from interface javax.persistence.metamodel.ManagedType

        getAttribute, getAttributes, getCollection, getCollection, getDeclaredAttribute, getDeclaredAttributes, getDeclaredCollection, getDeclaredCollection, getDeclaredList, getDeclaredList, getDeclaredMap, getDeclaredMap, getDeclaredPluralAttributes, getDeclaredSet, getDeclaredSet, getDeclaredSingularAttribute, getDeclaredSingularAttribute, getDeclaredSingularAttributes, getList, getList, getMap, getMap, getPluralAttributes, getSet, getSet, getSingularAttribute, getSingularAttribute, getSingularAttributes

      • Methods inherited from interface javax.persistence.metamodel.Type

        getJavaType, getPersistenceType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Metamodel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface Metamodel

  • public interface Metamodel
    Provides access to the metamodel of persistent entities in the persistence unit.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <X> EmbeddableType<X> embeddable(Class<X> cls)
      Return the metamodel embeddable type representing the embeddable class.
      <X> EntityType<X> entity(Class<X> cls)
      Return the metamodel entity type representing the entity.
      Set<EmbeddableType<?>> getEmbeddables()
      Return the metamodel embeddable types.
      Set<EntityType<?>> getEntities()
      Return the metamodel entity types.
      Set<ManagedType<?>> getManagedTypes()
      Return the metamodel managed types.
      <X> ManagedType<X> managedType(Class<X> cls)
      Return the metamodel managed type representing the entity, mapped superclass, or embeddable class.

    • Method Detail

      • entity

        <X> EntityType<X> entity(Class<X> cls)
        Return the metamodel entity type representing the entity.
        Parameters:
        cls - the type of the represented entity
        Returns:
        the metamodel entity type
        Throws:
        IllegalArgumentException - if not an entity

      • managedType

        <X> ManagedType<X> managedType(Class<X> cls)
        Return the metamodel managed type representing the entity, mapped superclass, or embeddable class.
        Parameters:
        cls - the type of the represented managed class
        Returns:
        the metamodel managed type
        Throws:
        IllegalArgumentException - if not a managed class

      • embeddable

        <X> EmbeddableType<X> embeddable(Class<X> cls)
        Return the metamodel embeddable type representing the embeddable class.
        Parameters:
        cls - the type of the represented embeddable class
        Returns:
        the metamodel embeddable type
        Throws:
        IllegalArgumentException - if not an embeddable class

      • getManagedTypes

        Set<ManagedType<?>> getManagedTypes()
        Return the metamodel managed types.
        Returns:
        the metamodel managed types

      • getEntities

        Set<EntityType<?>> getEntities()
        Return the metamodel entity types.
        Returns:
        the metamodel entity types

      • getEmbeddables

        Set<EmbeddableType<?>> getEmbeddables()
        Return the metamodel embeddable types. Returns empty set if there are no embeddable types.
        Returns:
        the metamodel embeddable types
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PluralAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface PluralAttribute<X,C,E>

  • Type Parameters:
    X - The type the represented collection belongs to
    C - The type of the represented collection
    E - The element type of the represented collection
    All Superinterfaces:
    Attribute<X,C>, Bindable<E>
    All Known Subinterfaces:
    CollectionAttribute<X,E>, ListAttribute<X,E>, MapAttribute<X,K,V>, SetAttribute<X,E>

    public interface PluralAttribute<X,C,E>
extends Attribute<X,C>, Bindable<E>
    Instances of the type PluralAttribute represent persistent collection-valued attributes.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Interface and Description
      static class  | PluralAttribute.CollectionType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Attribute

        Attribute.PersistentAttributeType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Bindable

        Bindable.BindableType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      PluralAttribute.CollectionType getCollectionType()
      Return the collection type.
      Type<E> getElementType()
      Return the type representing the element type of the collection.

      • Methods inherited from interface javax.persistence.metamodel.Attribute

        getDeclaringType, getJavaMember, getJavaType, getName, getPersistentAttributeType, isAssociation, isCollection

      • Methods inherited from interface javax.persistence.metamodel.Bindable

        getBindableJavaType, getBindableType

    • Method Detail

      • getCollectionType

        PluralAttribute.CollectionType getCollectionType()
        Return the collection type.
        Returns:
        collection type

      • getElementType

        Type<E> getElementType()
        Return the type representing the element type of the collection.
        Returns:
        element type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PluralAttribute.CollectionType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence.metamodel

Enum PluralAttribute.CollectionType

  • java.lang.Object
    • java.lang.Enum<PluralAttribute.CollectionType>
      • javax.persistence.metamodel.PluralAttribute.CollectionType
  • All Implemented Interfaces:
    Serializable, Comparable<PluralAttribute.CollectionType>
    Enclosing interface:
    PluralAttribute<X,C,E>

    public static enum PluralAttribute.CollectionType
extends Enum<PluralAttribute.CollectionType>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      COLLECTION
      Collection-valued attribute
      LIST
      List-valued attribute
      MAP
      Map-valued attribute
      SET
      Set-valued attribute

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static PluralAttribute.CollectionType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static PluralAttribute.CollectionType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • COLLECTION

        public static final PluralAttribute.CollectionType COLLECTION
        Collection-valued attribute

      • SET

        public static final PluralAttribute.CollectionType SET
        Set-valued attribute

      • LIST

        public static final PluralAttribute.CollectionType LIST
        List-valued attribute

      • MAP

        public static final PluralAttribute.CollectionType MAP
        Map-valued attribute

    • Method Detail

      • values

        public static PluralAttribute.CollectionType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (PluralAttribute.CollectionType c : PluralAttribute.CollectionType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static PluralAttribute.CollectionType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


SetAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface SetAttribute<X,E>

  • Type Parameters:
    X - The type the represented Set belongs to
    E - The element type of the represented Set
    All Superinterfaces:
    Attribute<X,Set<E>>, Bindable<E>, PluralAttribute<X,Set<E>,E>

    public interface SetAttribute<X,E>
extends PluralAttribute<X,Set<E>,E>
    Instances of the type SetAttribute represent persistent java.util.Set-valued attributes.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.PluralAttribute

        PluralAttribute.CollectionType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Attribute

        Attribute.PersistentAttributeType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Bindable

        Bindable.BindableType

    • Method Summary

      • Methods inherited from interface javax.persistence.metamodel.PluralAttribute

        getCollectionType, getElementType

      • Methods inherited from interface javax.persistence.metamodel.Attribute

        getDeclaringType, getJavaMember, getJavaType, getName, getPersistentAttributeType, isAssociation, isCollection

      • Methods inherited from interface javax.persistence.metamodel.Bindable

        getBindableJavaType, getBindableType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SingularAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface SingularAttribute<X,T>

  • Type Parameters:
    X - The type containing the represented attribute
    T - The type of the represented attribute
    All Superinterfaces:
    Attribute<X,T>, Bindable<T>

    public interface SingularAttribute<X,T>
extends Attribute<X,T>, Bindable<T>
    Instances of the type SingularAttribute represents persistent single-valued properties or fields.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Attribute

        Attribute.PersistentAttributeType

      • Nested classes/interfaces inherited from interface javax.persistence.metamodel.Bindable

        Bindable.BindableType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Type<T> getType()
      Return the type that represents the type of the attribute.
      boolean isId()
      Is the attribute an id attribute.
      boolean isOptional()
      Can the attribute be null.
      boolean isVersion()
      Is the attribute a version attribute.

      • Methods inherited from interface javax.persistence.metamodel.Attribute

        getDeclaringType, getJavaMember, getJavaType, getName, getPersistentAttributeType, isAssociation, isCollection

      • Methods inherited from interface javax.persistence.metamodel.Bindable

        getBindableJavaType, getBindableType

    • Method Detail

      • isId

        boolean isId()
        Is the attribute an id attribute. This method will return true if the attribute is an attribute that corresponds to a simple id, an embedded id, or an attribute of an id class.
        Returns:
        boolean indicating whether the attribute is an id

      • isVersion

        boolean isVersion()
        Is the attribute a version attribute.
        Returns:
        boolean indicating whether the attribute is a version attribute

      • isOptional

        boolean isOptional()
        Can the attribute be null.
        Returns:
        boolean indicating whether the attribute can be null

      • getType

        Type<T> getType()
        Return the type that represents the type of the attribute.
        Returns:
        type of attribute
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StaticMetamodel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.persistence.metamodel

Annotation Type StaticMetamodel

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface StaticMetamodel
    The StaticMetamodel annotation specifies that the class is a metamodel class that represents the entity, mapped superclass, or embeddable class designated by the value element.
    Since:
    Java Persistence 2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<?> value
      Class being modelled by the annotated class.

    • Element Detail

      • value

        public abstract Class<?> value
        Class being modelled by the annotated class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Type (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.metamodel

Interface Type<X>

  • Type Parameters:
    X - The type of the represented object or attribute
    All Known Subinterfaces:
    BasicType<X>, EmbeddableType<X>, EntityType<X>, IdentifiableType<X>, ManagedType<X>, MappedSuperclassType<X>

    public interface Type<X>
    Instances of the type Type represent persistent object or attribute types.
    Since:
    Java Persistence 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Interface and Description
      static class  | Type.PersistenceType

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<X> getJavaType()
      Return the represented Java type.
      Type.PersistenceType getPersistenceType()
      Return the persistence type.

    • Method Detail

      • getPersistenceType

        Type.PersistenceType getPersistenceType()
        Return the persistence type.
        Returns:
        persistence type

      • getJavaType

        Class<X> getJavaType()
        Return the represented Java type.
        Returns:
        Java type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Type.PersistenceType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence.metamodel

Enum Type.PersistenceType

  • java.lang.Object
    • java.lang.Enum<Type.PersistenceType>
      • javax.persistence.metamodel.Type.PersistenceType
  • All Implemented Interfaces:
    Serializable, Comparable<Type.PersistenceType>
    Enclosing interface:
    Type<X>

    public static enum Type.PersistenceType
extends Enum<Type.PersistenceType>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BASIC
      Basic type
      EMBEDDABLE
      Embeddable class
      ENTITY
      Entity
      MAPPED_SUPERCLASS
      Mapped superclass

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Type.PersistenceType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Type.PersistenceType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ENTITY

        public static final Type.PersistenceType ENTITY
        Entity

      • EMBEDDABLE

        public static final Type.PersistenceType EMBEDDABLE
        Embeddable class

      • MAPPED_SUPERCLASS

        public static final Type.PersistenceType MAPPED_SUPERCLASS
        Mapped superclass

      • BASIC

        public static final Type.PersistenceType BASIC
        Basic type

    • Method Detail

      • values

        public static Type.PersistenceType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Type.PersistenceType c : Type.PersistenceType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Type.PersistenceType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Uses of Package javax.persistence.metamodel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.persistence.metamodel

  • Packages that use javax.persistence.metamodel
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.metamodel
    Java Persistence Metamodel API
  • Classes in javax.persistence.metamodel used by javax.persistence
    Class and Description
    Attribute
    Represents an attribute of a Java type.
    Metamodel
    Provides access to the metamodel of persistent entities in the persistence unit.
  • Classes in javax.persistence.metamodel used by javax.persistence.criteria
    Class and Description
    Attribute
    Represents an attribute of a Java type.
    Bindable
    Instances of the type Bindable represent object or attribute types that can be bound into a Path.
    CollectionAttribute
    Instances of the type CollectionAttribute represent persistent java.util.Collection-valued attributes.
    EntityType
    Instances of the type EntityType represent entity types.
    ListAttribute
    Instances of the type ListAttribute represent persistent javax.util.List-valued attributes.
    MapAttribute
    Instances of the type MapAttribute represent persistent java.util.Map-valued attributes.
    PluralAttribute
    Instances of the type PluralAttribute represent persistent collection-valued attributes.
    SetAttribute
    Instances of the type SetAttribute represent persistent java.util.Set-valued attributes.
    SingularAttribute
    Instances of the type SingularAttribute represents persistent single-valued properties or fields.
  • Classes in javax.persistence.metamodel used by javax.persistence.metamodel
    Class and Description
    Attribute
    Represents an attribute of a Java type.
    Attribute.PersistentAttributeType
    Bindable
    Instances of the type Bindable represent object or attribute types that can be bound into a Path.
    Bindable.BindableType
    CollectionAttribute
    Instances of the type CollectionAttribute represent persistent java.util.Collection-valued attributes.
    EmbeddableType
    Instances of the type EmbeddableType represent embeddable types.
    EntityType
    Instances of the type EntityType represent entity types.
    IdentifiableType
    Instances of the type IdentifiableType represent entity or mapped superclass types.
    ListAttribute
    Instances of the type ListAttribute represent persistent javax.util.List-valued attributes.
    ManagedType
    Instances of the type ManagedType represent entity, mapped superclass, and embeddable types.
    MapAttribute
    Instances of the type MapAttribute represent persistent java.util.Map-valued attributes.
    PluralAttribute
    Instances of the type PluralAttribute represent persistent collection-valued attributes.
    PluralAttribute.CollectionType
    SetAttribute
    Instances of the type SetAttribute represent persistent java.util.Set-valued attributes.
    SingularAttribute
    Instances of the type SingularAttribute represents persistent single-valued properties or fields.
    Type
    Instances of the type Type represent persistent object or attribute types.
    Type.PersistenceType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.metamodel.Attribute.PersistentAttributeType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.metamodel.Attribute.PersistentAttributeType

  • Packages that use Attribute.PersistentAttributeType
    Package Description
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of Attribute.PersistentAttributeType in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return Attribute.PersistentAttributeType
      Modifier and Type Method and Description
      Attribute.PersistentAttributeType Attribute.getPersistentAttributeType()
      Return the persistent attribute type for the attribute.
      static Attribute.PersistentAttributeType Attribute.PersistentAttributeType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Attribute.PersistentAttributeType[] Attribute.PersistentAttributeType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.metamodel.Bindable.BindableType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.metamodel.Bindable.BindableType

  • Packages that use Bindable.BindableType
    Package Description
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of Bindable.BindableType in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return Bindable.BindableType
      Modifier and Type Method and Description
      Bindable.BindableType Bindable.getBindableType()
      Return the bindable type of the represented object.
      static Bindable.BindableType Bindable.BindableType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Bindable.BindableType[] Bindable.BindableType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.metamodel.PluralAttribute.CollectionType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.metamodel.PluralAttribute.CollectionType

  • Packages that use PluralAttribute.CollectionType
    Package Description
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of PluralAttribute.CollectionType in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return PluralAttribute.CollectionType
      Modifier and Type Method and Description
      PluralAttribute.CollectionType PluralAttribute.getCollectionType()
      Return the collection type.
      static PluralAttribute.CollectionType PluralAttribute.CollectionType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static PluralAttribute.CollectionType[] PluralAttribute.CollectionType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.metamodel.StaticMetamodel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.metamodel.StaticMetamodel

No usage of javax.persistence.metamodel.StaticMetamodel
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.metamodel.Type.PersistenceType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.metamodel.Type.PersistenceType

  • Packages that use Type.PersistenceType
    Package Description
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of Type.PersistenceType in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return Type.PersistenceType
      Modifier and Type Method and Description
      Type.PersistenceType Type.getPersistenceType()
      Return the persistence type.
      static Type.PersistenceType Type.PersistenceType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Type.PersistenceType[] Type.PersistenceType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.Attribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.Attribute

  • Packages that use Attribute
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of Attribute in javax.persistence

      Methods in javax.persistence with parameters of type Attribute
      Modifier and Type Method and Description
      void Subgraph.addAttributeNodes(Attribute<T,?>... attribute)
      Add one or more attribute nodes to the entity graph.
      void EntityGraph.addAttributeNodes(Attribute<T,?>... attribute)
      Add one or more attribute nodes to the entity graph.
      <X> Subgraph<X> Subgraph.addKeySubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a map key that is a managed type.
      <X> Subgraph<X> EntityGraph.addKeySubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a map key that is a managed type.
      <X> Subgraph<? extends X> Subgraph.addKeySubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a map key that is a managed type with inheritance.
      <X> Subgraph<? extends X> EntityGraph.addKeySubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a map key that is a managed type with inheritance.
      <X> Subgraph<X> Subgraph.addSubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a managed type.
      <X> Subgraph<X> EntityGraph.addSubgraph(Attribute<T,X> attribute)
      Add a node to the graph that corresponds to a managed type.
      <X> Subgraph<? extends X> Subgraph.addSubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a managed type with inheritance.
      <X> Subgraph<? extends X> EntityGraph.addSubgraph(Attribute<T,X> attribute, Class<? extends X> type)
      Add a node to the graph that corresponds to a managed type with inheritance.

    • Uses of Attribute in javax.persistence.criteria

      Methods in javax.persistence.criteria that return Attribute
      Modifier and Type Method and Description
      Attribute<? super Z,?> Join.getAttribute()
      Return the metamodel attribute corresponding to the join.
      Attribute<? super Z,?> Fetch.getAttribute()
      Return the metamodel attribute corresponding to the fetch join.

    • Uses of Attribute in javax.persistence.metamodel

      Subinterfaces of Attribute in javax.persistence.metamodel
      Modifier and Type Interface and Description
      interface  CollectionAttribute<X,E>
      Instances of the type CollectionAttribute represent persistent java.util.Collection-valued attributes.
      interface  ListAttribute<X,E>
      Instances of the type ListAttribute represent persistent javax.util.List-valued attributes.
      interface  MapAttribute<X,K,V>
      Instances of the type MapAttribute represent persistent java.util.Map-valued attributes.
      interface  PluralAttribute<X,C,E>
      Instances of the type PluralAttribute represent persistent collection-valued attributes.
      interface  SetAttribute<X,E>
      Instances of the type SetAttribute represent persistent java.util.Set-valued attributes.
      interface  SingularAttribute<X,T>
      Instances of the type SingularAttribute represents persistent single-valued properties or fields.
      Methods in javax.persistence.metamodel that return Attribute
      Modifier and Type Method and Description
      Attribute<? super X,?> ManagedType.getAttribute(String name)
      Return the attribute of the managed type that corresponds to the specified name.
      Attribute<X,?> ManagedType.getDeclaredAttribute(String name)
      Return the attribute declared by the managed type that corresponds to the specified name.
      Methods in javax.persistence.metamodel that return types with arguments of type Attribute
      Modifier and Type Method and Description
      Set<Attribute<? super X,?>> ManagedType.getAttributes()
      Return the attributes of the managed type.
      Set<Attribute<X,?>> ManagedType.getDeclaredAttributes()
      Return the attributes declared by the managed type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.BasicType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.BasicType

No usage of javax.persistence.metamodel.BasicType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.Bindable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.Bindable

  • Packages that use Bindable
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of Bindable in javax.persistence.criteria

      Methods in javax.persistence.criteria that return Bindable
      Modifier and Type Method and Description
      Bindable<X> Path.getModel()
      Return the bindable object that corresponds to the path expression.

    • Uses of Bindable in javax.persistence.metamodel

      Subinterfaces of Bindable in javax.persistence.metamodel
      Modifier and Type Interface and Description
      interface  CollectionAttribute<X,E>
      Instances of the type CollectionAttribute represent persistent java.util.Collection-valued attributes.
      interface  EntityType<X>
      Instances of the type EntityType represent entity types.
      interface  ListAttribute<X,E>
      Instances of the type ListAttribute represent persistent javax.util.List-valued attributes.
      interface  MapAttribute<X,K,V>
      Instances of the type MapAttribute represent persistent java.util.Map-valued attributes.
      interface  PluralAttribute<X,C,E>
      Instances of the type PluralAttribute represent persistent collection-valued attributes.
      interface  SetAttribute<X,E>
      Instances of the type SetAttribute represent persistent java.util.Set-valued attributes.
      interface  SingularAttribute<X,T>
      Instances of the type SingularAttribute represents persistent single-valued properties or fields.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.CollectionAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.CollectionAttribute

  • Packages that use CollectionAttribute
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of CollectionAttribute in javax.persistence.criteria

      Methods in javax.persistence.criteria that return CollectionAttribute
      Modifier and Type Method and Description
      CollectionAttribute<? super Z,E> CollectionJoin.getModel()
      Return the metamodel representation for the collection attribute.
      Methods in javax.persistence.criteria with parameters of type CollectionAttribute
      Modifier and Type Method and Description
      <Y> CollectionJoin<X,Y> From.join(CollectionAttribute<? super X,Y> collection)
      Create an inner join to the specified Collection-valued attribute.
      <Y> CollectionJoin<X,Y> From.join(CollectionAttribute<? super X,Y> collection, JoinType jt)
      Create a join to the specified Collection-valued attribute using the given join type.

    • Uses of CollectionAttribute in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return CollectionAttribute
      Modifier and Type Method and Description
      CollectionAttribute<? super X,?> ManagedType.getCollection(String name)
      Return the Collection-valued attribute of the managed type that corresponds to the specified name.
      <E> CollectionAttribute<? super X,E> ManagedType.getCollection(String name, Class<E> elementType)
      Return the Collection-valued attribute of the managed type that corresponds to the specified name and Java element type.
      CollectionAttribute<X,?> ManagedType.getDeclaredCollection(String name)
      Return the Collection-valued attribute declared by the managed type that corresponds to the specified name.
      <E> CollectionAttribute<X,E> ManagedType.getDeclaredCollection(String name, Class<E> elementType)
      Return the Collection-valued attribute declared by the managed type that corresponds to the specified name and Java element type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.EmbeddableType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.EmbeddableType

  • Packages that use EmbeddableType
    Package Description
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of EmbeddableType in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return EmbeddableType
      Modifier and Type Method and Description
      <X> EmbeddableType<X> Metamodel.embeddable(Class<X> cls)
      Return the metamodel embeddable type representing the embeddable class.
      Methods in javax.persistence.metamodel that return types with arguments of type EmbeddableType
      Modifier and Type Method and Description
      Set<EmbeddableType<?>> Metamodel.getEmbeddables()
      Return the metamodel embeddable types.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.EntityType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.EntityType

  • Packages that use EntityType
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of EntityType in javax.persistence.criteria

      Methods in javax.persistence.criteria that return EntityType
      Modifier and Type Method and Description
      EntityType<X> Root.getModel()
      Return the metamodel entity corresponding to the root.
      Methods in javax.persistence.criteria with parameters of type EntityType
      Modifier and Type Method and Description
      Root<T> CriteriaUpdate.from(EntityType<T> entity)
      Create and add a query root corresponding to the entity that is the target of the update.
      Root<T> CriteriaDelete.from(EntityType<T> entity)
      Create and add a query root corresponding to the entity that is the target of the delete.
      <X> Root<X> AbstractQuery.from(EntityType<X> entity)
      Create and add a query root corresponding to the given entity, forming a cartesian product with any existing roots.

    • Uses of EntityType in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return EntityType
      Modifier and Type Method and Description
      <X> EntityType<X> Metamodel.entity(Class<X> cls)
      Return the metamodel entity type representing the entity.
      Methods in javax.persistence.metamodel that return types with arguments of type EntityType
      Modifier and Type Method and Description
      Set<EntityType<?>> Metamodel.getEntities()
      Return the metamodel entity types.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.IdentifiableType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.IdentifiableType

  • Packages that use IdentifiableType
    Package Description
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of IdentifiableType in javax.persistence.metamodel

      Subinterfaces of IdentifiableType in javax.persistence.metamodel
      Modifier and Type Interface and Description
      interface  EntityType<X>
      Instances of the type EntityType represent entity types.
      interface  MappedSuperclassType<X>
      Instances of the type MappedSuperclassType represent mapped superclass types.
      Methods in javax.persistence.metamodel that return IdentifiableType
      Modifier and Type Method and Description
      IdentifiableType<? super X> IdentifiableType.getSupertype()
      Return the identifiable type that corresponds to the most specific mapped superclass or entity extended by the entity or mapped superclass.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.ListAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.ListAttribute

  • Packages that use ListAttribute
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of ListAttribute in javax.persistence.criteria

      Methods in javax.persistence.criteria that return ListAttribute
      Modifier and Type Method and Description
      ListAttribute<? super Z,E> ListJoin.getModel()
      Return the metamodel representation for the list attribute.
      Methods in javax.persistence.criteria with parameters of type ListAttribute
      Modifier and Type Method and Description
      <Y> ListJoin<X,Y> From.join(ListAttribute<? super X,Y> list)
      Create an inner join to the specified List-valued attribute.
      <Y> ListJoin<X,Y> From.join(ListAttribute<? super X,Y> list, JoinType jt)
      Create a join to the specified List-valued attribute using the given join type.

    • Uses of ListAttribute in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return ListAttribute
      Modifier and Type Method and Description
      ListAttribute<X,?> ManagedType.getDeclaredList(String name)
      Return the List-valued attribute declared by the managed type that corresponds to the specified name.
      <E> ListAttribute<X,E> ManagedType.getDeclaredList(String name, Class<E> elementType)
      Return the List-valued attribute declared by the managed type that corresponds to the specified name and Java element type.
      ListAttribute<? super X,?> ManagedType.getList(String name)
      Return the List-valued attribute of the managed type that corresponds to the specified name.
      <E> ListAttribute<? super X,E> ManagedType.getList(String name, Class<E> elementType)
      Return the List-valued attribute of the managed type that corresponds to the specified name and Java element type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.ManagedType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.ManagedType

  • Packages that use ManagedType
    Package Description
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of ManagedType in javax.persistence.metamodel

      Subinterfaces of ManagedType in javax.persistence.metamodel
      Modifier and Type Interface and Description
      interface  EmbeddableType<X>
      Instances of the type EmbeddableType represent embeddable types.
      interface  EntityType<X>
      Instances of the type EntityType represent entity types.
      interface  IdentifiableType<X>
      Instances of the type IdentifiableType represent entity or mapped superclass types.
      interface  MappedSuperclassType<X>
      Instances of the type MappedSuperclassType represent mapped superclass types.
      Methods in javax.persistence.metamodel that return ManagedType
      Modifier and Type Method and Description
      ManagedType<X> Attribute.getDeclaringType()
      Return the managed type representing the type in which the attribute was declared.
      <X> ManagedType<X> Metamodel.managedType(Class<X> cls)
      Return the metamodel managed type representing the entity, mapped superclass, or embeddable class.
      Methods in javax.persistence.metamodel that return types with arguments of type ManagedType
      Modifier and Type Method and Description
      Set<ManagedType<?>> Metamodel.getManagedTypes()
      Return the metamodel managed types.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.MapAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.MapAttribute

  • Packages that use MapAttribute
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of MapAttribute in javax.persistence.criteria

      Methods in javax.persistence.criteria that return MapAttribute
      Modifier and Type Method and Description
      MapAttribute<? super Z,K,V> MapJoin.getModel()
      Return the metamodel representation for the map attribute.
      Methods in javax.persistence.criteria with parameters of type MapAttribute
      Modifier and Type Method and Description
      <K,V,M extends Map<K,V>>
      Expression<M>             		Path.get(MapAttribute<X,K,V> map)
      Create a path corresponding to the referenced map-valued attribute.
      <K,V> MapJoin<X,K,V> From.join(MapAttribute<? super X,K,V> map)
      Create an inner join to the specified Map-valued attribute.
      <K,V> MapJoin<X,K,V> From.join(MapAttribute<? super X,K,V> map, JoinType jt)
      Create a join to the specified Map-valued attribute using the given join type.

    • Uses of MapAttribute in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return MapAttribute
      Modifier and Type Method and Description
      MapAttribute<X,?,?> ManagedType.getDeclaredMap(String name)
      Return the Map-valued attribute declared by the managed type that corresponds to the specified name.
      <K,V> MapAttribute<X,K,V> ManagedType.getDeclaredMap(String name, Class<K> keyType, Class<V> valueType)
      Return the Map-valued attribute declared by the managed type that corresponds to the specified name and Java key and value types.
      MapAttribute<? super X,?,?> ManagedType.getMap(String name)
      Return the Map-valued attribute of the managed type that corresponds to the specified name.
      <K,V> MapAttribute<? super X,K,V> ManagedType.getMap(String name, Class<K> keyType, Class<V> valueType)
      Return the Map-valued attribute of the managed type that corresponds to the specified name and Java key and value types.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.MappedSuperclassType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.MappedSuperclassType

No usage of javax.persistence.metamodel.MappedSuperclassType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.Metamodel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.Metamodel

  • Packages that use Metamodel
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.

    • Uses of Metamodel in javax.persistence

      Methods in javax.persistence that return Metamodel
      Modifier and Type Method and Description
      Metamodel EntityManagerFactory.getMetamodel()
      Return an instance of Metamodel interface for access to the metamodel of the persistence unit.
      Metamodel EntityManager.getMetamodel()
      Return an instance of Metamodel interface for access to the metamodel of the persistence unit.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.PluralAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.PluralAttribute

  • Packages that use PluralAttribute
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of PluralAttribute in javax.persistence.criteria

      Methods in javax.persistence.criteria that return PluralAttribute
      Modifier and Type Method and Description
      PluralAttribute<? super Z,C,E> PluralJoin.getModel()
      Return the metamodel representation for the collection-valued attribute corresponding to the join.
      Methods in javax.persistence.criteria with parameters of type PluralAttribute
      Modifier and Type Method and Description
      <Y> Fetch<X,Y> FetchParent.fetch(PluralAttribute<? super X,?,Y> attribute)
      Create a fetch join to the specified collection-valued attribute using an inner join.
      <Y> Fetch<X,Y> FetchParent.fetch(PluralAttribute<? super X,?,Y> attribute, JoinType jt)
      Create a fetch join to the specified collection-valued attribute using the given join type.
      <E,C extends Collection<E>>
      Expression<C>             		Path.get(PluralAttribute<X,C,E> collection)
      Create a path corresponding to the referenced collection-valued attribute.

    • Uses of PluralAttribute in javax.persistence.metamodel

      Subinterfaces of PluralAttribute in javax.persistence.metamodel
      Modifier and Type Interface and Description
      interface  CollectionAttribute<X,E>
      Instances of the type CollectionAttribute represent persistent java.util.Collection-valued attributes.
      interface  ListAttribute<X,E>
      Instances of the type ListAttribute represent persistent javax.util.List-valued attributes.
      interface  MapAttribute<X,K,V>
      Instances of the type MapAttribute represent persistent java.util.Map-valued attributes.
      interface  SetAttribute<X,E>
      Instances of the type SetAttribute represent persistent java.util.Set-valued attributes.
      Methods in javax.persistence.metamodel that return types with arguments of type PluralAttribute
      Modifier and Type Method and Description
      Set<PluralAttribute<X,?,?>> ManagedType.getDeclaredPluralAttributes()
      Return all multi-valued attributes (Collection-, Set-, List-, and Map-valued attributes) declared by the managed type.
      Set<PluralAttribute<? super X,?,?>> ManagedType.getPluralAttributes()
      Return all multi-valued attributes (Collection-, Set-, List-, and Map-valued attributes) of the managed type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.SetAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.SetAttribute

  • Packages that use SetAttribute
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of SetAttribute in javax.persistence.criteria

      Methods in javax.persistence.criteria that return SetAttribute
      Modifier and Type Method and Description
      SetAttribute<? super Z,E> SetJoin.getModel()
      Return the metamodel representation for the set attribute.
      Methods in javax.persistence.criteria with parameters of type SetAttribute
      Modifier and Type Method and Description
      <Y> SetJoin<X,Y> From.join(SetAttribute<? super X,Y> set)
      Create an inner join to the specified Set-valued attribute.
      <Y> SetJoin<X,Y> From.join(SetAttribute<? super X,Y> set, JoinType jt)
      Create a join to the specified Set-valued attribute using the given join type.

    • Uses of SetAttribute in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return SetAttribute
      Modifier and Type Method and Description
      SetAttribute<X,?> ManagedType.getDeclaredSet(String name)
      Return the Set-valued attribute declared by the managed type that corresponds to the specified name.
      <E> SetAttribute<X,E> ManagedType.getDeclaredSet(String name, Class<E> elementType)
      Return the Set-valued attribute declared by the managed type that corresponds to the specified name and Java element type.
      SetAttribute<? super X,?> ManagedType.getSet(String name)
      Return the Set-valued attribute of the managed type that corresponds to the specified name.
      <E> SetAttribute<? super X,E> ManagedType.getSet(String name, Class<E> elementType)
      Return the Set-valued attribute of the managed type that corresponds to the specified name and Java element type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.SingularAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.SingularAttribute

  • Packages that use SingularAttribute
    Package Description
    javax.persistence.criteria
    Java Persistence Criteria API
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of SingularAttribute in javax.persistence.criteria

      Methods in javax.persistence.criteria with parameters of type SingularAttribute
      Modifier and Type Method and Description
      <Y> Fetch<X,Y> FetchParent.fetch(SingularAttribute<? super X,Y> attribute)
      Create a fetch join to the specified single-valued attribute using an inner join.
      <Y> Fetch<X,Y> FetchParent.fetch(SingularAttribute<? super X,Y> attribute, JoinType jt)
      Create a fetch join to the specified single-valued attribute using the given join type.
      <Y> Path<Y> Path.get(SingularAttribute<? super X,Y> attribute)
      Create a path corresponding to the referenced single-valued attribute.
      <Y> Join<X,Y> From.join(SingularAttribute<? super X,Y> attribute)
      Create an inner join to the specified single-valued attribute.
      <Y> Join<X,Y> From.join(SingularAttribute<? super X,Y> attribute, JoinType jt)
      Create a join to the specified single-valued attribute using the given join type.
      <Y> CriteriaUpdate<T> CriteriaUpdate.set(SingularAttribute<? super T,Y> attribute, Expression<? extends Y> value)
      Update the value of the specified attribute.
      <Y,X extends Y>
      CriteriaUpdate<T>             		CriteriaUpdate.set(SingularAttribute<? super T,Y> attribute, X value)
      Update the value of the specified attribute.

    • Uses of SingularAttribute in javax.persistence.metamodel

      Methods in javax.persistence.metamodel that return SingularAttribute
      Modifier and Type Method and Description
      <Y> SingularAttribute<X,Y> IdentifiableType.getDeclaredId(Class<Y> type)
      Return the attribute that corresponds to the id attribute declared by the entity or mapped superclass.
      SingularAttribute<X,?> ManagedType.getDeclaredSingularAttribute(String name)
      Return the single-valued attribute declared by the managed type that corresponds to the specified name.
      <Y> SingularAttribute<X,Y> ManagedType.getDeclaredSingularAttribute(String name, Class<Y> type)
      Return the single-valued attribute declared by the managed type that corresponds to the specified name and Java type.
      <Y> SingularAttribute<X,Y> IdentifiableType.getDeclaredVersion(Class<Y> type)
      Return the attribute that corresponds to the version attribute declared by the entity or mapped superclass.
      <Y> SingularAttribute<? super X,Y> IdentifiableType.getId(Class<Y> type)
      Return the attribute that corresponds to the id attribute of the entity or mapped superclass.
      SingularAttribute<? super X,?> ManagedType.getSingularAttribute(String name)
      Return the single-valued attribute of the managed type that corresponds to the specified name.
      <Y> SingularAttribute<? super X,Y> ManagedType.getSingularAttribute(String name, Class<Y> type)
      Return the single-valued attribute of the managed type that corresponds to the specified name and Java type.
      <Y> SingularAttribute<? super X,Y> IdentifiableType.getVersion(Class<Y> type)
      Return the attribute that corresponds to the version attribute of the entity or mapped superclass.
      Methods in javax.persistence.metamodel that return types with arguments of type SingularAttribute
      Modifier and Type Method and Description
      Set<SingularAttribute<X,?>> ManagedType.getDeclaredSingularAttributes()
      Return the single-valued attributes declared by the managed type.
      Set<SingularAttribute<? super X,?>> IdentifiableType.getIdClassAttributes()
      Return the attributes corresponding to the id class of the identifiable type.
      Set<SingularAttribute<? super X,?>> ManagedType.getSingularAttributes()
      Return the single-valued attributes of the managed type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.metamodel.Type (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.metamodel.Type

  • Packages that use Type
    Package Description
    javax.persistence.metamodel
    Java Persistence Metamodel API

    • Uses of Type in javax.persistence.metamodel

      Subinterfaces of Type in javax.persistence.metamodel
      Modifier and Type Interface and Description
      interface  BasicType<X>
      Instances of the type BasicType represent basic types (including temporal and enumerated types).
      interface  EmbeddableType<X>
      Instances of the type EmbeddableType represent embeddable types.
      interface  EntityType<X>
      Instances of the type EntityType represent entity types.
      interface  IdentifiableType<X>
      Instances of the type IdentifiableType represent entity or mapped superclass types.
      interface  ManagedType<X>
      Instances of the type ManagedType represent entity, mapped superclass, and embeddable types.
      interface  MappedSuperclassType<X>
      Instances of the type MappedSuperclassType represent mapped superclass types.
      Methods in javax.persistence.metamodel that return Type
      Modifier and Type Method and Description
      Type<E> PluralAttribute.getElementType()
      Return the type representing the element type of the collection.
      Type<?> IdentifiableType.getIdType()
      Return the type that represents the type of the id.
      Type<K> MapAttribute.getKeyType()
      Return the type representing the key type of the map.
      Type<T> SingularAttribute.getType()
      Return the type that represents the type of the attribute.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ClassTransformer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.spi

Interface ClassTransformer

  • public interface ClassTransformer
    A persistence provider supplies an instance of this interface to the PersistenceUnitInfo.addTransformer method. The supplied transformer instance will get called to transform entity class files when they are loaded or redefined. The transformation occurs before the class is defined by the JVM.
    Since:
    Java Persistence 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      byte[] transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      Invoked when a class is being loaded or redefined.

    • Method Detail

      • transform

        byte[] transform(ClassLoader loader,
               String className,
               Class<?> classBeingRedefined,
               ProtectionDomain protectionDomain,
               byte[] classfileBuffer)
                 throws IllegalClassFormatException
        Invoked when a class is being loaded or redefined. The implementation of this method may transform the supplied class file and return a new replacement class file.
        Parameters:
        loader - the defining loader of the class to be transformed, may be null if the bootstrap loader
        className - the name of the class in the internal form of fully qualified class and interface names
        classBeingRedefined - if this is a redefine, the class being redefined, otherwise null
        protectionDomain - the protection domain of the class being defined or redefined
        classfileBuffer - the input byte buffer in class file format - must not be modified
        Returns:
        a well-formed class file buffer (the result of the transform), or null if no transform is performed
        Throws:
        IllegalClassFormatException - if the input does not represent a well-formed class file
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.persistence.spi (Java(TM) EE 7 Specification APIs)

javax.persistence.spi

Interfaces

  • ClassTransformer
  • PersistenceProvider
  • PersistenceProviderResolver
  • PersistenceUnitInfo
  • ProviderUtil

Classes

  • PersistenceProviderResolverHolder

Enums

  • LoadState
  • PersistenceUnitTransactionType


javax.persistence.spi (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.persistence.spi

SPI for Java Persistence providers

See: Description

  • Interface Summary
    Interface Description
    ClassTransformer
    A persistence provider supplies an instance of this interface to the PersistenceUnitInfo.addTransformer method.
    PersistenceProvider
    Interface implemented by the persistence provider.
    PersistenceProviderResolver
    Determine the list of persistence providers available in the runtime environment.
    PersistenceUnitInfo
    Interface implemented by the container and used by the persistence provider when creating an EntityManagerFactory.
    ProviderUtil
    Utility interface implemented by the persistence provider.
  • Class Summary
    Class Description
    PersistenceProviderResolverHolder
    Holds the global PersistenceProviderResolver instance.
  • Enum Summary
    Enum Description
    LoadState
    Load states returned by the ProviderUtil SPI methods.
    PersistenceUnitTransactionType
    Specifies whether entity managers created by the EntityManagerFactory will be JTA or resource-local entity managers.

Package javax.persistence.spi Description

SPI for Java Persistence providers
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.persistence.spi Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.persistence.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.persistence.spi.PersistenceProviderResolverHolder

Interface Hierarchy

  • javax.persistence.spi.ClassTransformer
  • javax.persistence.spi.PersistenceProvider
  • javax.persistence.spi.PersistenceProviderResolver
  • javax.persistence.spi.PersistenceUnitInfo
  • javax.persistence.spi.ProviderUtil

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.persistence.spi.PersistenceUnitTransactionType
      • javax.persistence.spi.LoadState
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LoadState (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence.spi

Enum LoadState

  • java.lang.Object
    • java.lang.Enum<LoadState>
      • javax.persistence.spi.LoadState
  • All Implemented Interfaces:
    Serializable, Comparable<LoadState>

    public enum LoadState
extends Enum<LoadState>
    Load states returned by the ProviderUtil SPI methods.
    Since:
    Java Persistence 2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      LOADED
      The state of the element is known to have been loaded.
      NOT_LOADED
      The state of the element is known not to have been loaded.
      UNKNOWN
      The load state of the element cannot be determined.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static LoadState valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static LoadState[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LOADED

        public static final LoadState LOADED
        The state of the element is known to have been loaded.

      • NOT_LOADED

        public static final LoadState NOT_LOADED
        The state of the element is known not to have been loaded.

      • UNKNOWN

        public static final LoadState UNKNOWN
        The load state of the element cannot be determined.

    • Method Detail

      • values

        public static LoadState[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (LoadState c : LoadState.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static LoadState valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


PersistenceProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.spi

Interface PersistenceProvider

  • public interface PersistenceProvider
    Interface implemented by the persistence provider.

    It is invoked by the container in Java EE environments and by the Persistence class in Java SE environments to create an EntityManagerFactory and/or to cause schema generation to occur.

    Since:
    Java Persistence 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      EntityManagerFactory createContainerEntityManagerFactory(PersistenceUnitInfo info, Map map)
      Called by the container when an EntityManagerFactory is to be created.
      EntityManagerFactory createEntityManagerFactory(String emName, Map map)
      Called by Persistence class when an EntityManagerFactory is to be created.
      void generateSchema(PersistenceUnitInfo info, Map map)
      Create database schemas and/or tables and/or create DDL scripts as determined by the supplied properties.
      boolean generateSchema(String persistenceUnitName, Map map)
      Create database schemas and/or tables and/or create DDL scripts as determined by the supplied properties.
      ProviderUtil getProviderUtil()
      Return the utility interface implemented by the persistence provider.

    • Method Detail

      • createEntityManagerFactory

        EntityManagerFactory createEntityManagerFactory(String emName,
                                              Map map)
        Called by Persistence class when an EntityManagerFactory is to be created.
        Parameters:
        emName - the name of the persistence unit
        map - a Map of properties for use by the persistence provider. These properties may be used to override the values of the corresponding elements in the persistence.xml file or specify values for properties not specified in the persistence.xml (and may be null if no properties are specified).
        Returns:
        EntityManagerFactory for the persistence unit, or null if the provider is not the right provider

      • createContainerEntityManagerFactory

        EntityManagerFactory createContainerEntityManagerFactory(PersistenceUnitInfo info,
                                                       Map map)
        Called by the container when an EntityManagerFactory is to be created.
        Parameters:
        info - metadata for use by the persistence provider
        map - a Map of integration-level properties for use by the persistence provider (may be null if no properties are specified). These properties may include properties to control schema generation. If a Bean Validation provider is present in the classpath, the container must pass the ValidatorFactory instance in the map with the key "javax.persistence.validation.factory". If the containing archive is a bean archive, the container must pass the BeanManager instance in the map with the key "javax.persistence.bean.manager".
        Returns:
        EntityManagerFactory for the persistence unit specified by the metadata

      • generateSchema

        void generateSchema(PersistenceUnitInfo info,
                  Map map)
        Create database schemas and/or tables and/or create DDL scripts as determined by the supplied properties.

        Called by the container when schema generation is to occur as a separate phase from creation of the entity manager factory.

        Parameters:
        info - metadata for use by the persistence provider
        map - properties for schema generation; these may also include provider-specific properties
        Throws:
        PersistenceException - if insufficient or inconsistent configuration information is provided of if schema generation otherwise fails
        Since:
        Java Persistence 2.1

      • generateSchema

        boolean generateSchema(String persistenceUnitName,
                     Map map)
        Create database schemas and/or tables and/or create DDL scripts as determined by the supplied properties.

        Called by the Persistence class when schema generation is to occur as a separate phase from creation of the entity manager factory.

        Parameters:
        persistenceUnitName - the name of the persistence unit
        map - properties for schema generation; these may also contain provider-specific properties. The value of these properties override any values that may have been configured elsewhere.
        Returns:
        true if schema was generated, otherwise false
        Throws:
        PersistenceException - if insufficient or inconsistent configuration information is provided or if schema generation otherwise fails
        Since:
        Java Persistence 2.1

      • getProviderUtil

        ProviderUtil getProviderUtil()
        Return the utility interface implemented by the persistence provider.
        Returns:
        ProviderUtil interface
        Since:
        Java Persistence 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PersistenceProviderResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.spi

Interface PersistenceProviderResolver

  • public interface PersistenceProviderResolver
    Determine the list of persistence providers available in the runtime environment.

    Implementations must be thread-safe.

    Note that the getPersistenceProviders method can potentially be called many times: it is recommended that the implementation of this method make use of caching.

    Since:
    Java Persistence 2.0
    See Also:
    PersistenceProvider

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearCachedProviders()
      Clear cache of providers.
      List<PersistenceProvider> getPersistenceProviders()
      Returns a list of the PersistenceProvider implementations available in the runtime environment.

    • Method Detail

      • getPersistenceProviders

        List<PersistenceProvider> getPersistenceProviders()
        Returns a list of the PersistenceProvider implementations available in the runtime environment.
        Returns:
        list of the persistence providers available in the environment

      • clearCachedProviders

        void clearCachedProviders()
        Clear cache of providers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PersistenceProviderResolverHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.spi

Class PersistenceProviderResolverHolder

  • java.lang.Object
    • javax.persistence.spi.PersistenceProviderResolverHolder

  • public class PersistenceProviderResolverHolder
extends Object
    Holds the global PersistenceProviderResolver instance. If no PersistenceProviderResolver is set by the environment, the default PersistenceProviderResolver is used. Implementations must be thread-safe.
    Since:
    Java Persistence 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      PersistenceProviderResolverHolder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static PersistenceProviderResolver getPersistenceProviderResolver()
      Returns the current persistence provider resolver.
      static void setPersistenceProviderResolver(PersistenceProviderResolver resolver)
      Defines the persistence provider resolver used.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PersistenceProviderResolverHolder

        public PersistenceProviderResolverHolder()

    • Method Detail

      • getPersistenceProviderResolver

        public static PersistenceProviderResolver getPersistenceProviderResolver()
        Returns the current persistence provider resolver.
        Returns:
        the current persistence provider resolver

      • setPersistenceProviderResolver

        public static void setPersistenceProviderResolver(PersistenceProviderResolver resolver)
        Defines the persistence provider resolver used.
        Parameters:
        resolver - persistence provider resolver to be used.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PersistenceUnitInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.spi

Interface PersistenceUnitInfo

  • public interface PersistenceUnitInfo
    Interface implemented by the container and used by the persistence provider when creating an EntityManagerFactory.
    Since:
    Java Persistence 1.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addTransformer(ClassTransformer transformer)
      Add a transformer supplied by the provider that will be called for every new class definition or class redefinition that gets loaded by the loader returned by the getClassLoader() method.
      boolean excludeUnlistedClasses()
      Returns whether classes in the root of the persistence unit that have not been explicitly listed are to be included in the set of managed classes.
      ClassLoader getClassLoader()
      Returns ClassLoader that the provider may use to load any classes, resources, or open URLs.
      List<URL> getJarFileUrls()
      Returns a list of URLs for the jar files or exploded jar file directories that the persistence provider must examine for managed classes of the persistence unit.
      DataSource getJtaDataSource()
      Returns the JTA-enabled data source to be used by the persistence provider.
      List<String> getManagedClassNames()
      Returns the list of the names of the classes that the persistence provider must add to its set of managed classes.
      List<String> getMappingFileNames()
      Returns the list of the names of the mapping files that the persistence provider must load to determine the mappings for the entity classes.
      ClassLoader getNewTempClassLoader()
      Return a new instance of a ClassLoader that the provider may use to temporarily load any classes, resources, or open URLs.
      DataSource getNonJtaDataSource()
      Returns the non-JTA-enabled data source to be used by the persistence provider for accessing data outside a JTA transaction.
      String getPersistenceProviderClassName()
      Returns the fully qualified name of the persistence provider implementation class.
      String getPersistenceUnitName()
      Returns the name of the persistence unit.
      URL getPersistenceUnitRootUrl()
      Returns the URL for the jar file or directory that is the root of the persistence unit.
      String getPersistenceXMLSchemaVersion()
      Returns the schema version of the persistence.xml file.
      Properties getProperties()
      Returns a properties object.
      SharedCacheMode getSharedCacheMode()
      Returns the specification of how the provider must use a second-level cache for the persistence unit.
      PersistenceUnitTransactionType getTransactionType()
      Returns the transaction type of the entity managers created by the EntityManagerFactory.
      ValidationMode getValidationMode()
      Returns the validation mode to be used by the persistence provider for the persistence unit.

    • Method Detail

      • getPersistenceUnitName

        String getPersistenceUnitName()
        Returns the name of the persistence unit. Corresponds to the name attribute in the persistence.xml file.
        Returns:
        the name of the persistence unit

      • getPersistenceProviderClassName

        String getPersistenceProviderClassName()
        Returns the fully qualified name of the persistence provider implementation class. Corresponds to the provider element in the persistence.xml file.
        Returns:
        the fully qualified name of the persistence provider implementation class

      • getTransactionType

        PersistenceUnitTransactionType getTransactionType()
        Returns the transaction type of the entity managers created by the EntityManagerFactory. The transaction type corresponds to the transaction-type attribute in the persistence.xml file.
        Returns:
        transaction type of the entity managers created by the EntityManagerFactory

      • getJtaDataSource

        DataSource getJtaDataSource()
        Returns the JTA-enabled data source to be used by the persistence provider. The data source corresponds to the jta-data-source element in the persistence.xml file or is provided at deployment or by the container.
        Returns:
        the JTA-enabled data source to be used by the persistence provider

      • getNonJtaDataSource

        DataSource getNonJtaDataSource()
        Returns the non-JTA-enabled data source to be used by the persistence provider for accessing data outside a JTA transaction. The data source corresponds to the named non-jta-data-source element in the persistence.xml file or provided at deployment or by the container.
        Returns:
        the non-JTA-enabled data source to be used by the persistence provider for accessing data outside a JTA transaction

      • getMappingFileNames

        List<String> getMappingFileNames()
        Returns the list of the names of the mapping files that the persistence provider must load to determine the mappings for the entity classes. The mapping files must be in the standard XML mapping format, be uniquely named and be resource-loadable from the application classpath. Each mapping file name corresponds to a mapping-file element in the persistence.xml file.
        Returns:
        the list of mapping file names that the persistence provider must load to determine the mappings for the entity classes

      • getJarFileUrls

        List<URL> getJarFileUrls()
        Returns a list of URLs for the jar files or exploded jar file directories that the persistence provider must examine for managed classes of the persistence unit. Each URL corresponds to a jar-file element in the persistence.xml file. A URL will either be a file: URL referring to a jar file or referring to a directory that contains an exploded jar file, or some other URL from which an InputStream in jar format can be obtained.
        Returns:
        a list of URL objects referring to jar files or directories

      • getPersistenceUnitRootUrl

        URL getPersistenceUnitRootUrl()
        Returns the URL for the jar file or directory that is the root of the persistence unit. (If the persistence unit is rooted in the WEB-INF/classes directory, this will be the URL of that directory.) The URL will either be a file: URL referring to a jar file or referring to a directory that contains an exploded jar file, or some other URL from which an InputStream in jar format can be obtained.
        Returns:
        a URL referring to a jar file or directory

      • getManagedClassNames

        List<String> getManagedClassNames()
        Returns the list of the names of the classes that the persistence provider must add to its set of managed classes. Each name corresponds to a named class element in the persistence.xml file.
        Returns:
        the list of the names of the classes that the persistence provider must add to its set of managed classes

      • excludeUnlistedClasses

        boolean excludeUnlistedClasses()
        Returns whether classes in the root of the persistence unit that have not been explicitly listed are to be included in the set of managed classes. This value corresponds to the exclude-unlisted-classes element in the persistence.xml file.
        Returns:
        whether classes in the root of the persistence unit that have not been explicitly listed are to be included in the set of managed classes

      • getSharedCacheMode

        SharedCacheMode getSharedCacheMode()
        Returns the specification of how the provider must use a second-level cache for the persistence unit. The result of this method corresponds to the shared-cache-mode element in the persistence.xml file.
        Returns:
        the second-level cache mode that must be used by the provider for the persistence unit
        Since:
        Java Persistence 2.0

      • getValidationMode

        ValidationMode getValidationMode()
        Returns the validation mode to be used by the persistence provider for the persistence unit. The validation mode corresponds to the validation-mode element in the persistence.xml file.
        Returns:
        the validation mode to be used by the persistence provider for the persistence unit
        Since:
        Java Persistence 2.0

      • getProperties

        Properties getProperties()
        Returns a properties object. Each property corresponds to a property element in the persistence.xml file or to a property set by the container.
        Returns:
        Properties object

      • getPersistenceXMLSchemaVersion

        String getPersistenceXMLSchemaVersion()
        Returns the schema version of the persistence.xml file.
        Returns:
        persistence.xml schema version
        Since:
        Java Persistence 2.0

      • getClassLoader

        ClassLoader getClassLoader()
        Returns ClassLoader that the provider may use to load any classes, resources, or open URLs.
        Returns:
        ClassLoader that the provider may use to load any classes, resources, or open URLs

      • addTransformer

        void addTransformer(ClassTransformer transformer)
        Add a transformer supplied by the provider that will be called for every new class definition or class redefinition that gets loaded by the loader returned by the getClassLoader() method. The transformer has no effect on the result returned by the getNewTempClassLoader() method. Classes are only transformed once within the same classloading scope, regardless of how many persistence units they may be a part of.
        Parameters:
        transformer - provider-supplied transformer that the container invokes at class-(re)definition time

      • getNewTempClassLoader

        ClassLoader getNewTempClassLoader()
        Return a new instance of a ClassLoader that the provider may use to temporarily load any classes, resources, or open URLs. The scope and classpath of this loader is exactly the same as that of the loader returned by getClassLoader(). None of the classes loaded by this class loader will be visible to application components. The provider may only use this ClassLoader within the scope of the PersistenceProvider.createContainerEntityManagerFactory(javax.persistence.spi.PersistenceUnitInfo, java.util.Map) call.
        Returns:
        temporary ClassLoader with same visibility as current loader
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PersistenceUnitTransactionType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.persistence.spi

Enum PersistenceUnitTransactionType

  • java.lang.Object
    • java.lang.Enum<PersistenceUnitTransactionType>
      • javax.persistence.spi.PersistenceUnitTransactionType
  • All Implemented Interfaces:
    Serializable, Comparable<PersistenceUnitTransactionType>

    public enum PersistenceUnitTransactionType
extends Enum<PersistenceUnitTransactionType>
    Specifies whether entity managers created by the EntityManagerFactory will be JTA or resource-local entity managers.
    Since:
    Java Persistence 1.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      JTA
      JTA entity managers will be created.
      RESOURCE_LOCAL
      Resource-local entity managers will be created.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static PersistenceUnitTransactionType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static PersistenceUnitTransactionType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • JTA

        public static final PersistenceUnitTransactionType JTA
        JTA entity managers will be created.

      • RESOURCE_LOCAL

        public static final PersistenceUnitTransactionType RESOURCE_LOCAL
        Resource-local entity managers will be created.

    • Method Detail

      • values

        public static PersistenceUnitTransactionType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (PersistenceUnitTransactionType c : PersistenceUnitTransactionType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static PersistenceUnitTransactionType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ProviderUtil (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.persistence.spi

Interface ProviderUtil

  • public interface ProviderUtil
    Utility interface implemented by the persistence provider. This interface is invoked by the PersistenceUtil implementation to determine the load status of an entity or entity attribute.
    Since:
    Java Persistence 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      LoadState isLoaded(Object entity)
      If the provider determines that the entity has been provided by itself and that the state of all attributes for which FetchType.EAGER has been specified have been loaded, this method returns LoadState.LOADED.
      LoadState isLoadedWithoutReference(Object entity, String attributeName)
      If the provider determines that the entity has been provided by itself and that the state of the specified attribute has been loaded, this method returns LoadState.LOADED.
      LoadState isLoadedWithReference(Object entity, String attributeName)
      If the provider determines that the entity has been provided by itself and that the state of the specified attribute has been loaded, this method returns LoadState.LOADED.

    • Method Detail

      • isLoadedWithoutReference

        LoadState isLoadedWithoutReference(Object entity,
                                 String attributeName)
        If the provider determines that the entity has been provided by itself and that the state of the specified attribute has been loaded, this method returns LoadState.LOADED.

        If the provider determines that the entity has been provided by itself and that either entity attributes with FetchType.EAGER have not been loaded or that the state of the specified attribute has not been loaded, this methods returns LoadState.NOT_LOADED.

        If a provider cannot determine the load state, this method returns LoadState.UNKNOWN.

        The provider's implementation of this method must not obtain a reference to an attribute value, as this could trigger the loading of entity state if the entity has been provided by a different provider.

        Parameters:
        entity - entity instance
        attributeName - name of attribute whose load status is to be determined
        Returns:
        load status of the attribute

      • isLoadedWithReference

        LoadState isLoadedWithReference(Object entity,
                              String attributeName)
        If the provider determines that the entity has been provided by itself and that the state of the specified attribute has been loaded, this method returns LoadState.LOADED.

        If a provider determines that the entity has been provided by itself and that either the entity attributes with FetchType.EAGER have not been loaded or that the state of the specified attribute has not been loaded, this method returns return LoadState.NOT_LOADED.

        If the provider cannot determine the load state, this method returns LoadState.UNKNOWN.

        The provider's implementation of this method is permitted to obtain a reference to the attribute value. (This access is safe because providers which might trigger the loading of the attribute state will have already been determined by isLoadedWithoutReference. )

        Parameters:
        entity - entity instance
        attributeName - name of attribute whose load status is to be determined
        Returns:
        load status of the attribute

      • isLoaded

        LoadState isLoaded(Object entity)
        If the provider determines that the entity has been provided by itself and that the state of all attributes for which FetchType.EAGER has been specified have been loaded, this method returns LoadState.LOADED.

        If the provider determines that the entity has been provided by itself and that not all attributes with FetchType.EAGER have been loaded, this method returns LoadState.NOT_LOADED.

        If the provider cannot determine if the entity has been provided by itself, this method returns LoadState.UNKNOWN.

        The provider's implementation of this method must not obtain a reference to any attribute value, as this could trigger the loading of entity state if the entity has been provided by a different provider.

        Parameters:
        entity - whose loaded status is to be determined
        Returns:
        load status of the entity
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.persistence.spi (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.persistence.spi

  • Packages that use javax.persistence.spi
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.spi
    SPI for Java Persistence providers
  • Classes in javax.persistence.spi used by javax.persistence
    Class and Description
    PersistenceProvider
    Interface implemented by the persistence provider.
  • Classes in javax.persistence.spi used by javax.persistence.spi
    Class and Description
    ClassTransformer
    A persistence provider supplies an instance of this interface to the PersistenceUnitInfo.addTransformer method.
    LoadState
    Load states returned by the ProviderUtil SPI methods.
    PersistenceProvider
    Interface implemented by the persistence provider.
    PersistenceProviderResolver
    Determine the list of persistence providers available in the runtime environment.
    PersistenceUnitInfo
    Interface implemented by the container and used by the persistence provider when creating an EntityManagerFactory.
    PersistenceUnitTransactionType
    Specifies whether entity managers created by the EntityManagerFactory will be JTA or resource-local entity managers.
    ProviderUtil
    Utility interface implemented by the persistence provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.spi.LoadState (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.spi.LoadState

  • Packages that use LoadState
    Package Description
    javax.persistence.spi
    SPI for Java Persistence providers

    • Uses of LoadState in javax.persistence.spi

      Methods in javax.persistence.spi that return LoadState
      Modifier and Type Method and Description
      LoadState ProviderUtil.isLoaded(Object entity)
      If the provider determines that the entity has been provided by itself and that the state of all attributes for which FetchType.EAGER has been specified have been loaded, this method returns LoadState.LOADED.
      LoadState ProviderUtil.isLoadedWithoutReference(Object entity, String attributeName)
      If the provider determines that the entity has been provided by itself and that the state of the specified attribute has been loaded, this method returns LoadState.LOADED.
      LoadState ProviderUtil.isLoadedWithReference(Object entity, String attributeName)
      If the provider determines that the entity has been provided by itself and that the state of the specified attribute has been loaded, this method returns LoadState.LOADED.
      static LoadState LoadState.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static LoadState[] LoadState.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.spi.PersistenceProviderResolverHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.spi.PersistenceProviderResolverHolder

No usage of javax.persistence.spi.PersistenceProviderResolverHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.persistence.spi.PersistenceUnitTransactionType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.persistence.spi.PersistenceUnitTransactionType

  • Packages that use PersistenceUnitTransactionType
    Package Description
    javax.persistence.spi
    SPI for Java Persistence providers

    • Uses of PersistenceUnitTransactionType in javax.persistence.spi

      Methods in javax.persistence.spi that return PersistenceUnitTransactionType
      Modifier and Type Method and Description
      PersistenceUnitTransactionType PersistenceUnitInfo.getTransactionType()
      Returns the transaction type of the entity managers created by the EntityManagerFactory.
      static PersistenceUnitTransactionType PersistenceUnitTransactionType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static PersistenceUnitTransactionType[] PersistenceUnitTransactionType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.spi.ClassTransformer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.spi.ClassTransformer

  • Packages that use ClassTransformer
    Package Description
    javax.persistence.spi
    SPI for Java Persistence providers

    • Uses of ClassTransformer in javax.persistence.spi

      Methods in javax.persistence.spi with parameters of type ClassTransformer
      Modifier and Type Method and Description
      void PersistenceUnitInfo.addTransformer(ClassTransformer transformer)
      Add a transformer supplied by the provider that will be called for every new class definition or class redefinition that gets loaded by the loader returned by the PersistenceUnitInfo.getClassLoader() method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.spi.PersistenceProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.spi.PersistenceProvider

  • Packages that use PersistenceProvider
    Package Description
    javax.persistence
    Java Persistence is the API for the management for persistence and object/relational mapping.
    javax.persistence.spi
    SPI for Java Persistence providers

    • Uses of PersistenceProvider in javax.persistence

      Fields in javax.persistence with type parameters of type PersistenceProvider
      Modifier and Type Field and Description
      protected static Set<PersistenceProvider> Persistence.providers
      Deprecated.

    • Uses of PersistenceProvider in javax.persistence.spi

      Methods in javax.persistence.spi that return types with arguments of type PersistenceProvider
      Modifier and Type Method and Description
      List<PersistenceProvider> PersistenceProviderResolver.getPersistenceProviders()
      Returns a list of the PersistenceProvider implementations available in the runtime environment.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.spi.PersistenceProviderResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.spi.PersistenceProviderResolver

  • Packages that use PersistenceProviderResolver
    Package Description
    javax.persistence.spi
    SPI for Java Persistence providers

    • Uses of PersistenceProviderResolver in javax.persistence.spi

      Methods in javax.persistence.spi that return PersistenceProviderResolver
      Modifier and Type Method and Description
      static PersistenceProviderResolver PersistenceProviderResolverHolder.getPersistenceProviderResolver()
      Returns the current persistence provider resolver.
      Methods in javax.persistence.spi with parameters of type PersistenceProviderResolver
      Modifier and Type Method and Description
      static void PersistenceProviderResolverHolder.setPersistenceProviderResolver(PersistenceProviderResolver resolver)
      Defines the persistence provider resolver used.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.spi.PersistenceUnitInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.spi.PersistenceUnitInfo

  • Packages that use PersistenceUnitInfo
    Package Description
    javax.persistence.spi
    SPI for Java Persistence providers

    • Uses of PersistenceUnitInfo in javax.persistence.spi

      Methods in javax.persistence.spi with parameters of type PersistenceUnitInfo
      Modifier and Type Method and Description
      EntityManagerFactory PersistenceProvider.createContainerEntityManagerFactory(PersistenceUnitInfo info, Map map)
      Called by the container when an EntityManagerFactory is to be created.
      void PersistenceProvider.generateSchema(PersistenceUnitInfo info, Map map)
      Create database schemas and/or tables and/or create DDL scripts as determined by the supplied properties.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.persistence.spi.ProviderUtil (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.persistence.spi.ProviderUtil

  • Packages that use ProviderUtil
    Package Description
    javax.persistence.spi
    SPI for Java Persistence providers

    • Uses of ProviderUtil in javax.persistence.spi

      Methods in javax.persistence.spi that return ProviderUtil
      Modifier and Type Method and Description
      ProviderUtil PersistenceProvider.getProviderUtil()
      Return the utility interface implemented by the persistence provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AdministeredObjectDefinition (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource

Annotation Type AdministeredObjectDefinition

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface AdministeredObjectDefinition
    Annotation used to define a Connector administered object to be registered in JNDI. Once defined, an administered object may be referenced by a component using the lookup element of the Resource annotation.
    Since:
    1.7
    Version:
    1.7
    See Also:
    Resource

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String className
      Fully qualified name of the administered object’s class
      String name
      JNDI name of the administered object being defined.
      String resourceAdapter
      The name of the resource adapter that the administered object must be created from.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String description
      Description of the administered object.
      String interfaceName
      Fully qualified name of the administered object’s interface
      String[] properties
      Properties of the administered object.

    • Element Detail

      • name

        public abstract String name
        JNDI name of the administered object being defined.

      • resourceAdapter

        public abstract String resourceAdapter
        The name of the resource adapter that the administered object must be created from. The resource adapter is required to be available at deployment time.

      • className

        public abstract String className
        Fully qualified name of the administered object’s class

      • description

        public abstract String description
        Description of the administered object.
        Default:
        ""

      • interfaceName

        public abstract String interfaceName
        Fully qualified name of the administered object’s interface
        Default:
        ""

      • properties

        public abstract String[] properties
        Properties of the administered object. These properties may be vendor-specific properties. Vendor-specific properties may be combined with or used to override the administered object properties defined using this annotation. Administered Object properties that are specified and are not supported in a given resource adapter or cannot be mapped to a vendor specific configuration property may be ignored.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AdministeredObjectDefinitions (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource

Annotation Type AdministeredObjectDefinitions

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface AdministeredObjectDefinitions
    Declares one or more AdministeredObjectDefinition annotations.
    Since:
    1.7
    Version:
    1.7
    See Also:
    AdministeredObjectDefinition

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      AdministeredObjectDefinition[] value

    • Element Detail

      • value

        public abstract AdministeredObjectDefinition[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ConnectionFactoryDefinition (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource

Annotation Type ConnectionFactoryDefinition

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface ConnectionFactoryDefinition
    Annotation used to define a Connector Connection Factory resource to be registered in JNDI. Once defined, a resource may be referenced by a component using the lookup element of the Resource annotation.
    Since:
    1.7
    Version:
    1.7
    See Also:
    Resource

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String interfaceName
      The fully qualified name of the connection factory interface class.
      String name
      JNDI name of the connection factory resource being defined.
      String resourceAdapter
      The name of the resource adapter that the administered object must be created from.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String description
      Description of the resource.
      int maxPoolSize
      The maximum number of connections that should be allocated for a connection pool that backs this connnection factory resource.
      int minPoolSize
      The minimum number of connections that should be allocated for a connection pool that backs this connnection factory resource.
      String[] properties
      Properties of the Connection Factory.
      TransactionSupport.TransactionSupportLevel transactionSupport
      The level of transaction support the connection factory resource needs to support.

    • Element Detail

      • name

        public abstract String name
        JNDI name of the connection factory resource being defined.

      • resourceAdapter

        public abstract String resourceAdapter
        The name of the resource adapter that the administered object must be created from. The resource adapter is required to be available at deployment time.

      • interfaceName

        public abstract String interfaceName
        The fully qualified name of the connection factory interface class.

      • description

        public abstract String description
        Description of the resource.
        Default:
        ""

      • transactionSupport

        public abstract TransactionSupport.TransactionSupportLevel transactionSupport
        The level of transaction support the connection factory resource needs to support. If a transaction support specification is specified, it must be a level of transaction support whose ordinal value in the TransactionSupport.TransactionSupportLevel enum is equal to or lesser than the resource adapter's transaction support classification.
        Default:
        javax.resource.spi.TransactionSupport.TransactionSupportLevel.NoTransaction

      • maxPoolSize

        public abstract int maxPoolSize
        The maximum number of connections that should be allocated for a connection pool that backs this connnection factory resource. The default for this attribute is vendor specific.
        Default:
        -1

      • minPoolSize

        public abstract int minPoolSize
        The minimum number of connections that should be allocated for a connection pool that backs this connnection factory resource. The default for this attribute is vendor specific.
        Default:
        -1

      • properties

        public abstract String[] properties
        Properties of the Connection Factory. These properties may be vendor-specific properties. Vendor-specific properties may be combined with or used to override the connection factory properties defined using this annotation. Connection Factory properties that are specified and are not supported in a given resource adapter or cannot be mapped to a vendor specific configuration property may be ignored.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ConnectionFactoryDefinitions (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource

Annotation Type ConnectionFactoryDefinitions

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface ConnectionFactoryDefinitions
    Declares one or more ConnectionFactoryDefinition annotations.
    Since:
    1.7
    Version:
    1.7
    See Also:
    ConnectionFactoryDefinition

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      ConnectionFactoryDefinition[] value

    • Element Detail

      • value

        public abstract ConnectionFactoryDefinition[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.resource (Java(TM) EE 7 Specification APIs)

javax.resource

Interfaces

  • Referenceable

Exceptions

  • NotSupportedException
  • ResourceException

Annotation Types

  • AdministeredObjectDefinition
  • AdministeredObjectDefinitions
  • ConnectionFactoryDefinition
  • ConnectionFactoryDefinitions


javax.resource (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.resource

The javax.resource package is the top-level package for the Java EE Connector API specification.

See: Description

  • Interface Summary
    Interface Description
    Referenceable
    The Referenceable interface extends the javax.naming.Referenceable interface.
  • Exception Summary
    Exception Description
    NotSupportedException
    A NotSupportedException is thrown to indicate that callee (resource adapter or application server for system contracts) cannot execute an operation because the operation is not a supported feature.
    ResourceException
    This is the root interface of the exception hierarchy defined for the Connector architecture.
  • Annotation Types Summary
    Annotation Type Description
    AdministeredObjectDefinition
    Annotation used to define a Connector administered object to be registered in JNDI.
    AdministeredObjectDefinitions
    Declares one or more AdministeredObjectDefinition annotations.
    ConnectionFactoryDefinition
    Annotation used to define a Connector Connection Factory resource to be registered in JNDI.
    ConnectionFactoryDefinitions
    Declares one or more ConnectionFactoryDefinition annotations.

Package javax.resource Description

The javax.resource package is the top-level package for the Java EE Connector API specification.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.resource Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.resource

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.NotSupportedException

Interface Hierarchy

  • javax.naming.Referenceable
    • javax.resource.Referenceable

Annotation Type Hierarchy

  • javax.resource.ConnectionFactoryDefinitions (implements java.lang.annotation.Annotation)
  • javax.resource.ConnectionFactoryDefinition (implements java.lang.annotation.Annotation)
  • javax.resource.AdministeredObjectDefinitions (implements java.lang.annotation.Annotation)
  • javax.resource.AdministeredObjectDefinition (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


NotSupportedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource

Class NotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.NotSupportedException
  • All Implemented Interfaces:
    Serializable

    public class NotSupportedException
extends ResourceException
    A NotSupportedException is thrown to indicate that callee (resource adapter or application server for system contracts) cannot execute an operation because the operation is not a supported feature. For example, if the transaction support level for a resource adapter is NO_TRANSACTION, an invocation of getXAResource method on a ManagedConnection object should throw a NotSupportedException exception.
    Version:
    1.0
    Author:
    Rahul Sharma, Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NotSupportedException()
      Constructs a new instance with null as its detail message.
      NotSupportedException(String message)
      Constructs a new instance with the specified detail message.
      NotSupportedException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and error code.
      NotSupportedException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      NotSupportedException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NotSupportedException

        public NotSupportedException()
        Constructs a new instance with null as its detail message.

      • NotSupportedException

        public NotSupportedException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • NotSupportedException

        public NotSupportedException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • NotSupportedException

        public NotSupportedException(String message,
                     Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • NotSupportedException

        public NotSupportedException(String message,
                     String errorCode)
        Constructs a new throwable with the specified detail message and error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Referenceable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource

Interface Referenceable

  • All Superinterfaces:
    Referenceable
    All Known Subinterfaces:
    ConnectionFactory

    public interface Referenceable
extends Referenceable
    The Referenceable interface extends the javax.naming.Referenceable interface. It enables support for JNDI Reference mechanism for the registration of the connection factory in the JNDI name space. Note that the implementation and structure of Reference is specific to an application server.

    The implementation class for a connection factory interface is required to implement both java.io.Serializable and javax.resource.Referenceable interfaces to support JNDI registration.

    Version:
    0.9
    Author:
    Rahul Sharma

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void setReference(Reference reference)
      Sets the Reference instance.

      • Methods inherited from interface javax.naming.Referenceable

        getReference

    • Method Detail

      • setReference

        void setReference(Reference reference)
        Sets the Reference instance. This method is called by the deployment code to set the Reference that can be later returned by the getReference method (as defined in the javax.naming.Referenceable interface).
        Parameters:
        reference - A Reference instance
        See Also:
        Referenceable.getReference()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource

Class ResourceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ApplicationServerInternalException, CommException, EISSystemException, IllegalStateException, InvalidPropertyException, LocalTransactionException, NotSupportedException, ResourceAdapterInternalException, ResourceAllocationException, ResourceWarning, SecurityException, SharingViolationException, UnavailableException, WorkException

    public class ResourceException
extends Exception
    This is the root interface of the exception hierarchy defined for the Connector architecture. The ResourceException provides the following information:
    • A resource adapter vendor specific string describing the error. This string is a standard Java exception message and is available through getMessage() method.
    • resource adapter vendor specific error code.
    • reference to another exception. Often a resource exception will be result of a lower level problem. If appropriate, this lower level exception can be linked to the ResourceException. Note, this has been deprecated in favor of J2SE release 1.4 exception chaining facility.
    Version:
    1.0
    Author:
    Rahul Sharma, Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceException()
      Constructs a new instance with null as its detail message.
      ResourceException(String message)
      Constructs a new instance with the specified detail message.
      ResourceException(String message, String errorCode)
      Create a new throwable with the specified message and error code.
      ResourceException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      ResourceException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getErrorCode()
      Get the error code.
      Exception getLinkedException()
      Deprecated.
      J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..
      String getMessage()
      Returns a detailed message string describing this exception.
      void setErrorCode(String errorCode)
      Set the error code.
      void setLinkedException(Exception ex)
      Deprecated.
      J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ResourceException

        public ResourceException()
        Constructs a new instance with null as its detail message.

      • ResourceException

        public ResourceException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • ResourceException

        public ResourceException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • ResourceException

        public ResourceException(String message,
                 Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • ResourceException

        public ResourceException(String message,
                 String errorCode)
        Create a new throwable with the specified message and error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.

    • Method Detail

      • setErrorCode

        public void setErrorCode(String errorCode)
        Set the error code.
        Parameters:
        errorCode - the error code.

      • getErrorCode

        public String getErrorCode()
        Get the error code.
        Returns:
        the error code.

      • getLinkedException

        public Exception getLinkedException()
        Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..
        Get the exception linked to this ResourceException
        Returns:
        linked Exception, null if none

      • setLinkedException

        public void setLinkedException(Exception ex)
        Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
        Add a linked Exception to this ResourceException.
        Parameters:
        ex - linked Exception

      • getMessage

        public String getMessage()
        Returns a detailed message string describing this exception.
        Overrides:
        getMessage in class Throwable
        Returns:
        a detailed message string.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.resource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.resource

  • Packages that use javax.resource
    Package Description
    javax.resource
    The javax.resource package is the top-level package for the Java EE Connector API specification.
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.endpoint
    This package contains system contracts for service endpoint interactions.
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.
  • Classes in javax.resource used by javax.resource
    Class and Description
    ResourceException
    This is the root interface of the exception hierarchy defined for the Connector architecture.
  • Classes in javax.resource used by javax.resource.cci
    Class and Description
    Referenceable
    The Referenceable interface extends the javax.naming.Referenceable interface.
    ResourceException
    This is the root interface of the exception hierarchy defined for the Connector architecture.
  • Classes in javax.resource used by javax.resource.spi
    Class and Description
    ResourceException
    This is the root interface of the exception hierarchy defined for the Connector architecture.
  • Classes in javax.resource used by javax.resource.spi.endpoint
    Class and Description
    ResourceException
    This is the root interface of the exception hierarchy defined for the Connector architecture.
  • Classes in javax.resource used by javax.resource.spi.work
    Class and Description
    NotSupportedException
    A NotSupportedException is thrown to indicate that callee (resource adapter or application server for system contracts) cannot execute an operation because the operation is not a supported feature.
    ResourceException
    This is the root interface of the exception hierarchy defined for the Connector architecture.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Connection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface Connection

  • public interface Connection
    A Connection represents an application-level handle that is used by a client to access the underlying physical connection. The actual physical connection associated with a Connection instance is represented by a ManagedConnection instance.

    A client gets a Connection instance by using the getConnection method on a ConnectionFactory instance. A connection can be associated with zero or more Interaction instances.

    Version:
    0.8
    Author:
    Rahul Sharma
    See Also:
    ConnectionFactory, Interaction

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Initiates close of the connection handle at the application level.
      Interaction createInteraction()
      Creates an Interaction associated with this Connection.
      LocalTransaction getLocalTransaction()
      Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection.
      ConnectionMetaData getMetaData()
      Gets the information on the underlying EIS instance represented through an active connection.
      ResultSetInfo getResultSetInfo()
      Gets the information on the ResultSet functionality supported by a connected EIS instance.

    • Method Detail

      • createInteraction

        Interaction createInteraction()
                              throws ResourceException
        Creates an Interaction associated with this Connection. An Interaction enables an application to execute EIS functions.
        Returns:
        Interaction instance
        Throws:
        ResourceException - Failed to create an Interaction

      • getLocalTransaction

        LocalTransaction getLocalTransaction()
                                     throws ResourceException
        Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection. If a resource adapter does not allow a component to demarcate local transactions on an Connection using LocalTransaction interface, then the method getLocalTransaction should throw a NotSupportedException.
        Returns:
        LocalTransaction instance
        Throws:
        ResourceException - Failed to return a LocalTransaction instance because of a resource adapter error
        NotSupportedException - Demarcation of Resource manager local transactions is not supported on this Connection
        See Also:
        LocalTransaction

      • getMetaData

        ConnectionMetaData getMetaData()
                               throws ResourceException
        Gets the information on the underlying EIS instance represented through an active connection.
        Returns:
        ConnectionMetaData instance representing information about the EIS instance
        Throws:
        ResourceException - Failed to get information about the connected EIS instance. Error can be resource adapter-internal, EIS-specific or communication related.

      • getResultSetInfo

        ResultSetInfo getResultSetInfo()
                               throws ResourceException
        Gets the information on the ResultSet functionality supported by a connected EIS instance.
        Returns:
        ResultSetInfo instance
        Throws:
        ResourceException - Failed to get ResultSet related information
        NotSupportedException - ResultSet functionality is not supported

      • close

        void close()
           throws ResourceException
        Initiates close of the connection handle at the application level. A client should not use a closed connection to interact with an EIS.
        Throws:
        ResourceException - Exception thrown if close on a connection handle fails.

        Any invalid connection close invocation--example, calling close on a connection handle that is already closed--should also throw this exception.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface ConnectionFactory

  • All Superinterfaces:
    Referenceable, Serializable

    public interface ConnectionFactory
extends Serializable, Referenceable
    ConnectionFactory provides an interface for getting connection to an EIS instance. An implementation of ConnectionFactory interface is provided by a resource adapter.

    Application code looks up a ConnectionFactory instance from JNDI namespace and uses it to get EIS connections.

    An implementation class for ConnectionFactory is required to implement java.io.Serializable and javax.resource.Referenceableinterfaces to support JNDI registration.

    Version:
    0.8
    Author:
    Rahul Sharma
    See Also:
    Connection, Referenceable

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Connection getConnection()
      Gets a connection to an EIS instance.
      Connection getConnection(ConnectionSpec properties)
      Gets a connection to an EIS instance.
      ResourceAdapterMetaData getMetaData()
      Gets metadata for the Resource Adapter.
      RecordFactory getRecordFactory()
      Gets a RecordFactory instance.

      • Methods inherited from interface javax.resource.Referenceable

        setReference

      • Methods inherited from interface javax.naming.Referenceable

        getReference

    • Method Detail

      • getConnection

        Connection getConnection()
                         throws ResourceException
        Gets a connection to an EIS instance. This getConnection variant should be used when a component wants the container to manage EIS sign-on. This case is termed container-managed sign-on. The component does not pass any security information.
        Returns:
        Connection instance
        Throws:
        ResourceException - Failed to get a connection to the EIS instance. Examples of error cases are:
        • Invalid configuration of ManagedConnectionFactory-- example: invalid server name
        • Application server-internal error--example: connection pool related error
        • Communication error
        • EIS-specific error--example: EIS not active
        • Resource adapter-internal error
        • Security related error; example: invalid user
        • Failure to allocate system resources

      • getConnection

        Connection getConnection(ConnectionSpec properties)
                         throws ResourceException
        Gets a connection to an EIS instance. A component should use the getConnection variant with javax.resource.cci.ConnectionSpec parameter, if it needs to pass any resource adapter specific security information and connection parameters. In the component- managed sign-on case, an application component passes security information (example: username, password) through the ConnectionSpec instance.

        It is important to note that the properties passed through the getConnection method should be client-specific (example: username, password, language) and not related to the configuration of a target EIS instance (example: port number, server name). The ManagedConnectionFactory instance is configured with complete set of properties required for the creation of a connection to an EIS instance.

        Parameters:
        properties - Connection parameters and security information specified as ConnectionSpec instance
        Returns:
        Connection instance
        Throws:
        ResourceException - Failed to get a connection to the EIS instance. Examples of error cases are:
        • Invalid specification of input parameters
        • Invalid configuration of ManagedConnectionFactory-- example: invalid server name
        • Application server-internal error--example: connection pool related error
        • Communication error
        • EIS-specific error--example: EIS not active
        • Resource adapter-internal error
        • Security related error; example: invalid user
        • Failure to allocate system resources
        See Also:
        ConnectionSpec

      • getRecordFactory

        RecordFactory getRecordFactory()
                               throws ResourceException
        Gets a RecordFactory instance. The RecordFactory is used for the creation of generic Record instances.
        Returns:
        RecordFactory RecordFactory instance
        Throws:
        ResourceException - Failed to create a RecordFactory
        NotSupportedException - Operation not supported

      • getMetaData

        ResourceAdapterMetaData getMetaData()
                                    throws ResourceException
        Gets metadata for the Resource Adapter. Note that the metadata information is about the ResourceAdapter and not the EIS instance. An invocation of this method does not require that an active connection to an EIS instance should have been established.
        Returns:
        ResourceAdapterMetaData instance
        Throws:
        ResourceException - Failed to get metadata information about the resource adapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionMetaData (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface ConnectionMetaData

  • public interface ConnectionMetaData
    The interface ConnectionMetaData provides information about an EIS instance connected through a Connection instance. A component calls the method Connection.getMetaData to get a ConnectionMetaData instance.
    Version:
    0.8
    Author:
    Rahul Sharma
    See Also:
    Connection, ResultSetInfo

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getEISProductName()
      Returns product name of the underlying EIS instance connected through the Connection that produced this metadata.
      String getEISProductVersion()
      Returns product version of the underlying EIS instance.
      String getUserName()
      Returns the user name for an active connection as known to the underlying EIS instance.

    • Method Detail

      • getEISProductName

        String getEISProductName()
                         throws ResourceException
        Returns product name of the underlying EIS instance connected through the Connection that produced this metadata.
        Returns:
        Product name of the EIS instance
        Throws:
        ResourceException - Failed to get the information for the EIS instance

      • getEISProductVersion

        String getEISProductVersion()
                            throws ResourceException
        Returns product version of the underlying EIS instance.
        Returns:
        Product version of an EIS instance.
        Throws:
        ResourceException - Failed to get the information for the EIS instance

      • getUserName

        String getUserName()
                   throws ResourceException
        Returns the user name for an active connection as known to the underlying EIS instance. The name corresponds the resource principal under whose security context a connection to the EIS instance has been established.
        Returns:
        String representing the user name
        Throws:
        ResourceException - Failed to get the information for the EIS instance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionSpec (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface ConnectionSpec

  • public interface ConnectionSpec
    ConnectionSpec is used by an application component to pass connection request-specific properties to the ConnectionFactory. getConnection method.

    It is recommended that the ConnectionSpec interface be implemented as a JavaBean to support tools. The properties on the ConnectionSpec implementation class must be defined through the getter and setter methods pattern.

    The CCI specification defines a set of standard properties for an ConnectionSpec. The properties are defined either on a derived interface or an implementation class of an empty ConnectionSpec interface. In addition, a resource adapter may define additional properties specific to its underlying EIS.

    Version:
    1.0 Public Draft 1
    Author:
    Rahul Sharma
    See Also:
    ConnectionFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IndexedRecord (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface IndexedRecord

  • All Superinterfaces:
    Cloneable, Collection, Iterable, List, Record, Serializable

    public interface IndexedRecord
extends Record, List, Serializable
    IndexedRecord represents an ordered collection of record elements based on the java.util.List interface. This interface allows a client to access elements by their integer index (position in the list) and search for elements in the List.
    Since:
    0.8
    Author:
    Rahul Sharma

    • Method Summary

      • Methods inherited from interface javax.resource.cci.Record

        clone, equals, getRecordName, getRecordShortDescription, hashCode, setRecordName, setRecordShortDescription

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, remove, remove, removeAll, retainAll, set, size, subList, toArray, toArray
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Interaction (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface Interaction

  • public interface Interaction
    The javax.resource.cci.Interaction enables a component to execute EIS functions. An Interaction instance supports the following ways of interacting with an EIS instance:
    • execute method that takes an input Record, output Record and an InteractionSpec. This method executes the EIS function represented by the InteractionSpec and updates the output Record
    • execute method that takes an input Record and an InteractionSpec. This method implementation executes the EIS function represented by the InteractionSpec and produces the output Record as a return value.

    An Interaction instance is created from a Connection and is required to maintain its association with the Connection instance. The close method releases all resources maintained by the resource adapter for the Interaction. The close of an Interaction instance should not close the associated Connection instance.

    Since:
    0.8
    Version:
    0.8
    Author:
    Rahul Sharma
    See Also:
    ResultSet

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearWarnings()
      Clears all the warning reported by this Interaction instance.
      void close()
      Closes the current Interaction and release all the resources held for this instance by the resource adapter.
      Record execute(InteractionSpec ispec, Record input)
      Executes an interaction represented by the InteractionSpec.
      boolean execute(InteractionSpec ispec, Record input, Record output)
      Executes an interaction represented by the InteractionSpec.
      Connection getConnection()
      Gets the Connection associated with the Interaction.
      ResourceWarning getWarnings()
      Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.

    • Method Detail

      • close

        void close()
           throws ResourceException
        Closes the current Interaction and release all the resources held for this instance by the resource adapter. The close of an Interaction instance does not close the associated Connection instance. It is recommended that Interaction instances be closed explicitly to free any held resources.
        Throws:
        ResourceException - Failed to close the Interaction instance. Invoking close on an already closed Interaction should also throw this exception.

      • getConnection

        Connection getConnection()
        Gets the Connection associated with the Interaction.
        Returns:
        Connection instance associated with the Interaction

      • execute

        boolean execute(InteractionSpec ispec,
              Record input,
              Record output)
                throws ResourceException
        Executes an interaction represented by the InteractionSpec. This form of invocation takes an input Record and updates the output Record.
        Parameters:
        ispec - InteractionSpec representing a target EIS data/function module
        input - Input Record
        output - Output Record
        Returns:
        true if execution of the EIS function has been successful and output Record has been updated; false otherwise
        Throws:
        ResourceException - Exception if execute operation fails. Examples of error cases are:
        • Resource adapter internal, EIS-specific or communication error
        • Invalid specification of an InteractionSpec, input or output record structure
        • Errors in use of input or output Record
        • Invalid connection associated with this Interaction
        NotSupportedException - Operation not supported

      • execute

        Record execute(InteractionSpec ispec,
             Record input)
               throws ResourceException
        Executes an interaction represented by the InteractionSpec. This form of invocation takes an input Record and returns an output Record if the execution of the Interaction has been successfull.
        Parameters:
        ispec - InteractionSpec representing a target EIS data/function module
        input - Input Record
        Returns:
        output Record if execution of the EIS function has been successful; null otherwise
        Throws:
        ResourceException - Exception if execute operation fails. Examples of error cases are:
        • Resource adapter internal, EIS-specific or communication error
        • Invalid specification of an InteractionSpec or input record structure
        • Errors in use of input Record or creation of an output Record
        • Invalid connection associated with this Interaction
        NotSupportedException - Operation not supported

      • getWarnings

        ResourceWarning getWarnings()
                            throws ResourceException
        Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.
        Returns:
        ResourceWarning at top of the warning chain
        Throws:
        ResourceException - Failed to get ResourceWarnings associated with Interaction

      • clearWarnings

        void clearWarnings()
                   throws ResourceException
        Clears all the warning reported by this Interaction instance. After a call to this method, the method getWarnings will return null until a new warning is reported for this Interaction.
        Throws:
        ResourceException - Failed to clear ResourceWarnings associated with Interaction
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InteractionSpec (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface InteractionSpec

  • All Superinterfaces:
    Serializable

    public interface InteractionSpec
extends Serializable
    An InteractionSpec holds properties for driving an Interaction with an EIS instance. An InteractionSpec is used by an Interaction to execute the specified function on an underlying EIS.

    The CCI specification defines a set of standard properties for an InteractionSpec. An InteractionSpec implementation is not required to support a standard property if that property does not apply to its underlying EIS.

    The InteractionSpec implementation class must provide getter and setter methods for each of its supported properties. The getter and setter methods convention should be based on the Java Beans design pattern.

    The standard properties are as follows:

    • FunctionName: name of an EIS function
    • InteractionVerb: mode of interaction with an EIS instance: SYNC_SEND, SYNC_SEND_RECEIVE, SYNC_RECEIVE
    • ExecutionTimeout: the number of milliseconds an Interaction will wait for an EIS to execute the specified function

    The following standard properties are used to give hints to an Interaction instance about the ResultSet requirements:

    • FetchSize
    • FetchDirection
    • MaxFieldSize
    • ResultSetType
    • ResultSetConcurrency

    A CCI implementation can provide additional properties beyond that described in the InteractionSpec interface. Note that the format and type of the additional properties is specific to an EIS and is outside the scope of the CCI specification.

    It is required that the InteractionSpec interface be implemented as a JavaBean for the toolability support. The properties on the InteractionSpec implementation class should be defined through the getter and setter methods pattern. An implementation class for InteractionSpec interface is required to implement the java.io.Serializable interface.

    Since:
    0.8
    Version:
    0.8
    Author:
    Rahul Sharma
    See Also:
    Interaction

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int SYNC_RECEIVE
      The execution of an Interaction results in a synchronous receive of an output Record.
      static int SYNC_SEND
      Interaction Verb type: The execution of an Interaction does only a send to the target EIS instance.
      static int SYNC_SEND_RECEIVE
      Interaction Verb type: The execution of an Interaction sends a request to the EIS instance and receives response synchronously.

    • Field Detail

      • SYNC_SEND

        static final int SYNC_SEND
        Interaction Verb type: The execution of an Interaction does only a send to the target EIS instance. The input record is sent to the EIS instance without any synchronous response in terms of an output Record or ResultSet.
        See Also:
        Constant Field Values

      • SYNC_SEND_RECEIVE

        static final int SYNC_SEND_RECEIVE
        Interaction Verb type: The execution of an Interaction sends a request to the EIS instance and receives response synchronously. The input record is sent to the EIS instance with the output received either as Record or CCIResultSet.
        See Also:
        Constant Field Values

      • SYNC_RECEIVE

        static final int SYNC_RECEIVE
        The execution of an Interaction results in a synchronous receive of an output Record. An example is: a session bean gets a method invocation and it uses this SEND_RECEIVE form of interaction to retrieve messages that have been delivered to a message queue.
        See Also:
        Constant Field Values
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.resource.cci (Java(TM) EE 7 Specification APIs)

javax.resource.cci

Interfaces

  • Connection
  • ConnectionFactory
  • ConnectionMetaData
  • ConnectionSpec
  • IndexedRecord
  • Interaction
  • InteractionSpec
  • LocalTransaction
  • MappedRecord
  • MessageListener
  • Record
  • RecordFactory
  • ResourceAdapterMetaData
  • ResultSet
  • ResultSetInfo
  • Streamable

Exceptions

  • ResourceWarning


javax.resource.cci (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.resource.cci

The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

See: Description

  • Interface Summary
    Interface Description
    Connection
    A Connection represents an application-level handle that is used by a client to access the underlying physical connection.
    ConnectionFactory
    ConnectionFactory provides an interface for getting connection to an EIS instance.
    ConnectionMetaData
    The interface ConnectionMetaData provides information about an EIS instance connected through a Connection instance.
    ConnectionSpec
    ConnectionSpec is used by an application component to pass connection request-specific properties to the ConnectionFactory.
    IndexedRecord
    IndexedRecord represents an ordered collection of record elements based on the java.util.List interface.
    Interaction
    The javax.resource.cci.Interaction enables a component to execute EIS functions.
    InteractionSpec
    An InteractionSpec holds properties for driving an Interaction with an EIS instance.
    LocalTransaction
    The LocalTransaction defines a transaction demarcation interface for resource manager local transactions.
    MappedRecord
    The interface javax.resource.cci.MappedRecord is used for key-value map based representation of record elements.
    MessageListener
    This serves as a request-response message listener type that message endpoints (message-driven beans) may implement.
    Record
    The javax.resource.cci.Record interface is the base interface for the representation of an input or output to the execute methods defined on an Interaction.
    RecordFactory
    The RecordFactory interface is used for creating MappedRecord and IndexedRecord instances.
    ResourceAdapterMetaData
    The interface javax.resource.cci.ResourceAdapterMetaData provides information about capabilities of a resource adapter implementation.
    ResultSet
    A ResultSet represents tabular data that is retrieved from an EIS instance by the execution of an Interaction..
    ResultSetInfo
    The interface javax.resource.cci.ResultSetInfo provides information on the support provided for ResultSet by a connected EIS instance.
    Streamable
    Streamable interface enables a resource adapter to extract data from an input Record or set data into an output Record as a stream of bytes.
  • Exception Summary
    Exception Description
    ResourceWarning
    A ResourceWarning provides information on warnings related to execution of an interaction with an EIS.

Package javax.resource.cci Description

The javax.resource.cci package contains API specification for the Common Client Interface (CCI).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.resource.cci Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.resource.cci

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.cci.ResourceWarning

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.sql.ResultSet (also extends java.sql.Wrapper)
      • javax.resource.cci.ResultSet (also extends javax.resource.cci.Record)
  • java.lang.Cloneable
    • javax.resource.cci.Record (also extends java.io.Serializable)
      • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, java.io.Serializable)
      • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, java.io.Serializable)
      • javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
  • javax.resource.cci.Connection
  • javax.resource.cci.ConnectionMetaData
  • javax.resource.cci.ConnectionSpec
  • javax.resource.cci.Interaction
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.List<E>
        • javax.resource.cci.IndexedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
  • javax.resource.cci.LocalTransaction
  • java.util.Map<K,V>
    • javax.resource.cci.MappedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
  • javax.resource.cci.MessageListener
  • javax.resource.cci.RecordFactory
  • javax.naming.Referenceable
    • javax.resource.Referenceable
      • javax.resource.cci.ConnectionFactory (also extends java.io.Serializable)
  • javax.resource.cci.ResourceAdapterMetaData
  • javax.resource.cci.ResultSetInfo
  • java.io.Serializable
    • javax.resource.cci.ConnectionFactory (also extends javax.resource.Referenceable)
    • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, javax.resource.cci.Record)
    • javax.resource.cci.InteractionSpec
    • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, javax.resource.cci.Record)
    • javax.resource.cci.Record (also extends java.lang.Cloneable)
      • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, java.io.Serializable)
      • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, java.io.Serializable)
      • javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
  • javax.resource.cci.Streamable
  • java.sql.Wrapper
    • java.sql.ResultSet (also extends java.lang.AutoCloseable)
      • javax.resource.cci.ResultSet (also extends javax.resource.cci.Record)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LocalTransaction (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface LocalTransaction

  • public interface LocalTransaction
    The LocalTransaction defines a transaction demarcation interface for resource manager local transactions. Note that this interface is used for application level local transaction demarcation. The system contract level LocalTransaction interface (as defined in the javax.resource.spi package) is used by the container for local transaction management.

    A local transaction is managed internal to a resource manager. There is no external transaction manager involved in the coordination of such transactions.

    A CCI implementation can (but is not required to) implement the LocalTransaction interface. If the LocalTransaction interface is supported by a CCI implementation, then the method Connection.getLocalTransaction should return a LocalTransaction instance. A component can then use the returned LocalTransaction to demarcate a resource manager local transaction (associated with the Connection instance) on the underlying EIS instance.

    Since:
    0.8
    Author:
    Rahul Sharma
    See Also:
    Connection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void begin()
      Begins a local transaction on an EIS instance.
      void commit()
      Commits the current local transaction and release all locks held by the underlying EIS instance.
      void rollback()
      Rollbacks the current resource manager local transaction.

    • Method Detail

      • begin

        void begin()
           throws ResourceException
        Begins a local transaction on an EIS instance.
        Throws:
        ResourceException - Failed to begin a local transaction. Examples of error cases are:
        • Resource adapter internal or EIS-specific error
        • Connection is already participating in a local or JTA transaction

      • commit

        void commit()
            throws ResourceException
        Commits the current local transaction and release all locks held by the underlying EIS instance.
        Throws:
        ResourceException - Failed to commit a local transaction. Examples of error cases are:
        • Resource adapter internal or EIS-specific error
        • Violation of integrity constraints, deadlock detection, communication failure during transaction completion, or any retry requirement
        • Connection is participating in an active JTA transaction
        • Invalid transaction context; commit operation invoked without an active transaction context

      • rollback

        void rollback()
              throws ResourceException
        Rollbacks the current resource manager local transaction.
        Throws:
        ResourceException - Failed to rollback a local transaction. Examples of error cases are:
        • Resource adapter internal or EIS-specific error
        • Connection is participating in an active JTA transaction
        • Invalid transaction context; rollback operation invoked without an active transaction context
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MappedRecord (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface MappedRecord

  • All Superinterfaces:
    Cloneable, Map, Record, Serializable

    public interface MappedRecord
extends Record, Map, Serializable
    The interface javax.resource.cci.MappedRecord is used for key-value map based representation of record elements. The MappedRecord interface extends both Record and java.util.Mapinterfaces.
    Version:
    0.8
    Author:
    Rahul Sharma

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Method Summary

      • Methods inherited from interface javax.resource.cci.Record

        clone, equals, getRecordName, getRecordShortDescription, hashCode, setRecordName, setRecordShortDescription

      • Methods inherited from interface java.util.Map

        clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface MessageListener

  • public interface MessageListener
    This serves as a request-response message listener type that message endpoints (message-driven beans) may implement. This allows an EIS to communicate with an endpoint using a request-response style.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Record onMessage(Record inputData)
      This method allows an EIS to call a message endpoint using a request-response style communication.

    • Method Detail

      • onMessage

        Record onMessage(Record inputData)
                 throws ResourceException
        This method allows an EIS to call a message endpoint using a request-response style communication.
        Parameters:
        inputData - a Record instance.
        Returns:
        a Record instance or null.
        Throws:
        ResourceException - indicates an exceptional condition.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Record (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface Record

  • All Superinterfaces:
    Cloneable, Serializable
    All Known Subinterfaces:
    IndexedRecord, MappedRecord, ResultSet

    public interface Record
extends Cloneable, Serializable
    The javax.resource.cci.Record interface is the base interface for the representation of an input or output to the execute methods defined on an Interaction.

    The Record interface can be extended to form a one of the following representations:

    • MappedRecord: A key-value pair based collection represents a record. This interface is based on the java.util.Map
    • IndexedRecord:An ordered and indexed collection represents a record. This interface is based on the java.util.List.
    • JavaBean based representation of an EIS abstraction: An example is a custom record generated to represent a purchase order in an ERP system.
    • javax.resource.cci.ResultSet: This interface extends both java.sql.ResultSet and javax.resource.cci.Record. A ResultSet represents tabular data.

    A MappedRecord or IndexedRecord can contain another Record. This means that MappedRecord and IndexedRecord can be used to create a hierarchical structure of any arbitrary depth. A basic Java type is used as the leaf element of a hierarchical structure represented by a MappedRecord or IndexedRecord.

    Version:
    0.8
    Author:
    Rahul Sharma
    See Also:
    Interaction, ResultSet

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object clone()
      Creates and returns a copy of this object.
      boolean equals(Object other)
      Check if this instance is equal to another Record.
      String getRecordName()
      Gets the name of the Record.
      String getRecordShortDescription()
      Gets a short description string for the Record.
      int hashCode()
      Returns the hash code for the Record instance.
      void setRecordName(String name)
      Sets the name of the Record.
      void setRecordShortDescription(String description)
      Sets a short description string for the Record.

    • Method Detail

      • getRecordName

        String getRecordName()
        Gets the name of the Record.
        Returns:
        String representing name of the Record

      • setRecordName

        void setRecordName(String name)
        Sets the name of the Record.
        Parameters:
        name - Name of the Record

      • setRecordShortDescription

        void setRecordShortDescription(String description)
        Sets a short description string for the Record. This property is used primarily by application development tools.
        Parameters:
        description - Description of the Record

      • getRecordShortDescription

        String getRecordShortDescription()
        Gets a short description string for the Record. This property is used primarily by application development tools.
        Returns:
        String representing a short description of the Record

      • equals

        boolean equals(Object other)
        Check if this instance is equal to another Record.
        Overrides:
        equals in class Object
        Returns:
        true if two instances are equal

      • hashCode

        int hashCode()
        Returns the hash code for the Record instance.
        Overrides:
        hashCode in class Object
        Returns:
        hash code

      • clone

        Object clone()
             throws CloneNotSupportedException
        Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object.
        Returns:
        a clone of this instance.
        Throws:
        CloneNotSupportedException - If the object's class does not support the Cloneable interface Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RecordFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface RecordFactory

  • public interface RecordFactory
    The RecordFactory interface is used for creating MappedRecord and IndexedRecord instances. Note that the RecordFactory is only used for creation of generic record instances. A CCI implementation provides an implementation class for the RecordFactory interface.
    Since:
    0.8
    Author:
    Rahul Sharma
    See Also:
    IndexedRecord, MappedRecord

    • Method Summary

      Methods
      Modifier and Type Method and Description
      IndexedRecord createIndexedRecord(String recordName)
      Creates a IndexedRecord.
      MappedRecord createMappedRecord(String recordName)
      Creates a MappedRecord.

    • Method Detail

      • createMappedRecord

        MappedRecord createMappedRecord(String recordName)
                                throws ResourceException
        Creates a MappedRecord. The method takes the name of the record that is to be created by the RecordFactory. The name of the record acts as a pointer to the meta information (stored in the metadata repository) for a specific record type.
        Parameters:
        recordName - Name of the Record
        Returns:
        MappedRecord
        Throws:
        ResourceException - Failed to create a MappedRecord. Example error cases are:
        • Invalid specification of record name
        • Resource adapter internal error
        • Failed to access metadata repository
        NotSupportedException - Operation not supported

      • createIndexedRecord

        IndexedRecord createIndexedRecord(String recordName)
                                  throws ResourceException
        Creates a IndexedRecord. The method takes the name of the record that is to be created by the RecordFactory. The name of the record acts as a pointer to the meta information (stored in the metadata repository) for a specific record type.
        Parameters:
        recordName - Name of the Record
        Returns:
        IndexedRecord
        Throws:
        ResourceException - Failed to create an IndexedRecord. Example error cases are:
        • Invalid specification of record name
        • Resource adapter internal error
        • Failed to access metadata repository
        NotSupportedException - Operation not supported
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceAdapterMetaData (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface ResourceAdapterMetaData

  • public interface ResourceAdapterMetaData
    The interface javax.resource.cci.ResourceAdapterMetaData provides information about capabilities of a resource adapter implementation. Note that this interface does not provide information about an EIS instance that is connected through the resource adapter.

    A CCI client uses a ConnectionFactory.getMetaData to get metadata information about the resource adapter. The getMetaData method does not require that an active connection to an EIS instance should have been established.

    The ResourceAdapterMetaData can be extended to provide more information specific to a resource adapter implementation.

    Since:
    0.8
    Version:
    0.8
    Author:
    Rahul Sharma
    See Also:
    ConnectionFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAdapterName()
      Gets a tool displayable name of the resource adapter.
      String getAdapterShortDescription()
      Gets a tool displayable short desription of the resource adapter.
      String getAdapterVendorName()
      Gets the name of the vendor that has provided the resource adapter.
      String getAdapterVersion()
      Gets the version of the resource adapter.
      String[] getInteractionSpecsSupported()
      Returns an array of fully-qualified names of InteractionSpec types supported by the CCI implementation for this resource adapter.
      String getSpecVersion()
      Returns a string representation of the version of the connector architecture specification that is supported by the resource adapter.
      boolean supportsExecuteWithInputAndOutputRecord()
      Returns true if the implementation class for the Interaction interface implements public boolean execute(InteractionSpec ispec, Record input, Record output) method; otherwise the method returns false.
      boolean supportsExecuteWithInputRecordOnly()
      Returns true if the implementation class for the Interaction interface implements public Record execute(InteractionSpec ispec, Record input) method; otherwise the method returns false.
      boolean supportsLocalTransactionDemarcation()
      Returns true if the resource adapter implements the LocalTransaction interface and supports local transaction demarcation on the underlying EIS instance through the LocalTransaction interface.

    • Method Detail

      • getAdapterVersion

        String getAdapterVersion()
        Gets the version of the resource adapter.
        Returns:
        String representing version of the resource adapter

      • getAdapterVendorName

        String getAdapterVendorName()
        Gets the name of the vendor that has provided the resource adapter.
        Returns:
        String representing name of the vendor that has provided the resource adapter

      • getAdapterName

        String getAdapterName()
        Gets a tool displayable name of the resource adapter.
        Returns:
        String representing the name of the resource adapter

      • getAdapterShortDescription

        String getAdapterShortDescription()
        Gets a tool displayable short desription of the resource adapter.
        Returns:
        String describing the resource adapter

      • getSpecVersion

        String getSpecVersion()
        Returns a string representation of the version of the connector architecture specification that is supported by the resource adapter.
        Returns:
        String representing the supported version of the connector architecture

      • getInteractionSpecsSupported

        String[] getInteractionSpecsSupported()
        Returns an array of fully-qualified names of InteractionSpec types supported by the CCI implementation for this resource adapter. Note that the fully-qualified class name is for the implementation class of an InteractionSpec. This method may be used by tools vendor to find information on the supported InteractionSpec types. The method should return an array of length 0 if the CCI implementation does not define specific InteractionSpec types.
        Returns:
        Array of fully-qualified class names of InteractionSpec classes supported by this resource adapter's CCI implementation
        See Also:
        InteractionSpec

      • supportsExecuteWithInputAndOutputRecord

        boolean supportsExecuteWithInputAndOutputRecord()
        Returns true if the implementation class for the Interaction interface implements public boolean execute(InteractionSpec ispec, Record input, Record output) method; otherwise the method returns false.
        Returns:
        boolean depending on method support
        See Also:
        Interaction

      • supportsExecuteWithInputRecordOnly

        boolean supportsExecuteWithInputRecordOnly()
        Returns true if the implementation class for the Interaction interface implements public Record execute(InteractionSpec ispec, Record input) method; otherwise the method returns false.
        Returns:
        boolean depending on method support
        See Also:
        Interaction

      • supportsLocalTransactionDemarcation

        boolean supportsLocalTransactionDemarcation()
        Returns true if the resource adapter implements the LocalTransaction interface and supports local transaction demarcation on the underlying EIS instance through the LocalTransaction interface.
        Returns:
        true if resource adapter supports resource manager local transaction demarcation through LocalTransaction interface; false otherwise
        See Also:
        LocalTransaction
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceWarning (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Class ResourceWarning

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.cci.ResourceWarning
  • All Implemented Interfaces:
    Serializable

    public class ResourceWarning
extends ResourceException
    A ResourceWarning provides information on warnings related to execution of an interaction with an EIS. Warnings are silently chained to the object whose method caused it to be reported.
    See Also:
    Interaction.getWarnings(), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceWarning()
      Constructs a new instance with null as its detail message.
      ResourceWarning(String message)
      Constructs a new instance with the specified detail message.
      ResourceWarning(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      ResourceWarning(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      ResourceWarning(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ResourceWarning getLinkedWarning()
      Deprecated.
      J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
      void setLinkedWarning(ResourceWarning warning)
      Deprecated.
      J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ResourceWarning

        public ResourceWarning()
        Constructs a new instance with null as its detail message.

      • ResourceWarning

        public ResourceWarning(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • ResourceWarning

        public ResourceWarning(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • ResourceWarning

        public ResourceWarning(String message,
               Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • ResourceWarning

        public ResourceWarning(String message,
               String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.

    • Method Detail

      • getLinkedWarning

        public ResourceWarning getLinkedWarning()
        Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
        Retrieves the warning chained to this ResourceWarning object.
        Returns:
        next ResourceWarning in the chain; null if none.

      • setLinkedWarning

        public void setLinkedWarning(ResourceWarning warning)
        Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
        Adds an ResourceWarning object to the end of the chain.
        Parameters:
        warning - ResourceWarning to be added to the chain.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResultSet (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface ResultSet

  • All Superinterfaces:
    AutoCloseable, Cloneable, Record, ResultSet, Serializable, Wrapper

    public interface ResultSet
extends Record, ResultSet
    A ResultSet represents tabular data that is retrieved from an EIS instance by the execution of an Interaction.. The CCI ResultSet is based on the JDBC ResultSet.

    Refer the CCI specification in Connectors 1.0 for detailed requirements on the implementation of a CCI ResultSet.

    Since:
    0.8
    Author:
    Rahul Sharma
    See Also:
    ResultSet

    • Field Summary

      • Fields inherited from interface java.sql.ResultSet

        CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE

    • Method Summary

      • Methods inherited from interface javax.resource.cci.Record

        clone, equals, getRecordName, getRecordShortDescription, hashCode, setRecordName, setRecordShortDescription

      • Methods inherited from interface java.sql.ResultSet

        absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, next, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull

      • Methods inherited from interface java.sql.Wrapper

        isWrapperFor, unwrap
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResultSetInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface ResultSetInfo

  • public interface ResultSetInfo
    The interface javax.resource.cci.ResultSetInfo provides information on the support provided for ResultSet by a connected EIS instance. A component calls the method Connection.getResultInfo to get the ResultSetInfo instance.

    A CCI implementation is not required to support javax.resource.cci.ResultSetInfo interface. The implementation of this interface is provided only if the CCI supports the ResultSet facility.

    Version:
    0.9
    Author:
    Rahul Sharma
    See Also:
    Connection, ResultSet, ConnectionMetaData

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean deletesAreDetected(int type)
      Indicates whether or not a visible row delete can be detected by calling ResultSet.rowDeleted.
      boolean insertsAreDetected(int type)
      Indicates whether or not a visible row insert can be detected by calling ResultSet.rowInserted.
      boolean othersDeletesAreVisible(int type)
      Indicates whether deletes made by others are visible.
      boolean othersInsertsAreVisible(int type)
      Indicates whether inserts made by others are visible.
      boolean othersUpdatesAreVisible(int type)
      Indicates whether updates made by others are visible.
      boolean ownDeletesAreVisible(int type)
      Indicates whether a ResultSet's own deletes are visible.
      boolean ownInsertsAreVisible(int type)
      Indicates whether a ResultSet's own inserts are visible.
      boolean ownUpdatesAreVisible(int type)
      Indicates whether a ResultSet's own updates are visible.
      boolean supportsResultSetType(int type)
      Indicates whether or not a resource adapter supports a type of ResultSet.
      boolean supportsResultTypeConcurrency(int type, int concurrency)
      Indicates whether or not a resource adapter supports the concurrency type in combination with the given ResultSet type/
      boolean updatesAreDetected(int type)
      Indicates whether or not a visible row update can be detected by calling the method ResultSet.rowUpdated.

    • Method Detail

      • updatesAreDetected

        boolean updatesAreDetected(int type)
                           throws ResourceException
        Indicates whether or not a visible row update can be detected by calling the method ResultSet.rowUpdated.
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        Returns:
        true if changes are detected by the result set type; false otherwise
        Throws:
        ResourceException - Failed to get the information
        See Also:
        ResultSet.rowUpdated()

      • insertsAreDetected

        boolean insertsAreDetected(int type)
                           throws ResourceException
        Indicates whether or not a visible row insert can be detected by calling ResultSet.rowInserted.
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        Returns:
        true if changes are detected by the result set type; false otherwise
        Throws:
        ResourceException - Failed to get the information
        See Also:
        ResultSet.rowInserted()

      • deletesAreDetected

        boolean deletesAreDetected(int type)
                           throws ResourceException
        Indicates whether or not a visible row delete can be detected by calling ResultSet.rowDeleted. If deletesAreDetected returns false, then deleted rows are removed from the ResultSet.
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        Returns:
        true if changes are detected by the result set type; false otherwise
        Throws:
        ResourceException - Failed to get the information
        See Also:
        ResultSet.rowDeleted()

      • supportsResultSetType

        boolean supportsResultSetType(int type)
                              throws ResourceException
        Indicates whether or not a resource adapter supports a type of ResultSet.
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        Returns:
        true if ResultSet type supported; false otherwise
        Throws:
        ResourceException - Failed to get the information

      • supportsResultTypeConcurrency

        boolean supportsResultTypeConcurrency(int type,
                                    int concurrency)
                                      throws ResourceException
        Indicates whether or not a resource adapter supports the concurrency type in combination with the given ResultSet type/
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        concurrency - ResultSet concurrency type defined in java.sql.ResultSet
        Returns:
        true if the specified combination supported; false otherwise
        Throws:
        ResourceException - Failed to get the information

      • othersUpdatesAreVisible

        boolean othersUpdatesAreVisible(int type)
                                throws ResourceException
        Indicates whether updates made by others are visible.
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        Returns:
        true if updates by others are visible for the ResultSet type; false otherwise
        Throws:
        ResourceException - Failed to get the information

      • othersDeletesAreVisible

        boolean othersDeletesAreVisible(int type)
                                throws ResourceException
        Indicates whether deletes made by others are visible.
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        Returns:
        true if deletes by others are visible for the ResultSet type; false otherwise
        Throws:
        ResourceException - Failed to get the information

      • othersInsertsAreVisible

        boolean othersInsertsAreVisible(int type)
                                throws ResourceException
        Indicates whether inserts made by others are visible.
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        Returns:
        true if inserts by others are visible for the ResultSet type; false otherwise
        Throws:
        ResourceException - Failed to get the information

      • ownUpdatesAreVisible

        boolean ownUpdatesAreVisible(int type)
                             throws ResourceException
        Indicates whether a ResultSet's own updates are visible.
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        Returns:
        true if updates are visible for the ResultSet type; false otherwise
        Throws:
        ResourceException - Failed to get the information

      • ownInsertsAreVisible

        boolean ownInsertsAreVisible(int type)
                             throws ResourceException
        Indicates whether a ResultSet's own inserts are visible.
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        Returns:
        true if inserts are visible for the ResultSet type; false otherwise
        Throws:
        ResourceException - Failed to get the information

      • ownDeletesAreVisible

        boolean ownDeletesAreVisible(int type)
                             throws ResourceException
        Indicates whether a ResultSet's own deletes are visible.
        Parameters:
        type - type of the ResultSet i.e. ResultSet.TYPE_XXX
        Returns:
        true if inserts are visible for the ResultSet type; false otherwise
        Throws:
        ResourceException - Failed to get the information
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Streamable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.cci

Interface Streamable

  • public interface Streamable
    Streamable interface enables a resource adapter to extract data from an input Record or set data into an output Record as a stream of bytes.

    The Streamable interface provides a resource adapter's view of the data that has been set in a Record instance by a component.

    The Streamable interface is not directly used by a component. It is used by a resource adapter implementation. A component uses Record or any derived interfaces to manage records.

    Since:
    0.8
    Author:
    Rahul Sharma
    See Also:
    Record

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void read(InputStream istream)
      Read data from an InputStream and initialize fields of a Streamable object.
      void write(OutputStream ostream)
      Write fields of a Streamable object to an OutputStream

    • Method Detail

      • read

        void read(InputStream istream)
          throws IOException
        Read data from an InputStream and initialize fields of a Streamable object.
        Parameters:
        istream - InputStream that represents a resource adapter specific internal representation of fields of a Streamable object
        Throws:
        IOException

      • write

        void write(OutputStream ostream)
           throws IOException
        Write fields of a Streamable object to an OutputStream
        Parameters:
        ostream - OutputStream that holds value of a Streamable object
        Throws:
        IOException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.resource.cci (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.resource.cci

  • Packages that use javax.resource.cci
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).
  • Classes in javax.resource.cci used by javax.resource.cci
    Class and Description
    Connection
    A Connection represents an application-level handle that is used by a client to access the underlying physical connection.
    ConnectionMetaData
    The interface ConnectionMetaData provides information about an EIS instance connected through a Connection instance.
    ConnectionSpec
    ConnectionSpec is used by an application component to pass connection request-specific properties to the ConnectionFactory.
    IndexedRecord
    IndexedRecord represents an ordered collection of record elements based on the java.util.List interface.
    Interaction
    The javax.resource.cci.Interaction enables a component to execute EIS functions.
    InteractionSpec
    An InteractionSpec holds properties for driving an Interaction with an EIS instance.
    LocalTransaction
    The LocalTransaction defines a transaction demarcation interface for resource manager local transactions.
    MappedRecord
    The interface javax.resource.cci.MappedRecord is used for key-value map based representation of record elements.
    Record
    The javax.resource.cci.Record interface is the base interface for the representation of an input or output to the execute methods defined on an Interaction.
    RecordFactory
    The RecordFactory interface is used for creating MappedRecord and IndexedRecord instances.
    ResourceAdapterMetaData
    The interface javax.resource.cci.ResourceAdapterMetaData provides information about capabilities of a resource adapter implementation.
    ResourceWarning
    A ResourceWarning provides information on warnings related to execution of an interaction with an EIS.
    ResultSetInfo
    The interface javax.resource.cci.ResultSetInfo provides information on the support provided for ResultSet by a connected EIS instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.cci.ResourceWarning (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.cci.ResourceWarning

  • Packages that use ResourceWarning
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of ResourceWarning in javax.resource.cci

      Methods in javax.resource.cci that return ResourceWarning
      Modifier and Type Method and Description
      ResourceWarning ResourceWarning.getLinkedWarning()
      Deprecated.
      J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
      ResourceWarning Interaction.getWarnings()
      Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.
      Methods in javax.resource.cci with parameters of type ResourceWarning
      Modifier and Type Method and Description
      void ResourceWarning.setLinkedWarning(ResourceWarning warning)
      Deprecated.
      J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.Connection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.Connection

  • Packages that use Connection
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of Connection in javax.resource.cci

      Methods in javax.resource.cci that return Connection
      Modifier and Type Method and Description
      Connection Interaction.getConnection()
      Gets the Connection associated with the Interaction.
      Connection ConnectionFactory.getConnection()
      Gets a connection to an EIS instance.
      Connection ConnectionFactory.getConnection(ConnectionSpec properties)
      Gets a connection to an EIS instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.ConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.ConnectionFactory

No usage of javax.resource.cci.ConnectionFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.ConnectionMetaData (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.ConnectionMetaData

  • Packages that use ConnectionMetaData
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of ConnectionMetaData in javax.resource.cci

      Methods in javax.resource.cci that return ConnectionMetaData
      Modifier and Type Method and Description
      ConnectionMetaData Connection.getMetaData()
      Gets the information on the underlying EIS instance represented through an active connection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.ConnectionSpec (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.ConnectionSpec

  • Packages that use ConnectionSpec
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of ConnectionSpec in javax.resource.cci

      Methods in javax.resource.cci with parameters of type ConnectionSpec
      Modifier and Type Method and Description
      Connection ConnectionFactory.getConnection(ConnectionSpec properties)
      Gets a connection to an EIS instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.IndexedRecord (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.IndexedRecord

  • Packages that use IndexedRecord
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of IndexedRecord in javax.resource.cci

      Methods in javax.resource.cci that return IndexedRecord
      Modifier and Type Method and Description
      IndexedRecord RecordFactory.createIndexedRecord(String recordName)
      Creates a IndexedRecord.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.Interaction (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.Interaction

  • Packages that use Interaction
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of Interaction in javax.resource.cci

      Methods in javax.resource.cci that return Interaction
      Modifier and Type Method and Description
      Interaction Connection.createInteraction()
      Creates an Interaction associated with this Connection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.InteractionSpec (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.InteractionSpec

  • Packages that use InteractionSpec
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of InteractionSpec in javax.resource.cci

      Methods in javax.resource.cci with parameters of type InteractionSpec
      Modifier and Type Method and Description
      Record Interaction.execute(InteractionSpec ispec, Record input)
      Executes an interaction represented by the InteractionSpec.
      boolean Interaction.execute(InteractionSpec ispec, Record input, Record output)
      Executes an interaction represented by the InteractionSpec.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.LocalTransaction (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.LocalTransaction

  • Packages that use LocalTransaction
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of LocalTransaction in javax.resource.cci

      Methods in javax.resource.cci that return LocalTransaction
      Modifier and Type Method and Description
      LocalTransaction Connection.getLocalTransaction()
      Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.MappedRecord (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.MappedRecord

  • Packages that use MappedRecord
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of MappedRecord in javax.resource.cci

      Methods in javax.resource.cci that return MappedRecord
      Modifier and Type Method and Description
      MappedRecord RecordFactory.createMappedRecord(String recordName)
      Creates a MappedRecord.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.MessageListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.MessageListener

No usage of javax.resource.cci.MessageListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.Record (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.Record

  • Packages that use Record
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of Record in javax.resource.cci

      Subinterfaces of Record in javax.resource.cci
      Modifier and Type Interface and Description
      interface  IndexedRecord
      IndexedRecord represents an ordered collection of record elements based on the java.util.List interface.
      interface  MappedRecord
      The interface javax.resource.cci.MappedRecord is used for key-value map based representation of record elements.
      interface  ResultSet
      A ResultSet represents tabular data that is retrieved from an EIS instance by the execution of an Interaction..
      Methods in javax.resource.cci that return Record
      Modifier and Type Method and Description
      Record Interaction.execute(InteractionSpec ispec, Record input)
      Executes an interaction represented by the InteractionSpec.
      Record MessageListener.onMessage(Record inputData)
      This method allows an EIS to call a message endpoint using a request-response style communication.
      Methods in javax.resource.cci with parameters of type Record
      Modifier and Type Method and Description
      Record Interaction.execute(InteractionSpec ispec, Record input)
      Executes an interaction represented by the InteractionSpec.
      boolean Interaction.execute(InteractionSpec ispec, Record input, Record output)
      Executes an interaction represented by the InteractionSpec.
      Record MessageListener.onMessage(Record inputData)
      This method allows an EIS to call a message endpoint using a request-response style communication.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.RecordFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.RecordFactory

  • Packages that use RecordFactory
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of RecordFactory in javax.resource.cci

      Methods in javax.resource.cci that return RecordFactory
      Modifier and Type Method and Description
      RecordFactory ConnectionFactory.getRecordFactory()
      Gets a RecordFactory instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.ResourceAdapterMetaData (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.ResourceAdapterMetaData

  • Packages that use ResourceAdapterMetaData
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of ResourceAdapterMetaData in javax.resource.cci

      Methods in javax.resource.cci that return ResourceAdapterMetaData
      Modifier and Type Method and Description
      ResourceAdapterMetaData ConnectionFactory.getMetaData()
      Gets metadata for the Resource Adapter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.ResultSet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.ResultSet

No usage of javax.resource.cci.ResultSet
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.ResultSetInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.ResultSetInfo

  • Packages that use ResultSetInfo
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of ResultSetInfo in javax.resource.cci

      Methods in javax.resource.cci that return ResultSetInfo
      Modifier and Type Method and Description
      ResultSetInfo Connection.getResultSetInfo()
      Gets the information on the ResultSet functionality supported by a connected EIS instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.cci.Streamable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.cci.Streamable

No usage of javax.resource.cci.Streamable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.AdministeredObjectDefinition (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.AdministeredObjectDefinition

No usage of javax.resource.AdministeredObjectDefinition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.AdministeredObjectDefinitions (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.AdministeredObjectDefinitions

No usage of javax.resource.AdministeredObjectDefinitions
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.ConnectionFactoryDefinition (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.ConnectionFactoryDefinition

No usage of javax.resource.ConnectionFactoryDefinition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.ConnectionFactoryDefinitions (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.ConnectionFactoryDefinitions

No usage of javax.resource.ConnectionFactoryDefinitions
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.NotSupportedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.NotSupportedException

  • Packages that use NotSupportedException
    Package Description
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of NotSupportedException in javax.resource.spi.work

      Methods in javax.resource.spi.work that throw NotSupportedException
      Modifier and Type Method and Description
      void ExecutionContext.setTransactionTimeout(long timeout)
      Set the transaction timeout value for a imported transaction.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.ResourceException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.ResourceException

  • Packages that use ResourceException
    Package Description
    javax.resource
    The javax.resource package is the top-level package for the Java EE Connector API specification.
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.endpoint
    This package contains system contracts for service endpoint interactions.
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of ResourceException in javax.resource

      Subclasses of ResourceException in javax.resource
      Modifier and Type Class and Description
      class  NotSupportedException
      A NotSupportedException is thrown to indicate that callee (resource adapter or application server for system contracts) cannot execute an operation because the operation is not a supported feature.

    • Uses of ResourceException in javax.resource.cci

      Subclasses of ResourceException in javax.resource.cci
      Modifier and Type Class and Description
      class  ResourceWarning
      A ResourceWarning provides information on warnings related to execution of an interaction with an EIS.
      Methods in javax.resource.cci that throw ResourceException
      Modifier and Type Method and Description
      void LocalTransaction.begin()
      Begins a local transaction on an EIS instance.
      void Interaction.clearWarnings()
      Clears all the warning reported by this Interaction instance.
      void Interaction.close()
      Closes the current Interaction and release all the resources held for this instance by the resource adapter.
      void Connection.close()
      Initiates close of the connection handle at the application level.
      void LocalTransaction.commit()
      Commits the current local transaction and release all locks held by the underlying EIS instance.
      IndexedRecord RecordFactory.createIndexedRecord(String recordName)
      Creates a IndexedRecord.
      Interaction Connection.createInteraction()
      Creates an Interaction associated with this Connection.
      MappedRecord RecordFactory.createMappedRecord(String recordName)
      Creates a MappedRecord.
      boolean ResultSetInfo.deletesAreDetected(int type)
      Indicates whether or not a visible row delete can be detected by calling ResultSet.rowDeleted.
      Record Interaction.execute(InteractionSpec ispec, Record input)
      Executes an interaction represented by the InteractionSpec.
      boolean Interaction.execute(InteractionSpec ispec, Record input, Record output)
      Executes an interaction represented by the InteractionSpec.
      Connection ConnectionFactory.getConnection()
      Gets a connection to an EIS instance.
      Connection ConnectionFactory.getConnection(ConnectionSpec properties)
      Gets a connection to an EIS instance.
      String ConnectionMetaData.getEISProductName()
      Returns product name of the underlying EIS instance connected through the Connection that produced this metadata.
      String ConnectionMetaData.getEISProductVersion()
      Returns product version of the underlying EIS instance.
      LocalTransaction Connection.getLocalTransaction()
      Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection.
      ResourceAdapterMetaData ConnectionFactory.getMetaData()
      Gets metadata for the Resource Adapter.
      ConnectionMetaData Connection.getMetaData()
      Gets the information on the underlying EIS instance represented through an active connection.
      RecordFactory ConnectionFactory.getRecordFactory()
      Gets a RecordFactory instance.
      ResultSetInfo Connection.getResultSetInfo()
      Gets the information on the ResultSet functionality supported by a connected EIS instance.
      String ConnectionMetaData.getUserName()
      Returns the user name for an active connection as known to the underlying EIS instance.
      ResourceWarning Interaction.getWarnings()
      Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.
      boolean ResultSetInfo.insertsAreDetected(int type)
      Indicates whether or not a visible row insert can be detected by calling ResultSet.rowInserted.
      Record MessageListener.onMessage(Record inputData)
      This method allows an EIS to call a message endpoint using a request-response style communication.
      boolean ResultSetInfo.othersDeletesAreVisible(int type)
      Indicates whether deletes made by others are visible.
      boolean ResultSetInfo.othersInsertsAreVisible(int type)
      Indicates whether inserts made by others are visible.
      boolean ResultSetInfo.othersUpdatesAreVisible(int type)
      Indicates whether updates made by others are visible.
      boolean ResultSetInfo.ownDeletesAreVisible(int type)
      Indicates whether a ResultSet's own deletes are visible.
      boolean ResultSetInfo.ownInsertsAreVisible(int type)
      Indicates whether a ResultSet's own inserts are visible.
      boolean ResultSetInfo.ownUpdatesAreVisible(int type)
      Indicates whether a ResultSet's own updates are visible.
      void LocalTransaction.rollback()
      Rollbacks the current resource manager local transaction.
      boolean ResultSetInfo.supportsResultSetType(int type)
      Indicates whether or not a resource adapter supports a type of ResultSet.
      boolean ResultSetInfo.supportsResultTypeConcurrency(int type, int concurrency)
      Indicates whether or not a resource adapter supports the concurrency type in combination with the given ResultSet type/
      boolean ResultSetInfo.updatesAreDetected(int type)
      Indicates whether or not a visible row update can be detected by calling the method ResultSet.rowUpdated.

    • Uses of ResourceException in javax.resource.spi

      Subclasses of ResourceException in javax.resource.spi
      Modifier and Type Class and Description
      class  ApplicationServerInternalException
      An ApplicationServerInternalException is thrown by an application server to indicate error conditions specific to an application server.
      class  CommException
      This indicates errors related to failed or interrupted communication with an EIS instance.
      class  EISSystemException
      An EISSystemException is used to indicate any EIS specific system-level error conditions.
      class  IllegalStateException
      An IllegalStateException is thrown from a method if the callee (resource adapter or application server for system contracts) is in an illegal or inappropriate state for the method invocation.
      class  InvalidPropertyException
      This exception is thrown to indicate invalid configuration property settings.
      class  LocalTransactionException
      A LocalTransactionException represents various error conditions related to the local transaction management contract.
      class  ResourceAdapterInternalException
      A ResourceAdapterInternalException indicates any system-level error conditions related to a resource adapter.
      class  ResourceAllocationException
      A ResourceAllocationException can be thrown by an application server or resource adapter to indicate any failure to allocate system resources (example: threads, physical connections).
      class  RetryableUnavailableException
      A subclass of the UnavailableException that indicates that the rejection of the work submission is transient.
      class  SecurityException
      A SecurityException indicates error conditions related to the security contract between an application server and resource adapter.
      class  SharingViolationException
      This is thrown to indicate a connection sharing violation.
      class  UnavailableException
      This is thrown to indicate that a service is unavailable.
      Methods in javax.resource.spi that throw ResourceException
      Modifier and Type Method and Description
      Object ConnectionManager.allocateConnection(ManagedConnectionFactory mcf, ConnectionRequestInfo cxRequestInfo)
      The method allocateConnection gets called by the resource adapter's connection factory instance.
      void ManagedConnection.associateConnection(Object connection)
      Used typically by the container to change the association of an application-level connection handle with a ManagedConneciton instance.
      void LazyAssociatableConnectionManager.associateConnection(Object connection, ManagedConnectionFactory mcf, ConnectionRequestInfo cxReqInfo)
      This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.
      void LocalTransaction.begin()
      Begin a local transaction
      void ManagedConnection.cleanup()
      Application server calls this method to force any cleanup on the ManagedConnection instance.
      void LocalTransaction.commit()
      Commit a local transaction
      Object ManagedConnectionFactory.createConnectionFactory()
      Creates a Connection Factory instance.
      Object ManagedConnectionFactory.createConnectionFactory(ConnectionManager cxManager)
      Creates a Connection Factory instance.
      ManagedConnection ManagedConnectionFactory.createManagedConnection(Subject subject, ConnectionRequestInfo cxRequestInfo)
      Creates a new physical connection to the underlying EIS resource manager.
      void ManagedConnection.destroy()
      Destroys the physical connection to the underlying resource manager.
      void DissociatableManagedConnection.dissociateConnections()
      This method is called by an application server (that is capable of lazy connection association optimization) in order to dissociate a ManagedConnection instance from all of its connection handles.
      void ResourceAdapter.endpointActivation(MessageEndpointFactory endpointFactory, ActivationSpec spec)
      This is called during the activation of a message endpoint.
      Object ManagedConnection.getConnection(Subject subject, ConnectionRequestInfo cxRequestInfo)
      Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance.
      String ManagedConnectionMetaData.getEISProductName()
      Returns Product name of the underlying EIS instance connected through the ManagedConnection.
      String ManagedConnectionMetaData.getEISProductVersion()
      Returns product version of the underlying EIS instance connected through the ManagedConnection.
      Set ValidatingManagedConnectionFactory.getInvalidConnections(Set connectionSet)
      This method returns a set of invalid ManagedConnection objects chosen from a specified set of ManagedConnection objects.
      LocalTransaction ManagedConnection.getLocalTransaction()
      Returns an javax.resource.spi.LocalTransaction instance.
      PrintWriter ManagedConnectionFactory.getLogWriter()
      Get the log writer for this ManagedConnectionFactory instance.
      PrintWriter ManagedConnection.getLogWriter()
      Gets the log writer for this ManagedConnection instance.
      int ManagedConnectionMetaData.getMaxConnections()
      Returns maximum limit on number of active concurrent connections that an EIS instance can support across client processes.
      ManagedConnectionMetaData ManagedConnection.getMetaData()
      Gets the metadata information for this connection's underlying EIS resource manager instance.
      String ManagedConnectionMetaData.getUserName()
      Returns name of the user associated with the ManagedConnection instance.
      XAResource ManagedConnection.getXAResource()
      Returns an javax.transaction.xa.XAresource instance.
      XAResource[] ResourceAdapter.getXAResources(ActivationSpec[] specs)
      This method is called by the application server during crash recovery.
      void LazyEnlistableConnectionManager.lazyEnlist(ManagedConnection mc)
      This method is called by a resource adapter (that is capable of lazy transaction enlistment optimization) in order to lazily enlist a connection object with a XA transaction.
      ManagedConnection ManagedConnectionFactory.matchManagedConnections(Set connectionSet, Subject subject, ConnectionRequestInfo cxRequestInfo)
      Returns a matched connection from the candidate set of connections.
      void LocalTransaction.rollback()
      Rollback a local transaction
      void ManagedConnectionFactory.setLogWriter(PrintWriter out)
      Set the log writer for this ManagedConnectionFactory instance.
      void ManagedConnection.setLogWriter(PrintWriter out)
      Sets the log writer for this ManagedConnection instance.
      void ResourceAdapterAssociation.setResourceAdapter(ResourceAdapter ra)
      Associate this object with a ResourceAdapter object.

    • Uses of ResourceException in javax.resource.spi.endpoint

      Methods in javax.resource.spi.endpoint that throw ResourceException
      Modifier and Type Method and Description
      void MessageEndpoint.afterDelivery()
      This is called by a resource adapter after a message is delivered.
      void MessageEndpoint.beforeDelivery(Method method)
      This is called by a resource adapter before a message is delivered.

    • Uses of ResourceException in javax.resource.spi.work

      Subclasses of ResourceException in javax.resource.spi.work
      Modifier and Type Class and Description
      class  RetryableWorkRejectedException
      A subclass of the WorkRejectedException that indicates that the the service unavailability is transient.
      class  WorkCompletedException
      This exception is thrown by a WorkManager to indicate that a submitted Work instance has completed with an exception.
      class  WorkException
      A common base class for all Work processing related exceptions.
      class  WorkRejectedException
      This exception is thrown by a WorkManager to indicate that a submitted Work instance has been rejected.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.Referenceable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.Referenceable

  • Packages that use Referenceable
    Package Description
    javax.resource.cci
    The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

    • Uses of Referenceable in javax.resource.cci

      Subinterfaces of Referenceable in javax.resource.cci
      Modifier and Type Interface and Description
      interface  ConnectionFactory
      ConnectionFactory provides an interface for getting connection to an EIS instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Activation (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource.spi

Annotation Type Activation

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface Activation
    Designates a JavaBean as an ActivationSpec. This annotation may be placed on a JavaBean. A JavaBean annotated with the Activation annotation is not required to implement the ActivationSpec interface.

    The ActivationSpec JavaBean contains the configuration information pertaining to inbound connectivity from an EIS instance. A resource adapter capable of message delivery to message endpoints must provide an JavaBean class implementing the ActivationSpec interface or annotate a JavaBean with the Activation annotation for each supported endpoint message listener type.

    The ActivationSpec JavaBean has a set of configurable properties specific to the messaging style and the message provider.

    Together with the messageListener annotation element, this annotation specifies information about a specific message listener type supported by the messaging resource adapter.

    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class[] messageListeners
      Indicates the message listener type(s) associated with this activation.

    • Element Detail

      • messageListeners

        public abstract Class[] messageListeners
        Indicates the message listener type(s) associated with this activation.
        Returns:
        The Java types of the Message Listener interface this activation-spec is associated with.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ActivationSpec (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface ActivationSpec

  • All Superinterfaces:
    ResourceAdapterAssociation

    public interface ActivationSpec
extends ResourceAdapterAssociation
    This interface serves as a marker. An instance of an ActivationSpec must be a JavaBean and must be serializable. This holds the activation configuration information for a message endpoint.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void validate()
      This method may be called by a deployment tool to validate the overall activation configuration information provided by the endpoint deployer.

      • Methods inherited from interface javax.resource.spi.ResourceAdapterAssociation

        getResourceAdapter, setResourceAdapter

    • Method Detail

      • validate

        void validate()
              throws InvalidPropertyException
        This method may be called by a deployment tool to validate the overall activation configuration information provided by the endpoint deployer. This helps to catch activation configuration errors earlier on without having to wait until endpoint activation time for configuration validation. The implementation of this self-validation check behavior is optional. Note: Since Java EE Connector 1.6 specification, resource adapter implementations are recommended to use the annotations or the XML validation deployment descriptor facilities defined by the Bean Validation specification to express their validation requirements of its configuration properties to the application server.
        Throws:
        InvalidPropertyException - indicates invalid configuration property settings.
        InvalidPropertyException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdministeredObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource.spi

Annotation Type AdministeredObject

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface AdministeredObject
    Designates a JavaBean as an administered object.Administered objects are specific to a messaging style or message provider.
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class[] adminObjectInterfaces
      Specifies the Java type of the interface implemented by the administered object.

    • Element Detail

      • adminObjectInterfaces

        public abstract Class[] adminObjectInterfaces
        Specifies the Java type of the interface implemented by the administered object.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ApplicationServerInternalException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class ApplicationServerInternalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.ApplicationServerInternalException
  • All Implemented Interfaces:
    Serializable

    public class ApplicationServerInternalException
extends ResourceException
    An ApplicationServerInternalException is thrown by an application server to indicate error conditions specific to an application server. These error conditions can be related to either configuration related errors or implementation of mechanisms internal to an application server (example: connection pooling, thread management).
    Version:
    1.0
    Author:
    Rahul Sharma, Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ApplicationServerInternalException()
      Constructs a new instance with null as its detail message.
      ApplicationServerInternalException(String message)
      Constructs a new instance with the specified detail message.
      ApplicationServerInternalException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      ApplicationServerInternalException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      ApplicationServerInternalException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ApplicationServerInternalException

        public ApplicationServerInternalException()
        Constructs a new instance with null as its detail message.

      • ApplicationServerInternalException

        public ApplicationServerInternalException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • ApplicationServerInternalException

        public ApplicationServerInternalException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • ApplicationServerInternalException

        public ApplicationServerInternalException(String message,
                                  Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • ApplicationServerInternalException

        public ApplicationServerInternalException(String message,
                                  String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AuthenticationMechanism (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource.spi

Annotation Type AuthenticationMechanism

  • @Documented
@Retention(value=RUNTIME)
@Target(value={})
public @interface AuthenticationMechanism

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String authMechanism
      The authentication-mechanismType specifies an authentication mechanism supported by the resource adapter.
      AuthenticationMechanism.CredentialInterface credentialInterface
      Represents the interface that the resource adapter implementation supports for the representation of the credentials.
      String[] description
      The optional description specifies any resource adapter specific requirement for the support of security contract and authentication mechanism.

    • Element Detail

      • authMechanism

        public abstract String authMechanism
        The authentication-mechanismType specifies an authentication mechanism supported by the resource adapter. Note that this support is for the resource adapter and not for the underlying EIS instance.
        Default:
        "BasicPassword"

      • description

        public abstract String[] description
        The optional description specifies any resource adapter specific requirement for the support of security contract and authentication mechanism.
        Default:
        {}

      • credentialInterface

        public abstract AuthenticationMechanism.CredentialInterface credentialInterface
        Represents the interface that the resource adapter implementation supports for the representation of the credentials. Note that BasicPassword mechanism type should support the javax.resource.spi.security.PasswordCredential interface. The Kerbv5 mechanism type should support the org.ietf.jgss.GSSCredential interface or the deprecated javax.resource.spi.security.GenericCredential interface.
        Default:
        javax.resource.spi.AuthenticationMechanism.CredentialInterface.PasswordCredential
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AuthenticationMechanism.CredentialInterface (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.resource.spi

Enum AuthenticationMechanism.CredentialInterface

  • java.lang.Object
    • java.lang.Enum<AuthenticationMechanism.CredentialInterface>
      • javax.resource.spi.AuthenticationMechanism.CredentialInterface
  • All Implemented Interfaces:
    Serializable, Comparable<AuthenticationMechanism.CredentialInterface>
    Enclosing class:
    AuthenticationMechanism

    public static enum AuthenticationMechanism.CredentialInterface
extends Enum<AuthenticationMechanism.CredentialInterface>
    An enumerated type that represents the various interfaces that a resource adapter may support for the representation of the credentials.
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      GenericCredential
      Corresponds to javax.resource.spi.security.GenericCredential
      GSSCredential
      Corresponds to org.ietf.jgss.GSSCredential
      PasswordCredential
      Corresponds to javax.resource.spi.security.PasswordCredential.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static AuthenticationMechanism.CredentialInterface valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AuthenticationMechanism.CredentialInterface[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PasswordCredential

        public static final AuthenticationMechanism.CredentialInterface PasswordCredential
        Corresponds to javax.resource.spi.security.PasswordCredential. This is the default credential interface

      • GSSCredential

        public static final AuthenticationMechanism.CredentialInterface GSSCredential
        Corresponds to org.ietf.jgss.GSSCredential

      • GenericCredential

        public static final AuthenticationMechanism.CredentialInterface GenericCredential
        Corresponds to javax.resource.spi.security.GenericCredential

    • Method Detail

      • values

        public static AuthenticationMechanism.CredentialInterface[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (AuthenticationMechanism.CredentialInterface c : AuthenticationMechanism.CredentialInterface.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static AuthenticationMechanism.CredentialInterface valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


BootstrapContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface BootstrapContext

  • public interface BootstrapContext
    This provides a mechanism to pass a bootstrap context to a resource adapter instance when it is bootstrapped. That is, when (start(BootstrapContext)) method on the ResourceAdapter class is invoked. The bootstrap context contains references to useful facilities that could be used by the resource adapter instance.
    Version:
    Java EE Connector Architecture 1.6
    Author:
    Ram Jeyaraman, Sivakumar Thyagarajan

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Timer createTimer()
      Creates a new java.util.Timer instance.
      TransactionSynchronizationRegistry getTransactionSynchronizationRegistry()
      Provides a handle to a TransactionSynchronization instance.
      WorkManager getWorkManager()
      Provides a handle to a WorkManager instance.
      XATerminator getXATerminator()
      Provides a handle to a XATerminator instance.
      boolean isContextSupported(Class<? extends WorkContext> workContextClass)
      A resource adapter can check an application server's support for a particular WorkContext type through this method.

    • Method Detail

      • getWorkManager

        WorkManager getWorkManager()
        Provides a handle to a WorkManager instance. The WorkManager instance could be used by a resource adapter to do its work by submitting Work instances for execution.
        Returns:
        a WorkManager instance.

      • getXATerminator

        XATerminator getXATerminator()
        Provides a handle to a XATerminator instance. The XATerminator instance could be used by a resource adapter to flow-in transaction completion and crash recovery calls from an EIS.
        Returns:
        a XATerminator instance.

      • createTimer

        Timer createTimer()
                  throws UnavailableException
        Creates a new java.util.Timer instance. The Timer instance could be used to perform periodic Work executions or other tasks.
        Returns:
        a new Timer instance.
        Throws:
        UnavailableException - indicates that a Timer instance is not available. The request may be retried later.

      • isContextSupported

        boolean isContextSupported(Class<? extends WorkContext> workContextClass)
        A resource adapter can check an application server's support for a particular WorkContext type through this method. This mechanism enables a resource adapter developer to dynamically change the WorkContexts submitted with a Work instance based on the support provided by the application server. The application server must employ an exact type equality check (that is java.lang.Class.equals(java.lang.Class) check) in this method, to check if it supports the WorkContext type provided by the resource adapter. This method must be idempotent, that is all calls to this method by a resource adapter for a particular WorkContext type must return the same boolean value throughout the lifecycle of that resource adapter instance.
        Parameters:
        workContextClass - The WorkContext type that is tested for support by the application server.
        Returns:
        true if the workContextClass is supported by the application server. false if the workContextClass is unsupported or unknown to the application server.
        Since:
        1.6

      • getTransactionSynchronizationRegistry

        TransactionSynchronizationRegistry getTransactionSynchronizationRegistry()
        Provides a handle to a TransactionSynchronization instance. The TransactionSynchronizationRegistry instance could be used by a resource adapter to register synchronization objects, get transaction state and status etc. This interface is implemented by the application server by a stateless service object. The same object can be used by any number of resource adapter objects with thread safety.
        Returns:
        a TransactionSynchronizationRegistry instance.
        Since:
        1.6
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CommException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class CommException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.CommException
  • All Implemented Interfaces:
    Serializable

    public class CommException
extends ResourceException
    This indicates errors related to failed or interrupted communication with an EIS instance. Examples of common error conditions represented by this exception type are communication protocol error and invalidated connection due to server failure.
    Version:
    1.0
    Author:
    Rahul Sharma, Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      CommException()
      Constructs a new instance with null as its detail message.
      CommException(String message)
      Constructs a new instance with the specified detail message.
      CommException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      CommException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      CommException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • CommException

        public CommException()
        Constructs a new instance with null as its detail message.

      • CommException

        public CommException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • CommException

        public CommException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • CommException

        public CommException(String message,
             Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • CommException

        public CommException(String message,
             String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConfigProperty (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource.spi

Annotation Type ConfigProperty

  • @Documented
@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface ConfigProperty
    Designates a JavaBean property as a configuration property
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean confidential
      Indicates that the configuration property is confidential and recommends application server's configuration tools to use special visual aids for editing them.
      String defaultValue
      Inferred by the container for field based annotations if possible.
      String[] description
      Describes the configuration property.
      boolean ignore
      Indicates that the configuration tools must ignore considering this Property during auto-discovery of Configuration properties.
      boolean supportsDynamicUpdates
      Indicates that the configuration property supports dynamic updates to its value during the lifetime of the JavaBean
      Class type
      Inferred by the container if unspecified.

    • Element Detail

      • type

        public abstract Class type
        Inferred by the container if unspecified.
        Default:
        java.lang.Object.class

      • description

        public abstract String[] description
        Describes the configuration property.
        Default:
        {}

      • defaultValue

        public abstract String defaultValue
        Inferred by the container for field based annotations if possible.
        Default:
        ""

      • ignore

        public abstract boolean ignore
        Indicates that the configuration tools must ignore considering this Property during auto-discovery of Configuration properties.
        Default:
        false

      • supportsDynamicUpdates

        public abstract boolean supportsDynamicUpdates
        Indicates that the configuration property supports dynamic updates to its value during the lifetime of the JavaBean
        Default:
        false

      • confidential

        public abstract boolean confidential
        Indicates that the configuration property is confidential and recommends application server's configuration tools to use special visual aids for editing them.
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ConnectionDefinition (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource.spi

Annotation Type ConnectionDefinition

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface ConnectionDefinition
    Defines a set of connection interfaces and classes pertaining to a particular connection type. This annotation can be placed only on a JavaBean that implements the ManagedConnectionFactory interface.
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class connection
      Specifies the Connection interface supported by the resource adapter.
      Class connectionFactory
      Specifies the ConnectionFactory interface supported by the resource adapter.
      Class connectionFactoryImpl
      Specifies the Class provided by the resource adapter that implements the resource adapter specific ConnectionFactory interface.
      Class connectionImpl
      Specifies the class provided by the resource adapter that implements the resource adapter specific Connection interface.

    • Element Detail

      • connectionFactory

        public abstract Class connectionFactory
        Specifies the ConnectionFactory interface supported by the resource adapter. Example: javax.resource.cci.ConnectionFactory or com.wombat.ConnectionFactory

      • connectionFactoryImpl

        public abstract Class connectionFactoryImpl
        Specifies the Class provided by the resource adapter that implements the resource adapter specific ConnectionFactory interface. Example: com.wombat.ConnectionFactoryImpl

      • connection

        public abstract Class connection
        Specifies the Connection interface supported by the resource adapter. Example: javax.resource.cci.Connection or com.wombat.Connection

      • connectionImpl

        public abstract Class connectionImpl
        Specifies the class provided by the resource adapter that implements the resource adapter specific Connection interface. Example: com.wombat.ConnectionImpl
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ConnectionDefinitions (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource.spi

Annotation Type ConnectionDefinitions

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface ConnectionDefinitions
    Defines a set of connection definitions that the JavaBean, that has been annotated with this annotation, is a part of. This annotation can be placed only on a JavaBean that implements the ManagedConnectionFactory interface.
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      ConnectionDefinition[] value
      An array of ConnectionDefinitions associated with the ManagedConectionFactory JavaBean.

    • Element Detail

      • value

        public abstract ConnectionDefinition[] value
        An array of ConnectionDefinitions associated with the ManagedConectionFactory JavaBean.
        Returns:
        an array of ConnectionDefinitions associated with the ManagedConnectionFactory instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ConnectionEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class ConnectionEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.resource.spi.ConnectionEvent
  • All Implemented Interfaces:
    Serializable

    public class ConnectionEvent
extends EventObject
    The ConnectionEvent class provides information about the source of a connection related event.A ConnectionEvent instance contains the following information:
    • Type of the connection event
    • ManagedConnection instance that generated the connection event. A ManagedConnection instance is returned from the method ConnectionEvent.getSource.
    • Connection handle associated with the ManagedConnection instance; required for the CONNECTION_CLOSED event and optional for the other event types.
    • Optionally, an exception indicating the connection related error. Note that exception is used for CONNECTION_ERROR_OCCURRED.

    This class defines following types of event notifications:

    • CONNECTION_CLOSED
    • LOCAL_TRANSACTION_STARTED
    • LOCAL_TRANSACTION_COMMITTED
    • LOCAL_TRANSACTION_ROLLEDBACK
    • CONNECTION_ERROR_OCCURRED
    Version:
    0.5
    Author:
    Rahul Sharma
    See Also:
    ConnectionEventListener, Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int CONNECTION_CLOSED
      Event notification that an application component has closed the connection
      static int CONNECTION_ERROR_OCCURRED
      Event notification that an error occurred on the connection.
      protected int id
      Type of the event
      static int LOCAL_TRANSACTION_COMMITTED
      Event notification that a Resource Manager Local Transaction was committed on the connection
      static int LOCAL_TRANSACTION_ROLLEDBACK
      Event notification that a Resource Manager Local Transaction was rolled back on the connection
      static int LOCAL_TRANSACTION_STARTED
      Event notification that a Resource Manager Local Transaction was started on the connection

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ConnectionEvent(ManagedConnection source, int eid)
      Construct a ConnectionEvent object.
      ConnectionEvent(ManagedConnection source, int eid, Exception exception)
      Construct a ConnectionEvent object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getConnectionHandle()
      Get the connection handle associated with the Managed Connection instance.
      Exception getException()
      Get the exception.
      int getId()
      Get the type of event
      void setConnectionHandle(Object connectionHandle)
      Set the connection handle.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • CONNECTION_CLOSED

        public static final int CONNECTION_CLOSED
        Event notification that an application component has closed the connection
        See Also:
        Constant Field Values

      • LOCAL_TRANSACTION_STARTED

        public static final int LOCAL_TRANSACTION_STARTED
        Event notification that a Resource Manager Local Transaction was started on the connection
        See Also:
        Constant Field Values

      • LOCAL_TRANSACTION_COMMITTED

        public static final int LOCAL_TRANSACTION_COMMITTED
        Event notification that a Resource Manager Local Transaction was committed on the connection
        See Also:
        Constant Field Values

      • LOCAL_TRANSACTION_ROLLEDBACK

        public static final int LOCAL_TRANSACTION_ROLLEDBACK
        Event notification that a Resource Manager Local Transaction was rolled back on the connection
        See Also:
        Constant Field Values

      • CONNECTION_ERROR_OCCURRED

        public static final int CONNECTION_ERROR_OCCURRED
        Event notification that an error occurred on the connection. This event indicates that the ManagedConnection instance is now invalid and unusable.
        See Also:
        Constant Field Values

      • id

        protected int id
        Type of the event

    • Constructor Detail

      • ConnectionEvent

        public ConnectionEvent(ManagedConnection source,
               int eid)
        Construct a ConnectionEvent object. Exception defaults to null.
        Parameters:
        source - ManagedConnection that is the source of the event
        eid - type of the Connection event

      • ConnectionEvent

        public ConnectionEvent(ManagedConnection source,
               int eid,
               Exception exception)
        Construct a ConnectionEvent object.
        Parameters:
        source - ManagedConnection that is the source of the event
        exception - exception about to be thrown to the application
        eid - type of the Connection event

    • Method Detail

      • getConnectionHandle

        public Object getConnectionHandle()
        Get the connection handle associated with the Managed Connection instance. Used for CONNECTION_CLOSED event.
        Returns:
        the connection handle. May be null

      • setConnectionHandle

        public void setConnectionHandle(Object connectionHandle)
        Set the connection handle. Used for CONNECTION_CLOSED event

      • getException

        public Exception getException()
        Get the exception. May be null.
        Returns:
        the exception about to be thrown.

      • getId

        public int getId()
        Get the type of event
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionEventListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface ConnectionEventListener

  • All Superinterfaces:
    EventListener

    public interface ConnectionEventListener
extends EventListener
    The ConnectionEventListener interface provides an event callback mechanism to enable an application server to receive notifications from a ManagedConnection instance.

    An application server uses these event notifications to manage its connection pool, to clean up any invalid or terminated connections and to manage local transactions.

    An application server implements the ConnectionEventListener interface. It registers a connection listener with a ManagedConnection instance by using ManagedConnection.addConnectionEventListener method.

    Version:
    0.5
    Author:
    Rahul Sharma
    See Also:
    ConnectionEvent

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void connectionClosed(ConnectionEvent event)
      Notifies that an application component has closed the connection.
      void connectionErrorOccurred(ConnectionEvent event)
      Notifies a connection related error.
      void localTransactionCommitted(ConnectionEvent event)
      Notifies that a Resource Manager Local Transaction was committed on the ManagedConnection instance.
      void localTransactionRolledback(ConnectionEvent event)
      Notifies that a Resource Manager Local Transaction was rolled back on the ManagedConnection instance.
      void localTransactionStarted(ConnectionEvent event)
      Notifies that a Resource Manager Local Transaction was started on the ManagedConnection instance.

    • Method Detail

      • connectionClosed

        void connectionClosed(ConnectionEvent event)
        Notifies that an application component has closed the connection.

        A ManagedConnection instance notifies its registered set of listeners by calling ConnectionEventListener.connectionClosed method when an application component closes a connection handle. The application server uses this connection close event to put the ManagedConnection instance back in to the connection pool.

        Parameters:
        event - event object describing the source of the event

      • localTransactionStarted

        void localTransactionStarted(ConnectionEvent event)
        Notifies that a Resource Manager Local Transaction was started on the ManagedConnection instance.
        Parameters:
        event - event object describing the source of the event

      • localTransactionCommitted

        void localTransactionCommitted(ConnectionEvent event)
        Notifies that a Resource Manager Local Transaction was committed on the ManagedConnection instance.
        Parameters:
        event - event object describing the source of the event

      • localTransactionRolledback

        void localTransactionRolledback(ConnectionEvent event)
        Notifies that a Resource Manager Local Transaction was rolled back on the ManagedConnection instance.
        Parameters:
        event - event object describing the source of the event

      • connectionErrorOccurred

        void connectionErrorOccurred(ConnectionEvent event)
        Notifies a connection related error. The ManagedConnection instance calls the method ConnectionEventListener.connectionErrorOccurred to notify its registered listeners of the occurrence of a physical connection-related error. The event notification happens just before a resource adapter throws an exception to the application component using the connection handle. The connectionErrorOccurred method indicates that the associated ManagedConnection instance is now invalid and unusable. The application server handles the connection error event notification by initiating application server-specific cleanup (for example, removing ManagedConnection instance from the connection pool) and then calling ManagedConnection.destroy method to destroy the physical connection.
        Parameters:
        event - event object describing the source of the event
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface ConnectionManager

  • All Superinterfaces:
    Serializable

    public interface ConnectionManager
extends Serializable

    ConnectionManager interface provides a hook for the resource adapter to pass a connection request to the application server.

    An application server provides implementation of the ConnectionManager interface. This implementation is not specific to any particular type of the resource adapter or connection factory interface.

    The ConnectionManager implementation delegates to the application server to enable latter to provide quality of services (QoS) - security, connection pool management, transaction management and error logging/tracing.

    An application server implements these services in a generic manner, independent of any resource adapter and EIS specific mechanisms. The connector architecture does not specify how an application server implements these services; the implementation is specific to an application server.

    After an application server hooks-in its services, the connection request gets delegated to a ManagedConnectionFactory instance either for the creation of a new physical connection or for the matching of an already existing physical connection.

    An implementation class for ConnectionManager interface is required to implement the java.io.Serializable interface.

    In the non-managed application scenario, the ConnectionManager implementation class can be provided either by a resource adapter (as a default ConnectionManager implementation) or by application developers. In both cases, QOS can be provided as components by third party vendors.

    Since:
    0.6
    Author:
    Rahul Sharma
    See Also:
    ManagedConnectionFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object allocateConnection(ManagedConnectionFactory mcf, ConnectionRequestInfo cxRequestInfo)
      The method allocateConnection gets called by the resource adapter's connection factory instance.

    • Method Detail

      • allocateConnection

        Object allocateConnection(ManagedConnectionFactory mcf,
                        ConnectionRequestInfo cxRequestInfo)
                          throws ResourceException

        The method allocateConnection gets called by the resource adapter's connection factory instance. This lets connection factory instance (provided by the resource adapter) pass a connection request to the ConnectionManager instance.

        The connectionRequestInfo parameter represents information specific to the resource adapter for handling of the connection request.

        Parameters:
        mcf - used by application server to delegate connection matching/creation
        cxRequestInfo - connection request Information
        Returns:
        connection handle with an EIS specific connection interface.
        Throws:
        ResourceException - Generic exception
        ApplicationServerInternalException - Application server specific exception
        SecurityException - Security related error
        ResourceAllocationException - Failed to allocate system resources for connection request
        ResourceAdapterInternalException - Resource adapter related error condition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionRequestInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface ConnectionRequestInfo

  • public interface ConnectionRequestInfo

    The ConnectionRequestInfo interface enables a resource adapter to pass its own request specific data structure across the connection request flow. A resource adapter extends the empty interface to supports its own data structures for connection request.

    A typical use allows a resource adapter to handle application component specified per-connection request properties (example - client ID, language). The application server passes these properties back across to match/createManagedConnection calls on the resource adapter. These properties remain opaque to the application server during the connection request flow.

    Once the ConnectionRequestInfo reaches match/createManagedConnection methods on the ManagedConnectionFactory instance, resource adapter uses this additional per-request information to do connection creation and matching.

    Version:
    0.8
    Author:
    Rahul Sharma
    See Also:
    ManagedConnectionFactory, ManagedConnection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object other)
      Checks whether this instance is equal to another.
      int hashCode()
      Returns the hashCode of the ConnectionRequestInfo.

    • Method Detail

      • equals

        boolean equals(Object other)
        Checks whether this instance is equal to another. Since connectionRequestInfo is defined specific to a resource adapter, the resource adapter is required to implement this method. The conditions for equality are specific to the resource adapter.
        Overrides:
        equals in class Object
        Returns:
        True if the two instances are equal.

      • hashCode

        int hashCode()
        Returns the hashCode of the ConnectionRequestInfo.
        Overrides:
        hashCode in class Object
        Returns:
        hash code os this instance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Connector (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource.spi

Annotation Type Connector

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface Connector
    The Connector annotation is a component-defining annotation and it can be used by the resource adapter developer to specify that the JavaBean is a resource adapter JavaBean. The Connector annotation is applied to the JavaBean class.
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      AuthenticationMechanism[] authMechanisms
      Specifies the authentication mechanisms supported by the resource adapter.
      String[] description
      Describes the resource adapter module.
      String[] displayName
      An optional short name, providing information about the resource adapter module, that is intended to be displayed by tools.
      String eisType
      Contains information about the type of EIS.
      String[] largeIcon
      Specifies the file name for large GIF or JPEG icon images that are used to represent the resource adapter in a GUI tool.
      String[] licenseDescription
      Specifies licensing requirements for the resource adapter module and an optional description of the licensing terms .
      boolean licenseRequired
      Specifies whether a license is required to deploy and use this resource adapter
      boolean reauthenticationSupport
      Specifies whether a license is required to deploy and use this resource adapter
      Class<? extends WorkContext>[] requiredWorkContexts
      Specifies a list of fully qualified classes that implements the WorkContext interface that a resource adapter requires the application server to support.
      SecurityPermission[] securityPermissions
      Specifies the extended security permissions required to be provided for the operation of the resource adapter module
      String[] smallIcon
      Specifies the file name for small GIF or JPEG icon images that are used to represent the resource adapter in a GUI tool.
      TransactionSupport.TransactionSupportLevel transactionSupport
      Specifies the level of transaction support provided by the resource adapter.
      String vendorName
      Specifies the name of the resource adapter provider vendor.
      String version
      Specifies the version of the resource adapter implementation.

    • Element Detail

      • description

        public abstract String[] description
        Describes the resource adapter module.
        Default:
        {}

      • displayName

        public abstract String[] displayName
        An optional short name, providing information about the resource adapter module, that is intended to be displayed by tools.
        Default:
        {}

      • smallIcon

        public abstract String[] smallIcon
        Specifies the file name for small GIF or JPEG icon images that are used to represent the resource adapter in a GUI tool. Each smallIcon must be associated with a largeIcon element and the application server must use the ordinal value in their respective arrays to find the related pairs of icons.
        Default:
        {}

      • largeIcon

        public abstract String[] largeIcon
        Specifies the file name for large GIF or JPEG icon images that are used to represent the resource adapter in a GUI tool. Each smallIcon must be associated with a largeIcon element and the application server must use the ordinal value in their respective arrays to find the related pairs of icons.
        Default:
        {}

      • vendorName

        public abstract String vendorName
        Specifies the name of the resource adapter provider vendor.
        Default:
        ""

      • eisType

        public abstract String eisType
        Contains information about the type of EIS. For example, the type of an EIS can be product name of the EIS independent of any version info.This helps in identifying EIS instances that can be used with this resource adapter.
        Default:
        ""

      • version

        public abstract String version
        Specifies the version of the resource adapter implementation.
        Default:
        ""

      • licenseDescription

        public abstract String[] licenseDescription
        Specifies licensing requirements for the resource adapter module and an optional description of the licensing terms .
        Default:
        {}

      • licenseRequired

        public abstract boolean licenseRequired
        Specifies whether a license is required to deploy and use this resource adapter
        Default:
        false

      • authMechanisms

        public abstract AuthenticationMechanism[] authMechanisms
        Specifies the authentication mechanisms supported by the resource adapter.
        See Also:
        AuthenticationMechanism
        Default:
        {}

      • reauthenticationSupport

        public abstract boolean reauthenticationSupport
        Specifies whether a license is required to deploy and use this resource adapter
        Default:
        false

      • securityPermissions

        public abstract SecurityPermission[] securityPermissions
        Specifies the extended security permissions required to be provided for the operation of the resource adapter module
        See Also:
        SecurityPermission
        Default:
        {}

      • transactionSupport

        public abstract TransactionSupport.TransactionSupportLevel transactionSupport
        Specifies the level of transaction support provided by the resource adapter.
        See Also:
        TransactionSupport.TransactionSupportLevel
        Default:
        javax.resource.spi.TransactionSupport.TransactionSupportLevel.NoTransaction

      • requiredWorkContexts

        public abstract Class<? extends WorkContext>[] requiredWorkContexts
        Specifies a list of fully qualified classes that implements the WorkContext interface that a resource adapter requires the application server to support.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DissociatableManagedConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface DissociatableManagedConnection

  • public interface DissociatableManagedConnection
    This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation. An implementation of this interface must support the lazy connection association optimization.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void dissociateConnections()
      This method is called by an application server (that is capable of lazy connection association optimization) in order to dissociate a ManagedConnection instance from all of its connection handles.

    • Method Detail

      • dissociateConnections

        void dissociateConnections()
                           throws ResourceException
        This method is called by an application server (that is capable of lazy connection association optimization) in order to dissociate a ManagedConnection instance from all of its connection handles.
        Throws:
        ResourceException - generic exception if operation fails.
        ResourceAdapterInternalException - resource adapter internal error condition
        IllegalStateException - Illegal state for dissociating a ManagedConnection from all of its connection handles.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EISSystemException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class EISSystemException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.EISSystemException
  • All Implemented Interfaces:
    Serializable

    public class EISSystemException
extends ResourceException
    An EISSystemException is used to indicate any EIS specific system-level error conditions. The common error conditions are: failure or inactivity of an EIS instance, communication failure and EIS specific error in the creation of a new physical connection.
    Version:
    1.0
    Author:
    Rahul Sharma, Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EISSystemException()
      Constructs a new instance with null as its detail message.
      EISSystemException(String message)
      Constructs a new instance with the specified detail message.
      EISSystemException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      EISSystemException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      EISSystemException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EISSystemException

        public EISSystemException()
        Constructs a new instance with null as its detail message.

      • EISSystemException

        public EISSystemException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • EISSystemException

        public EISSystemException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • EISSystemException

        public EISSystemException(String message,
                  Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • EISSystemException

        public EISSystemException(String message,
                  String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IllegalStateException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class IllegalStateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.IllegalStateException
  • All Implemented Interfaces:
    Serializable

    public class IllegalStateException
extends ResourceException
    An IllegalStateException is thrown from a method if the callee (resource adapter or application server for system contracts) is in an illegal or inappropriate state for the method invocation.
    Version:
    1.0
    Author:
    Rahul Sharma, Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      IllegalStateException()
      Constructs a new instance with null as its detail message.
      IllegalStateException(String message)
      Constructs a new instance with the specified detail message.
      IllegalStateException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      IllegalStateException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      IllegalStateException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • IllegalStateException

        public IllegalStateException()
        Constructs a new instance with null as its detail message.

      • IllegalStateException

        public IllegalStateException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • IllegalStateException

        public IllegalStateException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • IllegalStateException

        public IllegalStateException(String message,
                     Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • IllegalStateException

        public IllegalStateException(String message,
                     String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidPropertyException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class InvalidPropertyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.InvalidPropertyException
  • All Implemented Interfaces:
    Serializable

    public class InvalidPropertyException
extends ResourceException
    This exception is thrown to indicate invalid configuration property settings.
    Version:
    0.2
    Author:
    Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidPropertyException()
      Create a InvalidPropertyException.
      InvalidPropertyException(String message)
      Create a InvalidPropertyException.
      InvalidPropertyException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      InvalidPropertyException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      InvalidPropertyException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      PropertyDescriptor[] getInvalidPropertyDescriptors()
      Get the list of invalid properties.
      void setInvalidPropertyDescriptors(PropertyDescriptor[] invalidProperties)
      Set a list of invalid properties.

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidPropertyException

        public InvalidPropertyException()
        Create a InvalidPropertyException.

      • InvalidPropertyException

        public InvalidPropertyException(String message)
        Create a InvalidPropertyException.
        Parameters:
        message - a description of the exception

      • InvalidPropertyException

        public InvalidPropertyException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • InvalidPropertyException

        public InvalidPropertyException(String message,
                        Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • InvalidPropertyException

        public InvalidPropertyException(String message,
                        String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.

    • Method Detail

      • setInvalidPropertyDescriptors

        public void setInvalidPropertyDescriptors(PropertyDescriptor[] invalidProperties)
        Set a list of invalid properties.

      • getInvalidPropertyDescriptors

        public PropertyDescriptor[] getInvalidPropertyDescriptors()
        Get the list of invalid properties.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.resource.spi (Java(TM) EE 7 Specification APIs)

javax.resource.spi

Interfaces

  • ActivationSpec
  • BootstrapContext
  • ConnectionEventListener
  • ConnectionManager
  • ConnectionRequestInfo
  • DissociatableManagedConnection
  • LazyAssociatableConnectionManager
  • LazyEnlistableConnectionManager
  • LazyEnlistableManagedConnection
  • LocalTransaction
  • ManagedConnection
  • ManagedConnectionFactory
  • ManagedConnectionMetaData
  • ResourceAdapter
  • ResourceAdapterAssociation
  • RetryableException
  • TransactionSupport
  • ValidatingManagedConnectionFactory
  • XATerminator

Classes

  • ConnectionEvent

Enums

  • AuthenticationMechanism.CredentialInterface
  • TransactionSupport.TransactionSupportLevel

Exceptions

  • ApplicationServerInternalException
  • CommException
  • EISSystemException
  • IllegalStateException
  • InvalidPropertyException
  • LocalTransactionException
  • ResourceAdapterInternalException
  • ResourceAllocationException
  • RetryableUnavailableException
  • SecurityException
  • SharingViolationException
  • UnavailableException

Annotation Types

  • Activation
  • AdministeredObject
  • AuthenticationMechanism
  • ConfigProperty
  • ConnectionDefinition
  • ConnectionDefinitions
  • Connector
  • SecurityPermission


javax.resource.spi (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.resource.spi

The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

See: Description

  • Interface Summary
    Interface Description
    ActivationSpec
    This interface serves as a marker.
    BootstrapContext
    This provides a mechanism to pass a bootstrap context to a resource adapter instance when it is bootstrapped.
    ConnectionEventListener
    The ConnectionEventListener interface provides an event callback mechanism to enable an application server to receive notifications from a ManagedConnection instance.
    ConnectionManager
    ConnectionManager interface provides a hook for the resource adapter to pass a connection request to the application server.
    ConnectionRequestInfo
    The ConnectionRequestInfo interface enables a resource adapter to pass its own request specific data structure across the connection request flow.
    DissociatableManagedConnection
    This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation.
    LazyAssociatableConnectionManager
    This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation.
    LazyEnlistableConnectionManager
    This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation.
    LazyEnlistableManagedConnection
    This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation.
    LocalTransaction
    LocalTransaction interface provides support for transactions that are managed internal to an EIS resource manager, and do not require an external transaction manager.
    ManagedConnection
    ManagedConnection instance represents a physical connection to the underlying EIS.
    ManagedConnectionFactory
    ManagedConnectionFactory instance is a factory of both ManagedConnection and EIS-specific connection factory instances.
    ManagedConnectionMetaData
    The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with a ManagedConnection instance.
    ResourceAdapter
    This represents a resource adapter instance and contains operations for lifecycle management and message endpoint setup.
    ResourceAdapterAssociation
    This interface specifies the methods to associate a ResourceAdapter object with other objects that implement this interface like ManagedConnectionFactory and ActivationSpec.
    RetryableException
    A marker interface indicating that the Exception is transient.
    TransactionSupport
    This interface may be optionally implemented by a ManagedConnectionFactory to provide its level of transaction support at runtime.
    ValidatingManagedConnectionFactory
    This interface is implemented by a ManagedConnectionFactory instance that supports the ability to validate ManagedConnection objects.
    XATerminator
    The XATerminator interface is used for transaction completion and crash recovery flows.
  • Class Summary
    Class Description
    ConnectionEvent
    The ConnectionEvent class provides information about the source of a connection related event.A ConnectionEvent instance contains the following information: Type of the connection event ManagedConnection instance that generated the connection event.
  • Enum Summary
    Enum Description
    AuthenticationMechanism.CredentialInterface
    An enumerated type that represents the various interfaces that a resource adapter may support for the representation of the credentials.
    TransactionSupport.TransactionSupportLevel
    An enumerated type that represents the levels of transaction support a resource adapter may support.
  • Exception Summary
    Exception Description
    ApplicationServerInternalException
    An ApplicationServerInternalException is thrown by an application server to indicate error conditions specific to an application server.
    CommException
    This indicates errors related to failed or interrupted communication with an EIS instance.
    EISSystemException
    An EISSystemException is used to indicate any EIS specific system-level error conditions.
    IllegalStateException
    An IllegalStateException is thrown from a method if the callee (resource adapter or application server for system contracts) is in an illegal or inappropriate state for the method invocation.
    InvalidPropertyException
    This exception is thrown to indicate invalid configuration property settings.
    LocalTransactionException
    A LocalTransactionException represents various error conditions related to the local transaction management contract.
    ResourceAdapterInternalException
    A ResourceAdapterInternalException indicates any system-level error conditions related to a resource adapter.
    ResourceAllocationException
    A ResourceAllocationException can be thrown by an application server or resource adapter to indicate any failure to allocate system resources (example: threads, physical connections).
    RetryableUnavailableException
    A subclass of the UnavailableException that indicates that the rejection of the work submission is transient.
    SecurityException
    A SecurityException indicates error conditions related to the security contract between an application server and resource adapter.
    SharingViolationException
    This is thrown to indicate a connection sharing violation.
    UnavailableException
    This is thrown to indicate that a service is unavailable.
  • Annotation Types Summary
    Annotation Type Description
    Activation
    Designates a JavaBean as an ActivationSpec.
    AdministeredObject
    Designates a JavaBean as an administered object.Administered objects are specific to a messaging style or message provider.
    AuthenticationMechanism
    ConfigProperty
    Designates a JavaBean property as a configuration property
    ConnectionDefinition
    Defines a set of connection interfaces and classes pertaining to a particular connection type.
    ConnectionDefinitions
    Defines a set of connection definitions that the JavaBean, that has been annotated with this annotation, is a part of.
    Connector
    The Connector annotation is a component-defining annotation and it can be used by the resource adapter developer to specify that the JavaBean is a resource adapter JavaBean.
    SecurityPermission
    The SecurityPermission annotation can be used by the developer, as part of the Connector annotation, to specify the extended security permissions required by the resource adapter

Package javax.resource.spi Description

The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.resource.spi Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.resource.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.resource.spi.ConnectionEvent
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.ApplicationServerInternalException
          • javax.resource.spi.CommException
          • javax.resource.spi.EISSystemException
          • javax.resource.spi.IllegalStateException
          • javax.resource.spi.InvalidPropertyException
          • javax.resource.spi.LocalTransactionException
          • javax.resource.spi.ResourceAdapterInternalException
          • javax.resource.spi.ResourceAllocationException
          • javax.resource.spi.SecurityException
          • javax.resource.spi.SharingViolationException
          • javax.resource.spi.UnavailableException
            • javax.resource.spi.RetryableUnavailableException (implements javax.resource.spi.RetryableException)

Interface Hierarchy

  • javax.resource.spi.BootstrapContext
  • javax.resource.spi.ConnectionRequestInfo
  • javax.resource.spi.DissociatableManagedConnection
  • java.util.EventListener
    • javax.resource.spi.ConnectionEventListener
  • javax.resource.spi.LazyAssociatableConnectionManager
  • javax.resource.spi.LazyEnlistableConnectionManager
  • javax.resource.spi.LazyEnlistableManagedConnection
  • javax.resource.spi.LocalTransaction
  • javax.resource.spi.ManagedConnection
  • javax.resource.spi.ManagedConnectionMetaData
  • javax.resource.spi.ResourceAdapter
  • javax.resource.spi.ResourceAdapterAssociation
    • javax.resource.spi.ActivationSpec
  • java.io.Serializable
    • javax.resource.spi.ConnectionManager
    • javax.resource.spi.ManagedConnectionFactory
    • javax.resource.spi.RetryableException
    • javax.resource.spi.TransactionSupport
  • javax.resource.spi.ValidatingManagedConnectionFactory
  • javax.resource.spi.XATerminator

Annotation Type Hierarchy

  • javax.resource.spi.SecurityPermission (implements java.lang.annotation.Annotation)
  • javax.resource.spi.Connector (implements java.lang.annotation.Annotation)
  • javax.resource.spi.ConnectionDefinitions (implements java.lang.annotation.Annotation)
  • javax.resource.spi.ConnectionDefinition (implements java.lang.annotation.Annotation)
  • javax.resource.spi.ConfigProperty (implements java.lang.annotation.Annotation)
  • javax.resource.spi.AuthenticationMechanism (implements java.lang.annotation.Annotation)
  • javax.resource.spi.AdministeredObject (implements java.lang.annotation.Annotation)
  • javax.resource.spi.Activation (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.resource.spi.TransactionSupport.TransactionSupportLevel
      • javax.resource.spi.AuthenticationMechanism.CredentialInterface
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LazyAssociatableConnectionManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface LazyAssociatableConnectionManager

  • public interface LazyAssociatableConnectionManager
    This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation. An implementation of this interface must support the lazy connection association optimization.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void associateConnection(Object connection, ManagedConnectionFactory mcf, ConnectionRequestInfo cxReqInfo)
      This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.
      void inactiveConnectionClosed(Object connection, ManagedConnectionFactory mcf)
      This method is called by the resource adapter (that is capable of lazy connection association optimization) in order to notify the application server that a disassociated connection handle is closed.

    • Method Detail

      • associateConnection

        void associateConnection(Object connection,
                       ManagedConnectionFactory mcf,
                       ConnectionRequestInfo cxReqInfo)
                         throws ResourceException
        This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.
        Parameters:
        connection - the connection object that is to be associated.
        mcf - The ManagedConnectionFactory instance that was originally used to create the connection object.
        cxReqInfo - connection request information. This information must be the same as that used to originally create the connection object.
        Throws:
        ResourceException - Generic exception.
        ApplicationServerInternalException - Application server specific exception.
        SecurityException - Security related error.
        ResourceAllocationException - Failed to allocate system resources for connection request.
        ResourceAdapterInternalException - Resource adapter related error condition.

      • inactiveConnectionClosed

        void inactiveConnectionClosed(Object connection,
                            ManagedConnectionFactory mcf)
        This method is called by the resource adapter (that is capable of lazy connection association optimization) in order to notify the application server that a disassociated connection handle is closed.

        The application server can then perform any cleanup operations related to the disassociated connection handle in its connection pool.

        Parameters:
        connection - the disassociated connection object handle that has been closed
        mcf - The ManagedConnectionFactory instance that was originally used to create the connection object.
        Since:
        1.6
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LazyEnlistableConnectionManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface LazyEnlistableConnectionManager

  • public interface LazyEnlistableConnectionManager
    This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation. An implementation of this interface must support the lazy transaction enlistment optimization.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void lazyEnlist(ManagedConnection mc)
      This method is called by a resource adapter (that is capable of lazy transaction enlistment optimization) in order to lazily enlist a connection object with a XA transaction.

    • Method Detail

      • lazyEnlist

        void lazyEnlist(ManagedConnection mc)
                throws ResourceException
        This method is called by a resource adapter (that is capable of lazy transaction enlistment optimization) in order to lazily enlist a connection object with a XA transaction.
        Parameters:
        mc - The ManagedConnection instance that needs to be lazily associated.
        Throws:
        ResourceException - Generic exception.
        ApplicationServerInternalException - Application server specific exception.
        ResourceAllocationException - Failed to allocate system resources for connection request.
        ResourceAdapterInternalException - Resource adapter related error condition.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LazyEnlistableManagedConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface LazyEnlistableManagedConnection

  • public interface LazyEnlistableManagedConnection
    This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation. An implementation of this interface must support the lazy transaction enlistment optimization.
    Version:
    1.0
    Author:
    Ram Jeyaraman
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LocalTransaction (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface LocalTransaction

  • public interface LocalTransaction
    LocalTransaction interface provides support for transactions that are managed internal to an EIS resource manager, and do not require an external transaction manager.

    A resource adapter implements the javax.resource.spi.LocalTransaction interface to provide support for local transactions that are performed on the underlying resource manager.

    If a resource adapter supports the LocalTransaction interface, then the application server can choose to perform local transaction optimization (uses local transaction instead of a JTA transaction for a single resource manager case).

    Version:
    0.5
    Author:
    Rahul Sharma
    See Also:
    ManagedConnection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void begin()
      Begin a local transaction
      void commit()
      Commit a local transaction
      void rollback()
      Rollback a local transaction

    • Method Detail

      • begin

        void begin()
           throws ResourceException
        Begin a local transaction
        Throws:
        ResourceException - generic exception if operation fails
        LocalTransactionException - error condition related to local transaction management
        ResourceAdapterInternalException - error condition internal to resource adapter
        EISSystemException - EIS instance specific error condition

      • commit

        void commit()
            throws ResourceException
        Commit a local transaction
        Throws:
        ResourceException - generic exception if operation fails
        LocalTransactionException - error condition related to local transaction management
        ResourceAdapterInternalException - error condition internal to resource adapter
        EISSystemException - EIS instance specific error condition

      • rollback

        void rollback()
              throws ResourceException
        Rollback a local transaction
        Throws:
        ResourceException - generic exception if operation fails
        LocalTransactionException - error condition related to local transaction management
        ResourceAdapterInternalException - error condition internal to resource adapter
        EISSystemException - EIS instance specific error condition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LocalTransactionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class LocalTransactionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.LocalTransactionException
  • All Implemented Interfaces:
    Serializable

    public class LocalTransactionException
extends ResourceException
    A LocalTransactionException represents various error conditions related to the local transaction management contract. The Java Transaction API specification specifies the javax.transaction.xa.XAException class for exceptions related to XAResource based transaction management contract.

    The LocalTransactionException is used for the local transaction management contract to indicate the following common error conditions:

    • Invalid transaction context when a transaction operation is executed. For example, calling commit method on LocalTransaction object without an active local transaction is an error condition.
    • Transaction is rolled back instead of getting committed during a commit method call on the LocalTransaction object.
    • An attempt to start a local transaction from the same thread on a ManagedConnection that is already associated with an active local transaction.
    • Any resource adapter or resource manager specific error conditions related to local transaction management. Examples are violation of integrity of resources, deadlock detection, communication failure during transaction completion, retry required or any internal error in a resource manager.
    Version:
    1.0
    Author:
    Rahul Sharma, Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      LocalTransactionException()
      Constructs a new instance with null as its detail message.
      LocalTransactionException(String message)
      Constructs a new instance with the specified detail message.
      LocalTransactionException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      LocalTransactionException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      LocalTransactionException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • LocalTransactionException

        public LocalTransactionException()
        Constructs a new instance with null as its detail message.

      • LocalTransactionException

        public LocalTransactionException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • LocalTransactionException

        public LocalTransactionException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • LocalTransactionException

        public LocalTransactionException(String message,
                         Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • LocalTransactionException

        public LocalTransactionException(String message,
                         String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagedConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface ManagedConnection

  • public interface ManagedConnection
    ManagedConnection instance represents a physical connection to the underlying EIS.

    A ManagedConnection instance provides access to a pair of interfaces: javax.transaction.xa.XAResource and javax.resource.spi.LocalTransaction.

    XAResource interface is used by the transaction manager to associate and dissociate a transaction with the underlying EIS resource manager instance and to perform two-phase commit protocol. The ManagedConnection interface is not directly used by the transaction manager. More details on the XAResource interface are described in the JTA specification.

    The LocalTransaction interface is used by the application server to manage local transactions.

    Version:
    0.5
    Author:
    Rahul Sharma
    See Also:
    ManagedConnectionFactory, XAResource, LocalTransaction

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addConnectionEventListener(ConnectionEventListener listener)
      Adds a connection event listener to the ManagedConnection instance.
      void associateConnection(Object connection)
      Used typically by the container to change the association of an application-level connection handle with a ManagedConneciton instance.
      void cleanup()
      Application server calls this method to force any cleanup on the ManagedConnection instance.
      void destroy()
      Destroys the physical connection to the underlying resource manager.
      Object getConnection(Subject subject, ConnectionRequestInfo cxRequestInfo)
      Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance.
      LocalTransaction getLocalTransaction()
      Returns an javax.resource.spi.LocalTransaction instance.
      PrintWriter getLogWriter()
      Gets the log writer for this ManagedConnection instance.
      ManagedConnectionMetaData getMetaData()
      Gets the metadata information for this connection's underlying EIS resource manager instance.
      XAResource getXAResource()
      Returns an javax.transaction.xa.XAresource instance.
      void removeConnectionEventListener(ConnectionEventListener listener)
      Removes an already registered connection event listener from the ManagedConnection instance.
      void setLogWriter(PrintWriter out)
      Sets the log writer for this ManagedConnection instance.

    • Method Detail

      • getConnection

        Object getConnection(Subject subject,
                   ConnectionRequestInfo cxRequestInfo)
                     throws ResourceException
        Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance. This connection handle is used by the application code to refer to the underlying physical connection. This connection handle is associated with its ManagedConnection instance in a resource adapter implementation specific way.

        The ManagedConnection uses the Subject and additional ConnectionRequest Info (which is specific to resource adapter and opaque to application server) to set the state of the physical connection.

        Parameters:
        subject - security context as JAAS subject
        cxRequestInfo - ConnectionRequestInfo instance
        Returns:
        generic Object instance representing the connection handle. For CCI, the connection handle created by a ManagedConnection instance is of the type javax.resource.cci.Connection.
        Throws:
        ResourceException - generic exception if operation fails
        ResourceAdapterInternalException - resource adapter internal error condition
        SecurityException - security related error condition
        CommException - failed communication with EIS instance
        EISSystemException - internal error condition in EIS instance - used if EIS instance is involved in setting state of ManagedConnection

      • destroy

        void destroy()
             throws ResourceException
        Destroys the physical connection to the underlying resource manager.

        To manage the size of the connection pool, an application server can explictly call ManagedConnection.destroy to destroy a physical connection. A resource adapter should destroy all allocated system resources for this ManagedConnection instance when the method destroy is called.

        Throws:
        ResourceException - generic exception if operation failed
        IllegalStateException - illegal state for destroying connection

      • cleanup

        void cleanup()
             throws ResourceException
        Application server calls this method to force any cleanup on the ManagedConnection instance.

        The method ManagedConnection.cleanup initiates a cleanup of the any client-specific state as maintained by a ManagedConnection instance. The cleanup should invalidate all connection handles that had been created using this ManagedConnection instance. Any attempt by an application component to use the connection handle after cleanup of the underlying ManagedConnection should result in an exception.

        The cleanup of ManagedConnection is always driven by an application server. An application server should not invoke ManagedConnection.cleanup when there is an uncompleted transaction (associated with a ManagedConnection instance) in progress.

        The invocation of ManagedConnection.cleanup method on an already cleaned-up connection should not throw an exception.

        The cleanup of ManagedConnection instance resets its client specific state and prepares the connection to be put back in to a connection pool. The cleanup method should not cause resource adapter to close the physical pipe and reclaim system resources associated with the physical connection.

        Throws:
        ResourceException - generic exception if operation fails
        ResourceAdapterInternalException - resource adapter internal error condition
        IllegalStateException - Illegal state for calling connection cleanup. Example - if a localtransaction is in progress that doesn't allow connection cleanup

      • associateConnection

        void associateConnection(Object connection)
                         throws ResourceException
        Used typically by the container to change the association of an application-level connection handle with a ManagedConneciton instance. The container should find the right ManagedConnection instance and call the associateConnection method. In order to set a Connection Handle as the active connection handle, the container may also use the associateConnection method to set the same ManagedConnection associated with the Connection handle.

        The resource adapter is required to implement the associateConnection method. The method implementation for a ManagedConnection should dissociate the connection handle (passed as a parameter) from its currently associated ManagedConnection and associate the new connection handle with itself.

        Parameters:
        connection - Application-level connection handle
        Throws:
        ResourceException - Failed to associate the connection handle with this ManagedConnection instance
        IllegalStateException - Illegal state for invoking this method
        ResourceAdapterInternalException - Resource adapter internal error condition

      • addConnectionEventListener

        void addConnectionEventListener(ConnectionEventListener listener)
        Adds a connection event listener to the ManagedConnection instance.

        The registered ConnectionEventListener instances are notified of connection close and error events, also of local transaction related events on the Managed Connection.

        Parameters:
        listener - a new ConnectionEventListener to be registered

      • removeConnectionEventListener

        void removeConnectionEventListener(ConnectionEventListener listener)
        Removes an already registered connection event listener from the ManagedConnection instance.
        Parameters:
        listener - already registered connection event listener to be removed

      • getXAResource

        XAResource getXAResource()
                         throws ResourceException
        Returns an javax.transaction.xa.XAresource instance. An application server enlists this XAResource instance with the Transaction Manager if the ManagedConnection instance is being used in a JTA transaction that is being coordinated by the Transaction Manager.
        Returns:
        XAResource instance
        Throws:
        ResourceException - generic exception if operation fails
        NotSupportedException - if the operation is not supported
        ResourceAdapterInternalException - resource adapter internal error condition

      • getLocalTransaction

        LocalTransaction getLocalTransaction()
                                     throws ResourceException
        Returns an javax.resource.spi.LocalTransaction instance. The LocalTransaction interface is used by the container to manage local transactions for a RM instance.
        Returns:
        LocalTransaction instance
        Throws:
        ResourceException - generic exception if operation fails
        NotSupportedException - if the operation is not supported
        ResourceAdapterInternalException - resource adapter internal error condition

      • getMetaData

        ManagedConnectionMetaData getMetaData()
                                      throws ResourceException

        Gets the metadata information for this connection's underlying EIS resource manager instance. The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with the ManagedConenction instance.

        Returns:
        ManagedConnectionMetaData instance
        Throws:
        ResourceException - generic exception if operation fails
        NotSupportedException - if the operation is not supported

      • setLogWriter

        void setLogWriter(PrintWriter out)
                  throws ResourceException
        Sets the log writer for this ManagedConnection instance.

        The log writer is a character output stream to which all logging and tracing messages for this ManagedConnection instance will be printed. Application Server manages the association of output stream with the ManagedConnection instance based on the connection pooling requirements.

        When a ManagedConnection object is initially created, the default log writer associated with this instance is obtained from the ManagedConnectionFactory. An application server can set a log writer specific to this ManagedConnection to log/trace this instance using setLogWriter method.

        Parameters:
        out - Character Output stream to be associated
        Throws:
        ResourceException - generic exception if operation fails
        ResourceAdapterInternalException - resource adapter related error condition

      • getLogWriter

        PrintWriter getLogWriter()
                         throws ResourceException
        Gets the log writer for this ManagedConnection instance.

        The log writer is a character output stream to which all logging and tracing messages for this ManagedConnection instance will be printed. ConnectionManager manages the association of output stream with the ManagedConnection instance based on the connection pooling requirements.

        The Log writer associated with a ManagedConnection instance can be one set as default from the ManagedConnectionFactory (that created this connection) or one set specifically for this instance by the application server.

        Returns:
        Character ourput stream associated with this Managed- Connection instance
        Throws:
        ResourceException - generic exception if operation fails
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagedConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface ManagedConnectionFactory

  • All Superinterfaces:
    Serializable

    public interface ManagedConnectionFactory
extends Serializable
    ManagedConnectionFactory instance is a factory of both ManagedConnection and EIS-specific connection factory instances. This interface supports connection pooling by providing methods for matching and creation of ManagedConnection instance. A ManagedConnectionFactory instance is required to be a JavaBean.
    Version:
    0.6
    Author:
    Rahul Sharma
    See Also:
    ManagedConnection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object createConnectionFactory()
      Creates a Connection Factory instance.
      Object createConnectionFactory(ConnectionManager cxManager)
      Creates a Connection Factory instance.
      ManagedConnection createManagedConnection(Subject subject, ConnectionRequestInfo cxRequestInfo)
      Creates a new physical connection to the underlying EIS resource manager.
      boolean equals(Object other)
      Check if this ManagedConnectionFactory is equal to another ManagedConnectionFactory.
      PrintWriter getLogWriter()
      Get the log writer for this ManagedConnectionFactory instance.
      int hashCode()
      Returns the hash code for the ManagedConnectionFactory
      ManagedConnection matchManagedConnections(Set connectionSet, Subject subject, ConnectionRequestInfo cxRequestInfo)
      Returns a matched connection from the candidate set of connections.
      void setLogWriter(PrintWriter out)
      Set the log writer for this ManagedConnectionFactory instance.

    • Method Detail

      • createConnectionFactory

        Object createConnectionFactory(ConnectionManager cxManager)
                               throws ResourceException
        Creates a Connection Factory instance. The Connection Factory instance gets initialized with the passed ConnectionManager. In the managed scenario, ConnectionManager is provided by the application server.
        Parameters:
        cxManager - ConnectionManager to be associated with created EIS connection factory instance
        Returns:
        EIS-specific Connection Factory instance or javax.resource.cci.ConnectionFactory instance
        Throws:
        ResourceException - Generic exception
        ResourceAdapterInternalException - Resource adapter related error condition

      • createConnectionFactory

        Object createConnectionFactory()
                               throws ResourceException
        Creates a Connection Factory instance. The Connection Factory instance gets initialized with a default ConnectionManager provided by the resource adapter.
        Returns:
        EIS-specific Connection Factory instance or javax.resource.cci.ConnectionFactory instance
        Throws:
        ResourceException - Generic exception
        ResourceAdapterInternalException - Resource adapter related error condition

      • createManagedConnection

        ManagedConnection createManagedConnection(Subject subject,
                                        ConnectionRequestInfo cxRequestInfo)
                                          throws ResourceException
        Creates a new physical connection to the underlying EIS resource manager.

        ManagedConnectionFactory uses the security information (passed as Subject) and additional ConnectionRequestInfo (which is specific to ResourceAdapter and opaque to application server) to create this new connection.

        Parameters:
        subject - Caller's security information
        cxRequestInfo - Additional resource adapter specific connection request information
        Returns:
        ManagedConnection instance
        Throws:
        ResourceException - generic exception
        SecurityException - security related error
        ResourceAllocationException - failed to allocate system resources for connection request
        ResourceAdapterInternalException - resource adapter related error condition
        EISSystemException - internal error condition in EIS instance

      • matchManagedConnections

        ManagedConnection matchManagedConnections(Set connectionSet,
                                        Subject subject,
                                        ConnectionRequestInfo cxRequestInfo)
                                          throws ResourceException
        Returns a matched connection from the candidate set of connections.

        ManagedConnectionFactory uses the security info (as in Subject) and information provided through ConnectionRequestInfo and additional Resource Adapter specific criteria to do matching. Note that criteria used for matching is specific to a resource adapter and is not prescribed by the Connector specification.

        This method returns a ManagedConnection instance that is the best match for handling the connection allocation request.

        Parameters:
        connectionSet - candidate connection set
        subject - caller's security information
        cxRequestInfo - additional resource adapter specific connection request information
        Returns:
        ManagedConnection if resource adapter finds an acceptable match otherwise null
        Throws:
        ResourceException - generic exception
        SecurityException - security related error
        ResourceAdapterInternalException - resource adapter related error condition
        NotSupportedException - if operation is not supported

      • setLogWriter

        void setLogWriter(PrintWriter out)
                  throws ResourceException
        Set the log writer for this ManagedConnectionFactory instance.

        The log writer is a character output stream to which all logging and tracing messages for this ManagedConnectionfactory instance will be printed.

        ApplicationServer manages the association of output stream with the ManagedConnectionFactory. When a ManagedConnectionFactory object is created the log writer is initially null, in other words, logging is disabled. Once a log writer is associated with a ManagedConnectionFactory, logging and tracing for ManagedConnectionFactory instance is enabled.

        The ManagedConnection instances created by ManagedConnectionFactory "inherits" the log writer, which can be overridden by ApplicationServer using ManagedConnection.setLogWriter to set ManagedConnection specific logging and tracing.

        Parameters:
        out - PrintWriter - an out stream for error logging and tracing
        Throws:
        ResourceException - generic exception
        ResourceAdapterInternalException - resource adapter related error condition

      • getLogWriter

        PrintWriter getLogWriter()
                         throws ResourceException
        Get the log writer for this ManagedConnectionFactory instance.

        The log writer is a character output stream to which all logging and tracing messages for this ManagedConnectionFactory instance will be printed

        ApplicationServer manages the association of output stream with the ManagedConnectionFactory. When a ManagedConnectionFactory object is created the log writer is initially null, in other words, logging is disabled.

        Returns:
        PrintWriter
        Throws:
        ResourceException - generic exception

      • hashCode

        int hashCode()
        Returns the hash code for the ManagedConnectionFactory
        Overrides:
        hashCode in class Object
        Returns:
        hash code for the ManagedConnectionFactory

      • equals

        boolean equals(Object other)
        Check if this ManagedConnectionFactory is equal to another ManagedConnectionFactory.
        Overrides:
        equals in class Object
        Returns:
        true if two instances are equal
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ManagedConnectionMetaData (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface ManagedConnectionMetaData

  • public interface ManagedConnectionMetaData
    The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with a ManagedConnection instance. An application server uses this information to get runtime information about a connected EIS instance.

    The method ManagedConnection.getMetaData returns a ManagedConnectionMetaData instance.

    Version:
    0.8
    Author:
    Rahul Sharma
    See Also:
    ManagedConnection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getEISProductName()
      Returns Product name of the underlying EIS instance connected through the ManagedConnection.
      String getEISProductVersion()
      Returns product version of the underlying EIS instance connected through the ManagedConnection.
      int getMaxConnections()
      Returns maximum limit on number of active concurrent connections that an EIS instance can support across client processes.
      String getUserName()
      Returns name of the user associated with the ManagedConnection instance.

    • Method Detail

      • getEISProductName

        String getEISProductName()
                         throws ResourceException
        Returns Product name of the underlying EIS instance connected through the ManagedConnection.
        Returns:
        Product name of the EIS instance.
        Throws:
        ResourceException

      • getEISProductVersion

        String getEISProductVersion()
                            throws ResourceException
        Returns product version of the underlying EIS instance connected through the ManagedConnection.
        Returns:
        Product version of the EIS instance
        Throws:
        ResourceException

      • getMaxConnections

        int getMaxConnections()
                      throws ResourceException
        Returns maximum limit on number of active concurrent connections that an EIS instance can support across client processes. If an EIS instance does not know about (or does not have) any such limit, it returns a 0.
        Returns:
        Maximum limit for number of active concurrent connections
        Throws:
        ResourceException

      • getUserName

        String getUserName()
                   throws ResourceException
        Returns name of the user associated with the ManagedConnection instance. The name corresponds to the resource principal under whose whose security context, a connection to the EIS instance has been established.
        Returns:
        name of the user
        Throws:
        ResourceException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface ResourceAdapter

  • public interface ResourceAdapter
    This represents a resource adapter instance and contains operations for lifecycle management and message endpoint setup. A concrete implementation of this interface is required to be a JavaBean.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void endpointActivation(MessageEndpointFactory endpointFactory, ActivationSpec spec)
      This is called during the activation of a message endpoint.
      void endpointDeactivation(MessageEndpointFactory endpointFactory, ActivationSpec spec)
      This is called when a message endpoint is deactivated.
      XAResource[] getXAResources(ActivationSpec[] specs)
      This method is called by the application server during crash recovery.
      void start(BootstrapContext ctx)
      This is called when a resource adapter instance is bootstrapped.
      void stop()
      This is called when a resource adapter instance is undeployed or during application server shutdown.

    • Method Detail

      • start

        void start(BootstrapContext ctx)
           throws ResourceAdapterInternalException
        This is called when a resource adapter instance is bootstrapped. This may be during resource adapter deployment or application server startup. This is a startup notification from the application server, and this method is called by an application server thread. The application server thread executes in an unspecified context.

        During this method call a ResourceAdapter JavaBean is responsible for initializing the resource adapter instance. Any exception thrown during this method call causes the application server to abort the bootstrap procedure for this specific resource adapter instance.

        Parameters:
        ctx - a bootstrap context containing references to useful facilities that could be used by a resource adapter instance.
        Throws:
        ResourceAdapterInternalException - indicates bootstrap failure. The resource adapter instance is unusable and must be discarded.

      • stop

        void stop()
        This is called when a resource adapter instance is undeployed or during application server shutdown. This is a shutdown notification from the application server, and this method is called by an application server thread. The application server thread executes in an unspecified context.

        During this method call, a ResourceAdapter JavaBean is responsible for performing an orderly shutdown of the resource adapter instance. Any exception thrown by this method call does not alter the processing of the application server shutdown or resource adapter undeployment that caused this method call. The application server may log the exception information for error reporting purposes.

      • endpointActivation

        void endpointActivation(MessageEndpointFactory endpointFactory,
                      ActivationSpec spec)
                        throws ResourceException
        This is called during the activation of a message endpoint. This causes the resource adapter instance to do the necessary setup (ie., setup message delivery for the message endpoint with a message provider). Note that message delivery to the message endpoint might start even before this method returns.

        Endpoint activation is deemed successful only when this method completes successfully without throwing any exceptions.

        Parameters:
        endpointFactory - a message endpoint factory instance.
        spec - an activation spec JavaBean instance.
        Throws:
        NotSupportedException - indicates message endpoint activation rejection due to incorrect activation setup information.
        ResourceException

      • endpointDeactivation

        void endpointDeactivation(MessageEndpointFactory endpointFactory,
                        ActivationSpec spec)
        This is called when a message endpoint is deactivated. The instances passed as arguments to this method call should be identical to those passed in for the corresponding endpointActivation call. This causes the resource adapter to stop delivering messages to the message endpoint.

        Any exception thrown by this method is ignored. After this method call, the endpoint is deemed inactive.

        Parameters:
        endpointFactory - a message endpoint factory instance.
        spec - an activation spec JavaBean instance.

      • getXAResources

        XAResource[] getXAResources(ActivationSpec[] specs)
                            throws ResourceException
        This method is called by the application server during crash recovery. This method takes in an array of ActivationSpec JavaBeans and returns an array of XAResource objects each of which represents a unique resource manager. The resource adapter may return null if it does not implement the XAResource interface. Otherwise, it must return an array of XAResource objects, each of which represents a unique resource manager that was used by the endpoint applications. The application server uses the XAResource objects to query each resource manager for a list of in-doubt transactions. It then completes each pending transaction by sending the commit decision to the participating resource managers.
        Parameters:
        specs - an array of ActivationSpec JavaBeans each of which corresponds to an deployed endpoint application that was active prior to the system crash.
        Returns:
        an array of XAResource objects each of which represents a unique resource manager.
        Throws:
        ResourceException - generic exception if operation fails due to an error condition.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceAdapterAssociation (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface ResourceAdapterAssociation

  • All Known Subinterfaces:
    ActivationSpec

    public interface ResourceAdapterAssociation
    This interface specifies the methods to associate a ResourceAdapter object with other objects that implement this interface like ManagedConnectionFactory and ActivationSpec.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ResourceAdapter getResourceAdapter()
      Get the associated ResourceAdapter object.
      void setResourceAdapter(ResourceAdapter ra)
      Associate this object with a ResourceAdapter object.

    • Method Detail

      • getResourceAdapter

        ResourceAdapter getResourceAdapter()
        Get the associated ResourceAdapter object.
        Returns:
        the associated ResourceAdapter object.

      • setResourceAdapter

        void setResourceAdapter(ResourceAdapter ra)
                        throws ResourceException
        Associate this object with a ResourceAdapter object. Note, this method must be called exactly once. That is, the association must not change during the lifetime of this object.
        Parameters:
        ra - ResourceAdapter object to be associated with.
        Throws:
        ResourceException - generic exception.
        ResourceAdapterInternalException - resource adapter related error condition.
        IllegalStateException - indicates that this object is in an illegal state for the method invocation. For example, this occurs when this method is called more than once on the same object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceAdapterInternalException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class ResourceAdapterInternalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.ResourceAdapterInternalException
  • All Implemented Interfaces:
    Serializable

    public class ResourceAdapterInternalException
extends ResourceException
    A ResourceAdapterInternalException indicates any system-level error conditions related to a resource adapter. The common conditions indicated by this exception type are:
    • Invalid configuration for creation of a new physical connection. An example is invalid server name for a target EIS instance.
    • Failure to create a physical connection to a EIS instance due to communication protocol error or any resource adapter implementation specific error.
    • Error conditions internal to resource adapter implementation.
    Version:
    1.0
    Author:
    Rahul Sharma, Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceAdapterInternalException()
      Constructs a new instance with null as its detail message.
      ResourceAdapterInternalException(String message)
      Constructs a new instance with the specified detail message.
      ResourceAdapterInternalException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      ResourceAdapterInternalException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      ResourceAdapterInternalException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ResourceAdapterInternalException

        public ResourceAdapterInternalException()
        Constructs a new instance with null as its detail message.

      • ResourceAdapterInternalException

        public ResourceAdapterInternalException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • ResourceAdapterInternalException

        public ResourceAdapterInternalException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • ResourceAdapterInternalException

        public ResourceAdapterInternalException(String message,
                                Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • ResourceAdapterInternalException

        public ResourceAdapterInternalException(String message,
                                String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceAllocationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class ResourceAllocationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.ResourceAllocationException
  • All Implemented Interfaces:
    Serializable

    public class ResourceAllocationException
extends ResourceException
    A ResourceAllocationException can be thrown by an application server or resource adapter to indicate any failure to allocate system resources (example: threads, physical connections). An example is error condition when an upper bound is reached on the maximum number of physical connections that can be managed by an application server specific connection pool.
    Version:
    1.0
    Author:
    Rahul Sharma, Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceAllocationException()
      Constructs a new instance with null as its detail message.
      ResourceAllocationException(String message)
      Constructs a new instance with the specified detail message.
      ResourceAllocationException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      ResourceAllocationException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      ResourceAllocationException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ResourceAllocationException

        public ResourceAllocationException()
        Constructs a new instance with null as its detail message.

      • ResourceAllocationException

        public ResourceAllocationException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • ResourceAllocationException

        public ResourceAllocationException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • ResourceAllocationException

        public ResourceAllocationException(String message,
                           Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • ResourceAllocationException

        public ResourceAllocationException(String message,
                           String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RetryableException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface RetryableException

  • All Superinterfaces:
    Serializable
    All Known Implementing Classes:
    RetryableUnavailableException, RetryableWorkRejectedException

    public interface RetryableException
extends Serializable
    A marker interface indicating that the Exception is transient. It is used in situations where a previously failed operation might be able to succeed if the resource adapter performs some recovery steps and retries the operation.
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RetryableUnavailableException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class RetryableUnavailableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.UnavailableException
            • javax.resource.spi.RetryableUnavailableException
  • All Implemented Interfaces:
    Serializable, RetryableException

    public class RetryableUnavailableException
extends UnavailableException
implements RetryableException
    A subclass of the UnavailableException that indicates that the rejection of the work submission is transient. It is thrown in situations where the previously failed work submission might be able to succeed if the resource adapter retries the operation at a later point in time.
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      RetryableUnavailableException()
      Constructs a new instance with null as its detail message.
      RetryableUnavailableException(String message)
      Constructs a new instance with the specified detail message.
      RetryableUnavailableException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      RetryableUnavailableException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      RetryableUnavailableException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • RetryableUnavailableException

        public RetryableUnavailableException()
        Constructs a new instance with null as its detail message.

      • RetryableUnavailableException

        public RetryableUnavailableException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • RetryableUnavailableException

        public RetryableUnavailableException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • RetryableUnavailableException

        public RetryableUnavailableException(String message,
                             Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • RetryableUnavailableException

        public RetryableUnavailableException(String message,
                             String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SecurityException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class SecurityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.SecurityException
  • All Implemented Interfaces:
    Serializable

    public class SecurityException
extends ResourceException
    A SecurityException indicates error conditions related to the security contract between an application server and resource adapter. The common error conditions represented by this exception are:
    • Invalid security information (represented as a Subject instance) passed across the security contract - for example, credentials have expired or have invalid format.
    • Lack of support for a specific security mechanism in an EIS or resource adapter.
    • Failure to create a connection to an EIS because of failed authentication or authorization.
    • Failure to authenticate a resource principal to an EIS instance or failure to establish a secure association with an underlying EIS instance.
    • Access control exception to indicate that a requested access to an EIS resource or a request to create a new connection is denied.
    Version:
    1.0
    Author:
    Rahul Sharma, Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SecurityException()
      Constructs a new instance with null as its detail message.
      SecurityException(String message)
      Constructs a new instance with the specified detail message.
      SecurityException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      SecurityException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      SecurityException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SecurityException

        public SecurityException()
        Constructs a new instance with null as its detail message.

      • SecurityException

        public SecurityException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • SecurityException

        public SecurityException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • SecurityException

        public SecurityException(String message,
                 Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • SecurityException

        public SecurityException(String message,
                 String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SecurityPermission (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.resource.spi

Annotation Type SecurityPermission

  • @Documented
@Retention(value=RUNTIME)
@Target(value={})
public @interface SecurityPermission
    The SecurityPermission annotation can be used by the developer, as part of the Connector annotation, to specify the extended security permissions required by the resource adapter
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String[] description
      Specifies an optional description to mention any specific reason that a resource requires a given security permission.
      String permissionSpec
      Specifies a security permission based on the Security policy file syntax.

    • Element Detail

      • description

        public abstract String[] description
        Specifies an optional description to mention any specific reason that a resource requires a given security permission.
        Default:
        {}

      • permissionSpec

        public abstract String permissionSpec
        Specifies a security permission based on the Security policy file syntax. These security permissions are different from those required by the default permission set as specified in the connector specification.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


SharingViolationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class SharingViolationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.SharingViolationException
  • All Implemented Interfaces:
    Serializable

    public class SharingViolationException
extends ResourceException
    This is thrown to indicate a connection sharing violation.

    This may be thrown by a resource adapter when an application uses a shareable connection in an unshareable manner.

    Version:
    1.0
    Author:
    Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SharingViolationException()
      Constructs a new instance with null as its detail message.
      SharingViolationException(String message)
      Constructs a new instance with the specified detail message.
      SharingViolationException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and error code.
      SharingViolationException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      SharingViolationException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SharingViolationException

        public SharingViolationException()
        Constructs a new instance with null as its detail message.

      • SharingViolationException

        public SharingViolationException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • SharingViolationException

        public SharingViolationException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • SharingViolationException

        public SharingViolationException(String message,
                         Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • SharingViolationException

        public SharingViolationException(String message,
                         String errorCode)
        Constructs a new throwable with the specified detail message and error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionSupport (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface TransactionSupport

  • All Superinterfaces:
    Serializable

    public interface TransactionSupport
extends Serializable
    This interface may be optionally implemented by a ManagedConnectionFactory to provide its level of transaction support at runtime.

    When a ManagedConnectionFactory implements this interface, the application server uses the TransactionSupportLevel returned by getTransactionSupport() method and not the value specified in the resource adapter deployment descriptor or deployer configuration

    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  TransactionSupport.TransactionSupportLevel
      An enumerated type that represents the levels of transaction support a resource adapter may support.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      TransactionSupport.TransactionSupportLevel getTransactionSupport()
      Get the level of transaction support, supported by the ManagedConnectionFactory.

    • Method Detail

      • getTransactionSupport

        TransactionSupport.TransactionSupportLevel getTransactionSupport()
        Get the level of transaction support, supported by the ManagedConnectionFactory. A resource adapter must always return a level of transaction support whose ordinal value in TransactionSupportLevel enum is equal to or lesser than the resource adapter's transaction support classification.
        Since:
        1.6
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionSupport.TransactionSupportLevel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.resource.spi

Enum TransactionSupport.TransactionSupportLevel

  • java.lang.Object
    • java.lang.Enum<TransactionSupport.TransactionSupportLevel>
      • javax.resource.spi.TransactionSupport.TransactionSupportLevel
  • All Implemented Interfaces:
    Serializable, Comparable<TransactionSupport.TransactionSupportLevel>
    Enclosing interface:
    TransactionSupport

    public static enum TransactionSupport.TransactionSupportLevel
extends Enum<TransactionSupport.TransactionSupportLevel>
    An enumerated type that represents the levels of transaction support a resource adapter may support.
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      LocalTransaction
      The resource adapter supports resource manager local transactions by implementing the LocalTransaction interface.
      NoTransaction
      The resource adapter supports neither resource manager nor JTA transactions.
      XATransaction
      The resource adapter supports both resource manager local and JTA transactions by implementing the LocalTransaction and XAResource interfaces.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static TransactionSupport.TransactionSupportLevel valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static TransactionSupport.TransactionSupportLevel[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NoTransaction

        public static final TransactionSupport.TransactionSupportLevel NoTransaction
        The resource adapter supports neither resource manager nor JTA transactions.
        Since:
        1.6

      • LocalTransaction

        public static final TransactionSupport.TransactionSupportLevel LocalTransaction
        The resource adapter supports resource manager local transactions by implementing the LocalTransaction interface.
        Since:
        1.6

      • XATransaction

        public static final TransactionSupport.TransactionSupportLevel XATransaction
        The resource adapter supports both resource manager local and JTA transactions by implementing the LocalTransaction and XAResource interfaces.
        Since:
        1.6

    • Method Detail

      • values

        public static TransactionSupport.TransactionSupportLevel[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (TransactionSupport.TransactionSupportLevel c : TransactionSupport.TransactionSupportLevel.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static TransactionSupport.TransactionSupportLevel valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


UnavailableException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Class UnavailableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.UnavailableException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    RetryableUnavailableException

    public class UnavailableException
extends ResourceException
    This is thrown to indicate that a service is unavailable.
    Version:
    1.0
    Author:
    Ram Jeyaraman
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      UnavailableException()
      Constructs a new instance with null as its detail message.
      UnavailableException(String message)
      Constructs a new instance with the specified detail message.
      UnavailableException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      UnavailableException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      UnavailableException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnavailableException

        public UnavailableException()
        Constructs a new instance with null as its detail message.

      • UnavailableException

        public UnavailableException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • UnavailableException

        public UnavailableException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • UnavailableException

        public UnavailableException(String message,
                    Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • UnavailableException

        public UnavailableException(String message,
                    String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.resource.spi (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.resource.spi

  • Packages that use javax.resource.spi
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.endpoint
    This package contains system contracts for service endpoint interactions.
    javax.resource.spi.security
    The javax.resource.spi.security package contains APIs for the security management contract.
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.
  • Classes in javax.resource.spi used by javax.resource.spi
    Class and Description
    ActivationSpec
    This interface serves as a marker.
    AuthenticationMechanism.CredentialInterface
    An enumerated type that represents the various interfaces that a resource adapter may support for the representation of the credentials.
    BootstrapContext
    This provides a mechanism to pass a bootstrap context to a resource adapter instance when it is bootstrapped.
    ConnectionEvent
    The ConnectionEvent class provides information about the source of a connection related event.A ConnectionEvent instance contains the following information: Type of the connection event ManagedConnection instance that generated the connection event.
    ConnectionEventListener
    The ConnectionEventListener interface provides an event callback mechanism to enable an application server to receive notifications from a ManagedConnection instance.
    ConnectionManager
    ConnectionManager interface provides a hook for the resource adapter to pass a connection request to the application server.
    ConnectionRequestInfo
    The ConnectionRequestInfo interface enables a resource adapter to pass its own request specific data structure across the connection request flow.
    InvalidPropertyException
    This exception is thrown to indicate invalid configuration property settings.
    LocalTransaction
    LocalTransaction interface provides support for transactions that are managed internal to an EIS resource manager, and do not require an external transaction manager.
    ManagedConnection
    ManagedConnection instance represents a physical connection to the underlying EIS.
    ManagedConnectionFactory
    ManagedConnectionFactory instance is a factory of both ManagedConnection and EIS-specific connection factory instances.
    ManagedConnectionMetaData
    The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with a ManagedConnection instance.
    ResourceAdapter
    This represents a resource adapter instance and contains operations for lifecycle management and message endpoint setup.
    ResourceAdapterAssociation
    This interface specifies the methods to associate a ResourceAdapter object with other objects that implement this interface like ManagedConnectionFactory and ActivationSpec.
    ResourceAdapterInternalException
    A ResourceAdapterInternalException indicates any system-level error conditions related to a resource adapter.
    RetryableException
    A marker interface indicating that the Exception is transient.
    TransactionSupport.TransactionSupportLevel
    An enumerated type that represents the levels of transaction support a resource adapter may support.
    UnavailableException
    This is thrown to indicate that a service is unavailable.
    XATerminator
    The XATerminator interface is used for transaction completion and crash recovery flows.
  • Classes in javax.resource.spi used by javax.resource.spi.endpoint
    Class and Description
    UnavailableException
    This is thrown to indicate that a service is unavailable.
  • Classes in javax.resource.spi used by javax.resource.spi.security
    Class and Description
    ManagedConnectionFactory
    ManagedConnectionFactory instance is a factory of both ManagedConnection and EIS-specific connection factory instances.
    SecurityException
    A SecurityException indicates error conditions related to the security contract between an application server and resource adapter.
  • Classes in javax.resource.spi used by javax.resource.spi.work
    Class and Description
    RetryableException
    A marker interface indicating that the Exception is transient.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidatingManagedConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface ValidatingManagedConnectionFactory

  • public interface ValidatingManagedConnectionFactory
    This interface is implemented by a ManagedConnectionFactory instance that supports the ability to validate ManagedConnection objects.

    This may be used by the application server to prune invalid ManagedConnection objects from its connection pool.

    The application server may use this functionality to test the validity of a ManagedConnection by passing in a Set of size one( with the ManagedConnection that has to be tested for validity as the only member of the Set.

    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set getInvalidConnections(Set connectionSet)
      This method returns a set of invalid ManagedConnection objects chosen from a specified set of ManagedConnection objects.

    • Method Detail

      • getInvalidConnections

        Set getInvalidConnections(Set connectionSet)
                          throws ResourceException
        This method returns a set of invalid ManagedConnection objects chosen from a specified set of ManagedConnection objects.
        Parameters:
        connectionSet - a set of ManagedConnection objects that need to be validated.
        Returns:
        a set of invalid ManagedConnection objects.
        Throws:
        ResourceException - generic exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XATerminator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi

Interface XATerminator

  • public interface XATerminator

    The XATerminator interface is used for transaction completion and crash recovery flows.

    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      Xid[] recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      void rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.

    • Method Detail

      • commit

        void commit(Xid xid,
          boolean onePhase)
            throws XAException
        Commits the global transaction specified by xid.
        Parameters:
        xid - A global transaction identifier
        onePhase - If true, the resource manager should use a one-phase commit protocol to commit the work done on behalf of xid.
        Throws:
        XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

        If the resource manager did not commit the transaction and the parameter onePhase is set to true, the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

      • forget

        void forget(Xid xid)
            throws XAException
        Tells the resource manager to forget about a heuristically completed transaction branch.
        Parameters:
        xid - A global transaction identifier.
        Throws:
        XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

      • prepare

        int prepare(Xid xid)
            throws XAException
        Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
        Parameters:
        xid - A global transaction identifier.
        Returns:
        A value indicating the resource manager's vote on the outcome of the transaction. The possible values are: XA_RDONLY or XA_OK. These constants are defined in javax.transaction.xa.XAResource interface. If the resource manager wants to roll back the transaction, it should do so by raising an appropriate XAException in the prepare method.
        Throws:
        XAException - An error has occurred. Possible exception values are: XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

      • recover

        Xid[] recover(int flag)
              throws XAException
        Obtains a list of prepared transaction branches from a resource manager. The transaction manager calls this method during recovery to obtain the list of transaction branches that are currently in prepared or heuristically completed states.
        Parameters:
        flag - One of TMSTARTRSCAN, TMENDRSCAN, TMNOFLAGS. TMNOFLAGS must be used when no other flags are set in the parameter. These constants are defined in javax.transaction.xa.XAResource interface.
        Returns:
        The resource manager returns zero or more XIDs of the transaction branches that are currently in a prepared or heuristically completed state. If an error occurs during the operation, the resource manager should throw the appropriate XAException.
        Throws:
        XAException - An error has occurred. Possible values are XAER_RMERR, XAER_RMFAIL, XAER_INVAL, and XAER_PROTO.

      • rollback

        void rollback(Xid xid)
              throws XAException
        Informs the resource manager to roll back work done on behalf of a transaction branch.
        Parameters:
        xid - A global transaction identifier.
        Throws:
        XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

        If the transaction branch is already marked rollback-only the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.resource.spi.Activation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.Activation

No usage of javax.resource.spi.Activation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.AdministeredObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.AdministeredObject

No usage of javax.resource.spi.AdministeredObject
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.ApplicationServerInternalException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.ApplicationServerInternalException

No usage of javax.resource.spi.ApplicationServerInternalException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.AuthenticationMechanism (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.AuthenticationMechanism

No usage of javax.resource.spi.AuthenticationMechanism
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.AuthenticationMechanism.CredentialInterface (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.AuthenticationMechanism.CredentialInterface

  • Packages that use AuthenticationMechanism.CredentialInterface
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of AuthenticationMechanism.CredentialInterface in javax.resource.spi

      Methods in javax.resource.spi that return AuthenticationMechanism.CredentialInterface
      Modifier and Type Method and Description
      static AuthenticationMechanism.CredentialInterface AuthenticationMechanism.CredentialInterface.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AuthenticationMechanism.CredentialInterface[] AuthenticationMechanism.CredentialInterface.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.CommException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.CommException

No usage of javax.resource.spi.CommException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.ConfigProperty (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.ConfigProperty

No usage of javax.resource.spi.ConfigProperty
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.ConnectionDefinition (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.ConnectionDefinition

No usage of javax.resource.spi.ConnectionDefinition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.ConnectionDefinitions (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.ConnectionDefinitions

No usage of javax.resource.spi.ConnectionDefinitions
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.ConnectionEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.ConnectionEvent

  • Packages that use ConnectionEvent
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of ConnectionEvent in javax.resource.spi

      Methods in javax.resource.spi with parameters of type ConnectionEvent
      Modifier and Type Method and Description
      void ConnectionEventListener.connectionClosed(ConnectionEvent event)
      Notifies that an application component has closed the connection.
      void ConnectionEventListener.connectionErrorOccurred(ConnectionEvent event)
      Notifies a connection related error.
      void ConnectionEventListener.localTransactionCommitted(ConnectionEvent event)
      Notifies that a Resource Manager Local Transaction was committed on the ManagedConnection instance.
      void ConnectionEventListener.localTransactionRolledback(ConnectionEvent event)
      Notifies that a Resource Manager Local Transaction was rolled back on the ManagedConnection instance.
      void ConnectionEventListener.localTransactionStarted(ConnectionEvent event)
      Notifies that a Resource Manager Local Transaction was started on the ManagedConnection instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.Connector (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.Connector

No usage of javax.resource.spi.Connector
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.EISSystemException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.EISSystemException

No usage of javax.resource.spi.EISSystemException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.IllegalStateException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.IllegalStateException

No usage of javax.resource.spi.IllegalStateException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.InvalidPropertyException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.InvalidPropertyException

  • Packages that use InvalidPropertyException
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of InvalidPropertyException in javax.resource.spi

      Methods in javax.resource.spi that throw InvalidPropertyException
      Modifier and Type Method and Description
      void ActivationSpec.validate()
      This method may be called by a deployment tool to validate the overall activation configuration information provided by the endpoint deployer.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.LocalTransactionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.LocalTransactionException

No usage of javax.resource.spi.LocalTransactionException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.ResourceAdapterInternalException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.ResourceAdapterInternalException

  • Packages that use ResourceAdapterInternalException
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of ResourceAdapterInternalException in javax.resource.spi

      Methods in javax.resource.spi that throw ResourceAdapterInternalException
      Modifier and Type Method and Description
      void ResourceAdapter.start(BootstrapContext ctx)
      This is called when a resource adapter instance is bootstrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.ResourceAllocationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.ResourceAllocationException

No usage of javax.resource.spi.ResourceAllocationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.RetryableUnavailableException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.RetryableUnavailableException

No usage of javax.resource.spi.RetryableUnavailableException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.SecurityException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.SecurityException

  • Packages that use SecurityException
    Package Description
    javax.resource.spi.security
    The javax.resource.spi.security package contains APIs for the security management contract.

    • Uses of SecurityException in javax.resource.spi.security

      Methods in javax.resource.spi.security that throw SecurityException
      Modifier and Type Method and Description
      byte[] GenericCredential.getCredentialData()
      Deprecated.
      Gets security data for a specific security mechanism represented by the GenericCredential.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.SecurityPermission (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.SecurityPermission

No usage of javax.resource.spi.SecurityPermission
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.SharingViolationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.SharingViolationException

No usage of javax.resource.spi.SharingViolationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.TransactionSupport.TransactionSupportLevel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.TransactionSupport.TransactionSupportLevel

  • Packages that use TransactionSupport.TransactionSupportLevel
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of TransactionSupport.TransactionSupportLevel in javax.resource.spi

      Methods in javax.resource.spi that return TransactionSupport.TransactionSupportLevel
      Modifier and Type Method and Description
      TransactionSupport.TransactionSupportLevel TransactionSupport.getTransactionSupport()
      Get the level of transaction support, supported by the ManagedConnectionFactory.
      static TransactionSupport.TransactionSupportLevel TransactionSupport.TransactionSupportLevel.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static TransactionSupport.TransactionSupportLevel[] TransactionSupport.TransactionSupportLevel.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.UnavailableException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.UnavailableException

  • Packages that use UnavailableException
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.endpoint
    This package contains system contracts for service endpoint interactions.

    • Uses of UnavailableException in javax.resource.spi

      Subclasses of UnavailableException in javax.resource.spi
      Modifier and Type Class and Description
      class  RetryableUnavailableException
      A subclass of the UnavailableException that indicates that the rejection of the work submission is transient.
      Methods in javax.resource.spi that throw UnavailableException
      Modifier and Type Method and Description
      Timer BootstrapContext.createTimer()
      Creates a new java.util.Timer instance.

    • Uses of UnavailableException in javax.resource.spi.endpoint

      Methods in javax.resource.spi.endpoint that throw UnavailableException
      Modifier and Type Method and Description
      MessageEndpoint MessageEndpointFactory.createEndpoint(XAResource xaResource)
      This is used to create a message endpoint.
      MessageEndpoint MessageEndpointFactory.createEndpoint(XAResource xaResource, long timeout)
      This is used to create a message endpoint.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.ActivationSpec (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.ActivationSpec

  • Packages that use ActivationSpec
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of ActivationSpec in javax.resource.spi

      Methods in javax.resource.spi with parameters of type ActivationSpec
      Modifier and Type Method and Description
      void ResourceAdapter.endpointActivation(MessageEndpointFactory endpointFactory, ActivationSpec spec)
      This is called during the activation of a message endpoint.
      void ResourceAdapter.endpointDeactivation(MessageEndpointFactory endpointFactory, ActivationSpec spec)
      This is called when a message endpoint is deactivated.
      XAResource[] ResourceAdapter.getXAResources(ActivationSpec[] specs)
      This method is called by the application server during crash recovery.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.BootstrapContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.BootstrapContext

  • Packages that use BootstrapContext
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of BootstrapContext in javax.resource.spi

      Methods in javax.resource.spi with parameters of type BootstrapContext
      Modifier and Type Method and Description
      void ResourceAdapter.start(BootstrapContext ctx)
      This is called when a resource adapter instance is bootstrapped.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.ConnectionEventListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.ConnectionEventListener

  • Packages that use ConnectionEventListener
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of ConnectionEventListener in javax.resource.spi

      Methods in javax.resource.spi with parameters of type ConnectionEventListener
      Modifier and Type Method and Description
      void ManagedConnection.addConnectionEventListener(ConnectionEventListener listener)
      Adds a connection event listener to the ManagedConnection instance.
      void ManagedConnection.removeConnectionEventListener(ConnectionEventListener listener)
      Removes an already registered connection event listener from the ManagedConnection instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.ConnectionManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.ConnectionManager

  • Packages that use ConnectionManager
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of ConnectionManager in javax.resource.spi

      Methods in javax.resource.spi with parameters of type ConnectionManager
      Modifier and Type Method and Description
      Object ManagedConnectionFactory.createConnectionFactory(ConnectionManager cxManager)
      Creates a Connection Factory instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.ConnectionRequestInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.ConnectionRequestInfo

  • Packages that use ConnectionRequestInfo
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of ConnectionRequestInfo in javax.resource.spi

      Methods in javax.resource.spi with parameters of type ConnectionRequestInfo
      Modifier and Type Method and Description
      Object ConnectionManager.allocateConnection(ManagedConnectionFactory mcf, ConnectionRequestInfo cxRequestInfo)
      The method allocateConnection gets called by the resource adapter's connection factory instance.
      void LazyAssociatableConnectionManager.associateConnection(Object connection, ManagedConnectionFactory mcf, ConnectionRequestInfo cxReqInfo)
      This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.
      ManagedConnection ManagedConnectionFactory.createManagedConnection(Subject subject, ConnectionRequestInfo cxRequestInfo)
      Creates a new physical connection to the underlying EIS resource manager.
      Object ManagedConnection.getConnection(Subject subject, ConnectionRequestInfo cxRequestInfo)
      Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance.
      ManagedConnection ManagedConnectionFactory.matchManagedConnections(Set connectionSet, Subject subject, ConnectionRequestInfo cxRequestInfo)
      Returns a matched connection from the candidate set of connections.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.DissociatableManagedConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.DissociatableManagedConnection

No usage of javax.resource.spi.DissociatableManagedConnection
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.LazyAssociatableConnectionManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.LazyAssociatableConnectionManager

No usage of javax.resource.spi.LazyAssociatableConnectionManager
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.LazyEnlistableConnectionManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.LazyEnlistableConnectionManager

No usage of javax.resource.spi.LazyEnlistableConnectionManager
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.LazyEnlistableManagedConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.LazyEnlistableManagedConnection

No usage of javax.resource.spi.LazyEnlistableManagedConnection
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.LocalTransaction (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.LocalTransaction

  • Packages that use LocalTransaction
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of LocalTransaction in javax.resource.spi

      Methods in javax.resource.spi that return LocalTransaction
      Modifier and Type Method and Description
      LocalTransaction ManagedConnection.getLocalTransaction()
      Returns an javax.resource.spi.LocalTransaction instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.ManagedConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.ManagedConnection

  • Packages that use ManagedConnection
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of ManagedConnection in javax.resource.spi

      Methods in javax.resource.spi that return ManagedConnection
      Modifier and Type Method and Description
      ManagedConnection ManagedConnectionFactory.createManagedConnection(Subject subject, ConnectionRequestInfo cxRequestInfo)
      Creates a new physical connection to the underlying EIS resource manager.
      ManagedConnection ManagedConnectionFactory.matchManagedConnections(Set connectionSet, Subject subject, ConnectionRequestInfo cxRequestInfo)
      Returns a matched connection from the candidate set of connections.
      Methods in javax.resource.spi with parameters of type ManagedConnection
      Modifier and Type Method and Description
      void LazyEnlistableConnectionManager.lazyEnlist(ManagedConnection mc)
      This method is called by a resource adapter (that is capable of lazy transaction enlistment optimization) in order to lazily enlist a connection object with a XA transaction.
      Constructors in javax.resource.spi with parameters of type ManagedConnection
      Constructor and Description
      ConnectionEvent(ManagedConnection source, int eid)
      Construct a ConnectionEvent object.
      ConnectionEvent(ManagedConnection source, int eid, Exception exception)
      Construct a ConnectionEvent object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.ManagedConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.ManagedConnectionFactory

  • Packages that use ManagedConnectionFactory
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.security
    The javax.resource.spi.security package contains APIs for the security management contract.

    • Uses of ManagedConnectionFactory in javax.resource.spi

      Methods in javax.resource.spi with parameters of type ManagedConnectionFactory
      Modifier and Type Method and Description
      Object ConnectionManager.allocateConnection(ManagedConnectionFactory mcf, ConnectionRequestInfo cxRequestInfo)
      The method allocateConnection gets called by the resource adapter's connection factory instance.
      void LazyAssociatableConnectionManager.associateConnection(Object connection, ManagedConnectionFactory mcf, ConnectionRequestInfo cxReqInfo)
      This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.
      void LazyAssociatableConnectionManager.inactiveConnectionClosed(Object connection, ManagedConnectionFactory mcf)
      This method is called by the resource adapter (that is capable of lazy connection association optimization) in order to notify the application server that a disassociated connection handle is closed.

    • Uses of ManagedConnectionFactory in javax.resource.spi.security

      Methods in javax.resource.spi.security that return ManagedConnectionFactory
      Modifier and Type Method and Description
      ManagedConnectionFactory PasswordCredential.getManagedConnectionFactory()
      Gets the target ManagedConnectionFactory for which the user name and password has been set by the application server.
      Methods in javax.resource.spi.security with parameters of type ManagedConnectionFactory
      Modifier and Type Method and Description
      void PasswordCredential.setManagedConnectionFactory(ManagedConnectionFactory mcf)
      Sets the target ManagedConenctionFactory instance for which the user name and password has been set by the application server.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.ManagedConnectionMetaData (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.ManagedConnectionMetaData

  • Packages that use ManagedConnectionMetaData
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of ManagedConnectionMetaData in javax.resource.spi

      Methods in javax.resource.spi that return ManagedConnectionMetaData
      Modifier and Type Method and Description
      ManagedConnectionMetaData ManagedConnection.getMetaData()
      Gets the metadata information for this connection's underlying EIS resource manager instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.ResourceAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.ResourceAdapter

  • Packages that use ResourceAdapter
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of ResourceAdapter in javax.resource.spi

      Methods in javax.resource.spi that return ResourceAdapter
      Modifier and Type Method and Description
      ResourceAdapter ResourceAdapterAssociation.getResourceAdapter()
      Get the associated ResourceAdapter object.
      Methods in javax.resource.spi with parameters of type ResourceAdapter
      Modifier and Type Method and Description
      void ResourceAdapterAssociation.setResourceAdapter(ResourceAdapter ra)
      Associate this object with a ResourceAdapter object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.ResourceAdapterAssociation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.ResourceAdapterAssociation

  • Packages that use ResourceAdapterAssociation
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of ResourceAdapterAssociation in javax.resource.spi

      Subinterfaces of ResourceAdapterAssociation in javax.resource.spi
      Modifier and Type Interface and Description
      interface  ActivationSpec
      This interface serves as a marker.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.RetryableException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.RetryableException

  • Packages that use RetryableException
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of RetryableException in javax.resource.spi

      Classes in javax.resource.spi that implement RetryableException
      Modifier and Type Class and Description
      class  RetryableUnavailableException
      A subclass of the UnavailableException that indicates that the rejection of the work submission is transient.

    • Uses of RetryableException in javax.resource.spi.work

      Classes in javax.resource.spi.work that implement RetryableException
      Modifier and Type Class and Description
      class  RetryableWorkRejectedException
      A subclass of the WorkRejectedException that indicates that the the service unavailability is transient.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.TransactionSupport (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.TransactionSupport

No usage of javax.resource.spi.TransactionSupport
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.ValidatingManagedConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.ValidatingManagedConnectionFactory

No usage of javax.resource.spi.ValidatingManagedConnectionFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.XATerminator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.XATerminator

  • Packages that use XATerminator
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of XATerminator in javax.resource.spi

      Methods in javax.resource.spi that return XATerminator
      Modifier and Type Method and Description
      XATerminator BootstrapContext.getXATerminator()
      Provides a handle to a XATerminator instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.resource.spi.endpoint (Java(TM) EE 7 Specification APIs)

javax.resource.spi.endpoint

Interfaces

  • MessageEndpoint
  • MessageEndpointFactory


javax.resource.spi.endpoint (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.resource.spi.endpoint

This package contains system contracts for service endpoint interactions.

See: Description

  • Interface Summary
    Interface Description
    MessageEndpoint
    This defines a contract for a message endpoint.
    MessageEndpointFactory
    This serves as a factory for creating message endpoints.

Package javax.resource.spi.endpoint Description

This package contains system contracts for service endpoint interactions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.resource.spi.endpoint Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.resource.spi.endpoint

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.resource.spi.endpoint.MessageEndpoint
  • javax.resource.spi.endpoint.MessageEndpointFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MessageEndpoint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.endpoint

Interface MessageEndpoint

  • public interface MessageEndpoint
    This defines a contract for a message endpoint. This is implemented by an application server.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterDelivery()
      This is called by a resource adapter after a message is delivered.
      void beforeDelivery(Method method)
      This is called by a resource adapter before a message is delivered.
      void release()
      This method may be called by the resource adapter to indicate that it no longer needs a proxy endpoint instance.

    • Method Detail

      • beforeDelivery

        void beforeDelivery(Method method)
                    throws NoSuchMethodException,
                           ResourceException
        This is called by a resource adapter before a message is delivered.
        Parameters:
        method - description of a target method. This information about the intended target method allows an application server to decide whether to start a transaction during this method call, depending on the transaction preferences of the target method. The processing (by the application server) of the actual message delivery method call on the endpoint must be independent of the class loader associated with this descriptive method object.
        Throws:
        NoSuchMethodException - indicates that the specified method does not exist on the target endpoint.
        ResourceException - generic exception.
        ApplicationServerInternalException - indicates an error condition in the application server.
        IllegalStateException - indicates that the endpoint is in an illegal state for the method invocation. For example, this occurs when beforeDelivery and afterDelivery method calls are not paired.
        UnavailableException - indicates that the endpoint is not available.

      • afterDelivery

        void afterDelivery()
                   throws ResourceException
        This is called by a resource adapter after a message is delivered.
        Throws:
        ResourceException - generic exception.
        ApplicationServerInternalException - indicates an error condition in the application server.
        IllegalStateException - indicates that the endpoint is in an illegal state for the method invocation. For example, this occurs when beforeDelivery and afterDelivery method calls are not paired.
        UnavailableException - indicates that the endpoint is not available.

      • release

        void release()
        This method may be called by the resource adapter to indicate that it no longer needs a proxy endpoint instance. This hint may be used by the application server for endpoint pooling decisions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageEndpointFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.endpoint

Interface MessageEndpointFactory

  • public interface MessageEndpointFactory
    This serves as a factory for creating message endpoints.
    Since:
    1.5
    Version:
    1.7
    Author:
    Ram Jeyaraman, Sivakumar Thyagarajan

    • Method Summary

      Methods
      Modifier and Type Method and Description
      MessageEndpoint createEndpoint(XAResource xaResource)
      This is used to create a message endpoint.
      MessageEndpoint createEndpoint(XAResource xaResource, long timeout)
      This is used to create a message endpoint.
      String getActivationName()
      Returns a unique name for the message endpoint deployment represented by the MessageEndpointFactory.
      Class<?> getEndpointClass()
      Return the Class object corresponding to the message endpoint class.
      boolean isDeliveryTransacted(Method method)
      This is used to find out whether message deliveries to a target method on a message listener interface that is implemented by a message endpoint or a target method in the Class returned by the getBeanClass method, will be transacted or not.

    • Method Detail

      • createEndpoint

        MessageEndpoint createEndpoint(XAResource xaResource)
                               throws UnavailableException
        This is used to create a message endpoint. The message endpoint is expected to implement the correct message listener type.
        Parameters:
        xaResource - an optional XAResource instance used to get transaction notifications when the message delivery is transacted.
        Returns:
        a message endpoint instance.
        Throws:
        UnavailableException - indicates a transient failure in creating a message endpoint. Subsequent attempts to create a message endpoint might succeed.

      • createEndpoint

        MessageEndpoint createEndpoint(XAResource xaResource,
                             long timeout)
                               throws UnavailableException
        This is used to create a message endpoint. The message endpoint is expected to implement the correct message listener type.
        Parameters:
        xaResource - an optional XAResource instance used to get transaction notifications when the message delivery is transacted.
        timeout - an optional value used to specify the time duration (in milliseconds) within which the message endpoint needs to be created by the MessageEndpointFactory. Otherwise, the MessageEndpointFactory rejects the creation of the MessageEndpoint with an UnavailableException. Note, this does not offer real-time guarantees.
        Returns:
        a message endpoint instance.
        Throws:
        UnavailableException - indicates a transient failure in creating a message endpoint. Subsequent attempts to create a message endpoint might succeed.
        Since:
        1.6

      • isDeliveryTransacted

        boolean isDeliveryTransacted(Method method)
                             throws NoSuchMethodException
        This is used to find out whether message deliveries to a target method on a message listener interface that is implemented by a message endpoint or a target method in the Class returned by the getBeanClass method, will be transacted or not. The message endpoint may indicate its transacted delivery preferences (at a per method level) through its deployment descriptor. The message delivery preferences must not change during the lifetime of a message endpoint.
        Parameters:
        method - description of a target method. This information about the intended target method allows an application server to find out whether the target method call will be transacted or not.
        Returns:
        true, if message endpoint requires transacted message delivery.
        Throws:
        NoSuchMethodException - indicates that the specified method does not exist on the target endpoint.

      • getActivationName

        String getActivationName()
        Returns a unique name for the message endpoint deployment represented by the MessageEndpointFactory. If the message endpoint has been deployed into a clustered application server then this method must return the same name for that message endpoint’s activation in each application server instance. It is recommended that this name be human-readable since this name may be used by the resource adapter in ways that may be visible to a user or administrator. It is also recommended that this name remain unchanged even in cases when the application server is restarted or the message endpoint redeployed.
        Returns:
        a new String instance representing the unique name of the message endpoint deployment
        Since:
        1.7

      • getEndpointClass

        Class<?> getEndpointClass()
        Return the Class object corresponding to the message endpoint class. For example, for a Message Driven Bean this is the Class object corresponding to the application's MDB class. The resource adapter may use this to introspect the message endpoint class to discover annotations, interfaces implemented, etc. and modify the behavior of the resource adapter accordingly. A return value of null indicates that the MessageEndpoint doesn't implement the business methods of underlying message endpoint class.
        Returns:
        A Class corresponding to the message endpoint class.
        Since:
        1.7
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.resource.spi.endpoint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.resource.spi.endpoint

  • Packages that use javax.resource.spi.endpoint
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.endpoint
    This package contains system contracts for service endpoint interactions.
  • Classes in javax.resource.spi.endpoint used by javax.resource.spi
    Class and Description
    MessageEndpointFactory
    This serves as a factory for creating message endpoints.
  • Classes in javax.resource.spi.endpoint used by javax.resource.spi.endpoint
    Class and Description
    MessageEndpoint
    This defines a contract for a message endpoint.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.endpoint.MessageEndpoint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.endpoint.MessageEndpoint

  • Packages that use MessageEndpoint
    Package Description
    javax.resource.spi.endpoint
    This package contains system contracts for service endpoint interactions.

    • Uses of MessageEndpoint in javax.resource.spi.endpoint

      Methods in javax.resource.spi.endpoint that return MessageEndpoint
      Modifier and Type Method and Description
      MessageEndpoint MessageEndpointFactory.createEndpoint(XAResource xaResource)
      This is used to create a message endpoint.
      MessageEndpoint MessageEndpointFactory.createEndpoint(XAResource xaResource, long timeout)
      This is used to create a message endpoint.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.endpoint.MessageEndpointFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.endpoint.MessageEndpointFactory

  • Packages that use MessageEndpointFactory
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of MessageEndpointFactory in javax.resource.spi

      Methods in javax.resource.spi with parameters of type MessageEndpointFactory
      Modifier and Type Method and Description
      void ResourceAdapter.endpointActivation(MessageEndpointFactory endpointFactory, ActivationSpec spec)
      This is called during the activation of a message endpoint.
      void ResourceAdapter.endpointDeactivation(MessageEndpointFactory endpointFactory, ActivationSpec spec)
      This is called when a message endpoint is deactivated.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


GenericCredential (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.security

Interface GenericCredential

  • Deprecated.
    The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.

    public interface GenericCredential
    The interface javax.resource.spi.security.GenericCredential defines a security mechanism independent interface for accessing security credential of a resource principal.

    The GenericCredential interface provides a Java wrapper over an underlying mechanism specific representation of a security credential. For example, the GenericCredential interface can be used to wrap Kerberos credentials.

    The connector architecture does not define any standard format and requirements for security mechanism specific credentials. For example, a security credential wrapped by a GenericCredential interface can have a native representation specific to an operating system.

    The GenericCredential interface enables a resource adapter to extract information about a security credential. The resource adapter can then manage EIS sign-on for a resource principal by either:

    • using the credentials in an EIS specific manner if the underlying EIS supports the security mechanism type represented by the GenericCredential instance, or,
    • using GSS-API if the resource adapter and underlying EIS instance support GSS-API.
    Since:
    0.7
    Version:
    0.7
    Author:
    Rahul Sharma
    See Also:
    Subject, Principal

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object another)
      Deprecated.
      Tests if this GenericCredential instance refers to the same entity as the supplied object.
      byte[] getCredentialData()
      Deprecated.
      Gets security data for a specific security mechanism represented by the GenericCredential.
      String getMechType()
      Deprecated.
      Returns the mechanism type for the GenericCredential instance.
      String getName()
      Deprecated.
      Returns the name of the resource principal associated with a GenericCredential instance.
      int hashCode()
      Deprecated.
      Returns the hash code for this GenericCredential

    • Method Detail

      • getName

        String getName()
        Deprecated.
        Returns the name of the resource principal associated with a GenericCredential instance.
        Returns:
        Name of the principal

      • getMechType

        String getMechType()
        Deprecated.
        Returns the mechanism type for the GenericCredential instance. The mechanism type definition for GenericCredential should be consistent with the Object Identifier (OID) based representation specified in the GSS specification. In the GenericCredential interface, the mechanism type is returned as a stringified representation of the OID specification.
        Returns:
        mechanism type

      • getCredentialData

        byte[] getCredentialData()
                         throws SecurityException
        Deprecated.
        Gets security data for a specific security mechanism represented by the GenericCredential. An example is authentication data required for establishing a secure association with an EIS instance on behalf of the associated resource principal.

        The getCredentialData method returns the credential representation as an array of bytes. Note that the connector architecture does not define any standard format for the returned credential data.

        Returns:
        credential representation as an array of bytes.
        Throws:
        SecurityException - Failed operation due to security related error condition

      • equals

        boolean equals(Object another)
        Deprecated.
        Tests if this GenericCredential instance refers to the same entity as the supplied object. The two credentials must be acquired over the same mechanisms and must refer to the same principal. Returns true if the two GenericCredentials refer to the same entity; false otherwise.
        Overrides:
        equals in class Object

      • hashCode

        int hashCode()
        Deprecated.
        Returns the hash code for this GenericCredential
        Overrides:
        hashCode in class Object
        Returns:
        hash code for this GenericCredential
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.resource.spi.security (Java(TM) EE 7 Specification APIs)

javax.resource.spi.security

Interfaces

  • GenericCredential

Classes

  • PasswordCredential


javax.resource.spi.security (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.resource.spi.security

The javax.resource.spi.security package contains APIs for the security management contract.

See: Description

  • Interface Summary
    Interface Description
    GenericCredential Deprecated
    The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.
  • Class Summary
    Class Description
    PasswordCredential
    The class PasswordCredential acts as a holder for username and password.

Package javax.resource.spi.security Description

The javax.resource.spi.security package contains APIs for the security management contract.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.resource.spi.security Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.resource.spi.security

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.resource.spi.security.PasswordCredential (implements java.io.Serializable)

Interface Hierarchy

  • javax.resource.spi.security.GenericCredential
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


PasswordCredential (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.security

Class PasswordCredential

  • java.lang.Object
    • javax.resource.spi.security.PasswordCredential
  • All Implemented Interfaces:
    Serializable

    public final class PasswordCredential
extends Object
implements Serializable
    The class PasswordCredential acts as a holder for username and password.
    Since:
    0.6
    Version:
    0.6
    Author:
    Rahul Sharma
    See Also:
    ManagedConnectionFactory, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      PasswordCredential(String userName, char[] password)
      Creates a new PasswordCredential object from the given user name and password.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object other)
      Compares this PasswordCredential with the specified object for equality.
      ManagedConnectionFactory getManagedConnectionFactory()
      Gets the target ManagedConnectionFactory for which the user name and password has been set by the application server.
      char[] getPassword()
      Returns the user password.
      String getUserName()
      Returns the user name.
      int hashCode()
      Returns the hash code for this PasswordCredential
      void setManagedConnectionFactory(ManagedConnectionFactory mcf)
      Sets the target ManagedConenctionFactory instance for which the user name and password has been set by the application server.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PasswordCredential

        public PasswordCredential(String userName,
                  char[] password)
        Creates a new PasswordCredential object from the given user name and password.

        Note that the given user password is cloned before it is stored in the new PasswordCredential object.

        Parameters:
        userName - the user name
        password - the user's password

    • Method Detail

      • getUserName

        public String getUserName()
        Returns the user name.
        Returns:
        the user name

      • getPassword

        public char[] getPassword()
        Returns the user password.

        Note that this method returns a reference to the password. It is the caller's responsibility to zero out the password information after it is no longer needed.

        Returns:
        the password

      • getManagedConnectionFactory

        public ManagedConnectionFactory getManagedConnectionFactory()
        Gets the target ManagedConnectionFactory for which the user name and password has been set by the application server. A ManagedConnection- Factory uses this field to find out whether PasswordCredential should be used by it for sign-on to the target EIS instance.
        Returns:
        ManagedConnectionFactory instance for which user name and password have been specified

      • setManagedConnectionFactory

        public void setManagedConnectionFactory(ManagedConnectionFactory mcf)
        Sets the target ManagedConenctionFactory instance for which the user name and password has been set by the application server.
        Parameters:
        mcf - ManagedConnectionFactory instance for which user name and password have been specified

      • equals

        public boolean equals(Object other)
        Compares this PasswordCredential with the specified object for equality. The two PasswordCredential instances are the same if they are equal in username and password.
        Overrides:
        equals in class Object
        Parameters:
        other - Object to which PasswordCredential is to be compared
        Returns:
        true if and if the specified object is a PasswordCredential whose username and password are equal to this instance.

      • hashCode

        public int hashCode()
        Returns the hash code for this PasswordCredential
        Overrides:
        hashCode in class Object
        Returns:
        hash code for this PasswordCredential
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.resource.spi.security (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.resource.spi.security

No usage of javax.resource.spi.security
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.security.PasswordCredential (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.security.PasswordCredential

No usage of javax.resource.spi.security.PasswordCredential
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.security.GenericCredential (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.security.GenericCredential

No usage of javax.resource.spi.security.GenericCredential
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


DistributableWork (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Interface DistributableWork

  • All Superinterfaces:
    Runnable, Serializable, Work

    public interface DistributableWork
extends Work, Serializable
    This models a Work instance that would be distributed by a DistributableWorkManager for execution in a remote DistributableWorkManager
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Method Summary

      • Methods inherited from interface javax.resource.spi.work.Work

        release

      • Methods inherited from interface java.lang.Runnable

        run
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DistributableWorkManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Interface DistributableWorkManager

  • All Superinterfaces:
    WorkManager

    public interface DistributableWorkManager
extends WorkManager
    This interface models a WorkManager that supports distributed execution of Work instances.

    A DistributableWorkManager may choose to distribute a Work instance submitted by a resource adapter to another WorkManager instance running in a different Java virtual machine (that is running in the same host or different hosts) for achieving optimal resource utilization or for providing better response times.

    A WorkManager implementation that supports the submission of DistributableWork instances must implement the DistributableWorkManager marker interface.

    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Field Summary

      • Fields inherited from interface javax.resource.spi.work.WorkManager

        IMMEDIATE, INDEFINITE, UNKNOWN

    • Method Summary

      • Methods inherited from interface javax.resource.spi.work.WorkManager

        doWork, doWork, scheduleWork, scheduleWork, startWork, startWork
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExecutionContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class ExecutionContext

  • java.lang.Object
    • javax.resource.spi.work.ExecutionContext
  • Direct Known Subclasses:
    TransactionContext

    public class ExecutionContext
extends Object
    This class models an execution context (transaction, security, etc) with which the Work instance must be executed. This class is provided as a convenience for easily creating ExecutionContext instances by extending this class and overriding only those methods of interest.

    Some reasons why it is better for ExecutionContext to be a class rather than an interface:

    • There is no need for a resource adapter to implement this class. It only needs to implement the context information like transaction, etc.
    • The resource adapter code does not have to change when the ExecutionContext class evolves. For example, more context types could be added to the ExecutionContext class (in the future) without forcing resource adapter implementations to change.
    Note: Resource adapters that are developed for Connectors 1.6 specification compliant application servers and above, are recommended to use the TransactionContext interface instead of this class. See Chapter.11 Generic Work Context in the Connectors 1.6 specification for more details.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Constructor Summary

      Constructors
      Constructor and Description
      ExecutionContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getTransactionTimeout()
      Get the transaction timeout value for a imported transaction.
      Xid getXid()
      void setTransactionTimeout(long timeout)
      Set the transaction timeout value for a imported transaction.
      void setXid(Xid xid)
      set a transaction context.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ExecutionContext

        public ExecutionContext()

    • Method Detail

      • setXid

        public void setXid(Xid xid)
        set a transaction context.
        Parameters:
        xid - transaction context.

      • getXid

        public Xid getXid()
        Returns:
        an Xid object carrying a transaction context, if any.

      • setTransactionTimeout

        public void setTransactionTimeout(long timeout)
                           throws NotSupportedException
        Set the transaction timeout value for a imported transaction.
        Parameters:
        timeout - transaction timeout value in seconds. Only positive non-zero values are accepted. Other values are illegal and are rejected with a NotSupportedException.
        Throws:
        NotSupportedException - thrown to indicate an illegal timeout value.

      • getTransactionTimeout

        public long getTransactionTimeout()
        Get the transaction timeout value for a imported transaction.
        Returns:
        the specified transaction timeout value in seconds. When no timeout value or an illegal timeout value had been specified, a value of -1 (WorkManager.UNKNOWN) is returned; the timeout processing of such a transaction depends on the application server implementation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HintsContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class HintsContext

  • java.lang.Object
    • javax.resource.spi.work.HintsContext
  • All Implemented Interfaces:
    Serializable, WorkContext

    public class HintsContext
extends Object
implements WorkContext
    A standard WorkContext that allows a Work instance to propagate quality-of-service (QoS) hints about the Work to the WorkManager.
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6
    See Also:
    WorkContextProvider, Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected String | description
      static String | LONGRUNNING_HINT
      protected String | name
      static String | NAME_HINT

    • Constructor Summary

      Constructors
      Constructor and Description
      HintsContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDescription()
      Get the brief description of the role played by the WorkContext and any other related debugging information.
      Map<String,Serializable> getHints()
      String getName()
      Get the associated name of the WorkContext.
      void setDescription(String description)
      Set a brief description of the role played by the instance of HintsContext and any other related debugging information.
      void setHint(String hintName, Serializable value)
      Set a Hint and a related value.
      void setName(String name)
      Set the associated name of the HintsContext.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • NAME_HINT

        public static final String NAME_HINT
        See Also:
        Constant Field Values

      • LONGRUNNING_HINT

        public static final String LONGRUNNING_HINT
        See Also:
        Constant Field Values

      • description

        protected String description

      • name

        protected String name

    • Constructor Detail

      • HintsContext

        public HintsContext()

    • Method Detail

      • getDescription

        public String getDescription()
        Get the brief description of the role played by the WorkContext and any other related debugging information. This could be used by the WorkManager and the resource adapter for debugging purposes.

        Specified by:
        getDescription in interface WorkContext
        Returns:
        the associated description of the WorkContext

      • getName

        public String getName()
        Get the associated name of the WorkContext. This could be used by the WorkManager and the resource adapter for debugging purposes.

        Specified by:
        getName in interface WorkContext
        Returns:
        the associated name of the WorkContext

      • setDescription

        public void setDescription(String description)
        Set a brief description of the role played by the instance of HintsContext and any other related debugging information. This could be used by the resource adapter and the WorkManager for logging and debugging purposes.

      • setName

        public void setName(String name)
        Set the associated name of the HintsContext. This could be used by the resource adapter and the WorkManager for logging and debugging purposes.

      • setHint

        public void setHint(String hintName,
           Serializable value)
        Set a Hint and a related value. The hintName must be non-Null. Standard HintNames are defined in the Connector specification. Use of "javax.resource." prefixed hintNames are reserved for use by the Connector specification.

      • getHints

        public Map<String,Serializable> getHints()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.resource.spi.work (Java(TM) EE 7 Specification APIs)

javax.resource.spi.work

Interfaces

  • DistributableWork
  • DistributableWorkManager
  • Work
  • WorkContext
  • WorkContextLifecycleListener
  • WorkContextProvider
  • WorkListener
  • WorkManager

Classes

  • ExecutionContext
  • HintsContext
  • SecurityContext
  • TransactionContext
  • WorkAdapter
  • WorkContextErrorCodes
  • WorkEvent

Exceptions

  • RetryableWorkRejectedException
  • WorkCompletedException
  • WorkException
  • WorkRejectedException


javax.resource.spi.work (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.resource.spi.work

This package contains APIs for the Work Management, Generic and Security Work Context contracts.

See: Description

  • Interface Summary
    Interface Description
    DistributableWork
    This models a Work instance that would be distributed by a DistributableWorkManager for execution in a remote DistributableWorkManager
    DistributableWorkManager
    This interface models a WorkManager that supports distributed execution of Work instances.
    Work
    This models a Work instance that would be executed by a WorkManager upon submission.
    WorkContext
    This class serves as a standard mechanism for a resource adapter to propagate an imported context from an enterprise information system to an application server.
    WorkContextLifecycleListener
    This class models the various events that occur during the processing of the WorkContexts associated with a Work instance.
    WorkContextProvider
    This interface specifies the methods a Work instance uses to associate a List of WorkContext instances to be set when the Work instance gets executed by a WorkManager.
    WorkListener
    This models a WorkListener instance which would be notified by the WorkManager when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
    WorkManager
    This interface models a WorkManager which provides a facility to submit Work instances for execution.
  • Class Summary
    Class Description
    ExecutionContext
    This class models an execution context (transaction, security, etc) with which the Work instance must be executed.
    HintsContext
    A standard WorkContext that allows a Work instance to propagate quality-of-service (QoS) hints about the Work to the WorkManager.
    SecurityContext
    A standard WorkContext that allows a Work instance to propagate security related context information from an EIS to an application server.
    TransactionContext
    A standard WorkContext that allows a Work instance to propagate transaction related context information from an EIS to an application server.
    WorkAdapter
    This class is provided as a convenience for easily creating WorkListener instances by extending this class and overriding only those methods of interest.
    WorkContextErrorCodes
    This class models the possible error conditions that might occur during associating an WorkContext with a Work instance.
    WorkEvent
    This class models the various events that occur during the processing of a Work instance.
  • Exception Summary
    Exception Description
    RetryableWorkRejectedException
    A subclass of the WorkRejectedException that indicates that the the service unavailability is transient.
    WorkCompletedException
    This exception is thrown by a WorkManager to indicate that a submitted Work instance has completed with an exception.
    WorkException
    A common base class for all Work processing related exceptions.
    WorkRejectedException
    This exception is thrown by a WorkManager to indicate that a submitted Work instance has been rejected.

Package javax.resource.spi.work Description

This package contains APIs for the Work Management, Generic and Security Work Context contracts.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.resource.spi.work Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.resource.spi.work

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.resource.spi.work.WorkEvent
    • javax.resource.spi.work.ExecutionContext
      • javax.resource.spi.work.TransactionContext (implements javax.resource.spi.work.WorkContext)
    • javax.resource.spi.work.HintsContext (implements javax.resource.spi.work.WorkContext)
    • javax.resource.spi.work.SecurityContext (implements javax.resource.spi.work.WorkContext)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.work.WorkException
            • javax.resource.spi.work.WorkCompletedException
            • javax.resource.spi.work.WorkRejectedException
              • javax.resource.spi.work.RetryableWorkRejectedException (implements javax.resource.spi.RetryableException)
    • javax.resource.spi.work.WorkAdapter (implements javax.resource.spi.work.WorkListener)
    • javax.resource.spi.work.WorkContextErrorCodes

Interface Hierarchy

  • java.util.EventListener
    • javax.resource.spi.work.WorkListener
  • java.lang.Runnable
    • javax.resource.spi.work.Work
      • javax.resource.spi.work.DistributableWork (also extends java.io.Serializable)
  • java.io.Serializable
    • javax.resource.spi.work.DistributableWork (also extends javax.resource.spi.work.Work)
    • javax.resource.spi.work.WorkContext
    • javax.resource.spi.work.WorkContextProvider
  • javax.resource.spi.work.WorkContextLifecycleListener
  • javax.resource.spi.work.WorkManager
    • javax.resource.spi.work.DistributableWorkManager
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


RetryableWorkRejectedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class RetryableWorkRejectedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.work.WorkException
            • javax.resource.spi.work.WorkRejectedException
              • javax.resource.spi.work.RetryableWorkRejectedException
  • All Implemented Interfaces:
    Serializable, RetryableException

    public class RetryableWorkRejectedException
extends WorkRejectedException
implements RetryableException
    A subclass of the WorkRejectedException that indicates that the the service unavailability is transient. It is thrown in situations where the previously failed operation might be able to succeed if the resource adapter performs some recovery steps and retries the operation.
    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.resource.spi.work.WorkException

        INTERNAL, START_TIMED_OUT, TX_CONCURRENT_WORK_DISALLOWED, TX_RECREATE_FAILED, UNDEFINED

    • Constructor Summary

      Constructors
      Constructor and Description
      RetryableWorkRejectedException()
      Constructs a new instance with null as its detail message.
      RetryableWorkRejectedException(String message)
      Constructs a new instance with the specified detail message.
      RetryableWorkRejectedException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      RetryableWorkRejectedException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      RetryableWorkRejectedException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • RetryableWorkRejectedException

        public RetryableWorkRejectedException()
        Constructs a new instance with null as its detail message.

      • RetryableWorkRejectedException

        public RetryableWorkRejectedException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • RetryableWorkRejectedException

        public RetryableWorkRejectedException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • RetryableWorkRejectedException

        public RetryableWorkRejectedException(String message,
                              Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • RetryableWorkRejectedException

        public RetryableWorkRejectedException(String message,
                              String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SecurityContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class SecurityContext

  • java.lang.Object
    • javax.resource.spi.work.SecurityContext
  • All Implemented Interfaces:
    Serializable, WorkContext

    public abstract class SecurityContext
extends Object
implements WorkContext
    A standard WorkContext that allows a Work instance to propagate security related context information from an EIS to an application server.

    This allows an EIS/resource adapter to flow-in security context information and execute a Work instance, and call methods on a MessageEndpoint interface, to effect message inflow, within that Work instance, in the context of an established identity.

    A resource adapter indicates to the WorkManager, that a Work instance needs to be run in a specified security execution context by submitting a Work instance that implements WorkContextProvider interface and ensuring that the List of WorkContexts for that Work instance contains an instance of its subclass of Securitytext.

    It should be noted however that when a resource adapter flows-in an identity to be used by the application server, the propagated identity may or may not belong to the application server's security domain.

    There are therefore, two scenarios while a resource adapter propagates a security identity from an EIS to the application server:

    • Case 1: Resource adapter flows-in an identity in the application server's security domain: In this case, the application server could just set the initiating principal, flown-in from the resource adapter, as the security context the Work instance executes as.
    • Case 2: Resource adapter flows-in an identity belonging to the EIS' security domain: The resource adapter establishes a connection to the EIS and needs to perform a Work in the context of an EIS identity. In this case, the initiating or caller principal does not exist in the application server's security domain and a translation from one domain to the other needs to be performed.

    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6
    See Also:
    WorkContextProvider, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SecurityContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDescription()
      Get the brief description of the role played by the WorkContext and any other related debugging information.
      String getName()
      Get the associated name of the WorkContext.
      abstract void setupSecurityContext(CallbackHandler handler, Subject executionSubject, Subject serviceSubject)
      The container calls this method to set up the security Context for the Work instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SecurityContext

        public SecurityContext()

    • Method Detail

      • getDescription

        public String getDescription()
        Get the brief description of the role played by the WorkContext and any other related debugging information. This could be used by the WorkManager and the resource adapter for debugging purposes.

        Specified by:
        getDescription in interface WorkContext
        Returns:
        the associated description of the WorkContext

      • getName

        public String getName()
        Get the associated name of the WorkContext. This could be used by the WorkManager and the resource adapter for debugging purposes.

        Specified by:
        getName in interface WorkContext
        Returns:
        the associated name of the WorkContext

      • setupSecurityContext

        public abstract void setupSecurityContext(CallbackHandler handler,
                        Subject executionSubject,
                        Subject serviceSubject)
        The container calls this method to set up the security Context for the Work instance.

        The handler argument must not be null, and the argument handler and the CallbackHandler passed to this method must support the following Callbacks defined in JSR 196: Java Authentication SPI for Containers specification:

        • CallerPrincipalCallback
        • GroupPrincipalCallback
        • PasswordValidationCallback

        The following Callbacks may be supported by the container.

        • CertStoreCallback
        • PrivateKeyCallback
        • SecretKeyCallback
        • TrustStoreCallback

        A resource adapter might use the CallerPrincipalCallback "to set the container's representation of the caller principal. The CallbackHandler must establish the argument Principal as the caller principal associated with the invocation being processed by the container. When the argument Principal is null, the handler will establish the container's representation of the unauthenticated caller principal."

        A resource adapter might use the GroupPrincipalCallback "to establish the container's representation of the corresponding group principals within the Subject. When a null value is passed to the groups argument, the handler will establish the container's representation of no group principals within the Subject. Otherwise, the handler's processing of this callback is additive, yielding the union (without duplicates) of the principals existing within the Subject, and those created with the names occurring within the argument array. The CallbackHandler will define the type of the created principals."

        A resource adapter might use the PasswordValidationCallback "to employ the password validation facilities of its containing runtime."

        The executionSubject argument must be non-null and it must not be read-only. It is expected that this method will populate this executionSubject with principals and credentials that would be flown into the application server.

        The serviceSubject argument may be null, and when it is not null it must not be read-only. It represents the application server and it may be used by the Work implementation to retrieve Principals and credentials necessary to establish a connection to the EIS (in the cause of mutual-auth like scenarios). If the Subject is not null, the Work implementation may collect the server credentials, as necessary, by using the callback handler passed to them .

        When this method is called, the method implementation

        • identifies the security context that needs to be flown-in to the application server to serve as the execution context of the Work instance.
        • populates the executionSubject with the EIS Principals and Credentials that it wants to serve as the security context for the Work instance to be executed in.
        • adds instances of the necessary Callbacks , usually a subset of the ones listed above, to an array and invokes the handle() method in the container's CallbackHandler implementation passing in the array of Callback instances.
        • on successful return from the CallbackHandler.handle() method the setSecurityContext returns after ensuring that the executionSubject is populated with the valid Principals and Credentials that represent the execution context of the Work instance

        Parameters:
        handler - A CallbackHandler provided by the WorkManager that supports the Callbacks described above
        executionSubject - A Subject that represents the security identity that needs to be established as the context for the Work instance. It is used by the method implementation to store Principals and credentials that needs to be used as the security context of the Work instance.
        serviceSubject - A Subject that represents the application server It may be used by the method implementation as the source of Principals or credentials to be used to validate a connection to the EIS. If the Subject is not null, the method implementation may add additional Principals or credentials (pertaining to the recipient of the service request) to the Subject. *
        See Also:
        196: Java Authentication SPI for Containers specification and related JavaDoc
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class TransactionContext

  • java.lang.Object
    • javax.resource.spi.work.ExecutionContext
      • javax.resource.spi.work.TransactionContext
  • All Implemented Interfaces:
    Serializable, WorkContext

    public class TransactionContext
extends ExecutionContext
implements WorkContext
    A standard WorkContext that allows a Work instance to propagate transaction related context information from an EIS to an application server.

    This class extends ExecutionContext so that a resource adapter developer could migrate their existing code from ExecutionContext to TransactionContext easily.

    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6
    See Also:
    WorkContext, ExecutionContext, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDescription()
      Get the brief description of the role played by the WorkContext and any other related debugging information.
      String getName()
      Get the associated name of the WorkContext.

      • Methods inherited from class javax.resource.spi.work.ExecutionContext

        getTransactionTimeout, getXid, setTransactionTimeout, setXid

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TransactionContext

        public TransactionContext()

    • Method Detail

      • getDescription

        public String getDescription()
        Get the brief description of the role played by the WorkContext and any other related debugging information. This could be used by the WorkManager and the resource adapter for debugging purposes.

        Specified by:
        getDescription in interface WorkContext
        Returns:
        the associated description of the WorkContext

      • getName

        public String getName()
        Get the associated name of the WorkContext. This could be used by the WorkManager and the resource adapter for debugging purposes.

        Specified by:
        getName in interface WorkContext
        Returns:
        the associated name of the WorkContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.resource.spi.work (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.resource.spi.work

  • Packages that use javax.resource.spi.work
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.
  • Classes in javax.resource.spi.work used by javax.resource.spi
    Class and Description
    WorkContext
    This class serves as a standard mechanism for a resource adapter to propagate an imported context from an enterprise information system to an application server.
    WorkManager
    This interface models a WorkManager which provides a facility to submit Work instances for execution.
  • Classes in javax.resource.spi.work used by javax.resource.spi.work
    Class and Description
    ExecutionContext
    This class models an execution context (transaction, security, etc) with which the Work instance must be executed.
    Work
    This models a Work instance that would be executed by a WorkManager upon submission.
    WorkContext
    This class serves as a standard mechanism for a resource adapter to propagate an imported context from an enterprise information system to an application server.
    WorkEvent
    This class models the various events that occur during the processing of a Work instance.
    WorkException
    A common base class for all Work processing related exceptions.
    WorkListener
    This models a WorkListener instance which would be notified by the WorkManager when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
    WorkManager
    This interface models a WorkManager which provides a facility to submit Work instances for execution.
    WorkRejectedException
    This exception is thrown by a WorkManager to indicate that a submitted Work instance has been rejected.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Work (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Interface Work

  • All Superinterfaces:
    Runnable
    All Known Subinterfaces:
    DistributableWork

    public interface Work
extends Runnable
    This models a Work instance that would be executed by a WorkManager upon submission.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void release()
      The WorkManager might call this method to hint the active Work instance to complete execution as soon as possible.

      • Methods inherited from interface java.lang.Runnable

        run

    • Method Detail

      • release

        void release()
        The WorkManager might call this method to hint the active Work instance to complete execution as soon as possible. This would be called on a separate thread other than the one currently executing the Work instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class WorkAdapter

  • java.lang.Object
    • javax.resource.spi.work.WorkAdapter
  • All Implemented Interfaces:
    EventListener, WorkListener

    public class WorkAdapter
extends Object
implements WorkListener
    This class is provided as a convenience for easily creating WorkListener instances by extending this class and overriding only those methods of interest.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Constructor Summary

      Constructors
      Constructor and Description
      WorkAdapter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void workAccepted(WorkEvent e)
      Invoked when a Work instance has been accepted.
      void workCompleted(WorkEvent e)
      Invoked when a Work instance has completed execution.
      void workRejected(WorkEvent e)
      Invoked when a Work instance has been rejected.
      void workStarted(WorkEvent e)
      Invoked when a Work instance has started execution.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • WorkAdapter

        public WorkAdapter()

    • Method Detail

      • workAccepted

        public void workAccepted(WorkEvent e)
        Invoked when a Work instance has been accepted.
        Specified by:
        workAccepted in interface WorkListener
        Parameters:
        e - A WorkEvent object that provides more information about the accepted Work.

      • workRejected

        public void workRejected(WorkEvent e)
        Invoked when a Work instance has been rejected.
        Specified by:
        workRejected in interface WorkListener
        Parameters:
        e - A WorkEvent object that provides more information about the rejected Work.

      • workStarted

        public void workStarted(WorkEvent e)
        Invoked when a Work instance has started execution. This only means that a thread has been allocated.
        Specified by:
        workStarted in interface WorkListener
        Parameters:
        e - A WorkEvent object that provides more information about the rejected Work.

      • workCompleted

        public void workCompleted(WorkEvent e)
        Invoked when a Work instance has completed execution.
        Specified by:
        workCompleted in interface WorkListener
        Parameters:
        e - A WorkEvent object that provides more information about the completed Work.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkCompletedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class WorkCompletedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.work.WorkException
            • javax.resource.spi.work.WorkCompletedException
  • All Implemented Interfaces:
    Serializable

    public class WorkCompletedException
extends WorkException
    This exception is thrown by a WorkManager to indicate that a submitted Work instance has completed with an exception.

    This could be thrown only after the execution of a Work instance has started (that is, after a thread has been allocated for Work execution). The allocated thread sets up an execution context (if it has been specified), and then calls Work.run().

    Any exception thrown during execution context setup or during Work execution (that is, during Work.run()) is chained within this exception.

    An associated error code indicates the nature of the error condition. Possible error codes are WorkException.TX_RECREATE_FAILED, WorkException.TX_CONCURRENT_WORK_DISALLOWED or WorkException.UNDEFINED.

    Version:
    1.0
    Author:
    Ram Jeyaraman
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.resource.spi.work.WorkException

        INTERNAL, START_TIMED_OUT, TX_CONCURRENT_WORK_DISALLOWED, TX_RECREATE_FAILED, UNDEFINED

    • Constructor Summary

      Constructors
      Constructor and Description
      WorkCompletedException()
      Constructs a new instance with null as its detail message.
      WorkCompletedException(String message)
      Constructs a new instance with the specified detail message.
      WorkCompletedException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      WorkCompletedException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      WorkCompletedException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WorkCompletedException

        public WorkCompletedException()
        Constructs a new instance with null as its detail message.

      • WorkCompletedException

        public WorkCompletedException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • WorkCompletedException

        public WorkCompletedException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • WorkCompletedException

        public WorkCompletedException(String message,
                      Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • WorkCompletedException

        public WorkCompletedException(String message,
                      String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Interface WorkContext

  • All Superinterfaces:
    Serializable
    All Known Implementing Classes:
    HintsContext, SecurityContext, TransactionContext

    public interface WorkContext
extends Serializable
    This class serves as a standard mechanism for a resource adapter to propagate an imported context from an enterprise information system to an application server.

    A Work instance, that implements the WorkContextProvider, could provide a List of these WorkContext instances (through the getWorkContexts() method), and have them setup as the execution context by the WorkManager when the Work instance gets executed. The resource adapter must not make any changes to the state of the WorkContext after the Work instance corresponding to that WorkContext has been submitted to the WorkManager.

    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getDescription()
      Get the brief description of the role played by the WorkContext and any other related debugging information.
      String getName()
      Get the associated name of the WorkContext.

    • Method Detail

      • getName

        String getName()
        Get the associated name of the WorkContext. This could be used by the WorkManager and the resource adapter for debugging purposes.

        Returns:
        the associated name of the WorkContext

      • getDescription

        String getDescription()
        Get the brief description of the role played by the WorkContext and any other related debugging information. This could be used by the WorkManager and the resource adapter for debugging purposes.

        Returns:
        the associated description of the WorkContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkContextErrorCodes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class WorkContextErrorCodes

  • java.lang.Object
    • javax.resource.spi.work.WorkContextErrorCodes

  • public class WorkContextErrorCodes
extends Object
    This class models the possible error conditions that might occur during associating an WorkContext with a Work instance.

    This class is not designed as an Enumerated type (Enum), as the error codes listed below could be expanded to accommodate custom error conditions for custom WorkContext types.

    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CONTEXT_SETUP_FAILED
      Indicates a failure in recreating the WorkContext instance.
      static String CONTEXT_SETUP_UNSUPPORTED
      Indicates that the container cannot support recreating the WorkContext instance.
      static String DUPLICATE_CONTEXTS
      Indicates that there are more than one instance of a WorkContext type passed in by the Work instance.
      static String UNSUPPORTED_CONTEXT_TYPE
      Indicates that a WorkContext type, that was not specified as optional, passed in by the Work instance is not supported by the container.

    • Constructor Summary

      Constructors
      Constructor and Description
      WorkContextErrorCodes()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • UNSUPPORTED_CONTEXT_TYPE

        public static final String UNSUPPORTED_CONTEXT_TYPE
        Indicates that a WorkContext type, that was not specified as optional, passed in by the Work instance is not supported by the container.
        Since:
        1.6
        See Also:
        Constant Field Values

      • DUPLICATE_CONTEXTS

        public static final String DUPLICATE_CONTEXTS
        Indicates that there are more than one instance of a WorkContext type passed in by the Work instance.

        Since:
        1.6
        See Also:
        Constant Field Values

      • CONTEXT_SETUP_FAILED

        public static final String CONTEXT_SETUP_FAILED
        Indicates a failure in recreating the WorkContext instance. For TransactionContext instances, the WorkManager must use this failure code when it should have used WorkException.TX_RECREATE_FAILED as the error code.
        Since:
        1.6
        See Also:
        Constant Field Values

      • CONTEXT_SETUP_UNSUPPORTED

        public static final String CONTEXT_SETUP_UNSUPPORTED
        Indicates that the container cannot support recreating the WorkContext instance. For TransactionContext instances, the WorkManager must use this failure code when it should have used WorkException.TX_CONCURRENT_WORK_DISALLOWED as the error code.
        Since:
        1.6
        See Also:
        Constant Field Values

    • Constructor Detail

      • WorkContextErrorCodes

        public WorkContextErrorCodes()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkContextLifecycleListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Interface WorkContextLifecycleListener

  • public interface WorkContextLifecycleListener
    This class models the various events that occur during the processing of the WorkContexts associated with a Work instance. This interface may be implemented by a WorkContext instance to receive notifications from the WorkManager when the WorkContext is set as the execution context of the Work instance it is associated with.

    When a WorkManager sets up the execution context of a Work instance that implements WorkContextProvider, the WorkManager must make the relevant lifecycle notifications if an WorkContext instance implements this interface.

    When a Work instance is submitted to the Connector WorkManager using one of the methods that passes in a WorkListener as a parameter, the WorkManager must send Work related notifications to the WorkListener and WorkContext setup related notifications to this interface.

    The possible error conditions that might occur during associating an WorkContext with a Work instance is captured in WorkContextErrorCodes.

    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void contextSetupComplete()
      Invoked when the WorkContext instance was successfully set as the execution context for the Work instance.
      void contextSetupFailed(String errorCode)
      Invoked when the WorkContext instance was set as the execution context for the Work instance it was associated with.

    • Method Detail

      • contextSetupComplete

        void contextSetupComplete()
        Invoked when the WorkContext instance was successfully set as the execution context for the Work instance.
        Since:
        1.6

      • contextSetupFailed

        void contextSetupFailed(String errorCode)
        Invoked when the WorkContext instance was set as the execution context for the Work instance it was associated with.
        Parameters:
        errorCode - One of the error-codes defined in or subclasses of WorkContextErrorCodes
        Since:
        1.6
        See Also:
        WorkContextErrorCodes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkContextProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Interface WorkContextProvider

  • All Superinterfaces:
    Serializable

    public interface WorkContextProvider
extends Serializable
    This interface specifies the methods a Work instance uses to associate a List of WorkContext instances to be set when the Work instance gets executed by a WorkManager.

    A Work instance could optionally implement this interface to indicate to the WorkManager, that the WorkContexts provided by this Work instance through the getWorkContexts method must be used while setting the execution context of the Work instance. If the getWorkContexts method returns an empty List or null, the WorkManager must treat it as if no additional execution contexts are associated with that Work instance.

    Since:
    1.6
    Version:
    Java EE Connector Architecture 1.6

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<WorkContext> getWorkContexts()
      Gets an list of WorkContexts that needs to be used by the WorkManager to set up the execution context while executing a Work instance.

    • Method Detail

      • getWorkContexts

        List<WorkContext> getWorkContexts()
        Gets an list of WorkContexts that needs to be used by the WorkManager to set up the execution context while executing a Work instance.
        Returns:
        an List of WorkContext instances.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class WorkEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.resource.spi.work.WorkEvent
  • All Implemented Interfaces:
    Serializable

    public class WorkEvent
extends EventObject
    This class models the various events that occur during the processing of a Work instance.
    Version:
    1.0
    Author:
    Ram Jeyaraman
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int WORK_ACCEPTED
      Indicates Work instance has been accepted.
      static int WORK_COMPLETED
      Indicates Work instance has completed execution.
      static int WORK_REJECTED
      Indicates Work instance has been rejected.
      static int WORK_STARTED
      Indicates Work instance has started execution.

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      WorkEvent(Object source, int type, Work work, WorkException exc)
      Constructor.
      WorkEvent(Object source, int type, Work work, WorkException exc, long startDuration)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      WorkException getException()
      Return the WorkException.
      long getStartDuration()
      Return the start interval duration.
      int getType()
      Return the type of this event.
      Work getWork()
      Return the Work instance which is the cause of the event.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • WORK_ACCEPTED

        public static final int WORK_ACCEPTED
        Indicates Work instance has been accepted.
        See Also:
        Constant Field Values

      • WORK_REJECTED

        public static final int WORK_REJECTED
        Indicates Work instance has been rejected.
        See Also:
        Constant Field Values

      • WORK_STARTED

        public static final int WORK_STARTED
        Indicates Work instance has started execution.
        See Also:
        Constant Field Values

      • WORK_COMPLETED

        public static final int WORK_COMPLETED
        Indicates Work instance has completed execution.
        See Also:
        Constant Field Values

    • Constructor Detail

      • WorkEvent

        public WorkEvent(Object source,
         int type,
         Work work,
         WorkException exc)
        Constructor.
        Parameters:
        source - The object on which the event initially occurred.
        type - The event type.
        work - The Work object on which the event occured.
        exc - The exception that occured during Work processing.

      • WorkEvent

        public WorkEvent(Object source,
         int type,
         Work work,
         WorkException exc,
         long startDuration)
        Constructor.
        Parameters:
        source - The object on which the event initially occurred.
        type - The event type.
        work - The Work object on which the event occured.
        exc - The exception that occured during Work processing.
        startDuration - The start delay duration (in milliseconds).

    • Method Detail

      • getType

        public int getType()
        Return the type of this event.
        Returns:
        the event type.

      • getWork

        public Work getWork()
        Return the Work instance which is the cause of the event.
        Returns:
        the Work instance.

      • getStartDuration

        public long getStartDuration()
        Return the start interval duration.
        Returns:
        the time elapsed (in milliseconds) since the Work was accepted, until the Work execution started. Note, this does not offer real-time guarantees. It is valid to return -1, if the actual start interval duration is unknown.

      • getException

        public WorkException getException()
        Return the WorkException. The actual WorkException subtype returned depends on the type of the event.
        Returns:
        a WorkRejectedException or a WorkCompletedException, if any.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class WorkException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.work.WorkException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    WorkCompletedException, WorkRejectedException

    public class WorkException
extends ResourceException
    A common base class for all Work processing related exceptions.
    Version:
    1.0
    Author:
    Ram Jeyaraman
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String INTERNAL
      Indicates an internal error condition.
      static String START_TIMED_OUT
      Indicates start timeout expiration.
      static String TX_CONCURRENT_WORK_DISALLOWED
      Indicates that concurrent work within a transaction is disallowed.
      static String TX_RECREATE_FAILED
      Indicates a failure in recreating the specified transaction context.
      static String UNDEFINED
      Undefined error code.

    • Constructor Summary

      Constructors
      Constructor and Description
      WorkException()
      Constructs a new instance with null as its detail message.
      WorkException(String message)
      Constructs a new instance with the specified detail message.
      WorkException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      WorkException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      WorkException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • INTERNAL

        public static final String INTERNAL
        Indicates an internal error condition.
        See Also:
        Constant Field Values

      • UNDEFINED

        public static final String UNDEFINED
        Undefined error code.
        See Also:
        Constant Field Values

      • START_TIMED_OUT

        public static final String START_TIMED_OUT
        Indicates start timeout expiration.
        See Also:
        Constant Field Values

      • TX_CONCURRENT_WORK_DISALLOWED

        public static final String TX_CONCURRENT_WORK_DISALLOWED
        Indicates that concurrent work within a transaction is disallowed. That is, there is already another Work instance associated with the specified transaction context.
        See Also:
        Constant Field Values

      • TX_RECREATE_FAILED

        public static final String TX_RECREATE_FAILED
        Indicates a failure in recreating the specified transaction context.
        See Also:
        Constant Field Values

    • Constructor Detail

      • WorkException

        public WorkException()
        Constructs a new instance with null as its detail message.

      • WorkException

        public WorkException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • WorkException

        public WorkException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • WorkException

        public WorkException(String message,
             Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • WorkException

        public WorkException(String message,
             String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Interface WorkListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    WorkAdapter

    public interface WorkListener
extends EventListener
    This models a WorkListener instance which would be notified by the WorkManager when the various Work processing events (work accepted, work rejected, work started, work completed) occur. The WorkListener instance must not make any thread assumptions and must be thread-safe ie., a notification could occur from any arbitrary thread. Further, it must not make any assumptions on the ordering of notifications.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void workAccepted(WorkEvent e)
      Invoked when a Work instance has been accepted.
      void workCompleted(WorkEvent e)
      Invoked when a Work instance has completed execution.
      void workRejected(WorkEvent e)
      Invoked when a Work instance has been rejected.
      void workStarted(WorkEvent e)
      Invoked when a Work instance has started execution.

    • Method Detail

      • workAccepted

        void workAccepted(WorkEvent e)
        Invoked when a Work instance has been accepted.
        Parameters:
        e - A WorkEvent object that provides more information about the accepted Work.

      • workRejected

        void workRejected(WorkEvent e)
        Invoked when a Work instance has been rejected.
        Parameters:
        e - A WorkEvent object that provides more information about the rejected Work.

      • workStarted

        void workStarted(WorkEvent e)
        Invoked when a Work instance has started execution. This only means that a thread has been allocated.
        Parameters:
        e - A WorkEvent object that provides more information about the rejected Work.

      • workCompleted

        void workCompleted(WorkEvent e)
        Invoked when a Work instance has completed execution.
        Parameters:
        e - A WorkEvent object that provides more information about the completed Work.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Interface WorkManager

  • All Known Subinterfaces:
    DistributableWorkManager

    public interface WorkManager
    This interface models a WorkManager which provides a facility to submit Work instances for execution. This frees the user from having to create Java threads directly to do work. Further, this allows efficient pooling of thread resources and more control over thread usage. The various stages in Work processing are:
    • work submit: A Work instance is being submitted for execution. The Work instance could either be accepted or rejected with a WorkRejectedException set to an appropriate error code.
    • work accepted: The submitted Work instance has been accepted. The accepted Work instance could either start execution or could be rejected again with a WorkRejectedException set to an appropriate error code. There is no guarantee on when the execution would start unless a start timeout duration is specified. When a start timeout is specified, the Work execution must be started within the specified duration (not a real-time guarantee), failing which a WorkRejectedException set to an error code (WorkRejected.TIMED_OUT) is thrown.
    • work rejected: The Work instance has been rejected. The Work instance could be rejected during Work submittal or after the Work instance has been accepted (but before Work instance starts execution). The rejection could be due to internal factors or start timeout expiration. A WorkRejectedException with an appropriate error code (indicates the reason) is thrown in both cases.
    • work started: The execution of the Work instance has started. This means that a thread has been allocated for its execution. But this does not guarantee that the allocated thread has been scheduled to run on a CPU resource. Once execution is started, the allocated thread sets up an appropriate execution context (transaction , security, etc) and calls Work.run(). Note, any exception thrown during execution context setup or Work.run() leads to completion of processing.
    • work completed: The execution of the Work has been completed. The execution could complete with or without an exception. The WorkManager catches any exception thrown during Work processing (which includes execution context setup), and wraps it with a WorkCompletedException.
    Version:
    1.0
    Author:
    Ram Jeyaraman

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static long IMMEDIATE
      A constant to indicate timeout duration.
      static long INDEFINITE
      A constant to indicate timeout duration.
      static long UNKNOWN
      A constant to indicate an unknown start delay duration or other unknown values.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void doWork(Work work)
      Accepts a Work instance for processing.
      void doWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      void scheduleWork(Work work)
      Accepts a Work instance for processing.
      void scheduleWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      long startWork(Work work)
      Accepts a Work instance for processing.
      long startWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.

    • Field Detail

      • IMMEDIATE

        static final long IMMEDIATE
        A constant to indicate timeout duration. A zero timeout value indicates an action be performed immediately. The WorkManager implementation must timeout the action as soon as possible.
        See Also:
        Constant Field Values

      • INDEFINITE

        static final long INDEFINITE
        A constant to indicate timeout duration. A maximum timeout value indicates that an action be performed arbitrarily without any time constraint.
        See Also:
        Constant Field Values

      • UNKNOWN

        static final long UNKNOWN
        A constant to indicate an unknown start delay duration or other unknown values.
        See Also:
        Constant Field Values

    • Method Detail

      • doWork

        void doWork(Work work)
            throws WorkException
        Accepts a Work instance for processing. This call blocks until the Work instance completes execution. There is no guarantee on when the accepted Work instance would start execution ie., there is no time constraint to start execution. (that is, startTimeout=INDEFINITE)
        Parameters:
        work - The unit of work to be done. Could be long or short-lived.
        Throws:
        WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
        WorkCompletedException - indicates that a Work instance has completed execution with an exception.
        WorkException

      • doWork

        void doWork(Work work,
          long startTimeout,
          ExecutionContext execContext,
          WorkListener workListener)
            throws WorkException
        Accepts a Work instance for processing. This call blocks until the Work instance completes execution.
        Parameters:
        work - The unit of work to be done. Could be long or short-lived.
        startTimeout - a time duration (in milliseconds) within which the execution of the Work instance must start. Otherwise, the Work instance is rejected with a WorkRejectedException set to an appropriate error code (WorkRejectedException.TIMED_OUT). Note, this does not offer real-time guarantees.
        execContext - an object containing the execution context with which the submitted Work instance must be executed.
        workListener - an object which would be notified when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
        Throws:
        WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors or start timeout expiration.
        WorkCompletedException - indicates that a Work instance has completed execution with an exception.
        WorkException

      • startWork

        long startWork(Work work)
               throws WorkException
        Accepts a Work instance for processing. This call blocks until the Work instance starts execution but not until its completion. There is no guarantee on when the accepted Work instance would start execution ie., there is no time constraint to start execution. (that is, startTimeout=INDEFINITE)
        Parameters:
        work - The unit of work to be done. Could be long or short-lived.
        Returns:
        the time elapsed (in milliseconds) from Work acceptance until start of execution. Note, this does not offer real-time guarantees. It is valid to return -1, if the actual start delay duration is unknown.
        Throws:
        WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
        WorkException

      • startWork

        long startWork(Work work,
             long startTimeout,
             ExecutionContext execContext,
             WorkListener workListener)
               throws WorkException
        Accepts a Work instance for processing. This call blocks until the Work instance starts execution but not until its completion. There is no guarantee on when the accepted Work instance would start execution ie., there is no time constraint to start execution.
        Parameters:
        work - The unit of work to be done. Could be long or short-lived.
        startTimeout - a time duration (in milliseconds) within which the execution of the Work instance must start. Otherwise, the Work instance is rejected with a WorkRejectedException set to an appropriate error code (WorkRejectedException.TIMED_OUT). Note, this does not offer real-time guarantees.
        execContext - an object containing the execution context with which the submitted Work instance must be executed.
        workListener - an object which would be notified when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
        Returns:
        the time elapsed (in milliseconds) from Work acceptance until start of execution. Note, this does not offer real-time guarantees. It is valid to return -1, if the actual start delay duration is unknown.
        Throws:
        WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors or start timeout expiration.
        WorkException

      • scheduleWork

        void scheduleWork(Work work)
                  throws WorkException
        Accepts a Work instance for processing. This call does not block and returns immediately once a Work instance has been accepted for processing. There is no guarantee on when the submitted Work instance would start execution ie., there is no time constraint to start execution. (that is, startTimeout=INDEFINITE).
        Parameters:
        work - The unit of work to be done. Could be long or short-lived.
        Throws:
        WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
        WorkException

      • scheduleWork

        void scheduleWork(Work work,
                long startTimeout,
                ExecutionContext execContext,
                WorkListener workListener)
                  throws WorkException
        Accepts a Work instance for processing. This call does not block and returns immediately once a Work instance has been accepted for processing.
        Parameters:
        work - The unit of work to be done. Could be long or short-lived.
        startTimeout - a time duration (in milliseconds) within which the execution of the Work instance must start. Otherwise, the Work instance is rejected with a WorkRejectedException set to an appropriate error code (WorkRejectedException.TIMED_OUT). Note, this does not offer real-time guarantees.
        execContext - an object containing the execution context with which the submitted Work instance must be executed.
        workListener - an object which would be notified when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
        Throws:
        WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
        WorkException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WorkRejectedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.resource.spi.work

Class WorkRejectedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.work.WorkException
            • javax.resource.spi.work.WorkRejectedException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    RetryableWorkRejectedException

    public class WorkRejectedException
extends WorkException
    This exception is thrown by a WorkManager to indicate that a submitted Work instance has been rejected. The rejection could be due to internal factors or start timeout expiration.

    This could be thrown only before the execution of a Work instance starts (that is, before a thread has been allocated for Work execution).

    An associated error code indicates the nature of the error condition. Possible error codes are WorkException.START_TIMED_OUT, WorkException.INTERNAL or WorkException.UNDEFINED.

    Version:
    1.0
    Author:
    Ram Jeyaraman
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.resource.spi.work.WorkException

        INTERNAL, START_TIMED_OUT, TX_CONCURRENT_WORK_DISALLOWED, TX_RECREATE_FAILED, UNDEFINED

    • Constructor Summary

      Constructors
      Constructor and Description
      WorkRejectedException()
      Constructs a new instance with null as its detail message.
      WorkRejectedException(String message)
      Constructs a new instance with the specified detail message.
      WorkRejectedException(String message, String errorCode)
      Constructs a new throwable with the specified detail message and an error code.
      WorkRejectedException(String message, Throwable cause)
      Constructs a new throwable with the specified detail message and cause.
      WorkRejectedException(Throwable cause)
      Constructs a new throwable with the specified cause.

    • Method Summary

      • Methods inherited from class javax.resource.ResourceException

        getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WorkRejectedException

        public WorkRejectedException()
        Constructs a new instance with null as its detail message.

      • WorkRejectedException

        public WorkRejectedException(String message)
        Constructs a new instance with the specified detail message.
        Parameters:
        message - the detail message.

      • WorkRejectedException

        public WorkRejectedException(Throwable cause)
        Constructs a new throwable with the specified cause.
        Parameters:
        cause - a chained exception of type Throwable.

      • WorkRejectedException

        public WorkRejectedException(String message,
                     Throwable cause)
        Constructs a new throwable with the specified detail message and cause.
        Parameters:
        message - the detail message.
        cause - a chained exception of type Throwable.

      • WorkRejectedException

        public WorkRejectedException(String message,
                     String errorCode)
        Constructs a new throwable with the specified detail message and an error code.
        Parameters:
        message - a description of the exception.
        errorCode - a string specifying the vendor specific error code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.resource.spi.work.ExecutionContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.ExecutionContext

  • Packages that use ExecutionContext
    Package Description
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of ExecutionContext in javax.resource.spi.work

      Subclasses of ExecutionContext in javax.resource.spi.work
      Modifier and Type Class and Description
      class  TransactionContext
      A standard WorkContext that allows a Work instance to propagate transaction related context information from an EIS to an application server.
      Methods in javax.resource.spi.work with parameters of type ExecutionContext
      Modifier and Type Method and Description
      void WorkManager.doWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      void WorkManager.scheduleWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      long WorkManager.startWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.work.HintsContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.HintsContext

No usage of javax.resource.spi.work.HintsContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.work.RetryableWorkRejectedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.RetryableWorkRejectedException

No usage of javax.resource.spi.work.RetryableWorkRejectedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.work.SecurityContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.SecurityContext

No usage of javax.resource.spi.work.SecurityContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.work.TransactionContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.TransactionContext

No usage of javax.resource.spi.work.TransactionContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.work.WorkAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.WorkAdapter

No usage of javax.resource.spi.work.WorkAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.work.WorkCompletedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.WorkCompletedException

No usage of javax.resource.spi.work.WorkCompletedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.work.WorkContextErrorCodes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.WorkContextErrorCodes

No usage of javax.resource.spi.work.WorkContextErrorCodes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.work.WorkEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.WorkEvent

  • Packages that use WorkEvent
    Package Description
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of WorkEvent in javax.resource.spi.work

      Methods in javax.resource.spi.work with parameters of type WorkEvent
      Modifier and Type Method and Description
      void WorkListener.workAccepted(WorkEvent e)
      Invoked when a Work instance has been accepted.
      void WorkAdapter.workAccepted(WorkEvent e)
      Invoked when a Work instance has been accepted.
      void WorkListener.workCompleted(WorkEvent e)
      Invoked when a Work instance has completed execution.
      void WorkAdapter.workCompleted(WorkEvent e)
      Invoked when a Work instance has completed execution.
      void WorkListener.workRejected(WorkEvent e)
      Invoked when a Work instance has been rejected.
      void WorkAdapter.workRejected(WorkEvent e)
      Invoked when a Work instance has been rejected.
      void WorkListener.workStarted(WorkEvent e)
      Invoked when a Work instance has started execution.
      void WorkAdapter.workStarted(WorkEvent e)
      Invoked when a Work instance has started execution.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.work.WorkException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.WorkException

  • Packages that use WorkException
    Package Description
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of WorkException in javax.resource.spi.work

      Subclasses of WorkException in javax.resource.spi.work
      Modifier and Type Class and Description
      class  RetryableWorkRejectedException
      A subclass of the WorkRejectedException that indicates that the the service unavailability is transient.
      class  WorkCompletedException
      This exception is thrown by a WorkManager to indicate that a submitted Work instance has completed with an exception.
      class  WorkRejectedException
      This exception is thrown by a WorkManager to indicate that a submitted Work instance has been rejected.
      Methods in javax.resource.spi.work that return WorkException
      Modifier and Type Method and Description
      WorkException WorkEvent.getException()
      Return the WorkException.
      Methods in javax.resource.spi.work that throw WorkException
      Modifier and Type Method and Description
      void WorkManager.doWork(Work work)
      Accepts a Work instance for processing.
      void WorkManager.doWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      void WorkManager.scheduleWork(Work work)
      Accepts a Work instance for processing.
      void WorkManager.scheduleWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      long WorkManager.startWork(Work work)
      Accepts a Work instance for processing.
      long WorkManager.startWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      Constructors in javax.resource.spi.work with parameters of type WorkException
      Constructor and Description
      WorkEvent(Object source, int type, Work work, WorkException exc)
      Constructor.
      WorkEvent(Object source, int type, Work work, WorkException exc, long startDuration)
      Constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.resource.spi.work.WorkRejectedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.resource.spi.work.WorkRejectedException

  • Packages that use WorkRejectedException
    Package Description
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of WorkRejectedException in javax.resource.spi.work

      Subclasses of WorkRejectedException in javax.resource.spi.work
      Modifier and Type Class and Description
      class  RetryableWorkRejectedException
      A subclass of the WorkRejectedException that indicates that the the service unavailability is transient.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.work.DistributableWork (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.work.DistributableWork

No usage of javax.resource.spi.work.DistributableWork
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.work.DistributableWorkManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.work.DistributableWorkManager

No usage of javax.resource.spi.work.DistributableWorkManager
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.work.Work (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.work.Work

  • Packages that use Work
    Package Description
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of Work in javax.resource.spi.work

      Subinterfaces of Work in javax.resource.spi.work
      Modifier and Type Interface and Description
      interface  DistributableWork
      This models a Work instance that would be distributed by a DistributableWorkManager for execution in a remote DistributableWorkManager
      Methods in javax.resource.spi.work that return Work
      Modifier and Type Method and Description
      Work WorkEvent.getWork()
      Return the Work instance which is the cause of the event.
      Methods in javax.resource.spi.work with parameters of type Work
      Modifier and Type Method and Description
      void WorkManager.doWork(Work work)
      Accepts a Work instance for processing.
      void WorkManager.doWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      void WorkManager.scheduleWork(Work work)
      Accepts a Work instance for processing.
      void WorkManager.scheduleWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      long WorkManager.startWork(Work work)
      Accepts a Work instance for processing.
      long WorkManager.startWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      Constructors in javax.resource.spi.work with parameters of type Work
      Constructor and Description
      WorkEvent(Object source, int type, Work work, WorkException exc)
      Constructor.
      WorkEvent(Object source, int type, Work work, WorkException exc, long startDuration)
      Constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.work.WorkContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.work.WorkContext

  • Packages that use WorkContext
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of WorkContext in javax.resource.spi

      Method parameters in javax.resource.spi with type arguments of type WorkContext
      Modifier and Type Method and Description
      boolean BootstrapContext.isContextSupported(Class<? extends WorkContext> workContextClass)
      A resource adapter can check an application server's support for a particular WorkContext type through this method.

    • Uses of WorkContext in javax.resource.spi.work

      Classes in javax.resource.spi.work that implement WorkContext
      Modifier and Type Class and Description
      class  HintsContext
      A standard WorkContext that allows a Work instance to propagate quality-of-service (QoS) hints about the Work to the WorkManager.
      class  SecurityContext
      A standard WorkContext that allows a Work instance to propagate security related context information from an EIS to an application server.
      class  TransactionContext
      A standard WorkContext that allows a Work instance to propagate transaction related context information from an EIS to an application server.
      Methods in javax.resource.spi.work that return types with arguments of type WorkContext
      Modifier and Type Method and Description
      List<WorkContext> WorkContextProvider.getWorkContexts()
      Gets an list of WorkContexts that needs to be used by the WorkManager to set up the execution context while executing a Work instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.work.WorkContextLifecycleListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.work.WorkContextLifecycleListener

No usage of javax.resource.spi.work.WorkContextLifecycleListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.work.WorkContextProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.work.WorkContextProvider

No usage of javax.resource.spi.work.WorkContextProvider
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.work.WorkListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.work.WorkListener

  • Packages that use WorkListener
    Package Description
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of WorkListener in javax.resource.spi.work

      Classes in javax.resource.spi.work that implement WorkListener
      Modifier and Type Class and Description
      class  WorkAdapter
      This class is provided as a convenience for easily creating WorkListener instances by extending this class and overriding only those methods of interest.
      Methods in javax.resource.spi.work with parameters of type WorkListener
      Modifier and Type Method and Description
      void WorkManager.doWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      void WorkManager.scheduleWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
      long WorkManager.startWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener)
      Accepts a Work instance for processing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.resource.spi.work.WorkManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.resource.spi.work.WorkManager

  • Packages that use WorkManager
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.

    • Uses of WorkManager in javax.resource.spi

      Methods in javax.resource.spi that return WorkManager
      Modifier and Type Method and Description
      WorkManager BootstrapContext.getWorkManager()
      Provides a handle to a WorkManager instance.

    • Uses of WorkManager in javax.resource.spi.work

      Subinterfaces of WorkManager in javax.resource.spi.work
      Modifier and Type Interface and Description
      interface  DistributableWorkManager
      This interface models a WorkManager that supports distributed execution of Work instances.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AuthException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message

Class AuthException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.message.AuthException
  • All Implemented Interfaces:
    Serializable

    public class AuthException
extends LoginException
    A generic authentication exception.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      AuthException()
      Constructs an AuthException with no detail message.
      AuthException(String msg)
      Constructs an AuthException with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AuthException

        public AuthException()
        Constructs an AuthException with no detail message. A detail message is a String that describes this particular exception.

      • AuthException

        public AuthException(String msg)
        Constructs an AuthException with the specified detail message. A detail message is a String that describes this particular exception.

        Parameters:
        msg - The detail message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AuthStatus (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message

Class AuthStatus

  • java.lang.Object
    • javax.security.auth.message.AuthStatus

  • public class AuthStatus
extends Object
    The AuthStatus class is used to represent return values from Authentication modules and Authentication Contexts. An AuthStatus value is returned when the module processing has established a corresponding request or response message within the message parameters exchanged with the runtime.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static AuthStatus FAILURE
      Indicates that the message processing by the authentication module was NOT successful, and that the module replaced the application message with an error message.
      static AuthStatus SEND_CONTINUE
      Indicates the message processing by the authentication module is NOT complete, that the module replaced the application message with a security message, and that the runtime is to proceed by sending the security message.
      static AuthStatus SEND_FAILURE
      Indicates that the message processing by the authentication module was NOT successful, that the module replaced the application message with an error message, and that the runtime is to proceed by sending the error message.
      static AuthStatus SEND_SUCCESS
      Indicates that the message processing by the authentication module was successful and that the runtime is to proceed by sending a message returned by the authentication module.
      static AuthStatus SUCCESS
      Indicates that the message processing by the authentication module was successful and that the runtime is to proceed with its normal processing of the resulting message.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • SUCCESS

        public static final AuthStatus SUCCESS
        Indicates that the message processing by the authentication module was successful and that the runtime is to proceed with its normal processing of the resulting message.

      • FAILURE

        public static final AuthStatus FAILURE
        Indicates that the message processing by the authentication module was NOT successful, and that the module replaced the application message with an error message.

      • SEND_SUCCESS

        public static final AuthStatus SEND_SUCCESS
        Indicates that the message processing by the authentication module was successful and that the runtime is to proceed by sending a message returned by the authentication module.

      • SEND_FAILURE

        public static final AuthStatus SEND_FAILURE
        Indicates that the message processing by the authentication module was NOT successful, that the module replaced the application message with an error message, and that the runtime is to proceed by sending the error message.

      • SEND_CONTINUE

        public static final AuthStatus SEND_CONTINUE
        Indicates the message processing by the authentication module is NOT complete, that the module replaced the application message with a security message, and that the runtime is to proceed by sending the security message.

    • Method Detail

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientAuth (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message

Interface ClientAuth

  • All Known Subinterfaces:
    ClientAuthContext, ClientAuthModule

    public interface ClientAuth
    An implementation of this interface is used to secure service request messages, and validate received service response messages.
    See Also:
    MessageInfo, Subject

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void cleanSubject(MessageInfo messageInfo, Subject subject)
      Remove implementation specific principals and credentials from the subject.
      AuthStatus secureRequest(MessageInfo messageInfo, Subject clientSubject)
      Secure a service request message before sending it to the service.
      AuthStatus validateResponse(MessageInfo messageInfo, Subject clientSubject, Subject serviceSubject)
      Validate a received service response.

    • Method Detail

      • secureRequest

        AuthStatus secureRequest(MessageInfo messageInfo,
                       Subject clientSubject)
                         throws AuthException
        Secure a service request message before sending it to the service.

        This method is called to transform the request message acquired by calling getRequestMessage (on messageInfo) into the mechanism-specific form to be sent by the runtime.

        This method conveys the outcome of its message processing either by returning an AuthStatus value or by throwing an AuthException.

        Parameters:
        messageInfo - A contextual object that encapsulates the client request and server response objects, and that may be used to save state across a sequence of calls made to the methods of this interface for the purpose of completing a secure message exchange.
        clientSubject - A Subject that represents the source of the service request, or null. It may be used by the method implementation as the source of Principals or credentials to be used to secure the request. If the Subject is not null, the method implementation may add additional Principals or credentials (pertaining to the source of the service request) to the Subject.
        Returns:
        An AuthStatus object representing the completion status of the processing performed by the method. The AuthStatus values that may be returned by this method are defined as follows:
        • AuthStatus.SUCCESS when the application request message was successfully secured. The secured request message may be obtained by calling getRequestMessage on messageInfo.
        • AuthStatus.SEND_CONTINUE to indicate that the application request message (within messageInfo) was replaced with a security message that should elicit a security-specific response from the peer security system. This status value also indicates that the application message has not yet been secured. This status value serves to inform the calling runtime that (to successfully complete the message exchange) it will need to be capable of continuing the message dialog by conducting at least one additional request/response exchange after having received the security-specific response elicited by sending the security message. When this status value is returned, the corresponding invocation of validateResponse must be able to obtain the original application request message.
        • AuthStatus.FAILURE to indicate that a failure occured while securing the request message, and that an appropriate failure response message is available by calling getResponseMessage on messageInfo.
        Throws:
        AuthException - When the message processing failed without establishing a failure response message (in messageInfo).

      • validateResponse

        AuthStatus validateResponse(MessageInfo messageInfo,
                          Subject clientSubject,
                          Subject serviceSubject)
                            throws AuthException
        Validate a received service response.

        This method is called to transform the mechanism-specific response message acquired by calling getResponseMessage (on messageInfo) into the validated application message to be returned to the message processing runtime. If the response message is a (mechanism-specific) meta-message, the method implementation must attempt to transform the meta-message into the next mechanism-specific request message to be sent by the runtime.

        This method conveys the outcome of its message processing either by returning an AuthStatus value or by throwing an AuthException.

        Parameters:
        messageInfo - A contextual object that encapsulates the client request and server response objects, and that may be used to save state across a sequence of calls made to the methods of this interface for the purpose of completing a secure message exchange.
        clientSubject - A Subject that represents the recipient of the service response, or null. It may be used by the method implementation as the source of Principals or credentials to be used to validate the response. If the Subject is not null, the method implementation may add additional Principals or credentials (pertaining to the recipient of the service request) to the Subject.
        serviceSubject - A Subject that represents the source of the service response, or null. If the Subject is not null, the method implementation may add additional Principals or credentials (pertaining to the source of the service response) to the Subject.
        Returns:
        An AuthStatus object representing the completion status of the processing performed by the method. The AuthStatus values that may be returned by this method are defined as follows:
        • AuthStatus.SUCCESS when the application response message was successfully validated. The validated message is available by calling getResponseMessage on messageInfo.
        • AuthStatus.SEND_CONTINUE to indicate that response validation is incomplete, and that a continuation request was returned as the request message within messageInfo. This status value serves to inform the calling runtime that (to successfully complete the message exchange) it will need to be capable of continuing the message dialog by conducting at least one additional request/response exchange.
        • AuthStatus.FAILURE to indicate that validation of the response failed, and that a failure response message has been established in messageInfo.
        Throws:
        AuthException - When the message processing failed without establishing a failure response message (in messageInfo).

      • cleanSubject

        void cleanSubject(MessageInfo messageInfo,
                Subject subject)
                  throws AuthException
        Remove implementation specific principals and credentials from the subject.
        Parameters:
        messageInfo - A contextual object that encapsulates the client request and server response objects, and that may be used to save state across a sequence of calls made to the methods of this interface for the purpose of completing a secure message exchange.
        subject - The Subject instance from which the Principals and credentials are to be removed.
        Throws:
        AuthException - If an error occurs during the Subject processing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.security.auth.message (Java(TM) EE 7 Specification APIs)

javax.security.auth.message

Interfaces

  • ClientAuth
  • MessageInfo
  • MessagePolicy.ProtectionPolicy
  • MessagePolicy.Target
  • ServerAuth

Classes

  • AuthStatus
  • MessagePolicy
  • MessagePolicy.TargetPolicy

Exceptions

  • AuthException


javax.security.auth.message (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.security.auth.message

This package defines the core interfaces of the JSR 196 message authentication SPI.

See: Description

  • Interface Summary
    Interface Description
    ClientAuth
    An implementation of this interface is used to secure service request messages, and validate received service response messages.
    MessageInfo
    A message processing runtime uses this interface to pass messages and message processing state to authentication contexts for processing by authentication modules.
    MessagePolicy.ProtectionPolicy
    This interface is used to represent message authentication policy.
    MessagePolicy.Target
    This interface is used to represent and perform message targeting.
    ServerAuth
    An implementation of this interface is used to validate received service request messages, and to secure service response messages.
  • Class Summary
    Class Description
    AuthStatus
    The AuthStatus class is used to represent return values from Authentication modules and Authentication Contexts.
    MessagePolicy
    This class defines a message authentication policy.
    MessagePolicy.TargetPolicy
    This class defines the message protection policies for specific Targets.
  • Exception Summary
    Exception Description
    AuthException
    A generic authentication exception.

Package javax.security.auth.message Description

This package defines the core interfaces of the JSR 196 message authentication SPI. The SPI defines the interfaces by which pluggable message authentication modules may be configured and invoked by message processing runtimes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.security.auth.message Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.security.auth.message

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.security.auth.message.AuthStatus
    • javax.security.auth.message.MessagePolicy
    • javax.security.auth.message.MessagePolicy.TargetPolicy
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.message.AuthException

Interface Hierarchy

  • javax.security.auth.message.ClientAuth
  • javax.security.auth.message.MessageInfo
  • javax.security.auth.message.MessagePolicy.ProtectionPolicy
  • javax.security.auth.message.MessagePolicy.Target
  • javax.security.auth.message.ServerAuth
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MessageInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message

Interface MessageInfo

  • public interface MessageInfo
    A message processing runtime uses this interface to pass messages and message processing state to authentication contexts for processing by authentication modules.

    This interface encapsulates a request message object and a response message object for a message exchange. This interface may also be used to associate additional context in the form of key/value pairs, with the encapsulated messages.

    Every implementation of this interface should provide a zero argument constructor, and a constructor which takes a single Map argument. Additional constructors may also be provided.

    See Also:
    Map

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Map getMap()
      Get (a reference to) the Map object of this MessageInfo.
      Object getRequestMessage()
      Get the request message object from this MessageInfo.
      Object getResponseMessage()
      Get the response message object from this MessageInfo.
      void setRequestMessage(Object request)
      Set the request message object in this MessageInfo.
      void setResponseMessage(Object response)
      Set the response message object in this MessageInfo.

    • Method Detail

      • getRequestMessage

        Object getRequestMessage()
        Get the request message object from this MessageInfo.
        Returns:
        An object representing the request message, or null if no request message is set within the MessageInfo.

      • getResponseMessage

        Object getResponseMessage()
        Get the response message object from this MessageInfo.
        Returns:
        an object representing the response message, or null if no response message is set within the MessageInfo.

      • setRequestMessage

        void setRequestMessage(Object request)
        Set the request message object in this MessageInfo.
        Parameters:
        request - An object representing the request message.

      • setResponseMessage

        void setResponseMessage(Object response)
        Set the response message object in this MessageInfo.
        Parameters:
        response - An object representing the response message.

      • getMap

        Map getMap()
        Get (a reference to) the Map object of this MessageInfo. Operations performed on the acquired Map must effect the Map within the MessageInfo.
        Returns:
        the Map object of this MessageInfo. This method never returns null. If a Map has not been associated with the MessageInfo, this method instantiates a Map, associates it with this MessageInfo, and then returns it.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessagePolicy (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message

Class MessagePolicy

  • java.lang.Object
    • javax.security.auth.message.MessagePolicy

  • public class MessagePolicy
extends Object
    This class defines a message authentication policy.

    A ClientAuthContext uses this class to communicate (at module initialization time) request and response message protection policies to its ClientAuthModule objects. A ServerAuthContext uses this class to communicate request and response message protection policies to its ServerAuthModule objects.

    See Also:
    ClientAuthContext, ServerAuthContext, ClientAuthModule, ServerAuthModule

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static interface  MessagePolicy.ProtectionPolicy
      This interface is used to represent message authentication policy.
      static interface  MessagePolicy.Target
      This interface is used to represent and perform message targeting.
      static class  MessagePolicy.TargetPolicy
      This class defines the message protection policies for specific Targets.

    • Constructor Summary

      Constructors
      Constructor and Description
      MessagePolicy(MessagePolicy.TargetPolicy[] targetPolicies, boolean mandatory)
      Create a MessagePolicy instance with an array of target policies.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      MessagePolicy.TargetPolicy[] getTargetPolicies()
      Get the target policies that comprise the authentication policy.
      boolean isMandatory()
      Get the MessagePolicy modifier.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MessagePolicy

        public MessagePolicy(MessagePolicy.TargetPolicy[] targetPolicies,
             boolean mandatory)
        Create a MessagePolicy instance with an array of target policies.
        Parameters:
        targetPolicies - an array of target policies.
        mandatory - A boolean value indicating whether the MessagePolicy is mandatory or optional.
        Throws:
        IllegalArgumentException - if the specified targetPolicies is null.

    • Method Detail

      • isMandatory

        public boolean isMandatory()
        Get the MessagePolicy modifier.
        Returns:
        A boolean indicating whether the MessagePolicy is optional(false) or required(true).

      • getTargetPolicies

        public MessagePolicy.TargetPolicy[] getTargetPolicies()
        Get the target policies that comprise the authentication policy.

        Returns:
        An array of target authentication policies, where each element describes an authentication policy and the parts of the message to which the authentication policy applies. This method returns null to indicate that no security operations should be performed on the messages to which the policy applies. This method never returns a zero-length array.

        When this method returns an array of target policies, the order of elements in the array represents the order that the corresponding message transformations or validations described by the target policies are to be performed by the authentication module.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessagePolicy.ProtectionPolicy (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message

Interface MessagePolicy.ProtectionPolicy

  • Enclosing class:
    MessagePolicy

    public static interface MessagePolicy.ProtectionPolicy
    This interface is used to represent message authentication policy.

    The internal state of a ProtectionPolicy object defines the message authentication requirements to be applied to the associated Target.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String AUTHENTICATE_CONTENT
      The identifer for a ProtectionPolicy that indicates that the origin of data within the message is to be authenticated (that is, the message is to be protected such that its recipients can establish who defined the message content).
      static String AUTHENTICATE_RECIPIENT
      The identifer for a ProtectionPolicy that indicates that the message recipient is to be authenticated.
      static String AUTHENTICATE_SENDER
      The identifer for a ProtectionPolicy that indicates that the sending entity is to be authenticated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getID()
      Get the ProtectionPolicy identifier.

    • Field Detail

      • AUTHENTICATE_SENDER

        static final String AUTHENTICATE_SENDER
        The identifer for a ProtectionPolicy that indicates that the sending entity is to be authenticated.
        See Also:
        Constant Field Values

      • AUTHENTICATE_CONTENT

        static final String AUTHENTICATE_CONTENT
        The identifer for a ProtectionPolicy that indicates that the origin of data within the message is to be authenticated (that is, the message is to be protected such that its recipients can establish who defined the message content).
        See Also:
        Constant Field Values

      • AUTHENTICATE_RECIPIENT

        static final String AUTHENTICATE_RECIPIENT
        The identifer for a ProtectionPolicy that indicates that the message recipient is to be authenticated.
        See Also:
        Constant Field Values

    • Method Detail

      • getID

        String getID()
        Get the ProtectionPolicy identifier. An identifier may represent a conceptual protection policy (as is the case with the static identifiers defined within this interface) or it may identify a procedural policy expression or plan that may be more difficult to categorize in terms of a conceptual identifier.
        Returns:
        A String containing a policy identifier. This interface defines some policy identifier constants. Configuration systems may define and employ other policy identifiers values.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessagePolicy.Target (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message

Interface MessagePolicy.Target

  • Enclosing class:
    MessagePolicy

    public static interface MessagePolicy.Target
    This interface is used to represent and perform message targeting. Targets are used by message authentication modules to operate on the corresponding content within messages.

    The internal state of a Target indicates whether it applies to the request or response message of a MessageInfo and to which components it applies within the identified message.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object get(MessageInfo messageInfo)
      Get the Object identified by the Target from the MessageInfo.
      void put(MessageInfo messageInfo, Object data)
      Put the Object into the MessageInfo at the location identified by the target.
      void remove(MessageInfo messageInfo)
      Remove the Object identified by the Target from the MessageInfo.

    • Method Detail

      • get

        Object get(MessageInfo messageInfo)
        Get the Object identified by the Target from the MessageInfo.
        Parameters:
        messageInfo - The MessageInfo containing the request or response message from which the target is to be obtained.
        Returns:
        An Object representing the target, or null when the target could not be found in the MessageInfo.

      • remove

        void remove(MessageInfo messageInfo)
        Remove the Object identified by the Target from the MessageInfo.
        Parameters:
        messageInfo - The MessageInfo containing the request or response message from which the target is to be removed.

      • put

        void put(MessageInfo messageInfo,
       Object data)
        Put the Object into the MessageInfo at the location identified by the target.
        Parameters:
        messageInfo - The MessageInfo containing the request or response message into which the object is to be put.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessagePolicy.TargetPolicy (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message

Class MessagePolicy.TargetPolicy

  • java.lang.Object
    • javax.security.auth.message.MessagePolicy.TargetPolicy
  • Enclosing class:
    MessagePolicy

    public static class MessagePolicy.TargetPolicy
extends Object
    This class defines the message protection policies for specific Targets.

    This class is used to associate a message protection policy with targets within a message. Message targets are represented using an implementation of the Target interface matched to the message types in MessageInfo. The message protection policy is identified by an implementation of the ProtectionPolicy interface.

    See Also:
    ClientAuthModule, ServerAuthModule

    • Constructor Summary

      Constructors
      Constructor and Description
      MessagePolicy.TargetPolicy(MessagePolicy.Target[] targets, MessagePolicy.ProtectionPolicy protectionPolicy)
      Create a TargetPolicy instance with an array of Targets and with a ProtectionPolicy.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      MessagePolicy.ProtectionPolicy getProtectionPolicy()
      Get the ProtectionPolicy that applies to the targets.
      MessagePolicy.Target[] getTargets()
      Get the array of layer-specific target descriptors that identify the one or more message parts to which the specified message protection policy applies.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MessagePolicy.TargetPolicy

        public MessagePolicy.TargetPolicy(MessagePolicy.Target[] targets,
                          MessagePolicy.ProtectionPolicy protectionPolicy)
        Create a TargetPolicy instance with an array of Targets and with a ProtectionPolicy.
        Parameters:
        targets - An array of Targets. This argument may be null.
        protectionPolicy - The object that describes the message authentication policy that applies to the targets.
        Throws:
        IllegalArgumentException - if the specified targets or protectionPolicy is null.

    • Method Detail

      • getTargets

        public MessagePolicy.Target[] getTargets()
        Get the array of layer-specific target descriptors that identify the one or more message parts to which the specified message protection policy applies.
        Returns:
        An array of Target that identify targets within a message. This method returns null when the specified policy applies to the whole message (excluding any metadata added to the message to satisfy the policy). This method never returns a zero-length array.

      • getProtectionPolicy

        public MessagePolicy.ProtectionPolicy getProtectionPolicy()
        Get the ProtectionPolicy that applies to the targets.
        Returns:
        A ProtectionPolicy object that identifies the message authentication requirements that apply to the targets.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerAuth (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message

Interface ServerAuth

  • All Known Subinterfaces:
    ServerAuthContext, ServerAuthModule

    public interface ServerAuth
    An implementation of this interface is used to validate received service request messages, and to secure service response messages.
    See Also:
    MessageInfo, Subject

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void cleanSubject(MessageInfo messageInfo, Subject subject)
      Remove method specific principals and credentials from the subject.
      AuthStatus secureResponse(MessageInfo messageInfo, Subject serviceSubject)
      Secure a service response before sending it to the client.
      AuthStatus validateRequest(MessageInfo messageInfo, Subject clientSubject, Subject serviceSubject)
      Authenticate a received service request.

    • Method Detail

      • validateRequest

        AuthStatus validateRequest(MessageInfo messageInfo,
                         Subject clientSubject,
                         Subject serviceSubject)
                           throws AuthException
        Authenticate a received service request. This method is called to transform the mechanism-specific request message acquired by calling getRequestMessage (on messageInfo) into the validated application message to be returned to the message processing runtime. If the received message is a (mechanism-specific) meta-message, the method implementation must attempt to transform the meta-message into a corresponding mechanism-specific response message, or to the validated application request message. The runtime will bind a validated application message into the the corresponding service invocation.

        This method conveys the outcome of its message processing either by returning an AuthStatus value or by throwing an AuthException.

        Parameters:
        messageInfo - A contextual object that encapsulates the client request and server response objects, and that may be used to save state across a sequence of calls made to the methods of this interface for the purpose of completing a secure message exchange.
        clientSubject - A Subject that represents the source of the service request. It is used by the method implementation to store Principals and credentials validated in the request.
        serviceSubject - A Subject that represents the recipient of the service request, or null. It may be used by the method implementation as the source of Principals or credentials to be used to validate the request. If the Subject is not null, the method implementation may add additional Principals or credentials (pertaining to the recipient of the service request) to the Subject.
        Returns:
        An AuthStatus object representing the completion status of the processing performed by the method. The AuthStatus values that may be returned by this method are defined as follows:
        • AuthStatus.SUCCESS when the application request message was successfully validated. The validated request message is available by calling getRequestMessage on messageInfo.
        • AuthStatus.SEND_SUCCESS to indicate that validation/processing of the request message successfully produced the secured application response message (in messageInfo). The secured response message is available by calling getResponseMessage on messageInfo.
        • AuthStatus.SEND_CONTINUE to indicate that message validation is incomplete, and that a preliminary response was returned as the response message in messageInfo. When this status value is returned to challenge an application request message, the challenged request must be saved by the authentication module such that it can be recovered when the module's validateRequest message is called to process the request returned for the challenge.
        • AuthStatus.SEND_FAILURE to indicate that message validation failed and that an appropriate failure response message is available by calling getResponseMessage on messageInfo.
        Throws:
        AuthException - When the message processing failed without establishing a failure response message (in messageInfo).

      • secureResponse

        AuthStatus secureResponse(MessageInfo messageInfo,
                        Subject serviceSubject)
                          throws AuthException
        Secure a service response before sending it to the client. This method is called to transform the response message acquired by calling getResponseMessage (on messageInfo) into the mechanism-specific form to be sent by the runtime.

        This method conveys the outcome of its message processing either by returning an AuthStatus value or by throwing an AuthException.

        Parameters:
        messageInfo - A contextual object that encapsulates the client request and server response objects, and that may be used to save state across a sequence of calls made to the methods of this interface for the purpose of completing a secure message exchange.
        serviceSubject - A Subject that represents the source of the service response, or null. It may be used by the method implementation to retrieve Principals and credentials necessary to secure the response. If the Subject is not null, the method implementation may add additional Principals or credentials (pertaining to the source of the service response) to the Subject.
        Returns:
        An AuthStatus object representing the completion status of the processing performed by the method. The AuthStatus values that may be returned by this method are defined as follows:
        • AuthStatus.SEND_SUCCESS when the application response message was successfully secured. The secured response message may be obtained by calling getResponseMessage on messageInfo.
        • AuthStatus.SEND_CONTINUE to indicate that the application response message (within messageInfo) was replaced with a security message that should elicit a security-specific response (in the form of a request) from the peer. This status value serves to inform the calling runtime that (to successfully complete the message exchange) it will need to be capable of continuing the message dialog by processing at least one additional request/response exchange (after having sent the response message returned in messageInfo). When this status value is returned, the application response must be saved by the authentication module such that it can be recovered when the module's validateRequest message is called to process the elicited response.
        • AuthStatus.SEND_FAILURE to indicate that a failure occurred while securing the response message and that an appropriate failure response message is available by calling getResponseMeessage on messageInfo.
        Throws:
        AuthException - When the message processing failed without establishing a failure response message (in messageInfo).

      • cleanSubject

        void cleanSubject(MessageInfo messageInfo,
                Subject subject)
                  throws AuthException
        Remove method specific principals and credentials from the subject.
        Parameters:
        messageInfo - a contextual object that encapsulates the client request and server response objects, and that may be used to save state across a sequence of calls made to the methods of this interface for the purpose of completing a secure message exchange.
        subject - the Subject instance from which the Principals and credentials are to be removed.
        Throws:
        AuthException - If an error occurs during the Subject processing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.security.auth.message (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.security.auth.message

  • Packages that use javax.security.auth.message
    Package Description
    javax.security.auth.message
    This package defines the core interfaces of the JSR 196 message authentication SPI.
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.
    javax.security.auth.message.module
    This package defines the interfaces implemented by JSR 196 compatible authentication modules.
  • Classes in javax.security.auth.message used by javax.security.auth.message
    Class and Description
    AuthException
    A generic authentication exception.
    AuthStatus
    The AuthStatus class is used to represent return values from Authentication modules and Authentication Contexts.
    MessageInfo
    A message processing runtime uses this interface to pass messages and message processing state to authentication contexts for processing by authentication modules.
    MessagePolicy.ProtectionPolicy
    This interface is used to represent message authentication policy.
    MessagePolicy.Target
    This interface is used to represent and perform message targeting.
    MessagePolicy.TargetPolicy
    This class defines the message protection policies for specific Targets.
  • Classes in javax.security.auth.message used by javax.security.auth.message.config
    Class and Description
    AuthException
    A generic authentication exception.
    ClientAuth
    An implementation of this interface is used to secure service request messages, and validate received service response messages.
    MessageInfo
    A message processing runtime uses this interface to pass messages and message processing state to authentication contexts for processing by authentication modules.
    ServerAuth
    An implementation of this interface is used to validate received service request messages, and to secure service response messages.
  • Classes in javax.security.auth.message used by javax.security.auth.message.module
    Class and Description
    AuthException
    A generic authentication exception.
    ClientAuth
    An implementation of this interface is used to secure service request messages, and validate received service response messages.
    MessagePolicy
    This class defines a message authentication policy.
    ServerAuth
    An implementation of this interface is used to validate received service request messages, and to secure service response messages.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


CallerPrincipalCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class CallerPrincipalCallback

  • java.lang.Object
    • javax.security.auth.message.callback.CallerPrincipalCallback
  • All Implemented Interfaces:
    Callback

    public class CallerPrincipalCallback
extends Object
implements Callback
    Callback for setting the container's caller (or Remote user) principal. This callback is intended to be called by a serverAuthModule during its validateRequest processing.

    • Constructor Summary

      Constructors
      Constructor and Description
      CallerPrincipalCallback(Subject s, Principal p)
      Create a CallerPrincipalCallback to set the container's representation of the caller principal
      CallerPrincipalCallback(Subject s, String n)
      Create a CallerPrincipalCallback to set the container's representation of the caller principal.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Get the caller principal name.
      Principal getPrincipal()
      Get the caller principal.
      Subject getSubject()
      Get the Subject in which the handler will distinguish the caller principal

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CallerPrincipalCallback

        public CallerPrincipalCallback(Subject s,
                       Principal p)
        Create a CallerPrincipalCallback to set the container's representation of the caller principal
        Parameters:
        s - The Subject in which the container will distinguish the caller identity.
        p - The Principal that will be distinguished as the caller principal. This value may be null.

        The CallbackHandler must use the argument Principal to establish the caller principal associated with the invocation being processed by the container. When the argument Principal is null, the handler must establish the container's representation of the unauthenticated caller principal. The handler may perform principal mapping of non-null argument Principal values, but it must be possible to configure the handler such that it establishes the non-null argument Principal as the caller principal.

      • CallerPrincipalCallback

        public CallerPrincipalCallback(Subject s,
                       String n)
        Create a CallerPrincipalCallback to set the container's representation of the caller principal.
        Parameters:
        s - The Subject in which the container will distinguish the caller identity.
        n - The String value that will be returned when getName() is called on the principal established as the caller principal or null.

        The CallbackHandler must use the n argument to establish the caller principal associated with the invocation being processed by the container. When the n argument is null, the handler must establish the container's representation of the unauthenticated caller principal (which may or may not be equal to null, depending on the requirements of the container type ). The handler may perform principal mapping of non-null values of n, but it must be possible to configure the handler such that it establishes the non-null argument value as the value returned when getName is called on the established principal.

    • Method Detail

      • getSubject

        public Subject getSubject()
        Get the Subject in which the handler will distinguish the caller principal
        Returns:
        The subject.

      • getPrincipal

        public Principal getPrincipal()
        Get the caller principal.
        Returns:
        The principal or null.

        When the values returned by this method and the getName methods are null, the handler must establish the container's representation of the unauthenticated caller principal within the Subject.

      • getName

        public String getName()
        Get the caller principal name.
        Returns:
        The principal name or null.

        When the values returned by this method and the getPrincipal methods are null, the handler must establish the container's representation of the unauthenticated caller principal within the Subject.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CertStoreCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class CertStoreCallback

  • java.lang.Object
    • javax.security.auth.message.callback.CertStoreCallback
  • All Implemented Interfaces:
    Callback

    public class CertStoreCallback
extends Object
implements Callback
    Callback for CertStore.

    A CertStore is a generic repository for certificates. CertStores may be searched to locate public key certificates, as well as to put together certificate chains. Such a search may be necessary when the caller needs to verify a signature.

    • Constructor Summary

      Constructors
      Constructor and Description
      CertStoreCallback()
      Create a CertStoreCallback.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CertStore getCertStore()
      Used by the CertStore user to obtain the CertStore set within the Callback.
      void setCertStore(CertStore certStore)
      Used by the CallbackHandler to set the CertStore within the Callback.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CertStoreCallback

        public CertStoreCallback()
        Create a CertStoreCallback.

    • Method Detail

      • setCertStore

        public void setCertStore(CertStore certStore)
        Used by the CallbackHandler to set the CertStore within the Callback.
        Parameters:
        certStore - The certificate store, which may be null

      • getCertStore

        public CertStore getCertStore()
        Used by the CertStore user to obtain the CertStore set within the Callback.
        Returns:
        The CertStore, or null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


GroupPrincipalCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class GroupPrincipalCallback

  • java.lang.Object
    • javax.security.auth.message.callback.GroupPrincipalCallback
  • All Implemented Interfaces:
    Callback

    public class GroupPrincipalCallback
extends Object
implements Callback
    Callback establishing group principals within the argument subject. This callback is intended to be called by a serverAuthModule during its validateRequest processing.

    • Constructor Summary

      Constructors
      Constructor and Description
      GroupPrincipalCallback(Subject s, String[] g)
      Create a GroupPrincipalCallback to establish the container's representation of the corresponding group principals within the Subject.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String[] getGroups()
      Get the array of group names.
      Subject getSubject()
      Get the Subject in which the handler will establish the group principals.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • GroupPrincipalCallback

        public GroupPrincipalCallback(Subject s,
                      String[] g)
        Create a GroupPrincipalCallback to establish the container's representation of the corresponding group principals within the Subject.
        Parameters:
        s - The Subject in which the container will create group principals.
        g - An array of Strings, where each element contains the name of a group that will be used to create a corresponding group principal within the Subject.

        When a null value is passed to the g argument, the handler will establish the container's representation of no group principals within the Subject. Otherwise, the handler's processing of this callback is additive, yielding the union (without duplicates) of the principals existing within the Subject, and those created with the names occuring within the argument array. The CallbackHandler will define the type of the created principals.

    • Method Detail

      • getSubject

        public Subject getSubject()
        Get the Subject in which the handler will establish the group principals.
        Returns:
        The subject.

      • getGroups

        public String[] getGroups()
        Get the array of group names.
        Returns:
        Null, or an array containing 0 or more String group names.

        When the return value is null, the handler will establish the container's representation of no group principals within the Subject. Otherwise, the handler's processing of this callback is additive, yielding the union (without duplicates) of the principals created with the names in the returned array and those existing within the Subject.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.security.auth.message.callback (Java(TM) EE 7 Specification APIs)

javax.security.auth.message.callback

Interfaces

  • PrivateKeyCallback.Request
  • SecretKeyCallback.Request

Classes

  • CallerPrincipalCallback
  • CertStoreCallback
  • GroupPrincipalCallback
  • PasswordValidationCallback
  • PrivateKeyCallback
  • PrivateKeyCallback.AliasRequest
  • PrivateKeyCallback.DigestRequest
  • PrivateKeyCallback.IssuerSerialNumRequest
  • PrivateKeyCallback.SubjectKeyIDRequest
  • SecretKeyCallback
  • SecretKeyCallback.AliasRequest
  • TrustStoreCallback


javax.security.auth.message.callback (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.security.auth.message.callback

This package defines callback interfaces that may be used by a pluggable message authentication module to interact with the message processing runtime that invoked the module.

See: Description

  • Interface Summary
    Interface Description
    PrivateKeyCallback.Request
    Marker interface for private key request types.
    SecretKeyCallback.Request
    Marker interface for secret key request types.
  • Class Summary
    Class Description
    CallerPrincipalCallback
    Callback for setting the container's caller (or Remote user) principal.
    CertStoreCallback
    Callback for CertStore.
    GroupPrincipalCallback
    Callback establishing group principals within the argument subject.
    PasswordValidationCallback
    Callback for PasswordValidation.
    PrivateKeyCallback
    Callback for acquiring a Public Key Infrastructure (PKI) private key and its corresponding certificate chain.
    PrivateKeyCallback.AliasRequest
    Request type for private keys that are identified using an alias.
    PrivateKeyCallback.DigestRequest
    Request type for private keys that are identified using a certificate digest or thumbprint.
    PrivateKeyCallback.IssuerSerialNumRequest
    Request type for private keys that are identified using an issuer/serial number.
    PrivateKeyCallback.SubjectKeyIDRequest
    Request type for private keys that are identified using a SubjectKeyID
    SecretKeyCallback
    Callback for acquiring a shared secret from a key repository.
    SecretKeyCallback.AliasRequest
    Request type for secret keys that are identified using an alias.
    TrustStoreCallback
    Callback for trusted certificate KeyStore.

Package javax.security.auth.message.callback Description

This package defines callback interfaces that may be used by a pluggable message authentication module to interact with the message processing runtime that invoked the module.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.security.auth.message.callback Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.security.auth.message.callback

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.security.auth.message.callback.CallerPrincipalCallback (implements javax.security.auth.callback.Callback)
    • javax.security.auth.message.callback.CertStoreCallback (implements javax.security.auth.callback.Callback)
    • javax.security.auth.message.callback.GroupPrincipalCallback (implements javax.security.auth.callback.Callback)
    • javax.security.auth.message.callback.PasswordValidationCallback (implements javax.security.auth.callback.Callback)
    • javax.security.auth.message.callback.PrivateKeyCallback (implements javax.security.auth.callback.Callback)
    • javax.security.auth.message.callback.PrivateKeyCallback.AliasRequest (implements javax.security.auth.message.callback.PrivateKeyCallback.Request)
    • javax.security.auth.message.callback.PrivateKeyCallback.DigestRequest (implements javax.security.auth.message.callback.PrivateKeyCallback.Request)
    • javax.security.auth.message.callback.PrivateKeyCallback.IssuerSerialNumRequest (implements javax.security.auth.message.callback.PrivateKeyCallback.Request)
    • javax.security.auth.message.callback.PrivateKeyCallback.SubjectKeyIDRequest (implements javax.security.auth.message.callback.PrivateKeyCallback.Request)
    • javax.security.auth.message.callback.SecretKeyCallback (implements javax.security.auth.callback.Callback)
    • javax.security.auth.message.callback.SecretKeyCallback.AliasRequest (implements javax.security.auth.message.callback.SecretKeyCallback.Request)
    • javax.security.auth.message.callback.TrustStoreCallback (implements javax.security.auth.callback.Callback)

Interface Hierarchy

  • javax.security.auth.message.callback.PrivateKeyCallback.Request
  • javax.security.auth.message.callback.SecretKeyCallback.Request
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


PasswordValidationCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class PasswordValidationCallback

  • java.lang.Object
    • javax.security.auth.message.callback.PasswordValidationCallback
  • All Implemented Interfaces:
    Callback

    public class PasswordValidationCallback
extends Object
implements Callback
    Callback for PasswordValidation. This callback may be used by an authentication module to employ the password validation facilities of its containing runtime. This Callback would typically be called by a ServerAuthModule during validateRequest processing.

    • Constructor Summary

      Constructors
      Constructor and Description
      PasswordValidationCallback(Subject subject, String username, char[] password)
      Create a PasswordValidationCallback.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearPassword()
      Clear the password.
      char[] getPassword()
      Get the password.
      boolean getResult()
      Get the authentication result.
      Subject getSubject()
      Get the subject.
      String getUsername()
      Get the username.
      void setResult(boolean result)
      Set the authentication result.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PasswordValidationCallback

        public PasswordValidationCallback(Subject subject,
                          String username,
                          char[] password)
        Create a PasswordValidationCallback.
        Parameters:
        subject - The subject for authentication
        username - The username to authenticate
        password - tTe user's password, which may be null.

    • Method Detail

      • getSubject

        public Subject getSubject()
        Get the subject.
        Returns:
        The subject.

      • getUsername

        public String getUsername()
        Get the username.
        Returns:
        The username.

      • getPassword

        public char[] getPassword()
        Get the password.

        Note that this method returns a reference to the password. If a clone of the array is created it is the caller's responsibility to zero out the password information after it is no longer needed.

        Returns:
        The password, which may be null.

      • clearPassword

        public void clearPassword()
        Clear the password.

      • setResult

        public void setResult(boolean result)
        Set the authentication result.
        Parameters:
        result - True if authentication succeeded, false otherwise

      • getResult

        public boolean getResult()
        Get the authentication result.
        Returns:
        True if authentication succeeded, false otherwise
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PrivateKeyCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class PrivateKeyCallback

  • java.lang.Object
    • javax.security.auth.message.callback.PrivateKeyCallback
  • All Implemented Interfaces:
    Callback

    public class PrivateKeyCallback
extends Object
implements Callback
    Callback for acquiring a Public Key Infrastructure (PKI) private key and its corresponding certificate chain. This Callback may be used by client or server authentication modules to obtain private keys or private key references, from key repositories available to the CallbackHandler that processes the Callback.

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  PrivateKeyCallback.AliasRequest
      Request type for private keys that are identified using an alias.
      static class  PrivateKeyCallback.DigestRequest
      Request type for private keys that are identified using a certificate digest or thumbprint.
      static class  PrivateKeyCallback.IssuerSerialNumRequest
      Request type for private keys that are identified using an issuer/serial number.
      static interface  PrivateKeyCallback.Request
      Marker interface for private key request types.
      static class  PrivateKeyCallback.SubjectKeyIDRequest
      Request type for private keys that are identified using a SubjectKeyID

    • Constructor Summary

      Constructors
      Constructor and Description
      PrivateKeyCallback(PrivateKeyCallback.Request request)
      Constructs this PrivateKeyCallback with a private key Request object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Certificate[] getChain()
      Used to obtain the certicicate chain set within the Callback.
      PrivateKey getKey()
      Used to obtain the private key set within the Callback.
      PrivateKeyCallback.Request getRequest()
      Used by the CallbackHandler to get the Request object that identifies the private key to be returned.
      void setKey(PrivateKey key, Certificate[] chain)
      Used by the CallbackHandler to set the requested private key and the corresponding certificate chain within the Callback.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PrivateKeyCallback

        public PrivateKeyCallback(PrivateKeyCallback.Request request)
        Constructs this PrivateKeyCallback with a private key Request object.

        The request object identifies the private key to be returned. The corresponding certificate chain for the private key is also returned.

        If the request object is null, the handler of the callback relies on its own default.

        Parameters:
        request - Identifier for the private key, or null.

    • Method Detail

      • getRequest

        public PrivateKeyCallback.Request getRequest()
        Used by the CallbackHandler to get the Request object that identifies the private key to be returned.
        Returns:
        The Request object which identifies the private key to be returned, or null. If null, the handler of the callback relies on its own default.

      • setKey

        public void setKey(PrivateKey key,
          Certificate[] chain)
        Used by the CallbackHandler to set the requested private key and the corresponding certificate chain within the Callback.

        If the requested private key or chain could not be found, then both values must be set to null.

        Parameters:
        key - The private key, or null.
        chain - The corresponding certificate chain, or null.

      • getKey

        public PrivateKey getKey()
        Used to obtain the private key set within the Callback.
        Returns:
        The private key, or null if the key could not be found.

      • getChain

        public Certificate[] getChain()
        Used to obtain the certicicate chain set within the Callback.
        Returns:
        The certificate chain, or null if the chain could not be found.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PrivateKeyCallback.AliasRequest (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class PrivateKeyCallback.AliasRequest

  • java.lang.Object
    • javax.security.auth.message.callback.PrivateKeyCallback.AliasRequest
  • All Implemented Interfaces:
    PrivateKeyCallback.Request
    Enclosing class:
    PrivateKeyCallback

    public static class PrivateKeyCallback.AliasRequest
extends Object
implements PrivateKeyCallback.Request
    Request type for private keys that are identified using an alias.

    • Constructor Summary

      Constructors
      Constructor and Description
      PrivateKeyCallback.AliasRequest(String alias)
      Construct an AliasRequest with an alias.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAlias()
      Get the alias.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PrivateKeyCallback.AliasRequest

        public PrivateKeyCallback.AliasRequest(String alias)
        Construct an AliasRequest with an alias.

        The alias is used to directly identify the private key to be returned. The corresponding certificate chain for the private key is also returned.

        If the alias is null, the handler of the callback relies on its own default.

        Parameters:
        alias - Name identifier for the private key, or null.

    • Method Detail

      • getAlias

        public String getAlias()
        Get the alias.
        Returns:
        The alias, or null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PrivateKeyCallback.DigestRequest (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class PrivateKeyCallback.DigestRequest

  • java.lang.Object
    • javax.security.auth.message.callback.PrivateKeyCallback.DigestRequest
  • All Implemented Interfaces:
    PrivateKeyCallback.Request
    Enclosing class:
    PrivateKeyCallback

    public static class PrivateKeyCallback.DigestRequest
extends Object
implements PrivateKeyCallback.Request
    Request type for private keys that are identified using a certificate digest or thumbprint.

    • Constructor Summary

      Constructors
      Constructor and Description
      PrivateKeyCallback.DigestRequest(byte[] digest, String algorithm)
      Constructs a DigestRequest with a digest value and algorithm identifier.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAlgorithm()
      Get the algorithm identifier.
      byte[] getDigest()
      Get the digest value.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PrivateKeyCallback.DigestRequest

        public PrivateKeyCallback.DigestRequest(byte[] digest,
                                String algorithm)
        Constructs a DigestRequest with a digest value and algorithm identifier.

        The digest of the certificate whose private key is returned must match the provided digest. The certificate digest is computed by applying the specified algorithm to the bytes of the certificate. For example: MessageDigest.getInstance(algorithm).digest(cert.getEncoded()) . The corresponding certificate chain for the private key is also returned. If the digest or algorithm parameters are null, the handler of the callback relies on its own defaults.

        Parameters:
        digest - The digest value to use to select the corresponding certificate and private key (or null).
        algorithm - A string value identifying the digest algorithm. The value passed to this parameter may be null. If it is not null, it must conform to the requirements for the algorithm parameter of java.security.MessageDigest.getInstance().

    • Method Detail

      • getDigest

        public byte[] getDigest()
        Get the digest value.
        Returns:
        The digest value which must match the digest of the certificate corresponding to the returned private key.

      • getAlgorithm

        public String getAlgorithm()
        Get the algorithm identifier.
        Returns:
        The identifer of the algorithm used to compute the digest.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PrivateKeyCallback.IssuerSerialNumRequest (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class PrivateKeyCallback.IssuerSerialNumRequest

  • java.lang.Object
    • javax.security.auth.message.callback.PrivateKeyCallback.IssuerSerialNumRequest
  • All Implemented Interfaces:
    PrivateKeyCallback.Request
    Enclosing class:
    PrivateKeyCallback

    public static class PrivateKeyCallback.IssuerSerialNumRequest
extends Object
implements PrivateKeyCallback.Request
    Request type for private keys that are identified using an issuer/serial number.

    • Constructor Summary

      Constructors
      Constructor and Description
      PrivateKeyCallback.IssuerSerialNumRequest(X500Principal issuer, BigInteger serialNumber)
      Constructs a IssuerSerialNumRequest with an issuer/serial number.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      X500Principal getIssuer()
      Get the issuer.
      BigInteger getSerialNum()
      Get the serial number.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PrivateKeyCallback.IssuerSerialNumRequest

        public PrivateKeyCallback.IssuerSerialNumRequest(X500Principal issuer,
                                         BigInteger serialNumber)
        Constructs a IssuerSerialNumRequest with an issuer/serial number.

        The issuer/serial number is used to identify a public key certificate. The corresponding private key is returned in the callback. The corresponding certificate chain for the private key is also returned. If the issuer/serialNumber parameters are null, the handler of the callback relies on its own defaults.

        Parameters:
        issuer - The X500Principal name of the certificate issuer, or null.
        serialNumber - The serial number of the certificate, or null.

    • Method Detail

      • getIssuer

        public X500Principal getIssuer()
        Get the issuer.
        Returns:
        The issuer, or null.

      • getSerialNum

        public BigInteger getSerialNum()
        Get the serial number.
        Returns:
        The serial number, or null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PrivateKeyCallback.Request (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Interface PrivateKeyCallback.Request

  • All Known Implementing Classes:
    PrivateKeyCallback.AliasRequest, PrivateKeyCallback.DigestRequest, PrivateKeyCallback.IssuerSerialNumRequest, PrivateKeyCallback.SubjectKeyIDRequest
    Enclosing class:
    PrivateKeyCallback

    public static interface PrivateKeyCallback.Request
    Marker interface for private key request types.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PrivateKeyCallback.SubjectKeyIDRequest (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class PrivateKeyCallback.SubjectKeyIDRequest

  • java.lang.Object
    • javax.security.auth.message.callback.PrivateKeyCallback.SubjectKeyIDRequest
  • All Implemented Interfaces:
    PrivateKeyCallback.Request
    Enclosing class:
    PrivateKeyCallback

    public static class PrivateKeyCallback.SubjectKeyIDRequest
extends Object
implements PrivateKeyCallback.Request
    Request type for private keys that are identified using a SubjectKeyID

    • Constructor Summary

      Constructors
      Constructor and Description
      PrivateKeyCallback.SubjectKeyIDRequest(byte[] subjectKeyID)
      Construct a SubjectKeyIDRequest with an subjectKeyID.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      byte[] getSubjectKeyID()
      Get the subjectKeyID.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PrivateKeyCallback.SubjectKeyIDRequest

        public PrivateKeyCallback.SubjectKeyIDRequest(byte[] subjectKeyID)
        Construct a SubjectKeyIDRequest with an subjectKeyID.

        The subjectKeyID is used to directly identify the private key to be returned. The corresponding certificate chain for the private key is also returned.

        If the subjectKeyID is null, the handler of the callback relies on its own default.

        Parameters:
        subjectKeyID - Identifier for the private key, or null.

    • Method Detail

      • getSubjectKeyID

        public byte[] getSubjectKeyID()
        Get the subjectKeyID.
        Returns:
        The subjectKeyID, or null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SecretKeyCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class SecretKeyCallback

  • java.lang.Object
    • javax.security.auth.message.callback.SecretKeyCallback
  • All Implemented Interfaces:
    Callback

    public class SecretKeyCallback
extends Object
implements Callback
    Callback for acquiring a shared secret from a key repository. This Callback may be used by client or server authentication modules to obtain shared secrets (for example, passwords) without relying on a user during the Callback processing. This Callback is typically empoyed by ClientAuthModules invoked from intermediate components that need to acquire a password to authenticate to their target service.

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  SecretKeyCallback.AliasRequest
      Request type for secret keys that are identified using an alias.
      static interface  SecretKeyCallback.Request
      Marker interface for secret key request types.

    • Constructor Summary

      Constructors
      Constructor and Description
      SecretKeyCallback(SecretKeyCallback.Request request)
      Constructs this SecretKeyCallback with a secret key Request object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      SecretKey getKey()
      Used to obtain the secret key set within the Callback.
      SecretKeyCallback.Request getRequest()
      Used by the CallbackHandler to get the Request object which identifies the secret key to be returned.
      void setKey(SecretKey key)
      Used by the CallbackHandler to set the requested secret key within the Callback.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SecretKeyCallback

        public SecretKeyCallback(SecretKeyCallback.Request request)
        Constructs this SecretKeyCallback with a secret key Request object.

        The request object identifies the secret key to be returned. If the alias is null, the handler of the callback relies on its own default.

        Parameters:
        request - Request object identifying the secret key, or null.

    • Method Detail

      • getRequest

        public SecretKeyCallback.Request getRequest()
        Used by the CallbackHandler to get the Request object which identifies the secret key to be returned.
        Returns:
        The Request object which identifies the private key to be returned, or null. If null, the handler of the callback relies on its own default.

      • setKey

        public void setKey(SecretKey key)
        Used by the CallbackHandler to set the requested secret key within the Callback.
        Parameters:
        key - The secret key, or null if no key was found.

      • getKey

        public SecretKey getKey()
        Used to obtain the secret key set within the Callback.
        Returns:
        The secret key, or null if no key was found.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SecretKeyCallback.AliasRequest (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class SecretKeyCallback.AliasRequest

  • java.lang.Object
    • javax.security.auth.message.callback.SecretKeyCallback.AliasRequest
  • All Implemented Interfaces:
    SecretKeyCallback.Request
    Enclosing class:
    SecretKeyCallback

    public static class SecretKeyCallback.AliasRequest
extends Object
implements SecretKeyCallback.Request
    Request type for secret keys that are identified using an alias.

    • Constructor Summary

      Constructors
      Constructor and Description
      SecretKeyCallback.AliasRequest(String alias)
      Construct an AliasRequest with an alias.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAlias()
      Get the alias.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SecretKeyCallback.AliasRequest

        public SecretKeyCallback.AliasRequest(String alias)
        Construct an AliasRequest with an alias.

        The alias is used to directly identify the secret key to be returned.

        If the alias is null, the handler of the callback relies on its own default.

        Parameters:
        alias - Name identifier for the secret key, or null.

    • Method Detail

      • getAlias

        public String getAlias()
        Get the alias.
        Returns:
        The alias, or null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SecretKeyCallback.Request (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Interface SecretKeyCallback.Request

  • All Known Implementing Classes:
    SecretKeyCallback.AliasRequest
    Enclosing class:
    SecretKeyCallback

    public static interface SecretKeyCallback.Request
    Marker interface for secret key request types.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TrustStoreCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.callback

Class TrustStoreCallback

  • java.lang.Object
    • javax.security.auth.message.callback.TrustStoreCallback
  • All Implemented Interfaces:
    Callback

    public class TrustStoreCallback
extends Object
implements Callback
    Callback for trusted certificate KeyStore.

    A trusted certificate KeyStore may be used to determine whether a given certificate chain can be trusted.

    • Constructor Summary

      Constructors
      Constructor and Description
      TrustStoreCallback()
      Create a TrustStoreCallback.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      KeyStore getTrustStore()
      Used by the TrustStore user to obtain the TrustStore set within the Callback.
      void setTrustStore(KeyStore trustStore)
      Used by the CallbackHandler to set the trusted certificate keystore within the Callback.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TrustStoreCallback

        public TrustStoreCallback()
        Create a TrustStoreCallback.

    • Method Detail

      • setTrustStore

        public void setTrustStore(KeyStore trustStore)
        Used by the CallbackHandler to set the trusted certificate keystore within the Callback.
        Parameters:
        trustStore - The trusted certificate KeyStore, which must already be loaded.

      • getTrustStore

        public KeyStore getTrustStore()
        Used by the TrustStore user to obtain the TrustStore set within the Callback.
        Returns:
        The trusted certificate KeyStore. The KeyStore is guaranteed to already be loaded.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.security.auth.message.callback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.security.auth.message.callback

  • Packages that use javax.security.auth.message.callback
    Package Description
    javax.security.auth.message.callback
    This package defines callback interfaces that may be used by a pluggable message authentication module to interact with the message processing runtime that invoked the module.
  • Classes in javax.security.auth.message.callback used by javax.security.auth.message.callback
    Class and Description
    PrivateKeyCallback.Request
    Marker interface for private key request types.
    SecretKeyCallback.Request
    Marker interface for secret key request types.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.CallerPrincipalCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.CallerPrincipalCallback

No usage of javax.security.auth.message.callback.CallerPrincipalCallback
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.CertStoreCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.CertStoreCallback

No usage of javax.security.auth.message.callback.CertStoreCallback
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.GroupPrincipalCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.GroupPrincipalCallback

No usage of javax.security.auth.message.callback.GroupPrincipalCallback
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.PasswordValidationCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.PasswordValidationCallback

No usage of javax.security.auth.message.callback.PasswordValidationCallback
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.PrivateKeyCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.PrivateKeyCallback

No usage of javax.security.auth.message.callback.PrivateKeyCallback
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.PrivateKeyCallback.AliasRequest (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.PrivateKeyCallback.AliasRequest

No usage of javax.security.auth.message.callback.PrivateKeyCallback.AliasRequest
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.PrivateKeyCallback.DigestRequest (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.PrivateKeyCallback.DigestRequest

No usage of javax.security.auth.message.callback.PrivateKeyCallback.DigestRequest
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.PrivateKeyCallback.IssuerSerialNumRequest (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.PrivateKeyCallback.IssuerSerialNumRequest

No usage of javax.security.auth.message.callback.PrivateKeyCallback.IssuerSerialNumRequest
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.PrivateKeyCallback.SubjectKeyIDRequest (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.PrivateKeyCallback.SubjectKeyIDRequest

No usage of javax.security.auth.message.callback.PrivateKeyCallback.SubjectKeyIDRequest
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.SecretKeyCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.SecretKeyCallback

No usage of javax.security.auth.message.callback.SecretKeyCallback
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.SecretKeyCallback.AliasRequest (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.SecretKeyCallback.AliasRequest

No usage of javax.security.auth.message.callback.SecretKeyCallback.AliasRequest
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.callback.TrustStoreCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.callback.TrustStoreCallback

No usage of javax.security.auth.message.callback.TrustStoreCallback
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.callback.PrivateKeyCallback.Request (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.callback.PrivateKeyCallback.Request

  • Packages that use PrivateKeyCallback.Request
    Package Description
    javax.security.auth.message.callback
    This package defines callback interfaces that may be used by a pluggable message authentication module to interact with the message processing runtime that invoked the module.

    • Uses of PrivateKeyCallback.Request in javax.security.auth.message.callback

      Classes in javax.security.auth.message.callback that implement PrivateKeyCallback.Request
      Modifier and Type Class and Description
      static class  PrivateKeyCallback.AliasRequest
      Request type for private keys that are identified using an alias.
      static class  PrivateKeyCallback.DigestRequest
      Request type for private keys that are identified using a certificate digest or thumbprint.
      static class  PrivateKeyCallback.IssuerSerialNumRequest
      Request type for private keys that are identified using an issuer/serial number.
      static class  PrivateKeyCallback.SubjectKeyIDRequest
      Request type for private keys that are identified using a SubjectKeyID
      Methods in javax.security.auth.message.callback that return PrivateKeyCallback.Request
      Modifier and Type Method and Description
      PrivateKeyCallback.Request PrivateKeyCallback.getRequest()
      Used by the CallbackHandler to get the Request object that identifies the private key to be returned.
      Constructors in javax.security.auth.message.callback with parameters of type PrivateKeyCallback.Request
      Constructor and Description
      PrivateKeyCallback(PrivateKeyCallback.Request request)
      Constructs this PrivateKeyCallback with a private key Request object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.callback.SecretKeyCallback.Request (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.callback.SecretKeyCallback.Request

  • Packages that use SecretKeyCallback.Request
    Package Description
    javax.security.auth.message.callback
    This package defines callback interfaces that may be used by a pluggable message authentication module to interact with the message processing runtime that invoked the module.

    • Uses of SecretKeyCallback.Request in javax.security.auth.message.callback

      Classes in javax.security.auth.message.callback that implement SecretKeyCallback.Request
      Modifier and Type Class and Description
      static class  SecretKeyCallback.AliasRequest
      Request type for secret keys that are identified using an alias.
      Methods in javax.security.auth.message.callback that return SecretKeyCallback.Request
      Modifier and Type Method and Description
      SecretKeyCallback.Request SecretKeyCallback.getRequest()
      Used by the CallbackHandler to get the Request object which identifies the secret key to be returned.
      Constructors in javax.security.auth.message.callback with parameters of type SecretKeyCallback.Request
      Constructor and Description
      SecretKeyCallback(SecretKeyCallback.Request request)
      Constructs this SecretKeyCallback with a secret key Request object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.AuthException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.AuthException

  • Packages that use AuthException
    Package Description
    javax.security.auth.message
    This package defines the core interfaces of the JSR 196 message authentication SPI.
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.
    javax.security.auth.message.module
    This package defines the interfaces implemented by JSR 196 compatible authentication modules.

    • Uses of AuthException in javax.security.auth.message

      Methods in javax.security.auth.message that throw AuthException
      Modifier and Type Method and Description
      void ServerAuth.cleanSubject(MessageInfo messageInfo, Subject subject)
      Remove method specific principals and credentials from the subject.
      void ClientAuth.cleanSubject(MessageInfo messageInfo, Subject subject)
      Remove implementation specific principals and credentials from the subject.
      AuthStatus ClientAuth.secureRequest(MessageInfo messageInfo, Subject clientSubject)
      Secure a service request message before sending it to the service.
      AuthStatus ServerAuth.secureResponse(MessageInfo messageInfo, Subject serviceSubject)
      Secure a service response before sending it to the client.
      AuthStatus ServerAuth.validateRequest(MessageInfo messageInfo, Subject clientSubject, Subject serviceSubject)
      Authenticate a received service request.
      AuthStatus ClientAuth.validateResponse(MessageInfo messageInfo, Subject clientSubject, Subject serviceSubject)
      Validate a received service response.

    • Uses of AuthException in javax.security.auth.message.config

      Methods in javax.security.auth.message.config that throw AuthException
      Modifier and Type Method and Description
      ServerAuthContext ServerAuthConfig.getAuthContext(String authContextID, Subject serviceSubject, Map properties)
      Get a ServerAuthContext instance from this ServerAuthConfig.
      ClientAuthContext ClientAuthConfig.getAuthContext(String authContextID, Subject clientSubject, Map properties)
      Get a ClientAuthContext instance from this ClientAuthConfig.
      ClientAuthConfig AuthConfigProvider.getClientAuthConfig(String layer, String appContext, CallbackHandler handler)
      Get an instance of ClientAuthConfig from this provider.
      ServerAuthConfig AuthConfigProvider.getServerAuthConfig(String layer, String appContext, CallbackHandler handler)
      Get an instance of ServerAuthConfig from this provider.

    • Uses of AuthException in javax.security.auth.message.module

      Methods in javax.security.auth.message.module that throw AuthException
      Modifier and Type Method and Description
      void ServerAuthModule.initialize(MessagePolicy requestPolicy, MessagePolicy responsePolicy, CallbackHandler handler, Map options)
      Initialize this module with request and response message policies to enforce, a CallbackHandler, and any module-specific configuration properties.
      void ClientAuthModule.initialize(MessagePolicy requestPolicy, MessagePolicy responsePolicy, CallbackHandler handler, Map options)
      Initialize this module with request and response message policies to enforce, a CallbackHandler, and any module-specific configuration properties.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.AuthStatus (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.AuthStatus

  • Packages that use AuthStatus
    Package Description
    javax.security.auth.message
    This package defines the core interfaces of the JSR 196 message authentication SPI.

    • Uses of AuthStatus in javax.security.auth.message

      Fields in javax.security.auth.message declared as AuthStatus
      Modifier and Type Field and Description
      static AuthStatus AuthStatus.FAILURE
      Indicates that the message processing by the authentication module was NOT successful, and that the module replaced the application message with an error message.
      static AuthStatus AuthStatus.SEND_CONTINUE
      Indicates the message processing by the authentication module is NOT complete, that the module replaced the application message with a security message, and that the runtime is to proceed by sending the security message.
      static AuthStatus AuthStatus.SEND_FAILURE
      Indicates that the message processing by the authentication module was NOT successful, that the module replaced the application message with an error message, and that the runtime is to proceed by sending the error message.
      static AuthStatus AuthStatus.SEND_SUCCESS
      Indicates that the message processing by the authentication module was successful and that the runtime is to proceed by sending a message returned by the authentication module.
      static AuthStatus AuthStatus.SUCCESS
      Indicates that the message processing by the authentication module was successful and that the runtime is to proceed with its normal processing of the resulting message.
      Methods in javax.security.auth.message that return AuthStatus
      Modifier and Type Method and Description
      AuthStatus ClientAuth.secureRequest(MessageInfo messageInfo, Subject clientSubject)
      Secure a service request message before sending it to the service.
      AuthStatus ServerAuth.secureResponse(MessageInfo messageInfo, Subject serviceSubject)
      Secure a service response before sending it to the client.
      AuthStatus ServerAuth.validateRequest(MessageInfo messageInfo, Subject clientSubject, Subject serviceSubject)
      Authenticate a received service request.
      AuthStatus ClientAuth.validateResponse(MessageInfo messageInfo, Subject clientSubject, Subject serviceSubject)
      Validate a received service response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.MessagePolicy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.MessagePolicy

  • Packages that use MessagePolicy
    Package Description
    javax.security.auth.message.module
    This package defines the interfaces implemented by JSR 196 compatible authentication modules.

    • Uses of MessagePolicy in javax.security.auth.message.module

      Methods in javax.security.auth.message.module with parameters of type MessagePolicy
      Modifier and Type Method and Description
      void ServerAuthModule.initialize(MessagePolicy requestPolicy, MessagePolicy responsePolicy, CallbackHandler handler, Map options)
      Initialize this module with request and response message policies to enforce, a CallbackHandler, and any module-specific configuration properties.
      void ClientAuthModule.initialize(MessagePolicy requestPolicy, MessagePolicy responsePolicy, CallbackHandler handler, Map options)
      Initialize this module with request and response message policies to enforce, a CallbackHandler, and any module-specific configuration properties.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.MessagePolicy.TargetPolicy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.MessagePolicy.TargetPolicy

  • Packages that use MessagePolicy.TargetPolicy
    Package Description
    javax.security.auth.message
    This package defines the core interfaces of the JSR 196 message authentication SPI.

    • Uses of MessagePolicy.TargetPolicy in javax.security.auth.message

      Methods in javax.security.auth.message that return MessagePolicy.TargetPolicy
      Modifier and Type Method and Description
      MessagePolicy.TargetPolicy[] MessagePolicy.getTargetPolicies()
      Get the target policies that comprise the authentication policy.
      Constructors in javax.security.auth.message with parameters of type MessagePolicy.TargetPolicy
      Constructor and Description
      MessagePolicy(MessagePolicy.TargetPolicy[] targetPolicies, boolean mandatory)
      Create a MessagePolicy instance with an array of target policies.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.ClientAuth (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.ClientAuth

  • Packages that use ClientAuth
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.
    javax.security.auth.message.module
    This package defines the interfaces implemented by JSR 196 compatible authentication modules.

    • Uses of ClientAuth in javax.security.auth.message.config

      Subinterfaces of ClientAuth in javax.security.auth.message.config
      Modifier and Type Interface and Description
      interface  ClientAuthContext
      This ClientAuthContext class encapsulates ClientAuthModules that are used to secure service requests made by a client, and to validate any responses received to those requests.

    • Uses of ClientAuth in javax.security.auth.message.module

      Subinterfaces of ClientAuth in javax.security.auth.message.module
      Modifier and Type Interface and Description
      interface  ClientAuthModule
      A ClientAuthModule secures request messages, and validates received response messages.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.MessageInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.MessageInfo

  • Packages that use MessageInfo
    Package Description
    javax.security.auth.message
    This package defines the core interfaces of the JSR 196 message authentication SPI.
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.

    • Uses of MessageInfo in javax.security.auth.message

      Methods in javax.security.auth.message with parameters of type MessageInfo
      Modifier and Type Method and Description
      void ServerAuth.cleanSubject(MessageInfo messageInfo, Subject subject)
      Remove method specific principals and credentials from the subject.
      void ClientAuth.cleanSubject(MessageInfo messageInfo, Subject subject)
      Remove implementation specific principals and credentials from the subject.
      Object MessagePolicy.Target.get(MessageInfo messageInfo)
      Get the Object identified by the Target from the MessageInfo.
      void MessagePolicy.Target.put(MessageInfo messageInfo, Object data)
      Put the Object into the MessageInfo at the location identified by the target.
      void MessagePolicy.Target.remove(MessageInfo messageInfo)
      Remove the Object identified by the Target from the MessageInfo.
      AuthStatus ClientAuth.secureRequest(MessageInfo messageInfo, Subject clientSubject)
      Secure a service request message before sending it to the service.
      AuthStatus ServerAuth.secureResponse(MessageInfo messageInfo, Subject serviceSubject)
      Secure a service response before sending it to the client.
      AuthStatus ServerAuth.validateRequest(MessageInfo messageInfo, Subject clientSubject, Subject serviceSubject)
      Authenticate a received service request.
      AuthStatus ClientAuth.validateResponse(MessageInfo messageInfo, Subject clientSubject, Subject serviceSubject)
      Validate a received service response.

    • Uses of MessageInfo in javax.security.auth.message.config

      Methods in javax.security.auth.message.config with parameters of type MessageInfo
      Modifier and Type Method and Description
      String AuthConfig.getAuthContextID(MessageInfo messageInfo)
      Get the authentication context identifier corresponding to the request and response objects encapsulated in messageInfo.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.MessagePolicy.ProtectionPolicy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.MessagePolicy.ProtectionPolicy

  • Packages that use MessagePolicy.ProtectionPolicy
    Package Description
    javax.security.auth.message
    This package defines the core interfaces of the JSR 196 message authentication SPI.

    • Uses of MessagePolicy.ProtectionPolicy in javax.security.auth.message

      Methods in javax.security.auth.message that return MessagePolicy.ProtectionPolicy
      Modifier and Type Method and Description
      MessagePolicy.ProtectionPolicy MessagePolicy.TargetPolicy.getProtectionPolicy()
      Get the ProtectionPolicy that applies to the targets.
      Constructors in javax.security.auth.message with parameters of type MessagePolicy.ProtectionPolicy
      Constructor and Description
      MessagePolicy.TargetPolicy(MessagePolicy.Target[] targets, MessagePolicy.ProtectionPolicy protectionPolicy)
      Create a TargetPolicy instance with an array of Targets and with a ProtectionPolicy.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.MessagePolicy.Target (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.MessagePolicy.Target

  • Packages that use MessagePolicy.Target
    Package Description
    javax.security.auth.message
    This package defines the core interfaces of the JSR 196 message authentication SPI.

    • Uses of MessagePolicy.Target in javax.security.auth.message

      Methods in javax.security.auth.message that return MessagePolicy.Target
      Modifier and Type Method and Description
      MessagePolicy.Target[] MessagePolicy.TargetPolicy.getTargets()
      Get the array of layer-specific target descriptors that identify the one or more message parts to which the specified message protection policy applies.
      Constructors in javax.security.auth.message with parameters of type MessagePolicy.Target
      Constructor and Description
      MessagePolicy.TargetPolicy(MessagePolicy.Target[] targets, MessagePolicy.ProtectionPolicy protectionPolicy)
      Create a TargetPolicy instance with an array of Targets and with a ProtectionPolicy.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.ServerAuth (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.ServerAuth

  • Packages that use ServerAuth
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.
    javax.security.auth.message.module
    This package defines the interfaces implemented by JSR 196 compatible authentication modules.

    • Uses of ServerAuth in javax.security.auth.message.config

      Subinterfaces of ServerAuth in javax.security.auth.message.config
      Modifier and Type Interface and Description
      interface  ServerAuthContext
      This ServerAuthContext class encapsulates ServerAuthModules that are used to validate service requests received from clients, and to secure any response returned for those requests.

    • Uses of ServerAuth in javax.security.auth.message.module

      Subinterfaces of ServerAuth in javax.security.auth.message.module
      Modifier and Type Interface and Description
      interface  ServerAuthModule
      A ServerAuthModule validates client requests and secures responses to the client.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AuthConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.config

Interface AuthConfig

  • All Known Subinterfaces:
    ClientAuthConfig, ServerAuthConfig

    public interface AuthConfig
    This interface defines the common functionality implemented by Authentication context configuration objects.
    See Also:
    ClientAuthContext, ServerAuthContext

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAppContext()
      Get the application context identifier of this authentication context configuration object.
      String getAuthContextID(MessageInfo messageInfo)
      Get the authentication context identifier corresponding to the request and response objects encapsulated in messageInfo.
      String getMessageLayer()
      Get the message layer name of this authentication context configuration object.
      boolean isProtected()
      Used to determine whether the authentication context configuration object encapsulates any protected authentication contexts.
      void refresh()
      Causes a dynamic authentication context configuration object to update the internal state that it uses to process calls to its getAuthContext method.

    • Method Detail

      • getMessageLayer

        String getMessageLayer()
        Get the message layer name of this authentication context configuration object.
        Returns:
        The message layer name of this configuration object, or null if the configuration object pertains to an unspecified message layer.

      • getAppContext

        String getAppContext()
        Get the application context identifier of this authentication context configuration object.
        Returns:
        The String identifying the application context of this configuration object, or null if the configuration object pertains to an unspecified application context.

      • getAuthContextID

        String getAuthContextID(MessageInfo messageInfo)
        Get the authentication context identifier corresponding to the request and response objects encapsulated in messageInfo.
        Parameters:
        messageInfo - A contextual Object that encapsulates the client request and server response objects.
        Returns:
        The authentication context identifier corresponding to the encapsulated request and response objects, or null.
        Throws:
        IllegalArgumentException - If the type of the message objects incorporated in messageInfo are not compatible with the message types supported by this authentication context configuration object.

      • refresh

        void refresh()
        Causes a dynamic authentication context configuration object to update the internal state that it uses to process calls to its getAuthContext method.
        Throws:
        SecurityException - If the caller does not have permission to refresh the configuration object, or if an error occurred during the update.

      • isProtected

        boolean isProtected()
        Used to determine whether the authentication context configuration object encapsulates any protected authentication contexts.
        Returns:
        True if the configuration object encapsulates at least one protected authentication context. Otherwise, this method returns false.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AuthConfigFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.config

Class AuthConfigFactory

  • java.lang.Object
    • javax.security.auth.message.config.AuthConfigFactory

  • public abstract class AuthConfigFactory
extends Object
    This class is used to obtain AuthConfigProvider objects that can be used to obtain authentication context configuration objects, that is, ClientAuthConfig and ServerAuthConfig objects.

    Authentication context configuration objects are used to obtain authentication context objects. Authentication context objects, that is, ClientAuthContext and ServerAuthContex objects, encapsulate authentication modules. Authentication modules are pluggable components that perform security-related processing of request and response messages.

    Callers do not operate on modules directly. Instead they rely on an authentication context to manage the invocation of modules. A caller obtains an authentication context by calling the getAuthContext method on a ClientAuthConfig or ServerAuthConfig obtained from an AuthConfigProvider.

    The following represents a typical sequence of calls for obtaining a client authentication context, and then using it to secure a request.

    1. AuthConfigFactory factory = AuthConfigFactory.getFactory();
    2. AuthConfigProvider provider = factory.getConfigProvider(layer,appID,listener);
    3. ClientAuthConfig config = provider.getClientAuthConfig(layer,appID,cbh)
    4. String authContextID = config.getAuthContextID(messageInfo);
    5. ClientAuthContext context = config.getAuthContext(authContextID,subject,properties);
    6. context.secureRequest(messageInfo,subject);

    A system-wide AuthConfigFactory implementation can be set by invoking setFactory, and retrieved using getFactory.

    Every implementation of this abstract class must offer a public, zero argument constructor. This constructor must support the construction and registration (including self-registration) of AuthConfigProviders from a persistent declarative representation. For example, a factory implementation class could interpret the contents of a file containing a sequence of configuration entries, with one entry per AuthConfigProvider, and with each entry representing:

    • The fully qualified name of the provider implementation class (or null)
    • The list of provider initialization properties (which could be empty)
    Any provider initialization properties must be specified in a form that can be passed to the provider constructor within a Map of key, value pairs, and where all keys and values within the Map are of type String.

    The entry syntax must also provide for the optional inclusion of information sufficient to define a RegistrationContext. This information would only be present when the factory will register the provider. For example, each entry could provide for the inclusion of one or more RegistrationContext objects of the following form:

    • The message layer name (or null)
    • The application context identifier (or null)
    • The registration description (or null)
    When a RegistrationContext is not included, the factory must make it convenient for the provider to self-register with the factory during the provider construction (see registerConfigProvider(AuthConfigProvider provider, ...)).

    An AuthConfigFactory implementation is free to choose is own persistent declarative syntax as long as it conforms to the requirements defined by this class.

    See Also:
    ClientAuthContext, ServerAuthContext, ClientAuthConfig, ServerAuthConfig, Properties

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static interface  AuthConfigFactory.RegistrationContext
      Represents the layer identifier, application context identifier, and description components of an AuthConfigProvider registration at the factory.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DEFAULT_FACTORY_SECURITY_PROPERTY
      The name of the Security property used to define the default AuthConfigFactory implementation class.
      static String GET_FACTORY_PERMISSION_NAME
      The name of the SecurityPermission required to call getFactory
      static SecurityPermission getFactorySecurityPermission
      The SecurityPermission, with name GET_FACTORY_PERMISSION_NAME, that is used to authorize access to the getFactory method.
      static String PROVIDER_REGISTRATION_PERMISSION_NAME
      The name of the SecurityPermission to be used to authorize access to the update methods of the factory implementation class.
      static SecurityPermission providerRegistrationSecurityPermission
      An instance of the SecurityPermission (with name PROVIDER_REGISTRATION_PERMISSION_NAME) for use in authorizing access to the update methods of the factory implementation class.
      static String SET_FACTORY_PERMISSION_NAME
      The name of the SecurityPermission required to call setFactory
      static SecurityPermission setFactorySecurityPermission
      The SecurityPermission, with name SET_FACTORY_PERMISSION_NAME, that is used to authorize access to the setFactory method.

    • Constructor Summary

      Constructors
      Constructor and Description
      AuthConfigFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract String[] detachListener(RegistrationListener listener, String layer, String appContext)
      Disassociate the listener from all the provider registrations whose layer and appContext values are matched by the corresponding arguments to this method.
      abstract AuthConfigProvider getConfigProvider(String layer, String appContext, RegistrationListener listener)
      Get a registered AuthConfigProvider from the factory.
      static AuthConfigFactory getFactory()
      Get the system-wide AuthConfigFactory implementation.
      abstract AuthConfigFactory.RegistrationContext getRegistrationContext(String registrationID)
      Get the the registration context for the identified registration.
      abstract String[] getRegistrationIDs(AuthConfigProvider provider)
      Get the registration identifiers for all registrations of the provider instance at the factory.
      abstract void refresh()
      Cause the factory to reprocess its persistent declarative representation of provider registrations.
      abstract String registerConfigProvider(AuthConfigProvider provider, String layer, String appContext, String description)
      Registers within the (in-memory) factory, a provider of ServerAuthConfig and/or ClientAuthConfig objects for a message layer and application context identifier.
      abstract String registerConfigProvider(String className, Map properties, String layer, String appContext, String description)
      Registers within the factory and records within the factory's persistent declarative representation of provider registrations a provider of ServerAuthConfig and/or ClientAuthConfig objects for a message layer and application context identifier.
      abstract boolean removeRegistration(String registrationID)
      Remove the identified provider registration from the factory (and from the persistent declarative representation of provider registrations, if appropriate) and invoke any listeners associated with the removed registration.
      static void setFactory(AuthConfigFactory factory)
      Set the system-wide AuthConfigFactory implementation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • DEFAULT_FACTORY_SECURITY_PROPERTY

        public static final String DEFAULT_FACTORY_SECURITY_PROPERTY
        The name of the Security property used to define the default AuthConfigFactory implementation class.
        See Also:
        Constant Field Values

      • GET_FACTORY_PERMISSION_NAME

        public static final String GET_FACTORY_PERMISSION_NAME
        The name of the SecurityPermission required to call getFactory
        See Also:
        Constant Field Values

      • SET_FACTORY_PERMISSION_NAME

        public static final String SET_FACTORY_PERMISSION_NAME
        The name of the SecurityPermission required to call setFactory
        See Also:
        Constant Field Values

      • PROVIDER_REGISTRATION_PERMISSION_NAME

        public static final String PROVIDER_REGISTRATION_PERMISSION_NAME
        The name of the SecurityPermission to be used to authorize access to the update methods of the factory implementation class.
        See Also:
        Constant Field Values

      • getFactorySecurityPermission

        public static final SecurityPermission getFactorySecurityPermission
        The SecurityPermission, with name GET_FACTORY_PERMISSION_NAME, that is used to authorize access to the getFactory method.

      • setFactorySecurityPermission

        public static final SecurityPermission setFactorySecurityPermission
        The SecurityPermission, with name SET_FACTORY_PERMISSION_NAME, that is used to authorize access to the setFactory method.

      • providerRegistrationSecurityPermission

        public static final SecurityPermission providerRegistrationSecurityPermission
        An instance of the SecurityPermission (with name PROVIDER_REGISTRATION_PERMISSION_NAME) for use in authorizing access to the update methods of the factory implementation class.

    • Constructor Detail

      • AuthConfigFactory

        public AuthConfigFactory()

    • Method Detail

      • getFactory

        public static AuthConfigFactory getFactory()
        Get the system-wide AuthConfigFactory implementation.

        If a non-null system-wide factory instance is defined at the time of the call, for example, with setFactory, it will be returned. Otherwise, an attempt will be made to construct an instance of the default AuthConfigFactory implementation class. The fully qualified class name of the default factory implementation class is obtained from the value of the DEFAULT_FACTORY_SECURITY_PROPERTY security property. When an instance of the default factory implementation class is successfully constructed by this method, this method will set it as the system-wide factory instance.

        The absolute pathname of the Java security properties file is JAVA_HOME/lib/security/java.security, where JAVA_HOME refers to the directory where the JDK was installed.

        When a SecurityManager is enabled, the getFactorySecurityPermission will be required to call this method. If at the time of the call, a system-wide factory instance has not already been defined, then the setFactorySecurityPermission will also be required.

        Returns:
        The non-null system-wide AuthConfigFactory instance set at the time of the call, or if that value was null, the value of the system-wide factory instance established by this method. This method returns null when the system-wide factory was not defined when this method was called and no default factory name was defined via the security property.
        Throws:
        SecurityException - If the caller does not have permission to retrieve the factory, or set it as the system-wide instance. Also thrown if an exception was thrown during the class loading, or construction of the default AuthConfigFactory implementation class; in which case the SecurityException will contain the root Exception as its cause.

      • setFactory

        public static void setFactory(AuthConfigFactory factory)
        Set the system-wide AuthConfigFactory implementation.

        If an implementation was set previously, it will be replaced.

        Listeners are not notified of a change to the registered factory.

        Parameters:
        factory - The AuthConfigFactory instance, which may be null.
        Throws:
        SecurityException - If the caller does not have permission to set the factory.

      • getConfigProvider

        public abstract AuthConfigProvider getConfigProvider(String layer,
                                   String appContext,
                                   RegistrationListener listener)
        Get a registered AuthConfigProvider from the factory. Get the provider of ServerAuthConfig and ClientAuthConfig objects registered for the identified message layer and application context.

        All factories shall employ the following precedence rules to select the registered AuthConfigProvider that matches the layer and appContext arguments:

        • The provider specifically registered for the values passed as the layer and appContext arguments shall be selected.
        • If no provider is selected according to the preceding rule, the provider specifically registered for the value passed as the appContext argument and for all (that is, null) layers shall be selected.
        • If no provider is selected according to the preceding rules, the provider specifically registered for the value passed as the layer argument and for all (that is, null) appContexts shall be selected.
        • If no provider is selected according to the preceding rules, the provider registered for all (that is, null) layers and for all (that is, null) appContexts shall be selected.
        • If no provider is selected according to the preceding rules, the factory shall terminate its search for a registered provider.

        The above precedence rules apply equivalently to registrations created with a null or non-null className argument.

        Parameters:
        layer - A String identifying the message layer for which the registered AuthConfigProvider is to be returned. The value of this argument may be null.
        appContext - A String that identifies the application messaging context for which the registered AuthConfigProvider is to be returned. The value of this argument may be null.
        listener - The RegistrationListener whose notify method is to be invoked if the corresponding registration is unregistered or replaced. The value of this argument may be null.
        Returns:
        The implementation of the AuthConfigProvider interface registered at the factory for the layer and appContext, or null if no AuthConfigProvider is selected. An argument listener is attached even if the return value is null.

      • registerConfigProvider

        public abstract String registerConfigProvider(String className,
                            Map properties,
                            String layer,
                            String appContext,
                            String description)
        Registers within the factory and records within the factory's persistent declarative representation of provider registrations a provider of ServerAuthConfig and/or ClientAuthConfig objects for a message layer and application context identifier. This method typically constructs an instance of the provider before registering it with the factory. Factories may extend or modify the persisted registrations of existing provider instances, if those instances were registered with ClassName and properties arguments equivalent to those passed in the current call.

        This method employs the two argument constructor required to be supported by every implementation of the AuthConfigProvider interface, and this method must pass a null value for the factory argument of the constructor. AuthConfigProviderImpl AuthConfigProviderImpl(Map properties, AuthConfigFactory factory).

        At most one registration may exist within the factory for a given combination of message layer and appContext. Any pre-existing registration with identical values for layer and appContext is replaced by a subsequent registration. When replacement occurs, the registration identifier, layer, and appContext identifier remain unchanged, and the AuthConfigProvider (with initialization properties) and description are replaced.

        Within the lifetime of its Java process, a factory must assign unique registration identifiers to registrations, and must never assign a previously used registration identifier to a registration whose message layer and or appContext identifier differ from the previous use.

        Programmatic registrations performed by using this method must update (according to the replacement rules described above) the persistent declarative representation of provider registrations employed by the factory constructor.

        When a SecurityManager is enabled, before loading the argument provider, and before making any changes to the factory, this method must confirm that the calling access control context has been granted the providerRegistrationSecurityPermission

        Parameters:
        className - The fully qualified name of an AuthConfigProvider implementation class (or null). Calling this method with a null value for this parameter shall cause getConfigProvider to return null when it is called with layer and appContext values for which the resulting registration is the best match.
        properties - A Map object containing the initialization properties to be passed to the properties argument of the provider constructor. This argument may be null. When this argument is not null, all the values and keys occurring in the Map must be of type String.
        layer - A String identifying the message layer for which the provider will be registered at the factory. A null value may be passed as an argument for this parameter, in which case the provider is registered at all layers.
        appContext - A String value that may be used by a runtime to request a configuration object from this provider. A null value may be passed as an argument for this parameter, in which case the provider is registered for all configuration ids (at the indicated layers).
        description - A text String describing the provider. This value may be null.
        Returns:
        A String identifier assigned by the factory to the provider registration, and that may be used to remove the registration from the factory.
        Throws:
        SecurityException - If the caller does not have permission to register a provider at the factory, or if the the provider construction (given a non-null className) or registration fails.

      • registerConfigProvider

        public abstract String registerConfigProvider(AuthConfigProvider provider,
                            String layer,
                            String appContext,
                            String description)
        Registers within the (in-memory) factory, a provider of ServerAuthConfig and/or ClientAuthConfig objects for a message layer and application context identifier. This method does NOT effect the factory's persistent declarative representation of provider registrations, and is intended to be used by providers to perform self-Registration.

        At most one registration may exist within the factory for a given combination of message layer and appContext. Any pre-existing registration with identical values for layer and appContext is replaced by a subsequent registration. When replacement occurs, the registration identifier, layer, and appContext identifier remain unchanged, and the AuthConfigProvider (with initialization properties) and description are replaced.

        Within the lifetime of its Java process, a factory must assign unique registration identifiers to registrations, and must never assign a previously used registration identifier to a registration whose message layer and or appContext identifier differ from the previous use.

        When a SecurityManager is enabled, and before making any changes to the factory, this method must confirm that the calling access control context has been granted the providerRegistrationSecurityPermission

        Parameters:
        provider - The AuthConfigProvider to be registered at the factory (or null). Calling this method with a null value for this parameter shall cause getConfigProvider to return null when it is called with layer and appContext values for which the resulting registration is the best match.
        layer - A String identifying the message layer for which the provider will be registered at the factory. A null value may be passed as an argument for this parameter, in which case the provider is registered at all layers.
        appContext - A String value that may be used by a runtime to request a configuration object from this provider. A null value may be passed as an argument for this parameter, in which case the provider is registered for all configuration ids (at the indicated layers).
        description - A text String describing the provider. This value may be null.
        Returns:
        A String identifier assigned by the factory to the provider registration, and that may be used to remove the registration from the factory.
        Throws:
        SecurityException - If the caller does not have permission to register a provider at the factory, or if the provider registration fails.

      • removeRegistration

        public abstract boolean removeRegistration(String registrationID)
        Remove the identified provider registration from the factory (and from the persistent declarative representation of provider registrations, if appropriate) and invoke any listeners associated with the removed registration.

        When a SecurityManager is enabled, and before making any changes to the factory, this method must confirm that the calling access control context has been granted the providerRegistrationSecurityPermission

        Parameters:
        registrationID - A String that identifies a provider registration at the factory
        Returns:
        True if there was a registration with the specified identifier and it was removed. Return false if the registrationID was invalid.
        Throws:
        SecurityException - If the caller does not have permission to unregister the provider at the factory.

      • detachListener

        public abstract String[] detachListener(RegistrationListener listener,
                      String layer,
                      String appContext)
        Disassociate the listener from all the provider registrations whose layer and appContext values are matched by the corresponding arguments to this method.

        Factories should periodically notify Listeners to effectively detach listeners that are no longer in use.

        When a SecurityManager is enabled, and before making any changes to the factory, this method must confirm that the calling access control context has been granted the providerRegistrationSecurityPermission

        Parameters:
        listener - The RegistrationListener to be detached.
        layer - A String identifying the message layer or null.
        appContext - A String value identifying the application context or null.
        Returns:
        An array of String values where each value identifies a provider registration from which the listener was removed. This method never returns null; it returns an empty array if the listener was not removed from any registrations.
        Throws:
        SecurityException - If the caller does not have permission to detach the listener from the factory.

      • getRegistrationIDs

        public abstract String[] getRegistrationIDs(AuthConfigProvider provider)
        Get the registration identifiers for all registrations of the provider instance at the factory.
        Parameters:
        provider - The AuthConfigurationProvider whose registration identifiers are to be returned. This argument may be null, in which case it indicates that the IDs of all active registrations within the factory are to be returned.
        Returns:
        An array of String values where each value identifies a provider registration at the factory. This method never returns null; it returns an empty array when there are no registrations at the factory for the identified provider.

      • getRegistrationContext

        public abstract AuthConfigFactory.RegistrationContext getRegistrationContext(String registrationID)
        Get the the registration context for the identified registration.
        Parameters:
        registrationID - A String that identifies a provider registration at the factory
        Returns:
        A RegistrationContext or null. When a Non-null value is returned, it is a copy of the registration context corresponding to the registration. Null is returned when the registration identifier does not correspond to an active registration

      • refresh

        public abstract void refresh()
        Cause the factory to reprocess its persistent declarative representation of provider registrations.

        A factory should only replace an existing registration when a change of provider implementation class or initialization properties has occurred.

        When a SecurityManager is enabled, and before the point where this method could have caused any changes to the factory, this method must confirm that the calling access control context has been granted the providerRegistrationSecurityPermission

        Throws:
        SecurityException - If the caller does not have permission to refresh the factory, or if an error occurred during the reinitialization.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AuthConfigFactory.RegistrationContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.config

Interface AuthConfigFactory.RegistrationContext

  • Enclosing class:
    AuthConfigFactory

    public static interface AuthConfigFactory.RegistrationContext
    Represents the layer identifier, application context identifier, and description components of an AuthConfigProvider registration at the factory.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAppContext()
      Get the application context identifier from the registration context
      String getDescription()
      Get the description from the registration context
      String getMessageLayer()
      Get the layer name from the registration context
      boolean isPersistent()
      Get the persisted status from the registration context.

    • Method Detail

      • getMessageLayer

        String getMessageLayer()
        Get the layer name from the registration context
        Returns:
        A String identifying the message layer for which the AuthConfigProvider was registered. The returned value may be null.

      • getAppContext

        String getAppContext()
        Get the application context identifier from the registration context
        Returns:
        A String identifying the application context for which the AuthConfigProvider was registered. The returned value may be null.

      • getDescription

        String getDescription()
        Get the description from the registration context
        Returns:
        The description String from the registration, or null if no description string was included in the registration.

      • isPersistent

        boolean isPersistent()
        Get the persisted status from the registration context.
        Returns:
        A boolean indicating whether the registration is the result of a className based registration, or an instance-based (for example, self-) registration. Only registrations performed using the five argument registerConfigProvider method are persistent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AuthConfigProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.config

Interface AuthConfigProvider

  • public interface AuthConfigProvider
    This interface is implemented by objects that can be used to obtain authentication context configuration objects, that is, ClientAuthConfig or ServerAuthConfig objects.

    Authentication context configuration objects serve as sources of the authentication context objects, that is, ClientAuthContext or ServerAuthContext objects, for a specific message layer and messaging context.

    Authentication context objects encapsulate the initialization, configuration, and invocation of authentication modules, that is, ClientAuthModule or ServerAuthModule objects, for a specific message exchange within a specific message layer and messaging context.

    Callers do not directly operate on authentication modules. Instead, they rely on a ClientAuthContext or ServerAuthContext to manage the invocation of modules. A caller obtains an instance of ClientAuthContext or ServerAuthContext by calling the respective getAuthContext method on a ClientAuthConfig or ServerAuthConfig object obtained from an AuthConfigProvider.

    The following represents a typical sequence of calls for obtaining a client authentication context object, and then using it to secure a request.

    1. AuthConfigProvider provider;
    2. ClientAuthConfig config = provider.getClientAuthConfig(layer,appID,cbh);
    3. String authContextID = config.getAuthContextID(messageInfo);
    4. ClientAuthContext context = config.getAuthContext(authContextID,subject,properties);
    5. context.secureRequest(messageInfo,subject);

    Every implementation of this interface must offer a public, two argument constructor with the following signature:

 public AuthConfigProviderImpl(Map properties, AuthConfigFactory factory);
    where the properties argument may be null, and where all values and keys occurring in a non-null properties argument must be of type String. When the factory argument is not null, it indicates that the provider is to self-register at the factory by calling the following method on the factory:

 public String
 registerConfigProvider(AuthConfigProvider provider, String layer,
                        String appContext, String description);
    See Also:
    ClientAuthContext, ServerAuthContext, AuthConfigFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ClientAuthConfig getClientAuthConfig(String layer, String appContext, CallbackHandler handler)
      Get an instance of ClientAuthConfig from this provider.
      ServerAuthConfig getServerAuthConfig(String layer, String appContext, CallbackHandler handler)
      Get an instance of ServerAuthConfig from this provider.
      void refresh()
      Causes a dynamic configuration provider to update its internal state such that any resulting change to its state is reflected in the corresponding authentication context configuration objects previously created by the provider within the current process context.

    • Method Detail

      • getClientAuthConfig

        ClientAuthConfig getClientAuthConfig(String layer,
                                   String appContext,
                                   CallbackHandler handler)
                                     throws AuthException
        Get an instance of ClientAuthConfig from this provider.

        The implementation of this method returns a ClientAuthConfig instance that describes the configuration of ClientAuthModules at a given message layer, and for use in an identified application context.

        Parameters:
        layer - A String identifying the message layer for the returned ClientAuthConfig object. This argument must not be null.
        appContext - A String that identifies the messaging context for the returned ClientAuthConfig object. This argument must not be null.
        handler - A CallbackHandler to be passed to the ClientAuthModules encapsulated by ClientAuthContext objects derived from the returned ClientAuthConfig. This argument may be null, in which case the implementation may assign a default handler to the configuration. The CallbackHandler assigned to the configuration must support the Callback objects required to be supported by the profile of this specification being followed by the messaging runtime. The CallbackHandler instance must be initialized with any application context needed to process the required callbacks on behalf of the corresponding application.
        Returns:
        A ClientAuthConfig Object that describes the configuration of ClientAuthModules at the message layer and messaging context identified by the layer and appContext arguments. This method does not return null.
        Throws:
        AuthException - If this provider does not support the assignment of a default CallbackHandler to the returned ClientAuthConfig.
        SecurityException - If the caller does not have permission to retrieve the configuration.

      • getServerAuthConfig

        ServerAuthConfig getServerAuthConfig(String layer,
                                   String appContext,
                                   CallbackHandler handler)
                                     throws AuthException
        Get an instance of ServerAuthConfig from this provider.

        The implementation of this method returns a ServerAuthConfig instance that describes the configuration of ServerAuthModules at a given message layer, and for a particular application context.

        Parameters:
        layer - A String identifying the message layer for the returned ServerAuthConfig object. This argument must not be null.
        appContext - A String that identifies the messaging context for the returned ServerAuthConfig object. This argument must not be null.
        handler - A CallbackHandler to be passed to the ServerAuthModules encapsulated by ServerAuthContext objects derived from the returned ServerAuthConfig. This argument may be null, in which case the implementation may assign a default handler to the configuration. The CallbackHandler assigned to the configuration must support the Callback objects required to be supported by the profile of this specification being followed by the messaging runtime. The CallbackHandler instance must be initialized with any application context needed to process the required callbacks on behalf of the corresponding application.
        Returns:
        A ServerAuthConfig Object that describes the configuration of ServerAuthModules at a given message layer, and for a particular application context. This method does not return null.
        Throws:
        AuthException - If this provider does not support the assignment of a default CallbackHandler to the returned ServerAuthConfig.
        SecurityException - If the caller does not have permission to retrieve the configuration.

      • refresh

        void refresh()
        Causes a dynamic configuration provider to update its internal state such that any resulting change to its state is reflected in the corresponding authentication context configuration objects previously created by the provider within the current process context.
        Throws:
        SecurityException - If the caller does not have permission to refresh the provider, or if an error occurred during the refresh.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientAuthConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.config

Interface ClientAuthConfig

  • All Superinterfaces:
    AuthConfig

    public interface ClientAuthConfig
extends AuthConfig
    This interface encapsulates the configuration of ClientAuthContext objects for a message layer and application context (for example, the messaging context of a specific application, or set of applications).

    Implementations of this interface are returned by an AuthConfigProvider.

    Callers interact with a ClientAuthConfig to obtain ClientAuthContext objects suitable for processing a given message exchange at the layer and within the application context of the ClientAuthConfig. Each ClientAuthContext object is responsible for instantiating, initializing, and invoking the one or more ClientAuthModules encapsulated in the ClientAuthContext.

    After having acquired a ClientAuthContext, a caller operates on the context to cause it to invoke the encapsulated ClientAuthModules to secure client requests and to validate server responses.

    See Also:
    AuthConfigProvider

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ClientAuthContext getAuthContext(String authContextID, Subject clientSubject, Map properties)
      Get a ClientAuthContext instance from this ClientAuthConfig.

      • Methods inherited from interface javax.security.auth.message.config.AuthConfig

        getAppContext, getAuthContextID, getMessageLayer, isProtected, refresh

    • Method Detail

      • getAuthContext

        ClientAuthContext getAuthContext(String authContextID,
                               Subject clientSubject,
                               Map properties)
                                 throws AuthException
        Get a ClientAuthContext instance from this ClientAuthConfig.

        The implementation of this method returns a ClientAuthContext instance that encapsulates the ClientAuthModules used to secure and validate requests/responses associated with the given authContextID.

        Specifically, this method accesses this ClientAuthConfig object with the argument authContextID to determine the ClientAuthModules that are to be encapsulated in the returned ClientAuthContext instance.

        The ClientAuthConfig object establishes the request and response MessagePolicy objects that are passed to the encapsulated modules when they are initialized by the returned ClientAuthContext instance. It is the modules' responsibility to enforce these policies when invoked.

        Parameters:
        authContextID - An String identifier used to index the provided config, or null. This value must be identical to the value returned by the getAuthContextID method for all MessageInfo objects passed to the secureRequest method of the returned ClientAuthContext.
        clientSubject - A Subject that represents the source of the service request to be secured by the acquired authentication context. The principals and credentials of the Subject may be used to select or acquire the authentication context. If the Subject is not null, additional Principals or credentials (pertaining to the source of the request) may be added to the Subject. A null value may be passed for this parameter.
        properties - A Map object that may be used by the caller to augment the properties that will be passed to the encapsulated modules at module initialization. The null value may be passed for this parameter.
        Returns:
        A ClientAuthContext instance that encapsulates the ClientAuthModules used to secure and validate requests/responses associated with the given authContextID, or null (indicating that no modules are configured).
        Throws:
        AuthException - If this method fails.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientAuthContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.config

Interface ClientAuthContext

  • All Superinterfaces:
    ClientAuth

    public interface ClientAuthContext
extends ClientAuth
    This ClientAuthContext class encapsulates ClientAuthModules that are used to secure service requests made by a client, and to validate any responses received to those requests. A caller typically uses this class in the following manner:
    1. Retrieve an instance of this class by using ClientAuthConfig.getAuthContext.
    2. Invoke secureRequest.
      ClientAuthContext implementation invokes secureRequest of one or more encapsulated ClientAuthModules. Modules might attach credentials to request (for example, a user name and password), and/or secure the request (for example, sign and encrypt the request).
    3. Send request and receive response.
    4. Invoke validateResponse.
      ClientAuthContext implementation invokes validateResponse of one or more encapsulated ClientAuthModules. Modules verify or decrypt response as necessary.
    5. Invoke cleanSubject method (as necessary) to clean up any authentication state in Subject.

    A ClientAuthContext instance may be used concurrently by multiple callers.

    Implementations of this interface are responsible for constructing and initializing the encapsulated modules. The initialization step includes passing the relevant request and response MessagePolicy objects to the encapsulated modules. The MessagePolicy objects are obtained by the ClientAuthConfig instance used to obtain the ClientAuthContext object. See ClientAuthConfig.getAuthContext for more information.

    Implementations of this interface are instantiated by their associated configuration object such that they know which modules to invoke, in what order, and how results returned by preceding modules are to influence subsequent module invocations.

    Calls to the inherited methods of this interface delegate to the corresponding methods of the encapsulated authentication modules.

    See Also:
    ClientAuthConfig, ClientAuthModule

    • Method Summary

      • Methods inherited from interface javax.security.auth.message.ClientAuth

        cleanSubject, secureRequest, validateResponse
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.security.auth.message.config (Java(TM) EE 7 Specification APIs)

javax.security.auth.message.config

Interfaces

  • AuthConfig
  • AuthConfigFactory.RegistrationContext
  • AuthConfigProvider
  • ClientAuthConfig
  • ClientAuthContext
  • RegistrationListener
  • ServerAuthConfig
  • ServerAuthContext

Classes

  • AuthConfigFactory


javax.security.auth.message.config (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.security.auth.message.config

This package defines the interfaces implemented by JSR 196 compatible configuration systems.

See: Description

  • Interface Summary
    Interface Description
    AuthConfig
    This interface defines the common functionality implemented by Authentication context configuration objects.
    AuthConfigFactory.RegistrationContext
    Represents the layer identifier, application context identifier, and description components of an AuthConfigProvider registration at the factory.
    AuthConfigProvider
    This interface is implemented by objects that can be used to obtain authentication context configuration objects, that is, ClientAuthConfig or ServerAuthConfig objects.
    ClientAuthConfig
    This interface encapsulates the configuration of ClientAuthContext objects for a message layer and application context (for example, the messaging context of a specific application, or set of applications).
    ClientAuthContext
    This ClientAuthContext class encapsulates ClientAuthModules that are used to secure service requests made by a client, and to validate any responses received to those requests.
    RegistrationListener
    An implementation of this interface may be associated with an AuthConfigProvider registration at an AuthConfigFactory at the time the AuthConfigProvider is obtained for use from the factory.
    ServerAuthConfig
    This interface describes a configuration of ServerAuthConfiguration objects for a message layer and application context (for example, the messaging context of a specific application, or set of applications).
    ServerAuthContext
    This ServerAuthContext class encapsulates ServerAuthModules that are used to validate service requests received from clients, and to secure any response returned for those requests.
  • Class Summary
    Class Description
    AuthConfigFactory
    This class is used to obtain AuthConfigProvider objects that can be used to obtain authentication context configuration objects, that is, ClientAuthConfig and ServerAuthConfig objects.

Package javax.security.auth.message.config Description

This package defines the interfaces implemented by JSR 196 compatible configuration systems.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.security.auth.message.config Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.security.auth.message.config

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.security.auth.message.config.AuthConfigFactory

Interface Hierarchy

  • javax.security.auth.message.config.AuthConfig
    • javax.security.auth.message.config.ClientAuthConfig
    • javax.security.auth.message.config.ServerAuthConfig
  • javax.security.auth.message.config.AuthConfigFactory.RegistrationContext
  • javax.security.auth.message.config.AuthConfigProvider
  • javax.security.auth.message.ClientAuth
    • javax.security.auth.message.config.ClientAuthContext
  • javax.security.auth.message.config.RegistrationListener
  • javax.security.auth.message.ServerAuth
    • javax.security.auth.message.config.ServerAuthContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


RegistrationListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.config

Interface RegistrationListener

  • public interface RegistrationListener
    An implementation of this interface may be associated with an AuthConfigProvider registration at an AuthConfigFactory at the time the AuthConfigProvider is obtained for use from the factory. The AuthConfigFactory will invoke the notify method of the RegistrationListener if the corresponding provider registration is unregistered or replaced at the factory.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void notify(String layer, String appContext)
      Notify the listener that a registration with which it was associated was replaced or unregistered.

    • Method Detail

      • notify

        void notify(String layer,
          String appContext)
        Notify the listener that a registration with which it was associated was replaced or unregistered.

        When a RegistrationListener is associated with a provider registration within the factory, the factory must call its notify method when the corresponding registration is unregistered or replaced.

        Parameters:
        layer - A String identifying the one or more message layers corresponding to the registration for which the listerner is being notified.
        appContext - A String value identifying the application contexts corresponding to the registration for which the listener is being notified. The factory detaches the listener from the corresponding registration once the listener has been notified for the registration. The detachListerner method must be called to detach listeners that are no longer in use.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerAuthConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.config

Interface ServerAuthConfig

  • All Superinterfaces:
    AuthConfig

    public interface ServerAuthConfig
extends AuthConfig
    This interface describes a configuration of ServerAuthConfiguration objects for a message layer and application context (for example, the messaging context of a specific application, or set of applications).

    Implementations of this interface are returned by an AnthConfigProvider.

    Callers interact with a ServerAuthConfig to obtain ServerAuthContext objects suitable for processing a given message exchange at the layer and within the application context of the ServerAuthConfig. Each ServerAuthContext object is responsible for instantiating, initializing, and invoking the one or more ServerAuthModules encapsulated in the ServerAuthContext.

    After having acquired a ServerAuthContext, a caller operates on the context to cause it to invoke the encapsulated ServerAuthModules to validate service requests and to secure service responses.

    See Also:
    AuthConfigProvider

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ServerAuthContext getAuthContext(String authContextID, Subject serviceSubject, Map properties)
      Get a ServerAuthContext instance from this ServerAuthConfig.

      • Methods inherited from interface javax.security.auth.message.config.AuthConfig

        getAppContext, getAuthContextID, getMessageLayer, isProtected, refresh

    • Method Detail

      • getAuthContext

        ServerAuthContext getAuthContext(String authContextID,
                               Subject serviceSubject,
                               Map properties)
                                 throws AuthException
        Get a ServerAuthContext instance from this ServerAuthConfig.

        The implementation of this method returns a ServerAuthContext instance that encapsulates the ServerAuthModules used to validate requests and secure responses associated with the given authContextID.

        Specifically, this method accesses this ServerAuthConfig object with the argument authContextID to determine the ServerAuthModules that are to be encapsulated in the returned ServerAuthContext instance.

        The ServerAuthConfig object establishes the request and response MessagePolicy objects that are passed to the encapsulated modules when they are initialized by the returned ServerAuthContext instance. It is the modules' responsibility to enforce these policies when invoked.

        Parameters:
        authContextID - An identifier used to index the provided config, or null. This value must be identical to the value returned by the getAuthContextID method for all MessageInfo objects passed to the validateRequest method of the returned ServerAuthContext.
        serviceSubject - A Subject that represents the source of the service response to be secured by the acquired authentication context. The principal and credentials of the Subject may be used to select or acquire the authentication context. If the Subject is not null, additional Principals or credentials (pertaining to the source of the response) may be added to the Subject. A null value may be passed for this parameter.
        properties - A Map object that may be used by the caller to augment the properties that will be passed to the encapsulated modules at module initialization. The null value may be passed for this parameter.
        Returns:
        A ServerAuthContext instance that encapsulates the ServerAuthModules used to secure and validate requests/responses associated with the given authContextID, or null (indicating that no modules are configured).
        Throws:
        AuthException - If this method fails.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerAuthContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.config

Interface ServerAuthContext

  • All Superinterfaces:
    ServerAuth

    public interface ServerAuthContext
extends ServerAuth
    This ServerAuthContext class encapsulates ServerAuthModules that are used to validate service requests received from clients, and to secure any response returned for those requests. A caller typically uses this class in the following manner:
    1. Retrieve an instance of this class via ServerAuthConfig.getAuthContext.
    2. Invoke validateRequest.
      ServerAuthContext implementation invokes validateRequest of one or more encapsulated ServerAuthModules. Modules validate credentials present in request (for example, decrypt and verify a signature).
    3. If credentials valid and sufficient, authentication complete.
      Perform authorization check on authenticated identity and, if successful, dispatch to requested service application.
    4. Service application finished.
    5. Invoke secureResponse.
      ServerAuthContext implementation invokes secureResponse of one or more encapsulated ServerAuthModules. Modules secure response (sign and encrypt response, for example), and prepare response message.
    6. Send secured response to client.
    7. Invoke cleanSubject (as necessary) to clean up any authentication state in Subject(s).

    A ServerAuthContext instance may be used concurrently by multiple callers.

    Implementations of this interface are responsible for constructing and initializing the encapsulated modules. The initialization step includes passing the relevant request and response MessagePolicy objects to the encapsulated modules. The MessagePolicy objects are obtained by the ServerAuthConfig instance used to ontain the ServerAuthContext object. See ServerAuthConfig.getAuthContext for more information.

    Implementations of this interface are instantiated by their associated configuration object such that they know which modules to invoke, in what order, and how results returned by preceding modules are to influence subsequent module invocations.

    Calls to the inherited methods of this interface delegate to the corresponding methods of the encapsulated authentication modules.

    See Also:
    ServerAuthConfig, ServerAuthModule

    • Method Summary

      • Methods inherited from interface javax.security.auth.message.ServerAuth

        cleanSubject, secureResponse, validateRequest
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.security.auth.message.config (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.security.auth.message.config

  • Packages that use javax.security.auth.message.config
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.
  • Classes in javax.security.auth.message.config used by javax.security.auth.message.config
    Class and Description
    AuthConfig
    This interface defines the common functionality implemented by Authentication context configuration objects.
    AuthConfigFactory
    This class is used to obtain AuthConfigProvider objects that can be used to obtain authentication context configuration objects, that is, ClientAuthConfig and ServerAuthConfig objects.
    AuthConfigFactory.RegistrationContext
    Represents the layer identifier, application context identifier, and description components of an AuthConfigProvider registration at the factory.
    AuthConfigProvider
    This interface is implemented by objects that can be used to obtain authentication context configuration objects, that is, ClientAuthConfig or ServerAuthConfig objects.
    ClientAuthConfig
    This interface encapsulates the configuration of ClientAuthContext objects for a message layer and application context (for example, the messaging context of a specific application, or set of applications).
    ClientAuthContext
    This ClientAuthContext class encapsulates ClientAuthModules that are used to secure service requests made by a client, and to validate any responses received to those requests.
    RegistrationListener
    An implementation of this interface may be associated with an AuthConfigProvider registration at an AuthConfigFactory at the time the AuthConfigProvider is obtained for use from the factory.
    ServerAuthConfig
    This interface describes a configuration of ServerAuthConfiguration objects for a message layer and application context (for example, the messaging context of a specific application, or set of applications).
    ServerAuthContext
    This ServerAuthContext class encapsulates ServerAuthModules that are used to validate service requests received from clients, and to secure any response returned for those requests.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.auth.message.config.AuthConfigFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.auth.message.config.AuthConfigFactory

  • Packages that use AuthConfigFactory
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.

    • Uses of AuthConfigFactory in javax.security.auth.message.config

      Methods in javax.security.auth.message.config that return AuthConfigFactory
      Modifier and Type Method and Description
      static AuthConfigFactory AuthConfigFactory.getFactory()
      Get the system-wide AuthConfigFactory implementation.
      Methods in javax.security.auth.message.config with parameters of type AuthConfigFactory
      Modifier and Type Method and Description
      static void AuthConfigFactory.setFactory(AuthConfigFactory factory)
      Set the system-wide AuthConfigFactory implementation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.config.AuthConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.config.AuthConfig

  • Packages that use AuthConfig
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.

    • Uses of AuthConfig in javax.security.auth.message.config

      Subinterfaces of AuthConfig in javax.security.auth.message.config
      Modifier and Type Interface and Description
      interface  ClientAuthConfig
      This interface encapsulates the configuration of ClientAuthContext objects for a message layer and application context (for example, the messaging context of a specific application, or set of applications).
      interface  ServerAuthConfig
      This interface describes a configuration of ServerAuthConfiguration objects for a message layer and application context (for example, the messaging context of a specific application, or set of applications).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.config.AuthConfigFactory.RegistrationContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.config.AuthConfigFactory.RegistrationContext

  • Packages that use AuthConfigFactory.RegistrationContext
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.

    • Uses of AuthConfigFactory.RegistrationContext in javax.security.auth.message.config

      Methods in javax.security.auth.message.config that return AuthConfigFactory.RegistrationContext
      Modifier and Type Method and Description
      abstract AuthConfigFactory.RegistrationContext AuthConfigFactory.getRegistrationContext(String registrationID)
      Get the the registration context for the identified registration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.config.AuthConfigProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.config.AuthConfigProvider

  • Packages that use AuthConfigProvider
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.

    • Uses of AuthConfigProvider in javax.security.auth.message.config

      Methods in javax.security.auth.message.config that return AuthConfigProvider
      Modifier and Type Method and Description
      abstract AuthConfigProvider AuthConfigFactory.getConfigProvider(String layer, String appContext, RegistrationListener listener)
      Get a registered AuthConfigProvider from the factory.
      Methods in javax.security.auth.message.config with parameters of type AuthConfigProvider
      Modifier and Type Method and Description
      abstract String[] AuthConfigFactory.getRegistrationIDs(AuthConfigProvider provider)
      Get the registration identifiers for all registrations of the provider instance at the factory.
      abstract String AuthConfigFactory.registerConfigProvider(AuthConfigProvider provider, String layer, String appContext, String description)
      Registers within the (in-memory) factory, a provider of ServerAuthConfig and/or ClientAuthConfig objects for a message layer and application context identifier.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.config.ClientAuthConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.config.ClientAuthConfig

  • Packages that use ClientAuthConfig
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.

    • Uses of ClientAuthConfig in javax.security.auth.message.config

      Methods in javax.security.auth.message.config that return ClientAuthConfig
      Modifier and Type Method and Description
      ClientAuthConfig AuthConfigProvider.getClientAuthConfig(String layer, String appContext, CallbackHandler handler)
      Get an instance of ClientAuthConfig from this provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.config.ClientAuthContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.config.ClientAuthContext

  • Packages that use ClientAuthContext
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.

    • Uses of ClientAuthContext in javax.security.auth.message.config

      Methods in javax.security.auth.message.config that return ClientAuthContext
      Modifier and Type Method and Description
      ClientAuthContext ClientAuthConfig.getAuthContext(String authContextID, Subject clientSubject, Map properties)
      Get a ClientAuthContext instance from this ClientAuthConfig.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.config.RegistrationListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.config.RegistrationListener

  • Packages that use RegistrationListener
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.

    • Uses of RegistrationListener in javax.security.auth.message.config

      Methods in javax.security.auth.message.config with parameters of type RegistrationListener
      Modifier and Type Method and Description
      abstract String[] AuthConfigFactory.detachListener(RegistrationListener listener, String layer, String appContext)
      Disassociate the listener from all the provider registrations whose layer and appContext values are matched by the corresponding arguments to this method.
      abstract AuthConfigProvider AuthConfigFactory.getConfigProvider(String layer, String appContext, RegistrationListener listener)
      Get a registered AuthConfigProvider from the factory.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.config.ServerAuthConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.config.ServerAuthConfig

  • Packages that use ServerAuthConfig
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.

    • Uses of ServerAuthConfig in javax.security.auth.message.config

      Methods in javax.security.auth.message.config that return ServerAuthConfig
      Modifier and Type Method and Description
      ServerAuthConfig AuthConfigProvider.getServerAuthConfig(String layer, String appContext, CallbackHandler handler)
      Get an instance of ServerAuthConfig from this provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.config.ServerAuthContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.config.ServerAuthContext

  • Packages that use ServerAuthContext
    Package Description
    javax.security.auth.message.config
    This package defines the interfaces implemented by JSR 196 compatible configuration systems.

    • Uses of ServerAuthContext in javax.security.auth.message.config

      Methods in javax.security.auth.message.config that return ServerAuthContext
      Modifier and Type Method and Description
      ServerAuthContext ServerAuthConfig.getAuthContext(String authContextID, Subject serviceSubject, Map properties)
      Get a ServerAuthContext instance from this ServerAuthConfig.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ClientAuthModule (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.module

Interface ClientAuthModule

  • All Superinterfaces:
    ClientAuth

    public interface ClientAuthModule
extends ClientAuth
    A ClientAuthModule secures request messages, and validates received response messages.

    A module implementation should assume it may be used to secure different requests as different clients. A module should also assume it may be used concurrently by multiple callers. It is the module implementation's responsibility to properly save and restore any state as necessary. A module that does not need to do so may remain completely stateless.

    Every implementation of the interface must provide a public zero argument constructor.

    See Also:
    ClientAuthContext

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class[] getSupportedMessageTypes()
      Get the one or more Class objects representing the message types supported by the module.
      void initialize(MessagePolicy requestPolicy, MessagePolicy responsePolicy, CallbackHandler handler, Map options)
      Initialize this module with request and response message policies to enforce, a CallbackHandler, and any module-specific configuration properties.

      • Methods inherited from interface javax.security.auth.message.ClientAuth

        cleanSubject, secureRequest, validateResponse

    • Method Detail

      • initialize

        void initialize(MessagePolicy requestPolicy,
              MessagePolicy responsePolicy,
              CallbackHandler handler,
              Map options)
                throws AuthException
        Initialize this module with request and response message policies to enforce, a CallbackHandler, and any module-specific configuration properties.

        The request policy and the response policy must not both be null.

        Parameters:
        requestPolicy - The request policy this module must enforce, or null.
        responsePolicy - The response policy this module must enforce, or null.
        handler - CallbackHandler used to request information.
        options - A Map of module-specific configuration properties.
        Throws:
        AuthException - If module initialization fails, including for the case where the options argument contains elements that are not supported by the module.

      • getSupportedMessageTypes

        Class[] getSupportedMessageTypes()
        Get the one or more Class objects representing the message types supported by the module.
        Returns:
        An array of Class objects where each element defines a message type supported by the module. A module should return an array containing at least one element. An empty array indicates that the module will attempt to support any message type. This method never returns null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.security.auth.message.module (Java(TM) EE 7 Specification APIs)

javax.security.auth.message.module

Interfaces

  • ClientAuthModule
  • ServerAuthModule


javax.security.auth.message.module (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.security.auth.message.module

This package defines the interfaces implemented by JSR 196 compatible authentication modules.

See: Description

  • Interface Summary
    Interface Description
    ClientAuthModule
    A ClientAuthModule secures request messages, and validates received response messages.
    ServerAuthModule
    A ServerAuthModule validates client requests and secures responses to the client.

Package javax.security.auth.message.module Description

This package defines the interfaces implemented by JSR 196 compatible authentication modules.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.security.auth.message.module Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.security.auth.message.module

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.security.auth.message.ClientAuth
    • javax.security.auth.message.module.ClientAuthModule
  • javax.security.auth.message.ServerAuth
    • javax.security.auth.message.module.ServerAuthModule
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ServerAuthModule (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.auth.message.module

Interface ServerAuthModule

  • All Superinterfaces:
    ServerAuth

    public interface ServerAuthModule
extends ServerAuth
    A ServerAuthModule validates client requests and secures responses to the client.

    A module implementation should assume it may be used to secure different requests as different clients. A module should also assume it may be used concurrently by multiple callers. It is the module implementation's responsibility to properly save and restore any state as necessary. A module that does not need to do so may remain completely stateless.

    Every implementation of the interface must provide a public zero argument constructor.

    See Also:
    ServerAuthContext

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class[] getSupportedMessageTypes()
      Get the one or more Class objects representing the message types supported by the module.
      void initialize(MessagePolicy requestPolicy, MessagePolicy responsePolicy, CallbackHandler handler, Map options)
      Initialize this module with request and response message policies to enforce, a CallbackHandler, and any module-specific configuration properties.

      • Methods inherited from interface javax.security.auth.message.ServerAuth

        cleanSubject, secureResponse, validateRequest

    • Method Detail

      • initialize

        void initialize(MessagePolicy requestPolicy,
              MessagePolicy responsePolicy,
              CallbackHandler handler,
              Map options)
                throws AuthException
        Initialize this module with request and response message policies to enforce, a CallbackHandler, and any module-specific configuration properties.

        The request policy and the response policy must not both be null.

        Parameters:
        requestPolicy - The request policy this module must enforce, or null.
        responsePolicy - The response policy this module must enforce, or null.
        handler - CallbackHandler used to request information.
        options - A Map of module-specific configuration properties.
        Throws:
        AuthException - If module initialization fails, including for the case where the options argument contains elements that are not supported by the module.

      • getSupportedMessageTypes

        Class[] getSupportedMessageTypes()
        Get the one or more Class objects representing the message types supported by the module.
        Returns:
        An array of Class objects, with at least one element defining a message type supported by the module.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.security.auth.message.module (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.security.auth.message.module

No usage of javax.security.auth.message.module
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.module.ClientAuthModule (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.module.ClientAuthModule

No usage of javax.security.auth.message.module.ClientAuthModule
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.auth.message.module.ServerAuthModule (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.auth.message.module.ServerAuthModule

No usage of javax.security.auth.message.module.ServerAuthModule
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


EJBMethodPermission (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.jacc

Class EJBMethodPermission

  • java.lang.Object
    • java.security.Permission
      • javax.security.jacc.EJBMethodPermission
  • All Implemented Interfaces:
    Serializable, Guard

    public final class EJBMethodPermission
extends Permission
    Class for EJB method permissions.

    The name of an EJBMethodPermission contains the value of the ejb-name element in the application's deployment descriptor that identifies the target EJB.

    The actions of an EJBMethodPermission identifies the methods of the EJB to which the permission applies.

    Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

    Author:
    Ron Monzillo, Gary Ellison
    See Also:
    Permission, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EJBMethodPermission(String name, String actions)
      Creates a new EJBMethodPermission with the specified name and actions.
      EJBMethodPermission(String EJBName, String methodInterface, Method method)
      Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodInterface, and the Method object.
      EJBMethodPermission(String EJBName, String methodName, String methodInterface, String[] methodParams)
      Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodName, methodInterface, and methodParams.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object o)
      Checks two EJBMethodPermission objects for equality.
      String getActions()
      Returns a String containing a canonical representation of the actions of this EJBMethodPermission.
      int hashCode()
      Returns the hash code value for this EJBMethodPermission.
      boolean implies(Permission permission)
      Determines if the argument Permission is "implied by" this EJBMethodPermission.

      • Methods inherited from class java.security.Permission

        checkGuard, getName, newPermissionCollection, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EJBMethodPermission

        public EJBMethodPermission(String name,
                   String actions)
        Creates a new EJBMethodPermission with the specified name and actions.

        The name contains the value of the ejb-name element corresponding to an EJB in the application's deployment descriptor.

        The actions contains a methodSpec. The syntax of the actions parameter is defined as follows:

              methodNameSpec ::= methodName | emptyString

      methodInterfaceName ::= String

      methodInterfaceSpec ::= methodInterfaceName | emptyString

      typeName ::= typeName | typeName []

      methodParams ::= typeName | methodParams comma typeName

      methodParamsSpec ::= emptyString | methodParams

      methodSpec ::= null |
           methodNameSpec |
           methodNameSpec comma methodInterfaceName |
           methodNameSpec comma methodInterfaceSpec comma methodParamsSpec

        A MethodInterfaceName is a non-empty String and should contain a method-intf value as defined for use in EJB deployment descriptors. An implementation must be flexible such that it supports additional interface names especially if they are standardized by the EJB Specification. The EJB Specification currently defines the following method-intf values:

               { "Home", "LocalHome", "Remote", "Local", "ServiceEndpoint" }

        A null or empty string methodSpec indicates that the permission applies to all methods of the EJB. A methodSpec with a methodNameSpec of the empty string matches all methods of the EJB that match the methodInterface and methodParams elements of the methodSpec.

        A methodSpec with a methodInterfaceSpec of the empty string matches all methods of the EJB that match the methodNameSpec and methodParamsSpec elements of the methodSpec.

        A methodSpec without a methodParamsSpec matches all methods of the EJB that match the methodNameSpec and methodInterface elements of the methodSpec.

        The order of the typeNames in methodParams array must match the order of occurence of the corresponding parameters in the method signature of the target method(s). Each typeName in the methodParams must contain the canonical form of the corresponding parameter's typeName as defined by the getActions method. A methodSpec with an empty methodParamsSpec matches all 0 argument methods of the EJB that match the methodNameSpec and methodInterfaceSpec elements of the methodSpec.

        Parameters:
        name - of the EJB to which the permission pertains.

        actions - identifies the methods of the EJB to which the permission pertains.

      • EJBMethodPermission

        public EJBMethodPermission(String EJBName,
                   String methodName,
                   String methodInterface,
                   String[] methodParams)
        Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodName, methodInterface, and methodParams.

        Parameters:
        EJBName - The string representation of the name of the EJB as it appears in the corresponding ejb-name element in the deployment descriptor.

        methodName - A string that may be used to indicate the method of the EJB to which the permission pertains. A value of null or "" indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of method name.

        methodInterface - A string that may be used to specify the EJB interface to which the permission pertains. A value of null or "", indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of the interface they occur on.

        methodParams - An array of strings that may be used to specify (by typeNames) the parameter signature of the target methods. The order of the typeNames in methodParams array must match the order of occurence of the corresponding parameters in the method signature of the target method(s). Each typeName in the methodParams array must contain the canonical form of the corresponding parameter's typeName as defined by the getActions method. An empty methodParams array is used to represent a method signature with no arguments. A value of null indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of method signature.

      • EJBMethodPermission

        public EJBMethodPermission(String EJBName,
                   String methodInterface,
                   Method method)
        Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodInterface, and the Method object.

        A container uses this constructor prior to checking if a caller has permission to call the method of an EJB.

        Parameters:
        EJBName - The string representation of the name of the EJB as it appears in the corresponding ejb-name element in the deployment descriptor.

        methodInterface - A string that may be used to specify the EJB interface to which the permission pertains. A value of null or "", indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of the interface they occur on.

        method - an instance of the Java.lang.reflect.Method class corresponding to the method that the container is trying to determine whether the caller has permission to access. This value must not be null.

    • Method Detail

      • equals

        public boolean equals(Object o)
        Checks two EJBMethodPermission objects for equality. EJBMethodPermission objects are equivalent if they have case sensitive equivalent name and actions values.

        Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

        Specified by:
        equals in class Permission
        Parameters:
        o - the EJBMethodPermission object being tested for equality with this EJBMethodPermission

        Returns:
        true if the argument EJBMethodPermission object is equivalent to this EJBMethodPermission.

      • getActions

        public String getActions()
        Returns a String containing a canonical representation of the actions of this EJBMethodPermission. The Canonical form of the actions of an EJBMethodPermission is described by the following syntax description.

              methodNameSpec ::= methodName | emptyString

      methodInterfaceName ::= String

      methodInterfaceSpec ::= methodInterfaceName | emptyString

      typeName ::= typeName | typeName []

      methodParams ::= typeName | methodParams comma typeName

      methodParamsSpec ::= emptyString | methodParams

      methodSpec ::= null |
           methodName |
           methodNameSpec comma methodInterfaceName |
           methodNameSpec comma methodInterfaceSpec comma methodParamsSpec

        The canonical form of each typeName must begin with the fully qualified Java name of the corresponding parameter's type. The canonical form of a typeName for an array parameter is the fully qualified Java name of the array's component type followed by as many instances of the string "[]" as there are dimensions to the array. No additional characters (e.g. blanks) may occur in the canonical form.

        A MethodInterfaceName is a non-empty String and should contain a method-intf value as defined for use in EJB deployment descriptors. An implementation must be flexible such that it supports additional interface names especially if they are standardized by the EJB Specification. The EJB Specification currently defines the following method-intf values:

               { "Home", "LocalHome", "Remote", "Local", "ServiceEndpoint" }

        Specified by:
        getActions in class Permission
        Returns:
        a String containing the canonicalized actions of this EJBMethodPermission.

      • hashCode

        public int hashCode()
        Returns the hash code value for this EJBMethodPermission. The properties of the returned hash code must be as follows:

        • During the lifetime of a Java application, the hashCode method must return the same integer value every time it is called on a EJBMethodPermission object. The value returned by hashCode for a particular EJBMethodPermission need not remain consistent from one execution of an application to another.
        • If two EJBMethodPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

        Specified by:
        hashCode in class Permission
        Returns:
        the integer hash code value for this object.

      • implies

        public boolean implies(Permission permission)
        Determines if the argument Permission is "implied by" this EJBMethodPermission. For this to be the case,

        • The argument must be an instanceof EJBMethodPermission
        • with name equivalent to that of this EJBMethodPermission, and
        • the methods to which the argument permission applies (as defined in its actions) must be a subset of the methods to which this EJBMethodPermission applies (as defined in its actions).

        The argument permission applies to a subset of the methods to which this permission applies if all of the following conditions are met.

        • the method name component of the methodNameSpec of this permission is null, the empty string, or equivalent to the method name of the argument permission, and
        • the method interface component of the methodNameSpec of this permission is null, the empty string, or equivalent to the method interface of the argument permission, and
        • the method parameter list component of the methodNameSpec of this permission is null, the empty string, or equivalent to the method parameter list of the argument permission.

        The name and actions comparisons described above are case sensitive.

        Specified by:
        implies in class Permission
        Parameters:
        permission - "this" EJBMethodPermission is checked to see if it implies the argument permission.

        Returns:
        true if the specified permission is implied by this object, false if not.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EJBRoleRefPermission (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.jacc

Class EJBRoleRefPermission

  • java.lang.Object
    • java.security.Permission
      • javax.security.jacc.EJBRoleRefPermission
  • All Implemented Interfaces:
    Serializable, Guard

    public final class EJBRoleRefPermission
extends Permission
    Class for EJB isCallerInRole (String reference) permissions. An EJBRoleRefPermission is a named permission and has actions.

    The name of an EJBRoleRefPermission contains the value of the ejb-name element in the application's deployment descriptor that identifies the EJB in whose context the permission is being evalutated.

    the actions of an EJBRoleRefPermission identifies the role reference to which the permission applies. An EJBRoleRefPermission is checked to determine if the subject is a member of the role identified by the reference.

    Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

    Author:
    Ron Monzillo, Gary Ellison
    See Also:
    Permission, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EJBRoleRefPermission(String name, String actions)
      Creates a new EJBRoleRefPermission with the specified name and actions.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object o)
      Checks two EJBRoleRefPermission objects for equality.
      String getActions()
      Returns a canonical String representation of the actions of this EJBRoleRefPermission.
      int hashCode()
      Returns the hash code value for this EJBRoleRefPermission.
      boolean implies(Permission permission)
      Determines if the argument Permission is "implied by" this EJBRoleRefPermission.

      • Methods inherited from class java.security.Permission

        checkGuard, getName, newPermissionCollection, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EJBRoleRefPermission

        public EJBRoleRefPermission(String name,
                    String actions)
        Creates a new EJBRoleRefPermission with the specified name and actions.
        Parameters:
        name - the ejb-name that identifies the EJB in whose context the role references are to be evaluated.

        actions - identifies the role reference to which the permission pertains. The role reference is scoped to the EJB identified in the name parameter. The value of the role reference must not be null or the empty string.

    • Method Detail

      • equals

        public boolean equals(Object o)
        Checks two EJBRoleRefPermission objects for equality. EJBRoleRefPermission objects are equivalent if they have case equivalent name and actions values.

        Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

        Specified by:
        equals in class Permission
        Parameters:
        o - the EJBRoleRefPermission object being tested for equality with this EJBRoleRefPermission.

        Returns:
        true if the argument EJBRoleRefPermission object is equivalent to this EJBRoleRefPermission.

      • getActions

        public String getActions()
        Returns a canonical String representation of the actions of this EJBRoleRefPermission.

        Specified by:
        getActions in class Permission
        Returns:
        a String containing the canonicalized actions of this EJBRoleRefPermission.

      • hashCode

        public int hashCode()
        Returns the hash code value for this EJBRoleRefPermission. The properties of the returned hash code must be as follows:

        • During the lifetime of a Java application, the hashCode method must return the same integer value, every time it is called on a EJBRoleRefPermission object. The value returned by hashCode for a particular EJBRoleRefPermission need not remain consistent from one execution of an application to another.
        • If two EJBRoleRefPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

        Specified by:
        hashCode in class Permission
        Returns:
        the integer hash code value for this object.

      • implies

        public boolean implies(Permission permission)
        Determines if the argument Permission is "implied by" this EJBRoleRefPermission. For this to be the case,

    • The argument must be an instanceof EJBRoleRefPermission
    • with name equivalent to that of this EJBRoleRefPermission, and
    • with the role reference equivalent to that of this EJBRoleRefPermission applies.

      The name and actions comparisons described above are case sensitive.

Specified by:
implies in class Permission
Parameters:
permission - "this" EJBRoleRefPermission is checked to see if it implies the argument permission.

Returns:
true if the specified permission is implied by this object, false if not.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.security.jacc (Java(TM) EE 7 Specification APIs)

javax.security.jacc

Interfaces

  • PolicyConfiguration
  • PolicyContextHandler

Classes

  • EJBMethodPermission
  • EJBRoleRefPermission
  • PolicyConfigurationFactory
  • PolicyContext
  • WebResourcePermission
  • WebRoleRefPermission
  • WebUserDataPermission

Exceptions

  • PolicyContextException


javax.security.jacc (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.security.jacc

This package contains the Java Authorization Contract for Containers API

See: Description

  • Interface Summary
    Interface Description
    PolicyConfiguration
    The methods of this interface are used by containers to create policy statements in a Policy provider.
    PolicyContextHandler
    This interface defines the methods that must be implemented by handlers that are to be registered and activated by the PolicyContext class.
  • Class Summary
    Class Description
    EJBMethodPermission
    Class for EJB method permissions.
    EJBRoleRefPermission
    Class for EJB isCallerInRole (String reference) permissions.
    PolicyConfigurationFactory
    Abstract factory and finder class for obtaining the instance of the class that implements the PolicyConfigurationFactory of a provider.
    PolicyContext
    This utility class is used by containers to communicate policy context identifiers and other policy relevant context to Policy providers.
    WebResourcePermission
    Class for Servlet web resource permissions.
    WebRoleRefPermission
    Class for Servlet isUserInRole (String reference) permissions.
    WebUserDataPermission
    Class for Servlet Web user data permissions.
  • Exception Summary
    Exception Description
    PolicyContextException
    This checked exception is thrown by implementations of the javax.security.jacc.PolicyConfiguration Interface, the javax.security.jacc.PolicyConfigurationFactory abstract class, the javax.security.jacc.PolicyContext utility class, and implementations of the javax.security.jacc.PolicyContextException Interface.

Package javax.security.jacc Description

This package contains the Java Authorization Contract for Containers API
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.security.jacc Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.security.jacc

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • javax.security.jacc.EJBMethodPermission
      • javax.security.jacc.EJBRoleRefPermission
      • javax.security.jacc.WebResourcePermission
      • javax.security.jacc.WebRoleRefPermission (implements java.io.Serializable)
      • javax.security.jacc.WebUserDataPermission
    • javax.security.jacc.PolicyConfigurationFactory
    • javax.security.jacc.PolicyContext
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.security.jacc.PolicyContextException

Interface Hierarchy

  • javax.security.jacc.PolicyConfiguration
  • javax.security.jacc.PolicyContextHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


PolicyConfiguration (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.jacc

Interface PolicyConfiguration

  • public interface PolicyConfiguration
    The methods of this interface are used by containers to create policy statements in a Policy provider. An object that implements the PolicyConfiguration interface provides the policy statement configuration interface for a corresponding policy context within the corresponding Policy provider.

    The life cycle of a policy context is defined by three states; "open", "inService", and "deleted". A policy context is in one of these three states.

    A policy context in the "open" state is in the process of being configured, and may be operated on by any of the methods of the PolicyConfiguration interface. A policy context in the "open" state must not be assimilated at Policy.refresh into the policy statements used by the Policy provider in performing its access decisions. In order for the policy statements of a policy context to be assimilated by the associated provider, the policy context must be in the "inService" state. A policy context in the "open" state is transitioned to the "inService" state by calling the commit method.

    A policy context in the "inService" state is available for assimilation into the policy statements being used to perform access decisions by the associated Policy provider. Providers assimilate policy contexts containing policy statements when the refresh method of the provider is called. When a provider's refresh method is called, it must assimilate only those policy contexts whose state is "inService" and it must ensure that the policy statements put into service for each policy context are only those defined in the context at the time of the call to refresh. A policy context in the "inService" state is not available for additional configuration and may be returned to the "open" state by calling the getPolicyConfiguration method of the PolicyConfigurationFactory.

    A policy context in the "deleted" state is neither available for configuration, nor is it available for assimilation into the Provider. A policy context whose state is "deleted" may be reclaimed for subsequent processing by calling the getPolicyConfiguration method of the associated PolicyConfigurationFactory. A "deleted" policy context is transitioned to the "open" state when it it returned as a result of a call to getPolicyConfiguration.

    The following table captures the correspondence between the policy context life cycle and the methods of the PolicyConfiguration interface. The rightmost 3 columns of the table correspond to the PolicyConfiguration state identified at the head of the column. The values in the cells of these columns indicate the next state resulting from a call to the method identifed in the leftmost column of the corresponding row, or that calling the method is unsupported in the state represented by the column (in which case the state will remain unchanged).

    PolicyConfiguration State Table
    Method | Current State to Next State
    deleted | open | inService
    addToExcludedPolicy | Unsupported Operation | open | Unsupported Operation
    addToRole | Unsupported Operation | open | Unsupported Operation
    addToUncheckedPolicy | Unsupported Operation | open | Unsupported Operation
    commit | Unsupported Operation | inService | inService
    delete | deleted | deleted | deleted
    getContextID | deleted | open | inService
    inService | deleted | open | inService
    linkConfiguration | Unsupported Operation | open | Unsupported Operation
    removeExcludedPolicy | Unsupported Operation | open | Unsupported Operation
    removeRole | Unsupported Operation | open | Unsupported Operation
    removeUncheckedPolicy | Unsupported Operation | open | Unsupported Operation

    For a provider implementation to be compatible with multi-threaded environments, it may be necessary to synchronize the refresh method of the provider with the methods of its PolicyConfiguration interface and with the getPolicyConfiguration and inService methods of its PolicyConfigurationFactory.

    Author:
    Ron Monzillo, Gary Ellison
    See Also:
    Permission, PermissionCollection, PolicyContextException, PolicyConfigurationFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addToExcludedPolicy(Permission permission)
      Used to add a single excluded policy statement to this PolicyConfiguration.
      void addToExcludedPolicy(PermissionCollection permissions)
      Used to add excluded policy statements to this PolicyConfiguration.
      void addToRole(String roleName, Permission permission)
      Used to add a single permission to a named role in this PolicyConfiguration.
      void addToRole(String roleName, PermissionCollection permissions)
      Used to add permissions to a named role in this PolicyConfiguration.
      void addToUncheckedPolicy(Permission permission)
      Used to add a single unchecked policy statement to this PolicyConfiguration.
      void addToUncheckedPolicy(PermissionCollection permissions)
      Used to add unchecked policy statements to this PolicyConfiguration.
      void commit()
      This method is used to set to "inService" the state of the policy context whose interface is this PolicyConfiguration Object.
      void delete()
      Causes all policy statements to be deleted from this PolicyConfiguration and sets its internal state such that calling any method, other than delete, getContextID, or inService on the PolicyConfiguration will be rejected and cause an UnsupportedOperationException to be thrown.
      String getContextID()
      This method returns this object's policy context identifier.
      boolean inService()
      This method is used to determine if the policy context whose interface is this PolicyConfiguration Object is in the "inService" state.
      void linkConfiguration(PolicyConfiguration link)
      Creates a relationship between this configuration and another such that they share the same principal-to-role mappings.
      void removeExcludedPolicy()
      Used to remove any excluded policy statements from this PolicyConfiguration.
      void removeRole(String roleName)
      Used to remove a role and all its permissions from this PolicyConfiguration.
      void removeUncheckedPolicy()
      Used to remove any unchecked policy statements from this PolicyConfiguration.

    • Method Detail

      • getContextID

        String getContextID()
                    throws PolicyContextException
        This method returns this object's policy context identifier.
        Returns:
        this object's policy context identifier.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the getContextID method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • addToRole

        void addToRole(String roleName,
             PermissionCollection permissions)
               throws PolicyContextException
        Used to add permissions to a named role in this PolicyConfiguration. If the named role does not exist in the PolicyConfiguration, it is created as a result of the call to this function.

        It is the job of the Policy provider to ensure that all the permissions added to a role are granted to principals "mapped to the role".

        Parameters:
        roleName - the name of the Role to which the permissions are to be added.

        permissions - the collection of permissions to be added to the role. The collection may be either a homogenous or heterogenous collection.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToRole method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • addToRole

        void addToRole(String roleName,
             Permission permission)
               throws PolicyContextException
        Used to add a single permission to a named role in this PolicyConfiguration. If the named role does not exist in the PolicyConfiguration, it is created as a result of the call to this function.

        It is the job of the Policy provider to ensure that all the permissions added to a role are granted to principals "mapped to the role".

        Parameters:
        roleName - the name of the Role to which the permission is to be added.

        permission - the permission to be added to the role.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToRole method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • addToUncheckedPolicy

        void addToUncheckedPolicy(PermissionCollection permissions)
                          throws PolicyContextException
        Used to add unchecked policy statements to this PolicyConfiguration.

        Parameters:
        permissions - the collection of permissions to be added as unchecked policy statements. The collection may be either a homogenous or heterogenous collection.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToUncheckedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • addToUncheckedPolicy

        void addToUncheckedPolicy(Permission permission)
                          throws PolicyContextException
        Used to add a single unchecked policy statement to this PolicyConfiguration.

        Parameters:
        permission - the permission to be added to the unchecked policy statements.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToUncheckedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • addToExcludedPolicy

        void addToExcludedPolicy(PermissionCollection permissions)
                         throws PolicyContextException
        Used to add excluded policy statements to this PolicyConfiguration.

        Parameters:
        permissions - the collection of permissions to be added to the excluded policy statements. The collection may be either a homogenous or heterogenous collection.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToExcludedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • addToExcludedPolicy

        void addToExcludedPolicy(Permission permission)
                         throws PolicyContextException
        Used to add a single excluded policy statement to this PolicyConfiguration.

        Parameters:
        permission - the permission to be added to the excluded policy statements.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToExcludedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • removeRole

        void removeRole(String roleName)
                throws PolicyContextException
        Used to remove a role and all its permissions from this PolicyConfiguration. This method has no effect on the links between this PolicyConfiguration and others.

        Parameters:
        roleName - the name of the role to remove from this PolicyConfiguration. If the value of the roleName parameter is "*" and no role with name "*" exists in this PolicyConfiguration, then all roles must be removed from this PolicyConfiguration.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the removeRole method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • removeUncheckedPolicy

        void removeUncheckedPolicy()
                           throws PolicyContextException
        Used to remove any unchecked policy statements from this PolicyConfiguration. This method has no effect on the links between this PolicyConfiguration and others.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the removeUncheckedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • removeExcludedPolicy

        void removeExcludedPolicy()
                          throws PolicyContextException
        Used to remove any excluded policy statements from this PolicyConfiguration. This method has no effect on the links between this PolicyConfiguration and others.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the removeExcludedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • linkConfiguration

        void linkConfiguration(PolicyConfiguration link)
                       throws PolicyContextException
        Creates a relationship between this configuration and another such that they share the same principal-to-role mappings. PolicyConfigurations are linked to apply a common principal-to-role mapping to multiple seperately manageable PolicyConfigurations, as is required when an application is composed of multiple modules.

        Note that the policy statements which comprise a role, or comprise the excluded or unchecked policy collections in a PolicyConfiguration are unaffected by the configuration being linked to another.

        Parameters:
        link - a reference to a different PolicyConfiguration than this PolicyConfiguration.

        The relationship formed by this method is symetric, transitive and idempotent. If the argument PolicyConfiguration does not have a different Policy context identifier than this PolicyConfiguration no relationship is formed, and an exception, as described below, is thrown.

        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
        IllegalArgumentException - if called with an argument PolicyConfiguration whose Policy context is equivalent to that of this PolicyConfiguration.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the linkConfiguration method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • delete

        void delete()
            throws PolicyContextException
        Causes all policy statements to be deleted from this PolicyConfiguration and sets its internal state such that calling any method, other than delete, getContextID, or inService on the PolicyConfiguration will be rejected and cause an UnsupportedOperationException to be thrown.

        This operation has no affect on any linked PolicyConfigurations other than removing any links involving the deleted PolicyConfiguration.

        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the delete method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • commit

        void commit()
            throws PolicyContextException
        This method is used to set to "inService" the state of the policy context whose interface is this PolicyConfiguration Object. Only those policy contexts whose state is "inService" will be included in the policy contexts processed by the Policy.refresh method. A policy context whose state is "inService" may be returned to the "open" state by calling the getPolicyConfiguration method of the PolicyConfiguration factory with the policy context identifier of the policy context.

        When the state of a policy context is "inService", calling any method other than commit, delete, getContextID, or inService on its PolicyConfiguration Object will cause an UnsupportedOperationException to be thrown.

        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" when this method is called.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the commit method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • inService

        boolean inService()
                  throws PolicyContextException
        This method is used to determine if the policy context whose interface is this PolicyConfiguration Object is in the "inService" state.
        Returns:
        true if the state of the associated policy context is "inService"; false otherwise.
        Throws:
        SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the inService method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PolicyConfigurationFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.jacc

Class PolicyConfigurationFactory

  • java.lang.Object
    • javax.security.jacc.PolicyConfigurationFactory

  • public abstract class PolicyConfigurationFactory
extends Object
    Abstract factory and finder class for obtaining the instance of the class that implements the PolicyConfigurationFactory of a provider. The factory will be used to instantiate PolicyConfiguration objects that will be used by the deployment tools of the container to create and manage policy contexts within the Policy Provider.

    Implementation classes must have a public no argument constructor that may be used to create an operational instance of the factory implementation class.

    Author:
    Ron Monzillo, Gary Ellison, Harpreet Singh
    See Also:
    Permission, PolicyConfiguration, PolicyContextException

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyConfigurationFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract PolicyConfiguration getPolicyConfiguration(String contextID, boolean remove)
      This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider.
      static PolicyConfigurationFactory getPolicyConfigurationFactory()
      This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class.
      abstract boolean inService(String contextID)
      This method determines if the identified policy context exists with state "inService" in the Policy provider associated with the factory.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PolicyConfigurationFactory

        public PolicyConfigurationFactory()

    • Method Detail

      • getPolicyConfigurationFactory

        public static PolicyConfigurationFactory getPolicyConfigurationFactory()
                                                                throws ClassNotFoundException,
                                                                       PolicyContextException
        This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class. The name of the provider specific factory implementation class is obtained from the value of the system property,

             javax.security.jacc.PolicyConfigurationFactory.provider.

        Returns:
        the singleton instance of the provider specific PolicyConfigurationFactory implementation class.
        Throws:
        SecurityException - when called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        ClassNotFoundException - when the class named by the system property could not be found including because the value of the system property has not be set.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the getPolicyConfigurationFactory method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException

      • getPolicyConfiguration

        public abstract PolicyConfiguration getPolicyConfiguration(String contextID,
                                         boolean remove)
                                                    throws PolicyContextException
        This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider. The methods of the PolicyConfiguration interface are used to define the policy statements of the identified policy context.

        If at the time of the call, the identified policy context does not exist in the provider, then the policy context will be created in the provider and the Object that implements the context's PolicyConfiguration Interface will be returned. If the state of the identified context is "deleted" or "inService" it will be transitioned to the "open" state as a result of the call. The states in the lifecycle of a policy context are defined by the PolicyConfiguration interface.

        For a given value of policy context identifier, this method must always return the same instance of PolicyConfiguration and there must be at most one actual instance of a PolicyConfiguration with a given policy context identifier (during a process context).

        To preserve the invariant that there be at most one PolicyConfiguration object for a given policy context, it may be necessary for this method to be thread safe.

        Parameters:
        contextID - A String identifying the policy context whose PolicyConfiguration interface is to be returned. The value passed to this parameter must not be null.

        remove - A boolean value that establishes whether or not the policy statements and linkages of an existing policy context are to be removed before its PolicyConfiguration object is returned. If the value passed to this parameter is true, the policy statements and linkages of an existing policy context will be removed. If the value is false, they will not be removed.
        Returns:
        an Object that implements the PolicyConfiguration Interface matched to the Policy provider and corresponding to the identified policy context.
        Throws:
        SecurityException - when called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the getPolicyConfiguration method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

      • inService

        public abstract boolean inService(String contextID)
                           throws PolicyContextException
        This method determines if the identified policy context exists with state "inService" in the Policy provider associated with the factory.

        Parameters:
        contextID - A string identifying a policy context
        Returns:
        true if the identified policy context exists within the provider and its state is "inService", false otherwise.
        Throws:
        SecurityException - when called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the inService method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PolicyContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.jacc

Class PolicyContext

  • java.lang.Object
    • javax.security.jacc.PolicyContext

  • public final class PolicyContext
extends Object
    This utility class is used by containers to communicate policy context identifiers and other policy relevant context to Policy providers. Policy providers use the policy context identifier to select the subset of policy to apply in access decisions.

    The value of a policy context identifier is a String and each thread has an independently established policy context identifier. A container will establish the thread-scoped value of a policy context identifier by calling the static setContextID method. The value of a thread-scoped policy context identifier is available (to Policy) by calling the static getContextID method.

    This class is also used by Policy providers to request additional thread-scoped policy relevant context objects from the calling container. Containers register container-specific PolicyContext handlers using the static registerHandler method. Handler registration is scoped to the class, such that the same handler registrations are active in all thread contexts. Containers may use the static method setHandlerData to establish a thread-scoped parameter that will be passed to handlers when they are activated by Policy providers. The static getContext method is used to activate a handler and obtain the corresponding context object.

    The static accessor functions provided by this class allow per-thread policy context values to be established and communicated independent of a common reference to a particular PolicyContext instance.

    The PolicyContext class may encapsulate static ThreadLocal instance variables to represent the policy context identifier and handler data values.

    The Application server must bundle or install the PolicyContext class, and the containers of the application server must prevent the methods of the PolicyContext class from being called from calling contexts that are not authorized to call these methods. With the exception of the getContextID and GetHandlerKeys methods, containers must restrict and afford access to the methods of the PolicyContext class to calling contexts trusted by the container to perform container access decisions. The PolicyContext class may satisfy this requirement (on behalf of its container) by rejecting calls made from an AccessControlContext that has not been granted the "setPolicy" SecurityPermission, and by ensuring that Policy providers used to perform container access decisions are granted the "setPolicy" permission.

    Author:
    Ron Monzillo, Gary Ellison
    See Also:
    PolicyContextHandler

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Object getContext(String key)
      This method may be used by a Policy provider to activate the PolicyContextHandler registered to the context object key and cause it to return the corresponding policy context object from the container.
      static String getContextID()
      This static method returns the value of the policy context identifier associated with the thread on which the accessor is called.
      static Set getHandlerKeys()
      This method may be used to obtain the keys that identify the container specific context handlers registered by the container.
      static void registerHandler(String key, PolicyContextHandler handler, boolean replace)
      Authorization protected method used to register a container specific PolicyContext handler.
      static void setContextID(String contextID)
      Authorization protected method used to modify the value of the policy context identifier associated with the thread on which this method is called.
      static void setHandlerData(Object data)
      Authorization protected method that may be used to associate a thread-scoped handler data object with the PolicyContext.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • setContextID

        public static void setContextID(String contextID)
        Authorization protected method used to modify the value of the policy context identifier associated with the thread on which this method is called.
        Parameters:
        contextID - a String that represents the value of the policy context identifier to be assigned to the PolicyContext for the calling thread. The value null is a legitimate value for this parameter.
        Throws:
        SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.

      • getContextID

        public static String getContextID()
        This static method returns the value of the policy context identifier associated with the thread on which the accessor is called.
        Returns:
        The String (or null) policy context identifier established for the thread. This method must return the default policy context identifier, null, if the policy context identifier of the thread has not been set via setContext to another value.
        Throws:
        SecurityException - if the calling AccessControlContext is not authorized by the container to call this method. Containers may choose to authorize calls to this method by any AccessControlContext.

      • setHandlerData

        public static void setHandlerData(Object data)
        Authorization protected method that may be used to associate a thread-scoped handler data object with the PolicyContext. The handler data object will be made available to handlers, where it can serve to supply or bind the handler to invocation scoped state within the container.
        Parameters:
        data - a container-specific object that will be associated with the calling thread and passed to any handler activated by a Policy provider (on the thread). The value null is a legitimate value for this parameter, and is the value that will be used in the activation of handlers if the setHandlerData has not been called on the thread.
        Throws:
        SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.

      • registerHandler

        public static void registerHandler(String key,
                   PolicyContextHandler handler,
                   boolean replace)
                            throws PolicyContextException
        Authorization protected method used to register a container specific PolicyContext handler. A handler may be registered to handle multiple keys, but at any time, at most one handler may be registered for a key.
        Parameters:
        key - a (case-sensitive) String that identifies the context object handled by the handler. The value of this parameter must not be null.
        handler - an object that implements the PolicyContextHandler interface. The value of this parameter must not be null.
        replace - this boolean value defines the behavior of this method if, when it is called, a PolicyContextHandler has already been registered to handle the same key. In that case, and if the value of this argument is true, the existing handler is replaced with the argument handler. If the value of this parameter is false the existing registration is preserved and an exception is thrown.
        Throws:
        IllegalArgumentException - if the value of either of the handler or key arguments is null, or the value of the replace argument is false and a handler with the same key as the argument handler is already registered.
        SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.
        PolicyContextException - if an operation by this method on the argument PolicyContextHandler causes it to throw a checked exception that is not accounted for in the signature of this method.

      • getHandlerKeys

        public static Set getHandlerKeys()
        This method may be used to obtain the keys that identify the container specific context handlers registered by the container.
        Returns:
        A Set, the elements of which, are the String key values that identify the handlers that have been registered and therefore may be activated on the PolicyContext.
        Throws:
        SecurityException - if the calling AccessControlContext is not authorized by the container to call this method. Containers may choose to authorize calls to this method by any AccessControlContext.

      • getContext

        public static Object getContext(String key)
                         throws PolicyContextException
        This method may be used by a Policy provider to activate the PolicyContextHandler registered to the context object key and cause it to return the corresponding policy context object from the container. When this method activates a handler, it passes to the handler the context object key and the handler data associated with the calling thread.
        Parameters:
        key - a String that identifies the PolicyContextHandler to activate and the context object to be acquired from the handler. The value of this parameter must not be null.
        Returns:
        the container and handler specific object containing the desired context. A null value is returned if the corresponding handler has been registered, and the value of the corresponding context is null.
        Throws:
        IllegalArgumentException - if a PolicyContextHandler has not been registered for the key or the registered handler no longer supports the key.
        SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.
        PolicyContextException - if an operation by this method on the identified PolicyContextHandler causes it to throw a checked exception that is not accounted for in the signature of this method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PolicyContextException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.jacc

Class PolicyContextException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.security.jacc.PolicyContextException
  • All Implemented Interfaces:
    Serializable

    public class PolicyContextException
extends Exception
    This checked exception is thrown by implementations of the javax.security.jacc.PolicyConfiguration Interface, the javax.security.jacc.PolicyConfigurationFactory abstract class, the javax.security.jacc.PolicyContext utility class, and implementations of the javax.security.jacc.PolicyContextException Interface.

    This exception is used by javax.security.jacc implementation classes to rethrow checked exceptions ocurring within an implementation that are not declared by the interface or class being implemented.

    Author:
    Ron Monzillo, Gary Ellison
    See Also:
    Exception, PolicyConfiguration, PolicyConfigurationFactory, PolicyContext, PolicyContextHandler, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyContextException()
      Constructs a new PolicyContextException with null as its detail message.
      PolicyContextException(String msg)
      Constructs a new PolicyContextException with the specified detail message
      PolicyContextException(String msg, Throwable cause)
      Constructs a new PolicyContextException with the specified detail message and cause.
      PolicyContextException(Throwable cause)
      Constructs a new PolicyContextException with the specified cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PolicyContextException

        public PolicyContextException()
        Constructs a new PolicyContextException with null as its detail message. describing the cause of the exception.

      • PolicyContextException

        public PolicyContextException(String msg)
        Constructs a new PolicyContextException with the specified detail message
        Parameters:
        msg - - a String containing a detail message describing the cause of the exception.

      • PolicyContextException

        public PolicyContextException(String msg,
                      Throwable cause)
        Constructs a new PolicyContextException with the specified detail message and cause. The cause will be encapsulated in the constructed exception.
        Parameters:
        msg - - a String containing a detail message describing the cause of the exception.
        cause - - the Throwable that is "causing" this exception to be constructed. A null value is permitted, and the value passed through this parameter may subsequently be retrieved by calling getCause() on the constructed exception.

      • PolicyContextException

        public PolicyContextException(Throwable cause)
        Constructs a new PolicyContextException with the specified cause. The cause will be encapsulated in the constructed exception.
        Parameters:
        cause - - the Throwable that is "causing" this exception to be constructed. A null value is permitted, and the value passed through this parameter may subsequently be retrieved by calling getCause() on the constructed exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PolicyContextHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.jacc

Interface PolicyContextHandler

  • public interface PolicyContextHandler
    This interface defines the methods that must be implemented by handlers that are to be registered and activated by the PolicyContext class. The PolicyContext class provides methods for containers to register and activate container-specific PolicyContext handlers. Policy providers use the PolicyContext class to activate handlers to obtain (from the container) additional policy relevant context to apply in their access decisions. All handlers registered and activated via the PolicyContext class must implement the PolicyContextHandler interface.
    Author:
    Ron Monzillo, Gary Ellison
    See Also:
    PolicyContext, PolicyContextException

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getContext(String key, Object data)
      This public method is used by the PolicyContext class to activate the handler and obtain from it the context object identified by the (case-sensitive) key.
      String[] getKeys()
      This public method returns the keys identifying the context objects supported by the handler.
      boolean supports(String key)
      This public method returns a boolean result indicating whether or not the handler supports the context object identified by the (case-sensitive) key value.

    • Method Detail

      • supports

        boolean supports(String key)
                 throws PolicyContextException
        This public method returns a boolean result indicating whether or not the handler supports the context object identified by the (case-sensitive) key value.
        Parameters:
        key - a String value identifying a context object that could be supported by the handler. The value of this parameter must not be null.
        Returns:
        a boolean indicating whether or not the context object corresponding to the argument key is handled by the handler.
        Throws:
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException

      • getKeys

        String[] getKeys()
                 throws PolicyContextException
        This public method returns the keys identifying the context objects supported by the handler. The value of each key supported by a handler must be a non-null String value.
        Returns:
        an array containing String values identifing the context objects supported by the handler. The array must not contain duplicate key values. In the unlikely case that the Handler supports no keys, the handler must return a zero length array. The value null must never be returned by this method.
        Throws:
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException

      • getContext

        Object getContext(String key,
                Object data)
                  throws PolicyContextException
        This public method is used by the PolicyContext class to activate the handler and obtain from it the context object identified by the (case-sensitive) key. In addition to the key, the handler will be activated with the handler data value associated within the PolicyContext class with the thread on which the call to this method is made.

        Note that the policy context identifier associated with a thread is available to the handler by calling PolicyContext.getContextID().

        Parameters:
        key - a String that identifies the context object to be returned by the handler. The value of this paramter must not be null.
        data - the handler data Object associated with the thread on which the call to this method has been made. Note that the value passed through this parameter may be null.
        Returns:
        The container and handler specific Object containing the desired context. A null value may be returned if the value of the corresponding context is null.
        Throws:
        PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.security.jacc (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.security.jacc

  • Packages that use javax.security.jacc
    Package Description
    javax.security.jacc
    This package contains the Java Authorization Contract for Containers API
  • Classes in javax.security.jacc used by javax.security.jacc
    Class and Description
    PolicyConfiguration
    The methods of this interface are used by containers to create policy statements in a Policy provider.
    PolicyConfigurationFactory
    Abstract factory and finder class for obtaining the instance of the class that implements the PolicyConfigurationFactory of a provider.
    PolicyContextException
    This checked exception is thrown by implementations of the javax.security.jacc.PolicyConfiguration Interface, the javax.security.jacc.PolicyConfigurationFactory abstract class, the javax.security.jacc.PolicyContext utility class, and implementations of the javax.security.jacc.PolicyContextException Interface.
    PolicyContextHandler
    This interface defines the methods that must be implemented by handlers that are to be registered and activated by the PolicyContext class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WebResourcePermission (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.jacc

Class WebResourcePermission

  • java.lang.Object
    • java.security.Permission
      • javax.security.jacc.WebResourcePermission
  • All Implemented Interfaces:
    Serializable, Guard

    public final class WebResourcePermission
extends Permission
    Class for Servlet web resource permissions. A WebResourcePermission is a named permission and has actions.

    The name of a WebResourcePermission (also referred to as the target name) identifies the Web resources to which the permission pertains.

    Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

    Author:
    Ron Monzillo, Gary Ellison
    See Also:
    Permission, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      WebResourcePermission(HttpServletRequest request)
      Creates a new WebResourcePermission from the HttpServletRequest object.
      WebResourcePermission(String name, String actions)
      Creates a new WebResourcePermission with the specified name and actions.
      WebResourcePermission(String urlPatternSpec, String[] HTTPMethods)
      Creates a new WebResourcePermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object o)
      Checks two WebResourcePermission objects for equality.
      String getActions()
      Returns a canonical String representation of the actions of this WebResourcePermission.
      int hashCode()
      Returns the hash code value for this WebResourcePermission.
      boolean implies(Permission permission)
      Determines if the argument Permission is "implied by" this WebResourcePermission.

      • Methods inherited from class java.security.Permission

        checkGuard, getName, newPermissionCollection, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WebResourcePermission

        public WebResourcePermission(String name,
                     String actions)
        Creates a new WebResourcePermission with the specified name and actions.

        The name contains a URLPatternSpec that identifies the web resources to which the permissions applies. The syntax of a URLPatternSpec is as follows:

          URLPatternList ::= URLPattern | URLPatternList colon URLPattern

          URLPatternSpec ::= null | URLPattern | URLPattern colon URLPatternList

        A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor. The empty string is an exact URLPattern, and may occur anywhere in a URLPatternSpec that an exact URLPattern may occur. The first URLPattern in a URLPatternSpec may be any of the pattern types, exact, path-prefix, extension, or default as defined in the Java Servlet Specification). When a URLPatternSpec includes a URLPatternList, the patterns of the URLPatternList identify the resources to which the permission does NOT apply and depend on the pattern type and value of the first pattern as follows:

        • No pattern may exist in the URLPatternList that matches the first pattern.
        • If the first pattern is a path-prefix pattern, only exact patterns matched by the first pattern and path-prefix patterns matched by, but different from, the first pattern may occur in the URLPatternList.
        • If the first pattern is an extension pattern, only exact patterns that are matched by the first pattern and path-prefix patterns may occur in the URLPatternList.
        • If the first pattern is the default pattern, "/", any pattern except the default pattern may occur in the URLPatternList.
        • If the first pattern is an exact pattern a URLPatternList must not be present in the URLPatternSpec.

        The actions parameter contains a comma seperated list of HTTP methods. The syntax of the actions parameter is defined as follows:

          ExtensionMethod ::= any token as defined by RFC 2616
                    (that is, 1*[any CHAR except CTLs or separators])

          HTTPMethod ::= "GET" | "POST" | "PUT" | "DELETE" | "HEAD" |
                   "OPTIONS" | "TRACE" | ExtensionMethod

          HTTPMethodList ::= HTTPMethod | HTTPMethodList comma HTTPMethod

          HTTPMethodExceptionList ::= exclaimationPoint HTTPMethodList

          HTTPMethodSpec ::= null | HTTPMethodExceptionList |
                   HTTPMethodList

        If duplicates occur in the HTTPMethodSpec they must be eliminated by the permission constructor.

        A null or empty string HTTPMethodSpec indicates that the permission applies to all HTTP methods at the resources identified by the URL pattern.

        If the HTTPMethodSpec contains an HTTPMethodExceptionList (i.e., it begins with an exclaimationPoint), the permission pertains to all methods except those occuring in the exception list.

        Parameters:
        name - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor. All colons occuring within the URLPattern elements of the URLPatternSpec must be represented in escaped encoding as defined in RFC 2396.

        actions - identifies the HTTP methods to which the permission pertains. If the value passed through this parameter is null or the empty string, then the permission pertains to all the possible HTTP methods.

      • WebResourcePermission

        public WebResourcePermission(String urlPatternSpec,
                     String[] HTTPMethods)
        Creates a new WebResourcePermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods.

        Parameters:
        urlPatternSpec - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor. All colons occuring within the URLPattern elements of the URLPatternSpec must be represented in escaped encoding as defined in RFC 2396.

        HTTPMethods - an array of strings each element of which contains the value of an HTTP method. If the value passed through this parameter is null or is an array with no elements, then the permission pertains to all the possible HTTP methods.

      • WebResourcePermission

        public WebResourcePermission(HttpServletRequest request)
        Creates a new WebResourcePermission from the HttpServletRequest object.

        Parameters:
        request - the HttpServletRequest object corresponding to the Servlet operation to which the permission pertains. The permission name is the substring of the requestURI (HttpServletRequest.getRequestURI()) that begins after the contextPath (HttpServletRequest.getContextPath()). When the substring operation yields the string "/", the permission is constructed with the empty string as its name. The permission's actions field is obtained from HttpServletRequest.getMethod(). The constructor must transform all colon characters occuring in the name to escaped encoding as defined in RFC 2396.

    • Method Detail

      • equals

        public boolean equals(Object o)
        Checks two WebResourcePermission objects for equality. WebResourcePermission objects are equivalent if their URLPatternSpec and (canonicalized) actions values are equivalent. The URLPatternSpec of a reference permission is equivalent to that of an argument permission if their first patterns are equivalent, and the patterns of the URLPatternList of the reference permission collectively match exactly the same set of patterns as are matched by the patterns of the URLPatternList of the argument permission.

        Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

        Specified by:
        equals in class Permission
        Parameters:
        o - the WebResourcePermission object being tested for equality with this WebResourcePermission.

        Returns:
        true if the argument WebResourcePermission object is equivalent to this WebResourcePermission.

      • getActions

        public String getActions()
        Returns a canonical String representation of the actions of this WebResourcePermission. In the canonical form, predefined methods preceed extension methods, and within each method classification the corresponding methods occur in ascending lexical order. There may be no duplicate HTTP methods in the canonical form, and the canonical form of the set of all HTTP methods is the value null.

        Specified by:
        getActions in class Permission
        Returns:
        a String containing the canonicalized actions of this WebResourcePermission (or the null value).

      • hashCode

        public int hashCode()
        Returns the hash code value for this WebResourcePermission. The properties of the returned hash code must be as follows:

        • During the lifetime of a Java application, the hashCode method must return the same integer value, every time it is called on a WebResourcePermission object. The value returned by hashCode for a particular WebResourcePermission need not remain consistent from one execution of an application to another.
        • If two WebResourcePermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

        Specified by:
        hashCode in class Permission
        Returns:
        the integer hash code value for this object.

      • implies

        public boolean implies(Permission permission)
        Determines if the argument Permission is "implied by" this WebResourcePermission. For this to be the case, all of the following must be true:

        • The argument is an instanceof WebResourcePermission
        • The first URLPattern in the name of the argument permission is matched by the first URLPattern in the name of this permission.
        • The first URLPattern in the name of the argument permission is NOT matched by any URLPattern in the URLPatternList of the URLPatternSpec of this permission.
        • If the first URLPattern in the name of the argument permission matches the first URLPattern in the URLPatternSpec of this permission, then every URLPattern in the URLPatternList of the URLPatternSpec of this permission is matched by a URLPattern in the URLPatternList of the argument permission.
        • The HTTP methods represented by the actions of the argument permission are a subset of the HTTP methods represented by the actions of this permission.

        URLPattern matching is performed using the Servlet matching rules where two URL patterns match if they are related as follows:

        • their pattern values are String equivalent, or
        • this pattern is the path-prefix pattern "/*", or
        • this pattern is a path-prefix pattern (that is, it starts with "/" and ends with "/*") and the argument pattern starts with the substring of this pattern, minus its last 2 characters, and the next character of the argument pattern, if there is one, is "/", or
        • this pattern is an extension pattern (that is, it starts with "*.") and the argument pattern ends with this pattern, or
        • the reference pattern is the special default pattern, "/", which matches all argument patterns.

        All of the comparisons described above are case sensitive.

        Specified by:
        implies in class Permission
        Parameters:
        permission - "this" WebResourcePermission is checked to see if it implies the argument permission.

        Returns:
        true if the specified permission is implied by this object, false if not.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WebRoleRefPermission (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.jacc

Class WebRoleRefPermission

  • java.lang.Object
    • java.security.Permission
      • javax.security.jacc.WebRoleRefPermission
  • All Implemented Interfaces:
    Serializable, Guard

    public final class WebRoleRefPermission
extends Permission
implements Serializable
    Class for Servlet isUserInRole (String reference) permissions. A WebRoleRefPermission is a named permission and has actions.

    The name of an WebRoleRefPermission (also referred to as the target name) identifies a Web resource by the servlet name (in the deployment descriptor corresponding to the component from which the call to isUserInRole (String reference) is being made.

    The actions of an WebRoleRefPermission identifies the role reference to which the permission applies. A WebRoleRefPermission is checked to determine if the subject is a member of the role identified by the reference.

    Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

    Author:
    Ron Monzillo, Gary Ellison
    See Also:
    Permission, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      WebRoleRefPermission(String name, String actions)
      Creates a new WebRoleRefPermission with the specified name and actions.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object o)
      Checks two WebRoleRefPermission objects for equality.
      String getActions()
      Returns a canonical String representation of the actions of this WebRoleRefPermission.
      int hashCode()
      Returns the hash code value for this WebRoleRefPermission.
      boolean implies(Permission permission)
      Determines if the argument Permission is "implied by" this WebRoleRefPermission.

      • Methods inherited from class java.security.Permission

        checkGuard, getName, newPermissionCollection, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WebRoleRefPermission

        public WebRoleRefPermission(String name,
                    String actions)
        Creates a new WebRoleRefPermission with the specified name and actions.

        Parameters:
        name - the servlet-name that identifies the application specific web resource in whose context the role references are to be evaluated.

        actions - identifies the role reference to which the permission pertains. The role reference is scoped to the Web resource identified in the name parameter. The value of the role reference must not be null or the empty string.

    • Method Detail

      • equals

        public boolean equals(Object o)
        Checks two WebRoleRefPermission objects for equality. WebRoleRefPermission objects are equivalent if they have case equivalent name and actions values.

        Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

        The name and actions comparisons described above are case sensitive.

        Specified by:
        equals in class Permission
        Parameters:
        o - the WebRoleRefPermission object being tested for equality with this WebRoleRefPermission.
        Returns:
        true if the argument WebRoleRefPermission object is equivalent to this WebRoleRefPermission.

      • getActions

        public String getActions()
        Returns a canonical String representation of the actions of this WebRoleRefPermission.

        Specified by:
        getActions in class Permission
        Returns:
        a String containing the canonicalized actions of this WebRoleRefPermission.

      • hashCode

        public int hashCode()
        Returns the hash code value for this WebRoleRefPermission. The properties of the returned hash code must be as follows:

        • During the lifetime of a Java application, the hashCode method must return the same integer value, every time it is called on a WebRoleRefPermission object. The value returned by hashCode for a particular WebRoleRefPermission need not remain consistent from one execution of an application to another.
        • If two WebRoleRefPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

        Specified by:
        hashCode in class Permission
        Returns:
        the integer hash code value for this object.

      • implies

        public boolean implies(Permission permission)
        Determines if the argument Permission is "implied by" this WebRoleRefPermission. For this to be the case,

        • The argument must be an instanceof WebRoleRefPermission
        • with name equivalent to this WebRoleRefPermission, and
        • with role reference equivalent to this WebRoleRefPermission (as defined in their actions).

        The comparisons described above are case sensitive.

        Specified by:
        implies in class Permission
        Parameters:
        permission - "this" WebRoleRefPermission is checked to see if it implies the argument permission.

        Returns:
        true if the specified permission is implied by this object, false if not.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WebUserDataPermission (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.security.jacc

Class WebUserDataPermission

  • java.lang.Object
    • java.security.Permission
      • javax.security.jacc.WebUserDataPermission
  • All Implemented Interfaces:
    Serializable, Guard

    public final class WebUserDataPermission
extends Permission
    Class for Servlet Web user data permissions. A WebUserDataPermission is a named permission and has actions.

    The name of a WebUserDataPermission (also referred to as the target name) identifies a Web resource by its context path relative URL pattern.

    Author:
    Ron Monzillo, Gary Ellison
    See Also:
    Permission, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      WebUserDataPermission(HttpServletRequest request)
      Creates a new WebUserDataPermission from the HttpServletRequest object.
      WebUserDataPermission(String name, String actions)
      Creates a new WebUserDataPermission with the specified name and actions.
      WebUserDataPermission(String urlPatternSpec, String[] HTTPMethods, String transportType)
      Creates a new WebUserDataPermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods and the transport type.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object o)
      Checks two WebUserDataPermission objects for equality.
      String getActions()
      Returns a canonical String representation of the actions of this WebUserDataPermission.
      int hashCode()
      Returns the hash code value for this WebUserDataPermission.
      boolean implies(Permission permission)
      Determines if the argument Permission is "implied by" this WebUserDataPermission.

      • Methods inherited from class java.security.Permission

        checkGuard, getName, newPermissionCollection, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WebUserDataPermission

        public WebUserDataPermission(String name,
                     String actions)
        Creates a new WebUserDataPermission with the specified name and actions.

        The name contains a URLPatternSpec that identifies the web resources to which the permissions applies. The syntax of a URLPatternSpec is as follows:

          URLPatternList ::= URLPattern | URLPatternList colon URLPattern

          URLPatternSpec ::= null | URLPattern | URLPattern colon URLPatternList

        A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor. The empty string is an exact URLPattern, and may occur anywhere in a URLPatternSpec that an exact URLPattern may occur. The first URLPattern in a URLPatternSpec may be any of the pattern types, exact, path-prefix, extension, or default as defined in the Java Servlet Specification). When a URLPatternSpec includes a URLPatternList, the patterns of the URLPatternList identify the resources to which the permission does NOT apply and depend on the pattern type and value of the first pattern as follows:

        • No pattern may exist in the URLPatternList that matches the first pattern.
        • If the first pattern is a path-prefix pattern, only exact patterns matched by the first pattern and path-prefix patterns matched by, but different from, the first pattern may occur in the URLPatternList.
        • If the first pattern is an extension pattern, only exact patterns that are matched by the first pattern and path-prefix patterns may occur in the URLPatternList.
        • If the first pattern is the default pattern, "/", any pattern except the default pattern may occur in the URLPatternList.
        • If the first pattern is an exact pattern a URLPatternList must not be present in the URLPatternSpec.

        The actions parameter contains a comma separated list of HTTP methods that may be followed by a transportType separated from the HTTP method by a colon.

          ExtensionMethod ::= any token as defined by RFC 2616
                  (that is, 1*[any CHAR except CTLs or separators])

          HTTPMethod ::= "Get" | "POST" | "PUT" | "DELETE" | "HEAD" |
                  "OPTIONS" | "TRACE" | ExtensionMethod

          HTTPMethodList ::= HTTPMethod | HTTPMethodList comma HTTPMethod

          HTTPMethodExceptionList ::= exclaimationPoint HTTPMethodList

          HTTPMethodSpec ::= emptyString | HTTPMethodExceptionList |
                  HTTPMethodList

          transportType ::= "INTEGRAL" | "CONFIDENTIAL" | "NONE"

          actions ::= null | HTTPMethodSpec |
                  HTTPMethodSpec colon transportType

        If duplicates occur in the HTTPMethodSpec they must be eliminated by the permission constructor.

        An empty string HTTPMethodSpec is a shorthand for a List containing all the possible HTTP methods.

        If the HTTPMethodSpec contains an HTTPMethodExceptionList (i.e., it begins with an exclaimationPoint), the permission pertains to all methods except those occuring in the exception list.

        An actions string without a transportType is a shorthand for a actions string with the value "NONE" as its TransportType.

        A granted permission representing a transportType of "NONE", indicates that the associated resources may be accessed using any conection type.

        Parameters:
        name - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor. All colons occuring within the URLPattern elements of the URLPatternSpec must be represented in escaped encoding as defined in RFC 2396.

        actions - identifies the HTTP methods and transport type to which the permission pertains. If the value passed through this parameter is null or the empty string, then the permission is constructed with actions corresponding to all the possible HTTP methods and transportType "NONE".

      • WebUserDataPermission

        public WebUserDataPermission(String urlPatternSpec,
                     String[] HTTPMethods,
                     String transportType)
        Creates a new WebUserDataPermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods and the transport type.

        Parameters:
        urlPatternSpec - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor. All colons occuring within the URLPattern elements of the URLPatternSpec must be represented in escaped encoding as defined in RFC 2396.

        HTTPMethods - an array of strings each element of which contains the value of an HTTP method. If the value passed through this parameter is null or is an array with no elements, then the permission is constructed with actions corresponding to all the possible HTTP methods.

        transportType - a String whose value is a transportType. If the value passed through this parameter is null, then the permission is constructed with actions corresponding to transportType "NONE".

      • WebUserDataPermission

        public WebUserDataPermission(HttpServletRequest request)
        Creates a new WebUserDataPermission from the HttpServletRequest object.

        Parameters:
        request - the HttpServletRequest object corresponding to the Servlet operation to which the permission pertains. The permission name is the substring of the requestURI (HttpServletRequest.getRequestURI()) that begins after the contextPath (HttpServletRequest.getContextPath()). When the substring operation yields the string "/", the permission is constructed with the empty string as its name. The constructor must transform all colon characters occuring in the name to escaped encoding as defined in RFC 2396. The HTTP method component of the permission's actions is as obtained from HttpServletRequest.getMethod(). The TransportType component of the permission's actions is determined by calling HttpServletRequest.isSecure().

    • Method Detail

      • equals

        public boolean equals(Object o)
        Checks two WebUserDataPermission objects for equality. WebUserDataPermission objects are equivalent if their URLPatternSpec and (canonicalized) actions values are equivalent. The URLPatternSpec of a reference permission is equivalent to that of an argument permission if their first patterns are equivalent, and the patterns of the URLPatternList of the reference permission collectively match exactly the same set of patterns as are matched by the patterns of the URLPatternList of the argument permission.

        Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

        Specified by:
        equals in class Permission
        Parameters:
        o - the WebUserDataPermission object being tested for equality with this WebUserDataPermission.

        Returns:
        true if the argument WebUserDataPermission object is equivalent to this WebUserDataPermission.

      • getActions

        public String getActions()
        Returns a canonical String representation of the actions of this WebUserDataPermission. The canonical form of the actions of a WebUserDataPermission is described by the following syntax description.

          ExtensionMethod ::= any token as defined by RFC 2616
                   (that is, 1*[any CHAR except CTLs or separators])

          HTTPMethod ::= "GET" | "POST" | "PUT" | "DELETE" | "HEAD" |
                   "OPTIONS" | "TRACE" | ExtensionMethod

          HTTPMethodList ::= HTTPMethod | HTTPMethodList comma HTTPMethod

          HTTPMethodExceptionList ::= exclaimationPoint HTTPMethodList

          HTTPMethodSpec ::= emptyString | HTTPMethodExceptionList |
                  HTTPMethodList

          transportType ::= "INTEGRAL" | "CONFIDENTIAL" | "NONE"

          actions ::= null | HTTPMethodList |
                  HTTPMethodSpec colon transportType

        If the permission's HTTP methods correspond to the entire HTTP method set and the permission's transport type is "INTEGRAL" or "CONFIDENTIAL", the HTTP methods shall be represented in the canonical form by an emptyString HTTPMethodSpec. If the permission's HTTP methods correspond to the entire HTTP method set, and the permission's transport type is not "INTEGRAL"or "CONFIDENTIAL", the canonical actions value shall be the null value.

        If the permission's methods do not correspond to the entire HTTP method set, duplicates must be eliminated and the remaining elements must be ordered such that the predefined methods preceed the extension methods, and such that within each method classification the corresponding methods occur in ascending lexical order. The resulting (non-emptyString) HTTPMethodSpec must be included in the canonical form, and if the permission's transport type is not "INTEGRAL" or "CONFIDENTIAL", the canonical actions value must be exactly the resulting HTTPMethodSpec.

        Specified by:
        getActions in class Permission
        Returns:
        a String containing the canonicalized actions of this WebUserDataPermission (or the null value).

      • hashCode

        public int hashCode()
        Returns the hash code value for this WebUserDataPermission. The properties of the returned hash code must be as follows:

        • During the lifetime of a Java application, the hashCode method shall return the same integer value every time it is called on a WebUserDataPermission object. The value returned by hashCode for a particular EJBMethod permission need not remain consistent from one execution of an application to another.
        • If two WebUserDataPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

        Specified by:
        hashCode in class Permission
        Returns:
        the integer hash code value for this object.

      • implies

        public boolean implies(Permission permission)
        Determines if the argument Permission is "implied by" this WebUserDataPermission. For this to be the case all of the following must be true:

        • The argument is an instanceof WebUserDataPermission.
        • The first URLPattern in the name of the argument permission is matched by the first URLPattern in the name of this permission.
        • The first URLPattern in the name of the argument permission is NOT matched by any URLPattern in the URLPatternList of the URLPatternSpec of this permission.
        • If the first URLPattern in the name of the argument permission matches the first URLPattern in the URLPatternSpec of this permission, then every URLPattern in the URLPatternList of the URLPatternSpec of this permission is matched by a URLPattern in the URLPatternList of the argument permission.
        • The HTTP methods represented by the actions of the argument permission are a subset of the HTTP methods represented by the actions of this permission.
        • The transportType in the actions of this permission either corresponds to the value "NONE", or equals the transportType in the actions of the argument permission.

        URLPattern matching is performed using the Servlet matching rules where two URL patterns match if they are related as follows:

        • their pattern values are String equivalent, or
        • this pattern is the path-prefix pattern "/*", or
        • this pattern is a path-prefix pattern (that is, it starts with "/" and ends with "/*") and the argument pattern starts with the substring of this pattern, minus its last 2 characters, and the next character of the argument pattern, if there is one, is "/", or
        • this pattern is an extension pattern (that is, it starts with "*.") and the argument pattern ends with this pattern, or
        • the reference pattern is the special default pattern, "/", which matches all argument patterns.

        All of the comparisons described above are case sensitive.

        Specified by:
        implies in class Permission
        Parameters:
        permission - "this" WebUserDataPermission is checked to see if it implies the argument permission.

        Returns:
        true if the specified permission is implied by this object, false if not.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.security.jacc.EJBMethodPermission (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.jacc.EJBMethodPermission

No usage of javax.security.jacc.EJBMethodPermission
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.jacc.EJBRoleRefPermission (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.jacc.EJBRoleRefPermission

No usage of javax.security.jacc.EJBRoleRefPermission
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.jacc.PolicyConfigurationFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.jacc.PolicyConfigurationFactory

  • Packages that use PolicyConfigurationFactory
    Package Description
    javax.security.jacc
    This package contains the Java Authorization Contract for Containers API

    • Uses of PolicyConfigurationFactory in javax.security.jacc

      Methods in javax.security.jacc that return PolicyConfigurationFactory
      Modifier and Type Method and Description
      static PolicyConfigurationFactory PolicyConfigurationFactory.getPolicyConfigurationFactory()
      This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.jacc.PolicyContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.jacc.PolicyContext

No usage of javax.security.jacc.PolicyContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.jacc.PolicyContextException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.jacc.PolicyContextException

  • Packages that use PolicyContextException
    Package Description
    javax.security.jacc
    This package contains the Java Authorization Contract for Containers API

    • Uses of PolicyContextException in javax.security.jacc

      Methods in javax.security.jacc that throw PolicyContextException
      Modifier and Type Method and Description
      void PolicyConfiguration.addToExcludedPolicy(Permission permission)
      Used to add a single excluded policy statement to this PolicyConfiguration.
      void PolicyConfiguration.addToExcludedPolicy(PermissionCollection permissions)
      Used to add excluded policy statements to this PolicyConfiguration.
      void PolicyConfiguration.addToRole(String roleName, Permission permission)
      Used to add a single permission to a named role in this PolicyConfiguration.
      void PolicyConfiguration.addToRole(String roleName, PermissionCollection permissions)
      Used to add permissions to a named role in this PolicyConfiguration.
      void PolicyConfiguration.addToUncheckedPolicy(Permission permission)
      Used to add a single unchecked policy statement to this PolicyConfiguration.
      void PolicyConfiguration.addToUncheckedPolicy(PermissionCollection permissions)
      Used to add unchecked policy statements to this PolicyConfiguration.
      void PolicyConfiguration.commit()
      This method is used to set to "inService" the state of the policy context whose interface is this PolicyConfiguration Object.
      void PolicyConfiguration.delete()
      Causes all policy statements to be deleted from this PolicyConfiguration and sets its internal state such that calling any method, other than delete, getContextID, or inService on the PolicyConfiguration will be rejected and cause an UnsupportedOperationException to be thrown.
      static Object PolicyContext.getContext(String key)
      This method may be used by a Policy provider to activate the PolicyContextHandler registered to the context object key and cause it to return the corresponding policy context object from the container.
      Object PolicyContextHandler.getContext(String key, Object data)
      This public method is used by the PolicyContext class to activate the handler and obtain from it the context object identified by the (case-sensitive) key.
      String PolicyConfiguration.getContextID()
      This method returns this object's policy context identifier.
      String[] PolicyContextHandler.getKeys()
      This public method returns the keys identifying the context objects supported by the handler.
      abstract PolicyConfiguration PolicyConfigurationFactory.getPolicyConfiguration(String contextID, boolean remove)
      This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider.
      static PolicyConfigurationFactory PolicyConfigurationFactory.getPolicyConfigurationFactory()
      This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class.
      boolean PolicyConfiguration.inService()
      This method is used to determine if the policy context whose interface is this PolicyConfiguration Object is in the "inService" state.
      abstract boolean PolicyConfigurationFactory.inService(String contextID)
      This method determines if the identified policy context exists with state "inService" in the Policy provider associated with the factory.
      void PolicyConfiguration.linkConfiguration(PolicyConfiguration link)
      Creates a relationship between this configuration and another such that they share the same principal-to-role mappings.
      static void PolicyContext.registerHandler(String key, PolicyContextHandler handler, boolean replace)
      Authorization protected method used to register a container specific PolicyContext handler.
      void PolicyConfiguration.removeExcludedPolicy()
      Used to remove any excluded policy statements from this PolicyConfiguration.
      void PolicyConfiguration.removeRole(String roleName)
      Used to remove a role and all its permissions from this PolicyConfiguration.
      void PolicyConfiguration.removeUncheckedPolicy()
      Used to remove any unchecked policy statements from this PolicyConfiguration.
      boolean PolicyContextHandler.supports(String key)
      This public method returns a boolean result indicating whether or not the handler supports the context object identified by the (case-sensitive) key value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.jacc.WebResourcePermission (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.jacc.WebResourcePermission

No usage of javax.security.jacc.WebResourcePermission
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.jacc.WebRoleRefPermission (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.jacc.WebRoleRefPermission

No usage of javax.security.jacc.WebRoleRefPermission
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.security.jacc.WebUserDataPermission (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.security.jacc.WebUserDataPermission

No usage of javax.security.jacc.WebUserDataPermission
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.jacc.PolicyConfiguration (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.jacc.PolicyConfiguration

  • Packages that use PolicyConfiguration
    Package Description
    javax.security.jacc
    This package contains the Java Authorization Contract for Containers API

    • Uses of PolicyConfiguration in javax.security.jacc

      Methods in javax.security.jacc that return PolicyConfiguration
      Modifier and Type Method and Description
      abstract PolicyConfiguration PolicyConfigurationFactory.getPolicyConfiguration(String contextID, boolean remove)
      This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider.
      Methods in javax.security.jacc with parameters of type PolicyConfiguration
      Modifier and Type Method and Description
      void PolicyConfiguration.linkConfiguration(PolicyConfiguration link)
      Creates a relationship between this configuration and another such that they share the same principal-to-role mappings.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.security.jacc.PolicyContextHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.security.jacc.PolicyContextHandler

  • Packages that use PolicyContextHandler
    Package Description
    javax.security.jacc
    This package contains the Java Authorization Contract for Containers API

    • Uses of PolicyContextHandler in javax.security.jacc

      Methods in javax.security.jacc with parameters of type PolicyContextHandler
      Modifier and Type Method and Description
      static void PolicyContext.registerHandler(String key, PolicyContextHandler handler, boolean replace)
      Authorization protected method used to register a container specific PolicyContext handler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AsyncContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface AsyncContext

  • public interface AsyncContext
    Class representing the execution context for an asynchronous operation that was initiated on a ServletRequest.

    An AsyncContext is created and initialized by a call to ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse). Repeated invocations of these methods will return the same AsyncContext instance, reinitialized as appropriate.

    In the event that an asynchronous operation has timed out, the container must run through these steps:

    1. Invoke, at their onTimeout method, all AsyncListener instances registered with the ServletRequest on which the asynchronous operation was initiated.
    2. If none of the listeners called complete() or any of the dispatch() methods, perform an error dispatch with a status code equal to HttpServletResponse.SC_INTERNAL_SERVER_ERROR.
    3. If no matching error page was found, or the error page did not call complete() or any of the dispatch() methods, call complete().
    Since:
    Servlet 3.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ASYNC_CONTEXT_PATH
      The name of the request attribute under which the original context path is made available to the target of a dispatch(String) or dispatch(ServletContext,String)
      static String ASYNC_PATH_INFO
      The name of the request attribute under which the original path info is made available to the target of a dispatch(String) or dispatch(ServletContext,String)
      static String ASYNC_QUERY_STRING
      The name of the request attribute under which the original query string is made available to the target of a dispatch(String) or dispatch(ServletContext,String)
      static String ASYNC_REQUEST_URI
      The name of the request attribute under which the original request URI is made available to the target of a dispatch(String) or dispatch(ServletContext,String)
      static String ASYNC_SERVLET_PATH
      The name of the request attribute under which the original servlet path is made available to the target of a dispatch(String) or dispatch(ServletContext,String)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addListener(AsyncListener listener)
      Registers the given AsyncListener with the most recent asynchronous cycle that was started by a call to one of the ServletRequest.startAsync() methods.
      void addListener(AsyncListener listener, ServletRequest servletRequest, ServletResponse servletResponse)
      Registers the given AsyncListener with the most recent asynchronous cycle that was started by a call to one of the ServletRequest.startAsync() methods.
      void complete()
      Completes the asynchronous operation that was started on the request that was used to initialze this AsyncContext, closing the response that was used to initialize this AsyncContext.
      <T extends AsyncListener>
      T             		createListener(Class<T> clazz)
      Instantiates the given AsyncListener class.
      void dispatch()
      Dispatches the request and response objects of this AsyncContext to the servlet container.
      void dispatch(ServletContext context, String path)
      Dispatches the request and response objects of this AsyncContext to the given path scoped to the given context.
      void dispatch(String path)
      Dispatches the request and response objects of this AsyncContext to the given path.
      ServletRequest getRequest()
      Gets the request that was used to initialize this AsyncContext by calling ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse).
      ServletResponse getResponse()
      Gets the response that was used to initialize this AsyncContext by calling ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse).
      long getTimeout()
      Gets the timeout (in milliseconds) for this AsyncContext.
      boolean hasOriginalRequestAndResponse()
      Checks if this AsyncContext was initialized with the original or application-wrapped request and response objects.
      void setTimeout(long timeout)
      Sets the timeout (in milliseconds) for this AsyncContext.
      void start(Runnable run)
      Causes the container to dispatch a thread, possibly from a managed thread pool, to run the specified Runnable.

    • Field Detail

      • ASYNC_REQUEST_URI

        static final String ASYNC_REQUEST_URI
        The name of the request attribute under which the original request URI is made available to the target of a dispatch(String) or dispatch(ServletContext,String)
        See Also:
        Constant Field Values

      • ASYNC_CONTEXT_PATH

        static final String ASYNC_CONTEXT_PATH
        The name of the request attribute under which the original context path is made available to the target of a dispatch(String) or dispatch(ServletContext,String)
        See Also:
        Constant Field Values

      • ASYNC_PATH_INFO

        static final String ASYNC_PATH_INFO
        The name of the request attribute under which the original path info is made available to the target of a dispatch(String) or dispatch(ServletContext,String)
        See Also:
        Constant Field Values

      • ASYNC_SERVLET_PATH

        static final String ASYNC_SERVLET_PATH
        The name of the request attribute under which the original servlet path is made available to the target of a dispatch(String) or dispatch(ServletContext,String)
        See Also:
        Constant Field Values

      • ASYNC_QUERY_STRING

        static final String ASYNC_QUERY_STRING
        The name of the request attribute under which the original query string is made available to the target of a dispatch(String) or dispatch(ServletContext,String)
        See Also:
        Constant Field Values

    • Method Detail

      • getRequest

        ServletRequest getRequest()
        Gets the request that was used to initialize this AsyncContext by calling ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse).
        Returns:
        the request that was used to initialize this AsyncContext
        Throws:
        IllegalStateException - if complete() or any of the dispatch() methods has been called in the asynchronous cycle

      • getResponse

        ServletResponse getResponse()
        Gets the response that was used to initialize this AsyncContext by calling ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse).
        Returns:
        the response that was used to initialize this AsyncContext
        Throws:
        IllegalStateException - if complete() or any of the dispatch() methods has been called in the asynchronous cycle

      • hasOriginalRequestAndResponse

        boolean hasOriginalRequestAndResponse()
        Checks if this AsyncContext was initialized with the original or application-wrapped request and response objects.

        This information may be used by filters invoked in the outbound direction, after a request was put into asynchronous mode, to determine whether any request and/or response wrappers that they added during their inbound invocation need to be preserved for the duration of the asynchronous operation, or may be released.

        Returns:
        true if this AsyncContext was initialized with the original request and response objects by calling ServletRequest.startAsync(), or if it was initialized by calling ServletRequest.startAsync(ServletRequest, ServletResponse), and neither the ServletRequest nor ServletResponse arguments carried any application-provided wrappers; false otherwise

      • dispatch

        void dispatch()
        Dispatches the request and response objects of this AsyncContext to the servlet container.

        If the asynchronous cycle was started with ServletRequest.startAsync(ServletRequest, ServletResponse), and the request passed is an instance of HttpServletRequest, then the dispatch is to the URI returned by HttpServletRequest.getRequestURI(). Otherwise, the dispatch is to the URI of the request when it was last dispatched by the container.

        The following sequence illustrates how this will work:

         // REQUEST dispatch to /url/A
 AsyncContext ac = request.startAsync();
 ...
 ac.dispatch(); // ASYNC dispatch to /url/A

 // REQUEST to /url/A
 // FORWARD dispatch to /url/B
 request.getRequestDispatcher("/url/B").forward(request,response);
 // Start async operation from within the target of the FORWARD
 // dispatch
 ac = request.startAsync();
 ...
 ac.dispatch(); // ASYNC dispatch to /url/A

 // REQUEST to /url/A
 // FORWARD dispatch to /url/B
 request.getRequestDispatcher("/url/B").forward(request,response);
 // Start async operation from within the target of the FORWARD
 // dispatch
 ac = request.startAsync(request,response);
 ...
 ac.dispatch(); // ASYNC dispatch to /url/B

        This method returns immediately after passing the request and response objects to a container managed thread, on which the dispatch operation will be performed. If this method is called before the container-initiated dispatch that called startAsync has returned to the container, the dispatch operation will be delayed until after the container-initiated dispatch has returned to the container.

        The dispatcher type of the request is set to DispatcherType.ASYNC. Unlike forward dispatches, the response buffer and headers will not be reset, and it is legal to dispatch even if the response has already been committed.

        Control over the request and response is delegated to the dispatch target, and the response will be closed when the dispatch target has completed execution, unless ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse) are called.

        Any errors or exceptions that may occur during the execution of this method must be caught and handled by the container, as follows:

        1. Invoke, at their onError method, all AsyncListener instances registered with the ServletRequest for which this AsyncContext was created, and make the caught Throwable available via AsyncEvent.getThrowable().
        2. If none of the listeners called complete() or any of the dispatch() methods, perform an error dispatch with a status code equal to HttpServletResponse.SC_INTERNAL_SERVER_ERROR, and make the above Throwable available as the value of the RequestDispatcher.ERROR_EXCEPTION request attribute.
        3. If no matching error page was found, or the error page did not call complete() or any of the dispatch() methods, call complete().

        There can be at most one asynchronous dispatch operation per asynchronous cycle, which is started by a call to one of the ServletRequest.startAsync() methods. Any attempt to perform an additional asynchronous dispatch operation within the same asynchronous cycle will result in an IllegalStateException. If startAsync is subsequently called on the dispatched request, then any of the dispatch or complete() methods may be called.

        Throws:
        IllegalStateException - if one of the dispatch methods has been called and the startAsync method has not been called during the resulting dispatch, or if complete() was called
        See Also:
        ServletRequest.getDispatcherType()

      • dispatch

        void dispatch(String path)
        Dispatches the request and response objects of this AsyncContext to the given path.

        The path parameter is interpreted in the same way as in ServletRequest.getRequestDispatcher(String), within the scope of the ServletContext from which this AsyncContext was initialized.

        All path related query methods of the request must reflect the dispatch target, while the original request URI, context path, path info, servlet path, and query string may be recovered from the ASYNC_REQUEST_URI, ASYNC_CONTEXT_PATH, ASYNC_PATH_INFO, ASYNC_SERVLET_PATH, and ASYNC_QUERY_STRING attributes of the request. These attributes will always reflect the original path elements, even under repeated dispatches.

        There can be at most one asynchronous dispatch operation per asynchronous cycle, which is started by a call to one of the ServletRequest.startAsync() methods. Any attempt to perform an additional asynchronous dispatch operation within the same asynchronous cycle will result in an IllegalStateException. If startAsync is subsequently called on the dispatched request, then any of the dispatch or complete() methods may be called.

        See dispatch() for additional details, including error handling.

        Parameters:
        path - the path of the dispatch target, scoped to the ServletContext from which this AsyncContext was initialized
        Throws:
        IllegalStateException - if one of the dispatch methods has been called and the startAsync method has not been called during the resulting dispatch, or if complete() was called
        See Also:
        ServletRequest.getDispatcherType()

      • dispatch

        void dispatch(ServletContext context,
            String path)
        Dispatches the request and response objects of this AsyncContext to the given path scoped to the given context.

        The path parameter is interpreted in the same way as in ServletRequest.getRequestDispatcher(String), except that it is scoped to the given context.

        All path related query methods of the request must reflect the dispatch target, while the original request URI, context path, path info, servlet path, and query string may be recovered from the ASYNC_REQUEST_URI, ASYNC_CONTEXT_PATH, ASYNC_PATH_INFO, ASYNC_SERVLET_PATH, and ASYNC_QUERY_STRING attributes of the request. These attributes will always reflect the original path elements, even under repeated dispatches.

        There can be at most one asynchronous dispatch operation per asynchronous cycle, which is started by a call to one of the ServletRequest.startAsync() methods. Any attempt to perform an additional asynchronous dispatch operation within the same asynchronous cycle will result in an IllegalStateException. If startAsync is subsequently called on the dispatched request, then any of the dispatch or complete() methods may be called.

        See dispatch() for additional details, including error handling.

        Parameters:
        context - the ServletContext of the dispatch target
        path - the path of the dispatch target, scoped to the given ServletContext
        Throws:
        IllegalStateException - if one of the dispatch methods has been called and the startAsync method has not been called during the resulting dispatch, or if complete() was called
        See Also:
        ServletRequest.getDispatcherType()

      • complete

        void complete()
        Completes the asynchronous operation that was started on the request that was used to initialze this AsyncContext, closing the response that was used to initialize this AsyncContext.

        Any listeners of type AsyncListener that were registered with the ServletRequest for which this AsyncContext was created will be invoked at their onComplete method.

        It is legal to call this method any time after a call to ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse), and before a call to one of the dispatch methods of this class. If this method is called before the container-initiated dispatch that called startAsync has returned to the container, then the call will not take effect (and any invocations of AsyncListener.onComplete(AsyncEvent) will be delayed) until after the container-initiated dispatch has returned to the container.

      • start

        void start(Runnable run)
        Causes the container to dispatch a thread, possibly from a managed thread pool, to run the specified Runnable. The container may propagate appropriate contextual information to the Runnable.
        Parameters:
        run - the asynchronous handler

      • addListener

        void addListener(AsyncListener listener)
        Registers the given AsyncListener with the most recent asynchronous cycle that was started by a call to one of the ServletRequest.startAsync() methods.

        The given AsyncListener will receive an AsyncEvent when the asynchronous cycle completes successfully, times out, results in an error, or a new asynchronous cycle is being initiated via one of the ServletRequest.startAsync() methods.

        AsyncListener instances will be notified in the order in which they were added.

        If ServletRequest.startAsync(ServletRequest, ServletResponse) or ServletRequest.startAsync() is called, the exact same request and response objects are available from the AsyncEvent when the AsyncListener is notified.

        Parameters:
        listener - the AsyncListener to be registered
        Throws:
        IllegalStateException - if this method is called after the container-initiated dispatch, during which one of the ServletRequest.startAsync() methods was called, has returned to the container

      • addListener

        void addListener(AsyncListener listener,
               ServletRequest servletRequest,
               ServletResponse servletResponse)
        Registers the given AsyncListener with the most recent asynchronous cycle that was started by a call to one of the ServletRequest.startAsync() methods.

        The given AsyncListener will receive an AsyncEvent when the asynchronous cycle completes successfully, times out, results in an error, or a new asynchronous cycle is being initiated via one of the ServletRequest.startAsync() methods.

        AsyncListener instances will be notified in the order in which they were added.

        The given ServletRequest and ServletResponse objects will be made available to the given AsyncListener via the getSuppliedRequest and getSuppliedResponse methods, respectively, of the AsyncEvent delivered to it. These objects should not be read from or written to, respectively, at the time the AsyncEvent is delivered, because additional wrapping may have occurred since the given AsyncListener was registered, but may be used in order to release any resources associated with them.

        Parameters:
        listener - the AsyncListener to be registered
        servletRequest - the ServletRequest that will be included in the AsyncEvent
        servletResponse - the ServletResponse that will be included in the AsyncEvent
        Throws:
        IllegalStateException - if this method is called after the container-initiated dispatch, during which one of the ServletRequest.startAsync() methods was called, has returned to the container

      • createListener

        <T extends AsyncListener> T createListener(Class<T> clazz)
                                       throws ServletException
        Instantiates the given AsyncListener class.

        The returned AsyncListener instance may be further customized before it is registered with this AsyncContext via a call to one of the addListener methods.

        The given AsyncListener class must define a zero argument constructor, which is used to instantiate it.

        This method supports resource injection if the given clazz represents a Managed Bean. See the Java EE platform and JSR 299 specifications for additional details about Managed Beans and resource injection.

        This method supports any annotations applicable to AsyncListener.

        Parameters:
        clazz - the AsyncListener class to instantiate
        Returns:
        the new AsyncListener instance
        Throws:
        ServletException - if the given clazz fails to be instantiated

      • setTimeout

        void setTimeout(long timeout)
        Sets the timeout (in milliseconds) for this AsyncContext.

        The timeout applies to this AsyncContext once the container-initiated dispatch during which one of the ServletRequest.startAsync() methods was called has returned to the container.

        The timeout will expire if neither the complete() method nor any of the dispatch methods are called. A timeout value of zero or less indicates no timeout.

        If setTimeout(long) is not called, then the container's default timeout, which is available via a call to getTimeout(), will apply.

        The default value is 30000 ms.

        Parameters:
        timeout - the timeout in milliseconds
        Throws:
        IllegalStateException - if this method is called after the container-initiated dispatch, during which one of the ServletRequest.startAsync() methods was called, has returned to the container

      • getTimeout

        long getTimeout()
        Gets the timeout (in milliseconds) for this AsyncContext.

        This method returns the container's default timeout for asynchronous operations, or the timeout value passed to the most recent invocation of setTimeout(long).

        A timeout value of zero or less indicates no timeout.

        Returns:
        the timeout in milliseconds
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AsyncEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class AsyncEvent

  • java.lang.Object
    • javax.servlet.AsyncEvent

  • public class AsyncEvent
extends Object
    Event that gets fired when the asynchronous operation initiated on a ServletRequest (via a call to ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse)) has completed, timed out, or produced an error.
    Since:
    Servlet 3.0

    • Constructor Summary

      Constructors
      Constructor and Description
      AsyncEvent(AsyncContext context)
      Constructs an AsyncEvent from the given AsyncContext.
      AsyncEvent(AsyncContext context, ServletRequest request, ServletResponse response)
      Constructs an AsyncEvent from the given AsyncContext, ServletRequest, and ServletResponse.
      AsyncEvent(AsyncContext context, ServletRequest request, ServletResponse response, Throwable throwable)
      Constructs an AsyncEvent from the given AsyncContext, ServletRequest, ServletResponse, and Throwable.
      AsyncEvent(AsyncContext context, Throwable throwable)
      Constructs an AsyncEvent from the given AsyncContext and Throwable.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      AsyncContext getAsyncContext()
      Gets the AsyncContext from this AsyncEvent.
      ServletRequest getSuppliedRequest()
      Gets the ServletRequest from this AsyncEvent.
      ServletResponse getSuppliedResponse()
      Gets the ServletResponse from this AsyncEvent.
      Throwable getThrowable()
      Gets the Throwable from this AsyncEvent.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AsyncEvent

        public AsyncEvent(AsyncContext context)
        Constructs an AsyncEvent from the given AsyncContext.
        Parameters:
        context - the AsyncContex to be delivered with this AsyncEvent

      • AsyncEvent

        public AsyncEvent(AsyncContext context,
          ServletRequest request,
          ServletResponse response)
        Constructs an AsyncEvent from the given AsyncContext, ServletRequest, and ServletResponse.
        Parameters:
        context - the AsyncContex to be delivered with this AsyncEvent
        request - the ServletRequest to be delivered with this AsyncEvent
        response - the ServletResponse to be delivered with this AsyncEvent

      • AsyncEvent

        public AsyncEvent(AsyncContext context,
          Throwable throwable)
        Constructs an AsyncEvent from the given AsyncContext and Throwable.
        Parameters:
        context - the AsyncContex to be delivered with this AsyncEvent
        throwable - the Throwable to be delivered with this AsyncEvent

      • AsyncEvent

        public AsyncEvent(AsyncContext context,
          ServletRequest request,
          ServletResponse response,
          Throwable throwable)
        Constructs an AsyncEvent from the given AsyncContext, ServletRequest, ServletResponse, and Throwable.
        Parameters:
        context - the AsyncContex to be delivered with this AsyncEvent
        request - the ServletRequest to be delivered with this AsyncEvent
        response - the ServletResponse to be delivered with this AsyncEvent
        throwable - the Throwable to be delivered with this AsyncEvent

    • Method Detail

      • getAsyncContext

        public AsyncContext getAsyncContext()
        Gets the AsyncContext from this AsyncEvent.
        Returns:
        the AsyncContext that was used to initialize this AsyncEvent

      • getSuppliedRequest

        public ServletRequest getSuppliedRequest()
        Gets the ServletRequest from this AsyncEvent.

        If the AsyncListener to which this AsyncEvent is being delivered was added using AsyncContext.addListener(AsyncListener, ServletRequest, ServletResponse), the returned ServletRequest will be the same as the one supplied to the above method. If the AsyncListener was added via AsyncContext.addListener(AsyncListener), this method must return null.

        Returns:
        the ServletRequest that was used to initialize this AsyncEvent, or null if this AsyncEvent was initialized without any ServletRequest

      • getSuppliedResponse

        public ServletResponse getSuppliedResponse()
        Gets the ServletResponse from this AsyncEvent.

        If the AsyncListener to which this AsyncEvent is being delivered was added using AsyncContext.addListener(AsyncListener, ServletRequest, ServletResponse), the returned ServletResponse will be the same as the one supplied to the above method. If the AsyncListener was added via AsyncContext.addListener(AsyncListener), this method must return null.

        Returns:
        the ServletResponse that was used to initialize this AsyncEvent, or null if this AsyncEvent was initialized without any ServletResponse

      • getThrowable

        public Throwable getThrowable()
        Gets the Throwable from this AsyncEvent.
        Returns:
        the Throwable that was used to initialize this AsyncEvent, or null if this AsyncEvent was initialized without any Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AsyncListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface AsyncListener

  • All Superinterfaces:
    EventListener

    public interface AsyncListener
extends EventListener
    Listener that will be notified in the event that an asynchronous operation initiated on a ServletRequest to which the listener had been added has completed, timed out, or resulted in an error.
    Since:
    Servlet 3.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onComplete(AsyncEvent event)
      Notifies this AsyncListener that an asynchronous operation has been completed.
      void onError(AsyncEvent event)
      Notifies this AsyncListener that an asynchronous operation has failed to complete.
      void onStartAsync(AsyncEvent event)
      Notifies this AsyncListener that a new asynchronous cycle is being initiated via a call to one of the ServletRequest.startAsync() methods.
      void onTimeout(AsyncEvent event)
      Notifies this AsyncListener that an asynchronous operation has timed out.

    • Method Detail

      • onComplete

        void onComplete(AsyncEvent event)
                throws IOException
        Notifies this AsyncListener that an asynchronous operation has been completed.

        The AsyncContext corresponding to the asynchronous operation that has been completed may be obtained by calling getAsyncContext on the given event.

        In addition, if this AsyncListener had been registered via a call to AsyncContext.addListener(AsyncListener, ServletRequest, ServletResponse), the supplied ServletRequest and ServletResponse objects may be retrieved by calling getSuppliedRequest and getSuppliedResponse, respectively, on the given event.

        Parameters:
        event - the AsyncEvent indicating that an asynchronous operation has been completed
        Throws:
        IOException - if an I/O related error has occurred during the processing of the given AsyncEvent

      • onTimeout

        void onTimeout(AsyncEvent event)
               throws IOException
        Notifies this AsyncListener that an asynchronous operation has timed out.

        The AsyncContext corresponding to the asynchronous operation that has timed out may be obtained by calling getAsyncContext on the given event.

        In addition, if this AsyncListener had been registered via a call to AsyncContext.addListener(AsyncListener, ServletRequest, ServletResponse), the supplied ServletRequest and ServletResponse objects may be retrieved by calling getSuppliedRequest and getSuppliedResponse, respectively, on the given event.

        Parameters:
        event - the AsyncEvent indicating that an asynchronous operation has timed out
        Throws:
        IOException - if an I/O related error has occurred during the processing of the given AsyncEvent

      • onError

        void onError(AsyncEvent event)
             throws IOException
        Notifies this AsyncListener that an asynchronous operation has failed to complete.

        The AsyncContext corresponding to the asynchronous operation that failed to complete may be obtained by calling getAsyncContext on the given event.

        In addition, if this AsyncListener had been registered via a call to AsyncContext.addListener(AsyncListener, ServletRequest, ServletResponse), the supplied ServletRequest and ServletResponse objects may be retrieved by calling getSuppliedRequest and getSuppliedResponse, respectively, on the given event.

        Parameters:
        event - the AsyncEvent indicating that an asynchronous operation has failed to complete
        Throws:
        IOException - if an I/O related error has occurred during the processing of the given AsyncEvent

      • onStartAsync

        void onStartAsync(AsyncEvent event)
                  throws IOException
        Notifies this AsyncListener that a new asynchronous cycle is being initiated via a call to one of the ServletRequest.startAsync() methods.

        The AsyncContext corresponding to the asynchronous operation that is being reinitialized may be obtained by calling getAsyncContext on the given event.

        In addition, if this AsyncListener had been registered via a call to AsyncContext.addListener(AsyncListener, ServletRequest, ServletResponse), the supplied ServletRequest and ServletResponse objects may be retrieved by calling getSuppliedRequest and getSuppliedResponse, respectively, on the given event.

        This AsyncListener will not receive any events related to the new asynchronous cycle unless it registers itself (via a call to AsyncContext.addListener(javax.servlet.AsyncListener)) with the AsyncContext that is delivered as part of the given AsyncEvent.

        Parameters:
        event - the AsyncEvent indicating that a new asynchronous cycle is being initiated
        Throws:
        IOException - if an I/O related error has occurred during the processing of the given AsyncEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DispatcherType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.servlet

Enum DispatcherType

  • java.lang.Object
    • java.lang.Enum<DispatcherType>
      • javax.servlet.DispatcherType
  • All Implemented Interfaces:
    Serializable, Comparable<DispatcherType>

    public enum DispatcherType
extends Enum<DispatcherType>
    Enumeration of filter dispatcher types.
    Since:
    Servlet 3.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ASYNC
      ERROR
      FORWARD
      INCLUDE
      REQUEST

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static DispatcherType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static DispatcherType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • FORWARD

        public static final DispatcherType FORWARD

      • INCLUDE

        public static final DispatcherType INCLUDE

      • REQUEST

        public static final DispatcherType REQUEST

      • ASYNC

        public static final DispatcherType ASYNC

      • ERROR

        public static final DispatcherType ERROR

    • Method Detail

      • values

        public static DispatcherType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (DispatcherType c : DispatcherType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static DispatcherType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Filter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface Filter

  • public interface Filter
    A filter is an object that performs filtering tasks on either the request to a resource (a servlet or static content), or on the response from a resource, or both.

    Filters perform filtering in the doFilter method. Every Filter has access to a FilterConfig object from which it can obtain its initialization parameters, and a reference to the ServletContext which it can use, for example, to load resources needed for filtering tasks.

    Filters are configured in the deployment descriptor of a web application.

    Examples that have been identified for this design are:

    1. Authentication Filters
    2. Logging and Auditing Filters
    3. Image conversion Filters
    4. Data compression Filters
    5. Encryption Filters
    6. Tokenizing Filters
    7. Filters that trigger resource access events
    8. XSL/T filters
    9. Mime-type chain Filter
    Since:
    Servlet 2.3

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      Called by the web container to indicate to a filter that it is being taken out of service.
      void doFilter(ServletRequest request, ServletResponse response, FilterChain chain)
      The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain.
      void init(FilterConfig filterConfig)
      Called by the web container to indicate to a filter that it is being placed into service.

    • Method Detail

      • init

        void init(FilterConfig filterConfig)
          throws ServletException
        Called by the web container to indicate to a filter that it is being placed into service.

        The servlet container calls the init method exactly once after instantiating the filter. The init method must complete successfully before the filter is asked to do any filtering work.

        The web container cannot place the filter into service if the init method either

        1. Throws a ServletException
        2. Does not return within a time period defined by the web container
        Throws:
        ServletException

      • doFilter

        void doFilter(ServletRequest request,
            ServletResponse response,
            FilterChain chain)
              throws IOException,
                     ServletException
        The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain. The FilterChain passed in to this method allows the Filter to pass on the request and response to the next entity in the chain.

        A typical implementation of this method would follow the following pattern:

        1. Examine the request
        2. Optionally wrap the request object with a custom implementation to filter content or headers for input filtering
        3. Optionally wrap the response object with a custom implementation to filter content or headers for output filtering
          • Either invoke the next entity in the chain using the FilterChain object (chain.doFilter()),
          • or not pass on the request/response pair to the next entity in the filter chain to block the request processing
        5. Directly set headers on the response after invocation of the next entity in the filter chain.
        Throws:
        IOException
        ServletException

      • destroy

        void destroy()
        Called by the web container to indicate to a filter that it is being taken out of service.

        This method is only called once all threads within the filter's doFilter method have exited or after a timeout period has passed. After the web container calls this method, it will not call the doFilter method again on this instance of the filter.

        This method gives the filter an opportunity to clean up any resources that are being held (for example, memory, file handles, threads) and make sure that any persistent state is synchronized with the filter's current state in memory.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FilterChain (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface FilterChain

  • public interface FilterChain
    A FilterChain is an object provided by the servlet container to the developer giving a view into the invocation chain of a filtered request for a resource. Filters use the FilterChain to invoke the next filter in the chain, or if the calling filter is the last filter in the chain, to invoke the resource at the end of the chain.
    Since:
    Servlet 2.3
    See Also:
    Filter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void doFilter(ServletRequest request, ServletResponse response)
      Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.

    • Method Detail

      • doFilter

        void doFilter(ServletRequest request,
            ServletResponse response)
              throws IOException,
                     ServletException
        Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.
        Parameters:
        request - the request to pass along the chain.
        response - the response to pass along the chain.
        Throws:
        IOException
        ServletException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FilterConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface FilterConfig

  • public interface FilterConfig
    A filter configuration object used by a servlet container to pass information to a filter during initialization.
    Since:
    Servlet 2.3
    See Also:
    Filter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFilterName()
      Returns the filter-name of this filter as defined in the deployment descriptor.
      String getInitParameter(String name)
      Returns a String containing the value of the named initialization parameter, or null if the initialization parameter does not exist.
      Enumeration<String> getInitParameterNames()
      Returns the names of the filter's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the filter has no initialization parameters.
      ServletContext getServletContext()
      Returns a reference to the ServletContext in which the caller is executing.

    • Method Detail

      • getFilterName

        String getFilterName()
        Returns the filter-name of this filter as defined in the deployment descriptor.

      • getServletContext

        ServletContext getServletContext()
        Returns a reference to the ServletContext in which the caller is executing.
        Returns:
        a ServletContext object, used by the caller to interact with its servlet container
        See Also:
        ServletContext

      • getInitParameter

        String getInitParameter(String name)
        Returns a String containing the value of the named initialization parameter, or null if the initialization parameter does not exist.
        Parameters:
        name - a String specifying the name of the initialization parameter
        Returns:
        a String containing the value of the initialization parameter, or null if the initialization parameter does not exist

      • getInitParameterNames

        Enumeration<String> getInitParameterNames()
        Returns the names of the filter's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the filter has no initialization parameters.
        Returns:
        an Enumeration of String objects containing the names of the filter's initialization parameters
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FilterRegistration (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface FilterRegistration

  • All Superinterfaces:
    Registration
    All Known Subinterfaces:
    FilterRegistration.Dynamic

    public interface FilterRegistration
extends Registration
    Interface through which a Filter may be further configured.
    Since:
    Servlet 3.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  FilterRegistration.Dynamic
      Interface through which a Filter registered via one of the addFilter methods on ServletContext may be further configured.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addMappingForServletNames(EnumSet<DispatcherType> dispatcherTypes, boolean isMatchAfter, String... servletNames)
      Adds a filter mapping with the given servlet names and dispatcher types for the Filter represented by this FilterRegistration.
      void addMappingForUrlPatterns(EnumSet<DispatcherType> dispatcherTypes, boolean isMatchAfter, String... urlPatterns)
      Adds a filter mapping with the given url patterns and dispatcher types for the Filter represented by this FilterRegistration.
      Collection<String> getServletNameMappings()
      Gets the currently available servlet name mappings of the Filter represented by this FilterRegistration.
      Collection<String> getUrlPatternMappings()
      Gets the currently available URL pattern mappings of the Filter represented by this FilterRegistration.

      • Methods inherited from interface javax.servlet.Registration

        getClassName, getInitParameter, getInitParameters, getName, setInitParameter, setInitParameters

    • Method Detail

      • addMappingForServletNames

        void addMappingForServletNames(EnumSet<DispatcherType> dispatcherTypes,
                             boolean isMatchAfter,
                             String... servletNames)
        Adds a filter mapping with the given servlet names and dispatcher types for the Filter represented by this FilterRegistration.

        Filter mappings are matched in the order in which they were added.

        Depending on the value of the isMatchAfter parameter, the given filter mapping will be considered after or before any declared filter mappings of the ServletContext from which this FilterRegistration was obtained.

        If this method is called multiple times, each successive call adds to the effects of the former.

        Parameters:
        dispatcherTypes - the dispatcher types of the filter mapping, or null if the default DispatcherType.REQUEST is to be used
        isMatchAfter - true if the given filter mapping should be matched after any declared filter mappings, and false if it is supposed to be matched before any declared filter mappings of the ServletContext from which this FilterRegistration was obtained
        servletNames - the servlet names of the filter mapping
        Throws:
        IllegalArgumentException - if servletNames is null or empty
        IllegalStateException - if the ServletContext from which this FilterRegistration was obtained has already been initialized

      • getServletNameMappings

        Collection<String> getServletNameMappings()
        Gets the currently available servlet name mappings of the Filter represented by this FilterRegistration.

        If permitted, any changes to the returned Collection must not affect this FilterRegistration.

        Returns:
        a (possibly empty) Collection of the currently available servlet name mappings of the Filter represented by this FilterRegistration

      • addMappingForUrlPatterns

        void addMappingForUrlPatterns(EnumSet<DispatcherType> dispatcherTypes,
                            boolean isMatchAfter,
                            String... urlPatterns)
        Adds a filter mapping with the given url patterns and dispatcher types for the Filter represented by this FilterRegistration.

        Filter mappings are matched in the order in which they were added.

        Depending on the value of the isMatchAfter parameter, the given filter mapping will be considered after or before any declared filter mappings of the ServletContext from which this FilterRegistration was obtained.

        If this method is called multiple times, each successive call adds to the effects of the former.

        Parameters:
        dispatcherTypes - the dispatcher types of the filter mapping, or null if the default DispatcherType.REQUEST is to be used
        isMatchAfter - true if the given filter mapping should be matched after any declared filter mappings, and false if it is supposed to be matched before any declared filter mappings of the ServletContext from which this FilterRegistration was obtained
        urlPatterns - the url patterns of the filter mapping
        Throws:
        IllegalArgumentException - if urlPatterns is null or empty
        IllegalStateException - if the ServletContext from which this FilterRegistration was obtained has already been initialized

      • getUrlPatternMappings

        Collection<String> getUrlPatternMappings()
        Gets the currently available URL pattern mappings of the Filter represented by this FilterRegistration.

        If permitted, any changes to the returned Collection must not affect this FilterRegistration.

        Returns:
        a (possibly empty) Collection of the currently available URL pattern mappings of the Filter represented by this FilterRegistration
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FilterRegistration.Dynamic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface FilterRegistration.Dynamic

  • All Superinterfaces:
    FilterRegistration, Registration, Registration.Dynamic
    Enclosing interface:
    FilterRegistration

    public static interface FilterRegistration.Dynamic
extends FilterRegistration, Registration.Dynamic
    Interface through which a Filter registered via one of the addFilter methods on ServletContext may be further configured.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.servlet.FilterRegistration

        FilterRegistration.Dynamic

    • Method Summary

      • Methods inherited from interface javax.servlet.FilterRegistration

        addMappingForServletNames, addMappingForUrlPatterns, getServletNameMappings, getUrlPatternMappings

      • Methods inherited from interface javax.servlet.Registration.Dynamic

        setAsyncSupported

      • Methods inherited from interface javax.servlet.Registration

        getClassName, getInitParameter, getInitParameters, getName, setInitParameter, setInitParameters
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


GenericServlet (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class GenericServlet

  • java.lang.Object
    • javax.servlet.GenericServlet
  • All Implemented Interfaces:
    Serializable, Servlet, ServletConfig
    Direct Known Subclasses:
    HttpServlet

    public abstract class GenericServlet
extends Object
implements Servlet, ServletConfig, Serializable
    Defines a generic, protocol-independent servlet. To write an HTTP servlet for use on the Web, extend HttpServlet instead.

    GenericServlet implements the Servlet and ServletConfig interfaces. GenericServlet may be directly extended by a servlet, although it's more common to extend a protocol-specific subclass such as HttpServlet.

    GenericServlet makes writing servlets easier. It provides simple versions of the lifecycle methods init and destroy and of the methods in the ServletConfig interface. GenericServlet also implements the log method, declared in the ServletContext interface.

    To write a generic servlet, you need only override the abstract service method.

    Author:
    Various
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      GenericServlet()
      Does nothing.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.
      String getInitParameter(String name)
      Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
      Enumeration<String> getInitParameterNames()
      Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
      ServletConfig getServletConfig()
      Returns this servlet's ServletConfig object.
      ServletContext getServletContext()
      Returns a reference to the ServletContext in which this servlet is running.
      String getServletInfo()
      Returns information about the servlet, such as author, version, and copyright.
      String getServletName()
      Returns the name of this servlet instance.
      void init()
      A convenience method which can be overridden so that there's no need to call super.init(config).
      void init(ServletConfig config)
      Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
      void log(String msg)
      Writes the specified message to a servlet log file, prepended by the servlet's name.
      void log(String message, Throwable t)
      Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file, prepended by the servlet's name.
      abstract void service(ServletRequest req, ServletResponse res)
      Called by the servlet container to allow the servlet to respond to a request.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • GenericServlet

        public GenericServlet()
        Does nothing. All of the servlet initialization is done by one of the init methods.

    • Method Detail

      • destroy

        public void destroy()
        Called by the servlet container to indicate to a servlet that the servlet is being taken out of service. See Servlet.destroy().
        Specified by:
        destroy in interface Servlet

      • getInitParameter

        public String getInitParameter(String name)
        Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist. See ServletConfig.getInitParameter(java.lang.String).

        This method is supplied for convenience. It gets the value of the named parameter from the servlet's ServletConfig object.

        Specified by:
        getInitParameter in interface ServletConfig
        Parameters:
        name - a String specifying the name of the initialization parameter
        Returns:
        String a String containing the value of the initialization parameter

      • getInitParameterNames

        public Enumeration<String> getInitParameterNames()
        Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters. See ServletConfig.getInitParameterNames().

        This method is supplied for convenience. It gets the parameter names from the servlet's ServletConfig object.

        Specified by:
        getInitParameterNames in interface ServletConfig
        Returns:
        Enumeration an enumeration of String objects containing the names of the servlet's initialization parameters

      • getServletConfig

        public ServletConfig getServletConfig()
        Returns this servlet's ServletConfig object.
        Specified by:
        getServletConfig in interface Servlet
        Returns:
        ServletConfig the ServletConfig object that initialized this servlet
        See Also:
        Servlet.init(javax.servlet.ServletConfig)

      • getServletContext

        public ServletContext getServletContext()
        Returns a reference to the ServletContext in which this servlet is running. See ServletConfig.getServletContext().

        This method is supplied for convenience. It gets the context from the servlet's ServletConfig object.

        Specified by:
        getServletContext in interface ServletConfig
        Returns:
        ServletContext the ServletContext object passed to this servlet by the init method
        See Also:
        ServletContext

      • getServletInfo

        public String getServletInfo()
        Returns information about the servlet, such as author, version, and copyright. By default, this method returns an empty string. Override this method to have it return a meaningful value. See Servlet.getServletInfo().
        Specified by:
        getServletInfo in interface Servlet
        Returns:
        String information about this servlet, by default an empty string

      • init

        public void init(ServletConfig config)
          throws ServletException
        Called by the servlet container to indicate to a servlet that the servlet is being placed into service. See Servlet.init(javax.servlet.ServletConfig).

        This implementation stores the ServletConfig object it receives from the servlet container for later use. When overriding this form of the method, call super.init(config).

        Specified by:
        init in interface Servlet
        Parameters:
        config - the ServletConfig object that contains configutation information for this servlet
        Throws:
        ServletException - if an exception occurs that interrupts the servlet's normal operation
        See Also:
        UnavailableException

      • init

        public void init()
          throws ServletException
        A convenience method which can be overridden so that there's no need to call super.init(config).

        Instead of overriding init(ServletConfig), simply override this method and it will be called by GenericServlet.init(ServletConfig config). The ServletConfig object can still be retrieved via getServletConfig().

        Throws:
        ServletException - if an exception occurs that interrupts the servlet's normal operation

      • log

        public void log(String msg)
        Writes the specified message to a servlet log file, prepended by the servlet's name. See ServletContext.log(String).
        Parameters:
        msg - a String specifying the message to be written to the log file

      • log

        public void log(String message,
       Throwable t)
        Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file, prepended by the servlet's name. See ServletContext.log(String, Throwable).
        Parameters:
        message - a String that describes the error or exception
        t - the java.lang.Throwable error or exception

      • service

        public abstract void service(ServletRequest req,
           ServletResponse res)
                      throws ServletException,
                             IOException
        Called by the servlet container to allow the servlet to respond to a request. See Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse).

        This method is declared abstract so subclasses, such as HttpServlet, must override it.

        Specified by:
        service in interface Servlet
        Parameters:
        req - the ServletRequest object that contains the client's request
        res - the ServletResponse object that will contain the servlet's response
        Throws:
        ServletException - if an exception occurs that interferes with the servlet's normal operation occurred
        IOException - if an input or output exception occurs

      • getServletName

        public String getServletName()
        Returns the name of this servlet instance. See ServletConfig.getServletName().
        Specified by:
        getServletName in interface ServletConfig
        Returns:
        the name of this servlet instance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpConstraintElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class HttpConstraintElement

  • java.lang.Object
    • javax.servlet.HttpConstraintElement
  • Direct Known Subclasses:
    HttpMethodConstraintElement, ServletSecurityElement

    public class HttpConstraintElement
extends Object
    Java Class representation of an HttpConstraint annotation value.
    Since:
    Servlet 3.0

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpConstraintElement()
      Constructs a default HTTP constraint element
      HttpConstraintElement(ServletSecurity.EmptyRoleSemantic semantic)
      Convenience constructor to establish EmptyRoleSemantic.DENY
      HttpConstraintElement(ServletSecurity.EmptyRoleSemantic semantic, ServletSecurity.TransportGuarantee guarantee, String... roleNames)
      Constructor to establish all of getEmptyRoleSemantic, getRolesAllowed, and getTransportGuarantee.
      HttpConstraintElement(ServletSecurity.TransportGuarantee guarantee, String... roleNames)
      Constructor to establish non-empty getRolesAllowed and/or TransportGuarantee.CONFIDENTIAL.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ServletSecurity.EmptyRoleSemantic getEmptyRoleSemantic()
      Gets the default authorization semantic.
      String[] getRolesAllowed()
      Gets the names of the authorized roles.
      ServletSecurity.TransportGuarantee getTransportGuarantee()
      Gets the data protection requirement (i.e., whether or not SSL/TLS is required) that must be satisfied by the transport connection.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HttpConstraintElement

        public HttpConstraintElement()
        Constructs a default HTTP constraint element

      • HttpConstraintElement

        public HttpConstraintElement(ServletSecurity.EmptyRoleSemantic semantic)
        Convenience constructor to establish EmptyRoleSemantic.DENY
        Parameters:
        semantic - should be EmptyRoleSemantic.DENY

      • HttpConstraintElement

        public HttpConstraintElement(ServletSecurity.TransportGuarantee guarantee,
                     String... roleNames)
        Constructor to establish non-empty getRolesAllowed and/or TransportGuarantee.CONFIDENTIAL.
        Parameters:
        guarantee - TransportGuarantee.NONE or TransportGuarantee.CONFIDENTIAL
        roleNames - the names of the roles that are to be allowed access

      • HttpConstraintElement

        public HttpConstraintElement(ServletSecurity.EmptyRoleSemantic semantic,
                     ServletSecurity.TransportGuarantee guarantee,
                     String... roleNames)
        Constructor to establish all of getEmptyRoleSemantic, getRolesAllowed, and getTransportGuarantee.
        Parameters:
        semantic - EmptyRoleSemantic.DENY or EmptyRoleSemantic.PERMIT
        guarantee - TransportGuarantee.NONE or TransportGuarantee.CONFIDENTIAL
        roleNames - the names of the roles that are to be allowed access, or missing if the semantic is EmptyRoleSemantic.DENY

    • Method Detail

      • getEmptyRoleSemantic

        public ServletSecurity.EmptyRoleSemantic getEmptyRoleSemantic()
        Gets the default authorization semantic.

        This value is insignificant when getRolesAllowed returns a non-empty array, and should not be specified when a non-empty array is specified for getRolesAllowed.

        Returns:
        the ServletSecurity.EmptyRoleSemantic to be applied when getRolesAllowed returns an empty (that is, zero-length) array

      • getTransportGuarantee

        public ServletSecurity.TransportGuarantee getTransportGuarantee()
        Gets the data protection requirement (i.e., whether or not SSL/TLS is required) that must be satisfied by the transport connection.
        Returns:
        the ServletSecurity.TransportGuarantee indicating the data protection that must be provided by the connection

      • getRolesAllowed

        public String[] getRolesAllowed()
        Gets the names of the authorized roles.

        Duplicate role names appearing in getRolesAllowed are insignificant and may be discarded. The String "*" has no special meaning as a role name (should it occur in getRolesAllowed).

        Returns:
        a (possibly empty) array of role names. When the array is empty, its meaning depends on the value of getEmptyRoleSemantic(). If its value is DENY, and getRolesAllowed returns an empty array, access is to be denied independent of authentication state and identity. Conversely, if its value is PERMIT, it indicates that access is to be allowed independent of authentication state and identity. When the array contains the names of one or more roles, it indicates that access is contingent on membership in at least one of the named roles (independent of the value of getEmptyRoleSemantic()).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpMethodConstraintElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class HttpMethodConstraintElement

  • java.lang.Object
    • javax.servlet.HttpConstraintElement
      • javax.servlet.HttpMethodConstraintElement

  • public class HttpMethodConstraintElement
extends HttpConstraintElement
    Java Class represntation of an HttpMethodConstraint annotation value.
    Since:
    Servlet 3.0

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpMethodConstraintElement(String methodName)
      Constructs an instance with default HttpConstraintElement value.
      HttpMethodConstraintElement(String methodName, HttpConstraintElement constraint)
      Constructs an instance with specified HttpConstraintElement value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getMethodName()
      Gets the HTTP method name.

      • Methods inherited from class javax.servlet.HttpConstraintElement

        getEmptyRoleSemantic, getRolesAllowed, getTransportGuarantee

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HttpMethodConstraintElement

        public HttpMethodConstraintElement(String methodName)
        Constructs an instance with default HttpConstraintElement value.
        Parameters:
        methodName - the name of an HTTP protocol method. The name must not be null, or the empty string, and must be a legitimate HTTP Method name as defined by RFC 2616

      • HttpMethodConstraintElement

        public HttpMethodConstraintElement(String methodName,
                           HttpConstraintElement constraint)
        Constructs an instance with specified HttpConstraintElement value.
        Parameters:
        methodName - the name of an HTTP protocol method. The name must not be null, or the empty string, and must be a legitimate HTTP Method name as defined by RFC 2616
        constraint - the HTTPconstraintElement value to assign to the named HTTP method

    • Method Detail

      • getMethodName

        public String getMethodName()
        Gets the HTTP method name.
        Returns:
        the Http method name
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.servlet (Java(TM) EE 7 Specification APIs)

javax.servlet

Interfaces

  • AsyncContext
  • AsyncListener
  • Filter
  • FilterChain
  • FilterConfig
  • FilterRegistration
  • FilterRegistration.Dynamic
  • ReadListener
  • Registration
  • Registration.Dynamic
  • RequestDispatcher
  • Servlet
  • ServletConfig
  • ServletContainerInitializer
  • ServletContext
  • ServletContextAttributeListener
  • ServletContextListener
  • ServletRegistration
  • ServletRegistration.Dynamic
  • ServletRequest
  • ServletRequestAttributeListener
  • ServletRequestListener
  • ServletResponse
  • SessionCookieConfig
  • SingleThreadModel
  • WriteListener

Classes

  • AsyncEvent
  • GenericServlet
  • HttpConstraintElement
  • HttpMethodConstraintElement
  • MultipartConfigElement
  • ServletContextAttributeEvent
  • ServletContextEvent
  • ServletInputStream
  • ServletOutputStream
  • ServletRequestAttributeEvent
  • ServletRequestEvent
  • ServletRequestWrapper
  • ServletResponseWrapper
  • ServletSecurityElement

Enums

  • DispatcherType
  • SessionTrackingMode

Exceptions

  • ServletException
  • UnavailableException


javax.servlet (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet

The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

See: Description

  • Interface Summary
    Interface Description
    AsyncContext
    Class representing the execution context for an asynchronous operation that was initiated on a ServletRequest.
    AsyncListener
    Listener that will be notified in the event that an asynchronous operation initiated on a ServletRequest to which the listener had been added has completed, timed out, or resulted in an error.
    Filter
    A filter is an object that performs filtering tasks on either the request to a resource (a servlet or static content), or on the response from a resource, or both.
    FilterChain
    A FilterChain is an object provided by the servlet container to the developer giving a view into the invocation chain of a filtered request for a resource.
    FilterConfig
    A filter configuration object used by a servlet container to pass information to a filter during initialization.
    FilterRegistration
    Interface through which a Filter may be further configured.
    FilterRegistration.Dynamic
    Interface through which a Filter registered via one of the addFilter methods on ServletContext may be further configured.
    ReadListener
    This class represents a call-back mechanism that will notify implementations as HTTP request data becomes available to be read without blocking.
    Registration
    Interface through which a Servlet or Filter may be further configured.
    Registration.Dynamic
    Interface through which a Servlet or Filter registered via one of the addServlet or addFilter methods, respectively, on ServletContext may be further configured.
    RequestDispatcher
    Defines an object that receives requests from the client and sends them to any resource (such as a servlet, HTML file, or JSP file) on the server.
    Servlet
    Defines methods that all servlets must implement.
    ServletConfig
    A servlet configuration object used by a servlet container to pass information to a servlet during initialization.
    ServletContainerInitializer
    Interface which allows a library/runtime to be notified of a web application's startup phase and perform any required programmatic registration of servlets, filters, and listeners in response to it.
    ServletContext
    Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.
    ServletContextAttributeListener
    Interface for receiving notification events about ServletContext attribute changes.
    ServletContextListener
    Interface for receiving notification events about ServletContext lifecycle changes.
    ServletRegistration
    Interface through which a Servlet may be further configured.
    ServletRegistration.Dynamic
    Interface through which a Servlet registered via one of the addServlet methods on ServletContext may be further configured.
    ServletRequest
    Defines an object to provide client request information to a servlet.
    ServletRequestAttributeListener
    Interface for receiving notification events about ServletRequest attribute changes.
    ServletRequestListener
    Interface for receiving notification events about requests coming into and going out of scope of a web application.
    ServletResponse
    Defines an object to assist a servlet in sending a response to the client.
    SessionCookieConfig
    Class that may be used to configure various properties of cookies used for session tracking purposes.
    SingleThreadModel Deprecated
    As of Java Servlet API 2.4, with no direct replacement.
    WriteListener
    Callback notification mechanism that signals to the developer it's possible to write content without blocking.
  • Class Summary
    Class Description
    AsyncEvent
    Event that gets fired when the asynchronous operation initiated on a ServletRequest (via a call to ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse)) has completed, timed out, or produced an error.
    GenericServlet
    Defines a generic, protocol-independent servlet.
    HttpConstraintElement
    Java Class representation of an HttpConstraint annotation value.
    HttpMethodConstraintElement
    Java Class represntation of an HttpMethodConstraint annotation value.
    MultipartConfigElement
    Java Class represntation of an MultipartConfig annotation value.
    ServletContextAttributeEvent
    Event class for notifications about changes to the attributes of the ServletContext of a web application.
    ServletContextEvent
    This is the event class for notifications about changes to the servlet context of a web application.
    ServletInputStream
    Provides an input stream for reading binary data from a client request, including an efficient readLine method for reading data one line at a time.
    ServletOutputStream
    Provides an output stream for sending binary data to the client.
    ServletRequestAttributeEvent
    This is the event class for notifications of changes to the attributes of the servlet request in an application.
    ServletRequestEvent
    Events of this kind indicate lifecycle events for a ServletRequest.
    ServletRequestWrapper
    Provides a convenient implementation of the ServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
    ServletResponseWrapper
    Provides a convenient implementation of the ServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
    ServletSecurityElement
    Java Class represntation of a ServletSecurity annotation value.
  • Enum Summary
    Enum Description
    DispatcherType
    Enumeration of filter dispatcher types.
    SessionTrackingMode
    Enumeration of session tracking modes.
  • Exception Summary
    Exception Description
    ServletException
    Defines a general exception a servlet can throw when it encounters difficulty.
    UnavailableException
    Defines an exception that a servlet or filter throws to indicate that it is permanently or temporarily unavailable.

Package javax.servlet Description

The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.AsyncEvent
    • java.util.EventObject (implements java.io.Serializable)
      • javax.servlet.ServletContextEvent
        • javax.servlet.ServletContextAttributeEvent
      • javax.servlet.ServletRequestEvent
        • javax.servlet.ServletRequestAttributeEvent
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
    • javax.servlet.HttpConstraintElement
      • javax.servlet.HttpMethodConstraintElement
      • javax.servlet.ServletSecurityElement
    • java.io.InputStream (implements java.io.Closeable)
      • javax.servlet.ServletInputStream
    • javax.servlet.MultipartConfigElement
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • javax.servlet.ServletOutputStream
    • javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
    • javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.servlet.ServletException
          • javax.servlet.UnavailableException

Interface Hierarchy

  • javax.servlet.AsyncContext
  • java.util.EventListener
    • javax.servlet.AsyncListener
    • javax.servlet.ReadListener
    • javax.servlet.ServletContextAttributeListener
    • javax.servlet.ServletContextListener
    • javax.servlet.ServletRequestAttributeListener
    • javax.servlet.ServletRequestListener
    • javax.servlet.WriteListener
  • javax.servlet.Filter
  • javax.servlet.FilterChain
  • javax.servlet.FilterConfig
  • javax.servlet.Registration
    • javax.servlet.FilterRegistration
      • javax.servlet.FilterRegistration.Dynamic (also extends javax.servlet.Registration.Dynamic)
    • javax.servlet.Registration.Dynamic
      • javax.servlet.FilterRegistration.Dynamic (also extends javax.servlet.FilterRegistration)
      • javax.servlet.ServletRegistration.Dynamic (also extends javax.servlet.ServletRegistration)
    • javax.servlet.ServletRegistration
      • javax.servlet.ServletRegistration.Dynamic (also extends javax.servlet.Registration.Dynamic)
  • javax.servlet.RequestDispatcher
  • javax.servlet.Servlet
  • javax.servlet.ServletConfig
  • javax.servlet.ServletContainerInitializer
  • javax.servlet.ServletContext
  • javax.servlet.ServletRequest
  • javax.servlet.ServletResponse
  • javax.servlet.SessionCookieConfig
  • javax.servlet.SingleThreadModel

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.servlet.SessionTrackingMode
      • javax.servlet.DispatcherType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MultipartConfigElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class MultipartConfigElement

  • java.lang.Object
    • javax.servlet.MultipartConfigElement

  • public class MultipartConfigElement
extends Object
    Java Class represntation of an MultipartConfig annotation value.
    Since:
    Servlet 3.0

    • Constructor Summary

      Constructors
      Constructor and Description
      MultipartConfigElement(MultipartConfig annotation)
      Constructs an instance from a MultipartConfig annotation value.
      MultipartConfigElement(String location)
      Constructs an instance with defaults for all but location.
      MultipartConfigElement(String location, long maxFileSize, long maxRequestSize, int fileSizeThreshold)
      Constructs an instance with all values specified.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getFileSizeThreshold()
      Gets the size threshold after which files will be written to disk.
      String getLocation()
      Gets the directory location where files will be stored.
      long getMaxFileSize()
      Gets the maximum size allowed for uploaded files.
      long getMaxRequestSize()
      Gets the maximum size allowed for multipart/form-data requests.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MultipartConfigElement

        public MultipartConfigElement(String location)
        Constructs an instance with defaults for all but location.
        Parameters:
        location - defualts to "" if values is null.

      • MultipartConfigElement

        public MultipartConfigElement(String location,
                      long maxFileSize,
                      long maxRequestSize,
                      int fileSizeThreshold)
        Constructs an instance with all values specified.
        Parameters:
        location - the directory location where files will be stored
        maxFileSize - the maximum size allowed for uploaded files
        maxRequestSize - the maximum size allowed for multipart/form-data requests
        fileSizeThreshold - the size threshold after which files will be written to disk

      • MultipartConfigElement

        public MultipartConfigElement(MultipartConfig annotation)
        Constructs an instance from a MultipartConfig annotation value.
        Parameters:
        annotation - the annotation value

    • Method Detail

      • getLocation

        public String getLocation()
        Gets the directory location where files will be stored.
        Returns:
        the directory location where files will be stored

      • getMaxFileSize

        public long getMaxFileSize()
        Gets the maximum size allowed for uploaded files.
        Returns:
        the maximum size allowed for uploaded files

      • getMaxRequestSize

        public long getMaxRequestSize()
        Gets the maximum size allowed for multipart/form-data requests.
        Returns:
        the maximum size allowed for multipart/form-data requests

      • getFileSizeThreshold

        public int getFileSizeThreshold()
        Gets the size threshold after which files will be written to disk.
        Returns:
        the size threshold after which files will be written to disk
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ReadListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ReadListener

  • All Superinterfaces:
    EventListener

    public interface ReadListener
extends EventListener

    This class represents a call-back mechanism that will notify implementations as HTTP request data becomes available to be read without blocking.

    Since:
    Servlet 3.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onAllDataRead()
      Invoked when all data for the current request has been read.
      void onDataAvailable()
      When an instance of the ReadListener is registered with a ServletInputStream, this method will be invoked by the container the first time when it is possible to read data.
      void onError(Throwable t)
      Invoked when an error occurs processing the request.

    • Method Detail

      • onDataAvailable

        void onDataAvailable()
                     throws IOException
        When an instance of the ReadListener is registered with a ServletInputStream, this method will be invoked by the container the first time when it is possible to read data. Subsequently the container will invoke this method if and only if ServletInputStream.isReady() method has been called and has returned false.
        Throws:
        IOException - if an I/O related error has occurred during processing

      • onAllDataRead

        void onAllDataRead()
                   throws IOException
        Invoked when all data for the current request has been read.
        Throws:
        IOException - if an I/O related error has occurred during processing

      • onError

        void onError(Throwable t)
        Invoked when an error occurs processing the request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Registration (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface Registration

  • All Known Subinterfaces:
    FilterRegistration, FilterRegistration.Dynamic, Registration.Dynamic, ServletRegistration, ServletRegistration.Dynamic

    public interface Registration
    Interface through which a Servlet or Filter may be further configured.

    A Registration object whose getClassName() method returns null is considered preliminary. Servlets and Filters whose implementation class is container implementation specific may be declared without any servlet-class or filter-class elements, respectively, and will be represented as preliminary Registration objects. Preliminary registrations must be completed by calling one of the addServlet or addFilter methods on ServletContext, and passing in the Servlet or Filter name (obtained via getName()) along with the supporting Servlet or Filter implementation class name, Class object, or instance, respectively. In most cases, preliminary registrations will be completed by an appropriate, container-provided ServletContainerInitializer.

    Since:
    Servlet 3.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  Registration.Dynamic
      Interface through which a Servlet or Filter registered via one of the addServlet or addFilter methods, respectively, on ServletContext may be further configured.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getClassName()
      Gets the fully qualified class name of the Servlet or Filter that is represented by this Registration.
      String getInitParameter(String name)
      Gets the value of the initialization parameter with the given name that will be used to initialize the Servlet or Filter represented by this Registration object.
      Map<String,String> getInitParameters()
      Gets an immutable (and possibly empty) Map containing the currently available initialization parameters that will be used to initialize the Servlet or Filter represented by this Registration object.
      String getName()
      Gets the name of the Servlet or Filter that is represented by this Registration.
      boolean setInitParameter(String name, String value)
      Sets the initialization parameter with the given name and value on the Servlet or Filter that is represented by this Registration.
      Set<String> setInitParameters(Map<String,String> initParameters)
      Sets the given initialization parameters on the Servlet or Filter that is represented by this Registration.

    • Method Detail

      • getName

        String getName()
        Gets the name of the Servlet or Filter that is represented by this Registration.
        Returns:
        the name of the Servlet or Filter that is represented by this Registration

      • getClassName

        String getClassName()
        Gets the fully qualified class name of the Servlet or Filter that is represented by this Registration.
        Returns:
        the fully qualified class name of the Servlet or Filter that is represented by this Registration, or null if this Registration is preliminary

      • setInitParameter

        boolean setInitParameter(String name,
                       String value)
        Sets the initialization parameter with the given name and value on the Servlet or Filter that is represented by this Registration.
        Parameters:
        name - the initialization parameter name
        value - the initialization parameter value
        Returns:
        true if the update was successful, i.e., an initialization parameter with the given name did not already exist for the Servlet or Filter represented by this Registration, and false otherwise
        Throws:
        IllegalStateException - if the ServletContext from which this Registration was obtained has already been initialized
        IllegalArgumentException - if the given name or value is null

      • getInitParameter

        String getInitParameter(String name)
        Gets the value of the initialization parameter with the given name that will be used to initialize the Servlet or Filter represented by this Registration object.
        Parameters:
        name - the name of the initialization parameter whose value is requested
        Returns:
        the value of the initialization parameter with the given name, or null if no initialization parameter with the given name exists

      • setInitParameters

        Set<String> setInitParameters(Map<String,String> initParameters)
        Sets the given initialization parameters on the Servlet or Filter that is represented by this Registration.

        The given map of initialization parameters is processed by-value, i.e., for each initialization parameter contained in the map, this method calls setInitParameter(String,String). If that method would return false for any of the initialization parameters in the given map, no updates will be performed, and false will be returned. Likewise, if the map contains an initialization parameter with a null name or value, no updates will be performed, and an IllegalArgumentException will be thrown.

        Parameters:
        initParameters - the initialization parameters
        Returns:
        the (possibly empty) Set of initialization parameter names that are in conflict
        Throws:
        IllegalStateException - if the ServletContext from which this Registration was obtained has already been initialized
        IllegalArgumentException - if the given map contains an initialization parameter with a null name or value

      • getInitParameters

        Map<String,String> getInitParameters()
        Gets an immutable (and possibly empty) Map containing the currently available initialization parameters that will be used to initialize the Servlet or Filter represented by this Registration object.
        Returns:
        Map containing the currently available initialization parameters that will be used to initialize the Servlet or Filter represented by this Registration object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Registration.Dynamic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface Registration.Dynamic

  • All Superinterfaces:
    Registration
    All Known Subinterfaces:
    FilterRegistration.Dynamic, ServletRegistration.Dynamic
    Enclosing interface:
    Registration

    public static interface Registration.Dynamic
extends Registration
    Interface through which a Servlet or Filter registered via one of the addServlet or addFilter methods, respectively, on ServletContext may be further configured.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.servlet.Registration

        Registration.Dynamic

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void setAsyncSupported(boolean isAsyncSupported)
      Configures the Servlet or Filter represented by this dynamic Registration as supporting asynchronous operations or not.

      • Methods inherited from interface javax.servlet.Registration

        getClassName, getInitParameter, getInitParameters, getName, setInitParameter, setInitParameters

    • Method Detail

      • setAsyncSupported

        void setAsyncSupported(boolean isAsyncSupported)
        Configures the Servlet or Filter represented by this dynamic Registration as supporting asynchronous operations or not.

        By default, servlet and filters do not support asynchronous operations.

        A call to this method overrides any previous setting.

        Parameters:
        isAsyncSupported - true if the Servlet or Filter represented by this dynamic Registration supports asynchronous operations, false otherwise
        Throws:
        IllegalStateException - if the ServletContext from which this dynamic Registration was obtained has already been initialized
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RequestDispatcher (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface RequestDispatcher

  • public interface RequestDispatcher
    Defines an object that receives requests from the client and sends them to any resource (such as a servlet, HTML file, or JSP file) on the server. The servlet container creates the RequestDispatcher object, which is used as a wrapper around a server resource located at a particular path or given by a particular name.

    This interface is intended to wrap servlets, but a servlet container can create RequestDispatcher objects to wrap any type of resource.

    Author:
    Various
    See Also:
    ServletContext.getRequestDispatcher(java.lang.String),
ServletContext.getNamedDispatcher(java.lang.String),
ServletRequest.getRequestDispatcher(java.lang.String)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ERROR_EXCEPTION
      The name of the request attribute under which the exception object is propagated during an error dispatch
      static String ERROR_EXCEPTION_TYPE
      The name of the request attribute under which the type of the exception object is propagated during an error dispatch
      static String ERROR_MESSAGE
      The name of the request attribute under which the exception message is propagated during an error dispatch
      static String ERROR_REQUEST_URI
      The name of the request attribute under which the request URI whose processing caused the error is propagated during an error dispatch
      static String ERROR_SERVLET_NAME
      The name of the request attribute under which the name of the servlet in which the error occurred is propagated during an error dispatch
      static String ERROR_STATUS_CODE
      The name of the request attribute under which the response status is propagated during an error dispatch
      static String FORWARD_CONTEXT_PATH
      The name of the request attribute under which the original context path is made available to the target of a forward
      static String FORWARD_PATH_INFO
      The name of the request attribute under which the original path info is made available to the target of a forward
      static String FORWARD_QUERY_STRING
      The name of the request attribute under which the original query string is made available to the target of a forward
      static String FORWARD_REQUEST_URI
      The name of the request attribute under which the original request URI is made available to the target of a forward
      static String FORWARD_SERVLET_PATH
      The name of the request attribute under which the original servlet path is made available to the target of a forward
      static String INCLUDE_CONTEXT_PATH
      The name of the request attribute under which the context path of the target of an include is stored
      static String INCLUDE_PATH_INFO
      The name of the request attribute under which the path info of the target of an include is stored
      static String INCLUDE_QUERY_STRING
      The name of the request attribute under which the query string of the target of an include is stored
      static String INCLUDE_REQUEST_URI
      The name of the request attribute under which the request URI of the target of an include is stored
      static String INCLUDE_SERVLET_PATH
      The name of the request attribute under which the servlet path of the target of an include is stored

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void forward(ServletRequest request, ServletResponse response)
      Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server.
      void include(ServletRequest request, ServletResponse response)
      Includes the content of a resource (servlet, JSP page, HTML file) in the response.

    • Field Detail

      • FORWARD_REQUEST_URI

        static final String FORWARD_REQUEST_URI
        The name of the request attribute under which the original request URI is made available to the target of a forward
        See Also:
        Constant Field Values

      • FORWARD_CONTEXT_PATH

        static final String FORWARD_CONTEXT_PATH
        The name of the request attribute under which the original context path is made available to the target of a forward
        See Also:
        Constant Field Values

      • FORWARD_PATH_INFO

        static final String FORWARD_PATH_INFO
        The name of the request attribute under which the original path info is made available to the target of a forward
        See Also:
        Constant Field Values

      • FORWARD_SERVLET_PATH

        static final String FORWARD_SERVLET_PATH
        The name of the request attribute under which the original servlet path is made available to the target of a forward
        See Also:
        Constant Field Values

      • FORWARD_QUERY_STRING

        static final String FORWARD_QUERY_STRING
        The name of the request attribute under which the original query string is made available to the target of a forward
        See Also:
        Constant Field Values

      • INCLUDE_REQUEST_URI

        static final String INCLUDE_REQUEST_URI
        The name of the request attribute under which the request URI of the target of an include is stored
        See Also:
        Constant Field Values

      • INCLUDE_CONTEXT_PATH

        static final String INCLUDE_CONTEXT_PATH
        The name of the request attribute under which the context path of the target of an include is stored
        See Also:
        Constant Field Values

      • INCLUDE_PATH_INFO

        static final String INCLUDE_PATH_INFO
        The name of the request attribute under which the path info of the target of an include is stored
        See Also:
        Constant Field Values

      • INCLUDE_SERVLET_PATH

        static final String INCLUDE_SERVLET_PATH
        The name of the request attribute under which the servlet path of the target of an include is stored
        See Also:
        Constant Field Values

      • INCLUDE_QUERY_STRING

        static final String INCLUDE_QUERY_STRING
        The name of the request attribute under which the query string of the target of an include is stored
        See Also:
        Constant Field Values

      • ERROR_EXCEPTION

        static final String ERROR_EXCEPTION
        The name of the request attribute under which the exception object is propagated during an error dispatch
        See Also:
        Constant Field Values

      • ERROR_EXCEPTION_TYPE

        static final String ERROR_EXCEPTION_TYPE
        The name of the request attribute under which the type of the exception object is propagated during an error dispatch
        See Also:
        Constant Field Values

      • ERROR_MESSAGE

        static final String ERROR_MESSAGE
        The name of the request attribute under which the exception message is propagated during an error dispatch
        See Also:
        Constant Field Values

      • ERROR_REQUEST_URI

        static final String ERROR_REQUEST_URI
        The name of the request attribute under which the request URI whose processing caused the error is propagated during an error dispatch
        See Also:
        Constant Field Values

      • ERROR_SERVLET_NAME

        static final String ERROR_SERVLET_NAME
        The name of the request attribute under which the name of the servlet in which the error occurred is propagated during an error dispatch
        See Also:
        Constant Field Values

      • ERROR_STATUS_CODE

        static final String ERROR_STATUS_CODE
        The name of the request attribute under which the response status is propagated during an error dispatch
        See Also:
        Constant Field Values

    • Method Detail

      • forward

        void forward(ServletRequest request,
           ServletResponse response)
             throws ServletException,
                    IOException
        Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server. This method allows one servlet to do preliminary processing of a request and another resource to generate the response.

        For a RequestDispatcher obtained via getRequestDispatcher(), the ServletRequest object has its path elements and parameters adjusted to match the path of the target resource.

        forward should be called before the response has been committed to the client (before response body output has been flushed). If the response already has been committed, this method throws an IllegalStateException. Uncommitted output in the response buffer is automatically cleared before the forward.

        The request and response parameters must be either the same objects as were passed to the calling servlet's service method or be subclasses of the ServletRequestWrapper or ServletResponseWrapper classes that wrap them.

        This method sets the dispatcher type of the given request to DispatcherType.FORWARD.

        Parameters:
        request - a ServletRequest object that represents the request the client makes of the servlet
        response - a ServletResponse object that represents the response the servlet returns to the client
        Throws:
        ServletException - if the target resource throws this exception
        IOException - if the target resource throws this exception
        IllegalStateException - if the response was already committed
        See Also:
        ServletRequest.getDispatcherType()

      • include

        void include(ServletRequest request,
           ServletResponse response)
             throws ServletException,
                    IOException
        Includes the content of a resource (servlet, JSP page, HTML file) in the response. In essence, this method enables programmatic server-side includes.

        The ServletResponse object has its path elements and parameters remain unchanged from the caller's. The included servlet cannot change the response status code or set headers; any attempt to make a change is ignored.

        The request and response parameters must be either the same objects as were passed to the calling servlet's service method or be subclasses of the ServletRequestWrapper or ServletResponseWrapper classes that wrap them.

        This method sets the dispatcher type of the given request to DispatcherType.INCLUDE.

        Parameters:
        request - a ServletRequest object that contains the client's request
        response - a ServletResponse object that contains the servlet's response
        Throws:
        ServletException - if the included resource throws this exception
        IOException - if the included resource throws this exception
        See Also:
        ServletRequest.getDispatcherType()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Servlet (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface Servlet

  • All Known Subinterfaces:
    HttpJspPage, JspPage
    All Known Implementing Classes:
    FacesServlet, GenericServlet, HttpServlet

    public interface Servlet
    Defines methods that all servlets must implement.

    A servlet is a small Java program that runs within a Web server. Servlets receive and respond to requests from Web clients, usually across HTTP, the HyperText Transfer Protocol.

    To implement this interface, you can write a generic servlet that extends javax.servlet.GenericServlet or an HTTP servlet that extends javax.servlet.http.HttpServlet.

    This interface defines methods to initialize a servlet, to service requests, and to remove a servlet from the server. These are known as life-cycle methods and are called in the following sequence:

    1. The servlet is constructed, then initialized with the init method.
    2. Any calls from clients to the service method are handled.
    3. The servlet is taken out of service, then destroyed with the destroy method, then garbage collected and finalized.

    In addition to the life-cycle methods, this interface provides the getServletConfig method, which the servlet can use to get any startup information, and the getServletInfo method, which allows the servlet to return basic information about itself, such as author, version, and copyright.

    Author:
    Various
    See Also:
    GenericServlet, HttpServlet

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.
      ServletConfig getServletConfig()
      Returns a ServletConfig object, which contains initialization and startup parameters for this servlet.
      String getServletInfo()
      Returns information about the servlet, such as author, version, and copyright.
      void init(ServletConfig config)
      Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
      void service(ServletRequest req, ServletResponse res)
      Called by the servlet container to allow the servlet to respond to a request.

    • Method Detail

      • init

        void init(ServletConfig config)
          throws ServletException
        Called by the servlet container to indicate to a servlet that the servlet is being placed into service.

        The servlet container calls the init method exactly once after instantiating the servlet. The init method must complete successfully before the servlet can receive any requests.

        The servlet container cannot place the servlet into service if the init method

        1. Throws a ServletException
        2. Does not return within a time period defined by the Web server
        Parameters:
        config - a ServletConfig object containing the servlet's configuration and initialization parameters
        Throws:
        ServletException - if an exception has occurred that interferes with the servlet's normal operation
        See Also:
        UnavailableException, getServletConfig()

      • getServletConfig

        ServletConfig getServletConfig()
        Returns a ServletConfig object, which contains initialization and startup parameters for this servlet. The ServletConfig object returned is the one passed to the init method.

        Implementations of this interface are responsible for storing the ServletConfig object so that this method can return it. The GenericServlet class, which implements this interface, already does this.

        Returns:
        the ServletConfig object that initializes this servlet
        See Also:
        init(javax.servlet.ServletConfig)

      • service

        void service(ServletRequest req,
           ServletResponse res)
             throws ServletException,
                    IOException
        Called by the servlet container to allow the servlet to respond to a request.

        This method is only called after the servlet's init() method has completed successfully.

        The status code of the response always should be set for a servlet that throws or sends an error.

        Servlets typically run inside multithreaded servlet containers that can handle multiple requests concurrently. Developers must be aware to synchronize access to any shared resources such as files, network connections, and as well as the servlet's class and instance variables. More information on multithreaded programming in Java is available in the Java tutorial on multi-threaded programming.

        Parameters:
        req - the ServletRequest object that contains the client's request
        res - the ServletResponse object that contains the servlet's response
        Throws:
        ServletException - if an exception occurs that interferes with the servlet's normal operation
        IOException - if an input or output exception occurs

      • getServletInfo

        String getServletInfo()
        Returns information about the servlet, such as author, version, and copyright.

        The string that this method returns should be plain text and not markup of any kind (such as HTML, XML, etc.).

        Returns:
        a String containing servlet information

      • destroy

        void destroy()
        Called by the servlet container to indicate to a servlet that the servlet is being taken out of service. This method is only called once all threads within the servlet's service method have exited or after a timeout period has passed. After the servlet container calls this method, it will not call the service method again on this servlet.

        This method gives the servlet an opportunity to clean up any resources that are being held (for example, memory, file handles, threads) and make sure that any persistent state is synchronized with the servlet's current state in memory.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletConfig

  • All Known Implementing Classes:
    GenericServlet, HttpServlet

    public interface ServletConfig
    A servlet configuration object used by a servlet container to pass information to a servlet during initialization.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getInitParameter(String name)
      Gets the value of the initialization parameter with the given name.
      Enumeration<String> getInitParameterNames()
      Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
      ServletContext getServletContext()
      Returns a reference to the ServletContext in which the caller is executing.
      String getServletName()
      Returns the name of this servlet instance.

    • Method Detail

      • getServletName

        String getServletName()
        Returns the name of this servlet instance. The name may be provided via server administration, assigned in the web application deployment descriptor, or for an unregistered (and thus unnamed) servlet instance it will be the servlet's class name.
        Returns:
        the name of the servlet instance

      • getServletContext

        ServletContext getServletContext()
        Returns a reference to the ServletContext in which the caller is executing.
        Returns:
        a ServletContext object, used by the caller to interact with its servlet container
        See Also:
        ServletContext

      • getInitParameter

        String getInitParameter(String name)
        Gets the value of the initialization parameter with the given name.
        Parameters:
        name - the name of the initialization parameter whose value to get
        Returns:
        a String containing the value of the initialization parameter, or null if the initialization parameter does not exist

      • getInitParameterNames

        Enumeration<String> getInitParameterNames()
        Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
        Returns:
        an Enumeration of String objects containing the names of the servlet's initialization parameters
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletContainerInitializer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletContainerInitializer

  • public interface ServletContainerInitializer
    Interface which allows a library/runtime to be notified of a web application's startup phase and perform any required programmatic registration of servlets, filters, and listeners in response to it.

    Implementations of this interface may be annotated with HandlesTypes, in order to receive (at their onStartup(java.util.Set<java.lang.Class<?>>, javax.servlet.ServletContext) method) the Set of application classes that implement, extend, or have been annotated with the class types specified by the annotation.

    If an implementation of this interface does not use HandlesTypes annotation, or none of the application classes match the ones specified by the annotation, the container must pass a null Set of classes to onStartup(java.util.Set<java.lang.Class<?>>, javax.servlet.ServletContext).

    When examining the classes of an application to see if they match any of the criteria specified by the HandlesTypes annontation of a ServletContainerInitializer, the container may run into classloading problems if any of the application's optional JAR files are missing. Because the container is not in a position to decide whether these types of classloading failures will prevent the application from working correctly, it must ignore them, while at the same time providing a configuration option that would log them.

    Implementations of this interface must be declared by a JAR file resource located inside the META-INF/services directory and named for the fully qualified class name of this interface, and will be discovered using the runtime's service provider lookup mechanism or a container specific mechanism that is semantically equivalent to it. In either case, ServletContainerInitializer services from web fragment JAR files excluded from an absolute ordering must be ignored, and the order in which these services are discovered must follow the application's classloading delegation model.

    Since:
    Servlet 3.0
    See Also:
    HandlesTypes

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onStartup(Set<Class<?>> c, ServletContext ctx)
      Notifies this ServletContainerInitializer of the startup of the application represented by the given ServletContext.

    • Method Detail

      • onStartup

        void onStartup(Set<Class<?>> c,
             ServletContext ctx)
               throws ServletException
        Notifies this ServletContainerInitializer of the startup of the application represented by the given ServletContext.

        If this ServletContainerInitializer is bundled in a JAR file inside the WEB-INF/lib directory of an application, its onStartup method will be invoked only once during the startup of the bundling application. If this ServletContainerInitializer is bundled inside a JAR file outside of any WEB-INF/lib directory, but still discoverable as described above, its onStartup method will be invoked every time an application is started.

        Parameters:
        c - the Set of application classes that extend, implement, or have been annotated with the class types specified by the HandlesTypes annotation, or null if there are no matches, or this ServletContainerInitializer has not been annotated with HandlesTypes
        ctx - the ServletContext of the web application that is being started and in which the classes contained in c were found
        Throws:
        ServletException - if an error has occurred
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletContext

  • public interface ServletContext
    Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.

    There is one context per "web application" per Java Virtual Machine. (A "web application" is a collection of servlets and content installed under a specific subset of the server's URL namespace such as /catalog and possibly installed via a .war file.)

    In the case of a web application marked "distributed" in its deployment descriptor, there will be one context instance for each virtual machine. In this situation, the context cannot be used as a location to share global information (because the information won't be truly global). Use an external resource like a database instead.

    The ServletContext object is contained within the ServletConfig object, which the Web server provides the servlet when the servlet is initialized.

    Author:
    Various
    See Also:
    Servlet.getServletConfig(), ServletConfig.getServletContext()

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ORDERED_LIBS
      The name of the ServletContext attribute whose value (of type java.util.List<java.lang.String>) contains the list of names of JAR files in WEB-INF/lib ordered by their web fragment names (with possible exclusions if <absolute-ordering> without any <others/> is being used), or null if no absolute or relative ordering has been specified
      static String TEMPDIR
      The name of the ServletContext attribute which stores the private temporary directory (of type java.io.File) provided by the servlet container for the ServletContext

    • Method Summary

      Methods
      Modifier and Type Method and Description
      FilterRegistration.Dynamic addFilter(String filterName, Class<? extends Filter> filterClass)
      Adds the filter with the given name and class type to this servlet context.
      FilterRegistration.Dynamic addFilter(String filterName, Filter filter)
      Registers the given filter instance with this ServletContext under the given filterName.
      FilterRegistration.Dynamic addFilter(String filterName, String className)
      Adds the filter with the given name and class name to this servlet context.
      void addListener(Class<? extends EventListener> listenerClass)
      Adds a listener of the given class type to this ServletContext.
      void addListener(String className)
      Adds the listener with the given class name to this ServletContext.
      <T extends EventListener>
      void             		addListener(T t)
      Adds the given listener to this ServletContext.
      ServletRegistration.Dynamic addServlet(String servletName, Class<? extends Servlet> servletClass)
      Adds the servlet with the given name and class type to this servlet context.
      ServletRegistration.Dynamic addServlet(String servletName, Servlet servlet)
      Registers the given servlet instance with this ServletContext under the given servletName.
      ServletRegistration.Dynamic addServlet(String servletName, String className)
      Adds the servlet with the given name and class name to this servlet context.
      <T extends Filter>
      T             		createFilter(Class<T> clazz)
      Instantiates the given Filter class.
      <T extends EventListener>
      T             		createListener(Class<T> clazz)
      Instantiates the given EventListener class.
      <T extends Servlet>
      T             		createServlet(Class<T> clazz)
      Instantiates the given Servlet class.
      void declareRoles(String... roleNames)
      Declares role names that are tested using isUserInRole.
      Object getAttribute(String name)
      Returns the servlet container attribute with the given name, or null if there is no attribute by that name.
      Enumeration<String> getAttributeNames()
      Returns an Enumeration containing the attribute names available within this ServletContext.
      ClassLoader getClassLoader()
      Gets the class loader of the web application represented by this ServletContext.
      ServletContext getContext(String uripath)
      Returns a ServletContext object that corresponds to a specified URL on the server.
      String getContextPath()
      Returns the context path of the web application.
      Set<SessionTrackingMode> getDefaultSessionTrackingModes()
      Gets the session tracking modes that are supported by default for this ServletContext.
      int getEffectiveMajorVersion()
      Gets the major version of the Servlet specification that the application represented by this ServletContext is based on.
      int getEffectiveMinorVersion()
      Gets the minor version of the Servlet specification that the application represented by this ServletContext is based on.
      Set<SessionTrackingMode> getEffectiveSessionTrackingModes()
      Gets the session tracking modes that are in effect for this ServletContext.
      FilterRegistration getFilterRegistration(String filterName)
      Gets the FilterRegistration corresponding to the filter with the given filterName.
      Map<String,? extends FilterRegistration> getFilterRegistrations()
      Gets a (possibly empty) Map of the FilterRegistration objects (keyed by filter name) corresponding to all filters registered with this ServletContext.
      String getInitParameter(String name)
      Returns a String containing the value of the named context-wide initialization parameter, or null if the parameter does not exist.
      Enumeration<String> getInitParameterNames()
      Returns the names of the context's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the context has no initialization parameters.
      JspConfigDescriptor getJspConfigDescriptor()
      Gets the <jsp-config> related configuration that was aggregated from the web.xml and web-fragment.xml descriptor files of the web application represented by this ServletContext.
      int getMajorVersion()
      Returns the major version of the Servlet API that this servlet container supports.
      String getMimeType(String file)
      Returns the MIME type of the specified file, or null if the MIME type is not known.
      int getMinorVersion()
      Returns the minor version of the Servlet API that this servlet container supports.
      RequestDispatcher getNamedDispatcher(String name)
      Returns a RequestDispatcher object that acts as a wrapper for the named servlet.
      String getRealPath(String path)
      Gets the real path corresponding to the given virtual path.
      RequestDispatcher getRequestDispatcher(String path)
      Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
      URL getResource(String path)
      Returns a URL to the resource that is mapped to the given path.
      InputStream getResourceAsStream(String path)
      Returns the resource located at the named path as an InputStream object.
      Set<String> getResourcePaths(String path)
      Returns a directory-like listing of all the paths to resources within the web application whose longest sub-path matches the supplied path argument.
      String getServerInfo()
      Returns the name and version of the servlet container on which the servlet is running.
      Servlet getServlet(String name)
      Deprecated.
      As of Java Servlet API 2.1, with no direct replacement.

      This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

      In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.
      String getServletContextName()
      Returns the name of this web application corresponding to this ServletContext as specified in the deployment descriptor for this web application by the display-name element.
      Enumeration<String> getServletNames()
      Deprecated.
      As of Java Servlet API 2.1, with no replacement.

      This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.
      ServletRegistration getServletRegistration(String servletName)
      Gets the ServletRegistration corresponding to the servlet with the given servletName.
      Map<String,? extends ServletRegistration> getServletRegistrations()
      Gets a (possibly empty) Map of the ServletRegistration objects (keyed by servlet name) corresponding to all servlets registered with this ServletContext.
      Enumeration<Servlet> getServlets()
      Deprecated.
      As of Java Servlet API 2.0, with no replacement.

      This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.
      SessionCookieConfig getSessionCookieConfig()
      Gets the SessionCookieConfig object through which various properties of the session tracking cookies created on behalf of this ServletContext may be configured.
      String getVirtualServerName()
      Returns the configuration name of the logical host on which the ServletContext is deployed.
      void log(Exception exception, String msg)
      Deprecated.
      As of Java Servlet API 2.1, use log(String message, Throwable throwable) instead.

      This method was originally defined to write an exception's stack trace and an explanatory error message to the servlet log file.
      void log(String msg)
      Writes the specified message to a servlet log file, usually an event log.
      void log(String message, Throwable throwable)
      Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file.
      void removeAttribute(String name)
      Removes the attribute with the given name from this ServletContext.
      void setAttribute(String name, Object object)
      Binds an object to a given attribute name in this ServletContext.
      boolean setInitParameter(String name, String value)
      Sets the context initialization parameter with the given name and value on this ServletContext.
      void setSessionTrackingModes(Set<SessionTrackingMode> sessionTrackingModes)
      Sets the session tracking modes that are to become effective for this ServletContext.

    • Field Detail

      • TEMPDIR

        static final String TEMPDIR
        The name of the ServletContext attribute which stores the private temporary directory (of type java.io.File) provided by the servlet container for the ServletContext
        See Also:
        Constant Field Values

      • ORDERED_LIBS

        static final String ORDERED_LIBS
        The name of the ServletContext attribute whose value (of type java.util.List<java.lang.String>) contains the list of names of JAR files in WEB-INF/lib ordered by their web fragment names (with possible exclusions if <absolute-ordering> without any <others/> is being used), or null if no absolute or relative ordering has been specified
        See Also:
        Constant Field Values

    • Method Detail

      • getContextPath

        String getContextPath()
        Returns the context path of the web application.

        The context path is the portion of the request URI that is used to select the context of the request. The context path always comes first in a request URI. If this context is the “default” context rooted at the base of the Web server’s URL name space, this path will be an empty string. Otherwise, if the context is not rooted at the root of the server’s name space, the path starts with a / character but does not end with a / character.

        It is possible that a servlet container may match a context by more than one context path. In such cases the HttpServletRequest.getContextPath() will return the actual context path used by the request and it may differ from the path returned by this method. The context path returned by this method should be considered as the prime or preferred context path of the application.

        Returns:
        The context path of the web application, or "" for the default (root) context
        Since:
        Servlet 2.5
        See Also:
        HttpServletRequest.getContextPath()

      • getContext

        ServletContext getContext(String uripath)
        Returns a ServletContext object that corresponds to a specified URL on the server.

        This method allows servlets to gain access to the context for various parts of the server, and as needed obtain RequestDispatcher objects from the context. The given path must be begin with /, is interpreted relative to the server's document root and is matched against the context roots of other web applications hosted on this container.

        In a security conscious environment, the servlet container may return null for a given URL.

        Parameters:
        uripath - a String specifying the context path of another web application in the container.
        Returns:
        the ServletContext object that corresponds to the named URL, or null if either none exists or the container wishes to restrict this access.
        See Also:
        RequestDispatcher

      • getMajorVersion

        int getMajorVersion()
        Returns the major version of the Servlet API that this servlet container supports. All implementations that comply with Version 3.0 must have this method return the integer 3.
        Returns:
        3

      • getMinorVersion

        int getMinorVersion()
        Returns the minor version of the Servlet API that this servlet container supports. All implementations that comply with Version 3.0 must have this method return the integer 0.
        Returns:
        0

      • getEffectiveMajorVersion

        int getEffectiveMajorVersion()
        Gets the major version of the Servlet specification that the application represented by this ServletContext is based on.

        The value returned may be different from getMajorVersion(), which returns the major version of the Servlet specification supported by the Servlet container.

        Returns:
        the major version of the Servlet specification that the application represented by this ServletContext is based on
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • getEffectiveMinorVersion

        int getEffectiveMinorVersion()
        Gets the minor version of the Servlet specification that the application represented by this ServletContext is based on.

        The value returned may be different from getMinorVersion(), which returns the minor version of the Servlet specification supported by the Servlet container.

        Returns:
        the minor version of the Servlet specification that the application xrepresented by this ServletContext is based on
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • getMimeType

        String getMimeType(String file)
        Returns the MIME type of the specified file, or null if the MIME type is not known. The MIME type is determined by the configuration of the servlet container, and may be specified in a web application deployment descriptor. Common MIME types include text/html and image/gif.
        Parameters:
        file - a String specifying the name of a file
        Returns:
        a String specifying the file's MIME type

      • getResourcePaths

        Set<String> getResourcePaths(String path)
        Returns a directory-like listing of all the paths to resources within the web application whose longest sub-path matches the supplied path argument.

        Paths indicating subdirectory paths end with a /.

        The returned paths are all relative to the root of the web application, or relative to the /META-INF/resources directory of a JAR file inside the web application's /WEB-INF/lib directory, and have a leading /.

        For example, for a web application containing:

           /welcome.html
   /catalog/index.html
   /catalog/products.html
   /catalog/offers/books.html
   /catalog/offers/music.html
   /customer/login.jsp
   /WEB-INF/web.xml
   /WEB-INF/classes/com.acme.OrderServlet.class
   /WEB-INF/lib/catalog.jar!/META-INF/resources/catalog/moreOffers/books.html
        getResourcePaths("/") would return {"/welcome.html", "/catalog/", "/customer/", "/WEB-INF/"}, and getResourcePaths("/catalog/") would return {"/catalog/index.html", "/catalog/products.html", "/catalog/offers/", "/catalog/moreOffers/"}.
        Parameters:
        path - the partial path used to match the resources, which must start with a /
        Returns:
        a Set containing the directory listing, or null if there are no resources in the web application whose path begins with the supplied path.
        Since:
        Servlet 2.3

      • getResource

        URL getResource(String path)
                throws MalformedURLException
        Returns a URL to the resource that is mapped to the given path.

        The path must begin with a / and is interpreted as relative to the current context root, or relative to the /META-INF/resources directory of a JAR file inside the web application's /WEB-INF/lib directory. This method will first search the document root of the web application for the requested resource, before searching any of the JAR files inside /WEB-INF/lib. The order in which the JAR files inside /WEB-INF/lib are searched is undefined.

        This method allows the servlet container to make a resource available to servlets from any source. Resources can be located on a local or remote file system, in a database, or in a .war file.

        The servlet container must implement the URL handlers and URLConnection objects that are necessary to access the resource.

        This method returns null if no resource is mapped to the pathname.

        Some containers may allow writing to the URL returned by this method using the methods of the URL class.

        The resource content is returned directly, so be aware that requesting a .jsp page returns the JSP source code. Use a RequestDispatcher instead to include results of an execution.

        This method has a different purpose than java.lang.Class.getResource, which looks up resources based on a class loader. This method does not use class loaders.

        Parameters:
        path - a String specifying the path to the resource
        Returns:
        the resource located at the named path, or null if there is no resource at that path
        Throws:
        MalformedURLException - if the pathname is not given in the correct form

      • getResourceAsStream

        InputStream getResourceAsStream(String path)
        Returns the resource located at the named path as an InputStream object.

        The data in the InputStream can be of any type or length. The path must be specified according to the rules given in getResource. This method returns null if no resource exists at the specified path.

        Meta-information such as content length and content type that is available via getResource method is lost when using this method.

        The servlet container must implement the URL handlers and URLConnection objects necessary to access the resource.

        This method is different from java.lang.Class.getResourceAsStream, which uses a class loader. This method allows servlet containers to make a resource available to a servlet from any location, without using a class loader.

        Parameters:
        path - a String specifying the path to the resource
        Returns:
        the InputStream returned to the servlet, or null if no resource exists at the specified path

      • getRequestDispatcher

        RequestDispatcher getRequestDispatcher(String path)
        Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path. A RequestDispatcher object can be used to forward a request to the resource or to include the resource in a response. The resource can be dynamic or static.

        The pathname must begin with a / and is interpreted as relative to the current context root. Use getContext to obtain a RequestDispatcher for resources in foreign contexts.

        This method returns null if the ServletContext cannot return a RequestDispatcher.

        Parameters:
        path - a String specifying the pathname to the resource
        Returns:
        a RequestDispatcher object that acts as a wrapper for the resource at the specified path, or null if the ServletContext cannot return a RequestDispatcher
        See Also:
        RequestDispatcher, getContext(java.lang.String)

      • getNamedDispatcher

        RequestDispatcher getNamedDispatcher(String name)
        Returns a RequestDispatcher object that acts as a wrapper for the named servlet.

        Servlets (and JSP pages also) may be given names via server administration or via a web application deployment descriptor. A servlet instance can determine its name using ServletConfig.getServletName().

        This method returns null if the ServletContext cannot return a RequestDispatcher for any reason.

        Parameters:
        name - a String specifying the name of a servlet to wrap
        Returns:
        a RequestDispatcher object that acts as a wrapper for the named servlet, or null if the ServletContext cannot return a RequestDispatcher
        See Also:
        RequestDispatcher, getContext(java.lang.String), ServletConfig.getServletName()

      • getServlet

        Servlet getServlet(String name)
                   throws ServletException
        Deprecated. As of Java Servlet API 2.1, with no direct replacement.

        This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

        In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.

        Throws:
        ServletException

      • getServlets

        Enumeration<Servlet> getServlets()
        Deprecated. As of Java Servlet API 2.0, with no replacement.

        This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

      • getServletNames

        Enumeration<String> getServletNames()
        Deprecated. As of Java Servlet API 2.1, with no replacement.

        This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

      • log

        void log(String msg)
        Writes the specified message to a servlet log file, usually an event log. The name and type of the servlet log file is specific to the servlet container.
        Parameters:
        msg - a String specifying the message to be written to the log file

      • log

        void log(Exception exception,
       String msg)
        Deprecated. As of Java Servlet API 2.1, use log(String message, Throwable throwable) instead.

        This method was originally defined to write an exception's stack trace and an explanatory error message to the servlet log file.

      • log

        void log(String message,
       Throwable throwable)
        Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file. The name and type of the servlet log file is specific to the servlet container, usually an event log.
        Parameters:
        message - a String that describes the error or exception
        throwable - the Throwable error or exception

      • getRealPath

        String getRealPath(String path)
        Gets the real path corresponding to the given virtual path.

        For example, if path is equal to /index.html, this method will return the absolute file path on the server's filesystem to which a request of the form http://<host>:<port>/<contextPath>/index.html would be mapped, where <contextPath> corresponds to the context path of this ServletContext.

        The real path returned will be in a form appropriate to the computer and operating system on which the servlet container is running, including the proper path separators.

        Resources inside the /META-INF/resources directories of JAR files bundled in the application's /WEB-INF/lib directory must be considered only if the container has unpacked them from their containing JAR file, in which case the path to the unpacked location must be returned.

        This method returns null if the servlet container is unable to translate the given virtual path to a real path.

        Parameters:
        path - the virtual path to be translated to a real path
        Returns:
        the real path, or null if the translation cannot be performed

      • getServerInfo

        String getServerInfo()
        Returns the name and version of the servlet container on which the servlet is running.

        The form of the returned string is servername/versionnumber. For example, the JavaServer Web Development Kit may return the string JavaServer Web Dev Kit/1.0.

        The servlet container may return other optional information after the primary string in parentheses, for example, JavaServer Web Dev Kit/1.0 (JDK 1.1.6; Windows NT 4.0 x86).

        Returns:
        a String containing at least the servlet container name and version number

      • getInitParameter

        String getInitParameter(String name)
        Returns a String containing the value of the named context-wide initialization parameter, or null if the parameter does not exist.

        This method can make available configuration information useful to an entire web application. For example, it can provide a webmaster's email address or the name of a system that holds critical data.

        Parameters:
        name - a String containing the name of the parameter whose value is requested
        Returns:
        a String containing at least the servlet container name and version number
        See Also:
        ServletConfig.getInitParameter(java.lang.String)

      • getInitParameterNames

        Enumeration<String> getInitParameterNames()
        Returns the names of the context's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the context has no initialization parameters.
        Returns:
        an Enumeration of String objects containing the names of the context's initialization parameters
        See Also:
        ServletConfig.getInitParameter(java.lang.String)

      • setInitParameter

        boolean setInitParameter(String name,
                       String value)
        Sets the context initialization parameter with the given name and value on this ServletContext.
        Parameters:
        name - the name of the context initialization parameter to set
        value - the value of the context initialization parameter to set
        Returns:
        true if the context initialization parameter with the given name and value was set successfully on this ServletContext, and false if it was not set because this ServletContext already contains a context initialization parameter with a matching name
        Throws:
        IllegalStateException - if this ServletContext has already been initialized
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • getAttribute

        Object getAttribute(String name)
        Returns the servlet container attribute with the given name, or null if there is no attribute by that name.

        An attribute allows a servlet container to give the servlet additional information not already provided by this interface. See your server documentation for information about its attributes. A list of supported attributes can be retrieved using getAttributeNames.

        The attribute is returned as a java.lang.Object or some subclass.

        Attribute names should follow the same convention as package names. The Java Servlet API specification reserves names matching java.*, javax.*, and sun.*.

        Parameters:
        name - a String specifying the name of the attribute
        Returns:
        an Object containing the value of the attribute, or null if no attribute exists matching the given name
        See Also:
        getAttributeNames()

      • getAttributeNames

        Enumeration<String> getAttributeNames()
        Returns an Enumeration containing the attribute names available within this ServletContext.

        Use the getAttribute(java.lang.String) method with an attribute name to get the value of an attribute.

        Returns:
        an Enumeration of attribute names
        See Also:
        getAttribute(java.lang.String)

      • setAttribute

        void setAttribute(String name,
                Object object)
        Binds an object to a given attribute name in this ServletContext. If the name specified is already used for an attribute, this method will replace the attribute with the new to the new attribute.

        If listeners are configured on the ServletContext the container notifies them accordingly.

        If a null value is passed, the effect is the same as calling removeAttribute().

        Attribute names should follow the same convention as package names. The Java Servlet API specification reserves names matching java.*, javax.*, and sun.*.

        Parameters:
        name - a String specifying the name of the attribute
        object - an Object representing the attribute to be bound

      • removeAttribute

        void removeAttribute(String name)
        Removes the attribute with the given name from this ServletContext. After removal, subsequent calls to getAttribute(java.lang.String) to retrieve the attribute's value will return null.

        If listeners are configured on the ServletContext the container notifies them accordingly.

        Parameters:
        name - a String specifying the name of the attribute to be removed

      • getServletContextName

        String getServletContextName()
        Returns the name of this web application corresponding to this ServletContext as specified in the deployment descriptor for this web application by the display-name element.
        Returns:
        The name of the web application or null if no name has been declared in the deployment descriptor.
        Since:
        Servlet 2.3

      • addServlet

        ServletRegistration.Dynamic addServlet(String servletName,
                                     String className)
        Adds the servlet with the given name and class name to this servlet context.

        The registered servlet may be further configured via the returned ServletRegistration object.

        The specified className will be loaded using the classloader associated with the application represented by this ServletContext.

        If this ServletContext already contains a preliminary ServletRegistration for a servlet with the given servletName, it will be completed (by assigning the given className to it) and returned.

        This method introspects the class with the given className for the ServletSecurity, MultipartConfig, javax.annotation.security.RunAs, and javax.annotation.security.DeclareRoles annotations. In addition, this method supports resource injection if the class with the given className represents a Managed Bean. See the Java EE platform and JSR 299 specifications for additional details about Managed Beans and resource injection.

        Parameters:
        servletName - the name of the servlet
        className - the fully qualified class name of the servlet
        Returns:
        a ServletRegistration object that may be used to further configure the registered servlet, or null if this ServletContext already contains a complete ServletRegistration for a servlet with the given servletName
        Throws:
        IllegalStateException - if this ServletContext has already been initialized
        IllegalArgumentException - if servletName is null or an empty String
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • addServlet

        ServletRegistration.Dynamic addServlet(String servletName,
                                     Servlet servlet)
        Registers the given servlet instance with this ServletContext under the given servletName.

        The registered servlet may be further configured via the returned ServletRegistration object.

        If this ServletContext already contains a preliminary ServletRegistration for a servlet with the given servletName, it will be completed (by assigning the class name of the given servlet instance to it) and returned.

        Parameters:
        servletName - the name of the servlet
        servlet - the servlet instance to register
        Returns:
        a ServletRegistration object that may be used to further configure the given servlet, or null if this ServletContext already contains a complete ServletRegistration for a servlet with the given servletName or if the same servlet instance has already been registered with this or another ServletContext in the same container
        Throws:
        IllegalStateException - if this ServletContext has already been initialized
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        IllegalArgumentException - if the given servlet instance implements SingleThreadModel, or servletName is null or an empty String
        Since:
        Servlet 3.0

      • addServlet

        ServletRegistration.Dynamic addServlet(String servletName,
                                     Class<? extends Servlet> servletClass)
        Adds the servlet with the given name and class type to this servlet context.

        The registered servlet may be further configured via the returned ServletRegistration object.

        If this ServletContext already contains a preliminary ServletRegistration for a servlet with the given servletName, it will be completed (by assigning the name of the given servletClass to it) and returned.

        This method introspects the given servletClass for the ServletSecurity, MultipartConfig, javax.annotation.security.RunAs, and javax.annotation.security.DeclareRoles annotations. In addition, this method supports resource injection if the given servletClass represents a Managed Bean. See the Java EE platform and JSR 299 specifications for additional details about Managed Beans and resource injection.

        Parameters:
        servletName - the name of the servlet
        servletClass - the class object from which the servlet will be instantiated
        Returns:
        a ServletRegistration object that may be used to further configure the registered servlet, or null if this ServletContext already contains a complete ServletRegistration for the given servletName
        Throws:
        IllegalStateException - if this ServletContext has already been initialized
        IllegalArgumentException - if servletName is null or an empty String
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • createServlet

        <T extends Servlet> T createServlet(Class<T> clazz)
                                throws ServletException
        Instantiates the given Servlet class.

        The returned Servlet instance may be further customized before it is registered with this ServletContext via a call to addServlet(String,Servlet).

        The given Servlet class must define a zero argument constructor, which is used to instantiate it.

        This method introspects the given clazz for the following annotations: ServletSecurity, MultipartConfig, javax.annotation.security.RunAs, and javax.annotation.security.DeclareRoles. In addition, this method supports resource injection if the given clazz represents a Managed Bean. See the Java EE platform and JSR 299 specifications for additional details about Managed Beans and resource injection.

        Parameters:
        clazz - the Servlet class to instantiate
        Returns:
        the new Servlet instance
        Throws:
        ServletException - if the given clazz fails to be instantiated
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • getServletRegistration

        ServletRegistration getServletRegistration(String servletName)
        Gets the ServletRegistration corresponding to the servlet with the given servletName.
        Returns:
        the (complete or preliminary) ServletRegistration for the servlet with the given servletName, or null if no ServletRegistration exists under that name
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • getServletRegistrations

        Map<String,? extends ServletRegistration> getServletRegistrations()
        Gets a (possibly empty) Map of the ServletRegistration objects (keyed by servlet name) corresponding to all servlets registered with this ServletContext.

        The returned Map includes the ServletRegistration objects corresponding to all declared and annotated servlets, as well as the ServletRegistration objects corresponding to all servlets that have been added via one of the addServlet methods.

        If permitted, any changes to the returned Map must not affect this ServletContext.

        Returns:
        Map of the (complete and preliminary) ServletRegistration objects corresponding to all servlets currently registered with this ServletContext
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • addFilter

        FilterRegistration.Dynamic addFilter(String filterName,
                                   String className)
        Adds the filter with the given name and class name to this servlet context.

        The registered filter may be further configured via the returned FilterRegistration object.

        The specified className will be loaded using the classloader associated with the application represented by this ServletContext.

        If this ServletContext already contains a preliminary FilterRegistration for a filter with the given filterName, it will be completed (by assigning the given className to it) and returned.

        This method supports resource injection if the class with the given className represents a Managed Bean. See the Java EE platform and JSR 299 specifications for additional details about Managed Beans and resource injection.

        Parameters:
        filterName - the name of the filter
        className - the fully qualified class name of the filter
        Returns:
        a FilterRegistration object that may be used to further configure the registered filter, or null if this ServletContext already contains a complete FilterRegistration for a filter with the given filterName
        Throws:
        IllegalStateException - if this ServletContext has already been initialized
        IllegalArgumentException - if filterName is null or an empty String
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • addFilter

        FilterRegistration.Dynamic addFilter(String filterName,
                                   Filter filter)
        Registers the given filter instance with this ServletContext under the given filterName.

        The registered filter may be further configured via the returned FilterRegistration object.

        If this ServletContext already contains a preliminary FilterRegistration for a filter with the given filterName, it will be completed (by assigning the class name of the given filter instance to it) and returned.

        Parameters:
        filterName - the name of the filter
        filter - the filter instance to register
        Returns:
        a FilterRegistration object that may be used to further configure the given filter, or null if this ServletContext already contains a complete FilterRegistration for a filter with the given filterName or if the same filter instance has already been registered with this or another ServletContext in the same container
        Throws:
        IllegalStateException - if this ServletContext has already been initialized
        IllegalArgumentException - if filterName is null or an empty String
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • addFilter

        FilterRegistration.Dynamic addFilter(String filterName,
                                   Class<? extends Filter> filterClass)
        Adds the filter with the given name and class type to this servlet context.

        The registered filter may be further configured via the returned FilterRegistration object.

        If this ServletContext already contains a preliminary FilterRegistration for a filter with the given filterName, it will be completed (by assigning the name of the given filterClass to it) and returned.

        This method supports resource injection if the given filterClass represents a Managed Bean. See the Java EE platform and JSR 299 specifications for additional details about Managed Beans and resource injection.

        Parameters:
        filterName - the name of the filter
        filterClass - the class object from which the filter will be instantiated
        Returns:
        a FilterRegistration object that may be used to further configure the registered filter, or null if this ServletContext already contains a complete FilterRegistration for a filter with the given filterName
        Throws:
        IllegalStateException - if this ServletContext has already been initialized
        IllegalArgumentException - if filterName is null or an empty String
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • createFilter

        <T extends Filter> T createFilter(Class<T> clazz)
                              throws ServletException
        Instantiates the given Filter class.

        The returned Filter instance may be further customized before it is registered with this ServletContext via a call to addFilter(String,Filter).

        The given Filter class must define a zero argument constructor, which is used to instantiate it.

        This method supports resource injection if the given clazz represents a Managed Bean. See the Java EE platform and JSR 299 specifications for additional details about Managed Beans and resource injection.

        Parameters:
        clazz - the Filter class to instantiate
        Returns:
        the new Filter instance
        Throws:
        ServletException - if the given clazz fails to be instantiated
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • getFilterRegistration

        FilterRegistration getFilterRegistration(String filterName)
        Gets the FilterRegistration corresponding to the filter with the given filterName.
        Returns:
        the (complete or preliminary) FilterRegistration for the filter with the given filterName, or null if no FilterRegistration exists under that name
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • getFilterRegistrations

        Map<String,? extends FilterRegistration> getFilterRegistrations()
        Gets a (possibly empty) Map of the FilterRegistration objects (keyed by filter name) corresponding to all filters registered with this ServletContext.

        The returned Map includes the FilterRegistration objects corresponding to all declared and annotated filters, as well as the FilterRegistration objects corresponding to all filters that have been added via one of the addFilter methods.

        Any changes to the returned Map must not affect this ServletContext.

        Returns:
        Map of the (complete and preliminary) FilterRegistration objects corresponding to all filters currently registered with this ServletContext
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • getSessionCookieConfig

        SessionCookieConfig getSessionCookieConfig()
        Gets the SessionCookieConfig object through which various properties of the session tracking cookies created on behalf of this ServletContext may be configured.

        Repeated invocations of this method will return the same SessionCookieConfig instance.

        Returns:
        the SessionCookieConfig object through which various properties of the session tracking cookies created on behalf of this ServletContext may be configured
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • setSessionTrackingModes

        void setSessionTrackingModes(Set<SessionTrackingMode> sessionTrackingModes)
        Sets the session tracking modes that are to become effective for this ServletContext.

        The given sessionTrackingModes replaces any session tracking modes set by a previous invocation of this method on this ServletContext.

        Parameters:
        sessionTrackingModes - the set of session tracking modes to become effective for this ServletContext
        Throws:
        IllegalStateException - if this ServletContext has already been initialized
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        IllegalArgumentException - if sessionTrackingModes specifies a combination of SessionTrackingMode.SSL with a session tracking mode other than SessionTrackingMode.SSL, or if sessionTrackingModes specifies a session tracking mode that is not supported by the servlet container
        Since:
        Servlet 3.0

      • getDefaultSessionTrackingModes

        Set<SessionTrackingMode> getDefaultSessionTrackingModes()
        Gets the session tracking modes that are supported by default for this ServletContext.
        Returns:
        set of the session tracking modes supported by default for this ServletContext
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • getEffectiveSessionTrackingModes

        Set<SessionTrackingMode> getEffectiveSessionTrackingModes()
        Gets the session tracking modes that are in effect for this ServletContext.

        The session tracking modes in effect are those provided to setSessionTrackingModes.

        By default, the session tracking modes returned by getDefaultSessionTrackingModes are in effect.

        Returns:
        set of the session tracking modes in effect for this ServletContext
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • addListener

        void addListener(String className)
        Adds the listener with the given class name to this ServletContext.

        The class with the given name will be loaded using the classloader associated with the application represented by this ServletContext, and must implement one or more of the following interfaces:

        • ServletContextAttributeListener
        • ServletRequestListener
        • ServletRequestAttributeListener
        • HttpSessionAttributeListener
        • HttpSessionIdListener
        • HttpSessionListener

        If this ServletContext was passed to ServletContainerInitializer.onStartup(java.util.Set<java.lang.Class<?>>, javax.servlet.ServletContext), then the class with the given name may also implement ServletContextListener, in addition to the interfaces listed above.

        As part of this method call, the container must load the class with the specified class name to ensure that it implements one of the required interfaces.

        If the class with the given name implements a listener interface whose invocation order corresponds to the declaration order (i.e., if it implements ServletRequestListener, ServletContextListener, or HttpSessionListener), then the new listener will be added to the end of the ordered list of listeners of that interface.

        This method supports resource injection if the class with the given className represents a Managed Bean. See the Java EE platform and JSR 299 specifications for additional details about Managed Beans and resource injection.

        Parameters:
        className - the fully qualified class name of the listener
        Throws:
        IllegalArgumentException - if the class with the given name does not implement any of the above interfaces, or if it implements ServletContextListener and this ServletContext was not passed to ServletContainerInitializer.onStartup(java.util.Set<java.lang.Class<?>>, javax.servlet.ServletContext)
        IllegalStateException - if this ServletContext has already been initialized
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • addListener

        <T extends EventListener> void addListener(T t)
        Adds the given listener to this ServletContext.

        The given listener must be an instance of one or more of the following interfaces:

        • ServletContextAttributeListener
        • ServletRequestListener
        • ServletRequestAttributeListener
        • HttpSessionAttributeListener
        • HttpSessionIdListener
        • HttpSessionListener

        If this ServletContext was passed to ServletContainerInitializer.onStartup(java.util.Set<java.lang.Class<?>>, javax.servlet.ServletContext), then the given listener may also be an instance of ServletContextListener, in addition to the interfaces listed above.

        If the given listener is an instance of a listener interface whose invocation order corresponds to the declaration order (i.e., if it is an instance of ServletRequestListener, ServletContextListener, or HttpSessionListener), then the listener will be added to the end of the ordered list of listeners of that interface.

        Parameters:
        t - the listener to be added
        Throws:
        IllegalArgumentException - if the given listener is not an instance of any of the above interfaces, or if it is an instance of ServletContextListener and this ServletContext was not passed to ServletContainerInitializer.onStartup(java.util.Set<java.lang.Class<?>>, javax.servlet.ServletContext)
        IllegalStateException - if this ServletContext has already been initialized
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • addListener

        void addListener(Class<? extends EventListener> listenerClass)
        Adds a listener of the given class type to this ServletContext.

        The given listenerClass must implement one or more of the following interfaces:

        • ServletContextAttributeListener
        • ServletRequestListener
        • ServletRequestAttributeListener
        • HttpSessionAttributeListener
        • HttpSessionIdListener
        • HttpSessionListener

        If this ServletContext was passed to ServletContainerInitializer.onStartup(java.util.Set<java.lang.Class<?>>, javax.servlet.ServletContext), then the given listenerClass may also implement ServletContextListener, in addition to the interfaces listed above.

        If the given listenerClass implements a listener interface whose invocation order corresponds to the declaration order (i.e., if it implements ServletRequestListener, ServletContextListener, or HttpSessionListener), then the new listener will be added to the end of the ordered list of listeners of that interface.

        This method supports resource injection if the given listenerClass represents a Managed Bean. See the Java EE platform and JSR 299 specifications for additional details about Managed Beans and resource injection.

        Parameters:
        listenerClass - the listener class to be instantiated
        Throws:
        IllegalArgumentException - if the given listenerClass does not implement any of the above interfaces, or if it implements ServletContextListener and this ServletContext was not passed to ServletContainerInitializer.onStartup(java.util.Set<java.lang.Class<?>>, javax.servlet.ServletContext)
        IllegalStateException - if this ServletContext has already been initialized
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0

      • createListener

        <T extends EventListener> T createListener(Class<T> clazz)
                                       throws ServletException
        Instantiates the given EventListener class.

        The specified EventListener class must implement at least one of the ServletContextListener, ServletContextAttributeListener, ServletRequestListener, ServletRequestAttributeListener, HttpSessionAttributeListener HttpSessionIdListener, or HttpSessionListener, or interfaces.

        The returned EventListener instance may be further customized before it is registered with this ServletContext via a call to addListener(EventListener).

        The given EventListener class must define a zero argument constructor, which is used to instantiate it.

        This method supports resource injection if the given clazz represents a Managed Bean. See the Java EE platform and JSR 299 specifications for additional details about Managed Beans and resource injection.

        Parameters:
        clazz - the EventListener class to instantiate
        Returns:
        the new EventListener instance
        Throws:
        ServletException - if the given clazz fails to be instantiated
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        IllegalArgumentException - if the specified EventListener class does not implement any of the ServletContextListener, ServletContextAttributeListener, ServletRequestListener, ServletRequestAttributeListener, HttpSessionAttributeListener HttpSessionIdListener, or HttpSessionListener, or interfaces.
        Since:
        Servlet 3.0

      • getJspConfigDescriptor

        JspConfigDescriptor getJspConfigDescriptor()
        Gets the <jsp-config> related configuration that was aggregated from the web.xml and web-fragment.xml descriptor files of the web application represented by this ServletContext.
        Returns:
        the <jsp-config> related configuration that was aggregated from the web.xml and web-fragment.xml descriptor files of the web application represented by this ServletContext, or null if no such configuration exists
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.0
        See Also:
        JspConfigDescriptor

      • getClassLoader

        ClassLoader getClassLoader()
        Gets the class loader of the web application represented by this ServletContext.

        If a security manager exists, and the caller's class loader is not the same as, or an ancestor of the requested class loader, then the security manager's checkPermission method is called with a RuntimePermission("getClassLoader") permission to check whether access to the requested class loader should be granted.

        Returns:
        the class loader of the web application represented by this ServletContext
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        SecurityException - if a security manager denies access to the requested class loader
        Since:
        Servlet 3.0

      • declareRoles

        void declareRoles(String... roleNames)
        Declares role names that are tested using isUserInRole.

        Roles that are implicitly declared as a result of their use within the setServletSecurity or setRunAsRole methods of the ServletRegistration interface need not be declared.

        Parameters:
        roleNames - the role names being declared
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        IllegalArgumentException - if any of the argument roleNames is null or the empty string
        IllegalStateException - if the ServletContext has already been initialized
        Since:
        Servlet 3.0

      • getVirtualServerName

        String getVirtualServerName()
        Returns the configuration name of the logical host on which the ServletContext is deployed. Servlet containers may support multiple logical hosts. This method must return the same name for all the servlet contexts deployed on a logical host, and the name returned by this method must be distinct, stable per logical host, and suitable for use in associating server configuration information with the logical host. The returned value is NOT expected or required to be equivalent to a network address or hostname of the logical host.
        Returns:
        a String containing the configuration name of the logical host on which the servlet context is deployed.
        Throws:
        UnsupportedOperationException - if this ServletContext was passed to the ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method of a ServletContextListener that was neither declared in web.xml or web-fragment.xml, nor annotated with WebListener
        Since:
        Servlet 3.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletContextAttributeEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class ServletContextAttributeEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.servlet.ServletContextEvent
        • javax.servlet.ServletContextAttributeEvent
  • All Implemented Interfaces:
    Serializable

    public class ServletContextAttributeEvent
extends ServletContextEvent
    Event class for notifications about changes to the attributes of the ServletContext of a web application.
    Since:
    Servlet 2.3
    See Also:
    ServletContextAttributeListener, Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ServletContextAttributeEvent(ServletContext source, String name, Object value)
      Constructs a ServletContextAttributeEvent from the given ServletContext, attribute name, and attribute value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Gets the name of the ServletContext attribute that changed.
      Object getValue()
      Gets the value of the ServletContext attribute that changed.

      • Methods inherited from class javax.servlet.ServletContextEvent

        getServletContext

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServletContextAttributeEvent

        public ServletContextAttributeEvent(ServletContext source,
                            String name,
                            Object value)
        Constructs a ServletContextAttributeEvent from the given ServletContext, attribute name, and attribute value.
        Parameters:
        source - the ServletContext whose attribute changed
        name - the name of the ServletContext attribute that changed
        value - the value of the ServletContext attribute that changed

    • Method Detail

      • getName

        public String getName()
        Gets the name of the ServletContext attribute that changed.
        Returns:
        the name of the ServletContext attribute that changed

      • getValue

        public Object getValue()
        Gets the value of the ServletContext attribute that changed.

        If the attribute was added, this is the value of the attribute. If the attribute was removed, this is the value of the removed attribute. If the attribute was replaced, this is the old value of the attribute.

        Returns:
        the value of the ServletContext attribute that changed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletContextAttributeListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletContextAttributeListener

  • All Superinterfaces:
    EventListener

    public interface ServletContextAttributeListener
extends EventListener
    Interface for receiving notification events about ServletContext attribute changes.

    In order to receive these notification events, the implementation class must be either declared in the deployment descriptor of the web application, annotated with WebListener, or registered via one of the addListener methods defined on ServletContext.

    The order in which implementations of this interface are invoked is unspecified.

    Since:
    Servlet 2.3
    See Also:
    ServletContextAttributeEvent

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void attributeAdded(ServletContextAttributeEvent event)
      Receives notification that an attribute has been added to the ServletContext.
      void attributeRemoved(ServletContextAttributeEvent event)
      Receives notification that an attribute has been removed from the ServletContext.
      void | attributeReplaced(ServletContextAttributeEvent event)

    • Method Detail

      • attributeAdded

        void attributeAdded(ServletContextAttributeEvent event)
        Receives notification that an attribute has been added to the ServletContext.
        Parameters:
        event - the ServletContextAttributeEvent containing the ServletContext to which the attribute was added, along with the attribute name and value

      • attributeRemoved

        void attributeRemoved(ServletContextAttributeEvent event)
        Receives notification that an attribute has been removed from the ServletContext.
        Parameters:
        event - the ServletContextAttributeEvent containing the ServletContext from which the attribute was removed, along with the attribute name and value

      • attributeReplaced

        void attributeReplaced(ServletContextAttributeEvent event)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletContextEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class ServletContextEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.servlet.ServletContextEvent
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ServletContextAttributeEvent

    public class ServletContextEvent
extends EventObject
    This is the event class for notifications about changes to the servlet context of a web application.
    Since:
    Servlet 2.3
    See Also:
    ServletContextListener, Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ServletContextEvent(ServletContext source)
      Construct a ServletContextEvent from the given context.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ServletContext getServletContext()
      Return the ServletContext that changed.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServletContextEvent

        public ServletContextEvent(ServletContext source)
        Construct a ServletContextEvent from the given context.
        Parameters:
        source - - the ServletContext that is sending the event.

    • Method Detail

      • getServletContext

        public ServletContext getServletContext()
        Return the ServletContext that changed.
        Returns:
        the ServletContext that sent the event.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletContextListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletContextListener

  • All Superinterfaces:
    EventListener

    public interface ServletContextListener
extends EventListener
    Interface for receiving notification events about ServletContext lifecycle changes.

    In order to receive these notification events, the implementation class must be either declared in the deployment descriptor of the web application, annotated with WebListener, or registered via one of the addListener methods defined on ServletContext.

    Implementations of this interface are invoked at their contextInitialized(javax.servlet.ServletContextEvent) method in the order in which they have been declared, and at their contextDestroyed(javax.servlet.ServletContextEvent) method in reverse order.

    Since:
    Servlet 2.3
    See Also:
    ServletContextEvent

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void contextDestroyed(ServletContextEvent sce)
      Receives notification that the ServletContext is about to be shut down.
      void contextInitialized(ServletContextEvent sce)
      Receives notification that the web application initialization process is starting.

    • Method Detail

      • contextInitialized

        void contextInitialized(ServletContextEvent sce)
        Receives notification that the web application initialization process is starting.

        All ServletContextListeners are notified of context initialization before any filters or servlets in the web application are initialized.

        Parameters:
        sce - the ServletContextEvent containing the ServletContext that is being initialized

      • contextDestroyed

        void contextDestroyed(ServletContextEvent sce)
        Receives notification that the ServletContext is about to be shut down.

        All servlets and filters will have been destroyed before any ServletContextListeners are notified of context destruction.

        Parameters:
        sce - the ServletContextEvent containing the ServletContext that is being destroyed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class ServletException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.servlet.ServletException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    UnavailableException

    public class ServletException
extends Exception
    Defines a general exception a servlet can throw when it encounters difficulty.
    Author:
    Various
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ServletException()
      Constructs a new servlet exception.
      ServletException(String message)
      Constructs a new servlet exception with the specified message.
      ServletException(String message, Throwable rootCause)
      Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
      ServletException(Throwable rootCause)
      Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getRootCause()
      Returns the exception that caused this servlet exception.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServletException

        public ServletException()
        Constructs a new servlet exception.

      • ServletException

        public ServletException(String message)
        Constructs a new servlet exception with the specified message. The message can be written to the server log and/or displayed for the user.
        Parameters:
        message - a String specifying the text of the exception message

      • ServletException

        public ServletException(String message,
                Throwable rootCause)
        Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
        Parameters:
        message - a String containing the text of the exception message
        rootCause - the Throwable exception that interfered with the servlet's normal operation, making this servlet exception necessary

      • ServletException

        public ServletException(Throwable rootCause)
        Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation. The exception's message is based on the localized message of the underlying exception.

        This method calls the getLocalizedMessage method on the Throwable exception to get a localized exception message. When subclassing ServletException, this method can be overridden to create an exception message designed for a specific locale.

        Parameters:
        rootCause - the Throwable exception that interfered with the servlet's normal operation, making the servlet exception necessary

    • Method Detail

      • getRootCause

        public Throwable getRootCause()
        Returns the exception that caused this servlet exception.
        Returns:
        the Throwable that caused this servlet exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletInputStream (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class ServletInputStream

  • java.lang.Object
    • java.io.InputStream
      • javax.servlet.ServletInputStream
  • All Implemented Interfaces:
    Closeable, AutoCloseable

    public abstract class ServletInputStream
extends InputStream
    Provides an input stream for reading binary data from a client request, including an efficient readLine method for reading data one line at a time. With some protocols, such as HTTP POST and PUT, a ServletInputStream object can be used to read data sent from the client.

    A ServletInputStream object is normally retrieved via the ServletRequest.getInputStream() method.

    This is an abstract class that a servlet container implements. Subclasses of this class must implement the java.io.InputStream.read() method.

    Author:
    Various
    See Also:
    ServletRequest

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected ServletInputStream()
      Does nothing, because this is an abstract class.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract boolean isFinished()
      Returns true when all the data from the stream has been read else it returns false.
      abstract boolean isReady()
      Returns true if data can be read without blocking else returns false.
      int readLine(byte[] b, int off, int len)
      Reads the input stream, one line at a time.
      abstract void setReadListener(ReadListener readListener)
      Instructs the ServletInputStream to invoke the provided ReadListener when it is possible to read

      • Methods inherited from class java.io.InputStream

        available, close, mark, markSupported, read, read, read, reset, skip

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServletInputStream

        protected ServletInputStream()
        Does nothing, because this is an abstract class.

    • Method Detail

      • readLine

        public int readLine(byte[] b,
           int off,
           int len)
             throws IOException
        Reads the input stream, one line at a time. Starting at an offset, reads bytes into an array, until it reads a certain number of bytes or reaches a newline character, which it reads into the array as well.

        This method returns -1 if it reaches the end of the input stream before reading the maximum number of bytes.

        Parameters:
        b - an array of bytes into which data is read
        off - an integer specifying the character at which this method begins reading
        len - an integer specifying the maximum number of bytes to read
        Returns:
        an integer specifying the actual number of bytes read, or -1 if the end of the stream is reached
        Throws:
        IOException - if an input or output exception has occurred

      • isFinished

        public abstract boolean isFinished()
        Returns true when all the data from the stream has been read else it returns false.
        Returns:
        true when all data for this particular request has been read, otherwise returns false.
        Since:
        Servlet 3.1

      • isReady

        public abstract boolean isReady()
        Returns true if data can be read without blocking else returns false.
        Returns:
        true if data can be obtained without blocking, otherwise returns false.
        Since:
        Servlet 3.1

      • setReadListener

        public abstract void setReadListener(ReadListener readListener)
        Instructs the ServletInputStream to invoke the provided ReadListener when it is possible to read
        Parameters:
        readListener - the ReadListener that should be notified when it's possible to read.
        Throws:
        IllegalStateException - if one of the following conditions is true
        • the associated request is neither upgraded nor the async started
        • setReadListener is called more than once within the scope of the same request.
        NullPointerException - if readListener is null
        Since:
        Servlet 3.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletOutputStream (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class ServletOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • javax.servlet.ServletOutputStream
  • All Implemented Interfaces:
    Closeable, Flushable, AutoCloseable

    public abstract class ServletOutputStream
extends OutputStream
    Provides an output stream for sending binary data to the client. A ServletOutputStream object is normally retrieved via the ServletResponse.getOutputStream() method.

    This is an abstract class that the servlet container implements. Subclasses of this class must implement the java.io.OutputStream.write(int) method.

    Author:
    Various
    See Also:
    ServletResponse

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected ServletOutputStream()
      Does nothing, because this is an abstract class.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract boolean isReady()
      This method can be used to determine if data can be written without blocking.
      void print(boolean b)
      Writes a boolean value to the client, with no carriage return-line feed (CRLF) character at the end.
      void print(char c)
      Writes a character to the client, with no carriage return-line feed (CRLF) at the end.
      void print(double d)
      Writes a double value to the client, with no carriage return-line feed (CRLF) at the end.
      void print(float f)
      Writes a float value to the client, with no carriage return-line feed (CRLF) at the end.
      void print(int i)
      Writes an int to the client, with no carriage return-line feed (CRLF) at the end.
      void print(long l)
      Writes a long value to the client, with no carriage return-line feed (CRLF) at the end.
      void print(String s)
      Writes a String to the client, without a carriage return-line feed (CRLF) character at the end.
      void println()
      Writes a carriage return-line feed (CRLF) to the client.
      void println(boolean b)
      Writes a boolean value to the client, followed by a carriage return-line feed (CRLF).
      void println(char c)
      Writes a character to the client, followed by a carriage return-line feed (CRLF).
      void println(double d)
      Writes a double value to the client, followed by a carriage return-line feed (CRLF).
      void println(float f)
      Writes a float value to the client, followed by a carriage return-line feed (CRLF).
      void println(int i)
      Writes an int to the client, followed by a carriage return-line feed (CRLF) character.
      void println(long l)
      Writes a long value to the client, followed by a carriage return-line feed (CRLF).
      void println(String s)
      Writes a String to the client, followed by a carriage return-line feed (CRLF).
      abstract void setWriteListener(WriteListener writeListener)
      Instructs the ServletOutputStream to invoke the provided WriteListener when it is possible to write

      • Methods inherited from class java.io.OutputStream

        close, flush, write, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServletOutputStream

        protected ServletOutputStream()
        Does nothing, because this is an abstract class.

    • Method Detail

      • print

        public void print(String s)
           throws IOException
        Writes a String to the client, without a carriage return-line feed (CRLF) character at the end.
        Parameters:
        s - the String to send to the client
        Throws:
        IOException - if an input or output exception occurred

      • print

        public void print(boolean b)
           throws IOException
        Writes a boolean value to the client, with no carriage return-line feed (CRLF) character at the end.
        Parameters:
        b - the boolean value to send to the client
        Throws:
        IOException - if an input or output exception occurred

      • print

        public void print(char c)
           throws IOException
        Writes a character to the client, with no carriage return-line feed (CRLF) at the end.
        Parameters:
        c - the character to send to the client
        Throws:
        IOException - if an input or output exception occurred

      • print

        public void print(int i)
           throws IOException
        Writes an int to the client, with no carriage return-line feed (CRLF) at the end.
        Parameters:
        i - the int to send to the client
        Throws:
        IOException - if an input or output exception occurred

      • print

        public void print(long l)
           throws IOException
        Writes a long value to the client, with no carriage return-line feed (CRLF) at the end.
        Parameters:
        l - the long value to send to the client
        Throws:
        IOException - if an input or output exception occurred

      • print

        public void print(float f)
           throws IOException
        Writes a float value to the client, with no carriage return-line feed (CRLF) at the end.
        Parameters:
        f - the float value to send to the client
        Throws:
        IOException - if an input or output exception occurred

      • print

        public void print(double d)
           throws IOException
        Writes a double value to the client, with no carriage return-line feed (CRLF) at the end.
        Parameters:
        d - the double value to send to the client
        Throws:
        IOException - if an input or output exception occurred

      • println

        public void println()
             throws IOException
        Writes a carriage return-line feed (CRLF) to the client.
        Throws:
        IOException - if an input or output exception occurred

      • println

        public void println(String s)
             throws IOException
        Writes a String to the client, followed by a carriage return-line feed (CRLF).
        Parameters:
        s - the String to write to the client
        Throws:
        IOException - if an input or output exception occurred

      • println

        public void println(boolean b)
             throws IOException
        Writes a boolean value to the client, followed by a carriage return-line feed (CRLF).
        Parameters:
        b - the boolean value to write to the client
        Throws:
        IOException - if an input or output exception occurred

      • println

        public void println(char c)
             throws IOException
        Writes a character to the client, followed by a carriage return-line feed (CRLF).
        Parameters:
        c - the character to write to the client
        Throws:
        IOException - if an input or output exception occurred

      • println

        public void println(int i)
             throws IOException
        Writes an int to the client, followed by a carriage return-line feed (CRLF) character.
        Parameters:
        i - the int to write to the client
        Throws:
        IOException - if an input or output exception occurred

      • println

        public void println(long l)
             throws IOException
        Writes a long value to the client, followed by a carriage return-line feed (CRLF).
        Parameters:
        l - the long value to write to the client
        Throws:
        IOException - if an input or output exception occurred

      • println

        public void println(float f)
             throws IOException
        Writes a float value to the client, followed by a carriage return-line feed (CRLF).
        Parameters:
        f - the float value to write to the client
        Throws:
        IOException - if an input or output exception occurred

      • println

        public void println(double d)
             throws IOException
        Writes a double value to the client, followed by a carriage return-line feed (CRLF).
        Parameters:
        d - the double value to write to the client
        Throws:
        IOException - if an input or output exception occurred

      • isReady

        public abstract boolean isReady()
        This method can be used to determine if data can be written without blocking.
        Returns:
        true if a write to this ServletOutputStream will succeed, otherwise returns false.
        Since:
        Servlet 3.1

      • setWriteListener

        public abstract void setWriteListener(WriteListener writeListener)
        Instructs the ServletOutputStream to invoke the provided WriteListener when it is possible to write
        Parameters:
        writeListener - the WriteListener that should be notified when it's possible to write
        Throws:
        IllegalStateException - if one of the following conditions is true
        • the associated request is neither upgraded nor the async started
        • setWriteListener is called more than once within the scope of the same request.
        NullPointerException - if writeListener is null
        Since:
        Servlet 3.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletRegistration (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletRegistration

  • All Superinterfaces:
    Registration
    All Known Subinterfaces:
    ServletRegistration.Dynamic

    public interface ServletRegistration
extends Registration
    Interface through which a Servlet may be further configured.
    Since:
    Servlet 3.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  ServletRegistration.Dynamic
      Interface through which a Servlet registered via one of the addServlet methods on ServletContext may be further configured.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<String> addMapping(String... urlPatterns)
      Adds a servlet mapping with the given URL patterns for the Servlet represented by this ServletRegistration.
      Collection<String> getMappings()
      Gets the currently available mappings of the Servlet represented by this ServletRegistration.
      String getRunAsRole()
      Gets the name of the runAs role of the Servlet represented by this ServletRegistration.

      • Methods inherited from interface javax.servlet.Registration

        getClassName, getInitParameter, getInitParameters, getName, setInitParameter, setInitParameters

    • Method Detail

      • addMapping

        Set<String> addMapping(String... urlPatterns)
        Adds a servlet mapping with the given URL patterns for the Servlet represented by this ServletRegistration.

        If any of the specified URL patterns are already mapped to a different Servlet, no updates will be performed.

        If this method is called multiple times, each successive call adds to the effects of the former.

        Parameters:
        urlPatterns - the URL patterns of the servlet mapping
        Returns:
        the (possibly empty) Set of URL patterns that are already mapped to a different Servlet
        Throws:
        IllegalArgumentException - if urlPatterns is null or empty
        IllegalStateException - if the ServletContext from which this ServletRegistration was obtained has already been initialized

      • getMappings

        Collection<String> getMappings()
        Gets the currently available mappings of the Servlet represented by this ServletRegistration.

        If permitted, any changes to the returned Collection must not affect this ServletRegistration.

        Returns:
        a (possibly empty) Collection of the currently available mappings of the Servlet represented by this ServletRegistration

      • getRunAsRole

        String getRunAsRole()
        Gets the name of the runAs role of the Servlet represented by this ServletRegistration.
        Returns:
        the name of the runAs role, or null if the Servlet is configured to run as its caller
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletRegistration.Dynamic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletRegistration.Dynamic

  • All Superinterfaces:
    Registration, Registration.Dynamic, ServletRegistration
    Enclosing interface:
    ServletRegistration

    public static interface ServletRegistration.Dynamic
extends ServletRegistration, Registration.Dynamic
    Interface through which a Servlet registered via one of the addServlet methods on ServletContext may be further configured.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.servlet.ServletRegistration

        ServletRegistration.Dynamic

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void setLoadOnStartup(int loadOnStartup)
      Sets the loadOnStartup priority on the Servlet represented by this dynamic ServletRegistration.
      void setMultipartConfig(MultipartConfigElement multipartConfig)
      Sets the MultipartConfigElement to be applied to the mappings defined for this ServletRegistration.
      void setRunAsRole(String roleName)
      Sets the name of the runAs role for this ServletRegistration.
      Set<String> setServletSecurity(ServletSecurityElement constraint)
      Sets the ServletSecurityElement to be applied to the mappings defined for this ServletRegistration.

      • Methods inherited from interface javax.servlet.ServletRegistration

        addMapping, getMappings, getRunAsRole

      • Methods inherited from interface javax.servlet.Registration.Dynamic

        setAsyncSupported

      • Methods inherited from interface javax.servlet.Registration

        getClassName, getInitParameter, getInitParameters, getName, setInitParameter, setInitParameters

    • Method Detail

      • setLoadOnStartup

        void setLoadOnStartup(int loadOnStartup)
        Sets the loadOnStartup priority on the Servlet represented by this dynamic ServletRegistration.

        A loadOnStartup value of greater than or equal to zero indicates to the container the initialization priority of the Servlet. In this case, the container must instantiate and initialize the Servlet during the initialization phase of the ServletContext, that is, after it has invoked all of the ServletContextListener objects configured for the ServletContext at their ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent) method.

        If loadOnStartup is a negative integer, the container is free to instantiate and initialize the Servlet lazily.

        The default value for loadOnStartup is -1.

        A call to this method overrides any previous setting.

        Parameters:
        loadOnStartup - the initialization priority of the Servlet
        Throws:
        IllegalStateException - if the ServletContext from which this ServletRegistration was obtained has already been initialized

      • setServletSecurity

        Set<String> setServletSecurity(ServletSecurityElement constraint)
        Sets the ServletSecurityElement to be applied to the mappings defined for this ServletRegistration.

        This method applies to all mappings added to this ServletRegistration up until the point that the ServletContext from which it was obtained has been initialized.

        If a URL pattern of this ServletRegistration is an exact target of a security-constraint that was established via the portable deployment descriptor, then this method does not change the security-constraint for that pattern, and the pattern will be included in the return value.

        If a URL pattern of this ServletRegistration is an exact target of a security constraint that was established via the ServletSecurity annotation or a previous call to this method, then this method replaces the security constraint for that pattern.

        If a URL pattern of this ServletRegistration is neither the exact target of a security constraint that was established via the ServletSecurity annotation or a previous call to this method, nor the exact target of a security-constraint in the portable deployment descriptor, then this method establishes the security constraint for that pattern from the argument ServletSecurityElement.

        Parameters:
        constraint - the ServletSecurityElement to be applied to the patterns mapped to this ServletRegistration
        Returns:
        the (possibly empty) Set of URL patterns that were already the exact target of a security-constraint that was established via the portable deployment descriptor. This method has no effect on the patterns included in the returned set
        Throws:
        IllegalArgumentException - if constraint is null
        IllegalStateException - if the ServletContext from which this ServletRegistration was obtained has already been initialized

      • setMultipartConfig

        void setMultipartConfig(MultipartConfigElement multipartConfig)
        Sets the MultipartConfigElement to be applied to the mappings defined for this ServletRegistration. If this method is called multiple times, each successive call overrides the effects of the former.
        Parameters:
        multipartConfig - the MultipartConfigElement to be applied to the patterns mapped to the registration
        Throws:
        IllegalArgumentException - if multipartConfig is null
        IllegalStateException - if the ServletContext from which this ServletRegistration was obtained has already been initialized

      • setRunAsRole

        void setRunAsRole(String roleName)
        Sets the name of the runAs role for this ServletRegistration.
        Parameters:
        roleName - the name of the runAs role
        Throws:
        IllegalArgumentException - if roleName is null
        IllegalStateException - if the ServletContext from which this ServletRegistration was obtained has already been initialized
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletRequest (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletRequest

  • All Known Subinterfaces:
    HttpServletRequest
    All Known Implementing Classes:
    HttpServletRequestWrapper, ServletRequestWrapper

    public interface ServletRequest
    Defines an object to provide client request information to a servlet. The servlet container creates a ServletRequest object and passes it as an argument to the servlet's service method.

    A ServletRequest object provides data including parameter name and values, attributes, and an input stream. Interfaces that extend ServletRequest can provide additional protocol-specific data (for example, HTTP data is provided by HttpServletRequest.

    Author:
    Various
    See Also:
    HttpServletRequest

    • Method Summary

      Methods
      Modifier and Type Method and Description
      AsyncContext getAsyncContext()
      Gets the AsyncContext that was created or reinitialized by the most recent invocation of startAsync() or startAsync(ServletRequest,ServletResponse) on this request.
      Object getAttribute(String name)
      Returns the value of the named attribute as an Object, or null if no attribute of the given name exists.
      Enumeration<String> getAttributeNames()
      Returns an Enumeration containing the names of the attributes available to this request.
      String getCharacterEncoding()
      Returns the name of the character encoding used in the body of this request.
      int getContentLength()
      Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known ir is greater than Integer.MAX_VALUE.
      long getContentLengthLong()
      Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known.
      String getContentType()
      Returns the MIME type of the body of the request, or null if the type is not known.
      DispatcherType getDispatcherType()
      Gets the dispatcher type of this request.
      ServletInputStream getInputStream()
      Retrieves the body of the request as binary data using a ServletInputStream.
      String getLocalAddr()
      Returns the Internet Protocol (IP) address of the interface on which the request was received.
      Locale getLocale()
      Returns the preferred Locale that the client will accept content in, based on the Accept-Language header.
      Enumeration<Locale> getLocales()
      Returns an Enumeration of Locale objects indicating, in decreasing order starting with the preferred locale, the locales that are acceptable to the client based on the Accept-Language header.
      String getLocalName()
      Returns the host name of the Internet Protocol (IP) interface on which the request was received.
      int getLocalPort()
      Returns the Internet Protocol (IP) port number of the interface on which the request was received.
      String getParameter(String name)
      Returns the value of a request parameter as a String, or null if the parameter does not exist.
      Map<String,String[]> getParameterMap()
      Returns a java.util.Map of the parameters of this request.
      Enumeration<String> getParameterNames()
      Returns an Enumeration of String objects containing the names of the parameters contained in this request.
      String[] getParameterValues(String name)
      Returns an array of String objects containing all of the values the given request parameter has, or null if the parameter does not exist.
      String getProtocol()
      Returns the name and version of the protocol the request uses in the form protocol/majorVersion.minorVersion, for example, HTTP/1.1.
      BufferedReader getReader()
      Retrieves the body of the request as character data using a BufferedReader.
      String getRealPath(String path)
      Deprecated.
      As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.
      String getRemoteAddr()
      Returns the Internet Protocol (IP) address of the client or last proxy that sent the request.
      String getRemoteHost()
      Returns the fully qualified name of the client or the last proxy that sent the request.
      int getRemotePort()
      Returns the Internet Protocol (IP) source port of the client or last proxy that sent the request.
      RequestDispatcher getRequestDispatcher(String path)
      Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
      String getScheme()
      Returns the name of the scheme used to make this request, for example, http, https, or ftp.
      String getServerName()
      Returns the host name of the server to which the request was sent.
      int getServerPort()
      Returns the port number to which the request was sent.
      ServletContext getServletContext()
      Gets the servlet context to which this ServletRequest was last dispatched.
      boolean isAsyncStarted()
      Checks if this request has been put into asynchronous mode.
      boolean isAsyncSupported()
      Checks if this request supports asynchronous operation.
      boolean isSecure()
      Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.
      void removeAttribute(String name)
      Removes an attribute from this request.
      void setAttribute(String name, Object o)
      Stores an attribute in this request.
      void setCharacterEncoding(String env)
      Overrides the name of the character encoding used in the body of this request.
      AsyncContext startAsync()
      Puts this request into asynchronous mode, and initializes its AsyncContext with the original (unwrapped) ServletRequest and ServletResponse objects.
      AsyncContext startAsync(ServletRequest servletRequest, ServletResponse servletResponse)
      Puts this request into asynchronous mode, and initializes its AsyncContext with the given request and response objects.

    • Method Detail

      • getAttribute

        Object getAttribute(String name)
        Returns the value of the named attribute as an Object, or null if no attribute of the given name exists.

        Attributes can be set two ways. The servlet container may set attributes to make available custom information about a request. For example, for requests made using HTTPS, the attribute javax.servlet.request.X509Certificate can be used to retrieve information on the certificate of the client. Attributes can also be set programatically using setAttribute(java.lang.String, java.lang.Object). This allows information to be embedded into a request before a RequestDispatcher call.

        Attribute names should follow the same conventions as package names. This specification reserves names matching java.*, javax.*, and sun.*.

        Parameters:
        name - a String specifying the name of the attribute
        Returns:
        an Object containing the value of the attribute, or null if the attribute does not exist

      • getAttributeNames

        Enumeration<String> getAttributeNames()
        Returns an Enumeration containing the names of the attributes available to this request. This method returns an empty Enumeration if the request has no attributes available to it.
        Returns:
        an Enumeration of strings containing the names of the request's attributes

      • getCharacterEncoding

        String getCharacterEncoding()
        Returns the name of the character encoding used in the body of this request. This method returns null if the request does not specify a character encoding
        Returns:
        a String containing the name of the character encoding, or null if the request does not specify a character encoding

      • setCharacterEncoding

        void setCharacterEncoding(String env)
                          throws UnsupportedEncodingException
        Overrides the name of the character encoding used in the body of this request. This method must be called prior to reading request parameters or reading input using getReader(). Otherwise, it has no effect.
        Parameters:
        env - String containing the name of the character encoding.
        Throws:
        UnsupportedEncodingException - if this ServletRequest is still in a state where a character encoding may be set, but the specified encoding is invalid

      • getContentLength

        int getContentLength()
        Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known ir is greater than Integer.MAX_VALUE. For HTTP servlets, same as the value of the CGI variable CONTENT_LENGTH.
        Returns:
        an integer containing the length of the request body or -1 if the length is not known or is greater than Integer.MAX_VALUE.

      • getContentLengthLong

        long getContentLengthLong()
        Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known. For HTTP servlets, same as the value of the CGI variable CONTENT_LENGTH.
        Returns:
        a long containing the length of the request body or -1L if the length is not known
        Since:
        Servlet 3.1

      • getContentType

        String getContentType()
        Returns the MIME type of the body of the request, or null if the type is not known. For HTTP servlets, same as the value of the CGI variable CONTENT_TYPE.
        Returns:
        a String containing the name of the MIME type of the request, or null if the type is not known

      • getInputStream

        ServletInputStream getInputStream()
                                  throws IOException
        Retrieves the body of the request as binary data using a ServletInputStream. Either this method or getReader() may be called to read the body, not both.
        Returns:
        a ServletInputStream object containing the body of the request
        Throws:
        IllegalStateException - if the getReader() method has already been called for this request
        IOException - if an input or output exception occurred

      • getParameter

        String getParameter(String name)
        Returns the value of a request parameter as a String, or null if the parameter does not exist. Request parameters are extra information sent with the request. For HTTP servlets, parameters are contained in the query string or posted form data.

        You should only use this method when you are sure the parameter has only one value. If the parameter might have more than one value, use getParameterValues(java.lang.String).

        If you use this method with a multivalued parameter, the value returned is equal to the first value in the array returned by getParameterValues.

        If the parameter data was sent in the request body, such as occurs with an HTTP POST request, then reading the body directly via getInputStream() or getReader() can interfere with the execution of this method.

        Parameters:
        name - a String specifying the name of the parameter
        Returns:
        a String representing the single value of the parameter
        See Also:
        getParameterValues(java.lang.String)

      • getParameterNames

        Enumeration<String> getParameterNames()
        Returns an Enumeration of String objects containing the names of the parameters contained in this request. If the request has no parameters, the method returns an empty Enumeration.
        Returns:
        an Enumeration of String objects, each String containing the name of a request parameter; or an empty Enumeration if the request has no parameters

      • getParameterValues

        String[] getParameterValues(String name)
        Returns an array of String objects containing all of the values the given request parameter has, or null if the parameter does not exist.

        If the parameter has a single value, the array has a length of 1.

        Parameters:
        name - a String containing the name of the parameter whose value is requested
        Returns:
        an array of String objects containing the parameter's values
        See Also:
        getParameter(java.lang.String)

      • getParameterMap

        Map<String,String[]> getParameterMap()
        Returns a java.util.Map of the parameters of this request.

        Request parameters are extra information sent with the request. For HTTP servlets, parameters are contained in the query string or posted form data.

        Returns:
        an immutable java.util.Map containing parameter names as keys and parameter values as map values. The keys in the parameter map are of type String. The values in the parameter map are of type String array.

      • getProtocol

        String getProtocol()
        Returns the name and version of the protocol the request uses in the form protocol/majorVersion.minorVersion, for example, HTTP/1.1. For HTTP servlets, the value returned is the same as the value of the CGI variable SERVER_PROTOCOL.
        Returns:
        a String containing the protocol name and version number

      • getScheme

        String getScheme()
        Returns the name of the scheme used to make this request, for example, http, https, or ftp. Different schemes have different rules for constructing URLs, as noted in RFC 1738.
        Returns:
        a String containing the name of the scheme used to make this request

      • getServerName

        String getServerName()
        Returns the host name of the server to which the request was sent. It is the value of the part before ":" in the Host header value, if any, or the resolved server name, or the server IP address.
        Returns:
        a String containing the name of the server

      • getServerPort

        int getServerPort()
        Returns the port number to which the request was sent. It is the value of the part after ":" in the Host header value, if any, or the server port where the client connection was accepted on.
        Returns:
        an integer specifying the port number

      • getReader

        BufferedReader getReader()
                         throws IOException
        Retrieves the body of the request as character data using a BufferedReader. The reader translates the character data according to the character encoding used on the body. Either this method or getInputStream() may be called to read the body, not both.
        Returns:
        a BufferedReader containing the body of the request
        Throws:
        UnsupportedEncodingException - if the character set encoding used is not supported and the text cannot be decoded
        IllegalStateException - if getInputStream() method has been called on this request
        IOException - if an input or output exception occurred
        See Also:
        getInputStream()

      • getRemoteAddr

        String getRemoteAddr()
        Returns the Internet Protocol (IP) address of the client or last proxy that sent the request. For HTTP servlets, same as the value of the CGI variable REMOTE_ADDR.
        Returns:
        a String containing the IP address of the client that sent the request

      • getRemoteHost

        String getRemoteHost()
        Returns the fully qualified name of the client or the last proxy that sent the request. If the engine cannot or chooses not to resolve the hostname (to improve performance), this method returns the dotted-string form of the IP address. For HTTP servlets, same as the value of the CGI variable REMOTE_HOST.
        Returns:
        a String containing the fully qualified name of the client

      • setAttribute

        void setAttribute(String name,
                Object o)
        Stores an attribute in this request. Attributes are reset between requests. This method is most often used in conjunction with RequestDispatcher.

        Attribute names should follow the same conventions as package names. Names beginning with java.*, javax.*, and com.sun.*, are reserved for use by Sun Microsystems.
        If the object passed in is null, the effect is the same as calling removeAttribute(java.lang.String).
        It is warned that when the request is dispatched from the servlet resides in a different web application by RequestDispatcher, the object set by this method may not be correctly retrieved in the caller servlet.

        Parameters:
        name - a String specifying the name of the attribute
        o - the Object to be stored

      • removeAttribute

        void removeAttribute(String name)
        Removes an attribute from this request. This method is not generally needed as attributes only persist as long as the request is being handled.

        Attribute names should follow the same conventions as package names. Names beginning with java.*, javax.*, and com.sun.*, are reserved for use by Sun Microsystems.

        Parameters:
        name - a String specifying the name of the attribute to remove

      • getLocale

        Locale getLocale()
        Returns the preferred Locale that the client will accept content in, based on the Accept-Language header. If the client request doesn't provide an Accept-Language header, this method returns the default locale for the server.
        Returns:
        the preferred Locale for the client

      • getLocales

        Enumeration<Locale> getLocales()
        Returns an Enumeration of Locale objects indicating, in decreasing order starting with the preferred locale, the locales that are acceptable to the client based on the Accept-Language header. If the client request doesn't provide an Accept-Language header, this method returns an Enumeration containing one Locale, the default locale for the server.
        Returns:
        an Enumeration of preferred Locale objects for the client

      • isSecure

        boolean isSecure()
        Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.
        Returns:
        a boolean indicating if the request was made using a secure channel

      • getRequestDispatcher

        RequestDispatcher getRequestDispatcher(String path)
        Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path. A RequestDispatcher object can be used to forward a request to the resource or to include the resource in a response. The resource can be dynamic or static.

        The pathname specified may be relative, although it cannot extend outside the current servlet context. If the path begins with a "/" it is interpreted as relative to the current context root. This method returns null if the servlet container cannot return a RequestDispatcher.

        The difference between this method and ServletContext.getRequestDispatcher(java.lang.String) is that this method can take a relative path.

        Parameters:
        path - a String specifying the pathname to the resource. If it is relative, it must be relative against the current servlet.
        Returns:
        a RequestDispatcher object that acts as a wrapper for the resource at the specified path, or null if the servlet container cannot return a RequestDispatcher
        See Also:
        RequestDispatcher, ServletContext.getRequestDispatcher(java.lang.String)

      • getRealPath

        String getRealPath(String path)
        Deprecated. As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.

      • getRemotePort

        int getRemotePort()
        Returns the Internet Protocol (IP) source port of the client or last proxy that sent the request.
        Returns:
        an integer specifying the port number
        Since:
        Servlet 2.4

      • getLocalName

        String getLocalName()
        Returns the host name of the Internet Protocol (IP) interface on which the request was received.
        Returns:
        a String containing the host name of the IP on which the request was received.
        Since:
        Servlet 2.4

      • getLocalAddr

        String getLocalAddr()
        Returns the Internet Protocol (IP) address of the interface on which the request was received.
        Returns:
        a String containing the IP address on which the request was received.
        Since:
        Servlet 2.4

      • getLocalPort

        int getLocalPort()
        Returns the Internet Protocol (IP) port number of the interface on which the request was received.
        Returns:
        an integer specifying the port number
        Since:
        Servlet 2.4

      • getServletContext

        ServletContext getServletContext()
        Gets the servlet context to which this ServletRequest was last dispatched.
        Returns:
        the servlet context to which this ServletRequest was last dispatched
        Since:
        Servlet 3.0

      • startAsync

        AsyncContext startAsync()
                        throws IllegalStateException
        Puts this request into asynchronous mode, and initializes its AsyncContext with the original (unwrapped) ServletRequest and ServletResponse objects.

        Calling this method will cause committal of the associated response to be delayed until AsyncContext.complete() is called on the returned AsyncContext, or the asynchronous operation has timed out.

        Calling AsyncContext.hasOriginalRequestAndResponse() on the returned AsyncContext will return true. Any filters invoked in the outbound direction after this request was put into asynchronous mode may use this as an indication that any request and/or response wrappers that they added during their inbound invocation need not stay around for the duration of the asynchronous operation, and therefore any of their associated resources may be released.

        This method clears the list of AsyncListener instances (if any) that were registered with the AsyncContext returned by the previous call to one of the startAsync methods, after calling each AsyncListener at its onStartAsync method.

        Subsequent invocations of this method, or its overloaded variant, will return the same AsyncContext instance, reinitialized as appropriate.

        Returns:
        the (re)initialized AsyncContext
        Throws:
        IllegalStateException - if this request is within the scope of a filter or servlet that does not support asynchronous operations (that is, isAsyncSupported() returns false), or if this method is called again without any asynchronous dispatch (resulting from one of the AsyncContext.dispatch() methods), is called outside the scope of any such dispatch, or is called again within the scope of the same dispatch, or if the response has already been closed
        Since:
        Servlet 3.0
        See Also:
        AsyncContext.dispatch()

      • startAsync

        AsyncContext startAsync(ServletRequest servletRequest,
                      ServletResponse servletResponse)
                        throws IllegalStateException
        Puts this request into asynchronous mode, and initializes its AsyncContext with the given request and response objects.

        The ServletRequest and ServletResponse arguments must be the same instances, or instances of ServletRequestWrapper and ServletResponseWrapper that wrap them, that were passed to the service method of the Servlet or the doFilter method of the Filter, respectively, in whose scope this method is being called.

        Calling this method will cause committal of the associated response to be delayed until AsyncContext.complete() is called on the returned AsyncContext, or the asynchronous operation has timed out.

        Calling AsyncContext.hasOriginalRequestAndResponse() on the returned AsyncContext will return false, unless the passed in ServletRequest and ServletResponse arguments are the original ones or do not carry any application-provided wrappers. Any filters invoked in the outbound direction after this request was put into asynchronous mode may use this as an indication that some of the request and/or response wrappers that they added during their inbound invocation may need to stay in place for the duration of the asynchronous operation, and their associated resources may not be released. A ServletRequestWrapper applied during the inbound invocation of a filter may be released by the outbound invocation of the filter only if the given servletRequest, which is used to initialize the AsyncContext and will be returned by a call to AsyncContext.getRequest(), does not contain said ServletRequestWrapper. The same holds true for ServletResponseWrapper instances.

        This method clears the list of AsyncListener instances (if any) that were registered with the AsyncContext returned by the previous call to one of the startAsync methods, after calling each AsyncListener at its onStartAsync method.

        Subsequent invocations of this method, or its zero-argument variant, will return the same AsyncContext instance, reinitialized as appropriate. If a call to this method is followed by a call to its zero-argument variant, the specified (and possibly wrapped) request and response objects will remain locked in on the returned AsyncContext.

        Parameters:
        servletRequest - the ServletRequest used to initialize the AsyncContext
        servletResponse - the ServletResponse used to initialize the AsyncContext
        Returns:
        the (re)initialized AsyncContext
        Throws:
        IllegalStateException - if this request is within the scope of a filter or servlet that does not support asynchronous operations (that is, isAsyncSupported() returns false), or if this method is called again without any asynchronous dispatch (resulting from one of the AsyncContext.dispatch() methods), is called outside the scope of any such dispatch, or is called again within the scope of the same dispatch, or if the response has already been closed
        Since:
        Servlet 3.0

      • isAsyncStarted

        boolean isAsyncStarted()
        Checks if this request has been put into asynchronous mode.

        A ServletRequest is put into asynchronous mode by calling startAsync() or startAsync(ServletRequest,ServletResponse) on it.

        This method returns false if this request was put into asynchronous mode, but has since been dispatched using one of the AsyncContext.dispatch() methods or released from asynchronous mode via a call to AsyncContext.complete().

        Returns:
        true if this request has been put into asynchronous mode, false otherwise
        Since:
        Servlet 3.0

      • isAsyncSupported

        boolean isAsyncSupported()
        Checks if this request supports asynchronous operation.

        Asynchronous operation is disabled for this request if this request is within the scope of a filter or servlet that has not been annotated or flagged in the deployment descriptor as being able to support asynchronous handling.

        Returns:
        true if this request supports asynchronous operation, false otherwise
        Since:
        Servlet 3.0

      • getAsyncContext

        AsyncContext getAsyncContext()
        Gets the AsyncContext that was created or reinitialized by the most recent invocation of startAsync() or startAsync(ServletRequest,ServletResponse) on this request.
        Returns:
        the AsyncContext that was created or reinitialized by the most recent invocation of startAsync() or startAsync(ServletRequest,ServletResponse) on this request
        Throws:
        IllegalStateException - if this request has not been put into asynchronous mode, i.e., if neither startAsync() nor startAsync(ServletRequest,ServletResponse) has been called
        Since:
        Servlet 3.0

      • getDispatcherType

        DispatcherType getDispatcherType()
        Gets the dispatcher type of this request.

        The dispatcher type of a request is used by the container to select the filters that need to be applied to the request: Only filters with matching dispatcher type and url patterns will be applied.

        Allowing a filter that has been configured for multiple dispatcher types to query a request for its dispatcher type allows the filter to process the request differently depending on its dispatcher type.

        The initial dispatcher type of a request is defined as DispatcherType.REQUEST. The dispatcher type of a request dispatched via RequestDispatcher.forward(ServletRequest, ServletResponse) or RequestDispatcher.include(ServletRequest, ServletResponse) is given as DispatcherType.FORWARD or DispatcherType.INCLUDE, respectively, while the dispatcher type of an asynchronous request dispatched via one of the AsyncContext.dispatch() methods is given as DispatcherType.ASYNC. Finally, the dispatcher type of a request dispatched to an error page by the container's error handling mechanism is given as DispatcherType.ERROR.

        Returns:
        the dispatcher type of this request
        Since:
        Servlet 3.0
        See Also:
        DispatcherType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletRequestAttributeEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class ServletRequestAttributeEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.servlet.ServletRequestEvent
        • javax.servlet.ServletRequestAttributeEvent
  • All Implemented Interfaces:
    Serializable

    public class ServletRequestAttributeEvent
extends ServletRequestEvent
    This is the event class for notifications of changes to the attributes of the servlet request in an application.
    Since:
    Servlet 2.4
    See Also:
    ServletRequestAttributeListener, Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ServletRequestAttributeEvent(ServletContext sc, ServletRequest request, String name, Object value)
      Construct a ServletRequestAttributeEvent giving the servlet context of this web application, the ServletRequest whose attributes are changing and the name and value of the attribute.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Return the name of the attribute that changed on the ServletRequest.
      Object getValue()
      Returns the value of the attribute that has been added, removed or replaced.

      • Methods inherited from class javax.servlet.ServletRequestEvent

        getServletContext, getServletRequest

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServletRequestAttributeEvent

        public ServletRequestAttributeEvent(ServletContext sc,
                            ServletRequest request,
                            String name,
                            Object value)
        Construct a ServletRequestAttributeEvent giving the servlet context of this web application, the ServletRequest whose attributes are changing and the name and value of the attribute.
        Parameters:
        sc - the ServletContext that is sending the event.
        request - the ServletRequest that is sending the event.
        name - the name of the request attribute.
        value - the value of the request attribute.

    • Method Detail

      • getName

        public String getName()
        Return the name of the attribute that changed on the ServletRequest.
        Returns:
        the name of the changed request attribute

      • getValue

        public Object getValue()
        Returns the value of the attribute that has been added, removed or replaced. If the attribute was added, this is the value of the attribute. If the attribute was removed, this is the value of the removed attribute. If the attribute was replaced, this is the old value of the attribute.
        Returns:
        the value of the changed request attribute
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletRequestAttributeListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletRequestAttributeListener

  • All Superinterfaces:
    EventListener

    public interface ServletRequestAttributeListener
extends EventListener
    Interface for receiving notification events about ServletRequest attribute changes.

    Notifications will be generated while the request is within the scope of the web application. A ServletRequest is defined as coming into scope of a web application when it is about to enter the first servlet or filter of the web application, and as going out of scope when it exits the last servlet or the first filter in the chain.

    In order to receive these notification events, the implementation class must be either declared in the deployment descriptor of the web application, annotated with WebListener, or registered via one of the addListener methods defined on ServletContext.

    The order in which implementations of this interface are invoked is unspecified.

    Since:
    Servlet 2.4

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void attributeAdded(ServletRequestAttributeEvent srae)
      Receives notification that an attribute has been added to the ServletRequest.
      void attributeRemoved(ServletRequestAttributeEvent srae)
      Receives notification that an attribute has been removed from the ServletRequest.
      void attributeReplaced(ServletRequestAttributeEvent srae)
      Receives notification that an attribute has been replaced on the ServletRequest.

    • Method Detail

      • attributeAdded

        void attributeAdded(ServletRequestAttributeEvent srae)
        Receives notification that an attribute has been added to the ServletRequest.
        Parameters:
        srae - the ServletRequestAttributeEvent containing the ServletRequest and the name and value of the attribute that was added

      • attributeRemoved

        void attributeRemoved(ServletRequestAttributeEvent srae)
        Receives notification that an attribute has been removed from the ServletRequest.
        Parameters:
        srae - the ServletRequestAttributeEvent containing the ServletRequest and the name and value of the attribute that was removed

      • attributeReplaced

        void attributeReplaced(ServletRequestAttributeEvent srae)
        Receives notification that an attribute has been replaced on the ServletRequest.
        Parameters:
        srae - the ServletRequestAttributeEvent containing the ServletRequest and the name and (old) value of the attribute that was replaced
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletRequestEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class ServletRequestEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.servlet.ServletRequestEvent
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ServletRequestAttributeEvent

    public class ServletRequestEvent
extends EventObject
    Events of this kind indicate lifecycle events for a ServletRequest. The source of the event is the ServletContext of this web application.
    Since:
    Servlet 2.4
    See Also:
    ServletRequestListener, Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      ServletRequestEvent(ServletContext sc, ServletRequest request)
      Construct a ServletRequestEvent for the given ServletContext and ServletRequest.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ServletContext getServletContext()
      Returns the ServletContext of this web application.
      ServletRequest getServletRequest()
      Returns the ServletRequest that is changing.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServletRequestEvent

        public ServletRequestEvent(ServletContext sc,
                   ServletRequest request)
        Construct a ServletRequestEvent for the given ServletContext and ServletRequest.
        Parameters:
        sc - the ServletContext of the web application.
        request - the ServletRequest that is sending the event.

    • Method Detail

      • getServletRequest

        public ServletRequest getServletRequest()
        Returns the ServletRequest that is changing.

      • getServletContext

        public ServletContext getServletContext()
        Returns the ServletContext of this web application.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletRequestListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletRequestListener

  • All Superinterfaces:
    EventListener

    public interface ServletRequestListener
extends EventListener
    Interface for receiving notification events about requests coming into and going out of scope of a web application.

    A ServletRequest is defined as coming into scope of a web application when it is about to enter the first servlet or filter of the web application, and as going out of scope as it exits the last servlet or the first filter in the chain.

    In order to receive these notification events, the implementation class must be either declared in the deployment descriptor of the web application, annotated with WebListener, or registered via one of the addListener methods defined on ServletContext.

    Implementations of this interface are invoked at their requestInitialized(javax.servlet.ServletRequestEvent) method in the order in which they have been declared, and at their requestDestroyed(javax.servlet.ServletRequestEvent) method in reverse order.

    Since:
    Servlet 2.4

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void requestDestroyed(ServletRequestEvent sre)
      Receives notification that a ServletRequest is about to go out of scope of the web application.
      void requestInitialized(ServletRequestEvent sre)
      Receives notification that a ServletRequest is about to come into scope of the web application.

    • Method Detail

      • requestDestroyed

        void requestDestroyed(ServletRequestEvent sre)
        Receives notification that a ServletRequest is about to go out of scope of the web application.
        Parameters:
        sre - the ServletRequestEvent containing the ServletRequest and the ServletContext representing the web application

      • requestInitialized

        void requestInitialized(ServletRequestEvent sre)
        Receives notification that a ServletRequest is about to come into scope of the web application.
        Parameters:
        sre - the ServletRequestEvent containing the ServletRequest and the ServletContext representing the web application
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletRequestWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class ServletRequestWrapper

  • java.lang.Object
    • javax.servlet.ServletRequestWrapper
  • All Implemented Interfaces:
    ServletRequest
    Direct Known Subclasses:
    HttpServletRequestWrapper

    public class ServletRequestWrapper
extends Object
implements ServletRequest
    Provides a convenient implementation of the ServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped request object.
    Since:
    Servlet 2.3
    See Also:
    ServletRequest

    • Constructor Summary

      Constructors
      Constructor and Description
      ServletRequestWrapper(ServletRequest request)
      Creates a ServletRequest adaptor wrapping the given request object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      AsyncContext getAsyncContext()
      Gets the AsyncContext that was created or reinitialized by the most recent invocation of startAsync() or startAsync(ServletRequest,ServletResponse) on the wrapped request.
      Object getAttribute(String name)
      The default behavior of this method is to call getAttribute(String name) on the wrapped request object.
      Enumeration<String> getAttributeNames()
      The default behavior of this method is to return getAttributeNames() on the wrapped request object.
      String getCharacterEncoding()
      The default behavior of this method is to return getCharacterEncoding() on the wrapped request object.
      int getContentLength()
      The default behavior of this method is to return getContentLength() on the wrapped request object.
      long getContentLengthLong()
      The default behavior of this method is to return getContentLengthLong() on the wrapped request object.
      String getContentType()
      The default behavior of this method is to return getContentType() on the wrapped request object.
      DispatcherType getDispatcherType()
      Gets the dispatcher type of the wrapped request.
      ServletInputStream getInputStream()
      The default behavior of this method is to return getInputStream() on the wrapped request object.
      String getLocalAddr()
      The default behavior of this method is to return getLocalAddr() on the wrapped request object.
      Locale getLocale()
      The default behavior of this method is to return getLocale() on the wrapped request object.
      Enumeration<Locale> getLocales()
      The default behavior of this method is to return getLocales() on the wrapped request object.
      String getLocalName()
      The default behavior of this method is to return getLocalName() on the wrapped request object.
      int getLocalPort()
      The default behavior of this method is to return getLocalPort() on the wrapped request object.
      String getParameter(String name)
      The default behavior of this method is to return getParameter(String name) on the wrapped request object.
      Map<String,String[]> getParameterMap()
      The default behavior of this method is to return getParameterMap() on the wrapped request object.
      Enumeration<String> getParameterNames()
      The default behavior of this method is to return getParameterNames() on the wrapped request object.
      String[] getParameterValues(String name)
      The default behavior of this method is to return getParameterValues(String name) on the wrapped request object.
      String getProtocol()
      The default behavior of this method is to return getProtocol() on the wrapped request object.
      BufferedReader getReader()
      The default behavior of this method is to return getReader() on the wrapped request object.
      String getRealPath(String path)
      Deprecated.
      As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead
      String getRemoteAddr()
      The default behavior of this method is to return getRemoteAddr() on the wrapped request object.
      String getRemoteHost()
      The default behavior of this method is to return getRemoteHost() on the wrapped request object.
      int getRemotePort()
      The default behavior of this method is to return getRemotePort() on the wrapped request object.
      ServletRequest getRequest()
      Return the wrapped request object.
      RequestDispatcher getRequestDispatcher(String path)
      The default behavior of this method is to return getRequestDispatcher(String path) on the wrapped request object.
      String getScheme()
      The default behavior of this method is to return getScheme() on the wrapped request object.
      String getServerName()
      The default behavior of this method is to return getServerName() on the wrapped request object.
      int getServerPort()
      The default behavior of this method is to return getServerPort() on the wrapped request object.
      ServletContext getServletContext()
      Gets the servlet context to which the wrapped servlet request was last dispatched.
      boolean isAsyncStarted()
      Checks if the wrapped request has been put into asynchronous mode.
      boolean isAsyncSupported()
      Checks if the wrapped request supports asynchronous operation.
      boolean isSecure()
      The default behavior of this method is to return isSecure() on the wrapped request object.
      boolean isWrapperFor(Class<?> wrappedType)
      Checks (recursively) if this ServletRequestWrapper wraps a ServletRequest of the given class type.
      boolean isWrapperFor(ServletRequest wrapped)
      Checks (recursively) if this ServletRequestWrapper wraps the given ServletRequest instance.
      void removeAttribute(String name)
      The default behavior of this method is to call removeAttribute(String name) on the wrapped request object.
      void setAttribute(String name, Object o)
      The default behavior of this method is to return setAttribute(String name, Object o) on the wrapped request object.
      void setCharacterEncoding(String enc)
      The default behavior of this method is to set the character encoding on the wrapped request object.
      void setRequest(ServletRequest request)
      Sets the request object being wrapped.
      AsyncContext startAsync()
      The default behavior of this method is to invoke ServletRequest.startAsync() on the wrapped request object.
      AsyncContext startAsync(ServletRequest servletRequest, ServletResponse servletResponse)
      The default behavior of this method is to invoke ServletRequest.startAsync(ServletRequest, ServletResponse) on the wrapped request object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServletRequestWrapper

        public ServletRequestWrapper(ServletRequest request)
        Creates a ServletRequest adaptor wrapping the given request object.
        Throws:
        IllegalArgumentException - if the request is null

    • Method Detail

      • getRequest

        public ServletRequest getRequest()
        Return the wrapped request object.

      • setRequest

        public void setRequest(ServletRequest request)
        Sets the request object being wrapped.
        Throws:
        IllegalArgumentException - if the request is null.

      • getAttribute

        public Object getAttribute(String name)
        The default behavior of this method is to call getAttribute(String name) on the wrapped request object.
        Specified by:
        getAttribute in interface ServletRequest
        Parameters:
        name - a String specifying the name of the attribute
        Returns:
        an Object containing the value of the attribute, or null if the attribute does not exist

      • getAttributeNames

        public Enumeration<String> getAttributeNames()
        The default behavior of this method is to return getAttributeNames() on the wrapped request object.
        Specified by:
        getAttributeNames in interface ServletRequest
        Returns:
        an Enumeration of strings containing the names of the request's attributes

      • getCharacterEncoding

        public String getCharacterEncoding()
        The default behavior of this method is to return getCharacterEncoding() on the wrapped request object.
        Specified by:
        getCharacterEncoding in interface ServletRequest
        Returns:
        a String containing the name of the character encoding, or null if the request does not specify a character encoding

      • setCharacterEncoding

        public void setCharacterEncoding(String enc)
                          throws UnsupportedEncodingException
        The default behavior of this method is to set the character encoding on the wrapped request object.
        Specified by:
        setCharacterEncoding in interface ServletRequest
        Parameters:
        enc - String containing the name of the character encoding.
        Throws:
        UnsupportedEncodingException - if this ServletRequest is still in a state where a character encoding may be set, but the specified encoding is invalid

      • getContentLength

        public int getContentLength()
        The default behavior of this method is to return getContentLength() on the wrapped request object.
        Specified by:
        getContentLength in interface ServletRequest
        Returns:
        an integer containing the length of the request body or -1 if the length is not known or is greater than Integer.MAX_VALUE.

      • getContentLengthLong

        public long getContentLengthLong()
        The default behavior of this method is to return getContentLengthLong() on the wrapped request object.
        Specified by:
        getContentLengthLong in interface ServletRequest
        Returns:
        a long containing the length of the request body or -1L if the length is not known
        Since:
        Servlet 3.1

      • getContentType

        public String getContentType()
        The default behavior of this method is to return getContentType() on the wrapped request object.
        Specified by:
        getContentType in interface ServletRequest
        Returns:
        a String containing the name of the MIME type of the request, or null if the type is not known

      • getInputStream

        public ServletInputStream getInputStream()
                                  throws IOException
        The default behavior of this method is to return getInputStream() on the wrapped request object.
        Specified by:
        getInputStream in interface ServletRequest
        Returns:
        a ServletInputStream object containing the body of the request
        Throws:
        IOException - if an input or output exception occurred

      • getParameter

        public String getParameter(String name)
        The default behavior of this method is to return getParameter(String name) on the wrapped request object.
        Specified by:
        getParameter in interface ServletRequest
        Parameters:
        name - a String specifying the name of the parameter
        Returns:
        a String representing the single value of the parameter
        See Also:
        ServletRequest.getParameterValues(java.lang.String)

      • getParameterMap

        public Map<String,String[]> getParameterMap()
        The default behavior of this method is to return getParameterMap() on the wrapped request object.
        Specified by:
        getParameterMap in interface ServletRequest
        Returns:
        an immutable java.util.Map containing parameter names as keys and parameter values as map values. The keys in the parameter map are of type String. The values in the parameter map are of type String array.

      • getParameterNames

        public Enumeration<String> getParameterNames()
        The default behavior of this method is to return getParameterNames() on the wrapped request object.
        Specified by:
        getParameterNames in interface ServletRequest
        Returns:
        an Enumeration of String objects, each String containing the name of a request parameter; or an empty Enumeration if the request has no parameters

      • getParameterValues

        public String[] getParameterValues(String name)
        The default behavior of this method is to return getParameterValues(String name) on the wrapped request object.
        Specified by:
        getParameterValues in interface ServletRequest
        Parameters:
        name - a String containing the name of the parameter whose value is requested
        Returns:
        an array of String objects containing the parameter's values
        See Also:
        ServletRequest.getParameter(java.lang.String)

      • getProtocol

        public String getProtocol()
        The default behavior of this method is to return getProtocol() on the wrapped request object.
        Specified by:
        getProtocol in interface ServletRequest
        Returns:
        a String containing the protocol name and version number

      • getScheme

        public String getScheme()
        The default behavior of this method is to return getScheme() on the wrapped request object.
        Specified by:
        getScheme in interface ServletRequest
        Returns:
        a String containing the name of the scheme used to make this request

      • getServerName

        public String getServerName()
        The default behavior of this method is to return getServerName() on the wrapped request object.
        Specified by:
        getServerName in interface ServletRequest
        Returns:
        a String containing the name of the server

      • getServerPort

        public int getServerPort()
        The default behavior of this method is to return getServerPort() on the wrapped request object.
        Specified by:
        getServerPort in interface ServletRequest
        Returns:
        an integer specifying the port number

      • getReader

        public BufferedReader getReader()
                         throws IOException
        The default behavior of this method is to return getReader() on the wrapped request object.
        Specified by:
        getReader in interface ServletRequest
        Returns:
        a BufferedReader containing the body of the request
        Throws:
        UnsupportedEncodingException - if the character set encoding used is not supported and the text cannot be decoded
        IOException - if an input or output exception occurred
        See Also:
        ServletRequest.getInputStream()

      • getRemoteAddr

        public String getRemoteAddr()
        The default behavior of this method is to return getRemoteAddr() on the wrapped request object.
        Specified by:
        getRemoteAddr in interface ServletRequest
        Returns:
        a String containing the IP address of the client that sent the request

      • getRemoteHost

        public String getRemoteHost()
        The default behavior of this method is to return getRemoteHost() on the wrapped request object.
        Specified by:
        getRemoteHost in interface ServletRequest
        Returns:
        a String containing the fully qualified name of the client

      • setAttribute

        public void setAttribute(String name,
                Object o)
        The default behavior of this method is to return setAttribute(String name, Object o) on the wrapped request object.
        Specified by:
        setAttribute in interface ServletRequest
        Parameters:
        name - a String specifying the name of the attribute
        o - the Object to be stored

      • removeAttribute

        public void removeAttribute(String name)
        The default behavior of this method is to call removeAttribute(String name) on the wrapped request object.
        Specified by:
        removeAttribute in interface ServletRequest
        Parameters:
        name - a String specifying the name of the attribute to remove

      • getLocale

        public Locale getLocale()
        The default behavior of this method is to return getLocale() on the wrapped request object.
        Specified by:
        getLocale in interface ServletRequest
        Returns:
        the preferred Locale for the client

      • getLocales

        public Enumeration<Locale> getLocales()
        The default behavior of this method is to return getLocales() on the wrapped request object.
        Specified by:
        getLocales in interface ServletRequest
        Returns:
        an Enumeration of preferred Locale objects for the client

      • isSecure

        public boolean isSecure()
        The default behavior of this method is to return isSecure() on the wrapped request object.
        Specified by:
        isSecure in interface ServletRequest
        Returns:
        a boolean indicating if the request was made using a secure channel

      • getRequestDispatcher

        public RequestDispatcher getRequestDispatcher(String path)
        The default behavior of this method is to return getRequestDispatcher(String path) on the wrapped request object.
        Specified by:
        getRequestDispatcher in interface ServletRequest
        Parameters:
        path - a String specifying the pathname to the resource. If it is relative, it must be relative against the current servlet.
        Returns:
        a RequestDispatcher object that acts as a wrapper for the resource at the specified path, or null if the servlet container cannot return a RequestDispatcher
        See Also:
        RequestDispatcher, ServletContext.getRequestDispatcher(java.lang.String)

      • getRealPath

        public String getRealPath(String path)
        Deprecated. As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead
        The default behavior of this method is to return getRealPath(String path) on the wrapped request object.
        Specified by:
        getRealPath in interface ServletRequest

      • getRemotePort

        public int getRemotePort()
        The default behavior of this method is to return getRemotePort() on the wrapped request object.
        Specified by:
        getRemotePort in interface ServletRequest
        Returns:
        an integer specifying the port number
        Since:
        Servlet 2.4

      • getLocalName

        public String getLocalName()
        The default behavior of this method is to return getLocalName() on the wrapped request object.
        Specified by:
        getLocalName in interface ServletRequest
        Returns:
        a String containing the host name of the IP on which the request was received.
        Since:
        Servlet 2.4

      • getLocalAddr

        public String getLocalAddr()
        The default behavior of this method is to return getLocalAddr() on the wrapped request object.
        Specified by:
        getLocalAddr in interface ServletRequest
        Returns:
        a String containing the IP address on which the request was received.
        Since:
        Servlet 2.4

      • getLocalPort

        public int getLocalPort()
        The default behavior of this method is to return getLocalPort() on the wrapped request object.
        Specified by:
        getLocalPort in interface ServletRequest
        Returns:
        an integer specifying the port number
        Since:
        Servlet 2.4

      • getServletContext

        public ServletContext getServletContext()
        Gets the servlet context to which the wrapped servlet request was last dispatched.
        Specified by:
        getServletContext in interface ServletRequest
        Returns:
        the servlet context to which the wrapped servlet request was last dispatched
        Since:
        Servlet 3.0

      • startAsync

        public AsyncContext startAsync()
                        throws IllegalStateException
        The default behavior of this method is to invoke ServletRequest.startAsync() on the wrapped request object.
        Specified by:
        startAsync in interface ServletRequest
        Returns:
        the (re)initialized AsyncContext
        Throws:
        IllegalStateException - if the request is within the scope of a filter or servlet that does not support asynchronous operations (that is, isAsyncSupported() returns false), or if this method is called again without any asynchronous dispatch (resulting from one of the AsyncContext.dispatch() methods), is called outside the scope of any such dispatch, or is called again within the scope of the same dispatch, or if the response has already been closed
        Since:
        Servlet 3.0
        See Also:
        ServletRequest.startAsync()

      • startAsync

        public AsyncContext startAsync(ServletRequest servletRequest,
                      ServletResponse servletResponse)
                        throws IllegalStateException
        The default behavior of this method is to invoke ServletRequest.startAsync(ServletRequest, ServletResponse) on the wrapped request object.
        Specified by:
        startAsync in interface ServletRequest
        Parameters:
        servletRequest - the ServletRequest used to initialize the AsyncContext
        servletResponse - the ServletResponse used to initialize the AsyncContext
        Returns:
        the (re)initialized AsyncContext
        Throws:
        IllegalStateException - if the request is within the scope of a filter or servlet that does not support asynchronous operations (that is, isAsyncSupported() returns false), or if this method is called again without any asynchronous dispatch (resulting from one of the AsyncContext.dispatch() methods), is called outside the scope of any such dispatch, or is called again within the scope of the same dispatch, or if the response has already been closed
        Since:
        Servlet 3.0
        See Also:
        ServletRequest.startAsync(ServletRequest, ServletResponse)

      • isAsyncStarted

        public boolean isAsyncStarted()
        Checks if the wrapped request has been put into asynchronous mode.
        Specified by:
        isAsyncStarted in interface ServletRequest
        Returns:
        true if this request has been put into asynchronous mode, false otherwise
        Since:
        Servlet 3.0
        See Also:
        ServletRequest.isAsyncStarted()

      • isAsyncSupported

        public boolean isAsyncSupported()
        Checks if the wrapped request supports asynchronous operation.
        Specified by:
        isAsyncSupported in interface ServletRequest
        Returns:
        true if this request supports asynchronous operation, false otherwise
        Since:
        Servlet 3.0
        See Also:
        ServletRequest.isAsyncSupported()

      • getAsyncContext

        public AsyncContext getAsyncContext()
        Gets the AsyncContext that was created or reinitialized by the most recent invocation of startAsync() or startAsync(ServletRequest,ServletResponse) on the wrapped request.
        Specified by:
        getAsyncContext in interface ServletRequest
        Returns:
        the AsyncContext that was created or reinitialized by the most recent invocation of startAsync() or startAsync(ServletRequest,ServletResponse) on the wrapped request
        Throws:
        IllegalStateException - if this request has not been put into asynchronous mode, i.e., if neither startAsync() nor startAsync(ServletRequest,ServletResponse) has been called
        Since:
        Servlet 3.0
        See Also:
        ServletRequest.getAsyncContext()

      • isWrapperFor

        public boolean isWrapperFor(ServletRequest wrapped)
        Checks (recursively) if this ServletRequestWrapper wraps the given ServletRequest instance.
        Parameters:
        wrapped - the ServletRequest instance to search for
        Returns:
        true if this ServletRequestWrapper wraps the given ServletRequest instance, false otherwise
        Since:
        Servlet 3.0

      • isWrapperFor

        public boolean isWrapperFor(Class<?> wrappedType)
        Checks (recursively) if this ServletRequestWrapper wraps a ServletRequest of the given class type.
        Parameters:
        wrappedType - the ServletRequest class type to search for
        Returns:
        true if this ServletRequestWrapper wraps a ServletRequest of the given class type, false otherwise
        Throws:
        IllegalArgumentException - if the given class does not implement ServletRequest
        Since:
        Servlet 3.0

      • getDispatcherType

        public DispatcherType getDispatcherType()
        Gets the dispatcher type of the wrapped request.
        Specified by:
        getDispatcherType in interface ServletRequest
        Returns:
        the dispatcher type of the wrapped request
        Since:
        Servlet 3.0
        See Also:
        ServletRequest.getDispatcherType()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletResponse (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface ServletResponse

  • All Known Subinterfaces:
    HttpServletResponse
    All Known Implementing Classes:
    HttpServletResponseWrapper, ServletResponseWrapper

    public interface ServletResponse
    Defines an object to assist a servlet in sending a response to the client. The servlet container creates a ServletResponse object and passes it as an argument to the servlet's service method.

    To send binary data in a MIME body response, use the ServletOutputStream returned by getOutputStream(). To send character data, use the PrintWriter object returned by getWriter(). To mix binary and text data, for example, to create a multipart response, use a ServletOutputStream and manage the character sections manually.

    The charset for the MIME body response can be specified explicitly using the setCharacterEncoding(java.lang.String) and setContentType(java.lang.String) methods, or implicitly using the setLocale(java.util.Locale) method. Explicit specifications take precedence over implicit specifications. If no charset is specified, ISO-8859-1 will be used. The setCharacterEncoding, setContentType, or setLocale method must be called before getWriter and before committing the response for the character encoding to be used.

    See the Internet RFCs such as RFC 2045 for more information on MIME. Protocols such as SMTP and HTTP define profiles of MIME, and those standards are still evolving.

    Author:
    Various
    See Also:
    ServletOutputStream

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void flushBuffer()
      Forces any content in the buffer to be written to the client.
      int getBufferSize()
      Returns the actual buffer size used for the response.
      String getCharacterEncoding()
      Returns the name of the character encoding (MIME charset) used for the body sent in this response.
      String getContentType()
      Returns the content type used for the MIME body sent in this response.
      Locale getLocale()
      Returns the locale specified for this response using the setLocale(java.util.Locale) method.
      ServletOutputStream getOutputStream()
      Returns a ServletOutputStream suitable for writing binary data in the response.
      PrintWriter getWriter()
      Returns a PrintWriter object that can send character text to the client.
      boolean isCommitted()
      Returns a boolean indicating if the response has been committed.
      void reset()
      Clears any data that exists in the buffer as well as the status code, headers.
      void resetBuffer()
      Clears the content of the underlying buffer in the response without clearing headers or status code.
      void setBufferSize(int size)
      Sets the preferred buffer size for the body of the response.
      void setCharacterEncoding(String charset)
      Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8.
      void setContentLength(int len)
      Sets the length of the content body in the response In HTTP servlets, this method sets the HTTP Content-Length header.
      void setContentLengthLong(long len)
      Sets the length of the content body in the response In HTTP servlets, this method sets the HTTP Content-Length header.
      void setContentType(String type)
      Sets the content type of the response being sent to the client, if the response has not been committed yet.
      void setLocale(Locale loc)
      Sets the locale of the response, if the response has not been committed yet.

    • Method Detail

      • getCharacterEncoding

        String getCharacterEncoding()
        Returns the name of the character encoding (MIME charset) used for the body sent in this response. The character encoding may have been specified explicitly using the setCharacterEncoding(java.lang.String) or setContentType(java.lang.String) methods, or implicitly using the setLocale(java.util.Locale) method. Explicit specifications take precedence over implicit specifications. Calls made to these methods after getWriter has been called or after the response has been committed have no effect on the character encoding. If no character encoding has been specified, ISO-8859-1 is returned.

        See RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt) for more information about character encoding and MIME.

        Returns:
        a String specifying the name of the character encoding, for example, UTF-8

      • getContentType

        String getContentType()
        Returns the content type used for the MIME body sent in this response. The content type proper must have been specified using setContentType(java.lang.String) before the response is committed. If no content type has been specified, this method returns null. If a content type has been specified, and a character encoding has been explicitly or implicitly specified as described in getCharacterEncoding() or getWriter() has been called, the charset parameter is included in the string returned. If no character encoding has been specified, the charset parameter is omitted.
        Returns:
        a String specifying the content type, for example, text/html; charset=UTF-8, or null
        Since:
        Servlet 2.4

      • getOutputStream

        ServletOutputStream getOutputStream()
                                    throws IOException
        Returns a ServletOutputStream suitable for writing binary data in the response. The servlet container does not encode the binary data.

        Calling flush() on the ServletOutputStream commits the response. Either this method or getWriter() may be called to write the body, not both, except when reset() has been called.

        Returns:
        a ServletOutputStream for writing binary data
        Throws:
        IllegalStateException - if the getWriter method has been called on this response
        IOException - if an input or output exception occurred
        See Also:
        getWriter(), reset()

      • getWriter

        PrintWriter getWriter()
                      throws IOException
        Returns a PrintWriter object that can send character text to the client. The PrintWriter uses the character encoding returned by getCharacterEncoding(). If the response's character encoding has not been specified as described in getCharacterEncoding (i.e., the method just returns the default value ISO-8859-1), getWriter updates it to ISO-8859-1.

        Calling flush() on the PrintWriter commits the response.

        Either this method or getOutputStream() may be called to write the body, not both, except when reset() has been called.

        Returns:
        a PrintWriter object that can return character data to the client
        Throws:
        UnsupportedEncodingException - if the character encoding returned by getCharacterEncoding cannot be used
        IllegalStateException - if the getOutputStream method has already been called for this response object
        IOException - if an input or output exception occurred
        See Also:
        getOutputStream(),
setCharacterEncoding(java.lang.String),
reset()

      • setCharacterEncoding

        void setCharacterEncoding(String charset)
        Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8. If the character encoding has already been set by setContentType(java.lang.String) or setLocale(java.util.Locale), this method overrides it. Calling setContentType(java.lang.String) with the String of text/html and calling this method with the String of UTF-8 is equivalent with calling setContentType with the String of text/html; charset=UTF-8.

        This method can be called repeatedly to change the character encoding. This method has no effect if it is called after getWriter has been called or after the response has been committed.

        Containers must communicate the character encoding used for the servlet response's writer to the client if the protocol provides a way for doing so. In the case of HTTP, the character encoding is communicated as part of the Content-Type header for text media types. Note that the character encoding cannot be communicated via HTTP headers if the servlet does not specify a content type; however, it is still used to encode text written via the servlet response's writer.

        Parameters:
        charset - a String specifying only the character set defined by IANA Character Sets (http://www.iana.org/assignments/character-sets)
        Since:
        Servlet 2.4
        See Also:
        setContentType(java.lang.String), setLocale(java.util.Locale)

      • setContentLength

        void setContentLength(int len)
        Sets the length of the content body in the response In HTTP servlets, this method sets the HTTP Content-Length header.
        Parameters:
        len - an integer specifying the length of the content being returned to the client; sets the Content-Length header

      • setContentLengthLong

        void setContentLengthLong(long len)
        Sets the length of the content body in the response In HTTP servlets, this method sets the HTTP Content-Length header.
        Parameters:
        len - a long specifying the length of the content being returned to the client; sets the Content-Length header
        Since:
        Servlet 3.1

      • setContentType

        void setContentType(String type)
        Sets the content type of the response being sent to the client, if the response has not been committed yet. The given content type may include a character encoding specification, for example, text/html;charset=UTF-8. The response's character encoding is only set from the given content type if this method is called before getWriter is called.

        This method may be called repeatedly to change content type and character encoding. This method has no effect if called after the response has been committed. It does not set the response's character encoding if it is called after getWriter has been called or after the response has been committed.

        Containers must communicate the content type and the character encoding used for the servlet response's writer to the client if the protocol provides a way for doing so. In the case of HTTP, the Content-Type header is used.

        Parameters:
        type - a String specifying the MIME type of the content
        See Also:
        setLocale(java.util.Locale),
setCharacterEncoding(java.lang.String),
getOutputStream(),
getWriter()

      • setBufferSize

        void setBufferSize(int size)
        Sets the preferred buffer size for the body of the response. The servlet container will use a buffer at least as large as the size requested. The actual buffer size used can be found using getBufferSize.

        A larger buffer allows more content to be written before anything is actually sent, thus providing the servlet with more time to set appropriate status codes and headers. A smaller buffer decreases server memory load and allows the client to start receiving data more quickly.

        This method must be called before any response body content is written; if content has been written or the response object has been committed, this method throws an IllegalStateException.

        Parameters:
        size - the preferred buffer size
        Throws:
        IllegalStateException - if this method is called after content has been written
        See Also:
        getBufferSize(),
flushBuffer(),
isCommitted(),
reset()

      • getBufferSize

        int getBufferSize()
        Returns the actual buffer size used for the response. If no buffering is used, this method returns 0.
        Returns:
        the actual buffer size used
        See Also:
        setBufferSize(int),
flushBuffer(),
isCommitted(),
reset()

      • flushBuffer

        void flushBuffer()
                 throws IOException
        Forces any content in the buffer to be written to the client. A call to this method automatically commits the response, meaning the status code and headers will be written.
        Throws:
        IOException
        See Also:
        setBufferSize(int),
getBufferSize(),
isCommitted(),
reset()

      • resetBuffer

        void resetBuffer()
        Clears the content of the underlying buffer in the response without clearing headers or status code. If the response has been committed, this method throws an IllegalStateException.
        Since:
        Servlet 2.3
        See Also:
        setBufferSize(int),
getBufferSize(),
isCommitted(),
reset()

      • isCommitted

        boolean isCommitted()
        Returns a boolean indicating if the response has been committed. A committed response has already had its status code and headers written.
        Returns:
        a boolean indicating if the response has been committed
        See Also:
        setBufferSize(int),
getBufferSize(),
flushBuffer(),
reset()

      • reset

        void reset()
        Clears any data that exists in the buffer as well as the status code, headers. The state of calling getWriter() or getOutputStream() is also cleared. It is legal, for instance, to call getWriter(), reset() and then getOutputStream(). If getWriter() or getOutputStream() have been called before this method, then the corrresponding returned Writer or OutputStream will be staled and the behavior of using the stale object is undefined. If the response has been committed, this method throws an IllegalStateException.
        Throws:
        IllegalStateException - if the response has already been committed
        See Also:
        setBufferSize(int),
getBufferSize(),
flushBuffer(),
isCommitted()

      • setLocale

        void setLocale(Locale loc)
        Sets the locale of the response, if the response has not been committed yet. It also sets the response's character encoding appropriately for the locale, if the character encoding has not been explicitly set using setContentType(java.lang.String) or setCharacterEncoding(java.lang.String), getWriter hasn't been called yet, and the response hasn't been committed yet. If the deployment descriptor contains a locale-encoding-mapping-list element, and that element provides a mapping for the given locale, that mapping is used. Otherwise, the mapping from locale to character encoding is container dependent.

        This method may be called repeatedly to change locale and character encoding. The method has no effect if called after the response has been committed. It does not set the response's character encoding if it is called after setContentType(java.lang.String) has been called with a charset specification, after setCharacterEncoding(java.lang.String) has been called, after getWriter has been called, or after the response has been committed.

        Containers must communicate the locale and the character encoding used for the servlet response's writer to the client if the protocol provides a way for doing so. In the case of HTTP, the locale is communicated via the Content-Language header, the character encoding as part of the Content-Type header for text media types. Note that the character encoding cannot be communicated via HTTP headers if the servlet does not specify a content type; however, it is still used to encode text written via the servlet response's writer.

        Parameters:
        loc - the locale of the response
        See Also:
        getLocale(),
setContentType(java.lang.String),
setCharacterEncoding(java.lang.String)

      • getLocale

        Locale getLocale()
        Returns the locale specified for this response using the setLocale(java.util.Locale) method. Calls made to setLocale after the response is committed have no effect. If no locale has been specified, the container's default locale is returned.
        See Also:
        setLocale(java.util.Locale)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletResponseWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class ServletResponseWrapper

  • java.lang.Object
    • javax.servlet.ServletResponseWrapper
  • All Implemented Interfaces:
    ServletResponse
    Direct Known Subclasses:
    HttpServletResponseWrapper

    public class ServletResponseWrapper
extends Object
implements ServletResponse
    Provides a convenient implementation of the ServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped response object.
    Since:
    Servlet 2.3
    Author:
    Various
    See Also:
    ServletResponse

    • Constructor Summary

      Constructors
      Constructor and Description
      ServletResponseWrapper(ServletResponse response)
      Creates a ServletResponse adaptor wrapping the given response object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void flushBuffer()
      The default behavior of this method is to call flushBuffer() on the wrapped response object.
      int getBufferSize()
      The default behavior of this method is to return getBufferSize() on the wrapped response object.
      String getCharacterEncoding()
      The default behavior of this method is to return getCharacterEncoding() on the wrapped response object.
      String getContentType()
      The default behavior of this method is to return getContentType() on the wrapped response object.
      Locale getLocale()
      The default behavior of this method is to return getLocale() on the wrapped response object.
      ServletOutputStream getOutputStream()
      The default behavior of this method is to return getOutputStream() on the wrapped response object.
      ServletResponse getResponse()
      Return the wrapped ServletResponse object.
      PrintWriter getWriter()
      The default behavior of this method is to return getWriter() on the wrapped response object.
      boolean isCommitted()
      The default behavior of this method is to return isCommitted() on the wrapped response object.
      boolean isWrapperFor(Class<?> wrappedType)
      Checks (recursively) if this ServletResponseWrapper wraps a ServletResponse of the given class type.
      boolean isWrapperFor(ServletResponse wrapped)
      Checks (recursively) if this ServletResponseWrapper wraps the given ServletResponse instance.
      void reset()
      The default behavior of this method is to call reset() on the wrapped response object.
      void resetBuffer()
      The default behavior of this method is to call resetBuffer() on the wrapped response object.
      void setBufferSize(int size)
      The default behavior of this method is to call setBufferSize(int size) on the wrapped response object.
      void setCharacterEncoding(String charset)
      The default behavior of this method is to call setCharacterEncoding(String charset) on the wrapped response object.
      void setContentLength(int len)
      The default behavior of this method is to call setContentLength(int len) on the wrapped response object.
      void setContentLengthLong(long len)
      The default behavior of this method is to call setContentLengthLong(long len) on the wrapped response object.
      void setContentType(String type)
      The default behavior of this method is to call setContentType(String type) on the wrapped response object.
      void setLocale(Locale loc)
      The default behavior of this method is to call setLocale(Locale loc) on the wrapped response object.
      void setResponse(ServletResponse response)
      Sets the response being wrapped.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServletResponseWrapper

        public ServletResponseWrapper(ServletResponse response)
        Creates a ServletResponse adaptor wrapping the given response object.
        Throws:
        IllegalArgumentException - if the response is null.

    • Method Detail

      • getResponse

        public ServletResponse getResponse()
        Return the wrapped ServletResponse object.

      • setResponse

        public void setResponse(ServletResponse response)
        Sets the response being wrapped.
        Throws:
        IllegalArgumentException - if the response is null.

      • setCharacterEncoding

        public void setCharacterEncoding(String charset)
        The default behavior of this method is to call setCharacterEncoding(String charset) on the wrapped response object.
        Specified by:
        setCharacterEncoding in interface ServletResponse
        Parameters:
        charset - a String specifying only the character set defined by IANA Character Sets (http://www.iana.org/assignments/character-sets)
        Since:
        Servlet 2.4
        See Also:
        ServletResponse.setContentType(java.lang.String), ServletResponse.setLocale(java.util.Locale)

      • getCharacterEncoding

        public String getCharacterEncoding()
        The default behavior of this method is to return getCharacterEncoding() on the wrapped response object.
        Specified by:
        getCharacterEncoding in interface ServletResponse
        Returns:
        a String specifying the name of the character encoding, for example, UTF-8

      • getOutputStream

        public ServletOutputStream getOutputStream()
                                    throws IOException
        The default behavior of this method is to return getOutputStream() on the wrapped response object.
        Specified by:
        getOutputStream in interface ServletResponse
        Returns:
        a ServletOutputStream for writing binary data
        Throws:
        IOException - if an input or output exception occurred
        See Also:
        ServletResponse.getWriter(), ServletResponse.reset()

      • getWriter

        public PrintWriter getWriter()
                      throws IOException
        The default behavior of this method is to return getWriter() on the wrapped response object.
        Specified by:
        getWriter in interface ServletResponse
        Returns:
        a PrintWriter object that can return character data to the client
        Throws:
        UnsupportedEncodingException - if the character encoding returned by getCharacterEncoding cannot be used
        IOException - if an input or output exception occurred
        See Also:
        ServletResponse.getOutputStream(),
ServletResponse.setCharacterEncoding(java.lang.String),
ServletResponse.reset()

      • setContentLength

        public void setContentLength(int len)
        The default behavior of this method is to call setContentLength(int len) on the wrapped response object.
        Specified by:
        setContentLength in interface ServletResponse
        Parameters:
        len - an integer specifying the length of the content being returned to the client; sets the Content-Length header

      • setContentLengthLong

        public void setContentLengthLong(long len)
        The default behavior of this method is to call setContentLengthLong(long len) on the wrapped response object.
        Specified by:
        setContentLengthLong in interface ServletResponse
        Parameters:
        len - a long specifying the length of the content being returned to the client; sets the Content-Length header

      • setContentType

        public void setContentType(String type)
        The default behavior of this method is to call setContentType(String type) on the wrapped response object.
        Specified by:
        setContentType in interface ServletResponse
        Parameters:
        type - a String specifying the MIME type of the content
        See Also:
        ServletResponse.setLocale(java.util.Locale),
ServletResponse.setCharacterEncoding(java.lang.String),
ServletResponse.getOutputStream(),
ServletResponse.getWriter()

      • getContentType

        public String getContentType()
        The default behavior of this method is to return getContentType() on the wrapped response object.
        Specified by:
        getContentType in interface ServletResponse
        Returns:
        a String specifying the content type, for example, text/html; charset=UTF-8, or null
        Since:
        Servlet 2.4

      • setBufferSize

        public void setBufferSize(int size)
        The default behavior of this method is to call setBufferSize(int size) on the wrapped response object.
        Specified by:
        setBufferSize in interface ServletResponse
        Parameters:
        size - the preferred buffer size
        See Also:
        ServletResponse.getBufferSize(),
ServletResponse.flushBuffer(),
ServletResponse.isCommitted(),
ServletResponse.reset()

      • getBufferSize

        public int getBufferSize()
        The default behavior of this method is to return getBufferSize() on the wrapped response object.
        Specified by:
        getBufferSize in interface ServletResponse
        Returns:
        the actual buffer size used
        See Also:
        ServletResponse.setBufferSize(int),
ServletResponse.flushBuffer(),
ServletResponse.isCommitted(),
ServletResponse.reset()

      • flushBuffer

        public void flushBuffer()
                 throws IOException
        The default behavior of this method is to call flushBuffer() on the wrapped response object.
        Specified by:
        flushBuffer in interface ServletResponse
        Throws:
        IOException
        See Also:
        ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.isCommitted(),
ServletResponse.reset()

      • isCommitted

        public boolean isCommitted()
        The default behavior of this method is to return isCommitted() on the wrapped response object.
        Specified by:
        isCommitted in interface ServletResponse
        Returns:
        a boolean indicating if the response has been committed
        See Also:
        ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.flushBuffer(),
ServletResponse.reset()

      • reset

        public void reset()
        The default behavior of this method is to call reset() on the wrapped response object.
        Specified by:
        reset in interface ServletResponse
        See Also:
        ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.flushBuffer(),
ServletResponse.isCommitted()

      • resetBuffer

        public void resetBuffer()
        The default behavior of this method is to call resetBuffer() on the wrapped response object.
        Specified by:
        resetBuffer in interface ServletResponse
        See Also:
        ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.isCommitted(),
ServletResponse.reset()

      • setLocale

        public void setLocale(Locale loc)
        The default behavior of this method is to call setLocale(Locale loc) on the wrapped response object.
        Specified by:
        setLocale in interface ServletResponse
        Parameters:
        loc - the locale of the response
        See Also:
        ServletResponse.getLocale(),
ServletResponse.setContentType(java.lang.String),
ServletResponse.setCharacterEncoding(java.lang.String)

      • getLocale

        public Locale getLocale()
        The default behavior of this method is to return getLocale() on the wrapped response object.
        Specified by:
        getLocale in interface ServletResponse
        See Also:
        ServletResponse.setLocale(java.util.Locale)

      • isWrapperFor

        public boolean isWrapperFor(ServletResponse wrapped)
        Checks (recursively) if this ServletResponseWrapper wraps the given ServletResponse instance.
        Parameters:
        wrapped - the ServletResponse instance to search for
        Returns:
        true if this ServletResponseWrapper wraps the given ServletResponse instance, false otherwise
        Since:
        Servlet 3.0

      • isWrapperFor

        public boolean isWrapperFor(Class<?> wrappedType)
        Checks (recursively) if this ServletResponseWrapper wraps a ServletResponse of the given class type.
        Parameters:
        wrappedType - the ServletResponse class type to search for
        Returns:
        true if this ServletResponseWrapper wraps a ServletResponse of the given class type, false otherwise
        Throws:
        IllegalArgumentException - if the given class does not implement ServletResponse
        Since:
        Servlet 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletSecurityElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class ServletSecurityElement

  • java.lang.Object
    • javax.servlet.HttpConstraintElement
      • javax.servlet.ServletSecurityElement

  • public class ServletSecurityElement
extends HttpConstraintElement
    Java Class represntation of a ServletSecurity annotation value.
    Since:
    Servlet 3.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ServletSecurityElement()
      Constructs an instance using the default HttpConstraintElement value as the default Constraint element and with no HTTP Method specific constraint elements.
      ServletSecurityElement(Collection<HttpMethodConstraintElement> methodConstraints)
      Constructs an instance using the default HttpConstraintElement value as the default Constraint element and with a collection of HTTP Method specific constraint elements.
      ServletSecurityElement(HttpConstraintElement constraint)
      Constructs an instance with a default Constraint element and with no HTTP Method specific constraint elements.
      ServletSecurityElement(HttpConstraintElement constraint, Collection<HttpMethodConstraintElement> methodConstraints)
      Constructs an instance with a default Constraint element and with a collection of HTTP Method specific constraint elements.
      ServletSecurityElement(ServletSecurity annotation)
      Constructs an instance from a ServletSecurity annotation value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Collection<HttpMethodConstraintElement> getHttpMethodConstraints()
      Gets the (possibly empty) collection of HTTP Method specific constraint elements.
      Collection<String> getMethodNames()
      Gets the set of HTTP method names named by the HttpMethodConstraints.

      • Methods inherited from class javax.servlet.HttpConstraintElement

        getEmptyRoleSemantic, getRolesAllowed, getTransportGuarantee

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServletSecurityElement

        public ServletSecurityElement()
        Constructs an instance using the default HttpConstraintElement value as the default Constraint element and with no HTTP Method specific constraint elements.

      • ServletSecurityElement

        public ServletSecurityElement(HttpConstraintElement constraint)
        Constructs an instance with a default Constraint element and with no HTTP Method specific constraint elements.
        Parameters:
        constraint - the HttpConstraintElement to be applied to all HTTP methods other than those represented in the methodConstraints

      • ServletSecurityElement

        public ServletSecurityElement(Collection<HttpMethodConstraintElement> methodConstraints)
        Constructs an instance using the default HttpConstraintElement value as the default Constraint element and with a collection of HTTP Method specific constraint elements.
        Parameters:
        methodConstraints - the collection of HTTP method specific constraint elements
        Throws:
        IllegalArgumentException - if duplicate method names are detected

      • ServletSecurityElement

        public ServletSecurityElement(HttpConstraintElement constraint,
                      Collection<HttpMethodConstraintElement> methodConstraints)
        Constructs an instance with a default Constraint element and with a collection of HTTP Method specific constraint elements.
        Parameters:
        constraint - the HttpConstraintElement to be applied to all HTTP methods other than those represented in the methodConstraints
        methodConstraints - the collection of HTTP method specific constraint elements.
        Throws:
        IllegalArgumentException - if duplicate method names are detected

      • ServletSecurityElement

        public ServletSecurityElement(ServletSecurity annotation)
        Constructs an instance from a ServletSecurity annotation value.
        Parameters:
        annotation - the annotation value
        Throws:
        IllegalArgumentException - if duplicate method names are detected

    • Method Detail

      • getHttpMethodConstraints

        public Collection<HttpMethodConstraintElement> getHttpMethodConstraints()
        Gets the (possibly empty) collection of HTTP Method specific constraint elements.

        If permitted, any changes to the returned Collection must not affect this ServletSecurityElement.

        Returns:
        the (possibly empty) collection of HttpMethodConstraintElement objects

      • getMethodNames

        public Collection<String> getMethodNames()
        Gets the set of HTTP method names named by the HttpMethodConstraints.

        If permitted, any changes to the returned Collection must not affect this ServletSecurityElement.

        Returns:
        the collection String method names
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SessionCookieConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface SessionCookieConfig

  • public interface SessionCookieConfig
    Class that may be used to configure various properties of cookies used for session tracking purposes.

    An instance of this class is acquired by a call to ServletContext.getSessionCookieConfig().

    Since:
    Servlet 3.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getComment()
      Gets the comment that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
      String getDomain()
      Gets the domain name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
      int getMaxAge()
      Gets the lifetime (in seconds) of the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
      String getName()
      Gets the name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
      String getPath()
      Gets the path that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
      boolean isHttpOnly()
      Checks if the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired will be marked as HttpOnly.
      boolean isSecure()
      Checks if the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired will be marked as secure even if the request that initiated the corresponding session is using plain HTTP instead of HTTPS.
      void setComment(String comment)
      Sets the comment that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
      void setDomain(String domain)
      Sets the domain name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
      void setHttpOnly(boolean httpOnly)
      Marks or unmarks the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired as HttpOnly.
      void setMaxAge(int maxAge)
      Sets the lifetime (in seconds) for the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
      void setName(String name)
      Sets the name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
      void setPath(String path)
      Sets the path that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
      void setSecure(boolean secure)
      Marks or unmarks the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired as secure.

    • Method Detail

      • setName

        void setName(String name)
        Sets the name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

        NOTE: Changing the name of session tracking cookies may break other tiers (for example, a load balancing frontend) that assume the cookie name to be equal to the default JSESSIONID, and therefore should only be done cautiously.

        Parameters:
        name - the cookie name to use
        Throws:
        IllegalStateException - if the ServletContext from which this SessionCookieConfig was acquired has already been initialized

      • getName

        String getName()
        Gets the name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

        By default, JSESSIONID will be used as the cookie name.

        Returns:
        the cookie name set via setName(java.lang.String), or null if setName(java.lang.String) was never called
        See Also:
        Cookie.getName()

      • setDomain

        void setDomain(String domain)
        Sets the domain name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
        Parameters:
        domain - the cookie domain to use
        Throws:
        IllegalStateException - if the ServletContext from which this SessionCookieConfig was acquired has already been initialized
        See Also:
        Cookie.setDomain(String)

      • getDomain

        String getDomain()
        Gets the domain name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
        Returns:
        the cookie domain set via setDomain(java.lang.String), or null if setDomain(java.lang.String) was never called
        See Also:
        Cookie.getDomain()

      • setPath

        void setPath(String path)
        Sets the path that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
        Parameters:
        path - the cookie path to use
        Throws:
        IllegalStateException - if the ServletContext from which this SessionCookieConfig was acquired has already been initialized
        See Also:
        Cookie.setPath(String)

      • getPath

        String getPath()
        Gets the path that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

        By default, the context path of the ServletContext from which this SessionCookieConfig was acquired will be used.

        Returns:
        the cookie path set via setPath(java.lang.String), or null if setPath(java.lang.String) was never called
        See Also:
        Cookie.getPath()

      • setComment

        void setComment(String comment)
        Sets the comment that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

        As a side effect of this call, the session tracking cookies will be marked with a Version attribute equal to 1.

        Parameters:
        comment - the cookie comment to use
        Throws:
        IllegalStateException - if the ServletContext from which this SessionCookieConfig was acquired has already been initialized
        See Also:
        Cookie.setComment(String), Cookie.getVersion()

      • getComment

        String getComment()
        Gets the comment that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
        Returns:
        the cookie comment set via setComment(java.lang.String), or null if setComment(java.lang.String) was never called
        See Also:
        Cookie.getComment()

      • setHttpOnly

        void setHttpOnly(boolean httpOnly)
        Marks or unmarks the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired as HttpOnly.

        A cookie is marked as HttpOnly by adding the HttpOnly attribute to it. HttpOnly cookies are not supposed to be exposed to client-side scripting code, and may therefore help mitigate certain kinds of cross-site scripting attacks.

        Parameters:
        httpOnly - true if the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired shall be marked as HttpOnly, false otherwise
        Throws:
        IllegalStateException - if the ServletContext from which this SessionCookieConfig was acquired has already been initialized
        See Also:
        Cookie.setHttpOnly(boolean)

      • isHttpOnly

        boolean isHttpOnly()
        Checks if the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired will be marked as HttpOnly.
        Returns:
        true if the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired will be marked as HttpOnly, false otherwise
        See Also:
        Cookie.isHttpOnly()

      • setSecure

        void setSecure(boolean secure)
        Marks or unmarks the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired as secure.

        One use case for marking a session tracking cookie as secure, even though the request that initiated the session came over HTTP, is to support a topology where the web container is front-ended by an SSL offloading load balancer. In this case, the traffic between the client and the load balancer will be over HTTPS, whereas the traffic between the load balancer and the web container will be over HTTP.

        Parameters:
        secure - true if the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired shall be marked as secure even if the request that initiated the corresponding session is using plain HTTP instead of HTTPS, and false if they shall be marked as secure only if the request that initiated the corresponding session was also secure
        Throws:
        IllegalStateException - if the ServletContext from which this SessionCookieConfig was acquired has already been initialized
        See Also:
        Cookie.setSecure(boolean), ServletRequest.isSecure()

      • isSecure

        boolean isSecure()
        Checks if the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired will be marked as secure even if the request that initiated the corresponding session is using plain HTTP instead of HTTPS.
        Returns:
        true if the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired will be marked as secure even if the request that initiated the corresponding session is using plain HTTP instead of HTTPS, and false if they will be marked as secure only if the request that initiated the corresponding session was also secure
        See Also:
        Cookie.getSecure(), ServletRequest.isSecure()

      • setMaxAge

        void setMaxAge(int maxAge)
        Sets the lifetime (in seconds) for the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
        Parameters:
        maxAge - the lifetime (in seconds) of the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.
        Throws:
        IllegalStateException - if the ServletContext from which this SessionCookieConfig was acquired has already been initialized
        See Also:
        Cookie.setMaxAge(int)

      • getMaxAge

        int getMaxAge()
        Gets the lifetime (in seconds) of the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

        By default, -1 is returned.

        Returns:
        the lifetime (in seconds) of the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired, or -1 (the default)
        See Also:
        Cookie.getMaxAge()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SessionTrackingMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.servlet

Enum SessionTrackingMode

  • java.lang.Object
    • java.lang.Enum<SessionTrackingMode>
      • javax.servlet.SessionTrackingMode
  • All Implemented Interfaces:
    Serializable, Comparable<SessionTrackingMode>

    public enum SessionTrackingMode
extends Enum<SessionTrackingMode>
    Enumeration of session tracking modes.
    Since:
    Servlet 3.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      COOKIE
      SSL
      URL

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static SessionTrackingMode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SessionTrackingMode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • COOKIE

        public static final SessionTrackingMode COOKIE

      • URL

        public static final SessionTrackingMode URL

      • SSL

        public static final SessionTrackingMode SSL

    • Method Detail

      • values

        public static SessionTrackingMode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SessionTrackingMode c : SessionTrackingMode.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SessionTrackingMode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


SingleThreadModel (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface SingleThreadModel

  • Deprecated.
    As of Java Servlet API 2.4, with no direct replacement.

    public interface SingleThreadModel
    Ensures that servlets handle only one request at a time. This interface has no methods.

    If a servlet implements this interface, you are guaranteed that no two threads will execute concurrently in the servlet's service method. The servlet container can make this guarantee by synchronizing access to a single instance of the servlet, or by maintaining a pool of servlet instances and dispatching each new request to a free servlet.

    Note that SingleThreadModel does not solve all thread safety issues. For example, session attributes and static variables can still be accessed by multiple requests on multiple threads at the same time, even when SingleThreadModel servlets are used. It is recommended that a developer take other means to resolve those issues instead of implementing this interface, such as avoiding the usage of an instance variable or synchronizing the block of the code accessing those resources. This interface is deprecated in Servlet API version 2.4.

    Author:
    Various
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UnavailableException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Class UnavailableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.servlet.ServletException
          • javax.servlet.UnavailableException
  • All Implemented Interfaces:
    Serializable

    public class UnavailableException
extends ServletException
    Defines an exception that a servlet or filter throws to indicate that it is permanently or temporarily unavailable.

    When a servlet or filter is permanently unavailable, something is wrong with it, and it cannot handle requests until some action is taken. For example, a servlet might be configured incorrectly, or a filter's state may be corrupted. The component should log both the error and the corrective action that is needed.

    A servlet or filter is temporarily unavailable if it cannot handle requests momentarily due to some system-wide problem. For example, a third-tier server might not be accessible, or there may be insufficient memory or disk storage to handle requests. A system administrator may need to take corrective action.

    Servlet containers can safely treat both types of unavailable exceptions in the same way. However, treating temporary unavailability effectively makes the servlet container more robust. Specifically, the servlet container might block requests to the servlet or filter for a period of time suggested by the exception, rather than rejecting them until the servlet container restarts.

    Author:
    Various
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      UnavailableException(int seconds, Servlet servlet, String msg)
      Deprecated.
      As of Java Servlet API 2.2, use UnavailableException(String, int) instead.
      UnavailableException(Servlet servlet, String msg)
      Deprecated.
      As of Java Servlet API 2.2, use UnavailableException(String) instead.
      UnavailableException(String msg)
      Constructs a new exception with a descriptive message indicating that the servlet is permanently unavailable.
      UnavailableException(String msg, int seconds)
      Constructs a new exception with a descriptive message indicating that the servlet is temporarily unavailable and giving an estimate of how long it will be unavailable.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Servlet getServlet()
      Deprecated.
      As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.
      int getUnavailableSeconds()
      Returns the number of seconds the servlet expects to be temporarily unavailable.
      boolean isPermanent()
      Returns a boolean indicating whether the servlet is permanently unavailable.

      • Methods inherited from class javax.servlet.ServletException

        getRootCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnavailableException

        public UnavailableException(Servlet servlet,
                    String msg)
        Deprecated. As of Java Servlet API 2.2, use UnavailableException(String) instead.
        Parameters:
        servlet - the Servlet instance that is unavailable
        msg - a String specifying the descriptive message

      • UnavailableException

        public UnavailableException(int seconds,
                    Servlet servlet,
                    String msg)
        Deprecated. As of Java Servlet API 2.2, use UnavailableException(String, int) instead.
        Parameters:
        seconds - an integer specifying the number of seconds the servlet expects to be unavailable; if zero or negative, indicates that the servlet can't make an estimate
        servlet - the Servlet that is unavailable
        msg - a String specifying the descriptive message, which can be written to a log file or displayed for the user.

      • UnavailableException

        public UnavailableException(String msg)
        Constructs a new exception with a descriptive message indicating that the servlet is permanently unavailable.
        Parameters:
        msg - a String specifying the descriptive message

      • UnavailableException

        public UnavailableException(String msg,
                    int seconds)
        Constructs a new exception with a descriptive message indicating that the servlet is temporarily unavailable and giving an estimate of how long it will be unavailable.

        In some cases, the servlet cannot make an estimate. For example, the servlet might know that a server it needs is not running, but not be able to report how long it will take to be restored to functionality. This can be indicated with a negative or zero value for the seconds argument.

        Parameters:
        msg - a String specifying the descriptive message, which can be written to a log file or displayed for the user.
        seconds - an integer specifying the number of seconds the servlet expects to be unavailable; if zero or negative, indicates that the servlet can't make an estimate

    • Method Detail

      • isPermanent

        public boolean isPermanent()
        Returns a boolean indicating whether the servlet is permanently unavailable. If so, something is wrong with the servlet, and the system administrator must take some corrective action.
        Returns:
        true if the servlet is permanently unavailable; false if the servlet is available or temporarily unavailable

      • getServlet

        public Servlet getServlet()
        Deprecated. As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.
        Returns:
        the Servlet object that is throwing the UnavailableException

      • getUnavailableSeconds

        public int getUnavailableSeconds()
        Returns the number of seconds the servlet expects to be temporarily unavailable.

        If this method returns a negative number, the servlet is permanently unavailable or cannot provide an estimate of how long it will be unavailable. No effort is made to correct for the time elapsed since the exception was first reported.

        Returns:
        an integer specifying the number of seconds the servlet will be temporarily unavailable, or a negative number if the servlet is permanently unavailable or cannot make an estimate
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.servlet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet

  • Packages that use javax.servlet
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.xml.rpc.server
    This package defines APIs for the servlet based JAX-RPC endpoint model.
  • Classes in javax.servlet used by javax.faces.webapp
    Class and Description
    Servlet
    Defines methods that all servlets must implement.
    ServletConfig
    A servlet configuration object used by a servlet container to pass information to a servlet during initialization.
    ServletException
    Defines a general exception a servlet can throw when it encounters difficulty.
    ServletRequest
    Defines an object to provide client request information to a servlet.
    ServletResponse
    Defines an object to assist a servlet in sending a response to the client.
  • Classes in javax.servlet used by javax.servlet
    Class and Description
    AsyncContext
    Class representing the execution context for an asynchronous operation that was initiated on a ServletRequest.
    AsyncEvent
    Event that gets fired when the asynchronous operation initiated on a ServletRequest (via a call to ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse)) has completed, timed out, or produced an error.
    AsyncListener
    Listener that will be notified in the event that an asynchronous operation initiated on a ServletRequest to which the listener had been added has completed, timed out, or resulted in an error.
    DispatcherType
    Enumeration of filter dispatcher types.
    Filter
    A filter is an object that performs filtering tasks on either the request to a resource (a servlet or static content), or on the response from a resource, or both.
    FilterChain
    A FilterChain is an object provided by the servlet container to the developer giving a view into the invocation chain of a filtered request for a resource.
    FilterConfig
    A filter configuration object used by a servlet container to pass information to a filter during initialization.
    FilterRegistration
    Interface through which a Filter may be further configured.
    FilterRegistration.Dynamic
    Interface through which a Filter registered via one of the addFilter methods on ServletContext may be further configured.
    HttpConstraintElement
    Java Class representation of an HttpConstraint annotation value.
    HttpMethodConstraintElement
    Java Class represntation of an HttpMethodConstraint annotation value.
    MultipartConfigElement
    Java Class represntation of an MultipartConfig annotation value.
    ReadListener
    This class represents a call-back mechanism that will notify implementations as HTTP request data becomes available to be read without blocking.
    Registration
    Interface through which a Servlet or Filter may be further configured.
    Registration.Dynamic
    Interface through which a Servlet or Filter registered via one of the addServlet or addFilter methods, respectively, on ServletContext may be further configured.
    RequestDispatcher
    Defines an object that receives requests from the client and sends them to any resource (such as a servlet, HTML file, or JSP file) on the server.
    Servlet
    Defines methods that all servlets must implement.
    ServletConfig
    A servlet configuration object used by a servlet container to pass information to a servlet during initialization.
    ServletContext
    Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.
    ServletContextAttributeEvent
    Event class for notifications about changes to the attributes of the ServletContext of a web application.
    ServletContextEvent
    This is the event class for notifications about changes to the servlet context of a web application.
    ServletException
    Defines a general exception a servlet can throw when it encounters difficulty.
    ServletInputStream
    Provides an input stream for reading binary data from a client request, including an efficient readLine method for reading data one line at a time.
    ServletOutputStream
    Provides an output stream for sending binary data to the client.
    ServletRegistration
    Interface through which a Servlet may be further configured.
    ServletRegistration.Dynamic
    Interface through which a Servlet registered via one of the addServlet methods on ServletContext may be further configured.
    ServletRequest
    Defines an object to provide client request information to a servlet.
    ServletRequestAttributeEvent
    This is the event class for notifications of changes to the attributes of the servlet request in an application.
    ServletRequestEvent
    Events of this kind indicate lifecycle events for a ServletRequest.
    ServletResponse
    Defines an object to assist a servlet in sending a response to the client.
    ServletSecurityElement
    Java Class represntation of a ServletSecurity annotation value.
    SessionCookieConfig
    Class that may be used to configure various properties of cookies used for session tracking purposes.
    SessionTrackingMode
    Enumeration of session tracking modes.
    WriteListener
    Callback notification mechanism that signals to the developer it's possible to write content without blocking.
  • Classes in javax.servlet used by javax.servlet.http
    Class and Description
    GenericServlet
    Defines a generic, protocol-independent servlet.
    Servlet
    Defines methods that all servlets must implement.
    ServletConfig
    A servlet configuration object used by a servlet container to pass information to a servlet during initialization.
    ServletContext
    Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.
    ServletException
    Defines a general exception a servlet can throw when it encounters difficulty.
    ServletInputStream
    Provides an input stream for reading binary data from a client request, including an efficient readLine method for reading data one line at a time.
    ServletOutputStream
    Provides an output stream for sending binary data to the client.
    ServletRequest
    Defines an object to provide client request information to a servlet.
    ServletRequestWrapper
    Provides a convenient implementation of the ServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
    ServletResponse
    Defines an object to assist a servlet in sending a response to the client.
    ServletResponseWrapper
    Provides a convenient implementation of the ServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
  • Classes in javax.servlet used by javax.servlet.jsp
    Class and Description
    Servlet
    Defines methods that all servlets must implement.
    ServletConfig
    A servlet configuration object used by a servlet container to pass information to a servlet during initialization.
    ServletContext
    Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.
    ServletException
    Defines a general exception a servlet can throw when it encounters difficulty.
    ServletRequest
    Defines an object to provide client request information to a servlet.
    ServletResponse
    Defines an object to assist a servlet in sending a response to the client.
  • Classes in javax.servlet used by javax.servlet.jsp.jstl.core
    Class and Description
    ServletContext
    Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.
    ServletRequest
    Defines an object to provide client request information to a servlet.
  • Classes in javax.servlet used by javax.xml.rpc.server
    Class and Description
    ServletContext
    Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WriteListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet

Interface WriteListener

  • All Superinterfaces:
    EventListener

    public interface WriteListener
extends EventListener
    Callback notification mechanism that signals to the developer it's possible to write content without blocking.
    Since:
    Servlet 3.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onError(Throwable t)
      Invoked when an error occurs writing data using the non-blocking APIs.
      void onWritePossible()
      When an instance of the WriteListener is registered with a ServletOutputStream, this method will be invoked by the container the first time when it is possible to write data.

    • Method Detail

      • onWritePossible

        void onWritePossible()
                     throws IOException
        When an instance of the WriteListener is registered with a ServletOutputStream, this method will be invoked by the container the first time when it is possible to write data. Subsequently the container will invoke this method if and only if ServletOutputStream.isReady() method has been called and has returned false.
        Throws:
        IOException - if an I/O related error has occurred during processing

      • onError

        void onError(Throwable t)
        Invoked when an error occurs writing data using the non-blocking APIs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HandlesTypes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.servlet.annotation

Annotation Type HandlesTypes

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface HandlesTypes
    This annotation is used to declare the class types that a ServletContainerInitializer can handle.
    Since:
    Servlet 3.0
    See Also:
    ServletContainerInitializer

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<?>[] value
      The classes in which a ServletContainerInitializer has expressed interest.

    • Element Detail

      • value

        public abstract Class<?>[] value
        The classes in which a ServletContainerInitializer has expressed interest.

        If an implementation of ServletContainerInitializer specifies this annotation, the Servlet container must pass the Set of application classes that extend, implement, or have been annotated with the class types listed by this annotation to the ServletContainerInitializer.onStartup(java.util.Set<java.lang.Class<?>>, javax.servlet.ServletContext) method of the ServletContainerInitializer (if no matching classes are found, null must be passed instead)

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


HttpConstraint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.servlet.annotation

Annotation Type HttpConstraint

  • @Documented
@Retention(value=RUNTIME)
public @interface HttpConstraint
    This annotation is used within the ServletSecurity annotation to represent the security constraints to be applied to all HTTP protocol methods for which a corresponding HttpMethodConstraint element does NOT occur within the ServletSecurity annotation.

    For the special case where an @HttpConstraint that returns all default values occurs in combination with at least one HttpMethodConstraint that returns other than all default values, the @HttpConstraint represents that no security constraint is to be applied to any of the HTTP protocol methods to which a security constraint would otherwise apply. This exception is made to ensure that such potentially non-specific uses of @HttpConstraint do not yield constraints that will explicitly establish unprotected access for such methods; given that they would not otherwise be covered by a constraint.

    Since:
    Servlet 3.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String[] rolesAllowed
      The names of the authorized roles.
      ServletSecurity.TransportGuarantee transportGuarantee
      The data protection requirements (i.e., whether or not SSL/TLS is required) that must be satisfied by the connections on which requests arrive.
      ServletSecurity.EmptyRoleSemantic value
      The default authorization semantic.

    • Element Detail

      • value

        public abstract ServletSecurity.EmptyRoleSemantic value
        The default authorization semantic. This value is insignificant when rolesAllowed returns a non-empty array, and should not be specified when a non-empty array is specified for rolesAllowed.
        Returns:
        the ServletSecurity.EmptyRoleSemantic to be applied when rolesAllowed returns an empty (that is, zero-length) array.
        Default:
        javax.servlet.annotation.ServletSecurity.EmptyRoleSemantic.PERMIT

      • transportGuarantee

        public abstract ServletSecurity.TransportGuarantee transportGuarantee
        The data protection requirements (i.e., whether or not SSL/TLS is required) that must be satisfied by the connections on which requests arrive.
        Returns:
        the ServletSecurity.TransportGuarantee indicating the data protection that must be provided by the connection.
        Default:
        javax.servlet.annotation.ServletSecurity.TransportGuarantee.NONE

      • rolesAllowed

        public abstract String[] rolesAllowed
        The names of the authorized roles. Duplicate role names appearing in rolesAllowed are insignificant and may be discarded during runtime processing of the annotation. The String "*" has no special meaning as a role name (should it occur in rolesAllowed).
        Returns:
        an array of zero or more role names. When the array contains zero elements, its meaning depends on the EmptyRoleSemantic returned by the value method. If value returns DENY, and rolesAllowed returns a zero length array, access is to be denied independent of authentication state and identity. Conversely, if value returns PERMIT, it indicates that access is to be allowed independent of authentication state and identity. When the array contains the names of one or more roles, it indicates that access is contingent on membership in at least one of the named roles (independent of the EmptyRoleSemantic returned by the value method).
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


HttpMethodConstraint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.servlet.annotation

Annotation Type HttpMethodConstraint

  • @Documented
@Retention(value=RUNTIME)
public @interface HttpMethodConstraint
    This annotation is used within the ServletSecurity annotation to represent security constraints on specific HTTP protocol messages.
    Since:
    Servlet 3.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Http protocol method name

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      ServletSecurity.EmptyRoleSemantic emptyRoleSemantic
      The default authorization semantic.
      String[] rolesAllowed
      The names of the authorized roles.
      ServletSecurity.TransportGuarantee transportGuarantee
      The data protection requirements (i.e., whether or not SSL/TLS is required) that must be satisfied by the connections on which requests arrive.

    • Element Detail

      • value

        public abstract String value
        Http protocol method name
        Returns:
        the name of an HTTP protocol method. value may not be null, or the empty string, and must be a legitimate HTTP Method name as defined by RFC 2616.

      • emptyRoleSemantic

        public abstract ServletSecurity.EmptyRoleSemantic emptyRoleSemantic
        The default authorization semantic. This value is insignificant when rolesAllowed returns a non-empty array, and should not be specified when a non-empty array is specified for rolesAllowed.
        Returns:
        the ServletSecurity.EmptyRoleSemantic to be applied when rolesAllowed returns an empty (that is, zero-length) array.
        Default:
        javax.servlet.annotation.ServletSecurity.EmptyRoleSemantic.PERMIT

      • transportGuarantee

        public abstract ServletSecurity.TransportGuarantee transportGuarantee
        The data protection requirements (i.e., whether or not SSL/TLS is required) that must be satisfied by the connections on which requests arrive.
        Returns:
        the ServletSecurity.TransportGuarantee indicating the data protection that must be provided by the connection.
        Default:
        javax.servlet.annotation.ServletSecurity.TransportGuarantee.NONE

      • rolesAllowed

        public abstract String[] rolesAllowed
        The names of the authorized roles. Duplicate role names appearing in rolesAllowed are insignificant and may be discarded during runtime processing of the annotation. The String "*" has no special meaning as a role name (should it occur in rolesAllowed).
        Returns:
        an array of zero or more role names. When the array contains zero elements, its meaning depends on the value returned by emptyRoleSemantic. If emptyRoleSemantic returns DENY, and rolesAllowed returns a zero length array, access is to be denied independent of authentication state and identity. Conversely, if emptyRoleSemantic returns PERMIT, it indicates that access is to be allowed independent of authentication state and identity. When the array contains the names of one or more roles, it indicates that access is contingent on membership in at least one of the named roles (independent of the value returned by emptyRoleSemantic).
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.servlet.annotation (Java(TM) EE 7 Specification APIs)

javax.servlet.annotation

Enums

  • ServletSecurity.EmptyRoleSemantic
  • ServletSecurity.TransportGuarantee

Annotation Types

  • HandlesTypes
  • HttpConstraint
  • HttpMethodConstraint
  • MultipartConfig
  • ServletSecurity
  • WebFilter
  • WebInitParam
  • WebListener
  • WebServlet


javax.servlet.annotation (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet.annotation

The javax.servlet.annotation package contains a number of annotations that allow users to use annotations to declare servlets, filters, listeners and specify the metadata for the declared component.

See: Description

  • Enum Summary
    Enum Description
    ServletSecurity.EmptyRoleSemantic
    Defines the access semantic to be applied to an empty rolesAllowed array.
    ServletSecurity.TransportGuarantee
    Defines the data protection requirements that must be satisfied by the transport
  • Annotation Types Summary
    Annotation Type Description
    HandlesTypes
    This annotation is used to declare the class types that a ServletContainerInitializer can handle.
    HttpConstraint
    This annotation is used within the ServletSecurity annotation to represent the security constraints to be applied to all HTTP protocol methods for which a corresponding HttpMethodConstraint element does NOT occur within the ServletSecurity annotation.
    HttpMethodConstraint
    This annotation is used within the ServletSecurity annotation to represent security constraints on specific HTTP protocol messages.
    MultipartConfig
    Annotation that may be specified on a Servlet class, indicating that instances of the Servlet expect requests that conform to the multipart/form-data MIME type.
    ServletSecurity
    This annotation is used on a Servlet implementation class to specify security constraints to be enforced by a Servlet container on HTTP protocol messages.
    WebFilter
    Annotation used to declare a servlet filter.
    WebInitParam
    This annotation is used on a Servlet or Filter implementation class to specify an initialization parameter.
    WebListener
    This annotation is used to declare a WebListener.
    WebServlet
    Annotation used to declare a servlet.

Package javax.servlet.annotation Description

The javax.servlet.annotation package contains a number of annotations that allow users to use annotations to declare servlets, filters, listeners and specify the metadata for the declared component.
Since:
Servlet 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet.annotation Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet.annotation

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.servlet.annotation.WebServlet (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.WebListener (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.WebInitParam (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.WebFilter (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.ServletSecurity (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.MultipartConfig (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.HttpMethodConstraint (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.HttpConstraint (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.HandlesTypes (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.servlet.annotation.ServletSecurity.EmptyRoleSemantic
      • javax.servlet.annotation.ServletSecurity.TransportGuarantee
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MultipartConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.servlet.annotation

Annotation Type MultipartConfig

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface MultipartConfig
    Annotation that may be specified on a Servlet class, indicating that instances of the Servlet expect requests that conform to the multipart/form-data MIME type.

    Servlets annotated with MultipartConfig may retrieve the Part components of a given multipart/form-data request by calling getPart or getParts.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      int fileSizeThreshold
      The size threshold after which the file will be written to disk
      String location
      The directory location where files will be stored
      long maxFileSize
      The maximum size allowed for uploaded files.
      long maxRequestSize
      The maximum size allowed for multipart/form-data requests

    • Element Detail

      • location

        public abstract String location
        The directory location where files will be stored
        Default:
        ""

      • maxFileSize

        public abstract long maxFileSize
        The maximum size allowed for uploaded files.

        The default is -1L, which means unlimited.

        Default:
        -1L

      • maxRequestSize

        public abstract long maxRequestSize
        The maximum size allowed for multipart/form-data requests

        The default is -1L, which means unlimited.

        Default:
        -1L

      • fileSizeThreshold

        public abstract int fileSizeThreshold
        The size threshold after which the file will be written to disk
        Default:
        0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ServletSecurity (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.servlet.annotation

Annotation Type ServletSecurity

  • @Inherited
@Documented
@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface ServletSecurity
    This annotation is used on a Servlet implementation class to specify security constraints to be enforced by a Servlet container on HTTP protocol messages. The Servlet container will enforce these constraints on the url-patterns mapped to the servlets mapped to the annotated class.
    Since:
    Servlet 3.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      HttpMethodConstraint[] httpMethodConstraints
      Get the HTTP method specific constraints.
      HttpConstraint value
      Get the HttpConstraint that defines the protection that is to be applied to all HTTP methods that are NOT represented in the array returned by httpMethodConstraints.

    • Element Detail

      • value

        public abstract HttpConstraint value
        Get the HttpConstraint that defines the protection that is to be applied to all HTTP methods that are NOT represented in the array returned by httpMethodConstraints.
        Returns:
        a HttpConstraint object.
        Default:
        @javax.servlet.annotation.HttpConstraint

      • httpMethodConstraints

        public abstract HttpMethodConstraint[] httpMethodConstraints
        Get the HTTP method specific constraints. Each HttpMethodConstraint names an HTTP protocol method and defines the protection to be applied to it.
        Returns:
        an array of HttpMethodConstraint elements each defining the protection to be applied to one HTTP protocol method. For any HTTP method name, there must be at most one corresponding element in the returned array. If the returned array is of zero length, it indicates that no HTTP method specific constraints are defined.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ServletSecurity.EmptyRoleSemantic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.servlet.annotation

Enum ServletSecurity.EmptyRoleSemantic

  • java.lang.Object
    • java.lang.Enum<ServletSecurity.EmptyRoleSemantic>
      • javax.servlet.annotation.ServletSecurity.EmptyRoleSemantic
  • All Implemented Interfaces:
    Serializable, Comparable<ServletSecurity.EmptyRoleSemantic>
    Enclosing class:
    ServletSecurity

    public static enum ServletSecurity.EmptyRoleSemantic
extends Enum<ServletSecurity.EmptyRoleSemantic>
    Defines the access semantic to be applied to an empty rolesAllowed array.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      DENY
      access is to be denied independent of authentication state and identity.
      PERMIT
      access is to be permitted independent of authentication state and identity.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ServletSecurity.EmptyRoleSemantic valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ServletSecurity.EmptyRoleSemantic[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PERMIT

        public static final ServletSecurity.EmptyRoleSemantic PERMIT
        access is to be permitted independent of authentication state and identity.

      • DENY

        public static final ServletSecurity.EmptyRoleSemantic DENY
        access is to be denied independent of authentication state and identity.

    • Method Detail

      • values

        public static ServletSecurity.EmptyRoleSemantic[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ServletSecurity.EmptyRoleSemantic c : ServletSecurity.EmptyRoleSemantic.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ServletSecurity.EmptyRoleSemantic valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ServletSecurity.TransportGuarantee (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.servlet.annotation

Enum ServletSecurity.TransportGuarantee

  • java.lang.Object
    • java.lang.Enum<ServletSecurity.TransportGuarantee>
      • javax.servlet.annotation.ServletSecurity.TransportGuarantee
  • All Implemented Interfaces:
    Serializable, Comparable<ServletSecurity.TransportGuarantee>
    Enclosing class:
    ServletSecurity

    public static enum ServletSecurity.TransportGuarantee
extends Enum<ServletSecurity.TransportGuarantee>
    Defines the data protection requirements that must be satisfied by the transport

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      CONFIDENTIAL
      All user data must be encrypted by the transport (typically using SSL/TLS).
      NONE
      no protection of user data must be performed by the transport.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ServletSecurity.TransportGuarantee valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ServletSecurity.TransportGuarantee[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NONE

        public static final ServletSecurity.TransportGuarantee NONE
        no protection of user data must be performed by the transport.

      • CONFIDENTIAL

        public static final ServletSecurity.TransportGuarantee CONFIDENTIAL
        All user data must be encrypted by the transport (typically using SSL/TLS).

    • Method Detail

      • values

        public static ServletSecurity.TransportGuarantee[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ServletSecurity.TransportGuarantee c : ServletSecurity.TransportGuarantee.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ServletSecurity.TransportGuarantee valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Uses of Package javax.servlet.annotation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet.annotation

  • Packages that use javax.servlet.annotation
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.annotation
    The javax.servlet.annotation package contains a number of annotations that allow users to use annotations to declare servlets, filters, listeners and specify the metadata for the declared component.
  • Classes in javax.servlet.annotation used by javax.faces.webapp
    Class and Description
    MultipartConfig
    Annotation that may be specified on a Servlet class, indicating that instances of the Servlet expect requests that conform to the multipart/form-data MIME type.
  • Classes in javax.servlet.annotation used by javax.servlet
    Class and Description
    MultipartConfig
    Annotation that may be specified on a Servlet class, indicating that instances of the Servlet expect requests that conform to the multipart/form-data MIME type.
    ServletSecurity
    This annotation is used on a Servlet implementation class to specify security constraints to be enforced by a Servlet container on HTTP protocol messages.
    ServletSecurity.EmptyRoleSemantic
    Defines the access semantic to be applied to an empty rolesAllowed array.
    ServletSecurity.TransportGuarantee
    Defines the data protection requirements that must be satisfied by the transport
  • Classes in javax.servlet.annotation used by javax.servlet.annotation
    Class and Description
    ServletSecurity.EmptyRoleSemantic
    Defines the access semantic to be applied to an empty rolesAllowed array.
    ServletSecurity.TransportGuarantee
    Defines the data protection requirements that must be satisfied by the transport
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WebFilter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.servlet.annotation

Annotation Type WebFilter

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebFilter
    Annotation used to declare a servlet filter.

    This annotation is processed by the container at deployment time, and the corresponding filter applied to the specified URL patterns, servlets, and dispatcher types.

    Since:
    Servlet 3.0
    See Also:
    Filter

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean asyncSupported
      Declares whether the filter supports asynchronous operation mode.
      String description
      The description of the filter
      DispatcherType[] dispatcherTypes
      The dispatcher types to which the filter applies
      String displayName
      The display name of the filter
      String filterName
      The name of the filter
      WebInitParam[] initParams
      The init parameters of the filter
      String largeIcon
      The large-icon of the filter
      String[] servletNames
      The names of the servlets to which the filter applies.
      String smallIcon
      The small-icon of the filter
      String[] urlPatterns
      The URL patterns to which the filter applies
      String[] value
      The URL patterns to which the filter applies

    • Element Detail

      • description

        public abstract String description
        The description of the filter
        Default:
        ""

      • displayName

        public abstract String displayName
        The display name of the filter
        Default:
        ""

      • initParams

        public abstract WebInitParam[] initParams
        The init parameters of the filter
        Default:
        {}

      • filterName

        public abstract String filterName
        The name of the filter
        Default:
        ""

      • smallIcon

        public abstract String smallIcon
        The small-icon of the filter
        Default:
        ""

      • largeIcon

        public abstract String largeIcon
        The large-icon of the filter
        Default:
        ""

      • servletNames

        public abstract String[] servletNames
        The names of the servlets to which the filter applies.
        Default:
        {}

      • value

        public abstract String[] value
        The URL patterns to which the filter applies
        Default:
        {}

      • urlPatterns

        public abstract String[] urlPatterns
        The URL patterns to which the filter applies
        Default:
        {}

      • dispatcherTypes

        public abstract DispatcherType[] dispatcherTypes
        The dispatcher types to which the filter applies
        Default:
        javax.servlet.DispatcherType.REQUEST

      • asyncSupported

        public abstract boolean asyncSupported
        Declares whether the filter supports asynchronous operation mode.
        See Also:
        ServletRequest.startAsync(), ServletRequest.startAsync(ServletRequest, ServletResponse)
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebInitParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.servlet.annotation

Annotation Type WebInitParam

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebInitParam
    This annotation is used on a Servlet or Filter implementation class to specify an initialization parameter.
    Since:
    Servlet 3.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      Name of the initialization parameter
      String value
      Value of the initialization parameter

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String description
      Description of the initialization parameter

    • Element Detail

      • name

        public abstract String name
        Name of the initialization parameter

      • value

        public abstract String value
        Value of the initialization parameter

      • description

        public abstract String description
        Description of the initialization parameter
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.servlet.annotation

Annotation Type WebListener

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebListener
    This annotation is used to declare a WebListener. Any class annotated with WebListener must implement one or more of the ServletContextListener, ServletContextAttributeListener, ServletRequestListener, ServletRequestAttributeListener, HttpSessionListener, or HttpSessionAttributeListener, or HttpSessionIdListener interfaces.
    Since:
    Servlet 3.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String value
      Description of the listener

    • Element Detail

      • value

        public abstract String value
        Description of the listener
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebServlet (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.servlet.annotation

Annotation Type WebServlet

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServlet
    Annotation used to declare a servlet.

    This annotation is processed by the container at deployment time, and the corresponding servlet made available at the specified URL patterns.

    Since:
    Servlet 3.0
    See Also:
    Servlet

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean asyncSupported
      Declares whether the servlet supports asynchronous operation mode.
      String description
      The description of the servlet
      String displayName
      The display name of the servlet
      WebInitParam[] initParams
      The init parameters of the servlet
      String largeIcon
      The large-icon of the servlet
      int loadOnStartup
      The load-on-startup order of the servlet
      String name
      The name of the servlet
      String smallIcon
      The small-icon of the servlet
      String[] urlPatterns
      The URL patterns of the servlet
      String[] value
      The URL patterns of the servlet

    • Element Detail

      • name

        public abstract String name
        The name of the servlet
        Default:
        ""

      • value

        public abstract String[] value
        The URL patterns of the servlet
        Default:
        {}

      • urlPatterns

        public abstract String[] urlPatterns
        The URL patterns of the servlet
        Default:
        {}

      • loadOnStartup

        public abstract int loadOnStartup
        The load-on-startup order of the servlet
        Default:
        -1

      • initParams

        public abstract WebInitParam[] initParams
        The init parameters of the servlet
        Default:
        {}

      • asyncSupported

        public abstract boolean asyncSupported
        Declares whether the servlet supports asynchronous operation mode.
        See Also:
        ServletRequest.startAsync(), ServletRequest.startAsync(ServletRequest, ServletResponse)
        Default:
        false

      • smallIcon

        public abstract String smallIcon
        The small-icon of the servlet
        Default:
        ""

      • largeIcon

        public abstract String largeIcon
        The large-icon of the servlet
        Default:
        ""

      • description

        public abstract String description
        The description of the servlet
        Default:
        ""

      • displayName

        public abstract String displayName
        The display name of the servlet
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.servlet.annotation.HandlesTypes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.HandlesTypes

No usage of javax.servlet.annotation.HandlesTypes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.annotation.HttpConstraint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.HttpConstraint

No usage of javax.servlet.annotation.HttpConstraint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.annotation.HttpMethodConstraint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.HttpMethodConstraint

No usage of javax.servlet.annotation.HttpMethodConstraint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.annotation.MultipartConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.MultipartConfig

  • Packages that use MultipartConfig
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of MultipartConfig in javax.faces.webapp

      Classes in javax.faces.webapp with annotations of type MultipartConfig
      Modifier and Type Class and Description
      class  FacesServlet
      FacesServlet is a servlet that manages the request processing lifecycle for web applications that are utilizing JavaServer Faces to construct the user interface.

    • Uses of MultipartConfig in javax.servlet

      Constructors in javax.servlet with parameters of type MultipartConfig
      Constructor and Description
      MultipartConfigElement(MultipartConfig annotation)
      Constructs an instance from a MultipartConfig annotation value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.annotation.ServletSecurity (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.ServletSecurity

  • Packages that use ServletSecurity
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletSecurity in javax.servlet

      Constructors in javax.servlet with parameters of type ServletSecurity
      Constructor and Description
      ServletSecurityElement(ServletSecurity annotation)
      Constructs an instance from a ServletSecurity annotation value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.annotation.ServletSecurity.EmptyRoleSemantic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.ServletSecurity.EmptyRoleSemantic

  • Packages that use ServletSecurity.EmptyRoleSemantic
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.annotation
    The javax.servlet.annotation package contains a number of annotations that allow users to use annotations to declare servlets, filters, listeners and specify the metadata for the declared component.

    • Uses of ServletSecurity.EmptyRoleSemantic in javax.servlet

      Methods in javax.servlet that return ServletSecurity.EmptyRoleSemantic
      Modifier and Type Method and Description
      ServletSecurity.EmptyRoleSemantic HttpConstraintElement.getEmptyRoleSemantic()
      Gets the default authorization semantic.
      Constructors in javax.servlet with parameters of type ServletSecurity.EmptyRoleSemantic
      Constructor and Description
      HttpConstraintElement(ServletSecurity.EmptyRoleSemantic semantic)
      Convenience constructor to establish EmptyRoleSemantic.DENY
      HttpConstraintElement(ServletSecurity.EmptyRoleSemantic semantic, ServletSecurity.TransportGuarantee guarantee, String... roleNames)
      Constructor to establish all of getEmptyRoleSemantic, getRolesAllowed, and getTransportGuarantee.

    • Uses of ServletSecurity.EmptyRoleSemantic in javax.servlet.annotation

      Methods in javax.servlet.annotation that return ServletSecurity.EmptyRoleSemantic
      Modifier and Type Method and Description
      static ServletSecurity.EmptyRoleSemantic ServletSecurity.EmptyRoleSemantic.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ServletSecurity.EmptyRoleSemantic[] ServletSecurity.EmptyRoleSemantic.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.annotation.ServletSecurity.TransportGuarantee (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.ServletSecurity.TransportGuarantee

  • Packages that use ServletSecurity.TransportGuarantee
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.annotation
    The javax.servlet.annotation package contains a number of annotations that allow users to use annotations to declare servlets, filters, listeners and specify the metadata for the declared component.

    • Uses of ServletSecurity.TransportGuarantee in javax.servlet

      Methods in javax.servlet that return ServletSecurity.TransportGuarantee
      Modifier and Type Method and Description
      ServletSecurity.TransportGuarantee HttpConstraintElement.getTransportGuarantee()
      Gets the data protection requirement (i.e., whether or not SSL/TLS is required) that must be satisfied by the transport connection.
      Constructors in javax.servlet with parameters of type ServletSecurity.TransportGuarantee
      Constructor and Description
      HttpConstraintElement(ServletSecurity.EmptyRoleSemantic semantic, ServletSecurity.TransportGuarantee guarantee, String... roleNames)
      Constructor to establish all of getEmptyRoleSemantic, getRolesAllowed, and getTransportGuarantee.
      HttpConstraintElement(ServletSecurity.TransportGuarantee guarantee, String... roleNames)
      Constructor to establish non-empty getRolesAllowed and/or TransportGuarantee.CONFIDENTIAL.

    • Uses of ServletSecurity.TransportGuarantee in javax.servlet.annotation

      Methods in javax.servlet.annotation that return ServletSecurity.TransportGuarantee
      Modifier and Type Method and Description
      static ServletSecurity.TransportGuarantee ServletSecurity.TransportGuarantee.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ServletSecurity.TransportGuarantee[] ServletSecurity.TransportGuarantee.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.annotation.WebFilter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.WebFilter

No usage of javax.servlet.annotation.WebFilter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.annotation.WebInitParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.WebInitParam

No usage of javax.servlet.annotation.WebInitParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.annotation.WebListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.WebListener

No usage of javax.servlet.annotation.WebListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.annotation.WebServlet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.annotation.WebServlet

No usage of javax.servlet.annotation.WebServlet
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.AsyncEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.AsyncEvent

  • Packages that use AsyncEvent
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of AsyncEvent in javax.servlet

      Methods in javax.servlet with parameters of type AsyncEvent
      Modifier and Type Method and Description
      void AsyncListener.onComplete(AsyncEvent event)
      Notifies this AsyncListener that an asynchronous operation has been completed.
      void AsyncListener.onError(AsyncEvent event)
      Notifies this AsyncListener that an asynchronous operation has failed to complete.
      void AsyncListener.onStartAsync(AsyncEvent event)
      Notifies this AsyncListener that a new asynchronous cycle is being initiated via a call to one of the ServletRequest.startAsync() methods.
      void AsyncListener.onTimeout(AsyncEvent event)
      Notifies this AsyncListener that an asynchronous operation has timed out.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.DispatcherType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.DispatcherType

  • Packages that use DispatcherType
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of DispatcherType in javax.servlet

      Methods in javax.servlet that return DispatcherType
      Modifier and Type Method and Description
      DispatcherType ServletRequestWrapper.getDispatcherType()
      Gets the dispatcher type of the wrapped request.
      DispatcherType ServletRequest.getDispatcherType()
      Gets the dispatcher type of this request.
      static DispatcherType DispatcherType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static DispatcherType[] DispatcherType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Method parameters in javax.servlet with type arguments of type DispatcherType
      Modifier and Type Method and Description
      void FilterRegistration.addMappingForServletNames(EnumSet<DispatcherType> dispatcherTypes, boolean isMatchAfter, String... servletNames)
      Adds a filter mapping with the given servlet names and dispatcher types for the Filter represented by this FilterRegistration.
      void FilterRegistration.addMappingForUrlPatterns(EnumSet<DispatcherType> dispatcherTypes, boolean isMatchAfter, String... urlPatterns)
      Adds a filter mapping with the given url patterns and dispatcher types for the Filter represented by this FilterRegistration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.GenericServlet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.GenericServlet

  • Packages that use GenericServlet
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of GenericServlet in javax.servlet.http

      Subclasses of GenericServlet in javax.servlet.http
      Modifier and Type Class and Description
      class  HttpServlet
      Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.HttpConstraintElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.HttpConstraintElement

  • Packages that use HttpConstraintElement
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of HttpConstraintElement in javax.servlet

      Subclasses of HttpConstraintElement in javax.servlet
      Modifier and Type Class and Description
      class  HttpMethodConstraintElement
      Java Class represntation of an HttpMethodConstraint annotation value.
      class  ServletSecurityElement
      Java Class represntation of a ServletSecurity annotation value.
      Constructors in javax.servlet with parameters of type HttpConstraintElement
      Constructor and Description
      HttpMethodConstraintElement(String methodName, HttpConstraintElement constraint)
      Constructs an instance with specified HttpConstraintElement value.
      ServletSecurityElement(HttpConstraintElement constraint)
      Constructs an instance with a default Constraint element and with no HTTP Method specific constraint elements.
      ServletSecurityElement(HttpConstraintElement constraint, Collection<HttpMethodConstraintElement> methodConstraints)
      Constructs an instance with a default Constraint element and with a collection of HTTP Method specific constraint elements.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.HttpMethodConstraintElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.HttpMethodConstraintElement

  • Packages that use HttpMethodConstraintElement
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of HttpMethodConstraintElement in javax.servlet

      Methods in javax.servlet that return types with arguments of type HttpMethodConstraintElement
      Modifier and Type Method and Description
      Collection<HttpMethodConstraintElement> ServletSecurityElement.getHttpMethodConstraints()
      Gets the (possibly empty) collection of HTTP Method specific constraint elements.
      Constructor parameters in javax.servlet with type arguments of type HttpMethodConstraintElement
      Constructor and Description
      ServletSecurityElement(Collection<HttpMethodConstraintElement> methodConstraints)
      Constructs an instance using the default HttpConstraintElement value as the default Constraint element and with a collection of HTTP Method specific constraint elements.
      ServletSecurityElement(HttpConstraintElement constraint, Collection<HttpMethodConstraintElement> methodConstraints)
      Constructs an instance with a default Constraint element and with a collection of HTTP Method specific constraint elements.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.MultipartConfigElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.MultipartConfigElement

  • Packages that use MultipartConfigElement
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of MultipartConfigElement in javax.servlet

      Methods in javax.servlet with parameters of type MultipartConfigElement
      Modifier and Type Method and Description
      void ServletRegistration.Dynamic.setMultipartConfig(MultipartConfigElement multipartConfig)
      Sets the MultipartConfigElement to be applied to the mappings defined for this ServletRegistration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.ServletContextAttributeEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.ServletContextAttributeEvent

  • Packages that use ServletContextAttributeEvent
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletContextAttributeEvent in javax.servlet

      Methods in javax.servlet with parameters of type ServletContextAttributeEvent
      Modifier and Type | Method and Description
      void ServletContextAttributeListener.attributeAdded(ServletContextAttributeEvent event)
      Receives notification that an attribute has been added to the ServletContext.
      void ServletContextAttributeListener.attributeRemoved(ServletContextAttributeEvent event)
      Receives notification that an attribute has been removed from the ServletContext.
      void | ServletContextAttributeListener.attributeReplaced(ServletContextAttributeEvent event)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.ServletContextEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.ServletContextEvent

  • Packages that use ServletContextEvent
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletContextEvent in javax.servlet

      Subclasses of ServletContextEvent in javax.servlet
      Modifier and Type Class and Description
      class  ServletContextAttributeEvent
      Event class for notifications about changes to the attributes of the ServletContext of a web application.
      Methods in javax.servlet with parameters of type ServletContextEvent
      Modifier and Type Method and Description
      void ServletContextListener.contextDestroyed(ServletContextEvent sce)
      Receives notification that the ServletContext is about to be shut down.
      void ServletContextListener.contextInitialized(ServletContextEvent sce)
      Receives notification that the web application initialization process is starting.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.ServletException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.ServletException

  • Packages that use ServletException
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of ServletException in javax.faces.webapp

      Methods in javax.faces.webapp that throw ServletException
      Modifier and Type Method and Description
      void FacesServlet.init(ServletConfig servletConfig)
      Acquire the factory instances we will require.
      void FacesServlet.service(ServletRequest req, ServletResponse resp)

      Process an incoming request, and create the corresponding response according to the following specification.

    • Uses of ServletException in javax.servlet

      Subclasses of ServletException in javax.servlet
      Modifier and Type Class and Description
      class  UnavailableException
      Defines an exception that a servlet or filter throws to indicate that it is permanently or temporarily unavailable.
      Methods in javax.servlet that throw ServletException
      Modifier and Type Method and Description
      <T extends Filter>
      T             		ServletContext.createFilter(Class<T> clazz)
      Instantiates the given Filter class.
      <T extends EventListener>
      T             		ServletContext.createListener(Class<T> clazz)
      Instantiates the given EventListener class.
      <T extends AsyncListener>
      T             		AsyncContext.createListener(Class<T> clazz)
      Instantiates the given AsyncListener class.
      <T extends Servlet>
      T             		ServletContext.createServlet(Class<T> clazz)
      Instantiates the given Servlet class.
      void FilterChain.doFilter(ServletRequest request, ServletResponse response)
      Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.
      void Filter.doFilter(ServletRequest request, ServletResponse response, FilterChain chain)
      The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain.
      void RequestDispatcher.forward(ServletRequest request, ServletResponse response)
      Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server.
      Servlet ServletContext.getServlet(String name)
      Deprecated.
      As of Java Servlet API 2.1, with no direct replacement.

      This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

      In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.
      void RequestDispatcher.include(ServletRequest request, ServletResponse response)
      Includes the content of a resource (servlet, JSP page, HTML file) in the response.
      void GenericServlet.init()
      A convenience method which can be overridden so that there's no need to call super.init(config).
      void Filter.init(FilterConfig filterConfig)
      Called by the web container to indicate to a filter that it is being placed into service.
      void Servlet.init(ServletConfig config)
      Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
      void GenericServlet.init(ServletConfig config)
      Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
      void ServletContainerInitializer.onStartup(Set<Class<?>> c, ServletContext ctx)
      Notifies this ServletContainerInitializer of the startup of the application represented by the given ServletContext.
      void Servlet.service(ServletRequest req, ServletResponse res)
      Called by the servlet container to allow the servlet to respond to a request.
      abstract void GenericServlet.service(ServletRequest req, ServletResponse res)
      Called by the servlet container to allow the servlet to respond to a request.

    • Uses of ServletException in javax.servlet.http

      Methods in javax.servlet.http that throw ServletException
      Modifier and Type Method and Description
      boolean HttpServletRequestWrapper.authenticate(HttpServletResponse response)
      The default behavior of this method is to call authenticate on the wrapped request object.
      boolean HttpServletRequest.authenticate(HttpServletResponse response)
      Use the container login mechanism configured for the ServletContext to authenticate the user making this request.
      protected void HttpServlet.doDelete(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a DELETE request.
      protected void HttpServlet.doGet(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a GET request.
      protected void HttpServlet.doHead(HttpServletRequest req, HttpServletResponse resp)
      Receives an HTTP HEAD request from the protected service method and handles the request.
      protected void HttpServlet.doOptions(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a OPTIONS request.
      protected void HttpServlet.doPost(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a POST request.
      protected void HttpServlet.doPut(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a PUT request.
      protected void HttpServlet.doTrace(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a TRACE request.
      Part HttpServletRequestWrapper.getPart(String name)
      The default behavior of this method is to call getPart on the wrapped request object.
      Part HttpServletRequest.getPart(String name)
      Gets the Part with the given name.
      Collection<Part> HttpServletRequestWrapper.getParts()
      The default behavior of this method is to call getParts on the wrapped request object.
      Collection<Part> HttpServletRequest.getParts()
      Gets all the Part components of this request, provided that it is of type multipart/form-data.
      void HttpServletRequestWrapper.login(String username, String password)
      The default behavior of this method is to call login on the wrapped request object.
      void HttpServletRequest.login(String username, String password)
      Validate the provided username and password in the password validation realm used by the web container login mechanism configured for the ServletContext.
      void HttpServletRequestWrapper.logout()
      The default behavior of this method is to call login on the wrapped request object.
      void HttpServletRequest.logout()
      Establish null as the value returned when getUserPrincipal, getRemoteUser, and getAuthType is called on the request.
      protected void HttpServlet.service(HttpServletRequest req, HttpServletResponse resp)
      Receives standard HTTP requests from the public service method and dispatches them to the do XXX methods defined in this class.
      void HttpServlet.service(ServletRequest req, ServletResponse res)
      Dispatches client requests to the protected service method.
      <T extends HttpUpgradeHandler>
      T             		HttpServletRequestWrapper.upgrade(Class<T> handlerClass)
      Create an instance of HttpUpgradeHandler for an given class and uses it for the http protocol upgrade processing.
      <T extends HttpUpgradeHandler>
      T             		HttpServletRequest.upgrade(Class<T> handlerClass)
      Create an instance of HttpUpgradeHandler for an given class and uses it for the http protocol upgrade processing.

    • Uses of ServletException in javax.servlet.jsp

      Methods in javax.servlet.jsp that throw ServletException
      Modifier and Type Method and Description
      void HttpJspPage._jspService(HttpServletRequest request, HttpServletResponse response)
      The _jspService()method corresponds to the body of the JSP page.
      abstract void PageContext.forward(String relativeUrlPath)
      This method is used to re-direct, or "forward" the current ServletRequest and ServletResponse to another active component in the application.
      abstract void PageContext.handlePageException(Exception e)
      This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
      abstract void PageContext.handlePageException(Throwable t)
      This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
      abstract void PageContext.include(String relativeUrlPath)
      Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
      abstract void PageContext.include(String relativeUrlPath, boolean flush)
      Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.ServletInputStream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.ServletInputStream

  • Packages that use ServletInputStream
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletInputStream in javax.servlet

      Methods in javax.servlet that return ServletInputStream
      Modifier and Type Method and Description
      ServletInputStream ServletRequestWrapper.getInputStream()
      The default behavior of this method is to return getInputStream() on the wrapped request object.
      ServletInputStream ServletRequest.getInputStream()
      Retrieves the body of the request as binary data using a ServletInputStream.

    • Uses of ServletInputStream in javax.servlet.http

      Methods in javax.servlet.http that return ServletInputStream
      Modifier and Type Method and Description
      ServletInputStream WebConnection.getInputStream()
      Returns an input stream for this web connection.
      Methods in javax.servlet.http with parameters of type ServletInputStream
      Modifier and Type Method and Description
      static Hashtable<String,String[]> HttpUtils.parsePostData(int len, ServletInputStream in)
      Deprecated.
      Parses data from an HTML form that the client sends to the server using the HTTP POST method and the application/x-www-form-urlencoded MIME type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.ServletOutputStream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.ServletOutputStream

  • Packages that use ServletOutputStream
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletOutputStream in javax.servlet

      Methods in javax.servlet that return ServletOutputStream
      Modifier and Type Method and Description
      ServletOutputStream ServletResponseWrapper.getOutputStream()
      The default behavior of this method is to return getOutputStream() on the wrapped response object.
      ServletOutputStream ServletResponse.getOutputStream()
      Returns a ServletOutputStream suitable for writing binary data in the response.

    • Uses of ServletOutputStream in javax.servlet.http

      Methods in javax.servlet.http that return ServletOutputStream
      Modifier and Type Method and Description
      ServletOutputStream WebConnection.getOutputStream()
      Returns an output stream for this web connection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.ServletRequestAttributeEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.ServletRequestAttributeEvent

  • Packages that use ServletRequestAttributeEvent
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletRequestAttributeEvent in javax.servlet

      Methods in javax.servlet with parameters of type ServletRequestAttributeEvent
      Modifier and Type Method and Description
      void ServletRequestAttributeListener.attributeAdded(ServletRequestAttributeEvent srae)
      Receives notification that an attribute has been added to the ServletRequest.
      void ServletRequestAttributeListener.attributeRemoved(ServletRequestAttributeEvent srae)
      Receives notification that an attribute has been removed from the ServletRequest.
      void ServletRequestAttributeListener.attributeReplaced(ServletRequestAttributeEvent srae)
      Receives notification that an attribute has been replaced on the ServletRequest.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.ServletRequestEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.ServletRequestEvent

  • Packages that use ServletRequestEvent
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletRequestEvent in javax.servlet

      Subclasses of ServletRequestEvent in javax.servlet
      Modifier and Type Class and Description
      class  ServletRequestAttributeEvent
      This is the event class for notifications of changes to the attributes of the servlet request in an application.
      Methods in javax.servlet with parameters of type ServletRequestEvent
      Modifier and Type Method and Description
      void ServletRequestListener.requestDestroyed(ServletRequestEvent sre)
      Receives notification that a ServletRequest is about to go out of scope of the web application.
      void ServletRequestListener.requestInitialized(ServletRequestEvent sre)
      Receives notification that a ServletRequest is about to come into scope of the web application.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.ServletRequestWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.ServletRequestWrapper

  • Packages that use ServletRequestWrapper
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletRequestWrapper in javax.servlet.http

      Subclasses of ServletRequestWrapper in javax.servlet.http
      Modifier and Type Class and Description
      class  HttpServletRequestWrapper
      Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.ServletResponseWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.ServletResponseWrapper

  • Packages that use ServletResponseWrapper
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletResponseWrapper in javax.servlet.http

      Subclasses of ServletResponseWrapper in javax.servlet.http
      Modifier and Type Class and Description
      class  HttpServletResponseWrapper
      Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.ServletSecurityElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.ServletSecurityElement

  • Packages that use ServletSecurityElement
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletSecurityElement in javax.servlet

      Methods in javax.servlet with parameters of type ServletSecurityElement
      Modifier and Type Method and Description
      Set<String> ServletRegistration.Dynamic.setServletSecurity(ServletSecurityElement constraint)
      Sets the ServletSecurityElement to be applied to the mappings defined for this ServletRegistration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.SessionTrackingMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.SessionTrackingMode

  • Packages that use SessionTrackingMode
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of SessionTrackingMode in javax.servlet

      Methods in javax.servlet that return SessionTrackingMode
      Modifier and Type Method and Description
      static SessionTrackingMode SessionTrackingMode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SessionTrackingMode[] SessionTrackingMode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.servlet that return types with arguments of type SessionTrackingMode
      Modifier and Type Method and Description
      Set<SessionTrackingMode> ServletContext.getDefaultSessionTrackingModes()
      Gets the session tracking modes that are supported by default for this ServletContext.
      Set<SessionTrackingMode> ServletContext.getEffectiveSessionTrackingModes()
      Gets the session tracking modes that are in effect for this ServletContext.
      Method parameters in javax.servlet with type arguments of type SessionTrackingMode
      Modifier and Type Method and Description
      void ServletContext.setSessionTrackingModes(Set<SessionTrackingMode> sessionTrackingModes)
      Sets the session tracking modes that are to become effective for this ServletContext.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.UnavailableException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.UnavailableException

No usage of javax.servlet.UnavailableException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.AsyncContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.AsyncContext

  • Packages that use AsyncContext
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of AsyncContext in javax.servlet

      Methods in javax.servlet that return AsyncContext
      Modifier and Type Method and Description
      AsyncContext ServletRequestWrapper.getAsyncContext()
      Gets the AsyncContext that was created or reinitialized by the most recent invocation of ServletRequestWrapper.startAsync() or ServletRequestWrapper.startAsync(ServletRequest,ServletResponse) on the wrapped request.
      AsyncContext ServletRequest.getAsyncContext()
      Gets the AsyncContext that was created or reinitialized by the most recent invocation of ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest,ServletResponse) on this request.
      AsyncContext AsyncEvent.getAsyncContext()
      Gets the AsyncContext from this AsyncEvent.
      AsyncContext ServletRequestWrapper.startAsync()
      The default behavior of this method is to invoke ServletRequest.startAsync() on the wrapped request object.
      AsyncContext ServletRequest.startAsync()
      Puts this request into asynchronous mode, and initializes its AsyncContext with the original (unwrapped) ServletRequest and ServletResponse objects.
      AsyncContext ServletRequestWrapper.startAsync(ServletRequest servletRequest, ServletResponse servletResponse)
      The default behavior of this method is to invoke ServletRequest.startAsync(ServletRequest, ServletResponse) on the wrapped request object.
      AsyncContext ServletRequest.startAsync(ServletRequest servletRequest, ServletResponse servletResponse)
      Puts this request into asynchronous mode, and initializes its AsyncContext with the given request and response objects.
      Constructors in javax.servlet with parameters of type AsyncContext
      Constructor and Description
      AsyncEvent(AsyncContext context)
      Constructs an AsyncEvent from the given AsyncContext.
      AsyncEvent(AsyncContext context, ServletRequest request, ServletResponse response)
      Constructs an AsyncEvent from the given AsyncContext, ServletRequest, and ServletResponse.
      AsyncEvent(AsyncContext context, ServletRequest request, ServletResponse response, Throwable throwable)
      Constructs an AsyncEvent from the given AsyncContext, ServletRequest, ServletResponse, and Throwable.
      AsyncEvent(AsyncContext context, Throwable throwable)
      Constructs an AsyncEvent from the given AsyncContext and Throwable.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.AsyncListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.AsyncListener

  • Packages that use AsyncListener
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of AsyncListener in javax.servlet

      Methods in javax.servlet with type parameters of type AsyncListener
      Modifier and Type Method and Description
      <T extends AsyncListener>
      T             		AsyncContext.createListener(Class<T> clazz)
      Instantiates the given AsyncListener class.
      Methods in javax.servlet with parameters of type AsyncListener
      Modifier and Type Method and Description
      void AsyncContext.addListener(AsyncListener listener)
      Registers the given AsyncListener with the most recent asynchronous cycle that was started by a call to one of the ServletRequest.startAsync() methods.
      void AsyncContext.addListener(AsyncListener listener, ServletRequest servletRequest, ServletResponse servletResponse)
      Registers the given AsyncListener with the most recent asynchronous cycle that was started by a call to one of the ServletRequest.startAsync() methods.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.Filter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.Filter

  • Packages that use Filter
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of Filter in javax.servlet

      Methods in javax.servlet with type parameters of type Filter
      Modifier and Type Method and Description
      <T extends Filter>
      T             		ServletContext.createFilter(Class<T> clazz)
      Instantiates the given Filter class.
      Methods in javax.servlet with parameters of type Filter
      Modifier and Type Method and Description
      FilterRegistration.Dynamic ServletContext.addFilter(String filterName, Filter filter)
      Registers the given filter instance with this ServletContext under the given filterName.
      Method parameters in javax.servlet with type arguments of type Filter
      Modifier and Type Method and Description
      FilterRegistration.Dynamic ServletContext.addFilter(String filterName, Class<? extends Filter> filterClass)
      Adds the filter with the given name and class type to this servlet context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.FilterChain (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.FilterChain

  • Packages that use FilterChain
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of FilterChain in javax.servlet

      Methods in javax.servlet with parameters of type FilterChain
      Modifier and Type Method and Description
      void Filter.doFilter(ServletRequest request, ServletResponse response, FilterChain chain)
      The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.FilterConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.FilterConfig

  • Packages that use FilterConfig
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of FilterConfig in javax.servlet

      Methods in javax.servlet with parameters of type FilterConfig
      Modifier and Type Method and Description
      void Filter.init(FilterConfig filterConfig)
      Called by the web container to indicate to a filter that it is being placed into service.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.FilterRegistration (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.FilterRegistration

  • Packages that use FilterRegistration
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of FilterRegistration in javax.servlet

      Subinterfaces of FilterRegistration in javax.servlet
      Modifier and Type Interface and Description
      static interface  FilterRegistration.Dynamic
      Interface through which a Filter registered via one of the addFilter methods on ServletContext may be further configured.
      Methods in javax.servlet that return FilterRegistration
      Modifier and Type Method and Description
      FilterRegistration ServletContext.getFilterRegistration(String filterName)
      Gets the FilterRegistration corresponding to the filter with the given filterName.
      Methods in javax.servlet that return types with arguments of type FilterRegistration
      Modifier and Type Method and Description
      Map<String,? extends FilterRegistration> ServletContext.getFilterRegistrations()
      Gets a (possibly empty) Map of the FilterRegistration objects (keyed by filter name) corresponding to all filters registered with this ServletContext.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.FilterRegistration.Dynamic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.FilterRegistration.Dynamic

  • Packages that use FilterRegistration.Dynamic
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of FilterRegistration.Dynamic in javax.servlet

      Methods in javax.servlet that return FilterRegistration.Dynamic
      Modifier and Type Method and Description
      FilterRegistration.Dynamic ServletContext.addFilter(String filterName, Class<? extends Filter> filterClass)
      Adds the filter with the given name and class type to this servlet context.
      FilterRegistration.Dynamic ServletContext.addFilter(String filterName, Filter filter)
      Registers the given filter instance with this ServletContext under the given filterName.
      FilterRegistration.Dynamic ServletContext.addFilter(String filterName, String className)
      Adds the filter with the given name and class name to this servlet context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ReadListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ReadListener

  • Packages that use ReadListener
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ReadListener in javax.servlet

      Methods in javax.servlet with parameters of type ReadListener
      Modifier and Type Method and Description
      abstract void ServletInputStream.setReadListener(ReadListener readListener)
      Instructs the ServletInputStream to invoke the provided ReadListener when it is possible to read
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.Registration (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.Registration

  • Packages that use Registration
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of Registration in javax.servlet

      Subinterfaces of Registration in javax.servlet
      Modifier and Type Interface and Description
      interface  FilterRegistration
      Interface through which a Filter may be further configured.
      static interface  FilterRegistration.Dynamic
      Interface through which a Filter registered via one of the addFilter methods on ServletContext may be further configured.
      static interface  Registration.Dynamic
      Interface through which a Servlet or Filter registered via one of the addServlet or addFilter methods, respectively, on ServletContext may be further configured.
      interface  ServletRegistration
      Interface through which a Servlet may be further configured.
      static interface  ServletRegistration.Dynamic
      Interface through which a Servlet registered via one of the addServlet methods on ServletContext may be further configured.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.Registration.Dynamic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.Registration.Dynamic

  • Packages that use Registration.Dynamic
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of Registration.Dynamic in javax.servlet

      Subinterfaces of Registration.Dynamic in javax.servlet
      Modifier and Type Interface and Description
      static interface  FilterRegistration.Dynamic
      Interface through which a Filter registered via one of the addFilter methods on ServletContext may be further configured.
      static interface  ServletRegistration.Dynamic
      Interface through which a Servlet registered via one of the addServlet methods on ServletContext may be further configured.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.RequestDispatcher (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.RequestDispatcher

  • Packages that use RequestDispatcher
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of RequestDispatcher in javax.servlet

      Methods in javax.servlet that return RequestDispatcher
      Modifier and Type Method and Description
      RequestDispatcher ServletContext.getNamedDispatcher(String name)
      Returns a RequestDispatcher object that acts as a wrapper for the named servlet.
      RequestDispatcher ServletRequestWrapper.getRequestDispatcher(String path)
      The default behavior of this method is to return getRequestDispatcher(String path) on the wrapped request object.
      RequestDispatcher ServletRequest.getRequestDispatcher(String path)
      Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
      RequestDispatcher ServletContext.getRequestDispatcher(String path)
      Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.Servlet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.Servlet

  • Packages that use Servlet
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of Servlet in javax.faces.webapp

      Classes in javax.faces.webapp that implement Servlet
      Modifier and Type Class and Description
      class  FacesServlet
      FacesServlet is a servlet that manages the request processing lifecycle for web applications that are utilizing JavaServer Faces to construct the user interface.

    • Uses of Servlet in javax.servlet

      Classes in javax.servlet that implement Servlet
      Modifier and Type Class and Description
      class  GenericServlet
      Defines a generic, protocol-independent servlet.
      Methods in javax.servlet with type parameters of type Servlet
      Modifier and Type Method and Description
      <T extends Servlet>
      T             		ServletContext.createServlet(Class<T> clazz)
      Instantiates the given Servlet class.
      Methods in javax.servlet that return Servlet
      Modifier and Type Method and Description
      Servlet UnavailableException.getServlet()
      Deprecated.
      As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.
      Servlet ServletContext.getServlet(String name)
      Deprecated.
      As of Java Servlet API 2.1, with no direct replacement.

      This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

      In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.
      Methods in javax.servlet that return types with arguments of type Servlet
      Modifier and Type Method and Description
      Enumeration<Servlet> ServletContext.getServlets()
      Deprecated.
      As of Java Servlet API 2.0, with no replacement.

      This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.
      Methods in javax.servlet with parameters of type Servlet
      Modifier and Type Method and Description
      ServletRegistration.Dynamic ServletContext.addServlet(String servletName, Servlet servlet)
      Registers the given servlet instance with this ServletContext under the given servletName.
      Method parameters in javax.servlet with type arguments of type Servlet
      Modifier and Type Method and Description
      ServletRegistration.Dynamic ServletContext.addServlet(String servletName, Class<? extends Servlet> servletClass)
      Adds the servlet with the given name and class type to this servlet context.
      Constructors in javax.servlet with parameters of type Servlet
      Constructor and Description
      UnavailableException(int seconds, Servlet servlet, String msg)
      Deprecated.
      As of Java Servlet API 2.2, use UnavailableException.UnavailableException(String, int) instead.
      UnavailableException(Servlet servlet, String msg)
      Deprecated.
      As of Java Servlet API 2.2, use UnavailableException.UnavailableException(String) instead.

    • Uses of Servlet in javax.servlet.http

      Classes in javax.servlet.http that implement Servlet
      Modifier and Type Class and Description
      class  HttpServlet
      Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site.

    • Uses of Servlet in javax.servlet.jsp

      Subinterfaces of Servlet in javax.servlet.jsp
      Modifier and Type Interface and Description
      interface  HttpJspPage
      The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.
      interface  JspPage
      The JspPage interface describes the generic interaction that a JSP Page Implementation class must satisfy; pages that use the HTTP protocol are described by the HttpJspPage interface.
      Methods in javax.servlet.jsp with parameters of type Servlet
      Modifier and Type Method and Description
      abstract PageContext JspFactory.getPageContext(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int buffer, boolean autoflush)
      obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.
      abstract void PageContext.initialize(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int bufferSize, boolean autoFlush)
      The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletConfig

  • Packages that use ServletConfig
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of ServletConfig in javax.faces.webapp

      Methods in javax.faces.webapp that return ServletConfig
      Modifier and Type Method and Description
      ServletConfig FacesServlet.getServletConfig()
      Return the ServletConfig instance for this servlet.
      Methods in javax.faces.webapp with parameters of type ServletConfig
      Modifier and Type Method and Description
      void FacesServlet.init(ServletConfig servletConfig)
      Acquire the factory instances we will require.

    • Uses of ServletConfig in javax.servlet

      Classes in javax.servlet that implement ServletConfig
      Modifier and Type Class and Description
      class  GenericServlet
      Defines a generic, protocol-independent servlet.
      Methods in javax.servlet that return ServletConfig
      Modifier and Type Method and Description
      ServletConfig Servlet.getServletConfig()
      Returns a ServletConfig object, which contains initialization and startup parameters for this servlet.
      ServletConfig GenericServlet.getServletConfig()
      Returns this servlet's ServletConfig object.
      Methods in javax.servlet with parameters of type ServletConfig
      Modifier and Type Method and Description
      void Servlet.init(ServletConfig config)
      Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
      void GenericServlet.init(ServletConfig config)
      Called by the servlet container to indicate to a servlet that the servlet is being placed into service.

    • Uses of ServletConfig in javax.servlet.http

      Classes in javax.servlet.http that implement ServletConfig
      Modifier and Type Class and Description
      class  HttpServlet
      Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site.

    • Uses of ServletConfig in javax.servlet.jsp

      Methods in javax.servlet.jsp that return ServletConfig
      Modifier and Type Method and Description
      abstract ServletConfig PageContext.getServletConfig()
      The ServletConfig instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletContainerInitializer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletContainerInitializer

No usage of javax.servlet.ServletContainerInitializer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletContext

  • Packages that use ServletContext
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.xml.rpc.server
    This package defines APIs for the servlet based JAX-RPC endpoint model.

    • Uses of ServletContext in javax.servlet

      Methods in javax.servlet that return ServletContext
      Modifier and Type Method and Description
      ServletContext ServletContext.getContext(String uripath)
      Returns a ServletContext object that corresponds to a specified URL on the server.
      ServletContext ServletRequestWrapper.getServletContext()
      Gets the servlet context to which the wrapped servlet request was last dispatched.
      ServletContext ServletRequestEvent.getServletContext()
      Returns the ServletContext of this web application.
      ServletContext ServletRequest.getServletContext()
      Gets the servlet context to which this ServletRequest was last dispatched.
      ServletContext ServletContextEvent.getServletContext()
      Return the ServletContext that changed.
      ServletContext ServletConfig.getServletContext()
      Returns a reference to the ServletContext in which the caller is executing.
      ServletContext GenericServlet.getServletContext()
      Returns a reference to the ServletContext in which this servlet is running.
      ServletContext FilterConfig.getServletContext()
      Returns a reference to the ServletContext in which the caller is executing.
      Methods in javax.servlet with parameters of type ServletContext
      Modifier and Type Method and Description
      void AsyncContext.dispatch(ServletContext context, String path)
      Dispatches the request and response objects of this AsyncContext to the given path scoped to the given context.
      void ServletContainerInitializer.onStartup(Set<Class<?>> c, ServletContext ctx)
      Notifies this ServletContainerInitializer of the startup of the application represented by the given ServletContext.
      Constructors in javax.servlet with parameters of type ServletContext
      Constructor and Description
      ServletContextAttributeEvent(ServletContext source, String name, Object value)
      Constructs a ServletContextAttributeEvent from the given ServletContext, attribute name, and attribute value.
      ServletContextEvent(ServletContext source)
      Construct a ServletContextEvent from the given context.
      ServletRequestAttributeEvent(ServletContext sc, ServletRequest request, String name, Object value)
      Construct a ServletRequestAttributeEvent giving the servlet context of this web application, the ServletRequest whose attributes are changing and the name and value of the attribute.
      ServletRequestEvent(ServletContext sc, ServletRequest request)
      Construct a ServletRequestEvent for the given ServletContext and ServletRequest.

    • Uses of ServletContext in javax.servlet.http

      Methods in javax.servlet.http that return ServletContext
      Modifier and Type Method and Description
      ServletContext HttpSession.getServletContext()
      Returns the ServletContext to which this session belongs.

    • Uses of ServletContext in javax.servlet.jsp

      Methods in javax.servlet.jsp that return ServletContext
      Modifier and Type Method and Description
      abstract ServletContext PageContext.getServletContext()
      The ServletContext instance.
      Methods in javax.servlet.jsp with parameters of type ServletContext
      Modifier and Type Method and Description
      abstract JspApplicationContext JspFactory.getJspApplicationContext(ServletContext context)
      Obtains the JspApplicationContext instance associated with the web application for the given ServletContext.

    • Uses of ServletContext in javax.servlet.jsp.jstl.core

      Methods in javax.servlet.jsp.jstl.core with parameters of type ServletContext
      Modifier and Type Method and Description
      static Object Config.get(ServletContext context, String name)
      Looks up a configuration variable in the "application" scope.
      static void Config.remove(ServletContext context, String name)
      Removes a configuration variable from the "application" scope.
      static void Config.set(ServletContext context, String name, Object value)
      Sets the value of a configuration variable in the "application" scope.

    • Uses of ServletContext in javax.xml.rpc.server

      Methods in javax.xml.rpc.server that return ServletContext
      Modifier and Type Method and Description
      ServletContext ServletEndpointContext.getServletContext()
      The method getServletContext returns the ServletContext associated with the web application that contain this endpoint.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletContextAttributeListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletContextAttributeListener

No usage of javax.servlet.ServletContextAttributeListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletContextListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletContextListener

No usage of javax.servlet.ServletContextListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletRegistration (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletRegistration

  • Packages that use ServletRegistration
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletRegistration in javax.servlet

      Subinterfaces of ServletRegistration in javax.servlet
      Modifier and Type Interface and Description
      static interface  ServletRegistration.Dynamic
      Interface through which a Servlet registered via one of the addServlet methods on ServletContext may be further configured.
      Methods in javax.servlet that return ServletRegistration
      Modifier and Type Method and Description
      ServletRegistration ServletContext.getServletRegistration(String servletName)
      Gets the ServletRegistration corresponding to the servlet with the given servletName.
      Methods in javax.servlet that return types with arguments of type ServletRegistration
      Modifier and Type Method and Description
      Map<String,? extends ServletRegistration> ServletContext.getServletRegistrations()
      Gets a (possibly empty) Map of the ServletRegistration objects (keyed by servlet name) corresponding to all servlets registered with this ServletContext.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletRegistration.Dynamic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletRegistration.Dynamic

  • Packages that use ServletRegistration.Dynamic
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of ServletRegistration.Dynamic in javax.servlet

      Methods in javax.servlet that return ServletRegistration.Dynamic
      Modifier and Type Method and Description
      ServletRegistration.Dynamic ServletContext.addServlet(String servletName, Class<? extends Servlet> servletClass)
      Adds the servlet with the given name and class type to this servlet context.
      ServletRegistration.Dynamic ServletContext.addServlet(String servletName, Servlet servlet)
      Registers the given servlet instance with this ServletContext under the given servletName.
      ServletRegistration.Dynamic ServletContext.addServlet(String servletName, String className)
      Adds the servlet with the given name and class name to this servlet context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletRequest (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletRequest

  • Packages that use ServletRequest
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of ServletRequest in javax.faces.webapp

      Methods in javax.faces.webapp with parameters of type ServletRequest
      Modifier and Type Method and Description
      void FacesServlet.service(ServletRequest req, ServletResponse resp)

      Process an incoming request, and create the corresponding response according to the following specification.

    • Uses of ServletRequest in javax.servlet

      Classes in javax.servlet that implement ServletRequest
      Modifier and Type Class and Description
      class  ServletRequestWrapper
      Provides a convenient implementation of the ServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
      Methods in javax.servlet that return ServletRequest
      Modifier and Type Method and Description
      ServletRequest ServletRequestWrapper.getRequest()
      Return the wrapped request object.
      ServletRequest AsyncContext.getRequest()
      Gets the request that was used to initialize this AsyncContext by calling startAsync() or startAsync(ServletRequest, ServletResponse).
      ServletRequest ServletRequestEvent.getServletRequest()
      Returns the ServletRequest that is changing.
      ServletRequest AsyncEvent.getSuppliedRequest()
      Gets the ServletRequest from this AsyncEvent.
      Methods in javax.servlet with parameters of type ServletRequest
      Modifier and Type Method and Description
      void AsyncContext.addListener(AsyncListener listener, ServletRequest servletRequest, ServletResponse servletResponse)
      Registers the given AsyncListener with the most recent asynchronous cycle that was started by a call to one of the startAsync() methods.
      void FilterChain.doFilter(ServletRequest request, ServletResponse response)
      Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.
      void Filter.doFilter(ServletRequest request, ServletResponse response, FilterChain chain)
      The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain.
      void RequestDispatcher.forward(ServletRequest request, ServletResponse response)
      Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server.
      void RequestDispatcher.include(ServletRequest request, ServletResponse response)
      Includes the content of a resource (servlet, JSP page, HTML file) in the response.
      boolean ServletRequestWrapper.isWrapperFor(ServletRequest wrapped)
      Checks (recursively) if this ServletRequestWrapper wraps the given ServletRequest instance.
      void Servlet.service(ServletRequest req, ServletResponse res)
      Called by the servlet container to allow the servlet to respond to a request.
      abstract void GenericServlet.service(ServletRequest req, ServletResponse res)
      Called by the servlet container to allow the servlet to respond to a request.
      void ServletRequestWrapper.setRequest(ServletRequest request)
      Sets the request object being wrapped.
      AsyncContext ServletRequestWrapper.startAsync(ServletRequest servletRequest, ServletResponse servletResponse)
      The default behavior of this method is to invoke startAsync(ServletRequest, ServletResponse) on the wrapped request object.
      AsyncContext ServletRequest.startAsync(ServletRequest servletRequest, ServletResponse servletResponse)
      Puts this request into asynchronous mode, and initializes its AsyncContext with the given request and response objects.
      Constructors in javax.servlet with parameters of type ServletRequest
      Constructor and Description
      AsyncEvent(AsyncContext context, ServletRequest request, ServletResponse response)
      Constructs an AsyncEvent from the given AsyncContext, ServletRequest, and ServletResponse.
      AsyncEvent(AsyncContext context, ServletRequest request, ServletResponse response, Throwable throwable)
      Constructs an AsyncEvent from the given AsyncContext, ServletRequest, ServletResponse, and Throwable.
      ServletRequestAttributeEvent(ServletContext sc, ServletRequest request, String name, Object value)
      Construct a ServletRequestAttributeEvent giving the servlet context of this web application, the ServletRequest whose attributes are changing and the name and value of the attribute.
      ServletRequestEvent(ServletContext sc, ServletRequest request)
      Construct a ServletRequestEvent for the given ServletContext and ServletRequest.
      ServletRequestWrapper(ServletRequest request)
      Creates a ServletRequest adaptor wrapping the given request object.

    • Uses of ServletRequest in javax.servlet.http

      Subinterfaces of ServletRequest in javax.servlet.http
      Modifier and Type Interface and Description
      interface  HttpServletRequest
      Extends the ServletRequest interface to provide request information for HTTP servlets.
      Classes in javax.servlet.http that implement ServletRequest
      Modifier and Type Class and Description
      class  HttpServletRequestWrapper
      Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
      Methods in javax.servlet.http with parameters of type ServletRequest
      Modifier and Type Method and Description
      void HttpServlet.service(ServletRequest req, ServletResponse res)
      Dispatches client requests to the protected service method.

    • Uses of ServletRequest in javax.servlet.jsp

      Methods in javax.servlet.jsp that return ServletRequest
      Modifier and Type Method and Description
      abstract ServletRequest PageContext.getRequest()
      The current value of the request object (a ServletRequest).
      Methods in javax.servlet.jsp with parameters of type ServletRequest
      Modifier and Type Method and Description
      abstract PageContext JspFactory.getPageContext(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int buffer, boolean autoflush)
      obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.
      abstract void PageContext.initialize(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int bufferSize, boolean autoFlush)
      The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.

    • Uses of ServletRequest in javax.servlet.jsp.jstl.core

      Methods in javax.servlet.jsp.jstl.core with parameters of type ServletRequest
      Modifier and Type Method and Description
      static Object Config.get(ServletRequest request, String name)
      Looks up a configuration variable in the "request" scope.
      static void Config.remove(ServletRequest request, String name)
      Removes a configuration variable from the "request" scope.
      static void Config.set(ServletRequest request, String name, Object value)
      Sets the value of a configuration variable in the "request" scope.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletRequestAttributeListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletRequestAttributeListener

No usage of javax.servlet.ServletRequestAttributeListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletRequestListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletRequestListener

No usage of javax.servlet.ServletRequestListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.ServletResponse (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.ServletResponse

  • Packages that use ServletResponse
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of ServletResponse in javax.faces.webapp

      Methods in javax.faces.webapp with parameters of type ServletResponse
      Modifier and Type Method and Description
      void FacesServlet.service(ServletRequest req, ServletResponse resp)

      Process an incoming request, and create the corresponding response according to the following specification.

    • Uses of ServletResponse in javax.servlet

      Classes in javax.servlet that implement ServletResponse
      Modifier and Type Class and Description
      class  ServletResponseWrapper
      Provides a convenient implementation of the ServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
      Methods in javax.servlet that return ServletResponse
      Modifier and Type Method and Description
      ServletResponse ServletResponseWrapper.getResponse()
      Return the wrapped ServletResponse object.
      ServletResponse AsyncContext.getResponse()
      Gets the response that was used to initialize this AsyncContext by calling ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse).
      ServletResponse AsyncEvent.getSuppliedResponse()
      Gets the ServletResponse from this AsyncEvent.
      Methods in javax.servlet with parameters of type ServletResponse
      Modifier and Type Method and Description
      void AsyncContext.addListener(AsyncListener listener, ServletRequest servletRequest, ServletResponse servletResponse)
      Registers the given AsyncListener with the most recent asynchronous cycle that was started by a call to one of the ServletRequest.startAsync() methods.
      void FilterChain.doFilter(ServletRequest request, ServletResponse response)
      Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.
      void Filter.doFilter(ServletRequest request, ServletResponse response, FilterChain chain)
      The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain.
      void RequestDispatcher.forward(ServletRequest request, ServletResponse response)
      Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server.
      void RequestDispatcher.include(ServletRequest request, ServletResponse response)
      Includes the content of a resource (servlet, JSP page, HTML file) in the response.
      boolean ServletResponseWrapper.isWrapperFor(ServletResponse wrapped)
      Checks (recursively) if this ServletResponseWrapper wraps the given ServletResponse instance.
      void Servlet.service(ServletRequest req, ServletResponse res)
      Called by the servlet container to allow the servlet to respond to a request.
      abstract void GenericServlet.service(ServletRequest req, ServletResponse res)
      Called by the servlet container to allow the servlet to respond to a request.
      void ServletResponseWrapper.setResponse(ServletResponse response)
      Sets the response being wrapped.
      AsyncContext ServletRequestWrapper.startAsync(ServletRequest servletRequest, ServletResponse servletResponse)
      The default behavior of this method is to invoke ServletRequest.startAsync(ServletRequest, ServletResponse) on the wrapped request object.
      AsyncContext ServletRequest.startAsync(ServletRequest servletRequest, ServletResponse servletResponse)
      Puts this request into asynchronous mode, and initializes its AsyncContext with the given request and response objects.
      Constructors in javax.servlet with parameters of type ServletResponse
      Constructor and Description
      AsyncEvent(AsyncContext context, ServletRequest request, ServletResponse response)
      Constructs an AsyncEvent from the given AsyncContext, ServletRequest, and ServletResponse.
      AsyncEvent(AsyncContext context, ServletRequest request, ServletResponse response, Throwable throwable)
      Constructs an AsyncEvent from the given AsyncContext, ServletRequest, ServletResponse, and Throwable.
      ServletResponseWrapper(ServletResponse response)
      Creates a ServletResponse adaptor wrapping the given response object.

    • Uses of ServletResponse in javax.servlet.http

      Subinterfaces of ServletResponse in javax.servlet.http
      Modifier and Type Interface and Description
      interface  HttpServletResponse
      Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response.
      Classes in javax.servlet.http that implement ServletResponse
      Modifier and Type Class and Description
      class  HttpServletResponseWrapper
      Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
      Methods in javax.servlet.http with parameters of type ServletResponse
      Modifier and Type Method and Description
      void HttpServlet.service(ServletRequest req, ServletResponse res)
      Dispatches client requests to the protected service method.

    • Uses of ServletResponse in javax.servlet.jsp

      Methods in javax.servlet.jsp that return ServletResponse
      Modifier and Type Method and Description
      abstract ServletResponse PageContext.getResponse()
      The current value of the response object (a ServletResponse).
      Methods in javax.servlet.jsp with parameters of type ServletResponse
      Modifier and Type Method and Description
      abstract PageContext JspFactory.getPageContext(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int buffer, boolean autoflush)
      obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.
      abstract void PageContext.initialize(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int bufferSize, boolean autoFlush)
      The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.SessionCookieConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.SessionCookieConfig

  • Packages that use SessionCookieConfig
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of SessionCookieConfig in javax.servlet

      Methods in javax.servlet that return SessionCookieConfig
      Modifier and Type Method and Description
      SessionCookieConfig ServletContext.getSessionCookieConfig()
      Gets the SessionCookieConfig object through which various properties of the session tracking cookies created on behalf of this ServletContext may be configured.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.SingleThreadModel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.SingleThreadModel

No usage of javax.servlet.SingleThreadModel
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.WriteListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.WriteListener

  • Packages that use WriteListener
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of WriteListener in javax.servlet

      Methods in javax.servlet with parameters of type WriteListener
      Modifier and Type Method and Description
      abstract void ServletOutputStream.setWriteListener(WriteListener writeListener)
      Instructs the ServletOutputStream to invoke the provided WriteListener when it is possible to write
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.servlet.descriptor (Java(TM) EE 7 Specification APIs)

javax.servlet.descriptor

Interfaces

  • JspConfigDescriptor
  • JspPropertyGroupDescriptor
  • TaglibDescriptor


javax.servlet.descriptor (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet.descriptor

Provides programmatic access to a web application's configuration information that was aggregated from the web.xml and web-fragment.xml descriptors.

See: Description

  • Interface Summary
    Interface Description
    JspConfigDescriptor
    This interface provides access to the <jsp-config> related configuration of a web application.
    JspPropertyGroupDescriptor
    This interface provides access to the <jsp-property-group> related configuration of a web application.
    TaglibDescriptor
    This interface provides access to the <taglib> related configuration of a web application.

Package javax.servlet.descriptor Description

Provides programmatic access to a web application's configuration information that was aggregated from the web.xml and web-fragment.xml descriptors.
Since:
Servlet 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet.descriptor Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet.descriptor

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.servlet.descriptor.JspConfigDescriptor
  • javax.servlet.descriptor.JspPropertyGroupDescriptor
  • javax.servlet.descriptor.TaglibDescriptor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JspConfigDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.descriptor

Interface JspConfigDescriptor

  • public interface JspConfigDescriptor
    This interface provides access to the <jsp-config> related configuration of a web application.

    The configuration is aggregated from the web.xml and web-fragment.xml descriptor files of the web application.

    Since:
    Servlet 3.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Collection<JspPropertyGroupDescriptor> getJspPropertyGroups()
      Gets the <jsp-property-group> child elements of the <jsp-config> element represented by this JspConfigDescriptor.
      Collection<TaglibDescriptor> getTaglibs()
      Gets the <taglib> child elements of the <jsp-config> element represented by this JspConfigDescriptor.

    • Method Detail

      • getTaglibs

        Collection<TaglibDescriptor> getTaglibs()
        Gets the <taglib> child elements of the <jsp-config> element represented by this JspConfigDescriptor.

        Any changes to the returned Collection must not affect this JspConfigDescriptor.

        Returns:
        a (possibly empty) Collection of the <taglib<>/code> child elements of the <jsp-config> element represented by this JspConfigDescriptor

      • getJspPropertyGroups

        Collection<JspPropertyGroupDescriptor> getJspPropertyGroups()
        Gets the <jsp-property-group> child elements of the <jsp-config> element represented by this JspConfigDescriptor.

        Any changes to the returned Collection must not affect this JspConfigDescriptor.

        Returns:
        a (possibly empty) Collection of the <jsp-property-group> child elements of the <jsp-config> element represented by this JspConfigDescriptor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JspPropertyGroupDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.descriptor

Interface JspPropertyGroupDescriptor

  • public interface JspPropertyGroupDescriptor
    This interface provides access to the <jsp-property-group> related configuration of a web application.

    The configuration is aggregated from the web.xml and web-fragment.xml descriptor files of the web application.

    Since:
    Servlet 3.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getBuffer()
      Gets the value of the buffer configuration, which specifies the default size of the response buffer for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
      String getDefaultContentType()
      Gets the value of the default-content-type configuration, which specifies the default response content type for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
      String getDeferredSyntaxAllowedAsLiteral()
      Gets the value of the deferred-syntax-allowed-as-literal configuration, which specifies whether the character sequence "#{", which is normally reserved for Expression Language (EL) expressions, will cause a translation error if it appears as a String literal in any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
      String getElIgnored()
      Gets the value of the el-ignored configuration, which specifies whether Expression Language (EL) evaluation is enabled for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
      String getErrorOnUndeclaredNamespace()
      Gets the value of the error-on-undeclared-namespace configuration, which specifies whether an error will be raised at translation time if tag with an undeclared namespace is used in any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
      Collection<String> getIncludeCodas()
      Gets the include-coda configuration of the JSP property group represented by this JspPropertyGroupDescriptor.
      Collection<String> getIncludePreludes()
      Gets the include-prelude configuration of the JSP property group represented by this JspPropertyGroupDescriptor.
      String getIsXml()
      Gets the value of the is-xml configuration, which specifies whether any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor will be treated as JSP documents (XML syntax).
      String getPageEncoding()
      Gets the value of the page-encoding configuration, which specifies the default page encoding for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
      String getScriptingInvalid()
      Gets the value of the scripting-invalid configuration, which specifies whether scripting is enabled for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
      String getTrimDirectiveWhitespaces()
      Gets the value of the trim-directive-whitespaces configuration, which specifies whether template text containing only whitespaces must be removed from the response output of any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
      Collection<String> getUrlPatterns()
      Gets the URL patterns of the JSP property group represented by this JspPropertyGroupDescriptor.

    • Method Detail

      • getUrlPatterns

        Collection<String> getUrlPatterns()
        Gets the URL patterns of the JSP property group represented by this JspPropertyGroupDescriptor.

        Any changes to the returned Collection must not affect this JspPropertyGroupDescriptor.

        Returns:
        a (possibly empty) Collection of the URL patterns of the JSP property group represented by this JspPropertyGroupDescriptor

      • getElIgnored

        String getElIgnored()
        Gets the value of the el-ignored configuration, which specifies whether Expression Language (EL) evaluation is enabled for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
        Returns:
        the value of the el-ignored configuration, or null if unspecified

      • getPageEncoding

        String getPageEncoding()
        Gets the value of the page-encoding configuration, which specifies the default page encoding for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
        Returns:
        the value of the page-encoding configuration, or null if unspecified

      • getScriptingInvalid

        String getScriptingInvalid()
        Gets the value of the scripting-invalid configuration, which specifies whether scripting is enabled for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
        Returns:
        the value of the scripting-invalid configuration, or null if unspecified

      • getIsXml

        String getIsXml()
        Gets the value of the is-xml configuration, which specifies whether any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor will be treated as JSP documents (XML syntax).
        Returns:
        the value of the is-xml configuration, or null if unspecified

      • getIncludePreludes

        Collection<String> getIncludePreludes()
        Gets the include-prelude configuration of the JSP property group represented by this JspPropertyGroupDescriptor.

        Any changes to the returned Collection must not affect this JspPropertyGroupDescriptor.

        Returns:
        a (possibly empty) Collection of the include-prelude configuration of the JSP property group represented by this JspPropertyGroupDescriptor

      • getIncludeCodas

        Collection<String> getIncludeCodas()
        Gets the include-coda configuration of the JSP property group represented by this JspPropertyGroupDescriptor.

        Any changes to the returned Collection must not affect this JspPropertyGroupDescriptor.

        Returns:
        a (possibly empty) Collection of the include-coda configuration of the JSP property group represented by this JspPropertyGroupDescriptor

      • getDeferredSyntaxAllowedAsLiteral

        String getDeferredSyntaxAllowedAsLiteral()
        Gets the value of the deferred-syntax-allowed-as-literal configuration, which specifies whether the character sequence "#{", which is normally reserved for Expression Language (EL) expressions, will cause a translation error if it appears as a String literal in any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
        Returns:
        the value of the deferred-syntax-allowed-as-literal configuration, or null if unspecified

      • getTrimDirectiveWhitespaces

        String getTrimDirectiveWhitespaces()
        Gets the value of the trim-directive-whitespaces configuration, which specifies whether template text containing only whitespaces must be removed from the response output of any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
        Returns:
        the value of the trim-directive-whitespaces configuration, or null if unspecified

      • getDefaultContentType

        String getDefaultContentType()
        Gets the value of the default-content-type configuration, which specifies the default response content type for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
        Returns:
        the value of the default-content-type configuration, or null if unspecified

      • getBuffer

        String getBuffer()
        Gets the value of the buffer configuration, which specifies the default size of the response buffer for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
        Returns:
        the value of the buffer configuration, or null if unspecified

      • getErrorOnUndeclaredNamespace

        String getErrorOnUndeclaredNamespace()
        Gets the value of the error-on-undeclared-namespace configuration, which specifies whether an error will be raised at translation time if tag with an undeclared namespace is used in any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.
        Returns:
        the value of the error-on-undeclared-namespace configuration, or null if unspecified
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TaglibDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.descriptor

Interface TaglibDescriptor

  • public interface TaglibDescriptor
    This interface provides access to the <taglib> related configuration of a web application.

    The configuration is aggregated from the web.xml and web-fragment.xml descriptor files of the web application.

    Since:
    Servlet 3.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getTaglibLocation()
      Gets the location of the tag library represented by this TaglibDescriptor.
      String getTaglibURI()
      Gets the unique identifier of the tag library represented by this TaglibDescriptor.

    • Method Detail

      • getTaglibURI

        String getTaglibURI()
        Gets the unique identifier of the tag library represented by this TaglibDescriptor.
        Returns:
        the unique identifier of the tag library represented by this TaglibDescriptor

      • getTaglibLocation

        String getTaglibLocation()
        Gets the location of the tag library represented by this TaglibDescriptor.
        Returns:
        the location of the tag library represented by this TaglibDescriptor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.servlet.descriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet.descriptor

  • Packages that use javax.servlet.descriptor
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.descriptor
    Provides programmatic access to a web application's configuration information that was aggregated from the web.xml and web-fragment.xml descriptors.
  • Classes in javax.servlet.descriptor used by javax.servlet
    Class and Description
    JspConfigDescriptor
    This interface provides access to the <jsp-config> related configuration of a web application.
  • Classes in javax.servlet.descriptor used by javax.servlet.descriptor
    Class and Description
    JspPropertyGroupDescriptor
    This interface provides access to the <jsp-property-group> related configuration of a web application.
    TaglibDescriptor
    This interface provides access to the <taglib> related configuration of a web application.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.descriptor.JspConfigDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.descriptor.JspConfigDescriptor

  • Packages that use JspConfigDescriptor
    Package Description
    javax.servlet
    The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of JspConfigDescriptor in javax.servlet

      Methods in javax.servlet that return JspConfigDescriptor
      Modifier and Type Method and Description
      JspConfigDescriptor ServletContext.getJspConfigDescriptor()
      Gets the <jsp-config> related configuration that was aggregated from the web.xml and web-fragment.xml descriptor files of the web application represented by this ServletContext.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.descriptor.JspPropertyGroupDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.descriptor.JspPropertyGroupDescriptor

  • Packages that use JspPropertyGroupDescriptor
    Package Description
    javax.servlet.descriptor
    Provides programmatic access to a web application's configuration information that was aggregated from the web.xml and web-fragment.xml descriptors.

    • Uses of JspPropertyGroupDescriptor in javax.servlet.descriptor

      Methods in javax.servlet.descriptor that return types with arguments of type JspPropertyGroupDescriptor
      Modifier and Type Method and Description
      Collection<JspPropertyGroupDescriptor> JspConfigDescriptor.getJspPropertyGroups()
      Gets the <jsp-property-group> child elements of the <jsp-config> element represented by this JspConfigDescriptor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.descriptor.TaglibDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.descriptor.TaglibDescriptor

  • Packages that use TaglibDescriptor
    Package Description
    javax.servlet.descriptor
    Provides programmatic access to a web application's configuration information that was aggregated from the web.xml and web-fragment.xml descriptors.

    • Uses of TaglibDescriptor in javax.servlet.descriptor

      Methods in javax.servlet.descriptor that return types with arguments of type TaglibDescriptor
      Modifier and Type Method and Description
      Collection<TaglibDescriptor> JspConfigDescriptor.getTaglibs()
      Gets the <taglib> child elements of the <jsp-config> element represented by this JspConfigDescriptor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Cookie (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Class Cookie

  • java.lang.Object
    • javax.servlet.http.Cookie
  • All Implemented Interfaces:
    Serializable, Cloneable

    public class Cookie
extends Object
implements Cloneable, Serializable
    Creates a cookie, a small amount of information sent by a servlet to a Web browser, saved by the browser, and later sent back to the server. A cookie's value can uniquely identify a client, so cookies are commonly used for session management.

    A cookie has a name, a single value, and optional attributes such as a comment, path and domain qualifiers, a maximum age, and a version number. Some Web browsers have bugs in how they handle the optional attributes, so use them sparingly to improve the interoperability of your servlets.

    The servlet sends cookies to the browser by using the HttpServletResponse.addCookie(javax.servlet.http.Cookie) method, which adds fields to HTTP response headers to send cookies to the browser, one at a time. The browser is expected to support 20 cookies for each Web server, 300 cookies total, and may limit cookie size to 4 KB each.

    The browser returns cookies to the servlet by adding fields to HTTP request headers. Cookies can be retrieved from a request by using the HttpServletRequest.getCookies() method. Several cookies might have the same name but different path attributes.

    Cookies affect the caching of the Web pages that use them. HTTP 1.0 does not cache pages that use cookies created with this class. This class does not support the cache control defined with HTTP 1.1.

    This class supports both the Version 0 (by Netscape) and Version 1 (by RFC 2109) cookie specifications. By default, cookies are created using Version 0 to ensure the best interoperability.

    Author:
    Various
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      Cookie(String name, String value)
      Constructs a cookie with the specified name and value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object clone()
      Overrides the standard java.lang.Object.clone method to return a copy of this Cookie.
      String getComment()
      Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.
      String getDomain()
      Gets the domain name of this Cookie.
      int getMaxAge()
      Gets the maximum age in seconds of this Cookie.
      String getName()
      Returns the name of the cookie.
      String getPath()
      Returns the path on the server to which the browser returns this cookie.
      boolean getSecure()
      Returns true if the browser is sending cookies only over a secure protocol, or false if the browser can send cookies using any protocol.
      String getValue()
      Gets the current value of this Cookie.
      int getVersion()
      Returns the version of the protocol this cookie complies with.
      boolean isHttpOnly()
      Checks whether this Cookie has been marked as HttpOnly.
      void setComment(String purpose)
      Specifies a comment that describes a cookie's purpose.
      void setDomain(String domain)
      Specifies the domain within which this cookie should be presented.
      void setHttpOnly(boolean isHttpOnly)
      Marks or unmarks this Cookie as HttpOnly.
      void setMaxAge(int expiry)
      Sets the maximum age in seconds for this Cookie.
      void setPath(String uri)
      Specifies a path for the cookie to which the client should return the cookie.
      void setSecure(boolean flag)
      Indicates to the browser whether the cookie should only be sent using a secure protocol, such as HTTPS or SSL.
      void setValue(String newValue)
      Assigns a new value to this Cookie.
      void setVersion(int v)
      Sets the version of the cookie protocol that this Cookie complies with.

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Cookie

        public Cookie(String name,
      String value)
        Constructs a cookie with the specified name and value.

        The name must conform to RFC 2109. However, vendors may provide a configuration option that allows cookie names conforming to the original Netscape Cookie Specification to be accepted.

        The name of a cookie cannot be changed once the cookie has been created.

        The value can be anything the server chooses to send. Its value is probably of interest only to the server. The cookie's value can be changed after creation with the setValue method.

        By default, cookies are created according to the Netscape cookie specification. The version can be changed with the setVersion method.

        Parameters:
        name - the name of the cookie
        value - the value of the cookie
        Throws:
        IllegalArgumentException - if the cookie name is null or empty or contains any illegal characters (for example, a comma, space, or semicolon) or matches a token reserved for use by the cookie protocol
        See Also:
        setValue(java.lang.String), setVersion(int)

    • Method Detail

      • setComment

        public void setComment(String purpose)
        Specifies a comment that describes a cookie's purpose. The comment is useful if the browser presents the cookie to the user. Comments are not supported by Netscape Version 0 cookies.
        Parameters:
        purpose - a String specifying the comment to display to the user
        See Also:
        getComment()

      • getComment

        public String getComment()
        Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.
        Returns:
        the comment of the cookie, or null if unspecified
        See Also:
        setComment(java.lang.String)

      • setDomain

        public void setDomain(String domain)
        Specifies the domain within which this cookie should be presented.

        The form of the domain name is specified by RFC 2109. A domain name begins with a dot (.foo.com) and means that the cookie is visible to servers in a specified Domain Name System (DNS) zone (for example, www.foo.com, but not a.b.foo.com). By default, cookies are only returned to the server that sent them.

        Parameters:
        domain - the domain name within which this cookie is visible; form is according to RFC 2109
        See Also:
        getDomain()

      • getDomain

        public String getDomain()
        Gets the domain name of this Cookie.

        Domain names are formatted according to RFC 2109.

        Returns:
        the domain name of this Cookie
        See Also:
        setDomain(java.lang.String)

      • setMaxAge

        public void setMaxAge(int expiry)
        Sets the maximum age in seconds for this Cookie.

        A positive value indicates that the cookie will expire after that many seconds have passed. Note that the value is the maximum age when the cookie will expire, not the cookie's current age.

        A negative value means that the cookie is not stored persistently and will be deleted when the Web browser exits. A zero value causes the cookie to be deleted.

        Parameters:
        expiry - an integer specifying the maximum age of the cookie in seconds; if negative, means the cookie is not stored; if zero, deletes the cookie
        See Also:
        getMaxAge()

      • getMaxAge

        public int getMaxAge()
        Gets the maximum age in seconds of this Cookie.

        By default, -1 is returned, which indicates that the cookie will persist until browser shutdown.

        Returns:
        an integer specifying the maximum age of the cookie in seconds; if negative, means the cookie persists until browser shutdown
        See Also:
        setMaxAge(int)

      • setPath

        public void setPath(String uri)
        Specifies a path for the cookie to which the client should return the cookie.

        The cookie is visible to all the pages in the directory you specify, and all the pages in that directory's subdirectories. A cookie's path must include the servlet that set the cookie, for example, /catalog, which makes the cookie visible to all directories on the server under /catalog.

        Consult RFC 2109 (available on the Internet) for more information on setting path names for cookies.

        Parameters:
        uri - a String specifying a path
        See Also:
        getPath()

      • getPath

        public String getPath()
        Returns the path on the server to which the browser returns this cookie. The cookie is visible to all subpaths on the server.
        Returns:
        a String specifying a path that contains a servlet name, for example, /catalog
        See Also:
        setPath(java.lang.String)

      • setSecure

        public void setSecure(boolean flag)
        Indicates to the browser whether the cookie should only be sent using a secure protocol, such as HTTPS or SSL.

        The default value is false.

        Parameters:
        flag - if true, sends the cookie from the browser to the server only when using a secure protocol; if false, sent on any protocol
        See Also:
        getSecure()

      • getSecure

        public boolean getSecure()
        Returns true if the browser is sending cookies only over a secure protocol, or false if the browser can send cookies using any protocol.
        Returns:
        true if the browser uses a secure protocol, false otherwise
        See Also:
        setSecure(boolean)

      • getName

        public String getName()
        Returns the name of the cookie. The name cannot be changed after creation.
        Returns:
        the name of the cookie

      • setValue

        public void setValue(String newValue)
        Assigns a new value to this Cookie.

        If you use a binary value, you may want to use BASE64 encoding.

        With Version 0 cookies, values should not contain white space, brackets, parentheses, equals signs, commas, double quotes, slashes, question marks, at signs, colons, and semicolons. Empty values may not behave the same way on all browsers.

        Parameters:
        newValue - the new value of the cookie
        See Also:
        getValue()

      • getValue

        public String getValue()
        Gets the current value of this Cookie.
        Returns:
        the current value of this Cookie
        See Also:
        setValue(java.lang.String)

      • getVersion

        public int getVersion()
        Returns the version of the protocol this cookie complies with. Version 1 complies with RFC 2109, and version 0 complies with the original cookie specification drafted by Netscape. Cookies provided by a browser use and identify the browser's cookie version.
        Returns:
        0 if the cookie complies with the original Netscape specification; 1 if the cookie complies with RFC 2109
        See Also:
        setVersion(int)

      • setVersion

        public void setVersion(int v)
        Sets the version of the cookie protocol that this Cookie complies with.

        Version 0 complies with the original Netscape cookie specification. Version 1 complies with RFC 2109.

        Since RFC 2109 is still somewhat new, consider version 1 as experimental; do not use it yet on production sites.

        Parameters:
        v - 0 if the cookie should comply with the original Netscape specification; 1 if the cookie should comply with RFC 2109
        See Also:
        getVersion()

      • clone

        public Object clone()
        Overrides the standard java.lang.Object.clone method to return a copy of this Cookie.
        Overrides:
        clone in class Object

      • setHttpOnly

        public void setHttpOnly(boolean isHttpOnly)
        Marks or unmarks this Cookie as HttpOnly.

        If isHttpOnly is set to true, this cookie is marked as HttpOnly, by adding the HttpOnly attribute to it.

        HttpOnly cookies are not supposed to be exposed to client-side scripting code, and may therefore help mitigate certain kinds of cross-site scripting attacks.

        Parameters:
        isHttpOnly - true if this cookie is to be marked as HttpOnly, false otherwise
        Since:
        Servlet 3.0

      • isHttpOnly

        public boolean isHttpOnly()
        Checks whether this Cookie has been marked as HttpOnly.
        Returns:
        true if this Cookie has been marked as HttpOnly, false otherwise
        Since:
        Servlet 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpServlet (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Class HttpServlet

  • java.lang.Object
    • javax.servlet.GenericServlet
      • javax.servlet.http.HttpServlet
  • All Implemented Interfaces:
    Serializable, Servlet, ServletConfig

    public abstract class HttpServlet
extends GenericServlet
    Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site. A subclass of HttpServlet must override at least one method, usually one of these:
    • doGet, if the servlet supports HTTP GET requests
    • doPost, for HTTP POST requests
    • doPut, for HTTP PUT requests
    • doDelete, for HTTP DELETE requests
    • init and destroy, to manage resources that are held for the life of the servlet
    • getServletInfo, which the servlet uses to provide information about itself

    There's almost no reason to override the service method. service handles standard HTTP requests by dispatching them to the handler methods for each HTTP request type (the do XXX methods listed above).

    Likewise, there's almost no reason to override the doOptions and doTrace methods.

    Servlets typically run on multithreaded servers, so be aware that a servlet must handle concurrent requests and be careful to synchronize access to shared resources. Shared resources include in-memory data such as instance or class variables and external objects such as files, database connections, and network connections. See the Java Tutorial on Multithreaded Programming for more information on handling multiple threads in a Java program.

    Author:
    Various
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpServlet()
      Does nothing, because this is an abstract class.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected void doDelete(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a DELETE request.
      protected void doGet(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a GET request.
      protected void doHead(HttpServletRequest req, HttpServletResponse resp)
      Receives an HTTP HEAD request from the protected service method and handles the request.
      protected void doOptions(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a OPTIONS request.
      protected void doPost(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a POST request.
      protected void doPut(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a PUT request.
      protected void doTrace(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a TRACE request.
      protected long getLastModified(HttpServletRequest req)
      Returns the time the HttpServletRequest object was last modified, in milliseconds since midnight January 1, 1970 GMT.
      protected void service(HttpServletRequest req, HttpServletResponse resp)
      Receives standard HTTP requests from the public service method and dispatches them to the do XXX methods defined in this class.
      void service(ServletRequest req, ServletResponse res)
      Dispatches client requests to the protected service method.

      • Methods inherited from class javax.servlet.GenericServlet

        destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, init, log, log

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HttpServlet

        public HttpServlet()
        Does nothing, because this is an abstract class.

    • Method Detail

      • doGet

        protected void doGet(HttpServletRequest req,
         HttpServletResponse resp)
              throws ServletException,
                     IOException
        Called by the server (via the service method) to allow a servlet to handle a GET request.

        Overriding this method to support a GET request also automatically supports an HTTP HEAD request. A HEAD request is a GET request that returns no body in the response, only the request header fields.

        When overriding this method, read the request data, write the response headers, get the response's writer or output stream object, and finally, write the response data. It's best to include content type and encoding. When using a PrintWriter object to return the response, set the content type before accessing the PrintWriter object.

        The servlet container must write the headers before committing the response, because in HTTP the headers must be sent before the response body.

        Where possible, set the Content-Length header (with the ServletResponse.setContentLength(int) method), to allow the servlet container to use a persistent connection to return its response to the client, improving performance. The content length is automatically set if the entire response fits inside the response buffer.

        When using HTTP 1.1 chunked encoding (which means that the response has a Transfer-Encoding header), do not set the Content-Length header.

        The GET method should be safe, that is, without any side effects for which users are held responsible. For example, most form queries have no side effects. If a client request is intended to change stored data, the request should use some other HTTP method.

        The GET method should also be idempotent, meaning that it can be safely repeated. Sometimes making a method safe also makes it idempotent. For example, repeating queries is both safe and idempotent, but buying a product online or modifying data is neither safe nor idempotent.

        If the request is incorrectly formatted, doGet returns an HTTP "Bad Request" message.

        Parameters:
        req - an HttpServletRequest object that contains the request the client has made of the servlet
        resp - an HttpServletResponse object that contains the response the servlet sends to the client
        Throws:
        IOException - if an input or output error is detected when the servlet handles the GET request
        ServletException - if the request for the GET could not be handled
        See Also:
        ServletResponse.setContentType(java.lang.String)

      • getLastModified

        protected long getLastModified(HttpServletRequest req)
        Returns the time the HttpServletRequest object was last modified, in milliseconds since midnight January 1, 1970 GMT. If the time is unknown, this method returns a negative number (the default).

        Servlets that support HTTP GET requests and can quickly determine their last modification time should override this method. This makes browser and proxy caches work more effectively, reducing the load on server and network resources.

        Parameters:
        req - the HttpServletRequest object that is sent to the servlet
        Returns:
        a long integer specifying the time the HttpServletRequest object was last modified, in milliseconds since midnight, January 1, 1970 GMT, or -1 if the time is not known

      • doHead

        protected void doHead(HttpServletRequest req,
          HttpServletResponse resp)
               throws ServletException,
                      IOException

        Receives an HTTP HEAD request from the protected service method and handles the request. The client sends a HEAD request when it wants to see only the headers of a response, such as Content-Type or Content-Length. The HTTP HEAD method counts the output bytes in the response to set the Content-Length header accurately.

        If you override this method, you can avoid computing the response body and just set the response headers directly to improve performance. Make sure that the doHead method you write is both safe and idempotent (that is, protects itself from being called multiple times for one HTTP HEAD request).

        If the HTTP HEAD request is incorrectly formatted, doHead returns an HTTP "Bad Request" message.

        Parameters:
        req - the request object that is passed to the servlet
        resp - the response object that the servlet uses to return the headers to the clien
        Throws:
        IOException - if an input or output error occurs
        ServletException - if the request for the HEAD could not be handled

      • doPost

        protected void doPost(HttpServletRequest req,
          HttpServletResponse resp)
               throws ServletException,
                      IOException
        Called by the server (via the service method) to allow a servlet to handle a POST request. The HTTP POST method allows the client to send data of unlimited length to the Web server a single time and is useful when posting information such as credit card numbers.

        When overriding this method, read the request data, write the response headers, get the response's writer or output stream object, and finally, write the response data. It's best to include content type and encoding. When using a PrintWriter object to return the response, set the content type before accessing the PrintWriter object.

        The servlet container must write the headers before committing the response, because in HTTP the headers must be sent before the response body.

        Where possible, set the Content-Length header (with the ServletResponse.setContentLength(int) method), to allow the servlet container to use a persistent connection to return its response to the client, improving performance. The content length is automatically set if the entire response fits inside the response buffer.

        When using HTTP 1.1 chunked encoding (which means that the response has a Transfer-Encoding header), do not set the Content-Length header.

        This method does not need to be either safe or idempotent. Operations requested through POST can have side effects for which the user can be held accountable, for example, updating stored data or buying items online.

        If the HTTP POST request is incorrectly formatted, doPost returns an HTTP "Bad Request" message.

        Parameters:
        req - an HttpServletRequest object that contains the request the client has made of the servlet
        resp - an HttpServletResponse object that contains the response the servlet sends to the client
        Throws:
        IOException - if an input or output error is detected when the servlet handles the request
        ServletException - if the request for the POST could not be handled
        See Also:
        ServletOutputStream, ServletResponse.setContentType(java.lang.String)

      • doPut

        protected void doPut(HttpServletRequest req,
         HttpServletResponse resp)
              throws ServletException,
                     IOException
        Called by the server (via the service method) to allow a servlet to handle a PUT request. The PUT operation allows a client to place a file on the server and is similar to sending a file by FTP.

        When overriding this method, leave intact any content headers sent with the request (including Content-Length, Content-Type, Content-Transfer-Encoding, Content-Encoding, Content-Base, Content-Language, Content-Location, Content-MD5, and Content-Range). If your method cannot handle a content header, it must issue an error message (HTTP 501 - Not Implemented) and discard the request. For more information on HTTP 1.1, see RFC 2616 .

        This method does not need to be either safe or idempotent. Operations that doPut performs can have side effects for which the user can be held accountable. When using this method, it may be useful to save a copy of the affected URL in temporary storage.

        If the HTTP PUT request is incorrectly formatted, doPut returns an HTTP "Bad Request" message.

        Parameters:
        req - the HttpServletRequest object that contains the request the client made of the servlet
        resp - the HttpServletResponse object that contains the response the servlet returns to the client
        Throws:
        IOException - if an input or output error occurs while the servlet is handling the PUT request
        ServletException - if the request for the PUT cannot be handled

      • doDelete

        protected void doDelete(HttpServletRequest req,
            HttpServletResponse resp)
                 throws ServletException,
                        IOException
        Called by the server (via the service method) to allow a servlet to handle a DELETE request. The DELETE operation allows a client to remove a document or Web page from the server.

        This method does not need to be either safe or idempotent. Operations requested through DELETE can have side effects for which users can be held accountable. When using this method, it may be useful to save a copy of the affected URL in temporary storage.

        If the HTTP DELETE request is incorrectly formatted, doDelete returns an HTTP "Bad Request" message.

        Parameters:
        req - the HttpServletRequest object that contains the request the client made of the servlet
        resp - the HttpServletResponse object that contains the response the servlet returns to the client
        Throws:
        IOException - if an input or output error occurs while the servlet is handling the DELETE request
        ServletException - if the request for the DELETE cannot be handled

      • doOptions

        protected void doOptions(HttpServletRequest req,
             HttpServletResponse resp)
                  throws ServletException,
                         IOException
        Called by the server (via the service method) to allow a servlet to handle a OPTIONS request. The OPTIONS request determines which HTTP methods the server supports and returns an appropriate header. For example, if a servlet overrides doGet, this method returns the following header:

        Allow: GET, HEAD, TRACE, OPTIONS

        There's no need to override this method unless the servlet implements new HTTP methods, beyond those implemented by HTTP 1.1.

        Parameters:
        req - the HttpServletRequest object that contains the request the client made of the servlet
        resp - the HttpServletResponse object that contains the response the servlet returns to the client
        Throws:
        IOException - if an input or output error occurs while the servlet is handling the OPTIONS request
        ServletException - if the request for the OPTIONS cannot be handled

      • doTrace

        protected void doTrace(HttpServletRequest req,
           HttpServletResponse resp)
                throws ServletException,
                       IOException
        Called by the server (via the service method) to allow a servlet to handle a TRACE request. A TRACE returns the headers sent with the TRACE request to the client, so that they can be used in debugging. There's no need to override this method.
        Parameters:
        req - the HttpServletRequest object that contains the request the client made of the servlet
        resp - the HttpServletResponse object that contains the response the servlet returns to the client
        Throws:
        IOException - if an input or output error occurs while the servlet is handling the TRACE request
        ServletException - if the request for the TRACE cannot be handled

      • service

        protected void service(HttpServletRequest req,
           HttpServletResponse resp)
                throws ServletException,
                       IOException
        Receives standard HTTP requests from the public service method and dispatches them to the do XXX methods defined in this class. This method is an HTTP-specific version of the Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse) method. There's no need to override this method.
        Parameters:
        req - the HttpServletRequest object that contains the request the client made of the servlet
        resp - the HttpServletResponse object that contains the response the servlet returns to the client
        Throws:
        IOException - if an input or output error occurs while the servlet is handling the HTTP request
        ServletException - if the HTTP request cannot be handled
        See Also:
        Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)

      • service

        public void service(ServletRequest req,
           ServletResponse res)
             throws ServletException,
                    IOException
        Dispatches client requests to the protected service method. There's no need to override this method.
        Specified by:
        service in interface Servlet
        Specified by:
        service in class GenericServlet
        Parameters:
        req - the HttpServletRequest object that contains the request the client made of the servlet
        res - the HttpServletResponse object that contains the response the servlet returns to the client
        Throws:
        IOException - if an input or output error occurs while the servlet is handling the HTTP request
        ServletException - if the HTTP request cannot be handled
        See Also:
        Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpServletRequest (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface HttpServletRequest

  • All Superinterfaces:
    ServletRequest
    All Known Implementing Classes:
    HttpServletRequestWrapper

    public interface HttpServletRequest
extends ServletRequest
    Extends the ServletRequest interface to provide request information for HTTP servlets.

    The servlet container creates an HttpServletRequest object and passes it as an argument to the servlet's service methods (doGet, doPost, etc).

    Author:
    Various

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String BASIC_AUTH
      String identifier for Basic authentication.
      static String CLIENT_CERT_AUTH
      String identifier for Client Certificate authentication.
      static String DIGEST_AUTH
      String identifier for Digest authentication.
      static String FORM_AUTH
      String identifier for Form authentication.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean authenticate(HttpServletResponse response)
      Use the container login mechanism configured for the ServletContext to authenticate the user making this request.
      String changeSessionId()
      Change the session id of the current session associated with this request and return the new session id.
      String getAuthType()
      Returns the name of the authentication scheme used to protect the servlet.
      String getContextPath()
      Returns the portion of the request URI that indicates the context of the request.
      Cookie[] getCookies()
      Returns an array containing all of the Cookie objects the client sent with this request.
      long getDateHeader(String name)
      Returns the value of the specified request header as a long value that represents a Date object.
      String getHeader(String name)
      Returns the value of the specified request header as a String.
      Enumeration<String> getHeaderNames()
      Returns an enumeration of all the header names this request contains.
      Enumeration<String> getHeaders(String name)
      Returns all the values of the specified request header as an Enumeration of String objects.
      int getIntHeader(String name)
      Returns the value of the specified request header as an int.
      String getMethod()
      Returns the name of the HTTP method with which this request was made, for example, GET, POST, or PUT.
      Part getPart(String name)
      Gets the Part with the given name.
      Collection<Part> getParts()
      Gets all the Part components of this request, provided that it is of type multipart/form-data.
      String getPathInfo()
      Returns any extra path information associated with the URL the client sent when it made this request.
      String getPathTranslated()
      Returns any extra path information after the servlet name but before the query string, and translates it to a real path.
      String getQueryString()
      Returns the query string that is contained in the request URL after the path.
      String getRemoteUser()
      Returns the login of the user making this request, if the user has been authenticated, or null if the user has not been authenticated.
      String getRequestedSessionId()
      Returns the session ID specified by the client.
      String getRequestURI()
      Returns the part of this request's URL from the protocol name up to the query string in the first line of the HTTP request.
      StringBuffer getRequestURL()
      Reconstructs the URL the client used to make the request.
      String getServletPath()
      Returns the part of this request's URL that calls the servlet.
      HttpSession getSession()
      Returns the current session associated with this request, or if the request does not have a session, creates one.
      HttpSession getSession(boolean create)
      Returns the current HttpSession associated with this request or, if there is no current session and create is true, returns a new session.
      Principal getUserPrincipal()
      Returns a java.security.Principal object containing the name of the current authenticated user.
      boolean isRequestedSessionIdFromCookie()
      Checks whether the requested session ID came in as a cookie.
      boolean isRequestedSessionIdFromUrl()
      Deprecated.
      As of Version 2.1 of the Java Servlet API, use isRequestedSessionIdFromURL() instead.
      boolean isRequestedSessionIdFromURL()
      Checks whether the requested session ID came in as part of the request URL.
      boolean isRequestedSessionIdValid()
      Checks whether the requested session ID is still valid.
      boolean isUserInRole(String role)
      Returns a boolean indicating whether the authenticated user is included in the specified logical "role".
      void login(String username, String password)
      Validate the provided username and password in the password validation realm used by the web container login mechanism configured for the ServletContext.
      void logout()
      Establish null as the value returned when getUserPrincipal, getRemoteUser, and getAuthType is called on the request.
      <T extends HttpUpgradeHandler>
      T             		upgrade(Class<T> handlerClass)
      Create an instance of HttpUpgradeHandler for an given class and uses it for the http protocol upgrade processing.

      • Methods inherited from interface javax.servlet.ServletRequest

        getAsyncContext, getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentLengthLong, getContentType, getDispatcherType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequestDispatcher, getScheme, getServerName, getServerPort, getServletContext, isAsyncStarted, isAsyncSupported, isSecure, removeAttribute, setAttribute, setCharacterEncoding, startAsync, startAsync

    • Field Detail

      • BASIC_AUTH

        static final String BASIC_AUTH
        String identifier for Basic authentication. Value "BASIC"
        See Also:
        Constant Field Values

      • FORM_AUTH

        static final String FORM_AUTH
        String identifier for Form authentication. Value "FORM"
        See Also:
        Constant Field Values

      • CLIENT_CERT_AUTH

        static final String CLIENT_CERT_AUTH
        String identifier for Client Certificate authentication. Value "CLIENT_CERT"
        See Also:
        Constant Field Values

      • DIGEST_AUTH

        static final String DIGEST_AUTH
        String identifier for Digest authentication. Value "DIGEST"
        See Also:
        Constant Field Values

    • Method Detail

      • getAuthType

        String getAuthType()
        Returns the name of the authentication scheme used to protect the servlet. All servlet containers support basic, form and client certificate authentication, and may additionally support digest authentication. If the servlet is not authenticated null is returned.

        Same as the value of the CGI variable AUTH_TYPE.

        Returns:
        one of the static members BASIC_AUTH, FORM_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH (suitable for == comparison) or the container-specific string indicating the authentication scheme, or null if the request was not authenticated.

      • getCookies

        Cookie[] getCookies()
        Returns an array containing all of the Cookie objects the client sent with this request. This method returns null if no cookies were sent.
        Returns:
        an array of all the Cookies included with this request, or null if the request has no cookies

      • getDateHeader

        long getDateHeader(String name)
        Returns the value of the specified request header as a long value that represents a Date object. Use this method with headers that contain dates, such as If-Modified-Since.

        The date is returned as the number of milliseconds since January 1, 1970 GMT. The header name is case insensitive.

        If the request did not have a header of the specified name, this method returns -1. If the header can't be converted to a date, the method throws an IllegalArgumentException.

        Parameters:
        name - a String specifying the name of the header
        Returns:
        a long value representing the date specified in the header expressed as the number of milliseconds since January 1, 1970 GMT, or -1 if the named header was not included with the request
        Throws:
        IllegalArgumentException - If the header value can't be converted to a date

      • getHeader

        String getHeader(String name)
        Returns the value of the specified request header as a String. If the request did not include a header of the specified name, this method returns null. If there are multiple headers with the same name, this method returns the first head in the request. The header name is case insensitive. You can use this method with any request header.
        Parameters:
        name - a String specifying the header name
        Returns:
        a String containing the value of the requested header, or null if the request does not have a header of that name

      • getHeaders

        Enumeration<String> getHeaders(String name)
        Returns all the values of the specified request header as an Enumeration of String objects.

        Some headers, such as Accept-Language can be sent by clients as several headers each with a different value rather than sending the header as a comma separated list.

        If the request did not include any headers of the specified name, this method returns an empty Enumeration. The header name is case insensitive. You can use this method with any request header.

        Parameters:
        name - a String specifying the header name
        Returns:
        an Enumeration containing the values of the requested header. If the request does not have any headers of that name return an empty enumeration. If the container does not allow access to header information, return null

      • getHeaderNames

        Enumeration<String> getHeaderNames()
        Returns an enumeration of all the header names this request contains. If the request has no headers, this method returns an empty enumeration.

        Some servlet containers do not allow servlets to access headers using this method, in which case this method returns null

        Returns:
        an enumeration of all the header names sent with this request; if the request has no headers, an empty enumeration; if the servlet container does not allow servlets to use this method, null

      • getIntHeader

        int getIntHeader(String name)
        Returns the value of the specified request header as an int. If the request does not have a header of the specified name, this method returns -1. If the header cannot be converted to an integer, this method throws a NumberFormatException.

        The header name is case insensitive.

        Parameters:
        name - a String specifying the name of a request header
        Returns:
        an integer expressing the value of the request header or -1 if the request doesn't have a header of this name
        Throws:
        NumberFormatException - If the header value can't be converted to an int

      • getMethod

        String getMethod()
        Returns the name of the HTTP method with which this request was made, for example, GET, POST, or PUT. Same as the value of the CGI variable REQUEST_METHOD.
        Returns:
        a String specifying the name of the method with which this request was made

      • getPathInfo

        String getPathInfo()
        Returns any extra path information associated with the URL the client sent when it made this request. The extra path information follows the servlet path but precedes the query string and will start with a "/" character.

        This method returns null if there was no extra path information.

        Same as the value of the CGI variable PATH_INFO.

        Returns:
        a String, decoded by the web container, specifying extra path information that comes after the servlet path but before the query string in the request URL; or null if the URL does not have any extra path information

      • getPathTranslated

        String getPathTranslated()
        Returns any extra path information after the servlet name but before the query string, and translates it to a real path. Same as the value of the CGI variable PATH_TRANSLATED.

        If the URL does not have any extra path information, this method returns null or the servlet container cannot translate the virtual path to a real path for any reason (such as when the web application is executed from an archive). The web container does not decode this string.

        Returns:
        a String specifying the real path, or null if the URL does not have any extra path information

      • getContextPath

        String getContextPath()
        Returns the portion of the request URI that indicates the context of the request. The context path always comes first in a request URI. The path starts with a "/" character but does not end with a "/" character. For servlets in the default (root) context, this method returns "". The container does not decode this string.

        It is possible that a servlet container may match a context by more than one context path. In such cases this method will return the actual context path used by the request and it may differ from the path returned by the ServletContext.getContextPath() method. The context path returned by ServletContext.getContextPath() should be considered as the prime or preferred context path of the application.

        Returns:
        a String specifying the portion of the request URI that indicates the context of the request
        See Also:
        ServletContext.getContextPath()

      • getQueryString

        String getQueryString()
        Returns the query string that is contained in the request URL after the path. This method returns null if the URL does not have a query string. Same as the value of the CGI variable QUERY_STRING.
        Returns:
        a String containing the query string or null if the URL contains no query string. The value is not decoded by the container.

      • getRemoteUser

        String getRemoteUser()
        Returns the login of the user making this request, if the user has been authenticated, or null if the user has not been authenticated. Whether the user name is sent with each subsequent request depends on the browser and type of authentication. Same as the value of the CGI variable REMOTE_USER.
        Returns:
        a String specifying the login of the user making this request, or null if the user login is not known

      • isUserInRole

        boolean isUserInRole(String role)
        Returns a boolean indicating whether the authenticated user is included in the specified logical "role". Roles and role membership can be defined using deployment descriptors. If the user has not been authenticated, the method returns false.

        The role name “*” should never be used as an argument in calling isUserInRole. Any call to isUserInRole with “*” must return false. If the role-name of the security-role to be tested is “**”, and the application has NOT declared an application security-role with role-name “**”, isUserInRole must only return true if the user has been authenticated; that is, only when getRemoteUser() and getUserPrincipal() would both return a non-null value. Otherwise, the container must check the user for membership in the application role.

        Parameters:
        role - a String specifying the name of the role
        Returns:
        a boolean indicating whether the user making this request belongs to a given role; false if the user has not been authenticated

      • getUserPrincipal

        Principal getUserPrincipal()
        Returns a java.security.Principal object containing the name of the current authenticated user. If the user has not been authenticated, the method returns null.
        Returns:
        a java.security.Principal containing the name of the user making this request; null if the user has not been authenticated

      • getRequestedSessionId

        String getRequestedSessionId()
        Returns the session ID specified by the client. This may not be the same as the ID of the current valid session for this request. If the client did not specify a session ID, this method returns null.
        Returns:
        a String specifying the session ID, or null if the request did not specify a session ID
        See Also:
        isRequestedSessionIdValid()

      • getRequestURI

        String getRequestURI()
        Returns the part of this request's URL from the protocol name up to the query string in the first line of the HTTP request. The web container does not decode this String. For example:
        First line of HTTP request | Returned Value
        POST /some/path.html HTTP/1.1 | /some/path.html
        GET http://foo.bar/a.html HTTP/1.0 | /a.html
        HEAD /xyz?a=b HTTP/1.1 | /xyz

        To reconstruct an URL with a scheme and host, use HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest).

        Returns:
        a String containing the part of the URL from the protocol name up to the query string
        See Also:
        HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest)

      • getRequestURL

        StringBuffer getRequestURL()
        Reconstructs the URL the client used to make the request. The returned URL contains a protocol, server name, port number, and server path, but it does not include query string parameters.

        If this request has been forwarded using RequestDispatcher.forward(javax.servlet.ServletRequest, javax.servlet.ServletResponse), the server path in the reconstructed URL must reflect the path used to obtain the RequestDispatcher, and not the server path specified by the client.

        Because this method returns a StringBuffer, not a string, you can modify the URL easily, for example, to append query parameters.

        This method is useful for creating redirect messages and for reporting errors.

        Returns:
        a StringBuffer object containing the reconstructed URL

      • getServletPath

        String getServletPath()
        Returns the part of this request's URL that calls the servlet. This path starts with a "/" character and includes either the servlet name or a path to the servlet, but does not include any extra path information or a query string. Same as the value of the CGI variable SCRIPT_NAME.

        This method will return an empty string ("") if the servlet used to process this request was matched using the "/*" pattern.

        Returns:
        a String containing the name or path of the servlet being called, as specified in the request URL, decoded, or an empty string if the servlet used to process the request is matched using the "/*" pattern.

      • getSession

        HttpSession getSession(boolean create)
        Returns the current HttpSession associated with this request or, if there is no current session and create is true, returns a new session.

        If create is false and the request has no valid HttpSession, this method returns null.

        To make sure the session is properly maintained, you must call this method before the response is committed. If the container is using cookies to maintain session integrity and is asked to create a new session when the response is committed, an IllegalStateException is thrown.

        Parameters:
        create - true to create a new session for this request if necessary; false to return null if there's no current session
        Returns:
        the HttpSession associated with this request or null if create is false and the request has no valid session
        See Also:
        getSession()

      • getSession

        HttpSession getSession()
        Returns the current session associated with this request, or if the request does not have a session, creates one.
        Returns:
        the HttpSession associated with this request
        See Also:
        getSession(boolean)

      • changeSessionId

        String changeSessionId()
        Change the session id of the current session associated with this request and return the new session id.
        Returns:
        the new session id
        Throws:
        IllegalStateException - if there is no session associated with the request
        Since:
        Servlet 3.1

      • isRequestedSessionIdValid

        boolean isRequestedSessionIdValid()
        Checks whether the requested session ID is still valid.

        If the client did not specify any session ID, this method returns false.

        Returns:
        true if this request has an id for a valid session in the current session context; false otherwise
        See Also:
        getRequestedSessionId(), getSession(boolean), HttpSessionContext

      • isRequestedSessionIdFromCookie

        boolean isRequestedSessionIdFromCookie()
        Checks whether the requested session ID came in as a cookie.
        Returns:
        true if the session ID came in as a cookie; otherwise, false
        See Also:
        getSession(boolean)

      • isRequestedSessionIdFromURL

        boolean isRequestedSessionIdFromURL()
        Checks whether the requested session ID came in as part of the request URL.
        Returns:
        true if the session ID came in as part of a URL; otherwise, false
        See Also:
        getSession(boolean)

      • isRequestedSessionIdFromUrl

        boolean isRequestedSessionIdFromUrl()
        Deprecated. As of Version 2.1 of the Java Servlet API, use isRequestedSessionIdFromURL() instead.

      • authenticate

        boolean authenticate(HttpServletResponse response)
                     throws IOException,
                            ServletException
        Use the container login mechanism configured for the ServletContext to authenticate the user making this request.

        This method may modify and commit the argument HttpServletResponse.

        Parameters:
        response - The HttpServletResponse associated with this HttpServletRequest
        Returns:
        true when non-null values were or have been established as the values returned by getUserPrincipal, getRemoteUser, and getAuthType. Return false if authentication is incomplete and the underlying login mechanism has committed, in the response, the message (e.g., challenge) and HTTP status code to be returned to the user.
        Throws:
        IOException - if an input or output error occurred while reading from this request or writing to the given response
        IllegalStateException - if the login mechanism attempted to modify the response and it was already committed
        ServletException - if the authentication failed and the caller is responsible for handling the error (i.e., the underlying login mechanism did NOT establish the message and HTTP status code to be returned to the user)
        Since:
        Servlet 3.0

      • login

        void login(String username,
         String password)
           throws ServletException
        Validate the provided username and password in the password validation realm used by the web container login mechanism configured for the ServletContext.

        This method returns without throwing a ServletException when the login mechanism configured for the ServletContext supports username password validation, and when, at the time of the call to login, the identity of the caller of the request had not been established (i.e, all of getUserPrincipal, getRemoteUser, and getAuthType return null), and when validation of the provided credentials is successful. Otherwise, this method throws a ServletException as described below.

        When this method returns without throwing an exception, it must have established non-null values as the values returned by getUserPrincipal, getRemoteUser, and getAuthType.

        Parameters:
        username - The String value corresponding to the login identifier of the user.
        password - The password String corresponding to the identified user.
        Throws:
        ServletException - if the configured login mechanism does not support username password authentication, or if a non-null caller identity had already been established (prior to the call to login), or if validation of the provided username and password fails.
        Since:
        Servlet 3.0

      • logout

        void logout()
            throws ServletException
        Establish null as the value returned when getUserPrincipal, getRemoteUser, and getAuthType is called on the request.
        Throws:
        ServletException - if logout fails
        Since:
        Servlet 3.0

      • getParts

        Collection<Part> getParts()
                          throws IOException,
                                 ServletException
        Gets all the Part components of this request, provided that it is of type multipart/form-data.

        If this request is of type multipart/form-data, but does not contain any Part components, the returned Collection will be empty.

        Any changes to the returned Collection must not affect this HttpServletRequest.

        Returns:
        a (possibly empty) Collection of the Part components of this request
        Throws:
        IOException - if an I/O error occurred during the retrieval of the Part components of this request
        ServletException - if this request is not of type multipart/form-data
        IllegalStateException - if the request body is larger than maxRequestSize, or any Part in the request is larger than maxFileSize, or there is no @MultipartConfig or multipart-config in deployment descriptors
        Since:
        Servlet 3.0
        See Also:
        MultipartConfig.maxFileSize(), MultipartConfig.maxRequestSize()

      • getPart

        Part getPart(String name)
             throws IOException,
                    ServletException
        Gets the Part with the given name.
        Parameters:
        name - the name of the requested Part
        Returns:
        The Part with the given name, or null if this request is of type multipart/form-data, but does not contain the requested Part
        Throws:
        IOException - if an I/O error occurred during the retrieval of the requested Part
        ServletException - if this request is not of type multipart/form-data
        IllegalStateException - if the request body is larger than maxRequestSize, or any Part in the request is larger than maxFileSize, or there is no @MultipartConfig or multipart-config in deployment descriptors
        Since:
        Servlet 3.0
        See Also:
        MultipartConfig.maxFileSize(), MultipartConfig.maxRequestSize()

      • upgrade

        <T extends HttpUpgradeHandler> T upgrade(Class<T> handlerClass)
                                     throws IOException,
                                            ServletException
        Create an instance of HttpUpgradeHandler for an given class and uses it for the http protocol upgrade processing.
        Parameters:
        handlerClass - The HttpUpgradeHandler class used for the upgrade.
        Returns:
        an instance of the HttpUpgradeHandler
        Throws:
        IOException - if an I/O error occurred during the upgrade
        ServletException - if the given handlerClass fails to be instantiated
        Since:
        Servlet 3.1
        See Also:
        HttpUpgradeHandler, WebConnection
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpServletRequestWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Class HttpServletRequestWrapper

  • java.lang.Object
    • javax.servlet.ServletRequestWrapper
      • javax.servlet.http.HttpServletRequestWrapper
  • All Implemented Interfaces:
    HttpServletRequest, ServletRequest

    public class HttpServletRequestWrapper
extends ServletRequestWrapper
implements HttpServletRequest
    Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.

    This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped request object.

    Since:
    Servlet 2.3
    See Also:
    HttpServletRequest

    • Field Summary

      • Fields inherited from interface javax.servlet.http.HttpServletRequest

        BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpServletRequestWrapper(HttpServletRequest request)
      Constructs a request object wrapping the given request.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean authenticate(HttpServletResponse response)
      The default behavior of this method is to call authenticate on the wrapped request object.
      String changeSessionId()
      The default behavior of this method is to return changeSessionId() on the wrapped request object.
      String getAuthType()
      The default behavior of this method is to return getAuthType() on the wrapped request object.
      String getContextPath()
      The default behavior of this method is to return getContextPath() on the wrapped request object.
      Cookie[] getCookies()
      The default behavior of this method is to return getCookies() on the wrapped request object.
      long getDateHeader(String name)
      The default behavior of this method is to return getDateHeader(String name) on the wrapped request object.
      String getHeader(String name)
      The default behavior of this method is to return getHeader(String name) on the wrapped request object.
      Enumeration<String> getHeaderNames()
      The default behavior of this method is to return getHeaderNames() on the wrapped request object.
      Enumeration<String> getHeaders(String name)
      The default behavior of this method is to return getHeaders(String name) on the wrapped request object.
      int getIntHeader(String name)
      The default behavior of this method is to return getIntHeader(String name) on the wrapped request object.
      String getMethod()
      The default behavior of this method is to return getMethod() on the wrapped request object.
      Part getPart(String name)
      The default behavior of this method is to call getPart on the wrapped request object.
      Collection<Part> getParts()
      The default behavior of this method is to call getParts on the wrapped request object.
      String getPathInfo()
      The default behavior of this method is to return getPathInfo() on the wrapped request object.
      String getPathTranslated()
      The default behavior of this method is to return getPathTranslated() on the wrapped request object.
      String getQueryString()
      The default behavior of this method is to return getQueryString() on the wrapped request object.
      String getRemoteUser()
      The default behavior of this method is to return getRemoteUser() on the wrapped request object.
      String getRequestedSessionId()
      The default behavior of this method is to return getRequestedSessionId() on the wrapped request object.
      String getRequestURI()
      The default behavior of this method is to return getRequestURI() on the wrapped request object.
      StringBuffer getRequestURL()
      The default behavior of this method is to return getRequestURL() on the wrapped request object.
      String getServletPath()
      The default behavior of this method is to return getServletPath() on the wrapped request object.
      HttpSession getSession()
      The default behavior of this method is to return getSession() on the wrapped request object.
      HttpSession getSession(boolean create)
      The default behavior of this method is to return getSession(boolean create) on the wrapped request object.
      Principal getUserPrincipal()
      The default behavior of this method is to return getUserPrincipal() on the wrapped request object.
      boolean isRequestedSessionIdFromCookie()
      The default behavior of this method is to return isRequestedSessionIdFromCookie() on the wrapped request object.
      boolean isRequestedSessionIdFromUrl()
      The default behavior of this method is to return isRequestedSessionIdFromUrl() on the wrapped request object.
      boolean isRequestedSessionIdFromURL()
      The default behavior of this method is to return isRequestedSessionIdFromURL() on the wrapped request object.
      boolean isRequestedSessionIdValid()
      The default behavior of this method is to return isRequestedSessionIdValid() on the wrapped request object.
      boolean isUserInRole(String role)
      The default behavior of this method is to return isUserInRole(String role) on the wrapped request object.
      void login(String username, String password)
      The default behavior of this method is to call login on the wrapped request object.
      void logout()
      The default behavior of this method is to call login on the wrapped request object.
      <T extends HttpUpgradeHandler>
      T             		upgrade(Class<T> handlerClass)
      Create an instance of HttpUpgradeHandler for an given class and uses it for the http protocol upgrade processing.

      • Methods inherited from class javax.servlet.ServletRequestWrapper

        getAsyncContext, getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentLengthLong, getContentType, getDispatcherType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequest, getRequestDispatcher, getScheme, getServerName, getServerPort, getServletContext, isAsyncStarted, isAsyncSupported, isSecure, isWrapperFor, isWrapperFor, removeAttribute, setAttribute, setCharacterEncoding, setRequest, startAsync, startAsync

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.servlet.ServletRequest

        getAsyncContext, getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentLengthLong, getContentType, getDispatcherType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequestDispatcher, getScheme, getServerName, getServerPort, getServletContext, isAsyncStarted, isAsyncSupported, isSecure, removeAttribute, setAttribute, setCharacterEncoding, startAsync, startAsync

    • Constructor Detail

      • HttpServletRequestWrapper

        public HttpServletRequestWrapper(HttpServletRequest request)
        Constructs a request object wrapping the given request.
        Throws:
        IllegalArgumentException - if the request is null

    • Method Detail

      • getAuthType

        public String getAuthType()
        The default behavior of this method is to return getAuthType() on the wrapped request object.
        Specified by:
        getAuthType in interface HttpServletRequest
        Returns:
        one of the static members BASIC_AUTH, FORM_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH (suitable for == comparison) or the container-specific string indicating the authentication scheme, or null if the request was not authenticated.

      • getCookies

        public Cookie[] getCookies()
        The default behavior of this method is to return getCookies() on the wrapped request object.
        Specified by:
        getCookies in interface HttpServletRequest
        Returns:
        an array of all the Cookies included with this request, or null if the request has no cookies

      • getDateHeader

        public long getDateHeader(String name)
        The default behavior of this method is to return getDateHeader(String name) on the wrapped request object.
        Specified by:
        getDateHeader in interface HttpServletRequest
        Parameters:
        name - a String specifying the name of the header
        Returns:
        a long value representing the date specified in the header expressed as the number of milliseconds since January 1, 1970 GMT, or -1 if the named header was not included with the request

      • getHeader

        public String getHeader(String name)
        The default behavior of this method is to return getHeader(String name) on the wrapped request object.
        Specified by:
        getHeader in interface HttpServletRequest
        Parameters:
        name - a String specifying the header name
        Returns:
        a String containing the value of the requested header, or null if the request does not have a header of that name

      • getHeaders

        public Enumeration<String> getHeaders(String name)
        The default behavior of this method is to return getHeaders(String name) on the wrapped request object.
        Specified by:
        getHeaders in interface HttpServletRequest
        Parameters:
        name - a String specifying the header name
        Returns:
        an Enumeration containing the values of the requested header. If the request does not have any headers of that name return an empty enumeration. If the container does not allow access to header information, return null

      • getHeaderNames

        public Enumeration<String> getHeaderNames()
        The default behavior of this method is to return getHeaderNames() on the wrapped request object.
        Specified by:
        getHeaderNames in interface HttpServletRequest
        Returns:
        an enumeration of all the header names sent with this request; if the request has no headers, an empty enumeration; if the servlet container does not allow servlets to use this method, null

      • getIntHeader

        public int getIntHeader(String name)
        The default behavior of this method is to return getIntHeader(String name) on the wrapped request object.
        Specified by:
        getIntHeader in interface HttpServletRequest
        Parameters:
        name - a String specifying the name of a request header
        Returns:
        an integer expressing the value of the request header or -1 if the request doesn't have a header of this name

      • getMethod

        public String getMethod()
        The default behavior of this method is to return getMethod() on the wrapped request object.
        Specified by:
        getMethod in interface HttpServletRequest
        Returns:
        a String specifying the name of the method with which this request was made

      • getPathInfo

        public String getPathInfo()
        The default behavior of this method is to return getPathInfo() on the wrapped request object.
        Specified by:
        getPathInfo in interface HttpServletRequest
        Returns:
        a String, decoded by the web container, specifying extra path information that comes after the servlet path but before the query string in the request URL; or null if the URL does not have any extra path information

      • getPathTranslated

        public String getPathTranslated()
        The default behavior of this method is to return getPathTranslated() on the wrapped request object.
        Specified by:
        getPathTranslated in interface HttpServletRequest
        Returns:
        a String specifying the real path, or null if the URL does not have any extra path information

      • getContextPath

        public String getContextPath()
        The default behavior of this method is to return getContextPath() on the wrapped request object.
        Specified by:
        getContextPath in interface HttpServletRequest
        Returns:
        a String specifying the portion of the request URI that indicates the context of the request
        See Also:
        ServletContext.getContextPath()

      • getQueryString

        public String getQueryString()
        The default behavior of this method is to return getQueryString() on the wrapped request object.
        Specified by:
        getQueryString in interface HttpServletRequest
        Returns:
        a String containing the query string or null if the URL contains no query string. The value is not decoded by the container.

      • getRemoteUser

        public String getRemoteUser()
        The default behavior of this method is to return getRemoteUser() on the wrapped request object.
        Specified by:
        getRemoteUser in interface HttpServletRequest
        Returns:
        a String specifying the login of the user making this request, or null if the user login is not known

      • isUserInRole

        public boolean isUserInRole(String role)
        The default behavior of this method is to return isUserInRole(String role) on the wrapped request object.
        Specified by:
        isUserInRole in interface HttpServletRequest
        Parameters:
        role - a String specifying the name of the role
        Returns:
        a boolean indicating whether the user making this request belongs to a given role; false if the user has not been authenticated

      • getUserPrincipal

        public Principal getUserPrincipal()
        The default behavior of this method is to return getUserPrincipal() on the wrapped request object.
        Specified by:
        getUserPrincipal in interface HttpServletRequest
        Returns:
        a java.security.Principal containing the name of the user making this request; null if the user has not been authenticated

      • getRequestedSessionId

        public String getRequestedSessionId()
        The default behavior of this method is to return getRequestedSessionId() on the wrapped request object.
        Specified by:
        getRequestedSessionId in interface HttpServletRequest
        Returns:
        a String specifying the session ID, or null if the request did not specify a session ID
        See Also:
        HttpServletRequest.isRequestedSessionIdValid()

      • getRequestURI

        public String getRequestURI()
        The default behavior of this method is to return getRequestURI() on the wrapped request object.
        Specified by:
        getRequestURI in interface HttpServletRequest
        Returns:
        a String containing the part of the URL from the protocol name up to the query string
        See Also:
        HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest)

      • getRequestURL

        public StringBuffer getRequestURL()
        The default behavior of this method is to return getRequestURL() on the wrapped request object.
        Specified by:
        getRequestURL in interface HttpServletRequest
        Returns:
        a StringBuffer object containing the reconstructed URL

      • getServletPath

        public String getServletPath()
        The default behavior of this method is to return getServletPath() on the wrapped request object.
        Specified by:
        getServletPath in interface HttpServletRequest
        Returns:
        a String containing the name or path of the servlet being called, as specified in the request URL, decoded, or an empty string if the servlet used to process the request is matched using the "/*" pattern.

      • getSession

        public HttpSession getSession(boolean create)
        The default behavior of this method is to return getSession(boolean create) on the wrapped request object.
        Specified by:
        getSession in interface HttpServletRequest
        Parameters:
        create - true to create a new session for this request if necessary; false to return null if there's no current session
        Returns:
        the HttpSession associated with this request or null if create is false and the request has no valid session
        See Also:
        HttpServletRequest.getSession()

      • getSession

        public HttpSession getSession()
        The default behavior of this method is to return getSession() on the wrapped request object.
        Specified by:
        getSession in interface HttpServletRequest
        Returns:
        the HttpSession associated with this request
        See Also:
        HttpServletRequest.getSession(boolean)

      • changeSessionId

        public String changeSessionId()
        The default behavior of this method is to return changeSessionId() on the wrapped request object.
        Specified by:
        changeSessionId in interface HttpServletRequest
        Returns:
        the new session id
        Since:
        Servlet 3.1

      • isRequestedSessionIdValid

        public boolean isRequestedSessionIdValid()
        The default behavior of this method is to return isRequestedSessionIdValid() on the wrapped request object.
        Specified by:
        isRequestedSessionIdValid in interface HttpServletRequest
        Returns:
        true if this request has an id for a valid session in the current session context; false otherwise
        See Also:
        HttpServletRequest.getRequestedSessionId(), HttpServletRequest.getSession(boolean), HttpSessionContext

      • isRequestedSessionIdFromCookie

        public boolean isRequestedSessionIdFromCookie()
        The default behavior of this method is to return isRequestedSessionIdFromCookie() on the wrapped request object.
        Specified by:
        isRequestedSessionIdFromCookie in interface HttpServletRequest
        Returns:
        true if the session ID came in as a cookie; otherwise, false
        See Also:
        HttpServletRequest.getSession(boolean)

      • isRequestedSessionIdFromURL

        public boolean isRequestedSessionIdFromURL()
        The default behavior of this method is to return isRequestedSessionIdFromURL() on the wrapped request object.
        Specified by:
        isRequestedSessionIdFromURL in interface HttpServletRequest
        Returns:
        true if the session ID came in as part of a URL; otherwise, false
        See Also:
        HttpServletRequest.getSession(boolean)

      • isRequestedSessionIdFromUrl

        public boolean isRequestedSessionIdFromUrl()
        The default behavior of this method is to return isRequestedSessionIdFromUrl() on the wrapped request object.
        Specified by:
        isRequestedSessionIdFromUrl in interface HttpServletRequest

      • authenticate

        public boolean authenticate(HttpServletResponse response)
                     throws IOException,
                            ServletException
        The default behavior of this method is to call authenticate on the wrapped request object.
        Specified by:
        authenticate in interface HttpServletRequest
        Parameters:
        response - The HttpServletResponse associated with this HttpServletRequest
        Returns:
        true when non-null values were or have been established as the values returned by getUserPrincipal, getRemoteUser, and getAuthType. Return false if authentication is incomplete and the underlying login mechanism has committed, in the response, the message (e.g., challenge) and HTTP status code to be returned to the user.
        Throws:
        IOException - if an input or output error occurred while reading from this request or writing to the given response
        ServletException - if the authentication failed and the caller is responsible for handling the error (i.e., the underlying login mechanism did NOT establish the message and HTTP status code to be returned to the user)
        Since:
        Servlet 3.0

      • login

        public void login(String username,
         String password)
           throws ServletException
        The default behavior of this method is to call login on the wrapped request object.
        Specified by:
        login in interface HttpServletRequest
        Parameters:
        username - The String value corresponding to the login identifier of the user.
        password - The password String corresponding to the identified user.
        Throws:
        ServletException - if the configured login mechanism does not support username password authentication, or if a non-null caller identity had already been established (prior to the call to login), or if validation of the provided username and password fails.
        Since:
        Servlet 3.0

      • logout

        public void logout()
            throws ServletException
        The default behavior of this method is to call login on the wrapped request object.
        Specified by:
        logout in interface HttpServletRequest
        Throws:
        ServletException - if logout fails
        Since:
        Servlet 3.0

      • getParts

        public Collection<Part> getParts()
                          throws IOException,
                                 ServletException
        The default behavior of this method is to call getParts on the wrapped request object.

        Any changes to the returned Collection must not affect this HttpServletRequestWrapper.

        Specified by:
        getParts in interface HttpServletRequest
        Returns:
        a (possibly empty) Collection of the Part components of this request
        Throws:
        IOException - if an I/O error occurred during the retrieval of the Part components of this request
        ServletException - if this request is not of type multipart/form-data
        Since:
        Servlet 3.0
        See Also:
        MultipartConfig.maxFileSize(), MultipartConfig.maxRequestSize()

      • getPart

        public Part getPart(String name)
             throws IOException,
                    ServletException
        The default behavior of this method is to call getPart on the wrapped request object.
        Specified by:
        getPart in interface HttpServletRequest
        Parameters:
        name - the name of the requested Part
        Returns:
        The Part with the given name, or null if this request is of type multipart/form-data, but does not contain the requested Part
        Throws:
        IOException - if an I/O error occurred during the retrieval of the requested Part
        ServletException - if this request is not of type multipart/form-data
        Since:
        Servlet 3.0
        See Also:
        MultipartConfig.maxFileSize(), MultipartConfig.maxRequestSize()

      • upgrade

        public <T extends HttpUpgradeHandler> T upgrade(Class<T> handlerClass)
                                     throws IOException,
                                            ServletException
        Create an instance of HttpUpgradeHandler for an given class and uses it for the http protocol upgrade processing.
        Specified by:
        upgrade in interface HttpServletRequest
        Parameters:
        handlerClass - The HttpUpgradeHandler class used for the upgrade.
        Returns:
        an instance of the HttpUpgradeHandler
        Throws:
        IOException - if an I/O error occurred during the upgrade
        ServletException - if the given handlerClass fails to be instantiated
        Since:
        Servlet 3.1
        See Also:
        HttpUpgradeHandler, WebConnection
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpServletResponse (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface HttpServletResponse

  • All Superinterfaces:
    ServletResponse
    All Known Implementing Classes:
    HttpServletResponseWrapper

    public interface HttpServletResponse
extends ServletResponse
    Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response. For example, it has methods to access HTTP headers and cookies.

    The servlet container creates an HttpServletResponse object and passes it as an argument to the servlet's service methods (doGet, doPost, etc).

    Author:
    Various
    See Also:
    ServletResponse

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int SC_ACCEPTED
      Status code (202) indicating that a request was accepted for processing, but was not completed.
      static int SC_BAD_GATEWAY
      Status code (502) indicating that the HTTP server received an invalid response from a server it consulted when acting as a proxy or gateway.
      static int SC_BAD_REQUEST
      Status code (400) indicating the request sent by the client was syntactically incorrect.
      static int SC_CONFLICT
      Status code (409) indicating that the request could not be completed due to a conflict with the current state of the resource.
      static int SC_CONTINUE
      Status code (100) indicating the client can continue.
      static int SC_CREATED
      Status code (201) indicating the request succeeded and created a new resource on the server.
      static int SC_EXPECTATION_FAILED
      Status code (417) indicating that the server could not meet the expectation given in the Expect request header.
      static int SC_FORBIDDEN
      Status code (403) indicating the server understood the request but refused to fulfill it.
      static int SC_FOUND
      Status code (302) indicating that the resource reside temporarily under a different URI.
      static int SC_GATEWAY_TIMEOUT
      Status code (504) indicating that the server did not receive a timely response from the upstream server while acting as a gateway or proxy.
      static int SC_GONE
      Status code (410) indicating that the resource is no longer available at the server and no forwarding address is known.
      static int SC_HTTP_VERSION_NOT_SUPPORTED
      Status code (505) indicating that the server does not support or refuses to support the HTTP protocol version that was used in the request message.
      static int SC_INTERNAL_SERVER_ERROR
      Status code (500) indicating an error inside the HTTP server which prevented it from fulfilling the request.
      static int SC_LENGTH_REQUIRED
      Status code (411) indicating that the request cannot be handled without a defined Content-Length.
      static int SC_METHOD_NOT_ALLOWED
      Status code (405) indicating that the method specified in the Request-Line is not allowed for the resource identified by the Request-URI.
      static int SC_MOVED_PERMANENTLY
      Status code (301) indicating that the resource has permanently moved to a new location, and that future references should use a new URI with their requests.
      static int SC_MOVED_TEMPORARILY
      Status code (302) indicating that the resource has temporarily moved to another location, but that future references should still use the original URI to access the resource.
      static int SC_MULTIPLE_CHOICES
      Status code (300) indicating that the requested resource corresponds to any one of a set of representations, each with its own specific location.
      static int SC_NO_CONTENT
      Status code (204) indicating that the request succeeded but that there was no new information to return.
      static int SC_NON_AUTHORITATIVE_INFORMATION
      Status code (203) indicating that the meta information presented by the client did not originate from the server.
      static int SC_NOT_ACCEPTABLE
      Status code (406) indicating that the resource identified by the request is only capable of generating response entities which have content characteristics not acceptable according to the accept headers sent in the request.
      static int SC_NOT_FOUND
      Status code (404) indicating that the requested resource is not available.
      static int SC_NOT_IMPLEMENTED
      Status code (501) indicating the HTTP server does not support the functionality needed to fulfill the request.
      static int SC_NOT_MODIFIED
      Status code (304) indicating that a conditional GET operation found that the resource was available and not modified.
      static int SC_OK
      Status code (200) indicating the request succeeded normally.
      static int SC_PARTIAL_CONTENT
      Status code (206) indicating that the server has fulfilled the partial GET request for the resource.
      static int SC_PAYMENT_REQUIRED
      Status code (402) reserved for future use.
      static int SC_PRECONDITION_FAILED
      Status code (412) indicating that the precondition given in one or more of the request-header fields evaluated to false when it was tested on the server.
      static int SC_PROXY_AUTHENTICATION_REQUIRED
      Status code (407) indicating that the client MUST first authenticate itself with the proxy.
      static int SC_REQUEST_ENTITY_TOO_LARGE
      Status code (413) indicating that the server is refusing to process the request because the request entity is larger than the server is willing or able to process.
      static int SC_REQUEST_TIMEOUT
      Status code (408) indicating that the client did not produce a request within the time that the server was prepared to wait.
      static int SC_REQUEST_URI_TOO_LONG
      Status code (414) indicating that the server is refusing to service the request because the Request-URI is longer than the server is willing to interpret.
      static int SC_REQUESTED_RANGE_NOT_SATISFIABLE
      Status code (416) indicating that the server cannot serve the requested byte range.
      static int SC_RESET_CONTENT
      Status code (205) indicating that the agent SHOULD reset the document view which caused the request to be sent.
      static int SC_SEE_OTHER
      Status code (303) indicating that the response to the request can be found under a different URI.
      static int SC_SERVICE_UNAVAILABLE
      Status code (503) indicating that the HTTP server is temporarily overloaded, and unable to handle the request.
      static int SC_SWITCHING_PROTOCOLS
      Status code (101) indicating the server is switching protocols according to Upgrade header.
      static int SC_TEMPORARY_REDIRECT
      Status code (307) indicating that the requested resource resides temporarily under a different URI.
      static int SC_UNAUTHORIZED
      Status code (401) indicating that the request requires HTTP authentication.
      static int SC_UNSUPPORTED_MEDIA_TYPE
      Status code (415) indicating that the server is refusing to service the request because the entity of the request is in a format not supported by the requested resource for the requested method.
      static int SC_USE_PROXY
      Status code (305) indicating that the requested resource MUST be accessed through the proxy given by the Location field.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addCookie(Cookie cookie)
      Adds the specified cookie to the response.
      void addDateHeader(String name, long date)
      Adds a response header with the given name and date-value.
      void addHeader(String name, String value)
      Adds a response header with the given name and value.
      void addIntHeader(String name, int value)
      Adds a response header with the given name and integer value.
      boolean containsHeader(String name)
      Returns a boolean indicating whether the named response header has already been set.
      String encodeRedirectUrl(String url)
      Deprecated.
      As of version 2.1, use encodeRedirectURL(String url) instead
      String encodeRedirectURL(String url)
      Encodes the specified URL for use in the sendRedirect method or, if encoding is not needed, returns the URL unchanged.
      String encodeUrl(String url)
      Deprecated.
      As of version 2.1, use encodeURL(String url) instead
      String encodeURL(String url)
      Encodes the specified URL by including the session ID, or, if encoding is not needed, returns the URL unchanged.
      String getHeader(String name)
      Gets the value of the response header with the given name.
      Collection<String> getHeaderNames()
      Gets the names of the headers of this response.
      Collection<String> getHeaders(String name)
      Gets the values of the response header with the given name.
      int getStatus()
      Gets the current status code of this response.
      void sendError(int sc)
      Sends an error response to the client using the specified status code and clears the buffer.
      void sendError(int sc, String msg)
      Sends an error response to the client using the specified status and clears the buffer.
      void sendRedirect(String location)
      Sends a temporary redirect response to the client using the specified redirect location URL and clears the buffer.
      void setDateHeader(String name, long date)
      Sets a response header with the given name and date-value.
      void setHeader(String name, String value)
      Sets a response header with the given name and value.
      void setIntHeader(String name, int value)
      Sets a response header with the given name and integer value.
      void setStatus(int sc)
      Sets the status code for this response.
      void setStatus(int sc, String sm)
      Deprecated.
      As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String). Sets the status code and message for this response.

      • Methods inherited from interface javax.servlet.ServletResponse

        flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentLengthLong, setContentType, setLocale

    • Field Detail

      • SC_CONTINUE

        static final int SC_CONTINUE
        Status code (100) indicating the client can continue.
        See Also:
        Constant Field Values

      • SC_SWITCHING_PROTOCOLS

        static final int SC_SWITCHING_PROTOCOLS
        Status code (101) indicating the server is switching protocols according to Upgrade header.
        See Also:
        Constant Field Values

      • SC_OK

        static final int SC_OK
        Status code (200) indicating the request succeeded normally.
        See Also:
        Constant Field Values

      • SC_CREATED

        static final int SC_CREATED
        Status code (201) indicating the request succeeded and created a new resource on the server.
        See Also:
        Constant Field Values

      • SC_ACCEPTED

        static final int SC_ACCEPTED
        Status code (202) indicating that a request was accepted for processing, but was not completed.
        See Also:
        Constant Field Values

      • SC_NON_AUTHORITATIVE_INFORMATION

        static final int SC_NON_AUTHORITATIVE_INFORMATION
        Status code (203) indicating that the meta information presented by the client did not originate from the server.
        See Also:
        Constant Field Values

      • SC_NO_CONTENT

        static final int SC_NO_CONTENT
        Status code (204) indicating that the request succeeded but that there was no new information to return.
        See Also:
        Constant Field Values

      • SC_RESET_CONTENT

        static final int SC_RESET_CONTENT
        Status code (205) indicating that the agent SHOULD reset the document view which caused the request to be sent.
        See Also:
        Constant Field Values

      • SC_PARTIAL_CONTENT

        static final int SC_PARTIAL_CONTENT
        Status code (206) indicating that the server has fulfilled the partial GET request for the resource.
        See Also:
        Constant Field Values

      • SC_MULTIPLE_CHOICES

        static final int SC_MULTIPLE_CHOICES
        Status code (300) indicating that the requested resource corresponds to any one of a set of representations, each with its own specific location.
        See Also:
        Constant Field Values

      • SC_MOVED_PERMANENTLY

        static final int SC_MOVED_PERMANENTLY
        Status code (301) indicating that the resource has permanently moved to a new location, and that future references should use a new URI with their requests.
        See Also:
        Constant Field Values

      • SC_MOVED_TEMPORARILY

        static final int SC_MOVED_TEMPORARILY
        Status code (302) indicating that the resource has temporarily moved to another location, but that future references should still use the original URI to access the resource. This definition is being retained for backwards compatibility. SC_FOUND is now the preferred definition.
        See Also:
        Constant Field Values

      • SC_FOUND

        static final int SC_FOUND
        Status code (302) indicating that the resource reside temporarily under a different URI. Since the redirection might be altered on occasion, the client should continue to use the Request-URI for future requests.(HTTP/1.1) To represent the status code (302), it is recommended to use this variable.
        See Also:
        Constant Field Values

      • SC_SEE_OTHER

        static final int SC_SEE_OTHER
        Status code (303) indicating that the response to the request can be found under a different URI.
        See Also:
        Constant Field Values

      • SC_NOT_MODIFIED

        static final int SC_NOT_MODIFIED
        Status code (304) indicating that a conditional GET operation found that the resource was available and not modified.
        See Also:
        Constant Field Values

      • SC_USE_PROXY

        static final int SC_USE_PROXY
        Status code (305) indicating that the requested resource MUST be accessed through the proxy given by the Location field.
        See Also:
        Constant Field Values

      • SC_TEMPORARY_REDIRECT

        static final int SC_TEMPORARY_REDIRECT
        Status code (307) indicating that the requested resource resides temporarily under a different URI. The temporary URI SHOULD be given by the Location field in the response.
        See Also:
        Constant Field Values

      • SC_BAD_REQUEST

        static final int SC_BAD_REQUEST
        Status code (400) indicating the request sent by the client was syntactically incorrect.
        See Also:
        Constant Field Values

      • SC_UNAUTHORIZED

        static final int SC_UNAUTHORIZED
        Status code (401) indicating that the request requires HTTP authentication.
        See Also:
        Constant Field Values

      • SC_PAYMENT_REQUIRED

        static final int SC_PAYMENT_REQUIRED
        Status code (402) reserved for future use.
        See Also:
        Constant Field Values

      • SC_FORBIDDEN

        static final int SC_FORBIDDEN
        Status code (403) indicating the server understood the request but refused to fulfill it.
        See Also:
        Constant Field Values

      • SC_NOT_FOUND

        static final int SC_NOT_FOUND
        Status code (404) indicating that the requested resource is not available.
        See Also:
        Constant Field Values

      • SC_METHOD_NOT_ALLOWED

        static final int SC_METHOD_NOT_ALLOWED
        Status code (405) indicating that the method specified in the Request-Line is not allowed for the resource identified by the Request-URI.
        See Also:
        Constant Field Values

      • SC_NOT_ACCEPTABLE

        static final int SC_NOT_ACCEPTABLE
        Status code (406) indicating that the resource identified by the request is only capable of generating response entities which have content characteristics not acceptable according to the accept headers sent in the request.
        See Also:
        Constant Field Values

      • SC_PROXY_AUTHENTICATION_REQUIRED

        static final int SC_PROXY_AUTHENTICATION_REQUIRED
        Status code (407) indicating that the client MUST first authenticate itself with the proxy.
        See Also:
        Constant Field Values

      • SC_REQUEST_TIMEOUT

        static final int SC_REQUEST_TIMEOUT
        Status code (408) indicating that the client did not produce a request within the time that the server was prepared to wait.
        See Also:
        Constant Field Values

      • SC_CONFLICT

        static final int SC_CONFLICT
        Status code (409) indicating that the request could not be completed due to a conflict with the current state of the resource.
        See Also:
        Constant Field Values

      • SC_GONE

        static final int SC_GONE
        Status code (410) indicating that the resource is no longer available at the server and no forwarding address is known. This condition SHOULD be considered permanent.
        See Also:
        Constant Field Values

      • SC_LENGTH_REQUIRED

        static final int SC_LENGTH_REQUIRED
        Status code (411) indicating that the request cannot be handled without a defined Content-Length.
        See Also:
        Constant Field Values

      • SC_PRECONDITION_FAILED

        static final int SC_PRECONDITION_FAILED
        Status code (412) indicating that the precondition given in one or more of the request-header fields evaluated to false when it was tested on the server.
        See Also:
        Constant Field Values

      • SC_REQUEST_ENTITY_TOO_LARGE

        static final int SC_REQUEST_ENTITY_TOO_LARGE
        Status code (413) indicating that the server is refusing to process the request because the request entity is larger than the server is willing or able to process.
        See Also:
        Constant Field Values

      • SC_REQUEST_URI_TOO_LONG

        static final int SC_REQUEST_URI_TOO_LONG
        Status code (414) indicating that the server is refusing to service the request because the Request-URI is longer than the server is willing to interpret.
        See Also:
        Constant Field Values

      • SC_UNSUPPORTED_MEDIA_TYPE

        static final int SC_UNSUPPORTED_MEDIA_TYPE
        Status code (415) indicating that the server is refusing to service the request because the entity of the request is in a format not supported by the requested resource for the requested method.
        See Also:
        Constant Field Values

      • SC_REQUESTED_RANGE_NOT_SATISFIABLE

        static final int SC_REQUESTED_RANGE_NOT_SATISFIABLE
        Status code (416) indicating that the server cannot serve the requested byte range.
        See Also:
        Constant Field Values

      • SC_EXPECTATION_FAILED

        static final int SC_EXPECTATION_FAILED
        Status code (417) indicating that the server could not meet the expectation given in the Expect request header.
        See Also:
        Constant Field Values

      • SC_INTERNAL_SERVER_ERROR

        static final int SC_INTERNAL_SERVER_ERROR
        Status code (500) indicating an error inside the HTTP server which prevented it from fulfilling the request.
        See Also:
        Constant Field Values

      • SC_NOT_IMPLEMENTED

        static final int SC_NOT_IMPLEMENTED
        Status code (501) indicating the HTTP server does not support the functionality needed to fulfill the request.
        See Also:
        Constant Field Values

      • SC_BAD_GATEWAY

        static final int SC_BAD_GATEWAY
        Status code (502) indicating that the HTTP server received an invalid response from a server it consulted when acting as a proxy or gateway.
        See Also:
        Constant Field Values

      • SC_SERVICE_UNAVAILABLE

        static final int SC_SERVICE_UNAVAILABLE
        Status code (503) indicating that the HTTP server is temporarily overloaded, and unable to handle the request.
        See Also:
        Constant Field Values

      • SC_GATEWAY_TIMEOUT

        static final int SC_GATEWAY_TIMEOUT
        Status code (504) indicating that the server did not receive a timely response from the upstream server while acting as a gateway or proxy.
        See Also:
        Constant Field Values

      • SC_HTTP_VERSION_NOT_SUPPORTED

        static final int SC_HTTP_VERSION_NOT_SUPPORTED
        Status code (505) indicating that the server does not support or refuses to support the HTTP protocol version that was used in the request message.
        See Also:
        Constant Field Values

    • Method Detail

      • addCookie

        void addCookie(Cookie cookie)
        Adds the specified cookie to the response. This method can be called multiple times to set more than one cookie.
        Parameters:
        cookie - the Cookie to return to the client

      • containsHeader

        boolean containsHeader(String name)
        Returns a boolean indicating whether the named response header has already been set.
        Parameters:
        name - the header name
        Returns:
        true if the named response header has already been set; false otherwise

      • encodeURL

        String encodeURL(String url)
        Encodes the specified URL by including the session ID, or, if encoding is not needed, returns the URL unchanged. The implementation of this method includes the logic to determine whether the session ID needs to be encoded in the URL. For example, if the browser supports cookies, or session tracking is turned off, URL encoding is unnecessary.

        For robust session tracking, all URLs emitted by a servlet should be run through this method. Otherwise, URL rewriting cannot be used with browsers which do not support cookies.

        If the URL is relative, it is always relative to the current HttpServletRequest.

        Parameters:
        url - the url to be encoded.
        Returns:
        the encoded URL if encoding is needed; the unchanged URL otherwise.
        Throws:
        IllegalArgumentException - if the url is not valid

      • encodeRedirectURL

        String encodeRedirectURL(String url)
        Encodes the specified URL for use in the sendRedirect method or, if encoding is not needed, returns the URL unchanged. The implementation of this method includes the logic to determine whether the session ID needs to be encoded in the URL. For example, if the browser supports cookies, or session tracking is turned off, URL encoding is unnecessary. Because the rules for making this determination can differ from those used to decide whether to encode a normal link, this method is separated from the encodeURL method.

        All URLs sent to the HttpServletResponse.sendRedirect method should be run through this method. Otherwise, URL rewriting cannot be used with browsers which do not support cookies.

        If the URL is relative, it is always relative to the current HttpServletRequest.

        Parameters:
        url - the url to be encoded.
        Returns:
        the encoded URL if encoding is needed; the unchanged URL otherwise.
        Throws:
        IllegalArgumentException - if the url is not valid
        See Also:
        sendRedirect(java.lang.String), encodeUrl(java.lang.String)

      • encodeUrl

        String encodeUrl(String url)
        Deprecated. As of version 2.1, use encodeURL(String url) instead
        Parameters:
        url - the url to be encoded.
        Returns:
        the encoded URL if encoding is needed; the unchanged URL otherwise.
        Throws:
        IllegalArgumentException - if the url is not valid

      • encodeRedirectUrl

        String encodeRedirectUrl(String url)
        Deprecated. As of version 2.1, use encodeRedirectURL(String url) instead
        Parameters:
        url - the url to be encoded.
        Returns:
        the encoded URL if encoding is needed; the unchanged URL otherwise.
        Throws:
        IllegalArgumentException - if the url is not valid

      • sendError

        void sendError(int sc,
             String msg)
               throws IOException
        Sends an error response to the client using the specified status and clears the buffer. The server defaults to creating the response to look like an HTML-formatted server error page containing the specified message, setting the content type to "text/html". The server will preserve cookies and may clear or update any headers needed to serve the error page as a valid response. If an error-page declaration has been made for the web application corresponding to the status code passed in, it will be served back in preference to the suggested msg parameter and the msg parameter will be ignored.

        If the response has already been committed, this method throws an IllegalStateException. After using this method, the response should be considered to be committed and should not be written to.

        Parameters:
        sc - the error status code
        msg - the descriptive message
        Throws:
        IOException - If an input or output exception occurs
        IllegalStateException - If the response was committed

      • sendError

        void sendError(int sc)
               throws IOException
        Sends an error response to the client using the specified status code and clears the buffer. The server will preserve cookies and may clear or update any headers needed to serve the error page as a valid response. If an error-page declaration has been made for the web application corresponding to the status code passed in, it will be served back the error page

        If the response has already been committed, this method throws an IllegalStateException. After using this method, the response should be considered to be committed and should not be written to.

        Parameters:
        sc - the error status code
        Throws:
        IOException - If an input or output exception occurs
        IllegalStateException - If the response was committed before this method call

      • sendRedirect

        void sendRedirect(String location)
                  throws IOException
        Sends a temporary redirect response to the client using the specified redirect location URL and clears the buffer. The buffer will be replaced with the data set by this method. Calling this method sets the status code to SC_FOUND 302 (Found). This method can accept relative URLs;the servlet container must convert the relative URL to an absolute URL before sending the response to the client. If the location is relative without a leading '/' the container interprets it as relative to the current request URI. If the location is relative with a leading '/' the container interprets it as relative to the servlet container root. If the location is relative with two leading '/' the container interprets it as a network-path reference (see RFC 3986: Uniform Resource Identifier (URI): Generic Syntax, section 4.2 "Relative Reference").

        If the response has already been committed, this method throws an IllegalStateException. After using this method, the response should be considered to be committed and should not be written to.

        Parameters:
        location - the redirect location URL
        Throws:
        IOException - If an input or output exception occurs
        IllegalStateException - If the response was committed or if a partial URL is given and cannot be converted into a valid URL

      • setDateHeader

        void setDateHeader(String name,
                 long date)
        Sets a response header with the given name and date-value. The date is specified in terms of milliseconds since the epoch. If the header had already been set, the new value overwrites the previous one. The containsHeader method can be used to test for the presence of a header before setting its value.
        Parameters:
        name - the name of the header to set
        date - the assigned date value
        See Also:
        containsHeader(java.lang.String), addDateHeader(java.lang.String, long)

      • addDateHeader

        void addDateHeader(String name,
                 long date)
        Adds a response header with the given name and date-value. The date is specified in terms of milliseconds since the epoch. This method allows response headers to have multiple values.
        Parameters:
        name - the name of the header to set
        date - the additional date value
        See Also:
        setDateHeader(java.lang.String, long)

      • setHeader

        void setHeader(String name,
             String value)
        Sets a response header with the given name and value. If the header had already been set, the new value overwrites the previous one. The containsHeader method can be used to test for the presence of a header before setting its value.
        Parameters:
        name - the name of the header
        value - the header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
        See Also:
        containsHeader(java.lang.String), addHeader(java.lang.String, java.lang.String)

      • addHeader

        void addHeader(String name,
             String value)
        Adds a response header with the given name and value. This method allows response headers to have multiple values.
        Parameters:
        name - the name of the header
        value - the additional header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
        See Also:
        setHeader(java.lang.String, java.lang.String)

      • setIntHeader

        void setIntHeader(String name,
                int value)
        Sets a response header with the given name and integer value. If the header had already been set, the new value overwrites the previous one. The containsHeader method can be used to test for the presence of a header before setting its value.
        Parameters:
        name - the name of the header
        value - the assigned integer value
        See Also:
        containsHeader(java.lang.String), addIntHeader(java.lang.String, int)

      • addIntHeader

        void addIntHeader(String name,
                int value)
        Adds a response header with the given name and integer value. This method allows response headers to have multiple values.
        Parameters:
        name - the name of the header
        value - the assigned integer value
        See Also:
        setIntHeader(java.lang.String, int)

      • setStatus

        void setStatus(int sc)
        Sets the status code for this response.

        This method is used to set the return status code when there is no error (for example, for the SC_OK or SC_MOVED_TEMPORARILY status codes).

        If this method is used to set an error code, then the container's error page mechanism will not be triggered. If there is an error and the caller wishes to invoke an error page defined in the web application, then sendError(int, java.lang.String) must be used instead.

        This method preserves any cookies and other response headers.

        Valid status codes are those in the 2XX, 3XX, 4XX, and 5XX ranges. Other status codes are treated as container specific.

        Parameters:
        sc - the status code
        See Also:
        sendError(int, java.lang.String)

      • setStatus

        void setStatus(int sc,
             String sm)
        Deprecated. As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String). Sets the status code and message for this response.
        Parameters:
        sc - the status code
        sm - the status message

      • getStatus

        int getStatus()
        Gets the current status code of this response.
        Returns:
        the current status code of this response
        Since:
        Servlet 3.0

      • getHeader

        String getHeader(String name)
        Gets the value of the response header with the given name.

        If a response header with the given name exists and contains multiple values, the value that was added first will be returned.

        This method considers only response headers set or added via
 setHeader(java.lang.String, java.lang.String), addHeader(java.lang.String, java.lang.String), setDateHeader(java.lang.String, long),
 addDateHeader(java.lang.String, long), setIntHeader(java.lang.String, int), or
 addIntHeader(java.lang.String, int), respectively.

        Parameters:
        name - the name of the response header whose value to return
        Returns:
        the value of the response header with the given name, or null if no header with the given name has been set on this response
        Since:
        Servlet 3.0

      • getHeaders

        Collection<String> getHeaders(String name)
        Gets the values of the response header with the given name.

        This method considers only response headers set or added via
 setHeader(java.lang.String, java.lang.String), addHeader(java.lang.String, java.lang.String), setDateHeader(java.lang.String, long),
 addDateHeader(java.lang.String, long), setIntHeader(java.lang.String, int), or
 addIntHeader(java.lang.String, int), respectively.

        Any changes to the returned Collection must not affect this HttpServletResponse.

        Parameters:
        name - the name of the response header whose values to return
        Returns:
        a (possibly empty) Collection of the values of the response header with the given name
        Since:
        Servlet 3.0

      • getHeaderNames

        Collection<String> getHeaderNames()
        Gets the names of the headers of this response.

        This method considers only response headers set or added via
 setHeader(java.lang.String, java.lang.String), addHeader(java.lang.String, java.lang.String), setDateHeader(java.lang.String, long),
 addDateHeader(java.lang.String, long), setIntHeader(java.lang.String, int), or
 addIntHeader(java.lang.String, int), respectively.

        Any changes to the returned Collection must not affect this HttpServletResponse.

        Returns:
        a (possibly empty) Collection of the names of the headers of this response
        Since:
        Servlet 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpServletResponseWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Class HttpServletResponseWrapper

  • java.lang.Object
    • javax.servlet.ServletResponseWrapper
      • javax.servlet.http.HttpServletResponseWrapper
  • All Implemented Interfaces:
    HttpServletResponse, ServletResponse

    public class HttpServletResponseWrapper
extends ServletResponseWrapper
implements HttpServletResponse
    Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped response object.
    Since:
    Servlet 2.3
    Author:
    Various
    See Also:
    HttpServletResponse

    • Field Summary

      • Fields inherited from interface javax.servlet.http.HttpServletResponse

        SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_FOUND, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpServletResponseWrapper(HttpServletResponse response)
      Constructs a response adaptor wrapping the given response.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addCookie(Cookie cookie)
      The default behavior of this method is to call addCookie(Cookie cookie) on the wrapped response object.
      void addDateHeader(String name, long date)
      The default behavior of this method is to call addDateHeader(String name, long date) on the wrapped response object.
      void addHeader(String name, String value)
      The default behavior of this method is to return addHeader(String name, String value) on the wrapped response object.
      void addIntHeader(String name, int value)
      The default behavior of this method is to call addIntHeader(String name, int value) on the wrapped response object.
      boolean containsHeader(String name)
      The default behavior of this method is to call containsHeader(String name) on the wrapped response object.
      String encodeRedirectUrl(String url)
      Deprecated.
      As of version 2.1, use encodeRedirectURL(String url) instead
      String encodeRedirectURL(String url)
      The default behavior of this method is to return encodeRedirectURL(String url) on the wrapped response object.
      String encodeUrl(String url)
      Deprecated.
      As of version 2.1, use encodeURL(String url) instead
      String encodeURL(String url)
      The default behavior of this method is to call encodeURL(String url) on the wrapped response object.
      String getHeader(String name)
      The default behaviour of this method is to call HttpServletResponse.getHeader(java.lang.String) on the wrapped response object.
      Collection<String> getHeaderNames()
      The default behaviour of this method is to call HttpServletResponse.getHeaderNames() on the wrapped response object.
      Collection<String> getHeaders(String name)
      The default behaviour of this method is to call HttpServletResponse.getHeaders(java.lang.String) on the wrapped response object.
      int getStatus()
      The default behaviour of this method is to call HttpServletResponse.getStatus() on the wrapped response object.
      void sendError(int sc)
      The default behavior of this method is to call sendError(int sc) on the wrapped response object.
      void sendError(int sc, String msg)
      The default behavior of this method is to call sendError(int sc, String msg) on the wrapped response object.
      void sendRedirect(String location)
      The default behavior of this method is to return sendRedirect(String location) on the wrapped response object.
      void setDateHeader(String name, long date)
      The default behavior of this method is to call setDateHeader(String name, long date) on the wrapped response object.
      void setHeader(String name, String value)
      The default behavior of this method is to return setHeader(String name, String value) on the wrapped response object.
      void setIntHeader(String name, int value)
      The default behavior of this method is to call setIntHeader(String name, int value) on the wrapped response object.
      void setStatus(int sc)
      The default behavior of this method is to call setStatus(int sc) on the wrapped response object.
      void setStatus(int sc, String sm)
      Deprecated.
      As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String)

      • Methods inherited from class javax.servlet.ServletResponseWrapper

        flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getOutputStream, getResponse, getWriter, isCommitted, isWrapperFor, isWrapperFor, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentLengthLong, setContentType, setLocale, setResponse

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.servlet.ServletResponse

        flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentLengthLong, setContentType, setLocale

    • Constructor Detail

      • HttpServletResponseWrapper

        public HttpServletResponseWrapper(HttpServletResponse response)
        Constructs a response adaptor wrapping the given response.
        Throws:
        IllegalArgumentException - if the response is null

    • Method Detail

      • addCookie

        public void addCookie(Cookie cookie)
        The default behavior of this method is to call addCookie(Cookie cookie) on the wrapped response object.
        Specified by:
        addCookie in interface HttpServletResponse
        Parameters:
        cookie - the Cookie to return to the client

      • containsHeader

        public boolean containsHeader(String name)
        The default behavior of this method is to call containsHeader(String name) on the wrapped response object.
        Specified by:
        containsHeader in interface HttpServletResponse
        Parameters:
        name - the header name
        Returns:
        true if the named response header has already been set; false otherwise

      • encodeURL

        public String encodeURL(String url)
        The default behavior of this method is to call encodeURL(String url) on the wrapped response object.
        Specified by:
        encodeURL in interface HttpServletResponse
        Parameters:
        url - the url to be encoded.
        Returns:
        the encoded URL if encoding is needed; the unchanged URL otherwise.

      • encodeRedirectURL

        public String encodeRedirectURL(String url)
        The default behavior of this method is to return encodeRedirectURL(String url) on the wrapped response object.
        Specified by:
        encodeRedirectURL in interface HttpServletResponse
        Parameters:
        url - the url to be encoded.
        Returns:
        the encoded URL if encoding is needed; the unchanged URL otherwise.
        See Also:
        HttpServletResponse.sendRedirect(java.lang.String), HttpServletResponse.encodeUrl(java.lang.String)

      • encodeUrl

        public String encodeUrl(String url)
        Deprecated. As of version 2.1, use encodeURL(String url) instead
        The default behavior of this method is to call encodeUrl(String url) on the wrapped response object.
        Specified by:
        encodeUrl in interface HttpServletResponse
        Parameters:
        url - the url to be encoded.
        Returns:
        the encoded URL if encoding is needed; the unchanged URL otherwise.

      • encodeRedirectUrl

        public String encodeRedirectUrl(String url)
        Deprecated. As of version 2.1, use encodeRedirectURL(String url) instead
        The default behavior of this method is to return encodeRedirectUrl(String url) on the wrapped response object.
        Specified by:
        encodeRedirectUrl in interface HttpServletResponse
        Parameters:
        url - the url to be encoded.
        Returns:
        the encoded URL if encoding is needed; the unchanged URL otherwise.

      • sendError

        public void sendError(int sc,
             String msg)
               throws IOException
        The default behavior of this method is to call sendError(int sc, String msg) on the wrapped response object.
        Specified by:
        sendError in interface HttpServletResponse
        Parameters:
        sc - the error status code
        msg - the descriptive message
        Throws:
        IOException - If an input or output exception occurs

      • sendError

        public void sendError(int sc)
               throws IOException
        The default behavior of this method is to call sendError(int sc) on the wrapped response object.
        Specified by:
        sendError in interface HttpServletResponse
        Parameters:
        sc - the error status code
        Throws:
        IOException - If an input or output exception occurs

      • sendRedirect

        public void sendRedirect(String location)
                  throws IOException
        The default behavior of this method is to return sendRedirect(String location) on the wrapped response object.
        Specified by:
        sendRedirect in interface HttpServletResponse
        Parameters:
        location - the redirect location URL
        Throws:
        IOException - If an input or output exception occurs

      • setDateHeader

        public void setDateHeader(String name,
                 long date)
        The default behavior of this method is to call setDateHeader(String name, long date) on the wrapped response object.
        Specified by:
        setDateHeader in interface HttpServletResponse
        Parameters:
        name - the name of the header to set
        date - the assigned date value
        See Also:
        HttpServletResponse.containsHeader(java.lang.String), HttpServletResponse.addDateHeader(java.lang.String, long)

      • addDateHeader

        public void addDateHeader(String name,
                 long date)
        The default behavior of this method is to call addDateHeader(String name, long date) on the wrapped response object.
        Specified by:
        addDateHeader in interface HttpServletResponse
        Parameters:
        name - the name of the header to set
        date - the additional date value
        See Also:
        HttpServletResponse.setDateHeader(java.lang.String, long)

      • setHeader

        public void setHeader(String name,
             String value)
        The default behavior of this method is to return setHeader(String name, String value) on the wrapped response object.
        Specified by:
        setHeader in interface HttpServletResponse
        Parameters:
        name - the name of the header
        value - the header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
        See Also:
        HttpServletResponse.containsHeader(java.lang.String), HttpServletResponse.addHeader(java.lang.String, java.lang.String)

      • addHeader

        public void addHeader(String name,
             String value)
        The default behavior of this method is to return addHeader(String name, String value) on the wrapped response object.
        Specified by:
        addHeader in interface HttpServletResponse
        Parameters:
        name - the name of the header
        value - the additional header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
        See Also:
        HttpServletResponse.setHeader(java.lang.String, java.lang.String)

      • setIntHeader

        public void setIntHeader(String name,
                int value)
        The default behavior of this method is to call setIntHeader(String name, int value) on the wrapped response object.
        Specified by:
        setIntHeader in interface HttpServletResponse
        Parameters:
        name - the name of the header
        value - the assigned integer value
        See Also:
        HttpServletResponse.containsHeader(java.lang.String), HttpServletResponse.addIntHeader(java.lang.String, int)

      • addIntHeader

        public void addIntHeader(String name,
                int value)
        The default behavior of this method is to call addIntHeader(String name, int value) on the wrapped response object.
        Specified by:
        addIntHeader in interface HttpServletResponse
        Parameters:
        name - the name of the header
        value - the assigned integer value
        See Also:
        HttpServletResponse.setIntHeader(java.lang.String, int)

      • setStatus

        public void setStatus(int sc)
        The default behavior of this method is to call setStatus(int sc) on the wrapped response object.
        Specified by:
        setStatus in interface HttpServletResponse
        Parameters:
        sc - the status code
        See Also:
        HttpServletResponse.sendError(int, java.lang.String)

      • setStatus

        public void setStatus(int sc,
             String sm)
        Deprecated. As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String)
        The default behavior of this method is to call setStatus(int sc, String sm) on the wrapped response object.
        Specified by:
        setStatus in interface HttpServletResponse
        Parameters:
        sc - the status code
        sm - the status message

      • getStatus

        public int getStatus()
        The default behaviour of this method is to call HttpServletResponse.getStatus() on the wrapped response object.
        Specified by:
        getStatus in interface HttpServletResponse
        Returns:
        the current status code of the wrapped response

      • getHeader

        public String getHeader(String name)
        The default behaviour of this method is to call HttpServletResponse.getHeader(java.lang.String) on the wrapped response object.
        Specified by:
        getHeader in interface HttpServletResponse
        Parameters:
        name - the name of the response header whose value to return
        Returns:
        the value of the response header with the given name, or null if no header with the given name has been set on the wrapped response
        Since:
        Servlet 3.0

      • getHeaders

        public Collection<String> getHeaders(String name)
        The default behaviour of this method is to call HttpServletResponse.getHeaders(java.lang.String) on the wrapped response object.

        Any changes to the returned Collection must not affect this HttpServletResponseWrapper.

        Specified by:
        getHeaders in interface HttpServletResponse
        Parameters:
        name - the name of the response header whose values to return
        Returns:
        a (possibly empty) Collection of the values of the response header with the given name
        Since:
        Servlet 3.0

      • getHeaderNames

        public Collection<String> getHeaderNames()
        The default behaviour of this method is to call HttpServletResponse.getHeaderNames() on the wrapped response object.

        Any changes to the returned Collection must not affect this HttpServletResponseWrapper.

        Specified by:
        getHeaderNames in interface HttpServletResponse
        Returns:
        a (possibly empty) Collection of the names of the response headers
        Since:
        Servlet 3.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpSession (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface HttpSession

  • public interface HttpSession
    Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.

    The servlet container uses this interface to create a session between an HTTP client and an HTTP server. The session persists for a specified time period, across more than one connection or page request from the user. A session usually corresponds to one user, who may visit a site many times. The server can maintain a session in many ways such as using cookies or rewriting URLs.

    This interface allows servlets to

    • View and manipulate information about a session, such as the session identifier, creation time, and last accessed time
    • Bind objects to sessions, allowing user information to persist across multiple user connections

    When an application stores an object in or removes an object from a session, the session checks whether the object implements HttpSessionBindingListener. If it does, the servlet notifies the object that it has been bound to or unbound from the session. Notifications are sent after the binding methods complete. For session that are invalidated or expire, notifications are sent after the session has been invalidated or expired.

    When container migrates a session between VMs in a distributed container setting, all session attributes implementing the HttpSessionActivationListener interface are notified.

    A servlet should be able to handle cases in which the client does not choose to join a session, such as when cookies are intentionally turned off. Until the client joins the session, isNew returns true. If the client chooses not to join the session, getSession will return a different session on each request, and isNew will always return true.

    Session information is scoped only to the current web application (ServletContext), so information stored in one context will not be directly visible in another.

    Author:
    Various
    See Also:
    HttpSessionBindingListener, HttpSessionContext

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAttribute(String name)
      Returns the object bound with the specified name in this session, or null if no object is bound under the name.
      Enumeration<String> getAttributeNames()
      Returns an Enumeration of String objects containing the names of all the objects bound to this session.
      long getCreationTime()
      Returns the time when this session was created, measured in milliseconds since midnight January 1, 1970 GMT.
      String getId()
      Returns a string containing the unique identifier assigned to this session.
      long getLastAccessedTime()
      Returns the last time the client sent a request associated with this session, as the number of milliseconds since midnight January 1, 1970 GMT, and marked by the time the container received the request.
      int getMaxInactiveInterval()
      Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses.
      ServletContext getServletContext()
      Returns the ServletContext to which this session belongs.
      HttpSessionContext getSessionContext()
      Deprecated.
      As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.
      Object getValue(String name)
      Deprecated.
      As of Version 2.2, this method is replaced by getAttribute(java.lang.String).
      String[] getValueNames()
      Deprecated.
      As of Version 2.2, this method is replaced by getAttributeNames()
      void invalidate()
      Invalidates this session then unbinds any objects bound to it.
      boolean isNew()
      Returns true if the client does not yet know about the session or if the client chooses not to join the session.
      void putValue(String name, Object value)
      Deprecated.
      As of Version 2.2, this method is replaced by setAttribute(java.lang.String, java.lang.Object)
      void removeAttribute(String name)
      Removes the object bound with the specified name from this session.
      void removeValue(String name)
      Deprecated.
      As of Version 2.2, this method is replaced by removeAttribute(java.lang.String)
      void setAttribute(String name, Object value)
      Binds an object to this session, using the name specified.
      void setMaxInactiveInterval(int interval)
      Specifies the time, in seconds, between client requests before the servlet container will invalidate this session.

    • Method Detail

      • getCreationTime

        long getCreationTime()
        Returns the time when this session was created, measured in milliseconds since midnight January 1, 1970 GMT.
        Returns:
        a long specifying when this session was created, expressed in milliseconds since 1/1/1970 GMT
        Throws:
        IllegalStateException - if this method is called on an invalidated session

      • getId

        String getId()
        Returns a string containing the unique identifier assigned to this session. The identifier is assigned by the servlet container and is implementation dependent.
        Returns:
        a string specifying the identifier assigned to this session

      • getLastAccessedTime

        long getLastAccessedTime()
        Returns the last time the client sent a request associated with this session, as the number of milliseconds since midnight January 1, 1970 GMT, and marked by the time the container received the request.

        Actions that your application takes, such as getting or setting a value associated with the session, do not affect the access time.

        Returns:
        a long representing the last time the client sent a request associated with this session, expressed in milliseconds since 1/1/1970 GMT
        Throws:
        IllegalStateException - if this method is called on an invalidated session

      • getServletContext

        ServletContext getServletContext()
        Returns the ServletContext to which this session belongs.
        Returns:
        The ServletContext object for the web application
        Since:
        Servlet 2.3

      • setMaxInactiveInterval

        void setMaxInactiveInterval(int interval)
        Specifies the time, in seconds, between client requests before the servlet container will invalidate this session.

        An interval value of zero or less indicates that the session should never timeout.

        Parameters:
        interval - An integer specifying the number of seconds

      • getMaxInactiveInterval

        int getMaxInactiveInterval()
        Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses. After this interval, the servlet container will invalidate the session. The maximum time interval can be set with the setMaxInactiveInterval method.

        A return value of zero or less indicates that the session will never timeout.

        Returns:
        an integer specifying the number of seconds this session remains open between client requests
        See Also:
        setMaxInactiveInterval(int)

      • getSessionContext

        HttpSessionContext getSessionContext()
        Deprecated. As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.

      • getAttribute

        Object getAttribute(String name)
        Returns the object bound with the specified name in this session, or null if no object is bound under the name.
        Parameters:
        name - a string specifying the name of the object
        Returns:
        the object with the specified name
        Throws:
        IllegalStateException - if this method is called on an invalidated session

      • getValue

        Object getValue(String name)
        Deprecated. As of Version 2.2, this method is replaced by getAttribute(java.lang.String).
        Parameters:
        name - a string specifying the name of the object
        Returns:
        the object with the specified name
        Throws:
        IllegalStateException - if this method is called on an invalidated session

      • getAttributeNames

        Enumeration<String> getAttributeNames()
        Returns an Enumeration of String objects containing the names of all the objects bound to this session.
        Returns:
        an Enumeration of String objects specifying the names of all the objects bound to this session
        Throws:
        IllegalStateException - if this method is called on an invalidated session

      • getValueNames

        String[] getValueNames()
        Deprecated. As of Version 2.2, this method is replaced by getAttributeNames()
        Returns:
        an array of String objects specifying the names of all the objects bound to this session
        Throws:
        IllegalStateException - if this method is called on an invalidated session

      • setAttribute

        void setAttribute(String name,
                Object value)
        Binds an object to this session, using the name specified. If an object of the same name is already bound to the session, the object is replaced.

        After this method executes, and if the new object implements HttpSessionBindingListener, the container calls HttpSessionBindingListener.valueBound. The container then notifies any HttpSessionAttributeListeners in the web application.

        If an object was already bound to this session of this name that implements HttpSessionBindingListener, its HttpSessionBindingListener.valueUnbound method is called.

        If the value passed in is null, this has the same effect as calling removeAttribute().

        Parameters:
        name - the name to which the object is bound; cannot be null
        value - the object to be bound
        Throws:
        IllegalStateException - if this method is called on an invalidated session

      • putValue

        void putValue(String name,
            Object value)
        Deprecated. As of Version 2.2, this method is replaced by setAttribute(java.lang.String, java.lang.Object)
        Parameters:
        name - the name to which the object is bound; cannot be null
        value - the object to be bound; cannot be null
        Throws:
        IllegalStateException - if this method is called on an invalidated session

      • removeAttribute

        void removeAttribute(String name)
        Removes the object bound with the specified name from this session. If the session does not have an object bound with the specified name, this method does nothing.

        After this method executes, and if the object implements HttpSessionBindingListener, the container calls HttpSessionBindingListener.valueUnbound. The container then notifies any HttpSessionAttributeListeners in the web application.

        Parameters:
        name - the name of the object to remove from this session
        Throws:
        IllegalStateException - if this method is called on an invalidated session

      • removeValue

        void removeValue(String name)
        Deprecated. As of Version 2.2, this method is replaced by removeAttribute(java.lang.String)
        Parameters:
        name - the name of the object to remove from this session
        Throws:
        IllegalStateException - if this method is called on an invalidated session

      • invalidate

        void invalidate()
        Invalidates this session then unbinds any objects bound to it.
        Throws:
        IllegalStateException - if this method is called on an already invalidated session

      • isNew

        boolean isNew()
        Returns true if the client does not yet know about the session or if the client chooses not to join the session. For example, if the server used only cookie-based sessions, and the client had disabled the use of cookies, then a session would be new on each request.
        Returns:
        true if the server has created a session, but the client has not yet joined
        Throws:
        IllegalStateException - if this method is called on an already invalidated session
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpSessionActivationListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface HttpSessionActivationListener

  • All Superinterfaces:
    EventListener

    public interface HttpSessionActivationListener
extends EventListener
    Objects that are bound to a session may listen to container events notifying them that sessions will be passivated and that session will be activated. A container that migrates session between VMs or persists sessions is required to notify all attributes bound to sessions implementing HttpSessionActivationListener.
    Since:
    Servlet 2.3

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void sessionDidActivate(HttpSessionEvent se)
      Notification that the session has just been activated.
      void sessionWillPassivate(HttpSessionEvent se)
      Notification that the session is about to be passivated.

    • Method Detail

      • sessionWillPassivate

        void sessionWillPassivate(HttpSessionEvent se)
        Notification that the session is about to be passivated.

      • sessionDidActivate

        void sessionDidActivate(HttpSessionEvent se)
        Notification that the session has just been activated.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpSessionAttributeListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface HttpSessionAttributeListener

  • All Superinterfaces:
    EventListener

    public interface HttpSessionAttributeListener
extends EventListener
    Interface for receiving notification events about HttpSession attribute changes.

    In order to receive these notification events, the implementation class must be either declared in the deployment descriptor of the web application, annotated with WebListener, or registered via one of the addListener methods defined on ServletContext.

    The order in which implementations of this interface are invoked is unspecified.

    Since:
    Servlet 2.3

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void attributeAdded(HttpSessionBindingEvent event)
      Receives notification that an attribute has been added to a session.
      void attributeRemoved(HttpSessionBindingEvent event)
      Receives notification that an attribute has been removed from a session.
      void attributeReplaced(HttpSessionBindingEvent event)
      Receives notification that an attribute has been replaced in a session.

    • Method Detail

      • attributeAdded

        void attributeAdded(HttpSessionBindingEvent event)
        Receives notification that an attribute has been added to a session.
        Parameters:
        event - the HttpSessionBindingEvent containing the session and the name and value of the attribute that was added

      • attributeRemoved

        void attributeRemoved(HttpSessionBindingEvent event)
        Receives notification that an attribute has been removed from a session.
        Parameters:
        event - the HttpSessionBindingEvent containing the session and the name and value of the attribute that was removed

      • attributeReplaced

        void attributeReplaced(HttpSessionBindingEvent event)
        Receives notification that an attribute has been replaced in a session.
        Parameters:
        event - the HttpSessionBindingEvent containing the session and the name and (old) value of the attribute that was replaced
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpSessionBindingEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Class HttpSessionBindingEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.servlet.http.HttpSessionEvent
        • javax.servlet.http.HttpSessionBindingEvent
  • All Implemented Interfaces:
    Serializable

    public class HttpSessionBindingEvent
extends HttpSessionEvent
    Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.

    The session binds the object by a call to HttpSession.setAttribute and unbinds the object by a call to HttpSession.removeAttribute.

    Author:
    Various
    See Also:
    HttpSession, HttpSessionBindingListener, HttpSessionAttributeListener, Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpSessionBindingEvent(HttpSession session, String name)
      Constructs an event that notifies an object that it has been bound to or unbound from a session.
      HttpSessionBindingEvent(HttpSession session, String name, Object value)
      Constructs an event that notifies an object that it has been bound to or unbound from a session.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Returns the name with which the attribute is bound to or unbound from the session.
      HttpSession getSession()
      Return the session that changed.
      Object getValue()
      Returns the value of the attribute that has been added, removed or replaced.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • HttpSessionBindingEvent

        public HttpSessionBindingEvent(HttpSession session,
                       String name)
        Constructs an event that notifies an object that it has been bound to or unbound from a session. To receive the event, the object must implement HttpSessionBindingListener.
        Parameters:
        session - the session to which the object is bound or unbound
        name - the name with which the object is bound or unbound
        See Also:
        getName(), getSession()

      • HttpSessionBindingEvent

        public HttpSessionBindingEvent(HttpSession session,
                       String name,
                       Object value)
        Constructs an event that notifies an object that it has been bound to or unbound from a session. To receive the event, the object must implement HttpSessionBindingListener.
        Parameters:
        session - the session to which the object is bound or unbound
        name - the name with which the object is bound or unbound
        See Also:
        getName(), getSession()

    • Method Detail

      • getSession

        public HttpSession getSession()
        Return the session that changed.
        Overrides:
        getSession in class HttpSessionEvent

      • getName

        public String getName()
        Returns the name with which the attribute is bound to or unbound from the session.
        Returns:
        a string specifying the name with which the object is bound to or unbound from the session

      • getValue

        public Object getValue()
        Returns the value of the attribute that has been added, removed or replaced. If the attribute was added (or bound), this is the value of the attribute. If the attribute was removed (or unbound), this is the value of the removed attribute. If the attribute was replaced, this is the old value of the attribute.
        Since:
        Servlet 2.3
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpSessionBindingListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface HttpSessionBindingListener

  • All Superinterfaces:
    EventListener

    public interface HttpSessionBindingListener
extends EventListener
    Causes an object to be notified when it is bound to or unbound from a session. The object is notified by an HttpSessionBindingEvent object. This may be as a result of a servlet programmer explicitly unbinding an attribute from a session, due to a session being invalidated, or due to a session timing out.
    Author:
    Various
    See Also:
    HttpSession, HttpSessionBindingEvent

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void valueBound(HttpSessionBindingEvent event)
      Notifies the object that it is being bound to a session and identifies the session.
      void valueUnbound(HttpSessionBindingEvent event)
      Notifies the object that it is being unbound from a session and identifies the session.

    • Method Detail

      • valueBound

        void valueBound(HttpSessionBindingEvent event)
        Notifies the object that it is being bound to a session and identifies the session.
        Parameters:
        event - the event that identifies the session
        See Also:
        valueUnbound(javax.servlet.http.HttpSessionBindingEvent)

      • valueUnbound

        void valueUnbound(HttpSessionBindingEvent event)
        Notifies the object that it is being unbound from a session and identifies the session.
        Parameters:
        event - the event that identifies the session
        See Also:
        valueBound(javax.servlet.http.HttpSessionBindingEvent)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpSessionContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface HttpSessionContext

  • Deprecated.
    As of Java(tm) Servlet API 2.1 for security reasons, with no replacement. This interface will be removed in a future version of this API.

    public interface HttpSessionContext
    Author:
    Various
    See Also:
    HttpSession, HttpSessionBindingEvent, HttpSessionBindingListener

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Enumeration<String> getIds()
      Deprecated.
      As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.
      HttpSession getSession(String sessionId)
      Deprecated.
      As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.

    • Method Detail

      • getSession

        HttpSession getSession(String sessionId)
        Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.

      • getIds

        Enumeration<String> getIds()
        Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpSessionEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Class HttpSessionEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.servlet.http.HttpSessionEvent
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    HttpSessionBindingEvent

    public class HttpSessionEvent
extends EventObject
    This is the class representing event notifications for changes to sessions within a web application.
    Since:
    Servlet 2.3
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpSessionEvent(HttpSession source)
      Construct a session event from the given source.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      HttpSession getSession()
      Return the session that changed.

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • HttpSessionEvent

        public HttpSessionEvent(HttpSession source)
        Construct a session event from the given source.

    • Method Detail

      • getSession

        public HttpSession getSession()
        Return the session that changed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpSessionIdListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface HttpSessionIdListener

  • All Superinterfaces:
    EventListener

    public interface HttpSessionIdListener
extends EventListener
    Interface for receiving notification events about HttpSession id changes.

    In order to receive these notification events, the implementation class must be either declared in the deployment descriptor of the web application, annotated with WebListener, or registered via one of the addListener methods defined on ServletContext.

    The order in which implementations of this interface are invoked is unspecified.

    Since:
    Servlet 3.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void sessionIdChanged(HttpSessionEvent event, String oldSessionId)
      Receives notification that session id has been changed in a session.

    • Method Detail

      • sessionIdChanged

        void sessionIdChanged(HttpSessionEvent event,
                    String oldSessionId)
        Receives notification that session id has been changed in a session.
        Parameters:
        event - the HttpSessionBindingEvent containing the session and the name and (old) value of the attribute that was replaced
        oldSessionId - the old session id
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpSessionListener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface HttpSessionListener

  • All Superinterfaces:
    EventListener

    public interface HttpSessionListener
extends EventListener
    Interface for receiving notification events about HttpSession lifecycle changes.

    In order to receive these notification events, the implementation class must be either declared in the deployment descriptor of the web application, annotated with WebListener, or registered via one of the addListener methods defined on ServletContext.

    Implementations of this interface are invoked at their sessionCreated(javax.servlet.http.HttpSessionEvent) method in the order in which they have been declared, and at their sessionDestroyed(javax.servlet.http.HttpSessionEvent) method in reverse order.

    Since:
    Servlet 2.3
    See Also:
    HttpSessionEvent

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void sessionCreated(HttpSessionEvent se)
      Receives notification that a session has been created.
      void sessionDestroyed(HttpSessionEvent se)
      Receives notification that a session is about to be invalidated.

    • Method Detail

      • sessionCreated

        void sessionCreated(HttpSessionEvent se)
        Receives notification that a session has been created.
        Parameters:
        se - the HttpSessionEvent containing the session

      • sessionDestroyed

        void sessionDestroyed(HttpSessionEvent se)
        Receives notification that a session is about to be invalidated.
        Parameters:
        se - the HttpSessionEvent containing the session
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpUpgradeHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface HttpUpgradeHandler

  • public interface HttpUpgradeHandler
    This interface encapsulates the upgrade protocol processing. A HttpUpgradeHandler implementation would allow the servlet container to communicate with it.
    Since:
    Servlet 3.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      It is called when the client is disconnected.
      void init(WebConnection wc)
      It is called once the HTTP Upgrade process has been completed and the upgraded connection is ready to start using the new protocol.

    • Method Detail

      • init

        void init(WebConnection wc)
        It is called once the HTTP Upgrade process has been completed and the upgraded connection is ready to start using the new protocol.
        Parameters:
        wc - the WebConnection object associated to this upgrade request

      • destroy

        void destroy()
        It is called when the client is disconnected.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpUtils (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Class HttpUtils

  • java.lang.Object
    • javax.servlet.http.HttpUtils
  • Deprecated.
    As of Java(tm) Servlet API 2.3. These methods were only useful with the default encoding and have been moved to the request interfaces.

    public class HttpUtils
extends Object

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpUtils()
      Deprecated.
      Constructs an empty HttpUtils object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static StringBuffer getRequestURL(HttpServletRequest req)
      Deprecated.
      Reconstructs the URL the client used to make the request, using information in the HttpServletRequest object.
      static Hashtable<String,String[]> parsePostData(int len, ServletInputStream in)
      Deprecated.
      Parses data from an HTML form that the client sends to the server using the HTTP POST method and the application/x-www-form-urlencoded MIME type.
      static Hashtable<String,String[]> parseQueryString(String s)
      Deprecated.
      Parses a query string passed from the client to the server and builds a HashTable object with key-value pairs.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HttpUtils

        public HttpUtils()
        Deprecated.
        Constructs an empty HttpUtils object.

    • Method Detail

      • parseQueryString

        public static Hashtable<String,String[]> parseQueryString(String s)
        Deprecated.
        Parses a query string passed from the client to the server and builds a HashTable object with key-value pairs. The query string should be in the form of a string packaged by the GET or POST method, that is, it should have key-value pairs in the form key=value, with each pair separated from the next by a & character.

        A key can appear more than once in the query string with different values. However, the key appears only once in the hashtable, with its value being an array of strings containing the multiple values sent by the query string.

        The keys and values in the hashtable are stored in their decoded form, so any + characters are converted to spaces, and characters sent in hexadecimal notation (like %xx) are converted to ASCII characters.

        Parameters:
        s - a string containing the query to be parsed
        Returns:
        a HashTable object built from the parsed key-value pairs
        Throws:
        IllegalArgumentException - if the query string is invalid

      • parsePostData

        public static Hashtable<String,String[]> parsePostData(int len,
                                       ServletInputStream in)
        Deprecated.
        Parses data from an HTML form that the client sends to the server using the HTTP POST method and the application/x-www-form-urlencoded MIME type.

        The data sent by the POST method contains key-value pairs. A key can appear more than once in the POST data with different values. However, the key appears only once in the hashtable, with its value being an array of strings containing the multiple values sent by the POST method.

        The keys and values in the hashtable are stored in their decoded form, so any + characters are converted to spaces, and characters sent in hexadecimal notation (like %xx) are converted to ASCII characters.

        Parameters:
        len - an integer specifying the length, in characters, of the ServletInputStream object that is also passed to this method
        in - the ServletInputStream object that contains the data sent from the client
        Returns:
        a HashTable object built from the parsed key-value pairs
        Throws:
        IllegalArgumentException - if the data sent by the POST method is invalid

      • getRequestURL

        public static StringBuffer getRequestURL(HttpServletRequest req)
        Deprecated.
        Reconstructs the URL the client used to make the request, using information in the HttpServletRequest object. The returned URL contains a protocol, server name, port number, and server path, but it does not include query string parameters.

        Because this method returns a StringBuffer, not a string, you can modify the URL easily, for example, to append query parameters.

        This method is useful for creating redirect messages and for reporting errors.

        Parameters:
        req - a HttpServletRequest object containing the client's request
        Returns:
        a StringBuffer object containing the reconstructed URL
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.servlet.http (Java(TM) EE 7 Specification APIs)

javax.servlet.http

Interfaces

  • HttpServletRequest
  • HttpServletResponse
  • HttpSession
  • HttpSessionActivationListener
  • HttpSessionAttributeListener
  • HttpSessionBindingListener
  • HttpSessionContext
  • HttpSessionIdListener
  • HttpSessionListener
  • HttpUpgradeHandler
  • Part
  • WebConnection

Classes

  • Cookie
  • HttpServlet
  • HttpServletRequestWrapper
  • HttpServletResponseWrapper
  • HttpSessionBindingEvent
  • HttpSessionEvent
  • HttpUtils


javax.servlet.http (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet.http

The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

See: Description

  • Interface Summary
    Interface Description
    HttpServletRequest
    Extends the ServletRequest interface to provide request information for HTTP servlets.
    HttpServletResponse
    Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response.
    HttpSession
    Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.
    HttpSessionActivationListener
    Objects that are bound to a session may listen to container events notifying them that sessions will be passivated and that session will be activated.
    HttpSessionAttributeListener
    Interface for receiving notification events about HttpSession attribute changes.
    HttpSessionBindingListener
    Causes an object to be notified when it is bound to or unbound from a session.
    HttpSessionContext Deprecated
    As of Java(tm) Servlet API 2.1 for security reasons, with no replacement.
    HttpSessionIdListener
    Interface for receiving notification events about HttpSession id changes.
    HttpSessionListener
    Interface for receiving notification events about HttpSession lifecycle changes.
    HttpUpgradeHandler
    This interface encapsulates the upgrade protocol processing.
    Part
    This class represents a part or form item that was received within a multipart/form-data POST request.
    WebConnection
    This interface encapsulates the connection for an upgrade request.
  • Class Summary
    Class Description
    Cookie
    Creates a cookie, a small amount of information sent by a servlet to a Web browser, saved by the browser, and later sent back to the server.
    HttpServlet
    Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site.
    HttpServletRequestWrapper
    Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
    HttpServletResponseWrapper
    Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
    HttpSessionBindingEvent
    Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.
    HttpSessionEvent
    This is the class representing event notifications for changes to sessions within a web application.
    HttpUtils Deprecated
    As of Java(tm) Servlet API 2.3.

Package javax.servlet.http Description

The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet.http Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet.http

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.http.Cookie (implements java.lang.Cloneable, java.io.Serializable)
    • java.util.EventObject (implements java.io.Serializable)
      • javax.servlet.http.HttpSessionEvent
        • javax.servlet.http.HttpSessionBindingEvent
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet
    • javax.servlet.http.HttpUtils
    • javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
    • javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)

Interface Hierarchy

  • java.lang.AutoCloseable
    • javax.servlet.http.WebConnection
  • java.util.EventListener
    • javax.servlet.http.HttpSessionActivationListener
    • javax.servlet.http.HttpSessionAttributeListener
    • javax.servlet.http.HttpSessionBindingListener
    • javax.servlet.http.HttpSessionIdListener
    • javax.servlet.http.HttpSessionListener
  • javax.servlet.http.HttpSession
  • javax.servlet.http.HttpSessionContext
  • javax.servlet.http.HttpUpgradeHandler
  • javax.servlet.http.Part
  • javax.servlet.ServletRequest
    • javax.servlet.http.HttpServletRequest
  • javax.servlet.ServletResponse
    • javax.servlet.http.HttpServletResponse
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Part (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface Part

  • public interface Part

    This class represents a part or form item that was received within a multipart/form-data POST request.

    Since:
    Servlet 3.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void delete()
      Deletes the underlying storage for a file item, including deleting any associated temporary disk file.
      String getContentType()
      Gets the content type of this part.
      String getHeader(String name)
      Returns the value of the specified mime header as a String.
      Collection<String> getHeaderNames()
      Gets the header names of this Part.
      Collection<String> getHeaders(String name)
      Gets the values of the Part header with the given name.
      InputStream getInputStream()
      Gets the content of this part as an InputStream
      String getName()
      Gets the name of this part
      long getSize()
      Returns the size of this fille.
      String getSubmittedFileName()
      Gets the file name specified by the client
      void write(String fileName)
      A convenience method to write this uploaded item to disk.

    • Method Detail

      • getInputStream

        InputStream getInputStream()
                           throws IOException
        Gets the content of this part as an InputStream
        Returns:
        The content of this part as an InputStream
        Throws:
        IOException - If an error occurs in retrieving the contet as an InputStream

      • getContentType

        String getContentType()
        Gets the content type of this part.
        Returns:
        The content type of this part.

      • getName

        String getName()
        Gets the name of this part
        Returns:
        The name of this part as a String

      • getSubmittedFileName

        String getSubmittedFileName()
        Gets the file name specified by the client
        Returns:
        the submitted file name
        Since:
        Servlet 3.1

      • getSize

        long getSize()
        Returns the size of this fille.
        Returns:
        a long specifying the size of this part, in bytes.

      • write

        void write(String fileName)
           throws IOException
        A convenience method to write this uploaded item to disk.

        This method is not guaranteed to succeed if called more than once for the same part. This allows a particular implementation to use, for example, file renaming, where possible, rather than copying all of the underlying data, thus gaining a significant performance benefit.

        Parameters:
        fileName - the name of the file to which the stream will be written. The file is created relative to the location as specified in the MultipartConfig
        Throws:
        IOException - if an error occurs.

      • delete

        void delete()
            throws IOException
        Deletes the underlying storage for a file item, including deleting any associated temporary disk file.
        Throws:
        IOException - if an error occurs.

      • getHeader

        String getHeader(String name)
        Returns the value of the specified mime header as a String. If the Part did not include a header of the specified name, this method returns null. If there are multiple headers with the same name, this method returns the first header in the part. The header name is case insensitive. You can use this method with any request header.
        Parameters:
        name - a String specifying the header name
        Returns:
        a String containing the value of the requested header, or null if the part does not have a header of that name

      • getHeaders

        Collection<String> getHeaders(String name)
        Gets the values of the Part header with the given name.

        Any changes to the returned Collection must not affect this Part.

        Part header names are case insensitive.

        Parameters:
        name - the header name whose values to return
        Returns:
        a (possibly empty) Collection of the values of the header with the given name

      • getHeaderNames

        Collection<String> getHeaderNames()
        Gets the header names of this Part.

        Some servlet containers do not allow servlets to access headers using this method, in which case this method returns null

        Any changes to the returned Collection must not affect this Part.

        Returns:
        a (possibly empty) Collection of the header names of this Part
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.servlet.http (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet.http

  • Packages that use javax.servlet.http
    Package Description
    javax.security.jacc
    This package contains the Java Authorization Contract for Containers API
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.xml.rpc.server
    This package defines APIs for the servlet based JAX-RPC endpoint model.
  • Classes in javax.servlet.http used by javax.security.jacc
    Class and Description
    HttpServletRequest
    Extends the ServletRequest interface to provide request information for HTTP servlets.
  • Classes in javax.servlet.http used by javax.servlet.http
    Class and Description
    Cookie
    Creates a cookie, a small amount of information sent by a servlet to a Web browser, saved by the browser, and later sent back to the server.
    HttpServletRequest
    Extends the ServletRequest interface to provide request information for HTTP servlets.
    HttpServletResponse
    Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response.
    HttpSession
    Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.
    HttpSessionBindingEvent
    Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.
    HttpSessionContext
    Deprecated.
    As of Java(tm) Servlet API 2.1 for security reasons, with no replacement. This interface will be removed in a future version of this API.
    HttpSessionEvent
    This is the class representing event notifications for changes to sessions within a web application.
    HttpUpgradeHandler
    This interface encapsulates the upgrade protocol processing.
    Part
    This class represents a part or form item that was received within a multipart/form-data POST request.
    WebConnection
    This interface encapsulates the connection for an upgrade request.
  • Classes in javax.servlet.http used by javax.servlet.jsp
    Class and Description
    HttpServletRequest
    Extends the ServletRequest interface to provide request information for HTTP servlets.
    HttpServletResponse
    Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response.
    HttpSession
    Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.
  • Classes in javax.servlet.http used by javax.servlet.jsp.jstl.core
    Class and Description
    HttpSession
    Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.
  • Classes in javax.servlet.http used by javax.xml.rpc.server
    Class and Description
    HttpSession
    Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WebConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.http

Interface WebConnection

  • All Superinterfaces:
    AutoCloseable

    public interface WebConnection
extends AutoCloseable
    This interface encapsulates the connection for an upgrade request. It allows the protocol handler to send service requests and status queries to the container.
    Since:
    Servlet 3.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ServletInputStream getInputStream()
      Returns an input stream for this web connection.
      ServletOutputStream getOutputStream()
      Returns an output stream for this web connection.

      • Methods inherited from interface java.lang.AutoCloseable

        close

    • Method Detail

      • getInputStream

        ServletInputStream getInputStream()
                                  throws IOException
        Returns an input stream for this web connection.
        Returns:
        a ServletInputStream for reading binary data
        Throws:
        IOException - if an I/O error occurs

      • getOutputStream

        ServletOutputStream getOutputStream()
                                    throws IOException
        Returns an output stream for this web connection.
        Returns:
        a ServletOutputStream for writing binary data
        Throws:
        IOException - if an I/O error occurs
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.servlet.http.Cookie (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.http.Cookie

  • Packages that use Cookie
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of Cookie in javax.servlet.http

      Methods in javax.servlet.http that return Cookie
      Modifier and Type Method and Description
      Cookie[] HttpServletRequestWrapper.getCookies()
      The default behavior of this method is to return getCookies() on the wrapped request object.
      Cookie[] HttpServletRequest.getCookies()
      Returns an array containing all of the Cookie objects the client sent with this request.
      Methods in javax.servlet.http with parameters of type Cookie
      Modifier and Type Method and Description
      void HttpServletResponseWrapper.addCookie(Cookie cookie)
      The default behavior of this method is to call addCookie(Cookie cookie) on the wrapped response object.
      void HttpServletResponse.addCookie(Cookie cookie)
      Adds the specified cookie to the response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.http.HttpServlet (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.http.HttpServlet

No usage of javax.servlet.http.HttpServlet
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.http.HttpServletRequestWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.http.HttpServletRequestWrapper

No usage of javax.servlet.http.HttpServletRequestWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.http.HttpServletResponseWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.http.HttpServletResponseWrapper

No usage of javax.servlet.http.HttpServletResponseWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.http.HttpSessionBindingEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.http.HttpSessionBindingEvent

  • Packages that use HttpSessionBindingEvent
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of HttpSessionBindingEvent in javax.servlet.http

      Methods in javax.servlet.http with parameters of type HttpSessionBindingEvent
      Modifier and Type Method and Description
      void HttpSessionAttributeListener.attributeAdded(HttpSessionBindingEvent event)
      Receives notification that an attribute has been added to a session.
      void HttpSessionAttributeListener.attributeRemoved(HttpSessionBindingEvent event)
      Receives notification that an attribute has been removed from a session.
      void HttpSessionAttributeListener.attributeReplaced(HttpSessionBindingEvent event)
      Receives notification that an attribute has been replaced in a session.
      void HttpSessionBindingListener.valueBound(HttpSessionBindingEvent event)
      Notifies the object that it is being bound to a session and identifies the session.
      void HttpSessionBindingListener.valueUnbound(HttpSessionBindingEvent event)
      Notifies the object that it is being unbound from a session and identifies the session.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.http.HttpSessionEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.http.HttpSessionEvent

  • Packages that use HttpSessionEvent
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of HttpSessionEvent in javax.servlet.http

      Subclasses of HttpSessionEvent in javax.servlet.http
      Modifier and Type Class and Description
      class  HttpSessionBindingEvent
      Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.
      Methods in javax.servlet.http with parameters of type HttpSessionEvent
      Modifier and Type Method and Description
      void HttpSessionListener.sessionCreated(HttpSessionEvent se)
      Receives notification that a session has been created.
      void HttpSessionListener.sessionDestroyed(HttpSessionEvent se)
      Receives notification that a session is about to be invalidated.
      void HttpSessionActivationListener.sessionDidActivate(HttpSessionEvent se)
      Notification that the session has just been activated.
      void HttpSessionIdListener.sessionIdChanged(HttpSessionEvent event, String oldSessionId)
      Receives notification that session id has been changed in a session.
      void HttpSessionActivationListener.sessionWillPassivate(HttpSessionEvent se)
      Notification that the session is about to be passivated.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.http.HttpUtils (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.http.HttpUtils

No usage of javax.servlet.http.HttpUtils
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.HttpServletRequest (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.HttpServletRequest

  • Packages that use HttpServletRequest
    Package Description
    javax.security.jacc
    This package contains the Java Authorization Contract for Containers API
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of HttpServletRequest in javax.security.jacc

      Constructors in javax.security.jacc with parameters of type HttpServletRequest
      Constructor and Description
      WebResourcePermission(HttpServletRequest request)
      Creates a new WebResourcePermission from the HttpServletRequest object.
      WebUserDataPermission(HttpServletRequest request)
      Creates a new WebUserDataPermission from the HttpServletRequest object.

    • Uses of HttpServletRequest in javax.servlet.http

      Classes in javax.servlet.http that implement HttpServletRequest
      Modifier and Type Class and Description
      class  HttpServletRequestWrapper
      Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
      Methods in javax.servlet.http with parameters of type HttpServletRequest
      Modifier and Type Method and Description
      protected void HttpServlet.doDelete(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a DELETE request.
      protected void HttpServlet.doGet(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a GET request.
      protected void HttpServlet.doHead(HttpServletRequest req, HttpServletResponse resp)
      Receives an HTTP HEAD request from the protected service method and handles the request.
      protected void HttpServlet.doOptions(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a OPTIONS request.
      protected void HttpServlet.doPost(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a POST request.
      protected void HttpServlet.doPut(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a PUT request.
      protected void HttpServlet.doTrace(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a TRACE request.
      protected long HttpServlet.getLastModified(HttpServletRequest req)
      Returns the time the HttpServletRequest object was last modified, in milliseconds since midnight January 1, 1970 GMT.
      static StringBuffer HttpUtils.getRequestURL(HttpServletRequest req)
      Deprecated.
      Reconstructs the URL the client used to make the request, using information in the HttpServletRequest object.
      protected void HttpServlet.service(HttpServletRequest req, HttpServletResponse resp)
      Receives standard HTTP requests from the public service method and dispatches them to the do XXX methods defined in this class.
      Constructors in javax.servlet.http with parameters of type HttpServletRequest
      Constructor and Description
      HttpServletRequestWrapper(HttpServletRequest request)
      Constructs a request object wrapping the given request.

    • Uses of HttpServletRequest in javax.servlet.jsp

      Methods in javax.servlet.jsp with parameters of type HttpServletRequest
      Modifier and Type Method and Description
      void HttpJspPage._jspService(HttpServletRequest request, HttpServletResponse response)
      The _jspService()method corresponds to the body of the JSP page.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.HttpServletResponse (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.HttpServletResponse

  • Packages that use HttpServletResponse
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of HttpServletResponse in javax.servlet.http

      Classes in javax.servlet.http that implement HttpServletResponse
      Modifier and Type Class and Description
      class  HttpServletResponseWrapper
      Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
      Methods in javax.servlet.http with parameters of type HttpServletResponse
      Modifier and Type Method and Description
      boolean HttpServletRequestWrapper.authenticate(HttpServletResponse response)
      The default behavior of this method is to call authenticate on the wrapped request object.
      boolean HttpServletRequest.authenticate(HttpServletResponse response)
      Use the container login mechanism configured for the ServletContext to authenticate the user making this request.
      protected void HttpServlet.doDelete(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a DELETE request.
      protected void HttpServlet.doGet(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a GET request.
      protected void HttpServlet.doHead(HttpServletRequest req, HttpServletResponse resp)
      Receives an HTTP HEAD request from the protected service method and handles the request.
      protected void HttpServlet.doOptions(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a OPTIONS request.
      protected void HttpServlet.doPost(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a POST request.
      protected void HttpServlet.doPut(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a PUT request.
      protected void HttpServlet.doTrace(HttpServletRequest req, HttpServletResponse resp)
      Called by the server (via the service method) to allow a servlet to handle a TRACE request.
      protected void HttpServlet.service(HttpServletRequest req, HttpServletResponse resp)
      Receives standard HTTP requests from the public service method and dispatches them to the do XXX methods defined in this class.
      Constructors in javax.servlet.http with parameters of type HttpServletResponse
      Constructor and Description
      HttpServletResponseWrapper(HttpServletResponse response)
      Constructs a response adaptor wrapping the given response.

    • Uses of HttpServletResponse in javax.servlet.jsp

      Methods in javax.servlet.jsp with parameters of type HttpServletResponse
      Modifier and Type Method and Description
      void HttpJspPage._jspService(HttpServletRequest request, HttpServletResponse response)
      The _jspService()method corresponds to the body of the JSP page.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.HttpSession (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.HttpSession

  • Packages that use HttpSession
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.xml.rpc.server
    This package defines APIs for the servlet based JAX-RPC endpoint model.

    • Uses of HttpSession in javax.servlet.http

      Methods in javax.servlet.http that return HttpSession
      Modifier and Type Method and Description
      HttpSession HttpSessionEvent.getSession()
      Return the session that changed.
      HttpSession HttpSessionBindingEvent.getSession()
      Return the session that changed.
      HttpSession HttpServletRequestWrapper.getSession()
      The default behavior of this method is to return getSession() on the wrapped request object.
      HttpSession HttpServletRequest.getSession()
      Returns the current session associated with this request, or if the request does not have a session, creates one.
      HttpSession HttpServletRequestWrapper.getSession(boolean create)
      The default behavior of this method is to return getSession(boolean create) on the wrapped request object.
      HttpSession HttpServletRequest.getSession(boolean create)
      Returns the current HttpSession associated with this request or, if there is no current session and create is true, returns a new session.
      HttpSession HttpSessionContext.getSession(String sessionId)
      Deprecated.
      As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.
      Constructors in javax.servlet.http with parameters of type HttpSession
      Constructor and Description
      HttpSessionBindingEvent(HttpSession session, String name)
      Constructs an event that notifies an object that it has been bound to or unbound from a session.
      HttpSessionBindingEvent(HttpSession session, String name, Object value)
      Constructs an event that notifies an object that it has been bound to or unbound from a session.
      HttpSessionEvent(HttpSession source)
      Construct a session event from the given source.

    • Uses of HttpSession in javax.servlet.jsp

      Methods in javax.servlet.jsp that return HttpSession
      Modifier and Type Method and Description
      abstract HttpSession PageContext.getSession()
      The current value of the session object (an HttpSession).

    • Uses of HttpSession in javax.servlet.jsp.jstl.core

      Methods in javax.servlet.jsp.jstl.core with parameters of type HttpSession
      Modifier and Type Method and Description
      static Object Config.get(HttpSession session, String name)
      Looks up a configuration variable in the "session" scope.
      static void Config.remove(HttpSession session, String name)
      Removes a configuration variable from the "session" scope.
      static void Config.set(HttpSession session, String name, Object value)
      Sets the value of a configuration variable in the "session" scope.

    • Uses of HttpSession in javax.xml.rpc.server

      Methods in javax.xml.rpc.server that return HttpSession
      Modifier and Type Method and Description
      HttpSession ServletEndpointContext.getHttpSession()
      The getHttpSession method returns the current HTTP session (as a javax.servlet.http.HTTPSession).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.HttpSessionActivationListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.HttpSessionActivationListener

No usage of javax.servlet.http.HttpSessionActivationListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.HttpSessionAttributeListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.HttpSessionAttributeListener

No usage of javax.servlet.http.HttpSessionAttributeListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.HttpSessionBindingListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.HttpSessionBindingListener

No usage of javax.servlet.http.HttpSessionBindingListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.HttpSessionContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.HttpSessionContext

  • Packages that use HttpSessionContext
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of HttpSessionContext in javax.servlet.http

      Methods in javax.servlet.http that return HttpSessionContext
      Modifier and Type Method and Description
      HttpSessionContext HttpSession.getSessionContext()
      Deprecated.
      As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.HttpSessionIdListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.HttpSessionIdListener

No usage of javax.servlet.http.HttpSessionIdListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.HttpSessionListener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.HttpSessionListener

No usage of javax.servlet.http.HttpSessionListener
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.HttpUpgradeHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.HttpUpgradeHandler

  • Packages that use HttpUpgradeHandler
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of HttpUpgradeHandler in javax.servlet.http

      Methods in javax.servlet.http with type parameters of type HttpUpgradeHandler
      Modifier and Type Method and Description
      <T extends HttpUpgradeHandler>
      T             		HttpServletRequestWrapper.upgrade(Class<T> handlerClass)
      Create an instance of HttpUpgradeHandler for an given class and uses it for the http protocol upgrade processing.
      <T extends HttpUpgradeHandler>
      T             		HttpServletRequest.upgrade(Class<T> handlerClass)
      Create an instance of HttpUpgradeHandler for an given class and uses it for the http protocol upgrade processing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.Part (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.Part

  • Packages that use Part
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of Part in javax.servlet.http

      Methods in javax.servlet.http that return Part
      Modifier and Type Method and Description
      Part HttpServletRequestWrapper.getPart(String name)
      The default behavior of this method is to call getPart on the wrapped request object.
      Part HttpServletRequest.getPart(String name)
      Gets the Part with the given name.
      Methods in javax.servlet.http that return types with arguments of type Part
      Modifier and Type Method and Description
      Collection<Part> HttpServletRequestWrapper.getParts()
      The default behavior of this method is to call getParts on the wrapped request object.
      Collection<Part> HttpServletRequest.getParts()
      Gets all the Part components of this request, provided that it is of type multipart/form-data.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.http.WebConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.http.WebConnection

  • Packages that use WebConnection
    Package Description
    javax.servlet.http
    The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

    • Uses of WebConnection in javax.servlet.http

      Methods in javax.servlet.http with parameters of type WebConnection
      Modifier and Type Method and Description
      void HttpUpgradeHandler.init(WebConnection wc)
      It is called once the HTTP Upgrade process has been completed and the upgraded connection is ready to start using the new protocol.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ErrorData (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Class ErrorData

  • java.lang.Object
    • javax.servlet.jsp.ErrorData

  • public final class ErrorData
extends Object
    Contains information about an error, for error pages. The information contained in this instance is meaningless if not used in the context of an error page. To indicate a JSP is an error page, the page author must set the isErrorPage attribute of the page directive to "true".
    Since:
    JSP 2.0
    See Also:
    PageContext.getErrorData()

    • Constructor Summary

      Constructors
      Constructor and Description
      ErrorData(Throwable throwable, int statusCode, String uri, String servletName)
      Creates a new ErrorData object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getRequestURI()
      Returns the request URI.
      String getServletName()
      Returns the name of the servlet invoked.
      int getStatusCode()
      Returns the status code of the error.
      Throwable getThrowable()
      Returns the Throwable that caused the error.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ErrorData

        public ErrorData(Throwable throwable,
         int statusCode,
         String uri,
         String servletName)
        Creates a new ErrorData object.
        Parameters:
        throwable - The Throwable that is the cause of the error
        statusCode - The status code of the error
        uri - The request URI
        servletName - The name of the servlet invoked

    • Method Detail

      • getThrowable

        public Throwable getThrowable()
        Returns the Throwable that caused the error.
        Returns:
        The Throwable that caused the error

      • getStatusCode

        public int getStatusCode()
        Returns the status code of the error.
        Returns:
        The status code of the error

      • getRequestURI

        public String getRequestURI()
        Returns the request URI.
        Returns:
        The request URI

      • getServletName

        public String getServletName()
        Returns the name of the servlet invoked.
        Returns:
        The name of the servlet invoked
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpJspPage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Interface HttpJspPage

  • All Superinterfaces:
    JspPage, Servlet

    public interface HttpJspPage
extends JspPage
    The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.

    The behaviour is identical to that of the JspPage, except for the signature of the _jspService method, which is now expressible in the Java type system and included explicitly in the interface.

    See Also:
    JspPage

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void _jspService(HttpServletRequest request, HttpServletResponse response)
      The _jspService()method corresponds to the body of the JSP page.

      • Methods inherited from interface javax.servlet.jsp.JspPage

        jspDestroy, jspInit

      • Methods inherited from interface javax.servlet.Servlet

        destroy, getServletConfig, getServletInfo, init, service

    • Method Detail

      • _jspService

        void _jspService(HttpServletRequest request,
               HttpServletResponse response)
                 throws ServletException,
                        IOException
        The _jspService()method corresponds to the body of the JSP page. This method is defined automatically by the JSP container and should never be defined by the JSP page author.

        If a superclass is specified using the extends attribute, that superclass may choose to perform some actions in its service() method before or after calling the _jspService() method. See using the extends attribute in the JSP_Engine chapter of the JSP specification.

        Parameters:
        request - Provides client request information to the JSP.
        response - Assists the JSP in sending a response to the client.
        Throws:
        ServletException - Thrown if an error occurred during the processing of the JSP and that the container should take appropriate action to clean up the request.
        IOException - Thrown if an error occurred while writing the response for this page.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.servlet.jsp (Java(TM) EE 7 Specification APIs)

javax.servlet.jsp

Interfaces

  • HttpJspPage
  • JspApplicationContext
  • JspPage

Classes

  • ErrorData
  • JspContext
  • JspEngineInfo
  • JspFactory
  • JspWriter
  • PageContext

Exceptions

  • JspException
  • JspTagException
  • SkipPageException


javax.servlet.jsp (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet.jsp

Classes and interfaces for the Core JSP 2.3 API.

See: Description

  • Interface Summary
    Interface Description
    HttpJspPage
    The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.
    JspApplicationContext
    Stores application-scoped information relevant to JSP containers.
    JspPage
    The JspPage interface describes the generic interaction that a JSP Page Implementation class must satisfy; pages that use the HTTP protocol are described by the HttpJspPage interface.
  • Class Summary
    Class Description
    ErrorData
    Contains information about an error, for error pages.
    JspContext
    JspContext serves as the base class for the PageContext class and abstracts all information that is not specific to servlets.
    JspEngineInfo
    The JspEngineInfo is an abstract class that provides information on the current JSP engine.
    JspFactory
    The JspFactory is an abstract class that defines a number of factory methods available to a JSP page at runtime for the purposes of creating instances of various interfaces and classes used to support the JSP implementation.
    JspWriter
    The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.
    PageContext
    PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.
  • Exception Summary
    Exception Description
    JspException
    A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.
    JspTagException
    Exception to be used by a Tag Handler to indicate some unrecoverable error.
    SkipPageException
    Exception to indicate the calling page must cease evaluation.

Package javax.servlet.jsp Description

Classes and interfaces for the Core JSP 2.3 API.

The javax.servlet.jsp package contains a number of classes and interfaces that describe and define the contracts between a JSP page implementation class and the runtime environment provided for an instance of such a class by a conforming JSP container.

JSP Page Implementation Object Contract

This section describes the basic contract between a JSP Page implementation object and its container.

The main contract is defined by the classes JspPage and HttpJspPage. The JspFactory class describes the mechanism to portably instantiate all needed runtime objects, and JspEngineInfo provides basic information on the current JSP container. Class JspApplicationContext stores application-scoped information relevant to JSP containers. It was added in JSP 2.1 to support the integration of the unified Expression Language.

None of these classes are intended to be used by JSP page authors; an example of how these classes may be used is included below.

Implicit Objects

The PageContext object and the JspWriter are available by default as implicit objects.

Exceptions

The JspException class is the base class for all JSP exceptions. The JspTagException and SkipPageException exceptions are used by the tag extension mechanism.

For JSP error pages, the ErrorData class encapsulates information about the error.

An Implementation Example

An instance of an implementation dependent subclass of the PageContext abstract base class can be created by a JSP implementation class at the beginning of it's _jspService() method via an implementation default JspFactory.

Here is one example of how to use these classes

 public class foo implements Servlet {

 // ...

public void _jspService(HttpServletRequest request,
                        HttpServletResponse response)
       throws IOException, ServletException {

    JspFactory  factory     = JspFactory.getDefaultFactory();
    PageContext pageContext = factory.getPageContext(
                                        this,
                                        request,
                                        response,
                                        null,  // errorPageURL
                                        false, // needsSession
                                        JspWriter.DEFAULT_BUFFER,
                                        true   // autoFlush
                                );

    // initialize implicit variables for scripting env ...

    HttpSession session = pageContext.getSession();
    JspWriter   out     = pageContext.getOut();
    Object      page    = this;

    try {
        // body of translated JSP here ...
    } catch (Exception e) {
        out.clear();
        pageContext.handlePageException(e);
    } finally {
        out.close();
          factory.releasePageContext(pageContext);
    }
}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet.jsp Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet.jsp

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.jsp.ErrorData
    • javax.servlet.jsp.JspContext
      • javax.servlet.jsp.PageContext
    • javax.servlet.jsp.JspEngineInfo
    • javax.servlet.jsp.JspFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.servlet.jsp.JspException
          • javax.servlet.jsp.JspTagException
          • javax.servlet.jsp.SkipPageException
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • javax.servlet.jsp.JspWriter

Interface Hierarchy

  • javax.servlet.jsp.JspApplicationContext
  • javax.servlet.Servlet
    • javax.servlet.jsp.JspPage
      • javax.servlet.jsp.HttpJspPage
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JspApplicationContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Interface JspApplicationContext

  • public interface JspApplicationContext
    Stores application-scoped information relevant to JSP containers.

    The JSP container must create a single instance of JspApplicationContext for each ServletContext instance.

    An instance of JspApplicationContext is obtained by invoking the static JspFactory.getJspApplicationContext(javax.servlet.ServletContext) method, passing the ServletContext of the corresponding web application.

    The JspApplicationContext provides the following services to JSP applications:

    • Allows registration of ELResolvers, which are used to resolve variables in EL expressions contained in JSP pages and tag files.
    • Provides an instance of ExpressionFactory for those applications or frameworks that need to perform programmatic evaluation of EL expressions instead of allowing the JSP container to do it for them.
    • Allows the attachment of ELContextListener instances for notification whenever a new ELContext is created. This is necessary when an application wishes to make custom context objects available to their pluggable ELResolvers.

    Since:
    JSP 2.1
    See Also:
    ServletContext, JspFactory, ELResolver, ExpressionFactory, ELContextListener

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addELContextListener(ELContextListener listener)
      Registers a ELContextListeners so that context objects can be added whenever a new ELContext is created.
      void addELResolver(ELResolver resolver)
      Adds an ELResolver to affect the way EL variables and properties are resolved for EL expressions appearing in JSP pages and tag files.
      ExpressionFactory getExpressionFactory()
      Returns a factory used to create ValueExpressions and MethodExpressions so that EL expressions can be parsed and evaluated.

    • Method Detail

      • addELResolver

        void addELResolver(ELResolver resolver)
        Adds an ELResolver to affect the way EL variables and properties are resolved for EL expressions appearing in JSP pages and tag files.

        For example, in the EL expression ${employee.lastName}, an ELResolver determines what object "employee" references and how to find its "lastName" property.

        When evaluating an expression, the JSP container will consult a set of standard resolvers as well as any resolvers registered via this method. The set of resolvers are consulted in the following order:

        • ImplicitObjectELResolver
        • ELResolvers registered via this method, in the order in which they are registered.
        • MapELResolver
        • ListELResolver
        • ArrayELResolver
        • BeanELResolver
        • ScopedAttributeELResolver

        It is illegal to register an ELResolver after the application has received any request from the client. If an attempt is made to register an ELResolver after that time, an IllegalStateException is thrown.

        This restriction is in place to allow the JSP container to optimize for the common case where no additional ELResolvers are in the chain, aside from the standard ones. It is permissible to add ELResolvers before or after initialization to a CompositeELResolver that is already in the chain.

        It is not possible to remove an ELResolver registered with this method, once it has been registered.

        Parameters:
        resolver - The new ELResolver
        Throws:
        IllegalStateException - if an attempt is made to call this method after all ServletContextListeners have had their contextInitialized methods invoked.

      • getExpressionFactory

        ExpressionFactory getExpressionFactory()
        Returns a factory used to create ValueExpressions and MethodExpressions so that EL expressions can be parsed and evaluated.
        Returns:
        A concrete implementation of the an ExpressionFactory.

      • addELContextListener

        void addELContextListener(ELContextListener listener)
        Registers a ELContextListeners so that context objects can be added whenever a new ELContext is created.

        At a minimum, the ELContext objects created will contain a reference to the JspContext for this request, which is added by the JSP container. This is sufficient for all the default ELResolvers listed in addELResolver(javax.el.ELResolver). Note that JspContext.class is used as the key to ELContext.putContext() for the JspContext object reference.

        This method is generally used by frameworks and applications that register their own ELResolver that needs context other than JspContext. The listener will typically add the necessary context to the ELContext provided in the event object. Registering a listener that adds context allows the ELResolvers in the stack to access the context they need when they do a resolution.

        Parameters:
        listener - The listener to be notified when a new ELContext is created.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JspContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Class JspContext

  • java.lang.Object
    • javax.servlet.jsp.JspContext
  • Direct Known Subclasses:
    PageContext

    public abstract class JspContext
extends Object

    JspContext serves as the base class for the PageContext class and abstracts all information that is not specific to servlets. This allows for Simple Tag Extensions to be used outside of the context of a request/response Servlet.

    The JspContext provides a number of facilities to the page/component author and page implementor, including:

    • a single API to manage the various scoped namespaces
    • a mechanism to obtain the JspWriter for output
    • a mechanism to expose page directive attributes to the scripting environment

    Methods Intended for Container Generated Code

    The following methods enable the management of nested JspWriter streams to implement Tag Extensions: pushBody() and popBody()

    Methods Intended for JSP authors

    Some methods provide uniform access to the diverse objects representing scopes. The implementation must use the underlying machinery corresponding to that scope, so information can be passed back and forth between the underlying environment (e.g. Servlets) and JSP pages. The methods are: setAttribute(), getAttribute(), findAttribute(), removeAttribute(), getAttributesScope() and getAttributeNamesInScope().

    The following methods provide convenient access to implicit objects: getOut()

    The following methods provide programmatic access to the Expression Language evaluator: getExpressionEvaluator(), getVariableResolver()

    Since:
    JSP 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      JspContext()
      Sole constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Object findAttribute(String name)
      Searches for the named attribute in page, request, session (if valid), and application scope(s) in order and returns the value associated or null.
      abstract Object getAttribute(String name)
      Returns the object associated with the name in the page scope or null if not found.
      abstract Object getAttribute(String name, int scope)
      Return the object associated with the name in the specified scope or null if not found.
      abstract Enumeration<String> getAttributeNamesInScope(int scope)
      Enumerate all the attributes in a given scope.
      abstract int getAttributesScope(String name)
      Get the scope where a given attribute is defined.
      abstract ELContext getELContext()
      Returns the ELContext associated with this JspContext.
      abstract ExpressionEvaluator getExpressionEvaluator()
      Deprecated.
      As of JSP 2.1, replaced by JspApplicationContext.getExpressionFactory()
      abstract JspWriter getOut()
      The current value of the out object (a JspWriter).
      abstract VariableResolver getVariableResolver()
      Deprecated.
      As of JSP 2.1, replaced by ELContext.getELResolver(), which can be obtained by jspContext.getELContext().getELResolver().
      JspWriter popBody()
      Return the previous JspWriter "out" saved by the matching pushBody(), and update the value of the "out" attribute in the page scope attribute namespace of the JspContext.
      JspWriter pushBody(Writer writer)
      Return a new JspWriter object that sends output to the provided Writer.
      abstract void removeAttribute(String name)
      Remove the object reference associated with the given name from all scopes.
      abstract void removeAttribute(String name, int scope)
      Remove the object reference associated with the specified name in the given scope.
      abstract void setAttribute(String name, Object value)
      Register the name and value specified with page scope semantics.
      abstract void setAttribute(String name, Object value, int scope)
      Register the name and value specified with appropriate scope semantics.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JspContext

        public JspContext()
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • Method Detail

      • setAttribute

        public abstract void setAttribute(String name,
                Object value)
        Register the name and value specified with page scope semantics. If the value passed in is null, this has the same effect as calling removeAttribute( name, PageContext.PAGE_SCOPE ).
        Parameters:
        name - the name of the attribute to set
        value - the value to associate with the name, or null if the attribute is to be removed from the page scope.
        Throws:
        NullPointerException - if the name is null

      • setAttribute

        public abstract void setAttribute(String name,
                Object value,
                int scope)
        Register the name and value specified with appropriate scope semantics. If the value passed in is null, this has the same effect as calling removeAttribute( name, scope ).
        Parameters:
        name - the name of the attribute to set
        value - the object to associate with the name, or null if the attribute is to be removed from the specified scope.
        scope - the scope with which to associate the name/object
        Throws:
        NullPointerException - if the name is null
        IllegalArgumentException - if the scope is invalid
        IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.

      • getAttribute

        public abstract Object getAttribute(String name)
        Returns the object associated with the name in the page scope or null if not found.
        Parameters:
        name - the name of the attribute to get
        Returns:
        the object associated with the name in the page scope or null if not found.
        Throws:
        NullPointerException - if the name is null

      • getAttribute

        public abstract Object getAttribute(String name,
                  int scope)
        Return the object associated with the name in the specified scope or null if not found.
        Parameters:
        name - the name of the attribute to set
        scope - the scope with which to associate the name/object
        Returns:
        the object associated with the name in the specified scope or null if not found.
        Throws:
        NullPointerException - if the name is null
        IllegalArgumentException - if the scope is invalid
        IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.

      • findAttribute

        public abstract Object findAttribute(String name)
        Searches for the named attribute in page, request, session (if valid), and application scope(s) in order and returns the value associated or null.
        Parameters:
        name - the name of the attribute to search for
        Returns:
        the value associated or null
        Throws:
        NullPointerException - if the name is null

      • removeAttribute

        public abstract void removeAttribute(String name)
        Remove the object reference associated with the given name from all scopes. Does nothing if there is no such object.
        Parameters:
        name - The name of the object to remove.
        Throws:
        NullPointerException - if the name is null

      • removeAttribute

        public abstract void removeAttribute(String name,
                   int scope)
        Remove the object reference associated with the specified name in the given scope. Does nothing if there is no such object.
        Parameters:
        name - The name of the object to remove.
        scope - The scope where to look.
        Throws:
        IllegalArgumentException - if the scope is invalid
        IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.
        NullPointerException - if the name is null

      • getAttributesScope

        public abstract int getAttributesScope(String name)
        Get the scope where a given attribute is defined.
        Parameters:
        name - the name of the attribute to return the scope for
        Returns:
        the scope of the object associated with the name specified or 0
        Throws:
        NullPointerException - if the name is null

      • getAttributeNamesInScope

        public abstract Enumeration<String> getAttributeNamesInScope(int scope)
        Enumerate all the attributes in a given scope.
        Parameters:
        scope - the scope to enumerate all the attributes for
        Returns:
        an enumeration of names (java.lang.String) of all the attributes the specified scope
        Throws:
        IllegalArgumentException - if the scope is invalid
        IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.

      • getOut

        public abstract JspWriter getOut()
        The current value of the out object (a JspWriter).
        Returns:
        the current JspWriter stream being used for client response

      • getExpressionEvaluator

        public abstract ExpressionEvaluator getExpressionEvaluator()
        Deprecated. As of JSP 2.1, replaced by JspApplicationContext.getExpressionFactory()
        Provides programmatic access to the ExpressionEvaluator. The JSP Container must return a valid instance of an ExpressionEvaluator that can parse EL expressions.
        Returns:
        A valid instance of an ExpressionEvaluator.
        Since:
        JSP 2.0

      • getVariableResolver

        public abstract VariableResolver getVariableResolver()
        Deprecated. As of JSP 2.1, replaced by ELContext.getELResolver(), which can be obtained by jspContext.getELContext().getELResolver().
        Returns an instance of a VariableResolver that provides access to the implicit objects specified in the JSP specification using this JspContext as the context object.
        Returns:
        A valid instance of a VariableResolver.
        Since:
        JSP 2.0

      • getELContext

        public abstract ELContext getELContext()
        Returns the ELContext associated with this JspContext.

        The ELContext is created lazily and is reused if it already exists. There is a new ELContext for each JspContext.

        The ELContext must contain the ELResolver described in the JSP specification (and in the javadocs for JspApplicationContext.addELResolver(javax.el.ELResolver)).

        Returns:
        The ELContext associated with this JspContext.
        Since:
        JSP 2.1

      • pushBody

        public JspWriter pushBody(Writer writer)
        Return a new JspWriter object that sends output to the provided Writer. Saves the current "out" JspWriter, and updates the value of the "out" attribute in the page scope attribute namespace of the JspContext.

        The returned JspWriter must implement all methods and behave as though it were unbuffered. More specifically:

        • clear() must throw an IOException
        • clearBuffer() does nothing
        • getBufferSize() always returns 0
        • getRemaining() always returns 0

        Parameters:
        writer - The Writer for the returned JspWriter to send output to.
        Returns:
        a new JspWriter that writes to the given Writer.
        Since:
        JSP 2.0

      • popBody

        public JspWriter popBody()
        Return the previous JspWriter "out" saved by the matching pushBody(), and update the value of the "out" attribute in the page scope attribute namespace of the JspContext.
        Returns:
        the saved JspWriter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JspEngineInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Class JspEngineInfo

  • java.lang.Object
    • javax.servlet.jsp.JspEngineInfo

  • public abstract class JspEngineInfo
extends Object
    The JspEngineInfo is an abstract class that provides information on the current JSP engine.

    • Constructor Summary

      Constructors
      Constructor and Description
      JspEngineInfo()
      Sole constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract String getSpecificationVersion()
      Return the version number of the JSP specification that is supported by this JSP engine.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JspEngineInfo

        public JspEngineInfo()
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • Method Detail

      • getSpecificationVersion

        public abstract String getSpecificationVersion()
        Return the version number of the JSP specification that is supported by this JSP engine.

        Specification version numbers that consists of positive decimal integers separated by periods ".", for example, "2.0" or "1.2.3.4.5.6.7". This allows an extensible number to be used to represent major, minor, micro, etc versions. The version number must begin with a number.

        Returns:
        the specification version, null is returned if it is not known
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JspException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Class JspException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.servlet.jsp.JspException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    JspTagException, SkipPageException

    public class JspException
extends Exception
    A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JspException()
      Construct a JspException.
      JspException(String msg)
      Constructs a new JSP exception with the specified message.
      JspException(String message, Throwable cause)
      Constructs a new JspException with the specified detail message and cause.
      JspException(Throwable cause)
      Constructs a new JspException with the specified cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getRootCause()
      Deprecated.
      As of JSP 2.1, replaced by Throwable.getCause()

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JspException

        public JspException()
        Construct a JspException.

      • JspException

        public JspException(String msg)
        Constructs a new JSP exception with the specified message. The message can be written to the server log and/or displayed for the user.
        Parameters:
        msg - a String specifying the text of the exception message

      • JspException

        public JspException(String message,
            Throwable cause)
        Constructs a new JspException with the specified detail message and cause. The cause is saved for later retrieval by the Throwable.getCause() and getRootCause() methods.
        See Also:
        Exception.Exception(String, Throwable)

      • JspException

        public JspException(Throwable cause)
        Constructs a new JspException with the specified cause. The cause is saved for later retrieval by the Throwable.getCause() and getRootCause() methods.
        See Also:
        Exception.Exception(Throwable)

    • Method Detail

      • getRootCause

        public Throwable getRootCause()
        Deprecated. As of JSP 2.1, replaced by Throwable.getCause()
        Returns the exception that caused this JSP exception.
        Returns:
        the Throwable that caused this JSP exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JspFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Class JspFactory

  • java.lang.Object
    • javax.servlet.jsp.JspFactory

  • public abstract class JspFactory
extends Object

    The JspFactory is an abstract class that defines a number of factory methods available to a JSP page at runtime for the purposes of creating instances of various interfaces and classes used to support the JSP implementation.

    A conformant JSP Engine implementation will, during it's initialization instantiate an implementation dependent subclass of this class, and make it globally available for use by JSP implementation classes by registering the instance created with this class via the static setDefaultFactory() method.

    The only implementation-dependent classes that can be created from the factory are: PageContext, JspEngineInfo, and JspApplicationContext.

    With the exception of JspApplicationContext, JspFactory objects should not be used by JSP application developers.

    • Constructor Summary

      Constructors
      Constructor and Description
      JspFactory()
      Sole constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static JspFactory getDefaultFactory()
      Returns the default factory for this implementation.
      abstract JspEngineInfo getEngineInfo()
      called to get implementation-specific information on the current JSP engine.
      abstract JspApplicationContext getJspApplicationContext(ServletContext context)
      Obtains the JspApplicationContext instance associated with the web application for the given ServletContext.
      abstract PageContext getPageContext(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int buffer, boolean autoflush)
      obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.
      abstract void releasePageContext(PageContext pc)
      called to release a previously allocated PageContext object.
      static void setDefaultFactory(JspFactory deflt)
      set the default factory for this implementation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JspFactory

        public JspFactory()
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • Method Detail

      • setDefaultFactory

        public static void setDefaultFactory(JspFactory deflt)

        set the default factory for this implementation. It is illegal for any principal other than the JSP Engine runtime to call this method.

        Parameters:
        deflt - The default factory implementation

      • getDefaultFactory

        public static JspFactory getDefaultFactory()
        Returns the default factory for this implementation.
        Returns:
        the default factory for this implementation

      • getPageContext

        public abstract PageContext getPageContext(Servlet servlet,
                         ServletRequest request,
                         ServletResponse response,
                         String errorPageURL,
                         boolean needsSession,
                         int buffer,
                         boolean autoflush)

        obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.

        This method is typically called early in the processing of the _jspService() method of a JSP implementation class in order to obtain a PageContext object for the request being processed.

        Invoking this method shall result in the PageContext.initialize() method being invoked. The PageContext returned is properly initialized.

        All PageContext objects obtained via this method shall be released by invoking releasePageContext().

        Parameters:
        servlet - the requesting servlet
        request - the current request pending on the servlet
        response - the current response pending on the servlet
        errorPageURL - the URL of the error page for the requesting JSP, or null
        needsSession - true if the JSP participates in a session
        buffer - size of buffer in bytes, JspWriter.NO_BUFFER if no buffer, JspWriter.DEFAULT_BUFFER if implementation default.
        autoflush - should the buffer autoflush to the output stream on buffer overflow, or throw an IOException?
        Returns:
        the page context
        See Also:
        PageContext

      • releasePageContext

        public abstract void releasePageContext(PageContext pc)

        called to release a previously allocated PageContext object. Results in PageContext.release() being invoked. This method should be invoked prior to returning from the _jspService() method of a JSP implementation class.

        Parameters:
        pc - A PageContext previously obtained by getPageContext()

      • getEngineInfo

        public abstract JspEngineInfo getEngineInfo()

        called to get implementation-specific information on the current JSP engine.

        Returns:
        a JspEngineInfo object describing the current JSP engine

      • getJspApplicationContext

        public abstract JspApplicationContext getJspApplicationContext(ServletContext context)
        Obtains the JspApplicationContext instance associated with the web application for the given ServletContext.
        Parameters:
        context - The ServletContext for the web application the desired JspApplicationContext is associated with.
        Returns:
        The JspApplicationContext associated with the web application.
        Since:
        2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JspPage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Interface JspPage

  • All Superinterfaces:
    Servlet
    All Known Subinterfaces:
    HttpJspPage

    public interface JspPage
extends Servlet
    The JspPage interface describes the generic interaction that a JSP Page Implementation class must satisfy; pages that use the HTTP protocol are described by the HttpJspPage interface.

    Two plus One Methods

    The interface defines a protocol with 3 methods; only two of them: jspInit() and jspDestroy() are part of this interface as the signature of the third method: _jspService() depends on the specific protocol used and cannot be expressed in a generic way in Java.

    A class implementing this interface is responsible for invoking the above methods at the appropriate time based on the corresponding Servlet-based method invocations.

    The jspInit() and jspDestroy() methods can be defined by a JSP author, but the _jspService() method is defined automatically by the JSP processor based on the contents of the JSP page.

    _jspService()

    The _jspService()method corresponds to the body of the JSP page. This method is defined automatically by the JSP container and should never be defined by the JSP page author.

    If a superclass is specified using the extends attribute, that superclass may choose to perform some actions in its service() method before or after calling the _jspService() method. See using the extends attribute in the JSP_Engine chapter of the JSP specification.

    The specific signature depends on the protocol supported by the JSP page.

     public void _jspService(ServletRequestSubtype request,
                             ServletResponseSubtype response)
        throws ServletException, IOException;

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void jspDestroy()
      The jspDestroy() method is invoked when the JSP page is about to be destroyed.
      void jspInit()
      The jspInit() method is invoked when the JSP page is initialized.

      • Methods inherited from interface javax.servlet.Servlet

        destroy, getServletConfig, getServletInfo, init, service

    • Method Detail

      • jspInit

        void jspInit()
        The jspInit() method is invoked when the JSP page is initialized. It is the responsibility of the JSP implementation (and of the class mentioned by the extends attribute, if present) that at this point invocations to the getServletConfig() method will return the desired value. A JSP page can override this method by including a definition for it in a declaration element. A JSP page should redefine the init() method from Servlet.

      • jspDestroy

        void jspDestroy()
        The jspDestroy() method is invoked when the JSP page is about to be destroyed. A JSP page can override this method by including a definition for it in a declaration element. A JSP page should redefine the destroy() method from Servlet.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JspTagException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Class JspTagException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.servlet.jsp.JspException
          • javax.servlet.jsp.JspTagException
  • All Implemented Interfaces:
    Serializable

    public class JspTagException
extends JspException
    Exception to be used by a Tag Handler to indicate some unrecoverable error. This error is to be caught by the top level of the JSP page and will result in an error page.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JspTagException()
      Constructs a new JspTagException with no message.
      JspTagException(String msg)
      Constructs a new JspTagException with the specified message.
      JspTagException(String message, Throwable rootCause)
      Constructs a new JspTagException when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
      JspTagException(Throwable rootCause)
      Constructs a new JSP Tag exception when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.

    • Method Summary

      • Methods inherited from class javax.servlet.jsp.JspException

        getRootCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JspTagException

        public JspTagException(String msg)
        Constructs a new JspTagException with the specified message. The message can be written to the server log and/or displayed for the user.
        Parameters:
        msg - a String specifying the text of the exception message

      • JspTagException

        public JspTagException()
        Constructs a new JspTagException with no message.

      • JspTagException

        public JspTagException(String message,
               Throwable rootCause)
        Constructs a new JspTagException when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
        Parameters:
        message - a String containing the text of the exception message
        rootCause - the Throwable exception that interfered with the JSP Tag's normal operation, making this JSP Tag exception necessary
        Since:
        JSP 2.0

      • JspTagException

        public JspTagException(Throwable rootCause)
        Constructs a new JSP Tag exception when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation. The exception's message is based on the localized message of the underlying exception.

        This method calls the getLocalizedMessage method on the Throwable exception to get a localized exception message. When subclassing JspTagException, this method can be overridden to create an exception message designed for a specific locale.

        Parameters:
        rootCause - the Throwable exception that interfered with the JSP Tag's normal operation, making the JSP Tag exception necessary
        Since:
        JSP 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JspWriter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Class JspWriter

  • java.lang.Object
    • java.io.Writer
      • javax.servlet.jsp.JspWriter
  • All Implemented Interfaces:
    Closeable, Flushable, Appendable, AutoCloseable
    Direct Known Subclasses:
    BodyContent

    public abstract class JspWriter
extends Writer

    The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.

    This abstract class emulates some of the functionality found in the java.io.BufferedWriter and java.io.PrintWriter classes, however it differs in that it throws java.io.IOException from the print methods while PrintWriter does not.

    Buffering

    The initial JspWriter object is associated with the PrintWriter object of the ServletResponse in a way that depends on whether the page is or is not buffered. If the page is not buffered, output written to this JspWriter object will be written through to the PrintWriter directly, which will be created if necessary by invoking the getWriter() method on the response object. But if the page is buffered, the PrintWriter object will not be created until the buffer is flushed and operations like setContentType() are legal. Since this flexibility simplifies programming substantially, buffering is the default for JSP pages.

    Buffering raises the issue of what to do when the buffer is exceeded. Two approaches can be taken:

    • Exceeding the buffer is not a fatal error; when the buffer is exceeded, just flush the output.
    • Exceeding the buffer is a fatal error; when the buffer is exceeded, raise an exception.

    Both approaches are valid, and thus both are supported in the JSP technology. The behavior of a page is controlled by the autoFlush attribute, which defaults to true. In general, JSP pages that need to be sure that correct and complete data has been sent to their client may want to set autoFlush to false, with a typical case being that where the client is an application itself. On the other hand, JSP pages that send data that is meaningful even when partially constructed may want to set autoFlush to true; such as when the data is sent for immediate display through a browser. Each application will need to consider their specific needs.

    An alternative considered was to make the buffer size unbounded; but, this had the disadvantage that runaway computations would consume an unbounded amount of resources.

    The "out" implicit variable of a JSP implementation class is of this type. If the page directive selects autoflush="true" then all the I/O operations on this class shall automatically flush the contents of the buffer if an overflow condition would result if the current operation were performed without a flush. If autoflush="false" then all the I/O operations on this class shall throw an IOException if performing the current operation would result in a buffer overflow condition.

    See Also:
    Writer, BufferedWriter, PrintWriter

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean autoFlush
      Whether the JspWriter is autoflushing.
      protected int bufferSize
      The size of the buffer used by the JspWriter.
      static int DEFAULT_BUFFER
      Constant indicating that the Writer is buffered and is using the implementation default buffer size.
      static int NO_BUFFER
      Constant indicating that the Writer is not buffering output.
      static int UNBOUNDED_BUFFER
      Constant indicating that the Writer is buffered and is unbounded; this is used in BodyContent.

      • Fields inherited from class java.io.Writer

        lock

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected JspWriter(int bufferSize, boolean autoFlush)
      Protected constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void clear()
      Clear the contents of the buffer.
      abstract void clearBuffer()
      Clears the current contents of the buffer.
      abstract void close()
      Close the stream, flushing it first.
      abstract void flush()
      Flush the stream.
      int getBufferSize()
      This method returns the size of the buffer used by the JspWriter.
      abstract int getRemaining()
      This method returns the number of unused bytes in the buffer.
      boolean isAutoFlush()
      This method indicates whether the JspWriter is autoFlushing.
      abstract void newLine()
      Write a line separator.
      abstract void print(boolean b)
      Print a boolean value.
      abstract void print(char c)
      Print a character.
      abstract void print(char[] s)
      Print an array of characters.
      abstract void print(double d)
      Print a double-precision floating-point number.
      abstract void print(float f)
      Print a floating-point number.
      abstract void print(int i)
      Print an integer.
      abstract void print(long l)
      Print a long integer.
      abstract void print(Object obj)
      Print an object.
      abstract void print(String s)
      Print a string.
      abstract void println()
      Terminate the current line by writing the line separator string.
      abstract void println(boolean x)
      Print a boolean value and then terminate the line.
      abstract void println(char x)
      Print a character and then terminate the line.
      abstract void println(char[] x)
      Print an array of characters and then terminate the line.
      abstract void println(double x)
      Print a double-precision floating-point number and then terminate the line.
      abstract void println(float x)
      Print a floating-point number and then terminate the line.
      abstract void println(int x)
      Print an integer and then terminate the line.
      abstract void println(long x)
      Print a long integer and then terminate the line.
      abstract void println(Object x)
      Print an Object and then terminate the line.
      abstract void println(String x)
      Print a String and then terminate the line.

      • Methods inherited from class java.io.Writer

        append, append, append, write, write, write, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • NO_BUFFER

        public static final int NO_BUFFER
        Constant indicating that the Writer is not buffering output.
        See Also:
        Constant Field Values

      • DEFAULT_BUFFER

        public static final int DEFAULT_BUFFER
        Constant indicating that the Writer is buffered and is using the implementation default buffer size.
        See Also:
        Constant Field Values

      • UNBOUNDED_BUFFER

        public static final int UNBOUNDED_BUFFER
        Constant indicating that the Writer is buffered and is unbounded; this is used in BodyContent.
        See Also:
        Constant Field Values

      • bufferSize

        protected int bufferSize
        The size of the buffer used by the JspWriter.

      • autoFlush

        protected boolean autoFlush
        Whether the JspWriter is autoflushing.

    • Constructor Detail

      • JspWriter

        protected JspWriter(int bufferSize,
         boolean autoFlush)
        Protected constructor.
        Parameters:
        bufferSize - the size of the buffer to be used by the JspWriter
        autoFlush - whether the JspWriter should be autoflushing

    • Method Detail

      • newLine

        public abstract void newLine()
                      throws IOException
        Write a line separator. The line separator string is defined by the system property line.separator, and is not necessarily a single newline ('\n') character.
        Throws:
        IOException - If an I/O error occurs

      • print

        public abstract void print(boolean b)
                    throws IOException
        Print a boolean value. The string produced by String.valueOf(boolean) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.
        Parameters:
        b - The boolean to be printed
        Throws:
        IOException - If an error occured while writing

      • print

        public abstract void print(char c)
                    throws IOException
        Print a character. The character is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.
        Parameters:
        c - The char to be printed
        Throws:
        IOException - If an error occured while writing

      • print

        public abstract void print(int i)
                    throws IOException
        Print an integer. The string produced by String.valueOf(int) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.
        Parameters:
        i - The int to be printed
        Throws:
        IOException - If an error occured while writing
        See Also:
        Integer.toString(int)

      • print

        public abstract void print(long l)
                    throws IOException
        Print a long integer. The string produced by String.valueOf(long) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.
        Parameters:
        l - The long to be printed
        Throws:
        IOException - If an error occured while writing
        See Also:
        Long.toString(long)

      • print

        public abstract void print(float f)
                    throws IOException
        Print a floating-point number. The string produced by String.valueOf(float) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.
        Parameters:
        f - The float to be printed
        Throws:
        IOException - If an error occured while writing
        See Also:
        Float.toString(float)

      • print

        public abstract void print(double d)
                    throws IOException
        Print a double-precision floating-point number. The string produced by String.valueOf(double) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.
        Parameters:
        d - The double to be printed
        Throws:
        IOException - If an error occured while writing
        See Also:
        Double.toString(double)

      • print

        public abstract void print(char[] s)
                    throws IOException
        Print an array of characters. The characters are written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.
        Parameters:
        s - The array of chars to be printed
        Throws:
        NullPointerException - If s is null
        IOException - If an error occured while writing

      • print

        public abstract void print(String s)
                    throws IOException
        Print a string. If the argument is null then the string "null" is printed. Otherwise, the string's characters are written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.
        Parameters:
        s - The String to be printed
        Throws:
        IOException - If an error occured while writing

      • print

        public abstract void print(Object obj)
                    throws IOException
        Print an object. The string produced by the String.valueOf(Object) method is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.
        Parameters:
        obj - The Object to be printed
        Throws:
        IOException - If an error occured while writing
        See Also:
        Object.toString()

      • println

        public abstract void println()
                      throws IOException
        Terminate the current line by writing the line separator string. The line separator string is defined by the system property line.separator, and is not necessarily a single newline character ('\n').
        Throws:
        IOException - If an error occured while writing

      • println

        public abstract void println(boolean x)
                      throws IOException
        Print a boolean value and then terminate the line. This method behaves as though it invokes print(boolean) and then println().
        Parameters:
        x - the boolean to write
        Throws:
        IOException - If an error occured while writing

      • println

        public abstract void println(char x)
                      throws IOException
        Print a character and then terminate the line. This method behaves as though it invokes print(char) and then println().
        Parameters:
        x - the char to write
        Throws:
        IOException - If an error occured while writing

      • println

        public abstract void println(int x)
                      throws IOException
        Print an integer and then terminate the line. This method behaves as though it invokes print(int) and then println().
        Parameters:
        x - the int to write
        Throws:
        IOException - If an error occured while writing

      • println

        public abstract void println(long x)
                      throws IOException
        Print a long integer and then terminate the line. This method behaves as though it invokes print(long) and then println().
        Parameters:
        x - the long to write
        Throws:
        IOException - If an error occured while writing

      • println

        public abstract void println(float x)
                      throws IOException
        Print a floating-point number and then terminate the line. This method behaves as though it invokes print(float) and then println().
        Parameters:
        x - the float to write
        Throws:
        IOException - If an error occured while writing

      • println

        public abstract void println(double x)
                      throws IOException
        Print a double-precision floating-point number and then terminate the line. This method behaves as though it invokes print(double) and then println().
        Parameters:
        x - the double to write
        Throws:
        IOException - If an error occured while writing

      • println

        public abstract void println(char[] x)
                      throws IOException
        Print an array of characters and then terminate the line. This method behaves as though it invokes print(char[]) and then println().
        Parameters:
        x - the char[] to write
        Throws:
        IOException - If an error occured while writing

      • println

        public abstract void println(String x)
                      throws IOException
        Print a String and then terminate the line. This method behaves as though it invokes print(String) and then println().
        Parameters:
        x - the String to write
        Throws:
        IOException - If an error occured while writing

      • println

        public abstract void println(Object x)
                      throws IOException
        Print an Object and then terminate the line. This method behaves as though it invokes print(Object) and then println().
        Parameters:
        x - the Object to write
        Throws:
        IOException - If an error occured while writing

      • clear

        public abstract void clear()
                    throws IOException
        Clear the contents of the buffer. If the buffer has been already been flushed then the clear operation shall throw an IOException to signal the fact that some data has already been irrevocably written to the client response stream.
        Throws:
        IOException - If an I/O error occurs

      • clearBuffer

        public abstract void clearBuffer()
                          throws IOException
        Clears the current contents of the buffer. Unlike clear(), this method will not throw an IOException if the buffer has already been flushed. It merely clears the current content of the buffer and returns.
        Throws:
        IOException - If an I/O error occurs

      • flush

        public abstract void flush()
                    throws IOException
        Flush the stream. If the stream has saved any characters from the various write() methods in a buffer, write them immediately to their intended destination. Then, if that destination is another character or byte stream, flush it. Thus one flush() invocation will flush all the buffers in a chain of Writers and OutputStreams.

        The method may be invoked indirectly if the buffer size is exceeded.

        Once a stream has been closed, further write() or flush() invocations will cause an IOException to be thrown.

        Specified by:
        flush in interface Flushable
        Specified by:
        flush in class Writer
        Throws:
        IOException - If an I/O error occurs

      • close

        public abstract void close()
                    throws IOException
        Close the stream, flushing it first.

        This method needs not be invoked explicitly for the initial JspWriter as the code generated by the JSP container will automatically include a call to close().

        Closing a previously-closed stream, unlike flush(), has no effect.

        Specified by:
        close in interface Closeable
        Specified by:
        close in interface AutoCloseable
        Specified by:
        close in class Writer
        Throws:
        IOException - If an I/O error occurs

      • getBufferSize

        public int getBufferSize()
        This method returns the size of the buffer used by the JspWriter.
        Returns:
        the size of the buffer in bytes, or 0 is unbuffered.

      • getRemaining

        public abstract int getRemaining()
        This method returns the number of unused bytes in the buffer.
        Returns:
        the number of bytes unused in the buffer

      • isAutoFlush

        public boolean isAutoFlush()
        This method indicates whether the JspWriter is autoFlushing.
        Returns:
        if this JspWriter is auto flushing or throwing IOExceptions on buffer overflow conditions
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PageContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Class PageContext

  • java.lang.Object
    • javax.servlet.jsp.JspContext
      • javax.servlet.jsp.PageContext

  • public abstract class PageContext
extends JspContext

    PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.

    A PageContext instance provides access to all the namespaces associated with a JSP page, provides access to several page attributes, as well as a layer above the implementation details. Implicit objects are added to the pageContext automatically.

    The PageContext class is an abstract class, designed to be extended to provide implementation dependent implementations thereof, by conformant JSP engine runtime environments. A PageContext instance is obtained by a JSP implementation class by calling the JspFactory.getPageContext() method, and is released by calling JspFactory.releasePageContext().

    An example of how PageContext, JspFactory, and other classes can be used within a JSP Page Implementation object is given elsewhere.

    The PageContext provides a number of facilities to the page/component author and page implementor, including:

    • a single API to manage the various scoped namespaces
    • a number of convenience API's to access various public objects
    • a mechanism to obtain the JspWriter for output
    • a mechanism to manage session usage by the page
    • a mechanism to expose page directive attributes to the scripting environment
    • mechanisms to forward or include the current request to other active components in the application
    • a mechanism to handle errorpage exception processing

    Methods Intended for Container Generated Code

    Some methods are intended to be used by the code generated by the container, not by code written by JSP page authors, or JSP tag library authors.

    The methods supporting lifecycle are initialize() and release()

    The following methods enable the management of nested JspWriter streams to implement Tag Extensions: pushBody()

    Methods Intended for JSP authors

    The following methods provide convenient access to implicit objects:
getException(),  getPage()
getRequest(),  getResponse(),
getSession(),  getServletConfig()
and getServletContext().

    The following methods provide support for forwarding, inclusion and error handling: forward(), include(), and handlePageException().

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String APPLICATION
      Name used to store ServletContext in PageContext name table.
      static int APPLICATION_SCOPE
      Application scope: named reference remains available in the ServletContext until it is reclaimed.
      static String CONFIG
      Name used to store ServletConfig in PageContext name table.
      static String EXCEPTION
      Name used to store uncaught exception in ServletRequest attribute list and PageContext name table.
      static String OUT
      Name used to store current JspWriter in PageContext name table.
      static String PAGE
      Name used to store the Servlet in this PageContext's nametables.
      static int PAGE_SCOPE
      Page scope: (this is the default) the named reference remains available in this PageContext until the return from the current Servlet.service() invocation.
      static String PAGECONTEXT
      Name used to store this PageContext in it's own name table.
      static String REQUEST
      Name used to store ServletRequest in PageContext name table.
      static int REQUEST_SCOPE
      Request scope: the named reference remains available from the ServletRequest associated with the Servlet until the current request is completed.
      static String RESPONSE
      Name used to store ServletResponse in PageContext name table.
      static String SESSION
      Name used to store HttpSession in PageContext name table.
      static int SESSION_SCOPE
      Session scope (only valid if this page participates in a session): the named reference remains available from the HttpSession (if any) associated with the Servlet until the HttpSession is invalidated.

    • Constructor Summary

      Constructors
      Constructor and Description
      PageContext()
      Sole constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void forward(String relativeUrlPath)
      This method is used to re-direct, or "forward" the current ServletRequest and ServletResponse to another active component in the application.
      ErrorData getErrorData()
      Provides convenient access to error information.
      abstract Exception getException()
      The current value of the exception object (an Exception).
      abstract Object getPage()
      The current value of the page object (In a Servlet environment, this is an instance of javax.servlet.Servlet).
      abstract ServletRequest getRequest()
      The current value of the request object (a ServletRequest).
      abstract ServletResponse getResponse()
      The current value of the response object (a ServletResponse).
      abstract ServletConfig getServletConfig()
      The ServletConfig instance.
      abstract ServletContext getServletContext()
      The ServletContext instance.
      abstract HttpSession getSession()
      The current value of the session object (an HttpSession).
      abstract void handlePageException(Exception e)
      This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
      abstract void handlePageException(Throwable t)
      This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
      abstract void include(String relativeUrlPath)
      Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
      abstract void include(String relativeUrlPath, boolean flush)
      Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
      abstract void initialize(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int bufferSize, boolean autoFlush)
      The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.
      BodyContent pushBody()
      Return a new BodyContent object, save the current "out" JspWriter, and update the value of the "out" attribute in the page scope attribute namespace of the PageContext.
      abstract void release()
      This method shall "reset" the internal state of a PageContext, releasing all internal references, and preparing the PageContext for potential reuse by a later invocation of initialize().

      • Methods inherited from class javax.servlet.jsp.JspContext

        findAttribute, getAttribute, getAttribute, getAttributeNamesInScope, getAttributesScope, getELContext, getExpressionEvaluator, getOut, getVariableResolver, popBody, pushBody, removeAttribute, removeAttribute, setAttribute, setAttribute

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • PAGE_SCOPE

        public static final int PAGE_SCOPE
        Page scope: (this is the default) the named reference remains available in this PageContext until the return from the current Servlet.service() invocation.
        See Also:
        Constant Field Values

      • REQUEST_SCOPE

        public static final int REQUEST_SCOPE
        Request scope: the named reference remains available from the ServletRequest associated with the Servlet until the current request is completed.
        See Also:
        Constant Field Values

      • SESSION_SCOPE

        public static final int SESSION_SCOPE
        Session scope (only valid if this page participates in a session): the named reference remains available from the HttpSession (if any) associated with the Servlet until the HttpSession is invalidated.
        See Also:
        Constant Field Values

      • APPLICATION_SCOPE

        public static final int APPLICATION_SCOPE
        Application scope: named reference remains available in the ServletContext until it is reclaimed.
        See Also:
        Constant Field Values

      • PAGE

        public static final String PAGE
        Name used to store the Servlet in this PageContext's nametables.
        See Also:
        Constant Field Values

      • PAGECONTEXT

        public static final String PAGECONTEXT
        Name used to store this PageContext in it's own name table.
        See Also:
        Constant Field Values

      • REQUEST

        public static final String REQUEST
        Name used to store ServletRequest in PageContext name table.
        See Also:
        Constant Field Values

      • RESPONSE

        public static final String RESPONSE
        Name used to store ServletResponse in PageContext name table.
        See Also:
        Constant Field Values

      • CONFIG

        public static final String CONFIG
        Name used to store ServletConfig in PageContext name table.
        See Also:
        Constant Field Values

      • SESSION

        public static final String SESSION
        Name used to store HttpSession in PageContext name table.
        See Also:
        Constant Field Values

      • OUT

        public static final String OUT
        Name used to store current JspWriter in PageContext name table.
        See Also:
        Constant Field Values

      • APPLICATION

        public static final String APPLICATION
        Name used to store ServletContext in PageContext name table.
        See Also:
        Constant Field Values

      • EXCEPTION

        public static final String EXCEPTION
        Name used to store uncaught exception in ServletRequest attribute list and PageContext name table.
        See Also:
        Constant Field Values

    • Constructor Detail

      • PageContext

        public PageContext()
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • Method Detail

      • initialize

        public abstract void initialize(Servlet servlet,
              ServletRequest request,
              ServletResponse response,
              String errorPageURL,
              boolean needsSession,
              int bufferSize,
              boolean autoFlush)
                         throws IOException,
                                IllegalStateException,
                                IllegalArgumentException

        The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.

        This method is typically called from JspFactory.getPageContext() in order to initialize state.

        This method is required to create an initial JspWriter, and associate the "out" name in page scope with this newly created object.

        This method should not be used by page or tag library authors.

        Parameters:
        servlet - The Servlet that is associated with this PageContext
        request - The currently pending request for this Servlet
        response - The currently pending response for this Servlet
        errorPageURL - The value of the errorpage attribute from the page directive or null
        needsSession - The value of the session attribute from the page directive
        bufferSize - The value of the buffer attribute from the page directive
        autoFlush - The value of the autoflush attribute from the page directive
        Throws:
        IOException - during creation of JspWriter
        IllegalStateException - if out not correctly initialized
        IllegalArgumentException - If one of the given parameters is invalid

      • release

        public abstract void release()

        This method shall "reset" the internal state of a PageContext, releasing all internal references, and preparing the PageContext for potential reuse by a later invocation of initialize(). This method is typically called from JspFactory.releasePageContext().

        Subclasses shall envelope this method.

        This method should not be used by page or tag library authors.

      • getSession

        public abstract HttpSession getSession()
        The current value of the session object (an HttpSession).
        Returns:
        the HttpSession for this PageContext or null

      • getPage

        public abstract Object getPage()
        The current value of the page object (In a Servlet environment, this is an instance of javax.servlet.Servlet).
        Returns:
        the Page implementation class instance associated with this PageContext

      • getRequest

        public abstract ServletRequest getRequest()
        The current value of the request object (a ServletRequest).
        Returns:
        The ServletRequest for this PageContext

      • getResponse

        public abstract ServletResponse getResponse()
        The current value of the response object (a ServletResponse).
        Returns:
        the ServletResponse for this PageContext

      • getException

        public abstract Exception getException()
        The current value of the exception object (an Exception).
        Returns:
        any exception passed to this as an errorpage

      • getServletConfig

        public abstract ServletConfig getServletConfig()
        The ServletConfig instance.
        Returns:
        the ServletConfig for this PageContext

      • getServletContext

        public abstract ServletContext getServletContext()
        The ServletContext instance.
        Returns:
        the ServletContext for this PageContext

      • forward

        public abstract void forward(String relativeUrlPath)
                      throws ServletException,
                             IOException

        This method is used to re-direct, or "forward" the current ServletRequest and ServletResponse to another active component in the application.

        If the relativeUrlPath begins with a "/" then the URL specified is calculated relative to the DOCROOT of the ServletContext for this JSP. If the path does not begin with a "/" then the URL specified is calculated relative to the URL of the request that was mapped to the calling JSP.

        It is only valid to call this method from a Thread executing within a _jspService(...) method of a JSP.

        Once this method has been called successfully, it is illegal for the calling Thread to attempt to modify the ServletResponse object. Any such attempt to do so, shall result in undefined behavior. Typically, callers immediately return from _jspService(...) after calling this method.

        Parameters:
        relativeUrlPath - specifies the relative URL path to the target resource as described above
        Throws:
        IllegalStateException - if ServletResponse is not in a state where a forward can be performed
        ServletException - if the page that was forwarded to throws a ServletException
        IOException - if an I/O error occurred while forwarding

      • include

        public abstract void include(String relativeUrlPath)
                      throws ServletException,
                             IOException

        Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread. The output of the target resources processing of the request is written directly to the ServletResponse output stream.

        The current JspWriter "out" for this JSP is flushed as a side-effect of this call, prior to processing the include.

        If the relativeUrlPath begins with a "/" then the URL specified is calculated relative to the DOCROOT of the ServletContext for this JSP. If the path does not begin with a "/" then the URL specified is calculated relative to the URL of the request that was mapped to the calling JSP.

        It is only valid to call this method from a Thread executing within a _jspService(...) method of a JSP.

        Parameters:
        relativeUrlPath - specifies the relative URL path to the target resource to be included
        Throws:
        ServletException - if the page that was forwarded to throws a ServletException
        IOException - if an I/O error occurred while forwarding

      • include

        public abstract void include(String relativeUrlPath,
           boolean flush)
                      throws ServletException,
                             IOException

        Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread. The output of the target resources processing of the request is written directly to the current JspWriter returned by a call to getOut().

        If flush is true, The current JspWriter "out" for this JSP is flushed as a side-effect of this call, prior to processing the include. Otherwise, the JspWriter "out" is not flushed.

        If the relativeUrlPath begins with a "/" then the URL specified is calculated relative to the DOCROOT of the ServletContext for this JSP. If the path does not begin with a "/" then the URL specified is calculated relative to the URL of the request that was mapped to the calling JSP.

        It is only valid to call this method from a Thread executing within a _jspService(...) method of a JSP.

        Parameters:
        relativeUrlPath - specifies the relative URL path to the target resource to be included
        flush - True if the JspWriter is to be flushed before the include, or false if not.
        Throws:
        ServletException - if the page that was forwarded to throws a ServletException
        IOException - if an I/O error occurred while forwarding
        Since:
        JSP 2.0

      • handlePageException

        public abstract void handlePageException(Exception e)
                                  throws ServletException,
                                         IOException

        This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP. If forwarding is not possible (for example because the response has already been committed), an implementation dependent mechanism should be used to invoke the error page (e.g. "including" the error page instead).

        If no error page is defined in the page, the exception should be rethrown so that the standard servlet error handling takes over.

        A JSP implementation class shall typically clean up any local state prior to invoking this and will return immediately thereafter. It is illegal to generate any output to the client, or to modify any ServletResponse state after invoking this call.

        This method is kept for backwards compatiblity reasons. Newly generated code should use PageContext.handlePageException(Throwable).

        Parameters:
        e - the exception to be handled
        Throws:
        ServletException - if an error occurs while invoking the error page
        IOException - if an I/O error occurred while invoking the error page
        NullPointerException - if the exception is null
        See Also:
        handlePageException(Throwable)

      • handlePageException

        public abstract void handlePageException(Throwable t)
                                  throws ServletException,
                                         IOException

        This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP. If forwarding is not possible (for example because the response has already been committed), an implementation dependent mechanism should be used to invoke the error page (e.g. "including" the error page instead).

        If no error page is defined in the page, the exception should be rethrown so that the standard servlet error handling takes over.

        This method is intended to process an unhandled "page" level exception by redirecting the exception to either the specified error page for this JSP, or if none was specified, to perform some implementation dependent action.

        A JSP implementation class shall typically clean up any local state prior to invoking this and will return immediately thereafter. It is illegal to generate any output to the client, or to modify any ServletResponse state after invoking this call.

        Parameters:
        t - the throwable to be handled
        Throws:
        ServletException - if an error occurs while invoking the error page
        IOException - if an I/O error occurred while invoking the error page
        NullPointerException - if the exception is null
        See Also:
        handlePageException(Exception)

      • pushBody

        public BodyContent pushBody()
        Return a new BodyContent object, save the current "out" JspWriter, and update the value of the "out" attribute in the page scope attribute namespace of the PageContext.
        Returns:
        the new BodyContent

      • getErrorData

        public ErrorData getErrorData()
        Provides convenient access to error information.
        Returns:
        an ErrorData instance containing information about the error, as obtained from the request attributes, as per the Servlet specification. If this is not an error page (that is, if the isErrorPage attribute of the page directive is not set to "true"), the information is meaningless.
        Since:
        JSP 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SkipPageException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp

Class SkipPageException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.servlet.jsp.JspException
          • javax.servlet.jsp.SkipPageException
  • All Implemented Interfaces:
    Serializable

    public class SkipPageException
extends JspException
    Exception to indicate the calling page must cease evaluation. Thrown by a simple tag handler to indicate that the remainder of the page must not be evaluated. The result is propagated back to the pagein the case where one tag invokes another (as can be the case with tag files). The effect is similar to that of a Classic Tag Handler returning Tag.SKIP_PAGE from doEndTag(). Jsp Fragments may also throw this exception. This exception should not be thrown manually in a JSP page or tag file - the behavior is undefined. The exception is intended to be thrown inside SimpleTag handlers and in JSP fragments.
    Since:
    JSP 2.0
    See Also:
    SimpleTag.doTag(),
JspFragment.invoke(java.io.Writer),
Tag.doEndTag(),
Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SkipPageException()
      Creates a SkipPageException with no message.
      SkipPageException(String message)
      Creates a SkipPageException with the provided message.
      SkipPageException(String message, Throwable rootCause)
      Creates a SkipPageException with the provided message and root cause.
      SkipPageException(Throwable rootCause)
      Creates a SkipPageException with the provided root cause.

    • Method Summary

      • Methods inherited from class javax.servlet.jsp.JspException

        getRootCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SkipPageException

        public SkipPageException()
        Creates a SkipPageException with no message.

      • SkipPageException

        public SkipPageException(String message)
        Creates a SkipPageException with the provided message.
        Parameters:
        message - the detail message

      • SkipPageException

        public SkipPageException(String message,
                 Throwable rootCause)
        Creates a SkipPageException with the provided message and root cause.
        Parameters:
        message - the detail message
        rootCause - the originating cause of this exception

      • SkipPageException

        public SkipPageException(Throwable rootCause)
        Creates a SkipPageException with the provided root cause.
        Parameters:
        rootCause - the originating cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.servlet.jsp (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet.jsp

  • Packages that use javax.servlet.jsp
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.jstl.fmt
    Classes and interfaces related to the locale sensitive formatting tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.
  • Classes in javax.servlet.jsp used by javax.faces.webapp
    Class and Description
    JspException
    A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.
    JspWriter
    The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.
    PageContext
    PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.
  • Classes in javax.servlet.jsp used by javax.servlet.jsp
    Class and Description
    ErrorData
    Contains information about an error, for error pages.
    JspApplicationContext
    Stores application-scoped information relevant to JSP containers.
    JspContext
    JspContext serves as the base class for the PageContext class and abstracts all information that is not specific to servlets.
    JspEngineInfo
    The JspEngineInfo is an abstract class that provides information on the current JSP engine.
    JspException
    A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.
    JspFactory
    The JspFactory is an abstract class that defines a number of factory methods available to a JSP page at runtime for the purposes of creating instances of various interfaces and classes used to support the JSP implementation.
    JspPage
    The JspPage interface describes the generic interaction that a JSP Page Implementation class must satisfy; pages that use the HTTP protocol are described by the HttpJspPage interface.
    JspWriter
    The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.
    PageContext
    PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.
  • Classes in javax.servlet.jsp used by javax.servlet.jsp.jstl.core
    Class and Description
    JspException
    A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.
    JspTagException
    Exception to be used by a Tag Handler to indicate some unrecoverable error.
    PageContext
    PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.
  • Classes in javax.servlet.jsp used by javax.servlet.jsp.jstl.fmt
    Class and Description
    PageContext
    PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.
  • Classes in javax.servlet.jsp used by javax.servlet.jsp.tagext
    Class and Description
    JspContext
    JspContext serves as the base class for the PageContext class and abstracts all information that is not specific to servlets.
    JspException
    A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.
    JspWriter
    The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.
    PageContext
    PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.ErrorData (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.ErrorData

  • Packages that use ErrorData
    Package Description
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of ErrorData in javax.servlet.jsp

      Methods in javax.servlet.jsp that return ErrorData
      Modifier and Type Method and Description
      ErrorData PageContext.getErrorData()
      Provides convenient access to error information.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.JspContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.JspContext

  • Packages that use JspContext
    Package Description
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of JspContext in javax.servlet.jsp

      Subclasses of JspContext in javax.servlet.jsp
      Modifier and Type Class and Description
      class  PageContext
      PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.

    • Uses of JspContext in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext that return JspContext
      Modifier and Type Method and Description
      protected JspContext SimpleTagSupport.getJspContext()
      Returns the page context passed in by the container via setJspContext.
      abstract JspContext JspFragment.getJspContext()
      Returns the JspContext that is bound to this JspFragment.
      Methods in javax.servlet.jsp.tagext with parameters of type JspContext
      Modifier and Type Method and Description
      void SimpleTagSupport.setJspContext(JspContext pc)
      Stores the provided JSP context in the private jspContext field.
      void SimpleTag.setJspContext(JspContext pc)
      Called by the container to provide this tag handler with the JspContext for this invocation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.JspEngineInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.JspEngineInfo

  • Packages that use JspEngineInfo
    Package Description
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of JspEngineInfo in javax.servlet.jsp

      Methods in javax.servlet.jsp that return JspEngineInfo
      Modifier and Type Method and Description
      abstract JspEngineInfo JspFactory.getEngineInfo()
      called to get implementation-specific information on the current JSP engine.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.JspException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.JspException

  • Packages that use JspException
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of JspException in javax.faces.webapp

      Methods in javax.faces.webapp that throw JspException
      Modifier and Type Method and Description
      protected UIComponent UIComponentELTag.createComponent(FacesContext context, String newId)
      Create and return a new child component of the type returned by calling getComponentType().
      protected abstract UIComponent UIComponentClassicTagBase.createComponent(FacesContext context, String newId)
      Create and return a new child component of the type returned by calling getComponentType().
      protected Converter ConverterTag.createConverter()
      Deprecated.
      Create and return a new Converter to be registered on our surrounding UIComponent.
      protected abstract Converter ConverterELTag.createConverter()
      Create and return a new Converter to be registered on our surrounding UIComponent.
      protected Validator ValidatorTag.createValidator()
      Deprecated.
      Create and return a new Validator to be registered on our surrounding UIComponent.
      protected abstract Validator ValidatorELTag.createValidator()
      Create and return a new Validator to be registered on our surrounding UIComponent.
      int UIComponentClassicTagBase.doAfterBody()
      Perform any processing necessary to handle the content implications of CASE 4 in the class description.
      int UIComponentClassicTagBase.doEndTag()
      Perform any processing necessary to handle the content implications of CASE 3 in the class description.
      int AttributeTag.doEndTag()
      Deprecated.
      void UIComponentClassicTagBase.doInitBody()
      Prepare for evaluation of the body.
      int ValidatorTag.doStartTag()
      Deprecated.
      Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.
      int ValidatorELTag.doStartTag()
      Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.
      int UIComponentClassicTagBase.doStartTag()
      Perform any processing necessary to find (or create) the UIComponent instance in the view corresponding to this tag instance in the page and, if and only if a component was created, insert it into the tree at the proper location as expected by the page author.
      int FacetTag.doStartTag()
      Return EVAL_BODY_INCLUDE to cause nested body content to be evaluated.
      int ConverterTag.doStartTag()
      Deprecated.
      Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.
      int ConverterELTag.doStartTag()
      Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentClassicTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.
      int AttributeTag.doStartTag()
      Deprecated.
      Register the specified attribute name and value with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if this UIComponent does not already have a value for the specified attribute name.
      protected UIComponent UIComponentClassicTagBase.findComponent(FacesContext context)
      Find and return the UIComponent, from the component tree, that corresponds to this tag handler instance.
      protected int UIComponentClassicTagBase.getDoAfterBodyValue()
      Return the flag value that should be returned from the doAfterBody() method when it is called.
      protected int UIComponentClassicTagBase.getDoEndValue()
      Return the flag value that should be returned from the doEnd() method when it is called.
      protected int UIComponentClassicTagBase.getDoStartValue()
      Return the flag value that should be returned from the doStart() method when it is called.
      void ValidatorTag.setBinding(String binding)
      Deprecated.
      Set the expression that will be used to create a ValueExpression that references a backing bean property of the Validator instance to be created.
      void UIComponentTag.setBinding(String binding)
      Deprecated.
      Set the value binding expression for our component.
      void ConverterTag.setBinding(String binding)
      Deprecated.
      Set the expression that will be used to create a ValueExpression that references a backing bean property of the Converter instance to be created.
      void UIComponentELTag.setBinding(ValueExpression binding)
      Set the value expression for our component.

    • Uses of JspException in javax.servlet.jsp

      Subclasses of JspException in javax.servlet.jsp
      Modifier and Type Class and Description
      class  JspTagException
      Exception to be used by a Tag Handler to indicate some unrecoverable error.
      class  SkipPageException
      Exception to indicate the calling page must cease evaluation.

    • Uses of JspException in javax.servlet.jsp.jstl.core

      Methods in javax.servlet.jsp.jstl.core that throw JspException
      Modifier and Type Method and Description
      int LoopTagSupport.doAfterBody()
      Continues the iteration when appropriate -- that is, if we (a) have more items and (b) don't run over our 'end' (given our 'step').
      int LoopTagSupport.doStartTag()
      Begins iterating by processing the first item.
      int ConditionalTagSupport.doStartTag()
      Includes its body if condition() evaluates to true.

    • Uses of JspException in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext that throw JspException
      Modifier and Type Method and Description
      int TagSupport.doAfterBody()
      Default processing for a body.
      int IterationTag.doAfterBody()
      Process body (re)evaluation.
      int BodyTagSupport.doAfterBody()
      After the body evaluation: do not reevaluate and continue with the page.
      int TagSupport.doEndTag()
      Default processing of the end tag returning EVAL_PAGE.
      int TagAdapter.doEndTag()
      Must not be called.
      int Tag.doEndTag()
      Process the end tag for this instance.
      int BodyTagSupport.doEndTag()
      Default processing of the end tag returning EVAL_PAGE.
      void BodyTagSupport.doInitBody()
      Prepare for evaluation of the body just before the first body evaluation: no action.
      void BodyTag.doInitBody()
      Prepare for evaluation of the body.
      int TagSupport.doStartTag()
      Default processing of the start tag, returning SKIP_BODY.
      int TagAdapter.doStartTag()
      Must not be called.
      int Tag.doStartTag()
      Process the start tag for this instance.
      int BodyTagSupport.doStartTag()
      Default processing of the start tag returning EVAL_BODY_BUFFERED.
      void SimpleTagSupport.doTag()
      Default processing of the tag does nothing.
      void SimpleTag.doTag()
      Called by the container to invoke this tag.
      abstract void JspFragment.invoke(Writer out)
      Executes the fragment and directs all output to the given Writer, or the JspWriter returned by the getOut() method of the JspContext associated with the fragment if out is null.
      void DynamicAttributes.setDynamicAttribute(String uri, String localName, Object value)
      Called when a tag declared to accept dynamic attributes is passed an attribute that is not declared in the Tag Library Descriptor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.JspFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.JspFactory

  • Packages that use JspFactory
    Package Description
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of JspFactory in javax.servlet.jsp

      Methods in javax.servlet.jsp that return JspFactory
      Modifier and Type Method and Description
      static JspFactory JspFactory.getDefaultFactory()
      Returns the default factory for this implementation.
      Methods in javax.servlet.jsp with parameters of type JspFactory
      Modifier and Type Method and Description
      static void JspFactory.setDefaultFactory(JspFactory deflt)
      set the default factory for this implementation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.JspTagException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.JspTagException

  • Packages that use JspTagException
    Package Description
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of JspTagException in javax.servlet.jsp.jstl.core

      Methods in javax.servlet.jsp.jstl.core that throw JspTagException
      Modifier and Type Method and Description
      protected abstract boolean ConditionalTagSupport.condition()
      Subclasses implement this method to compute the boolean result of the conditional action.
      protected abstract boolean LoopTagSupport.hasNext()
      Returns information concerning the availability of more items over which to iterate.
      protected abstract Object LoopTagSupport.next()
      Returns the next object over which the tag should iterate.
      protected abstract void LoopTagSupport.prepare()
      Prepares for a single tag invocation.
      protected void LoopTagSupport.validateBegin()
      Ensures the "begin" property is sensible, throwing an exception expected to propagate up if it isn't
      protected void LoopTagSupport.validateEnd()
      Ensures the "end" property is sensible, throwing an exception expected to propagate up if it isn't
      protected void LoopTagSupport.validateStep()
      Ensures the "step" property is sensible, throwing an exception expected to propagate up if it isn't
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.JspWriter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.JspWriter

  • Packages that use JspWriter
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of JspWriter in javax.faces.webapp

      Methods in javax.faces.webapp that return JspWriter
      Modifier and Type Method and Description
      JspWriter UIComponentClassicTagBase.getPreviousOut()
      Get the JspWriter from our BodyContent.

    • Uses of JspWriter in javax.servlet.jsp

      Methods in javax.servlet.jsp that return JspWriter
      Modifier and Type Method and Description
      abstract JspWriter JspContext.getOut()
      The current value of the out object (a JspWriter).
      JspWriter JspContext.popBody()
      Return the previous JspWriter "out" saved by the matching pushBody(), and update the value of the "out" attribute in the page scope attribute namespace of the JspContext.
      JspWriter JspContext.pushBody(Writer writer)
      Return a new JspWriter object that sends output to the provided Writer.

    • Uses of JspWriter in javax.servlet.jsp.tagext

      Subclasses of JspWriter in javax.servlet.jsp.tagext
      Modifier and Type Class and Description
      class  BodyContent
      An encapsulation of the evaluation of the body of an action so it is available to a tag handler.
      Methods in javax.servlet.jsp.tagext that return JspWriter
      Modifier and Type Method and Description
      JspWriter BodyContent.getEnclosingWriter()
      Get the enclosing JspWriter.
      JspWriter BodyTagSupport.getPreviousOut()
      Get surrounding out JspWriter.
      Constructors in javax.servlet.jsp.tagext with parameters of type JspWriter
      Constructor and Description
      BodyContent(JspWriter e)
      Protected constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.PageContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.PageContext

  • Packages that use PageContext
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.jstl.fmt
    Classes and interfaces related to the locale sensitive formatting tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of PageContext in javax.faces.webapp

      Fields in javax.faces.webapp declared as PageContext
      Modifier and Type Field and Description
      protected PageContext UIComponentClassicTagBase.pageContext
      The JSP PageContext for the page we are embedded in.
      Methods in javax.faces.webapp with parameters of type PageContext
      Modifier and Type Method and Description
      static UIComponentClassicTagBase UIComponentClassicTagBase.getParentUIComponentClassicTagBase(PageContext context)
      Locate and return the nearest enclosing UIComponentClassicTagBase if any; otherwise, return null.
      static UIComponentTag UIComponentTag.getParentUIComponentTag(PageContext context)
      Deprecated.
      Locate and return the nearest enclosing UIComponentTag if any; otherwise, return null.
      void UIComponentClassicTagBase.setPageContext(PageContext pageContext)
      Set the PageContext of the page containing this tag instance.

    • Uses of PageContext in javax.servlet.jsp

      Methods in javax.servlet.jsp that return PageContext
      Modifier and Type Method and Description
      abstract PageContext JspFactory.getPageContext(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int buffer, boolean autoflush)
      obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.
      Methods in javax.servlet.jsp with parameters of type PageContext
      Modifier and Type Method and Description
      abstract void JspFactory.releasePageContext(PageContext pc)
      called to release a previously allocated PageContext object.

    • Uses of PageContext in javax.servlet.jsp.jstl.core

      Methods in javax.servlet.jsp.jstl.core with parameters of type PageContext
      Modifier and Type Method and Description
      static Object Config.find(PageContext pc, String name)
      Finds the value associated with a specific configuration setting identified by its context initialization parameter name.
      static Object Config.get(PageContext pc, String name, int scope)
      Looks up a configuration variable in the given scope.
      static void Config.remove(PageContext pc, String name, int scope)
      Removes a configuration variable from the given scope.
      static void Config.set(PageContext pc, String name, Object value, int scope)
      Sets the value of a configuration variable in the given scope.

    • Uses of PageContext in javax.servlet.jsp.jstl.fmt

      Methods in javax.servlet.jsp.jstl.fmt with parameters of type PageContext
      Modifier and Type Method and Description
      static String LocaleSupport.getLocalizedMessage(PageContext pageContext, String key)
      Retrieves the localized message corresponding to the given key.
      static String LocaleSupport.getLocalizedMessage(PageContext pageContext, String key, Object[] args)
      Retrieves the localized message corresponding to the given key, and performs parametric replacement using the arguments specified via args.
      static String LocaleSupport.getLocalizedMessage(PageContext pageContext, String key, Object[] args, String basename)
      Retrieves the localized message corresponding to the given key, and performs parametric replacement using the arguments specified via args.
      static String LocaleSupport.getLocalizedMessage(PageContext pageContext, String key, String basename)
      Retrieves the localized message corresponding to the given key.

    • Uses of PageContext in javax.servlet.jsp.tagext

      Fields in javax.servlet.jsp.tagext declared as PageContext
      Modifier and Type Field and Description
      protected PageContext TagSupport.pageContext
      The PageContext.
      Methods in javax.servlet.jsp.tagext with parameters of type PageContext
      Modifier and Type Method and Description
      void TagSupport.setPageContext(PageContext pageContext)
      Set the page context.
      void TagAdapter.setPageContext(PageContext pc)
      Must not be called.
      void Tag.setPageContext(PageContext pc)
      Set the current page context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.SkipPageException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.SkipPageException

No usage of javax.servlet.jsp.SkipPageException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.HttpJspPage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.HttpJspPage

No usage of javax.servlet.jsp.HttpJspPage
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.JspApplicationContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.JspApplicationContext

  • Packages that use JspApplicationContext
    Package Description
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of JspApplicationContext in javax.servlet.jsp

      Methods in javax.servlet.jsp that return JspApplicationContext
      Modifier and Type Method and Description
      abstract JspApplicationContext JspFactory.getJspApplicationContext(ServletContext context)
      Obtains the JspApplicationContext instance associated with the web application for the given ServletContext.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.JspPage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.JspPage

  • Packages that use JspPage
    Package Description
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of JspPage in javax.servlet.jsp

      Subinterfaces of JspPage in javax.servlet.jsp
      Modifier and Type Interface and Description
      interface  HttpJspPage
      The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ELException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.el

Class ELException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.servlet.jsp.el.ELException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ELParseException
    Deprecated.
    As of JSP 2.1, replaced by ELException

    public class ELException
extends Exception
    Represents any of the exception conditions that arise during the operation evaluation of the evaluator.
    Since:
    JSP 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ELException()
      Deprecated.
      Creates an ELException with no detail message.
      ELException(String pMessage)
      Deprecated.
      Creates an ELException with the provided detail message.
      ELException(String pMessage, Throwable pRootCause)
      Deprecated.
      Creates an ELException with the given detail message and root cause.
      ELException(Throwable pRootCause)
      Deprecated.
      Creates an ELException with the given root cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getRootCause()
      Deprecated.
      Returns the root cause.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ELException

        public ELException()
        Deprecated.
        Creates an ELException with no detail message.

      • ELException

        public ELException(String pMessage)
        Deprecated.
        Creates an ELException with the provided detail message.
        Parameters:
        pMessage - the detail message

      • ELException

        public ELException(Throwable pRootCause)
        Deprecated.
        Creates an ELException with the given root cause.
        Parameters:
        pRootCause - the originating cause of this exception

      • ELException

        public ELException(String pMessage,
           Throwable pRootCause)
        Deprecated.
        Creates an ELException with the given detail message and root cause.
        Parameters:
        pMessage - the detail message
        pRootCause - the originating cause of this exception

    • Method Detail

      • getRootCause

        public Throwable getRootCause()
        Deprecated.
        Returns the root cause.
        Returns:
        the root cause of this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ELParseException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.el

Class ELParseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.servlet.jsp.el.ELException
          • javax.servlet.jsp.el.ELParseException
  • All Implemented Interfaces:
    Serializable
    Deprecated.
    As of JSP 2.1, replaced by ELException

    public class ELParseException
extends ELException
    Represents a parsing error encountered while parsing an EL expression.
    Since:
    JSP 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ELParseException()
      Deprecated.
      Creates an ELParseException with no detail message.
      ELParseException(String pMessage)
      Deprecated.
      Creates an ELParseException with the provided detail message.

    • Method Summary

      • Methods inherited from class javax.servlet.jsp.el.ELException

        getRootCause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ELParseException

        public ELParseException()
        Deprecated.
        Creates an ELParseException with no detail message.

      • ELParseException

        public ELParseException(String pMessage)
        Deprecated.
        Creates an ELParseException with the provided detail message.
        Parameters:
        pMessage - the detail message
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Expression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.el

Class Expression

  • java.lang.Object
    • javax.servlet.jsp.el.Expression
  • Deprecated.
    As of JSP 2.1, replaced by ValueExpression

    public abstract class Expression
extends Object

    The abstract class for a prepared expression.

    An instance of an Expression can be obtained via from an ExpressionEvaluator instance.

    An Expression may or not have done a syntactic parse of the expression. A client invoking the evaluate() method should be ready for the case where ELParseException exceptions are raised.

    Since:
    JSP 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      Expression()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Object evaluate(VariableResolver vResolver)
      Deprecated.
      Evaluates an expression that was previously prepared.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Expression

        public Expression()
        Deprecated.

    • Method Detail

      • evaluate

        public abstract Object evaluate(VariableResolver vResolver)
                         throws ELException
        Deprecated.
        Evaluates an expression that was previously prepared. In some implementations preparing an expression involves full syntactic validation, but others may not do so. Evaluating the expression may raise an ELParseException as well as other ELExceptions due to run-time evaluation.
        Parameters:
        vResolver - A VariableResolver instance that can be used at runtime to resolve the name of implicit objects into Objects.
        Returns:
        The result of the expression evaluation.
        Throws:
        ELException - Thrown if the expression evaluation failed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExpressionEvaluator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.el

Class ExpressionEvaluator

  • java.lang.Object
    • javax.servlet.jsp.el.ExpressionEvaluator
  • Deprecated.
    As of JSP 2.1, replaced by ExpressionFactory

    public abstract class ExpressionEvaluator
extends Object

    The abstract base class for an expression-language evaluator. Classes that implement an expression language expose their functionality via this abstract class.

    An instance of the ExpressionEvaluator can be obtained via the JspContext / PageContext

    The parseExpression() and evaluate() methods must be thread-safe. That is, multiple threads may call these methods on the same ExpressionEvaluator object simultaneously. Implementations should synchronize access if they depend on transient state. Implementations should not, however, assume that only one object of each ExpressionEvaluator type will be instantiated; global caching should therefore be static.

    Only a single EL expression, starting with '${' and ending with '}', can be parsed or evaluated at a time. EL expressions cannot be mixed with static text. For example, attempting to parse or evaluate "abc${1+1}def${1+1}ghi" or even "${1+1}${1+1}" will cause an ELException to be thrown.

    The following are examples of syntactically legal EL expressions:

    • ${person.lastName}
    • ${8 * 8}
    • ${my:reverse('hello')}

    Since:
    JSP 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      ExpressionEvaluator()
      Deprecated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Object evaluate(String expression, Class expectedType, VariableResolver vResolver, FunctionMapper fMapper)
      Deprecated.
      Evaluates an expression.
      abstract Expression parseExpression(String expression, Class expectedType, FunctionMapper fMapper)
      Deprecated.
      Prepare an expression for later evaluation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ExpressionEvaluator

        public ExpressionEvaluator()
        Deprecated.

    • Method Detail

      • parseExpression

        public abstract Expression parseExpression(String expression,
                         Class expectedType,
                         FunctionMapper fMapper)
                                    throws ELException
        Deprecated.
        Prepare an expression for later evaluation. This method should perform syntactic validation of the expression; if in doing so it detects errors, it should raise an ELParseException.
        Parameters:
        expression - The expression to be evaluated.
        expectedType - The expected type of the result of the evaluation
        fMapper - A FunctionMapper to resolve functions found in the expression. It can be null, in which case no functions are supported for this invocation. The ExpressionEvaluator must not hold on to the FunctionMapper reference after returning from parseExpression(). The Expression object returned must invoke the same functions regardless of whether the mappings in the provided FunctionMapper instance change between calling ExpressionEvaluator.parseExpression() and Expression.evaluate().
        Returns:
        The Expression object encapsulating the arguments.
        Throws:
        ELException - Thrown if parsing errors were found.

      • evaluate

        public abstract Object evaluate(String expression,
              Class expectedType,
              VariableResolver vResolver,
              FunctionMapper fMapper)
                         throws ELException
        Deprecated.
        Evaluates an expression. This method may perform some syntactic validation and, if so, it should raise an ELParseException error if it encounters syntactic errors. EL evaluation errors should cause an ELException to be raised.
        Parameters:
        expression - The expression to be evaluated.
        expectedType - The expected type of the result of the evaluation
        vResolver - A VariableResolver instance that can be used at runtime to resolve the name of implicit objects into Objects.
        fMapper - A FunctionMapper to resolve functions found in the expression. It can be null, in which case no functions are supported for this invocation.
        Returns:
        The result of the expression evaluation.
        Throws:
        ELException - Thrown if the expression evaluation failed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FunctionMapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.el

Interface FunctionMapper

  • Deprecated.
    As of JSP 2.1, replaced by FunctionMapper

    public interface FunctionMapper

    The interface to a map between EL function names and methods.

    Classes implementing this interface may, for instance, consult tag library information to resolve the map.

    Since:
    JSP 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Method resolveFunction(String prefix, String localName)
      Deprecated.
      Resolves the specified local name and prefix into a Java.lang.Method.

    • Method Detail

      • resolveFunction

        Method resolveFunction(String prefix,
                     String localName)
        Deprecated.
        Resolves the specified local name and prefix into a Java.lang.Method. Returns null if the prefix and local name are not found.
        Parameters:
        prefix - the prefix of the function, or "" if no prefix.
        localName - the short name of the function
        Returns:
        the result of the method mapping. Null means no entry found.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ImplicitObjectELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.el

Class ImplicitObjectELResolver

  • java.lang.Object
    • javax.el.ELResolver
      • javax.servlet.jsp.el.ImplicitObjectELResolver

  • public class ImplicitObjectELResolver
extends ELResolver
    Defines variable resolution behavior for the EL implicit objects defined in the JSP specification.

    The following variables are resolved by this ELResolver, as per the JSP specification:

    • pageContext - the PageContext object.
    • pageScope - a Map that maps page-scoped attribute names to their values.
    • requestScope - a Map that maps request-scoped attribute names to their values.
    • sessionScope - a Map that maps session-scoped attribute names to their values.
    • applicationScope - a Map that maps application-scoped attribute names to their values.
    • param - a Map that maps parameter names to a single String parameter value (obtained by calling ServletRequest.getParameter(String name)).
    • paramValues - a Map that maps parameter names to a String[] of all values for that parameter (obtained by calling ServletRequest.getParameterValues(String name)).
    • header - a Map that maps header names to a single String header value (obtained by calling HttpServletRequest.getHeader(String name)).
    • headerValues - a Map that maps header names to a String[] of all values for that header (obtained by calling HttpServletRequest.getHeaders(String)).
    • cookie - a Map that maps cookie names to a single Cookie object. Cookies are retrieved according to the semantics of HttpServletRequest.getCookies(). If the same name is shared by multiple cookies, an implementation must use the first one encountered in the array of Cookie objects returned by the getCookies() method. However, users of the cookie implicit object must be aware that the ordering of cookies is currently unspecified in the servlet specification.
    • initParam - a Map that maps context initialization parameter names to their String parameter value (obtained by calling ServletContext.getInitParameter(String name)).

    Since:
    JSP 2.1
    See Also:
    ELResolver

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      ImplicitObjectELResolver()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<String> getCommonPropertyType(ELContext context, Object base)
      If the base object is null, returns String.class.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      If the base object is null, and the property matches the name of a JSP implicit object, returns an Iterator containing FeatureDescriptor objects with information about each JSP implicit object resolved by this resolver.
      Class getType(ELContext context, Object base, Object property)
      If the base object is null, and the property matches the name of a JSP implicit object, returns null to indicate that no types are ever accepted to setValue().
      Object getValue(ELContext context, Object base, Object property)
      If the base object is null, and the property matches the name of a JSP implicit object, returns the implicit object.
      boolean isReadOnly(ELContext context, Object base, Object property)
      If the base object is null, and the property matches the name of a JSP implicit object, returns true to indicate that implicit objects cannot be overwritten.
      void setValue(ELContext context, Object base, Object property, Object val)
      If the base object is null, and the property matches the name of a JSP implicit object, throws PropertyNotWritableException to indicate that implicit objects cannot be overwritten.

      • Methods inherited from class javax.el.ELResolver

        convertToType, invoke

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ImplicitObjectELResolver

        public ImplicitObjectELResolver()

    • Method Detail

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)
        If the base object is null, and the property matches the name of a JSP implicit object, returns the implicit object.

        The propertyResolved property of the ELContext object must be set to true by this resolver before returning if an implicit object is matched. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in an immediate return.
        property - The name of the implicit object to resolve.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the implicit object; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getType

        public Class getType(ELContext context,
            Object base,
            Object property)
        If the base object is null, and the property matches the name of a JSP implicit object, returns null to indicate that no types are ever accepted to setValue().

        The propertyResolved property of the ELContext object must be set to true by this resolver before returning if an implicit object is matched. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in an immediate return.
        property - The name of the implicit object to resolve.
        Returns:
        If the propertyResolved property of ELContext was set to true, then null; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object val)
        If the base object is null, and the property matches the name of a JSP implicit object, throws PropertyNotWritableException to indicate that implicit objects cannot be overwritten.

        The propertyResolved property of the ELContext object must be set to true by this resolver before returning if an implicit object is matched. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in an immediate return.
        property - The name of the implicit object.
        val - The value to be associated with the implicit object.
        Throws:
        NullPointerException - if context is null.
        PropertyNotWritableException - always thrown, if the implicit object name is recognized by this resolver.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        If the base object is null, and the property matches the name of a JSP implicit object, returns true to indicate that implicit objects cannot be overwritten.

        The propertyResolved property of the ELContext object must be set to true by this resolver before returning if an implicit object is matched. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in an immediate return.
        property - The name of the implicit object.
        Returns:
        If the propertyResolved property of ELContext was set to true, then true; otherwise undefined.
        Throws:
        NullPointerException - if context is null.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        If the base object is null, and the property matches the name of a JSP implicit object, returns an Iterator containing FeatureDescriptor objects with information about each JSP implicit object resolved by this resolver. Otherwise, returns null.

        The Iterator returned must contain one instance of FeatureDescriptor for each of the EL implicit objects defined by the JSP spec. Each info object contains information about a single implicit object, and is initialized as follows:

      • displayName - The name of the implicit object.
      • name - Same as displayName property.
      • shortDescription - A suitable description for the implicit object. Will vary by implementation.
      • expert - false
      • hidden - false
      • preferred - true
        • In addition, the following named attributes must be set in the returned FeatureDescriptors:
      • ELResolver.TYPE - The runtime type of the implicit object.
      • ELResolver.RESOLVABLE_AT_DESIGN_TIME - true.

        • Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in a null return value.
        Returns:
        An Iterator containing one FeatureDescriptor object for each implicit object, or null if base is not null.
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<String> getCommonPropertyType(ELContext context,
                                  Object base)
        If the base object is null, returns String.class. Otherwise, returns null.
        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in a null return value.
        Returns:
        null if base is not null; otherwise String.class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.servlet.jsp.el (Java(TM) EE 7 Specification APIs)

javax.servlet.jsp.el

Interfaces

  • FunctionMapper
  • VariableResolver

Classes

  • Expression
  • ExpressionEvaluator
  • ImplicitObjectELResolver
  • ScopedAttributeELResolver

Exceptions

  • ELException
  • ELParseException


javax.servlet.jsp.el (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet.jsp.el

Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.

See: Description

  • Interface Summary
    Interface Description
    FunctionMapper Deprecated
    As of JSP 2.1, replaced by FunctionMapper
    VariableResolver Deprecated
    As of JSP 2.1, replaced by ELResolver
  • Class Summary
    Class Description
    Expression Deprecated
    As of JSP 2.1, replaced by ValueExpression
    ExpressionEvaluator Deprecated
    As of JSP 2.1, replaced by ExpressionFactory
    ImplicitObjectELResolver
    Defines variable resolution behavior for the EL implicit objects defined in the JSP specification.
    ScopedAttributeELResolver
    Defines variable resolution behavior for scoped attributes.
  • Exception Summary
    Exception Description
    ELException Deprecated
    As of JSP 2.1, replaced by ELException
    ELParseException Deprecated
    As of JSP 2.1, replaced by ELException

Package javax.servlet.jsp.el Description

Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.

The package also defines programmatic access to the old Expression Language evaluator (pre JSP 2.1).

Please note that as of JSP 2.1, all classes and interfaces that were in package javax.servlet.jsp.el have been deprecated in favor of the new unified Expression Language APIs (javax.el). See the Expression Language specification document for more details.

While a JSP container must still support the deprecated APIs defined in javax.servlet.jsp.el, developers should only rely on the new javax.el APIs for new development work.

Two ELResolver classes have been added in JSP 2.1 to implement object resolution rules that must be supported by a JSP container with the new unified Expression Language: ImplicitObjectELResolver and ScopedAttributeELResolver.

Documentation on the old and deprecated API

The JavaServer Pages(tm) (JSP) 2.0 specification provides a portable API for evaluating "EL Expressions". As of JSP 2.0, EL expressions can be placed directly in the template text of JSP pages and tag files.

This package contains a number of classes and interfaces that describe and define programmatic access to the Expression Language evaluator. This API can also be used by an implementation of JSP to evaluate the expressions, but other implementations, like open-coding into Java bytecodes, are allowed. This package is intended to have no dependencies on other portions of the JSP 2.0 specification.

Expression Evaluator

Programmatic access to the EL Expression Evaluator is provided through the following types:
  • ExpressionEvaluator
  • Expression
  • FunctionMapper
  • VariableResolver

An ExpressionEvaluator object can be obtained from a JspContext object through the getExpressionEvaluator method. An ExpressionEvaluator encapsulates the EL processor. An EL expression provided as a String can then be evaluated directly, or it can be parsed first into an Expression object. The parse step, can be used to factor out the cost of parsing the expression, or even the cost of optimizing the implementation.

The parsing of an expression string is done against a target type, a default prefix (that applies when a function has no prefix), and a FunctionMapper. The FunctionMapper object maps a prefix and a local name part into a java.lang.reflect.Method object.

The interpretation or evaluation of a parsed expression is done using a VariableResolver object. This object resolves top level object names into Objects. A VariableResolver can be obtained from a JspContext object through the getVariableResolver method.

Exceptions

The ELException exception is used by the expression language to denote any exception that may arise during the parsing or evaluation of an expression. The ELParseException exception is a subclass of ELException that corresponds to parsing errors

Parsing errors are conveyed as exceptions to simplify the API. It is expected that many JSP containers will use additional mechanisms to parse EL expressions and report their errors - a run-time API cannot provide accurate line-error numbers without additional machinery.

Code Fragment

Below is a non-normative code fragment outlining how the APIs can be used.

// Get an instance of an ExpressionEvaluator

ExpressionEvaluator ee = myJspContext.getExpressionEvaluator();
VariableResolver vr = myJspContext.getVariableResolver();

FunctionMapper fm; // we don't have a portable implementation yet

// Example of compiling an expression.  See [ISSUE-2]
// Errors detected this way may have higher quality than those
// found with a simple validate() invocation.

ExpressionCompilation ce;

try {
  ce = ee.prepareExpression(expr,
                            targetClass,
                            fm,
                            null // no prefixes
                            );
} catch (ELParseException e) {
        log (e.getMessage());
}

try {
  ce.evaluate(vr);
} catch (ElException e) {
        log (e);
}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet.jsp.el Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet.jsp.el

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.el.ELResolver
      • javax.servlet.jsp.el.ImplicitObjectELResolver
      • javax.servlet.jsp.el.ScopedAttributeELResolver
    • javax.servlet.jsp.el.Expression
    • javax.servlet.jsp.el.ExpressionEvaluator
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.servlet.jsp.el.ELException
          • javax.servlet.jsp.el.ELParseException

Interface Hierarchy

  • javax.servlet.jsp.el.FunctionMapper
  • javax.servlet.jsp.el.VariableResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ScopedAttributeELResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.el

Class ScopedAttributeELResolver

  • java.lang.Object
    • javax.el.ELResolver
      • javax.servlet.jsp.el.ScopedAttributeELResolver

  • public class ScopedAttributeELResolver
extends ELResolver
    Defines variable resolution behavior for scoped attributes.

    This resolver handles all variable resolutions (where base is null. It searches PageContext.findAttribute() for a matching attribute. If not found, it will return null, or in the case of setValue it will create a new attribute in the page scope with the given name.

    Since:
    JSP 2.1
    See Also:
    ELResolver

    • Field Summary

      • Fields inherited from class javax.el.ELResolver

        RESOLVABLE_AT_DESIGN_TIME, TYPE

    • Constructor Summary

      Constructors
      Constructor and Description
      ScopedAttributeELResolver()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<String> getCommonPropertyType(ELContext context, Object base)
      If the base object is null, returns String.class.
      Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
      If the base object is null, returns an Iterator containing FeatureDescriptor objects with information about each scoped attribute resolved by this resolver.
      Class<Object> getType(ELContext context, Object base, Object property)
      If the base object is null, returns Object.class to indicate that any type is valid to set for a scoped attribute.
      Object getValue(ELContext context, Object base, Object property)
      If the base object is null, searches the page, request, session and application scopes for an attribute with the given name and returns it, or null if no attribute exists with the current name.
      boolean isReadOnly(ELContext context, Object base, Object property)
      If the base object is null, returns false to indicate that scoped attributes are never read-only.
      void setValue(ELContext context, Object base, Object property, Object val)
      If the base object is null, sets an existing scoped attribute to the new value, or creates a new scoped attribute if one does not exist by this name.

      • Methods inherited from class javax.el.ELResolver

        convertToType, invoke

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ScopedAttributeELResolver

        public ScopedAttributeELResolver()

    • Method Detail

      • getValue

        public Object getValue(ELContext context,
              Object base,
              Object property)
        If the base object is null, searches the page, request, session and application scopes for an attribute with the given name and returns it, or null if no attribute exists with the current name.

        The propertyResolved property of the ELContext object must be set to true by this resolver before returning if base is null. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        getValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in an immediate return.
        property - The name of the scoped attribute to resolve.
        Returns:
        If the propertyResolved property of ELContext was set to true, then the scoped attribute; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getType

        public Class<Object> getType(ELContext context,
                    Object base,
                    Object property)
        If the base object is null, returns Object.class to indicate that any type is valid to set for a scoped attribute.

        The propertyResolved property of the ELContext object must be set to true by this resolver before returning if base is null. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        getType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in an immediate return.
        property - The name of the scoped attribute to resolve.
        Returns:
        If the propertyResolved property of ELContext was set to true, then Object.class; otherwise undefined.
        Throws:
        NullPointerException - if context is null
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • setValue

        public void setValue(ELContext context,
            Object base,
            Object property,
            Object val)
        If the base object is null, sets an existing scoped attribute to the new value, or creates a new scoped attribute if one does not exist by this name.

        If the provided attribute name matches the key of an attribute in page scope, request scope, session scope, or application scope, the corresponding attribute value will be replaced by the provided value. Otherwise, a new page scope attribute will be created with the given name and value.

        The propertyResolved property of the ELContext object must be set to true by this resolver before returning if base is null. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        setValue in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in an immediate return.
        property - The name of the scoped attribute to set.
        val - The value for the scoped attribute.
        Throws:
        NullPointerException - if context is null.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • isReadOnly

        public boolean isReadOnly(ELContext context,
                 Object base,
                 Object property)
        If the base object is null, returns false to indicate that scoped attributes are never read-only.

        The propertyResolved property of the ELContext object must be set to true by this resolver before returning if base is null. If this property is not true after this method is called, the caller should ignore the return value.

        Specified by:
        isReadOnly in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in an immediate return.
        property - The name of the scoped attribute.
        Returns:
        If the propertyResolved property of ELContext was set to true, then false; otherwise undefined.
        Throws:
        NullPointerException - if context is null.
        ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

      • getFeatureDescriptors

        public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                Object base)
        If the base object is null, returns an Iterator containing FeatureDescriptor objects with information about each scoped attribute resolved by this resolver. Otherwise, returns null.

        The Iterator returned must contain one instance of FeatureDescriptor for each scoped attribute found in any scope. Each info object contains information about a single scoped attribute, and is initialized as follows:

      • displayName - The name of the scoped attribute.
      • name - Same as displayName property.
      • shortDescription - A suitable description for the scoped attribute. Should include the attribute's current scope (page, request, session, application). Will vary by implementation.
      • expert - false
      • hidden - false
      • preferred - true
        • In addition, the following named attributes must be set in the returned FeatureDescriptors:
      • ELResolver.TYPE - The current runtime type of the scoped attribute.
      • ELResolver.RESOLVABLE_AT_DESIGN_TIME - true.

        • Specified by:
        getFeatureDescriptors in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in a null return value.
        Returns:
        An Iterator containing one FeatureDescriptor object for each scoped attribute, or null if base is not null.
        See Also:
        FeatureDescriptor

      • getCommonPropertyType

        public Class<String> getCommonPropertyType(ELContext context,
                                  Object base)
        If the base object is null, returns String.class. Otherwise, returns null.
        Specified by:
        getCommonPropertyType in class ELResolver
        Parameters:
        context - The context of this evaluation.
        base - Only null is handled by this resolver. Other values will result in a null return value.
        Returns:
        null if base is not null; otherwise String.class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.servlet.jsp.el (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet.jsp.el

  • Packages that use javax.servlet.jsp.el
    Package Description
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.el
    Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.
  • Classes in javax.servlet.jsp.el used by javax.servlet.jsp
    Class and Description
    ExpressionEvaluator
    Deprecated.
    As of JSP 2.1, replaced by ExpressionFactory
    VariableResolver
    Deprecated.
    As of JSP 2.1, replaced by ELResolver
  • Classes in javax.servlet.jsp.el used by javax.servlet.jsp.el
    Class and Description
    ELException
    Deprecated.
    As of JSP 2.1, replaced by ELException
    Expression
    Deprecated.
    As of JSP 2.1, replaced by ValueExpression
    FunctionMapper
    Deprecated.
    As of JSP 2.1, replaced by FunctionMapper
    VariableResolver
    Deprecated.
    As of JSP 2.1, replaced by ELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


VariableResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.el

Interface VariableResolver

  • Deprecated.
    As of JSP 2.1, replaced by ELResolver

    public interface VariableResolver

    This class is used to customize the way an ExpressionEvaluator resolves variable references at evaluation time. For example, instances of this class can implement their own variable lookup mechanisms, or introduce the notion of "implicit variables" which override any other variables. An instance of this class should be passed when evaluating an expression.

    An instance of this class includes the context against which resolution will happen

    Since:
    JSP 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object resolveVariable(String pName)
      Deprecated.
      Resolves the specified variable.

    • Method Detail

      • resolveVariable

        Object resolveVariable(String pName)
                       throws ELException
        Deprecated.
        Resolves the specified variable. Returns null if the variable is not found.
        Parameters:
        pName - the name of the variable to resolve
        Returns:
        the result of the variable resolution
        Throws:
        ELException - if a failure occurred while trying to resolve the given variable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.servlet.jsp.el.ELException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.el.ELException

  • Packages that use ELException
    Package Description
    javax.servlet.jsp.el
    Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.

    • Uses of ELException in javax.servlet.jsp.el

      Subclasses of ELException in javax.servlet.jsp.el
      Modifier and Type Class and Description
      class  ELParseException
      Deprecated.
      As of JSP 2.1, replaced by ELException
      Methods in javax.servlet.jsp.el that throw ELException
      Modifier and Type Method and Description
      abstract Object ExpressionEvaluator.evaluate(String expression, Class expectedType, VariableResolver vResolver, FunctionMapper fMapper)
      Deprecated.
      Evaluates an expression.
      abstract Object Expression.evaluate(VariableResolver vResolver)
      Deprecated.
      Evaluates an expression that was previously prepared.
      abstract Expression ExpressionEvaluator.parseExpression(String expression, Class expectedType, FunctionMapper fMapper)
      Deprecated.
      Prepare an expression for later evaluation.
      Object VariableResolver.resolveVariable(String pName)
      Deprecated.
      Resolves the specified variable.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.el.ELParseException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.el.ELParseException

No usage of javax.servlet.jsp.el.ELParseException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.el.Expression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.el.Expression

  • Packages that use Expression
    Package Description
    javax.servlet.jsp.el
    Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.

    • Uses of Expression in javax.servlet.jsp.el

      Methods in javax.servlet.jsp.el that return Expression
      Modifier and Type Method and Description
      abstract Expression ExpressionEvaluator.parseExpression(String expression, Class expectedType, FunctionMapper fMapper)
      Deprecated.
      Prepare an expression for later evaluation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.el.ExpressionEvaluator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.el.ExpressionEvaluator

  • Packages that use ExpressionEvaluator
    Package Description
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.

    • Uses of ExpressionEvaluator in javax.servlet.jsp

      Methods in javax.servlet.jsp that return ExpressionEvaluator
      Modifier and Type Method and Description
      abstract ExpressionEvaluator JspContext.getExpressionEvaluator()
      Deprecated.
      As of JSP 2.1, replaced by JspApplicationContext.getExpressionFactory()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.el.ImplicitObjectELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.el.ImplicitObjectELResolver

No usage of javax.servlet.jsp.el.ImplicitObjectELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.el.ScopedAttributeELResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.el.ScopedAttributeELResolver

No usage of javax.servlet.jsp.el.ScopedAttributeELResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.el.FunctionMapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.el.FunctionMapper

  • Packages that use FunctionMapper
    Package Description
    javax.servlet.jsp.el
    Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.

    • Uses of FunctionMapper in javax.servlet.jsp.el

      Methods in javax.servlet.jsp.el with parameters of type FunctionMapper
      Modifier and Type Method and Description
      abstract Object ExpressionEvaluator.evaluate(String expression, Class expectedType, VariableResolver vResolver, FunctionMapper fMapper)
      Deprecated.
      Evaluates an expression.
      abstract Expression ExpressionEvaluator.parseExpression(String expression, Class expectedType, FunctionMapper fMapper)
      Deprecated.
      Prepare an expression for later evaluation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.el.VariableResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.el.VariableResolver

  • Packages that use VariableResolver
    Package Description
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.el
    Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.

    • Uses of VariableResolver in javax.servlet.jsp

      Methods in javax.servlet.jsp that return VariableResolver
      Modifier and Type Method and Description
      abstract VariableResolver JspContext.getVariableResolver()
      Deprecated.
      As of JSP 2.1, replaced by ELContext.getELResolver(), which can be obtained by jspContext.getELContext().getELResolver().

    • Uses of VariableResolver in javax.servlet.jsp.el

      Methods in javax.servlet.jsp.el with parameters of type VariableResolver
      Modifier and Type Method and Description
      abstract Object ExpressionEvaluator.evaluate(String expression, Class expectedType, VariableResolver vResolver, FunctionMapper fMapper)
      Deprecated.
      Evaluates an expression.
      abstract Object Expression.evaluate(VariableResolver vResolver)
      Deprecated.
      Evaluates an expression that was previously prepared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ConditionalTagSupport (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.core

Class ConditionalTagSupport

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport
      • javax.servlet.jsp.jstl.core.ConditionalTagSupport
  • All Implemented Interfaces:
    Serializable, IterationTag, JspTag, Tag

    public abstract class ConditionalTagSupport
extends TagSupport

    Abstract class that facilitates implementation of conditional actions where the boolean result is exposed as a JSP scoped variable. The boolean result may then be used as the test condition in a <c:when> action.

    This base class provides support for:

    • Conditional processing of the action's body based on the returned value of the abstract method condition().
    • Storing the result of condition() as a Boolean object into a JSP scoped variable identified by attributes var and scope.
    Author:
    Shawn Bayern
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.servlet.jsp.tagext.TagSupport

        id, pageContext

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      ConditionalTagSupport()
      Base constructor to initialize local state.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected abstract boolean condition()
      Subclasses implement this method to compute the boolean result of the conditional action.
      int doStartTag()
      Includes its body if condition() evaluates to true.
      void release()
      Releases any resources this ConditionalTagSupport may have (or inherit).
      void setScope(String scope)
      Sets the 'scope' attribute.
      void setVar(String var)
      Sets the 'var' attribute.

      • Methods inherited from class javax.servlet.jsp.tagext.TagSupport

        doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ConditionalTagSupport

        public ConditionalTagSupport()
        Base constructor to initialize local state. As with TagSupport, subclasses should not implement constructors with arguments, and no-argument constructors implemented by subclasses must call the superclass constructor.

    • Method Detail

      • condition

        protected abstract boolean condition()
                              throws JspTagException

        Subclasses implement this method to compute the boolean result of the conditional action. This method is invoked once per tag invocation by doStartTag().

        Returns:
        a boolean representing the condition that a particular subclass uses to drive its conditional logic.
        Throws:
        JspTagException

      • doStartTag

        public int doStartTag()
               throws JspException
        Includes its body if condition() evaluates to true.
        Specified by:
        doStartTag in interface Tag
        Overrides:
        doStartTag in class TagSupport
        Returns:
        SKIP_BODY
        Throws:
        JspException - if an error occurs while processing this tag
        See Also:
        Tag.doStartTag()

      • release

        public void release()
        Releases any resources this ConditionalTagSupport may have (or inherit).
        Specified by:
        release in interface Tag
        Overrides:
        release in class TagSupport
        See Also:
        Tag.release()

      • setVar

        public void setVar(String var)
        Sets the 'var' attribute.
        Parameters:
        var - Name of the exported scoped variable storing the result of condition().

      • setScope

        public void setScope(String scope)
        Sets the 'scope' attribute.
        Parameters:
        scope - Scope of the 'var' attribute
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Config (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.core

Class Config

  • java.lang.Object
    • javax.servlet.jsp.jstl.core.Config

  • public class Config
extends Object
    Class supporting access to configuration settings.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FMT_FALLBACK_LOCALE
      Name of configuration setting for fallback locale
      static String FMT_LOCALE
      Name of configuration setting for application- (as opposed to browser-) based preferred locale
      static String FMT_LOCALIZATION_CONTEXT
      Name of configuration setting for i18n localization context
      static String FMT_TIME_ZONE
      Name of localization setting for time zone
      static String SQL_DATA_SOURCE
      Name of configuration setting for SQL data source
      static String SQL_MAX_ROWS
      Name of configuration setting for maximum number of rows to be included in SQL query result

    • Constructor Summary

      Constructors
      Constructor and Description
      Config()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Object find(PageContext pc, String name)
      Finds the value associated with a specific configuration setting identified by its context initialization parameter name.
      static Object get(HttpSession session, String name)
      Looks up a configuration variable in the "session" scope.
      static Object get(PageContext pc, String name, int scope)
      Looks up a configuration variable in the given scope.
      static Object get(ServletContext context, String name)
      Looks up a configuration variable in the "application" scope.
      static Object get(ServletRequest request, String name)
      Looks up a configuration variable in the "request" scope.
      static void remove(HttpSession session, String name)
      Removes a configuration variable from the "session" scope.
      static void remove(PageContext pc, String name, int scope)
      Removes a configuration variable from the given scope.
      static void remove(ServletContext context, String name)
      Removes a configuration variable from the "application" scope.
      static void remove(ServletRequest request, String name)
      Removes a configuration variable from the "request" scope.
      static void set(HttpSession session, String name, Object value)
      Sets the value of a configuration variable in the "session" scope.
      static void set(PageContext pc, String name, Object value, int scope)
      Sets the value of a configuration variable in the given scope.
      static void set(ServletContext context, String name, Object value)
      Sets the value of a configuration variable in the "application" scope.
      static void set(ServletRequest request, String name, Object value)
      Sets the value of a configuration variable in the "request" scope.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FMT_LOCALE

        public static final String FMT_LOCALE
        Name of configuration setting for application- (as opposed to browser-) based preferred locale
        See Also:
        Constant Field Values

      • FMT_FALLBACK_LOCALE

        public static final String FMT_FALLBACK_LOCALE
        Name of configuration setting for fallback locale
        See Also:
        Constant Field Values

      • FMT_LOCALIZATION_CONTEXT

        public static final String FMT_LOCALIZATION_CONTEXT
        Name of configuration setting for i18n localization context
        See Also:
        Constant Field Values

      • FMT_TIME_ZONE

        public static final String FMT_TIME_ZONE
        Name of localization setting for time zone
        See Also:
        Constant Field Values

      • SQL_DATA_SOURCE

        public static final String SQL_DATA_SOURCE
        Name of configuration setting for SQL data source
        See Also:
        Constant Field Values

      • SQL_MAX_ROWS

        public static final String SQL_MAX_ROWS
        Name of configuration setting for maximum number of rows to be included in SQL query result
        See Also:
        Constant Field Values

    • Constructor Detail

      • Config

        public Config()

    • Method Detail

      • get

        public static Object get(PageContext pc,
         String name,
         int scope)
        Looks up a configuration variable in the given scope.

        The lookup of configuration variables is performed as if each scope had its own name space, that is, the same configuration variable name in one scope does not replace one stored in a different scope.

        Parameters:
        pc - Page context in which the configuration variable is to be looked up
        name - Configuration variable name
        scope - Scope in which the configuration variable is to be looked up
        Returns:
        The java.lang.Object associated with the configuration variable, or null if it is not defined.

      • get

        public static Object get(ServletRequest request,
         String name)
        Looks up a configuration variable in the "request" scope.

        The lookup of configuration variables is performed as if each scope had its own name space, that is, the same configuration variable name in one scope does not replace one stored in a different scope.

        Parameters:
        request - Request object in which the configuration variable is to be looked up
        name - Configuration variable name
        Returns:
        The java.lang.Object associated with the configuration variable, or null if it is not defined.

      • get

        public static Object get(HttpSession session,
         String name)
        Looks up a configuration variable in the "session" scope.

        The lookup of configuration variables is performed as if each scope had its own name space, that is, the same configuration variable name in one scope does not replace one stored in a different scope.

        Parameters:
        session - Session object in which the configuration variable is to be looked up
        name - Configuration variable name
        Returns:
        The java.lang.Object associated with the configuration variable, or null if it is not defined, if session is null, or if the session is invalidated.

      • get

        public static Object get(ServletContext context,
         String name)
        Looks up a configuration variable in the "application" scope.

        The lookup of configuration variables is performed as if each scope had its own name space, that is, the same configuration variable name in one scope does not replace one stored in a different scope.

        Parameters:
        context - Servlet context in which the configuration variable is to be looked up
        name - Configuration variable name
        Returns:
        The java.lang.Object associated with the configuration variable, or null if it is not defined.

      • set

        public static void set(PageContext pc,
       String name,
       Object value,
       int scope)
        Sets the value of a configuration variable in the given scope.

        Setting the value of a configuration variable is performed as if each scope had its own namespace, that is, the same configuration variable name in one scope does not replace one stored in a different scope.

        Parameters:
        pc - Page context in which the configuration variable is to be set
        name - Configuration variable name
        value - Configuration variable value
        scope - Scope in which the configuration variable is to be set

      • set

        public static void set(ServletRequest request,
       String name,
       Object value)
        Sets the value of a configuration variable in the "request" scope.

        Setting the value of a configuration variable is performed as if each scope had its own namespace, that is, the same configuration variable name in one scope does not replace one stored in a different scope.

        Parameters:
        request - Request object in which the configuration variable is to be set
        name - Configuration variable name
        value - Configuration variable value

      • set

        public static void set(HttpSession session,
       String name,
       Object value)
        Sets the value of a configuration variable in the "session" scope.

        Setting the value of a configuration variable is performed as if each scope had its own namespace, that is, the same configuration variable name in one scope does not replace one stored in a different scope.

        Parameters:
        session - Session object in which the configuration variable is to be set
        name - Configuration variable name
        value - Configuration variable value

      • set

        public static void set(ServletContext context,
       String name,
       Object value)
        Sets the value of a configuration variable in the "application" scope.

        Setting the value of a configuration variable is performed as if each scope had its own namespace, that is, the same configuration variable name in one scope does not replace one stored in a different scope.

        Parameters:
        context - Servlet context in which the configuration variable is to be set
        name - Configuration variable name
        value - Configuration variable value

      • remove

        public static void remove(PageContext pc,
          String name,
          int scope)
        Removes a configuration variable from the given scope.

        Removing a configuration variable is performed as if each scope had its own namespace, that is, the same configuration variable name in one scope does not impact one stored in a different scope.

        Parameters:
        pc - Page context from which the configuration variable is to be removed
        name - Configuration variable name
        scope - Scope from which the configuration variable is to be removed

      • remove

        public static void remove(ServletRequest request,
          String name)
        Removes a configuration variable from the "request" scope.

        Removing a configuration variable is performed as if each scope had its own namespace, that is, the same configuration variable name in one scope does not impact one stored in a different scope.

        Parameters:
        request - Request object from which the configuration variable is to be removed
        name - Configuration variable name

      • remove

        public static void remove(HttpSession session,
          String name)
        Removes a configuration variable from the "session" scope.

        Removing a configuration variable is performed as if each scope had its own namespace, that is, the same configuration variable name in one scope does not impact one stored in a different scope.

        Parameters:
        session - Session object from which the configuration variable is to be removed
        name - Configuration variable name

      • remove

        public static void remove(ServletContext context,
          String name)
        Removes a configuration variable from the "application" scope.

        Removing a configuration variable is performed as if each scope had its own namespace, that is, the same configuration variable name in one scope does not impact one stored in a different scope.

        Parameters:
        context - Servlet context from which the configuration variable is to be removed
        name - Configuration variable name

      • find

        public static Object find(PageContext pc,
          String name)
        Finds the value associated with a specific configuration setting identified by its context initialization parameter name.

        For each of the JSP scopes (page, request, session, application), get the value of the configuration variable identified by name using method get(). Return as soon as a non-null value is found. If no value is found, get the value of the context initialization parameter identified by name.

        Parameters:
        pc - Page context in which the configuration setting is to be searched
        name - Context initialization parameter name of the configuration setting
        Returns:
        The java.lang.Object associated with the configuration setting identified by name, or null if it is not defined.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IndexedValueExpression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.core

Class IndexedValueExpression

  • java.lang.Object
    • javax.el.Expression
      • javax.el.ValueExpression
        • javax.servlet.jsp.jstl.core.IndexedValueExpression
  • All Implemented Interfaces:
    Serializable

    public final class IndexedValueExpression
extends ValueExpression
    Version:
    $Id: IndexedValueExpression.java,v 1.3 2006/11/03 17:21:57 jluehe Exp $
    Author:
    Jacob Hookom
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected Integer | i
      protected ValueExpression | orig

    • Constructor Summary

      Constructors
      Constructor and Description
      IndexedValueExpression(ValueExpression orig, int i)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Determines whether the specified object is equal to this Expression.
      Class getExpectedType()
      Returns the type the result of the expression will be coerced to after evaluation.
      String getExpressionString()
      Returns the original String used to create this Expression, unmodified.
      Class getType(ELContext context)
      Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ValueExpression.setValue(javax.el.ELContext, java.lang.Object) method.
      Object getValue(ELContext context)
      Evaluates the expression relative to the provided context, and returns the resulting value.
      int hashCode()
      Returns the hash code for this Expression.
      boolean isLiteralText()
      Returns whether this expression was created from only literal text.
      boolean isReadOnly(ELContext context)
      Evaluates the expression relative to the provided context, and returns true if a call to ValueExpression.setValue(javax.el.ELContext, java.lang.Object) will always fail.
      void setValue(ELContext context, Object value)
      Evaluates the expression relative to the provided context, and sets the result to the provided value.

      • Methods inherited from class javax.el.ValueExpression

        getValueReference

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • i

        protected final Integer i

      • orig

        protected final ValueExpression orig

    • Constructor Detail

      • IndexedValueExpression

        public IndexedValueExpression(ValueExpression orig,
                      int i)

    • Method Detail

      • getValue

        public Object getValue(ELContext context)
        Description copied from class: ValueExpression
        Evaluates the expression relative to the provided context, and returns the resulting value.

        The resulting value is automatically coerced to the type returned by getExpectedType(), which was provided to the ExpressionFactory when this expression was created.

        Specified by:
        getValue in class ValueExpression
        Parameters:
        context - The context of this evaluation.
        Returns:
        The result of the expression evaluation.

      • setValue

        public void setValue(ELContext context,
            Object value)
        Description copied from class: ValueExpression
        Evaluates the expression relative to the provided context, and sets the result to the provided value.
        Specified by:
        setValue in class ValueExpression
        Parameters:
        context - The context of this evaluation.
        value - The new value to be set.

      • isReadOnly

        public boolean isReadOnly(ELContext context)
        Description copied from class: ValueExpression
        Evaluates the expression relative to the provided context, and returns true if a call to ValueExpression.setValue(javax.el.ELContext, java.lang.Object) will always fail.
        Specified by:
        isReadOnly in class ValueExpression
        Parameters:
        context - The context of this evaluation.
        Returns:
        true if the expression is read-only or false if not.

      • getType

        public Class getType(ELContext context)
        Description copied from class: ValueExpression
        Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ValueExpression.setValue(javax.el.ELContext, java.lang.Object) method.

        This is not always the same as getValue().getClass(). For example, in the case of an expression that references an array element, the getType method will return the element type of the array, which might be a superclass of the type of the actual element that is currently in the specified array element.

        Specified by:
        getType in class ValueExpression
        Parameters:
        context - The context of this evaluation.
        Returns:
        the most general acceptable type; otherwise undefined.

      • getExpectedType

        public Class getExpectedType()
        Description copied from class: ValueExpression
        Returns the type the result of the expression will be coerced to after evaluation.
        Specified by:
        getExpectedType in class ValueExpression
        Returns:
        the expectedType passed to the ExpressionFactory.createValueExpression method that created this ValueExpression.

      • getExpressionString

        public String getExpressionString()
        Description copied from class: Expression
        Returns the original String used to create this Expression, unmodified.

        This is used for debugging purposes but also for the purposes of comparison (e.g. to ensure the expression in a configuration file has not changed).

        This method does not provide sufficient information to re-create an expression. Two different expressions can have exactly the same expression string but different function mappings. Serialization should be used to save and restore the state of an Expression.

        Specified by:
        getExpressionString in class Expression
        Returns:
        The original expression String.

      • equals

        public boolean equals(Object obj)
        Description copied from class: Expression
        Determines whether the specified object is equal to this Expression.

        The result is true if and only if the argument is not null, is an Expression object that is the of the same type (ValueExpression or MethodExpression), and has an identical parsed representation.

        Note that two expressions can be equal if their expression Strings are different. For example, ${fn1:foo()} and ${fn2:foo()} are equal if their corresponding FunctionMappers mapped fn1:foo and fn2:foo to the same method.

        Specified by:
        equals in class Expression
        Parameters:
        obj - the Object to test for equality.
        Returns:
        true if obj equals this Expression; false otherwise.
        See Also:
        Hashtable, Object.equals(java.lang.Object)

      • hashCode

        public int hashCode()
        Description copied from class: Expression
        Returns the hash code for this Expression.

        See the note in the Expression.equals(java.lang.Object) method on how two expressions can be equal if their expression Strings are different. Recall that if two objects are equal according to the equals(Object) method, then calling the hashCode method on each of the two objects must produce the same integer result. Implementations must take special note and implement hashCode correctly.

        Specified by:
        hashCode in class Expression
        Returns:
        The hash code for this Expression.
        See Also:
        Expression.equals(java.lang.Object), Hashtable, Object.hashCode()

      • isLiteralText

        public boolean isLiteralText()
        Description copied from class: Expression
        Returns whether this expression was created from only literal text.

        This method must return true if and only if the expression string this expression was created from contained no unescaped EL delimeters (${...} or #{...}).

        Specified by:
        isLiteralText in class Expression
        Returns:
        true if this expression was created from only literal text; false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IteratedExpression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.core

Class IteratedExpression

  • java.lang.Object
    • javax.servlet.jsp.jstl.core.IteratedExpression

  • public final class IteratedExpression
extends Object
    Version:
    $Id: IteratedExpression.java,v 1.6 2006/11/17 19:48:41 jluehe Exp $
    Author:
    Kin-man Chung

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected String | delims
      protected ValueExpression | orig

    • Constructor Summary

      Constructors
      Constructor and Description
      IteratedExpression(ValueExpression orig, String delims)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getItem(ELContext context, int i)
      Evaluates the stored ValueExpression and return the indexed item.
      ValueExpression getValueExpression()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • orig

        protected final ValueExpression orig

      • delims

        protected final String delims

    • Constructor Detail

      • IteratedExpression

        public IteratedExpression(ValueExpression orig,
                  String delims)

    • Method Detail

      • getItem

        public Object getItem(ELContext context,
             int i)
        Evaluates the stored ValueExpression and return the indexed item.
        Parameters:
        context - The ELContext used to evaluate the ValueExpression
        i - The index of the item to be retrieved

      • getValueExpression

        public ValueExpression getValueExpression()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IteratedValueExpression (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.core

Class IteratedValueExpression

  • java.lang.Object
    • javax.el.Expression
      • javax.el.ValueExpression
        • javax.servlet.jsp.jstl.core.IteratedValueExpression
  • All Implemented Interfaces:
    Serializable

    public final class IteratedValueExpression
extends ValueExpression
    Version:
    $Id: IteratedValueExpression.java,v 1.2 2005/12/08 01:20:43 kchung Exp $
    Author:
    Kin-man Chung
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected int | i
      protected IteratedExpression | iteratedExpression

    • Constructor Summary

      Constructors
      Constructor and Description
      IteratedValueExpression(IteratedExpression iteratedExpr, int i)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Determines whether the specified object is equal to this Expression.
      Class getExpectedType()
      Returns the type the result of the expression will be coerced to after evaluation.
      String getExpressionString()
      Returns the original String used to create this Expression, unmodified.
      Class getType(ELContext context)
      Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ValueExpression.setValue(javax.el.ELContext, java.lang.Object) method.
      Object getValue(ELContext context)
      Evaluates the expression relative to the provided context, and returns the resulting value.
      int hashCode()
      Returns the hash code for this Expression.
      boolean isLiteralText()
      Returns whether this expression was created from only literal text.
      boolean isReadOnly(ELContext context)
      Evaluates the expression relative to the provided context, and returns true if a call to ValueExpression.setValue(javax.el.ELContext, java.lang.Object) will always fail.
      void setValue(ELContext context, Object value)
      Evaluates the expression relative to the provided context, and sets the result to the provided value.

      • Methods inherited from class javax.el.ValueExpression

        getValueReference

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • i

        protected final int i

      • iteratedExpression

        protected final IteratedExpression iteratedExpression

    • Constructor Detail

      • IteratedValueExpression

        public IteratedValueExpression(IteratedExpression iteratedExpr,
                       int i)

    • Method Detail

      • getValue

        public Object getValue(ELContext context)
        Description copied from class: ValueExpression
        Evaluates the expression relative to the provided context, and returns the resulting value.

        The resulting value is automatically coerced to the type returned by getExpectedType(), which was provided to the ExpressionFactory when this expression was created.

        Specified by:
        getValue in class ValueExpression
        Parameters:
        context - The context of this evaluation.
        Returns:
        The result of the expression evaluation.

      • setValue

        public void setValue(ELContext context,
            Object value)
        Description copied from class: ValueExpression
        Evaluates the expression relative to the provided context, and sets the result to the provided value.
        Specified by:
        setValue in class ValueExpression
        Parameters:
        context - The context of this evaluation.
        value - The new value to be set.

      • isReadOnly

        public boolean isReadOnly(ELContext context)
        Description copied from class: ValueExpression
        Evaluates the expression relative to the provided context, and returns true if a call to ValueExpression.setValue(javax.el.ELContext, java.lang.Object) will always fail.
        Specified by:
        isReadOnly in class ValueExpression
        Parameters:
        context - The context of this evaluation.
        Returns:
        true if the expression is read-only or false if not.

      • getType

        public Class getType(ELContext context)
        Description copied from class: ValueExpression
        Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ValueExpression.setValue(javax.el.ELContext, java.lang.Object) method.

        This is not always the same as getValue().getClass(). For example, in the case of an expression that references an array element, the getType method will return the element type of the array, which might be a superclass of the type of the actual element that is currently in the specified array element.

        Specified by:
        getType in class ValueExpression
        Parameters:
        context - The context of this evaluation.
        Returns:
        the most general acceptable type; otherwise undefined.

      • getExpectedType

        public Class getExpectedType()
        Description copied from class: ValueExpression
        Returns the type the result of the expression will be coerced to after evaluation.
        Specified by:
        getExpectedType in class ValueExpression
        Returns:
        the expectedType passed to the ExpressionFactory.createValueExpression method that created this ValueExpression.

      • getExpressionString

        public String getExpressionString()
        Description copied from class: Expression
        Returns the original String used to create this Expression, unmodified.

        This is used for debugging purposes but also for the purposes of comparison (e.g. to ensure the expression in a configuration file has not changed).

        This method does not provide sufficient information to re-create an expression. Two different expressions can have exactly the same expression string but different function mappings. Serialization should be used to save and restore the state of an Expression.

        Specified by:
        getExpressionString in class Expression
        Returns:
        The original expression String.

      • equals

        public boolean equals(Object obj)
        Description copied from class: Expression
        Determines whether the specified object is equal to this Expression.

        The result is true if and only if the argument is not null, is an Expression object that is the of the same type (ValueExpression or MethodExpression), and has an identical parsed representation.

        Note that two expressions can be equal if their expression Strings are different. For example, ${fn1:foo()} and ${fn2:foo()} are equal if their corresponding FunctionMappers mapped fn1:foo and fn2:foo to the same method.

        Specified by:
        equals in class Expression
        Parameters:
        obj - the Object to test for equality.
        Returns:
        true if obj equals this Expression; false otherwise.
        See Also:
        Hashtable, Object.equals(java.lang.Object)

      • hashCode

        public int hashCode()
        Description copied from class: Expression
        Returns the hash code for this Expression.

        See the note in the Expression.equals(java.lang.Object) method on how two expressions can be equal if their expression Strings are different. Recall that if two objects are equal according to the equals(Object) method, then calling the hashCode method on each of the two objects must produce the same integer result. Implementations must take special note and implement hashCode correctly.

        Specified by:
        hashCode in class Expression
        Returns:
        The hash code for this Expression.
        See Also:
        Expression.equals(java.lang.Object), Hashtable, Object.hashCode()

      • isLiteralText

        public boolean isLiteralText()
        Description copied from class: Expression
        Returns whether this expression was created from only literal text.

        This method must return true if and only if the expression string this expression was created from contained no unescaped EL delimeters (${...} or #{...}).

        Specified by:
        isLiteralText in class Expression
        Returns:
        true if this expression was created from only literal text; false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.servlet.jsp.jstl.core (Java(TM) EE 7 Specification APIs)

javax.servlet.jsp.jstl.core

Interfaces

  • LoopTag
  • LoopTagStatus

Classes

  • ConditionalTagSupport
  • Config
  • IndexedValueExpression
  • IteratedExpression
  • IteratedValueExpression
  • LoopTagSupport


javax.servlet.jsp.jstl.core (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet.jsp.jstl.core

Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

See: Description

  • Interface Summary
    Interface Description
    LoopTag
    JSTL allows developers to write custom iteration tags by implementing the LoopTag interface.
    LoopTagStatus
    Exposes the current status of an iteration.
  • Class Summary
    Class Description
    ConditionalTagSupport
    Abstract class that facilitates implementation of conditional actions where the boolean result is exposed as a JSP scoped variable.
    Config
    Class supporting access to configuration settings.
    IndexedValueExpression
    IteratedExpression
    IteratedValueExpression
    LoopTagSupport
    Base support class to facilitate implementation of iteration tags.

Package javax.servlet.jsp.jstl.core Description

Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

This tag library component provides:

  • General-purpose tags for the manipulation of scoped variables and handling of error conditions
  • Conditional tags for the conditional processing of a JSP page
  • Iterator tags for iterating over a wide variety of objects
  • URL-related tags for linking or redirecting to URL resources from a JSP page, or importing a URL resource into a JSP page
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet.jsp.jstl.core Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet.jsp.jstl.core

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.jsp.jstl.core.Config
    • javax.el.Expression (implements java.io.Serializable)
      • javax.el.ValueExpression
        • javax.servlet.jsp.jstl.core.IndexedValueExpression
        • javax.servlet.jsp.jstl.core.IteratedValueExpression
    • javax.servlet.jsp.jstl.core.IteratedExpression
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.servlet.jsp.jstl.core.ConditionalTagSupport
      • javax.servlet.jsp.jstl.core.LoopTagSupport (implements javax.servlet.jsp.tagext.IterationTag, javax.servlet.jsp.jstl.core.LoopTag, javax.servlet.jsp.tagext.TryCatchFinally)

Interface Hierarchy

  • javax.servlet.jsp.tagext.JspTag
    • javax.servlet.jsp.tagext.Tag
      • javax.servlet.jsp.jstl.core.LoopTag
  • javax.servlet.jsp.jstl.core.LoopTagStatus
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LoopTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.core

Interface LoopTag

  • All Superinterfaces:
    JspTag, Tag
    All Known Implementing Classes:
    LoopTagSupport

    public interface LoopTag
extends Tag

    JSTL allows developers to write custom iteration tags by implementing the LoopTag interface. This is not to be confused with javax.servlet.jsp.tagext.IterationTag as defined in JSP 1.2. LoopTag establishes a mechanism for iteration tags to be recognized and for type-safe implicit collaboration with custom subtags.

    In most cases, it will not be necessary to implement this interface manually, for a base support class (LoopTagSupport) is provided to facilitate implementation.

    Author:
    Shawn Bayern

    • Field Summary

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getCurrent()
      Retrieves the current item in the iteration.
      LoopTagStatus getLoopStatus()
      Retrieves a 'status' object to provide information about the current round of the iteration.

      • Methods inherited from interface javax.servlet.jsp.tagext.Tag

        doEndTag, doStartTag, getParent, release, setPageContext, setParent

    • Method Detail

      • getCurrent

        Object getCurrent()
        Retrieves the current item in the iteration. Behaves idempotently; calling getCurrent() repeatedly should return the same Object until the iteration is advanced. (Specifically, calling getCurrent() does not advance the iteration.)
        Returns:
        the current item as an object

      • getLoopStatus

        LoopTagStatus getLoopStatus()
        Retrieves a 'status' object to provide information about the current round of the iteration.
        Returns:
        The LoopTagStatus for the current LoopTag.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LoopTagStatus (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.core

Interface LoopTagStatus

  • public interface LoopTagStatus

    Exposes the current status of an iteration. JSTL provides a mechanism for LoopTags to return information about the current index of the iteration and convenience methods to determine whether or not the current round is either the first or last in the iteration. It also lets authors use the status object to obtain information about the iteration range, step, and current object.

    Environments that require more status can extend this interface.

    Author:
    Shawn Bayern

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Integer getBegin()
      Returns the value of the 'begin' attribute for the associated tag, or null if no 'begin' attribute was specified.
      int getCount()
      Retrieves the "count" of the current round of the iteration.
      Object getCurrent()
      Retrieves the current item in the iteration.
      Integer getEnd()
      Returns the value of the 'end' attribute for the associated tag, or null if no 'end' attribute was specified.
      int getIndex()
      Retrieves the index of the current round of the iteration.
      Integer getStep()
      Returns the value of the 'step' attribute for the associated tag, or null if no 'step' attribute was specified.
      boolean isFirst()
      Returns information about whether the current round of the iteration is the first one.
      boolean isLast()
      Returns information about whether the current round of the iteration is the last one.

    • Method Detail

      • getCurrent

        Object getCurrent()
        Retrieves the current item in the iteration. Behaves idempotently; calling getCurrent() repeatedly should return the same Object until the iteration is advanced. (Specifically, calling getCurrent() does not advance the iteration.)
        Returns:
        the current item as an object

      • getIndex

        int getIndex()
        Retrieves the index of the current round of the iteration. If iteration is being performed over a subset of an underlying array, java.lang.Collection, or other type, the index returned is absolute with respect to the underlying collection. Indices are 0-based.
        Returns:
        the 0-based index of the current round of the iteration

      • getCount

        int getCount()

        Retrieves the "count" of the current round of the iteration. The count is a relative, 1-based sequence number identifying the current "round" of iteration (in context with all rounds the current iteration will perform).

        As an example, an iteration with begin = 5, end = 15, and step = 5 produces the counts 1, 2, and 3 in that order.

        Returns:
        the 1-based count of the current round of the iteration

      • isFirst

        boolean isFirst()
        Returns information about whether the current round of the iteration is the first one. This current round may be the 'first' even when getIndex() != 0, for 'index' refers to the absolute index of the current 'item' in the context of its underlying collection. It is always that case that a true result from isFirst() implies getCount() == 1.
        Returns:
        true if the current round is the first in the iteration, false otherwise.

      • isLast

        boolean isLast()
        Returns information about whether the current round of the iteration is the last one. As with isFirst(), subsetting is taken into account. isLast() doesn't necessarily refer to the status of the underlying Iterator; it refers to whether or not the current round will be the final round of iteration for the tag associated with this LoopTagStatus.
        Returns:
        true if the current round is the last in the iteration, false otherwise.

      • getBegin

        Integer getBegin()
        Returns the value of the 'begin' attribute for the associated tag, or null if no 'begin' attribute was specified.
        Returns:
        the 'begin' value for the associated tag, or null if no 'begin' attribute was specified

      • getEnd

        Integer getEnd()
        Returns the value of the 'end' attribute for the associated tag, or null if no 'end' attribute was specified.
        Returns:
        the 'end' value for the associated tag, or null if no 'end' attribute was specified

      • getStep

        Integer getStep()
        Returns the value of the 'step' attribute for the associated tag, or null if no 'step' attribute was specified.
        Returns:
        the 'step' value for the associated tag, or null if no 'step' attribute was specified
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LoopTagSupport (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.core

Class LoopTagSupport

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport
      • javax.servlet.jsp.jstl.core.LoopTagSupport
  • All Implemented Interfaces:
    Serializable, LoopTag, IterationTag, JspTag, Tag, TryCatchFinally

    public abstract class LoopTagSupport
extends TagSupport
implements LoopTag, IterationTag, TryCatchFinally

    Base support class to facilitate implementation of iteration tags.

    Since most iteration tags will behave identically with respect to actual iterative behavior, JSTL provides this base support class to facilitate implementation. Many iteration tags will extend this and merely implement the hasNext() and next() methods to provide contents for the handler to iterate over.

    In particular, this base class provides support for:

    • Iteration control, based on protected prepare(), next(), and hasNext() methods
    • Subsetting (begin, end, step>functionality, including validation of subset parameters for sensibility)
    • item retrieval (getCurrent())
    • status retrieval (LoopTagStatus)
    • exposing attributes (set by var and varStatus attributes)

    In providing support for these tasks, LoopTagSupport contains certain control variables that act to modify the iteration. Accessors are provided for these control variables when the variables represent information needed or wanted at translation time (e.g., var, varStatus). For other variables, accessors cannot be provided here since subclasses may differ on their implementations of how those accessors are received. For instance, one subclass might accept a String and convert it into an object of a specific type by using an expression evaluator; others might accept objects directly. Still others might not want to expose such information to outside control.

    Author:
    Shawn Bayern
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected int begin
      Starting index ('begin' attribute)
      protected boolean beginSpecified
      Boolean flag indicating whether 'begin' was specified.
      protected ValueExpression deferredExpression
      The deferred expression if any
      protected int end
      Ending index of the iteration ('end' attribute).
      protected boolean endSpecified
      Boolean flag indicating whether 'end' was specified.
      protected String itemId
      Attribute-exposing control
      protected String statusId
      Attribute-exposing control
      protected int step
      Iteration step ('step' attribute)
      protected boolean stepSpecified
      Boolean flag indicating whether 'step' was specified.

      • Fields inherited from class javax.servlet.jsp.tagext.TagSupport

        id, pageContext

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      LoopTagSupport()
      Constructs a new LoopTagSupport.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      int doAfterBody()
      Continues the iteration when appropriate -- that is, if we (a) have more items and (b) don't run over our 'end' (given our 'step').
      void doCatch(Throwable t)
      Rethrows the given Throwable.
      void doFinally()
      Removes any attributes that this LoopTagSupport set.
      int doStartTag()
      Begins iterating by processing the first item.
      Object getCurrent()
      Retrieves the current item in the iteration.
      protected String | getDelims()
      LoopTagStatus getLoopStatus()
      Retrieves a 'status' object to provide information about the current round of the iteration.
      protected abstract boolean hasNext()
      Returns information concerning the availability of more items over which to iterate.
      protected abstract Object next()
      Returns the next object over which the tag should iterate.
      protected abstract void prepare()
      Prepares for a single tag invocation.
      void release()
      Releases any resources this LoopTagSupport may have (or inherit).
      void setVar(String id)
      Sets the 'var' attribute.
      void setVarStatus(String statusId)
      Sets the 'varStatus' attribute.
      protected void validateBegin()
      Ensures the "begin" property is sensible, throwing an exception expected to propagate up if it isn't
      protected void validateEnd()
      Ensures the "end" property is sensible, throwing an exception expected to propagate up if it isn't
      protected void validateStep()
      Ensures the "step" property is sensible, throwing an exception expected to propagate up if it isn't

      • Methods inherited from class javax.servlet.jsp.tagext.TagSupport

        doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.servlet.jsp.tagext.Tag

        doEndTag, getParent, setPageContext, setParent

    • Field Detail

      • begin

        protected int begin
        Starting index ('begin' attribute)

      • end

        protected int end
        Ending index of the iteration ('end' attribute). A value of -1 internally indicates 'no end specified', although accessors for the core JSTL tags do not allow this value to be supplied directly by the user.

      • step

        protected int step
        Iteration step ('step' attribute)

      • beginSpecified

        protected boolean beginSpecified
        Boolean flag indicating whether 'begin' was specified.

      • endSpecified

        protected boolean endSpecified
        Boolean flag indicating whether 'end' was specified.

      • stepSpecified

        protected boolean stepSpecified
        Boolean flag indicating whether 'step' was specified.

      • itemId

        protected String itemId
        Attribute-exposing control

      • statusId

        protected String statusId
        Attribute-exposing control

      • deferredExpression

        protected ValueExpression deferredExpression
        The deferred expression if any

    • Constructor Detail

      • LoopTagSupport

        public LoopTagSupport()
        Constructs a new LoopTagSupport. As with TagSupport, subclasses should not implement constructors with arguments, and no-arguments constructors implemented by subclasses must call the superclass constructor.

    • Method Detail

      • next

        protected abstract Object next()
                        throws JspTagException

        Returns the next object over which the tag should iterate. This method must be provided by concrete subclasses of LoopTagSupport to inform the base logic about what objects it should iterate over.

        It is expected that this method will generally be backed by an Iterator, but this will not always be the case. In particular, if retrieving the next object raises the possibility of an exception being thrown, this method allows that exception to propagate back to the JSP container as a JspTagException; a standalone Iterator would not be able to do this. (This explains why LoopTagSupport does not simply call for an Iterator from its subtags.)

        Returns:
        the java.lang.Object to use in the next round of iteration
        Throws:
        NoSuchElementException - if next() is called but no new elements are available
        JspTagException - for other, unexpected exceptions

      • hasNext

        protected abstract boolean hasNext()
                            throws JspTagException

        Returns information concerning the availability of more items over which to iterate. This method must be provided by concrete subclasses of LoopTagSupport to assist the iterative logic provided by the supporting base class.

        See next for more information about the purpose and expectations behind this tag.

        Returns:
        true if there is at least one more item to iterate over, false otherwise
        Throws:
        JspTagException
        See Also:
        next()

      • prepare

        protected abstract void prepare()
                         throws JspTagException

        Prepares for a single tag invocation. Specifically, allows subclasses to prepare for calls to hasNext() and next(). Subclasses can assume that prepare() will be called once for each invocation of doStartTag() in the superclass.

        Throws:
        JspTagException

      • release

        public void release()
        Releases any resources this LoopTagSupport may have (or inherit).
        Specified by:
        release in interface Tag
        Overrides:
        release in class TagSupport
        See Also:
        Tag.release()

      • doStartTag

        public int doStartTag()
               throws JspException
        Begins iterating by processing the first item.
        Specified by:
        doStartTag in interface Tag
        Overrides:
        doStartTag in class TagSupport
        Returns:
        SKIP_BODY
        Throws:
        JspException - if an error occurs while processing this tag
        See Also:
        Tag.doStartTag()

      • doAfterBody

        public int doAfterBody()
                throws JspException
        Continues the iteration when appropriate -- that is, if we (a) have more items and (b) don't run over our 'end' (given our 'step').
        Specified by:
        doAfterBody in interface IterationTag
        Overrides:
        doAfterBody in class TagSupport
        Returns:
        SKIP_BODY
        Throws:
        JspException - if an error occurs while processing this tag
        See Also:
        IterationTag.doAfterBody()

      • doFinally

        public void doFinally()
        Removes any attributes that this LoopTagSupport set.

        These attributes are intended to support scripting variables with NESTED scope, so we don't want to pollute attribute space by leaving them lying around.

        Specified by:
        doFinally in interface TryCatchFinally

      • doCatch

        public void doCatch(Throwable t)
             throws Throwable
        Rethrows the given Throwable.
        Specified by:
        doCatch in interface TryCatchFinally
        Parameters:
        t - The throwable exception navigating through this tag.
        Throws:
        Throwable - if the exception is to be rethrown further up the nest chain.

      • getCurrent

        public Object getCurrent()
        Description copied from interface: LoopTag
        Retrieves the current item in the iteration. Behaves idempotently; calling getCurrent() repeatedly should return the same Object until the iteration is advanced. (Specifically, calling getCurrent() does not advance the iteration.)
        Specified by:
        getCurrent in interface LoopTag
        Returns:
        the current item as an object

      • getLoopStatus

        public LoopTagStatus getLoopStatus()
        Description copied from interface: LoopTag
        Retrieves a 'status' object to provide information about the current round of the iteration.
        Specified by:
        getLoopStatus in interface LoopTag
        Returns:
        The LoopTagStatus for the current LoopTag.

      • getDelims

        protected String getDelims()

      • setVar

        public void setVar(String id)
        Sets the 'var' attribute.
        Parameters:
        id - Name of the exported scoped variable storing the current item of the iteration.

      • setVarStatus

        public void setVarStatus(String statusId)
        Sets the 'varStatus' attribute.
        Parameters:
        statusId - Name of the exported scoped variable storing the status of the iteration.

      • validateBegin

        protected void validateBegin()
                      throws JspTagException
        Ensures the "begin" property is sensible, throwing an exception expected to propagate up if it isn't
        Throws:
        JspTagException

      • validateEnd

        protected void validateEnd()
                    throws JspTagException
        Ensures the "end" property is sensible, throwing an exception expected to propagate up if it isn't
        Throws:
        JspTagException

      • validateStep

        protected void validateStep()
                     throws JspTagException
        Ensures the "step" property is sensible, throwing an exception expected to propagate up if it isn't
        Throws:
        JspTagException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.servlet.jsp.jstl.core (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet.jsp.jstl.core

  • Packages that use javax.servlet.jsp.jstl.core
    Package Description
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
  • Classes in javax.servlet.jsp.jstl.core used by javax.servlet.jsp.jstl.core
    Class and Description
    IteratedExpression
    LoopTag
    JSTL allows developers to write custom iteration tags by implementing the LoopTag interface.
    LoopTagStatus
    Exposes the current status of an iteration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.core.ConditionalTagSupport (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.core.ConditionalTagSupport

No usage of javax.servlet.jsp.jstl.core.ConditionalTagSupport
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.core.Config (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.core.Config

No usage of javax.servlet.jsp.jstl.core.Config
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.core.IndexedValueExpression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.core.IndexedValueExpression

No usage of javax.servlet.jsp.jstl.core.IndexedValueExpression
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.core.IteratedExpression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.core.IteratedExpression

  • Packages that use IteratedExpression
    Package Description
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of IteratedExpression in javax.servlet.jsp.jstl.core

      Fields in javax.servlet.jsp.jstl.core declared as IteratedExpression
      Modifier and Type | Field and Description
      protected IteratedExpression | IteratedValueExpression.iteratedExpression
      Constructors in javax.servlet.jsp.jstl.core with parameters of type IteratedExpression
      Constructor and Description
      IteratedValueExpression(IteratedExpression iteratedExpr, int i)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.core.IteratedValueExpression (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.core.IteratedValueExpression

No usage of javax.servlet.jsp.jstl.core.IteratedValueExpression
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.core.LoopTagSupport (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.core.LoopTagSupport

No usage of javax.servlet.jsp.jstl.core.LoopTagSupport
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.jstl.core.LoopTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.jstl.core.LoopTag

  • Packages that use LoopTag
    Package Description
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of LoopTag in javax.servlet.jsp.jstl.core

      Classes in javax.servlet.jsp.jstl.core that implement LoopTag
      Modifier and Type Class and Description
      class  LoopTagSupport
      Base support class to facilitate implementation of iteration tags.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.jstl.core.LoopTagStatus (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.jstl.core.LoopTagStatus

  • Packages that use LoopTagStatus
    Package Description
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of LoopTagStatus in javax.servlet.jsp.jstl.core

      Methods in javax.servlet.jsp.jstl.core that return LoopTagStatus
      Modifier and Type | Method and Description
      LoopTagStatus | LoopTagSupport.getLoopStatus()
      LoopTagStatus LoopTag.getLoopStatus()
      Retrieves a 'status' object to provide information about the current round of the iteration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.servlet.jsp.jstl.fmt (Java(TM) EE 7 Specification APIs)

javax.servlet.jsp.jstl.fmt

Classes

  • LocaleSupport
  • LocalizationContext


javax.servlet.jsp.jstl.fmt (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet.jsp.jstl.fmt

Classes and interfaces related to the locale sensitive formatting tag library component of the JavaServer Pages Standard Tag Library (JSTL).

See: Description

  • Class Summary
    Class Description
    LocaleSupport
    Class which exposes the locale-determination logic for resource bundles through convenience methods.
    LocalizationContext
    Class representing an I18N localization context.

Package javax.servlet.jsp.jstl.fmt Description

Classes and interfaces related to the locale sensitive formatting tag library component of the JavaServer Pages Standard Tag Library (JSTL).

This tag library component provides a number of formatting tags which allow numbers, dates, and times in a JSP page to be formatted and parsed in a locale-sensitive or customized manner.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet.jsp.jstl.fmt Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet.jsp.jstl.fmt

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.jsp.jstl.fmt.LocaleSupport
    • javax.servlet.jsp.jstl.fmt.LocalizationContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LocaleSupport (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.fmt

Class LocaleSupport

  • java.lang.Object
    • javax.servlet.jsp.jstl.fmt.LocaleSupport

  • public class LocaleSupport
extends Object
    Class which exposes the locale-determination logic for resource bundles through convenience methods.

    This class may be useful to any tag handler implementation that needs to produce localized messages. For example, this might be useful for exception messages that are intended directly for user consumption on an error page.

    Author:
    Jan Luehe

    • Constructor Summary

      Constructors
      Constructor and Description
      LocaleSupport()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static String getLocalizedMessage(PageContext pageContext, String key)
      Retrieves the localized message corresponding to the given key.
      static String getLocalizedMessage(PageContext pageContext, String key, Object[] args)
      Retrieves the localized message corresponding to the given key, and performs parametric replacement using the arguments specified via args.
      static String getLocalizedMessage(PageContext pageContext, String key, Object[] args, String basename)
      Retrieves the localized message corresponding to the given key, and performs parametric replacement using the arguments specified via args.
      static String getLocalizedMessage(PageContext pageContext, String key, String basename)
      Retrieves the localized message corresponding to the given key.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • LocaleSupport

        public LocaleSupport()

    • Method Detail

      • getLocalizedMessage

        public static String getLocalizedMessage(PageContext pageContext,
                         String key)
        Retrieves the localized message corresponding to the given key.

        The given key is looked up in the resource bundle of the default I18N localization context, which is retrieved from the javax.servlet.jsp.jstl.fmt.localizationContext configuration setting.

        If the configuration setting is empty, or the default I18N localization context does not contain any resource bundle, or the given key is undefined in its resource bundle, the string "???<key>???" is returned, where "<key>" is replaced with the given key.

        Parameters:
        pageContext - the page in which to get the localized message corresponding to the given key
        key - the message key
        Returns:
        the localized message corresponding to the given key

      • getLocalizedMessage

        public static String getLocalizedMessage(PageContext pageContext,
                         String key,
                         String basename)
        Retrieves the localized message corresponding to the given key.

        The given key is looked up in the resource bundle with the given base name.

        If no resource bundle with the given base name exists, or the given key is undefined in the resource bundle, the string "???<key>???" is returned, where "<key>" is replaced with the given key.

        Parameters:
        pageContext - the page in which to get the localized message corresponding to the given key
        key - the message key
        basename - the resource bundle base name
        Returns:
        the localized message corresponding to the given key

      • getLocalizedMessage

        public static String getLocalizedMessage(PageContext pageContext,
                         String key,
                         Object[] args)
        Retrieves the localized message corresponding to the given key, and performs parametric replacement using the arguments specified via args.

        See the specification of the <fmt:message> action for a description of how parametric replacement is implemented.

        The localized message is retrieved as in getLocalizedMessage(pageContext, key).

        Parameters:
        pageContext - the page in which to get the localized message corresponding to the given key
        key - the message key
        args - the arguments for parametric replacement
        Returns:
        the localized message corresponding to the given key

      • getLocalizedMessage

        public static String getLocalizedMessage(PageContext pageContext,
                         String key,
                         Object[] args,
                         String basename)
        Retrieves the localized message corresponding to the given key, and performs parametric replacement using the arguments specified via args.

        See the specification of the <fmt:message> action for a description of how parametric replacement is implemented.

        The localized message is retrieved as in getLocalizedMessage(pageContext, key, basename).

        Parameters:
        pageContext - the page in which to get the localized message corresponding to the given key
        key - the message key
        args - the arguments for parametric replacement
        basename - the resource bundle base name
        Returns:
        the localized message corresponding to the given key
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LocalizationContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.fmt

Class LocalizationContext

  • java.lang.Object
    • javax.servlet.jsp.jstl.fmt.LocalizationContext

  • public class LocalizationContext
extends Object
    Class representing an I18N localization context.

    An I18N localization context has two components: a resource bundle and the locale that led to the resource bundle match.

    The resource bundle component is used by <fmt:message> for mapping message keys to localized messages, and the locale component is used by the <fmt:message>, <fmt:formatNumber>, <fmt:parseNumber>, <fmt:formatDate>, and <fmt:parseDate> actions as their formatting or parsing locale, respectively.

    Author:
    Jan Luehe

    • Constructor Summary

      Constructors
      Constructor and Description
      LocalizationContext()
      Constructs an empty I18N localization context.
      LocalizationContext(ResourceBundle bundle)
      Constructs an I18N localization context from the given resource bundle.
      LocalizationContext(ResourceBundle bundle, Locale locale)
      Constructs an I18N localization context from the given resource bundle and locale.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Locale getLocale()
      Gets the locale of this I18N localization context.
      ResourceBundle getResourceBundle()
      Gets the resource bundle of this I18N localization context.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • LocalizationContext

        public LocalizationContext()
        Constructs an empty I18N localization context.

      • LocalizationContext

        public LocalizationContext(ResourceBundle bundle,
                   Locale locale)
        Constructs an I18N localization context from the given resource bundle and locale.

        The specified locale is the application- or browser-based preferred locale that led to the resource bundle match.

        Parameters:
        bundle - The localization context's resource bundle
        locale - The localization context's locale

      • LocalizationContext

        public LocalizationContext(ResourceBundle bundle)
        Constructs an I18N localization context from the given resource bundle.

        The localization context's locale is taken from the given resource bundle.

        Parameters:
        bundle - The resource bundle

    • Method Detail

      • getResourceBundle

        public ResourceBundle getResourceBundle()
        Gets the resource bundle of this I18N localization context.
        Returns:
        The resource bundle of this I18N localization context, or null if this I18N localization context is empty

      • getLocale

        public Locale getLocale()
        Gets the locale of this I18N localization context.
        Returns:
        The locale of this I18N localization context, or null if this I18N localization context is empty, or its resource bundle is a (locale-less) root resource bundle.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.servlet.jsp.jstl.fmt (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet.jsp.jstl.fmt

No usage of javax.servlet.jsp.jstl.fmt
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.fmt.LocaleSupport (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.fmt.LocaleSupport

No usage of javax.servlet.jsp.jstl.fmt.LocaleSupport
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.fmt.LocalizationContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.fmt.LocalizationContext

No usage of javax.servlet.jsp.jstl.fmt.LocalizationContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.servlet.jsp.jstl.sql (Java(TM) EE 7 Specification APIs)

javax.servlet.jsp.jstl.sql

Interfaces

  • Result
  • SQLExecutionTag

Classes

  • ResultSupport


javax.servlet.jsp.jstl.sql (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet.jsp.jstl.sql

Classes and interfaces related to the sql tag library component of the JavaServer Pages Standard Tag Library (JSTL).

See: Description

  • Interface Summary
    Interface Description
    Result
    This interface represents the result of a <sql:query> action.
    SQLExecutionTag
    This interface allows tag handlers implementing it to receive values for parameter markers in their SQL statements.
  • Class Summary
    Class Description
    ResultSupport
    Supports the creation of a javax.servlet.jsp.jstl.sql.Result object from a source java.sql.ResultSet object.

Package javax.servlet.jsp.jstl.sql Description

Classes and interfaces related to the sql tag library component of the JavaServer Pages Standard Tag Library (JSTL).

This tag library component provides a number of SQL tags which provide basic capabilities to interact with relational databases.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet.jsp.jstl.sql Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet.jsp.jstl.sql

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.jsp.jstl.sql.ResultSupport

Interface Hierarchy

  • javax.servlet.jsp.jstl.sql.Result
  • javax.servlet.jsp.jstl.sql.SQLExecutionTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Result (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.sql

Interface Result

  • public interface Result

    This interface represents the result of a <sql:query> action. It provides access to the following information in the query result:

    • The result rows (getRows() and getRowsByIndex())
    • The column names (getColumnNames())
    • The number of rows in the result (getRowCount())
    • An indication whether the rows returned represent the complete result or just a subset that is limited by a maximum row setting (isLimitedByMaxRows())

    An implementation of the Result interface provides a disconnected view into the result of a query.

    Author:
    Justyna Horwat

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String[] getColumnNames()
      Returns the names of the columns in the result.
      int getRowCount()
      Returns the number of rows in the cached ResultSet
      SortedMap[] getRows()
      Returns the result of the query as an array of SortedMap objects.
      Object[][] getRowsByIndex()
      Returns the result of the query as an array of arrays.
      boolean isLimitedByMaxRows()
      Returns true if the query was limited by a maximum row setting

    • Method Detail

      • getRows

        SortedMap[] getRows()

        Returns the result of the query as an array of SortedMap objects. Each item of the array represents a specific row in the query result.

        A row is structured as a SortedMap object where the key is the column name, and where the value is the value associated with the column identified by the key. The column value is an Object of the Java type corresponding to the mapping between column types and Java types defined by the JDBC specification when the ResultSet.getObject() method is used.

        The SortedMap must use the Comparator java.util.String.CASE_INSENSITIVE_ORDER. This makes it possible to access the key as a case insensitive representation of a column name. This method will therefore work regardless of the case of the column name returned by the database.

        Returns:
        The result rows as an array of SortedMap objects

      • getRowsByIndex

        Object[][] getRowsByIndex()
        Returns the result of the query as an array of arrays. The first array dimension represents a specific row in the query result. The array elements for each row are Object instances of the Java type corresponding to the mapping between column types and Java types defined by the JDBC specification when the ResultSet.getObject() method is used.
        Returns:
        the result rows as an array of Object[] objects

      • getColumnNames

        String[] getColumnNames()
        Returns the names of the columns in the result. The order of the names in the array matches the order in which columns are returned in method getRowsByIndex().
        Returns:
        the column names as an array of String objects

      • getRowCount

        int getRowCount()
        Returns the number of rows in the cached ResultSet
        Returns:
        the number of rows in the result

      • isLimitedByMaxRows

        boolean isLimitedByMaxRows()
        Returns true if the query was limited by a maximum row setting
        Returns:
        true if the query was limited by a maximum row setting
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResultSupport (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.sql

Class ResultSupport

  • java.lang.Object
    • javax.servlet.jsp.jstl.sql.ResultSupport

  • public class ResultSupport
extends Object

    Supports the creation of a javax.servlet.jsp.jstl.sql.Result object from a source java.sql.ResultSet object. A Result object makes it much easier for page authors to access and manipulate the data resulting from a SQL query.

    Author:
    Justyna Horwat

    • Constructor Summary

      Constructors
      Constructor and Description
      ResultSupport()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Result toResult(ResultSet rs)
      Converts a ResultSet object to a Result object.
      static Result toResult(ResultSet rs, int maxRows)
      Converts maxRows of a ResultSet object to a Result object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ResultSupport

        public ResultSupport()

    • Method Detail

      • toResult

        public static Result toResult(ResultSet rs)
        Converts a ResultSet object to a Result object.
        Parameters:
        rs - the ResultSet object
        Returns:
        The Result object created from the ResultSet

      • toResult

        public static Result toResult(ResultSet rs,
              int maxRows)
        Converts maxRows of a ResultSet object to a Result object.
        Parameters:
        rs - the ResultSet object
        maxRows - the maximum number of rows to be cached into the Result object.
        Returns:
        The Result object created from the ResultSet, limited by maxRows
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SQLExecutionTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.sql

Interface SQLExecutionTag

  • public interface SQLExecutionTag

    This interface allows tag handlers implementing it to receive values for parameter markers in their SQL statements.

    This interface is implemented by both <sql:query> and <sql:update>. Its addSQLParameter() method is called by nested parameter actions (such as <sql:param>) to substitute PreparedStatement parameter values for "?" parameter markers in the SQL statement of the enclosing SQLExecutionTag action.

    The given parameter values are converted to their corresponding SQL type (following the rules in the JDBC specification) before they are sent to the database.

    Keeping track of the index of the parameter values being added is the responsibility of the tag handler implementing this interface

    The SQLExcecutionTag interface is exposed in order to support custom parameter actions which may retrieve their parameters from any source and process them before substituting them for a parameter marker in the SQL statement of the enclosing SQLExecutionTag action

    Author:
    Justyna Horwat

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addSQLParameter(Object value)
      Adds a PreparedStatement parameter value.

    • Method Detail

      • addSQLParameter

        void addSQLParameter(Object value)
        Adds a PreparedStatement parameter value. Must behave as if it calls PreparedStatement.setObject(int, Object). For each tag invocation, the integral index passed logically to setObject() must begin with 1 and must be incremented by 1 for each subsequent invocation of addSQLParameter(). The Object logically passed to setObject() must be the unmodified object received in the value argument.
        Parameters:
        value - the PreparedStatement parameter value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.servlet.jsp.jstl.sql (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet.jsp.jstl.sql

  • Packages that use javax.servlet.jsp.jstl.sql
    Package Description
    javax.faces.model
    Standard model data beans for JavaServer Faces.
    javax.servlet.jsp.jstl.sql
    Classes and interfaces related to the sql tag library component of the JavaServer Pages Standard Tag Library (JSTL).
  • Classes in javax.servlet.jsp.jstl.sql used by javax.faces.model
    Class and Description
    Result
    This interface represents the result of a <sql:query> action.
  • Classes in javax.servlet.jsp.jstl.sql used by javax.servlet.jsp.jstl.sql
    Class and Description
    Result
    This interface represents the result of a <sql:query> action.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.sql.ResultSupport (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.sql.ResultSupport

No usage of javax.servlet.jsp.jstl.sql.ResultSupport
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.jstl.sql.Result (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.jstl.sql.Result

  • Packages that use Result
    Package Description
    javax.faces.model
    Standard model data beans for JavaServer Faces.
    javax.servlet.jsp.jstl.sql
    Classes and interfaces related to the sql tag library component of the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of Result in javax.faces.model

      Constructors in javax.faces.model with parameters of type Result
      Constructor and Description
      ResultDataModel(Result result)
      Construct a new ResultDataModel wrapping the specified Result.

    • Uses of Result in javax.servlet.jsp.jstl.sql

      Methods in javax.servlet.jsp.jstl.sql that return Result
      Modifier and Type Method and Description
      static Result ResultSupport.toResult(ResultSet rs)
      Converts a ResultSet object to a Result object.
      static Result ResultSupport.toResult(ResultSet rs, int maxRows)
      Converts maxRows of a ResultSet object to a Result object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.jstl.sql.SQLExecutionTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.jstl.sql.SQLExecutionTag

No usage of javax.servlet.jsp.jstl.sql.SQLExecutionTag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.servlet.jsp.jstl.tlv (Java(TM) EE 7 Specification APIs)

javax.servlet.jsp.jstl.tlv

Classes

  • PermittedTaglibsTLV
  • ScriptFreeTLV


javax.servlet.jsp.jstl.tlv (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet.jsp.jstl.tlv

Reusable Tag Library Validator (TLV) classes provided by the JavaServer Pages Standard Tag Library (JSTL).

See: Description

  • Class Summary
    Class Description
    PermittedTaglibsTLV
    A TagLibraryValidator class to allow a TLD to restrict what taglibs (in addition to itself) may be imported on a page where it's used.
    ScriptFreeTLV
    A TagLibraryValidator for enforcing restrictions against the use of JSP scripting elements.

Package javax.servlet.jsp.jstl.tlv Description

Reusable Tag Library Validator (TLV) classes provided by the JavaServer Pages Standard Tag Library (JSTL).

TLVs allow translation-time validation of the XML view of a JSP page. The TLVs provided by JSTL allow tag library authors to enforce restrictions regarding the use of scripting elements and permitted tag libraries in JSP pages.

For example, any JSP page that imports the tag library with the following Tag Library Descriptor (TLD) file will be restricted to using JSTL tags:

<?xml version="1.0" encoding="UTF-8" ?>

<taglib xmlns="http://java.sun.com/xml/ns/javaee"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-jsptaglibrary_2_1.xsd"
    version="2.1">
  <description>
    Restricts JSP pages to the JSTL tag libraries
  </description>
  <display-name>permittedTaglibs</display-name>
  <tlib-version>1.1</tlib-version>
  <short-name>permittedTaglibs</short-name>
  <uri>http://java.sun.com/jstl/permittedTaglibs</uri>

  <validator>
    <validator-class>
        javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV
    </validator-class>
    <init-param>
      <description>
        Whitespace-separated list of taglib URIs to permit.
      </description>
      <param-name>permittedTaglibs</param-name>
      <param-value>
        http://java.sun.com/jsp/jstl/core
        http://java.sun.com/jsp/jstl/fmt
        http://java.sun.com/jsp/jstl/sql
        http://java.sun.com/jsp/jstl/xml
      </param-value>
    </init-param>
  </validator>
</taglib>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet.jsp.jstl.tlv Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet.jsp.jstl.tlv

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagLibraryValidator
      • javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV
      • javax.servlet.jsp.jstl.tlv.ScriptFreeTLV
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


PermittedTaglibsTLV (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.tlv

Class PermittedTaglibsTLV

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagLibraryValidator
      • javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV

  • public class PermittedTaglibsTLV
extends TagLibraryValidator

    A TagLibraryValidator class to allow a TLD to restrict what taglibs (in addition to itself) may be imported on a page where it's used.

    This TLV supports the following initialization parameter:

    • permittedTaglibs: A whitespace-separated list of URIs corresponding to tag libraries permitted to be imported on the page in addition to the tag library that references PermittedTaglibsTLV (which is allowed implicitly).
    Author:
    Shawn Bayern

    • Constructor Summary

      Constructors
      Constructor and Description
      PermittedTaglibsTLV()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void release()
      Release any data kept by this instance for validation purposes.
      ValidationMessage[] validate(String prefix, String uri, PageData page)
      Validate a JSP page.

      • Methods inherited from class javax.servlet.jsp.tagext.TagLibraryValidator

        getInitParameters, setInitParameters

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PermittedTaglibsTLV

        public PermittedTaglibsTLV()

    • Method Detail

      • release

        public void release()
        Description copied from class: TagLibraryValidator
        Release any data kept by this instance for validation purposes.
        Overrides:
        release in class TagLibraryValidator

      • validate

        public ValidationMessage[] validate(String prefix,
                           String uri,
                           PageData page)
        Description copied from class: TagLibraryValidator
        Validate a JSP page. This will get invoked once per unique tag library URI in the XML view. This method will return null if the page is valid; otherwise the method should return an array of ValidationMessage objects. An array of length zero is also interpreted as no errors.
        Overrides:
        validate in class TagLibraryValidator
        Parameters:
        prefix - the first prefix with which the tag library is associated, in the XML view. Note that some tags may use a different prefix if the namespace is redefined.
        uri - the tag library's unique identifier
        page - the JspData page object
        Returns:
        A null object, or zero length array if no errors, an array of ValidationMessages otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ScriptFreeTLV (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.jstl.tlv

Class ScriptFreeTLV

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagLibraryValidator
      • javax.servlet.jsp.jstl.tlv.ScriptFreeTLV

  • public class ScriptFreeTLV
extends TagLibraryValidator

    A TagLibraryValidator for enforcing restrictions against the use of JSP scripting elements.

    This TLV supports four initialization parameters, for controlling which of the four types of scripting elements are allowed or prohibited:

    • allowDeclarations: if true, indicates that declaration elements are not prohibited.
    • allowScriptlets: if true, indicates that scriptlets are not prohibited
    • allowExpressions: if true, indicates that top-level expression elements (i.e., expressions not associated with request-time attribute values) are not prohibited.
    • allowRTExpressions: if true, indicates that expression elements associated with request-time attribute values are not prohibited.

    The default value for all for initialization parameters is false, indicating all forms of scripting elements are to be prohibited.

    Author:
    Mark A. Kolb, Shawn Bayern (minor changes)

    • Constructor Summary

      Constructors
      Constructor and Description
      ScriptFreeTLV()
      Constructs a new validator instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void setInitParameters(Map<String,Object> initParms)
      Sets the values of the initialization parameters, as supplied in the TLD.
      ValidationMessage[] validate(String prefix, String uri, PageData page)
      Validates a single JSP page.

      • Methods inherited from class javax.servlet.jsp.tagext.TagLibraryValidator

        getInitParameters, release

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ScriptFreeTLV

        public ScriptFreeTLV()
        Constructs a new validator instance. Initializes the parser factory to create non-validating, namespace-aware SAX parsers.

    • Method Detail

      • setInitParameters

        public void setInitParameters(Map<String,Object> initParms)
        Sets the values of the initialization parameters, as supplied in the TLD.
        Overrides:
        setInitParameters in class TagLibraryValidator
        Parameters:
        initParms - a mapping from the names of the initialization parameters to their values, as specified in the TLD.

      • validate

        public ValidationMessage[] validate(String prefix,
                           String uri,
                           PageData page)
        Validates a single JSP page.
        Overrides:
        validate in class TagLibraryValidator
        Parameters:
        prefix - the namespace prefix specified by the page for the custom tag library being validated.
        uri - the URI specified by the page for the TLD of the custom tag library being validated.
        page - a wrapper around the XML representation of the page being validated.
        Returns:
        null, if the page is valid; otherwise, a ValidationMessage[] containing one or more messages indicating why the page is not valid.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.servlet.jsp.jstl.tlv (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet.jsp.jstl.tlv

No usage of javax.servlet.jsp.jstl.tlv
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV

No usage of javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.jstl.tlv.ScriptFreeTLV (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.jstl.tlv.ScriptFreeTLV

No usage of javax.servlet.jsp.jstl.tlv.ScriptFreeTLV
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BodyContent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class BodyContent

  • java.lang.Object
    • java.io.Writer
      • javax.servlet.jsp.JspWriter
        • javax.servlet.jsp.tagext.BodyContent
  • All Implemented Interfaces:
    Closeable, Flushable, Appendable, AutoCloseable

    public abstract class BodyContent
extends JspWriter
    An encapsulation of the evaluation of the body of an action so it is available to a tag handler. BodyContent is a subclass of JspWriter.

    Note that the content of BodyContent is the result of evaluation, so it will not contain actions and the like, but the result of their invocation.

    BodyContent has methods to convert its contents into a String, to read its contents, and to clear the contents.

    The buffer size of a BodyContent object is unbounded. A BodyContent object cannot be in autoFlush mode. It is not possible to invoke flush on a BodyContent object, as there is no backing stream.

    Instances of BodyContent are created by invoking the pushBody and popBody methods of the PageContext class. A BodyContent is enclosed within another JspWriter (maybe another BodyContent object) following the structure of their associated actions.

    A BodyContent is made available to a BodyTag through a setBodyContent() call. The tag handler can use the object until after the call to doEndTag().

    • Field Summary

      • Fields inherited from class javax.servlet.jsp.JspWriter

        autoFlush, bufferSize, DEFAULT_BUFFER, NO_BUFFER, UNBOUNDED_BUFFER

      • Fields inherited from class java.io.Writer

        lock

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected BodyContent(JspWriter e)
      Protected constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clearBody()
      Clear the body without throwing any exceptions.
      void flush()
      Redefined flush() so it is not legal.
      JspWriter getEnclosingWriter()
      Get the enclosing JspWriter.
      abstract Reader getReader()
      Return the value of this BodyContent as a Reader.
      abstract String getString()
      Return the value of the BodyContent as a String.
      abstract void writeOut(Writer out)
      Write the contents of this BodyContent into a Writer.

      • Methods inherited from class javax.servlet.jsp.JspWriter

        clear, clearBuffer, close, getBufferSize, getRemaining, isAutoFlush, newLine, print, print, print, print, print, print, print, print, print, println, println, println, println, println, println, println, println, println, println

      • Methods inherited from class java.io.Writer

        append, append, append, write, write, write, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BodyContent

        protected BodyContent(JspWriter e)
        Protected constructor. Unbounded buffer, no autoflushing.
        Parameters:
        e - the enclosing JspWriter

    • Method Detail

      • flush

        public void flush()
           throws IOException
        Redefined flush() so it is not legal.

        It is not valid to flush a BodyContent because there is no backing stream behind it.

        Specified by:
        flush in interface Flushable
        Specified by:
        flush in class JspWriter
        Throws:
        IOException - always thrown

      • clearBody

        public void clearBody()
        Clear the body without throwing any exceptions.

      • getReader

        public abstract Reader getReader()
        Return the value of this BodyContent as a Reader.
        Returns:
        the value of this BodyContent as a Reader

      • getString

        public abstract String getString()
        Return the value of the BodyContent as a String.
        Returns:
        the value of the BodyContent as a String

      • writeOut

        public abstract void writeOut(Writer out)
                       throws IOException
        Write the contents of this BodyContent into a Writer. Subclasses may optimize common invocation patterns.
        Parameters:
        out - The writer into which to place the contents of this body evaluation
        Throws:
        IOException - if an I/O error occurred while writing the contents of this BodyContent to the given Writer

      • getEnclosingWriter

        public JspWriter getEnclosingWriter()
        Get the enclosing JspWriter.
        Returns:
        the enclosing JspWriter passed at construction time
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BodyTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Interface BodyTag

  • All Superinterfaces:
    IterationTag, JspTag, Tag
    All Known Implementing Classes:
    BodyTagSupport, UIComponentBodyTag, UIComponentClassicTagBase, UIComponentELTag, UIComponentTag

    public interface BodyTag
extends IterationTag
    The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.

    It is the responsibility of the tag handler to manipulate the body content. For example the tag handler may take the body content, convert it into a String using the bodyContent.getString method and then use it. Or the tag handler may take the body content and write it out into its enclosing JspWriter using the bodyContent.writeOut method.

    A tag handler that implements BodyTag is treated as one that implements IterationTag, except that the doStartTag method can return SKIP_BODY, EVAL_BODY_INCLUDE or EVAL_BODY_BUFFERED.

    If EVAL_BODY_INCLUDE is returned, then evaluation happens as in IterationTag.

    If EVAL_BODY_BUFFERED is returned, then a BodyContent object will be created (by code generated by the JSP compiler) to capture the body evaluation. The code generated by the JSP compiler obtains the BodyContent object by calling the pushBody method of the current pageContext, which additionally has the effect of saving the previous out value. The page compiler returns this object by calling the popBody method of the PageContext class; the call also restores the value of out.

    The interface provides one new property with a setter method and one new action method.

    Properties

    There is a new property: bodyContent, to contain the BodyContent object, where the JSP Page implementation object will place the evaluation (and reevaluation, if appropriate) of the body. The setter method (setBodyContent) will only be invoked if doStartTag() returns EVAL_BODY_BUFFERED and the corresponding action element does not have an empty body.

    Methods

    In addition to the setter method for the bodyContent property, there is a new action method: doInitBody(), which is invoked right after setBodyContent() and before the body evaluation. This method is only invoked if doStartTag() returns EVAL_BODY_BUFFERED.

    Lifecycle

    Lifecycle details are described by the transition diagram below. Exceptions that are thrown during the computation of doStartTag(), setBodyContent(), doInitBody(), BODY, doAfterBody() interrupt the execution sequence and are propagated up the stack, unless the tag handler implements the TryCatchFinally interface; see that interface for details.

    Lifecycle Details Transition Diagram for BodyTag

    Empty and Non-Empty Action

    If the TagLibraryDescriptor file indicates that the action must always have an empty element body, by an <body-content> entry of "empty", then the doStartTag() method must return SKIP_BODY. Otherwise, the doStartTag() method may return SKIP_BODY, EVAL_BODY_INCLUDE, or EVAL_BODY_BUFFERED.

    Note that which methods are invoked after the doStartTag() depends on both the return value and on if the custom action element is empty or not in the JSP page, not how it's declared in the TLD.

    If SKIP_BODY is returned the body is not evaluated, and doEndTag() is invoked.

    If EVAL_BODY_INCLUDE is returned, and the custom action element is not empty, setBodyContent() is not invoked, doInitBody() is not invoked, the body is evaluated and "passed through" to the current out, doAfterBody() is invoked and then, after zero or more iterations, doEndTag() is invoked. If the custom action element is empty, only doStart() and doEndTag() are invoked.

    If EVAL_BODY_BUFFERED is returned, and the custom action element is not empty, setBodyContent() is invoked, doInitBody() is invoked, the body is evaluated, doAfterBody() is invoked, and then, after zero or more iterations, doEndTag() is invoked. If the custom action element is empty, only doStart() and doEndTag() are invoked.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int EVAL_BODY_BUFFERED
      Request the creation of new buffer, a BodyContent on which to evaluate the body of this tag.
      static int EVAL_BODY_TAG
      Deprecated.
      As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void doInitBody()
      Prepare for evaluation of the body.
      void setBodyContent(BodyContent b)
      Set the bodyContent property.

      • Methods inherited from interface javax.servlet.jsp.tagext.IterationTag

        doAfterBody

      • Methods inherited from interface javax.servlet.jsp.tagext.Tag

        doEndTag, doStartTag, getParent, release, setPageContext, setParent

    • Field Detail

      • EVAL_BODY_TAG

        static final int EVAL_BODY_TAG
        Deprecated. As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.
        Deprecated constant that has the same value as EVAL_BODY_BUFFERED and EVAL_BODY_AGAIN. This name has been marked as deprecated to encourage the use of the two different terms, which are much more descriptive.
        See Also:
        Constant Field Values

      • EVAL_BODY_BUFFERED

        static final int EVAL_BODY_BUFFERED
        Request the creation of new buffer, a BodyContent on which to evaluate the body of this tag. Returned from doStartTag when it implements BodyTag. This is an illegal return value for doStartTag when the class does not implement BodyTag.
        See Also:
        Constant Field Values

    • Method Detail

      • setBodyContent

        void setBodyContent(BodyContent b)
        Set the bodyContent property. This method is invoked by the JSP page implementation object at most once per action invocation. This method will be invoked before doInitBody. This method will not be invoked for empty tags or for non-empty tags whose doStartTag() method returns SKIP_BODY or EVAL_BODY_INCLUDE.

        When setBodyContent is invoked, the value of the implicit object out has already been changed in the pageContext object. The BodyContent object passed will have not data on it but may have been reused (and cleared) from some previous invocation.

        The BodyContent object is available and with the appropriate content until after the invocation of the doEndTag method, at which case it may be reused.

        Parameters:
        b - the BodyContent
        See Also:
        doInitBody(), IterationTag.doAfterBody()

      • doInitBody

        void doInitBody()
                throws JspException
        Prepare for evaluation of the body. This method is invoked by the JSP page implementation object after setBodyContent and before the first time the body is to be evaluated. This method will not be invoked for empty tags or for non-empty tags whose doStartTag() method returns SKIP_BODY or EVAL_BODY_INCLUDE.

        The JSP container will resynchronize the values of any AT_BEGIN and NESTED variables (defined by the associated TagExtraInfo or TLD) after the invocation of doInitBody().

        Throws:
        JspException - if an error occurred while processing this tag
        See Also:
        IterationTag.doAfterBody()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BodyTagSupport (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class BodyTagSupport

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport
      • javax.servlet.jsp.tagext.BodyTagSupport
  • All Implemented Interfaces:
    Serializable, BodyTag, IterationTag, JspTag, Tag

    public class BodyTagSupport
extends TagSupport
implements BodyTag
    A base class for defining tag handlers implementing BodyTag.

    The BodyTagSupport class implements the BodyTag interface and adds additional convenience methods including getter methods for the bodyContent property and methods to get at the previous out JspWriter.

    Many tag handlers will extend BodyTagSupport and only redefine a few methods.

    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected BodyContent bodyContent
      The current BodyContent for this BodyTag.

      • Fields inherited from class javax.servlet.jsp.tagext.TagSupport

        id, pageContext

      • Fields inherited from interface javax.servlet.jsp.tagext.BodyTag

        EVAL_BODY_BUFFERED, EVAL_BODY_TAG

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      BodyTagSupport()
      Default constructor, all subclasses are required to only define a public constructor with the same signature, and to call the superclass constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int doAfterBody()
      After the body evaluation: do not reevaluate and continue with the page.
      int doEndTag()
      Default processing of the end tag returning EVAL_PAGE.
      void doInitBody()
      Prepare for evaluation of the body just before the first body evaluation: no action.
      int doStartTag()
      Default processing of the start tag returning EVAL_BODY_BUFFERED.
      BodyContent getBodyContent()
      Get current bodyContent.
      JspWriter getPreviousOut()
      Get surrounding out JspWriter.
      void release()
      Release state.
      void setBodyContent(BodyContent b)
      Prepare for evaluation of the body: stash the bodyContent away.

      • Methods inherited from class javax.servlet.jsp.tagext.TagSupport

        findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.servlet.jsp.tagext.Tag

        getParent, setPageContext, setParent

    • Field Detail

      • bodyContent

        protected BodyContent bodyContent
        The current BodyContent for this BodyTag.

    • Constructor Detail

      • BodyTagSupport

        public BodyTagSupport()
        Default constructor, all subclasses are required to only define a public constructor with the same signature, and to call the superclass constructor. This constructor is called by the code generated by the JSP translator.

    • Method Detail

      • doStartTag

        public int doStartTag()
               throws JspException
        Default processing of the start tag returning EVAL_BODY_BUFFERED.
        Specified by:
        doStartTag in interface Tag
        Overrides:
        doStartTag in class TagSupport
        Returns:
        EVAL_BODY_BUFFERED
        Throws:
        JspException - if an error occurred while processing this tag
        See Also:
        Tag.doStartTag()

      • doEndTag

        public int doEndTag()
             throws JspException
        Default processing of the end tag returning EVAL_PAGE.
        Specified by:
        doEndTag in interface Tag
        Overrides:
        doEndTag in class TagSupport
        Returns:
        EVAL_PAGE
        Throws:
        JspException - if an error occurred while processing this tag
        See Also:
        Tag.doEndTag()

      • setBodyContent

        public void setBodyContent(BodyContent b)
        Prepare for evaluation of the body: stash the bodyContent away.
        Specified by:
        setBodyContent in interface BodyTag
        Parameters:
        b - the BodyContent
        See Also:
        doAfterBody(),
doInitBody(),
BodyTag.setBodyContent(javax.servlet.jsp.tagext.BodyContent)

      • doInitBody

        public void doInitBody()
                throws JspException
        Prepare for evaluation of the body just before the first body evaluation: no action.
        Specified by:
        doInitBody in interface BodyTag
        Throws:
        JspException - if an error occurred while processing this tag
        See Also:
        setBodyContent(javax.servlet.jsp.tagext.BodyContent),
doAfterBody(),
BodyTag.doInitBody()

      • doAfterBody

        public int doAfterBody()
                throws JspException
        After the body evaluation: do not reevaluate and continue with the page. By default nothing is done with the bodyContent data (if any).
        Specified by:
        doAfterBody in interface IterationTag
        Overrides:
        doAfterBody in class TagSupport
        Returns:
        SKIP_BODY
        Throws:
        JspException - if an error occurred while processing this tag
        See Also:
        doInitBody(), IterationTag.doAfterBody()

      • release

        public void release()
        Release state.
        Specified by:
        release in interface Tag
        Overrides:
        release in class TagSupport
        See Also:
        Tag.release()

      • getBodyContent

        public BodyContent getBodyContent()
        Get current bodyContent.
        Returns:
        the body content.

      • getPreviousOut

        public JspWriter getPreviousOut()
        Get surrounding out JspWriter.
        Returns:
        the enclosing JspWriter, from the bodyContent.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DynamicAttributes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Interface DynamicAttributes

  • public interface DynamicAttributes
    For a tag to declare that it accepts dynamic attributes, it must implement this interface. The entry for the tag in the Tag Library Descriptor must also be configured to indicate dynamic attributes are accepted.
    For any attribute that is not declared in the Tag Library Descriptor for this tag, instead of getting an error at translation time, the setDynamicAttribute() method is called, with the name and value of the attribute. It is the responsibility of the tag to remember the names and values of the dynamic attributes.
    Since:
    JSP 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void setDynamicAttribute(String uri, String localName, Object value)
      Called when a tag declared to accept dynamic attributes is passed an attribute that is not declared in the Tag Library Descriptor.

    • Method Detail

      • setDynamicAttribute

        void setDynamicAttribute(String uri,
                       String localName,
                       Object value)
                         throws JspException
        Called when a tag declared to accept dynamic attributes is passed an attribute that is not declared in the Tag Library Descriptor.
        Parameters:
        uri - the namespace of the attribute, or null if in the default namespace.
        localName - the name of the attribute being set.
        value - the value of the attribute
        Throws:
        JspException - if the tag handler wishes to signal that it does not accept the given attribute. The container must not call doStartTag() or doTag() for this tag.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FunctionInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class FunctionInfo

  • java.lang.Object
    • javax.servlet.jsp.tagext.FunctionInfo

  • public class FunctionInfo
extends Object
    Information for a function in a Tag Library. This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
    Since:
    JSP 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      FunctionInfo(String name, String klass, String signature)
      Constructor for FunctionInfo.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFunctionClass()
      The class of the function.
      String getFunctionSignature()
      The signature of the function.
      String getName()
      The name of the function.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FunctionInfo

        public FunctionInfo(String name,
            String klass,
            String signature)
        Constructor for FunctionInfo.
        Parameters:
        name - The name of the function
        klass - The class of the function
        signature - The signature of the function

    • Method Detail

      • getName

        public String getName()
        The name of the function.
        Returns:
        The name of the function

      • getFunctionClass

        public String getFunctionClass()
        The class of the function.
        Returns:
        The class of the function

      • getFunctionSignature

        public String getFunctionSignature()
        The signature of the function.
        Returns:
        The signature of the function
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IterationTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Interface IterationTag

  • All Superinterfaces:
    JspTag, Tag
    All Known Subinterfaces:
    BodyTag
    All Known Implementing Classes:
    AttributeTag, BodyTagSupport, ConditionalTagSupport, ConverterELTag, ConverterTag, FacetTag, LoopTagSupport, TagSupport, UIComponentBodyTag, UIComponentClassicTagBase, UIComponentELTag, UIComponentTag, ValidatorELTag, ValidatorTag

    public interface IterationTag
extends Tag
    The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.

    A tag handler that implements IterationTag is treated as one that implements Tag regarding the doStartTag() and doEndTag() methods. IterationTag provides a new method: doAfterBody().

    The doAfterBody() method is invoked after every body evaluation to control whether the body will be reevaluated or not. If doAfterBody() returns IterationTag.EVAL_BODY_AGAIN, then the body will be reevaluated. If doAfterBody() returns Tag.SKIP_BODY, then the body will be skipped and doEndTag() will be evaluated instead.

    Properties There are no new properties in addition to those in Tag.

    Methods There is one new methods: doAfterBody().

    Lifecycle

    Lifecycle details are described by the transition diagram below. Exceptions that are thrown during the computation of doStartTag(), BODY and doAfterBody() interrupt the execution sequence and are propagated up the stack, unless the tag handler implements the TryCatchFinally interface; see that interface for details.

    Lifecycle Details Transition Diagram for IterationTag

    Empty and Non-Empty Action

    If the TagLibraryDescriptor file indicates that the action must always have an empty element body, by a <body-content> entry of "empty", then the doStartTag() method must return SKIP_BODY.

    Note that which methods are invoked after the doStartTag() depends on both the return value and on if the custom action element is empty or not in the JSP page, not on how it's declared in the TLD.

    If SKIP_BODY is returned the body is not evaluated, and then doEndTag() is invoked.

    If EVAL_BODY_INCLUDE is returned, and the custom action element is not empty, the body is evaluated and "passed through" to the current out, then doAfterBody() is invoked and, after zero or more iterations, doEndTag() is invoked.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int EVAL_BODY_AGAIN
      Request the reevaluation of some body.

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int doAfterBody()
      Process body (re)evaluation.

      • Methods inherited from interface javax.servlet.jsp.tagext.Tag

        doEndTag, doStartTag, getParent, release, setPageContext, setParent

    • Field Detail

      • EVAL_BODY_AGAIN

        static final int EVAL_BODY_AGAIN
        Request the reevaluation of some body. Returned from doAfterBody. For compatibility with JSP 1.1, the value is carefully selected to be the same as the, now deprecated, BodyTag.EVAL_BODY_TAG,
        See Also:
        Constant Field Values

    • Method Detail

      • doAfterBody

        int doAfterBody()
                throws JspException
        Process body (re)evaluation. This method is invoked by the JSP Page implementation object after every evaluation of the body into the BodyEvaluation object. The method is not invoked if there is no body evaluation.

        If doAfterBody returns EVAL_BODY_AGAIN, a new evaluation of the body will happen (followed by another invocation of doAfterBody). If doAfterBody returns SKIP_BODY, no more body evaluations will occur, and the doEndTag method will be invoked.

        If this tag handler implements BodyTag and doAfterBody returns SKIP_BODY, the value of out will be restored using the popBody method in pageContext prior to invoking doEndTag.

        The method re-invocations may be lead to different actions because there might have been some changes to shared state, or because of external computation.

        The JSP container will resynchronize the values of any AT_BEGIN and NESTED variables (defined by the associated TagExtraInfo or TLD) after the invocation of doAfterBody().

        Returns:
        whether additional evaluations of the body are desired
        Throws:
        JspException - if an error occurred while processing this tag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.servlet.jsp.tagext (Java(TM) EE 7 Specification APIs)

javax.servlet.jsp.tagext

Interfaces

  • BodyTag
  • DynamicAttributes
  • IterationTag
  • JspIdConsumer
  • JspTag
  • SimpleTag
  • Tag
  • TryCatchFinally

Classes

  • BodyContent
  • BodyTagSupport
  • FunctionInfo
  • JspFragment
  • PageData
  • SimpleTagSupport
  • TagAdapter
  • TagAttributeInfo
  • TagData
  • TagExtraInfo
  • TagFileInfo
  • TagInfo
  • TagLibraryInfo
  • TagLibraryValidator
  • TagSupport
  • TagVariableInfo
  • ValidationMessage
  • VariableInfo


javax.servlet.jsp.tagext (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.servlet.jsp.tagext

Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

See: Description

  • Interface Summary
    Interface Description
    BodyTag
    The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.
    DynamicAttributes
    For a tag to declare that it accepts dynamic attributes, it must implement this interface.
    IterationTag
    The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.
    JspIdConsumer
    This interface indicates to the container that a tag handler wishes to be provided with a compiler generated ID.
    JspTag
    Serves as a base class for Tag and SimpleTag.
    SimpleTag
    Interface for defining Simple Tag Handlers.
    Tag
    The interface of a classic tag handler that does not want to manipulate its body.
    TryCatchFinally
    The auxiliary interface of a Tag, IterationTag or BodyTag tag handler that wants additional hooks for managing resources.
  • Class Summary
    Class Description
    BodyContent
    An encapsulation of the evaluation of the body of an action so it is available to a tag handler.
    BodyTagSupport
    A base class for defining tag handlers implementing BodyTag.
    FunctionInfo
    Information for a function in a Tag Library.
    JspFragment
    Encapsulates a portion of JSP code in an object that can be invoked as many times as needed.
    PageData
    Translation-time information on a JSP page.
    SimpleTagSupport
    A base class for defining tag handlers implementing SimpleTag.
    TagAdapter
    Wraps any SimpleTag and exposes it using a Tag interface.
    TagAttributeInfo
    Information on the attributes of a Tag, available at translation time.
    TagData
    The (translation-time only) attribute/value information for a tag instance.
    TagExtraInfo
    Optional class provided by the tag library author to describe additional translation-time information not described in the TLD.
    TagFileInfo
    Tag information for a tag file in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
    TagInfo
    Tag information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
    TagLibraryInfo
    Translation-time information associated with a taglib directive, and its underlying TLD file.
    TagLibraryValidator
    Translation-time validator class for a JSP page.
    TagSupport
    A base class for defining new tag handlers implementing Tag.
    TagVariableInfo
    Variable information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
    ValidationMessage
    A validation message from either TagLibraryValidator or TagExtraInfo.
    VariableInfo
    Information on the scripting variables that are created/modified by a tag (at run-time).

Package javax.servlet.jsp.tagext Description

Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

Custom actions can be used by JSP authors and authoring tools to simplify writing JSP pages. A custom action can be either an empty or a non-empty action.

An empty tag has no body. There are two equivalent syntaxes, one with separate start and end tags, and one where the start and end tags are combined. The two following examples are identical:

<x:foo att="myObject"></foo>
<x:foo att="myObject"/>

A non-empty tag has a start tag, a body, and an end tag. A prototypical example is of the form:

<x:foo att="myObject" >
  BODY
</x:foo/>

The JavaServer Pages(tm) (JSP) specification provides a portable mechanism for the description of tag libraries.

A JSP tag library contains

  • A Tag Library Descriptor
  • A number of Tag Files or Tag handler classes defining request-time behavior
  • Additional classes and resources used at runtime
  • Possibly some additional classes to provide extra translation information

This API is described in the following sections:

  1. Classic Tag Handlers
  2. Tag Handlers that want to access their Body Content
  3. Dynamic Attributes
  4. Annotated Tag Handler Management Example
  5. Cooperating Actions
  6. Simple Tag Handlers
  7. JSP Fragments
  8. Example Simple Tag Handler Scenario
  9. Translation-time Classes

1. Classic Tag Handlers

 This section introduces the notion of a tag handler and describes the classic types of tag handler.

JSP 2.0 introduces a new type of Tag Handler called a Simple Tag Handler, which is described in a later section. The protocol for Simple Tag handlers is much more straightforward.

Tag Handler

A tag handler is a run-time, container-managed object that evaluates custom actions during the execution of a JSP page. A tag handler supports a protocol that allows the JSP container to provide good integration of the server-side actions within a JSP page.

A tag handler is created initially using a zero argument constructor on its corresponding class; the method java.beans.Beans.instantiate() is not used.

A tag handler has some properties that are exposed to the page as attributes on an action; these properties are managed by the JSP container (via generated code). The setter methods used to set the properties are discovered using the JavaBeans introspector machinery.

The protocol supported by a tag handler provides for passing of parameters, the evaluation and reevaluation of the body of the action, and for getting access to objects and other tag handlers in the JSP page.

A tag handler instance is responsible for processing one request at a time. It is the responsability of the JSP container to enforce this.

Additional translation time information associated with the action indicates the name of any scripting variables it may introduce, their types and their scope. At specific moments, the JSP container will automatically synchronize the PageContext information with variables in the scripting language so they can be made available directly through the scripting elements.

Properties

A tag handler has some properties. All tag handlers have a pageContext property for the JSP page where the tag is located, and a parent property for the tag handler to the closest enclosing action. Specific tag handler classes may have additional properties.

All attributes of a custom action must be JavaBeans component properties, although some properties may not be exposed as attributes. The attributes that are visible to the JSP translator are exactly those listed in the Tag Library Descriptor (TLD).

All properties of a tag handler instance exposed as attributes will be initialized by the container using the appropriate setter methods before the instance can be used to perform the action methods. It is the responsibility of the JSP container to invoke the appropriate setter methods to initialize these properties. It is the responsability of user code, be it scriptlets, JavaBeans code, or code inside custom tags, to not invoke these setter methods, as doing otherwise would interfere with the container knowledge.

The setter methods that should be used when assigning a value to an attribute of a custom action are determined by using the JavaBeans introspector on the tag handler class, then use the setter method associated with the property that has the same name as the attribute in question. An implication (unclear in the JavaBeans specification) is that there is only one setter per property.

Unspecified attributes/properties should not be set (using a setter method).

Once properly set, all properties are expected to be persistent, so that if the JSP container ascertains that a property has already been set on a given tag handler instance, it must not set it again.

The JSP container may reuse classic tag handler instances for multiple occurrences of the corresponding custom action, in the same page or in different pages, but only if the same set of attributes are used for all occurrences. If a tag handler is used for more than one occurence, the container must reset all attributes where the values differ between the custom action occurrences. Attributes with the same value in all occurrences must not be reset. If an attribute value is set as a request-time attribute value (using a scripting or an EL expression), the container must reset the attribute between all reuses of the tag handler instance. To prevent confusion, a tag handler with an empty body must not reuse any previous tag handler with a non-empty body.

User code can access property information and access and modify tag handler internal state starting with the first action method (doStartTag) up until the last action method (doEndTag or doFinally for tag handlers implementing TryCatchFinally).

Tag Handler as a Container-Managed Object

Since a tag handler is a container managed object, the container needs to maintain its references; specifically, user code should not keep references to a tag handler except between the start of the first action method (doStartTag()) and the end of the last action method (doEndTag() or doFinally() for those tags that implement TryCatchFinally).

The restrictions on references to tag handler objects and on modifying attribute properties gives the JSP container substantial freedom in effectively managing tag handler objects to achieve different goals. For example, a container may implementing different pooling strategies to minimize creation cost, or may hoist setting of properties to reduce cost when a tag handler is inside another iterative tag.

Conversions

A tag handler implements an action; the JSP container must follow the type conversions described in Section 2.13.2 when assigning values to the attributes of an action.

Empty and Non-Empty Actions

An empty action has no body; it may use one of two syntaxes: either <foo/> or <foo></foo>. Since empty actions have no body the methods related to body manipulation are not invoked. There is a mechanism in the Tag Library Descriptor to indicate that a tag can only be used to write empty actions; when used, non-empty actions using that tag will produce a translation error.

A non-empty action has a body.

The Tag Interface

A Tag handler that does not want to process its body can implement just the Tag interface. A tag handler may not want to process its body because it is an empty tag or because the body is just to be "passed through".

The Tag interface includes methods to provide page context information to the Tag Handler instance, methods to handle the life-cycle of tag handlers, and two main methods for performing actions on a tag: doStartTag() and doEndTag(). The method doStartTag() is invoked when encountering the start tag and its return value indicates whether the body (if there is any) should be skipped, or evaluated and passed through to the current response stream. The method doEndTag() is invoked when encountering the end tag; its return value indicates whether the rest of the page should continue to be evaluated or not.

If an exception is encountered during the evaluation of the body of a tag, its doEndTag method will not be evaluated. See the TryCatchFinally tag for methods that are guaranteed to be evaluated.

The IterationTag Interface

The IterationTag interface is used to repeatedly reevaluate the body of a custom action. The interface has one method: doAfterBody() which is invoked after each evaluation of the body to determine whether to reevaluate or not.

Reevaluation is requested with the value 2, which in JSP 1.1 is defined to be BodyTag.EVAL_BODY_TAG. That constant value is still kept in JSP 1.2 (for full backwards compatibility) but, to improve clarity, a new name is also available: IterationTag.EVAL_BODY_AGAIN. To stop iterating, the returned value should be 0, which is Tag.SKIP_BODY.

The JspIdConsumer Interface

This interface indicates to the container that a tag handler wishes to be provided with a compiler generated ID that is unique within the page.

The TagSupport Base Class

The TagSupport class is a base class that can be used when implementing the Tag or IterationTag interfaces.

2. Tag Handlers that want Access to their Body Content

The evaluation of a body is delivered into a BodyContent object. This is then made available to tag handlers that implement the BodyTag interface. The BodyTagSupport class provides a useful base class to simplify writing these handlers.

If a Tag handler wants to have access to the content of its body then it must implement the BodyTag interface. This interface extends IterationTag, provides two additional methods setBodyContent(BodyContent) and doInitBody() and refers to an object of type BodyContent.

A BodyContent is a subclass of JspWriter that has a few additional methods to convert its contents into a String, insert the contents into another JspWriter, to get a Reader into its contents, and to clear the contents. Its semantics also assure that buffer size will never be exceeded.

The JSP page implementation will create a BodyContent if the doStartTag() method returns a EVAL_BODY_BUFFERED. This object will be passed to doInitBody(); then the body of the tag will be evaluated, and during that evaluation out will be bound to the BodyContent just passed to the BodyTag handler. Then doAfterBody() will be evaluated. If that method returns SKIP_BODY, no more evaluations of the body will be done; if the method returns EVAL_BODY_AGAIN, then the body will be evaluated, and doAfterBody() will be invoked again.

The content of a BodyContent instance remains available until after the invocation of its associated doEndTag() method.

A common use of the BodyContent is to extract its contents into a String and then use the String as a value for some operation. Another common use is to take its contents and push it into the out Stream that was valid when the start tag was encountered (that is available from the PageContext object passed to the handler in setPageContext).

3. Dynamic Attributes

Any tag handler can optionally extend the DynamicAttributes interface to indicate that it supports dynamic attributes. In addition to implementing the DynamicAttributes interface, tag handlers that support dynamic attributes must declare that they do so in the Tag Library Descriptor.

The TLD is what ultimately determines whether a tag handler accepts dynamic attributes or not. If a tag handler declares that it supports dynamic attributes in the TLD but it does not implement the DynamicAttributes interface, the tag handler must be considered invalid by the container.

If the dynamic-attributes element for a tag being invoked contains the value "true", the following requirements apply:

  • For each attribute specified in the tag invocation that does not have a corresponding attribute element in the TLD for this tag, a call must be made to setDynamicAttribute(), passing in the namespace of the attribute (or null if the attribute does not have a namespace or prefix), the name of the attribute without the namespace prefix, and the final value of the attribute.
  • Dynamic attributes must be considered to accept request-time expression values as well as deferred expressions.
  • Dynamic attributes must be treated as though they were of type java.lang.Object. If a ValueExpression is passed as a dynamic attribute, the default value for the expected return type is assumed to be java.lang.Object. If a MethodExpression is passed as a dynamic attribute, the default method signature is assumed to be void method().
  • Note that passing a String literal as a dynamic attribute will never be considered as a deferred expression.
  • The JSP container must recognize dynamic attributes that are passed to the tag handler using the <jsp:attribute> standard action.
  • If the setDynamicAttribute() method throws JspException, the doStartTag() or doTag() method is not invoked for this tag, and the exception must be treated in the same manner as if it came from a regular attribute setter method.
  • For a JSP document in either standard or XML syntax, If a dynamic attribute has a prefix that doesn't map to a namespace, a translation error must occur. In standard syntax, only namespaces defined using taglib directives are recognized.

In the following example, assume attributes a and b are declared using the attribute element in the TLD, attributes d1 and d2 are not declared, and the dynamic-attributes element is set to "true". The attributes are set using the calls:

  • setA( "1" ),
  • setDynamicAttribute( null, "d1", "2" ),
  • setDynamicAttribute( "http://www.foo.com/jsp/taglib/mytag.tld", "d2", "3" ),
  • setB( "4" ),
  • setDynamicAttribute( null, "d3", "5" ), and
  • setDynamicAttribute( "http://www.foo.com/jsp/taglib/mytag.tld", "d4", "6" ).
<jsp:root xmlns:mytag="http://www.foo.com/jsp/taglib/mytag.tld" version="2.0">
  <mytag:invokeDynamic a="1" d1="2" mytag:d2="3">
    <jsp:attribute name="b">4</jsp:attribute>
    <jsp:attribute name="d3">5</jsp:attribute>
    <jsp:attribute name="mytag:d4">6</jsp:attribute>
  </mytag:invokeDynamic>
</jsp:root>

4. Annotated Tag Handler Management Example

 Below is a somewhat complete example of the way one JSP container could choose to do some tag handler management. There are many other strategies that could be followed, with different pay offs.

In this example, we are assuming that x:iterate is an iterative tag, while x:doit and x:foobar are simple tag. We will also assume that x:iterate and x:foobar implement the TryCatchFinally interface, while x:doit does not.

<x:iterate src="foo">
  <x:doit att1="one" att2="<%= 1 + 1 %>" />
  <x:foobar />
  <x:doit att1="one" att2="<%= 2 + 2 %>" />
</x:iterate>
<x:doit att1="one" att2="<%= 3 + 3 %>" />

The particular code shown below assumes there is some pool of tag handlers that are managed (details not described, although pool managing is simpler when there are no optional attributes), and attemps to reuse tag handlers if possible. The code also "hoists" setting of properties to reduce the cost when appropriate, e.g. inside an iteration.

boolean b1, b2;
IterationTag i; // for x:iterate
Tag d; // for x:doit
Tag d; // for x:foobar

page: // label to end of page...

// initialize iteration tag
i = get tag from pool or new();

i.setPageContext(pc);
i.setParent(null);
i.setSrc("foo");

// x:iterate implements TryCatchFinally
try {
    if ((b1 = i.doStartTag()) == EVAL_BODY_INCLUDE) {

        // initialize doit tag
        // code has been moved out of the loop for show
        d = get tag from pool or new();

        d.setPageContext(pc);
        d.setParent(i);
        d.setAtt1("one");

    loop:
        while (1) do {
            // I'm ignoring newlines...

            // two invocations, fused together

            // first invocation of x:doit
            d.setAtt2(1+1);
            if ((b2 = d.doStartTag()) == EVAL_BODY_INCLUDE) {
                // nothing
            } else if (b2 != SKIP_BODY) {
                // Q? protocol error ...
            }
            if ((b2 = d.doEndTag()) == SKIP_PAGE) {
                break page;  // be done with it.
            } else if (b2 != EVAL_PAGE) {
                // Q? protocol error
            }

            // x:foobar invocation
            f = get tag from pool or new();
            f.setPageContext(pc);
            f.setParent(i);

            // x:foobar implements TryCatchFinally
            try {

                if ((b2 = f.doStartTag()) == EVAL_BODY_INCLUDE) {
                    // nothing
                } else if (b2 != SKIP_BODY) {
                    // Q? protocol error
                }
                if ((b2 = f.doEndTag()) == SKIP_PAGE) {
                    break page;  // be done with it.
                } else if (b2 != EVAL_PAGE) {
                    // Q? protocol error
                }
            } catch (Throwable t) {
                f.doCatch(t); // caught, may been rethrown!
            } finally {
                f.doFinally();
            }

            // put f back to pool

            // second invocation of x:doit
            d.setAtt2(2+2);
            if ((b2 = d.doStartTag()) == EVAL_BODY_INCLUDE) {
                // nothing
            } else if (b2 != SKIP_BODY) {
                // Q? protocol error
            }
            if ((b2 = d.doEndTag()) == SKIP_PAGE) {
                break page;  // be done with it.
            } else if (b2 != EVAL_PAGE) {
                // Q? protocol error
            }

            if ((b2 = i.doAfterBody()) == EVAL_BODY_AGAIN) {
                break loop;
            } else if (b2 != SKIP_BODY) {
                // Q? protocol error
            }
        // loop
        }

    } else if (b1 != SKIP_BODY) {
        // Q? protocol error
    }

    // tail end of the IteratorTag ...

    if ((b1 = i.doEndTag()) == SKIP_PAGE) {
        break page;   // be done with it.
    } else if (b1 != EVAL_PAGE) {
        // Q? protocol error
    }

    // third invocation
    // this tag handler could be reused from the previous ones.
    d = get tag from pool or new();

    d.setPageContext(pc);
    d.setParent(null);
    d.setAtt1("one");
    d.setAtt2(3+3);

    if ((b1 = d.doStartTag()) == EVAL_BODY_INCLUDE) {
        // nothing
    } else if (b1 != SKIP_BODY) {
        // Q? protocol error
    }
    if ((b1 = d.doEndTag()) == SKIP_PAGE) {
        break page;  // be done with it.
    } else if (b1 != EVAL_PAGE) {
        // Q? protocol error
    }

} catch (Throwable t) {
    i.doCatch(t); // caught, may been rethrown!
} finally {
    i.doFinally();
}

5. Cooperating Actions

 Actions can cooperate with other actions and with scripting code in a number of ways.

PageContext

Often two actions in a JSP page will want to cooperate, perhaps by one action creating some server-side object that needs to be accessed by another. One mechanism for doing this is by giving the object a name within the JSP page; the first action will create the object and associate the name to it while the second action will use the name to retrieve the object.

For example, in the following JSP segment the foo action might create a server-side object and give it the name "myObject". Then the bar action might access that server-side object and take some action.

<x:foo id="myObject" />
<x:bar ref="myObjet" />

In a JSP implementation, the mapping "name"->value is kept by the implicit object pageContext. This object is passed around through the Tag handler instances so it can be used to communicate information: all it is needed is to know the name under which the information is stored into the pageContext.

The Runtime Stack

An alternative to explicit communication of information through a named object is implicit coordination based on syntactic scoping.

For example, in the following JSP segment the foo action might create a server-side object; later the nested bar action might access that server-side object. The object is not named within the pageContext: it is found because the specific foo element is the closest enclosing instance of a known element type.

<foo>
   <bar/>
</foo>

This functionality is supported through the TagSupport.findAncestorWithClass(Tag, Class), which uses a reference to parent tag kept by each Tag instance, which effectively provides a run-time execution stack.

6. Simple Tag Handlers

This section presents the API to implement Simple Tag Handlers. Simple Tag Handlers present a much simpler invocation protocol than do Classic Tag Handlers.

The Tag Library Descriptor maps tag library declarations to their physical underlying implementations. A Simple Tag Handler is represented in Java by a class which implements the SimpleTag interface.

Unlike classic tag handlers, the SimpleTag interface does not extend Tag. Instead of supporting doStartTag() and doEndTag(), the SimpleTag interface provides a simple doTag() method, which is called once and only once for any given tag invocation. All tag logic, iteration, body evaluations, etc. are to be performed in this single method. Thus, simple tag handlers have the equivalent power of BodyTag, but with a much simpler lifecycle and interface.

To support body content, the setJspBody() method is provided. The container invokes the setJspBody() method with a JspFragment object encapsulating the body of the tag. The tag handler implementation can call invoke() on that fragment to evaluate the body. The SimpleTagSupport convenience class provides getJspBody() and other useful methods to make this even easier.

Lifecycle of Simple Tag Handlers

This section describes the lifecycle of simple tag handlers, from creation to invocation. For all semantics left unspecified by this section, the semantics default to that of a classic tag handler.

When a simple tag handler is invoked, the following steps occur (in order):

  1. Simple tag handlers are created initially using a zero argument constructor on the corresponding implementation class. Unlike classic tag handlers, this instance must never be pooled by the container. A new instance must be created for each tag invocation.
  2. The setJspContext() and setParent() methods are invoked on the tag handler. The setParent() method need not be called if the value being passed in is null. In the case of tag files, a JspContext wrapper is created so that the tag file can appear to have its own page scope. Calling getJspContext() must return the wrapped JspContext.
  3. The attributes specified as XML element attributes (if any) are evaluated next, in the order in which they are declared, according to the following rules (referred to as "evaluating an XML element attribute" below). The appropriate bean property setter is invoked for each. If no setter is defined for the specified attribute but the tag accepts dynamic attributes, the setDynamicAttribute() method is invoked as the setter.
    • If the attribute is a scripting expression (e.g. "<%= 1+1 %>" in JSP syntax, or "%= 1+1 %" in XML syntax), the expression is evaluated, and the result is converted as per the rules in "Type Conversions", and passed to the setter.
    • Otherwise, if the attribute contains any Expression Language expressions (e.g. "Hello ${name}"), the expression is evaluated, and the result is converted and passed to the setter.
    • Otherwise, the attribute value is taken verbatim, converted, and passed to the setter.
  4. The value for each <jsp:attribute> element is evaluated, and the corresponding bean property setter methods are invoked for each, in the order in which they appear in the body of the tag. If no setter is defined for the specified attribute but the tag accepts dynamic attributes, the setDynamicAttribute() method is invoked as the setter.
    • Otherwise, if the attribute is not of type JspFragment, the container evaluates the body of the <jsp:attribute> element. This evaluation can be done in a container-specific manner. Container implementors should note that in the process of evaluating this body, other custom actions may be invoked.
    • Otherwise, if the attribute is of type JspFragment, an instance of a JspFragment object is created and passed in.
  5. The value for the body of the tag is determined, and if a body exists the setJspBody() method is called on the tag handler.
    • If the tag is declared to have a body-content of "empty" or no body or an empty body is passed for this invocation, then setJspBody() is not called.
    • Otherwise, the body of the tag is either the body of the <jsp:body> element, or the body of the custom action invocation if no <jsp:body> or <jsp:attribute> elements are present. In this case, an instance of a JspFragment object is created as per the lifecycle described in the JSP Fragments section and it is passed to the setter. If the tag is declared to have a body-content of "tagdependent" the JspFragment must echo the body's contents verbatim. Otherwise, if the tag is declared to have a body-content of type "scriptless", the JspFragment must evaluate the body's contents as a JSP scriptless body.
  6. The doTag() method is invoked.
  7. The implementation of doTag() performs its function, potentially calling other tag handlers (if the tag handler is implemented as a tag file) and invoking fragments.
  8. The doTag() method returns, and the tag handler instance is discarded. If SkipPageException is thrown, the rest of the page is not evaluated and the request is completed. If this request was forwarded or included from another page (or Servlet), only the current page evaluation stops.
  9. For each tag scripting variable declared with scopes AT_BEGIN or AT_END, the appropriate scripting variables and scoped attributes are declared, as with classic tag handlers.

7. JSP Fragments

JSP Fragments are represented in Java by an instance of the javax.servlet.jsp.tagext.JspFragment abstract class. Pieces of JSP code are translated into JSP fragments in the context of a tag invocation. JSP Fragments are created when providing the body of a <jsp:attribute> standard action for an attribute that is defined as a fragment or of type JspFragment, or when providing the body of a tag invocation handled by a Simple Tag Handler.

Before being passed to a tag handler, the JspFragment instance is associated with the JspContext of the surrounding page in an implementation-dependent manner. In addition, it is associated with the parent Tag or SimpleTag instance for collaboration purposes, so that when a custom action is invoked from within the fragment, setParent() can be called with the appropriate value. The fragment implementation must keep these associations for the duration of the tag invocation in which it is used.

The invoke() method executes the body and directs all output to either the passed in java.io.Writer or the JspWriter returned by the getOut() method of the JspContext associated with the fragment.

The implementation of each method can optionally throw a JspException, which must be handled by the invoker. Note that tag library developers and page authors should not generate JspFragment implementations manually.

The following sections specify the creation and invocation lifecycles of a JSP Fragment in detail, from the JSP Container's perspective.

Creation of a JSP Fragment

When a JSP fragment is created, the following steps occur (in order):

  1. An instance of a class implementing the JspFragment abstract class is obtained (may either be created or can optionally be cached) each time the tag is invoked. This instance must be configured to produce the contents of the body of the fragment when invoked. If the fragment is defining the body of a <jsp:attribute>, the fragment must evaluate the body each time it is invoked. Otherwise, if the fragment is defining the body of a simple tag, the behavior of the fragment when invoked varies depending on the body-content declared for the tag:
    • If the body-content is "tagdependent", then the fragment must echo the contents of the body verbatim when invoked.
    • If the body-content is "scriptless", then the fragment must evaluate the body each time it is invoked.
  2. The JspFragment instance is passed a reference to the current JspContext. Whenever the fragment invokes a tag handler, it must use this value when calling setJspContext().
  3. The JspFragment instance is associated with an instance of the tag handler of the nearest enclosing tag invocation, or with null if there is no enclosing tag. Whenever the fragment invokes a tag handler, the fragment must use this value when calling setParent().

Invocation of a JSP Fragment

After a JSP fragment is created, it is passed to a tag handler for later invocation. JSP fragments can be invoked either programmatically from a tag handler written in Java, or from a tag file using the <jsp:invoke> or <jsp:doBody> standard action.

JSP fragments are passed to tag handlers using a bean property of type JspFragment. These fragments can be invoked by calling the invoke() method in the JspFragment abstract class. Note that it is legal (and possible) for a fragment to recursively invoke itself, indirectly.

The following steps are followed when invoking a JSP fragment:

  1. The tag handler invoking the fragment is responsible for setting the values of all declared AT_BEGIN and NESTED variables in the JspContext of the calling page/tag, before invoking the fragment. Note that this is not always the same as the JspContext of the fragment being invoked, as fragments can be passed from one tag to another. In the case of tag files, for each variable declared in scope AT_BEGIN or NESTED, if a page scoped attribute exists with the provided name in the tag file, the JSP container must generate code to create/update the page scoped attribute of the provided name in the calling page/tag. If a page scoped attribute with the provided name does not exist in the tag file, and a page scoped attribute of the provided name is present in the calling page, the scoped attribute is removed from the calling page's page scope. See the chapter on Tag Files for details.
  2. If <jsp:invoke> or <jsp:doBody> is being used to invoke a fragment, if the var attribute is specified, a custom java.io.Writer is created that can expose the result of the invocation as a java.lang.String object. If the varReader attribute is specified, a custom java.io.Writer object is created that can expose the resulting invocation as a java.io.Reader object.
  3. The invoke() method of the fragment is invoked, passing in an optional Writer.
  4. Before executing the body of the fragment, if a non-null value is provided for the writer parameter, then the value of JspContext.getOut() and the implicit "out" object must be updated to send output to that writer. To accomplish this, the container must call pushBody( writer ) on the current JspContext, where writer is the instance of java.io.Writer passed to the fragment upon invocation.
  5. The body of the fragment is then evaluated by executing the generated code. The body of the fragment may execute other standard or custom actions. If a classic Custom Tag Handler is invoked and returns SKIP_PAGE, or if a Simple Tag Handler is invoked and throws SkipPageException, the JspFragment must throw SkipPageException to signal that the calling page is to be skipped.
  6. Once the fragment has completed its evaluation, even if an exception is thrown, the value of JspContext.getOut() must be restored via a call to popBody() on the current JspContext.
  7. The fragment returns from invoke()
  8. If <jsp:invoke> or <jsp:doBody> is being used to invoke a fragment, if the var or varReader attribute is specified, a scoped variable with a name equal to the value of the var or varReader attribute is created (or modified) in the page scope, and the value is set to a java.lang.String or java.io.Reader respectively that can produce the results of the fragment invocation.
  9. The invoke() method can be called again, zero or more times. When the tag invocation defining the fragment is complete, the tag must discard the fragment instance since it might be reused by the container.

8. Example Simple Tag Handler Scenario

The following non-normative example is intended to help solidify some of the concepts relating to Tag Files, JSP Fragments and Simple Tag Handlers. In the first section, two sample input files are presented, a JSP (my.jsp), and a simple tag handler implemented using a tag file (simpletag.tag). One possible output of the translation process is presented in the second section.

Although short, the example shows all concepts, including the variable directive. In practice most uses of tags will be much simpler, but probably longer.

The sample generated code is annotated with comments that point to lifecycle steps presented in various sections. The notation is as follows:

  • "Step T.x" = Annotated step x from "Lifecycle of Simple Tag Handlers" earlier in this Chapter.
  • "Step C.x" = Annotated step x from "Creation of a JSP Fragment" earlier in this Chapter.
  • "Step F.x" = Annotated step x from "Invocation of a JSP Fragment" earlier in this Chapter.

Sample Source Files

This section presents the sample source files in this scenario, from which the output files are generated.

Original JSP (my.jsp)

<%@ taglib prefix="my" tagdir="/WEB-INF/tags" %>

<my:simpleTag x="10">
    <jsp:attribute name="y">20</jsp:attribute>
    <jsp:attribute name="nonfragment">
        Nonfragment Template Text
    </jsp:attribute>
    <jsp:attribute name="frag">
        Fragment Template Text ${var1}
    </jsp:attribute>
    <jsp:body>
        Body of tag that defines an AT_BEGIN
        scripting variable ${var1}.
    </jsp:body>
</my:simpleTag>

Original Tag File (/WEB-INF/tags/simpletag.tag)

<%-- /WEB-INF/tags/simpletag.tag --%>
<%@ attribute name="x" %>
<%@ attribute name="y" %>
<%@ attribute name="nonfragment" %>
<%@ attribute name="frag" fragment="true" %>
<%@ variable name-given="var1" scope="AT_BEGIN" %>
<%@ taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core" %>

Some template text.
<c:set var="var1" value="${x+y}"/>
<jsp:invoke fragment="frag" varReader="var1"/>

Invoke the body:
<jsp:doBody/>

Sample Generated Files

This section presents sample output files that might be generated by a JSP compiler, from the source files presented in the previous section.

Helper class for JspFragment (JspFragmentBase.java)

public abstract class JspFragmentBase
    implements javax.servlet.jsp.tagext.JspFragment
{
    protected javax.servlet.jsp.JspContext jspContext;
    protected javax.servlet.jsp.tagext.JspTag parentTag;
    public void JspFragmentBase(
        javax.servlet.jsp.JspContext jspContext,
        javax.servlet.jsp.tagext.JspTag parentTag )
    {
        this.jspContext = jspContext;
        this.parentTag = parentTag;
    }
}

Relevant Portion of JSP Service Method

// Step T.1 - Initial creation
MySimpleTag _jsp_mySimpleTag = new MySimpleTag();
// Step T.2 - Set page context and parent (since parent is null,
// no need to call setParent() in this case)
_jsp_mySimpleTag.setJspContext( jspContext );
// Step T.3 - XML element attributes evaluated and set
_jsp.mySimpleTag.setX( "10" );
// Step T.4 - <jsp:attribute> elements evaluated and set
//   - parameter y
// (using PageContext.pushBody() is one possible implementation -
// one limitation is that this code will only work for Servlet-based code).
out = ((PageContext)jspContext).pushBody();
out.write( "20" );
_jsp_mySimpleTag.setY(
    ((javax.servlet.jsp.tagext.BodyContent)out).getString() );
out = jspContext.popBody();
//   - parameter nonfragment
// (using PageContext.pushBody() is one possible implementation -
// one limitation is that this code will only work for Servlet-based code).
// Note that trim is enabled by default, else we would have "\n    Non..."
out = ((PageContext)jspContext).pushBody();
out.write( "Nonfragment Template Text" );
_jsp_mySimpleTag.setNonfragment(
    ((javax.servlet.jsp.tagext.BodyContent)out).getString() );
out = jspContext.popBody();
//   - parameter frag
_jsp_mySimpleTag.setFrag(
    // Step C.1 - New instance of fragment created
    // Step C.2 - Store jspContext
    // Step C.3 - Association with nearest enclosing Tag instance
    new JspFragmentBase( jspContext, _jsp_mySimpleTag ) {
        public void invoke( java.io.Writer writer ) {
            javax.servlet.jsp.JspWriter out;
            // Step F.1-F.3 done in tag file (see following example)
            // Step F.4 - If writer provided, push body:
            if( out == null ) {
                out = this.jspContext.getOut();
            }
            else {
                out = this.jspContext.pushBody( writer );
            }
            // Step F.5 - Evaluate body of fragment:
            try {
                out.write( "Fragment Template Text " );
                out.write( jspContext.getExpressionEvaluator().evaluate(
                    "${var1}",
                    java.lang.String.class,
                    vResolver, fMapper, "my" ) );
            }
            finally {
                // Step F.6 - Restore value of JspContext.getOut()
                if( writer != null ) {
                    this.jspContext.popBody();
                }
            }

            // Step F.7-F.9 done in tag file (see following example)
        }
    } );
// Step T.5 - Determine and set body of the tag
// - body of tag
_jsp_mySimpleTag.setJspBody(
    // Step C.1 - New instance of fragment created
    // Step C.2 - Store jspContext
    // Step C.3 - Association with nearest enclosing Tag instance
    new JspFragmentBase( jspContext, _jsp_mySimpleTag ) {
        public void invoke( java.io.Writer writer ) {
            javax.servlet.jsp.JspWriter out;
            // Step F.1-F.3 done in tag file (see following example)
            // Step F.4 - If writer provided, push body:
            if( writer == null ) {
                out = this.jspContext.getOut();
            }
            else {
                out = this.jspContext.pushBody( writer );
            }
            // Step F.5 - Evaluate body of fragment:
            try {
                out.write(
                    "Body of tag that defines an AT_BEGIN\n" +
                    " scripting variable " );
                out.write( jspContext.getExpressionEvaluator().evaluate(
                    "${var1}",
                    java.lang.String.class,
                    vResolver, fMapper, "my" ) );
                out.write( ".\n" );
            }
            finally {
                // Step F.6 - Restore value of JspContext.getOut()
                if( writer != null ) {
                    this.jspContext.popBody();
                }
            }

            // Step F.7-F.9 done in tag file (see following example)
        }
    } );
// Step T.6 - Inovke doTag
// Step T.7 occurs in the tag file (see following example)
// Step T.8 - doTag returns - page will catch SkipPageException.
_jsp_mySimpleTag.doTag();
// Step T.9 - Declare AT_BEGIN and AT_END scripting variables
String var1 = (String)jspContext.findAttribute( "var1" );

Generated Simple Tag Handler (MySimpleTag.java)

public class MySimpleTag
    extends javax.servlet.jsp.tagext.SimpleTagSupport
{
    // Attributes:
    private String x;
    private String y;
    private String nonfragment;
    private javax.servlet.jsp.tagext.JspFragment frag;
    // Setters and getters for attributes:
    public void setX( Stirng x ) {
        this.x = x;
    }
    public String getX() {
        return this.x;
    }
    public void setY( String y ) {
        this.y = y;
    }
    public String getY() {
        return this.y;
    }
    public void setNonfragment( String nonfragment ) {
        this.nonfragment = nonfragment;
    }
    public String getNonfragment() {
        return this.nonfragment;
    }
    public void setFrag( javax.servlet.jsp.tagext.JspFragment frag ) {
        this.frag = frag;
    }
    public javax.servlet.jsp.tagext.JspFragment getFrag() {
        return this.frag;
    }

    protected JspContext jspContext;
    public void setJspContext( JspContext ctx ) {
        super.setJspContext( ctx );
        // Step T.2 - A JspContext wrapper is created.
        // (Implementation of wrapper not shown).
        this.jspContext = new utils.JspContextWrapper( ctx );
    }
    public JspContext getJspContext() {
        // Step T.2 - Calling getJspContext() must return the
        // wrapped JspContext.
        return this.jspContext;
    }

    public void doTag() throws JspException {
        java.lang.Object jspValue;
        JspContext jspContext = getJspContext();
        JspContext _jsp_parentContext =
            SimpleTagSupport.this.getJspContext();
        try {
            javax.servlet.jsp.JspWriter out = jspContext.getOut();

            // Create page-scope attributes for each tag attribute:
            this.jspContext.setAttribute( "x", getX() );
            this.jspContext.setAttribute( "y", getY() );
            this.jspContext.setAttribute( "nonfragment", getNonfragment() );
            this.jspContext.setAttribute( "frag", getFrag() );

            // Synchronize AT_BEGIN variables from calling page
            if( (jspValue = _jsp_parentContext.getAttribute(
                    "var1" )) != null )
            {
                jspContext.setAttribute( "var1", value );
            }
            else {
                jspContext.removeAttribute( "var1",
                    JspContext.PAGE_SCOPE );
            }

            // Tag template text:
            out.write( "\n\n\n\n\n\n\n\nSome template text.\n" );

            // Invoke c:set - recognized tag handler from JSTL:
            jspContext.setAttribute( "var1",
                jspContext.getExpressionEvaluator().evaluate(
                    "${x+y}",
                    java.lang.String.class,
                    jspContext,
                    prefixMap, functionMap, "my" ) );

            // Invoke the "frag" fragment:
            // Step F.1 - Set values of AT_BEGIN and NESTED variables
            //     in calling page context.
            if( (jspValue = jspContext.getAttribute( "var1" )) != null ) {
                _jsp_parentContext.setAttribute( "var1", value );
            }
            else {
                _jsp_parentContext.removeAttribute( "var1",
                    JspContext.PAGE_SCOPE );
            }

            // Step F.2 - varReader is specified, generate a writer.
            java.io.Writer _jsp_sout = new java.io.StringWriter();

            // Step F.3 - Invoke fragment with writer
            getFrag().invoke( _jsp_sout );

            // Step F.4 - F.6 occur in the fragment (see above)
            // Step F.7 - fragment returns

            // Step F.8 - varReader specified, so save to var
            jspContext.setAttribute(
                "var1", new StringReader( _jsp_sout.toString() ) );

            // Step F.9 - Done!

            out.write( "\n\nInvoke the body:\n" );

            // Invoke the body of the tag:
            // Step F.1 - Set values of AT_BEGIN and NESTED variables
            //     in calling page context.
            if( (jspValue = jspContext.getAttribute( "var1" )) != null ) {
                _jsp_parentContext.setAttribute( "var1", value );
            }
            else {
                _jsp_parentContext.removeAttribute( "var1",
                    JspContext.PAGE_SCOPE);
            }

            // Step F.2 - varReader is not specified - does not apply.

            try {
                // Step F.3 - Invoke body, passing optional writer
                getJspBody().invoke( null );
            }
            finally {
                // Steps F.4 - F.6 occur in the fragment (see above)
                // Step F.7 - fragment returns
            }

            // Step F.8 does not apply.
            // Step F.9 - Done!
        }
        finally {
            // Tag handlers generate code to synchronize AT_BEGIN with
            // calling page, regardless of whether an error occurs.
            if( (jspValue = jspContext.getAttribute( "var1" )) != null ) {
                _jsp_parentContext.setAttribute( "var1", value );
            }
            else {
                _jsp_parentContext.removeAttribute( "var1",
                    JspContext.PAGE_SCOPE );
            }
        }
    }
}

9. Translation-time Classes

 The following classes are used at translation time.

Tag mapping, Tag name

A taglib directive introduces a tag library and associates a prefix to it. The TLD associated with the library associates Tag handler classes (plus other information) with tag names. This information is used to associate a Tag class, a prefix, and a name with each custom action element appearing in a JSP page.

At execution time the implementation of a JSP page will use an available Tag instance with the appropriate property settings and then follow the protocol described by the interfaces Tag, IterationTag, BodyTag, SimpleTag, and TryCatchFinally. The implementation guarantees that all tag handler instances are initialized and all are released, but the implementation can assume that previous settings are preserved by a tag handler, to reduce run-time costs.

Scripting Variables

JSP supports scripting variables that can be declared within a scriptlet and can be used in another. JSP actions also can be used to define scripting variables so they can used in scripting elements, or in other actions. This is very useful in some cases; for example, the jsp:useBean standard action may define an object which can later be used through a scripting variable.

In some cases the information on scripting variables can be described directly into the TLD using elements. A special case is typical interpretation of the "id" attribute. In other cases the logic that decides whether an action instance will define a scripting variable may be quite complex and the name of a TagExtraInfo class is instead given in the TLD. The getVariableInfo method of this class is used at translation time to obtain information on each variable that will be created at request time when this action is executed. The method is passed a TagData instance that contains the translation-time attribute values.

Validation

The TLD file contains several pieces of information that is used to do syntactic validation at translation-time. It also contains two extensible validation mechanisms: a TagLibraryValidator class can be used to validate a complete JSP page, and a TagExtraInfo class can be used to validate a specific action. In some cases, additional request-time validation will be done dynamically within the methods in the Tag instance. If an error is discovered, an instance of JspTagException can be thrown. If uncaught, this object will invoke the errorpage mechanism of JSP.

The TagLibraryValidator is an addition to the JSP 1.2 specification and is very open ended, being strictly more powerful than the TagExtraInfo mechanism. A JSP page is presented via the PageData object, which abstracts the XML view of the JSP page.

A PageData instance will provides an InputStream (read-only) on the page. Later specifications may add other views on the page (DOM, SAX, JDOM are all candidates), for now these views can be generated from the InputStream and perhaps can be cached for improved performance (recall the view of the page is just read-only).

As of JSP 2.0, the JSP container must support a jsp:id attribute to provide higher quality validation errors. The container will track the JSP pages as passed to the container, and will assign to each element a unique "id", which is passed as the value of the jsp:id attribute. Each XML element in the XML view will be extended with this attribute. The TagLibraryValidator can use the attribute in one or more ValidationMessage objects. The container then, in turn, can use these values to provide more precise information on the location of an error.

The prefix for the id attribute need not be "jsp" but it must map to the namespace http://java.sun.com/JSP/Page. In the case where the user has redefined the jsp prefix, an alternative prefix must be used by the container.

Validation Details

In detail, validation is done as follows:

First, the JSP page is parsed using the information in the TLD. At this stage valid mandatory and optional attributes are checked.

Second, for each unique tag library in the page as determined by the tag library URI, and in the lexical order in which they appear, their associated validator class (if any) is invoked. This involves several substeps.

The first substep is to obtain an initialized validator instance by either:

  • construct a new instance and invoke setInitParameters() on it, or
  • obtain an existing instance that is not being used, invoke release() on it, and then invoke setInitParameters() on it, or
  • locate an existing instance that is not being used on which the desired setInitParameters() has already been invoked

The class name is as indicated in the <validator-class> element, and the Map passed through setInitParameters() is as described in the <init-params> element. All TagLibraryValidator classes are supposed to keep their initParameters until new ones are set, or until release() is invoked on them.

The second substep is to perform the actual validation. This is done by invoking the validate() method with a prefix, uri, and PageData that correspond to the taglib directive instance being validated and the PageData representing the page. In the case where a single URI is mapped to more than one prefix, the prefix of the first URI must be used.

The last substep is to invoke the release() method on the validator tag when it is no longer needed. This method releases all resources.

Finally, after checking all the tag library validator classes, the TagExtraInfo classes for all tags will be consulted by invoking their validate method. The order of invocation of this methods is undefined.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.servlet.jsp.tagext Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.servlet.jsp.tagext

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.jsp.tagext.FunctionInfo
    • javax.servlet.jsp.tagext.JspFragment
    • javax.servlet.jsp.tagext.PageData
    • javax.servlet.jsp.tagext.SimpleTagSupport (implements javax.servlet.jsp.tagext.SimpleTag)
    • javax.servlet.jsp.tagext.TagAdapter (implements javax.servlet.jsp.tagext.Tag)
    • javax.servlet.jsp.tagext.TagAttributeInfo
    • javax.servlet.jsp.tagext.TagData (implements java.lang.Cloneable)
    • javax.servlet.jsp.tagext.TagExtraInfo
    • javax.servlet.jsp.tagext.TagFileInfo
    • javax.servlet.jsp.tagext.TagInfo
    • javax.servlet.jsp.tagext.TagLibraryInfo
    • javax.servlet.jsp.tagext.TagLibraryValidator
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
    • javax.servlet.jsp.tagext.TagVariableInfo
    • javax.servlet.jsp.tagext.ValidationMessage
    • javax.servlet.jsp.tagext.VariableInfo
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • javax.servlet.jsp.JspWriter
        • javax.servlet.jsp.tagext.BodyContent

Interface Hierarchy

  • javax.servlet.jsp.tagext.DynamicAttributes
  • javax.servlet.jsp.tagext.JspIdConsumer
  • javax.servlet.jsp.tagext.JspTag
    • javax.servlet.jsp.tagext.SimpleTag
    • javax.servlet.jsp.tagext.Tag
      • javax.servlet.jsp.tagext.IterationTag
        • javax.servlet.jsp.tagext.BodyTag
  • javax.servlet.jsp.tagext.TryCatchFinally
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JspFragment (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class JspFragment

  • java.lang.Object
    • javax.servlet.jsp.tagext.JspFragment

  • public abstract class JspFragment
extends Object
    Encapsulates a portion of JSP code in an object that can be invoked as many times as needed. JSP Fragments are defined using JSP syntax as the body of a tag for an invocation to a SimpleTag handler, or as the body of a <jsp:attribute> standard action specifying the value of an attribute that is declared as a fragment, or to be of type JspFragment in the TLD.

    The definition of the JSP fragment must only contain template text and JSP action elements. In other words, it must not contain scriptlets or scriptlet expressions. At translation time, the container generates an implementation of the JspFragment abstract class capable of executing the defined fragment.

    A tag handler can invoke the fragment zero or more times, or pass it along to other tags, before returning. To communicate values to/from a JSP fragment, tag handlers store/retrieve values in the JspContext associated with the fragment.

    Note that tag library developers and page authors should not generate JspFragment implementations manually.

    Implementation Note: It is not necessary to generate a separate class for each fragment. One possible implementation is to generate a single helper class for each page that implements JspFragment. Upon construction, a discriminator can be passed to select which fragment that instance will execute.

    Since:
    JSP 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      JspFragment()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract JspContext getJspContext()
      Returns the JspContext that is bound to this JspFragment.
      abstract void invoke(Writer out)
      Executes the fragment and directs all output to the given Writer, or the JspWriter returned by the getOut() method of the JspContext associated with the fragment if out is null.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JspFragment

        public JspFragment()

    • Method Detail

      • invoke

        public abstract void invoke(Writer out)
                     throws JspException,
                            IOException
        Executes the fragment and directs all output to the given Writer, or the JspWriter returned by the getOut() method of the JspContext associated with the fragment if out is null.
        Parameters:
        out - The Writer to output the fragment to, or null if output should be sent to JspContext.getOut().
        Throws:
        JspException - Thrown if an error occured while invoking this fragment.
        SkipPageException - Thrown if the page that (either directly or indirectly) invoked the tag handler that invoked this fragment is to cease evaluation. The container must throw this exception if a Classic Tag Handler returned Tag.SKIP_PAGE or if a Simple Tag Handler threw SkipPageException.
        IOException - If there was an error writing to the stream.

      • getJspContext

        public abstract JspContext getJspContext()
        Returns the JspContext that is bound to this JspFragment.
        Returns:
        The JspContext used by this fragment at invocation time.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JspIdConsumer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Interface JspIdConsumer

  • All Known Implementing Classes:
    UIComponentBodyTag, UIComponentClassicTagBase, UIComponentELTag, UIComponentTag

    public interface JspIdConsumer

    This interface indicates to the container that a tag handler wishes to be provided with a compiler generated ID.

    The container sets the jspId attribute of the tag handler with an identification string, as part of tag property initialization. Each tag in a JSP page has a unique jspId, and a given tag in a JSP page always has the same jspId, even for multiple requests to the page.

    Tag handler instances that implement JspIdConsumer cannot be reused.

    Even though the jspId attribute is similar in concept to the jsp:id attribute of an XML view (see Section JSP.10.1.13 of the spec), they are not related. The jsp:id attribute is available only at translation time, and the jspId attribute is avalable only at request time.

    The JSP container must provide a value for jspId that conforms to the following rules:

    • It must start with a letter (as defined by the Character.isLetter() method) or underscore ('_').
    • Subsequent characters may be letters (as defined by the Character.isLetter() method), digits (as defined by the Character.isDigit() method), dashes ('-'), or underscores ('_')

    Note that the rules exclude colons ':' in a jspId, and that they are the same rules used for a component ID in JavaServer Faces.

    Since:
    JSP 2.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void setJspId(String id)
      Called by the container generated code to set a value for the jspId attribute.

    • Method Detail

      • setJspId

        void setJspId(String id)
        Called by the container generated code to set a value for the jspId attribute. An unique identification string, relative to this page, is generated at translation time.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JspTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Interface JspTag

  • All Known Subinterfaces:
    BodyTag, IterationTag, LoopTag, SimpleTag, Tag
    All Known Implementing Classes:
    AttributeTag, BodyTagSupport, ConditionalTagSupport, ConverterELTag, ConverterTag, FacetTag, LoopTagSupport, SimpleTagSupport, TagAdapter, TagSupport, UIComponentBodyTag, UIComponentClassicTagBase, UIComponentELTag, UIComponentTag, UIComponentTagBase, ValidatorELTag, ValidatorTag

    public interface JspTag
    Serves as a base class for Tag and SimpleTag. This is mostly for organizational and type-safety purposes.
    Since:
    JSP 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PageData (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class PageData

  • java.lang.Object
    • javax.servlet.jsp.tagext.PageData

  • public abstract class PageData
extends Object
    Translation-time information on a JSP page. The information corresponds to the XML view of the JSP page.

    Objects of this type are generated by the JSP translator, e.g. when being pased to a TagLibraryValidator instance.

    • Constructor Summary

      Constructors
      Constructor and Description
      PageData()
      Sole constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract InputStream getInputStream()
      Returns an input stream on the XML view of a JSP page.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PageData

        public PageData()
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • Method Detail

      • getInputStream

        public abstract InputStream getInputStream()
        Returns an input stream on the XML view of a JSP page. The stream is encoded in UTF-8. Recall tht the XML view of a JSP page has the include directives expanded.
        Returns:
        An input stream on the document.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SimpleTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Interface SimpleTag

  • All Superinterfaces:
    JspTag
    All Known Implementing Classes:
    SimpleTagSupport

    public interface SimpleTag
extends JspTag
    Interface for defining Simple Tag Handlers.

    Simple Tag Handlers differ from Classic Tag Handlers in that instead of supporting doStartTag() and doEndTag(), the SimpleTag interface provides a simple doTag() method, which is called once and only once for any given tag invocation. All tag logic, iteration, body evaluations, etc. are to be performed in this single method. Thus, simple tag handlers have the equivalent power of BodyTag, but with a much simpler lifecycle and interface.

    To support body content, the setJspBody() method is provided. The container invokes the setJspBody() method with a JspFragment object encapsulating the body of the tag. The tag handler implementation can call invoke() on that fragment to evaluate the body as many times as it needs.

    A SimpleTag handler must have a public no-args constructor. Most SimpleTag handlers should extend SimpleTagSupport.

    Lifecycle

    The following is a non-normative, brief overview of the SimpleTag lifecycle. Refer to the JSP Specification for details.

    1. A new tag handler instance is created each time by the container by calling the provided zero-args constructor. Unlike classic tag handlers, simple tag handlers are never cached and reused by the JSP container.
    2. The setJspContext() and setParent() methods are called by the container. The setParent() method is only called if the element is nested within another tag invocation.
    3. The setters for each attribute defined for this tag are called by the container.
    4. If a body exists, the setJspBody() method is called by the container to set the body of this tag, as a JspFragment. If the action element is empty in the page, this method is not called at all.
    5. The doTag() method is called by the container. All tag logic, iteration, body evaluations, etc. occur in this method.
    6. The doTag() method returns and all variables are synchronized.
    Since:
    JSP 2.0
    See Also:
    SimpleTagSupport

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void doTag()
      Called by the container to invoke this tag.
      JspTag getParent()
      Returns the parent of this tag, for collaboration purposes.
      void setJspBody(JspFragment jspBody)
      Provides the body of this tag as a JspFragment object, able to be invoked zero or more times by the tag handler.
      void setJspContext(JspContext pc)
      Called by the container to provide this tag handler with the JspContext for this invocation.
      void setParent(JspTag parent)
      Sets the parent of this tag, for collaboration purposes.

    • Method Detail

      • doTag

        void doTag()
           throws JspException,
                  IOException
        Called by the container to invoke this tag. The implementation of this method is provided by the tag library developer, and handles all tag processing, body iteration, etc.

        The JSP container will resynchronize any AT_BEGIN and AT_END variables (defined by the associated tag file, TagExtraInfo, or TLD) after the invocation of doTag().

        Throws:
        JspException - If an error occurred while processing this tag.
        SkipPageException - If the page that (either directly or indirectly) invoked this tag is to cease evaluation. A Simple Tag Handler generated from a tag file must throw this exception if an invoked Classic Tag Handler returned SKIP_PAGE or if an invoked Simple Tag Handler threw SkipPageException or if an invoked Jsp Fragment threw a SkipPageException.
        IOException - If there was an error writing to the output stream.

      • setParent

        void setParent(JspTag parent)
        Sets the parent of this tag, for collaboration purposes.

        The container invokes this method only if this tag invocation is nested within another tag invocation.

        Parameters:
        parent - the tag that encloses this tag

      • getParent

        JspTag getParent()
        Returns the parent of this tag, for collaboration purposes.
        Returns:
        the parent of this tag

      • setJspContext

        void setJspContext(JspContext pc)
        Called by the container to provide this tag handler with the JspContext for this invocation. An implementation should save this value.
        Parameters:
        pc - the page context for this invocation
        See Also:
        Tag.setPageContext(javax.servlet.jsp.PageContext)

      • setJspBody

        void setJspBody(JspFragment jspBody)
        Provides the body of this tag as a JspFragment object, able to be invoked zero or more times by the tag handler.

        This method is invoked by the JSP page implementation object prior to doTag(). If the action element is empty in the page, this method is not called at all.

        Parameters:
        jspBody - The fragment encapsulating the body of this tag.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SimpleTagSupport (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class SimpleTagSupport

  • java.lang.Object
    • javax.servlet.jsp.tagext.SimpleTagSupport
  • All Implemented Interfaces:
    JspTag, SimpleTag

    public class SimpleTagSupport
extends Object
implements SimpleTag
    A base class for defining tag handlers implementing SimpleTag.

    The SimpleTagSupport class is a utility class intended to be used as the base class for new simple tag handlers. The SimpleTagSupport class implements the SimpleTag interface and adds additional convenience methods including getter methods for the properties in SimpleTag.

    Since:
    JSP 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      SimpleTagSupport()
      Sole constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void doTag()
      Default processing of the tag does nothing.
      static JspTag findAncestorWithClass(JspTag from, Class<?> klass)
      Find the instance of a given class type that is closest to a given instance.
      protected JspFragment getJspBody()
      Returns the body passed in by the container via setJspBody.
      protected JspContext getJspContext()
      Returns the page context passed in by the container via setJspContext.
      JspTag getParent()
      Returns the parent of this tag, for collaboration purposes.
      void setJspBody(JspFragment jspBody)
      Stores the provided JspFragment.
      void setJspContext(JspContext pc)
      Stores the provided JSP context in the private jspContext field.
      void setParent(JspTag parent)
      Sets the parent of this tag, for collaboration purposes.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SimpleTagSupport

        public SimpleTagSupport()
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • Method Detail

      • doTag

        public void doTag()
           throws JspException,
                  IOException
        Default processing of the tag does nothing.
        Specified by:
        doTag in interface SimpleTag
        Throws:
        JspException - Subclasses can throw JspException to indicate an error occurred while processing this tag.
        SkipPageException - If the page that (either directly or indirectly) invoked this tag is to cease evaluation. A Simple Tag Handler generated from a tag file must throw this exception if an invoked Classic Tag Handler returned SKIP_PAGE or if an invoked Simple Tag Handler threw SkipPageException or if an invoked Jsp Fragment threw a SkipPageException.
        IOException - Subclasses can throw IOException if there was an error writing to the output stream
        See Also:
        SimpleTag.doTag()

      • setParent

        public void setParent(JspTag parent)
        Sets the parent of this tag, for collaboration purposes.

        The container invokes this method only if this tag invocation is nested within another tag invocation.

        Specified by:
        setParent in interface SimpleTag
        Parameters:
        parent - the tag that encloses this tag

      • getParent

        public JspTag getParent()
        Returns the parent of this tag, for collaboration purposes.
        Specified by:
        getParent in interface SimpleTag
        Returns:
        the parent of this tag

      • setJspContext

        public void setJspContext(JspContext pc)
        Stores the provided JSP context in the private jspContext field. Subclasses can access the JspContext via getJspContext().
        Specified by:
        setJspContext in interface SimpleTag
        Parameters:
        pc - the page context for this invocation
        See Also:
        SimpleTag.setJspContext(javax.servlet.jsp.JspContext)

      • getJspContext

        protected JspContext getJspContext()
        Returns the page context passed in by the container via setJspContext.
        Returns:
        the page context for this invocation

      • setJspBody

        public void setJspBody(JspFragment jspBody)
        Stores the provided JspFragment.
        Specified by:
        setJspBody in interface SimpleTag
        Parameters:
        jspBody - The fragment encapsulating the body of this tag. If the action element is empty in the page, this method is not called at all.
        See Also:
        SimpleTag.setJspBody(javax.servlet.jsp.tagext.JspFragment)

      • getJspBody

        protected JspFragment getJspBody()
        Returns the body passed in by the container via setJspBody.
        Returns:
        the fragment encapsulating the body of this tag, or null if the action element is empty in the page.

      • findAncestorWithClass

        public static final JspTag findAncestorWithClass(JspTag from,
                           Class<?> klass)
        Find the instance of a given class type that is closest to a given instance. This method uses the getParent method from the Tag and/or SimpleTag interfaces. This method is used for coordination among cooperating tags.

        For every instance of TagAdapter encountered while traversing the ancestors, the tag handler returned by TagAdapter.getAdaptee() - instead of the TagAdpater itself - is compared to klass. If the tag handler matches, it - and not its TagAdapter - is returned.

        The current version of the specification only provides one formal way of indicating the observable type of a tag handler: its tag handler implementation class, described in the tag-class subelement of the tag element. This is extended in an informal manner by allowing the tag library author to indicate in the description subelement an observable type. The type should be a subtype of the tag handler implementation class or void. This addititional constraint can be exploited by a specialized container that knows about that specific tag library, as in the case of the JSP standard tag library.

        When a tag library author provides information on the observable type of a tag handler, client programmatic code should adhere to that constraint. Specifically, the Class passed to findAncestorWithClass should be a subtype of the observable type.

        Parameters:
        from - The instance from where to start looking.
        klass - The subclass of JspTag or interface to be matched
        Returns:
        the nearest ancestor that implements the interface or is an instance of the class specified
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Tag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Interface Tag

  • All Superinterfaces:
    JspTag
    All Known Subinterfaces:
    BodyTag, IterationTag, LoopTag
    All Known Implementing Classes:
    AttributeTag, BodyTagSupport, ConditionalTagSupport, ConverterELTag, ConverterTag, FacetTag, LoopTagSupport, TagAdapter, TagSupport, UIComponentBodyTag, UIComponentClassicTagBase, UIComponentELTag, UIComponentTag, ValidatorELTag, ValidatorTag

    public interface Tag
extends JspTag
    The interface of a classic tag handler that does not want to manipulate its body. The Tag interface defines the basic protocol between a Tag handler and JSP page implementation class. It defines the life cycle and the methods to be invoked at start and end tag.

    Properties

    The Tag interface specifies the setter and getter methods for the core pageContext and parent properties.

    The JSP page implementation object invokes setPageContext and setParent, in that order, before invoking doStartTag() or doEndTag().

    Methods

    There are two main actions: doStartTag and doEndTag. Once all appropriate properties have been initialized, the doStartTag and doEndTag methods can be invoked on the tag handler. Between these invocations, the tag handler is assumed to hold a state that must be preserved. After the doEndTag invocation, the tag handler is available for further invocations (and it is expected to have retained its properties).

    Lifecycle

    Lifecycle details are described by the transition diagram below, with the following comments:

    • [1] This transition is intended to be for releasing long-term data. no guarantees are assumed on whether any properties have been retained or not.
    • [2] This transition happens if and only if the tag ends normally without raising an exception
    • [3] Some setters may be called again before a tag handler is reused. For instance, setParent() is called if it's reused within the same page but at a different level, setPageContext() is called if it's used in another page, and attribute setters are called if the values differ or are expressed as request-time attribute values.
    • Check the TryCatchFinally interface for additional details related to exception handling and resource management.

    Lifecycle Details Transition Diagram for Tag

    Once all invocations on the tag handler are completed, the release method is invoked on it. Once a release method is invoked all properties, including parent and pageContext, are assumed to have been reset to an unspecified value. The page compiler guarantees that release() will be invoked on the Tag handler before the handler is released to the GC.

    Empty and Non-Empty Action

    If the TagLibraryDescriptor file indicates that the action must always have an empty action, by an <body-content> entry of "empty", then the doStartTag() method must return SKIP_BODY.

    Otherwise, the doStartTag() method may return SKIP_BODY or EVAL_BODY_INCLUDE.

    If SKIP_BODY is returned the body, if present, is not evaluated.

    If EVAL_BODY_INCLUDE is returned, the body is evaluated and "passed through" to the current out.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int EVAL_BODY_INCLUDE
      Evaluate body into existing out stream.
      static int EVAL_PAGE
      Continue evaluating the page.
      static int SKIP_BODY
      Skip body evaluation.
      static int SKIP_PAGE
      Skip the rest of the page.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int doEndTag()
      Process the end tag for this instance.
      int doStartTag()
      Process the start tag for this instance.
      Tag getParent()
      Get the parent (closest enclosing tag handler) for this tag handler.
      void release()
      Called on a Tag handler to release state.
      void setPageContext(PageContext pc)
      Set the current page context.
      void setParent(Tag t)
      Set the parent (closest enclosing tag handler) of this tag handler.

    • Field Detail

      • SKIP_BODY

        static final int SKIP_BODY
        Skip body evaluation. Valid return value for doStartTag and doAfterBody.
        See Also:
        Constant Field Values

      • EVAL_BODY_INCLUDE

        static final int EVAL_BODY_INCLUDE
        Evaluate body into existing out stream. Valid return value for doStartTag.
        See Also:
        Constant Field Values

      • SKIP_PAGE

        static final int SKIP_PAGE
        Skip the rest of the page. Valid return value for doEndTag.
        See Also:
        Constant Field Values

      • EVAL_PAGE

        static final int EVAL_PAGE
        Continue evaluating the page. Valid return value for doEndTag().
        See Also:
        Constant Field Values

    • Method Detail

      • setPageContext

        void setPageContext(PageContext pc)
        Set the current page context. This method is invoked by the JSP page implementation object prior to doStartTag().

        This value is *not* reset by doEndTag() and must be explicitly reset by a page implementation if it changes between calls to doStartTag().

        Parameters:
        pc - The page context for this tag handler.

      • setParent

        void setParent(Tag t)
        Set the parent (closest enclosing tag handler) of this tag handler. Invoked by the JSP page implementation object prior to doStartTag().

        This value is *not* reset by doEndTag() and must be explicitly reset by a page implementation.

        Parameters:
        t - The parent tag, or null.

      • getParent

        Tag getParent()
        Get the parent (closest enclosing tag handler) for this tag handler.

        The getParent() method can be used to navigate the nested tag handler structure at runtime for cooperation among custom actions; for example, the findAncestorWithClass() method in TagSupport provides a convenient way of doing this.

        The current version of the specification only provides one formal way of indicating the observable type of a tag handler: its tag handler implementation class, described in the tag-class subelement of the tag element. This is extended in an informal manner by allowing the tag library author to indicate in the description subelement an observable type. The type should be a subtype of the tag handler implementation class or void. This addititional constraint can be exploited by a specialized container that knows about that specific tag library, as in the case of the JSP standard tag library.

        Returns:
        the current parent, or null if none.
        See Also:
        TagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.Tag, java.lang.Class)

      • doStartTag

        int doStartTag()
               throws JspException
        Process the start tag for this instance. This method is invoked by the JSP page implementation object.

        The doStartTag method assumes that the properties pageContext and parent have been set. It also assumes that any properties exposed as attributes have been set too. When this method is invoked, the body has not yet been evaluated.

        This method returns Tag.EVAL_BODY_INCLUDE or BodyTag.EVAL_BODY_BUFFERED to indicate that the body of the action should be evaluated or SKIP_BODY to indicate otherwise.

        When a Tag returns EVAL_BODY_INCLUDE the result of evaluating the body (if any) is included into the current "out" JspWriter as it happens and then doEndTag() is invoked.

        BodyTag.EVAL_BODY_BUFFERED is only valid if the tag handler implements BodyTag.

        The JSP container will resynchronize the values of any AT_BEGIN and NESTED variables (defined by the associated TagExtraInfo or TLD) after the invocation of doStartTag(), except for a tag handler implementing BodyTag whose doStartTag() method returns BodyTag.EVAL_BODY_BUFFERED.

        Returns:
        EVAL_BODY_INCLUDE if the tag wants to process body, SKIP_BODY if it does not want to process it.
        Throws:
        JspException - if an error occurred while processing this tag
        See Also:
        BodyTag

      • doEndTag

        int doEndTag()
             throws JspException
        Process the end tag for this instance. This method is invoked by the JSP page implementation object on all Tag handlers.

        This method will be called after returning from doStartTag. The body of the action may or may not have been evaluated, depending on the return value of doStartTag.

        If this method returns EVAL_PAGE, the rest of the page continues to be evaluated. If this method returns SKIP_PAGE, the rest of the page is not evaluated, the request is completed, and the doEndTag() methods of enclosing tags are not invoked. If this request was forwarded or included from another page (or Servlet), only the current page evaluation is stopped.

        The JSP container will resynchronize the values of any AT_BEGIN and AT_END variables (defined by the associated TagExtraInfo or TLD) after the invocation of doEndTag().

        Returns:
        indication of whether to continue evaluating the JSP page.
        Throws:
        JspException - if an error occurred while processing this tag

      • release

        void release()
        Called on a Tag handler to release state. The page compiler guarantees that JSP page implementation objects will invoke this method on all tag handlers, but there may be multiple invocations on doStartTag and doEndTag in between.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class TagAdapter

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagAdapter
  • All Implemented Interfaces:
    JspTag, Tag

    public class TagAdapter
extends Object
implements Tag
    Wraps any SimpleTag and exposes it using a Tag interface. This is used to allow collaboration between classic Tag handlers and SimpleTag handlers.

    Because SimpleTag does not extend Tag, and because Tag.setParent() only accepts a Tag instance, a classic tag handler (one that implements Tag) cannot have a SimpleTag as its parent. To remedy this, a TagAdapter is created to wrap the SimpleTag parent, and the adapter is passed to setParent() instead. A classic Tag Handler can call getAdaptee() to retrieve the encapsulated SimpleTag instance.

    Since:
    JSP 2.0

    • Field Summary

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      TagAdapter(SimpleTag adaptee)
      Creates a new TagAdapter that wraps the given SimpleTag and returns the parent tag when getParent() is called.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int doEndTag()
      Must not be called.
      int doStartTag()
      Must not be called.
      JspTag getAdaptee()
      Gets the tag that is being adapted to the Tag interface.
      Tag getParent()
      Returns the parent of this tag, which is always getAdaptee().getParent().
      void release()
      Must not be called.
      void setPageContext(PageContext pc)
      Must not be called.
      void setParent(Tag parentTag)
      Must not be called.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TagAdapter

        public TagAdapter(SimpleTag adaptee)
        Creates a new TagAdapter that wraps the given SimpleTag and returns the parent tag when getParent() is called.
        Parameters:
        adaptee - The SimpleTag being adapted as a Tag.

    • Method Detail

      • setPageContext

        public void setPageContext(PageContext pc)
        Must not be called.
        Specified by:
        setPageContext in interface Tag
        Parameters:
        pc - ignored.
        Throws:
        UnsupportedOperationException - Must not be called

      • setParent

        public void setParent(Tag parentTag)
        Must not be called. The parent of this tag is always getAdaptee().getParent().
        Specified by:
        setParent in interface Tag
        Parameters:
        parentTag - ignored.
        Throws:
        UnsupportedOperationException - Must not be called.

      • getParent

        public Tag getParent()
        Returns the parent of this tag, which is always getAdaptee().getParent(). This will either be the enclosing Tag (if getAdaptee().getParent() implements Tag), or an adapter to the enclosing Tag (if getAdaptee().getParent() does not implement Tag).
        Specified by:
        getParent in interface Tag
        Returns:
        The parent of the tag being adapted.
        See Also:
        TagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.Tag, java.lang.Class)

      • getAdaptee

        public JspTag getAdaptee()
        Gets the tag that is being adapted to the Tag interface. This should be an instance of SimpleTag in JSP 2.0, but room is left for other kinds of tags in future spec versions.
        Returns:
        the tag that is being adapted

      • doStartTag

        public int doStartTag()
               throws JspException
        Must not be called.
        Specified by:
        doStartTag in interface Tag
        Returns:
        always throws UnsupportedOperationException
        Throws:
        UnsupportedOperationException - Must not be called
        JspException - never thrown
        See Also:
        BodyTag

      • doEndTag

        public int doEndTag()
             throws JspException
        Must not be called.
        Specified by:
        doEndTag in interface Tag
        Returns:
        always throws UnsupportedOperationException
        Throws:
        UnsupportedOperationException - Must not be called
        JspException - never thrown

      • release

        public void release()
        Must not be called.
        Specified by:
        release in interface Tag
        Throws:
        UnsupportedOperationException - Must not be called
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagAttributeInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class TagAttributeInfo

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagAttributeInfo

  • public class TagAttributeInfo
extends Object
    Information on the attributes of a Tag, available at translation time. This class is instantiated from the Tag Library Descriptor file (TLD).

    Only the information needed to generate code is included here. Other information like SCHEMA for validation belongs elsewhere.

    Note from the Expert Group:
    This should have been designed as an interface. Every time we change the TLD, we need to add a new constructor to this class (not good). This class should only be instantiated by container implementations (not by JSP developers).

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ID
      "id" is wired in to be ID.

    • Constructor Summary

      Constructors
      Constructor and Description
      TagAttributeInfo(String name, boolean required, String type, boolean reqTime)
      Constructor for TagAttributeInfo.
      TagAttributeInfo(String name, boolean required, String type, boolean reqTime, boolean fragment)
      JSP 2.0 Constructor for TagAttributeInfo.
      TagAttributeInfo(String name, boolean required, String type, boolean reqTime, boolean fragment, String description, boolean deferredValue, boolean deferredMethod, String expectedTypeName, String methodSignature)
      JSP 2.1 Constructor for TagAttributeInfo.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean canBeRequestTime()
      Whether this attribute has been specified in the TLD as rtexprvalue.
      String getDescription()
      Gets the description string of this tag attribute.
      String getExpectedTypeName()
      Returns the name of the expected type (as a String) of this deferred value attribute.
      static TagAttributeInfo getIdAttribute(TagAttributeInfo[] a)
      Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".
      String getMethodSignature()
      Returns the expected method signature of this deferred method attribute.
      String getName()
      The name of this attribute.
      String getTypeName()
      The type (as a String) of this attribute.
      boolean isDeferredMethod()
      Returns true if this attribute is to be passed a MethodExpression so that expression evaluation can be deferred.
      boolean isDeferredValue()
      Returns true if this attribute is to be passed a ValueExpression so that expression evaluation can be deferred.
      boolean isFragment()
      Whether this attribute is of type JspFragment.
      boolean isRequired()
      Whether this attribute is required.
      String toString()
      Returns a String representation of this TagAttributeInfo, suitable for debugging purposes.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • ID

        public static final String ID
        "id" is wired in to be ID. There is no real benefit in having it be something else IDREFs are not handled any differently.
        See Also:
        Constant Field Values

    • Constructor Detail

      • TagAttributeInfo

        public TagAttributeInfo(String name,
                boolean required,
                String type,
                boolean reqTime)
        Constructor for TagAttributeInfo. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor).
        Parameters:
        name - The name of the attribute.
        required - If this attribute is required in tag instances.
        type - The name of the type of the attribute.
        reqTime - Whether this attribute holds a request-time Attribute.

      • TagAttributeInfo

        public TagAttributeInfo(String name,
                boolean required,
                String type,
                boolean reqTime,
                boolean fragment)
        JSP 2.0 Constructor for TagAttributeInfo. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor).
        Parameters:
        name - The name of the attribute.
        required - If this attribute is required in tag instances.
        type - The name of the type of the attribute.
        reqTime - Whether this attribute holds a request-time Attribute.
        fragment - Whether this attribute is of type JspFragment
        Since:
        JSP 2.0

      • TagAttributeInfo

        public TagAttributeInfo(String name,
                boolean required,
                String type,
                boolean reqTime,
                boolean fragment,
                String description,
                boolean deferredValue,
                boolean deferredMethod,
                String expectedTypeName,
                String methodSignature)
        JSP 2.1 Constructor for TagAttributeInfo. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor).
        Parameters:
        name - The name of the attribute.
        required - If this attribute is required in tag instances.
        type - The name of the type of the attribute.
        reqTime - Whether this attribute holds a request-time Attribute.
        fragment - Whether this attribute is of type JspFragment
        description - The description of the attribute.
        deferredValue - Whether this attribute is a deferred value.
        deferredMethod - Whether this attribute is a deferred method. rtexpr or deferred value.
        expectedTypeName - The name of the expected type of this deferred value (or null if this is not a deferred value).
        methodSignature - The expected method signature of this deferred method (or null if this is not a deferred method).
        Since:
        JSP 2.1

    • Method Detail

      • getName

        public String getName()
        The name of this attribute.
        Returns:
        the name of the attribute

      • getTypeName

        public String getTypeName()
        The type (as a String) of this attribute.

        This method must return "javax.el.ValueExpression" if isDeferredValue() returns true and canBeRequestTime() returns false. It must return "javax.el.MethodExpression" if isDeferredMethod() returns true. It must return "java.lang.Object" if isDeferredValue() returns true and canBeRequestTime() returns true.

        Returns:
        the type of the attribute

      • canBeRequestTime

        public boolean canBeRequestTime()
        Whether this attribute has been specified in the TLD as rtexprvalue. If true, this means the attribute can hold a request-time value.
        Returns:
        true if the attribute has been specified in the TLD as rtexprvalue

      • isRequired

        public boolean isRequired()
        Whether this attribute is required.
        Returns:
        if the attribute is required.

      • getIdAttribute

        public static TagAttributeInfo getIdAttribute(TagAttributeInfo[] a)
        Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".
        Parameters:
        a - An array of TagAttributeInfo
        Returns:
        The TagAttributeInfo reference with name "id"

      • isFragment

        public boolean isFragment()
        Whether this attribute is of type JspFragment.
        Returns:
        if the attribute is of type JspFragment
        Since:
        JSP 2.0

      • getDescription

        public String getDescription()
        Gets the description string of this tag attribute.
        Returns:
        the description string of this tag attribute

      • isDeferredValue

        public boolean isDeferredValue()
        Returns true if this attribute is to be passed a ValueExpression so that expression evaluation can be deferred.

        If this method returns true, then getTypeName() must return "javax.el.ValueExpression".

        The getExpectedType() method can be used to retrieve the expected type this value expression will be constructed with.

        Returns:
        true if this attribute accepts a deferred value; false otherwise.
        Since:
        JSP 2.1

      • isDeferredMethod

        public boolean isDeferredMethod()
        Returns true if this attribute is to be passed a MethodExpression so that expression evaluation can be deferred.

        If this method returns true, then getTypeName() must return "javax.el.MethodExpression".

        The getMethodSignature() method can be used to retrieve the expected method signature this method expression will be constructed with.

        Returns:
        true if this attribute accepts a deferred method; false otherwise.
        Since:
        JSP 2.1

      • getExpectedTypeName

        public String getExpectedTypeName()
        Returns the name of the expected type (as a String) of this deferred value attribute.

        This method returns null if isDeferredValue() returns false.

        Returns:
        the name of the expected type
        Since:
        JSP 2.1

      • getMethodSignature

        public String getMethodSignature()
        Returns the expected method signature of this deferred method attribute.

        This method returns null if isDeferredMethod() returns false.

        Returns:
        the method signature
        Since:
        JSP 2.1

      • toString

        public String toString()
        Returns a String representation of this TagAttributeInfo, suitable for debugging purposes.
        Overrides:
        toString in class Object
        Returns:
        a String representation of this TagAttributeInfo
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagData (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class TagData

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagData
  • All Implemented Interfaces:
    Cloneable

    public class TagData
extends Object
implements Cloneable
    The (translation-time only) attribute/value information for a tag instance.

    TagData is only used as an argument to the isValid, validate, and getVariableInfo methods of TagExtraInfo, which are invoked at translation time.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static Object REQUEST_TIME_VALUE
      Distinguished value for an attribute to indicate its value is a request-time expression (which is not yet available because TagData instances are used at translation-time).

    • Constructor Summary

      Constructors
      Constructor and Description
      TagData(Hashtable<String,Object> attrs)
      Constructor for a TagData.
      TagData(Object[][] atts)
      Constructor for TagData.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getAttribute(String attName)
      The value of the attribute.
      Enumeration<String> getAttributes()
      Enumerates the attributes.
      String getAttributeString(String attName)
      Get the value for a given attribute.
      String getId()
      The value of the tag's id attribute.
      void setAttribute(String attName, Object value)
      Set the value of an attribute.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • REQUEST_TIME_VALUE

        public static final Object REQUEST_TIME_VALUE
        Distinguished value for an attribute to indicate its value is a request-time expression (which is not yet available because TagData instances are used at translation-time).

    • Constructor Detail

      • TagData

        public TagData(Object[][] atts)
        Constructor for TagData.

        A typical constructor may be

         static final Object[][] att = {{"connection", "conn0"}, {"id", "query0"}};
 static final TagData td = new TagData(att);
        All values must be Strings except for those holding the distinguished object REQUEST_TIME_VALUE.
        Parameters:
        atts - the static attribute and values. May be null.

      • TagData

        public TagData(Hashtable<String,Object> attrs)
        Constructor for a TagData. If you already have the attributes in a hashtable, use this constructor.
        Parameters:
        attrs - A hashtable to get the values from.

    • Method Detail

      • getId

        public String getId()
        The value of the tag's id attribute.
        Returns:
        the value of the tag's id attribute, or null if no such attribute was specified.

      • getAttribute

        public Object getAttribute(String attName)
        The value of the attribute. If a static value is specified for an attribute that accepts a request-time attribute expression then that static value is returned, even if the value is provided in the body of a <jsp:attribute> action. The distinguished object REQUEST_TIME_VALUE is only returned if the value is specified as a request-time attribute expression or via the <jsp:attribute> action with a body that contains dynamic content (scriptlets, scripting expressions, EL expressions, standard actions, or custom actions). Returns null if the attribute is not set.
        Parameters:
        attName - the name of the attribute
        Returns:
        the attribute's value

      • setAttribute

        public void setAttribute(String attName,
                Object value)
        Set the value of an attribute.
        Parameters:
        attName - the name of the attribute
        value - the value.

      • getAttributeString

        public String getAttributeString(String attName)
        Get the value for a given attribute.
        Parameters:
        attName - the name of the attribute
        Returns:
        the attribute value string
        Throws:
        ClassCastException - if attribute value is not a String

      • getAttributes

        public Enumeration<String> getAttributes()
        Enumerates the attributes.
        Returns:
        An enumeration of the attributes in a TagData
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagExtraInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class TagExtraInfo

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagExtraInfo

  • public abstract class TagExtraInfo
extends Object
    Optional class provided by the tag library author to describe additional translation-time information not described in the TLD. The TagExtraInfo class is mentioned in the Tag Library Descriptor file (TLD).

    This class can be used:

    • to indicate that the tag defines scripting variables
    • to perform translation-time validation of the tag attributes.

    It is the responsibility of the JSP translator that the initial value to be returned by calls to getTagInfo() corresponds to a TagInfo object for the tag being translated. If an explicit call to setTagInfo() is done, then the object passed will be returned in subsequent calls to getTagInfo().

    The only way to affect the value returned by getTagInfo() is through a setTagInfo() call, and thus, TagExtraInfo.setTagInfo() is to be called by the JSP translator, with a TagInfo object that corresponds to the tag being translated. The call should happen before any invocation on validate() and before any invocation on getVariableInfo().

    NOTE: It is a (translation time) error for a tag definition in a TLD with one or more variable subelements to have an associated TagExtraInfo implementation that returns a VariableInfo array with one or more elements from a call to getVariableInfo().

    • Constructor Summary

      Constructors
      Constructor and Description
      TagExtraInfo()
      Sole constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      TagInfo getTagInfo()
      Get the TagInfo for this class.
      VariableInfo[] getVariableInfo(TagData data)
      information on scripting variables defined by the tag associated with this TagExtraInfo instance.
      boolean isValid(TagData data)
      Translation-time validation of the attributes.
      void setTagInfo(TagInfo tagInfo)
      Set the TagInfo for this class.
      ValidationMessage[] validate(TagData data)
      Translation-time validation of the attributes.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TagExtraInfo

        public TagExtraInfo()
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • Method Detail

      • getVariableInfo

        public VariableInfo[] getVariableInfo(TagData data)
        information on scripting variables defined by the tag associated with this TagExtraInfo instance. Request-time attributes are indicated as such in the TagData parameter.
        Parameters:
        data - The TagData instance.
        Returns:
        An array of VariableInfo data, or null or a zero length array if no scripting variables are to be defined.

      • isValid

        public boolean isValid(TagData data)
        Translation-time validation of the attributes. Request-time attributes are indicated as such in the TagData parameter. Note that the preferred way to do validation is with the validate() method, since it can return more detailed information.
        Parameters:
        data - The TagData instance.
        Returns:
        Whether this tag instance is valid.
        See Also:
        validate(javax.servlet.jsp.tagext.TagData)

      • validate

        public ValidationMessage[] validate(TagData data)
        Translation-time validation of the attributes. Request-time attributes are indicated as such in the TagData parameter. Because of the higher quality validation messages possible, this is the preferred way to do validation (although isValid() still works).

        JSP 2.0 and higher containers call validate() instead of isValid(). The default implementation of this method is to call isValid(). If isValid() returns false, a generic ValidationMessage[] is returned indicating isValid() returned false.

        Parameters:
        data - The TagData instance.
        Returns:
        A null object, or zero length array if no errors, an array of ValidationMessages otherwise.
        Since:
        JSP 2.0

      • setTagInfo

        public final void setTagInfo(TagInfo tagInfo)
        Set the TagInfo for this class.
        Parameters:
        tagInfo - The TagInfo this instance is extending

      • getTagInfo

        public final TagInfo getTagInfo()
        Get the TagInfo for this class.
        Returns:
        the taginfo instance this instance is extending
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagFileInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class TagFileInfo

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagFileInfo

  • public class TagFileInfo
extends Object
    Tag information for a tag file in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
    Since:
    JSP 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      TagFileInfo(String name, String path, TagInfo tagInfo)
      Constructor for TagFileInfo from data in the JSP 2.0 format for TLD.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      The unique action name of this tag.
      String getPath()
      Where to find the .tag file implementing this action.
      TagInfo getTagInfo()
      Returns information about this tag, parsed from the directives in the tag file.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TagFileInfo

        public TagFileInfo(String name,
           String path,
           TagInfo tagInfo)
        Constructor for TagFileInfo from data in the JSP 2.0 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagFileInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.
        Parameters:
        name - The unique action name of this tag
        path - Where to find the .tag file implementing this action, relative to the location of the TLD file.
        tagInfo - The detailed information about this tag, as parsed from the directives in the tag file.

    • Method Detail

      • getName

        public String getName()
        The unique action name of this tag.
        Returns:
        The (short) name of the tag.

      • getPath

        public String getPath()
        Where to find the .tag file implementing this action.
        Returns:
        The path of the tag file, relative to the TLD, or "." if the tag file was defined in an implicit tag file.

      • getTagInfo

        public TagInfo getTagInfo()
        Returns information about this tag, parsed from the directives in the tag file.
        Returns:
        a TagInfo object containing information about this tag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class TagInfo

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagInfo

  • public class TagInfo
extends Object
    Tag information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String BODY_CONTENT_EMPTY
      Static constant for getBodyContent() when it is empty.
      static String BODY_CONTENT_JSP
      Static constant for getBodyContent() when it is JSP.
      static String BODY_CONTENT_SCRIPTLESS
      Static constant for getBodyContent() when it is scriptless.
      static String BODY_CONTENT_TAG_DEPENDENT
      Static constant for getBodyContent() when it is Tag dependent.

    • Constructor Summary

      Constructors
      Constructor and Description
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo)
      Constructor for TagInfo from data in the JSP 1.1 format for TLD.
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi)
      Constructor for TagInfo from data in the JSP 1.2 format for TLD.
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi, boolean dynamicAttributes)
      Constructor for TagInfo from data in the JSP 2.0 format for TLD.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      TagAttributeInfo[] getAttributes()
      Attribute information (in the TLD) on this tag.
      String getBodyContent()
      The bodycontent information for this tag.
      String getDisplayName()
      Get the displayName.
      String getInfoString()
      The information string for the tag.
      String getLargeIcon()
      Get the path to the large icon.
      String getSmallIcon()
      Get the path to the small icon.
      String getTagClassName()
      Name of the class that provides the handler for this tag.
      TagExtraInfo getTagExtraInfo()
      The instance (if any) for extra tag information.
      TagLibraryInfo getTagLibrary()
      The instance of TabLibraryInfo we belong to.
      String getTagName()
      The name of the Tag.
      TagVariableInfo[] getTagVariableInfos()
      Get TagVariableInfo objects associated with this TagInfo.
      VariableInfo[] getVariableInfo(TagData data)
      Information on the scripting objects created by this tag at runtime.
      boolean hasDynamicAttributes()
      Get dynamicAttributes associated with this TagInfo.
      boolean isValid(TagData data)
      Translation-time validation of the attributes.
      void setTagExtraInfo(TagExtraInfo tei)
      Set the instance for extra tag information.
      void setTagLibrary(TagLibraryInfo tl)
      Set the TagLibraryInfo property.
      ValidationMessage[] validate(TagData data)
      Translation-time validation of the attributes.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • BODY_CONTENT_JSP

        public static final String BODY_CONTENT_JSP
        Static constant for getBodyContent() when it is JSP.
        See Also:
        Constant Field Values

      • BODY_CONTENT_TAG_DEPENDENT

        public static final String BODY_CONTENT_TAG_DEPENDENT
        Static constant for getBodyContent() when it is Tag dependent.
        See Also:
        Constant Field Values

      • BODY_CONTENT_EMPTY

        public static final String BODY_CONTENT_EMPTY
        Static constant for getBodyContent() when it is empty.
        See Also:
        Constant Field Values

      • BODY_CONTENT_SCRIPTLESS

        public static final String BODY_CONTENT_SCRIPTLESS
        Static constant for getBodyContent() when it is scriptless.
        Since:
        JSP 2.0
        See Also:
        Constant Field Values

    • Constructor Detail

      • TagInfo

        public TagInfo(String tagName,
       String tagClassName,
       String bodycontent,
       String infoString,
       TagLibraryInfo taglib,
       TagExtraInfo tagExtraInfo,
       TagAttributeInfo[] attributeInfo)
        Constructor for TagInfo from data in the JSP 1.1 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.
        Parameters:
        tagName - The name of this tag
        tagClassName - The name of the tag handler class
        bodycontent - Information on the body content of these tags
        infoString - The (optional) string information for this tag
        taglib - The instance of the tag library that contains us.
        tagExtraInfo - The instance providing extra Tag info. May be null
        attributeInfo - An array of AttributeInfo data from descriptor. May be null;

      • TagInfo

        public TagInfo(String tagName,
       String tagClassName,
       String bodycontent,
       String infoString,
       TagLibraryInfo taglib,
       TagExtraInfo tagExtraInfo,
       TagAttributeInfo[] attributeInfo,
       String displayName,
       String smallIcon,
       String largeIcon,
       TagVariableInfo[] tvi)
        Constructor for TagInfo from data in the JSP 1.2 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.
        Parameters:
        tagName - The name of this tag
        tagClassName - The name of the tag handler class
        bodycontent - Information on the body content of these tags
        infoString - The (optional) string information for this tag
        taglib - The instance of the tag library that contains us.
        tagExtraInfo - The instance providing extra Tag info. May be null
        attributeInfo - An array of AttributeInfo data from descriptor. May be null;
        displayName - A short name to be displayed by tools
        smallIcon - Path to a small icon to be displayed by tools
        largeIcon - Path to a large icon to be displayed by tools
        tvi - An array of a TagVariableInfo (or null)

      • TagInfo

        public TagInfo(String tagName,
       String tagClassName,
       String bodycontent,
       String infoString,
       TagLibraryInfo taglib,
       TagExtraInfo tagExtraInfo,
       TagAttributeInfo[] attributeInfo,
       String displayName,
       String smallIcon,
       String largeIcon,
       TagVariableInfo[] tvi,
       boolean dynamicAttributes)
        Constructor for TagInfo from data in the JSP 2.0 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.
        Parameters:
        tagName - The name of this tag
        tagClassName - The name of the tag handler class
        bodycontent - Information on the body content of these tags
        infoString - The (optional) string information for this tag
        taglib - The instance of the tag library that contains us.
        tagExtraInfo - The instance providing extra Tag info. May be null
        attributeInfo - An array of AttributeInfo data from descriptor. May be null;
        displayName - A short name to be displayed by tools
        smallIcon - Path to a small icon to be displayed by tools
        largeIcon - Path to a large icon to be displayed by tools
        tvi - An array of a TagVariableInfo (or null)
        dynamicAttributes - True if supports dynamic attributes
        Since:
        JSP 2.0

    • Method Detail

      • getTagName

        public String getTagName()
        The name of the Tag.
        Returns:
        The (short) name of the tag.

      • getAttributes

        public TagAttributeInfo[] getAttributes()
        Attribute information (in the TLD) on this tag. The return is an array describing the attributes of this tag, as indicated in the TLD.
        Returns:
        The array of TagAttributeInfo for this tag, or a zero-length array if the tag has no attributes.

      • getVariableInfo

        public VariableInfo[] getVariableInfo(TagData data)
        Information on the scripting objects created by this tag at runtime. This is a convenience method on the associated TagExtraInfo class.
        Parameters:
        data - TagData describing this action.
        Returns:
        if a TagExtraInfo object is associated with this TagInfo, the result of getTagExtraInfo().getVariableInfo( data ), otherwise null.

      • isValid

        public boolean isValid(TagData data)
        Translation-time validation of the attributes. This is a convenience method on the associated TagExtraInfo class.
        Parameters:
        data - The translation-time TagData instance.
        Returns:
        Whether the data is valid.

      • validate

        public ValidationMessage[] validate(TagData data)
        Translation-time validation of the attributes. This is a convenience method on the associated TagExtraInfo class.
        Parameters:
        data - The translation-time TagData instance.
        Returns:
        A null object, or zero length array if no errors, an array of ValidationMessages otherwise.
        Since:
        JSP 2.0

      • setTagExtraInfo

        public void setTagExtraInfo(TagExtraInfo tei)
        Set the instance for extra tag information.
        Parameters:
        tei - the TagExtraInfo instance

      • getTagExtraInfo

        public TagExtraInfo getTagExtraInfo()
        The instance (if any) for extra tag information.
        Returns:
        The TagExtraInfo instance, if any.

      • getTagClassName

        public String getTagClassName()
        Name of the class that provides the handler for this tag.
        Returns:
        The name of the tag handler class.

      • getBodyContent

        public String getBodyContent()
        The bodycontent information for this tag. If the bodycontent is not defined for this tag, the default of JSP will be returned.
        Returns:
        the body content string.

      • getInfoString

        public String getInfoString()
        The information string for the tag.
        Returns:
        the info string, or null if not defined

      • setTagLibrary

        public void setTagLibrary(TagLibraryInfo tl)
        Set the TagLibraryInfo property. Note that a TagLibraryInfo element is dependent not just on the TLD information but also on the specific taglib instance used. This means that a fair amount of work needs to be done to construct and initialize TagLib objects. If used carefully, this setter can be used to avoid having to create new TagInfo elements for each taglib directive.
        Parameters:
        tl - the TagLibraryInfo to assign

      • getTagLibrary

        public TagLibraryInfo getTagLibrary()
        The instance of TabLibraryInfo we belong to.
        Returns:
        the tag library instance we belong to

      • getDisplayName

        public String getDisplayName()
        Get the displayName.
        Returns:
        A short name to be displayed by tools, or null if not defined

      • getSmallIcon

        public String getSmallIcon()
        Get the path to the small icon.
        Returns:
        Path to a small icon to be displayed by tools, or null if not defined

      • getLargeIcon

        public String getLargeIcon()
        Get the path to the large icon.
        Returns:
        Path to a large icon to be displayed by tools, or null if not defined

      • getTagVariableInfos

        public TagVariableInfo[] getTagVariableInfos()
        Get TagVariableInfo objects associated with this TagInfo.
        Returns:
        Array of TagVariableInfo objects corresponding to variables declared by this tag, or a zero length array if no variables have been declared

      • hasDynamicAttributes

        public boolean hasDynamicAttributes()
        Get dynamicAttributes associated with this TagInfo.
        Returns:
        True if tag handler supports dynamic attributes
        Since:
        JSP 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagLibraryInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class TagLibraryInfo

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagLibraryInfo

  • public abstract class TagLibraryInfo
extends Object
    Translation-time information associated with a taglib directive, and its underlying TLD file. Most of the information is directly from the TLD, except for the prefix and the uri values used in the taglib directive

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected FunctionInfo[] functions
      An array describing the functions that are defined in this tag library.
      protected String info
      Information (documentation) for this TLD.
      protected String jspversion
      The version of the JSP specification this tag library is written to.
      protected String prefix
      The prefix assigned to this taglib from the taglib directive.
      protected String shortname
      The preferred short name (prefix) as indicated in the TLD.
      protected TagFileInfo[] tagFiles
      An array describing the tag files that are defined in this tag library.
      protected TagInfo[] tags
      An array describing the tags that are defined in this tag library.
      protected String tlibversion
      The version of the tag library.
      protected String uri
      The value of the uri attribute from the taglib directive for this library.
      protected String urn
      The "reliable" URN indicated in the TLD.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected TagLibraryInfo(String prefix, String uri)
      Constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      FunctionInfo getFunction(String name)
      Get the FunctionInfo for a given function name, looking through all the functions in this tag library.
      FunctionInfo[] getFunctions()
      An array describing the functions that are defined in this tag library.
      String getInfoString()
      Information (documentation) for this TLD.
      String getPrefixString()
      The prefix assigned to this taglib from the taglib directive
      String getReliableURN()
      The "reliable" URN indicated in the TLD (the uri element).
      String getRequiredVersion()
      A string describing the required version of the JSP container.
      String getShortName()
      The preferred short name (prefix) as indicated in the TLD.
      TagInfo getTag(String shortname)
      Get the TagInfo for a given tag name, looking through all the tags in this tag library.
      TagFileInfo getTagFile(String shortname)
      Get the TagFileInfo for a given tag name, looking through all the tag files in this tag library.
      TagFileInfo[] getTagFiles()
      An array describing the tag files that are defined in this tag library.
      abstract TagLibraryInfo[] getTagLibraryInfos()
      Returns an array of TagLibraryInfo objects representing the entire set of tag libraries (including this TagLibraryInfo) imported by taglib directives in the translation unit that references this TagLibraryInfo.
      TagInfo[] getTags()
      An array describing the tags that are defined in this tag library.
      String getURI()
      The value of the uri attribute from the taglib directive for this library.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • prefix

        protected String prefix
        The prefix assigned to this taglib from the taglib directive.

      • uri

        protected String uri
        The value of the uri attribute from the taglib directive for this library.

      • tags

        protected TagInfo[] tags
        An array describing the tags that are defined in this tag library.

      • tagFiles

        protected TagFileInfo[] tagFiles
        An array describing the tag files that are defined in this tag library.
        Since:
        JSP 2.0

      • functions

        protected FunctionInfo[] functions
        An array describing the functions that are defined in this tag library.
        Since:
        JSP 2.0

      • tlibversion

        protected String tlibversion
        The version of the tag library.

      • jspversion

        protected String jspversion
        The version of the JSP specification this tag library is written to.

      • shortname

        protected String shortname
        The preferred short name (prefix) as indicated in the TLD.

      • urn

        protected String urn
        The "reliable" URN indicated in the TLD.

      • info

        protected String info
        Information (documentation) for this TLD.

    • Constructor Detail

      • TagLibraryInfo

        protected TagLibraryInfo(String prefix,
              String uri)
        Constructor.
        Parameters:
        prefix - the prefix actually used by the taglib directive
        uri - the URI actually used by the taglib directive

    • Method Detail

      • getURI

        public String getURI()
        The value of the uri attribute from the taglib directive for this library.
        Returns:
        the value of the uri attribute

      • getPrefixString

        public String getPrefixString()
        The prefix assigned to this taglib from the taglib directive
        Returns:
        the prefix assigned to this taglib from the taglib directive

      • getShortName

        public String getShortName()
        The preferred short name (prefix) as indicated in the TLD. This may be used by authoring tools as the preferred prefix to use when creating an taglib directive for this library.
        Returns:
        the preferred short name for the library

      • getReliableURN

        public String getReliableURN()
        The "reliable" URN indicated in the TLD (the uri element). This may be used by authoring tools as a global identifier to use when creating a taglib directive for this library.
        Returns:
        a reliable URN to a TLD like this

      • getInfoString

        public String getInfoString()
        Information (documentation) for this TLD.
        Returns:
        the info string for this tag lib

      • getRequiredVersion

        public String getRequiredVersion()
        A string describing the required version of the JSP container.
        Returns:
        the (minimal) required version of the JSP container.
        See Also:
        JspEngineInfo

      • getTags

        public TagInfo[] getTags()
        An array describing the tags that are defined in this tag library.
        Returns:
        the TagInfo objects corresponding to the tags defined by this tag library, or a zero length array if this tag library defines no tags

      • getTagFiles

        public TagFileInfo[] getTagFiles()
        An array describing the tag files that are defined in this tag library.
        Returns:
        the TagFileInfo objects corresponding to the tag files defined by this tag library, or a zero length array if this tag library defines no tags files
        Since:
        JSP 2.0

      • getTag

        public TagInfo getTag(String shortname)
        Get the TagInfo for a given tag name, looking through all the tags in this tag library.
        Parameters:
        shortname - The short name (no prefix) of the tag
        Returns:
        the TagInfo for the tag with the specified short name, or null if no such tag is found

      • getTagFile

        public TagFileInfo getTagFile(String shortname)
        Get the TagFileInfo for a given tag name, looking through all the tag files in this tag library.
        Parameters:
        shortname - The short name (no prefix) of the tag
        Returns:
        the TagFileInfo for the specified Tag file, or null if no Tag file is found
        Since:
        JSP 2.0

      • getFunctions

        public FunctionInfo[] getFunctions()
        An array describing the functions that are defined in this tag library.
        Returns:
        the functions defined in this tag library, or a zero length array if the tag library defines no functions.
        Since:
        JSP 2.0

      • getFunction

        public FunctionInfo getFunction(String name)
        Get the FunctionInfo for a given function name, looking through all the functions in this tag library.
        Parameters:
        name - The name (no prefix) of the function
        Returns:
        the FunctionInfo for the function with the given name, or null if no such function exists
        Since:
        JSP 2.0

      • getTagLibraryInfos

        public abstract TagLibraryInfo[] getTagLibraryInfos()
        Returns an array of TagLibraryInfo objects representing the entire set of tag libraries (including this TagLibraryInfo) imported by taglib directives in the translation unit that references this TagLibraryInfo. If a tag library is imported more than once and bound to different prefices, only the TagLibraryInfo bound to the first prefix must be included in the returned array.
        Returns:
        Array of TagLibraryInfo objects representing the entire set of tag libraries (including this TagLibraryInfo) imported by taglib directives in the translation unit that references this TagLibraryInfo.
        Since:
        JSP 2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagLibraryValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class TagLibraryValidator

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagLibraryValidator
  • Direct Known Subclasses:
    PermittedTaglibsTLV, ScriptFreeTLV

    public abstract class TagLibraryValidator
extends Object
    Translation-time validator class for a JSP page. A validator operates on the XML view associated with the JSP page.

    The TLD file associates a TagLibraryValidator class and some init arguments with a tag library.

    The JSP container is reponsible for locating an appropriate instance of the appropriate subclass by

    • new a fresh instance, or reuse an available one
    • invoke the setInitParams(Map) method on the instance
    once initialized, the validate(String, String, PageData) method will be invoked, where the first two arguments are the prefix and uri for this tag library in the XML View. The prefix is intended to make it easier to produce an error message. However, it is not always accurate. In the case where a single URI is mapped to more than one prefix in the XML view, the prefix of the first URI is provided. Therefore, to provide high quality error messages in cases where the tag elements themselves are checked, the prefix parameter should be ignored and the actual prefix of the element should be used instead. TagLibraryValidators should always use the uri to identify elements as beloning to the tag library, not the prefix.

    A TagLibraryValidator instance may create auxiliary objects internally to perform the validation (e.g. an XSchema validator) and may reuse it for all the pages in a given translation run.

    The JSP container is not guaranteed to serialize invocations of validate() method, and TagLibraryValidators should perform any synchronization they may require.

    As of JSP 2.0, a JSP container must provide a jsp:id attribute to provide higher quality validation errors. The container will track the JSP pages as passed to the container, and will assign to each element a unique "id", which is passed as the value of the jsp:id attribute. Each XML element in the XML view available will be extended with this attribute. The TagLibraryValidator can then use the attribute in one or more ValidationMessage objects. The container then, in turn, can use these values to provide more precise information on the location of an error.

    The actual prefix of the id attribute may or may not be jsp but it will always map to the namespace http://java.sun.com/JSP/Page. A TagLibraryValidator implementation must rely on the uri, not the prefix, of the id attribute.

    • Constructor Summary

      Constructors
      Constructor and Description
      TagLibraryValidator()
      Sole constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Map<String,Object> getInitParameters()
      Get the init parameters data as an immutable Map.
      void release()
      Release any data kept by this instance for validation purposes.
      void setInitParameters(Map<String,Object> map)
      Set the init data in the TLD for this validator.
      ValidationMessage[] validate(String prefix, String uri, PageData page)
      Validate a JSP page.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TagLibraryValidator

        public TagLibraryValidator()
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • Method Detail

      • setInitParameters

        public void setInitParameters(Map<String,Object> map)
        Set the init data in the TLD for this validator. Parameter names are keys, and parameter values are the values.
        Parameters:
        map - A Map describing the init parameters

      • getInitParameters

        public Map<String,Object> getInitParameters()
        Get the init parameters data as an immutable Map. Parameter names are keys, and parameter values are the values.
        Returns:
        The init parameters as an immutable map.

      • validate

        public ValidationMessage[] validate(String prefix,
                           String uri,
                           PageData page)
        Validate a JSP page. This will get invoked once per unique tag library URI in the XML view. This method will return null if the page is valid; otherwise the method should return an array of ValidationMessage objects. An array of length zero is also interpreted as no errors.
        Parameters:
        prefix - the first prefix with which the tag library is associated, in the XML view. Note that some tags may use a different prefix if the namespace is redefined.
        uri - the tag library's unique identifier
        page - the JspData page object
        Returns:
        A null object, or zero length array if no errors, an array of ValidationMessages otherwise.

      • release

        public void release()
        Release any data kept by this instance for validation purposes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagSupport (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class TagSupport

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport
  • All Implemented Interfaces:
    Serializable, IterationTag, JspTag, Tag
    Direct Known Subclasses:
    AttributeTag, BodyTagSupport, ConditionalTagSupport, ConverterELTag, ConverterTag, FacetTag, LoopTagSupport, ValidatorELTag, ValidatorTag

    public class TagSupport
extends Object
implements IterationTag, Serializable
    A base class for defining new tag handlers implementing Tag.

    The TagSupport class is a utility class intended to be used as the base class for new tag handlers. The TagSupport class implements the Tag and IterationTag interfaces and adds additional convenience methods including getter methods for the properties in Tag. TagSupport has one static method that is included to facilitate coordination among cooperating tags.

    Many tag handlers will extend TagSupport and only redefine a few methods.

    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected String id
      The value of the id attribute of this tag; or null.
      protected PageContext pageContext
      The PageContext.

      • Fields inherited from interface javax.servlet.jsp.tagext.IterationTag

        EVAL_BODY_AGAIN

      • Fields inherited from interface javax.servlet.jsp.tagext.Tag

        EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE

    • Constructor Summary

      Constructors
      Constructor and Description
      TagSupport()
      Default constructor, all subclasses are required to define only a public constructor with the same signature, and to call the superclass constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int doAfterBody()
      Default processing for a body.
      int doEndTag()
      Default processing of the end tag returning EVAL_PAGE.
      int doStartTag()
      Default processing of the start tag, returning SKIP_BODY.
      static Tag findAncestorWithClass(Tag from, Class klass)
      Find the instance of a given class type that is closest to a given instance.
      String getId()
      The value of the id attribute of this tag; or null.
      Tag getParent()
      The Tag instance most closely enclosing this tag instance.
      Object getValue(String k)
      Get a the value associated with a key.
      Enumeration<String> getValues()
      Enumerate the keys for the values kept by this tag handler.
      void release()
      Release state.
      void removeValue(String k)
      Remove a value associated with a key.
      void setId(String id)
      Set the id attribute for this tag.
      void setPageContext(PageContext pageContext)
      Set the page context.
      void setParent(Tag t)
      Set the nesting tag of this tag.
      void setValue(String k, Object o)
      Associate a value with a String key.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • id

        protected String id
        The value of the id attribute of this tag; or null.

      • pageContext

        protected PageContext pageContext
        The PageContext.

    • Constructor Detail

      • TagSupport

        public TagSupport()
        Default constructor, all subclasses are required to define only a public constructor with the same signature, and to call the superclass constructor. This constructor is called by the code generated by the JSP translator.

    • Method Detail

      • findAncestorWithClass

        public static final Tag findAncestorWithClass(Tag from,
                        Class klass)
        Find the instance of a given class type that is closest to a given instance. This method uses the getParent method from the Tag interface. This method is used for coordination among cooperating tags.

        The current version of the specification only provides one formal way of indicating the observable type of a tag handler: its tag handler implementation class, described in the tag-class subelement of the tag element. This is extended in an informal manner by allowing the tag library author to indicate in the description subelement an observable type. The type should be a subtype of the tag handler implementation class or void. This addititional constraint can be exploited by a specialized container that knows about that specific tag library, as in the case of the JSP standard tag library.

        When a tag library author provides information on the observable type of a tag handler, client programmatic code should adhere to that constraint. Specifically, the Class passed to findAncestorWithClass should be a subtype of the observable type.

        Parameters:
        from - The instance from where to start looking.
        klass - The subclass of Tag or interface to be matched
        Returns:
        the nearest ancestor that implements the interface or is an instance of the class specified

      • doStartTag

        public int doStartTag()
               throws JspException
        Default processing of the start tag, returning SKIP_BODY.
        Specified by:
        doStartTag in interface Tag
        Returns:
        SKIP_BODY
        Throws:
        JspException - if an error occurs while processing this tag
        See Also:
        Tag.doStartTag()

      • doEndTag

        public int doEndTag()
             throws JspException
        Default processing of the end tag returning EVAL_PAGE.
        Specified by:
        doEndTag in interface Tag
        Returns:
        EVAL_PAGE
        Throws:
        JspException - if an error occurs while processing this tag
        See Also:
        Tag.doEndTag()

      • doAfterBody

        public int doAfterBody()
                throws JspException
        Default processing for a body.
        Specified by:
        doAfterBody in interface IterationTag
        Returns:
        SKIP_BODY
        Throws:
        JspException - if an error occurs while processing this tag
        See Also:
        IterationTag.doAfterBody()

      • release

        public void release()
        Release state.
        Specified by:
        release in interface Tag
        See Also:
        Tag.release()

      • setParent

        public void setParent(Tag t)
        Set the nesting tag of this tag.
        Specified by:
        setParent in interface Tag
        Parameters:
        t - The parent Tag.
        See Also:
        Tag.setParent(Tag)

      • getParent

        public Tag getParent()
        The Tag instance most closely enclosing this tag instance.
        Specified by:
        getParent in interface Tag
        Returns:
        the parent tag instance or null
        See Also:
        Tag.getParent()

      • setId

        public void setId(String id)
        Set the id attribute for this tag.
        Parameters:
        id - The String for the id.

      • getId

        public String getId()
        The value of the id attribute of this tag; or null.
        Returns:
        the value of the id attribute, or null

      • setPageContext

        public void setPageContext(PageContext pageContext)
        Set the page context.
        Specified by:
        setPageContext in interface Tag
        Parameters:
        pageContext - The PageContext.
        See Also:
        Tag.setPageContext(javax.servlet.jsp.PageContext)

      • setValue

        public void setValue(String k,
            Object o)
        Associate a value with a String key.
        Parameters:
        k - The key String.
        o - The value to associate.

      • getValue

        public Object getValue(String k)
        Get a the value associated with a key.
        Parameters:
        k - The string key.
        Returns:
        The value associated with the key, or null.

      • removeValue

        public void removeValue(String k)
        Remove a value associated with a key.
        Parameters:
        k - The string key.

      • getValues

        public Enumeration<String> getValues()
        Enumerate the keys for the values kept by this tag handler.
        Returns:
        An enumeration of all the keys for the values set, or null or an empty Enumeration if no values have been set.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TagVariableInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class TagVariableInfo

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagVariableInfo

  • public class TagVariableInfo
extends Object
    Variable information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time. This object should be immutable. This information is only available in JSP 1.2 format TLDs or above.

    • Constructor Summary

      Constructors
      Constructor and Description
      TagVariableInfo(String nameGiven, String nameFromAttribute, String className, boolean declare, int scope)
      Constructor for TagVariableInfo.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getClassName()
      The body of the <variable-class> element.
      boolean getDeclare()
      The body of the <declare> element.
      String getNameFromAttribute()
      The body of the <name-from-attribute> element.
      String getNameGiven()
      The body of the <name-given> element.
      int getScope()
      The body of the <scope> element.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TagVariableInfo

        public TagVariableInfo(String nameGiven,
               String nameFromAttribute,
               String className,
               boolean declare,
               int scope)
        Constructor for TagVariableInfo.
        Parameters:
        nameGiven - value of <name-given>
        nameFromAttribute - value of <name-from-attribute>
        className - value of <variable-class>
        declare - value of <declare>
        scope - value of <scope>

    • Method Detail

      • getNameGiven

        public String getNameGiven()
        The body of the <name-given> element.
        Returns:
        The variable name as a constant

      • getNameFromAttribute

        public String getNameFromAttribute()
        The body of the <name-from-attribute> element. This is the name of an attribute whose (translation-time) value will give the name of the variable. One of <name-given> or <name-from-attribute> is required.
        Returns:
        The attribute whose value defines the variable name

      • getClassName

        public String getClassName()
        The body of the <variable-class> element.
        Returns:
        The name of the class of the variable or 'java.lang.String' if not defined in the TLD.

      • getDeclare

        public boolean getDeclare()
        The body of the <declare> element.
        Returns:
        Whether the variable is to be declared or not. If not defined in the TLD, 'true' will be returned.

      • getScope

        public int getScope()
        The body of the <scope> element.
        Returns:
        The scope to give the variable. NESTED scope will be returned if not defined in the TLD.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TryCatchFinally (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Interface TryCatchFinally

  • All Known Implementing Classes:
    LoopTagSupport

    public interface TryCatchFinally
    The auxiliary interface of a Tag, IterationTag or BodyTag tag handler that wants additional hooks for managing resources.

    This interface provides two new methods: doCatch(Throwable) and doFinally(). The prototypical invocation is as follows:

     h = get a Tag();  // get a tag handler, perhaps from pool

 h.setPageContext(pc);  // initialize as desired
 h.setParent(null);
 h.setFoo("foo");

 // tag invocation protocol; see Tag.java
 try {
   doStartTag()...
   ....
   doEndTag()...
 } catch (Throwable t) {
   // react to exceptional condition
   h.doCatch(t);
 } finally {
   // restore data invariants and release per-invocation resources
   h.doFinally();
 }

 ... other invocations perhaps with some new setters
 ...
 h.release();  // release long-term resources

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void doCatch(Throwable t)
      Invoked if a Throwable occurs while evaluating the BODY inside a tag or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().
      void doFinally()
      Invoked in all cases after doEndTag() for any class implementing Tag, IterationTag or BodyTag.

    • Method Detail

      • doCatch

        void doCatch(Throwable t)
             throws Throwable
        Invoked if a Throwable occurs while evaluating the BODY inside a tag or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().

        This method is not invoked if the Throwable occurs during one of the setter methods.

        This method may throw an exception (the same or a new one) that will be propagated further up the nest chain. If an exception is thrown, doFinally() will be invoked.

        This method is intended to be used to respond to an exceptional condition.

        Parameters:
        t - The throwable exception navigating through this tag.
        Throws:
        Throwable - if the exception is to be rethrown further up the nest chain.

      • doFinally

        void doFinally()
        Invoked in all cases after doEndTag() for any class implementing Tag, IterationTag or BodyTag. This method is invoked even if an exception has occurred in the BODY of the tag, or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().

        This method is not invoked if the Throwable occurs during one of the setter methods.

        This method should not throw an Exception.

        This method is intended to maintain per-invocation data integrity and resource management actions.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.servlet.jsp.tagext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.servlet.jsp.tagext

  • Packages that use javax.servlet.jsp.tagext
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.jstl.tlv
    Reusable Tag Library Validator (TLV) classes provided by the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.
  • Classes in javax.servlet.jsp.tagext used by javax.faces.webapp
    Class and Description
    BodyContent
    An encapsulation of the evaluation of the body of an action so it is available to a tag handler.
    BodyTag
    The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.
    IterationTag
    The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.
    JspIdConsumer
    This interface indicates to the container that a tag handler wishes to be provided with a compiler generated ID.
    JspTag
    Serves as a base class for Tag and SimpleTag.
    Tag
    The interface of a classic tag handler that does not want to manipulate its body.
    TagSupport
    A base class for defining new tag handlers implementing Tag.
  • Classes in javax.servlet.jsp.tagext used by javax.servlet.jsp
    Class and Description
    BodyContent
    An encapsulation of the evaluation of the body of an action so it is available to a tag handler.
  • Classes in javax.servlet.jsp.tagext used by javax.servlet.jsp.jstl.core
    Class and Description
    IterationTag
    The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.
    JspTag
    Serves as a base class for Tag and SimpleTag.
    Tag
    The interface of a classic tag handler that does not want to manipulate its body.
    TagSupport
    A base class for defining new tag handlers implementing Tag.
    TryCatchFinally
    The auxiliary interface of a Tag, IterationTag or BodyTag tag handler that wants additional hooks for managing resources.
  • Classes in javax.servlet.jsp.tagext used by javax.servlet.jsp.jstl.tlv
    Class and Description
    PageData
    Translation-time information on a JSP page.
    TagLibraryValidator
    Translation-time validator class for a JSP page.
    ValidationMessage
    A validation message from either TagLibraryValidator or TagExtraInfo.
  • Classes in javax.servlet.jsp.tagext used by javax.servlet.jsp.tagext
    Class and Description
    BodyContent
    An encapsulation of the evaluation of the body of an action so it is available to a tag handler.
    BodyTag
    The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.
    FunctionInfo
    Information for a function in a Tag Library.
    IterationTag
    The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.
    JspFragment
    Encapsulates a portion of JSP code in an object that can be invoked as many times as needed.
    JspTag
    Serves as a base class for Tag and SimpleTag.
    PageData
    Translation-time information on a JSP page.
    SimpleTag
    Interface for defining Simple Tag Handlers.
    Tag
    The interface of a classic tag handler that does not want to manipulate its body.
    TagAttributeInfo
    Information on the attributes of a Tag, available at translation time.
    TagData
    The (translation-time only) attribute/value information for a tag instance.
    TagExtraInfo
    Optional class provided by the tag library author to describe additional translation-time information not described in the TLD.
    TagFileInfo
    Tag information for a tag file in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
    TagInfo
    Tag information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
    TagLibraryInfo
    Translation-time information associated with a taglib directive, and its underlying TLD file.
    TagSupport
    A base class for defining new tag handlers implementing Tag.
    TagVariableInfo
    Variable information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
    ValidationMessage
    A validation message from either TagLibraryValidator or TagExtraInfo.
    VariableInfo
    Information on the scripting variables that are created/modified by a tag (at run-time).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidationMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class ValidationMessage

  • java.lang.Object
    • javax.servlet.jsp.tagext.ValidationMessage

  • public class ValidationMessage
extends Object
    A validation message from either TagLibraryValidator or TagExtraInfo.

    As of JSP 2.0, a JSP container must support a jsp:id attribute to provide higher quality validation errors. The container will track the JSP pages as passed to the container, and will assign to each element a unique "id", which is passed as the value of the jsp:id attribute. Each XML element in the XML view available will be extended with this attribute. The TagLibraryValidator can then use the attribute in one or more ValidationMessage objects. The container then, in turn, can use these values to provide more precise information on the location of an error.

    The actual prefix of the id attribute may or may not be jsp but it will always map to the namespace http://java.sun.com/JSP/Page. A TagLibraryValidator implementation must rely on the uri, not the prefix, of the id attribute.

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidationMessage(String id, String message)
      Create a ValidationMessage.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getId()
      Get the jsp:id.
      String getMessage()
      Get the localized validation message.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ValidationMessage

        public ValidationMessage(String id,
                 String message)
        Create a ValidationMessage. The message String should be non-null. The value of id may be null, if the message is not specific to any XML element, or if no jsp:id attributes were passed on. If non-null, the value of id must be the value of a jsp:id attribute for the PageData passed into the validate() method.
        Parameters:
        id - Either null, or the value of a jsp:id attribute.
        message - A localized validation message.

    • Method Detail

      • getId

        public String getId()
        Get the jsp:id. Null means that there is no information available.
        Returns:
        The jsp:id information.

      • getMessage

        public String getMessage()
        Get the localized validation message.
        Returns:
        A validation message
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


VariableInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.servlet.jsp.tagext

Class VariableInfo

  • java.lang.Object
    • javax.servlet.jsp.tagext.VariableInfo

  • public class VariableInfo
extends Object
    Information on the scripting variables that are created/modified by a tag (at run-time). This information is provided by TagExtraInfo classes and it is used by the translation phase of JSP.

    Scripting variables generated by a custom action have an associated scope of either AT_BEGIN, NESTED, or AT_END.

    The class name (VariableInfo.getClassName) in the returned objects is used to determine the types of the scripting variables. Note that because scripting variables are assigned their values from scoped attributes which cannot be of primitive types, "boxed" types such as java.lang.Integer must be used instead of primitives.

    The class name may be a Fully Qualified Class Name, or a short class name.

    If a Fully Qualified Class Name is provided, it should refer to a class that should be in the CLASSPATH for the Web Application (see Servlet 2.4 specification - essentially it is WEB-INF/lib and WEB-INF/classes). Failure to be so will lead to a translation-time error.

    If a short class name is given in the VariableInfo objects, then the class name must be that of a public class in the context of the import directives of the page where the custom action appears. The class must also be in the CLASSPATH for the Web Application (see Servlet 2.4 specification - essentially it is WEB-INF/lib and WEB-INF/classes). Failure to be so will lead to a translation-time error.

    Usage Comments

    Frequently a fully qualified class name will refer to a class that is known to the tag library and thus, delivered in the same JAR file as the tag handlers. In most other remaining cases it will refer to a class that is in the platform on which the JSP processor is built (like Java EE). Using fully qualified class names in this manner makes the usage relatively resistant to configuration errors.

    A short name is usually generated by the tag library based on some attributes passed through from the custom action user (the author), and it is thus less robust: for instance a missing import directive in the referring JSP page will lead to an invalid short name class and a translation error.

    Synchronization Protocol

    The result of the invocation on getVariableInfo is an array of VariableInfo objects. Each such object describes a scripting variable by providing its name, its type, whether the variable is new or not, and what its scope is. Scope is best described through a picture:

    NESTED, AT_BEGIN and AT_END Variable Scopes

    The JSP 2.0 specification defines the interpretation of 3 values:

    • NESTED, if the scripting variable is available between the start tag and the end tag of the action that defines it.
    • AT_BEGIN, if the scripting variable is available from the start tag of the action that defines it until the end of the scope.
    • AT_END, if the scripting variable is available after the end tag of the action that defines it until the end of the scope.
    The scope value for a variable implies what methods may affect its value and thus where synchronization is needed as illustrated by the table below. Note: the synchronization of the variable(s) will occur after the respective method has been called.
    Variable Synchronization Points
    doStartTag() doInitBody() doAfterBody() doEndTag() doTag()
    Tag
                 AT_BEGIN, NESTED

            AT_BEGIN, AT_END
    IterationTag
                 AT_BEGIN, NESTED
            AT_BEGIN, NESTED
             AT_BEGIN, AT_END
    BodyTag
                 AT_BEGIN, NESTED1
             AT_BEGIN, NESTED1
             AT_BEGIN, NESTED
             AT_BEGIN, AT_END
    SimpleTag

            AT_BEGIN, AT_END
    1 Called after doStartTag() if EVAL_BODY_INCLUDE is returned, or after doInitBody() otherwise.

    Variable Information in the TLD

    Scripting variable information can also be encoded directly for most cases into the Tag Library Descriptor using the <variable> subelement of the <tag> element. See the JSP specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int AT_BEGIN
      Scope information that scripting variable is visible after start tag.
      static int AT_END
      Scope information that scripting variable is visible after end tag.
      static int NESTED
      Scope information that scripting variable is visible only within the start/end tags.

    • Constructor Summary

      Constructors
      Constructor and Description
      VariableInfo(String varName, String className, boolean declare, int scope)
      Constructor These objects can be created (at translation time) by the TagExtraInfo instances.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getClassName()
      Returns the type of this variable.
      boolean getDeclare()
      Returns whether this is a new variable.
      int getScope()
      Returns the lexical scope of the variable.
      String getVarName()
      Returns the name of the scripting variable.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • NESTED

        public static final int NESTED
        Scope information that scripting variable is visible only within the start/end tags.
        See Also:
        Constant Field Values

      • AT_BEGIN

        public static final int AT_BEGIN
        Scope information that scripting variable is visible after start tag.
        See Also:
        Constant Field Values

      • AT_END

        public static final int AT_END
        Scope information that scripting variable is visible after end tag.
        See Also:
        Constant Field Values

    • Constructor Detail

      • VariableInfo

        public VariableInfo(String varName,
            String className,
            boolean declare,
            int scope)
        Constructor These objects can be created (at translation time) by the TagExtraInfo instances.
        Parameters:
        varName - The name of the scripting variable
        className - The type of this variable
        declare - If true, it is a new variable (in some languages this will require a declaration)
        scope - Indication on the lexical scope of the variable

    • Method Detail

      • getVarName

        public String getVarName()
        Returns the name of the scripting variable.
        Returns:
        the name of the scripting variable

      • getClassName

        public String getClassName()
        Returns the type of this variable.
        Returns:
        the type of this variable

      • getDeclare

        public boolean getDeclare()
        Returns whether this is a new variable. If so, in some languages this will require a declaration.
        Returns:
        whether this is a new variable.

      • getScope

        public int getScope()
        Returns the lexical scope of the variable.
        Returns:
        the lexical scope of the variable, either AT_BEGIN, AT_END, or NESTED.
        See Also:
        AT_BEGIN, AT_END, NESTED
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.servlet.jsp.tagext.BodyContent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.BodyContent

  • Packages that use BodyContent
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp
    Classes and interfaces for the Core JSP 2.3 API.
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of BodyContent in javax.faces.webapp

      Fields in javax.faces.webapp declared as BodyContent
      Modifier and Type Field and Description
      protected BodyContent UIComponentClassicTagBase.bodyContent
      The bodyContent for this tag handler.
      Methods in javax.faces.webapp that return BodyContent
      Modifier and Type | Method and Description
      BodyContent | UIComponentClassicTagBase.getBodyContent()
      Methods in javax.faces.webapp with parameters of type BodyContent
      Modifier and Type Method and Description
      void UIComponentClassicTagBase.setBodyContent(BodyContent bodyContent)
      Set the bodyContent for this tag handler.

    • Uses of BodyContent in javax.servlet.jsp

      Methods in javax.servlet.jsp that return BodyContent
      Modifier and Type Method and Description
      BodyContent PageContext.pushBody()
      Return a new BodyContent object, save the current "out" JspWriter, and update the value of the "out" attribute in the page scope attribute namespace of the PageContext.

    • Uses of BodyContent in javax.servlet.jsp.tagext

      Fields in javax.servlet.jsp.tagext declared as BodyContent
      Modifier and Type Field and Description
      protected BodyContent BodyTagSupport.bodyContent
      The current BodyContent for this BodyTag.
      Methods in javax.servlet.jsp.tagext that return BodyContent
      Modifier and Type Method and Description
      BodyContent BodyTagSupport.getBodyContent()
      Get current bodyContent.
      Methods in javax.servlet.jsp.tagext with parameters of type BodyContent
      Modifier and Type Method and Description
      void BodyTagSupport.setBodyContent(BodyContent b)
      Prepare for evaluation of the body: stash the bodyContent away.
      void BodyTag.setBodyContent(BodyContent b)
      Set the bodyContent property.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.BodyTagSupport (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.BodyTagSupport

No usage of javax.servlet.jsp.tagext.BodyTagSupport
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.FunctionInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.FunctionInfo

  • Packages that use FunctionInfo
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of FunctionInfo in javax.servlet.jsp.tagext

      Fields in javax.servlet.jsp.tagext declared as FunctionInfo
      Modifier and Type Field and Description
      protected FunctionInfo[] TagLibraryInfo.functions
      An array describing the functions that are defined in this tag library.
      Methods in javax.servlet.jsp.tagext that return FunctionInfo
      Modifier and Type Method and Description
      FunctionInfo TagLibraryInfo.getFunction(String name)
      Get the FunctionInfo for a given function name, looking through all the functions in this tag library.
      FunctionInfo[] TagLibraryInfo.getFunctions()
      An array describing the functions that are defined in this tag library.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.JspFragment (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.JspFragment

  • Packages that use JspFragment
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of JspFragment in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext that return JspFragment
      Modifier and Type Method and Description
      protected JspFragment SimpleTagSupport.getJspBody()
      Returns the body passed in by the container via setJspBody.
      Methods in javax.servlet.jsp.tagext with parameters of type JspFragment
      Modifier and Type Method and Description
      void SimpleTagSupport.setJspBody(JspFragment jspBody)
      Stores the provided JspFragment.
      void SimpleTag.setJspBody(JspFragment jspBody)
      Provides the body of this tag as a JspFragment object, able to be invoked zero or more times by the tag handler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.PageData (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.PageData

  • Packages that use PageData
    Package Description
    javax.servlet.jsp.jstl.tlv
    Reusable Tag Library Validator (TLV) classes provided by the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of PageData in javax.servlet.jsp.jstl.tlv

      Methods in javax.servlet.jsp.jstl.tlv with parameters of type PageData
      Modifier and Type | Method and Description
      ValidationMessage[] ScriptFreeTLV.validate(String prefix, String uri, PageData page)
      Validates a single JSP page.
      ValidationMessage[] | PermittedTaglibsTLV.validate(String prefix, String uri, PageData page)

    • Uses of PageData in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext with parameters of type PageData
      Modifier and Type Method and Description
      ValidationMessage[] TagLibraryValidator.validate(String prefix, String uri, PageData page)
      Validate a JSP page.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.SimpleTagSupport (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.SimpleTagSupport

No usage of javax.servlet.jsp.tagext.SimpleTagSupport
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.TagAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.TagAdapter

No usage of javax.servlet.jsp.tagext.TagAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.TagAttributeInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.TagAttributeInfo

  • Packages that use TagAttributeInfo
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of TagAttributeInfo in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext that return TagAttributeInfo
      Modifier and Type Method and Description
      TagAttributeInfo[] TagInfo.getAttributes()
      Attribute information (in the TLD) on this tag.
      static TagAttributeInfo TagAttributeInfo.getIdAttribute(TagAttributeInfo[] a)
      Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".
      Methods in javax.servlet.jsp.tagext with parameters of type TagAttributeInfo
      Modifier and Type Method and Description
      static TagAttributeInfo TagAttributeInfo.getIdAttribute(TagAttributeInfo[] a)
      Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".
      Constructors in javax.servlet.jsp.tagext with parameters of type TagAttributeInfo
      Constructor and Description
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo)
      Constructor for TagInfo from data in the JSP 1.1 format for TLD.
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi)
      Constructor for TagInfo from data in the JSP 1.2 format for TLD.
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi, boolean dynamicAttributes)
      Constructor for TagInfo from data in the JSP 2.0 format for TLD.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.TagData (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.TagData

  • Packages that use TagData
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of TagData in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext with parameters of type TagData
      Modifier and Type Method and Description
      VariableInfo[] TagInfo.getVariableInfo(TagData data)
      Information on the scripting objects created by this tag at runtime.
      VariableInfo[] TagExtraInfo.getVariableInfo(TagData data)
      information on scripting variables defined by the tag associated with this TagExtraInfo instance.
      boolean TagInfo.isValid(TagData data)
      Translation-time validation of the attributes.
      boolean TagExtraInfo.isValid(TagData data)
      Translation-time validation of the attributes.
      ValidationMessage[] TagInfo.validate(TagData data)
      Translation-time validation of the attributes.
      ValidationMessage[] TagExtraInfo.validate(TagData data)
      Translation-time validation of the attributes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.TagExtraInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.TagExtraInfo

  • Packages that use TagExtraInfo
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of TagExtraInfo in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext that return TagExtraInfo
      Modifier and Type Method and Description
      TagExtraInfo TagInfo.getTagExtraInfo()
      The instance (if any) for extra tag information.
      Methods in javax.servlet.jsp.tagext with parameters of type TagExtraInfo
      Modifier and Type Method and Description
      void TagInfo.setTagExtraInfo(TagExtraInfo tei)
      Set the instance for extra tag information.
      Constructors in javax.servlet.jsp.tagext with parameters of type TagExtraInfo
      Constructor and Description
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo)
      Constructor for TagInfo from data in the JSP 1.1 format for TLD.
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi)
      Constructor for TagInfo from data in the JSP 1.2 format for TLD.
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi, boolean dynamicAttributes)
      Constructor for TagInfo from data in the JSP 2.0 format for TLD.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.TagFileInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.TagFileInfo

  • Packages that use TagFileInfo
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of TagFileInfo in javax.servlet.jsp.tagext

      Fields in javax.servlet.jsp.tagext declared as TagFileInfo
      Modifier and Type Field and Description
      protected TagFileInfo[] TagLibraryInfo.tagFiles
      An array describing the tag files that are defined in this tag library.
      Methods in javax.servlet.jsp.tagext that return TagFileInfo
      Modifier and Type Method and Description
      TagFileInfo TagLibraryInfo.getTagFile(String shortname)
      Get the TagFileInfo for a given tag name, looking through all the tag files in this tag library.
      TagFileInfo[] TagLibraryInfo.getTagFiles()
      An array describing the tag files that are defined in this tag library.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.TagInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.TagInfo

  • Packages that use TagInfo
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of TagInfo in javax.servlet.jsp.tagext

      Fields in javax.servlet.jsp.tagext declared as TagInfo
      Modifier and Type Field and Description
      protected TagInfo[] TagLibraryInfo.tags
      An array describing the tags that are defined in this tag library.
      Methods in javax.servlet.jsp.tagext that return TagInfo
      Modifier and Type Method and Description
      TagInfo TagLibraryInfo.getTag(String shortname)
      Get the TagInfo for a given tag name, looking through all the tags in this tag library.
      TagInfo TagFileInfo.getTagInfo()
      Returns information about this tag, parsed from the directives in the tag file.
      TagInfo TagExtraInfo.getTagInfo()
      Get the TagInfo for this class.
      TagInfo[] TagLibraryInfo.getTags()
      An array describing the tags that are defined in this tag library.
      Methods in javax.servlet.jsp.tagext with parameters of type TagInfo
      Modifier and Type Method and Description
      void TagExtraInfo.setTagInfo(TagInfo tagInfo)
      Set the TagInfo for this class.
      Constructors in javax.servlet.jsp.tagext with parameters of type TagInfo
      Constructor and Description
      TagFileInfo(String name, String path, TagInfo tagInfo)
      Constructor for TagFileInfo from data in the JSP 2.0 format for TLD.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.TagLibraryInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.TagLibraryInfo

  • Packages that use TagLibraryInfo
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of TagLibraryInfo in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext that return TagLibraryInfo
      Modifier and Type Method and Description
      TagLibraryInfo TagInfo.getTagLibrary()
      The instance of TabLibraryInfo we belong to.
      abstract TagLibraryInfo[] TagLibraryInfo.getTagLibraryInfos()
      Returns an array of TagLibraryInfo objects representing the entire set of tag libraries (including this TagLibraryInfo) imported by taglib directives in the translation unit that references this TagLibraryInfo.
      Methods in javax.servlet.jsp.tagext with parameters of type TagLibraryInfo
      Modifier and Type Method and Description
      void TagInfo.setTagLibrary(TagLibraryInfo tl)
      Set the TagLibraryInfo property.
      Constructors in javax.servlet.jsp.tagext with parameters of type TagLibraryInfo
      Constructor and Description
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo)
      Constructor for TagInfo from data in the JSP 1.1 format for TLD.
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi)
      Constructor for TagInfo from data in the JSP 1.2 format for TLD.
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi, boolean dynamicAttributes)
      Constructor for TagInfo from data in the JSP 2.0 format for TLD.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.TagLibraryValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.TagLibraryValidator

  • Packages that use TagLibraryValidator
    Package Description
    javax.servlet.jsp.jstl.tlv
    Reusable Tag Library Validator (TLV) classes provided by the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of TagLibraryValidator in javax.servlet.jsp.jstl.tlv

      Subclasses of TagLibraryValidator in javax.servlet.jsp.jstl.tlv
      Modifier and Type Class and Description
      class  PermittedTaglibsTLV
      A TagLibraryValidator class to allow a TLD to restrict what taglibs (in addition to itself) may be imported on a page where it's used.
      class  ScriptFreeTLV
      A TagLibraryValidator for enforcing restrictions against the use of JSP scripting elements.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.TagSupport (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.TagSupport

  • Packages that use TagSupport
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of TagSupport in javax.faces.webapp

      Subclasses of TagSupport in javax.faces.webapp
      Modifier and Type Class and Description
      class  AttributeTag
      Deprecated.
      The Faces implementation must now provide the implementation for this class.
      class  ConverterELTag
      ConverterELTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentClassicTagBase.
      class  ConverterTag
      Deprecated.
      This has been partially replaced by ConverterELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ConverterTag.createConverter() method, is now an implementation detail.
      class  FacetTag
      FacetTag is the JSP mechanism for denoting a UIComponent is to be added as a facet to the component associated with its parent.
      class  ValidatorELTag
      ValidatorELTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag.
      class  ValidatorTag
      Deprecated.
      This has been partially replaced by ValidatorELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ValidatorTag.createValidator() method, is now an implementation detail.

    • Uses of TagSupport in javax.servlet.jsp.jstl.core

      Subclasses of TagSupport in javax.servlet.jsp.jstl.core
      Modifier and Type Class and Description
      class  ConditionalTagSupport
      Abstract class that facilitates implementation of conditional actions where the boolean result is exposed as a JSP scoped variable.
      class  LoopTagSupport
      Base support class to facilitate implementation of iteration tags.

    • Uses of TagSupport in javax.servlet.jsp.tagext

      Subclasses of TagSupport in javax.servlet.jsp.tagext
      Modifier and Type Class and Description
      class  BodyTagSupport
      A base class for defining tag handlers implementing BodyTag.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.TagVariableInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.TagVariableInfo

  • Packages that use TagVariableInfo
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of TagVariableInfo in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext that return TagVariableInfo
      Modifier and Type Method and Description
      TagVariableInfo[] TagInfo.getTagVariableInfos()
      Get TagVariableInfo objects associated with this TagInfo.
      Constructors in javax.servlet.jsp.tagext with parameters of type TagVariableInfo
      Constructor and Description
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi)
      Constructor for TagInfo from data in the JSP 1.2 format for TLD.
      TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi, boolean dynamicAttributes)
      Constructor for TagInfo from data in the JSP 2.0 format for TLD.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.ValidationMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.ValidationMessage

  • Packages that use ValidationMessage
    Package Description
    javax.servlet.jsp.jstl.tlv
    Reusable Tag Library Validator (TLV) classes provided by the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of ValidationMessage in javax.servlet.jsp.jstl.tlv

      Methods in javax.servlet.jsp.jstl.tlv that return ValidationMessage
      Modifier and Type | Method and Description
      ValidationMessage[] ScriptFreeTLV.validate(String prefix, String uri, PageData page)
      Validates a single JSP page.
      ValidationMessage[] | PermittedTaglibsTLV.validate(String prefix, String uri, PageData page)

    • Uses of ValidationMessage in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext that return ValidationMessage
      Modifier and Type Method and Description
      ValidationMessage[] TagLibraryValidator.validate(String prefix, String uri, PageData page)
      Validate a JSP page.
      ValidationMessage[] TagInfo.validate(TagData data)
      Translation-time validation of the attributes.
      ValidationMessage[] TagExtraInfo.validate(TagData data)
      Translation-time validation of the attributes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.servlet.jsp.tagext.VariableInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.servlet.jsp.tagext.VariableInfo

  • Packages that use VariableInfo
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of VariableInfo in javax.servlet.jsp.tagext

      Methods in javax.servlet.jsp.tagext that return VariableInfo
      Modifier and Type Method and Description
      VariableInfo[] TagInfo.getVariableInfo(TagData data)
      Information on the scripting objects created by this tag at runtime.
      VariableInfo[] TagExtraInfo.getVariableInfo(TagData data)
      information on scripting variables defined by the tag associated with this TagExtraInfo instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.tagext.BodyTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.tagext.BodyTag

  • Packages that use BodyTag
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of BodyTag in javax.faces.webapp

      Classes in javax.faces.webapp that implement BodyTag
      Modifier and Type Class and Description
      class  UIComponentBodyTag
      Deprecated.
      All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.
      class  UIComponentClassicTagBase
      UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view.
      class  UIComponentELTag
      UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.
      class  UIComponentTag
      Deprecated.
      Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.

    • Uses of BodyTag in javax.servlet.jsp.tagext

      Classes in javax.servlet.jsp.tagext that implement BodyTag
      Modifier and Type Class and Description
      class  BodyTagSupport
      A base class for defining tag handlers implementing BodyTag.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.tagext.DynamicAttributes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.tagext.DynamicAttributes

No usage of javax.servlet.jsp.tagext.DynamicAttributes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.tagext.IterationTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.tagext.IterationTag

  • Packages that use IterationTag
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of IterationTag in javax.faces.webapp

      Classes in javax.faces.webapp that implement IterationTag
      Modifier and Type Class and Description
      class  AttributeTag
      Deprecated.
      The Faces implementation must now provide the implementation for this class.
      class  ConverterELTag
      ConverterELTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentClassicTagBase.
      class  ConverterTag
      Deprecated.
      This has been partially replaced by ConverterELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ConverterTag.createConverter() method, is now an implementation detail.
      class  FacetTag
      FacetTag is the JSP mechanism for denoting a UIComponent is to be added as a facet to the component associated with its parent.
      class  UIComponentBodyTag
      Deprecated.
      All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.
      class  UIComponentClassicTagBase
      UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view.
      class  UIComponentELTag
      UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.
      class  UIComponentTag
      Deprecated.
      Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
      class  ValidatorELTag
      ValidatorELTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag.
      class  ValidatorTag
      Deprecated.
      This has been partially replaced by ValidatorELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ValidatorTag.createValidator() method, is now an implementation detail.

    • Uses of IterationTag in javax.servlet.jsp.jstl.core

      Classes in javax.servlet.jsp.jstl.core that implement IterationTag
      Modifier and Type Class and Description
      class  ConditionalTagSupport
      Abstract class that facilitates implementation of conditional actions where the boolean result is exposed as a JSP scoped variable.
      class  LoopTagSupport
      Base support class to facilitate implementation of iteration tags.

    • Uses of IterationTag in javax.servlet.jsp.tagext

      Subinterfaces of IterationTag in javax.servlet.jsp.tagext
      Modifier and Type Interface and Description
      interface  BodyTag
      The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.
      Classes in javax.servlet.jsp.tagext that implement IterationTag
      Modifier and Type Class and Description
      class  BodyTagSupport
      A base class for defining tag handlers implementing BodyTag.
      class  TagSupport
      A base class for defining new tag handlers implementing Tag.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.tagext.JspIdConsumer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.tagext.JspIdConsumer

  • Packages that use JspIdConsumer
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

    • Uses of JspIdConsumer in javax.faces.webapp

      Classes in javax.faces.webapp that implement JspIdConsumer
      Modifier and Type Class and Description
      class  UIComponentBodyTag
      Deprecated.
      All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.
      class  UIComponentClassicTagBase
      UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view.
      class  UIComponentELTag
      UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.
      class  UIComponentTag
      Deprecated.
      Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.tagext.JspTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.tagext.JspTag

  • Packages that use JspTag
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of JspTag in javax.faces.webapp

      Classes in javax.faces.webapp that implement JspTag
      Modifier and Type Class and Description
      class  AttributeTag
      Deprecated.
      The Faces implementation must now provide the implementation for this class.
      class  ConverterELTag
      ConverterELTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentClassicTagBase.
      class  ConverterTag
      Deprecated.
      This has been partially replaced by ConverterELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ConverterTag.createConverter() method, is now an implementation detail.
      class  FacetTag
      FacetTag is the JSP mechanism for denoting a UIComponent is to be added as a facet to the component associated with its parent.
      class  UIComponentBodyTag
      Deprecated.
      All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.
      class  UIComponentClassicTagBase
      UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view.
      class  UIComponentELTag
      UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.
      class  UIComponentTag
      Deprecated.
      Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
      class  UIComponentTagBase
      UIComponentTagBase is the base class for all JSP tags that correspond to a UIComponent instance in the view.
      class  ValidatorELTag
      ValidatorELTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag.
      class  ValidatorTag
      Deprecated.
      This has been partially replaced by ValidatorELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ValidatorTag.createValidator() method, is now an implementation detail.

    • Uses of JspTag in javax.servlet.jsp.jstl.core

      Subinterfaces of JspTag in javax.servlet.jsp.jstl.core
      Modifier and Type Interface and Description
      interface  LoopTag
      JSTL allows developers to write custom iteration tags by implementing the LoopTag interface.
      Classes in javax.servlet.jsp.jstl.core that implement JspTag
      Modifier and Type Class and Description
      class  ConditionalTagSupport
      Abstract class that facilitates implementation of conditional actions where the boolean result is exposed as a JSP scoped variable.
      class  LoopTagSupport
      Base support class to facilitate implementation of iteration tags.

    • Uses of JspTag in javax.servlet.jsp.tagext

      Subinterfaces of JspTag in javax.servlet.jsp.tagext
      Modifier and Type Interface and Description
      interface  BodyTag
      The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.
      interface  IterationTag
      The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.
      interface  SimpleTag
      Interface for defining Simple Tag Handlers.
      interface  Tag
      The interface of a classic tag handler that does not want to manipulate its body.
      Classes in javax.servlet.jsp.tagext that implement JspTag
      Modifier and Type Class and Description
      class  BodyTagSupport
      A base class for defining tag handlers implementing BodyTag.
      class  SimpleTagSupport
      A base class for defining tag handlers implementing SimpleTag.
      class  TagAdapter
      Wraps any SimpleTag and exposes it using a Tag interface.
      class  TagSupport
      A base class for defining new tag handlers implementing Tag.
      Methods in javax.servlet.jsp.tagext that return JspTag
      Modifier and Type Method and Description
      static JspTag SimpleTagSupport.findAncestorWithClass(JspTag from, Class<?> klass)
      Find the instance of a given class type that is closest to a given instance.
      JspTag TagAdapter.getAdaptee()
      Gets the tag that is being adapted to the Tag interface.
      JspTag SimpleTagSupport.getParent()
      Returns the parent of this tag, for collaboration purposes.
      JspTag SimpleTag.getParent()
      Returns the parent of this tag, for collaboration purposes.
      Methods in javax.servlet.jsp.tagext with parameters of type JspTag
      Modifier and Type Method and Description
      static JspTag SimpleTagSupport.findAncestorWithClass(JspTag from, Class<?> klass)
      Find the instance of a given class type that is closest to a given instance.
      void SimpleTagSupport.setParent(JspTag parent)
      Sets the parent of this tag, for collaboration purposes.
      void SimpleTag.setParent(JspTag parent)
      Sets the parent of this tag, for collaboration purposes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.tagext.SimpleTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.tagext.SimpleTag

  • Packages that use SimpleTag
    Package Description
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of SimpleTag in javax.servlet.jsp.tagext

      Classes in javax.servlet.jsp.tagext that implement SimpleTag
      Modifier and Type Class and Description
      class  SimpleTagSupport
      A base class for defining tag handlers implementing SimpleTag.
      Constructors in javax.servlet.jsp.tagext with parameters of type SimpleTag
      Constructor and Description
      TagAdapter(SimpleTag adaptee)
      Creates a new TagAdapter that wraps the given SimpleTag and returns the parent tag when getParent() is called.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.tagext.Tag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.tagext.Tag

  • Packages that use Tag
    Package Description
    javax.faces.webapp
    Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
    javax.servlet.jsp.tagext
    Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

    • Uses of Tag in javax.faces.webapp

      Classes in javax.faces.webapp that implement Tag
      Modifier and Type Class and Description
      class  AttributeTag
      Deprecated.
      The Faces implementation must now provide the implementation for this class.
      class  ConverterELTag
      ConverterELTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentClassicTagBase.
      class  ConverterTag
      Deprecated.
      This has been partially replaced by ConverterELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ConverterTag.createConverter() method, is now an implementation detail.
      class  FacetTag
      FacetTag is the JSP mechanism for denoting a UIComponent is to be added as a facet to the component associated with its parent.
      class  UIComponentBodyTag
      Deprecated.
      All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.
      class  UIComponentClassicTagBase
      UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view.
      class  UIComponentELTag
      UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.
      class  UIComponentTag
      Deprecated.
      Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
      class  ValidatorELTag
      ValidatorELTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag.
      class  ValidatorTag
      Deprecated.
      This has been partially replaced by ValidatorELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ValidatorTag.createValidator() method, is now an implementation detail.
      Methods in javax.faces.webapp that return Tag
      Modifier and Type Method and Description
      Tag UIComponentClassicTagBase.getParent()
      Return the Tag that is the parent of this instance.
      Methods in javax.faces.webapp with parameters of type Tag
      Modifier and Type Method and Description
      void UIComponentClassicTagBase.setParent(Tag parent)
      Set the Tag that is the parent of this instance.

    • Uses of Tag in javax.servlet.jsp.jstl.core

      Subinterfaces of Tag in javax.servlet.jsp.jstl.core
      Modifier and Type Interface and Description
      interface  LoopTag
      JSTL allows developers to write custom iteration tags by implementing the LoopTag interface.
      Classes in javax.servlet.jsp.jstl.core that implement Tag
      Modifier and Type Class and Description
      class  ConditionalTagSupport
      Abstract class that facilitates implementation of conditional actions where the boolean result is exposed as a JSP scoped variable.
      class  LoopTagSupport
      Base support class to facilitate implementation of iteration tags.

    • Uses of Tag in javax.servlet.jsp.tagext

      Subinterfaces of Tag in javax.servlet.jsp.tagext
      Modifier and Type Interface and Description
      interface  BodyTag
      The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.
      interface  IterationTag
      The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.
      Classes in javax.servlet.jsp.tagext that implement Tag
      Modifier and Type Class and Description
      class  BodyTagSupport
      A base class for defining tag handlers implementing BodyTag.
      class  TagAdapter
      Wraps any SimpleTag and exposes it using a Tag interface.
      class  TagSupport
      A base class for defining new tag handlers implementing Tag.
      Methods in javax.servlet.jsp.tagext that return Tag
      Modifier and Type Method and Description
      static Tag TagSupport.findAncestorWithClass(Tag from, Class klass)
      Find the instance of a given class type that is closest to a given instance.
      Tag TagSupport.getParent()
      The Tag instance most closely enclosing this tag instance.
      Tag TagAdapter.getParent()
      Returns the parent of this tag, which is always getAdaptee().getParent().
      Tag Tag.getParent()
      Get the parent (closest enclosing tag handler) for this tag handler.
      Methods in javax.servlet.jsp.tagext with parameters of type Tag
      Modifier and Type Method and Description
      static Tag TagSupport.findAncestorWithClass(Tag from, Class klass)
      Find the instance of a given class type that is closest to a given instance.
      void TagSupport.setParent(Tag t)
      Set the nesting tag of this tag.
      void TagAdapter.setParent(Tag parentTag)
      Must not be called.
      void Tag.setParent(Tag t)
      Set the parent (closest enclosing tag handler) of this tag handler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.servlet.jsp.tagext.TryCatchFinally (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.servlet.jsp.tagext.TryCatchFinally

  • Packages that use TryCatchFinally
    Package Description
    javax.servlet.jsp.jstl.core
    Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

    • Uses of TryCatchFinally in javax.servlet.jsp.jstl.core

      Classes in javax.servlet.jsp.jstl.core that implement TryCatchFinally
      Modifier and Type Class and Description
      class  LoopTagSupport
      Base support class to facilitate implementation of iteration tags.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


HeuristicCommitException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Class HeuristicCommitException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.transaction.HeuristicCommitException
  • All Implemented Interfaces:
    Serializable

    public class HeuristicCommitException
extends Exception
    This exception is thrown by the rollback operation on a resource to report that a heuristic decision was made and that all relevant updates have been committed.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      HeuristicCommitException()
      HeuristicCommitException(String msg)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • HeuristicCommitException

        public HeuristicCommitException()

      • HeuristicCommitException

        public HeuristicCommitException(String msg)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HeuristicMixedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Class HeuristicMixedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.transaction.HeuristicMixedException
  • All Implemented Interfaces:
    Serializable

    public class HeuristicMixedException
extends Exception
    This exception is thrown to report that a heuristic decision was made and that some relevant updates have been committed and others have been rolled back.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      HeuristicMixedException()
      HeuristicMixedException(String msg)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • HeuristicMixedException

        public HeuristicMixedException()

      • HeuristicMixedException

        public HeuristicMixedException(String msg)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HeuristicRollbackException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Class HeuristicRollbackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.transaction.HeuristicRollbackException
  • All Implemented Interfaces:
    Serializable

    public class HeuristicRollbackException
extends Exception
    This exception is thrown by the commit operation to report that a heuristic decision was made and that all relevant updates have been rolled back.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      HeuristicRollbackException()
      HeuristicRollbackException(String msg)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • HeuristicRollbackException

        public HeuristicRollbackException()

      • HeuristicRollbackException

        public HeuristicRollbackException(String msg)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidTransactionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Class InvalidTransactionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.InvalidTransactionException
  • All Implemented Interfaces:
    Serializable

    public class InvalidTransactionException
extends RemoteException
    This exception indicates that the request carried an invalid transaction context. For example, this exception could be raised if an error occurred when trying to register a resource.
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidTransactionException()
      InvalidTransactionException(String msg)

    • Method Summary

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidTransactionException

        public InvalidTransactionException()

      • InvalidTransactionException

        public InvalidTransactionException(String msg)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.transaction (Java(TM) EE 7 Specification APIs)

javax.transaction

Interfaces

  • Status
  • Synchronization
  • Transaction
  • TransactionManager
  • TransactionSynchronizationRegistry
  • UserTransaction

Enums

  • Transactional.TxType

Exceptions

  • HeuristicCommitException
  • HeuristicMixedException
  • HeuristicRollbackException
  • InvalidTransactionException
  • NotSupportedException
  • RollbackException
  • SystemException
  • TransactionalException
  • TransactionRequiredException
  • TransactionRolledbackException

Annotation Types

  • Transactional
  • TransactionScoped


javax.transaction (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.transaction

Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

See: Description

  • Interface Summary
    Interface Description
    Status
    The Status interface defines static variables used for transaction status codes.
    Synchronization
    The transaction manager supports a synchronization mechanism that allows the interested party to be notified before and after the transaction completes.
    Transaction
    The Transaction interface allows operations to be performed against the transaction in the target Transaction object.
    TransactionManager
    The TransactionManager interface defines the methods that allow an application server to manage transaction boundaries.
    TransactionSynchronizationRegistry
    This interface is intended for use by system level application server components such as persistence managers, resource adapters, as well as EJB and Web application components.
    UserTransaction
    The UserTransaction interface defines the methods that allow an application to explicitly manage transaction boundaries.
  • Enum Summary
    Enum Description
    Transactional.TxType
    The TxType element of the annotation indicates whether a bean method is to be executed within a transaction context where the values provide the following corresponding behavior.
  • Exception Summary
    Exception Description
    HeuristicCommitException
    This exception is thrown by the rollback operation on a resource to report that a heuristic decision was made and that all relevant updates have been committed.
    HeuristicMixedException
    This exception is thrown to report that a heuristic decision was made and that some relevant updates have been committed and others have been rolled back.
    HeuristicRollbackException
    This exception is thrown by the commit operation to report that a heuristic decision was made and that all relevant updates have been rolled back.
    InvalidTransactionException
    This exception indicates that the request carried an invalid transaction context.
    NotSupportedException
    NotSupportedException exception indicates that the request cannot be executed because the operation is not a supported feature.
    RollbackException
    RollbackException exception is thrown when the transaction has been marked for rollback only or the transaction has been rolled back instead of committed.
    SystemException
    The SystemException is thrown by the transaction manager to indicate that it has encountered an unexpected error condition that prevents future transaction services from proceeding.
    TransactionalException
    The TransactionalException thrown from the Transactional interceptors implementation contains the original exception as its nested exception and is a RuntimeException, therefore, by default any transaction that was started as a result of a Transactional annotation earlier in the call stream will be marked for rollback as a result of the TransactionalException being thrown by the Transactional interceptor of the second bean.
    TransactionRequiredException
    This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.
    TransactionRolledbackException
    This exception indicates that the transaction associated with processing of the request has been rolled back, or it has been marked to roll back.
  • Annotation Types Summary
    Annotation Type Description
    Transactional
    The javax.transaction.Transactional annotation provides the application the ability to declaratively control transaction boundaries on CDI managed beans, as well as classes defined as managed beans by the Java EE specification, at both the class and method level where method level annotations override those at the class level.
    TransactionScoped
    The javax.transaction.TransactionScoped annotation provides the ability to specify a standard CDI scope to define bean instances whose lifecycle is scoped to the currently active JTA transaction.

Package javax.transaction Description

Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server. The implementation of this API is provided by the application server vendor and the resource manager driver vendor.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.transaction Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.transaction

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.transaction.HeuristicCommitException
        • javax.transaction.HeuristicMixedException
        • javax.transaction.HeuristicRollbackException
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.InvalidTransactionException
            • javax.transaction.TransactionRequiredException
            • javax.transaction.TransactionRolledbackException
        • javax.transaction.NotSupportedException
        • javax.transaction.RollbackException
        • java.lang.RuntimeException
          • javax.transaction.TransactionalException
        • javax.transaction.SystemException

Interface Hierarchy

  • javax.transaction.Status
  • javax.transaction.Synchronization
  • javax.transaction.Transaction
  • javax.transaction.TransactionManager
  • javax.transaction.TransactionSynchronizationRegistry
  • javax.transaction.UserTransaction

Annotation Type Hierarchy

  • javax.transaction.TransactionScoped (implements java.lang.annotation.Annotation)
  • javax.transaction.Transactional (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.transaction.Transactional.TxType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


NotSupportedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Class NotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.transaction.NotSupportedException
  • All Implemented Interfaces:
    Serializable

    public class NotSupportedException
extends Exception
    NotSupportedException exception indicates that the request cannot be executed because the operation is not a supported feature. For example, because nested transactions are not supported, the Transaction Manager throws this exception when a calling thread that is already associated with a transaction attempts to start a new transaction. (A nested transaction occurs when a thread is already associated with one transaction and attempts to start a second transaction.)
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NotSupportedException()
      NotSupportedException(String msg)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NotSupportedException

        public NotSupportedException()

      • NotSupportedException

        public NotSupportedException(String msg)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RollbackException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Class RollbackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.transaction.RollbackException
  • All Implemented Interfaces:
    Serializable

    public class RollbackException
extends Exception
    RollbackException exception is thrown when the transaction has been marked for rollback only or the transaction has been rolled back instead of committed. This is a local exception thrown by methods in the UserTransaction, Transaction, and TransactionManager interfaces.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      RollbackException()
      RollbackException(String msg)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • RollbackException

        public RollbackException()

      • RollbackException

        public RollbackException(String msg)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Status (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Interface Status

  • public interface Status
    The Status interface defines static variables used for transaction status codes.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int STATUS_ACTIVE
      A transaction is associated with the target object and it is in the active state.
      static int STATUS_COMMITTED
      A transaction is associated with the target object and it has been committed.
      static int STATUS_COMMITTING
      A transaction is associated with the target object and it is in the process of committing.
      static int STATUS_MARKED_ROLLBACK
      A transaction is associated with the target object and it has been marked for rollback, perhaps as a result of a setRollbackOnly operation.
      static int STATUS_NO_TRANSACTION
      No transaction is currently associated with the target object.
      static int STATUS_PREPARED
      A transaction is associated with the target object and it has been prepared.
      static int STATUS_PREPARING
      A transaction is associated with the target object and it is in the process of preparing.
      static int STATUS_ROLLEDBACK
      A transaction is associated with the target object and the outcome has been determined to be rollback.
      static int STATUS_ROLLING_BACK
      A transaction is associated with the target object and it is in the process of rolling back.
      static int STATUS_UNKNOWN
      A transaction is associated with the target object but its current status cannot be determined.

    • Field Detail

      • STATUS_ACTIVE

        static final int STATUS_ACTIVE
        A transaction is associated with the target object and it is in the active state. An implementation returns this status after a transaction has been started and prior to a Coordinator issuing any prepares, unless the transaction has been marked for rollback.
        See Also:
        Constant Field Values

      • STATUS_MARKED_ROLLBACK

        static final int STATUS_MARKED_ROLLBACK
        A transaction is associated with the target object and it has been marked for rollback, perhaps as a result of a setRollbackOnly operation.
        See Also:
        Constant Field Values

      • STATUS_PREPARED

        static final int STATUS_PREPARED
        A transaction is associated with the target object and it has been prepared. That is, all subordinates have agreed to commit. The target object may be waiting for instructions from a superior as to how to proceed.
        See Also:
        Constant Field Values

      • STATUS_COMMITTED

        static final int STATUS_COMMITTED
        A transaction is associated with the target object and it has been committed. It is likely that heuristics exist; otherwise, the transaction would have been destroyed and NoTransaction returned.
        See Also:
        Constant Field Values

      • STATUS_ROLLEDBACK

        static final int STATUS_ROLLEDBACK
        A transaction is associated with the target object and the outcome has been determined to be rollback. It is likely that heuristics exist; otherwise, the transaction would have been destroyed and NoTransaction returned.
        See Also:
        Constant Field Values

      • STATUS_UNKNOWN

        static final int STATUS_UNKNOWN
        A transaction is associated with the target object but its current status cannot be determined. This is a transient condition and a subsequent invocation will ultimately return a different status.
        See Also:
        Constant Field Values

      • STATUS_NO_TRANSACTION

        static final int STATUS_NO_TRANSACTION
        No transaction is currently associated with the target object. This will occur after a transaction has completed.
        See Also:
        Constant Field Values

      • STATUS_PREPARING

        static final int STATUS_PREPARING
        A transaction is associated with the target object and it is in the process of preparing. An implementation returns this status if it has started preparing, but has not yet completed the process. The likely reason for this is that the implementation is probably waiting for responses to prepare from one or more Resources.
        See Also:
        Constant Field Values

      • STATUS_COMMITTING

        static final int STATUS_COMMITTING
        A transaction is associated with the target object and it is in the process of committing. An implementation returns this status if it has decided to commit but has not yet completed the committing process. This occurs because the implementation is probably waiting for responses from one or more Resources.
        See Also:
        Constant Field Values

      • STATUS_ROLLING_BACK

        static final int STATUS_ROLLING_BACK
        A transaction is associated with the target object and it is in the process of rolling back. An implementation returns this status if it has decided to rollback but has not yet completed the process. The implementation is probably waiting for responses from one or more Resources.
        See Also:
        Constant Field Values
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Synchronization (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Interface Synchronization

  • public interface Synchronization
    The transaction manager supports a synchronization mechanism that allows the interested party to be notified before and after the transaction completes. Using the registerSynchronization method, the application server registers a Synchronization object for the transaction currently associated with the target Transaction object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterCompletion(int status)
      This method is called by the transaction manager after the transaction is committed or rolled back.
      void beforeCompletion()
      The beforeCompletion method is called by the transaction manager prior to the start of the two-phase transaction commit process.

    • Method Detail

      • beforeCompletion

        void beforeCompletion()
        The beforeCompletion method is called by the transaction manager prior to the start of the two-phase transaction commit process. This call is executed with the transaction context of the transaction that is being committed.

      • afterCompletion

        void afterCompletion(int status)
        This method is called by the transaction manager after the transaction is committed or rolled back.
        Parameters:
        status - The status of the transaction completion.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SystemException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Class SystemException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.transaction.SystemException
  • All Implemented Interfaces:
    Serializable

    public class SystemException
extends Exception
    The SystemException is thrown by the transaction manager to indicate that it has encountered an unexpected error condition that prevents future transaction services from proceeding.
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      int errorCode
      The error code with which to create the SystemException.

    • Constructor Summary

      Constructors
      Constructor and Description
      SystemException()
      SystemException(int errcode)
      Create a SystemException with a given error code.
      SystemException(String s)
      Create a SystemException with a given string.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • errorCode

        public int errorCode
        The error code with which to create the SystemException.

    • Constructor Detail

      • SystemException

        public SystemException()

      • SystemException

        public SystemException(String s)
        Create a SystemException with a given string.
        Parameters:
        s - The string message for the exception

      • SystemException

        public SystemException(int errcode)
        Create a SystemException with a given error code.
        Parameters:
        errcode - The error code for the exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Transaction (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Interface Transaction

  • public interface Transaction
    The Transaction interface allows operations to be performed against the transaction in the target Transaction object. A Transaction object is created corresponding to each global transaction creation. The Transaction object can be used for resource enlistment, synchronization registration, transaction completion, and status query operations.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void commit()
      Complete the transaction represented by this Transaction object.
      boolean delistResource(XAResource xaRes, int flag)
      Disassociate the resource specified from the transaction associated with the target Transaction object.
      boolean enlistResource(XAResource xaRes)
      Enlist the resource specified with the transaction associated with the target Transaction object.
      int getStatus()
      Obtain the status of the transaction associated with the target Transaction object.
      void registerSynchronization(Synchronization sync)
      Register a synchronization object for the transaction currently associated with the target object.
      void rollback()
      Rollback the transaction represented by this Transaction object.
      void setRollbackOnly()
      Modify the transaction associated with the target object such that the only possible outcome of the transaction is to roll back the transaction.

    • Method Detail

      • commit

        void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
        Complete the transaction represented by this Transaction object.
        Throws:
        RollbackException - Thrown to indicate that the transaction has been rolled back rather than committed.
        HeuristicMixedException - Thrown to indicate that a heuristic decision was made and that some relevant updates have been committed while others have been rolled back.
        HeuristicRollbackException - Thrown to indicate that a heuristic decision was made and that all relevant updates have been rolled back.
        SecurityException - Thrown to indicate that the thread is not allowed to commit the transaction.
        IllegalStateException - Thrown if the transaction in the target object is inactive.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • delistResource

        boolean delistResource(XAResource xaRes,
                     int flag)
                       throws IllegalStateException,
                              SystemException
        Disassociate the resource specified from the transaction associated with the target Transaction object.
        Parameters:
        xaRes - The XAResource object associated with the resource (connection).
        flag - One of the values of TMSUCCESS, TMSUSPEND, or TMFAIL.
        Returns:
        true if the resource was delisted successfully; otherwise false.
        Throws:
        IllegalStateException - Thrown if the transaction in the target object is inactive.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • enlistResource

        boolean enlistResource(XAResource xaRes)
                       throws RollbackException,
                              IllegalStateException,
                              SystemException
        Enlist the resource specified with the transaction associated with the target Transaction object.
        Parameters:
        xaRes - The XAResource object associated with the resource (connection).
        Returns:
        true if the resource was enlisted successfully; otherwise false.
        Throws:
        RollbackException - Thrown to indicate that the transaction has been marked for rollback only.
        IllegalStateException - Thrown if the transaction in the target object is in the prepared state or the transaction is inactive.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • getStatus

        int getStatus()
              throws SystemException
        Obtain the status of the transaction associated with the target Transaction object.
        Returns:
        The transaction status. If no transaction is associated with the target object, this method returns the Status.NoTransaction value.
        Throws:
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • registerSynchronization

        void registerSynchronization(Synchronization sync)
                             throws RollbackException,
                                    IllegalStateException,
                                    SystemException
        Register a synchronization object for the transaction currently associated with the target object. The transction manager invokes the beforeCompletion method prior to starting the two-phase transaction commit process. After the transaction is completed, the transaction manager invokes the afterCompletion method.
        Parameters:
        sync - The Synchronization object for the transaction associated with the target object.
        Throws:
        RollbackException - Thrown to indicate that the transaction has been marked for rollback only.
        IllegalStateException - Thrown if the transaction in the target object is in the prepared state or the transaction is inactive.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • rollback

        void rollback()
              throws IllegalStateException,
                     SystemException
        Rollback the transaction represented by this Transaction object.
        Throws:
        IllegalStateException - Thrown if the transaction in the target object is in the prepared state or the transaction is inactive.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • setRollbackOnly

        void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
        Modify the transaction associated with the target object such that the only possible outcome of the transaction is to roll back the transaction.
        Throws:
        IllegalStateException - Thrown if the target object is not associated with any transaction.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Transactional (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.transaction

Annotation Type Transactional

  • @Inherited
@InterceptorBinding
@Target(value={TYPE,METHOD})
@Retention(value=RUNTIME)
public @interface Transactional

    The javax.transaction.Transactional annotation provides the application the ability to declaratively control transaction boundaries on CDI managed beans, as well as classes defined as managed beans by the Java EE specification, at both the class and method level where method level annotations override those at the class level.

    See the EJB specification for restrictions on the use of @Transactional with EJBs.

    This support is provided via an implementation of CDI interceptors that conduct the necessary suspending, resuming, etc. The Transactional interceptor interposes on business method invocations only and not on lifecycle events. Lifecycle methods are invoked in an unspecified transaction context.

    If an attempt is made to call any method of the UserTransaction interface from within the scope of a bean or method annotated with @Transactional and a Transactional.TxType other than NOT_SUPPORTED or NEVER, an IllegalStateException must be thrown. The use of the UserTransaction is allowed within life cycle events. The use of the TransactionSynchronizationRegistry is allowed regardless of any @Transactional annotation.

    The Transactional interceptors must have a priority of Interceptor.Priority.PLATFORM_BEFORE+200. Refer to the Interceptors specification for more details.

    The TxType element of the annotation indicates whether a bean method is to be executed within a transaction context. TxType.REQUIRED is the default.

    By default checked exceptions do not result in the transactional interceptor marking the transaction for rollback and instances of RuntimeException and its subclasses do. This default behavior can be modified by specifying exceptions that result in the interceptor marking the transaction for rollback and/or exceptions that do not result in rollback.

    The rollbackOn element can be set to indicate exceptions that must cause the interceptor to mark the transaction for rollback.

    Conversely, the dontRollbackOn element can be set to indicate exceptions that must not cause the interceptor to mark the transaction for rollback.

    When a class is specified for either of these elements, the designated behavior applies to subclasses of that class as well. If both elements are specified, dontRollbackOn takes precedence.

    Since:
    JTA1.2

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class[] dontRollbackOn
      The dontRollbackOn element can be set to indicate exceptions that must not cause the interceptor to mark the transaction for rollback.
      Class[] rollbackOn
      The rollbackOn element can be set to indicate exceptions that must cause the interceptor to mark the transaction for rollback.
      Transactional.TxType value
      The TxType element of the Transactional annotation indicates whether a bean method is to be executed within a transaction context.

    • Element Detail

      • value

        public abstract Transactional.TxType value
        The TxType element of the Transactional annotation indicates whether a bean method is to be executed within a transaction context.
        Default:
        javax.transaction.Transactional.TxType.REQUIRED

      • rollbackOn

        public abstract Class[] rollbackOn
        The rollbackOn element can be set to indicate exceptions that must cause the interceptor to mark the transaction for rollback. Conversely, the dontRollbackOn element can be set to indicate exceptions that must not cause the interceptor to mark the transaction for rollback. When a class is specified for either of these elements, the designated behavior applies to subclasses of that class as well. If both elements are specified, dontRollbackOn takes precedence.
        Returns:
        Class[] of Exceptions
        Default:
        {}

      • dontRollbackOn

        public abstract Class[] dontRollbackOn
        The dontRollbackOn element can be set to indicate exceptions that must not cause the interceptor to mark the transaction for rollback. Conversely, the rollbackOn element can be set to indicate exceptions that must cause the interceptor to mark the transaction for rollback. When a class is specified for either of these elements, the designated behavior applies to subclasses of that class as well. If both elements are specified, dontRollbackOn takes precedence.
        Returns:
        Class[] of Exceptions
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Transactional.TxType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.transaction

Enum Transactional.TxType

  • java.lang.Object
    • java.lang.Enum<Transactional.TxType>
      • javax.transaction.Transactional.TxType
  • All Implemented Interfaces:
    Serializable, Comparable<Transactional.TxType>
    Enclosing class:
    Transactional

    public static enum Transactional.TxType
extends Enum<Transactional.TxType>
    The TxType element of the annotation indicates whether a bean method is to be executed within a transaction context where the values provide the following corresponding behavior.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      MANDATORY
      If called outside a transaction context, a TransactionalException with a nested TransactionRequiredException must be thrown.
      NEVER
      If called outside a transaction context, managed bean method execution must then continue outside a transaction context.
      NOT_SUPPORTED
      If called outside a transaction context, managed bean method execution must then continue outside a transaction context.
      REQUIRED
      If called outside a transaction context, the interceptor must begin a new JTA transaction, the managed bean method execution must then continue inside this transaction context, and the transaction must be completed by the interceptor.
      REQUIRES_NEW
      If called outside a transaction context, the interceptor must begin a new JTA transaction, the managed bean method execution must then continue inside this transaction context, and the transaction must be completed by the interceptor.
      SUPPORTS
      If called outside a transaction context, managed bean method execution must then continue outside a transaction context.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Transactional.TxType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Transactional.TxType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • REQUIRED

        public static final Transactional.TxType REQUIRED

        If called outside a transaction context, the interceptor must begin a new JTA transaction, the managed bean method execution must then continue inside this transaction context, and the transaction must be completed by the interceptor.

        If called inside a transaction context, the managed bean method execution must then continue inside this transaction context.

      • REQUIRES_NEW

        public static final Transactional.TxType REQUIRES_NEW

        If called outside a transaction context, the interceptor must begin a new JTA transaction, the managed bean method execution must then continue inside this transaction context, and the transaction must be completed by the interceptor.

        If called inside a transaction context, the current transaction context must be suspended, a new JTA transaction will begin, the managed bean method execution must then continue inside this transaction context, the transaction must be completed, and the previously suspended transaction must be resumed.

      • MANDATORY

        public static final Transactional.TxType MANDATORY

        If called outside a transaction context, a TransactionalException with a nested TransactionRequiredException must be thrown.

        If called inside a transaction context, managed bean method execution will then continue under that context.

      • SUPPORTS

        public static final Transactional.TxType SUPPORTS

        If called outside a transaction context, managed bean method execution must then continue outside a transaction context.

        If called inside a transaction context, the managed bean method execution must then continue inside this transaction context.

      • NOT_SUPPORTED

        public static final Transactional.TxType NOT_SUPPORTED

        If called outside a transaction context, managed bean method execution must then continue outside a transaction context.

        If called inside a transaction context, the current transaction context must be suspended, the managed bean method execution must then continue outside a transaction context, and the previously suspended transaction must be resumed by the interceptor that suspended it after the method execution has completed.

      • NEVER

        public static final Transactional.TxType NEVER

        If called outside a transaction context, managed bean method execution must then continue outside a transaction context.

        If called inside a transaction context, a TransactionalException with a nested InvalidTransactionException must be thrown.

    • Method Detail

      • values

        public static Transactional.TxType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Transactional.TxType c : Transactional.TxType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Transactional.TxType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


TransactionalException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Class TransactionalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.transaction.TransactionalException
  • All Implemented Interfaces:
    Serializable

    public class TransactionalException
extends RuntimeException
    The TransactionalException thrown from the Transactional interceptors implementation contains the original exception as its nested exception and is a RuntimeException, therefore, by default any transaction that was started as a result of a Transactional annotation earlier in the call stream will be marked for rollback as a result of the TransactionalException being thrown by the Transactional interceptor of the second bean. For example if a transaction is begun as a result of a call to a bean annotated with Transactional(TxType.REQUIRED) and this bean in turn calls a second bean annotated with Transactional(TxType.NEVER), the transaction begun by the first bean will be marked for rollback.
    Since:
    JTA1.2
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionalException(String s, Throwable throwable)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionalException

        public TransactionalException(String s,
                      Throwable throwable)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Interface TransactionManager

  • public interface TransactionManager
    The TransactionManager interface defines the methods that allow an application server to manage transaction boundaries.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void begin()
      Create a new transaction and associate it with the current thread.
      void commit()
      Complete the transaction associated with the current thread.
      int getStatus()
      Obtain the status of the transaction associated with the current thread.
      Transaction getTransaction()
      Get the transaction object that represents the transaction context of the calling thread.
      void resume(Transaction tobj)
      Resume the transaction context association of the calling thread with the transaction represented by the supplied Transaction object.
      void rollback()
      Roll back the transaction associated with the current thread.
      void setRollbackOnly()
      Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.
      void setTransactionTimeout(int seconds)
      Modify the timeout value that is associated with transactions started by the current thread with the begin method.
      Transaction suspend()
      Suspend the transaction currently associated with the calling thread and return a Transaction object that represents the transaction context being suspended.

    • Method Detail

      • begin

        void begin()
           throws NotSupportedException,
                  SystemException
        Create a new transaction and associate it with the current thread.
        Throws:
        NotSupportedException - Thrown if the thread is already associated with a transaction and the Transaction Manager implementation does not support nested transactions.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • commit

        void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
        Complete the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.
        Throws:
        RollbackException - Thrown to indicate that the transaction has been rolled back rather than committed.
        HeuristicMixedException - Thrown to indicate that a heuristic decision was made and that some relevant updates have been committed while others have been rolled back.
        HeuristicRollbackException - Thrown to indicate that a heuristic decision was made and that all relevant updates have been rolled back.
        SecurityException - Thrown to indicate that the thread is not allowed to commit the transaction.
        IllegalStateException - Thrown if the current thread is not associated with a transaction.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • getStatus

        int getStatus()
              throws SystemException
        Obtain the status of the transaction associated with the current thread.
        Returns:
        The transaction status. If no transaction is associated with the current thread, this method returns the Status.NoTransaction value.
        Throws:
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • getTransaction

        Transaction getTransaction()
                           throws SystemException
        Get the transaction object that represents the transaction context of the calling thread.
        Returns:
        the Transaction object representing the transaction associated with the calling thread.
        Throws:
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • resume

        void resume(Transaction tobj)
            throws InvalidTransactionException,
                   IllegalStateException,
                   SystemException
        Resume the transaction context association of the calling thread with the transaction represented by the supplied Transaction object. When this method returns, the calling thread is associated with the transaction context specified.
        Parameters:
        tobj - The Transaction object that represents the transaction to be resumed.
        Throws:
        InvalidTransactionException - Thrown if the parameter transaction object contains an invalid transaction.
        IllegalStateException - Thrown if the thread is already associated with another transaction.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • rollback

        void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
        Roll back the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.
        Throws:
        SecurityException - Thrown to indicate that the thread is not allowed to roll back the transaction.
        IllegalStateException - Thrown if the current thread is not associated with a transaction.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • setRollbackOnly

        void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
        Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.
        Throws:
        IllegalStateException - Thrown if the current thread is not associated with a transaction.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • setTransactionTimeout

        void setTransactionTimeout(int seconds)
                           throws SystemException
        Modify the timeout value that is associated with transactions started by the current thread with the begin method.

        If an application has not called this method, the transaction service uses some default value for the transaction timeout.

        Parameters:
        seconds - The value of the timeout in seconds. If the value is zero, the transaction service restores the default value. If the value is negative a SystemException is thrown.
        Throws:
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • suspend

        Transaction suspend()
                    throws SystemException
        Suspend the transaction currently associated with the calling thread and return a Transaction object that represents the transaction context being suspended. If the calling thread is not associated with a transaction, the method returns a null object reference. When this method returns, the calling thread is not associated with a transaction.
        Returns:
        Transaction object representing the suspended transaction.
        Throws:
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionRequiredException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Class TransactionRequiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.TransactionRequiredException
  • All Implemented Interfaces:
    Serializable

    public class TransactionRequiredException
extends RemoteException
    This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionRequiredException()
      TransactionRequiredException(String msg)

    • Method Summary

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionRequiredException

        public TransactionRequiredException()

      • TransactionRequiredException

        public TransactionRequiredException(String msg)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionRolledbackException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Class TransactionRolledbackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.TransactionRolledbackException
  • All Implemented Interfaces:
    Serializable

    public class TransactionRolledbackException
extends RemoteException
    This exception indicates that the transaction associated with processing of the request has been rolled back, or it has been marked to roll back. Thus the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless.
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionRolledbackException()
      TransactionRolledbackException(String msg)

    • Method Summary

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionRolledbackException

        public TransactionRolledbackException()

      • TransactionRolledbackException

        public TransactionRolledbackException(String msg)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionScoped (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.transaction

Annotation Type TransactionScoped

  • @Retention(value=RUNTIME)
@Target(value={TYPE,METHOD,FIELD})
@NormalScope(passivating=true)
public @interface TransactionScoped

    The javax.transaction.TransactionScoped annotation provides the ability to specify a standard CDI scope to define bean instances whose lifecycle is scoped to the currently active JTA transaction. This annotation has no effect on classes which have non-contextual references such those defined as managed beans by the Java EE specification.

    The transaction scope is active when the return from a call to UserTransaction.getStatus or TransactionManager.getStatus is one of the following states:
  • Status.STATUS_ACTIVE
  • Status.STATUS_MARKED_ROLLBACK
  • Status.STATUS_PREPARED
  • Status.STATUS_UNKNOWN
  • Status.STATUS_PREPARING
  • Status.STATUS_COMMITTING
  • Status.STATUS_ROLLING_BACK

    • It is not intended that the term "active" as defined here in relation to the TransactionScoped annotation should also apply to its use in relation to transaction context, lifecycle, etc. mentioned elsewhere in this specification. The object with this annotation will be associated with the current active JTA transaction when the object is used. This association must be retained through any transaction suspend or resume calls as well as any Synchronization.beforeCompletion callbacks. Any Synchronization.afterCompletion methods will be invoked in an undefined context. The way in which the JTA transaction is begun and completed (for example via UserTransaction, Transactional interceptor, etc.) is of no consequence. The contextual references used across different JTA transactions are distinct. Refer to the CDI specification for more details on contextual references. A javax.enterprise.context.ContextNotActiveException will be thrown if an object with this annotation is used when the transaction context is not active.

Since:
JTA1.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


TransactionSynchronizationRegistry (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Interface TransactionSynchronizationRegistry

  • public interface TransactionSynchronizationRegistry
    This interface is intended for use by system level application server components such as persistence managers, resource adapters, as well as EJB and Web application components. This provides the ability to register synchronization objects with special ordering semantics, associate resource objects with the current transaction, get the transaction context of the current transaction, get current transaction status, and mark the current transaction for rollback. This interface is implemented by the application server by a stateless service object. The same object can be used by any number of components with thread safety.

    In standard application server environments, an instance implementing this interface can be looked up by a standard name via JNDI. The standard name is java:comp/TransactionSynchronizationRegistry.

    Since:
    JTA 1.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getResource(Object key)
      Get an object from the Map of resources being managed for the transaction bound to the current thread at the time this method is called.
      boolean getRollbackOnly()
      Get the rollbackOnly status of the transaction bound to the current thread at the time this method is called.
      Object getTransactionKey()
      Return an opaque object to represent the transaction bound to the current thread at the time this method is called.
      int getTransactionStatus()
      Return the status of the transaction bound to the current thread at the time this method is called.
      void putResource(Object key, Object value)
      Add or replace an object in the Map of resources being managed for the transaction bound to the current thread at the time this method is called.
      void registerInterposedSynchronization(Synchronization sync)
      Register a Synchronization instance with special ordering semantics.
      void setRollbackOnly()
      Set the rollbackOnly status of the transaction bound to the current thread at the time this method is called.

    • Method Detail

      • getTransactionKey

        Object getTransactionKey()
        Return an opaque object to represent the transaction bound to the current thread at the time this method is called. This object overrides hashCode and equals to allow its use as the key in a hashMap for use by the caller. If there is no transaction currently active, return null.

        This object will return the same hashCode and compare equal to all other objects returned by calling this method from any component executing in the same transaction context in the same application server.

        The toString method returns a String that might be usable by a human reader to usefully understand the transaction context. The toString result is otherwise not defined. Specifically, there is no forward or backward compatibility guarantee of the results of toString.

        The object is not necessarily serializable, and has no defined behavior outside the virtual machine whence it was obtained.

        Returns:
        an opaque object representing the transaction bound to the current thread at the time this method is called.
        Since:
        JTA 1.1

      • putResource

        void putResource(Object key,
               Object value)
        Add or replace an object in the Map of resources being managed for the transaction bound to the current thread at the time this method is called. The supplied key should be of an caller- defined class so as not to conflict with other users. The class of the key must guarantee that the hashCode and equals methods are suitable for use as keys in a map. The key and value are not examined or used by the implementation. The general contract of this method is that of Map.put(Object, Object) for a Map that supports non-null keys and null values. For example, if there is already an value associated with the key, it is replaced by the value parameter.
        Parameters:
        key - the key for the Map entry.
        value - the value for the Map entry.
        Throws:
        IllegalStateException - if no transaction is active.
        NullPointerException - if the parameter key is null.
        Since:
        JTA 1.1

      • getResource

        Object getResource(Object key)
        Get an object from the Map of resources being managed for the transaction bound to the current thread at the time this method is called. The key should have been supplied earlier by a call to putResouce in the same transaction. If the key cannot be found in the current resource Map, null is returned. The general contract of this method is that of Map.get(Object) for a Map that supports non-null keys and null values. For example, the returned value is null if there is no entry for the parameter key or if the value associated with the key is actually null.
        Parameters:
        key - the key for the Map entry.
        Returns:
        the value associated with the key.
        Throws:
        IllegalStateException - if no transaction is active.
        NullPointerException - if the parameter key is null.
        Since:
        JTA 1.1

      • registerInterposedSynchronization

        void registerInterposedSynchronization(Synchronization sync)
        Register a Synchronization instance with special ordering semantics. Its beforeCompletion will be called after all SessionSynchronization beforeCompletion callbacks and callbacks registered directly with the Transaction, but before the 2-phase commit process starts. Similarly, the afterCompletion callback will be called after 2-phase commit completes but before any SessionSynchronization and Transaction afterCompletion callbacks.

        The beforeCompletion callback will be invoked in the transaction context of the transaction bound to the current thread at the time this method is called. Allowable methods include access to resources, e.g. Connectors. No access is allowed to "user components" (e.g. timer services or bean methods), as these might change the state of data being managed by the caller, and might change the state of data that has already been flushed by another caller of registerInterposedSynchronization. The general context is the component context of the caller of registerInterposedSynchronization.

        The afterCompletion callback will be invoked in an undefined context. No access is permitted to "user components" as defined above. Resources can be closed but no transactional work can be performed with them.

        If this method is invoked without an active transaction context, an IllegalStateException is thrown.

        If this method is invoked after the two-phase commit processing has started, an IllegalStateException is thrown.

        Parameters:
        sync - the Synchronization instance.
        Throws:
        IllegalStateException - if no transaction is active.
        Since:
        JTA 1.1

      • getTransactionStatus

        int getTransactionStatus()
        Return the status of the transaction bound to the current thread at the time this method is called. This is the result of executing TransactionManager.getStatus() in the context of the transaction bound to the current thread at the time this method is called.
        Returns:
        the status of the transaction bound to the current thread at the time this method is called.
        Since:
        JTA 1.1

      • setRollbackOnly

        void setRollbackOnly()
        Set the rollbackOnly status of the transaction bound to the current thread at the time this method is called.
        Throws:
        IllegalStateException - if no transaction is active.
        Since:
        JTA 1.1

      • getRollbackOnly

        boolean getRollbackOnly()
        Get the rollbackOnly status of the transaction bound to the current thread at the time this method is called.
        Returns:
        the rollbackOnly status.
        Throws:
        IllegalStateException - if no transaction is active.
        Since:
        JTA 1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UserTransaction (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction

Interface UserTransaction

  • public interface UserTransaction
    The UserTransaction interface defines the methods that allow an application to explicitly manage transaction boundaries.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void begin()
      Create a new transaction and associate it with the current thread.
      void commit()
      Complete the transaction associated with the current thread.
      int getStatus()
      Obtain the status of the transaction associated with the current thread.
      void rollback()
      Roll back the transaction associated with the current thread.
      void setRollbackOnly()
      Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.
      void setTransactionTimeout(int seconds)
      Modify the timeout value that is associated with transactions started by the current thread with the begin method.

    • Method Detail

      • begin

        void begin()
           throws NotSupportedException,
                  SystemException
        Create a new transaction and associate it with the current thread.
        Throws:
        NotSupportedException - Thrown if the thread is already associated with a transaction and the Transaction Manager implementation does not support nested transactions.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • commit

        void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
        Complete the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.
        Throws:
        RollbackException - Thrown to indicate that the transaction has been rolled back rather than committed.
        HeuristicMixedException - Thrown to indicate that a heuristic decision was made and that some relevant updates have been committed while others have been rolled back.
        HeuristicRollbackException - Thrown to indicate that a heuristic decision was made and that all relevant updates have been rolled back.
        SecurityException - Thrown to indicate that the thread is not allowed to commit the transaction.
        IllegalStateException - Thrown if the current thread is not associated with a transaction.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • rollback

        void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
        Roll back the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.
        Throws:
        SecurityException - Thrown to indicate that the thread is not allowed to roll back the transaction.
        IllegalStateException - Thrown if the current thread is not associated with a transaction.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • setRollbackOnly

        void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
        Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.
        Throws:
        IllegalStateException - Thrown if the current thread is not associated with a transaction.
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • getStatus

        int getStatus()
              throws SystemException
        Obtain the status of the transaction associated with the current thread.
        Returns:
        The transaction status. If no transaction is associated with the current thread, this method returns the Status.NoTransaction value.
        Throws:
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.

      • setTransactionTimeout

        void setTransactionTimeout(int seconds)
                           throws SystemException
        Modify the timeout value that is associated with transactions started by the current thread with the begin method.

        If an application has not called this method, the transaction service uses some default value for the transaction timeout.

        Parameters:
        seconds - The value of the timeout in seconds. If the value is zero, the transaction service restores the default value. If the value is negative a SystemException is thrown.
        Throws:
        SystemException - Thrown if the transaction manager encounters an unexpected error condition.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.transaction (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.transaction

  • Packages that use javax.transaction
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.
  • Classes in javax.transaction used by javax.ejb
    Class and Description
    UserTransaction
    The UserTransaction interface defines the methods that allow an application to explicitly manage transaction boundaries.
  • Classes in javax.transaction used by javax.resource.spi
    Class and Description
    TransactionSynchronizationRegistry
    This interface is intended for use by system level application server components such as persistence managers, resource adapters, as well as EJB and Web application components.
  • Classes in javax.transaction used by javax.transaction
    Class and Description
    HeuristicMixedException
    This exception is thrown to report that a heuristic decision was made and that some relevant updates have been committed and others have been rolled back.
    HeuristicRollbackException
    This exception is thrown by the commit operation to report that a heuristic decision was made and that all relevant updates have been rolled back.
    InvalidTransactionException
    This exception indicates that the request carried an invalid transaction context.
    NotSupportedException
    NotSupportedException exception indicates that the request cannot be executed because the operation is not a supported feature.
    RollbackException
    RollbackException exception is thrown when the transaction has been marked for rollback only or the transaction has been rolled back instead of committed.
    Synchronization
    The transaction manager supports a synchronization mechanism that allows the interested party to be notified before and after the transaction completes.
    SystemException
    The SystemException is thrown by the transaction manager to indicate that it has encountered an unexpected error condition that prevents future transaction services from proceeding.
    Transaction
    The Transaction interface allows operations to be performed against the transaction in the target Transaction object.
    Transactional.TxType
    The TxType element of the annotation indicates whether a bean method is to be executed within a transaction context where the values provide the following corresponding behavior.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.HeuristicCommitException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.HeuristicCommitException

No usage of javax.transaction.HeuristicCommitException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.HeuristicMixedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.HeuristicMixedException

  • Packages that use HeuristicMixedException
    Package Description
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of HeuristicMixedException in javax.transaction

      Methods in javax.transaction that throw HeuristicMixedException
      Modifier and Type Method and Description
      void UserTransaction.commit()
      Complete the transaction associated with the current thread.
      void TransactionManager.commit()
      Complete the transaction associated with the current thread.
      void Transaction.commit()
      Complete the transaction represented by this Transaction object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.HeuristicRollbackException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.HeuristicRollbackException

  • Packages that use HeuristicRollbackException
    Package Description
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of HeuristicRollbackException in javax.transaction

      Methods in javax.transaction that throw HeuristicRollbackException
      Modifier and Type Method and Description
      void UserTransaction.commit()
      Complete the transaction associated with the current thread.
      void TransactionManager.commit()
      Complete the transaction associated with the current thread.
      void Transaction.commit()
      Complete the transaction represented by this Transaction object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.InvalidTransactionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.InvalidTransactionException

  • Packages that use InvalidTransactionException
    Package Description
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of InvalidTransactionException in javax.transaction

      Methods in javax.transaction that throw InvalidTransactionException
      Modifier and Type Method and Description
      void TransactionManager.resume(Transaction tobj)
      Resume the transaction context association of the calling thread with the transaction represented by the supplied Transaction object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.NotSupportedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.NotSupportedException

  • Packages that use NotSupportedException
    Package Description
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of NotSupportedException in javax.transaction

      Methods in javax.transaction that throw NotSupportedException
      Modifier and Type Method and Description
      void UserTransaction.begin()
      Create a new transaction and associate it with the current thread.
      void TransactionManager.begin()
      Create a new transaction and associate it with the current thread.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.RollbackException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.RollbackException

  • Packages that use RollbackException
    Package Description
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of RollbackException in javax.transaction

      Methods in javax.transaction that throw RollbackException
      Modifier and Type Method and Description
      void UserTransaction.commit()
      Complete the transaction associated with the current thread.
      void TransactionManager.commit()
      Complete the transaction associated with the current thread.
      void Transaction.commit()
      Complete the transaction represented by this Transaction object.
      boolean Transaction.enlistResource(XAResource xaRes)
      Enlist the resource specified with the transaction associated with the target Transaction object.
      void Transaction.registerSynchronization(Synchronization sync)
      Register a synchronization object for the transaction currently associated with the target object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.SystemException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.SystemException

  • Packages that use SystemException
    Package Description
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of SystemException in javax.transaction

      Methods in javax.transaction that throw SystemException
      Modifier and Type Method and Description
      void UserTransaction.begin()
      Create a new transaction and associate it with the current thread.
      void TransactionManager.begin()
      Create a new transaction and associate it with the current thread.
      void UserTransaction.commit()
      Complete the transaction associated with the current thread.
      void TransactionManager.commit()
      Complete the transaction associated with the current thread.
      void Transaction.commit()
      Complete the transaction represented by this Transaction object.
      boolean Transaction.delistResource(XAResource xaRes, int flag)
      Disassociate the resource specified from the transaction associated with the target Transaction object.
      boolean Transaction.enlistResource(XAResource xaRes)
      Enlist the resource specified with the transaction associated with the target Transaction object.
      int UserTransaction.getStatus()
      Obtain the status of the transaction associated with the current thread.
      int TransactionManager.getStatus()
      Obtain the status of the transaction associated with the current thread.
      int Transaction.getStatus()
      Obtain the status of the transaction associated with the target Transaction object.
      Transaction TransactionManager.getTransaction()
      Get the transaction object that represents the transaction context of the calling thread.
      void Transaction.registerSynchronization(Synchronization sync)
      Register a synchronization object for the transaction currently associated with the target object.
      void TransactionManager.resume(Transaction tobj)
      Resume the transaction context association of the calling thread with the transaction represented by the supplied Transaction object.
      void UserTransaction.rollback()
      Roll back the transaction associated with the current thread.
      void TransactionManager.rollback()
      Roll back the transaction associated with the current thread.
      void Transaction.rollback()
      Rollback the transaction represented by this Transaction object.
      void UserTransaction.setRollbackOnly()
      Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.
      void TransactionManager.setRollbackOnly()
      Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.
      void Transaction.setRollbackOnly()
      Modify the transaction associated with the target object such that the only possible outcome of the transaction is to roll back the transaction.
      void UserTransaction.setTransactionTimeout(int seconds)
      Modify the timeout value that is associated with transactions started by the current thread with the begin method.
      void TransactionManager.setTransactionTimeout(int seconds)
      Modify the timeout value that is associated with transactions started by the current thread with the begin method.
      Transaction TransactionManager.suspend()
      Suspend the transaction currently associated with the calling thread and return a Transaction object that represents the transaction context being suspended.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.Transactional (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.Transactional

No usage of javax.transaction.Transactional
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.Transactional.TxType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.Transactional.TxType

  • Packages that use Transactional.TxType
    Package Description
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of Transactional.TxType in javax.transaction

      Methods in javax.transaction that return Transactional.TxType
      Modifier and Type Method and Description
      static Transactional.TxType Transactional.TxType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Transactional.TxType[] Transactional.TxType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.TransactionalException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.TransactionalException

No usage of javax.transaction.TransactionalException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.TransactionRequiredException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.TransactionRequiredException

No usage of javax.transaction.TransactionRequiredException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.TransactionRolledbackException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.TransactionRolledbackException

No usage of javax.transaction.TransactionRolledbackException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.transaction.TransactionScoped (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.TransactionScoped

No usage of javax.transaction.TransactionScoped
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.transaction.Status (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.transaction.Status

No usage of javax.transaction.Status
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.transaction.Synchronization (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.transaction.Synchronization

  • Packages that use Synchronization
    Package Description
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of Synchronization in javax.transaction

      Methods in javax.transaction with parameters of type Synchronization
      Modifier and Type Method and Description
      void TransactionSynchronizationRegistry.registerInterposedSynchronization(Synchronization sync)
      Register a Synchronization instance with special ordering semantics.
      void Transaction.registerSynchronization(Synchronization sync)
      Register a synchronization object for the transaction currently associated with the target object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.transaction.Transaction (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.transaction.Transaction

  • Packages that use Transaction
    Package Description
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

    • Uses of Transaction in javax.transaction

      Methods in javax.transaction that return Transaction
      Modifier and Type Method and Description
      Transaction TransactionManager.getTransaction()
      Get the transaction object that represents the transaction context of the calling thread.
      Transaction TransactionManager.suspend()
      Suspend the transaction currently associated with the calling thread and return a Transaction object that represents the transaction context being suspended.
      Methods in javax.transaction with parameters of type Transaction
      Modifier and Type Method and Description
      void TransactionManager.resume(Transaction tobj)
      Resume the transaction context association of the calling thread with the transaction represented by the supplied Transaction object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.transaction.TransactionManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.transaction.TransactionManager

No usage of javax.transaction.TransactionManager
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.transaction.TransactionSynchronizationRegistry (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.transaction.TransactionSynchronizationRegistry

  • Packages that use TransactionSynchronizationRegistry
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

    • Uses of TransactionSynchronizationRegistry in javax.resource.spi

      Methods in javax.resource.spi that return TransactionSynchronizationRegistry
      Modifier and Type Method and Description
      TransactionSynchronizationRegistry BootstrapContext.getTransactionSynchronizationRegistry()
      Provides a handle to a TransactionSynchronization instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.transaction.UserTransaction (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.transaction.UserTransaction

  • Packages that use UserTransaction
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

    • Uses of UserTransaction in javax.ejb

      Methods in javax.ejb that return UserTransaction
      Modifier and Type Method and Description
      UserTransaction EJBContext.getUserTransaction()
      Obtain the transaction demarcation interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.transaction.xa (Java(TM) EE 7 Specification APIs)

javax.transaction.xa

Interfaces

  • XAResource
  • Xid

Exceptions

  • XAException


javax.transaction.xa (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.transaction.xa

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

See: Description

  • Interface Summary
    Interface Description
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
    Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
  • Exception Summary
    Exception Description
    XAException
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.

Package javax.transaction.xa Description

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions. The driver vendor for a specific resource manager provides the implementation of this API.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.transaction.xa Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.transaction.xa

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.transaction.xa.XAException

Interface Hierarchy

  • javax.transaction.xa.XAResource
  • javax.transaction.xa.Xid
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.transaction.xa (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.transaction.xa

  • Packages that use javax.transaction.xa
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.endpoint
    This package contains system contracts for service endpoint interactions.
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.
  • Classes in javax.transaction.xa used by javax.jms
    Class and Description
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
  • Classes in javax.transaction.xa used by javax.resource.spi
    Class and Description
    XAException
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
    Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
  • Classes in javax.transaction.xa used by javax.resource.spi.endpoint
    Class and Description
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
  • Classes in javax.transaction.xa used by javax.resource.spi.work
    Class and Description
    Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
  • Classes in javax.transaction.xa used by javax.transaction
    Class and Description
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
  • Classes in javax.transaction.xa used by javax.transaction.xa
    Class and Description
    XAException
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
    Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


XAException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction.xa

Class XAException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.transaction.xa.XAException
  • All Implemented Interfaces:
    Serializable

    public class XAException
extends Exception
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      int errorCode
      The error code with which to create the SystemException.
      static int XA_HEURCOM
      The transaction branch has been heuristically committed.
      static int XA_HEURHAZ
      The transaction branch may have been heuristically completed.
      static int XA_HEURMIX
      The transaction branch has been heuristically committed and rolled back.
      static int XA_HEURRB
      The transaction branch has been heuristically rolled back.
      static int XA_NOMIGRATE
      Resumption must occur where the suspension occurred.
      static int XA_RBBASE
      The inclusive lower bound of the rollback codes.
      static int XA_RBCOMMFAIL
      Indicates that the rollback was caused by a communication failure.
      static int XA_RBDEADLOCK
      A deadlock was detected.
      static int XA_RBEND
      The inclusive upper bound of the rollback error code.
      static int XA_RBINTEGRITY
      A condition that violates the integrity of the resource was detected.
      static int XA_RBOTHER
      The resource manager rolled back the transaction branch for a reason not on this list.
      static int XA_RBPROTO
      A protocol error occurred in the resource manager.
      static int XA_RBROLLBACK
      Indicates that the rollback was caused by an unspecified reason.
      static int XA_RBTIMEOUT
      A transaction branch took too long.
      static int XA_RBTRANSIENT
      May retry the transaction branch.
      static int XA_RDONLY
      The transaction branch was read-only and has been committed.
      static int XA_RETRY
      Routine returned with no effect and may be reissued.
      static int XAER_ASYNC
      There is an asynchronous operation already outstanding.
      static int XAER_DUPID
      The XID already exists.
      static int XAER_INVAL
      Invalid arguments were given.
      static int XAER_NOTA
      The XID is not valid.
      static int XAER_OUTSIDE
      The resource manager is doing work outside a global transaction.
      static int XAER_PROTO
      Routine was invoked in an improper context.
      static int XAER_RMERR
      A resource manager error has occurred in the transaction branch.
      static int XAER_RMFAIL
      Resource manager is unavailable.

    • Constructor Summary

      Constructors
      Constructor and Description
      XAException()
      Create an XAException.
      XAException(int errcode)
      Create an XAException with a given error code.
      XAException(String s)
      Create an XAException with a given string.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • errorCode

        public int errorCode
        The error code with which to create the SystemException.

      • XA_RBBASE

        public static final int XA_RBBASE
        The inclusive lower bound of the rollback codes.
        See Also:
        Constant Field Values

      • XA_RBROLLBACK

        public static final int XA_RBROLLBACK
        Indicates that the rollback was caused by an unspecified reason.
        See Also:
        Constant Field Values

      • XA_RBCOMMFAIL

        public static final int XA_RBCOMMFAIL
        Indicates that the rollback was caused by a communication failure.
        See Also:
        Constant Field Values

      • XA_RBDEADLOCK

        public static final int XA_RBDEADLOCK
        A deadlock was detected.
        See Also:
        Constant Field Values

      • XA_RBINTEGRITY

        public static final int XA_RBINTEGRITY
        A condition that violates the integrity of the resource was detected.
        See Also:
        Constant Field Values

      • XA_RBOTHER

        public static final int XA_RBOTHER
        The resource manager rolled back the transaction branch for a reason not on this list.
        See Also:
        Constant Field Values

      • XA_RBPROTO

        public static final int XA_RBPROTO
        A protocol error occurred in the resource manager.
        See Also:
        Constant Field Values

      • XA_RBTIMEOUT

        public static final int XA_RBTIMEOUT
        A transaction branch took too long.
        See Also:
        Constant Field Values

      • XA_RBTRANSIENT

        public static final int XA_RBTRANSIENT
        May retry the transaction branch.
        See Also:
        Constant Field Values

      • XA_RBEND

        public static final int XA_RBEND
        The inclusive upper bound of the rollback error code.
        See Also:
        Constant Field Values

      • XA_NOMIGRATE

        public static final int XA_NOMIGRATE
        Resumption must occur where the suspension occurred.
        See Also:
        Constant Field Values

      • XA_HEURHAZ

        public static final int XA_HEURHAZ
        The transaction branch may have been heuristically completed.
        See Also:
        Constant Field Values

      • XA_HEURCOM

        public static final int XA_HEURCOM
        The transaction branch has been heuristically committed.
        See Also:
        Constant Field Values

      • XA_HEURRB

        public static final int XA_HEURRB
        The transaction branch has been heuristically rolled back.
        See Also:
        Constant Field Values

      • XA_HEURMIX

        public static final int XA_HEURMIX
        The transaction branch has been heuristically committed and rolled back.
        See Also:
        Constant Field Values

      • XA_RETRY

        public static final int XA_RETRY
        Routine returned with no effect and may be reissued.
        See Also:
        Constant Field Values

      • XA_RDONLY

        public static final int XA_RDONLY
        The transaction branch was read-only and has been committed.
        See Also:
        Constant Field Values

      • XAER_ASYNC

        public static final int XAER_ASYNC
        There is an asynchronous operation already outstanding.
        See Also:
        Constant Field Values

      • XAER_RMERR

        public static final int XAER_RMERR
        A resource manager error has occurred in the transaction branch.
        See Also:
        Constant Field Values

      • XAER_NOTA

        public static final int XAER_NOTA
        The XID is not valid.
        See Also:
        Constant Field Values

      • XAER_INVAL

        public static final int XAER_INVAL
        Invalid arguments were given.
        See Also:
        Constant Field Values

      • XAER_PROTO

        public static final int XAER_PROTO
        Routine was invoked in an improper context.
        See Also:
        Constant Field Values

      • XAER_RMFAIL

        public static final int XAER_RMFAIL
        Resource manager is unavailable.
        See Also:
        Constant Field Values

      • XAER_DUPID

        public static final int XAER_DUPID
        The XID already exists.
        See Also:
        Constant Field Values

      • XAER_OUTSIDE

        public static final int XAER_OUTSIDE
        The resource manager is doing work outside a global transaction.
        See Also:
        Constant Field Values

    • Constructor Detail

      • XAException

        public XAException()
        Create an XAException.

      • XAException

        public XAException(String s)
        Create an XAException with a given string.
        Parameters:
        s - The String object containing the exception message.

      • XAException

        public XAException(int errcode)
        Create an XAException with a given error code.
        Parameters:
        errcode - The error code identifying the exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XAResource (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction.xa

Interface XAResource

  • public interface XAResource

    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).

    The XA interface defines the contract between a Resource Manager and a Transaction Manager in a distributed transaction processing (DTP) environment. A JDBC driver or a JMS provider implements this interface to support the association between a global transaction and a database or message service connection.

    The XAResource interface can be supported by any transactional resource that is intended to be used by application programs in an environment where transactions are controlled by an external transaction manager. An example of such a resource is a database management system. An application may access data through multiple database connections. Each database connection is enlisted with the transaction manager as a transactional resource. The transaction manager obtains an XAResource for each connection participating in a global transaction. The transaction manager uses the start method to associate the global transaction with the resource, and it uses the end method to disassociate the transaction from the resource. The resource manager is responsible for associating the global transaction to all work performed on its data between the start and end method invocations.

    At transaction commit time, the resource managers are informed by the transaction manager to prepare, commit, or rollback a transaction according to the two-phase commit protocol.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int TMENDRSCAN
      Ends a recovery scan.
      static int TMFAIL
      Disassociates the caller and marks the transaction branch rollback-only.
      static int TMJOIN
      Caller is joining existing transaction branch.
      static int TMNOFLAGS
      Use TMNOFLAGS to indicate no flags value is selected.
      static int TMONEPHASE
      Caller is using one-phase optimization.
      static int TMRESUME
      Caller is resuming association with a suspended transaction branch.
      static int TMSTARTRSCAN
      Starts a recovery scan.
      static int TMSUCCESS
      Disassociates caller from a transaction branch.
      static int TMSUSPEND
      Caller is suspending (not ending) its association with a transaction branch.
      static int XA_OK
      The transaction work has been prepared normally.
      static int XA_RDONLY
      The transaction branch has been read-only and has been committed.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void end(Xid xid, int flags)
      Ends the work performed on behalf of a transaction branch.
      void forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int getTransactionTimeout()
      Obtains the current transaction timeout value set for this XAResource instance.
      boolean isSameRM(XAResource xares)
      This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
      int prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      Xid[] recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      void rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.
      boolean setTransactionTimeout(int seconds)
      Sets the current transaction timeout value for this XAResource instance.
      void start(Xid xid, int flags)
      Starts work on behalf of a transaction branch specified in xid.

    • Field Detail

      • TMENDRSCAN

        static final int TMENDRSCAN
        Ends a recovery scan.
        See Also:
        Constant Field Values

      • TMFAIL

        static final int TMFAIL
        Disassociates the caller and marks the transaction branch rollback-only.
        See Also:
        Constant Field Values

      • TMJOIN

        static final int TMJOIN
        Caller is joining existing transaction branch.
        See Also:
        Constant Field Values

      • TMNOFLAGS

        static final int TMNOFLAGS
        Use TMNOFLAGS to indicate no flags value is selected.
        See Also:
        Constant Field Values

      • TMONEPHASE

        static final int TMONEPHASE
        Caller is using one-phase optimization.
        See Also:
        Constant Field Values

      • TMRESUME

        static final int TMRESUME
        Caller is resuming association with a suspended transaction branch.
        See Also:
        Constant Field Values

      • TMSTARTRSCAN

        static final int TMSTARTRSCAN
        Starts a recovery scan.
        See Also:
        Constant Field Values

      • TMSUCCESS

        static final int TMSUCCESS
        Disassociates caller from a transaction branch.
        See Also:
        Constant Field Values

      • TMSUSPEND

        static final int TMSUSPEND
        Caller is suspending (not ending) its association with a transaction branch.
        See Also:
        Constant Field Values

      • XA_RDONLY

        static final int XA_RDONLY
        The transaction branch has been read-only and has been committed.
        See Also:
        Constant Field Values

      • XA_OK

        static final int XA_OK
        The transaction work has been prepared normally.
        See Also:
        Constant Field Values

    • Method Detail

      • commit

        void commit(Xid xid,
          boolean onePhase)
            throws XAException
        Commits the global transaction specified by xid.
        Parameters:
        xid - A global transaction identifier
        onePhase - If true, the resource manager should use a one-phase commit protocol to commit the work done on behalf of xid.
        Throws:
        XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

        If the resource manager did not commit the transaction and the parameter onePhase is set to true, the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

      • end

        void end(Xid xid,
       int flags)
         throws XAException
        Ends the work performed on behalf of a transaction branch. The resource manager disassociates the XA resource from the transaction branch specified and lets the transaction complete.

        If TMSUSPEND is specified in the flags, the transaction branch is temporarily suspended in an incomplete state. The transaction context is in a suspended state and must be resumed via the start method with TMRESUME specified.

        If TMFAIL is specified, the portion of work has failed. The resource manager may mark the transaction as rollback-only

        If TMSUCCESS is specified, the portion of work has completed successfully.

        Parameters:
        xid - A global transaction identifier that is the same as the identifier used previously in the start method.
        flags - One of TMSUCCESS, TMFAIL, or TMSUSPEND.
        Throws:
        XAException - An error has occurred. Possible XAException values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, XAER_PROTO, or XA_RB*.

      • forget

        void forget(Xid xid)
            throws XAException
        Tells the resource manager to forget about a heuristically completed transaction branch.
        Parameters:
        xid - A global transaction identifier.
        Throws:
        XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

      • getTransactionTimeout

        int getTransactionTimeout()
                          throws XAException
        Obtains the current transaction timeout value set for this XAResource instance. If XAResource.setTransactionTimeout was not used prior to invoking this method, the return value is the default timeout set for the resource manager; otherwise, the value used in the previous setTransactionTimeout call is returned.
        Returns:
        the transaction timeout value in seconds.
        Throws:
        XAException - An error has occurred. Possible exception values are XAER_RMERR and XAER_RMFAIL.

      • isSameRM

        boolean isSameRM(XAResource xares)
                 throws XAException
        This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
        Parameters:
        xares - An XAResource object whose resource manager instance is to be compared with the resource manager instance of the target object.
        Returns:
        true if it's the same RM instance; otherwise false.
        Throws:
        XAException - An error has occurred. Possible exception values are XAER_RMERR and XAER_RMFAIL.

      • prepare

        int prepare(Xid xid)
            throws XAException
        Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
        Parameters:
        xid - A global transaction identifier.
        Returns:
        A value indicating the resource manager's vote on the outcome of the transaction. The possible values are: XA_RDONLY or XA_OK. If the resource manager wants to roll back the transaction, it should do so by raising an appropriate XAException in the prepare method.
        Throws:
        XAException - An error has occurred. Possible exception values are: XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

      • recover

        Xid[] recover(int flag)
              throws XAException
        Obtains a list of prepared transaction branches from a resource manager. The transaction manager calls this method during recovery to obtain the list of transaction branches that are currently in prepared or heuristically completed states.
        Parameters:
        flag - One of TMSTARTRSCAN, TMENDRSCAN, TMNOFLAGS. TMNOFLAGS must be used when no other flags are set in the parameter.
        Returns:
        The resource manager returns zero or more XIDs of the transaction branches that are currently in a prepared or heuristically completed state. If an error occurs during the operation, the resource manager should throw the appropriate XAException.
        Throws:
        XAException - An error has occurred. Possible values are XAER_RMERR, XAER_RMFAIL, XAER_INVAL, and XAER_PROTO.

      • rollback

        void rollback(Xid xid)
              throws XAException
        Informs the resource manager to roll back work done on behalf of a transaction branch.
        Parameters:
        xid - A global transaction identifier.
        Throws:
        XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

        If the transaction branch is already marked rollback-only the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

      • setTransactionTimeout

        boolean setTransactionTimeout(int seconds)
                              throws XAException

        Sets the current transaction timeout value for this XAResource instance. Once set, this timeout value is effective until setTransactionTimeout is invoked again with a different value. To reset the timeout value to the default value used by the resource manager, set the value to zero. If the timeout operation is performed successfully, the method returns true; otherwise false. If a resource manager does not support explicitly setting the transaction timeout value, this method returns false.

        Parameters:
        seconds - The transaction timeout value in seconds.
        Returns:
        true if the transaction timeout value is set successfully; otherwise false.
        Throws:
        XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, or XAER_INVAL.

      • start

        void start(Xid xid,
         int flags)
           throws XAException
        Starts work on behalf of a transaction branch specified in xid. If TMJOIN is specified, the start applies to joining a transaction previously seen by the resource manager. If TMRESUME is specified, the start applies to resuming a suspended transaction specified in the parameter xid. If neither TMJOIN nor TMRESUME is specified and the transaction specified by xid has previously been seen by the resource manager, the resource manager throws the XAException exception with XAER_DUPID error code.
        Parameters:
        xid - A global transaction identifier to be associated with the resource.
        flags - One of TMNOFLAGS, TMJOIN, or TMRESUME.
        Throws:
        XAException - An error has occurred. Possible exceptions are XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_DUPID, XAER_OUTSIDE, XAER_NOTA, XAER_INVAL, or XAER_PROTO.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Xid (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.transaction.xa

Interface Xid

  • public interface Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure. This interface specifies three accessor methods to retrieve a global transaction's format ID, global transaction ID, and branch qualifier. The Xid interface is used by the transaction manager and the resource managers. This interface is not visible to the application programs.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int MAXBQUALSIZE
      Maximum number of bytes returned by getBqual.
      static int MAXGTRIDSIZE
      Maximum number of bytes returned by getGtrid.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      byte[] getBranchQualifier()
      Obtain the transaction branch identifier part of XID as an array of bytes.
      int getFormatId()
      Obtain the format identifier part of the XID.
      byte[] getGlobalTransactionId()
      Obtain the global transaction identifier part of XID as an array of bytes.

    • Field Detail

      • MAXGTRIDSIZE

        static final int MAXGTRIDSIZE
        Maximum number of bytes returned by getGtrid.
        See Also:
        Constant Field Values

      • MAXBQUALSIZE

        static final int MAXBQUALSIZE
        Maximum number of bytes returned by getBqual.
        See Also:
        Constant Field Values

    • Method Detail

      • getFormatId

        int getFormatId()
        Obtain the format identifier part of the XID.
        Returns:
        Format identifier. O means the OSI CCR format.

      • getGlobalTransactionId

        byte[] getGlobalTransactionId()
        Obtain the global transaction identifier part of XID as an array of bytes.
        Returns:
        Global transaction identifier.

      • getBranchQualifier

        byte[] getBranchQualifier()
        Obtain the transaction branch identifier part of XID as an array of bytes.
        Returns:
        Global transaction identifier.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.transaction.xa.XAException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.transaction.xa.XAException

  • Packages that use XAException
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

    • Uses of XAException in javax.resource.spi

      Methods in javax.resource.spi that throw XAException
      Modifier and Type Method and Description
      void XATerminator.commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void XATerminator.forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int XATerminator.prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      Xid[] XATerminator.recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      void XATerminator.rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.

    • Uses of XAException in javax.transaction.xa

      Methods in javax.transaction.xa that throw XAException
      Modifier and Type Method and Description
      void XAResource.commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void XAResource.end(Xid xid, int flags)
      Ends the work performed on behalf of a transaction branch.
      void XAResource.forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int XAResource.getTransactionTimeout()
      Obtains the current transaction timeout value set for this XAResource instance.
      boolean XAResource.isSameRM(XAResource xares)
      This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
      int XAResource.prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      Xid[] XAResource.recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      void XAResource.rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.
      boolean XAResource.setTransactionTimeout(int seconds)
      Sets the current transaction timeout value for this XAResource instance.
      void XAResource.start(Xid xid, int flags)
      Starts work on behalf of a transaction branch specified in xid.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.transaction.xa.XAResource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.transaction.xa.XAResource

  • Packages that use XAResource
    Package Description
    javax.jms
    The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.endpoint
    This package contains system contracts for service endpoint interactions.
    javax.transaction
    Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

    • Uses of XAResource in javax.jms

      Methods in javax.jms that return XAResource
      Modifier and Type Method and Description
      XAResource XASession.getXAResource()
      Returns an XA resource to the caller.
      XAResource XAJMSContext.getXAResource()
      Returns an XAResource to the caller.

    • Uses of XAResource in javax.resource.spi

      Methods in javax.resource.spi that return XAResource
      Modifier and Type Method and Description
      XAResource ManagedConnection.getXAResource()
      Returns an javax.transaction.xa.XAresource instance.
      XAResource[] ResourceAdapter.getXAResources(ActivationSpec[] specs)
      This method is called by the application server during crash recovery.

    • Uses of XAResource in javax.resource.spi.endpoint

      Methods in javax.resource.spi.endpoint with parameters of type XAResource
      Modifier and Type Method and Description
      MessageEndpoint MessageEndpointFactory.createEndpoint(XAResource xaResource)
      This is used to create a message endpoint.
      MessageEndpoint MessageEndpointFactory.createEndpoint(XAResource xaResource, long timeout)
      This is used to create a message endpoint.

    • Uses of XAResource in javax.transaction

      Methods in javax.transaction with parameters of type XAResource
      Modifier and Type Method and Description
      boolean Transaction.delistResource(XAResource xaRes, int flag)
      Disassociate the resource specified from the transaction associated with the target Transaction object.
      boolean Transaction.enlistResource(XAResource xaRes)
      Enlist the resource specified with the transaction associated with the target Transaction object.

    • Uses of XAResource in javax.transaction.xa

      Methods in javax.transaction.xa with parameters of type XAResource
      Modifier and Type Method and Description
      boolean XAResource.isSameRM(XAResource xares)
      This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.transaction.xa.Xid (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.transaction.xa.Xid

  • Packages that use Xid
    Package Description
    javax.resource.spi
    The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
    javax.resource.spi.work
    This package contains APIs for the Work Management, Generic and Security Work Context contracts.
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

    • Uses of Xid in javax.resource.spi

      Methods in javax.resource.spi that return Xid
      Modifier and Type Method and Description
      Xid[] XATerminator.recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      Methods in javax.resource.spi with parameters of type Xid
      Modifier and Type Method and Description
      void XATerminator.commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void XATerminator.forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int XATerminator.prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      void XATerminator.rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.

    • Uses of Xid in javax.resource.spi.work

      Methods in javax.resource.spi.work that return Xid
      Modifier and Type | Method and Description
      Xid | ExecutionContext.getXid()
      Methods in javax.resource.spi.work with parameters of type Xid
      Modifier and Type Method and Description
      void ExecutionContext.setXid(Xid xid)
      set a transaction context.

    • Uses of Xid in javax.transaction.xa

      Methods in javax.transaction.xa that return Xid
      Modifier and Type Method and Description
      Xid[] XAResource.recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      Methods in javax.transaction.xa with parameters of type Xid
      Modifier and Type Method and Description
      void XAResource.commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void XAResource.end(Xid xid, int flags)
      Ends the work performed on behalf of a transaction branch.
      void XAResource.forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int XAResource.prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      void XAResource.rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.
      void XAResource.start(Xid xid, int flags)
      Starts work on behalf of a transaction branch specified in xid.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BootstrapConfiguration (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface BootstrapConfiguration

  • public interface BootstrapConfiguration
    Represents the user specified default configuration in META-INF/validation.xml.

    Note that modifications to the returned objects do not have any effect. Instead use the methods provided on Configuration in order to apply modifications to the configuration.

    Since:
    1.1
    Author:
    Emmanuel Bernard, Gunnar Morling, Hardy Ferentschik

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<String> getConstraintMappingResourcePaths()
      Returns a set of resource paths pointing to XML constraint mapping files.
      String getConstraintValidatorFactoryClassName()
      Class name of the ConstraintValidatorFactory implementation or null if none is specified.
      String getDefaultProviderClassName()
      Class name of the ValidationProvider implementation or null if none is specified.
      Set<ExecutableType> getDefaultValidatedExecutableTypes()
      Returns the set of executable types that should be considered unless explicitly overridden via ValidateOnExecution

      Returns a set containing ExecutableType.CONSTRUCTORS and ExecutableType.NON_GETTER_METHODS if unspecified in the configuration.
      String getMessageInterpolatorClassName()
      Class name of the MessageInterpolator implementation or null if none is specified.
      String getParameterNameProviderClassName()
      Class name of the ParameterNameProvider implementation or null if none is specified.
      Map<String,String> getProperties()
      Returns properties as a map of string based key/value pairs.
      String getTraversableResolverClassName()
      Class name of the TraversableResolver implementation or null if none is specified.
      boolean isExecutableValidationEnabled()
      Returns true if the validation execution is explicitly marked as enabled or if it is left undefined.

    • Method Detail

      • getDefaultProviderClassName

        String getDefaultProviderClassName()
        Class name of the ValidationProvider implementation or null if none is specified.
        Returns:
        validation provider class name

      • getConstraintValidatorFactoryClassName

        String getConstraintValidatorFactoryClassName()
        Class name of the ConstraintValidatorFactory implementation or null if none is specified.
        Returns:
        constraint validator factory class name

      • getMessageInterpolatorClassName

        String getMessageInterpolatorClassName()
        Class name of the MessageInterpolator implementation or null if none is specified.
        Returns:
        message interpolator class name or null

      • getTraversableResolverClassName

        String getTraversableResolverClassName()
        Class name of the TraversableResolver implementation or null if none is specified.
        Returns:
        traversable resolver class name or null

      • getParameterNameProviderClassName

        String getParameterNameProviderClassName()
        Class name of the ParameterNameProvider implementation or null if none is specified.
        Returns:
        parameter name provider class name or null

      • getConstraintMappingResourcePaths

        Set<String> getConstraintMappingResourcePaths()
        Returns a set of resource paths pointing to XML constraint mapping files. The set is empty if none are specified.
        Returns:
        set of constraint mapping resource paths

      • isExecutableValidationEnabled

        boolean isExecutableValidationEnabled()
        Returns true if the validation execution is explicitly marked as enabled or if it is left undefined.
        Returns:
        whether validation execution is globally enabled

      • getDefaultValidatedExecutableTypes

        Set<ExecutableType> getDefaultValidatedExecutableTypes()
        Returns the set of executable types that should be considered unless explicitly overridden via ValidateOnExecution

        Returns a set containing ExecutableType.CONSTRUCTORS and ExecutableType.NON_GETTER_METHODS if unspecified in the configuration.

        Returns:
        set of validated executable types

      • getProperties

        Map<String,String> getProperties()
        Returns properties as a map of string based key/value pairs. The map is empty if no property has been specified.
        Returns:
        the properties map
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Configuration (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Configuration<T extends Configuration<T>>

  • public interface Configuration<T extends Configuration<T>>
    Receives configuration information, selects the appropriate Bean Validation provider and builds the appropriate ValidatorFactory.

    Usage:

     Configuration configuration = //provided by one of the Validation bootstrap methods
     ValidatorFactory = configuration
         .messageInterpolator( new CustomMessageInterpolator() )
         .buildValidatorFactory();

    By default, the configuration information is retrieved from META-INF/validation.xml. It is possible to override the configuration retrieved from the XML file by using one or more of the Configuration methods.

    The ValidationProviderResolver is specified at configuration time (see ValidationProvider). If none is explicitly requested, the default ValidationProviderResolver is used.

    The provider is selected in the following way:

    • if a specific provider is requested programmatically using Validation.byProvider(Class), find the first provider implementing the provider class requested and use it
    • if a specific provider is requested in META-INF/validation.xml>, find the first provider implementing the provider class requested and use it
    • otherwise, use the first provider returned by the ValidationProviderResolver

    Implementations are not meant to be thread-safe.

    Author:
    Emmanuel Bernard, Gunnar Morling, Hardy Ferentschik

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T addMapping(InputStream stream)
      Add a stream describing constraint mapping in the Bean Validation XML format.
      T addProperty(String name, String value)
      Adds a provider specific property.
      ValidatorFactory buildValidatorFactory()
      Build a ValidatorFactory implementation.
      T constraintValidatorFactory(ConstraintValidatorFactory constraintValidatorFactory)
      Defines the constraint validator factory.
      BootstrapConfiguration getBootstrapConfiguration()
      Returns configuration information stored in the META-INF/validation.xml file.
      ConstraintValidatorFactory getDefaultConstraintValidatorFactory()
      Returns an implementation of the ConstraintValidatorFactory interface following the default ConstraintValidatorFactory defined in the specification: uses the public no-arg constructor of the ConstraintValidator
      MessageInterpolator getDefaultMessageInterpolator()
      Returns an implementation of the MessageInterpolator interface following the default MessageInterpolator defined in the specification: use the ValidationMessages resource bundle to load keys use Locale.getDefault()
      ParameterNameProvider getDefaultParameterNameProvider()
      Returns an implementation of the ParameterNameProvider interface following the default ParameterNameProvider defined in the specification: returns names in the form arg&lt;PARAMETER_INDEX&gt; where PARAMETER_INDEX starts at 0 for the first parameter, e.g.
      TraversableResolver getDefaultTraversableResolver()
      Returns an implementation of the TraversableResolver interface following the default TraversableResolver defined in the specification: if Java Persistence is available in the runtime environment, a property is considered reachable if Java Persistence considers the property as loaded if Java Persistence is not available in the runtime environment, all properties are considered reachable all properties are considered cascadable.
      T ignoreXmlConfiguration()
      Ignores data from the META-INF/validation.xml file if this method is called.
      T messageInterpolator(MessageInterpolator interpolator)
      Defines the message interpolator used.
      T parameterNameProvider(ParameterNameProvider parameterNameProvider)
      Defines the parameter name provider.
      T traversableResolver(TraversableResolver resolver)
      Defines the traversable resolver used.

    • Method Detail

      • ignoreXmlConfiguration

        T ignoreXmlConfiguration()
        Ignores data from the META-INF/validation.xml file if this method is called.

        This method is typically useful for containers that parse META-INF/validation.xml themselves and pass the information via the Configuration methods.

        Returns:
        this following the chaining method pattern.

      • messageInterpolator

        T messageInterpolator(MessageInterpolator interpolator)
        Defines the message interpolator used. Has priority over the configuration based message interpolator.

        If null is passed, the default message interpolator is used (defined in XML or the specification default).

        Parameters:
        interpolator - message interpolator implementation
        Returns:
        this following the chaining method pattern

      • traversableResolver

        T traversableResolver(TraversableResolver resolver)
        Defines the traversable resolver used. Has priority over the configuration based traversable resolver.

        If null is passed, the default traversable resolver is used (defined in XML or the specification default).

        Parameters:
        resolver - traversable resolver implementation
        Returns:
        this following the chaining method pattern

      • constraintValidatorFactory

        T constraintValidatorFactory(ConstraintValidatorFactory constraintValidatorFactory)
        Defines the constraint validator factory. Has priority over the configuration based constraint factory.

        If null is passed, the default constraint validator factory is used (defined in XML or the specification default).

        Parameters:
        constraintValidatorFactory - constraint factory implementation
        Returns:
        this following the chaining method pattern

      • parameterNameProvider

        T parameterNameProvider(ParameterNameProvider parameterNameProvider)
        Defines the parameter name provider. Has priority over the configuration based provider.

        If null is passed, the default parameter name provider is used (defined in XML or the specification default).

        Parameters:
        parameterNameProvider - parameter name provider implementation
        Returns:
        this following the chaining method pattern.
        Since:
        1.1

      • addMapping

        T addMapping(InputStream stream)
        Add a stream describing constraint mapping in the Bean Validation XML format.

        The stream should be closed by the client API after the ValidatorFactory has been built. The Bean Validation provider must not close the stream.

        Parameters:
        stream - XML mapping stream; the given stream should support the mark/reset contract (see InputStream.markSupported()); if it doesn't, it will be wrapped into a stream supporting the mark/reset contract by the Bean Validation provider
        Returns:
        this following the chaining method pattern
        Throws:
        IllegalArgumentException - if stream is null

      • addProperty

        T addProperty(String name,
            String value)
        Adds a provider specific property. This property is equivalent to XML configuration properties. If the underlying provider does not know how to handle the property, it must silently ignore it.

        Note: Using this non type-safe method is generally not recommended.

        It is more appropriate to use, if available, the type-safe equivalent provided by a specific provider via its Configuration subclass.

         ValidatorFactory factory = Validation.byProvider(ACMEProvider.class)
     .configure()
         .providerSpecificProperty(ACMEState.FAST)
     .buildValidatorFactory();
        This method is typically used by containers parsing META-INF/validation.xml themselves and injecting the state to the Configuration object.

        If a property with a given name is defined both via this method and in the XML configuration, the value set programmatically has priority.

        If null is passed as a value, the value defined in XML is used. If no value is defined in XML, the property is considered unset.

        Parameters:
        name - property name
        value - property value
        Returns:
        this following the chaining method pattern
        Throws:
        IllegalArgumentException - if name is null

      • getDefaultMessageInterpolator

        MessageInterpolator getDefaultMessageInterpolator()
        Returns an implementation of the MessageInterpolator interface following the default MessageInterpolator defined in the specification:
        • use the ValidationMessages resource bundle to load keys
        • use Locale.getDefault()
        Returns:
        default MessageInterpolator implementation compliant with the specification

      • getDefaultTraversableResolver

        TraversableResolver getDefaultTraversableResolver()
        Returns an implementation of the TraversableResolver interface following the default TraversableResolver defined in the specification:
        • if Java Persistence is available in the runtime environment, a property is considered reachable if Java Persistence considers the property as loaded
        • if Java Persistence is not available in the runtime environment, all properties are considered reachable
        • all properties are considered cascadable.
        Returns:
        default TraversableResolver implementation compliant with the specification

      • getDefaultConstraintValidatorFactory

        ConstraintValidatorFactory getDefaultConstraintValidatorFactory()
        Returns an implementation of the ConstraintValidatorFactory interface following the default ConstraintValidatorFactory defined in the specification:
        • uses the public no-arg constructor of the ConstraintValidator
        Returns:
        default ConstraintValidatorFactory implementation compliant with the specification

      • getDefaultParameterNameProvider

        ParameterNameProvider getDefaultParameterNameProvider()
        Returns an implementation of the ParameterNameProvider interface following the default ParameterNameProvider defined in the specification:
        • returns names in the form arg&lt;PARAMETER_INDEX&gt; where PARAMETER_INDEX starts at 0 for the first parameter, e.g. arg0, arg1 etc.
        Returns:
        default ParameterNameProvider implementation compliant with the specification
        Since:
        1.1

      • getBootstrapConfiguration

        BootstrapConfiguration getBootstrapConfiguration()
        Returns configuration information stored in the META-INF/validation.xml file.

        Note:
        Implementations are encouraged to lazily build this object to delay parsing.

        Returns:
        returns an instance of BootstrapConfiguration; this method never returns null; if there is no META-INF/validation.xml the different getters of the returned instance will return null respectively an empty set or map
        Since:
        1.1

      • buildValidatorFactory

        ValidatorFactory buildValidatorFactory()
        Build a ValidatorFactory implementation.
        Returns:
        the ValidatorFactory
        Throws:
        ValidationException - if the ValidatorFactory cannot be built
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Constraint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation

Annotation Type Constraint

  • @Documented
@Target(value=ANNOTATION_TYPE)
@Retention(value=RUNTIME)
public @interface Constraint
    Marks an annotation as being a Bean Validation constraint.

    A given constraint annotation must be annotated by a @Constraint annotation which refers to its list of constraint validation implementations.

    Each constraint annotation must host the following attributes:

    • String message() default [...]; which should default to an error message key made of the fully-qualified class name of the constraint followed by .message. For example "{com.acme.constraints.NotSafe.message}"
    • Class<?>[] groups() default {}; for user to customize the targeted groups
    • Class<? extends Payload>[] payload() default {}; for extensibility purposes

    When building a constraint that is both generic and cross-parameter, the constraint annotation must host the validationAppliesTo() property. A constraint is generic if it targets the annotated element and is cross-parameter if it targets the array of parameters of a method or constructor.

         ConstraintTarget validationAppliesTo() default ConstraintTarget.IMPLICIT;
    This property allows the constraint user to choose whether the constraint targets the return type of the executable or its array of parameters. A constraint is both generic and cross-parameter if
    • two kinds of ConstraintValidators are attached to the constraint, one targeting ValidationTarget.ANNOTATED_ELEMENT and one targeting ValidationTarget.PARAMETERS,
    • or if a ConstraintValidator targets both ANNOTATED_ELEMENT and PARAMETERS.
    Such dual constraints are rare. See SupportedValidationTarget for more info.

    Here is an example of constraint definition:

     @Documented
 @Constraint(validatedBy = OrderNumberValidator.class)
 @Target({ METHOD, FIELD, ANNOTATION_TYPE, CONSTRUCTOR, PARAMETER })
 @Retention(RUNTIME)
 public @interface OrderNumber {
     String message() default "{com.acme.constraint.OrderNumber.message}";
     Class[] groups() default {};
     Class[] payload() default {};
 }
    Author:
    Emmanuel Bernard, Gavin King, Hardy Ferentschik

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<? extends ConstraintValidator<?,?>>[] validatedBy
      ConstraintValidator classes must reference distinct target types for a given ValidationTarget If two ConstraintValidators refer to the same type, an exception will occur.

    • Element Detail

      • validatedBy

        public abstract Class<? extends ConstraintValidator<?,?>>[] validatedBy
        ConstraintValidator classes must reference distinct target types for a given ValidationTarget If two ConstraintValidators refer to the same type, an exception will occur.

        At most one ConstraintValidator targeting the array of parameters of methods or constructors (aka cross-parameter) is accepted. If two or more are present, an exception will occur.

        Returns:
        array of (@code ConstraintValidator} classes implementing the constraint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ConstraintDeclarationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Class ConstraintDeclarationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.validation.ValidationException
            • javax.validation.ConstraintDeclarationException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    UnexpectedTypeException

    public class ConstraintDeclarationException
extends ValidationException
    Exception raised if a constraint declaration is not legal.
    Author:
    Emmanuel Bernard
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ConstraintDeclarationException()
      ConstraintDeclarationException(String message)
      ConstraintDeclarationException(String message, Throwable cause)
      ConstraintDeclarationException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ConstraintDeclarationException

        public ConstraintDeclarationException(String message)

      • ConstraintDeclarationException

        public ConstraintDeclarationException()

      • ConstraintDeclarationException

        public ConstraintDeclarationException(String message,
                              Throwable cause)

      • ConstraintDeclarationException

        public ConstraintDeclarationException(Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintDefinitionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Class ConstraintDefinitionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.validation.ValidationException
            • javax.validation.ConstraintDefinitionException
  • All Implemented Interfaces:
    Serializable

    public class ConstraintDefinitionException
extends ValidationException
    Exception raised if a constraint definition is not legal.
    Author:
    Emmanuel Bernard
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ConstraintDefinitionException()
      ConstraintDefinitionException(String message)
      ConstraintDefinitionException(String message, Throwable cause)
      ConstraintDefinitionException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ConstraintDefinitionException

        public ConstraintDefinitionException(String message)

      • ConstraintDefinitionException

        public ConstraintDefinitionException()

      • ConstraintDefinitionException

        public ConstraintDefinitionException(String message,
                             Throwable cause)

      • ConstraintDefinitionException

        public ConstraintDefinitionException(Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.validation

Enum ConstraintTarget

  • java.lang.Object
    • java.lang.Enum<ConstraintTarget>
      • javax.validation.ConstraintTarget
  • All Implemented Interfaces:
    Serializable, Comparable<ConstraintTarget>

    public enum ConstraintTarget
extends Enum<ConstraintTarget>
    Defines the constraint target.
    Since:
    1.1
    Author:
    Emmanuel Bernard

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      IMPLICIT
      Discover the type when no ambiguity is present if neither on a method nor a constructor, it implies the annotated element (type, field etc), if on a method or constructor with no parameter, it implies RETURN_VALUE, if on a method with no return value (void), it implies PARAMETERS. Otherwise, IMPLICIT is not accepted and either RETURN_VALUE or PARAMETERS is required.
      PARAMETERS
      Constraint applies to the parameters of a method or a constructor
      RETURN_VALUE
      Constraint applies to the return value of a method or a constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ConstraintTarget valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ConstraintTarget[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • IMPLICIT

        public static final ConstraintTarget IMPLICIT
        Discover the type when no ambiguity is present
        • if neither on a method nor a constructor, it implies the annotated element (type, field etc),
        • if on a method or constructor with no parameter, it implies RETURN_VALUE,
        • if on a method with no return value (void), it implies PARAMETERS.
        Otherwise, IMPLICIT is not accepted and either RETURN_VALUE or PARAMETERS is required. This is the case for constructors with parameters and methods with parameters and return value.

      • RETURN_VALUE

        public static final ConstraintTarget RETURN_VALUE
        Constraint applies to the return value of a method or a constructor.

      • PARAMETERS

        public static final ConstraintTarget PARAMETERS
        Constraint applies to the parameters of a method or a constructor

    • Method Detail

      • values

        public static ConstraintTarget[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ConstraintTarget c : ConstraintTarget.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ConstraintTarget valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ConstraintValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintValidator<A extends Annotation,T>

  • public interface ConstraintValidator<A extends Annotation,T>
    Defines the logic to validate a given constraint A for a given object type T.

    Implementations must comply to the following restriction:

    • T must resolve to a non parameterized type
    • or generic parameters of T must be unbounded wildcard types

    The annotation SupportedValidationTarget can be put on a ConstraintValidator implementation to mark it as supporting cross-parameter constraints. Check out SupportedValidationTarget and Constraint for more information.

    Author:
    Emmanuel Bernard, Hardy Ferentschik

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void initialize(A constraintAnnotation)
      Initializes the validator in preparation for isValid(Object, ConstraintValidatorContext) calls.
      boolean isValid(T value, ConstraintValidatorContext context)
      Implements the validation logic.

    • Method Detail

      • initialize

        void initialize(A constraintAnnotation)
        Initializes the validator in preparation for isValid(Object, ConstraintValidatorContext) calls. The constraint annotation for a given constraint declaration is passed.

        This method is guaranteed to be called before any use of this instance for validation.

        Parameters:
        constraintAnnotation - annotation instance for a given constraint declaration

      • isValid

        boolean isValid(T value,
              ConstraintValidatorContext context)
        Implements the validation logic. The state of value must not be altered.

        This method can be accessed concurrently, thread-safety must be ensured by the implementation.

        Parameters:
        value - object to validate
        context - context in which the constraint is evaluated
        Returns:
        false if value does not pass the constraint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintValidatorContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintValidatorContext

  • public interface ConstraintValidatorContext
    Provides contextual data and operation when applying a given constraint validator. At least one ConstraintViolation must be defined (either the default one, of if the default ConstraintViolation is disabled, a custom one).
    Author:
    Emmanuel Bernard

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  ConstraintValidatorContext.ConstraintViolationBuilder
      ConstraintViolation builder allowing to optionally associate the violation report to a sub path.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder buildConstraintViolationWithTemplate(String messageTemplate)
      Returns a constraint violation builder building a violation report allowing to optionally associate it to a sub path.
      void disableDefaultConstraintViolation()
      Disables the default ConstraintViolation object generation (which is using the message template declared on the constraint).
      String getDefaultConstraintMessageTemplate()
      <T> T unwrap(Class<T> type)
      Returns an instance of the specified type allowing access to provider-specific APIs.

    • Method Detail

      • disableDefaultConstraintViolation

        void disableDefaultConstraintViolation()
        Disables the default ConstraintViolation object generation (which is using the message template declared on the constraint).

        Useful to set a different violation message or generate a ConstraintViolation based on a different property.

      • getDefaultConstraintMessageTemplate

        String getDefaultConstraintMessageTemplate()
        Returns:
        the current un-interpolated default message

      • buildConstraintViolationWithTemplate

        ConstraintValidatorContext.ConstraintViolationBuilder buildConstraintViolationWithTemplate(String messageTemplate)
        Returns a constraint violation builder building a violation report allowing to optionally associate it to a sub path. The violation message will be interpolated.

        To create the ConstraintViolation, one must call either one of the addConstraintViolation() methods available in one of the interfaces of the fluent API. If another method is called after addConstraintViolation() on ConstraintViolationBuilder or any of its associated nested interfaces an IllegalStateException is raised.

        If ConstraintValidator.isValid(Object, ConstraintValidatorContext) returns false, a ConstraintViolation object will be built per constraint violation report including the default one (unless disableDefaultConstraintViolation() has been called).

        ConstraintViolation objects generated from such a call contain the same contextual information (root bean, path and so on) unless the path has been overridden.

        To create a different ConstraintViolation, a new constraint violation builder has to be retrieved from ConstraintValidatorContext Here are a few usage examples:

         //assuming the following domain model
 public class User {
     public Map getAddresses() { ... }
 }

 public class Address {
     public String getStreet() { ... }
     public Country getCountry() { ... }
 }

 public class Country {
     public String getName() { ... }
 }

 //From a property-level constraint on User.addresses
 //Build a constraint violation on the default path - i.e. the "addresses" property
 context.buildConstraintViolationWithTemplate( "this detail is wrong" )
             .addConstraintViolation();

 //From a class level constraint on Address
 //Build a constraint violation on the default path + "street"
 //i.e. the street property of Address
 context.buildConstraintViolationWithTemplate( "this detail is wrong" )
             .addPropertyNode( "street" )
             .addConstraintViolation();

 //From a property-level constraint on  User.addresses
 //Build a constraint violation on the default path + the bean stored
 //under the "home" key in the map
 context.buildConstraintViolationWithTemplate( "Incorrect home address" )
             .addBeanNode()
                 .inIterable().atKey( "home" )
             .addConstraintViolation();

 //From a class level constraint on User
 //Build a constraint violation on the default path + addresses["home"].country.name
 //i.e. property "country.name" on the object stored under "home" in the map
 context.buildConstraintViolationWithTemplate( "this detail is wrong" )
             .addPropertyNode( "addresses" )
             .addPropertyNode( "country" )
                 .inIterable().atKey( "home" )
             .addPropertyNode( "name" )
             .addConstraintViolation();

        Cross-parameter constraints on a method can create a node specific to a particular parameter if required. Let's explore a few examples:

         //Cross-parameter constraint on method createUser(String password, String passwordRepeat)
 //Build a constraint violation on the default path + "passwordRepeat"
 context.buildConstraintViolationWithTemplate("Passwords do not match")
             .addParameterNode(1)
             .addConstraintViolation();

 //Cross-parameter constraint on a method
 //mergeAddresses(Map addresses, Map otherAddresses)
 //Build a constraint violation on the default path + "otherAddresses["home"]
 //i.e. the Address bean hosted in the "home" key of the "otherAddresses" map parameter
 context.buildConstraintViolationWithTemplate(
         "Map entry home present in both and does not match")
             .addParameterNode(1)
             .addBeanNode()
                 .inIterable().atKey("home")
             .addConstraintViolation();

 //Cross-parameter constraint on a method
 //mergeAddresses(Map addresses, Map otherAddresses)
 //Build a constraint violation on the default path + "otherAddresses["home"].city
 //i.e. on the "city" property of the Address bean hosted in
 //the "home" key of the "otherAddresses" map
 context.buildConstraintViolationWithTemplate(
         "Map entry home present in both but city does not match")
             .addParameterNode(1)
             .addPropertyNode("city")
                 .inIterable().atKey("home")
             .addConstraintViolation();
        Parameters:
        messageTemplate - new un-interpolated constraint message
        Returns:
        returns a constraint violation builder

      • unwrap

        <T> T unwrap(Class<T> type)
        Returns an instance of the specified type allowing access to provider-specific APIs. If the Bean Validation provider implementation does not support the specified class, ValidationException is thrown.
        Parameters:
        type - the class of the object to be returned
        Returns:
        an instance of the specified class
        Throws:
        ValidationException - if the provider does not support the call
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintValidatorContext.ConstraintViolationBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintValidatorContext.ConstraintViolationBuilder

  • Enclosing interface:
    ConstraintValidatorContext

    public static interface ConstraintValidatorContext.ConstraintViolationBuilder
    ConstraintViolation builder allowing to optionally associate the violation report to a sub path.

    To create the ConstraintViolation, one must call either one of the addConstraintViolation() methods available in one of the interfaces of the fluent API.

    If another method is called after addConstraintViolation() on ConstraintViolationBuilder or any of its associated objects an IllegalStateException is raised.

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext
      Represents a node whose context is configurable (i.e.
      static interface  ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext
      Represents a node whose context is known (i.e.
      static interface  ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder
      Represents refinement choices for a node which is in an Iterator or Map.
      static interface  ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext
      Represents a node whose context is configurable (i.e.
      static interface  ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext
      Represents a node whose context is known (i.e.
      static interface  ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder
      Represents refinement choices for a node which is in an Iterator or Map.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext addBeanNode()
      Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext addNode(String name)
      Deprecated.
      since 1.1 - replaced by addPropertyNode(String), addBeanNode() and addParameterNode(int)
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext addParameterNode(int index)
      Adds a method parameter node to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addPropertyNode(String name)
      Adds a property node to the path the ConstraintViolation will be associated to.

    • Method Detail

      • addNode

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext addNode(String name)
        Deprecated. since 1.1 - replaced by addPropertyNode(String), addBeanNode() and addParameterNode(int)
        Adds a node to the path the ConstraintViolation will be associated to.

        name describes a single property. In particular, dot (.) is not allowed.

        Parameters:
        name - property name
        Returns:
        a builder representing node name

      • addPropertyNode

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addPropertyNode(String name)
        Adds a property node to the path the ConstraintViolation will be associated to.

        name describes a single property. In particular, dot (.) is not allowed.

        Parameters:
        name - property name
        Returns:
        a builder representing node name
        Throws:
        IllegalArgumentException - if the name is null
        Since:
        1.1

      • addBeanNode

        ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext addBeanNode()
        Adds a bean node (class-level) to the path the ConstraintViolation will be associated to. Note that bean nodes are always leaf nodes.
        Returns:
        a builder representing the bean node
        Since:
        1.1

      • addParameterNode

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext addParameterNode(int index)
        Adds a method parameter node to the path the ConstraintViolation will be associated to. The parameter index must be valid (i.e. within the boundaries of the method parameter indexes). May only be called from within cross-parameter validators.
        Parameters:
        index - the parameter index
        Returns:
        a builder representing the index-th parameter node
        Throws:
        IllegalArgumentException - if the index is not valid
        Since:
        1.1

      • addConstraintViolation

        ConstraintValidatorContext addConstraintViolation()
        Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.

        Methods of this ConstraintViolationBuilder instance and its nested objects throw IllegalStateException from now on.

        Returns:
        the ConstraintValidatorContext instance the ConstraintViolationBuilder comes from
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext

  • Enclosing interface:
    ConstraintValidatorContext.ConstraintViolationBuilder

    public static interface ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext
    Represents a node whose context is configurable (i.e. index, key and isInIterable) and that is a leaf node (i.e. no subnode can be added).
    Since:
    1.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintValidatorContext addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder inIterable()
      Marks the node as being in an Iterable or a Map.

    • Method Detail

      • inIterable

        ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder inIterable()
        Marks the node as being in an Iterable or a Map.
        Returns:
        a builder representing iterable details

      • addConstraintViolation

        ConstraintValidatorContext addConstraintViolation()
        Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.

        Methods of the ConstraintViolationBuilder instance this object comes from and the constraint violation builder nested objects throw IllegalStateException after this call.

        Returns:
        ConstraintValidatorContext instance the ConstraintViolationBuilder comes from
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext

  • Enclosing interface:
    ConstraintValidatorContext.ConstraintViolationBuilder

    public static interface ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext
    Represents a node whose context is known (i.e. index, key and isInIterable) and that is a leaf node (i.e. no subnode can be added).
    Since:
    1.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintValidatorContext addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.

    • Method Detail

      • addConstraintViolation

        ConstraintValidatorContext addConstraintViolation()
        Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.

        Methods of the ConstraintViolationBuilder instance this object comes from and the constraint violation builder nested objects throw IllegalStateException after this call.

        Returns:
        ConstraintValidatorContext instance the ConstraintViolationBuilder comes from
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder

  • Enclosing interface:
    ConstraintValidatorContext.ConstraintViolationBuilder

    public static interface ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder
    Represents refinement choices for a node which is in an Iterator or Map.

    If the iterator is an indexed collection or a map, the index or the key should be set.

    The node is a leaf node (i.e. no subnode can be added).

    Since:
    1.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintValidatorContext addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext atIndex(Integer index)
      Defines the index the object is into the List or array
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext atKey(Object key)
      Defines the key the object is into the Map.

    • Method Detail

      • atKey

        ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext atKey(Object key)
        Defines the key the object is into the Map.
        Parameters:
        key - map key
        Returns:
        a builder representing the current node

      • atIndex

        ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext atIndex(Integer index)
        Defines the index the object is into the List or array
        Parameters:
        index - index
        Returns:
        a builder representing the current node

      • addConstraintViolation

        ConstraintValidatorContext addConstraintViolation()
        Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.

        Methods of the ConstraintViolationBuilder instance this object comes from and the constraint violation builder nested objects throw IllegalStateException after this call.

        Returns:
        ConstraintValidatorContext instance the ConstraintViolationBuilder comes from
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext

  • Enclosing interface:
    ConstraintValidatorContext.ConstraintViolationBuilder

    public static interface ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext
    Represents a node whose context is configurable (i.e. index, key and isInIterable) and that is not necessarily a leaf node (i.e. subnodes can be added).

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext addBeanNode()
      Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addNode(String name)
      Deprecated.
      since 1.1 - replaced by addPropertyNode(String) and addBeanNode()
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addPropertyNode(String name)
      Adds a property node to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder inIterable()
      Marks the node as being in an Iterable or a Map.

    • Method Detail

      • inIterable

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder inIterable()
        Marks the node as being in an Iterable or a Map.
        Returns:
        a builder representing iterable details

      • addNode

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addNode(String name)
        Deprecated. since 1.1 - replaced by addPropertyNode(String) and addBeanNode()
        Adds a node to the path the ConstraintViolation will be associated to. name describes a single property. In particular, dot (.) is not allowed.
        Parameters:
        name - property name
        Returns:
        a builder representing node name

      • addPropertyNode

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addPropertyNode(String name)
        Adds a property node to the path the ConstraintViolation will be associated to. name describes a single property. In particular, dot (.) is not allowed.
        Parameters:
        name - property name
        Returns:
        a builder representing node name
        Throws:
        IllegalArgumentException - if the name is null
        Since:
        1.1

      • addBeanNode

        ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext addBeanNode()
        Adds a bean node (class-level) to the path the ConstraintViolation will be associated to. Note that bean nodes are always leaf nodes.
        Returns:
        a builder representing the bean node
        Since:
        1.1

      • addConstraintViolation

        ConstraintValidatorContext addConstraintViolation()
        Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.

        Methods of the ConstraintViolationBuilder instance this object comes from and the constraint violation builder nested objects throw IllegalStateException after this call.

        Returns:
        ConstraintValidatorContext instance the ConstraintViolationBuilder comes from
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext

  • Enclosing interface:
    ConstraintValidatorContext.ConstraintViolationBuilder

    public static interface ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext
    Represents a node whose context is known (i.e. index, key and isInIterable) and that is not necessarily a leaf node (i.e. subnodes can be added).

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext addBeanNode()
      Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addNode(String name)
      Deprecated.
      since 1.1 - replaced by addPropertyNode(String) and addBeanNode()
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addPropertyNode(String name)
      Adds a property node to the path the ConstraintViolation will be associated to.

    • Method Detail

      • addNode

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addNode(String name)
        Deprecated. since 1.1 - replaced by addPropertyNode(String) and addBeanNode()
        Adds a node to the path the ConstraintViolation will be associated to.

        name describes a single property. In particular, dot (.) is not allowed.

        Parameters:
        name - property name
        Returns:
        a builder representing node name

      • addPropertyNode

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addPropertyNode(String name)
        Adds a property node to the path the ConstraintViolation will be associated to.

        name describes a single property. In particular, dot (.) is not allowed.

        Parameters:
        name - property name
        Returns:
        a builder representing node name
        Throws:
        IllegalArgumentException - if the name is null
        Since:
        1.1

      • addBeanNode

        ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext addBeanNode()
        Adds a bean node (class-level) to the path the ConstraintViolation will be associated to. Note that bean nodes are always leaf nodes.
        Returns:
        a builder representing the bean node
        Since:
        1.1

      • addConstraintViolation

        ConstraintValidatorContext addConstraintViolation()
        Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.

        Methods of the ConstraintViolationBuilder instance this object comes from and the constraint violation builder nested objects throw IllegalStateException after this call.

        Returns:
        ConstraintValidatorContext instance the ConstraintViolationBuilder comes from
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder

  • Enclosing interface:
    ConstraintValidatorContext.ConstraintViolationBuilder

    public static interface ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder
    Represents refinement choices for a node which is in an Iterator or Map.

    If the iterator is an indexed collection or a map, the index or the key should be set.

    The node is not necessarily a leaf node (i.e. subnodes can be added).

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext addBeanNode()
      Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addNode(String name)
      Deprecated.
      since 1.1 - replaced by addPropertyNode(String) and addBeanNode()
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addPropertyNode(String name)
      Adds a property node to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext atIndex(Integer index)
      Defines the index the object is into the List or array.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext atKey(Object key)
      Defines the key the object is into the Map.

    • Method Detail

      • atKey

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext atKey(Object key)
        Defines the key the object is into the Map.
        Parameters:
        key - map key
        Returns:
        a builder representing the current node

      • atIndex

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext atIndex(Integer index)
        Defines the index the object is into the List or array.
        Parameters:
        index - index
        Returns:
        a builder representing the current node

      • addNode

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addNode(String name)
        Deprecated. since 1.1 - replaced by addPropertyNode(String) and addBeanNode()
        Adds a node to the path the ConstraintViolation will be associated to. name describes a single property. In particular, dot (.) is not allowed.
        Parameters:
        name - property name
        Returns:
        a builder representing node name

      • addPropertyNode

        ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext addPropertyNode(String name)
        Adds a property node to the path the ConstraintViolation will be associated to. name describes a single property. In particular, dot (.) is not allowed.
        Parameters:
        name - property name
        Returns:
        a builder representing node name
        Throws:
        IllegalArgumentException - if the name is null
        Since:
        1.1

      • addBeanNode

        ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext addBeanNode()
        Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.

        Note that bean nodes are always leaf nodes.

        Returns:
        a builder representing the bean node
        Since:
        1.1

      • addConstraintViolation

        ConstraintValidatorContext addConstraintViolation()
        Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.

        Methods of the ConstraintViolationBuilder instance this object comes from and the constraint violation builder nested objects throw IllegalStateException after this call.

        Returns:
        ConstraintValidatorContext instance the ConstraintViolationBuilder comes from
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintValidatorFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintValidatorFactory

  • public interface ConstraintValidatorFactory
    Instantiates a ConstraintValidator instance based off its class. The ConstraintValidatorFactory is not responsible for calling ConstraintValidator.initialize(java.lang.annotation.Annotation).
    Author:
    Dhanji R. Prasanna, Emmanuel Bernard, Hardy Ferentschik

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T extends ConstraintValidator<?,?>>
      T             		getInstance(Class<T> key)
      void releaseInstance(ConstraintValidator<?,?> instance)
      Signals ConstraintValidatorFactory that the instance is no longer being used by the Bean Validation provider.

    • Method Detail

      • getInstance

        <T extends ConstraintValidator<?,?>> T getInstance(Class<T> key)
        Parameters:
        key - The class of the constraint validator to instantiate
        Returns:
        A new constraint validator instance of the specified class

      • releaseInstance

        void releaseInstance(ConstraintValidator<?,?> instance)
        Signals ConstraintValidatorFactory that the instance is no longer being used by the Bean Validation provider.
        Parameters:
        instance - validator being released
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintViolation (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ConstraintViolation<T>

  • public interface ConstraintViolation<T>
    Describes a constraint violation. This object exposes the constraint violation context as well as the message describing the violation.
    Author:
    Emmanuel Bernard

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintDescriptor<?> getConstraintDescriptor()
      Returns the constraint metadata reported to fail.
      Object[] getExecutableParameters()
      Returns an Object[] representing the constructor or method invocation arguments if the ConstraintViolation is returned after validating the method or constructor parameters.
      Object getExecutableReturnValue()
      Returns the return value of the constructor or method invocation if the ConstraintViolation is returned after validating the method or constructor return value.
      Object getInvalidValue()
      Returns the value failing to pass the constraint.
      Object getLeafBean()
      Returns: the bean instance the constraint is applied on if it is a bean constraint the bean instance hosting the property the constraint is applied on if it is a property constraint null when the ConstraintViolation is returned after calling Validator.validateValue(Class, String, Object, Class[]) the object the method is executed on if it is a method parameter, cross-parameter or return value constraint null if it is a constructor parameter or cross-parameter constraint the object the constructor has created if it is a constructor return value constraint
      String getMessage()
      String getMessageTemplate()
      Path getPropertyPath()
      T getRootBean()
      Returns the root bean being validated.
      Class<T> getRootBeanClass()
      Returns the class of the root bean being validated.
      <U> U unwrap(Class<U> type)
      Returns an instance of the specified type allowing access to provider-specific APIs.

    • Method Detail

      • getMessage

        String getMessage()
        Returns:
        the interpolated error message for this constraint violation

      • getMessageTemplate

        String getMessageTemplate()
        Returns:
        the non-interpolated error message for this constraint violation

      • getRootBean

        T getRootBean()
        Returns the root bean being validated. For method validation, returns the object the method is executed on.

        Returns null when:

        • the ConstraintViolation is returned after calling Validator.validateValue(Class, String, Object, Class[])
        • the ConstraintViolation is returned after validating a constructor.
        Returns:
        the validated object, the object hosting the validated element or null

      • getRootBeanClass

        Class<T> getRootBeanClass()
        Returns the class of the root bean being validated. For method validation, this is the object class the method is executed on. For constructor validation, this is the class the constructor is declared on.
        Returns:
        the class of the root bean or of the object hosting the validated element

      • getLeafBean

        Object getLeafBean()
        Returns:
        • the bean instance the constraint is applied on if it is a bean constraint
        • the bean instance hosting the property the constraint is applied on if it is a property constraint
        • null when the ConstraintViolation is returned after calling Validator.validateValue(Class, String, Object, Class[])
        • the object the method is executed on if it is a method parameter, cross-parameter or return value constraint
        • null if it is a constructor parameter or cross-parameter constraint
        • the object the constructor has created if it is a constructor return value constraint
        Returns:
        the leaf bean

      • getExecutableParameters

        Object[] getExecutableParameters()
        Returns an Object[] representing the constructor or method invocation arguments if the ConstraintViolation is returned after validating the method or constructor parameters. Returns null otherwise.
        Returns:
        parameters of the method or constructor invocation or null
        Since:
        1.1

      • getExecutableReturnValue

        Object getExecutableReturnValue()
        Returns the return value of the constructor or method invocation if the ConstraintViolation is returned after validating the method or constructor return value.

        Returns null if the method has no return value. Returns null otherwise.

        Returns:
        the method or constructor return value or null
        Since:
        1.1

      • getPropertyPath

        Path getPropertyPath()
        Returns:
        the property path to the value from rootBean

      • getInvalidValue

        Object getInvalidValue()
        Returns the value failing to pass the constraint. For cross-parameter constraints, an Object[] representing the method invocation arguments is returned.
        Returns:
        the value failing to pass the constraint

      • getConstraintDescriptor

        ConstraintDescriptor<?> getConstraintDescriptor()
        Returns the constraint metadata reported to fail. The returned instance is immutable.
        Returns:
        constraint metadata

      • unwrap

        <U> U unwrap(Class<U> type)
        Returns an instance of the specified type allowing access to provider-specific APIs. If the Bean Validation provider implementation does not support the specified class, ValidationException is thrown.
        Parameters:
        type - the class of the object to be returned
        Returns:
        an instance of the specified class
        Throws:
        ValidationException - if the provider does not support the call
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintViolationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Class ConstraintViolationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.validation.ValidationException
            • javax.validation.ConstraintViolationException
  • All Implemented Interfaces:
    Serializable

    public class ConstraintViolationException
extends ValidationException
    Reports the result of constraint violations.
    Author:
    Emmanuel Bernard, Gunnar Morling
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ConstraintViolationException(Set<? extends ConstraintViolation<?>> constraintViolations)
      Creates a constraint violation report.
      ConstraintViolationException(String message, Set<? extends ConstraintViolation<?>> constraintViolations)
      Creates a constraint violation report.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<ConstraintViolation<?>> getConstraintViolations()
      Set of constraint violations reported during a validation.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ConstraintViolationException

        public ConstraintViolationException(String message,
                            Set<? extends ConstraintViolation<?>> constraintViolations)
        Creates a constraint violation report.
        Parameters:
        message - error message
        constraintViolations - Set of ConstraintViolation

      • ConstraintViolationException

        public ConstraintViolationException(Set<? extends ConstraintViolation<?>> constraintViolations)
        Creates a constraint violation report.
        Parameters:
        constraintViolations - Set of ConstraintViolation

    • Method Detail

      • getConstraintViolations

        public Set<ConstraintViolation<?>> getConstraintViolations()
        Set of constraint violations reported during a validation.
        Returns:
        Set of ConstraintViolation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ElementKind (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.validation

Enum ElementKind

  • java.lang.Object
    • java.lang.Enum<ElementKind>
      • javax.validation.ElementKind
  • All Implemented Interfaces:
    Serializable, Comparable<ElementKind>

    public enum ElementKind
extends Enum<ElementKind>
    Enum of possible kinds of elements encountered in Bean Validation.

    Mostly elements that can be constrained and described in the metadata but also elements that can be part of a Path and represented by a Path.Node

    Since:
    1.1
    Author:
    Emmanuel Bernard, Gunnar Morling

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BEAN
      A Java Bean or object.
      CONSTRUCTOR
      A constructor.
      CROSS_PARAMETER
      Element holding cross-parameter constraints of a method or constructor.
      METHOD
      A method.
      PARAMETER
      A parameter of a method or constructor.
      PROPERTY
      A property of a Java Bean.
      RETURN_VALUE
      The return value of a method or constructor.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ElementKind valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ElementKind[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BEAN

        public static final ElementKind BEAN
        A Java Bean or object.

      • PROPERTY

        public static final ElementKind PROPERTY
        A property of a Java Bean.

      • METHOD

        public static final ElementKind METHOD
        A method.

      • CONSTRUCTOR

        public static final ElementKind CONSTRUCTOR
        A constructor.

      • PARAMETER

        public static final ElementKind PARAMETER
        A parameter of a method or constructor.

      • CROSS_PARAMETER

        public static final ElementKind CROSS_PARAMETER
        Element holding cross-parameter constraints of a method or constructor.

      • RETURN_VALUE

        public static final ElementKind RETURN_VALUE
        The return value of a method or constructor.

    • Method Detail

      • values

        public static ElementKind[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ElementKind c : ElementKind.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ElementKind valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


GroupDefinitionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Class GroupDefinitionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.validation.ValidationException
            • javax.validation.GroupDefinitionException
  • All Implemented Interfaces:
    Serializable

    public class GroupDefinitionException
extends ValidationException
    Exception raised if a group definition is not legal.
    Author:
    Emmanuel Bernard
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      GroupDefinitionException()
      GroupDefinitionException(String message)
      GroupDefinitionException(String message, Throwable cause)
      GroupDefinitionException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • GroupDefinitionException

        public GroupDefinitionException(String message)

      • GroupDefinitionException

        public GroupDefinitionException()

      • GroupDefinitionException

        public GroupDefinitionException(String message,
                        Throwable cause)

      • GroupDefinitionException

        public GroupDefinitionException(Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


GroupSequence (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation

Annotation Type GroupSequence

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface GroupSequence
    Defines group sequence.

    The interface hosting @GroupSequence is representing the group sequence. When hosted on a class, represents the Default group for that class.

    Author:
    Emmanuel Bernard, Hardy Ferentschik

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<?>[] value

    • Element Detail

      • value

        public abstract Class<?>[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.validation (Java(TM) EE 7 Specification APIs)

javax.validation

Interfaces

  • BootstrapConfiguration
  • Configuration
  • ConstraintValidator
  • ConstraintValidatorContext
  • ConstraintValidatorContext.ConstraintViolationBuilder
  • ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext
  • ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext
  • ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder
  • ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext
  • ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext
  • ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder
  • ConstraintValidatorFactory
  • ConstraintViolation
  • MessageInterpolator
  • MessageInterpolator.Context
  • ParameterNameProvider
  • Path
  • Path.BeanNode
  • Path.ConstructorNode
  • Path.CrossParameterNode
  • Path.MethodNode
  • Path.Node
  • Path.ParameterNode
  • Path.PropertyNode
  • Path.ReturnValueNode
  • Payload
  • TraversableResolver
  • ValidationProviderResolver
  • Validator
  • ValidatorContext
  • ValidatorFactory

Classes

  • Validation

Enums

  • ConstraintTarget
  • ElementKind

Exceptions

  • ConstraintDeclarationException
  • ConstraintDefinitionException
  • ConstraintViolationException
  • GroupDefinitionException
  • UnexpectedTypeException
  • ValidationException

Annotation Types

  • Constraint
  • GroupSequence
  • OverridesAttribute
  • OverridesAttribute.List
  • ReportAsSingleViolation
  • Valid


javax.validation (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.validation

Top level package of the Bean Validation API.

See: Description

  • Interface Summary
    Interface Description
    BootstrapConfiguration
    Represents the user specified default configuration in META-INF/validation.xml.
    Configuration<T extends Configuration<T>>
    Receives configuration information, selects the appropriate Bean Validation provider and builds the appropriate ValidatorFactory.
    ConstraintValidator<A extends Annotation,T>
    Defines the logic to validate a given constraint A for a given object type T.
    ConstraintValidatorContext
    Provides contextual data and operation when applying a given constraint validator.
    ConstraintValidatorContext.ConstraintViolationBuilder
    ConstraintViolation builder allowing to optionally associate the violation report to a sub path.
    ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext
    Represents a node whose context is configurable (i.e.
    ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext
    Represents a node whose context is known (i.e.
    ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder
    Represents refinement choices for a node which is in an Iterator or Map.
    ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext
    Represents a node whose context is configurable (i.e.
    ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext
    Represents a node whose context is known (i.e.
    ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder
    Represents refinement choices for a node which is in an Iterator or Map.
    ConstraintValidatorFactory
    Instantiates a ConstraintValidator instance based off its class.
    ConstraintViolation<T>
    Describes a constraint violation.
    MessageInterpolator
    Interpolates a given constraint violation message.
    MessageInterpolator.Context
    Information related to the interpolation context.
    ParameterNameProvider
    Provides names for method and constructor parameters.
    Path
    Represents the navigation path from an object to another in an object graph.
    Path.BeanNode
    Node representing a bean.
    Path.ConstructorNode
    Node representing a constructor.
    Path.CrossParameterNode
    Node representing the element holding cross-parameter constraints of a method or constructor.
    Path.MethodNode
    Node representing a method.
    Path.Node
    Represents an element of a navigation path.
    Path.ParameterNode
    Node representing a parameter of a method or constructor.
    Path.PropertyNode
    Node representing a property.
    Path.ReturnValueNode
    Node representing the return value of a method or constructor.
    Payload
    Payload type that can be attached to a given constraint declaration.
    TraversableResolver
    Contract determining if a property can be accessed by the Bean Validation provider.
    ValidationProviderResolver
    Determines the list of Bean Validation providers available in the runtime environment

    Bean Validation providers are identified by the presence of META-INF/services/javax.validation.spi.ValidationProvider files following the Service Provider pattern described here.
    Validator
    Validates bean instances.
    ValidatorContext
    Represents the context that is used to create Validator instances.
    ValidatorFactory
    Factory returning initialized Validator instances.
  • Class Summary
    Class Description
    Validation
    This class is the entry point for Bean Validation.
  • Enum Summary
    Enum Description
    ConstraintTarget
    Defines the constraint target.
    ElementKind
    Enum of possible kinds of elements encountered in Bean Validation.
  • Exception Summary
    Exception Description
    ConstraintDeclarationException
    Exception raised if a constraint declaration is not legal.
    ConstraintDefinitionException
    Exception raised if a constraint definition is not legal.
    ConstraintViolationException
    Reports the result of constraint violations.
    GroupDefinitionException
    Exception raised if a group definition is not legal.
    UnexpectedTypeException
    Exception raised in the case that the constraint validator resolution cannot determine a suitable validator for a given type.
    ValidationException
    Base exception of all Bean Validation "unexpected" problems.
  • Annotation Types Summary
    Annotation Type Description
    Constraint
    Marks an annotation as being a Bean Validation constraint.
    GroupSequence
    Defines group sequence.
    OverridesAttribute
    Marks an attribute as overriding the attribute of a composing constraint.
    OverridesAttribute.List
    Defines several OverridesAttribute annotations on the same element
    ReportAsSingleViolation
    A constraint annotation hosting this annotation will return the composed annotation error report if any of the composing annotations fail.
    Valid
    Marks a property, method parameter or method return type for validation cascading.

Package javax.validation Description

Top level package of the Bean Validation API. The main runtime artifacts are:
  • Validation: the entry point to bootstrap Bean Validation
  • ValidatorFactory: the bootstrapped Bean Validation engine
  • Validator: contract to validate beans and access the metadata
  • ConstraintViolation: constraint violation report
The main constraint definition artifacts are:
  • Constraint: annotation marking an annotation as being a constraint
  • ConstraintValidator: interface implemented by the piece of code validating a given constraint
  • ReportAsSingleViolation: marks a composed constraint as returning a single constraint violation report
The main constraint declaration artifacts are:
  • Valid: annotation marking an association as cascaded during validation
  • GroupSequence: defines a sequence of groups that should be validated sequentially
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.validation Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.validation

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.validation.ValidationException
            • javax.validation.ConstraintDeclarationException
              • javax.validation.UnexpectedTypeException
            • javax.validation.ConstraintDefinitionException
            • javax.validation.ConstraintViolationException
            • javax.validation.GroupDefinitionException
    • javax.validation.Validation

Interface Hierarchy

  • javax.validation.BootstrapConfiguration
  • javax.validation.Configuration<T>
  • javax.validation.ConstraintValidator<A,T>
  • javax.validation.ConstraintValidatorContext
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder
  • javax.validation.ConstraintValidatorFactory
  • javax.validation.ConstraintViolation<T>
  • java.lang.Iterable<T>
    • javax.validation.Path
  • javax.validation.MessageInterpolator
  • javax.validation.MessageInterpolator.Context
  • javax.validation.ParameterNameProvider
  • javax.validation.Path.Node
    • javax.validation.Path.BeanNode
    • javax.validation.Path.ConstructorNode
    • javax.validation.Path.CrossParameterNode
    • javax.validation.Path.MethodNode
    • javax.validation.Path.ParameterNode
    • javax.validation.Path.PropertyNode
    • javax.validation.Path.ReturnValueNode
  • javax.validation.Payload
  • javax.validation.TraversableResolver
  • javax.validation.ValidationProviderResolver
  • javax.validation.Validator
  • javax.validation.ValidatorContext
  • javax.validation.ValidatorFactory

Annotation Type Hierarchy

  • javax.validation.Valid (implements java.lang.annotation.Annotation)
  • javax.validation.ReportAsSingleViolation (implements java.lang.annotation.Annotation)
  • javax.validation.OverridesAttribute (implements java.lang.annotation.Annotation)
  • javax.validation.OverridesAttribute.List (implements java.lang.annotation.Annotation)
  • javax.validation.GroupSequence (implements java.lang.annotation.Annotation)
  • javax.validation.Constraint (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.validation.ElementKind
      • javax.validation.ConstraintTarget
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MessageInterpolator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface MessageInterpolator

  • public interface MessageInterpolator
    Interpolates a given constraint violation message.

    Implementations should be as tolerant as possible on syntax errors. Implementations must be thread-safe.

    Author:
    Emmanuel Bernard, Hardy Ferentschik

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  MessageInterpolator.Context
      Information related to the interpolation context.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String interpolate(String messageTemplate, MessageInterpolator.Context context)
      Interpolates the message template based on the constraint validation context.
      String interpolate(String messageTemplate, MessageInterpolator.Context context, Locale locale)
      Interpolates the message template based on the constraint validation context.

    • Method Detail

      • interpolate

        String interpolate(String messageTemplate,
                 MessageInterpolator.Context context)
        Interpolates the message template based on the constraint validation context.

        The locale is defaulted according to the MessageInterpolator implementation. See the implementation documentation for more detail.

        Parameters:
        messageTemplate - the message to interpolate
        context - contextual information related to the interpolation
        Returns:
        interpolated error message

      • interpolate

        String interpolate(String messageTemplate,
                 MessageInterpolator.Context context,
                 Locale locale)
        Interpolates the message template based on the constraint validation context. The Locale used is provided as a parameter.
        Parameters:
        messageTemplate - the message to interpolate
        context - contextual information related to the interpolation
        locale - the locale targeted for the message
        Returns:
        interpolated error message
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageInterpolator.Context (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface MessageInterpolator.Context

  • Enclosing interface:
    MessageInterpolator

    public static interface MessageInterpolator.Context
    Information related to the interpolation context.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintDescriptor<?> getConstraintDescriptor()
      Object getValidatedValue()
      <T> T unwrap(Class<T> type)
      Returns an instance of the specified type allowing access to provider-specific APIs.

    • Method Detail

      • getConstraintDescriptor

        ConstraintDescriptor<?> getConstraintDescriptor()
        Returns:
        ConstraintDescriptor corresponding to the constraint being validated

      • getValidatedValue

        Object getValidatedValue()
        Returns:
        value being validated

      • unwrap

        <T> T unwrap(Class<T> type)
        Returns an instance of the specified type allowing access to provider-specific APIs. If the Bean Validation provider implementation does not support the specified class, ValidationException is thrown.
        Parameters:
        type - the class of the object to be returned
        Returns:
        an instance of the specified class
        Throws:
        ValidationException - if the provider does not support the call
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


OverridesAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation

Annotation Type OverridesAttribute

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface OverridesAttribute
    Marks an attribute as overriding the attribute of a composing constraint. Both attributes must share the same type.
    Author:
    Emmanuel Bernard

    • Required Element Summary

      Required Elements
      Modifier and Type | Required Element and Description
      Class<? extends Annotation> | constraint
      String name
      Name of the Constraint attribute overridden.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      int constraintIndex
      The index of the targeted constraint declaration when using multiple constraints of the same type.

    • Element Detail

      • constraint

        public abstract Class<? extends Annotation> constraint
        Returns:
        constraint type the attribute is overriding

      • name

        public abstract String name
        Name of the Constraint attribute overridden. Defaults to the name of the attribute hosting @OverridesAttribute.
        Returns:
        name of constraint attribute overridden

      • constraintIndex

        public abstract int constraintIndex
        The index of the targeted constraint declaration when using multiple constraints of the same type.

        The index represents the index of the constraint in the value() array.

        By default, no index is defined and the single constraint declaration is targeted.

        Returns:
        constraint declaration index if multivalued annotation is used
        Default:
        -1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


OverridesAttribute.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation

Annotation Type OverridesAttribute.List

  • @Documented
@Target(value=METHOD)
@Retention(value=RUNTIME)
public static @interface OverridesAttribute.List
    Defines several OverridesAttribute annotations on the same element
    See Also:
    OverridesAttribute

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      OverridesAttribute[] value

    • Element Detail

      • value

        public abstract OverridesAttribute[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ParameterNameProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ParameterNameProvider

  • public interface ParameterNameProvider
    Provides names for method and constructor parameters.

    Used by the Bean Validation runtime when creating constraint violation objects for violated method constraints.

    Implementations must be thread-safe.

    Since:
    1.1
    Author:
    Gunnar Morling

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<String> getParameterNames(Constructor<?> constructor)
      Returns the names of the parameters of the given constructor.
      List<String> getParameterNames(Method method)
      Returns the names of the parameters of the given method.

    • Method Detail

      • getParameterNames

        List<String> getParameterNames(Constructor<?> constructor)
        Returns the names of the parameters of the given constructor.
        Parameters:
        constructor - the constructor for which the parameter names shall be retrieved; never null
        Returns:
        a list containing the names of the parameters of the given constructor; may be empty but never null

      • getParameterNames

        List<String> getParameterNames(Method method)
        Returns the names of the parameters of the given method.
        Parameters:
        method - the method for which the parameter names shall be retrieved; never null
        Returns:
        a list containing the names of the parameters of the given method; may be empty but never null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Path (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Path

  • All Superinterfaces:
    Iterable<Path.Node>

    public interface Path
extends Iterable<Path.Node>
    Represents the navigation path from an object to another in an object graph. Each path element is represented by a Node.

    The path corresponds to the succession of nodes in the order they are returned by the Iterator.

    Author:
    Emmanuel Bernard, Gunnar Morling

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  Path.BeanNode
      Node representing a bean.
      static interface  Path.ConstructorNode
      Node representing a constructor.
      static interface  Path.CrossParameterNode
      Node representing the element holding cross-parameter constraints of a method or constructor.
      static interface  Path.MethodNode
      Node representing a method.
      static interface  Path.Node
      Represents an element of a navigation path.
      static interface  Path.ParameterNode
      Node representing a parameter of a method or constructor.
      static interface  Path.PropertyNode
      Node representing a property.
      static interface  Path.ReturnValueNode
      Node representing the return value of a method or constructor.

    • Method Summary

      • Methods inherited from interface java.lang.Iterable

        iterator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Path.BeanNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Path.BeanNode

  • All Superinterfaces:
    Path.Node
    Enclosing interface:
    Path

    public static interface Path.BeanNode
extends Path.Node
    Node representing a bean.
    Since:
    1.1

    • Method Summary

      • Methods inherited from interface javax.validation.Path.Node

        as, getIndex, getKey, getKind, getName, isInIterable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Path.ConstructorNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Path.ConstructorNode

  • All Superinterfaces:
    Path.Node
    Enclosing interface:
    Path

    public static interface Path.ConstructorNode
extends Path.Node
    Node representing a constructor.
    Since:
    1.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<Class<?>> getParameterTypes()

      • Methods inherited from interface javax.validation.Path.Node

        as, getIndex, getKey, getKind, getName, isInIterable

    • Method Detail

      • getParameterTypes

        List<Class<?>> getParameterTypes()
        Returns:
        the list of parameter types
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Path.CrossParameterNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Path.CrossParameterNode

  • All Superinterfaces:
    Path.Node
    Enclosing interface:
    Path

    public static interface Path.CrossParameterNode
extends Path.Node
    Node representing the element holding cross-parameter constraints of a method or constructor.
    Since:
    1.1

    • Method Summary

      • Methods inherited from interface javax.validation.Path.Node

        as, getIndex, getKey, getKind, getName, isInIterable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Path.MethodNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Path.MethodNode

  • All Superinterfaces:
    Path.Node
    Enclosing interface:
    Path

    public static interface Path.MethodNode
extends Path.Node
    Node representing a method.
    Since:
    1.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<Class<?>> getParameterTypes()

      • Methods inherited from interface javax.validation.Path.Node

        as, getIndex, getKey, getKind, getName, isInIterable

    • Method Detail

      • getParameterTypes

        List<Class<?>> getParameterTypes()
        Returns:
        the list of parameter types
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Path.Node (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Path.Node

  • All Known Subinterfaces:
    Path.BeanNode, Path.ConstructorNode, Path.CrossParameterNode, Path.MethodNode, Path.ParameterNode, Path.PropertyNode, Path.ReturnValueNode
    Enclosing interface:
    Path

    public static interface Path.Node
    Represents an element of a navigation path.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      <T extends Path.Node>
      T             		as(Class<T> nodeType)
      Narrows the type of this node down to the given type.
      Integer getIndex()
      Object getKey()
      ElementKind getKind()
      The kind of element represented by the node.
      String getName()
      Returns the name of the element which the node represents: null if it is a leaf node which represents an entity / bean.
      boolean | isInIterable()

    • Method Detail

      • getName

        String getName()
        Returns the name of the element which the node represents:
        • null if it is a leaf node which represents an entity / bean. In particular, the node representing the root object.
        • The property name for a property.
        • The method name for a method.
        • The unqualified name of the type declaring the constructor for a constructor.
        • The parameter named as defined by the ParameterNameProvider for a method or constructor parameter.
        • The literal <cross-parameter> for a method or constructor cross-parameter.
        • The literal <return value> for a method or constructor return value.
        Returns:
        name of the element which the node represents

      • isInIterable

        boolean isInIterable()
        Returns:
        true if the node represents an object contained in an Iterable or in a Map, false otherwise

      • getIndex

        Integer getIndex()
        Returns:
        the index the node is placed in if contained in an array or List; null otherwise

      • getKey

        Object getKey()
        Returns:
        the key the node is placed in if contained in a Map, null otherwise

      • getKind

        ElementKind getKind()
        The kind of element represented by the node. The following relationship between an ElementKind and its Node subtype exists:
        • ElementKind.BEAN: Path.BeanNode
        • ElementKind.PROPERTY: Path.PropertyNode
        • ElementKind.METHOD: Path.MethodNode
        • ElementKind.CONSTRUCTOR: Path.ConstructorNode
        • ElementKind.PARAMETER: Path.ParameterNode
        • ElementKind.CROSS_PARAMETER: Path.CrossParameterNode
        • ElementKind.RETURN_VALUE: Path.ReturnValueNode

        This is useful to narrow down the Node type and access node specific information:

         switch(node.getKind() {
 case METHOD:
     name = node.getName();
     params = node.as(MethodNode.class).getParameterTypes();
 case PARAMETER:
     index = node.as(ParameterNode.class).getParameterIndex();
 [...]
 }
        Returns:
        the ElementKind
        Since:
        1.1

      • as

        <T extends Path.Node> T as(Class<T> nodeType)
        Narrows the type of this node down to the given type. The appropriate type should be checked before by calling getKind().
        Type Parameters:
        T - the type to narrow down to
        Parameters:
        nodeType - class object representing the descriptor type to narrow down to to
        Returns:
        this node narrowed down to the given type.
        Throws:
        ClassCastException - If this node is not assignable to the type T
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Path.ParameterNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Path.ParameterNode

  • All Superinterfaces:
    Path.Node
    Enclosing interface:
    Path

    public static interface Path.ParameterNode
extends Path.Node
    Node representing a parameter of a method or constructor.
    Since:
    1.1

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      int | getParameterIndex()

      • Methods inherited from interface javax.validation.Path.Node

        as, getIndex, getKey, getKind, getName, isInIterable

    • Method Detail

      • getParameterIndex

        int getParameterIndex()
        Returns:
        the parameter index in the method or constructor definition
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Path.PropertyNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Path.PropertyNode

  • All Superinterfaces:
    Path.Node
    Enclosing interface:
    Path

    public static interface Path.PropertyNode
extends Path.Node
    Node representing a property.
    Since:
    1.1

    • Method Summary

      • Methods inherited from interface javax.validation.Path.Node

        as, getIndex, getKey, getKind, getName, isInIterable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Path.ReturnValueNode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Path.ReturnValueNode

  • All Superinterfaces:
    Path.Node
    Enclosing interface:
    Path

    public static interface Path.ReturnValueNode
extends Path.Node
    Node representing the return value of a method or constructor.
    Since:
    1.1

    • Method Summary

      • Methods inherited from interface javax.validation.Path.Node

        as, getIndex, getKey, getKind, getName, isInIterable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Payload (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Payload

  • public interface Payload
    Payload type that can be attached to a given constraint declaration.

    Payloads are typically used to carry on metadata information consumed by a validation client.

    Use of payloads is not considered portable.
    Author:
    Emmanuel Bernard, Gerhard Petracek
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ReportAsSingleViolation (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation

Annotation Type ReportAsSingleViolation

  • @Target(value=ANNOTATION_TYPE)
@Retention(value=RUNTIME)
public @interface ReportAsSingleViolation
    A constraint annotation hosting this annotation will return the composed annotation error report if any of the composing annotations fail. The error reports of each individual composing constraint are ignored.

    Note: Evaluation of composed constraints stops on the first validation error in case the composing constraint is annotated with @ReportAsSingleViolation.

    Author:
    Emmanuel Bernard
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


TraversableResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface TraversableResolver

  • public interface TraversableResolver
    Contract determining if a property can be accessed by the Bean Validation provider. This contract is called for each property that is being either validated or cascaded.

    A traversable resolver implementation must be thread-safe.

    Author:
    Emmanuel Bernard

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isCascadable(Object traversableObject, Path.Node traversableProperty, Class<?> rootBeanType, Path pathToTraversableObject, ElementType elementType)
      Determines if the Bean Validation provider is allowed to cascade validation on the bean instance returned by the property value marked as @Valid.
      boolean isReachable(Object traversableObject, Path.Node traversableProperty, Class<?> rootBeanType, Path pathToTraversableObject, ElementType elementType)
      Determines if the Bean Validation provider is allowed to reach the property state.

    • Method Detail

      • isReachable

        boolean isReachable(Object traversableObject,
                  Path.Node traversableProperty,
                  Class<?> rootBeanType,
                  Path pathToTraversableObject,
                  ElementType elementType)
        Determines if the Bean Validation provider is allowed to reach the property state.
        Parameters:
        traversableObject - object hosting traversableProperty or null if validateValue is called
        traversableProperty - the traversable property
        rootBeanType - type of the root object passed to the Validator or hosting the method or constructor validated
        pathToTraversableObject - path from the root object to traversableObject (using the path specification defined by Bean Validator)
        elementType - either FIELD or METHOD
        Returns:
        true if the Bean Validation provider is allowed to reach the property state, false otherwise

      • isCascadable

        boolean isCascadable(Object traversableObject,
                   Path.Node traversableProperty,
                   Class<?> rootBeanType,
                   Path pathToTraversableObject,
                   ElementType elementType)
        Determines if the Bean Validation provider is allowed to cascade validation on the bean instance returned by the property value marked as @Valid.

        Note that this method is called only if isReachable(Object, javax.validation.Path.Node, Class, Path, java.lang.annotation.ElementType) returns true for the same set of arguments and if the property is marked as Valid.

        Parameters:
        traversableObject - object hosting traversableProperty or null if validateValue is called
        traversableProperty - the traversable property
        rootBeanType - type of the root object passed to the Validator or hosting the method or constructor validated
        pathToTraversableObject - path from the root object to traversableObject (using the path specification defined by Bean Validator)
        elementType - either FIELD or METHOD
        Returns:
        true if the Bean Validation provider is allowed to cascade validation, false otherwise
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UnexpectedTypeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Class UnexpectedTypeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.validation.ValidationException
            • javax.validation.ConstraintDeclarationException
              • javax.validation.UnexpectedTypeException
  • All Implemented Interfaces:
    Serializable

    public class UnexpectedTypeException
extends ConstraintDeclarationException
    Exception raised in the case that the constraint validator resolution cannot determine a suitable validator for a given type.
    Author:
    Hardy Ferentschik
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      UnexpectedTypeException()
      UnexpectedTypeException(String message)
      UnexpectedTypeException(String message, Throwable cause)
      UnexpectedTypeException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnexpectedTypeException

        public UnexpectedTypeException(String message)

      • UnexpectedTypeException

        public UnexpectedTypeException()

      • UnexpectedTypeException

        public UnexpectedTypeException(String message,
                       Throwable cause)

      • UnexpectedTypeException

        public UnexpectedTypeException(Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.validation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.validation

  • Packages that use javax.validation
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.bootstrap
    Package containing bootstrap specific objects.
    javax.validation.constraints
    Contains all the Bean Validation provided constraints also called built-in constraints.
    javax.validation.executable
    Package related to the control and execution of executable validation.
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.
  • Classes in javax.validation used by javax.validation
    Class and Description
    BootstrapConfiguration
    Represents the user specified default configuration in META-INF/validation.xml.
    Configuration
    Receives configuration information, selects the appropriate Bean Validation provider and builds the appropriate ValidatorFactory.
    ConstraintDeclarationException
    Exception raised if a constraint declaration is not legal.
    ConstraintTarget
    Defines the constraint target.
    ConstraintValidator
    Defines the logic to validate a given constraint A for a given object type T.
    ConstraintValidatorContext
    Provides contextual data and operation when applying a given constraint validator.
    ConstraintValidatorContext.ConstraintViolationBuilder
    ConstraintViolation builder allowing to optionally associate the violation report to a sub path.
    ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext
    Represents a node whose context is configurable (i.e.
    ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext
    Represents a node whose context is known (i.e.
    ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder
    Represents refinement choices for a node which is in an Iterator or Map.
    ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext
    Represents a node whose context is configurable (i.e.
    ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext
    Represents a node whose context is known (i.e.
    ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder
    Represents refinement choices for a node which is in an Iterator or Map.
    ConstraintValidatorFactory
    Instantiates a ConstraintValidator instance based off its class.
    ConstraintViolation
    Describes a constraint violation.
    ElementKind
    Enum of possible kinds of elements encountered in Bean Validation.
    MessageInterpolator
    Interpolates a given constraint violation message.
    MessageInterpolator.Context
    Information related to the interpolation context.
    ParameterNameProvider
    Provides names for method and constructor parameters.
    Path
    Represents the navigation path from an object to another in an object graph.
    Path.Node
    Represents an element of a navigation path.
    TraversableResolver
    Contract determining if a property can be accessed by the Bean Validation provider.
    ValidationException
    Base exception of all Bean Validation "unexpected" problems.
    Validator
    Validates bean instances.
    ValidatorContext
    Represents the context that is used to create Validator instances.
    ValidatorFactory
    Factory returning initialized Validator instances.
  • Classes in javax.validation used by javax.validation.bootstrap
    Class and Description
    Configuration
    Receives configuration information, selects the appropriate Bean Validation provider and builds the appropriate ValidatorFactory.
    ValidationProviderResolver
    Determines the list of Bean Validation providers available in the runtime environment

    Bean Validation providers are identified by the presence of META-INF/services/javax.validation.spi.ValidationProvider files following the Service Provider pattern described here.
  • Classes in javax.validation used by javax.validation.constraints
    Class and Description
    Constraint
    Marks an annotation as being a Bean Validation constraint.
  • Classes in javax.validation used by javax.validation.executable
    Class and Description
    ConstraintViolation
    Describes a constraint violation.
  • Classes in javax.validation used by javax.validation.metadata
    Class and Description
    ConstraintTarget
    Defines the constraint target.
    ConstraintValidator
    Defines the logic to validate a given constraint A for a given object type T.
    Payload
    Payload type that can be attached to a given constraint declaration.
  • Classes in javax.validation used by javax.validation.spi
    Class and Description
    Configuration
    Receives configuration information, selects the appropriate Bean Validation provider and builds the appropriate ValidatorFactory.
    ConstraintValidatorFactory
    Instantiates a ConstraintValidator instance based off its class.
    MessageInterpolator
    Interpolates a given constraint violation message.
    ParameterNameProvider
    Provides names for method and constructor parameters.
    TraversableResolver
    Contract determining if a property can be accessed by the Bean Validation provider.
    ValidationProviderResolver
    Determines the list of Bean Validation providers available in the runtime environment

    Bean Validation providers are identified by the presence of META-INF/services/javax.validation.spi.ValidationProvider files following the Service Provider pattern described here.
    ValidatorFactory
    Factory returning initialized Validator instances.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Valid (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation

Annotation Type Valid

  • @Target(value={METHOD,FIELD,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
public @interface Valid
    Marks a property, method parameter or method return type for validation cascading.

    Constraints defined on the object and its properties are be validated when the property, method parameter or method return type is validated.

    This behavior is applied recursively.

    Author:
    Emmanuel Bernard, Hardy Ferentschik
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Validation (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Class Validation

  • java.lang.Object
    • javax.validation.Validation

  • public class Validation
extends Object
    This class is the entry point for Bean Validation.

    There are three ways to bootstrap it:

    • The easiest approach is to build the default ValidatorFactory.
       ValidatorFactory factory = Validation.buildDefaultValidatorFactory();
      In this case, the default validation provider resolver will be used to locate available providers.

      The chosen provider is defined as followed:

      • if the XML configuration defines a provider, this provider is used
      • if the XML configuration does not define a provider or if no XML configuration is present the first provider returned by the ValidationProviderResolver instance is used.
    • The second bootstrap approach allows to choose a custom ValidationProviderResolver. The chosen ValidationProvider is then determined in the same way as in the default bootstrapping case (see above).
       Configuration configuration = Validation
    .byDefaultProvider()
    .providerResolver( new MyResolverStrategy() )
    .configure();
 ValidatorFactory factory = configuration.buildValidatorFactory();
    • The third approach allows you to specify explicitly and in a type safe fashion the expected provider.

      Optionally you can choose a custom ValidationProviderResolver.

       ACMEConfiguration configuration = Validation
    .byProvider(ACMEProvider.class)
    .providerResolver( new MyResolverStrategy() )  // optionally set the provider resolver
    .configure();
 ValidatorFactory factory = configuration.buildValidatorFactory();

    Note:

    • The ValidatorFactory object built by the bootstrap process should be cached and shared amongst Validator consumers.
    • This class is thread-safe.
    Author:
    Emmanuel Bernard, Hardy Ferentschik

    • Constructor Summary

      Constructors
      Constructor and Description
      Validation()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ValidatorFactory buildDefaultValidatorFactory()
      Builds and returns a ValidatorFactory instance based on the default Bean Validation provider and following the XML configuration.
      static GenericBootstrap byDefaultProvider()
      Builds a Configuration.
      static <T extends Configuration<T>,U extends ValidationProvider<T>>
      ProviderSpecificBootstrap<T>             		byProvider(Class<U> providerType)
      Builds a Configuration for a particular provider implementation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Validation

        public Validation()

    • Method Detail

      • buildDefaultValidatorFactory

        public static ValidatorFactory buildDefaultValidatorFactory()
        Builds and returns a ValidatorFactory instance based on the default Bean Validation provider and following the XML configuration.

        The provider list is resolved using the default validation provider resolver logic.

        The code is semantically equivalent to Validation.byDefaultProvider().configure().buildValidatorFactory().

        Returns:
        ValidatorFactory instance
        Throws:
        ValidationException - if the ValidatorFactory cannot be built

      • byDefaultProvider

        public static GenericBootstrap byDefaultProvider()
        Builds a Configuration. The provider list is resolved using the strategy provided to the bootstrap state.
         Configuration<?> configuration = Validation
    .byDefaultProvider()
    .providerResolver( new MyResolverStrategy() )
    .configure();
 ValidatorFactory factory = configuration.buildValidatorFactory();
        The provider can be specified in the XML configuration. If the XML configuration does not exist or if no provider is specified, the first available provider will be returned.
        Returns:
        instance building a generic Configuration compliant with the bootstrap state provided

      • byProvider

        public static <T extends Configuration<T>,U extends ValidationProvider<T>> ProviderSpecificBootstrap<T> byProvider(Class<U> providerType)
        Builds a Configuration for a particular provider implementation.

        Optionally overrides the provider resolution strategy used to determine the provider.

        Used by applications targeting a specific provider programmatically.

         ACMEConfiguration configuration =
     Validation.byProvider(ACMEProvider.class)
             .providerResolver( new MyResolverStrategy() )
             .configure();
        , where ACMEConfiguration is the Configuration sub interface uniquely identifying the ACME Bean Validation provider. and ACMEProvider is the ValidationProvider implementation of the ACME provider.
        Parameters:
        providerType - the ValidationProvider implementation type
        Returns:
        instance building a provider specific Configuration sub interface implementation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Class ValidationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.validation.ValidationException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ConstraintDeclarationException, ConstraintDefinitionException, ConstraintViolationException, GroupDefinitionException

    public class ValidationException
extends RuntimeException
    Base exception of all Bean Validation "unexpected" problems.
    Author:
    Emmanuel Bernard
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidationException()
      ValidationException(String message)
      ValidationException(String message, Throwable cause)
      ValidationException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ValidationException

        public ValidationException(String message)

      • ValidationException

        public ValidationException()

      • ValidationException

        public ValidationException(String message,
                   Throwable cause)

      • ValidationException

        public ValidationException(Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidationProviderResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ValidationProviderResolver

  • public interface ValidationProviderResolver
    Determines the list of Bean Validation providers available in the runtime environment

    Bean Validation providers are identified by the presence of META-INF/services/javax.validation.spi.ValidationProvider files following the Service Provider pattern described here.

    Each META-INF/services/javax.validation.spi.ValidationProvider file contains the list of ValidationProvider implementations each of them representing a provider.

    Implementations must be thread-safe.

    Author:
    Emmanuel Bernard

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<ValidationProvider<?>> getValidationProviders()
      Returns a list of ValidationProvider available in the runtime environment.

    • Method Detail

      • getValidationProviders

        List<ValidationProvider<?>> getValidationProviders()
        Returns a list of ValidationProvider available in the runtime environment.
        Returns:
        list of validation providers
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Validator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface Validator

  • public interface Validator
    Validates bean instances. Implementations of this interface must be thread-safe.
    Author:
    Emmanuel Bernard, Hardy Ferentschik, Gunnar Morling

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ExecutableValidator forExecutables()
      Returns the contract for validating parameters and return values of methods and constructors.
      BeanDescriptor getConstraintsForClass(Class<?> clazz)
      Returns the descriptor object describing bean constraints.
      <T> T unwrap(Class<T> type)
      Returns an instance of the specified type allowing access to provider-specific APIs.
      <T> Set<ConstraintViolation<T>> validate(T object, Class<?>... groups)
      Validates all constraints on object.
      <T> Set<ConstraintViolation<T>> validateProperty(T object, String propertyName, Class<?>... groups)
      Validates all constraints placed on the property of object named propertyName.
      <T> Set<ConstraintViolation<T>> validateValue(Class<T> beanType, String propertyName, Object value, Class<?>... groups)
      Validates all constraints placed on the property named propertyName of the class beanType would the property value be value.

    • Method Detail

      • validate

        <T> Set<ConstraintViolation<T>> validate(T object,
                                       Class<?>... groups)
        Validates all constraints on object.
        Parameters:
        object - object to validate
        groups - the group or list of groups targeted for validation (defaults to Default)
        Returns:
        constraint violations or an empty set if none
        Throws:
        IllegalArgumentException - if object is null or if null is passed to the varargs groups
        ValidationException - if a non recoverable error happens during the validation process

      • validateProperty

        <T> Set<ConstraintViolation<T>> validateProperty(T object,
                                               String propertyName,
                                               Class<?>... groups)
        Validates all constraints placed on the property of object named propertyName.
        Parameters:
        object - object to validate
        propertyName - property to validate (i.e. field and getter constraints)
        groups - the group or list of groups targeted for validation (defaults to Default)
        Returns:
        constraint violations or an empty set if none
        Throws:
        IllegalArgumentException - if object is null, if propertyName is null, empty or not a valid object property or if null is passed to the varargs groups
        ValidationException - if a non recoverable error happens during the validation process

      • validateValue

        <T> Set<ConstraintViolation<T>> validateValue(Class<T> beanType,
                                            String propertyName,
                                            Object value,
                                            Class<?>... groups)
        Validates all constraints placed on the property named propertyName of the class beanType would the property value be value.

        ConstraintViolation objects return null for ConstraintViolation.getRootBean() and ConstraintViolation.getLeafBean().

        Parameters:
        beanType - the bean type
        propertyName - property to validate
        value - property value to validate
        groups - the group or list of groups targeted for validation (defaults to Default).
        Returns:
        constraint violations or an empty set if none
        Throws:
        IllegalArgumentException - if beanType is null, if propertyName is null, empty or not a valid object property or if null is passed to the varargs groups
        ValidationException - if a non recoverable error happens during the validation process

      • getConstraintsForClass

        BeanDescriptor getConstraintsForClass(Class<?> clazz)
        Returns the descriptor object describing bean constraints.

        The returned object (and associated objects including ConstraintDescriptors) are immutable.

        Parameters:
        clazz - class or interface type evaluated
        Returns:
        the bean descriptor for the specified class
        Throws:
        IllegalArgumentException - if clazz is null
        ValidationException - if a non recoverable error happens during the metadata discovery or if some constraints are invalid.

      • unwrap

        <T> T unwrap(Class<T> type)
        Returns an instance of the specified type allowing access to provider-specific APIs.

        If the Bean Validation provider implementation does not support the specified class, ValidationException is thrown.

        Parameters:
        type - the class of the object to be returned
        Returns:
        an instance of the specified class
        Throws:
        ValidationException - if the provider does not support the call

      • forExecutables

        ExecutableValidator forExecutables()
        Returns the contract for validating parameters and return values of methods and constructors.
        Returns:
        contract for method and constructor validation
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidatorContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ValidatorContext

  • public interface ValidatorContext
    Represents the context that is used to create Validator instances. A client may use methods of the ValidatorContext returned by ValidatorFactory.usingContext() to customize the context used to create Validator instances (for instance establish different message interpolators or traversable resolvers).
    Author:
    Emmanuel Bernard, Gunnar Morling

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ValidatorContext constraintValidatorFactory(ConstraintValidatorFactory factory)
      Defines the constraint validator factory implementation used by the Validator.
      Validator getValidator()
      Returns an initialized Validator instance respecting the defined state.
      ValidatorContext messageInterpolator(MessageInterpolator messageInterpolator)
      Defines the message interpolator implementation used by the Validator.
      ValidatorContext parameterNameProvider(ParameterNameProvider parameterNameProvider)
      Defines the parameter name provider implementation used by the Validator.
      ValidatorContext traversableResolver(TraversableResolver traversableResolver)
      Defines the traversable resolver implementation used by the Validator.

    • Method Detail

      • messageInterpolator

        ValidatorContext messageInterpolator(MessageInterpolator messageInterpolator)
        Defines the message interpolator implementation used by the Validator.

        If not set or if null is passed as a parameter, the message interpolator of the ValidatorFactory is used.

        Parameters:
        messageInterpolator - the MessageInterpolator used by the Validator
        Returns:
        self following the chaining method pattern

      • traversableResolver

        ValidatorContext traversableResolver(TraversableResolver traversableResolver)
        Defines the traversable resolver implementation used by the Validator.

        If not set or if null is passed as a parameter, the traversable resolver of the ValidatorFactory is used.

        Parameters:
        traversableResolver - the TraversableResolver used by the Validator
        Returns:
        self following the chaining method pattern

      • constraintValidatorFactory

        ValidatorContext constraintValidatorFactory(ConstraintValidatorFactory factory)
        Defines the constraint validator factory implementation used by the Validator. If not set or if null is passed as a parameter, the constraint validator factory of the ValidatorFactory is used.
        Parameters:
        factory - the ConstraintValidatorFactory used by the Validator
        Returns:
        self following the chaining method pattern

      • parameterNameProvider

        ValidatorContext parameterNameProvider(ParameterNameProvider parameterNameProvider)
        Defines the parameter name provider implementation used by the Validator. If not set or if null is passed as a parameter, the parameter name provider of the ValidatorFactory is used.
        Parameters:
        parameterNameProvider - parameter name provider implementation.
        Returns:
        self following the chaining method pattern
        Since:
        1.1

      • getValidator

        Validator getValidator()
        Returns an initialized Validator instance respecting the defined state. Validator instances can be pooled and shared by the implementation.
        Returns:
        contextualized Validator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidatorFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation

Interface ValidatorFactory

  • public interface ValidatorFactory
    Factory returning initialized Validator instances.

    Implementations are thread-safe and instances are typically cached and reused.

    Author:
    Emmanuel Bernard, Gunnar Morling, Hardy Ferentschik

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes the ValidatorFactory instance.
      ConstraintValidatorFactory getConstraintValidatorFactory()
      Returns the ConstraintValidatorFactory instance configured at initialization time for the ValidatorFactory.
      MessageInterpolator getMessageInterpolator()
      Returns the MessageInterpolator instance configured at initialization time for the ValidatorFactory.
      ParameterNameProvider getParameterNameProvider()
      Returns the ParameterNameProvider instance configured at initialization time for the ValidatorFactory.
      TraversableResolver getTraversableResolver()
      Returns the TraversableResolver instance configured at initialization time for the ValidatorFactory.
      Validator getValidator()
      Returns an initialized Validator instance using the factory defaults for message interpolator, traversable resolver and constraint validator factory.
      <T> T unwrap(Class<T> type)
      Returns an instance of the specified type allowing access to provider-specific APIs.
      ValidatorContext usingContext()
      Defines a new validator context and returns a Validator compliant this new context.

    • Method Detail

      • getValidator

        Validator getValidator()
        Returns an initialized Validator instance using the factory defaults for message interpolator, traversable resolver and constraint validator factory.

        Validator instances can be pooled and shared by the implementation.

        Returns:
        an initialized Validator instance

      • usingContext

        ValidatorContext usingContext()
        Defines a new validator context and returns a Validator compliant this new context.
        Returns:
        a ValidatorContext instance

      • getMessageInterpolator

        MessageInterpolator getMessageInterpolator()
        Returns the MessageInterpolator instance configured at initialization time for the ValidatorFactory. This is the instance used by getValidator().
        Returns:
        MessageInterpolator instance

      • getTraversableResolver

        TraversableResolver getTraversableResolver()
        Returns the TraversableResolver instance configured at initialization time for the ValidatorFactory. This is the instance used by getValidator().
        Returns:
        TraversableResolver instance

      • getConstraintValidatorFactory

        ConstraintValidatorFactory getConstraintValidatorFactory()
        Returns the ConstraintValidatorFactory instance configured at initialization time for the ValidatorFactory. This is the instance used by getValidator().
        Returns:
        ConstraintValidatorFactory instance

      • getParameterNameProvider

        ParameterNameProvider getParameterNameProvider()
        Returns the ParameterNameProvider instance configured at initialization time for the ValidatorFactory. This is the instance used by #getValidator().
        Returns:
        ParameterNameProvider instance
        Since:
        1.1

      • unwrap

        <T> T unwrap(Class<T> type)
        Returns an instance of the specified type allowing access to provider-specific APIs. If the Bean Validation provider implementation does not support the specified class, a ValidationException is thrown.
        Parameters:
        type - the class of the object to be returned
        Returns:
        an instance of the specified class
        Throws:
        ValidationException - if the provider does not support the call.

      • close

        void close()
        Closes the ValidatorFactory instance. After the ValidatorFactory instance is closed, calling the following methods is not allowed:
        • methods of this ValidatorFactory instance
        • methods of Validator instances created by this ValidatorFactory
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


GenericBootstrap (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.bootstrap

Interface GenericBootstrap

  • public interface GenericBootstrap
    Defines the state used to bootstrap Bean Validation and creates a provider agnostic Configuration.
    Author:
    Emmanuel Bernard

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Configuration<?> configure()
      Returns a generic Configuration implementation.
      GenericBootstrap providerResolver(ValidationProviderResolver resolver)
      Defines the provider resolution strategy.

    • Method Detail

      • providerResolver

        GenericBootstrap providerResolver(ValidationProviderResolver resolver)
        Defines the provider resolution strategy. This resolver returns the list of providers evaluated to build the Configuration.

        If no resolver is defined, the default ValidationProviderResolver implementation is used.

        Parameters:
        resolver - the ValidationProviderResolver to use for bootstrapping
        Returns:
        this following the chaining method pattern

      • configure

        Configuration<?> configure()
        Returns a generic Configuration implementation. At this stage the provider used to build the ValidatorFactory is not defined.

        The Configuration implementation is provided by the first provider returned by the ValidationProviderResolver strategy.

        Returns:
        a Configuration implementation compliant with the bootstrap state
        Throws:
        ValidationException - if the Configuration object cannot be built; this is generally due to an issue with the ValidationProviderResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.validation.bootstrap (Java(TM) EE 7 Specification APIs)

javax.validation.bootstrap

Interfaces

  • GenericBootstrap
  • ProviderSpecificBootstrap


javax.validation.bootstrap (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.validation.bootstrap

Package containing bootstrap specific objects.

See: Description

  • Interface Summary
    Interface Description
    GenericBootstrap
    Defines the state used to bootstrap Bean Validation and creates a provider agnostic Configuration.
    ProviderSpecificBootstrap<T extends Configuration<T>>
    Defines the state used to bootstrap Bean Validation and creates a provider specific Configuration of type T.

Package javax.validation.bootstrap Description

Package containing bootstrap specific objects. Typical users are not interested in these objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.validation.bootstrap Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.validation.bootstrap

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.validation.bootstrap.GenericBootstrap
  • javax.validation.bootstrap.ProviderSpecificBootstrap<T>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ProviderSpecificBootstrap (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.bootstrap

Interface ProviderSpecificBootstrap<T extends Configuration<T>>

  • public interface ProviderSpecificBootstrap<T extends Configuration<T>>
    Defines the state used to bootstrap Bean Validation and creates a provider specific Configuration of type T.

    The specific Configuration is linked to the provider via the generic parameter of the ValidationProvider implementation.

    The requested provider is the first provider instance assignable to the requested provider type (known when ProviderSpecificBootstrap is built). The list of providers evaluated is returned by ValidationProviderResolver. If no ValidationProviderResolver is defined, the default ValidationProviderResolver strategy is used.

    Author:
    Emmanuel Bernard

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T configure()
      Determines the provider implementation suitable for T and delegates the creation of this specific Configuration subclass to the provider.
      ProviderSpecificBootstrap<T> providerResolver(ValidationProviderResolver resolver)
      Optionally defines the provider resolver implementation used.

    • Method Detail

      • providerResolver

        ProviderSpecificBootstrap<T> providerResolver(ValidationProviderResolver resolver)
        Optionally defines the provider resolver implementation used. If not defined, use the default ValidationProviderResolver
        Parameters:
        resolver - ValidationProviderResolver implementation used
        Returns:
        this following the chaining method pattern

      • configure

        T configure()
        Determines the provider implementation suitable for T and delegates the creation of this specific Configuration subclass to the provider.
        Returns:
        Configuration sub interface implementation
        Throws:
        ValidationException - if the Configuration object cannot be built; this is generally due to an issue with the ValidationProviderResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.validation.bootstrap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.validation.bootstrap

  • Packages that use javax.validation.bootstrap
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.bootstrap
    Package containing bootstrap specific objects.
  • Classes in javax.validation.bootstrap used by javax.validation
    Class and Description
    GenericBootstrap
    Defines the state used to bootstrap Bean Validation and creates a provider agnostic Configuration.
    ProviderSpecificBootstrap
    Defines the state used to bootstrap Bean Validation and creates a provider specific Configuration of type T.
  • Classes in javax.validation.bootstrap used by javax.validation.bootstrap
    Class and Description
    GenericBootstrap
    Defines the state used to bootstrap Bean Validation and creates a provider agnostic Configuration.
    ProviderSpecificBootstrap
    Defines the state used to bootstrap Bean Validation and creates a provider specific Configuration of type T.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.bootstrap.GenericBootstrap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.bootstrap.GenericBootstrap

  • Packages that use GenericBootstrap
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.bootstrap
    Package containing bootstrap specific objects.

    • Uses of GenericBootstrap in javax.validation

      Methods in javax.validation that return GenericBootstrap
      Modifier and Type Method and Description
      static GenericBootstrap Validation.byDefaultProvider()
      Builds a Configuration.

    • Uses of GenericBootstrap in javax.validation.bootstrap

      Methods in javax.validation.bootstrap that return GenericBootstrap
      Modifier and Type Method and Description
      GenericBootstrap GenericBootstrap.providerResolver(ValidationProviderResolver resolver)
      Defines the provider resolution strategy.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.bootstrap.ProviderSpecificBootstrap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.bootstrap.ProviderSpecificBootstrap

  • Packages that use ProviderSpecificBootstrap
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.bootstrap
    Package containing bootstrap specific objects.

    • Uses of ProviderSpecificBootstrap in javax.validation

      Methods in javax.validation that return ProviderSpecificBootstrap
      Modifier and Type Method and Description
      static <T extends Configuration<T>,U extends ValidationProvider<T>>
      ProviderSpecificBootstrap<T>             		Validation.byProvider(Class<U> providerType)
      Builds a Configuration for a particular provider implementation.

    • Uses of ProviderSpecificBootstrap in javax.validation.bootstrap

      Methods in javax.validation.bootstrap that return ProviderSpecificBootstrap
      Modifier and Type Method and Description
      ProviderSpecificBootstrap<T> ProviderSpecificBootstrap.providerResolver(ValidationProviderResolver resolver)
      Optionally defines the provider resolver implementation used.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.Constraint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.Constraint

  • Packages that use Constraint
    Package Description
    javax.validation.constraints
    Contains all the Bean Validation provided constraints also called built-in constraints.

    • Uses of Constraint in javax.validation.constraints

      Classes in javax.validation.constraints with annotations of type Constraint
      Modifier and Type Class and Description
      interface  AssertFalse
      The annotated element must be false.
      interface  AssertTrue
      The annotated element must be true.
      interface  DecimalMax
      The annotated element must be a number whose value must be lower or equal to the specified maximum.
      interface  DecimalMin
      The annotated element must be a number whose value must be higher or equal to the specified minimum.
      interface  Digits
      The annotated element must be a number within accepted range Supported types are: BigDecimal BigInteger CharSequence byte, short, int, long, and their respective wrapper types

      null elements are considered valid.
      interface  Future
      The annotated element must be a date in the future.
      interface  Max
      The annotated element must be a number whose value must be lower or equal to the specified maximum.
      interface  Min
      The annotated element must be a number whose value must be higher or equal to the specified minimum.
      interface  NotNull
      The annotated element must not be null.
      interface  Null
      The annotated element must be null.
      interface  Past
      The annotated element must be a date in the past.
      interface  Pattern
      The annotated CharSequence must match the specified regular expression.
      interface  Size
      The annotated element size must be between the specified boundaries (included).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.ConstraintDeclarationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.ConstraintDeclarationException

  • Packages that use ConstraintDeclarationException
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ConstraintDeclarationException in javax.validation

      Subclasses of ConstraintDeclarationException in javax.validation
      Modifier and Type Class and Description
      class  UnexpectedTypeException
      Exception raised in the case that the constraint validator resolution cannot determine a suitable validator for a given type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.ConstraintDefinitionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.ConstraintDefinitionException

No usage of javax.validation.ConstraintDefinitionException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.ConstraintTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.ConstraintTarget

  • Packages that use ConstraintTarget
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of ConstraintTarget in javax.validation

      Methods in javax.validation that return ConstraintTarget
      Modifier and Type Method and Description
      static ConstraintTarget ConstraintTarget.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ConstraintTarget[] ConstraintTarget.values()
      Returns an array containing the constants of this enum type, in the order they are declared.

    • Uses of ConstraintTarget in javax.validation.metadata

      Methods in javax.validation.metadata that return ConstraintTarget
      Modifier and Type Method and Description
      ConstraintTarget ConstraintDescriptor.getValidationAppliesTo()
      The ConstraintTarget value of validationAppliesTo if the constraint hosts it or null otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.ConstraintViolationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.ConstraintViolationException

No usage of javax.validation.ConstraintViolationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.ElementKind (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.ElementKind

  • Packages that use ElementKind
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ElementKind in javax.validation

      Methods in javax.validation that return ElementKind
      Modifier and Type Method and Description
      ElementKind Path.Node.getKind()
      The kind of element represented by the node.
      static ElementKind ElementKind.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ElementKind[] ElementKind.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.GroupDefinitionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.GroupDefinitionException

No usage of javax.validation.GroupDefinitionException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.GroupSequence (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.GroupSequence

No usage of javax.validation.GroupSequence
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.OverridesAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.OverridesAttribute

No usage of javax.validation.OverridesAttribute
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.OverridesAttribute.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.OverridesAttribute.List

No usage of javax.validation.OverridesAttribute.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.ReportAsSingleViolation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.ReportAsSingleViolation

No usage of javax.validation.ReportAsSingleViolation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.UnexpectedTypeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.UnexpectedTypeException

No usage of javax.validation.UnexpectedTypeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.Valid (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.Valid

No usage of javax.validation.Valid
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.Validation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.Validation

No usage of javax.validation.Validation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.ValidationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.ValidationException

  • Packages that use ValidationException
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ValidationException in javax.validation

      Subclasses of ValidationException in javax.validation
      Modifier and Type Class and Description
      class  ConstraintDeclarationException
      Exception raised if a constraint declaration is not legal.
      class  ConstraintDefinitionException
      Exception raised if a constraint definition is not legal.
      class  ConstraintViolationException
      Reports the result of constraint violations.
      class  GroupDefinitionException
      Exception raised if a group definition is not legal.
      class  UnexpectedTypeException
      Exception raised in the case that the constraint validator resolution cannot determine a suitable validator for a given type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.BootstrapConfiguration (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.BootstrapConfiguration

  • Packages that use BootstrapConfiguration
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of BootstrapConfiguration in javax.validation

      Methods in javax.validation that return BootstrapConfiguration
      Modifier and Type Method and Description
      BootstrapConfiguration Configuration.getBootstrapConfiguration()
      Returns configuration information stored in the META-INF/validation.xml file.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Configuration (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Configuration

  • Packages that use Configuration
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.bootstrap
    Package containing bootstrap specific objects.
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

    • Uses of Configuration in javax.validation

      Classes in javax.validation with type parameters of type Configuration
      Modifier and Type Interface and Description
      interface  Configuration<T extends Configuration<T>>
      Receives configuration information, selects the appropriate Bean Validation provider and builds the appropriate ValidatorFactory.
      Methods in javax.validation with type parameters of type Configuration
      Modifier and Type Method and Description
      static <T extends Configuration<T>,U extends ValidationProvider<T>>
      ProviderSpecificBootstrap<T>             		Validation.byProvider(Class<U> providerType)
      Builds a Configuration for a particular provider implementation.

    • Uses of Configuration in javax.validation.bootstrap

      Classes in javax.validation.bootstrap with type parameters of type Configuration
      Modifier and Type Interface and Description
      interface  ProviderSpecificBootstrap<T extends Configuration<T>>
      Defines the state used to bootstrap Bean Validation and creates a provider specific Configuration of type T.
      Methods in javax.validation.bootstrap that return Configuration
      Modifier and Type Method and Description
      Configuration<?> GenericBootstrap.configure()
      Returns a generic Configuration implementation.

    • Uses of Configuration in javax.validation.spi

      Classes in javax.validation.spi with type parameters of type Configuration
      Modifier and Type Interface and Description
      interface  ValidationProvider<T extends Configuration<T>>
      Contract between the validation bootstrap mechanism and the provider engine.
      Methods in javax.validation.spi that return Configuration
      Modifier and Type Method and Description
      Configuration<?> ValidationProvider.createGenericConfiguration(BootstrapState state)
      Returns a Configuration instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintValidator

  • Packages that use ConstraintValidator
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of ConstraintValidator in javax.validation

      Methods in javax.validation with type parameters of type ConstraintValidator
      Modifier and Type Method and Description
      <T extends ConstraintValidator<?,?>>
      T             		ConstraintValidatorFactory.getInstance(Class<T> key)
      Methods in javax.validation with parameters of type ConstraintValidator
      Modifier and Type Method and Description
      void ConstraintValidatorFactory.releaseInstance(ConstraintValidator<?,?> instance)
      Signals ConstraintValidatorFactory that the instance is no longer being used by the Bean Validation provider.

    • Uses of ConstraintValidator in javax.validation.metadata

      Methods in javax.validation.metadata that return types with arguments of type ConstraintValidator
      Modifier and Type Method and Description
      List<Class<? extends ConstraintValidator<T,?>>> ConstraintDescriptor.getConstraintValidatorClasses()
      List of the constraint validation implementation classes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintValidatorContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintValidatorContext

  • Packages that use ConstraintValidatorContext
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ConstraintValidatorContext in javax.validation

      Methods in javax.validation that return ConstraintValidatorContext
      Modifier and Type Method and Description
      ConstraintValidatorContext ConstraintValidatorContext.ConstraintViolationBuilder.addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.
      ConstraintValidatorContext ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext.addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.
      ConstraintValidatorContext ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext.addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.
      ConstraintValidatorContext ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder.addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.
      ConstraintValidatorContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.
      ConstraintValidatorContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext.addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.
      ConstraintValidatorContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addConstraintViolation()
      Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.
      Methods in javax.validation with parameters of type ConstraintValidatorContext
      Modifier and Type Method and Description
      boolean ConstraintValidator.isValid(T value, ConstraintValidatorContext context)
      Implements the validation logic.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder

  • Packages that use ConstraintValidatorContext.ConstraintViolationBuilder
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ConstraintValidatorContext.ConstraintViolationBuilder in javax.validation

      Methods in javax.validation that return ConstraintValidatorContext.ConstraintViolationBuilder
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder ConstraintValidatorContext.buildConstraintViolationWithTemplate(String messageTemplate)
      Returns a constraint violation builder building a violation report allowing to optionally associate it to a sub path.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext

  • Packages that use ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext in javax.validation

      Methods in javax.validation that return ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.addBeanNode()
      Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addBeanNode()
      Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext.addBeanNode()
      Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addBeanNode()
      Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext

  • Packages that use ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext in javax.validation

      Methods in javax.validation that return ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder.atIndex(Integer index)
      Defines the index the object is into the List or array
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder.atKey(Object key)
      Defines the key the object is into the Map.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder

  • Packages that use ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder in javax.validation

      Methods in javax.validation that return ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext.inIterable()
      Marks the node as being in an Iterable or a Map.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext

  • Packages that use ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext in javax.validation

      Methods in javax.validation that return ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addNode(String name)
      Deprecated.
      since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addPropertyNode(String) and ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addBeanNode()
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext.addNode(String name)
      Deprecated.
      since 1.1 - replaced by addPropertyNode(String) and addBeanNode()
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addNode(String name)
      Deprecated.
      since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addPropertyNode(String) and ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addBeanNode()
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.addPropertyNode(String name)
      Adds a property node to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addPropertyNode(String name)
      Adds a property node to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext.addPropertyNode(String name)
      Adds a property node to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addPropertyNode(String name)
      Adds a property node to the path the ConstraintViolation will be associated to.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext

  • Packages that use ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext in javax.validation

      Methods in javax.validation that return ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext ConstraintValidatorContext.ConstraintViolationBuilder.addNode(String name)
      Deprecated.
      since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.addPropertyNode(String), ConstraintValidatorContext.ConstraintViolationBuilder.addBeanNode() and ConstraintValidatorContext.ConstraintViolationBuilder.addParameterNode(int)
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext ConstraintValidatorContext.ConstraintViolationBuilder.addParameterNode(int index)
      Adds a method parameter node to the path the ConstraintViolation will be associated to.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.atIndex(Integer index)
      Defines the index the object is into the List or array.
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.atKey(Object key)
      Defines the key the object is into the Map.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder

  • Packages that use ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder in javax.validation

      Methods in javax.validation that return ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder
      Modifier and Type Method and Description
      ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext.inIterable()
      Marks the node as being in an Iterable or a Map.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintValidatorFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintValidatorFactory

  • Packages that use ConstraintValidatorFactory
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

    • Uses of ConstraintValidatorFactory in javax.validation

      Methods in javax.validation that return ConstraintValidatorFactory
      Modifier and Type Method and Description
      ConstraintValidatorFactory ValidatorFactory.getConstraintValidatorFactory()
      Returns the ConstraintValidatorFactory instance configured at initialization time for the ValidatorFactory.
      ConstraintValidatorFactory Configuration.getDefaultConstraintValidatorFactory()
      Returns an implementation of the ConstraintValidatorFactory interface following the default ConstraintValidatorFactory defined in the specification: uses the public no-arg constructor of the ConstraintValidator
      Methods in javax.validation with parameters of type ConstraintValidatorFactory
      Modifier and Type Method and Description
      ValidatorContext ValidatorContext.constraintValidatorFactory(ConstraintValidatorFactory factory)
      Defines the constraint validator factory implementation used by the Validator.
      T Configuration.constraintValidatorFactory(ConstraintValidatorFactory constraintValidatorFactory)
      Defines the constraint validator factory.

    • Uses of ConstraintValidatorFactory in javax.validation.spi

      Methods in javax.validation.spi that return ConstraintValidatorFactory
      Modifier and Type Method and Description
      ConstraintValidatorFactory ConfigurationState.getConstraintValidatorFactory()
      Returns the constraint validator factory of this configuration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ConstraintViolation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ConstraintViolation

  • Packages that use ConstraintViolation
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.executable
    Package related to the control and execution of executable validation.

    • Uses of ConstraintViolation in javax.validation

      Methods in javax.validation that return types with arguments of type ConstraintViolation
      Modifier and Type Method and Description
      Set<ConstraintViolation<?>> ConstraintViolationException.getConstraintViolations()
      Set of constraint violations reported during a validation.
      <T> Set<ConstraintViolation<T>> Validator.validate(T object, Class<?>... groups)
      Validates all constraints on object.
      <T> Set<ConstraintViolation<T>> Validator.validateProperty(T object, String propertyName, Class<?>... groups)
      Validates all constraints placed on the property of object named propertyName.
      <T> Set<ConstraintViolation<T>> Validator.validateValue(Class<T> beanType, String propertyName, Object value, Class<?>... groups)
      Validates all constraints placed on the property named propertyName of the class beanType would the property value be value.
      Constructor parameters in javax.validation with type arguments of type ConstraintViolation
      Constructor and Description
      ConstraintViolationException(Set<? extends ConstraintViolation<?>> constraintViolations)
      Creates a constraint violation report.
      ConstraintViolationException(String message, Set<? extends ConstraintViolation<?>> constraintViolations)
      Creates a constraint violation report.

    • Uses of ConstraintViolation in javax.validation.executable

      Methods in javax.validation.executable that return types with arguments of type ConstraintViolation
      Modifier and Type Method and Description
      <T> Set<ConstraintViolation<T>> ExecutableValidator.validateConstructorParameters(Constructor<? extends T> constructor, Object[] parameterValues, Class<?>... groups)
      Validates all constraints placed on the parameters of the given constructor.
      <T> Set<ConstraintViolation<T>> ExecutableValidator.validateConstructorReturnValue(Constructor<? extends T> constructor, T createdObject, Class<?>... groups)
      Validates all return value constraints of the given constructor.
      <T> Set<ConstraintViolation<T>> ExecutableValidator.validateParameters(T object, Method method, Object[] parameterValues, Class<?>... groups)
      Validates all constraints placed on the parameters of the given method.
      <T> Set<ConstraintViolation<T>> ExecutableValidator.validateReturnValue(T object, Method method, Object returnValue, Class<?>... groups)
      Validates all return value constraints of the given method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.MessageInterpolator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.MessageInterpolator

  • Packages that use MessageInterpolator
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

    • Uses of MessageInterpolator in javax.validation

      Methods in javax.validation that return MessageInterpolator
      Modifier and Type Method and Description
      MessageInterpolator Configuration.getDefaultMessageInterpolator()
      Returns an implementation of the MessageInterpolator interface following the default MessageInterpolator defined in the specification: use the ValidationMessages resource bundle to load keys use Locale.getDefault()
      MessageInterpolator ValidatorFactory.getMessageInterpolator()
      Returns the MessageInterpolator instance configured at initialization time for the ValidatorFactory.
      Methods in javax.validation with parameters of type MessageInterpolator
      Modifier and Type Method and Description
      ValidatorContext ValidatorContext.messageInterpolator(MessageInterpolator messageInterpolator)
      Defines the message interpolator implementation used by the Validator.
      T Configuration.messageInterpolator(MessageInterpolator interpolator)
      Defines the message interpolator used.

    • Uses of MessageInterpolator in javax.validation.spi

      Methods in javax.validation.spi that return MessageInterpolator
      Modifier and Type Method and Description
      MessageInterpolator ConfigurationState.getMessageInterpolator()
      Returns the message interpolator of this configuration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.MessageInterpolator.Context (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.MessageInterpolator.Context

  • Packages that use MessageInterpolator.Context
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of MessageInterpolator.Context in javax.validation

      Methods in javax.validation with parameters of type MessageInterpolator.Context
      Modifier and Type Method and Description
      String MessageInterpolator.interpolate(String messageTemplate, MessageInterpolator.Context context)
      Interpolates the message template based on the constraint validation context.
      String MessageInterpolator.interpolate(String messageTemplate, MessageInterpolator.Context context, Locale locale)
      Interpolates the message template based on the constraint validation context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ParameterNameProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ParameterNameProvider

  • Packages that use ParameterNameProvider
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

    • Uses of ParameterNameProvider in javax.validation

      Methods in javax.validation that return ParameterNameProvider
      Modifier and Type Method and Description
      ParameterNameProvider Configuration.getDefaultParameterNameProvider()
      Returns an implementation of the ParameterNameProvider interface following the default ParameterNameProvider defined in the specification: returns names in the form arg&lt;PARAMETER_INDEX&gt; where PARAMETER_INDEX starts at 0 for the first parameter, e.g.
      ParameterNameProvider ValidatorFactory.getParameterNameProvider()
      Returns the ParameterNameProvider instance configured at initialization time for the ValidatorFactory.
      Methods in javax.validation with parameters of type ParameterNameProvider
      Modifier and Type Method and Description
      ValidatorContext ValidatorContext.parameterNameProvider(ParameterNameProvider parameterNameProvider)
      Defines the parameter name provider implementation used by the Validator.
      T Configuration.parameterNameProvider(ParameterNameProvider parameterNameProvider)
      Defines the parameter name provider.

    • Uses of ParameterNameProvider in javax.validation.spi

      Methods in javax.validation.spi that return ParameterNameProvider
      Modifier and Type Method and Description
      ParameterNameProvider ConfigurationState.getParameterNameProvider()
      Returns the parameter name provider for this configuration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Path (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Path

  • Packages that use Path
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of Path in javax.validation

      Methods in javax.validation that return Path
      Modifier and Type | Method and Description
      Path | ConstraintViolation.getPropertyPath()
      Methods in javax.validation with parameters of type Path
      Modifier and Type Method and Description
      boolean TraversableResolver.isCascadable(Object traversableObject, Path.Node traversableProperty, Class<?> rootBeanType, Path pathToTraversableObject, ElementType elementType)
      Determines if the Bean Validation provider is allowed to cascade validation on the bean instance returned by the property value marked as @Valid.
      boolean TraversableResolver.isReachable(Object traversableObject, Path.Node traversableProperty, Class<?> rootBeanType, Path pathToTraversableObject, ElementType elementType)
      Determines if the Bean Validation provider is allowed to reach the property state.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Path.BeanNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Path.BeanNode

No usage of javax.validation.Path.BeanNode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Path.ConstructorNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Path.ConstructorNode

No usage of javax.validation.Path.ConstructorNode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Path.CrossParameterNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Path.CrossParameterNode

No usage of javax.validation.Path.CrossParameterNode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Path.MethodNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Path.MethodNode

No usage of javax.validation.Path.MethodNode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Path.Node (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Path.Node

  • Packages that use Path.Node
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of Path.Node in javax.validation

      Subinterfaces of Path.Node in javax.validation
      Modifier and Type Interface and Description
      static interface  Path.BeanNode
      Node representing a bean.
      static interface  Path.ConstructorNode
      Node representing a constructor.
      static interface  Path.CrossParameterNode
      Node representing the element holding cross-parameter constraints of a method or constructor.
      static interface  Path.MethodNode
      Node representing a method.
      static interface  Path.ParameterNode
      Node representing a parameter of a method or constructor.
      static interface  Path.PropertyNode
      Node representing a property.
      static interface  Path.ReturnValueNode
      Node representing the return value of a method or constructor.
      Methods in javax.validation with type parameters of type Path.Node
      Modifier and Type Method and Description
      <T extends Path.Node>
      T             		Path.Node.as(Class<T> nodeType)
      Narrows the type of this node down to the given type.
      Methods in javax.validation with parameters of type Path.Node
      Modifier and Type Method and Description
      boolean TraversableResolver.isCascadable(Object traversableObject, Path.Node traversableProperty, Class<?> rootBeanType, Path pathToTraversableObject, ElementType elementType)
      Determines if the Bean Validation provider is allowed to cascade validation on the bean instance returned by the property value marked as @Valid.
      boolean TraversableResolver.isReachable(Object traversableObject, Path.Node traversableProperty, Class<?> rootBeanType, Path pathToTraversableObject, ElementType elementType)
      Determines if the Bean Validation provider is allowed to reach the property state.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Path.ParameterNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Path.ParameterNode

No usage of javax.validation.Path.ParameterNode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Path.PropertyNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Path.PropertyNode

No usage of javax.validation.Path.PropertyNode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Path.ReturnValueNode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Path.ReturnValueNode

No usage of javax.validation.Path.ReturnValueNode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Payload (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Payload

  • Packages that use Payload
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of Payload in javax.validation.metadata

      Methods in javax.validation.metadata that return types with arguments of type Payload
      Modifier and Type Method and Description
      Set<Class<? extends Payload>> ConstraintDescriptor.getPayload()
      The set of payload the constraint hosts.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.TraversableResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.TraversableResolver

  • Packages that use TraversableResolver
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

    • Uses of TraversableResolver in javax.validation

      Methods in javax.validation that return TraversableResolver
      Modifier and Type Method and Description
      TraversableResolver Configuration.getDefaultTraversableResolver()
      Returns an implementation of the TraversableResolver interface following the default TraversableResolver defined in the specification: if Java Persistence is available in the runtime environment, a property is considered reachable if Java Persistence considers the property as loaded if Java Persistence is not available in the runtime environment, all properties are considered reachable all properties are considered cascadable.
      TraversableResolver ValidatorFactory.getTraversableResolver()
      Returns the TraversableResolver instance configured at initialization time for the ValidatorFactory.
      Methods in javax.validation with parameters of type TraversableResolver
      Modifier and Type Method and Description
      ValidatorContext ValidatorContext.traversableResolver(TraversableResolver traversableResolver)
      Defines the traversable resolver implementation used by the Validator.
      T Configuration.traversableResolver(TraversableResolver resolver)
      Defines the traversable resolver used.

    • Uses of TraversableResolver in javax.validation.spi

      Methods in javax.validation.spi that return TraversableResolver
      Modifier and Type Method and Description
      TraversableResolver ConfigurationState.getTraversableResolver()
      Returns the traversable resolver for this configuration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ValidationProviderResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ValidationProviderResolver

  • Packages that use ValidationProviderResolver
    Package Description
    javax.validation.bootstrap
    Package containing bootstrap specific objects.
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

    • Uses of ValidationProviderResolver in javax.validation.bootstrap

      Methods in javax.validation.bootstrap with parameters of type ValidationProviderResolver
      Modifier and Type Method and Description
      ProviderSpecificBootstrap<T> ProviderSpecificBootstrap.providerResolver(ValidationProviderResolver resolver)
      Optionally defines the provider resolver implementation used.
      GenericBootstrap GenericBootstrap.providerResolver(ValidationProviderResolver resolver)
      Defines the provider resolution strategy.

    • Uses of ValidationProviderResolver in javax.validation.spi

      Methods in javax.validation.spi that return ValidationProviderResolver
      Modifier and Type Method and Description
      ValidationProviderResolver BootstrapState.getDefaultValidationProviderResolver()
      Specification default ValidationProviderResolver strategy instance.
      ValidationProviderResolver BootstrapState.getValidationProviderResolver()
      User defined ValidationProviderResolver strategy instance or null if undefined.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.Validator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.Validator

  • Packages that use Validator
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of Validator in javax.validation

      Methods in javax.validation that return Validator
      Modifier and Type Method and Description
      Validator ValidatorFactory.getValidator()
      Returns an initialized Validator instance using the factory defaults for message interpolator, traversable resolver and constraint validator factory.
      Validator ValidatorContext.getValidator()
      Returns an initialized Validator instance respecting the defined state.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ValidatorContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ValidatorContext

  • Packages that use ValidatorContext
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ValidatorContext in javax.validation

      Methods in javax.validation that return ValidatorContext
      Modifier and Type Method and Description
      ValidatorContext ValidatorContext.constraintValidatorFactory(ConstraintValidatorFactory factory)
      Defines the constraint validator factory implementation used by the Validator.
      ValidatorContext ValidatorContext.messageInterpolator(MessageInterpolator messageInterpolator)
      Defines the message interpolator implementation used by the Validator.
      ValidatorContext ValidatorContext.parameterNameProvider(ParameterNameProvider parameterNameProvider)
      Defines the parameter name provider implementation used by the Validator.
      ValidatorContext ValidatorContext.traversableResolver(TraversableResolver traversableResolver)
      Defines the traversable resolver implementation used by the Validator.
      ValidatorContext ValidatorFactory.usingContext()
      Defines a new validator context and returns a Validator compliant this new context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.ValidatorFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.ValidatorFactory

  • Packages that use ValidatorFactory
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

    • Uses of ValidatorFactory in javax.validation

      Methods in javax.validation that return ValidatorFactory
      Modifier and Type Method and Description
      static ValidatorFactory Validation.buildDefaultValidatorFactory()
      Builds and returns a ValidatorFactory instance based on the default Bean Validation provider and following the XML configuration.
      ValidatorFactory Configuration.buildValidatorFactory()
      Build a ValidatorFactory implementation.

    • Uses of ValidatorFactory in javax.validation.spi

      Methods in javax.validation.spi that return ValidatorFactory
      Modifier and Type Method and Description
      ValidatorFactory ValidationProvider.buildValidatorFactory(ConfigurationState configurationState)
      Build a ValidatorFactory using the current provider implementation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AssertFalse (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type AssertFalse

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface AssertFalse
    The annotated element must be false. Supported types are boolean and Boolean.

    null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.AssertFalse.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AssertFalse.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type AssertFalse.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface AssertFalse.List
    Defines several AssertFalse annotations on the same element.
    See Also:
    AssertFalse

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      AssertFalse[] value

    • Element Detail

      • value

        public abstract AssertFalse[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AssertTrue (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type AssertTrue

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface AssertTrue
    The annotated element must be true. Supported types are boolean and Boolean.

    null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.AssertTrue.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AssertTrue.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type AssertTrue.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface AssertTrue.List
    Defines several AssertTrue annotations on the same element.
    See Also:
    AssertTrue

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      AssertTrue[] value

    • Element Detail

      • value

        public abstract AssertTrue[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DecimalMax (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type DecimalMax

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface DecimalMax
    The annotated element must be a number whose value must be lower or equal to the specified maximum.

    Supported types are:

    • BigDecimal
    • BigInteger
    • CharSequence
    • byte, short, int, long, and their respective wrappers
    Note that double and float are not supported due to rounding errors (some providers might provide some approximative support).

    null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      The String representation of the max value according to the BigDecimal string representation.

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      boolean inclusive
      Specifies whether the specified maximum is inclusive or exclusive.
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • value

        public abstract String value
        The String representation of the max value according to the BigDecimal string representation.
        Returns:
        value the element must be lower or equal to

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.DecimalMax.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}

      • inclusive

        public abstract boolean inclusive
        Specifies whether the specified maximum is inclusive or exclusive. By default, it is inclusive.
        Returns:
        true if the value must be lower or equal to the specified maximum, false if the value must be lower
        Since:
        1.1
        Default:
        true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DecimalMax.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type DecimalMax.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface DecimalMax.List
    Defines several DecimalMax annotations on the same element.
    See Also:
    DecimalMax

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      DecimalMax[] value

    • Element Detail

      • value

        public abstract DecimalMax[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DecimalMin (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type DecimalMin

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface DecimalMin
    The annotated element must be a number whose value must be higher or equal to the specified minimum.

    Supported types are:

    • BigDecimal
    • BigInteger
    • CharSequence
    • byte, short, int, long, and their respective wrappers
    Note that double and float are not supported due to rounding errors (some providers might provide some approximative support).

    null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      The String representation of the min value according to the BigDecimal string representation.

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      boolean inclusive
      Specifies whether the specified minimum is inclusive or exclusive.
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • value

        public abstract String value
        The String representation of the min value according to the BigDecimal string representation.
        Returns:
        value the element must be higher or equal to

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.DecimalMin.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}

      • inclusive

        public abstract boolean inclusive
        Specifies whether the specified minimum is inclusive or exclusive. By default, it is inclusive.
        Returns:
        true if the value must be higher or equal to the specified minimum, false if the value must be higher
        Since:
        1.1
        Default:
        true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DecimalMin.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type DecimalMin.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface DecimalMin.List
    Defines several DecimalMin annotations on the same element.
    See Also:
    DecimalMin

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      DecimalMin[] value

    • Element Detail

      • value

        public abstract DecimalMin[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Digits (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Digits

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface Digits
    The annotated element must be a number within accepted range Supported types are:
    • BigDecimal
    • BigInteger
    • CharSequence
    • byte, short, int, long, and their respective wrapper types

    null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Required Element Summary

      Required Elements
      Modifier and Type | Required Element and Description
      int | fraction
      int | integer

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • integer

        public abstract int integer
        Returns:
        maximum number of integral digits accepted for this number

      • fraction

        public abstract int fraction
        Returns:
        maximum number of fractional digits accepted for this number

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.Digits.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Digits.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Digits.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface Digits.List
    Defines several Digits annotations on the same element.
    See Also:
    Digits

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Digits[] value

    • Element Detail

      • value

        public abstract Digits[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Future (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Future

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface Future
    The annotated element must be a date in the future. Now is defined as the current time according to the virtual machine The calendar used if the compared type is of type Calendar is the calendar based on the current timezone and the current locale.

    Supported types are:

    • java.util.Date
    • java.util.Calendar

    null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.Future.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Future.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Future.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface Future.List
    Defines several Future annotations on the same element.
    See Also:
    Future

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Future[] value

    • Element Detail

      • value

        public abstract Future[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


javax.validation.constraints (Java(TM) EE 7 Specification APIs)

javax.validation.constraints

Enums

  • Pattern.Flag

Annotation Types

  • AssertFalse
  • AssertFalse.List
  • AssertTrue
  • AssertTrue.List
  • DecimalMax
  • DecimalMax.List
  • DecimalMin
  • DecimalMin.List
  • Digits
  • Digits.List
  • Future
  • Future.List
  • Max
  • Max.List
  • Min
  • Min.List
  • NotNull
  • NotNull.List
  • Null
  • Null.List
  • Past
  • Past.List
  • Pattern
  • Pattern.List
  • Size
  • Size.List


javax.validation.constraints (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.validation.constraints

Contains all the Bean Validation provided constraints also called built-in constraints.

See: Description

  • Enum Summary
    Enum Description
    Pattern.Flag
    Possible Regexp flags.
  • Annotation Types Summary
    Annotation Type Description
    AssertFalse
    The annotated element must be false.
    AssertFalse.List
    Defines several AssertFalse annotations on the same element.
    AssertTrue
    The annotated element must be true.
    AssertTrue.List
    Defines several AssertTrue annotations on the same element.
    DecimalMax
    The annotated element must be a number whose value must be lower or equal to the specified maximum.
    DecimalMax.List
    Defines several DecimalMax annotations on the same element.
    DecimalMin
    The annotated element must be a number whose value must be higher or equal to the specified minimum.
    DecimalMin.List
    Defines several DecimalMin annotations on the same element.
    Digits
    The annotated element must be a number within accepted range Supported types are: BigDecimal BigInteger CharSequence byte, short, int, long, and their respective wrapper types

    null elements are considered valid.
    Digits.List
    Defines several Digits annotations on the same element.
    Future
    The annotated element must be a date in the future.
    Future.List
    Defines several Future annotations on the same element.
    Max
    The annotated element must be a number whose value must be lower or equal to the specified maximum.
    Max.List
    Defines several Max annotations on the same element.
    Min
    The annotated element must be a number whose value must be higher or equal to the specified minimum.
    Min.List
    Defines several Min annotations on the same element.
    NotNull
    The annotated element must not be null.
    NotNull.List
    Defines several NotNull annotations on the same element.
    Null
    The annotated element must be null.
    Null.List
    Defines several Null annotations on the same element.
    Past
    The annotated element must be a date in the past.
    Past.List
    Defines several Past annotations on the same element.
    Pattern
    The annotated CharSequence must match the specified regular expression.
    Pattern.List
    Defines several Pattern annotations on the same element.
    Size
    The annotated element size must be between the specified boundaries (included).
    Size.List
    Defines several Size annotations on the same element.

Package javax.validation.constraints Description

Contains all the Bean Validation provided constraints also called built-in constraints.

These constraints do not cover all functional use cases but do represent all the fundamental blocks to express low level constraints on basic JDK types.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.validation.constraints Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.validation.constraints

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.validation.constraints.Size (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Size.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Pattern (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Pattern.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Past (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Past.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Null (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Null.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.NotNull (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.NotNull.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Min (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Min.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Max (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Max.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Future (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Future.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Digits (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Digits.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.DecimalMin (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.DecimalMin.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.DecimalMax (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.DecimalMax.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.AssertTrue (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.AssertTrue.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.AssertFalse (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.AssertFalse.List (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.validation.constraints.Pattern.Flag
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Max (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Max

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface Max
    The annotated element must be a number whose value must be lower or equal to the specified maximum.

    Supported types are:

    • BigDecimal
    • BigInteger
    • byte, short, int, long, and their respective wrappers
    Note that double and float are not supported due to rounding errors (some providers might provide some approximative support).

    null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Required Element Summary

      Required Elements
      Modifier and Type | Required Element and Description
      long | value

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • value

        public abstract long value
        Returns:
        value the element must be lower or equal to

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.Max.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Max.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Max.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface Max.List
    Defines several Max annotations on the same element.
    See Also:
    Max

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Max[] value

    • Element Detail

      • value

        public abstract Max[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Min (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Min

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface Min
    The annotated element must be a number whose value must be higher or equal to the specified minimum.

    Supported types are:

    • BigDecimal
    • BigInteger
    • byte, short, int, long, and their respective wrappers
    Note that double and float are not supported due to rounding errors (some providers might provide some approximative support).

    null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Required Element Summary

      Required Elements
      Modifier and Type | Required Element and Description
      long | value

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • value

        public abstract long value
        Returns:
        value the element must be higher or equal to

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.Min.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Min.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Min.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface Min.List
    Defines several Min annotations on the same element.
    See Also:
    Min

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Min[] value

    • Element Detail

      • value

        public abstract Min[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NotNull (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type NotNull

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface NotNull
    The annotated element must not be null. Accepts any type.
    Author:
    Emmanuel Bernard

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.NotNull.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NotNull.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type NotNull.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface NotNull.List
    Defines several NotNull annotations on the same element.
    See Also:
    NotNull

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      NotNull[] value

    • Element Detail

      • value

        public abstract NotNull[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Null (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Null

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface Null
    The annotated element must be null. Accepts any type.
    Author:
    Emmanuel Bernard

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.Null.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Null.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Null.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface Null.List
    Defines several Null annotations on the same element.
    See Also:
    Null

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Null[] value

    • Element Detail

      • value

        public abstract Null[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Past (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Past

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface Past
    The annotated element must be a date in the past. Now is defined as the current time according to the virtual machine.

    The calendar used if the compared type is of type Calendar is the calendar based on the current timezone and the current locale.

    Supported types are:

    • java.util.Date
    • java.util.Calendar

    null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.Past.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Past.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Past.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface Past.List
    Defines several Past annotations on the same element.
    See Also:
    Past

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Past[] value

    • Element Detail

      • value

        public abstract Past[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Pattern (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Pattern

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface Pattern
    The annotated CharSequence must match the specified regular expression. The regular expression follows the Java regular expression conventions see Pattern.

    Accepts CharSequence. null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String regexp

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Pattern.Flag[] flags
      Class<?>[] groups
      String message
      Class<? extends Payload>[] | payload

    • Element Detail

      • regexp

        public abstract String regexp
        Returns:
        the regular expression to match

      • flags

        public abstract Pattern.Flag[] flags
        Returns:
        array of Flags considered when resolving the regular expression
        Default:
        {}

      • message

        public abstract String message
        Returns:
        the error message template
        Default:
        "{javax.validation.constraints.Pattern.message}"

      • groups

        public abstract Class<?>[] groups
        Returns:
        the groups the constraint belongs to
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Returns:
        the payload associated to the constraint
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Pattern.Flag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.validation.constraints

Enum Pattern.Flag

  • java.lang.Object
    • java.lang.Enum<Pattern.Flag>
      • javax.validation.constraints.Pattern.Flag
  • All Implemented Interfaces:
    Serializable, Comparable<Pattern.Flag>
    Enclosing class:
    Pattern

    public static enum Pattern.Flag
extends Enum<Pattern.Flag>
    Possible Regexp flags.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      CANON_EQ
      Enables canonical equivalence.
      CASE_INSENSITIVE
      Enables case-insensitive matching.
      COMMENTS
      Permits whitespace and comments in pattern.
      DOTALL
      Enables dotall mode.
      MULTILINE
      Enables multiline mode.
      UNICODE_CASE
      Enables Unicode-aware case folding.
      UNIX_LINES
      Enables Unix lines mode.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      int | getValue()
      static Pattern.Flag valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Pattern.Flag[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNIX_LINES

        public static final Pattern.Flag UNIX_LINES
        Enables Unix lines mode.
        See Also:
        Pattern.UNIX_LINES

      • CASE_INSENSITIVE

        public static final Pattern.Flag CASE_INSENSITIVE
        Enables case-insensitive matching.
        See Also:
        Pattern.CASE_INSENSITIVE

      • COMMENTS

        public static final Pattern.Flag COMMENTS
        Permits whitespace and comments in pattern.
        See Also:
        Pattern.COMMENTS

      • MULTILINE

        public static final Pattern.Flag MULTILINE
        Enables multiline mode.
        See Also:
        Pattern.MULTILINE

      • DOTALL

        public static final Pattern.Flag DOTALL
        Enables dotall mode.
        See Also:
        Pattern.DOTALL

      • UNICODE_CASE

        public static final Pattern.Flag UNICODE_CASE
        Enables Unicode-aware case folding.
        See Also:
        Pattern.UNICODE_CASE

      • CANON_EQ

        public static final Pattern.Flag CANON_EQ
        Enables canonical equivalence.
        See Also:
        Pattern.CANON_EQ

    • Method Detail

      • values

        public static Pattern.Flag[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Pattern.Flag c : Pattern.Flag.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Pattern.Flag valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • getValue

        public int getValue()
        Returns:
        flag value as defined in Pattern
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Pattern.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Pattern.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface Pattern.List
    Defines several Pattern annotations on the same element.
    See Also:
    Pattern

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Pattern[] value

    • Element Detail

      • value

        public abstract Pattern[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Size (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Size

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
@Constraint(validatedBy={})
public @interface Size
    The annotated element size must be between the specified boundaries (included).

    Supported types are:

    • CharSequence (length of character sequence is evaluated)
    • Collection (collection size is evaluated)
    • Map (map size is evaluated)
    • Array (array length is evaluated)

    null elements are considered valid.

    Author:
    Emmanuel Bernard

    • Optional Element Summary

      Optional Elements
      Modifier and Type | Optional Element and Description
      Class<?>[] groups
      int | max
      String message
      int | min
      Class<? extends Payload>[] | payload

    • Element Detail

      • message

        public abstract String message
        Default:
        "{javax.validation.constraints.Size.message}"

      • groups

        public abstract Class<?>[] groups
        Default:
        {}

      • payload

        public abstract Class<? extends Payload>[] payload
        Default:
        {}

      • min

        public abstract int min
        Returns:
        size the element must be higher or equal to
        Default:
        0

      • max

        public abstract int max
        Returns:
        size the element must be lower or equal to
        Default:
        2147483647
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Size.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraints

Annotation Type Size.List

  • @Target(value={METHOD,FIELD,ANNOTATION_TYPE,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface Size.List
    Defines several Size annotations on the same element.
    See Also:
    Size

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Size[] value

    • Element Detail

      • value

        public abstract Size[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.validation.constraints (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.validation.constraints

  • Packages that use javax.validation.constraints
    Package Description
    javax.validation.constraints
    Contains all the Bean Validation provided constraints also called built-in constraints.
  • Classes in javax.validation.constraints used by javax.validation.constraints
    Class and Description
    Pattern.Flag
    Possible Regexp flags.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.AssertFalse (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.AssertFalse

No usage of javax.validation.constraints.AssertFalse
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.AssertFalse.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.AssertFalse.List

No usage of javax.validation.constraints.AssertFalse.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.AssertTrue (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.AssertTrue

No usage of javax.validation.constraints.AssertTrue
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.AssertTrue.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.AssertTrue.List

No usage of javax.validation.constraints.AssertTrue.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.DecimalMax (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.DecimalMax

No usage of javax.validation.constraints.DecimalMax
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.DecimalMax.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.DecimalMax.List

No usage of javax.validation.constraints.DecimalMax.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.DecimalMin (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.DecimalMin

No usage of javax.validation.constraints.DecimalMin
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.DecimalMin.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.DecimalMin.List

No usage of javax.validation.constraints.DecimalMin.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Digits (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Digits

No usage of javax.validation.constraints.Digits
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Digits.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Digits.List

No usage of javax.validation.constraints.Digits.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Future (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Future

No usage of javax.validation.constraints.Future
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Future.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Future.List

No usage of javax.validation.constraints.Future.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Max (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Max

No usage of javax.validation.constraints.Max
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Max.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Max.List

No usage of javax.validation.constraints.Max.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Min (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Min

No usage of javax.validation.constraints.Min
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Min.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Min.List

No usage of javax.validation.constraints.Min.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.NotNull (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.NotNull

No usage of javax.validation.constraints.NotNull
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.NotNull.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.NotNull.List

No usage of javax.validation.constraints.NotNull.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Null (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Null

No usage of javax.validation.constraints.Null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Null.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Null.List

No usage of javax.validation.constraints.Null.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Past (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Past

No usage of javax.validation.constraints.Past
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Past.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Past.List

No usage of javax.validation.constraints.Past.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Pattern (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Pattern

No usage of javax.validation.constraints.Pattern
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Pattern.Flag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Pattern.Flag

  • Packages that use Pattern.Flag
    Package Description
    javax.validation.constraints
    Contains all the Bean Validation provided constraints also called built-in constraints.

    • Uses of Pattern.Flag in javax.validation.constraints

      Methods in javax.validation.constraints that return Pattern.Flag
      Modifier and Type Method and Description
      static Pattern.Flag Pattern.Flag.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Pattern.Flag[] Pattern.Flag.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Pattern.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Pattern.List

No usage of javax.validation.constraints.Pattern.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Size (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Size

No usage of javax.validation.constraints.Size
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraints.Size.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraints.Size.List

No usage of javax.validation.constraints.Size.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.validation.constraintvalidation (Java(TM) EE 7 Specification APIs)

javax.validation.constraintvalidation

Enums

  • ValidationTarget

Annotation Types

  • SupportedValidationTarget


javax.validation.constraintvalidation (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.validation.constraintvalidation

Package containing constructs specific to constraint validators In particular SupportedValidationTarget is used to refine the validation target of a ConstraintValidator.

See: Description

  • Enum Summary
    Enum Description
    ValidationTarget
    List of possible targets for a ConstraintValidator.
  • Annotation Types Summary
    Annotation Type Description
    SupportedValidationTarget
    Defines the target(s) a ConstraintValidator can validate.

Package javax.validation.constraintvalidation Description

Package containing constructs specific to constraint validators In particular SupportedValidationTarget is used to refine the validation target of a ConstraintValidator.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.validation.constraintvalidation Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.validation.constraintvalidation

Package Hierarchies:
  • All Packages

Annotation Type Hierarchy

  • javax.validation.constraintvalidation.SupportedValidationTarget (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.validation.constraintvalidation.ValidationTarget
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


SupportedValidationTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.constraintvalidation

Annotation Type SupportedValidationTarget

  • @Documented
@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SupportedValidationTarget
    Defines the target(s) a ConstraintValidator can validate.

    A ConstraintValidator can target the (returned) element annotated by the constraint, the array of parameters of a method or constructor (aka cross-parameter) or both.

    If @SupportedValidationTarget is not present, the ConstraintValidator targets the (returned) element annotated by the constraint.

    A ConstraintValidator targeting cross-parameter must accept Object[] (or Object) as the type of object it validates.

    Since:
    1.1
    Author:
    Emmanuel Bernard

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      ValidationTarget[] value

    • Element Detail

      • value

        public abstract ValidationTarget[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.validation.constraintvalidation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.validation.constraintvalidation

  • Packages that use javax.validation.constraintvalidation
    Package Description
    javax.validation.constraintvalidation
    Package containing constructs specific to constraint validators In particular SupportedValidationTarget is used to refine the validation target of a ConstraintValidator.
  • Classes in javax.validation.constraintvalidation used by javax.validation.constraintvalidation
    Class and Description
    ValidationTarget
    List of possible targets for a ConstraintValidator.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidationTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.validation.constraintvalidation

Enum ValidationTarget

  • java.lang.Object
    • java.lang.Enum<ValidationTarget>
      • javax.validation.constraintvalidation.ValidationTarget
  • All Implemented Interfaces:
    Serializable, Comparable<ValidationTarget>

    public enum ValidationTarget
extends Enum<ValidationTarget>
    List of possible targets for a ConstraintValidator.
    Since:
    1.1
    Author:
    Emmanuel Bernard

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ANNOTATED_ELEMENT
      (Returned) element annotated by the constraint.
      PARAMETERS
      Array of parameters of the annotated method or constructor (aka cross-parameter).

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ValidationTarget valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ValidationTarget[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ANNOTATED_ELEMENT

        public static final ValidationTarget ANNOTATED_ELEMENT
        (Returned) element annotated by the constraint.

      • PARAMETERS

        public static final ValidationTarget PARAMETERS
        Array of parameters of the annotated method or constructor (aka cross-parameter).

    • Method Detail

      • values

        public static ValidationTarget[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ValidationTarget c : ValidationTarget.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ValidationTarget valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Uses of Class javax.validation.constraintvalidation.SupportedValidationTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraintvalidation.SupportedValidationTarget

No usage of javax.validation.constraintvalidation.SupportedValidationTarget
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.constraintvalidation.ValidationTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.constraintvalidation.ValidationTarget

  • Packages that use ValidationTarget
    Package Description
    javax.validation.constraintvalidation
    Package containing constructs specific to constraint validators In particular SupportedValidationTarget is used to refine the validation target of a ConstraintValidator.

    • Uses of ValidationTarget in javax.validation.constraintvalidation

      Methods in javax.validation.constraintvalidation that return ValidationTarget
      Modifier and Type Method and Description
      static ValidationTarget ValidationTarget.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ValidationTarget[] ValidationTarget.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ExecutableType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.validation.executable

Enum ExecutableType

  • java.lang.Object
    • java.lang.Enum<ExecutableType>
      • javax.validation.executable.ExecutableType
  • All Implemented Interfaces:
    Serializable, Comparable<ExecutableType>

    public enum ExecutableType
extends Enum<ExecutableType>
    Defines the types of executables targeted by an operation.
    Since:
    1.1
    Author:
    Emmanuel Bernard

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ALL
      All executables (constructors and methods).
      CONSTRUCTORS
      All constructors.
      GETTER_METHODS
      /** All methods following the getter pattern.
      IMPLICIT
      If the annotation using ExecutableType is on a type (class or interface), the behavior is equivalent to the annotation not being present.
      NON_GETTER_METHODS
      All methods except the ones following the getter pattern.
      NONE
      None of the executables.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static ExecutableType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ExecutableType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • IMPLICIT

        public static final ExecutableType IMPLICIT
        If the annotation using ExecutableType is on a type (class or interface), the behavior is equivalent to the annotation not being present.

        If on a constructor, it is equivalent to CONSTRUCTORS.

        If on a non-getter method, it is equivalent to NON_GETTER_METHODS.

        If on a getter method, it is equivalent to GETTER_METHODS.

      • NONE

        public static final ExecutableType NONE
        None of the executables.

        Note that this option is equivalent to an empty list of executable types and is present to improve readability. If NONE and other types of executables are present in a list, NONE is ignored.

      • CONSTRUCTORS

        public static final ExecutableType CONSTRUCTORS
        All constructors.

      • NON_GETTER_METHODS

        public static final ExecutableType NON_GETTER_METHODS
        All methods except the ones following the getter pattern. A getter according to the JavaBeans specification is a method whose:
        • name starts with get, has a return type but no parameter
        • name starts with is, has a return type and is returning boolean.

      • GETTER_METHODS

        public static final ExecutableType GETTER_METHODS
        /** All methods following the getter pattern. A getter according to the JavaBeans specification is a method whose:
        • name starts with get, has a return type but no parameter
        • name starts with is, has a return type and is returning boolean.

      • ALL

        public static final ExecutableType ALL
        All executables (constructors and methods).

    • Method Detail

      • values

        public static ExecutableType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (ExecutableType c : ExecutableType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static ExecutableType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ExecutableValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.executable

Interface ExecutableValidator

  • public interface ExecutableValidator
    Validates parameters and return values of methods and constructors. Implementations of this interface must be thread-safe.
    Since:
    1.1
    Author:
    Gunnar Morling

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T> Set<ConstraintViolation<T>> validateConstructorParameters(Constructor<? extends T> constructor, Object[] parameterValues, Class<?>... groups)
      Validates all constraints placed on the parameters of the given constructor.
      <T> Set<ConstraintViolation<T>> validateConstructorReturnValue(Constructor<? extends T> constructor, T createdObject, Class<?>... groups)
      Validates all return value constraints of the given constructor.
      <T> Set<ConstraintViolation<T>> validateParameters(T object, Method method, Object[] parameterValues, Class<?>... groups)
      Validates all constraints placed on the parameters of the given method.
      <T> Set<ConstraintViolation<T>> validateReturnValue(T object, Method method, Object returnValue, Class<?>... groups)
      Validates all return value constraints of the given method.

    • Method Detail

      • validateParameters

        <T> Set<ConstraintViolation<T>> validateParameters(T object,
                                                 Method method,
                                                 Object[] parameterValues,
                                                 Class<?>... groups)
        Validates all constraints placed on the parameters of the given method.
        Type Parameters:
        T - the type hosting the method to validate
        Parameters:
        object - the object on which the method to validate is invoked
        method - the method for which the parameter constraints is validated
        parameterValues - the values provided by the caller for the given method's parameters
        groups - the group or list of groups targeted for validation (defaults to Default)
        Returns:
        a set with the constraint violations caused by this validation; will be empty if no error occurs, but never null
        Throws:
        IllegalArgumentException - if null is passed for any of the parameters or if parameters don't match with each other
        ValidationException - if a non recoverable error happens during the validation process

      • validateReturnValue

        <T> Set<ConstraintViolation<T>> validateReturnValue(T object,
                                                  Method method,
                                                  Object returnValue,
                                                  Class<?>... groups)
        Validates all return value constraints of the given method.
        Type Parameters:
        T - the type hosting the method to validate
        Parameters:
        object - the object on which the method to validate is invoked
        method - the method for which the return value constraints is validated
        returnValue - the value returned by the given method
        groups - the group or list of groups targeted for validation (defaults to Default)
        Returns:
        a set with the constraint violations caused by this validation; will be empty if no error occurs, but never null
        Throws:
        IllegalArgumentException - if null is passed for any of the object, method or groups parameters or if parameters don't match with each other
        ValidationException - if a non recoverable error happens during the validation process

      • validateConstructorParameters

        <T> Set<ConstraintViolation<T>> validateConstructorParameters(Constructor<? extends T> constructor,
                                                            Object[] parameterValues,
                                                            Class<?>... groups)
        Validates all constraints placed on the parameters of the given constructor.
        Type Parameters:
        T - the type hosting the constructor to validate
        Parameters:
        constructor - the constructor for which the parameter constraints is validated
        parameterValues - the values provided by the caller for the given constructor's parameters
        groups - the group or list of groups targeted for validation (defaults to Default)
        Returns:
        a set with the constraint violations caused by this validation; Will be empty if no error occurs, but never null
        Throws:
        IllegalArgumentException - if null is passed for any of the parameters or if parameters don't match with each other
        ValidationException - if a non recoverable error happens during the validation process

      • validateConstructorReturnValue

        <T> Set<ConstraintViolation<T>> validateConstructorReturnValue(Constructor<? extends T> constructor,
                                                             T createdObject,
                                                             Class<?>... groups)
        Validates all return value constraints of the given constructor.
        Type Parameters:
        T - the type hosting the constructor to validate
        Parameters:
        constructor - the constructor for which the return value constraints is validated
        createdObject - the object instantiated by the given method
        groups - the group or list of groups targeted for validation (defaults to Default)
        Returns:
        a set with the constraint violations caused by this validation; will be empty, if no error occurs, but never null
        Throws:
        IllegalArgumentException - if null is passed for any of the parameters or if parameters don't match with each other
        ValidationException - if a non recoverable error happens during the validation process
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.validation.executable (Java(TM) EE 7 Specification APIs)

javax.validation.executable

Interfaces

  • ExecutableValidator

Enums

  • ExecutableType

Annotation Types

  • ValidateOnExecution


javax.validation.executable (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.validation.executable

Package related to the control and execution of executable validation.

See: Description

  • Interface Summary
    Interface Description
    ExecutableValidator
    Validates parameters and return values of methods and constructors.
  • Enum Summary
    Enum Description
    ExecutableType
    Defines the types of executables targeted by an operation.
  • Annotation Types Summary
    Annotation Type Description
    ValidateOnExecution
    Expresses which executables (methods or constructors) should have their parameters and return value validated upon execution.

Package javax.validation.executable Description

Package related to the control and execution of executable validation. Use ValidateOnExecution to control whether or not a (set of) constructors or methods are being validated.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.validation.executable Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.validation.executable

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.validation.executable.ExecutableValidator

Annotation Type Hierarchy

  • javax.validation.executable.ValidateOnExecution (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.validation.executable.ExecutableType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.validation.executable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.validation.executable

  • Packages that use javax.validation.executable
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.executable
    Package related to the control and execution of executable validation.
  • Classes in javax.validation.executable used by javax.validation
    Class and Description
    ExecutableType
    Defines the types of executables targeted by an operation.
    ExecutableValidator
    Validates parameters and return values of methods and constructors.
  • Classes in javax.validation.executable used by javax.validation.executable
    Class and Description
    ExecutableType
    Defines the types of executables targeted by an operation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidateOnExecution (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.executable

Annotation Type ValidateOnExecution

  • @Target(value={CONSTRUCTOR,METHOD,TYPE,PACKAGE})
@Retention(value=RUNTIME)
public @interface ValidateOnExecution
    Expresses which executables (methods or constructors) should have their parameters and return value validated upon execution. Can be on executable (method, constructor) or type level (with the former taking precedence).

    If not present for a given executable, the default configuration from META-INF/validation.xml and finally the implicit default validated executable types (constructors and non-getters) are taken into account to determine whether a given executable is validated upon execution or not.

    The following describes the formal rules for deciding whether an executable is validated. They are applied in decreasing order:

    • the executable is validated if it is annotated with @ValidateOnExecution and the type attribute contains the executable type or ExecutableType.IMPLICIT. If the type attribute does neither contain the executable type nor IMPLICIT, the executable is not validated.
    • otherwise the executable is validated if the type (class, interface) on which it is declared is annotated with @ValidateOnExecution and the type attribute contains the executable type. If the type attribute contains IMPLICIT, then this rule is ignored and the behavior is equivalent to ValidateOnExecution not being present. If the type attribute does not contain the executable type, the executable is not validated.
    • otherwise the executable is validated if the global executable validation setting contains the executable type. If the global setting does not contain the executable type, the executable is not validated.
    • The rules above do not apply to methods overriding a superclass method or implementing an interface method. In this case, the method inherits the behavior of the method it overrides or implements. Out of the box, a conforming implementation raises a ValidationException if the overriding / implementing method hosts the ValidateOnExecution annotation.

    Note that you can exclude an executable from validation by making sure the rules above do not match or by annotating the executable with @ValidateOnExecution(NONE).

    Since:
    1.1
    Author:
    Emmanuel Bernard

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      ExecutableType[] type
      List of executable types to be validated when called.

    • Element Detail

      • type

        public abstract ExecutableType[] type
        List of executable types to be validated when called. Defaults to the types discovered implicitly (see ExecutableType.IMPLICIT).
        Default:
        javax.validation.executable.ExecutableType.IMPLICIT
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.validation.executable.ExecutableType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.executable.ExecutableType

  • Packages that use ExecutableType
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.executable
    Package related to the control and execution of executable validation.

    • Uses of ExecutableType in javax.validation

      Methods in javax.validation that return types with arguments of type ExecutableType
      Modifier and Type Method and Description
      Set<ExecutableType> BootstrapConfiguration.getDefaultValidatedExecutableTypes()
      Returns the set of executable types that should be considered unless explicitly overridden via ValidateOnExecution

      Returns a set containing CONSTRUCTORS and NON_GETTER_METHODS if unspecified in the configuration.

    • Uses of ExecutableType in javax.validation.executable

      Methods in javax.validation.executable that return ExecutableType
      Modifier and Type Method and Description
      static ExecutableType ExecutableType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static ExecutableType[] ExecutableType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.executable.ValidateOnExecution (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.executable.ValidateOnExecution

No usage of javax.validation.executable.ValidateOnExecution
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.executable.ExecutableValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.executable.ExecutableValidator

  • Packages that use ExecutableValidator
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ExecutableValidator in javax.validation

      Methods in javax.validation that return ExecutableValidator
      Modifier and Type Method and Description
      ExecutableValidator Validator.forExecutables()
      Returns the contract for validating parameters and return values of methods and constructors.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ConvertGroup (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.groups

Annotation Type ConvertGroup

  • @Target(value={TYPE,METHOD,FIELD,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public @interface ConvertGroup
    Converts group from to group to during cascading.

    Can be used everywhere Valid is used and must be on an element annotated with Valid.

    Since:
    1.1
    Author:
    Emmanuel Bernard

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<?> from
      Class<?> to

    • Element Detail

      • from

        public abstract Class<?> from

      • to

        public abstract Class<?> to
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ConvertGroup.List (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.validation.groups

Annotation Type ConvertGroup.List

  • @Target(value={TYPE,METHOD,FIELD,CONSTRUCTOR,PARAMETER})
@Retention(value=RUNTIME)
@Documented
public static @interface ConvertGroup.List
    Defines several ConvertGroup annotations on the same element.

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      ConvertGroup[] value

    • Element Detail

      • value

        public abstract ConvertGroup[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Default (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.groups

Interface Default

  • public interface Default
    Default Bean Validation group.

    Unless a list of groups is explicitly defined:

    • constraints belong to the Default group
    • validation applies to the Default group
    Most structural constraints should belong to the default group.
    Author:
    Emmanuel Bernard
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.validation.groups (Java(TM) EE 7 Specification APIs)

javax.validation.groups

Interfaces

  • Default

Annotation Types

  • ConvertGroup
  • ConvertGroup.List


javax.validation.groups (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.validation.groups

A group defines a subset of constraints.

See: Description

  • Interface Summary
    Interface Description
    Default
    Default Bean Validation group.
  • Annotation Types Summary
    Annotation Type Description
    ConvertGroup
    Converts group from to group to during cascading.
    ConvertGroup.List
    Defines several ConvertGroup annotations on the same element.

Package javax.validation.groups Description

A group defines a subset of constraints. Instead of validating all constraints for a given object graph, only a subset is validated depending on the group targeted.

Each constraint declaration defines the list of groups it belongs to. If no group is explicitly declared, a constraint belongs to the Default group.

When applying validation, the list of target groups is passed along. If no group is explicitly passed along, the javax.validation.groups.Default group is used.

During cascading, groups can be converted from one to another by the use of ConvertGroup

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.validation.groups Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.validation.groups

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.validation.groups.Default

Annotation Type Hierarchy

  • javax.validation.groups.ConvertGroup (implements java.lang.annotation.Annotation)
  • javax.validation.groups.ConvertGroup.List (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.validation.groups (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.validation.groups

No usage of javax.validation.groups
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.groups.ConvertGroup (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.groups.ConvertGroup

No usage of javax.validation.groups.ConvertGroup
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.groups.ConvertGroup.List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.groups.ConvertGroup.List

No usage of javax.validation.groups.ConvertGroup.List
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.groups.Default (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.groups.Default

No usage of javax.validation.groups.Default
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BeanDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface BeanDescriptor

  • All Superinterfaces:
    ElementDescriptor

    public interface BeanDescriptor
extends ElementDescriptor
    Describes a constrained Java Bean and the constraints associated to it. All objects returned by the methods of this descriptor (and associated objects including ConstraintDescriptors) are immutable.
    Author:
    Emmanuel Bernard, Gunnar Morling

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.validation.metadata.ElementDescriptor

        ElementDescriptor.ConstraintFinder

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<ConstructorDescriptor> getConstrainedConstructors()
      Returns a set with descriptors for the constrained constructors of the bean represented by this descriptor.
      Set<MethodDescriptor> getConstrainedMethods(MethodType methodType, MethodType... methodTypes)
      Returns a set with descriptors for the constrained methods of the bean represented by this descriptor.
      Set<PropertyDescriptor> getConstrainedProperties()
      Returns a set of property descriptors having at least one constraint defined or marked as cascaded (Valid).
      ConstructorDescriptor getConstraintsForConstructor(Class<?>... parameterTypes)
      Returns a constructor descriptor for the given constructor.
      MethodDescriptor getConstraintsForMethod(String methodName, Class<?>... parameterTypes)
      Returns a method descriptor for the given method.
      PropertyDescriptor getConstraintsForProperty(String propertyName)
      Returns the property descriptor for a given property.
      boolean isBeanConstrained()
      Returns true if the bean involves validation: a constraint is hosted on the bean itself a constraint is hosted on one of the bean properties or a bean property is marked for cascaded validation (Valid)

      Constrained methods and constructors are ignored.

      • Methods inherited from interface javax.validation.metadata.ElementDescriptor

        findConstraints, getConstraintDescriptors, getElementClass, hasConstraints

    • Method Detail

      • isBeanConstrained

        boolean isBeanConstrained()
        Returns true if the bean involves validation:
        • a constraint is hosted on the bean itself
        • a constraint is hosted on one of the bean properties
        • or a bean property is marked for cascaded validation (Valid)

        Constrained methods and constructors are ignored.

        Returns:
        true if the bean involves validation, false otherwise

      • getConstraintsForProperty

        PropertyDescriptor getConstraintsForProperty(String propertyName)
        Returns the property descriptor for a given property.

        Returns null if the property does not exist or has no constraint nor is marked as cascaded (see getConstrainedProperties()) Properties of super types are considered.

        Parameters:
        propertyName - property evaluated
        Returns:
        the property descriptor for a given property
        Throws:
        IllegalArgumentException - if propertyName is null

      • getConstrainedProperties

        Set<PropertyDescriptor> getConstrainedProperties()
        Returns a set of property descriptors having at least one constraint defined or marked as cascaded (Valid).

        If not property matches, an empty set is returned. Properties of super types are considered.

        Returns:
        the set of PropertyDescriptors for the constraint properties; if there are no constraint properties, the empty set is returned

      • getConstraintsForMethod

        MethodDescriptor getConstraintsForMethod(String methodName,
                                       Class<?>... parameterTypes)
        Returns a method descriptor for the given method.

        Returns null if no method with the given name and parameter types exists or the specified method neither has parameter or return value constraints nor a parameter or return value marked for cascaded validation. Methods of super types are considered.

        Parameters:
        methodName - the name of the method
        parameterTypes - the parameter types of the method
        Returns:
        a method descriptor for the given method
        Throws:
        IllegalArgumentException - if methodName is null
        Since:
        1.1

      • getConstrainedMethods

        Set<MethodDescriptor> getConstrainedMethods(MethodType methodType,
                                          MethodType... methodTypes)
        Returns a set with descriptors for the constrained methods of the bean represented by this descriptor.

        Constrained methods have at least one parameter or return value constraint or at least one parameter or return value marked for cascaded validation. Methods of super types are considered.

        Only methods matching the given method type(s) are considered.

        Parameters:
        methodType - method type to consider
        methodTypes - remaining optional method types to consider
        Returns:
        a set with descriptors for the constrained methods of this bean; will be empty if this bean has no constrained methods of the considered method type(s) but never null
        Since:
        1.1

      • getConstraintsForConstructor

        ConstructorDescriptor getConstraintsForConstructor(Class<?>... parameterTypes)
        Returns a constructor descriptor for the given constructor.

        Returns null if no constructor with the given parameter types exists or the specified constructor neither has parameter or return value constraints nor a parameter or return value marked for cascaded validation. Constructor of super types are considered.

        Parameters:
        parameterTypes - the parameter types of the constructor
        Returns:
        a constructor descriptor for the given constructor
        Since:
        1.1

      • getConstrainedConstructors

        Set<ConstructorDescriptor> getConstrainedConstructors()
        Returns a set with descriptors for the constrained constructors of the bean represented by this descriptor.

        Constrained constructors have at least one parameter or return value constraint or at least one parameter or return value marked for cascaded validation.

        Returns:
        a set with descriptors for the constrained constructor of this bean; will be empty if this bea has no constrained constructor but never null
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CascadableDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface CascadableDescriptor

  • All Known Subinterfaces:
    ParameterDescriptor, PropertyDescriptor, ReturnValueDescriptor

    public interface CascadableDescriptor
    Represents a cascadable element.
    Since:
    1.1
    Author:
    Gunnar Morling

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<GroupConversionDescriptor> getGroupConversions()
      Returns the group conversions configured for this element.
      boolean isCascaded()
      Whether this element is marked for cascaded validation or not.

    • Method Detail

      • isCascaded

        boolean isCascaded()
        Whether this element is marked for cascaded validation or not.
        Returns:
        true, if this element is marked for cascaded validation, false otherwise

      • getGroupConversions

        Set<GroupConversionDescriptor> getGroupConversions()
        Returns the group conversions configured for this element.
        Returns:
        a set containing this element's group conversions; an empty set may be returned if no conversions are configured but never null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstraintDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface ConstraintDescriptor<T extends Annotation>

  • public interface ConstraintDescriptor<T extends Annotation>
    Describes a single constraint and its composing constraints.

    T is the constraint's annotation type.

    Author:
    Emmanuel Bernard, Hardy Ferentschik

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      T getAnnotation()
      Returns the annotation describing the constraint declaration.
      Map<String,Object> getAttributes()
      Returns a map containing the annotation attribute names as keys and the annotation attribute values as value.
      Set<ConstraintDescriptor<?>> getComposingConstraints()
      Return a set of composing ConstraintDescriptors where each descriptor describes a composing constraint.
      List<Class<? extends ConstraintValidator<T,?>>> getConstraintValidatorClasses()
      List of the constraint validation implementation classes.
      Set<Class<?>> getGroups()
      The set of groups the constraint is applied on.
      String getMessageTemplate()
      The non-interpolated error message
      Set<Class<? extends Payload>> getPayload()
      The set of payload the constraint hosts.
      ConstraintTarget getValidationAppliesTo()
      The ConstraintTarget value of validationAppliesTo if the constraint hosts it or null otherwise.
      boolean | isReportAsSingleViolation()

    • Method Detail

      • getAnnotation

        T getAnnotation()
        Returns the annotation describing the constraint declaration. If a composing constraint, attribute values are reflecting the overridden attributes of the composing constraint
        Returns:
        the annotation for this constraint

      • getMessageTemplate

        String getMessageTemplate()
        The non-interpolated error message
        Returns:
        the non-interpolated error message
        Since:
        1.1

      • getGroups

        Set<Class<?>> getGroups()
        The set of groups the constraint is applied on. If the constraint declares no group, a set with only the Default group is returned.
        Returns:
        the groups the constraint is applied on

      • getPayload

        Set<Class<? extends Payload>> getPayload()
        The set of payload the constraint hosts.
        Returns:
        payload classes hosted on the constraint or an empty set if none

      • getValidationAppliesTo

        ConstraintTarget getValidationAppliesTo()
        The ConstraintTarget value of validationAppliesTo if the constraint hosts it or null otherwise.
        Returns:
        the ConstraintTarget value or null
        Since:
        1.1

      • getConstraintValidatorClasses

        List<Class<? extends ConstraintValidator<T,?>>> getConstraintValidatorClasses()
        List of the constraint validation implementation classes.
        Returns:
        list of the constraint validation implementation classes

      • getAttributes

        Map<String,Object> getAttributes()
        Returns a map containing the annotation attribute names as keys and the annotation attribute values as value.

        If this constraint is used as part of a composed constraint, attribute values are reflecting the overridden attribute of the composing constraint.

        Returns:
        a map containing the annotation attribute names as keys and the annotation attribute values as value

      • getComposingConstraints

        Set<ConstraintDescriptor<?>> getComposingConstraints()
        Return a set of composing ConstraintDescriptors where each descriptor describes a composing constraint. ConstraintDescriptor instances of composing constraints reflect overridden attribute values in getAttributes() and getAnnotation().
        Returns:
        a set of ConstraintDescriptor objects or an empty set in case there are no composing constraints

      • isReportAsSingleViolation

        boolean isReportAsSingleViolation()
        Returns:
        true if the constraint is annotated with ReportAsSingleViolation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstructorDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface ConstructorDescriptor

  • All Superinterfaces:
    ElementDescriptor, ExecutableDescriptor

    public interface ConstructorDescriptor
extends ExecutableDescriptor
    Describes a validated constructor.
    Since:
    1.1
    Author:
    Gunnar Morling, Emmanuel Bernard

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.validation.metadata.ElementDescriptor

        ElementDescriptor.ConstraintFinder

    • Method Summary

      • Methods inherited from interface javax.validation.metadata.ExecutableDescriptor

        findConstraints, getConstraintDescriptors, getCrossParameterDescriptor, getName, getParameterDescriptors, getReturnValueDescriptor, hasConstrainedParameters, hasConstrainedReturnValue, hasConstraints

      • Methods inherited from interface javax.validation.metadata.ElementDescriptor

        getElementClass
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CrossParameterDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface CrossParameterDescriptor

  • All Superinterfaces:
    ElementDescriptor

    public interface CrossParameterDescriptor
extends ElementDescriptor
    Describes an element holding cross-parameter constraints of a method or constructor
    Since:
    1.1
    Author:
    Emmanuel Bernard

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.validation.metadata.ElementDescriptor

        ElementDescriptor.ConstraintFinder

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getElementClass()

      • Methods inherited from interface javax.validation.metadata.ElementDescriptor

        findConstraints, getConstraintDescriptors, hasConstraints

    • Method Detail

      • getElementClass

        Class<?> getElementClass()
        Specified by:
        getElementClass in interface ElementDescriptor
        Returns:
        Object[].class - the type of the parameter array
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ElementDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface ElementDescriptor

  • All Known Subinterfaces:
    BeanDescriptor, ConstructorDescriptor, CrossParameterDescriptor, ExecutableDescriptor, MethodDescriptor, ParameterDescriptor, PropertyDescriptor, ReturnValueDescriptor

    public interface ElementDescriptor
    Describes a validated element (class, property, method etc.).
    Author:
    Emmanuel Bernard, Hardy Ferentschik, Gunnar Morling

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  ElementDescriptor.ConstraintFinder
      Declares restrictions on retrieved constraints.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      ElementDescriptor.ConstraintFinder findConstraints()
      Finds constraints and potentially restricts them to certain criteria.
      Set<ConstraintDescriptor<?>> getConstraintDescriptors()
      Returns all constraint descriptors for this element in the class hierarchy or an empty Set if none are present.
      Class<?> getElementClass()
      boolean | hasConstraints()

    • Method Detail

      • hasConstraints

        boolean hasConstraints()
        Returns:
        returns true if at least one constraint declaration is present for this element in the class hierarchy, false otherwise

      • getElementClass

        Class<?> getElementClass()
        Returns:
        the statically defined returned type

      • getConstraintDescriptors

        Set<ConstraintDescriptor<?>> getConstraintDescriptors()
        Returns all constraint descriptors for this element in the class hierarchy or an empty Set if none are present.
        Returns:
        Set of constraint descriptors for this element

      • findConstraints

        ElementDescriptor.ConstraintFinder findConstraints()
        Finds constraints and potentially restricts them to certain criteria.
        Returns:
        ConstraintFinder object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ElementDescriptor.ConstraintFinder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface ElementDescriptor.ConstraintFinder

  • Enclosing interface:
    ElementDescriptor

    public static interface ElementDescriptor.ConstraintFinder
    Declares restrictions on retrieved constraints. Restrictions are cumulative.

    A ConstraintFinder is not thread-safe. The set of matching ConstraintDescriptor is.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ElementDescriptor.ConstraintFinder declaredOn(ElementType... types)
      Restricts to the constraints hosted on the listed types for a given element.
      Set<ConstraintDescriptor<?>> getConstraintDescriptors()
      Retrieves the constraint descriptors following the defined restrictions and hosted on the element described by ElementDescriptor.
      boolean hasConstraints()
      Returns true if at least one constraint declaration matching the restrictions is present on the element, false otherwise.
      ElementDescriptor.ConstraintFinder lookingAt(Scope scope)
      Restricts to the constraints matching the provided scope for this element.
      ElementDescriptor.ConstraintFinder unorderedAndMatchingGroups(Class<?>... groups)
      Restricts to the constraints matching a given set of groups for this element.

    • Method Detail

      • unorderedAndMatchingGroups

        ElementDescriptor.ConstraintFinder unorderedAndMatchingGroups(Class<?>... groups)
        Restricts to the constraints matching a given set of groups for this element.

        This method respects group conversion, group sequences and group inheritance (including class-level Default group overriding) but does not return ConstraintDescriptors in any particular order. Specifically, ordering of the group sequence is not respected.

        Parameters:
        groups - groups targeted
        Returns:
        this following the chaining method pattern

      • lookingAt

        ElementDescriptor.ConstraintFinder lookingAt(Scope scope)
        Restricts to the constraints matching the provided scope for this element. Defaults to Scope.HIERARCHY
        Parameters:
        scope - expected scope
        Returns:
        this following the chaining method pattern

      • declaredOn

        ElementDescriptor.ConstraintFinder declaredOn(ElementType... types)
        Restricts to the constraints hosted on the listed types for a given element.

        Defaults to all possible types of the element.

        Typically used to restrict to fields (FIELD) or getters (METHOD).

        Parameters:
        types - targeted types
        Returns:
        this following the chaining method pattern

      • getConstraintDescriptors

        Set<ConstraintDescriptor<?>> getConstraintDescriptors()
        Retrieves the constraint descriptors following the defined restrictions and hosted on the element described by ElementDescriptor.
        Returns:
        matching constraint descriptors

      • hasConstraints

        boolean hasConstraints()
        Returns true if at least one constraint declaration matching the restrictions is present on the element, false otherwise.
        Returns:
        true if there is at least one constraint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExecutableDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface ExecutableDescriptor

  • All Superinterfaces:
    ElementDescriptor
    All Known Subinterfaces:
    ConstructorDescriptor, MethodDescriptor

    public interface ExecutableDescriptor
extends ElementDescriptor
    Provides the common functionality of MethodDescriptor and ConstructorDescriptor.
    Since:
    1.1
    Author:
    Gunnar Morling

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.validation.metadata.ElementDescriptor

        ElementDescriptor.ConstraintFinder

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ElementDescriptor.ConstraintFinder findConstraints()
      Returns a finder that will always return an empty Set.
      Set<ConstraintDescriptor<?>> getConstraintDescriptors()
      Returns an empty Set.
      CrossParameterDescriptor getCrossParameterDescriptor()
      Returns a descriptor containing the cross-parameter constraints of this executable.
      String getName()
      Returns the method name in case this descriptor represents a method or the non-qualified name of the declaring class in case this descriptor represents a constructor.
      List<ParameterDescriptor> getParameterDescriptors()
      Returns a list of descriptors representing this executable's parameters, in the order of their declaration, including synthetic parameters.
      ReturnValueDescriptor getReturnValueDescriptor()
      Returns a descriptor for this executable's return value.
      boolean hasConstrainedParameters()
      Returns true if the executable parameters are constrained either: because of a constraint on at least one of the parameters because of a cascade on at least one of the parameters (via Valid) because of at least one cross-parameter constraint

      Also returns false if there is no parameter.
      boolean hasConstrainedReturnValue()
      Returns true if the executable return value is constrained either: because of a constraint on the return value because validation is cascaded on the return value (via Valid)

      Also returns false if there is no return value.
      boolean hasConstraints()
      Returns false.

      • Methods inherited from interface javax.validation.metadata.ElementDescriptor

        getElementClass

    • Method Detail

      • getName

        String getName()
        Returns the method name in case this descriptor represents a method or the non-qualified name of the declaring class in case this descriptor represents a constructor.
        Returns:
        the name of the executable represented by this descriptor

      • getParameterDescriptors

        List<ParameterDescriptor> getParameterDescriptors()
        Returns a list of descriptors representing this executable's parameters, in the order of their declaration, including synthetic parameters.
        Returns:
        a list of descriptors representing this executable's parameters; an empty list will be returned if this executable has no parameters, but never null

      • getCrossParameterDescriptor

        CrossParameterDescriptor getCrossParameterDescriptor()
        Returns a descriptor containing the cross-parameter constraints of this executable.
        Returns:
        a descriptor containing the cross-parameter constraints of this executable

      • getReturnValueDescriptor

        ReturnValueDescriptor getReturnValueDescriptor()
        Returns a descriptor for this executable's return value.

        An executable without return value will return a descriptor representing void. This descriptor will have no constraint associated.

        Returns:
        a descriptor for this executable's return value

      • hasConstrainedParameters

        boolean hasConstrainedParameters()
        Returns true if the executable parameters are constrained either:
        • because of a constraint on at least one of the parameters
        • because of a cascade on at least one of the parameters (via Valid)
        • because of at least one cross-parameter constraint

        Also returns false if there is no parameter.

        Returns:
        true if the executable parameters are constrained

      • hasConstrainedReturnValue

        boolean hasConstrainedReturnValue()
        Returns true if the executable return value is constrained either:
        • because of a constraint on the return value
        • because validation is cascaded on the return value (via Valid)

        Also returns false if there is no return value.

        Returns:
        true if the executable return value is constrained

      • hasConstraints

        boolean hasConstraints()
        Returns false.

        An executable per se does not host constraints, use getParameterDescriptors(), getCrossParameterDescriptor() and getReturnValueDescriptor() to discover constraints.

        Specified by:
        hasConstraints in interface ElementDescriptor
        Returns:
        false

      • getConstraintDescriptors

        Set<ConstraintDescriptor<?>> getConstraintDescriptors()
        Returns an empty Set.

        An executable per se does not host constraints, use getParameterDescriptors(), getCrossParameterDescriptor() and getReturnValueDescriptor() to discover constraints.

        Specified by:
        getConstraintDescriptors in interface ElementDescriptor
        Returns:
        an empty Set

      • findConstraints

        ElementDescriptor.ConstraintFinder findConstraints()
        Returns a finder that will always return an empty Set.

        An executable per se does not host constraints, use getParameterDescriptors(), getCrossParameterDescriptor() and getReturnValueDescriptor() to discover constraints.

        Specified by:
        findConstraints in interface ElementDescriptor
        Returns:
        ConstraintFinder object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


GroupConversionDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface GroupConversionDescriptor

  • public interface GroupConversionDescriptor
    A group conversion rule to be applied during cascaded validation. Two group conversion descriptors are considered equal if they have the same from and to group respectively.
    Since:
    1.1
    Author:
    Gunnar Morling
    See Also:
    ConvertGroup

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getFrom()
      Returns the source group of this conversion rule.
      Class<?> getTo()
      Returns the target group of this conversion rule.

    • Method Detail

      • getFrom

        Class<?> getFrom()
        Returns the source group of this conversion rule.
        Returns:
        the source group of this conversion rule

      • getTo

        Class<?> getTo()
        Returns the target group of this conversion rule.
        Returns:
        the target group of this conversion rule
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.validation.metadata (Java(TM) EE 7 Specification APIs)

javax.validation.metadata

Interfaces

  • BeanDescriptor
  • CascadableDescriptor
  • ConstraintDescriptor
  • ConstructorDescriptor
  • CrossParameterDescriptor
  • ElementDescriptor
  • ElementDescriptor.ConstraintFinder
  • ExecutableDescriptor
  • GroupConversionDescriptor
  • MethodDescriptor
  • ParameterDescriptor
  • PropertyDescriptor
  • ReturnValueDescriptor

Enums

  • MethodType
  • Scope


javax.validation.metadata (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.validation.metadata

Package containing all objects specifically used and returned by the metadata API.

See: Description

  • Interface Summary
    Interface Description
    BeanDescriptor
    Describes a constrained Java Bean and the constraints associated to it.
    CascadableDescriptor
    Represents a cascadable element.
    ConstraintDescriptor<T extends Annotation>
    Describes a single constraint and its composing constraints.
    ConstructorDescriptor
    Describes a validated constructor.
    CrossParameterDescriptor
    Describes an element holding cross-parameter constraints of a method or constructor
    ElementDescriptor
    Describes a validated element (class, property, method etc.).
    ElementDescriptor.ConstraintFinder
    Declares restrictions on retrieved constraints.
    ExecutableDescriptor
    Provides the common functionality of MethodDescriptor and ConstructorDescriptor.
    GroupConversionDescriptor
    A group conversion rule to be applied during cascaded validation.
    MethodDescriptor
    Describes a validated method.
    ParameterDescriptor
    Describes a validated method or constructor parameter.
    PropertyDescriptor
    Describes a Java Bean property hosting validation constraints.
    ReturnValueDescriptor
    Describes a validated return value of a method or constructor.
  • Enum Summary
    Enum Description
    MethodType
    Represents the type of a method: getter or non getter.
    Scope
    Scope looked at when discovering constraints.

Package javax.validation.metadata Description

Package containing all objects specifically used and returned by the metadata API.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.validation.metadata Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.validation.metadata

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.validation.metadata.CascadableDescriptor
    • javax.validation.metadata.ParameterDescriptor (also extends javax.validation.metadata.ElementDescriptor)
    • javax.validation.metadata.PropertyDescriptor (also extends javax.validation.metadata.ElementDescriptor)
    • javax.validation.metadata.ReturnValueDescriptor (also extends javax.validation.metadata.ElementDescriptor)
  • javax.validation.metadata.ConstraintDescriptor<T>
  • javax.validation.metadata.ElementDescriptor
    • javax.validation.metadata.BeanDescriptor
    • javax.validation.metadata.CrossParameterDescriptor
    • javax.validation.metadata.ExecutableDescriptor
      • javax.validation.metadata.ConstructorDescriptor
      • javax.validation.metadata.MethodDescriptor
    • javax.validation.metadata.ParameterDescriptor (also extends javax.validation.metadata.CascadableDescriptor)
    • javax.validation.metadata.PropertyDescriptor (also extends javax.validation.metadata.CascadableDescriptor)
    • javax.validation.metadata.ReturnValueDescriptor (also extends javax.validation.metadata.CascadableDescriptor)
  • javax.validation.metadata.ElementDescriptor.ConstraintFinder
  • javax.validation.metadata.GroupConversionDescriptor

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.validation.metadata.Scope
      • javax.validation.metadata.MethodType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MethodDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface MethodDescriptor

  • All Superinterfaces:
    ElementDescriptor, ExecutableDescriptor

    public interface MethodDescriptor
extends ExecutableDescriptor
    Describes a validated method.
    Since:
    1.1
    Author:
    Gunnar Morling, Emmanuel Bernard

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.validation.metadata.ElementDescriptor

        ElementDescriptor.ConstraintFinder

    • Method Summary

      • Methods inherited from interface javax.validation.metadata.ExecutableDescriptor

        findConstraints, getConstraintDescriptors, getCrossParameterDescriptor, getName, getParameterDescriptors, getReturnValueDescriptor, hasConstrainedParameters, hasConstrainedReturnValue, hasConstraints

      • Methods inherited from interface javax.validation.metadata.ElementDescriptor

        getElementClass
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MethodType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.validation.metadata

Enum MethodType

  • java.lang.Object
    • java.lang.Enum<MethodType>
      • javax.validation.metadata.MethodType
  • All Implemented Interfaces:
    Serializable, Comparable<MethodType>

    public enum MethodType
extends Enum<MethodType>
    Represents the type of a method: getter or non getter.
    Since:
    1.1
    Author:
    Emmanuel Bernard

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      GETTER
      A method following the getter pattern.
      NON_GETTER
      A method that does not follow the getter pattern.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static MethodType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static MethodType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • GETTER

        public static final MethodType GETTER
        A method following the getter pattern. A getter according to the JavaBeans specification is a method whose:
        • name starts with get, has a return type but no parameter
        • name starts with is, has a return type and is returning boolean.

      • NON_GETTER

        public static final MethodType NON_GETTER
        A method that does not follow the getter pattern. A getter according to the JavaBeans specification is a method whose:
        • name starts with get, has a return type but no parameter
        • name starts with is, has a return type and is returning boolean.

    • Method Detail

      • values

        public static MethodType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (MethodType c : MethodType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static MethodType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ParameterDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface ParameterDescriptor

  • All Superinterfaces:
    CascadableDescriptor, ElementDescriptor

    public interface ParameterDescriptor
extends ElementDescriptor, CascadableDescriptor
    Describes a validated method or constructor parameter.
    Since:
    1.1
    Author:
    Gunnar Morling

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.validation.metadata.ElementDescriptor

        ElementDescriptor.ConstraintFinder

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getIndex()
      Returns this parameter's index within the parameter array of the method or constructor holding it.
      String getName()
      Returns this parameter's name as retrieved by the current parameter name resolver.

      • Methods inherited from interface javax.validation.metadata.ElementDescriptor

        findConstraints, getConstraintDescriptors, getElementClass, hasConstraints

      • Methods inherited from interface javax.validation.metadata.CascadableDescriptor

        getGroupConversions, isCascaded

    • Method Detail

      • getIndex

        int getIndex()
        Returns this parameter's index within the parameter array of the method or constructor holding it.
        Returns:
        this parameter's index

      • getName

        String getName()
        Returns this parameter's name as retrieved by the current parameter name resolver.
        Returns:
        this parameter's name
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PropertyDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface PropertyDescriptor

  • All Superinterfaces:
    CascadableDescriptor, ElementDescriptor

    public interface PropertyDescriptor
extends ElementDescriptor, CascadableDescriptor
    Describes a Java Bean property hosting validation constraints. Constraints placed on the attribute and the getter of a given property are all referenced.
    Author:
    Emmanuel Bernard

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.validation.metadata.ElementDescriptor

        ElementDescriptor.ConstraintFinder

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getPropertyName()
      Name of the property according to the Java Bean specification.

      • Methods inherited from interface javax.validation.metadata.ElementDescriptor

        findConstraints, getConstraintDescriptors, getElementClass, hasConstraints

      • Methods inherited from interface javax.validation.metadata.CascadableDescriptor

        getGroupConversions, isCascaded

    • Method Detail

      • getPropertyName

        String getPropertyName()
        Name of the property according to the Java Bean specification.
        Returns:
        property name
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ReturnValueDescriptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.metadata

Interface ReturnValueDescriptor

  • All Superinterfaces:
    CascadableDescriptor, ElementDescriptor

    public interface ReturnValueDescriptor
extends ElementDescriptor, CascadableDescriptor
    Describes a validated return value of a method or constructor.
    Since:
    1.1
    Author:
    Gunnar Morling

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.validation.metadata.ElementDescriptor

        ElementDescriptor.ConstraintFinder

    • Method Summary

      • Methods inherited from interface javax.validation.metadata.ElementDescriptor

        findConstraints, getConstraintDescriptors, getElementClass, hasConstraints

      • Methods inherited from interface javax.validation.metadata.CascadableDescriptor

        getGroupConversions, isCascaded
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Scope (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.validation.metadata

Enum Scope

  • java.lang.Object
    • java.lang.Enum<Scope>
      • javax.validation.metadata.Scope
  • All Implemented Interfaces:
    Serializable, Comparable<Scope>

    public enum Scope
extends Enum<Scope>
    Scope looked at when discovering constraints.
    Author:
    Emmanuel Bernard

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      HIERARCHY
      Look for constraints declared on all elements of the class hierarchy with the same name.
      LOCAL_ELEMENT
      Look for constraints declared on the current class element and ignore inheritance and elements with the same name in the class hierarchy.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Scope valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Scope[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LOCAL_ELEMENT

        public static final Scope LOCAL_ELEMENT
        Look for constraints declared on the current class element and ignore inheritance and elements with the same name in the class hierarchy.

      • HIERARCHY

        public static final Scope HIERARCHY
        Look for constraints declared on all elements of the class hierarchy with the same name.

    • Method Detail

      • values

        public static Scope[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Scope c : Scope.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Scope valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Uses of Package javax.validation.metadata (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.validation.metadata

  • Packages that use javax.validation.metadata
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.
  • Classes in javax.validation.metadata used by javax.validation
    Class and Description
    BeanDescriptor
    Describes a constrained Java Bean and the constraints associated to it.
    ConstraintDescriptor
    Describes a single constraint and its composing constraints.
  • Classes in javax.validation.metadata used by javax.validation.metadata
    Class and Description
    CascadableDescriptor
    Represents a cascadable element.
    ConstraintDescriptor
    Describes a single constraint and its composing constraints.
    ConstructorDescriptor
    Describes a validated constructor.
    CrossParameterDescriptor
    Describes an element holding cross-parameter constraints of a method or constructor
    ElementDescriptor
    Describes a validated element (class, property, method etc.).
    ElementDescriptor.ConstraintFinder
    Declares restrictions on retrieved constraints.
    ExecutableDescriptor
    Provides the common functionality of MethodDescriptor and ConstructorDescriptor.
    GroupConversionDescriptor
    A group conversion rule to be applied during cascaded validation.
    MethodDescriptor
    Describes a validated method.
    MethodType
    Represents the type of a method: getter or non getter.
    ParameterDescriptor
    Describes a validated method or constructor parameter.
    PropertyDescriptor
    Describes a Java Bean property hosting validation constraints.
    ReturnValueDescriptor
    Describes a validated return value of a method or constructor.
    Scope
    Scope looked at when discovering constraints.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.metadata.MethodType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.metadata.MethodType

  • Packages that use MethodType
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of MethodType in javax.validation.metadata

      Methods in javax.validation.metadata that return MethodType
      Modifier and Type Method and Description
      static MethodType MethodType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static MethodType[] MethodType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.validation.metadata with parameters of type MethodType
      Modifier and Type Method and Description
      Set<MethodDescriptor> BeanDescriptor.getConstrainedMethods(MethodType methodType, MethodType... methodTypes)
      Returns a set with descriptors for the constrained methods of the bean represented by this descriptor.
      Set<MethodDescriptor> BeanDescriptor.getConstrainedMethods(MethodType methodType, MethodType... methodTypes)
      Returns a set with descriptors for the constrained methods of the bean represented by this descriptor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.validation.metadata.Scope (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.validation.metadata.Scope

  • Packages that use Scope
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of Scope in javax.validation.metadata

      Methods in javax.validation.metadata that return Scope
      Modifier and Type Method and Description
      static Scope Scope.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Scope[] Scope.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.validation.metadata with parameters of type Scope
      Modifier and Type Method and Description
      ElementDescriptor.ConstraintFinder ElementDescriptor.ConstraintFinder.lookingAt(Scope scope)
      Restricts to the constraints matching the provided scope for this element.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.BeanDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.BeanDescriptor

  • Packages that use BeanDescriptor
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of BeanDescriptor in javax.validation

      Methods in javax.validation that return BeanDescriptor
      Modifier and Type Method and Description
      BeanDescriptor Validator.getConstraintsForClass(Class<?> clazz)
      Returns the descriptor object describing bean constraints.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.CascadableDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.CascadableDescriptor

  • Packages that use CascadableDescriptor
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of CascadableDescriptor in javax.validation.metadata

      Subinterfaces of CascadableDescriptor in javax.validation.metadata
      Modifier and Type Interface and Description
      interface  ParameterDescriptor
      Describes a validated method or constructor parameter.
      interface  PropertyDescriptor
      Describes a Java Bean property hosting validation constraints.
      interface  ReturnValueDescriptor
      Describes a validated return value of a method or constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.ConstraintDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.ConstraintDescriptor

  • Packages that use ConstraintDescriptor
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of ConstraintDescriptor in javax.validation

      Methods in javax.validation that return ConstraintDescriptor
      Modifier and Type | Method and Description
      ConstraintDescriptor<?> | MessageInterpolator.Context.getConstraintDescriptor()
      ConstraintDescriptor<?> ConstraintViolation.getConstraintDescriptor()
      Returns the constraint metadata reported to fail.

    • Uses of ConstraintDescriptor in javax.validation.metadata

      Methods in javax.validation.metadata that return types with arguments of type ConstraintDescriptor
      Modifier and Type Method and Description
      Set<ConstraintDescriptor<?>> ConstraintDescriptor.getComposingConstraints()
      Return a set of composing ConstraintDescriptors where each descriptor describes a composing constraint.
      Set<ConstraintDescriptor<?>> ExecutableDescriptor.getConstraintDescriptors()
      Returns an empty Set.
      Set<ConstraintDescriptor<?>> ElementDescriptor.getConstraintDescriptors()
      Returns all constraint descriptors for this element in the class hierarchy or an empty Set if none are present.
      Set<ConstraintDescriptor<?>> ElementDescriptor.ConstraintFinder.getConstraintDescriptors()
      Retrieves the constraint descriptors following the defined restrictions and hosted on the element described by ElementDescriptor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.ConstructorDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.ConstructorDescriptor

  • Packages that use ConstructorDescriptor
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of ConstructorDescriptor in javax.validation.metadata

      Methods in javax.validation.metadata that return ConstructorDescriptor
      Modifier and Type Method and Description
      ConstructorDescriptor BeanDescriptor.getConstraintsForConstructor(Class<?>... parameterTypes)
      Returns a constructor descriptor for the given constructor.
      Methods in javax.validation.metadata that return types with arguments of type ConstructorDescriptor
      Modifier and Type Method and Description
      Set<ConstructorDescriptor> BeanDescriptor.getConstrainedConstructors()
      Returns a set with descriptors for the constrained constructors of the bean represented by this descriptor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.CrossParameterDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.CrossParameterDescriptor

  • Packages that use CrossParameterDescriptor
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of CrossParameterDescriptor in javax.validation.metadata

      Methods in javax.validation.metadata that return CrossParameterDescriptor
      Modifier and Type Method and Description
      CrossParameterDescriptor ExecutableDescriptor.getCrossParameterDescriptor()
      Returns a descriptor containing the cross-parameter constraints of this executable.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.ElementDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.ElementDescriptor

  • Packages that use ElementDescriptor
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of ElementDescriptor in javax.validation.metadata

      Subinterfaces of ElementDescriptor in javax.validation.metadata
      Modifier and Type Interface and Description
      interface  BeanDescriptor
      Describes a constrained Java Bean and the constraints associated to it.
      interface  ConstructorDescriptor
      Describes a validated constructor.
      interface  CrossParameterDescriptor
      Describes an element holding cross-parameter constraints of a method or constructor
      interface  ExecutableDescriptor
      Provides the common functionality of MethodDescriptor and ConstructorDescriptor.
      interface  MethodDescriptor
      Describes a validated method.
      interface  ParameterDescriptor
      Describes a validated method or constructor parameter.
      interface  PropertyDescriptor
      Describes a Java Bean property hosting validation constraints.
      interface  ReturnValueDescriptor
      Describes a validated return value of a method or constructor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.ElementDescriptor.ConstraintFinder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.ElementDescriptor.ConstraintFinder

  • Packages that use ElementDescriptor.ConstraintFinder
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of ElementDescriptor.ConstraintFinder in javax.validation.metadata

      Methods in javax.validation.metadata that return ElementDescriptor.ConstraintFinder
      Modifier and Type Method and Description
      ElementDescriptor.ConstraintFinder ElementDescriptor.ConstraintFinder.declaredOn(ElementType... types)
      Restricts to the constraints hosted on the listed types for a given element.
      ElementDescriptor.ConstraintFinder ExecutableDescriptor.findConstraints()
      Returns a finder that will always return an empty Set.
      ElementDescriptor.ConstraintFinder ElementDescriptor.findConstraints()
      Finds constraints and potentially restricts them to certain criteria.
      ElementDescriptor.ConstraintFinder ElementDescriptor.ConstraintFinder.lookingAt(Scope scope)
      Restricts to the constraints matching the provided scope for this element.
      ElementDescriptor.ConstraintFinder ElementDescriptor.ConstraintFinder.unorderedAndMatchingGroups(Class<?>... groups)
      Restricts to the constraints matching a given set of groups for this element.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.ExecutableDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.ExecutableDescriptor

  • Packages that use ExecutableDescriptor
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of ExecutableDescriptor in javax.validation.metadata

      Subinterfaces of ExecutableDescriptor in javax.validation.metadata
      Modifier and Type Interface and Description
      interface  ConstructorDescriptor
      Describes a validated constructor.
      interface  MethodDescriptor
      Describes a validated method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.GroupConversionDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.GroupConversionDescriptor

  • Packages that use GroupConversionDescriptor
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of GroupConversionDescriptor in javax.validation.metadata

      Methods in javax.validation.metadata that return types with arguments of type GroupConversionDescriptor
      Modifier and Type Method and Description
      Set<GroupConversionDescriptor> CascadableDescriptor.getGroupConversions()
      Returns the group conversions configured for this element.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.MethodDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.MethodDescriptor

  • Packages that use MethodDescriptor
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of MethodDescriptor in javax.validation.metadata

      Methods in javax.validation.metadata that return MethodDescriptor
      Modifier and Type Method and Description
      MethodDescriptor BeanDescriptor.getConstraintsForMethod(String methodName, Class<?>... parameterTypes)
      Returns a method descriptor for the given method.
      Methods in javax.validation.metadata that return types with arguments of type MethodDescriptor
      Modifier and Type Method and Description
      Set<MethodDescriptor> BeanDescriptor.getConstrainedMethods(MethodType methodType, MethodType... methodTypes)
      Returns a set with descriptors for the constrained methods of the bean represented by this descriptor.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.ParameterDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.ParameterDescriptor

  • Packages that use ParameterDescriptor
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of ParameterDescriptor in javax.validation.metadata

      Methods in javax.validation.metadata that return types with arguments of type ParameterDescriptor
      Modifier and Type Method and Description
      List<ParameterDescriptor> ExecutableDescriptor.getParameterDescriptors()
      Returns a list of descriptors representing this executable's parameters, in the order of their declaration, including synthetic parameters.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.PropertyDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.PropertyDescriptor

  • Packages that use PropertyDescriptor
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of PropertyDescriptor in javax.validation.metadata

      Methods in javax.validation.metadata that return PropertyDescriptor
      Modifier and Type Method and Description
      PropertyDescriptor BeanDescriptor.getConstraintsForProperty(String propertyName)
      Returns the property descriptor for a given property.
      Methods in javax.validation.metadata that return types with arguments of type PropertyDescriptor
      Modifier and Type Method and Description
      Set<PropertyDescriptor> BeanDescriptor.getConstrainedProperties()
      Returns a set of property descriptors having at least one constraint defined or marked as cascaded (Valid).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.metadata.ReturnValueDescriptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.metadata.ReturnValueDescriptor

  • Packages that use ReturnValueDescriptor
    Package Description
    javax.validation.metadata
    Package containing all objects specifically used and returned by the metadata API.

    • Uses of ReturnValueDescriptor in javax.validation.metadata

      Methods in javax.validation.metadata that return ReturnValueDescriptor
      Modifier and Type Method and Description
      ReturnValueDescriptor ExecutableDescriptor.getReturnValueDescriptor()
      Returns a descriptor for this executable's return value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BootstrapState (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.spi

Interface BootstrapState

  • public interface BootstrapState
    Defines the state used to bootstrap the Configuration.
    Author:
    Emmanuel Bernard, Sebastian Thomschke

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ValidationProviderResolver getDefaultValidationProviderResolver()
      Specification default ValidationProviderResolver strategy instance.
      ValidationProviderResolver getValidationProviderResolver()
      User defined ValidationProviderResolver strategy instance or null if undefined.

    • Method Detail

      • getValidationProviderResolver

        ValidationProviderResolver getValidationProviderResolver()
        User defined ValidationProviderResolver strategy instance or null if undefined.
        Returns:
        ValidationProviderResolver instance or null

      • getDefaultValidationProviderResolver

        ValidationProviderResolver getDefaultValidationProviderResolver()
        Specification default ValidationProviderResolver strategy instance.
        Returns:
        default implementation of ValidationProviderResolver
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConfigurationState (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.spi

Interface ConfigurationState

  • public interface ConfigurationState
    Contract between a Configuration and a ValidationProvider to create a ValidatorFactory.

    The configuration artifacts defined in the XML configuration and provided to the Configuration are merged and passed along via ConfigurationState.

    Author:
    Emmanuel Bernard, Hardy Ferentschik, Gunnar Morling

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ConstraintValidatorFactory getConstraintValidatorFactory()
      Returns the constraint validator factory of this configuration.
      Set<InputStream> getMappingStreams()
      Returns a set of configuration streams.
      MessageInterpolator getMessageInterpolator()
      Returns the message interpolator of this configuration.
      ParameterNameProvider getParameterNameProvider()
      Returns the parameter name provider for this configuration.
      Map<String,String> getProperties()
      Returns a map of non type-safe custom properties.
      TraversableResolver getTraversableResolver()
      Returns the traversable resolver for this configuration.
      boolean isIgnoreXmlConfiguration()
      Returns true if Configuration.ignoreXmlConfiguration() has been called.

    • Method Detail

      • isIgnoreXmlConfiguration

        boolean isIgnoreXmlConfiguration()
        Returns true if Configuration.ignoreXmlConfiguration() has been called.

        In this case, the ValidatorFactory must ignore META-INF/validation.xml.

        Returns:
        true if META-INF/validation.xml should be ignored

      • getMessageInterpolator

        MessageInterpolator getMessageInterpolator()
        Returns the message interpolator of this configuration.

        Message interpolator is defined in the following decreasing priority:

        • set via the Configuration programmatic API
        • defined in META-INF/validation.xml provided that ignoreXmlConfiguration is false. In this case the instance is created via its no-arg constructor.
        • null if undefined.
        Returns:
        message interpolator instance or null if not defined

      • getMappingStreams

        Set<InputStream> getMappingStreams()
        Returns a set of configuration streams.

        The streams are defined by:

        • mapping XML streams passed programmatically in Configuration
        • mapping XML streams located in the resources defined in META-INF/validation.xml (constraint-mapping element)

        Streams represented in the XML configuration and opened by the Configuration implementation must be closed by the Configuration implementation after the ValidatorFactory creation (or if an exception occurs). All streams are guaranteed to adhere to the mark/reset contract (see InputStream.markSupported() by the Bean Validation provider.

        Returns:
        set of input stream

      • getConstraintValidatorFactory

        ConstraintValidatorFactory getConstraintValidatorFactory()
        Returns the constraint validator factory of this configuration.

        The ConstraintValidatorFactory implementation is defined in the following decreasing priority:

        • set via the Configuration programmatic API
        • defined in META-INF/validation.xml provided that ignoredXmlConfiguration is false. In this case the instance is created via its no-arg constructor.
        • null if undefined.
        Returns:
        factory instance or null if not defined

      • getTraversableResolver

        TraversableResolver getTraversableResolver()
        Returns the traversable resolver for this configuration.

        TraversableResolver is defined in the following decreasing priority:

        • set via the Configuration programmatic API
        • defined in META-INF/validation.xml provided that ignoredXmlConfiguration is false. In this case the instance is created via its no-arg constructor.
        • null if undefined.
        Returns:
        traversable resolver instance or null if not defined

      • getParameterNameProvider

        ParameterNameProvider getParameterNameProvider()
        Returns the parameter name provider for this configuration.

        ParameterNameProvider is defined in the following decreasing priority:

        • set via the Configuration programmatic API
        • defined in META-INF/validation.xml provided that ignoreXmlConfiguration is false. In this case the instance is created via its no-arg constructor.
        • null if undefined.
        Returns:
        parameter name provider instance or null if not defined
        Since:
        1.1

      • getProperties

        Map<String,String> getProperties()
        Returns a map of non type-safe custom properties.

        Properties defined via:

        • Configuration.addProperty(String, String)
        • META-INF/validation.xml provided that ignoreXmlConfiguration
          • is false.

        If a property is defined both programmatically and in XML, the value defined programmatically has priority.

        Returns:
        Map whose key is the property key and the value the property value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.validation.spi (Java(TM) EE 7 Specification APIs)

javax.validation.spi

Interfaces

  • BootstrapState
  • ConfigurationState
  • ValidationProvider


javax.validation.spi (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.validation.spi

Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

See: Description

  • Interface Summary
    Interface Description
    BootstrapState
    Defines the state used to bootstrap the Configuration.
    ConfigurationState
    Contract between a Configuration and a ValidationProvider to create a ValidatorFactory.
    ValidationProvider<T extends Configuration<T>>
    Contract between the validation bootstrap mechanism and the provider engine.

Package javax.validation.spi Description

Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.validation.spi Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.validation.spi

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.validation.spi.BootstrapState
  • javax.validation.spi.ConfigurationState
  • javax.validation.spi.ValidationProvider<T>
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.validation.spi (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.validation.spi

  • Packages that use javax.validation.spi
    Package Description
    javax.validation
    Top level package of the Bean Validation API.
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.
  • Classes in javax.validation.spi used by javax.validation
    Class and Description
    ValidationProvider
    Contract between the validation bootstrap mechanism and the provider engine.
  • Classes in javax.validation.spi used by javax.validation.spi
    Class and Description
    BootstrapState
    Defines the state used to bootstrap the Configuration.
    ConfigurationState
    Contract between a Configuration and a ValidationProvider to create a ValidatorFactory.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidationProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.validation.spi

Interface ValidationProvider<T extends Configuration<T>>

  • public interface ValidationProvider<T extends Configuration<T>>
    Contract between the validation bootstrap mechanism and the provider engine.

    Implementations must have a public no-arg constructor. The construction of a provider should be as "lightweight" as possible. T represents the provider specific Configuration subclass which typically host provider's additional configuration methods.

    Author:
    Emmanuel Bernard, Hardy Ferentschik

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ValidatorFactory buildValidatorFactory(ConfigurationState configurationState)
      Build a ValidatorFactory using the current provider implementation.
      Configuration<?> createGenericConfiguration(BootstrapState state)
      Returns a Configuration instance.
      T createSpecializedConfiguration(BootstrapState state)
      Returns a Configuration instance implementing T, the Configuration sub-interface.

    • Method Detail

      • createSpecializedConfiguration

        T createSpecializedConfiguration(BootstrapState state)
        Returns a Configuration instance implementing T, the Configuration sub-interface. The returned Configuration instance must use the current provider (this) to build the ValidatorFactory instance.
        Parameters:
        state - bootstrap state
        Returns:
        specific Configuration implementation

      • createGenericConfiguration

        Configuration<?> createGenericConfiguration(BootstrapState state)
        Returns a Configuration instance. This instance is not bound to use the current provider. The choice of provider follows the algorithm described in Configuration

        The ValidationProviderResolver used by Configuration is provided by state. If null, the default ValidationProviderResolver is used.

        Parameters:
        state - bootstrap state
        Returns:
        non specialized Configuration implementation

      • buildValidatorFactory

        ValidatorFactory buildValidatorFactory(ConfigurationState configurationState)
        Build a ValidatorFactory using the current provider implementation.

        The ValidatorFactory is assembled and follows the configuration passed via ConfigurationState.

        The returned ValidatorFactory is properly initialized and ready for use.

        Parameters:
        configurationState - the configuration descriptor
        Returns:
        the instantiated ValidatorFactory
        Throws:
        ValidationException - if the ValidatorFactory cannot be built
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface javax.validation.spi.BootstrapState (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.spi.BootstrapState

  • Packages that use BootstrapState
    Package Description
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

    • Uses of BootstrapState in javax.validation.spi

      Methods in javax.validation.spi with parameters of type BootstrapState
      Modifier and Type Method and Description
      Configuration<?> ValidationProvider.createGenericConfiguration(BootstrapState state)
      Returns a Configuration instance.
      T ValidationProvider.createSpecializedConfiguration(BootstrapState state)
      Returns a Configuration instance implementing T, the Configuration sub-interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.spi.ConfigurationState (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.spi.ConfigurationState

  • Packages that use ConfigurationState
    Package Description
    javax.validation.spi
    Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

    • Uses of ConfigurationState in javax.validation.spi

      Methods in javax.validation.spi with parameters of type ConfigurationState
      Modifier and Type Method and Description
      ValidatorFactory ValidationProvider.buildValidatorFactory(ConfigurationState configurationState)
      Build a ValidatorFactory using the current provider implementation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.validation.spi.ValidationProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.validation.spi.ValidationProvider

  • Packages that use ValidationProvider
    Package Description
    javax.validation
    Top level package of the Bean Validation API.

    • Uses of ValidationProvider in javax.validation

      Methods in javax.validation with type parameters of type ValidationProvider
      Modifier and Type Method and Description
      static <T extends Configuration<T>,U extends ValidationProvider<T>>
      ProviderSpecificBootstrap<T>             		Validation.byProvider(Class<U> providerType)
      Builds a Configuration for a particular provider implementation.
      Methods in javax.validation that return types with arguments of type ValidationProvider
      Modifier and Type Method and Description
      List<ValidationProvider<?>> ValidationProviderResolver.getValidationProviders()
      Returns a list of ValidationProvider available in the runtime environment.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ClientEndpoint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.websocket

Annotation Type ClientEndpoint

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface ClientEndpoint
    The ClientEndpoint annotation a class level annotation is used to denote that a POJO is a web socket client and can be deployed as such. Similar to ServerEndpoint, POJOs that are annotated with this annotation can have methods that, using the web socket method level annotations, are web socket lifecycle methods.

    For example:

 @ClientEndpoint(subprotocols="chat")
 public class HelloServer {

     @OnMessage
     public void processMessageFromServer(String message, Session session) {
         System.out.println("Message came from the server ! " + message);
     }

 }
    Author:
    dannycoward

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class<? extends ClientEndpointConfig.Configurator> configurator
      An optional custom configurator class that the developer would like to use to provide custom configuration of new instances of this endpoint.
      Class<? extends Decoder>[] decoders
      The array of Java classes that are to act as Decoders for messages coming into the client.
      Class<? extends Encoder>[] encoders
      The array of Java classes that are to act as Encoders for messages sent by the client.
      String[] subprotocols
      The names of the subprotocols this client supports.

    • Element Detail

      • subprotocols

        public abstract String[] subprotocols
        The names of the subprotocols this client supports.
        Returns:
        the array of names of the subprotocols.
        Default:
        {}

      • decoders

        public abstract Class<? extends Decoder>[] decoders
        The array of Java classes that are to act as Decoders for messages coming into the client.
        Returns:
        the array of decoders.
        Default:
        {}

      • encoders

        public abstract Class<? extends Encoder>[] encoders
        The array of Java classes that are to act as Encoders for messages sent by the client.
        Returns:
        the array of decoders.
        Default:
        {}

      • configurator

        public abstract Class<? extends ClientEndpointConfig.Configurator> configurator
        An optional custom configurator class that the developer would like to use to provide custom configuration of new instances of this endpoint. The implementation creates a new instance of the configurator per logical endpoint.
        Returns:
        the custom configurator class, or ClientEndpointConfigurator.class if none was provided in the annotation.
        Default:
        javax.websocket.ClientEndpointConfig.Configurator.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ClientEndpointConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface ClientEndpointConfig

  • All Superinterfaces:
    EndpointConfig

    public interface ClientEndpointConfig
extends EndpointConfig
    The ClientEndpointConfig is a special kind of endpoint configuration object that contains web socket configuration information specific only to client endpoints. Developers deploying programmatic client endpoints can create instances of this configuration by using a ClientEndpointConfig.Builder. Developers can override some of the configuration operations by providing an implementation of ClientEndpointConfig.Configurator.
    Author:
    dannycoward

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  ClientEndpointConfig.Builder
      The ClientEndpointConfig.Builder is a class used for creating ClientEndpointConfig objects for the purposes of deploying a client endpoint.
      static class  ClientEndpointConfig.Configurator
      The Configurator class may be extended by developers who want to provide custom configuration algorithms, such as intercepting the opening handshake, or providing arbitrary methods and algorithms that can be accessed from each endpoint instance configured with this configurator.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ClientEndpointConfig.Configurator getConfigurator()
      Return the custom configurator for this configuration.
      List<Extension> getExtensions()
      Return the extensions, in order of preference, favorite first, that this client would like to use for its sessions.
      List<String> getPreferredSubprotocols()
      Return the ordered list of sub protocols a client endpoint would like to use, in order of preference, favorite first that this client would like to use for its sessions.

      • Methods inherited from interface javax.websocket.EndpointConfig

        getDecoders, getEncoders, getUserProperties

    • Method Detail

      • getPreferredSubprotocols

        List<String> getPreferredSubprotocols()
        Return the ordered list of sub protocols a client endpoint would like to use, in order of preference, favorite first that this client would like to use for its sessions. This list is used to generate the Sec-WebSocket-Protocol header in the opening handshake for clients using this configuration. The first protocol name is the most preferred. See Client Opening Handshake.
        Returns:
        the list of the preferred subprotocols, the empty list if there are none

      • getExtensions

        List<Extension> getExtensions()
        Return the extensions, in order of preference, favorite first, that this client would like to use for its sessions. These are the extensions that will be used to populate the Sec-WebSocket-Extensions header in the opening handshake for clients using this configuration. The first extension in the list is the most preferred extension. See Negotiating Extensions.
        Returns:
        the list of extensions, the empty list if there are none.

      • getConfigurator

        ClientEndpointConfig.Configurator getConfigurator()
        Return the custom configurator for this configuration. If the developer did not provide one, the platform default configurator is returned.
        Returns:
        the configurator in use with this configuration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientEndpointConfig.Builder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Class ClientEndpointConfig.Builder

  • java.lang.Object
    • javax.websocket.ClientEndpointConfig.Builder
  • Enclosing interface:
    ClientEndpointConfig

    public static final class ClientEndpointConfig.Builder
extends Object
    The ClientEndpointConfig.Builder is a class used for creating ClientEndpointConfig objects for the purposes of deploying a client endpoint. Here are some examples: Building a plain configuration with no encoders, decoders, subprotocols or extensions. ClientEndpointConfig cec = ClientEndpointConfig.Builder.create().build(); Building a configuration with no subprotocols and a custom configurator.

 ClientEndpointConfig customCec = ClientEndpointConfig.Builder.create()
         .preferredSubprotocols(mySubprotocols)
         .configurator(new MyClientConfigurator())
         .build();
    Author:
    dannycoward

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ClientEndpointConfig build()
      Builds a configuration object using the attributes set on this builder.
      ClientEndpointConfig.Builder configurator(ClientEndpointConfig.Configurator clientEndpointConfigurator)
      Sets the configurator object for the configuration this builder will build.
      static ClientEndpointConfig.Builder create()
      Creates a new builder object with no subprotocols, extensions, encoders, decoders and a null configurator.
      ClientEndpointConfig.Builder decoders(List<Class<? extends Decoder>> decoders)
      Assign the list of decoder implementation classes the client will use.
      ClientEndpointConfig.Builder encoders(List<Class<? extends Encoder>> encoders)
      Assign the list of encoder implementation classes the client will use.
      ClientEndpointConfig.Builder extensions(List<Extension> extensions)
      Set the extensions for the configuration this builder will build.
      ClientEndpointConfig.Builder preferredSubprotocols(List<String> preferredSubprotocols)
      Set the preferred sub protocols for the configuration this builder will build.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • create

        public static ClientEndpointConfig.Builder create()
        Creates a new builder object with no subprotocols, extensions, encoders, decoders and a null configurator.
        Returns:
        a new builder object.

      • build

        public ClientEndpointConfig build()
        Builds a configuration object using the attributes set on this builder.
        Returns:
        a new configuration object.

      • configurator

        public ClientEndpointConfig.Builder configurator(ClientEndpointConfig.Configurator clientEndpointConfigurator)
        Sets the configurator object for the configuration this builder will build.
        Parameters:
        clientEndpointConfigurator - the configurator
        Returns:
        the builder instance

      • preferredSubprotocols

        public ClientEndpointConfig.Builder preferredSubprotocols(List<String> preferredSubprotocols)
        Set the preferred sub protocols for the configuration this builder will build. The list is treated in order of preference, favorite first, that this client would like to use for its sessions.
        Parameters:
        preferredSubprotocols - the preferred subprotocol names.
        Returns:
        the builder instance

      • extensions

        public ClientEndpointConfig.Builder extensions(List<Extension> extensions)
        Set the extensions for the configuration this builder will build. The list is treated in order of preference, favorite first, that the client would like to use for its sessions.
        Parameters:
        extensions - the extensions
        Returns:
        the builder instance

      • encoders

        public ClientEndpointConfig.Builder encoders(List<Class<? extends Encoder>> encoders)
        Assign the list of encoder implementation classes the client will use.
        Parameters:
        encoders - the encoder implementation classes
        Returns:
        the builder instance

      • decoders

        public ClientEndpointConfig.Builder decoders(List<Class<? extends Decoder>> decoders)
        Assign the list of decoder implementation classes the client will use.
        Parameters:
        decoders - the decoder implementation classes
        Returns:
        this builder instance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientEndpointConfig.Configurator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Class ClientEndpointConfig.Configurator

  • java.lang.Object
    • javax.websocket.ClientEndpointConfig.Configurator
  • Enclosing interface:
    ClientEndpointConfig

    public static class ClientEndpointConfig.Configurator
extends Object
    The Configurator class may be extended by developers who want to provide custom configuration algorithms, such as intercepting the opening handshake, or providing arbitrary methods and algorithms that can be accessed from each endpoint instance configured with this configurator.

    • Constructor Summary

      Constructors
      Constructor and Description
      ClientEndpointConfig.Configurator()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterResponse(HandshakeResponse hr)
      This method is called by the implementation after it has received a handshake response from the server as a result of a handshake interaction it initiated.
      void beforeRequest(Map<String,List<String>> headers)
      This method is called by the implementation after it has formulated the handshake request that will be used to initiate the connection to the server, but before it has sent any part of the request.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ClientEndpointConfig.Configurator

        public ClientEndpointConfig.Configurator()

    • Method Detail

      • beforeRequest

        public void beforeRequest(Map<String,List<String>> headers)
        This method is called by the implementation after it has formulated the handshake request that will be used to initiate the connection to the server, but before it has sent any part of the request. This allows the developer to inspect and modify the handshake request headers prior to the start of the handshake interaction.
        Parameters:
        headers - the mutable map of handshake request headers the implementation is about to send to start the handshake interaction.

      • afterResponse

        public void afterResponse(HandshakeResponse hr)
        This method is called by the implementation after it has received a handshake response from the server as a result of a handshake interaction it initiated. The developer may implement this method in order to inspect the returning handshake response.
        Parameters:
        hr - the handshake response sent by the server.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CloseReason (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Class CloseReason

  • java.lang.Object
    • javax.websocket.CloseReason

  • public class CloseReason
extends Object
    A class encapsulating the reason why a web socket has been closed, or why it is being asked to close. Note the acceptable uses of codes and reason phrase are defined in more detail by RFC 6455.
    Author:
    dannycoward

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static interface  CloseReason.CloseCode
      A marker interface for the close codes.
      static class  CloseReason.CloseCodes
      An Enumeration of status codes for a web socket close that are defined in the specification.

    • Constructor Summary

      Constructors
      Constructor and Description
      CloseReason(CloseReason.CloseCode closeCode, String reasonPhrase)
      Creates a reason for closing a web socket connection with the given code and reason phrase.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      CloseReason.CloseCode getCloseCode()
      The Close code associated with this CloseReason.
      String getReasonPhrase()
      The reason phrase associated with this CloseReason.
      String toString()
      Converts the CloseReason to a debug-friendly string.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • CloseReason

        public CloseReason(CloseReason.CloseCode closeCode,
           String reasonPhrase)
        Creates a reason for closing a web socket connection with the given code and reason phrase.
        Parameters:
        closeCode - the close code, may not be null
        reasonPhrase - the reason phrase, may be null.

    • Method Detail

      • getCloseCode

        public CloseReason.CloseCode getCloseCode()
        The Close code associated with this CloseReason.
        Returns:
        the close code.

      • getReasonPhrase

        public String getReasonPhrase()
        The reason phrase associated with this CloseReason.
        Returns:
        the reason phrase. If there is no reason phrase, this returns the empty string

      • toString

        public String toString()
        Converts the CloseReason to a debug-friendly string. The exact format is not defined by the specification and may change in future releases.
        Overrides:
        toString in class Object
        Returns:
        A String representation of this CloseReason
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CloseReason.CloseCode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface CloseReason.CloseCode

  • All Known Implementing Classes:
    CloseReason.CloseCodes
    Enclosing class:
    CloseReason

    public static interface CloseReason.CloseCode
    A marker interface for the close codes. This interface may be implemented by enumerations that contain web socket close codes, for example enumerations that contain all the in use close codes as of web socket 1.0, or an enumeration that contains close codes that are currently reserved for special use by the web socket specification.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getCode()
      Returns the code number, for example the integer '1000' for normal closure.

    • Method Detail

      • getCode

        int getCode()
        Returns the code number, for example the integer '1000' for normal closure.
        Returns:
        the code number
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CloseReason.CloseCodes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.websocket

Enum CloseReason.CloseCodes

  • java.lang.Object
    • java.lang.Enum<CloseReason.CloseCodes>
      • javax.websocket.CloseReason.CloseCodes
  • All Implemented Interfaces:
    Serializable, Comparable<CloseReason.CloseCodes>, CloseReason.CloseCode
    Enclosing class:
    CloseReason

    public static enum CloseReason.CloseCodes
extends Enum<CloseReason.CloseCodes>
implements CloseReason.CloseCode
    An Enumeration of status codes for a web socket close that are defined in the specification.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      CANNOT_ACCEPT
      1003 indicates that an endpoint is terminating the connection because it has received a type of data it cannot accept (e.g., an endpoint that understands only text data MAY send this if it receives a binary message).
      CLOSED_ABNORMALLY
      1006 is a reserved value and MUST NOT be set as a status code in a Close control frame by an endpoint.
      GOING_AWAY
      1001 indicates that an endpoint is "going away", such as a server going down or a browser having navigated away from a page.
      NO_EXTENSION
      1010 indicates that an endpoint (client) is terminating the connection because it has expected the server to negotiate one or more extension, but the server didn't return them in the response message of the WebSocket handshake.
      NO_STATUS_CODE
      1005 is a reserved value and MUST NOT be set as a status code in a Close control frame by an endpoint.
      NORMAL_CLOSURE
      1000 indicates a normal closure, meaning that the purpose for which the connection was established has been fulfilled.
      NOT_CONSISTENT
      1007 indicates that an endpoint is terminating the connection because it has received data within a message that was not consistent with the type of the message (e.g., non-UTF-8 data within a text message).
      PROTOCOL_ERROR
      1002 indicates that an endpoint is terminating the connection due to a protocol error.
      RESERVED
      Reserved.
      SERVICE_RESTART
      1012 indicates that the service will be restarted.
      TLS_HANDSHAKE_FAILURE
      1015 is a reserved value and MUST NOT be set as a status code in a Close control frame by an endpoint.
      TOO_BIG
      1009 indicates that an endpoint is terminating the connection because it has received a message that is too big for it to process.
      TRY_AGAIN_LATER
      1013 indicates that the service is experiencing overload
      UNEXPECTED_CONDITION
      1011 indicates that a server is terminating the connection because it encountered an unexpected condition that prevented it from fulfilling the request.
      VIOLATED_POLICY
      1008 indicates that an endpoint is terminating the connection because it has received a message that violates its policy.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static CloseReason.CloseCode getCloseCode(int code)
      Creates a CloseCode from the given int code number.
      int getCode()
      Return the code number of this status code.
      static CloseReason.CloseCodes valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CloseReason.CloseCodes[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NORMAL_CLOSURE

        public static final CloseReason.CloseCodes NORMAL_CLOSURE
        1000 indicates a normal closure, meaning that the purpose for which the connection was established has been fulfilled.

      • GOING_AWAY

        public static final CloseReason.CloseCodes GOING_AWAY
        1001 indicates that an endpoint is "going away", such as a server going down or a browser having navigated away from a page.

      • PROTOCOL_ERROR

        public static final CloseReason.CloseCodes PROTOCOL_ERROR
        1002 indicates that an endpoint is terminating the connection due to a protocol error.

      • CANNOT_ACCEPT

        public static final CloseReason.CloseCodes CANNOT_ACCEPT
        1003 indicates that an endpoint is terminating the connection because it has received a type of data it cannot accept (e.g., an endpoint that understands only text data MAY send this if it receives a binary message).

      • RESERVED

        public static final CloseReason.CloseCodes RESERVED
        Reserved. The specific meaning might be defined in the future.

      • NO_STATUS_CODE

        public static final CloseReason.CloseCodes NO_STATUS_CODE
        1005 is a reserved value and MUST NOT be set as a status code in a Close control frame by an endpoint. It is designated for use in applications expecting a status code to indicate that no status code was actually present.

      • CLOSED_ABNORMALLY

        public static final CloseReason.CloseCodes CLOSED_ABNORMALLY
        1006 is a reserved value and MUST NOT be set as a status code in a Close control frame by an endpoint. It is designated for use in applications expecting a status code to indicate that the connection was closed abnormally, e.g., without sending or receiving a Close control frame.

      • NOT_CONSISTENT

        public static final CloseReason.CloseCodes NOT_CONSISTENT
        1007 indicates that an endpoint is terminating the connection because it has received data within a message that was not consistent with the type of the message (e.g., non-UTF-8 data within a text message).

      • VIOLATED_POLICY

        public static final CloseReason.CloseCodes VIOLATED_POLICY
        1008 indicates that an endpoint is terminating the connection because it has received a message that violates its policy. This is a generic status code that can be returned when there is no other more suitable status code (e.g., 1003 or 1009) or if there is a need to hide specific details about the policy.

      • TOO_BIG

        public static final CloseReason.CloseCodes TOO_BIG
        1009 indicates that an endpoint is terminating the connection because it has received a message that is too big for it to process.

      • NO_EXTENSION

        public static final CloseReason.CloseCodes NO_EXTENSION
        1010 indicates that an endpoint (client) is terminating the connection because it has expected the server to negotiate one or more extension, but the server didn't return them in the response message of the WebSocket handshake. The list of extensions that are needed SHOULD appear in the /reason/ part of the Close frame. Note that this status code is not used by the server, because it can fail the WebSocket handshake instead.

      • UNEXPECTED_CONDITION

        public static final CloseReason.CloseCodes UNEXPECTED_CONDITION
        1011 indicates that a server is terminating the connection because it encountered an unexpected condition that prevented it from fulfilling the request.

      • SERVICE_RESTART

        public static final CloseReason.CloseCodes SERVICE_RESTART
        1012 indicates that the service will be restarted.

      • TRY_AGAIN_LATER

        public static final CloseReason.CloseCodes TRY_AGAIN_LATER
        1013 indicates that the service is experiencing overload

      • TLS_HANDSHAKE_FAILURE

        public static final CloseReason.CloseCodes TLS_HANDSHAKE_FAILURE
        1015 is a reserved value and MUST NOT be set as a status code in a Close control frame by an endpoint. It is designated for use in applications expecting a status code to indicate that the connection was closed due to a failure to perform a TLS handshake (e.g., the server certificate can't be verified).

    • Method Detail

      • values

        public static CloseReason.CloseCodes[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (CloseReason.CloseCodes c : CloseReason.CloseCodes.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static CloseReason.CloseCodes valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • getCloseCode

        public static CloseReason.CloseCode getCloseCode(int code)
        Creates a CloseCode from the given int code number. This method throws an IllegalArgumentException if the int is not one of the
        Parameters:
        code - the integer code number
        Returns:
        a new CloseCode with the given code number
        Throws:
        IllegalArgumentException - if the code is not a valid close code

      • getCode

        public int getCode()
        Return the code number of this status code.
        Specified by:
        getCode in interface CloseReason.CloseCode
        Returns:
        the code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ContainerProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Class ContainerProvider

  • java.lang.Object
    • javax.websocket.ContainerProvider

  • public abstract class ContainerProvider
extends Object
    Provider class that allows the developer to get a reference to the implementation of the WebSocketContainer. The provider class uses the ServiceLoader to load an implementation of ContainerProvider. Specifically, the fully qualified classname of the container implementation of ContainerProvider must be listed in the META-INF/services/javax.websocket.ContainerProvider file in the implementation JAR file.
    Author:
    dannycoward

    • Constructor Summary

      Constructors
      Constructor and Description
      ContainerProvider()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected abstract WebSocketContainer getContainer()
      Load the container implementation.
      static WebSocketContainer getWebSocketContainer()
      Obtain a new instance of a WebSocketContainer.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ContainerProvider

        public ContainerProvider()

    • Method Detail

      • getWebSocketContainer

        public static WebSocketContainer getWebSocketContainer()
        Obtain a new instance of a WebSocketContainer. The method looks for the ContainerProvider implementation class in the order listed in the META-INF/services/javax.websocket.ContainerProvider file, returning the WebSocketContainer implementation from the ContainerProvider implementation that is not null.
        Returns:
        an implementation provided instance of type WebSocketContainer

      • getContainer

        protected abstract WebSocketContainer getContainer()
        Load the container implementation.
        Returns:
        the implementation class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DecodeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Class DecodeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.websocket.DecodeException
  • All Implemented Interfaces:
    Serializable

    public class DecodeException
extends Exception
    A general exception that occurs when trying to decode a custom object from a text or binary message.
    Author:
    dannycoward
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DecodeException(ByteBuffer bb, String message)
      Constructs a DecodedException with the given ByteBuffer that cannot be decoded, and reason why.
      DecodeException(ByteBuffer bb, String message, Throwable cause)
      Constructor with the binary data that could not be decoded, and the reason why it failed to be, and the cause.
      DecodeException(String encodedString, String message)
      Constructs a DecodedException with the given encoded string that cannot be decoded, and reason why.
      DecodeException(String encodedString, String message, Throwable cause)
      Constructor with the text data that could not be decoded, and the reason why it failed to be, and the cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ByteBuffer getBytes()
      Return the ByteBuffer containing either the whole message, or the partial message, that could not be decoded, or null if this exception arose from a failure to decode a text message.
      String getText()
      Return the encoded string that is either the whole message, or the partial message that could not be decoded, or null if this exception arose from a failure to decode a binary message..

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DecodeException

        public DecodeException(ByteBuffer bb,
               String message,
               Throwable cause)
        Constructor with the binary data that could not be decoded, and the reason why it failed to be, and the cause. The buffer may represent the whole message, or the part of the message most relevant to the decoding error, depending whether the application is using one of the streaming methods or not.
        Parameters:
        bb - the byte buffer containing the (part of) the message that could not be decoded.
        message - the reason for the failure.
        cause - the cause of the error.

      • DecodeException

        public DecodeException(String encodedString,
               String message,
               Throwable cause)
        Constructor with the text data that could not be decoded, and the reason why it failed to be, and the cause. The encoded string may represent the whole message, or the part of the message most relevant to the decoding error, depending whether the application is using one of the streaming methods or not.
        Parameters:
        encodedString - the string representing the (part of) the message that could not be decoded.
        message - the reason for the failure.
        cause - the cause of the error.

      • DecodeException

        public DecodeException(ByteBuffer bb,
               String message)
        Constructs a DecodedException with the given ByteBuffer that cannot be decoded, and reason why. The buffer may represent the whole message, or the part of the message most relevant to the decoding error, depending whether the application is using one of the streaming methods or not.
        Parameters:
        bb - the byte buffer containing the (part of) the message that could not be decoded.
        message - the reason for the failure.

      • DecodeException

        public DecodeException(String encodedString,
               String message)
        Constructs a DecodedException with the given encoded string that cannot be decoded, and reason why. The encoded string may represent the whole message, or the part of the message most relevant to the decoding error, depending whether the application is using one of the streaming methods or not.
        Parameters:
        encodedString - the string representing the (part of) the message that could not be decoded.
        message - the reason for the failure.

    • Method Detail

      • getBytes

        public ByteBuffer getBytes()
        Return the ByteBuffer containing either the whole message, or the partial message, that could not be decoded, or null if this exception arose from a failure to decode a text message.
        Returns:
        the binary data not decoded or null for text message failures.

      • getText

        public String getText()
        Return the encoded string that is either the whole message, or the partial message that could not be decoded, or null if this exception arose from a failure to decode a binary message..
        Returns:
        the text not decoded or null for binary message failures.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Decoder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Decoder

  • All Known Subinterfaces:
    Decoder.Binary<T>, Decoder.BinaryStream<T>, Decoder.Text<T>, Decoder.TextStream<T>

    public interface Decoder
    The Decoder interface holds member interfaces that define how a developer can provide the web socket container a way web socket messages into developer defined custom objects. The websocket implementation creates a new instance of the decoder per endpoint instance per connection. The lifecycle of the Decoder instance is governed by the container calls to the init(javax.websocket.EndpointConfig) and destroy() methods.
    Author:
    dannycoward

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  Decoder.Binary<T>
      This interface defines how a custom object (of type T) is decoded from a web socket message in the form of a byte buffer.
      static interface  Decoder.BinaryStream<T>
      This interface defines how a custom object is decoded from a web socket message in the form of a binary stream.
      static interface  Decoder.Text<T>
      This interface defines how a custom object is decoded from a web socket message in the form of a string.
      static interface  Decoder.TextStream<T>
      This interface defines how a custom object of type T is decoded from a web socket message in the form of a character stream.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      This method is called when the decoder is about to be removed from service in order that any resources the encoder used may be closed gracefully.
      void init(EndpointConfig config)
      This method is called with the endpoint configuration object of the endpoint this decoder is intended for when it is about to be brought into service.

    • Method Detail

      • init

        void init(EndpointConfig config)
        This method is called with the endpoint configuration object of the endpoint this decoder is intended for when it is about to be brought into service.
        Parameters:
        config - the endpoint configuration object when being brought into service

      • destroy

        void destroy()
        This method is called when the decoder is about to be removed from service in order that any resources the encoder used may be closed gracefully.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Decoder.Binary (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Decoder.Binary<T>

  • All Superinterfaces:
    Decoder
    Enclosing interface:
    Decoder

    public static interface Decoder.Binary<T>
extends Decoder
    This interface defines how a custom object (of type T) is decoded from a web socket message in the form of a byte buffer.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.Decoder

        Decoder.Binary<T>, Decoder.BinaryStream<T>, Decoder.Text<T>, Decoder.TextStream<T>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T decode(ByteBuffer bytes)
      Decode the given bytes into an object of type T.
      boolean willDecode(ByteBuffer bytes)
      Answer whether the given bytes can be decoded into an object of type T.

      • Methods inherited from interface javax.websocket.Decoder

        destroy, init

    • Method Detail

      • decode

        T decode(ByteBuffer bytes)
         throws DecodeException
        Decode the given bytes into an object of type T.
        Parameters:
        bytes - the bytes to be decoded.
        Returns:
        the decoded object.
        Throws:
        DecodeException

      • willDecode

        boolean willDecode(ByteBuffer bytes)
        Answer whether the given bytes can be decoded into an object of type T.
        Parameters:
        bytes - the bytes to be decoded.
        Returns:
        whether or not the bytes can be decoded by this decoder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Decoder.BinaryStream (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Decoder.BinaryStream<T>

  • All Superinterfaces:
    Decoder
    Enclosing interface:
    Decoder

    public static interface Decoder.BinaryStream<T>
extends Decoder
    This interface defines how a custom object is decoded from a web socket message in the form of a binary stream.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.Decoder

        Decoder.Binary<T>, Decoder.BinaryStream<T>, Decoder.Text<T>, Decoder.TextStream<T>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T decode(InputStream is)
      Decode the given bytes read from the input stream into an object of type T.

      • Methods inherited from interface javax.websocket.Decoder

        destroy, init

    • Method Detail

      • decode

        T decode(InputStream is)
         throws DecodeException,
                IOException
        Decode the given bytes read from the input stream into an object of type T.
        Parameters:
        is - the input stream carrying the bytes.
        Returns:
        the decoded object.
        Throws:
        DecodeException
        IOException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Decoder.Text (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Decoder.Text<T>

  • All Superinterfaces:
    Decoder
    Enclosing interface:
    Decoder

    public static interface Decoder.Text<T>
extends Decoder
    This interface defines how a custom object is decoded from a web socket message in the form of a string.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.Decoder

        Decoder.Binary<T>, Decoder.BinaryStream<T>, Decoder.Text<T>, Decoder.TextStream<T>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T decode(String s)
      Decode the given String into an object of type T.
      boolean willDecode(String s)
      Answer whether the given String can be decoded into an object of type T.

      • Methods inherited from interface javax.websocket.Decoder

        destroy, init

    • Method Detail

      • decode

        T decode(String s)
         throws DecodeException
        Decode the given String into an object of type T.
        Parameters:
        s - string to be decoded.
        Returns:
        the decoded message as an object of type T
        Throws:
        DecodeException

      • willDecode

        boolean willDecode(String s)
        Answer whether the given String can be decoded into an object of type T.
        Parameters:
        s - the string being tested for decodability.
        Returns:
        whether this decoder can decoded the supplied string.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Decoder.TextStream (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Decoder.TextStream<T>

  • All Superinterfaces:
    Decoder
    Enclosing interface:
    Decoder

    public static interface Decoder.TextStream<T>
extends Decoder
    This interface defines how a custom object of type T is decoded from a web socket message in the form of a character stream.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.Decoder

        Decoder.Binary<T>, Decoder.BinaryStream<T>, Decoder.Text<T>, Decoder.TextStream<T>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T decode(Reader reader)
      Reads the websocket message from the implementation provided Reader and decodes it into an instance of the supplied object type.

      • Methods inherited from interface javax.websocket.Decoder

        destroy, init

    • Method Detail

      • decode

        T decode(Reader reader)
         throws DecodeException,
                IOException
        Reads the websocket message from the implementation provided Reader and decodes it into an instance of the supplied object type.
        Parameters:
        reader - the reader from which to read the web socket message.
        Returns:
        the instance of the object that is the decoded web socket message.
        Throws:
        DecodeException
        IOException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeploymentException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Class DeploymentException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.websocket.DeploymentException
  • All Implemented Interfaces:
    Serializable

    public class DeploymentException
extends Exception
    Checked exception indicating some kind of failure either to publish an endpoint on its server, or a failure to connect a client to its server.
    Author:
    dannycoward
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DeploymentException(String message)
      Creates a deployment exception with the given reason for the deployment failure.
      DeploymentException(String message, Throwable cause)
      Creates a deployment exception with the given reason for the deployment failure and wrapped cause of the failure.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DeploymentException

        public DeploymentException(String message)
        Creates a deployment exception with the given reason for the deployment failure.
        Parameters:
        message - the reason for the failure.

      • DeploymentException

        public DeploymentException(String message,
                   Throwable cause)
        Creates a deployment exception with the given reason for the deployment failure and wrapped cause of the failure.
        Parameters:
        message - the reason for the failure.
        cause - the cause of the problem.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EncodeException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Class EncodeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.websocket.EncodeException
  • All Implemented Interfaces:
    Serializable

    public class EncodeException
extends Exception
    A general exception that occurs when trying to encode a custom object to a string or binary message.
    Author:
    dannycoward
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      EncodeException(Object object, String message)
      Constructor with the object being encoded, and the reason why it failed to be.
      EncodeException(Object object, String message, Throwable cause)
      Constructor with the object being encoded, and the reason why it failed to be, and the cause.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getObject()
      Return the Object that could not be encoded.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EncodeException

        public EncodeException(Object object,
               String message)
        Constructor with the object being encoded, and the reason why it failed to be.
        Parameters:
        object - the object that could not be encoded.
        message - the reason for the failure.

      • EncodeException

        public EncodeException(Object object,
               String message,
               Throwable cause)
        Constructor with the object being encoded, and the reason why it failed to be, and the cause.
        Parameters:
        object - the object that could not be encoded.
        message - the reason for the failure.
        cause - the cause of the problem.

    • Method Detail

      • getObject

        public Object getObject()
        Return the Object that could not be encoded.
        Returns:
        the object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Encoder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Encoder

  • All Known Subinterfaces:
    Encoder.Binary<T>, Encoder.BinaryStream<T>, Encoder.Text<T>, Encoder.TextStream<T>

    public interface Encoder
    The Encoder interface defines how developers can provide a way to convert their custom objects into web socket messages. The Encoder interface contains subinterfaces that allow encoding algorithms to encode custom objects to: text, binary data, character stream and write to an output stream. The websocket implementation creates a new instance of the encoder per endpoint instance per connection. This means that each encoder instance has at most one calling thread at a time. The lifecycle of the Encoder instance is governed by the container calls to the init(javax.websocket.EndpointConfig) and destroy() methods.
    Author:
    dannycoward

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  Encoder.Binary<T>
      This interface defines how to provide a way to convert a custom object into a binary message.
      static interface  Encoder.BinaryStream<T>
      This interface may be implemented by encoding algorithms that want to write the encoded object to a binary stream.
      static interface  Encoder.Text<T>
      This interface defines how to provide a way to convert a custom object into a text message.
      static interface  Encoder.TextStream<T>
      This interface may be implemented by encoding algorithms that want to write the encoded object to a character stream.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      This method is called when the encoder is about to be removed from service in order that any resources the encoder used may be closed gracefully.
      void init(EndpointConfig config)
      This method is called with the endpoint configuration object of the endpoint this encoder is intended for when it is about to be brought into service.

    • Method Detail

      • init

        void init(EndpointConfig config)
        This method is called with the endpoint configuration object of the endpoint this encoder is intended for when it is about to be brought into service.
        Parameters:
        config - the endpoint configuration object when being brought into service

      • destroy

        void destroy()
        This method is called when the encoder is about to be removed from service in order that any resources the encoder used may be closed gracefully.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Encoder.Binary (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Encoder.Binary<T>

  • Type Parameters:
    T - The type of the custom object that this Encoder can encoder to a ByteBuffer.
    All Superinterfaces:
    Encoder
    Enclosing interface:
    Encoder

    public static interface Encoder.Binary<T>
extends Encoder
    This interface defines how to provide a way to convert a custom object into a binary message.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.Encoder

        Encoder.Binary<T>, Encoder.BinaryStream<T>, Encoder.Text<T>, Encoder.TextStream<T>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ByteBuffer encode(T object)
      Encode the given object into a byte array.

      • Methods inherited from interface javax.websocket.Encoder

        destroy, init

    • Method Detail

      • encode

        ByteBuffer encode(T object)
                  throws EncodeException
        Encode the given object into a byte array.
        Parameters:
        object - the object being encoded.
        Returns:
        the binary data.
        Throws:
        EncodeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Encoder.BinaryStream (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Encoder.BinaryStream<T>

  • Type Parameters:
    T - the type of the object this encoder can encode.
    All Superinterfaces:
    Encoder
    Enclosing interface:
    Encoder

    public static interface Encoder.BinaryStream<T>
extends Encoder
    This interface may be implemented by encoding algorithms that want to write the encoded object to a binary stream.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.Encoder

        Encoder.Binary<T>, Encoder.BinaryStream<T>, Encoder.Text<T>, Encoder.TextStream<T>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void encode(T object, OutputStream os)
      Encode the given object into a binary stream written to the implementation provided OutputStream.

      • Methods inherited from interface javax.websocket.Encoder

        destroy, init

    • Method Detail

      • encode

        void encode(T object,
          OutputStream os)
            throws EncodeException,
                   IOException
        Encode the given object into a binary stream written to the implementation provided OutputStream.
        Parameters:
        object - the object being encoded.
        os - the output stream where the encoded data is written.
        Throws:
        EncodeException
        IOException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Encoder.Text (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Encoder.Text<T>

  • Type Parameters:
    T - The type of the custom developer object that this Encoder can encode into a String.
    All Superinterfaces:
    Encoder
    Enclosing interface:
    Encoder

    public static interface Encoder.Text<T>
extends Encoder
    This interface defines how to provide a way to convert a custom object into a text message.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.Encoder

        Encoder.Binary<T>, Encoder.BinaryStream<T>, Encoder.Text<T>, Encoder.TextStream<T>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String encode(T object)
      Encode the given object into a String.

      • Methods inherited from interface javax.websocket.Encoder

        destroy, init

    • Method Detail

      • encode

        String encode(T object)
              throws EncodeException
        Encode the given object into a String.
        Parameters:
        object - the object being encoded.
        Returns:
        the encoded object as a string.
        Throws:
        EncodeException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Encoder.TextStream (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Encoder.TextStream<T>

  • Type Parameters:
    T - the type of the object this encoder can encode to a CharacterStream.
    All Superinterfaces:
    Encoder
    Enclosing interface:
    Encoder

    public static interface Encoder.TextStream<T>
extends Encoder
    This interface may be implemented by encoding algorithms that want to write the encoded object to a character stream.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.Encoder

        Encoder.Binary<T>, Encoder.BinaryStream<T>, Encoder.Text<T>, Encoder.TextStream<T>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void encode(T object, Writer writer)
      Encode the given object to a character stream writing it to the supplied Writer.

      • Methods inherited from interface javax.websocket.Encoder

        destroy, init

    • Method Detail

      • encode

        void encode(T object,
          Writer writer)
            throws EncodeException,
                   IOException
        Encode the given object to a character stream writing it to the supplied Writer. Implementations of this method may use the EncodeException to indicate a failure to convert the supplied object to an encoded form, and may use the IOException to indicate a failure to write the data to the supplied stream.
        Parameters:
        object - the object to be encoded.
        writer - the writer provided by the web socket runtime to write the encoded data.
        Throws:
        EncodeException - if there was an error encoding the object due to its state.
        IOException - if there was an exception writing to the writer.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Endpoint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Class Endpoint

  • java.lang.Object
    • javax.websocket.Endpoint

  • public abstract class Endpoint
extends Object
    The Web Socket Endpoint represents an object that can handle websocket conversations. Developers may extend this class in order to implement a programmatic websocket endpoint. The Endpoint class holds lifecycle methods that may be overridden to intercept websocket open, error and close events. By implementing the onOpen method, the programmatic endpoint gains access to the Session object, to which the developer may add MessageHandler implementations in order to intercept incoming websocket messages. Each instance of a websocket endpoint is guaranteed not to be called by more than one thread at a time per active connection.

    If deployed as a client endpoint, it will be instantiated once for the single connection to the server.

    When deployed as a server endpoint, the implementation uses the ServerEndpointConfig.Configurator.getEndpointInstance(java.lang.Class<T>) method to obtain the endpoint instance it will use for each new client connection. If the developer uses the default ServerEndpointConfig.Configurator, there will be precisely one endpoint instance per active client connection. Consequently, in this typical case, when implementing/overriding the methods of Endpoint, the developer is guaranteed that there will be at most one thread calling each endpoint instance at a time.

    If the developer provides a custom ServerEndpointConfig.Configurator which overrides the default policy for endpoint instance creation, for example, using a single Endpoint instance for multiple client connections, the developer may need to write code that can execute concurrently.

    Here is an example of a simple endpoint that echoes any incoming text message back to the sender.

 public class EchoServer extends Endpoint {

     public void onOpen(Session session, EndpointConfig config) {
         final RemoteEndpoint remote = session.getBasicRemote();
         session.addMessageHandler(new MessageHandler.Whole<String>() {
             public void onMessage(String text) {
                 try {
                     remote.sendString("Got your message (" + text + "). Thanks !");
                 } catch (IOException ioe) {
                     // handle send failure here
                 }
             }
         });
     }

 }
    Author:
    dannycoward

    • Constructor Summary

      Constructors
      Constructor and Description
      Endpoint()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onClose(Session session, CloseReason closeReason)
      This method is called immediately prior to the session with the remote peer being closed.
      void onError(Session session, Throwable thr)
      Developers may implement this method when the web socket session creates some kind of error that is not modeled in the web socket protocol.
      abstract void onOpen(Session session, EndpointConfig config)
      Developers must implement this method to be notified when a new conversation has just begun.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Endpoint

        public Endpoint()

    • Method Detail

      • onOpen

        public abstract void onOpen(Session session,
          EndpointConfig config)
        Developers must implement this method to be notified when a new conversation has just begun.
        Parameters:
        session - the session that has just been activated.
        config - the configuration used to configure this endpoint.

      • onClose

        public void onClose(Session session,
           CloseReason closeReason)
        This method is called immediately prior to the session with the remote peer being closed. It is called whether the session is being closed because the remote peer initiated a close and sent a close frame, or whether the local websocket container or this endpoint requests to close the session. The developer may take this last opportunity to retrieve session attributes such as the ID, or any application data it holds before it becomes unavailable after the completion of the method. Developers should not attempt to modify the session from within this method, or send new messages from this call as the underlying connection will not be able to send them at this stage.
        Parameters:
        session - the session about to be closed.
        closeReason - the reason the session was closed.

      • onError

        public void onError(Session session,
           Throwable thr)
        Developers may implement this method when the web socket session creates some kind of error that is not modeled in the web socket protocol. This may for example be a notification that an incoming message is too big to handle, or that the incoming message could not be encoded.

        There are a number of categories of exception that this method is (currently) defined to handle:

        • connection problems, for example, a socket failure that occurs before the web socket connection can be formally closed. These are modeled as SessionExceptions
        • runtime errors thrown by developer created message handlers calls.
        • conversion errors encoding incoming messages before any message handler has been called. These are modeled as DecodeExceptions
        Parameters:
        session - the session in use when the error occurs.
        thr - the throwable representing the problem.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EndpointConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface EndpointConfig

  • All Known Subinterfaces:
    ClientEndpointConfig, ServerEndpointConfig

    public interface EndpointConfig
    The endpoint configuration contains all the information needed during the handshake process for this end point. All endpoints specify, for example, a URI. In the case of a server endpoint, the URI signifies the URI to which the endpoint will be mapped. In the case of a client application the URI signifies the URI of the server to which the client endpoint will attempt to connect.
    Author:
    dannycoward

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<Class<? extends Decoder>> getDecoders()
      Return the Decoder implementation classes configured.
      List<Class<? extends Encoder>> getEncoders()
      Return the Encoder implementation classes configured.
      Map<String,Object> getUserProperties()
      This method returns a modifiable Map that the developer may use to store application specific information relating to the endpoint that uses this configuration instance.

    • Method Detail

      • getEncoders

        List<Class<? extends Encoder>> getEncoders()
        Return the Encoder implementation classes configured. These will be instantiated by the container to encode custom objects passed into the send() methods on remote endpoints.
        Returns:
        the encoder implementation classes, an empty list if none.

      • getDecoders

        List<Class<? extends Decoder>> getDecoders()
        Return the Decoder implementation classes configured. These will be instantiated by the container to decode incoming messages into the expected custom objects on MessageHandler.Whole.onMessage(Object) callbacks.
        Returns:
        the decoder implementation classes, the empty list if none.

      • getUserProperties

        Map<String,Object> getUserProperties()
        This method returns a modifiable Map that the developer may use to store application specific information relating to the endpoint that uses this configuration instance. Web socket applications running on distributed implementations of the web container should make any application specific objects stored here java.io.Serializable, or the object may not be recreated after a failover.
        Returns:
        a modifiable Map of application data.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Extension (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Extension

  • public interface Extension
    A simple representation of a websocket extension as a name and map of extension parameters.
    Author:
    dannycoward

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  Extension.Parameter
      This member interface defines a single websocket extension parameter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      The name of the extension.
      List<Extension.Parameter> getParameters()
      The extension parameters for this extension in the order they appear in the http headers.

    • Method Detail

      • getName

        String getName()
        The name of the extension.
        Returns:
        the name of the extension.

      • getParameters

        List<Extension.Parameter> getParameters()
        The extension parameters for this extension in the order they appear in the http headers.
        Returns:
        The read-only Map of extension parameters belonging to this extension.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Extension.Parameter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Extension.Parameter

  • Enclosing interface:
    Extension

    public static interface Extension.Parameter
    This member interface defines a single websocket extension parameter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Return the name of the extension parameter.
      String getValue()
      Return the value of the extension parameter.

    • Method Detail

      • getName

        String getName()
        Return the name of the extension parameter.
        Returns:
        the name of the parameter.

      • getValue

        String getValue()
        Return the value of the extension parameter.
        Returns:
        the value of the parameter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HandshakeResponse (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface HandshakeResponse

  • public interface HandshakeResponse
    The handshake response represents the web socket-defined Http response that is the response to the opening handshake request.
    Author:
    dannycoward

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String SEC_WEBSOCKET_ACCEPT
      The Sec-WebSocket-Accept header name.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Map<String,List<String>> getHeaders()
      Return the list of Http headers sent by the web socket server.

    • Field Detail

      • SEC_WEBSOCKET_ACCEPT

        static final String SEC_WEBSOCKET_ACCEPT
        The Sec-WebSocket-Accept header name.
        See Also:
        Constant Field Values

    • Method Detail

      • getHeaders

        Map<String,List<String>> getHeaders()
        Return the list of Http headers sent by the web socket server.
        Returns:
        the http headers .
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.websocket (Java(TM) EE 7 Specification APIs)

javax.websocket

Interfaces

  • ClientEndpointConfig
  • CloseReason.CloseCode
  • Decoder
  • Decoder.Binary
  • Decoder.BinaryStream
  • Decoder.Text
  • Decoder.TextStream
  • Encoder
  • Encoder.Binary
  • Encoder.BinaryStream
  • Encoder.Text
  • Encoder.TextStream
  • EndpointConfig
  • Extension
  • Extension.Parameter
  • HandshakeResponse
  • MessageHandler
  • MessageHandler.Partial
  • MessageHandler.Whole
  • PongMessage
  • RemoteEndpoint
  • RemoteEndpoint.Async
  • RemoteEndpoint.Basic
  • SendHandler
  • Session
  • WebSocketContainer

Classes

  • ClientEndpointConfig.Builder
  • ClientEndpointConfig.Configurator
  • CloseReason
  • ContainerProvider
  • Endpoint
  • SendResult

Enums

  • CloseReason.CloseCodes

Exceptions

  • DecodeException
  • DeploymentException
  • EncodeException
  • SessionException

Annotation Types

  • ClientEndpoint
  • OnClose
  • OnError
  • OnMessage
  • OnOpen


javax.websocket (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.websocket

This package contains all the WebSocket APIs common to both the client and server side.

See: Description

  • Interface Summary
    Interface Description
    ClientEndpointConfig
    The ClientEndpointConfig is a special kind of endpoint configuration object that contains web socket configuration information specific only to client endpoints.
    CloseReason.CloseCode
    A marker interface for the close codes.
    Decoder
    The Decoder interface holds member interfaces that define how a developer can provide the web socket container a way web socket messages into developer defined custom objects.
    Decoder.Binary<T>
    This interface defines how a custom object (of type T) is decoded from a web socket message in the form of a byte buffer.
    Decoder.BinaryStream<T>
    This interface defines how a custom object is decoded from a web socket message in the form of a binary stream.
    Decoder.Text<T>
    This interface defines how a custom object is decoded from a web socket message in the form of a string.
    Decoder.TextStream<T>
    This interface defines how a custom object of type T is decoded from a web socket message in the form of a character stream.
    Encoder
    The Encoder interface defines how developers can provide a way to convert their custom objects into web socket messages.
    Encoder.Binary<T>
    This interface defines how to provide a way to convert a custom object into a binary message.
    Encoder.BinaryStream<T>
    This interface may be implemented by encoding algorithms that want to write the encoded object to a binary stream.
    Encoder.Text<T>
    This interface defines how to provide a way to convert a custom object into a text message.
    Encoder.TextStream<T>
    This interface may be implemented by encoding algorithms that want to write the encoded object to a character stream.
    EndpointConfig
    The endpoint configuration contains all the information needed during the handshake process for this end point.
    Extension
    A simple representation of a websocket extension as a name and map of extension parameters.
    Extension.Parameter
    This member interface defines a single websocket extension parameter.
    HandshakeResponse
    The handshake response represents the web socket-defined Http response that is the response to the opening handshake request.
    MessageHandler
    Developers implement MessageHandlers in order to receive incoming messages during a web socket conversation.
    MessageHandler.Partial<T>
    This kind of handler is notified by the implementation as it becomes ready to deliver parts of a whole message.
    MessageHandler.Whole<T>
    This kind of handler is notified by the container on arrival of a complete message.
    PongMessage
    The PongMessage interface represents a web socket pong.
    RemoteEndpoint
    The RemoteEndpoint object is supplied by the container and represents the 'other end' or peer of the Web Socket conversation.
    RemoteEndpoint.Async
    This representation of the peer of a web socket conversation has the ability to send messages asynchronously.
    RemoteEndpoint.Basic
    This representation of the peer of a web socket conversation has the ability to send messages synchronously.
    SendHandler
    A simple callback object for asynchronous sending of web socket messages.
    Session
    A Web Socket session represents a conversation between two web socket endpoints.
    WebSocketContainer
    A WebSocketContainer is an implementation provided object that provides applications a view on the container running it.
  • Class Summary
    Class Description
    ClientEndpointConfig.Builder
    The ClientEndpointConfig.Builder is a class used for creating ClientEndpointConfig objects for the purposes of deploying a client endpoint.
    ClientEndpointConfig.Configurator
    The Configurator class may be extended by developers who want to provide custom configuration algorithms, such as intercepting the opening handshake, or providing arbitrary methods and algorithms that can be accessed from each endpoint instance configured with this configurator.
    CloseReason
    A class encapsulating the reason why a web socket has been closed, or why it is being asked to close.
    ContainerProvider
    Provider class that allows the developer to get a reference to the implementation of the WebSocketContainer.
    Endpoint
    The Web Socket Endpoint represents an object that can handle websocket conversations.
    SendResult
    The result of asynchronously sending a web socket message.
  • Enum Summary
    Enum Description
    CloseReason.CloseCodes
    An Enumeration of status codes for a web socket close that are defined in the specification.
  • Exception Summary
    Exception Description
    DecodeException
    A general exception that occurs when trying to decode a custom object from a text or binary message.
    DeploymentException
    Checked exception indicating some kind of failure either to publish an endpoint on its server, or a failure to connect a client to its server.
    EncodeException
    A general exception that occurs when trying to encode a custom object to a string or binary message.
    SessionException
    A SessionException represents a general exception type reporting problems occurring on a websocket session.
  • Annotation Types Summary
    Annotation Type Description
    ClientEndpoint
    The ClientEndpoint annotation a class level annotation is used to denote that a POJO is a web socket client and can be deployed as such.
    OnClose
    This method level annotation can be used to decorate a Java method that wishes to be called when a web socket session is closing.
    OnError
    This method level annotation can be used to decorate a Java method that wishes to be called in order to handle errors.
    OnMessage
    This method level annotation can be used to make a Java method receive incoming web socket messages.
    OnOpen
    This method level annotation can be used to decorate a Java method that wishes to be called when a new web socket session is open.

Package javax.websocket Description

This package contains all the WebSocket APIs common to both the client and server side.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.websocket Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.websocket

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.websocket.ClientEndpointConfig.Builder
    • javax.websocket.ClientEndpointConfig.Configurator
    • javax.websocket.CloseReason
    • javax.websocket.ContainerProvider
    • javax.websocket.Endpoint
    • javax.websocket.SendResult
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.websocket.DecodeException
        • javax.websocket.DeploymentException
        • javax.websocket.EncodeException
        • javax.websocket.SessionException

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • javax.websocket.Session
  • javax.websocket.CloseReason.CloseCode
  • javax.websocket.Decoder
    • javax.websocket.Decoder.Binary<T>
    • javax.websocket.Decoder.BinaryStream<T>
    • javax.websocket.Decoder.Text<T>
    • javax.websocket.Decoder.TextStream<T>
  • javax.websocket.Encoder
    • javax.websocket.Encoder.Binary<T>
    • javax.websocket.Encoder.BinaryStream<T>
    • javax.websocket.Encoder.Text<T>
    • javax.websocket.Encoder.TextStream<T>
  • javax.websocket.EndpointConfig
    • javax.websocket.ClientEndpointConfig
  • javax.websocket.Extension
  • javax.websocket.Extension.Parameter
  • javax.websocket.HandshakeResponse
  • javax.websocket.MessageHandler
    • javax.websocket.MessageHandler.Partial<T>
    • javax.websocket.MessageHandler.Whole<T>
  • javax.websocket.PongMessage
  • javax.websocket.RemoteEndpoint
    • javax.websocket.RemoteEndpoint.Async
    • javax.websocket.RemoteEndpoint.Basic
  • javax.websocket.SendHandler
  • javax.websocket.WebSocketContainer

Annotation Type Hierarchy

  • javax.websocket.OnOpen (implements java.lang.annotation.Annotation)
  • javax.websocket.OnMessage (implements java.lang.annotation.Annotation)
  • javax.websocket.OnError (implements java.lang.annotation.Annotation)
  • javax.websocket.OnClose (implements java.lang.annotation.Annotation)
  • javax.websocket.ClientEndpoint (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.websocket.CloseReason.CloseCodes (implements javax.websocket.CloseReason.CloseCode)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MessageHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface MessageHandler

  • All Known Subinterfaces:
    MessageHandler.Partial<T>, MessageHandler.Whole<T>

    public interface MessageHandler
    Developers implement MessageHandlers in order to receive incoming messages during a web socket conversation. Each web socket session uses no more than one thread at a time to call its MessageHandlers. This means that, provided each message handler instance is used to handle messages for one web socket session, at most one thread at a time can be calling any of its methods. Developers who wish to handle messages from multiple clients within the same message handlers may do so by adding the same instance as a handler on each of the Session objects for the clients. In that case, they will need to code with the possibility of their MessageHandler being called concurrently by multiple threads, each one arising from a different client session.

    See Endpoint for a usage example.

    Author:
    dannycoward

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  MessageHandler.Partial<T>
      This kind of handler is notified by the implementation as it becomes ready to deliver parts of a whole message.
      static interface  MessageHandler.Whole<T>
      This kind of handler is notified by the container on arrival of a complete message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageHandler.Partial (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface MessageHandler.Partial<T>

  • Type Parameters:
    T - The type of the object that represent pieces of the incoming message that this MessageHandler will consume.
    All Superinterfaces:
    MessageHandler
    Enclosing interface:
    MessageHandler

    public static interface MessageHandler.Partial<T>
extends MessageHandler
    This kind of handler is notified by the implementation as it becomes ready to deliver parts of a whole message.

    For handling parts of text messages, the type T is String

    For handling parts of binary messages, the allowable types for T are

    • ByteBuffer
    • byte[]

    Developers should not continue to reference message objects of type ByteBuffer after the completion of the onMessage() call, since they may be recycled by the implementation.

    Note: Implementations may choose their own schemes for delivering large messages in smaller parts through this API. These schemes may or may not bear a relationship to the underlying websocket dataframes in which the message is received off the wire.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.MessageHandler

        MessageHandler.Partial<T>, MessageHandler.Whole<T>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onMessage(T partialMessage, boolean last)
      Called when the next part of a message has been fully received.

    • Method Detail

      • onMessage

        void onMessage(T partialMessage,
             boolean last)
        Called when the next part of a message has been fully received.
        Parameters:
        partialMessage - the partial message data.
        last - flag to indicate if this partialMessage is the last of the whole message being delivered.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageHandler.Whole (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface MessageHandler.Whole<T>

  • Type Parameters:
    T - The type of the message object that this MessageHandler will consume.
    All Superinterfaces:
    MessageHandler
    Enclosing interface:
    MessageHandler

    public static interface MessageHandler.Whole<T>
extends MessageHandler
    This kind of handler is notified by the container on arrival of a complete message. If the message is received in parts, the container buffers it until it is has been fully received before this method is called.

    For handling incoming text messages, the allowed types for T are

    • String
    • Reader
    • any developer object for which there is a corresponding Decoder.Text or Decoder.TextStream configured

    For handling incoming binary messages, the allowed types for T are

    • ByteBuffer
    • byte[]
    • InputStream
    • any developer object for which there is a corresponding Decoder.Binary or Decoder.BinaryStream configured

    For handling incoming pong messages, the type of T is PongMessage

    Developers should not continue to reference message objects of type Reader, ByteBuffer or InputStream after the completion of the onMessage() call, since they may be recycled by the implementation.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.MessageHandler

        MessageHandler.Partial<T>, MessageHandler.Whole<T>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onMessage(T message)
      Called when the message has been fully received.

    • Method Detail

      • onMessage

        void onMessage(T message)
        Called when the message has been fully received.
        Parameters:
        message - the message data.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


OnClose (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.websocket

Annotation Type OnClose

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface OnClose
    This method level annotation can be used to decorate a Java method that wishes to be called when a web socket session is closing.

    The method may only take the following parameters:-

    • optional Session parameter
    • optional CloseReason parameter
    • Zero to n String parameters annotated with the PathParam annotation.

    The parameters may appear in any order. See Endpoint.onClose(javax.websocket.Session, javax.websocket.CloseReason) for more details on how the session parameter may be used during method calls annotated with this annotation.

    Author:
    dannycoward
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


OnError (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.websocket

Annotation Type OnError

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface OnError
    This method level annotation can be used to decorate a Java method that wishes to be called in order to handle errors. See Endpoint.onError(javax.websocket.Session, java.lang.Throwable) for a description of the different categories of error.

    The method may only take the following parameters:-

    • optional Session parameter
    • a Throwable parameter
    • Zero to n String parameters annotated with the PathParam annotation

    The parameters may appear in any order.

    Author:
    dannycoward
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


OnMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.websocket

Annotation Type OnMessage

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface OnMessage
    This method level annotation can be used to make a Java method receive incoming web socket messages. Each websocket endpoint may only have one message handling method for each of the native websocket message formats: text, binary and pong. Methods using this annotation are allowed to have parameters of types described below, otherwise the container will generate an error at deployment time.

    The allowed parameters are:

    1. Exactly one of any of the following choices
      • if the method is handling text messages:
        • String to receive the whole message
        • Java primitive or class equivalent to receive the whole message converted to that type
        • String and boolean pair to receive the message in parts
        • Reader to receive the whole message as a blocking stream
        • any object parameter for which the endpoint has a text decoder (Decoder.Text or Decoder.TextStream).
      • if the method is handling binary messages:
        • byte[] or ByteBuffer to receive the whole message
        • byte[] and boolean pair, or ByteBuffer and boolean pair to receive the message in parts
        • InputStream to receive the whole message as a blocking stream
        • any object parameter for which the endpoint has a binary decoder (Decoder.Binary or Decoder.BinaryStream).
      • if the method is handling pong messages:
        • PongMessage for handling pong messages
    2. and Zero to n String or Java primitive parameters annotated with the PathParam annotation for server endpoints.
    3. and an optional Session parameter

    The parameters may be listed in any order.

    The method may have a non-void return type, in which case the web socket runtime must interpret this as a web socket message to return to the peer. The allowed data types for this return type, other than void, are String, ByteBuffer, byte[], any Java primitive or class equivalent, and anything for which there is an encoder. If the method uses a Java primitive as a return value, the implementation must construct the text message to send using the standard Java string representation of the Java primitive unless there developer provided encoder for the type configured for this endpoint, in which case that encoder must be used. If the method uses a class equivalent of a Java primitive as a return value, the implementation must construct the text message from the Java primitive equivalent as described above.

    Developers should note that if developer closes the session during the invocation of a method with a return type, the method will complete but the return value will not be delivered to the remote endpoint. The send failure will be passed back into the endpoint's error handling method.

    For example:

 @OnMessage
 public void processGreeting(String message, Session session) {
     System.out.println("Greeting received:" + message);
 }
    For example:

 @OnMessage
 public void processUpload(byte[] b, boolean last, Session session) {
     // process partial data here, which check on last to see if these is more on the way
 }
    Developers should not continue to reference message objects of type Reader, ByteBuffer or InputStream after the annotated method has completed, since they may be recycled by the implementation.
    Author:
    dannycoward

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      long maxMessageSize
      Specifies the maximum size of message in bytes that the method this annotates will be able to process, or -1 to indicate that there is no maximum.

    • Element Detail

      • maxMessageSize

        public abstract long maxMessageSize
        Specifies the maximum size of message in bytes that the method this annotates will be able to process, or -1 to indicate that there is no maximum. The default is -1. This attribute only applies when the annotation is used to process whole messages, not to those methods that process messages in parts or use a stream or reader parameter to handle the incoming message. If the incoming whole message exceeds this limit, then the implementation generates an error and closes the connection using the reason that the message was too big.
        Returns:
        the maximum size in bytes.
        Default:
        -1L
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


OnOpen (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.websocket

Annotation Type OnOpen

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface OnOpen
    This method level annotation can be used to decorate a Java method that wishes to be called when a new web socket session is open.

    The method may only take the following parameters:-

    • optional Session parameter
    • optional EndpointConfig parameter
    • Zero to n String parameters annotated with the PathParam annotation.

    The parameters may appear in any order.

    Author:
    dannycoward
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PongMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface PongMessage

  • public interface PongMessage
    The PongMessage interface represents a web socket pong. PongMessages may be received by using a MessageHandler.Basic<PongMessage>. The payload of the PongMessage is the application data sent by the peer.
    Author:
    dannycoward

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ByteBuffer getApplicationData()
      The application data inside the pong message from the peer.

    • Method Detail

      • getApplicationData

        ByteBuffer getApplicationData()
        The application data inside the pong message from the peer.
        Returns:
        the application data.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RemoteEndpoint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface RemoteEndpoint

  • All Known Subinterfaces:
    RemoteEndpoint.Async, RemoteEndpoint.Basic

    public interface RemoteEndpoint
    The RemoteEndpoint object is supplied by the container and represents the 'other end' or peer of the Web Socket conversation. Instances of the RemoteEndpoint are obtained from the Session using Session.getBasicRemote() or Session.getAsyncRemote(). Objects of this kind include numerous ways to send web socket messages. There are two kinds of RemoteEndpoint objects: RemoteEndpoint.Basic for synchronous sending of websocket messages, and RemoteEndpoint.Async for sending messages asynchronously.

    There is no guarantee of the successful delivery of a web socket message to the peer, but if the action of sending a message causes an error known to the container, the API throws it. RemoteEndpoints include a variety of ways to send messages: by whole message, in parts, and in various data formats including websocket pings and pongs.

    Implementations may or may not support batching of messages. More detail of the expected semantics of implementations that do support batching are laid out in setBatchingAllowed(boolean).

    Note: Implementations may choose their own schemes for sending large messages in smaller parts. These schemes may or may not bear a relationship to the underlying websocket dataframes in which the message is ultimately sent on the wire.

    If the underlying connection is closed and methods on the RemoteEndpoint are attempted to be called, they will result in an error being generated. For the methods that send messages, this will be an IOException, for the methods that alter configuration of the endpoint, this will be runtime IllegalArgumentExceptions.

    Author:
    dannycoward

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  RemoteEndpoint.Async
      This representation of the peer of a web socket conversation has the ability to send messages asynchronously.
      static interface  RemoteEndpoint.Basic
      This representation of the peer of a web socket conversation has the ability to send messages synchronously.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void flushBatch()
      This method is only used when batching is allowed for this RemoteEndpint.
      boolean getBatchingAllowed()
      Return whether the implementation is allowed to batch outgoing messages before sending.
      void sendPing(ByteBuffer applicationData)
      Send a Ping message containing the given application data to the remote endpoint.
      void sendPong(ByteBuffer applicationData)
      Allows the developer to send an unsolicited Pong message containing the given application data in order to serve as a unidirectional heartbeat for the session.
      void setBatchingAllowed(boolean allowed)
      Indicate to the implementation that it is allowed to batch outgoing messages before sending.

    • Method Detail

      • setBatchingAllowed

        void setBatchingAllowed(boolean allowed)
                        throws IOException
        Indicate to the implementation that it is allowed to batch outgoing messages before sending. Not all implementations support batching of outgoing messages. The default mode for RemoteEndpoints is false. If the developer has indicated that batching of outgoing messages is permitted, then the developer must call flushBatch() in order to be sure that all the messages passed into the send methods of this RemoteEndpoint are sent. When batching is allowed, the implementations send operations are considered to have completed if the message has been written to the local batch, in the case when there is still room in the batch for the message, and are considered to have completed if the batch has been send to the peer and the remainder written to the new batch, in the case when writing the message causes the batch to need to be sent. The blocking and asynchronous send methods use this notion of completion in order to complete blocking calls, notify SendHandlers and complete Futures respectively. When batching is allowed, if the developer has called send methods on this RemoteEndpoint without calling flushBatch(), then the implementation may not have sent all the messages the developer has asked to be sent. If the parameter value is false and the implementation has a batch of unsent messages, then the implementation must immediately send the batch of unsent messages.
        Parameters:
        allowed - whether the implementation is allowed to batch messages.
        Throws:
        IOException - if batching is being disabled and there are unsent messages this error may be thrown as the implementation sends the batch of unsent messages if there is a problem.

      • getBatchingAllowed

        boolean getBatchingAllowed()
        Return whether the implementation is allowed to batch outgoing messages before sending. The default mode for RemoteEndpoints is false. The value may be changed by calling setBatchingAllowed.

      • flushBatch

        void flushBatch()
                throws IOException
        This method is only used when batching is allowed for this RemoteEndpint. Calling this method forces the implementation to send any unsent messages it has been batching.
        Throws:
        IOException

      • sendPing

        void sendPing(ByteBuffer applicationData)
              throws IOException,
                     IllegalArgumentException
        Send a Ping message containing the given application data to the remote endpoint. The corresponding Pong message may be picked up using the MessageHandler.Pong handler.
        Parameters:
        applicationData - the data to be carried in the ping request.
        Throws:
        IOException - if the ping failed to be sent
        IllegalArgumentException - if the applicationData exceeds the maximum allowed payload of 125 bytes

      • sendPong

        void sendPong(ByteBuffer applicationData)
              throws IOException,
                     IllegalArgumentException
        Allows the developer to send an unsolicited Pong message containing the given application data in order to serve as a unidirectional heartbeat for the session.
        Parameters:
        applicationData - the application data to be carried in the pong response.
        Throws:
        IOException - if the pong failed to be sent
        IllegalArgumentException - if the applicationData exceeds the maximum allowed payload of 125 bytes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RemoteEndpoint.Async (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface RemoteEndpoint.Async

  • All Superinterfaces:
    RemoteEndpoint
    Enclosing interface:
    RemoteEndpoint

    public static interface RemoteEndpoint.Async
extends RemoteEndpoint
    This representation of the peer of a web socket conversation has the ability to send messages asynchronously. The point of completion of the send is defined when all the supplied data has been written to the underlying connection. The completion handlers for the asynchronous methods are always called with a different thread from that which initiated the send.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.RemoteEndpoint

        RemoteEndpoint.Async, RemoteEndpoint.Basic

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getSendTimeout()
      Return the number of milliseconds the implementation will timeout attempting to send a websocket message.
      Future<Void> sendBinary(ByteBuffer data)
      Initiates the asynchronous transmission of a binary message.
      void sendBinary(ByteBuffer data, SendHandler handler)
      Initiates the asynchronous transmission of a binary message.
      Future<Void> sendObject(Object data)
      Initiates the asynchronous transmission of a custom developer object.
      void sendObject(Object data, SendHandler handler)
      Initiates the asynchronous transmission of a custom developer object.
      Future<Void> sendText(String text)
      Initiates the asynchronous transmission of a text message.
      void sendText(String text, SendHandler handler)
      Initiates the asynchronous transmission of a text message.
      void setSendTimeout(long timeoutmillis)
      Sets the number of milliseconds the implementation will timeout attempting to send a websocket message.

      • Methods inherited from interface javax.websocket.RemoteEndpoint

        flushBatch, getBatchingAllowed, sendPing, sendPong, setBatchingAllowed

    • Method Detail

      • getSendTimeout

        long getSendTimeout()
        Return the number of milliseconds the implementation will timeout attempting to send a websocket message. A non-positive number indicates the implementation will not timeout attempting to send a websocket message asynchronously. This value overrides the default value assigned in the WebSocketContainer.
        Returns:
        the timeout time in milliseconds.

      • setSendTimeout

        void setSendTimeout(long timeoutmillis)
        Sets the number of milliseconds the implementation will timeout attempting to send a websocket message. A non-positive number indicates the implementation will not timeout attempting to send a websocket message asynchronously. This value overrides the default value assigned in the WebSocketContainer.
        Parameters:
        timeoutmillis - The number of milliseconds this RemoteEndpoint will wait before timing out an incomplete asynchronous message send.

      • sendText

        void sendText(String text,
            SendHandler handler)
        Initiates the asynchronous transmission of a text message. This method returns before the message is transmitted. Developers provide a callback to be notified when the message has been transmitted. Errors in transmission are given to the developer in the SendResult object.
        Parameters:
        text - the text being sent.
        handler - the handler which will be notified of progress.
        Throws:
        IllegalArgumentException - if the text or the handler is null.

      • sendText

        Future<Void> sendText(String text)
        Initiates the asynchronous transmission of a text message. This method returns before the message is transmitted. Developers use the returned Future object to track progress of the transmission. The Future's get() method returns null upon successful completion. Errors in transmission are wrapped in the ExecutionException thrown when querying the Future object.
        Parameters:
        text - the text being sent.
        Returns:
        the Future object representing the send operation.
        Throws:
        IllegalArgumentException - if the text is null.

      • sendBinary

        Future<Void> sendBinary(ByteBuffer data)
        Initiates the asynchronous transmission of a binary message. This method returns before the message is transmitted. Developers use the returned Future object to track progress of the transmission. The Future's get() method returns null upon successful completion. Errors in transmission are wrapped in the ExecutionException thrown when querying the Future object.
        Parameters:
        data - the data being sent.
        Returns:
        the Future object representing the send operation.
        Throws:
        IllegalArgumentException - if the data is null.

      • sendBinary

        void sendBinary(ByteBuffer data,
              SendHandler handler)
        Initiates the asynchronous transmission of a binary message. This method returns before the message is transmitted. Developers provide a callback to be notified when the message has been transmitted. Errors in transmission are given to the developer in the SendResult object.
        Parameters:
        data - the data being sent, must not be null.
        handler - the handler that will be notified of progress, must not be null.
        Throws:
        IllegalArgumentException - if either the data or the handler are null.

      • sendObject

        Future<Void> sendObject(Object data)
        Initiates the asynchronous transmission of a custom developer object. The developer will have provided an encoder for this object type in the endpoint configuration. Containers will by default be able to encode java primitive types and their object equivalents, otherwise the developer must have provided an encoder for the object type in the endpoint configuration. Progress may be tracked using the Future object. The Future's get() methods return null upon successful completion. Errors in transmission are wrapped in the ExecutionException thrown when querying the Future object.
        Parameters:
        data - the object being sent.
        Returns:
        the Future object representing the send operation.
        Throws:
        IllegalArgumentException - if the data is null.

      • sendObject

        void sendObject(Object data,
              SendHandler handler)
        Initiates the asynchronous transmission of a custom developer object. Containers will by default be able to encode java primitive types and their object equivalents, otherwise the developer must have provided an encoder for the object type in the endpoint configuration. Developers are notified when transmission is complete through the supplied callback object.
        Parameters:
        data - the object being sent.
        handler - the handler that will be notified of progress, must not be null.
        Throws:
        IllegalArgumentException - if either the data or the handler are null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RemoteEndpoint.Basic (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface RemoteEndpoint.Basic

  • All Superinterfaces:
    RemoteEndpoint
    Enclosing interface:
    RemoteEndpoint

    public static interface RemoteEndpoint.Basic
extends RemoteEndpoint
    This representation of the peer of a web socket conversation has the ability to send messages synchronously. The point of completion of the send is defined when all the supplied data has been written to the underlying connection. The methods for sending messages on the RemoteEndpoint.Basic block until this point of completion is reached, except for getSendStream and getSendWriter which present traditional blocking I/O streams to write messages.

    If the websocket connection underlying this RemoteEndpoint is busy sending a message when a call is made to send another one, for example if two threads attempt to call a send method concurrently, or if a developer attempts to send a new message while in the middle of sending an existing one, the send method called while the connection is already busy may throw an IllegalStateException.

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.websocket.RemoteEndpoint

        RemoteEndpoint.Async, RemoteEndpoint.Basic

    • Method Summary

      Methods
      Modifier and Type Method and Description
      OutputStream getSendStream()
      Opens an output stream on which a binary message may be sent.
      Writer getSendWriter()
      Opens an character stream on which a text message may be sent.
      void sendBinary(ByteBuffer data)
      Send a binary message, returning when all of the message has been transmitted.
      void sendBinary(ByteBuffer partialByte, boolean isLast)
      Send a binary message in parts, blocking until all of the message has been transmitted.
      void sendObject(Object data)
      Sends a custom developer object, blocking until it has been transmitted.
      void sendText(String text)
      Send a text message, blocking until all of the message has been transmitted.
      void sendText(String partialMessage, boolean isLast)
      Send a text message in parts, blocking until all of the message has been transmitted.

      • Methods inherited from interface javax.websocket.RemoteEndpoint

        flushBatch, getBatchingAllowed, sendPing, sendPong, setBatchingAllowed

    • Method Detail

      • sendText

        void sendText(String text)
              throws IOException
        Send a text message, blocking until all of the message has been transmitted.
        Parameters:
        text - the message to be sent.
        Throws:
        IOException - if there is a problem delivering the message.
        IllegalArgumentException - if the text is null.

      • sendBinary

        void sendBinary(ByteBuffer data)
                throws IOException
        Send a binary message, returning when all of the message has been transmitted.
        Parameters:
        data - the message to be sent.
        Throws:
        IOException - if there is a problem delivering the message.
        IllegalArgumentException - if the data is null.

      • sendText

        void sendText(String partialMessage,
            boolean isLast)
              throws IOException
        Send a text message in parts, blocking until all of the message has been transmitted. The runtime reads the message in order. Non-final parts of the message are sent with isLast set to false. The final part must be sent with isLast set to true.
        Parameters:
        partialMessage - the parts of the message being sent.
        isLast - Whether the partial message being sent is the last part of the message.
        Throws:
        IOException - if there is a problem delivering the message fragment.
        IllegalArgumentException - if the partialMessage is null.

      • sendBinary

        void sendBinary(ByteBuffer partialByte,
              boolean isLast)
                throws IOException
        Send a binary message in parts, blocking until all of the message has been transmitted. The runtime reads the message in order. Non-final parts are sent with isLast set to false. The final piece must be sent with isLast set to true.
        Parameters:
        partialByte - the part of the message being sent.
        isLast - Whether the partial message being sent is the last part of the message.
        Throws:
        IOException - if there is a problem delivering the partial message.
        IllegalArgumentException - if the partialByte is null.

      • getSendStream

        OutputStream getSendStream()
                           throws IOException
        Opens an output stream on which a binary message may be sent. The developer must close the output stream in order to indicate that the complete message has been placed into the output stream.
        Returns:
        the output stream to which the message will be written.
        Throws:
        IOException - if there is a problem obtaining the OutputStream to write the binary message.

      • getSendWriter

        Writer getSendWriter()
                     throws IOException
        Opens an character stream on which a text message may be sent. The developer must close the writer in order to indicate that the complete message has been placed into the character stream.
        Returns:
        the writer to which the message will be written.
        Throws:
        IOException - if there is a problem obtaining the Writer to write the text message.

      • sendObject

        void sendObject(Object data)
                throws IOException,
                       EncodeException
        Sends a custom developer object, blocking until it has been transmitted. Containers will by default be able to encode java primitive types and their object equivalents, otherwise the developer must have provided an encoder for the object type in the endpoint configuration. A developer-provided encoder for a Java primitive type overrides the container default encoder.
        Parameters:
        data - the object to be sent.
        Throws:
        IOException - if there is a communication error sending the message object.
        EncodeException - if there was a problem encoding the message object into the form of a native websocket message.
        IllegalArgumentException - if the data parameter is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SendHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface SendHandler

  • public interface SendHandler
    A simple callback object for asynchronous sending of web socket messages.
    Author:
    dannycoward

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onResult(SendResult result)
      Called once the message has been transmitted.

    • Method Detail

      • onResult

        void onResult(SendResult result)
        Called once the message has been transmitted.
        Parameters:
        result - the result.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SendResult (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Class SendResult

  • java.lang.Object
    • javax.websocket.SendResult

  • public final class SendResult
extends Object
    The result of asynchronously sending a web socket message. A SendResult is either ok indicating there was no problem, or is not OK in which case there was a problem and it carries an exception to indicate what the problem was.
    Author:
    dannycoward

    • Constructor Summary

      Constructors
      Constructor and Description
      SendResult()
      Construct a SendResult signifying a successful send carrying no exception.
      SendResult(Throwable exception)
      Construct a SendResult carrying an exception.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getException()
      The problem sending the message.
      boolean isOK()
      Determines if this result is ok or not.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SendResult

        public SendResult(Throwable exception)
        Construct a SendResult carrying an exception.
        Parameters:
        exception - the exception causing a send failure.

      • SendResult

        public SendResult()
        Construct a SendResult signifying a successful send carrying no exception.

    • Method Detail

      • getException

        public Throwable getException()
        The problem sending the message.
        Returns:
        the problem or null if the send was successful.

      • isOK

        public boolean isOK()
        Determines if this result is ok or not.
        Returns:
        whether the send was successful or not.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Session (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface Session

  • All Superinterfaces:
    AutoCloseable, Closeable

    public interface Session
extends Closeable
    A Web Socket session represents a conversation between two web socket endpoints. As soon as the websocket handshake completes successfully, the web socket implementation provides the endpoint an open websocket session. The endpoint can then register interest in incoming messages that are part of this newly created session by providing a MessageHandler to the session, and can send messages to the other end of the conversation by means of the RemoteEndpoint object obtained from this session.

    Once the session is closed, it is no longer valid for use by applications. Calling any of its methods (with the exception of the close() methods) once the session has been closed will result in an IllegalStateException being thrown. Developers should retrieve any information from the session during the Endpoint.onClose(javax.websocket.Session, javax.websocket.CloseReason) method. Following the convention of Closeable calling the Session close() methods after the Session has been closed has no effect.

    Session objects may be called by multiple threads. Implementations must ensure the integrity of the mutable properties of the session under such circumstances.

    Author:
    dannycoward

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addMessageHandler(MessageHandler handler)
      Register to handle to incoming messages in this conversation.
      void close()
      Close the current conversation with a normal status code and no reason phrase.
      void close(CloseReason closeReason)
      Close the current conversation, giving a reason for the closure.
      RemoteEndpoint.Async getAsyncRemote()
      Return a reference a RemoteEndpoint object representing the peer of this conversation that is able to send messages asynchronously to the peer.
      RemoteEndpoint.Basic getBasicRemote()
      Return a reference a RemoteEndpoint object representing the peer of this conversation that is able to send messages synchronously to the peer.
      WebSocketContainer getContainer()
      Return the container that this session is part of.
      String getId()
      Returns a string containing the unique identifier assigned to this session.
      int getMaxBinaryMessageBufferSize()
      The maximum length of incoming binary messages that this Session can buffer.
      long getMaxIdleTimeout()
      Return the number of milliseconds before this conversation may be closed by the container if it is inactive, i.e.
      int getMaxTextMessageBufferSize()
      The maximum length of incoming text messages that this Session can buffer.
      Set<MessageHandler> getMessageHandlers()
      Return an unmodifiable copy of the set of MessageHandlers for this Session.
      List<Extension> getNegotiatedExtensions()
      Return the list of extensions currently in use for this conversation.
      String getNegotiatedSubprotocol()
      Return the sub protocol agreed during the websocket handshake for this conversation.
      Set<Session> getOpenSessions()
      Return a copy of the Set of all the open web socket sessions that represent connections to the same endpoint to which this session represents a connection.
      Map<String,String> getPathParameters()
      Return a map of the path parameter names and values used associated with the request this session was opened under.
      String getProtocolVersion()
      Returns the version of the websocket protocol currently being used.
      String getQueryString()
      Return the query string associated with the request this session was opened under.
      Map<String,List<String>> getRequestParameterMap()
      Return the request parameters associated with the request this session was opened under.
      URI getRequestURI()
      Return the URI under which this session was opened, including the query string if there is one.
      Principal getUserPrincipal()
      Return the authenticated user for this Session or null if no user is authenticated for this session.
      Map<String,Object> getUserProperties()
      While the session is open, this method returns a Map that the developer may use to store application specific information relating to this session instance.
      boolean isOpen()
      Return true if and only if the underlying socket is open.
      boolean isSecure()
      Return true if and only if the underlying socket is using a secure transport.
      void removeMessageHandler(MessageHandler handler)
      Remove the given MessageHandler from the set belonging to this session.
      void setMaxBinaryMessageBufferSize(int length)
      Sets the maximum length of incoming binary messages that this Session can buffer.
      void setMaxIdleTimeout(long milliseconds)
      Set the non-zero number of milliseconds before this session will be closed by the container if it is inactive, ie no messages are either sent or received.
      void setMaxTextMessageBufferSize(int length)
      Sets the maximum length of incoming text messages that this Session can buffer.

    • Method Detail

      • getContainer

        WebSocketContainer getContainer()
        Return the container that this session is part of.
        Returns:
        the container.

      • addMessageHandler

        void addMessageHandler(MessageHandler handler)
                       throws IllegalStateException
        Register to handle to incoming messages in this conversation. A maximum of one message handler per native websocket message type (text, binary, pong) may be added to each Session. I.e. a maximum of one message handler to handle incoming text messages a maximum of one message handler for handling incoming binary messages, and a maximum of one for handling incoming pong messages. For further details of which message handlers handle which of the native websocket message types please see MessageHandler.Whole and MessageHandler.Partial. Adding more than one of any one type will result in a runtime exception.

        See Endpoint for a usage example.

        Parameters:
        handler - the MessageHandler to be added.
        Throws:
        IllegalStateException - if there is already a MessageHandler registered for the same native websocket message type as this handler.

      • getMessageHandlers

        Set<MessageHandler> getMessageHandlers()
        Return an unmodifiable copy of the set of MessageHandlers for this Session.
        Returns:
        the set of message handlers.

      • removeMessageHandler

        void removeMessageHandler(MessageHandler handler)
        Remove the given MessageHandler from the set belonging to this session. This method may block if the given handler is processing a message until it is no longer in use.
        Parameters:
        handler - the handler to be removed.

      • getProtocolVersion

        String getProtocolVersion()
        Returns the version of the websocket protocol currently being used. This is taken as the value of the Sec-WebSocket-Version header used in the opening handshake. i.e. "13".
        Returns:
        the protocol version.

      • getNegotiatedSubprotocol

        String getNegotiatedSubprotocol()
        Return the sub protocol agreed during the websocket handshake for this conversation.
        Returns:
        the negotiated subprotocol, or the empty string if there isn't one.

      • getNegotiatedExtensions

        List<Extension> getNegotiatedExtensions()
        Return the list of extensions currently in use for this conversation.
        Returns:
        the negotiated extensions.

      • isSecure

        boolean isSecure()
        Return true if and only if the underlying socket is using a secure transport.
        Returns:
        whether its using a secure transport.

      • isOpen

        boolean isOpen()
        Return true if and only if the underlying socket is open.
        Returns:
        whether the session is active.

      • getMaxIdleTimeout

        long getMaxIdleTimeout()
        Return the number of milliseconds before this conversation may be closed by the container if it is inactive, i.e. no messages are either sent or received in that time.
        Returns:
        the timeout in milliseconds.

      • setMaxIdleTimeout

        void setMaxIdleTimeout(long milliseconds)
        Set the non-zero number of milliseconds before this session will be closed by the container if it is inactive, ie no messages are either sent or received. A value that is 0 or negative indicates the session will never timeout due to inactivity.
        Parameters:
        milliseconds - the number of milliseconds.

      • setMaxBinaryMessageBufferSize

        void setMaxBinaryMessageBufferSize(int length)
        Sets the maximum length of incoming binary messages that this Session can buffer.
        Parameters:
        length - the maximum length.

      • getMaxBinaryMessageBufferSize

        int getMaxBinaryMessageBufferSize()
        The maximum length of incoming binary messages that this Session can buffer. If the implementation receives a binary message that it cannot buffer because it is too large, it must close the session with a close code of CloseReason.CloseCodes.TOO_BIG.
        Returns:
        the maximum binary message size that can be buffered.

      • setMaxTextMessageBufferSize

        void setMaxTextMessageBufferSize(int length)
        Sets the maximum length of incoming text messages that this Session can buffer.
        Parameters:
        length - the maximum length.

      • getMaxTextMessageBufferSize

        int getMaxTextMessageBufferSize()
        The maximum length of incoming text messages that this Session can buffer. If the implementation receives a text message that it cannot buffer because it is too large, it must close the session with a close code of CloseReason.CloseCodes.TOO_BIG.
        Returns:
        the maximum text message size that can be buffered.

      • getAsyncRemote

        RemoteEndpoint.Async getAsyncRemote()
        Return a reference a RemoteEndpoint object representing the peer of this conversation that is able to send messages asynchronously to the peer.
        Returns:
        the remote endpoint.

      • getBasicRemote

        RemoteEndpoint.Basic getBasicRemote()
        Return a reference a RemoteEndpoint object representing the peer of this conversation that is able to send messages synchronously to the peer.
        Returns:
        the remote endpoint.

      • getId

        String getId()
        Returns a string containing the unique identifier assigned to this session. The identifier is assigned by the web socket implementation and is implementation dependent.
        Returns:
        the unique identifier for this session instance.

      • close

        void close()
           throws IOException
        Close the current conversation with a normal status code and no reason phrase.
        Specified by:
        close in interface AutoCloseable
        Specified by:
        close in interface Closeable
        Throws:
        IOException - if there was a connection error closing the connection.

      • close

        void close(CloseReason closeReason)
           throws IOException
        Close the current conversation, giving a reason for the closure. The close call causes the implementation to attempt notify the client of the close as soon as it can. This may cause the sending of unsent messages immediately prior to the close notification. After the close notification has been sent the implementation notifies the endpoint's onClose method. Note the websocket specification defines the acceptable uses of status codes and reason phrases. If the application cannot determine a suitable close code to use for the closeReason, it is recommended to use CloseReason.CloseCodes.NO_STATUS_CODE.
        Parameters:
        closeReason - the reason for the closure.
        Throws:
        IOException - if there was a connection error closing the connection

      • getRequestURI

        URI getRequestURI()
        Return the URI under which this session was opened, including the query string if there is one.
        Returns:
        the request URI.

      • getRequestParameterMap

        Map<String,List<String>> getRequestParameterMap()
        Return the request parameters associated with the request this session was opened under.
        Returns:
        the unmodifiable map of the request parameters.

      • getQueryString

        String getQueryString()
        Return the query string associated with the request this session was opened under.
        Returns:
        the query string

      • getPathParameters

        Map<String,String> getPathParameters()
        Return a map of the path parameter names and values used associated with the request this session was opened under.
        Returns:
        the unmodifiable map of path parameters. The key of the map is the parameter name, the values in the map are the parameter values.

      • getUserProperties

        Map<String,Object> getUserProperties()
        While the session is open, this method returns a Map that the developer may use to store application specific information relating to this session instance. The developer may retrieve information from this Map at any time between the opening of the session and during the onClose() method. But outside that time, any information stored using this Map may no longer be kept by the container. Web socket applications running on distributed implementations of the web container should make any application specific objects stored here java.io.Serializable, or the object may not be recreated after a failover.
        Returns:
        an editable Map of application data.

      • getUserPrincipal

        Principal getUserPrincipal()
        Return the authenticated user for this Session or null if no user is authenticated for this session.
        Returns:
        the user principal.

      • getOpenSessions

        Set<Session> getOpenSessions()
        Return a copy of the Set of all the open web socket sessions that represent connections to the same endpoint to which this session represents a connection. The Set includes the session this method is called on. These sessions may not still be open at any point after the return of this method. For example, iterating over the set at a later time may yield one or more closed sessions. Developers should use session.isOpen() to check.
        Returns:
        the set of sessions, open at the time of return.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SessionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Class SessionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.websocket.SessionException
  • All Implemented Interfaces:
    Serializable

    public class SessionException
extends Exception
    A SessionException represents a general exception type reporting problems occurring on a websocket session.
    Author:
    dannycoward
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SessionException(String message, Throwable cause, Session session)
      Creates a new instance of this exception with the given message, the wrapped cause of the exception and the session with which the problem is associated.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Session getSession()
      Return the Session on which the problem occurred.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SessionException

        public SessionException(String message,
                Throwable cause,
                Session session)
        Creates a new instance of this exception with the given message, the wrapped cause of the exception and the session with which the problem is associated.
        Parameters:
        message - a description of the problem
        cause - the error that caused the problem
        session - the session on which the problem occurred.

    • Method Detail

      • getSession

        public Session getSession()
        Return the Session on which the problem occurred.
        Returns:
        the session
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.websocket (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.websocket

  • Packages that use javax.websocket
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.
  • Classes in javax.websocket used by javax.websocket
    Class and Description
    ClientEndpointConfig
    The ClientEndpointConfig is a special kind of endpoint configuration object that contains web socket configuration information specific only to client endpoints.
    ClientEndpointConfig.Builder
    The ClientEndpointConfig.Builder is a class used for creating ClientEndpointConfig objects for the purposes of deploying a client endpoint.
    ClientEndpointConfig.Configurator
    The Configurator class may be extended by developers who want to provide custom configuration algorithms, such as intercepting the opening handshake, or providing arbitrary methods and algorithms that can be accessed from each endpoint instance configured with this configurator.
    CloseReason
    A class encapsulating the reason why a web socket has been closed, or why it is being asked to close.
    CloseReason.CloseCode
    A marker interface for the close codes.
    CloseReason.CloseCodes
    An Enumeration of status codes for a web socket close that are defined in the specification.
    DecodeException
    A general exception that occurs when trying to decode a custom object from a text or binary message.
    Decoder
    The Decoder interface holds member interfaces that define how a developer can provide the web socket container a way web socket messages into developer defined custom objects.
    DeploymentException
    Checked exception indicating some kind of failure either to publish an endpoint on its server, or a failure to connect a client to its server.
    EncodeException
    A general exception that occurs when trying to encode a custom object to a string or binary message.
    Encoder
    The Encoder interface defines how developers can provide a way to convert their custom objects into web socket messages.
    Endpoint
    The Web Socket Endpoint represents an object that can handle websocket conversations.
    EndpointConfig
    The endpoint configuration contains all the information needed during the handshake process for this end point.
    Extension
    A simple representation of a websocket extension as a name and map of extension parameters.
    Extension.Parameter
    This member interface defines a single websocket extension parameter.
    HandshakeResponse
    The handshake response represents the web socket-defined Http response that is the response to the opening handshake request.
    MessageHandler
    Developers implement MessageHandlers in order to receive incoming messages during a web socket conversation.
    RemoteEndpoint
    The RemoteEndpoint object is supplied by the container and represents the 'other end' or peer of the Web Socket conversation.
    RemoteEndpoint.Async
    This representation of the peer of a web socket conversation has the ability to send messages asynchronously.
    RemoteEndpoint.Basic
    This representation of the peer of a web socket conversation has the ability to send messages synchronously.
    SendHandler
    A simple callback object for asynchronous sending of web socket messages.
    SendResult
    The result of asynchronously sending a web socket message.
    Session
    A Web Socket session represents a conversation between two web socket endpoints.
    WebSocketContainer
    A WebSocketContainer is an implementation provided object that provides applications a view on the container running it.
  • Classes in javax.websocket used by javax.websocket.server
    Class and Description
    Decoder
    The Decoder interface holds member interfaces that define how a developer can provide the web socket container a way web socket messages into developer defined custom objects.
    DeploymentException
    Checked exception indicating some kind of failure either to publish an endpoint on its server, or a failure to connect a client to its server.
    Encoder
    The Encoder interface defines how developers can provide a way to convert their custom objects into web socket messages.
    Endpoint
    The Web Socket Endpoint represents an object that can handle websocket conversations.
    EndpointConfig
    The endpoint configuration contains all the information needed during the handshake process for this end point.
    Extension
    A simple representation of a websocket extension as a name and map of extension parameters.
    HandshakeResponse
    The handshake response represents the web socket-defined Http response that is the response to the opening handshake request.
    WebSocketContainer
    A WebSocketContainer is an implementation provided object that provides applications a view on the container running it.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WebSocketContainer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket

Interface WebSocketContainer

  • All Known Subinterfaces:
    ServerContainer

    public interface WebSocketContainer
    A WebSocketContainer is an implementation provided object that provides applications a view on the container running it. The WebSocketContainer container various configuration parameters that control default session and buffer properties of the endpoints it contains. It also allows the developer to deploy websocket client endpoints by initiating a web socket handshake from the provided endpoint to a supplied URI where the peer endpoint is presumed to reside.

    A WebSocketContainer may be accessed by concurrent threads, so implementations must ensure the integrity of its mutable attributes in such circumstances.

    Author:
    dannycoward

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Session connectToServer(Class<?> annotatedEndpointClass, URI path)
      Connect the supplied annotated endpoint to its server.
      Session connectToServer(Class<? extends Endpoint> endpointClass, ClientEndpointConfig cec, URI path)
      Connect the supplied programmatic endpoint to its server with the given configuration.
      Session connectToServer(Endpoint endpointInstance, ClientEndpointConfig cec, URI path)
      Connect the supplied programmatic client endpoint instance to its server with the given configuration.
      Session connectToServer(Object annotatedEndpointInstance, URI path)
      Connect the supplied annotated endpoint instance to its server.
      long getDefaultAsyncSendTimeout()
      Return the number of milliseconds the implementation will timeout attempting to send a websocket message for all RemoteEndpoints associated with this container.
      int getDefaultMaxBinaryMessageBufferSize()
      Returns the default maximum size of incoming binary message that this container will buffer.
      long getDefaultMaxSessionIdleTimeout()
      Return the default time in milliseconds after which any web socket sessions in this container will be closed if it has been inactive.
      int getDefaultMaxTextMessageBufferSize()
      Returns the default maximum size of incoming text message that this container will buffer.
      Set<Extension> getInstalledExtensions()
      Return the set of Extensions installed in the container.
      void setAsyncSendTimeout(long timeoutmillis)
      Sets the number of milliseconds the implementation will timeout attempting to send a websocket message for all RemoteEndpoints associated with this container.
      void setDefaultMaxBinaryMessageBufferSize(int max)
      Sets the default maximum size of incoming binary message that this container will buffer.
      void setDefaultMaxSessionIdleTimeout(long timeout)
      Sets the default time in milliseconds after which any web socket sessions in this container will be closed if it has been inactive.
      void setDefaultMaxTextMessageBufferSize(int max)
      Sets the maximum size of incoming text message that this container will buffer.

    • Method Detail

      • getDefaultAsyncSendTimeout

        long getDefaultAsyncSendTimeout()
        Return the number of milliseconds the implementation will timeout attempting to send a websocket message for all RemoteEndpoints associated with this container. A non-positive number indicates the implementation will not timeout attempting to send a websocket message asynchronously. Note this default may be overridden in each RemoteEndpoint.
        Returns:
        the timeout time in millsenconds.

      • setAsyncSendTimeout

        void setAsyncSendTimeout(long timeoutmillis)
        Sets the number of milliseconds the implementation will timeout attempting to send a websocket message for all RemoteEndpoints associated with this container. A non-positive number indicates the implementation will not timeout attempting to send a websocket message asynchronously. Note this default may be overridden in each RemoteEndpoint.

      • connectToServer

        Session connectToServer(Object annotatedEndpointInstance,
                      URI path)
                        throws DeploymentException,
                               IOException
        Connect the supplied annotated endpoint instance to its server. The supplied object must be a class decorated with the class level ServerEndpoint annotation. This method blocks until the connection is established, or throws an error if either the connection could not be made or there was a problem with the supplied endpoint class. If the developer uses this method to deploy the client endpoint, services like dependency injection that are supported, for example, when the implementation is part of the Java EE platform may not be available. If the client endpoint uses dependency injection, use connectToServer(java.lang.Class, java.net.URI) instead.
        Parameters:
        annotatedEndpointInstance - the annotated websocket client endpoint instance.
        path - the complete path to the server endpoint.
        Returns:
        the Session created if the connection is successful.
        Throws:
        DeploymentException - if the annotated endpoint instance is not valid.
        IOException - if there was a network or protocol problem that prevented the client endpoint being connected to its server.
        IllegalStateException - if called during the deployment phase of the containing application.

      • connectToServer

        Session connectToServer(Class<?> annotatedEndpointClass,
                      URI path)
                        throws DeploymentException,
                               IOException
        Connect the supplied annotated endpoint to its server. The supplied object must be a class decorated with the class level ServerEndpoint annotation. This method blocks until the connection is established, or throws an error if either the connection could not be made or there was a problem with the supplied endpoint class.
        Parameters:
        annotatedEndpointClass - the annotated websocket client endpoint.
        path - the complete path to the server endpoint.
        Returns:
        the Session created if the connection is successful.
        Throws:
        DeploymentException - if the class is not a valid annotated endpoint class.
        IOException - if there was a network or protocol problem that prevented the client endpoint being connected to its server.
        IllegalStateException - if called during the deployment phase of the containing application.

      • connectToServer

        Session connectToServer(Endpoint endpointInstance,
                      ClientEndpointConfig cec,
                      URI path)
                        throws DeploymentException,
                               IOException
        Connect the supplied programmatic client endpoint instance to its server with the given configuration. This method blocks until the connection is established, or throws an error if the connection could not be made. If the developer uses this method to deploy the client endpoint, services like dependency injection that are supported, for example, when the implementation is part of the Java EE platform may not be available. If the client endpoint uses dependency injection, use connectToServer(java.lang.Class, javax.websocket.ClientEndpointConfig, java.net.URI) instead.
        Parameters:
        endpointInstance - the programmatic client endpoint instance Endpoint.
        path - the complete path to the server endpoint.
        cec - the configuration used to configure the programmatic endpoint.
        Returns:
        the Session created if the connection is successful.
        Throws:
        DeploymentException - if the configuration is not valid
        IOException - if there was a network or protocol problem that prevented the client endpoint being connected to its server
        IllegalStateException - if called during the deployment phase of the containing application.

      • connectToServer

        Session connectToServer(Class<? extends Endpoint> endpointClass,
                      ClientEndpointConfig cec,
                      URI path)
                        throws DeploymentException,
                               IOException
        Connect the supplied programmatic endpoint to its server with the given configuration. This method blocks until the connection is established, or throws an error if the connection could not be made.
        Parameters:
        endpointClass - the programmatic client endpoint class Endpoint.
        path - the complete path to the server endpoint.
        cec - the configuration used to configure the programmatic endpoint.
        Returns:
        the Session created if the connection is successful.
        Throws:
        DeploymentException - if the configuration is not valid
        IOException - if there was a network or protocol problem that prevented the client endpoint being connected to its server
        IllegalStateException - if called during the deployment phase of the containing application.

      • getDefaultMaxSessionIdleTimeout

        long getDefaultMaxSessionIdleTimeout()
        Return the default time in milliseconds after which any web socket sessions in this container will be closed if it has been inactive. A value that is 0 or negative indicates the sessions will never timeout due to inactivity. The value may be overridden on a per session basis using Session.setMaxIdleTimeout(long)
        Returns:
        the default number of milliseconds after which an idle session in this container will be closed

      • setDefaultMaxSessionIdleTimeout

        void setDefaultMaxSessionIdleTimeout(long timeout)
        Sets the default time in milliseconds after which any web socket sessions in this container will be closed if it has been inactive. A value that is 0 or negative indicates the sessions will never timeout due to inactivity. The value may be overridden on a per session basis using Session.setMaxIdleTimeout(long)
        Parameters:
        timeout - the maximum time in milliseconds.

      • getDefaultMaxBinaryMessageBufferSize

        int getDefaultMaxBinaryMessageBufferSize()
        Returns the default maximum size of incoming binary message that this container will buffer. This default may be overridden on a per session basis using Session.setMaxBinaryMessageBufferSize(int)
        Returns:
        the maximum size of incoming binary message in number of bytes.

      • setDefaultMaxBinaryMessageBufferSize

        void setDefaultMaxBinaryMessageBufferSize(int max)
        Sets the default maximum size of incoming binary message that this container will buffer.
        Parameters:
        max - the maximum size of binary message in number of bytes.

      • getDefaultMaxTextMessageBufferSize

        int getDefaultMaxTextMessageBufferSize()
        Returns the default maximum size of incoming text message that this container will buffer. This default may be overridden on a per session basis using Session.setMaxTextMessageBufferSize(int)
        Returns:
        the maximum size of incoming text message in number of bytes.

      • setDefaultMaxTextMessageBufferSize

        void setDefaultMaxTextMessageBufferSize(int max)
        Sets the maximum size of incoming text message that this container will buffer.
        Parameters:
        max - the maximum size of text message in number of bytes.

      • getInstalledExtensions

        Set<Extension> getInstalledExtensions()
        Return the set of Extensions installed in the container.
        Returns:
        the set of extensions.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.websocket.ClientEndpoint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.ClientEndpoint

No usage of javax.websocket.ClientEndpoint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.ClientEndpointConfig.Builder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.ClientEndpointConfig.Builder

  • Packages that use ClientEndpointConfig.Builder
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of ClientEndpointConfig.Builder in javax.websocket

      Methods in javax.websocket that return ClientEndpointConfig.Builder
      Modifier and Type Method and Description
      ClientEndpointConfig.Builder ClientEndpointConfig.Builder.configurator(ClientEndpointConfig.Configurator clientEndpointConfigurator)
      Sets the configurator object for the configuration this builder will build.
      static ClientEndpointConfig.Builder ClientEndpointConfig.Builder.create()
      Creates a new builder object with no subprotocols, extensions, encoders, decoders and a null configurator.
      ClientEndpointConfig.Builder ClientEndpointConfig.Builder.decoders(List<Class<? extends Decoder>> decoders)
      Assign the list of decoder implementation classes the client will use.
      ClientEndpointConfig.Builder ClientEndpointConfig.Builder.encoders(List<Class<? extends Encoder>> encoders)
      Assign the list of encoder implementation classes the client will use.
      ClientEndpointConfig.Builder ClientEndpointConfig.Builder.extensions(List<Extension> extensions)
      Set the extensions for the configuration this builder will build.
      ClientEndpointConfig.Builder ClientEndpointConfig.Builder.preferredSubprotocols(List<String> preferredSubprotocols)
      Set the preferred sub protocols for the configuration this builder will build.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.ClientEndpointConfig.Configurator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.ClientEndpointConfig.Configurator

  • Packages that use ClientEndpointConfig.Configurator
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of ClientEndpointConfig.Configurator in javax.websocket

      Methods in javax.websocket that return ClientEndpointConfig.Configurator
      Modifier and Type Method and Description
      ClientEndpointConfig.Configurator ClientEndpointConfig.getConfigurator()
      Return the custom configurator for this configuration.
      Methods in javax.websocket with parameters of type ClientEndpointConfig.Configurator
      Modifier and Type Method and Description
      ClientEndpointConfig.Builder ClientEndpointConfig.Builder.configurator(ClientEndpointConfig.Configurator clientEndpointConfigurator)
      Sets the configurator object for the configuration this builder will build.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.CloseReason (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.CloseReason

  • Packages that use CloseReason
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of CloseReason in javax.websocket

      Methods in javax.websocket with parameters of type CloseReason
      Modifier and Type Method and Description
      void Session.close(CloseReason closeReason)
      Close the current conversation, giving a reason for the closure.
      void Endpoint.onClose(Session session, CloseReason closeReason)
      This method is called immediately prior to the session with the remote peer being closed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.CloseReason.CloseCodes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.CloseReason.CloseCodes

  • Packages that use CloseReason.CloseCodes
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of CloseReason.CloseCodes in javax.websocket

      Methods in javax.websocket that return CloseReason.CloseCodes
      Modifier and Type Method and Description
      static CloseReason.CloseCodes CloseReason.CloseCodes.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CloseReason.CloseCodes[] CloseReason.CloseCodes.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.ContainerProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.ContainerProvider

No usage of javax.websocket.ContainerProvider
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.DecodeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.DecodeException

  • Packages that use DecodeException
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of DecodeException in javax.websocket

      Methods in javax.websocket that throw DecodeException
      Modifier and Type Method and Description
      T Decoder.Binary.decode(ByteBuffer bytes)
      Decode the given bytes into an object of type T.
      T Decoder.BinaryStream.decode(InputStream is)
      Decode the given bytes read from the input stream into an object of type T.
      T Decoder.TextStream.decode(Reader reader)
      Reads the websocket message from the implementation provided Reader and decodes it into an instance of the supplied object type.
      T Decoder.Text.decode(String s)
      Decode the given String into an object of type T.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.DeploymentException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.DeploymentException

  • Packages that use DeploymentException
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of DeploymentException in javax.websocket

      Methods in javax.websocket that throw DeploymentException
      Modifier and Type Method and Description
      Session WebSocketContainer.connectToServer(Class<?> annotatedEndpointClass, URI path)
      Connect the supplied annotated endpoint to its server.
      Session WebSocketContainer.connectToServer(Class<? extends Endpoint> endpointClass, ClientEndpointConfig cec, URI path)
      Connect the supplied programmatic endpoint to its server with the given configuration.
      Session WebSocketContainer.connectToServer(Endpoint endpointInstance, ClientEndpointConfig cec, URI path)
      Connect the supplied programmatic client endpoint instance to its server with the given configuration.
      Session WebSocketContainer.connectToServer(Object annotatedEndpointInstance, URI path)
      Connect the supplied annotated endpoint instance to its server.

    • Uses of DeploymentException in javax.websocket.server

      Methods in javax.websocket.server that throw DeploymentException
      Modifier and Type | Method and Description
      void ServerContainer.addEndpoint(Class<?> endpointClass)
      Deploys the given annotated endpoint into this ServerContainer during the initialization phase of deploying the application.
      void | ServerContainer.addEndpoint(ServerEndpointConfig serverConfig)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.EncodeException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.EncodeException

  • Packages that use EncodeException
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of EncodeException in javax.websocket

      Methods in javax.websocket that throw EncodeException
      Modifier and Type Method and Description
      String Encoder.Text.encode(T object)
      Encode the given object into a String.
      ByteBuffer Encoder.Binary.encode(T object)
      Encode the given object into a byte array.
      void Encoder.BinaryStream.encode(T object, OutputStream os)
      Encode the given object into a binary stream written to the implementation provided OutputStream.
      void Encoder.TextStream.encode(T object, Writer writer)
      Encode the given object to a character stream writing it to the supplied Writer.
      void RemoteEndpoint.Basic.sendObject(Object data)
      Sends a custom developer object, blocking until it has been transmitted.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.Endpoint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.Endpoint

  • Packages that use Endpoint
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of Endpoint in javax.websocket

      Methods in javax.websocket with parameters of type Endpoint
      Modifier and Type Method and Description
      Session WebSocketContainer.connectToServer(Endpoint endpointInstance, ClientEndpointConfig cec, URI path)
      Connect the supplied programmatic client endpoint instance to its server with the given configuration.
      Method parameters in javax.websocket with type arguments of type Endpoint
      Modifier and Type Method and Description
      Session WebSocketContainer.connectToServer(Class<? extends Endpoint> endpointClass, ClientEndpointConfig cec, URI path)
      Connect the supplied programmatic endpoint to its server with the given configuration.

    • Uses of Endpoint in javax.websocket.server

      Method parameters in javax.websocket.server with type arguments of type Endpoint
      Modifier and Type Method and Description
      Set<ServerEndpointConfig> ServerApplicationConfig.getEndpointConfigs(Set<Class<? extends Endpoint>> endpointClasses)
      Return a set of ServerEndpointConfig instances that the server container will use to deploy the programmatic endpoints.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.OnClose (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.OnClose

No usage of javax.websocket.OnClose
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.OnError (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.OnError

No usage of javax.websocket.OnError
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.OnMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.OnMessage

No usage of javax.websocket.OnMessage
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.OnOpen (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.OnOpen

No usage of javax.websocket.OnOpen
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.SendResult (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.SendResult

  • Packages that use SendResult
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of SendResult in javax.websocket

      Methods in javax.websocket with parameters of type SendResult
      Modifier and Type Method and Description
      void SendHandler.onResult(SendResult result)
      Called once the message has been transmitted.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.SessionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.SessionException

No usage of javax.websocket.SessionException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.ClientEndpointConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.ClientEndpointConfig

  • Packages that use ClientEndpointConfig
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of ClientEndpointConfig in javax.websocket

      Methods in javax.websocket that return ClientEndpointConfig
      Modifier and Type Method and Description
      ClientEndpointConfig ClientEndpointConfig.Builder.build()
      Builds a configuration object using the attributes set on this builder.
      Methods in javax.websocket with parameters of type ClientEndpointConfig
      Modifier and Type Method and Description
      Session WebSocketContainer.connectToServer(Class<? extends Endpoint> endpointClass, ClientEndpointConfig cec, URI path)
      Connect the supplied programmatic endpoint to its server with the given configuration.
      Session WebSocketContainer.connectToServer(Endpoint endpointInstance, ClientEndpointConfig cec, URI path)
      Connect the supplied programmatic client endpoint instance to its server with the given configuration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.CloseReason.CloseCode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.CloseReason.CloseCode

  • Packages that use CloseReason.CloseCode
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of CloseReason.CloseCode in javax.websocket

      Classes in javax.websocket that implement CloseReason.CloseCode
      Modifier and Type Class and Description
      static class  CloseReason.CloseCodes
      An Enumeration of status codes for a web socket close that are defined in the specification.
      Methods in javax.websocket that return CloseReason.CloseCode
      Modifier and Type Method and Description
      CloseReason.CloseCode CloseReason.getCloseCode()
      The Close code associated with this CloseReason.
      static CloseReason.CloseCode CloseReason.CloseCodes.getCloseCode(int code)
      Creates a CloseCode from the given int code number.
      Constructors in javax.websocket with parameters of type CloseReason.CloseCode
      Constructor and Description
      CloseReason(CloseReason.CloseCode closeCode, String reasonPhrase)
      Creates a reason for closing a web socket connection with the given code and reason phrase.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Decoder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Decoder

  • Packages that use Decoder
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of Decoder in javax.websocket

      Subinterfaces of Decoder in javax.websocket
      Modifier and Type Interface and Description
      static interface  Decoder.Binary<T>
      This interface defines how a custom object (of type T) is decoded from a web socket message in the form of a byte buffer.
      static interface  Decoder.BinaryStream<T>
      This interface defines how a custom object is decoded from a web socket message in the form of a binary stream.
      static interface  Decoder.Text<T>
      This interface defines how a custom object is decoded from a web socket message in the form of a string.
      static interface  Decoder.TextStream<T>
      This interface defines how a custom object of type T is decoded from a web socket message in the form of a character stream.
      Methods in javax.websocket that return types with arguments of type Decoder
      Modifier and Type Method and Description
      List<Class<? extends Decoder>> EndpointConfig.getDecoders()
      Return the Decoder implementation classes configured.
      Method parameters in javax.websocket with type arguments of type Decoder
      Modifier and Type Method and Description
      ClientEndpointConfig.Builder ClientEndpointConfig.Builder.decoders(List<Class<? extends Decoder>> decoders)
      Assign the list of decoder implementation classes the client will use.

    • Uses of Decoder in javax.websocket.server

      Method parameters in javax.websocket.server with type arguments of type Decoder
      Modifier and Type Method and Description
      ServerEndpointConfig.Builder ServerEndpointConfig.Builder.decoders(List<Class<? extends Decoder>> decoders)
      Sets the decoder implementation classes to use in the configuration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Decoder.Binary (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Decoder.Binary

No usage of javax.websocket.Decoder.Binary
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Decoder.BinaryStream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Decoder.BinaryStream

No usage of javax.websocket.Decoder.BinaryStream
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Decoder.Text (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Decoder.Text

No usage of javax.websocket.Decoder.Text
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Decoder.TextStream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Decoder.TextStream

No usage of javax.websocket.Decoder.TextStream
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Encoder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Encoder

  • Packages that use Encoder
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of Encoder in javax.websocket

      Subinterfaces of Encoder in javax.websocket
      Modifier and Type Interface and Description
      static interface  Encoder.Binary<T>
      This interface defines how to provide a way to convert a custom object into a binary message.
      static interface  Encoder.BinaryStream<T>
      This interface may be implemented by encoding algorithms that want to write the encoded object to a binary stream.
      static interface  Encoder.Text<T>
      This interface defines how to provide a way to convert a custom object into a text message.
      static interface  Encoder.TextStream<T>
      This interface may be implemented by encoding algorithms that want to write the encoded object to a character stream.
      Methods in javax.websocket that return types with arguments of type Encoder
      Modifier and Type Method and Description
      List<Class<? extends Encoder>> EndpointConfig.getEncoders()
      Return the Encoder implementation classes configured.
      Method parameters in javax.websocket with type arguments of type Encoder
      Modifier and Type Method and Description
      ClientEndpointConfig.Builder ClientEndpointConfig.Builder.encoders(List<Class<? extends Encoder>> encoders)
      Assign the list of encoder implementation classes the client will use.

    • Uses of Encoder in javax.websocket.server

      Method parameters in javax.websocket.server with type arguments of type Encoder
      Modifier and Type Method and Description
      ServerEndpointConfig.Builder ServerEndpointConfig.Builder.encoders(List<Class<? extends Encoder>> encoders)
      Sets the list of encoder implementation classes for this builder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Encoder.Binary (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Encoder.Binary

No usage of javax.websocket.Encoder.Binary
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Encoder.BinaryStream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Encoder.BinaryStream

No usage of javax.websocket.Encoder.BinaryStream
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Encoder.Text (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Encoder.Text

No usage of javax.websocket.Encoder.Text
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Encoder.TextStream (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Encoder.TextStream

No usage of javax.websocket.Encoder.TextStream
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.EndpointConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.EndpointConfig

  • Packages that use EndpointConfig
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of EndpointConfig in javax.websocket

      Subinterfaces of EndpointConfig in javax.websocket
      Modifier and Type Interface and Description
      interface  ClientEndpointConfig
      The ClientEndpointConfig is a special kind of endpoint configuration object that contains web socket configuration information specific only to client endpoints.
      Methods in javax.websocket with parameters of type EndpointConfig
      Modifier and Type Method and Description
      void Encoder.init(EndpointConfig config)
      This method is called with the endpoint configuration object of the endpoint this encoder is intended for when it is about to be brought into service.
      void Decoder.init(EndpointConfig config)
      This method is called with the endpoint configuration object of the endpoint this decoder is intended for when it is about to be brought into service.
      abstract void Endpoint.onOpen(Session session, EndpointConfig config)
      Developers must implement this method to be notified when a new conversation has just begun.

    • Uses of EndpointConfig in javax.websocket.server

      Subinterfaces of EndpointConfig in javax.websocket.server
      Modifier and Type Interface and Description
      interface  ServerEndpointConfig
      The ServerEndpointConfig is a special kind of endpoint configuration object that contains web socket configuration information specific only to server endpoints.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Extension (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Extension

  • Packages that use Extension
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of Extension in javax.websocket

      Methods in javax.websocket that return types with arguments of type Extension
      Modifier and Type Method and Description
      List<Extension> ClientEndpointConfig.getExtensions()
      Return the extensions, in order of preference, favorite first, that this client would like to use for its sessions.
      Set<Extension> WebSocketContainer.getInstalledExtensions()
      Return the set of Extensions installed in the container.
      List<Extension> Session.getNegotiatedExtensions()
      Return the list of extensions currently in use for this conversation.
      Method parameters in javax.websocket with type arguments of type Extension
      Modifier and Type Method and Description
      ClientEndpointConfig.Builder ClientEndpointConfig.Builder.extensions(List<Extension> extensions)
      Set the extensions for the configuration this builder will build.

    • Uses of Extension in javax.websocket.server

      Methods in javax.websocket.server that return types with arguments of type Extension
      Modifier and Type Method and Description
      List<Extension> ServerEndpointConfig.getExtensions()
      Return the websocket extensions configured.
      List<Extension> ServerEndpointConfig.Configurator.getNegotiatedExtensions(List<Extension> installed, List<Extension> requested)
      Return the ordered list of extensions that t server endpoint will support given the requested extension list passed in, the empty list if none.
      Method parameters in javax.websocket.server with type arguments of type Extension
      Modifier and Type Method and Description
      ServerEndpointConfig.Builder ServerEndpointConfig.Builder.extensions(List<Extension> extensions)
      Sets the extensions to use in the configuration.
      List<Extension> ServerEndpointConfig.Configurator.getNegotiatedExtensions(List<Extension> installed, List<Extension> requested)
      Return the ordered list of extensions that t server endpoint will support given the requested extension list passed in, the empty list if none.
      List<Extension> ServerEndpointConfig.Configurator.getNegotiatedExtensions(List<Extension> installed, List<Extension> requested)
      Return the ordered list of extensions that t server endpoint will support given the requested extension list passed in, the empty list if none.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Extension.Parameter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Extension.Parameter

  • Packages that use Extension.Parameter
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of Extension.Parameter in javax.websocket

      Methods in javax.websocket that return types with arguments of type Extension.Parameter
      Modifier and Type Method and Description
      List<Extension.Parameter> Extension.getParameters()
      The extension parameters for this extension in the order they appear in the http headers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.HandshakeResponse (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.HandshakeResponse

  • Packages that use HandshakeResponse
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of HandshakeResponse in javax.websocket

      Methods in javax.websocket with parameters of type HandshakeResponse
      Modifier and Type Method and Description
      void ClientEndpointConfig.Configurator.afterResponse(HandshakeResponse hr)
      This method is called by the implementation after it has received a handshake response from the server as a result of a handshake interaction it initiated.

    • Uses of HandshakeResponse in javax.websocket.server

      Methods in javax.websocket.server with parameters of type HandshakeResponse
      Modifier and Type Method and Description
      void ServerEndpointConfig.Configurator.modifyHandshake(ServerEndpointConfig sec, HandshakeRequest request, HandshakeResponse response)
      Called by the container after it has formulated a handshake response resulting from a well-formed handshake request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.MessageHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.MessageHandler

  • Packages that use MessageHandler
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of MessageHandler in javax.websocket

      Subinterfaces of MessageHandler in javax.websocket
      Modifier and Type Interface and Description
      static interface  MessageHandler.Partial<T>
      This kind of handler is notified by the implementation as it becomes ready to deliver parts of a whole message.
      static interface  MessageHandler.Whole<T>
      This kind of handler is notified by the container on arrival of a complete message.
      Methods in javax.websocket that return types with arguments of type MessageHandler
      Modifier and Type Method and Description
      Set<MessageHandler> Session.getMessageHandlers()
      Return an unmodifiable copy of the set of MessageHandlers for this Session.
      Methods in javax.websocket with parameters of type MessageHandler
      Modifier and Type Method and Description
      void Session.addMessageHandler(MessageHandler handler)
      Register to handle to incoming messages in this conversation.
      void Session.removeMessageHandler(MessageHandler handler)
      Remove the given MessageHandler from the set belonging to this session.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.MessageHandler.Partial (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.MessageHandler.Partial

No usage of javax.websocket.MessageHandler.Partial
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.MessageHandler.Whole (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.MessageHandler.Whole

No usage of javax.websocket.MessageHandler.Whole
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.PongMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.PongMessage

No usage of javax.websocket.PongMessage
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.RemoteEndpoint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.RemoteEndpoint

  • Packages that use RemoteEndpoint
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of RemoteEndpoint in javax.websocket

      Subinterfaces of RemoteEndpoint in javax.websocket
      Modifier and Type Interface and Description
      static interface  RemoteEndpoint.Async
      This representation of the peer of a web socket conversation has the ability to send messages asynchronously.
      static interface  RemoteEndpoint.Basic
      This representation of the peer of a web socket conversation has the ability to send messages synchronously.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.RemoteEndpoint.Async (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.RemoteEndpoint.Async

  • Packages that use RemoteEndpoint.Async
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of RemoteEndpoint.Async in javax.websocket

      Methods in javax.websocket that return RemoteEndpoint.Async
      Modifier and Type Method and Description
      RemoteEndpoint.Async Session.getAsyncRemote()
      Return a reference a RemoteEndpoint object representing the peer of this conversation that is able to send messages asynchronously to the peer.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.RemoteEndpoint.Basic (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.RemoteEndpoint.Basic

  • Packages that use RemoteEndpoint.Basic
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of RemoteEndpoint.Basic in javax.websocket

      Methods in javax.websocket that return RemoteEndpoint.Basic
      Modifier and Type Method and Description
      RemoteEndpoint.Basic Session.getBasicRemote()
      Return a reference a RemoteEndpoint object representing the peer of this conversation that is able to send messages synchronously to the peer.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.SendHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.SendHandler

  • Packages that use SendHandler
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of SendHandler in javax.websocket

      Methods in javax.websocket with parameters of type SendHandler
      Modifier and Type Method and Description
      void RemoteEndpoint.Async.sendBinary(ByteBuffer data, SendHandler handler)
      Initiates the asynchronous transmission of a binary message.
      void RemoteEndpoint.Async.sendObject(Object data, SendHandler handler)
      Initiates the asynchronous transmission of a custom developer object.
      void RemoteEndpoint.Async.sendText(String text, SendHandler handler)
      Initiates the asynchronous transmission of a text message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.Session (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.Session

  • Packages that use Session
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.

    • Uses of Session in javax.websocket

      Methods in javax.websocket that return Session
      Modifier and Type Method and Description
      Session WebSocketContainer.connectToServer(Class<?> annotatedEndpointClass, URI path)
      Connect the supplied annotated endpoint to its server.
      Session WebSocketContainer.connectToServer(Class<? extends Endpoint> endpointClass, ClientEndpointConfig cec, URI path)
      Connect the supplied programmatic endpoint to its server with the given configuration.
      Session WebSocketContainer.connectToServer(Endpoint endpointInstance, ClientEndpointConfig cec, URI path)
      Connect the supplied programmatic client endpoint instance to its server with the given configuration.
      Session WebSocketContainer.connectToServer(Object annotatedEndpointInstance, URI path)
      Connect the supplied annotated endpoint instance to its server.
      Session SessionException.getSession()
      Return the Session on which the problem occurred.
      Methods in javax.websocket that return types with arguments of type Session
      Modifier and Type Method and Description
      Set<Session> Session.getOpenSessions()
      Return a copy of the Set of all the open web socket sessions that represent connections to the same endpoint to which this session represents a connection.
      Methods in javax.websocket with parameters of type Session
      Modifier and Type Method and Description
      void Endpoint.onClose(Session session, CloseReason closeReason)
      This method is called immediately prior to the session with the remote peer being closed.
      void Endpoint.onError(Session session, Throwable thr)
      Developers may implement this method when the web socket session creates some kind of error that is not modeled in the web socket protocol.
      abstract void Endpoint.onOpen(Session session, EndpointConfig config)
      Developers must implement this method to be notified when a new conversation has just begun.
      Constructors in javax.websocket with parameters of type Session
      Constructor and Description
      SessionException(String message, Throwable cause, Session session)
      Creates a new instance of this exception with the given message, the wrapped cause of the exception and the session with which the problem is associated.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.WebSocketContainer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.WebSocketContainer

  • Packages that use WebSocketContainer
    Package Description
    javax.websocket
    This package contains all the WebSocket APIs common to both the client and server side.
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of WebSocketContainer in javax.websocket

      Methods in javax.websocket that return WebSocketContainer
      Modifier and Type Method and Description
      WebSocketContainer Session.getContainer()
      Return the container that this session is part of.
      protected abstract WebSocketContainer ContainerProvider.getContainer()
      Load the container implementation.
      static WebSocketContainer ContainerProvider.getWebSocketContainer()
      Obtain a new instance of a WebSocketContainer.

    • Uses of WebSocketContainer in javax.websocket.server

      Subinterfaces of WebSocketContainer in javax.websocket.server
      Modifier and Type Interface and Description
      interface  ServerContainer
      The ServerContainer is the specialized view of the WebSocketContainer available in server-side deployments.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


HandshakeRequest (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket.server

Interface HandshakeRequest

  • public interface HandshakeRequest
    The handshake request represents the web socket defined Http GET request for the opening handshake of a web socket session.
    Author:
    dannycoward

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String SEC_WEBSOCKET_EXTENSIONS
      The Sec-WebSocket-Extensions header name
      static String SEC_WEBSOCKET_KEY
      The Sec-WebSocket-Key header name
      static String SEC_WEBSOCKET_PROTOCOL
      The Sec-WebSocket-Protocol header name
      static String SEC_WEBSOCKET_VERSION
      The Sec-WebSocket-Version header name

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Map<String,List<String>> getHeaders()
      Return the read only Map of Http Headers that came with the handshake request.
      Object getHttpSession()
      Return a reference to the HttpSession that the web socket handshake that started this conversation was part of, if the implementation is part of a Java EE web container.
      Map<String,List<String>> getParameterMap()
      Return the request parameters associated with the request.
      String getQueryString()
      Return the query string associated with the request.
      URI getRequestURI()
      Return the request URI of the handshake request.
      Principal getUserPrincipal()
      Return the authenticated user or null if no user is authenticated for this handshake.
      boolean isUserInRole(String role)
      Checks whether the current user is in the given role.

    • Field Detail

      • SEC_WEBSOCKET_KEY

        static final String SEC_WEBSOCKET_KEY
        The Sec-WebSocket-Key header name
        See Also:
        Constant Field Values

      • SEC_WEBSOCKET_PROTOCOL

        static final String SEC_WEBSOCKET_PROTOCOL
        The Sec-WebSocket-Protocol header name
        See Also:
        Constant Field Values

      • SEC_WEBSOCKET_VERSION

        static final String SEC_WEBSOCKET_VERSION
        The Sec-WebSocket-Version header name
        See Also:
        Constant Field Values

      • SEC_WEBSOCKET_EXTENSIONS

        static final String SEC_WEBSOCKET_EXTENSIONS
        The Sec-WebSocket-Extensions header name
        See Also:
        Constant Field Values

    • Method Detail

      • getHeaders

        Map<String,List<String>> getHeaders()
        Return the read only Map of Http Headers that came with the handshake request. The header names are case insensitive.
        Returns:
        the list of headers.

      • getUserPrincipal

        Principal getUserPrincipal()
        Return the authenticated user or null if no user is authenticated for this handshake.
        Returns:
        the user principal.

      • getRequestURI

        URI getRequestURI()
        Return the request URI of the handshake request.
        Returns:
        the request uri of the handshake request.

      • isUserInRole

        boolean isUserInRole(String role)
        Checks whether the current user is in the given role. Roles and role membership can be defined using deployment descriptors of the containing WAR file, if running in a Java EE web container. If the user has not been authenticated, the method returns false.
        Parameters:
        role - the role being checked.
        Returns:
        whether the authenticated user is in the role, or false if the user has not been authenticated.

      • getHttpSession

        Object getHttpSession()
        Return a reference to the HttpSession that the web socket handshake that started this conversation was part of, if the implementation is part of a Java EE web container.
        Returns:
        the http session or null if either the websocket implementation is not part of a Java EE web container, or there is no HttpSession associated with the opening handshake request.

      • getParameterMap

        Map<String,List<String>> getParameterMap()
        Return the request parameters associated with the request.
        Returns:
        the unmodifiable map of the request parameters.

      • getQueryString

        String getQueryString()
        Return the query string associated with the request.
        Returns:
        the query string.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.websocket.server (Java(TM) EE 7 Specification APIs)

javax.websocket.server

Interfaces

  • HandshakeRequest
  • ServerApplicationConfig
  • ServerContainer
  • ServerEndpointConfig

Classes

  • ServerEndpointConfig.Builder
  • ServerEndpointConfig.Configurator

Annotation Types

  • PathParam
  • ServerEndpoint


javax.websocket.server (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.websocket.server

This package contains all the WebSocket APIs used only by server side applications.

See: Description

  • Interface Summary
    Interface Description
    HandshakeRequest
    The handshake request represents the web socket defined Http GET request for the opening handshake of a web socket session.
    ServerApplicationConfig
    Developers include implementations of ServerApplicationConfig in an archive containing websocket endpoints (WAR file, or JAR file within the WAR file) in order to specify the websocket endpoints within the archive the implementation must deploy.
    ServerContainer
    The ServerContainer is the specialized view of the WebSocketContainer available in server-side deployments.
    ServerEndpointConfig
    The ServerEndpointConfig is a special kind of endpoint configuration object that contains web socket configuration information specific only to server endpoints.
  • Class Summary
    Class Description
    ServerEndpointConfig.Builder
    The ServerEndpointConfig.Builder is a class used for creating ServerEndpointConfig.Builder objects for the purposes of deploying a server endpoint.
    ServerEndpointConfig.Configurator
    The ServerEndpointConfig.Configurator class may be extended by developers who want to provide custom configuration algorithms, such as intercepting the opening handshake, or providing arbitrary methods and algorithms that can be accessed from each endpoint instance configured with this configurator.
  • Annotation Types Summary
    Annotation Type Description
    PathParam
    This annotation may be used to annotate method parameters on server endpoints where a URI-template has been used in the path-mapping of the ServerEndpoint annotation.
    ServerEndpoint
    This class level annotation declares that the class it decorates is a web socket endpoint that will be deployed and made available in the URI-space of a web socket server.

Package javax.websocket.server Description

This package contains all the WebSocket APIs used only by server side applications.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.websocket.server Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.websocket.server

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.websocket.server.ServerEndpointConfig.Builder
    • javax.websocket.server.ServerEndpointConfig.Configurator

Interface Hierarchy

  • javax.websocket.EndpointConfig
    • javax.websocket.server.ServerEndpointConfig
  • javax.websocket.server.HandshakeRequest
  • javax.websocket.server.ServerApplicationConfig
  • javax.websocket.WebSocketContainer
    • javax.websocket.server.ServerContainer

Annotation Type Hierarchy

  • javax.websocket.server.ServerEndpoint (implements java.lang.annotation.Annotation)
  • javax.websocket.server.PathParam (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


PathParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.websocket.server

Annotation Type PathParam

  • @Retention(value=RUNTIME)
@Target(value=PARAMETER)
public @interface PathParam
    This annotation may be used to annotate method parameters on server endpoints where a URI-template has been used in the path-mapping of the ServerEndpoint annotation. The method parameter may be of type String, any Java primitive type or any boxed version thereof. If a client URI matches the URI-template, but the requested path parameter cannot be decoded, then the websocket's error handler will be called.

    For example:-

 @ServerEndpoint("/bookings/{guest-id}")
 public class BookingServer {

     @OnMessage
     public void processBookingRequest(@PathParam("guest-id") String guestID, String message, Session session) {
         // process booking from the given guest here
     }
 }

    For example:-

 @ServerEndpoint("/rewards/{vip-level}")
 public class RewardServer {

     @OnMessage
     public void processReward(@PathParam("vip-level") Integer vipLevel, String message, Session session) {
         // process reward here
     }
 }
    Author:
    dannycoward

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      The name of the variable used in the URI-template.

    • Element Detail

      • value

        public abstract String value
        The name of the variable used in the URI-template. If the name does not match a path variable in the URI-template, the value of the method parameter this annotation annotates is null.
        Returns:
        the name of the variable used in the URI-template.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ServerApplicationConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket.server

Interface ServerApplicationConfig

  • public interface ServerApplicationConfig
    Developers include implementations of ServerApplicationConfig in an archive containing websocket endpoints (WAR file, or JAR file within the WAR file) in order to specify the websocket endpoints within the archive the implementation must deploy. There is a separate method for programmatic endpoints and for annotated endpoints.
    Author:
    dannycoward

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<Class<?>> getAnnotatedEndpointClasses(Set<Class<?>> scanned)
      Return a set of annotated endpoint classes that the server container must deploy.
      Set<ServerEndpointConfig> getEndpointConfigs(Set<Class<? extends Endpoint>> endpointClasses)
      Return a set of ServerEndpointConfig instances that the server container will use to deploy the programmatic endpoints.

    • Method Detail

      • getEndpointConfigs

        Set<ServerEndpointConfig> getEndpointConfigs(Set<Class<? extends Endpoint>> endpointClasses)
        Return a set of ServerEndpointConfig instances that the server container will use to deploy the programmatic endpoints. The set of Endpoint classes passed in to this method is the set obtained by scanning the archive containing the implementation of this ServerApplicationConfig. This set passed in may be used the build the set of ServerEndpointConfig instances to return to the container for deployment.
        Parameters:
        endpointClasses - the set of all the Endpoint classes in the archive containing the implementation of this interface.
        Returns:
        the non-null set of ServerEndpointConfig s to deploy on the server, using the empty set to indicate none.

      • getAnnotatedEndpointClasses

        Set<Class<?>> getAnnotatedEndpointClasses(Set<Class<?>> scanned)
        Return a set of annotated endpoint classes that the server container must deploy. The set of classes passed in to this method is the set obtained by scanning the archive containing the implementation of this interface. Therefore, this set passed in contains all the annotated endpoint classes in the JAR or WAR file containing the implementation of this interface. This set passed in may be used the build the set to return to the container for deployment.
        Parameters:
        scanned - the set of all the annotated endpoint classes in the archive containing the implementation of this interface.
        Returns:
        the non-null set of annotated endpoint classes to deploy on the server, using the empty set to indicate none.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerContainer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket.server

Interface ServerContainer

  • All Superinterfaces:
    WebSocketContainer

    public interface ServerContainer
extends WebSocketContainer
    The ServerContainer is the specialized view of the WebSocketContainer available in server-side deployments. There is one ServerContainer instance per websocket application. The ServerContainer holds the methods to be able to register server endpoints during the initialization phase of the application.

    For websocket enabled web containers, developers may obtain a reference to the ServerContainer instance by retrieving it as an attribute named javax.websocket.server.ServerContainer on the ServletContext. This way, the registration methods held on this interface may be called to register server endpoints from a ServletContextListener during the deployment of the WAR file containing the endpoint.

    WebSocket implementations that run outside the web container may have other means by which to provide a ServerContainer instance to the developer at application deployment time.

    Once the application deployment phase is complete, and the websocket application has begun accepting incoming connections, the registration methods may no longer be called.

    Author:
    dannycoward

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void addEndpoint(Class<?> endpointClass)
      Deploys the given annotated endpoint into this ServerContainer during the initialization phase of deploying the application.
      void | addEndpoint(ServerEndpointConfig serverConfig)

      • Methods inherited from interface javax.websocket.WebSocketContainer

        connectToServer, connectToServer, connectToServer, connectToServer, getDefaultAsyncSendTimeout, getDefaultMaxBinaryMessageBufferSize, getDefaultMaxSessionIdleTimeout, getDefaultMaxTextMessageBufferSize, getInstalledExtensions, setAsyncSendTimeout, setDefaultMaxBinaryMessageBufferSize, setDefaultMaxSessionIdleTimeout, setDefaultMaxTextMessageBufferSize

    • Method Detail

      • addEndpoint

        void addEndpoint(Class<?> endpointClass)
                 throws DeploymentException
        Deploys the given annotated endpoint into this ServerContainer during the initialization phase of deploying the application.
        Parameters:
        endpointClass - the class of the annotated endpoint
        Throws:
        DeploymentException - if the annotated endpoint was badly formed.
        IllegalStateException - if the containing websocket application has already been deployed.

      • addEndpoint

        void addEndpoint(ServerEndpointConfig serverConfig)
                 throws DeploymentException
        Parameters:
        serverConfig - the configuration instance representing the logical endpoint that will be registered.
        Throws:
        DeploymentException - if the endpoint was badly formed.
        IllegalStateException - if the containing websocket application has already been deployed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerEndpoint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.websocket.server

Annotation Type ServerEndpoint

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface ServerEndpoint
    This class level annotation declares that the class it decorates is a web socket endpoint that will be deployed and made available in the URI-space of a web socket server. The annotation allows the developer to define the URL (or URI template) which this endpoint will be published, and other important properties of the endpoint to the websocket runtime, such as the encoders it uses to send messages.

    The annotated class must have a public no-arg constructor.

    For example:

 @ServerEndpoint("/hello");
 public class HelloServer {

     @OnMessage
     public void processGreeting(String message, Session session) {
         System.out.println("Greeting received:" + message);
     }

 }
    Author:
    dannycoward

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      The URI or URI-template, level-1 (See RFC 6570) where the endpoint will be deployed.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class<? extends ServerEndpointConfig.Configurator> configurator
      The optional custom configurator class that the developer would like to use to further configure new instances of this endpoint.
      Class<? extends Decoder>[] decoders
      The ordered array of decoder classes this endpoint will use.
      Class<? extends Encoder>[] encoders
      The ordered array of encoder classes this endpoint will use.
      String[] subprotocols
      The ordered array of web socket protocols this endpoint supports.

    • Element Detail

      • value

        public abstract String value
        The URI or URI-template, level-1 (See RFC 6570) where the endpoint will be deployed. The URI us relative to the root of the web socket container and must begin with a leading "/". Trailing "/"'s are ignored. Examples:

 @ServerEndpoint("/chat")
 @ServerEndpoint("/chat/{user}")
 @ServerEndpoint("/booking/{privilege-level}")
        Returns:
        the URI or URI-template

      • subprotocols

        public abstract String[] subprotocols
        The ordered array of web socket protocols this endpoint supports. For example, {"superchat", "chat"}.
        Returns:
        the subprotocols.
        Default:
        {}

      • decoders

        public abstract Class<? extends Decoder>[] decoders
        The ordered array of decoder classes this endpoint will use. For example, if the developer has provided a MysteryObject decoder, this endpoint will be able to receive MysteryObjects as web socket messages. The websocket runtime will use the first decoder in the list able to decode a message, ignoring the remaining decoders.
        Returns:
        the decoders.
        Default:
        {}

      • encoders

        public abstract Class<? extends Encoder>[] encoders
        The ordered array of encoder classes this endpoint will use. For example, if the developer has provided a MysteryObject encoder, this class will be able to send web socket messages in the form of MysteryObjects. The websocket runtime will use the first encoder in the list able to encode a message, ignoring the remaining encoders.
        Returns:
        the encoders.
        Default:
        {}

      • configurator

        public abstract Class<? extends ServerEndpointConfig.Configurator> configurator
        The optional custom configurator class that the developer would like to use to further configure new instances of this endpoint. If no configurator class is provided, the implementation uses its own. The implementation creates a new instance of the configurator per logical endpoint.
        Returns:
        the custom configuration class, or ServerEndpointConfig.Configurator.class if none was set in the annotation.
        Default:
        javax.websocket.server.ServerEndpointConfig.Configurator.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ServerEndpointConfig (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket.server

Interface ServerEndpointConfig

  • All Superinterfaces:
    EndpointConfig

    public interface ServerEndpointConfig
extends EndpointConfig
    The ServerEndpointConfig is a special kind of endpoint configuration object that contains web socket configuration information specific only to server endpoints. For developers deploying programmatic endpoints, ServerEndpointConfig objects can be created using a ServerEndpointConfig.Builder. Certain configuration operations can be customized by providing a ServerEndpointConfig.Configurator
    Author:
    dannycoward

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  ServerEndpointConfig.Builder
      The ServerEndpointConfig.Builder is a class used for creating ServerEndpointConfig.Builder objects for the purposes of deploying a server endpoint.
      static class  ServerEndpointConfig.Configurator
      The ServerEndpointConfig.Configurator class may be extended by developers who want to provide custom configuration algorithms, such as intercepting the opening handshake, or providing arbitrary methods and algorithms that can be accessed from each endpoint instance configured with this configurator.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ServerEndpointConfig.Configurator getConfigurator()
      Return the ServerEndpointConfig.Configurator this configuration is using.
      Class<?> getEndpointClass()
      Returns the Class of the endpoint this configuration is configuring.
      List<Extension> getExtensions()
      Return the websocket extensions configured.
      String getPath()
      Return the path for this endpoint configuration.
      List<String> getSubprotocols()
      Return the websocket subprotocols configured.

      • Methods inherited from interface javax.websocket.EndpointConfig

        getDecoders, getEncoders, getUserProperties

    • Method Detail

      • getEndpointClass

        Class<?> getEndpointClass()
        Returns the Class of the endpoint this configuration is configuring. If the endpoint is an annotated endpoint, the value is the class of the Java class annotated with @ServerEndpoint. if the endpoint is a programmatic, the value is the class of the subclass of Endpoint.
        Returns:
        the class of the endpoint, annotated or programmatic.

      • getPath

        String getPath()
        Return the path for this endpoint configuration. The path is the URI or URI-template (level 1) relative to the websocket root of the server to which the endpoint using this configuration will be mapped. The path is always non-null and always begins with a leading "/".
        Returns:
        the relative path for this configuration.

      • getSubprotocols

        List<String> getSubprotocols()
        Return the websocket subprotocols configured.
        Returns:
        the list of subprotocols, the empty list if none

      • getExtensions

        List<Extension> getExtensions()
        Return the websocket extensions configured.
        Returns:
        the list of extensions, the empty list if none.

      • getConfigurator

        ServerEndpointConfig.Configurator getConfigurator()
        Return the ServerEndpointConfig.Configurator this configuration is using. If none was set by calling ServerEndpointConfig.Builder.configurator(javax.websocket.server.ServerEndpointConfig.Configurator) this methods returns the platform default configurator.
        Returns:
        the configurator in use.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerEndpointConfig.Builder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket.server

Class ServerEndpointConfig.Builder

  • java.lang.Object
    • javax.websocket.server.ServerEndpointConfig.Builder
  • Enclosing interface:
    ServerEndpointConfig

    public static final class ServerEndpointConfig.Builder
extends Object
    The ServerEndpointConfig.Builder is a class used for creating ServerEndpointConfig.Builder objects for the purposes of deploying a server endpoint.

    Here are some examples:

    Building a plain configuration for an endpoint with just a path.

 ServerEndpointConfig config = ServerEndpointConfig.Builder.create(ProgrammaticEndpoint.class, "/foo").build();

    Building a configuration with no subprotocols and a custom configurator.

 ServerEndpointConfig config = ServerEndpointConfig.Builder.create(ProgrammaticEndpoint.class, "/bar")
         .subprotocols(subprotocols)
         .configurator(new MyServerConfigurator())
         .build();
    Author:
    dannycoward

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ServerEndpointConfig build()
      Builds the configuration object using the current attributes that have been set on this builder object.
      ServerEndpointConfig.Builder configurator(ServerEndpointConfig.Configurator serverEndpointConfigurator)
      Sets the custom configurator to use on the configuration object built by this builder.
      static ServerEndpointConfig.Builder create(Class<?> endpointClass, String path)
      Creates the builder with the mandatory information of the endpoint class (programmatic or annotated), the relative URI or URI-template to use, and with no subprotocols, extensions, encoders, decoders or custom configurator.
      ServerEndpointConfig.Builder decoders(List<Class<? extends Decoder>> decoders)
      Sets the decoder implementation classes to use in the configuration.
      ServerEndpointConfig.Builder encoders(List<Class<? extends Encoder>> encoders)
      Sets the list of encoder implementation classes for this builder.
      ServerEndpointConfig.Builder extensions(List<Extension> extensions)
      Sets the extensions to use in the configuration.
      ServerEndpointConfig.Builder subprotocols(List<String> subprotocols)
      Sets the subprotocols to use in the configuration.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • create

        public static ServerEndpointConfig.Builder create(Class<?> endpointClass,
                                  String path)
        Creates the builder with the mandatory information of the endpoint class (programmatic or annotated), the relative URI or URI-template to use, and with no subprotocols, extensions, encoders, decoders or custom configurator.
        Parameters:
        endpointClass - the class of the endpoint to configure
        path - The URI or URI template where the endpoint will be deployed. A trailing "/" will be ignored and the path must begin with /.
        Returns:
        a new instance of ServerEndpointConfig.Builder

      • build

        public ServerEndpointConfig build()
        Builds the configuration object using the current attributes that have been set on this builder object.
        Returns:
        a new ServerEndpointConfig object.

      • encoders

        public ServerEndpointConfig.Builder encoders(List<Class<? extends Encoder>> encoders)
        Sets the list of encoder implementation classes for this builder.
        Parameters:
        encoders - the encoders
        Returns:
        this builder instance

      • decoders

        public ServerEndpointConfig.Builder decoders(List<Class<? extends Decoder>> decoders)
        Sets the decoder implementation classes to use in the configuration.
        Parameters:
        decoders - the decoders
        Returns:
        this builder instance.

      • subprotocols

        public ServerEndpointConfig.Builder subprotocols(List<String> subprotocols)
        Sets the subprotocols to use in the configuration.
        Parameters:
        subprotocols - the subprotocols.
        Returns:
        this builder instance

      • extensions

        public ServerEndpointConfig.Builder extensions(List<Extension> extensions)
        Sets the extensions to use in the configuration.
        Parameters:
        extensions - the extensions to use.
        Returns:
        this builder instance.

      • configurator

        public ServerEndpointConfig.Builder configurator(ServerEndpointConfig.Configurator serverEndpointConfigurator)
        Sets the custom configurator to use on the configuration object built by this builder.
        Parameters:
        serverEndpointConfigurator - the configurator
        Returns:
        this builder instance
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerEndpointConfig.Configurator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.websocket.server

Class ServerEndpointConfig.Configurator

  • java.lang.Object
    • javax.websocket.server.ServerEndpointConfig.Configurator
  • Enclosing interface:
    ServerEndpointConfig

    public static class ServerEndpointConfig.Configurator
extends Object
    The ServerEndpointConfig.Configurator class may be extended by developers who want to provide custom configuration algorithms, such as intercepting the opening handshake, or providing arbitrary methods and algorithms that can be accessed from each endpoint instance configured with this configurator. The implementation must provide a platform default configurator loading using the service loader.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServerEndpointConfig.Configurator()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean checkOrigin(String originHeaderValue)
      Check the value of the Origin header (See Origin Header) the client passed during the opening handshake.
      <T> T getEndpointInstance(Class<T> endpointClass)
      This method is called by the container each time a new client connects to the logical endpoint this configurator configures.
      List<Extension> getNegotiatedExtensions(List<Extension> installed, List<Extension> requested)
      Return the ordered list of extensions that t server endpoint will support given the requested extension list passed in, the empty list if none.
      String getNegotiatedSubprotocol(List<String> supported, List<String> requested)
      Return the subprotocol the server endpoint has chosen from the requested list supplied by a client who wishes to connect, or none if there wasn't one this server endpoint liked.
      void modifyHandshake(ServerEndpointConfig sec, HandshakeRequest request, HandshakeResponse response)
      Called by the container after it has formulated a handshake response resulting from a well-formed handshake request.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServerEndpointConfig.Configurator

        public ServerEndpointConfig.Configurator()

    • Method Detail

      • getNegotiatedSubprotocol

        public String getNegotiatedSubprotocol(List<String> supported,
                              List<String> requested)
        Return the subprotocol the server endpoint has chosen from the requested list supplied by a client who wishes to connect, or none if there wasn't one this server endpoint liked. See Sending the Server's Opening Handshake. Subclasses may provide custom algorithms based on other factors.

        The default platform implementation of this method returns the first subprotocol in the list sent by the client that the server supports, or the empty string if there isn't one.

        Parameters:
        requested - the requested subprotocols from the client endpoint
        supported - the subprotocols supported by the server endpoint
        Returns:
        the negotiated subprotocol or the empty string if there isn't one.

      • getNegotiatedExtensions

        public List<Extension> getNegotiatedExtensions(List<Extension> installed,
                                      List<Extension> requested)
        Return the ordered list of extensions that t server endpoint will support given the requested extension list passed in, the empty list if none. See Negotiating Extensions

        The default platform implementation of this method returns a list containing all of the requested extensions passed to this method that it supports, using the order in the requested extensions, the empty list if none.

        Parameters:
        installed - the installed extensions on the implementation.
        requested - the requested extensions, in the order they were requested by the client
        Returns:
        the list of extensions negotiated, the empty list if none.

      • checkOrigin

        public boolean checkOrigin(String originHeaderValue)
        Check the value of the Origin header (See Origin Header) the client passed during the opening handshake.

        The platform default implementation of this method makes a check of the validity of the Origin header sent along with the opening handshake following the recommendation at: Sending the Server's Opening Handshake.

        Parameters:
        originHeaderValue - the value of the origin header passed by the client.
        Returns:
        whether the check passed or not

      • modifyHandshake

        public void modifyHandshake(ServerEndpointConfig sec,
                   HandshakeRequest request,
                   HandshakeResponse response)
        Called by the container after it has formulated a handshake response resulting from a well-formed handshake request. The container has already checked that this configuration has a matching URI, determined the validity of the origin using the checkOrigin method, and filled out the negotiated subprotocols and extensions based on this configuration. Custom configurations may override this method in order to inspect the request parameters and modify the handshake response that the server has formulated. and the URI checking also.

        If the developer does not override this method, no further modification of the request and response are made by the implementation.

        Parameters:
        sec - the configuration object involved in the handshake
        request - the opening handshake request.
        response - the proposed opening handshake response

      • getEndpointInstance

        public <T> T getEndpointInstance(Class<T> endpointClass)
                      throws InstantiationException
        This method is called by the container each time a new client connects to the logical endpoint this configurator configures. Developers may override this method to control instantiation of endpoint instances in order to customize the initialization of the endpoint instance, or manage them in some other way. If the developer overrides this method, services like dependency injection that are otherwise supported, for example, when the implementation is part of the Java EE platform may not be available. The platform default implementation of this method returns a new endpoint instance per call, thereby ensuring that there is one endpoint instance per client, the default deployment cardinality.
        Type Parameters:
        T - the type of the endpoint
        Parameters:
        endpointClass - the class of the endpoint
        Returns:
        an instance of the endpoint that will handle all interactions from a new client.
        Throws:
        InstantiationException - if there was an error producing the endpoint instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.websocket.server (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.websocket.server

  • Packages that use javax.websocket.server
    Package Description
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.
  • Classes in javax.websocket.server used by javax.websocket.server
    Class and Description
    HandshakeRequest
    The handshake request represents the web socket defined Http GET request for the opening handshake of a web socket session.
    ServerEndpointConfig
    The ServerEndpointConfig is a special kind of endpoint configuration object that contains web socket configuration information specific only to server endpoints.
    ServerEndpointConfig.Builder
    The ServerEndpointConfig.Builder is a class used for creating ServerEndpointConfig.Builder objects for the purposes of deploying a server endpoint.
    ServerEndpointConfig.Configurator
    The ServerEndpointConfig.Configurator class may be extended by developers who want to provide custom configuration algorithms, such as intercepting the opening handshake, or providing arbitrary methods and algorithms that can be accessed from each endpoint instance configured with this configurator.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.server.PathParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.server.PathParam

No usage of javax.websocket.server.PathParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.server.ServerEndpoint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.server.ServerEndpoint

No usage of javax.websocket.server.ServerEndpoint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.server.ServerEndpointConfig.Builder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.server.ServerEndpointConfig.Builder

  • Packages that use ServerEndpointConfig.Builder
    Package Description
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of ServerEndpointConfig.Builder in javax.websocket.server

      Methods in javax.websocket.server that return ServerEndpointConfig.Builder
      Modifier and Type Method and Description
      ServerEndpointConfig.Builder ServerEndpointConfig.Builder.configurator(ServerEndpointConfig.Configurator serverEndpointConfigurator)
      Sets the custom configurator to use on the configuration object built by this builder.
      static ServerEndpointConfig.Builder ServerEndpointConfig.Builder.create(Class<?> endpointClass, String path)
      Creates the builder with the mandatory information of the endpoint class (programmatic or annotated), the relative URI or URI-template to use, and with no subprotocols, extensions, encoders, decoders or custom configurator.
      ServerEndpointConfig.Builder ServerEndpointConfig.Builder.decoders(List<Class<? extends Decoder>> decoders)
      Sets the decoder implementation classes to use in the configuration.
      ServerEndpointConfig.Builder ServerEndpointConfig.Builder.encoders(List<Class<? extends Encoder>> encoders)
      Sets the list of encoder implementation classes for this builder.
      ServerEndpointConfig.Builder ServerEndpointConfig.Builder.extensions(List<Extension> extensions)
      Sets the extensions to use in the configuration.
      ServerEndpointConfig.Builder ServerEndpointConfig.Builder.subprotocols(List<String> subprotocols)
      Sets the subprotocols to use in the configuration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.websocket.server.ServerEndpointConfig.Configurator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.websocket.server.ServerEndpointConfig.Configurator

  • Packages that use ServerEndpointConfig.Configurator
    Package Description
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of ServerEndpointConfig.Configurator in javax.websocket.server

      Methods in javax.websocket.server that return ServerEndpointConfig.Configurator
      Modifier and Type Method and Description
      ServerEndpointConfig.Configurator ServerEndpointConfig.getConfigurator()
      Return the ServerEndpointConfig.Configurator this configuration is using.
      Methods in javax.websocket.server with parameters of type ServerEndpointConfig.Configurator
      Modifier and Type Method and Description
      ServerEndpointConfig.Builder ServerEndpointConfig.Builder.configurator(ServerEndpointConfig.Configurator serverEndpointConfigurator)
      Sets the custom configurator to use on the configuration object built by this builder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.server.HandshakeRequest (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.server.HandshakeRequest

  • Packages that use HandshakeRequest
    Package Description
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of HandshakeRequest in javax.websocket.server

      Methods in javax.websocket.server with parameters of type HandshakeRequest
      Modifier and Type Method and Description
      void ServerEndpointConfig.Configurator.modifyHandshake(ServerEndpointConfig sec, HandshakeRequest request, HandshakeResponse response)
      Called by the container after it has formulated a handshake response resulting from a well-formed handshake request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.server.ServerApplicationConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.server.ServerApplicationConfig

No usage of javax.websocket.server.ServerApplicationConfig
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.server.ServerContainer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.server.ServerContainer

No usage of javax.websocket.server.ServerContainer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.websocket.server.ServerEndpointConfig (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.websocket.server.ServerEndpointConfig

  • Packages that use ServerEndpointConfig
    Package Description
    javax.websocket.server
    This package contains all the WebSocket APIs used only by server side applications.

    • Uses of ServerEndpointConfig in javax.websocket.server

      Methods in javax.websocket.server that return ServerEndpointConfig
      Modifier and Type Method and Description
      ServerEndpointConfig ServerEndpointConfig.Builder.build()
      Builds the configuration object using the current attributes that have been set on this builder object.
      Methods in javax.websocket.server that return types with arguments of type ServerEndpointConfig
      Modifier and Type Method and Description
      Set<ServerEndpointConfig> ServerApplicationConfig.getEndpointConfigs(Set<Class<? extends Endpoint>> endpointClasses)
      Return a set of ServerEndpointConfig instances that the server container will use to deploy the programmatic endpoints.
      Methods in javax.websocket.server with parameters of type ServerEndpointConfig
      Modifier and Type | Method and Description
      void | ServerContainer.addEndpoint(ServerEndpointConfig serverConfig)
      void ServerEndpointConfig.Configurator.modifyHandshake(ServerEndpointConfig sec, HandshakeRequest request, HandshakeResponse response)
      Called by the container after it has formulated a handshake response resulting from a well-formed handshake request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ApplicationPath (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type ApplicationPath

  • @Documented
@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface ApplicationPath
    Identifies the application path that serves as the base URI for all resource URIs provided by Path. May only be applied to a subclass of Application.

    When published in a Servlet container, the value of the application path may be overridden using a servlet-mapping element in the web.xml.

    Since:
    1.1
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Application, Path

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Defines the base URI for all resource URIs.

    • Element Detail

      • value

        public abstract String value
        Defines the base URI for all resource URIs. A trailing '/' character will be automatically appended if one is not present.

        The supplied value is automatically percent encoded to conform to the path production of RFC 3986 section 3.3. Note that percent encoded values are allowed in the value, an implementation will recognize such values and will not double encode the '%' character.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


BadRequestException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class BadRequestException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ClientErrorException
              • javax.ws.rs.BadRequestException
  • All Implemented Interfaces:
    Serializable

    public class BadRequestException
extends ClientErrorException
    A runtime exception indicating a bad client request.
    Since:
    2.0
    Author:
    Sergey Beryozkin, Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      BadRequestException()
      Construct a new bad client request exception.
      BadRequestException(Response response)
      Construct a new bad client request exception.
      BadRequestException(Response response, Throwable cause)
      Construct a new bad client request exception.
      BadRequestException(String message)
      Construct a new bad client request exception.
      BadRequestException(String message, Response response)
      Construct a new bad client request exception.
      BadRequestException(String message, Response response, Throwable cause)
      Construct a new bad client request exception.
      BadRequestException(String message, Throwable cause)
      Construct a new bad client request exception.
      BadRequestException(Throwable cause)
      Construct a new bad client request exception.

    • Method Summary

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BadRequestException

        public BadRequestException()
        Construct a new bad client request exception.

      • BadRequestException

        public BadRequestException(String message)
        Construct a new bad client request exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • BadRequestException

        public BadRequestException(Response response)
        Construct a new bad client request exception.
        Parameters:
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 400.

      • BadRequestException

        public BadRequestException(String message,
                   Response response)
        Construct a new bad client request exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 400.

      • BadRequestException

        public BadRequestException(Throwable cause)
        Construct a new bad client request exception.
        Parameters:
        cause - the underlying cause of the exception.

      • BadRequestException

        public BadRequestException(String message,
                   Throwable cause)
        Construct a new bad client request exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the underlying cause of the exception.

      • BadRequestException

        public BadRequestException(Response response,
                   Throwable cause)
        Construct a new bad client request exception.
        Parameters:
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 400.

      • BadRequestException

        public BadRequestException(String message,
                   Response response,
                   Throwable cause)
        Construct a new bad client request exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 400.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BeanParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type BeanParam

  • @Target(value={PARAMETER,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface BeanParam
    The annotation that may be used to inject custom JAX-RS "parameter aggregator" value object into a resource class field, property or resource method parameter.

    The JAX-RS runtime will instantiate the object and inject all it's fields and properties annotated with either one of the @XxxParam annotation (@PathParam, @FormParam ...) or the @Context annotation. For the POJO classes same instantiation and injection rules apply as in case of instantiation and injection of request-scoped root resource classes.

    For example:

     public class MyBean {
   @FormParam("myData")
   private String data;

   @HeaderParam("myHeader")
   private String header;

   @PathParam("id")
   public void setResourceId(String id) {...}

   ...
 }

 @Path("myresources")
 public class MyResources {
   @POST
   @Path("{id}")
   public void post(@BeanParam MyBean myBean) {...}

   ...
 }

    Because injection occurs at object creation time, use of this annotation on resource class fields and bean properties is only supported for the default per-request resource class lifecycle. Resource classes using other lifecycles should only use this annotation on resource method parameters.

    Since:
    2.0
    Author:
    Marek Potociar
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ClientErrorException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class ClientErrorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ClientErrorException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    BadRequestException, ForbiddenException, NotAcceptableException, NotAllowedException, NotAuthorizedException, NotFoundException, NotSupportedException

    public class ClientErrorException
extends WebApplicationException
    A base runtime application exception indicating a client request error (HTTP 4xx status codes).
    Since:
    2.0
    Author:
    Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ClientErrorException(int status)
      Construct a new client error exception.
      ClientErrorException(int status, Throwable cause)
      Construct a new client error exception.
      ClientErrorException(Response.Status status)
      Construct a new client error exception.
      ClientErrorException(Response.Status status, Throwable cause)
      Construct a new client error exception.
      ClientErrorException(Response response)
      Construct a new client error exception.
      ClientErrorException(Response response, Throwable cause)
      Construct a new client error exception.
      ClientErrorException(String message, int status)
      Construct a new client error exception.
      ClientErrorException(String message, int status, Throwable cause)
      Construct a new client error exception.
      ClientErrorException(String message, Response.Status status)
      Construct a new client error exception.
      ClientErrorException(String message, Response.Status status, Throwable cause)
      Construct a new client error exception.
      ClientErrorException(String message, Response response)
      Construct a new client error exception.
      ClientErrorException(String message, Response response, Throwable cause)
      Construct a new client error exception.

    • Method Summary

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ClientErrorException

        public ClientErrorException(Response.Status status)
        Construct a new client error exception.
        Parameters:
        status - client error status. Must be a 4xx status code.
        Throws:
        IllegalArgumentException - in case the status code is null or is not from Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(String message,
                    Response.Status status)
        Construct a new client error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - client error status. Must be a 4xx status code.
        Throws:
        IllegalArgumentException - in case the status code is null or is not from Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(int status)
        Construct a new client error exception.
        Parameters:
        status - client error status. Must be a 4xx status code.
        Throws:
        IllegalArgumentException - in case the status code is not a valid HTTP status code or if it is not from the Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(String message,
                    int status)
        Construct a new client error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - client error status. Must be a 4xx status code.
        Throws:
        IllegalArgumentException - in case the status code is not a valid HTTP status code or if it is not from the Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(Response response)
        Construct a new client error exception.
        Parameters:
        response - client error response. Must have a status code set to a 4xx status code.
        Throws:
        IllegalArgumentException - in case the response status code is not from the Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(String message,
                    Response response)
        Construct a new client error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - client error response. Must have a status code set to a 4xx status code.
        Throws:
        IllegalArgumentException - in case the response status code is not from the Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(Response.Status status,
                    Throwable cause)
        Construct a new client error exception.
        Parameters:
        status - client error status. Must be a 4xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code is null or is not from Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(String message,
                    Response.Status status,
                    Throwable cause)
        Construct a new client error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - client error status. Must be a 4xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code is null or is not from Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(int status,
                    Throwable cause)
        Construct a new client error exception.
        Parameters:
        status - client error status. Must be a 4xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code is not a valid HTTP status code or if it is not from the Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(String message,
                    int status,
                    Throwable cause)
        Construct a new client error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - client error status. Must be a 4xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code is not a valid HTTP status code or if it is not from the Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(Response response,
                    Throwable cause)
        Construct a new client error exception.
        Parameters:
        response - client error response. Must have a status code set to a 4xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the response status code is not from the Response.Status.Family.CLIENT_ERROR status code family.

      • ClientErrorException

        public ClientErrorException(String message,
                    Response response,
                    Throwable cause)
        Construct a new client error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - client error response. Must have a status code set to a 4xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the response status code is not from the Response.Status.Family.CLIENT_ERROR status code family.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConstrainedTo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type ConstrainedTo

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface ConstrainedTo
    Indicates the run-time context in which an annotated JAX-RS provider is applicable. If a @ConstrainedTo annotation is not present on a JAX-RS provider type declaration, the declared provider may be used in any run-time context. If such a annotation is present, the JAX-RS runtime will enforce the specified usage restriction.

    The following example illustrates restricting a MessageBodyReader provider implementation to run only as part of a JAX-RS client run-time:

      @ConstrainedTo(RuntimeType.CLIENT)
  public class MyReader implements MessageBodyReader {
      ...
  }

    The following example illustrates restricting a WriterInterceptor provider implementation to run only as part of a JAX-RS server run-time:

      @ConstrainedTo(RuntimeType.SERVER)
  public class MyWriterInterceptor implements WriterInterceptor {
      ...
  }

    It is a configuration error to constraint a JAX-RS provider implementation to a run-time context in which the provider cannot be applied. In such case a JAX-RS runtime SHOULD inform a user about the issue and ignore the provider implementation in further processing.

    For example, the following restriction of a ClientRequestFilter to run only as part of a JAX-RS server run-time would be considered invalid:

      // reported as invalid and ignored by JAX-RS runtime
  @ConstrainedTo(RuntimeType.SERVER)
  public class MyFilter implements ClientRequestFilter {
      ...
  }
    Since:
    2.0
    Author:
    Marek Potociar

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      RuntimeType value
      Define the constraint type to be placed on a JAX-RS provider.

    • Element Detail

      • value

        public abstract RuntimeType value
        Define the constraint type to be placed on a JAX-RS provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Consumes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type Consumes

  • @Inherited
@Target(value={TYPE,METHOD})
@Retention(value=RUNTIME)
@Documented
public @interface Consumes
    Defines the media types that the methods of a resource class or MessageBodyReader can accept. If not specified, a container will assume that any media type is acceptable. Method level annotations override a class level annotation. A container is responsible for ensuring that the method invoked is capable of consuming the media type of the HTTP request entity body. If no such method is available the container must respond with a HTTP "415 Unsupported Media Type" as specified by RFC 2616.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    MessageBodyReader

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String[] value
      A list of media types.

    • Element Detail

      • value

        public abstract String[] value
        A list of media types. Each entry may specify a single type or consist of a comma separated list of types, with any leading or trailing white-spaces in a single type entry being ignored. For example:
          {"image/jpeg, image/gif ", " image/png"}
        Use of the comma-separated form allows definition of a common string constant for use on multiple targets.
        Default:
        "*/*"
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


CookieParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type CookieParam

  • @Target(value={PARAMETER,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface CookieParam
    Binds the value of a HTTP cookie to a resource method parameter, resource class field, or resource class bean property. A default value can be specified using the DefaultValue annotation. The type T of the annotated parameter, field or property must either:
    1. Be a primitive type
    2. Be Cookie
    3. Have a constructor that accepts a single String argument
    4. Have a static method named valueOf or fromString that accepts a single String argument (see, for example, Integer.valueOf(String))
    5. Have a registered implementation of ParamConverterProvider JAX-RS extension SPI that returns a ParamConverter instance capable of a "from string" conversion for the type.
    6. Be List<T>, Set<T> or SortedSet<T>, where T satisfies 2, 3, 4 or 5 above. The resulting collection is read-only.

    Because injection occurs at object creation time, use of this annotation on resource class fields and bean properties is only supported for the default per-request resource class lifecycle. Resource classes using other lifecycles should only use this annotation on resource method parameters.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    DefaultValue, Cookie, HttpHeaders.getCookies()

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Defines the name of the HTTP cookie whose value will be used to initialize the value of the annotated method argument, class field or bean property.

    • Element Detail

      • value

        public abstract String value
        Defines the name of the HTTP cookie whose value will be used to initialize the value of the annotated method argument, class field or bean property.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DefaultValue (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type DefaultValue

  • @Target(value={PARAMETER,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface DefaultValue
    Defines the default value of request meta-data that is bound using one of the following annotations: PathParam, QueryParam, MatrixParam, CookieParam, FormParam, or HeaderParam. The default value is used if the corresponding meta-data is not present in the request.

    If the type of the annotated parameter is List, Set or SortedSet then the resulting collection will have a single entry mapped from the supplied default value.

    If this annotation is not used and the corresponding meta-data is not present in the request, the value will be an empty collection for List, Set or SortedSet, null for other object types, and the Java-defined default for primitive types.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    PathParam, QueryParam, FormParam, HeaderParam, MatrixParam, CookieParam

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      The specified default value.

    • Element Detail

      • value

        public abstract String value
        The specified default value.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


DELETE (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type DELETE

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
@HttpMethod(value="DELETE")
@Documented
public @interface DELETE
    Indicates that the annotated method responds to HTTP DELETE requests.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    HttpMethod
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Encoded (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type Encoded

  • @Target(value={PARAMETER,METHOD,FIELD,CONSTRUCTOR,TYPE})
@Retention(value=RUNTIME)
@Documented
public @interface Encoded
    Disables automatic decoding of parameter values bound using QueryParam, PathParam, FormParam or MatrixParam. Using this annotation on a method will disable decoding for all parameters. Using this annotation on a class will disable decoding for all parameters of all methods.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    QueryParam, MatrixParam, PathParam, FormParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ForbiddenException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class ForbiddenException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ClientErrorException
              • javax.ws.rs.ForbiddenException
  • All Implemented Interfaces:
    Serializable

    public class ForbiddenException
extends ClientErrorException
    A runtime exception indicating that an access to a resource requested by a client has been forbidden by the server.
    Since:
    2.0
    Author:
    Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ForbiddenException()
      Construct a new "forbidden" exception.
      ForbiddenException(Response response)
      Construct a new "forbidden" exception.
      ForbiddenException(Response response, Throwable cause)
      Construct a new "forbidden" exception.
      ForbiddenException(String message)
      Construct a new "forbidden" exception.
      ForbiddenException(String message, Response response)
      Construct a new "forbidden" exception.
      ForbiddenException(String message, Response response, Throwable cause)
      Construct a new "forbidden" exception.
      ForbiddenException(String message, Throwable cause)
      Construct a new "forbidden" exception.
      ForbiddenException(Throwable cause)
      Construct a new "forbidden" exception.

    • Method Summary

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ForbiddenException

        public ForbiddenException()
        Construct a new "forbidden" exception.

      • ForbiddenException

        public ForbiddenException(String message)
        Construct a new "forbidden" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • ForbiddenException

        public ForbiddenException(Response response)
        Construct a new "forbidden" exception.
        Parameters:
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 403.

      • ForbiddenException

        public ForbiddenException(String message,
                  Response response)
        Construct a new "forbidden" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 403.

      • ForbiddenException

        public ForbiddenException(Throwable cause)
        Construct a new "forbidden" exception.
        Parameters:
        cause - the underlying cause of the exception.

      • ForbiddenException

        public ForbiddenException(String message,
                  Throwable cause)
        Construct a new "forbidden" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the underlying cause of the exception.

      • ForbiddenException

        public ForbiddenException(Response response,
                  Throwable cause)
        Construct a new "forbidden" exception.
        Parameters:
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 403.

      • ForbiddenException

        public ForbiddenException(String message,
                  Response response,
                  Throwable cause)
        Construct a new "forbidden" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 403.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FormParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type FormParam

  • @Target(value={PARAMETER,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface FormParam
    Binds the value(s) of a form parameter contained within a request entity body to a resource method parameter. Values are URL decoded unless this is disabled using the Encoded annotation. A default value can be specified using the DefaultValue annotation. If the request entity body is absent or is an unsupported media type, the default value is used. The type T of the annotated parameter must either:
    1. Be a primitive type
    2. Have a constructor that accepts a single String argument
    3. Have a static method named valueOf or fromString that accepts a single
    4. Have a registered implementation of ParamConverterProvider JAX-RS extension SPI that returns a ParamConverter instance capable of a "from string" conversion for the type.
      5. String argument (see, for example, Integer.valueOf(String))
    5. Be List<T>, Set<T> or SortedSet<T>, where T satisfies 2, 3 or 4 above. The resulting collection is read-only.

    If the type is not one of the collection types listed in 5 above and the form parameter is represented by multiple values then the first value (lexically) of the parameter is used.

    Note that, whilst the annotation target permits use on fields and methods, this annotation is only required to be supported on resource method parameters.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    DefaultValue, Encoded

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Defines the name of the form parameter whose value will be used to initialize the value of the annotated method argument.

    • Element Detail

      • value

        public abstract String value
        Defines the name of the form parameter whose value will be used to initialize the value of the annotated method argument. The name is specified in decoded form, any percent encoded literals within the value will not be decoded and will instead be treated as literal text. E.g. if the parameter name is "a b" then the value of the annotation is "a b", not "a+b" or "a%20b".
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


GET (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type GET

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
@HttpMethod(value="GET")
@Documented
public @interface GET
    Indicates that the annotated method responds to HTTP GET requests.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    HttpMethod
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


HEAD (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type HEAD

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
@HttpMethod(value="HEAD")
@Documented
public @interface HEAD
    Indicates that the annotated method responds to HTTP HEAD requests.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    HttpMethod
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


HeaderParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type HeaderParam

  • @Target(value={PARAMETER,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface HeaderParam
    Binds the value(s) of a HTTP header to a resource method parameter, resource class field, or resource class bean property. A default value can be specified using the DefaultValue annotation. The type T of the annotated parameter, field or property must either:
    1. Be a primitive type
    2. Have a constructor that accepts a single String argument
    3. Have a static method named valueOf or fromString that accepts a single String argument (see, for example, Integer.valueOf(String))
    4. Have a registered implementation of ParamConverterProvider JAX-RS extension SPI that returns a ParamConverter instance capable of a "from string" conversion for the type.
    5. Be List<T>, Set<T> or SortedSet<T>, where T satisfies 2, 3 or 4 above. The resulting collection is read-only.

    If the type is not one of the collection types listed in 5 above and the header parameter is represented by multiple values then the first value (lexically) of the parameter is used.

    Because injection occurs at object creation time, use of this annotation on resource class fields and bean properties is only supported for the default per-request resource class lifecycle. Resource classes using other lifecycles should only use this annotation on resource method parameters.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    DefaultValue, HttpHeaders

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Defines the name of the HTTP header whose value will be used to initialize the value of the annotated method argument, class field or bean property.

    • Element Detail

      • value

        public abstract String value
        Defines the name of the HTTP header whose value will be used to initialize the value of the annotated method argument, class field or bean property. Case insensitive.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


HttpMethod (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type HttpMethod

  • @Target(value=ANNOTATION_TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface HttpMethod
    Associates the name of a HTTP method with an annotation. A Java method annotated with a runtime annotation that is itself annotated with this annotation will be used to handle HTTP requests of the indicated HTTP method. It is an error for a method to be annotated with more than one annotation that is annotated with HttpMethod.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    GET, POST, PUT, DELETE, HEAD

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Specifies the name of a HTTP method.

    • Element Detail

      • value

        public abstract String value
        Specifies the name of a HTTP method. E.g. "GET".
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


InternalServerErrorException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class InternalServerErrorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ServerErrorException
              • javax.ws.rs.InternalServerErrorException
  • All Implemented Interfaces:
    Serializable

    public class InternalServerErrorException
extends ServerErrorException
    A runtime exception indicating an internal server error.
    Since:
    2.0
    Author:
    Sergey Beryozkin, Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      InternalServerErrorException()
      Construct a new internal server error exception.
      InternalServerErrorException(Response response)
      Construct a new internal server error exception.
      InternalServerErrorException(Response response, Throwable cause)
      Construct a new internal server error exception.
      InternalServerErrorException(String message)
      Construct a new internal server error exception.
      InternalServerErrorException(String message, Response response)
      Construct a new internal server error exception.
      InternalServerErrorException(String message, Response response, Throwable cause)
      Construct a new internal server error exception.
      InternalServerErrorException(String message, Throwable cause)
      Construct a new internal server error exception.
      InternalServerErrorException(Throwable cause)
      Construct a new internal server error exception.

    • Method Summary

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InternalServerErrorException

        public InternalServerErrorException()
        Construct a new internal server error exception.

      • InternalServerErrorException

        public InternalServerErrorException(String message)
        Construct a new internal server error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • InternalServerErrorException

        public InternalServerErrorException(Response response)
        Construct a new internal server error exception.
        Parameters:
        response - internal server error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 500.

      • InternalServerErrorException

        public InternalServerErrorException(String message,
                            Response response)
        Construct a new internal server error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - internal server error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 500.

      • InternalServerErrorException

        public InternalServerErrorException(Throwable cause)
        Construct a new internal server error exception.
        Parameters:
        cause - the underlying cause of the exception.

      • InternalServerErrorException

        public InternalServerErrorException(String message,
                            Throwable cause)
        Construct a new internal server error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the underlying cause of the exception.

      • InternalServerErrorException

        public InternalServerErrorException(Response response,
                            Throwable cause)
        Construct a new internal server error exception.
        Parameters:
        response - internal server error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 500.

      • InternalServerErrorException

        public InternalServerErrorException(String message,
                            Response response,
                            Throwable cause)
        Construct a new internal server error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - internal server error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 500.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.ws.rs (Java(TM) EE 7 Specification APIs)

javax.ws.rs

Classes

  • Priorities

Enums

  • RuntimeType

Exceptions

  • BadRequestException
  • ClientErrorException
  • ForbiddenException
  • InternalServerErrorException
  • NotAcceptableException
  • NotAllowedException
  • NotAuthorizedException
  • NotFoundException
  • NotSupportedException
  • ProcessingException
  • RedirectionException
  • ServerErrorException
  • ServiceUnavailableException
  • WebApplicationException

Annotation Types

  • ApplicationPath
  • BeanParam
  • ConstrainedTo
  • Consumes
  • CookieParam
  • DefaultValue
  • DELETE
  • Encoded
  • FormParam
  • GET
  • HEAD
  • HeaderParam
  • HttpMethod
  • MatrixParam
  • NameBinding
  • OPTIONS
  • Path
  • PathParam
  • POST
  • Produces
  • PUT
  • QueryParam


javax.ws.rs (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.ws.rs

High-level interfaces and annotations used to create RESTful service resources.

See: Description

  • Class Summary
    Class Description
    Priorities
    A collection of built-in priority constants for the JAX-RS components that are supposed to be ordered based on their javax.annotation.Priority class-level annotation value when used or applied by JAX-RS runtime.
  • Enum Summary
    Enum Description
    RuntimeType
    Enumeration of JAX-RS runtime types.
  • Exception Summary
    Exception Description
    BadRequestException
    A runtime exception indicating a bad client request.
    ClientErrorException
    A base runtime application exception indicating a client request error (HTTP 4xx status codes).
    ForbiddenException
    A runtime exception indicating that an access to a resource requested by a client has been forbidden by the server.
    InternalServerErrorException
    A runtime exception indicating an internal server error.
    NotAcceptableException
    A runtime exception indicating that a client request is not acceptable by the server.
    NotAllowedException
    A runtime exception indicating a client requesting a resource method that is not allowed.
    NotAuthorizedException
    A runtime exception indicating request authorization failure caused by one of the following scenarios: a client did not send the required authorization credentials to access the requested resource, i.e.
    NotFoundException
    A runtime exception indicating a resource requested by a client was not found on the server.
    NotSupportedException
    A runtime exception indicating that the client request entity media type is not supported.
    ProcessingException
    A base JAX-RS runtime processing exception.
    RedirectionException
    A runtime application exception indicating a request redirection (HTTP 3xx status codes).
    ServerErrorException
    A base runtime application exception indicating a server error (HTTP 5xx status codes).
    ServiceUnavailableException
    A runtime exception indicating that the requested resource cannot be served.
    WebApplicationException
    Runtime exception for applications.
  • Annotation Types Summary
    Annotation Type Description
    ApplicationPath
    Identifies the application path that serves as the base URI for all resource URIs provided by Path.
    BeanParam
    The annotation that may be used to inject custom JAX-RS "parameter aggregator" value object into a resource class field, property or resource method parameter.
    ConstrainedTo
    Indicates the run-time context in which an annotated JAX-RS provider is applicable.
    Consumes
    Defines the media types that the methods of a resource class or MessageBodyReader can accept.
    CookieParam
    Binds the value of a HTTP cookie to a resource method parameter, resource class field, or resource class bean property.
    DefaultValue
    Defines the default value of request meta-data that is bound using one of the following annotations: PathParam, QueryParam, MatrixParam, CookieParam, FormParam, or HeaderParam.
    DELETE
    Indicates that the annotated method responds to HTTP DELETE requests.
    Encoded
    Disables automatic decoding of parameter values bound using QueryParam, PathParam, FormParam or MatrixParam.
    FormParam
    Binds the value(s) of a form parameter contained within a request entity body to a resource method parameter.
    GET
    Indicates that the annotated method responds to HTTP GET requests.
    HEAD
    Indicates that the annotated method responds to HTTP HEAD requests.
    HeaderParam
    Binds the value(s) of a HTTP header to a resource method parameter, resource class field, or resource class bean property.
    HttpMethod
    Associates the name of a HTTP method with an annotation.
    MatrixParam
    Binds the value(s) of a URI matrix parameter to a resource method parameter, resource class field, or resource class bean property.
    NameBinding
    Meta-annotation used to create name binding annotations for filters and interceptors.
    OPTIONS
    Indicates that the annotated method responds to HTTP OPTIONS requests.
    Path
    Identifies the URI path that a resource class or class method will serve requests for.
    PathParam
    Binds the value of a URI template parameter or a path segment containing the template parameter to a resource method parameter, resource class field, or resource class bean property.
    POST
    Indicates that the annotated method responds to HTTP POST requests.
    Produces
    Defines the media type(s) that the methods of a resource class or MessageBodyWriter can produce.
    PUT
    Indicates that the annotated method responds to HTTP PUT requests.
    QueryParam
    Binds the value(s) of a HTTP query parameter to a resource method parameter, resource class field, or resource class bean property.

Package javax.ws.rs Description

High-level interfaces and annotations used to create RESTful service resources. For example:
 @Path("widgets/{widgetid}")
 @Consumes("application/widgets+xml")
 @Produces("application/widgets+xml")
 public class WidgetResource {

     @GET
     public String getWidget(@PathParam("widgetid") String id) {
         return getWidgetAsXml(id);
     }

     @PUT
     public void updateWidget(@PathParam("widgetid") String id,
                              Source update) {
         updateWidgetFromXml(id, update);
     }

     ...
 }
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.ws.rs Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.ws.rs

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.ws.rs.Priorities
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.ProcessingException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ClientErrorException
              • javax.ws.rs.BadRequestException
              • javax.ws.rs.ForbiddenException
              • javax.ws.rs.NotAcceptableException
              • javax.ws.rs.NotAllowedException
              • javax.ws.rs.NotAuthorizedException
              • javax.ws.rs.NotFoundException
              • javax.ws.rs.NotSupportedException
            • javax.ws.rs.RedirectionException
            • javax.ws.rs.ServerErrorException
              • javax.ws.rs.InternalServerErrorException
              • javax.ws.rs.ServiceUnavailableException

Annotation Type Hierarchy

  • javax.ws.rs.QueryParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.PUT (implements java.lang.annotation.Annotation)
  • javax.ws.rs.Produces (implements java.lang.annotation.Annotation)
  • javax.ws.rs.POST (implements java.lang.annotation.Annotation)
  • javax.ws.rs.PathParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.Path (implements java.lang.annotation.Annotation)
  • javax.ws.rs.OPTIONS (implements java.lang.annotation.Annotation)
  • javax.ws.rs.NameBinding (implements java.lang.annotation.Annotation)
  • javax.ws.rs.MatrixParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.HttpMethod (implements java.lang.annotation.Annotation)
  • javax.ws.rs.HeaderParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.HEAD (implements java.lang.annotation.Annotation)
  • javax.ws.rs.GET (implements java.lang.annotation.Annotation)
  • javax.ws.rs.FormParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.Encoded (implements java.lang.annotation.Annotation)
  • javax.ws.rs.DELETE (implements java.lang.annotation.Annotation)
  • javax.ws.rs.DefaultValue (implements java.lang.annotation.Annotation)
  • javax.ws.rs.CookieParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.Consumes (implements java.lang.annotation.Annotation)
  • javax.ws.rs.ConstrainedTo (implements java.lang.annotation.Annotation)
  • javax.ws.rs.BeanParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.ApplicationPath (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.ws.rs.RuntimeType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MatrixParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type MatrixParam

  • @Target(value={PARAMETER,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface MatrixParam
    Binds the value(s) of a URI matrix parameter to a resource method parameter, resource class field, or resource class bean property. Values are URL decoded unless this is disabled using the Encoded annotation. A default value can be specified using the DefaultValue annotation.

    Note that the @MatrixParam annotation value refers to a name of a matrix parameter that resides in the last matched path segment of the Path-annotated Java structure that injects the value of the matrix parameter.

    The type T of the annotated parameter, field or property must either:

    1. Be a primitive type
    2. Have a constructor that accepts a single String argument
    3. Have a static method named valueOf or fromString that accepts a single String argument (see, for example, Integer.valueOf(String))
    4. Have a registered implementation of ParamConverterProvider JAX-RS extension SPI that returns a ParamConverter instance capable of a "from string" conversion for the type.
    5. Be List<T>, Set<T> or SortedSet<T>, where T satisfies 2, 3 or 4 above. The resulting collection is read-only.

    If the type is not one of the collection types listed in 5 above and the matrix parameter is represented by multiple values then the first value (lexically) of the parameter is used.

    Because injection occurs at object creation time, use of this annotation on resource class fields and bean properties is only supported for the default per-request resource class lifecycle. Resource classes using other lifecycles should only use this annotation on resource method parameters.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    DefaultValue, Encoded, Matrix URIs

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Defines the name of the URI matrix parameter whose value will be used to initialize the value of the annotated method argument, class field or bean property.

    • Element Detail

      • value

        public abstract String value
        Defines the name of the URI matrix parameter whose value will be used to initialize the value of the annotated method argument, class field or bean property. The name is specified in decoded form, any percent encoded literals within the value will not be decoded and will instead be treated as literal text. E.g. if the parameter name is "a b" then the value of the annotation is "a b", not "a+b" or "a%20b".
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NameBinding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type NameBinding

  • @Target(value=ANNOTATION_TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface NameBinding
    Meta-annotation used to create name binding annotations for filters and interceptors.

    Name binding via annotations is only supported as part of the Server API. In name binding, a name-binding annotation is first defined using the @NameBinding meta-annotation:

      @Target({ ElementType.TYPE, ElementType.METHOD })
  @Retention(value = RetentionPolicy.RUNTIME)
  @NameBinding
  public @interface Logged { }
    The defined name-binding annotation is then used to decorate a filter or interceptor class (more than one filter or interceptor may be decorated with the same name-binding annotation):
      @Logged
  public class LoggingFilter
          implements ContainerRequestFilter, ContainerResponseFilter {
      ...
  }
    At last, the name-binding annotation is applied to the resource method(s) to which the name-bound JAX-RS provider(s) should be bound to:
      @Path("/")
  public class MyResourceClass {
      @GET
      @Produces("text/plain")
      @Path("{name}")
      @Logged
      public String hello(@PathParam("name") String name) {
          return "Hello " + name;
      }
  }
    A name-binding annotation may also be attached to a custom JAX-RS Application subclass. In such case a name-bound JAX-RS provider bound by the annotation will be applied to all resource and sub-resource methods in the JAX-RS application:
      @Logged
  @ApplicationPath("myApp")
  public class MyApplication extends javax.ws.rs.core.Application {
      ...
  }

    Since:
    2.0
    Author:
    Santiago Pericas-Geertsen, Marek Potociar
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


NotAcceptableException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class NotAcceptableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ClientErrorException
              • javax.ws.rs.NotAcceptableException
  • All Implemented Interfaces:
    Serializable

    public class NotAcceptableException
extends ClientErrorException
    A runtime exception indicating that a client request is not acceptable by the server.
    Since:
    2.0
    Author:
    Sergey Beryozkin, Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NotAcceptableException()
      Construct a new "request not acceptable" exception.
      NotAcceptableException(Response response)
      Construct a new "request not acceptable" exception.
      NotAcceptableException(Response response, Throwable cause)
      Construct a new "request not acceptable" exception.
      NotAcceptableException(String message)
      Construct a new "request not acceptable" exception.
      NotAcceptableException(String message, Response response)
      Construct a new "request not acceptable" exception.
      NotAcceptableException(String message, Response response, Throwable cause)
      Construct a new "request not acceptable" exception.
      NotAcceptableException(String message, Throwable cause)
      Construct a new "request not acceptable" exception.
      NotAcceptableException(Throwable cause)
      Construct a new "request not acceptable" exception.

    • Method Summary

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NotAcceptableException

        public NotAcceptableException()
        Construct a new "request not acceptable" exception.

      • NotAcceptableException

        public NotAcceptableException(String message)
        Construct a new "request not acceptable" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • NotAcceptableException

        public NotAcceptableException(Response response)
        Construct a new "request not acceptable" exception.
        Parameters:
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 406.

      • NotAcceptableException

        public NotAcceptableException(String message,
                      Response response)
        Construct a new "request not acceptable" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 406.

      • NotAcceptableException

        public NotAcceptableException(Throwable cause)
        Construct a new "request not acceptable" exception.
        Parameters:
        cause - the underlying cause of the exception.

      • NotAcceptableException

        public NotAcceptableException(String message,
                      Throwable cause)
        Construct a new "request not acceptable" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the underlying cause of the exception.

      • NotAcceptableException

        public NotAcceptableException(Response response,
                      Throwable cause)
        Construct a new "request not acceptable" exception.
        Parameters:
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 406.

      • NotAcceptableException

        public NotAcceptableException(String message,
                      Response response,
                      Throwable cause)
        Construct a new "request not acceptable" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 406.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NotAllowedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class NotAllowedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ClientErrorException
              • javax.ws.rs.NotAllowedException
  • All Implemented Interfaces:
    Serializable

    public class NotAllowedException
extends ClientErrorException
    A runtime exception indicating a client requesting a resource method that is not allowed.
    Since:
    2.0
    Author:
    Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NotAllowedException(Response response)
      Construct a new method not allowed exception.
      NotAllowedException(Response response, Throwable cause)
      Construct a new method not allowed exception.
      NotAllowedException(String message, Response response)
      Construct a new method not allowed exception.
      NotAllowedException(String message, Response response, Throwable cause)
      Construct a new method not allowed exception.
      NotAllowedException(String allowed, String... moreAllowed)
      Construct a new method not allowed exception.
      NotAllowedException(String message, String allowed, String... moreAllowed)
      Construct a new method not allowed exception.
      NotAllowedException(String message, Throwable cause, String... allowedMethods)
      Construct a new method not allowed exception.
      NotAllowedException(Throwable cause, String... allowedMethods)
      Construct a new method not allowed exception.

    • Method Summary

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NotAllowedException

        public NotAllowedException(String allowed,
                   String... moreAllowed)
        Construct a new method not allowed exception.
        Parameters:
        allowed - allowed request method.
        moreAllowed - more allowed request methods.
        Throws:
        NullPointerException - in case the allowed method is null.

      • NotAllowedException

        public NotAllowedException(String message,
                   String allowed,
                   String... moreAllowed)
        Construct a new method not allowed exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        allowed - allowed request method.
        moreAllowed - more allowed request methods.
        Throws:
        NullPointerException - in case the allowed method is null.

      • NotAllowedException

        public NotAllowedException(Response response)
        Construct a new method not allowed exception.

        Note that this constructor does not validate the presence of HTTP Allow header. I.e. it is possible to use the constructor to create a client-side exception instance even for an invalid HTTP 405 response content returned from a server.

        Parameters:
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 405.

      • NotAllowedException

        public NotAllowedException(String message,
                   Response response)
        Construct a new method not allowed exception.

        Note that this constructor does not validate the presence of HTTP Allow header. I.e. it is possible to use the constructor to create a client-side exception instance even for an invalid HTTP 405 response content returned from a server.

        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 405.

      • NotAllowedException

        public NotAllowedException(Throwable cause,
                   String... allowedMethods)
        Construct a new method not allowed exception.
        Parameters:
        cause - the underlying cause of the exception.
        allowedMethods - allowed request methods.
        Throws:
        IllegalArgumentException - in case the allowed methods varargs are null.

      • NotAllowedException

        public NotAllowedException(String message,
                   Throwable cause,
                   String... allowedMethods)
        Construct a new method not allowed exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the underlying cause of the exception.
        allowedMethods - allowed request methods.
        Throws:
        IllegalArgumentException - in case the allowed methods varargs are null.

      • NotAllowedException

        public NotAllowedException(Response response,
                   Throwable cause)
        Construct a new method not allowed exception.
        Parameters:
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 405 or does not contain an HTTP Allow header.

      • NotAllowedException

        public NotAllowedException(String message,
                   Response response,
                   Throwable cause)
        Construct a new method not allowed exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 405 or does not contain an HTTP Allow header.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NotAuthorizedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class NotAuthorizedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ClientErrorException
              • javax.ws.rs.NotAuthorizedException
  • All Implemented Interfaces:
    Serializable

    public class NotAuthorizedException
extends ClientErrorException
    A runtime exception indicating request authorization failure caused by one of the following scenarios:
    • a client did not send the required authorization credentials to access the requested resource, i.e. Authorization HTTP header is missing in the request,
    • or - in case the request already contains the HTTP Authorization header - then the exception indicates that authorization has been refused for the credentials contained in the request header.
    Since:
    2.0
    Author:
    Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NotAuthorizedException(Object challenge, Object... moreChallenges)
      Construct a new "not authorized" exception.
      NotAuthorizedException(Response response)
      Construct a new "not authorized" exception.
      NotAuthorizedException(Response response, Throwable cause)
      Construct a new "not authorized" exception.
      NotAuthorizedException(String message, Object challenge, Object... moreChallenges)
      Construct a new "not authorized" exception.
      NotAuthorizedException(String message, Response response)
      Construct a new "not authorized" exception.
      NotAuthorizedException(String message, Response response, Throwable cause)
      Construct a new "not authorized" exception.
      NotAuthorizedException(String message, Throwable cause, Object challenge, Object... moreChallenges)
      Construct a new "not authorized" exception.
      NotAuthorizedException(Throwable cause, Object challenge, Object... moreChallenges)
      Construct a new "not authorized" exception.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<Object> getChallenges()
      Get the list of authorization challenges associated with the exception and applicable to the resource requested by the client.

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NotAuthorizedException

        public NotAuthorizedException(Object challenge,
                      Object... moreChallenges)
        Construct a new "not authorized" exception.
        Parameters:
        challenge - authorization challenge applicable to the resource requested by the client.
        moreChallenges - additional authorization challenge applicable to the requested resource.
        Throws:
        NullPointerException - in case the challenge parameter is null.

      • NotAuthorizedException

        public NotAuthorizedException(String message,
                      Object challenge,
                      Object... moreChallenges)
        Construct a new "not authorized" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        challenge - authorization challenge applicable to the resource requested by the client.
        moreChallenges - additional authorization challenge applicable to the requested resource.
        Throws:
        NullPointerException - in case the challenge parameter is null.

      • NotAuthorizedException

        public NotAuthorizedException(Response response)
        Construct a new "not authorized" exception.
        Parameters:
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 401.

      • NotAuthorizedException

        public NotAuthorizedException(String message,
                      Response response)
        Construct a new "not authorized" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 401.

      • NotAuthorizedException

        public NotAuthorizedException(Throwable cause,
                      Object challenge,
                      Object... moreChallenges)
        Construct a new "not authorized" exception.
        Parameters:
        cause - the underlying cause of the exception.
        challenge - authorization challenge applicable to the requested resource.
        moreChallenges - additional authorization challenge applicable to the requested resource.

      • NotAuthorizedException

        public NotAuthorizedException(String message,
                      Throwable cause,
                      Object challenge,
                      Object... moreChallenges)
        Construct a new "not authorized" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the underlying cause of the exception.
        challenge - authorization challenge applicable to the requested resource.
        moreChallenges - additional authorization challenge applicable to the requested resource.

      • NotAuthorizedException

        public NotAuthorizedException(Response response,
                      Throwable cause)
        Construct a new "not authorized" exception.
        Parameters:
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 401.

      • NotAuthorizedException

        public NotAuthorizedException(String message,
                      Response response,
                      Throwable cause)
        Construct a new "not authorized" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 401.

    • Method Detail

      • getChallenges

        public List<Object> getChallenges()
        Get the list of authorization challenges associated with the exception and applicable to the resource requested by the client.
        Returns:
        list of authorization challenges applicable to the resource requested by the client.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NotFoundException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class NotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ClientErrorException
              • javax.ws.rs.NotFoundException
  • All Implemented Interfaces:
    Serializable

    public class NotFoundException
extends ClientErrorException
    A runtime exception indicating a resource requested by a client was not found on the server.
    Since:
    2.0
    Author:
    Sergey Beryozkin, Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NotFoundException()
      Construct a new "not found" exception.
      NotFoundException(Response response)
      Construct a new "not found" exception.
      NotFoundException(Response response, Throwable cause)
      Construct a new "not found" exception.
      NotFoundException(String message)
      Construct a new "not found" exception.
      NotFoundException(String message, Response response)
      Construct a new "not found" exception.
      NotFoundException(String message, Response response, Throwable cause)
      Construct a new "not found" exception.
      NotFoundException(String message, Throwable cause)
      Construct a new "not found" exception.
      NotFoundException(Throwable cause)
      Construct a new "not found" exception.

    • Method Summary

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NotFoundException

        public NotFoundException()
        Construct a new "not found" exception.

      • NotFoundException

        public NotFoundException(String message)
        Construct a new "not found" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • NotFoundException

        public NotFoundException(Response response)
        Construct a new "not found" exception.
        Parameters:
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 404.

      • NotFoundException

        public NotFoundException(String message,
                 Response response)
        Construct a new "not found" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 404.

      • NotFoundException

        public NotFoundException(Throwable cause)
        Construct a new "not found" exception.
        Parameters:
        cause - the underlying cause of the exception.

      • NotFoundException

        public NotFoundException(String message,
                 Throwable cause)
        Construct a new "not found" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the underlying cause of the exception.

      • NotFoundException

        public NotFoundException(Response response,
                 Throwable cause)
        Construct a new "not found" exception.
        Parameters:
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 404.

      • NotFoundException

        public NotFoundException(String message,
                 Response response,
                 Throwable cause)
        Construct a new "not found" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 404.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NotSupportedException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class NotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ClientErrorException
              • javax.ws.rs.NotSupportedException
  • All Implemented Interfaces:
    Serializable

    public class NotSupportedException
extends ClientErrorException
    A runtime exception indicating that the client request entity media type is not supported.
    Since:
    2.0
    Author:
    Sergey Beryozkin, Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NotSupportedException()
      Construct a new unsupported media type exception.
      NotSupportedException(Response response)
      Construct a new unsupported media type exception.
      NotSupportedException(Response response, Throwable cause)
      Construct a new unsupported media type exception.
      NotSupportedException(String message)
      Construct a new unsupported media type exception.
      NotSupportedException(String message, Response response)
      Construct a new unsupported media type exception.
      NotSupportedException(String message, Response response, Throwable cause)
      Construct a new unsupported media type exception.
      NotSupportedException(String message, Throwable cause)
      Construct a new unsupported media type exception.
      NotSupportedException(Throwable cause)
      Construct a new unsupported media type exception.

    • Method Summary

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NotSupportedException

        public NotSupportedException()
        Construct a new unsupported media type exception.

      • NotSupportedException

        public NotSupportedException(String message)
        Construct a new unsupported media type exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • NotSupportedException

        public NotSupportedException(Response response)
        Construct a new unsupported media type exception.
        Parameters:
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 415.

      • NotSupportedException

        public NotSupportedException(String message,
                     Response response)
        Construct a new unsupported media type exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 415.

      • NotSupportedException

        public NotSupportedException(Throwable cause)
        Construct a new unsupported media type exception.
        Parameters:
        cause - the underlying cause of the exception.

      • NotSupportedException

        public NotSupportedException(String message,
                     Throwable cause)
        Construct a new unsupported media type exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the underlying cause of the exception.

      • NotSupportedException

        public NotSupportedException(Response response,
                     Throwable cause)
        Construct a new unsupported media type exception.
        Parameters:
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 415.

      • NotSupportedException

        public NotSupportedException(String message,
                     Response response,
                     Throwable cause)
        Construct a new unsupported media type exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 415.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


OPTIONS (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type OPTIONS

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
@HttpMethod(value="OPTIONS")
@Documented
public @interface OPTIONS
    Indicates that the annotated method responds to HTTP OPTIONS requests.
    Since:
    1.1
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    HttpMethod
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Path (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type Path

  • @Target(value={TYPE,METHOD})
@Retention(value=RUNTIME)
@Documented
public @interface Path
    Identifies the URI path that a resource class or class method will serve requests for.

    Paths are relative. For an annotated class the base URI is the application path, see ApplicationPath. For an annotated method the base URI is the effective URI of the containing class. For the purposes of absolutizing a path against the base URI , a leading '/' in a path is ignored and base URIs are treated as if they ended in '/'. E.g.:

    @Path("widgets")
 public class WidgetsResource {
  @GET
  String getList() {...}

  @GET @Path("{id}")
  String getWidget(@PathParam("id") String id) {...}
 }

    In the above, if the application path is catalogue and the application is deployed at http://example.com/, then GET requests for http://example.com/catalogue/widgets will be handled by the getList method while requests for http://example.com/catalogue/widgets/nnn (where nnn is some value) will be handled by the getWidget method. The same would apply if the value of either @Path annotation started with '/'.

    Classes and methods may also be annotated with Consumes and Produces to filter the requests they will receive.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Consumes, Produces, PathParam

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Defines a URI template for the resource class or method, must not include matrix parameters.

    • Element Detail

      • value

        public abstract String value
        Defines a URI template for the resource class or method, must not include matrix parameters.

        Embedded template parameters are allowed and are of the form:

         param = "{" *WSP name *WSP [ ":" *WSP regex *WSP ] "}"
 name = (ALPHA / DIGIT / "_")*(ALPHA / DIGIT / "." / "_" / "-" ) ; \w[\w\.-]*
 regex = *( nonbrace / "{" *nonbrace "}" ) ; where nonbrace is any char other than "{" and "}"

        See RFC 5234 for a description of the syntax used above and the expansions of WSP, ALPHA and DIGIT. In the above name is the template parameter name and the optional regex specifies the contents of the capturing group for the parameter. If regex is not supplied then a default value of [^/]+ which terminates at a path segment boundary, is used. Matching of request URIs to URI templates is performed against encoded path values and implementations will not escape literal characters in regex automatically, therefore any literals in regex should be escaped by the author according to the rules of RFC 3986 section 3.3. Caution is recommended in the use of regex, incorrect use can lead to a template parameter matching unexpected URI paths. See Pattern for further information on the syntax of regular expressions. Values of template parameters may be extracted using PathParam.

        The literal part of the supplied value (those characters that are not part of a template parameter) is automatically percent encoded to conform to the path production of RFC 3986 section 3.3. Note that percent encoded values are allowed in the literal part of the value, an implementation will recognize such values and will not double encode the '%' character.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PathParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type PathParam

  • @Target(value={PARAMETER,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface PathParam
    Binds the value of a URI template parameter or a path segment containing the template parameter to a resource method parameter, resource class field, or resource class bean property. The value is URL decoded unless this is disabled using the @Encoded annotation. A default value can be specified using the @DefaultValue annotation. The type of the annotated parameter, field or property must either:
    • Be PathSegment, the value will be the final segment of the matching part of the path. See UriInfo for a means of retrieving all request path segments.
    • Be List<javax.ws.rs.core.PathSegment>, the value will be a list of PathSegment corresponding to the path segment(s) that matched the named template parameter. See UriInfo for a means of retrieving all request path segments.
    • Be a primitive type.
    • Have a constructor that accepts a single String argument.
    • Have a static method named valueOf or fromString that accepts a single String argument (see, for example, Integer.valueOf(String)).
    • Have a registered implementation of ParamConverterProvider JAX-RS extension SPI that returns a ParamConverter instance capable of a "from string" conversion for the type.

    The injected value corresponds to the latest use (in terms of scope) of the path parameter. E.g. if a class and a sub-resource method are both annotated with a @Path containing the same URI template parameter, use of @PathParam on a sub-resource method parameter will bind the value matching URI template parameter in the method's @Path annotation.

    Because injection occurs at object creation time, use of this annotation on resource class fields and bean properties is only supported for the default per-request resource class lifecycle. Resource classes using other lifecycles should only use this annotation on resource method parameters.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    @Encoded, @DefaultValue, PathSegment, UriInfo

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Defines the name of the URI template parameter whose value will be used to initialize the value of the annotated method parameter, class field or property.

    • Element Detail

      • value

        public abstract String value
        Defines the name of the URI template parameter whose value will be used to initialize the value of the annotated method parameter, class field or property. See Path.value() for a description of the syntax of template parameters.

        E.g. a class annotated with: @Path("widgets/{id}") can have methods annotated whose arguments are annotated with @PathParam("id").

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


POST (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type POST

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
@HttpMethod(value="POST")
@Documented
public @interface POST
    Indicates that the annotated method responds to HTTP POST requests.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    HttpMethod
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Priorities (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class Priorities

  • java.lang.Object
    • javax.ws.rs.Priorities

  • public final class Priorities
extends Object
    A collection of built-in priority constants for the JAX-RS components that are supposed to be ordered based on their javax.annotation.Priority class-level annotation value when used or applied by JAX-RS runtime.

    For example, JAX-RS filters and interceptors are grouped in chains for each of the message processing extension points: Pre, PreMatch, Post as well as ReadFrom and WriteTo. Each of these chains is sorted based on priorities which are represented as integer numbers. All chains, except Post, are sorted in ascending order; the lower the number the higher the priority. The Post filter chain is sorted in descending order to ensure that response filters are executed in reverse order.

    JAX-RS components that belong to the same priority class (same integer value) are executed in an implementation-defined manner. By default, when the @Priority annotation is absent on a component, for which a priority should be applied, the USER priority value is used.

    Since:
    2.0
    Author:
    Marek Potociar (marek.potociar at oracle.com)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int AUTHENTICATION
      Security authentication filter/interceptor priority.
      static int AUTHORIZATION
      Security authorization filter/interceptor priority.
      static int ENTITY_CODER
      Message encoder or decoder filter/interceptor priority.
      static int HEADER_DECORATOR
      Header decorator filter/interceptor priority.
      static int USER
      User-level filter/interceptor priority.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • AUTHENTICATION

        public static final int AUTHENTICATION
        Security authentication filter/interceptor priority.
        See Also:
        Constant Field Values

      • AUTHORIZATION

        public static final int AUTHORIZATION
        Security authorization filter/interceptor priority.
        See Also:
        Constant Field Values

      • HEADER_DECORATOR

        public static final int HEADER_DECORATOR
        Header decorator filter/interceptor priority.
        See Also:
        Constant Field Values

      • ENTITY_CODER

        public static final int ENTITY_CODER
        Message encoder or decoder filter/interceptor priority.
        See Also:
        Constant Field Values

      • USER

        public static final int USER
        User-level filter/interceptor priority.
        See Also:
        Constant Field Values
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProcessingException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class ProcessingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.ProcessingException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ResponseProcessingException

    public class ProcessingException
extends RuntimeException
    A base JAX-RS runtime processing exception. The exception of this type is thrown during HTTP request or response processing, to signal a runtime processing failure. Typical classes of failures covered by ProcessingException include
    • failures in filter or interceptor chain execution,
    • errors caused by missing message body readers or writers for the particular Java type and media type combinations,
    • propagated IO exceptions thrown by entity readers and writers during entity serialization and de-serialization.
    as well as any other JAX-RS runtime processing errors. The exception message or nested Throwable cause SHOULD contain additional information about the reason of the processing failure.

    Note that the exception is used to indicate (internal) JAX-RS processing errors. It is not used to indicate HTTP error response states. A HTTP error response is represented by a WebApplicationException class or one of it's sub-classes.

    Since:
    2.0
    Author:
    Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ProcessingException(String message)
      Constructs a new JAX-RS runtime processing exception with the specified detail message.
      ProcessingException(String message, Throwable cause)
      Constructs a new JAX-RS runtime processing exception with the specified detail message and cause.
      ProcessingException(Throwable cause)
      Constructs a new JAX-RS runtime processing exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ProcessingException

        public ProcessingException(Throwable cause)
        Constructs a new JAX-RS runtime processing exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause). This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.
        Parameters:
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • ProcessingException

        public ProcessingException(String message,
                   Throwable cause)
        Constructs a new JAX-RS runtime processing exception with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.

        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • ProcessingException

        public ProcessingException(String message)
        Constructs a new JAX-RS runtime processing exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Produces (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type Produces

  • @Inherited
@Target(value={TYPE,METHOD})
@Retention(value=RUNTIME)
@Documented
public @interface Produces
    Defines the media type(s) that the methods of a resource class or MessageBodyWriter can produce. If not specified then a container will assume that any type can be produced. Method level annotations override a class level annotation. A container is responsible for ensuring that the method invoked is capable of producing one of the media types requested in the HTTP request. If no such method is available the container must respond with a HTTP "406 Not Acceptable" as specified by RFC 2616.

    A method for which there is a single-valued @Produces is not required to set the media type of representations that it produces: the container will use the value of the @Produces when sending a response.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    MessageBodyWriter

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String[] value
      A list of media types.

    • Element Detail

      • value

        public abstract String[] value
        A list of media types. Each entry may specify a single type or consist of a comma separated list of types, with any leading or trailing white-spaces in a single type entry being ignored. For example:
          {"image/jpeg, image/gif ", " image/png"}
        Use of the comma-separated form allows definition of a common string constant for use on multiple targets.
        Default:
        "*/*"
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


PUT (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type PUT

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
@HttpMethod(value="PUT")
@Documented
public @interface PUT
    Indicates that the annotated method responds to HTTP PUT requests.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    HttpMethod
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


QueryParam (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs

Annotation Type QueryParam

  • @Target(value={PARAMETER,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface QueryParam
    Binds the value(s) of a HTTP query parameter to a resource method parameter, resource class field, or resource class bean property. Values are URL decoded unless this is disabled using the Encoded annotation. A default value can be specified using the DefaultValue annotation. The type T of the annotated parameter, field or property must either:
    1. Be a primitive type
    2. Have a constructor that accepts a single String argument
    3. Have a static method named valueOf or fromString that accepts a single String argument (see, for example, Integer.valueOf(String))
    4. Have a registered implementation of ParamConverterProvider JAX-RS extension SPI that returns a ParamConverter instance capable of a "from string" conversion for the type.
    5. Be List<T>, Set<T> or SortedSet<T>, where T satisfies 2, 3 or 4 above. The resulting collection is read-only.

    If the type is not one of the collection types listed in 5 above and the query parameter is represented by multiple values then the first value (lexically) of the parameter is used.

    Because injection occurs at object creation time, use of this annotation on resource class fields and bean properties is only supported for the default per-request resource class lifecycle. Resource classes using other lifecycles should only use this annotation on resource method parameters.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    DefaultValue, Encoded, UriInfo.getQueryParameters()

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      Defines the name of the HTTP query parameter whose value will be used to initialize the value of the annotated method argument, class field or bean property.

    • Element Detail

      • value

        public abstract String value
        Defines the name of the HTTP query parameter whose value will be used to initialize the value of the annotated method argument, class field or bean property. The name is specified in decoded form, any percent encoded literals within the value will not be decoded and will instead be treated as literal text. E.g. if the parameter name is "a b" then the value of the annotation is "a b", not "a+b" or "a%20b".
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


RedirectionException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class RedirectionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.RedirectionException
  • All Implemented Interfaces:
    Serializable

    public class RedirectionException
extends WebApplicationException
    A runtime application exception indicating a request redirection (HTTP 3xx status codes).
    Since:
    2.0
    Author:
    Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      RedirectionException(int status, URI location)
      Construct a new redirection exception.
      RedirectionException(Response.Status status, URI location)
      Construct a new redirection exception.
      RedirectionException(Response response)
      Construct a new redirection exception.
      RedirectionException(String message, int status, URI location)
      Construct a new redirection exception.
      RedirectionException(String message, Response.Status status, URI location)
      Construct a new redirection exception.
      RedirectionException(String message, Response response)
      Construct a new redirection exception.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      URI getLocation()
      Get the redirection response location.

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • RedirectionException

        public RedirectionException(Response.Status status,
                    URI location)
        Construct a new redirection exception.
        Parameters:
        status - redirection status. Must be a 3xx redirection code.
        location - redirection URI placed into the response Location header.
        Throws:
        IllegalArgumentException - in case the status code is null or is not from Response.Status.Family.REDIRECTION status code family.

      • RedirectionException

        public RedirectionException(String message,
                    Response.Status status,
                    URI location)
        Construct a new redirection exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - redirection status. Must be a 3xx redirection code.
        location - redirection URI placed into the response Location header.
        Throws:
        IllegalArgumentException - in case the status code is null or is not from Response.Status.Family.REDIRECTION status code family.

      • RedirectionException

        public RedirectionException(int status,
                    URI location)
        Construct a new redirection exception.
        Parameters:
        status - redirection status. Must be a 3xx redirection code.
        location - redirection URI placed into the response Location header.
        Throws:
        IllegalArgumentException - in case the status code is not a valid HTTP status code or if it is not from the Response.Status.Family.REDIRECTION status code family.

      • RedirectionException

        public RedirectionException(String message,
                    int status,
                    URI location)
        Construct a new redirection exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - redirection status. Must be a 3xx redirection code.
        location - redirection URI placed into the response Location header.
        Throws:
        IllegalArgumentException - in case the status code is not a valid HTTP status code or if it is not from the Response.Status.Family.REDIRECTION status code family.

      • RedirectionException

        public RedirectionException(Response response)
        Construct a new redirection exception.
        Parameters:
        response - redirection response. Must have a status code set to a 3xx redirection code.
        Throws:
        IllegalArgumentException - in case the response status code is not from the Response.Status.Family.REDIRECTION status code family.

      • RedirectionException

        public RedirectionException(String message,
                    Response response)
        Construct a new redirection exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - redirection response. Must have a status code set to a 3xx redirection code.
        Throws:
        IllegalArgumentException - in case the response status code is not from the Response.Status.Family.REDIRECTION status code family.

    • Method Detail

      • getLocation

        public URI getLocation()
        Get the redirection response location.
        Returns:
        redirection response location.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RuntimeType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.ws.rs

Enum RuntimeType

  • java.lang.Object
    • java.lang.Enum<RuntimeType>
      • javax.ws.rs.RuntimeType
  • All Implemented Interfaces:
    Serializable, Comparable<RuntimeType>

    public enum RuntimeType
extends Enum<RuntimeType>
    Enumeration of JAX-RS runtime types.
    Since:
    2.0
    Author:
    Marek Potociar

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      CLIENT
      JAX-RS client run-time.
      SERVER
      JAX-RS server run-time.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static RuntimeType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static RuntimeType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CLIENT

        public static final RuntimeType CLIENT
        JAX-RS client run-time.

      • SERVER

        public static final RuntimeType SERVER
        JAX-RS server run-time.

    • Method Detail

      • values

        public static RuntimeType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (RuntimeType c : RuntimeType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static RuntimeType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ServerErrorException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class ServerErrorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ServerErrorException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    InternalServerErrorException, ServiceUnavailableException

    public class ServerErrorException
extends WebApplicationException
    A base runtime application exception indicating a server error (HTTP 5xx status codes).
    Since:
    2.0
    Author:
    Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ServerErrorException(int status)
      Construct a new server error exception.
      ServerErrorException(int status, Throwable cause)
      Construct a new server error exception.
      ServerErrorException(Response.Status status)
      Construct a new server error exception.
      ServerErrorException(Response.Status status, Throwable cause)
      Construct a new server error exception.
      ServerErrorException(Response response)
      Construct a new server error exception.
      ServerErrorException(Response response, Throwable cause)
      Construct a new server error exception.
      ServerErrorException(String message, int status)
      Construct a new server error exception.
      ServerErrorException(String message, int status, Throwable cause)
      Construct a new server error exception.
      ServerErrorException(String message, Response.Status status)
      Construct a new server error exception.
      ServerErrorException(String message, Response.Status status, Throwable cause)
      Construct a new server error exception.
      ServerErrorException(String message, Response response)
      Construct a new server error exception.
      ServerErrorException(String message, Response response, Throwable cause)
      Construct a new server error exception.

    • Method Summary

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServerErrorException

        public ServerErrorException(Response.Status status)
        Construct a new server error exception.
        Parameters:
        status - server error status. Must be a 5xx status code.
        Throws:
        IllegalArgumentException - in case the status code is null or is not from Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(String message,
                    Response.Status status)
        Construct a new server error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - server error status. Must be a 5xx status code.
        Throws:
        IllegalArgumentException - in case the status code is null or is not from Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(int status)
        Construct a new server error exception.
        Parameters:
        status - server error status. Must be a 5xx status code.
        Throws:
        IllegalArgumentException - in case the status code is not a valid HTTP status code or if it is not from the Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(String message,
                    int status)
        Construct a new server error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - server error status. Must be a 5xx status code.
        Throws:
        IllegalArgumentException - in case the status code is not a valid HTTP status code or if it is not from the Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(Response response)
        Construct a new server error exception.
        Parameters:
        response - server error response. Must have a status code set to a 5xx status code.
        Throws:
        IllegalArgumentException - in case the response status code is not from the Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(String message,
                    Response response)
        Construct a new server error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - server error response. Must have a status code set to a 5xx status code.
        Throws:
        IllegalArgumentException - in case the response status code is not from the Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(Response.Status status,
                    Throwable cause)
        Construct a new server error exception.
        Parameters:
        status - server error status. Must be a 5xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code is null or is not from Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(String message,
                    Response.Status status,
                    Throwable cause)
        Construct a new server error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - server error status. Must be a 5xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code is null or is not from Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(int status,
                    Throwable cause)
        Construct a new server error exception.
        Parameters:
        status - server error status. Must be a 5xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code is not a valid HTTP status code or if it is not from the Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(String message,
                    int status,
                    Throwable cause)
        Construct a new server error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - server error status. Must be a 5xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code is not a valid HTTP status code or if it is not from the Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(Response response,
                    Throwable cause)
        Construct a new server error exception.
        Parameters:
        response - server error response. Must have a status code set to a 5xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the response status code is not from the Response.Status.Family.SERVER_ERROR status code family.

      • ServerErrorException

        public ServerErrorException(String message,
                    Response response,
                    Throwable cause)
        Construct a new server error exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - server error response. Must have a status code set to a 5xx status code.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the response status code is not from the Response.Status.Family.SERVER_ERROR status code family.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceUnavailableException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class ServiceUnavailableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ServerErrorException
              • javax.ws.rs.ServiceUnavailableException
  • All Implemented Interfaces:
    Serializable

    public class ServiceUnavailableException
extends ServerErrorException
    A runtime exception indicating that the requested resource cannot be served.
    Since:
    2.0
    Author:
    Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceUnavailableException()
      Construct a new "service unavailable" exception without any "Retry-After" information specified for the failed request.
      ServiceUnavailableException(Date retryAfter)
      Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.
      ServiceUnavailableException(Date retryAfter, Throwable cause)
      Construct a new "service unavailable" exception with a date specifying the "Retry-After" information for the failed request and an underlying request failure cause.
      ServiceUnavailableException(Long retryAfter)
      Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.
      ServiceUnavailableException(Long retryAfter, Throwable cause)
      Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request and an underlying request failure cause.
      ServiceUnavailableException(Response response)
      Construct a new "service unavailable" exception.
      ServiceUnavailableException(Response response, Throwable cause)
      Construct a new "service unavailable" exception.
      ServiceUnavailableException(String message)
      Construct a new "service unavailable" exception without any "Retry-After" information specified for the failed request.
      ServiceUnavailableException(String message, Date retryAfter)
      Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.
      ServiceUnavailableException(String message, Date retryAfter, Throwable cause)
      Construct a new "service unavailable" exception with a date specifying the "Retry-After" information for the failed request and an underlying request failure cause.
      ServiceUnavailableException(String message, Long retryAfter)
      Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.
      ServiceUnavailableException(String message, Long retryAfter, Throwable cause)
      Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request and an underlying request failure cause.
      ServiceUnavailableException(String message, Response response)
      Construct a new "service unavailable" exception.
      ServiceUnavailableException(String message, Response response, Throwable cause)
      Construct a new "service unavailable" exception.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Date getRetryTime(Date requestTime)
      Get the retry time for the failed request.
      boolean hasRetryAfter()
      Check if the underlying response contains the information on when is it possible to retry the request.

      • Methods inherited from class javax.ws.rs.WebApplicationException

        getResponse

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServiceUnavailableException

        public ServiceUnavailableException()
        Construct a new "service unavailable" exception without any "Retry-After" information specified for the failed request.

      • ServiceUnavailableException

        public ServiceUnavailableException(String message)
        Construct a new "service unavailable" exception without any "Retry-After" information specified for the failed request.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • ServiceUnavailableException

        public ServiceUnavailableException(Long retryAfter)
        Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.
        Parameters:
        retryAfter - decimal interval in seconds after which the failed request may be retried.

      • ServiceUnavailableException

        public ServiceUnavailableException(String message,
                           Long retryAfter)
        Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        retryAfter - decimal interval in seconds after which the failed request may be retried.

      • ServiceUnavailableException

        public ServiceUnavailableException(Date retryAfter)
        Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.
        Parameters:
        retryAfter - a date/time after which the failed request may be retried.

      • ServiceUnavailableException

        public ServiceUnavailableException(String message,
                           Date retryAfter)
        Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        retryAfter - a date/time after which the failed request may be retried.

      • ServiceUnavailableException

        public ServiceUnavailableException(Response response)
        Construct a new "service unavailable" exception.
        Parameters:
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 503.

      • ServiceUnavailableException

        public ServiceUnavailableException(String message,
                           Response response)
        Construct a new "service unavailable" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 503.

      • ServiceUnavailableException

        public ServiceUnavailableException(Date retryAfter,
                           Throwable cause)
        Construct a new "service unavailable" exception with a date specifying the "Retry-After" information for the failed request and an underlying request failure cause.
        Parameters:
        retryAfter - a date/time after which the failed request may be retried.
        cause - the underlying cause of the exception.

      • ServiceUnavailableException

        public ServiceUnavailableException(String message,
                           Date retryAfter,
                           Throwable cause)
        Construct a new "service unavailable" exception with a date specifying the "Retry-After" information for the failed request and an underlying request failure cause.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        retryAfter - a date/time after which the failed request may be retried.
        cause - the underlying cause of the exception.

      • ServiceUnavailableException

        public ServiceUnavailableException(Long retryAfter,
                           Throwable cause)
        Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request and an underlying request failure cause.
        Parameters:
        retryAfter - decimal interval in seconds after which the failed request may be retried.
        cause - the underlying cause of the exception.

      • ServiceUnavailableException

        public ServiceUnavailableException(String message,
                           Long retryAfter,
                           Throwable cause)
        Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request and an underlying request failure cause.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        retryAfter - decimal interval in seconds after which the failed request may be retried.
        cause - the underlying cause of the exception.

      • ServiceUnavailableException

        public ServiceUnavailableException(Response response,
                           Throwable cause)
        Construct a new "service unavailable" exception.
        Parameters:
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 503.

      • ServiceUnavailableException

        public ServiceUnavailableException(String message,
                           Response response,
                           Throwable cause)
        Construct a new "service unavailable" exception.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - error response.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - in case the status code set in the response is not HTTP 503.

    • Method Detail

      • hasRetryAfter

        public boolean hasRetryAfter()
        Check if the underlying response contains the information on when is it possible to retry the request.
        Returns:
        true in case the retry time is specified in the underlying response, false otherwise.

      • getRetryTime

        public Date getRetryTime(Date requestTime)
        Get the retry time for the failed request.
        Parameters:
        requestTime - time of sending the original request that may be used to compute the retry time (in case the retry time information specified as a decimal interval in seconds).
        Returns:
        time when the request may be retried or null if there is no retry information available.
        Throws:
        NullPointerException - in case the requestTime parameter is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.ws.rs (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.ws.rs

  • Packages that use javax.ws.rs
    Package Description
    javax.ws.rs
    High-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.
  • Classes in javax.ws.rs used by javax.ws.rs
    Class and Description
    ClientErrorException
    A base runtime application exception indicating a client request error (HTTP 4xx status codes).
    HttpMethod
    Associates the name of a HTTP method with an annotation.
    RuntimeType
    Enumeration of JAX-RS runtime types.
    ServerErrorException
    A base runtime application exception indicating a server error (HTTP 5xx status codes).
    WebApplicationException
    Runtime exception for applications.
  • Classes in javax.ws.rs used by javax.ws.rs.client
    Class and Description
    ProcessingException
    A base JAX-RS runtime processing exception.
  • Classes in javax.ws.rs used by javax.ws.rs.core
    Class and Description
    RuntimeType
    Enumeration of JAX-RS runtime types.
    WebApplicationException
    Runtime exception for applications.
  • Classes in javax.ws.rs used by javax.ws.rs.ext
    Class and Description
    WebApplicationException
    Runtime exception for applications.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WebApplicationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs

Class WebApplicationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.WebApplicationException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ClientErrorException, RedirectionException, ServerErrorException

    public class WebApplicationException
extends RuntimeException
    Runtime exception for applications.

    This exception may be thrown by a resource method, provider or StreamingOutput implementation if a specific HTTP error response needs to be produced. Only effective if thrown prior to the response being committed.

    Since:
    1.0
    Author:
    Paul Sandoz, Marek Potociar
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      WebApplicationException()
      Construct a new instance with a blank message and default HTTP status code of 500.
      WebApplicationException(int status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(Response.Status status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(Response response)
      Construct a new instance using the supplied response.
      WebApplicationException(String message)
      Construct a new instance with a blank message and default HTTP status code of 500.
      WebApplicationException(String message, int status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(String message, Response.Status status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(String message, Response response)
      Construct a new instance using the supplied response.
      WebApplicationException(String message, Throwable cause)
      Construct a new instance with a blank message and default HTTP status code of 500.
      WebApplicationException(String message, Throwable cause, int status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(String message, Throwable cause, Response.Status status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(String message, Throwable cause, Response response)
      Construct a new instance using the supplied response.
      WebApplicationException(Throwable cause)
      Construct a new instance with a blank message and default HTTP status code of 500.
      WebApplicationException(Throwable cause, int status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(Throwable cause, Response.Status status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(Throwable cause, Response response)
      Construct a new instance using the supplied response.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Response getResponse()
      Get the HTTP response.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WebApplicationException

        public WebApplicationException()
        Construct a new instance with a blank message and default HTTP status code of 500.

      • WebApplicationException

        public WebApplicationException(String message)
        Construct a new instance with a blank message and default HTTP status code of 500.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        Since:
        2.0

      • WebApplicationException

        public WebApplicationException(Response response)
        Construct a new instance using the supplied response.
        Parameters:
        response - the response that will be returned to the client, a value of null will be replaced with an internal server error response (status code 500).

      • WebApplicationException

        public WebApplicationException(String message,
                       Response response)
        Construct a new instance using the supplied response.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - the response that will be returned to the client, a value of null will be replaced with an internal server error response (status code 500).
        Since:
        2.0

      • WebApplicationException

        public WebApplicationException(int status)
        Construct a new instance with a blank message and specified HTTP status code.
        Parameters:
        status - the HTTP status code that will be returned to the client.

      • WebApplicationException

        public WebApplicationException(String message,
                       int status)
        Construct a new instance with a blank message and specified HTTP status code.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - the HTTP status code that will be returned to the client.
        Since:
        2.0

      • WebApplicationException

        public WebApplicationException(Response.Status status)
        Construct a new instance with a blank message and specified HTTP status code.
        Parameters:
        status - the HTTP status code that will be returned to the client.
        Throws:
        IllegalArgumentException - if status is null.

      • WebApplicationException

        public WebApplicationException(String message,
                       Response.Status status)
        Construct a new instance with a blank message and specified HTTP status code.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - the HTTP status code that will be returned to the client.
        Throws:
        IllegalArgumentException - if status is null.
        Since:
        2.0

      • WebApplicationException

        public WebApplicationException(Throwable cause)
        Construct a new instance with a blank message and default HTTP status code of 500.
        Parameters:
        cause - the underlying cause of the exception.

      • WebApplicationException

        public WebApplicationException(String message,
                       Throwable cause)
        Construct a new instance with a blank message and default HTTP status code of 500.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the underlying cause of the exception.
        Since:
        2.0

      • WebApplicationException

        public WebApplicationException(Throwable cause,
                       Response response)
        Construct a new instance using the supplied response.
        Parameters:
        response - the response that will be returned to the client, a value of null will be replaced with an internal server error response (status code 500).
        cause - the underlying cause of the exception.

      • WebApplicationException

        public WebApplicationException(String message,
                       Throwable cause,
                       Response response)
        Construct a new instance using the supplied response.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        response - the response that will be returned to the client, a value of null will be replaced with an internal server error response (status code 500).
        cause - the underlying cause of the exception.
        Since:
        2.0

      • WebApplicationException

        public WebApplicationException(Throwable cause,
                       int status)
        Construct a new instance with a blank message and specified HTTP status code.
        Parameters:
        status - the HTTP status code that will be returned to the client.
        cause - the underlying cause of the exception.

      • WebApplicationException

        public WebApplicationException(String message,
                       Throwable cause,
                       int status)
        Construct a new instance with a blank message and specified HTTP status code.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - the HTTP status code that will be returned to the client.
        cause - the underlying cause of the exception.
        Since:
        2.0

      • WebApplicationException

        public WebApplicationException(Throwable cause,
                       Response.Status status)
                        throws IllegalArgumentException
        Construct a new instance with a blank message and specified HTTP status code.
        Parameters:
        status - the HTTP status code that will be returned to the client.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException - if status is null.

      • WebApplicationException

        public WebApplicationException(String message,
                       Throwable cause,
                       Response.Status status)
                        throws IllegalArgumentException
        Construct a new instance with a blank message and specified HTTP status code.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        status - the HTTP status code that will be returned to the client.
        cause - the underlying cause of the exception.
        Throws:
        IllegalArgumentException
        Since:
        2.0

    • Method Detail

      • getResponse

        public Response getResponse()
        Get the HTTP response.
        Returns:
        the HTTP response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.ws.rs.ApplicationPath (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.ApplicationPath

No usage of javax.ws.rs.ApplicationPath
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.BadRequestException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.BadRequestException

No usage of javax.ws.rs.BadRequestException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.BeanParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.BeanParam

No usage of javax.ws.rs.BeanParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.ClientErrorException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.ClientErrorException

  • Packages that use ClientErrorException
    Package Description
    javax.ws.rs
    High-level interfaces and annotations used to create RESTful service resources.

    • Uses of ClientErrorException in javax.ws.rs

      Subclasses of ClientErrorException in javax.ws.rs
      Modifier and Type Class and Description
      class  BadRequestException
      A runtime exception indicating a bad client request.
      class  ForbiddenException
      A runtime exception indicating that an access to a resource requested by a client has been forbidden by the server.
      class  NotAcceptableException
      A runtime exception indicating that a client request is not acceptable by the server.
      class  NotAllowedException
      A runtime exception indicating a client requesting a resource method that is not allowed.
      class  NotAuthorizedException
      A runtime exception indicating request authorization failure caused by one of the following scenarios: a client did not send the required authorization credentials to access the requested resource, i.e.
      class  NotFoundException
      A runtime exception indicating a resource requested by a client was not found on the server.
      class  NotSupportedException
      A runtime exception indicating that the client request entity media type is not supported.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.ConstrainedTo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.ConstrainedTo

No usage of javax.ws.rs.ConstrainedTo
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.Consumes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.Consumes

No usage of javax.ws.rs.Consumes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.CookieParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.CookieParam

No usage of javax.ws.rs.CookieParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.DefaultValue (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.DefaultValue

No usage of javax.ws.rs.DefaultValue
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.DELETE (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.DELETE

No usage of javax.ws.rs.DELETE
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.Encoded (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.Encoded

No usage of javax.ws.rs.Encoded
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.ForbiddenException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.ForbiddenException

No usage of javax.ws.rs.ForbiddenException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.FormParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.FormParam

No usage of javax.ws.rs.FormParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.GET (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.GET

No usage of javax.ws.rs.GET
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.HEAD (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.HEAD

No usage of javax.ws.rs.HEAD
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.HeaderParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.HeaderParam

No usage of javax.ws.rs.HeaderParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.HttpMethod (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.HttpMethod

  • Packages that use HttpMethod
    Package Description
    javax.ws.rs
    High-level interfaces and annotations used to create RESTful service resources.

    • Uses of HttpMethod in javax.ws.rs

      Classes in javax.ws.rs with annotations of type HttpMethod
      Modifier and Type Class and Description
      interface  DELETE
      Indicates that the annotated method responds to HTTP DELETE requests.
      interface  GET
      Indicates that the annotated method responds to HTTP GET requests.
      interface  HEAD
      Indicates that the annotated method responds to HTTP HEAD requests.
      interface  OPTIONS
      Indicates that the annotated method responds to HTTP OPTIONS requests.
      interface  POST
      Indicates that the annotated method responds to HTTP POST requests.
      interface  PUT
      Indicates that the annotated method responds to HTTP PUT requests.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.InternalServerErrorException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.InternalServerErrorException

No usage of javax.ws.rs.InternalServerErrorException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.MatrixParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.MatrixParam

No usage of javax.ws.rs.MatrixParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.NameBinding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.NameBinding

No usage of javax.ws.rs.NameBinding
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.NotAcceptableException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.NotAcceptableException

No usage of javax.ws.rs.NotAcceptableException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.NotAllowedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.NotAllowedException

No usage of javax.ws.rs.NotAllowedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.NotAuthorizedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.NotAuthorizedException

No usage of javax.ws.rs.NotAuthorizedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.NotFoundException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.NotFoundException

No usage of javax.ws.rs.NotFoundException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.NotSupportedException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.NotSupportedException

No usage of javax.ws.rs.NotSupportedException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.OPTIONS (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.OPTIONS

No usage of javax.ws.rs.OPTIONS
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.Path (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.Path

No usage of javax.ws.rs.Path
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.PathParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.PathParam

No usage of javax.ws.rs.PathParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.POST (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.POST

No usage of javax.ws.rs.POST
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.Priorities (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.Priorities

No usage of javax.ws.rs.Priorities
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.ProcessingException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.ProcessingException

  • Packages that use ProcessingException
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of ProcessingException in javax.ws.rs.client

      Subclasses of ProcessingException in javax.ws.rs.client
      Modifier and Type Class and Description
      class  ResponseProcessingException
      JAX-RS client-side runtime processing exception thrown to indicate that response processing has failed (e.g.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.Produces (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.Produces

No usage of javax.ws.rs.Produces
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.PUT (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.PUT

No usage of javax.ws.rs.PUT
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.QueryParam (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.QueryParam

No usage of javax.ws.rs.QueryParam
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.RedirectionException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.RedirectionException

No usage of javax.ws.rs.RedirectionException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.RuntimeType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.RuntimeType

  • Packages that use RuntimeType
    Package Description
    javax.ws.rs
    High-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of RuntimeType in javax.ws.rs

      Methods in javax.ws.rs that return RuntimeType
      Modifier and Type Method and Description
      static RuntimeType RuntimeType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static RuntimeType[] RuntimeType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.

    • Uses of RuntimeType in javax.ws.rs.core

      Methods in javax.ws.rs.core that return RuntimeType
      Modifier and Type Method and Description
      RuntimeType Configuration.getRuntimeType()
      Get the runtime type of this configuration context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.ServerErrorException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.ServerErrorException

  • Packages that use ServerErrorException
    Package Description
    javax.ws.rs
    High-level interfaces and annotations used to create RESTful service resources.

    • Uses of ServerErrorException in javax.ws.rs

      Subclasses of ServerErrorException in javax.ws.rs
      Modifier and Type Class and Description
      class  InternalServerErrorException
      A runtime exception indicating an internal server error.
      class  ServiceUnavailableException
      A runtime exception indicating that the requested resource cannot be served.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.ServiceUnavailableException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.ServiceUnavailableException

No usage of javax.ws.rs.ServiceUnavailableException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.WebApplicationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.WebApplicationException

  • Packages that use WebApplicationException
    Package Description
    javax.ws.rs
    High-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of WebApplicationException in javax.ws.rs

      Subclasses of WebApplicationException in javax.ws.rs
      Modifier and Type Class and Description
      class  BadRequestException
      A runtime exception indicating a bad client request.
      class  ClientErrorException
      A base runtime application exception indicating a client request error (HTTP 4xx status codes).
      class  ForbiddenException
      A runtime exception indicating that an access to a resource requested by a client has been forbidden by the server.
      class  InternalServerErrorException
      A runtime exception indicating an internal server error.
      class  NotAcceptableException
      A runtime exception indicating that a client request is not acceptable by the server.
      class  NotAllowedException
      A runtime exception indicating a client requesting a resource method that is not allowed.
      class  NotAuthorizedException
      A runtime exception indicating request authorization failure caused by one of the following scenarios: a client did not send the required authorization credentials to access the requested resource, i.e.
      class  NotFoundException
      A runtime exception indicating a resource requested by a client was not found on the server.
      class  NotSupportedException
      A runtime exception indicating that the client request entity media type is not supported.
      class  RedirectionException
      A runtime application exception indicating a request redirection (HTTP 3xx status codes).
      class  ServerErrorException
      A base runtime application exception indicating a server error (HTTP 5xx status codes).
      class  ServiceUnavailableException
      A runtime exception indicating that the requested resource cannot be served.

    • Uses of WebApplicationException in javax.ws.rs.core

      Methods in javax.ws.rs.core that throw WebApplicationException
      Modifier and Type Method and Description
      void StreamingOutput.write(OutputStream output)
      Called to write the message body.

    • Uses of WebApplicationException in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that throw WebApplicationException
      Modifier and Type Method and Description
      Object ReaderInterceptor.aroundReadFrom(ReaderInterceptorContext context)
      Interceptor method wrapping calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream) method.
      void WriterInterceptor.aroundWriteTo(WriterInterceptorContext context)
      Interceptor method wrapping calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream) method.
      void WriterInterceptorContext.proceed()
      Proceed to the next interceptor in the chain.
      Object ReaderInterceptorContext.proceed()
      Proceed to the next interceptor in the chain.
      T MessageBodyReader.readFrom(Class<T> type, Type genericType, Annotation[] annotations, MediaType mediaType, MultivaluedMap<String,String> httpHeaders, InputStream entityStream)
      Read a type from the InputStream.
      void MessageBodyWriter.writeTo(T t, Class<?> type, Type genericType, Annotation[] annotations, MediaType mediaType, MultivaluedMap<String,Object> httpHeaders, OutputStream entityStream)
      Write a type to an HTTP message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AsyncInvoker (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface AsyncInvoker

  • public interface AsyncInvoker
    Uniform interface for asynchronous invocation of HTTP methods.
    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Future<Response> delete()
      Invoke HTTP DELETE method for the current request asynchronously.
      <T> Future<T> delete(Class<T> responseType)
      Invoke HTTP DELETE method for the current request asynchronously.
      <T> Future<T> delete(GenericType<T> responseType)
      Invoke HTTP DELETE method for the current request asynchronously.
      <T> Future<T> delete(InvocationCallback<T> callback)
      Invoke HTTP DELETE method for the current request asynchronously.
      Future<Response> get()
      Invoke HTTP GET method for the current request asynchronously.
      <T> Future<T> get(Class<T> responseType)
      Invoke HTTP GET method for the current request asynchronously.
      <T> Future<T> get(GenericType<T> responseType)
      Invoke HTTP GET method for the current request asynchronously.
      <T> Future<T> get(InvocationCallback<T> callback)
      Invoke HTTP GET method for the current request asynchronously.
      Future<Response> head()
      Invoke HTTP HEAD method for the current request asynchronously.
      Future<Response> head(InvocationCallback<Response> callback)
      Invoke HTTP HEAD method for the current request asynchronously.
      Future<Response> method(String name)
      Invoke an arbitrary method for the current request asynchronously.
      <T> Future<T> method(String name, Class<T> responseType)
      Invoke an arbitrary method for the current request asynchronously.
      Future<Response> method(String name, Entity<?> entity)
      Invoke an arbitrary method for the current request asynchronously.
      <T> Future<T> method(String name, Entity<?> entity, Class<T> responseType)
      Invoke an arbitrary method for the current request asynchronously.
      <T> Future<T> method(String name, Entity<?> entity, GenericType<T> responseType)
      Invoke an arbitrary method for the current request asynchronously.
      <T> Future<T> method(String name, Entity<?> entity, InvocationCallback<T> callback)
      Invoke an arbitrary method for the current request asynchronously.
      <T> Future<T> method(String name, GenericType<T> responseType)
      Invoke an arbitrary method for the current request asynchronously.
      <T> Future<T> method(String name, InvocationCallback<T> callback)
      Invoke an arbitrary method for the current request asynchronously.
      Future<Response> options()
      Invoke HTTP OPTIONS method for the current request asynchronously.
      <T> Future<T> options(Class<T> responseType)
      Invoke HTTP OPTIONS method for the current request asynchronously.
      <T> Future<T> options(GenericType<T> responseType)
      Invoke HTTP OPTIONS method for the current request asynchronously.
      <T> Future<T> options(InvocationCallback<T> callback)
      Invoke HTTP OPTIONS method for the current request asynchronously.
      Future<Response> post(Entity<?> entity)
      Invoke HTTP POST method for the current request asynchronously.
      <T> Future<T> post(Entity<?> entity, Class<T> responseType)
      Invoke HTTP POST method for the current request asynchronously.
      <T> Future<T> post(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP POST method for the current request asynchronously.
      <T> Future<T> post(Entity<?> entity, InvocationCallback<T> callback)
      Invoke HTTP POST method for the current request asynchronously.
      Future<Response> put(Entity<?> entity)
      Invoke HTTP PUT method for the current request asynchronously.
      <T> Future<T> put(Entity<?> entity, Class<T> responseType)
      Invoke HTTP PUT method for the current request asynchronously.
      <T> Future<T> put(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP PUT method for the current request asynchronously.
      <T> Future<T> put(Entity<?> entity, InvocationCallback<T> callback)
      Invoke HTTP PUT method for the current request asynchronously.
      Future<Response> trace()
      Invoke HTTP TRACE method for the current request asynchronously.
      <T> Future<T> trace(Class<T> responseType)
      Invoke HTTP TRACE method for the current request asynchronously.
      <T> Future<T> trace(GenericType<T> responseType)
      Invoke HTTP TRACE method for the current request asynchronously.
      <T> Future<T> trace(InvocationCallback<T> callback)
      Invoke HTTP TRACE method for the current request asynchronously.

    • Method Detail

      • get

        Future<Response> get()
        Invoke HTTP GET method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. Note that in case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Returns:
        invocation response future.

      • get

        <T> Future<T> get(Class<T> responseType)
        Invoke HTTP GET method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - response entity type.
        Parameters:
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • get

        <T> Future<T> get(GenericType<T> responseType)
        Invoke HTTP GET method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • get

        <T> Future<T> get(InvocationCallback<T> callback)
        Invoke HTTP GET method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the generic type of the supplied response callback is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        callback - asynchronous invocation callback.
        Returns:
        invocation response future.

      • put

        Future<Response> put(Entity<?> entity)
        Invoke HTTP PUT method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        Returns:
        invocation response future.

      • put

        <T> Future<T> put(Entity<?> entity,
                Class<T> responseType)
        Invoke HTTP PUT method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - response entity type.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • put

        <T> Future<T> put(Entity<?> entity,
                GenericType<T> responseType)
        Invoke HTTP PUT method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • put

        <T> Future<T> put(Entity<?> entity,
                InvocationCallback<T> callback)
        Invoke HTTP PUT method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the generic type of the supplied response callback is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        callback - asynchronous invocation callback.
        Returns:
        invocation response future.

      • post

        Future<Response> post(Entity<?> entity)
        Invoke HTTP POST method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        Returns:
        invocation response future.
        Throws:
        ProcessingException - in case the invocation processing has failed.

      • post

        <T> Future<T> post(Entity<?> entity,
                 Class<T> responseType)
        Invoke HTTP POST method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - response entity type.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • post

        <T> Future<T> post(Entity<?> entity,
                 GenericType<T> responseType)
        Invoke HTTP POST method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • post

        <T> Future<T> post(Entity<?> entity,
                 InvocationCallback<T> callback)
        Invoke HTTP POST method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the generic type of the supplied response callback is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        callback - asynchronous invocation callback.
        Returns:
        invocation response future.

      • delete

        Future<Response> delete()
        Invoke HTTP DELETE method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Returns:
        invocation response future.

      • delete

        <T> Future<T> delete(Class<T> responseType)
        Invoke HTTP DELETE method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - response entity type.
        Parameters:
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • delete

        <T> Future<T> delete(GenericType<T> responseType)
        Invoke HTTP DELETE method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • delete

        <T> Future<T> delete(InvocationCallback<T> callback)
        Invoke HTTP DELETE method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the generic type of the supplied response callback is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        callback - asynchronous invocation callback.
        Returns:
        invocation response future.

      • head

        Future<Response> head()
        Invoke HTTP HEAD method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Returns:
        invocation response future.

      • head

        Future<Response> head(InvocationCallback<Response> callback)
        Invoke HTTP HEAD method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Parameters:
        callback - asynchronous invocation callback.
        Returns:
        invocation response future.

      • options

        Future<Response> options()
        Invoke HTTP OPTIONS method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Returns:
        invocation response future.

      • options

        <T> Future<T> options(Class<T> responseType)
        Invoke HTTP OPTIONS method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - response entity type.
        Parameters:
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • options

        <T> Future<T> options(GenericType<T> responseType)
        Invoke HTTP OPTIONS method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • options

        <T> Future<T> options(InvocationCallback<T> callback)
        Invoke HTTP OPTIONS method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the generic type of the supplied response callback is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        callback - asynchronous invocation callback.
        Returns:
        invocation response future.

      • trace

        Future<Response> trace()
        Invoke HTTP TRACE method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Returns:
        invocation response future.

      • trace

        <T> Future<T> trace(Class<T> responseType)
        Invoke HTTP TRACE method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - response entity type.
        Parameters:
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • trace

        <T> Future<T> trace(GenericType<T> responseType)
        Invoke HTTP TRACE method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • trace

        <T> Future<T> trace(InvocationCallback<T> callback)
        Invoke HTTP TRACE method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the generic type of the supplied response callback is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        callback - asynchronous invocation callback.
        Returns:
        invocation response future.

      • method

        Future<Response> method(String name)
        Invoke an arbitrary method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Parameters:
        name - method name.
        Returns:
        invocation response future.

      • method

        <T> Future<T> method(String name,
                   Class<T> responseType)
        Invoke an arbitrary method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - response entity type.
        Parameters:
        name - method name.
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • method

        <T> Future<T> method(String name,
                   GenericType<T> responseType)
        Invoke an arbitrary method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        name - method name.
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • method

        <T> Future<T> method(String name,
                   InvocationCallback<T> callback)
        Invoke an arbitrary method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the generic type of the supplied response callback is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        name - method name.
        callback - asynchronous invocation callback.
        Returns:
        invocation response future.

      • method

        Future<Response> method(String name,
                      Entity<?> entity)
        Invoke an arbitrary method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Parameters:
        name - method name.
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        Returns:
        invocation response future.

      • method

        <T> Future<T> method(String name,
                   Entity<?> entity,
                   Class<T> responseType)
        Invoke an arbitrary method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - response entity type.
        Parameters:
        name - method name.
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • method

        <T> Future<T> method(String name,
                   Entity<?> entity,
                   GenericType<T> responseType)
        Invoke an arbitrary method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        name - method name.
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response future.

      • method

        <T> Future<T> method(String name,
                   Entity<?> entity,
                   InvocationCallback<T> callback)
        Invoke an arbitrary method for the current request asynchronously.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the generic type of the supplied response callback is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response entity type.
        Parameters:
        name - method name.
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        callback - asynchronous invocation callback.
        Returns:
        invocation response future.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Client (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface Client

  • All Superinterfaces:
    Configurable<Client>

    public interface Client
extends Configurable<Client>
    Client is the main entry point to the fluent API used to build and execute client requests in order to consume responses returned.

    Clients are heavy-weight objects that manage the client-side communication infrastructure. Initialization as well as disposal of a Client instance may be a rather expensive operation. It is therefore advised to construct only a small number of Client instances in the application. Client instances must be properly closed before being disposed to avoid leaking resources.

    Since:
    2.0
    Author:
    Marek Potociar
    See Also:
    Configurable

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Close client instance and all it's associated resources.
      HostnameVerifier getHostnameVerifier()
      Get the hostname verifier configured in the client or null in case no hostname verifier has been configured.
      SSLContext getSslContext()
      Get the SSL context configured to be used with the current client run-time.
      Invocation.Builder invocation(Link link)
      Build an invocation builder from a link.
      WebTarget target(Link link)
      Build a new web resource target.
      WebTarget target(String uri)
      Build a new web resource target.
      WebTarget target(URI uri)
      Build a new web resource target.
      WebTarget target(UriBuilder uriBuilder)
      Build a new web resource target.

      • Methods inherited from interface javax.ws.rs.core.Configurable

        getConfiguration, property, register, register, register, register, register, register, register, register

    • Method Detail

      • close

        void close()
        Close client instance and all it's associated resources. Subsequent calls have no effect and are ignored. Once the client is closed, invoking any other method on the client instance would result in an IllegalStateException being thrown.

        Calling this method effectively invalidates all resource targets produced by the client instance. Invoking any method on such targets once the client is closed would result in an IllegalStateException being thrown.

      • target

        WebTarget target(String uri)
        Build a new web resource target.
        Parameters:
        uri - web resource URI. May contain template parameters. Must not be null.
        Returns:
        web resource target bound to the provided URI.
        Throws:
        IllegalArgumentException - in case the supplied string is not a valid URI template.
        NullPointerException - in case the supplied argument is null.

      • target

        WebTarget target(URI uri)
        Build a new web resource target.
        Parameters:
        uri - web resource URI. Must not be null.
        Returns:
        web resource target bound to the provided URI.
        Throws:
        NullPointerException - in case the supplied argument is null.

      • target

        WebTarget target(UriBuilder uriBuilder)
        Build a new web resource target.
        Parameters:
        uriBuilder - web resource URI represented as URI builder. Must not be null.
        Returns:
        web resource target bound to the provided URI.
        Throws:
        NullPointerException - in case the supplied argument is null.

      • target

        WebTarget target(Link link)
        Build a new web resource target.
        Parameters:
        link - link to a web resource. Must not be null.
        Returns:
        web resource target bound to the linked web resource.
        Throws:
        NullPointerException - in case the supplied argument is null.

      • invocation

        Invocation.Builder invocation(Link link)

        Build an invocation builder from a link. It uses the URI and the type of the link to initialize the invocation builder. The type is used as the initial value for the HTTP Accept header, if present.

        Parameters:
        link - link to build invocation from. Must not be null.
        Returns:
        newly created invocation builder.
        Throws:
        NullPointerException - in case link is null.

      • getSslContext

        SSLContext getSslContext()
        Get the SSL context configured to be used with the current client run-time.
        Returns:
        SSL context configured to be used with the current client run-time.

      • getHostnameVerifier

        HostnameVerifier getHostnameVerifier()
        Get the hostname verifier configured in the client or null in case no hostname verifier has been configured.
        Returns:
        client hostname verifier or null if not set.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Class ClientBuilder

  • java.lang.Object
    • javax.ws.rs.client.ClientBuilder
  • All Implemented Interfaces:
    Configurable<ClientBuilder>

    public abstract class ClientBuilder
extends Object
implements Configurable<ClientBuilder>
    Main entry point to the client API used to bootstrap Client instances.
    Since:
    2.0
    Author:
    Marek Potociar

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String JAXRS_DEFAULT_CLIENT_BUILDER_PROPERTY
      Name of the property identifying the ClientBuilder implementation to be returned from newBuilder().

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected ClientBuilder()
      Allows custom implementations to extend the ClientBuilder class.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Client build()
      Build a new client instance using all the configuration previously specified in this client builder.
      abstract ClientBuilder hostnameVerifier(HostnameVerifier verifier)
      Set the hostname verifier to be used by the client to verify the endpoint's hostname against it's identification information.
      abstract ClientBuilder keyStore(KeyStore keyStore, char[] password)
      Set the client-side key store.
      ClientBuilder keyStore(KeyStore keyStore, String password)
      Set the client-side key store.
      static ClientBuilder newBuilder()
      Create a new ClientBuilder instance using the default client builder implementation class provided by the JAX-RS implementation provider.
      static Client newClient()
      Create a new Client instance using the default client builder implementation class provided by the JAX-RS implementation provider.
      static Client newClient(Configuration configuration)
      Create a new custom-configured Client instance using the default client builder implementation class provided by the JAX-RS implementation provider.
      abstract ClientBuilder sslContext(SSLContext sslContext)
      Set the SSL context that will be used when creating secured transport connections to server endpoints from web targets created by the client instance that is using this SSL context.
      abstract ClientBuilder trustStore(KeyStore trustStore)
      Set the client-side trust store.
      abstract ClientBuilder withConfig(Configuration config)
      Set the internal configuration state to an externally provided configuration state.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.ws.rs.core.Configurable

        getConfiguration, property, register, register, register, register, register, register, register, register

    • Field Detail

      • JAXRS_DEFAULT_CLIENT_BUILDER_PROPERTY

        public static final String JAXRS_DEFAULT_CLIENT_BUILDER_PROPERTY
        Name of the property identifying the ClientBuilder implementation to be returned from newBuilder().
        See Also:
        Constant Field Values

    • Constructor Detail

      • ClientBuilder

        protected ClientBuilder()
        Allows custom implementations to extend the ClientBuilder class.

    • Method Detail

      • newBuilder

        public static ClientBuilder newBuilder()
        Create a new ClientBuilder instance using the default client builder implementation class provided by the JAX-RS implementation provider.
        Returns:
        new client builder instance.

      • newClient

        public static Client newClient()
        Create a new Client instance using the default client builder implementation class provided by the JAX-RS implementation provider.
        Returns:
        new client instance.

      • newClient

        public static Client newClient(Configuration configuration)
        Create a new custom-configured Client instance using the default client builder implementation class provided by the JAX-RS implementation provider.
        Parameters:
        configuration - data used to provide initial configuration for the new client instance.
        Returns:
        new configured client instance.

      • withConfig

        public abstract ClientBuilder withConfig(Configuration config)
        Set the internal configuration state to an externally provided configuration state.
        Parameters:
        config - external configuration state to replace the configuration of this configurable instance.
        Returns:
        the updated client builder instance.

      • sslContext

        public abstract ClientBuilder sslContext(SSLContext sslContext)
        Set the SSL context that will be used when creating secured transport connections to server endpoints from web targets created by the client instance that is using this SSL context. The SSL context is expected to have all the security infrastructure initialized, including the key and trust managers.

        Setting a SSL context instance resets any key store or trust store values previously specified.

        Parameters:
        sslContext - secure socket protocol implementation which acts as a factory for secure socket factories or SSL engines. Must not be null.
        Returns:
        an updated client builder instance.
        Throws:
        NullPointerException - in case the sslContext parameter is null.
        See Also:
        keyStore(java.security.KeyStore, char[]),
keyStore(java.security.KeyStore, String),
trustStore(java.security.KeyStore)

      • keyStore

        public abstract ClientBuilder keyStore(KeyStore keyStore,
                     char[] password)
        Set the client-side key store. Key store contains client's private keys, and the certificates with their corresponding public keys.

        Setting a key store instance resets any SSL context instance value previously specified.

        Note that a custom key store is only required if you want to enable a custom setup of a 2-way SSL connections (client certificate authentication).

        Parameters:
        keyStore - client-side key store. Must not be null.
        password - client key password. Must not be null.
        Returns:
        an updated client builder instance.
        Throws:
        NullPointerException - in case any of the supplied parameters is null.
        See Also:
        sslContext(javax.net.ssl.SSLContext),
keyStore(java.security.KeyStore, String),
trustStore(java.security.KeyStore)

      • keyStore

        public ClientBuilder keyStore(KeyStore keyStore,
                     String password)
        Set the client-side key store. Key store contains client's private keys, and the certificates with their corresponding public keys.

        Setting a key store instance resets any SSL context instance value previously specified.

        Note that for improved security of working with password data and avoid storing passwords in Java string objects, the keyStore(java.security.KeyStore, char[]) version of the method can be utilized. Also note that a custom key store is only required if you want to enable a custom setup of a 2-way SSL connections (client certificate authentication).

        Parameters:
        keyStore - client-side key store. Must not be null.
        password - client key password. Must not be null.
        Returns:
        an updated client builder instance.
        Throws:
        NullPointerException - in case any of the supplied parameters is null.
        See Also:
        sslContext(javax.net.ssl.SSLContext),
keyStore(java.security.KeyStore, char[]),
trustStore(java.security.KeyStore)

      • trustStore

        public abstract ClientBuilder trustStore(KeyStore trustStore)
        Set the client-side trust store. Trust store is expected to contain certificates from other parties the client is you expect to communicate with, or from Certificate Authorities that are trusted to identify other parties.

        Setting a trust store instance resets any SSL context instance value previously specified.

        In case a custom trust store or custom SSL context is not specified, the trust management will be configured to use the default Java runtime settings.

        Parameters:
        trustStore - client-side trust store. Must not be null.
        Returns:
        an updated client builder instance.
        Throws:
        NullPointerException - in case the supplied trust store parameter is null.
        See Also:
        sslContext(javax.net.ssl.SSLContext),
keyStore(java.security.KeyStore, char[]),
keyStore(java.security.KeyStore, String)

      • hostnameVerifier

        public abstract ClientBuilder hostnameVerifier(HostnameVerifier verifier)
        Set the hostname verifier to be used by the client to verify the endpoint's hostname against it's identification information.
        Parameters:
        verifier - hostname verifier.
        Returns:
        an updated client builder instance.

      • build

        public abstract Client build()
        Build a new client instance using all the configuration previously specified in this client builder.
        Returns:
        a new client instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientRequestContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface ClientRequestContext

  • public interface ClientRequestContext
    Client request filter context. A mutable class that provides request-specific information for the filter, such as request URI, message headers, message entity or request-scoped properties. The exposed setters allow modification of the exposed request-specific information.
    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void abortWith(Response response)
      Abort the filter chain with a response.
      List<Locale> getAcceptableLanguages()
      Get a list of languages that are acceptable for the response.
      List<MediaType> getAcceptableMediaTypes()
      Get a list of media types that are acceptable for the response.
      Client getClient()
      Get the client instance associated with the request.
      Configuration getConfiguration()
      Get the immutable configuration of the request.
      Map<String,Cookie> getCookies()
      Get any cookies that accompanied the request.
      Date getDate()
      Get message date.
      Object getEntity()
      Get the message entity Java instance.
      Annotation[] getEntityAnnotations()
      Get the annotations attached to the entity instance.
      Class<?> getEntityClass()
      Get the raw entity type information.
      OutputStream getEntityStream()
      Get the entity output stream.
      Type getEntityType()
      Get the generic entity type information.
      MultivaluedMap<String,Object> getHeaders()
      Get the mutable request headers multivalued map.
      String getHeaderString(String name)
      Get a message header as a single string value.
      Locale getLanguage()
      Get the language of the entity.
      MediaType getMediaType()
      Get the media type of the entity.
      String getMethod()
      Get the request method.
      Object getProperty(String name)
      Returns the property with the given name registered in the current request/response exchange context, or null if there is no property by that name.
      Collection<String> getPropertyNames()
      Returns an immutable collection containing the property names available within the context of the current request/response exchange context.
      MultivaluedMap<String,String> getStringHeaders()
      Get a string view of header values associated with the message.
      URI getUri()
      Get the request URI.
      boolean hasEntity()
      Check if there is an entity available in the request.
      void removeProperty(String name)
      Removes a property with the given name from the current request/response exchange context.
      void setEntity(Object entity)
      Set a new message entity.
      void setEntity(Object entity, Annotation[] annotations, MediaType mediaType)
      Set a new message entity, including the attached annotations and the media type.
      void setEntityStream(OutputStream outputStream)
      Set a new entity output stream.
      void setMethod(String method)
      Set the request method.
      void setProperty(String name, Object object)
      Binds an object to a given property name in the current request/response exchange context.
      void setUri(URI uri)
      Set a new request URI.

    • Method Detail

      • getProperty

        Object getProperty(String name)
        Returns the property with the given name registered in the current request/response exchange context, or null if there is no property by that name.

        A property allows a JAX-RS filters and interceptors to exchange additional custom information not already provided by this interface.

        A list of supported properties can be retrieved using getPropertyNames(). Custom property names should follow the same convention as package names.

        Parameters:
        name - a String specifying the name of the property.
        Returns:
        an Object containing the value of the property, or null if no property exists matching the given name.
        See Also:
        getPropertyNames()

      • getPropertyNames

        Collection<String> getPropertyNames()
        Returns an immutable collection containing the property names available within the context of the current request/response exchange context.

        Use the getProperty(java.lang.String) method with a property name to get the value of a property.

        Returns:
        an immutable collection of property names.
        See Also:
        getProperty(java.lang.String)

      • setProperty

        void setProperty(String name,
               Object object)
        Binds an object to a given property name in the current request/response exchange context. If the name specified is already used for a property, this method will replace the value of the property with the new value.

        A property allows a JAX-RS filters and interceptors to exchange additional custom information not already provided by this interface.

        A list of supported properties can be retrieved using getPropertyNames(). Custom property names should follow the same convention as package names.

        If a null value is passed, the effect is the same as calling the removeProperty(String) method.

        Parameters:
        name - a String specifying the name of the property.
        object - an Object representing the property to be bound.

      • removeProperty

        void removeProperty(String name)
        Removes a property with the given name from the current request/response exchange context. After removal, subsequent calls to getProperty(java.lang.String) to retrieve the property value will return null.
        Parameters:
        name - a String specifying the name of the property to be removed.

      • getUri

        URI getUri()
        Get the request URI.
        Returns:
        request URI.

      • setUri

        void setUri(URI uri)
        Set a new request URI.
        Parameters:
        uri - new request URI.

      • getMethod

        String getMethod()
        Get the request method.
        Returns:
        the request method.
        See Also:
        HttpMethod

      • setMethod

        void setMethod(String method)
        Set the request method.
        Parameters:
        method - new request method.
        See Also:
        HttpMethod

      • getHeaders

        MultivaluedMap<String,Object> getHeaders()
        Get the mutable request headers multivalued map.
        Returns:
        mutable multivalued map of request headers.
        See Also:
        getStringHeaders(), getHeaderString(String)

      • getStringHeaders

        MultivaluedMap<String,String> getStringHeaders()
        Get a string view of header values associated with the message. Changes in the underlying headers map are reflected in this view.

        The method converts the non-string header values to strings using a RuntimeDelegate.HeaderDelegate if one is available via RuntimeDelegate.createHeaderDelegate(java.lang.Class) for the class of the value or using the values toString method if a header delegate is not available.

        Returns:
        response headers as a string view of header values.
        See Also:
        getHeaders(), getHeaderString(String)

      • getHeaderString

        String getHeaderString(String name)
        Get a message header as a single string value. Each single header value is converted to String using a RuntimeDelegate.HeaderDelegate if one is available via RuntimeDelegate.createHeaderDelegate(java.lang.Class) for the header value class or using its toString method if a header delegate is not available.
        Parameters:
        name - the message header.
        Returns:
        the message header value. If the message header is not present then null is returned. If the message header is present but has no value then the empty string is returned. If the message header is present more than once then the values of joined together and separated by a ',' character.
        See Also:
        getHeaders(), getStringHeaders()

      • getDate

        Date getDate()
        Get message date.
        Returns:
        the message date, otherwise null if not present.

      • getLanguage

        Locale getLanguage()
        Get the language of the entity.
        Returns:
        the language of the entity or null if not specified

      • getMediaType

        MediaType getMediaType()
        Get the media type of the entity.
        Returns:
        the media type or null if not specified (e.g. there's no request entity).

      • getAcceptableMediaTypes

        List<MediaType> getAcceptableMediaTypes()
        Get a list of media types that are acceptable for the response.
        Returns:
        a read-only list of requested response media types sorted according to their q-value, with highest preference first.

      • getAcceptableLanguages

        List<Locale> getAcceptableLanguages()
        Get a list of languages that are acceptable for the response.
        Returns:
        a read-only list of acceptable languages sorted according to their q-value, with highest preference first.

      • getCookies

        Map<String,Cookie> getCookies()
        Get any cookies that accompanied the request.
        Returns:
        a read-only map of cookie name (String) to Cookie.

      • hasEntity

        boolean hasEntity()
        Check if there is an entity available in the request. The method returns true if the entity is present, returns false otherwise.
        Returns:
        true if there is an entity present in the message, false otherwise.

      • getEntity

        Object getEntity()
        Get the message entity Java instance. Returns null if the message does not contain an entity.
        Returns:
        the message entity or null if message does not contain an entity body.

      • getEntityClass

        Class<?> getEntityClass()
        Get the raw entity type information.
        Returns:
        raw entity type.

      • getEntityType

        Type getEntityType()
        Get the generic entity type information.
        Returns:
        generic entity type.

      • setEntity

        void setEntity(Object entity)
        Set a new message entity. The existing entity annotations and media type are preserved.

        It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required.

        Parameters:
        entity - entity object.
        See Also:
        setEntity(Object, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType), MessageBodyWriter

      • setEntity

        void setEntity(Object entity,
             Annotation[] annotations,
             MediaType mediaType)
        Set a new message entity, including the attached annotations and the media type.

        It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required.

        Parameters:
        entity - entity object.
        annotations - annotations attached to the entity instance.
        mediaType - entity media type.
        See Also:
        setEntity(Object), MessageBodyWriter

      • getEntityAnnotations

        Annotation[] getEntityAnnotations()
        Get the annotations attached to the entity instance.

        Note that the returned annotations array contains only those annotations explicitly attached to entity instance (such as the ones attached using Entity.Entity(Object, javax.ws.rs.core.MediaType, java.lang.annotation.Annotation[]) method). The entity instance annotations array does not include annotations declared on the entity implementation class or its ancestors.

        Returns:
        annotations attached to the entity instance.

      • getEntityStream

        OutputStream getEntityStream()
        Get the entity output stream. The JAX-RS runtime is responsible for closing the output stream.
        Returns:
        entity output stream.

      • setEntityStream

        void setEntityStream(OutputStream outputStream)
        Set a new entity output stream. The JAX-RS runtime is responsible for closing the output stream.
        Parameters:
        outputStream - new entity output stream.

      • getClient

        Client getClient()
        Get the client instance associated with the request.
        Returns:
        client instance associated with the request.

      • getConfiguration

        Configuration getConfiguration()
        Get the immutable configuration of the request.
        Returns:
        immutable request configuration.

      • abortWith

        void abortWith(Response response)
        Abort the filter chain with a response. This method breaks the filter chain processing and returns the provided response back to the client. The provided response goes through the chain of applicable response filters.
        Parameters:
        response - response to be sent back to the client.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientRequestFilter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface ClientRequestFilter

  • public interface ClientRequestFilter
    An extension interface implemented by client request filters. Filters implementing this interface MUST be annotated with @Provider. This type of filters is supported only as part of the Client API.
    Since:
    2.0
    Author:
    Marek Potociar, Santiago Pericas-Geertsen
    See Also:
    ClientResponseFilter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void filter(ClientRequestContext requestContext)
      Filter method called before a request has been dispatched to a client transport layer.

    • Method Detail

      • filter

        void filter(ClientRequestContext requestContext)
            throws IOException
        Filter method called before a request has been dispatched to a client transport layer. Filters in the filter chain are ordered according to their javax.annotation.Priority class-level annotation value.
        Parameters:
        requestContext - request context.
        Throws:
        IOException - if an I/O exception occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientResponseContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface ClientResponseContext

  • public interface ClientResponseContext
    Client response filter context. A mutable class that provides response-specific information for the filter, such as message headers, message entity or request-scoped properties. The exposed setters allow modification of the exposed response-specific information.
    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<String> getAllowedMethods()
      Get the allowed HTTP methods from the Allow HTTP header.
      Map<String,NewCookie> getCookies()
      Get any new cookies set on the response message.
      Date getDate()
      Get message date.
      InputStream getEntityStream()
      Get the entity input stream.
      EntityTag getEntityTag()
      Get the entity tag.
      MultivaluedMap<String,String> getHeaders()
      Get the mutable response headers multivalued map.
      String getHeaderString(String name)
      Get a message header as a single string value.
      Locale getLanguage()
      Get the language of the entity.
      Date getLastModified()
      Get the last modified date.
      int getLength()
      Get Content-Length value.
      Link getLink(String relation)
      Get the link for the relation.
      Link.Builder getLinkBuilder(String relation)
      Convenience method that returns a Link.Builder for the relation.
      Set<Link> getLinks()
      Get the links attached to the message as header.
      URI getLocation()
      Get the location.
      MediaType getMediaType()
      Get the media type of the entity.
      int getStatus()
      Get the status code associated with the response.
      Response.StatusType getStatusInfo()
      Get the complete status information associated with the response.
      boolean hasEntity()
      Check if there is a non-empty entity input stream is available in the response message.
      boolean hasLink(String relation)
      Check if link for relation exists.
      void setEntityStream(InputStream input)
      Set a new entity input stream.
      void setStatus(int code)
      Set a new response status code.
      void setStatusInfo(Response.StatusType statusInfo)
      Set the complete status information (status code and reason phrase) associated with the response.

    • Method Detail

      • getStatus

        int getStatus()
        Get the status code associated with the response.
        Returns:
        the response status code or -1 if the status was not set.

      • setStatus

        void setStatus(int code)
        Set a new response status code.
        Parameters:
        code - new status code.

      • getStatusInfo

        Response.StatusType getStatusInfo()
        Get the complete status information associated with the response.
        Returns:
        the response status information or null if the status was not set.

      • setStatusInfo

        void setStatusInfo(Response.StatusType statusInfo)
        Set the complete status information (status code and reason phrase) associated with the response.
        Parameters:
        statusInfo - the response status information.

      • getHeaders

        MultivaluedMap<String,String> getHeaders()
        Get the mutable response headers multivalued map.
        Returns:
        mutable multivalued map of response headers.
        See Also:
        getHeaderString(String)

      • getHeaderString

        String getHeaderString(String name)
        Get a message header as a single string value.
        Parameters:
        name - the message header.
        Returns:
        the message header value. If the message header is not present then null is returned. If the message header is present but has no value then the empty string is returned. If the message header is present more than once then the values of joined together and separated by a ',' character.
        See Also:
        getHeaders()

      • getAllowedMethods

        Set<String> getAllowedMethods()
        Get the allowed HTTP methods from the Allow HTTP header.
        Returns:
        the allowed HTTP methods, all methods will returned as upper case strings.

      • getDate

        Date getDate()
        Get message date.
        Returns:
        the message date, otherwise null if not present.

      • getLanguage

        Locale getLanguage()
        Get the language of the entity.
        Returns:
        the language of the entity or null if not specified

      • getLength

        int getLength()
        Get Content-Length value.
        Returns:
        Content-Length as integer if present and valid number. In other cases returns -1.

      • getMediaType

        MediaType getMediaType()
        Get the media type of the entity.
        Returns:
        the media type or null if not specified (e.g. there's no response entity).

      • getCookies

        Map<String,NewCookie> getCookies()
        Get any new cookies set on the response message.
        Returns:
        a read-only map of cookie name (String) to a new cookie.

      • getEntityTag

        EntityTag getEntityTag()
        Get the entity tag.
        Returns:
        the entity tag, otherwise null if not present.

      • getLastModified

        Date getLastModified()
        Get the last modified date.
        Returns:
        the last modified date, otherwise null if not present.

      • getLocation

        URI getLocation()
        Get the location.
        Returns:
        the location URI, otherwise null if not present.

      • getLinks

        Set<Link> getLinks()
        Get the links attached to the message as header.
        Returns:
        links, may return empty Set if no links are present. Never returns null.

      • hasLink

        boolean hasLink(String relation)
        Check if link for relation exists.
        Parameters:
        relation - link relation.
        Returns:
        true if the for the relation link exists, false otherwise.

      • getLink

        Link getLink(String relation)
        Get the link for the relation.
        Parameters:
        relation - link relation.
        Returns:
        the link for the relation, otherwise null if not present.

      • getLinkBuilder

        Link.Builder getLinkBuilder(String relation)
        Convenience method that returns a Link.Builder for the relation.
        Parameters:
        relation - link relation.
        Returns:
        the link builder for the relation, otherwise null if not present.

      • hasEntity

        boolean hasEntity()
        Check if there is a non-empty entity input stream is available in the response message. The method returns true if the entity is present, returns false otherwise.
        Returns:
        true if there is an entity present in the message, false otherwise.

      • getEntityStream

        InputStream getEntityStream()
        Get the entity input stream. The JAX-RS runtime is responsible for closing the input stream.
        Returns:
        entity input stream.

      • setEntityStream

        void setEntityStream(InputStream input)
        Set a new entity input stream. The JAX-RS runtime is responsible for closing the input stream.
        Parameters:
        input - new entity input stream.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientResponseFilter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface ClientResponseFilter

  • public interface ClientResponseFilter
    An extension interface implemented by client response filters. Filters implementing this interface MUST be annotated with @Provider. This type of filters is supported only as part of the Client API.
    Since:
    2.0
    Author:
    Marek Potociar, Santiago Pericas-Geertsen
    See Also:
    ClientRequestFilter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void filter(ClientRequestContext requestContext, ClientResponseContext responseContext)
      Filter method called after a response has been provided for a request (either by a request filter or when the HTTP invocation returns.

    • Method Detail

      • filter

        void filter(ClientRequestContext requestContext,
          ClientResponseContext responseContext)
            throws IOException
        Filter method called after a response has been provided for a request (either by a request filter or when the HTTP invocation returns. Filters in the filter chain are ordered according to their javax.annotation.Priority class-level annotation value.
        Parameters:
        requestContext - request context.
        responseContext - response context.
        Throws:
        IOException - if an I/O exception occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Entity (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Class Entity<T>

  • java.lang.Object
    • javax.ws.rs.client.Entity<T>
  • Type Parameters:
    T - entity type.

    public final class Entity<T>
extends Object
    Encapsulates message entity including the associated variant information.
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static <T> Entity<T> entity(T entity, MediaType mediaType)
      Create an entity using a supplied content media type.
      static <T> Entity<T> entity(T entity, MediaType mediaType, Annotation[] annotations)
      Create an entity using a supplied content media type.
      static <T> Entity<T> entity(T entity, String mediaType)
      Create an entity using a supplied content media type.
      static <T> Entity<T> entity(T entity, Variant variant)
      Create an entity using a supplied content media type.
      static <T> Entity<T> entity(T entity, Variant variant, Annotation[] annotations)
      Create an entity using a supplied content media type.
      static Entity<Form> form(Form form)
      Create an "application/x-www-form-urlencoded" form entity.
      static Entity<Form> form(MultivaluedMap<String,String> formData)
      Create an "application/x-www-form-urlencoded" form entity.
      Annotation[] getAnnotations()
      Get the entity annotations.
      String getEncoding()
      Get entity encoding.
      T getEntity()
      Get entity data.
      Locale getLanguage()
      Get entity language.
      MediaType getMediaType()
      Get entity media type.
      Variant getVariant()
      Get entity variant information.
      static <T> Entity<T> html(T entity)
      Create a "text/html" entity.
      static <T> Entity<T> json(T entity)
      Create an "application/json" entity.
      static <T> Entity<T> text(T entity)
      Create a "text/plain" entity.
      static <T> Entity<T> xhtml(T entity)
      Create an "application/xhtml+xml" entity.
      static <T> Entity<T> xml(T entity)
      Create an "application/xml" entity.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • entity

        public static <T> Entity<T> entity(T entity,
                   MediaType mediaType)
        Create an entity using a supplied content media type.
        Type Parameters:
        T - entity Java type.
        Parameters:
        entity - entity data.
        mediaType - entity content type.
        Returns:
        entity instance.

      • entity

        public static <T> Entity<T> entity(T entity,
                   MediaType mediaType,
                   Annotation[] annotations)
        Create an entity using a supplied content media type.
        Type Parameters:
        T - entity Java type.
        Parameters:
        entity - entity data.
        mediaType - entity content type.
        annotations - entity annotations.
        Returns:
        entity instance.

      • entity

        public static <T> Entity<T> entity(T entity,
                   String mediaType)
        Create an entity using a supplied content media type.
        Type Parameters:
        T - entity Java type.
        Parameters:
        entity - entity data.
        mediaType - entity content type.
        Returns:
        entity instance.
        Throws:
        IllegalArgumentException - if the supplied string cannot be parsed or is null.

      • entity

        public static <T> Entity<T> entity(T entity,
                   Variant variant)
        Create an entity using a supplied content media type.
        Type Parameters:
        T - entity Java type.
        Parameters:
        entity - entity data.
        variant - entity variant information.
        Returns:
        entity instance.

      • entity

        public static <T> Entity<T> entity(T entity,
                   Variant variant,
                   Annotation[] annotations)
        Create an entity using a supplied content media type.
        Type Parameters:
        T - entity Java type.
        Parameters:
        entity - entity data.
        variant - entity variant information.
        annotations - entity annotations.
        Returns:
        entity instance.

      • text

        public static <T> Entity<T> text(T entity)
        Create a "text/plain" entity.
        Type Parameters:
        T - entity Java type.
        Parameters:
        entity - entity data.
        Returns:
        "text/plain" entity instance.

      • xml

        public static <T> Entity<T> xml(T entity)
        Create an "application/xml" entity.
        Type Parameters:
        T - entity Java type.
        Parameters:
        entity - entity data.
        Returns:
        "application/xml" entity instance.

      • json

        public static <T> Entity<T> json(T entity)
        Create an "application/json" entity.
        Type Parameters:
        T - entity Java type.
        Parameters:
        entity - entity data.
        Returns:
        "application/json" entity instance.

      • html

        public static <T> Entity<T> html(T entity)
        Create a "text/html" entity.
        Type Parameters:
        T - entity Java type.
        Parameters:
        entity - entity data.
        Returns:
        "text/html" entity instance.

      • xhtml

        public static <T> Entity<T> xhtml(T entity)
        Create an "application/xhtml+xml" entity.
        Type Parameters:
        T - entity Java type.
        Parameters:
        entity - entity data.
        Returns:
        "application/xhtml+xml" entity instance.

      • form

        public static Entity<Form> form(Form form)
        Create an "application/x-www-form-urlencoded" form entity.
        Parameters:
        form - form data.
        Returns:
        "application/x-www-form-urlencoded" form entity instance.

      • form

        public static Entity<Form> form(MultivaluedMap<String,String> formData)
        Create an "application/x-www-form-urlencoded" form entity.
        Parameters:
        formData - multivalued map representing the form data.
        Returns:
        "application/x-www-form-urlencoded" form entity instance.

      • getVariant

        public Variant getVariant()
        Get entity variant information.
        Returns:
        entity variant information.

      • getMediaType

        public MediaType getMediaType()
        Get entity media type.
        Returns:
        entity media type.

      • getEncoding

        public String getEncoding()
        Get entity encoding.
        Returns:
        entity encoding.

      • getLanguage

        public Locale getLanguage()
        Get entity language.
        Returns:
        entity language.

      • getEntity

        public T getEntity()
        Get entity data.
        Returns:
        entity data.

      • getAnnotations

        public Annotation[] getAnnotations()
        Get the entity annotations.
        Returns:
        entity annotations if set, an empty annotation array if no entity annotations have been specified.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Invocation (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface Invocation

  • public interface Invocation
    A client request invocation. An invocation is a request that has been prepared and is ready for execution. Invocations provide a generic (command) interface that enables a separation of concerns between the creator and the submitter. In particular, the submitter does not need to know how the invocation was prepared, but only how it should be executed (synchronously or asynchronously) and when.
    Author:
    Marek Potociar
    See Also:
    Invocation.Builder

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  Invocation.Builder
      A client request invocation builder.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Response invoke()
      Synchronously invoke the request and receive a response back.
      <T> T invoke(Class<T> responseType)
      Synchronously invoke the request and receive a response of the specified type back.
      <T> T invoke(GenericType<T> responseType)
      Synchronously invoke the request and receive a response of the specified generic type back.
      Invocation property(String name, Object value)
      Set a new property in the context of a request represented by this invocation.
      Future<Response> submit()
      Submit the request for an asynchronous invocation and receive a future response back.
      <T> Future<T> submit(Class<T> responseType)
      Submit the request for an asynchronous invocation and receive a future response of the specified type back.
      <T> Future<T> submit(GenericType<T> responseType)
      Submit the request for an asynchronous invocation and receive a future response of the specified generic type back.
      <T> Future<T> submit(InvocationCallback<T> callback)
      Submit the request for an asynchronous invocation and register an InvocationCallback to process the future result of the invocation.

    • Method Detail

      • property

        Invocation property(String name,
                  Object value)
        Set a new property in the context of a request represented by this invocation.

        The property is available for a later retrieval via ClientRequestContext.getProperty(String) or InterceptorContext.getProperty(String). If a property with a given name is already set in the request context, the existing value of the property will be updated. Setting a null value into a property effectively removes the property from the request property bag.

        Parameters:
        name - property name.
        value - (new) property value. null value removes the property with the given name.
        Returns:
        the updated invocation.
        See Also:
        Invocation.Builder.property(String, Object)

      • invoke

        Response invoke()
        Synchronously invoke the request and receive a response back.
        Returns:
        response object as a result of the request invocation.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.

      • invoke

        <T> T invoke(Class<T> responseType)
        Synchronously invoke the request and receive a response of the specified type back.
        Type Parameters:
        T - response type
        Parameters:
        responseType - Java type the response should be converted into.
        Returns:
        response object of the specified type as a result of the request invocation.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful.

      • invoke

        <T> T invoke(GenericType<T> responseType)
        Synchronously invoke the request and receive a response of the specified generic type back.
        Type Parameters:
        T - generic response type
        Parameters:
        responseType - type literal representing a generic Java type the response should be converted into.
        Returns:
        response object of the specified generic type as a result of the request invocation.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful.

      • submit

        Future<Response> submit()
        Submit the request for an asynchronous invocation and receive a future response back.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps a ProcessingException thrown in case of an invocation processing failure. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Returns:
        future response object as a result of the request invocation.

      • submit

        <T> Future<T> submit(Class<T> responseType)
        Submit the request for an asynchronous invocation and receive a future response of the specified type back.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - response type
        Parameters:
        responseType - Java type the response should be converted into.
        Returns:
        future response object of the specified type as a result of the request invocation.

      • submit

        <T> Future<T> submit(GenericType<T> responseType)
        Submit the request for an asynchronous invocation and receive a future response of the specified generic type back.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the specified response type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - generic response type
        Parameters:
        responseType - type literal representing a generic Java type the response should be converted into.
        Returns:
        future response object of the specified generic type as a result of the request invocation.

      • submit

        <T> Future<T> submit(InvocationCallback<T> callback)
        Submit the request for an asynchronous invocation and register an InvocationCallback to process the future result of the invocation.

        Note that calling the Future.get() method on the returned Future instance may throw an ExecutionException that wraps either a ProcessingException thrown in case of an invocation processing failure or a WebApplicationException or one of its subclasses thrown in case the received response status code is not successful and the generic type of the supplied response callback is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed.

        Type Parameters:
        T - response type
        Parameters:
        callback - invocation callback for asynchronous processing of the request invocation result.
        Returns:
        future response object of the specified type as a result of the request invocation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Invocation.Builder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface Invocation.Builder

  • All Superinterfaces:
    SyncInvoker
    Enclosing interface:
    Invocation

    public static interface Invocation.Builder
extends SyncInvoker
    A client request invocation builder. The builder, obtained via a call to one of the request(...) methods on a resource target, provides methods for preparing a client request invocation. Once the request is prepared the invocation builder can be either used to build an Invocation with a generic execution interface:
       Client client = ClientBuilder.newClient();
   WebTarget resourceTarget = client.target("http://examples.jaxrs.com/");

   // Build a HTTP GET request that accepts "text/plain" response type
   // and contains a custom HTTP header entry "Foo: bar".
   Invocation invocation = resourceTarget.request("text/plain")
           .header("Foo", "bar").buildGet();

   // Invoke the request using generic interface
   String response = invocation.invoke(String.class);
    Alternatively, one of the inherited synchronous invocation methods can be used to invoke the prepared request and return the server response in a single step, e.g.:
       Client client = ClientBuilder.newClient();
   WebTarget resourceTarget = client.target("http://examples.jaxrs.com/");

   // Build and invoke the get request in a single step
   String response = resourceTarget.request("text/plain")
           .header("Foo", "bar").get(String.class);
    Once the request is fully prepared for invoking, switching to an asynchronous invocation mode is possible by calling the async() method on the builder, e.g.:
       Client client = ClientBuilder.newClient();
   WebTarget resourceTarget = client.target("http://examples.jaxrs.com/");

   // Build and invoke the get request asynchronously in a single step
   Future response = resourceTarget.request("text/plain")
           .header("Foo", "bar").async().get(String.class);

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Invocation.Builder accept(MediaType... mediaTypes)
      Add the accepted response media types.
      Invocation.Builder accept(String... mediaTypes)
      Add the accepted response media types.
      Invocation.Builder acceptEncoding(String... encodings)
      Add acceptable encodings.
      Invocation.Builder acceptLanguage(Locale... locales)
      Add acceptable languages.
      Invocation.Builder acceptLanguage(String... locales)
      Add acceptable languages.
      AsyncInvoker async()
      Access the asynchronous uniform request invocation interface to asynchronously invoke the built request.
      Invocation build(String method)
      Build a request invocation using an arbitrary request method name.
      Invocation build(String method, Entity<?> entity)
      Build a request invocation using an arbitrary request method name and request entity.
      Invocation buildDelete()
      Build a DELETE request invocation.
      Invocation buildGet()
      Build a GET request invocation.
      Invocation buildPost(Entity<?> entity)
      Build a POST request invocation.
      Invocation buildPut(Entity<?> entity)
      Build a PUT request invocation.
      Invocation.Builder cacheControl(CacheControl cacheControl)
      Set the cache control data of the message.
      Invocation.Builder cookie(Cookie cookie)
      Add a cookie to be set.
      Invocation.Builder cookie(String name, String value)
      Add a cookie to be set.
      Invocation.Builder header(String name, Object value)
      Add an arbitrary header.
      Invocation.Builder headers(MultivaluedMap<String,Object> headers)
      Replaces all existing headers with the newly supplied headers.
      Invocation.Builder property(String name, Object value)
      Set a new property in the context of a request represented by this invocation builder.

      • Methods inherited from interface javax.ws.rs.client.SyncInvoker

        delete, delete, delete, get, get, get, head, method, method, method, method, method, method, options, options, options, post, post, post, put, put, put, trace, trace, trace

    • Method Detail

      • build

        Invocation build(String method)
        Build a request invocation using an arbitrary request method name.
        Parameters:
        method - request method name.
        Returns:
        invocation encapsulating the built request.

      • build

        Invocation build(String method,
               Entity<?> entity)
        Build a request invocation using an arbitrary request method name and request entity.
        Parameters:
        method - request method name.
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        Returns:
        invocation encapsulating the built request.

      • buildGet

        Invocation buildGet()
        Build a GET request invocation.
        Returns:
        invocation encapsulating the built GET request.

      • buildDelete

        Invocation buildDelete()
        Build a DELETE request invocation.
        Returns:
        invocation encapsulating the built DELETE request.

      • buildPost

        Invocation buildPost(Entity<?> entity)
        Build a POST request invocation.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        Returns:
        invocation encapsulating the built POST request.

      • buildPut

        Invocation buildPut(Entity<?> entity)
        Build a PUT request invocation.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        Returns:
        invocation encapsulating the built PUT request.

      • async

        AsyncInvoker async()
        Access the asynchronous uniform request invocation interface to asynchronously invoke the built request.
        Returns:
        asynchronous uniform request invocation interface.

      • accept

        Invocation.Builder accept(String... mediaTypes)
        Add the accepted response media types.
        Parameters:
        mediaTypes - accepted response media types.
        Returns:
        the updated builder.

      • accept

        Invocation.Builder accept(MediaType... mediaTypes)
        Add the accepted response media types.
        Parameters:
        mediaTypes - accepted response media types.
        Returns:
        the updated builder.

      • acceptLanguage

        Invocation.Builder acceptLanguage(Locale... locales)
        Add acceptable languages.
        Parameters:
        locales - an array of the acceptable languages.
        Returns:
        the updated builder.

      • acceptLanguage

        Invocation.Builder acceptLanguage(String... locales)
        Add acceptable languages.
        Parameters:
        locales - an array of the acceptable languages.
        Returns:
        the updated builder.

      • acceptEncoding

        Invocation.Builder acceptEncoding(String... encodings)
        Add acceptable encodings.
        Parameters:
        encodings - an array of the acceptable encodings.
        Returns:
        the updated builder.

      • cookie

        Invocation.Builder cookie(Cookie cookie)
        Add a cookie to be set.
        Parameters:
        cookie - to be set.
        Returns:
        the updated builder.

      • cookie

        Invocation.Builder cookie(String name,
                        String value)
        Add a cookie to be set.
        Parameters:
        name - the name of the cookie.
        value - the value of the cookie.
        Returns:
        the updated builder.

      • cacheControl

        Invocation.Builder cacheControl(CacheControl cacheControl)
        Set the cache control data of the message.
        Parameters:
        cacheControl - the cache control directives, if null any existing cache control directives will be removed.
        Returns:
        the updated builder.

      • header

        Invocation.Builder header(String name,
                        Object value)
        Add an arbitrary header.
        Parameters:
        name - the name of the header
        value - the value of the header, the header will be serialized using a RuntimeDelegate.HeaderDelegate if one is available via RuntimeDelegate.createHeaderDelegate(java.lang.Class) for the class of value or using its toString method if a header delegate is not available. If value is null then all current headers of the same name will be removed.
        Returns:
        the updated builder.

      • headers

        Invocation.Builder headers(MultivaluedMap<String,Object> headers)
        Replaces all existing headers with the newly supplied headers.
        Parameters:
        headers - new headers to be set, if null all existing headers will be removed.
        Returns:
        the updated builder.

      • property

        Invocation.Builder property(String name,
                          Object value)
        Set a new property in the context of a request represented by this invocation builder.

        The property is available for a later retrieval via ClientRequestContext.getProperty(String) or InterceptorContext.getProperty(String). If a property with a given name is already set in the request context, the existing value of the property will be updated. Setting a null value into a property effectively removes the property from the request property bag.

        Parameters:
        name - property name.
        value - (new) property value. null value removes the property with the given name.
        Returns:
        the updated builder.
        See Also:
        Invocation.property(String, Object)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvocationCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface InvocationCallback<RESPONSE>

  • Type Parameters:
    RESPONSE - response type. It can be either a general-purpose Response or the anticipated response entity type.

    public interface InvocationCallback<RESPONSE>
    Callback that can be implemented to receive the asynchronous processing events from the invocation processing.
    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void completed(RESPONSE response)
      Called when the invocation was successfully completed.
      void failed(Throwable throwable)
      Called when the invocation has failed for any reason.

    • Method Detail

      • completed

        void completed(RESPONSE response)
        Called when the invocation was successfully completed. Note that this does not necessarily mean the response has bean fully read, which depends on the parameterized invocation callback response type.

        Once this invocation callback method returns, the underlying Response instance will be automatically closed by the runtime.

        Parameters:
        response - response data.

      • failed

        void failed(Throwable throwable)
        Called when the invocation has failed for any reason.

        Note that the provided Throwable may be a ProcessingException in case the invocation processing failure has been caused by a client-side runtime component error. The Throwable may also be a WebApplicationException or one of its subclasses in case the response status code is not successful and the generic callback type is not Response. In case a processing of a properly received response fails, the wrapped processing exception will be of ResponseProcessingException type and will contain the Response instance whose processing has failed. A CancellationException would be indicate that the invocation has been cancelled. An InterruptedException would indicate that the thread executing the invocation has been interrupted.

        Once this invocation callback method returns, the underlying Response instance will be automatically closed by the runtime.

        Parameters:
        throwable - contains failure details.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.ws.rs.client (Java(TM) EE 7 Specification APIs)

javax.ws.rs.client

Interfaces

  • AsyncInvoker
  • Client
  • ClientRequestContext
  • ClientRequestFilter
  • ClientResponseContext
  • ClientResponseFilter
  • Invocation
  • Invocation.Builder
  • InvocationCallback
  • SyncInvoker
  • WebTarget

Classes

  • ClientBuilder
  • Entity

Exceptions

  • ResponseProcessingException


javax.ws.rs.client (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.ws.rs.client

The JAX-RS client API

See: Description

  • Interface Summary
    Interface Description
    AsyncInvoker
    Uniform interface for asynchronous invocation of HTTP methods.
    Client
    Client is the main entry point to the fluent API used to build and execute client requests in order to consume responses returned.
    ClientRequestContext
    Client request filter context.
    ClientRequestFilter
    An extension interface implemented by client request filters.
    ClientResponseContext
    Client response filter context.
    ClientResponseFilter
    An extension interface implemented by client response filters.
    Invocation
    A client request invocation.
    Invocation.Builder
    A client request invocation builder.
    InvocationCallback<RESPONSE>
    Callback that can be implemented to receive the asynchronous processing events from the invocation processing.
    SyncInvoker
    Uniform interface for synchronous invocation of HTTP methods.
    WebTarget
    A resource target identified by the resource URI.
  • Class Summary
    Class Description
    ClientBuilder
    Main entry point to the client API used to bootstrap Client instances.
    Entity<T>
    Encapsulates message entity including the associated variant information.
  • Exception Summary
    Exception Description
    ResponseProcessingException
    JAX-RS client-side runtime processing exception thrown to indicate that response processing has failed (e.g.

Package javax.ws.rs.client Description

The JAX-RS client API

The JAX-RS client API is a Java based API used to access Web resources. It is not restricted to resources implemented using JAX-RS. It provides a higher-level abstraction compared to a plain HTTP communication API as well as integration with the JAX-RS extension providers, in order to enable concise and efficient implementation of reusable client-side solutions that leverage existing and well established client-side implementations of HTTP-based communication.

The JAX-RS Client API encapsulates the Uniform Interface Constraint – a key constraint of the REST architectural style – and associated data elements as client-side Java artifacts and supports a pluggable architecture by defining multiple extension points.

Client API Bootstrapping and Configuration

The main entry point to the API is a ClientBuilder that is used to bootstrap Client instances - configurable, heavy-weight objects that manage the underlying communication infrastructure and serve as the root objects for accessing any Web resource. The following example illustrates the bootstrapping and configuration of a Client instance:
   Client client = ClientBuilder.newClient();

   client.property("MyProperty", "MyValue")
         .register(MyProvider.class)
         .enable(MyFeature.class);

Accessing Web Resources

A Web resource can be accessed using a fluent API in which method invocations are chained to configure and ultimately submit an HTTP request. The following example gets a text/plain representation of the resource identified by "http://example.org/hello":
   Client client = ClientBuilder.newClient();
   Response res = client.target("http://example.org/hello").request("text/plain").get();
Conceptually, the steps required to submit a request are the following:
  1. obtain an Client instance
  2. create a WebTarget pointing at a Web resource
  3. build a request
  4. submit a request to directly retrieve a response or get a prepared Invocation for later submission
As illustrated above, individual Web resources are in the JAX-RS Client API represented as resource targets. Each WebTarget instance is bound to a concrete URI, e.g. "http://example.org/messages/123", or a URI template, e.g. "http://example.org/messages/{id}". That way a single target can either point at a particular resource or represent a larger group of resources (that e.g. share a common configuration) from which concrete resources can be later derived:
   // Parent target for all messages
   WebTarget messages = client.target("http://example.org/messages/{id}");

   WebTarget msg123 = messages.resolveTemplate("id", 123); // New target for http://example.org/messages/123
   WebTarget msg456 = messages.resolveTemplate("id", 456); // New target for http://example.org/messages/456

Generic Invocations

An Invocation is a request that has been prepared and is ready for execution. Invocations provide a generic interface that enables a separation of concerns between the creator and the submitter. In particular, the submitter does not need to know how the invocation was prepared, but only whether it should be executed synchronously or asynchronously.
   Invocation inv1 = client.target("http://example.org/atm/balance")
       .queryParam("card", "111122223333").queryParam("pin", "9876")
       .request("text/plain").buildGet();
   Invocation inv2 = client.target("http://example.org/atm/withdrawal")
       .queryParam("card", "111122223333").queryParam("pin", "9876")
       .request().buildPost(text("50.0")));

   Collection invs = Arrays.asList(inv1, inv2);
   // Executed by the submitter
   Collection ress = Collections.transform(invs, new F() {
      public Response apply(Invocation inv) {return inv.invoke(); }
   });
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.ws.rs.client Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.ws.rs.client

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.ws.rs.client.ClientBuilder (implements javax.ws.rs.core.Configurable<C>)
    • javax.ws.rs.client.Entity<T>
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.ProcessingException
            • javax.ws.rs.client.ResponseProcessingException

Interface Hierarchy

  • javax.ws.rs.client.AsyncInvoker
  • javax.ws.rs.client.ClientRequestContext
  • javax.ws.rs.client.ClientRequestFilter
  • javax.ws.rs.client.ClientResponseContext
  • javax.ws.rs.client.ClientResponseFilter
  • javax.ws.rs.core.Configurable<C>
    • javax.ws.rs.client.Client
    • javax.ws.rs.client.WebTarget
  • javax.ws.rs.client.Invocation
  • javax.ws.rs.client.InvocationCallback<RESPONSE>
  • javax.ws.rs.client.SyncInvoker
    • javax.ws.rs.client.Invocation.Builder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ResponseProcessingException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Class ResponseProcessingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.ProcessingException
            • javax.ws.rs.client.ResponseProcessingException
  • All Implemented Interfaces:
    Serializable

    public class ResponseProcessingException
extends ProcessingException
    JAX-RS client-side runtime processing exception thrown to indicate that response processing has failed (e.g. in a filter chain or during message entity de-serialization). The exception contains the nested Response instance for which the runtime response processing failed.
    Since:
    2.0
    Author:
    Marek Potociar (marek.potociar at oracle.com)
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ResponseProcessingException(Response response, String message)
      Constructs a new JAX-RS runtime processing exception with the specified detail message.
      ResponseProcessingException(Response response, String message, Throwable cause)
      Constructs a new JAX-RS runtime response processing exception with the specified detail message and cause.
      ResponseProcessingException(Response response, Throwable cause)
      Constructs a new JAX-RS runtime response processing exception for a specific response with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Response getResponse()
      Get the HTTP response for which the processing has failed.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ResponseProcessingException

        public ResponseProcessingException(Response response,
                           Throwable cause)
        Constructs a new JAX-RS runtime response processing exception for a specific response with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause). This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.
        Parameters:
        response - the response instance for which the processing failed.
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • ResponseProcessingException

        public ResponseProcessingException(Response response,
                           String message,
                           Throwable cause)
        Constructs a new JAX-RS runtime response processing exception with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.

        Parameters:
        response - the response instance for which the processing failed.
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • ResponseProcessingException

        public ResponseProcessingException(Response response,
                           String message)
        Constructs a new JAX-RS runtime processing exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).
        Parameters:
        response - the response instance for which the processing failed.
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

    • Method Detail

      • getResponse

        public Response getResponse()
        Get the HTTP response for which the processing has failed.
        Returns:
        the HTTP response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SyncInvoker (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface SyncInvoker

  • All Known Subinterfaces:
    Invocation.Builder

    public interface SyncInvoker
    Uniform interface for synchronous invocation of HTTP methods.
    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Response delete()
      Invoke HTTP DELETE method for the current request synchronously.
      <T> T delete(Class<T> responseType)
      Invoke HTTP DELETE method for the current request synchronously.
      <T> T delete(GenericType<T> responseType)
      Invoke HTTP DELETE method for the current request synchronously.
      Response get()
      Invoke HTTP GET method for the current request synchronously.
      <T> T get(Class<T> responseType)
      Invoke HTTP GET method for the current request synchronously.
      <T> T get(GenericType<T> responseType)
      Invoke HTTP GET method for the current request synchronously.
      Response head()
      Invoke HTTP HEAD method for the current request synchronously.
      Response method(String name)
      Invoke an arbitrary method for the current request synchronously.
      <T> T method(String name, Class<T> responseType)
      Invoke an arbitrary method for the current request synchronously.
      Response method(String name, Entity<?> entity)
      Invoke an arbitrary method for the current request synchronously.
      <T> T method(String name, Entity<?> entity, Class<T> responseType)
      Invoke an arbitrary method for the current request synchronously.
      <T> T method(String name, Entity<?> entity, GenericType<T> responseType)
      Invoke an arbitrary method for the current request synchronously.
      <T> T method(String name, GenericType<T> responseType)
      Invoke an arbitrary method for the current request synchronously.
      Response options()
      Invoke HTTP OPTIONS method for the current request synchronously.
      <T> T options(Class<T> responseType)
      Invoke HTTP OPTIONS method for the current request synchronously.
      <T> T options(GenericType<T> responseType)
      Invoke HTTP OPTIONS method for the current request synchronously.
      Response post(Entity<?> entity)
      Invoke HTTP POST method for the current request synchronously.
      <T> T post(Entity<?> entity, Class<T> responseType)
      Invoke HTTP POST method for the current request synchronously.
      <T> T post(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP POST method for the current request synchronously.
      Response put(Entity<?> entity)
      Invoke HTTP PUT method for the current request synchronously.
      <T> T put(Entity<?> entity, Class<T> responseType)
      Invoke HTTP PUT method for the current request synchronously.
      <T> T put(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP PUT method for the current request synchronously.
      Response trace()
      Invoke HTTP TRACE method for the current request synchronously.
      <T> T trace(Class<T> responseType)
      Invoke HTTP TRACE method for the current request synchronously.
      <T> T trace(GenericType<T> responseType)
      Invoke HTTP TRACE method for the current request synchronously.

    • Method Detail

      • get

        Response get()
        Invoke HTTP GET method for the current request synchronously.
        Returns:
        invocation response.
        Throws:
        ProcessingException - in case the invocation processing has failed.

      • get

        <T> T get(Class<T> responseType)
        Invoke HTTP GET method for the current request synchronously.
        Type Parameters:
        T - response entity type.
        Parameters:
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified response type is not Response.

      • get

        <T> T get(GenericType<T> responseType)
        Invoke HTTP GET method for the current request synchronously.
        Type Parameters:
        T - generic response entity type.
        Parameters:
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified generic response type does not represent Response

      • put

        Response put(Entity<?> entity)
        Invoke HTTP PUT method for the current request synchronously.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.

      • put

        <T> T put(Entity<?> entity,
        Class<T> responseType)
        Invoke HTTP PUT method for the current request synchronously.
        Type Parameters:
        T - response entity type.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified response type is not Response.

      • put

        <T> T put(Entity<?> entity,
        GenericType<T> responseType)
        Invoke HTTP PUT method for the current request synchronously.
        Type Parameters:
        T - generic response entity type.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified generic response type does not represent Response.

      • post

        Response post(Entity<?> entity)
        Invoke HTTP POST method for the current request synchronously.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.

      • post

        <T> T post(Entity<?> entity,
         Class<T> responseType)
        Invoke HTTP POST method for the current request synchronously.
        Type Parameters:
        T - response entity type.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified response type is not Response.

      • post

        <T> T post(Entity<?> entity,
         GenericType<T> responseType)
        Invoke HTTP POST method for the current request synchronously.
        Type Parameters:
        T - generic response entity type.
        Parameters:
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified generic response type does not represent Response.

      • delete

        Response delete()
        Invoke HTTP DELETE method for the current request synchronously.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.

      • delete

        <T> T delete(Class<T> responseType)
        Invoke HTTP DELETE method for the current request synchronously.
        Type Parameters:
        T - response entity type.
        Parameters:
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified response type is not Response.

      • delete

        <T> T delete(GenericType<T> responseType)
        Invoke HTTP DELETE method for the current request synchronously.
        Type Parameters:
        T - generic response entity type.
        Parameters:
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified generic response type does not represent Response.

      • head

        Response head()
        Invoke HTTP HEAD method for the current request synchronously.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.

      • options

        Response options()
        Invoke HTTP OPTIONS method for the current request synchronously.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.

      • options

        <T> T options(Class<T> responseType)
        Invoke HTTP OPTIONS method for the current request synchronously.
        Type Parameters:
        T - response entity type.
        Parameters:
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified response type is not Response.

      • options

        <T> T options(GenericType<T> responseType)
        Invoke HTTP OPTIONS method for the current request synchronously.
        Type Parameters:
        T - generic response entity type.
        Parameters:
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified generic response type does not represent Response.

      • trace

        Response trace()
        Invoke HTTP TRACE method for the current request synchronously.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.

      • trace

        <T> T trace(Class<T> responseType)
        Invoke HTTP TRACE method for the current request synchronously.
        Type Parameters:
        T - response entity type.
        Parameters:
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified response type is not Response.

      • trace

        <T> T trace(GenericType<T> responseType)
        Invoke HTTP TRACE method for the current request synchronously.
        Type Parameters:
        T - generic response entity type.
        Parameters:
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified generic response type does not represent Response.

      • method

        Response method(String name)
        Invoke an arbitrary method for the current request synchronously.
        Parameters:
        name - method name.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.

      • method

        <T> T method(String name,
           Class<T> responseType)
        Invoke an arbitrary method for the current request synchronously.
        Type Parameters:
        T - response entity type.
        Parameters:
        name - method name.
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified response type is not Response.

      • method

        <T> T method(String name,
           GenericType<T> responseType)
        Invoke an arbitrary method for the current request synchronously.
        Type Parameters:
        T - generic response entity type.
        Parameters:
        name - method name.
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified generic response type does not represent Response.

      • method

        Response method(String name,
              Entity<?> entity)
        Invoke an arbitrary method for the current request synchronously.
        Parameters:
        name - method name.
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.

      • method

        <T> T method(String name,
           Entity<?> entity,
           Class<T> responseType)
        Invoke an arbitrary method for the current request synchronously.
        Type Parameters:
        T - response entity type.
        Parameters:
        name - method name.
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified response type is not Response.

      • method

        <T> T method(String name,
           Entity<?> entity,
           GenericType<T> responseType)
        Invoke an arbitrary method for the current request synchronously.
        Type Parameters:
        T - generic response entity type.
        Parameters:
        name - method name.
        entity - request entity, including it's full Variant information. Any variant-related HTTP headers previously set (namely Content-Type, Content-Language and Content-Encoding) will be overwritten using the entity variant information.
        responseType - representation of a generic Java type the response entity will be converted to.
        Returns:
        invocation response.
        Throws:
        ResponseProcessingException - in case processing of a received HTTP response fails (e.g. in a filter or during conversion of the response entity data to an instance of a particular Java type).
        ProcessingException - in case the request processing or subsequent I/O operation fails.
        WebApplicationException - in case the response status code of the response returned by the server is not successful and the specified generic response type does not represent Response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.ws.rs.client (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.ws.rs.client

  • Packages that use javax.ws.rs.client
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
  • Classes in javax.ws.rs.client used by javax.ws.rs.client
    Class and Description
    AsyncInvoker
    Uniform interface for asynchronous invocation of HTTP methods.
    Client
    Client is the main entry point to the fluent API used to build and execute client requests in order to consume responses returned.
    ClientBuilder
    Main entry point to the client API used to bootstrap Client instances.
    ClientRequestContext
    Client request filter context.
    ClientResponseContext
    Client response filter context.
    Entity
    Encapsulates message entity including the associated variant information.
    Invocation
    A client request invocation.
    Invocation.Builder
    A client request invocation builder.
    InvocationCallback
    Callback that can be implemented to receive the asynchronous processing events from the invocation processing.
    SyncInvoker
    Uniform interface for synchronous invocation of HTTP methods.
    WebTarget
    A resource target identified by the resource URI.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WebTarget (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.client

Interface WebTarget

  • All Superinterfaces:
    Configurable<WebTarget>

    public interface WebTarget
extends Configurable<WebTarget>
    A resource target identified by the resource URI.
    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      URI getUri()
      Get the URI identifying the resource.
      UriBuilder getUriBuilder()
      Get the URI builder initialized with the URI of the current resource target.
      WebTarget matrixParam(String name, Object... values)
      Create a new WebTarget instance by appending a matrix parameter to the existing set of matrix parameters of the current final segment of the URI of the current target instance.
      WebTarget path(String path)
      Create a new WebTarget instance by appending path to the URI of the current target instance.
      WebTarget queryParam(String name, Object... values)
      Create a new WebTarget instance by configuring a query parameter on the URI of the current target instance.
      Invocation.Builder request()
      Start building a request to the targeted web resource.
      Invocation.Builder request(MediaType... acceptedResponseTypes)
      Start building a request to the targeted web resource and define the accepted response media types.
      Invocation.Builder request(String... acceptedResponseTypes)
      Start building a request to the targeted web resource and define the accepted response media types.
      WebTarget resolveTemplate(String name, Object value)
      Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied value.
      WebTarget resolveTemplate(String name, Object value, boolean encodeSlashInPath)
      Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied value.
      WebTarget resolveTemplateFromEncoded(String name, Object value)
      Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied encoded value.
      WebTarget resolveTemplates(Map<String,Object> templateValues)
      Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-value pairs.
      WebTarget resolveTemplates(Map<String,Object> templateValues, boolean encodeSlashInPath)
      Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-value pairs.
      WebTarget resolveTemplatesFromEncoded(Map<String,Object> templateValues)
      Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-encoded value pairs.

      • Methods inherited from interface javax.ws.rs.core.Configurable

        getConfiguration, property, register, register, register, register, register, register, register, register

    • Method Detail

      • getUri

        URI getUri()
        Get the URI identifying the resource.
        Returns:
        the resource URI.

      • getUriBuilder

        UriBuilder getUriBuilder()
        Get the URI builder initialized with the URI of the current resource target. The returned URI builder is detached from the target, i.e. any updates in the URI builder MUST NOT have any effects on the URI of the originating target.
        Returns:
        the initialized URI builder.

      • path

        WebTarget path(String path)
        Create a new WebTarget instance by appending path to the URI of the current target instance.

        When constructing the final path, a '/' separator will be inserted between the existing path and the supplied path if necessary. Existing '/' characters are preserved thus a single value can represent multiple URI path segments.

        A snapshot of the present configuration of the current (parent) target instance is taken and is inherited by the newly constructed (child) target instance.

        Parameters:
        path - the path, may contain URI template parameters.
        Returns:
        a new target instance.
        Throws:
        NullPointerException - if path is null.

      • resolveTemplate

        WebTarget resolveTemplate(String name,
                        Object value)
        Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied value. In case a null template name or value is entered a NullPointerException is thrown.

        A snapshot of the present configuration of the current (parent) target instance is taken and is inherited by the newly constructed (child) target instance.

        Parameters:
        name - name of the URI template.
        value - value to be used to resolve the template.
        Returns:
        a new target instance.
        Throws:
        NullPointerException - if the resolved template name or value is null.

      • resolveTemplate

        WebTarget resolveTemplate(String name,
                        Object value,
                        boolean encodeSlashInPath)
        Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied value. In case a null template name or value is entered a NullPointerException is thrown.

        A snapshot of the present configuration of the current (parent) target instance is taken and is inherited by the newly constructed (child) target instance.

        Parameters:
        name - name of the URI template.
        value - value to be used to resolve the template.
        encodeSlashInPath - if true, the slash ('/') characters in template values will be encoded if the template is placed in the URI path component, otherwise the slash characters will not be encoded in path templates.
        Returns:
        a new target instance.
        Throws:
        NullPointerException - if the resolved template name or value is null.

      • resolveTemplateFromEncoded

        WebTarget resolveTemplateFromEncoded(String name,
                                   Object value)
        Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied encoded value. A template with a matching name will be replaced by the supplied value. Value is converted to String using its toString() method and is then encoded to match the rules of the URI component to which they pertain. All % characters in the stringified values that are not followed by two hexadecimal numbers will be encoded. In case a null template name or value is entered a NullPointerException is thrown.

        A snapshot of the present configuration of the current (parent) target instance is taken and is inherited by the newly constructed (child) target instance.

        Parameters:
        name - name of the URI template.
        value - encoded value to be used to resolve the template.
        Returns:
        a new target instance.
        Throws:
        NullPointerException - if the resolved template name or value is null.

      • resolveTemplates

        WebTarget resolveTemplates(Map<String,Object> templateValues)
        Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-value pairs. A call to the method with an empty parameter map is ignored, i.e. same WebTarget instance is returned.

        A snapshot of the present configuration of the current (parent) target instance is taken and is inherited by the newly constructed (child) target instance.

        Parameters:
        templateValues - a map of URI template names and their values.
        Returns:
        a new target instance or the same target instance in case the input name-value map is empty.
        Throws:
        NullPointerException - if the name-value map or any of the names or values in the map is null.

      • resolveTemplates

        WebTarget resolveTemplates(Map<String,Object> templateValues,
                         boolean encodeSlashInPath)
        Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-value pairs. A call to the method with an empty parameter map is ignored, i.e. same WebTarget instance is returned.

        A snapshot of the present configuration of the current (parent) target instance is taken and is inherited by the newly constructed (child) target instance.

        Parameters:
        templateValues - a map of URI template names and their values.
        encodeSlashInPath - if true, the slash ('/') characters in template values will be encoded if the template is placed in the URI path component, otherwise the slash characters will not be encoded in path templates.
        Returns:
        a new target instance or the same target instance in case the input name-value map is empty.
        Throws:
        NullPointerException - if the name-value map or any of the names or values in the map is null.

      • resolveTemplatesFromEncoded

        WebTarget resolveTemplatesFromEncoded(Map<String,Object> templateValues)
        Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-encoded value pairs. All templates with their name matching one of the keys in the supplied map will be replaced by the value in the supplied map. Values are converted to String using their toString() method and are then encoded to match the rules of the URI component to which they pertain. All % characters in the stringified values that are not followed by two hexadecimal numbers will be encoded. A call to the method with an empty parameter map is ignored, i.e. same WebTarget instance is returned.

        A snapshot of the present configuration of the current (parent) target instance is taken and is inherited by the newly constructed (child) target instance.

        Parameters:
        templateValues - a map of URI template names and their encoded values.
        Returns:
        a new target instance or the same target instance in case the input name-value map is empty.
        Throws:
        NullPointerException - if the name-value map or any of the names or encoded values in the map is null.

      • matrixParam

        WebTarget matrixParam(String name,
                    Object... values)
        Create a new WebTarget instance by appending a matrix parameter to the existing set of matrix parameters of the current final segment of the URI of the current target instance. If multiple values are supplied the parameter will be added once per value. In case a single null value is entered, all parameters with that name in the current final path segment are removed (if present) from the collection of last segment matrix parameters inherited from the current target.

        Note that the matrix parameters are tied to a particular path segment; appending a value to an existing matrix parameter name will not affect the position of the matrix parameter in the URI path.

        A snapshot of the present configuration of the current (parent) target instance is taken and is inherited by the newly constructed (child) target instance.

        Parameters:
        name - the matrix parameter name, may contain URI template parameters.
        values - the matrix parameter value(s), each object will be converted to a String using its toString() method. Stringified values may contain URI template parameters.
        Returns:
        a new target instance.
        Throws:
        NullPointerException - if the parameter name is null or if there are multiple values present and any of those values is null.
        See Also:
        Matrix URIs

      • queryParam

        WebTarget queryParam(String name,
                   Object... values)
        Create a new WebTarget instance by configuring a query parameter on the URI of the current target instance. If multiple values are supplied the parameter will be added once per value. In case a single null value is entered, all parameters with that name are removed (if present) from the collection of query parameters inherited from the current target.

        A snapshot of the present configuration of the current (parent) target instance is taken and is inherited by the newly constructed (child) target instance.

        Parameters:
        name - the query parameter name, may contain URI template parameters
        values - the query parameter value(s), each object will be converted to a String using its toString() method. Stringified values may contain URI template parameters.
        Returns:
        a new target instance.
        Throws:
        NullPointerException - if the parameter name is null or if there are multiple values present and any of those values is null.

      • request

        Invocation.Builder request()
        Start building a request to the targeted web resource.
        Returns:
        builder for a request targeted at the URI referenced by this target instance.

      • request

        Invocation.Builder request(String... acceptedResponseTypes)
        Start building a request to the targeted web resource and define the accepted response media types.

        Invoking this method is identical to:

         webTarget.request().accept(types);
        Parameters:
        acceptedResponseTypes - accepted response media types.
        Returns:
        builder for a request targeted at the URI referenced by this target instance.

      • request

        Invocation.Builder request(MediaType... acceptedResponseTypes)
        Start building a request to the targeted web resource and define the accepted response media types.

        Invoking this method is identical to:

         webTarget.request().accept(types);
        Parameters:
        acceptedResponseTypes - accepted response media types.
        Returns:
        builder for a request targeted at the URI referenced by this target instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.ws.rs.client.ClientBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.client.ClientBuilder

  • Packages that use ClientBuilder
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of ClientBuilder in javax.ws.rs.client

      Methods in javax.ws.rs.client that return ClientBuilder
      Modifier and Type Method and Description
      abstract ClientBuilder ClientBuilder.hostnameVerifier(HostnameVerifier verifier)
      Set the hostname verifier to be used by the client to verify the endpoint's hostname against it's identification information.
      abstract ClientBuilder ClientBuilder.keyStore(KeyStore keyStore, char[] password)
      Set the client-side key store.
      ClientBuilder ClientBuilder.keyStore(KeyStore keyStore, String password)
      Set the client-side key store.
      static ClientBuilder ClientBuilder.newBuilder()
      Create a new ClientBuilder instance using the default client builder implementation class provided by the JAX-RS implementation provider.
      abstract ClientBuilder ClientBuilder.sslContext(SSLContext sslContext)
      Set the SSL context that will be used when creating secured transport connections to server endpoints from web targets created by the client instance that is using this SSL context.
      abstract ClientBuilder ClientBuilder.trustStore(KeyStore trustStore)
      Set the client-side trust store.
      abstract ClientBuilder ClientBuilder.withConfig(Configuration config)
      Set the internal configuration state to an externally provided configuration state.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.client.Entity (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.client.Entity

  • Packages that use Entity
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of Entity in javax.ws.rs.client

      Methods in javax.ws.rs.client that return Entity
      Modifier and Type Method and Description
      static <T> Entity<T> Entity.entity(T entity, MediaType mediaType)
      Create an entity using a supplied content media type.
      static <T> Entity<T> Entity.entity(T entity, MediaType mediaType, Annotation[] annotations)
      Create an entity using a supplied content media type.
      static <T> Entity<T> Entity.entity(T entity, String mediaType)
      Create an entity using a supplied content media type.
      static <T> Entity<T> Entity.entity(T entity, Variant variant)
      Create an entity using a supplied content media type.
      static <T> Entity<T> Entity.entity(T entity, Variant variant, Annotation[] annotations)
      Create an entity using a supplied content media type.
      static Entity<Form> Entity.form(Form form)
      Create an "application/x-www-form-urlencoded" form entity.
      static Entity<Form> Entity.form(MultivaluedMap<String,String> formData)
      Create an "application/x-www-form-urlencoded" form entity.
      static <T> Entity<T> Entity.html(T entity)
      Create a "text/html" entity.
      static <T> Entity<T> Entity.json(T entity)
      Create an "application/json" entity.
      static <T> Entity<T> Entity.text(T entity)
      Create a "text/plain" entity.
      static <T> Entity<T> Entity.xhtml(T entity)
      Create an "application/xhtml+xml" entity.
      static <T> Entity<T> Entity.xml(T entity)
      Create an "application/xml" entity.
      Methods in javax.ws.rs.client with parameters of type Entity
      Modifier and Type Method and Description
      Invocation Invocation.Builder.build(String method, Entity<?> entity)
      Build a request invocation using an arbitrary request method name and request entity.
      Invocation Invocation.Builder.buildPost(Entity<?> entity)
      Build a POST request invocation.
      Invocation Invocation.Builder.buildPut(Entity<?> entity)
      Build a PUT request invocation.
      Response SyncInvoker.method(String name, Entity<?> entity)
      Invoke an arbitrary method for the current request synchronously.
      Future<Response> AsyncInvoker.method(String name, Entity<?> entity)
      Invoke an arbitrary method for the current request asynchronously.
      <T> T SyncInvoker.method(String name, Entity<?> entity, Class<T> responseType)
      Invoke an arbitrary method for the current request synchronously.
      <T> Future<T> AsyncInvoker.method(String name, Entity<?> entity, Class<T> responseType)
      Invoke an arbitrary method for the current request asynchronously.
      <T> T SyncInvoker.method(String name, Entity<?> entity, GenericType<T> responseType)
      Invoke an arbitrary method for the current request synchronously.
      <T> Future<T> AsyncInvoker.method(String name, Entity<?> entity, GenericType<T> responseType)
      Invoke an arbitrary method for the current request asynchronously.
      <T> Future<T> AsyncInvoker.method(String name, Entity<?> entity, InvocationCallback<T> callback)
      Invoke an arbitrary method for the current request asynchronously.
      Response SyncInvoker.post(Entity<?> entity)
      Invoke HTTP POST method for the current request synchronously.
      Future<Response> AsyncInvoker.post(Entity<?> entity)
      Invoke HTTP POST method for the current request asynchronously.
      <T> T SyncInvoker.post(Entity<?> entity, Class<T> responseType)
      Invoke HTTP POST method for the current request synchronously.
      <T> Future<T> AsyncInvoker.post(Entity<?> entity, Class<T> responseType)
      Invoke HTTP POST method for the current request asynchronously.
      <T> T SyncInvoker.post(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP POST method for the current request synchronously.
      <T> Future<T> AsyncInvoker.post(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP POST method for the current request asynchronously.
      <T> Future<T> AsyncInvoker.post(Entity<?> entity, InvocationCallback<T> callback)
      Invoke HTTP POST method for the current request asynchronously.
      Response SyncInvoker.put(Entity<?> entity)
      Invoke HTTP PUT method for the current request synchronously.
      Future<Response> AsyncInvoker.put(Entity<?> entity)
      Invoke HTTP PUT method for the current request asynchronously.
      <T> T SyncInvoker.put(Entity<?> entity, Class<T> responseType)
      Invoke HTTP PUT method for the current request synchronously.
      <T> Future<T> AsyncInvoker.put(Entity<?> entity, Class<T> responseType)
      Invoke HTTP PUT method for the current request asynchronously.
      <T> T SyncInvoker.put(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP PUT method for the current request synchronously.
      <T> Future<T> AsyncInvoker.put(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP PUT method for the current request asynchronously.
      <T> Future<T> AsyncInvoker.put(Entity<?> entity, InvocationCallback<T> callback)
      Invoke HTTP PUT method for the current request asynchronously.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.client.ResponseProcessingException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.client.ResponseProcessingException

No usage of javax.ws.rs.client.ResponseProcessingException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.AsyncInvoker (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.AsyncInvoker

  • Packages that use AsyncInvoker
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of AsyncInvoker in javax.ws.rs.client

      Methods in javax.ws.rs.client that return AsyncInvoker
      Modifier and Type Method and Description
      AsyncInvoker Invocation.Builder.async()
      Access the asynchronous uniform request invocation interface to asynchronously invoke the built request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.Client (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.Client

  • Packages that use Client
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of Client in javax.ws.rs.client

      Methods in javax.ws.rs.client that return Client
      Modifier and Type Method and Description
      abstract Client ClientBuilder.build()
      Build a new client instance using all the configuration previously specified in this client builder.
      Client ClientRequestContext.getClient()
      Get the client instance associated with the request.
      static Client ClientBuilder.newClient()
      Create a new Client instance using the default client builder implementation class provided by the JAX-RS implementation provider.
      static Client ClientBuilder.newClient(Configuration configuration)
      Create a new custom-configured Client instance using the default client builder implementation class provided by the JAX-RS implementation provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.ClientRequestContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.ClientRequestContext

  • Packages that use ClientRequestContext
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of ClientRequestContext in javax.ws.rs.client

      Methods in javax.ws.rs.client with parameters of type ClientRequestContext
      Modifier and Type Method and Description
      void ClientRequestFilter.filter(ClientRequestContext requestContext)
      Filter method called before a request has been dispatched to a client transport layer.
      void ClientResponseFilter.filter(ClientRequestContext requestContext, ClientResponseContext responseContext)
      Filter method called after a response has been provided for a request (either by a request filter or when the HTTP invocation returns.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.ClientRequestFilter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.ClientRequestFilter

No usage of javax.ws.rs.client.ClientRequestFilter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.ClientResponseContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.ClientResponseContext

  • Packages that use ClientResponseContext
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of ClientResponseContext in javax.ws.rs.client

      Methods in javax.ws.rs.client with parameters of type ClientResponseContext
      Modifier and Type Method and Description
      void ClientResponseFilter.filter(ClientRequestContext requestContext, ClientResponseContext responseContext)
      Filter method called after a response has been provided for a request (either by a request filter or when the HTTP invocation returns.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.ClientResponseFilter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.ClientResponseFilter

No usage of javax.ws.rs.client.ClientResponseFilter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.Invocation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.Invocation

  • Packages that use Invocation
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of Invocation in javax.ws.rs.client

      Methods in javax.ws.rs.client that return Invocation
      Modifier and Type Method and Description
      Invocation Invocation.Builder.build(String method)
      Build a request invocation using an arbitrary request method name.
      Invocation Invocation.Builder.build(String method, Entity<?> entity)
      Build a request invocation using an arbitrary request method name and request entity.
      Invocation Invocation.Builder.buildDelete()
      Build a DELETE request invocation.
      Invocation Invocation.Builder.buildGet()
      Build a GET request invocation.
      Invocation Invocation.Builder.buildPost(Entity<?> entity)
      Build a POST request invocation.
      Invocation Invocation.Builder.buildPut(Entity<?> entity)
      Build a PUT request invocation.
      Invocation Invocation.property(String name, Object value)
      Set a new property in the context of a request represented by this invocation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.Invocation.Builder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.Invocation.Builder

  • Packages that use Invocation.Builder
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of Invocation.Builder in javax.ws.rs.client

      Methods in javax.ws.rs.client that return Invocation.Builder
      Modifier and Type Method and Description
      Invocation.Builder Invocation.Builder.accept(MediaType... mediaTypes)
      Add the accepted response media types.
      Invocation.Builder Invocation.Builder.accept(String... mediaTypes)
      Add the accepted response media types.
      Invocation.Builder Invocation.Builder.acceptEncoding(String... encodings)
      Add acceptable encodings.
      Invocation.Builder Invocation.Builder.acceptLanguage(Locale... locales)
      Add acceptable languages.
      Invocation.Builder Invocation.Builder.acceptLanguage(String... locales)
      Add acceptable languages.
      Invocation.Builder Invocation.Builder.cacheControl(CacheControl cacheControl)
      Set the cache control data of the message.
      Invocation.Builder Invocation.Builder.cookie(Cookie cookie)
      Add a cookie to be set.
      Invocation.Builder Invocation.Builder.cookie(String name, String value)
      Add a cookie to be set.
      Invocation.Builder Invocation.Builder.header(String name, Object value)
      Add an arbitrary header.
      Invocation.Builder Invocation.Builder.headers(MultivaluedMap<String,Object> headers)
      Replaces all existing headers with the newly supplied headers.
      Invocation.Builder Client.invocation(Link link)
      Build an invocation builder from a link.
      Invocation.Builder Invocation.Builder.property(String name, Object value)
      Set a new property in the context of a request represented by this invocation builder.
      Invocation.Builder WebTarget.request()
      Start building a request to the targeted web resource.
      Invocation.Builder WebTarget.request(MediaType... acceptedResponseTypes)
      Start building a request to the targeted web resource and define the accepted response media types.
      Invocation.Builder WebTarget.request(String... acceptedResponseTypes)
      Start building a request to the targeted web resource and define the accepted response media types.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.InvocationCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.InvocationCallback

  • Packages that use InvocationCallback
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of InvocationCallback in javax.ws.rs.client

      Methods in javax.ws.rs.client with parameters of type InvocationCallback
      Modifier and Type Method and Description
      <T> Future<T> AsyncInvoker.delete(InvocationCallback<T> callback)
      Invoke HTTP DELETE method for the current request asynchronously.
      <T> Future<T> AsyncInvoker.get(InvocationCallback<T> callback)
      Invoke HTTP GET method for the current request asynchronously.
      Future<Response> AsyncInvoker.head(InvocationCallback<Response> callback)
      Invoke HTTP HEAD method for the current request asynchronously.
      <T> Future<T> AsyncInvoker.method(String name, Entity<?> entity, InvocationCallback<T> callback)
      Invoke an arbitrary method for the current request asynchronously.
      <T> Future<T> AsyncInvoker.method(String name, InvocationCallback<T> callback)
      Invoke an arbitrary method for the current request asynchronously.
      <T> Future<T> AsyncInvoker.options(InvocationCallback<T> callback)
      Invoke HTTP OPTIONS method for the current request asynchronously.
      <T> Future<T> AsyncInvoker.post(Entity<?> entity, InvocationCallback<T> callback)
      Invoke HTTP POST method for the current request asynchronously.
      <T> Future<T> AsyncInvoker.put(Entity<?> entity, InvocationCallback<T> callback)
      Invoke HTTP PUT method for the current request asynchronously.
      <T> Future<T> Invocation.submit(InvocationCallback<T> callback)
      Submit the request for an asynchronous invocation and register an InvocationCallback to process the future result of the invocation.
      <T> Future<T> AsyncInvoker.trace(InvocationCallback<T> callback)
      Invoke HTTP TRACE method for the current request asynchronously.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.SyncInvoker (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.SyncInvoker

  • Packages that use SyncInvoker
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of SyncInvoker in javax.ws.rs.client

      Subinterfaces of SyncInvoker in javax.ws.rs.client
      Modifier and Type Interface and Description
      static interface  Invocation.Builder
      A client request invocation builder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.client.WebTarget (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.client.WebTarget

  • Packages that use WebTarget
    Package Description
    javax.ws.rs.client
    The JAX-RS client API

    • Uses of WebTarget in javax.ws.rs.client

      Methods in javax.ws.rs.client that return WebTarget
      Modifier and Type Method and Description
      WebTarget WebTarget.matrixParam(String name, Object... values)
      Create a new WebTarget instance by appending a matrix parameter to the existing set of matrix parameters of the current final segment of the URI of the current target instance.
      WebTarget WebTarget.path(String path)
      Create a new WebTarget instance by appending path to the URI of the current target instance.
      WebTarget WebTarget.queryParam(String name, Object... values)
      Create a new WebTarget instance by configuring a query parameter on the URI of the current target instance.
      WebTarget WebTarget.resolveTemplate(String name, Object value)
      Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied value.
      WebTarget WebTarget.resolveTemplate(String name, Object value, boolean encodeSlashInPath)
      Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied value.
      WebTarget WebTarget.resolveTemplateFromEncoded(String name, Object value)
      Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied encoded value.
      WebTarget WebTarget.resolveTemplates(Map<String,Object> templateValues)
      Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-value pairs.
      WebTarget WebTarget.resolveTemplates(Map<String,Object> templateValues, boolean encodeSlashInPath)
      Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-value pairs.
      WebTarget WebTarget.resolveTemplatesFromEncoded(Map<String,Object> templateValues)
      Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-encoded value pairs.
      WebTarget Client.target(Link link)
      Build a new web resource target.
      WebTarget Client.target(String uri)
      Build a new web resource target.
      WebTarget Client.target(URI uri)
      Build a new web resource target.
      WebTarget Client.target(UriBuilder uriBuilder)
      Build a new web resource target.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AsyncResponse (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface AsyncResponse

  • public interface AsyncResponse
    An injectable JAX-RS asynchronous response that provides means for asynchronous server side response processing.

    A new instance of AsyncResponse may be injected into a resource or sub-resource method parameter using the @Suspend annotation.

    Each asynchronous response instance is bound to the running request and can be used to asynchronously provide the request processing result or otherwise manipulate the suspended client connection. The available operations include:
    • updating suspended state data (time-out value, response ...)
    • resuming the suspended request processing
    • canceling the suspended request processing

    Following example demonstrates the use of the AsyncResponse for asynchronous HTTP request processing:

     @Path("/messages/next")
 public class MessagingResource {
     private static final BlockingQueue<AsyncResponse> suspended =
             new ArrayBlockingQueue<AsyncResponse>(5);

     @GET
     public void readMessage(@Suspended AsyncResponse ar) throws InterruptedException {
         suspended.put(ar);
     }

     @POST
     public String postMessage(final String message) throws InterruptedException {
         final AsyncResponse ar = suspended.take();
         ar.resume(message); // resumes the processing of one GET request
         return "Message sent";
     }
 }

    If the asynchronous response was suspended with a positive timeout value, and has not been explicitly resumed before the timeout has expired, the processing will be resumed once the specified timeout threshold is reached, provided a positive timeout value was set on the response.

    By default a timed-out asynchronous response is resumed with a WebApplicationException that has HTTP 503 (Service unavailable) error response status code set. This default behavior may be overridden by setting a custom time-out handler.

    Since:
    2.0
    Author:
    Marek Potociar

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static long NO_TIMEOUT
      Constant specifying no suspend timeout value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean cancel()
      Cancel the suspended request processing.
      boolean cancel(Date retryAfter)
      Cancel the suspended request processing.
      boolean cancel(int retryAfter)
      Cancel the suspended request processing.
      boolean isCancelled()
      Check if the asynchronous response instance has been cancelled.
      boolean isDone()
      Check if the processing of a request this asynchronous response instance belongs to has finished.
      boolean isSuspended()
      Check if the asynchronous response instance is in a suspended state.
      Collection<Class<?>> register(Class<?> callback)
      Register an asynchronous processing lifecycle callback class to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.
      Map<Class<?>,Collection<Class<?>>> register(Class<?> callback, Class<?>... callbacks)
      Register asynchronous processing lifecycle callback classes to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.
      Collection<Class<?>> register(Object callback)
      Register an asynchronous processing lifecycle callback instance to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.
      Map<Class<?>,Collection<Class<?>>> register(Object callback, Object... callbacks)
      Register an asynchronous processing lifecycle callback instances to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.
      boolean resume(Object response)
      Resume the suspended request processing using the provided response data.
      boolean resume(Throwable response)
      Resume the suspended request processing using the provided throwable.
      boolean setTimeout(long time, TimeUnit unit)
      Set/update the suspend timeout.
      void setTimeoutHandler(TimeoutHandler handler)
      Set/replace a time-out handler for the suspended asynchronous response.

    • Field Detail

      • NO_TIMEOUT

        static final long NO_TIMEOUT
        Constant specifying no suspend timeout value.
        See Also:
        Constant Field Values

    • Method Detail

      • resume

        boolean resume(Object response)
        Resume the suspended request processing using the provided response data. The provided response data can be of any Java type that can be returned from a JAX-RS resource method.

        The asynchronous response must be still in a suspended state for this method to succeed.

        By executing this method, the request is guaranteed to complete either successfully or with an error. The data processing by the JAX-RS runtime follows the same path as it would for the response data returned synchronously by a JAX-RS resource, except that unmapped exceptions are not re-thrown by JAX-RS runtime to be handled by a hosting I/O container. Instead, any unmapped exceptions are propagated to the hosting I/O container via a container-specific callback mechanism. Depending on the container implementation, propagated unmapped exceptions typically result in an error status being sent to the client and/or the connection being closed.

        Parameters:
        response - data to be sent back in response to the suspended request.
        Returns:
        true if the request processing has been resumed, returns false in case the request processing is not suspended and could not be resumed.
        See Also:
        resume(Throwable)

      • resume

        boolean resume(Throwable response)
        Resume the suspended request processing using the provided throwable. For the provided throwable same rules apply as for an exception thrown by a JAX-RS resource method.

        By executing this method, the request is guaranteed to complete either successfully or with an error. The throwable processing by the JAX-RS runtime follows the same path as it would for the response data returned synchronously by a JAX-RS resource, except that unmapped exceptions are not re-thrown by JAX-RS runtime to be handled by a hosting I/O container. Instead, any unmapped exceptions are propagated to the hosting I/O container via a container-specific callback mechanism. Depending on the container implementation, propagated unmapped exceptions typically result in an error status being sent to the client and/or the connection being closed.

        Parameters:
        response - an exception to be raised in response to the suspended request.
        Returns:
        true if the response has been resumed, returns false in case the response is not suspended and could not be resumed.
        See Also:
        resume(Object)

      • cancel

        boolean cancel()
        Cancel the suspended request processing.

        When a request processing is cancelled using this method, the JAX-RS implementation MUST indicate to the client that the request processing has been cancelled by sending back a HTTP 503 (Service unavailable) error response.

        Invoking a cancel(...) method multiple times to cancel request processing has the same effect as canceling the request processing only once. Invoking a cancel(...) method on an asynchronous response instance that has already been cancelled or resumed has no effect and the method call is ignored while returning true, in case the request has been cancelled previously. Otherwise, in case the request has been resumed regularly (using a resume(...) method) or resumed due to a time-out, method returns false.

        Returns:
        true if the request processing has been cancelled, returns false in case the request processing is not suspended and could not be cancelled and is not cancelled already.
        See Also:
        cancel(int), cancel(java.util.Date)

      • cancel

        boolean cancel(int retryAfter)
        Cancel the suspended request processing.

        When a request processing is cancelled using this method, the JAX-RS implementation MUST indicate to the client that the request processing has been cancelled by sending back a HTTP 503 (Service unavailable) error response with a Retry-After header set to the value provided by the method parameter.

        Invoking a cancel(...) method multiple times to cancel request processing has the same effect as canceling the request processing only once. Invoking a cancel(...) method on an asynchronous response instance that has already been cancelled or resumed has no effect and the method call is ignored while returning true, in case the request has been cancelled previously. Otherwise, in case the request has been resumed regularly (using a resume(...) method) or resumed due to a time-out, method returns false.

        Parameters:
        retryAfter - a decimal integer number of seconds after the response is sent to the client that indicates how long the service is expected to be unavailable to the requesting client.
        Returns:
        true if the request processing has been cancelled, returns false in case the request processing is not suspended and could not be cancelled and is not cancelled already.
        See Also:
        cancel(), cancel(java.util.Date)

      • cancel

        boolean cancel(Date retryAfter)
        Cancel the suspended request processing.

        When a request processing is cancelled using this method, the JAX-RS implementation MUST indicate to the client that the request processing has been cancelled by sending back a HTTP 503 (Service unavailable) error response with a Retry-After header set to the value provided by the method parameter.

        Invoking a cancel(...) method multiple times to cancel request processing has the same effect as canceling the request processing only once. Invoking a cancel(...) method on an asynchronous response instance that has already been cancelled or resumed has no effect and the method call is ignored while returning true, in case the request has been cancelled previously. Otherwise, in case the request has been resumed regularly (using a resume(...) method) or resumed due to a time-out, method returns false.

        Parameters:
        retryAfter - a date that indicates how long the service is expected to be unavailable to the requesting client.
        Returns:
        true if the request processing has been cancelled, returns false in case the request processing is not suspended and could not be cancelled and is not cancelled already.
        See Also:
        cancel(), cancel(int)

      • isSuspended

        boolean isSuspended()
        Check if the asynchronous response instance is in a suspended state. Method returns true if this asynchronous response is still suspended and has not finished processing yet (either by resuming or canceling the response).
        Returns:
        true if this asynchronous response is in a suspend state, false otherwise.
        See Also:
        isCancelled(), isDone()

      • isCancelled

        boolean isCancelled()
        Check if the asynchronous response instance has been cancelled. Method returns true if this asynchronous response has been canceled before completion.
        Returns:
        true if this task was canceled before completion.
        See Also:
        isSuspended(), isDone()

      • isDone

        boolean isDone()
        Check if the processing of a request this asynchronous response instance belongs to has finished. Method returns true if the processing of a request this asynchronous response is bound to is finished.

        The request processing may be finished due to a normal termination, a suspend timeout, or cancellation -- in all of these cases, this method will return true.

        Returns:
        true if this execution context has finished processing.
        See Also:
        isSuspended(), isCancelled()

      • setTimeout

        boolean setTimeout(long time,
                 TimeUnit unit)
        Set/update the suspend timeout.

        The new suspend timeout values override any timeout value previously specified. The asynchronous response must be still in a suspended state for this method to succeed.

        Parameters:
        time - suspend timeout value in the give time unit. Value lower or equal to 0 causes the context to suspend indefinitely.
        unit - suspend timeout value time unit.
        Returns:
        true if the suspend time out has been set, returns false in case the request processing is not in the suspended state.

      • setTimeoutHandler

        void setTimeoutHandler(TimeoutHandler handler)
        Set/replace a time-out handler for the suspended asynchronous response.

        The time-out handler will be invoked when the suspend period of this asynchronous response times out. The job of the time-out handler is to resolve the time-out situation by either

        • resuming the suspended response
        • cancelling the suspended response
        • extending the suspend period by setting a new suspend time-out

        Note that in case the response is suspended indefinitely, the time-out handler may never be invoked.

        Parameters:
        handler - response time-out handler.

      • register

        Collection<Class<?>> register(Class<?> callback)
        Register an asynchronous processing lifecycle callback class to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.
        Parameters:
        callback - callback class.
        Returns:
        collection of registered callback interfaces. If the callback class does not implement any recognized callback interfaces, the returned collection will be empty.
        Throws:
        NullPointerException - in case the callback class is null.

      • register

        Map<Class<?>,Collection<Class<?>>> register(Class<?> callback,
                                          Class<?>... callbacks)
        Register asynchronous processing lifecycle callback classes to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.
        Parameters:
        callback - callback class.
        callbacks - additional callback classes.
        Returns:
        map of registered classes and the callback interfaces registered for each class. If a callback class does not implement any recognized callback interfaces, the associated collection of registered interfaces for the class will be empty.
        Throws:
        NullPointerException - in case any of the callback classes is null.

      • register

        Collection<Class<?>> register(Object callback)
        Register an asynchronous processing lifecycle callback instance to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.
        Parameters:
        callback - callback instance implementing one or more of the recognized callback interfaces.
        Returns:
        collection of registered callback interfaces. If the callback class does not implement any recognized callback interfaces, the returned collection will be empty.
        Throws:
        NullPointerException - in case the callback instance is null.

      • register

        Map<Class<?>,Collection<Class<?>>> register(Object callback,
                                          Object... callbacks)
        Register an asynchronous processing lifecycle callback instances to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.
        Parameters:
        callback - callback instance.
        callbacks - additional callback instances.
        Returns:
        map of registered classes and the callback interfaces registered for each class. If a callback class does not implement any recognized callback interfaces, the associated collection of registered interfaces for the class will be empty.
        Throws:
        NullPointerException - in case any of the callback instances is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CompletionCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface CompletionCallback

  • public interface CompletionCallback
    A request processing callback that receives request processing completion events.

    A completion callback is invoked when the whole request processing is over, i.e. once a response for the request has been processed and sent back to the client or in when an unmapped exception or error is being propagated to the container.

    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onComplete(Throwable throwable)
      A completion callback notification method that will be invoked when the request processing is finished, after a response is processed and is sent back to the client or when an unmapped throwable has been propagated to the hosting I/O container.

    • Method Detail

      • onComplete

        void onComplete(Throwable throwable)
        A completion callback notification method that will be invoked when the request processing is finished, after a response is processed and is sent back to the client or when an unmapped throwable has been propagated to the hosting I/O container.

        An unmapped throwable is propagated to the hosting I/O container in case no exception mapper has been found for a throwable indicating a request processing failure. In this case a non-null unmapped throwable instance is passed to the method. Note that the throwable instance represents the actual unmapped exception thrown during the request processing, before it has been wrapped into an I/O container-specific exception that was used to propagate the throwable to the hosting I/O container.

        Parameters:
        throwable - is null, if the request processing has completed with a response that has been sent to the client. In case the request processing resulted in an unmapped exception or error that has been propagated to the hosting I/O container, this parameter contains the unmapped exception instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionCallback (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface ConnectionCallback

  • public interface ConnectionCallback
    Asynchronous request processing lifecycle callback that receives connection related asynchronous response lifecycle events.

    Support for this type of callback by JAX-RS runtime is OPTIONAL.

    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void onDisconnect(AsyncResponse disconnected)
      This callback notification method is invoked in case the container detects that the remote client connection associated with the asynchronous response has been disconnected.

    • Method Detail

      • onDisconnect

        void onDisconnect(AsyncResponse disconnected)
        This callback notification method is invoked in case the container detects that the remote client connection associated with the asynchronous response has been disconnected.
        Parameters:
        disconnected - asynchronous response for which the remote client connection has been lost.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ContainerRequestContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface ContainerRequestContext

  • public interface ContainerRequestContext
    Container request filter context. A mutable class that provides request-specific information for the filter, such as request URI, message headers, message entity or request-scoped properties. The exposed setters allow modification of the exposed request-specific information.
    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void abortWith(Response response)
      Abort the filter chain with a response.
      List<Locale> getAcceptableLanguages()
      Get a list of languages that are acceptable for the response.
      List<MediaType> getAcceptableMediaTypes()
      Get a list of media types that are acceptable for the response.
      Map<String,Cookie> getCookies()
      Get any cookies that accompanied the request.
      Date getDate()
      Get message date.
      InputStream getEntityStream()
      Get the entity input stream.
      MultivaluedMap<String,String> getHeaders()
      Get the mutable request headers multivalued map.
      String getHeaderString(String name)
      Get a message header as a single string value.
      Locale getLanguage()
      Get the language of the entity.
      int getLength()
      Get Content-Length value.
      MediaType getMediaType()
      Get the media type of the entity.
      String getMethod()
      Get the request method.
      Object getProperty(String name)
      Returns the property with the given name registered in the current request/response exchange context, or null if there is no property by that name.
      Collection<String> getPropertyNames()
      Returns an immutable collection containing the property names available within the context of the current request/response exchange context.
      Request getRequest()
      Get the injectable request information.
      SecurityContext getSecurityContext()
      Get the injectable security context information for the current request.
      UriInfo getUriInfo()
      Get request URI information.
      boolean hasEntity()
      Check if there is a non-empty entity input stream available in the request message.
      void removeProperty(String name)
      Removes a property with the given name from the current request/response exchange context.
      void setEntityStream(InputStream input)
      Set a new entity input stream.
      void setMethod(String method)
      Set the request method.
      void setProperty(String name, Object object)
      Binds an object to a given property name in the current request/response exchange context.
      void setRequestUri(URI requestUri)
      Set a new request URI using the current base URI of the application to resolve the application-specific request URI part.
      void setRequestUri(URI baseUri, URI requestUri)
      Set a new request URI using a new base URI to resolve the application-specific request URI part.
      void setSecurityContext(SecurityContext context)
      Set a new injectable security context information for the current request.

    • Method Detail

      • getProperty

        Object getProperty(String name)
        Returns the property with the given name registered in the current request/response exchange context, or null if there is no property by that name.

        A property allows a JAX-RS filters and interceptors to exchange additional custom information not already provided by this interface.

        A list of supported properties can be retrieved using getPropertyNames(). Custom property names should follow the same convention as package names.

        In a Servlet container, the properties are synchronized with the ServletRequest and expose all the attributes available in the ServletRequest. Any modifications of the properties are also reflected in the set of properties of the associated ServletRequest.

        Parameters:
        name - a String specifying the name of the property.
        Returns:
        an Object containing the value of the property, or null if no property exists matching the given name.
        See Also:
        getPropertyNames()

      • getPropertyNames

        Collection<String> getPropertyNames()
        Returns an immutable collection containing the property names available within the context of the current request/response exchange context.

        Use the getProperty(java.lang.String) method with a property name to get the value of a property.

        In a Servlet container, the properties are synchronized with the ServletRequest and expose all the attributes available in the ServletRequest. Any modifications of the properties are also reflected in the set of properties of the associated ServletRequest.

        Returns:
        an immutable collection of property names.
        See Also:
        getProperty(java.lang.String)

      • setProperty

        void setProperty(String name,
               Object object)
        Binds an object to a given property name in the current request/response exchange context. If the name specified is already used for a property, this method will replace the value of the property with the new value.

        A property allows a JAX-RS filters and interceptors to exchange additional custom information not already provided by this interface.

        A list of supported properties can be retrieved using getPropertyNames(). Custom property names should follow the same convention as package names.

        If a null value is passed, the effect is the same as calling the removeProperty(String) method.

        In a Servlet container, the properties are synchronized with the ServletRequest and expose all the attributes available in the ServletRequest. Any modifications of the properties are also reflected in the set of properties of the associated ServletRequest.

        Parameters:
        name - a String specifying the name of the property.
        object - an Object representing the property to be bound.

      • removeProperty

        void removeProperty(String name)
        Removes a property with the given name from the current request/response exchange context. After removal, subsequent calls to getProperty(java.lang.String) to retrieve the property value will return null.

        In a Servlet container, the properties are synchronized with the ServletRequest and expose all the attributes available in the ServletRequest. Any modifications of the properties are also reflected in the set of properties of the associated ServletRequest.

        Parameters:
        name - a String specifying the name of the property to be removed.

      • getUriInfo

        UriInfo getUriInfo()
        Get request URI information. The returned object contains "live" view of the request URI information in a sense that any changes made to the request URI using one of the setRequestUri(...) methods will be reflected in the previously returned UriInfo instance.
        Returns:
        request URI information.

      • setRequestUri

        void setRequestUri(URI requestUri)
        Set a new request URI using the current base URI of the application to resolve the application-specific request URI part.

        Note that the method is usable only in pre-matching filters, prior to the resource matching occurs. Trying to invoke the method in a filter bound to a resource method results in an IllegalStateException being thrown.

        Parameters:
        requestUri - new URI of the request.
        Throws:
        IllegalStateException - in case the method is not invoked from a pre-matching request filter.
        See Also:
        setRequestUri(java.net.URI, java.net.URI)

      • setRequestUri

        void setRequestUri(URI baseUri,
                 URI requestUri)
        Set a new request URI using a new base URI to resolve the application-specific request URI part.

        Note that the method is usable only in pre-matching filters, prior to the resource matching occurs. Trying to invoke the method in a filter bound to a resource method results in an IllegalStateException being thrown.

        Parameters:
        baseUri - base URI that will be used to resolve the application-specific part of the request URI.
        requestUri - new URI of the request.
        Throws:
        IllegalStateException - in case the method is not invoked from a pre-matching request filter.
        See Also:
        setRequestUri(java.net.URI)

      • getRequest

        Request getRequest()
        Get the injectable request information.
        Returns:
        injectable request information.

      • getMethod

        String getMethod()
        Get the request method.
        Returns:
        the request method.
        See Also:
        HttpMethod

      • setMethod

        void setMethod(String method)
        Set the request method.

        Note that the method is usable only in pre-matching filters, prior to the resource matching occurs. Trying to invoke the method in a filter bound to a resource method results in an IllegalStateException being thrown.

        Parameters:
        method - new request method.
        Throws:
        IllegalStateException - in case the method is not invoked from a pre-matching request filter.
        See Also:
        HttpMethod

      • getHeaders

        MultivaluedMap<String,String> getHeaders()
        Get the mutable request headers multivalued map.
        Returns:
        mutable multivalued map of request headers.
        See Also:
        getHeaderString(String)

      • getHeaderString

        String getHeaderString(String name)
        Get a message header as a single string value.
        Parameters:
        name - the message header.
        Returns:
        the message header value. If the message header is not present then null is returned. If the message header is present but has no value then the empty string is returned. If the message header is present more than once then the values of joined together and separated by a ',' character.
        See Also:
        getHeaders()

      • getDate

        Date getDate()
        Get message date.
        Returns:
        the message date, otherwise null if not present.

      • getLanguage

        Locale getLanguage()
        Get the language of the entity.
        Returns:
        the language of the entity or null if not specified

      • getLength

        int getLength()
        Get Content-Length value.
        Returns:
        Content-Length as integer if present and valid number. In other cases returns -1.

      • getMediaType

        MediaType getMediaType()
        Get the media type of the entity.
        Returns:
        the media type or null if not specified (e.g. there's no request entity).

      • getAcceptableMediaTypes

        List<MediaType> getAcceptableMediaTypes()
        Get a list of media types that are acceptable for the response.
        Returns:
        a read-only list of requested response media types sorted according to their q-value, with highest preference first.

      • getAcceptableLanguages

        List<Locale> getAcceptableLanguages()
        Get a list of languages that are acceptable for the response.
        Returns:
        a read-only list of acceptable languages sorted according to their q-value, with highest preference first.

      • getCookies

        Map<String,Cookie> getCookies()
        Get any cookies that accompanied the request.
        Returns:
        a read-only map of cookie name (String) to Cookie.

      • hasEntity

        boolean hasEntity()
        Check if there is a non-empty entity input stream available in the request message. The method returns true if the entity is present, returns false otherwise.
        Returns:
        true if there is an entity present in the message, false otherwise.

      • getEntityStream

        InputStream getEntityStream()
        Get the entity input stream. The JAX-RS runtime is responsible for closing the input stream.
        Returns:
        entity input stream.

      • setEntityStream

        void setEntityStream(InputStream input)
        Set a new entity input stream. The JAX-RS runtime is responsible for closing the intput stream.
        Parameters:
        input - new entity input stream.
        Throws:
        IllegalStateException - in case the method is invoked from a response filter.

      • getSecurityContext

        SecurityContext getSecurityContext()
        Get the injectable security context information for the current request. The SecurityContext.getUserPrincipal() must return null if the current request has not been authenticated.
        Returns:
        injectable request security context information.

      • setSecurityContext

        void setSecurityContext(SecurityContext context)
        Set a new injectable security context information for the current request. The SecurityContext.getUserPrincipal() must return null if the current request has not been authenticated.
        Parameters:
        context - new injectable request security context information.
        Throws:
        IllegalStateException - in case the method is invoked from a response filter.

      • abortWith

        void abortWith(Response response)
        Abort the filter chain with a response. This method breaks the filter chain processing and returns the provided response back to the client. The provided response goes through the chain of applicable response filters.
        Parameters:
        response - response to be sent back to the client.
        Throws:
        IllegalStateException - in case the method is invoked from a response filter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ContainerRequestFilter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface ContainerRequestFilter

  • public interface ContainerRequestFilter
    An extension interface implemented by container request filters.

    By default, i.e. if no name binding is applied to the filter implementation class, the filter instance is applied globally, however only after the incoming request has been matched to a particular resource by JAX-RS runtime. If there is a @NameBinding annotation applied to the filter, the filter will also be executed at the post-match request extension point, but only in case the matched resource or sub-resource method is bound to the same name-binding annotation.

    In case the filter should be applied at the pre-match extension point, i.e. before any request matching has been performed by JAX-RS runtime, the filter MUST be annotated with a @PreMatching annotation.

    Use a pre-match request filter to update the input to the JAX-RS matching algorithm, e.g., the HTTP method, Accept header, return cached responses etc. Otherwise, the use of a request filter invoked at the post-match request extension point (after a successful resource method matching) is recommended.

    Filters implementing this interface must be annotated with @Provider to be discovered by the JAX-RS runtime. Container request filter instances may also be discovered and bound dynamically to particular resource methods.

    Since:
    2.0
    Author:
    Marek Potociar, Santiago Pericas-Geertsen
    See Also:
    PreMatching, ContainerResponseFilter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void filter(ContainerRequestContext requestContext)
      Filter method called before a request has been dispatched to a resource.

    • Method Detail

      • filter

        void filter(ContainerRequestContext requestContext)
            throws IOException
        Filter method called before a request has been dispatched to a resource.

        Filters in the filter chain are ordered according to their javax.annotation.Priority class-level annotation value. If a request filter produces a response by calling ContainerRequestContext.abortWith(javax.ws.rs.core.Response) method, the execution of the (either pre-match or post-match) request filter chain is stopped and the response is passed to the corresponding response filter chain (either pre-match or post-match). For example, a pre-match caching filter may produce a response in this way, which would effectively skip any post-match request filters as well as post-match response filters. Note however that a responses produced in this manner would still be processed by the pre-match response filter chain.

        Parameters:
        requestContext - request context.
        Throws:
        IOException - if an I/O exception occurs.
        See Also:
        PreMatching
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ContainerResponseContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface ContainerResponseContext

  • public interface ContainerResponseContext
    Container response filter context. A mutable class that provides response-specific information for the filter, such as message headers, message entity or request-scoped properties. The exposed setters allow modification of the exposed response-specific information.
    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<String> getAllowedMethods()
      Get the allowed HTTP methods from the Allow HTTP header.
      Map<String,NewCookie> getCookies()
      Get any new cookies set on the response message.
      Date getDate()
      Get message date.
      Object getEntity()
      Get the message entity Java instance.
      Annotation[] getEntityAnnotations()
      Get the annotations attached to the entity instance.
      Class<?> getEntityClass()
      Get the raw entity type information.
      OutputStream getEntityStream()
      Get the entity output stream.
      EntityTag getEntityTag()
      Get the entity tag.
      Type getEntityType()
      Get the generic entity type information.
      MultivaluedMap<String,Object> getHeaders()
      Get the mutable response headers multivalued map.
      String getHeaderString(String name)
      Get a message header as a single string value.
      Locale getLanguage()
      Get the language of the entity.
      Date getLastModified()
      Get the last modified date.
      int getLength()
      Get Content-Length value.
      Link getLink(String relation)
      Get the link for the relation.
      Link.Builder getLinkBuilder(String relation)
      Convenience method that returns a Link.Builder for the relation.
      Set<Link> getLinks()
      Get the links attached to the message as header.
      URI getLocation()
      Get the location.
      MediaType getMediaType()
      Get the media type of the entity.
      int getStatus()
      Get the status code associated with the response.
      Response.StatusType getStatusInfo()
      Get the complete status information associated with the response.
      MultivaluedMap<String,String> getStringHeaders()
      Get a string view of header values associated with the message.
      boolean hasEntity()
      Check if there is an entity available in the response.
      boolean hasLink(String relation)
      Check if link for relation exists.
      void setEntity(Object entity)
      Set a new message entity.
      void setEntity(Object entity, Annotation[] annotations, MediaType mediaType)
      Set a new message entity, including the attached annotations and the media type.
      void setEntityStream(OutputStream outputStream)
      Set a new entity output stream.
      void setStatus(int code)
      Set a new response status code.
      void setStatusInfo(Response.StatusType statusInfo)
      Set the complete status information (status code and reason phrase) associated with the response.

    • Method Detail

      • getStatus

        int getStatus()
        Get the status code associated with the response.
        Returns:
        the response status code or -1 if the status was not set.

      • setStatus

        void setStatus(int code)
        Set a new response status code.
        Parameters:
        code - new status code.

      • getStatusInfo

        Response.StatusType getStatusInfo()
        Get the complete status information associated with the response.
        Returns:
        the response status information or null if the status was not set.

      • setStatusInfo

        void setStatusInfo(Response.StatusType statusInfo)
        Set the complete status information (status code and reason phrase) associated with the response.
        Parameters:
        statusInfo - the response status information.

      • getHeaders

        MultivaluedMap<String,Object> getHeaders()
        Get the mutable response headers multivalued map.
        Returns:
        mutable multivalued map of response headers.
        See Also:
        getStringHeaders(), getHeaderString(String)

      • getStringHeaders

        MultivaluedMap<String,String> getStringHeaders()
        Get a string view of header values associated with the message. Changes in the underlying headers map are reflected in this view.

        The method converts the non-string header values to strings using a RuntimeDelegate.HeaderDelegate if one is available via RuntimeDelegate.createHeaderDelegate(java.lang.Class) for the class of the value or using the values toString method if a header delegate is not available.

        Returns:
        response headers as a string view of header values.
        See Also:
        getHeaders(), getHeaderString(String)

      • getHeaderString

        String getHeaderString(String name)
        Get a message header as a single string value. Each single header value is converted to String using a RuntimeDelegate.HeaderDelegate if one is available via RuntimeDelegate.createHeaderDelegate(java.lang.Class) for the header value class or using its toString method if a header delegate is not available.
        Parameters:
        name - the message header.
        Returns:
        the message header value. If the message header is not present then null is returned. If the message header is present but has no value then the empty string is returned. If the message header is present more than once then the values of joined together and separated by a ',' character.
        See Also:
        getHeaders(), getStringHeaders()

      • getAllowedMethods

        Set<String> getAllowedMethods()
        Get the allowed HTTP methods from the Allow HTTP header.
        Returns:
        the allowed HTTP methods, all methods will returned as upper case strings.

      • getDate

        Date getDate()
        Get message date.
        Returns:
        the message date, otherwise null if not present.

      • getLanguage

        Locale getLanguage()
        Get the language of the entity.
        Returns:
        the language of the entity or null if not specified

      • getLength

        int getLength()
        Get Content-Length value.
        Returns:
        Content-Length as integer if present and valid number. In other cases returns -1.

      • getMediaType

        MediaType getMediaType()
        Get the media type of the entity.
        Returns:
        the media type or null if not specified (e.g. there's no response entity).

      • getCookies

        Map<String,NewCookie> getCookies()
        Get any new cookies set on the response message.
        Returns:
        a read-only map of cookie name (String) to a new cookie.

      • getEntityTag

        EntityTag getEntityTag()
        Get the entity tag.
        Returns:
        the entity tag, otherwise null if not present.

      • getLastModified

        Date getLastModified()
        Get the last modified date.
        Returns:
        the last modified date, otherwise null if not present.

      • getLocation

        URI getLocation()
        Get the location.
        Returns:
        the location URI, otherwise null if not present.

      • getLinks

        Set<Link> getLinks()
        Get the links attached to the message as header.
        Returns:
        links, may return empty Set if no links are present. Never returns null.

      • hasLink

        boolean hasLink(String relation)
        Check if link for relation exists.
        Parameters:
        relation - link relation.
        Returns:
        true if the for the relation link exists, false otherwise.

      • getLink

        Link getLink(String relation)
        Get the link for the relation.
        Parameters:
        relation - link relation.
        Returns:
        the link for the relation, otherwise null if not present.

      • getLinkBuilder

        Link.Builder getLinkBuilder(String relation)
        Convenience method that returns a Link.Builder for the relation.
        Parameters:
        relation - link relation.
        Returns:
        the link builder for the relation, otherwise null if not present.

      • hasEntity

        boolean hasEntity()
        Check if there is an entity available in the response. The method returns true if the entity is present, returns false otherwise.
        Returns:
        true if there is an entity present in the message, false otherwise.

      • getEntity

        Object getEntity()
        Get the message entity Java instance. Returns null if the message does not contain an entity.
        Returns:
        the message entity or null if message does not contain an entity body.

      • getEntityClass

        Class<?> getEntityClass()
        Get the raw entity type information.
        Returns:
        raw entity type.

      • getEntityType

        Type getEntityType()
        Get the generic entity type information.
        Returns:
        declared generic entity type.

      • setEntity

        void setEntity(Object entity)
        Set a new message entity. The existing entity annotations and media type are preserved.

        It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required.

        Parameters:
        entity - entity object.
        See Also:
        setEntity(Object, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType), MessageBodyWriter

      • setEntity

        void setEntity(Object entity,
             Annotation[] annotations,
             MediaType mediaType)
        Set a new message entity, including the attached annotations and the media type.

        It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required.

        Parameters:
        entity - entity object.
        annotations - annotations attached to the entity instance.
        mediaType - entity media type.
        See Also:
        setEntity(Object), MessageBodyWriter

      • getEntityAnnotations

        Annotation[] getEntityAnnotations()
        Get the annotations attached to the entity instance.

        Note that the returned annotations array contains only those annotations explicitly attached to entity instance (such as the ones attached using Response.ResponseBuilder.entity(Object, java.lang.annotation.Annotation[]) method or the ones attached to the resource method that returned the response). The entity instance annotations array does not include annotations declared on the entity implementation class or its ancestors.

        Returns:
        annotations attached to the entity instance.

      • getEntityStream

        OutputStream getEntityStream()
        Get the entity output stream. The JAX-RS runtime is responsible for closing the output stream.
        Returns:
        entity output stream.

      • setEntityStream

        void setEntityStream(OutputStream outputStream)
        Set a new entity output stream. The JAX-RS runtime is responsible for closing the output stream.
        Parameters:
        outputStream - new entity output stream.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ContainerResponseFilter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface ContainerResponseFilter

  • public interface ContainerResponseFilter
    An extension interface implemented by container response filters.

    By default, i.e. if no name binding is applied to the filter implementation class, the filter instance is applied globally to any outgoing response. If there is a @NameBinding annotation applied to the filter, the filter will only be executed for a response for which the request has been matched to a resource or sub-resource method AND the method or the whole custom JAX-RS Application class is bound to the same name-binding annotation.

    Implement a name-bound response filter in cases when you want limit the filter functionality to a matched resource or resource method. In other cases, when the filter should be applied globally to any outgoing response, implement an unbound, global response filter.

    Filters implementing this interface must be annotated with @Provider to be discovered by the JAX-RS runtime. Container response filter instances may also be discovered and bound dynamically to particular resource methods.

    Since:
    2.0
    Author:
    Marek Potociar, Santiago Pericas-Geertsen
    See Also:
    ContainerRequestFilter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void filter(ContainerRequestContext requestContext, ContainerResponseContext responseContext)
      Filter method called after a response has been provided for a request (either by a request filter or by a matched resource method.

    • Method Detail

      • filter

        void filter(ContainerRequestContext requestContext,
          ContainerResponseContext responseContext)
            throws IOException
        Filter method called after a response has been provided for a request (either by a request filter or by a matched resource method.

        Filters in the filter chain are ordered according to their javax.annotation.Priority class-level annotation value.

        Parameters:
        requestContext - request context.
        responseContext - response context.
        Throws:
        IOException - if an I/O exception occurs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DynamicFeature (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface DynamicFeature

  • public interface DynamicFeature
    A JAX-RS meta-provider for dynamic registration of post-matching providers during a JAX-RS application setup at deployment time. Dynamic feature is used by JAX-RS runtime to register providers that shall be applied to a particular resource class and method and overrides any annotation-based binding definitions defined on any registered resource filter or interceptor instance.

    Providers implementing this interface MAY be annotated with @Provider annotation in order to be discovered by JAX-RS runtime when scanning for resources and providers. This provider types is supported only as part of the Server API.

    Since:
    2.0
    Author:
    Santiago Pericas-Geertsen, Bill Burke, Marek Potociar
    See Also:
    NameBinding

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void configure(ResourceInfo resourceInfo, FeatureContext context)
      A callback method called by the JAX-RS runtime during the application deployment to register provider instances or classes in a runtime configuration scope of a particular resource or sub-resource method; i.e.

    • Method Detail

      • configure

        void configure(ResourceInfo resourceInfo,
             FeatureContext context)
        A callback method called by the JAX-RS runtime during the application deployment to register provider instances or classes in a runtime configuration scope of a particular resource or sub-resource method; i.e. the providers that should be dynamically bound to the method.

        The registered provider instances or classes are expected to be implementing one or more of the following interfaces:

        • ContainerRequestFilter
        • ContainerResponseFilter
        • ReaderInterceptor
        • WriterInterceptor
        • Feature

        A provider instance or class that does not implement any of the interfaces above may be ignored by the JAX-RS implementation. In such case a warning message must be logged. JAX-RS implementations may support additional provider contracts that can be registered using a dynamic feature concept.

        Conceptually, this callback method is called during a resource or sub-resource method discovery phase (typically once per each discovered resource or sub-resource method) to register provider instances or classes in a configuration scope of each particular method identified by the supplied resource information. The responsibility of the feature is to properly update the supplied configuration context.

        Parameters:
        resourceInfo - resource class and method information.
        context - configurable resource or sub-resource method-level runtime context associated with the resourceInfo in which the feature
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.ws.rs.container (Java(TM) EE 7 Specification APIs)

javax.ws.rs.container

Interfaces

  • AsyncResponse
  • CompletionCallback
  • ConnectionCallback
  • ContainerRequestContext
  • ContainerRequestFilter
  • ContainerResponseContext
  • ContainerResponseFilter
  • DynamicFeature
  • ResourceContext
  • ResourceInfo
  • TimeoutHandler

Annotation Types

  • PreMatching
  • Suspended


javax.ws.rs.container (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.ws.rs.container

Container-specific JAX-RS API.

See: Description

  • Interface Summary
    Interface Description
    AsyncResponse
    An injectable JAX-RS asynchronous response that provides means for asynchronous server side response processing.
    CompletionCallback
    A request processing callback that receives request processing completion events.
    ConnectionCallback
    Asynchronous request processing lifecycle callback that receives connection related asynchronous response lifecycle events.
    ContainerRequestContext
    Container request filter context.
    ContainerRequestFilter
    An extension interface implemented by container request filters.
    ContainerResponseContext
    Container response filter context.
    ContainerResponseFilter
    An extension interface implemented by container response filters.
    DynamicFeature
    A JAX-RS meta-provider for dynamic registration of post-matching providers during a JAX-RS application setup at deployment time.
    ResourceContext
    The resource context provides access to instances of resource classes.
    ResourceInfo
    An injectable class to access the resource class and resource method matched by the current request.
    TimeoutHandler
    Asynchronous response suspend time-out handler.
  • Annotation Types Summary
    Annotation Type Description
    PreMatching
    Global binding annotation that can be applied to a container request filter to indicate that such filter should be applied globally on all resources in the application before the actual resource matching occurs.
    Suspended
    Inject a suspended AsyncResponse into a parameter of an invoked JAX-RS resource or sub-resource method.

Package javax.ws.rs.container Description

Container-specific JAX-RS API.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.ws.rs.container Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.ws.rs.container

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.ws.rs.container.AsyncResponse
  • javax.ws.rs.container.CompletionCallback
  • javax.ws.rs.container.ConnectionCallback
  • javax.ws.rs.container.ContainerRequestContext
  • javax.ws.rs.container.ContainerRequestFilter
  • javax.ws.rs.container.ContainerResponseContext
  • javax.ws.rs.container.ContainerResponseFilter
  • javax.ws.rs.container.DynamicFeature
  • javax.ws.rs.container.ResourceContext
  • javax.ws.rs.container.ResourceInfo
  • javax.ws.rs.container.TimeoutHandler

Annotation Type Hierarchy

  • javax.ws.rs.container.Suspended (implements java.lang.annotation.Annotation)
  • javax.ws.rs.container.PreMatching (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


PreMatching (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs.container

Annotation Type PreMatching

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface PreMatching
    Global binding annotation that can be applied to a container request filter to indicate that such filter should be applied globally on all resources in the application before the actual resource matching occurs.

    The JAX-RS runtime will apply the filters marked with the @PreMatching annotation globally to all resources, before the incoming request has been matched to a particular resource method. Any named binding annotations will be ignored on a component annotated with the @PreMatching annotation.

    Author:
    Marek Potociar
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ResourceContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface ResourceContext

  • public interface ResourceContext
    The resource context provides access to instances of resource classes.

    This interface can be injected using the Context annotation.

    The resource context can be utilized when instances of managed resource classes are to be returned by sub-resource locator methods. Such instances will be injected and managed within the declared scope just like instances of root resource classes.

    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T> T getResource(Class<T> resourceClass)
      Get a resolved instance of a resource or sub-resource class.
      <T> T initResource(T resource)
      Initialize the resource or sub-resource instance.

    • Method Detail

      • getResource

        <T> T getResource(Class<T> resourceClass)
        Get a resolved instance of a resource or sub-resource class.

        The resolved resource instance is properly initialized in the context of the current request processing scope. The scope of the resolved resource instance depends on the managing container. For resources managed by JAX-RS container the default scope is per-request.

        Type Parameters:
        T - the type of the resource class.
        Parameters:
        resourceClass - the resource class.
        Returns:
        an instance if it could be resolved, otherwise null.

      • initResource

        <T> T initResource(T resource)
        Initialize the resource or sub-resource instance. All JAX-RS injectable fields in the resource instance will be properly initialized in the context of the current request processing scope.
        Type Parameters:
        T - resource instance type.
        Parameters:
        resource - resource instance.
        Returns:
        initialized (same) resource instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResourceInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface ResourceInfo

  • public interface ResourceInfo
    An injectable class to access the resource class and resource method matched by the current request. Methods in this class MAY return null if a resource class and method have not been matched, e.g. in a standalone, pre-matching ContainerRequestFilter that was not provided by a post-matching PreMatching.
    Since:
    2.0
    Author:
    Santiago Pericas-Geertsen

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<?> getResourceClass()
      Get the resource class that is the target of a request, or null if this information is not available.
      Method getResourceMethod()
      Get the resource method that is the target of a request, or null if this information is not available.

    • Method Detail

      • getResourceMethod

        Method getResourceMethod()
        Get the resource method that is the target of a request, or null if this information is not available.
        Returns:
        resource method instance or null
        See Also:
        getResourceClass()

      • getResourceClass

        Class<?> getResourceClass()
        Get the resource class that is the target of a request, or null if this information is not available.
        Returns:
        resource class instance or null
        See Also:
        getResourceMethod()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Suspended (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs.container

Annotation Type Suspended

  • @Target(value=PARAMETER)
@Retention(value=RUNTIME)
@Documented
public @interface Suspended
    Inject a suspended AsyncResponse into a parameter of an invoked JAX-RS resource or sub-resource method. The injected AsyncResponse instance is bound to the processing of the active request and can be used to resume the request processing when a response is available.

    By default there is no suspend timeout set and the asynchronous response is suspended indefinitely. The suspend timeout as well as a custom timeout handler can be specified programmatically using the AsyncResponse.setTimeout(long, TimeUnit) and AsyncResponse.setTimeoutHandler(TimeoutHandler) methods. For example:

      @Stateless
  @Path("/")
  public class MyEjbResource {
    …
    @GET
    @Asynchronous
    public void longRunningOperation(@Suspended AsyncResponse ar) {
      ar.setTimeoutHandler(customHandler);
      ar.setTimeout(10, TimeUnit.SECONDS);
      final String result = executeLongRunningOperation();
      ar.resume(result);
    }

    private String executeLongRunningOperation() { … }
  }

    A resource or sub-resource method that injects a suspended instance of an AsyncResponse using the @Suspended annotation is expected be declared to return void type. Methods that inject asynchronous response instance using the @Suspended annotation and declare a return type other than void MUST be detected by the JAX-RS runtime and a warning message MUST be logged. Any response value returned from such resource or sub-resource method MUST be ignored by the framework:

     @Path("/messages/next")
 public class MessagingResource {
     …
     @GET
     public String readMessage(@Suspended AsyncResponse ar) {
         suspended.put(ar);
         return "This response will be ignored.";
     }
     …
 }
    Since:
    2.0
    Author:
    Marek Potociar
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


TimeoutHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.container

Interface TimeoutHandler

  • public interface TimeoutHandler
    Asynchronous response suspend time-out handler. JAX-RS users may utilize this callback interface to provide custom resolution of time-out events.

    By default, JAX-RS runtime generates a WebApplicationException with a HTTP 503 (Service unavailable) error response status code. A custom time-out handler may be set on an asynchronous response instance to provide custom time-out event resolution.

    In case of a suspend time-out event, a custom time-out handler takes typically one of the following actions:

    • Resumes the suspended asynchronous response using a custom response or a custom exception
    • Cancels the response by calling one of the AsyncResponse cancel(...) methods.
    • Extends the suspend period of the response by setting a new suspend time-out
    If the registered time-out handler does not take any of the actions above, the default time-out event processing continues and the response is resumed with a generated WebApplicationException containing the HTTP 503 status code.

    Following example illustrates the use of a custom TimeoutHandler:

     public class MyTimeoutHandler implements TimeoutHandler {
     …
     public void handleTimeout(AsyncResponse ar) {
         if (keepSuspended) {
             ar.setTimeout(10, SECONDS);
         } else if (cancel) {
             ar.cancel(retryPeriod);
         } else {
             ar.resume(defaultResponse);
         }
     }
     …
 }

 @Path("/messages/next")
 public class MessagingResource {
     …
     @GET
     public void readMessage(@Suspended AsyncResponse ar) {
         ar.setTimeoutHandler(new MyTimeoutHandler());
         suspended.put(ar);
     }
     …
 }
    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void handleTimeout(AsyncResponse asyncResponse)
      Invoked when the suspended asynchronous response is about to time out.

    • Method Detail

      • handleTimeout

        void handleTimeout(AsyncResponse asyncResponse)
        Invoked when the suspended asynchronous response is about to time out. Implementing time-out handlers may use the callback method to change the default time-out strategy defined by JAX-RS specification (see AsyncResponse API documentation).

        A custom time-out handler may decide to either

        • resume the suspended response using one of it's resume(...) methods,
        • cancel the suspended response using one of it's cancel(...) methods, or
        • extend the suspend period by setting a new suspend time-out

        In case the time-out handler does not take any of the actions mentioned above, a default time-out strategy is executed by the JAX-RS runtime.
        Parameters:
        asyncResponse - suspended asynchronous response that is timing out.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.ws.rs.container (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.ws.rs.container

  • Packages that use javax.ws.rs.container
    Package Description
    javax.ws.rs.container
    Container-specific JAX-RS API.
  • Classes in javax.ws.rs.container used by javax.ws.rs.container
    Class and Description
    AsyncResponse
    An injectable JAX-RS asynchronous response that provides means for asynchronous server side response processing.
    ContainerRequestContext
    Container request filter context.
    ContainerResponseContext
    Container response filter context.
    ResourceInfo
    An injectable class to access the resource class and resource method matched by the current request.
    TimeoutHandler
    Asynchronous response suspend time-out handler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.container.PreMatching (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.container.PreMatching

No usage of javax.ws.rs.container.PreMatching
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.container.Suspended (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.container.Suspended

No usage of javax.ws.rs.container.Suspended
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.AsyncResponse (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.AsyncResponse

  • Packages that use AsyncResponse
    Package Description
    javax.ws.rs.container
    Container-specific JAX-RS API.

    • Uses of AsyncResponse in javax.ws.rs.container

      Methods in javax.ws.rs.container with parameters of type AsyncResponse
      Modifier and Type Method and Description
      void TimeoutHandler.handleTimeout(AsyncResponse asyncResponse)
      Invoked when the suspended asynchronous response is about to time out.
      void ConnectionCallback.onDisconnect(AsyncResponse disconnected)
      This callback notification method is invoked in case the container detects that the remote client connection associated with the asynchronous response has been disconnected.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.CompletionCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.CompletionCallback

No usage of javax.ws.rs.container.CompletionCallback
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.ConnectionCallback (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.ConnectionCallback

No usage of javax.ws.rs.container.ConnectionCallback
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.ContainerRequestContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.ContainerRequestContext

  • Packages that use ContainerRequestContext
    Package Description
    javax.ws.rs.container
    Container-specific JAX-RS API.

    • Uses of ContainerRequestContext in javax.ws.rs.container

      Methods in javax.ws.rs.container with parameters of type ContainerRequestContext
      Modifier and Type Method and Description
      void ContainerRequestFilter.filter(ContainerRequestContext requestContext)
      Filter method called before a request has been dispatched to a resource.
      void ContainerResponseFilter.filter(ContainerRequestContext requestContext, ContainerResponseContext responseContext)
      Filter method called after a response has been provided for a request (either by a request filter or by a matched resource method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.ContainerRequestFilter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.ContainerRequestFilter

No usage of javax.ws.rs.container.ContainerRequestFilter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.ContainerResponseContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.ContainerResponseContext

  • Packages that use ContainerResponseContext
    Package Description
    javax.ws.rs.container
    Container-specific JAX-RS API.

    • Uses of ContainerResponseContext in javax.ws.rs.container

      Methods in javax.ws.rs.container with parameters of type ContainerResponseContext
      Modifier and Type Method and Description
      void ContainerResponseFilter.filter(ContainerRequestContext requestContext, ContainerResponseContext responseContext)
      Filter method called after a response has been provided for a request (either by a request filter or by a matched resource method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.ContainerResponseFilter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.ContainerResponseFilter

No usage of javax.ws.rs.container.ContainerResponseFilter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.DynamicFeature (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.DynamicFeature

No usage of javax.ws.rs.container.DynamicFeature
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.ResourceContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.ResourceContext

No usage of javax.ws.rs.container.ResourceContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.ResourceInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.ResourceInfo

  • Packages that use ResourceInfo
    Package Description
    javax.ws.rs.container
    Container-specific JAX-RS API.

    • Uses of ResourceInfo in javax.ws.rs.container

      Methods in javax.ws.rs.container with parameters of type ResourceInfo
      Modifier and Type Method and Description
      void DynamicFeature.configure(ResourceInfo resourceInfo, FeatureContext context)
      A callback method called by the JAX-RS runtime during the application deployment to register provider instances or classes in a runtime configuration scope of a particular resource or sub-resource method; i.e.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.container.TimeoutHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.container.TimeoutHandler

  • Packages that use TimeoutHandler
    Package Description
    javax.ws.rs.container
    Container-specific JAX-RS API.

    • Uses of TimeoutHandler in javax.ws.rs.container

      Methods in javax.ws.rs.container with parameters of type TimeoutHandler
      Modifier and Type Method and Description
      void AsyncResponse.setTimeoutHandler(TimeoutHandler handler)
      Set/replace a time-out handler for the suspended asynchronous response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AbstractMultivaluedMap (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class AbstractMultivaluedMap<K,V>

  • java.lang.Object
    • javax.ws.rs.core.AbstractMultivaluedMap<K,V>
  • Type Parameters:
    K - the type of keys maintained by this map.
    V - the type of mapped values.
    All Implemented Interfaces:
    Map<K,List<V>>, MultivaluedMap<K,V>
    Direct Known Subclasses:
    MultivaluedHashMap

    public abstract class AbstractMultivaluedMap<K,V>
extends Object
implements MultivaluedMap<K,V>
    Abstract skeleton implementation of a MultivaluedMap that is backed by a [key, multi-value] store represented as a Map<K, List<V>>.
    Author:
    Marek Potociar

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Map<K,List<V>> store
      Backing store for the [key, multi-value] pairs.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractMultivaluedMap(Map<K,List<V>> store)
      Initialize the backing store in the abstract parent multivalued map implementation.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      void add(K key, V value)
      Add a value to the current list of values for the supplied key.
      void addAll(K key, List<V> valueList)
      Add all the values from the supplied value list to the current list of values for the supplied key.
      void addAll(K key, V... newValues)
      Add multiple values to the current list of values for the supplied key.
      void addFirst(K key, V value)
      Add a value to the first position in the current list of values for the supplied key.
      protected void addFirstNull(List<V> values)
      Define the behavior for adding a null values to the first position in the value list.
      protected void addNull(List<V> values)
      Define the behavior for adding a null values to the value list.
      void | clear()
      boolean | containsKey(Object key)
      boolean | containsValue(Object value)
      Set<Map.Entry<K,List<V>>> entrySet()
      boolean equals(Object o)

      This implementation delegates the method call to to the the underlying [key, multi-value] store.
      boolean equalsIgnoreValueOrder(MultivaluedMap<K,V> omap)
      Compare the specified map with this map for equality modulo the order of values for each key.
      List<V> | get(Object key)
      V getFirst(K key)
      A shortcut to get the first value of the supplied key.
      protected List<V> getValues(K key)
      Return a non-null list of values for a given key.
      int hashCode()

      This implementation delegates the method call to to the the underlying [key, multi-value] store.
      boolean | isEmpty()
      Set<K> keySet()
      List<V> | put(K key, List<V> value)
      void | putAll(Map<? extends K,? extends List<V>> m)
      void putSingle(K key, V value)
      Set the value for the key to be a one item list consisting of the supplied value.
      List<V> | remove(Object key)
      int | size()
      String toString()
      Collection<List<V>> values()

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Field Detail

      • store

        protected final Map<K,List<V>> store
        Backing store for the [key, multi-value] pairs.

    • Constructor Detail

      • AbstractMultivaluedMap

        public AbstractMultivaluedMap(Map<K,List<V>> store)
        Initialize the backing store in the abstract parent multivalued map implementation.
        Parameters:
        store - the backing Map to be used as a [key, multi-value] store. Must not be null.
        Throws:
        NullPointerException - in case the underlying store parameter is null.

    • Method Detail

      • putSingle

        public final void putSingle(K key,
             V value)
        Set the value for the key to be a one item list consisting of the supplied value. Any existing values will be replaced.

        NOTE: This implementation ignores null values; A supplied value of null is ignored and not added to the purged value list. As a result of such operation, empty value list would be registered for the supplied key. Overriding implementations may modify this behavior by redefining the addNull(java.util.List) method.

        Specified by:
        putSingle in interface MultivaluedMap<K,V>
        Parameters:
        key - the key
        value - the single value of the key. If the value is null it will be ignored.

      • addNull

        protected void addNull(List<V> values)
        Define the behavior for adding a null values to the value list.

        Default implementation is a no-op, i.e. the null values are ignored. Overriding implementations may modify this behavior by providing their own definitions of this method.

        Parameters:
        values - value list where the null value addition is being requested.

      • addFirstNull

        protected void addFirstNull(List<V> values)
        Define the behavior for adding a null values to the first position in the value list.

        Default implementation is a no-op, i.e. the null values are ignored. Overriding implementations may modify this behavior by providing their own definitions of this method.

        Parameters:
        values - value list where the null value addition is being requested.

      • add

        public final void add(K key,
       V value)
        Add a value to the current list of values for the supplied key.

        NOTE: This implementation ignores null values; A supplied value of null is ignored and not added to the value list. Overriding implementations may modify this behavior by redefining the addNull(java.util.List) method.

        Specified by:
        add in interface MultivaluedMap<K,V>
        Parameters:
        key - the key
        value - the value to be added.

      • addAll

        public final void addAll(K key,
          V... newValues)
        Add multiple values to the current list of values for the supplied key. If the supplied array of new values is empty, method returns immediately. Method throws a NullPointerException if the supplied array of values is null.

        NOTE: This implementation ignores null values; Any of the supplied values of null is ignored and not added to the value list. Overriding implementations may modify this behavior by redefining the addNull(java.util.List) method.

        Specified by:
        addAll in interface MultivaluedMap<K,V>
        Parameters:
        key - the key.
        newValues - the values to be added.
        Throws:
        NullPointerException - if the supplied array of new values is null.

      • addAll

        public final void addAll(K key,
          List<V> valueList)
        Add all the values from the supplied value list to the current list of values for the supplied key. If the supplied value list is empty, method returns immediately. Method throws a NullPointerException if the supplied array of values is null.

        NOTE: This implementation ignores null values; Any null value in the supplied value list is ignored and not added to the value list. Overriding implementations may modify this behavior by redefining the addNull(java.util.List) method.

        Specified by:
        addAll in interface MultivaluedMap<K,V>
        Parameters:
        key - the key.
        valueList - the list of values to be added.
        Throws:
        NullPointerException - if the supplied value list is null.

      • getFirst

        public final V getFirst(K key)
        Description copied from interface: MultivaluedMap
        A shortcut to get the first value of the supplied key.
        Specified by:
        getFirst in interface MultivaluedMap<K,V>
        Parameters:
        key - the key
        Returns:
        the first value for the specified key or null if the key is not in the map.

      • addFirst

        public final void addFirst(K key,
            V value)
        Add a value to the first position in the current list of values for the supplied key.

        NOTE: This implementation ignores null values; A supplied value of null is ignored and not added to the purged value list. Overriding implementations may modify this behavior by redefining the addFirstNull(java.util.List) method.

        Specified by:
        addFirst in interface MultivaluedMap<K,V>
        Parameters:
        key - the key
        value - the value to be added.

      • getValues

        protected final List<V> getValues(K key)
        Return a non-null list of values for a given key. The returned list may be empty.

        If there is no entry for the key in the map, a new empty List instance is created, registered within the map to hold the values of the key and returned from the method.

        Parameters:
        key - the key.
        Returns:
        value list registered with the key. The method is guaranteed to never return null.

      • toString

        public String toString()
        Overrides:
        toString in class Object

      • hashCode

        public int hashCode()

        This implementation delegates the method call to to the the underlying [key, multi-value] store.

        Specified by:
        hashCode in interface Map<K,List<V>>
        Overrides:
        hashCode in class Object
        Returns:
        a hash code value for the underlying [key, multi-value] store.

      • equals

        public boolean equals(Object o)

        This implementation delegates the method call to to the the underlying [key, multi-value] store.

        Specified by:
        equals in interface Map<K,List<V>>
        Overrides:
        equals in class Object
        Returns:
        true if the specified object is equal to the underlying [key, multi-value] store, false otherwise.

      • values

        public Collection<List<V>> values()
        Specified by:
        values in interface Map<K,List<V>>

      • size

        public int size()
        Specified by:
        size in interface Map<K,List<V>>

      • remove

        public List<V> remove(Object key)
        Specified by:
        remove in interface Map<K,List<V>>

      • putAll

        public void putAll(Map<? extends K,? extends List<V>> m)
        Specified by:
        putAll in interface Map<K,List<V>>

      • put

        public List<V> put(K key,
          List<V> value)
        Specified by:
        put in interface Map<K,List<V>>

      • keySet

        public Set<K> keySet()
        Specified by:
        keySet in interface Map<K,List<V>>

      • isEmpty

        public boolean isEmpty()
        Specified by:
        isEmpty in interface Map<K,List<V>>

      • get

        public List<V> get(Object key)
        Specified by:
        get in interface Map<K,List<V>>

      • entrySet

        public Set<Map.Entry<K,List<V>>> entrySet()
        Specified by:
        entrySet in interface Map<K,List<V>>

      • containsValue

        public boolean containsValue(Object value)
        Specified by:
        containsValue in interface Map<K,List<V>>

      • containsKey

        public boolean containsKey(Object key)
        Specified by:
        containsKey in interface Map<K,List<V>>

      • clear

        public void clear()
        Specified by:
        clear in interface Map<K,List<V>>

      • equalsIgnoreValueOrder

        public boolean equalsIgnoreValueOrder(MultivaluedMap<K,V> omap)
        Description copied from interface: MultivaluedMap
        Compare the specified map with this map for equality modulo the order of values for each key. Specifically, the values associated with each key are compared as if they were ordered lists.
        Specified by:
        equalsIgnoreValueOrder in interface MultivaluedMap<K,V>
        Parameters:
        omap - map to be compared to this one.
        Returns:
        true if the maps are equal modulo value ordering.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Application (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class Application

  • java.lang.Object
    • javax.ws.rs.core.Application

  • public class Application
extends Object
    Defines the components of a JAX-RS application and supplies additional meta-data. A JAX-RS application or implementation supplies a concrete subclass of this abstract class.

    The implementation-created instance of an Application subclass may be injected into resource classes and providers using Context.

    In case any of the Application subclass methods or it's constructor throws a RuntimeException, the deployment of the application SHOULD be aborted with a failure.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley, Marek Potociar

    • Constructor Summary

      Constructors
      Constructor and Description
      Application()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<Class<?>> getClasses()
      Get a set of root resource, provider and feature classes.
      Map<String,Object> getProperties()
      Get a map of custom application-wide properties.
      Set<Object> getSingletons()
      Get a set of root resource, provider and feature instances.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Application

        public Application()

    • Method Detail

      • getClasses

        public Set<Class<?>> getClasses()
        Get a set of root resource, provider and feature classes. The default life-cycle for resource class instances is per-request. The default life-cycle for providers (registered directly or via a feature) is singleton.

        Implementations should warn about and ignore classes that do not conform to the requirements of root resource or provider/feature classes. Implementations should warn about and ignore classes for which getSingletons() returns an instance. Implementations MUST NOT modify the returned set.

        The default implementation returns an empty set.

        Returns:
        a set of root resource and provider classes. Returning null is equivalent to returning an empty set.

      • getSingletons

        public Set<Object> getSingletons()
        Get a set of root resource, provider and feature instances. Fields and properties of returned instances are injected with their declared dependencies (see Context) by the runtime prior to use.

        Implementations should warn about and ignore classes that do not conform to the requirements of root resource or provider classes. Implementations should flag an error if the returned set includes more than one instance of the same class. Implementations MUST NOT modify the returned set.

        The default implementation returns an empty set.

        Returns:
        a set of root resource and provider instances. Returning null is equivalent to returning an empty set.

      • getProperties

        public Map<String,Object> getProperties()
        Get a map of custom application-wide properties.

        The returned properties are reflected in the application configuration passed to the server-side features or injected into server-side JAX-RS components.

        The set of returned properties may be further extended or customized at deployment time using container-specific features and deployment descriptors. For example, in a Servlet-based deployment scenario, web application's <context-param> and Servlet <init-param> values may be used to extend or override values of the properties programmatically returned by this method.

        The default implementation returns an empty set.

        Returns:
        a map of custom application-wide properties. Returning null is equivalent to returning an empty set.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CacheControl (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class CacheControl

  • java.lang.Object
    • javax.ws.rs.core.CacheControl

  • public class CacheControl
extends Object
    An abstraction for the value of a HTTP Cache-Control response header.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    HTTP/1.1 section 14.9

    • Constructor Summary

      Constructors
      Constructor and Description
      CacheControl()
      Create a new instance of CacheControl.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Compares object argument to this cache control to see if they are the same considering all property values.
      Map<String,String> getCacheExtension()
      Corresponds to a set of extension cache control directives.
      int getMaxAge()
      Corresponds to the max-age cache control directive.
      List<String> getNoCacheFields()
      Corresponds to the value of the no-cache cache control directive.
      List<String> getPrivateFields()
      Corresponds to the value of the private cache control directive.
      int getSMaxAge()
      Corresponds to the s-maxage cache control directive.
      int hashCode()
      Generate hash code from cache control properties.
      boolean isMustRevalidate()
      Corresponds to the must-revalidate cache control directive.
      boolean isNoCache()
      Corresponds to the no-cache cache control directive.
      boolean isNoStore()
      Corresponds to the no-store cache control directive.
      boolean isNoTransform()
      Corresponds to the no-transform cache control directive.
      boolean isPrivate()
      Corresponds to the private cache control directive.
      boolean isProxyRevalidate()
      Corresponds to the proxy-revalidate cache control directive.
      void setMaxAge(int maxAge)
      Corresponds to the max-age cache control directive.
      void setMustRevalidate(boolean mustRevalidate)
      Corresponds to the must-revalidate cache control directive.
      void setNoCache(boolean noCache)
      Corresponds to the no-cache cache control directive.
      void setNoStore(boolean noStore)
      Corresponds to the no-store cache control directive.
      void setNoTransform(boolean noTransform)
      Corresponds to the no-transform cache control directive.
      void setPrivate(boolean flag)
      Corresponds to the private cache control directive.
      void setProxyRevalidate(boolean proxyRevalidate)
      Corresponds to the must-revalidate cache control directive.
      void setSMaxAge(int sMaxAge)
      Corresponds to the s-maxage cache control directive.
      String toString()
      Convert the cache control to a string suitable for use as the value of the corresponding HTTP header.
      static CacheControl valueOf(String value)
      Creates a new instance of CacheControl by parsing the supplied string.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • CacheControl

        public CacheControl()
        Create a new instance of CacheControl. The new instance will have the following default settings:
        • private = false
        • noCache = false
        • noStore = false
        • noTransform = true
        • mustRevalidate = false
        • proxyRevalidate = false
        • An empty list of private fields
        • An empty list of no-cache fields
        • An empty map of cache extensions

    • Method Detail

      • valueOf

        public static CacheControl valueOf(String value)
        Creates a new instance of CacheControl by parsing the supplied string.
        Parameters:
        value - the cache control string
        Returns:
        the newly created CacheControl
        Throws:
        IllegalArgumentException - if the supplied string cannot be parsed or is null

      • isMustRevalidate

        public boolean isMustRevalidate()
        Corresponds to the must-revalidate cache control directive.
        Returns:
        true if the must-revalidate cache control directive will be included in the response, false otherwise.
        See Also:
        HTTP/1.1 section 14.9.4

      • setMustRevalidate

        public void setMustRevalidate(boolean mustRevalidate)
        Corresponds to the must-revalidate cache control directive.
        Parameters:
        mustRevalidate - true if the must-revalidate cache control directive should be included in the response, false otherwise.
        See Also:
        HTTP/1.1 section 14.9.4

      • isProxyRevalidate

        public boolean isProxyRevalidate()
        Corresponds to the proxy-revalidate cache control directive.
        Returns:
        true if the proxy-revalidate cache control directive will be included in the response, false otherwise.
        See Also:
        HTTP/1.1 section 14.9.4

      • setProxyRevalidate

        public void setProxyRevalidate(boolean proxyRevalidate)
        Corresponds to the must-revalidate cache control directive.
        Parameters:
        proxyRevalidate - true if the proxy-revalidate cache control directive should be included in the response, false otherwise.
        See Also:
        HTTP/1.1 section 14.9.4

      • getMaxAge

        public int getMaxAge()
        Corresponds to the max-age cache control directive.
        Returns:
        the value of the max-age cache control directive, -1 if the directive is disabled.
        See Also:
        HTTP/1.1 section 14.9.3

      • setMaxAge

        public void setMaxAge(int maxAge)
        Corresponds to the max-age cache control directive.
        Parameters:
        maxAge - the value of the max-age cache control directive, a value of -1 will disable the directive.
        See Also:
        HTTP/1.1 section 14.9.3

      • getSMaxAge

        public int getSMaxAge()
        Corresponds to the s-maxage cache control directive.
        Returns:
        the value of the s-maxage cache control directive, -1 if the directive is disabled.
        See Also:
        HTTP/1.1 section 14.9.3

      • setSMaxAge

        public void setSMaxAge(int sMaxAge)
        Corresponds to the s-maxage cache control directive.
        Parameters:
        sMaxAge - the value of the s-maxage cache control directive, a value of -1 will disable the directive.
        See Also:
        HTTP/1.1 section 14.9.3

      • getNoCacheFields

        public List<String> getNoCacheFields()
        Corresponds to the value of the no-cache cache control directive.
        Returns:
        a mutable list of field-names that will form the value of the no-cache cache control directive. An empty list results in a bare no-cache directive.
        See Also:
        isNoCache(), setNoCache(boolean), HTTP/1.1 section 14.9.1

      • setNoCache

        public void setNoCache(boolean noCache)
        Corresponds to the no-cache cache control directive.
        Parameters:
        noCache - true if the no-cache cache control directive should be included in the response, false otherwise.
        See Also:
        getNoCacheFields(), HTTP/1.1 section 14.9.1

      • isNoCache

        public boolean isNoCache()
        Corresponds to the no-cache cache control directive.
        Returns:
        true if the no-cache cache control directive will be included in the response, false otherwise.
        See Also:
        getNoCacheFields(), HTTP/1.1 section 14.9.1

      • isPrivate

        public boolean isPrivate()
        Corresponds to the private cache control directive.
        Returns:
        true if the private cache control directive will be included in the response, false otherwise.
        See Also:
        getPrivateFields(), HTTP/1.1 section 14.9.1

      • getPrivateFields

        public List<String> getPrivateFields()
        Corresponds to the value of the private cache control directive.
        Returns:
        a mutable list of field-names that will form the value of the private cache control directive. An empty list results in a bare no-cache directive.
        See Also:
        isPrivate(), setPrivate(boolean), HTTP/1.1 section 14.9.1

      • setPrivate

        public void setPrivate(boolean flag)
        Corresponds to the private cache control directive.
        Parameters:
        flag - true if the private cache control directive should be included in the response, false otherwise.
        See Also:
        getPrivateFields(), HTTP/1.1 section 14.9.1

      • isNoTransform

        public boolean isNoTransform()
        Corresponds to the no-transform cache control directive.
        Returns:
        true if the no-transform cache control directive will be included in the response, false otherwise.
        See Also:
        HTTP/1.1 section 14.9.5

      • setNoTransform

        public void setNoTransform(boolean noTransform)
        Corresponds to the no-transform cache control directive.
        Parameters:
        noTransform - true if the no-transform cache control directive should be included in the response, false otherwise.
        See Also:
        HTTP/1.1 section 14.9.5

      • isNoStore

        public boolean isNoStore()
        Corresponds to the no-store cache control directive.
        Returns:
        true if the no-store cache control directive will be included in the response, false otherwise.
        See Also:
        HTTP/1.1 section 14.9.2

      • setNoStore

        public void setNoStore(boolean noStore)
        Corresponds to the no-store cache control directive.
        Parameters:
        noStore - true if the no-store cache control directive should be included in the response, false otherwise.
        See Also:
        HTTP/1.1 section 14.9.2

      • getCacheExtension

        public Map<String,String> getCacheExtension()
        Corresponds to a set of extension cache control directives.
        Returns:
        a mutable map of cache control extension names and their values. If a key has a null value, it will appear as a bare directive. If a key has a value that contains no whitespace then the directive will appear as a simple name=value pair. If a key has a value that contains whitespace then the directive will appear as a quoted name="value" pair.
        See Also:
        HTTP/1.1 section 14.9.6

      • toString

        public String toString()
        Convert the cache control to a string suitable for use as the value of the corresponding HTTP header.
        Overrides:
        toString in class Object
        Returns:
        a stringified cache control

      • hashCode

        public int hashCode()
        Generate hash code from cache control properties.
        Overrides:
        hashCode in class Object
        Returns:
        the hashCode

      • equals

        public boolean equals(Object obj)
        Compares object argument to this cache control to see if they are the same considering all property values.
        Overrides:
        equals in class Object
        Parameters:
        obj - the object to compare to
        Returns:
        true if the two cache controls are the same, false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Configurable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface Configurable<C extends Configurable>

  • All Known Subinterfaces:
    Client, FeatureContext, WebTarget
    All Known Implementing Classes:
    ClientBuilder

    public interface Configurable<C extends Configurable>
    Represents a client or server-side configurable context in JAX-RS. A configurable context can be used to define the JAX-RS components as well as additional meta-data that should be used in the scope of the configured context. The modification of the context typically involves setting properties or registering custom JAX-RS components, such as providers and/or features. All modifications of a Configurable context are reflected in the associated Configuration state which is exposed via getConfiguration() method.

    A configurable context can be either indirectly associated with a particular JAX-RS component (such as application or resource method configurable context passed to a Feature or DynamicFeature meta-providers) or can be directly represented by a concrete JAX-RS component implementing the Configurable interface (such as Client or WebTarget). As such, the exact scope of a configuration context is typically determined by a use case scenario in which the context is accessed.

    Setting properties.

    New properties can be set using the property(java.lang.String, java.lang.Object) method. Similarly, updating a value of an existing property can be achieved using the same method. Information about the configured set of properties is available via the underlying Configuration object. An existing property can be removed by assigning a null value to the property.

    Registering JAX-RS components.

    Registered custom JAX-RS component classes and instances are important part of the contextual configuration information as these are the main factors that determine the capabilities of a configured runtime. Implementations SHOULD warn about and ignore registrations that do not conform to the requirements of supported JAX-RS components in a given configurable context.

    In most cases, when registering a JAX-RS component, the simplest form of methods (register(Class) or register(Object)) of the available registration API is sufficient.

    For example:

     config.register(HtmlDocumentReader.class);
 config.register(new HtmlDocumentWriter(writerConfig));

    In some situations a JAX-RS component class or instance may implement multiple provider contracts recognized by a JAX-RS implementation (e.g. filter, interceptor or entity provider). By default, the JAX-RS implementation MUST register the new component class or instance as a provider for all the recognized provider contracts implemented by the component class.

    For example:

     @Priority(ENTITY_CODER)
 public class GzipInterceptor
         implements ReaderInterceptor, WriterInterceptor { ... }

 ...

 // register GzipInterceptor as a ReaderInterceptor
 // as well as a WriterInterceptor
 config.register(GzipInterceptor.class);

    There are however situations when the default registration of a JAX-RS component to all the recognized provider contracts is not desirable. In such cases users may use other versions of the register(...) method to explicitly specify the collection of the provider contracts for which the JAX-RS component should be registered and/or the priority of each registered provider contract.

    For example:

     @Priority(USER)
 public class ClientLoggingFilter
         implements ClientRequestFilter, ClientResponseFilter { ... }

 @Priority(ENTITY_CODER)
 public class GzipInterceptor
         implements ReaderInterceptor, WriterInterceptor { ... }

 ...

 // register ClientLoggingFilter as a ClientResponseFilter only
 config.register(ClientLoggingFilter.class, ClientResponseFilter.class);

 // override the priority of registered GzipInterceptor
 // and both of it's provider contracts
 config.register(GzipInterceptor.class, 6500);

    As a general rule, for each JAX-RS component class there can be at most one registration — class-based or instance-based — configured at any given moment. Implementations MUST reject any attempts to configure a new registration for a provider class that has been already registered in the given configurable context earlier. Implementations SHOULD also raise a warning to inform the user about the rejected component registration.

    For example:

     config.register(GzipInterceptor.class, WriterInterceptor.class);
 config.register(GzipInterceptor.class);       // Rejected by runtime.
 config.register(new GzipInterceptor());       // Rejected by runtime.
 config.register(GzipInterceptor.class, 6500); // Rejected by runtime.

 config.register(new ClientLoggingFilter());
 config.register(ClientLoggingFilter.class);   // rejected by runtime.
 config.register(ClientLoggingFilter.class,
                 ClientResponseFilter.class);  // Rejected by runtime.

    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Configuration getConfiguration()
      Get a live view of an internal configuration state of this configurable instance.
      C property(String name, Object value)
      Set the new configuration property, if already set, the existing value of the property will be updated.
      C register(Class<?> componentClass)
      Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.
      C register(Class<?> componentClass, Class<?>... contracts)
      Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.
      C register(Class<?> componentClass, int priority)
      Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.
      C register(Class<?> componentClass, Map<Class<?>,Integer> contracts)
      Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.
      C register(Object component)
      Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.
      C register(Object component, Class<?>... contracts)
      Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.
      C register(Object component, int priority)
      Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.
      C register(Object component, Map<Class<?>,Integer> contracts)
      Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

    • Method Detail

      • getConfiguration

        Configuration getConfiguration()
        Get a live view of an internal configuration state of this configurable instance. Any changes made using methods of this Configurable instance will be reflected in the returned Configuration instance.

        The returned Configuration instance and the collection data it provides are not thread-safe wrt. modification made using methods on the parent configurable object.

        Returns:
        configuration live view of the internal configuration state.

      • property

        C property(String name,
         Object value)
        Set the new configuration property, if already set, the existing value of the property will be updated. Setting a null value into a property effectively removes the property from the property bag.
        Parameters:
        name - property name.
        value - (new) property value. null value removes the property with the given name.
        Returns:
        the updated configurable instance.

      • register

        C register(Class<?> componentClass)
        Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context. Implementations SHOULD warn about and ignore registrations that do not conform to the requirements of supported JAX-RS component types in the given configurable context. Any subsequent registration attempts for a component type, for which a class or instance-based registration already exists in the system MUST be rejected by the JAX-RS implementation and a warning SHOULD be raised to inform the user about the rejected registration. The registered JAX-RS component class is registered as a contract provider of all the recognized JAX-RS or implementation-specific extension contracts including meta-provider contracts, such as Feature or DynamicFeature.

        As opposed to component instances registered via register(Object) method, the lifecycle of components registered using this class-based register(...) method is fully managed by the JAX-RS implementation or any underlying IoC container supported by the implementation.

        Parameters:
        componentClass - JAX-RS component class to be configured in the scope of this configurable context.
        Returns:
        the updated configurable context.

      • register

        C register(Class<?> componentClass,
         int priority)
        Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

        This registration method provides the same functionality as register(Class) except that any priority specified on the registered JAX-RS component class via javax.annotation.Priority annotation is overridden with the supplied priority value.

        Note that in case the priority is not applicable to a particular provider contract implemented by the class of the registered component, the supplied priority value will be ignored for that contract.

        Parameters:
        componentClass - JAX-RS component class to be configured in the scope of this configurable context.
        priority - the overriding priority for the registered component and all the provider contracts the component implements.
        Returns:
        the updated configurable context.

      • register

        C register(Class<?> componentClass,
         Class<?>... contracts)
        Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

        This registration method provides the same functionality as register(Class) except the JAX-RS component class is only registered as a provider of the listed extension provider or meta-provider contracts. All explicitly enumerated contract types must represent a class or an interface implemented or extended by the registered component. Contracts that are not assignable from the registered component class MUST be ignored and implementations SHOULD raise a warning to inform users about the ignored contract(s).

        Parameters:
        componentClass - JAX-RS component class to be configured in the scope of this configurable context.
        contracts - the specific extension provider or meta-provider contracts implemented by the component for which the component should be registered. Implementations MUST ignore attempts to register a component class for an empty or null collection of contracts via this method and SHOULD raise a warning about such event.
        Returns:
        the updated configurable context.

      • register

        C register(Class<?> componentClass,
         Map<Class<?>,Integer> contracts)
        Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

        This registration method provides same functionality as register(Class, Class[]) except that any priority specified on the registered JAX-RS component class via javax.annotation.Priority annotation is overridden for each extension provider contract type separately with an integer priority value specified as a value in the supplied map of [contract type, priority] pairs.

        Note that in case a priority is not applicable to a provider contract registered for the JAX-RS component, the supplied priority value is ignored for such contract.

        Parameters:
        componentClass - JAX-RS component class to be configured in the scope of this configurable context.
        contracts - map of the specific extension provider and meta-provider contracts and their associated priorities for which the JAX-RS component is registered. All contracts in the map must represent a class or an interface implemented or extended by the JAX-RS component. Contracts that are not assignable from the registered component class MUST be ignored and implementations SHOULD raise a warning to inform users about the ignored contract(s).
        Returns:
        the updated configurable context.

      • register

        C register(Object component)
        Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context. Implementations SHOULD warn about and ignore registrations that do not conform to the requirements of supported JAX-RS component types in the given configurable context. Any subsequent registration attempts for a component type, for which a class or instance-based registration already exists in the system MUST be rejected by the JAX-RS implementation and a warning SHOULD be raised to inform the user about the rejected registration. The registered JAX-RS component is registered as a contract provider of all the recognized JAX-RS or implementation-specific extension contracts including meta-provider contracts, such as Feature or DynamicFeature.

        As opposed to components registered via register(Class) method, the lifecycle of providers registered using this instance-based register(...) is not managed by JAX-RS runtime. The same registered component instance is used during the whole lifespan of the configurable context. Fields and properties of all registered JAX-RS component instances are injected with their declared dependencies (see Context) by the JAX-RS runtime prior to use.

        Parameters:
        component - JAX-RS component instance to be configured in the scope of this configurable context.
        Returns:
        the updated configurable context.

      • register

        C register(Object component,
         int priority)
        Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

        This registration method provides the same functionality as register(Object) except that any priority specified on the registered JAX-RS component class via javax.annotation.Priority annotation is overridden with the supplied priority value.

        Note that in case the priority is not applicable to a particular provider contract implemented by the class of the registered component, the supplied priority value will be ignored for that contract.

        Parameters:
        component - JAX-RS component instance to be configured in the scope of this configurable context.
        priority - the overriding priority for the registered component and all the provider contracts the component implements.
        Returns:
        the updated configurable context.

      • register

        C register(Object component,
         Class<?>... contracts)
        Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

        This registration method provides the same functionality as register(Object) except the JAX-RS component class is only registered as a provider of the listed extension provider or meta-provider contracts. All explicitly enumerated contract types must represent a class or an interface implemented or extended by the registered component. Contracts that are not assignable from the registered component class MUST be ignored and implementations SHOULD raise a warning to inform users about the ignored contract(s).

        Parameters:
        component - JAX-RS component instance to be configured in the scope of this configurable context.
        contracts - the specific extension provider or meta-provider contracts implemented by the component for which the component should be registered. Implementations MUST ignore attempts to register a component class for an empty or null collection of contracts via this method and SHOULD raise a warning about such event.
        Returns:
        the updated configurable context.

      • register

        C register(Object component,
         Map<Class<?>,Integer> contracts)
        Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

        This registration method provides same functionality as register(Object, Class[]) except that any priority specified on the registered JAX-RS component class via javax.annotation.Priority annotation is overridden for each extension provider contract type separately with an integer priority value specified as a value in the supplied map of [contract type, priority] pairs.

        Note that in case a priority is not applicable to a provider contract registered for the JAX-RS component, the supplied priority value is ignored for such contract.

        Parameters:
        component - JAX-RS component instance to be configured in the scope of this configurable context.
        contracts - map of the specific extension provider and meta-provider contracts and their associated priorities for which the JAX-RS component is registered. All contracts in the map must represent a class or an interface implemented or extended by the JAX-RS component. Contracts that are not assignable from the registered component class MUST be ignored and implementations SHOULD raise a warning to inform users about the ignored contract(s).
        Returns:
        the updated configurable context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Configuration (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface Configuration

  • public interface Configuration
    A configuration state associated with a configurable JAX-RS context. Defines the components as well as additional meta-data for the configured context.

    A configuration state may be used to retrieve configuration information about of the associated JAX-RS context (e.g. application, resource method, etc.) or component (e.g. Client, WebTarget, etc.). Configuration information consists of properties, registered JAX-RS component classes and/or instances.

    This interface can be injected using the Context annotation.

    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<Class<?>> getClasses()
      Get the immutable set of registered JAX-RS component (such as provider or feature) classes to be instantiated, injected and utilized in the scope of the configurable instance.
      Map<Class<?>,Integer> getContracts(Class<?> componentClass)
      Get the extension contract registration information for a component of a given class.
      Set<Object> getInstances()
      Get the immutable set of registered JAX-RS component (such as provider or feature) instances to be utilized by the configurable instance.
      Map<String,Object> getProperties()
      Get the immutable bag of configuration properties.
      Object getProperty(String name)
      Get the value for the property with a given name.
      Collection<String> getPropertyNames()
      Returns an immutable collection containing the property names available within the context of the current configuration instance.
      RuntimeType getRuntimeType()
      Get the runtime type of this configuration context.
      boolean isEnabled(Class<? extends Feature> featureClass)
      Check if a feature instance of featureClass class has been previously enabled in the runtime configuration context.
      boolean isEnabled(Feature feature)
      Check if a particular feature instance has been previously enabled in the runtime configuration context.
      boolean isRegistered(Class<?> componentClass)
      Check if a JAX-RS component of the supplied componentClass class has been previously registered in the runtime configuration context.
      boolean isRegistered(Object component)
      Check if a particular JAX-RS component instance (such as providers or features) has been previously registered in the runtime configuration context.

    • Method Detail

      • getRuntimeType

        RuntimeType getRuntimeType()
        Get the runtime type of this configuration context.
        Returns:
        configuration context runtime type.

      • getProperties

        Map<String,Object> getProperties()
        Get the immutable bag of configuration properties.
        Returns:
        the immutable view of configuration properties.

      • getProperty

        Object getProperty(String name)
        Get the value for the property with a given name.
        Parameters:
        name - property name.
        Returns:
        the property value for the specified property name or null if the property with such name is not configured.

      • getPropertyNames

        Collection<String> getPropertyNames()
        Returns an immutable collection containing the property names available within the context of the current configuration instance.

        Use the getProperty(java.lang.String) method with a property name to get the value of a property.

        Returns:
        an immutable collection of property names.
        See Also:
        getProperty(java.lang.String)

      • isEnabled

        boolean isEnabled(Feature feature)
        Check if a particular feature instance has been previously enabled in the runtime configuration context.

        Method returns true only in case an instance equal to the feature instance is already present among the features previously successfully enabled in the configuration context.

        Parameters:
        feature - a feature instance to test for.
        Returns:
        true if the feature instance has been previously enabled in this configuration context, false otherwise.

      • isEnabled

        boolean isEnabled(Class<? extends Feature> featureClass)
        Check if a feature instance of featureClass class has been previously enabled in the runtime configuration context.

        Method returns true in case any instance of the featureClass class is already present among the features previously successfully enabled in the configuration context.

        Parameters:
        featureClass - a feature class to test for.
        Returns:
        true if a feature of a given class has been previously enabled in this configuration context, false otherwise.

      • isRegistered

        boolean isRegistered(Object component)
        Check if a particular JAX-RS component instance (such as providers or features) has been previously registered in the runtime configuration context.

        Method returns true only in case an instance equal to the component instance is already present among the components previously registered in the configuration context.

        Parameters:
        component - a component instance to test for.
        Returns:
        true if the component instance has been previously registered in this configuration context, false otherwise.
        See Also:
        isEnabled(Feature)

      • isRegistered

        boolean isRegistered(Class<?> componentClass)
        Check if a JAX-RS component of the supplied componentClass class has been previously registered in the runtime configuration context.

        Method returns true in case a component of the supplied componentClass class is already present among the previously registered component classes or instances in the configuration context.

        Parameters:
        componentClass - a component class to test for.
        Returns:
        true if a component of a given class has been previously registered in this configuration context, false otherwise.
        See Also:
        isEnabled(Class)

      • getContracts

        Map<Class<?>,Integer> getContracts(Class<?> componentClass)
        Get the extension contract registration information for a component of a given class. For component classes that are not configured in this configuration context the method returns an empty Map. Method does not return null.
        Returns:
        map of extension contracts and their priorities for which the component class is registered. May return an empty map in case the component has not been registered for any extension contract supported by the implementation.

      • getClasses

        Set<Class<?>> getClasses()
        Get the immutable set of registered JAX-RS component (such as provider or feature) classes to be instantiated, injected and utilized in the scope of the configurable instance.

        For each component type, there can be only a single class-based or instance-based registration present in the configuration context at any given time.

        Returns:
        the immutable set of registered JAX-RS component classes. The returned value may be empty but will never be null.
        See Also:
        getInstances()

      • getInstances

        Set<Object> getInstances()
        Get the immutable set of registered JAX-RS component (such as provider or feature) instances to be utilized by the configurable instance. Fields and properties of returned instances are injected with their declared dependencies (see Context) by the runtime prior to use.

        For each component type, there can be only a single class-based or instance-based registration present in the configuration context at any given time.

        Returns:
        the immutable set of registered JAX-RS component instances. The returned value may be empty but will never be null.
        See Also:
        getClasses()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Context (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs.core

Annotation Type Context

  • @Target(value={PARAMETER,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface Context
    This annotation is used to inject information into a class field, bean property or method parameter.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Application, UriInfo, Request, HttpHeaders, SecurityContext, Providers
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Cookie (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class Cookie

  • java.lang.Object
    • javax.ws.rs.core.Cookie
  • Direct Known Subclasses:
    NewCookie

    public class Cookie
extends Object
    Represents the value of a HTTP cookie, transferred in a request. RFC 2109 specifies the legal characters for name, value, path and domain. The default version of 1 corresponds to RFC 2109.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    IETF RFC 2109

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int DEFAULT_VERSION
      Cookies using the default version correspond to RFC 2109.

    • Constructor Summary

      Constructors
      Constructor and Description
      Cookie(String name, String value)
      Create a new instance.
      Cookie(String name, String value, String path, String domain)
      Create a new instance.
      Cookie(String name, String value, String path, String domain, int version)
      Create a new instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Compare for equality.
      String getDomain()
      Get the domain of the cookie.
      String getName()
      Get the name of the cookie.
      String getPath()
      Get the path of the cookie.
      String getValue()
      Get the value of the cookie.
      int getVersion()
      Get the version of the cookie.
      int hashCode()
      Generate a hash code by hashing all of the cookies properties.
      String toString()
      Convert the cookie to a string suitable for use as the value of the corresponding HTTP header.
      static Cookie valueOf(String value)
      Creates a new instance of Cookie by parsing the supplied string.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Field Detail

      • DEFAULT_VERSION

        public static final int DEFAULT_VERSION
        Cookies using the default version correspond to RFC 2109.
        See Also:
        Constant Field Values

    • Constructor Detail

      • Cookie

        public Cookie(String name,
      String value,
      String path,
      String domain,
      int version)
       throws IllegalArgumentException
        Create a new instance.
        Parameters:
        name - the name of the cookie.
        value - the value of the cookie.
        path - the URI path for which the cookie is valid.
        domain - the host domain for which the cookie is valid.
        version - the version of the specification to which the cookie complies.
        Throws:
        IllegalArgumentException - if name is null.

      • Cookie

        public Cookie(String name,
      String value,
      String path,
      String domain)
       throws IllegalArgumentException
        Create a new instance.
        Parameters:
        name - the name of the cookie.
        value - the value of the cookie.
        path - the URI path for which the cookie is valid.
        domain - the host domain for which the cookie is valid.
        Throws:
        IllegalArgumentException - if name is null.

      • Cookie

        public Cookie(String name,
      String value)
       throws IllegalArgumentException
        Create a new instance.
        Parameters:
        name - the name of the cookie.
        value - the value of the cookie.
        Throws:
        IllegalArgumentException - if name is null.

    • Method Detail

      • valueOf

        public static Cookie valueOf(String value)
        Creates a new instance of Cookie by parsing the supplied string.
        Parameters:
        value - the cookie string.
        Returns:
        the newly created Cookie.
        Throws:
        IllegalArgumentException - if the supplied string cannot be parsed or is null.

      • getName

        public String getName()
        Get the name of the cookie.
        Returns:
        the cookie name.

      • getValue

        public String getValue()
        Get the value of the cookie.
        Returns:
        the cookie value.

      • getVersion

        public int getVersion()
        Get the version of the cookie.
        Returns:
        the cookie version.

      • getDomain

        public String getDomain()
        Get the domain of the cookie.
        Returns:
        the cookie domain.

      • getPath

        public String getPath()
        Get the path of the cookie.
        Returns:
        the cookie path.

      • toString

        public String toString()
        Convert the cookie to a string suitable for use as the value of the corresponding HTTP header.
        Overrides:
        toString in class Object
        Returns:
        a stringified cookie.

      • hashCode

        public int hashCode()
        Generate a hash code by hashing all of the cookies properties.
        Overrides:
        hashCode in class Object
        Returns:
        the cookie hash code.

      • equals

        public boolean equals(Object obj)
        Compare for equality.
        Overrides:
        equals in class Object
        Parameters:
        obj - the object to compare to.
        Returns:
        true, if the object is a Cookie with the same value for all properties, false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityTag (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class EntityTag

  • java.lang.Object
    • javax.ws.rs.core.EntityTag

  • public class EntityTag
extends Object
    An abstraction for the value of a HTTP Entity Tag, used as the value of an ETag response header.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    HTTP/1.1 section 3.11

    • Constructor Summary

      Constructors
      Constructor and Description
      EntityTag(String value)
      Creates a new instance of a strong EntityTag.
      EntityTag(String value, boolean weak)
      Creates a new instance of an EntityTag.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Compares obj to this tag to see if they are the same considering weakness and value.
      String getValue()
      Get the value of an EntityTag.
      int hashCode()
      Generate hashCode based on value and weakness.
      boolean isWeak()
      Check the strength of an EntityTag.
      String toString()
      Convert the entity tag to a string suitable for use as the value of the corresponding HTTP header.
      static EntityTag valueOf(String value)
      Creates a new instance of EntityTag by parsing the supplied string.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EntityTag

        public EntityTag(String value)
        Creates a new instance of a strong EntityTag.
        Parameters:
        value - the value of the tag, quotes not included.
        Throws:
        IllegalArgumentException - if value is null.

      • EntityTag

        public EntityTag(String value,
         boolean weak)
        Creates a new instance of an EntityTag.
        Parameters:
        value - the value of the tag, quotes not included.
        weak - true if this represents a weak tag, false otherwise.
        Throws:
        IllegalArgumentException - if value is null.

    • Method Detail

      • valueOf

        public static EntityTag valueOf(String value)
        Creates a new instance of EntityTag by parsing the supplied string.
        Parameters:
        value - the entity tag string.
        Returns:
        the newly created entity tag.
        Throws:
        IllegalArgumentException - if the supplied string cannot be parsed or is null.

      • isWeak

        public boolean isWeak()
        Check the strength of an EntityTag.
        Returns:
        true if this represents a weak tag, false otherwise.

      • getValue

        public String getValue()
        Get the value of an EntityTag.
        Returns:
        the value of the tag.

      • equals

        public boolean equals(Object obj)
        Compares obj to this tag to see if they are the same considering weakness and value.
        Overrides:
        equals in class Object
        Parameters:
        obj - the object to compare to.
        Returns:
        true if the two tags are the same, false otherwise.

      • hashCode

        public int hashCode()
        Generate hashCode based on value and weakness.
        Overrides:
        hashCode in class Object
        Returns:
        the entity tag hash code.

      • toString

        public String toString()
        Convert the entity tag to a string suitable for use as the value of the corresponding HTTP header.
        Overrides:
        toString in class Object
        Returns:
        a string version of the entity tag.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Feature (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface Feature

  • public interface Feature
    A feature extension contract. Typically encapsulates a concept or facility that involves configuration of multiple providers (e.g. filters or interceptors) and/or properties.

    A Feature is a special type of JAX-RS configuration meta-provider. Once a feature is registered, it's configure(FeatureContext) method is invoked during JAX-RS runtime configuration and bootstrapping phase allowing the feature to further configure the runtime context in which it has been registered. From within the invoked configure(...) method a feature may provide additional runtime configuration for the facility or conceptual domain it represents, such as registering additional contract providers, including nested features and/or specifying domain-specific properties.

    Since:
    2.0
    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean configure(FeatureContext context)
      A call-back method called when the feature is to be enabled in a given runtime configuration scope.

    • Method Detail

      • configure

        boolean configure(FeatureContext context)
        A call-back method called when the feature is to be enabled in a given runtime configuration scope. The responsibility of the feature is to properly update the supplied runtime configuration context and return true if the feature was successfully enabled or false otherwise.

        Note that under some circumstances the feature may decide not to enable itself, which is indicated by returning false. In such case the configuration context does not add the feature to the collection of enabled features and a subsequent call to Configuration.isEnabled(Feature) or Configuration.isEnabled(Class) method would return false.

        Parameters:
        context - configurable context in which the feature should be enabled.
        Returns:
        true if the feature was successfully enabled, false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FeatureContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface FeatureContext

  • All Superinterfaces:
    Configurable<FeatureContext>

    public interface FeatureContext
extends Configurable<FeatureContext>
    A configurable context passed to Feature and DynamicFeature instances by JAX-RS runtime during the phase of their configuration.
    Author:
    Marek Potociar (marek.potociar at oracle.com)

    • Method Summary

      • Methods inherited from interface javax.ws.rs.core.Configurable

        getConfiguration, property, register, register, register, register, register, register, register, register
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Form (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class Form

  • java.lang.Object
    • javax.ws.rs.core.Form

  • public class Form
extends Object
    Represents the the HTML form data request entity encoded using the "application/x-www-form-urlencoded" content type.
    Since:
    2.0
    Author:
    Marek Potociar

    • Constructor Summary

      Constructors
      Constructor and Description
      Form()
      Create a new form data instance.
      Form(MultivaluedMap<String,String> store)
      Create a new form data instance and register a custom underlying parameter store.
      Form(String parameterName, String parameterValue)
      Create a new form data instance with a single parameter entry.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      MultivaluedMap<String,String> asMap()
      Returns multivalued map representation of the form.
      Form param(String name, String value)
      Adds a new value to the specified form parameter.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Form

        public Form()
        Create a new form data instance.

        The underlying form parameter store is configured to preserve the insertion order of the parameters. I.e. parameters can be iterated in the same order as they were inserted into the Form.

      • Form

        public Form(String parameterName,
    String parameterValue)
        Create a new form data instance with a single parameter entry.

        The underlying form parameter store is configured to preserve the insertion order of the parameters. I.e. parameters can be iterated in the same order as they were inserted into the Form.

        Parameters:
        parameterName - form parameter name.
        parameterValue - form parameter value.

      • Form

        public Form(MultivaluedMap<String,String> store)
        Create a new form data instance and register a custom underlying parameter store.

        This method is useful in situations when a custom parameter store is needed in order to change the default parameter iteration order, improve performance or facilitate other custom requirements placed on the parameter store.

        Parameters:
        store - form data store used by the created form instance.

    • Method Detail

      • param

        public Form param(String name,
         String value)
        Adds a new value to the specified form parameter.
        Parameters:
        name - name of the parameter.
        value - new parameter value to be added.
        Returns:
        updated Form instance.

      • asMap

        public MultivaluedMap<String,String> asMap()
        Returns multivalued map representation of the form.
        Returns:
        form represented as multivalued map.
        See Also:
        MultivaluedMap
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


GenericEntity (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class GenericEntity<T>

  • java.lang.Object
    • javax.ws.rs.core.GenericEntity<T>
  • Type Parameters:
    T - response entity instance type

    public class GenericEntity<T>
extends Object
    Represents a message entity of a generic type T.

    Normally type erasure removes generic type information such that a Response instance that contains, e.g., an entity of type List<String> appears to contain a raw List<?> at runtime. When the generic type is required to select a suitable MessageBodyWriter, this class may be used to wrap the entity and capture its generic type.

    There are two ways to create an instance:

    1. Create a (typically anonymous) subclass of this class which enables retrieval of the type information at runtime despite type erasure. For example, the following code shows how to create a Response containing an entity of type List<String> whose generic type will be available at runtime for selection of a suitable MessageBodyWriter:
      List<String> list = new ArrayList<String>();
 GenericEntity<List<String>> entity = new GenericEntity<List<String>>(list) {};
 Response response = Response.ok(entity).build();

      where list is the instance of List<String> that will form the response body and entity is an instance of an anonymous subclass of GenericEntity.

    2. Create an instance directly by supplying the generic type information with the entity. For example the following code shows how to create a response containing the result of a method invoked via reflection:
      Method method = ...;
 GenericEntity<Object> entity = new GenericEntity<Object>(
    method.invoke(...), method.getGenericReturnType());
 Response response = Response.ok(entity).build();

      3. The above obtains the generic type from the return type of the method, the raw type is the class of entity.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    GenericType

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected GenericEntity(T entity)
      Constructs a new generic entity.
        GenericEntity(T entity, Type genericType)
      Create a new instance of GenericEntity, supplying the generic type information.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      boolean | equals(Object obj)
      T getEntity()
      Get the enclosed entity.
      Class<?> getRawType()
      Gets the raw type of the enclosed entity.
      Type getType()
      Gets underlying Type instance.
      int | hashCode()
      String toString()

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • GenericEntity

        protected GenericEntity(T entity)
        Constructs a new generic entity. Derives represented class from type parameter. Note that this constructor is protected, users should create a (usually anonymous) subclass as shown above.
        Parameters:
        entity - the entity instance, must not be null.
        Throws:
        IllegalArgumentException - if entity is null.

      • GenericEntity

        public GenericEntity(T entity,
             Type genericType)
        Create a new instance of GenericEntity, supplying the generic type information. The entity must be assignable to a variable of the supplied generic type, e.g. if entity is an instance of ArrayList<String> then genericType could be the same or a superclass of ArrayList with the same generic type like List<String>.
        Parameters:
        entity - the entity instance, must not be null.
        genericType - the generic type, must not be null.
        Throws:
        IllegalArgumentException - if the entity is not assignable to a variable of the supplied generic type or if entity or genericType is null.

    • Method Detail

      • getRawType

        public final Class<?> getRawType()
        Gets the raw type of the enclosed entity. Note that this is the raw type of the instance, not the raw type of the type parameter. I.e. in the example in the introduction, the raw type is ArrayList not List.
        Returns:
        the raw type.

      • getType

        public final Type getType()
        Gets underlying Type instance. Note that this is derived from the type parameter, not the enclosed instance. I.e. in the example in the introduction, the type is List<String> not ArrayList<String>.
        Returns:
        the type

      • getEntity

        public final T getEntity()
        Get the enclosed entity.
        Returns:
        the enclosed entity.

      • equals

        public boolean equals(Object obj)
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Overrides:
        hashCode in class Object

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


GenericType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class GenericType<T>

  • java.lang.Object
    • javax.ws.rs.core.GenericType<T>
  • Type Parameters:
    T - the generic type parameter.

    public class GenericType<T>
extends Object
    Represents a generic message entity type T. Supports in-line instantiation of objects that represent generic types with actual type parameters. An object that represents any parameterized type may be obtained by sub-classing GenericType. Alternatively, an object representing a concrete parameterized type can be created using a GenericType(java.lang.reflect.Type) and manually specifying the actual (parameterized) type.

    For example:

      GenericType<List<String>> stringListType = new GenericType<List<String>>() {};

    Or:

      public class MyGenericType extends GenericType<List<String>> { ... }

  ...

  MyGenericType stringListType = new MyGenericType();

    Note that due to the Java type erasure limitations the parameterized type information must be specified on a subclass, not just during the instance creation. For example, the following case would throw an IllegalArgumentException:

      public class MyGenericType<T> extends GenericType<T> { ... }

  ...

  // The type is only specified on instance, not in a sub-class
  MyGenericType<List<String>> stringListType =
          new MyGenericType<List<String>>();
    Since:
    2.0
    Author:
    Marek Potociar, Paul Sandoz, Martin Matula

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected GenericType()
      Constructs a new generic type, deriving the generic type and class from type parameter.
        GenericType(Type genericType)
      Constructs a new generic type, supplying the generic type information and deriving the class.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      boolean | equals(Object obj)
      Class<?> getRawType()
      Returns the object representing the class or interface that declared the type represented by this generic type instance.
      Type getType()
      Retrieve the type represented by the generic type instance.
      int | hashCode()
      String toString()

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • GenericType

        protected GenericType()
        Constructs a new generic type, deriving the generic type and class from type parameter. Note that this constructor is protected, users should create a (usually anonymous) subclass as shown above.
        Throws:
        IllegalArgumentException - in case the generic type parameter value is not provided by any of the subclasses.

      • GenericType

        public GenericType(Type genericType)
        Constructs a new generic type, supplying the generic type information and deriving the class.
        Parameters:
        genericType - the generic type.
        Throws:
        IllegalArgumentException - if genericType is null or not an instance of Class or ParameterizedType whose raw type is an instance of Class.

    • Method Detail

      • getType

        public final Type getType()
        Retrieve the type represented by the generic type instance.
        Returns:
        the actual type represented by this generic type instance.

      • getRawType

        public final Class<?> getRawType()
        Returns the object representing the class or interface that declared the type represented by this generic type instance.
        Returns:
        the class or interface that declared the type represented by this generic type instance.

      • equals

        public boolean equals(Object obj)
        Overrides:
        equals in class Object

      • hashCode

        public int hashCode()
        Overrides:
        hashCode in class Object

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpHeaders (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface HttpHeaders

  • public interface HttpHeaders
    An injectable interface that provides access to HTTP header information. All methods throw IllegalStateException if called outside the scope of a request (e.g. from a provider constructor).
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Context

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ACCEPT
      See HTTP/1.1 documentation.
      static String ACCEPT_CHARSET
      See HTTP/1.1 documentation.
      static String ACCEPT_ENCODING
      See HTTP/1.1 documentation.
      static String ACCEPT_LANGUAGE
      See HTTP/1.1 documentation.
      static String ALLOW
      See HTTP/1.1 documentation.
      static String AUTHORIZATION
      See HTTP/1.1 documentation.
      static String CACHE_CONTROL
      See HTTP/1.1 documentation.
      static String CONTENT_DISPOSITION
      See IETF RFC-2183.
      static String CONTENT_ENCODING
      See HTTP/1.1 documentation.
      static String CONTENT_ID
      See IETF RFC-2392.
      static String CONTENT_LANGUAGE
      See HTTP/1.1 documentation.
      static String CONTENT_LENGTH
      See HTTP/1.1 documentation.
      static String CONTENT_LOCATION
      See HTTP/1.1 documentation.
      static String CONTENT_TYPE
      See HTTP/1.1 documentation.
      static String COOKIE
      See IETF RFC 2109.
      static String DATE
      See HTTP/1.1 documentation.
      static String ETAG
      See HTTP/1.1 documentation.
      static String EXPIRES
      See HTTP/1.1 documentation.
      static String HOST
      See HTTP/1.1 documentation.
      static String IF_MATCH
      See HTTP/1.1 documentation.
      static String IF_MODIFIED_SINCE
      See HTTP/1.1 documentation.
      static String IF_NONE_MATCH
      See HTTP/1.1 documentation.
      static String IF_UNMODIFIED_SINCE
      See HTTP/1.1 documentation.
      static String LAST_MODIFIED
      See HTTP/1.1 documentation.
      static String LINK
      See Web Linking (IETF RFC-5988) documentation.
      static String LOCATION
      See HTTP/1.1 documentation.
      static String RETRY_AFTER
      See HTTP/1.1 documentation.
      static String SET_COOKIE
      See IETF RFC 2109.
      static String USER_AGENT
      See HTTP/1.1 documentation.
      static String VARY
      See HTTP/1.1 documentation.
      static String WWW_AUTHENTICATE
      See HTTP/1.1 documentation.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<Locale> getAcceptableLanguages()
      Get a list of languages that are acceptable for the response.
      List<MediaType> getAcceptableMediaTypes()
      Get a list of media types that are acceptable for the response.
      Map<String,Cookie> getCookies()
      Get any cookies that accompanied the request.
      Date getDate()
      Get message date.
      String getHeaderString(String name)
      Get a HTTP header as a single string value.
      Locale getLanguage()
      Get the language of the request entity.
      int getLength()
      Get Content-Length value.
      MediaType getMediaType()
      Get the media type of the request entity.
      List<String> getRequestHeader(String name)
      Get the values of a HTTP request header.
      MultivaluedMap<String,String> getRequestHeaders()
      Get the values of HTTP request headers.

    • Field Detail

      • ACCEPT

        static final String ACCEPT
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • ACCEPT_CHARSET

        static final String ACCEPT_CHARSET
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • ACCEPT_ENCODING

        static final String ACCEPT_ENCODING
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • ACCEPT_LANGUAGE

        static final String ACCEPT_LANGUAGE
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • ALLOW

        static final String ALLOW
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • AUTHORIZATION

        static final String AUTHORIZATION
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • CACHE_CONTROL

        static final String CACHE_CONTROL
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • CONTENT_DISPOSITION

        static final String CONTENT_DISPOSITION
        See IETF RFC-2183.
        See Also:
        Constant Field Values

      • CONTENT_ENCODING

        static final String CONTENT_ENCODING
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • CONTENT_ID

        static final String CONTENT_ID
        See IETF RFC-2392.
        See Also:
        Constant Field Values

      • CONTENT_LANGUAGE

        static final String CONTENT_LANGUAGE
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • CONTENT_LENGTH

        static final String CONTENT_LENGTH
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • CONTENT_LOCATION

        static final String CONTENT_LOCATION
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • CONTENT_TYPE

        static final String CONTENT_TYPE
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • DATE

        static final String DATE
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • ETAG

        static final String ETAG
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • EXPIRES

        static final String EXPIRES
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • HOST

        static final String HOST
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • IF_MATCH

        static final String IF_MATCH
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • IF_MODIFIED_SINCE

        static final String IF_MODIFIED_SINCE
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • IF_NONE_MATCH

        static final String IF_NONE_MATCH
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • IF_UNMODIFIED_SINCE

        static final String IF_UNMODIFIED_SINCE
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • LAST_MODIFIED

        static final String LAST_MODIFIED
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • LOCATION

        static final String LOCATION
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • LINK

        static final String LINK
        See Web Linking (IETF RFC-5988) documentation.
        See Also:
        Constant Field Values

      • RETRY_AFTER

        static final String RETRY_AFTER
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • USER_AGENT

        static final String USER_AGENT
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • VARY

        static final String VARY
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • WWW_AUTHENTICATE

        static final String WWW_AUTHENTICATE
        See HTTP/1.1 documentation.
        See Also:
        Constant Field Values

      • COOKIE

        static final String COOKIE
        See IETF RFC 2109.
        See Also:
        Constant Field Values

      • SET_COOKIE

        static final String SET_COOKIE
        See IETF RFC 2109.
        See Also:
        Constant Field Values

    • Method Detail

      • getRequestHeader

        List<String> getRequestHeader(String name)
        Get the values of a HTTP request header. The returned List is read-only. This is a shortcut for getRequestHeaders().get(name).
        Parameters:
        name - the header name, case insensitive.
        Returns:
        a read-only list of header values.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getHeaderString

        String getHeaderString(String name)
        Get a HTTP header as a single string value.

        Each single header value is converted to String using a RuntimeDelegate.HeaderDelegate if one is available via RuntimeDelegate.createHeaderDelegate(java.lang.Class) for the header value class or using its toString method if a header delegate is not available.

        Parameters:
        name - the HTTP header.
        Returns:
        the HTTP header value. If the HTTP header is not present then null is returned. If the HTTP header is present but has no value then the empty string is returned. If the HTTP header is present more than once then the values of joined together and separated by a ',' character.
        Since:
        2.0
        See Also:
        getRequestHeader(java.lang.String)

      • getRequestHeaders

        MultivaluedMap<String,String> getRequestHeaders()
        Get the values of HTTP request headers. The returned Map is case-insensitive wrt. keys and is read-only. The method never returns null.
        Returns:
        a read-only map of header names and values.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getAcceptableMediaTypes

        List<MediaType> getAcceptableMediaTypes()
        Get a list of media types that are acceptable for the response.

        If no acceptable media types are specified, a read-only list containing a single wildcard media type instance is returned.

        Returns:
        a read-only list of requested response media types sorted according to their q-value, with highest preference first.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getAcceptableLanguages

        List<Locale> getAcceptableLanguages()
        Get a list of languages that are acceptable for the response.

        If no acceptable languages are specified, a read-only list containing a single wildcard Locale instance (with language field set to "*") is returned.

        Returns:
        a read-only list of acceptable languages sorted according to their q-value, with highest preference first.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getMediaType

        MediaType getMediaType()
        Get the media type of the request entity.
        Returns:
        the media type or null if there is no request entity.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getLanguage

        Locale getLanguage()
        Get the language of the request entity.
        Returns:
        the language of the entity or null if not specified.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getCookies

        Map<String,Cookie> getCookies()
        Get any cookies that accompanied the request.
        Returns:
        a read-only map of cookie name (String) to Cookie.
        Throws:
        IllegalStateException - if called outside the scope of a request

      • getDate

        Date getDate()
        Get message date.
        Returns:
        the message date, otherwise null if not present.
        Since:
        2.0

      • getLength

        int getLength()
        Get Content-Length value.
        Returns:
        Content-Length as integer if present and valid number. In other cases returns -1.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.ws.rs.core (Java(TM) EE 7 Specification APIs)

javax.ws.rs.core

Interfaces

  • Configurable
  • Configuration
  • Feature
  • FeatureContext
  • HttpHeaders
  • Link.Builder
  • MultivaluedMap
  • PathSegment
  • Request
  • Response.StatusType
  • SecurityContext
  • StreamingOutput
  • UriInfo

Classes

  • AbstractMultivaluedMap
  • Application
  • CacheControl
  • Cookie
  • EntityTag
  • Form
  • GenericEntity
  • GenericType
  • Link
  • Link.JaxbAdapter
  • Link.JaxbLink
  • MediaType
  • MultivaluedHashMap
  • NewCookie
  • Response
  • Response.ResponseBuilder
  • UriBuilder
  • Variant
  • Variant.VariantListBuilder

Enums

  • Response.Status
  • Response.Status.Family

Exceptions

  • NoContentException
  • UriBuilderException

Annotation Types

  • Context


javax.ws.rs.core (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.ws.rs.core

Low-level interfaces and annotations used to create RESTful service resources.

See: Description

  • Interface Summary
    Interface Description
    Configurable<C extends Configurable>
    Represents a client or server-side configurable context in JAX-RS.
    Configuration
    A configuration state associated with a configurable JAX-RS context.
    Feature
    A feature extension contract.
    FeatureContext
    A configurable context passed to Feature and DynamicFeature instances by JAX-RS runtime during the phase of their configuration.
    HttpHeaders
    An injectable interface that provides access to HTTP header information.
    Link.Builder
    Builder class for hypermedia links.
    MultivaluedMap<K,V>
    A map of key-values pairs.
    PathSegment
    Represents a URI path segment and any associated matrix parameters.
    Request
    An injectable helper for request processing, all methods throw an IllegalStateException if called outside the scope of a request (e.g.
    Response.StatusType
    Base interface for statuses used in responses.
    SecurityContext
    An injectable interface that provides access to security related information.
    StreamingOutput
    A type that may be used as a resource method return value or as the entity in a Response when the application wishes to stream the output.
    UriInfo
    An injectable interface that provides access to application and request URI information.
  • Class Summary
    Class Description
    AbstractMultivaluedMap<K,V>
    Abstract skeleton implementation of a MultivaluedMap that is backed by a [key, multi-value] store represented as a Map<K, List<V>>.
    Application
    Defines the components of a JAX-RS application and supplies additional meta-data.
    CacheControl
    An abstraction for the value of a HTTP Cache-Control response header.
    Cookie
    Represents the value of a HTTP cookie, transferred in a request.
    EntityTag
    An abstraction for the value of a HTTP Entity Tag, used as the value of an ETag response header.
    Form
    Represents the the HTML form data request entity encoded using the "application/x-www-form-urlencoded" content type.
    GenericEntity<T>
    Represents a message entity of a generic type T.
    GenericType<T>
    Represents a generic message entity type T.
    Link
    Class representing hypermedia links.
    Link.JaxbAdapter
    An implementation of JAXB XmlAdapter that maps the JAX-RS Link type to a value that can be marshalled and unmarshalled by JAXB.
    Link.JaxbLink
    Value type for Link that can be marshalled and unmarshalled by JAXB.
    MediaType
    An abstraction for a media type.
    MultivaluedHashMap<K,V>
    A hash table based implementation of MultivaluedMap interface.
    NewCookie
    Used to create a new HTTP cookie, transferred in a response.
    Response
    Defines the contract between a returned instance and the runtime when an application needs to provide meta-data to the runtime.
    Response.ResponseBuilder
    A class used to build Response instances that contain metadata instead of or in addition to an entity.
    UriBuilder
    URI template-aware utility class for building URIs from their components.
    Variant
    Abstraction for a resource representation variant.
    Variant.VariantListBuilder
    A builder for a list of representation variants.
  • Enum Summary
    Enum Description
    Response.Status
    Commonly used status codes defined by HTTP, see HTTP/1.1 documentation for the complete list.
    Response.Status.Family
    An enumeration representing the class of status code.
  • Exception Summary
    Exception Description
    NoContentException
    An I/O exception thrown by MessageBodyReader implementations when reading a zero-length message content to indicate that the message body reader is not able to produce an instance representing an zero-length message content.
    UriBuilderException
    A runtime exception thrown by UriBuilder.build(Object...) methods when a URI cannot be constructed based on the current state of the builder.
  • Annotation Types Summary
    Annotation Type Description
    Context
    This annotation is used to inject information into a class field, bean property or method parameter.

Package javax.ws.rs.core Description

Low-level interfaces and annotations used to create RESTful service resources.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.ws.rs.core Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.ws.rs.core

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.ws.rs.core.AbstractMultivaluedMap<K,V> (implements javax.ws.rs.core.MultivaluedMap<K,V>)
      • javax.ws.rs.core.MultivaluedHashMap<K,V> (implements java.io.Serializable)
    • javax.ws.rs.core.Application
    • javax.ws.rs.core.CacheControl
    • javax.ws.rs.core.Cookie
      • javax.ws.rs.core.NewCookie
    • javax.ws.rs.core.EntityTag
    • javax.ws.rs.core.Form
    • javax.ws.rs.core.GenericEntity<T>
    • javax.ws.rs.core.GenericType<T>
    • javax.ws.rs.core.Link
    • javax.ws.rs.core.Link.JaxbLink
    • javax.ws.rs.core.MediaType
    • javax.ws.rs.core.Response
    • javax.ws.rs.core.Response.ResponseBuilder
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.ws.rs.core.NoContentException
        • java.lang.RuntimeException
          • javax.ws.rs.core.UriBuilderException
    • javax.ws.rs.core.UriBuilder
    • javax.ws.rs.core.Variant
    • javax.ws.rs.core.Variant.VariantListBuilder
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.ws.rs.core.Link.JaxbAdapter

Interface Hierarchy

  • javax.ws.rs.core.Configurable<C>
    • javax.ws.rs.core.FeatureContext
  • javax.ws.rs.core.Configuration
  • javax.ws.rs.core.Feature
  • javax.ws.rs.core.HttpHeaders
  • javax.ws.rs.core.Link.Builder
  • java.util.Map<K,V>
    • javax.ws.rs.core.MultivaluedMap<K,V>
  • javax.ws.rs.core.PathSegment
  • javax.ws.rs.core.Request
  • javax.ws.rs.core.Response.StatusType
  • javax.ws.rs.core.SecurityContext
  • javax.ws.rs.core.StreamingOutput
  • javax.ws.rs.core.UriInfo

Annotation Type Hierarchy

  • javax.ws.rs.core.Context (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.ws.rs.core.Response.Status (implements javax.ws.rs.core.Response.StatusType)
      • javax.ws.rs.core.Response.Status.Family
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Link (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class Link

  • java.lang.Object
    • javax.ws.rs.core.Link

  • public abstract class Link
extends Object

    Class representing hypermedia links. A hypermedia link may include additional parameters beyond its underlying URI. Parameters such as rel or type provide additional meta-data. Links in responses can be followed by creating an Invocation.Builder or a WebTarget.

    The methods toString() and valueOf(java.lang.String) can be used to serialize and de-serialize a link into a link header (RFC 5988).

    Since:
    2.0
    Author:
    Marek Potociar, Santiago Pericas-Geertsen
    See Also:
    Client.invocation(javax.ws.rs.core.Link),
Client.target(javax.ws.rs.core.Link),
Response.getLink(java.lang.String)

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static interface  Link.Builder
      Builder class for hypermedia links.
      static class  Link.JaxbAdapter
      An implementation of JAXB XmlAdapter that maps the JAX-RS Link type to a value that can be marshalled and unmarshalled by JAXB.
      static class  Link.JaxbLink
      Value type for Link that can be marshalled and unmarshalled by JAXB.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String REL
      Rel link param from RFC 5988.
      static String TITLE
      Title link param from RFC 5988.
      static String TYPE
      Type link param from RFC 5988.

    • Constructor Summary

      Constructors
      Constructor and Description
      Link()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Link.Builder fromLink(Link link)
      Create a new builder instance initialized from another link.
      static Link.Builder fromMethod(Class<?> resource, String method)
      Convenience method to build a link from a resource.
      static Link.Builder fromPath(String path)
      Convenience method to build a link from a path.
      static Link.Builder fromResource(Class<?> resource)
      Convenience method to build a link from a resource.
      static Link.Builder fromUri(String uri)
      Create a new builder instance initialized from an existing URI represented as a string.
      static Link.Builder fromUri(URI uri)
      Create a new builder instance initialized from an existing URI.
      static Link.Builder fromUriBuilder(UriBuilder uriBuilder)
      Create a new builder instance initialized from a URI builder.
      abstract Map<String,String> getParams()
      Returns an immutable map that includes all the link parameters defined on this link.
      abstract String getRel()
      Returns the value associated with the link rel param, or null if this param is not specified.
      abstract List<String> getRels()
      Returns the value associated with the link rel param as a list of strings or the empty list if rel is not defined.
      abstract String getTitle()
      Returns the value associated with the link title param, or null if this param is not specified.
      abstract String getType()
      Returns the value associated with the link type param, or null if this param is not specified.
      abstract URI getUri()
      Returns the underlying URI associated with this link.
      abstract UriBuilder getUriBuilder()
      Convenience method that returns a UriBuilder initialized with this link's underlying URI.
      abstract String toString()
      Returns a string representation as a link header (RFC 5988).
      static Link valueOf(String value)
      Simple parser to convert link header string representations into a link.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • TITLE

        public static final String TITLE
        Title link param from RFC 5988.
        See Also:
        Constant Field Values

      • REL

        public static final String REL
        Rel link param from RFC 5988.
        See Also:
        Constant Field Values

      • TYPE

        public static final String TYPE
        Type link param from RFC 5988.
        See Also:
        Constant Field Values

    • Constructor Detail

      • Link

        public Link()

    • Method Detail

      • getUri

        public abstract URI getUri()
        Returns the underlying URI associated with this link.
        Returns:
        underlying URI.

      • getUriBuilder

        public abstract UriBuilder getUriBuilder()
        Convenience method that returns a UriBuilder initialized with this link's underlying URI.
        Returns:
        UriBuilder initialized using underlying URI.

      • getRel

        public abstract String getRel()
        Returns the value associated with the link rel param, or null if this param is not specified.
        Returns:
        relation types as string or null.

      • getRels

        public abstract List<String> getRels()
        Returns the value associated with the link rel param as a list of strings or the empty list if rel is not defined.
        Returns:
        relation types as list of strings or empty list.

      • getTitle

        public abstract String getTitle()
        Returns the value associated with the link title param, or null if this param is not specified.
        Returns:
        value of title parameter or null.

      • getType

        public abstract String getType()
        Returns the value associated with the link type param, or null if this param is not specified.
        Returns:
        value of type parameter or null.

      • getParams

        public abstract Map<String,String> getParams()
        Returns an immutable map that includes all the link parameters defined on this link. If defined, this map will include entries for rel, title and type.
        Returns:
        immutable map of link parameters.

      • toString

        public abstract String toString()
        Returns a string representation as a link header (RFC 5988). All link params are serialized as link-param="value" where value is a quoted-string. For example, ; title="employee"; rel="manager friend"
        Overrides:
        toString in class Object
        Returns:
        string link header representation for this link.

      • valueOf

        public static Link valueOf(String value)
        Simple parser to convert link header string representations into a link.
         link ::= '<' uri '>' (';' link-param)*
 link-param ::= name '=' quoted-string
        See RFC 5988 for more information.
        Parameters:
        value - String representation.
        Returns:
        newly parsed link.
        Throws:
        IllegalArgumentException - if a syntax error is found.
        See Also:
        Link.Builder.link(java.lang.String)

      • fromUri

        public static Link.Builder fromUri(URI uri)
        Create a new builder instance initialized from an existing URI.
        Parameters:
        uri - a URI that will be used to initialize the builder.
        Returns:
        a new builder.
        Throws:
        IllegalArgumentException - if uri is null.

      • fromUri

        public static Link.Builder fromUri(String uri)
        Create a new builder instance initialized from an existing URI represented as a string.
        Parameters:
        uri - a URI that will be used to initialize the builder.
        Returns:
        a new builder.
        Throws:
        IllegalArgumentException - if uri is null.

      • fromUriBuilder

        public static Link.Builder fromUriBuilder(UriBuilder uriBuilder)
        Create a new builder instance initialized from a URI builder.
        Parameters:
        uriBuilder - instance of URI builder.
        Returns:
        a new builder.

      • fromLink

        public static Link.Builder fromLink(Link link)
        Create a new builder instance initialized from another link.
        Parameters:
        link - other link used for initialization.
        Returns:
        a new builder.

      • fromPath

        public static Link.Builder fromPath(String path)
        Convenience method to build a link from a path. Equivalent to fromUriBuilder(UriBuilder.fromPath(path)).
        Parameters:
        path - a URI path that will be used to initialize the Link, may contain URI template parameters.
        Returns:
        a new Link.Builder.
        Throws:
        IllegalArgumentException - if path is null.

      • fromResource

        public static Link.Builder fromResource(Class<?> resource)
        Convenience method to build a link from a resource. Equivalent to Link.fromUriBuilder(UriBuilder.fromResource(resource)). Note that the link URI passed to the Link.Builder instance returned by this method is relative. Should the link be built as absolute, a base URI has to be specified in the builder prior to building the new link instance. For example, on a server side a UriInfo.getBaseUri() may be typically used to define the base URI of a link created using this method.
        Parameters:
        resource - a root resource whose Path value will be used to initialize the builder.
        Returns:
        a new link builder instance.
        Throws:
        IllegalArgumentException - if resource is not annotated with Path or resource is null.
        See Also:
        UriInfo.getBaseUri()

      • fromMethod

        public static Link.Builder fromMethod(Class<?> resource,
                      String method)
        Convenience method to build a link from a resource. Equivalent to Link.fromUriBuilder(UriBuilder.fromMethod(resource, method)). Note that the link URI passed to the Link.Builder instance returned by this method is relative. Should the link be built as absolute, a base URI has to be specified in the builder prior to building the new link instance. For example, on a server side a UriInfo.getBaseUri() may be typically used to define the base URI of a link created using this method.
        Parameters:
        resource - the resource containing the method.
        method - the name of the method whose Path value will be used to obtain the path to append.
        Returns:
        the updated Link.Builder.
        Throws:
        IllegalArgumentException - if resource or method is null, or there is more than or less than one variant of the method annotated with Path.
        See Also:
        UriInfo.getBaseUri()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Link.Builder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface Link.Builder

  • Enclosing class:
    Link

    public static interface Link.Builder
    Builder class for hypermedia links.
    Since:
    2.0
    See Also:
    Link

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Link.Builder baseUri(String uri)
      Set the base URI as a string for resolution of relative URIs.
      Link.Builder baseUri(URI uri)
      Set the base URI for resolution of relative URIs.
      Link build(Object... values)
      Finish building this link using the supplied values as URI parameters.
      Link buildRelativized(URI uri, Object... values)
      Finish building this link using the supplied values as URI parameters and relativize the result with respect to the supplied URI.
      Link.Builder link(Link link)
      Initialize builder using another link.
      Link.Builder link(String link)
      Initialize builder using another link represented as a string.
      Link.Builder param(String name, String value)
      Set an arbitrary parameter on this link.
      Link.Builder rel(String rel)
      Convenience method to set a link relation.
      Link.Builder title(String title)
      Convenience method to set a title on this link.
      Link.Builder type(String type)
      Convenience method to set a type on this link.
      Link.Builder uri(String uri)
      Set underlying string representing URI template for the link being constructed.
      Link.Builder uri(URI uri)
      Set underlying URI template for the link being constructed.
      Link.Builder uriBuilder(UriBuilder uriBuilder)
      Set underlying URI builder representing the URI template for the link being constructed.

    • Method Detail

      • link

        Link.Builder link(Link link)
        Initialize builder using another link. Sets underlying URI and copies all parameters.
        Parameters:
        link - other link from which to initialize.
        Returns:
        the updated builder.

      • link

        Link.Builder link(String link)
        Initialize builder using another link represented as a string. Uses simple parser to convert string representation into a link.
         link ::= '<' uri '>' (';' link-param)*
 link-param ::= name '=' quoted-string
        See RFC 5988 for more information.
        Parameters:
        link - other link in string representation.
        Returns:
        the updated builder.
        Throws:
        IllegalArgumentException - if string representation of URI is invalid.

      • uri

        Link.Builder uri(URI uri)
        Set underlying URI template for the link being constructed.
        Parameters:
        uri - underlying URI for link
        Returns:
        the updated builder.

      • uri

        Link.Builder uri(String uri)
        Set underlying string representing URI template for the link being constructed.
        Parameters:
        uri - underlying URI for link.
        Returns:
        the updated builder.
        Throws:
        IllegalArgumentException - if string representation of URI is invalid.

      • baseUri

        Link.Builder baseUri(URI uri)
        Set the base URI for resolution of relative URIs. If the underlying URI is already absolute, the base URI is ignored.
        Parameters:
        uri - base URI for relative links.
        Returns:
        the updated builder.
        See Also:
        Link.fromPath(java.lang.String),
Link.fromResource(java.lang.Class),
Link.fromMethod(java.lang.Class, java.lang.String)

      • baseUri

        Link.Builder baseUri(String uri)
        Set the base URI as a string for resolution of relative URIs. If the underlying URI is already absolute, the base URI is ignored.
        Parameters:
        uri - base URI for relative links.
        Returns:
        the updated builder.
        Throws:
        IllegalArgumentException - if string representation of URI is invalid.
        See Also:
        Link.fromPath(java.lang.String),
Link.fromResource(java.lang.Class),
Link.fromMethod(java.lang.Class, java.lang.String)

      • uriBuilder

        Link.Builder uriBuilder(UriBuilder uriBuilder)
        Set underlying URI builder representing the URI template for the link being constructed.
        Parameters:
        uriBuilder - underlying URI builder.
        Returns:
        the updated builder.

      • rel

        Link.Builder rel(String rel)
        Convenience method to set a link relation. More than one rel value can be specified by using one or more whitespace characters as delimiters according to RFC 5988. The effect of calling this method is cumulative; relations are appended using a single space character as separator.
        Parameters:
        rel - relation name.
        Returns:
        the updated builder.
        Throws:
        IllegalArgumentException - if the name is null.

      • title

        Link.Builder title(String title)
        Convenience method to set a title on this link.
        Parameters:
        title - title parameter of this link.
        Returns:
        the updated builder.
        Throws:
        IllegalArgumentException - if the title is null.

      • type

        Link.Builder type(String type)
        Convenience method to set a type on this link.
        Parameters:
        type - type parameter of this link.
        Returns:
        the updated builder.
        Throws:
        IllegalArgumentException - if the type is null.

      • param

        Link.Builder param(String name,
                 String value)
        Set an arbitrary parameter on this link. Note that link parameters are those defined in RFC 5988 and should not be confused with URI parameters which can be specified when calling build(Object...).
        Parameters:
        name - the name of the parameter.
        value - the value set for the parameter.
        Returns:
        the updated builder.
        Throws:
        IllegalArgumentException - if either the name or value are null.

      • build

        Link build(Object... values)
        Finish building this link using the supplied values as URI parameters. The state of the builder is unaffected; this method may be called multiple times on the same builder instance.
        Parameters:
        values - parameters used to build underlying URI.
        Returns:
        newly built link.
        Throws:
        IllegalArgumentException - if there are any URI template parameters without a supplied value, or if a value is null.
        UriBuilderException - if a URI cannot be constructed based on the current state of the underlying URI builder.

      • buildRelativized

        Link buildRelativized(URI uri,
                    Object... values)
        Finish building this link using the supplied values as URI parameters and relativize the result with respect to the supplied URI. If the underlying link is already relative or if it is absolute but does not share a prefix with the supplied URI, this method is equivalent to calling build(java.lang.Object[]). Note that a base URI can be set on a relative link using baseUri(java.net.URI). The state of the builder is unaffected; this method may be called multiple times on the same builder instance.
        Parameters:
        uri - URI used for relativization.
        values - parameters used to build underlying URI.
        Returns:
        newly built link.
        Throws:
        IllegalArgumentException - if there are any URI template parameters without a supplied value, or if a value is null.
        UriBuilderException - if a URI cannot be constructed based on the current state of the underlying URI builder.
        See Also:
        baseUri(java.lang.String), baseUri(java.net.URI)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Link.JaxbAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class Link.JaxbAdapter

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<Link.JaxbLink,Link>
      • javax.ws.rs.core.Link.JaxbAdapter
  • Enclosing class:
    Link

    public static class Link.JaxbAdapter
extends XmlAdapter<Link.JaxbLink,Link>

    An implementation of JAXB XmlAdapter that maps the JAX-RS Link type to a value that can be marshalled and unmarshalled by JAXB. The following example shows how to use this adapter on a JAXB bean class:

     @XmlRootElement
 public class MyModel {

   private Link link;

   @XmlElement(name="link")
   @XmlJavaTypeAdapter(JaxbAdapter.class)
   public Link getLink() {
     return link;
   }
   ...
 }
    Since:
    2.0
    See Also:
    Link.JaxbLink

    • Constructor Summary

      Constructors
      Constructor and Description
      Link.JaxbAdapter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Link.JaxbLink marshal(Link v)
      Convert a Link into a Link.JaxbLink.
      Link unmarshal(Link.JaxbLink v)
      Convert a Link.JaxbLink into a Link.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Link.JaxbAdapter

        public Link.JaxbAdapter()

    • Method Detail

      • unmarshal

        public Link unmarshal(Link.JaxbLink v)
        Convert a Link.JaxbLink into a Link.
        Specified by:
        unmarshal in class XmlAdapter<Link.JaxbLink,Link>
        Parameters:
        v - instance of type Link.JaxbLink.
        Returns:
        mapped instance of type Link.JaxbLink

      • marshal

        public Link.JaxbLink marshal(Link v)
        Convert a Link into a Link.JaxbLink.
        Specified by:
        marshal in class XmlAdapter<Link.JaxbLink,Link>
        Parameters:
        v - instance of type Link.
        Returns:
        mapped instance of type Link.JaxbLink.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Link.JaxbLink (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class Link.JaxbLink

  • java.lang.Object
    • javax.ws.rs.core.Link.JaxbLink
  • Enclosing class:
    Link

    public static class Link.JaxbLink
extends Object
    Value type for Link that can be marshalled and unmarshalled by JAXB.
    Since:
    2.0
    See Also:
    Link.JaxbAdapter

    • Constructor Summary

      Constructors
      Constructor and Description
      Link.JaxbLink()
      Default constructor needed during unmarshalling.
      Link.JaxbLink(URI uri)
      Construct an instance from a URI and no parameters.
      Link.JaxbLink(URI uri, Map<QName,Object> params)
      Construct an instance from a URI and some parameters.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Map<QName,Object> getParams()
      Get the parameter map for this link.
      URI getUri()
      Get the underlying URI for this link.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Link.JaxbLink

        public Link.JaxbLink()
        Default constructor needed during unmarshalling.

      • Link.JaxbLink

        public Link.JaxbLink(URI uri)
        Construct an instance from a URI and no parameters.
        Parameters:
        uri - underlying URI.

      • Link.JaxbLink

        public Link.JaxbLink(URI uri,
             Map<QName,Object> params)
        Construct an instance from a URI and some parameters.
        Parameters:
        uri - underlying URI.
        params - parameters of this link.

    • Method Detail

      • getUri

        public URI getUri()
        Get the underlying URI for this link.
        Returns:
        underlying URI.

      • getParams

        public Map<QName,Object> getParams()
        Get the parameter map for this link.
        Returns:
        parameter map.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MediaType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class MediaType

  • java.lang.Object
    • javax.ws.rs.core.MediaType

  • public class MediaType
extends Object
    An abstraction for a media type. Instances are immutable.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    HTTP/1.1 section 3.7

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String APPLICATION_ATOM_XML
      A String constant representing ""application/atom+xml"" media type.
      static MediaType APPLICATION_ATOM_XML_TYPE
      A MediaType constant representing ""application/atom+xml"" media type.
      static String APPLICATION_FORM_URLENCODED
      A String constant representing ""application/x-www-form-urlencoded"" media type.
      static MediaType APPLICATION_FORM_URLENCODED_TYPE
      A MediaType constant representing ""application/x-www-form-urlencoded"" media type.
      static String APPLICATION_JSON
      A String constant representing ""application/json"" media type.
      static MediaType APPLICATION_JSON_TYPE
      A MediaType constant representing ""application/json"" media type.
      static String APPLICATION_OCTET_STREAM
      A String constant representing ""application/octet-stream"" media type.
      static MediaType APPLICATION_OCTET_STREAM_TYPE
      A MediaType constant representing ""application/octet-stream"" media type.
      static String APPLICATION_SVG_XML
      A String constant representing ""application/svg+xml"" media type.
      static MediaType APPLICATION_SVG_XML_TYPE
      A MediaType constant representing ""application/svg+xml"" media type.
      static String APPLICATION_XHTML_XML
      A String constant representing ""application/xhtml+xml"" media type.
      static MediaType APPLICATION_XHTML_XML_TYPE
      A MediaType constant representing ""application/xhtml+xml"" media type.
      static String APPLICATION_XML
      A String constant representing ""application/xml"" media type.
      static MediaType APPLICATION_XML_TYPE
      A MediaType constant representing ""application/xml"" media type.
      static String CHARSET_PARAMETER
      The media type charset parameter name.
      static String MEDIA_TYPE_WILDCARD
      The value of a type or subtype wildcard ""*"".
      static String MULTIPART_FORM_DATA
      A String constant representing ""multipart/form-data"" media type.
      static MediaType MULTIPART_FORM_DATA_TYPE
      A MediaType constant representing ""multipart/form-data"" media type.
      static String TEXT_HTML
      A String constant representing ""text/html"" media type.
      static MediaType TEXT_HTML_TYPE
      A MediaType constant representing ""text/html"" media type.
      static String TEXT_PLAIN
      A String constant representing ""text/plain"" media type.
      static MediaType TEXT_PLAIN_TYPE
      A MediaType constant representing ""text/plain"" media type.
      static String TEXT_XML
      A String constant representing ""text/xml"" media type.
      static MediaType TEXT_XML_TYPE
      A MediaType constant representing ""text/xml"" media type.
      static String WILDCARD
      A String constant representing wildcard ""*/*"" media type .
      static MediaType WILDCARD_TYPE
      A MediaType constant representing wildcard ""*/*"" media type.

    • Constructor Summary

      Constructors
      Constructor and Description
      MediaType()
      Creates a new instance of MediaType, both type and subtype are wildcards.
      MediaType(String type, String subtype)
      Creates a new instance of MediaType with the supplied type and subtype.
      MediaType(String type, String subtype, Map<String,String> parameters)
      Creates a new instance of MediaType with the supplied type, subtype and parameters.
      MediaType(String type, String subtype, String charset)
      Creates a new instance of MediaType with the supplied type, subtype and ""charset"" parameter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Compares obj to this media type to see if they are the same by comparing type, subtype and parameters.
      Map<String,String> getParameters()
      Getter for a read-only parameter map.
      String getSubtype()
      Getter for subtype.
      String getType()
      Getter for primary type.
      int hashCode()
      Generate a hash code from the type, subtype and parameters.
      boolean isCompatible(MediaType other)
      Check if this media type is compatible with another media type.
      boolean isWildcardSubtype()
      Checks if the subtype is a wildcard.
      boolean isWildcardType()
      Checks if the primary type is a wildcard.
      String toString()
      Convert the media type to a string suitable for use as the value of a corresponding HTTP header.
      static MediaType valueOf(String type)
      Creates a new instance of MediaType by parsing the supplied string.
      MediaType withCharset(String charset)
      Create a new MediaType instance with the same type, subtype and parameters copied from the original instance and the supplied ""charset"" parameter.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Field Detail

      • CHARSET_PARAMETER

        public static final String CHARSET_PARAMETER
        The media type charset parameter name.
        See Also:
        Constant Field Values

      • MEDIA_TYPE_WILDCARD

        public static final String MEDIA_TYPE_WILDCARD
        The value of a type or subtype wildcard ""*"".
        See Also:
        Constant Field Values

      • WILDCARD

        public static final String WILDCARD
        A String constant representing wildcard ""*/*"" media type .
        See Also:
        Constant Field Values

      • WILDCARD_TYPE

        public static final MediaType WILDCARD_TYPE
        A MediaType constant representing wildcard ""*/*"" media type.

      • APPLICATION_XML

        public static final String APPLICATION_XML
        A String constant representing ""application/xml"" media type.
        See Also:
        Constant Field Values

      • APPLICATION_XML_TYPE

        public static final MediaType APPLICATION_XML_TYPE
        A MediaType constant representing ""application/xml"" media type.

      • APPLICATION_ATOM_XML

        public static final String APPLICATION_ATOM_XML
        A String constant representing ""application/atom+xml"" media type.
        See Also:
        Constant Field Values

      • APPLICATION_ATOM_XML_TYPE

        public static final MediaType APPLICATION_ATOM_XML_TYPE
        A MediaType constant representing ""application/atom+xml"" media type.

      • APPLICATION_XHTML_XML

        public static final String APPLICATION_XHTML_XML
        A String constant representing ""application/xhtml+xml"" media type.
        See Also:
        Constant Field Values

      • APPLICATION_XHTML_XML_TYPE

        public static final MediaType APPLICATION_XHTML_XML_TYPE
        A MediaType constant representing ""application/xhtml+xml"" media type.

      • APPLICATION_SVG_XML

        public static final String APPLICATION_SVG_XML
        A String constant representing ""application/svg+xml"" media type.
        See Also:
        Constant Field Values

      • APPLICATION_SVG_XML_TYPE

        public static final MediaType APPLICATION_SVG_XML_TYPE
        A MediaType constant representing ""application/svg+xml"" media type.

      • APPLICATION_JSON

        public static final String APPLICATION_JSON
        A String constant representing ""application/json"" media type.
        See Also:
        Constant Field Values

      • APPLICATION_JSON_TYPE

        public static final MediaType APPLICATION_JSON_TYPE
        A MediaType constant representing ""application/json"" media type.

      • APPLICATION_FORM_URLENCODED

        public static final String APPLICATION_FORM_URLENCODED
        A String constant representing ""application/x-www-form-urlencoded"" media type.
        See Also:
        Constant Field Values

      • APPLICATION_FORM_URLENCODED_TYPE

        public static final MediaType APPLICATION_FORM_URLENCODED_TYPE
        A MediaType constant representing ""application/x-www-form-urlencoded"" media type.

      • MULTIPART_FORM_DATA

        public static final String MULTIPART_FORM_DATA
        A String constant representing ""multipart/form-data"" media type.
        See Also:
        Constant Field Values

      • MULTIPART_FORM_DATA_TYPE

        public static final MediaType MULTIPART_FORM_DATA_TYPE
        A MediaType constant representing ""multipart/form-data"" media type.

      • APPLICATION_OCTET_STREAM

        public static final String APPLICATION_OCTET_STREAM
        A String constant representing ""application/octet-stream"" media type.
        See Also:
        Constant Field Values

      • APPLICATION_OCTET_STREAM_TYPE

        public static final MediaType APPLICATION_OCTET_STREAM_TYPE
        A MediaType constant representing ""application/octet-stream"" media type.

      • TEXT_PLAIN

        public static final String TEXT_PLAIN
        A String constant representing ""text/plain"" media type.
        See Also:
        Constant Field Values

      • TEXT_PLAIN_TYPE

        public static final MediaType TEXT_PLAIN_TYPE
        A MediaType constant representing ""text/plain"" media type.

      • TEXT_XML

        public static final String TEXT_XML
        A String constant representing ""text/xml"" media type.
        See Also:
        Constant Field Values

      • TEXT_XML_TYPE

        public static final MediaType TEXT_XML_TYPE
        A MediaType constant representing ""text/xml"" media type.

      • TEXT_HTML

        public static final String TEXT_HTML
        A String constant representing ""text/html"" media type.
        See Also:
        Constant Field Values

      • TEXT_HTML_TYPE

        public static final MediaType TEXT_HTML_TYPE
        A MediaType constant representing ""text/html"" media type.

    • Constructor Detail

      • MediaType

        public MediaType(String type,
         String subtype,
         Map<String,String> parameters)
        Creates a new instance of MediaType with the supplied type, subtype and parameters.
        Parameters:
        type - the primary type, null is equivalent to MEDIA_TYPE_WILDCARD.
        subtype - the subtype, null is equivalent to MEDIA_TYPE_WILDCARD.
        parameters - a map of media type parameters, null is the same as an empty map.

      • MediaType

        public MediaType(String type,
         String subtype)
        Creates a new instance of MediaType with the supplied type and subtype.
        Parameters:
        type - the primary type, null is equivalent to MEDIA_TYPE_WILDCARD
        subtype - the subtype, null is equivalent to MEDIA_TYPE_WILDCARD

      • MediaType

        public MediaType(String type,
         String subtype,
         String charset)
        Creates a new instance of MediaType with the supplied type, subtype and ""charset"" parameter.
        Parameters:
        type - the primary type, null is equivalent to MEDIA_TYPE_WILDCARD
        subtype - the subtype, null is equivalent to MEDIA_TYPE_WILDCARD
        charset - the ""charset"" parameter value. If null or empty the ""charset"" parameter will not be set.

      • MediaType

        public MediaType()
        Creates a new instance of MediaType, both type and subtype are wildcards. Consider using the constant WILDCARD_TYPE instead.

    • Method Detail

      • valueOf

        public static MediaType valueOf(String type)
        Creates a new instance of MediaType by parsing the supplied string.
        Parameters:
        type - the media type string.
        Returns:
        the newly created MediaType.
        Throws:
        IllegalArgumentException - if the supplied string cannot be parsed or is null.

      • getType

        public String getType()
        Getter for primary type.
        Returns:
        value of primary type.

      • isWildcardType

        public boolean isWildcardType()
        Checks if the primary type is a wildcard.
        Returns:
        true if the primary type is a wildcard.

      • getSubtype

        public String getSubtype()
        Getter for subtype.
        Returns:
        value of subtype.

      • isWildcardSubtype

        public boolean isWildcardSubtype()
        Checks if the subtype is a wildcard.
        Returns:
        true if the subtype is a wildcard.

      • getParameters

        public Map<String,String> getParameters()
        Getter for a read-only parameter map. Keys are case-insensitive.
        Returns:
        an immutable map of parameters.

      • withCharset

        public MediaType withCharset(String charset)
        Create a new MediaType instance with the same type, subtype and parameters copied from the original instance and the supplied ""charset"" parameter.
        Parameters:
        charset - the ""charset"" parameter value. If null or empty the ""charset"" parameter will not be set or updated.
        Returns:
        copy of the current MediaType instance with the ""charset"" parameter set to the supplied value.
        Since:
        2.0

      • isCompatible

        public boolean isCompatible(MediaType other)
        Check if this media type is compatible with another media type. E.g. image/* is compatible with image/jpeg, image/png, etc. Media type parameters are ignored. The function is commutative.
        Parameters:
        other - the media type to compare with.
        Returns:
        true if the types are compatible, false otherwise.

      • equals

        public boolean equals(Object obj)
        Compares obj to this media type to see if they are the same by comparing type, subtype and parameters. Note that the case-sensitivity of parameter values is dependent on the semantics of the parameter name, see HTTP/1.1. This method assumes that values are case-sensitive.

        Note that the equals(...) implementation does not perform a class equality check (this.getClass() == obj.getClass()). Therefore any class that extends from MediaType class and needs to override one of the equals(...) and hashCode() methods must always override both methods to ensure the contract between Object.equals(java.lang.Object) and Object.hashCode() does not break.

        Overrides:
        equals in class Object
        Parameters:
        obj - the object to compare to.
        Returns:
        true if the two media types are the same, false otherwise.

      • hashCode

        public int hashCode()
        Generate a hash code from the type, subtype and parameters.

        Note that the equals(java.lang.Object) implementation does not perform a class equality check (this.getClass() == obj.getClass()). Therefore any class that extends from MediaType class and needs to override one of the equals(Object) and hashCode() methods must always override both methods to ensure the contract between Object.equals(java.lang.Object) and Object.hashCode() does not break.

        Overrides:
        hashCode in class Object
        Returns:
        a generated hash code.

      • toString

        public String toString()
        Convert the media type to a string suitable for use as the value of a corresponding HTTP header.
        Overrides:
        toString in class Object
        Returns:
        a string version of the media type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MultivaluedHashMap (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class MultivaluedHashMap<K,V>

  • java.lang.Object
    • javax.ws.rs.core.AbstractMultivaluedMap<K,V>
      • javax.ws.rs.core.MultivaluedHashMap<K,V>
  • Type Parameters:
    K - the type of keys maintained by this map.
    V - the type of mapped values.
    All Implemented Interfaces:
    Serializable, Map<K,List<V>>, MultivaluedMap<K,V>

    public class MultivaluedHashMap<K,V>
extends AbstractMultivaluedMap<K,V>
implements Serializable
    A hash table based implementation of MultivaluedMap interface. This implementation provides all of the optional map operations. This class makes no guarantees as to the order of the map; in particular, it does not guarantee that the order will remain constant over time. The implementation permits null key. By default the implementation does also permit null values, but ignores them. This behavior can be customized by overriding the protected addNull(...) and addFirstNull(...) methods.

    This implementation provides constant-time performance for the basic operations (get and put), assuming the hash function disperses the elements properly among the buckets. Iteration over collection views requires time proportional to the "capacity" of the map instance (the number of buckets) plus its size (the number of key-value mappings). Thus, it's very important not to set the initial capacity too high (or the load factor too low) if iteration performance is important.

    An instance of MultivaluedHashMap has two parameters that affect its performance: initial capacity and load factor. The capacity is the number of buckets in the hash table, and the initial capacity is simply the capacity at the time the hash table is created. The load factor is a measure of how full the hash table is allowed to get before its capacity is automatically increased. When the number of entries in the hash table exceeds the product of the load factor and the current capacity, the hash table is rehashed (that is, internal data structures are rebuilt) so that the hash table has approximately twice the number of buckets.

    As a general rule, the default load factor (.75) offers a good tradeoff between time and space costs. Higher values decrease the space overhead but increase the lookup cost (reflected in most of the operations of the HashMap class, including get and put). The expected number of entries in the map and its load factor should be taken into account when setting its initial capacity, so as to minimize the number of rehash operations. If the initial capacity is greater than the maximum number of entries divided by the load factor, no rehash operations will ever occur.

    If many mappings are to be stored in a MultivaluedHashMap instance, creating it with a sufficiently large capacity will allow the mappings to be stored more efficiently than letting it perform automatic rehashing as needed to grow the table.

    Note that this implementation is not guaranteed to be synchronized. If multiple threads access a hash map concurrently, and at least one of the threads modifies the map structurally, it must be synchronized externally. (A structural modification is any operation that adds or deletes one or more mappings; merely changing the value associated with a key that an instance already contains is not a structural modification.) This is typically accomplished by synchronizing on some object that naturally encapsulates the map.

    The iterators returned by all of this class's "collection view methods" are fail-fast: if the map is structurally modified at any time after the iterator is created, in any way except through the iterator's own remove method, the iterator will throw a ConcurrentModificationException. Thus, in the face of concurrent modification, the iterator fails quickly and cleanly, rather than risking arbitrary, non-deterministic behavior at an undetermined time in the future.

    Note that the fail-fast behavior of an iterator cannot be guaranteed as it is, generally speaking, impossible to make any hard guarantees in the presence of unsynchronized concurrent modification. Fail-fast iterators throw ConcurrentModificationException on a best-effort basis. Therefore, it would be wrong to write a program that depended on this exception for its correctness: the fail-fast behavior of iterators should be used only to detect bugs.

    Since:
    2.0
    Author:
    Paul Sandoz, Marek Potociar
    See Also:
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      • Fields inherited from class javax.ws.rs.core.AbstractMultivaluedMap

        store

    • Constructor Summary

      Constructors
      Constructor and Description
      MultivaluedHashMap()
      Constructs an empty multivalued hash map with the default initial capacity (16) and the default load factor (0.75).
      MultivaluedHashMap(int initialCapacity)
      Constructs an empty multivalued hash map with the specified initial capacity and the default load factor (0.75).
      MultivaluedHashMap(int initialCapacity, float loadFactor)
      Constructs an empty multivalued hash map with the specified initial capacity and load factor.
      MultivaluedHashMap(Map<? extends K,? extends V> map)
      Constructs a new multivalued hash map with the same mappings as the specified single-valued Map.
      MultivaluedHashMap(MultivaluedMap<? extends K,? extends V> map)
      Constructs a new multivalued hash map with the same mappings as the specified MultivaluedMap.

    • Method Summary

      • Methods inherited from class javax.ws.rs.core.AbstractMultivaluedMap

        add, addAll, addAll, addFirst, addFirstNull, addNull, clear, containsKey, containsValue, entrySet, equals, equalsIgnoreValueOrder, get, getFirst, getValues, hashCode, isEmpty, keySet, put, putAll, putSingle, remove, size, toString, values

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MultivaluedHashMap

        public MultivaluedHashMap()
        Constructs an empty multivalued hash map with the default initial capacity (16) and the default load factor (0.75).

      • MultivaluedHashMap

        public MultivaluedHashMap(int initialCapacity)
        Constructs an empty multivalued hash map with the specified initial capacity and the default load factor (0.75).
        Parameters:
        initialCapacity - the initial capacity.
        Throws:
        IllegalArgumentException - if the initial capacity is negative.

      • MultivaluedHashMap

        public MultivaluedHashMap(int initialCapacity,
                  float loadFactor)
        Constructs an empty multivalued hash map with the specified initial capacity and load factor.
        Parameters:
        initialCapacity - the initial capacity
        loadFactor - the load factor
        Throws:
        IllegalArgumentException - if the initial capacity is negative or the load factor is nonpositive

      • MultivaluedHashMap

        public MultivaluedHashMap(MultivaluedMap<? extends K,? extends V> map)
        Constructs a new multivalued hash map with the same mappings as the specified MultivaluedMap. The List instances holding the values of each key are created anew instead of being reused.
        Parameters:
        map - the multivalued map whose mappings are to be placed in this multivalued map.
        Throws:
        NullPointerException - if the specified map is null

      • MultivaluedHashMap

        public MultivaluedHashMap(Map<? extends K,? extends V> map)
        Constructs a new multivalued hash map with the same mappings as the specified single-valued Map.
        Parameters:
        map - the single-valued map whose mappings are to be placed in this multivalued map.
        Throws:
        NullPointerException - if the specified map is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MultivaluedMap (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface MultivaluedMap<K,V>

  • Type Parameters:
    K - the type of keys maintained by this map
    V - the type of mapped values
    All Superinterfaces:
    Map<K,List<V>>
    All Known Implementing Classes:
    AbstractMultivaluedMap, MultivaluedHashMap

    public interface MultivaluedMap<K,V>
extends Map<K,List<V>>
    A map of key-values pairs. Each key can have zero or more values.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley, Marek Potociar

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void add(K key, V value)
      Add a value to the current list of values for the supplied key.
      void addAll(K key, List<V> valueList)
      Add all the values from the supplied value list to the current list of values for the supplied key.
      void addAll(K key, V... newValues)
      Add multiple values to the current list of values for the supplied key.
      void addFirst(K key, V value)
      Add a value to the first position in the current list of values for the supplied key.
      boolean equalsIgnoreValueOrder(MultivaluedMap<K,V> otherMap)
      Compare the specified map with this map for equality modulo the order of values for each key.
      V getFirst(K key)
      A shortcut to get the first value of the supplied key.
      void putSingle(K key, V value)
      Set the key's value to be a one item list consisting of the supplied value.

      • Methods inherited from interface java.util.Map

        clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

    • Method Detail

      • putSingle

        void putSingle(K key,
             V value)
        Set the key's value to be a one item list consisting of the supplied value. Any existing values will be replaced.
        Parameters:
        key - the key
        value - the single value of the key

      • add

        void add(K key,
       V value)
        Add a value to the current list of values for the supplied key.
        Parameters:
        key - the key
        value - the value to be added.

      • getFirst

        V getFirst(K key)
        A shortcut to get the first value of the supplied key.
        Parameters:
        key - the key
        Returns:
        the first value for the specified key or null if the key is not in the map.

      • addAll

        void addAll(K key,
          V... newValues)
        Add multiple values to the current list of values for the supplied key. If the supplied array of new values is empty, method returns immediately. Method throws a NullPointerException if the supplied array of values is null.
        Parameters:
        key - the key.
        newValues - the values to be added.
        Throws:
        NullPointerException - if the supplied array of new values is null.
        Since:
        2.0

      • addAll

        void addAll(K key,
          List<V> valueList)
        Add all the values from the supplied value list to the current list of values for the supplied key. If the supplied value list is empty, method returns immediately. Method throws a NullPointerException if the supplied array of values is null.
        Parameters:
        key - the key.
        valueList - the list of values to be added.
        Throws:
        NullPointerException - if the supplied value list is null.
        Since:
        2.0

      • addFirst

        void addFirst(K key,
            V value)
        Add a value to the first position in the current list of values for the supplied key.
        Parameters:
        key - the key
        value - the value to be added.
        Since:
        2.0

      • equalsIgnoreValueOrder

        boolean equalsIgnoreValueOrder(MultivaluedMap<K,V> otherMap)
        Compare the specified map with this map for equality modulo the order of values for each key. Specifically, the values associated with each key are compared as if they were ordered lists.
        Parameters:
        otherMap - map to be compared to this one.
        Returns:
        true if the maps are equal modulo value ordering.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NewCookie (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class NewCookie

  • java.lang.Object
    • javax.ws.rs.core.Cookie
      • javax.ws.rs.core.NewCookie

  • public class NewCookie
extends Cookie
    Used to create a new HTTP cookie, transferred in a response.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    IETF RFC 2109

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int DEFAULT_MAX_AGE
      Specifies that the cookie expires with the current application/browser session.

      • Fields inherited from class javax.ws.rs.core.Cookie

        DEFAULT_VERSION

    • Constructor Summary

      Constructors
      Constructor and Description
      NewCookie(Cookie cookie)
      Create a new instance copying the information in the supplied cookie.
      NewCookie(Cookie cookie, String comment, int maxAge, boolean secure)
      Create a new instance supplementing the information in the supplied cookie.
      NewCookie(Cookie cookie, String comment, int maxAge, Date expiry, boolean secure, boolean httpOnly)
      Create a new instance supplementing the information in the supplied cookie.
      NewCookie(String name, String value)
      Create a new instance.
      NewCookie(String name, String value, String path, String domain, int version, String comment, int maxAge, boolean secure)
      Create a new instance.
      NewCookie(String name, String value, String path, String domain, int version, String comment, int maxAge, Date expiry, boolean secure, boolean httpOnly)
      Create a new instance.
      NewCookie(String name, String value, String path, String domain, String comment, int maxAge, boolean secure)
      Create a new instance.
      NewCookie(String name, String value, String path, String domain, String comment, int maxAge, boolean secure, boolean httpOnly)
      Create a new instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Compare for equality.
      String getComment()
      Get the comment associated with the cookie.
      Date getExpiry()
      Get the cookie expiry date.
      int getMaxAge()
      Get the maximum age of the the cookie in seconds.
      int hashCode()
      Generate a hash code by hashing all of the properties.
      boolean isHttpOnly()
      Returns true if this cookie contains the HttpOnly attribute.
      boolean isSecure()
      Whether the cookie will only be sent over a secure connection.
      Cookie toCookie()
      Obtain a new instance of a Cookie with the same name, value, path, domain and version as this NewCookie.
      String toString()
      Convert the cookie to a string suitable for use as the value of the corresponding HTTP header.
      static NewCookie valueOf(String value)
      Creates a new instance of NewCookie by parsing the supplied string.

      • Methods inherited from class javax.ws.rs.core.Cookie

        getDomain, getName, getPath, getValue, getVersion

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Field Detail

      • DEFAULT_MAX_AGE

        public static final int DEFAULT_MAX_AGE
        Specifies that the cookie expires with the current application/browser session.
        See Also:
        Constant Field Values

    • Constructor Detail

      • NewCookie

        public NewCookie(String name,
         String value)
        Create a new instance.
        Parameters:
        name - the name of the cookie.
        value - the value of the cookie.
        Throws:
        IllegalArgumentException - if name is null.

      • NewCookie

        public NewCookie(String name,
         String value,
         String path,
         String domain,
         String comment,
         int maxAge,
         boolean secure)
        Create a new instance.
        Parameters:
        name - the name of the cookie.
        value - the value of the cookie.
        path - the URI path for which the cookie is valid.
        domain - the host domain for which the cookie is valid.
        comment - the comment.
        maxAge - the maximum age of the cookie in seconds.
        secure - specifies whether the cookie will only be sent over a secure connection.
        Throws:
        IllegalArgumentException - if name is null.

      • NewCookie

        public NewCookie(String name,
         String value,
         String path,
         String domain,
         String comment,
         int maxAge,
         boolean secure,
         boolean httpOnly)
        Create a new instance.
        Parameters:
        name - the name of the cookie.
        value - the value of the cookie.
        path - the URI path for which the cookie is valid.
        domain - the host domain for which the cookie is valid.
        comment - the comment.
        maxAge - the maximum age of the cookie in seconds.
        secure - specifies whether the cookie will only be sent over a secure connection.
        httpOnly - if true make the cookie HTTP only, i.e. only visible as part of an HTTP request.
        Throws:
        IllegalArgumentException - if name is null.
        Since:
        2.0

      • NewCookie

        public NewCookie(String name,
         String value,
         String path,
         String domain,
         int version,
         String comment,
         int maxAge,
         boolean secure)
        Create a new instance.
        Parameters:
        name - the name of the cookie
        value - the value of the cookie
        path - the URI path for which the cookie is valid
        domain - the host domain for which the cookie is valid
        version - the version of the specification to which the cookie complies
        comment - the comment
        maxAge - the maximum age of the cookie in seconds
        secure - specifies whether the cookie will only be sent over a secure connection
        Throws:
        IllegalArgumentException - if name is null.

      • NewCookie

        public NewCookie(String name,
         String value,
         String path,
         String domain,
         int version,
         String comment,
         int maxAge,
         Date expiry,
         boolean secure,
         boolean httpOnly)
        Create a new instance.
        Parameters:
        name - the name of the cookie
        value - the value of the cookie
        path - the URI path for which the cookie is valid
        domain - the host domain for which the cookie is valid
        version - the version of the specification to which the cookie complies
        comment - the comment
        maxAge - the maximum age of the cookie in seconds
        expiry - the cookie expiry date.
        secure - specifies whether the cookie will only be sent over a secure connection
        httpOnly - if true make the cookie HTTP only, i.e. only visible as part of an HTTP request.
        Throws:
        IllegalArgumentException - if name is null.
        Since:
        2.0

      • NewCookie

        public NewCookie(Cookie cookie)
        Create a new instance copying the information in the supplied cookie.
        Parameters:
        cookie - the cookie to clone.
        Throws:
        IllegalArgumentException - if cookie is null.

      • NewCookie

        public NewCookie(Cookie cookie,
         String comment,
         int maxAge,
         boolean secure)
        Create a new instance supplementing the information in the supplied cookie.
        Parameters:
        cookie - the cookie to clone.
        comment - the comment.
        maxAge - the maximum age of the cookie in seconds.
        secure - specifies whether the cookie will only be sent over a secure connection.
        Throws:
        IllegalArgumentException - if cookie is null.

      • NewCookie

        public NewCookie(Cookie cookie,
         String comment,
         int maxAge,
         Date expiry,
         boolean secure,
         boolean httpOnly)
        Create a new instance supplementing the information in the supplied cookie.
        Parameters:
        cookie - the cookie to clone.
        comment - the comment.
        maxAge - the maximum age of the cookie in seconds.
        expiry - the cookie expiry date.
        secure - specifies whether the cookie will only be sent over a secure connection.
        httpOnly - if true make the cookie HTTP only, i.e. only visible as part of an HTTP request.
        Throws:
        IllegalArgumentException - if cookie is null.
        Since:
        2.0

    • Method Detail

      • valueOf

        public static NewCookie valueOf(String value)
        Creates a new instance of NewCookie by parsing the supplied string.
        Parameters:
        value - the cookie string.
        Returns:
        the newly created NewCookie.
        Throws:
        IllegalArgumentException - if the supplied string cannot be parsed or is null.

      • getComment

        public String getComment()
        Get the comment associated with the cookie.
        Returns:
        the comment or null if none set

      • getMaxAge

        public int getMaxAge()
        Get the maximum age of the the cookie in seconds. Cookies older than the maximum age are discarded. A cookie can be unset by sending a new cookie with maximum age of 0 since it will overwrite any existing cookie and then be immediately discarded. The default value of -1 indicates that the cookie will be discarded at the end of the browser/application session.

        Note that it is recommended to use Max-Age to control cookie expiration, however some browsers do not understand Max-Age, in which case setting getExpiry() Expires} parameter may be necessary.

        Returns:
        the maximum age in seconds.
        See Also:
        getExpiry()

      • getExpiry

        public Date getExpiry()
        Get the cookie expiry date. Cookies whose expiry date has passed are discarded. A cookie can be unset by setting a new cookie with an expiry date in the past, typically the lowest possible date that can be set.

        Note that it is recommended to use Max-Age to control cookie expiration, however some browsers do not understand Max-Age, in which case setting Expires parameter may be necessary.

        Returns:
        cookie expiry date or null if no expiry date was set.
        Since:
        2.0
        See Also:
        getMaxAge()

      • isSecure

        public boolean isSecure()
        Whether the cookie will only be sent over a secure connection. Defaults to false.
        Returns:
        true if the cookie will only be sent over a secure connection, false otherwise.

      • isHttpOnly

        public boolean isHttpOnly()
        Returns true if this cookie contains the HttpOnly attribute. This means that the cookie should not be accessible to scripting engines, like javascript.
        Returns:
        true if this cookie should be considered http only, false otherwise.
        Since:
        2.0

      • toCookie

        public Cookie toCookie()
        Obtain a new instance of a Cookie with the same name, value, path, domain and version as this NewCookie. This method can be used to obtain an object that can be compared for equality with another Cookie; since a Cookie will never compare equal to a NewCookie.
        Returns:
        a Cookie

      • toString

        public String toString()
        Convert the cookie to a string suitable for use as the value of the corresponding HTTP header.
        Overrides:
        toString in class Cookie
        Returns:
        a stringified cookie.

      • hashCode

        public int hashCode()
        Generate a hash code by hashing all of the properties.
        Overrides:
        hashCode in class Cookie
        Returns:
        the hash code.

      • equals

        public boolean equals(Object obj)
        Compare for equality. Use toCookie() to compare a NewCookie to a Cookie considering only the common properties.
        Overrides:
        equals in class Cookie
        Parameters:
        obj - the object to compare to
        Returns:
        true if the object is a NewCookie with the same value for all properties, false otherwise.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoContentException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class NoContentException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.ws.rs.core.NoContentException
  • All Implemented Interfaces:
    Serializable

    public class NoContentException
extends IOException
    An I/O exception thrown by MessageBodyReader implementations when reading a zero-length message content to indicate that the message body reader is not able to produce an instance representing an zero-length message content.

    This exception, when thrown while reading a server request entity, is automatically translated by JAX-RS server runtime into a BadRequestException wrapping the original NoContentException and rethrown for a standard processing by the registered exception mappers.

    Since:
    2.0
    Author:
    Marek Potociar (marek.potociar at oracle.com)
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoContentException(String message)
      Construct a new NoContentException instance.
      NoContentException(String message, Throwable cause)
      Construct a new NoContentException instance.
      NoContentException(Throwable cause)
      Construct a new NoContentException instance.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoContentException

        public NoContentException(String message)
        Construct a new NoContentException instance.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • NoContentException

        public NoContentException(String message,
                  Throwable cause)
        Construct a new NoContentException instance.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the underlying cause of the exception.

      • NoContentException

        public NoContentException(Throwable cause)
        Construct a new NoContentException instance.
        Parameters:
        cause - the underlying cause of the exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PathSegment (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface PathSegment

  • public interface PathSegment
    Represents a URI path segment and any associated matrix parameters. When an instance of this type is injected with PathParam, the value of the annotation identifies which path segment is selected and the presence of an Encoded annotation will result in an instance that supplies the path and matrix parameter values in URI encoded form.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    UriInfo.getPathSegments(), PathParam

    • Method Summary

      Methods
      Modifier and Type Method and Description
      MultivaluedMap<String,String> getMatrixParameters()
      Get a map of the matrix parameters associated with the path segment.
      String getPath()
      Get the path segment.

    • Method Detail

      • getPath

        String getPath()
        Get the path segment.

        Returns:
        the path segment

      • getMatrixParameters

        MultivaluedMap<String,String> getMatrixParameters()
        Get a map of the matrix parameters associated with the path segment. The map keys are the names of the matrix parameters with any percent-escaped octets decoded.
        Returns:
        the map of matrix parameters
        See Also:
        Matrix URIs
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Request (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface Request

  • public interface Request
    An injectable helper for request processing, all methods throw an IllegalStateException if called outside the scope of a request (e.g. from a provider constructor). Precondition processing (see the evaluatePreconditions methods) can result in either a null return value to indicate that preconditions have been met and that the request should continue, or a non-null return value to indicate that preconditions were not met. In the event that preconditions were not met, the returned ResponseBuilder instance will have an appropriate status and will also include a Vary header if the selectVariant(List) method was called prior to to calling evaluatePreconditions. It is the responsibility of the caller to check the status and add additional metadata if required. E.g., see HTTP/1.1, section 10.3.5 for details of the headers that are expected to accompany a 304 Not Modified response.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley, Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Response.ResponseBuilder evaluatePreconditions()
      Evaluate request preconditions for a resource that does not currently exist.
      Response.ResponseBuilder evaluatePreconditions(Date lastModified)
      Evaluate request preconditions based on the passed in value.
      Response.ResponseBuilder evaluatePreconditions(Date lastModified, EntityTag eTag)
      Evaluate request preconditions based on the passed in value.
      Response.ResponseBuilder evaluatePreconditions(EntityTag eTag)
      Evaluate request preconditions based on the passed in value.
      String getMethod()
      Get the request method, e.g.
      Variant selectVariant(List<Variant> variants)
      Select the representation variant that best matches the request.

    • Method Detail

      • getMethod

        String getMethod()
        Get the request method, e.g. GET, POST, etc.
        Returns:
        the request method.
        See Also:
        HttpMethod

      • selectVariant

        Variant selectVariant(List<Variant> variants)
        Select the representation variant that best matches the request. Returns null in case there is no matching variant in the list.

        More explicit variants are chosen ahead of less explicit ones. A vary header is computed from the supplied list and automatically added to the response.

        Parameters:
        variants - a list of Variant that describe all of the available representation variants.
        Returns:
        the variant that best matches the request or null if there's no match.
        Throws:
        IllegalArgumentException - if variants is empty or null.
        IllegalStateException - if called outside the scope of a request.
        See Also:
        Variant.VariantListBuilder

      • evaluatePreconditions

        Response.ResponseBuilder evaluatePreconditions(EntityTag eTag)
        Evaluate request preconditions based on the passed in value.
        Parameters:
        eTag - an ETag for the current state of the resource
        Returns:
        null if the preconditions are met or a ResponseBuilder set with the appropriate status if the preconditions are not met. A returned ResponseBuilder will include an ETag header set with the value of eTag, provided none of the precondition evaluation has failed, in which case the ETag header would not be included and the status code of the returned ResponseBuilder would be set to Response.Status.PRECONDITION_FAILED.
        Throws:
        IllegalArgumentException - if eTag is null.
        IllegalStateException - if called outside the scope of a request.

      • evaluatePreconditions

        Response.ResponseBuilder evaluatePreconditions(Date lastModified)
        Evaluate request preconditions based on the passed in value.
        Parameters:
        lastModified - a date that specifies the modification date of the resource
        Returns:
        null if the preconditions are met or a ResponseBuilder set with the appropriate status if the preconditions are not met.
        Throws:
        IllegalArgumentException - if lastModified is null.
        IllegalStateException - if called outside the scope of a request.

      • evaluatePreconditions

        Response.ResponseBuilder evaluatePreconditions(Date lastModified,
                                             EntityTag eTag)
        Evaluate request preconditions based on the passed in value.
        Parameters:
        lastModified - a date that specifies the modification date of the resource
        eTag - an ETag for the current state of the resource
        Returns:
        null if the preconditions are met or a ResponseBuilder set with the appropriate status if the preconditions are not met. A returned ResponseBuilder will include an ETag header set with the value of eTag, provided none of the precondition evaluation has failed, in which case the ETag header would not be included and the status code of the returned ResponseBuilder would be set to Response.Status.PRECONDITION_FAILED.
        Throws:
        IllegalArgumentException - if lastModified or eTag is null.
        IllegalStateException - if called outside the scope of a request.

      • evaluatePreconditions

        Response.ResponseBuilder evaluatePreconditions()
        Evaluate request preconditions for a resource that does not currently exist. The primary use of this method is to support the If-Match: * and If-None-Match: * preconditions.

        Note that both preconditions If-None-Match: * and If-None-Match: something will always be considered to have been met and it is the applications responsibility to enforce any additional method-specific semantics. E.g. a PUT on a resource that does not exist might succeed whereas a GET on a resource that does not exist would likely result in a 404 response. It would be the responsibility of the application to generate the 404 response.

        Returns:
        null if the preconditions are met or a ResponseBuilder set with the appropriate status if the preconditions are not met.
        Throws:
        IllegalStateException - if called outside the scope of a request.
        Since:
        1.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Response (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class Response

  • java.lang.Object
    • javax.ws.rs.core.Response

  • public abstract class Response
extends Object
    Defines the contract between a returned instance and the runtime when an application needs to provide meta-data to the runtime.

    An application class should not extend this class directly. Response class is reserved for an extension by a JAX-RS implementation providers. An application should use one of the static methods to create a Response instance using a ResponseBuilder.

    Several methods have parameters of type URI, UriBuilder provides convenient methods to create such values as does URI.create(java.lang.String).

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley, Marek Potociar
    See Also:
    Response.ResponseBuilder

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  Response.ResponseBuilder
      A class used to build Response instances that contain metadata instead of or in addition to an entity.
      static class  Response.Status
      Commonly used status codes defined by HTTP, see HTTP/1.1 documentation for the complete list.
      static interface  Response.StatusType
      Base interface for statuses used in responses.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Response()
      Protected constructor, use one of the static methods to obtain a Response.ResponseBuilder instance and obtain a Response from that.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Response.ResponseBuilder accepted()
      Create a new ResponseBuilder with an ACCEPTED status.
      static Response.ResponseBuilder accepted(Object entity)
      Create a new ResponseBuilder with an ACCEPTED status that contains a representation.
      abstract boolean bufferEntity()
      Buffer the message entity data.
      abstract void close()
      Close the underlying message entity input stream (if available and open) as well as releases any other resources associated with the response (e.g.
      static Response.ResponseBuilder created(URI location)
      Create a new ResponseBuilder for a created resource, set the location header using the supplied value.
      static Response.ResponseBuilder fromResponse(Response response)
      Create a new ResponseBuilder by performing a shallow copy of an existing Response.
      abstract Set<String> getAllowedMethods()
      Get the allowed HTTP methods from the Allow HTTP header.
      abstract Map<String,NewCookie> getCookies()
      Get any new cookies set on the response message.
      abstract Date getDate()
      Get message date.
      abstract Object getEntity()
      Get the message entity Java instance.
      abstract EntityTag getEntityTag()
      Get the entity tag.
      MultivaluedMap<String,Object> getHeaders()
      Get view of the response headers and their object values.
      abstract String getHeaderString(String name)
      Get a message header as a single string value.
      abstract Locale getLanguage()
      Get the language of the message entity.
      abstract Date getLastModified()
      Get the last modified date.
      abstract int getLength()
      Get Content-Length value.
      abstract Link getLink(String relation)
      Get the link for the relation.
      abstract Link.Builder getLinkBuilder(String relation)
      Convenience method that returns a Link.Builder for the relation.
      abstract Set<Link> getLinks()
      Get the links attached to the message as headers.
      abstract URI getLocation()
      Get the location.
      abstract MediaType getMediaType()
      Get the media type of the message entity.
      abstract MultivaluedMap<String,Object> getMetadata()
      See getHeaders().
      abstract int getStatus()
      Get the status code associated with the response.
      abstract Response.StatusType getStatusInfo()
      Get the complete status information associated with the response.
      abstract MultivaluedMap<String,String> getStringHeaders()
      Get view of the response headers and their string values.
      abstract boolean hasEntity()
      Check if there is an entity available in the response.
      abstract boolean hasLink(String relation)
      Check if link for relation exists.
      static Response.ResponseBuilder noContent()
      Create a new ResponseBuilder for an empty response.
      static Response.ResponseBuilder notAcceptable(List<Variant> variants)
      Create a new ResponseBuilder for a not acceptable response.
      static Response.ResponseBuilder notModified()
      Create a new ResponseBuilder with a not-modified status.
      static Response.ResponseBuilder notModified(EntityTag tag)
      Create a new ResponseBuilder with a not-modified status.
      static Response.ResponseBuilder notModified(String tag)
      Create a new ResponseBuilder with a not-modified status and a strong entity tag.
      static Response.ResponseBuilder ok()
      Create a new ResponseBuilder with an OK status.
      static Response.ResponseBuilder ok(Object entity)
      Create a new ResponseBuilder that contains a representation.
      static Response.ResponseBuilder ok(Object entity, MediaType type)
      Create a new ResponseBuilder that contains a representation.
      static Response.ResponseBuilder ok(Object entity, String type)
      Create a new ResponseBuilder that contains a representation.
      static Response.ResponseBuilder ok(Object entity, Variant variant)
      Create a new ResponseBuilder that contains a representation.
      abstract <T> T readEntity(Class<T> entityType)
      Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.
      abstract <T> T readEntity(Class<T> entityType, Annotation[] annotations)
      Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.
      abstract <T> T readEntity(GenericType<T> entityType)
      Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.
      abstract <T> T readEntity(GenericType<T> entityType, Annotation[] annotations)
      Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.
      static Response.ResponseBuilder seeOther(URI location)
      Create a new ResponseBuilder for a redirection.
      static Response.ResponseBuilder serverError()
      Create a new ResponseBuilder with an server error status.
      static Response.ResponseBuilder status(int status)
      Create a new ResponseBuilder with the supplied status.
      static Response.ResponseBuilder status(Response.Status status)
      Create a new ResponseBuilder with the supplied status.
      static Response.ResponseBuilder status(Response.StatusType status)
      Create a new ResponseBuilder with the supplied status.
      static Response.ResponseBuilder temporaryRedirect(URI location)
      Create a new ResponseBuilder for a temporary redirection.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Response

        protected Response()
        Protected constructor, use one of the static methods to obtain a Response.ResponseBuilder instance and obtain a Response from that.

    • Method Detail

      • getStatus

        public abstract int getStatus()
        Get the status code associated with the response.
        Returns:
        the response status code.

      • getStatusInfo

        public abstract Response.StatusType getStatusInfo()
        Get the complete status information associated with the response.
        Returns:
        the response status information. The returned value is never null.
        Since:
        2.0

      • getEntity

        public abstract Object getEntity()
        Get the message entity Java instance. Returns null if the message does not contain an entity body.

        If the entity is represented by an un-consumed input stream the method will return the input stream.

        Returns:
        the message entity or null if message does not contain an entity body (i.e. when hasEntity() returns false).
        Throws:
        IllegalStateException - if the entity was previously fully consumed as an input stream, or if the response has been closed.

      • readEntity

        public abstract <T> T readEntity(Class<T> entityType)
        Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.

        Method throws an ProcessingException if the content of the message cannot be mapped to an entity of the requested type and IllegalStateException in case the entity is not backed by an input stream or if the original entity input stream has already been consumed without buffering the entity data prior consuming.

        A message instance returned from this method will be cached for subsequent retrievals via getEntity(). Unless the supplied entity type is an input stream, this method automatically closes the an unconsumed original response entity data stream if open. In case the entity data has been buffered, the buffer will be reset prior consuming the buffered data to enable subsequent invocations of readEntity(...) methods on this response.

        Type Parameters:
        T - entity instance Java type.
        Parameters:
        entityType - the type of entity.
        Returns:
        the message entity; for a zero-length response entities returns a corresponding Java object that represents zero-length data. In case no zero-length representation is defined for the Java type, a ProcessingException wrapping the underlying NoContentException is thrown.
        Throws:
        ProcessingException - if the content of the message cannot be mapped to an entity of the requested type.
        IllegalStateException - if the entity is not backed by an input stream, the response has been closed already, or if the entity input stream has been fully consumed already and has not been buffered prior consuming.
        Since:
        2.0
        See Also:
        MessageBodyReader

      • readEntity

        public abstract <T> T readEntity(GenericType<T> entityType)
        Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.

        Method throws an ProcessingException if the content of the message cannot be mapped to an entity of the requested type and IllegalStateException in case the entity is not backed by an input stream or if the original entity input stream has already been consumed without buffering the entity data prior consuming.

        A message instance returned from this method will be cached for subsequent retrievals via getEntity(). Unless the supplied entity type is an input stream, this method automatically closes the an unconsumed original response entity data stream if open. In case the entity data has been buffered, the buffer will be reset prior consuming the buffered data to enable subsequent invocations of readEntity(...) methods on this response.

        Type Parameters:
        T - entity instance Java type.
        Parameters:
        entityType - the type of entity; may be generic.
        Returns:
        the message entity; for a zero-length response entities returns a corresponding Java object that represents zero-length data. In case no zero-length representation is defined for the Java type, a ProcessingException wrapping the underlying NoContentException is thrown.
        Throws:
        ProcessingException - if the content of the message cannot be mapped to an entity of the requested type.
        IllegalStateException - if the entity is not backed by an input stream, the response has been closed already, or if the entity input stream has been fully consumed already and has not been buffered prior consuming.
        Since:
        2.0
        See Also:
        MessageBodyReader

      • readEntity

        public abstract <T> T readEntity(Class<T> entityType,
               Annotation[] annotations)
        Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.

        Method throws an ProcessingException if the content of the message cannot be mapped to an entity of the requested type and IllegalStateException in case the entity is not backed by an input stream or if the original entity input stream has already been consumed without buffering the entity data prior consuming.

        A message instance returned from this method will be cached for subsequent retrievals via getEntity(). Unless the supplied entity type is an input stream, this method automatically closes the an unconsumed original response entity data stream if open. In case the entity data has been buffered, the buffer will be reset prior consuming the buffered data to enable subsequent invocations of readEntity(...) methods on this response.

        Type Parameters:
        T - entity instance Java type.
        Parameters:
        entityType - the type of entity.
        annotations - annotations that will be passed to the MessageBodyReader.
        Returns:
        the message entity; for a zero-length response entities returns a corresponding Java object that represents zero-length data. In case no zero-length representation is defined for the Java type, a ProcessingException wrapping the underlying NoContentException is thrown.
        Throws:
        ProcessingException - if the content of the message cannot be mapped to an entity of the requested type.
        IllegalStateException - if the entity is not backed by an input stream, the response has been closed already, or if the entity input stream has been fully consumed already and has not been buffered prior consuming.
        Since:
        2.0
        See Also:
        MessageBodyReader

      • readEntity

        public abstract <T> T readEntity(GenericType<T> entityType,
               Annotation[] annotations)
        Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.

        Method throws an ProcessingException if the content of the message cannot be mapped to an entity of the requested type and IllegalStateException in case the entity is not backed by an input stream or if the original entity input stream has already been consumed without buffering the entity data prior consuming.

        A message instance returned from this method will be cached for subsequent retrievals via getEntity(). Unless the supplied entity type is an input stream, this method automatically closes the an unconsumed original response entity data stream if open. In case the entity data has been buffered, the buffer will be reset prior consuming the buffered data to enable subsequent invocations of readEntity(...) methods on this response.

        Type Parameters:
        T - entity instance Java type.
        Parameters:
        entityType - the type of entity; may be generic.
        annotations - annotations that will be passed to the MessageBodyReader.
        Returns:
        the message entity; for a zero-length response entities returns a corresponding Java object that represents zero-length data. In case no zero-length representation is defined for the Java type, a ProcessingException wrapping the underlying NoContentException is thrown.
        Throws:
        ProcessingException - if the content of the message cannot be mapped to an entity of the requested type.
        IllegalStateException - if the entity is not backed by an input stream, the response has been closed already, or if the entity input stream has been fully consumed already and has not been buffered prior consuming.
        Since:
        2.0
        See Also:
        MessageBodyReader

      • hasEntity

        public abstract boolean hasEntity()
        Check if there is an entity available in the response. The method returns true if the entity is present, returns false otherwise.

        Note that the method may return true also for response messages with a zero-length content, in case the "Content-Length" and "Content-Type" headers are specified in the message. In such case, an attempt to read the entity using one of the readEntity(...) methods will return a corresponding instance representing a zero-length entity for a given Java type or produce a ProcessingException in case no such instance is available for the Java type.

        Returns:
        true if there is an entity present in the message, false otherwise.
        Throws:
        IllegalStateException - in case the response has been closed.
        Since:
        2.0

      • bufferEntity

        public abstract boolean bufferEntity()
        Buffer the message entity data.

        In case the message entity is backed by an unconsumed entity input stream, all the bytes of the original entity input stream are read and stored in a local buffer. The original entity input stream is consumed and automatically closed as part of the operation and the method returns true.

        In case the response entity instance is not backed by an unconsumed input stream an invocation of bufferEntity method is ignored and the method returns false.

        This operation is idempotent, i.e. it can be invoked multiple times with the same effect which also means that calling the bufferEntity() method on an already buffered (and thus closed) message instance is legal and has no further effect. Also, the result returned by the bufferEntity() method is consistent across all invocations of the method on the same Response instance.

        Buffering the message entity data allows for multiple invocations of readEntity(...) methods on the response instance. Note however, that once the response instance itself is closed, the implementations are expected to release the buffered message entity data too. Therefore any subsequent attempts to read a message entity stream on such closed response will result in an IllegalStateException being thrown.

        Returns:
        true if the message entity input stream was available and was buffered successfully, returns false if the entity stream was not available.
        Throws:
        ProcessingException - if there was an error while buffering the entity input stream.
        IllegalStateException - in case the response has been closed.
        Since:
        2.0

      • close

        public abstract void close()
        Close the underlying message entity input stream (if available and open) as well as releases any other resources associated with the response (e.g. buffered message entity data).

        This operation is idempotent, i.e. it can be invoked multiple times with the same effect which also means that calling the close() method on an already closed message instance is legal and has no further effect.

        The close() method should be invoked on all instances that contain an un-consumed entity input stream to ensure the resources associated with the instance are properly cleaned-up and prevent potential memory leaks. This is typical for client-side scenarios where application layer code processes only the response headers and ignores the response entity.

        Any attempts to manipulate (read, get, buffer) a message entity on a closed response will result in an IllegalStateException being thrown.

        Throws:
        ProcessingException - if there is an error closing the response.
        Since:
        2.0

      • getMediaType

        public abstract MediaType getMediaType()
        Get the media type of the message entity.
        Returns:
        the media type or null if there is no response entity.
        Since:
        2.0

      • getLanguage

        public abstract Locale getLanguage()
        Get the language of the message entity.
        Returns:
        the language of the entity or null if not specified.
        Since:
        2.0

      • getLength

        public abstract int getLength()
        Get Content-Length value.
        Returns:
        Content-Length as integer if present and valid number. In other cases returns -1.
        Since:
        2.0

      • getAllowedMethods

        public abstract Set<String> getAllowedMethods()
        Get the allowed HTTP methods from the Allow HTTP header.
        Returns:
        the allowed HTTP methods, all methods will returned as upper case strings.
        Since:
        2.0

      • getCookies

        public abstract Map<String,NewCookie> getCookies()
        Get any new cookies set on the response message.
        Returns:
        a read-only map of cookie name (String) to Cookie.
        Since:
        2.0

      • getEntityTag

        public abstract EntityTag getEntityTag()
        Get the entity tag.
        Returns:
        the entity tag, otherwise null if not present.
        Since:
        2.0

      • getDate

        public abstract Date getDate()
        Get message date.
        Returns:
        the message date, otherwise null if not present.
        Since:
        2.0

      • getLastModified

        public abstract Date getLastModified()
        Get the last modified date.
        Returns:
        the last modified date, otherwise null if not present.
        Since:
        2.0

      • getLocation

        public abstract URI getLocation()
        Get the location.
        Returns:
        the location URI, otherwise null if not present.
        Since:
        2.0

      • getLinks

        public abstract Set<Link> getLinks()
        Get the links attached to the message as headers. Any links in the message that are relative must be resolved with respect to the actual request URI that produced this response. Note that request URIs may be updated by filters, so the actual request URI may differ from that in the original invocation.
        Returns:
        links, may return empty Set if no links are present. Does not return null.
        Since:
        2.0

      • hasLink

        public abstract boolean hasLink(String relation)
        Check if link for relation exists.
        Parameters:
        relation - link relation.
        Returns:
        true if the link for the relation is present in the message headers, false otherwise.
        Since:
        2.0

      • getLink

        public abstract Link getLink(String relation)
        Get the link for the relation. A relative link is resolved with respect to the actual request URI that produced this response. Note that request URIs may be updated by filters, so the actual request URI may differ from that in the original invocation.
        Parameters:
        relation - link relation.
        Returns:
        the link for the relation, otherwise null if not present.
        Since:
        2.0

      • getLinkBuilder

        public abstract Link.Builder getLinkBuilder(String relation)
        Convenience method that returns a Link.Builder for the relation. See getLink(java.lang.String) for more information.
        Parameters:
        relation - link relation.
        Returns:
        the link builder for the relation, otherwise null if not present.
        Since:
        2.0

      • getMetadata

        public abstract MultivaluedMap<String,Object> getMetadata()
        See getHeaders(). This method is considered deprecated. Users are encouraged to switch their code to use the getHeaders() method instead. The method may be annotated as @Deprecated in a future release of JAX-RS API.
        Returns:
        response headers as a multivalued map.

      • getHeaders

        public MultivaluedMap<String,Object> getHeaders()
        Get view of the response headers and their object values. The underlying header data may be subsequently modified by the JAX-RS runtime on the server side. Changes in the underlying header data are reflected in this view.

        On the server-side, when the message is sent, the non-string values will be serialized using a RuntimeDelegate.HeaderDelegate if one is available via RuntimeDelegate.createHeaderDelegate(java.lang.Class) for the class of the value or using the values toString method if a header delegate is not available.

        On the client side, the returned map is identical to the one returned by getStringHeaders().

        Returns:
        response headers as an object view of header values.
        Since:
        2.0
        See Also:
        getStringHeaders(), getHeaderString(java.lang.String)

      • getStringHeaders

        public abstract MultivaluedMap<String,String> getStringHeaders()
        Get view of the response headers and their string values. The underlying header data may be subsequently modified by the JAX-RS runtime on the server side. Changes in the underlying header data are reflected in this view.
        Returns:
        response headers as a string view of header values.
        Since:
        2.0
        See Also:
        getHeaders(), getHeaderString(java.lang.String)

      • getHeaderString

        public abstract String getHeaderString(String name)
        Get a message header as a single string value. Each single header value is converted to String using a RuntimeDelegate.HeaderDelegate if one is available via RuntimeDelegate.createHeaderDelegate(java.lang.Class) for the header value class or using its toString method if a header delegate is not available.
        Parameters:
        name - the message header.
        Returns:
        the message header value. If the message header is not present then null is returned. If the message header is present but has no value then the empty string is returned. If the message header is present more than once then the values of joined together and separated by a ',' character.
        Since:
        2.0
        See Also:
        getHeaders(), getStringHeaders()

      • fromResponse

        public static Response.ResponseBuilder fromResponse(Response response)
        Create a new ResponseBuilder by performing a shallow copy of an existing Response.

        The returned builder has its own response headers but the header values are shared with the original Response instance. The original response entity instance reference is set in the new response builder.

        Note that if the entity is backed by an un-consumed input stream, the reference to the stream is copied. In such case make sure to buffer the entity stream of the original response instance before passing it to this method.

        Parameters:
        response - a Response from which the status code, entity and response headers will be copied.
        Returns:
        a new response builder.
        Since:
        2.0

      • status

        public static Response.ResponseBuilder status(Response.StatusType status)
        Create a new ResponseBuilder with the supplied status.
        Parameters:
        status - the response status.
        Returns:
        a new response builder.
        Throws:
        IllegalArgumentException - if status is null.

      • status

        public static Response.ResponseBuilder status(Response.Status status)
        Create a new ResponseBuilder with the supplied status.
        Parameters:
        status - the response status.
        Returns:
        a new response builder.
        Throws:
        IllegalArgumentException - if status is null.

      • status

        public static Response.ResponseBuilder status(int status)
        Create a new ResponseBuilder with the supplied status.
        Parameters:
        status - the response status.
        Returns:
        a new response builder.
        Throws:
        IllegalArgumentException - if status is less than 100 or greater than 599.

      • ok

        public static Response.ResponseBuilder ok()
        Create a new ResponseBuilder with an OK status.
        Returns:
        a new response builder.

      • ok

        public static Response.ResponseBuilder ok(Object entity)
        Create a new ResponseBuilder that contains a representation. It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required.
        Parameters:
        entity - the representation entity data.
        Returns:
        a new response builder.

      • ok

        public static Response.ResponseBuilder ok(Object entity,
                          MediaType type)
        Create a new ResponseBuilder that contains a representation. It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required.
        Parameters:
        entity - the representation entity data.
        type - the media type of the entity.
        Returns:
        a new response builder.

      • ok

        public static Response.ResponseBuilder ok(Object entity,
                          String type)
        Create a new ResponseBuilder that contains a representation. It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required.
        Parameters:
        entity - the representation entity data.
        type - the media type of the entity.
        Returns:
        a new response builder.

      • ok

        public static Response.ResponseBuilder ok(Object entity,
                          Variant variant)
        Create a new ResponseBuilder that contains a representation. It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required.
        Parameters:
        entity - the representation entity data.
        variant - representation metadata.
        Returns:
        a new response builder.

      • serverError

        public static Response.ResponseBuilder serverError()
        Create a new ResponseBuilder with an server error status.
        Returns:
        a new response builder.

      • created

        public static Response.ResponseBuilder created(URI location)
        Create a new ResponseBuilder for a created resource, set the location header using the supplied value.
        Parameters:
        location - the URI of the new resource. If a relative URI is supplied it will be converted into an absolute URI by resolving it relative to the request URI (see UriInfo.getRequestUri()).
        Returns:
        a new response builder.
        Throws:
        IllegalArgumentException - if location is null.

      • accepted

        public static Response.ResponseBuilder accepted()
        Create a new ResponseBuilder with an ACCEPTED status.
        Returns:
        a new response builder.
        Since:
        2.0

      • accepted

        public static Response.ResponseBuilder accepted(Object entity)
        Create a new ResponseBuilder with an ACCEPTED status that contains a representation. It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required.
        Parameters:
        entity - the representation entity data.
        Returns:
        a new response builder.
        Since:
        2.0

      • noContent

        public static Response.ResponseBuilder noContent()
        Create a new ResponseBuilder for an empty response.
        Returns:
        a new response builder.

      • notModified

        public static Response.ResponseBuilder notModified()
        Create a new ResponseBuilder with a not-modified status.
        Returns:
        a new response builder.

      • notModified

        public static Response.ResponseBuilder notModified(EntityTag tag)
        Create a new ResponseBuilder with a not-modified status.
        Parameters:
        tag - a tag for the unmodified entity.
        Returns:
        a new response builder.
        Throws:
        IllegalArgumentException - if tag is null.

      • notModified

        public static Response.ResponseBuilder notModified(String tag)
        Create a new ResponseBuilder with a not-modified status and a strong entity tag. This is a shortcut for notModified(new EntityTag(value)).
        Parameters:
        tag - the string content of a strong entity tag. The JAX-RS runtime will quote the supplied value when creating the header.
        Returns:
        a new response builder.
        Throws:
        IllegalArgumentException - if tag is null.

      • seeOther

        public static Response.ResponseBuilder seeOther(URI location)
        Create a new ResponseBuilder for a redirection. Used in the redirect-after-POST (aka POST/redirect/GET) pattern.
        Parameters:
        location - the redirection URI. If a relative URI is supplied it will be converted into an absolute URI by resolving it relative to the base URI of the application (see UriInfo.getBaseUri()).
        Returns:
        a new response builder.
        Throws:
        IllegalArgumentException - if location is null.

      • temporaryRedirect

        public static Response.ResponseBuilder temporaryRedirect(URI location)
        Create a new ResponseBuilder for a temporary redirection.
        Parameters:
        location - the redirection URI. If a relative URI is supplied it will be converted into an absolute URI by resolving it relative to the base URI of the application (see UriInfo.getBaseUri()).
        Returns:
        a new response builder.
        Throws:
        IllegalArgumentException - if location is null.

      • notAcceptable

        public static Response.ResponseBuilder notAcceptable(List<Variant> variants)
        Create a new ResponseBuilder for a not acceptable response.
        Parameters:
        variants - list of variants that were available, a null value is equivalent to an empty list.
        Returns:
        a new response builder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Response.ResponseBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class Response.ResponseBuilder

  • java.lang.Object
    • javax.ws.rs.core.Response.ResponseBuilder
  • Enclosing class:
    Response

    public abstract static class Response.ResponseBuilder
extends Object
    A class used to build Response instances that contain metadata instead of or in addition to an entity. An initial instance may be obtained via static methods of the Response class, instance methods provide the ability to set metadata. E.g. to create a response that indicates the creation of a new resource:
    @POST
 Response addWidget(...) {
   Widget w = ...
   URI widgetId = UriBuilder.fromResource(Widget.class)...
   return Response.created(widgetId).build();
 }

    Several methods have parameters of type URI, UriBuilder provides convenient methods to create such values as does URI.create().

    Where multiple variants of the same method are provided, the type of the supplied parameter is retained in the metadata of the built Response.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Response.ResponseBuilder()
      Protected constructor, use one of the static methods of Response to obtain an instance.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      abstract Response.ResponseBuilder allow(Set<String> methods)
      Set the list of allowed methods for the resource.
      abstract Response.ResponseBuilder allow(String... methods)
      Set the list of allowed methods for the resource.
      abstract Response build()
      Create a Response instance from the current ResponseBuilder.
      abstract Response.ResponseBuilder cacheControl(CacheControl cacheControl)
      Set the cache control data of the message.
      abstract Response.ResponseBuilder | clone()
      abstract Response.ResponseBuilder contentLocation(URI location)
      Set the content location.
      abstract Response.ResponseBuilder cookie(NewCookie... cookies)
      Add cookies to the response message.
      abstract Response.ResponseBuilder encoding(String encoding)
      Set the message entity content encoding.
      abstract Response.ResponseBuilder entity(Object entity)
      Set the response entity in the builder.
      abstract Response.ResponseBuilder entity(Object entity, Annotation[] annotations)
      Set the response entity in the builder.
      abstract Response.ResponseBuilder expires(Date expires)
      Set the response expiration date.
      abstract Response.ResponseBuilder header(String name, Object value)
      Add an arbitrary header.
      abstract Response.ResponseBuilder language(Locale language)
      Set the message entity language.
      abstract Response.ResponseBuilder language(String language)
      Set the message entity language.
      abstract Response.ResponseBuilder lastModified(Date lastModified)
      Set the response entity last modification date.
      abstract Response.ResponseBuilder link(String uri, String rel)
      Add a link header.
      abstract Response.ResponseBuilder link(URI uri, String rel)
      Add a link header.
      abstract Response.ResponseBuilder links(Link... links)
      Add one or more link headers.
      abstract Response.ResponseBuilder location(URI location)
      Set the location.
      protected static Response.ResponseBuilder newInstance()
      Create a new builder instance.
      abstract Response.ResponseBuilder replaceAll(MultivaluedMap<String,Object> headers)
      Replaces all existing headers with the newly supplied headers.
      abstract Response.ResponseBuilder status(int status)
      Set the status on the ResponseBuilder.
      Response.ResponseBuilder status(Response.Status status)
      Set the status on the ResponseBuilder.
      Response.ResponseBuilder status(Response.StatusType status)
      Set the status on the ResponseBuilder.
      abstract Response.ResponseBuilder tag(EntityTag tag)
      Set a response entity tag.
      abstract Response.ResponseBuilder tag(String tag)
      Set a strong response entity tag.
      abstract Response.ResponseBuilder type(MediaType type)
      Set the message entity media type.
      abstract Response.ResponseBuilder type(String type)
      Set the message entity media type.
      abstract Response.ResponseBuilder variant(Variant variant)
      Set message entity representation metadata.
      abstract Response.ResponseBuilder variants(List<Variant> variants)
      Add a Vary header that lists the available variants.
      abstract Response.ResponseBuilder variants(Variant... variants)
      Add a Vary header that lists the available variants.

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Response.ResponseBuilder

        protected Response.ResponseBuilder()
        Protected constructor, use one of the static methods of Response to obtain an instance.

    • Method Detail

      • newInstance

        protected static Response.ResponseBuilder newInstance()
        Create a new builder instance.
        Returns:
        a new response builder.

      • build

        public abstract Response build()
        Create a Response instance from the current ResponseBuilder. The builder is reset to a blank state equivalent to calling the ok method.
        Returns:
        a Response instance.

      • clone

        public abstract Response.ResponseBuilder clone()

        Create a copy of the ResponseBuilder preserving its state.

        Overrides:
        clone in class Object
        Returns:
        a copy of the ResponseBuilder.

      • status

        public abstract Response.ResponseBuilder status(int status)
        Set the status on the ResponseBuilder.
        Parameters:
        status - the response status.
        Returns:
        the updated response builder.
        Throws:
        IllegalArgumentException - if status is less than 100 or greater than 599.

      • status

        public Response.ResponseBuilder status(Response.StatusType status)
        Set the status on the ResponseBuilder.
        Parameters:
        status - the response status.
        Returns:
        the updated response builder.
        Throws:
        IllegalArgumentException - if status is null.
        Since:
        1.1

      • status

        public Response.ResponseBuilder status(Response.Status status)
        Set the status on the ResponseBuilder.
        Parameters:
        status - the response status.
        Returns:
        the updated response builder.
        Throws:
        IllegalArgumentException - if status is null.

      • entity

        public abstract Response.ResponseBuilder entity(Object entity)
        Set the response entity in the builder.

        Any Java type instance for a response entity, that is supported by the runtime can be passed. It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required. Note that the entity can be also set as an input stream.

        A specific entity media type can be set using one of the type(...) methods.

        Parameters:
        entity - the request entity.
        Returns:
        updated response builder instance.
        See Also:
        entity(java.lang.Object, java.lang.annotation.Annotation[]),
type(javax.ws.rs.core.MediaType),
type(java.lang.String)

      • entity

        public abstract Response.ResponseBuilder entity(Object entity,
                              Annotation[] annotations)
        Set the response entity in the builder.

        Any Java type instance for a response entity, that is supported by the runtime can be passed. It is the callers responsibility to wrap the actual entity with GenericEntity if preservation of its generic type is required. Note that the entity can be also set as an input stream.

        A specific entity media type can be set using one of the type(...) methods.

        Parameters:
        entity - the request entity.
        annotations - annotations that will be passed to the MessageBodyWriter.
        Returns:
        updated response builder instance.
        Since:
        2.0
        See Also:
        entity(java.lang.Object),
type(javax.ws.rs.core.MediaType),
type(java.lang.String)

      • allow

        public abstract Response.ResponseBuilder allow(String... methods)
        Set the list of allowed methods for the resource. Any duplicate method names will be truncated to a single entry.
        Parameters:
        methods - the methods to be listed as allowed for the resource, if null any existing allowed method list will be removed.
        Returns:
        the updated response builder.
        Since:
        2.0

      • allow

        public abstract Response.ResponseBuilder allow(Set<String> methods)
        Set the list of allowed methods for the resource.
        Parameters:
        methods - the methods to be listed as allowed for the resource, if null any existing allowed method list will be removed.
        Returns:
        the updated response builder.
        Since:
        2.0

      • cacheControl

        public abstract Response.ResponseBuilder cacheControl(CacheControl cacheControl)
        Set the cache control data of the message.
        Parameters:
        cacheControl - the cache control directives, if null any existing cache control directives will be removed.
        Returns:
        the updated response builder.

      • encoding

        public abstract Response.ResponseBuilder encoding(String encoding)
        Set the message entity content encoding.
        Parameters:
        encoding - the content encoding of the message entity, if null any existing value for content encoding will be removed.
        Returns:
        the updated response builder.
        Since:
        2.0

      • header

        public abstract Response.ResponseBuilder header(String name,
                              Object value)
        Add an arbitrary header.
        Parameters:
        name - the name of the header
        value - the value of the header, the header will be serialized using a RuntimeDelegate.HeaderDelegate if one is available via RuntimeDelegate.createHeaderDelegate(java.lang.Class) for the class of value or using its toString method if a header delegate is not available. If value is null then all current headers of the same name will be removed.
        Returns:
        the updated response builder.

      • replaceAll

        public abstract Response.ResponseBuilder replaceAll(MultivaluedMap<String,Object> headers)
        Replaces all existing headers with the newly supplied headers.
        Parameters:
        headers - new headers to be set, if null all existing headers will be removed.
        Returns:
        the updated response builder.
        Since:
        2.0

      • language

        public abstract Response.ResponseBuilder language(String language)
        Set the message entity language.
        Parameters:
        language - the language of the message entity, if null any existing value for language will be removed.
        Returns:
        the updated response builder.

      • language

        public abstract Response.ResponseBuilder language(Locale language)
        Set the message entity language.
        Parameters:
        language - the language of the message entity, if null any existing value for type will be removed.
        Returns:
        the updated response builder.

      • type

        public abstract Response.ResponseBuilder type(MediaType type)
        Set the message entity media type.
        Parameters:
        type - the media type of the message entity. If null, any existing value for type will be removed.
        Returns:
        the updated response builder.

      • type

        public abstract Response.ResponseBuilder type(String type)
        Set the message entity media type.
        Parameters:
        type - the media type of the message entity. If null, any existing value for type will be removed.
        Returns:
        the updated response builder.

      • variant

        public abstract Response.ResponseBuilder variant(Variant variant)
        Set message entity representation metadata.

        Equivalent to setting the values of content type, content language, and content encoding separately using the values of the variant properties.

        Parameters:
        variant - metadata of the message entity, a null value is equivalent to a variant with all null properties.
        Returns:
        the updated response builder.
        Since:
        2.0
        See Also:
        encoding(java.lang.String),
language(java.util.Locale),
type(javax.ws.rs.core.MediaType)

      • contentLocation

        public abstract Response.ResponseBuilder contentLocation(URI location)
        Set the content location.
        Parameters:
        location - the content location. Relative or absolute URIs may be used for the value of content location. If null any existing value for content location will be removed.
        Returns:
        the updated response builder.

      • cookie

        public abstract Response.ResponseBuilder cookie(NewCookie... cookies)
        Add cookies to the response message.
        Parameters:
        cookies - new cookies that will accompany the response. A null value will remove all cookies, including those added via the header(java.lang.String, java.lang.Object) method.
        Returns:
        the updated response builder.

      • expires

        public abstract Response.ResponseBuilder expires(Date expires)
        Set the response expiration date.
        Parameters:
        expires - the expiration date, if null removes any existing expires value.
        Returns:
        the updated response builder.

      • lastModified

        public abstract Response.ResponseBuilder lastModified(Date lastModified)
        Set the response entity last modification date.
        Parameters:
        lastModified - the last modified date, if null any existing last modified value will be removed.
        Returns:
        the updated response builder.

      • location

        public abstract Response.ResponseBuilder location(URI location)
        Set the location.
        Parameters:
        location - the location. If a relative URI is supplied it will be converted into an absolute URI by resolving it relative to the base URI of the application (see UriInfo.getBaseUri()). If null any existing value for location will be removed.
        Returns:
        the updated response builder.

      • tag

        public abstract Response.ResponseBuilder tag(EntityTag tag)
        Set a response entity tag.
        Parameters:
        tag - the entity tag, if null any existing entity tag value will be removed.
        Returns:
        the updated response builder.

      • tag

        public abstract Response.ResponseBuilder tag(String tag)
        Set a strong response entity tag.

        This is a shortcut for tag(new EntityTag(value)).

        Parameters:
        tag - the string content of a strong entity tag. The JAX-RS runtime will quote the supplied value when creating the header. If null any existing entity tag value will be removed.
        Returns:
        the updated response builder.

      • variants

        public abstract Response.ResponseBuilder variants(Variant... variants)
        Add a Vary header that lists the available variants.
        Parameters:
        variants - a list of available representation variants, a null value will remove an existing value for Vary header.
        Returns:
        the updated response builder.
        Since:
        2.0

      • variants

        public abstract Response.ResponseBuilder variants(List<Variant> variants)
        Add a Vary header that lists the available variants.
        Parameters:
        variants - a list of available representation variants, a null value will remove an existing value for Vary header.
        Returns:
        the updated response builder.

      • links

        public abstract Response.ResponseBuilder links(Link... links)
        Add one or more link headers.
        Parameters:
        links - links to be added to the message as headers, a null value will remove any existing Link headers.
        Returns:
        the updated response builder.
        Since:
        2.0

      • link

        public abstract Response.ResponseBuilder link(URI uri,
                            String rel)
        Add a link header.
        Parameters:
        uri - underlying URI for link header.
        rel - value of "rel" parameter.
        Returns:
        the updated response builder.
        Since:
        2.0

      • link

        public abstract Response.ResponseBuilder link(String uri,
                            String rel)
        Add a link header.
        Parameters:
        uri - underlying URI for link header.
        rel - value of "rel" parameter.
        Returns:
        the updated response builder.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Response.Status (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.ws.rs.core

Enum Response.Status

  • java.lang.Object
    • java.lang.Enum<Response.Status>
      • javax.ws.rs.core.Response.Status
  • All Implemented Interfaces:
    Serializable, Comparable<Response.Status>, Response.StatusType
    Enclosing class:
    Response

    public static enum Response.Status
extends Enum<Response.Status>
implements Response.StatusType
    Commonly used status codes defined by HTTP, see HTTP/1.1 documentation for the complete list. Additional status codes can be added by applications by creating an implementation of Response.StatusType.

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  Response.Status.Family
      An enumeration representing the class of status code.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ACCEPTED
      202 Accepted, see HTTP/1.1 documentation.
      BAD_GATEWAY
      502 Bad Gateway, see HTTP/1.1 documentation.
      BAD_REQUEST
      400 Bad Request, see HTTP/1.1 documentation.
      CONFLICT
      409 Conflict, see HTTP/1.1 documentation.
      CREATED
      201 Created, see HTTP/1.1 documentation.
      EXPECTATION_FAILED
      417 Expectation Failed, see HTTP/1.1 documentation.
      FORBIDDEN
      403 Forbidden, see HTTP/1.1 documentation.
      FOUND
      302 Found, see HTTP/1.1 documentation.
      GATEWAY_TIMEOUT
      504 Gateway Timeout, see HTTP/1.1 documentation.
      GONE
      410 Gone, see HTTP/1.1 documentation.
      HTTP_VERSION_NOT_SUPPORTED
      505 HTTP Version Not Supported, see HTTP/1.1 documentation.
      INTERNAL_SERVER_ERROR
      500 Internal Server Error, see HTTP/1.1 documentation.
      LENGTH_REQUIRED
      411 Length Required, see HTTP/1.1 documentation.
      METHOD_NOT_ALLOWED
      405 Method Not Allowed, see HTTP/1.1 documentation.
      MOVED_PERMANENTLY
      301 Moved Permanently, see HTTP/1.1 documentation.
      NO_CONTENT
      204 No Content, see HTTP/1.1 documentation.
      NOT_ACCEPTABLE
      406 Not Acceptable, see HTTP/1.1 documentation.
      NOT_FOUND
      404 Not Found, see HTTP/1.1 documentation.
      NOT_IMPLEMENTED
      501 Not Implemented, see HTTP/1.1 documentation.
      NOT_MODIFIED
      304 Not Modified, see HTTP/1.1 documentation.
      OK
      200 OK, see HTTP/1.1 documentation.
      PARTIAL_CONTENT
      206 Reset Content, see HTTP/1.1 documentation.
      PAYMENT_REQUIRED
      402 Payment Required, see HTTP/1.1 documentation.
      PRECONDITION_FAILED
      412 Precondition Failed, see HTTP/1.1 documentation.
      PROXY_AUTHENTICATION_REQUIRED
      407 Proxy Authentication Required, see HTTP/1.1 documentation.
      REQUEST_ENTITY_TOO_LARGE
      413 Request Entity Too Large, see HTTP/1.1 documentation.
      REQUEST_TIMEOUT
      408 Request Timeout, see HTTP/1.1 documentation.
      REQUEST_URI_TOO_LONG
      414 Request-URI Too Long, see HTTP/1.1 documentation.
      REQUESTED_RANGE_NOT_SATISFIABLE
      416 Requested Range Not Satisfiable, see HTTP/1.1 documentation.
      RESET_CONTENT
      205 Reset Content, see HTTP/1.1 documentation.
      SEE_OTHER
      303 See Other, see HTTP/1.1 documentation.
      SERVICE_UNAVAILABLE
      503 Service Unavailable, see HTTP/1.1 documentation.
      TEMPORARY_REDIRECT
      307 Temporary Redirect, see HTTP/1.1 documentation.
      UNAUTHORIZED
      401 Unauthorized, see HTTP/1.1 documentation.
      UNSUPPORTED_MEDIA_TYPE
      415 Unsupported Media Type, see HTTP/1.1 documentation.
      USE_PROXY
      305 Use Proxy, see HTTP/1.1 documentation.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Response.Status fromStatusCode(int statusCode)
      Convert a numerical status code into the corresponding Status.
      Response.Status.Family getFamily()
      Get the class of status code.
      String getReasonPhrase()
      Get the reason phrase.
      int getStatusCode()
      Get the associated status code.
      String toString()
      Get the reason phrase.
      static Response.Status valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Response.Status[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • OK

        public static final Response.Status OK
        200 OK, see HTTP/1.1 documentation.

      • CREATED

        public static final Response.Status CREATED
        201 Created, see HTTP/1.1 documentation.

      • ACCEPTED

        public static final Response.Status ACCEPTED
        202 Accepted, see HTTP/1.1 documentation.

      • NO_CONTENT

        public static final Response.Status NO_CONTENT
        204 No Content, see HTTP/1.1 documentation.

      • RESET_CONTENT

        public static final Response.Status RESET_CONTENT
        205 Reset Content, see HTTP/1.1 documentation.
        Since:
        2.0

      • PARTIAL_CONTENT

        public static final Response.Status PARTIAL_CONTENT
        206 Reset Content, see HTTP/1.1 documentation.
        Since:
        2.0

      • MOVED_PERMANENTLY

        public static final Response.Status MOVED_PERMANENTLY
        301 Moved Permanently, see HTTP/1.1 documentation.

      • FOUND

        public static final Response.Status FOUND
        302 Found, see HTTP/1.1 documentation.
        Since:
        2.0

      • SEE_OTHER

        public static final Response.Status SEE_OTHER
        303 See Other, see HTTP/1.1 documentation.

      • NOT_MODIFIED

        public static final Response.Status NOT_MODIFIED
        304 Not Modified, see HTTP/1.1 documentation.

      • USE_PROXY

        public static final Response.Status USE_PROXY
        305 Use Proxy, see HTTP/1.1 documentation.
        Since:
        2.0

      • TEMPORARY_REDIRECT

        public static final Response.Status TEMPORARY_REDIRECT
        307 Temporary Redirect, see HTTP/1.1 documentation.

      • BAD_REQUEST

        public static final Response.Status BAD_REQUEST
        400 Bad Request, see HTTP/1.1 documentation.

      • UNAUTHORIZED

        public static final Response.Status UNAUTHORIZED
        401 Unauthorized, see HTTP/1.1 documentation.

      • PAYMENT_REQUIRED

        public static final Response.Status PAYMENT_REQUIRED
        402 Payment Required, see HTTP/1.1 documentation.
        Since:
        2.0

      • FORBIDDEN

        public static final Response.Status FORBIDDEN
        403 Forbidden, see HTTP/1.1 documentation.

      • NOT_FOUND

        public static final Response.Status NOT_FOUND
        404 Not Found, see HTTP/1.1 documentation.

      • METHOD_NOT_ALLOWED

        public static final Response.Status METHOD_NOT_ALLOWED
        405 Method Not Allowed, see HTTP/1.1 documentation.
        Since:
        2.0

      • NOT_ACCEPTABLE

        public static final Response.Status NOT_ACCEPTABLE
        406 Not Acceptable, see HTTP/1.1 documentation.

      • PROXY_AUTHENTICATION_REQUIRED

        public static final Response.Status PROXY_AUTHENTICATION_REQUIRED
        407 Proxy Authentication Required, see HTTP/1.1 documentation.
        Since:
        2.0

      • REQUEST_TIMEOUT

        public static final Response.Status REQUEST_TIMEOUT
        408 Request Timeout, see HTTP/1.1 documentation.
        Since:
        2.0

      • CONFLICT

        public static final Response.Status CONFLICT
        409 Conflict, see HTTP/1.1 documentation.

      • GONE

        public static final Response.Status GONE
        410 Gone, see HTTP/1.1 documentation.

      • LENGTH_REQUIRED

        public static final Response.Status LENGTH_REQUIRED
        411 Length Required, see HTTP/1.1 documentation.
        Since:
        2.0

      • PRECONDITION_FAILED

        public static final Response.Status PRECONDITION_FAILED
        412 Precondition Failed, see HTTP/1.1 documentation.

      • REQUEST_ENTITY_TOO_LARGE

        public static final Response.Status REQUEST_ENTITY_TOO_LARGE
        413 Request Entity Too Large, see HTTP/1.1 documentation.
        Since:
        2.0

      • REQUEST_URI_TOO_LONG

        public static final Response.Status REQUEST_URI_TOO_LONG
        414 Request-URI Too Long, see HTTP/1.1 documentation.
        Since:
        2.0

      • UNSUPPORTED_MEDIA_TYPE

        public static final Response.Status UNSUPPORTED_MEDIA_TYPE
        415 Unsupported Media Type, see HTTP/1.1 documentation.

      • REQUESTED_RANGE_NOT_SATISFIABLE

        public static final Response.Status REQUESTED_RANGE_NOT_SATISFIABLE
        416 Requested Range Not Satisfiable, see HTTP/1.1 documentation.
        Since:
        2.0

      • EXPECTATION_FAILED

        public static final Response.Status EXPECTATION_FAILED
        417 Expectation Failed, see HTTP/1.1 documentation.
        Since:
        2.0

      • INTERNAL_SERVER_ERROR

        public static final Response.Status INTERNAL_SERVER_ERROR
        500 Internal Server Error, see HTTP/1.1 documentation.

      • NOT_IMPLEMENTED

        public static final Response.Status NOT_IMPLEMENTED
        501 Not Implemented, see HTTP/1.1 documentation.
        Since:
        2.0

      • BAD_GATEWAY

        public static final Response.Status BAD_GATEWAY
        502 Bad Gateway, see HTTP/1.1 documentation.
        Since:
        2.0

      • SERVICE_UNAVAILABLE

        public static final Response.Status SERVICE_UNAVAILABLE
        503 Service Unavailable, see HTTP/1.1 documentation.

      • GATEWAY_TIMEOUT

        public static final Response.Status GATEWAY_TIMEOUT
        504 Gateway Timeout, see HTTP/1.1 documentation.
        Since:
        2.0

      • HTTP_VERSION_NOT_SUPPORTED

        public static final Response.Status HTTP_VERSION_NOT_SUPPORTED
        505 HTTP Version Not Supported, see HTTP/1.1 documentation.
        Since:
        2.0

    • Method Detail

      • values

        public static Response.Status[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Response.Status c : Response.Status.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Response.Status valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • getFamily

        public Response.Status.Family getFamily()
        Get the class of status code.
        Specified by:
        getFamily in interface Response.StatusType
        Returns:
        the class of status code.

      • getStatusCode

        public int getStatusCode()
        Get the associated status code.
        Specified by:
        getStatusCode in interface Response.StatusType
        Returns:
        the status code.

      • getReasonPhrase

        public String getReasonPhrase()
        Get the reason phrase.
        Specified by:
        getReasonPhrase in interface Response.StatusType
        Returns:
        the reason phrase.

      • toString

        public String toString()
        Get the reason phrase.
        Overrides:
        toString in class Enum<Response.Status>
        Returns:
        the reason phrase.

      • fromStatusCode

        public static Response.Status fromStatusCode(int statusCode)
        Convert a numerical status code into the corresponding Status.
        Parameters:
        statusCode - the numerical status code.
        Returns:
        the matching Status or null is no matching Status is defined.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Response.Status.Family (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.ws.rs.core

Enum Response.Status.Family

  • java.lang.Object
    • java.lang.Enum<Response.Status.Family>
      • javax.ws.rs.core.Response.Status.Family
  • All Implemented Interfaces:
    Serializable, Comparable<Response.Status.Family>
    Enclosing class:
    Response.Status

    public static enum Response.Status.Family
extends Enum<Response.Status.Family>
    An enumeration representing the class of status code. Family is used here since class is overloaded in Java.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      CLIENT_ERROR
      4xx HTTP status codes.
      INFORMATIONAL
      1xx HTTP status codes.
      OTHER
      Other, unrecognized HTTP status codes.
      REDIRECTION
      3xx HTTP status codes.
      SERVER_ERROR
      5xx HTTP status codes.
      SUCCESSFUL
      2xx HTTP status codes.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Response.Status.Family familyOf(int statusCode)
      Get the response status family for the status code.
      static Response.Status.Family valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Response.Status.Family[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • INFORMATIONAL

        public static final Response.Status.Family INFORMATIONAL
        1xx HTTP status codes.

      • SUCCESSFUL

        public static final Response.Status.Family SUCCESSFUL
        2xx HTTP status codes.

      • REDIRECTION

        public static final Response.Status.Family REDIRECTION
        3xx HTTP status codes.

      • CLIENT_ERROR

        public static final Response.Status.Family CLIENT_ERROR
        4xx HTTP status codes.

      • SERVER_ERROR

        public static final Response.Status.Family SERVER_ERROR
        5xx HTTP status codes.

      • OTHER

        public static final Response.Status.Family OTHER
        Other, unrecognized HTTP status codes.

    • Method Detail

      • values

        public static Response.Status.Family[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Response.Status.Family c : Response.Status.Family.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Response.Status.Family valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • familyOf

        public static Response.Status.Family familyOf(int statusCode)
        Get the response status family for the status code.
        Parameters:
        statusCode - response status code to get the family for.
        Returns:
        family of the response status code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


Response.StatusType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface Response.StatusType

  • All Known Implementing Classes:
    Response.Status
    Enclosing class:
    Response

    public static interface Response.StatusType
    Base interface for statuses used in responses.
    Since:
    1.1

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Response.Status.Family getFamily()
      Get the class of status code.
      String getReasonPhrase()
      Get the reason phrase.
      int getStatusCode()
      Get the associated status code.

    • Method Detail

      • getStatusCode

        int getStatusCode()
        Get the associated status code.
        Returns:
        the status code.

      • getFamily

        Response.Status.Family getFamily()
        Get the class of status code.
        Returns:
        the class of status code.

      • getReasonPhrase

        String getReasonPhrase()
        Get the reason phrase.
        Returns:
        the reason phrase.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SecurityContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface SecurityContext

  • public interface SecurityContext
    An injectable interface that provides access to security related information.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Context

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String BASIC_AUTH
      String identifier for Basic authentication.
      static String CLIENT_CERT_AUTH
      String identifier for Client Certificate authentication.
      static String DIGEST_AUTH
      String identifier for Digest authentication.
      static String FORM_AUTH
      String identifier for Form authentication.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAuthenticationScheme()
      Returns the string value of the authentication scheme used to protect the resource.
      Principal getUserPrincipal()
      Returns a java.security.Principal object containing the name of the current authenticated user.
      boolean isSecure()
      Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.
      boolean isUserInRole(String role)
      Returns a boolean indicating whether the authenticated user is included in the specified logical "role".

    • Field Detail

      • BASIC_AUTH

        static final String BASIC_AUTH
        String identifier for Basic authentication. Value "BASIC"
        See Also:
        Constant Field Values

      • CLIENT_CERT_AUTH

        static final String CLIENT_CERT_AUTH
        String identifier for Client Certificate authentication. Value "CLIENT_CERT"
        See Also:
        Constant Field Values

      • DIGEST_AUTH

        static final String DIGEST_AUTH
        String identifier for Digest authentication. Value "DIGEST"
        See Also:
        Constant Field Values

      • FORM_AUTH

        static final String FORM_AUTH
        String identifier for Form authentication. Value "FORM"
        See Also:
        Constant Field Values

    • Method Detail

      • getUserPrincipal

        Principal getUserPrincipal()
        Returns a java.security.Principal object containing the name of the current authenticated user. If the user has not been authenticated, the method returns null.
        Returns:
        a java.security.Principal containing the name of the user making this request; null if the user has not been authenticated
        Throws:
        IllegalStateException - if called outside the scope of a request

      • isUserInRole

        boolean isUserInRole(String role)
        Returns a boolean indicating whether the authenticated user is included in the specified logical "role". If the user has not been authenticated, the method returns false.
        Parameters:
        role - a String specifying the name of the role
        Returns:
        a boolean indicating whether the user making the request belongs to a given role; false if the user has not been authenticated
        Throws:
        IllegalStateException - if called outside the scope of a request

      • isSecure

        boolean isSecure()
        Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.
        Returns:
        true if the request was made using a secure channel, false otherwise
        Throws:
        IllegalStateException - if called outside the scope of a request

      • getAuthenticationScheme

        String getAuthenticationScheme()
        Returns the string value of the authentication scheme used to protect the resource. If the resource is not authenticated, null is returned. Values are the same as the CGI variable AUTH_TYPE
        Returns:
        one of the static members BASIC_AUTH, FORM_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH (suitable for == comparison) or the container-specific string indicating the authentication scheme, or null if the request was not authenticated.
        Throws:
        IllegalStateException - if called outside the scope of a request
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StreamingOutput (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface StreamingOutput

  • public interface StreamingOutput
    A type that may be used as a resource method return value or as the entity in a Response when the application wishes to stream the output. This is a lightweight alternative to a MessageBodyWriter.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    MessageBodyWriter, Response

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void write(OutputStream output)
      Called to write the message body.

    • Method Detail

      • write

        void write(OutputStream output)
           throws IOException,
                  WebApplicationException
        Called to write the message body.
        Parameters:
        output - the OutputStream to write to.
        Throws:
        IOException - if an IO error is encountered
        WebApplicationException - if a specific HTTP error response needs to be produced. Only effective if thrown prior to any bytes being written to output.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UriBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class UriBuilder

  • java.lang.Object
    • javax.ws.rs.core.UriBuilder

  • public abstract class UriBuilder
extends Object
    URI template-aware utility class for building URIs from their components. See Path.value() for an explanation of URI templates.

    Builder methods perform contextual encoding of characters not permitted in the corresponding URI component following the rules of the application/x-www-form-urlencoded media type for query parameters and RFC 3986 for all other components. Note that only characters not permitted in a particular component are subject to encoding so, e.g., a path supplied to one of the path methods may contain matrix parameters or multiple path segments since the separators are legal characters and will not be encoded. Percent encoded values are also recognized where allowed and will not be double encoded.

    URI templates are allowed in most components of a URI but their value is restricted to a particular component. E.g.

    UriBuilder.fromPath("{arg1}").build("foo#bar");
    would result in encoding of the '#' such that the resulting URI is "foo%23bar". To create a URI "foo#bar" use
    UriBuilder.fromPath("{arg1}").fragment("{arg2}").build("foo", "bar")
    instead. URI template names and delimiters are never encoded but their values are encoded when a URI is built. Template parameter regular expressions are ignored when building a URI, i.e. no validation is performed.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    URI, Path

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected UriBuilder()
      Protected constructor, use one of the static fromXxx(...) methods to obtain an instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract URI build(Object... values)
      Build a URI, using the supplied values in order to replace any URI template parameters.
      abstract URI build(Object[] values, boolean encodeSlashInPath)
      Build a URI, using the supplied values in order to replace any URI template parameters.
      abstract URI buildFromEncoded(Object... values)
      Build a URI.
      abstract URI buildFromEncodedMap(Map<String,?> values)
      Build a URI.
      abstract URI buildFromMap(Map<String,?> values)
      Build a URI.
      abstract URI buildFromMap(Map<String,?> values, boolean encodeSlashInPath)
      Build a URI.
      abstract UriBuilder clone()
      Create a copy of the UriBuilder preserving its state.
      abstract UriBuilder fragment(String fragment)
      Set the URI fragment.
      static UriBuilder fromLink(Link link)
      Create a new instance initialized from a Link.
      static UriBuilder fromMethod(Class<?> resource, String method)
      Create a new instance representing a relative URI initialized from a Path-annotated method.
      static UriBuilder fromPath(String path)
      Create a new instance representing a relative URI initialized from a URI path.
      static UriBuilder fromResource(Class<?> resource)
      Create a new instance representing a relative URI initialized from a root resource class.
      static UriBuilder fromUri(String uriTemplate)
      Create a new instance initialized from an existing URI.
      static UriBuilder fromUri(URI uri)
      Create a new instance initialized from an existing URI.
      abstract UriBuilder host(String host)
      Set the URI host.
      abstract UriBuilder matrixParam(String name, Object... values)
      Append a matrix parameter to the existing set of matrix parameters of the current final segment of the URI path.
      protected static UriBuilder newInstance()
      Creates a new instance of UriBuilder.
      abstract UriBuilder path(Class resource)
      Append the path from a Path-annotated class to the existing path.
      abstract UriBuilder path(Class resource, String method)
      Append the path from a Path-annotated method to the existing path.
      abstract UriBuilder path(Method method)
      Append the path from a Path-annotated method to the existing path.
      abstract UriBuilder path(String path)
      Append path to the existing path.
      abstract UriBuilder port(int port)
      Set the URI port.
      abstract UriBuilder queryParam(String name, Object... values)
      Append a query parameter to the existing set of query parameters.
      abstract UriBuilder replaceMatrix(String matrix)
      Set the matrix parameters of the current final segment of the current URI path.
      abstract UriBuilder replaceMatrixParam(String name, Object... values)
      Replace the existing value(s) of a matrix parameter on the current final segment of the URI path.
      abstract UriBuilder replacePath(String path)
      Set the URI path.
      abstract UriBuilder replaceQuery(String query)
      Set the URI query string.
      abstract UriBuilder replaceQueryParam(String name, Object... values)
      Replace the existing value(s) of a query parameter.
      abstract UriBuilder resolveTemplate(String name, Object value)
      Resolve a URI template with a given name in this UriBuilder instance using a supplied value.
      abstract UriBuilder resolveTemplate(String name, Object value, boolean encodeSlashInPath)
      Resolve a URI template with a given name in this UriBuilder instance using a supplied value.
      abstract UriBuilder resolveTemplateFromEncoded(String name, Object value)
      Resolve a URI template with a given name in this UriBuilder instance using a supplied encoded value.
      abstract UriBuilder resolveTemplates(Map<String,Object> templateValues)
      Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs.
      abstract UriBuilder resolveTemplates(Map<String,Object> templateValues, boolean encodeSlashInPath)
      Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs.
      abstract UriBuilder resolveTemplatesFromEncoded(Map<String,Object> templateValues)
      Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs.
      abstract UriBuilder scheme(String scheme)
      Set the URI scheme.
      abstract UriBuilder schemeSpecificPart(String ssp)
      Set the URI scheme-specific-part (see URI).
      abstract UriBuilder segment(String... segments)
      Append path segments to the existing path.
      abstract String toTemplate()
      Get the URI template string represented by this URI builder.
      abstract UriBuilder uri(String uriTemplate)
      Parses the uriTemplate string and copies the parsed components of the supplied URI to the UriBuilder replacing any existing values for those components.
      abstract UriBuilder uri(URI uri)
      Copies the non-null components of the supplied URI to the UriBuilder replacing any existing values for those components.
      abstract UriBuilder userInfo(String ui)
      Set the URI user-info.

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • UriBuilder

        protected UriBuilder()
        Protected constructor, use one of the static fromXxx(...) methods to obtain an instance.

    • Method Detail

      • newInstance

        protected static UriBuilder newInstance()
        Creates a new instance of UriBuilder.
        Returns:
        a new instance of UriBuilder.

      • fromUri

        public static UriBuilder fromUri(URI uri)
        Create a new instance initialized from an existing URI.
        Parameters:
        uri - a URI that will be used to initialize the UriBuilder.
        Returns:
        a new UriBuilder.
        Throws:
        IllegalArgumentException - if uri is null.

      • fromUri

        public static UriBuilder fromUri(String uriTemplate)
        Create a new instance initialized from an existing URI.
        Parameters:
        uriTemplate - a URI template that will be used to initialize the UriBuilder, may contain URI parameters.
        Returns:
        a new UriBuilder.
        Throws:
        IllegalArgumentException - if uriTemplate is not a valid URI template or is null.

      • fromLink

        public static UriBuilder fromLink(Link link)
        Create a new instance initialized from a Link.
        Parameters:
        link - a Link that will be used to initialize the UriBuilder, only its URI is used.
        Returns:
        a new UriBuilder
        Throws:
        IllegalArgumentException - if link is null
        Since:
        2.0

      • fromPath

        public static UriBuilder fromPath(String path)
                           throws IllegalArgumentException
        Create a new instance representing a relative URI initialized from a URI path.
        Parameters:
        path - a URI path that will be used to initialize the UriBuilder, may contain URI template parameters.
        Returns:
        a new UriBuilder.
        Throws:
        IllegalArgumentException - if path is null.

      • fromResource

        public static UriBuilder fromResource(Class<?> resource)
        Create a new instance representing a relative URI initialized from a root resource class.
        Parameters:
        resource - a root resource whose Path value will be used to initialize the UriBuilder.
        Returns:
        a new UriBuilder.
        Throws:
        IllegalArgumentException - if resource is not annotated with Path or resource is null.

      • fromMethod

        public static UriBuilder fromMethod(Class<?> resource,
                    String method)
        Create a new instance representing a relative URI initialized from a Path-annotated method. This method can only be used in cases where there is a single method with the specified name that is annotated with Path.
        Parameters:
        resource - the resource containing the method.
        method - the name of the method whose Path value will be used to obtain the path to append.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if resource or method is null, or there is more than or less than one variant of the method annotated with Path.
        Since:
        2.0

      • clone

        public abstract UriBuilder clone()
        Create a copy of the UriBuilder preserving its state. This is a more efficient means of creating a copy than constructing a new UriBuilder from a URI returned by the build(Object...) method.
        Overrides:
        clone in class Object
        Returns:
        a copy of the UriBuilder.

      • uri

        public abstract UriBuilder uri(URI uri)
        Copies the non-null components of the supplied URI to the UriBuilder replacing any existing values for those components.
        Parameters:
        uri - the URI to copy components from.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if the uri parameter is null.

      • uri

        public abstract UriBuilder uri(String uriTemplate)
        Parses the uriTemplate string and copies the parsed components of the supplied URI to the UriBuilder replacing any existing values for those components.
        Parameters:
        uriTemplate - a URI template that will be used to initialize the UriBuilder, may contain URI parameters.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if uriTemplate is not a valid URI template or is null.
        Since:
        2.0

      • scheme

        public abstract UriBuilder scheme(String scheme)
        Set the URI scheme.
        Parameters:
        scheme - the URI scheme, may contain URI template parameters. A null value will unset the URI scheme, but will not unset the any scheme-specific-part components.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if scheme is invalid.

      • schemeSpecificPart

        public abstract UriBuilder schemeSpecificPart(String ssp)
        Set the URI scheme-specific-part (see URI). This method will overwrite any existing values for authority, user-info, host, port and path.
        Parameters:
        ssp - the URI scheme-specific-part, may contain URI template parameters.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if ssp cannot be parsed or is null.

      • userInfo

        public abstract UriBuilder userInfo(String ui)
        Set the URI user-info.
        Parameters:
        ui - the URI user-info, may contain URI template parameters. A null value will unset userInfo component of the URI.
        Returns:
        the updated UriBuilder.

      • host

        public abstract UriBuilder host(String host)
        Set the URI host.
        Parameters:
        host - the URI host, may contain URI template parameters. A null value will unset the host component of the URI, but will not unset other authority component parts (user info or port).
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if host is invalid.

      • port

        public abstract UriBuilder port(int port)
        Set the URI port.
        Parameters:
        port - the URI port, a value of -1 will unset an explicit port.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if port is invalid.

      • replacePath

        public abstract UriBuilder replacePath(String path)
        Set the URI path. This method will overwrite any existing path and associated matrix parameters. Existing '/' characters are preserved thus a single value can represent multiple URI path segments.
        Parameters:
        path - the path, may contain URI template parameters. A null value will unset the path component of the URI.
        Returns:
        the updated UriBuilder.

      • path

        public abstract UriBuilder path(String path)
        Append path to the existing path. When constructing the final path, a '/' separator will be inserted between the existing path and the supplied path if necessary. Existing '/' characters are preserved thus a single value can represent multiple URI path segments.
        Parameters:
        path - the path, may contain URI template parameters.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if path is null.

      • path

        public abstract UriBuilder path(Class resource)
        Append the path from a Path-annotated class to the existing path. When constructing the final path, a '/' separator will be inserted between the existing path and the supplied path if necessary.
        Parameters:
        resource - a resource whose Path value will be used to obtain the path to append.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if resource is null, or if resource is not annotated with Path.

      • path

        public abstract UriBuilder path(Class resource,
              String method)
        Append the path from a Path-annotated method to the existing path. When constructing the final path, a '/' separator will be inserted between the existing path and the supplied path if necessary. This method is a convenience shortcut to path(Method), it can only be used in cases where there is a single method with the specified name that is annotated with Path.
        Parameters:
        resource - the resource containing the method.
        method - the name of the method whose Path value will be used to obtain the path to append.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if resource or method is null, or there is more than or less than one variant of the method annotated with Path.

      • path

        public abstract UriBuilder path(Method method)
        Append the path from a Path-annotated method to the existing path. When constructing the final path, a '/' separator will be inserted between the existing path and the supplied path if necessary.
        Parameters:
        method - a method whose Path value will be used to obtain the path to append to the existing path.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if method is null or is not annotated with a Path.

      • segment

        public abstract UriBuilder segment(String... segments)
        Append path segments to the existing path. When constructing the final path, a '/' separator will be inserted between the existing path and the first path segment if necessary and each supplied segment will also be separated by '/'. Existing '/' characters are encoded thus a single value can only represent a single URI path segment.
        Parameters:
        segments - the path segment values, each may contain URI template parameters.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if segments or any element of segments is null.

      • replaceMatrix

        public abstract UriBuilder replaceMatrix(String matrix)
        Set the matrix parameters of the current final segment of the current URI path. This method will overwrite any existing matrix parameters on the current final segment of the current URI path. Note that the matrix parameters are tied to a particular path segment; subsequent addition of path segments will not affect their position in the URI path.
        Parameters:
        matrix - the matrix parameters, may contain URI template parameters. A null value will remove all matrix parameters of the current final segment of the current URI path.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if matrix cannot be parsed.
        See Also:
        Matrix URIs

      • matrixParam

        public abstract UriBuilder matrixParam(String name,
                     Object... values)
        Append a matrix parameter to the existing set of matrix parameters of the current final segment of the URI path. If multiple values are supplied the parameter will be added once per value. Note that the matrix parameters are tied to a particular path segment; subsequent addition of path segments will not affect their position in the URI path.
        Parameters:
        name - the matrix parameter name, may contain URI template parameters.
        values - the matrix parameter value(s), each object will be converted. to a String using its toString() method. Stringified values may contain URI template parameters.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if name or values is null.
        See Also:
        Matrix URIs

      • replaceMatrixParam

        public abstract UriBuilder replaceMatrixParam(String name,
                            Object... values)
        Replace the existing value(s) of a matrix parameter on the current final segment of the URI path. If multiple values are supplied the parameter will be added once per value. Note that the matrix parameters are tied to a particular path segment; subsequent addition of path segments will not affect their position in the URI path.
        Parameters:
        name - the matrix parameter name, may contain URI template parameters.
        values - the matrix parameter value(s), each object will be converted. to a String using its toString() method. Stringified values may contain URI template parameters. If values is empty or null then all current values of the parameter are removed.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if name is null.
        See Also:
        Matrix URIs

      • replaceQuery

        public abstract UriBuilder replaceQuery(String query)
        Set the URI query string. This method will overwrite any existing query parameters.
        Parameters:
        query - the URI query string, may contain URI template parameters. A null value will remove all query parameters.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if query cannot be parsed.

      • queryParam

        public abstract UriBuilder queryParam(String name,
                    Object... values)
        Append a query parameter to the existing set of query parameters. If multiple values are supplied the parameter will be added once per value.
        Parameters:
        name - the query parameter name, may contain URI template parameters.
        values - the query parameter value(s), each object will be converted to a String using its toString() method. Stringified values may contain URI template parameters.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if name or values is null.

      • replaceQueryParam

        public abstract UriBuilder replaceQueryParam(String name,
                           Object... values)
        Replace the existing value(s) of a query parameter. If multiple values are supplied the parameter will be added once per value.
        Parameters:
        name - the query parameter name, may contain URI template parameters.
        values - the query parameter value(s), each object will be converted to a String using its toString() method. Stringified values may contain URI template parameters. If values is empty or null then all current values of the parameter are removed.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if name is null.

      • fragment

        public abstract UriBuilder fragment(String fragment)
        Set the URI fragment.
        Parameters:
        fragment - the URI fragment, may contain URI template parameters. A null value will remove any existing fragment.
        Returns:
        the updated UriBuilder.

      • resolveTemplate

        public abstract UriBuilder resolveTemplate(String name,
                         Object value)
        Resolve a URI template with a given name in this UriBuilder instance using a supplied value. In case a null template name or value is entered a IllegalArgumentException is thrown.
        Parameters:
        name - name of the URI template.
        value - value to be used to resolve the template.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if the resolved template name or value is null.
        Since:
        2.0

      • resolveTemplate

        public abstract UriBuilder resolveTemplate(String name,
                         Object value,
                         boolean encodeSlashInPath)
        Resolve a URI template with a given name in this UriBuilder instance using a supplied value. In case a null template name or value is entered a IllegalArgumentException is thrown.
        Parameters:
        name - name of the URI template.
        value - value to be used to resolve the template.
        encodeSlashInPath - if true, the slash ('/') characters in template values will be encoded if the template is placed in the URI path component, otherwise the slash characters will not be encoded in path templates.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if the resolved template name or value is null.
        Since:
        2.0

      • resolveTemplateFromEncoded

        public abstract UriBuilder resolveTemplateFromEncoded(String name,
                                    Object value)
        Resolve a URI template with a given name in this UriBuilder instance using a supplied encoded value. A template with a matching name will be replaced by the supplied value. Value is converted to String using its toString() method and is then encoded to match the rules of the URI component to which they pertain. All % characters in the stringified values that are not followed by two hexadecimal numbers will be encoded. In case a null template name or encoded value is entered a IllegalArgumentException is thrown.
        Parameters:
        name - name of the URI template.
        value - encoded value to be used to resolve the template.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if the resolved template name or encoded value is null.
        Since:
        2.0

      • resolveTemplates

        public abstract UriBuilder resolveTemplates(Map<String,Object> templateValues)
        Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs. A call to the method with an empty parameter map is ignored.
        Parameters:
        templateValues - a map of URI template names and their values.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if the name-value map or any of the names or values in the map is null.
        Since:
        2.0

      • resolveTemplates

        public abstract UriBuilder resolveTemplates(Map<String,Object> templateValues,
                          boolean encodeSlashInPath)
                                     throws IllegalArgumentException
        Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs. A call to the method with an empty parameter map is ignored.
        Parameters:
        templateValues - a map of URI template names and their values.
        encodeSlashInPath - if true, the slash ('/') characters in template values will be encoded if the template is placed in the URI path component, otherwise the slash characters will not be encoded in path templates.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if the name-value map or any of the names or values in the map is null.
        Since:
        2.0

      • resolveTemplatesFromEncoded

        public abstract UriBuilder resolveTemplatesFromEncoded(Map<String,Object> templateValues)
        Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs. All templates with their name matching one of the keys in the supplied map will be replaced by the value in the supplied map. Values are converted to String using their toString() method and are then encoded to match the rules of the URI component to which they pertain. All % characters in the stringified values that are not followed by two hexadecimal numbers will be encoded. A call to the method with an empty parameter map is ignored.
        Parameters:
        templateValues - a map of URI template names and their values.
        Returns:
        the updated UriBuilder.
        Throws:
        IllegalArgumentException - if the name-value map or any of the names or values in the map is null.
        Since:
        2.0

      • buildFromMap

        public abstract URI buildFromMap(Map<String,?> values)
        Build a URI. Any URI template parameters will be replaced by the value in the supplied map. Values are converted to String using their toString() method and are then encoded to match the rules of the URI component to which they pertain. All '%' characters in the stringified values will be encoded. The state of the builder is unaffected; this method may be called multiple times on the same builder instance.

        NOTE: By default all '/' characters in the stringified values will be encoded in path templates, i.e. the result is identical to invoking buildFromMap(valueMap, true). To override this behavior use buildFromMap(valueMap, false) instead.

        Parameters:
        values - a map of URI template parameter names and values.
        Returns:
        the URI built from the UriBuilder.
        Throws:
        IllegalArgumentException - if there are any URI template parameters without a supplied value, or if a template parameter value is null.
        UriBuilderException - if a URI cannot be constructed based on the current state of the builder.
        See Also:
        buildFromMap(java.util.Map, boolean), buildFromEncodedMap(java.util.Map)

      • buildFromMap

        public abstract URI buildFromMap(Map<String,?> values,
               boolean encodeSlashInPath)
                          throws IllegalArgumentException,
                                 UriBuilderException
        Build a URI. Any URI template parameters will be replaced by the value in the supplied map. Values are converted to String using their toString() method and are then encoded to match the rules of the URI component to which they pertain. All '%' characters in the stringified values will be encoded. The state of the builder is unaffected; this method may be called multiple times on the same builder instance.

        The encodeSlashInPath parameter may be used to override the default encoding of '/' characters in the stringified template values in cases when the template is part of the URI path component when using the buildFromMap(java.util.Map) method. If the encodeSlashInPath parameter is set to true (default), the slash ('/') characters in parameter values will be encoded if the template is placed in the URI path component. If set to false the default encoding behavior is overridden an slash characters in template values will not be encoded when used to substitute path templates.

        Parameters:
        values - a map of URI template parameter names and values.
        encodeSlashInPath - if true, the slash ('/') characters in parameter values will be encoded if the template is placed in the URI path component, otherwise the slash characters will not be encoded in path templates.
        Returns:
        the URI built from the UriBuilder.
        Throws:
        IllegalArgumentException - if there are any URI template parameters without a supplied value, or if a template parameter value is null.
        UriBuilderException - if a URI cannot be constructed based on the current state of the builder.
        See Also:
        buildFromMap(java.util.Map), buildFromEncodedMap(java.util.Map)

      • buildFromEncodedMap

        public abstract URI buildFromEncodedMap(Map<String,?> values)
                                 throws IllegalArgumentException,
                                        UriBuilderException
        Build a URI. Any URI template parameters will be replaced by the value in the supplied map. Values are converted to String using their toString() method and are then encoded to match the rules of the URI component to which they pertain. All % characters in the stringified values that are not followed by two hexadecimal numbers will be encoded. The state of the builder is unaffected; this method may be called multiple times on the same builder instance.
        Parameters:
        values - a map of URI template parameter names and values.
        Returns:
        the URI built from the UriBuilder.
        Throws:
        IllegalArgumentException - if there are any URI template parameters without a supplied value, or if a template parameter value is null.
        UriBuilderException - if a URI cannot be constructed based on the current state of the builder.
        Since:
        2.0
        See Also:
        buildFromMap(java.util.Map), buildFromMap(java.util.Map, boolean)

      • build

        public abstract URI build(Object... values)
                   throws IllegalArgumentException,
                          UriBuilderException
        Build a URI, using the supplied values in order to replace any URI template parameters. Values are converted to String using their toString() method and are then encoded to match the rules of the URI component to which they pertain. All '%' characters in the stringified values will be encoded. The state of the builder is unaffected; this method may be called multiple times on the same builder instance.

        All instances of the same template parameter will be replaced by the same value that corresponds to the position of the first instance of the template parameter. e.g. the template "{a}/{b}/{a}" with values {"x", "y", "z"} will result in the the URI "x/y/x", not "x/y/z".

        NOTE: By default all '/' characters in the stringified values will be encoded in path templates, i.e. the result is identical to invoking build(Object[], boolean) build(values, true)}. To override this behavior use build(values, false) instead.

        Parameters:
        values - a list of URI template parameter values.
        Returns:
        the URI built from the UriBuilder.
        Throws:
        IllegalArgumentException - if there are any URI template parameters without a supplied value, or if a value is null.
        UriBuilderException - if a URI cannot be constructed based on the current state of the builder.
        See Also:
        build(Object[], boolean), buildFromEncoded(Object...)

      • build

        public abstract URI build(Object[] values,
        boolean encodeSlashInPath)
                   throws IllegalArgumentException,
                          UriBuilderException
        Build a URI, using the supplied values in order to replace any URI template parameters. Values are converted to String using their toString() method and are then encoded to match the rules of the URI component to which they pertain. All '%' characters in the stringified values will be encoded. The state of the builder is unaffected; this method may be called multiple times on the same builder instance.

        All instances of the same template parameter will be replaced by the same value that corresponds to the position of the first instance of the template parameter. e.g. the template "{a}/{b}/{a}" with values {"x", "y", "z"} will result in the the URI "x/y/x", not "x/y/z".

        The encodeSlashInPath parameter may be used to override the default encoding of '/' characters in the stringified template values in cases when the template is part of the URI path component when using the build(Object[]) method. If the encodeSlashInPath parameter is set to true (default), the slash ('/') characters in parameter values will be encoded if the template is placed in the URI path component. If set to false the default encoding behavior is overridden an slash characters in template values will not be encoded when used to substitute path templates.

        Parameters:
        values - a list of URI template parameter values.
        encodeSlashInPath - if true, the slash ('/') characters in parameter values will be encoded if the template is placed in the URI path component, otherwise the slash characters will not be encoded in path templates.
        Returns:
        the URI built from the UriBuilder.
        Throws:
        IllegalArgumentException - if there are any URI template parameters without a supplied value, or if a value is null.
        UriBuilderException - if a URI cannot be constructed based on the current state of the builder.
        Since:
        2.0
        See Also:
        build(Object[]), buildFromEncoded(Object...)

      • buildFromEncoded

        public abstract URI buildFromEncoded(Object... values)
                              throws IllegalArgumentException,
                                     UriBuilderException
        Build a URI. Any URI templates parameters will be replaced with the supplied values in order. Values are converted to String using their toString() method and are then encoded to match the rules of the URI component to which they pertain. All % characters in the stringified values that are not followed by two hexadecimal numbers will be encoded. The state of the builder is unaffected; this method may be called multiple times on the same builder instance.

        All instances of the same template parameter will be replaced by the same value that corresponds to the position of the first instance of the template parameter. e.g. the template "{a}/{b}/{a}" with values {"x", "y", "z"} will result in the the URI "x/y/x", not "x/y/z".

        Parameters:
        values - a list of URI template parameter values.
        Returns:
        the URI built from the UriBuilder.
        Throws:
        IllegalArgumentException - if there are any URI template parameters without a supplied value, or if a value is null.
        UriBuilderException - if a URI cannot be constructed based on the current state of the builder.
        See Also:
        build(Object[]), build(Object[], boolean)

      • toTemplate

        public abstract String toTemplate()
        Get the URI template string represented by this URI builder.
        Returns:
        the URI template string for this URI builder.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UriBuilderException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class UriBuilderException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.ws.rs.core.UriBuilderException
  • All Implemented Interfaces:
    Serializable

    public class UriBuilderException
extends RuntimeException
    A runtime exception thrown by UriBuilder.build(Object...) methods when a URI cannot be constructed based on the current state of the builder.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      UriBuilderException()
      Creates a new instance of UriBuilderException without detail message.
      UriBuilderException(String msg)
      Constructs an instance of UriBuilderException with the specified detail message.
      UriBuilderException(String msg, Throwable cause)
      Constructs an instance of UriBuilderException with the specified detail message and cause.
      UriBuilderException(Throwable cause)
      Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UriBuilderException

        public UriBuilderException()
        Creates a new instance of UriBuilderException without detail message.

      • UriBuilderException

        public UriBuilderException(String msg)
        Constructs an instance of UriBuilderException with the specified detail message.
        Parameters:
        msg - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).

      • UriBuilderException

        public UriBuilderException(String msg,
                   Throwable cause)
        Constructs an instance of UriBuilderException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        Parameters:
        msg - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • UriBuilderException

        public UriBuilderException(Throwable cause)
        Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause). This constructor is useful for exceptions that are little more than wrappers for other throwables.
        Parameters:
        cause - the original exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UriInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Interface UriInfo

  • public interface UriInfo
    An injectable interface that provides access to application and request URI information. Relative URIs are relative to the base URI of the application, see getBaseUri().

    All methods throw java.lang.IllegalStateException if called outside the scope of a request (e.g. from a provider constructor).

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Context

    • Method Summary

      Methods
      Modifier and Type Method and Description
      URI getAbsolutePath()
      Get the absolute path of the request.
      UriBuilder getAbsolutePathBuilder()
      Get the absolute path of the request in the form of a UriBuilder.
      URI getBaseUri()
      Get the base URI of the application.
      UriBuilder getBaseUriBuilder()
      Get the base URI of the application in the form of a UriBuilder.
      List<Object> getMatchedResources()
      Get a read-only list of the currently matched resource class instances.
      List<String> getMatchedURIs()
      Get a read-only list of URIs for matched resources.
      List<String> getMatchedURIs(boolean decode)
      Get a read-only list of URIs for matched resources.
      String getPath()
      Get the path of the current request relative to the base URI as a string.
      String getPath(boolean decode)
      Get the path of the current request relative to the base URI as a string.
      MultivaluedMap<String,String> getPathParameters()
      Get the values of any embedded URI template parameters.
      MultivaluedMap<String,String> getPathParameters(boolean decode)
      Get the values of any embedded URI template parameters.
      List<PathSegment> getPathSegments()
      Get the path of the current request relative to the base URI as a list of PathSegment.
      List<PathSegment> getPathSegments(boolean decode)
      Get the path of the current request relative to the base URI as a list of PathSegment.
      MultivaluedMap<String,String> getQueryParameters()
      Get the URI query parameters of the current request.
      MultivaluedMap<String,String> getQueryParameters(boolean decode)
      Get the URI query parameters of the current request.
      URI getRequestUri()
      Get the absolute request URI including any query parameters.
      UriBuilder getRequestUriBuilder()
      Get the absolute request URI in the form of a UriBuilder.
      URI relativize(URI uri)
      Relativize a URI with respect to the current request URI.
      URI resolve(URI uri)
      Resolve a relative URI with respect to the base URI of the application.

    • Method Detail

      • getPath

        String getPath()
        Get the path of the current request relative to the base URI as a string. All sequences of escaped octets are decoded, equivalent to getPath(true).
        Returns:
        the relative URI path.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getPath

        String getPath(boolean decode)
        Get the path of the current request relative to the base URI as a string.
        Parameters:
        decode - controls whether sequences of escaped octets are decoded (true) or not (false).
        Returns:
        the relative URI path
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getPathSegments

        List<PathSegment> getPathSegments()
        Get the path of the current request relative to the base URI as a list of PathSegment. This method is useful when the path needs to be parsed, particularly when matrix parameters may be present in the path. All sequences of escaped octets in path segments and matrix parameter values are decoded, equivalent to getPathSegments(true).
        Returns:
        an unmodifiable list of PathSegment. The matrix parameter map of each path segment is also unmodifiable.
        Throws:
        IllegalStateException - if called outside the scope of a request
        See Also:
        PathSegment, Matrix URIs

      • getPathSegments

        List<PathSegment> getPathSegments(boolean decode)
        Get the path of the current request relative to the base URI as a list of PathSegment. This method is useful when the path needs to be parsed, particularly when matrix parameters may be present in the path.
        Parameters:
        decode - controls whether sequences of escaped octets in path segments and matrix parameter values are decoded (true) or not (false).
        Returns:
        an unmodifiable list of PathSegment. The matrix parameter map of each path segment is also unmodifiable.
        Throws:
        IllegalStateException - if called outside the scope of a request
        See Also:
        PathSegment, Matrix URIs

      • getRequestUri

        URI getRequestUri()
        Get the absolute request URI including any query parameters.
        Returns:
        the absolute request URI
        Throws:
        IllegalStateException - if called outside the scope of a request

      • getRequestUriBuilder

        UriBuilder getRequestUriBuilder()
        Get the absolute request URI in the form of a UriBuilder.
        Returns:
        a UriBuilder initialized with the absolute request URI.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getAbsolutePath

        URI getAbsolutePath()
        Get the absolute path of the request. This includes everything preceding the path (host, port etc) but excludes query parameters. This is a shortcut for uriInfo.getBaseUri().resolve(uriInfo.getPath(false)).
        Returns:
        the absolute path of the request.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getAbsolutePathBuilder

        UriBuilder getAbsolutePathBuilder()
        Get the absolute path of the request in the form of a UriBuilder. This includes everything preceding the path (host, port etc) but excludes query parameters.
        Returns:
        a UriBuilder initialized with the absolute path of the request.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getBaseUri

        URI getBaseUri()
        Get the base URI of the application. URIs of root resource classes are all relative to this base URI.
        Returns:
        the base URI of the application.

      • getBaseUriBuilder

        UriBuilder getBaseUriBuilder()
        Get the base URI of the application in the form of a UriBuilder.
        Returns:
        a UriBuilder initialized with the base URI of the application.

      • getPathParameters

        MultivaluedMap<String,String> getPathParameters()
        Get the values of any embedded URI template parameters. All sequences of escaped octets are decoded, equivalent to getPathParameters(true).
        Returns:
        an unmodifiable map of parameter names and values.
        Throws:
        IllegalStateException - if called outside the scope of a request.
        See Also:
        Path, PathParam

      • getPathParameters

        MultivaluedMap<String,String> getPathParameters(boolean decode)
        Get the values of any embedded URI template parameters.
        Parameters:
        decode - controls whether sequences of escaped octets are decoded (true) or not (false).
        Returns:
        an unmodifiable map of parameter names and values
        Throws:
        IllegalStateException - if called outside the scope of a request.
        See Also:
        Path, PathParam

      • getQueryParameters

        MultivaluedMap<String,String> getQueryParameters()
        Get the URI query parameters of the current request. The map keys are the names of the query parameters with any escaped characters decoded. All sequences of escaped octets in parameter names and values are decoded, equivalent to getQueryParameters(true).
        Returns:
        an unmodifiable map of query parameter names and values.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getQueryParameters

        MultivaluedMap<String,String> getQueryParameters(boolean decode)
        Get the URI query parameters of the current request. The map keys are the names of the query parameters with any escaped characters decoded.
        Parameters:
        decode - controls whether sequences of escaped octets in parameter names and values are decoded (true) or not (false).
        Returns:
        an unmodifiable map of query parameter names and values.
        Throws:
        IllegalStateException - if called outside the scope of a request.

      • getMatchedURIs

        List<String> getMatchedURIs()
        Get a read-only list of URIs for matched resources. Each entry is a relative URI that matched a resource class, a sub-resource method or a sub-resource locator. All sequences of escaped octets are decoded, equivalent to getMatchedURIs(true). Entries do not include query parameters but do include matrix parameters if present in the request URI. Entries are ordered in reverse request URI matching order, with the current resource URI first. E.g. given the following resource classes:
        @Path("foo")
 public class FooResource {
  @GET
  public String getFoo() {...}

  @Path("bar")
  public BarResource getBarResource() {...}
 }

 public class BarResource {
  @GET
  public String getBar() {...}
 }

        The values returned by this method based on request uri and where the method is called from are:

        Request | Called from | Value(s)
        GET /foo | FooResource.getFoo | foo
        GET /foo/bar | FooResource.getBarResource | foo/bar, foo
        GET /foo/bar | BarResource.getBar | foo/bar, foo
        In case the method is invoked prior to the request matching (e.g. from a pre-matching filter), the method returns an empty list.
        Returns:
        a read-only list of URI paths for matched resources.

      • getMatchedURIs

        List<String> getMatchedURIs(boolean decode)
        Get a read-only list of URIs for matched resources. Each entry is a relative URI that matched a resource class, a sub-resource method or a sub-resource locator. Entries do not include query parameters but do include matrix parameters if present in the request URI. Entries are ordered in reverse request URI matching order, with the current resource URI first. See getMatchedURIs() for an example. In case the method is invoked prior to the request matching (e.g. from a pre-matching filter), the method returns an empty list.
        Parameters:
        decode - controls whether sequences of escaped octets are decoded (true) or not (false).
        Returns:
        a read-only list of URI paths for matched resources.

      • getMatchedResources

        List<Object> getMatchedResources()
        Get a read-only list of the currently matched resource class instances. Each entry is a resource class instance that matched the request URI either directly or via a sub-resource method or a sub-resource locator. Entries are ordered according to reverse request URI matching order, with the current resource first. E.g. given the following resource classes:
        @Path("foo")
 public class FooResource {
  @GET
  public String getFoo() {...}

  @Path("bar")
  public BarResource getBarResource() {...}
 }

 public class BarResource {
  @GET
  public String getBar() {...}
 }

        The values returned by this method based on request uri and where the method is called from are:

        Request | Called from | Value(s)
        GET /foo | FooResource.getFoo | FooResource
        GET /foo/bar | FooResource.getBarResource | FooResource
        GET /foo/bar | BarResource.getBar | BarResource, FooResource
        In case the method is invoked prior to the request matching (e.g. from a pre-matching filter), the method returns an empty list.
        Returns:
        a read-only list of matched resource class instances.

      • resolve

        URI resolve(URI uri)
        Resolve a relative URI with respect to the base URI of the application. The resolved URI returned by this method is normalized. If the supplied URI is already resolved, it is just returned.
        Parameters:
        uri - URI to resolve against the base URI of the application.
        Returns:
        newly resolved URI or supplied URI if already resolved.
        Since:
        2.0

      • relativize

        URI relativize(URI uri)

        Relativize a URI with respect to the current request URI. Relativization works as follows:

        1. If the URI to relativize is already relative, it is first resolved using resolve(java.net.URI).
        2. The resulting URI is relativized with respect to the current request URI. If the two URIs do not share a prefix, the URI computed in step 1 is returned.

        Examples (for base URI http://example.com:8080/app/root/):

        Request URI: http://example.com:8080/app/root/a/b/c/resource.html
        Supplied URI: a/b/c/d/file.txt
        Returned URI: d/file.txt

        Request URI: http://example.com:8080/app/root/a/b/c/resource.html
        Supplied URI: http://example2.com:9090/app2/root2/a/d/file.txt
        Returned URI: http://example2.com:9090/app2/root2/a/d/file.txt

        In the second example, the supplied URI is returned given that it is absolute and there is no common prefix between it and the request URI.

        Parameters:
        uri - URI to relativize against the request URI.
        Returns:
        newly relativized URI.
        Throws:
        IllegalStateException - if called outside the scope of a request.
        Since:
        2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.ws.rs.core (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.ws.rs.core

  • Packages that use javax.ws.rs.core
    Package Description
    javax.ws.rs
    High-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.
  • Classes in javax.ws.rs.core used by javax.ws.rs
    Class and Description
    Response
    Defines the contract between a returned instance and the runtime when an application needs to provide meta-data to the runtime.
    Response.Status
    Commonly used status codes defined by HTTP, see HTTP/1.1 documentation for the complete list.
  • Classes in javax.ws.rs.core used by javax.ws.rs.client
    Class and Description
    CacheControl
    An abstraction for the value of a HTTP Cache-Control response header.
    Configurable
    Represents a client or server-side configurable context in JAX-RS.
    Configuration
    A configuration state associated with a configurable JAX-RS context.
    Cookie
    Represents the value of a HTTP cookie, transferred in a request.
    EntityTag
    An abstraction for the value of a HTTP Entity Tag, used as the value of an ETag response header.
    Form
    Represents the the HTML form data request entity encoded using the "application/x-www-form-urlencoded" content type.
    GenericType
    Represents a generic message entity type T.
    Link
    Class representing hypermedia links.
    Link.Builder
    Builder class for hypermedia links.
    MediaType
    An abstraction for a media type.
    MultivaluedMap
    A map of key-values pairs.
    NewCookie
    Used to create a new HTTP cookie, transferred in a response.
    Response
    Defines the contract between a returned instance and the runtime when an application needs to provide meta-data to the runtime.
    Response.StatusType
    Base interface for statuses used in responses.
    UriBuilder
    URI template-aware utility class for building URIs from their components.
    Variant
    Abstraction for a resource representation variant.
  • Classes in javax.ws.rs.core used by javax.ws.rs.container
    Class and Description
    Cookie
    Represents the value of a HTTP cookie, transferred in a request.
    EntityTag
    An abstraction for the value of a HTTP Entity Tag, used as the value of an ETag response header.
    FeatureContext
    A configurable context passed to Feature and DynamicFeature instances by JAX-RS runtime during the phase of their configuration.
    Link
    Class representing hypermedia links.
    Link.Builder
    Builder class for hypermedia links.
    MediaType
    An abstraction for a media type.
    MultivaluedMap
    A map of key-values pairs.
    NewCookie
    Used to create a new HTTP cookie, transferred in a response.
    Request
    An injectable helper for request processing, all methods throw an IllegalStateException if called outside the scope of a request (e.g.
    Response
    Defines the contract between a returned instance and the runtime when an application needs to provide meta-data to the runtime.
    Response.StatusType
    Base interface for statuses used in responses.
    SecurityContext
    An injectable interface that provides access to security related information.
    UriInfo
    An injectable interface that provides access to application and request URI information.
  • Classes in javax.ws.rs.core used by javax.ws.rs.core
    Class and Description
    AbstractMultivaluedMap
    Abstract skeleton implementation of a MultivaluedMap that is backed by a [key, multi-value] store represented as a Map<K, List<V>>.
    CacheControl
    An abstraction for the value of a HTTP Cache-Control response header.
    Configurable
    Represents a client or server-side configurable context in JAX-RS.
    Configuration
    A configuration state associated with a configurable JAX-RS context.
    Cookie
    Represents the value of a HTTP cookie, transferred in a request.
    EntityTag
    An abstraction for the value of a HTTP Entity Tag, used as the value of an ETag response header.
    Feature
    A feature extension contract.
    FeatureContext
    A configurable context passed to Feature and DynamicFeature instances by JAX-RS runtime during the phase of their configuration.
    Form
    Represents the the HTML form data request entity encoded using the "application/x-www-form-urlencoded" content type.
    GenericType
    Represents a generic message entity type T.
    Link
    Class representing hypermedia links.
    Link.Builder
    Builder class for hypermedia links.
    Link.JaxbLink
    Value type for Link that can be marshalled and unmarshalled by JAXB.
    MediaType
    An abstraction for a media type.
    MultivaluedMap
    A map of key-values pairs.
    NewCookie
    Used to create a new HTTP cookie, transferred in a response.
    PathSegment
    Represents a URI path segment and any associated matrix parameters.
    Response
    Defines the contract between a returned instance and the runtime when an application needs to provide meta-data to the runtime.
    Response.ResponseBuilder
    A class used to build Response instances that contain metadata instead of or in addition to an entity.
    Response.Status
    Commonly used status codes defined by HTTP, see HTTP/1.1 documentation for the complete list.
    Response.Status.Family
    An enumeration representing the class of status code.
    Response.StatusType
    Base interface for statuses used in responses.
    UriBuilder
    URI template-aware utility class for building URIs from their components.
    UriBuilderException
    A runtime exception thrown by UriBuilder.build(Object...) methods when a URI cannot be constructed based on the current state of the builder.
    Variant
    Abstraction for a resource representation variant.
    Variant.VariantListBuilder
    A builder for a list of representation variants.
  • Classes in javax.ws.rs.core used by javax.ws.rs.ext
    Class and Description
    Application
    Defines the components of a JAX-RS application and supplies additional meta-data.
    Link.Builder
    Builder class for hypermedia links.
    MediaType
    An abstraction for a media type.
    MultivaluedMap
    A map of key-values pairs.
    Response
    Defines the contract between a returned instance and the runtime when an application needs to provide meta-data to the runtime.
    Response.ResponseBuilder
    A class used to build Response instances that contain metadata instead of or in addition to an entity.
    UriBuilder
    URI template-aware utility class for building URIs from their components.
    Variant.VariantListBuilder
    A builder for a list of representation variants.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Variant (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class Variant

  • java.lang.Object
    • javax.ws.rs.core.Variant

  • public class Variant
extends Object
    Abstraction for a resource representation variant. Contains information about media type, language and encoding of the resource representation.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  Variant.VariantListBuilder
      A builder for a list of representation variants.

    • Constructor Summary

      Constructors
      Constructor and Description
      Variant(MediaType mediaType, Locale language, String encoding)
      Create a new instance of Variant.
      Variant(MediaType mediaType, String language, String encoding)
      Create a new instance of Variant.
      Variant(MediaType mediaType, String language, String country, String encoding)
      Create a new instance of Variant.
      Variant(MediaType mediaType, String language, String country, String languageVariant, String encoding)
      Create a new instance of Variant.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Variant.VariantListBuilder encodings(String... encodings)
      Create a Variant.VariantListBuilder initialized with a set of supported encodings.
      boolean equals(Object obj)
      Compares obj to this variant to see if they are the same considering all property values.
      String getEncoding()
      Get the encoding of the variant.
      Locale getLanguage()
      Get the language of the variant.
      String getLanguageString()
      Get the string representation of the variant language, or null if no language has been set.
      MediaType getMediaType()
      Get the media type of the variant.
      int hashCode()
      Generate hash code from variant properties.
      static Variant.VariantListBuilder languages(Locale... languages)
      Create a Variant.VariantListBuilder initialized with a set of supported languages.
      static Variant.VariantListBuilder mediaTypes(MediaType... mediaTypes)
      Create a Variant.VariantListBuilder initialized with a set of supported media types.
      String toString()

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Variant

        public Variant(MediaType mediaType,
       String language,
       String encoding)
        Create a new instance of Variant.
        Parameters:
        mediaType - the media type of the variant - may be null.
        language - the language of the variant (two-letter ISO-639 code); may be null.
        encoding - the content encoding of the variant - may be null.
        Throws:
        IllegalArgumentException - if all the parameters are null.
        Since:
        2.0

      • Variant

        public Variant(MediaType mediaType,
       String language,
       String country,
       String encoding)
        Create a new instance of Variant.
        Parameters:
        mediaType - the media type of the variant - may be null.
        language - the language of the variant (two-letter ISO-639 code); may be null.
        country - uppercase two-letter ISO-3166 language code of the variant; may be null provided language is null too.
        encoding - the content encoding of the variant - may be null.
        Throws:
        IllegalArgumentException - if all the parameters are null.
        Since:
        2.0

      • Variant

        public Variant(MediaType mediaType,
       String language,
       String country,
       String languageVariant,
       String encoding)
        Create a new instance of Variant.
        Parameters:
        mediaType - the media type of the variant - may be null.
        language - the language of the variant (two-letter ISO-639 code); may be null.
        country - uppercase two-letter ISO-3166 language code of the variant; may be null provided language is null too.
        languageVariant - vendor and browser specific language code of the variant (see also Locale class description); may be null provided language and country are null too.
        encoding - the content encoding of the variant - may be null.
        Throws:
        IllegalArgumentException - if all the parameters are null.
        Since:
        2.0

      • Variant

        public Variant(MediaType mediaType,
       Locale language,
       String encoding)
        Create a new instance of Variant.
        Parameters:
        mediaType - the media type of the variant - may be null.
        language - the language of the variant - may be null.
        encoding - the content encoding of the variant - may be null.
        Throws:
        IllegalArgumentException - if all the parameters are null.

    • Method Detail

      • getLanguage

        public Locale getLanguage()
        Get the language of the variant.
        Returns:
        the language or null if none set.

      • getLanguageString

        public String getLanguageString()
        Get the string representation of the variant language, or null if no language has been set.
        Returns:
        the string representing variant language or null if none set.
        Since:
        2.0

      • getMediaType

        public MediaType getMediaType()
        Get the media type of the variant.
        Returns:
        the media type or null if none set.

      • getEncoding

        public String getEncoding()
        Get the encoding of the variant.
        Returns:
        the encoding or null if none set.

      • mediaTypes

        public static Variant.VariantListBuilder mediaTypes(MediaType... mediaTypes)
        Create a Variant.VariantListBuilder initialized with a set of supported media types.
        Parameters:
        mediaTypes - the available mediaTypes. If specific char-sets are supported they should be included as parameters of the respective media type.
        Returns:
        the initialized builder.
        Throws:
        IllegalArgumentException - if mediaTypes is null or contains no elements.

      • languages

        public static Variant.VariantListBuilder languages(Locale... languages)
        Create a Variant.VariantListBuilder initialized with a set of supported languages.
        Parameters:
        languages - the available languages.
        Returns:
        the initialized builder.
        Throws:
        IllegalArgumentException - if languages is null or contains no elements.

      • encodings

        public static Variant.VariantListBuilder encodings(String... encodings)
        Create a Variant.VariantListBuilder initialized with a set of supported encodings.
        Parameters:
        encodings - the available encodings.
        Returns:
        the initialized builder.
        Throws:
        IllegalArgumentException - if encodings is null or contains no elements.

      • hashCode

        public int hashCode()
        Generate hash code from variant properties.
        Overrides:
        hashCode in class Object
        Returns:
        the hash code.

      • equals

        public boolean equals(Object obj)
        Compares obj to this variant to see if they are the same considering all property values.
        Overrides:
        equals in class Object
        Parameters:
        obj - the object to compare to.
        Returns:
        true if the two variants are the same, false otherwise.

      • toString

        public String toString()
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Variant.VariantListBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.core

Class Variant.VariantListBuilder

  • java.lang.Object
    • javax.ws.rs.core.Variant.VariantListBuilder
  • Enclosing class:
    Variant

    public abstract static class Variant.VariantListBuilder
extends Object
    A builder for a list of representation variants.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Variant.VariantListBuilder()
      Protected constructor, use the static newInstance method to obtain an instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Variant.VariantListBuilder add()
      Add the current combination of metadata to the list of supported variants, after this method is called the current combination of metadata is emptied.
      abstract List<Variant> build()
      Add the current combination of metadata to the list of supported variants (provided the current combination of metadata is not empty) and build a list of representation variants from the current state of the builder.
      abstract Variant.VariantListBuilder encodings(String... encodings)
      Set the encoding(s) for this variant.
      abstract Variant.VariantListBuilder languages(Locale... languages)
      Set the language(s) for this variant.
      abstract Variant.VariantListBuilder mediaTypes(MediaType... mediaTypes)
      Set the media type(s) for this variant.
      static Variant.VariantListBuilder newInstance()
      Create a new builder instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Variant.VariantListBuilder

        protected Variant.VariantListBuilder()
        Protected constructor, use the static newInstance method to obtain an instance.

    • Method Detail

      • newInstance

        public static Variant.VariantListBuilder newInstance()
        Create a new builder instance.
        Returns:
        a new builder instance.

      • build

        public abstract List<Variant> build()
        Add the current combination of metadata to the list of supported variants (provided the current combination of metadata is not empty) and build a list of representation variants from the current state of the builder. After this method is called the builder is reset to an empty state.
        Returns:
        a list of representation variants.

      • add

        public abstract Variant.VariantListBuilder add()
        Add the current combination of metadata to the list of supported variants, after this method is called the current combination of metadata is emptied.

        If more than one value is supplied for one or more of the variant properties then a variant will be generated for each possible combination. E.g. in the following list would have five (4 + 1) members:

        List list = VariantListBuilder.newInstance()
         .languages(Locale.ENGLISH, Locale.FRENCH).encodings("zip", "identity").add()
         .languages(Locale.GERMAN).mediaTypes(MediaType.TEXT_PLAIN_TYPE).add()
         .build()

        Note that it is not necessary to call the add() method immediately before the build method is called. E.g. the resulting list produced in the example above would be identical to the list produced by the following code:

        List list = VariantListBuilder.newInstance()
         .languages(Locale.ENGLISH, Locale.FRENCH).encodings("zip", "identity").add()
         .languages(Locale.GERMAN).mediaTypes(MediaType.TEXT_PLAIN_TYPE)
         .build()
        Returns:
        the updated builder.
        Throws:
        IllegalStateException - if there is not at least one mediaType, language or encoding set for the current variant.

      • languages

        public abstract Variant.VariantListBuilder languages(Locale... languages)
        Set the language(s) for this variant.
        Parameters:
        languages - the available languages.
        Returns:
        the updated builder.

      • encodings

        public abstract Variant.VariantListBuilder encodings(String... encodings)
        Set the encoding(s) for this variant.
        Parameters:
        encodings - the available encodings.
        Returns:
        the updated builder.

      • mediaTypes

        public abstract Variant.VariantListBuilder mediaTypes(MediaType... mediaTypes)
        Set the media type(s) for this variant.
        Parameters:
        mediaTypes - the available mediaTypes. If specific charsets are supported they should be included as parameters of the respective media type.
        Returns:
        the updated builder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.ws.rs.core.AbstractMultivaluedMap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.AbstractMultivaluedMap

  • Packages that use AbstractMultivaluedMap
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of AbstractMultivaluedMap in javax.ws.rs.core

      Subclasses of AbstractMultivaluedMap in javax.ws.rs.core
      Modifier and Type Class and Description
      class  MultivaluedHashMap<K,V>
      A hash table based implementation of MultivaluedMap interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Application (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Application

  • Packages that use Application
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of Application in javax.ws.rs.ext

      Methods in javax.ws.rs.ext with parameters of type Application
      Modifier and Type Method and Description
      abstract <T> T RuntimeDelegate.createEndpoint(Application application, Class<T> endpointType)
      Create a configured instance of the supplied endpoint type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.CacheControl (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.CacheControl

  • Packages that use CacheControl
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of CacheControl in javax.ws.rs.client

      Methods in javax.ws.rs.client with parameters of type CacheControl
      Modifier and Type Method and Description
      Invocation.Builder Invocation.Builder.cacheControl(CacheControl cacheControl)
      Set the cache control data of the message.

    • Uses of CacheControl in javax.ws.rs.core

      Methods in javax.ws.rs.core that return CacheControl
      Modifier and Type Method and Description
      static CacheControl CacheControl.valueOf(String value)
      Creates a new instance of CacheControl by parsing the supplied string.
      Methods in javax.ws.rs.core with parameters of type CacheControl
      Modifier and Type Method and Description
      abstract Response.ResponseBuilder Response.ResponseBuilder.cacheControl(CacheControl cacheControl)
      Set the cache control data of the message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Context (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Context

No usage of javax.ws.rs.core.Context
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Cookie (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Cookie

  • Packages that use Cookie
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Cookie in javax.ws.rs.client

      Methods in javax.ws.rs.client that return types with arguments of type Cookie
      Modifier and Type Method and Description
      Map<String,Cookie> ClientRequestContext.getCookies()
      Get any cookies that accompanied the request.
      Methods in javax.ws.rs.client with parameters of type Cookie
      Modifier and Type Method and Description
      Invocation.Builder Invocation.Builder.cookie(Cookie cookie)
      Add a cookie to be set.

    • Uses of Cookie in javax.ws.rs.container

      Methods in javax.ws.rs.container that return types with arguments of type Cookie
      Modifier and Type Method and Description
      Map<String,Cookie> ContainerRequestContext.getCookies()
      Get any cookies that accompanied the request.

    • Uses of Cookie in javax.ws.rs.core

      Subclasses of Cookie in javax.ws.rs.core
      Modifier and Type Class and Description
      class  NewCookie
      Used to create a new HTTP cookie, transferred in a response.
      Methods in javax.ws.rs.core that return Cookie
      Modifier and Type Method and Description
      Cookie NewCookie.toCookie()
      Obtain a new instance of a Cookie with the same name, value, path, domain and version as this NewCookie.
      static Cookie Cookie.valueOf(String value)
      Creates a new instance of Cookie by parsing the supplied string.
      Methods in javax.ws.rs.core that return types with arguments of type Cookie
      Modifier and Type Method and Description
      Map<String,Cookie> HttpHeaders.getCookies()
      Get any cookies that accompanied the request.
      Constructors in javax.ws.rs.core with parameters of type Cookie
      Constructor and Description
      NewCookie(Cookie cookie)
      Create a new instance copying the information in the supplied cookie.
      NewCookie(Cookie cookie, String comment, int maxAge, boolean secure)
      Create a new instance supplementing the information in the supplied cookie.
      NewCookie(Cookie cookie, String comment, int maxAge, Date expiry, boolean secure, boolean httpOnly)
      Create a new instance supplementing the information in the supplied cookie.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.EntityTag (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.EntityTag

  • Packages that use EntityTag
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of EntityTag in javax.ws.rs.client

      Methods in javax.ws.rs.client that return EntityTag
      Modifier and Type Method and Description
      EntityTag ClientResponseContext.getEntityTag()
      Get the entity tag.

    • Uses of EntityTag in javax.ws.rs.container

      Methods in javax.ws.rs.container that return EntityTag
      Modifier and Type Method and Description
      EntityTag ContainerResponseContext.getEntityTag()
      Get the entity tag.

    • Uses of EntityTag in javax.ws.rs.core

      Methods in javax.ws.rs.core that return EntityTag
      Modifier and Type Method and Description
      abstract EntityTag Response.getEntityTag()
      Get the entity tag.
      static EntityTag EntityTag.valueOf(String value)
      Creates a new instance of EntityTag by parsing the supplied string.
      Methods in javax.ws.rs.core with parameters of type EntityTag
      Modifier and Type Method and Description
      Response.ResponseBuilder Request.evaluatePreconditions(Date lastModified, EntityTag eTag)
      Evaluate request preconditions based on the passed in value.
      Response.ResponseBuilder Request.evaluatePreconditions(EntityTag eTag)
      Evaluate request preconditions based on the passed in value.
      static Response.ResponseBuilder Response.notModified(EntityTag tag)
      Create a new ResponseBuilder with a not-modified status.
      abstract Response.ResponseBuilder Response.ResponseBuilder.tag(EntityTag tag)
      Set a response entity tag.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Form (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Form

  • Packages that use Form
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Form in javax.ws.rs.client

      Methods in javax.ws.rs.client that return types with arguments of type Form
      Modifier and Type Method and Description
      static Entity<Form> Entity.form(Form form)
      Create an "application/x-www-form-urlencoded" form entity.
      static Entity<Form> Entity.form(MultivaluedMap<String,String> formData)
      Create an "application/x-www-form-urlencoded" form entity.
      Methods in javax.ws.rs.client with parameters of type Form
      Modifier and Type Method and Description
      static Entity<Form> Entity.form(Form form)
      Create an "application/x-www-form-urlencoded" form entity.

    • Uses of Form in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Form
      Modifier and Type Method and Description
      Form Form.param(String name, String value)
      Adds a new value to the specified form parameter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.GenericEntity (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.GenericEntity

No usage of javax.ws.rs.core.GenericEntity
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.GenericType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.GenericType

  • Packages that use GenericType
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of GenericType in javax.ws.rs.client

      Methods in javax.ws.rs.client with parameters of type GenericType
      Modifier and Type Method and Description
      <T> T SyncInvoker.delete(GenericType<T> responseType)
      Invoke HTTP DELETE method for the current request synchronously.
      <T> Future<T> AsyncInvoker.delete(GenericType<T> responseType)
      Invoke HTTP DELETE method for the current request asynchronously.
      <T> T SyncInvoker.get(GenericType<T> responseType)
      Invoke HTTP GET method for the current request synchronously.
      <T> Future<T> AsyncInvoker.get(GenericType<T> responseType)
      Invoke HTTP GET method for the current request asynchronously.
      <T> T Invocation.invoke(GenericType<T> responseType)
      Synchronously invoke the request and receive a response of the specified generic type back.
      <T> T SyncInvoker.method(String name, Entity<?> entity, GenericType<T> responseType)
      Invoke an arbitrary method for the current request synchronously.
      <T> Future<T> AsyncInvoker.method(String name, Entity<?> entity, GenericType<T> responseType)
      Invoke an arbitrary method for the current request asynchronously.
      <T> T SyncInvoker.method(String name, GenericType<T> responseType)
      Invoke an arbitrary method for the current request synchronously.
      <T> Future<T> AsyncInvoker.method(String name, GenericType<T> responseType)
      Invoke an arbitrary method for the current request asynchronously.
      <T> T SyncInvoker.options(GenericType<T> responseType)
      Invoke HTTP OPTIONS method for the current request synchronously.
      <T> Future<T> AsyncInvoker.options(GenericType<T> responseType)
      Invoke HTTP OPTIONS method for the current request asynchronously.
      <T> T SyncInvoker.post(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP POST method for the current request synchronously.
      <T> Future<T> AsyncInvoker.post(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP POST method for the current request asynchronously.
      <T> T SyncInvoker.put(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP PUT method for the current request synchronously.
      <T> Future<T> AsyncInvoker.put(Entity<?> entity, GenericType<T> responseType)
      Invoke HTTP PUT method for the current request asynchronously.
      <T> Future<T> Invocation.submit(GenericType<T> responseType)
      Submit the request for an asynchronous invocation and receive a future response of the specified generic type back.
      <T> T SyncInvoker.trace(GenericType<T> responseType)
      Invoke HTTP TRACE method for the current request synchronously.
      <T> Future<T> AsyncInvoker.trace(GenericType<T> responseType)
      Invoke HTTP TRACE method for the current request asynchronously.

    • Uses of GenericType in javax.ws.rs.core

      Methods in javax.ws.rs.core with parameters of type GenericType
      Modifier and Type Method and Description
      abstract <T> T Response.readEntity(GenericType<T> entityType)
      Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.
      abstract <T> T Response.readEntity(GenericType<T> entityType, Annotation[] annotations)
      Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Link (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Link

  • Packages that use Link
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Link in javax.ws.rs.client

      Methods in javax.ws.rs.client that return Link
      Modifier and Type Method and Description
      Link ClientResponseContext.getLink(String relation)
      Get the link for the relation.
      Methods in javax.ws.rs.client that return types with arguments of type Link
      Modifier and Type Method and Description
      Set<Link> ClientResponseContext.getLinks()
      Get the links attached to the message as header.
      Methods in javax.ws.rs.client with parameters of type Link
      Modifier and Type Method and Description
      Invocation.Builder Client.invocation(Link link)
      Build an invocation builder from a link.
      WebTarget Client.target(Link link)
      Build a new web resource target.

    • Uses of Link in javax.ws.rs.container

      Methods in javax.ws.rs.container that return Link
      Modifier and Type Method and Description
      Link ContainerResponseContext.getLink(String relation)
      Get the link for the relation.
      Methods in javax.ws.rs.container that return types with arguments of type Link
      Modifier and Type Method and Description
      Set<Link> ContainerResponseContext.getLinks()
      Get the links attached to the message as header.

    • Uses of Link in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Link
      Modifier and Type Method and Description
      Link Link.Builder.build(Object... values)
      Finish building this link using the supplied values as URI parameters.
      Link Link.Builder.buildRelativized(URI uri, Object... values)
      Finish building this link using the supplied values as URI parameters and relativize the result with respect to the supplied URI.
      abstract Link Response.getLink(String relation)
      Get the link for the relation.
      Link Link.JaxbAdapter.unmarshal(Link.JaxbLink v)
      Convert a Link.JaxbLink into a Link.
      static Link Link.valueOf(String value)
      Simple parser to convert link header string representations into a link.
      Methods in javax.ws.rs.core that return types with arguments of type Link
      Modifier and Type Method and Description
      abstract Set<Link> Response.getLinks()
      Get the links attached to the message as headers.
      Methods in javax.ws.rs.core with parameters of type Link
      Modifier and Type Method and Description
      static UriBuilder UriBuilder.fromLink(Link link)
      Create a new instance initialized from a Link.
      static Link.Builder Link.fromLink(Link link)
      Create a new builder instance initialized from another link.
      Link.Builder Link.Builder.link(Link link)
      Initialize builder using another link.
      abstract Response.ResponseBuilder Response.ResponseBuilder.links(Link... links)
      Add one or more link headers.
      Link.JaxbLink Link.JaxbAdapter.marshal(Link v)
      Convert a Link into a Link.JaxbLink.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Link.JaxbAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Link.JaxbAdapter

No usage of javax.ws.rs.core.Link.JaxbAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Link.JaxbLink (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Link.JaxbLink

  • Packages that use Link.JaxbLink
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Link.JaxbLink in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Link.JaxbLink
      Modifier and Type Method and Description
      Link.JaxbLink Link.JaxbAdapter.marshal(Link v)
      Convert a Link into a Link.JaxbLink.
      Methods in javax.ws.rs.core with parameters of type Link.JaxbLink
      Modifier and Type Method and Description
      Link Link.JaxbAdapter.unmarshal(Link.JaxbLink v)
      Convert a Link.JaxbLink into a Link.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.MediaType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.MediaType

  • Packages that use MediaType
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of MediaType in javax.ws.rs.client

      Methods in javax.ws.rs.client that return MediaType
      Modifier and Type Method and Description
      MediaType Entity.getMediaType()
      Get entity media type.
      MediaType ClientResponseContext.getMediaType()
      Get the media type of the entity.
      MediaType ClientRequestContext.getMediaType()
      Get the media type of the entity.
      Methods in javax.ws.rs.client that return types with arguments of type MediaType
      Modifier and Type Method and Description
      List<MediaType> ClientRequestContext.getAcceptableMediaTypes()
      Get a list of media types that are acceptable for the response.
      Methods in javax.ws.rs.client with parameters of type MediaType
      Modifier and Type Method and Description
      Invocation.Builder Invocation.Builder.accept(MediaType... mediaTypes)
      Add the accepted response media types.
      static <T> Entity<T> Entity.entity(T entity, MediaType mediaType)
      Create an entity using a supplied content media type.
      static <T> Entity<T> Entity.entity(T entity, MediaType mediaType, Annotation[] annotations)
      Create an entity using a supplied content media type.
      Invocation.Builder WebTarget.request(MediaType... acceptedResponseTypes)
      Start building a request to the targeted web resource and define the accepted response media types.
      void ClientRequestContext.setEntity(Object entity, Annotation[] annotations, MediaType mediaType)
      Set a new message entity, including the attached annotations and the media type.

    • Uses of MediaType in javax.ws.rs.container

      Methods in javax.ws.rs.container that return MediaType
      Modifier and Type Method and Description
      MediaType ContainerResponseContext.getMediaType()
      Get the media type of the entity.
      MediaType ContainerRequestContext.getMediaType()
      Get the media type of the entity.
      Methods in javax.ws.rs.container that return types with arguments of type MediaType
      Modifier and Type Method and Description
      List<MediaType> ContainerRequestContext.getAcceptableMediaTypes()
      Get a list of media types that are acceptable for the response.
      Methods in javax.ws.rs.container with parameters of type MediaType
      Modifier and Type Method and Description
      void ContainerResponseContext.setEntity(Object entity, Annotation[] annotations, MediaType mediaType)
      Set a new message entity, including the attached annotations and the media type.

    • Uses of MediaType in javax.ws.rs.core

      Fields in javax.ws.rs.core declared as MediaType
      Modifier and Type Field and Description
      static MediaType MediaType.APPLICATION_ATOM_XML_TYPE
      A MediaType constant representing ""application/atom+xml"" media type.
      static MediaType MediaType.APPLICATION_FORM_URLENCODED_TYPE
      A MediaType constant representing ""application/x-www-form-urlencoded"" media type.
      static MediaType MediaType.APPLICATION_JSON_TYPE
      A MediaType constant representing ""application/json"" media type.
      static MediaType MediaType.APPLICATION_OCTET_STREAM_TYPE
      A MediaType constant representing ""application/octet-stream"" media type.
      static MediaType MediaType.APPLICATION_SVG_XML_TYPE
      A MediaType constant representing ""application/svg+xml"" media type.
      static MediaType MediaType.APPLICATION_XHTML_XML_TYPE
      A MediaType constant representing ""application/xhtml+xml"" media type.
      static MediaType MediaType.APPLICATION_XML_TYPE
      A MediaType constant representing ""application/xml"" media type.
      static MediaType MediaType.MULTIPART_FORM_DATA_TYPE
      A MediaType constant representing ""multipart/form-data"" media type.
      static MediaType MediaType.TEXT_HTML_TYPE
      A MediaType constant representing ""text/html"" media type.
      static MediaType MediaType.TEXT_PLAIN_TYPE
      A MediaType constant representing ""text/plain"" media type.
      static MediaType MediaType.TEXT_XML_TYPE
      A MediaType constant representing ""text/xml"" media type.
      static MediaType MediaType.WILDCARD_TYPE
      A MediaType constant representing wildcard ""*/*"" media type.
      Methods in javax.ws.rs.core that return MediaType
      Modifier and Type Method and Description
      MediaType Variant.getMediaType()
      Get the media type of the variant.
      abstract MediaType Response.getMediaType()
      Get the media type of the message entity.
      MediaType HttpHeaders.getMediaType()
      Get the media type of the request entity.
      static MediaType MediaType.valueOf(String type)
      Creates a new instance of MediaType by parsing the supplied string.
      MediaType MediaType.withCharset(String charset)
      Create a new MediaType instance with the same type, subtype and parameters copied from the original instance and the supplied ""charset"" parameter.
      Methods in javax.ws.rs.core that return types with arguments of type MediaType
      Modifier and Type Method and Description
      List<MediaType> HttpHeaders.getAcceptableMediaTypes()
      Get a list of media types that are acceptable for the response.
      Methods in javax.ws.rs.core with parameters of type MediaType
      Modifier and Type Method and Description
      boolean MediaType.isCompatible(MediaType other)
      Check if this media type is compatible with another media type.
      static Variant.VariantListBuilder Variant.mediaTypes(MediaType... mediaTypes)
      Create a Variant.VariantListBuilder initialized with a set of supported media types.
      abstract Variant.VariantListBuilder Variant.VariantListBuilder.mediaTypes(MediaType... mediaTypes)
      Set the media type(s) for this variant.
      static Response.ResponseBuilder Response.ok(Object entity, MediaType type)
      Create a new ResponseBuilder that contains a representation.
      abstract Response.ResponseBuilder Response.ResponseBuilder.type(MediaType type)
      Set the message entity media type.
      Constructors in javax.ws.rs.core with parameters of type MediaType
      Constructor and Description
      Variant(MediaType mediaType, Locale language, String encoding)
      Create a new instance of Variant.
      Variant(MediaType mediaType, String language, String encoding)
      Create a new instance of Variant.
      Variant(MediaType mediaType, String language, String country, String encoding)
      Create a new instance of Variant.
      Variant(MediaType mediaType, String language, String country, String languageVariant, String encoding)
      Create a new instance of Variant.

    • Uses of MediaType in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return MediaType
      Modifier and Type Method and Description
      MediaType InterceptorContext.getMediaType()
      Get media type of HTTP entity.
      Methods in javax.ws.rs.ext with parameters of type MediaType
      Modifier and Type Method and Description
      <T> ContextResolver<T> Providers.getContextResolver(Class<T> contextType, MediaType mediaType)
      Get a context resolver for a particular type of context and media type.
      <T> MessageBodyReader<T> Providers.getMessageBodyReader(Class<T> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Get a message body reader that matches a set of criteria.
      <T> MessageBodyWriter<T> Providers.getMessageBodyWriter(Class<T> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Get a message body writer that matches a set of criteria.
      long MessageBodyWriter.getSize(T t, Class<?> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Originally, the method has been called before writeTo to ascertain the length in bytes of the serialized form of t.
      boolean MessageBodyReader.isReadable(Class<?> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Ascertain if the MessageBodyReader can produce an instance of a particular type.
      boolean MessageBodyWriter.isWriteable(Class<?> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Ascertain if the MessageBodyWriter supports a particular type.
      T MessageBodyReader.readFrom(Class<T> type, Type genericType, Annotation[] annotations, MediaType mediaType, MultivaluedMap<String,String> httpHeaders, InputStream entityStream)
      Read a type from the InputStream.
      void InterceptorContext.setMediaType(MediaType mediaType)
      Update media type of HTTP entity.
      void MessageBodyWriter.writeTo(T t, Class<?> type, Type genericType, Annotation[] annotations, MediaType mediaType, MultivaluedMap<String,Object> httpHeaders, OutputStream entityStream)
      Write a type to an HTTP message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.MultivaluedHashMap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.MultivaluedHashMap

No usage of javax.ws.rs.core.MultivaluedHashMap
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.NewCookie (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.NewCookie

  • Packages that use NewCookie
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of NewCookie in javax.ws.rs.client

      Methods in javax.ws.rs.client that return types with arguments of type NewCookie
      Modifier and Type Method and Description
      Map<String,NewCookie> ClientResponseContext.getCookies()
      Get any new cookies set on the response message.

    • Uses of NewCookie in javax.ws.rs.container

      Methods in javax.ws.rs.container that return types with arguments of type NewCookie
      Modifier and Type Method and Description
      Map<String,NewCookie> ContainerResponseContext.getCookies()
      Get any new cookies set on the response message.

    • Uses of NewCookie in javax.ws.rs.core

      Methods in javax.ws.rs.core that return NewCookie
      Modifier and Type Method and Description
      static NewCookie NewCookie.valueOf(String value)
      Creates a new instance of NewCookie by parsing the supplied string.
      Methods in javax.ws.rs.core that return types with arguments of type NewCookie
      Modifier and Type Method and Description
      abstract Map<String,NewCookie> Response.getCookies()
      Get any new cookies set on the response message.
      Methods in javax.ws.rs.core with parameters of type NewCookie
      Modifier and Type Method and Description
      abstract Response.ResponseBuilder Response.ResponseBuilder.cookie(NewCookie... cookies)
      Add cookies to the response message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.NoContentException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.NoContentException

No usage of javax.ws.rs.core.NoContentException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Response (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Response

  • Packages that use Response
    Package Description
    javax.ws.rs
    High-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of Response in javax.ws.rs

      Methods in javax.ws.rs that return Response
      Modifier and Type Method and Description
      Response WebApplicationException.getResponse()
      Get the HTTP response.
      Constructors in javax.ws.rs with parameters of type Response
      Constructor and Description
      BadRequestException(Response response)
      Construct a new bad client request exception.
      BadRequestException(Response response, Throwable cause)
      Construct a new bad client request exception.
      BadRequestException(String message, Response response)
      Construct a new bad client request exception.
      BadRequestException(String message, Response response, Throwable cause)
      Construct a new bad client request exception.
      ClientErrorException(Response response)
      Construct a new client error exception.
      ClientErrorException(Response response, Throwable cause)
      Construct a new client error exception.
      ClientErrorException(String message, Response response)
      Construct a new client error exception.
      ClientErrorException(String message, Response response, Throwable cause)
      Construct a new client error exception.
      ForbiddenException(Response response)
      Construct a new "forbidden" exception.
      ForbiddenException(Response response, Throwable cause)
      Construct a new "forbidden" exception.
      ForbiddenException(String message, Response response)
      Construct a new "forbidden" exception.
      ForbiddenException(String message, Response response, Throwable cause)
      Construct a new "forbidden" exception.
      InternalServerErrorException(Response response)
      Construct a new internal server error exception.
      InternalServerErrorException(Response response, Throwable cause)
      Construct a new internal server error exception.
      InternalServerErrorException(String message, Response response)
      Construct a new internal server error exception.
      InternalServerErrorException(String message, Response response, Throwable cause)
      Construct a new internal server error exception.
      NotAcceptableException(Response response)
      Construct a new "request not acceptable" exception.
      NotAcceptableException(Response response, Throwable cause)
      Construct a new "request not acceptable" exception.
      NotAcceptableException(String message, Response response)
      Construct a new "request not acceptable" exception.
      NotAcceptableException(String message, Response response, Throwable cause)
      Construct a new "request not acceptable" exception.
      NotAllowedException(Response response)
      Construct a new method not allowed exception.
      NotAllowedException(Response response, Throwable cause)
      Construct a new method not allowed exception.
      NotAllowedException(String message, Response response)
      Construct a new method not allowed exception.
      NotAllowedException(String message, Response response, Throwable cause)
      Construct a new method not allowed exception.
      NotAuthorizedException(Response response)
      Construct a new "not authorized" exception.
      NotAuthorizedException(Response response, Throwable cause)
      Construct a new "not authorized" exception.
      NotAuthorizedException(String message, Response response)
      Construct a new "not authorized" exception.
      NotAuthorizedException(String message, Response response, Throwable cause)
      Construct a new "not authorized" exception.
      NotFoundException(Response response)
      Construct a new "not found" exception.
      NotFoundException(Response response, Throwable cause)
      Construct a new "not found" exception.
      NotFoundException(String message, Response response)
      Construct a new "not found" exception.
      NotFoundException(String message, Response response, Throwable cause)
      Construct a new "not found" exception.
      NotSupportedException(Response response)
      Construct a new unsupported media type exception.
      NotSupportedException(Response response, Throwable cause)
      Construct a new unsupported media type exception.
      NotSupportedException(String message, Response response)
      Construct a new unsupported media type exception.
      NotSupportedException(String message, Response response, Throwable cause)
      Construct a new unsupported media type exception.
      RedirectionException(Response response)
      Construct a new redirection exception.
      RedirectionException(String message, Response response)
      Construct a new redirection exception.
      ServerErrorException(Response response)
      Construct a new server error exception.
      ServerErrorException(Response response, Throwable cause)
      Construct a new server error exception.
      ServerErrorException(String message, Response response)
      Construct a new server error exception.
      ServerErrorException(String message, Response response, Throwable cause)
      Construct a new server error exception.
      ServiceUnavailableException(Response response)
      Construct a new "service unavailable" exception.
      ServiceUnavailableException(Response response, Throwable cause)
      Construct a new "service unavailable" exception.
      ServiceUnavailableException(String message, Response response)
      Construct a new "service unavailable" exception.
      ServiceUnavailableException(String message, Response response, Throwable cause)
      Construct a new "service unavailable" exception.
      WebApplicationException(Response response)
      Construct a new instance using the supplied response.
      WebApplicationException(String message, Response response)
      Construct a new instance using the supplied response.
      WebApplicationException(String message, Throwable cause, Response response)
      Construct a new instance using the supplied response.
      WebApplicationException(Throwable cause, Response response)
      Construct a new instance using the supplied response.

    • Uses of Response in javax.ws.rs.client

      Methods in javax.ws.rs.client that return Response
      Modifier and Type Method and Description
      Response SyncInvoker.delete()
      Invoke HTTP DELETE method for the current request synchronously.
      Response SyncInvoker.get()
      Invoke HTTP GET method for the current request synchronously.
      Response ResponseProcessingException.getResponse()
      Get the HTTP response for which the processing has failed.
      Response SyncInvoker.head()
      Invoke HTTP HEAD method for the current request synchronously.
      Response Invocation.invoke()
      Synchronously invoke the request and receive a response back.
      Response SyncInvoker.method(String name)
      Invoke an arbitrary method for the current request synchronously.
      Response SyncInvoker.method(String name, Entity<?> entity)
      Invoke an arbitrary method for the current request synchronously.
      Response SyncInvoker.options()
      Invoke HTTP OPTIONS method for the current request synchronously.
      Response SyncInvoker.post(Entity<?> entity)
      Invoke HTTP POST method for the current request synchronously.
      Response SyncInvoker.put(Entity<?> entity)
      Invoke HTTP PUT method for the current request synchronously.
      Response SyncInvoker.trace()
      Invoke HTTP TRACE method for the current request synchronously.
      Methods in javax.ws.rs.client that return types with arguments of type Response
      Modifier and Type Method and Description
      Future<Response> AsyncInvoker.delete()
      Invoke HTTP DELETE method for the current request asynchronously.
      Future<Response> AsyncInvoker.get()
      Invoke HTTP GET method for the current request asynchronously.
      Future<Response> AsyncInvoker.head()
      Invoke HTTP HEAD method for the current request asynchronously.
      Future<Response> AsyncInvoker.head(InvocationCallback<Response> callback)
      Invoke HTTP HEAD method for the current request asynchronously.
      Future<Response> AsyncInvoker.method(String name)
      Invoke an arbitrary method for the current request asynchronously.
      Future<Response> AsyncInvoker.method(String name, Entity<?> entity)
      Invoke an arbitrary method for the current request asynchronously.
      Future<Response> AsyncInvoker.options()
      Invoke HTTP OPTIONS method for the current request asynchronously.
      Future<Response> AsyncInvoker.post(Entity<?> entity)
      Invoke HTTP POST method for the current request asynchronously.
      Future<Response> AsyncInvoker.put(Entity<?> entity)
      Invoke HTTP PUT method for the current request asynchronously.
      Future<Response> Invocation.submit()
      Submit the request for an asynchronous invocation and receive a future response back.
      Future<Response> AsyncInvoker.trace()
      Invoke HTTP TRACE method for the current request asynchronously.
      Methods in javax.ws.rs.client with parameters of type Response
      Modifier and Type Method and Description
      void ClientRequestContext.abortWith(Response response)
      Abort the filter chain with a response.
      Method parameters in javax.ws.rs.client with type arguments of type Response
      Modifier and Type Method and Description
      Future<Response> AsyncInvoker.head(InvocationCallback<Response> callback)
      Invoke HTTP HEAD method for the current request asynchronously.
      Constructors in javax.ws.rs.client with parameters of type Response
      Constructor and Description
      ResponseProcessingException(Response response, String message)
      Constructs a new JAX-RS runtime processing exception with the specified detail message.
      ResponseProcessingException(Response response, String message, Throwable cause)
      Constructs a new JAX-RS runtime response processing exception with the specified detail message and cause.
      ResponseProcessingException(Response response, Throwable cause)
      Constructs a new JAX-RS runtime response processing exception for a specific response with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Uses of Response in javax.ws.rs.container

      Methods in javax.ws.rs.container with parameters of type Response
      Modifier and Type Method and Description
      void ContainerRequestContext.abortWith(Response response)
      Abort the filter chain with a response.

    • Uses of Response in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Response
      Modifier and Type Method and Description
      abstract Response Response.ResponseBuilder.build()
      Create a Response instance from the current ResponseBuilder.
      Methods in javax.ws.rs.core with parameters of type Response
      Modifier and Type Method and Description
      static Response.ResponseBuilder Response.fromResponse(Response response)
      Create a new ResponseBuilder by performing a shallow copy of an existing Response.

    • Uses of Response in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return Response
      Modifier and Type Method and Description
      Response ExceptionMapper.toResponse(E exception)
      Map an exception to a Response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Response.ResponseBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Response.ResponseBuilder

  • Packages that use Response.ResponseBuilder
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of Response.ResponseBuilder in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Response.ResponseBuilder
      Modifier and Type | Method and Description
      static Response.ResponseBuilder Response.accepted()
      Create a new ResponseBuilder with an ACCEPTED status.
      static Response.ResponseBuilder Response.accepted(Object entity)
      Create a new ResponseBuilder with an ACCEPTED status that contains a representation.
      abstract Response.ResponseBuilder Response.ResponseBuilder.allow(Set<String> methods)
      Set the list of allowed methods for the resource.
      abstract Response.ResponseBuilder Response.ResponseBuilder.allow(String... methods)
      Set the list of allowed methods for the resource.
      abstract Response.ResponseBuilder Response.ResponseBuilder.cacheControl(CacheControl cacheControl)
      Set the cache control data of the message.
      abstract Response.ResponseBuilder | Response.ResponseBuilder.clone()
      abstract Response.ResponseBuilder Response.ResponseBuilder.contentLocation(URI location)
      Set the content location.
      abstract Response.ResponseBuilder Response.ResponseBuilder.cookie(NewCookie... cookies)
      Add cookies to the response message.
      static Response.ResponseBuilder Response.created(URI location)
      Create a new ResponseBuilder for a created resource, set the location header using the supplied value.
      abstract Response.ResponseBuilder Response.ResponseBuilder.encoding(String encoding)
      Set the message entity content encoding.
      abstract Response.ResponseBuilder Response.ResponseBuilder.entity(Object entity)
      Set the response entity in the builder.
      abstract Response.ResponseBuilder Response.ResponseBuilder.entity(Object entity, Annotation[] annotations)
      Set the response entity in the builder.
      Response.ResponseBuilder Request.evaluatePreconditions()
      Evaluate request preconditions for a resource that does not currently exist.
      Response.ResponseBuilder Request.evaluatePreconditions(Date lastModified)
      Evaluate request preconditions based on the passed in value.
      Response.ResponseBuilder Request.evaluatePreconditions(Date lastModified, EntityTag eTag)
      Evaluate request preconditions based on the passed in value.
      Response.ResponseBuilder Request.evaluatePreconditions(EntityTag eTag)
      Evaluate request preconditions based on the passed in value.
      abstract Response.ResponseBuilder Response.ResponseBuilder.expires(Date expires)
      Set the response expiration date.
      static Response.ResponseBuilder Response.fromResponse(Response response)
      Create a new ResponseBuilder by performing a shallow copy of an existing Response.
      abstract Response.ResponseBuilder Response.ResponseBuilder.header(String name, Object value)
      Add an arbitrary header.
      abstract Response.ResponseBuilder Response.ResponseBuilder.language(Locale language)
      Set the message entity language.
      abstract Response.ResponseBuilder Response.ResponseBuilder.language(String language)
      Set the message entity language.
      abstract Response.ResponseBuilder Response.ResponseBuilder.lastModified(Date lastModified)
      Set the response entity last modification date.
      abstract Response.ResponseBuilder Response.ResponseBuilder.link(String uri, String rel)
      Add a link header.
      abstract Response.ResponseBuilder Response.ResponseBuilder.link(URI uri, String rel)
      Add a link header.
      abstract Response.ResponseBuilder Response.ResponseBuilder.links(Link... links)
      Add one or more link headers.
      abstract Response.ResponseBuilder Response.ResponseBuilder.location(URI location)
      Set the location.
      protected static Response.ResponseBuilder Response.ResponseBuilder.newInstance()
      Create a new builder instance.
      static Response.ResponseBuilder Response.noContent()
      Create a new ResponseBuilder for an empty response.
      static Response.ResponseBuilder Response.notAcceptable(List<Variant> variants)
      Create a new ResponseBuilder for a not acceptable response.
      static Response.ResponseBuilder Response.notModified()
      Create a new ResponseBuilder with a not-modified status.
      static Response.ResponseBuilder Response.notModified(EntityTag tag)
      Create a new ResponseBuilder with a not-modified status.
      static Response.ResponseBuilder Response.notModified(String tag)
      Create a new ResponseBuilder with a not-modified status and a strong entity tag.
      static Response.ResponseBuilder Response.ok()
      Create a new ResponseBuilder with an OK status.
      static Response.ResponseBuilder Response.ok(Object entity)
      Create a new ResponseBuilder that contains a representation.
      static Response.ResponseBuilder Response.ok(Object entity, MediaType type)
      Create a new ResponseBuilder that contains a representation.
      static Response.ResponseBuilder Response.ok(Object entity, String type)
      Create a new ResponseBuilder that contains a representation.
      static Response.ResponseBuilder Response.ok(Object entity, Variant variant)
      Create a new ResponseBuilder that contains a representation.
      abstract Response.ResponseBuilder Response.ResponseBuilder.replaceAll(MultivaluedMap<String,Object> headers)
      Replaces all existing headers with the newly supplied headers.
      static Response.ResponseBuilder Response.seeOther(URI location)
      Create a new ResponseBuilder for a redirection.
      static Response.ResponseBuilder Response.serverError()
      Create a new ResponseBuilder with an server error status.
      static Response.ResponseBuilder Response.status(int status)
      Create a new ResponseBuilder with the supplied status.
      abstract Response.ResponseBuilder Response.ResponseBuilder.status(int status)
      Set the status on the ResponseBuilder.
      static Response.ResponseBuilder Response.status(Response.Status status)
      Create a new ResponseBuilder with the supplied status.
      Response.ResponseBuilder Response.ResponseBuilder.status(Response.Status status)
      Set the status on the ResponseBuilder.
      static Response.ResponseBuilder Response.status(Response.StatusType status)
      Create a new ResponseBuilder with the supplied status.
      Response.ResponseBuilder Response.ResponseBuilder.status(Response.StatusType status)
      Set the status on the ResponseBuilder.
      abstract Response.ResponseBuilder Response.ResponseBuilder.tag(EntityTag tag)
      Set a response entity tag.
      abstract Response.ResponseBuilder Response.ResponseBuilder.tag(String tag)
      Set a strong response entity tag.
      static Response.ResponseBuilder Response.temporaryRedirect(URI location)
      Create a new ResponseBuilder for a temporary redirection.
      abstract Response.ResponseBuilder Response.ResponseBuilder.type(MediaType type)
      Set the message entity media type.
      abstract Response.ResponseBuilder Response.ResponseBuilder.type(String type)
      Set the message entity media type.
      abstract Response.ResponseBuilder Response.ResponseBuilder.variant(Variant variant)
      Set message entity representation metadata.
      abstract Response.ResponseBuilder Response.ResponseBuilder.variants(List<Variant> variants)
      Add a Vary header that lists the available variants.
      abstract Response.ResponseBuilder Response.ResponseBuilder.variants(Variant... variants)
      Add a Vary header that lists the available variants.

    • Uses of Response.ResponseBuilder in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return Response.ResponseBuilder
      Modifier and Type Method and Description
      abstract Response.ResponseBuilder RuntimeDelegate.createResponseBuilder()
      Create a new instance of a Response.ResponseBuilder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Response.Status (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Response.Status

  • Packages that use Response.Status
    Package Description
    javax.ws.rs
    High-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Response.Status in javax.ws.rs

      Constructors in javax.ws.rs with parameters of type Response.Status
      Constructor and Description
      ClientErrorException(Response.Status status)
      Construct a new client error exception.
      ClientErrorException(Response.Status status, Throwable cause)
      Construct a new client error exception.
      ClientErrorException(String message, Response.Status status)
      Construct a new client error exception.
      ClientErrorException(String message, Response.Status status, Throwable cause)
      Construct a new client error exception.
      RedirectionException(Response.Status status, URI location)
      Construct a new redirection exception.
      RedirectionException(String message, Response.Status status, URI location)
      Construct a new redirection exception.
      ServerErrorException(Response.Status status)
      Construct a new server error exception.
      ServerErrorException(Response.Status status, Throwable cause)
      Construct a new server error exception.
      ServerErrorException(String message, Response.Status status)
      Construct a new server error exception.
      ServerErrorException(String message, Response.Status status, Throwable cause)
      Construct a new server error exception.
      WebApplicationException(Response.Status status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(String message, Response.Status status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(String message, Throwable cause, Response.Status status)
      Construct a new instance with a blank message and specified HTTP status code.
      WebApplicationException(Throwable cause, Response.Status status)
      Construct a new instance with a blank message and specified HTTP status code.

    • Uses of Response.Status in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Response.Status
      Modifier and Type Method and Description
      static Response.Status Response.Status.fromStatusCode(int statusCode)
      Convert a numerical status code into the corresponding Status.
      static Response.Status Response.Status.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Response.Status[] Response.Status.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.ws.rs.core with parameters of type Response.Status
      Modifier and Type Method and Description
      static Response.ResponseBuilder Response.status(Response.Status status)
      Create a new ResponseBuilder with the supplied status.
      Response.ResponseBuilder Response.ResponseBuilder.status(Response.Status status)
      Set the status on the ResponseBuilder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Response.Status.Family (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Response.Status.Family

  • Packages that use Response.Status.Family
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Response.Status.Family in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Response.Status.Family
      Modifier and Type Method and Description
      static Response.Status.Family Response.Status.Family.familyOf(int statusCode)
      Get the response status family for the status code.
      Response.Status.Family Response.StatusType.getFamily()
      Get the class of status code.
      Response.Status.Family Response.Status.getFamily()
      Get the class of status code.
      static Response.Status.Family Response.Status.Family.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Response.Status.Family[] Response.Status.Family.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.UriBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.UriBuilder

  • Packages that use UriBuilder
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of UriBuilder in javax.ws.rs.client

      Methods in javax.ws.rs.client that return UriBuilder
      Modifier and Type Method and Description
      UriBuilder WebTarget.getUriBuilder()
      Get the URI builder initialized with the URI of the current resource target.
      Methods in javax.ws.rs.client with parameters of type UriBuilder
      Modifier and Type Method and Description
      WebTarget Client.target(UriBuilder uriBuilder)
      Build a new web resource target.

    • Uses of UriBuilder in javax.ws.rs.core

      Methods in javax.ws.rs.core that return UriBuilder
      Modifier and Type Method and Description
      abstract UriBuilder UriBuilder.clone()
      Create a copy of the UriBuilder preserving its state.
      abstract UriBuilder UriBuilder.fragment(String fragment)
      Set the URI fragment.
      static UriBuilder UriBuilder.fromLink(Link link)
      Create a new instance initialized from a Link.
      static UriBuilder UriBuilder.fromMethod(Class<?> resource, String method)
      Create a new instance representing a relative URI initialized from a Path-annotated method.
      static UriBuilder UriBuilder.fromPath(String path)
      Create a new instance representing a relative URI initialized from a URI path.
      static UriBuilder UriBuilder.fromResource(Class<?> resource)
      Create a new instance representing a relative URI initialized from a root resource class.
      static UriBuilder UriBuilder.fromUri(String uriTemplate)
      Create a new instance initialized from an existing URI.
      static UriBuilder UriBuilder.fromUri(URI uri)
      Create a new instance initialized from an existing URI.
      UriBuilder UriInfo.getAbsolutePathBuilder()
      Get the absolute path of the request in the form of a UriBuilder.
      UriBuilder UriInfo.getBaseUriBuilder()
      Get the base URI of the application in the form of a UriBuilder.
      UriBuilder UriInfo.getRequestUriBuilder()
      Get the absolute request URI in the form of a UriBuilder.
      abstract UriBuilder Link.getUriBuilder()
      Convenience method that returns a UriBuilder initialized with this link's underlying URI.
      abstract UriBuilder UriBuilder.host(String host)
      Set the URI host.
      abstract UriBuilder UriBuilder.matrixParam(String name, Object... values)
      Append a matrix parameter to the existing set of matrix parameters of the current final segment of the URI path.
      protected static UriBuilder UriBuilder.newInstance()
      Creates a new instance of UriBuilder.
      abstract UriBuilder UriBuilder.path(Class resource)
      Append the path from a Path-annotated class to the existing path.
      abstract UriBuilder UriBuilder.path(Class resource, String method)
      Append the path from a Path-annotated method to the existing path.
      abstract UriBuilder UriBuilder.path(Method method)
      Append the path from a Path-annotated method to the existing path.
      abstract UriBuilder UriBuilder.path(String path)
      Append path to the existing path.
      abstract UriBuilder UriBuilder.port(int port)
      Set the URI port.
      abstract UriBuilder UriBuilder.queryParam(String name, Object... values)
      Append a query parameter to the existing set of query parameters.
      abstract UriBuilder UriBuilder.replaceMatrix(String matrix)
      Set the matrix parameters of the current final segment of the current URI path.
      abstract UriBuilder UriBuilder.replaceMatrixParam(String name, Object... values)
      Replace the existing value(s) of a matrix parameter on the current final segment of the URI path.
      abstract UriBuilder UriBuilder.replacePath(String path)
      Set the URI path.
      abstract UriBuilder UriBuilder.replaceQuery(String query)
      Set the URI query string.
      abstract UriBuilder UriBuilder.replaceQueryParam(String name, Object... values)
      Replace the existing value(s) of a query parameter.
      abstract UriBuilder UriBuilder.resolveTemplate(String name, Object value)
      Resolve a URI template with a given name in this UriBuilder instance using a supplied value.
      abstract UriBuilder UriBuilder.resolveTemplate(String name, Object value, boolean encodeSlashInPath)
      Resolve a URI template with a given name in this UriBuilder instance using a supplied value.
      abstract UriBuilder UriBuilder.resolveTemplateFromEncoded(String name, Object value)
      Resolve a URI template with a given name in this UriBuilder instance using a supplied encoded value.
      abstract UriBuilder UriBuilder.resolveTemplates(Map<String,Object> templateValues)
      Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs.
      abstract UriBuilder UriBuilder.resolveTemplates(Map<String,Object> templateValues, boolean encodeSlashInPath)
      Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs.
      abstract UriBuilder UriBuilder.resolveTemplatesFromEncoded(Map<String,Object> templateValues)
      Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs.
      abstract UriBuilder UriBuilder.scheme(String scheme)
      Set the URI scheme.
      abstract UriBuilder UriBuilder.schemeSpecificPart(String ssp)
      Set the URI scheme-specific-part (see URI).
      abstract UriBuilder UriBuilder.segment(String... segments)
      Append path segments to the existing path.
      abstract UriBuilder UriBuilder.uri(String uriTemplate)
      Parses the uriTemplate string and copies the parsed components of the supplied URI to the UriBuilder replacing any existing values for those components.
      abstract UriBuilder UriBuilder.uri(URI uri)
      Copies the non-null components of the supplied URI to the UriBuilder replacing any existing values for those components.
      abstract UriBuilder UriBuilder.userInfo(String ui)
      Set the URI user-info.
      Methods in javax.ws.rs.core with parameters of type UriBuilder
      Modifier and Type Method and Description
      static Link.Builder Link.fromUriBuilder(UriBuilder uriBuilder)
      Create a new builder instance initialized from a URI builder.
      Link.Builder Link.Builder.uriBuilder(UriBuilder uriBuilder)
      Set underlying URI builder representing the URI template for the link being constructed.

    • Uses of UriBuilder in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return UriBuilder
      Modifier and Type Method and Description
      abstract UriBuilder RuntimeDelegate.createUriBuilder()
      Create a new instance of a UriBuilder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.UriBuilderException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.UriBuilderException

  • Packages that use UriBuilderException
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of UriBuilderException in javax.ws.rs.core

      Methods in javax.ws.rs.core that throw UriBuilderException
      Modifier and Type Method and Description
      abstract URI UriBuilder.build(Object... values)
      Build a URI, using the supplied values in order to replace any URI template parameters.
      abstract URI UriBuilder.build(Object[] values, boolean encodeSlashInPath)
      Build a URI, using the supplied values in order to replace any URI template parameters.
      abstract URI UriBuilder.buildFromEncoded(Object... values)
      Build a URI.
      abstract URI UriBuilder.buildFromEncodedMap(Map<String,?> values)
      Build a URI.
      abstract URI UriBuilder.buildFromMap(Map<String,?> values, boolean encodeSlashInPath)
      Build a URI.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Variant (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Variant

  • Packages that use Variant
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Variant in javax.ws.rs.client

      Methods in javax.ws.rs.client that return Variant
      Modifier and Type Method and Description
      Variant Entity.getVariant()
      Get entity variant information.
      Methods in javax.ws.rs.client with parameters of type Variant
      Modifier and Type Method and Description
      static <T> Entity<T> Entity.entity(T entity, Variant variant)
      Create an entity using a supplied content media type.
      static <T> Entity<T> Entity.entity(T entity, Variant variant, Annotation[] annotations)
      Create an entity using a supplied content media type.

    • Uses of Variant in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Variant
      Modifier and Type Method and Description
      Variant Request.selectVariant(List<Variant> variants)
      Select the representation variant that best matches the request.
      Methods in javax.ws.rs.core that return types with arguments of type Variant
      Modifier and Type Method and Description
      abstract List<Variant> Variant.VariantListBuilder.build()
      Add the current combination of metadata to the list of supported variants (provided the current combination of metadata is not empty) and build a list of representation variants from the current state of the builder.
      Methods in javax.ws.rs.core with parameters of type Variant
      Modifier and Type Method and Description
      static Response.ResponseBuilder Response.ok(Object entity, Variant variant)
      Create a new ResponseBuilder that contains a representation.
      abstract Response.ResponseBuilder Response.ResponseBuilder.variant(Variant variant)
      Set message entity representation metadata.
      abstract Response.ResponseBuilder Response.ResponseBuilder.variants(Variant... variants)
      Add a Vary header that lists the available variants.
      Method parameters in javax.ws.rs.core with type arguments of type Variant
      Modifier and Type Method and Description
      static Response.ResponseBuilder Response.notAcceptable(List<Variant> variants)
      Create a new ResponseBuilder for a not acceptable response.
      Variant Request.selectVariant(List<Variant> variants)
      Select the representation variant that best matches the request.
      abstract Response.ResponseBuilder Response.ResponseBuilder.variants(List<Variant> variants)
      Add a Vary header that lists the available variants.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.core.Variant.VariantListBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.core.Variant.VariantListBuilder

  • Packages that use Variant.VariantListBuilder
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of Variant.VariantListBuilder in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Variant.VariantListBuilder
      Modifier and Type Method and Description
      abstract Variant.VariantListBuilder Variant.VariantListBuilder.add()
      Add the current combination of metadata to the list of supported variants, after this method is called the current combination of metadata is emptied.
      static Variant.VariantListBuilder Variant.encodings(String... encodings)
      Create a Variant.VariantListBuilder initialized with a set of supported encodings.
      abstract Variant.VariantListBuilder Variant.VariantListBuilder.encodings(String... encodings)
      Set the encoding(s) for this variant.
      static Variant.VariantListBuilder Variant.languages(Locale... languages)
      Create a Variant.VariantListBuilder initialized with a set of supported languages.
      abstract Variant.VariantListBuilder Variant.VariantListBuilder.languages(Locale... languages)
      Set the language(s) for this variant.
      static Variant.VariantListBuilder Variant.mediaTypes(MediaType... mediaTypes)
      Create a Variant.VariantListBuilder initialized with a set of supported media types.
      abstract Variant.VariantListBuilder Variant.VariantListBuilder.mediaTypes(MediaType... mediaTypes)
      Set the media type(s) for this variant.
      static Variant.VariantListBuilder Variant.VariantListBuilder.newInstance()
      Create a new builder instance.

    • Uses of Variant.VariantListBuilder in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return Variant.VariantListBuilder
      Modifier and Type Method and Description
      abstract Variant.VariantListBuilder RuntimeDelegate.createVariantListBuilder()
      Create a new instance of a Variant.VariantListBuilder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.Configurable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.Configurable

  • Packages that use Configurable
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Configurable in javax.ws.rs.client

      Subinterfaces of Configurable in javax.ws.rs.client
      Modifier and Type Interface and Description
      interface  Client
      Client is the main entry point to the fluent API used to build and execute client requests in order to consume responses returned.
      interface  WebTarget
      A resource target identified by the resource URI.
      Classes in javax.ws.rs.client that implement Configurable
      Modifier and Type Class and Description
      class  ClientBuilder
      Main entry point to the client API used to bootstrap Client instances.

    • Uses of Configurable in javax.ws.rs.core

      Classes in javax.ws.rs.core with type parameters of type Configurable
      Modifier and Type Interface and Description
      interface  Configurable<C extends Configurable>
      Represents a client or server-side configurable context in JAX-RS.
      Subinterfaces of Configurable in javax.ws.rs.core
      Modifier and Type Interface and Description
      interface  FeatureContext
      A configurable context passed to Feature and DynamicFeature instances by JAX-RS runtime during the phase of their configuration.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.Configuration (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.Configuration

  • Packages that use Configuration
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Configuration in javax.ws.rs.client

      Methods in javax.ws.rs.client that return Configuration
      Modifier and Type Method and Description
      Configuration ClientRequestContext.getConfiguration()
      Get the immutable configuration of the request.
      Methods in javax.ws.rs.client with parameters of type Configuration
      Modifier and Type Method and Description
      static Client ClientBuilder.newClient(Configuration configuration)
      Create a new custom-configured Client instance using the default client builder implementation class provided by the JAX-RS implementation provider.
      abstract ClientBuilder ClientBuilder.withConfig(Configuration config)
      Set the internal configuration state to an externally provided configuration state.

    • Uses of Configuration in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Configuration
      Modifier and Type Method and Description
      Configuration Configurable.getConfiguration()
      Get a live view of an internal configuration state of this configurable instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.Feature (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.Feature

  • Packages that use Feature
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Feature in javax.ws.rs.core

      Methods in javax.ws.rs.core with parameters of type Feature
      Modifier and Type Method and Description
      boolean Configuration.isEnabled(Feature feature)
      Check if a particular feature instance has been previously enabled in the runtime configuration context.
      Method parameters in javax.ws.rs.core with type arguments of type Feature
      Modifier and Type Method and Description
      boolean Configuration.isEnabled(Class<? extends Feature> featureClass)
      Check if a feature instance of featureClass class has been previously enabled in the runtime configuration context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.FeatureContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.FeatureContext

  • Packages that use FeatureContext
    Package Description
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of FeatureContext in javax.ws.rs.container

      Methods in javax.ws.rs.container with parameters of type FeatureContext
      Modifier and Type Method and Description
      void DynamicFeature.configure(ResourceInfo resourceInfo, FeatureContext context)
      A callback method called by the JAX-RS runtime during the application deployment to register provider instances or classes in a runtime configuration scope of a particular resource or sub-resource method; i.e.

    • Uses of FeatureContext in javax.ws.rs.core

      Methods in javax.ws.rs.core with parameters of type FeatureContext
      Modifier and Type Method and Description
      boolean Feature.configure(FeatureContext context)
      A call-back method called when the feature is to be enabled in a given runtime configuration scope.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.HttpHeaders (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.HttpHeaders

No usage of javax.ws.rs.core.HttpHeaders
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.Link.Builder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.Link.Builder

  • Packages that use Link.Builder
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of Link.Builder in javax.ws.rs.client

      Methods in javax.ws.rs.client that return Link.Builder
      Modifier and Type Method and Description
      Link.Builder ClientResponseContext.getLinkBuilder(String relation)
      Convenience method that returns a Link.Builder for the relation.

    • Uses of Link.Builder in javax.ws.rs.container

      Methods in javax.ws.rs.container that return Link.Builder
      Modifier and Type Method and Description
      Link.Builder ContainerResponseContext.getLinkBuilder(String relation)
      Convenience method that returns a Link.Builder for the relation.

    • Uses of Link.Builder in javax.ws.rs.core

      Methods in javax.ws.rs.core that return Link.Builder
      Modifier and Type Method and Description
      Link.Builder Link.Builder.baseUri(String uri)
      Set the base URI as a string for resolution of relative URIs.
      Link.Builder Link.Builder.baseUri(URI uri)
      Set the base URI for resolution of relative URIs.
      static Link.Builder Link.fromLink(Link link)
      Create a new builder instance initialized from another link.
      static Link.Builder Link.fromMethod(Class<?> resource, String method)
      Convenience method to build a link from a resource.
      static Link.Builder Link.fromPath(String path)
      Convenience method to build a link from a path.
      static Link.Builder Link.fromResource(Class<?> resource)
      Convenience method to build a link from a resource.
      static Link.Builder Link.fromUri(String uri)
      Create a new builder instance initialized from an existing URI represented as a string.
      static Link.Builder Link.fromUri(URI uri)
      Create a new builder instance initialized from an existing URI.
      static Link.Builder Link.fromUriBuilder(UriBuilder uriBuilder)
      Create a new builder instance initialized from a URI builder.
      abstract Link.Builder Response.getLinkBuilder(String relation)
      Convenience method that returns a Link.Builder for the relation.
      Link.Builder Link.Builder.link(Link link)
      Initialize builder using another link.
      Link.Builder Link.Builder.link(String link)
      Initialize builder using another link represented as a string.
      Link.Builder Link.Builder.param(String name, String value)
      Set an arbitrary parameter on this link.
      Link.Builder Link.Builder.rel(String rel)
      Convenience method to set a link relation.
      Link.Builder Link.Builder.title(String title)
      Convenience method to set a title on this link.
      Link.Builder Link.Builder.type(String type)
      Convenience method to set a type on this link.
      Link.Builder Link.Builder.uri(String uri)
      Set underlying string representing URI template for the link being constructed.
      Link.Builder Link.Builder.uri(URI uri)
      Set underlying URI template for the link being constructed.
      Link.Builder Link.Builder.uriBuilder(UriBuilder uriBuilder)
      Set underlying URI builder representing the URI template for the link being constructed.

    • Uses of Link.Builder in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return Link.Builder
      Modifier and Type Method and Description
      abstract Link.Builder RuntimeDelegate.createLinkBuilder()
      Create a new instance of a Link.Builder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.MultivaluedMap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.MultivaluedMap

  • Packages that use MultivaluedMap
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of MultivaluedMap in javax.ws.rs.client

      Methods in javax.ws.rs.client that return MultivaluedMap
      Modifier and Type Method and Description
      MultivaluedMap<String,String> ClientResponseContext.getHeaders()
      Get the mutable response headers multivalued map.
      MultivaluedMap<String,Object> ClientRequestContext.getHeaders()
      Get the mutable request headers multivalued map.
      MultivaluedMap<String,String> ClientRequestContext.getStringHeaders()
      Get a string view of header values associated with the message.
      Methods in javax.ws.rs.client with parameters of type MultivaluedMap
      Modifier and Type Method and Description
      static Entity<Form> Entity.form(MultivaluedMap<String,String> formData)
      Create an "application/x-www-form-urlencoded" form entity.
      Invocation.Builder Invocation.Builder.headers(MultivaluedMap<String,Object> headers)
      Replaces all existing headers with the newly supplied headers.

    • Uses of MultivaluedMap in javax.ws.rs.container

      Methods in javax.ws.rs.container that return MultivaluedMap
      Modifier and Type Method and Description
      MultivaluedMap<String,Object> ContainerResponseContext.getHeaders()
      Get the mutable response headers multivalued map.
      MultivaluedMap<String,String> ContainerRequestContext.getHeaders()
      Get the mutable request headers multivalued map.
      MultivaluedMap<String,String> ContainerResponseContext.getStringHeaders()
      Get a string view of header values associated with the message.

    • Uses of MultivaluedMap in javax.ws.rs.core

      Classes in javax.ws.rs.core that implement MultivaluedMap
      Modifier and Type Class and Description
      class  AbstractMultivaluedMap<K,V>
      Abstract skeleton implementation of a MultivaluedMap that is backed by a [key, multi-value] store represented as a Map<K, List<V>>.
      class  MultivaluedHashMap<K,V>
      A hash table based implementation of MultivaluedMap interface.
      Methods in javax.ws.rs.core that return MultivaluedMap
      Modifier and Type Method and Description
      MultivaluedMap<String,String> Form.asMap()
      Returns multivalued map representation of the form.
      MultivaluedMap<String,Object> Response.getHeaders()
      Get view of the response headers and their object values.
      MultivaluedMap<String,String> PathSegment.getMatrixParameters()
      Get a map of the matrix parameters associated with the path segment.
      abstract MultivaluedMap<String,Object> Response.getMetadata()
      See Response.getHeaders().
      MultivaluedMap<String,String> UriInfo.getPathParameters()
      Get the values of any embedded URI template parameters.
      MultivaluedMap<String,String> UriInfo.getPathParameters(boolean decode)
      Get the values of any embedded URI template parameters.
      MultivaluedMap<String,String> UriInfo.getQueryParameters()
      Get the URI query parameters of the current request.
      MultivaluedMap<String,String> UriInfo.getQueryParameters(boolean decode)
      Get the URI query parameters of the current request.
      MultivaluedMap<String,String> HttpHeaders.getRequestHeaders()
      Get the values of HTTP request headers.
      abstract MultivaluedMap<String,String> Response.getStringHeaders()
      Get view of the response headers and their string values.
      Methods in javax.ws.rs.core with parameters of type MultivaluedMap
      Modifier and Type | Method and Description
      boolean MultivaluedMap.equalsIgnoreValueOrder(MultivaluedMap<K,V> otherMap)
      Compare the specified map with this map for equality modulo the order of values for each key.
      boolean | AbstractMultivaluedMap.equalsIgnoreValueOrder(MultivaluedMap<K,V> omap)
      abstract Response.ResponseBuilder Response.ResponseBuilder.replaceAll(MultivaluedMap<String,Object> headers)
      Replaces all existing headers with the newly supplied headers.
      Constructors in javax.ws.rs.core with parameters of type MultivaluedMap
      Constructor and Description
      Form(MultivaluedMap<String,String> store)
      Create a new form data instance and register a custom underlying parameter store.
      MultivaluedHashMap(MultivaluedMap<? extends K,? extends V> map)
      Constructs a new multivalued hash map with the same mappings as the specified MultivaluedMap.

    • Uses of MultivaluedMap in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return MultivaluedMap
      Modifier and Type Method and Description
      MultivaluedMap<String,Object> WriterInterceptorContext.getHeaders()
      Get mutable map of HTTP headers.
      MultivaluedMap<String,String> ReaderInterceptorContext.getHeaders()
      Get mutable map of HTTP headers.
      Methods in javax.ws.rs.ext with parameters of type MultivaluedMap
      Modifier and Type Method and Description
      T MessageBodyReader.readFrom(Class<T> type, Type genericType, Annotation[] annotations, MediaType mediaType, MultivaluedMap<String,String> httpHeaders, InputStream entityStream)
      Read a type from the InputStream.
      void MessageBodyWriter.writeTo(T t, Class<?> type, Type genericType, Annotation[] annotations, MediaType mediaType, MultivaluedMap<String,Object> httpHeaders, OutputStream entityStream)
      Write a type to an HTTP message.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.PathSegment (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.PathSegment

  • Packages that use PathSegment
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of PathSegment in javax.ws.rs.core

      Methods in javax.ws.rs.core that return types with arguments of type PathSegment
      Modifier and Type Method and Description
      List<PathSegment> UriInfo.getPathSegments()
      Get the path of the current request relative to the base URI as a list of PathSegment.
      List<PathSegment> UriInfo.getPathSegments(boolean decode)
      Get the path of the current request relative to the base URI as a list of PathSegment.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.Request (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.Request

  • Packages that use Request
    Package Description
    javax.ws.rs.container
    Container-specific JAX-RS API.

    • Uses of Request in javax.ws.rs.container

      Methods in javax.ws.rs.container that return Request
      Modifier and Type Method and Description
      Request ContainerRequestContext.getRequest()
      Get the injectable request information.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.Response.StatusType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.Response.StatusType

  • Packages that use Response.StatusType
    Package Description
    javax.ws.rs.client
    The JAX-RS client API
    javax.ws.rs.container
    Container-specific JAX-RS API.
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of Response.StatusType in javax.ws.rs.client

      Methods in javax.ws.rs.client that return Response.StatusType
      Modifier and Type Method and Description
      Response.StatusType ClientResponseContext.getStatusInfo()
      Get the complete status information associated with the response.
      Methods in javax.ws.rs.client with parameters of type Response.StatusType
      Modifier and Type Method and Description
      void ClientResponseContext.setStatusInfo(Response.StatusType statusInfo)
      Set the complete status information (status code and reason phrase) associated with the response.

    • Uses of Response.StatusType in javax.ws.rs.container

      Methods in javax.ws.rs.container that return Response.StatusType
      Modifier and Type Method and Description
      Response.StatusType ContainerResponseContext.getStatusInfo()
      Get the complete status information associated with the response.
      Methods in javax.ws.rs.container with parameters of type Response.StatusType
      Modifier and Type Method and Description
      void ContainerResponseContext.setStatusInfo(Response.StatusType statusInfo)
      Set the complete status information (status code and reason phrase) associated with the response.

    • Uses of Response.StatusType in javax.ws.rs.core

      Classes in javax.ws.rs.core that implement Response.StatusType
      Modifier and Type Class and Description
      static class  Response.Status
      Commonly used status codes defined by HTTP, see HTTP/1.1 documentation for the complete list.
      Methods in javax.ws.rs.core that return Response.StatusType
      Modifier and Type Method and Description
      abstract Response.StatusType Response.getStatusInfo()
      Get the complete status information associated with the response.
      Methods in javax.ws.rs.core with parameters of type Response.StatusType
      Modifier and Type Method and Description
      static Response.ResponseBuilder Response.status(Response.StatusType status)
      Create a new ResponseBuilder with the supplied status.
      Response.ResponseBuilder Response.ResponseBuilder.status(Response.StatusType status)
      Set the status on the ResponseBuilder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.SecurityContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.SecurityContext

  • Packages that use SecurityContext
    Package Description
    javax.ws.rs.container
    Container-specific JAX-RS API.

    • Uses of SecurityContext in javax.ws.rs.container

      Methods in javax.ws.rs.container that return SecurityContext
      Modifier and Type Method and Description
      SecurityContext ContainerRequestContext.getSecurityContext()
      Get the injectable security context information for the current request.
      Methods in javax.ws.rs.container with parameters of type SecurityContext
      Modifier and Type Method and Description
      void ContainerRequestContext.setSecurityContext(SecurityContext context)
      Set a new injectable security context information for the current request.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.StreamingOutput (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.StreamingOutput

No usage of javax.ws.rs.core.StreamingOutput
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.core.UriInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.core.UriInfo

  • Packages that use UriInfo
    Package Description
    javax.ws.rs.container
    Container-specific JAX-RS API.

    • Uses of UriInfo in javax.ws.rs.container

      Methods in javax.ws.rs.container that return UriInfo
      Modifier and Type Method and Description
      UriInfo ContainerRequestContext.getUriInfo()
      Get request URI information.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ContextResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface ContextResolver<T>

  • Type Parameters:
    T - type of the context

    public interface ContextResolver<T>
    Contract for a provider that supplies context information to resource classes and other providers. A ContextResolver implementation may be annotated with Produces to restrict the media types for which it will be considered suitable.

    Providers implementing ContextResolver contract must be either programmatically registered in a JAX-RS runtime or must be annotated with @Provider annotation to be automatically discovered by the JAX-RS runtime during a provider scanning phase.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Context, Providers.getContextResolver(Class, javax.ws.rs.core.MediaType), Provider, Produces

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T getContext(Class<?> type)
      Get a context of type T that is applicable to the supplied type.

    • Method Detail

      • getContext

        T getContext(Class<?> type)
        Get a context of type T that is applicable to the supplied type.
        Parameters:
        type - the class of object for which a context is desired
        Returns:
        a context for the supplied type or null if a context for the supplied type is not available from this provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExceptionMapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface ExceptionMapper<E extends Throwable>

  • Type Parameters:
    E - exception type supported by the provider.

    public interface ExceptionMapper<E extends Throwable>
    Contract for a provider that maps Java exceptions to Response.

    Providers implementing ExceptionMapper contract must be either programmatically registered in a JAX-RS runtime or must be annotated with @Provider annotation to be automatically discovered by the JAX-RS runtime during a provider scanning phase.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Provider, Response

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Response toResponse(E exception)
      Map an exception to a Response.

    • Method Detail

      • toResponse

        Response toResponse(E exception)
        Map an exception to a Response. Returning null results in a Response.Status.NO_CONTENT response. Throwing a runtime exception results in a Response.Status.INTERNAL_SERVER_ERROR response.
        Parameters:
        exception - the exception to map to a response.
        Returns:
        a response mapped from the supplied exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InterceptorContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface InterceptorContext

  • All Known Subinterfaces:
    ReaderInterceptorContext, WriterInterceptorContext

    public interface InterceptorContext
    Context shared by message body interceptors that can be used to wrap calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream) and MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream). The getters and setters in this context class correspond to the parameters in the aforementioned methods.
    Since:
    2.0
    Author:
    Santiago Pericas-Geertsen, Bill Burke
    See Also:
    ReaderInterceptor, WriterInterceptor, ReaderInterceptorContext, WriterInterceptorContext

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Annotation[] getAnnotations()
      Get an array of the annotations formally declared on the artifact that initiated the intercepted entity provider invocation.
      Type getGenericType()
      Get the type of the object to be produced or written.
      MediaType getMediaType()
      Get media type of HTTP entity.
      Object getProperty(String name)
      Returns the property with the given name registered in the current request/response exchange context, or null if there is no property by that name.
      Collection<String> getPropertyNames()
      Returns an immutable collection containing the property names available within the context of the current request/response exchange context.
      Class<?> getType()
      Get Java type supported by corresponding message body provider.
      void removeProperty(String name)
      Removes a property with the given name from the current request/response exchange context.
      void setAnnotations(Annotation[] annotations)
      Update annotations on the formal declaration of the artifact that initiated the intercepted entity provider invocation.
      void setGenericType(Type genericType)
      Update type of the object to be produced or written.
      void setMediaType(MediaType mediaType)
      Update media type of HTTP entity.
      void setProperty(String name, Object object)
      Binds an object to a given property name in the current request/response exchange context.
      void setType(Class<?> type)
      Update Java type before calling message body provider.

    • Method Detail

      • getProperty

        Object getProperty(String name)
        Returns the property with the given name registered in the current request/response exchange context, or null if there is no property by that name.

        A property allows a JAX-RS filters and interceptors to exchange additional custom information not already provided by this interface.

        A list of supported properties can be retrieved using getPropertyNames(). Custom property names should follow the same convention as package names.

        In a Servlet container, on the server side, the properties are backed by the ServletRequest and contain all the attributes available in the ServletRequest.

        Parameters:
        name - a String specifying the name of the property.
        Returns:
        an Object containing the value of the property, or null if no property exists matching the given name.
        See Also:
        getPropertyNames()

      • getPropertyNames

        Collection<String> getPropertyNames()
        Returns an immutable collection containing the property names available within the context of the current request/response exchange context.

        Use the getProperty(java.lang.String) method with a property name to get the value of a property.

        In a Servlet container, the properties are synchronized with the ServletRequest and expose all the attributes available in the ServletRequest. Any modifications of the properties are also reflected in the set of properties of the associated ServletRequest.

        Returns:
        an immutable collection of property names.
        See Also:
        getProperty(java.lang.String)

      • setProperty

        void setProperty(String name,
               Object object)
        Binds an object to a given property name in the current request/response exchange context. If the name specified is already used for a property, this method will replace the value of the property with the new value.

        A property allows a JAX-RS filters and interceptors to exchange additional custom information not already provided by this interface.

        A list of supported properties can be retrieved using getPropertyNames(). Custom property names should follow the same convention as package names.

        If a null value is passed, the effect is the same as calling the removeProperty(String) method.

        In a Servlet container, on the server side, the properties are backed by the ServletRequest and contain all the attributes available in the ServletRequest.

        Parameters:
        name - a String specifying the name of the property.
        object - an Object representing the property to be bound.

      • removeProperty

        void removeProperty(String name)
        Removes a property with the given name from the current request/response exchange context. After removal, subsequent calls to getProperty(java.lang.String) to retrieve the property value will return null.

        In a Servlet container, on the server side, the properties are backed by the ServletRequest and contain all the attributes available in the ServletRequest.

        Parameters:
        name - a String specifying the name of the property to be removed.

      • getAnnotations

        Annotation[] getAnnotations()
        Get an array of the annotations formally declared on the artifact that initiated the intercepted entity provider invocation. E.g. if the message body is to be converted into a method parameter, this will be the annotations on that parameter returned by Method.getParameterAnnotations(); if the server-side response entity instance is to be converted into an output stream, this will be the annotations on the matched resource method returned by Method.getAnnotations(). This method may return an empty array in case the interceptor is not invoked in a context of any particular resource method (e.g. as part of the client API), but will never return null.
        Returns:
        annotations declared on the artifact that initiated the intercepted entity provider invocation.

      • setAnnotations

        void setAnnotations(Annotation[] annotations)
        Update annotations on the formal declaration of the artifact that initiated the intercepted entity provider invocation. Calling this method has no effect in the client API.
        Parameters:
        annotations - updated annotations declarataion of the artifact that initiated the intercepted entity provider invocation. Must not be null.
        Throws:
        NullPointerException - in case the input parameter is null.

      • getType

        Class<?> getType()
        Get Java type supported by corresponding message body provider.
        Returns:
        java type supported by provider

      • setType

        void setType(Class<?> type)
        Update Java type before calling message body provider.
        Parameters:
        type - java type for provider

      • getGenericType

        Type getGenericType()
        Get the type of the object to be produced or written.
        Returns:
        type of object produced or written

      • setGenericType

        void setGenericType(Type genericType)
        Update type of the object to be produced or written.
        Parameters:
        genericType - new type for object

      • getMediaType

        MediaType getMediaType()
        Get media type of HTTP entity.
        Returns:
        media type of HTTP entity

      • setMediaType

        void setMediaType(MediaType mediaType)
        Update media type of HTTP entity.
        Parameters:
        mediaType - new type for HTTP entity
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.ws.rs.ext (Java(TM) EE 7 Specification APIs)

javax.ws.rs.ext

Interfaces

  • ContextResolver
  • ExceptionMapper
  • InterceptorContext
  • MessageBodyReader
  • MessageBodyWriter
  • ParamConverter
  • ParamConverterProvider
  • Providers
  • ReaderInterceptor
  • ReaderInterceptorContext
  • RuntimeDelegate.HeaderDelegate
  • WriterInterceptor
  • WriterInterceptorContext

Classes

  • RuntimeDelegate

Annotation Types

  • ParamConverter.Lazy
  • Provider


javax.ws.rs.ext (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.ws.rs.ext

APIs that provide extensions to the types supported by the JAX-RS API.

See: Description

  • Interface Summary
    Interface Description
    ContextResolver<T>
    Contract for a provider that supplies context information to resource classes and other providers.
    ExceptionMapper<E extends Throwable>
    Contract for a provider that maps Java exceptions to Response.
    InterceptorContext
    Context shared by message body interceptors that can be used to wrap calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream) and MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream).
    MessageBodyReader<T>
    Contract for a provider that supports the conversion of a stream to a Java type.
    MessageBodyWriter<T>
    Contract for a provider that supports the conversion of a Java type to a stream.
    ParamConverter<T>
    Defines a contract for a delegate responsible for converting between a String form of a message parameter value and the corresponding custom Java type T.
    ParamConverterProvider
    Contract for a provider of ParamConverter instances.
    Providers
    An injectable interface providing runtime lookup of provider instances.
    ReaderInterceptor
    Interface for message body reader interceptors that wrap around calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream).
    ReaderInterceptorContext
    Context class used by ReaderInterceptor to intercept calls to (@link javax.ws.rs.ext.MessageBodyReader#readFrom}.
    RuntimeDelegate.HeaderDelegate<T>
    Defines the contract for a delegate that is responsible for converting between the String form of a HTTP header and the corresponding JAX-RS type T.
    WriterInterceptor
    Interface for message body writer interceptors that wrap around calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream).
    WriterInterceptorContext
    Context class used by WriterInterceptor to intercept calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream).
  • Class Summary
    Class Description
    RuntimeDelegate
    Implementations of JAX-RS provide a concrete subclass of RuntimeDelegate and various JAX-RS API methods defer to methods of RuntimeDelegate for their functionality.
  • Annotation Types Summary
    Annotation Type Description
    ParamConverter.Lazy
    Mandates that a conversion of any default value delegated to a parameter converter annotated with @Lazy annotation SHOULD occur only once the value is actually required (e.g.
    Provider
    Marks an implementation of an extension interface that should be discoverable by JAX-RS runtime during a provider scanning phase.

Package javax.ws.rs.ext Description

APIs that provide extensions to the types supported by the JAX-RS API.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.ws.rs.ext Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.ws.rs.ext

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.ws.rs.ext.RuntimeDelegate

Interface Hierarchy

  • javax.ws.rs.ext.ContextResolver<T>
  • javax.ws.rs.ext.ExceptionMapper<E>
  • javax.ws.rs.ext.InterceptorContext
    • javax.ws.rs.ext.ReaderInterceptorContext
    • javax.ws.rs.ext.WriterInterceptorContext
  • javax.ws.rs.ext.MessageBodyReader<T>
  • javax.ws.rs.ext.MessageBodyWriter<T>
  • javax.ws.rs.ext.ParamConverter<T>
  • javax.ws.rs.ext.ParamConverterProvider
  • javax.ws.rs.ext.Providers
  • javax.ws.rs.ext.ReaderInterceptor
  • javax.ws.rs.ext.RuntimeDelegate.HeaderDelegate<T>
  • javax.ws.rs.ext.WriterInterceptor

Annotation Type Hierarchy

  • javax.ws.rs.ext.Provider (implements java.lang.annotation.Annotation)
  • javax.ws.rs.ext.ParamConverter.Lazy (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MessageBodyReader (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface MessageBodyReader<T>

  • Type Parameters:
    T - Java type supported by the provider

    public interface MessageBodyReader<T>
    Contract for a provider that supports the conversion of a stream to a Java type. A MessageBodyReader implementation may be annotated with Consumes to restrict the media types for which it will be considered suitable.

    Providers implementing MessageBodyReader contract must be either programmatically registered in a JAX-RS runtime or must be annotated with @Provider annotation to be automatically discovered by the JAX-RS runtime during a provider scanning phase.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Provider, Consumes

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isReadable(Class<?> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Ascertain if the MessageBodyReader can produce an instance of a particular type.
      T readFrom(Class<T> type, Type genericType, Annotation[] annotations, MediaType mediaType, MultivaluedMap<String,String> httpHeaders, InputStream entityStream)
      Read a type from the InputStream.

    • Method Detail

      • isReadable

        boolean isReadable(Class<?> type,
                 Type genericType,
                 Annotation[] annotations,
                 MediaType mediaType)
        Ascertain if the MessageBodyReader can produce an instance of a particular type. The type parameter gives the class of the instance that should be produced, the genericType parameter gives the java.lang.reflect.Type of the instance that should be produced. E.g. if the instance to be produced is List<String>, the type parameter will be java.util.List and the genericType parameter will be java.lang.reflect.ParameterizedType.
        Parameters:
        type - the class of instance to be produced.
        genericType - the type of instance to be produced. E.g. if the message body is to be converted into a method parameter, this will be the formal type of the method parameter as returned by Method.getGenericParameterTypes.
        annotations - an array of the annotations on the declaration of the artifact that will be initialized with the produced instance. E.g. if the message body is to be converted into a method parameter, this will be the annotations on that parameter returned by Method.getParameterAnnotations.
        mediaType - the media type of the HTTP entity, if one is not specified in the request then application/octet-stream is used.
        Returns:
        true if the type is supported, otherwise false.

      • readFrom

        T readFrom(Class<T> type,
         Type genericType,
         Annotation[] annotations,
         MediaType mediaType,
         MultivaluedMap<String,String> httpHeaders,
         InputStream entityStream)
           throws IOException,
                  WebApplicationException
        Read a type from the InputStream.

        In case the entity input stream is empty, the reader is expected to either return a Java representation of a zero-length entity or throw a NoContentException in case no zero-length entity representation is defined for the supported Java type. A NoContentException, if thrown by a message body reader while reading a server request entity, is automatically translated by JAX-RS server runtime into a BadRequestException wrapping the original NoContentException and rethrown for a standard processing by the registered exception mappers.

        Parameters:
        type - the type that is to be read from the entity stream.
        genericType - the type of instance to be produced. E.g. if the message body is to be converted into a method parameter, this will be the formal type of the method parameter as returned by Method.getGenericParameterTypes.
        annotations - an array of the annotations on the declaration of the artifact that will be initialized with the produced instance. E.g. if the message body is to be converted into a method parameter, this will be the annotations on that parameter returned by Method.getParameterAnnotations.
        mediaType - the media type of the HTTP entity.
        httpHeaders - the read-only HTTP headers associated with HTTP entity.
        entityStream - the InputStream of the HTTP entity. The caller is responsible for ensuring that the input stream ends when the entity has been consumed. The implementation should not close the input stream.
        Returns:
        the type that was read from the stream. In case the entity input stream is empty, the reader is expected to either return an instance representing a zero-length entity or throw a NoContentException in case no zero-length entity representation is defined for the supported Java type.
        Throws:
        IOException - if an IO error arises. In case the entity input stream is empty and the reader is not able to produce a Java representation for a zero-length entity, NoContentException is expected to be thrown.
        WebApplicationException - if a specific HTTP error response needs to be produced. Only effective if thrown prior to the response being committed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageBodyWriter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface MessageBodyWriter<T>

  • Type Parameters:
    T - the type that can be written.

    public interface MessageBodyWriter<T>
    Contract for a provider that supports the conversion of a Java type to a stream. A MessageBodyWriter implementation may be annotated with Produces to restrict the media types for which it will be considered suitable.

    Providers implementing MessageBodyWriter contract must be either programmatically registered in a JAX-RS runtime or must be annotated with @Provider annotation to be automatically discovered by the JAX-RS runtime during a provider scanning phase.

    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Provider, Produces

    • Method Summary

      Methods
      Modifier and Type Method and Description
      long getSize(T t, Class<?> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Originally, the method has been called before writeTo to ascertain the length in bytes of the serialized form of t.
      boolean isWriteable(Class<?> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Ascertain if the MessageBodyWriter supports a particular type.
      void writeTo(T t, Class<?> type, Type genericType, Annotation[] annotations, MediaType mediaType, MultivaluedMap<String,Object> httpHeaders, OutputStream entityStream)
      Write a type to an HTTP message.

    • Method Detail

      • isWriteable

        boolean isWriteable(Class<?> type,
                  Type genericType,
                  Annotation[] annotations,
                  MediaType mediaType)
        Ascertain if the MessageBodyWriter supports a particular type.
        Parameters:
        type - the class of instance that is to be written.
        genericType - the type of instance to be written, obtained either by reflection of a resource method return type or via inspection of the returned instance. GenericEntity provides a way to specify this information at runtime.
        annotations - an array of the annotations attached to the message entity instance.
        mediaType - the media type of the HTTP entity.
        Returns:
        true if the type is supported, otherwise false.

      • getSize

        long getSize(T t,
           Class<?> type,
           Type genericType,
           Annotation[] annotations,
           MediaType mediaType)
        Originally, the method has been called before writeTo to ascertain the length in bytes of the serialized form of t. A non-negative return value has been used in a HTTP Content-Length header.

        As of JAX-RS 2.0, the method has been deprecated and the value returned by the method is ignored by a JAX-RS runtime. All MessageBodyWriter implementations are advised to return -1 from the method. Responsibility to compute the actual Content-Length header value has been delegated to JAX-RS runtime.

        Parameters:
        t - the instance to write
        type - the class of instance that is to be written.
        genericType - the type of instance to be written. GenericEntity provides a way to specify this information at runtime.
        annotations - an array of the annotations attached to the message entity instance.
        mediaType - the media type of the HTTP entity.
        Returns:
        length in bytes or -1 if the length cannot be determined in advance.

      • writeTo

        void writeTo(T t,
           Class<?> type,
           Type genericType,
           Annotation[] annotations,
           MediaType mediaType,
           MultivaluedMap<String,Object> httpHeaders,
           OutputStream entityStream)
             throws IOException,
                    WebApplicationException
        Write a type to an HTTP message. The message header map is mutable but any changes must be made before writing to the output stream since the headers will be flushed prior to writing the message body.
        Parameters:
        t - the instance to write.
        type - the class of instance that is to be written.
        genericType - the type of instance to be written. GenericEntity provides a way to specify this information at runtime.
        annotations - an array of the annotations attached to the message entity instance.
        mediaType - the media type of the HTTP entity.
        httpHeaders - a mutable map of the HTTP message headers.
        entityStream - the OutputStream for the HTTP entity. The implementation should not close the output stream.
        Throws:
        IOException - if an IO error arises.
        WebApplicationException - if a specific HTTP error response needs to be produced. Only effective if thrown prior to the message being committed.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ParamConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface ParamConverter<T>

  • Type Parameters:
    T - the supported Java type convertible to/from a String format.

    public interface ParamConverter<T>
    Defines a contract for a delegate responsible for converting between a String form of a message parameter value and the corresponding custom Java type T. Conversion of message parameter values injected via @PathParam, @QueryParam, @MatrixParam, @FormParam, @CookieParam and @HeaderParam is supported.

    By default, when used for injection of parameter values, a selected ParamConverter instance MUST be used eagerly by a JAX-RS runtime to convert any default value in the resource or provider model, that is during the application deployment, before any value – default or otherwise – is actually required. This conversion strategy ensures that any errors in the default values are reported as early as possible. This default behavior may be overridden by annotating the ParamConverter implementation class with a @Lazy annotation. In such case any default value conversion delegated to the @Lazy-annotated converter will be deferred to a latest possible moment (i.e. until the injection of such default value is required).

    NOTE: A service implementing this contract is not recognized as a registrable JAX-RS extension provider. Instead, a ParamConverterProvider instance responsible for providing ParamConverter instances has to be registered as one of the JAX-RS extension providers.

    Author:
    Marek Potociar

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  ParamConverter.Lazy
      Mandates that a conversion of any default value delegated to a parameter converter annotated with @Lazy annotation SHOULD occur only once the value is actually required (e.g.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T fromString(String value)
      Parse the supplied value and create an instance of T.
      String toString(T value)
      Convert the supplied value to a String.

    • Method Detail

      • fromString

        T fromString(String value)
        Parse the supplied value and create an instance of T.
        Parameters:
        value - the string value.
        Returns:
        the newly created instance of T.
        Throws:
        IllegalArgumentException - if the supplied string cannot be parsed or is null.

      • toString

        String toString(T value)
        Convert the supplied value to a String.

        This method is reserved for future use. Proprietary JAX-RS extensions may leverage the method. Users should be aware that any such support for the method comes at the expense of producing non-portable code.

        Parameters:
        value - the value of type T.
        Returns:
        a String representation of the value.
        Throws:
        IllegalArgumentException - if the supplied object cannot be serialized or is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ParamConverter.Lazy (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs.ext

Annotation Type ParamConverter.Lazy

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public static @interface ParamConverter.Lazy
    Mandates that a conversion of any default value delegated to a parameter converter annotated with @Lazy annotation SHOULD occur only once the value is actually required (e.g. to be injected for the first time).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


ParamConverterProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface ParamConverterProvider

  • public interface ParamConverterProvider
    Contract for a provider of ParamConverter instances.

    Providers implementing ParamConverterProvider contract must be either programmatically registered in a JAX-RS runtime or must be annotated with @Provider annotation to be automatically discovered by the JAX-RS runtime during a provider scanning phase.

    Author:
    Marek Potociar

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T> ParamConverter<T> getConverter(Class<T> rawType, Type genericType, Annotation[] annotations)
      Obtain a ParamConverter that can provide from/to string conversion for an instance of a particular Java type.

    • Method Detail

      • getConverter

        <T> ParamConverter<T> getConverter(Class<T> rawType,
                                 Type genericType,
                                 Annotation[] annotations)
        Obtain a ParamConverter that can provide from/to string conversion for an instance of a particular Java type.
        Type Parameters:
        T - the supported Java type convertible to/from a String format.
        Parameters:
        rawType - the raw type of the object to be converted.
        genericType - the type of object to be converted. E.g. if an String value representing the injected request parameter is to be converted into a method parameter, this will be the formal type of the method parameter as returned by Class.getGenericParameterTypes.
        annotations - an array of the annotations associated with the convertible parameter instance. E.g. if a string value is to be converted into a method parameter, this would be the annotations on that parameter as returned by Method.getParameterAnnotations().
        Returns:
        the string converter, otherwise null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Provider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.ws.rs.ext

Annotation Type Provider

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface Provider
    Marks an implementation of an extension interface that should be discoverable by JAX-RS runtime during a provider scanning phase.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Providers (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface Providers

  • public interface Providers
    An injectable interface providing runtime lookup of provider instances.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley
    See Also:
    Context, MessageBodyReader, MessageBodyWriter, ContextResolver, ExceptionMapper

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T> ContextResolver<T> getContextResolver(Class<T> contextType, MediaType mediaType)
      Get a context resolver for a particular type of context and media type.
      <T extends Throwable>
      ExceptionMapper<T>             		getExceptionMapper(Class<T> type)
      Get an exception mapping provider for a particular class of exception.
      <T> MessageBodyReader<T> getMessageBodyReader(Class<T> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Get a message body reader that matches a set of criteria.
      <T> MessageBodyWriter<T> getMessageBodyWriter(Class<T> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Get a message body writer that matches a set of criteria.

    • Method Detail

      • getMessageBodyReader

        <T> MessageBodyReader<T> getMessageBodyReader(Class<T> type,
                                            Type genericType,
                                            Annotation[] annotations,
                                            MediaType mediaType)
        Get a message body reader that matches a set of criteria. The set of readers is first filtered by comparing the supplied value of mediaType with the value of each reader's Consumes, ensuring the supplied value of type is assignable to the generic type of the reader, and eliminating those that do not match. The list of matching readers is then ordered with those with the best matching values of Consumes (x/y > x/* > */*) sorted first. Finally, the MessageBodyReader.isReadable(Class, Type, Annotation[], MediaType) method is called on each reader in order using the supplied criteria and the first reader that returns true is selected and returned.
        Type Parameters:
        T - type of the the object that is to be read.
        Parameters:
        type - the class of the object that is to be read.
        genericType - the type of object to be produced. E.g. if the message body is to be converted into a method parameter, this will be the formal type of the method parameter as returned by Class.getGenericParameterTypes.
        annotations - an array of the annotations on the declaration of the artifact that will be initialized with the produced instance. E.g. if the message body is to be converted into a method parameter, this will be the annotations on that parameter returned by Class.getParameterAnnotations.
        mediaType - the media type of the data that will be read.
        Returns:
        a MessageBodyReader that matches the supplied criteria or null if none is found.

      • getMessageBodyWriter

        <T> MessageBodyWriter<T> getMessageBodyWriter(Class<T> type,
                                            Type genericType,
                                            Annotation[] annotations,
                                            MediaType mediaType)
        Get a message body writer that matches a set of criteria. The set of writers is first filtered by comparing the supplied value of mediaType with the value of each writer's Produces, ensuring the supplied value of type is assignable to the generic type of the reader, and eliminating those that do not match. The list of matching writers is then ordered with those with the best matching values of Produces (x/y > x/* > */*) sorted first. Finally, the MessageBodyWriter.isWriteable(Class, Type, Annotation[], MediaType) method is called on each writer in order using the supplied criteria and the first writer that returns true is selected and returned.
        Type Parameters:
        T - type of the object that is to be written.
        Parameters:
        type - the class of the object that is to be written.
        genericType - the type of object to be written. E.g. if the message body is to be produced from a field, this will be the declared type of the field as returned by Field.getGenericType.
        annotations - an array of the annotations on the declaration of the artifact that will be written. E.g. if the message body is to be produced from a field, this will be the annotations on that field returned by Field.getDeclaredAnnotations.
        mediaType - the media type of the data that will be written.
        Returns:
        a MessageBodyReader that matches the supplied criteria or null if none is found.

      • getExceptionMapper

        <T extends Throwable> ExceptionMapper<T> getExceptionMapper(Class<T> type)
        Get an exception mapping provider for a particular class of exception. Returns the provider whose generic type is the nearest superclass of type.
        Type Parameters:
        T - type of the exception handled by the exception mapping provider.
        Parameters:
        type - the class of exception.
        Returns:
        an ExceptionMapper for the supplied type or null if none is found.

      • getContextResolver

        <T> ContextResolver<T> getContextResolver(Class<T> contextType,
                                        MediaType mediaType)
        Get a context resolver for a particular type of context and media type. The set of resolvers is first filtered by comparing the supplied value of mediaType with the value of each resolver's Produces, ensuring the generic type of the context resolver is assignable to the supplied value of contextType, and eliminating those that do not match. If only one resolver matches the criteria then it is returned. If more than one resolver matches then the list of matching resolvers is ordered with those with the best matching values of Produces (x/y > x/* > */*) sorted first. A proxy is returned that delegates calls to ContextResolver.getContext(java.lang.Class) to each matching context resolver in order and returns the first non-null value it obtains or null if all matching context resolvers return null.
        Type Parameters:
        T - type of the context.
        Parameters:
        contextType - the class of context desired.
        mediaType - the media type of data for which a context is required.
        Returns:
        a matching context resolver instance or null if no matching context providers are found.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ReaderInterceptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface ReaderInterceptor

  • public interface ReaderInterceptor
    Interface for message body reader interceptors that wrap around calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream).

    Providers implementing ReaderInterceptor contract must be either programmatically registered in a JAX-RS runtime or must be annotated with @Provider annotation to be automatically discovered by the JAX-RS runtime during a provider scanning phase. Message body interceptor instances may also be discovered and bound dynamically to particular resource methods.

    Since:
    2.0
    Author:
    Santiago Pericas-Geertsen, Bill Burke, Marek Potociar
    See Also:
    MessageBodyReader

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object aroundReadFrom(ReaderInterceptorContext context)
      Interceptor method wrapping calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream) method.

    • Method Detail

      • aroundReadFrom

        Object aroundReadFrom(ReaderInterceptorContext context)
                      throws IOException,
                             WebApplicationException
        Interceptor method wrapping calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream) method. The parameters of the wrapped method called are available from context. Implementations of this method SHOULD explicitly call ReaderInterceptorContext.proceed() to invoke the next interceptor in the chain, and ultimately the wrapped MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream) method.
        Parameters:
        context - invocation context.
        Returns:
        result of next interceptor invoked or the wrapped method if last interceptor in chain.
        Throws:
        IOException - if an IO error arises or is thrown by the wrapped MessageBodyReader.readFrom method.
        WebApplicationException - thrown by the wrapped MessageBodyReader.readFrom method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ReaderInterceptorContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface ReaderInterceptorContext

  • All Superinterfaces:
    InterceptorContext

    public interface ReaderInterceptorContext
extends InterceptorContext
    Context class used by ReaderInterceptor to intercept calls to (@link javax.ws.rs.ext.MessageBodyReader#readFrom}. The getters and setters in this context class correspond to the parameters of the intercepted method.
    Since:
    2.0
    Author:
    Santiago Pericas-Geertsen, Bill Burke
    See Also:
    ReaderInterceptor, MessageBodyReader

    • Method Summary

      Methods
      Modifier and Type Method and Description
      MultivaluedMap<String,String> getHeaders()
      Get mutable map of HTTP headers.
      InputStream getInputStream()
      Get the input stream of the object to be read.
      Object proceed()
      Proceed to the next interceptor in the chain.
      void setInputStream(InputStream is)
      Set the input stream of the object to be read.

      • Methods inherited from interface javax.ws.rs.ext.InterceptorContext

        getAnnotations, getGenericType, getMediaType, getProperty, getPropertyNames, getType, removeProperty, setAnnotations, setGenericType, setMediaType, setProperty, setType

    • Method Detail

      • proceed

        Object proceed()
               throws IOException,
                      WebApplicationException
        Proceed to the next interceptor in the chain. Return the result of the next interceptor invoked. Interceptors MUST explicitly call this method to continue the execution chain; the call to this method in the last interceptor of the chain will invoke the wrapped MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream).
        Returns:
        result of next interceptor invoked.
        Throws:
        IOException - if an IO error arises or is thrown by the wrapped MessageBodyReader.readFrom method.
        WebApplicationException - thrown by the wrapped MessageBodyReader.readFrom method.

      • getInputStream

        InputStream getInputStream()
        Get the input stream of the object to be read. The JAX-RS runtime is responsible for closing the input stream.
        Returns:
        input stream of the object to be read.

      • setInputStream

        void setInputStream(InputStream is)
        Set the input stream of the object to be read. For example, by wrapping it with another input stream. The JAX-RS runtime is responsible for closing the input stream that is set.
        Parameters:
        is - new input stream.

      • getHeaders

        MultivaluedMap<String,String> getHeaders()
        Get mutable map of HTTP headers.

        Note that while the headers are mutable, a reader interceptor should typically roll-back any header modifications once the call to context.proceed() returns, to avoid externally visible side-effects of the interceptor invocation.

        Returns:
        map of HTTP headers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RuntimeDelegate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Class RuntimeDelegate

  • java.lang.Object
    • javax.ws.rs.ext.RuntimeDelegate

  • public abstract class RuntimeDelegate
extends Object
    Implementations of JAX-RS provide a concrete subclass of RuntimeDelegate and various JAX-RS API methods defer to methods of RuntimeDelegate for their functionality. Regular users of JAX-RS are not expected to use this class directly and overriding an implementation of this class with a user supplied subclass may cause unexpected behavior.
    Since:
    1.0
    Author:
    Paul Sandoz, Marc Hadley

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static interface  RuntimeDelegate.HeaderDelegate<T>
      Defines the contract for a delegate that is responsible for converting between the String form of a HTTP header and the corresponding JAX-RS type T.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String JAXRS_RUNTIME_DELEGATE_PROPERTY
      Name of the property identifying the RuntimeDelegate implementation to be returned from getInstance().

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected RuntimeDelegate()
      Allows custom implementations to extend the RuntimeDelegate class.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract <T> T createEndpoint(Application application, Class<T> endpointType)
      Create a configured instance of the supplied endpoint type.
      abstract <T> RuntimeDelegate.HeaderDelegate<T> createHeaderDelegate(Class<T> type)
      Obtain an instance of a RuntimeDelegate.HeaderDelegate for the supplied class.
      abstract Link.Builder createLinkBuilder()
      Create a new instance of a Link.Builder.
      abstract Response.ResponseBuilder createResponseBuilder()
      Create a new instance of a Response.ResponseBuilder.
      abstract UriBuilder createUriBuilder()
      Create a new instance of a UriBuilder.
      abstract Variant.VariantListBuilder createVariantListBuilder()
      Create a new instance of a Variant.VariantListBuilder.
      static RuntimeDelegate getInstance()
      Obtain a RuntimeDelegate instance.
      static void setInstance(RuntimeDelegate rd)
      Set the runtime delegate that will be used by JAX-RS classes.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • JAXRS_RUNTIME_DELEGATE_PROPERTY

        public static final String JAXRS_RUNTIME_DELEGATE_PROPERTY
        Name of the property identifying the RuntimeDelegate implementation to be returned from getInstance().
        See Also:
        Constant Field Values

    • Constructor Detail

      • RuntimeDelegate

        protected RuntimeDelegate()
        Allows custom implementations to extend the RuntimeDelegate class.

    • Method Detail

      • getInstance

        public static RuntimeDelegate getInstance()
        Obtain a RuntimeDelegate instance. If an instance had not already been created and set via setInstance(RuntimeDelegate), the first invocation will create an instance which will then be cached for future use.

        The algorithm used to locate the RuntimeDelegate subclass to use consists of the following steps:

        • If a resource with the name of META-INF/services/javax.ws.rs.ext.RuntimeDelegate exists, then its first line, if present, is used as the UTF-8 encoded name of the implementation class.
        • If the $java.home/lib/jaxrs.properties file exists and it is readable by the java.util.Properties.load(InputStream) method and it contains an entry whose key is javax.ws.rs.ext.RuntimeDelegate, then the value of that entry is used as the name of the implementation class.
        • If a system property with the name javax.ws.rs.ext.RuntimeDelegate is defined, then its value is used as the name of the implementation class.
        • Finally, a default implementation class name is used.
        Returns:
        an instance of RuntimeDelegate.

      • setInstance

        public static void setInstance(RuntimeDelegate rd)
        Set the runtime delegate that will be used by JAX-RS classes. If this method is not called prior to getInstance() then an implementation will be sought as described in getInstance().
        Parameters:
        rd - the runtime delegate instance
        Throws:
        SecurityException - if there is a security manager and the permission ReflectPermission("suppressAccessChecks") has not been granted.

      • createUriBuilder

        public abstract UriBuilder createUriBuilder()
        Create a new instance of a UriBuilder.
        Returns:
        new UriBuilder instance.
        See Also:
        UriBuilder

      • createResponseBuilder

        public abstract Response.ResponseBuilder createResponseBuilder()
        Create a new instance of a Response.ResponseBuilder.
        Returns:
        new ResponseBuilder instance.
        See Also:
        Response.ResponseBuilder

      • createVariantListBuilder

        public abstract Variant.VariantListBuilder createVariantListBuilder()
        Create a new instance of a Variant.VariantListBuilder.
        Returns:
        new VariantListBuilder instance.
        See Also:
        Variant.VariantListBuilder

      • createEndpoint

        public abstract <T> T createEndpoint(Application application,
                   Class<T> endpointType)
                          throws IllegalArgumentException,
                                 UnsupportedOperationException
        Create a configured instance of the supplied endpoint type. How the returned endpoint instance is published is dependent on the type of endpoint.
        Type Parameters:
        T - endpoint type.
        Parameters:
        application - the application configuration.
        endpointType - the type of endpoint instance to be created.
        Returns:
        a configured instance of the requested type.
        Throws:
        IllegalArgumentException - if application is null or the requested endpoint type is not supported.
        UnsupportedOperationException - if the implementation supports no endpoint types.

      • createHeaderDelegate

        public abstract <T> RuntimeDelegate.HeaderDelegate<T> createHeaderDelegate(Class<T> type)
                                                                throws IllegalArgumentException
        Obtain an instance of a RuntimeDelegate.HeaderDelegate for the supplied class. An implementation is required to support the following values for type: CacheControl, Cookie, EntityTag, Link, NewCookie, MediaType and java.util.Date.
        Type Parameters:
        T - header type.
        Parameters:
        type - the class of the header.
        Returns:
        an instance of HeaderDelegate for the supplied type.
        Throws:
        IllegalArgumentException - if type is null.
        See Also:
        RuntimeDelegate.HeaderDelegate

      • createLinkBuilder

        public abstract Link.Builder createLinkBuilder()
        Create a new instance of a Link.Builder.
        Returns:
        new Link.Builder instance.
        See Also:
        Link.Builder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RuntimeDelegate.HeaderDelegate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface RuntimeDelegate.HeaderDelegate<T>

  • Type Parameters:
    T - a JAX-RS type that corresponds to the value of a HTTP header.
    Enclosing class:
    RuntimeDelegate

    public static interface RuntimeDelegate.HeaderDelegate<T>
    Defines the contract for a delegate that is responsible for converting between the String form of a HTTP header and the corresponding JAX-RS type T.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T fromString(String value)
      Parse the supplied value and create an instance of T.
      String toString(T value)
      Convert the supplied value to a String.

    • Method Detail

      • fromString

        T fromString(String value)
        Parse the supplied value and create an instance of T.
        Parameters:
        value - the string value.
        Returns:
        the newly created instance of T.
        Throws:
        IllegalArgumentException - if the supplied string cannot be parsed or is null.

      • toString

        String toString(T value)
        Convert the supplied value to a String.
        Parameters:
        value - the value of type T.
        Returns:
        a String representation of the value.
        Throws:
        IllegalArgumentException - if the supplied object cannot be serialized or is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.ws.rs.ext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.ws.rs.ext

  • Packages that use javax.ws.rs.ext
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.
  • Classes in javax.ws.rs.ext used by javax.ws.rs.ext
    Class and Description
    ContextResolver
    Contract for a provider that supplies context information to resource classes and other providers.
    ExceptionMapper
    Contract for a provider that maps Java exceptions to Response.
    InterceptorContext
    Context shared by message body interceptors that can be used to wrap calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream) and MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream).
    MessageBodyReader
    Contract for a provider that supports the conversion of a stream to a Java type.
    MessageBodyWriter
    Contract for a provider that supports the conversion of a Java type to a stream.
    ParamConverter
    Defines a contract for a delegate responsible for converting between a String form of a message parameter value and the corresponding custom Java type T.
    ReaderInterceptorContext
    Context class used by ReaderInterceptor to intercept calls to (@link javax.ws.rs.ext.MessageBodyReader#readFrom}.
    RuntimeDelegate
    Implementations of JAX-RS provide a concrete subclass of RuntimeDelegate and various JAX-RS API methods defer to methods of RuntimeDelegate for their functionality.
    RuntimeDelegate.HeaderDelegate
    Defines the contract for a delegate that is responsible for converting between the String form of a HTTP header and the corresponding JAX-RS type T.
    WriterInterceptorContext
    Context class used by WriterInterceptor to intercept calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WriterInterceptor (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface WriterInterceptor

  • public interface WriterInterceptor
    Interface for message body writer interceptors that wrap around calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream).

    Providers implementing WriterInterceptor contract must be either programmatically registered in a JAX-RS runtime or must be annotated with @Provider annotation to be automatically discovered by the JAX-RS runtime during a provider scanning phase. Message body interceptor instances may also be discovered and bound dynamically to particular resource methods.

    Since:
    2.0
    Author:
    Santiago Pericas-Geertsen, Bill Burke, Marek Potociar
    See Also:
    MessageBodyWriter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void aroundWriteTo(WriterInterceptorContext context)
      Interceptor method wrapping calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream) method.

    • Method Detail

      • aroundWriteTo

        void aroundWriteTo(WriterInterceptorContext context)
                   throws IOException,
                          WebApplicationException
        Interceptor method wrapping calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream) method. The parameters of the wrapped method called are available from context. Implementations of this method SHOULD explicitly call WriterInterceptorContext.proceed() to invoke the next interceptor in the chain, and ultimately the wrapped MessageBodyWriter.writeTo method.
        Parameters:
        context - invocation context.
        Throws:
        IOException - if an IO error arises or is thrown by the wrapped MessageBodyWriter.writeTo method.
        WebApplicationException - thrown by the wrapped MessageBodyWriter.writeTo method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WriterInterceptorContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.ws.rs.ext

Interface WriterInterceptorContext

  • All Superinterfaces:
    InterceptorContext

    public interface WriterInterceptorContext
extends InterceptorContext
    Context class used by WriterInterceptor to intercept calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream). The getters and setters in this context class correspond to the parameters of the intercepted method.
    Since:
    2.0
    Author:
    Santiago Pericas-Geertsen, Bill Burke
    See Also:
    WriterInterceptor, MessageBodyWriter

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getEntity()
      Get object to be written as HTTP entity.
      MultivaluedMap<String,Object> getHeaders()
      Get mutable map of HTTP headers.
      OutputStream getOutputStream()
      Get the output stream for the object to be written.
      void proceed()
      Proceed to the next interceptor in the chain.
      void setEntity(Object entity)
      Update object to be written as HTTP entity.
      void setOutputStream(OutputStream os)
      Set a new output stream for the object to be written.

      • Methods inherited from interface javax.ws.rs.ext.InterceptorContext

        getAnnotations, getGenericType, getMediaType, getProperty, getPropertyNames, getType, removeProperty, setAnnotations, setGenericType, setMediaType, setProperty, setType

    • Method Detail

      • proceed

        void proceed()
             throws IOException,
                    WebApplicationException
        Proceed to the next interceptor in the chain. Interceptors MUST explicitly call this method to continue the execution chain; the call to this method in the last interceptor of the chain will invoke the wrapped MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream) method.
        Throws:
        IOException - if an IO error arises or is thrown by the wrapped MessageBodyWriter.writeTo method.
        WebApplicationException - thrown by the wrapped MessageBodyWriter.writeTo method.

      • getEntity

        Object getEntity()
        Get object to be written as HTTP entity.
        Returns:
        object to be written as HTTP entity.

      • setEntity

        void setEntity(Object entity)
        Update object to be written as HTTP entity.
        Parameters:
        entity - new object to be written.

      • getOutputStream

        OutputStream getOutputStream()
        Get the output stream for the object to be written. The JAX-RS runtime is responsible for closing the output stream.
        Returns:
        output stream for the object to be written.

      • setOutputStream

        void setOutputStream(OutputStream os)
        Set a new output stream for the object to be written. For example, by wrapping it with another output stream. The JAX-RS runtime is responsible for closing the output stream that is set.
        Parameters:
        os - new output stream for the object to be written.

      • getHeaders

        MultivaluedMap<String,Object> getHeaders()
        Get mutable map of HTTP headers.
        Returns:
        map of HTTP headers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.ws.rs.ext.ParamConverter.Lazy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.ext.ParamConverter.Lazy

No usage of javax.ws.rs.ext.ParamConverter.Lazy
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.ext.Provider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.ext.Provider

No usage of javax.ws.rs.ext.Provider
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.ws.rs.ext.RuntimeDelegate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.ws.rs.ext.RuntimeDelegate

  • Packages that use RuntimeDelegate
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of RuntimeDelegate in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return RuntimeDelegate
      Modifier and Type Method and Description
      static RuntimeDelegate RuntimeDelegate.getInstance()
      Obtain a RuntimeDelegate instance.
      Methods in javax.ws.rs.ext with parameters of type RuntimeDelegate
      Modifier and Type Method and Description
      static void RuntimeDelegate.setInstance(RuntimeDelegate rd)
      Set the runtime delegate that will be used by JAX-RS classes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.ContextResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.ContextResolver

  • Packages that use ContextResolver
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of ContextResolver in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return ContextResolver
      Modifier and Type Method and Description
      <T> ContextResolver<T> Providers.getContextResolver(Class<T> contextType, MediaType mediaType)
      Get a context resolver for a particular type of context and media type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.ExceptionMapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.ExceptionMapper

  • Packages that use ExceptionMapper
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of ExceptionMapper in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return ExceptionMapper
      Modifier and Type Method and Description
      <T extends Throwable>
      ExceptionMapper<T>             		Providers.getExceptionMapper(Class<T> type)
      Get an exception mapping provider for a particular class of exception.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.InterceptorContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.InterceptorContext

  • Packages that use InterceptorContext
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of InterceptorContext in javax.ws.rs.ext

      Subinterfaces of InterceptorContext in javax.ws.rs.ext
      Modifier and Type Interface and Description
      interface  ReaderInterceptorContext
      Context class used by ReaderInterceptor to intercept calls to (@link javax.ws.rs.ext.MessageBodyReader#readFrom}.
      interface  WriterInterceptorContext
      Context class used by WriterInterceptor to intercept calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream).
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.MessageBodyReader (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.MessageBodyReader

  • Packages that use MessageBodyReader
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of MessageBodyReader in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return MessageBodyReader
      Modifier and Type Method and Description
      <T> MessageBodyReader<T> Providers.getMessageBodyReader(Class<T> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Get a message body reader that matches a set of criteria.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.MessageBodyWriter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.MessageBodyWriter

  • Packages that use MessageBodyWriter
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of MessageBodyWriter in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return MessageBodyWriter
      Modifier and Type Method and Description
      <T> MessageBodyWriter<T> Providers.getMessageBodyWriter(Class<T> type, Type genericType, Annotation[] annotations, MediaType mediaType)
      Get a message body writer that matches a set of criteria.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.ParamConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.ParamConverter

  • Packages that use ParamConverter
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of ParamConverter in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return ParamConverter
      Modifier and Type Method and Description
      <T> ParamConverter<T> ParamConverterProvider.getConverter(Class<T> rawType, Type genericType, Annotation[] annotations)
      Obtain a ParamConverter that can provide from/to string conversion for an instance of a particular Java type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.ParamConverterProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.ParamConverterProvider

No usage of javax.ws.rs.ext.ParamConverterProvider
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.Providers (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.Providers

No usage of javax.ws.rs.ext.Providers
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.ReaderInterceptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.ReaderInterceptor

No usage of javax.ws.rs.ext.ReaderInterceptor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.ReaderInterceptorContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.ReaderInterceptorContext

  • Packages that use ReaderInterceptorContext
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of ReaderInterceptorContext in javax.ws.rs.ext

      Methods in javax.ws.rs.ext with parameters of type ReaderInterceptorContext
      Modifier and Type Method and Description
      Object ReaderInterceptor.aroundReadFrom(ReaderInterceptorContext context)
      Interceptor method wrapping calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream) method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.RuntimeDelegate.HeaderDelegate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.RuntimeDelegate.HeaderDelegate

  • Packages that use RuntimeDelegate.HeaderDelegate
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of RuntimeDelegate.HeaderDelegate in javax.ws.rs.ext

      Methods in javax.ws.rs.ext that return RuntimeDelegate.HeaderDelegate
      Modifier and Type Method and Description
      abstract <T> RuntimeDelegate.HeaderDelegate<T> RuntimeDelegate.createHeaderDelegate(Class<T> type)
      Obtain an instance of a RuntimeDelegate.HeaderDelegate for the supplied class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.WriterInterceptor (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.WriterInterceptor

No usage of javax.ws.rs.ext.WriterInterceptor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.ws.rs.ext.WriterInterceptorContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.ws.rs.ext.WriterInterceptorContext

  • Packages that use WriterInterceptorContext
    Package Description
    javax.ws.rs.ext
    APIs that provide extensions to the types supported by the JAX-RS API.

    • Uses of WriterInterceptorContext in javax.ws.rs.ext

      Methods in javax.ws.rs.ext with parameters of type WriterInterceptorContext
      Modifier and Type Method and Description
      void WriterInterceptor.aroundWriteTo(WriterInterceptorContext context)
      Interceptor method wrapping calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream) method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Binder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class Binder<XmlNode>

  • java.lang.Object
    • javax.xml.bind.Binder<XmlNode>

  • public abstract class Binder<XmlNode>
extends Object
    Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.

    An instance of this class maintains the association between XML nodes of an infoset preserving view and a JAXB representation of an XML document. Navigation between the two views is provided by the methods getXMLNode(Object) and getJAXBNode(Object).

    Modifications can be made to either the infoset preserving view or the JAXB representation of the document while the other view remains unmodified. The binder is able to synchronize the changes made in the modified view back into the other view using the appropriate Binder update methods, updateXML(Object, Object) or updateJAXB(Object).

    A typical usage scenario is the following:

    • load XML document into an XML infoset representation
    • unmarshal(Object) XML infoset view to JAXB view. (Note to conserve resources, it is possible to only unmarshal a subtree of the XML infoset view to the JAXB view.)
    • application access/updates JAXB view of XML document.
    • updateXML(Object) synchronizes modifications to JAXB view back into the XML infoset view. Update operation preserves as much of original XML infoset as possible (i.e. comments, PI, ...)

    A Binder instance is created using the factory method JAXBContext.createBinder() or JAXBContext.createBinder(Class).

    The template parameter, XmlNode, is the root interface/class for the XML infoset preserving representation. A Binder implementation is required to minimally support an XmlNode value of org.w3c.dom.Node.class. A Binder implementation can support alternative XML infoset preserving representations.

    Since:
    JAXB 2.0
    Author:
    Kohsuke Kawaguchi (kohsuke.kawaguchi@sun.com) Joseph Fialli

    • Constructor Summary

      Constructors
      Constructor and Description
      Binder()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      abstract Object getJAXBNode(XmlNode xmlNode)
      Gets the JAXB object associated with the given XML element.
      abstract Object getProperty(String name)
      Get the particular property in the underlying implementation of Binder.
      abstract Schema getSchema()
      Gets the last Schema object (including null) set by the setSchema(Schema) method.
      abstract XmlNode getXMLNode(Object jaxbObject)
      Gets the XML element associated with the given JAXB object.
      abstract void marshal(Object jaxbObject, XmlNode xmlNode)
      Marshal a JAXB object tree to a new XML document.
      abstract void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      abstract void setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Binder.
      abstract void setSchema(Schema schema)
      Specifies whether marshal, unmarshal and update methods performs validation on their XML content.
      abstract Object unmarshal(XmlNode xmlNode)
      Unmarshal XML infoset view to a JAXB object tree.
      abstract <T> JAXBElement<T> unmarshal(XmlNode xmlNode, Class<T> declaredType)
      Unmarshal XML root element by provided declaredType to a JAXB object tree.
      abstract Object updateJAXB(XmlNode xmlNode)
      Takes an XML node and updates its associated JAXB object and its descendants.
      abstract XmlNode updateXML(Object jaxbObject)
      Takes an JAXB object and updates its associated XML node and its descendants.
      abstract XmlNode updateXML(Object jaxbObject, XmlNode xmlNode)
      Changes in JAXB object tree are updated in its associated XML parse tree.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Binder

        public Binder()

    • Method Detail

      • unmarshal

        public abstract Object unmarshal(XmlNode xmlNode)
                          throws JAXBException
        Unmarshal XML infoset view to a JAXB object tree.

        This method is similar to Unmarshaller.unmarshal(Node) with the addition of maintaining the association between XML nodes and the produced JAXB objects, enabling future update operations, updateXML(Object, Object) or updateJAXB(Object).

        When getSchema() is non-null, xmlNode and its descendants is validated during this operation.

        This method throws UnmarshalException when the Binder's JAXBContext does not have a mapping for the XML element name or the type, specifiable via @xsi:type, of xmlNode to a JAXB mapped class. The method unmarshal(Object, Class) enables an application to specify the JAXB mapped class that the xmlNode should be mapped to.

        Parameters:
        xmlNode - the document/element to unmarshal XML data from.
        Returns:
        the newly created root object of the JAXB object tree.
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to perform the XML to Java binding.
        IllegalArgumentException - If the node parameter is null

      • unmarshal

        public abstract <T> JAXBElement<T> unmarshal(XmlNode xmlNode,
                           Class<T> declaredType)
                                  throws JAXBException
        Unmarshal XML root element by provided declaredType to a JAXB object tree.

        Implements Unmarshal by Declared Type

        This method is similar to Unmarshaller.unmarshal(Node, Class) with the addition of maintaining the association between XML nodes and the produced JAXB objects, enabling future update operations, updateXML(Object, Object) or updateJAXB(Object).

        When getSchema() is non-null, xmlNode and its descendants is validated during this operation.

        Parameters:
        xmlNode - the document/element to unmarshal XML data from.
        declaredType - appropriate JAXB mapped class to hold node's XML data.
        Returns:
        JAXB Element representation of node
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to perform the XML to Java binding.
        IllegalArgumentException - If any of the input parameters are null
        Since:
        JAXB2.0

      • marshal

        public abstract void marshal(Object jaxbObject,
           XmlNode xmlNode)
                      throws JAXBException
        Marshal a JAXB object tree to a new XML document.

        This method is similar to Marshaller.marshal(Object, Node) with the addition of maintaining the association between JAXB objects and the produced XML nodes, enabling future update operations such as updateXML(Object, Object) or updateJAXB(Object).

        When getSchema() is non-null, the marshalled xml content is validated during this operation.

        Parameters:
        jaxbObject - The content tree to be marshalled.
        xmlNode - The parameter must be a Node that accepts children.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to marshal jaxbObject (or any object reachable from jaxbObject).
        IllegalArgumentException - If any of the method parameters are null

      • getXMLNode

        public abstract XmlNode getXMLNode(Object jaxbObject)
        Gets the XML element associated with the given JAXB object.

        Once a JAXB object tree is associated with an XML fragment, this method enables navigation between the two trees.

        An association between an XML element and a JAXB object is established by the bind methods and the update methods. Note that this association is partial; not all XML elements have associated JAXB objects, and not all JAXB objects have associated XML elements.

        Parameters:
        jaxbObject - An instance that is reachable from a prior call to a bind or update method that returned a JAXB object tree.
        Returns:
        null if the specified JAXB object is not known to this Binder, or if it is not associated with an XML element.
        Throws:
        IllegalArgumentException - If the jaxbObject parameter is null

      • getJAXBNode

        public abstract Object getJAXBNode(XmlNode xmlNode)
        Gets the JAXB object associated with the given XML element.

        Once a JAXB object tree is associated with an XML fragment, this method enables navigation between the two trees.

        An association between an XML element and a JAXB object is established by the unmarshal, marshal and update methods. Note that this association is partial; not all XML elements have associated JAXB objects, and not all JAXB objects have associated XML elements.

        Returns:
        null if the specified XML node is not known to this Binder, or if it is not associated with a JAXB object.
        Throws:
        IllegalArgumentException - If the node parameter is null

      • updateXML

        public abstract XmlNode updateXML(Object jaxbObject)
                           throws JAXBException
        Takes an JAXB object and updates its associated XML node and its descendants.

        This is a convenience method of:

         updateXML( jaxbObject, getXMLNode(jaxbObject));
        Throws:
        JAXBException - If any unexpected problem occurs updating corresponding XML content.
        IllegalArgumentException - If the jaxbObject parameter is null

      • updateXML

        public abstract XmlNode updateXML(Object jaxbObject,
                XmlNode xmlNode)
                           throws JAXBException
        Changes in JAXB object tree are updated in its associated XML parse tree.

        This operation can be thought of as an "in-place" marshalling. The difference is that instead of creating a whole new XML tree, this operation updates an existing tree while trying to preserve the XML as much as possible.

        For example, unknown elements/attributes in XML that were not bound to JAXB will be left untouched (whereas a marshalling operation would create a new tree that doesn't contain any of those.)

        As a side-effect, this operation updates the association between XML nodes and JAXB objects.

        Parameters:
        jaxbObject - root of potentially modified JAXB object tree
        xmlNode - root of update target XML parse tree
        Returns:
        Returns the updated XML node. Typically, this is the same node you passed in as xmlNode, but it maybe a different object, for example when the tag name of the object has changed.
        Throws:
        JAXBException - If any unexpected problem occurs updating corresponding XML content.
        IllegalArgumentException - If any of the input parameters are null

      • updateJAXB

        public abstract Object updateJAXB(XmlNode xmlNode)
                           throws JAXBException
        Takes an XML node and updates its associated JAXB object and its descendants.

        This operation can be thought of as an "in-place" unmarshalling. The difference is that instead of creating a whole new JAXB tree, this operation updates an existing tree, reusing as much JAXB objects as possible.

        As a side-effect, this operation updates the association between XML nodes and JAXB objects.

        Returns:
        Returns the updated JAXB object. Typically, this is the same object that was returned from earlier marshal(Object,Object) or updateJAXB(Object) method invocation, but it maybe a different object, for example when the name of the XML element has changed.
        Throws:
        JAXBException - If any unexpected problem occurs updating corresponding JAXB mapped content.
        IllegalArgumentException - If node parameter is null

      • setSchema

        public abstract void setSchema(Schema schema)
        Specifies whether marshal, unmarshal and update methods performs validation on their XML content.
        Parameters:
        schema - set to null to disable validation.
        See Also:
        Unmarshaller.setSchema(Schema)

      • getSchema

        public abstract Schema getSchema()
        Gets the last Schema object (including null) set by the setSchema(Schema) method.
        Returns:
        the Schema object for validation or null if not present

      • setEventHandler

        public abstract void setEventHandler(ValidationEventHandler handler)
                              throws JAXBException
        Allow an application to register a ValidationEventHandler.

        The ValidationEventHandler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the Binder unmarshal, marshal and update methods.

        Calling this method with a null parameter will cause the Binder to revert back to the default default event handler.

        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        public abstract ValidationEventHandler getEventHandler()
                                                throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler

      • setProperty

        public abstract void setProperty(String name,
               Object value)
                          throws PropertyException
        Set the particular property in the underlying implementation of Binder. This method can only be used to set one of the standard JAXB defined unmarshal/marshal properties or a provider specific property for binder, unmarshal or marshal. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Unmarshal Properties and Supported Marshal Properties.
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        public abstract Object getProperty(String name)
                            throws PropertyException
        Get the particular property in the underlying implementation of Binder. This method can only be used to get one of the standard JAXB defined unmarshal/marshal properties or a provider specific property for binder, unmarshal or marshal. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Unmarshal Properties and Supported Marshal Properties.
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DataBindingException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class DataBindingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.bind.DataBindingException
  • All Implemented Interfaces:
    Serializable

    public class DataBindingException
extends RuntimeException
    Exception that represents a failure in a JAXB operation.

    This exception differs from JAXBException in that this is an unchecked exception, while JAXBException is a checked exception.

    Since:
    JAXB2.1
    See Also:
    JAXB, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DataBindingException(String message, Throwable cause)
      DataBindingException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DataBindingException

        public DataBindingException(String message,
                    Throwable cause)

      • DataBindingException

        public DataBindingException(Throwable cause)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DatatypeConverter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class DatatypeConverter

  • java.lang.Object
    • javax.xml.bind.DatatypeConverter

  • public final class DatatypeConverter
extends Object

    The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype. Customizations can involve writing a parse and print method for parsing and printing lexical representations of a XML schema datatype respectively. However, writing parse and print methods requires knowledge of the lexical representations ( XML Schema Part2: Datatypes specification ) and hence may be difficult to write.

    This class makes it easier to write parse and print methods. It defines static parse and print methods that provide access to a JAXB provider's implementation of parse and print methods. These methods are invoked by custom parse and print methods. For example, the binding of xsd:dateTime to a long can be customized using parse and print methods as follows:

        // Customized parse method
    public long myParseCal( String dateTimeString ) {
        java.util.Calendar cal = DatatypeConverter.parseDateTime(dateTimeString);
        long longval = convert_calendar_to_long(cal); //application specific
        return longval;
    }

    // Customized print method
    public String myPrintCal( Long longval ) {
        java.util.Calendar cal = convert_long_to_calendar(longval) ; //application specific
        String dateTimeString = DatatypeConverter.printDateTime(cal);
        return dateTimeString;
    }

    There is a static parse and print method corresponding to each parse and print method respectively in the DatatypeConverterInterface.

    The static methods defined in the class can also be used to specify a parse or a print method in a javaType binding declaration.

    JAXB Providers are required to call the setDatatypeConverter api at some point before the first marshal or unmarshal operation (perhaps during the call to JAXBContext.newInstance). This step is necessary to configure the converter that should be used to perform the print and parse functionality.

    A print method for a XML schema datatype can output any lexical representation that is valid with respect to the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException, or a subclass of IllegalArgumentException must be thrown by the method.

    Since:
    JAXB1.0
    Author:
    • Sekhar Vajjhala, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Ryan Shoemaker,Sun Microsystems Inc.
    See Also:
    DatatypeConverterInterface, ParseConversionEvent, PrintConversionEvent

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static String parseAnySimpleType(String lexicalXSDAnySimpleType)
      Return a string containing the lexical representation of the simple type.
      static byte[] parseBase64Binary(String lexicalXSDBase64Binary)
      Converts the string argument into an array of bytes.
      static boolean parseBoolean(String lexicalXSDBoolean)
      Converts the string argument into a boolean value.
      static byte parseByte(String lexicalXSDByte)
      Converts the string argument into a byte value.
      static Calendar parseDate(String lexicalXSDDate)
      Converts the string argument into a Calendar value.
      static Calendar parseDateTime(String lexicalXSDDateTime)
      Converts the string argument into a Calendar value.
      static BigDecimal parseDecimal(String lexicalXSDDecimal)
      Converts the string argument into a BigDecimal value.
      static double parseDouble(String lexicalXSDDouble)
      Converts the string argument into a double value.
      static float parseFloat(String lexicalXSDFloat)
      Converts the string argument into a float value.
      static byte[] parseHexBinary(String lexicalXSDHexBinary)
      Converts the string argument into an array of bytes.
      static int parseInt(String lexicalXSDInt)
      Convert the string argument into an int value.
      static BigInteger parseInteger(String lexicalXSDInteger)
      Convert the string argument into a BigInteger value.
      static long parseLong(String lexicalXSDLong)
      Converts the string argument into a long value.
      static QName parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a byte value.
      static short parseShort(String lexicalXSDShort)
      Converts the string argument into a short value.
      static String parseString(String lexicalXSDString)
      Convert the lexical XSD string argument into a String value.
      static Calendar parseTime(String lexicalXSDTime)
      Converts the string argument into a Calendar value.
      static long parseUnsignedInt(String lexicalXSDUnsignedInt)
      Converts the string argument into a long value.
      static int parseUnsignedShort(String lexicalXSDUnsignedShort)
      Converts the string argument into an int value.
      static String printAnySimpleType(String val)
      Converts a string value into a string.
      static String printBase64Binary(byte[] val)
      Converts an array of bytes into a string.
      static String printBoolean(boolean val)
      Converts a boolean value into a string.
      static String printByte(byte val)
      Converts a byte value into a string.
      static String printDate(Calendar val)
      Converts a Calendar value into a string.
      static String printDateTime(Calendar val)
      Converts a Calendar value into a string.
      static String printDecimal(BigDecimal val)
      Converts a BigDecimal value into a string.
      static String printDouble(double val)
      Converts a double value into a string.
      static String printFloat(float val)
      Converts a float value into a string.
      static String printHexBinary(byte[] val)
      Converts an array of bytes into a string.
      static String printInt(int val)
      Converts an int value into a string.
      static String printInteger(BigInteger val)
      Converts a BigInteger value into a string.
      static String printLong(long val)
      Converts A long value into a string.
      static String printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      static String printShort(short val)
      Converts a short value into a string.
      static String printString(String val)
      Converts the string argument into a string.
      static String printTime(Calendar val)
      Converts a Calendar value into a string.
      static String printUnsignedInt(long val)
      Converts a long value into a string.
      static String printUnsignedShort(int val)
      Converts an int value into a string.
      static void setDatatypeConverter(DatatypeConverterInterface converter)
      This method is for JAXB provider use only.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • setDatatypeConverter

        public static void setDatatypeConverter(DatatypeConverterInterface converter)
        This method is for JAXB provider use only.

        JAXB Providers are required to call this method at some point before allowing any of the JAXB client marshal or unmarshal operations to occur. This is necessary to configure the datatype converter that should be used to perform the print and parse conversions.

        Calling this api repeatedly will have no effect - the DatatypeConverterInterface instance passed into the first invocation is the one that will be used from then on.

        Parameters:
        converter - an instance of a class that implements the DatatypeConverterInterface class - this parameter must not be null.
        Throws:
        IllegalArgumentException - if the parameter is null
        SecurityException - If the SecurityManager in charge denies the access to set the datatype converter.
        See Also:
        JAXBPermission

      • parseString

        public static String parseString(String lexicalXSDString)

        Convert the lexical XSD string argument into a String value.

        Parameters:
        lexicalXSDString - A string containing a lexical representation of xsd:string.
        Returns:
        A String value represented by the string argument.

      • parseInteger

        public static BigInteger parseInteger(String lexicalXSDInteger)

        Convert the string argument into a BigInteger value.

        Parameters:
        lexicalXSDInteger - A string containing a lexical representation of xsd:integer.
        Returns:
        A BigInteger value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDInteger is not a valid string representation of a BigInteger value.

      • parseInt

        public static int parseInt(String lexicalXSDInt)

        Convert the string argument into an int value.

        Parameters:
        lexicalXSDInt - A string containing a lexical representation of xsd:int.
        Returns:
        A int value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDInt is not a valid string representation of an int value.

      • parseLong

        public static long parseLong(String lexicalXSDLong)

        Converts the string argument into a long value.

        Parameters:
        lexicalXSDLong - A string containing lexical representation of xsd:long.
        Returns:
        A long value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDLong is not a valid string representation of a long value.

      • parseShort

        public static short parseShort(String lexicalXSDShort)

        Converts the string argument into a short value.

        Parameters:
        lexicalXSDShort - A string containing lexical representation of xsd:short.
        Returns:
        A short value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDShort is not a valid string representation of a short value.

      • parseDecimal

        public static BigDecimal parseDecimal(String lexicalXSDDecimal)

        Converts the string argument into a BigDecimal value.

        Parameters:
        lexicalXSDDecimal - A string containing lexical representation of xsd:decimal.
        Returns:
        A BigDecimal value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDDecimal is not a valid string representation of BigDecimal.

      • parseFloat

        public static float parseFloat(String lexicalXSDFloat)

        Converts the string argument into a float value.

        Parameters:
        lexicalXSDFloat - A string containing lexical representation of xsd:float.
        Returns:
        A float value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDFloat is not a valid string representation of a float value.

      • parseDouble

        public static double parseDouble(String lexicalXSDDouble)

        Converts the string argument into a double value.

        Parameters:
        lexicalXSDDouble - A string containing lexical representation of xsd:double.
        Returns:
        A double value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDDouble is not a valid string representation of a double value.

      • parseBoolean

        public static boolean parseBoolean(String lexicalXSDBoolean)

        Converts the string argument into a boolean value.

        Parameters:
        lexicalXSDBoolean - A string containing lexical representation of xsd:boolean.
        Returns:
        A boolean value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:boolean.

      • parseByte

        public static byte parseByte(String lexicalXSDByte)

        Converts the string argument into a byte value.

        Parameters:
        lexicalXSDByte - A string containing lexical representation of xsd:byte.
        Returns:
        A byte value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:byte.

      • parseQName

        public static QName parseQName(String lexicalXSDQName,
               NamespaceContext nsc)

        Converts the string argument into a byte value.

        String parameter lexicalXSDQname must conform to lexical value space specifed at XML Schema Part 2:Datatypes specification:QNames

        Parameters:
        lexicalXSDQName - A string containing lexical representation of xsd:QName.
        nsc - A namespace context for interpreting a prefix within a QName.
        Returns:
        A QName value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to XML Schema Part 2 specification or if namespace prefix of lexicalXSDQname is not bound to a URI in NamespaceContext nsc.

      • parseDateTime

        public static Calendar parseDateTime(String lexicalXSDDateTime)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDDateTime - A string containing lexical representation of xsd:datetime.
        Returns:
        A Calendar object represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:dateTime.

      • parseBase64Binary

        public static byte[] parseBase64Binary(String lexicalXSDBase64Binary)

        Converts the string argument into an array of bytes.

        Parameters:
        lexicalXSDBase64Binary - A string containing lexical representation of xsd:base64Binary.
        Returns:
        An array of bytes represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:base64Binary

      • parseHexBinary

        public static byte[] parseHexBinary(String lexicalXSDHexBinary)

        Converts the string argument into an array of bytes.

        Parameters:
        lexicalXSDHexBinary - A string containing lexical representation of xsd:hexBinary.
        Returns:
        An array of bytes represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:hexBinary.

      • parseUnsignedInt

        public static long parseUnsignedInt(String lexicalXSDUnsignedInt)

        Converts the string argument into a long value.

        Parameters:
        lexicalXSDUnsignedInt - A string containing lexical representation of xsd:unsignedInt.
        Returns:
        A long value represented by the string argument.
        Throws:
        NumberFormatException - if string parameter can not be parsed into a long value.

      • parseUnsignedShort

        public static int parseUnsignedShort(String lexicalXSDUnsignedShort)

        Converts the string argument into an int value.

        Parameters:
        lexicalXSDUnsignedShort - A string containing lexical representation of xsd:unsignedShort.
        Returns:
        An int value represented by the string argument.
        Throws:
        NumberFormatException - if string parameter can not be parsed into an int value.

      • parseTime

        public static Calendar parseTime(String lexicalXSDTime)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDTime - A string containing lexical representation of xsd:time.
        Returns:
        A Calendar value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Time.

      • parseDate

        public static Calendar parseDate(String lexicalXSDDate)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDDate - A string containing lexical representation of xsd:Date.
        Returns:
        A Calendar value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Date.

      • parseAnySimpleType

        public static String parseAnySimpleType(String lexicalXSDAnySimpleType)

        Return a string containing the lexical representation of the simple type.

        Parameters:
        lexicalXSDAnySimpleType - A string containing lexical representation of the simple type.
        Returns:
        A string containing the lexical representation of the simple type.

      • printString

        public static String printString(String val)

        Converts the string argument into a string.

        Parameters:
        val - A string value.
        Returns:
        A string containing a lexical representation of xsd:string.

      • printInteger

        public static String printInteger(BigInteger val)

        Converts a BigInteger value into a string.

        Parameters:
        val - A BigInteger value
        Returns:
        A string containing a lexical representation of xsd:integer
        Throws:
        IllegalArgumentException - val is null.

      • printInt

        public static String printInt(int val)

        Converts an int value into a string.

        Parameters:
        val - An int value
        Returns:
        A string containing a lexical representation of xsd:int

      • printLong

        public static String printLong(long val)

        Converts A long value into a string.

        Parameters:
        val - A long value
        Returns:
        A string containing a lexical representation of xsd:long

      • printShort

        public static String printShort(short val)

        Converts a short value into a string.

        Parameters:
        val - A short value
        Returns:
        A string containing a lexical representation of xsd:short

      • printDecimal

        public static String printDecimal(BigDecimal val)

        Converts a BigDecimal value into a string.

        Parameters:
        val - A BigDecimal value
        Returns:
        A string containing a lexical representation of xsd:decimal
        Throws:
        IllegalArgumentException - val is null.

      • printFloat

        public static String printFloat(float val)

        Converts a float value into a string.

        Parameters:
        val - A float value
        Returns:
        A string containing a lexical representation of xsd:float

      • printDouble

        public static String printDouble(double val)

        Converts a double value into a string.

        Parameters:
        val - A double value
        Returns:
        A string containing a lexical representation of xsd:double

      • printBoolean

        public static String printBoolean(boolean val)

        Converts a boolean value into a string.

        Parameters:
        val - A boolean value
        Returns:
        A string containing a lexical representation of xsd:boolean

      • printByte

        public static String printByte(byte val)

        Converts a byte value into a string.

        Parameters:
        val - A byte value
        Returns:
        A string containing a lexical representation of xsd:byte

      • printQName

        public static String printQName(QName val,
                NamespaceContext nsc)

        Converts a QName instance into a string.

        Parameters:
        val - A QName value
        nsc - A namespace context for interpreting a prefix within a QName.
        Returns:
        A string containing a lexical representation of QName
        Throws:
        IllegalArgumentException - if val is null or if nsc is non-null or nsc.getPrefix(nsprefixFromVal) is null.

      • printDateTime

        public static String printDateTime(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:dateTime
        Throws:
        IllegalArgumentException - if val is null.

      • printBase64Binary

        public static String printBase64Binary(byte[] val)

        Converts an array of bytes into a string.

        Parameters:
        val - An array of bytes
        Returns:
        A string containing a lexical representation of xsd:base64Binary
        Throws:
        IllegalArgumentException - if val is null.

      • printHexBinary

        public static String printHexBinary(byte[] val)

        Converts an array of bytes into a string.

        Parameters:
        val - An array of bytes
        Returns:
        A string containing a lexical representation of xsd:hexBinary
        Throws:
        IllegalArgumentException - if val is null.

      • printUnsignedInt

        public static String printUnsignedInt(long val)

        Converts a long value into a string.

        Parameters:
        val - A long value
        Returns:
        A string containing a lexical representation of xsd:unsignedInt

      • printUnsignedShort

        public static String printUnsignedShort(int val)

        Converts an int value into a string.

        Parameters:
        val - An int value
        Returns:
        A string containing a lexical representation of xsd:unsignedShort

      • printTime

        public static String printTime(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:time
        Throws:
        IllegalArgumentException - if val is null.

      • printDate

        public static String printDate(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:date
        Throws:
        IllegalArgumentException - if val is null.

      • printAnySimpleType

        public static String printAnySimpleType(String val)

        Converts a string value into a string.

        Parameters:
        val - A string value
        Returns:
        A string containing a lexical representation of xsd:AnySimpleType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DatatypeConverterInterface (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface DatatypeConverterInterface

  • public interface DatatypeConverterInterface

    The DatatypeConverterInterface is for JAXB provider use only. A JAXB provider must supply a class that implements this interface. JAXB Providers are required to call the DatatypeConverter.setDatatypeConverter api at some point before the first marshal or unmarshal operation (perhaps during the call to JAXBContext.newInstance). This step is necessary to configure the converter that should be used to perform the print and parse functionality. Calling this api repeatedly will have no effect - the DatatypeConverter instance passed into the first invocation is the one that will be used from then on.

    This interface defines the parse and print methods. There is one parse and print method for each XML schema datatype specified in the the default binding Table 5-1 in the JAXB specification.

    The parse and print methods defined here are invoked by the static parse and print methods defined in the DatatypeConverter class.

    A parse method for a XML schema datatype must be capable of converting any lexical representation of the XML schema datatype ( specified by the XML Schema Part2: Datatypes specification into a value in the value space of the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException or a subclass of IllegalArgumentException must be thrown by the method.

    A print method for a XML schema datatype can output any lexical representation that is valid with respect to the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException, or a subclass of IllegalArgumentException must be thrown by the method.

    The prefix xsd: is used to refer to XML schema datatypes XML Schema Part2: Datatypes specification.

    Since:
    JAXB1.0
    Author:
    • Sekhar Vajjhala, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Ryan Shoemaker,Sun Microsystems Inc.
    See Also:
    DatatypeConverter, ParseConversionEvent, PrintConversionEvent

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String parseAnySimpleType(String lexicalXSDAnySimpleType)
      Return a string containing the lexical representation of the simple type.
      byte[] parseBase64Binary(String lexicalXSDBase64Binary)
      Converts the string argument into an array of bytes.
      boolean parseBoolean(String lexicalXSDBoolean)
      Converts the string argument into a boolean value.
      byte parseByte(String lexicalXSDByte)
      Converts the string argument into a byte value.
      Calendar parseDate(String lexicalXSDDate)
      Converts the string argument into a Calendar value.
      Calendar parseDateTime(String lexicalXSDDateTime)
      Converts the string argument into a Calendar value.
      BigDecimal parseDecimal(String lexicalXSDDecimal)
      Converts the string argument into a BigDecimal value.
      double parseDouble(String lexicalXSDDouble)
      Converts the string argument into a double value.
      float parseFloat(String lexicalXSDFloat)
      Converts the string argument into a float value.
      byte[] parseHexBinary(String lexicalXSDHexBinary)
      Converts the string argument into an array of bytes.
      int parseInt(String lexicalXSDInt)
      Convert the string argument into an int value.
      BigInteger parseInteger(String lexicalXSDInteger)
      Convert the string argument into a BigInteger value.
      long parseLong(String lexicalXSDLong)
      Converts the string argument into a long value.
      QName parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a QName value.
      short parseShort(String lexicalXSDShort)
      Converts the string argument into a short value.
      String parseString(String lexicalXSDString)
      Convert the string argument into a string.
      Calendar parseTime(String lexicalXSDTime)
      Converts the string argument into a Calendar value.
      long parseUnsignedInt(String lexicalXSDUnsignedInt)
      Converts the string argument into a long value.
      int parseUnsignedShort(String lexicalXSDUnsignedShort)
      Converts the string argument into an int value.
      String printAnySimpleType(String val)
      Converts a string value into a string.
      String printBase64Binary(byte[] val)
      Converts an array of bytes into a string.
      String printBoolean(boolean val)
      Converts a boolean value into a string.
      String printByte(byte val)
      Converts a byte value into a string.
      String printDate(Calendar val)
      Converts a Calendar value into a string.
      String printDateTime(Calendar val)
      Converts a Calendar value into a string.
      String printDecimal(BigDecimal val)
      Converts a BigDecimal value into a string.
      String printDouble(double val)
      Converts a double value into a string.
      String printFloat(float val)
      Converts a float value into a string.
      String printHexBinary(byte[] val)
      Converts an array of bytes into a string.
      String printInt(int val)
      Converts an int value into a string.
      String printInteger(BigInteger val)
      Converts a BigInteger value into a string.
      String printLong(long val)
      Converts a long value into a string.
      String printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      String printShort(short val)
      Converts a short value into a string.
      String printString(String val)
      Converts the string argument into a string.
      String printTime(Calendar val)
      Converts a Calendar value into a string.
      String printUnsignedInt(long val)
      Converts a long value into a string.
      String printUnsignedShort(int val)
      Converts an int value into a string.

    • Method Detail

      • parseString

        String parseString(String lexicalXSDString)

        Convert the string argument into a string.

        Parameters:
        lexicalXSDString - A lexical representation of the XML Schema datatype xsd:string
        Returns:
        A string that is the same as the input string.

      • parseInteger

        BigInteger parseInteger(String lexicalXSDInteger)

        Convert the string argument into a BigInteger value.

        Parameters:
        lexicalXSDInteger - A string containing a lexical representation of xsd:integer.
        Returns:
        A BigInteger value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDInteger is not a valid string representation of a BigInteger value.

      • parseInt

        int parseInt(String lexicalXSDInt)

        Convert the string argument into an int value.

        Parameters:
        lexicalXSDInt - A string containing a lexical representation of xsd:int.
        Returns:
        An int value represented byte the string argument.
        Throws:
        NumberFormatException - lexicalXSDInt is not a valid string representation of an int value.

      • parseLong

        long parseLong(String lexicalXSDLong)

        Converts the string argument into a long value.

        Parameters:
        lexicalXSDLong - A string containing lexical representation of xsd:long.
        Returns:
        A long value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDLong is not a valid string representation of a long value.

      • parseShort

        short parseShort(String lexicalXSDShort)

        Converts the string argument into a short value.

        Parameters:
        lexicalXSDShort - A string containing lexical representation of xsd:short.
        Returns:
        A short value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDShort is not a valid string representation of a short value.

      • parseDecimal

        BigDecimal parseDecimal(String lexicalXSDDecimal)

        Converts the string argument into a BigDecimal value.

        Parameters:
        lexicalXSDDecimal - A string containing lexical representation of xsd:decimal.
        Returns:
        A BigDecimal value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDDecimal is not a valid string representation of BigDecimal.

      • parseFloat

        float parseFloat(String lexicalXSDFloat)

        Converts the string argument into a float value.

        Parameters:
        lexicalXSDFloat - A string containing lexical representation of xsd:float.
        Returns:
        A float value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDFloat is not a valid string representation of a float value.

      • parseDouble

        double parseDouble(String lexicalXSDDouble)

        Converts the string argument into a double value.

        Parameters:
        lexicalXSDDouble - A string containing lexical representation of xsd:double.
        Returns:
        A double value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDDouble is not a valid string representation of a double value.

      • parseBoolean

        boolean parseBoolean(String lexicalXSDBoolean)

        Converts the string argument into a boolean value.

        Parameters:
        lexicalXSDBoolean - A string containing lexical representation of xsd:boolean.
        Returns:
        A boolean value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:boolean.

      • parseByte

        byte parseByte(String lexicalXSDByte)

        Converts the string argument into a byte value.

        Parameters:
        lexicalXSDByte - A string containing lexical representation of xsd:byte.
        Returns:
        A byte value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDByte does not contain a parseable byte.
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:byte.

      • parseQName

        QName parseQName(String lexicalXSDQName,
               NamespaceContext nsc)

        Converts the string argument into a QName value.

        String parameter lexicalXSDQname must conform to lexical value space specifed at XML Schema Part 2:Datatypes specification:QNames

        Parameters:
        lexicalXSDQName - A string containing lexical representation of xsd:QName.
        nsc - A namespace context for interpreting a prefix within a QName.
        Returns:
        A QName value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to XML Schema Part 2 specification or if namespace prefix of lexicalXSDQname is not bound to a URI in NamespaceContext nsc.

      • parseDateTime

        Calendar parseDateTime(String lexicalXSDDateTime)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDDateTime - A string containing lexical representation of xsd:datetime.
        Returns:
        A Calendar object represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:dateTime.

      • parseBase64Binary

        byte[] parseBase64Binary(String lexicalXSDBase64Binary)

        Converts the string argument into an array of bytes.

        Parameters:
        lexicalXSDBase64Binary - A string containing lexical representation of xsd:base64Binary.
        Returns:
        An array of bytes represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:base64Binary

      • parseHexBinary

        byte[] parseHexBinary(String lexicalXSDHexBinary)

        Converts the string argument into an array of bytes.

        Parameters:
        lexicalXSDHexBinary - A string containing lexical representation of xsd:hexBinary.
        Returns:
        An array of bytes represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:hexBinary.

      • parseUnsignedInt

        long parseUnsignedInt(String lexicalXSDUnsignedInt)

        Converts the string argument into a long value.

        Parameters:
        lexicalXSDUnsignedInt - A string containing lexical representation of xsd:unsignedInt.
        Returns:
        A long value represented by the string argument.
        Throws:
        NumberFormatException - if string parameter can not be parsed into a long value.

      • parseUnsignedShort

        int parseUnsignedShort(String lexicalXSDUnsignedShort)

        Converts the string argument into an int value.

        Parameters:
        lexicalXSDUnsignedShort - A string containing lexical representation of xsd:unsignedShort.
        Returns:
        An int value represented by the string argument.
        Throws:
        NumberFormatException - if string parameter can not be parsed into an int value.

      • parseTime

        Calendar parseTime(String lexicalXSDTime)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDTime - A string containing lexical representation of xsd:Time.
        Returns:
        A Calendar value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Time.

      • parseDate

        Calendar parseDate(String lexicalXSDDate)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDDate - A string containing lexical representation of xsd:Date.
        Returns:
        A Calendar value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Date.

      • parseAnySimpleType

        String parseAnySimpleType(String lexicalXSDAnySimpleType)

        Return a string containing the lexical representation of the simple type.

        Parameters:
        lexicalXSDAnySimpleType - A string containing lexical representation of the simple type.
        Returns:
        A string containing the lexical representation of the simple type.

      • printString

        String printString(String val)

        Converts the string argument into a string.

        Parameters:
        val - A string value.
        Returns:
        A string containing a lexical representation of xsd:string

      • printInteger

        String printInteger(BigInteger val)

        Converts a BigInteger value into a string.

        Parameters:
        val - A BigInteger value
        Returns:
        A string containing a lexical representation of xsd:integer
        Throws:
        IllegalArgumentException - val is null.

      • printInt

        String printInt(int val)

        Converts an int value into a string.

        Parameters:
        val - An int value
        Returns:
        A string containing a lexical representation of xsd:int

      • printLong

        String printLong(long val)

        Converts a long value into a string.

        Parameters:
        val - A long value
        Returns:
        A string containing a lexical representation of xsd:long

      • printShort

        String printShort(short val)

        Converts a short value into a string.

        Parameters:
        val - A short value
        Returns:
        A string containing a lexical representation of xsd:short

      • printDecimal

        String printDecimal(BigDecimal val)

        Converts a BigDecimal value into a string.

        Parameters:
        val - A BigDecimal value
        Returns:
        A string containing a lexical representation of xsd:decimal
        Throws:
        IllegalArgumentException - val is null.

      • printFloat

        String printFloat(float val)

        Converts a float value into a string.

        Parameters:
        val - A float value
        Returns:
        A string containing a lexical representation of xsd:float

      • printDouble

        String printDouble(double val)

        Converts a double value into a string.

        Parameters:
        val - A double value
        Returns:
        A string containing a lexical representation of xsd:double

      • printBoolean

        String printBoolean(boolean val)

        Converts a boolean value into a string.

        Parameters:
        val - A boolean value
        Returns:
        A string containing a lexical representation of xsd:boolean

      • printByte

        String printByte(byte val)

        Converts a byte value into a string.

        Parameters:
        val - A byte value
        Returns:
        A string containing a lexical representation of xsd:byte

      • printQName

        String printQName(QName val,
                NamespaceContext nsc)

        Converts a QName instance into a string.

        Parameters:
        val - A QName value
        nsc - A namespace context for interpreting a prefix within a QName.
        Returns:
        A string containing a lexical representation of QName
        Throws:
        IllegalArgumentException - if val is null or if nsc is non-null or nsc.getPrefix(nsprefixFromVal) is null.

      • printDateTime

        String printDateTime(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:dateTime
        Throws:
        IllegalArgumentException - if val is null.

      • printBase64Binary

        String printBase64Binary(byte[] val)

        Converts an array of bytes into a string.

        Parameters:
        val - an array of bytes
        Returns:
        A string containing a lexical representation of xsd:base64Binary
        Throws:
        IllegalArgumentException - if val is null.

      • printHexBinary

        String printHexBinary(byte[] val)

        Converts an array of bytes into a string.

        Parameters:
        val - an array of bytes
        Returns:
        A string containing a lexical representation of xsd:hexBinary
        Throws:
        IllegalArgumentException - if val is null.

      • printUnsignedInt

        String printUnsignedInt(long val)

        Converts a long value into a string.

        Parameters:
        val - A long value
        Returns:
        A string containing a lexical representation of xsd:unsignedInt

      • printUnsignedShort

        String printUnsignedShort(int val)

        Converts an int value into a string.

        Parameters:
        val - An int value
        Returns:
        A string containing a lexical representation of xsd:unsignedShort

      • printTime

        String printTime(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:time
        Throws:
        IllegalArgumentException - if val is null.

      • printDate

        String printDate(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:date
        Throws:
        IllegalArgumentException - if val is null.

      • printAnySimpleType

        String printAnySimpleType(String val)

        Converts a string value into a string.

        Parameters:
        val - A string value
        Returns:
        A string containing a lexical representation of xsd:AnySimpleType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Element (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface Element

  • public interface Element
    This is an element marker interface. Under certain circumstances, it is necessary for the binding compiler to generate derived java content classes that implement this interface. In those cases, client applications must supply element instances rather than types of elements. For more detail, see section 5.7 "Element Declaration" and 5.7.1 "Bind to Java Element Interface" of the specification.
    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.bind (Java(TM) EE 7 Specification APIs)

javax.xml.bind

Interfaces

  • DatatypeConverterInterface
  • Element
  • Marshaller
  • NotIdentifiableEvent
  • ParseConversionEvent
  • PrintConversionEvent
  • Unmarshaller
  • UnmarshallerHandler
  • ValidationEvent
  • ValidationEventHandler
  • ValidationEventLocator
  • Validator

Classes

  • Binder
  • DatatypeConverter
  • JAXB
  • JAXBContext
  • JAXBElement
  • JAXBElement.GlobalScope
  • JAXBIntrospector
  • JAXBPermission
  • Marshaller.Listener
  • SchemaOutputResolver
  • Unmarshaller.Listener

Exceptions

  • DataBindingException
  • JAXBException
  • MarshalException
  • PropertyException
  • TypeConstraintException
  • UnmarshalException
  • ValidationException


javax.xml.bind (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind

Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

See: Description

  • Interface Summary
    Interface Description
    DatatypeConverterInterface
    The DatatypeConverterInterface is for JAXB provider use only.
    Element
    This is an element marker interface.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    NotIdentifiableEvent
    This event indicates that a problem was encountered resolving an ID/IDREF.
    ParseConversionEvent
    This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
    PrintConversionEvent
    This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    UnmarshallerHandler
    Unmarshaller implemented as SAX ContentHandler.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
    ValidationEventLocator
    Encapsulate the location of a ValidationEvent.
    Validator Deprecated
    since JAXB 2.0
  • Class Summary
    Class Description
    Binder<XmlNode>
    Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.
    DatatypeConverter
    The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype.
    JAXB
    Class that defines convenience methods for common, simple use of JAXB.
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
    JAXBElement<T>
    JAXB representation of an Xml Element.
    JAXBElement.GlobalScope
    Designates global scope for an xml element.
    JAXBIntrospector
    Provide access to JAXB xml binding data for a JAXB object.
    JAXBPermission
    This class is for JAXB permissions.
    Marshaller.Listener

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.
    SchemaOutputResolver
    Controls where a JAXB implementation puts the generates schema files.
    Unmarshaller.Listener

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.
  • Exception Summary
    Exception Description
    DataBindingException
    Exception that represents a failure in a JAXB operation.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    MarshalException
    This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.
    PropertyException
    This exception indicates that an error was encountered while getting or setting a property.
    TypeConstraintException
    This exception indicates that a violation of a dynamically checked type constraint was detected.
    UnmarshalException
    This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
    ValidationException
    This exception indicates that an error has occurred while performing a validate operation.

Package javax.xml.bind Description

Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

JAXBContext is the client-entry point to the runtime binding framework.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.bind Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.Binder<XmlNode>
    • javax.xml.bind.DatatypeConverter
    • javax.xml.bind.JAXB
    • javax.xml.bind.JAXBContext
    • javax.xml.bind.JAXBElement<T> (implements java.io.Serializable)
    • javax.xml.bind.JAXBElement.GlobalScope
    • javax.xml.bind.JAXBIntrospector
    • javax.xml.bind.Marshaller.Listener
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.xml.bind.JAXBPermission
    • javax.xml.bind.SchemaOutputResolver
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
          • javax.xml.bind.PropertyException
          • javax.xml.bind.UnmarshalException
          • javax.xml.bind.ValidationException
        • java.lang.RuntimeException
          • javax.xml.bind.DataBindingException
          • javax.xml.bind.TypeConstraintException
    • javax.xml.bind.Unmarshaller.Listener

Interface Hierarchy

  • org.xml.sax.ContentHandler
    • javax.xml.bind.UnmarshallerHandler
  • javax.xml.bind.DatatypeConverterInterface
  • javax.xml.bind.Element
  • javax.xml.bind.Marshaller
  • javax.xml.bind.Unmarshaller
  • javax.xml.bind.ValidationEvent
    • javax.xml.bind.NotIdentifiableEvent
    • javax.xml.bind.ParseConversionEvent
    • javax.xml.bind.PrintConversionEvent
  • javax.xml.bind.ValidationEventHandler
  • javax.xml.bind.ValidationEventLocator
  • javax.xml.bind.Validator
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JAXB (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXB

  • java.lang.Object
    • javax.xml.bind.JAXB

  • public final class JAXB
extends Object
    Class that defines convenience methods for common, simple use of JAXB.

    Methods defined in this class are convenience methods that combine several basic operations in the JAXBContext, Unmarshaller, and Marshaller. They are designed to be the prefered methods for developers new to JAXB. They have the following characterstics:

    1. Generally speaking, the performance is not necessarily optimal. It is expected that people who need to write performance critical code will use the rest of the JAXB API directly.
    2. Errors that happen during the processing is wrapped into DataBindingException (which will have JAXBException as its cause. It is expected that people who prefer the checked exception would use the rest of the JAXB API directly.

    In addition, the unmarshal methods have the following characteristic:

    1. Schema validation is not performed on the input XML. The processing will try to continue even if there are errors in the XML, as much as possible. Only as the last resort, this method fails with DataBindingException.

    Similarly, the marshal methods have the following characteristic:

    1. The processing will try to continue even if the Java object tree does not meet the validity requirement. Only as the last resort, this method fails with DataBindingException.

    All the methods on this class require non-null arguments to all parameters. The unmarshal methods either fail with an exception or return a non-null value.

    Since:
    2.1
    Author:
    Kohsuke Kawaguchi

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static void marshal(Object jaxbObject, File xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, OutputStream xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, Result xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, String xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, URI xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, URL xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, Writer xml)
      Writes a Java object tree to XML and store it to the specified location.
      static <T> T unmarshal(File xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(InputStream xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(Reader xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(Source xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(String xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(URI xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(URL xml, Class<T> type)
      Reads in a Java object tree from the given XML input.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • unmarshal

        public static <T> T unmarshal(File xml,
              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - Reads the entire file as XML.

      • unmarshal

        public static <T> T unmarshal(URL xml,
              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The resource pointed by the URL is read in its entirety.

      • unmarshal

        public static <T> T unmarshal(URI xml,
              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The URI is turned into URL and then follows the handling of URL.

      • unmarshal

        public static <T> T unmarshal(String xml,
              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The string is first interpreted as an absolute URI. If it's not a valid absolute URI, then it's interpreted as a File

      • unmarshal

        public static <T> T unmarshal(InputStream xml,
              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The entire stream is read as an XML infoset. Upon a successful completion, the stream will be closed by this method.

      • unmarshal

        public static <T> T unmarshal(Reader xml,
              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The character stream is read as an XML infoset. The encoding declaration in the XML will be ignored. Upon a successful completion, the stream will be closed by this method.

      • unmarshal

        public static <T> T unmarshal(Source xml,
              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The XML infoset that the Source represents is read.

      • marshal

        public static void marshal(Object jaxbObject,
           File xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - XML will be written to this file. If it already exists, it will be overwritten.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           URL xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent to the resource pointed by this URL. Note that not all URLs support such operation, and exact semantics depends on the URL implementations. In case of HTTP URLs, this will perform HTTP POST.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           URI xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The URI is turned into URL and then follows the handling of URL. See above.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           String xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The string is first interpreted as an absolute URI. If it's not a valid absolute URI, then it's interpreted as a File
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           OutputStream xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent to the given OutputStream. Upon a successful completion, the stream will be closed by this method.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           Writer xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent as a character stream to the given Writer. Upon a successful completion, the stream will be closed by this method.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           Result xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent to the Result object.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JAXBContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBContext

  • java.lang.Object
    • javax.xml.bind.JAXBContext

  • public abstract class JAXBContext
extends Object

    The JAXBContext class provides the client's entry point to the JAXB API. It provides an abstraction for managing the XML/Java binding information necessary to implement the JAXB binding framework operations: unmarshal, marshal and validate.

    A client application normally obtains new instances of this class using one of these two styles for newInstance methods, although there are other specialized forms of the method available:

    • JAXBContext.newInstance( "com.acme.foo:com.acme.bar" )
      The JAXBContext instance is initialized from a list of colon separated Java package names. Each java package contains JAXB mapped classes, schema-derived classes and/or user annotated classes. Additionally, the java package may contain JAXB package annotations that must be processed. (see JLS, Section 7.4.1 "Named Packages").
    • JAXBContext.newInstance( com.acme.foo.Foo.class )
      The JAXBContext instance is intialized with class(es) passed as parameter(s) and classes that are statically reachable from these class(es). See newInstance(Class...) for details.

    SPEC REQUIREMENT: the provider must supply an implementation class containing the following method signatures:

     public static JAXBContext createContext( String contextPath, ClassLoader classLoader, Map<String,Object> properties ) throws JAXBException
 public static JAXBContext createContext( Class[] classes, Map<String,Object> properties ) throws JAXBException

    The following JAXB 1.0 requirement is only required for schema to java interface/implementation binding. It does not apply to JAXB annotated classes. JAXB Providers must generate a jaxb.properties file in each package containing schema derived classes. The property file must contain a property named javax.xml.bind.context.factory whose value is the name of the class that implements the createContext APIs.

    The class supplied by the provider does not have to be assignable to javax.xml.bind.JAXBContext, it simply has to provide a class that implements the createContext APIs.

    In addition, the provider must call the DatatypeConverter.setDatatypeConverter api prior to any client invocations of the marshal and unmarshal methods. This is necessary to configure the datatype converter that will be used during these operations.

    Unmarshalling

    The Unmarshaller class provides the client application the ability to convert XML data into a tree of Java content objects. The unmarshal method allows for any global XML element declared in the schema to be unmarshalled as the root of an instance document. Additionally, the unmarshal method allows for an unrecognized root element that has an xsi:type attribute's value that references a type definition declared in the schema to be unmarshalled as the root of an instance document. The JAXBContext object allows the merging of global elements and type definitions across a set of schemas (listed in the contextPath). Since each schema in the schema set can belong to distinct namespaces, the unification of schemas to an unmarshalling context should be namespace independent. This means that a client application is able to unmarshal XML documents that are instances of any of the schemas listed in the contextPath. For example:

            JAXBContext jc = JAXBContext.newInstance( "com.acme.foo:com.acme.bar" );
        Unmarshaller u = jc.createUnmarshaller();
        FooObject fooObj = (FooObject)u.unmarshal( new File( "foo.xml" ) ); // ok
        BarObject barObj = (BarObject)u.unmarshal( new File( "bar.xml" ) ); // ok
        BazObject bazObj = (BazObject)u.unmarshal( new File( "baz.xml" ) ); // error, "com.acme.baz" not in contextPath

    The client application may also generate Java content trees explicitly rather than unmarshalling existing XML data. For all JAXB-annotated value classes, an application can create content using constructors. For schema-derived interface/implementation classes and for the creation of elements that are not bound to a JAXB-annotated class, an application needs to have access and knowledge about each of the schema derived ObjectFactory classes that exist in each of java packages contained in the contextPath. For each schema derived java class, there is a static factory method that produces objects of that type. For example, assume that after compiling a schema, you have a package com.acme.foo that contains a schema derived interface named PurchaseOrder. In order to create objects of that type, the client application would use the factory method like this:

           com.acme.foo.PurchaseOrder po =
           com.acme.foo.ObjectFactory.createPurchaseOrder();

    Once the client application has an instance of the the schema derived object, it can use the mutator methods to set content on it.

    For more information on the generated ObjectFactory classes, see Section 4.2 Java Package of the specification.

    SPEC REQUIREMENT: the provider must generate a class in each package that contains all of the necessary object factory methods for that package named ObjectFactory as well as the static newInstance( javaContentInterface ) method

    Marshalling

    The Marshaller class provides the client application the ability to convert a Java content tree back into XML data. There is no difference between marshalling a content tree that is created manually using the factory methods and marshalling a content tree that is the result an unmarshal operation. Clients can marshal a java content tree back to XML data to a java.io.OutputStream or a java.io.Writer. The marshalling process can alternatively produce SAX2 event streams to a registered ContentHandler or produce a DOM Node object. Client applications have control over the output encoding as well as whether or not to marshal the XML data as a complete document or as a fragment.

    Here is a simple example that unmarshals an XML document and then marshals it back out:

            JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );

        // unmarshal from foo.xml
        Unmarshaller u = jc.createUnmarshaller();
        FooObject fooObj = (FooObject)u.unmarshal( new File( "foo.xml" ) );

        // marshal to System.out
        Marshaller m = jc.createMarshaller();
        m.marshal( fooObj, System.out );

    Validation

    Validation has been changed significantly since JAXB 1.0. The Validator class has been deprecated and made optional. This means that you are advised not to use this class and, in fact, it may not even be available depending on your JAXB provider. JAXB 1.0 client applications that rely on Validator will still work properly when deployed with the JAXB 1.0 runtime system. In JAXB 2.0, the Unmarshaller has included convenince methods that expose the JAXP 1.3 javax.xml.validation framework. Please refer to the Unmarshaller.setSchema(javax.xml.validation.Schema) API for more information.

    JAXB Runtime Binding Framework Compatibility

    The following JAXB 1.0 restriction only applies to binding schema to interfaces/implementation classes. Since this binding does not require a common runtime system, a JAXB client application must not attempt to mix runtime objects (JAXBContext, Marshaller, etc. ) from different providers. This does not mean that the client application isn't portable, it simply means that a client has to use a runtime system provided by the same provider that was used to compile the schema.

    Discovery of JAXB implementation

    When one of the newInstance methods is called, a JAXB implementation is discovered by the following steps.

    1. For each package/class explicitly passed in to the newInstance(java.lang.String) method, in the order they are specified, jaxb.properties file is looked up in its package, by using the associated classloader — this is the owner class loader for a Class argument, and for a package the specified ClassLoader.

      If such a file is discovered, it is loaded as a property file, and the value of the JAXB_CONTEXT_FACTORY key will be assumed to be the provider factory class. This class is then loaded by the associated classloader discussed above.

      This phase of the look up allows some packages to force the use of a certain JAXB implementation. (For example, perhaps the schema compiler has generated some vendor extension in the code.)

    2. If the system property JAXB_CONTEXT_FACTORY exists, then its value is assumed to be the provider factory class. This phase of the look up enables per-JVM override of the JAXB implementation.
    3. Look for /META-INF/services/javax.xml.bind.JAXBContext file in the associated classloader. This file follows the standard service descriptor convention, and if such a file exists, its content is assumed to be the provider factory class. This phase of the look up is for automatic discovery. It allows users to just put a JAXB implementation in a classpath and use it without any furhter configuration.
    4. Finally, if all the steps above fail, then the rest of the look up is unspecified. That said, the recommended behavior is to simply look for some hard-coded platform default JAXB implementation. This phase of the look up is so that JavaSE can have its own JAXB implementation as the last resort.

    Once the provider factory class is discovered, its public static JAXBContext createContext(String,ClassLoader,Map) method (see newInstance(String, ClassLoader, Map) for the parameter semantics.) or public static JAXBContext createContet(Class[],Map) method (see newInstance(Class[], Map) for the parameter semantics) are invoked to create a JAXBContext.

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    Marshaller, Unmarshaller, 7.4.1 "Named Packages" in Java Language Specification

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String JAXB_CONTEXT_FACTORY
      The name of the property that contains the name of the class capable of creating new JAXBContext objects.

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | JAXBContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Binder<Node> createBinder()
      Creates a Binder for W3C DOM.
      <T> Binder<T> createBinder(Class<T> domType)
      Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
      JAXBIntrospector createJAXBIntrospector()
      Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
      abstract Marshaller createMarshaller()
      Create a Marshaller object that can be used to convert a java content tree into XML data.
      abstract Unmarshaller createUnmarshaller()
      Create an Unmarshaller object that can be used to convert XML data into a java content tree.
      abstract Validator createValidator()
      Deprecated.
      since JAXB2.0
      void generateSchema(SchemaOutputResolver outputResolver)
      Generates the schema documents for this context.
      static JAXBContext newInstance(Class... classesToBeBound)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(Class[] classesToBeBound, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(String contextPath)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(String contextPath, ClassLoader classLoader)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • JAXB_CONTEXT_FACTORY

        public static final String JAXB_CONTEXT_FACTORY
        The name of the property that contains the name of the class capable of creating new JAXBContext objects.
        See Also:
        Constant Field Values

    • Constructor Detail

      • JAXBContext

        protected JAXBContext()

    • Method Detail

      • newInstance

        public static JAXBContext newInstance(String contextPath)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        This is a convenience method to invoke the newInstance(String,ClassLoader) method with the context class loader of the current thread.

        Throws:
        JAXBException - if an error was encountered while creating the JAXBContext such as
        1. failure to locate either ObjectFactory.class or jaxb.index in the packages
        2. an ambiguity among global elements contained in the contextPath
        3. failure to locate a value for the context factory provider property
        4. mixing schema derived packages from different providers on the same contextPath

      • newInstance

        public static JAXBContext newInstance(String contextPath,
                      ClassLoader classLoader)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        The client application must supply a context path which is a list of colon (':', \u003A) separated java package names that contain schema-derived classes and/or fully qualified JAXB-annotated classes. Schema-derived code is registered with the JAXBContext by the ObjectFactory.class generated per package. Alternatively than being listed in the context path, programmer annotated JAXB mapped classes can be listed in a jaxb.index resource file, format described below. Note that a java package can contain both schema-derived classes and user annotated JAXB classes. Additionally, the java package may contain JAXB package annotations that must be processed. (see JLS, Section 7.4.1 "Named Packages").

        Every package listed on the contextPath must meet one or both of the following conditions otherwise a JAXBException will be thrown:

        1. it must contain ObjectFactory.class
        2. it must contain jaxb.index

        Format for jaxb.index

        The file contains a newline-separated list of class names. Space and tab characters, as well as blank lines, are ignored. The comment character is '#' (0x23); on each line all characters following the first comment character are ignored. The file must be encoded in UTF-8. Classes that are reachable, as defined in newInstance(Class...), from the listed classes are also registered with JAXBContext.

        Constraints on class name occuring in a jaxb.index file are:

        • Must not end with ".class".
        • Class names are resolved relative to package containing jaxb.index file. Only classes occuring directly in package containing jaxb.index file are allowed.
        • Fully qualified class names are not allowed. A qualified class name,relative to current package, is only allowed to specify a nested or inner class.

        To maintain compatibility with JAXB 1.0 schema to java interface/implementation binding, enabled by schema customization <jaxb:globalBindings valueClass="false">, the JAXB provider will ensure that each package on the context path has a jaxb.properties file which contains a value for the javax.xml.bind.context.factory property and that all values resolve to the same provider. This requirement does not apply to JAXB annotated classes.

        If there are any global XML element name collisions across the various packages listed on the contextPath, a JAXBException will be thrown.

        Mixing generated interface/impl bindings from multiple JAXB Providers in the same context path may result in a JAXBException being thrown.

        The steps involved in discovering the JAXB implementation is discussed in the class javadoc.

        Parameters:
        contextPath - list of java package names that contain schema derived class and/or java to schema (JAXB-annotated) mapped classes
        classLoader - This class loader will be used to locate the implementation classes.
        Returns:
        a new instance of a JAXBContext
        Throws:
        JAXBException - if an error was encountered while creating the JAXBContext such as
        1. failure to locate either ObjectFactory.class or jaxb.index in the packages
        2. an ambiguity among global elements contained in the contextPath
        3. failure to locate a value for the context factory provider property
        4. mixing schema derived packages from different providers on the same contextPath

      • newInstance

        public static JAXBContext newInstance(String contextPath,
                      ClassLoader classLoader,
                      Map<String,?> properties)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        This is mostly the same as newInstance(String, ClassLoader), but this version allows you to pass in provider-specific properties to configure the instantiation of JAXBContext.

        The interpretation of properties is up to implementations. Implementations should throw JAXBException if it finds properties that it doesn't understand.

        Parameters:
        contextPath - list of java package names that contain schema derived classes
        classLoader - This class loader will be used to locate the implementation classes.
        properties - provider-specific properties. Can be null, which means the same thing as passing in an empty map.
        Returns:
        a new instance of a JAXBContext
        Throws:
        JAXBException - if an error was encountered while creating the JAXBContext such as
        1. failure to locate either ObjectFactory.class or jaxb.index in the packages
        2. an ambiguity among global elements contained in the contextPath
        3. failure to locate a value for the context factory provider property
        4. mixing schema derived packages from different providers on the same contextPath
        Since:
        JAXB2.0

      • newInstance

        public static JAXBContext newInstance(Class... classesToBeBound)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        The client application must supply a list of classes that the new context object needs to recognize. Not only the new context will recognize all the classes specified, but it will also recognize any classes that are directly/indirectly referenced statically from the specified classes. Subclasses of referenced classes nor @XmlTransient referenced classes are not registered with JAXBContext. For example, in the following Java code, if you do newInstance(Foo.class), the newly created JAXBContext will recognize both Foo and Bar, but not Zot or FooBar:

         class Foo {
      @XmlTransient FooBar c;
      Bar b;
 }
 class Bar { int x; }
 class Zot extends Bar { int y; }
 class FooBar { }
        Therefore, a typical client application only needs to specify the top-level classes, but it needs to be careful.

        Note that for each java package registered with JAXBContext, when the optional package annotations exist, they must be processed. (see JLS, Section 7.4.1 "Named Packages").

        The steps involved in discovering the JAXB implementation is discussed in the class javadoc.

        Parameters:
        classesToBeBound - list of java classes to be recognized by the new JAXBContext. Can be empty, in which case a JAXBContext that only knows about spec-defined classes will be returned.
        Returns:
        A new instance of a JAXBContext. Always non-null valid object.
        Throws:
        JAXBException - if an error was encountered while creating the JAXBContext, such as (but not limited to):
        1. No JAXB implementation was discovered
        2. Classes use JAXB annotations incorrectly
        3. Classes have colliding annotations (i.e., two classes with the same type name)
        4. The JAXB implementation was unable to locate provider-specific out-of-band information (such as additional files generated at the development time.)
        IllegalArgumentException - if the parameter contains null (i.e., newInstance(null);)
        Since:
        JAXB2.0

      • newInstance

        public static JAXBContext newInstance(Class[] classesToBeBound,
                      Map<String,?> properties)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        An overloading of newInstance(Class...) to configure 'properties' for this instantiation of JAXBContext.

        The interpretation of properties is up to implementations. Implementations should throw JAXBException if it finds properties that it doesn't understand.

        Parameters:
        classesToBeBound - list of java classes to be recognized by the new JAXBContext. Can be empty, in which case a JAXBContext that only knows about spec-defined classes will be returned.
        properties - provider-specific properties. Can be null, which means the same thing as passing in an empty map.
        Returns:
        A new instance of a JAXBContext. Always non-null valid object.
        Throws:
        JAXBException - if an error was encountered while creating the JAXBContext, such as (but not limited to):
        1. No JAXB implementation was discovered
        2. Classes use JAXB annotations incorrectly
        3. Classes have colliding annotations (i.e., two classes with the same type name)
        4. The JAXB implementation was unable to locate provider-specific out-of-band information (such as additional files generated at the development time.)
        IllegalArgumentException - if the parameter contains null (i.e., newInstance(null,someMap);)
        Since:
        JAXB2.0

      • createUnmarshaller

        public abstract Unmarshaller createUnmarshaller()
                                         throws JAXBException
        Create an Unmarshaller object that can be used to convert XML data into a java content tree.
        Returns:
        an Unmarshaller object
        Throws:
        JAXBException - if an error was encountered while creating the Unmarshaller object

      • createMarshaller

        public abstract Marshaller createMarshaller()
                                     throws JAXBException
        Create a Marshaller object that can be used to convert a java content tree into XML data.
        Returns:
        a Marshaller object
        Throws:
        JAXBException - if an error was encountered while creating the Marshaller object

      • createValidator

        public abstract Validator createValidator()
                                   throws JAXBException
        Deprecated. since JAXB2.0
        Validator has been made optional and deprecated in JAXB 2.0. Please refer to the javadoc for Validator for more detail.

        Create a Validator object that can be used to validate a java content tree against its source schema.

        Returns:
        a Validator object
        Throws:
        JAXBException - if an error was encountered while creating the Validator object

      • createBinder

        public <T> Binder<T> createBinder(Class<T> domType)
        Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
        Parameters:
        domType - select the DOM API to use by passing in its DOM Node class.
        Returns:
        always a new valid Binder object.
        Throws:
        UnsupportedOperationException - if DOM API corresponding to domType is not supported by the implementation.
        Since:
        JAXB2.0

      • createBinder

        public Binder<Node> createBinder()
        Creates a Binder for W3C DOM.
        Returns:
        always a new valid Binder object.
        Since:
        JAXB2.0

      • createJAXBIntrospector

        public JAXBIntrospector createJAXBIntrospector()
        Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
        Returns:
        always return a non-null valid JAXBIntrospector object.
        Throws:
        UnsupportedOperationException - Calling this method on JAXB 1.0 implementations will throw an UnsupportedOperationException.
        Since:
        JAXB2.0

      • generateSchema

        public void generateSchema(SchemaOutputResolver outputResolver)
                    throws IOException
        Generates the schema documents for this context.
        Parameters:
        outputResolver - this object controls the output to which schemas will be sent.
        Throws:
        IOException - if SchemaOutputResolver throws an IOException.
        UnsupportedOperationException - Calling this method on JAXB 1.0 implementations will throw an UnsupportedOperationException.
        Since:
        JAXB 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JAXBElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBElement<T>

  • java.lang.Object
    • javax.xml.bind.JAXBElement<T>
  • All Implemented Interfaces:
    Serializable

    public class JAXBElement<T>
extends Object
implements Serializable

    JAXB representation of an Xml Element.

    This class represents information about an Xml Element from both the element declaration within a schema and the element instance value within an xml document with the following properties

    • element's xml tag name
    • value represents the element instance's atttribute(s) and content model
    • element declaration's declaredType (xs:element @type attribute)
    • scope of element declaration
    • boolean nil property. (element instance's xsi:nil attribute)

    The declaredType and scope property are the JAXB class binding for the xml type definition.

    Scope is either JAXBElement.GlobalScope or the Java class representing the complex type definition containing the schema element declaration.

    There is a property constraint that if value is null, then nil must be true. The converse is not true to enable representing a nil element with attribute(s). If nil is true, it is possible that value is non-null so it can hold the value of the attributes associated with a nil element.

    Since:
    JAXB 2.0
    Author:
    Kohsuke Kawaguchi, Joe Fialli
    See Also:
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  JAXBElement.GlobalScope
      Designates global scope for an xml element.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Class<T> declaredType
      Java datatype binding for xml element declaration's type.
      protected QName name
      xml element tag name
      protected boolean nil
      true iff the xml element instance has xsi:nil="true".
      protected Class scope
      Scope of xml element declaration representing this xml element instance.
      protected T value
      xml element value.

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
      Construct an xml element instance.
      JAXBElement(QName name, Class<T> declaredType, T value)
      Construct an xml element instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class<T> getDeclaredType()
      Returns the Java binding of the xml element declaration's type attribute.
      QName getName()
      Returns the xml element tag name.
      Class getScope()
      Returns scope of xml element declaration.
      T getValue()
      Return the content model and attribute values for this element.
      boolean isGlobalScope()
      Returns true iff this xml element declaration is global.
      boolean isNil()
      Returns true iff this element instance content model is nil.
      boolean isTypeSubstituted()
      Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.
      void setNil(boolean value)
      Set whether this element has nil content.
      void setValue(T t)
      Set the content model and attributes of this xml element.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • name

        protected final QName name
        xml element tag name

      • declaredType

        protected final Class<T> declaredType
        Java datatype binding for xml element declaration's type.

      • scope

        protected final Class scope
        Scope of xml element declaration representing this xml element instance. Can be one of the following values: - JAXBElement.GlobalScope for global xml element declaration. - local element declaration has a scope set to the Java class representation of complex type defintion containing xml element declaration.

      • value

        protected T value
        xml element value. Represents content model and attributes of an xml element instance.

      • nil

        protected boolean nil
        true iff the xml element instance has xsi:nil="true".

    • Constructor Detail

      • JAXBElement

        public JAXBElement(QName name,
           Class<T> declaredType,
           Class scope,
           T value)

        Construct an xml element instance.

        Parameters:
        name - Java binding of xml element tag name
        declaredType - Java binding of xml element declaration's type
        scope - Java binding of scope of xml element declaration. Passing null is the same as passing GlobalScope.class
        value - Java instance representing xml element's value.
        See Also:
        getScope(), isTypeSubstituted()

      • JAXBElement

        public JAXBElement(QName name,
           Class<T> declaredType,
           T value)
        Construct an xml element instance. This is just a convenience method for new JAXBElement(name,declaredType,GlobalScope.class,value)

    • Method Detail

      • getDeclaredType

        public Class<T> getDeclaredType()
        Returns the Java binding of the xml element declaration's type attribute.

      • getName

        public QName getName()
        Returns the xml element tag name.

      • setValue

        public void setValue(T t)

        Set the content model and attributes of this xml element.

        When this property is set to null, isNil() must by true. Details of constraint are described at isNil().

        See Also:
        isTypeSubstituted()

      • getValue

        public T getValue()

        Return the content model and attribute values for this element.

        See isNil() for a description of a property constraint when this value is null

      • getScope

        public Class getScope()
        Returns scope of xml element declaration.
        Returns:
        GlobalScope.class if this element is of global scope.
        See Also:
        isGlobalScope()

      • isNil

        public boolean isNil()

        Returns true iff this element instance content model is nil.

        This property always returns true when getValue() is null. Note that the converse is not true, when this property is true, getValue() can contain a non-null value for attribute(s). It is valid for a nil xml element to have attribute(s).

      • setNil

        public void setNil(boolean value)

        Set whether this element has nil content.

        See Also:
        isNil()

      • isGlobalScope

        public boolean isGlobalScope()
        Returns true iff this xml element declaration is global.

      • isTypeSubstituted

        public boolean isTypeSubstituted()
        Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JAXBElement.GlobalScope (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBElement.GlobalScope

  • java.lang.Object
    • javax.xml.bind.JAXBElement.GlobalScope
  • Enclosing class:
    JAXBElement<T>

    public static final class JAXBElement.GlobalScope
extends Object
    Designates global scope for an xml element.

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBElement.GlobalScope()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JAXBElement.GlobalScope

        public JAXBElement.GlobalScope()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JAXBException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    MarshalException, PropertyException, UnmarshalException, ValidationException

    public class JAXBException
extends Exception
    This is the root exception class for all JAXB exceptions.
    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    See Also:
    JAXBContext, Marshaller, Unmarshaller, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBException(String message)
      Construct a JAXBException with the specified detail message.
      JAXBException(String message, String errorCode)
      Construct a JAXBException with the specified detail message and vendor specific errorCode.
      JAXBException(String message, String errorCode, Throwable exception)
      Construct a JAXBException with the specified detail message, vendor specific errorCode, and linkedException.
      JAXBException(String message, Throwable exception)
      Construct a JAXBException with the specified detail message and linkedException.
      JAXBException(Throwable exception)
      Construct a JAXBException with a linkedException.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getCause()
      String getErrorCode()
      Get the vendor specific error code
      Throwable getLinkedException()
      Get the linked exception
      void printStackTrace()
      Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
      void printStackTrace(PrintStream s)
      Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
      void printStackTrace(PrintWriter s)
      Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintWriter.
      void setLinkedException(Throwable exception)
      Add a linked Exception.
      String toString()
      Returns a short description of this JAXBException.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JAXBException

        public JAXBException(String message)
        Construct a JAXBException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • JAXBException

        public JAXBException(String message,
             String errorCode)
        Construct a JAXBException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • JAXBException

        public JAXBException(Throwable exception)
        Construct a JAXBException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • JAXBException

        public JAXBException(String message,
             Throwable exception)
        Construct a JAXBException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • JAXBException

        public JAXBException(String message,
             String errorCode,
             Throwable exception)
        Construct a JAXBException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception

    • Method Detail

      • getErrorCode

        public String getErrorCode()
        Get the vendor specific error code
        Returns:
        a string specifying the vendor specific error code

      • getLinkedException

        public Throwable getLinkedException()
        Get the linked exception
        Returns:
        the linked Exception, null if none exists

      • setLinkedException

        public void setLinkedException(Throwable exception)
        Add a linked Exception.
        Parameters:
        exception - the linked Exception (A null value is permitted and indicates that the linked exception does not exist or is unknown).

      • toString

        public String toString()
        Returns a short description of this JAXBException.
        Overrides:
        toString in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace()
        Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
        Overrides:
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintWriter.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintWriter to use for output

      • getCause

        public Throwable getCause()
        Overrides:
        getCause in class Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JAXBIntrospector (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBIntrospector

  • java.lang.Object
    • javax.xml.bind.JAXBIntrospector

  • public abstract class JAXBIntrospector
extends Object
    Provide access to JAXB xml binding data for a JAXB object.

    Intially, the intent of this class is to just conceptualize how a JAXB application developer can access xml binding information, independent if binding model is java to schema or schema to java. Since accessing the XML element name related to a JAXB element is a highly requested feature, demonstrate access to this binding information. The factory method to get a JAXBIntrospector instance is JAXBContext.createJAXBIntrospector().

    Since:
    JAXB2.0
    See Also:
    JAXBContext.createJAXBIntrospector()

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBIntrospector()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract QName getElementName(Object jaxbElement)
      Get xml element qname for jaxbElement.
      static Object getValue(Object jaxbElement)
      Get the element value of a JAXB element.
      abstract boolean isElement(Object object)
      Return true if object represents a JAXB element.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JAXBIntrospector

        public JAXBIntrospector()

    • Method Detail

      • isElement

        public abstract boolean isElement(Object object)

        Return true if object represents a JAXB element.

        Parameter object is a JAXB element for following cases:

        1. It is an instance of javax.xml.bind.JAXBElement.
        2. The class of object is annotated with @XmlRootElement.
        See Also:
        getElementName(Object)

      • getElementName

        public abstract QName getElementName(Object jaxbElement)

        Get xml element qname for jaxbElement.

        Parameters:
        jaxbElement - is an object that isElement(Object) returned true.
        Returns:
        xml element qname associated with jaxbElement; null if jaxbElement is not a JAXB Element.

      • getValue

        public static Object getValue(Object jaxbElement)

        Get the element value of a JAXB element.

        Convenience method to abstract whether working with either a javax.xml.bind.JAXBElement instance or an instance of @XmlRootElement annotated Java class.

        Parameters:
        jaxbElement - object that #isElement(Object) returns true.
        Returns:
        The element value of the jaxbElement.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JAXBPermission (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.xml.bind.JAXBPermission
  • All Implemented Interfaces:
    Serializable, Guard

    public final class JAXBPermission
extends BasicPermission
    This class is for JAXB permissions. A JAXBPermission contains a name (also referred to as a "target name") but no actions list; you either have the named permission or you don't.

    The target name is the name of the JAXB permission (see below).

    The following table lists all the possible JAXBPermission target names, and for each provides a description of what the permission allows and a discussion of the risks of granting code the permission.

    Permission Target Name | What the Permission Allows | Risks of Allowing this Permission
    setDatatypeConverter | Allows the code to set VM-wide DatatypeConverterInterface via the setDatatypeConverter method that all the methods on DatatypeConverter uses. | Malicious code can set DatatypeConverterInterface, which has VM-wide singleton semantics, before a genuine JAXB implementation sets one. This allows malicious code to gain access to objects that it may otherwise not have access to, such as Frame#getFrames() that belongs to another application running in the same JVM.
    Since:
    JAXB 2.2
    Author:
    Joe Fialli
    See Also:
    BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBPermission(String name)
      Creates a new JAXBPermission with the specified name.

    • Method Summary

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JAXBPermission

        public JAXBPermission(String name)
        Creates a new JAXBPermission with the specified name.
        Parameters:
        name - The name of the JAXBPermission. As of 2.2 only "setDatatypeConverter" is defined.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MarshalException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class MarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
  • All Implemented Interfaces:
    Serializable

    public class MarshalException
extends JAXBException
    This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.

    The ValidationEventHandler can cause this exception to be thrown during the marshal operations. See ValidationEventHandler.handleEvent(ValidationEvent).

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    See Also:
    JAXBException, Marshaller, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MarshalException(String message)
      Construct a MarshalException with the specified detail message.
      MarshalException(String message, String errorCode)
      Construct a MarshalException with the specified detail message and vendor specific errorCode.
      MarshalException(String message, String errorCode, Throwable exception)
      Construct a MarshalException with the specified detail message, vendor specific errorCode, and linkedException.
      MarshalException(String message, Throwable exception)
      Construct a MarshalException with the specified detail message and linkedException.
      MarshalException(Throwable exception)
      Construct a MarshalException with a linkedException.

    • Method Summary

      • Methods inherited from class javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MarshalException

        public MarshalException(String message)
        Construct a MarshalException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • MarshalException

        public MarshalException(String message,
                String errorCode)
        Construct a MarshalException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • MarshalException

        public MarshalException(Throwable exception)
        Construct a MarshalException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • MarshalException

        public MarshalException(String message,
                Throwable exception)
        Construct a MarshalException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • MarshalException

        public MarshalException(String message,
                String errorCode,
                Throwable exception)
        Construct a MarshalException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Marshaller (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface Marshaller

  • All Known Implementing Classes:
    AbstractMarshallerImpl

    public interface Marshaller

    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data. It provides the basic marshalling methods:

    Assume the following setup code for all following code fragments:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object element = u.unmarshal( new File( "foo.xml" ) );
       Marshaller m = jc.createMarshaller();

    Marshalling to a File:

           OutputStream os = new FileOutputStream( "nosferatu.xml" );
       m.marshal( element, os );

    Marshalling to a SAX ContentHandler:

           // assume MyContentHandler instanceof ContentHandler
       m.marshal( element, new MyContentHandler() );

    Marshalling to a DOM Node:

           DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.newDocument();

       m.marshal( element, doc );

    Marshalling to a java.io.OutputStream:

           m.marshal( element, System.out );

    Marshalling to a java.io.Writer:

           m.marshal( element, new PrintWriter( System.out ) );

    Marshalling to a javax.xml.transform.SAXResult:

           // assume MyContentHandler instanceof ContentHandler
       SAXResult result = new SAXResult( new MyContentHandler() );

       m.marshal( element, result );

    Marshalling to a javax.xml.transform.DOMResult:

           DOMResult result = new DOMResult();

       m.marshal( element, result );

    Marshalling to a javax.xml.transform.StreamResult:

           StreamResult result = new StreamResult( System.out );

       m.marshal( element, result );

    Marshalling to a javax.xml.stream.XMLStreamWriter:

           XMLStreamWriter xmlStreamWriter =
           XMLOutputFactory.newInstance().createXMLStreamWriter( ... );

       m.marshal( element, xmlStreamWriter );

    Marshalling to a javax.xml.stream.XMLEventWriter:

           XMLEventWriter xmlEventWriter =
           XMLOutputFactory.newInstance().createXMLEventWriter( ... );

       m.marshal( element, xmlEventWriter );

    Marshalling content tree rooted by a JAXB element

    The first parameter of the overloaded Marshaller.marshal(java.lang.Object, ...) methods must be a JAXB element as computed by JAXBIntrospector.isElement(java.lang.Object); otherwise, a Marshaller.marshal method must throw a MarshalException. There exist two mechanisms to enable marshalling an instance that is not a JAXB element. One method is to wrap the instance as a value of a JAXBElement, and pass the wrapper element as the first parameter to a Marshaller.marshal method. For java to schema binding, it is also possible to simply annotate the instance's class with @XmlRootElement.

    Encoding

    By default, the Marshaller will use UTF-8 encoding when generating XML data to a java.io.OutputStream, or a java.io.Writer. Use the setProperty API to change the output encoding used during these marshal operations. Client applications are expected to supply a valid character encoding name as defined in the W3C XML 1.0 Recommendation and supported by your Java Platform.

    Validation and Well-Formedness

    Client applications are not required to validate the Java content tree prior to calling any of the marshal API's. Furthermore, there is no requirement that the Java content tree be valid with respect to its original schema in order to marshal it back into XML data. Different JAXB Providers will support marshalling invalid Java content trees at varying levels, however all JAXB Providers must be able to marshal a valid content tree back to XML data. A JAXB Provider must throw a MarshalException when it is unable to complete the marshal operation due to invalid content. Some JAXB Providers will fully allow marshalling invalid content, others will fail on the first validation error.

    Even when schema validation is not explictly enabled for the marshal operation, it is possible that certain types of validation events will be detected during the operation. Validation events will be reported to the registered event handler. If the client application has not registered an event handler prior to invoking one of the marshal API's, then events will be delivered to a default event handler which will terminate the marshal operation after encountering the first error or fatal error. Note that for JAXB 2.0 and later versions, DefaultValidationEventHandler is no longer used.

    Supported Properties

    All JAXB Providers are required to support the following set of properties. Some providers may support additional properties.

    jaxb.encoding - value must be a java.lang.String
    The output encoding to use when marshalling the XML data. The Marshaller will use "UTF-8" by default if this property is not specified.
    jaxb.formatted.output - value must be a java.lang.Boolean
    This property controls whether or not the Marshaller will format the resulting XML data with line breaks and indentation. A true value for this property indicates human readable indented xml data, while a false value indicates unformatted xml data. The Marshaller will default to false (unformatted) if this property is not specified.
    jaxb.schemaLocation - value must be a java.lang.String
    This property allows the client application to specify an xsi:schemaLocation attribute in the generated XML data. The format of the schemaLocation attribute value is discussed in an easy to understand, non-normative form in Section 5.6 of the W3C XML Schema Part 0: Primer and specified in Section 2.6 of the W3C XML Schema Part 1: Structures.
    jaxb.noNamespaceSchemaLocation - value must be a java.lang.String
    This property allows the client application to specify an xsi:noNamespaceSchemaLocation attribute in the generated XML data. The format of the schemaLocation attribute value is discussed in an easy to understand, non-normative form in Section 5.6 of the W3C XML Schema Part 0: Primer and specified in Section 2.6 of the W3C XML Schema Part 1: Structures.
    jaxb.fragment - value must be a java.lang.Boolean
    This property determines whether or not document level events will be generated by the Marshaller. If the property is not specified, the default is false. This property has different implications depending on which marshal api you are using - when this property is set to true:
    • marshal(Object,ContentHandler) - the Marshaller won't
             invoke ContentHandler.startDocument() and
             ContentHandler.endDocument().
    • marshal(Object,Node) - the property has no effect on this API.
    • marshal(Object,OutputStream) - the Marshaller won't generate an xml declaration.
    • marshal(Object,Writer) - the Marshaller won't generate an xml declaration.
    • marshal(Object,Result) - depends on the kind of Result object, see semantics for Node, ContentHandler, and Stream APIs
    • marshal(Object,XMLEventWriter) - the Marshaller will not generate XMLStreamConstants.START_DOCUMENT and XMLStreamConstants.END_DOCUMENT events.
    • marshal(Object,XMLStreamWriter) - the Marshaller will not generate XMLStreamConstants.START_DOCUMENT and XMLStreamConstants.END_DOCUMENT events.

    Marshal Event Callbacks

    "The Marshaller provides two styles of callback mechanisms that allow application specific processing during key points in the unmarshalling process. In 'class defined' event callbacks, application specific code placed in JAXB mapped classes is triggered during marshalling. 'External listeners' allow for centralized processing of marshal events in one callback method rather than by type event callbacks.

    Class defined event callback methods allow any JAXB mapped class to specify its own specific callback methods by defining methods with the following method signatures:

       // Invoked by Marshaller after it has created an instance of this object.
   boolean beforeMarshal(Marshaller);

   // Invoked by Marshaller after it has marshalled all properties of this object.
   void afterMmarshal(Marshaller);
    The class defined event callback methods should be used when the callback method requires access to non-public methods and/or fields of the class.

    The external listener callback mechanism enables the registration of a Marshaller.Listener instance with a setListener(Listener). The external listener receives all callback events, allowing for more centralized processing than per class defined callback methods.

    The 'class defined' and external listener event callback methods are independent of each other, both can be called for one event. The invocation ordering when both listener callback methods exist is defined in Marshaller.Listener.beforeMarshal(Object) and Marshaller.Listener.afterMarshal(Object).

    An event callback method throwing an exception terminates the current marshal process.

    Since:
    JAXB1.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    JAXBContext, Validator, Unmarshaller

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  Marshaller.Listener

      Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String JAXB_ENCODING
      The name of the property used to specify the output encoding in the marshalled XML data.
      static String JAXB_FORMATTED_OUTPUT
      The name of the property used to specify whether or not the marshalled XML data is formatted with linefeeds and indentation.
      static String JAXB_FRAGMENT
      The name of the property used to specify whether or not the marshaller will generate document level events (ie calling startDocument or endDocument).
      static String JAXB_NO_NAMESPACE_SCHEMA_LOCATION
      The name of the property used to specify the xsi:noNamespaceSchemaLocation attribute value to place in the marshalled XML output.
      static String JAXB_SCHEMA_LOCATION
      The name of the property used to specify the xsi:schemaLocation attribute value to place in the marshalled XML output.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <A extends XmlAdapter>
      A             		getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      AttachmentMarshaller getAttachmentMarshaller()
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Marshaller.Listener getListener()
      Return Marshaller.Listener registered with this Marshaller.
      Node getNode(Object contentTree)
      Get a DOM tree view of the content tree(Optional).
      Object getProperty(String name)
      Get the particular property in the underlying implementation of Marshaller.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
      void marshal(Object jaxbElement, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.
      void marshal(Object jaxbElement, File output)
      Marshal the content tree rooted at jaxbElement into a file.
      void marshal(Object jaxbElement, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      void marshal(Object jaxbElement, OutputStream os)
      Marshal the content tree rooted at jaxbElement into an output stream.
      void marshal(Object jaxbElement, Result result)
      Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.
      void marshal(Object jaxbElement, Writer writer)
      Marshal the content tree rooted at jaxbElement into a Writer.
      void marshal(Object jaxbElement, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
      void marshal(Object jaxbElement, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
      <A extends XmlAdapter>
      void             		setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAttachmentMarshaller(AttachmentMarshaller am)
      Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void setListener(Marshaller.Listener listener)
      Register marshal event callback Marshaller.Listener with this Marshaller.
      void setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Marshaller.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.

    • Field Detail

      • JAXB_ENCODING

        static final String JAXB_ENCODING
        The name of the property used to specify the output encoding in the marshalled XML data.
        See Also:
        Constant Field Values

      • JAXB_FORMATTED_OUTPUT

        static final String JAXB_FORMATTED_OUTPUT
        The name of the property used to specify whether or not the marshalled XML data is formatted with linefeeds and indentation.
        See Also:
        Constant Field Values

      • JAXB_SCHEMA_LOCATION

        static final String JAXB_SCHEMA_LOCATION
        The name of the property used to specify the xsi:schemaLocation attribute value to place in the marshalled XML output.
        See Also:
        Constant Field Values

      • JAXB_NO_NAMESPACE_SCHEMA_LOCATION

        static final String JAXB_NO_NAMESPACE_SCHEMA_LOCATION
        The name of the property used to specify the xsi:noNamespaceSchemaLocation attribute value to place in the marshalled XML output.
        See Also:
        Constant Field Values

      • JAXB_FRAGMENT

        static final String JAXB_FRAGMENT
        The name of the property used to specify whether or not the marshaller will generate document level events (ie calling startDocument or endDocument).
        See Also:
        Constant Field Values

    • Method Detail

      • marshal

        void marshal(Object jaxbElement,
           Result result)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.

        All JAXB Providers must at least support DOMResult, SAXResult, and StreamResult. It can support other derived classes of Result as well.

        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        result - XML will be sent to this Result
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException` - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
           OutputStream os)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into an output stream.
        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        os - XML will be added to this stream.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
           File output)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into a file.
        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        output - File to be written. If this file already exists, it will be overwritten.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null
        Since:
        JAXB2.1

      • marshal

        void marshal(Object jaxbElement,
           Writer writer)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into a Writer.
        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        writer - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
           ContentHandler handler)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into SAX2 events.
        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        handler - XML will be sent to this handler as SAX2 events.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
           Node node)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into a DOM tree.
        Parameters:
        jaxbElement - The content tree to be marshalled.
        node - DOM nodes will be added as children of this node. This parameter must be a Node that accepts children (Document, DocumentFragment, or Element)
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal jaxbElement (or any object reachable from jaxbElement). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
           XMLStreamWriter writer)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
        Parameters:
        jaxbElement - The content tree to be marshalled.
        writer - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null
        Since:
        JAXB 2.0

      • marshal

        void marshal(Object jaxbElement,
           XMLEventWriter writer)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
        Parameters:
        jaxbElement - The content tree rooted at jaxbElement to be marshalled.
        writer - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null
        Since:
        JAXB 2.0

      • getNode

        Node getNode(Object contentTree)
             throws JAXBException
        Get a DOM tree view of the content tree(Optional). If the returned DOM tree is updated, these changes are also visible in the content tree. Use marshal(Object, org.w3c.dom.Node) to force a deep copy of the content tree to a DOM representation.
        Parameters:
        contentTree - - JAXB Java representation of XML content
        Returns:
        the DOM tree view of the contentTree
        Throws:
        UnsupportedOperationException - If the JAXB provider implementation does not support a DOM view of the content tree
        IllegalArgumentException - If any of the method parameters are null
        JAXBException - If any unexpected problem occurs

      • setProperty

        void setProperty(String name,
               Object value)
                 throws PropertyException
        Set the particular property in the underlying implementation of Marshaller. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        Object getProperty(String name)
                   throws PropertyException
        Get the particular property in the underlying implementation of Marshaller. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null

      • setEventHandler

        void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the marshal API's. If the client application does not register a validation event handler before invoking one of the marshal methods, then validation events will be handled by the default event handler which will terminate the marshal operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Marshaller to revert back to the default default event handler.

        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler

      • setAdapter

        void setAdapter(XmlAdapter adapter)
        Associates a configured instance of XmlAdapter with this marshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        Throws:
        IllegalArgumentException - if the adapter parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB 2.0
        See Also:
        setAdapter(Class,XmlAdapter)

      • setAdapter

        <A extends XmlAdapter> void setAdapter(Class<A> type,
                                     A adapter)
        Associates a configured instance of XmlAdapter with this marshaller.

        Every marshaller internally maintains a Map<Class,XmlAdapter>, which it uses for marshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, a marshaller will create one by invoking its default constructor.

        Parameters:
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.
        Throws:
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB 2.0

      • getAdapter

        <A extends XmlAdapter> A getAdapter(Class<A> type)
        Gets the adapter associated with the specified type. This is the reverse operation of the setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        Throws:
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB 2.0

      • setAttachmentMarshaller

        void setAttachmentMarshaller(AttachmentMarshaller am)

        Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment. The attachment is referenced from the XML document content model by content-id URIs(cid) references stored within the xml document.

        Throws:
        IllegalStateException - if attempt to concurrently call this method during a marshal operation.

      • getAttachmentMarshaller

        AttachmentMarshaller getAttachmentMarshaller()

      • setSchema

        void setSchema(Schema schema)
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against. Passing null into this method will disable validation.

        This method allows the caller to validate the marshalled XML as it's marshalled.

        Initially this property is set to null.

        Parameters:
        schema - Schema object to validate marshal operations against or null to disable validation
        Throws:
        UnsupportedOperationException - could be thrown if this method is invoked on an Marshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        Since:
        JAXB2.0

      • getSchema

        Schema getSchema()
        Get the JAXP 1.3 Schema object being used to perform marshal-time validation. If there is no Schema set on the marshaller, then this method will return null indicating that marshal-time validation will not be performed.
        Returns:
        the Schema object being used to perform marshal-time validation or null if not present.
        Throws:
        UnsupportedOperationException - could be thrown if this method is invoked on an Marshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        Since:
        JAXB2.0

      • setListener

        void setListener(Marshaller.Listener listener)

        Register marshal event callback Marshaller.Listener with this Marshaller.

        There is only one Listener per Marshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        Parameters:
        listener - an instance of a class that implements Marshaller.Listener
        Since:
        JAXB2.0

      • getListener

        Marshaller.Listener getListener()

        Return Marshaller.Listener registered with this Marshaller.

        Returns:
        registered Marshaller.Listener or null if no Listener is registered with this Marshaller.
        Since:
        JAXB2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Marshaller.Listener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class Marshaller.Listener

  • java.lang.Object
    • javax.xml.bind.Marshaller.Listener
  • Enclosing interface:
    Marshaller

    public abstract static class Marshaller.Listener
extends Object

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.

    This class enables pre and post processing of each marshalled object. The event callbacks are called when marshalling from an instance that maps to an xml element or complex type definition. The event callbacks are not called when marshalling from an instance of a Java datatype that represents a simple type definition.

    External listener is one of two different mechanisms for defining marshal event callbacks. See Marshal Event Callbacks for an overview.

    Since:
    JAXB2.0
    See Also:
    Marshaller.setListener(Listener), Marshaller.getListener()

    • Constructor Summary

      Constructors
      Constructor and Description
      Marshaller.Listener()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterMarshal(Object source)

      Callback method invoked after marshalling source to XML.
      void beforeMarshal(Object source)

      Callback method invoked before marshalling from source to XML.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Marshaller.Listener

        public Marshaller.Listener()

    • Method Detail

      • beforeMarshal

        public void beforeMarshal(Object source)

        Callback method invoked before marshalling from source to XML.

        This method is invoked just before marshalling process starts to marshal source. Note that if the class of source defines its own beforeMarshal method, the class specific callback method is invoked just before this method is invoked.

        Parameters:
        source - instance of JAXB mapped class prior to marshalling from it.

      • afterMarshal

        public void afterMarshal(Object source)

        Callback method invoked after marshalling source to XML.

        This method is invoked after source and all its descendants have been marshalled. Note that if the class of source defines its own afterMarshal method, the class specific callback method is invoked just before this method is invoked.

        Parameters:
        source - instance of JAXB mapped class after marshalling it.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NotIdentifiableEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface NotIdentifiableEvent

  • All Superinterfaces:
    ValidationEvent
    All Known Implementing Classes:
    NotIdentifiableEventImpl

    public interface NotIdentifiableEvent
extends ValidationEvent
    This event indicates that a problem was encountered resolving an ID/IDREF.
    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    Validator, ValidationEventHandler

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Method Summary

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ParseConversionEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface ParseConversionEvent

  • All Superinterfaces:
    ValidationEvent
    All Known Implementing Classes:
    ParseConversionEventImpl

    public interface ParseConversionEvent
extends ValidationEvent
    This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    ValidationEvent, ValidationEventHandler, Unmarshaller

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Method Summary

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PrintConversionEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface PrintConversionEvent

  • All Superinterfaces:
    ValidationEvent
    All Known Implementing Classes:
    PrintConversionEventImpl

    public interface PrintConversionEvent
extends ValidationEvent
    This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    ValidationEvent, ValidationEventHandler, Marshaller

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Method Summary

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PropertyException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class PropertyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.PropertyException
  • All Implemented Interfaces:
    Serializable

    public class PropertyException
extends JAXBException
    This exception indicates that an error was encountered while getting or setting a property.
    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    JAXBContext, Validator, Unmarshaller, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      PropertyException(String message)
      Construct a PropertyException with the specified detail message.
      PropertyException(String name, Object value)
      Construct a PropertyException whose message field is set based on the name of the property and value.toString().
      PropertyException(String message, String errorCode)
      Construct a PropertyException with the specified detail message and vendor specific errorCode.
      PropertyException(String message, String errorCode, Throwable exception)
      Construct a PropertyException with the specified detail message, vendor specific errorCode, and linkedException.
      PropertyException(String message, Throwable exception)
      Construct a PropertyException with the specified detail message and linkedException.
      PropertyException(Throwable exception)
      Construct a PropertyException with a linkedException.

    • Method Summary

      • Methods inherited from class javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PropertyException

        public PropertyException(String message)
        Construct a PropertyException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • PropertyException

        public PropertyException(String message,
                 String errorCode)
        Construct a PropertyException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • PropertyException

        public PropertyException(Throwable exception)
        Construct a PropertyException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • PropertyException

        public PropertyException(String message,
                 Throwable exception)
        Construct a PropertyException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • PropertyException

        public PropertyException(String message,
                 String errorCode,
                 Throwable exception)
        Construct a PropertyException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception

      • PropertyException

        public PropertyException(String name,
                 Object value)
        Construct a PropertyException whose message field is set based on the name of the property and value.toString().
        Parameters:
        name - the name of the property related to this exception
        value - the value of the property related to this exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SchemaOutputResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class SchemaOutputResolver

  • java.lang.Object
    • javax.xml.bind.SchemaOutputResolver

  • public abstract class SchemaOutputResolver
extends Object
    Controls where a JAXB implementation puts the generates schema files.

    An implementation of this abstract class has to be provided by the calling application to generate schemas.

    This is a class, not an interface so as to allow future versions to evolve without breaking the compatibility.

    Author:
    Kohsuke Kawaguchi (kohsuke.kawaguchi@sun.com)

    • Constructor Summary

      Constructors
      Constructor and Description
      SchemaOutputResolver()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Result createOutput(String namespaceUri, String suggestedFileName)
      Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SchemaOutputResolver

        public SchemaOutputResolver()

    • Method Detail

      • createOutput

        public abstract Result createOutput(String namespaceUri,
                  String suggestedFileName)
                             throws IOException
        Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.

        This method is called only once for any given namespace. IOW, all the components in one namespace is always written into the same schema document.

        Parameters:
        namespaceUri - The namespace URI that the schema declares. Can be the empty string, but never be null.
        suggestedFileName - A JAXB implementation generates an unique file name (like "schema1.xsd") for the convenience of the callee. This name can be used for the file name of the schema, or the callee can just ignore this name and come up with its own name. This is just a hint.
        Returns:
        a Result object that encapsulates the actual destination of the schema. If the Result object has a system ID, it must be an absolute system ID. Those system IDs are relativized by the caller and used for <xs:import> statements. If the Result object does not have a system ID, a schema for the namespace URI is generated but it won't be explicitly <xs:import>ed from other schemas. If null is returned, the schema generation for this namespace URI will be skipped.
        Throws:
        IOException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TypeConstraintException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class TypeConstraintException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.bind.TypeConstraintException
  • All Implemented Interfaces:
    Serializable

    public class TypeConstraintException
extends RuntimeException
    This exception indicates that a violation of a dynamically checked type constraint was detected.

    This exception can be thrown by the generated setter methods of the schema derived Java content classes. However, since fail-fast validation is an optional feature for JAXB Providers to support, not all setter methods will throw this exception when a type constraint is violated.

    If this exception is throw while invoking a fail-fast setter, the value of the property is guaranteed to remain unchanged, as if the setter were never called.

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    ValidationEvent, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeConstraintException(String message)
      Construct a TypeConstraintException with the specified detail message.
      TypeConstraintException(String message, String errorCode)
      Construct a TypeConstraintException with the specified detail message and vendor specific errorCode.
      TypeConstraintException(String message, String errorCode, Throwable exception)
      Construct a TypeConstraintException with the specified detail message, vendor specific errorCode, and linkedException.
      TypeConstraintException(String message, Throwable exception)
      Construct a TypeConstraintException with the specified detail message and linkedException.
      TypeConstraintException(Throwable exception)
      Construct a TypeConstraintException with a linkedException.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getErrorCode()
      Get the vendor specific error code
      Throwable getLinkedException()
      Get the linked exception
      void printStackTrace()
      Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
      void printStackTrace(PrintStream s)
      Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
      void setLinkedException(Throwable exception)
      Add a linked Exception.
      String toString()
      Returns a short description of this TypeConstraintException.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TypeConstraintException

        public TypeConstraintException(String message)
        Construct a TypeConstraintException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • TypeConstraintException

        public TypeConstraintException(String message,
                       String errorCode)
        Construct a TypeConstraintException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • TypeConstraintException

        public TypeConstraintException(Throwable exception)
        Construct a TypeConstraintException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • TypeConstraintException

        public TypeConstraintException(String message,
                       Throwable exception)
        Construct a TypeConstraintException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • TypeConstraintException

        public TypeConstraintException(String message,
                       String errorCode,
                       Throwable exception)
        Construct a TypeConstraintException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception

    • Method Detail

      • getErrorCode

        public String getErrorCode()
        Get the vendor specific error code
        Returns:
        a string specifying the vendor specific error code

      • getLinkedException

        public Throwable getLinkedException()
        Get the linked exception
        Returns:
        the linked Exception, null if none exists

      • setLinkedException

        public void setLinkedException(Throwable exception)
        Add a linked Exception.
        Parameters:
        exception - the linked Exception (A null value is permitted and indicates that the linked exception does not exist or is unknown).

      • toString

        public String toString()
        Returns a short description of this TypeConstraintException.
        Overrides:
        toString in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace()
        Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
        Overrides:
        printStackTrace in class Throwable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UnmarshalException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class UnmarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.UnmarshalException
  • All Implemented Interfaces:
    Serializable

    public class UnmarshalException
extends JAXBException
    This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.

    The ValidationEventHandler can cause this exception to be thrown during the unmarshal operations. See ValidationEventHandler.handleEvent(ValidationEvent).

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    See Also:
    JAXBException, Unmarshaller, ValidationEventHandler, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      UnmarshalException(String message)
      Construct an UnmarshalException with the specified detail message.
      UnmarshalException(String message, String errorCode)
      Construct an UnmarshalException with the specified detail message and vendor specific errorCode.
      UnmarshalException(String message, String errorCode, Throwable exception)
      Construct an UnmarshalException with the specified detail message, vendor specific errorCode, and linkedException.
      UnmarshalException(String message, Throwable exception)
      Construct an UnmarshalException with the specified detail message and linkedException.
      UnmarshalException(Throwable exception)
      Construct an UnmarshalException with a linkedException.

    • Method Summary

      • Methods inherited from class javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnmarshalException

        public UnmarshalException(String message)
        Construct an UnmarshalException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • UnmarshalException

        public UnmarshalException(String message,
                  String errorCode)
        Construct an UnmarshalException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • UnmarshalException

        public UnmarshalException(Throwable exception)
        Construct an UnmarshalException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • UnmarshalException

        public UnmarshalException(String message,
                  Throwable exception)
        Construct an UnmarshalException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • UnmarshalException

        public UnmarshalException(String message,
                  String errorCode,
                  Throwable exception)
        Construct an UnmarshalException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Unmarshaller (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface Unmarshaller

  • All Known Implementing Classes:
    AbstractUnmarshallerImpl

    public interface Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled. It provides an overloading of unmarshal methods for many different input kinds.

    Unmarshalling from a File:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object o = u.unmarshal( new File( "nosferatu.xml" ) );

    Unmarshalling from an InputStream:

           InputStream is = new FileInputStream( "nosferatu.xml" );
       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object o = u.unmarshal( is );

    Unmarshalling from a URL:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       URL url = new URL( "http://beaker.east/nosferatu.xml" );
       Object o = u.unmarshal( url );

    Unmarshalling from a StringBuffer using a javax.xml.transform.stream.StreamSource:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       StringBuffer xmlStr = new StringBuffer( "<?xml version="1.0"?>..." );
       Object o = u.unmarshal( new StreamSource( new StringReader( xmlStr.toString() ) ) );

    Unmarshalling from a org.w3c.dom.Node:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.parse(new File( "nosferatu.xml"));

       Object o = u.unmarshal( doc );

    Unmarshalling from a javax.xml.transform.sax.SAXSource using a client specified validating SAX2.0 parser:

           // configure a validating SAX2.0 parser (Xerces2)
       static final String JAXP_SCHEMA_LANGUAGE =
           "http://java.sun.com/xml/jaxp/properties/schemaLanguage";
       static final String JAXP_SCHEMA_LOCATION =
           "http://java.sun.com/xml/jaxp/properties/schemaSource";
       static final String W3C_XML_SCHEMA =
           "http://www.w3.org/2001/XMLSchema";

       System.setProperty( "javax.xml.parsers.SAXParserFactory",
                           "org.apache.xerces.jaxp.SAXParserFactoryImpl" );

       SAXParserFactory spf = SAXParserFactory.newInstance();
       spf.setNamespaceAware(true);
       spf.setValidating(true);
       SAXParser saxParser = spf.newSAXParser();

       try {
           saxParser.setProperty(JAXP_SCHEMA_LANGUAGE, W3C_XML_SCHEMA);
           saxParser.setProperty(JAXP_SCHEMA_LOCATION, "http://....");
       } catch (SAXNotRecognizedException x) {
           // exception handling omitted
       }

       XMLReader xmlReader = saxParser.getXMLReader();
       SAXSource source =
           new SAXSource( xmlReader, new InputSource( "http://..." ) );

       // Setup JAXB to unmarshal
       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       ValidationEventCollector vec = new ValidationEventCollector();
       u.setEventHandler( vec );

       // turn off the JAXB provider's default validation mechanism to
       // avoid duplicate validation
       u.setValidating( false )

       // unmarshal
       Object o = u.unmarshal( source );

       // check for events
       if( vec.hasEvents() ) {
          // iterate over events
       }

    Unmarshalling from a StAX XMLStreamReader:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       javax.xml.stream.XMLStreamReader xmlStreamReader =
           javax.xml.stream.XMLInputFactory().newInstance().createXMLStreamReader( ... );

       Object o = u.unmarshal( xmlStreamReader );

    Unmarshalling from a StAX XMLEventReader:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       javax.xml.stream.XMLEventReader xmlEventReader =
           javax.xml.stream.XMLInputFactory().newInstance().createXMLEventReader( ... );

       Object o = u.unmarshal( xmlEventReader );

    Unmarshalling XML Data

    Unmarshalling can deserialize XML data that represents either an entire XML document or a subtree of an XML document. Typically, it is sufficient to use the unmarshalling methods described by Unmarshal root element that is declared globally. These unmarshal methods utilize JAXBContext's mapping of global XML element declarations and type definitions to JAXB mapped classes to initiate the unmarshalling of the root element of XML data. When the JAXBContext's mappings are not sufficient to unmarshal the root element of XML data, the application can assist the unmarshalling process by using the unmarshal by declaredType methods. These methods are useful for unmarshalling XML data where the root element corresponds to a local element declaration in the schema.
    An unmarshal method never returns null. If the unmarshal process is unable to unmarshal the root of XML content to a JAXB mapped object, a fatal error is reported that terminates processing by throwing JAXBException.

    Unmarshal a root element that is globally declared

    The unmarshal methods that do not have an declaredType parameter use JAXBContext to unmarshal the root element of an XML data. The JAXBContext instance is the one that was used to create this Unmarshaller. The JAXBContext instance maintains a mapping of globally declared XML element and type definition names to JAXB mapped classes. The unmarshal method checks if JAXBContext has a mapping from the root element's XML name and/or @xsi:type to a JAXB mapped class. If it does, it umarshalls the XML data using the appropriate JAXB mapped class. Note that when the root element name is unknown and the root element has an @xsi:type, the XML data is unmarshalled using that JAXB mapped class as the value of a JAXBElement. When the JAXBContext object does not have a mapping for the root element's name nor its @xsi:type, if it exists, then the unmarshal operation will abort immediately by throwing a UnmarshalException. This exception scenario can be worked around by using the unmarshal by declaredType methods described in the next subsection.

    Unmarshal by Declared Type

    The unmarshal methods with a declaredType parameter enable an application to deserialize a root element of XML data, even when there is no mapping in JAXBContext of the root element's XML name. The unmarshaller unmarshals the root element using the application provided mapping specified as the declaredType parameter. Note that even when the root element's element name is mapped by JAXBContext, the declaredType parameter overrides that mapping for deserializing the root element when using these unmarshal methods. Additionally, when the root element of XML data has an xsi:type attribute and that attribute's value references a type definition that is mapped to a JAXB mapped class by JAXBContext, that the root element's xsi:type attribute takes precedence over the unmarshal methods declaredType parameter. These methods always return a JAXBElement<declaredType> instance. The table below shows how the properties of the returned JAXBElement instance are set.

    Unmarshal By Declared Type returned JAXBElement
    JAXBElement Property | Value
    name | xml element name
    value | instanceof declaredType
    declaredType | unmarshal method declaredType parameter
    scope | null (actual scope is unknown)

    The following is an example of unmarshal by declaredType method.

    Unmarshal by declaredType from a org.w3c.dom.Node:

           Schema fragment for example
       <xs:schema>
          <xs:complexType name="FooType">...<\xs:complexType>
          <!-- global element declaration "PurchaseOrder" -->
          <xs:element name="PurchaseOrder">
              <xs:complexType>
                 <xs:sequence>
                    <!-- local element declaration "foo" -->
                    <xs:element name="foo" type="FooType"/>
                    ...
                 </xs:sequence>
              </xs:complexType>
          </xs:element>
       </xs:schema>

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.parse(new File( "nosferatu.xml"));
       Element  fooSubtree = ...; // traverse DOM till reach xml element foo, constrained by a
                                  // local element declaration in schema.

       // FooType is the JAXB mapping of the type of local element declaration foo.
       JAXBElement<FooType> foo = u.unmarshal( fooSubtree, FooType.class);

    Support for SAX2.0 Compliant Parsers

    A client application has the ability to select the SAX2.0 compliant parser of their choice. If a SAX parser is not selected, then the JAXB Provider's default parser will be used. Even though the JAXB Provider's default parser is not required to be SAX2.0 compliant, all providers are required to allow a client application to specify their own SAX2.0 parser. Some providers may require the client application to specify the SAX2.0 parser at schema compile time. See unmarshal(Source) for more detail.

    Validation and Well-Formedness

    A client application can enable or disable JAXP 1.3 validation mechanism via the setSchema(javax.xml.validation.Schema) API. Sophisticated clients can specify their own validating SAX 2.0 compliant parser and bypass the JAXP 1.3 validation mechanism using the unmarshal(Source) API.

    Since unmarshalling invalid XML content is defined in JAXB 2.0, the Unmarshaller default validation event handler was made more lenient than in JAXB 1.0. When schema-derived code generated by JAXB 1.0 binding compiler is registered with JAXBContext, the default unmarshal validation handler is DefaultValidationEventHandler and it terminates the marshal operation after encountering either a fatal error or an error. For a JAXB 2.0 client application, there is no explicitly defined default validation handler and the default event handling only terminates the unmarshal operation after encountering a fatal error.

    Supported Properties

    There currently are not any properties required to be supported by all JAXB Providers on Unmarshaller. However, some providers may support their own set of provider specific properties.

    Unmarshal Event Callbacks

    The Unmarshaller provides two styles of callback mechanisms that allow application specific processing during key points in the unmarshalling process. In 'class defined' event callbacks, application specific code placed in JAXB mapped classes is triggered during unmarshalling. 'External listeners' allow for centralized processing of unmarshal events in one callback method rather than by type event callbacks.

    'Class defined' event callback methods allow any JAXB mapped class to specify its own specific callback methods by defining methods with the following method signature:

       // This method is called immediately after the object is created and before the unmarshalling of this
   // object begins. The callback provides an opportunity to initialize JavaBean properties prior to unmarshalling.
   void beforeUnmarshal(Unmarshaller, Object parent);

   //This method is called after all the properties (except IDREF) are unmarshalled for this object,
   //but before this object is set to the parent object.
   void afterUnmarshal(Unmarshaller, Object parent);
    The class defined callback methods should be used when the callback method requires access to non-public methods and/or fields of the class.

    The external listener callback mechanism enables the registration of a Unmarshaller.Listener instance with an setListener(Listener). The external listener receives all callback events, allowing for more centralized processing than per class defined callback methods. The external listener receives events when unmarshalling proces is marshalling to a JAXB element or to JAXB mapped class.

    The 'class defined' and external listener event callback methods are independent of each other, both can be called for one event. The invocation ordering when both listener callback methods exist is defined in Unmarshaller.Listener.beforeUnmarshal(Object, Object) and Unmarshaller.Listener.afterUnmarshal(Object, Object).

    An event callback method throwing an exception terminates the current unmarshal process.

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    JAXBContext, Marshaller, Validator

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  Unmarshaller.Listener

      Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <A extends XmlAdapter>
      A             		getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      AttachmentUnmarshaller getAttachmentUnmarshaller()
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Unmarshaller.Listener getListener()
      Return Unmarshaller.Listener registered with this Unmarshaller.
      Object getProperty(String name)
      Get the particular property in the underlying implementation of Unmarshaller.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
      UnmarshallerHandler getUnmarshallerHandler()
      Get an unmarshaller handler object that can be used as a component in an XML pipeline.
      boolean isValidating()
      Deprecated.
      since JAXB2.0, please see getSchema()
      <A extends XmlAdapter>
      void             		setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
      Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void setListener(Unmarshaller.Listener listener)
      Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.
      void setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Unmarshaller.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.
      void setValidating(boolean validating)
      Deprecated.
      since JAXB2.0, please see setSchema(javax.xml.validation.Schema)
      Object unmarshal(File f)
      Unmarshal XML data from the specified file and return the resulting content tree.
      Object unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
      Object unmarshal(InputStream is)
      Unmarshal XML data from the specified InputStream and return the resulting content tree.
      Object unmarshal(Node node)
      Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Node node, Class<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      Object unmarshal(Reader reader)
      Unmarshal XML data from the specified Reader and return the resulting content tree.
      Object unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Source source, Class<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      Object unmarshal(URL url)
      Unmarshal XML data from the specified URL and return the resulting content tree.
      Object unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLEventReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      Object unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLStreamReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

    • Method Detail

      • unmarshal

        Object unmarshal(File f)
                 throws JAXBException
        Unmarshal XML data from the specified file and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Parameters:
        f - the file to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the file parameter is null

      • unmarshal

        Object unmarshal(InputStream is)
                 throws JAXBException
        Unmarshal XML data from the specified InputStream and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API.

        Implements Unmarshal Global Root Element.

        Parameters:
        is - the InputStream to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the InputStream parameter is null

      • unmarshal

        Object unmarshal(Reader reader)
                 throws JAXBException
        Unmarshal XML data from the specified Reader and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API, because a Reader does not provide the system ID.

        Implements Unmarshal Global Root Element.

        Parameters:
        reader - the Reader to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the InputStream parameter is null
        Since:
        JAXB2.0

      • unmarshal

        Object unmarshal(URL url)
                 throws JAXBException
        Unmarshal XML data from the specified URL and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Parameters:
        url - the url to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the URL parameter is null

      • unmarshal

        Object unmarshal(InputSource source)
                 throws JAXBException
        Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Parameters:
        source - the input source to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the InputSource parameter is null

      • unmarshal

        Object unmarshal(Node node)
                 throws JAXBException
        Unmarshal global XML data from the specified DOM tree and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Parameters:
        node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the Node parameter is null
        See Also:
        unmarshal(org.w3c.dom.Node, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(Node node,
                           Class<T> declaredType)
                         throws JAXBException
        Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        Parameters:
        node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
        declaredType - appropriate JAXB mapped class to hold node's XML data.
        Returns:
        JAXB Element representation of node
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        Since:
        JAXB2.0

      • unmarshal

        Object unmarshal(Source source)
                 throws JAXBException
        Unmarshal XML data from the specified XML Source and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        SAX 2.0 Parser Pluggability

        A client application can choose not to use the default parser mechanism supplied with their JAXB provider. Any SAX 2.0 compliant parser can be substituted for the JAXB provider's default mechanism. To do so, the client application must properly configure a SAXSource containing an XMLReader implemented by the SAX 2.0 parser provider. If the XMLReader has an org.xml.sax.ErrorHandler registered on it, it will be replaced by the JAXB Provider so that validation errors can be reported via the ValidationEventHandler mechanism of JAXB. If the SAXSource does not contain an XMLReader, then the JAXB provider's default parser mechanism will be used.

        This parser replacement mechanism can also be used to replace the JAXB provider's unmarshal-time validation engine. The client application must properly configure their SAX 2.0 compliant parser to perform validation (as shown in the example above). Any SAXParserExceptions encountered by the parser during the unmarshal operation will be processed by the JAXB provider and converted into JAXB ValidationEvent objects which will be reported back to the client via the ValidationEventHandler registered with the Unmarshaller. Note: specifying a substitute validating SAX 2.0 parser for unmarshalling does not necessarily replace the validation engine used by the JAXB provider for performing on-demand validation.

        The only way for a client application to specify an alternate parser mechanism to be used during unmarshal is via the unmarshal(SAXSource) API. All other forms of the unmarshal method (File, URL, Node, etc) will use the JAXB provider's default parser and validator mechanisms.

        Parameters:
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the Source parameter is null
        See Also:
        unmarshal(javax.xml.transform.Source, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(Source source,
                           Class<T> declaredType)
                         throws JAXBException
        Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        See SAX 2.0 Parser Pluggability

        Parameters:
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        declaredType - appropriate JAXB mapped class to hold source's xml root element
        Returns:
        Java content rooted by JAXB Element
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        Since:
        JAXB2.0

      • unmarshal

        Object unmarshal(XMLStreamReader reader)
                 throws JAXBException
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Parameters:
        reader - The parser to be read.
        Returns:
        the newly created root object of the java content tree.
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the reader parameter is null
        IllegalStateException - If reader is not pointing to a START_DOCUMENT or START_ELEMENT event.
        Since:
        JAXB2.0
        See Also:
        unmarshal(javax.xml.stream.XMLStreamReader, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(XMLStreamReader reader,
                           Class<T> declaredType)
                         throws JAXBException
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Parameters:
        reader - The parser to be read.
        declaredType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        Returns:
        content tree rooted by JAXB Element representation
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        Since:
        JAXB2.0

      • unmarshal

        Object unmarshal(XMLEventReader reader)
                 throws JAXBException
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        This method is an Unmarshal Global Root method.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Parameters:
        reader - The parser to be read.
        Returns:
        the newly created root object of the java content tree.
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the reader parameter is null
        IllegalStateException - If reader is not pointing to a START_DOCUMENT or START_ELEMENT event.
        Since:
        JAXB2.0
        See Also:
        unmarshal(javax.xml.stream.XMLEventReader, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(XMLEventReader reader,
                           Class<T> declaredType)
                         throws JAXBException
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Parameters:
        reader - The parser to be read.
        declaredType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        Returns:
        content tree rooted by JAXB Element representation
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        Since:
        JAXB2.0

      • getUnmarshallerHandler

        UnmarshallerHandler getUnmarshallerHandler()
        Get an unmarshaller handler object that can be used as a component in an XML pipeline.

        The JAXB Provider can return the same handler object for multiple invocations of this method. In other words, this method does not necessarily create a new instance of UnmarshallerHandler. If the application needs to use more than one UnmarshallerHandler, it should create more than one Unmarshaller.

        Returns:
        the unmarshaller handler object
        See Also:
        UnmarshallerHandler

      • setValidating

        void setValidating(boolean validating)
                   throws JAXBException
        Deprecated. since JAXB2.0, please see setSchema(javax.xml.validation.Schema)
        Specifies whether or not the default validation mechanism of the Unmarshaller should validate during unmarshal operations. By default, the Unmarshaller does not validate.

        This method may only be invoked before or after calling one of the unmarshal methods.

        This method only controls the JAXB Provider's default unmarshal-time validation mechanism - it has no impact on clients that specify their own validating SAX 2.0 compliant parser. Clients that specify their own unmarshal-time validation mechanism may wish to turn off the JAXB Provider's default validation mechanism via this API to avoid "double validation".

        This method is deprecated as of JAXB 2.0 - please use the new setSchema(javax.xml.validation.Schema) API.

        Parameters:
        validating - true if the Unmarshaller should validate during unmarshal, false otherwise
        Throws:
        JAXBException - if an error occurred while enabling or disabling validation at unmarshal time
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 2.0 mapped classes

      • isValidating

        boolean isValidating()
                     throws JAXBException
        Deprecated. since JAXB2.0, please see getSchema()
        Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.

        This API returns the state of the JAXB Provider's default unmarshal-time validation mechanism.

        This method is deprecated as of JAXB 2.0 - please use the new getSchema() API.

        Returns:
        true if the Unmarshaller is configured to validate during unmarshal operations, false otherwise
        Throws:
        JAXBException - if an error occurs while retrieving the validating flag
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 2.0 mapped classes

      • setEventHandler

        void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Allow an application to register a ValidationEventHandler.

        The ValidationEventHandler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the unmarshal methods. If the client application does not register a ValidationEventHandler before invoking the unmarshal methods, then ValidationEvents will be handled by the default event handler which will terminate the unmarshal operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Unmarshaller to revert back to the default event handler.

        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler

      • setProperty

        void setProperty(String name,
               Object value)
                 throws PropertyException
        Set the particular property in the underlying implementation of Unmarshaller. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        Object getProperty(String name)
                   throws PropertyException
        Get the particular property in the underlying implementation of Unmarshaller. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null

      • setSchema

        void setSchema(Schema schema)
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against. Passing null into this method will disable validation.

        This method replaces the deprecated setValidating(boolean) API.

        Initially this property is set to null.

        Parameters:
        schema - Schema object to validate unmarshal operations against or null to disable validation
        Throws:
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        Since:
        JAXB2.0

      • getSchema

        Schema getSchema()
        Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation. If there is no Schema set on the unmarshaller, then this method will return null indicating that unmarshal-time validation will not be performed.

        This method provides replacement functionality for the deprecated isValidating() API as well as access to the Schema object. To determine if the Unmarshaller has validation enabled, simply test the return type for null:

        boolean isValidating = u.getSchema()!=null;

        Returns:
        the Schema object being used to perform unmarshal-time validation or null if not present
        Throws:
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        Since:
        JAXB2.0

      • setAdapter

        void setAdapter(XmlAdapter adapter)
        Associates a configured instance of XmlAdapter with this unmarshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        Throws:
        IllegalArgumentException - if the adapter parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB2.0
        See Also:
        setAdapter(Class,XmlAdapter)

      • setAdapter

        <A extends XmlAdapter> void setAdapter(Class<A> type,
                                     A adapter)
        Associates a configured instance of XmlAdapter with this unmarshaller.

        Every unmarshaller internally maintains a Map<Class,XmlAdapter>, which it uses for unmarshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, an unmarshaller will create one by invoking its default constructor.

        Parameters:
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.
        Throws:
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB2.0

      • getAdapter

        <A extends XmlAdapter> A getAdapter(Class<A> type)
        Gets the adapter associated with the specified type. This is the reverse operation of the setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        Throws:
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB2.0

      • setAttachmentUnmarshaller

        void setAttachmentUnmarshaller(AttachmentUnmarshaller au)

        Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

        Unmarshal time validation, enabled via setSchema(Schema), must be supported even when unmarshaller is performing XOP processing.

        Throws:
        IllegalStateException - if attempt to concurrently call this method during a unmarshal operation.

      • getAttachmentUnmarshaller

        AttachmentUnmarshaller getAttachmentUnmarshaller()

      • setListener

        void setListener(Unmarshaller.Listener listener)

        Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

        There is only one Listener per Unmarshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        Parameters:
        listener - provides unmarshal event callbacks for this Unmarshaller
        Since:
        JAXB2.0

      • getListener

        Unmarshaller.Listener getListener()

        Return Unmarshaller.Listener registered with this Unmarshaller.

        Returns:
        registered Unmarshaller.Listener or null if no Listener is registered with this Unmarshaller.
        Since:
        JAXB2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Unmarshaller.Listener (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class Unmarshaller.Listener

  • java.lang.Object
    • javax.xml.bind.Unmarshaller.Listener
  • Enclosing interface:
    Unmarshaller

    public abstract static class Unmarshaller.Listener
extends Object

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

    This class enables pre and post processing of an instance of a JAXB mapped class as XML data is unmarshalled into it. The event callbacks are called when unmarshalling XML content into a JAXBElement instance or a JAXB mapped class that represents a complex type definition. The event callbacks are not called when unmarshalling to an instance of a Java datatype that represents a simple type definition.

    External listener is one of two different mechanisms for defining unmarshal event callbacks. See Unmarshal Event Callbacks for an overview.

    (@link #setListener(Listener)} (@link #getListener()}

    Since:
    JAXB2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      Unmarshaller.Listener()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void afterUnmarshal(Object target, Object parent)

      Callback method invoked after unmarshalling XML data into target.
      void beforeUnmarshal(Object target, Object parent)

      Callback method invoked before unmarshalling into target.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Unmarshaller.Listener

        public Unmarshaller.Listener()

    • Method Detail

      • beforeUnmarshal

        public void beforeUnmarshal(Object target,
                   Object parent)

        Callback method invoked before unmarshalling into target.

        This method is invoked immediately after target was created and before the unmarshalling of this object begins. Note that if the class of target defines its own beforeUnmarshal method, the class specific callback method is invoked before this method is invoked.

        Parameters:
        target - non-null instance of JAXB mapped class prior to unmarshalling into it.
        parent - instance of JAXB mapped class that will eventually reference target. null when target is root element.

      • afterUnmarshal

        public void afterUnmarshal(Object target,
                  Object parent)

        Callback method invoked after unmarshalling XML data into target.

        This method is invoked after all the properties (except IDREF) are unmarshalled into target, but before target is set into its parent object. Note that if the class of target defines its own afterUnmarshal method, the class specific callback method is invoked before this method is invoked.

        Parameters:
        target - non-null instance of JAXB mapped class prior to unmarshalling into it.
        parent - instance of JAXB mapped class that will reference target. null when target is root element.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UnmarshallerHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface UnmarshallerHandler

  • All Superinterfaces:
    ContentHandler

    public interface UnmarshallerHandler
extends ContentHandler
    Unmarshaller implemented as SAX ContentHandler.

    Applications can use this interface to use their JAXB provider as a component in an XML pipeline. For example:

           JAXBContext context = JAXBContext.newInstance( "org.acme.foo" );

       Unmarshaller unmarshaller = context.createUnmarshaller();

       UnmarshallerHandler unmarshallerHandler = unmarshaller.getUnmarshallerHandler();

       SAXParserFactory spf = SAXParserFactory.newInstance();
       spf.setNamespaceAware( true );

       XMLReader xmlReader = spf.newSAXParser().getXMLReader();
       xmlReader.setContentHandler( unmarshallerHandler );
       xmlReader.parse(new InputSource( new FileInputStream( XML_FILE ) ) );

       MyObject myObject= (MyObject)unmarshallerHandler.getResult();

    This interface is reusable: even if the user fails to unmarshal an object, s/he can still start a new round of unmarshalling.

    Since:
    JAXB1.0
    Author:
    • Kohsuke KAWAGUCHI, Sun Microsystems, Inc.
    See Also:
    Unmarshaller.getUnmarshallerHandler()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getResult()
      Obtains the unmarshalled result.

      • Methods inherited from interface org.xml.sax.ContentHandler

        characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

    • Method Detail

      • getResult

        Object getResult()
                 throws JAXBException,
                        IllegalStateException
        Obtains the unmarshalled result. This method can be called only after this handler receives the endDocument SAX event.
        Returns:
        always return a non-null valid object which was unmarshalled.
        Throws:
        IllegalStateException - if this method is called before this handler receives the endDocument event.
        JAXBException - if there is any unmarshalling error. Note that the implementation is allowed to throw SAXException during the parsing when it finds an error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.bind (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind

  • Packages that use javax.xml.bind
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
  • Classes in javax.xml.bind used by javax.xml.bind
    Class and Description
    Binder
    Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.
    DatatypeConverterInterface
    The DatatypeConverterInterface is for JAXB provider use only.
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
    JAXBElement
    JAXB representation of an Xml Element.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    JAXBIntrospector
    Provide access to JAXB xml binding data for a JAXB object.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    Marshaller.Listener

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.
    PropertyException
    This exception indicates that an error was encountered while getting or setting a property.
    SchemaOutputResolver
    Controls where a JAXB implementation puts the generates schema files.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    Unmarshaller.Listener

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.
    UnmarshallerHandler
    Unmarshaller implemented as SAX ContentHandler.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
    ValidationEventLocator
    Encapsulate the location of a ValidationEvent.
    Validator
    Deprecated.
    since JAXB 2.0
  • Classes in javax.xml.bind used by javax.xml.bind.annotation
    Class and Description
    ValidationEventHandler
    A basic event handler interface for validation errors.
  • Classes in javax.xml.bind used by javax.xml.bind.helpers
    Class and Description
    JAXBElement
    JAXB representation of an Xml Element.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    Marshaller.Listener

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.
    NotIdentifiableEvent
    This event indicates that a problem was encountered resolving an ID/IDREF.
    ParseConversionEvent
    This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
    PrintConversionEvent
    This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
    PropertyException
    This exception indicates that an error was encountered while getting or setting a property.
    UnmarshalException
    This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    Unmarshaller.Listener

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
    ValidationEventLocator
    Encapsulate the location of a ValidationEvent.
  • Classes in javax.xml.bind used by javax.xml.bind.util
    Class and Description
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
  • Classes in javax.xml.bind used by javax.xml.ws
    Class and Description
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
  • Classes in javax.xml.bind used by javax.xml.ws.handler.soap
    Class and Description
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
  • Classes in javax.xml.bind used by javax.xml.ws.spi
    Class and Description
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidationEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface ValidationEvent

  • All Known Subinterfaces:
    NotIdentifiableEvent, ParseConversionEvent, PrintConversionEvent
    All Known Implementing Classes:
    NotIdentifiableEventImpl, ParseConversionEventImpl, PrintConversionEventImpl, ValidationEventImpl

    public interface ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    Validator, ValidationEventHandler

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int ERROR
      Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation
      static int FATAL_ERROR
      Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation
      static int WARNING
      Conditions that are not errors or fatal errors as defined by the XML 1.0 recommendation

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getLinkedException()
      Retrieve the linked exception for this warning/error.
      ValidationEventLocator getLocator()
      Retrieve the locator for this warning/error.
      String getMessage()
      Retrieve the text message for this warning/error.
      int getSeverity()
      Retrieve the severity code for this warning/error.

    • Field Detail

      • WARNING

        static final int WARNING
        Conditions that are not errors or fatal errors as defined by the XML 1.0 recommendation
        See Also:
        Constant Field Values

      • ERROR

        static final int ERROR
        Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation
        See Also:
        Constant Field Values

      • FATAL_ERROR

        static final int FATAL_ERROR
        Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation
        See Also:
        Constant Field Values

    • Method Detail

      • getSeverity

        int getSeverity()
        Retrieve the severity code for this warning/error.

        Must be one of ValidationError.WARNING, ValidationError.ERROR, or ValidationError.FATAL_ERROR.

        Returns:
        the severity code for this warning/error

      • getMessage

        String getMessage()
        Retrieve the text message for this warning/error.
        Returns:
        the text message for this warning/error or null if one wasn't set

      • getLinkedException

        Throwable getLinkedException()
        Retrieve the linked exception for this warning/error.
        Returns:
        the linked exception for this warning/error or null if one wasn't set

      • getLocator

        ValidationEventLocator getLocator()
        Retrieve the locator for this warning/error.
        Returns:
        the locator that indicates where the warning/error occurred
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidationEventHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface ValidationEventHandler

  • All Known Implementing Classes:
    DefaultValidationEventHandler, ValidationEventCollector

    public interface ValidationEventHandler
    A basic event handler interface for validation errors.

    If an application needs to implement customized event handling, it must implement this interface and then register it with either the Unmarshaller, the Validator, or the Marshaller. The JAXB Provider will then report validation errors and warnings encountered during the unmarshal, marshal, and validate operations to these event handlers.

    If the handleEvent method throws an unchecked runtime exception, the JAXB Provider must treat that as if the method returned false, effectively terminating whatever operation was in progress at the time (unmarshal, validate, or marshal).

    Modifying the Java content tree within your event handler is undefined by the specification and may result in unexpected behaviour.

    Failing to return false from the handleEvent method after encountering a fatal error is undefined by the specification and may result in unexpected behavior.

    Default Event Handler

    See: Validator javadocs
    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    Unmarshaller, Validator, Marshaller, ValidationEvent, ValidationEventCollector

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.

    • Method Detail

      • handleEvent

        boolean handleEvent(ValidationEvent event)
        Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

        If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

        Parameters:
        event - the encapsulated validation event information. It is a provider error if this parameter is null.
        Returns:
        true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
        Throws:
        IllegalArgumentException - if the event object is null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidationEventLocator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface ValidationEventLocator

  • All Known Implementing Classes:
    ValidationEventLocatorImpl

    public interface ValidationEventLocator
    Encapsulate the location of a ValidationEvent.

    The ValidationEventLocator indicates where the ValidationEvent occurred. Different fields will be set depending on the type of validation that was being performed when the error or warning was detected. For example, on-demand validation would produce locators that contained references to objects in the Java content tree while unmarshal-time validation would produce locators containing information appropriate to the source of the XML data (file, url, Node, etc).

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    Validator, ValidationEvent

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      Return the column number if available
      int getLineNumber()
      Return the line number if available
      Node getNode()
      Return a reference to the DOM Node if available
      Object getObject()
      Return a reference to the object in the Java content tree if available
      int getOffset()
      Return the byte offset if available
      URL getURL()
      Return the name of the XML source as a URL if available

    • Method Detail

      • getURL

        URL getURL()
        Return the name of the XML source as a URL if available
        Returns:
        the name of the XML source as a URL or null if unavailable

      • getOffset

        int getOffset()
        Return the byte offset if available
        Returns:
        the byte offset into the input source or -1 if unavailable

      • getLineNumber

        int getLineNumber()
        Return the line number if available
        Returns:
        the line number or -1 if unavailable

      • getColumnNumber

        int getColumnNumber()
        Return the column number if available
        Returns:
        the column number or -1 if unavailable

      • getObject

        Object getObject()
        Return a reference to the object in the Java content tree if available
        Returns:
        a reference to the object in the Java content tree or null if unavailable

      • getNode

        Node getNode()
        Return a reference to the DOM Node if available
        Returns:
        a reference to the DOM Node or null if unavailable
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidationException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class ValidationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.ValidationException
  • All Implemented Interfaces:
    Serializable

    public class ValidationException
extends JAXBException
    This exception indicates that an error has occurred while performing a validate operation.

    The ValidationEventHandler can cause this exception to be thrown during the validate operations. See ValidationEventHandler.handleEvent(ValidationEvent).

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    See Also:
    JAXBException, Validator, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidationException(String message)
      Construct an ValidationException with the specified detail message.
      ValidationException(String message, String errorCode)
      Construct an ValidationException with the specified detail message and vendor specific errorCode.
      ValidationException(String message, String errorCode, Throwable exception)
      Construct an ValidationException with the specified detail message, vendor specific errorCode, and linkedException.
      ValidationException(String message, Throwable exception)
      Construct an ValidationException with the specified detail message and linkedException.
      ValidationException(Throwable exception)
      Construct an ValidationException with a linkedException.

    • Method Summary

      • Methods inherited from class javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ValidationException

        public ValidationException(String message)
        Construct an ValidationException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • ValidationException

        public ValidationException(String message,
                   String errorCode)
        Construct an ValidationException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • ValidationException

        public ValidationException(Throwable exception)
        Construct an ValidationException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • ValidationException

        public ValidationException(String message,
                   Throwable exception)
        Construct an ValidationException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • ValidationException

        public ValidationException(String message,
                   String errorCode,
                   Throwable exception)
        Construct an ValidationException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Validator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface Validator

  • Deprecated.
    since JAXB 2.0

    public interface Validator
    As of JAXB 2.0, this class is deprecated and optional.

    The Validator class is responsible for controlling the validation of content trees during runtime.

    Three Forms of Validation

    Unmarshal-Time Validation
    This form of validation enables a client application to receive information about validation errors and warnings detected while unmarshalling XML data into a Java content tree and is completely orthogonal to the other types of validation. To enable or disable it, see the javadoc for Unmarshaller.setValidating. All JAXB 1.0 Providers are required to support this operation.
    On-Demand Validation
    This form of validation enables a client application to receive information about validation errors and warnings detected in the Java content tree. At any point, client applications can call the Validator.validate method on the Java content tree (or any sub-tree of it). All JAXB 1.0 Providers are required to support this operation.
    Fail-Fast Validation
    This form of validation enables a client application to receive immediate feedback about modifications to the Java content tree that violate type constraints on Java Properties as defined in the specification. JAXB Providers are not required support this type of validation. Of the JAXB Providers that do support this type of validation, some may require you to decide at schema compile time whether or not a client application will be allowed to request fail-fast validation at runtime.

    The Validator class is responsible for managing On-Demand Validation. The Unmarshaller class is responsible for managing Unmarshal-Time Validation during the unmarshal operations. Although there is no formal method of enabling validation during the marshal operations, the Marshaller may detect errors, which will be reported to the ValidationEventHandler registered on it.

    Using the Default EventHandler

    If the client application does not set an event handler on their Validator, Unmarshaller, or Marshaller prior to calling the validate, unmarshal, or marshal methods, then a default event handler will receive notification of any errors or warnings encountered. The default event handler will cause the current operation to halt after encountering the first error or fatal error (but will attempt to continue after receiving warnings).

    Handling Validation Events

    There are three ways to handle events encountered during the unmarshal, validate, and marshal operations:
    Use the default event handler
    The default event handler will be used if you do not specify one via the setEventHandler API's on Validator, Unmarshaller, or Marshaller.
    Implement and register a custom event handler
    Client applications that require sophisticated event processing can implement the ValidationEventHandler interface and register it with the Unmarshaller and/or Validator.
    Use the ValidationEventCollector utility
    For convenience, a specialized event handler is provided that simply collects any ValidationEvent objects created during the unmarshal, validate, and marshal operations and returns them to the client application as a java.util.Collection.

    Validation and Well-Formedness

    Validation events are handled differently depending on how the client application is configured to process them as described in the previous section. However, there are certain cases where a JAXB Provider indicates that it is no longer able to reliably detect and report errors. In these cases, the JAXB Provider will set the severity of the ValidationEvent to FATAL_ERROR to indicate that the unmarshal, validate, or marshal operations should be terminated. The default event handler and ValidationEventCollector utility class must terminate processing after being notified of a fatal error. Client applications that supply their own ValidationEventHandler should also terminate processing after being notified of a fatal error. If not, unexpected behaviour may occur.

    Supported Properties

    There currently are not any properties required to be supported by all JAXB Providers on Validator. However, some providers may support their own set of provider specific properties.

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    JAXBContext, Unmarshaller, ValidationEventHandler, ValidationEvent, ValidationEventCollector

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ValidationEventHandler getEventHandler()
      Deprecated.
      since JAXB2.0
      Object getProperty(String name)
      Deprecated.
      since JAXB2.0
      void setEventHandler(ValidationEventHandler handler)
      Deprecated.
      since JAXB2.0
      void setProperty(String name, Object value)
      Deprecated.
      since JAXB2.0
      boolean validate(Object subrootObj)
      Deprecated.
      since JAXB2.0
      boolean validateRoot(Object rootObj)
      Deprecated.
      since JAXB2.0

    • Method Detail

      • setEventHandler

        void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Deprecated. since JAXB2.0
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to validate. If the client application does not register a validation event handler before invoking the validate method, then validation events will be handled by the default event handler which will terminate the validate operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Validator to revert back to the default default event handler.

        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Deprecated. since JAXB2.0
        Return the current event handler or the default event handler if one hasn't been set.
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler

      • validate

        boolean validate(Object subrootObj)
                 throws JAXBException
        Deprecated. since JAXB2.0
        Validate the Java content tree starting at subrootObj.

        Client applications can use this method to validate Java content trees on-demand at runtime. This method can be used to validate any arbitrary subtree of the Java content tree. Global constraint checking will not be performed as part of this operation (i.e. ID/IDREF constraints).

        Parameters:
        subrootObj - the obj to begin validation at
        Returns:
        true if the subtree rooted at subrootObj is valid, false otherwise
        Throws:
        JAXBException - if any unexpected problem occurs during validation
        ValidationException - If the ValidationEventHandler returns false from its handleEvent method or the Validator is unable to validate the content tree rooted at subrootObj
        IllegalArgumentException - If the subrootObj parameter is null

      • validateRoot

        boolean validateRoot(Object rootObj)
                     throws JAXBException
        Deprecated. since JAXB2.0
        Validate the Java content tree rooted at rootObj.

        Client applications can use this method to validate Java content trees on-demand at runtime. This method is used to validate an entire Java content tree. Global constraint checking will be performed as part of this operation (i.e. ID/IDREF constraints).

        Parameters:
        rootObj - the root obj to begin validation at
        Returns:
        true if the tree rooted at rootObj is valid, false otherwise
        Throws:
        JAXBException - if any unexpected problem occurs during validation
        ValidationException - If the ValidationEventHandler returns false from its handleEvent method or the Validator is unable to validate the content tree rooted at rootObj
        IllegalArgumentException - If the rootObj parameter is null

      • setProperty

        void setProperty(String name,
               Object value)
                 throws PropertyException
        Deprecated. since JAXB2.0
        Set the particular property in the underlying implementation of Validator. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        Object getProperty(String name)
                   throws PropertyException
        Deprecated. since JAXB2.0
        Get the particular property in the underlying implementation of Validator. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DomHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Interface DomHandler<ElementT,ResultT extends Result>

  • All Known Implementing Classes:
    W3CDomHandler

    public interface DomHandler<ElementT,ResultT extends Result>
    Converts an element (and its descendants) from/to DOM (or similar) representation.

    Implementations of this interface will be used in conjunction with XmlAnyElement annotation to map an element of XML into a representation of infoset such as W3C DOM.

    Implementations hide how a portion of XML is converted into/from such DOM-like representation, allowing JAXB providers to work with arbitrary such library.

    This interface is intended to be implemented by library writers and consumed by JAXB providers. None of those methods are intended to be called from applications.

    Since:
    JAXB2.0
    Author:
    Kohsuke Kawaguchi

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ResultT createUnmarshaller(ValidationEventHandler errorHandler)
      When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
      ElementT getElement(ResultT rt)
      Once the portion is sent to the Result.
      Source marshal(ElementT n, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.

    • Method Detail

      • createUnmarshaller

        ResultT createUnmarshaller(ValidationEventHandler errorHandler)
        When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.

        A JAXB provider will then send a portion of the XML into the given result. Such a portion always form a subtree of the whole XML document rooted at an element.

        Parameters:
        errorHandler - if any error happens between the invocation of this method and the invocation of getElement(Result), they must be reported to this handler. The caller must provide a non-null error handler. The Result object created from this method may hold a reference to this error handler.
        Returns:
        null if the operation fails. The error must have been reported to the error handler.

      • getElement

        ElementT getElement(ResultT rt)
        Once the portion is sent to the Result. This method is called by a JAXB provider to obtain the unmarshalled element representation.

        Multiple invocations of this method may return different objects. This method can be invoked only when the whole sub-tree are fed to the Result object.

        Parameters:
        rt - The Result object created by createUnmarshaller(ValidationEventHandler).
        Returns:
        null if the operation fails. The error must have been reported to the error handler.

      • marshal

        Source marshal(ElementT n,
             ValidationEventHandler errorHandler)
        This method is called when a JAXB provider needs to marshal an element to XML.

        If non-null, the returned Source must contain a whole document rooted at one element, which will then be weaved into a bigger document that the JAXB provider is marshalling.

        Parameters:
        errorHandler - Receives any errors happened during the process of converting an element into a Source. The caller must provide a non-null error handler.
        Returns:
        null if there was an error. The error should have been reported to the handler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.bind.annotation (Java(TM) EE 7 Specification APIs)

javax.xml.bind.annotation

Interfaces

  • DomHandler

Classes

  • W3CDomHandler
  • XmlElement.DEFAULT
  • XmlElementDecl.GLOBAL
  • XmlElementRef.DEFAULT
  • XmlSchemaType.DEFAULT
  • XmlType.DEFAULT

Enums

  • XmlAccessOrder
  • XmlAccessType
  • XmlNsForm

Annotation Types

  • XmlAccessorOrder
  • XmlAccessorType
  • XmlAnyAttribute
  • XmlAnyElement
  • XmlAttachmentRef
  • XmlAttribute
  • XmlElement
  • XmlElementDecl
  • XmlElementRef
  • XmlElementRefs
  • XmlElements
  • XmlElementWrapper
  • XmlEnum
  • XmlEnumValue
  • XmlID
  • XmlIDREF
  • XmlInlineBinaryData
  • XmlList
  • XmlMimeType
  • XmlMixed
  • XmlNs
  • XmlRegistry
  • XmlRootElement
  • XmlSchema
  • XmlSchemaType
  • XmlSchemaTypes
  • XmlSeeAlso
  • XmlTransient
  • XmlType
  • XmlValue


javax.xml.bind.annotation (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind.annotation

Defines annotations for customizing Java program elements to XML Schema mapping.

See: Description

  • Interface Summary
    Interface Description
    DomHandler<ElementT,ResultT extends Result>
    Converts an element (and its descendants) from/to DOM (or similar) representation.
  • Class Summary
    Class Description
    W3CDomHandler
    DomHandler implementation for W3C DOM (org.w3c.dom package.)
    XmlElement.DEFAULT
    Used in XmlElement.type() to signal that the type be inferred from the signature of the property.
    XmlElementDecl.GLOBAL
    Used in XmlElementDecl.scope() to signal that the declaration is in the global scope.
    XmlElementRef.DEFAULT
    Used in XmlElementRef.type() to signal that the type be inferred from the signature of the property.
    XmlSchemaType.DEFAULT
    Used in XmlSchemaType.type() to signal that the type be inferred from the signature of the property.
    XmlType.DEFAULT
    Used in XmlType.factoryClass() to signal that either factory mehod is not used or that it's in the class with this XmlType itself.
  • Enum Summary
    Enum Description
    XmlAccessOrder
    Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
    XmlAccessType
    Used by XmlAccessorType to control serialization of fields or properties.
    XmlNsForm
    Enumeration of XML Schema namespace qualifications.
  • Annotation Types Summary
    Annotation Type Description
    XmlAccessorOrder
    Controls the ordering of fields and properties in a class.
    XmlAccessorType
    Controls whether fields or Javabean properties are serialized by default.
    XmlAnyAttribute
    Maps a JavaBean property to a map of wildcard attributes.
    XmlAnyElement
    Maps a JavaBean property to XML infoset representation and/or JAXB element.
    XmlAttachmentRef
    Marks a field/property that its XML form is a uri reference to mime content.
    XmlAttribute
    Maps a JavaBean property to a XML attribute.
    XmlElement
    Maps a JavaBean property to a XML element derived from property name.
    XmlElementDecl
    Maps a factory method to a XML element.
    XmlElementRef
    Maps a JavaBean property to a XML element derived from property's type.
    XmlElementRefs
    Marks a property that refers to classes with XmlElement or JAXBElement.
    XmlElements
    A container for multiple @XmlElement annotations.
    XmlElementWrapper
    Generates a wrapper element around XML representation.
    XmlEnum
    Maps an enum type Enum to XML representation.
    XmlEnumValue
    Maps an enum constant in Enum type to XML representation.
    XmlID
    Maps a JavaBean property to XML ID.
    XmlIDREF
    Maps a JavaBean property to XML IDREF.
    XmlInlineBinaryData
    Disable consideration of XOP encoding for datatypes that are bound to base64-encoded binary data in XML.
    XmlList
    Used to map a property to a list simple type.
    XmlMimeType
    Associates the MIME type that controls the XML representation of the property.
    XmlMixed
    Annotate a JavaBean multi-valued property to support mixed content.
    XmlNs
    Associates a namespace prefix with a XML namespace URI.
    XmlRegistry
    Marks a class that has XmlElementDecls.
    XmlRootElement
    Maps a class or an enum type to an XML element.
    XmlSchema
    Maps a package name to a XML namespace.
    XmlSchemaType
    Maps a Java type to a simple schema built-in type.
    XmlSchemaTypes
    A container for multiple @XmlSchemaType annotations.
    XmlSeeAlso
    Instructs JAXB to also bind other classes when binding this class.
    XmlTransient
    Prevents the mapping of a JavaBean property/type to XML representation.
    XmlType
    Maps a class or an enum type to a XML Schema type.
    XmlValue
    Enables mapping a class to a XML Schema complex type with a simpleContent or a XML Schema simple type.

Package javax.xml.bind.annotation Description

Defines annotations for customizing Java program elements to XML Schema mapping.

Package Specification

The following table shows the JAXB mapping annotations that can be associated with each program element.

Program Element JAXB annotation
Package
XmlAccessorOrder
XmlAccessorType
XmlSchema
XmlSchemaType
XmlSchemaTypes
XmlJavaTypeAdapter
XmlJavaTypeAdapters
Class
XmlAccessorOrder
XmlAccessorType
XmlInlineBinaryData
XmlRootElement
XmlType
XmlJavaTypeAdapter
Enum type
XmlEnum
XmlEnumValue (enum constant only)
XmlRootElement
XmlType
XmlJavaTypeAdapter
JavaBean Property/field
XmlElement
XmlElements
XmlElementRef
XmlElementRefs
XmlElementWrapper
XmlAnyElement
XmlAttribute
XmlAnyAttribute
XmlTransient
XmlValue
XmlID
XmlIDREF
XmlList
XmlMixed
XmlMimeType
XmlAttachmentRef
XmlInlineBinaryData
XmlElementDecl (only on method)
XmlJavaTypeAdapter
Parameter
XmlList
XmlAttachmentRef
XmlMimeType
XmlJavaTypeAdapter

Terminology

JavaBean property and field: For the purposes of mapping, there is no semantic difference between a field and a JavaBean property. Thus, an annotation that can be applied to a JavaBean property can always be applied to a field. Hence in the Javadoc documentation, for brevity, the term JavaBean property or property is used to mean either JavaBean property or a field. Where required, both are explicitly mentioned.

top level class: For the purpose of mapping, there is no semantic difference between a top level class and a static nested class. Thus, an annotation that can be applied to a top level class, can always be applied to a nested static class. Hence in the Javadoc documentation, for brevity, the term "top level class" or just class is used to mean either a top level class or a nested static class.

mapping annotation:A JAXB 2.0 defined program annotation based on the JSR 175 programming annotation facility.

Common Usage Constraints

The following usage constraints are defined here since they apply to more than annotation:

  • For a property, a given annotation can be applied to either read or write property but not both.
  • A property name must be different from any other property name in any of the super classes of the class being mapped.
  • A mapped field name or the decapitalized name of a mapped property must be unique within a class.

Notations

Namespace prefixes

The following namespace prefixes are used in the XML Schema fragments in this package.

Prefix | Namespace | Notes
xs | http://www.w3.org/2001/XMLSchema | Namespace of XML Schema namespace
ref | http://ws-i.org/profiles/basic/1.1/xsd | Namespace for swaref schema component
xsi | http://www.w3.org/2001/XMLSchema-instance | XML Schema namespace for instances
Since:
JAXB 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.bind.annotation Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind.annotation

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.annotation.W3CDomHandler (implements javax.xml.bind.annotation.DomHandler<ElementT,ResultT>)
    • javax.xml.bind.annotation.XmlElement.DEFAULT
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
    • javax.xml.bind.annotation.XmlType.DEFAULT

Interface Hierarchy

  • javax.xml.bind.annotation.DomHandler<ElementT,ResultT>

Annotation Type Hierarchy

  • javax.xml.bind.annotation.XmlValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlTransient (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSeeAlso (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaTypes (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchema (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRootElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRegistry (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlNs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMixed (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMimeType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlList (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlInlineBinaryData (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlIDREF (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlID (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnumValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnum (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElements (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementDecl (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttachmentRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorOrder (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.bind.annotation.XmlNsForm
      • javax.xml.bind.annotation.XmlAccessType
      • javax.xml.bind.annotation.XmlAccessOrder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.xml.bind.annotation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind.annotation

  • Packages that use javax.xml.bind.annotation
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.bind.annotation used by javax.ws.rs.core
    Class and Description
    XmlAnyAttribute
    Maps a JavaBean property to a map of wildcard attributes.
    XmlAttribute
    Maps a JavaBean property to a XML attribute.
  • Classes in javax.xml.bind.annotation used by javax.xml.bind.annotation
    Class and Description
    DomHandler
    Converts an element (and its descendants) from/to DOM (or similar) representation.
    XmlAccessOrder
    Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
    XmlAccessType
    Used by XmlAccessorType to control serialization of fields or properties.
    XmlNsForm
    Enumeration of XML Schema namespace qualifications.
  • Classes in javax.xml.bind.annotation used by javax.xml.ws
    Class and Description
    XmlTransient
    Prevents the mapping of a JavaBean property/type to XML representation.
  • Classes in javax.xml.bind.annotation used by javax.xml.ws.wsaddressing
    Class and Description
    XmlRootElement
    Maps a class or an enum type to an XML element.
    XmlType
    Maps a class or an enum type to a XML Schema type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


W3CDomHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class W3CDomHandler

  • java.lang.Object
    • javax.xml.bind.annotation.W3CDomHandler
  • All Implemented Interfaces:
    DomHandler<Element,DOMResult>

    public class W3CDomHandler
extends Object
implements DomHandler<Element,DOMResult>
    DomHandler implementation for W3C DOM (org.w3c.dom package.)
    Since:
    JAXB2.0
    Author:
    Kohsuke Kawaguchi

    • Constructor Summary

      Constructors
      Constructor and Description
      W3CDomHandler()
      Default constructor.
      W3CDomHandler(DocumentBuilder builder)
      Constructor that allows applications to specify which DOM implementation to be used.

    • Method Summary

      Methods
      Modifier and Type | Method and Description
      DOMResult createUnmarshaller(ValidationEventHandler errorHandler)
      When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
      DocumentBuilder getBuilder()
      Element getElement(DOMResult r)
      Once the portion is sent to the Result.
      Source marshal(Element element, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.
      void | setBuilder(DocumentBuilder builder)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • W3CDomHandler

        public W3CDomHandler()
        Default constructor. It is up to a JAXB provider to decide which DOM implementation to use or how that is configured.

      • W3CDomHandler

        public W3CDomHandler(DocumentBuilder builder)
        Constructor that allows applications to specify which DOM implementation to be used.
        Parameters:
        builder - must not be null. JAXB uses this DocumentBuilder to create a new element.

    • Method Detail

      • getBuilder

        public DocumentBuilder getBuilder()

      • setBuilder

        public void setBuilder(DocumentBuilder builder)

      • createUnmarshaller

        public DOMResult createUnmarshaller(ValidationEventHandler errorHandler)
        Description copied from interface: DomHandler
        When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.

        A JAXB provider will then send a portion of the XML into the given result. Such a portion always form a subtree of the whole XML document rooted at an element.

        Specified by:
        createUnmarshaller in interface DomHandler<Element,DOMResult>
        Parameters:
        errorHandler - if any error happens between the invocation of this method and the invocation of DomHandler.getElement(Result), they must be reported to this handler. The caller must provide a non-null error handler. The Result object created from this method may hold a reference to this error handler.
        Returns:
        null if the operation fails. The error must have been reported to the error handler.

      • getElement

        public Element getElement(DOMResult r)
        Description copied from interface: DomHandler
        Once the portion is sent to the Result. This method is called by a JAXB provider to obtain the unmarshalled element representation.

        Multiple invocations of this method may return different objects. This method can be invoked only when the whole sub-tree are fed to the Result object.

        Specified by:
        getElement in interface DomHandler<Element,DOMResult>
        Parameters:
        r - The Result object created by DomHandler.createUnmarshaller(ValidationEventHandler).
        Returns:
        null if the operation fails. The error must have been reported to the error handler.

      • marshal

        public Source marshal(Element element,
             ValidationEventHandler errorHandler)
        Description copied from interface: DomHandler
        This method is called when a JAXB provider needs to marshal an element to XML.

        If non-null, the returned Source must contain a whole document rooted at one element, which will then be weaved into a bigger document that the JAXB provider is marshalling.

        Specified by:
        marshal in interface DomHandler<Element,DOMResult>
        errorHandler - Receives any errors happened during the process of converting an element into a Source. The caller must provide a non-null error handler.
        Returns:
        null if there was an error. The error should have been reported to the handler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XmlAccessOrder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.bind.annotation

Enum XmlAccessOrder

  • java.lang.Object
    • java.lang.Enum<XmlAccessOrder>
      • javax.xml.bind.annotation.XmlAccessOrder
  • All Implemented Interfaces:
    Serializable, Comparable<XmlAccessOrder>

    public enum XmlAccessOrder
extends Enum<XmlAccessOrder>
    Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlAccessorOrder

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ALPHABETICAL
      The ordering of fields and properties in a class is in alphabetical order as determined by the method java.lang.String.compareTo(String anotherString).
      UNDEFINED
      The ordering of fields and properties in a class is undefined.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static XmlAccessOrder valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessOrder[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNDEFINED

        public static final XmlAccessOrder UNDEFINED
        The ordering of fields and properties in a class is undefined.

      • ALPHABETICAL

        public static final XmlAccessOrder ALPHABETICAL
        The ordering of fields and properties in a class is in alphabetical order as determined by the method java.lang.String.compareTo(String anotherString).

    • Method Detail

      • values

        public static XmlAccessOrder[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (XmlAccessOrder c : XmlAccessOrder.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static XmlAccessOrder valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


XmlAccessorOrder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlAccessorOrder

  • @Inherited
@Retention(value=RUNTIME)
@Target(value={PACKAGE,TYPE})
public @interface XmlAccessorOrder

    Controls the ordering of fields and properties in a class.

    Usage

    @XmlAccessorOrder annotation can be used with the following program elements:

    • package
    • a top level class

    See "Package Specification" in javax.xml.bind package javadoc for additional common information.

    The effective XmlAccessOrder on a class is determined as follows:

    • If there is a @XmlAccessorOrder on a class, then it is used.
    • Otherwise, if a @XmlAccessorOrder exists on one of its super classes, then it is inherited (by the virtue of Inherited)
    • Otherwise, the @XmlAccessorOrder on the package of the class is used, if it's there.
    • Otherwise XmlAccessOrder.UNDEFINED.

    This annotation can be used with the following annotations: XmlType, XmlRootElement, XmlAccessorType, XmlSchema, XmlSchemaType, XmlSchemaTypes, , XmlJavaTypeAdapter. It can also be used with the following annotations at the package level: XmlJavaTypeAdapter.

    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlAccessOrder

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      XmlAccessOrder value

    • Element Detail

      • value

        public abstract XmlAccessOrder value
        Default:
        javax.xml.bind.annotation.XmlAccessOrder.UNDEFINED
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlAccessorType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlAccessorType

  • @Inherited
@Retention(value=RUNTIME)
@Target(value={PACKAGE,TYPE})
public @interface XmlAccessorType

    Controls whether fields or Javabean properties are serialized by default.

    Usage

    @XmlAccessorType annotation can be used with the following program elements:

    • package
    • a top level class

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    This annotation provides control over the default serialization of properties and fields in a class.

    The annotation @XmlAccessorType on a package applies to all classes in the package. The following inheritance semantics apply:

    • If there is a @XmlAccessorType on a class, then it is used.
    • Otherwise, if a @XmlAccessorType exists on one of its super classes, then it is inherited.
    • Otherwise, the @XmlAccessorType on a package is inherited.

    Defaulting Rules:

    By default, if @XmlAccessorType on a package is absent, then the following package level annotation is assumed.

       @XmlAccessorType(XmlAccessType.PUBLIC_MEMBER)

    By default, if @XmlAccessorType on a class is absent, and none of its super classes is annotated with @XmlAccessorType, then the following default on the class is assumed:

       @XmlAccessorType(XmlAccessType.PUBLIC_MEMBER)

    This annotation can be used with the following annotations: XmlType, XmlRootElement, XmlAccessorOrder, XmlSchema, XmlSchemaType, XmlSchemaTypes, , XmlJavaTypeAdapter. It can also be used with the following annotations at the package level: XmlJavaTypeAdapter.

    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlAccessType

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      XmlAccessType value
      Specifies whether fields or properties are serialized.

    • Element Detail

      • value

        public abstract XmlAccessType value
        Specifies whether fields or properties are serialized.
        See Also:
        XmlAccessType
        Default:
        javax.xml.bind.annotation.XmlAccessType.PUBLIC_MEMBER
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlAccessType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.bind.annotation

Enum XmlAccessType

  • java.lang.Object
    • java.lang.Enum<XmlAccessType>
      • javax.xml.bind.annotation.XmlAccessType
  • All Implemented Interfaces:
    Serializable, Comparable<XmlAccessType>

    public enum XmlAccessType
extends Enum<XmlAccessType>
    Used by XmlAccessorType to control serialization of fields or properties.
    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlAccessorType

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      FIELD
      Every non static, non transient field in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient.
      NONE
      None of the fields or properties is bound to XML unless they are specifically annotated with some of the JAXB annotations.
      PROPERTY
      Every getter/setter pair in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient.
      PUBLIC_MEMBER
      Every public getter/setter pair and every public field will be automatically bound to XML, unless annotated by XmlTransient.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static XmlAccessType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PROPERTY

        public static final XmlAccessType PROPERTY
        Every getter/setter pair in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient. Fields are bound to XML only when they are explicitly annotated by some of the JAXB annotations.

      • FIELD

        public static final XmlAccessType FIELD
        Every non static, non transient field in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient. Getter/setter pairs are bound to XML only when they are explicitly annotated by some of the JAXB annotations.

      • PUBLIC_MEMBER

        public static final XmlAccessType PUBLIC_MEMBER
        Every public getter/setter pair and every public field will be automatically bound to XML, unless annotated by XmlTransient. Fields or getter/setter pairs that are private, protected, or defaulted to package-only access are bound to XML only when they are explicitly annotated by the appropriate JAXB annotations.

      • NONE

        public static final XmlAccessType NONE
        None of the fields or properties is bound to XML unless they are specifically annotated with some of the JAXB annotations.

    • Method Detail

      • values

        public static XmlAccessType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (XmlAccessType c : XmlAccessType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static XmlAccessType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


XmlAnyAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlAnyAttribute

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlAnyAttribute

    Maps a JavaBean property to a map of wildcard attributes.

    Usage

    The @XmlAnyAttribute annotation can be used with the following program elements:

    • JavaBean property
    • non static, non transient field

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:
    • At most one field or property in a class can be annotated with @XmlAnyAttribute.
    • The type of the property or the field must java.util.Map

    While processing attributes to be unmarshalled into a value class, each attribute that is not statically associated with another JavaBean property, via XmlAttribute, is entered into the wildcard attribute map represented by Map<QName,Object>. The attribute QName is the map's key. The key's value is the String value of the attribute.

    Since:
    JAXB2.0
    Author:
    Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlAnyElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlAnyElement

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlAnyElement
    Maps a JavaBean property to XML infoset representation and/or JAXB element.

    This annotation serves as a "catch-all" property while unmarshalling xml content into a instance of a JAXB annotated class. It typically annotates a multi-valued JavaBean property, but it can occur on single value JavaBean property. During unmarshalling, each xml element that does not match a static @XmlElement or @XmlElementRef annotation for the other JavaBean properties on the class, is added to this "catch-all" property.

    Usages:

     @XmlAnyElement
 public Element[] others;

 // Collection of Element or JAXB elements.
 @XmlAnyElement(lax="true")
 public Object[] others;

 @XmlAnyElement
 private List<Element> nodes;

 @XmlAnyElement
 private Element node;

    Restriction usage constraints

    This annotation is mutually exclusive with XmlElement, XmlAttribute, XmlValue, XmlElements, XmlID, and XmlIDREF.

    There can be only one XmlAnyElement annotated JavaBean property in a class and its super classes.

    Relationship to other annotations

    This annotation can be used with XmlJavaTypeAdapter, so that users can map their own data structure to DOM, which in turn can be composed into XML.

    This annotation can be used with XmlMixed like this:

     // List of java.lang.String or DOM nodes.
 @XmlAnyElement @XmlMixed
 List<Object> others;

    Schema To Java example

    The following schema would produce the following Java class:
     <xs:complexType name="foo">
   <xs:sequence>
     <xs:element name="a" type="xs:int" />
     <xs:element name="b" type="xs:int" />
     <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded" />
   </xs:sequence>
 </xs:complexType>

     class Foo {
   int a;
   int b;
   @XmlAnyElement
   List<Element> any;
 }
    It can unmarshal instances like
     <foo xmlns:e="extra">
   <a>1
   <e:other />  // this will be bound to DOM, because unmarshalling is orderless
   <b>3
   <e:other />
   <c>5     // this will be bound to DOM, because the annotation doesn't remember namespaces.
 </foo>
    The following schema would produce the following Java class:
     <xs:complexType name="bar">
   <xs:complexContent>
   <xs:extension base="foo">
     <xs:sequence>
       <xs:element name="c" type="xs:int" />
       <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded" />
     </xs:sequence>
   </xs:extension>
 </xs:complexType>

     class Bar extends Foo {
   int c;
   // Foo.getAny() also represents wildcard content for type definition bar.
 }
    It can unmarshal instances like
     <bar xmlns:e="extra">
   <a>1
   <e:other />  // this will be bound to DOM, because unmarshalling is orderless
   <b>3
   <e:other />
   <c>5     // this now goes to Bar.c
   <e:other />  // this will go to Foo.any
 </bar>

    Using XmlAnyElement with XmlElementRef

    The XmlAnyElement annotation can be used with XmlElementRefs to designate additional elements that can participate in the content tree.

    The following schema would produce the following Java class:

     <xs:complexType name="foo">
   <xs:choice maxOccurs="unbounded" minOccurs="0">
     <xs:element name="a" type="xs:int" />
     <xs:element name="b" type="xs:int" />
     <xs:any namespace="##other" processContents="lax" />
   </xs:choice>
 </xs:complexType>

     class Foo {
   @XmlAnyElement(lax="true")
   @XmlElementRefs({
     @XmlElementRef(name="a", type="JAXBElement.class")
     @XmlElementRef(name="b", type="JAXBElement.class")
   })
   List<Object> others;
 }

 @XmlRegistry
 class ObjectFactory {
   ...
   @XmlElementDecl(name = "a", namespace = "", scope = Foo.class)
   JAXBElement<Integer> createFooA( Integer i ) { ... }

   @XmlElementDecl(name = "b", namespace = "", scope = Foo.class)
   JAXBElement<Integer> createFooB( Integer i ) { ... }
    It can unmarshal instances like
     <foo xmlns:e="extra">
   <a>1     // this will unmarshal to a JAXBElement instance whose value is 1.
   <e:other />  // this will unmarshal to a DOM Element.
   <b>3     // this will unmarshal to a JAXBElement instance whose value is 1.
 </foo>

    W3C XML Schema "lax" wildcard emulation

    The lax element of the annotation enables the emulation of the "lax" wildcard semantics. For example, when the Java source code is annotated like this:
     @XmlRootElement
 class Foo {
   @XmlAnyElement(lax=true)
   public Object[] others;
 }
    then the following document will unmarshal like this:
     <foo>
   <unknown />
   <foo />
 </foo>

 Foo foo = unmarshal();
 // 1 for 'unknown', another for 'foo'
 assert foo.others.length==2;
 // 'unknown' unmarshals to a DOM element
 assert foo.others[0] instanceof Element;
 // because of lax=true, the 'foo' element eagerly
 // unmarshals to a Foo object.
 assert foo.others[1] instanceof Foo;
    Since:
    JAXB2.0
    Author:
    Kohsuke Kawaguchi

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean lax
      Controls the unmarshaller behavior when it sees elements known to the current JAXBContext.
      Class<? extends DomHandler> value
      Specifies the DomHandler which is responsible for actually converting XML from/to a DOM-like data structure.

    • Element Detail

      • lax

        public abstract boolean lax
        Controls the unmarshaller behavior when it sees elements known to the current JAXBContext.

        When false

        If false, all the elements that match the property will be unmarshalled to DOM, and the property will only contain DOM elements.

        When true

        If true, when an element matches a property marked with XmlAnyElement is known to JAXBContext (for example, there's a class with XmlRootElement that has the same tag name, or there's XmlElementDecl that has the same tag name), the unmarshaller will eagerly unmarshal this element to the JAXB object, instead of unmarshalling it to DOM. Additionally, if the element is unknown but it has a known xsi:type, the unmarshaller eagerly unmarshals the element to a JAXBElement, with the unknown element name and the JAXBElement value is set to an instance of the JAXB mapping of the known xsi:type.

        As a result, after the unmarshalling, the property can become heterogeneous; it can have both DOM nodes and some JAXB objects at the same time.

        This can be used to emulate the "lax" wildcard semantics of the W3C XML Schema.

        Default:
        false

      • value

        public abstract Class<? extends DomHandler> value
        Specifies the DomHandler which is responsible for actually converting XML from/to a DOM-like data structure.
        Default:
        javax.xml.bind.annotation.W3CDomHandler.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlAttachmentRef (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlAttachmentRef

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlAttachmentRef
    Marks a field/property that its XML form is a uri reference to mime content. The mime content is optimally stored out-of-line as an attachment. A field/property must always map to the DataHandler class.

    Usage

     @XmlRootElement
 class Foo {
   @XmlAttachmentRef
   @XmlAttribute
   DataHandler data;

   @XmlAttachmentRef
   @XmlElement
   DataHandler body;
 }
    The above code maps to the following XML:
     <xs:element name="foo" xmlns:ref="http://ws-i.org/profiles/basic/1.1/xsd">
   <xs:complexType>
     <xs:sequence>
       <xs:element name="body" type="ref:swaRef" minOccurs="0" />
     </xs:sequence>
     <xs:attribute name="data" type="ref:swaRef" use="optional" />
   </xs:complexType>
 </xs:element>

    The above binding supports WS-I AP 1.0 WS-I Attachments Profile Version 1.0.

    Since:
    JAXB2.0
    Author:
    Kohsuke Kawaguchi
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlAttribute (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlAttribute

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlAttribute

    Maps a JavaBean property to a XML attribute.

    Usage

    The @XmlAttribute annotation can be used with the following program elements:

    • JavaBean property
    • field

    A static final field is mapped to a XML fixed attribute.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:
    • If type of the field or the property is a collection type, then the collection item type must be mapped to schema simple type.
           // Examples
     @XmlAttribute List<Integer> items; //legal
     @XmlAttribute List<Bar> foo; // illegal if Bar does not map to a schema simple type
    • If the type of the field or the property is a non collection type, then the type of the property or field must map to a simple schema type.
           // Examples
     @XmlAttribute int foo; // legal
     @XmlAttribute Foo foo; // illegal if Foo does not map to a schema simple type
    • This annotation can be used with the following annotations: XmlID, XmlIDREF, XmlList, XmlSchemaType, XmlValue, XmlAttachmentRef, XmlMimeType, XmlInlineBinaryData, XmlJavaTypeAdapter.

    Example 1: Map a JavaBean property to an XML attribute.

         //Example: Code fragment
     public class USPrice {
         @XmlAttribute
         public java.math.BigDecimal getPrice() {...} ;
         public void setPrice(java.math.BigDecimal ) {...};
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="USPrice">
       <xs:sequence>
       </xs:sequence>
       <xs:attribute name="price" type="xs:decimal"/>
     </xs:complexType>

    Example 2: Map a JavaBean property to an XML attribute with anonymous type.

    See Example 7 in @XmlType.

    Example 3: Map a JavaBean collection property to an XML attribute.

         // Example: Code fragment
     class Foo {
         ...
         @XmlAttribute List<Integer> items;
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="foo">
         ...
       <xs:attribute name="items">
         <xs:simpleType>
           <xs:list itemType="xs:int"/>
         </xs:simpleType>
     </xs:complexType>
    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlType

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      Name of the XML Schema attribute.
      String namespace
      Specifies the XML target namespace of the XML Schema attribute.
      boolean required
      Specifies if the XML Schema attribute is optional or required.

    • Element Detail

      • name

        public abstract String name
        Name of the XML Schema attribute. By default, the XML Schema attribute name is derived from the JavaBean property name.
        Default:
        "##default"

      • required

        public abstract boolean required
        Specifies if the XML Schema attribute is optional or required. If true, then the JavaBean property is mapped to a XML Schema attribute that is required. Otherwise it is mapped to a XML Schema attribute that is optional.
        Default:
        false

      • namespace

        public abstract String namespace
        Specifies the XML target namespace of the XML Schema attribute.
        Default:
        "##default"
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlElement

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlElement
    Maps a JavaBean property to a XML element derived from property name.

    Usage

    @XmlElement annotation can be used with the following program elements:

    • a JavaBean property
    • non static, non transient field
    • within XmlElements

    The usage is subject to the following constraints:
    • This annotation can be used with following annotations: XmlID, XmlIDREF, XmlList, XmlSchemaType, XmlValue, XmlAttachmentRef, XmlMimeType, XmlInlineBinaryData, XmlElementWrapper, XmlJavaTypeAdapter
    • if the type of JavaBean property is a collection type of array, an indexed property, or a parameterized list, and this annotation is used with XmlElements then, @XmlElement.type() must be DEFAULT.class since the collection item type is already known.

    A JavaBean property, when annotated with @XmlElement annotation is mapped to a local element in the XML Schema complex type to which the containing class is mapped.

    Example 1: Map a public non static non final field to local element

         //Example: Code fragment
     public class USPrice {
         @XmlElement(name="itemprice")
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice"/>
       <xs:sequence>
         <xs:element name="itemprice" type="xs:decimal" minOccurs="0"/>
       </sequence>
     </xs:complexType>

    Example 2: Map a field to a nillable element.

     //Example: Code fragment
     public class USPrice {
         @XmlElement(nillable=true)
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal" nillable="true" minOccurs="0"/>
       </sequence>
     </xs:complexType>

    Example 3: Map a field to a nillable, required element.

     //Example: Code fragment
     public class USPrice {
         @XmlElement(nillable=true, required=true)
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal" nillable="true" minOccurs="1"/>
       </sequence>
     </xs:complexType>

    Example 4: Map a JavaBean property to an XML element with anonymous type.

    See Example 6 in @XmlType.

    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String defaultValue
      Default value of this element.
      String name
      Name of the XML Schema element.
      String namespace
      XML target namespace of the XML Schema element.
      boolean nillable
      Customize the element declaration to be nillable.
      boolean required
      Customize the element declaration to be required.
      Class type
      The Java class being referenced.

    • Element Detail

      • name

        public abstract String name
        Name of the XML Schema element.

        If the value is "##default", then element name is derived from the JavaBean property name.

        Default:
        "##default"

      • nillable

        public abstract boolean nillable
        Customize the element declaration to be nillable.

        If nillable() is true, then the JavaBean property is mapped to a XML Schema nillable element declaration.

        Default:
        false

      • required

        public abstract boolean required
        Customize the element declaration to be required.

        If required() is true, then Javabean property is mapped to an XML schema element declaration with minOccurs="1". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        If required() is false, then the Javabean property is mapped to XML Schema element declaration with minOccurs="0". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        Default:
        false

      • namespace

        public abstract String namespace
        XML target namespace of the XML Schema element.

        If the value is "##default", then the namespace is determined as follows:

        1. If the enclosing package has XmlSchema annotation, and its elementFormDefault is QUALIFIED, then the namespace of the enclosing class.
        2. Otherwise '' (which produces unqualified element in the default namespace.
        Default:
        "##default"

      • defaultValue

        public abstract String defaultValue
        Default value of this element.

        The

        ''
        value specified as a default of this annotation element is used as a poor-man's substitute for null to allow implementations to recognize the 'no default value' state.
        Default:
        "\u0000"

      • type

        public abstract Class type
        The Java class being referenced.
        Default:
        javax.xml.bind.annotation.XmlElement.DEFAULT.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlElement.DEFAULT (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class XmlElement.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlElement.DEFAULT
  • Enclosing class:
    XmlElement

    public static final class XmlElement.DEFAULT
extends Object
    Used in XmlElement.type() to signal that the type be inferred from the signature of the property.

    • Constructor Summary

      Constructors
      Constructor and Description
      XmlElement.DEFAULT()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XmlElement.DEFAULT

        public XmlElement.DEFAULT()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XmlElementDecl (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementDecl

  • @Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface XmlElementDecl
    Maps a factory method to a XML element.

    Usage

    The annotation creates a mapping between an XML schema element declaration and a element factory method that returns a JAXBElement instance representing the element declaration. Typically, the element factory method is generated (and annotated) from a schema into the ObjectFactory class in a Java package that represents the binding of the element declaration's target namespace. Thus, while the annotation syntax allows @XmlElementDecl to be used on any method, semantically its use is restricted to annotation of element factory method. The usage is subject to the following constraints:
    • The class containing the element factory method annotated with @XmlElementDecl must be marked with XmlRegistry.
    • The element factory method must take one parameter assignable to Object.

    Example 1: Annotation on a factory method

         // Example: code fragment
     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(name="foo")
         JAXBElement<String> createFoo(String s) { ... }
     }

     <!-- XML input -->
       <foo>string

     // Example: code fragment corresponding to XML input
     JAXBElement o =
     (JAXBElement)unmarshaller.unmarshal(aboveDocument);
     // print JAXBElement instance to show values
     System.out.println(o.getName());   // prints  "{}foo"
     System.out.println(o.getValue());  // prints  "string"
     System.out.println(o.getValue().getClass()); // prints "java.lang.String"

     <!-- Example: XML schema definition -->
     <xs:element name="foo" type="xs:string"/>

    Example 2: Element declaration with non local scope

    The following example illustrates the use of scope annotation parameter in binding of element declaration in schema derived code.

    The following example may be replaced in a future revision of this javadoc.

         <!-- Example: XML schema definition -->
     <xs:schema>
       <xs:complexType name="pea">
         <xs:choice maxOccurs="unbounded">
           <xs:element name="foo" type="xs:string"/>
           <xs:element name="bar" type="xs:string"/>
         </xs:choice>
       </xs:complexType>
       <xs:element name="foo" type="xs:int"/>
     </xs:schema>

         // Example: expected default binding
     class Pea {
         @XmlElementRefs({
             @XmlElementRef(name="foo",type=JAXBElement.class)
             @XmlElementRef(name="bar",type=JAXBElement.class)
         })
         List<JAXBElement<String>> fooOrBar;
     }

     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(scope=Pea.class,name="foo")
         JAXBElement createPeaFoo(String s);

         @XmlElementDecl(scope=Pea.class,name="bar")
         JAXBElement createPeaBar(String s);

         @XmlElementDecl(name="foo")
         JAXBElement createFoo(Integer i);
     }
    Without scope createFoo and createPeaFoo would become ambiguous since both of them map to a XML schema element with the same local name "foo".
    Since:
    JAXB 2.0
    See Also:
    XmlRegistry

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      local name of the XML element.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String defaultValue
      Default value of this element.
      String namespace
      namespace name of the XML element.
      Class scope
      scope of the mapping.
      String substitutionHeadName
      XML local name of a substitution group's head element.
      String substitutionHeadNamespace
      namespace name of a substitution group's head XML element.

    • Element Detail

      • name

        public abstract String name
        local name of the XML element.

        Note to reviewers: There is no default name; since the annotation is on a factory method, it is not clear that the method name can be derived from the factory method name.

        See Also:
        namespace()

      • scope

        public abstract Class scope
        scope of the mapping.

        If this is not XmlElementDecl.GLOBAL, then this element declaration mapping is only active within the specified class.

        Default:
        javax.xml.bind.annotation.XmlElementDecl.GLOBAL.class

      • namespace

        public abstract String namespace
        namespace name of the XML element.

        If the value is "##default", then the value is the namespace name for the package of the class containing this factory method.

        See Also:
        name()
        Default:
        "##default"

      • substitutionHeadNamespace

        public abstract String substitutionHeadNamespace
        namespace name of a substitution group's head XML element.

        This specifies the namespace name of the XML element whose local name is specified by substitutionHeadName().

        If susbtitutionHeadName() is "", then this value can only be "##default". But the value is ignored since since this element is not part of susbtitution group when the value of susbstitutionHeadName() is "".

        If susbtitutionHeadName() is not "" and the value is "##default", then the namespace name is the namespace name to which the package of the containing class, marked with XmlRegistry, is mapped.

        If susbtitutionHeadName() is not "" and the value is not "##default", then the value is the namespace name.

        See Also:
        substitutionHeadName()
        Default:
        "##default"

      • substitutionHeadName

        public abstract String substitutionHeadName
        XML local name of a substitution group's head element.

        If the value is "", then this element is not part of any substitution group.

        See Also:
        substitutionHeadNamespace()
        Default:
        ""

      • defaultValue

        public abstract String defaultValue
        Default value of this element.

        The

        ''
        value specified as a default of this annotation element is used as a poor-man's substitute for null to allow implementations to recognize the 'no default value' state.
        Default:
        "\u0000"
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlElementDecl.GLOBAL (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class XmlElementDecl.GLOBAL

  • java.lang.Object
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
  • Enclosing class:
    XmlElementDecl

    public static final class XmlElementDecl.GLOBAL
extends Object
    Used in XmlElementDecl.scope() to signal that the declaration is in the global scope.

    • Constructor Summary

      Constructors
      Constructor and Description
      XmlElementDecl.GLOBAL()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XmlElementDecl.GLOBAL

        public XmlElementDecl.GLOBAL()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XmlElementRef (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementRef

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElementRef

    Maps a JavaBean property to a XML element derived from property's type.

    Usage

    @XmlElementRef annotation can be used with a JavaBean property or from within XmlElementRefs

    This annotation dynamically associates an XML element name with the JavaBean property. When a JavaBean property is annotated with XmlElement, the XML element name is statically derived from the JavaBean property name. However, when this annotation is used, the XML element name is derived from the instance of the type of the JavaBean property at runtime.

    XML Schema substitution group support

    XML Schema allows a XML document author to use XML element names that were not statically specified in the content model of a schema using substitution groups. Schema derived code provides support for substitution groups using an element property, (section 5.5.5, "Element Property" of JAXB 2.0 specification). An element property method signature is of the form:
         public void setTerm(JAXBElement);
     public JAXBElement getTerm();

    An element factory method annotated with XmlElementDecl is used to create a JAXBElement instance, containing an XML element name. The presence of @XmlElementRef annotation on an element property indicates that the element name from JAXBElement instance be used instead of deriving an XML element name from the JavaBean property name.

    The usage is subject to the following constraints:

    • If the collection item type (for collection property) or property type (for single valued property) is JAXBElement, then @XmlElementRef}.name() and @XmlElementRef.namespace() must point an element factory method with an @XmlElementDecl annotation in a class annotated with @XmlRegistry (usually ObjectFactory class generated by the schema compiler) :
      • @XmlElementDecl.name() must equal @XmlElementRef.name()
      • @XmlElementDecl.namespace() must equal @XmlElementRef.namespace().
    • If the collection item type (for collection property) or property type (for single valued property) is not JAXBElement, then the type referenced by the property or field must be annotated with XmlRootElement.
    • This annotation can be used with the following annotations: XmlElementWrapper, XmlJavaTypeAdapter.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example 1: Ant Task Example

    The following Java class hierarchy models an Ant build script. An Ant task corresponds to a class in the class hierarchy. The XML element name of an Ant task is indicated by the @XmlRootElement annotation on its corresponding class.
         @XmlRootElement(name="target")
     class Target {
         // The presence of @XmlElementRef indicates that the XML
         // element name will be derived from the @XmlRootElement
         // annotation on the type (for e.g. "jar" for JarTask).
         @XmlElementRef
         List<Task> tasks;
     }

     abstract class Task {
     }

     @XmlRootElement(name="jar")
     class JarTask extends Task {
         ...
     }

     @XmlRootElement(name="javac")
     class JavacTask extends Task {
         ...
     }

     <!-- XML Schema fragment -->
     <xs:element name="target" type="Target">
     <xs:complexType name="Target">
       <xs:sequence>
         <xs:choice maxOccurs="unbounded">
           <xs:element ref="jar">
           <xs:element ref="javac">
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

    Thus the following code fragment:

         Target target = new Target();
     target.tasks.add(new JarTask());
     target.tasks.add(new JavacTask());
     marshal(target);
    will produce the following XML output:
         <target>
       <jar>
         ....
       </jar>
       <javac>
         ....
       </javac>
     </target>

    It is not an error to have a class that extends Task that doesn't have XmlRootElement. But they can't show up in an XML instance (because they don't have XML element names).

    Example 2: XML Schema Susbstitution group support

    The following example shows the annotations for XML Schema substitution groups. The annotations and the ObjectFactory are derived from the schema.

         @XmlElement
     class Math {
         //  The value of type()is
         //  JAXBElement.class , which indicates the XML
         //  element name ObjectFactory - in general a class marked
         //  with @XmlRegistry. (See ObjectFactory below)
         //
         //  The name() is "operator", a pointer to a
         // factory method annotated with a
         //  XmlElementDecl with the name "operator". Since
         //  "operator" is the head of a substitution group that
         //  contains elements "add" and "sub" elements, "operator"
         //  element can be substituted in an instance document by
         //  elements "add" or "sub". At runtime, JAXBElement
         //  instance contains the element name that has been
         //  substituted in the XML document.
         //
         @XmlElementRef(type=JAXBElement.class,name="operator")
         JAXBElement<? extends Operator> term;
     }

     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(name="operator")
         JAXBElement<Operator> createOperator(Operator o) {...}
         @XmlElementDecl(name="add",substitutionHeadName="operator")
         JAXBElement<Operator> createAdd(Operator o) {...}
         @XmlElementDecl(name="sub",substitutionHeadName="operator")
         JAXBElement<Operator> createSub(Operator o) {...}
     }

     class Operator {
         ...
     }

    Thus, the following code fragment

         Math m = new Math();
     m.term = new ObjectFactory().createAdd(new Operator());
     marshal(m);
    will produce the following XML output:
         <math>
       <add>...</add>
     </math>
    Since:
    JAXB2.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems,Inc.
    • Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlElementRefs

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      String namespace
      This parameter and name() are used to determine the XML element for the JavaBean property.
      boolean required
      Customize the element declaration to be required.
      Class type
      The Java type being referenced.

    • Element Detail

      • type

        public abstract Class type
        The Java type being referenced.

        If the value is DEFAULT.class, the type is inferred from the the type of the JavaBean property.

        Default:
        javax.xml.bind.annotation.XmlElementRef.DEFAULT.class

      • namespace

        public abstract String namespace
        This parameter and name() are used to determine the XML element for the JavaBean property.

        If type() is JAXBElement.class , then namespace() and name() point to a factory method with XmlElementDecl. The XML element name is the element name from the factory method's XmlElementDecl annotation or if an element from its substitution group (of which it is a head element) has been substituted in the XML document, then the element name is from the XmlElementDecl on the substituted element.

        If type() is not JAXBElement.class, then the XML element name is the XML element name statically associated with the type using the annotation XmlRootElement on the type. If the type is not annotated with an XmlElementDecl, then it is an error.

        If type() is not JAXBElement.class, then this value must be "".

        Default:
        ""

      • name

        public abstract String name
        See Also:
        namespace()
        Default:
        "##default"

      • required

        public abstract boolean required
        Customize the element declaration to be required.

        If required() is true, then Javabean property is mapped to an XML schema element declaration with minOccurs="1". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        If required() is false, then the Javabean property is mapped to XML Schema element declaration with minOccurs="0". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        For compatibility with JAXB 2.1, this property defaults to true, despite the fact that XmlElement.required() defaults to false.

        Since:
        2.2
        Default:
        true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlElementRef.DEFAULT (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class XmlElementRef.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
  • Enclosing class:
    XmlElementRef

    public static final class XmlElementRef.DEFAULT
extends Object
    Used in XmlElementRef.type() to signal that the type be inferred from the signature of the property.

    • Constructor Summary

      Constructors
      Constructor and Description
      XmlElementRef.DEFAULT()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XmlElementRef.DEFAULT

        public XmlElementRef.DEFAULT()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XmlElementRefs (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementRefs

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElementRefs
    Marks a property that refers to classes with XmlElement or JAXBElement.

    Compared to an element property (property with XmlElement annotation), a reference property has a different substitution semantics. When a sub-class is assigned to a property, an element property produces the same tag name with @xsi:type, whereas a reference property produces a different tag name (the tag name that's on the the sub-class.)

    This annotation can be used with the following annotations: XmlJavaTypeAdapter, XmlElementWrapper.

    Since:
    JAXB2.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlElementWrapper, XmlElementRef

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      XmlElementRef[] value

    • Element Detail

      • value

        public abstract XmlElementRef[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlElements (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlElements

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElements

    A container for multiple @XmlElement annotations. Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlElements as follows:

     @XmlElements({ @XmlElement(...),@XmlElement(...) })

    The @XmlElements annnotation can be used with the following program elements:

    • a JavaBean property
    • non static, non transient field
    This annotation is intended for annotation a JavaBean collection property (e.g. List).

    Usage

    The usage is subject to the following constraints:

    • This annotation can be used with the following annotations: @XmlIDREF, @XmlElementWrapper.
    • If @XmlIDREF is also specified on the JavaBean property, then each @XmlElement.type() must contain a JavaBean property annotated with @XmlID.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example 1: Map to a list of elements

    // Mapped code fragment
    public class Foo {
        @XmlElements(
            @XmlElement(name="A", type=Integer.class),
            @XmlElement(name="B", type=Float.class)
         }
         public List items;
    }

    <!-- XML Representation for a List of {1,2.5}
            XML output is not wrapped using another element -->
    ...
    <A> 1 </A>
    <B> 2.5 </B>
    ...

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:choice minOccurs="0" maxOccurs="unbounded">
          <xs:element name="A" type="xs:int"/>
          <xs:element name="B" type="xs:float"/>
        <xs:choice>
      </xs:sequence>
    </xs:complexType>

    Example 2: Map to a list of elements wrapped with another element

    // Mapped code fragment
    public class Foo {
        @XmlElementWrapper(name="bar")
        @XmlElements(
            @XmlElement(name="A", type=Integer.class),
            @XmlElement(name="B", type=Float.class)
        }
        public List items;
    }

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:element name="bar">
          <xs:complexType>
            <xs:choice minOccurs="0" maxOccurs="unbounded">
              <xs:element name="A" type="xs:int"/>
              <xs:element name="B" type="xs:float"/>
            </xs:choice>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>

    Example 3: Change element name based on type using an adapter.

        class Foo {
       @XmlJavaTypeAdapter(QtoPAdapter.class)
       @XmlElements({
           @XmlElement(name="A",type=PX.class),
           @XmlElement(name="B",type=PY.class)
       })
       Q bar;
    }

    @XmlType abstract class P {...}
    @XmlType(name="PX") class PX extends P {...}
    @XmlType(name="PY") class PY extends P {...}

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:element name="bar">
          <xs:complexType>
            <xs:choice minOccurs="0" maxOccurs="unbounded">
              <xs:element name="A" type="PX"/>
              <xs:element name="B" type="PY"/>
            </xs:choice>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>
    Since:
    JAXB2.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlElement, XmlElementRef, XmlElementRefs, XmlJavaTypeAdapter

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      XmlElement[] value
      Collection of @XmlElement annotations

    • Element Detail

      • value

        public abstract XmlElement[] value
        Collection of @XmlElement annotations
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlElementWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementWrapper

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElementWrapper
    Generates a wrapper element around XML representation. This is primarily intended to be used to produce a wrapper XML element around collections. The annotation therefore supports two forms of serialization shown below.
        //Example: code fragment
      int[] names;

    // XML Serialization Form 1 (Unwrapped collection)
    <names> ... </names>
    <names> ... </names>

    // XML Serialization Form 2 ( Wrapped collection )
    <wrapperElement>
       <names> value-of-item </names>
       <names> value-of-item </names>
       ....
    </wrapperElement>

    The two serialized XML forms allow a null collection to be represented either by absence or presence of an element with a nillable attribute.

    Usage

    The @XmlElementWrapper annotation can be used with the following program elements:

    • JavaBean property
    • non static, non transient field

    The usage is subject to the following constraints:

    • The property must be a collection property
    • This annotation can be used with the following annotations: XmlElement, XmlElements, XmlElementRef, XmlElementRefs, XmlJavaTypeAdapter.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Since:
    JAXB2.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlElement, XmlElements, XmlElementRef, XmlElementRefs

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      Name of the XML wrapper element.
      String namespace
      XML target namespace of the XML wrapper element.
      boolean nillable
      If true, the absence of the collection is represented by using xsi:nil='true'.
      boolean required
      Customize the wrapper element declaration to be required.

    • Element Detail

      • name

        public abstract String name
        Name of the XML wrapper element. By default, the XML wrapper element name is derived from the JavaBean property name.
        Default:
        "##default"

      • namespace

        public abstract String namespace
        XML target namespace of the XML wrapper element.

        If the value is "##default", then the namespace is determined as follows:

        1. If the enclosing package has XmlSchema annotation, and its elementFormDefault is QUALIFIED, then the namespace of the enclosing class.
        2. Otherwise "" (which produces unqualified element in the default namespace.
        Default:
        "##default"

      • nillable

        public abstract boolean nillable
        If true, the absence of the collection is represented by using xsi:nil='true'. Otherwise, it is represented by the absence of the element.
        Default:
        false

      • required

        public abstract boolean required
        Customize the wrapper element declaration to be required.

        If required() is true, then the corresponding generated XML schema element declaration will have minOccurs="1", to indicate that the wrapper element is always expected.

        Note that this only affects the schema generation, and not the unmarshalling or marshalling capability. This is simply a mechanism to let users express their application constraints better.

        Since:
        JAXB 2.1
        Default:
        false
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlEnum (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlEnum

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlEnum

    Maps an enum type Enum to XML representation.

    This annotation, together with XmlEnumValue provides a mapping of enum type to XML representation.

    Usage

    The @XmlEnum annotation can be used with the following program elements:

    • enum type

    The usage is subject to the following constraints:

    • This annotation can be used the following other annotations: XmlType, XmlRootElement

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information

    An enum type is mapped to a schema simple type with enumeration facets. The schema type is derived from the Java type to which @XmlEnum.value(). Each enum constant @XmlEnumValue must have a valid lexical representation for the type @XmlEnum.value() .

    Examples: See examples in XmlEnumValue

    Since:
    JAXB2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class<?> value
      Java type that is mapped to a XML simple type.

    • Element Detail

      • value

        public abstract Class<?> value
        Java type that is mapped to a XML simple type.
        Default:
        java.lang.String.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlEnumValue (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlEnumValue

  • @Retention(value=RUNTIME)
@Target(value=FIELD)
public @interface XmlEnumValue
    Maps an enum constant in Enum type to XML representation.

    Usage

    The @XmlEnumValue annotation can be used with the following program elements:

    • enum constant

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    This annotation, together with XmlEnum provides a mapping of enum type to XML representation.

    An enum type is mapped to a schema simple type with enumeration facets. The schema type is derived from the Java type specified in @XmlEnum.value(). Each enum constant @XmlEnumValue must have a valid lexical representation for the type @XmlEnum.value()

    In the absence of this annotation, Enum.name() is used as the XML representation.

    Example 1: Map enum constant name -> enumeration facet

         //Example: Code fragment
     @XmlEnum(String.class)
     public enum Card { CLUBS, DIAMONDS, HEARTS, SPADES }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Card">
       <xs:restriction base="xs:string"/>
         <xs:enumeration value="CLUBS"/>
         <xs:enumeration value="DIAMONDS"/>
         <xs:enumeration value="HEARTS"/>
         <xs:enumeration value="SPADES"/>
     </xs:simpleType>

    Example 2: Map enum constant name(value) -> enumeration facet

         //Example: code fragment
     @XmlType
     @XmlEnum(Integer.class)
     public enum Coin {
         @XmlEnumValue("1") PENNY(1),
         @XmlEnumValue("5") NICKEL(5),
         @XmlEnumValue("10") DIME(10),
         @XmlEnumValue("25") QUARTER(25) }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Coin">
       <xs:restriction base="xs:int">
         <xs:enumeration value="1"/>
         <xs:enumeration value="5"/>
         <xs:enumeration value="10"/>
         <xs:enumeration value="25"/>
       </xs:restriction>
     </xs:simpleType>

    Example 3: Map enum constant name -> enumeration facet

         //Code fragment
     @XmlType
     @XmlEnum(Integer.class)
     public enum Code {
         @XmlEnumValue("1") ONE,
         @XmlEnumValue("2") TWO;
     }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Code">
       <xs:restriction base="xs:int">
         <xs:enumeration value="1"/>
         <xs:enumeration value="2"/>
       </xs:restriction>
     </xs:simpleType>
    Since:
    JAXB 2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value

    • Element Detail

      • value

        public abstract String value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlID (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlID

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlID

    Maps a JavaBean property to XML ID.

    To preserve referential integrity of an object graph across XML serialization followed by a XML deserialization, requires an object reference to be marshalled by reference or containment appropriately. Annotations @XmlID and @XmlIDREF together allow a customized mapping of a JavaBean property's type by containment or reference.

    Usage

    The @XmlID annotation can be used with the following program elements:
    • a JavaBean property
    • non static, non transient field

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:
    • At most one field or property in a class can be annotated with @XmlID.
    • The JavaBean property's type must be java.lang.String.
    • The only other mapping annotations that can be used with @XmlID are:@XmlElement and @XmlAttribute.

    Example: Map a JavaBean property's type to xs:ID

        // Example: code fragment
    public class Customer {
        @XmlAttribute
        @XmlID
        public String getCustomerID();
        public void setCustomerID(String id);
        .... other properties not shown
    }

    <!-- Example: XML Schema fragment -->
    <xs:complexType name="Customer">
      <xs:complexContent>
        <xs:sequence>
          ....
        </xs:sequence>
        <xs:attribute name="customerID" type="xs:ID"/>
      </xs:complexContent>
    </xs:complexType>
    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlIDREF
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlIDREF (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlIDREF

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlIDREF

    Maps a JavaBean property to XML IDREF.

    To preserve referential integrity of an object graph across XML serialization followed by a XML deserialization, requires an object reference to be marshalled by reference or containment appropriately. Annotations @XmlID and @XmlIDREF together allow a customized mapping of a JavaBean property's type by containment or reference.

    Usage

    The @XmlIDREF annotation can be used with the following program elements:
    • a JavaBean property
    • non static, non transient field

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:

    • If the type of the field or property is a collection type, then the collection item type must contain a property or field annotated with @XmlID.
    • If the field or property is single valued, then the type of the property or field must contain a property or field annotated with @XmlID.

      Note: If the collection item type or the type of the property (for non collection type) is java.lang.Object, then the instance must contain a property/field annotated with @XmlID attribute.

    • This annotation can be used with the following annotations: XmlElement, XmlAttribute, XmlList, and XmlElements.

    Example: Map a JavaBean property to xs:IDREF (i.e. by reference rather than by containment)

   //EXAMPLE: Code fragment
   public class Shipping {
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);
       ....
    }

   <!-- Example: XML Schema fragment -->
   <xs:complexType name="Shipping">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

    Example 2: The following is a complete example of containment versus reference.

        // By default, Customer maps to complex type xs:Customer
    public class Customer {

        // map JavaBean property type to xs:ID
        @XmlID public String getCustomerID();
        public void setCustomerID(String id);

        // .... other properties not shown
    }

   // By default, Invoice maps to a complex type xs:Invoice
   public class Invoice {

       // map by reference
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);

      // .... other properties not shown here
   }

   // By default, Shipping maps to complex type xs:Shipping
   public class Shipping {

       // map by reference
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);
   }

   // at least one class must reference Customer by containment;
   // Customer instances won't be marshalled.
   @XmlElement(name="CustomerData")
   public class CustomerData {
       // map reference to Customer by containment by default.
       public Customer getCustomer();

       // maps reference to Shipping by containment by default.
       public Shipping getShipping();

       // maps reference to Invoice by containment by default.
       public Invoice getInvoice();
   }

   <!-- XML Schema mapping for above code frament -->

   <xs:complexType name="Invoice">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="Shipping">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="Customer">
     <xs:complexContent>
       <xs:sequence>
         ....
       </xs:sequence>
       <xs:attribute name="CustomerID" type="xs:ID"/>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="CustomerData">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:Customer"/>
         <xs:element name="shipping" type="xs:Shipping"/>
         <xs:element name="invoice"  type="xs:Invoice"/>
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:element name"customerData" type="xs:CustomerData"/>

   <!-- Instance document conforming to the above XML Schema -->
    <customerData>
       <customer customerID="Alice">
           ....
       </customer>

       <shipping customer="Alice">
           ....
       </shipping>

       <invoice customer="Alice">
           ....
       </invoice>
   </customerData>

    Example 3: Mapping List to repeating element of type IDREF

         // Code fragment
     public class Shipping {
         @XmlIDREF
         @XmlElement(name="Alice")
             public List customers;
     }

     <!-- XML schema fragment -->
     <xs:complexType name="Shipping">
       <xs:sequence>
         <xs:choice minOccurs="0" maxOccurs="unbounded">
           <xs:element name="Alice" type="xs:IDREF"/>
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

    Example 4: Mapping a List to a list of elements of type IDREF.

         //Code fragment
     public class Shipping {
         @XmlIDREF
         @XmlElements(
             @XmlElement(name="Alice", type="Customer.class")
              @XmlElement(name="John", type="InternationalCustomer.class")
         public List customers;
     }

     <!-- XML Schema fragment -->
     <xs:complexType name="Shipping">
       <xs:sequence>
         <xs:choice minOccurs="0" maxOccurs="unbounded">
           <xs:element name="Alice" type="xs:IDREF"/>
           <xs:element name="John" type="xs:IDREF"/>
         </xs:choice>
       </xs:sequence>
     </xs:complexType>
    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlID
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlInlineBinaryData (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlInlineBinaryData

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,TYPE})
public @interface XmlInlineBinaryData
    Disable consideration of XOP encoding for datatypes that are bound to base64-encoded binary data in XML.

    When XOP encoding is enabled as described in AttachmentMarshaller.isXOPPackage(), this annotation disables datatypes such as Image or Source or byte[] that are bound to base64-encoded binary from being considered for XOP encoding. If a JAXB property is annotated with this annotation or if the JAXB property's base type is annotated with this annotation, neither AttachmentMarshaller.addMtomAttachment(DataHandler, String, String) nor AttachmentMarshaller.addMtomAttachment(byte[], int, int, String, String, String) is ever called for the property. The binary data will always be inlined.

    Since:
    JAXB2.0
    Author:
    Joseph Fialli
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlList (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlList

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlList
    Used to map a property to a list simple type.

    Usage

    The @XmlList annotation can be used with the following program elements:

    • JavaBean property
    • field

    When a collection property is annotated just with @XmlElement, each item in the collection will be wrapped by an element. For example,

     @XmlRootElement
 class Foo {
     @XmlElement
     List<String> data;
 }
    would produce XML like this:
     <foo>
   <data>abc
   <data>def
 </foo>
    @XmlList annotation, on the other hand, allows multiple values to be represented as whitespace-separated tokens in a single element. For example,
     @XmlRootElement
 class Foo {
     @XmlElement
     @XmlList
     List<String> data;
 }
    the above code will produce XML like this:
     <foo>
   <data>abc def
 </foo>

    This annotation can be used with the following annotations: XmlElement, XmlAttribute, XmlValue, XmlIDREF.

    • The use of @XmlList with XmlValue while allowed, is redundant since XmlList maps a collection type to a simple schema type that derives by list just as XmlValue would.
    • The use of @XmlList with XmlAttribute while allowed, is redundant since XmlList maps a collection type to a simple schema type that derives by list just as XmlAttribute would.
    Since:
    JAXB2.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Sekhar Vajjhala, Sun Microsystems, Inc.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlMimeType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlMimeType

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlMimeType
    Associates the MIME type that controls the XML representation of the property.

    This annotation is used in conjunction with datatypes such as Image or Source that are bound to base64-encoded binary in XML.

    If a property that has this annotation has a sibling property bound to the xmime:contentType attribute, and if in the instance the property has a value, the value of the attribute takes precedence and that will control the marshalling.

    Since:
    JAXB2.0
    Author:
    Kohsuke Kawaguchi

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      The textual representation of the MIME type, such as "image/jpeg" "image/*", "text/xml; charset=iso-8859-1" and so on.

    • Element Detail

      • value

        public abstract String value
        The textual representation of the MIME type, such as "image/jpeg" "image/*", "text/xml; charset=iso-8859-1" and so on.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlMixed (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlMixed

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlMixed

    Annotate a JavaBean multi-valued property to support mixed content.

    The usage is subject to the following constraints:

    • can be used with @XmlElementRef, @XmlElementRefs or @XmlAnyElement

    The following can be inserted into @XmlMixed annotated multi-valued property

    • XML text information items are added as values of java.lang.String.
    • Children element information items are added as instances of JAXBElement or instances with a class that is annotated with @XmlRootElement.
    • Unknown content that is not be bound to a JAXB mapped class is inserted as Element. (Assumes property annotated with @XmlAnyElement)
    Below is an example of binding and creation of mixed content.
      <!-- schema fragment having  mixed content -->
  <xs:complexType name="letterBody" mixed="true">
    <xs:sequence>
        <xs:element name="name" type="xs:string"/>
        <xs:element name="quantity" type="xs:positiveInteger"/>
        <xs:element name="productName" type="xs:string"/>
        <!-- etc. -->
    </xs:sequence>
  </xs:complexType>
  <xs:element name="letterBody" type="letterBody"/>

 // Schema-derived Java code:
 // (Only annotations relevant to mixed content are shown below,
 //  others are ommitted.)
 import java.math.BigInteger;
 public class ObjectFactory {
        // element instance factories
        JAXBElement<LetterBody> createLetterBody(LetterBody value);
        JAXBElement<String>     createLetterBodyName(String value);
        JAXBElement<BigInteger> createLetterBodyQuantity(BigInteger value);
        JAXBElement<String>     createLetterBodyProductName(String value);
      // type instance factory
        LetterBody> createLetterBody();
 }

     public class LetterBody {
        // Mixed content can contain instances of Element classes
        // Name, Quantity and ProductName. Text data is represented as
        // java.util.String for text.
        @XmlMixed
        @XmlElementRefs({
                @XmlElementRef(name="productName", type=JAXBElement.class),
                @XmlElementRef(name="quantity", type=JAXBElement.class),
                @XmlElementRef(name="name", type=JAXBElement.class)})
        List getContent(){...}
 }
    The following is an XML instance document with mixed content
     <letterBody>
 Dear Mr.<name>Robert Smith</name>
 Your order of <quantity>1</quantity> <productName>Baby
 Monitor</productName> shipped from our warehouse. ....
 </letterBody>
    that can be constructed using following JAXB API calls.
     LetterBody lb = ObjectFactory.createLetterBody();
 JAXBElement<LetterBody> lbe = ObjectFactory.createLetterBody(lb);
 List gcl = lb.getContent();  //add mixed content to general content property.
 gcl.add("Dear Mr.");  // add text information item as a String.

 // add child element information item
 gcl.add(ObjectFactory.createLetterBodyName("Robert Smith"));
 gcl.add("Your order of "); // add text information item as a String

 // add children element information items
 gcl.add(ObjectFactory.
                        createLetterBodyQuantity(new BigInteger("1")));
 gcl.add(ObjectFactory.createLetterBodyProductName("Baby Monitor"));
 gcl.add("shipped from our warehouse");  // add text information item

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Since:
    JAXB2.0
    Author:
    Kohsuke Kawaguchi
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlNs (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlNs

  • @Retention(value=RUNTIME)
@Target(value={})
public @interface XmlNs

    Associates a namespace prefix with a XML namespace URI.

    Usage

    @XmlNs annotation is intended for use from other program annotations.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example:See XmlSchema annotation type for an example.

    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String namespaceURI
      Namespace URI
      String prefix
      Namespace prefix

    • Element Detail

      • prefix

        public abstract String prefix
        Namespace prefix

      • namespaceURI

        public abstract String namespaceURI
        Namespace URI
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlNsForm (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.bind.annotation

Enum XmlNsForm

  • java.lang.Object
    • java.lang.Enum<XmlNsForm>
      • javax.xml.bind.annotation.XmlNsForm
  • All Implemented Interfaces:
    Serializable, Comparable<XmlNsForm>

    public enum XmlNsForm
extends Enum<XmlNsForm>
    Enumeration of XML Schema namespace qualifications.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Usage

    The namespace qualification values are used in the annotations defined in this packge. The enumeration values are mapped as follows:

    Enum Value | XML Schema Value
    UNQUALIFIED | unqualified
    QUALIFIED | qualified
    UNSET | namespace qualification attribute is absent from the XML Schema fragment
    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      QUALIFIED
      UNQUALIFIED
      UNSET

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static XmlNsForm valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlNsForm[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNQUALIFIED

        public static final XmlNsForm UNQUALIFIED

      • QUALIFIED

        public static final XmlNsForm QUALIFIED

      • UNSET

        public static final XmlNsForm UNSET

    • Method Detail

      • values

        public static XmlNsForm[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (XmlNsForm c : XmlNsForm.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static XmlNsForm valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


XmlRegistry (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlRegistry

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlRegistry
    Marks a class that has XmlElementDecls.
    Since:
    JAXB 2.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlElementDecl
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlRootElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlRootElement

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlRootElement
    Maps a class or an enum type to an XML element.

    Usage

    The @XmlRootElement annotation can be used with the following program elements:

    • a top level class
    • an enum type

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    When a top level class or an enum type is annotated with the @XmlRootElement annotation, then its value is represented as XML element in an XML document.

    This annotation can be used with the following annotations: XmlType, XmlEnum, XmlAccessorType, XmlAccessorOrder.

    Example 1: Associate an element with XML Schema type

         // Example: Code fragment
     @XmlRootElement
     class Point {
        int x;
        int y;
        Point(int _x,int _y) {x=_x;y=_y;}
     }

         //Example: Code fragment corresponding to XML output
     marshal( new Point(3,5), System.out);

         <!-- Example: XML output -->
     <point>
       <x> 3
       <y> 5
     </point>
    The annotation causes an global element declaration to be produced in the schema. The global element declaration is associated with the XML schema type to which the class is mapped.
         <!-- Example: XML schema definition -->
     <xs:element name="point" type="point"/>
     <xs:complexType name="point">
       <xs:sequence>
         <xs:element name="x" type="xs:int"/>
         <xs:element name="y" type="xs:int"/>
       </xs:sequence>
     </xs:complexType>

    Example 2: Orthogonality to type inheritance

    An element declaration annotated on a type is not inherited by its derived types. The following example shows this.

         // Example: Code fragment
     @XmlRootElement
     class Point3D extends Point {
         int z;
         Point3D(int _x,int _y,int _z) {super(_x,_y);z=_z;}
     }

     //Example: Code fragment corresponding to XML output *
     marshal( new Point3D(3,5,0), System.out );

     <!-- Example: XML output -->
     <!-- The element name is point3D not point -->
     <point3D>
       <x>3</x>
       <y>5</y>
       <z>0</z>
     </point3D>

     <!-- Example: XML schema definition -->
     <xs:element name="point3D" type="point3D"/>
     <xs:complexType name="point3D">
       <xs:complexContent>
         <xs:extension base="point">
           <xs:sequence>
             <xs:element name="z" type="xs:int"/>
           </xs:sequence>
         </xs:extension>
       </xs:complexContent>
     </xs:complexType>
    Example 3: Associate a global element with XML Schema type to which the class is mapped.
         //Example: Code fragment
     @XmlRootElement(name="PriceElement")
     public class USPrice {
         @XmlElement
         public java.math.BigDecimal price;
     }

     <!-- Example: XML schema definition -->
     <xs:element name="PriceElement" type="USPrice"/>
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal"/>
       </sequence>
     </xs:complexType>
    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      local name of the XML element.
      String namespace
      namespace name of the XML element.

    • Element Detail

      • namespace

        public abstract String namespace
        namespace name of the XML element.

        If the value is "##default", then the XML namespace name is derived from the package of the class ( XmlSchema ). If the package is unnamed, then the XML namespace is the default empty namespace.

        Default:
        "##default"

      • name

        public abstract String name
        local name of the XML element.

        If the value is "##default", then the name is derived from the class name.

        Default:
        "##default"
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlSchema (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlSchema

  • @Retention(value=RUNTIME)
@Target(value=PACKAGE)
public @interface XmlSchema

    Maps a package name to a XML namespace.

    Usage

    The XmlSchema annotation can be used with the following program elements:

    • package

    This is a package level annotation and follows the recommendations and restrictions contained in JSR 175, section III, "Annotations". Thus the usage is subject to the following constraints and recommendations.

    • There can only be one package declaration as noted in JSR 175, section III, "Annotations".
    • JSR 175 recommends package-info.java for package level annotations. JAXB Providers that follow this recommendation will allow the package level annotations to be defined in package-info.java.

    Example 1: Customize name of XML namespace to which package is mapped.

        @javax.xml.bind.annotation.XmlSchema (
      namespace = "http://www.example.com/MYPO1"
    )

    <!-- XML Schema fragment -->
    <schema
      xmlns=...
      xmlns:po=....
      targetNamespace="http://www.example.com/MYPO1"
    >
    <!-- prefixes generated by default are implementation
            depedenent -->

    Example 2: Customize namespace prefix, namespace URI mapping

        // Package level annotation
    @javax.xml.bind.annotation.XmlSchema (
      xmlns = {
        @javax.xml.bind.annotation.XmlNs(prefix = "po",
                   namespaceURI="http://www.example.com/myPO1"),

        @javax.xml.bind.annotation.XmlNs(prefix="xs",
                   namespaceURI="http://www.w3.org/2001/XMLSchema")
      )
    )

    <!-- XML Schema fragment -->
    <schema
        xmlns:xs="http://www.w3.org/2001/XMLSchema"
        xmlns:po="http://www.example.com/PO1"
        targetNamespace="http://www.example.com/PO1">

    Example 3: Customize elementFormDefault

        @javax.xml.bind.annotation.XmlSchema (
      elementFormDefault=XmlNsForm.UNQUALIFIED
      ...
    )

    <!-- XML Schema fragment -->
    <schema
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:po="http://www.example.com/PO1"
        elementFormDefault="unqualified">
    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      XmlNsForm attributeFormDefault
      Namespace qualification for attributes.
      XmlNsForm elementFormDefault
      Namespace qualification for elements.
      String location
      Indicates that this namespace (specified by namespace()) has a schema already available exeternally, available at this location.
      String namespace
      Name of the XML namespace.
      XmlNs[] xmlns
      Customize the namespace URI, prefix associations.

    • Element Detail

      • xmlns

        public abstract XmlNs[] xmlns
        Customize the namespace URI, prefix associations. By default, the namespace prefixes for a XML namespace are generated by a JAXB Provider in an implementation dependent way.
        Default:
        {}

      • namespace

        public abstract String namespace
        Name of the XML namespace.
        Default:
        ""

      • elementFormDefault

        public abstract XmlNsForm elementFormDefault
        Namespace qualification for elements. By default, element default attribute will be absent from the XML Schema fragment.
        Default:
        javax.xml.bind.annotation.XmlNsForm.UNSET

      • attributeFormDefault

        public abstract XmlNsForm attributeFormDefault
        Namespace qualification for attributes. By default, attributesFormDefault will be absent from the XML Schema fragment.
        Default:
        javax.xml.bind.annotation.XmlNsForm.UNSET

      • location

        public abstract String location
        Indicates that this namespace (specified by namespace()) has a schema already available exeternally, available at this location.

        This instructs the JAXB schema generators to simply refer to the pointed schema, as opposed to generating components into the schema. This schema is assumed to match what would be otherwise produced by the schema generator (same element names, same type names...)

        This feature is intended to be used when a set of the Java classes is originally generated from an existing schema, hand-written to match externally defined schema, or the generated schema is modified manually.

        Value could be any absolute URI, like http://example.org/some.xsd. It is also possible to specify the empty string, to indicate that the schema is externally available but the location is unspecified (and thus it's the responsibility of the reader of the generate schema to locate it.) Finally, the default value of this property "##generate" indicates that the schema generator is going to generate components for this namespace (as it did in JAXB 2.0.)

        Multiple XmlSchema annotations on multiple packages are allowed to govern the same namespace(). In such case, all of them must have the same location() values.

        Note to implementor

        More precisely, the value must be either "", "##generate", or a valid lexical representation of xs:anyURI that begins with <scheme>:.

        A schema generator is expected to generate a corresponding <xs:import namespace="..." schemaLocation="..."/> (or no schemaLocation attribute at all if the empty string is specified.) However, the schema generator is allowed to use a different value in the schemaLocation attribute (including not generating such attribute), for example so that the user can specify a local copy of the resource through the command line interface.

        Since:
        JAXB2.1
        Default:
        "##generate"
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlSchemaType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlSchemaType

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PACKAGE})
public @interface XmlSchemaType
    Maps a Java type to a simple schema built-in type.

    Usage

    @XmlSchemaType annotation can be used with the following program elements:

    • a JavaBean property
    • field
    • package

    @XmlSchemaType annotation defined for Java type applies to all references to the Java type from a property/field. A @XmlSchemaType annotation specified on the property/field overrides the @XmlSchemaType annotation specified at the package level.

    This annotation can be used with the following annotations: XmlElement, XmlAttribute.

    Example 1: Customize mapping of XMLGregorianCalendar on the field.

         //Example: Code fragment
     public class USPrice {
         @XmlElement
         @XmlSchemaType(name="date")
         public XMLGregorianCalendar date;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice"/>
       <xs:sequence>
         <xs:element name="date" type="xs:date"/>
       </sequence>
     </xs:complexType>

    Example 2: Customize mapping of XMLGregorianCalendar at package level

         package foo;
     @javax.xml.bind.annotation.XmlSchemaType(
          name="date", type=javax.xml.datatype.XMLGregorianCalendar.class)
     }
    Since:
    JAXB2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String namespace
      Class type
      If this annotation is used at the package level, then value of the type() must be specified.

    • Element Detail

      • name

        public abstract String name

      • namespace

        public abstract String namespace
        Default:
        "http://www.w3.org/2001/XMLSchema"

      • type

        public abstract Class type
        If this annotation is used at the package level, then value of the type() must be specified.
        Default:
        javax.xml.bind.annotation.XmlSchemaType.DEFAULT.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlSchemaType.DEFAULT (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class XmlSchemaType.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
  • Enclosing class:
    XmlSchemaType

    public static final class XmlSchemaType.DEFAULT
extends Object
    Used in XmlSchemaType.type() to signal that the type be inferred from the signature of the property.

    • Constructor Summary

      Constructors
      Constructor and Description
      XmlSchemaType.DEFAULT()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XmlSchemaType.DEFAULT

        public XmlSchemaType.DEFAULT()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XmlSchemaTypes (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlSchemaTypes

  • @Retention(value=RUNTIME)
@Target(value=PACKAGE)
public @interface XmlSchemaTypes

    A container for multiple @XmlSchemaType annotations.

    Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlSchemaType annotations as follows:

     @XmlSchemaTypes({ @XmlSchemaType(...), @XmlSchemaType(...) })

    The @XmlSchemaTypes annnotation can be used to define XmlSchemaType for different types at the package level.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Since:
    JAXB2.0
    Author:
    • Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlSchemaType

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      XmlSchemaType[] value
      Collection of @XmlSchemaType annotations

    • Element Detail

      • value

        public abstract XmlSchemaType[] value
        Collection of @XmlSchemaType annotations
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlSeeAlso (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlSeeAlso

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface XmlSeeAlso
    Instructs JAXB to also bind other classes when binding this class.

    Java makes it impractical/impossible to list all sub-classes of a given class. This often gets in a way of JAXB users, as it JAXB cannot automatically list up the classes that need to be known to JAXBContext.

    For example, with the following class definitions:

     class Animal {}
 class Dog extends Animal {}
 class Cat extends Animal {}

    The user would be required to create JAXBContext as JAXBContext.newInstance(Dog.class,Cat.class) (Animal will be automatically picked up since Dog and Cat refers to it.)

    XmlSeeAlso annotation would allow you to write:

     @XmlSeeAlso({Dog.class,Cat.class})
 class Animal {}
 class Dog extends Animal {}
 class Cat extends Animal {}

    This would allow you to do JAXBContext.newInstance(Animal.class). By the help of this annotation, JAXB implementations will be able to correctly bind Dog and Cat.

    Since:
    JAXB2.1
    Author:
    Kohsuke Kawaguchi

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class[] value

    • Element Detail

      • value

        public abstract Class[] value
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlTransient (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlTransient

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,TYPE})
public @interface XmlTransient

    Prevents the mapping of a JavaBean property/type to XML representation.

    The @XmlTransient annotation is useful for resolving name collisions between a JavaBean property name and a field name or preventing the mapping of a field/property. A name collision can occur when the decapitalized JavaBean property name and a field name are the same. If the JavaBean property refers to the field, then the name collision can be resolved by preventing the mapping of either the field or the JavaBean property using the @XmlTransient annotation.

    When placed on a class, it indicates that the class shouldn't be mapped to XML by itself. Properties on such class will be mapped to XML along with its derived classes, as if the class is inlined.

    Usage

    The @XmlTransient annotation can be used with the following program elements:

    • a JavaBean property
    • field
    • class

    @XmlTransientis mutually exclusive with all other JAXB defined annotations.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example: Resolve name collision between JavaBean property and field name

       // Example: Code fragment
   public class USAddress {

       // The field name "name" collides with the property name
       // obtained by bean decapitalization of getName() below
       @XmlTransient public String name;

       String getName() {..};
       String setName() {..};
   }

   <!-- Example: XML Schema fragment -->
   <xs:complexType name="USAddress">
     <xs:sequence>
       <xs:element name="name" type="xs:string"/>
     </xs:sequence>
   </xs:complexType>
    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlType

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlType

    Maps a class or an enum type to a XML Schema type.

    Usage

    The @XmlType annnotation can be used with the following program elements:

    • a top level class
    • an enum type

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Mapping a Class

    A class maps to a XML Schema type. A class is a data container for values represented by properties and fields. A schema type is a data container for values represented by schema components within a schema type's content model (e.g. model groups, attributes etc).

    To be mapped, a class must either have a public no-arg constructor or a static no-arg factory method. The static factory method can be specified in factoryMethod() and factoryClass() annotation elements. The static factory method or the no-arg constructor is used during unmarshalling to create an instance of this class. If both are present, the static factory method overrides the no-arg constructor.

    A class maps to either a XML Schema complex type or a XML Schema simple type. The XML Schema type is derived based on the mapping of JavaBean properties and fields contained within the class. The schema type to which the class is mapped can either be named or anonymous. A class can be mapped to an anonymous schema type by annotating the class with @XmlType(name="").

    Either a global element, local element or a local attribute can be associated with an anonymous type as follows:

    • global element: A global element of an anonymous type can be derived by annotating the class with @XmlRootElement. See Example 3 below.
    • local element: A JavaBean property that references a class annotated with @XmlType(name="") and is mapped to the element associated with the anonymous type. See Example 4 below.
    • attribute: A JavaBean property that references a class annotated with @XmlType(name="") and is mapped to the attribute associated with the anonymous type. See Example 5 below.
    Mapping to XML Schema Complex Type
    • If class is annotated with @XmlType(name="") , it is mapped to an anonymous type otherwise, the class name maps to a complex type name. The XmlName() annotation element can be used to customize the name.
    • Properties and fields that are mapped to elements are mapped to a content model within a complex type. The annotation element propOrder() can be used to customize the content model to be xs:all or xs:sequence. It is used for specifying the order of XML elements in xs:sequence.
    • Properties and fields can be mapped to attributes within the complex type.
    • The targetnamespace of the XML Schema type can be customized using the annotation element namespace().

    Mapping class to XML Schema simple type

    A class can be mapped to a XML Schema simple type using the @XmlValue annotation. For additional details and examples, see @XmlValue annotation type.

    The following table shows the mapping of the class to a XML Schema complex type or simple type. The notational symbols used in the table are:

    • -> : represents a mapping
    • [x]+ : one or more occurances of x
    • [ @XmlValue property ]: JavaBean property annotated with @XmlValue
    • X : don't care
    Target propOrder ClassBody ComplexType SimpleType
    Class {} [property]+ -> elements complexcontent
    xs:all
    Class non empty [property]+ -> elements complexcontent
    xs:sequence
    Class X no property -> element complexcontent
    empty sequence
    Class X 1 [ @XmlValue property] &&
    [property]+ ->attributes     		simplecontent
    Class X 1 [ @XmlValue property ]&&
    no properties -> attribute     		simpletype

    Mapping an enum type

    An enum type maps to a XML schema simple type with enumeration facets. The following annotation elements are ignored since they are not meaningful: propOrder() , factoryMethod() , factoryClass() .

    Usage with other annotations

    This annotation can be used with the following annotations: XmlRootElement, XmlAccessorOrder, XmlAccessorType, XmlEnum. However, XmlAccessorOrder and XmlAccessorType are ignored when this annotation is used on an enum type.

    Example 1: Map a class to a complex type with xs:sequence with a customized ordering of JavaBean properties.

       @XmlType(propOrder={"street", "city" , "state", "zip", "name" })
   public class USAddress {
     String getName() {..};
     void setName(String) {..};

     String getStreet() {..};
     void setStreet(String) {..};

     String getCity() {..};
     void setCity(String) {..};

     String getState() {..};
     void setState(String) {..};

     java.math.BigDecimal getZip() {..};
     void setZip(java.math.BigDecimal) {..};
   }

   <!-- XML Schema mapping for USAddress -->
   <xs:complexType name="USAddress">
     <xs:sequence>
       <xs:element name="street" type="xs:string"/>
       <xs:element name="city" type="xs:string"/>
       <xs:element name="state" type="xs:string"/>
       <xs:element name="zip" type="xs:decimal"/>
       <xs:element name="name" type="xs:string"/>
     </xs:all>
   </xs:complexType>

    Example 2: Map a class to a complex type with xs:all

     @XmlType(propOrder={})
 public class USAddress { ...}

 <!-- XML Schema mapping for USAddress -->
 <xs:complexType name="USAddress">
   <xs:all>
     <xs:element name="name" type="xs:string"/>
     <xs:element name="street" type="xs:string"/>
     <xs:element name="city" type="xs:string"/>
     <xs:element name="state" type="xs:string"/>
     <xs:element name="zip" type="xs:decimal"/>
   </xs:sequence>
 </xs:complexType>

    Example 3: Map a class to a global element with an anonymous type.

       @XmlRootElement
   @XmlType(name="")
   public class USAddress { ...}

   <!-- XML Schema mapping for USAddress -->
   <xs:element name="USAddress">
     <xs:complexType>
       <xs:sequence>
         <xs:element name="name" type="xs:string"/>
         <xs:element name="street" type="xs:string"/>
         <xs:element name="city" type="xs:string"/>
         <xs:element name="state" type="xs:string"/>
         <xs:element name="zip" type="xs:decimal"/>
       </xs:sequence>
     </xs:complexType>
   </xs:element>

    Example 4: Map a property to a local element with anonmyous type.

       //Example: Code fragment
   public class Invoice {
       USAddress addr;
           ...
       }

   @XmlType(name="")
   public class USAddress { ... }
   }

   <!-- XML Schema mapping for USAddress -->
   <xs:complexType name="Invoice">
     <xs:sequence>
       <xs:element name="addr">
         <xs:complexType>
           <xs:element name="name", type="xs:string"/>
           <xs:element name="city", type="xs:string"/>
           <xs:element name="city" type="xs:string"/>
           <xs:element name="state" type="xs:string"/>
           <xs:element name="zip" type="xs:decimal"/>
         </xs:complexType>
       ...
     </xs:sequence>
   </xs:complexType>

    Example 5: Map a property to an attribute with anonymous type.

     //Example: Code fragment
     public class Item {
         public String name;
         @XmlAttribute
         public USPrice price;
     }

     // map class to anonymous simple type.
     @XmlType(name="")
     public class USPrice {
         @XmlValue
         public java.math.BigDecimal price;
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="Item">
       <xs:sequence>
         <xs:element name="name" type="xs:string"/>
         <xs:attribute name="price">
           <xs:simpleType>
             <xs:restriction base="xs:decimal"/>
           </xs:simpleType>
         </xs:attribute>
       </xs:sequence>
     </xs:complexType>

    Example 6: Define a factoryClass and factoryMethod

      @XmlType(name="USAddressType", factoryClass=USAddressFactory.class,
      factoryMethod="getUSAddress")
      public class USAddress {

          private String city;
          private String name;
          private String state;
          private String street;
          private int    zip;

      public USAddress(String name, String street, String city,
          String state, int zip) {
          this.name = name;
          this.street = street;
          this.city = city;
          this.state = state;
          this.zip = zip;
      }
  }

  public class USAddressFactory {
      public static USAddress getUSAddress(){
       return new USAddress("Mark Baker", "23 Elm St",
          "Dayton", "OH", 90952);
  }

    Example 7: Define factoryMethod and use the default factoryClass

          @XmlType(name="USAddressType", factoryMethod="getNewInstance")
      public class USAddress {

          private String city;
          private String name;
          private String state;
          private String street;
          private int    zip;

          private USAddress() {}

          public static USAddress getNewInstance(){
              return new USAddress();
          }
      }
    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlElement, XmlAttribute, XmlValue, XmlSchema

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class factoryClass
      Class containing a no-arg factory method for creating an instance of this class.
      String factoryMethod
      Name of a no-arg factory method in the class specified in factoryClass factoryClass().
      String name
      Name of the XML Schema type which the class is mapped.
      String namespace
      Name of the target namespace of the XML Schema type.
      String[] propOrder
      Specifies the order for XML Schema elements when class is mapped to a XML Schema complex type.

    • Element Detail

      • name

        public abstract String name
        Name of the XML Schema type which the class is mapped.
        Default:
        "##default"

      • propOrder

        public abstract String[] propOrder
        Specifies the order for XML Schema elements when class is mapped to a XML Schema complex type.

        Refer to the table for how the propOrder affects the mapping of class

        The propOrder is a list of names of JavaBean properties in the class. Each name in the list is the name of a Java identifier of the JavaBean property. The order in which JavaBean properties are listed is the order of XML Schema elements to which the JavaBean properties are mapped.

        All of the JavaBean properties being mapped to XML Schema elements must be listed.

        A JavaBean property or field listed in propOrder must not be transient or annotated with @XmlTransient.

        The default ordering of JavaBean properties is determined by @XmlAccessorOrder.

        Default:
        ""

      • namespace

        public abstract String namespace
        Name of the target namespace of the XML Schema type. By default, this is the target namespace to which the package containing the class is mapped.
        Default:
        "##default"

      • factoryClass

        public abstract Class factoryClass
        Class containing a no-arg factory method for creating an instance of this class. The default is this class.

        If factoryClass is DEFAULT.class and factoryMethod is "", then there is no static factory method.

        If factoryClass is DEFAULT.class and factoryMethod is not "", then factoryMethod is the name of a static factory method in this class.

        If factoryClass is not DEFAULT.class, then factoryMethod must not be "" and must be the name of a static factory method specified in factoryClass.

        Default:
        javax.xml.bind.annotation.XmlType.DEFAULT.class

      • factoryMethod

        public abstract String factoryMethod
        Name of a no-arg factory method in the class specified in factoryClass factoryClass().
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlType.DEFAULT (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class XmlType.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlType.DEFAULT
  • Enclosing class:
    XmlType

    public static final class XmlType.DEFAULT
extends Object
    Used in XmlType.factoryClass() to signal that either factory mehod is not used or that it's in the class with this XmlType itself.

    • Constructor Summary

      Constructors
      Constructor and Description
      XmlType.DEFAULT()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XmlType.DEFAULT

        public XmlType.DEFAULT()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XmlValue (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation

Annotation Type XmlValue

  • @Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlValue

    Enables mapping a class to a XML Schema complex type with a simpleContent or a XML Schema simple type.

    Usage:

    The @XmlValue annotation can be used with the following program elements:

    • a JavaBean property.
    • non static, non transient field.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following usage constraints:
    • At most one field or property can be annotated with the @XmlValue annotation.
    • @XmlValue can be used with the following annotations: XmlList. However this is redundant since XmlList maps a type to a simple schema type that derives by list just as XmlValue would.
    • If the type of the field or property is a collection type, then the collection item type must map to a simple schema type.
    • If the type of the field or property is not a collection type, then the type must map to a XML Schema simple type.

    If the annotated JavaBean property is the sole class member being mapped to XML Schema construct, then the class is mapped to a simple type. If there are additional JavaBean properties (other than the JavaBean property annotated with @XmlValue annotation) that are mapped to XML attributes, then the class is mapped to a complex type with simpleContent.

    Example 1: Map a class to XML Schema simpleType

     // Example 1: Code fragment
     public class USPrice {
         @XmlValue
         public java.math.BigDecimal price;
     }

     <!-- Example 1: XML Schema fragment -->
     <xs:simpleType name="USPrice">
       <xs:restriction base="xs:decimal"/>
     </xs:simpleType>

    Example 2: Map a class to XML Schema complexType with with simpleContent.

   // Example 2: Code fragment
   public class InternationalPrice {
       @XmlValue
       public java.math.BigDecimal price;

       @XmlAttribute
       public String currency;
   }

   <!-- Example 2: XML Schema fragment -->
   <xs:complexType name="InternationalPrice">
     <xs:simpleContent>
       <xs:extension base="xs:decimal">
         <xs:attribute name="currency" type="xs:string"/>
       </xs:extension>
     </xs:simpleContent>
   </xs:complexType>

    Since:
    JAXB2.0
    Author:
    Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


CollapsedStringAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation.adapters

Class CollapsedStringAdapter

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<String,String>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter

  • public class CollapsedStringAdapter
extends XmlAdapter<String,String>
    Built-in XmlAdapter to handle xs:token and its derived types.

    This adapter removes leading and trailing whitespaces, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.

    Since:
    JAXB 2.0
    Author:
    Kohsuke Kawaguchi

    • Constructor Summary

      Constructors
      Constructor and Description
      CollapsedStringAdapter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected static boolean isWhiteSpace(char ch)
      returns true if the specified char is a white space character.
      String marshal(String s)
      No-op.
      String unmarshal(String text)
      Removes leading and trailing whitespaces of the string given as the parameter, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CollapsedStringAdapter

        public CollapsedStringAdapter()

    • Method Detail

      • unmarshal

        public String unmarshal(String text)
        Removes leading and trailing whitespaces of the string given as the parameter, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.
        Specified by:
        unmarshal in class XmlAdapter<String,String>
        Parameters:
        text - The value to be converted. Can be null.

      • marshal

        public String marshal(String s)
        No-op. Just return the same string given as the parameter.
        Specified by:
        marshal in class XmlAdapter<String,String>
        Parameters:
        s - The value to be convereted. Can be null.

      • isWhiteSpace

        protected static boolean isWhiteSpace(char ch)
        returns true if the specified char is a white space character.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HexBinaryAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation.adapters

Class HexBinaryAdapter

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<String,byte[]>
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter

  • public final class HexBinaryAdapter
extends XmlAdapter<String,byte[]>
    XmlAdapter for xs:hexBinary.

    This XmlAdapter binds byte[] to the hexBinary representation in XML.

    Since:
    JAXB 2.0
    Author:
    Kohsuke Kawaguchi

    • Constructor Summary

      Constructors
      Constructor and Description
      HexBinaryAdapter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String marshal(byte[] bytes)
      Convert a bound type to a value type.
      byte[] unmarshal(String s)
      Convert a value type to a bound type.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HexBinaryAdapter

        public HexBinaryAdapter()

    • Method Detail

      • unmarshal

        public byte[] unmarshal(String s)
        Description copied from class: XmlAdapter
        Convert a value type to a bound type.
        Specified by:
        unmarshal in class XmlAdapter<String,byte[]>
        Parameters:
        s - The value to be converted. Can be null.

      • marshal

        public String marshal(byte[] bytes)
        Description copied from class: XmlAdapter
        Convert a bound type to a value type.
        Specified by:
        marshal in class XmlAdapter<String,byte[]>
        Parameters:
        bytes - The value to be convereted. Can be null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.bind.annotation.adapters (Java(TM) EE 7 Specification APIs)

javax.xml.bind.annotation.adapters

Classes

  • CollapsedStringAdapter
  • HexBinaryAdapter
  • NormalizedStringAdapter
  • XmlAdapter
  • XmlJavaTypeAdapter.DEFAULT

Annotation Types

  • XmlJavaTypeAdapter
  • XmlJavaTypeAdapters


javax.xml.bind.annotation.adapters (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind.annotation.adapters

XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.

See: Description

  • Class Summary
    Class Description
    CollapsedStringAdapter
    Built-in XmlAdapter to handle xs:token and its derived types.
    HexBinaryAdapter
    XmlAdapter for xs:hexBinary.
    NormalizedStringAdapter
    XmlAdapter to handle xs:normalizedString.
    XmlAdapter<ValueType,BoundType>
    Adapts a Java type for custom marshaling.
    XmlJavaTypeAdapter.DEFAULT
    Used in XmlJavaTypeAdapter.type() to signal that the type be inferred from the signature of the field, property, parameter or the class.
  • Annotation Types Summary
    Annotation Type Description
    XmlJavaTypeAdapter
    Use an adapter that implements XmlAdapter for custom marshaling.
    XmlJavaTypeAdapters
    A container for multiple @XmlJavaTypeAdapter annotations.

Package javax.xml.bind.annotation.adapters Description

XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.bind.annotation.adapters Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind.annotation.adapters

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT

Annotation Type Hierarchy

  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


NormalizedStringAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation.adapters

Class NormalizedStringAdapter

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<String,String>
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter

  • public final class NormalizedStringAdapter
extends XmlAdapter<String,String>
    XmlAdapter to handle xs:normalizedString.

    Replaces any tab, CR, and LF by a whitespace character ' ', as specified in the whitespace facet 'replace'

    Since:
    JAXB 2.0
    Author:
    Kohsuke Kawaguchi, Martin Grebac

    • Constructor Summary

      Constructors
      Constructor and Description
      NormalizedStringAdapter()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected static boolean isWhiteSpaceExceptSpace(char ch)
      Returns true if the specified char is a white space character but not 0x20.
      String marshal(String s)
      No-op.
      String unmarshal(String text)
      Replace any tab, CR, and LF by a whitespace character ' ', as specified in the whitespace facet 'replace'

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NormalizedStringAdapter

        public NormalizedStringAdapter()

    • Method Detail

      • unmarshal

        public String unmarshal(String text)
        Replace any tab, CR, and LF by a whitespace character ' ', as specified in the whitespace facet 'replace'
        Specified by:
        unmarshal in class XmlAdapter<String,String>
        Parameters:
        text - The value to be converted. Can be null.

      • marshal

        public String marshal(String s)
        No-op. Just return the same string given as the parameter.
        Specified by:
        marshal in class XmlAdapter<String,String>
        Parameters:
        s - The value to be convereted. Can be null.

      • isWhiteSpaceExceptSpace

        protected static boolean isWhiteSpaceExceptSpace(char ch)
        Returns true if the specified char is a white space character but not 0x20.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.bind.annotation.adapters (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind.annotation.adapters

  • Packages that use javax.xml.bind.annotation.adapters
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation.adapters
    XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
  • Classes in javax.xml.bind.annotation.adapters used by javax.ws.rs.core
    Class and Description
    XmlAdapter
    Adapts a Java type for custom marshaling.
  • Classes in javax.xml.bind.annotation.adapters used by javax.xml.bind
    Class and Description
    XmlAdapter
    Adapts a Java type for custom marshaling.
  • Classes in javax.xml.bind.annotation.adapters used by javax.xml.bind.annotation.adapters
    Class and Description
    XmlAdapter
    Adapts a Java type for custom marshaling.
  • Classes in javax.xml.bind.annotation.adapters used by javax.xml.bind.helpers
    Class and Description
    XmlAdapter
    Adapts a Java type for custom marshaling.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


XmlAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation.adapters

Class XmlAdapter<ValueType,BoundType>

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
  • Type Parameters:
    BoundType - The type that JAXB doesn't know how to handle. An adapter is written to allow this type to be used as an in-memory representation through the ValueType.
    ValueType - The type that JAXB knows how to handle out of the box.
    Direct Known Subclasses:
    CollapsedStringAdapter, HexBinaryAdapter, Link.JaxbAdapter, NormalizedStringAdapter

    public abstract class XmlAdapter<ValueType,BoundType>
extends Object
    Adapts a Java type for custom marshaling.

    Usage:

    Some Java types do not map naturally to a XML representation, for example HashMap or other non JavaBean classes. Conversely, a XML repsentation may map to a Java type but an application may choose to accesss the XML representation using another Java type. For example, the schema to Java binding rules bind xs:DateTime by default to XmlGregorianCalendar. But an application may desire to bind xs:DateTime to a custom type, MyXmlGregorianCalendar, for example. In both cases, there is a mismatch between bound type , used by an application to access XML content and the value type, that is mapped to an XML representation.

    This abstract class defines methods for adapting a bound type to a value type or vice versa. The methods are invoked by the JAXB binding framework during marshaling and unmarshalling:

    • XmlAdapter.marshal(...): During marshalling, JAXB binding framework invokes XmlAdapter.marshal(..) to adapt a bound type to value type, which is then marshaled to XML representation.
    • XmlAdapter.unmarshal(...): During unmarshalling, JAXB binding framework first unmarshals XML representation to a value type and then invokes XmlAdapter.unmarshal(..) to adapt the value type to a bound type.
    Writing an adapter therefore involves the following steps:
    • Write an adapter that implements this abstract class.
    • Install the adapter using the annotation XmlJavaTypeAdapter

    Example: Customized mapping of HashMap

    The following example illustrates the use of @XmlAdapter and @XmlJavaTypeAdapter to customize the mapping of a HashMap.

    Step 1: Determine the desired XML representation for HashMap.

         <hashmap>
         <entry key="id123">this is a value</entry>
         <entry key="id312">this is another value</entry>
         ...
       </hashmap>

    Step 2: Determine the schema definition that the desired XML representation shown above should follow.

     <xs:complexType name="myHashMapType">
       <xs:sequence>
         <xs:element name="entry" type="myHashMapEntryType"
                        minOccurs = "0" maxOccurs="unbounded"/>
       </xs:sequence>
     </xs:complexType>

     <xs:complexType name="myHashMapEntryType">
       <xs:simpleContent>
         <xs:extension base="xs:string">
           <xs:attribute name="key" type="xs:int"/>
         </xs:extension>
       </xs:simpleContent>
     </xs:complexType>

    Step 3: Write value types that can generate the above schema definition.

         public class MyHashMapType {
         List<MyHashMapEntryType> entry;
     }

     public class MyHashMapEntryType {
         @XmlAttribute
         public Integer key;

         @XmlValue
         public String value;
     }

    Step 4: Write the adapter that adapts the value type, MyHashMapType to a bound type, HashMap, used by the application.

         public final class MyHashMapAdapter extends
                        XmlAdapter<MyHashMapType,HashMap> { ... }

    Step 5: Use the adapter.

         public class Foo {
         @XmlJavaTypeAdapter(MyHashMapAdapter.class)
         HashMap hashmap;
         ...
     }
    The above code fragment will map to the following schema:
         <xs:complexType name="Foo">
       <xs:sequence>
         <xs:element name="hashmap" type="myHashMapType"
       </xs:sequence>
     </xs:complexType>
    Since:
    JAXB 2.0
    Author:
    • Sekhar Vajjhala, Sun Microsystems Inc.
    • Kohsuke Kawaguchi, Sun Microsystems Inc.
    See Also:
    XmlJavaTypeAdapter

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected XmlAdapter()
      Do-nothing constructor for the derived classes.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract ValueType marshal(BoundType v)
      Convert a bound type to a value type.
      abstract BoundType unmarshal(ValueType v)
      Convert a value type to a bound type.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XmlAdapter

        protected XmlAdapter()
        Do-nothing constructor for the derived classes.

    • Method Detail

      • unmarshal

        public abstract BoundType unmarshal(ValueType v)
                             throws Exception
        Convert a value type to a bound type.
        Parameters:
        v - The value to be converted. Can be null.
        Throws:
        Exception - if there's an error during the conversion. The caller is responsible for reporting the error to the user through ValidationEventHandler.

      • marshal

        public abstract ValueType marshal(BoundType v)
                           throws Exception
        Convert a bound type to a value type.
        Parameters:
        v - The value to be convereted. Can be null.
        Throws:
        Exception - if there's an error during the conversion. The caller is responsible for reporting the error to the user through ValidationEventHandler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XmlJavaTypeAdapter (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation.adapters

Annotation Type XmlJavaTypeAdapter

  • @Retention(value=RUNTIME)
@Target(value={PACKAGE,FIELD,METHOD,TYPE,PARAMETER})
public @interface XmlJavaTypeAdapter
    Use an adapter that implements XmlAdapter for custom marshaling.

    Usage:

    The @XmlJavaTypeAdapter annotation can be used with the following program elements:

    • a JavaBean property
    • field
    • parameter
    • package
    • from within XmlJavaTypeAdapters

    When @XmlJavaTypeAdapter annotation is defined on a class, it applies to all references to the class.

    When @XmlJavaTypeAdapter annotation is defined at the package level it applies to all references from within the package to @XmlJavaTypeAdapter.type().

    When @XmlJavaTypeAdapter annotation is defined on the field, property or parameter, then the annotation applies to the field, property or the parameter only.

    A @XmlJavaTypeAdapter annotation on a field, property or parameter overrides the @XmlJavaTypeAdapter annotation associated with the class being referenced by the field, property or parameter.

    A @XmlJavaTypeAdapter annotation on a class overrides the @XmlJavaTypeAdapter annotation specified at the package level for that class.

    This annotation can be used with the following other annotations: XmlElement, XmlAttribute, XmlElementRef, XmlElementRefs, XmlAnyElement. This can also be used at the package level with the following annotations: XmlAccessorType, XmlSchema, XmlSchemaType, XmlSchemaTypes.

    Example: See example in XmlAdapter

    Since:
    JAXB2.0
    Author:
    • Sekhar Vajjhala, Sun Microsystems Inc.
    • Kohsuke Kawaguchi, Sun Microsystems Inc.
    See Also:
    XmlAdapter

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<? extends XmlAdapter> value
      Points to the class that converts a value type to a bound type or vice versa.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class type
      If this annotation is used at the package level, then value of the type() must be specified.

    • Element Detail

      • value

        public abstract Class<? extends XmlAdapter> value
        Points to the class that converts a value type to a bound type or vice versa. See XmlAdapter for more details.

      • type

        public abstract Class type
        If this annotation is used at the package level, then value of the type() must be specified.
        Default:
        javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT.class
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


XmlJavaTypeAdapter.DEFAULT (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation.adapters

Class XmlJavaTypeAdapter.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
  • Enclosing class:
    XmlJavaTypeAdapter

    public static final class XmlJavaTypeAdapter.DEFAULT
extends Object
    Used in XmlJavaTypeAdapter.type() to signal that the type be inferred from the signature of the field, property, parameter or the class.

    • Constructor Summary

      Constructors
      Constructor and Description
      XmlJavaTypeAdapter.DEFAULT()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XmlJavaTypeAdapter.DEFAULT

        public XmlJavaTypeAdapter.DEFAULT()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XmlJavaTypeAdapters (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.bind.annotation.adapters

Annotation Type XmlJavaTypeAdapters

  • @Retention(value=RUNTIME)
@Target(value=PACKAGE)
public @interface XmlJavaTypeAdapters

    A container for multiple @XmlJavaTypeAdapter annotations.

    Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlJavaTypeAdapter as follows:

     @XmlJavaTypeAdapters ({ @XmlJavaTypeAdapter(...),@XmlJavaTypeAdapter(...) })

    The @XmlJavaTypeAdapters annnotation is useful for defining XmlJavaTypeAdapter annotations for different types at the package level.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Since:
    JAXB2.0
    Author:
    • Sekhar Vajjhala, Sun Microsystems, Inc.
    See Also:
    XmlJavaTypeAdapter

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      XmlJavaTypeAdapter[] value
      Collection of @XmlJavaTypeAdapter annotations

    • Element Detail

      • value

        public abstract XmlJavaTypeAdapter[] value
        Collection of @XmlJavaTypeAdapter annotations
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.xml.bind.annotation.adapters.CollapsedStringAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.CollapsedStringAdapter

No usage of javax.xml.bind.annotation.adapters.CollapsedStringAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.adapters.HexBinaryAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.HexBinaryAdapter

No usage of javax.xml.bind.annotation.adapters.HexBinaryAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.adapters.NormalizedStringAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.NormalizedStringAdapter

No usage of javax.xml.bind.annotation.adapters.NormalizedStringAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.adapters.XmlAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.XmlAdapter

  • Packages that use XmlAdapter
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation.adapters
    XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of XmlAdapter in javax.ws.rs.core

      Subclasses of XmlAdapter in javax.ws.rs.core
      Modifier and Type Class and Description
      static class  Link.JaxbAdapter
      An implementation of JAXB XmlAdapter that maps the JAX-RS Link type to a value that can be marshalled and unmarshalled by JAXB.

    • Uses of XmlAdapter in javax.xml.bind

      Methods in javax.xml.bind with type parameters of type XmlAdapter
      Modifier and Type Method and Description
      <A extends XmlAdapter>
      A             		Unmarshaller.getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      <A extends XmlAdapter>
      A             		Marshaller.getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      <A extends XmlAdapter>
      void             		Unmarshaller.setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      <A extends XmlAdapter>
      void             		Marshaller.setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      Methods in javax.xml.bind with parameters of type XmlAdapter
      Modifier and Type Method and Description
      void Unmarshaller.setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void Marshaller.setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this marshaller.

    • Uses of XmlAdapter in javax.xml.bind.annotation.adapters

      Subclasses of XmlAdapter in javax.xml.bind.annotation.adapters
      Modifier and Type Class and Description
      class  CollapsedStringAdapter
      Built-in XmlAdapter to handle xs:token and its derived types.
      class  HexBinaryAdapter
      XmlAdapter for xs:hexBinary.
      class  NormalizedStringAdapter
      XmlAdapter to handle xs:normalizedString.

    • Uses of XmlAdapter in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with type parameters of type XmlAdapter
      Modifier and Type Method and Description
      <A extends XmlAdapter>
      A             		AbstractUnmarshallerImpl.getAdapter(Class<A> type)
      <A extends XmlAdapter>
      A             		AbstractMarshallerImpl.getAdapter(Class<A> type)
      <A extends XmlAdapter>
      void             		AbstractUnmarshallerImpl.setAdapter(Class<A> type, A adapter)
      <A extends XmlAdapter>
      void             		AbstractMarshallerImpl.setAdapter(Class<A> type, A adapter)
      Methods in javax.xml.bind.helpers with parameters of type XmlAdapter
      Modifier and Type | Method and Description
      void | AbstractUnmarshallerImpl.setAdapter(XmlAdapter adapter)
      void | AbstractMarshallerImpl.setAdapter(XmlAdapter adapter)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter

No usage of javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT

No usage of javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters

No usage of javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.W3CDomHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.W3CDomHandler

No usage of javax.xml.bind.annotation.W3CDomHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlAccessOrder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAccessOrder

  • Packages that use XmlAccessOrder
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of XmlAccessOrder in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return XmlAccessOrder
      Modifier and Type Method and Description
      static XmlAccessOrder XmlAccessOrder.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessOrder[] XmlAccessOrder.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlAccessorOrder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAccessorOrder

No usage of javax.xml.bind.annotation.XmlAccessorOrder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlAccessorType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAccessorType

No usage of javax.xml.bind.annotation.XmlAccessorType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlAccessType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAccessType

  • Packages that use XmlAccessType
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of XmlAccessType in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return XmlAccessType
      Modifier and Type Method and Description
      static XmlAccessType XmlAccessType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessType[] XmlAccessType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlAnyAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAnyAttribute

  • Packages that use XmlAnyAttribute
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of XmlAnyAttribute in javax.ws.rs.core

      Methods in javax.ws.rs.core with annotations of type XmlAnyAttribute
      Modifier and Type Method and Description
      Map<QName,Object> Link.JaxbLink.getParams()
      Get the parameter map for this link.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlAnyElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAnyElement

No usage of javax.xml.bind.annotation.XmlAnyElement
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlAttachmentRef (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAttachmentRef

No usage of javax.xml.bind.annotation.XmlAttachmentRef
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlAttribute (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAttribute

  • Packages that use XmlAttribute
    Package Description
    javax.ws.rs.core
    Low-level interfaces and annotations used to create RESTful service resources.

    • Uses of XmlAttribute in javax.ws.rs.core

      Methods in javax.ws.rs.core with annotations of type XmlAttribute
      Modifier and Type Method and Description
      URI Link.JaxbLink.getUri()
      Get the underlying URI for this link.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElement

No usage of javax.xml.bind.annotation.XmlElement
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlElement.DEFAULT (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElement.DEFAULT

No usage of javax.xml.bind.annotation.XmlElement.DEFAULT
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlElementDecl (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementDecl

No usage of javax.xml.bind.annotation.XmlElementDecl
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlElementDecl.GLOBAL (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementDecl.GLOBAL

No usage of javax.xml.bind.annotation.XmlElementDecl.GLOBAL
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlElementRef (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementRef

No usage of javax.xml.bind.annotation.XmlElementRef
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlElementRef.DEFAULT (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementRef.DEFAULT

No usage of javax.xml.bind.annotation.XmlElementRef.DEFAULT
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlElementRefs (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementRefs

No usage of javax.xml.bind.annotation.XmlElementRefs
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlElements (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElements

No usage of javax.xml.bind.annotation.XmlElements
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlElementWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementWrapper

No usage of javax.xml.bind.annotation.XmlElementWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlEnum (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlEnum

No usage of javax.xml.bind.annotation.XmlEnum
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlEnumValue (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlEnumValue

No usage of javax.xml.bind.annotation.XmlEnumValue
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlID (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlID

No usage of javax.xml.bind.annotation.XmlID
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlIDREF (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlIDREF

No usage of javax.xml.bind.annotation.XmlIDREF
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlInlineBinaryData (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlInlineBinaryData

No usage of javax.xml.bind.annotation.XmlInlineBinaryData
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlList (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlList

No usage of javax.xml.bind.annotation.XmlList
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlMimeType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlMimeType

No usage of javax.xml.bind.annotation.XmlMimeType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlMixed (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlMixed

No usage of javax.xml.bind.annotation.XmlMixed
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlNs (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlNs

No usage of javax.xml.bind.annotation.XmlNs
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlNsForm (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlNsForm

  • Packages that use XmlNsForm
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of XmlNsForm in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return XmlNsForm
      Modifier and Type Method and Description
      static XmlNsForm XmlNsForm.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlNsForm[] XmlNsForm.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlRegistry (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlRegistry

No usage of javax.xml.bind.annotation.XmlRegistry
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlRootElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlRootElement

  • Packages that use XmlRootElement
    Package Description
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of XmlRootElement in javax.xml.ws.wsaddressing

      Classes in javax.xml.ws.wsaddressing with annotations of type XmlRootElement
      Modifier and Type Class and Description
      class  W3CEndpointReference
      This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlSchema (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlSchema

No usage of javax.xml.bind.annotation.XmlSchema
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlSchemaType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlSchemaType

No usage of javax.xml.bind.annotation.XmlSchemaType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlSchemaType.DEFAULT (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlSchemaType.DEFAULT

No usage of javax.xml.bind.annotation.XmlSchemaType.DEFAULT
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlSchemaTypes (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlSchemaTypes

No usage of javax.xml.bind.annotation.XmlSchemaTypes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlSeeAlso (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlSeeAlso

No usage of javax.xml.bind.annotation.XmlSeeAlso
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlTransient (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlTransient

  • Packages that use XmlTransient
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of XmlTransient in javax.xml.ws

      Classes in javax.xml.ws with annotations of type XmlTransient
      Modifier and Type Class and Description
      class  EndpointReference
      This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlType

  • Packages that use XmlType
    Package Description
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of XmlType in javax.xml.ws.wsaddressing

      Classes in javax.xml.ws.wsaddressing with annotations of type XmlType
      Modifier and Type Class and Description
      class  W3CEndpointReference
      This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlType.DEFAULT (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlType.DEFAULT

No usage of javax.xml.bind.annotation.XmlType.DEFAULT
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.annotation.XmlValue (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlValue

No usage of javax.xml.bind.annotation.XmlValue
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.annotation.DomHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.annotation.DomHandler

  • Packages that use DomHandler
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of DomHandler in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation that implement DomHandler
      Modifier and Type Class and Description
      class  W3CDomHandler
      DomHandler implementation for W3C DOM (org.w3c.dom package.)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AttachmentMarshaller (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.attachment

Class AttachmentMarshaller

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentMarshaller

  • public abstract class AttachmentMarshaller
extends Object

    Enable JAXB marshalling to optimize storage of binary data.

    This API enables an efficient cooperative creation of optimized binary data formats between a JAXB marshalling process and a MIME-based package processor. A JAXB implementation marshals the root body of a MIME-based package, delegating the creation of referenceable MIME parts to the MIME-based package processor that implements this abstraction.

    XOP processing is enabled when isXOPPackage() is true. See addMtomAttachment(DataHandler, String, String) for details.

    WS-I Attachment Profile 1.0 is supported by addSwaRefAttachment(DataHandler) being called by the marshaller for each JAXB property related to {http://ws-i.org/profiles/basic/1.1/xsd}swaRef.

    Since:
    JAXB 2.0
    Author:
    Marc Hadley, Kohsuke Kawaguchi, Joseph Fialli
    See Also:
    Marshaller.setAttachmentMarshaller(AttachmentMarshaller), XML-binary Optimized Packaging, WS-I Attachments Profile Version 1.0.

    • Constructor Summary

      Constructors
      Constructor and Description
      AttachmentMarshaller()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract String addMtomAttachment(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName)
      Consider binary data for optimized binary storage as an attachment.
      abstract String addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName)
      Consider MIME content data for optimized binary storage as an attachment.
      abstract String addSwaRefAttachment(DataHandler data)
      Add MIME data as an attachment and return attachment's content-id, cid.
      boolean isXOPPackage()
      Read-only property that returns true if JAXB marshaller should enable XOP creation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttachmentMarshaller

        public AttachmentMarshaller()

    • Method Detail

      • addMtomAttachment

        public abstract String addMtomAttachment(DataHandler data,
                       String elementNamespace,
                       String elementLocalName)

        Consider MIME content data for optimized binary storage as an attachment.

        This method is called by JAXB marshal process when isXOPPackage() is true, for each element whose datatype is "base64Binary", as described in Step 3 in Creating XOP Packages.

        The method implementor determines whether data shall be attached separately or inlined as base64Binary data. If the implementation chooses to optimize the storage of the binary data as a MIME part, it is responsible for attaching data to the MIME-based package, and then assigning an unique content-id, cid, that identifies the MIME part within the MIME message. This method returns the cid, which enables the JAXB marshaller to marshal a XOP element that refers to that cid in place of marshalling the binary data. When the method returns null, the JAXB marshaller inlines data as base64binary data.

        The caller of this method is required to meet the following constraint. If the element infoset item containing data has the attribute xmime:contentType or if the JAXB property/field representing datais annotated with a known MIME type, data.getContentType() should be set to that MIME type.

        The elementNamespace and elementLocalName parameters provide the context that contains the binary data. This information could be used by the MIME-based package processor to determine if the binary data should be inlined or optimized as an attachment.

        Parameters:
        data - represents the data to be attached. Must be non-null.
        elementNamespace - the namespace URI of the element that encloses the base64Binary data. Can be empty but never null.
        elementLocalName - The local name of the element. Always a non-null valid string.
        Returns:
        a valid content-id URI (see RFC 2387) that identifies the attachment containing data. Otherwise, null if the attachment was not added and should instead be inlined in the message.
        See Also:
        XML-binary Optimized Packaging, Describing Media Content of Binary Data in XML

      • addMtomAttachment

        public abstract String addMtomAttachment(byte[] data,
                       int offset,
                       int length,
                       String mimeType,
                       String elementNamespace,
                       String elementLocalName)

        Consider binary data for optimized binary storage as an attachment.

        Since content type is not known, the attachment's MIME content type must be set to "application/octet-stream".

        The elementNamespace and elementLocalName parameters provide the context that contains the binary data. This information could be used by the MIME-based package processor to determine if the binary data should be inlined or optimized as an attachment.

        Parameters:
        data - represents the data to be attached. Must be non-null. The actual data region is specified by (data,offset,length) tuple.
        offset - The offset within the array of the first byte to be read; must be non-negative and no larger than array.length
        length - The number of bytes to be read from the given array; must be non-negative and no larger than array.length
        mimeType - If the data has an associated MIME type known to JAXB, that is passed as this parameter. If none is known, "application/octet-stream". This parameter may never be null.
        elementNamespace - the namespace URI of the element that encloses the base64Binary data. Can be empty but never null.
        elementLocalName - The local name of the element. Always a non-null valid string.
        Returns:
        content-id URI, cid, to the attachment containing data or null if data should be inlined.
        See Also:
        addMtomAttachment(DataHandler, String, String)

      • isXOPPackage

        public boolean isXOPPackage()

        Read-only property that returns true if JAXB marshaller should enable XOP creation.

        This value must not change during the marshalling process. When this value is true, the addMtomAttachment(...) method is invoked when the appropriate binary datatypes are encountered by the marshal process.

        Marshaller.marshal() must throw IllegalStateException if this value is true and the XML content to be marshalled violates Step 1 in Creating XOP Pacakges http://www.w3.org/TR/2005/REC-xop10-20050125/#creating_xop_packages. "Ensure the Original XML Infoset contains no element information item with a [namespace name] of "http://www.w3.org/2004/08/xop/include" and a [local name] of Include"

        When this method returns true and during the marshal process at least one call to addMtomAttachment(...) returns a content-id, the MIME-based package processor must label the root part with the application/xop+xml media type as described in Step 5 of Creating XOP Pacakges.

        Returns:
        true when MIME context is a XOP Package.

      • addSwaRefAttachment

        public abstract String addSwaRefAttachment(DataHandler data)

        Add MIME data as an attachment and return attachment's content-id, cid.

        This method is called by JAXB marshal process for each element/attribute typed as {http://ws-i.org/profiles/basic/1.1/xsd}swaRef. The MIME-based package processor implementing this method is responsible for attaching the specified data to a MIME attachment, and generating a content-id, cid, that uniquely identifies the attachment within the MIME-based package.

        Caller inserts the returned content-id, cid, into the XML content being marshalled.

        Parameters:
        data - represents the data to be attached. Must be non-null.
        Returns:
        must be a valid URI used as cid. Must satisfy Conformance Requirement R2928 from WS-I Attachments Profile Version 1.0.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AttachmentUnmarshaller (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.attachment

Class AttachmentUnmarshaller

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentUnmarshaller

  • public abstract class AttachmentUnmarshaller
extends Object

    Enables JAXB unmarshalling of a root document containing optimized binary data formats.

    This API enables an efficient cooperative processing of optimized binary data formats between a JAXB 2.0 implementation and MIME-based package processor (MTOM/XOP and WS-I AP 1.0). JAXB unmarshals the body of a package, delegating the understanding of the packaging format being used to a MIME-based package processor that implements this abstract class.

    This abstract class identifies if a package requires XOP processing, isXOPPackage() and provides retrieval of binary content stored as attachments by content-id.

    Identifying the content-id, cid, to pass to getAttachment*(String cid)

    • For XOP processing, the infoset representation of the cid is described in step 2a in Section 3.2 Interpreting XOP Packages
    • For WS-I AP 1.0, the cid is identified as an element or attribute of type ref:swaRef specified in Section 4.4 Referencing Attachments from the SOAP Envelope
    Since:
    JAXB 2.0
    Author:
    Marc Hadley, Kohsuke Kawaguchi, Joseph Fialli
    See Also:
    Unmarshaller.setAttachmentUnmarshaller(AttachmentUnmarshaller), XML-binary Optimized Packaging, WS-I Attachments Profile Version 1.0., Describing Media Content of Binary Data in XML

    • Constructor Summary

      Constructors
      Constructor and Description
      AttachmentUnmarshaller()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract byte[] getAttachmentAsByteArray(String cid)
      Retrieve the attachment identified by content-id, cid, as a byte[]
      abstract DataHandler getAttachmentAsDataHandler(String cid)
      Lookup MIME content by content-id, cid, and return as a DataHandler.
      boolean isXOPPackage()
      Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttachmentUnmarshaller

        public AttachmentUnmarshaller()

    • Method Detail

      • getAttachmentAsDataHandler

        public abstract DataHandler getAttachmentAsDataHandler(String cid)

        Lookup MIME content by content-id, cid, and return as a DataHandler.

        The returned DataHandler instance must be configured to meet the following required mapping constaint.

        Required Mappings between MIME and Java Types
        MIME Type | Java Type
        DataHandler.getContentType() | instanceof DataHandler.getContent()
        image/gif | java.awt.Image
        image/jpeg | java.awt.Image
        text/xml or application/xml | javax.xml.transform.Source
        Note that it is allowable to support additional mappings.

        Parameters:
        cid - It is expected to be a valid lexical form of the XML Schema xs:anyURI datatype. If isXOPPackage() ==true, it must be a valid URI per the cid: URI scheme (see RFC 2387)
        Returns:
        a DataHandler that represents the MIME attachment.
        Throws:
        IllegalArgumentException - if the attachment for the given cid is not found.

      • getAttachmentAsByteArray

        public abstract byte[] getAttachmentAsByteArray(String cid)

        Retrieve the attachment identified by content-id, cid, as a byte[]

        .
        Parameters:
        cid - It is expected to be a valid lexical form of the XML Schema xs:anyURI datatype. If isXOPPackage() ==true, it must be a valid URI per the cid: URI scheme (see RFC 2387)
        Returns:
        byte[] representation of attachment identified by cid.
        Throws:
        IllegalArgumentException - if the attachment for the given cid is not found.

      • isXOPPackage

        public boolean isXOPPackage()

        Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.

        This method returns true when the constraints specified in Identifying XOP Documents are met. This value must not change during the unmarshalling process.

        Returns:
        true when MIME context is a XOP Document.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.bind.attachment (Java(TM) EE 7 Specification APIs)

javax.xml.bind.attachment

Classes

  • AttachmentMarshaller
  • AttachmentUnmarshaller


javax.xml.bind.attachment (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind.attachment

This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.

See: Description

  • Class Summary
    Class Description
    AttachmentMarshaller
    Enable JAXB marshalling to optimize storage of binary data.
    AttachmentUnmarshaller
    Enables JAXB unmarshalling of a root document containing optimized binary data formats.

Package javax.xml.bind.attachment Description

This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.

Soap MTOM[1], XOP([2][3]) and WS-I AP[4] standardize approaches to optimized transmission of binary datatypes as an attachment. To optimally support these standards within a message passing environment, this package enables an integrated solution between a MIME-based package processor and JAXB unmarshall/marshal processes.

Package Specification

  • JAXB Specification

Related Standards

  • [1]SOAP Message Transmission Optimization Mechanism
  • [2]XML-binary Optimized Packaging
  • [3]WS-I Attachments Profile Version 1.0.
  • [4]Describing Media Content of Binary Data in XML
Since:
JAXB 2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.bind.attachment Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind.attachment

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentMarshaller
    • javax.xml.bind.attachment.AttachmentUnmarshaller
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.xml.bind.attachment (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind.attachment

  • Packages that use javax.xml.bind.attachment
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
  • Classes in javax.xml.bind.attachment used by javax.xml.bind
    Class and Description
    AttachmentMarshaller
    Enable JAXB marshalling to optimize storage of binary data.
    AttachmentUnmarshaller
    Enables JAXB unmarshalling of a root document containing optimized binary data formats.
  • Classes in javax.xml.bind.attachment used by javax.xml.bind.helpers
    Class and Description
    AttachmentMarshaller
    Enable JAXB marshalling to optimize storage of binary data.
    AttachmentUnmarshaller
    Enables JAXB unmarshalling of a root document containing optimized binary data formats.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.attachment.AttachmentMarshaller (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.attachment.AttachmentMarshaller

  • Packages that use AttachmentMarshaller
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of AttachmentMarshaller in javax.xml.bind

      Methods in javax.xml.bind that return AttachmentMarshaller
      Modifier and Type | Method and Description
      AttachmentMarshaller | Marshaller.getAttachmentMarshaller()
      Methods in javax.xml.bind with parameters of type AttachmentMarshaller
      Modifier and Type Method and Description
      void Marshaller.setAttachmentMarshaller(AttachmentMarshaller am)
      Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.

    • Uses of AttachmentMarshaller in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return AttachmentMarshaller
      Modifier and Type | Method and Description
      AttachmentMarshaller | AbstractMarshallerImpl.getAttachmentMarshaller()
      Methods in javax.xml.bind.helpers with parameters of type AttachmentMarshaller
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.setAttachmentMarshaller(AttachmentMarshaller am)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.attachment.AttachmentUnmarshaller (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.attachment.AttachmentUnmarshaller

  • Packages that use AttachmentUnmarshaller
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of AttachmentUnmarshaller in javax.xml.bind

      Methods in javax.xml.bind that return AttachmentUnmarshaller
      Modifier and Type | Method and Description
      AttachmentUnmarshaller | Unmarshaller.getAttachmentUnmarshaller()
      Methods in javax.xml.bind with parameters of type AttachmentUnmarshaller
      Modifier and Type Method and Description
      void Unmarshaller.setAttachmentUnmarshaller(AttachmentUnmarshaller au)
      Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

    • Uses of AttachmentUnmarshaller in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return AttachmentUnmarshaller
      Modifier and Type | Method and Description
      AttachmentUnmarshaller | AbstractUnmarshallerImpl.getAttachmentUnmarshaller()
      Methods in javax.xml.bind.helpers with parameters of type AttachmentUnmarshaller
      Modifier and Type | Method and Description
      void | AbstractUnmarshallerImpl.setAttachmentUnmarshaller(AttachmentUnmarshaller au)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.Binder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.Binder

  • Packages that use Binder
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of Binder in javax.xml.bind

      Methods in javax.xml.bind that return Binder
      Modifier and Type Method and Description
      Binder<Node> JAXBContext.createBinder()
      Creates a Binder for W3C DOM.
      <T> Binder<T> JAXBContext.createBinder(Class<T> domType)
      Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.DataBindingException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.DataBindingException

No usage of javax.xml.bind.DataBindingException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.DatatypeConverter (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.DatatypeConverter

No usage of javax.xml.bind.DatatypeConverter
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.JAXB (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXB

No usage of javax.xml.bind.JAXB
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.JAXBContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBContext

  • Packages that use JAXBContext
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of JAXBContext in javax.xml.bind

      Methods in javax.xml.bind that return JAXBContext
      Modifier and Type Method and Description
      static JAXBContext JAXBContext.newInstance(Class... classesToBeBound)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.

    • Uses of JAXBContext in javax.xml.bind.util

      Constructors in javax.xml.bind.util with parameters of type JAXBContext
      Constructor and Description
      JAXBResult(JAXBContext context)
      Creates a new instance that uses the specified JAXBContext to unmarshal.
      JAXBSource(JAXBContext context, Object contentObject)
      Creates a new Source for the given content object.

    • Uses of JAXBContext in javax.xml.ws

      Methods in javax.xml.ws with parameters of type JAXBContext
      Modifier and Type Method and Description
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Object LogicalMessage.getPayload(JAXBContext context)
      Gets the message payload as a JAXB object.
      void LogicalMessage.setPayload(Object payload, JAXBContext context)
      Sets the message payload

    • Uses of JAXBContext in javax.xml.ws.handler.soap

      Methods in javax.xml.ws.handler.soap with parameters of type JAXBContext
      Modifier and Type Method and Description
      Object[] SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
      Gets headers that have a particular qualified name from the message in the message context.

    • Uses of JAXBContext in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type JAXBContext
      Modifier and Type Method and Description
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.JAXBElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBElement

  • Packages that use JAXBElement
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of JAXBElement in javax.xml.bind

      Methods in javax.xml.bind that return JAXBElement
      Modifier and Type Method and Description
      <T> JAXBElement<T> Unmarshaller.unmarshal(Node node, Class<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Source source, Class<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      abstract <T> JAXBElement<T> Binder.unmarshal(XmlNode xmlNode, Class<T> declaredType)
      Unmarshal XML root element by provided declaredType to a JAXB object tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

    • Uses of JAXBElement in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return JAXBElement
      Modifier and Type | Method and Description
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.JAXBElement.GlobalScope (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBElement.GlobalScope

No usage of javax.xml.bind.JAXBElement.GlobalScope
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.JAXBException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBException

  • Packages that use JAXBException
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of JAXBException in javax.xml.bind

      Subclasses of JAXBException in javax.xml.bind
      Modifier and Type Class and Description
      class  MarshalException
      This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.
      class  PropertyException
      This exception indicates that an error was encountered while getting or setting a property.
      class  UnmarshalException
      This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
      class  ValidationException
      This exception indicates that an error has occurred while performing a validate operation.
      Methods in javax.xml.bind that throw JAXBException
      Modifier and Type Method and Description
      abstract Marshaller JAXBContext.createMarshaller()
      Create a Marshaller object that can be used to convert a java content tree into XML data.
      abstract Unmarshaller JAXBContext.createUnmarshaller()
      Create an Unmarshaller object that can be used to convert XML data into a java content tree.
      abstract Validator JAXBContext.createValidator()
      Deprecated.
      since JAXB2.0
      ValidationEventHandler Validator.getEventHandler()
      Deprecated.
      since JAXB2.0
      ValidationEventHandler Unmarshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      ValidationEventHandler Marshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      abstract ValidationEventHandler Binder.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Node Marshaller.getNode(Object contentTree)
      Get a DOM tree view of the content tree(Optional).
      Object UnmarshallerHandler.getResult()
      Obtains the unmarshalled result.
      boolean Unmarshaller.isValidating()
      Deprecated.
      since JAXB2.0, please see Unmarshaller.getSchema()
      void Marshaller.marshal(Object jaxbElement, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.
      void Marshaller.marshal(Object jaxbElement, File output)
      Marshal the content tree rooted at jaxbElement into a file.
      void Marshaller.marshal(Object jaxbElement, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      void Marshaller.marshal(Object jaxbElement, OutputStream os)
      Marshal the content tree rooted at jaxbElement into an output stream.
      void Marshaller.marshal(Object jaxbElement, Result result)
      Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.
      void Marshaller.marshal(Object jaxbElement, Writer writer)
      Marshal the content tree rooted at jaxbElement into a Writer.
      void Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
      abstract void Binder.marshal(Object jaxbObject, XmlNode xmlNode)
      Marshal a JAXB object tree to a new XML document.
      void Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
      static JAXBContext JAXBContext.newInstance(Class... classesToBeBound)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      void Validator.setEventHandler(ValidationEventHandler handler)
      Deprecated.
      since JAXB2.0
      void Unmarshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void Marshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      abstract void Binder.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void Unmarshaller.setValidating(boolean validating)
      Deprecated.
      since JAXB2.0, please see Unmarshaller.setSchema(javax.xml.validation.Schema)
      Object Unmarshaller.unmarshal(File f)
      Unmarshal XML data from the specified file and return the resulting content tree.
      Object Unmarshaller.unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
      Object Unmarshaller.unmarshal(InputStream is)
      Unmarshal XML data from the specified InputStream and return the resulting content tree.
      Object Unmarshaller.unmarshal(Node node)
      Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Node node, Class<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      Object Unmarshaller.unmarshal(Reader reader)
      Unmarshal XML data from the specified Reader and return the resulting content tree.
      Object Unmarshaller.unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Source source, Class<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      Object Unmarshaller.unmarshal(URL url)
      Unmarshal XML data from the specified URL and return the resulting content tree.
      Object Unmarshaller.unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      abstract Object Binder.unmarshal(XmlNode xmlNode)
      Unmarshal XML infoset view to a JAXB object tree.
      abstract <T> JAXBElement<T> Binder.unmarshal(XmlNode xmlNode, Class<T> declaredType)
      Unmarshal XML root element by provided declaredType to a JAXB object tree.
      Object Unmarshaller.unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      abstract Object Binder.updateJAXB(XmlNode xmlNode)
      Takes an XML node and updates its associated JAXB object and its descendants.
      abstract XmlNode Binder.updateXML(Object jaxbObject)
      Takes an JAXB object and updates its associated XML node and its descendants.
      abstract XmlNode Binder.updateXML(Object jaxbObject, XmlNode xmlNode)
      Changes in JAXB object tree are updated in its associated XML parse tree.
      boolean Validator.validate(Object subrootObj)
      Deprecated.
      since JAXB2.0
      boolean Validator.validateRoot(Object rootObj)
      Deprecated.
      since JAXB2.0

    • Uses of JAXBException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that throw JAXBException
      Modifier and Type | Method and Description
      ValidationEventHandler AbstractUnmarshallerImpl.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      ValidationEventHandler | AbstractMarshallerImpl.getEventHandler()
      Node AbstractMarshallerImpl.getNode(Object obj)
      By default, the getNode method is unsupported and throw an UnsupportedOperationException.
      protected XMLReader AbstractUnmarshallerImpl.getXMLReader()
      Obtains a configured XMLReader.
      boolean AbstractUnmarshallerImpl.isValidating()
      Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.
      void | AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)
      void | AbstractMarshallerImpl.marshal(Object jaxbElement, File output)
      void | AbstractMarshallerImpl.marshal(Object obj, Node node)
      void | AbstractMarshallerImpl.marshal(Object obj, OutputStream os)
      void | AbstractMarshallerImpl.marshal(Object obj, Writer w)
      void | AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)
      void | AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)
      void AbstractUnmarshallerImpl.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void | AbstractMarshallerImpl.setEventHandler(ValidationEventHandler handler)
      void AbstractUnmarshallerImpl.setValidating(boolean validating)
      Specifies whether or not the Unmarshaller should validate during unmarshal operations.
      Object | AbstractUnmarshallerImpl.unmarshal(File f)
      Object | AbstractUnmarshallerImpl.unmarshal(InputSource source)
      Object | AbstractUnmarshallerImpl.unmarshal(InputStream is)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
      Object | AbstractUnmarshallerImpl.unmarshal(Reader reader)
      Object | AbstractUnmarshallerImpl.unmarshal(Source source)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)
      Object | AbstractUnmarshallerImpl.unmarshal(URL url)
      Object | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)
      protected abstract Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.
      Object | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

    • Uses of JAXBException in javax.xml.bind.util

      Methods in javax.xml.bind.util that throw JAXBException
      Modifier and Type Method and Description
      Object JAXBResult.getResult()
      Gets the unmarshalled object created by the transformation.
      Constructors in javax.xml.bind.util that throw JAXBException
      Constructor and Description
      JAXBResult(JAXBContext context)
      Creates a new instance that uses the specified JAXBContext to unmarshal.
      JAXBResult(Unmarshaller _unmarshaller)
      Creates a new instance that uses the specified Unmarshaller to unmarshal an object.
      JAXBSource(JAXBContext context, Object contentObject)
      Creates a new Source for the given content object.
      JAXBSource(Marshaller marshaller, Object contentObject)
      Creates a new Source for the given content object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.JAXBIntrospector (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBIntrospector

  • Packages that use JAXBIntrospector
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of JAXBIntrospector in javax.xml.bind

      Methods in javax.xml.bind that return JAXBIntrospector
      Modifier and Type Method and Description
      JAXBIntrospector JAXBContext.createJAXBIntrospector()
      Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.JAXBPermission (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBPermission

No usage of javax.xml.bind.JAXBPermission
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.MarshalException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.MarshalException

No usage of javax.xml.bind.MarshalException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.Marshaller.Listener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.Marshaller.Listener

  • Packages that use Marshaller.Listener
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of Marshaller.Listener in javax.xml.bind

      Methods in javax.xml.bind that return Marshaller.Listener
      Modifier and Type Method and Description
      Marshaller.Listener Marshaller.getListener()
      Return Marshaller.Listener registered with this Marshaller.
      Methods in javax.xml.bind with parameters of type Marshaller.Listener
      Modifier and Type Method and Description
      void Marshaller.setListener(Marshaller.Listener listener)
      Register marshal event callback Marshaller.Listener with this Marshaller.

    • Uses of Marshaller.Listener in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Marshaller.Listener
      Modifier and Type | Method and Description
      Marshaller.Listener | AbstractMarshallerImpl.getListener()
      Methods in javax.xml.bind.helpers with parameters of type Marshaller.Listener
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.setListener(Marshaller.Listener listener)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.PropertyException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.PropertyException

  • Packages that use PropertyException
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of PropertyException in javax.xml.bind

      Methods in javax.xml.bind that throw PropertyException
      Modifier and Type Method and Description
      Object Validator.getProperty(String name)
      Deprecated.
      since JAXB2.0
      Object Unmarshaller.getProperty(String name)
      Get the particular property in the underlying implementation of Unmarshaller.
      Object Marshaller.getProperty(String name)
      Get the particular property in the underlying implementation of Marshaller.
      abstract Object Binder.getProperty(String name)
      Get the particular property in the underlying implementation of Binder.
      void Validator.setProperty(String name, Object value)
      Deprecated.
      since JAXB2.0
      void Unmarshaller.setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Unmarshaller.
      void Marshaller.setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Marshaller.
      abstract void Binder.setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Binder.

    • Uses of PropertyException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that throw PropertyException
      Modifier and Type Method and Description
      Object AbstractUnmarshallerImpl.getProperty(String name)
      Default implementation of the getProperty method always throws PropertyException since there are no required properties.
      Object AbstractMarshallerImpl.getProperty(String name)
      Default implementation of the getProperty method handles the four defined properties in Marshaller.
      void AbstractUnmarshallerImpl.setProperty(String name, Object value)
      Default implementation of the setProperty method always throws PropertyException since there are no required properties.
      void AbstractMarshallerImpl.setProperty(String name, Object value)
      Default implementation of the setProperty method handles the four defined properties in Marshaller.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.SchemaOutputResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.SchemaOutputResolver

  • Packages that use SchemaOutputResolver
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of SchemaOutputResolver in javax.xml.bind

      Methods in javax.xml.bind with parameters of type SchemaOutputResolver
      Modifier and Type Method and Description
      void JAXBContext.generateSchema(SchemaOutputResolver outputResolver)
      Generates the schema documents for this context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.TypeConstraintException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.TypeConstraintException

No usage of javax.xml.bind.TypeConstraintException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.UnmarshalException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.UnmarshalException

  • Packages that use UnmarshalException
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of UnmarshalException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return UnmarshalException
      Modifier and Type Method and Description
      protected UnmarshalException AbstractUnmarshallerImpl.createUnmarshalException(SAXException e)
      Creates an UnmarshalException from a SAXException.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.Unmarshaller.Listener (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.Unmarshaller.Listener

  • Packages that use Unmarshaller.Listener
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of Unmarshaller.Listener in javax.xml.bind

      Methods in javax.xml.bind that return Unmarshaller.Listener
      Modifier and Type Method and Description
      Unmarshaller.Listener Unmarshaller.getListener()
      Return Unmarshaller.Listener registered with this Unmarshaller.
      Methods in javax.xml.bind with parameters of type Unmarshaller.Listener
      Modifier and Type Method and Description
      void Unmarshaller.setListener(Unmarshaller.Listener listener)
      Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

    • Uses of Unmarshaller.Listener in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Unmarshaller.Listener
      Modifier and Type | Method and Description
      Unmarshaller.Listener | AbstractUnmarshallerImpl.getListener()
      Methods in javax.xml.bind.helpers with parameters of type Unmarshaller.Listener
      Modifier and Type | Method and Description
      void | AbstractUnmarshallerImpl.setListener(Unmarshaller.Listener listener)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.ValidationException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.ValidationException

No usage of javax.xml.bind.ValidationException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.DatatypeConverterInterface (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.DatatypeConverterInterface

  • Packages that use DatatypeConverterInterface
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of DatatypeConverterInterface in javax.xml.bind

      Methods in javax.xml.bind with parameters of type DatatypeConverterInterface
      Modifier and Type Method and Description
      static void DatatypeConverter.setDatatypeConverter(DatatypeConverterInterface converter)
      This method is for JAXB provider use only.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.Element (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.Element

No usage of javax.xml.bind.Element
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.Marshaller (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.Marshaller

  • Packages that use Marshaller
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of Marshaller in javax.xml.bind

      Methods in javax.xml.bind that return Marshaller
      Modifier and Type Method and Description
      abstract Marshaller JAXBContext.createMarshaller()
      Create a Marshaller object that can be used to convert a java content tree into XML data.

    • Uses of Marshaller in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement Marshaller
      Modifier and Type Class and Description
      class  AbstractMarshallerImpl
      Partial default Marshaller implementation.

    • Uses of Marshaller in javax.xml.bind.util

      Constructors in javax.xml.bind.util with parameters of type Marshaller
      Constructor and Description
      JAXBSource(Marshaller marshaller, Object contentObject)
      Creates a new Source for the given content object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.NotIdentifiableEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.NotIdentifiableEvent

  • Packages that use NotIdentifiableEvent
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of NotIdentifiableEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement NotIdentifiableEvent
      Modifier and Type Class and Description
      class  NotIdentifiableEventImpl
      Default implementation of the NotIdentifiableEvent interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.ParseConversionEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.ParseConversionEvent

  • Packages that use ParseConversionEvent
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of ParseConversionEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ParseConversionEvent
      Modifier and Type Class and Description
      class  ParseConversionEventImpl
      Default implementation of the ParseConversionEvent interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.PrintConversionEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.PrintConversionEvent

  • Packages that use PrintConversionEvent
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of PrintConversionEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement PrintConversionEvent
      Modifier and Type Class and Description
      class  PrintConversionEventImpl
      Default implementation of the PrintConversionEvent interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.Unmarshaller (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.Unmarshaller

  • Packages that use Unmarshaller
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of Unmarshaller in javax.xml.bind

      Methods in javax.xml.bind that return Unmarshaller
      Modifier and Type Method and Description
      abstract Unmarshaller JAXBContext.createUnmarshaller()
      Create an Unmarshaller object that can be used to convert XML data into a java content tree.

    • Uses of Unmarshaller in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement Unmarshaller
      Modifier and Type Class and Description
      class  AbstractUnmarshallerImpl
      Partial default Unmarshaller implementation.

    • Uses of Unmarshaller in javax.xml.bind.util

      Constructors in javax.xml.bind.util with parameters of type Unmarshaller
      Constructor and Description
      JAXBResult(Unmarshaller _unmarshaller)
      Creates a new instance that uses the specified Unmarshaller to unmarshal an object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.UnmarshallerHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.UnmarshallerHandler

  • Packages that use UnmarshallerHandler
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of UnmarshallerHandler in javax.xml.bind

      Methods in javax.xml.bind that return UnmarshallerHandler
      Modifier and Type Method and Description
      UnmarshallerHandler Unmarshaller.getUnmarshallerHandler()
      Get an unmarshaller handler object that can be used as a component in an XML pipeline.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.ValidationEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.ValidationEvent

  • Packages that use ValidationEvent
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of ValidationEvent in javax.xml.bind

      Subinterfaces of ValidationEvent in javax.xml.bind
      Modifier and Type Interface and Description
      interface  NotIdentifiableEvent
      This event indicates that a problem was encountered resolving an ID/IDREF.
      interface  ParseConversionEvent
      This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
      interface  PrintConversionEvent
      This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
      Methods in javax.xml.bind with parameters of type ValidationEvent
      Modifier and Type Method and Description
      boolean ValidationEventHandler.handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.

    • Uses of ValidationEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ValidationEvent
      Modifier and Type Class and Description
      class  NotIdentifiableEventImpl
      Default implementation of the NotIdentifiableEvent interface.
      class  ParseConversionEventImpl
      Default implementation of the ParseConversionEvent interface.
      class  PrintConversionEventImpl
      Default implementation of the PrintConversionEvent interface.
      class  ValidationEventImpl
      Default implementation of the ValidationEvent interface.
      Methods in javax.xml.bind.helpers with parameters of type ValidationEvent
      Modifier and Type | Method and Description
      boolean | DefaultValidationEventHandler.handleEvent(ValidationEvent event)

    • Uses of ValidationEvent in javax.xml.bind.util

      Methods in javax.xml.bind.util that return ValidationEvent
      Modifier and Type Method and Description
      ValidationEvent[] ValidationEventCollector.getEvents()
      Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
      Methods in javax.xml.bind.util with parameters of type ValidationEvent
      Modifier and Type | Method and Description
      boolean | ValidationEventCollector.handleEvent(ValidationEvent event)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.ValidationEventHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.ValidationEventHandler

  • Packages that use ValidationEventHandler
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of ValidationEventHandler in javax.xml.bind

      Methods in javax.xml.bind that return ValidationEventHandler
      Modifier and Type Method and Description
      ValidationEventHandler Validator.getEventHandler()
      Deprecated.
      since JAXB2.0
      ValidationEventHandler Unmarshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      ValidationEventHandler Marshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      abstract ValidationEventHandler Binder.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Methods in javax.xml.bind with parameters of type ValidationEventHandler
      Modifier and Type Method and Description
      void Validator.setEventHandler(ValidationEventHandler handler)
      Deprecated.
      since JAXB2.0
      void Unmarshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void Marshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      abstract void Binder.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.

    • Uses of ValidationEventHandler in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation with parameters of type ValidationEventHandler
      Modifier and Type | Method and Description
      DOMResult | W3CDomHandler.createUnmarshaller(ValidationEventHandler errorHandler)
      ResultT DomHandler.createUnmarshaller(ValidationEventHandler errorHandler)
      When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
      Source DomHandler.marshal(ElementT n, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.
      Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

    • Uses of ValidationEventHandler in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ValidationEventHandler
      Modifier and Type Class and Description
      class  DefaultValidationEventHandler
      JAXB 1.0 only default validation event handler.
      Methods in javax.xml.bind.helpers that return ValidationEventHandler
      Modifier and Type | Method and Description
      ValidationEventHandler AbstractUnmarshallerImpl.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      ValidationEventHandler | AbstractMarshallerImpl.getEventHandler()
      Methods in javax.xml.bind.helpers with parameters of type ValidationEventHandler
      Modifier and Type | Method and Description
      void AbstractUnmarshallerImpl.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void | AbstractMarshallerImpl.setEventHandler(ValidationEventHandler handler)

    • Uses of ValidationEventHandler in javax.xml.bind.util

      Classes in javax.xml.bind.util that implement ValidationEventHandler
      Modifier and Type Class and Description
      class  ValidationEventCollector
      ValidationEventHandler implementation that collects all events.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.ValidationEventLocator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.ValidationEventLocator

  • Packages that use ValidationEventLocator
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of ValidationEventLocator in javax.xml.bind

      Methods in javax.xml.bind that return ValidationEventLocator
      Modifier and Type Method and Description
      ValidationEventLocator ValidationEvent.getLocator()
      Retrieve the locator for this warning/error.

    • Uses of ValidationEventLocator in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ValidationEventLocator
      Modifier and Type Class and Description
      class  ValidationEventLocatorImpl
      Default implementation of the ValidationEventLocator interface.
      Methods in javax.xml.bind.helpers that return ValidationEventLocator
      Modifier and Type | Method and Description
      ValidationEventLocator | ValidationEventImpl.getLocator()
      Methods in javax.xml.bind.helpers with parameters of type ValidationEventLocator
      Modifier and Type Method and Description
      void ValidationEventImpl.setLocator(ValidationEventLocator _locator)
      Set the locator object for this event.
      Constructors in javax.xml.bind.helpers with parameters of type ValidationEventLocator
      Constructor and Description
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new NotIdentifiableEventImpl.
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new NotIdentifiableEventImpl.
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ParseConversionEventImpl.
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ParseConversionEventImpl.
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new PrintConversionEventImpl.
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new PrintConversionEventImpl.
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ValidationEventImpl.
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ValidationEventImpl.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.bind.Validator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.Validator

  • Packages that use Validator
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of Validator in javax.xml.bind

      Methods in javax.xml.bind that return Validator
      Modifier and Type Method and Description
      abstract Validator JAXBContext.createValidator()
      Deprecated.
      since JAXB2.0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AbstractMarshallerImpl (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class AbstractMarshallerImpl

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractMarshallerImpl
  • All Implemented Interfaces:
    Marshaller

    public abstract class AbstractMarshallerImpl
extends Object
implements Marshaller
    Partial default Marshaller implementation.

    This class provides a partial default implementation for the Marshaller interface.

    The only methods that a JAXB Provider has to implement are
marshal(Object, javax.xml.transform.Result),
marshal(Object, javax.xml.stream.XMLStreamWriter), and
marshal(Object, javax.xml.stream.XMLEventWriter).

    Since:
    JAXB1.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    See Also:
    Marshaller

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.xml.bind.Marshaller

        Marshaller.Listener

    • Field Summary

      • Fields inherited from interface javax.xml.bind.Marshaller

        JAXB_ENCODING, JAXB_FORMATTED_OUTPUT, JAXB_FRAGMENT, JAXB_NO_NAMESPACE_SCHEMA_LOCATION, JAXB_SCHEMA_LOCATION

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractMarshallerImpl()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <A extends XmlAdapter>
      A             		getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      AttachmentMarshaller getAttachmentMarshaller()
      protected String getEncoding()
      Convenience method for getting the current output encoding.
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      protected String getJavaEncoding(String encoding)
      Gets the corresponding Java encoding name from an IANA name.
      Marshaller.Listener getListener()
      Return Marshaller.Listener registered with this Marshaller.
      Node getNode(Object obj)
      By default, the getNode method is unsupported and throw an UnsupportedOperationException.
      protected String getNoNSSchemaLocation()
      Convenience method for getting the current noNamespaceSchemaLocation.
      Object getProperty(String name)
      Default implementation of the getProperty method handles the four defined properties in Marshaller.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
      protected String getSchemaLocation()
      Convenience method for getting the current schemaLocation.
      protected boolean isFormattedOutput()
      Convenience method for getting the formatted output flag.
      protected boolean isFragment()
      Convenience method for getting the fragment flag.
      void marshal(Object obj, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.
      void marshal(Object jaxbElement, File output)
      Marshal the content tree rooted at jaxbElement into a file.
      void marshal(Object obj, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      void marshal(Object obj, OutputStream os)
      Marshal the content tree rooted at jaxbElement into an output stream.
      void marshal(Object obj, Writer w)
      Marshal the content tree rooted at jaxbElement into a Writer.
      void marshal(Object obj, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
      void marshal(Object obj, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
      <A extends XmlAdapter>
      void             		setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAttachmentMarshaller(AttachmentMarshaller am)
      Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.
      protected void setEncoding(String encoding)
      Convenience method for setting the output encoding.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      protected void setFormattedOutput(boolean v)
      Convenience method for setting the formatted output flag.
      protected void setFragment(boolean v)
      Convenience method for setting the fragment flag.
      void setListener(Marshaller.Listener listener)
      Register marshal event callback Marshaller.Listener with this Marshaller.
      protected void setNoNSSchemaLocation(String location)
      Convenience method for setting the noNamespaceSchemaLocation.
      void setProperty(String name, Object value)
      Default implementation of the setProperty method handles the four defined properties in Marshaller.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.
      protected void setSchemaLocation(String location)
      Convenience method for setting the schemaLocation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.xml.bind.Marshaller

        marshal

    • Constructor Detail

      • AbstractMarshallerImpl

        public AbstractMarshallerImpl()

    • Method Detail

      • marshal

        public final void marshal(Object obj,
           OutputStream os)
                   throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into an output stream.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The root of content tree to be marshalled.
        os - XML will be added to this stream.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public void marshal(Object jaxbElement,
           File output)
             throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into a file.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        output - File to be written. If this file already exists, it will be overwritten.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public final void marshal(Object obj,
           Writer w)
                   throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into a Writer.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The root of content tree to be marshalled.
        w - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public final void marshal(Object obj,
           ContentHandler handler)
                   throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into SAX2 events.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The root of content tree to be marshalled.
        handler - XML will be sent to this handler as SAX2 events.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public final void marshal(Object obj,
           Node node)
                   throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into a DOM tree.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The content tree to be marshalled.
        node - DOM nodes will be added as children of this node. This parameter must be a Node that accepts children (Document, DocumentFragment, or Element)
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal jaxbElement (or any object reachable from jaxbElement). See Marshalling a JAXB element.

      • getNode

        public Node getNode(Object obj)
             throws JAXBException
        By default, the getNode method is unsupported and throw an UnsupportedOperationException. Implementations that choose to support this method must override this method.
        Specified by:
        getNode in interface Marshaller
        Parameters:
        obj - - JAXB Java representation of XML content
        Returns:
        the DOM tree view of the contentTree
        Throws:
        JAXBException - If any unexpected problem occurs

      • getEncoding

        protected String getEncoding()
        Convenience method for getting the current output encoding.
        Returns:
        the current encoding or "UTF-8" if it hasn't been set.

      • setEncoding

        protected void setEncoding(String encoding)
        Convenience method for setting the output encoding.
        Parameters:
        encoding - a valid encoding as specified in the Marshaller class documentation

      • getSchemaLocation

        protected String getSchemaLocation()
        Convenience method for getting the current schemaLocation.
        Returns:
        the current schemaLocation or null if it hasn't been set

      • setSchemaLocation

        protected void setSchemaLocation(String location)
        Convenience method for setting the schemaLocation.
        Parameters:
        location - the schemaLocation value

      • getNoNSSchemaLocation

        protected String getNoNSSchemaLocation()
        Convenience method for getting the current noNamespaceSchemaLocation.
        Returns:
        the current noNamespaceSchemaLocation or null if it hasn't been set

      • setNoNSSchemaLocation

        protected void setNoNSSchemaLocation(String location)
        Convenience method for setting the noNamespaceSchemaLocation.
        Parameters:
        location - the noNamespaceSchemaLocation value

      • isFormattedOutput

        protected boolean isFormattedOutput()
        Convenience method for getting the formatted output flag.
        Returns:
        the current value of the formatted output flag or false if it hasn't been set.

      • setFormattedOutput

        protected void setFormattedOutput(boolean v)
        Convenience method for setting the formatted output flag.
        Parameters:
        v - value of the formatted output flag.

      • isFragment

        protected boolean isFragment()
        Convenience method for getting the fragment flag.
        Returns:
        the current value of the fragment flag or false if it hasn't been set.

      • setFragment

        protected void setFragment(boolean v)
        Convenience method for setting the fragment flag.
        Parameters:
        v - value of the fragment flag.

      • getJavaEncoding

        protected String getJavaEncoding(String encoding)
                          throws UnsupportedEncodingException
        Gets the corresponding Java encoding name from an IANA name. This method is a helper method for the derived class to convert encoding names.
        Throws:
        UnsupportedEncodingException - If this implementation couldn't find the Java encoding name.

      • setProperty

        public void setProperty(String name,
               Object value)
                 throws PropertyException
        Default implementation of the setProperty method handles the four defined properties in Marshaller. If a provider needs to handle additional properties, it should override this method in a derived class.
        Specified by:
        setProperty in interface Marshaller
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value

      • getProperty

        public Object getProperty(String name)
                   throws PropertyException
        Default implementation of the getProperty method handles the four defined properties in Marshaller. If a provider needs to support additional provider specific properties, it should override this method in a derived class.
        Specified by:
        getProperty in interface Marshaller
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name

      • getEventHandler

        public ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Description copied from interface: Marshaller
        Return the current event handler or the default event handler if one hasn't been set.
        Specified by:
        getEventHandler in interface Marshaller
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler
        See Also:
        Marshaller.getEventHandler()

      • setEventHandler

        public void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Description copied from interface: Marshaller
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the marshal API's. If the client application does not register a validation event handler before invoking one of the marshal methods, then validation events will be handled by the default event handler which will terminate the marshal operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Marshaller to revert back to the default default event handler.

        Specified by:
        setEventHandler in interface Marshaller
        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler
        See Also:
        Marshaller.setEventHandler(ValidationEventHandler)

      • marshal

        public void marshal(Object obj,
           XMLEventWriter writer)
             throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The content tree rooted at jaxbElement to be marshalled.
        writer - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public void marshal(Object obj,
           XMLStreamWriter writer)
             throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The content tree to be marshalled.
        writer - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • setSchema

        public void setSchema(Schema schema)
        Description copied from interface: Marshaller
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against. Passing null into this method will disable validation.

        This method allows the caller to validate the marshalled XML as it's marshalled.

        Initially this property is set to null.

        Specified by:
        setSchema in interface Marshaller
        Parameters:
        schema - Schema object to validate marshal operations against or null to disable validation

      • getSchema

        public Schema getSchema()
        Description copied from interface: Marshaller
        Get the JAXP 1.3 Schema object being used to perform marshal-time validation. If there is no Schema set on the marshaller, then this method will return null indicating that marshal-time validation will not be performed.
        Specified by:
        getSchema in interface Marshaller
        Returns:
        the Schema object being used to perform marshal-time validation or null if not present.

      • setAdapter

        public void setAdapter(XmlAdapter adapter)
        Description copied from interface: Marshaller
        Associates a configured instance of XmlAdapter with this marshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        Specified by:
        setAdapter in interface Marshaller
        See Also:
        Marshaller.setAdapter(Class,XmlAdapter)

      • setAdapter

        public <A extends XmlAdapter> void setAdapter(Class<A> type,
                                     A adapter)
        Description copied from interface: Marshaller
        Associates a configured instance of XmlAdapter with this marshaller.

        Every marshaller internally maintains a Map<Class,XmlAdapter>, which it uses for marshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, a marshaller will create one by invoking its default constructor.

        Specified by:
        setAdapter in interface Marshaller
        Parameters:
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.

      • getAdapter

        public <A extends XmlAdapter> A getAdapter(Class<A> type)
        Description copied from interface: Marshaller
        Gets the adapter associated with the specified type. This is the reverse operation of the Marshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        Specified by:
        getAdapter in interface Marshaller

      • setAttachmentMarshaller

        public void setAttachmentMarshaller(AttachmentMarshaller am)
        Description copied from interface: Marshaller

        Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment. The attachment is referenced from the XML document content model by content-id URIs(cid) references stored within the xml document.

        Specified by:
        setAttachmentMarshaller in interface Marshaller

      • getAttachmentMarshaller

        public AttachmentMarshaller getAttachmentMarshaller()
        Specified by:
        getAttachmentMarshaller in interface Marshaller

      • setListener

        public void setListener(Marshaller.Listener listener)
        Description copied from interface: Marshaller

        Register marshal event callback Marshaller.Listener with this Marshaller.

        There is only one Listener per Marshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        Specified by:
        setListener in interface Marshaller
        Parameters:
        listener - an instance of a class that implements Marshaller.Listener

      • getListener

        public Marshaller.Listener getListener()
        Description copied from interface: Marshaller

        Return Marshaller.Listener registered with this Marshaller.

        Specified by:
        getListener in interface Marshaller
        Returns:
        registered Marshaller.Listener or null if no Listener is registered with this Marshaller.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AbstractUnmarshallerImpl (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class AbstractUnmarshallerImpl

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl
  • All Implemented Interfaces:
    Unmarshaller

    public abstract class AbstractUnmarshallerImpl
extends Object
implements Unmarshaller
    Partial default Unmarshaller implementation.

    This class provides a partial default implementation for the Unmarshallerinterface.

    A JAXB Provider has to implement five methods (getUnmarshallerHandler, unmarshal(Node), unmarshal(XMLReader,InputSource), unmarshal(XMLStreamReader), and unmarshal(XMLEventReader).

    Since:
    JAXB1.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    See Also:
    Unmarshaller

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.xml.bind.Unmarshaller

        Unmarshaller.Listener

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean validating
      whether or not the unmarshaller will validate

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractUnmarshallerImpl()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected UnmarshalException createUnmarshalException(SAXException e)
      Creates an UnmarshalException from a SAXException.
      <A extends XmlAdapter>
      A             		getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      AttachmentUnmarshaller getAttachmentUnmarshaller()
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Unmarshaller.Listener getListener()
      Return Unmarshaller.Listener registered with this Unmarshaller.
      Object getProperty(String name)
      Default implementation of the getProperty method always throws PropertyException since there are no required properties.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
      protected XMLReader getXMLReader()
      Obtains a configured XMLReader.
      boolean isValidating()
      Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.
      <A extends XmlAdapter>
      void             		setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
      Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void setListener(Unmarshaller.Listener listener)
      Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.
      void setProperty(String name, Object value)
      Default implementation of the setProperty method always throws PropertyException since there are no required properties.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.
      void setValidating(boolean validating)
      Specifies whether or not the Unmarshaller should validate during unmarshal operations.
      Object unmarshal(File f)
      Unmarshal XML data from the specified file and return the resulting content tree.
      Object unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
      Object unmarshal(InputStream is)
      Unmarshal XML data from the specified InputStream and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Node node, Class<T> expectedType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      Object unmarshal(Reader reader)
      Unmarshal XML data from the specified Reader and return the resulting content tree.
      Object unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Source source, Class<T> expectedType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      Object unmarshal(URL url)
      Unmarshal XML data from the specified URL and return the resulting content tree.
      Object unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLEventReader reader, Class<T> expectedType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      protected abstract Object unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.
      Object unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLStreamReader reader, Class<T> expectedType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.xml.bind.Unmarshaller

        getUnmarshallerHandler, unmarshal

    • Field Detail

      • validating

        protected boolean validating
        whether or not the unmarshaller will validate

    • Constructor Detail

      • AbstractUnmarshallerImpl

        public AbstractUnmarshallerImpl()

    • Method Detail

      • getXMLReader

        protected XMLReader getXMLReader()
                          throws JAXBException
        Obtains a configured XMLReader. This method is used when the client-specified SAXSource object doesn't have XMLReader. Unmarshaller is not re-entrant, so we will only use one instance of XMLReader.
        Throws:
        JAXBException

      • unmarshal

        public Object unmarshal(Source source)
                 throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified XML Source and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        SAX 2.0 Parser Pluggability

        A client application can choose not to use the default parser mechanism supplied with their JAXB provider. Any SAX 2.0 compliant parser can be substituted for the JAXB provider's default mechanism. To do so, the client application must properly configure a SAXSource containing an XMLReader implemented by the SAX 2.0 parser provider. If the XMLReader has an org.xml.sax.ErrorHandler registered on it, it will be replaced by the JAXB Provider so that validation errors can be reported via the ValidationEventHandler mechanism of JAXB. If the SAXSource does not contain an XMLReader, then the JAXB provider's default parser mechanism will be used.

        This parser replacement mechanism can also be used to replace the JAXB provider's unmarshal-time validation engine. The client application must properly configure their SAX 2.0 compliant parser to perform validation (as shown in the example above). Any SAXParserExceptions encountered by the parser during the unmarshal operation will be processed by the JAXB provider and converted into JAXB ValidationEvent objects which will be reported back to the client via the ValidationEventHandler registered with the Unmarshaller. Note: specifying a substitute validating SAX 2.0 parser for unmarshalling does not necessarily replace the validation engine used by the JAXB provider for performing on-demand validation.

        The only way for a client application to specify an alternate parser mechanism to be used during unmarshal is via the unmarshal(SAXSource) API. All other forms of the unmarshal method (File, URL, Node, etc) will use the JAXB provider's default parser and validator mechanisms.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        See Also:
        Unmarshaller.unmarshal(javax.xml.transform.Source, Class)

      • unmarshal

        protected abstract Object unmarshal(XMLReader reader,
               InputSource source)
                             throws JAXBException
        Unmarshals an object by using the specified XMLReader and the InputSource. The callee should call the setErrorHandler method of the XMLReader so that errors are passed to the client-specified ValidationEventHandler.
        Throws:
        JAXBException

      • unmarshal

        public final Object unmarshal(InputSource source)
                       throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        source - the input source to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(URL url)
                       throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified URL and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        url - the url to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(File f)
                       throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified file and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        f - the file to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(InputStream is)
                       throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified InputStream and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API.

        Implements Unmarshal Global Root Element.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        is - the InputStream to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(Reader reader)
                       throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified Reader and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API, because a Reader does not provide the system ID.

        Implements Unmarshal Global Root Element.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        reader - the Reader to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • isValidating

        public boolean isValidating()
                     throws JAXBException
        Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.

        Note: I named this method isValidating() to stay in-line with JAXP, as opposed to naming it getValidating().

        Specified by:
        isValidating in interface Unmarshaller
        Returns:
        true if the Unmarshaller is configured to validate during unmarshal operations, false otherwise
        Throws:
        JAXBException - if an error occurs while retrieving the validating flag

      • setEventHandler

        public void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the unmarshal methods. If the client application does not register a validation event handler before invoking the unmarshal methods, then all validation events will be silently ignored and may result in unexpected behaviour.

        Specified by:
        setEventHandler in interface Unmarshaller
        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler

      • setValidating

        public void setValidating(boolean validating)
                   throws JAXBException
        Specifies whether or not the Unmarshaller should validate during unmarshal operations. By default, the Unmarshaller does not validate.

        This method may only be invoked before or after calling one of the unmarshal methods.

        Specified by:
        setValidating in interface Unmarshaller
        Parameters:
        validating - true if the Unmarshaller should validate during unmarshal, false otherwise
        Throws:
        JAXBException - if an error occurred while enabling or disabling validation at unmarshal time

      • getEventHandler

        public ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        Specified by:
        getEventHandler in interface Unmarshaller
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler

      • createUnmarshalException

        protected UnmarshalException createUnmarshalException(SAXException e)
        Creates an UnmarshalException from a SAXException. This is an utility method provided for the derived classes.

        When a provider-implemented ContentHandler wants to throw a JAXBException, it needs to wrap the exception by a SAXException. If the unmarshaller implementation blindly wrap SAXException by JAXBException, such an exception will be a JAXBException wrapped by a SAXException wrapped by another JAXBException. This is silly.

        This method checks the nested exception of SAXException and reduce those excessive wrapping.

        Returns:
        the resulting UnmarshalException

      • setProperty

        public void setProperty(String name,
               Object value)
                 throws PropertyException
        Default implementation of the setProperty method always throws PropertyException since there are no required properties. If a provider needs to handle additional properties, it should override this method in a derived class.
        Specified by:
        setProperty in interface Unmarshaller
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value

      • getProperty

        public Object getProperty(String name)
                   throws PropertyException
        Default implementation of the getProperty method always throws PropertyException since there are no required properties. If a provider needs to handle additional properties, it should override this method in a derived class.
        Specified by:
        getProperty in interface Unmarshaller
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name

      • unmarshal

        public Object unmarshal(XMLEventReader reader)
                 throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        This method is an Unmarshal Global Root method.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        reader - The parser to be read.
        Returns:
        the newly created root object of the java content tree.
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        See Also:
        Unmarshaller.unmarshal(javax.xml.stream.XMLEventReader, Class)

      • unmarshal

        public Object unmarshal(XMLStreamReader reader)
                 throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        reader - The parser to be read.
        Returns:
        the newly created root object of the java content tree.
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        See Also:
        Unmarshaller.unmarshal(javax.xml.stream.XMLStreamReader, Class)

      • unmarshal

        public <T> JAXBElement<T> unmarshal(Node node,
                           Class<T> expectedType)
                         throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
        expectedType - appropriate JAXB mapped class to hold node's XML data.
        Returns:
        JAXB Element representation of node
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public <T> JAXBElement<T> unmarshal(Source source,
                           Class<T> expectedType)
                         throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        See SAX 2.0 Parser Pluggability

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        expectedType - appropriate JAXB mapped class to hold source's xml root element
        Returns:
        Java content rooted by JAXB Element
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public <T> JAXBElement<T> unmarshal(XMLStreamReader reader,
                           Class<T> expectedType)
                         throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        reader - The parser to be read.
        expectedType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        Returns:
        content tree rooted by JAXB Element representation
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public <T> JAXBElement<T> unmarshal(XMLEventReader reader,
                           Class<T> expectedType)
                         throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        reader - The parser to be read.
        expectedType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        Returns:
        content tree rooted by JAXB Element representation
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • setSchema

        public void setSchema(Schema schema)
        Description copied from interface: Unmarshaller
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against. Passing null into this method will disable validation.

        This method replaces the deprecated setValidating(boolean) API.

        Initially this property is set to null.

        Specified by:
        setSchema in interface Unmarshaller
        Parameters:
        schema - Schema object to validate unmarshal operations against or null to disable validation

      • getSchema

        public Schema getSchema()
        Description copied from interface: Unmarshaller
        Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation. If there is no Schema set on the unmarshaller, then this method will return null indicating that unmarshal-time validation will not be performed.

        This method provides replacement functionality for the deprecated Unmarshaller.isValidating() API as well as access to the Schema object. To determine if the Unmarshaller has validation enabled, simply test the return type for null:

        boolean isValidating = u.getSchema()!=null;

        Specified by:
        getSchema in interface Unmarshaller
        Returns:
        the Schema object being used to perform unmarshal-time validation or null if not present

      • setAdapter

        public void setAdapter(XmlAdapter adapter)
        Description copied from interface: Unmarshaller
        Associates a configured instance of XmlAdapter with this unmarshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        Specified by:
        setAdapter in interface Unmarshaller
        See Also:
        Unmarshaller.setAdapter(Class,XmlAdapter)

      • setAdapter

        public <A extends XmlAdapter> void setAdapter(Class<A> type,
                                     A adapter)
        Description copied from interface: Unmarshaller
        Associates a configured instance of XmlAdapter with this unmarshaller.

        Every unmarshaller internally maintains a Map<Class,XmlAdapter>, which it uses for unmarshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, an unmarshaller will create one by invoking its default constructor.

        Specified by:
        setAdapter in interface Unmarshaller
        Parameters:
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.

      • getAdapter

        public <A extends XmlAdapter> A getAdapter(Class<A> type)
        Description copied from interface: Unmarshaller
        Gets the adapter associated with the specified type. This is the reverse operation of the Unmarshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        Specified by:
        getAdapter in interface Unmarshaller

      • setAttachmentUnmarshaller

        public void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
        Description copied from interface: Unmarshaller

        Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

        Unmarshal time validation, enabled via Unmarshaller.setSchema(Schema), must be supported even when unmarshaller is performing XOP processing.

        Specified by:
        setAttachmentUnmarshaller in interface Unmarshaller

      • getAttachmentUnmarshaller

        public AttachmentUnmarshaller getAttachmentUnmarshaller()
        Specified by:
        getAttachmentUnmarshaller in interface Unmarshaller

      • setListener

        public void setListener(Unmarshaller.Listener listener)
        Description copied from interface: Unmarshaller

        Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

        There is only one Listener per Unmarshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        Specified by:
        setListener in interface Unmarshaller
        Parameters:
        listener - provides unmarshal event callbacks for this Unmarshaller

      • getListener

        public Unmarshaller.Listener getListener()
        Description copied from interface: Unmarshaller

        Return Unmarshaller.Listener registered with this Unmarshaller.

        Specified by:
        getListener in interface Unmarshaller
        Returns:
        registered Unmarshaller.Listener or null if no Listener is registered with this Unmarshaller.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DefaultValidationEventHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class DefaultValidationEventHandler

  • java.lang.Object
    • javax.xml.bind.helpers.DefaultValidationEventHandler
  • All Implemented Interfaces:
    ValidationEventHandler

    public class DefaultValidationEventHandler
extends Object
implements ValidationEventHandler

    JAXB 1.0 only default validation event handler. This is the default handler for all objects created from a JAXBContext that is managing schema-derived code generated by a JAXB 1.0 binding compiler.

    This handler causes the unmarshal and validate operations to fail on the first error or fatal error.

    This handler is not the default handler for JAXB mapped classes following JAXB 2.0 or later versions. Default validation event handling has changed and is specified in Unmarshaller and Marshaller.

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    See Also:
    Unmarshaller, Validator, ValidationEventHandler

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultValidationEventHandler()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DefaultValidationEventHandler

        public DefaultValidationEventHandler()

    • Method Detail

      • handleEvent

        public boolean handleEvent(ValidationEvent event)
        Description copied from interface: ValidationEventHandler
        Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

        If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

        Specified by:
        handleEvent in interface ValidationEventHandler
        Parameters:
        event - the encapsulated validation event information. It is a provider error if this parameter is null.
        Returns:
        true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.bind.helpers (Java(TM) EE 7 Specification APIs)

javax.xml.bind.helpers

Classes

  • AbstractMarshallerImpl
  • AbstractUnmarshallerImpl
  • DefaultValidationEventHandler
  • NotIdentifiableEventImpl
  • ParseConversionEventImpl
  • PrintConversionEventImpl
  • ValidationEventImpl
  • ValidationEventLocatorImpl


javax.xml.bind.helpers (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind.helpers

JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

See: Description

  • Class Summary
    Class Description
    AbstractMarshallerImpl
    Partial default Marshaller implementation.
    AbstractUnmarshallerImpl
    Partial default Unmarshaller implementation.
    DefaultValidationEventHandler
    JAXB 1.0 only default validation event handler.
    NotIdentifiableEventImpl
    Default implementation of the NotIdentifiableEvent interface.
    ParseConversionEventImpl
    Default implementation of the ParseConversionEvent interface.
    PrintConversionEventImpl
    Default implementation of the PrintConversionEvent interface.
    ValidationEventImpl
    Default implementation of the ValidationEvent interface.
    ValidationEventLocatorImpl
    Default implementation of the ValidationEventLocator interface.

Package javax.xml.bind.helpers Description

JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

JAXB Providers can extend these classes and implement the abstract methods.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.bind.helpers Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind.helpers

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractMarshallerImpl (implements javax.xml.bind.Marshaller)
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl (implements javax.xml.bind.Unmarshaller)
    • javax.xml.bind.helpers.DefaultValidationEventHandler (implements javax.xml.bind.ValidationEventHandler)
    • javax.xml.bind.helpers.ValidationEventImpl (implements javax.xml.bind.ValidationEvent)
      • javax.xml.bind.helpers.NotIdentifiableEventImpl (implements javax.xml.bind.NotIdentifiableEvent)
      • javax.xml.bind.helpers.ParseConversionEventImpl (implements javax.xml.bind.ParseConversionEvent)
      • javax.xml.bind.helpers.PrintConversionEventImpl (implements javax.xml.bind.PrintConversionEvent)
    • javax.xml.bind.helpers.ValidationEventLocatorImpl (implements javax.xml.bind.ValidationEventLocator)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


NotIdentifiableEventImpl (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class NotIdentifiableEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
      • javax.xml.bind.helpers.NotIdentifiableEventImpl
  • All Implemented Interfaces:
    NotIdentifiableEvent, ValidationEvent

    public class NotIdentifiableEventImpl
extends ValidationEventImpl
implements NotIdentifiableEvent
    Default implementation of the NotIdentifiableEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    See Also:
    NotIdentifiableEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new NotIdentifiableEventImpl.
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new NotIdentifiableEventImpl.

    • Method Summary

      • Methods inherited from class javax.xml.bind.helpers.ValidationEventImpl

        getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity

    • Constructor Detail

      • NotIdentifiableEventImpl

        public NotIdentifiableEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator)
        Create a new NotIdentifiableEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

      • NotIdentifiableEventImpl

        public NotIdentifiableEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator,
                        Throwable _linkedException)
        Create a new NotIdentifiableEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ParseConversionEventImpl (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class ParseConversionEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
      • javax.xml.bind.helpers.ParseConversionEventImpl
  • All Implemented Interfaces:
    ParseConversionEvent, ValidationEvent

    public class ParseConversionEventImpl
extends ValidationEventImpl
implements ParseConversionEvent
    Default implementation of the ParseConversionEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    See Also:
    ParseConversionEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ParseConversionEventImpl.
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ParseConversionEventImpl.

    • Method Summary

      • Methods inherited from class javax.xml.bind.helpers.ValidationEventImpl

        getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity

    • Constructor Detail

      • ParseConversionEventImpl

        public ParseConversionEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator)
        Create a new ParseConversionEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

      • ParseConversionEventImpl

        public ParseConversionEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator,
                        Throwable _linkedException)
        Create a new ParseConversionEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PrintConversionEventImpl (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class PrintConversionEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
      • javax.xml.bind.helpers.PrintConversionEventImpl
  • All Implemented Interfaces:
    PrintConversionEvent, ValidationEvent

    public class PrintConversionEventImpl
extends ValidationEventImpl
implements PrintConversionEvent
    Default implementation of the PrintConversionEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    Since:
    JAXB1.0
    Author:
    • Ryan Shoemaker, Sun Microsystems, Inc.
    See Also:
    PrintConversionEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new PrintConversionEventImpl.
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new PrintConversionEventImpl.

    • Method Summary

      • Methods inherited from class javax.xml.bind.helpers.ValidationEventImpl

        getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity

    • Constructor Detail

      • PrintConversionEventImpl

        public PrintConversionEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator)
        Create a new PrintConversionEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

      • PrintConversionEventImpl

        public PrintConversionEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator,
                        Throwable _linkedException)
        Create a new PrintConversionEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.bind.helpers (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind.helpers

  • Packages that use javax.xml.bind.helpers
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
  • Classes in javax.xml.bind.helpers used by javax.xml.bind.helpers
    Class and Description
    ValidationEventImpl
    Default implementation of the ValidationEvent interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidationEventImpl (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class ValidationEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
  • All Implemented Interfaces:
    ValidationEvent
    Direct Known Subclasses:
    NotIdentifiableEventImpl, ParseConversionEventImpl, PrintConversionEventImpl

    public class ValidationEventImpl
extends Object
implements ValidationEvent
    Default implementation of the ValidationEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    Since:
    JAXB1.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    See Also:
    Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ValidationEventImpl.
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ValidationEventImpl.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getLinkedException()
      Retrieve the linked exception for this warning/error.
      ValidationEventLocator getLocator()
      Retrieve the locator for this warning/error.
      String getMessage()
      Retrieve the text message for this warning/error.
      int getSeverity()
      Retrieve the severity code for this warning/error.
      void setLinkedException(Throwable _linkedException)
      Set the linked exception field of this event.
      void setLocator(ValidationEventLocator _locator)
      Set the locator object for this event.
      void setMessage(String _message)
      Set the message field of this event.
      void setSeverity(int _severity)
      Set the severity field of this event.
      String toString()
      Returns a string representation of this object in a format helpful to debugging.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ValidationEventImpl

        public ValidationEventImpl(int _severity,
                   String _message,
                   ValidationEventLocator _locator)
        Create a new ValidationEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

      • ValidationEventImpl

        public ValidationEventImpl(int _severity,
                   String _message,
                   ValidationEventLocator _locator,
                   Throwable _linkedException)
        Create a new ValidationEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

    • Method Detail

      • getSeverity

        public int getSeverity()
        Description copied from interface: ValidationEvent
        Retrieve the severity code for this warning/error.

        Must be one of ValidationError.WARNING, ValidationError.ERROR, or ValidationError.FATAL_ERROR.

        Specified by:
        getSeverity in interface ValidationEvent
        Returns:
        the severity code for this warning/error

      • setSeverity

        public void setSeverity(int _severity)
        Set the severity field of this event.
        Parameters:
        _severity - Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

      • getMessage

        public String getMessage()
        Description copied from interface: ValidationEvent
        Retrieve the text message for this warning/error.
        Specified by:
        getMessage in interface ValidationEvent
        Returns:
        the text message for this warning/error or null if one wasn't set

      • setMessage

        public void setMessage(String _message)
        Set the message field of this event.
        Parameters:
        _message - String message - may be null.

      • getLinkedException

        public Throwable getLinkedException()
        Description copied from interface: ValidationEvent
        Retrieve the linked exception for this warning/error.
        Specified by:
        getLinkedException in interface ValidationEvent
        Returns:
        the linked exception for this warning/error or null if one wasn't set

      • setLinkedException

        public void setLinkedException(Throwable _linkedException)
        Set the linked exception field of this event.
        Parameters:
        _linkedException - Optional linked exception - may be null.

      • getLocator

        public ValidationEventLocator getLocator()
        Description copied from interface: ValidationEvent
        Retrieve the locator for this warning/error.
        Specified by:
        getLocator in interface ValidationEvent
        Returns:
        the locator that indicates where the warning/error occurred

      • setLocator

        public void setLocator(ValidationEventLocator _locator)
        Set the locator object for this event.
        Parameters:
        _locator - The locator - may be null.

      • toString

        public String toString()
        Returns a string representation of this object in a format helpful to debugging.
        Overrides:
        toString in class Object
        See Also:
        Object.equals(Object)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ValidationEventLocatorImpl (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class ValidationEventLocatorImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventLocatorImpl
  • All Implemented Interfaces:
    ValidationEventLocator

    public class ValidationEventLocatorImpl
extends Object
implements ValidationEventLocator
    Default implementation of the ValidationEventLocator interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEventLocator interface. This class is just provided for a convenience.

    Since:
    JAXB1.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    See Also:
    Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidationEventLocatorImpl()
      Creates an object with all fields unavailable.
      ValidationEventLocatorImpl(Locator loc)
      Constructs an object from an org.xml.sax.Locator.
      ValidationEventLocatorImpl(Node _node)
      Constructs an object that points to a DOM Node.
      ValidationEventLocatorImpl(Object _object)
      Constructs an object that points to a JAXB content object.
      ValidationEventLocatorImpl(SAXParseException e)
      Constructs an object from the location information of a SAXParseException.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      Return the column number if available
      int getLineNumber()
      Return the line number if available
      Node getNode()
      Return a reference to the DOM Node if available
      Object getObject()
      Return a reference to the object in the Java content tree if available
      int getOffset()
      Return the byte offset if available
      URL getURL()
      Return the name of the XML source as a URL if available
      void setColumnNumber(int _columnNumber)
      Set the columnNumber field on this event locator.
      void setLineNumber(int _lineNumber)
      Set the lineNumber field on this event locator.
      void setNode(Node _node)
      Set the Node field on this event locator.
      void setObject(Object _object)
      Set the Object field on this event locator.
      void setOffset(int _offset)
      Set the offset field on this event locator.
      void setURL(URL _url)
      Set the URL field on this event locator.
      String toString()
      Returns a string representation of this object in a format helpful to debugging.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl()
        Creates an object with all fields unavailable.

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(Locator loc)
        Constructs an object from an org.xml.sax.Locator. The object's ColumnNumber, LineNumber, and URL become available from the values returned by the locator's getColumnNumber(), getLineNumber(), and getSystemId() methods respectively. Node, Object, and Offset are not available.
        Parameters:
        loc - the SAX Locator object that will be used to populate this event locator.
        Throws:
        IllegalArgumentException - if the Locator is null

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(SAXParseException e)
        Constructs an object from the location information of a SAXParseException. The object's ColumnNumber, LineNumber, and URL become available from the values returned by the locator's getColumnNumber(), getLineNumber(), and getSystemId() methods respectively. Node, Object, and Offset are not available.
        Parameters:
        e - the SAXParseException object that will be used to populate this event locator.
        Throws:
        IllegalArgumentException - if the SAXParseException is null

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(Node _node)
        Constructs an object that points to a DOM Node. The object's Node becomes available. ColumnNumber, LineNumber, Object, Offset, and URL are not available.
        Parameters:
        _node - the DOM Node object that will be used to populate this event locator.
        Throws:
        IllegalArgumentException - if the Node is null

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(Object _object)
        Constructs an object that points to a JAXB content object. The object's Object becomes available. ColumnNumber, LineNumber, Node, Offset, and URL are not available.
        Parameters:
        _object - the Object that will be used to populate this event locator.
        Throws:
        IllegalArgumentException - if the Object is null

    • Method Detail

      • getURL

        public URL getURL()
        Description copied from interface: ValidationEventLocator
        Return the name of the XML source as a URL if available
        Specified by:
        getURL in interface ValidationEventLocator
        Returns:
        the name of the XML source as a URL or null if unavailable
        See Also:
        ValidationEventLocator.getURL()

      • setURL

        public void setURL(URL _url)
        Set the URL field on this event locator. Null values are allowed.
        Parameters:
        _url - the url

      • getOffset

        public int getOffset()
        Description copied from interface: ValidationEventLocator
        Return the byte offset if available
        Specified by:
        getOffset in interface ValidationEventLocator
        Returns:
        the byte offset into the input source or -1 if unavailable
        See Also:
        ValidationEventLocator.getOffset()

      • setOffset

        public void setOffset(int _offset)
        Set the offset field on this event locator.
        Parameters:
        _offset - the offset

      • getLineNumber

        public int getLineNumber()
        Description copied from interface: ValidationEventLocator
        Return the line number if available
        Specified by:
        getLineNumber in interface ValidationEventLocator
        Returns:
        the line number or -1 if unavailable
        See Also:
        ValidationEventLocator.getLineNumber()

      • setLineNumber

        public void setLineNumber(int _lineNumber)
        Set the lineNumber field on this event locator.
        Parameters:
        _lineNumber - the line number

      • getColumnNumber

        public int getColumnNumber()
        Description copied from interface: ValidationEventLocator
        Return the column number if available
        Specified by:
        getColumnNumber in interface ValidationEventLocator
        Returns:
        the column number or -1 if unavailable
        See Also:
        ValidationEventLocator.getColumnNumber()

      • setColumnNumber

        public void setColumnNumber(int _columnNumber)
        Set the columnNumber field on this event locator.
        Parameters:
        _columnNumber - the column number

      • getObject

        public Object getObject()
        Description copied from interface: ValidationEventLocator
        Return a reference to the object in the Java content tree if available
        Specified by:
        getObject in interface ValidationEventLocator
        Returns:
        a reference to the object in the Java content tree or null if unavailable
        See Also:
        ValidationEventLocator.getObject()

      • setObject

        public void setObject(Object _object)
        Set the Object field on this event locator. Null values are allowed.
        Parameters:
        _object - the java content object

      • getNode

        public Node getNode()
        Description copied from interface: ValidationEventLocator
        Return a reference to the DOM Node if available
        Specified by:
        getNode in interface ValidationEventLocator
        Returns:
        a reference to the DOM Node or null if unavailable
        See Also:
        ValidationEventLocator.getNode()

      • setNode

        public void setNode(Node _node)
        Set the Node field on this event locator. Null values are allowed.
        Parameters:
        _node - the Node

      • toString

        public String toString()
        Returns a string representation of this object in a format helpful to debugging.
        Overrides:
        toString in class Object
        See Also:
        Object.equals(Object)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.xml.bind.helpers.AbstractMarshallerImpl (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.AbstractMarshallerImpl

No usage of javax.xml.bind.helpers.AbstractMarshallerImpl
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.helpers.AbstractUnmarshallerImpl (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.AbstractUnmarshallerImpl

No usage of javax.xml.bind.helpers.AbstractUnmarshallerImpl
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.helpers.DefaultValidationEventHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.DefaultValidationEventHandler

No usage of javax.xml.bind.helpers.DefaultValidationEventHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.helpers.NotIdentifiableEventImpl (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.NotIdentifiableEventImpl

No usage of javax.xml.bind.helpers.NotIdentifiableEventImpl
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.helpers.ParseConversionEventImpl (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.ParseConversionEventImpl

No usage of javax.xml.bind.helpers.ParseConversionEventImpl
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.helpers.PrintConversionEventImpl (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.PrintConversionEventImpl

No usage of javax.xml.bind.helpers.PrintConversionEventImpl
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.helpers.ValidationEventImpl (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.ValidationEventImpl

  • Packages that use ValidationEventImpl
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of ValidationEventImpl in javax.xml.bind.helpers

      Subclasses of ValidationEventImpl in javax.xml.bind.helpers
      Modifier and Type Class and Description
      class  NotIdentifiableEventImpl
      Default implementation of the NotIdentifiableEvent interface.
      class  ParseConversionEventImpl
      Default implementation of the ParseConversionEvent interface.
      class  PrintConversionEventImpl
      Default implementation of the PrintConversionEvent interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.helpers.ValidationEventLocatorImpl (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.ValidationEventLocatorImpl

No usage of javax.xml.bind.helpers.ValidationEventLocatorImpl
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.xml.bind.util (Java(TM) EE 7 Specification APIs)

javax.xml.bind.util

Classes

  • JAXBResult
  • JAXBSource
  • ValidationEventCollector


javax.xml.bind.util (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind.util

Useful client utility classes.

See: Description

  • Class Summary
    Class Description
    JAXBResult
    JAXP Result implementation that unmarshals a JAXB object.
    JAXBSource
    JAXP Source implementation that marshals a JAXB-generated object.
    ValidationEventCollector
    ValidationEventHandler implementation that collects all events.

Package javax.xml.bind.util Description

Useful client utility classes.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.bind.util Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • javax.xml.bind.util.JAXBResult
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • javax.xml.bind.util.JAXBSource
    • javax.xml.bind.util.ValidationEventCollector (implements javax.xml.bind.ValidationEventHandler)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JAXBResult (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.util

Class JAXBResult

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult
      • javax.xml.bind.util.JAXBResult
  • All Implemented Interfaces:
    Result

    public class JAXBResult
extends SAXResult
    JAXP Result implementation that unmarshals a JAXB object.

    This utility class is useful to combine JAXB with other Java/XML technologies.

    The following example shows how to use JAXB to unmarshal a document resulting from an XSLT transformation.

           JAXBResult result = new JAXBResult(
         JAXBContext.newInstance("org.acme.foo") );

       // set up XSLT transformation
       TransformerFactory tf = TransformerFactory.newInstance();
       Transformer t = tf.newTransformer(new StreamSource("test.xsl"));

       // run transformation
       t.transform(new StreamSource("document.xml"),result);

       // obtain the unmarshalled content tree
       Object o = result.getResult();

    The fact that JAXBResult derives from SAXResult is an implementation detail. Thus in general applications are strongly discouraged from accessing methods defined on SAXResult.

    In particular it shall never attempt to call the setHandler, setLexicalHandler, and setSystemId methods.

    Author:
    Kohsuke Kawaguchi (kohsuke.kawaguchi@sun.com)

    • Field Summary

      • Fields inherited from class javax.xml.transform.sax.SAXResult

        FEATURE

      • Fields inherited from interface javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBResult(JAXBContext context)
      Creates a new instance that uses the specified JAXBContext to unmarshal.
      JAXBResult(Unmarshaller _unmarshaller)
      Creates a new instance that uses the specified Unmarshaller to unmarshal an object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object getResult()
      Gets the unmarshalled object created by the transformation.

      • Methods inherited from class javax.xml.transform.sax.SAXResult

        getHandler, getLexicalHandler, getSystemId, setHandler, setLexicalHandler, setSystemId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JAXBResult

        public JAXBResult(JAXBContext context)
           throws JAXBException
        Creates a new instance that uses the specified JAXBContext to unmarshal.
        Parameters:
        context - The JAXBContext that will be used to create the necessary Unmarshaller. This parameter must not be null.
        Throws:
        JAXBException - if an error is encountered while creating the JAXBResult or if the context parameter is null.

      • JAXBResult

        public JAXBResult(Unmarshaller _unmarshaller)
           throws JAXBException
        Creates a new instance that uses the specified Unmarshaller to unmarshal an object.

        This JAXBResult object will use the specified Unmarshaller instance. It is the caller's responsibility not to use the same Unmarshaller for other purposes while it is being used by this object.

        The primary purpose of this method is to allow the client to configure Unmarshaller. Unless you know what you are doing, it's easier and safer to pass a JAXBContext.

        Parameters:
        _unmarshaller - the unmarshaller. This parameter must not be null.
        Throws:
        JAXBException - if an error is encountered while creating the JAXBResult or the Unmarshaller parameter is null.

    • Method Detail

      • getResult

        public Object getResult()
                 throws JAXBException
        Gets the unmarshalled object created by the transformation.
        Returns:
        Always return a non-null object.
        Throws:
        IllegalStateException - if this method is called before an object is unmarshalled.
        JAXBException - if there is any unmarshalling error. Note that the implementation is allowed to throw SAXException during the parsing when it finds an error.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JAXBSource (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.util

Class JAXBSource

  • java.lang.Object
    • javax.xml.transform.sax.SAXSource
      • javax.xml.bind.util.JAXBSource
  • All Implemented Interfaces:
    Source

    public class JAXBSource
extends SAXSource
    JAXP Source implementation that marshals a JAXB-generated object.

    This utility class is useful to combine JAXB with other Java/XML technologies.

    The following example shows how to use JAXB to marshal a document for transformation by XSLT.

           MyObject o = // get JAXB content tree

       // jaxbContext is a JAXBContext object from which 'o' is created.
       JAXBSource source = new JAXBSource( jaxbContext, o );

       // set up XSLT transformation
       TransformerFactory tf = TransformerFactory.newInstance();
       Transformer t = tf.newTransformer(new StreamSource("test.xsl"));

       // run transformation
       t.transform(source,new StreamResult(System.out));

    The fact that JAXBSource derives from SAXSource is an implementation detail. Thus in general applications are strongly discouraged from accessing methods defined on SAXSource. In particular, the setXMLReader and setInputSource methods shall never be called. The XMLReader object obtained by the getXMLReader method shall be used only for parsing the InputSource object returned by the getInputSource method.

    Similarly the InputSource object obtained by the getInputSource method shall be used only for being parsed by the XMLReader object returned by the getXMLReader.

    Author:
    Kohsuke Kawaguchi (kohsuke.kawaguchi@sun.com)

    • Field Summary

      • Fields inherited from class javax.xml.transform.sax.SAXSource

        FEATURE

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBSource(JAXBContext context, Object contentObject)
      Creates a new Source for the given content object.
      JAXBSource(Marshaller marshaller, Object contentObject)
      Creates a new Source for the given content object.

    • Method Summary

      • Methods inherited from class javax.xml.transform.sax.SAXSource

        getInputSource, getSystemId, getXMLReader, setInputSource, setSystemId, setXMLReader, sourceToInputSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JAXBSource

        public JAXBSource(JAXBContext context,
          Object contentObject)
           throws JAXBException
        Creates a new Source for the given content object.
        Parameters:
        context - JAXBContext that was used to create contentObject. This context is used to create a new instance of marshaller and must not be null.
        contentObject - An instance of a JAXB-generated class, which will be used as a Source (by marshalling it into XML). It must not be null.
        Throws:
        JAXBException - if an error is encountered while creating the JAXBSource or if either of the parameters are null.

      • JAXBSource

        public JAXBSource(Marshaller marshaller,
          Object contentObject)
           throws JAXBException
        Creates a new Source for the given content object.
        Parameters:
        marshaller - A marshaller instance that will be used to marshal contentObject into XML. This must be created from a JAXBContext that was used to build contentObject and must not be null.
        contentObject - An instance of a JAXB-generated class, which will be used as a Source (by marshalling it into XML). It must not be null.
        Throws:
        JAXBException - if an error is encountered while creating the JAXBSource or if either of the parameters are null.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.bind.util (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind.util

No usage of javax.xml.bind.util
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ValidationEventCollector (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.util

Class ValidationEventCollector

  • java.lang.Object
    • javax.xml.bind.util.ValidationEventCollector
  • All Implemented Interfaces:
    ValidationEventHandler

    public class ValidationEventCollector
extends Object
implements ValidationEventHandler
    ValidationEventHandler implementation that collects all events.

    To use this class, create a new instance and pass it to the setEventHandler method of the Validator, Unmarshaller, Marshaller class. After the call to validate or unmarshal completes, call the getEvents method to retrieve all the reported errors and warnings.

    Since:
    JAXB1.0
    Author:
    • Kohsuke Kawaguchi, Sun Microsystems, Inc.
    • Ryan Shoemaker, Sun Microsystems, Inc.
    • Joe Fialli, Sun Microsystems, Inc.
    See Also:
    Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidationEventCollector()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ValidationEvent[] getEvents()
      Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
      boolean handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.
      boolean hasEvents()
      Returns true if this event collector contains at least one ValidationEvent.
      void reset()
      Clear all collected errors and warnings.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ValidationEventCollector

        public ValidationEventCollector()

    • Method Detail

      • getEvents

        public ValidationEvent[] getEvents()
        Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
        Returns:
        a copy of all the collected errors and warnings or an empty array if there weren't any

      • reset

        public void reset()
        Clear all collected errors and warnings.

      • hasEvents

        public boolean hasEvents()
        Returns true if this event collector contains at least one ValidationEvent.
        Returns:
        true if this event collector contains at least one ValidationEvent, false otherwise

      • handleEvent

        public boolean handleEvent(ValidationEvent event)
        Description copied from interface: ValidationEventHandler
        Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

        If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

        Specified by:
        handleEvent in interface ValidationEventHandler
        Parameters:
        event - the encapsulated validation event information. It is a provider error if this parameter is null.
        Returns:
        true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.xml.bind.util.JAXBResult (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.util.JAXBResult

No usage of javax.xml.bind.util.JAXBResult
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.util.JAXBSource (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.util.JAXBSource

No usage of javax.xml.bind.util.JAXBSource
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.bind.util.ValidationEventCollector (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.util.ValidationEventCollector

No usage of javax.xml.bind.util.ValidationEventCollector
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BulkResponse (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface BulkResponse

  • All Superinterfaces:
    JAXRResponse

    public interface BulkResponse
extends JAXRResponse
    Contains the response of a method in the API that performs a bulk operation and returns a bulk response. Partial commits are allowed on a bulk operation.

    In the event of a partial success where only a subset of objects were processed successfully, the getStatus method of the BulkResponse must return JAXRResponse.STATUS_WARNING. In this case, a Collection of JAXRException instances is included in the BulkResponse instance. The JAXRExceptions provide information on each error that prevented some objects in the request to not be processed successfully.

    Author:
    Farrukh S. Najmi
    See Also:
    QueryManager, LifeCycleManager

    • Field Summary

      • Fields inherited from interface javax.xml.registry.JAXRResponse

        STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Collection getCollection()
      Get the Collection of objects returned as a response of a bulk operation.
      Collection getExceptions()
      Get the Collection of RegistryException instances in case of partial commit.
      boolean isPartialResponse()
      Determines whether the response is a partial response due to large result set.

      • Methods inherited from interface javax.xml.registry.JAXRResponse

        getRequestId, getStatus, isAvailable

    • Method Detail

      • getCollection

        Collection getCollection()
                         throws JAXRException
        Get the Collection of objects returned as a response of a bulk operation. Caller thread will block here if result is not yet available.

        Capability Level: 0
        Returns:
        Collection of RegistryObject instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        RegistryObject

      • getExceptions

        Collection getExceptions()
                         throws JAXRException
        Get the Collection of RegistryException instances in case of partial commit. Caller thread will block here if result is not yet available.

        Capability Level: 0
        Returns:
        Collection of RegistryException instances. Return null if result is available and there is no RegistryException.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        RegistryException

      • isPartialResponse

        boolean isPartialResponse()
                          throws JAXRException
        Determines whether the response is a partial response due to large result set.

        Capability Level: 0
        Returns:
        true if the response is partial; false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BusinessLifeCycleManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface BusinessLifeCycleManager

  • All Superinterfaces:
    LifeCycleManager

    public interface BusinessLifeCycleManager
extends LifeCycleManager
    The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API. Note that there is no authentication information provided, because the Connection interface keeps that state and context on behalf of the client.
    Author:
    Farrukh S. Najmi
    See Also:
    LifeCycleManager

    • Field Summary

      • Fields inherited from interface javax.xml.registry.LifeCycleManager

        ASSOCIATION, AUDITABLE_EVENT, CLASSIFICATION, CLASSIFICATION_SCHEME, CONCEPT, EMAIL_ADDRESS, EXTERNAL_IDENTIFIER, EXTERNAL_LINK, EXTRINSIC_OBJECT, INTERNATIONAL_STRING, KEY, LOCALIZED_STRING, ORGANIZATION, PERSON_NAME, POSTAL_ADDRESS, REGISTRY_ENTRY, REGISTRY_PACKAGE, SERVICE, SERVICE_BINDING, SLOT, SPECIFICATION_LINK, TELEPHONE_NUMBER, USER, VERSIONABLE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void confirmAssociation(Association assoc)
      Confirms this Association by the User associated with the caller.
      BulkResponse deleteAssociations(Collection associationKeys)
      Deletes the Associations corresponding to the specified Keys.
      BulkResponse deleteClassificationSchemes(Collection schemeKeys)
      Deletes the ClassificationSchemes corresponding to the specified Keys.
      BulkResponse deleteConcepts(Collection conceptKeys)
      Deletes the Concepts corresponding to the specified Keys.
      BulkResponse deleteOrganizations(Collection organizationKeys)
      Deletes the organizations corresponding to the specified Keys.
      BulkResponse deleteServiceBindings(Collection bindingKeys)
      Deletes the ServiceBindings corresponding to the specified Keys.
      BulkResponse deleteServices(Collection serviceKeys)
      Deletes the services corresponding to the specified Keys.
      BulkResponse saveAssociations(Collection associations, boolean replace)
      Saves the specified Association instances.
      BulkResponse saveClassificationSchemes(Collection schemes)
      Saves the specified ClassificationScheme instances.
      BulkResponse saveConcepts(Collection concepts)
      Saves the specified Concepts.
      BulkResponse saveOrganizations(Collection organizations)
      Saves the specified Organizations.
      BulkResponse saveServiceBindings(Collection bindings)
      Saves the specified ServiceBindings.
      BulkResponse saveServices(Collection services)
      Saves the specified Services.
      void unConfirmAssociation(Association assoc)
      Undoes a previous confirmation of this Association by the User associated with the caller.

      • Methods inherited from interface javax.xml.registry.LifeCycleManager

        createAssociation, createClassification, createClassification, createClassification, createClassificationScheme, createClassificationScheme, createClassificationScheme, createConcept, createConcept, createEmailAddress, createEmailAddress, createExternalIdentifier, createExternalIdentifier, createExternalLink, createExternalLink, createExtrinsicObject, createInternationalString, createInternationalString, createInternationalString, createKey, createLocalizedString, createLocalizedString, createObject, createOrganization, createOrganization, createPersonName, createPersonName, createPostalAddress, createRegistryPackage, createRegistryPackage, createService, createService, createServiceBinding, createSlot, createSlot, createSpecificationLink, createTelephoneNumber, createUser, deleteObjects, deleteObjects, deprecateObjects, getRegistryService, saveObjects, unDeprecateObjects

    • Method Detail

      • saveOrganizations

        BulkResponse saveOrganizations(Collection organizations)
                               throws JAXRException
        Saves the specified Organizations.

        If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

        Partial commits are allowed. Processing stops on first SaveException encountered.

        Capability Level: 0
        Parameters:
        organizations - the Collection of Organization objects to be saved
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • saveServices

        BulkResponse saveServices(Collection services)
                          throws JAXRException
        Saves the specified Services.

        If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

        Partial commits are allowed. Processing stops on first SaveException encountered.

        Capability Level: 0
        Parameters:
        services - the Collection of Service objects to be saved
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • saveServiceBindings

        BulkResponse saveServiceBindings(Collection bindings)
                                 throws JAXRException
        Saves the specified ServiceBindings.

        If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

        Partial commits are allowed. Processing stops on first SaveException encountered.

        Capability Level: 0
        Parameters:
        bindings - the Collection of ServiceBinding objects to be saved
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • saveConcepts

        BulkResponse saveConcepts(Collection concepts)
                          throws JAXRException
        Saves the specified Concepts.

        If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

        Partial commits are allowed. Processing stops on first SaveException encountered.

        Capability Level: 0
        Parameters:
        concepts - the Collection of Concept objects to be saved
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • saveClassificationSchemes

        BulkResponse saveClassificationSchemes(Collection schemes)
                                       throws JAXRException
        Saves the specified ClassificationScheme instances.

        If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

        Partial commits are allowed. Processing stops on first SaveException encountered.

        Capability Level: 0
        Parameters:
        schemes - the Collection of ClassificationScheme objects to be saved
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • saveAssociations

        BulkResponse saveAssociations(Collection associations,
                            boolean replace)
                              throws JAXRException
        Saves the specified Association instances.

        If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

        Partial commits are allowed. Processing stops on first SaveException encountered.

        Capability Level: 0
        Parameters:
        associations - the Collection of Association objects to be saved
        replace - If set to true, the specified associations replace any existing associations owned by the caller. If set to false, the specified associations are saved, while any existing associations not being updated by this call are preserved.
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • deleteOrganizations

        BulkResponse deleteOrganizations(Collection organizationKeys)
                                 throws JAXRException
        Deletes the organizations corresponding to the specified Keys.

        Partial commits are allowed. Processing stops on first DeleteException encountered.

        Capability Level: 0
        Parameters:
        organizationKeys - the Collection of keys for the Organization objects to be deleted
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • deleteServices

        BulkResponse deleteServices(Collection serviceKeys)
                            throws JAXRException
        Deletes the services corresponding to the specified Keys.

        Partial commits are allowed. Processing stops on first DeleteException encountered.

        Capability Level: 0
        Parameters:
        serviceKeys - the Collection of keys for the Service objects to be deleted
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • deleteServiceBindings

        BulkResponse deleteServiceBindings(Collection bindingKeys)
                                   throws JAXRException
        Deletes the ServiceBindings corresponding to the specified Keys.

        Partial commits are allowed. Processing stops on first DeleteException encountered.

        Capability Level: 0
        Parameters:
        bindingKeys - the Collection of keys for the ServiceBinding objects to be deleted
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • deleteConcepts

        BulkResponse deleteConcepts(Collection conceptKeys)
                            throws JAXRException
        Deletes the Concepts corresponding to the specified Keys.

        Partial commits are allowed. Processing stops on first DeleteException encountered.

        Capability Level: 0
        Parameters:
        conceptKeys - the Collection of keys for the Concept objects to be deleted
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • deleteClassificationSchemes

        BulkResponse deleteClassificationSchemes(Collection schemeKeys)
                                         throws JAXRException
        Deletes the ClassificationSchemes corresponding to the specified Keys.

        Partial commits are allowed. Processing stops on first DeleteException encountered.

        Capability Level: 0
        Parameters:
        schemeKeys - the Collection of keys for the ClassificationScheme objects to be deleted
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • deleteAssociations

        BulkResponse deleteAssociations(Collection associationKeys)
                                throws JAXRException
        Deletes the Associations corresponding to the specified Keys.

        Partial commits are allowed. Processing stops on first DeleteException encountered.

        Capability Level: 0
        Parameters:
        associationKeys - the Collection of keys for the Association objects to be deleted
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • confirmAssociation

        void confirmAssociation(Association assoc)
                        throws JAXRException,
                               InvalidRequestException
        Confirms this Association by the User associated with the caller. The User must be the owner of the sourceObject or the targetObject in this association.

        • If the Association is intramural, this method does nothing and returns.
        • If the Association is extramural and already confirmed (isConfirmed returns true), this method does nothing and returns.
        • If the Association is extramural and not already confirmed, this method confirms the association for the User associated with the caller.

        The details of confirming an extramural Association are registry-specific. For UDDI and ebXML registries, the registry-specific details are described in the JAXR specification.

        Capability Level: 0
        Parameters:
        assoc - the Association object to be confirmed
        Throws:
        JAXRException - if the JAXR provider encounters an internal error
        InvalidRequestException - if the User is not the owner of the sourceObject or the targetObject

      • unConfirmAssociation

        void unConfirmAssociation(Association assoc)
                          throws JAXRException,
                                 InvalidRequestException
        Undoes a previous confirmation of this Association by the User associated with the caller. The User must be the owner of the sourceObject or the targetObject in this association.

        • If the Association is intramural, this method does nothing and returns.
        • If the Association is extramural and already confirmed (isConfirmed returns true), this method unconfirms it for the requestor.
        • If the Association is extramural and not already confirmed, this method does nothing and returns.

        The details of unconfirming an extramural Association are registry-specific. For UDDI and ebXML registries, the registry-specific details are described in the JAXR specification.

        Capability Level: 0
        Parameters:
        assoc - the Association object to be unconfirmed
        Throws:
        JAXRException - if the JAXR provider encounters an internal error
        InvalidRequestException - if the User is not the owner of the sourceObject or the targetObject
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BusinessQueryManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface BusinessQueryManager

  • All Superinterfaces:
    QueryManager

    public interface BusinessQueryManager
extends QueryManager
    The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface. It is also referred to as the focused query interface.
    Author:
    Farrukh S. Najmi
    See Also:
    DeclarativeQueryManager, FindQualifier, BulkResponse

    • Method Summary

      Methods
      Modifier and Type Method and Description
      BulkResponse findAssociations(Collection findQualifiers, String sourceObjectId, String targetObjectId, Collection associationTypes)
      Finds all Association objects that match all of the criteria specified by the parameters of this call.
      BulkResponse findCallerAssociations(Collection findQualifiers, Boolean confirmedByCaller, Boolean confirmedByOtherParty, Collection associationTypes)
      Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call.
      ClassificationScheme findClassificationSchemeByName(Collection findQualifiers, String namePattern)
      Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.
      BulkResponse findClassificationSchemes(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalLinks)
      Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call.
      Concept findConceptByPath(String path)
      Finds a Concept based on the path specified.
      BulkResponse findConcepts(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalIdentifiers, Collection externalLinks)
      Finds all Concept objects that match all of the criteria specified by the parameters of this call.
      BulkResponse findOrganizations(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications, Collection externalIdentifiers, Collection externalLinks)
      Finds all Organization objects that match all of the criteria specified by the parameters of this call.
      BulkResponse findRegistryPackages(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalLinks)
      Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call.
      BulkResponse findServiceBindings(Key serviceKey, Collection findQualifiers, Collection classifications, Collection specifications)
      Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call.
      BulkResponse findServices(Key orgKey, Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications)
      Finds all Service objects that match all of the criteria specified by the parameters of this call.

      • Methods inherited from interface javax.xml.registry.QueryManager

        getRegistryObject, getRegistryObject, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryService

    • Method Detail

      • findAssociations

        BulkResponse findAssociations(Collection findQualifiers,
                            String sourceObjectId,
                            String targetObjectId,
                            Collection associationTypes)
                              throws JAXRException
        Finds all Association objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters. If no parameters are specified, no Associations are returned.

        Capability Level: 0
        Parameters:
        findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
        sourceObjectId - a String that represents the id for a RegistryObject that must be the sourceObject of the Associations that match. This parameter is ignored if specified as null.
        targetObjectId - a String that represents the id for a RegistryObject that must be the targetObject of the Associations that match. This parameter is ignored if specified as null.
        associationTypes - a Collection of associationTypes. This is a logical OR operation across the collection. This parameter is ignored if specified as null.
        Returns:
        a BulkResponse containing a Collection of Associations
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • findCallerAssociations

        BulkResponse findCallerAssociations(Collection findQualifiers,
                                  Boolean confirmedByCaller,
                                  Boolean confirmedByOtherParty,
                                  Collection associationTypes)
                                    throws JAXRException
        Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters. If no parameters are specified, no Associations are returned.

        This call is sensitive to the identity of the caller and is a privileged operation that requires the caller to have provided its identity credentials to the Connection associated with this object.

        Capability Level: 0
        Parameters:
        findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
        confirmedByCaller - If true, provider must include Associations involving the caller that have been confirmed by the caller. If false, provider must include Associations involving the caller that have not been confirmed by the caller. This parameter is ignored if specified as null.
        confirmedByOtherParty - If true, provider must include Associations involving the caller that have been confirmed by the other party. If false, provider must include Associations involving the caller that have not been confirmed by the other party. This parameter is ignored if specified as null.
        associationTypes - a Collection of associationTypes. This is a logical OR operation across the collection. This parameter is ignored if specified as null.
        Returns:
        a BulkResponse containing a Collection of Associations
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • findOrganizations

        BulkResponse findOrganizations(Collection findQualifiers,
                             Collection namePatterns,
                             Collection classifications,
                             Collection specifications,
                             Collection externalIdentifiers,
                             Collection externalLinks)
                               throws JAXRException
        Finds all Organization objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

        Capability Level: 0
        Parameters:
        findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
        namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
        classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
        specifications - a Collection of RegistryObjects that represent (proxy) a technical specification. It is analogous to a tModelBag in the UDDI specification. In the case of a UDDI provider, the RegistryObject is a specification Concept. In the case of an ebXML provider, the RegistryObject is likely to be an ExtrinsicObject. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Specifications qualifies as a match for this criterion.
        externalIdentifiers - a Collection of ExternalIdentifier objects that provide an external identifier for the object using an identification scheme such as DUNS. It is analogous to an identifierBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalIdentifiers qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createExternalIdentifier method to create a transient ExternalIdentifier for use in this Collection.
        externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
        Returns:
        a BulkResponse containing a Collection of Organizations
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • findServices

        BulkResponse findServices(Key orgKey,
                        Collection findQualifiers,
                        Collection namePatterns,
                        Collection classifications,
                        Collection specifications)
                          throws JAXRException
        Finds all Service objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

        Capability Level: 0
        Parameters:
        orgKey - Key identifying an Organization. Required for UDDI providers.
        findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
        namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
        classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
        specifications - a Collection of RegistryObjects that represent (proxy) a technical specification. It is analogous to a tModelBag in the UDDI specification. In the case of a UDDI provider, the RegistryObject is a specification Concept. In the case of an ebXML provider, the RegistryObject is likely to be an ExtrinsicObject. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Specifications qualifies as a match for this criterion.
        Returns:
        a BulkResponse containing a Collection of Services
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • findServiceBindings

        BulkResponse findServiceBindings(Key serviceKey,
                               Collection findQualifiers,
                               Collection classifications,
                               Collection specifications)
                                 throws JAXRException
        Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

        Capability Level: 0
        Parameters:
        serviceKey - Key identifying a Service. Required for UDDI providers.
        findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
        classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
        specifications - a Collection of RegistryObjects that represent (proxy) a technical specification. It is analogous to a tModelBag in the UDDI specification. In the case of a UDDI provider, the RegistryObject is a specification Concept. In the case of an ebXML provider, the RegistryObject is likely to be an ExtrinsicObject. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Specifications qualifies as a match for this criterion.
        Returns:
        a BulkResponse containing a Collection of ServiceBindings
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • findClassificationSchemes

        BulkResponse findClassificationSchemes(Collection findQualifiers,
                                     Collection namePatterns,
                                     Collection classifications,
                                     Collection externalLinks)
                                       throws JAXRException
        Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

        Capability Level: 0
        Parameters:
        findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
        namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
        classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
        externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
        Returns:
        a BulkResponse containing a Collection of ClassificationSchemes
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • findClassificationSchemeByName

        ClassificationScheme findClassificationSchemeByName(Collection findQualifiers,
                                                  String namePattern)
                                                    throws JAXRException
        Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.

        Capability Level: 0
        Parameters:
        findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
        namePattern - a String that is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification
        Returns:
        the ClassificationScheme matching the namePattern, or null if no match is found.
        Throws:
        JAXRException - if the JAXR provider encounters an internal error. Throws an InvalidRequestException if multiple matches are found.

      • findConcepts

        BulkResponse findConcepts(Collection findQualifiers,
                        Collection namePatterns,
                        Collection classifications,
                        Collection externalIdentifiers,
                        Collection externalLinks)
                          throws JAXRException
        Finds all Concept objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

        Capability Level: 0
        Parameters:
        findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
        namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
        classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
        externalIdentifiers - a Collection of ExternalIdentifier objects that provide an external identifier for the object using an identification scheme such as DUNS. It is analogous to an identifierBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalIdentifiers qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createExternalIdentifier method to create a transient ExternalIdentifier for use in this Collection.
        externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
        Returns:
        a BulkResponse containing a Collection of Concepts
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • findConceptByPath

        Concept findConceptByPath(String path)
                          throws JAXRException
        Finds a Concept based on the path specified. If the specified path matches more than one Concept, the one that is most general (higher in the concept hierarchy) is returned.

        Capability Level: 0
        Parameters:
        path - a canonical path expression, as defined in the JAXR specification, that identifies the Concept.
        Returns:
        the Concept found, or null if no match is found
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • findRegistryPackages

        BulkResponse findRegistryPackages(Collection findQualifiers,
                                Collection namePatterns,
                                Collection classifications,
                                Collection externalLinks)
                                  throws JAXRException
        Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

        Capability Level: 1
        Parameters:
        findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
        namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
        classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
        externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
        Returns:
        a BulkResponse containing a Collection of RegistryPackages
        Throws:
        JAXRException - if the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CapabilityProfile (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface CapabilityProfile

  • public interface CapabilityProfile
    Provides information about the capabilities of a JAXR provider.
    Author:
    Farrukh S. Najmi

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getCapabilityLevel()
      Gets the capability level supported by the JAXR provider.
      String getVersion()
      Gets the JAXR specification version supported by the JAXR provider.

    • Method Detail

      • getVersion

        String getVersion()
                  throws JAXRException
        Gets the JAXR specification version supported by the JAXR provider.

        Capability Level: 0
        Returns:
        the specification version
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getCapabilityLevel

        int getCapabilityLevel()
                       throws JAXRException
        Gets the capability level supported by the JAXR provider.

        Capability Level: 0
        Returns:
        the capability level
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Connection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface Connection

  • All Known Subinterfaces:
    FederatedConnection

    public interface Connection
    This class represents a connection between a JAXR client and a JAXR provider.
    Author:
    Farrukh S. Najmi
    See Also:
    ConnectionFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close()
      Closes a Connection when it is no longer needed.
      Set getCredentials()
      Gets the credentials associated with this client.
      RegistryService getRegistryService()
      Gets the RegistryService interface associated with the Connection.
      boolean isClosed()
      Indicated whether this Connection has been closed or not.
      boolean isSynchronous()
      Indicates whether a client uses synchronous communication with JAXR provider or not.
      void setCredentials(Set credentials)
      Sets the Credentials associated with this client.
      void setSynchronous(boolean sync)
      Sets whether the client uses synchronous communication or not.

    • Method Detail

      • getRegistryService

        RegistryService getRegistryService()
                                   throws JAXRException
        Gets the RegistryService interface associated with the Connection. If a Connection property (e.g. credentials) is set after the client calls getRegistryService then the newly set Connection property is visible to the RegistryService previously returned by this call.

        Capability Level: 0
        Returns:
        the RegistryService associated with this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        RegistryService

      • close

        void close()
           throws JAXRException
        Closes a Connection when it is no longer needed. Since a provider typically allocates significant resources outside the JVM on behalf of a Connection, clients should close them when they are not needed.

        Capability Level: 0
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • isClosed

        boolean isClosed()
                 throws JAXRException
        Indicated whether this Connection has been closed or not.

        Capability Level: 0
        Returns:
        true if Connection is closed; false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • isSynchronous

        boolean isSynchronous()
                      throws JAXRException
        Indicates whether a client uses synchronous communication with JAXR provider or not. A JAXR provider must support both modes of communication. A JAXR client can choose which mode it wants to use.

        Capability Level: 0
        Returns:
        true if Connection is synchronous (default); false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setSynchronous

        void setSynchronous(boolean sync)
                    throws JAXRException
        Sets whether the client uses synchronous communication or not. A JAXR client may dynamically change its communication style preference.

        Capability Level: 0
        Parameters:
        sync - true if Connection is desired to be synchronous; false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setCredentials

        void setCredentials(Set credentials)
                    throws JAXRException
        Sets the Credentials associated with this client. The credentials is used to authenticate the client with the JAXR provider. A JAXR client may dynamically change its identity by changing the credentials associated with it.

        Capability Level: 0
        Parameters:
        credentials - a Collection oj java.lang.Objects which provide identity related information for the caller.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getCredentials

        Set getCredentials()
                   throws JAXRException
        Gets the credentials associated with this client.

        Capability Level: 0
        Returns:
        Set of java.lang.Object instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Class ConnectionFactory

  • java.lang.Object
    • javax.xml.registry.ConnectionFactory

  • public abstract class ConnectionFactory
extends Object
    This is the abstract base class for factory classes for creating a JAXR connection. A JAXR ConnectionFactory object is configured in a provider-specific way to create connections with registry providers.

    Looking Up a ConnectionFactory Using the JNDI API

    The preferred way for a client to look up a JAXR ConnectionFactory is within the Java Naming and Directory InterfaceTM (JNDI) API. A ConnectionFactory object is registered with a naming service in a provider specific way, such as one based on the JNDI API. This registration associates the ConnectionFactory object with a logical name. When an application wants to establish a connection with the provider associated with that ConnectionFactory object, it does a lookup, providing the logical name. The application can then use the ConnectionFactory object that is returned to create a connection to the messaging provider.

    Looking Up a ConnectionFactory Without Using the JNDI API

    The JAXR API provides an alternative way to look up a JAXR ConnectionFactory that does not require the use of the JNDI API. This is done using the newInstance static method on the abstract class ConnectionFactory provided in the JAXR API. The newInstance method returns a JAXR ConnectionFactory. The client may indicate which factory class should be instantiated by the newInstance method by defining the system property javax.xml.registry.ConnectionFactoryClass. If this property is not set, the JAXR provider must return a default ConnectionFactory instance.
    Author:
    Farrukh S. Najmi
    See Also:
    Connection

    • Constructor Summary

      Constructors
      Constructor and Description
      ConnectionFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Connection createConnection()
      Create a named connection.
      abstract FederatedConnection createFederatedConnection(Collection connections)
      Create a FederatedConnection.
      abstract Properties getProperties()
      Gets the Properties used during createConnection and createFederatedConnection calls.
      static ConnectionFactory newInstance()
      Creates a default ConnectionFactory object.
      abstract void setProperties(Properties properties)
      Sets the Properties used during createConnection and createFederatedConnection calls.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ConnectionFactory

        public ConnectionFactory()

    • Method Detail

      • setProperties

        public abstract void setProperties(Properties properties)
                            throws JAXRException
        Sets the Properties used during createConnection and createFederatedConnection calls.

        Standard Connection Properties:
        javax.xml.registry.queryManagerURL - URL String for the query manager service within the target registry provider
        javax.xml.registry.lifeCycleManagerURL - URL String for the life cycle manager service within the target registry provider. If unspecified, must default to value of the queryManagerURL described above
        javax.xml.registry.semanticEquivalences - String that allows specification of semantic equivalences
        javax.xml.registry.security.authenticationMethod - string that provides a hint to the JAXR provider on the authentication method to be used when authenticating with the registry provider. Possible value include but are not limited to "UDDI_GET_AUTHTOKEN", "HTTP_BASIC", "CLIENT_CERTIFICATE", "MS_PASSPORT"
        javax.xml.registry.uddi.maxRows - integer that specifies the maximum number of rows to be returned for find operations. This property is specific for UDDI providers
        javax.xml.registry.postalAddressScheme - String that specifies the id of a ClassificationScheme that is used as the default postal address scheme for this connection

        Capability Level: 0
        Parameters:
        properties - configuration properties that are either specified by JAXR specification or are provider specific.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getProperties

        public abstract Properties getProperties()
                                  throws JAXRException
        Gets the Properties used during createConnection and createFederatedConnection calls.

        Capability Level: 0
        Returns:
        the Properties defined for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • createConnection

        public abstract Connection createConnection()
                                     throws JAXRException
        Create a named connection. Such a connection can be used to communicate with a JAXR provider.

        Capability Level: 0
        Returns:
        the Connection created by this call
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • createFederatedConnection

        public abstract FederatedConnection createFederatedConnection(Collection connections)
                                                       throws JAXRException
        Create a FederatedConnection.

        Capability Level: 0 (optional)
        Parameters:
        connections - Is a Collection of Connection objects. Note that Connection objects may also be FederatedConnection objects.
        Returns:
        the FederatedConnection created by this call
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • newInstance

        public static ConnectionFactory newInstance()
                                     throws JAXRException
        Creates a default ConnectionFactory object.
        Returns:
        a new instance of a ConnectionFactory
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeclarativeQueryManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface DeclarativeQueryManager

  • All Superinterfaces:
    QueryManager

    public interface DeclarativeQueryManager
extends QueryManager
    This interface provides the ability to execute declarative queries (e.g. SQL)
    Author:
    Farrukh S. Najmi

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Query createQuery(int queryType, String queryString)
      Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.
      BulkResponse executeQuery(Query query)
      Executes a query as specified by query parameter.

      • Methods inherited from interface javax.xml.registry.QueryManager

        getRegistryObject, getRegistryObject, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryService

    • Method Detail

      • createQuery

        Query createQuery(int queryType,
                String queryString)
                  throws InvalidRequestException,
                         JAXRException
        Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.

        Capability Level: 1
        Parameters:
        queryType - the type of query
        queryString - the query in its string representation
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        InvalidRequestException - If the JAXR provider validates query syntax (optional) and the sqlQuery is not valid
        See Also:
        Query.QUERY_TYPE_SQL, Query.QUERY_TYPE_XQUERY, Query.QUERY_TYPE_EBXML_FILTER_QUERY

      • executeQuery

        BulkResponse executeQuery(Query query)
                          throws JAXRException
        Executes a query as specified by query parameter.

        Capability Level: 1
        Parameters:
        query - the query to be executed
        Returns:
        the BulkResponse that is the result of the query
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeleteException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Class DeleteException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.registry.JAXRException
          • javax.xml.registry.RegistryException
            • javax.xml.registry.DeleteException
  • All Implemented Interfaces:
    Serializable, JAXRResponse

    public class DeleteException
extends RegistryException
    A RegistryException that occurs during a delete action.
    Author:
    Farrukh S. Najmi
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.xml.registry.JAXRException

        cause

      • Fields inherited from interface javax.xml.registry.JAXRResponse

        STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      DeleteException()
      Constructs a JAXRException object with no reason or embedded Throwable.
      DeleteException(String reason)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown.
      DeleteException(String reason, Throwable cause)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
      DeleteException(Throwable cause)
      Constructs a JAXRException object initialized with the given Throwable object.

    • Method Summary

      • Methods inherited from class javax.xml.registry.RegistryException

        getErrorObjectKey, setErrorObjectKey

      • Methods inherited from class javax.xml.registry.JAXRException

        getCause, getMessage, getRequestId, getStatus, initCause, isAvailable

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DeleteException

        public DeleteException()
        Constructs a JAXRException object with no reason or embedded Throwable.

      • DeleteException

        public DeleteException(String reason)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown.
        Parameters:
        reason - a description of what caused the exception

      • DeleteException

        public DeleteException(String reason,
               Throwable cause)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
        Parameters:
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this JAXRException object

      • DeleteException

        public DeleteException(Throwable cause)
        Constructs a JAXRException object initialized with the given Throwable object.
        Parameters:
        cause - the Throwable that caused this Exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FederatedConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface FederatedConnection

  • All Superinterfaces:
    Connection

    public interface FederatedConnection
extends Connection
    Represents a single logical connection to a federation or group of registry providers. This interface is used in support of the distributed query feature of the JAXR API.
    Author:
    Farrukh S. Najmi

    • Method Summary

      • Methods inherited from interface javax.xml.registry.Connection

        close, getCredentials, getRegistryService, isClosed, isSynchronous, setCredentials, setSynchronous
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FindException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Class FindException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.registry.JAXRException
          • javax.xml.registry.RegistryException
            • javax.xml.registry.FindException
  • All Implemented Interfaces:
    Serializable, JAXRResponse

    public class FindException
extends RegistryException
    A RegistryException that occurs during a find action.
    Author:
    Farrukh S. Najmi
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.xml.registry.JAXRException

        cause

      • Fields inherited from interface javax.xml.registry.JAXRResponse

        STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      FindException()
      Constructs a JAXRException object with no reason or embedded Throwable.
      FindException(String reason)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown.
      FindException(String reason, Throwable cause)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
      FindException(Throwable cause)
      Constructs a JAXRException object initialized with the given Throwable object.

    • Method Summary

      • Methods inherited from class javax.xml.registry.RegistryException

        getErrorObjectKey, setErrorObjectKey

      • Methods inherited from class javax.xml.registry.JAXRException

        getCause, getMessage, getRequestId, getStatus, initCause, isAvailable

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FindException

        public FindException()
        Constructs a JAXRException object with no reason or embedded Throwable.

      • FindException

        public FindException(String reason)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown.
        Parameters:
        reason - a description of what caused the exception

      • FindException

        public FindException(String reason,
             Throwable cause)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
        Parameters:
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this JAXRException object

      • FindException

        public FindException(Throwable cause)
        Constructs a JAXRException object initialized with the given Throwable object.
        Parameters:
        cause - the Throwable that caused this Exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FindQualifier (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface FindQualifier

  • public interface FindQualifier
    FindQualifier provides various constants that identify options that effect find method behavior. A JAXR provider may silently ignore any qualifiers marked as optional. A JAXR provider must support qualifiers not marked optional.
    See Also:
    BusinessQueryManager

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static String | AND_ALL_KEYS
      static String CASE_SENSITIVE_MATCH
      Specifies a hint to queries that they should case-sensitive match when comparing String values.
      static String COMBINE_CLASSIFICATIONS
      Maps to UDDI combineCategoryBags.
      static String EXACT_NAME_MATCH
      Specifies a hint to queries that they should use exact (case-insensitive) match when comparing String values.
      static String OR_ALL_KEYS
      Specifies a hint to queries that the candidate set of objects matching the query should include any object that is classified by any one of the taxonomy values specified in any of the Classification for the query.
      static String OR_LIKE_KEYS
      Specifies a hint to queries that when multiple taxonomy values from the same ClassificationScheme are specified in the Classifications for the query then the candidate set of objects matching the query should include any object that is classified by any one of the taxonomy values.
      static String SERVICE_SUBSET
      Maps to UDDI serviceSubset.
      static String SORT_BY_DATE_ASC
      Specifies a hint to queries that they should sort results by creation/modification date in ascending order.
      static String SORT_BY_DATE_DESC
      Specifies a hint to queries that they should sort results by creation/modification date in descending order.
      static String SORT_BY_NAME_ASC
      Specifies a hint to queries that they should sort results by Name in ascending alpha-numeric order.
      static String SORT_BY_NAME_DESC
      Specifies a hint to queries that they should sort results by Name in descending alpha-numeric order.
      static String SOUNDEX
      Optional qualifier that allows matching strings by their sounds.

    • Field Detail

      • EXACT_NAME_MATCH

        static final String EXACT_NAME_MATCH
        Specifies a hint to queries that they should use exact (case-insensitive) match when comparing String values.
        See Also:
        Constant Field Values

      • CASE_SENSITIVE_MATCH

        static final String CASE_SENSITIVE_MATCH
        Specifies a hint to queries that they should case-sensitive match when comparing String values.
        See Also:
        Constant Field Values

      • SORT_BY_NAME_ASC

        static final String SORT_BY_NAME_ASC
        Specifies a hint to queries that they should sort results by Name in ascending alpha-numeric order.
        See Also:
        Constant Field Values

      • SORT_BY_NAME_DESC

        static final String SORT_BY_NAME_DESC
        Specifies a hint to queries that they should sort results by Name in descending alpha-numeric order.
        See Also:
        Constant Field Values

      • SORT_BY_DATE_ASC

        static final String SORT_BY_DATE_ASC
        Specifies a hint to queries that they should sort results by creation/modification date in ascending order.
        See Also:
        Constant Field Values

      • SORT_BY_DATE_DESC

        static final String SORT_BY_DATE_DESC
        Specifies a hint to queries that they should sort results by creation/modification date in descending order.
        See Also:
        Constant Field Values

      • OR_LIKE_KEYS

        static final String OR_LIKE_KEYS
        Specifies a hint to queries that when multiple taxonomy values from the same ClassificationScheme are specified in the Classifications for the query then the candidate set of objects matching the query should include any object that is classified by any one of the taxonomy values. For example, if a query includes Classifications with both Japan and Korea taxonomy values under the geography ClassificationScheme, then it should match objects that are classified by either Japan or Korea ClassificationNodes.
        See Also:
        Constant Field Values

      • OR_ALL_KEYS

        static final String OR_ALL_KEYS
        Specifies a hint to queries that the candidate set of objects matching the query should include any object that is classified by any one of the taxonomy values specified in any of the Classification for the query.
        See Also:
        Constant Field Values

      • COMBINE_CLASSIFICATIONS

        static final String COMBINE_CLASSIFICATIONS
        Maps to UDDI combineCategoryBags. Required for JAXR UDDI providers, optional for all others.
        See Also:
        Constant Field Values

      • SERVICE_SUBSET

        static final String SERVICE_SUBSET
        Maps to UDDI serviceSubset. Required for JAXR UDDI providers, optional for all others.
        See Also:
        Constant Field Values

      • AND_ALL_KEYS

        static final String AND_ALL_KEYS
        See Also:
        Constant Field Values

      • SOUNDEX

        static final String SOUNDEX
        Optional qualifier that allows matching strings by their sounds.
        See Also:
        Constant Field Values
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidRequestException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Class InvalidRequestException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.registry.JAXRException
          • javax.xml.registry.InvalidRequestException
  • All Implemented Interfaces:
    Serializable, JAXRResponse

    public class InvalidRequestException
extends JAXRException
    This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.
    Author:
    Farrukh S. Najmi
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.xml.registry.JAXRException

        cause

      • Fields inherited from interface javax.xml.registry.JAXRResponse

        STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidRequestException()
      Constructs a JAXRException object with no reason or embedded Throwable.
      InvalidRequestException(String reason)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown.
      InvalidRequestException(String reason, Throwable cause)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
      InvalidRequestException(Throwable cause)
      Constructs a JAXRException object initialized with the given Throwable object.

    • Method Summary

      • Methods inherited from class javax.xml.registry.JAXRException

        getCause, getMessage, getRequestId, getStatus, initCause, isAvailable

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidRequestException

        public InvalidRequestException()
        Constructs a JAXRException object with no reason or embedded Throwable.

      • InvalidRequestException

        public InvalidRequestException(String reason)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown.
        Parameters:
        reason - a description of what caused the exception

      • InvalidRequestException

        public InvalidRequestException(String reason,
                       Throwable cause)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
        Parameters:
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this JAXRException object

      • InvalidRequestException

        public InvalidRequestException(Throwable cause)
        Constructs a JAXRException object initialized with the given Throwable object.
        Parameters:
        cause - the Throwable that caused this Exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.registry (Java(TM) EE 7 Specification APIs)

javax.xml.registry

Interfaces

  • BulkResponse
  • BusinessLifeCycleManager
  • BusinessQueryManager
  • CapabilityProfile
  • Connection
  • DeclarativeQueryManager
  • FederatedConnection
  • FindQualifier
  • JAXRResponse
  • LifeCycleManager
  • Query
  • QueryManager
  • RegistryService

Classes

  • ConnectionFactory

Exceptions

  • DeleteException
  • FindException
  • InvalidRequestException
  • JAXRException
  • RegistryException
  • SaveException
  • UnexpectedObjectException
  • UnsupportedCapabilityException


javax.xml.registry (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.registry

This package defines APIs to access and programatically interact with metadata registries.

See: Description

  • Interface Summary
    Interface Description
    BulkResponse
    Contains the response of a method in the API that performs a bulk operation and returns a bulk response.
    BusinessLifeCycleManager
    The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API.
    BusinessQueryManager
    The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface.
    CapabilityProfile
    Provides information about the capabilities of a JAXR provider.
    Connection
    This class represents a connection between a JAXR client and a JAXR provider.
    DeclarativeQueryManager
    This interface provides the ability to execute declarative queries (e.g.
    FederatedConnection
    Represents a single logical connection to a federation or group of registry providers.
    FindQualifier
    FindQualifier provides various constants that identify options that effect find method behavior.
    JAXRResponse
    A JAXR requests' response.
    LifeCycleManager
    The LifeCycleManager interface is the main interface in the API for managing life cycle operations on objects defined by the information model.
    Query
    The Query interface encapsulates a query in a declarative query language.
    QueryManager
    This is the common base interface for all QueryManagers in the API.
    RegistryService
    This is the principal interface implemented by a JAXR provider.
  • Class Summary
    Class Description
    ConnectionFactory
    This is the abstract base class for factory classes for creating a JAXR connection.
  • Exception Summary
    Exception Description
    DeleteException
    A RegistryException that occurs during a delete action.
    FindException
    A RegistryException that occurs during a find action.
    InvalidRequestException
    This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.
    JAXRException
    Signals that a JAXR exception has occurred.
    RegistryException
    This is the common base class for all Exceptions that are detected on the registry provider side rather than the JAXR client side.
    SaveException
    A RegistryException that occurs during a save action.
    UnexpectedObjectException
    This exception is thrown when the JAXR provider finds a Object that is out-of-place or of the wrong type within the context of a user request.
    UnsupportedCapabilityException
    This exception must be thrown when a JAXR client attempts to invoke an API method that is not supported by the capability profile that is supported by the JAXR provider.

Package javax.xml.registry Description

This package defines APIs to access and programatically interact with metadata registries.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.registry Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.registry

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.registry.ConnectionFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.registry.JAXRException (implements javax.xml.registry.JAXRResponse)
          • javax.xml.registry.InvalidRequestException
          • javax.xml.registry.RegistryException
            • javax.xml.registry.DeleteException
            • javax.xml.registry.FindException
            • javax.xml.registry.SaveException
          • javax.xml.registry.UnexpectedObjectException
          • javax.xml.registry.UnsupportedCapabilityException

Interface Hierarchy

  • javax.xml.registry.CapabilityProfile
  • javax.xml.registry.Connection
    • javax.xml.registry.FederatedConnection
  • javax.xml.registry.FindQualifier
  • javax.xml.registry.JAXRResponse
    • javax.xml.registry.BulkResponse
  • javax.xml.registry.LifeCycleManager
    • javax.xml.registry.BusinessLifeCycleManager
  • javax.xml.registry.Query
  • javax.xml.registry.QueryManager
    • javax.xml.registry.BusinessQueryManager
    • javax.xml.registry.DeclarativeQueryManager
  • javax.xml.registry.RegistryService
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JAXRException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Class JAXRException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.registry.JAXRException
  • All Implemented Interfaces:
    Serializable, JAXRResponse
    Direct Known Subclasses:
    InvalidRequestException, RegistryException, UnexpectedObjectException, UnsupportedCapabilityException

    public class JAXRException
extends Exception
implements JAXRResponse
    Signals that a JAXR exception has occurred. It contains no members other than the standard reason String.
    Author:
    Nicholas Kassem, Mark Hapner, Rajiv Mordani, Farrukh Najmi
    See Also:
    JAXRResponse, Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Throwable cause
      The Throwable that caused this JAXRException to occur.

      • Fields inherited from interface javax.xml.registry.JAXRResponse

        STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXRException()
      Constructs a JAXRException object with no reason or embedded Throwable.
      JAXRException(String reason)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown.
      JAXRException(String reason, Throwable cause)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
      JAXRException(Throwable cause)
      Constructs a JAXRException object initialized with the given Throwable object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the Throwable embedded in this JAXRException if there is one.
      String getMessage()
      Returns the detail message for this JAXRException object.
      String getRequestId()
      Returns the unique id for the request that generated this response.
      int getStatus()
      Returns the status for this response.
      Throwable initCause(Throwable cause)
      Initializes the cause of this throwable to the specified value.
      boolean isAvailable()
      Returns true if a response is available, false otherwise.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • cause

        protected Throwable cause
        The Throwable that caused this JAXRException to occur. This is used when a JAXRException has a nested Throwable.

    • Constructor Detail

      • JAXRException

        public JAXRException()
        Constructs a JAXRException object with no reason or embedded Throwable.

      • JAXRException

        public JAXRException(String reason)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown.
        Parameters:
        reason - a description of what caused the exception

      • JAXRException

        public JAXRException(String reason,
             Throwable cause)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
        Parameters:
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this JAXRException object

      • JAXRException

        public JAXRException(Throwable cause)
        Constructs a JAXRException object initialized with the given Throwable object.
        Parameters:
        cause - the Throwable that caused this Exception

    • Method Detail

      • getMessage

        public String getMessage()
        Returns the detail message for this JAXRException object.

        If there is an embedded Throwable, and if the JAXRException object has no detail message of its own, this method will return the detail message from the embedded Throwable.

        Overrides:
        getMessage in class Throwable
        Returns:
        the error or warning message for this JAXRException or, if it has none, the message of the embedded Throwable, if there is one

      • getCause

        public Throwable getCause()
        Returns the Throwable embedded in this JAXRException if there is one. Otherwise, this method returns null.
        Overrides:
        getCause in class Throwable
        Returns:
        the embedded Throwable or null if there is none

      • initCause

        public Throwable initCause(Throwable cause)
        Initializes the cause of this throwable to the specified value. (The cause is the throwable that caused this throwable to get thrown.)

        This method can be called at most once. It is generally called from within the constructor, or immediately after creating the throwable. If this throwable was created with JAXRException(Throwable) or JAXRException(String,Throwable), this method cannot be called even once.

        Overrides:
        initCause in class Throwable
        Parameters:
        cause - the cause (which is saved for later retrieval by the getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
        Returns:
        a reference to this Throwable instance.
        Throws:
        IllegalArgumentException - if cause is this throwable. (A throwable cannot be its own cause.)
        IllegalStateException - if this throwable was created with JAXRException(Throwable) or JAXRException(String,Throwable), or this method has already been called on this throwable.

      • getRequestId

        public String getRequestId()
        Description copied from interface: JAXRResponse
        Returns the unique id for the request that generated this response.

        Capability Level: 0
        Specified by:
        getRequestId in interface JAXRResponse
        Returns:
        the request id

      • getStatus

        public int getStatus()
        Description copied from interface: JAXRResponse
        Returns the status for this response.

        Capability Level: 0
        Specified by:
        getStatus in interface JAXRResponse
        Returns:
        the status which is an integer enumerated value
        See Also:
        JAXRResponse.STATUS_SUCCESS

      • isAvailable

        public boolean isAvailable()
                    throws JAXRException
        Returns true if a response is available, false otherwise. This is a polling method and must not block.
        Specified by:
        isAvailable in interface JAXRResponse
        Returns:
        true if the response is available; false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


JAXRResponse (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface JAXRResponse

  • All Known Subinterfaces:
    BulkResponse
    All Known Implementing Classes:
    DeleteException, FindException, InvalidRequestException, JAXRException, RegistryException, SaveException, UnexpectedObjectException, UnsupportedCapabilityException

    public interface JAXRResponse
    A JAXR requests' response.
    Author:
    Farrukh S. Najmi
    See Also:
    JAXRException

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int STATUS_FAILURE
      Status indicating a failure response.
      static int STATUS_SUCCESS
      Status indicating a successful response.
      static int STATUS_UNAVAILABLE
      Status indicating that the results are currently unavailable.
      static int STATUS_WARNING
      Status indicating a successful response that included at least one warning.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getRequestId()
      Returns the unique id for the request that generated this response.
      int getStatus()
      Returns the status for this response.
      boolean isAvailable()
      Returns true if a response is available, false otherwise.

    • Field Detail

      • STATUS_SUCCESS

        static final int STATUS_SUCCESS
        Status indicating a successful response.
        See Also:
        Constant Field Values

      • STATUS_WARNING

        static final int STATUS_WARNING
        Status indicating a successful response that included at least one warning.
        See Also:
        Constant Field Values

      • STATUS_FAILURE

        static final int STATUS_FAILURE
        Status indicating a failure response.
        See Also:
        Constant Field Values

      • STATUS_UNAVAILABLE

        static final int STATUS_UNAVAILABLE
        Status indicating that the results are currently unavailable.
        See Also:
        Constant Field Values

    • Method Detail

      • getRequestId

        String getRequestId()
                    throws JAXRException
        Returns the unique id for the request that generated this response.

        Capability Level: 0
        Returns:
        the request id
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getStatus

        int getStatus()
              throws JAXRException
        Returns the status for this response.

        Capability Level: 0
        Returns:
        the status which is an integer enumerated value
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        STATUS_SUCCESS

      • isAvailable

        boolean isAvailable()
                    throws JAXRException
        Returns true if a response is available, false otherwise. This is a polling method and must not block.

        Capability Level: 0
        Returns:
        true if the response is available; false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LifeCycleManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface LifeCycleManager

  • All Known Subinterfaces:
    BusinessLifeCycleManager

    public interface LifeCycleManager
    The LifeCycleManager interface is the main interface in the API for managing life cycle operations on objects defined by the information model.

    The factory methods of this interface must throw an UnsupportedCapabilityException if the client attempts to create an instance of an infomodel interface that is not supported by the capability level of the JAXR provider.

    Author:
    Farrukh S. Najmi

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ASSOCIATION
      Constant representing the javax.xml.registry.infomodel.Association interface.
      static String AUDITABLE_EVENT
      Constant representing the javax.xml.registry.infomodel.AuditableEvent interface.
      static String CLASSIFICATION
      Constant representing the javax.xml.registry.infomodel.Classification interface.
      static String CLASSIFICATION_SCHEME
      Constant representing the javax.xml.registry.infomodel.ClassificationScheme interface.
      static String CONCEPT
      Constant representing the javax.xml.registry.infomodel.Concept interface.
      static String EMAIL_ADDRESS
      Constant representing the javax.xml.registry.infomodel.EmailAddress interface.
      static String EXTERNAL_IDENTIFIER
      Constant representing the javax.xml.registry.infomodel.ExternalIdentifier interface.
      static String EXTERNAL_LINK
      Constant representing the javax.xml.registry.infomodel.ExternalLink interface.
      static String EXTRINSIC_OBJECT
      Constant representing the javax.xml.registry.infomodel.ExternalLink interface.
      static String INTERNATIONAL_STRING
      Constant representing the javax.xml.registry.infomodel.InternationalString interface.
      static String KEY
      Constant representing the javax.xml.registry.infomodel.Key interface.
      static String LOCALIZED_STRING
      Constant representing the javax.xml.registry.infomodel.LocalizedString interface.
      static String ORGANIZATION
      Constant representing the javax.xml.registry.infomodel.Organization interface.
      static String PERSON_NAME
      Constant representing the javax.xml.registry.infomodel.PersonName interface.
      static String POSTAL_ADDRESS
      Constant representing the javax.xml.registry.infomodel.PostalAddress interface.
      static String REGISTRY_ENTRY
      Constant representing the javax.xml.registry.infomodel.RegistryEntry interface.
      static String REGISTRY_PACKAGE
      Constant representing the javax.xml.registry.infomodel.RegistryPackage interface.
      static String SERVICE
      Constant representing the javax.xml.registry.infomodel.Service interface.
      static String SERVICE_BINDING
      Constant representing the javax.xml.registry.infomodel.ServiceBinding interface.
      static String SLOT
      Constant representing the javax.xml.registry.infomodel.Slot interface.
      static String SPECIFICATION_LINK
      Constant representing the javax.xml.registry.infomodel.SpecificationLink interface.
      static String TELEPHONE_NUMBER
      Constant representing the javax.xml.registry.infomodel.TelephoneNumber interface.
      static String USER
      Constant representing the javax.xml.registry.infomodel.User interface.
      static String VERSIONABLE
      Constant representing the javax.xml.registry.infomodel.Versionable interface.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Association createAssociation(RegistryObject targetObject, Concept associationType)
      Creates an Association instance using the specified parameters.
      Classification createClassification(ClassificationScheme scheme, InternationalString name, String value)
      Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.
      Classification createClassification(ClassificationScheme scheme, String name, String value)
      Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.
      Classification createClassification(Concept concept)
      Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.
      ClassificationScheme createClassificationScheme(Concept concept)
      Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.
      ClassificationScheme createClassificationScheme(InternationalString name, InternationalString description)
      Creates a ClassificationScheme given the specified InternationalString parameters.
      ClassificationScheme createClassificationScheme(String name, String description)
      Creates a ClassificationScheme given the specified String parameters.
      Concept createConcept(RegistryObject parent, InternationalString name, String value)
      Creates a Concept instance using the specified parameters, where the name is an InternationalString.
      Concept createConcept(RegistryObject parent, String name, String value)
      Creates a Concept instance using the specified parameters, where the name is a String.
      EmailAddress createEmailAddress(String address)
      Creates an EmailAddress instance using an address as the parameter.
      EmailAddress createEmailAddress(String address, String type)
      Creates an EmailAddress instance using both an address and a type as parameters.
      ExternalIdentifier createExternalIdentifier(ClassificationScheme identificationScheme, InternationalString name, String value)
      Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.
      ExternalIdentifier createExternalIdentifier(ClassificationScheme identificationScheme, String name, String value)
      Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.
      ExternalLink createExternalLink(String externalURI, InternationalString description)
      Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.
      ExternalLink createExternalLink(String externalURI, String description)
      Creates an ExternalLink instance using the specified parameters, where the description is a String.
      ExtrinsicObject createExtrinsicObject(DataHandler repositoryItem)
      Creates an ExtrinsicObject instance using the specified parameters.
      InternationalString createInternationalString()
      Creates an empty InternationalString instance.
      InternationalString createInternationalString(Locale l, String s)
      Creates an InternationalString instance using the specified Locale and String parameters.
      InternationalString createInternationalString(String s)
      Creates an InternationalString instance using a String parameter and the default Locale.
      Key createKey(String id)
      Creates a Key instance from an ID.
      LocalizedString createLocalizedString(Locale l, String s)
      Creates a LocalizedString instance using the specified Locale and String parameters.
      LocalizedString createLocalizedString(Locale l, String s, String charSetName)
      Creates a LocalizedString instance using the specified Locale, String, and character set parameters.
      Object createObject(String interfaceName)
      Creates instances of information model interfaces (factory method).
      Organization createOrganization(InternationalString name)
      Creates an Organization instance using the specified name, where the name is an InternationalString.
      Organization createOrganization(String name)
      Creates an Organization instance using the specified name, where the name is a String.
      PersonName createPersonName(String fullName)
      Creates a PersonName instance using the specified full name.
      PersonName createPersonName(String firstName, String middleName, String lastName)
      Creates a PersonName instance using the specified first, middle, and last names.
      PostalAddress createPostalAddress(String streetNumber, String street, String city, String stateOrProvince, String country, String postalCode, String type)
      Creates a PostalAddress instance using the specified parameters.
      RegistryPackage createRegistryPackage(InternationalString name)
      Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.
      RegistryPackage createRegistryPackage(String name)
      Creates a RegistryPackage instance using the specified name, where the name is a String.
      Service createService(InternationalString name)
      Creates a Service instance using the specified name, where the name is an InternationalString.
      Service createService(String name)
      Creates a Service instance using the specified name, where the name is a String.
      ServiceBinding createServiceBinding()
      Creates an empty ServiceBinding instance.
      Slot createSlot(String name, Collection values, String slotType)
      Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.
      Slot createSlot(String name, String value, String slotType)
      Creates a Slot instance using the specified parameters, where the value is a String.
      SpecificationLink createSpecificationLink()
      Creates an empty SpecificationLink instance.
      TelephoneNumber createTelephoneNumber()
      Creates an empty TelephoneNumber instance.
      User createUser()
      Creates an empty User instance.
      BulkResponse deleteObjects(Collection keys)
      Deletes one or more previously submitted objects from the registry using the object keys.
      BulkResponse deleteObjects(Collection keys, String objectType)
      Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.
      BulkResponse deprecateObjects(Collection keys)
      Deprecates one or more previously submitted objects.
      RegistryService getRegistryService()
      Returns the parent RegistryService that created this object.
      BulkResponse saveObjects(Collection objects)
      Saves one or more Objects to the registry.
      BulkResponse unDeprecateObjects(Collection keys)
      Undeprecates one or more previously deprecated objects.

    • Field Detail

      • ASSOCIATION

        static final String ASSOCIATION
        Constant representing the javax.xml.registry.infomodel.Association interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • AUDITABLE_EVENT

        static final String AUDITABLE_EVENT
        Constant representing the javax.xml.registry.infomodel.AuditableEvent interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • CLASSIFICATION

        static final String CLASSIFICATION
        Constant representing the javax.xml.registry.infomodel.Classification interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • CLASSIFICATION_SCHEME

        static final String CLASSIFICATION_SCHEME
        Constant representing the javax.xml.registry.infomodel.ClassificationScheme interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • CONCEPT

        static final String CONCEPT
        Constant representing the javax.xml.registry.infomodel.Concept interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • EMAIL_ADDRESS

        static final String EMAIL_ADDRESS
        Constant representing the javax.xml.registry.infomodel.EmailAddress interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • EXTERNAL_IDENTIFIER

        static final String EXTERNAL_IDENTIFIER
        Constant representing the javax.xml.registry.infomodel.ExternalIdentifier interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • EXTERNAL_LINK

        static final String EXTERNAL_LINK
        Constant representing the javax.xml.registry.infomodel.ExternalLink interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • EXTRINSIC_OBJECT

        static final String EXTRINSIC_OBJECT
        Constant representing the javax.xml.registry.infomodel.ExternalLink interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • INTERNATIONAL_STRING

        static final String INTERNATIONAL_STRING
        Constant representing the javax.xml.registry.infomodel.InternationalString interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • KEY

        static final String KEY
        Constant representing the javax.xml.registry.infomodel.Key interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • LOCALIZED_STRING

        static final String LOCALIZED_STRING
        Constant representing the javax.xml.registry.infomodel.LocalizedString interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • ORGANIZATION

        static final String ORGANIZATION
        Constant representing the javax.xml.registry.infomodel.Organization interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • PERSON_NAME

        static final String PERSON_NAME
        Constant representing the javax.xml.registry.infomodel.PersonName interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • POSTAL_ADDRESS

        static final String POSTAL_ADDRESS
        Constant representing the javax.xml.registry.infomodel.PostalAddress interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • REGISTRY_ENTRY

        static final String REGISTRY_ENTRY
        Constant representing the javax.xml.registry.infomodel.RegistryEntry interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • REGISTRY_PACKAGE

        static final String REGISTRY_PACKAGE
        Constant representing the javax.xml.registry.infomodel.RegistryPackage interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • SERVICE

        static final String SERVICE
        Constant representing the javax.xml.registry.infomodel.Service interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • SERVICE_BINDING

        static final String SERVICE_BINDING
        Constant representing the javax.xml.registry.infomodel.ServiceBinding interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • SLOT

        static final String SLOT
        Constant representing the javax.xml.registry.infomodel.Slot interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • SPECIFICATION_LINK

        static final String SPECIFICATION_LINK
        Constant representing the javax.xml.registry.infomodel.SpecificationLink interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • TELEPHONE_NUMBER

        static final String TELEPHONE_NUMBER
        Constant representing the javax.xml.registry.infomodel.TelephoneNumber interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • USER

        static final String USER
        Constant representing the javax.xml.registry.infomodel.User interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

      • VERSIONABLE

        static final String VERSIONABLE
        Constant representing the javax.xml.registry.infomodel.Versionable interface.
        See Also:
        LifeCycleManager.createObject, Constant Field Values

    • Method Detail

      • createObject

        Object createObject(String interfaceName)
                    throws JAXRException,
                           InvalidRequestException,
                           UnsupportedCapabilityException
        Creates instances of information model interfaces (factory method). To create an Organization, use this method as follows:
         Organization org = (Organization)
    lifeCycleMgr.createObject(LifeCycleManager.ORGANIZATION);

        Capability Level: 0
        Parameters:
        interfaceName - the unqualified name of an interface in the javax.xml.registry.infomodel package
        Returns:
        an Object that can then be cast to an instance of the interface
        Throws:
        JAXRException - if the JAXR provider encounters an internal error
        InvalidRequestException - if the interface is not an interface in the javax.xml.registry.infomodel package
        UnsupportedCapabilityException - if the client attempts to create an instance of an infomodel interface that is not supported by the capability level of the JAXR provider

      • createAssociation

        Association createAssociation(RegistryObject targetObject,
                            Concept associationType)
                              throws JAXRException
        Creates an Association instance using the specified parameters. The sourceObject is left null and will be set when the Association is added to a RegistryObject.

        Note that for a UDDI provider an Association may only be created between Organizations.

        Capability Level: 0
        Parameters:
        targetObject - the target RegistryObject for the association
        associationType - the association type for the Association
        Returns:
        the Association instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createClassification

        Classification createClassification(ClassificationScheme scheme,
                                  String name,
                                  String value)
                                    throws JAXRException
        Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.

        Capability Level: 0
        Parameters:
        scheme - the ClassificationScheme to be used
        name - the name of the taxonomy element (a String)
        value - the value of the taxonomy element
        Returns:
        the Classification instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createClassification

        Classification createClassification(ClassificationScheme scheme,
                                  InternationalString name,
                                  String value)
                                    throws JAXRException
        Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.

        Capability Level: 0
        Parameters:
        scheme - the ClassificationScheme to be used
        name - the name of the taxonomy element (an InternationalString)
        value - the value of the taxonomy element
        Returns:
        the Classification instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createClassification

        Classification createClassification(Concept concept)
                                    throws JAXRException,
                                           InvalidRequestException
        Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.

        Capability Level: 0
        Parameters:
        concept - the Concept that identifies the taxonomy element
        Returns:
        the Classification instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error
        InvalidRequestException - if the Concept is not under a ClassificationScheme

      • createClassificationScheme

        ClassificationScheme createClassificationScheme(String name,
                                              String description)
                                                throws JAXRException,
                                                       InvalidRequestException
        Creates a ClassificationScheme given the specified String parameters.

        Capability Level: 0
        Parameters:
        name - the name of the ClassificationScheme (a String)
        description - a description of the ClassificationScheme (a String)
        Returns:
        the ClassificationScheme instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error
        InvalidRequestException

      • createClassificationScheme

        ClassificationScheme createClassificationScheme(InternationalString name,
                                              InternationalString description)
                                                throws JAXRException,
                                                       InvalidRequestException
        Creates a ClassificationScheme given the specified InternationalString parameters.

        Capability Level: 0
        Parameters:
        name - the name of the ClassificationScheme (an InternationalString)
        description - a description of the ClassificationScheme (an InternationalString)
        Returns:
        the ClassificationScheme instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error
        InvalidRequestException

      • createClassificationScheme

        ClassificationScheme createClassificationScheme(Concept concept)
                                                throws JAXRException,
                                                       InvalidRequestException
        Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.

        This method is a special-case method to do a type-safe conversion from Concept to ClassificationScheme.

        This method is provided to allow for Concepts returned by the BusinessQueryManager findConcepts call to be safely cast to ClassificationScheme. It is up to the programmer to make sure that the Concept is indeed semantically a ClassificationScheme.

        This method is necessary because in the UDDI specification a tModel may serve multiple purposes, and there is no way to know when a tModel maps to a Concept and when it maps to a ClassificationScheme. The UDDI specification leaves the determination to the programmer, and consequently so does this method.

        Capability Level: 0
        Parameters:
        concept - the Concept to be used
        Returns:
        the ClassificationScheme instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error
        InvalidRequestException - if the Concept has a parent Concept or is under a ClassificationScheme

      • createConcept

        Concept createConcept(RegistryObject parent,
                    String name,
                    String value)
                      throws JAXRException
        Creates a Concept instance using the specified parameters, where the name is a String.

        Capability Level: 0
        Parameters:
        parent - a reference either to a parent ClassificationScheme or to a Concept
        name - the name of the concept (a String)
        value - the value of the concept
        Returns:
        the Concept instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createConcept

        Concept createConcept(RegistryObject parent,
                    InternationalString name,
                    String value)
                      throws JAXRException
        Creates a Concept instance using the specified parameters, where the name is an InternationalString.

        Capability Level: 0
        Parameters:
        parent - a reference either to a parent ClassificationScheme or to a Concept
        name - the name of the concept (an InternationalString)
        value - the value of the concept
        Returns:
        the Concept instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createEmailAddress

        EmailAddress createEmailAddress(String address)
                                throws JAXRException
        Creates an EmailAddress instance using an address as the parameter.

        Capability Level: 0
        Parameters:
        address - the email address
        Returns:
        the EmailAddress instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createEmailAddress

        EmailAddress createEmailAddress(String address,
                              String type)
                                throws JAXRException
        Creates an EmailAddress instance using both an address and a type as parameters.

        Capability Level: 0
        Parameters:
        address - the email address
        type - the type of the address
        Returns:
        the EmailAddress instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createExternalIdentifier

        ExternalIdentifier createExternalIdentifier(ClassificationScheme identificationScheme,
                                          String name,
                                          String value)
                                            throws JAXRException
        Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.

        Capability Level: 0
        Parameters:
        identificationScheme - the ClassificationScheme used
        name - the name of the external identifier (a String)
        value - the value of the external identifier
        Returns:
        the ExternalIdentifier instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createExternalIdentifier

        ExternalIdentifier createExternalIdentifier(ClassificationScheme identificationScheme,
                                          InternationalString name,
                                          String value)
                                            throws JAXRException
        Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.

        Capability Level: 0
        Parameters:
        identificationScheme - the ClassificationScheme used
        name - the name of the external identifier (an InternationalString)
        value - the value of the external identifier
        Returns:
        the ExternalIdentifier instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createExternalLink

        ExternalLink createExternalLink(String externalURI,
                              String description)
                                throws JAXRException
        Creates an ExternalLink instance using the specified parameters, where the description is a String.

        Capability Level: 0
        Parameters:
        externalURI - the external URI
        description - a description of the link (a String)
        Returns:
        the ExternalLink instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createExternalLink

        ExternalLink createExternalLink(String externalURI,
                              InternationalString description)
                                throws JAXRException
        Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.

        Capability Level: 0
        Parameters:
        externalURI - the external URI
        description - a description of the link (an InternationalString)
        Returns:
        the ExternalLink instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createExtrinsicObject

        ExtrinsicObject createExtrinsicObject(DataHandler repositoryItem)
                                      throws JAXRException
        Creates an ExtrinsicObject instance using the specified parameters.

        Capability Level: 1
        Parameters:
        repositoryItem - the DataHandler for the repository item. Must not be null.
        Returns:
        the ExtrinsicObject instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createInternationalString

        InternationalString createInternationalString()
                                              throws JAXRException
        Creates an empty InternationalString instance.

        Capability Level: 0
        Returns:
        the InternationalString instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createInternationalString

        InternationalString createInternationalString(String s)
                                              throws JAXRException
        Creates an InternationalString instance using a String parameter and the default Locale.

        Capability Level: 0
        Parameters:
        s - the String from which to create the InternationalString
        Returns:
        the InternationalString instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createInternationalString

        InternationalString createInternationalString(Locale l,
                                            String s)
                                              throws JAXRException
        Creates an InternationalString instance using the specified Locale and String parameters.

        Capability Level: 0
        Parameters:
        l - the Locale in which to create the InternationalString
        s - the String from which to create the InternationalString
        Returns:
        the InternationalString instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createKey

        Key createKey(String id)
              throws JAXRException
        Creates a Key instance from an ID.

        Capability Level: 0
        Parameters:
        id - the ID string from which to create the Key
        Returns:
        the Key instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createLocalizedString

        LocalizedString createLocalizedString(Locale l,
                                    String s)
                                      throws JAXRException
        Creates a LocalizedString instance using the specified Locale and String parameters.

        Capability Level: 0
        Parameters:
        l - the Locale in which to create the LocalizedString
        s - the String from which to create the LocalizedString
        Returns:
        the LocalizedString instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createLocalizedString

        LocalizedString createLocalizedString(Locale l,
                                    String s,
                                    String charSetName)
                                      throws JAXRException
        Creates a LocalizedString instance using the specified Locale, String, and character set parameters.

        Capability Level: 0
        Parameters:
        l - the Locale in which to create the LocalizedString
        s - the String from which to create the LocalizedString
        charSetName - the name of the character set to use
        Returns:
        the LocalizedString instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createOrganization

        Organization createOrganization(String name)
                                throws JAXRException
        Creates an Organization instance using the specified name, where the name is a String.

        Capability Level: 0
        Parameters:
        name - the name of the Organization
        Returns:
        the Organization instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createOrganization

        Organization createOrganization(InternationalString name)
                                throws JAXRException
        Creates an Organization instance using the specified name, where the name is an InternationalString.

        Capability Level: 0
        Parameters:
        name - the name of the Organization
        Returns:
        the Organization instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createPersonName

        PersonName createPersonName(String firstName,
                          String middleName,
                          String lastName)
                            throws JAXRException
        Creates a PersonName instance using the specified first, middle, and last names.

        Capability Level: 1
        Parameters:
        firstName - the person's first name
        middleName - the person's middle name
        lastName - the person's last name
        Returns:
        the PersonName instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createPersonName

        PersonName createPersonName(String fullName)
                            throws JAXRException
        Creates a PersonName instance using the specified full name.

        Capability Level: 0
        Parameters:
        fullName - the person's full name
        Returns:
        the PersonName instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createPostalAddress

        PostalAddress createPostalAddress(String streetNumber,
                                String street,
                                String city,
                                String stateOrProvince,
                                String country,
                                String postalCode,
                                String type)
                                  throws JAXRException
        Creates a PostalAddress instance using the specified parameters.

        Capability Level: 0
        Parameters:
        streetNumber - the street number
        street - the street name
        city - the city name
        stateOrProvince - the state or province name
        country - the country name
        postalCode - the postal code (such as a US ZIP code)
        type - the type of the address
        Returns:
        the PostalAddress instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createRegistryPackage

        RegistryPackage createRegistryPackage(String name)
                                      throws JAXRException
        Creates a RegistryPackage instance using the specified name, where the name is a String.

        Capability Level: 1
        Parameters:
        name - the name of the registry package (a String)
        Returns:
        the RegistryPackage instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createRegistryPackage

        RegistryPackage createRegistryPackage(InternationalString name)
                                      throws JAXRException
        Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.

        Capability Level: 1
        Parameters:
        name - the name of the registry package (an InternationalString)
        Returns:
        the RegistryPackage instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createService

        Service createService(String name)
                      throws JAXRException
        Creates a Service instance using the specified name, where the name is a String.

        Capability Level: 0
        Parameters:
        name - the name of the Service (a String)
        Returns:
        the Service instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createService

        Service createService(InternationalString name)
                      throws JAXRException
        Creates a Service instance using the specified name, where the name is an InternationalString.

        Capability Level: 0
        Parameters:
        name - the name of the Service (an InternationalString)
        Returns:
        the Service instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createServiceBinding

        ServiceBinding createServiceBinding()
                                    throws JAXRException
        Creates an empty ServiceBinding instance.

        Capability Level: 0
        Returns:
        the ServiceBinding instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createSlot

        Slot createSlot(String name,
              String value,
              String slotType)
                throws JAXRException
        Creates a Slot instance using the specified parameters, where the value is a String.

        Capability Level: 0
        Parameters:
        name - the name of the Slot
        value - the value (a String)
        slotType - the slot type
        Returns:
        the Slot instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createSlot

        Slot createSlot(String name,
              Collection values,
              String slotType)
                throws JAXRException
        Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.

        Capability Level: 0
        Parameters:
        name - the name of the Slot
        value - the value (a Collection of Strings)
        slotType - the slot type
        Returns:
        the Slot instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createSpecificationLink

        SpecificationLink createSpecificationLink()
                                          throws JAXRException
        Creates an empty SpecificationLink instance.

        Capability Level: 0
        Returns:
        the SpecificationLink instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createTelephoneNumber

        TelephoneNumber createTelephoneNumber()
                                      throws JAXRException
        Creates an empty TelephoneNumber instance.

        Capability Level: 0
        Returns:
        the TelephoneNumber instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • createUser

        User createUser()
                throws JAXRException
        Creates an empty User instance.

        Capability Level: 0
        Returns:
        the User instance created
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • saveObjects

        BulkResponse saveObjects(Collection objects)
                         throws JAXRException
        Saves one or more Objects to the registry. An object may be a RegistryObject subclass instance.

        If an object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, then its state is updated (replaced) in the registry.

        Capability Level: 0
        Parameters:
        objects - a potentially heterogeneous Collection of RegistryObject instances
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • deprecateObjects

        BulkResponse deprecateObjects(Collection keys)
                              throws JAXRException
        Deprecates one or more previously submitted objects. Deprecation marks an object as "soon to be deleted". Once an object is deprecated, the JAXR provider must not allow any new references (e.g. new Associations, Classifications and ExternalLinks) to that object to be submitted. If a client makes an API call that results in a new reference to a deprecated object, the JAXR provider must throw a java.lang.IllegalStateException within a JAXRException. However, existing references to a deprecated object continue to function normally.

        Capability Level: 1
        Parameters:
        keys - a Collection of keys for the objects to be deprecated
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were deprecated successfully and any JAXRException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • unDeprecateObjects

        BulkResponse unDeprecateObjects(Collection keys)
                                throws JAXRException
        Undeprecates one or more previously deprecated objects. If an object was not previously deprecated, it is not an error, and no exception is thrown. Once an object is undeprecated, the JAXR provider must again allow new references (e.g. new Associations, Classifications and ExternalLinks) to that object to be submitted.

        Capability Level: 1
        Parameters:
        keys - a Collection of keys for the objects to be undeprecated
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were deprecated successfully and any JAXRException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • deleteObjects

        BulkResponse deleteObjects(Collection keys)
                           throws JAXRException
        Deletes one or more previously submitted objects from the registry using the object keys.

        Capability Level: 1
        Parameters:
        keys - a Collection of keys for the objects to be deleted
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • deleteObjects

        BulkResponse deleteObjects(Collection keys,
                         String objectType)
                           throws JAXRException
        Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.

        Capability Level: 0
        Parameters:
        keys - a Collection of keys for the objects to be deleted
        objectType - the objectType attribute for the objects to be deleted
        Returns:
        a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
        Throws:
        JAXRException - if the JAXR provider encounters an internal error

      • getRegistryService

        RegistryService getRegistryService()
                                   throws JAXRException
        Returns the parent RegistryService that created this object.

        Capability Level: 0
        Returns:
        the parent RegistryService
        Throws:
        JAXRException - if the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Query (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface Query

  • public interface Query
    The Query interface encapsulates a query in a declarative query language. Currently a Query can be an SQL query or an ebXML Filter Query only. In future support for other query languages such as XQL query may be added. The query must conform to a fixed schema as defined by the JAXR specification.
    Author:
    Farrukh S. Najmi

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int QUERY_TYPE_EBXML_FILTER_QUERY
      An OASIS ebXML Registry XML Filter Query type.
      static int QUERY_TYPE_SQL
      An SQL query type.
      static int QUERY_TYPE_XQUERY
      A W3C XQuery type.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getType()
      Gets the type of Query (for example, QUERY_TYPE_SQL).
      String toString()
      Returns the String representing the query.

    • Field Detail

      • QUERY_TYPE_SQL

        static final int QUERY_TYPE_SQL
        An SQL query type.
        See Also:
        Constant Field Values

      • QUERY_TYPE_XQUERY

        static final int QUERY_TYPE_XQUERY
        A W3C XQuery type.
        See Also:
        Constant Field Values

      • QUERY_TYPE_EBXML_FILTER_QUERY

        static final int QUERY_TYPE_EBXML_FILTER_QUERY
        An OASIS ebXML Registry XML Filter Query type.
        See Also:
        Constant Field Values

    • Method Detail

      • getType

        int getType()
            throws JAXRException
        Gets the type of Query (for example, QUERY_TYPE_SQL).

        Capability Level: 1
        Returns:
        the type of query
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        QUERY_TYPE_SQL, QUERY_TYPE_XQUERY, QUERY_TYPE_EBXML_FILTER_QUERY

      • toString

        String toString()
        Returns the String representing the query. For example, in the case of an SQL query, returns the SQL query as a string.

        Capability Level: 1
        Overrides:
        toString in class Object
        Returns:
        the String representation for this query
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QueryManager (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface QueryManager

  • All Known Subinterfaces:
    BusinessQueryManager, DeclarativeQueryManager

    public interface QueryManager
    This is the common base interface for all QueryManagers in the API.
    Author:
    Farrukh S. Najmi

    • Method Summary

      Methods
      Modifier and Type Method and Description
      RegistryObject getRegistryObject(String id)
      Gets the RegistryObject specified by the Id.
      RegistryObject getRegistryObject(String id, String objectType)
      Gets the RegistryObject specified by the Id and type of object.
      BulkResponse getRegistryObjects()
      Gets the RegistryObjects owned by the caller.
      BulkResponse getRegistryObjects(Collection objectKeys)
      Gets the specified RegistryObjects.
      BulkResponse getRegistryObjects(Collection objectKeys, String objectTypes)
      Gets the specified RegistryObjects.
      BulkResponse getRegistryObjects(String objectType)
      Gets the RegistryObjects owned by the caller, that are of the specified type.
      RegistryService getRegistryService()
      Returns the parent RegistryService that created this object.

    • Method Detail

      • getRegistryObject

        RegistryObject getRegistryObject(String id,
                               String objectType)
                                 throws JAXRException
        Gets the RegistryObject specified by the Id and type of object.

        Capability Level: 0
        Parameters:
        id - is the id of the Key for a RegistryObject.
        objectType - is a constant definition from LifeCycleManager that specifies the type of object desired.
        Returns:
        the RegistryObject, returned as its concrete type (e.g. Organization, User etc.).
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getRegistryObject

        RegistryObject getRegistryObject(String id)
                                 throws JAXRException
        Gets the RegistryObject specified by the Id.

        Capability Level: 1
        Parameters:
        id - the id for the desired object
        Returns:
        the RegistryObject, returned as its concrete type (e.g. Organization, User etc.).
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getRegistryObjects

        BulkResponse getRegistryObjects(Collection objectKeys)
                                throws JAXRException
        Gets the specified RegistryObjects. The objects are returned as their concrete type (e.g. Organization, User etc.).

        Capability Level: 1
        Parameters:
        objectKeys - a Collection of Key objects for the desired objects
        Returns:
        BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getRegistryObjects

        BulkResponse getRegistryObjects(Collection objectKeys,
                              String objectTypes)
                                throws JAXRException
        Gets the specified RegistryObjects. The objects are returned as their concrete type (e.g. Organization, User etc.).

        Capability Level: 0
        Parameters:
        objectKeys - a Collection of Key objects for the desired objects
        objectTypes - a Collection of String objects that allow filtering desired objects by their type
        Returns:
        BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getRegistryObjects

        BulkResponse getRegistryObjects()
                                throws JAXRException
        Gets the RegistryObjects owned by the caller. The objects are returned as their concrete type (e.g. Organization, User etc.).

        Capability Level: 0
        Returns:
        BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getRegistryObjects

        BulkResponse getRegistryObjects(String objectType)
                                throws JAXRException
        Gets the RegistryObjects owned by the caller, that are of the specified type. The objects are returned as their concrete type (e.g. Organization, User etc.).

        Capability Level: 0
        Parameters:
        objectType - Is a constant that defines the type of object sought. See LifeCycleManager for constants for object types.
        Returns:
        BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        LifeCycleManager.ORGANIZATION

      • getRegistryService

        RegistryService getRegistryService()
                                   throws JAXRException
        Returns the parent RegistryService that created this object.

        Capability Level: 0
        Returns:
        the RegistryService created this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RegistryException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Class RegistryException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.registry.JAXRException
          • javax.xml.registry.RegistryException
  • All Implemented Interfaces:
    Serializable, JAXRResponse
    Direct Known Subclasses:
    DeleteException, FindException, SaveException

    public class RegistryException
extends JAXRException
    This is the common base class for all Exceptions that are detected on the registry provider side rather than the JAXR client side.
    Author:
    Farrukh S. Najmi
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.xml.registry.JAXRException

        cause

      • Fields inherited from interface javax.xml.registry.JAXRResponse

        STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      RegistryException()
      Constructs a JAXRException object with no reason or embedded Throwable.
      RegistryException(String reason)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown.
      RegistryException(String reason, Throwable cause)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
      RegistryException(Throwable cause)
      Constructs a JAXRException object initialized with the given Throwable object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Key getErrorObjectKey()
      Gets the Key to the first object that encountered an error in the registry.
      void setErrorObjectKey(Key key)
      Sets the Key to the first object that encountered an error in the registry.

      • Methods inherited from class javax.xml.registry.JAXRException

        getCause, getMessage, getRequestId, getStatus, initCause, isAvailable

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • RegistryException

        public RegistryException()
        Constructs a JAXRException object with no reason or embedded Throwable.

      • RegistryException

        public RegistryException(String reason)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown.
        Parameters:
        reason - a description of what caused the exception

      • RegistryException

        public RegistryException(String reason,
                 Throwable cause)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
        Parameters:
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this JAXRException object

      • RegistryException

        public RegistryException(Throwable cause)
        Constructs a JAXRException object initialized with the given Throwable object.
        Parameters:
        cause - the Throwable that caused this Exception

    • Method Detail

      • getErrorObjectKey

        public Key getErrorObjectKey()
                      throws JAXRException
        Gets the Key to the first object that encountered an error in the registry.
        Returns:
        the key to the first object in error
        Throws:
        JAXRException

      • setErrorObjectKey

        public void setErrorObjectKey(Key key)
                       throws JAXRException
        Sets the Key to the first object that encountered an error in the registry.
        Parameters:
        key - the key to the first object in error
        Throws:
        JAXRException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RegistryService (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Interface RegistryService

  • public interface RegistryService
    This is the principal interface implemented by a JAXR provider. A registry client can get this interface from a Connection to a registry. It provides the methods that are used by the client to discover various capability specific interfaces implemented by the JAXR provider.
    Author:
    Farrukh S. Najmi
    See Also:
    Connection

    • Method Summary

      Methods
      Modifier and Type Method and Description
      BulkResponse getBulkResponse(String requestId)
      Returns the BulkResponse associated with specified requestId.
      BusinessLifeCycleManager getBusinessLifeCycleManager()
      Returns the BusinessLifeCycleManager object implemented by the JAXR provider.
      BusinessQueryManager getBusinessQueryManager()
      Returns the BusinessQueryManager object implemented by the JAXR provider.
      CapabilityProfile getCapabilityProfile()
      Returns the CapabilityProfile for the JAXR provider.
      DeclarativeQueryManager getDeclarativeQueryManager()
      Returns the DeclarativeQueryManager object implemented by the JAXR provider.
      ClassificationScheme getDefaultPostalScheme()
      Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.
      String makeRegistrySpecificRequest(String request)
      Takes a String that is an XML request in a registry-specific format, sends the request to the registry, and returns a String that is the registry-specific XML response.

    • Method Detail

      • getCapabilityProfile

        CapabilityProfile getCapabilityProfile()
                                       throws JAXRException
        Returns the CapabilityProfile for the JAXR provider.

        Capability Level: 0
        Returns:
        the CapabilityProfile for a JAXR provider
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        LifeCycleManager

      • getBusinessLifeCycleManager

        BusinessLifeCycleManager getBusinessLifeCycleManager()
                                                     throws JAXRException
        Returns the BusinessLifeCycleManager object implemented by the JAXR provider.

        Capability Level: 0
        Returns:
        the BusinessLifeCycleManager
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        LifeCycleManager

      • getBusinessQueryManager

        BusinessQueryManager getBusinessQueryManager()
                                             throws JAXRException
        Returns the BusinessQueryManager object implemented by the JAXR provider.

        Capability Level: 0
        Returns:
        the BusinessQueryManaer
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getDeclarativeQueryManager

        DeclarativeQueryManager getDeclarativeQueryManager()
                                                   throws JAXRException,
                                                          UnsupportedCapabilityException
        Returns the DeclarativeQueryManager object implemented by the JAXR provider.

        Capability Level: 1
        Returns:
        the DeclarativeQueryManager
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        UnsupportedCapabilityException

      • getBulkResponse

        BulkResponse getBulkResponse(String requestId)
                             throws InvalidRequestException,
                                    JAXRException
        Returns the BulkResponse associated with specified requestId. Once a client retrieves a BulkResponse for a particular requestId any subsequent calls to retrieve the Bulkresponse for the same requestId should result in an InvalidRequestException.

        Capability Level: 0
        Parameters:
        requestId - the id for a previous asynchronous request
        Returns:
        the BulkResponse that contains the result for the specified request
        Throws:
        InvalidRequestException - if no responses exist for specified requestId
        JAXRException - If the JAXR provider encounters an internal error

      • getDefaultPostalScheme

        ClassificationScheme getDefaultPostalScheme()
                                            throws JAXRException
        Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.

        Capability Level: 0
        Returns:
        the ClassificationScheme that is the default postal scheme
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • makeRegistrySpecificRequest

        String makeRegistrySpecificRequest(String request)
                                   throws JAXRException
        Takes a String that is an XML request in a registry-specific format, sends the request to the registry, and returns a String that is the registry-specific XML response.

        Capability Level: 0
        Parameters:
        request - the registry-specific request in a String representation
        Returns:
        the String that is the XML response in a registry-specific manner
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SaveException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Class SaveException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.registry.JAXRException
          • javax.xml.registry.RegistryException
            • javax.xml.registry.SaveException
  • All Implemented Interfaces:
    Serializable, JAXRResponse

    public class SaveException
extends RegistryException
    A RegistryException that occurs during a save action.
    Author:
    Farrukh S. Najmi
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.xml.registry.JAXRException

        cause

      • Fields inherited from interface javax.xml.registry.JAXRResponse

        STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      SaveException()
      Constructs a JAXRException object with no reason or embedded Throwable.
      SaveException(String reason)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown.
      SaveException(String reason, Throwable cause)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
      SaveException(Throwable cause)
      Constructs a JAXRException object initialized with the given Throwable object.

    • Method Summary

      • Methods inherited from class javax.xml.registry.RegistryException

        getErrorObjectKey, setErrorObjectKey

      • Methods inherited from class javax.xml.registry.JAXRException

        getCause, getMessage, getRequestId, getStatus, initCause, isAvailable

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SaveException

        public SaveException()
        Constructs a JAXRException object with no reason or embedded Throwable.

      • SaveException

        public SaveException(String reason)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown.
        Parameters:
        reason - a description of what caused the exception

      • SaveException

        public SaveException(String reason,
             Throwable cause)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
        Parameters:
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this JAXRException object

      • SaveException

        public SaveException(Throwable cause)
        Constructs a JAXRException object initialized with the given Throwable object.
        Parameters:
        cause - the Throwable that caused this Exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UnexpectedObjectException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Class UnexpectedObjectException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.registry.JAXRException
          • javax.xml.registry.UnexpectedObjectException
  • All Implemented Interfaces:
    Serializable, JAXRResponse

    public class UnexpectedObjectException
extends JAXRException
    This exception is thrown when the JAXR provider finds a Object that is out-of-place or of the wrong type within the context of a user request. For example a saveOrganizations request in BusinessLifeCycleManager would throw this Exception if it found an Object other than Organization in the Collection of Objects provided by client to be saved by the request.
    Author:
    Farrukh S. Najmi
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.xml.registry.JAXRException

        cause

      • Fields inherited from interface javax.xml.registry.JAXRResponse

        STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      UnexpectedObjectException()
      Constructs a JAXRException object with no reason or embedded Throwable.
      UnexpectedObjectException(String reason)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown.
      UnexpectedObjectException(String reason, Throwable cause)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
      UnexpectedObjectException(Throwable cause)
      Constructs a JAXRException object initialized with the given Throwable object.

    • Method Summary

      • Methods inherited from class javax.xml.registry.JAXRException

        getCause, getMessage, getRequestId, getStatus, initCause, isAvailable

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnexpectedObjectException

        public UnexpectedObjectException()
        Constructs a JAXRException object with no reason or embedded Throwable.

      • UnexpectedObjectException

        public UnexpectedObjectException(String reason)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown.
        Parameters:
        reason - a description of what caused the exception

      • UnexpectedObjectException

        public UnexpectedObjectException(String reason,
                         Throwable cause)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
        Parameters:
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this JAXRException object

      • UnexpectedObjectException

        public UnexpectedObjectException(Throwable cause)
        Constructs a JAXRException object initialized with the given Throwable object.
        Parameters:
        cause - the Throwable that caused this Exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UnsupportedCapabilityException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry

Class UnsupportedCapabilityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.registry.JAXRException
          • javax.xml.registry.UnsupportedCapabilityException
  • All Implemented Interfaces:
    Serializable, JAXRResponse

    public class UnsupportedCapabilityException
extends JAXRException
    This exception must be thrown when a JAXR client attempts to invoke an API method that is not supported by the capability profile that is supported by the JAXR provider.
    Author:
    Farrukh S. Najmi
    See Also:
    RegistryService, Serialized Form

    • Field Summary

      • Fields inherited from class javax.xml.registry.JAXRException

        cause

      • Fields inherited from interface javax.xml.registry.JAXRResponse

        STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      UnsupportedCapabilityException()
      Constructs a JAXRException object with no reason or embedded Throwable.
      UnsupportedCapabilityException(String reason)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown.
      UnsupportedCapabilityException(String reason, Throwable cause)
      Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
      UnsupportedCapabilityException(Throwable cause)
      Constructs a JAXRException object initialized with the given Throwable object.

    • Method Summary

      • Methods inherited from class javax.xml.registry.JAXRException

        getCause, getMessage, getRequestId, getStatus, initCause, isAvailable

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnsupportedCapabilityException

        public UnsupportedCapabilityException()
        Constructs a JAXRException object with no reason or embedded Throwable.

      • UnsupportedCapabilityException

        public UnsupportedCapabilityException(String reason)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown.
        Parameters:
        reason - a description of what caused the exception

      • UnsupportedCapabilityException

        public UnsupportedCapabilityException(String reason,
                              Throwable cause)
        Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
        Parameters:
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this JAXRException object

      • UnsupportedCapabilityException

        public UnsupportedCapabilityException(Throwable cause)
        Constructs a JAXRException object initialized with the given Throwable object.
        Parameters:
        cause - the Throwable that caused this Exception
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.registry (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.registry

  • Packages that use javax.xml.registry
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.
  • Classes in javax.xml.registry used by javax.xml.registry
    Class and Description
    BulkResponse
    Contains the response of a method in the API that performs a bulk operation and returns a bulk response.
    BusinessLifeCycleManager
    The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API.
    BusinessQueryManager
    The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface.
    CapabilityProfile
    Provides information about the capabilities of a JAXR provider.
    Connection
    This class represents a connection between a JAXR client and a JAXR provider.
    ConnectionFactory
    This is the abstract base class for factory classes for creating a JAXR connection.
    DeclarativeQueryManager
    This interface provides the ability to execute declarative queries (e.g.
    FederatedConnection
    Represents a single logical connection to a federation or group of registry providers.
    InvalidRequestException
    This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.
    JAXRException
    Signals that a JAXR exception has occurred.
    JAXRResponse
    A JAXR requests' response.
    LifeCycleManager
    The LifeCycleManager interface is the main interface in the API for managing life cycle operations on objects defined by the information model.
    Query
    The Query interface encapsulates a query in a declarative query language.
    QueryManager
    This is the common base interface for all QueryManagers in the API.
    RegistryException
    This is the common base class for all Exceptions that are detected on the registry provider side rather than the JAXR client side.
    RegistryService
    This is the principal interface implemented by a JAXR provider.
    UnsupportedCapabilityException
    This exception must be thrown when a JAXR client attempts to invoke an API method that is not supported by the capability profile that is supported by the JAXR provider.
  • Classes in javax.xml.registry used by javax.xml.registry.infomodel
    Class and Description
    JAXRException
    Signals that a JAXR exception has occurred.
    LifeCycleManager
    The LifeCycleManager interface is the main interface in the API for managing life cycle operations on objects defined by the information model.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.registry.ConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.registry.ConnectionFactory

  • Packages that use ConnectionFactory
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of ConnectionFactory in javax.xml.registry

      Methods in javax.xml.registry that return ConnectionFactory
      Modifier and Type Method and Description
      static ConnectionFactory ConnectionFactory.newInstance()
      Creates a default ConnectionFactory object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.registry.DeleteException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.registry.DeleteException

No usage of javax.xml.registry.DeleteException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.registry.FindException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.registry.FindException

No usage of javax.xml.registry.FindException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.registry.InvalidRequestException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.registry.InvalidRequestException

  • Packages that use InvalidRequestException
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of InvalidRequestException in javax.xml.registry

      Methods in javax.xml.registry that throw InvalidRequestException
      Modifier and Type Method and Description
      void BusinessLifeCycleManager.confirmAssociation(Association assoc)
      Confirms this Association by the User associated with the caller.
      Classification LifeCycleManager.createClassification(Concept concept)
      Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.
      ClassificationScheme LifeCycleManager.createClassificationScheme(Concept concept)
      Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.
      ClassificationScheme LifeCycleManager.createClassificationScheme(InternationalString name, InternationalString description)
      Creates a ClassificationScheme given the specified InternationalString parameters.
      ClassificationScheme LifeCycleManager.createClassificationScheme(String name, String description)
      Creates a ClassificationScheme given the specified String parameters.
      Object LifeCycleManager.createObject(String interfaceName)
      Creates instances of information model interfaces (factory method).
      Query DeclarativeQueryManager.createQuery(int queryType, String queryString)
      Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.
      BulkResponse RegistryService.getBulkResponse(String requestId)
      Returns the BulkResponse associated with specified requestId.
      void BusinessLifeCycleManager.unConfirmAssociation(Association assoc)
      Undoes a previous confirmation of this Association by the User associated with the caller.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.registry.JAXRException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.registry.JAXRException

  • Packages that use JAXRException
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of JAXRException in javax.xml.registry

      Subclasses of JAXRException in javax.xml.registry
      Modifier and Type Class and Description
      class  DeleteException
      A RegistryException that occurs during a delete action.
      class  FindException
      A RegistryException that occurs during a find action.
      class  InvalidRequestException
      This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.
      class  RegistryException
      This is the common base class for all Exceptions that are detected on the registry provider side rather than the JAXR client side.
      class  SaveException
      A RegistryException that occurs during a save action.
      class  UnexpectedObjectException
      This exception is thrown when the JAXR provider finds a Object that is out-of-place or of the wrong type within the context of a user request.
      class  UnsupportedCapabilityException
      This exception must be thrown when a JAXR client attempts to invoke an API method that is not supported by the capability profile that is supported by the JAXR provider.
      Methods in javax.xml.registry that throw JAXRException
      Modifier and Type Method and Description
      void Connection.close()
      Closes a Connection when it is no longer needed.
      void BusinessLifeCycleManager.confirmAssociation(Association assoc)
      Confirms this Association by the User associated with the caller.
      Association LifeCycleManager.createAssociation(RegistryObject targetObject, Concept associationType)
      Creates an Association instance using the specified parameters.
      Classification LifeCycleManager.createClassification(ClassificationScheme scheme, InternationalString name, String value)
      Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.
      Classification LifeCycleManager.createClassification(ClassificationScheme scheme, String name, String value)
      Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.
      Classification LifeCycleManager.createClassification(Concept concept)
      Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.
      ClassificationScheme LifeCycleManager.createClassificationScheme(Concept concept)
      Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.
      ClassificationScheme LifeCycleManager.createClassificationScheme(InternationalString name, InternationalString description)
      Creates a ClassificationScheme given the specified InternationalString parameters.
      ClassificationScheme LifeCycleManager.createClassificationScheme(String name, String description)
      Creates a ClassificationScheme given the specified String parameters.
      Concept LifeCycleManager.createConcept(RegistryObject parent, InternationalString name, String value)
      Creates a Concept instance using the specified parameters, where the name is an InternationalString.
      Concept LifeCycleManager.createConcept(RegistryObject parent, String name, String value)
      Creates a Concept instance using the specified parameters, where the name is a String.
      abstract Connection ConnectionFactory.createConnection()
      Create a named connection.
      EmailAddress LifeCycleManager.createEmailAddress(String address)
      Creates an EmailAddress instance using an address as the parameter.
      EmailAddress LifeCycleManager.createEmailAddress(String address, String type)
      Creates an EmailAddress instance using both an address and a type as parameters.
      ExternalIdentifier LifeCycleManager.createExternalIdentifier(ClassificationScheme identificationScheme, InternationalString name, String value)
      Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.
      ExternalIdentifier LifeCycleManager.createExternalIdentifier(ClassificationScheme identificationScheme, String name, String value)
      Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.
      ExternalLink LifeCycleManager.createExternalLink(String externalURI, InternationalString description)
      Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.
      ExternalLink LifeCycleManager.createExternalLink(String externalURI, String description)
      Creates an ExternalLink instance using the specified parameters, where the description is a String.
      ExtrinsicObject LifeCycleManager.createExtrinsicObject(DataHandler repositoryItem)
      Creates an ExtrinsicObject instance using the specified parameters.
      abstract FederatedConnection ConnectionFactory.createFederatedConnection(Collection connections)
      Create a FederatedConnection.
      InternationalString LifeCycleManager.createInternationalString()
      Creates an empty InternationalString instance.
      InternationalString LifeCycleManager.createInternationalString(Locale l, String s)
      Creates an InternationalString instance using the specified Locale and String parameters.
      InternationalString LifeCycleManager.createInternationalString(String s)
      Creates an InternationalString instance using a String parameter and the default Locale.
      Key LifeCycleManager.createKey(String id)
      Creates a Key instance from an ID.
      LocalizedString LifeCycleManager.createLocalizedString(Locale l, String s)
      Creates a LocalizedString instance using the specified Locale and String parameters.
      LocalizedString LifeCycleManager.createLocalizedString(Locale l, String s, String charSetName)
      Creates a LocalizedString instance using the specified Locale, String, and character set parameters.
      Object LifeCycleManager.createObject(String interfaceName)
      Creates instances of information model interfaces (factory method).
      Organization LifeCycleManager.createOrganization(InternationalString name)
      Creates an Organization instance using the specified name, where the name is an InternationalString.
      Organization LifeCycleManager.createOrganization(String name)
      Creates an Organization instance using the specified name, where the name is a String.
      PersonName LifeCycleManager.createPersonName(String fullName)
      Creates a PersonName instance using the specified full name.
      PersonName LifeCycleManager.createPersonName(String firstName, String middleName, String lastName)
      Creates a PersonName instance using the specified first, middle, and last names.
      PostalAddress LifeCycleManager.createPostalAddress(String streetNumber, String street, String city, String stateOrProvince, String country, String postalCode, String type)
      Creates a PostalAddress instance using the specified parameters.
      Query DeclarativeQueryManager.createQuery(int queryType, String queryString)
      Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.
      RegistryPackage LifeCycleManager.createRegistryPackage(InternationalString name)
      Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.
      RegistryPackage LifeCycleManager.createRegistryPackage(String name)
      Creates a RegistryPackage instance using the specified name, where the name is a String.
      Service LifeCycleManager.createService(InternationalString name)
      Creates a Service instance using the specified name, where the name is an InternationalString.
      Service LifeCycleManager.createService(String name)
      Creates a Service instance using the specified name, where the name is a String.
      ServiceBinding LifeCycleManager.createServiceBinding()
      Creates an empty ServiceBinding instance.
      Slot LifeCycleManager.createSlot(String name, Collection values, String slotType)
      Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.
      Slot LifeCycleManager.createSlot(String name, String value, String slotType)
      Creates a Slot instance using the specified parameters, where the value is a String.
      SpecificationLink LifeCycleManager.createSpecificationLink()
      Creates an empty SpecificationLink instance.
      TelephoneNumber LifeCycleManager.createTelephoneNumber()
      Creates an empty TelephoneNumber instance.
      User LifeCycleManager.createUser()
      Creates an empty User instance.
      BulkResponse BusinessLifeCycleManager.deleteAssociations(Collection associationKeys)
      Deletes the Associations corresponding to the specified Keys.
      BulkResponse BusinessLifeCycleManager.deleteClassificationSchemes(Collection schemeKeys)
      Deletes the ClassificationSchemes corresponding to the specified Keys.
      BulkResponse BusinessLifeCycleManager.deleteConcepts(Collection conceptKeys)
      Deletes the Concepts corresponding to the specified Keys.
      BulkResponse LifeCycleManager.deleteObjects(Collection keys)
      Deletes one or more previously submitted objects from the registry using the object keys.
      BulkResponse LifeCycleManager.deleteObjects(Collection keys, String objectType)
      Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.
      BulkResponse BusinessLifeCycleManager.deleteOrganizations(Collection organizationKeys)
      Deletes the organizations corresponding to the specified Keys.
      BulkResponse BusinessLifeCycleManager.deleteServiceBindings(Collection bindingKeys)
      Deletes the ServiceBindings corresponding to the specified Keys.
      BulkResponse BusinessLifeCycleManager.deleteServices(Collection serviceKeys)
      Deletes the services corresponding to the specified Keys.
      BulkResponse LifeCycleManager.deprecateObjects(Collection keys)
      Deprecates one or more previously submitted objects.
      BulkResponse DeclarativeQueryManager.executeQuery(Query query)
      Executes a query as specified by query parameter.
      BulkResponse BusinessQueryManager.findAssociations(Collection findQualifiers, String sourceObjectId, String targetObjectId, Collection associationTypes)
      Finds all Association objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findCallerAssociations(Collection findQualifiers, Boolean confirmedByCaller, Boolean confirmedByOtherParty, Collection associationTypes)
      Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call.
      ClassificationScheme BusinessQueryManager.findClassificationSchemeByName(Collection findQualifiers, String namePattern)
      Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.
      BulkResponse BusinessQueryManager.findClassificationSchemes(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalLinks)
      Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call.
      Concept BusinessQueryManager.findConceptByPath(String path)
      Finds a Concept based on the path specified.
      BulkResponse BusinessQueryManager.findConcepts(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalIdentifiers, Collection externalLinks)
      Finds all Concept objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findOrganizations(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications, Collection externalIdentifiers, Collection externalLinks)
      Finds all Organization objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findRegistryPackages(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalLinks)
      Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findServiceBindings(Key serviceKey, Collection findQualifiers, Collection classifications, Collection specifications)
      Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findServices(Key orgKey, Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications)
      Finds all Service objects that match all of the criteria specified by the parameters of this call.
      BulkResponse RegistryService.getBulkResponse(String requestId)
      Returns the BulkResponse associated with specified requestId.
      BusinessLifeCycleManager RegistryService.getBusinessLifeCycleManager()
      Returns the BusinessLifeCycleManager object implemented by the JAXR provider.
      BusinessQueryManager RegistryService.getBusinessQueryManager()
      Returns the BusinessQueryManager object implemented by the JAXR provider.
      int CapabilityProfile.getCapabilityLevel()
      Gets the capability level supported by the JAXR provider.
      CapabilityProfile RegistryService.getCapabilityProfile()
      Returns the CapabilityProfile for the JAXR provider.
      Collection BulkResponse.getCollection()
      Get the Collection of objects returned as a response of a bulk operation.
      Set Connection.getCredentials()
      Gets the credentials associated with this client.
      DeclarativeQueryManager RegistryService.getDeclarativeQueryManager()
      Returns the DeclarativeQueryManager object implemented by the JAXR provider.
      ClassificationScheme RegistryService.getDefaultPostalScheme()
      Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.
      Key RegistryException.getErrorObjectKey()
      Gets the Key to the first object that encountered an error in the registry.
      Collection BulkResponse.getExceptions()
      Get the Collection of RegistryException instances in case of partial commit.
      abstract Properties ConnectionFactory.getProperties()
      Gets the Properties used during createConnection and createFederatedConnection calls.
      RegistryObject QueryManager.getRegistryObject(String id)
      Gets the RegistryObject specified by the Id.
      RegistryObject QueryManager.getRegistryObject(String id, String objectType)
      Gets the RegistryObject specified by the Id and type of object.
      BulkResponse QueryManager.getRegistryObjects()
      Gets the RegistryObjects owned by the caller.
      BulkResponse QueryManager.getRegistryObjects(Collection objectKeys)
      Gets the specified RegistryObjects.
      BulkResponse QueryManager.getRegistryObjects(Collection objectKeys, String objectTypes)
      Gets the specified RegistryObjects.
      BulkResponse QueryManager.getRegistryObjects(String objectType)
      Gets the RegistryObjects owned by the caller, that are of the specified type.
      RegistryService QueryManager.getRegistryService()
      Returns the parent RegistryService that created this object.
      RegistryService LifeCycleManager.getRegistryService()
      Returns the parent RegistryService that created this object.
      RegistryService Connection.getRegistryService()
      Gets the RegistryService interface associated with the Connection.
      String JAXRResponse.getRequestId()
      Returns the unique id for the request that generated this response.
      int JAXRResponse.getStatus()
      Returns the status for this response.
      int Query.getType()
      Gets the type of Query (for example, QUERY_TYPE_SQL).
      String CapabilityProfile.getVersion()
      Gets the JAXR specification version supported by the JAXR provider.
      boolean JAXRResponse.isAvailable()
      Returns true if a response is available, false otherwise.
      boolean JAXRException.isAvailable()
      Returns true if a response is available, false otherwise.
      boolean Connection.isClosed()
      Indicated whether this Connection has been closed or not.
      boolean BulkResponse.isPartialResponse()
      Determines whether the response is a partial response due to large result set.
      boolean Connection.isSynchronous()
      Indicates whether a client uses synchronous communication with JAXR provider or not.
      String RegistryService.makeRegistrySpecificRequest(String request)
      Takes a String that is an XML request in a registry-specific format, sends the request to the registry, and returns a String that is the registry-specific XML response.
      static ConnectionFactory ConnectionFactory.newInstance()
      Creates a default ConnectionFactory object.
      BulkResponse BusinessLifeCycleManager.saveAssociations(Collection associations, boolean replace)
      Saves the specified Association instances.
      BulkResponse BusinessLifeCycleManager.saveClassificationSchemes(Collection schemes)
      Saves the specified ClassificationScheme instances.
      BulkResponse BusinessLifeCycleManager.saveConcepts(Collection concepts)
      Saves the specified Concepts.
      BulkResponse LifeCycleManager.saveObjects(Collection objects)
      Saves one or more Objects to the registry.
      BulkResponse BusinessLifeCycleManager.saveOrganizations(Collection organizations)
      Saves the specified Organizations.
      BulkResponse BusinessLifeCycleManager.saveServiceBindings(Collection bindings)
      Saves the specified ServiceBindings.
      BulkResponse BusinessLifeCycleManager.saveServices(Collection services)
      Saves the specified Services.
      void Connection.setCredentials(Set credentials)
      Sets the Credentials associated with this client.
      void RegistryException.setErrorObjectKey(Key key)
      Sets the Key to the first object that encountered an error in the registry.
      abstract void ConnectionFactory.setProperties(Properties properties)
      Sets the Properties used during createConnection and createFederatedConnection calls.
      void Connection.setSynchronous(boolean sync)
      Sets whether the client uses synchronous communication or not.
      void BusinessLifeCycleManager.unConfirmAssociation(Association assoc)
      Undoes a previous confirmation of this Association by the User associated with the caller.
      BulkResponse LifeCycleManager.unDeprecateObjects(Collection keys)
      Undeprecates one or more previously deprecated objects.

    • Uses of JAXRException in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that throw JAXRException
      Modifier and Type Method and Description
      void RegistryObject.addAssociation(Association association)
      Adds specified Association to use this object as source.
      void RegistryObject.addAssociations(Collection associations)
      Adds specified Associations to use this object as source.
      void Concept.addChildConcept(Concept concept)
      Adds a child Concept.
      void ClassificationScheme.addChildConcept(Concept concept)
      Adds a child Concept.
      void Concept.addChildConcepts(Collection concepts)
      Adds a Collection of Concept children.
      void ClassificationScheme.addChildConcepts(Collection concepts)
      Adds a Collection of Concept children.
      void Organization.addChildOrganization(Organization organization)
      Adds a child Organization.
      void Organization.addChildOrganizations(Collection organizations)
      Adds a Collection of Organization children.
      void RegistryObject.addClassification(Classification classification)
      Adds specified Classification to this object.
      void RegistryObject.addClassifications(Collection classifications)
      Adds specified Classifications to this object.
      void RegistryObject.addExternalIdentifier(ExternalIdentifier externalIdentifier)
      Adds specified ExternalIdentifier as an external identifier to this object.
      void RegistryObject.addExternalIdentifiers(Collection externalIdentifiers)
      Adds specified ExternalIdentifiers as an external identifiers to this object.
      void RegistryObject.addExternalLink(ExternalLink externalLink)
      Adds specified ExternalLink to this object.
      void RegistryObject.addExternalLinks(Collection externalLinks)
      Adds specified ExternalLinks to this object.
      void InternationalString.addLocalizedString(LocalizedString localizedString)
      Adds a LocalizedString to this object.
      void InternationalString.addLocalizedStrings(Collection localizedStrings)
      Adds many LocalizedStrings to this object.
      void RegistryPackage.addRegistryObject(RegistryObject registryObject)
      Adds a child RegistryObject as member.
      void RegistryPackage.addRegistryObjects(Collection registryObjects)
      Adds a Collection of RegistryObject children as members.
      void Organization.addService(Service service)
      Adds a child Service.
      void Service.addServiceBinding(ServiceBinding serviceBinding)
      Adds a child ServiceBinding.
      void Service.addServiceBindings(Collection serviceBindings)
      Adds a Collection of ServiceBinding children.
      void Organization.addServices(Collection services)
      Adds a Collection of Service children.
      void ExtensibleObject.addSlot(Slot slot)
      Adds a Slot to this object.
      void ExtensibleObject.addSlots(Collection slots)
      Adds more Slots to this object.
      void ServiceBinding.addSpecificationLink(SpecificationLink specificationLink)
      Adds a child SpecificationLink.
      void ServiceBinding.addSpecificationLinks(Collection specificationLinks)
      Adds a Collection of SpecificationLink children.
      void Organization.addUser(User user)
      Adds a User.
      void Organization.addUsers(Collection users)
      Adds a Collection of Users.
      String ServiceBinding.getAccessURI()
      Gets the URI that gives access to the service via this binding.
      String EmailAddress.getAddress()
      Returns the email address for this object.
      String TelephoneNumber.getAreaCode()
      Gets the area code.
      Collection RegistryObject.getAssociatedObjects()
      Returns the collection of RegistryObject instances associated with this object.
      Collection RegistryObject.getAssociations()
      Gets all Associations where this object is source.
      Concept Association.getAssociationType()
      Gets the association type for this Association.
      Collection RegistryObject.getAuditTrail()
      Returns the complete audit trail of all requests that effected a state change in this object as an ordered Collection of AuditableEvent objects.
      String LocalizedString.getCharsetName()
      Gets the canonical name for the charset for this object.
      int Concept.getChildConceptCount()
      Gets number of children.
      int ClassificationScheme.getChildConceptCount()
      Gets number of children.
      int Organization.getChildOrganizationCount()
      Gets number of children.
      Collection Organization.getChildOrganizations()
      Gets all immediate children Organizations.
      Collection Concept.getChildrenConcepts()
      Gets all immediate children Concepts.
      Collection ClassificationScheme.getChildrenConcepts()
      Gets all immediate children Concepts.
      String PostalAddress.getCity()
      Returns the city.
      Collection RegistryObject.getClassifications()
      Gets the Classification instances that classify this object.
      ClassificationScheme Concept.getClassificationScheme()
      Gets the ClassificationScheme that this Concept is a descendent of.
      ClassificationScheme Classification.getClassificationScheme()
      Gets the ClassificationScheme that is used in classifying the object.
      RegistryObject Classification.getClassifiedObject()
      Gets the Object that is being classified.
      Concept Classification.getConcept()
      Gets the Concept that is classifying the object.
      String PostalAddress.getCountry()
      Returns the country.
      String TelephoneNumber.getCountryCode()
      Gets the country code.
      Collection Concept.getDescendantConcepts()
      Gets all descendant Concepts.
      Collection ClassificationScheme.getDescendantConcepts()
      Gets all descendant Concepts.
      Collection Organization.getDescendantOrganizations()
      Gets all descendant Organizations.
      InternationalString RegistryObject.getDescription()
      Gets the textual description for this object.
      Collection User.getEmailAddresses()
      Gets the email addresses for this User.
      int AuditableEvent.getEventType()
      Gets the type of this event.
      Date RegistryEntry.getExpiration()
      Gets expirationDate attribute of the RegistryEntry within the Registry.
      String TelephoneNumber.getExtension()
      Gets the internal extension.
      Collection RegistryObject.getExternalIdentifiers()
      Returns the ExternalIdentifiers associated with this object that are external identifiers for this object.
      Collection RegistryObject.getExternalLinks()
      Returns the ExternalLinks associated with this object.
      String ExternalLink.getExternalURI()
      Gets URI to the an external resource.
      String PersonName.getFirstName()
      Gets the first name for this Person.
      String PersonName.getFullName()
      Gets the fully formatted name for this person.
      String Key.getId()
      Returns the unique Id of this key.
      ClassificationScheme ExternalIdentifier.getIdentificationScheme()
      Gets the ClassificationScheme that is used as the identification scheme for identifying this object.
      Key RegistryObject.getKey()
      Gets the key representing the universally unique ID (UUID) for this object.
      String PersonName.getLastName()
      Gets the last name (surname) for this Person.
      LifeCycleManager RegistryObject.getLifeCycleManager()
      Returns the LifeCycleManager that created this object.
      Collection ExternalLink.getLinkedObjects()
      Gets the collection of RegistryObjects that are annotated by this ExternalLink.
      Locale LocalizedString.getLocale()
      Get the Locale for this object.
      LocalizedString InternationalString.getLocalizedString(Locale locale, String charsetName)
      Gets the LocalizedString for the specified Locale and charsetName.
      Collection InternationalString.getLocalizedStrings()
      Returns the LocalizedStrings associated with this object.
      int Versionable.getMajorVersion()
      Gets the major revision number for this version of the Versionable object.
      String PersonName.getMiddleName()
      Gets the middle name for this Person.
      String ExtrinsicObject.getMimeType()
      Gets the mime type associated with this object.
      int Versionable.getMinorVersion()
      Gets the minor revision number for this version of the Versionable object.
      String Slot.getName()
      Gets the name for this Slot.
      InternationalString RegistryObject.getName()
      Gets the user-friendly name of this object.
      String TelephoneNumber.getNumber()
      Gets the telephone number suffix, not including the country or area code.
      Concept RegistryObject.getObjectType()
      Gets the object type that best describes the RegistryObject.
      Organization User.getOrganization()
      Gets the Organization that this User is affiliated with.
      RegistryObject Concept.getParent()
      Gets the parent Concept or ClassificationScheme for this object.
      Concept Concept.getParentConcept()
      Gets the parent Concept or null if parent is a ClassificationScheme.
      Organization Organization.getParentOrganization()
      Gets the parent (container) organization.
      String Concept.getPath()
      Gets the canonical path representation for this Concept.
      PersonName User.getPersonName()
      Returns the name of this User.
      PostalAddress Organization.getPostalAddress()
      Gets the Address for this Organization.
      Collection User.getPostalAddresses()
      Gets the postal address for this User.
      String PostalAddress.getPostalCode()
      Returns the postal or zip code.
      ClassificationScheme PostalAddress.getPostalScheme()
      Returns a user-defined postal scheme for codifying the attributes of PostalAddress.
      User Organization.getPrimaryContact()
      Gets the primary Contact for this Organization.
      Organization Service.getProvidingOrganization()
      Gets the Organization that provides this service.
      RegistryObject ExternalIdentifier.getRegistryObject()
      Gets the parent RegistryObject for this ExternalIdentifier.
      RegistryObject AuditableEvent.getRegistryObject()
      Gets the RegistryObject associated with this AuditableEvent.
      Set RegistryPackage.getRegistryObjects()
      Gets the collection of member RegistryObjects of this RegistryPackage.
      Collection RegistryObject.getRegistryPackages()
      Returns the Package associated with this object.
      DataHandler ExtrinsicObject.getRepositoryItem()
      Gets the repository item for this object.
      Organization Organization.getRootOrganization()
      Gets the root organization.
      Service ServiceBinding.getService()
      Gets the parent service for which this is a binding.
      ServiceBinding SpecificationLink.getServiceBinding()
      Gets the parent ServiceBinding for this SpecificationLink.
      Collection Service.getServiceBindings()
      Gets all children ServiceBindings.
      Collection Organization.getServices()
      Gets all children Services.
      Slot ExtensibleObject.getSlot(String slotName)
      Gets the slot specified by slotName.
      Collection ExtensibleObject.getSlots()
      Returns the Slots associated with this object.
      String Slot.getSlotType()
      Gets the slotType for this Slot.
      RegistryObject Association.getSourceObject()
      Gets the Object that is the source of this Association.
      Collection ServiceBinding.getSpecificationLinks()
      Gets all children SpecificationLinks.
      RegistryObject SpecificationLink.getSpecificationObject()
      Gets the specification object for this object.
      int RegistryEntry.getStability()
      Gets the stability indicator for the RegistryEntry within the Registry.
      String PostalAddress.getStateOrProvince()
      Returns the state or province.
      int RegistryEntry.getStatus()
      Gets the life cycle status of the RegistryEntry within the registry.
      String PostalAddress.getStreet()
      Returns the street name.
      String PostalAddress.getStreetNumber()
      Returns the street number.
      Organization RegistryObject.getSubmittingOrganization()
      Gets the Organization that submitted this RegistryObject.
      ServiceBinding ServiceBinding.getTargetBinding()
      Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.
      RegistryObject Association.getTargetObject()
      Gets the Object that is the target of this Association.
      Collection User.getTelephoneNumbers(String phoneType)
      Gets the telephone numbers for this User that match the specified telephone number type.
      Collection Organization.getTelephoneNumbers(String phoneType)
      Gets the telephone numbers for this User that match the specified telephone number type.
      Timestamp AuditableEvent.getTimestamp()
      Gets the Timestamp for when this event occurred.
      String User.getType()
      Gets the type for this User.
      String TelephoneNumber.getType()
      The type of telephone number (for example, "fax").
      String PostalAddress.getType()
      Returns the type of address (for example, "headquarters") as a String.
      String EmailAddress.getType()
      Gets the type for this object.
      URL User.getUrl()
      Gets the URL to the web page for this User.
      String TelephoneNumber.getUrl()
      Gets the URL that can dial this number electronically.
      InternationalString SpecificationLink.getUsageDescription()
      Gets the description of usage parameters.
      Collection SpecificationLink.getUsageParameters()
      Gets any usage parameters.
      User AuditableEvent.getUser()
      Gets the User associated with this object.
      Collection Organization.getUsers()
      Gets the Collection of Users affiliated with this Organization.
      String Versionable.getUserVersion()
      Gets the user-specified revision number for this version of the Versionable object.
      boolean URIValidator.getValidateURI()
      Gets whether to do URI validation for this object.
      String LocalizedString.getValue()
      Get the String value for this object.
      String InternationalString.getValue()
      Gets the String value for the Locale returned by Locale.getDefault().
      String ExternalIdentifier.getValue()
      Gets the value of an ExternalIdentifier.
      String Concept.getValue()
      Gets the value (usually a code in a taxonomy) associated with this Concept.
      String Classification.getValue()
      Gets the taxonomy value for this Classification.
      String InternationalString.getValue(Locale locale)
      Gets the String value for the specified Locale.
      Collection Slot.getValues()
      Gets the values for this Slot.
      int ClassificationScheme.getValueType()
      Gets the value type for this object.
      boolean Association.isConfirmed()
      Determines whether an Association has been confirmed completely.
      boolean Association.isConfirmedBySourceOwner()
      Determines whether an Association has been confirmed by the owner of the source object.
      boolean Association.isConfirmedByTargetOwner()
      Determines whether an Association has been confirmed by the owner of the target object.
      boolean ClassificationScheme.isExternal()
      Determines whether this ClassificationScheme is an external ClassificationScheme or an internal ClassificationScheme.
      boolean Classification.isExternal()
      Returns true if this is an external classification.
      boolean Association.isExtramural()
      Determines whether an Association is extramural or not.
      boolean ExtrinsicObject.isOpaque()
      Determines whether the ExtrinsicObject is opaque (not readable) by the registry operator.
      void RegistryObject.removeAssociation(Association association)
      Removes specified Association from this object.
      void RegistryObject.removeAssociations(Collection associations)
      Removes specified Associations from this object.
      void Concept.removeChildConcept(Concept concept)
      Removes a child Concept.
      void ClassificationScheme.removeChildConcept(Concept concept)
      Removes a child Concept.
      void Concept.removeChildConcepts(Collection concepts)
      Removes a Collection of children Concepts.
      void ClassificationScheme.removeChildConcepts(Collection concepts)
      Removes a Collection of children Concepts.
      void Organization.removeChildOrganization(Organization organization)
      Removes a child Organization.
      void Organization.removeChildOrganizations(Collection organizations)
      Removes a Collection of children Organizations.
      void RegistryObject.removeClassification(Classification classification)
      Removes specified Classification from this object.
      void RegistryObject.removeClassifications(Collection classifications)
      Removes specified Classifications from this object.
      void RegistryObject.removeExternalIdentifier(ExternalIdentifier externalIdentifier)
      Removes specified ExternalIdentifier as an external identifier from this object.
      void RegistryObject.removeExternalIdentifiers(Collection externalIdentifiers)
      Removes specified ExternalIdentifiers as an external identifiers from this object.
      void RegistryObject.removeExternalLink(ExternalLink externalLink)
      Removes specified ExternalLink from this object.
      void RegistryObject.removeExternalLinks(Collection externalLinks)
      Removes specified ExternalLinks from this object.
      void InternationalString.removeLocalizedString(LocalizedString localizedString)
      Removes a LocalizedString from this object.
      void InternationalString.removeLocalizedStrings(Collection localizedStrings)
      Removes specified LocalizedStrings to this object.
      void RegistryPackage.removeRegistryObject(RegistryObject registryObject)
      Removes a child RegistryObject from membership.
      void RegistryPackage.removeRegistryObjects(Collection registryObjects)
      Removes a Collection of children RegistryObjects from membership.
      void Organization.removeService(Service service)
      Removes a Service from this object.
      void Service.removeServiceBinding(ServiceBinding serviceBinding)
      Removes a child ServiceBinding.
      void Service.removeServiceBindings(Collection serviceBindings)
      Removes a Collection of children ServiceBindings.
      void Organization.removeServices(Collection services)
      Removes a Collection of children Services from this object.
      void ExtensibleObject.removeSlot(String slotName)
      Removes a Slot from this object.
      void ExtensibleObject.removeSlots(Collection slotNames)
      Removes specified Slots from this object.
      void ServiceBinding.removeSpecificationLink(SpecificationLink specificationLink)
      Removes a child SpecificationLink.
      void ServiceBinding.removeSpecificationLinks(Collection specificationLinks)
      Removes a Collection of children SpecificationLinks.
      void Organization.removeUser(User user)
      Removes a User.
      void Organization.removeUsers(Collection users)
      Removes a Collection of Users.
      void ServiceBinding.setAccessURI(String uri)
      Sets the URI that gives access to the service via this binding.
      void EmailAddress.setAddress(String address)
      Sets the email address for this object.
      void TelephoneNumber.setAreaCode(String areaCode)
      Sets the area code.
      void RegistryObject.setAssociations(Collection associations)
      Replaces all previous Associations from this object with specified Associations.
      void Association.setAssociationType(Concept associationType)
      Sets the association type for this Association.
      void LocalizedString.setCharsetName(String charsetName)
      Set the canonical name for the charset for this object.
      void PostalAddress.setCity(String city)
      Sets the city.
      void RegistryObject.setClassifications(Collection classifications)
      Replaces all previous Classifications with specified Classifications.
      void Classification.setClassificationScheme(ClassificationScheme classificationScheme)
      Sets the ClassificationScheme for this external classification.
      void Classification.setClassifiedObject(RegistryObject classifiedObject)
      Sets the object that is being classified.
      void Classification.setConcept(Concept concept)
      Sets the concept for this internal classification.
      void PostalAddress.setCountry(String country)
      Sets the country.
      void TelephoneNumber.setCountryCode(String countryCode)
      Sets country code.
      void RegistryObject.setDescription(InternationalString description)
      Sets the context independent textual description for this object.
      void User.setEmailAddresses(Collection emailAddresses)
      Sets the Collection of EmailAddress instances for this User.
      void RegistryEntry.setExpiration(Date expiration)
      Sets the expirationDate.
      void TelephoneNumber.setExtension(String extension)
      Sets the internal extension.
      void RegistryObject.setExternalIdentifiers(Collection externalIdentifiers)
      Replaces all previous external identifiers with specified Collection of ExternalIdentifiers as an external identifier.
      void RegistryObject.setExternalLinks(Collection externalLinks)
      Replaces all previous ExternalLinks with specified ExternalLinks.
      void ExternalLink.setExternalURI(String uri)
      Sets URI for an external resource.
      void PersonName.setFirstName(String firstName)
      Sets the first name for this Person.
      void PersonName.setFullName(String fullName)
      Sets the fully formatted name for this person.
      void Key.setId(String id)
      Sets the unique id associated with this key.
      void ExternalIdentifier.setIdentificationScheme(ClassificationScheme identificationScheme)
      Sets the ClassificationScheme that is used as the identification scheme for identifying this object.
      void RegistryObject.setKey(Key key)
      Sets the key representing the universally unique ID (UUID) for this object.
      void PersonName.setLastName(String lastName)
      Sets the last name (surname) for this Person.
      void LocalizedString.setLocale(Locale locale)
      Set the Locale for this object.
      void Versionable.setMajorVersion(int majorVersion)
      Sets the major revision number for this version of the Versionable object.
      void PersonName.setMiddleName(String middleName)
      Sets the middle name for this Person.
      void ExtrinsicObject.setMimeType(String mimeType)
      Sets the mime type associated with this object.
      void Versionable.setMinorVersion(int minorVersion)
      Sets the minor revision number for this version of the Versionable object.
      void RegistryObject.setName(InternationalString name)
      Sets user-friendly name of object in repository.
      void Slot.setName(String name)
      Sets the name for this Slot.
      void TelephoneNumber.setNumber(String number)
      Sets the telephone number suffix, not including the country or area code.
      void ExtrinsicObject.setOpaque(boolean isOpaque)
      Sets whether the ExtrinsicObject is opaque (not readable) by the registry.
      void User.setPersonName(PersonName personName)
      Sets the name of this User.
      void Organization.setPostalAddress(PostalAddress address)
      Sets the address for this Organization.
      void User.setPostalAddresses(Collection addresses)
      Sets the addresses for this User.
      void PostalAddress.setPostalCode(String postalCode)
      Sets the postal or zip code.
      void PostalAddress.setPostalScheme(ClassificationScheme scheme)
      Sets a user-defined postal scheme for codifying the attributes of PostalAddress.
      void Organization.setPrimaryContact(User primaryContact)
      Sets the primary contact for this Organization.
      void Service.setProvidingOrganization(Organization providingOrganization)
      Sets the Organization that provides this service.
      void ExtrinsicObject.setRepositoryItem(DataHandler repositoryItem)
      Sets the repository item for this object.
      void Slot.setSlotType(String slotType)
      Sets the slotType for this Slot.
      void Association.setSourceObject(RegistryObject srcObject)
      Sets the Object that is the source of this Association.
      void SpecificationLink.setSpecificationObject(RegistryObject obj)
      Sets the specification object for this object.
      void RegistryEntry.setStability(int stability)
      Sets the stability indicator for the RegistryEntry.
      void PostalAddress.setStateOrProvince(String stateOrProvince)
      Sets the state or province.
      void PostalAddress.setStreet(String street)
      Sets the street name.
      void PostalAddress.setStreetNumber(String streetNumber)
      Sets the street number.
      void ServiceBinding.setTargetBinding(ServiceBinding binding)
      Sets the next ServiceBinding in case there is a redirection.
      void Association.setTargetObject(RegistryObject targetObject)
      Sets the Object that is the target of this Association.
      void User.setTelephoneNumbers(Collection phoneNumbers)
      Sets the various telephone numbers for this user.
      void Organization.setTelephoneNumbers(Collection phoneNumbers)
      Sets the various telephone numbers for this user.
      void User.setType(String type)
      Sets the type for this User.
      void TelephoneNumber.setType(String type)
      Sets the type of telephone number (for example, "fax").
      void PostalAddress.setType(String type)
      Sets the type of address (for example, "headquarters") as a String.
      void EmailAddress.setType(String type)
      Sets the type for this object.
      void TelephoneNumber.setUrl(String url)
      Sets the URL that can dial this number electronically.
      void User.setUrl(URL url)
      Sets the URL to the web page for this User.
      void SpecificationLink.setUsageDescription(InternationalString usageDescription)
      Sets the description of usage parameters.
      void SpecificationLink.setUsageParameters(Collection usageParameters)
      Sets any usage parameters.
      void Versionable.setUserVersion(String userVersion)
      Sets the user specified revision number for this version of the Versionable object.
      void URIValidator.setValidateURI(boolean validate)
      Sets whether to do URI validation for this object.
      void InternationalString.setValue(Locale locale, String value)
      Sets the String value for the specified Locale.
      void LocalizedString.setValue(String value)
      Set the String value for the specified object.
      void InternationalString.setValue(String value)
      Sets the String value for the Locale returned by Locale.getDefault().
      void ExternalIdentifier.setValue(String value)
      Sets the value of an ExternalIdentifier.
      void Concept.setValue(String value)
      Sets the value (usually a taxonomy value) associated with this Concept.
      void Classification.setValue(String value)
      Sets the taxonomy value for this external Classification.
      void Slot.setValues(Collection values)
      Sets the values for this Slot.
      void ClassificationScheme.setValueType(int valueType)
      Sets the value type for this object.
      String RegistryObject.toXML()
      Returns a registry provider specific XML representation of this Object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.registry.RegistryException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.registry.RegistryException

  • Packages that use RegistryException
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of RegistryException in javax.xml.registry

      Subclasses of RegistryException in javax.xml.registry
      Modifier and Type Class and Description
      class  DeleteException
      A RegistryException that occurs during a delete action.
      class  FindException
      A RegistryException that occurs during a find action.
      class  SaveException
      A RegistryException that occurs during a save action.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.registry.SaveException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.registry.SaveException

No usage of javax.xml.registry.SaveException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.registry.UnexpectedObjectException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.registry.UnexpectedObjectException

No usage of javax.xml.registry.UnexpectedObjectException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.registry.UnsupportedCapabilityException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.registry.UnsupportedCapabilityException

  • Packages that use UnsupportedCapabilityException
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of UnsupportedCapabilityException in javax.xml.registry

      Methods in javax.xml.registry that throw UnsupportedCapabilityException
      Modifier and Type Method and Description
      Object LifeCycleManager.createObject(String interfaceName)
      Creates instances of information model interfaces (factory method).
      DeclarativeQueryManager RegistryService.getDeclarativeQueryManager()
      Returns the DeclarativeQueryManager object implemented by the JAXR provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.BulkResponse (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.BulkResponse

  • Packages that use BulkResponse
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of BulkResponse in javax.xml.registry

      Methods in javax.xml.registry that return BulkResponse
      Modifier and Type Method and Description
      BulkResponse BusinessLifeCycleManager.deleteAssociations(Collection associationKeys)
      Deletes the Associations corresponding to the specified Keys.
      BulkResponse BusinessLifeCycleManager.deleteClassificationSchemes(Collection schemeKeys)
      Deletes the ClassificationSchemes corresponding to the specified Keys.
      BulkResponse BusinessLifeCycleManager.deleteConcepts(Collection conceptKeys)
      Deletes the Concepts corresponding to the specified Keys.
      BulkResponse LifeCycleManager.deleteObjects(Collection keys)
      Deletes one or more previously submitted objects from the registry using the object keys.
      BulkResponse LifeCycleManager.deleteObjects(Collection keys, String objectType)
      Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.
      BulkResponse BusinessLifeCycleManager.deleteOrganizations(Collection organizationKeys)
      Deletes the organizations corresponding to the specified Keys.
      BulkResponse BusinessLifeCycleManager.deleteServiceBindings(Collection bindingKeys)
      Deletes the ServiceBindings corresponding to the specified Keys.
      BulkResponse BusinessLifeCycleManager.deleteServices(Collection serviceKeys)
      Deletes the services corresponding to the specified Keys.
      BulkResponse LifeCycleManager.deprecateObjects(Collection keys)
      Deprecates one or more previously submitted objects.
      BulkResponse DeclarativeQueryManager.executeQuery(Query query)
      Executes a query as specified by query parameter.
      BulkResponse BusinessQueryManager.findAssociations(Collection findQualifiers, String sourceObjectId, String targetObjectId, Collection associationTypes)
      Finds all Association objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findCallerAssociations(Collection findQualifiers, Boolean confirmedByCaller, Boolean confirmedByOtherParty, Collection associationTypes)
      Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findClassificationSchemes(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalLinks)
      Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findConcepts(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalIdentifiers, Collection externalLinks)
      Finds all Concept objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findOrganizations(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications, Collection externalIdentifiers, Collection externalLinks)
      Finds all Organization objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findRegistryPackages(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalLinks)
      Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findServiceBindings(Key serviceKey, Collection findQualifiers, Collection classifications, Collection specifications)
      Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findServices(Key orgKey, Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications)
      Finds all Service objects that match all of the criteria specified by the parameters of this call.
      BulkResponse RegistryService.getBulkResponse(String requestId)
      Returns the BulkResponse associated with specified requestId.
      BulkResponse QueryManager.getRegistryObjects()
      Gets the RegistryObjects owned by the caller.
      BulkResponse QueryManager.getRegistryObjects(Collection objectKeys)
      Gets the specified RegistryObjects.
      BulkResponse QueryManager.getRegistryObjects(Collection objectKeys, String objectTypes)
      Gets the specified RegistryObjects.
      BulkResponse QueryManager.getRegistryObjects(String objectType)
      Gets the RegistryObjects owned by the caller, that are of the specified type.
      BulkResponse BusinessLifeCycleManager.saveAssociations(Collection associations, boolean replace)
      Saves the specified Association instances.
      BulkResponse BusinessLifeCycleManager.saveClassificationSchemes(Collection schemes)
      Saves the specified ClassificationScheme instances.
      BulkResponse BusinessLifeCycleManager.saveConcepts(Collection concepts)
      Saves the specified Concepts.
      BulkResponse LifeCycleManager.saveObjects(Collection objects)
      Saves one or more Objects to the registry.
      BulkResponse BusinessLifeCycleManager.saveOrganizations(Collection organizations)
      Saves the specified Organizations.
      BulkResponse BusinessLifeCycleManager.saveServiceBindings(Collection bindings)
      Saves the specified ServiceBindings.
      BulkResponse BusinessLifeCycleManager.saveServices(Collection services)
      Saves the specified Services.
      BulkResponse LifeCycleManager.unDeprecateObjects(Collection keys)
      Undeprecates one or more previously deprecated objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.BusinessLifeCycleManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.BusinessLifeCycleManager

  • Packages that use BusinessLifeCycleManager
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of BusinessLifeCycleManager in javax.xml.registry

      Methods in javax.xml.registry that return BusinessLifeCycleManager
      Modifier and Type Method and Description
      BusinessLifeCycleManager RegistryService.getBusinessLifeCycleManager()
      Returns the BusinessLifeCycleManager object implemented by the JAXR provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.BusinessQueryManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.BusinessQueryManager

  • Packages that use BusinessQueryManager
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of BusinessQueryManager in javax.xml.registry

      Methods in javax.xml.registry that return BusinessQueryManager
      Modifier and Type Method and Description
      BusinessQueryManager RegistryService.getBusinessQueryManager()
      Returns the BusinessQueryManager object implemented by the JAXR provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.CapabilityProfile (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.CapabilityProfile

  • Packages that use CapabilityProfile
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of CapabilityProfile in javax.xml.registry

      Methods in javax.xml.registry that return CapabilityProfile
      Modifier and Type Method and Description
      CapabilityProfile RegistryService.getCapabilityProfile()
      Returns the CapabilityProfile for the JAXR provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.Connection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.Connection

  • Packages that use Connection
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of Connection in javax.xml.registry

      Subinterfaces of Connection in javax.xml.registry
      Modifier and Type Interface and Description
      interface  FederatedConnection
      Represents a single logical connection to a federation or group of registry providers.
      Methods in javax.xml.registry that return Connection
      Modifier and Type Method and Description
      abstract Connection ConnectionFactory.createConnection()
      Create a named connection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.DeclarativeQueryManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.DeclarativeQueryManager

  • Packages that use DeclarativeQueryManager
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of DeclarativeQueryManager in javax.xml.registry

      Methods in javax.xml.registry that return DeclarativeQueryManager
      Modifier and Type Method and Description
      DeclarativeQueryManager RegistryService.getDeclarativeQueryManager()
      Returns the DeclarativeQueryManager object implemented by the JAXR provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.FederatedConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.FederatedConnection

  • Packages that use FederatedConnection
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of FederatedConnection in javax.xml.registry

      Methods in javax.xml.registry that return FederatedConnection
      Modifier and Type Method and Description
      abstract FederatedConnection ConnectionFactory.createFederatedConnection(Collection connections)
      Create a FederatedConnection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.FindQualifier (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.FindQualifier

No usage of javax.xml.registry.FindQualifier
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.JAXRResponse (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.JAXRResponse

  • Packages that use JAXRResponse
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of JAXRResponse in javax.xml.registry

      Subinterfaces of JAXRResponse in javax.xml.registry
      Modifier and Type Interface and Description
      interface  BulkResponse
      Contains the response of a method in the API that performs a bulk operation and returns a bulk response.
      Classes in javax.xml.registry that implement JAXRResponse
      Modifier and Type Class and Description
      class  DeleteException
      A RegistryException that occurs during a delete action.
      class  FindException
      A RegistryException that occurs during a find action.
      class  InvalidRequestException
      This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.
      class  JAXRException
      Signals that a JAXR exception has occurred.
      class  RegistryException
      This is the common base class for all Exceptions that are detected on the registry provider side rather than the JAXR client side.
      class  SaveException
      A RegistryException that occurs during a save action.
      class  UnexpectedObjectException
      This exception is thrown when the JAXR provider finds a Object that is out-of-place or of the wrong type within the context of a user request.
      class  UnsupportedCapabilityException
      This exception must be thrown when a JAXR client attempts to invoke an API method that is not supported by the capability profile that is supported by the JAXR provider.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.LifeCycleManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.LifeCycleManager

  • Packages that use LifeCycleManager
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of LifeCycleManager in javax.xml.registry

      Subinterfaces of LifeCycleManager in javax.xml.registry
      Modifier and Type Interface and Description
      interface  BusinessLifeCycleManager
      The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API.

    • Uses of LifeCycleManager in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return LifeCycleManager
      Modifier and Type Method and Description
      LifeCycleManager RegistryObject.getLifeCycleManager()
      Returns the LifeCycleManager that created this object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.Query (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.Query

  • Packages that use Query
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of Query in javax.xml.registry

      Methods in javax.xml.registry that return Query
      Modifier and Type Method and Description
      Query DeclarativeQueryManager.createQuery(int queryType, String queryString)
      Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.
      Methods in javax.xml.registry with parameters of type Query
      Modifier and Type Method and Description
      BulkResponse DeclarativeQueryManager.executeQuery(Query query)
      Executes a query as specified by query parameter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.QueryManager (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.QueryManager

  • Packages that use QueryManager
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of QueryManager in javax.xml.registry

      Subinterfaces of QueryManager in javax.xml.registry
      Modifier and Type Interface and Description
      interface  BusinessQueryManager
      The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface.
      interface  DeclarativeQueryManager
      This interface provides the ability to execute declarative queries (e.g.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.RegistryService (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.RegistryService

  • Packages that use RegistryService
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of RegistryService in javax.xml.registry

      Methods in javax.xml.registry that return RegistryService
      Modifier and Type Method and Description
      RegistryService QueryManager.getRegistryService()
      Returns the parent RegistryService that created this object.
      RegistryService LifeCycleManager.getRegistryService()
      Returns the parent RegistryService that created this object.
      RegistryService Connection.getRegistryService()
      Gets the RegistryService interface associated with the Connection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Association (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface Association

  • All Superinterfaces:
    ExtensibleObject, RegistryObject

    public interface Association
extends RegistryObject
    A RegistryObject instance may be associated with zero or more RegistryObject instances. The information model defines an Association interface, an instance of which may be used to associate any two RegistryObject instances.

    Example of an Association

    One example of such an association is between two ClassificationScheme instances, where one ClassificationScheme supersedes the other ClassificationScheme as shown in Figure 1. This may be the case when a new version of a ClassificationScheme is submitted. In Figure 1, we see how an Association is defined between a new version of the NAICS ClassificationScheme and an older version of the NAICS ClassificationScheme.

    Example of RegistryObject Association
    Figure 1. Example of RegistryObject Association

    Source and Target Objects

    An Association instance represents an association between a source RegistryObject and a target RegistryObject. These are referred to as sourceObject and targetObject for the Association instance. It is important which object is the sourceObject and which is the targetObject as it determines the directional semantics of an Association. In the example in Figure 1, it is important to make the newer version of NAICS ClassificationScheme be the sourceObject and the older version of NAICS be the targetObject because the associationType implies that the sourceObject supersedes the targetObject (and not the other way around).

    Association Types

    Each Association must have an associationType attribute that identifies the type of that association. The associationType attribute is a reference to an enumeration Concept as defined by the predefined associationType ClassificationScheme in the JAXR specification. Our example uses the pre-defined associationType Concept named Supersedes.

    Intramural Associations

    A common use case for the Association interface is when a User "u" creates an Association "a" between two RegistryObjects "o1" and "o2" where association "a" and RegistryObjects "o1" and "o2" are objects that were created by the same User "u". This is the simplest use case where the association is between two objects that are owned by same User that is defining the Association. Such associations are referred to as intramural associations. Figure 2 extends the previous example in Figure 1 for the intramural association case.

    Example of Intramural Association
    Figure 2. Example of Intramural Association

    Extramural Association

    The information model also allows a more sophisticated use case where a User "u1" creates an Association "a" between two RegistryObjects "o1" and "o2" where association "a" is owned by User "u1", but RegistryObjects "o1" and "o2" are owned by User "u2" and User "u3" respectively. In this use case the Association is being defined where either or both objects that are being associated are owned by a User different from the User defining the Association. Such associations are referred to as extramural associations. The Association interface provides a convenience method called isExtramural that returns true if the Association instance is an extramural Association. Figure 3 extends the previous example in Figure 1 for the extramural association case. Note that it is possible for an extramural association to have two distinct Users rather than three distinct Users as shown in Figure 3. In such case, one of the two users owns two of the three objects involved (Association, sourceObject and targetObject).

    Example of Extramural Association
    Figure 3. Example of Extramural Association

    Confirmation of an Association

    An association may need to be confirmed by the parties whose objects are involved in that Association. This section describes the semantics of confirmation of an association by the parties involved.

    Confirmation of Intramural Associations

    Intramural associations may be viewed as declarations of truth and do not require any explicit steps to confirm that Association as being true. In other words, intramural associations are implicitly considered be confirmed.

    Confirmation of Extramural Associations

    Extramural associations may be viewed as a unilateral assertion that may not be viewed as truth until it has been confirmed by the other (extramural) parties (Users "u2" and "u3" in example). The confirmAssociation method on the BusinessLifeCycleManager interface may be called by the extramural parties that own the sourceObject or targetObject.

    Visibility of Unconfirmed Associations

    Extramural associations require each extramural party to confirm the assertion being made by the extramural Association before the Association is visible to 3rd parties that are not involved in the Association. This ensures that unconfirmed Associations are not visible to 3rd party registry clients.

    Possible Confirmation States

    Assume the most general case where there are three distinct User instances as shown in Figure 23 for an extramural Association. The extramural Association needs to be confirmed by both the other (extramural) parties (Users "u2" and "u3" in example) in order to be fully confirmed. The methods isConfirmedBySourceOwner and isConfiremedByTargetOwner in the Association interface provide access to confirmation state for both the sourceObject and targetObject. A third convenience method called isConfirmed provides a way to determine whether the Association is fully confirmed or not. So there are the following four possibilities related to confirmation state of an extramural Association:
    • The Association is confirmed neither by the owner of the sourceObject nor is it confirmed by owner of targetObject.
    • The Association is confirmed by the owner of the sourceObject but it is not confirmed by owner of targetObject.
    • The Association is not confirmed by the owner of the sourceObject but it is confirmed by owner of targetObject.
    • The Association is confirmed by the owner of the sourceObject and it is confirmed by owner of targetObject. This is the only state where the Association is fully confirmed.
    Author:
    Farrukh S. Najmi
    See Also:
    RegistryObject

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Concept getAssociationType()
      Gets the association type for this Association.
      RegistryObject getSourceObject()
      Gets the Object that is the source of this Association.
      RegistryObject getTargetObject()
      Gets the Object that is the target of this Association.
      boolean isConfirmed()
      Determines whether an Association has been confirmed completely.
      boolean isConfirmedBySourceOwner()
      Determines whether an Association has been confirmed by the owner of the source object.
      boolean isConfirmedByTargetOwner()
      Determines whether an Association has been confirmed by the owner of the target object.
      boolean isExtramural()
      Determines whether an Association is extramural or not.
      void setAssociationType(Concept associationType)
      Sets the association type for this Association.
      void setSourceObject(RegistryObject srcObject)
      Sets the Object that is the source of this Association.
      void setTargetObject(RegistryObject targetObject)
      Sets the Object that is the target of this Association.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

    • Method Detail

      • getSourceObject

        RegistryObject getSourceObject()
                               throws JAXRException
        Gets the Object that is the source of this Association.

        Capability Level: 0
        Returns:
        The RegistryObject that is the source object of this Association
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setSourceObject

        void setSourceObject(RegistryObject srcObject)
                     throws JAXRException
        Sets the Object that is the source of this Association.

        Capability Level: 0
        Parameters:
        srcObject - the RegistryObject that is the source object of this Association
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getTargetObject

        RegistryObject getTargetObject()
                               throws JAXRException
        Gets the Object that is the target of this Association.

        Capability Level: 0
        Returns:
        The RegistryObject that is the target object of this Association
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setTargetObject

        void setTargetObject(RegistryObject targetObject)
                     throws JAXRException
        Sets the Object that is the target of this Association.

        Capability Level: 0
        Parameters:
        targetObject - the RegistryObject that is the target object of this Association
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getAssociationType

        Concept getAssociationType()
                           throws JAXRException
        Gets the association type for this Association.

        Capability Level: 0
        Returns:
        The association type for this Association which is a Concept in the AssociationType ClassificationScheme
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setAssociationType

        void setAssociationType(Concept associationType)
                        throws JAXRException
        Sets the association type for this Association.

        Capability Level: 0
        Parameters:
        associationType - the association type for this Association which is a Concept in the AssociationType ClassificationScheme
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • isExtramural

        boolean isExtramural()
                     throws JAXRException
        Determines whether an Association is extramural or not.

        An Extramural Association must be confirmed by the User(s) that own the source and/or targert object, if they are different from the User who creates this extramural association. Both the sourceObject and targetObject owners must confirm an extramural Association, in order for it to be visible to third parties.

        Capability Level: 0
        Returns:
        true if the sourceObject and/or the targetObject are owned by a User that is different from the User that created the Association; false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • isConfirmedBySourceOwner

        boolean isConfirmedBySourceOwner()
                                 throws JAXRException
        Determines whether an Association has been confirmed by the owner of the source object.

        Capability Level: 0
        Returns:
        true if the association has been confirmed by the owner of the sourceObject; false otherwise. For intramural Associations always return true
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • isConfirmedByTargetOwner

        boolean isConfirmedByTargetOwner()
                                 throws JAXRException
        Determines whether an Association has been confirmed by the owner of the target object.

        Capability Level: 0
        Returns:
        true if the association has been confirmed by the owner of the targetObject; false otherwise. For intramural Associations always return true
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • isConfirmed

        boolean isConfirmed()
                    throws JAXRException
        Determines whether an Association has been confirmed completely.

        An association should only be visible to third parties (not involved with the Association) if isConfirmed returns true.

        Capability Level: 0
        Returns:
        true if the isConfirmedBySourceOwner and isConfirmedByTargetOwner methods both return true; false otherwise. For intramural Associations always return true
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        isConfirmedBySourceOwner(), isConfirmedByTargetOwner()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AuditableEvent (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface AuditableEvent

  • All Superinterfaces:
    ExtensibleObject, RegistryObject

    public interface AuditableEvent
extends RegistryObject
    AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject. Such events are usually a result of a client initiated request. AuditableEvent instances are generated by the registry service to log such events.

    Often such events effect a change in the life cycle of a RegistryObject. For example a client request could Create, Update, Deprecate or Delete a RegistryObject. No AuditableEvent is created for requests that do not alter the state of a RegistryObject. Specifically, read-only requests do not generate an AuditableEvent. No AuditableEvent is generated for a RegistryObject when it is classified, assigned to a Package or associated with another Object.

    A RegistryObject is associated with an ordered Collection of AuditableEvent instances that provide a complete audit trail for that Object.

    Author:
    Farrukh S. Najmi
    See Also:
    RegistryObject

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int EVENT_TYPE_CREATED
      An event where a RegistryObject is created.
      static int EVENT_TYPE_DELETED
      An event where a RegistryObject is deleted.
      static int EVENT_TYPE_DEPRECATED
      An event where a RegistryObject is deprecated.
      static int EVENT_TYPE_UNDEPRECATED
      An event where a RegistryObject is undeprecated.
      static int EVENT_TYPE_UPDATED
      An event where a RegistryObject is updated.
      static int EVENT_TYPE_VERSIONED
      An event where a RegistryObject is versioned.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getEventType()
      Gets the type of this event.
      RegistryObject getRegistryObject()
      Gets the RegistryObject associated with this AuditableEvent.
      Timestamp getTimestamp()
      Gets the Timestamp for when this event occurred.
      User getUser()
      Gets the User associated with this object.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

    • Field Detail

      • EVENT_TYPE_CREATED

        static final int EVENT_TYPE_CREATED
        An event where a RegistryObject is created.
        See Also:
        Constant Field Values

      • EVENT_TYPE_DELETED

        static final int EVENT_TYPE_DELETED
        An event where a RegistryObject is deleted.
        See Also:
        Constant Field Values

      • EVENT_TYPE_DEPRECATED

        static final int EVENT_TYPE_DEPRECATED
        An event where a RegistryObject is deprecated.
        See Also:
        Constant Field Values

      • EVENT_TYPE_UPDATED

        static final int EVENT_TYPE_UPDATED
        An event where a RegistryObject is updated.
        See Also:
        Constant Field Values

      • EVENT_TYPE_VERSIONED

        static final int EVENT_TYPE_VERSIONED
        An event where a RegistryObject is versioned.
        See Also:
        Constant Field Values

      • EVENT_TYPE_UNDEPRECATED

        static final int EVENT_TYPE_UNDEPRECATED
        An event where a RegistryObject is undeprecated.
        See Also:
        Constant Field Values

    • Method Detail

      • getUser

        User getUser()
             throws JAXRException
        Gets the User associated with this object.

        Capability Level: 1
        Returns:
        the User that sent the request that generated this this AuditableEvent. Must not be null
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getTimestamp

        Timestamp getTimestamp()
                       throws JAXRException
        Gets the Timestamp for when this event occurred.

        Capability Level: 1
        Returns:
        the timestamp that records the time the event occured
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getEventType

        int getEventType()
                 throws JAXRException
        Gets the type of this event.

        Capability Level: 1
        Returns:
        the type of this event
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        EVENT_TYPE_CREATED

      • getRegistryObject

        RegistryObject getRegistryObject()
                                 throws JAXRException
        Gets the RegistryObject associated with this AuditableEvent.

        Capability Level: 1
        Returns:
        the RegistryObject that was the focus of this event
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Classification (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface Classification

  • All Superinterfaces:
    ExtensibleObject, RegistryObject

    public interface Classification
extends RegistryObject
    The Classification interface is used to classify RegistryObject instances. A RegistryObject may be classified along multiple dimensions by adding zero or more Classification instances to the RegistryObject. For example, an Organization may be classified by its industry, by the products it sells and by its geographical location. In this example the RegistryObject would have at least three Classification instances added to it. The RegistryObject interface provides several addClassification methods to allow a client to add Classification instances to a Registry Object.

    Figure 1 shows how a Classification classifies a RegistryObject using a ClassificationScheme.

    Using a ClassificationScheme to Classify an Object
    Figure 1. Using a ClassificationScheme to Classify an Object

    Internal vs. External Taxonomies

    A taxonomy may be represented within a JAXR provider in one of the following ways:
    1. The taxonomy elements and their structural relationship with each other are available within the JAXR provider. This case is referred to as Internal Taxonomy since the structure of the taxonomy is available internal to the JAXR provider.
    2. The taxonomy elements and their structural relationship with each other is represented somewhere external to the JAXR provider. This case is referred to as External Taxonomy since the structure of the taxonomy is not available to the JAXR provider.

    Internal vs. External Classifications

    The Classification interface allows the classification of RegistryObjects using a ClassificationScheme whether the ClassificationScheme represents an internal taxonomy or an external taxonomy. When a Classification instance uses a ClassificationScheme representing an internal taxonomy then it is referred to as an internal Classification. When a Classification instance uses a ClassificationScheme representing an external taxonomy then it is referred to as an external Classification.

    Internal Classification

    When a Classification instance is used to classify a RegistryObject using an internal taxonomy it is referred to as an internal Classification. A client must call the setConcept method on a Classification and define a reference to a Concept instance from the Classification instance in order for that Classification to use an internal taxonomy. It is not necessary for the client to call setClassificationScheme for internal Classifications since the classifying Concept already knows it root ClassificationScheme.

    Example of Internal Classification

    Figure 2 shows an example of internal classification using a Concept to represent a taxonomy element. The example classifies an Organization instance as a Book Publisher using the NAICS standard taxonomy available as an internal taxonomy. Note that the figure does not show all the Concepts between the Book Publishers node and the NAICS ClassificationScheme to save space. Had they been there they would have been linked together by the parent attribute of each Concept.

    Example of Internal Classification
    Figure 2. Example of Internal Classification

    External Classification

    When a Classification instance is used to classify a RegistryObject using an external taxonomy it is referred to as an external Classification. A client must call the setValue method on a Classification and define a unique value that logically represents a taxonomy element within the taxonomy whose structure is defined externally. It is necessary for the client call setClassificationScheme for external Classifications since there is no other way to infer the ClassificationScheme that represents the external taxonomy.

    Example of External Classification

    Figure 3 shows an example of external classification. The example uses the same scenario where a Classification classifies an Organization instance as a Book Publisher using the NAICS standard taxonomy. However, this time the structure of the NAICS taxonomy is not available internally to the JAXR provider and consequently there is no Concept instance. Instead, the name and value attributes of the Classification are used to pinpoint the Book Publisher's taxonomy element. Note that name is optional but value is required.

    Example of External Classification
    Figure 3. Example of External Classification

    An Example of Multiple Classifications

    The next example shows how a RegistryObject may be classified by multiple classification schemes. In this example, two internal ClassificationSchemes named Industry and Geography are used to classify several Organization RegistryObjects by their industry and Geography. In Figure 4, in order to save space and improve readability, the Classification instances are not explicitly shown but are implied as associations between the RegistryObjects (shaded leaf node) and the associated Concepts.

    Example of Multiple Classifications
    Figure 4. Example of Multiple Classifications
    Author:
    Farrukh S. Najmi
    See Also:
    RegistryObject, Concept

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ClassificationScheme getClassificationScheme()
      Gets the ClassificationScheme that is used in classifying the object.
      RegistryObject getClassifiedObject()
      Gets the Object that is being classified.
      Concept getConcept()
      Gets the Concept that is classifying the object.
      String getValue()
      Gets the taxonomy value for this Classification.
      boolean isExternal()
      Returns true if this is an external classification.
      void setClassificationScheme(ClassificationScheme classificationScheme)
      Sets the ClassificationScheme for this external classification.
      void setClassifiedObject(RegistryObject classifiedObject)
      Sets the object that is being classified.
      void setConcept(Concept concept)
      Sets the concept for this internal classification.
      void setValue(String value)
      Sets the taxonomy value for this external Classification.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

    • Method Detail

      • getConcept

        Concept getConcept()
                   throws JAXRException
        Gets the Concept that is classifying the object.

        Capability Level: 0
        Returns:
        the Concept that is classifying the classified object. null if this is a external Classification
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setConcept

        void setConcept(Concept concept)
                throws JAXRException
        Sets the concept for this internal classification.

        This method should be used mutually exclusively with the setClassificationScheme method.

        Capability Level: 0
        Parameters:
        concept - the Concept that is classifying the classified object.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getClassificationScheme

        ClassificationScheme getClassificationScheme()
                                             throws JAXRException
        Gets the ClassificationScheme that is used in classifying the object. If the Classification is an internal Classification then this method should return the value returned by calling the getClassificationScheme method on the Concept representing the taxonomy element.

        Capability Level: 0
        Returns:
        the ClassificationScheme used by this Classification
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        ClassificationScheme

      • setClassificationScheme

        void setClassificationScheme(ClassificationScheme classificationScheme)
                             throws JAXRException
        Sets the ClassificationScheme for this external classification.

        If this method is called then you must also call setValue method. This method should be used mutually exclusively with the setConcept method.

        Capability Level: 0
        Parameters:
        classificationScheme - the ClassificationScheme used by this Classification
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getValue

        String getValue()
                throws JAXRException
        Gets the taxonomy value for this Classification.

        Capability Level: 0
        Returns:
        the value of the taxonomy element if external Classification; the value of the Concept representing the taxonomy element if internal Classification
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setValue

        void setValue(String value)
              throws JAXRException
        Sets the taxonomy value for this external Classification.

        Capability Level: 0
        Parameters:
        value - the taxonomy value used by this external Classification
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getClassifiedObject

        RegistryObject getClassifiedObject()
                                   throws JAXRException
        Gets the Object that is being classified.

        Capability Level: 0
        Returns:
        the RegistryObject that is classified by this Classification
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setClassifiedObject

        void setClassifiedObject(RegistryObject classifiedObject)
                         throws JAXRException
        Sets the object that is being classified.

        Capability Level: 0
        Parameters:
        classifiedObject - the RegistryObject that is classified by this Classification
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • isExternal

        boolean isExternal()
                   throws JAXRException
        Returns true if this is an external classification.

        Capability Level: 0
        Returns:
        true if this is an external Classification; false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClassificationScheme (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface ClassificationScheme

  • All Superinterfaces:
    ExtensibleObject, RegistryEntry, RegistryObject, Versionable

    public interface ClassificationScheme
extends RegistryEntry
    A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances. A very common example of a classification scheme in science is the Classification of living things where living things are categorized in under a tree like structure. Another example is the Dewey Decimal system used in libraries to categorize books and other publications. A common example in eBusiness is that of North American Industry Classification System (NAICS), which is a classification scheme used to classify businesses and services by the industry to which they belong.

    Figure 1 shows how a ClassificationScheme is used by a Classification to classify a RegistryObject.

    Using a ClassificationScheme to Classify an Object
    Figure 1. Using a ClassificationScheme to Classify an Object

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int VALUE_TYPE_EMBEDDED_PATH
      Each taxonomy value in ClassificationScheme embeds the full path from scheme to that Concept.
      static int VALUE_TYPE_NON_UNIQUE
      Taxonomy values in ClassificationScheme may be repeated within the same scheme.
      static int VALUE_TYPE_UNIQUE
      Each taxonomy value in ClassificationScheme is unique.

      • Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry

        STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addChildConcept(Concept concept)
      Adds a child Concept.
      void addChildConcepts(Collection concepts)
      Adds a Collection of Concept children.
      int getChildConceptCount()
      Gets number of children.
      Collection getChildrenConcepts()
      Gets all immediate children Concepts.
      Collection getDescendantConcepts()
      Gets all descendant Concepts.
      int getValueType()
      Gets the value type for this object.
      boolean isExternal()
      Determines whether this ClassificationScheme is an external ClassificationScheme or an internal ClassificationScheme.
      void removeChildConcept(Concept concept)
      Removes a child Concept.
      void removeChildConcepts(Collection concepts)
      Removes a Collection of children Concepts.
      void setValueType(int valueType)
      Sets the value type for this object.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry

        getExpiration, getStability, getStatus, setExpiration, setStability

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

      • Methods inherited from interface javax.xml.registry.infomodel.Versionable

        getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

    • Field Detail

      • VALUE_TYPE_UNIQUE

        static final int VALUE_TYPE_UNIQUE
        Each taxonomy value in ClassificationScheme is unique.
        See Also:
        Constant Field Values

      • VALUE_TYPE_EMBEDDED_PATH

        static final int VALUE_TYPE_EMBEDDED_PATH
        Each taxonomy value in ClassificationScheme embeds the full path from scheme to that Concept. This also implies that each taxonomy value is unique.
        See Also:
        Constant Field Values

      • VALUE_TYPE_NON_UNIQUE

        static final int VALUE_TYPE_NON_UNIQUE
        Taxonomy values in ClassificationScheme may be repeated within the same scheme. However, two Concepts that have the same parent cannot have the same value.
        See Also:
        Constant Field Values

    • Method Detail

      • addChildConcept

        void addChildConcept(Concept concept)
                     throws JAXRException
        Adds a child Concept.

        Capability Level: 0
        Parameters:
        concept - the concept being added as a child of this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addChildConcepts

        void addChildConcepts(Collection concepts)
                      throws JAXRException
        Adds a Collection of Concept children.

        Capability Level: 0
        Parameters:
        concepts - the Collection of Concepts being added as a children of this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeChildConcept

        void removeChildConcept(Concept concept)
                        throws JAXRException
        Removes a child Concept.

        Capability Level: 0
        Parameters:
        concept - the concept being removed as a child Concept of this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeChildConcepts

        void removeChildConcepts(Collection concepts)
                         throws JAXRException
        Removes a Collection of children Concepts.

        Capability Level: 0
        Parameters:
        concepts - the Collection of Concepts being removed as children Concepts of this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getChildConceptCount

        int getChildConceptCount()
                         throws JAXRException
        Gets number of children.

        Capability Level: 0
        Returns:
        the number of children Concepts
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getChildrenConcepts

        Collection getChildrenConcepts()
                               throws JAXRException
        Gets all immediate children Concepts.

        Capability Level: 0
        Returns:
        Collection of Concept instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        Concept

      • getDescendantConcepts

        Collection getDescendantConcepts()
                                 throws JAXRException
        Gets all descendant Concepts.

        Capability Level: 0
        Returns:
        Collection of Concept instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        Concept

      • isExternal

        boolean isExternal()
                   throws JAXRException
        Determines whether this ClassificationScheme is an external ClassificationScheme or an internal ClassificationScheme.

        Capability Level: 0
        Returns:
        trueif this is an external ClassificationScheme; false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getValueType

        int getValueType()
                 throws JAXRException
        Gets the value type for this object. The value type describes how taxonomy values are defined within the scheme.

        Capability Level: 1
        Returns:
        an integer constant that describes the type of values supported by this ClassificationScheme
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        VALUE_TYPE_UNIQUE, VALUE_TYPE_EMBEDDED_PATH, VALUE_TYPE_NON_UNIQUE

      • setValueType

        void setValueType(int valueType)
                  throws JAXRException
        Sets the value type for this object.

        Capability Level: 1
        Parameters:
        valueType - an integer constant that describes the type of values supported by this ClassificationScheme
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        VALUE_TYPE_UNIQUE, VALUE_TYPE_EMBEDDED_PATH, VALUE_TYPE_NON_UNIQUE
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Concept (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface Concept

  • All Superinterfaces:
    ExtensibleObject, RegistryObject

    public interface Concept
extends RegistryObject
    The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy. Concept instances are used to define tree structures where the root of the tree is a ClassificationScheme instance and each node in the tree is a Concept instance. Two Concepts may be defined as being equivalent.

    Figure 1 shows how Concept instances are used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.

    Using Concepts to Represent Taxonomy Elements
    Figure 1. Using Concepts to Represent Taxonomy Elements
    Author:
    Farrukh S. Najmi
    See Also:
    RegistryObject, Classification, ClassificationScheme

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addChildConcept(Concept concept)
      Adds a child Concept.
      void addChildConcepts(Collection concepts)
      Adds a Collection of Concept children.
      int getChildConceptCount()
      Gets number of children.
      Collection getChildrenConcepts()
      Gets all immediate children Concepts.
      ClassificationScheme getClassificationScheme()
      Gets the ClassificationScheme that this Concept is a descendent of.
      Collection getDescendantConcepts()
      Gets all descendant Concepts.
      RegistryObject getParent()
      Gets the parent Concept or ClassificationScheme for this object.
      Concept getParentConcept()
      Gets the parent Concept or null if parent is a ClassificationScheme.
      String getPath()
      Gets the canonical path representation for this Concept.
      String getValue()
      Gets the value (usually a code in a taxonomy) associated with this Concept.
      void removeChildConcept(Concept concept)
      Removes a child Concept.
      void removeChildConcepts(Collection concepts)
      Removes a Collection of children Concepts.
      void setValue(String value)
      Sets the value (usually a taxonomy value) associated with this Concept.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

    • Method Detail

      • getValue

        String getValue()
                throws JAXRException
        Gets the value (usually a code in a taxonomy) associated with this Concept.

        Capability Level: 0
        Returns:
        the value (usually a taxonomy value) associated with this Concept
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setValue

        void setValue(String value)
              throws JAXRException
        Sets the value (usually a taxonomy value) associated with this Concept.

        Capability Level: 0
        Parameters:
        value - the value (usually a taxonomy value) associated with this Concept
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addChildConcept

        void addChildConcept(Concept concept)
                     throws JAXRException
        Adds a child Concept.

        Capability Level: 0
        Parameters:
        concept - the concept being added as a child of this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addChildConcepts

        void addChildConcepts(Collection concepts)
                      throws JAXRException
        Adds a Collection of Concept children.

        Capability Level: 0
        Parameters:
        concepts - the Collection of Concepts being added as a children of this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeChildConcept

        void removeChildConcept(Concept concept)
                        throws JAXRException
        Removes a child Concept.

        Capability Level: 0
        Parameters:
        concept - the concept being removed as a child Concept of this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeChildConcepts

        void removeChildConcepts(Collection concepts)
                         throws JAXRException
        Removes a Collection of children Concepts.

        Capability Level: 0
        Parameters:
        concepts - the Collection of Concepts being removed as children Concepts of this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getChildConceptCount

        int getChildConceptCount()
                         throws JAXRException
        Gets number of children.

        Capability Level: 0
        Returns:
        the number of children Concepts
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getChildrenConcepts

        Collection getChildrenConcepts()
                               throws JAXRException
        Gets all immediate children Concepts.

        Capability Level: 0
        Returns:
        Collection of Concept instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        Concept

      • getDescendantConcepts

        Collection getDescendantConcepts()
                                 throws JAXRException
        Gets all descendant Concepts.

        Capability Level: 0
        Returns:
        Collection of Concept instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        Concept

      • getParentConcept

        Concept getParentConcept()
                         throws JAXRException
        Gets the parent Concept or null if parent is a ClassificationScheme.

        Capability Level: 0
        Returns:
        the Concept that is the parent of this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getClassificationScheme

        ClassificationScheme getClassificationScheme()
                                             throws JAXRException
        Gets the ClassificationScheme that this Concept is a descendent of.

        Capability Level: 0
        Returns:
        the ClassificationScheme that is the ancestor of this object. May return null
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getPath

        String getPath()
               throws JAXRException
        Gets the canonical path representation for this Concept.

        Capability Level: 0
        Returns:
        the canonical path String representing this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getParent

        RegistryObject getParent()
                         throws JAXRException
        Gets the parent Concept or ClassificationScheme for this object.

        Capability Level: 0
        Returns:
        the parent Concept or ClassificationScheme for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EmailAddress (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface EmailAddress

  • public interface EmailAddress
    Represents an email address.
    Author:
    Farrukh S. Najmi
    See Also:
    User

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAddress()
      Returns the email address for this object.
      String getType()
      Gets the type for this object.
      void setAddress(String address)
      Sets the email address for this object.
      void setType(String type)
      Sets the type for this object.

    • Method Detail

      • getAddress

        String getAddress()
                  throws JAXRException
        Returns the email address for this object. Default is a NULL String.

        Capability Level: 0
        Returns:
        the actual email address (e.g. john.doe@acme.com)
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setAddress

        void setAddress(String address)
                throws JAXRException
        Sets the email address for this object.

        Capability Level: 0
        Parameters:
        address - the actual email address (e.g. john.doe@acme.com)
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getType

        String getType()
               throws JAXRException
        Gets the type for this object. Default is a NULL String.

        Capability Level: 0
        Returns:
        the usage type for this object which is an arbitrary value (e.g. "Home" or "Office")
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setType

        void setType(String type)
             throws JAXRException
        Sets the type for this object.

        Capability Level: 0
        Parameters:
        type - the usage type for this object which is an arbitrary value (e.g. "Home" or "Office")
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExtensibleObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface ExtensibleObject

  • All Known Subinterfaces:
    Association, AuditableEvent, Classification, ClassificationScheme, Concept, ExternalIdentifier, ExternalLink, ExtrinsicObject, Organization, PostalAddress, RegistryEntry, RegistryObject, RegistryPackage, Service, ServiceBinding, SpecificationLink, User

    public interface ExtensibleObject
    An ExtensibleObject is one that allows itself to be extended by utilizing dynamically added Slots that add arbitrary attributes to the object on a per instance basis.
    Author:
    Farrukh S. Najmi
    See Also:
    Slot

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addSlot(Slot slot)
      Adds a Slot to this object.
      void addSlots(Collection slots)
      Adds more Slots to this object.
      Slot getSlot(String slotName)
      Gets the slot specified by slotName.
      Collection getSlots()
      Returns the Slots associated with this object.
      void removeSlot(String slotName)
      Removes a Slot from this object.
      void removeSlots(Collection slotNames)
      Removes specified Slots from this object.

    • Method Detail

      • addSlot

        void addSlot(Slot slot)
             throws JAXRException
        Adds a Slot to this object.

        Capability Level: 0
        Parameters:
        slot - the Slot object being added to this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addSlots

        void addSlots(Collection slots)
              throws JAXRException
        Adds more Slots to this object.

        Capability Level: 0
        Parameters:
        slots - the Collection of Slot objects being added to this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeSlot

        void removeSlot(String slotName)
                throws JAXRException
        Removes a Slot from this object. The Slot is identified by its name.

        Capability Level: 0
        Parameters:
        slotName - the name for the Slot object being removed from this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeSlots

        void removeSlots(Collection slotNames)
                 throws JAXRException
        Removes specified Slots from this object. The Slots are identified by its name.

        Capability Level: 0
        Parameters:
        slotNames - the Collection of names for Slot objects being removed from this object. Must be a Collection of Strings
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getSlot

        Slot getSlot(String slotName)
             throws JAXRException
        Gets the slot specified by slotName.

        Capability Level: 0
        Parameters:
        slotName - the name of the desired Slot object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getSlots

        Collection getSlots()
                    throws JAXRException
        Returns the Slots associated with this object.

        Capability Level: 0
        Returns:
        Collection of Slot instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExternalIdentifier (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface ExternalIdentifier

  • All Superinterfaces:
    ExtensibleObject, RegistryObject

    public interface ExternalIdentifier
extends RegistryObject
    ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization. The attribute name inherited from RegistryObject is used to contain the identification scheme ("DUNS" "Social Security Number", etc.), and the attribute value contains the actual information (e.g. the actual DUNS number). Each RegistryObject may have 0 or more ExternalIdentifiers.
    Author:
    Farrukh S. Najmi
    See Also:
    RegistryObject

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ClassificationScheme getIdentificationScheme()
      Gets the ClassificationScheme that is used as the identification scheme for identifying this object.
      RegistryObject getRegistryObject()
      Gets the parent RegistryObject for this ExternalIdentifier.
      String getValue()
      Gets the value of an ExternalIdentifier.
      void setIdentificationScheme(ClassificationScheme identificationScheme)
      Sets the ClassificationScheme that is used as the identification scheme for identifying this object.
      void setValue(String value)
      Sets the value of an ExternalIdentifier.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

    • Method Detail

      • getRegistryObject

        RegistryObject getRegistryObject()
                                 throws JAXRException
        Gets the parent RegistryObject for this ExternalIdentifier. To set the registryObject call addExternalIdentifier on a RegistryObject.

        Capability Level: 0
        Returns:
        the RegistryObject that this object identifies
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        RegistryObject.addExternalIdentifier(ExternalIdentifier ei)

      • getValue

        String getValue()
                throws JAXRException
        Gets the value of an ExternalIdentifier.

        Capability Level: 0
        Returns:
        the identification value defined by this object (e.g. a company's DUNS number)
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setValue

        void setValue(String value)
              throws JAXRException
        Sets the value of an ExternalIdentifier.

        Capability Level: 0
        Parameters:
        value - the identification value defined by this object (e.g. a company's DUNS number)
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getIdentificationScheme

        ClassificationScheme getIdentificationScheme()
                                             throws JAXRException
        Gets the ClassificationScheme that is used as the identification scheme for identifying this object.

        Capability Level: 0
        Returns:
        the ClassificationScheme that is used as the identification scheme (e.g. "DUNS")
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setIdentificationScheme

        void setIdentificationScheme(ClassificationScheme identificationScheme)
                             throws JAXRException
        Sets the ClassificationScheme that is used as the identification scheme for identifying this object.

        Capability Level: 0
        Parameters:
        identificationScheme - the ClassificationScheme that is used as the identification scheme (e.g. "DUNS")
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExternalLink (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface ExternalLink

  • All Superinterfaces:
    ExtensibleObject, RegistryObject, URIValidator

    public interface ExternalLink
extends RegistryObject, URIValidator
    ExternalLink instances model a named URI to content that may reside outside the registry. RegistryObject may be associated with any number of ExternalLinks to annotate a RegistryObject with external links to external content.

    Consider the case where a Submitting Organization submits a repository item (e.g. a DTD) and wants to associate some external content to that object (e.g. the Submitting Organization's home page). The ExternalLink enables this capability.

    Author:
    Farrukh S. Najmi
    See Also:
    RegistryObject

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getExternalURI()
      Gets URI to the an external resource.
      Collection getLinkedObjects()
      Gets the collection of RegistryObjects that are annotated by this ExternalLink.
      void setExternalURI(String uri)
      Sets URI for an external resource.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

      • Methods inherited from interface javax.xml.registry.infomodel.URIValidator

        getValidateURI, setValidateURI

    • Method Detail

      • getLinkedObjects

        Collection getLinkedObjects()
                            throws JAXRException
        Gets the collection of RegistryObjects that are annotated by this ExternalLink.

        Capability Level: 0
        Returns:
        Collection of RegistryObjects. Return an empty Collection if no RegistryObjects are annotated by this object.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getExternalURI

        String getExternalURI()
                      throws JAXRException
        Gets URI to the an external resource. Default is a NULL String.

        Capability Level: 0
        Returns:
        the URI String for this object (e.g. "http://java.sun.com")
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setExternalURI

        void setExternalURI(String uri)
                    throws JAXRException
        Sets URI for an external resource.

        Capability Level: 0
        Parameters:
        uri - the URI String for this object (e.g. "http://java.sun.com")
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExtrinsicObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface ExtrinsicObject

  • All Superinterfaces:
    ExtensibleObject, RegistryEntry, RegistryObject, Versionable

    public interface ExtrinsicObject
extends RegistryEntry
    ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).

    Examples of content described by ExtrinsicObject include Collaboration Protocol Profiles (CPP), business process descriptions, and schemas.

    Author:
    Farrukh S. Najmi

    • Field Summary

      • Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry

        STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getMimeType()
      Gets the mime type associated with this object.
      DataHandler getRepositoryItem()
      Gets the repository item for this object.
      boolean isOpaque()
      Determines whether the ExtrinsicObject is opaque (not readable) by the registry operator.
      void setMimeType(String mimeType)
      Sets the mime type associated with this object.
      void setOpaque(boolean isOpaque)
      Sets whether the ExtrinsicObject is opaque (not readable) by the registry.
      void setRepositoryItem(DataHandler repositoryItem)
      Sets the repository item for this object.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry

        getExpiration, getStability, getStatus, setExpiration, setStability

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

      • Methods inherited from interface javax.xml.registry.infomodel.Versionable

        getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

    • Method Detail

      • getMimeType

        String getMimeType()
                   throws JAXRException
        Gets the mime type associated with this object. Default is a NULL String.

        Capability Level: 1
        Returns:
        the mime type associated with this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setMimeType

        void setMimeType(String mimeType)
                 throws JAXRException
        Sets the mime type associated with this object.

        Capability Level: 1
        Parameters:
        mimeType - the mime type associated with this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • isOpaque

        boolean isOpaque()
                 throws JAXRException
        Determines whether the ExtrinsicObject is opaque (not readable) by the registry operator.

        In some situations, a Submitting Organization may submit content that is encrypted and not even readable by the registry. This attribute allows the registry to know whether this is the case.

        Capability Level: 1
        Returns:
        true if the ExtrinsicObject is readable by the registry operator; false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setOpaque

        void setOpaque(boolean isOpaque)
               throws JAXRException
        Sets whether the ExtrinsicObject is opaque (not readable) by the registry.

        Capability Level: 1
        Parameters:
        isOpaque - boolean value set to true if the ExtrinsicObject is readable by the registry operator; false otherwise
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getRepositoryItem

        DataHandler getRepositoryItem()
                              throws JAXRException
        Gets the repository item for this object. Must not return null.

        Capability Level: 1
        Returns:
        the DataHandler for the repository item
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setRepositoryItem

        void setRepositoryItem(DataHandler repositoryItem)
                       throws JAXRException
        Sets the repository item for this object.

        Capability Level: 1
        Parameters:
        repositoryItem - the DataHandler for the repository item. Must not be null
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InternationalString (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface InternationalString

  • public interface InternationalString
    This interface represents a String that has been internationalized into several Locales. This interface is used as a replacement for the String type whenever a String attribute needs to be I18N capable. An instance of the InternationalString interface composes within it a Collection of LocalizedString instances, where each String is specific to a particular Locale. The InternationalString interface provides set/get methods for adding or getting locale specific String values for the InternationalString instance.
    Author:
    Farrukh S. Najmi
    See Also:
    LocalizedString

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addLocalizedString(LocalizedString localizedString)
      Adds a LocalizedString to this object.
      void addLocalizedStrings(Collection localizedStrings)
      Adds many LocalizedStrings to this object.
      LocalizedString getLocalizedString(Locale locale, String charsetName)
      Gets the LocalizedString for the specified Locale and charsetName.
      Collection getLocalizedStrings()
      Returns the LocalizedStrings associated with this object.
      String getValue()
      Gets the String value for the Locale returned by Locale.getDefault().
      String getValue(Locale locale)
      Gets the String value for the specified Locale.
      void removeLocalizedString(LocalizedString localizedString)
      Removes a LocalizedString from this object.
      void removeLocalizedStrings(Collection localizedStrings)
      Removes specified LocalizedStrings to this object.
      void setValue(Locale locale, String value)
      Sets the String value for the specified Locale.
      void setValue(String value)
      Sets the String value for the Locale returned by Locale.getDefault().

    • Method Detail

      • getValue

        String getValue()
                throws JAXRException
        Gets the String value for the Locale returned by Locale.getDefault().

        Capability Level: 0
        Returns:
        the String value for the Locale returned by Locale.getDefault()
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getValue

        String getValue(Locale locale)
                throws JAXRException
        Gets the String value for the specified Locale. Return null if no locale specific value is found for the specified locale.

        Capability Level: 0
        Parameters:
        locale - The Locale for the desired value
        Returns:
        the String value for the specified Locale
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setValue

        void setValue(String value)
              throws JAXRException
        Sets the String value for the Locale returned by Locale.getDefault().

        Capability Level: 0
        Parameters:
        value - the String value for the Locale returned by Locale.getDefault()
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setValue

        void setValue(Locale locale,
            String value)
              throws JAXRException
        Sets the String value for the specified Locale.

        Capability Level: 0
        Parameters:
        locale - The locale for this value being set
        value - The value being set
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addLocalizedString

        void addLocalizedString(LocalizedString localizedString)
                        throws JAXRException
        Adds a LocalizedString to this object.

        Capability Level: 0
        Parameters:
        localizedString - the LocalizedString being added to this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addLocalizedStrings

        void addLocalizedStrings(Collection localizedStrings)
                         throws JAXRException
        Adds many LocalizedStrings to this object.

        Capability Level: 0
        Parameters:
        localizedStrings - the Collection of LocalizedStrings being added to this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeLocalizedString

        void removeLocalizedString(LocalizedString localizedString)
                           throws JAXRException
        Removes a LocalizedString from this object.

        Capability Level: 0
        Parameters:
        localizedString - the LocalizedString being removed from this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeLocalizedStrings

        void removeLocalizedStrings(Collection localizedStrings)
                            throws JAXRException
        Removes specified LocalizedStrings to this object.

        Capability Level: 0
        Parameters:
        localizedStrings - the Collection of LocalizedStrings being removed from this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getLocalizedString

        LocalizedString getLocalizedString(Locale locale,
                                 String charsetName)
                                   throws JAXRException
        Gets the LocalizedString for the specified Locale and charsetName.

        Capability Level: 0
        Parameters:
        locale - The loacle for the desired LocalizedStrings
        charsetName - The character set name for the desired LocalizedStrings
        Returns:
        the LocalizedString that matches specified locale and character set
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getLocalizedStrings

        Collection getLocalizedStrings()
                               throws JAXRException
        Returns the LocalizedStrings associated with this object.

        Capability Level: 0
        Returns:
        Collection of LocalizedString instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        LocalizedString
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.registry.infomodel (Java(TM) EE 7 Specification APIs)

javax.xml.registry.infomodel

Interfaces

  • Association
  • AuditableEvent
  • Classification
  • ClassificationScheme
  • Concept
  • EmailAddress
  • ExtensibleObject
  • ExternalIdentifier
  • ExternalLink
  • ExtrinsicObject
  • InternationalString
  • Key
  • LocalizedString
  • Organization
  • PersonName
  • PostalAddress
  • RegistryEntry
  • RegistryObject
  • RegistryPackage
  • Service
  • ServiceBinding
  • Slot
  • SpecificationLink
  • TelephoneNumber
  • URIValidator
  • User
  • Versionable


javax.xml.registry.infomodel (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.registry.infomodel

This package defines interfaces that define the information model for metadata registries.

See: Description

  • Interface Summary
    Interface Description
    Association
    A RegistryObject instance may be associated with zero or more RegistryObject instances.
    AuditableEvent
    AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject.
    Classification
    The Classification interface is used to classify RegistryObject instances.
    ClassificationScheme
    A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
    Concept
    The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.
    EmailAddress
    Represents an email address.
    ExtensibleObject
    An ExtensibleObject is one that allows itself to be extended by utilizing dynamically added Slots that add arbitrary attributes to the object on a per instance basis.
    ExternalIdentifier
    ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization.
    ExternalLink
    ExternalLink instances model a named URI to content that may reside outside the registry.
    ExtrinsicObject
    ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).
    InternationalString
    This interface represents a String that has been internationalized into several Locales.
    Key
    Represents a unique key that identifies a RegistryObject.
    LocalizedString
    This interface is used as a simple wrapper interface that associates a String with its Locale.
    Organization
    Organization instances provide information on organizations such as a Submitting Organization.
    PersonName
    Represents a person's name.
    PostalAddress
    PostalAddress is a simple re-usable entity class that defines attributes of a postal Address.
    RegistryEntry
    The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface.
    RegistryObject
    The RegistryObject class is an abstract base class used by most classes in the model.
    RegistryPackage
    RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together.
    Service
    Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization.
    ServiceBinding
    ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance.
    Slot
    Slot instances provide a dynamic way to add arbitrary attributes to RegistryObject instances.
    SpecificationLink
    A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding.
    TelephoneNumber
    A simple re-usable entity class that defines attributes of a telephone number.
    URIValidator
    Defines common behavior expected of any class that validates URIs.
    User
    User instances are RegistryObjects that are used to provide information about registered users within the registry.
    Versionable
    The Versionable interface defines the behavior common to classes that are capable of creating versions of their instances.

Package javax.xml.registry.infomodel Description

This package defines interfaces that define the information model for metadata registries.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.registry.infomodel Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.registry.infomodel

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.registry.infomodel.EmailAddress
  • javax.xml.registry.infomodel.ExtensibleObject
    • javax.xml.registry.infomodel.PostalAddress
    • javax.xml.registry.infomodel.RegistryObject
      • javax.xml.registry.infomodel.Association
      • javax.xml.registry.infomodel.AuditableEvent
      • javax.xml.registry.infomodel.Classification
      • javax.xml.registry.infomodel.Concept
      • javax.xml.registry.infomodel.ExternalIdentifier
      • javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.URIValidator)
      • javax.xml.registry.infomodel.Organization
      • javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.Versionable)
        • javax.xml.registry.infomodel.ClassificationScheme
        • javax.xml.registry.infomodel.ExtrinsicObject
        • javax.xml.registry.infomodel.RegistryPackage
        • javax.xml.registry.infomodel.Service
      • javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.URIValidator)
      • javax.xml.registry.infomodel.SpecificationLink
      • javax.xml.registry.infomodel.User
  • javax.xml.registry.infomodel.InternationalString
  • javax.xml.registry.infomodel.Key
  • javax.xml.registry.infomodel.LocalizedString
  • javax.xml.registry.infomodel.PersonName
  • javax.xml.registry.infomodel.Slot
  • javax.xml.registry.infomodel.TelephoneNumber
  • javax.xml.registry.infomodel.URIValidator
    • javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.RegistryObject)
    • javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.RegistryObject)
  • javax.xml.registry.infomodel.Versionable
    • javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.RegistryObject)
      • javax.xml.registry.infomodel.ClassificationScheme
      • javax.xml.registry.infomodel.ExtrinsicObject
      • javax.xml.registry.infomodel.RegistryPackage
      • javax.xml.registry.infomodel.Service
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Key (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface Key

  • public interface Key
    Represents a unique key that identifies a RegistryObject. Must be a DCE 128 UUID.
    Author:
    Farrukh S. Najmi
    See Also:
    RegistryObject

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getId()
      Returns the unique Id of this key.
      void setId(String id)
      Sets the unique id associated with this key.

    • Method Detail

      • getId

        String getId()
             throws JAXRException
        Returns the unique Id of this key. Default is a NULL String.

        Capability Level: 0
        Returns:
        the id for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setId

        void setId(String id)
           throws JAXRException
        Sets the unique id associated with this key.

        Capability Level: 0
        Parameters:
        id - the id being defined for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LocalizedString (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface LocalizedString

  • public interface LocalizedString
    This interface is used as a simple wrapper interface that associates a String with its Locale. The interface is needed in the InternationalString interface where a Collection of LocalizedString instances are kept. Each LocalizedString instance has a Locale and a String instance.
    Author:
    Farrukh S. Najmi
    See Also:
    InternationalString

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DEFAULT_CHARSET_NAME
      The default name returned by getCharsetName if no other name has explicitly been set.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getCharsetName()
      Gets the canonical name for the charset for this object.
      Locale getLocale()
      Get the Locale for this object.
      String getValue()
      Get the String value for this object.
      void setCharsetName(String charsetName)
      Set the canonical name for the charset for this object.
      void setLocale(Locale locale)
      Set the Locale for this object.
      void setValue(String value)
      Set the String value for the specified object.

    • Field Detail

      • DEFAULT_CHARSET_NAME

        static final String DEFAULT_CHARSET_NAME
        The default name returned by getCharsetName if no other name has explicitly been set.
        See Also:
        Constant Field Values

    • Method Detail

      • getCharsetName

        String getCharsetName()
                      throws JAXRException
        Gets the canonical name for the charset for this object. Must return the default charset when there is no charset name defined.

        Capability Level: 0
        Returns:
        the character set name for the character set used by this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        DEFAULT_CHARSET_NAME

      • getLocale

        Locale getLocale()
                 throws JAXRException
        Get the Locale for this object. Must return the default Locale when no Locale has been defined.

        Capability Level: 0
        Returns:
        the Locale used by this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        Locale.getDefault()

      • getValue

        String getValue()
                throws JAXRException
        Get the String value for this object.

        Capability Level: 0
        Returns:
        the value defined by this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setCharsetName

        void setCharsetName(String charsetName)
                    throws JAXRException
        Set the canonical name for the charset for this object.

        Capability Level: 0
        Parameters:
        charsetName - the character set name for the character set used by this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setLocale

        void setLocale(Locale locale)
               throws JAXRException
        Set the Locale for this object.

        Capability Level: 0
        Parameters:
        locale - the Locale used by this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setValue

        void setValue(String value)
              throws JAXRException
        Set the String value for the specified object.

        Capability Level: 0
        Parameters:
        value - the value defined by this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Organization (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface Organization

  • All Superinterfaces:
    ExtensibleObject, RegistryObject

    public interface Organization
extends RegistryObject
    Organization instances provide information on organizations such as a Submitting Organization. Each Organization instance may have a reference to a parent Organization. In addition it may have a contact attribute defining the primary contact within the organization. An Organization also has an address attribute.
    Author:
    Farrukh S. Najmi
    See Also:
    Service

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addChildOrganization(Organization organization)
      Adds a child Organization.
      void addChildOrganizations(Collection organizations)
      Adds a Collection of Organization children.
      void addService(Service service)
      Adds a child Service.
      void addServices(Collection services)
      Adds a Collection of Service children.
      void addUser(User user)
      Adds a User.
      void addUsers(Collection users)
      Adds a Collection of Users.
      int getChildOrganizationCount()
      Gets number of children.
      Collection getChildOrganizations()
      Gets all immediate children Organizations.
      Collection getDescendantOrganizations()
      Gets all descendant Organizations.
      Organization getParentOrganization()
      Gets the parent (container) organization.
      PostalAddress getPostalAddress()
      Gets the Address for this Organization.
      User getPrimaryContact()
      Gets the primary Contact for this Organization.
      Organization getRootOrganization()
      Gets the root organization.
      Collection getServices()
      Gets all children Services.
      Collection getTelephoneNumbers(String phoneType)
      Gets the telephone numbers for this User that match the specified telephone number type.
      Collection getUsers()
      Gets the Collection of Users affiliated with this Organization.
      void removeChildOrganization(Organization organization)
      Removes a child Organization.
      void removeChildOrganizations(Collection organizations)
      Removes a Collection of children Organizations.
      void removeService(Service service)
      Removes a Service from this object.
      void removeServices(Collection services)
      Removes a Collection of children Services from this object.
      void removeUser(User user)
      Removes a User.
      void removeUsers(Collection users)
      Removes a Collection of Users.
      void setPostalAddress(PostalAddress address)
      Sets the address for this Organization.
      void setPrimaryContact(User primaryContact)
      Sets the primary contact for this Organization.
      void setTelephoneNumbers(Collection phoneNumbers)
      Sets the various telephone numbers for this user.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

    • Method Detail

      • getPostalAddress

        PostalAddress getPostalAddress()
                               throws JAXRException
        Gets the Address for this Organization.

        Capability Level: 1
        Returns:
        the PostalAddress for this Organization
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setPostalAddress

        void setPostalAddress(PostalAddress address)
                      throws JAXRException
        Sets the address for this Organization.

        Capability Level: 1
        Parameters:
        address - the PostalAddress for this Organization
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getPrimaryContact

        User getPrimaryContact()
                       throws JAXRException
        Gets the primary Contact for this Organization. The primary contact is one of the Users of the Organization, as returned by the getUsers call on an Organization instance.

        Capability Level: 0
        Returns:
        the User that is the primary Contact for this Organization. Must not be null
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setPrimaryContact

        void setPrimaryContact(User primaryContact)
                       throws JAXRException
        Sets the primary contact for this Organization. If the primary contact is not in the existing Collection of User instances for this object then it must be added to that Collection. If the primary contact is already in the existing Collection of User instances for this object, then it should not be added to the Users collection as a duplicate entry. In either case, the primary contact is a distinguished User instance within the Collection of User instances for this Object.

        Capability Level: 0
        Parameters:
        primaryContact - the User that is the primary Contact for this Organization
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addUser

        void addUser(User user)
             throws JAXRException
        Adds a User.

        Capability Level: 0
        Parameters:
        user - the User being added to this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addUsers

        void addUsers(Collection users)
              throws JAXRException
        Adds a Collection of Users.

        Capability Level: 0
        Parameters:
        users - the Collection of Users being added to this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeUser

        void removeUser(User user)
                throws JAXRException
        Removes a User.

        Capability Level: 0
        Parameters:
        user - the User being removed from this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeUsers

        void removeUsers(Collection users)
                 throws JAXRException
        Removes a Collection of Users.

        Capability Level: 0
        Parameters:
        users - the Collection of Users being removed from this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getUsers

        Collection getUsers()
                    throws JAXRException
        Gets the Collection of Users affiliated with this Organization. One of these users is designated as the primary contact.

        Capability Level: 0
        Returns:
        Collection of User instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        User

      • getTelephoneNumbers

        Collection getTelephoneNumbers(String phoneType)
                               throws JAXRException
        Gets the telephone numbers for this User that match the specified telephone number type. If phoneType is null return all telephoneNumbers.

        Capability Level: 0
        Parameters:
        phoneType - a String that specifies the type of phone numbers desired
        Returns:
        Collection of TelephoneNumber instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        TelephoneNumber

      • setTelephoneNumbers

        void setTelephoneNumbers(Collection phoneNumbers)
                         throws JAXRException
        Sets the various telephone numbers for this user.

        Capability Level: 0
        Parameters:
        phoneNumbers - the TelephoneNumbers being set for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addService

        void addService(Service service)
                throws JAXRException
        Adds a child Service.

        Capability Level: 0
        Parameters:
        service - the Service being added to this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addServices

        void addServices(Collection services)
                 throws JAXRException
        Adds a Collection of Service children.

        Capability Level: 0
        Parameters:
        services - the Collection of Services being added to this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeService

        void removeService(Service service)
                   throws JAXRException
        Removes a Service from this object.

        Capability Level: 0
        Parameters:
        service - the Service being removed from this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeServices

        void removeServices(Collection services)
                    throws JAXRException
        Removes a Collection of children Services from this object.

        Capability Level: 0
        Parameters:
        services - the Collection of Services being removed from this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getServices

        Collection getServices()
                       throws JAXRException
        Gets all children Services.

        Capability Level: 0
        Returns:
        Collection of Service instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        Service

      • addChildOrganization

        void addChildOrganization(Organization organization)
                          throws JAXRException
        Adds a child Organization.

        Capability Level: 1
        Parameters:
        organization - the child Organization being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addChildOrganizations

        void addChildOrganizations(Collection organizations)
                           throws JAXRException
        Adds a Collection of Organization children.

        Capability Level: 1
        Parameters:
        organizations - the Collection of child Organizations being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeChildOrganization

        void removeChildOrganization(Organization organization)
                             throws JAXRException
        Removes a child Organization.

        Capability Level: 1
        Parameters:
        organization - the child Organization being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeChildOrganizations

        void removeChildOrganizations(Collection organizations)
                              throws JAXRException
        Removes a Collection of children Organizations.

        Capability Level: 1
        Parameters:
        organizations - the Collection of child Organizations being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getChildOrganizationCount

        int getChildOrganizationCount()
                              throws JAXRException
        Gets number of children.

        Capability Level: 1
        Returns:
        the number of children Organizations
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getChildOrganizations

        Collection getChildOrganizations()
                                 throws JAXRException
        Gets all immediate children Organizations.

        Capability Level: 1
        Returns:
        Collection of Organization instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        Organization

      • getDescendantOrganizations

        Collection getDescendantOrganizations()
                                      throws JAXRException
        Gets all descendant Organizations.

        Capability Level: 1
        Returns:
        Collection of Organization instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        Organization

      • getParentOrganization

        Organization getParentOrganization()
                                   throws JAXRException
        Gets the parent (container) organization.

        Capability Level: 1
        Returns:
        the parent Organization or null if object has no parent Organization
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getRootOrganization

        Organization getRootOrganization()
                                 throws JAXRException
        Gets the root organization.

        Capability Level: 1
        Returns:
        the root Organization or null if object has no parent Organization
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PersonName (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface PersonName

  • public interface PersonName
    Represents a person's name.
    Author:
    Farrukh S. Najmi

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getFirstName()
      Gets the first name for this Person.
      String getFullName()
      Gets the fully formatted name for this person.
      String getLastName()
      Gets the last name (surname) for this Person.
      String getMiddleName()
      Gets the middle name for this Person.
      void setFirstName(String firstName)
      Sets the first name for this Person.
      void setFullName(String fullName)
      Sets the fully formatted name for this person.
      void setLastName(String lastName)
      Sets the last name (surname) for this Person.
      void setMiddleName(String middleName)
      Sets the middle name for this Person.

    • Method Detail

      • getLastName

        String getLastName()
                   throws JAXRException
        Gets the last name (surname) for this Person. Default is a NULL String.

        Capability Level: 1
        Returns:
        the person's last name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setLastName

        void setLastName(String lastName)
                 throws JAXRException
        Sets the last name (surname) for this Person.

        Capability Level: 1
        Parameters:
        lastName - the person's last name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getFirstName

        String getFirstName()
                    throws JAXRException
        Gets the first name for this Person. Default is an empty String.

        Capability Level: 1
        Returns:
        the person's first name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setFirstName

        void setFirstName(String firstName)
                  throws JAXRException
        Sets the first name for this Person.

        Capability Level: 1
        Parameters:
        firstName - the person's first name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getMiddleName

        String getMiddleName()
                     throws JAXRException
        Gets the middle name for this Person. Default is an empty String.

        Capability Level: 1
        Returns:
        the person's middle name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setMiddleName

        void setMiddleName(String middleName)
                   throws JAXRException
        Sets the middle name for this Person.

        Capability Level: 1
        Parameters:
        middleName - the person's middle name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getFullName

        String getFullName()
                   throws JAXRException
        Gets the fully formatted name for this person. Default is an empty String.

        Capability Level: 0
        Returns:
        the person's full name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setFullName

        void setFullName(String fullName)
                 throws JAXRException
        Sets the fully formatted name for this person.

        Capability Level: 0
        Parameters:
        fullName - the person's full name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PostalAddress (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface PostalAddress

  • All Superinterfaces:
    ExtensibleObject

    public interface PostalAddress
extends ExtensibleObject
    PostalAddress is a simple re-usable entity class that defines attributes of a postal Address.
    Author:
    Farrukh S. Najmi

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getCity()
      Returns the city.
      String getCountry()
      Returns the country.
      String getPostalCode()
      Returns the postal or zip code.
      ClassificationScheme getPostalScheme()
      Returns a user-defined postal scheme for codifying the attributes of PostalAddress.
      String getStateOrProvince()
      Returns the state or province.
      String getStreet()
      Returns the street name.
      String getStreetNumber()
      Returns the street number.
      String getType()
      Returns the type of address (for example, "headquarters") as a String.
      void setCity(String city)
      Sets the city.
      void setCountry(String country)
      Sets the country.
      void setPostalCode(String postalCode)
      Sets the postal or zip code.
      void setPostalScheme(ClassificationScheme scheme)
      Sets a user-defined postal scheme for codifying the attributes of PostalAddress.
      void setStateOrProvince(String stateOrProvince)
      Sets the state or province.
      void setStreet(String street)
      Sets the street name.
      void setStreetNumber(String streetNumber)
      Sets the street number.
      void setType(String type)
      Sets the type of address (for example, "headquarters") as a String.

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

    • Method Detail

      • getStreet

        String getStreet()
                 throws JAXRException
        Returns the street name. Default is an empty String.

        Capability Level: 0
        Returns:
        the street name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setStreet

        void setStreet(String street)
               throws JAXRException
        Sets the street name.

        Capability Level: 0
        Parameters:
        street - the street name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getStreetNumber

        String getStreetNumber()
                       throws JAXRException
        Returns the street number. Default is an empty String.

        Capability Level: 0
        Returns:
        the street number
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setStreetNumber

        void setStreetNumber(String streetNumber)
                     throws JAXRException
        Sets the street number.

        Capability Level: 0
        Parameters:
        streetNumber - the street number
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getCity

        String getCity()
               throws JAXRException
        Returns the city. Default is an empty String.

        Capability Level: 0
        Returns:
        the city
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setCity

        void setCity(String city)
             throws JAXRException
        Sets the city.

        Capability Level: 0
        Parameters:
        city - the city
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getStateOrProvince

        String getStateOrProvince()
                          throws JAXRException
        Returns the state or province. Default is an empty String.

        Capability Level: 0
        Returns:
        the state or province
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setStateOrProvince

        void setStateOrProvince(String stateOrProvince)
                        throws JAXRException
        Sets the state or province.

        Capability Level: 0
        Parameters:
        stateOrProvince - the state or province
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getPostalCode

        String getPostalCode()
                     throws JAXRException
        Returns the postal or zip code. Default is an empty String.

        Capability Level: 0
        Returns:
        the postal code (e.g. US zip code)
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setPostalCode

        void setPostalCode(String postalCode)
                   throws JAXRException
        Sets the postal or zip code.

        Capability Level: 0
        Parameters:
        postalCode - the postal code (e.g. US zip code)
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getCountry

        String getCountry()
                  throws JAXRException
        Returns the country. Default is an empty String.

        Capability Level: 0
        Returns:
        the country
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setCountry

        void setCountry(String country)
                throws JAXRException
        Sets the country.

        Capability Level: 0
        Parameters:
        country - the country
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getType

        String getType()
               throws JAXRException
        Returns the type of address (for example, "headquarters") as a String.

        Capability Level: 0
        Returns:
        the type for this PostalAddress. This is an arbitrary String (e.g. "Home", "Office")
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setType

        void setType(String type)
             throws JAXRException
        Sets the type of address (for example, "headquarters") as a String.

        Capability Level: 0
        Parameters:
        type - the type for this PostalAddress. This is an arbitrary String (e.g. "Home", "Office")
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setPostalScheme

        void setPostalScheme(ClassificationScheme scheme)
                     throws JAXRException
        Sets a user-defined postal scheme for codifying the attributes of PostalAddress.

        Capability Level: 0
        Parameters:
        scheme - the user defined postal scheme.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getPostalScheme

        ClassificationScheme getPostalScheme()
                                     throws JAXRException
        Returns a user-defined postal scheme for codifying the attributes of PostalAddress. If none is defined for this object, then must return the default value returned by RegistryService#getDefaultPostalScheme()

        Capability Level: 0
        Returns:
        the user defined postal scheme.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        RegistryService.getDefaultPostalScheme()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RegistryEntry (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface RegistryEntry

  • All Superinterfaces:
    ExtensibleObject, RegistryObject, Versionable
    All Known Subinterfaces:
    ClassificationScheme, ExtrinsicObject, RegistryPackage, Service

    public interface RegistryEntry
extends RegistryObject, Versionable
    The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface. A few interfaces in the model represent high level (coarse grain) objects in the registry that require additional metadata such as version information and indication of the stability or volatility of the information.
    Author:
    Farrukh S. Najmi

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int STABILITY_DYNAMIC
      RegistryEntry may change at any time.
      static int STABILITY_DYNAMIC_COMPATIBLE
      RegistryEntry may change at any time, however the changes will be backward compatible.
      static int STABILITY_STATIC
      RegistryEntry will not change.
      static int STATUS_APPROVED
      RegistryEntry has been submitted and approved.
      static int STATUS_DEPRECATED
      RegistryEntry has been deprecated.
      static int STATUS_SUBMITTED
      RegistryEntry has been submitted.
      static int STATUS_WITHDRAWN
      RegistryEntry has been withdrawn by the submitter.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Date getExpiration()
      Gets expirationDate attribute of the RegistryEntry within the Registry.
      int getStability()
      Gets the stability indicator for the RegistryEntry within the Registry.
      int getStatus()
      Gets the life cycle status of the RegistryEntry within the registry.
      void setExpiration(Date expiration)
      Sets the expirationDate.
      void setStability(int stability)
      Sets the stability indicator for the RegistryEntry.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

      • Methods inherited from interface javax.xml.registry.infomodel.Versionable

        getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

    • Field Detail

      • STATUS_SUBMITTED

        static final int STATUS_SUBMITTED
        RegistryEntry has been submitted.
        See Also:
        Constant Field Values

      • STATUS_APPROVED

        static final int STATUS_APPROVED
        RegistryEntry has been submitted and approved.
        See Also:
        Constant Field Values

      • STATUS_DEPRECATED

        static final int STATUS_DEPRECATED
        RegistryEntry has been deprecated.
        See Also:
        Constant Field Values

      • STATUS_WITHDRAWN

        static final int STATUS_WITHDRAWN
        RegistryEntry has been withdrawn by the submitter.
        See Also:
        Constant Field Values

      • STABILITY_DYNAMIC

        static final int STABILITY_DYNAMIC
        RegistryEntry may change at any time.
        See Also:
        Constant Field Values

      • STABILITY_DYNAMIC_COMPATIBLE

        static final int STABILITY_DYNAMIC_COMPATIBLE
        RegistryEntry may change at any time, however the changes will be backward compatible.
        See Also:
        Constant Field Values

      • STABILITY_STATIC

        static final int STABILITY_STATIC
        RegistryEntry will not change.
        See Also:
        Constant Field Values

    • Method Detail

      • getStatus

        int getStatus()
              throws JAXRException
        Gets the life cycle status of the RegistryEntry within the registry.

        Capability Level: 1
        This method must throw UnsupportedCapabilityException in lower capability levels.
        Returns:
        the life cycle status as an integer enumeration
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getStability

        int getStability()
                 throws JAXRException
        Gets the stability indicator for the RegistryEntry within the Registry. The stability indicator is provided by the submitter as an indication of the level of stability for the content.

        Capability Level: 1
        This method must throw UnsupportedCapabilityException in lower capability levels.
        Returns:
        the stability indicator as an integer enumeration
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        STABILITY_DYNAMIC

      • setStability

        void setStability(int stability)
                  throws JAXRException
        Sets the stability indicator for the RegistryEntry.

        Capability Level: 1
        This method must throw UnsupportedCapabilityException in lower capability levels.
        Parameters:
        stability - the stability indicator
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getExpiration

        Date getExpiration()
                   throws JAXRException
        Gets expirationDate attribute of the RegistryEntry within the Registry. This attribute defines a time limit upon the stability indication provided by the stability attribute. Once the expirationDate has been reached the stability attribute in effect becomes STABILITY_DYNAMIC implying that content can change at any time and in any manner. A null value implies that there is no expiration on stability attribute.

        Capability Level: 1
        This method must throw UnsupportedCapabilityException in lower capability levels.
        Returns:
        the expiration Date for the stability indicator
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setExpiration

        void setExpiration(Date expiration)
                   throws JAXRException
        Sets the expirationDate.

        Capability Level: 1
        Parameters:
        expiration - the expiration Date for the stability indicator
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RegistryObject (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface RegistryObject

  • All Superinterfaces:
    ExtensibleObject
    All Known Subinterfaces:
    Association, AuditableEvent, Classification, ClassificationScheme, Concept, ExternalIdentifier, ExternalLink, ExtrinsicObject, Organization, RegistryEntry, RegistryPackage, Service, ServiceBinding, SpecificationLink, User

    public interface RegistryObject
extends ExtensibleObject
    The RegistryObject class is an abstract base class used by most classes in the model. It provides minimal metadata for registry objects. It also provides methods for accessing related objects that provide additional dynamic metadata for the registry object.
    Author:
    Farrukh S. Najmi
    See Also:
    RegistryEntry

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addAssociation(Association association)
      Adds specified Association to use this object as source.
      void addAssociations(Collection associations)
      Adds specified Associations to use this object as source.
      void addClassification(Classification classification)
      Adds specified Classification to this object.
      void addClassifications(Collection classifications)
      Adds specified Classifications to this object.
      void addExternalIdentifier(ExternalIdentifier externalIdentifier)
      Adds specified ExternalIdentifier as an external identifier to this object.
      void addExternalIdentifiers(Collection externalIdentifiers)
      Adds specified ExternalIdentifiers as an external identifiers to this object.
      void addExternalLink(ExternalLink externalLink)
      Adds specified ExternalLink to this object.
      void addExternalLinks(Collection externalLinks)
      Adds specified ExternalLinks to this object.
      Collection getAssociatedObjects()
      Returns the collection of RegistryObject instances associated with this object.
      Collection getAssociations()
      Gets all Associations where this object is source.
      Collection getAuditTrail()
      Returns the complete audit trail of all requests that effected a state change in this object as an ordered Collection of AuditableEvent objects.
      Collection getClassifications()
      Gets the Classification instances that classify this object.
      InternationalString getDescription()
      Gets the textual description for this object.
      Collection getExternalIdentifiers()
      Returns the ExternalIdentifiers associated with this object that are external identifiers for this object.
      Collection getExternalLinks()
      Returns the ExternalLinks associated with this object.
      Key getKey()
      Gets the key representing the universally unique ID (UUID) for this object.
      LifeCycleManager getLifeCycleManager()
      Returns the LifeCycleManager that created this object.
      InternationalString getName()
      Gets the user-friendly name of this object.
      Concept getObjectType()
      Gets the object type that best describes the RegistryObject.
      Collection getRegistryPackages()
      Returns the Package associated with this object.
      Organization getSubmittingOrganization()
      Gets the Organization that submitted this RegistryObject.
      void removeAssociation(Association association)
      Removes specified Association from this object.
      void removeAssociations(Collection associations)
      Removes specified Associations from this object.
      void removeClassification(Classification classification)
      Removes specified Classification from this object.
      void removeClassifications(Collection classifications)
      Removes specified Classifications from this object.
      void removeExternalIdentifier(ExternalIdentifier externalIdentifier)
      Removes specified ExternalIdentifier as an external identifier from this object.
      void removeExternalIdentifiers(Collection externalIdentifiers)
      Removes specified ExternalIdentifiers as an external identifiers from this object.
      void removeExternalLink(ExternalLink externalLink)
      Removes specified ExternalLink from this object.
      void removeExternalLinks(Collection externalLinks)
      Removes specified ExternalLinks from this object.
      void setAssociations(Collection associations)
      Replaces all previous Associations from this object with specified Associations.
      void setClassifications(Collection classifications)
      Replaces all previous Classifications with specified Classifications.
      void setDescription(InternationalString description)
      Sets the context independent textual description for this object.
      void setExternalIdentifiers(Collection externalIdentifiers)
      Replaces all previous external identifiers with specified Collection of ExternalIdentifiers as an external identifier.
      void setExternalLinks(Collection externalLinks)
      Replaces all previous ExternalLinks with specified ExternalLinks.
      void setKey(Key key)
      Sets the key representing the universally unique ID (UUID) for this object.
      void setName(InternationalString name)
      Sets user-friendly name of object in repository.
      String toXML()
      Returns a registry provider specific XML representation of this Object.

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

    • Method Detail

      • getKey

        Key getKey()
           throws JAXRException
        Gets the key representing the universally unique ID (UUID) for this object.

        Capability Level: 0
        Returns:
        the Key for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getDescription

        InternationalString getDescription()
                                   throws JAXRException
        Gets the textual description for this object.

        Capability Level: 0
        Returns:
        the description for this object which must not be null
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setDescription

        void setDescription(InternationalString description)
                    throws JAXRException
        Sets the context independent textual description for this object.

        Capability Level: 0
        Parameters:
        description - the description for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getName

        InternationalString getName()
                            throws JAXRException
        Gets the user-friendly name of this object.

        Capability Level: 0
        Returns:
        the name for this object which must not be null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setName

        void setName(InternationalString name)
             throws JAXRException
        Sets user-friendly name of object in repository.

        Capability Level: 0
        Parameters:
        name - the name for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setKey

        void setKey(Key key)
            throws JAXRException
        Sets the key representing the universally unique ID (UUID) for this object.

        Capability Level: 0
        Parameters:
        key - the key for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • toXML

        String toXML()
             throws JAXRException
        Returns a registry provider specific XML representation of this Object. This may be used as a last resort back door way to get to a provider specific information element that is not accessible via the API. Implementation may choose to throw a UnsupportedCapabilityException.

        Capability Level: 0
        Returns:
        the String containing the XML representation for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addClassification

        void addClassification(Classification classification)
                       throws JAXRException
        Adds specified Classification to this object. Silently replaces the classifiedObject in Classification with reference to this object.

        Capability Level: 0
        Parameters:
        classification - the Classification being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addClassifications

        void addClassifications(Collection classifications)
                        throws JAXRException
        Adds specified Classifications to this object. Silently replaces the classifiedObject in Classifications with reference to this object.

        Capability Level: 0
        Parameters:
        classifications - the Collection of Classifications being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeClassification

        void removeClassification(Classification classification)
                          throws JAXRException
        Removes specified Classification from this object.

        Capability Level: 0
        Parameters:
        classification - the Classification being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeClassifications

        void removeClassifications(Collection classifications)
                           throws JAXRException
        Removes specified Classifications from this object.

        Capability Level: 0
        Parameters:
        classifications - the Collection of Classifications being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setClassifications

        void setClassifications(Collection classifications)
                        throws JAXRException
        Replaces all previous Classifications with specified Classifications.

        Capability Level: 0
        Parameters:
        classifications - the Collection of Classifications being set
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getClassifications

        Collection getClassifications()
                              throws JAXRException
        Gets the Classification instances that classify this object.

        Capability Level: 0
        Returns:
        Collection of Classification instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        Classification

      • getAuditTrail

        Collection getAuditTrail()
                         throws JAXRException
        Returns the complete audit trail of all requests that effected a state change in this object as an ordered Collection of AuditableEvent objects.

        Capability Level: 1
        This method must throw UnsupportedCapabilityException in lower capability levels.
        Returns:
        Collection of AuditableEvent instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        AuditableEvent

      • addAssociation

        void addAssociation(Association association)
                    throws JAXRException
        Adds specified Association to use this object as source. Silently replaces the sourceObject in Association with reference to this object.

        Capability Level: 0
        Parameters:
        association - the Association being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addAssociations

        void addAssociations(Collection associations)
                     throws JAXRException
        Adds specified Associations to use this object as source. Silently replaces the sourceObject in Associations with reference to this object.

        Capability Level: 0
        Parameters:
        associations - the Collection of Associations being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeAssociation

        void removeAssociation(Association association)
                       throws JAXRException
        Removes specified Association from this object.

        Capability Level: 0
        Parameters:
        association - the Association being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeAssociations

        void removeAssociations(Collection associations)
                        throws JAXRException
        Removes specified Associations from this object.

        Capability Level: 0
        Parameters:
        associations - the Collection of Associations being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setAssociations

        void setAssociations(Collection associations)
                     throws JAXRException
        Replaces all previous Associations from this object with specified Associations.

        Capability Level: 0
        Parameters:
        associations - the Collection of Associations being set
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getAssociations

        Collection getAssociations()
                           throws JAXRException
        Gets all Associations where this object is source.

        Capability Level: 0
        Returns:
        Collection of Association instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        Association

      • getAssociatedObjects

        Collection getAssociatedObjects()
                                throws JAXRException
        Returns the collection of RegistryObject instances associated with this object.

        Capability Level: 1
        This method must throw UnsupportedCapabilityException in lower capability levels.
        Returns:
        Collection of RegistryObject instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        RegistryObject

      • addExternalIdentifier

        void addExternalIdentifier(ExternalIdentifier externalIdentifier)
                           throws JAXRException
        Adds specified ExternalIdentifier as an external identifier to this object. Silently replaces the registryObject in ExternalIdentifier with reference to this object.

        Capability Level: 0
        Parameters:
        externalIdentifier - the ExternalIdentifier being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addExternalIdentifiers

        void addExternalIdentifiers(Collection externalIdentifiers)
                            throws JAXRException
        Adds specified ExternalIdentifiers as an external identifiers to this object. Silently replaces the registryObject in ExternalIdentifiers with reference to this object.

        Capability Level: 0
        Parameters:
        externalIdentifiers - the Collection of ExternalIdentifiers being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeExternalIdentifier

        void removeExternalIdentifier(ExternalIdentifier externalIdentifier)
                              throws JAXRException
        Removes specified ExternalIdentifier as an external identifier from this object.

        Capability Level: 0
        Parameters:
        externalIdentifier - the ExternalIdentifier being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeExternalIdentifiers

        void removeExternalIdentifiers(Collection externalIdentifiers)
                               throws JAXRException
        Removes specified ExternalIdentifiers as an external identifiers from this object.

        Capability Level: 0
        Parameters:
        externalIdentifiers - the Collection of ExternalIdentifiers being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setExternalIdentifiers

        void setExternalIdentifiers(Collection externalIdentifiers)
                            throws JAXRException
        Replaces all previous external identifiers with specified Collection of ExternalIdentifiers as an external identifier.

        Capability Level: 0
        Parameters:
        externalIdentifiers - the Collection of ExternalIdentifiers being set
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getExternalIdentifiers

        Collection getExternalIdentifiers()
                                  throws JAXRException
        Returns the ExternalIdentifiers associated with this object that are external identifiers for this object.

        Capability Level: 0
        Returns:
        Collection of ExternalIdentifier instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        ExternalIdentifier

      • addExternalLink

        void addExternalLink(ExternalLink externalLink)
                     throws JAXRException
        Adds specified ExternalLink to this object.

        Capability Level: 0
        Parameters:
        externalLinks - the ExternalLink being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addExternalLinks

        void addExternalLinks(Collection externalLinks)
                      throws JAXRException
        Adds specified ExternalLinks to this object.

        Capability Level: 0
        Parameters:
        externalLinks - the Collection of ExternalLinks being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeExternalLink

        void removeExternalLink(ExternalLink externalLink)
                        throws JAXRException
        Removes specified ExternalLink from this object.

        Capability Level: 0
        Parameters:
        externalLink - the ExternalLink being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeExternalLinks

        void removeExternalLinks(Collection externalLinks)
                         throws JAXRException
        Removes specified ExternalLinks from this object.

        Capability Level: 0
        Parameters:
        externalLinks - the Collection of ExternalLinks being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setExternalLinks

        void setExternalLinks(Collection externalLinks)
                      throws JAXRException
        Replaces all previous ExternalLinks with specified ExternalLinks.

        Capability Level: 0
        Parameters:
        externalLink - the Collection of ExternalLinks being set
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getExternalLinks

        Collection getExternalLinks()
                            throws JAXRException
        Returns the ExternalLinks associated with this object.

        Capability Level: 0
        Returns:
        Collection of ExternalLink instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        ExternalLink

      • getObjectType

        Concept getObjectType()
                      throws JAXRException
        Gets the object type that best describes the RegistryObject.

        Capability Level: 1
        This method must throw UnsupportedCapabilityException in lower capability levels.
        Returns:
        the object type as a Concept within the pre-defined ClassificationScheme named ObjectType
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getSubmittingOrganization

        Organization getSubmittingOrganization()
                                       throws JAXRException
        Gets the Organization that submitted this RegistryObject.
        Returns:
        the Organization that submitted this object to the registry
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getRegistryPackages

        Collection getRegistryPackages()
                               throws JAXRException
        Returns the Package associated with this object.

        Capability Level: 1
        This method must throw UnsupportedCapabilityException in lower capability levels.
        Returns:
        Collection of RegistryPackage instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        RegistryPackage

      • getLifeCycleManager

        LifeCycleManager getLifeCycleManager()
                                     throws JAXRException
        Returns the LifeCycleManager that created this object.

        Capability Level: 0
        Returns:
        the LifeCycleManager objet that created this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RegistryPackage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface RegistryPackage

  • All Superinterfaces:
    ExtensibleObject, RegistryEntry, RegistryObject, Versionable

    public interface RegistryPackage
extends RegistryEntry
    RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together. A package may contain any number of RegistryObjects. A RegistryObject may be a member of any number of Packages.
    Author:
    Farrukh S. Najmi
    See Also:
    RegistryObject

    • Field Summary

      • Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry

        STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addRegistryObject(RegistryObject registryObject)
      Adds a child RegistryObject as member.
      void addRegistryObjects(Collection registryObjects)
      Adds a Collection of RegistryObject children as members.
      Set getRegistryObjects()
      Gets the collection of member RegistryObjects of this RegistryPackage.
      void removeRegistryObject(RegistryObject registryObject)
      Removes a child RegistryObject from membership.
      void removeRegistryObjects(Collection registryObjects)
      Removes a Collection of children RegistryObjects from membership.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry

        getExpiration, getStability, getStatus, setExpiration, setStability

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

      • Methods inherited from interface javax.xml.registry.infomodel.Versionable

        getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

    • Method Detail

      • addRegistryObject

        void addRegistryObject(RegistryObject registryObject)
                       throws JAXRException
        Adds a child RegistryObject as member.

        Capability Level: 1
        Parameters:
        registryObject - the RegistryObject being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addRegistryObjects

        void addRegistryObjects(Collection registryObjects)
                        throws JAXRException
        Adds a Collection of RegistryObject children as members.

        Capability Level: 1
        Parameters:
        registryObjects - the Collection of RegistryObjects being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeRegistryObject

        void removeRegistryObject(RegistryObject registryObject)
                          throws JAXRException
        Removes a child RegistryObject from membership.

        Capability Level: 1
        Parameters:
        registryObject - the RegistryObject being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeRegistryObjects

        void removeRegistryObjects(Collection registryObjects)
                           throws JAXRException
        Removes a Collection of children RegistryObjects from membership.

        Capability Level: 1
        Parameters:
        registryObjects - the Collection of RegistryObject being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getRegistryObjects

        Set getRegistryObjects()
                       throws JAXRException
        Gets the collection of member RegistryObjects of this RegistryPackage.

        Capability Level: 1
        Returns:
        the Set of RegistryObjects that are members of this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Service (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface Service

  • All Superinterfaces:
    ExtensibleObject, RegistryEntry, RegistryObject, Versionable

    public interface Service
extends RegistryEntry
    Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization. A Service may have a set of ServiceBinding instances. Maps to a BusinessService in UDDI.
    Author:
    Farrukh S. Najmi
    See Also:
    ServiceBinding

    • Field Summary

      • Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry

        STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addServiceBinding(ServiceBinding serviceBinding)
      Adds a child ServiceBinding.
      void addServiceBindings(Collection serviceBindings)
      Adds a Collection of ServiceBinding children.
      Organization getProvidingOrganization()
      Gets the Organization that provides this service.
      Collection getServiceBindings()
      Gets all children ServiceBindings.
      void removeServiceBinding(ServiceBinding serviceBinding)
      Removes a child ServiceBinding.
      void removeServiceBindings(Collection serviceBindings)
      Removes a Collection of children ServiceBindings.
      void setProvidingOrganization(Organization providingOrganization)
      Sets the Organization that provides this service.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry

        getExpiration, getStability, getStatus, setExpiration, setStability

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

      • Methods inherited from interface javax.xml.registry.infomodel.Versionable

        getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

    • Method Detail

      • getProvidingOrganization

        Organization getProvidingOrganization()
                                      throws JAXRException
        Gets the Organization that provides this service. Providing Organization may be null. The providing Organization may be different from the Submitting Organization as defined by RegistryObject#getSubmittingOrganization.

        Capability Level: 0
        Returns:
        the Organization that provides this service
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        RegistryObject.getSubmittingOrganization()

      • setProvidingOrganization

        void setProvidingOrganization(Organization providingOrganization)
                              throws JAXRException
        Sets the Organization that provides this service.

        Capability Level: 0
        Parameters:
        providingOrganization - the Organization that provides this service
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addServiceBinding

        void addServiceBinding(ServiceBinding serviceBinding)
                       throws JAXRException
        Adds a child ServiceBinding.

        Capability Level: 0
        Parameters:
        serviceBinding - the ServiceBinding being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addServiceBindings

        void addServiceBindings(Collection serviceBindings)
                        throws JAXRException
        Adds a Collection of ServiceBinding children.

        Capability Level: 0
        Parameters:
        serviceBindings - the Collection of ServiceBindings being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeServiceBinding

        void removeServiceBinding(ServiceBinding serviceBinding)
                          throws JAXRException
        Removes a child ServiceBinding.

        Capability Level: 0
        Parameters:
        serviceBinding - the ServiceBinding being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeServiceBindings

        void removeServiceBindings(Collection serviceBindings)
                           throws JAXRException
        Removes a Collection of children ServiceBindings.

        Capability Level: 0
        Parameters:
        serviceBindings - the Collection of ServiceBindings being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getServiceBindings

        Collection getServiceBindings()
                              throws JAXRException
        Gets all children ServiceBindings.

        Capability Level: 0
        Returns:
        Collection of ServiceBinding instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        ServiceBinding
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceBinding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface ServiceBinding

  • All Superinterfaces:
    ExtensibleObject, RegistryObject, URIValidator

    public interface ServiceBinding
extends RegistryObject, URIValidator
    ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance. A ServiceBinding may have a set of SpecificationLink instances. Maps to a BindingTemplate in UDDI.
    Author:
    Farrukh S. Najmi
    See Also:
    Concept

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addSpecificationLink(SpecificationLink specificationLink)
      Adds a child SpecificationLink.
      void addSpecificationLinks(Collection specificationLinks)
      Adds a Collection of SpecificationLink children.
      String getAccessURI()
      Gets the URI that gives access to the service via this binding.
      Service getService()
      Gets the parent service for which this is a binding.
      Collection getSpecificationLinks()
      Gets all children SpecificationLinks.
      ServiceBinding getTargetBinding()
      Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.
      void removeSpecificationLink(SpecificationLink specificationLink)
      Removes a child SpecificationLink.
      void removeSpecificationLinks(Collection specificationLinks)
      Removes a Collection of children SpecificationLinks.
      void setAccessURI(String uri)
      Sets the URI that gives access to the service via this binding.
      void setTargetBinding(ServiceBinding binding)
      Sets the next ServiceBinding in case there is a redirection.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

      • Methods inherited from interface javax.xml.registry.infomodel.URIValidator

        getValidateURI, setValidateURI

    • Method Detail

      • getAccessURI

        String getAccessURI()
                    throws JAXRException
        Gets the URI that gives access to the service via this binding. Default is a NULL String.

        Capability Level: 0
        Returns:
        the URI that gives access to the service via this binding
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setAccessURI

        void setAccessURI(String uri)
                  throws JAXRException
        Sets the URI that gives access to the service via this binding. The accessURI is mutually exclusive from targetBinding. JAXR Provider must throw an InvalidRequestException if an accessURI is set when there is already a non-null targetBinding defined.

        Capability Level: 0
        Parameters:
        uri - the URI that gives access to the service via this binding
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getTargetBinding

        ServiceBinding getTargetBinding()
                                throws JAXRException
        Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.

        Capability Level: 0
        Returns:
        the next ServiceBinding in case there is a service redirection
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setTargetBinding

        void setTargetBinding(ServiceBinding binding)
                      throws JAXRException
        Sets the next ServiceBinding in case there is a redirection. The targetBinding is mutually exclusive from the accessURI. JAXR Provider must throw an InvalidRequestExcpetion if a targetBinding is set when there is already a non-null accessURI defined.

        Capability Level: 0
        Parameters:
        binding - the target ServiceBinding to which this object is redirected to
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getService

        Service getService()
                   throws JAXRException
        Gets the parent service for which this is a binding.

        Capability Level: 0
        Returns:
        the parent Service object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addSpecificationLink

        void addSpecificationLink(SpecificationLink specificationLink)
                          throws JAXRException
        Adds a child SpecificationLink.

        Capability Level: 0
        Parameters:
        specificationLink - the SpecificationLink being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • addSpecificationLinks

        void addSpecificationLinks(Collection specificationLinks)
                           throws JAXRException
        Adds a Collection of SpecificationLink children.

        Capability Level: 0
        Parameters:
        specificationLinks - the Collection of SpecificationLinks being added
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeSpecificationLink

        void removeSpecificationLink(SpecificationLink specificationLink)
                             throws JAXRException
        Removes a child SpecificationLink.

        Capability Level: 0
        Parameters:
        specificationLink - the SpecificationLink being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • removeSpecificationLinks

        void removeSpecificationLinks(Collection specificationLinks)
                              throws JAXRException
        Removes a Collection of children SpecificationLinks.

        Capability Level: 0
        Parameters:
        specificationLinks - the Collection of SpecificationLinks being removed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getSpecificationLinks

        Collection getSpecificationLinks()
                                 throws JAXRException
        Gets all children SpecificationLinks.

        Capability Level: 0
        Returns:
        Collection of SpecificationLink instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        SpecificationLink
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Slot (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface Slot

  • public interface Slot
    Slot instances provide a dynamic way to add arbitrary attributes to RegistryObject instances. This ability to add attributes dynamically to RegistryObject instances enables extensibility within the Registry Information Model.

    A RegistryObject may have 0 or more Slots. A slot is composed of a name, a slotType and a collection of values. The name of a slot is locally unique within the RegistryObject instance. Similarly, the value of a Slot is locally unique within a slot instance. Since a Slot represents an extensible attribute whose value may be a collection, a Slot is allowed to have a collection of values rather than a single value. The slotType attribute may optionally specify a type or category for the slot.

    Author:
    Farrukh S. Najmi
    See Also:
    ExtensibleObject

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ADDRESS_LINES_SLOT
      Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.
      static String AUTHORIZED_NAME_SLOT
      Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.
      static String OPERATOR_SLOT
      Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.
      static String SORT_CODE_SLOT
      Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Gets the name for this Slot.
      String getSlotType()
      Gets the slotType for this Slot.
      Collection getValues()
      Gets the values for this Slot.
      void setName(String name)
      Sets the name for this Slot.
      void setSlotType(String slotType)
      Sets the slotType for this Slot.
      void setValues(Collection values)
      Sets the values for this Slot.

    • Field Detail

      • SORT_CODE_SLOT

        static final String SORT_CODE_SLOT
        Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.
        See Also:
        Constant Field Values

      • ADDRESS_LINES_SLOT

        static final String ADDRESS_LINES_SLOT
        Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.
        See Also:
        Constant Field Values

      • AUTHORIZED_NAME_SLOT

        static final String AUTHORIZED_NAME_SLOT
        Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.
        See Also:
        Constant Field Values

      • OPERATOR_SLOT

        static final String OPERATOR_SLOT
        Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.
        See Also:
        Constant Field Values

    • Method Detail

      • getName

        String getName()
               throws JAXRException
        Gets the name for this Slot. Default is a NULL String.

        Capability Level: 0
        Returns:
        the name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setName

        void setName(String name)
             throws JAXRException
        Sets the name for this Slot. Default is a NULL String.

        Capability Level: 0
        Parameters:
        name - the name
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getSlotType

        String getSlotType()
                   throws JAXRException
        Gets the slotType for this Slot. Default is a NULL String.

        Capability Level: 0
        Returns:
        the slot type which is an arbitrary String
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setSlotType

        void setSlotType(String slotType)
                 throws JAXRException
        Sets the slotType for this Slot.

        Capability Level: 0
        Parameters:
        slotType - the slot type which is an arbitrary String
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getValues

        Collection getValues()
                     throws JAXRException
        Gets the values for this Slot.

        Capability Level: 0
        Returns:
        Collection of String instances representing the values for this Slot. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        String

      • setValues

        void setValues(Collection values)
               throws JAXRException
        Sets the values for this Slot.

        Capability Level: 0
        Parameters:
        values - the values for this Slot
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SpecificationLink (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface SpecificationLink

  • All Superinterfaces:
    ExtensibleObject, RegistryObject

    public interface SpecificationLink
extends RegistryObject
    A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding. For example, a ServiceBinding may have a SpecificationLink instance that describes how to access the service using a technical specification in the form of a WSDL document or a CORBA IDL document. It serves the same purpose as the union of the tModelInstanceInfo and instanceDetails structures in UDDI.
    Author:
    Farrukh S. Najmi
    See Also:
    Concept

    • Method Summary

      Methods
      Modifier and Type Method and Description
      ServiceBinding getServiceBinding()
      Gets the parent ServiceBinding for this SpecificationLink.
      RegistryObject getSpecificationObject()
      Gets the specification object for this object.
      InternationalString getUsageDescription()
      Gets the description of usage parameters.
      Collection getUsageParameters()
      Gets any usage parameters.
      void setSpecificationObject(RegistryObject obj)
      Sets the specification object for this object.
      void setUsageDescription(InternationalString usageDescription)
      Sets the description of usage parameters.
      void setUsageParameters(Collection usageParameters)
      Sets any usage parameters.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

    • Method Detail

      • getSpecificationObject

        RegistryObject getSpecificationObject()
                                      throws JAXRException
        Gets the specification object for this object.

        Capability Level: 0
        Returns:
        the RegistryObject that is the specification object. For a UDDI provider the specification object must be a Concept with no parent. For an ebXML provider it is likely to be an ExtrinsicObject.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setSpecificationObject

        void setSpecificationObject(RegistryObject obj)
                            throws JAXRException
        Sets the specification object for this object.

        Capability Level: 0
        Parameters:
        obj - the RegistryObject that is the specification object. For a UDDI provider the specification object must be a Concept with no parent. For an ebXML provider it is likely to be an ExtrinsicObject.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getUsageDescription

        InternationalString getUsageDescription()
                                        throws JAXRException
        Gets the description of usage parameters. Default is an empty String.

        Capability Level: 0
        Returns:
        the usage description for this object, which must not be null
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setUsageDescription

        void setUsageDescription(InternationalString usageDescription)
                         throws JAXRException
        Sets the description of usage parameters.

        Capability Level: 0
        Parameters:
        usageDescription - the description of usage parameters for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getUsageParameters

        Collection getUsageParameters()
                              throws JAXRException
        Gets any usage parameters. A usage parameter is an arbitrary String that describes how to use the technical specification accessed via this SpecificationLink. Each parameter is a String.

        Capability Level: 0
        Returns:
        the Collection of String instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setUsageParameters

        void setUsageParameters(Collection usageParameters)
                        throws JAXRException
        Sets any usage parameters. Each parameter is a String

        Capability Level: 0
        Parameters:
        usageParameters - the Collection of usage parameter Strings
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getServiceBinding

        ServiceBinding getServiceBinding()
                                 throws JAXRException
        Gets the parent ServiceBinding for this SpecificationLink.

        Capability Level: 0
        Returns:
        the parent ServiceBinding within which this object is composed
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TelephoneNumber (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface TelephoneNumber

  • public interface TelephoneNumber
    A simple re-usable entity class that defines attributes of a telephone number.
    Author:
    Farrukh S. Najmi

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getAreaCode()
      Gets the area code.
      String getCountryCode()
      Gets the country code.
      String getExtension()
      Gets the internal extension.
      String getNumber()
      Gets the telephone number suffix, not including the country or area code.
      String getType()
      The type of telephone number (for example, "fax").
      String getUrl()
      Gets the URL that can dial this number electronically.
      void setAreaCode(String areaCode)
      Sets the area code.
      void setCountryCode(String countryCode)
      Sets country code.
      void setExtension(String extension)
      Sets the internal extension.
      void setNumber(String number)
      Sets the telephone number suffix, not including the country or area code.
      void setType(String type)
      Sets the type of telephone number (for example, "fax").
      void setUrl(String url)
      Sets the URL that can dial this number electronically.

    • Method Detail

      • getCountryCode

        String getCountryCode()
                      throws JAXRException
        Gets the country code. Default is an empty String.

        Capability Level: 1
        Returns:
        the country code
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getAreaCode

        String getAreaCode()
                   throws JAXRException
        Gets the area code. Default is an empty String.

        Capability Level: 1
        Returns:
        the area code
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getNumber

        String getNumber()
                 throws JAXRException
        Gets the telephone number suffix, not including the country or area code. Default is an empty String.

        Capability Level: 0
        Returns:
        the telephone number
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getExtension

        String getExtension()
                    throws JAXRException
        Gets the internal extension. Default is an empty String.

        Capability Level: 1
        Returns:
        the internal extension number
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getUrl

        String getUrl()
              throws JAXRException
        Gets the URL that can dial this number electronically. Default is a NULL String.

        Capability Level: 1
        Returns:
        the url
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getType

        String getType()
               throws JAXRException
        The type of telephone number (for example, "fax"). Any String would do.

        Capability Level: 0
        Returns:
        the type for this TelephoneNumber, which is an arbitrary String
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setCountryCode

        void setCountryCode(String countryCode)
                    throws JAXRException
        Sets country code.

        Capability Level: 1
        Parameters:
        countryCode - the country code
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setAreaCode

        void setAreaCode(String areaCode)
                 throws JAXRException
        Sets the area code.

        Capability Level: 1
        Parameters:
        areaCode - the area code
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setNumber

        void setNumber(String number)
               throws JAXRException
        Sets the telephone number suffix, not including the country or area code.

        Capability Level: 0
        Parameters:
        number - the telephone number
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setExtension

        void setExtension(String extension)
                  throws JAXRException
        Sets the internal extension.

        Capability Level: 1
        Parameters:
        extension - the internal extension number
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setUrl

        void setUrl(String url)
            throws JAXRException
        Sets the URL that can dial this number electronically.

        Capability Level: 1
        Parameters:
        url - the URL string
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setType

        void setType(String type)
             throws JAXRException
        Sets the type of telephone number (for example, "fax"). Any String will do.

        Capability Level: 0
        Parameters:
        type - the type for this TelephoneNumber, which is an arbitrary String
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


URIValidator (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface URIValidator

  • All Known Subinterfaces:
    ExternalLink, ServiceBinding

    public interface URIValidator
    Defines common behavior expected of any class that validates URIs.
    Author:
    Farrukh S. Najmi

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean getValidateURI()
      Gets whether to do URI validation for this object.
      void setValidateURI(boolean validate)
      Sets whether to do URI validation for this object.

    • Method Detail

      • setValidateURI

        void setValidateURI(boolean validate)
                    throws JAXRException
        Sets whether to do URI validation for this object. Default is true.

        Capability Level: 0
        Parameters:
        validate - true implies JAXR provider must perform validation of URIs when they are set; false implies validation is turned off
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getValidateURI

        boolean getValidateURI()
                       throws JAXRException
        Gets whether to do URI validation for this object.

        Capability Level: 0
        Returns:
        true implies JAXR provider must perform validation of URIs when they are set; false implies validation is turned off
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


User (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface User

  • All Superinterfaces:
    ExtensibleObject, RegistryObject

    public interface User
extends RegistryObject
    User instances are RegistryObjects that are used to provide information about registered users within the registry. Users are affiliated with Organizations. User objects are used in the audit trail for a RegistryObject.
    Author:
    Farrukh S. Najmi
    See Also:
    Organization, AuditableEvent

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Collection getEmailAddresses()
      Gets the email addresses for this User.
      Organization getOrganization()
      Gets the Organization that this User is affiliated with.
      PersonName getPersonName()
      Returns the name of this User.
      Collection getPostalAddresses()
      Gets the postal address for this User.
      Collection getTelephoneNumbers(String phoneType)
      Gets the telephone numbers for this User that match the specified telephone number type.
      String getType()
      Gets the type for this User.
      URL getUrl()
      Gets the URL to the web page for this User.
      void setEmailAddresses(Collection emailAddresses)
      Sets the Collection of EmailAddress instances for this User.
      void setPersonName(PersonName personName)
      Sets the name of this User.
      void setPostalAddresses(Collection addresses)
      Sets the addresses for this User.
      void setTelephoneNumbers(Collection phoneNumbers)
      Sets the various telephone numbers for this user.
      void setType(String type)
      Sets the type for this User.
      void setUrl(URL url)
      Sets the URL to the web page for this User.

      • Methods inherited from interface javax.xml.registry.infomodel.RegistryObject

        addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML

      • Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject

        addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

    • Method Detail

      • getOrganization

        Organization getOrganization()
                             throws JAXRException
        Gets the Organization that this User is affiliated with.

        Capability Level: 0
        Returns:
        the Organization that this User is affiliated with
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getPersonName

        PersonName getPersonName()
                         throws JAXRException
        Returns the name of this User.

        Capability Level: 0
        Returns:
        the name of this User
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setPersonName

        void setPersonName(PersonName personName)
                   throws JAXRException
        Sets the name of this User.

        Capability Level: 0
        Parameters:
        personName - the name of this User
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getPostalAddresses

        Collection getPostalAddresses()
                              throws JAXRException
        Gets the postal address for this User.

        Capability Level: 0
        Returns:
        Collection of PostalAddress instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        PostalAddress

      • setPostalAddresses

        void setPostalAddresses(Collection addresses)
                        throws JAXRException
        Sets the addresses for this User.

        Capability Level: 0
        Parameters:
        addresses - Is a Collection of PostAddress instances.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getUrl

        URL getUrl()
           throws JAXRException
        Gets the URL to the web page for this User.

        Capability Level: 1
        Returns:
        the URL for this User's home page
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setUrl

        void setUrl(URL url)
            throws JAXRException
        Sets the URL to the web page for this User.

        Capability Level: 1
        Parameters:
        url - the URL for this User's home page
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getTelephoneNumbers

        Collection getTelephoneNumbers(String phoneType)
                               throws JAXRException
        Gets the telephone numbers for this User that match the specified telephone number type.

        Capability Level: 0
        Parameters:
        phoneType - specifies the type of phone numbers to be returned. If phoneType is null, return all telephoneNumbers
        Returns:
        Collection of TelephoneNumber instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        TelephoneNumber

      • setTelephoneNumbers

        void setTelephoneNumbers(Collection phoneNumbers)
                         throws JAXRException
        Sets the various telephone numbers for this user.

        Capability Level: 0
        Parameters:
        phoneNumbers - the Collection of TelephoneNumbers to be set
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getEmailAddresses

        Collection getEmailAddresses()
                             throws JAXRException
        Gets the email addresses for this User.

        Capability Level: 0
        Returns:
        Collection of EmailAddress instances. The Collection may be empty but not null.
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
        See Also:
        EmailAddress

      • setEmailAddresses

        void setEmailAddresses(Collection emailAddresses)
                       throws JAXRException
        Sets the Collection of EmailAddress instances for this User.

        Capability Level: 0
        Parameters:
        emailAddresses - the Collection of EmailAddresses to be set
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getType

        String getType()
               throws JAXRException
        Gets the type for this User. Default is a NULL String.

        Capability Level: 0
        Returns:
        the type for this User, which is an arbitrary String
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setType

        void setType(String type)
             throws JAXRException
        Sets the type for this User.

        Capability Level: 0
        Parameters:
        type - the type for this User, which is an arbitrary String
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.registry.infomodel (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.registry.infomodel

  • Packages that use javax.xml.registry.infomodel
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.
  • Classes in javax.xml.registry.infomodel used by javax.xml.registry
    Class and Description
    Association
    A RegistryObject instance may be associated with zero or more RegistryObject instances.
    Classification
    The Classification interface is used to classify RegistryObject instances.
    ClassificationScheme
    A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
    Concept
    The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.
    EmailAddress
    Represents an email address.
    ExternalIdentifier
    ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization.
    ExternalLink
    ExternalLink instances model a named URI to content that may reside outside the registry.
    ExtrinsicObject
    ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).
    InternationalString
    This interface represents a String that has been internationalized into several Locales.
    Key
    Represents a unique key that identifies a RegistryObject.
    LocalizedString
    This interface is used as a simple wrapper interface that associates a String with its Locale.
    Organization
    Organization instances provide information on organizations such as a Submitting Organization.
    PersonName
    Represents a person's name.
    PostalAddress
    PostalAddress is a simple re-usable entity class that defines attributes of a postal Address.
    RegistryObject
    The RegistryObject class is an abstract base class used by most classes in the model.
    RegistryPackage
    RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together.
    Service
    Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization.
    ServiceBinding
    ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance.
    Slot
    Slot instances provide a dynamic way to add arbitrary attributes to RegistryObject instances.
    SpecificationLink
    A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding.
    TelephoneNumber
    A simple re-usable entity class that defines attributes of a telephone number.
    User
    User instances are RegistryObjects that are used to provide information about registered users within the registry.
  • Classes in javax.xml.registry.infomodel used by javax.xml.registry.infomodel
    Class and Description
    Association
    A RegistryObject instance may be associated with zero or more RegistryObject instances.
    Classification
    The Classification interface is used to classify RegistryObject instances.
    ClassificationScheme
    A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
    Concept
    The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.
    ExtensibleObject
    An ExtensibleObject is one that allows itself to be extended by utilizing dynamically added Slots that add arbitrary attributes to the object on a per instance basis.
    ExternalIdentifier
    ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization.
    ExternalLink
    ExternalLink instances model a named URI to content that may reside outside the registry.
    InternationalString
    This interface represents a String that has been internationalized into several Locales.
    Key
    Represents a unique key that identifies a RegistryObject.
    LocalizedString
    This interface is used as a simple wrapper interface that associates a String with its Locale.
    Organization
    Organization instances provide information on organizations such as a Submitting Organization.
    PersonName
    Represents a person's name.
    PostalAddress
    PostalAddress is a simple re-usable entity class that defines attributes of a postal Address.
    RegistryEntry
    The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface.
    RegistryObject
    The RegistryObject class is an abstract base class used by most classes in the model.
    Service
    Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization.
    ServiceBinding
    ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance.
    Slot
    Slot instances provide a dynamic way to add arbitrary attributes to RegistryObject instances.
    SpecificationLink
    A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding.
    URIValidator
    Defines common behavior expected of any class that validates URIs.
    User
    User instances are RegistryObjects that are used to provide information about registered users within the registry.
    Versionable
    The Versionable interface defines the behavior common to classes that are capable of creating versions of their instances.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Versionable (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.registry.infomodel

Interface Versionable

  • All Known Subinterfaces:
    ClassificationScheme, ExtrinsicObject, RegistryEntry, RegistryPackage, Service

    public interface Versionable
    The Versionable interface defines the behavior common to classes that are capable of creating versions of their instances. At present all RegistryEntry classes are required to implement the Versionable interface.
    Author:
    Farrukh S. Najmi
    See Also:
    RegistryEntry

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getMajorVersion()
      Gets the major revision number for this version of the Versionable object.
      int getMinorVersion()
      Gets the minor revision number for this version of the Versionable object.
      String getUserVersion()
      Gets the user-specified revision number for this version of the Versionable object.
      void setMajorVersion(int majorVersion)
      Sets the major revision number for this version of the Versionable object.
      void setMinorVersion(int minorVersion)
      Sets the minor revision number for this version of the Versionable object.
      void setUserVersion(String userVersion)
      Sets the user specified revision number for this version of the Versionable object.

    • Method Detail

      • getMajorVersion

        int getMajorVersion()
                    throws JAXRException
        Gets the major revision number for this version of the Versionable object.

        Capability Level: 1
        Returns:
        the major version for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setMajorVersion

        void setMajorVersion(int majorVersion)
                     throws JAXRException
        Sets the major revision number for this version of the Versionable object.

        Capability Level: 1
        Parameters:
        majorVersion - the major version number
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getMinorVersion

        int getMinorVersion()
                    throws JAXRException
        Gets the minor revision number for this version of the Versionable object.

        Capability Level: 1
        Returns:
        the minor version for this object
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setMinorVersion

        void setMinorVersion(int minorVersion)
                     throws JAXRException
        Sets the minor revision number for this version of the Versionable object.

        Capability Level: 1
        Parameters:
        minorVersion - the minor version number
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • getUserVersion

        String getUserVersion()
                      throws JAXRException
        Gets the user-specified revision number for this version of the Versionable object.

        Capability Level: 1
        Returns:
        the user-defined version number
        Throws:
        JAXRException - If the JAXR provider encounters an internal error

      • setUserVersion

        void setUserVersion(String userVersion)
                    throws JAXRException
        Sets the user specified revision number for this version of the Versionable object.

        Capability Level: 1
        Parameters:
        userVersion - the user-defined version number
        Throws:
        JAXRException - If the JAXR provider encounters an internal error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface javax.xml.registry.infomodel.Association (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.Association

  • Packages that use Association
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of Association in javax.xml.registry

      Methods in javax.xml.registry that return Association
      Modifier and Type Method and Description
      Association LifeCycleManager.createAssociation(RegistryObject targetObject, Concept associationType)
      Creates an Association instance using the specified parameters.
      Methods in javax.xml.registry with parameters of type Association
      Modifier and Type Method and Description
      void BusinessLifeCycleManager.confirmAssociation(Association assoc)
      Confirms this Association by the User associated with the caller.
      void BusinessLifeCycleManager.unConfirmAssociation(Association assoc)
      Undoes a previous confirmation of this Association by the User associated with the caller.

    • Uses of Association in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel with parameters of type Association
      Modifier and Type Method and Description
      void RegistryObject.addAssociation(Association association)
      Adds specified Association to use this object as source.
      void RegistryObject.removeAssociation(Association association)
      Removes specified Association from this object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.AuditableEvent (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.AuditableEvent

No usage of javax.xml.registry.infomodel.AuditableEvent
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.Classification (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.Classification

  • Packages that use Classification
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of Classification in javax.xml.registry

      Methods in javax.xml.registry that return Classification
      Modifier and Type Method and Description
      Classification LifeCycleManager.createClassification(ClassificationScheme scheme, InternationalString name, String value)
      Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.
      Classification LifeCycleManager.createClassification(ClassificationScheme scheme, String name, String value)
      Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.
      Classification LifeCycleManager.createClassification(Concept concept)
      Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.

    • Uses of Classification in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel with parameters of type Classification
      Modifier and Type Method and Description
      void RegistryObject.addClassification(Classification classification)
      Adds specified Classification to this object.
      void RegistryObject.removeClassification(Classification classification)
      Removes specified Classification from this object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.ClassificationScheme (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.ClassificationScheme

  • Packages that use ClassificationScheme
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of ClassificationScheme in javax.xml.registry

      Methods in javax.xml.registry that return ClassificationScheme
      Modifier and Type Method and Description
      ClassificationScheme LifeCycleManager.createClassificationScheme(Concept concept)
      Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.
      ClassificationScheme LifeCycleManager.createClassificationScheme(InternationalString name, InternationalString description)
      Creates a ClassificationScheme given the specified InternationalString parameters.
      ClassificationScheme LifeCycleManager.createClassificationScheme(String name, String description)
      Creates a ClassificationScheme given the specified String parameters.
      ClassificationScheme BusinessQueryManager.findClassificationSchemeByName(Collection findQualifiers, String namePattern)
      Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.
      ClassificationScheme RegistryService.getDefaultPostalScheme()
      Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.
      Methods in javax.xml.registry with parameters of type ClassificationScheme
      Modifier and Type Method and Description
      Classification LifeCycleManager.createClassification(ClassificationScheme scheme, InternationalString name, String value)
      Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.
      Classification LifeCycleManager.createClassification(ClassificationScheme scheme, String name, String value)
      Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.
      ExternalIdentifier LifeCycleManager.createExternalIdentifier(ClassificationScheme identificationScheme, InternationalString name, String value)
      Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.
      ExternalIdentifier LifeCycleManager.createExternalIdentifier(ClassificationScheme identificationScheme, String name, String value)
      Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.

    • Uses of ClassificationScheme in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return ClassificationScheme
      Modifier and Type Method and Description
      ClassificationScheme Concept.getClassificationScheme()
      Gets the ClassificationScheme that this Concept is a descendent of.
      ClassificationScheme Classification.getClassificationScheme()
      Gets the ClassificationScheme that is used in classifying the object.
      ClassificationScheme ExternalIdentifier.getIdentificationScheme()
      Gets the ClassificationScheme that is used as the identification scheme for identifying this object.
      ClassificationScheme PostalAddress.getPostalScheme()
      Returns a user-defined postal scheme for codifying the attributes of PostalAddress.
      Methods in javax.xml.registry.infomodel with parameters of type ClassificationScheme
      Modifier and Type Method and Description
      void Classification.setClassificationScheme(ClassificationScheme classificationScheme)
      Sets the ClassificationScheme for this external classification.
      void ExternalIdentifier.setIdentificationScheme(ClassificationScheme identificationScheme)
      Sets the ClassificationScheme that is used as the identification scheme for identifying this object.
      void PostalAddress.setPostalScheme(ClassificationScheme scheme)
      Sets a user-defined postal scheme for codifying the attributes of PostalAddress.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.Concept (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.Concept

  • Packages that use Concept
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of Concept in javax.xml.registry

      Methods in javax.xml.registry that return Concept
      Modifier and Type Method and Description
      Concept LifeCycleManager.createConcept(RegistryObject parent, InternationalString name, String value)
      Creates a Concept instance using the specified parameters, where the name is an InternationalString.
      Concept LifeCycleManager.createConcept(RegistryObject parent, String name, String value)
      Creates a Concept instance using the specified parameters, where the name is a String.
      Concept BusinessQueryManager.findConceptByPath(String path)
      Finds a Concept based on the path specified.
      Methods in javax.xml.registry with parameters of type Concept
      Modifier and Type Method and Description
      Association LifeCycleManager.createAssociation(RegistryObject targetObject, Concept associationType)
      Creates an Association instance using the specified parameters.
      Classification LifeCycleManager.createClassification(Concept concept)
      Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.
      ClassificationScheme LifeCycleManager.createClassificationScheme(Concept concept)
      Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.

    • Uses of Concept in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return Concept
      Modifier and Type Method and Description
      Concept Association.getAssociationType()
      Gets the association type for this Association.
      Concept Classification.getConcept()
      Gets the Concept that is classifying the object.
      Concept RegistryObject.getObjectType()
      Gets the object type that best describes the RegistryObject.
      Concept Concept.getParentConcept()
      Gets the parent Concept or null if parent is a ClassificationScheme.
      Methods in javax.xml.registry.infomodel with parameters of type Concept
      Modifier and Type Method and Description
      void Concept.addChildConcept(Concept concept)
      Adds a child Concept.
      void ClassificationScheme.addChildConcept(Concept concept)
      Adds a child Concept.
      void Concept.removeChildConcept(Concept concept)
      Removes a child Concept.
      void ClassificationScheme.removeChildConcept(Concept concept)
      Removes a child Concept.
      void Association.setAssociationType(Concept associationType)
      Sets the association type for this Association.
      void Classification.setConcept(Concept concept)
      Sets the concept for this internal classification.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.EmailAddress (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.EmailAddress

  • Packages that use EmailAddress
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of EmailAddress in javax.xml.registry

      Methods in javax.xml.registry that return EmailAddress
      Modifier and Type Method and Description
      EmailAddress LifeCycleManager.createEmailAddress(String address)
      Creates an EmailAddress instance using an address as the parameter.
      EmailAddress LifeCycleManager.createEmailAddress(String address, String type)
      Creates an EmailAddress instance using both an address and a type as parameters.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.ExtensibleObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.ExtensibleObject

  • Packages that use ExtensibleObject
    Package Description
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of ExtensibleObject in javax.xml.registry.infomodel

      Subinterfaces of ExtensibleObject in javax.xml.registry.infomodel
      Modifier and Type Interface and Description
      interface  Association
      A RegistryObject instance may be associated with zero or more RegistryObject instances.
      interface  AuditableEvent
      AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject.
      interface  Classification
      The Classification interface is used to classify RegistryObject instances.
      interface  ClassificationScheme
      A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
      interface  Concept
      The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.
      interface  ExternalIdentifier
      ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization.
      interface  ExternalLink
      ExternalLink instances model a named URI to content that may reside outside the registry.
      interface  ExtrinsicObject
      ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).
      interface  Organization
      Organization instances provide information on organizations such as a Submitting Organization.
      interface  PostalAddress
      PostalAddress is a simple re-usable entity class that defines attributes of a postal Address.
      interface  RegistryEntry
      The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface.
      interface  RegistryObject
      The RegistryObject class is an abstract base class used by most classes in the model.
      interface  RegistryPackage
      RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together.
      interface  Service
      Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization.
      interface  ServiceBinding
      ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance.
      interface  SpecificationLink
      A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding.
      interface  User
      User instances are RegistryObjects that are used to provide information about registered users within the registry.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.ExternalIdentifier (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.ExternalIdentifier

  • Packages that use ExternalIdentifier
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of ExternalIdentifier in javax.xml.registry

      Methods in javax.xml.registry that return ExternalIdentifier
      Modifier and Type Method and Description
      ExternalIdentifier LifeCycleManager.createExternalIdentifier(ClassificationScheme identificationScheme, InternationalString name, String value)
      Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.
      ExternalIdentifier LifeCycleManager.createExternalIdentifier(ClassificationScheme identificationScheme, String name, String value)
      Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.

    • Uses of ExternalIdentifier in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel with parameters of type ExternalIdentifier
      Modifier and Type Method and Description
      void RegistryObject.addExternalIdentifier(ExternalIdentifier externalIdentifier)
      Adds specified ExternalIdentifier as an external identifier to this object.
      void RegistryObject.removeExternalIdentifier(ExternalIdentifier externalIdentifier)
      Removes specified ExternalIdentifier as an external identifier from this object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.ExternalLink (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.ExternalLink

  • Packages that use ExternalLink
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of ExternalLink in javax.xml.registry

      Methods in javax.xml.registry that return ExternalLink
      Modifier and Type Method and Description
      ExternalLink LifeCycleManager.createExternalLink(String externalURI, InternationalString description)
      Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.
      ExternalLink LifeCycleManager.createExternalLink(String externalURI, String description)
      Creates an ExternalLink instance using the specified parameters, where the description is a String.

    • Uses of ExternalLink in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel with parameters of type ExternalLink
      Modifier and Type Method and Description
      void RegistryObject.addExternalLink(ExternalLink externalLink)
      Adds specified ExternalLink to this object.
      void RegistryObject.removeExternalLink(ExternalLink externalLink)
      Removes specified ExternalLink from this object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.ExtrinsicObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.ExtrinsicObject

  • Packages that use ExtrinsicObject
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of ExtrinsicObject in javax.xml.registry

      Methods in javax.xml.registry that return ExtrinsicObject
      Modifier and Type Method and Description
      ExtrinsicObject LifeCycleManager.createExtrinsicObject(DataHandler repositoryItem)
      Creates an ExtrinsicObject instance using the specified parameters.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.InternationalString (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.InternationalString

  • Packages that use InternationalString
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of InternationalString in javax.xml.registry

      Methods in javax.xml.registry that return InternationalString
      Modifier and Type Method and Description
      InternationalString LifeCycleManager.createInternationalString()
      Creates an empty InternationalString instance.
      InternationalString LifeCycleManager.createInternationalString(Locale l, String s)
      Creates an InternationalString instance using the specified Locale and String parameters.
      InternationalString LifeCycleManager.createInternationalString(String s)
      Creates an InternationalString instance using a String parameter and the default Locale.
      Methods in javax.xml.registry with parameters of type InternationalString
      Modifier and Type Method and Description
      Classification LifeCycleManager.createClassification(ClassificationScheme scheme, InternationalString name, String value)
      Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.
      ClassificationScheme LifeCycleManager.createClassificationScheme(InternationalString name, InternationalString description)
      Creates a ClassificationScheme given the specified InternationalString parameters.
      Concept LifeCycleManager.createConcept(RegistryObject parent, InternationalString name, String value)
      Creates a Concept instance using the specified parameters, where the name is an InternationalString.
      ExternalIdentifier LifeCycleManager.createExternalIdentifier(ClassificationScheme identificationScheme, InternationalString name, String value)
      Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.
      ExternalLink LifeCycleManager.createExternalLink(String externalURI, InternationalString description)
      Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.
      Organization LifeCycleManager.createOrganization(InternationalString name)
      Creates an Organization instance using the specified name, where the name is an InternationalString.
      RegistryPackage LifeCycleManager.createRegistryPackage(InternationalString name)
      Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.
      Service LifeCycleManager.createService(InternationalString name)
      Creates a Service instance using the specified name, where the name is an InternationalString.

    • Uses of InternationalString in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return InternationalString
      Modifier and Type Method and Description
      InternationalString RegistryObject.getDescription()
      Gets the textual description for this object.
      InternationalString RegistryObject.getName()
      Gets the user-friendly name of this object.
      InternationalString SpecificationLink.getUsageDescription()
      Gets the description of usage parameters.
      Methods in javax.xml.registry.infomodel with parameters of type InternationalString
      Modifier and Type Method and Description
      void RegistryObject.setDescription(InternationalString description)
      Sets the context independent textual description for this object.
      void RegistryObject.setName(InternationalString name)
      Sets user-friendly name of object in repository.
      void SpecificationLink.setUsageDescription(InternationalString usageDescription)
      Sets the description of usage parameters.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.Key (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.Key

  • Packages that use Key
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of Key in javax.xml.registry

      Methods in javax.xml.registry that return Key
      Modifier and Type Method and Description
      Key LifeCycleManager.createKey(String id)
      Creates a Key instance from an ID.
      Key RegistryException.getErrorObjectKey()
      Gets the Key to the first object that encountered an error in the registry.
      Methods in javax.xml.registry with parameters of type Key
      Modifier and Type Method and Description
      BulkResponse BusinessQueryManager.findServiceBindings(Key serviceKey, Collection findQualifiers, Collection classifications, Collection specifications)
      Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call.
      BulkResponse BusinessQueryManager.findServices(Key orgKey, Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications)
      Finds all Service objects that match all of the criteria specified by the parameters of this call.
      void RegistryException.setErrorObjectKey(Key key)
      Sets the Key to the first object that encountered an error in the registry.

    • Uses of Key in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return Key
      Modifier and Type Method and Description
      Key RegistryObject.getKey()
      Gets the key representing the universally unique ID (UUID) for this object.
      Methods in javax.xml.registry.infomodel with parameters of type Key
      Modifier and Type Method and Description
      void RegistryObject.setKey(Key key)
      Sets the key representing the universally unique ID (UUID) for this object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.LocalizedString (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.LocalizedString

  • Packages that use LocalizedString
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of LocalizedString in javax.xml.registry

      Methods in javax.xml.registry that return LocalizedString
      Modifier and Type Method and Description
      LocalizedString LifeCycleManager.createLocalizedString(Locale l, String s)
      Creates a LocalizedString instance using the specified Locale and String parameters.
      LocalizedString LifeCycleManager.createLocalizedString(Locale l, String s, String charSetName)
      Creates a LocalizedString instance using the specified Locale, String, and character set parameters.

    • Uses of LocalizedString in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return LocalizedString
      Modifier and Type Method and Description
      LocalizedString InternationalString.getLocalizedString(Locale locale, String charsetName)
      Gets the LocalizedString for the specified Locale and charsetName.
      Methods in javax.xml.registry.infomodel with parameters of type LocalizedString
      Modifier and Type Method and Description
      void InternationalString.addLocalizedString(LocalizedString localizedString)
      Adds a LocalizedString to this object.
      void InternationalString.removeLocalizedString(LocalizedString localizedString)
      Removes a LocalizedString from this object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.Organization (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.Organization

  • Packages that use Organization
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of Organization in javax.xml.registry

      Methods in javax.xml.registry that return Organization
      Modifier and Type Method and Description
      Organization LifeCycleManager.createOrganization(InternationalString name)
      Creates an Organization instance using the specified name, where the name is an InternationalString.
      Organization LifeCycleManager.createOrganization(String name)
      Creates an Organization instance using the specified name, where the name is a String.

    • Uses of Organization in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return Organization
      Modifier and Type Method and Description
      Organization User.getOrganization()
      Gets the Organization that this User is affiliated with.
      Organization Organization.getParentOrganization()
      Gets the parent (container) organization.
      Organization Service.getProvidingOrganization()
      Gets the Organization that provides this service.
      Organization Organization.getRootOrganization()
      Gets the root organization.
      Organization RegistryObject.getSubmittingOrganization()
      Gets the Organization that submitted this RegistryObject.
      Methods in javax.xml.registry.infomodel with parameters of type Organization
      Modifier and Type Method and Description
      void Organization.addChildOrganization(Organization organization)
      Adds a child Organization.
      void Organization.removeChildOrganization(Organization organization)
      Removes a child Organization.
      void Service.setProvidingOrganization(Organization providingOrganization)
      Sets the Organization that provides this service.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.PersonName (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.PersonName

  • Packages that use PersonName
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of PersonName in javax.xml.registry

      Methods in javax.xml.registry that return PersonName
      Modifier and Type Method and Description
      PersonName LifeCycleManager.createPersonName(String fullName)
      Creates a PersonName instance using the specified full name.
      PersonName LifeCycleManager.createPersonName(String firstName, String middleName, String lastName)
      Creates a PersonName instance using the specified first, middle, and last names.

    • Uses of PersonName in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return PersonName
      Modifier and Type Method and Description
      PersonName User.getPersonName()
      Returns the name of this User.
      Methods in javax.xml.registry.infomodel with parameters of type PersonName
      Modifier and Type Method and Description
      void User.setPersonName(PersonName personName)
      Sets the name of this User.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.PostalAddress (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.PostalAddress

  • Packages that use PostalAddress
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of PostalAddress in javax.xml.registry

      Methods in javax.xml.registry that return PostalAddress
      Modifier and Type Method and Description
      PostalAddress LifeCycleManager.createPostalAddress(String streetNumber, String street, String city, String stateOrProvince, String country, String postalCode, String type)
      Creates a PostalAddress instance using the specified parameters.

    • Uses of PostalAddress in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return PostalAddress
      Modifier and Type Method and Description
      PostalAddress Organization.getPostalAddress()
      Gets the Address for this Organization.
      Methods in javax.xml.registry.infomodel with parameters of type PostalAddress
      Modifier and Type Method and Description
      void Organization.setPostalAddress(PostalAddress address)
      Sets the address for this Organization.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.RegistryEntry (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.RegistryEntry

  • Packages that use RegistryEntry
    Package Description
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of RegistryEntry in javax.xml.registry.infomodel

      Subinterfaces of RegistryEntry in javax.xml.registry.infomodel
      Modifier and Type Interface and Description
      interface  ClassificationScheme
      A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
      interface  ExtrinsicObject
      ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).
      interface  RegistryPackage
      RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together.
      interface  Service
      Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.RegistryObject (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.RegistryObject

  • Packages that use RegistryObject
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of RegistryObject in javax.xml.registry

      Methods in javax.xml.registry that return RegistryObject
      Modifier and Type Method and Description
      RegistryObject QueryManager.getRegistryObject(String id)
      Gets the RegistryObject specified by the Id.
      RegistryObject QueryManager.getRegistryObject(String id, String objectType)
      Gets the RegistryObject specified by the Id and type of object.
      Methods in javax.xml.registry with parameters of type RegistryObject
      Modifier and Type Method and Description
      Association LifeCycleManager.createAssociation(RegistryObject targetObject, Concept associationType)
      Creates an Association instance using the specified parameters.
      Concept LifeCycleManager.createConcept(RegistryObject parent, InternationalString name, String value)
      Creates a Concept instance using the specified parameters, where the name is an InternationalString.
      Concept LifeCycleManager.createConcept(RegistryObject parent, String name, String value)
      Creates a Concept instance using the specified parameters, where the name is a String.

    • Uses of RegistryObject in javax.xml.registry.infomodel

      Subinterfaces of RegistryObject in javax.xml.registry.infomodel
      Modifier and Type Interface and Description
      interface  Association
      A RegistryObject instance may be associated with zero or more RegistryObject instances.
      interface  AuditableEvent
      AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject.
      interface  Classification
      The Classification interface is used to classify RegistryObject instances.
      interface  ClassificationScheme
      A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
      interface  Concept
      The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.
      interface  ExternalIdentifier
      ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization.
      interface  ExternalLink
      ExternalLink instances model a named URI to content that may reside outside the registry.
      interface  ExtrinsicObject
      ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).
      interface  Organization
      Organization instances provide information on organizations such as a Submitting Organization.
      interface  RegistryEntry
      The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface.
      interface  RegistryPackage
      RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together.
      interface  Service
      Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization.
      interface  ServiceBinding
      ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance.
      interface  SpecificationLink
      A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding.
      interface  User
      User instances are RegistryObjects that are used to provide information about registered users within the registry.
      Methods in javax.xml.registry.infomodel that return RegistryObject
      Modifier and Type Method and Description
      RegistryObject Classification.getClassifiedObject()
      Gets the Object that is being classified.
      RegistryObject Concept.getParent()
      Gets the parent Concept or ClassificationScheme for this object.
      RegistryObject ExternalIdentifier.getRegistryObject()
      Gets the parent RegistryObject for this ExternalIdentifier.
      RegistryObject AuditableEvent.getRegistryObject()
      Gets the RegistryObject associated with this AuditableEvent.
      RegistryObject Association.getSourceObject()
      Gets the Object that is the source of this Association.
      RegistryObject SpecificationLink.getSpecificationObject()
      Gets the specification object for this object.
      RegistryObject Association.getTargetObject()
      Gets the Object that is the target of this Association.
      Methods in javax.xml.registry.infomodel with parameters of type RegistryObject
      Modifier and Type Method and Description
      void RegistryPackage.addRegistryObject(RegistryObject registryObject)
      Adds a child RegistryObject as member.
      void RegistryPackage.removeRegistryObject(RegistryObject registryObject)
      Removes a child RegistryObject from membership.
      void Classification.setClassifiedObject(RegistryObject classifiedObject)
      Sets the object that is being classified.
      void Association.setSourceObject(RegistryObject srcObject)
      Sets the Object that is the source of this Association.
      void SpecificationLink.setSpecificationObject(RegistryObject obj)
      Sets the specification object for this object.
      void Association.setTargetObject(RegistryObject targetObject)
      Sets the Object that is the target of this Association.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.RegistryPackage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.RegistryPackage

  • Packages that use RegistryPackage
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of RegistryPackage in javax.xml.registry

      Methods in javax.xml.registry that return RegistryPackage
      Modifier and Type Method and Description
      RegistryPackage LifeCycleManager.createRegistryPackage(InternationalString name)
      Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.
      RegistryPackage LifeCycleManager.createRegistryPackage(String name)
      Creates a RegistryPackage instance using the specified name, where the name is a String.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.Service (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.Service

  • Packages that use Service
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of Service in javax.xml.registry

      Methods in javax.xml.registry that return Service
      Modifier and Type Method and Description
      Service LifeCycleManager.createService(InternationalString name)
      Creates a Service instance using the specified name, where the name is an InternationalString.
      Service LifeCycleManager.createService(String name)
      Creates a Service instance using the specified name, where the name is a String.

    • Uses of Service in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return Service
      Modifier and Type Method and Description
      Service ServiceBinding.getService()
      Gets the parent service for which this is a binding.
      Methods in javax.xml.registry.infomodel with parameters of type Service
      Modifier and Type Method and Description
      void Organization.addService(Service service)
      Adds a child Service.
      void Organization.removeService(Service service)
      Removes a Service from this object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.ServiceBinding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.ServiceBinding

  • Packages that use ServiceBinding
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of ServiceBinding in javax.xml.registry

      Methods in javax.xml.registry that return ServiceBinding
      Modifier and Type Method and Description
      ServiceBinding LifeCycleManager.createServiceBinding()
      Creates an empty ServiceBinding instance.

    • Uses of ServiceBinding in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return ServiceBinding
      Modifier and Type Method and Description
      ServiceBinding SpecificationLink.getServiceBinding()
      Gets the parent ServiceBinding for this SpecificationLink.
      ServiceBinding ServiceBinding.getTargetBinding()
      Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.
      Methods in javax.xml.registry.infomodel with parameters of type ServiceBinding
      Modifier and Type Method and Description
      void Service.addServiceBinding(ServiceBinding serviceBinding)
      Adds a child ServiceBinding.
      void Service.removeServiceBinding(ServiceBinding serviceBinding)
      Removes a child ServiceBinding.
      void ServiceBinding.setTargetBinding(ServiceBinding binding)
      Sets the next ServiceBinding in case there is a redirection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.Slot (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.Slot

  • Packages that use Slot
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of Slot in javax.xml.registry

      Methods in javax.xml.registry that return Slot
      Modifier and Type Method and Description
      Slot LifeCycleManager.createSlot(String name, Collection values, String slotType)
      Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.
      Slot LifeCycleManager.createSlot(String name, String value, String slotType)
      Creates a Slot instance using the specified parameters, where the value is a String.

    • Uses of Slot in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return Slot
      Modifier and Type Method and Description
      Slot ExtensibleObject.getSlot(String slotName)
      Gets the slot specified by slotName.
      Methods in javax.xml.registry.infomodel with parameters of type Slot
      Modifier and Type Method and Description
      void ExtensibleObject.addSlot(Slot slot)
      Adds a Slot to this object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.SpecificationLink (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.SpecificationLink

  • Packages that use SpecificationLink
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of SpecificationLink in javax.xml.registry

      Methods in javax.xml.registry that return SpecificationLink
      Modifier and Type Method and Description
      SpecificationLink LifeCycleManager.createSpecificationLink()
      Creates an empty SpecificationLink instance.

    • Uses of SpecificationLink in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel with parameters of type SpecificationLink
      Modifier and Type Method and Description
      void ServiceBinding.addSpecificationLink(SpecificationLink specificationLink)
      Adds a child SpecificationLink.
      void ServiceBinding.removeSpecificationLink(SpecificationLink specificationLink)
      Removes a child SpecificationLink.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.TelephoneNumber (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.TelephoneNumber

  • Packages that use TelephoneNumber
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.

    • Uses of TelephoneNumber in javax.xml.registry

      Methods in javax.xml.registry that return TelephoneNumber
      Modifier and Type Method and Description
      TelephoneNumber LifeCycleManager.createTelephoneNumber()
      Creates an empty TelephoneNumber instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.URIValidator (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.URIValidator

  • Packages that use URIValidator
    Package Description
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of URIValidator in javax.xml.registry.infomodel

      Subinterfaces of URIValidator in javax.xml.registry.infomodel
      Modifier and Type Interface and Description
      interface  ExternalLink
      ExternalLink instances model a named URI to content that may reside outside the registry.
      interface  ServiceBinding
      ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.User (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.User

  • Packages that use User
    Package Description
    javax.xml.registry
    This package defines APIs to access and programatically interact with metadata registries.
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of User in javax.xml.registry

      Methods in javax.xml.registry that return User
      Modifier and Type Method and Description
      User LifeCycleManager.createUser()
      Creates an empty User instance.

    • Uses of User in javax.xml.registry.infomodel

      Methods in javax.xml.registry.infomodel that return User
      Modifier and Type Method and Description
      User Organization.getPrimaryContact()
      Gets the primary Contact for this Organization.
      User AuditableEvent.getUser()
      Gets the User associated with this object.
      Methods in javax.xml.registry.infomodel with parameters of type User
      Modifier and Type Method and Description
      void Organization.addUser(User user)
      Adds a User.
      void Organization.removeUser(User user)
      Removes a User.
      void Organization.setPrimaryContact(User primaryContact)
      Sets the primary contact for this Organization.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.registry.infomodel.Versionable (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.registry.infomodel.Versionable

  • Packages that use Versionable
    Package Description
    javax.xml.registry.infomodel
    This package defines interfaces that define the information model for metadata registries.

    • Uses of Versionable in javax.xml.registry.infomodel

      Subinterfaces of Versionable in javax.xml.registry.infomodel
      Modifier and Type Interface and Description
      interface  ClassificationScheme
      A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
      interface  ExtrinsicObject
      ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).
      interface  RegistryEntry
      The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface.
      interface  RegistryPackage
      RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together.
      interface  Service
      Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Call (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc

Interface Call

  • public interface Call
    The javax.xml.rpc.Call interface provides support for the dynamic invocation of a service endpoint. The javax.xml.rpc.Service interface acts as a factory for the creation of Call instances.

    Once a Call instance is created, various setter and getter methods may be used to configure this Call instance.

    Version:
    1.0
    Author:
    Rahul Sharma

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ENCODINGSTYLE_URI_PROPERTY
      Standard property for encoding Style: Encoding style specified as a namespace URI.
      static String OPERATION_STYLE_PROPERTY
      Standard property for operation style.
      static String PASSWORD_PROPERTY
      Standard property: Password for authentication
      static String SESSION_MAINTAIN_PROPERTY
      Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.
      static String SOAPACTION_URI_PROPERTY
      Standard property for SOAPAction.
      static String SOAPACTION_USE_PROPERTY
      Standard property for SOAPAction.
      static String USERNAME_PROPERTY
      Standard property: User name for authentication

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addParameter(String paramName, QName xmlType, Class javaType, ParameterMode parameterMode)
      Adds a parameter type and mode for a specific operation.
      void addParameter(String paramName, QName xmlType, ParameterMode parameterMode)
      Adds a parameter type and mode for a specific operation.
      QName getOperationName()
      Gets the name of the operation to be invoked using this Call instance.
      Map getOutputParams()
      Returns a Map of {name, value} for the output parameters of the last invoked operation.
      List getOutputValues()
      Returns a List values for the output parameters of the last invoked operation.
      QName getParameterTypeByName(String paramName)
      Gets the XML type of a parameter by name
      QName getPortTypeName()
      Gets the qualified name of the port type.
      Object getProperty(String name)
      Gets the value of a named property.
      Iterator getPropertyNames()
      Gets the names of configurable properties supported by this Call object.
      QName getReturnType()
      Gets the return type for a specific operation
      String getTargetEndpointAddress()
      Gets the address of a target service endpoint.
      Object invoke(Object[] inputParams)
      Invokes a specific operation using a synchronous request-response interaction mode.
      Object invoke(QName operationName, Object[] inputParams)
      Invokes a specific operation using a synchronous request-response interaction mode.
      void invokeOneWay(Object[] inputParams)
      Invokes a remote method using the one-way interaction mode.
      boolean isParameterAndReturnSpecRequired(QName operationName)
      Indicates whether addParameter and setReturnType methods are to be invoked to specify the parameter and return type specification for a specific operation.
      void removeAllParameters()
      Removes all specified parameters from this Call instance.
      void removeProperty(String name)
      Removes a named property.
      void setOperationName(QName operationName)
      Sets the name of the operation to be invoked using this Call instance.
      void setPortTypeName(QName portType)
      Sets the qualified name of the port type.
      void setProperty(String name, Object value)
      Sets the value for a named property.
      void setReturnType(QName xmlType)
      Sets the return type for a specific operation.
      void setReturnType(QName xmlType, Class javaType)
      Sets the return type for a specific operation.
      void setTargetEndpointAddress(String address)
      Sets the address of the target service endpoint.

    • Field Detail

      • USERNAME_PROPERTY

        static final String USERNAME_PROPERTY
        Standard property: User name for authentication

        Type: java.lang.String

        See Also:
        Constant Field Values

      • PASSWORD_PROPERTY

        static final String PASSWORD_PROPERTY
        Standard property: Password for authentication

        Type: java.lang.String

        See Also:
        Constant Field Values

      • OPERATION_STYLE_PROPERTY

        static final String OPERATION_STYLE_PROPERTY
        Standard property for operation style. This property is set to "rpc" if the operation style is rpc; "document" if the operation style is document.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • SOAPACTION_USE_PROPERTY

        static final String SOAPACTION_USE_PROPERTY
        Standard property for SOAPAction. This boolean property indicates whether or not SOAPAction is to be used. The default value of this property is false indicating that the SOAPAction is not used.

        Type: java.lang.Boolean

        See Also:
        Constant Field Values

      • SOAPACTION_URI_PROPERTY

        static final String SOAPACTION_URI_PROPERTY
        Standard property for SOAPAction. Indicates the SOAPAction URI if the javax.xml.rpc.soap.http.soapaction.use property is set to true.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • ENCODINGSTYLE_URI_PROPERTY

        static final String ENCODINGSTYLE_URI_PROPERTY
        Standard property for encoding Style: Encoding style specified as a namespace URI. The default value is the SOAP 1.1 encoding http://schemas.xmlsoap.org/soap/encoding/

        Type: java.lang.String

        See Also:
        Constant Field Values

      • SESSION_MAINTAIN_PROPERTY

        static final String SESSION_MAINTAIN_PROPERTY
        Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint. If this property is set to true, the service client indicates that it wants the session to be maintained. If set to false, the session is not maintained. The default value for this property is false.

        Type: java.lang.Boolean

        See Also:
        Constant Field Values

    • Method Detail

      • isParameterAndReturnSpecRequired

        boolean isParameterAndReturnSpecRequired(QName operationName)
        Indicates whether addParameter and setReturnType methods are to be invoked to specify the parameter and return type specification for a specific operation.
        Parameters:
        operationName - Qualified name of the operation
        Returns:
        Returns true if the Call implementation class requires addParameter and setReturnType to be invoked in the client code for the specified operation. This method returns false otherwise.
        Throws:
        IllegalArgumentException - If invalid operation name is specified

      • addParameter

        void addParameter(String paramName,
                QName xmlType,
                ParameterMode parameterMode)
        Adds a parameter type and mode for a specific operation. Note that the client code may not call any addParameter and setReturnType methods before calling the invoke method. In this case, the Call implementation class determines the parameter types by using reflection on parameters, using the WSDL description and configured type mapping registry.
        Parameters:
        paramName - Name of the parameter
        xmlType - XML type of the parameter
        parameterMode - Mode of the parameter-whether ParameterMode.IN, ParameterMode.OUT, or ParameterMode.INOUT,
        Throws:
        javax.xml.rpc.JAXRPCException: - This exception may be thrown if the method isParameterAndReturnSpecRequired returns false for this operation.
        IllegalArgumentException - If any illegal parameter name or XML type is specified
        See Also:
        isParameterAndReturnSpecRequired(javax.xml.namespace.QName)

      • addParameter

        void addParameter(String paramName,
                QName xmlType,
                Class javaType,
                ParameterMode parameterMode)
        Adds a parameter type and mode for a specific operation. This method is used to specify the Java type for either OUT or INOUT parameters.
        Parameters:
        paramName - Name of the parameter
        xmlType - XML type of the parameter
        javaType - Java class of the parameter
        parameterMode - Mode of the parameter-whether ParameterMode.IN, OUT or INOUT
        Throws:
        JAXRPCException -
        • This exception may be thrown if this method is invoked when the method isParameterAndReturnSpecRequired returns false.
        • If specified XML type and Java type mapping is not valid. For example, TypeMappingRegistry has no serializers for this mapping.
        IllegalArgumentException - If any illegal parameter name or XML type is specified
        UnsupportedOperationException - If this method is not supported
        See Also:
        isParameterAndReturnSpecRequired(javax.xml.namespace.QName)

      • getParameterTypeByName

        QName getParameterTypeByName(String paramName)
        Gets the XML type of a parameter by name
        Parameters:
        paramName - Name of the parameter
        Returns:
        Returns XML type for the specified parameter

      • setReturnType

        void setReturnType(QName xmlType)
        Sets the return type for a specific operation. Invoking setReturnType(null) removes the return type for this Call object.
        Parameters:
        xmlType - XML data type of the return value
        Throws:
        JAXRPCException - This exception may be thrown when the method isParameterAndReturnSpecRequired returns false.
        IllegalArgumentException - If an illegal XML type is specified

      • setReturnType

        void setReturnType(QName xmlType,
                 Class javaType)
        Sets the return type for a specific operation.
        Parameters:
        xmlType - XML data type of the return value
        javaType - Java Class of the return value
        Throws:
        JAXRPCException -
        • This exception may be thrown if this method is invoked when the method isParameterAndReturnSpecRequired returns false.
        • If XML type and Java type cannot be mapped using the standard type mapping or TypeMapping registry
        UnsupportedOperationException - If this method is not supported
        IllegalArgumentException - If an illegal XML type is specified

      • getReturnType

        QName getReturnType()
        Gets the return type for a specific operation
        Returns:
        Returns the XML type for the return value

      • removeAllParameters

        void removeAllParameters()
        Removes all specified parameters from this Call instance. Note that this method removes only the parameters and not the return type. The setReturnType(null) is used to remove the return type.
        Throws:
        JAXRPCException - This exception may be thrown If this method is called when the method isParameterAndReturnSpecRequired returns false for this Call's operation.

      • getOperationName

        QName getOperationName()
        Gets the name of the operation to be invoked using this Call instance.
        Returns:
        Qualified name of the operation

      • setOperationName

        void setOperationName(QName operationName)
        Sets the name of the operation to be invoked using this Call instance.
        Parameters:
        operationName - QName of the operation to be invoked using the Call instance

      • getPortTypeName

        QName getPortTypeName()
        Gets the qualified name of the port type.
        Returns:
        Qualified name of the port type

      • setPortTypeName

        void setPortTypeName(QName portType)
        Sets the qualified name of the port type.
        Parameters:
        portType - Qualified name of the port type

      • setTargetEndpointAddress

        void setTargetEndpointAddress(String address)
        Sets the address of the target service endpoint. This address must correspond to the transport specified in the binding for this Call instance.
        Parameters:
        address - Address of the target service endpoint; specified as an URI

      • getTargetEndpointAddress

        String getTargetEndpointAddress()
        Gets the address of a target service endpoint.
        Returns:
        Address of the target service endpoint as an URI

      • setProperty

        void setProperty(String name,
               Object value)
        Sets the value for a named property. JAX-RPC specification specifies a standard set of properties that may be passed to the Call.setProperty method.
        Parameters:
        name - Name of the property
        value - Value of the property
        Throws:
        JAXRPCException -
        • If an optional standard property name is specified, however this Call implementation class does not support the configuration of this property.
        • If an invalid (or unsupported) property name is specified or if a value of mismatched property type is passed.
        • If there is any error in the configuration of a valid property.

      • getProperty

        Object getProperty(String name)
        Gets the value of a named property.
        Parameters:
        name - Name of the property
        Returns:
        Value of the named property
        Throws:
        JAXRPCException - if an invalid or unsupported property name is passed.

      • removeProperty

        void removeProperty(String name)
        Removes a named property.
        Parameters:
        name - Name of the property
        Throws:
        JAXRPCException - if an invalid or unsupported property name is passed.

      • getPropertyNames

        Iterator getPropertyNames()
        Gets the names of configurable properties supported by this Call object.
        Returns:
        Iterator for the property names

      • invoke

        Object invoke(Object[] inputParams)
              throws RemoteException
        Invokes a specific operation using a synchronous request-response interaction mode.
        Parameters:
        inputParams - Object[]--Parameters for this invocation. This includes only the input params
        Returns:
        Returns the return value or null
        Throws:
        RemoteException - if there is any error in the remote method invocation
        SOAPFaultException - Indicates a SOAP fault
        JAXRPCException -
        • If there is an error in the configuration of the Call object
        • If inputParams do not match the required parameter set (as specified through the addParameter invocations or in the corresponding WSDL)
        • If parameters and return type are incorrectly specified

      • invoke

        Object invoke(QName operationName,
            Object[] inputParams)
              throws RemoteException
        Invokes a specific operation using a synchronous request-response interaction mode.
        Parameters:
        operationName - QName of the operation
        inputParams - Object[]--Parameters for this invocation. This includes only the input params.
        Returns:
        Return value or null
        Throws:
        RemoteException - if there is any error in the remote method invocation.
        SOAPFaultException - Indicates a SOAP fault
        JAXRPCException -
        • If there is an error in the configuration of the Call object
        • If inputParams do not match the required parameter set (as specified through the addParameter invocations or in the corresponding WSDL)
        • If parameters and return type are incorrectly specified

      • invokeOneWay

        void invokeOneWay(Object[] inputParams)
        Invokes a remote method using the one-way interaction mode. The client thread does not normally block waiting for the completion of the server processing for this remote method invocation. When the protocol in use is SOAP/HTTP, this method should block until an HTTP response code has been received or an error occurs. This method must not throw any remote exceptions. This method may throw a JAXRPCException during the processing of the one-way remote call.
        Parameters:
        inputParams - Object[]--Parameters for this invocation. This includes only the input params.
        Throws:
        JAXRPCException - if there is an error in the configuration of the Call object (example: a non-void return type has been incorrectly specified for the one-way call) or if there is any error during the invocation of the one-way remote call

      • getOutputParams

        Map getOutputParams()
        Returns a Map of {name, value} for the output parameters of the last invoked operation. The parameter names in the returned Map are of type java.lang.String.
        Returns:
        Map Output parameters for the last Call.invoke(). Empty Map is returned if there are no output parameters.
        Throws:
        JAXRPCException - If this method is invoked for a one-way operation or is invoked before any invoke method has been called.

      • getOutputValues

        List getOutputValues()
        Returns a List values for the output parameters of the last invoked operation.
        Returns:
        java.util.List Values for the output parameters. An empty List is returned if there are no output values.
        Throws:
        JAXRPCException - If this method is invoked for a one-way operation or is invoked before any invoke method has been called.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.rpc (Java(TM) EE 7 Specification APIs)

javax.xml.rpc

Interfaces

  • Call
  • Service
  • Stub

Classes

  • NamespaceConstants
  • ParameterMode
  • ServiceFactory

Exceptions

  • JAXRPCException
  • ServiceException


javax.xml.rpc (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.rpc

This package contains the core JAX-RPC APIs for the client programming model.

See: Description

  • Interface Summary
    Interface Description
    Call
    The javax.xml.rpc.Call interface provides support for the dynamic invocation of a service endpoint.
    Service
    Service class acts as a factory of the following: Dynamic proxy for the target service endpoint.
    Stub
    The interface javax.xml.rpc.Stub is the common base interface for the stub classes.
  • Class Summary
    Class Description
    NamespaceConstants
    Constants used in JAX-RPC for namespace prefixes and URIs
    ParameterMode
    The javax.xml.rpc.ParameterMode is a type-safe enumeration for parameter mode.
    ServiceFactory
    The javax.xml.rpc.ServiceFactory is an abstract class that provides a factory for the creation of instances of the type javax.xml.rpc.Service.
  • Exception Summary
    Exception Description
    JAXRPCException
    The javax.xml.rpc.JAXRPCException is thrown from the core JAX-RPC APIs to indicate an exception related to the JAX-RPC runtime mechanisms.
    ServiceException
    The javax.xml.rpc.ServiceException is thrown from the methods in the javax.xml.rpc.Service interface and ServiceFactory class.

Package javax.xml.rpc Description

This package contains the core JAX-RPC APIs for the client programming model.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.rpc Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.rpc

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.rpc.NamespaceConstants
    • javax.xml.rpc.ParameterMode
    • javax.xml.rpc.ServiceFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.rpc.JAXRPCException
        • javax.xml.rpc.ServiceException

Interface Hierarchy

  • javax.xml.rpc.Call
  • javax.xml.rpc.Service
  • javax.xml.rpc.Stub
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


JAXRPCException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc

Class JAXRPCException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.rpc.JAXRPCException
  • All Implemented Interfaces:
    Serializable

    public class JAXRPCException
extends RuntimeException
    The javax.xml.rpc.JAXRPCException is thrown from the core JAX-RPC APIs to indicate an exception related to the JAX-RPC runtime mechanisms.
    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXRPCException()
      Constructs a new exception with null as its detail message.
      JAXRPCException(String message)
      Constructs a new exception with the specified detail message.
      JAXRPCException(String message, Throwable cause)
      Constructs a new exception with the specified detail message and cause.
      JAXRPCException(Throwable cause)
      Constructs a new JAXRPCException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getLinkedCause()
      Gets the Linked cause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JAXRPCException

        public JAXRPCException()
        Constructs a new exception with null as its detail message. The cause is not initialized.

      • JAXRPCException

        public JAXRPCException(String message)
        Constructs a new exception with the specified detail message. The cause is not initialized.
        Parameters:
        message - The detail message which is later retrieved using the getMessage method

      • JAXRPCException

        public JAXRPCException(String message,
               Throwable cause)
        Constructs a new exception with the specified detail message and cause.
        Parameters:
        message - The detail message which is later retrieved using the getMessage method
        cause - The cause which is saved for the later retrieval throw by the getCause method

      • JAXRPCException

        public JAXRPCException(Throwable cause)
        Constructs a new JAXRPCException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - The cause which is saved for the later retrieval throw by the getCause method. (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • Method Detail

      • getLinkedCause

        public Throwable getLinkedCause()
        Gets the Linked cause
        Returns:
        The cause of this Exception or null if the cause is noexistent or unknown
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NamespaceConstants (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc

Class NamespaceConstants

  • java.lang.Object
    • javax.xml.rpc.NamespaceConstants

  • public class NamespaceConstants
extends Object
    Constants used in JAX-RPC for namespace prefixes and URIs
    Version:
    1.0
    Author:
    Rahul Sharma

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String NSPREFIX_SCHEMA_XSD
      Namespace prefix for XML schema XSD
      static String NSPREFIX_SCHEMA_XSI
      Namespace prefix for XML Schema XSI
      static String NSPREFIX_SOAP_ENCODING
      Namespace prefix for SOAP Encoding
      static String NSPREFIX_SOAP_ENVELOPE
      Namespace prefix for SOAP Envelope
      static String NSURI_SCHEMA_XSD
      Namespace URI for XML Schema XSD
      static String NSURI_SCHEMA_XSI
      Namespace URI for XML Schema XSI
      static String NSURI_SOAP_ENCODING
      Nameapace URI for SOAP 1.1 Encoding
      static String NSURI_SOAP_ENVELOPE
      Nameapace URI for SOAP 1.1 Envelope
      static String NSURI_SOAP_NEXT_ACTOR
      Nameapace URI for SOAP 1.1 next actor role

    • Constructor Summary

      Constructors
      Constructor and Description
      NamespaceConstants()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • NSPREFIX_SOAP_ENVELOPE

        public static final String NSPREFIX_SOAP_ENVELOPE
        Namespace prefix for SOAP Envelope
        See Also:
        Constant Field Values

      • NSPREFIX_SOAP_ENCODING

        public static final String NSPREFIX_SOAP_ENCODING
        Namespace prefix for SOAP Encoding
        See Also:
        Constant Field Values

      • NSPREFIX_SCHEMA_XSD

        public static final String NSPREFIX_SCHEMA_XSD
        Namespace prefix for XML schema XSD
        See Also:
        Constant Field Values

      • NSPREFIX_SCHEMA_XSI

        public static final String NSPREFIX_SCHEMA_XSI
        Namespace prefix for XML Schema XSI
        See Also:
        Constant Field Values

      • NSURI_SOAP_ENVELOPE

        public static final String NSURI_SOAP_ENVELOPE
        Nameapace URI for SOAP 1.1 Envelope
        See Also:
        Constant Field Values

      • NSURI_SOAP_ENCODING

        public static final String NSURI_SOAP_ENCODING
        Nameapace URI for SOAP 1.1 Encoding
        See Also:
        Constant Field Values

      • NSURI_SOAP_NEXT_ACTOR

        public static final String NSURI_SOAP_NEXT_ACTOR
        Nameapace URI for SOAP 1.1 next actor role
        See Also:
        Constant Field Values

      • NSURI_SCHEMA_XSD

        public static final String NSURI_SCHEMA_XSD
        Namespace URI for XML Schema XSD
        See Also:
        Constant Field Values

      • NSURI_SCHEMA_XSI

        public static final String NSURI_SCHEMA_XSI
        Namespace URI for XML Schema XSI
        See Also:
        Constant Field Values

    • Constructor Detail

      • NamespaceConstants

        public NamespaceConstants()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ParameterMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc

Class ParameterMode

  • java.lang.Object
    • javax.xml.rpc.ParameterMode

  • public class ParameterMode
extends Object
    The javax.xml.rpc.ParameterMode is a type-safe enumeration for parameter mode. This class is used in the CallAPI to specify parameter passing modes.
    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    Call

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static ParameterMode IN
      IN mode for parameter passing
      static ParameterMode INOUT
      INOUT mode for parameter passing
      static ParameterMode OUT
      OUT mode for parameter passing

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String toString()
      Returns a String describing this ParameterMode object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • IN

        public static final ParameterMode IN
        IN mode for parameter passing

      • OUT

        public static final ParameterMode OUT
        OUT mode for parameter passing

      • INOUT

        public static final ParameterMode INOUT
        INOUT mode for parameter passing

    • Method Detail

      • toString

        public String toString()
        Returns a String describing this ParameterMode object.
        Overrides:
        toString in class Object
        Returns:
        A string representation of the object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Service (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc

Interface Service

  • public interface Service
    Service class acts as a factory of the following:
    • Dynamic proxy for the target service endpoint.
    • Instance of the type javax.xml.rpc.Call for the dynamic invocation of a remote operation on the target service endpoint.
    • Instance of a generated stub class
    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    Call, Stub

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Call createCall()
      Creates a Call object not associated with specific operation or target service endpoint.
      Call createCall(QName portName)
      Creates a Call instance.
      Call createCall(QName portName, QName operationName)
      Creates a Call instance.
      Call createCall(QName portName, String operationName)
      Creates a Call instance.
      Call[] getCalls(QName portName)
      Gets an array of preconfigured Call objects for invoking operations on the specified port.
      HandlerRegistry getHandlerRegistry()
      Returns the configured HandlerRegistry instance for this Service instance.
      Remote getPort(Class serviceEndpointInterface)
      The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
      Remote getPort(QName portName, Class serviceEndpointInterface)
      The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
      Iterator getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      QName getServiceName()
      Gets the name of this service.
      TypeMappingRegistry getTypeMappingRegistry()
      Gets the TypeMappingRegistry for this Service object.
      URL getWSDLDocumentLocation()
      Gets the location of the WSDL document for this Service.

    • Method Detail

      • getPort

        Remote getPort(QName portName,
             Class serviceEndpointInterface)
               throws ServiceException
        The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy. A service client uses this dynamic proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy or stub instance.
        Parameters:
        portName - Qualified name of the service endpoint in the WSDL service description
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy or stub instance
        Returns:
        java.rmi.Remote Stub instance or dynamic proxy that supports the specified service endpoint interface
        Throws:
        ServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the dynamic proxy or stub instance
        • If there is any missing WSDL metadata as required by this method
        • Optionally, if an illegal serviceEndpointInterface or portName is specified
        See Also:
        Proxy, InvocationHandler

      • getPort

        Remote getPort(Class serviceEndpointInterface)
               throws ServiceException
        The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned stub or proxy. In the implementation of this method, the JAX-RPC runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the stub accordingly. The returned Stub instance should not be reconfigured by the client.
        Parameters:
        serviceEndpointInterface - Service endpoint interface
        Returns:
        Stub instance or dynamic proxy that supports the specified service endpoint interface
        Throws:
        ServiceException -
        • If there is an error during creation of stub instance or dynamic proxy
        • If there is any missing WSDL metadata as required by this method
        • Optionally, if an illegal serviceEndpointInterface is specified

      • getCalls

        Call[] getCalls(QName portName)
                throws ServiceException
        Gets an array of preconfigured Call objects for invoking operations on the specified port. There is one Call object per operation that can be invoked on the specified port. Each Call object is pre-configured and does not need to be configured using the setter methods on Call interface.

        Each invocation of the getCalls method returns a new array of preconfigured Call objects

        This method requires the Service implementation class to have access to the WSDL related metadata.

        Parameters:
        portName - Qualified name for the target service endpoint
        Returns:
        Call[] Array of pre-configured Call objects
        Throws:
        ServiceException - If this Service class does not have access to the required WSDL metadata or if an illegal portName is specified.

      • createCall

        Call createCall(QName portName)
                throws ServiceException
        Creates a Call instance.
        Parameters:
        portName - Qualified name for the target service endpoint
        Returns:
        Call instance
        Throws:
        ServiceException - If any error in the creation of the Call object

      • createCall

        Call createCall(QName portName,
              QName operationName)
                throws ServiceException
        Creates a Call instance.
        Parameters:
        portName - Qualified name for the target service endpoint
        operationName - Qualified Name of the operation for which this Call object is to be created.
        Returns:
        Call instance
        Throws:
        ServiceException - If any error in the creation of the Call object

      • createCall

        Call createCall(QName portName,
              String operationName)
                throws ServiceException
        Creates a Call instance.
        Parameters:
        portName - Qualified name for the target service endpoint
        operationName - Name of the operation for which this Call object is to be created.
        Returns:
        Call instance
        Throws:
        ServiceException - If any error in the creation of the Call object

      • createCall

        Call createCall()
                throws ServiceException
        Creates a Call object not associated with specific operation or target service endpoint. This Call object needs to be configured using the setter methods on the Call interface.
        Returns:
        Call object
        Throws:
        ServiceException - If any error in the creation of the Call object

      • getServiceName

        QName getServiceName()
        Gets the name of this service.
        Returns:
        Qualified name of this service

      • getPorts

        Iterator getPorts()
                  throws ServiceException
        Returns an Iterator for the list of QNames of service endpoints grouped by this service
        Returns:
        Returns java.util.Iterator with elements of type javax.xml.namespace.QName
        Throws:
        ServiceException - If this Service class does not have access to the required WSDL metadata

      • getWSDLDocumentLocation

        URL getWSDLDocumentLocation()
        Gets the location of the WSDL document for this Service.
        Returns:
        URL for the location of the WSDL document for this service

      • getTypeMappingRegistry

        TypeMappingRegistry getTypeMappingRegistry()
        Gets the TypeMappingRegistry for this Service object. The returned TypeMappingRegistry instance is pre-configured to support the standard type mapping between XML and Java types types as required by the JAX-RPC specification.
        Returns:
        The TypeMappingRegistry for this Service object.
        Throws:
        java.lang.UnsupportedOperationException - if the Service class does not support the configuration of TypeMappingRegistry.

      • getHandlerRegistry

        HandlerRegistry getHandlerRegistry()
        Returns the configured HandlerRegistry instance for this Service instance.
        Returns:
        HandlerRegistry
        Throws:
        java.lang.UnsupportedOperationException - if the Service class does not support the configuration of a HandlerRegistry
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc

Class ServiceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.rpc.ServiceException
  • All Implemented Interfaces:
    Serializable

    public class ServiceException
extends Exception
    The javax.xml.rpc.ServiceException is thrown from the methods in the javax.xml.rpc.Service interface and ServiceFactory class.
    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceException()
      Constructs a new exception with null as its detail message.
      ServiceException(String message)
      Constructs a new exception with the specified detail message.
      ServiceException(String message, Throwable cause)
      Constructs a new exception with the specified detail message and cause.
      ServiceException(Throwable cause)
      Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getLinkedCause()
      Gets the Linked cause

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServiceException

        public ServiceException()
        Constructs a new exception with null as its detail message. The cause is not initialized.

      • ServiceException

        public ServiceException(String message)
        Constructs a new exception with the specified detail message. The cause is not initialized.
        Parameters:
        message - The detail message which is later retrieved using the getMessage method

      • ServiceException

        public ServiceException(String message,
                Throwable cause)
        Constructs a new exception with the specified detail message and cause.
        Parameters:
        message - The detail message which is later retrieved using the getMessage method
        cause - The cause which is saved for the later retrieval throw by the getCause method

      • ServiceException

        public ServiceException(Throwable cause)
        Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - The cause which is saved for the later retrieval throw by the getCause method. (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • Method Detail

      • getLinkedCause

        public Throwable getLinkedCause()
        Gets the Linked cause
        Returns:
        The cause of this Exception or null if the cause is noexistent or unknown
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc

Class ServiceFactory

  • java.lang.Object
    • javax.xml.rpc.ServiceFactory

  • public abstract class ServiceFactory
extends Object
    The javax.xml.rpc.ServiceFactory is an abstract class that provides a factory for the creation of instances of the type javax.xml.rpc.Service. This abstract class follows the abstract static factory design pattern. This enables a J2SE based client to create a Service instance in a portable manner without using the constructor of the Service implementation class.

    The ServiceFactory implementation class is set using the system property SERVICEFACTORY_PROPERTY.

    Version:
    1.1
    Author:
    Rahul Sharma, Roberto Chinnici
    See Also:
    Service

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String SERVICEFACTORY_PROPERTY
      A constant representing the property used to lookup the name of a ServiceFactory implementation class.

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | ServiceFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Service createService(QName serviceName)
      Create a Service instance.
      abstract Service createService(URL wsdlDocumentLocation, QName serviceName)
      Create a Service instance.
      abstract Service loadService(Class serviceInterface)
      Create an instance of the generated service implementation class for a given service interface, if available.
      abstract Service loadService(URL wsdlDocumentLocation, Class serviceInterface, Properties properties)
      Create an instance of the generated service implementation class for a given service interface, if available.
      abstract Service loadService(URL wsdlDocumentLocation, QName serviceName, Properties properties)
      Create an instance of the generated service implementation class for a given service, if available.
      static ServiceFactory newInstance()
      Gets an instance of the ServiceFactory

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • SERVICEFACTORY_PROPERTY

        public static final String SERVICEFACTORY_PROPERTY
        A constant representing the property used to lookup the name of a ServiceFactory implementation class.
        See Also:
        Constant Field Values

    • Constructor Detail

      • ServiceFactory

        protected ServiceFactory()

    • Method Detail

      • newInstance

        public static ServiceFactory newInstance()
                                  throws ServiceException
        Gets an instance of the ServiceFactory

        Only one copy of a factory exists and is returned to the application each time this method is called.

        The implementation class to be used can be overridden by setting the javax.xml.rpc.ServiceFactory system property.

        Throws:
        ServiceException

      • createService

        public abstract Service createService(URL wsdlDocumentLocation,
                    QName serviceName)
                               throws ServiceException
        Create a Service instance.
        Parameters:
        wsdlDocumentLocation - URL for the WSDL document location for the service
        serviceName - QName for the service
        Throws:
        ServiceException - If any error in creation of the specified service

      • createService

        public abstract Service createService(QName serviceName)
                               throws ServiceException
        Create a Service instance.
        Parameters:
        serviceName - QName for the service
        Throws:
        ServiceException - If any error in creation of the specified service

      • loadService

        public abstract Service loadService(Class serviceInterface)
                             throws ServiceException
        Create an instance of the generated service implementation class for a given service interface, if available.
        Parameters:
        serviceInterface - Service interface
        Throws:
        ServiceException - If there is any error while creating the specified service, including the case where a generated service implementation class cannot be located

      • loadService

        public abstract Service loadService(URL wsdlDocumentLocation,
                  Class serviceInterface,
                  Properties properties)
                             throws ServiceException
        Create an instance of the generated service implementation class for a given service interface, if available. An implementation may use the provided wsdlDocumentLocation and properties to help locate the generated implementation class. If no such class is present, a ServiceException will be thrown.
        Parameters:
        wsdlDocumentLocation - URL for the WSDL document location for the service or null
        serviceInterface - Service interface
        properties - A set of implementation-specific properties to help locate the generated service implementation class
        Throws:
        ServiceException - If there is any error while creating the specified service, including the case where a generated service implementation class cannot be located

      • loadService

        public abstract Service loadService(URL wsdlDocumentLocation,
                  QName serviceName,
                  Properties properties)
                             throws ServiceException
        Create an instance of the generated service implementation class for a given service, if available. The service is uniquely identified by the wsdlDocumentLocation and serviceName arguments. An implementation may use the provided properties to help locate the generated implementation class. If no such class is present, a ServiceException will be thrown.
        Parameters:
        wsdlDocumentLocation - URL for the WSDL document location for the service or null
        serviceName - Qualified name for the service
        properties - A set of implementation-specific properties to help locate the generated service implementation class
        Throws:
        ServiceException - If there is any error while creating the specified service, including the case where a generated service implementation class cannot be located
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Stub (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc

Interface Stub

  • public interface Stub
    The interface javax.xml.rpc.Stub is the common base interface for the stub classes. All generated stub classes are required to implement the javax.xml.rpc.Stub interface. An instance of a stub class represents a client side proxy or stub instance for the target service endpoint.

    The javax.xml.rpc.Stub interface provides an extensible property mechanism for the dynamic configuration of a stub instance.

    Version:
    0.1
    Author:
    Rahul Sharma
    See Also:
    Service

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ENDPOINT_ADDRESS_PROPERTY
      Standard property: Target service endpoint address.
      static String PASSWORD_PROPERTY
      Standard property: Password for authentication.
      static String SESSION_MAINTAIN_PROPERTY
      Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.
      static String USERNAME_PROPERTY
      Standard property: User name for authentication.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object _getProperty(String name)
      Gets the value of a specific configuration property.
      Iterator _getPropertyNames()
      Returns an Iterato view of the names of the properties that can be configured on this stub instance.
      void _setProperty(String name, Object value)
      Sets the name and value of a configuration property for this Stub instance.

    • Field Detail

      • USERNAME_PROPERTY

        static final String USERNAME_PROPERTY
        Standard property: User name for authentication.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • PASSWORD_PROPERTY

        static final String PASSWORD_PROPERTY
        Standard property: Password for authentication.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • ENDPOINT_ADDRESS_PROPERTY

        static final String ENDPOINT_ADDRESS_PROPERTY
        Standard property: Target service endpoint address. The URI scheme for the endpoint address specification must correspond to the protocol/transport binding for this stub class.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • SESSION_MAINTAIN_PROPERTY

        static final String SESSION_MAINTAIN_PROPERTY
        Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint. If this property is set to true, the service client indicates that it wants the session to be maintained. If set to false, the session is not maintained. The default value for this property is false.

        Type: java.lang.Boolean

        See Also:
        Constant Field Values

    • Method Detail

      • _setProperty

        void _setProperty(String name,
                Object value)
        Sets the name and value of a configuration property for this Stub instance. If the Stub instances contains a value of the same property, the old value is replaced.

        Note that the _setProperty method may not perform validity check on a configured property value. An example is the standard property for the target service endpoint address that is not checked for validity in the _setProperty method. In this case, stub configuration errors are detected at the remote method invocation.

        Parameters:
        name - Name of the configuration property
        value - Value of the property
        Throws:
        JAXRPCException -
        • If an optional standard property name is specified, however this Stub implementation class does not support the configuration of this property.
        • If an invalid or unsupported property name is specified or if a value of mismatched property type is passed.
        • If there is any error in the configuration of a valid property.

      • _getProperty

        Object _getProperty(String name)
        Gets the value of a specific configuration property.
        Parameters:
        name - Name of the property whose value is to be retrieved
        Returns:
        Value of the configuration property
        Throws:
        JAXRPCException - if an invalid or unsupported property name is passed.

      • _getPropertyNames

        Iterator _getPropertyNames()
        Returns an Iterato view of the names of the properties that can be configured on this stub instance.
        Returns:
        Iterator for the property names of the type java.lang.String
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.rpc (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.rpc

  • Packages that use javax.xml.rpc
    Package Description
    javax.xml.rpc
    This package contains the core JAX-RPC APIs for the client programming model.
    javax.xml.rpc.server
    This package defines APIs for the servlet based JAX-RPC endpoint model.
  • Classes in javax.xml.rpc used by javax.xml.rpc
    Class and Description
    Call
    The javax.xml.rpc.Call interface provides support for the dynamic invocation of a service endpoint.
    ParameterMode
    The javax.xml.rpc.ParameterMode is a type-safe enumeration for parameter mode.
    Service
    Service class acts as a factory of the following: Dynamic proxy for the target service endpoint.
    ServiceException
    The javax.xml.rpc.ServiceException is thrown from the methods in the javax.xml.rpc.Service interface and ServiceFactory class.
    ServiceFactory
    The javax.xml.rpc.ServiceFactory is an abstract class that provides a factory for the creation of instances of the type javax.xml.rpc.Service.
  • Classes in javax.xml.rpc used by javax.xml.rpc.server
    Class and Description
    ServiceException
    The javax.xml.rpc.ServiceException is thrown from the methods in the javax.xml.rpc.Service interface and ServiceFactory class.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.JAXRPCException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.JAXRPCException

No usage of javax.xml.rpc.JAXRPCException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.NamespaceConstants (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.NamespaceConstants

No usage of javax.xml.rpc.NamespaceConstants
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.ParameterMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.ParameterMode

  • Packages that use ParameterMode
    Package Description
    javax.xml.rpc
    This package contains the core JAX-RPC APIs for the client programming model.

    • Uses of ParameterMode in javax.xml.rpc

      Fields in javax.xml.rpc declared as ParameterMode
      Modifier and Type Field and Description
      static ParameterMode ParameterMode.IN
      IN mode for parameter passing
      static ParameterMode ParameterMode.INOUT
      INOUT mode for parameter passing
      static ParameterMode ParameterMode.OUT
      OUT mode for parameter passing
      Methods in javax.xml.rpc with parameters of type ParameterMode
      Modifier and Type Method and Description
      void Call.addParameter(String paramName, QName xmlType, Class javaType, ParameterMode parameterMode)
      Adds a parameter type and mode for a specific operation.
      void Call.addParameter(String paramName, QName xmlType, ParameterMode parameterMode)
      Adds a parameter type and mode for a specific operation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.ServiceException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.ServiceException

  • Packages that use ServiceException
    Package Description
    javax.xml.rpc
    This package contains the core JAX-RPC APIs for the client programming model.
    javax.xml.rpc.server
    This package defines APIs for the servlet based JAX-RPC endpoint model.

    • Uses of ServiceException in javax.xml.rpc

      Methods in javax.xml.rpc that throw ServiceException
      Modifier and Type Method and Description
      Call Service.createCall()
      Creates a Call object not associated with specific operation or target service endpoint.
      Call Service.createCall(QName portName)
      Creates a Call instance.
      Call Service.createCall(QName portName, QName operationName)
      Creates a Call instance.
      Call Service.createCall(QName portName, String operationName)
      Creates a Call instance.
      abstract Service ServiceFactory.createService(QName serviceName)
      Create a Service instance.
      abstract Service ServiceFactory.createService(URL wsdlDocumentLocation, QName serviceName)
      Create a Service instance.
      Call[] Service.getCalls(QName portName)
      Gets an array of preconfigured Call objects for invoking operations on the specified port.
      Remote Service.getPort(Class serviceEndpointInterface)
      The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
      Remote Service.getPort(QName portName, Class serviceEndpointInterface)
      The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
      Iterator Service.getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      abstract Service ServiceFactory.loadService(Class serviceInterface)
      Create an instance of the generated service implementation class for a given service interface, if available.
      abstract Service ServiceFactory.loadService(URL wsdlDocumentLocation, Class serviceInterface, Properties properties)
      Create an instance of the generated service implementation class for a given service interface, if available.
      abstract Service ServiceFactory.loadService(URL wsdlDocumentLocation, QName serviceName, Properties properties)
      Create an instance of the generated service implementation class for a given service, if available.
      static ServiceFactory ServiceFactory.newInstance()
      Gets an instance of the ServiceFactory

    • Uses of ServiceException in javax.xml.rpc.server

      Methods in javax.xml.rpc.server that throw ServiceException
      Modifier and Type Method and Description
      void ServiceLifecycle.init(Object context)
      Used for initialization of a service endpoint.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.ServiceFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.ServiceFactory

  • Packages that use ServiceFactory
    Package Description
    javax.xml.rpc
    This package contains the core JAX-RPC APIs for the client programming model.

    • Uses of ServiceFactory in javax.xml.rpc

      Methods in javax.xml.rpc that return ServiceFactory
      Modifier and Type Method and Description
      static ServiceFactory ServiceFactory.newInstance()
      Gets an instance of the ServiceFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.Call (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.Call

  • Packages that use Call
    Package Description
    javax.xml.rpc
    This package contains the core JAX-RPC APIs for the client programming model.

    • Uses of Call in javax.xml.rpc

      Methods in javax.xml.rpc that return Call
      Modifier and Type Method and Description
      Call Service.createCall()
      Creates a Call object not associated with specific operation or target service endpoint.
      Call Service.createCall(QName portName)
      Creates a Call instance.
      Call Service.createCall(QName portName, QName operationName)
      Creates a Call instance.
      Call Service.createCall(QName portName, String operationName)
      Creates a Call instance.
      Call[] Service.getCalls(QName portName)
      Gets an array of preconfigured Call objects for invoking operations on the specified port.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.Service (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.Service

  • Packages that use Service
    Package Description
    javax.xml.rpc
    This package contains the core JAX-RPC APIs for the client programming model.

    • Uses of Service in javax.xml.rpc

      Methods in javax.xml.rpc that return Service
      Modifier and Type Method and Description
      abstract Service ServiceFactory.createService(QName serviceName)
      Create a Service instance.
      abstract Service ServiceFactory.createService(URL wsdlDocumentLocation, QName serviceName)
      Create a Service instance.
      abstract Service ServiceFactory.loadService(Class serviceInterface)
      Create an instance of the generated service implementation class for a given service interface, if available.
      abstract Service ServiceFactory.loadService(URL wsdlDocumentLocation, Class serviceInterface, Properties properties)
      Create an instance of the generated service implementation class for a given service interface, if available.
      abstract Service ServiceFactory.loadService(URL wsdlDocumentLocation, QName serviceName, Properties properties)
      Create an instance of the generated service implementation class for a given service, if available.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.Stub (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.Stub

No usage of javax.xml.rpc.Stub
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


DeserializationContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.encoding

Interface DeserializationContext

  • public interface DeserializationContext
    The javax.xml.rpc.encoding.DeserializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner. A deserializer uses this interface to access and maintain context information during the deserialization..
    Version:
    1.0
    Author:
    Rahul Sharma
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Deserializer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.encoding

Interface Deserializer

  • All Superinterfaces:
    Serializable

    public interface Deserializer
extends Serializable
    The javax.xml.rpc.encoding.Deserializer interface defines a base interface for deserializers. A Deserializer converts an XML representation to a Java object using a specific XML processing mechanism and based on the specified type mapping and encoding style.
    Version:
    1.0
    Author:
    Rahul Sharma

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getMechanismType()
      Gets the type of the XML processing mechanism and representation used by this Deserializer.

    • Method Detail

      • getMechanismType

        String getMechanismType()
        Gets the type of the XML processing mechanism and representation used by this Deserializer.
        Returns:
        XML processing mechanism type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DeserializerFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.encoding

Interface DeserializerFactory

  • All Superinterfaces:
    Serializable

    public interface DeserializerFactory
extends Serializable
    The javax.xml.rpc.encoding.DeserializerFactory is a factory of deserializers. A DeserializerFactory is registered with a TypeMapping instance as part of the TypeMappingRegistry.
    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    Serializer

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Deserializer getDeserializerAs(String mechanismType)
      Returns a Deserializer for the specified XML processing mechanism type.
      Iterator getSupportedMechanismTypes()
      Returns a list of all XML processing mechanism types supported by this DeserializerFactory.

    • Method Detail

      • getDeserializerAs

        Deserializer getDeserializerAs(String mechanismType)
        Returns a Deserializer for the specified XML processing mechanism type.
        Parameters:
        mechanismType - XML processing mechanism type [TBD: definition of valid constants]
        Throws:
        JAXRPCException - If DeserializerFactory does not support the specified XML processing mechanism

      • getSupportedMechanismTypes

        Iterator getSupportedMechanismTypes()
        Returns a list of all XML processing mechanism types supported by this DeserializerFactory.
        Returns:
        List of unique identifiers for the supported XML processing mechanism types
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.rpc.encoding (Java(TM) EE 7 Specification APIs)

javax.xml.rpc.encoding

Interfaces

  • DeserializationContext
  • Deserializer
  • DeserializerFactory
  • SerializationContext
  • Serializer
  • SerializerFactory
  • TypeMapping
  • TypeMappingRegistry

Classes

  • XMLType


javax.xml.rpc.encoding (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.rpc.encoding

This package defines APIs for the extensible type mapping framework.

See: Description

  • Interface Summary
    Interface Description
    DeserializationContext
    The javax.xml.rpc.encoding.DeserializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner.
    Deserializer
    The javax.xml.rpc.encoding.Deserializer interface defines a base interface for deserializers.
    DeserializerFactory
    The javax.xml.rpc.encoding.DeserializerFactory is a factory of deserializers.
    SerializationContext
    The javax.xml.rpc.encoding.SerializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner.
    Serializer
    The javax.xml.rpc.encoding.Serializer interface defines the base interface for serializers.
    SerializerFactory
    The javax.xml.rpc.encoding.SerializerFactory is a factory of the serializers.
    TypeMapping
    The javax.xml.rpc.encoding.TypeMapping is the base interface for the representation of a type mapping.
    TypeMappingRegistry
    The interface javax.xml.rpc.encoding.TypeMappingRegistry defines a registry of TypeMapping instances for various encoding styles.
  • Class Summary
    Class Description
    XMLType
    Constants for common XML Schema and SOAP 1.1 types.

Package javax.xml.rpc.encoding Description

This package defines APIs for the extensible type mapping framework.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.rpc.encoding Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.rpc.encoding

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.rpc.encoding.XMLType

Interface Hierarchy

  • javax.xml.rpc.encoding.DeserializationContext
  • java.io.Serializable
    • javax.xml.rpc.encoding.Deserializer
    • javax.xml.rpc.encoding.DeserializerFactory
    • javax.xml.rpc.encoding.Serializer
    • javax.xml.rpc.encoding.SerializerFactory
    • javax.xml.rpc.encoding.TypeMappingRegistry
  • javax.xml.rpc.encoding.SerializationContext
  • javax.xml.rpc.encoding.TypeMapping
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


SerializationContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.encoding

Interface SerializationContext

  • public interface SerializationContext
    The javax.xml.rpc.encoding.SerializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner. A serializer uses the SerializationContext interface during the serialization to get the context information related to the XML processing mechanism and to manage information specific to serialization.
    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    Serializer
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Serializer (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.encoding

Interface Serializer

  • All Superinterfaces:
    Serializable

    public interface Serializer
extends Serializable
    The javax.xml.rpc.encoding.Serializer interface defines the base interface for serializers. A Serializer converts a Java object to an XML representation using a specific XML processing mechanism and based on the specified type mapping and encoding style.
    Version:
    1.0
    Author:
    Rahul Sharma

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getMechanismType()
      Gets the type of the XML processing mechanism and representation used by this Serializer.

    • Method Detail

      • getMechanismType

        String getMechanismType()
        Gets the type of the XML processing mechanism and representation used by this Serializer.
        Returns:
        XML processing mechanism type
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SerializerFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.encoding

Interface SerializerFactory

  • All Superinterfaces:
    Serializable

    public interface SerializerFactory
extends Serializable
    The javax.xml.rpc.encoding.SerializerFactory is a factory of the serializers. A SerializerFactory is registered with a TypeMapping object as part of the TypeMappingRegistry.
    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    Serializer

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Serializer getSerializerAs(String mechanismType)
      Returns a Serializer for the specified XML processing mechanism type.
      Iterator getSupportedMechanismTypes()
      Returns a list of all XML processing mechanism types supported by this SerializerFactory.

    • Method Detail

      • getSerializerAs

        Serializer getSerializerAs(String mechanismType)
        Returns a Serializer for the specified XML processing mechanism type.
        Parameters:
        mechanismType - XML processing mechanism type [TBD: definition of valid constants]
        Throws:
        JAXRPCException - If SerializerFactory does not support the specified XML processing mechanism
        IllegalArgumentException - If an invalid mechanism type is specified.

      • getSupportedMechanismTypes

        Iterator getSupportedMechanismTypes()
        Returns a list of all XML processing mechanism types supported by this SerializerFactory.
        Returns:
        List of unique identifiers for the supported XML processing mechanism types
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TypeMapping (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.encoding

Interface TypeMapping

  • public interface TypeMapping
    The javax.xml.rpc.encoding.TypeMapping is the base interface for the representation of a type mapping. A TypeMapping implementation class may support one or more encoding styles.

    For its supported encoding styles, a TypeMapping instance maintains a set of tuples of the type {Java type, SerializerFactory, DeserializerFactory, XML type}.

    Version:
    1.0
    Author:
    Rahul Sharma

    • Method Summary

      Methods
      Modifier and Type Method and Description
      DeserializerFactory getDeserializer(Class javaType, QName xmlType)
      Gets the DeserializerFactory registered for the specified pair of Java type and XML data type.
      SerializerFactory getSerializer(Class javaType, QName xmlType)
      Gets the SerializerFactory registered for the specified pair of Java type and XML data type.
      String[] getSupportedEncodings()
      Returns the encodingStyle URIs (as String[]) supported by this TypeMapping instance.
      boolean isRegistered(Class javaType, QName xmlType)
      Checks whether or not type mapping between specified XML type and Java type is registered.
      void register(Class javaType, QName xmlType, SerializerFactory sf, DeserializerFactory dsf)
      Registers SerializerFactory and DeserializerFactory for a specific type mapping between an XML type and Java type.
      void removeDeserializer(Class javaType, QName xmlType)
      Removes the DeserializerFactory registered for the specified pair of Java type and XML data type.
      void removeSerializer(Class javaType, QName xmlType)
      Removes the SerializerFactory registered for the specified pair of Java type and XML data type.
      void setSupportedEncodings(String[] encodingStyleURIs)
      Sets the encodingStyle URIs supported by this TypeMapping instance.

    • Method Detail

      • getSupportedEncodings

        String[] getSupportedEncodings()
        Returns the encodingStyle URIs (as String[]) supported by this TypeMapping instance. A TypeMapping that contains only encoding style independent serializers and deserializers returns null from this method.
        Returns:
        Array of encodingStyle URIs for the supported encoding styles

      • setSupportedEncodings

        void setSupportedEncodings(String[] encodingStyleURIs)
        Sets the encodingStyle URIs supported by this TypeMapping instance. A TypeMapping that contains only encoding independent serializers and deserializers requires null as the parameter for this method.
        Parameters:
        encodingStyleURIs - Array of encodingStyle URIs for the supported encoding styles

      • isRegistered

        boolean isRegistered(Class javaType,
                   QName xmlType)
        Checks whether or not type mapping between specified XML type and Java type is registered.
        Parameters:
        javaType - Class of the Java type
        xmlType - Qualified name of the XML data type
        Returns:
        boolean; true if type mapping between the specified XML type and Java type is registered; otherwise false

      • register

        void register(Class javaType,
            QName xmlType,
            SerializerFactory sf,
            DeserializerFactory dsf)
        Registers SerializerFactory and DeserializerFactory for a specific type mapping between an XML type and Java type. This method replaces any existing registered SerializerFactory DeserializerFactory instances.
        Parameters:
        javaType - Class of the Java type
        xmlType - Qualified name of the XML data type
        sf - SerializerFactory
        dsf - DeserializerFactory
        Throws:
        JAXRPCException - If any error during the registration

      • getSerializer

        SerializerFactory getSerializer(Class javaType,
                              QName xmlType)
        Gets the SerializerFactory registered for the specified pair of Java type and XML data type.
        Parameters:
        javaType - Class of the Java type
        xmlType - Qualified name of the XML data type
        Returns:
        Registered SerializerFactory or null if there is no registered factory

      • getDeserializer

        DeserializerFactory getDeserializer(Class javaType,
                                  QName xmlType)
        Gets the DeserializerFactory registered for the specified pair of Java type and XML data type.
        Parameters:
        javaType - Class of the Java type
        xmlType - Qualified name of the XML data type
        Returns:
        Registered DeserializerFactory or null if there is no registered factory

      • removeSerializer

        void removeSerializer(Class javaType,
                    QName xmlType)
        Removes the SerializerFactory registered for the specified pair of Java type and XML data type.
        Throws:
        JAXRPCException - If there is error in removing the registered SerializerFactory

      • removeDeserializer

        void removeDeserializer(Class javaType,
                      QName xmlType)
        Removes the DeserializerFactory registered for the specified pair of Java type and XML data type.
        Throws:
        JAXRPCException - If there is error in removing the registered DeserializerFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TypeMappingRegistry (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.encoding

Interface TypeMappingRegistry

  • All Superinterfaces:
    Serializable

    public interface TypeMappingRegistry
extends Serializable
    The interface javax.xml.rpc.encoding.TypeMappingRegistry defines a registry of TypeMapping instances for various encoding styles.
    Version:
    1.0
    Author:
    Rahul Sharma

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void clear()
      Removes all registered TypeMappings and encodingStyleURIs from this TypeMappingRegistry.
      TypeMapping createTypeMapping()
      Creates a new empty TypeMapping object.
      TypeMapping getDefaultTypeMapping()
      Gets the registered default TypeMapping instance.
      String[] getRegisteredEncodingStyleURIs()
      Returns a list of registered encodingStyle URIs in this TypeMappingRegistry instance.
      TypeMapping getTypeMapping(String encodingStyleURI)
      Returns the registered TypeMapping for the specified encodingStyle URI.
      TypeMapping register(String encodingStyleURI, TypeMapping mapping)
      Registers a TypeMapping instance with the TypeMappingRegistry.
      void registerDefault(TypeMapping mapping)
      Registers the TypeMapping instance that is default for all encoding styles supported by the TypeMappingRegistry.
      boolean removeTypeMapping(TypeMapping mapping)
      Removes a TypeMapping from the TypeMappingRegistry.
      TypeMapping unregisterTypeMapping(String encodingStyleURI)
      Unregisters a TypeMapping instance, if present, from the specified encodingStyleURI.

    • Method Detail

      • register

        TypeMapping register(String encodingStyleURI,
                   TypeMapping mapping)
        Registers a TypeMapping instance with the TypeMappingRegistry. This method replaces any existing registered TypeMapping instance for the specified encodingStyleURI.
        Parameters:
        encodingStyleURI - An encoding style specified as an URI. An example is "http://schemas.xmlsoap.org/soap/encoding/"
        mapping - TypeMapping instance
        Returns:
        Previous TypeMapping associated with the specified encodingStyleURI, or null if there was no TypeMapping associated with the specified encodingStyleURI
        Throws:
        JAXRPCException - If there is an error in the registration of the TypeMapping for the specified encodingStyleURI.

      • registerDefault

        void registerDefault(TypeMapping mapping)
        Registers the TypeMapping instance that is default for all encoding styles supported by the TypeMappingRegistry. A default TypeMapping should include serializers and deserializers that are independent of and usable with any encoding style. Successive invocations of the registerDefault method replace any existing default TypeMapping instance.

        If the default TypeMapping is registered, any other TypeMapping instances registered through the TypeMappingRegistry.register method (for a set of encodingStyle URIs) override the default TypeMapping.

        Parameters:
        mapping - TypeMapping instance
        Throws:
        JAXRPCException - If there is an error in the registration of the default TypeMapping

      • getDefaultTypeMapping

        TypeMapping getDefaultTypeMapping()
        Gets the registered default TypeMapping instance. This method returns null if there is no registered default TypeMapping in the registry.
        Returns:
        The registered default TypeMapping instance or null

      • getRegisteredEncodingStyleURIs

        String[] getRegisteredEncodingStyleURIs()
        Returns a list of registered encodingStyle URIs in this TypeMappingRegistry instance.
        Returns:
        Array of the registered encodingStyle URIs

      • getTypeMapping

        TypeMapping getTypeMapping(String encodingStyleURI)
        Returns the registered TypeMapping for the specified encodingStyle URI. If there is no registered TypeMapping for the specified encodingStyleURI, this method returns null.
        Parameters:
        encodingStyleURI - Encoding style specified as an URI
        Returns:
        TypeMapping for the specified encodingStyleURI or null

      • createTypeMapping

        TypeMapping createTypeMapping()
        Creates a new empty TypeMapping object.
        Returns:
        TypeMapping instance

      • unregisterTypeMapping

        TypeMapping unregisterTypeMapping(String encodingStyleURI)
        Unregisters a TypeMapping instance, if present, from the specified encodingStyleURI.
        Parameters:
        encodingStyleURI - Encoding style specified as an URI
        Returns:
        TypeMapping instance that has been unregistered or null if there was no TypeMapping registered for the specified encodingStyleURI

      • removeTypeMapping

        boolean removeTypeMapping(TypeMapping mapping)
        Removes a TypeMapping from the TypeMappingRegistry. A TypeMapping is associated with 1 or more encodingStyleURIs. This method unregisters the specified TypeMapping instance from all associated encodingStyleURIs and then removes this TypeMapping instance from the registry.
        Parameters:
        mapping - TypeMapping to be removed
        Returns:
        true if specified TypeMapping is removed from the TypeMappingRegistry; false if the specified TypeMapping was not in the TypeMappingRegistry

      • clear

        void clear()
        Removes all registered TypeMappings and encodingStyleURIs from this TypeMappingRegistry.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.rpc.encoding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.rpc.encoding

  • Packages that use javax.xml.rpc.encoding
    Package Description
    javax.xml.rpc
    This package contains the core JAX-RPC APIs for the client programming model.
    javax.xml.rpc.encoding
    This package defines APIs for the extensible type mapping framework.
  • Classes in javax.xml.rpc.encoding used by javax.xml.rpc
    Class and Description
    TypeMappingRegistry
    The interface javax.xml.rpc.encoding.TypeMappingRegistry defines a registry of TypeMapping instances for various encoding styles.
  • Classes in javax.xml.rpc.encoding used by javax.xml.rpc.encoding
    Class and Description
    Deserializer
    The javax.xml.rpc.encoding.Deserializer interface defines a base interface for deserializers.
    DeserializerFactory
    The javax.xml.rpc.encoding.DeserializerFactory is a factory of deserializers.
    Serializer
    The javax.xml.rpc.encoding.Serializer interface defines the base interface for serializers.
    SerializerFactory
    The javax.xml.rpc.encoding.SerializerFactory is a factory of the serializers.
    TypeMapping
    The javax.xml.rpc.encoding.TypeMapping is the base interface for the representation of a type mapping.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


XMLType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.encoding

Class XMLType

  • java.lang.Object
    • javax.xml.rpc.encoding.XMLType

  • public class XMLType
extends Object
    Constants for common XML Schema and SOAP 1.1 types.
    Version:
    1.0
    Author:
    Rahul Sharma

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static QName SOAP_ARRAY
      The name of the SOAP-ENC:Array type.
      static QName SOAP_BASE64
      The name of the SOAP-ENC:base64 type.
      static QName SOAP_BOOLEAN
      The name of the SOAP-ENC:boolean type.
      static QName SOAP_BYTE
      The name of the SOAP-ENC:byte type.
      static QName SOAP_DOUBLE
      The name of the SOAP-ENC:double type.
      static QName SOAP_FLOAT
      The name of the SOAP-ENC:float type.
      static QName SOAP_INT
      The name of the SOAP-ENC:int type.
      static QName SOAP_LONG
      The name of the SOAP-ENC:long type.
      static QName SOAP_SHORT
      The name of the SOAP-ENC:short type.
      static QName SOAP_STRING
      The name of the SOAP-ENC:string type.
      static QName XSD_BASE64
      The name of the xsd:base64Binary type.
      static QName XSD_BOOLEAN
      The name of the xsd:boolean type.
      static QName XSD_BYTE
      The name of the xsd:byte type.
      static QName XSD_DATETIME
      The name of the xsd:dateTime type.
      static QName XSD_DECIMAL
      The name of the xsd:decimal type.
      static QName XSD_DOUBLE
      The name of the xsd:double type.
      static QName XSD_FLOAT
      The name of the xsd:float type.
      static QName XSD_HEXBINARY
      The name of the xsd:hexBinary type.
      static QName XSD_INT
      The name of the xsd:int type.
      static QName XSD_INTEGER
      The name of the xsd:integer type.
      static QName XSD_LONG
      The name of the xsd:long type.
      static QName XSD_QNAME
      The name of the xsd:QName type.
      static QName XSD_SHORT
      The name of the xsd:short type.
      static QName XSD_STRING
      The name of the xsd:string type.

    • Constructor Summary

      Constructors
      Constructor and Description
      XMLType()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • XSD_STRING

        public static final QName XSD_STRING
        The name of the xsd:string type.

      • XSD_FLOAT

        public static final QName XSD_FLOAT
        The name of the xsd:float type.

      • XSD_BOOLEAN

        public static final QName XSD_BOOLEAN
        The name of the xsd:boolean type.

      • XSD_DOUBLE

        public static final QName XSD_DOUBLE
        The name of the xsd:double type.

      • XSD_INTEGER

        public static final QName XSD_INTEGER
        The name of the xsd:integer type.

      • XSD_INT

        public static final QName XSD_INT
        The name of the xsd:int type.

      • XSD_LONG

        public static final QName XSD_LONG
        The name of the xsd:long type.

      • XSD_SHORT

        public static final QName XSD_SHORT
        The name of the xsd:short type.

      • XSD_DECIMAL

        public static final QName XSD_DECIMAL
        The name of the xsd:decimal type.

      • XSD_BASE64

        public static final QName XSD_BASE64
        The name of the xsd:base64Binary type.

      • XSD_HEXBINARY

        public static final QName XSD_HEXBINARY
        The name of the xsd:hexBinary type.

      • XSD_BYTE

        public static final QName XSD_BYTE
        The name of the xsd:byte type.

      • XSD_DATETIME

        public static final QName XSD_DATETIME
        The name of the xsd:dateTime type.

      • XSD_QNAME

        public static final QName XSD_QNAME
        The name of the xsd:QName type.

      • SOAP_STRING

        public static final QName SOAP_STRING
        The name of the SOAP-ENC:string type.

      • SOAP_BOOLEAN

        public static final QName SOAP_BOOLEAN
        The name of the SOAP-ENC:boolean type.

      • SOAP_DOUBLE

        public static final QName SOAP_DOUBLE
        The name of the SOAP-ENC:double type.

      • SOAP_BASE64

        public static final QName SOAP_BASE64
        The name of the SOAP-ENC:base64 type.

      • SOAP_FLOAT

        public static final QName SOAP_FLOAT
        The name of the SOAP-ENC:float type.

      • SOAP_INT

        public static final QName SOAP_INT
        The name of the SOAP-ENC:int type.

      • SOAP_LONG

        public static final QName SOAP_LONG
        The name of the SOAP-ENC:long type.

      • SOAP_SHORT

        public static final QName SOAP_SHORT
        The name of the SOAP-ENC:short type.

      • SOAP_BYTE

        public static final QName SOAP_BYTE
        The name of the SOAP-ENC:byte type.

      • SOAP_ARRAY

        public static final QName SOAP_ARRAY
        The name of the SOAP-ENC:Array type.

    • Constructor Detail

      • XMLType

        public XMLType()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.xml.rpc.encoding.XMLType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.encoding.XMLType

No usage of javax.xml.rpc.encoding.XMLType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.encoding.DeserializationContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.encoding.DeserializationContext

No usage of javax.xml.rpc.encoding.DeserializationContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.encoding.Deserializer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.encoding.Deserializer

  • Packages that use Deserializer
    Package Description
    javax.xml.rpc.encoding
    This package defines APIs for the extensible type mapping framework.

    • Uses of Deserializer in javax.xml.rpc.encoding

      Methods in javax.xml.rpc.encoding that return Deserializer
      Modifier and Type Method and Description
      Deserializer DeserializerFactory.getDeserializerAs(String mechanismType)
      Returns a Deserializer for the specified XML processing mechanism type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.encoding.DeserializerFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.encoding.DeserializerFactory

  • Packages that use DeserializerFactory
    Package Description
    javax.xml.rpc.encoding
    This package defines APIs for the extensible type mapping framework.

    • Uses of DeserializerFactory in javax.xml.rpc.encoding

      Methods in javax.xml.rpc.encoding that return DeserializerFactory
      Modifier and Type Method and Description
      DeserializerFactory TypeMapping.getDeserializer(Class javaType, QName xmlType)
      Gets the DeserializerFactory registered for the specified pair of Java type and XML data type.
      Methods in javax.xml.rpc.encoding with parameters of type DeserializerFactory
      Modifier and Type Method and Description
      void TypeMapping.register(Class javaType, QName xmlType, SerializerFactory sf, DeserializerFactory dsf)
      Registers SerializerFactory and DeserializerFactory for a specific type mapping between an XML type and Java type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.encoding.SerializationContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.encoding.SerializationContext

No usage of javax.xml.rpc.encoding.SerializationContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.encoding.Serializer (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.encoding.Serializer

  • Packages that use Serializer
    Package Description
    javax.xml.rpc.encoding
    This package defines APIs for the extensible type mapping framework.

    • Uses of Serializer in javax.xml.rpc.encoding

      Methods in javax.xml.rpc.encoding that return Serializer
      Modifier and Type Method and Description
      Serializer SerializerFactory.getSerializerAs(String mechanismType)
      Returns a Serializer for the specified XML processing mechanism type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.encoding.SerializerFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.encoding.SerializerFactory

  • Packages that use SerializerFactory
    Package Description
    javax.xml.rpc.encoding
    This package defines APIs for the extensible type mapping framework.

    • Uses of SerializerFactory in javax.xml.rpc.encoding

      Methods in javax.xml.rpc.encoding that return SerializerFactory
      Modifier and Type Method and Description
      SerializerFactory TypeMapping.getSerializer(Class javaType, QName xmlType)
      Gets the SerializerFactory registered for the specified pair of Java type and XML data type.
      Methods in javax.xml.rpc.encoding with parameters of type SerializerFactory
      Modifier and Type Method and Description
      void TypeMapping.register(Class javaType, QName xmlType, SerializerFactory sf, DeserializerFactory dsf)
      Registers SerializerFactory and DeserializerFactory for a specific type mapping between an XML type and Java type.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.encoding.TypeMapping (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.encoding.TypeMapping

  • Packages that use TypeMapping
    Package Description
    javax.xml.rpc.encoding
    This package defines APIs for the extensible type mapping framework.

    • Uses of TypeMapping in javax.xml.rpc.encoding

      Methods in javax.xml.rpc.encoding that return TypeMapping
      Modifier and Type Method and Description
      TypeMapping TypeMappingRegistry.createTypeMapping()
      Creates a new empty TypeMapping object.
      TypeMapping TypeMappingRegistry.getDefaultTypeMapping()
      Gets the registered default TypeMapping instance.
      TypeMapping TypeMappingRegistry.getTypeMapping(String encodingStyleURI)
      Returns the registered TypeMapping for the specified encodingStyle URI.
      TypeMapping TypeMappingRegistry.register(String encodingStyleURI, TypeMapping mapping)
      Registers a TypeMapping instance with the TypeMappingRegistry.
      TypeMapping TypeMappingRegistry.unregisterTypeMapping(String encodingStyleURI)
      Unregisters a TypeMapping instance, if present, from the specified encodingStyleURI.
      Methods in javax.xml.rpc.encoding with parameters of type TypeMapping
      Modifier and Type Method and Description
      TypeMapping TypeMappingRegistry.register(String encodingStyleURI, TypeMapping mapping)
      Registers a TypeMapping instance with the TypeMappingRegistry.
      void TypeMappingRegistry.registerDefault(TypeMapping mapping)
      Registers the TypeMapping instance that is default for all encoding styles supported by the TypeMappingRegistry.
      boolean TypeMappingRegistry.removeTypeMapping(TypeMapping mapping)
      Removes a TypeMapping from the TypeMappingRegistry.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.encoding.TypeMappingRegistry (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.encoding.TypeMappingRegistry

  • Packages that use TypeMappingRegistry
    Package Description
    javax.xml.rpc
    This package contains the core JAX-RPC APIs for the client programming model.

    • Uses of TypeMappingRegistry in javax.xml.rpc

      Methods in javax.xml.rpc that return TypeMappingRegistry
      Modifier and Type Method and Description
      TypeMappingRegistry Service.getTypeMappingRegistry()
      Gets the TypeMappingRegistry for this Service object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


GenericHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.handler

Class GenericHandler

  • java.lang.Object
    • javax.xml.rpc.handler.GenericHandler
  • All Implemented Interfaces:
    Handler

    public abstract class GenericHandler
extends Object
implements Handler
    The javax.xml.rpc.handler.GenericHandler class implements the Handler interface. SOAP Message Handler developers should typically subclass GenericHandler class unless the Handler class needs another class as a superclass.

    The GenericHandler class is a convenience abstract class that makes writing Handlers easy. This class provides default implementations of the lifecycle methods init and destroy and also different handle methods. A Handler developer should only override methods that it needs to specialize as part of the derived Handler implementation class.

    Version:
    1.0
    Author:
    Rahul Sharma

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected GenericHandler()
      Default constructor

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      The destroy method indicates the end of lifecycle for a Handler instance.
      abstract QName[] getHeaders()
      Gets the header blocks processed by this Handler instance.
      boolean handleFault(MessageContext context)
      The handleFault method processes the SOAP faults based on the SOAP message processing model.
      boolean handleRequest(MessageContext context)
      The handleRequest method processes the request SOAP message.
      boolean handleResponse(MessageContext context)
      The handleResponse method processes the response message.
      void init(HandlerInfo config)
      The init method to enable the Handler instance to initialize itself.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • GenericHandler

        protected GenericHandler()
        Default constructor

    • Method Detail

      • handleRequest

        public boolean handleRequest(MessageContext context)
        The handleRequest method processes the request SOAP message. The default implementation of this method returns true. This indicates that the handler chain should continue processing of the request SOAP message. This method should be overridden if the derived Handler class needs to specialize implementation of this method.
        Specified by:
        handleRequest in interface Handler
        Parameters:
        context - MessageContext parameter provides access to the request message.
        Returns:
        boolean Indicates the processing mode
        • Return true to indicate continued processing of the request handler chain. The HandlerChain takes the responsibility of invoking the next entity. The next entity may be the next handler in the HandlerChain or if this handler is the last handler in the chain, the next entity is the service endpoint object.
        • Return false to indicate blocking of the request handler chain. In this case, further processing of the request handler chain is blocked and the target service endpoint is not dispatched. The JAX-RPC runtime system takes the responsibility of invoking the response handler chain next with the SOAPMessageContext. The Handler implementation class has the the responsibility of setting the appropriate response SOAP message in either handleRequest and/or handleResponse method. In the default processing model, the response handler chain starts processing from the same Handler instance (that returned false) and goes backward in the execution sequence.
        See Also:
        Handler.handleRequest(javax.xml.rpc.handler.MessageContext)

      • handleResponse

        public boolean handleResponse(MessageContext context)
        The handleResponse method processes the response message. The default implementation of this method returns true. This indicates that the handler chain should continue processing of the response SOAP message. This method should be overridden if the derived Handler class needs to specialize implementation of this method.
        Specified by:
        handleResponse in interface Handler
        Parameters:
        context - MessageContext parameter provides access to the response SOAP message
        Returns:
        boolean Indicates the processing mode
        • Return true to indicate continued processing ofthe response handler chain. The HandlerChain invokes the handleResponse method on the next Handler in the handler chain.
        • Return false to indicate blocking of the response handler chain. In this case, no other response handlers in the handler chain are invoked.
        See Also:
        Handler.handleResponse(javax.xml.rpc.handler.MessageContext)

      • handleFault

        public boolean handleFault(MessageContext context)
        The handleFault method processes the SOAP faults based on the SOAP message processing model. The default implementation of this method returns true. This indicates that the handler chain should continue processing of the SOAP fault. This method should be overridden if the derived Handler class needs to specialize implementation of this method.
        Specified by:
        handleFault in interface Handler
        Parameters:
        context - MessageContext parameter provides access to the SOAP message
        Returns:
        boolean Indicates the processing mode
        • Return true to indicate continued processing of SOAP Fault. The HandlerChain invokes the handleFault method on the next Handler in the handler chain.
        • Return false to indicate end of the SOAP fault processing. In this case, no other handlers in the handler chain are invoked.
        See Also:
        Handler.handleFault(javax.xml.rpc.handler.MessageContext)

      • init

        public void init(HandlerInfo config)
        The init method to enable the Handler instance to initialize itself. This method should be overridden if the derived Handler class needs to specialize implementation of this method.
        Specified by:
        init in interface Handler
        Parameters:
        config - Configuration for the initialization of this handler
        See Also:
        Handler.init(javax.xml.rpc.handler.HandlerInfo)

      • destroy

        public void destroy()
        The destroy method indicates the end of lifecycle for a Handler instance. This method should be overridden if the derived Handler class needs to specialize implementation of this method.
        Specified by:
        destroy in interface Handler
        See Also:
        Handler.destroy()

      • getHeaders

        public abstract QName[] getHeaders()
        Gets the header blocks processed by this Handler instance.
        Specified by:
        getHeaders in interface Handler
        Returns:
        Array of QNames of header blocks processed by this handler instance. QName is the qualified name of the outermost element of the Header block.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Handler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.handler

Interface Handler

  • All Known Implementing Classes:
    GenericHandler

    public interface Handler
    The javax.xml.rpc.handler.Handler interface is required to be implemented by a SOAP message handler. The handleRequest, handleResponse and handleFault methods for a SOAP message handler get access to the SOAPMessage from the SOAPMessageContext. The implementation of these methods can modify the SOAPMessage including the headers and body elements.
    Version:
    1.0
    Author:
    Rahul Sharma

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      The destroy method indicates the end of lifecycle for a Handler instance.
      QName[] getHeaders()
      Gets the header blocks that can be processed by this Handler instance.
      boolean handleFault(MessageContext context)
      The handleFault method processes the SOAP faults based on the SOAP message processing model.
      boolean handleRequest(MessageContext context)
      The handleRequest method processes the request message.
      boolean handleResponse(MessageContext context)
      The handleResponse method processes the response SOAP message.
      void init(HandlerInfo config)
      The init method enables the Handler instance to initialize itself.

    • Method Detail

      • handleRequest

        boolean handleRequest(MessageContext context)
        The handleRequest method processes the request message.
        Parameters:
        context - MessageContext parameter provides access to the request message.
        Returns:
        boolean Indicates the processing mode
        • Return true to indicate continued processing of the request handler chain. The HandlerChain takes the responsibility of invoking the next entity. The next entity may be the next handler in the HandlerChain or if this handler is the last handler in the chain, the next entity is the service endpoint object.
        • Return false to indicate blocking of the request handler chain. In this case, further processing of the request handler chain is blocked and the target service endpoint is not dispatched. The JAX-RPC runtime system takes the responsibility of invoking the response handler chain next with the SOAPMessageContext. The Handler implementation class has the the responsibility of setting the appropriate response SOAP message in either handleRequest and/or handleResponse method. In the default processing model, the response handler chain starts processing from the same Handler instance (that returned false) and goes backward in the execution sequence.
        Throws:
        JAXRPCException - This exception indicates handler specific runtime error. If JAXRPCException is thrown by a handleRequest method, the HandlerChain terminates the further processing of this handler chain. On the server side, the HandlerChain generates a SOAP fault that indicates that the message could not be processed for reasons not directly attributable to the contents of the message itself but rather to a runtime error during the processing of the message. On the client side, the exception is propagated to the client code
        SOAPFaultException - This indicates a SOAP fault. The Handler implementation class has the the responsibility of setting the SOAP fault in the SOAP message in either handleRequest and/or handleFault method. If SOAPFaultException is thrown by a server-side request handler's handleRequest method, the HandlerChain terminates the further processing of the request handlers in this handler chain and invokes the handleFault method on the HandlerChain with the SOAP message context. Next, the HandlerChain invokes the handleFault method on handlers registered in the handler chain, beginning with the Handler instance that threw the exception and going backward in execution. The client-side request handler's handleRequest method should not throw the SOAPFaultException.

      • handleResponse

        boolean handleResponse(MessageContext context)
        The handleResponse method processes the response SOAP message.
        Parameters:
        context - MessageContext parameter provides access to the response SOAP message
        Returns:
        boolean Indicates the processing mode
        • Return true to indicate continued processing ofthe response handler chain. The HandlerChain invokes the handleResponse method on the next Handler in the handler chain.
        • Return false to indicate blocking of the response handler chain. In this case, no other response handlers in the handler chain are invoked.
        Throws:
        JAXRPCException - Indicates handler specific runtime error. If JAXRPCException is thrown by a handleResponse method, the HandlerChain terminates the further processing of this handler chain. On the server side, the HandlerChain generates a SOAP fault that indicates that the message could not be processed for reasons not directly attributable to the contents of the message itself but rather to a runtime error during the processing of the message. On the client side, the runtime exception is propagated to the client code.

      • handleFault

        boolean handleFault(MessageContext context)
        The handleFault method processes the SOAP faults based on the SOAP message processing model.
        Parameters:
        context - MessageContext parameter provides access to the SOAP message
        Returns:
        boolean Indicates the processing mode
        • Return true to indicate continued processing of SOAP Fault. The HandlerChain invokes the handleFault method on the next Handler in the handler chain.
        • Return false to indicate end of the SOAP fault processing. In this case, no other handlers in the handler chain are invoked.
        Throws:
        JAXRPCException - Indicates handler specific runtime error. If JAXRPCException is thrown by a handleFault method, the HandlerChain terminates the further processing of this handler chain. On the server side, the HandlerChain generates a SOAP fault that indicates that the message could not be processed for reasons not directly attributable to the contents of the message itself but rather to a runtime error during the processing of the message. On the client side, the JAXRPCException is propagated to the client code.

      • init

        void init(HandlerInfo config)
        The init method enables the Handler instance to initialize itself. The init method passes the handler configuration as a HandlerInfo instance. The HandlerInfo is used to configure the Handler (for example: setup access to an external resource or service) during the initialization.

        In the init method, the Handler class may get access to any resources (for example; access to a logging service or database) and maintain these as part of its instance variables. Note that these instance variables must not have any state specific to the SOAP message processing performed in the various handle method.

        Parameters:
        config - Configuration for the initialization of this handler
        Throws:
        JAXRPCException - If initialization of the handler fails

      • destroy

        void destroy()
        The destroy method indicates the end of lifecycle for a Handler instance. The Handler implementation class should release its resources and perform cleanup in the implementation of the destroy method.
        Throws:
        JAXRPCException - If any error during destroy

      • getHeaders

        QName[] getHeaders()
        Gets the header blocks that can be processed by this Handler instance.
        Returns:
        Array of QNames of header blocks processed by this handler instance. QName is the qualified name of the outermost element of the Header block.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HandlerChain (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.handler

Interface HandlerChain

  • All Superinterfaces:
    Collection, Iterable, List

    public interface HandlerChain
extends List
    The javax.xml.rpc.handler.HandlerChain represents a list of handlers. All elements in the HandlerChain are of the type javax.xml.rpc.handler.Handler.

    An implementation class for the HandlerChain interface abstracts the policy and mechanism for the invocation of the registered handlers.

    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    HandlerChain

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      Indicates the end of lifecycle for a HandlerChain.
      String[] getRoles()
      Gets SOAP actor roles registered for this HandlerChain at this SOAP node.
      boolean handleFault(MessageContext context)
      The handleFault method initiates the SOAP fault processing for this handler chain.
      boolean handleRequest(MessageContext context)
      The handleRequest method initiates the request processing for this handler chain.
      boolean handleResponse(MessageContext context)
      The handleResponse method initiates the response processing for this handler chain.
      void init(Map config)
      Initializes the configuration for a HandlerChain.
      void setRoles(String[] soapActorNames)
      Sets SOAP Actor roles for this HandlerChain.

      • Methods inherited from interface java.util.List

        add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, remove, remove, removeAll, retainAll, set, size, subList, toArray, toArray

    • Method Detail

      • handleRequest

        boolean handleRequest(MessageContext context)
        The handleRequest method initiates the request processing for this handler chain.
        Parameters:
        context - MessageContext parameter provides access to the request SOAP message.
        Returns:
        boolean Returns true if all handlers in chain have been processed. Returns false if a handler in the chain returned false from its handleRequest method.
        Throws:
        JAXRPCException - if any processing error happens
        See Also:
        Handler.handleRequest(javax.xml.rpc.handler.MessageContext)

      • handleResponse

        boolean handleResponse(MessageContext context)
        The handleResponse method initiates the response processing for this handler chain.
        Parameters:
        context - MessageContext parameter provides access to the response SOAP message.
        Returns:
        boolean Returns true if all handlers in chain have been processed. Returns false if a handler in the chain returned false from its handleResponse method.
        Throws:
        JAXRPCException - if any processing error happens
        See Also:
        Handler.handleResponse(javax.xml.rpc.handler.MessageContext)

      • handleFault

        boolean handleFault(MessageContext context)
        The handleFault method initiates the SOAP fault processing for this handler chain.
        Parameters:
        context - MessageContext parameter provides access to the SOAP message.
        Returns:
        boolean Returns true if all handlers in chain have been processed. Returns false if a handler in the chain returned false from its handleFault method.
        Throws:
        JAXRPCException - if any processing error happens
        See Also:
        Handler.handleFault(javax.xml.rpc.handler.MessageContext)

      • init

        void init(Map config)
        Initializes the configuration for a HandlerChain.
        Parameters:
        config - Configuration for the initialization of this handler chain
        Throws:
        JAXRPCException - If any error during initialization

      • destroy

        void destroy()
        Indicates the end of lifecycle for a HandlerChain.
        Throws:
        JAXRPCException - If any error during destroy

      • setRoles

        void setRoles(String[] soapActorNames)
        Sets SOAP Actor roles for this HandlerChain. This specifies the set of roles in which this HandlerChain is to act for the SOAP message processing at this SOAP node. These roles assumed by a HandlerChain must be invariant during the processing of an individual SOAP message through the HandlerChain.

        A HandlerChain always acts in the role of the special SOAP actor next. Refer to the SOAP specification for the URI name for this special SOAP actor. There is no need to set this special role using this method.

        Parameters:
        soapActorNames - URIs for SOAP actor name
        See Also:
        NamespaceConstants

      • getRoles

        String[] getRoles()
        Gets SOAP actor roles registered for this HandlerChain at this SOAP node. The returned array includes the special SOAP actor next.
        Returns:
        String[] SOAP Actor roles as URIs
        See Also:
        NamespaceConstants
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HandlerInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.handler

Class HandlerInfo

  • java.lang.Object
    • javax.xml.rpc.handler.HandlerInfo
  • All Implemented Interfaces:
    Serializable

    public class HandlerInfo
extends Object
implements Serializable
    The javax.xml.rpc.handler.HandlerInfo represents information about a handler in the HandlerChain. A HandlerInfo instance is passed in the Handler.init method to initialize a Handler instance.
    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    HandlerChain, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      HandlerInfo()
      Default constructor
      HandlerInfo(Class handlerClass, Map config, QName[] headers)
      Constructor for HandlerInfo

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Class getHandlerClass()
      Gets the Handler class
      Map getHandlerConfig()
      Gets the Handler configuration
      QName[] getHeaders()
      Gets the header blocks processed by this Handler.
      void setHandlerClass(Class handlerClass)
      Sets the Handler class
      void setHandlerConfig(Map config)
      Sets the Handler configuration as java.util.Map
      void setHeaders(QName[] headers)
      Sets the header blocks processed by this Handler.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HandlerInfo

        public HandlerInfo()
        Default constructor

      • HandlerInfo

        public HandlerInfo(Class handlerClass,
           Map config,
           QName[] headers)
        Constructor for HandlerInfo
        Parameters:
        handlerClass - Java Class for the Handler
        config - Handler Configuration as a java.util.Map
        headers - QNames for the header blocks processed by this Handler. QName is the qualified name of the outermost element of a header block

    • Method Detail

      • setHandlerClass

        public void setHandlerClass(Class handlerClass)
        Sets the Handler class
        Parameters:
        handlerClass - Class for the Handler

      • getHandlerClass

        public Class getHandlerClass()
        Gets the Handler class
        Returns:
        Returns null if no Handler class has been set; otherwise the set handler class

      • setHandlerConfig

        public void setHandlerConfig(Map config)
        Sets the Handler configuration as java.util.Map
        Parameters:
        config - Configuration map

      • getHandlerConfig

        public Map getHandlerConfig()
        Gets the Handler configuration
        Returns:
        Returns empty Map if no configuration map has been set; otherwise returns the set configuration map

      • setHeaders

        public void setHeaders(QName[] headers)
        Sets the header blocks processed by this Handler.
        Parameters:
        headers - QNames of the header blocks. QName is the qualified name of the outermost element of the SOAP header block

      • getHeaders

        public QName[] getHeaders()
        Gets the header blocks processed by this Handler.
        Returns:
        Array of QNames for the header blocks. Returns null if no header blocks have been set using the setHeaders method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HandlerRegistry (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.handler

Interface HandlerRegistry

  • All Superinterfaces:
    Serializable

    public interface HandlerRegistry
extends Serializable
    The javax.xml.rpc.handler.HandlerRegistry provides support for the programmatic configuration of handlers in a HandlerRegistry.

    A handler chain is registered per service endpoint, as indicated by the qualified name of a port. The getHandlerChain returns the handler chain (as a java.util.List) for the specified service endpoint. The returned handler chain is configured using the java.util.List interface. Each element in this list is required to be of the Java type javax.xml.rpc.handler.HandlerInfo.

    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    Service

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List getHandlerChain(QName portName)
      Gets the handler chain for the specified service endpoint.
      void setHandlerChain(QName portName, List chain)
      Sets the handler chain for the specified service endpoint as a java.util.List.

    • Method Detail

      • getHandlerChain

        List getHandlerChain(QName portName)
        Gets the handler chain for the specified service endpoint. The returned List is used to configure this specific handler chain in this HandlerRegistry. Each element in this list is required to be of the Java type javax.xml.rpc.handler.HandlerInfo.
        Parameters:
        portName - Qualified name of the target service endpoint
        Returns:
        java.util.List Handler chain
        Throws:
        IllegalArgumentException - If an invalid portName is specified

      • setHandlerChain

        void setHandlerChain(QName portName,
                   List chain)
        Sets the handler chain for the specified service endpoint as a java.util.List. Each element in this list is required to be of the Java type javax.xml.rpc.handler.HandlerInfo.
        Parameters:
        portName - Qualified name of the target service endpoint
        chain - A List representing configuration for the handler chain
        Throws:
        JAXRPCException - If any error in the configuration of the handler chain
        UnsupportedOperationException - If this set operation is not supported. This is done to avoid any overriding of a pre-configured handler chain.
        IllegalArgumentException - If an invalid portName is specified
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.rpc.handler (Java(TM) EE 7 Specification APIs)

javax.xml.rpc.handler

Interfaces

  • Handler
  • HandlerChain
  • HandlerRegistry
  • MessageContext

Classes

  • GenericHandler
  • HandlerInfo


javax.xml.rpc.handler (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.rpc.handler

This package defines APIs for SOAP Message Handlers

See: Description

  • Interface Summary
    Interface Description
    Handler
    The javax.xml.rpc.handler.Handler interface is required to be implemented by a SOAP message handler.
    HandlerChain
    The javax.xml.rpc.handler.HandlerChain represents a list of handlers.
    HandlerRegistry
    The javax.xml.rpc.handler.HandlerRegistry provides support for the programmatic configuration of handlers in a HandlerRegistry.
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Class Summary
    Class Description
    GenericHandler
    The javax.xml.rpc.handler.GenericHandler class implements the Handler interface.
    HandlerInfo
    The javax.xml.rpc.handler.HandlerInfo represents information about a handler in the HandlerChain.

Package javax.xml.rpc.handler Description

This package defines APIs for SOAP Message Handlers
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.rpc.handler Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.rpc.handler

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.rpc.handler.GenericHandler (implements javax.xml.rpc.handler.Handler)
    • javax.xml.rpc.handler.HandlerInfo (implements java.io.Serializable)

Interface Hierarchy

  • javax.xml.rpc.handler.Handler
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.List<E>
        • javax.xml.rpc.handler.HandlerChain
  • javax.xml.rpc.handler.MessageContext
  • java.io.Serializable
    • javax.xml.rpc.handler.HandlerRegistry
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MessageContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.handler

Interface MessageContext

  • All Known Subinterfaces:
    SOAPMessageContext

    public interface MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

    The MessageContext interface provides methods to manage a property set. MessageContext properties enable handlers in a handler chain to share processing related state.

    Version:
    1.1
    Author:
    Rahul Sharma, Roberto Chinnici
    See Also:
    Handler

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean containsProperty(String name)
      Returns true if the MessageContext contains a property with the specified name.
      Object getProperty(String name)
      Gets the value of a specific property from the MessageContext
      Iterator getPropertyNames()
      Returns an Iterator view of the names of the properties in this MessageContext
      void removeProperty(String name)
      Removes a property (name-value pair) from the MessageContext
      void setProperty(String name, Object value)
      Sets the name and value of a property associated with the MessageContext.

    • Method Detail

      • setProperty

        void setProperty(String name,
               Object value)
        Sets the name and value of a property associated with the MessageContext. If the MessageContext contains a value of the same property, the old value is replaced.
        Parameters:
        name - Name of the property associated with the MessageContext
        value - Value of the property
        Throws:
        IllegalArgumentException - If some aspect of the property is prevents it from being stored in the context
        UnsupportedOperationException - If this method is not supported.

      • getProperty

        Object getProperty(String name)
        Gets the value of a specific property from the MessageContext
        Parameters:
        name - Name of the property whose value is to be retrieved
        Returns:
        Value of the property
        Throws:
        IllegalArgumentException - if an illegal property name is specified

      • removeProperty

        void removeProperty(String name)
        Removes a property (name-value pair) from the MessageContext
        Parameters:
        name - Name of the property to be removed
        Throws:
        IllegalArgumentException - if an illegal property name is specified

      • containsProperty

        boolean containsProperty(String name)
        Returns true if the MessageContext contains a property with the specified name.
        Parameters:
        name - Name of the property whose presense is to be tested
        Returns:
        Returns true if the MessageContext contains the property; otherwise false

      • getPropertyNames

        Iterator getPropertyNames()
        Returns an Iterator view of the names of the properties in this MessageContext
        Returns:
        Iterator for the property names
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.rpc.handler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.rpc.handler

  • Packages that use javax.xml.rpc.handler
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
    javax.xml.rpc
    This package contains the core JAX-RPC APIs for the client programming model.
    javax.xml.rpc.handler
    This package defines APIs for SOAP Message Handlers
    javax.xml.rpc.handler.soap
    This package defines APIs for SOAP Message Handlers
    javax.xml.rpc.server
    This package defines APIs for the servlet based JAX-RPC endpoint model.
  • Classes in javax.xml.rpc.handler used by javax.ejb
    Class and Description
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Classes in javax.xml.rpc.handler used by javax.xml.rpc
    Class and Description
    HandlerRegistry
    The javax.xml.rpc.handler.HandlerRegistry provides support for the programmatic configuration of handlers in a HandlerRegistry.
  • Classes in javax.xml.rpc.handler used by javax.xml.rpc.handler
    Class and Description
    Handler
    The javax.xml.rpc.handler.Handler interface is required to be implemented by a SOAP message handler.
    HandlerInfo
    The javax.xml.rpc.handler.HandlerInfo represents information about a handler in the HandlerChain.
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Classes in javax.xml.rpc.handler used by javax.xml.rpc.handler.soap
    Class and Description
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Classes in javax.xml.rpc.handler used by javax.xml.rpc.server
    Class and Description
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.handler.GenericHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.handler.GenericHandler

No usage of javax.xml.rpc.handler.GenericHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.handler.HandlerInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.handler.HandlerInfo

  • Packages that use HandlerInfo
    Package Description
    javax.xml.rpc.handler
    This package defines APIs for SOAP Message Handlers

    • Uses of HandlerInfo in javax.xml.rpc.handler

      Methods in javax.xml.rpc.handler with parameters of type HandlerInfo
      Modifier and Type Method and Description
      void Handler.init(HandlerInfo config)
      The init method enables the Handler instance to initialize itself.
      void GenericHandler.init(HandlerInfo config)
      The init method to enable the Handler instance to initialize itself.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.handler.Handler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.handler.Handler

  • Packages that use Handler
    Package Description
    javax.xml.rpc.handler
    This package defines APIs for SOAP Message Handlers

    • Uses of Handler in javax.xml.rpc.handler

      Classes in javax.xml.rpc.handler that implement Handler
      Modifier and Type Class and Description
      class  GenericHandler
      The javax.xml.rpc.handler.GenericHandler class implements the Handler interface.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.handler.HandlerChain (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.handler.HandlerChain

No usage of javax.xml.rpc.handler.HandlerChain
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.handler.HandlerRegistry (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.handler.HandlerRegistry

  • Packages that use HandlerRegistry
    Package Description
    javax.xml.rpc
    This package contains the core JAX-RPC APIs for the client programming model.

    • Uses of HandlerRegistry in javax.xml.rpc

      Methods in javax.xml.rpc that return HandlerRegistry
      Modifier and Type Method and Description
      HandlerRegistry Service.getHandlerRegistry()
      Returns the configured HandlerRegistry instance for this Service instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.handler.MessageContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.handler.MessageContext

  • Packages that use MessageContext
    Package Description
    javax.ejb
    Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
    javax.xml.rpc.handler
    This package defines APIs for SOAP Message Handlers
    javax.xml.rpc.handler.soap
    This package defines APIs for SOAP Message Handlers
    javax.xml.rpc.server
    This package defines APIs for the servlet based JAX-RPC endpoint model.

    • Uses of MessageContext in javax.ejb

      Methods in javax.ejb that return MessageContext
      Modifier and Type Method and Description
      MessageContext SessionContext.getMessageContext()
      Obtain a reference to the JAX-RPC MessageContext.

    • Uses of MessageContext in javax.xml.rpc.handler

      Methods in javax.xml.rpc.handler with parameters of type MessageContext
      Modifier and Type Method and Description
      boolean HandlerChain.handleFault(MessageContext context)
      The handleFault method initiates the SOAP fault processing for this handler chain.
      boolean Handler.handleFault(MessageContext context)
      The handleFault method processes the SOAP faults based on the SOAP message processing model.
      boolean GenericHandler.handleFault(MessageContext context)
      The handleFault method processes the SOAP faults based on the SOAP message processing model.
      boolean HandlerChain.handleRequest(MessageContext context)
      The handleRequest method initiates the request processing for this handler chain.
      boolean Handler.handleRequest(MessageContext context)
      The handleRequest method processes the request message.
      boolean GenericHandler.handleRequest(MessageContext context)
      The handleRequest method processes the request SOAP message.
      boolean HandlerChain.handleResponse(MessageContext context)
      The handleResponse method initiates the response processing for this handler chain.
      boolean Handler.handleResponse(MessageContext context)
      The handleResponse method processes the response SOAP message.
      boolean GenericHandler.handleResponse(MessageContext context)
      The handleResponse method processes the response message.

    • Uses of MessageContext in javax.xml.rpc.handler.soap

      Subinterfaces of MessageContext in javax.xml.rpc.handler.soap
      Modifier and Type Interface and Description
      interface  SOAPMessageContext
      The interface javax.xml.rpc.soap.SOAPMessageContext provides access to the SOAP message for either RPC request or response.

    • Uses of MessageContext in javax.xml.rpc.server

      Methods in javax.xml.rpc.server that return MessageContext
      Modifier and Type Method and Description
      MessageContext ServletEndpointContext.getMessageContext()
      The method getMessageContext returns the MessageContext targeted for this endpoint instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.xml.rpc.handler.soap (Java(TM) EE 7 Specification APIs)

javax.xml.rpc.handler.soap

Interfaces

  • SOAPMessageContext


javax.xml.rpc.handler.soap (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.rpc.handler.soap

This package defines APIs for SOAP Message Handlers

See: Description

  • Interface Summary
    Interface Description
    SOAPMessageContext
    The interface javax.xml.rpc.soap.SOAPMessageContext provides access to the SOAP message for either RPC request or response.

Package javax.xml.rpc.handler.soap Description

This package defines APIs for SOAP Message Handlers
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.rpc.handler.soap Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.rpc.handler.soap

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.rpc.handler.MessageContext
    • javax.xml.rpc.handler.soap.SOAPMessageContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


SOAPMessageContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.handler.soap

Interface SOAPMessageContext

  • All Superinterfaces:
    MessageContext

    public interface SOAPMessageContext
extends MessageContext
    The interface javax.xml.rpc.soap.SOAPMessageContext provides access to the SOAP message for either RPC request or response. The javax.xml.soap.SOAPMessage specifies the standard Java API for the representation of a SOAP 1.1 message with attachments.
    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    SOAPMessage

    • Method Summary

      Methods
      Modifier and Type Method and Description
      SOAPMessage getMessage()
      Gets the SOAPMessage from this message context
      String[] getRoles()
      Gets the SOAP actor roles associated with an execution of the HandlerChain and its contained Handler instances.
      void setMessage(SOAPMessage message)
      Sets the SOAPMessage in this message context

      • Methods inherited from interface javax.xml.rpc.handler.MessageContext

        containsProperty, getProperty, getPropertyNames, removeProperty, setProperty

    • Method Detail

      • getMessage

        SOAPMessage getMessage()
        Gets the SOAPMessage from this message context
        Returns:
        Returns the SOAPMessage; returns null if no SOAPMessage is present in this message context

      • setMessage

        void setMessage(SOAPMessage message)
        Sets the SOAPMessage in this message context
        Parameters:
        message - SOAP message
        Throws:
        JAXRPCException - If any error during the setting of the SOAPMessage in this message context
        UnsupportedOperationException - If this operation is not supported

      • getRoles

        String[] getRoles()
        Gets the SOAP actor roles associated with an execution of the HandlerChain and its contained Handler instances. Note that SOAP actor roles apply to the SOAP node and are managed using HandlerChain.setRoles and HandlerChain.getRoles. Handler instances in the HandlerChain use this information about the SOAP actor roles to process the SOAP header blocks. Note that the SOAP actor roles are invariant during the processing of SOAP message through the HandlerChain.
        Returns:
        Array of URIs for SOAP actor roles
        See Also:
        HandlerChain.setRoles(java.lang.String[]), HandlerChain.getRoles()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.rpc.handler.soap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.rpc.handler.soap

No usage of javax.xml.rpc.handler.soap
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.handler.soap.SOAPMessageContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.handler.soap.SOAPMessageContext

No usage of javax.xml.rpc.handler.soap.SOAPMessageContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


BigDecimalHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class BigDecimalHolder

  • java.lang.Object
    • javax.xml.rpc.holders.BigDecimalHolder
  • All Implemented Interfaces:
    Holder

    public final class BigDecimalHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      BigDecimal value

    • Constructor Summary

      Constructors
      Constructor and Description
      BigDecimalHolder()
      BigDecimalHolder(BigDecimal myBigDecimal)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public BigDecimal value

    • Constructor Detail

      • BigDecimalHolder

        public BigDecimalHolder()

      • BigDecimalHolder

        public BigDecimalHolder(BigDecimal myBigDecimal)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BigIntegerHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class BigIntegerHolder

  • java.lang.Object
    • javax.xml.rpc.holders.BigIntegerHolder
  • All Implemented Interfaces:
    Holder

    public final class BigIntegerHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      BigInteger value

    • Constructor Summary

      Constructors
      Constructor and Description
      BigIntegerHolder()
      BigIntegerHolder(BigInteger myBigInteger)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public BigInteger value

    • Constructor Detail

      • BigIntegerHolder

        public BigIntegerHolder()

      • BigIntegerHolder

        public BigIntegerHolder(BigInteger myBigInteger)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BooleanHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class BooleanHolder

  • java.lang.Object
    • javax.xml.rpc.holders.BooleanHolder
  • All Implemented Interfaces:
    Holder

    public final class BooleanHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      boolean | value

    • Constructor Summary

      Constructors
      Constructor and Description
      BooleanHolder()
      BooleanHolder(boolean myboolean)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public boolean value

    • Constructor Detail

      • BooleanHolder

        public BooleanHolder()

      • BooleanHolder

        public BooleanHolder(boolean myboolean)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BooleanWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class BooleanWrapperHolder

  • java.lang.Object
    • javax.xml.rpc.holders.BooleanWrapperHolder
  • All Implemented Interfaces:
    Holder

    public final class BooleanWrapperHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Boolean value

    • Constructor Summary

      Constructors
      Constructor and Description
      BooleanWrapperHolder()
      BooleanWrapperHolder(Boolean myboolean)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Boolean value

    • Constructor Detail

      • BooleanWrapperHolder

        public BooleanWrapperHolder()

      • BooleanWrapperHolder

        public BooleanWrapperHolder(Boolean myboolean)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ByteArrayHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class ByteArrayHolder

  • java.lang.Object
    • javax.xml.rpc.holders.ByteArrayHolder
  • All Implemented Interfaces:
    Holder

    public final class ByteArrayHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      byte[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      ByteArrayHolder()
      ByteArrayHolder(byte[] mybyteArray)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public byte[] value

    • Constructor Detail

      • ByteArrayHolder

        public ByteArrayHolder()

      • ByteArrayHolder

        public ByteArrayHolder(byte[] mybyteArray)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ByteHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class ByteHolder

  • java.lang.Object
    • javax.xml.rpc.holders.ByteHolder
  • All Implemented Interfaces:
    Holder

    public final class ByteHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      byte | value

    • Constructor Summary

      Constructors
      Constructor and Description
      ByteHolder()
      ByteHolder(byte mybyte)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public byte value

    • Constructor Detail

      • ByteHolder

        public ByteHolder()

      • ByteHolder

        public ByteHolder(byte mybyte)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ByteWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class ByteWrapperHolder

  • java.lang.Object
    • javax.xml.rpc.holders.ByteWrapperHolder
  • All Implemented Interfaces:
    Holder

    public final class ByteWrapperHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Byte value

    • Constructor Summary

      Constructors
      Constructor and Description
      ByteWrapperHolder()
      ByteWrapperHolder(Byte mybyte)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Byte value

    • Constructor Detail

      • ByteWrapperHolder

        public ByteWrapperHolder()

      • ByteWrapperHolder

        public ByteWrapperHolder(Byte mybyte)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CalendarHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class CalendarHolder

  • java.lang.Object
    • javax.xml.rpc.holders.CalendarHolder
  • All Implemented Interfaces:
    Holder

    public final class CalendarHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Calendar value

    • Constructor Summary

      Constructors
      Constructor and Description
      CalendarHolder()
      CalendarHolder(Calendar myCalendar)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Calendar value

    • Constructor Detail

      • CalendarHolder

        public CalendarHolder()

      • CalendarHolder

        public CalendarHolder(Calendar myCalendar)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DoubleHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class DoubleHolder

  • java.lang.Object
    • javax.xml.rpc.holders.DoubleHolder
  • All Implemented Interfaces:
    Holder

    public final class DoubleHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      double | value

    • Constructor Summary

      Constructors
      Constructor and Description
      DoubleHolder()
      DoubleHolder(double mydouble)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public double value

    • Constructor Detail

      • DoubleHolder

        public DoubleHolder()

      • DoubleHolder

        public DoubleHolder(double mydouble)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DoubleWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class DoubleWrapperHolder

  • java.lang.Object
    • javax.xml.rpc.holders.DoubleWrapperHolder
  • All Implemented Interfaces:
    Holder

    public final class DoubleWrapperHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Double value

    • Constructor Summary

      Constructors
      Constructor and Description
      DoubleWrapperHolder()
      DoubleWrapperHolder(Double mydouble)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Double value

    • Constructor Detail

      • DoubleWrapperHolder

        public DoubleWrapperHolder()

      • DoubleWrapperHolder

        public DoubleWrapperHolder(Double mydouble)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FloatHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class FloatHolder

  • java.lang.Object
    • javax.xml.rpc.holders.FloatHolder
  • All Implemented Interfaces:
    Holder

    public final class FloatHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      float | value

    • Constructor Summary

      Constructors
      Constructor and Description
      FloatHolder()
      FloatHolder(float myfloat)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public float value

    • Constructor Detail

      • FloatHolder

        public FloatHolder()

      • FloatHolder

        public FloatHolder(float myfloat)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FloatWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class FloatWrapperHolder

  • java.lang.Object
    • javax.xml.rpc.holders.FloatWrapperHolder
  • All Implemented Interfaces:
    Holder

    public final class FloatWrapperHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Float value

    • Constructor Summary

      Constructors
      Constructor and Description
      FloatWrapperHolder()
      FloatWrapperHolder(Float myfloat)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Float value

    • Constructor Detail

      • FloatWrapperHolder

        public FloatWrapperHolder()

      • FloatWrapperHolder

        public FloatWrapperHolder(Float myfloat)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Holder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Interface Holder

  • All Known Implementing Classes:
    BigDecimalHolder, BigIntegerHolder, BooleanHolder, BooleanWrapperHolder, ByteArrayHolder, ByteHolder, ByteWrapperHolder, CalendarHolder, DoubleHolder, DoubleWrapperHolder, FloatHolder, FloatWrapperHolder, IntegerWrapperHolder, IntHolder, LongHolder, LongWrapperHolder, ObjectHolder, QNameHolder, ShortHolder, ShortWrapperHolder, StringHolder

    public interface Holder
    The java.xml.rpc.holders.Holder interface represents the base interface for both standard and generated Holder classes. A generated Holder class is required to implement this Holder interface.
    Version:
    1.0
    Author:
    Rahul Sharma
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IntegerWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class IntegerWrapperHolder

  • java.lang.Object
    • javax.xml.rpc.holders.IntegerWrapperHolder
  • All Implemented Interfaces:
    Holder

    public final class IntegerWrapperHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Integer value

    • Constructor Summary

      Constructors
      Constructor and Description
      IntegerWrapperHolder()
      IntegerWrapperHolder(Integer myint)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Integer value

    • Constructor Detail

      • IntegerWrapperHolder

        public IntegerWrapperHolder()

      • IntegerWrapperHolder

        public IntegerWrapperHolder(Integer myint)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IntHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class IntHolder

  • java.lang.Object
    • javax.xml.rpc.holders.IntHolder
  • All Implemented Interfaces:
    Holder

    public final class IntHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      int | value

    • Constructor Summary

      Constructors
      Constructor and Description
      IntHolder()
      IntHolder(int myint)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public int value

    • Constructor Detail

      • IntHolder

        public IntHolder()

      • IntHolder

        public IntHolder(int myint)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.rpc.holders (Java(TM) EE 7 Specification APIs)

javax.xml.rpc.holders

Interfaces

  • Holder

Classes

  • BigDecimalHolder
  • BigIntegerHolder
  • BooleanHolder
  • BooleanWrapperHolder
  • ByteArrayHolder
  • ByteHolder
  • ByteWrapperHolder
  • CalendarHolder
  • DoubleHolder
  • DoubleWrapperHolder
  • FloatHolder
  • FloatWrapperHolder
  • IntegerWrapperHolder
  • IntHolder
  • LongHolder
  • LongWrapperHolder
  • ObjectHolder
  • QNameHolder
  • ShortHolder
  • ShortWrapperHolder
  • StringHolder


javax.xml.rpc.holders (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.rpc.holders

This package contains the standard Java Holder classes.

See: Description

  • Interface Summary
    Interface Description
    Holder
    The java.xml.rpc.holders.Holder interface represents the base interface for both standard and generated Holder classes.
  • Class Summary
    Class Description
    BigDecimalHolder
    BigIntegerHolder
    BooleanHolder
    BooleanWrapperHolder
    ByteArrayHolder
    ByteHolder
    ByteWrapperHolder
    CalendarHolder
    DoubleHolder
    DoubleWrapperHolder
    FloatHolder
    FloatWrapperHolder
    IntegerWrapperHolder
    IntHolder
    LongHolder
    LongWrapperHolder
    ObjectHolder
    QNameHolder
    ShortHolder
    ShortWrapperHolder
    StringHolder

Package javax.xml.rpc.holders Description

This package contains the standard Java Holder classes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.rpc.holders Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.rpc.holders

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.rpc.holders.BigDecimalHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.BigIntegerHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.BooleanHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.BooleanWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ByteArrayHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ByteHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ByteWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.CalendarHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.DoubleHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.DoubleWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.FloatHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.FloatWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.IntegerWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.IntHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.LongHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.LongWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ObjectHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.QNameHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ShortHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ShortWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.StringHolder (implements javax.xml.rpc.holders.Holder)

Interface Hierarchy

  • javax.xml.rpc.holders.Holder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LongHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class LongHolder

  • java.lang.Object
    • javax.xml.rpc.holders.LongHolder
  • All Implemented Interfaces:
    Holder

    public final class LongHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      long | value

    • Constructor Summary

      Constructors
      Constructor and Description
      LongHolder()
      LongHolder(long mylong)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public long value

    • Constructor Detail

      • LongHolder

        public LongHolder()

      • LongHolder

        public LongHolder(long mylong)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LongWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class LongWrapperHolder

  • java.lang.Object
    • javax.xml.rpc.holders.LongWrapperHolder
  • All Implemented Interfaces:
    Holder

    public final class LongWrapperHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Long value

    • Constructor Summary

      Constructors
      Constructor and Description
      LongWrapperHolder()
      LongWrapperHolder(Long mylong)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Long value

    • Constructor Detail

      • LongWrapperHolder

        public LongWrapperHolder()

      • LongWrapperHolder

        public LongWrapperHolder(Long mylong)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class ObjectHolder

  • java.lang.Object
    • javax.xml.rpc.holders.ObjectHolder
  • All Implemented Interfaces:
    Holder

    public final class ObjectHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Object value

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectHolder()
      ObjectHolder(Object value)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Object value

    • Constructor Detail

      • ObjectHolder

        public ObjectHolder()

      • ObjectHolder

        public ObjectHolder(Object value)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


QNameHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class QNameHolder

  • java.lang.Object
    • javax.xml.rpc.holders.QNameHolder
  • All Implemented Interfaces:
    Holder

    public final class QNameHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      QName value

    • Constructor Summary

      Constructors
      Constructor and Description
      QNameHolder()
      QNameHolder(QName myQName)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public QName value

    • Constructor Detail

      • QNameHolder

        public QNameHolder()

      • QNameHolder

        public QNameHolder(QName myQName)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ShortHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class ShortHolder

  • java.lang.Object
    • javax.xml.rpc.holders.ShortHolder
  • All Implemented Interfaces:
    Holder

    public final class ShortHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short | value

    • Constructor Summary

      Constructors
      Constructor and Description
      ShortHolder()
      ShortHolder(short myshort)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public short value

    • Constructor Detail

      • ShortHolder

        public ShortHolder()

      • ShortHolder

        public ShortHolder(short myshort)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ShortWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class ShortWrapperHolder

  • java.lang.Object
    • javax.xml.rpc.holders.ShortWrapperHolder
  • All Implemented Interfaces:
    Holder

    public final class ShortWrapperHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Short value

    • Constructor Summary

      Constructors
      Constructor and Description
      ShortWrapperHolder()
      ShortWrapperHolder(Short myshort)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Short value

    • Constructor Detail

      • ShortWrapperHolder

        public ShortWrapperHolder()

      • ShortWrapperHolder

        public ShortWrapperHolder(Short myshort)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


StringHolder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.holders

Class StringHolder

  • java.lang.Object
    • javax.xml.rpc.holders.StringHolder
  • All Implemented Interfaces:
    Holder

    public final class StringHolder
extends Object
implements Holder

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String value

    • Constructor Summary

      Constructors
      Constructor and Description
      StringHolder()
      StringHolder(String myString)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public String value

    • Constructor Detail

      • StringHolder

        public StringHolder()

      • StringHolder

        public StringHolder(String myString)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.rpc.holders (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.rpc.holders

  • Packages that use javax.xml.rpc.holders
    Package Description
    javax.xml.rpc.holders
    This package contains the standard Java Holder classes.
  • Classes in javax.xml.rpc.holders used by javax.xml.rpc.holders
    Class and Description
    Holder
    The java.xml.rpc.holders.Holder interface represents the base interface for both standard and generated Holder classes.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.BigDecimalHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.BigDecimalHolder

No usage of javax.xml.rpc.holders.BigDecimalHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.BigIntegerHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.BigIntegerHolder

No usage of javax.xml.rpc.holders.BigIntegerHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.BooleanHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.BooleanHolder

No usage of javax.xml.rpc.holders.BooleanHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.BooleanWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.BooleanWrapperHolder

No usage of javax.xml.rpc.holders.BooleanWrapperHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.ByteArrayHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.ByteArrayHolder

No usage of javax.xml.rpc.holders.ByteArrayHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.ByteHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.ByteHolder

No usage of javax.xml.rpc.holders.ByteHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.ByteWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.ByteWrapperHolder

No usage of javax.xml.rpc.holders.ByteWrapperHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.CalendarHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.CalendarHolder

No usage of javax.xml.rpc.holders.CalendarHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.DoubleHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.DoubleHolder

No usage of javax.xml.rpc.holders.DoubleHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.DoubleWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.DoubleWrapperHolder

No usage of javax.xml.rpc.holders.DoubleWrapperHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.FloatHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.FloatHolder

No usage of javax.xml.rpc.holders.FloatHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.FloatWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.FloatWrapperHolder

No usage of javax.xml.rpc.holders.FloatWrapperHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.IntegerWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.IntegerWrapperHolder

No usage of javax.xml.rpc.holders.IntegerWrapperHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.IntHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.IntHolder

No usage of javax.xml.rpc.holders.IntHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.LongHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.LongHolder

No usage of javax.xml.rpc.holders.LongHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.LongWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.LongWrapperHolder

No usage of javax.xml.rpc.holders.LongWrapperHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.ObjectHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.ObjectHolder

No usage of javax.xml.rpc.holders.ObjectHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.QNameHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.QNameHolder

No usage of javax.xml.rpc.holders.QNameHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.ShortHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.ShortHolder

No usage of javax.xml.rpc.holders.ShortHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.ShortWrapperHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.ShortWrapperHolder

No usage of javax.xml.rpc.holders.ShortWrapperHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.holders.StringHolder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.holders.StringHolder

No usage of javax.xml.rpc.holders.StringHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.holders.Holder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.holders.Holder

  • Packages that use Holder
    Package Description
    javax.xml.rpc.holders
    This package contains the standard Java Holder classes.

    • Uses of Holder in javax.xml.rpc.holders

      Classes in javax.xml.rpc.holders that implement Holder
      Modifier and Type | Class and Description
      class  | BigDecimalHolder
      class  | BigIntegerHolder
      class  | BooleanHolder
      class  | BooleanWrapperHolder
      class  | ByteArrayHolder
      class  | ByteHolder
      class  | ByteWrapperHolder
      class  | CalendarHolder
      class  | DoubleHolder
      class  | DoubleWrapperHolder
      class  | FloatHolder
      class  | FloatWrapperHolder
      class  | IntegerWrapperHolder
      class  | IntHolder
      class  | LongHolder
      class  | LongWrapperHolder
      class  | ObjectHolder
      class  | QNameHolder
      class  | ShortHolder
      class  | ShortWrapperHolder
      class  | StringHolder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.xml.rpc.server (Java(TM) EE 7 Specification APIs)

javax.xml.rpc.server

Interfaces

  • ServiceLifecycle
  • ServletEndpointContext


javax.xml.rpc.server (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.rpc.server

This package defines APIs for the servlet based JAX-RPC endpoint model.

See: Description

  • Interface Summary
    Interface Description
    ServiceLifecycle
    The javax.xml.rpc.server.ServiceLifecycle defines a lifecycle interface for a JAX-RPC service endpoint.
    ServletEndpointContext
    The ServletEndpointContext provides an endpoint context maintained by the underlying servlet container based JAX-RPC runtime system.

Package javax.xml.rpc.server Description

This package defines APIs for the servlet based JAX-RPC endpoint model.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.rpc.server Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.rpc.server

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.rpc.server.ServiceLifecycle
  • javax.xml.rpc.server.ServletEndpointContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


ServiceLifecycle (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.server

Interface ServiceLifecycle

  • public interface ServiceLifecycle
    The javax.xml.rpc.server.ServiceLifecycle defines a lifecycle interface for a JAX-RPC service endpoint. If the service endpoint class implements the ServiceLifeycle interface, the servlet container based JAX-RPC runtime system is required to manage the lifecycle of the corresponding service endpoint objects.
    Version:
    1.0
    Author:
    Rahul Sharma

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void destroy()
      JAX-RPC runtime system ends the lifecycle of a service endpoint instance by invoking the destroy method.
      void init(Object context)
      Used for initialization of a service endpoint.

    • Method Detail

      • init

        void init(Object context)
          throws ServiceException
        Used for initialization of a service endpoint. After a service endpoint instance (an instance of a service endpoint class) is instantiated, the JAX-RPC runtime system invokes the init method. The service endpoint class uses the init method to initialize its configuration and setup access to any external resources. The context parameter in the init method enables the endpoint instance to access the endpoint context provided by the underlying JAX-RPC runtime system.

        The init method implementation should typecast the context parameter to an appropriate Java type. For service endpoints deployed on a servlet container based JAX-RPC runtime system, the context parameter is of the Java type javax.xml.rpc.server.ServletEndpointContext. The ServletEndpointContext provides an endpoint context maintained by the underlying servlet container based JAX-RPC runtime system

        Parameters:
        context - Endpoint context for a JAX-RPC service endpoint
        Throws:
        ServiceException - If any error in initialization of the service endpoint; or if any illegal context has been provided in the init method

      • destroy

        void destroy()
        JAX-RPC runtime system ends the lifecycle of a service endpoint instance by invoking the destroy method. The service endpoint releases its resourcesin the implementation of the destroy method.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServletEndpointContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.server

Interface ServletEndpointContext

  • public interface ServletEndpointContext
    The ServletEndpointContext provides an endpoint context maintained by the underlying servlet container based JAX-RPC runtime system. For service endpoints deployed on a servlet container based JAX-RPC runtime system, the context parameter in the ServiceLifecycle.init method is required to be of the Java type javax.xml.rpc.server.ServletEndpointContext.

    A servlet container based JAX-RPC runtime system implements the ServletEndpointContext interface. The JAX-RPC runtime system is required to provide appropriate session, message context, servlet context and user principal information per method invocation on the endpoint class.

    Version:
    1.1
    Author:
    Rahul Sharma, Roberto Chinnici

    • Method Summary

      Methods
      Modifier and Type Method and Description
      HttpSession getHttpSession()
      The getHttpSession method returns the current HTTP session (as a javax.servlet.http.HTTPSession).
      MessageContext getMessageContext()
      The method getMessageContext returns the MessageContext targeted for this endpoint instance.
      ServletContext getServletContext()
      The method getServletContext returns the ServletContext associated with the web application that contain this endpoint.
      Principal getUserPrincipal()
      Returns a java.security.Principal instance that contains the name of the authenticated user for the current method invocation on the endpoint instance.
      boolean isUserInRole(String role)
      Returns a boolean indicating whether the authenticated user for the current method invocation on the endpoint instance is included in the specified logical "role".

    • Method Detail

      • getMessageContext

        MessageContext getMessageContext()
        The method getMessageContext returns the MessageContext targeted for this endpoint instance. This enables the service endpoint instance to acccess the MessageContext propagated by request HandlerChain (and its contained Handler instances) to the target endpoint instance and to share any SOAP message processing related context. The endpoint instance can access and manipulate the MessageContext and share the SOAP message processing related context with the response HandlerChain.
        Returns:
        MessageContext; If there is no associated MessageContext, this method returns null.
        Throws:
        IllegalStateException - if this method is invoked outside a remote method implementation by a service endpoint instance.
        See Also:
        MessageContext, HandlerChain, Handler

      • getUserPrincipal

        Principal getUserPrincipal()
        Returns a java.security.Principal instance that contains the name of the authenticated user for the current method invocation on the endpoint instance. This method returns null if there is no associated principal yet. The underlying JAX-RPC runtime system takes the responsibility of providing the appropriate authenticated principal for a remote method invocation on the service endpoint instance.
        Returns:
        A java.security.Principal for the authenticated principal associated with the current invocation on the servlet endpoint instance; Returns null if there no authenticated user associated with a method invocation.
        See Also:
        Principal

      • getHttpSession

        HttpSession getHttpSession()
        The getHttpSession method returns the current HTTP session (as a javax.servlet.http.HTTPSession). When invoked by the service endpoint within a remote method implementation, the getHttpSession returns the HTTP session associated currently with this method invocation. This method returns null if there is no HTTP session currently active and associated with this service endpoint. An endpoint class should not rely on an active HTTP session being always there; the underlying JAX-RPC runtime system is responsible for managing whether or not there is an active HTTP session.

        The getHttpSession method throws JAXRPCException if invoked by an non HTTP bound endpoint.

        Returns:
        The HTTP session associated with the current invocation or null if there is no active session.
        Throws:
        JAXRPCException - If this method invoked by any non-HTTP bound endpoint
        See Also:
        HttpSession

      • getServletContext

        ServletContext getServletContext()
        The method getServletContext returns the ServletContext associated with the web application that contain this endpoint. According to the Servlet specification, There is one context per web application (installed as a WAR) per JVM . A servlet based service endpoint is deployed as part of a web application.
        Returns:
        ServletContext
        See Also:
        ServletContext

      • isUserInRole

        boolean isUserInRole(String role)
        Returns a boolean indicating whether the authenticated user for the current method invocation on the endpoint instance is included in the specified logical "role".
        Parameters:
        role - a String specifying the name of the role
        Returns:
        a boolean indicating whether the authenticated user associated with the current method invocation belongs to a given role; false if the user has not been authenticated
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.rpc.server (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.rpc.server

No usage of javax.xml.rpc.server
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.server.ServiceLifecycle (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.server.ServiceLifecycle

No usage of javax.xml.rpc.server.ServiceLifecycle
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.rpc.server.ServletEndpointContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.rpc.server.ServletEndpointContext

No usage of javax.xml.rpc.server.ServletEndpointContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.xml.rpc.soap (Java(TM) EE 7 Specification APIs)

javax.xml.rpc.soap

Exceptions

  • SOAPFaultException


javax.xml.rpc.soap (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.rpc.soap

This package defines APIs specific to the SOAP binding.

See: Description

  • Exception Summary
    Exception Description
    SOAPFaultException
    The SOAPFaultException exception represents a SOAP fault.

Package javax.xml.rpc.soap Description

This package defines APIs specific to the SOAP binding.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.rpc.soap Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.rpc.soap

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.rpc.soap.SOAPFaultException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


SOAPFaultException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.rpc.soap

Class SOAPFaultException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.rpc.soap.SOAPFaultException
  • All Implemented Interfaces:
    Serializable

    public class SOAPFaultException
extends RuntimeException
    The SOAPFaultException exception represents a SOAP fault.

    The message part in the SOAP fault maps to the contents of faultdetail element accessible through the getDetail method on the SOAPFaultException. The method createDetail on the javax.xml.soap.SOAPFactory creates an instance of the javax.xml.soap.Detail.

    The faultstring provides a human-readable description of the SOAP fault. The faultcode element provides an algorithmic mapping of the SOAP fault.

    Refer to SOAP 1.1 and WSDL 1.1 specifications for more details of the SOAP faults.

    Version:
    1.0
    Author:
    Rahul Sharma
    See Also:
    Detail, SOAPFactory.createDetail(), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPFaultException(QName faultcode, String faultstring, String faultactor, Detail faultdetail)
      Constructor for the SOAPFaultException

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Detail getDetail()
      Gets the detail element.
      String getFaultActor()
      Gets the faultactor element.
      QName getFaultCode()
      Gets the faultcode element.
      String getFaultString()
      Gets the faultstring element.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SOAPFaultException

        public SOAPFaultException(QName faultcode,
                  String faultstring,
                  String faultactor,
                  Detail faultdetail)
        Constructor for the SOAPFaultException
        Parameters:
        faultcode - QName for the SOAP faultcode
        faultstring - faultstring element of SOAP fault
        faultactor - faultactor element of SOAP fault
        faultdetail - faultdetail element of SOAP fault
        See Also:
        SOAPFactory.createDetail()

    • Method Detail

      • getFaultCode

        public QName getFaultCode()
        Gets the faultcode element. The faultcode element provides an algorithmic mechanism for identifying the fault. SOAP defines a small set of SOAP fault codes covering basic SOAP faults.
        Returns:
        QName of the faultcode element

      • getFaultString

        public String getFaultString()
        Gets the faultstring element. The faultstring provides a human-readable description of the SOAP fault and is not intended for algorithmic processing.
        Returns:
        faultstring element of the SOAP fault

      • getFaultActor

        public String getFaultActor()
        Gets the faultactor element. The faultactor element provides information about which SOAP node on the SOAP message path caused the fault to happen. It indicates the source of the fault.
        Returns:
        faultactor element of the SOAP fault

      • getDetail

        public Detail getDetail()
        Gets the detail element. The detail element is intended for carrying application specific error information related to the SOAP Body.
        Returns:
        detail element of the SOAP fault
        See Also:
        Detail
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.rpc.soap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.rpc.soap

No usage of javax.xml.rpc.soap
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.rpc.soap.SOAPFaultException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.rpc.soap.SOAPFaultException

No usage of javax.xml.rpc.soap.SOAPFaultException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


AttachmentPart (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class AttachmentPart

  • java.lang.Object
    • javax.xml.soap.AttachmentPart

  • public abstract class AttachmentPart
extends Object
    A single attachment to a SOAPMessage object. A SOAPMessage object may contain zero, one, or many AttachmentPart objects. Each AttachmentPart object consists of two parts, application-specific content and associated MIME headers. The MIME headers consists of name/value pairs that can be used to identify and describe the content.

    An AttachmentPart object must conform to certain standards.

    1. It must conform to MIME [RFC2045] standards
    2. It MUST contain content
    3. The header portion MUST include the following header:
      • Content-Type
        This header identifies the type of data in the content of an AttachmentPart object and MUST conform to [RFC2045]. The following is an example of a Content-Type header:
               Content-Type:  application/xml
        The following line of code, in which ap is an AttachmentPart object, sets the header shown in the previous example.
               ap.setMimeHeader("Content-Type", "application/xml");

    There are no restrictions on the content portion of an AttachmentPart object. The content may be anything from a simple plain text object to a complex XML document or image file.

    An AttachmentPart object is created with the method SOAPMessage.createAttachmentPart. After setting its MIME headers, the AttachmentPart object is added to the message that created it with the method SOAPMessage.addAttachmentPart.

    The following code fragment, in which m is a SOAPMessage object and contentStringl is a String, creates an instance of AttachmentPart, sets the AttachmentPart object with some content and header information, and adds the AttachmentPart object to the SOAPMessage object.

         AttachmentPart ap1 = m.createAttachmentPart();
     ap1.setContent(contentString1, "text/plain");
     m.addAttachmentPart(ap1);

    The following code fragment creates and adds a second AttachmentPart instance to the same message. jpegData is a binary byte buffer representing the jpeg file.

         AttachmentPart ap2 = m.createAttachmentPart();
     byte[] jpegData =  ...;
     ap2.setContent(new ByteArrayInputStream(jpegData), "image/jpeg");
     m.addAttachmentPart(ap2);

    The getContent method retrieves the contents and header from an AttachmentPart object. Depending on the DataContentHandler objects present, the returned Object can either be a typed Java object corresponding to the MIME type or an InputStream object that contains the content as bytes.

         String content1 = ap1.getContent();
     java.io.InputStream content2 = ap2.getContent();
    The method clearContent removes all the content from an AttachmentPart object but does not affect its header information.
         ap1.clearContent();

    • Constructor Summary

      Constructors
      Constructor and Description
      AttachmentPart()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addMimeHeader(String name, String value)
      Adds a MIME header with the specified name and value to this AttachmentPart object.
      abstract void clearContent()
      Clears out the content of this AttachmentPart object.
      abstract Iterator getAllMimeHeaders()
      Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.
      abstract InputStream getBase64Content()
      Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
      abstract Object getContent()
      Gets the content of this AttachmentPart object as a Java object.
      String getContentId()
      Gets the value of the MIME header whose name is "Content-ID".
      String getContentLocation()
      Gets the value of the MIME header whose name is "Content-Location".
      String getContentType()
      Gets the value of the MIME header whose name is "Content-Type".
      abstract DataHandler getDataHandler()
      Gets the DataHandler object for this AttachmentPart object.
      abstract Iterator getMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects that match a name in the given array.
      abstract String[] getMimeHeader(String name)
      Gets all the values of the header identified by the given String.
      abstract Iterator getNonMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects whose name does not match a name in the given array.
      abstract InputStream getRawContent()
      Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract byte[] getRawContentBytes()
      Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract int getSize()
      Returns the number of bytes in this AttachmentPart object.
      abstract void removeAllMimeHeaders()
      Removes all the MIME header entries.
      abstract void removeMimeHeader(String header)
      Removes all MIME headers that match the given name.
      abstract void setBase64Content(InputStream content, String contentType)
      Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.
      abstract void setContent(Object object, String contentType)
      Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type.
      void setContentId(String contentId)
      Sets the MIME header whose name is "Content-ID" with the given value.
      void setContentLocation(String contentLocation)
      Sets the MIME header whose name is "Content-Location" with the given value.
      void setContentType(String contentType)
      Sets the MIME header whose name is "Content-Type" with the given value.
      abstract void setDataHandler(DataHandler dataHandler)
      Sets the given DataHandler object as the data handler for this AttachmentPart object.
      abstract void setMimeHeader(String name, String value)
      Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches.
      abstract void setRawContent(InputStream content, String contentType)
      Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.
      abstract void setRawContentBytes(byte[] content, int offset, int len, String contentType)
      Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttachmentPart

        public AttachmentPart()

    • Method Detail

      • getSize

        public abstract int getSize()
                     throws SOAPException
        Returns the number of bytes in this AttachmentPart object.
        Returns:
        the size of this AttachmentPart object in bytes or -1 if the size cannot be determined
        Throws:
        SOAPException - if the content of this attachment is corrupted of if there was an exception while trying to determine the size.

      • clearContent

        public abstract void clearContent()
        Clears out the content of this AttachmentPart object. The MIME header portion is left untouched.

      • getContent

        public abstract Object getContent()
                           throws SOAPException
        Gets the content of this AttachmentPart object as a Java object. The type of the returned Java object depends on (1) the DataContentHandler object that is used to interpret the bytes and (2) the Content-Type given in the header.

        For the MIME content types "text/plain", "text/html" and "text/xml", the DataContentHandler object does the conversions to and from the Java types corresponding to the MIME types. For other MIME types,the DataContentHandler object can return an InputStream object that contains the content data as raw bytes.

        A SAAJ-compliant implementation must, as a minimum, return a java.lang.String object corresponding to any content stream with a Content-Type value of text/plain, a javax.xml.transform.stream.StreamSource object corresponding to a content stream with a Content-Type value of text/xml, a java.awt.Image object corresponding to a content stream with a Content-Type value of image/gif or image/jpeg. For those content types that an installed DataContentHandler object does not understand, the DataContentHandler object is required to return a java.io.InputStream object with the raw bytes.

        Returns:
        a Java object with the content of this AttachmentPart object
        Throws:
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error

      • getRawContent

        public abstract InputStream getRawContent()
                                   throws SOAPException
        Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

        Note that reading from the returned InputStream would result in consuming the data in the stream. It is the responsibility of the caller to reset the InputStream appropriately before calling a Subsequent API. If a copy of the raw attachment content is required then the getRawContentBytes() API should be used instead.

        Returns:
        an InputStream from which the raw data contained by the AttachmentPart can be accessed.
        Throws:
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
        Since:
        SAAJ 1.3
        See Also:
        getRawContentBytes()

      • getRawContentBytes

        public abstract byte[] getRawContentBytes()
                                   throws SOAPException
        Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
        Returns:
        a byte[] array containing the raw data of the AttachmentPart.
        Throws:
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
        Since:
        SAAJ 1.3

      • getBase64Content

        public abstract InputStream getBase64Content()
                                      throws SOAPException
        Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
        Returns:
        an InputStream from which the Base64 encoded AttachmentPart can be read.
        Throws:
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
        Since:
        SAAJ 1.3

      • setContent

        public abstract void setContent(Object object,
              String contentType)
        Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type. The type of the Object should correspond to the value given for the Content-Type. This depends on the particular set of DataContentHandler objects in use.
        Parameters:
        object - the Java object that makes up the content for this attachment part
        contentType - the MIME string that specifies the type of the content
        Throws:
        IllegalArgumentException - may be thrown if the contentType does not match the type of the content object, or if there was no DataContentHandler object for this content object
        See Also:
        getContent()

      • setRawContent

        public abstract void setRawContent(InputStream content,
                 String contentType)
                            throws SOAPException
        Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.

        A subsequent call to getSize() may not be an exact measure of the content size.

        Parameters:
        content - the raw data to add to the attachment part
        contentType - the value to set into the Content-Type header
        Throws:
        SOAPException - if an there is an error in setting the content
        NullPointerException - if content is null
        Since:
        SAAJ 1.3

      • setRawContentBytes

        public abstract void setRawContentBytes(byte[] content,
                      int offset,
                      int len,
                      String contentType)
                                 throws SOAPException
        Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.
        Parameters:
        content - the raw data to add to the attachment part
        contentType - the value to set into the Content-Type header
        offset - the offset in the byte array of the content
        len - the number of bytes that form the content
        Throws:
        SOAPException - if an there is an error in setting the content or content is null
        Since:
        SAAJ 1.3

      • setBase64Content

        public abstract void setBase64Content(InputStream content,
                    String contentType)
                               throws SOAPException
        Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.

        A subsequent call to getSize() may not be an exact measure of the content size.

        Parameters:
        content - the base64 encoded data to add to the attachment part
        contentType - the value to set into the Content-Type header
        Throws:
        SOAPException - if an there is an error in setting the content
        NullPointerException - if content is null
        Since:
        SAAJ 1.3

      • getDataHandler

        public abstract DataHandler getDataHandler()
                                    throws SOAPException
        Gets the DataHandler object for this AttachmentPart object.
        Returns:
        the DataHandler object associated with this AttachmentPart object
        Throws:
        SOAPException - if there is no data in this AttachmentPart object

      • setDataHandler

        public abstract void setDataHandler(DataHandler dataHandler)
        Sets the given DataHandler object as the data handler for this AttachmentPart object. Typically, on an incoming message, the data handler is automatically set. When a message is being created and populated with content, the setDataHandler method can be used to get data from various data sources into the message.
        Parameters:
        dataHandler - the DataHandler object to be set
        Throws:
        IllegalArgumentException - if there was a problem with the specified DataHandler object

      • getContentId

        public String getContentId()
        Gets the value of the MIME header whose name is "Content-ID".
        Returns:
        a String giving the value of the "Content-ID" header or null if there is none
        See Also:
        setContentId(java.lang.String)

      • getContentLocation

        public String getContentLocation()
        Gets the value of the MIME header whose name is "Content-Location".
        Returns:
        a String giving the value of the "Content-Location" header or null if there is none

      • getContentType

        public String getContentType()
        Gets the value of the MIME header whose name is "Content-Type".
        Returns:
        a String giving the value of the "Content-Type" header or null if there is none

      • setContentId

        public void setContentId(String contentId)
        Sets the MIME header whose name is "Content-ID" with the given value.
        Parameters:
        contentId - a String giving the value of the "Content-ID" header
        Throws:
        IllegalArgumentException - if there was a problem with the specified contentId value
        See Also:
        getContentId()

      • setContentLocation

        public void setContentLocation(String contentLocation)
        Sets the MIME header whose name is "Content-Location" with the given value.
        Parameters:
        contentLocation - a String giving the value of the "Content-Location" header
        Throws:
        IllegalArgumentException - if there was a problem with the specified content location

      • setContentType

        public void setContentType(String contentType)
        Sets the MIME header whose name is "Content-Type" with the given value.
        Parameters:
        contentType - a String giving the value of the "Content-Type" header
        Throws:
        IllegalArgumentException - if there was a problem with the specified content type

      • removeMimeHeader

        public abstract void removeMimeHeader(String header)
        Removes all MIME headers that match the given name.
        Parameters:
        header - the string name of the MIME header/s to be removed

      • removeAllMimeHeaders

        public abstract void removeAllMimeHeaders()
        Removes all the MIME header entries.

      • getMimeHeader

        public abstract String[] getMimeHeader(String name)
        Gets all the values of the header identified by the given String.
        Parameters:
        name - the name of the header; example: "Content-Type"
        Returns:
        a String array giving the value for the specified header
        See Also:
        setMimeHeader(java.lang.String, java.lang.String)

      • setMimeHeader

        public abstract void setMimeHeader(String name,
                 String value)
        Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches. This method also removes all matching headers but the first.

        Note that RFC822 headers can only contain US-ASCII characters.

        Parameters:
        name - a String giving the name of the header for which to search
        value - a String giving the value to be set for the header whose name matches the given name
        Throws:
        IllegalArgumentException - if there was a problem with the specified mime header name or value

      • addMimeHeader

        public abstract void addMimeHeader(String name,
                 String value)
        Adds a MIME header with the specified name and value to this AttachmentPart object.

        Note that RFC822 headers can contain only US-ASCII characters.

        Parameters:
        name - a String giving the name of the header to be added
        value - a String giving the value of the header to be added
        Throws:
        IllegalArgumentException - if there was a problem with the specified mime header name or value

      • getAllMimeHeaders

        public abstract Iterator getAllMimeHeaders()
        Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.
        Returns:
        an Iterator object with all of the Mime headers for this AttachmentPart object

      • getMatchingMimeHeaders

        public abstract Iterator getMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects that match a name in the given array.
        Parameters:
        names - a String array with the name(s) of the MIME headers to be returned
        Returns:
        all of the MIME headers that match one of the names in the given array as an Iterator object

      • getNonMatchingMimeHeaders

        public abstract Iterator getNonMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects whose name does not match a name in the given array.
        Parameters:
        names - a String array with the name(s) of the MIME headers not to be returned
        Returns:
        all of the MIME headers in this AttachmentPart object except those that match one of the names in the given array. The nonmatching MIME headers are returned as an Iterator object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Detail (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface Detail

  • All Superinterfaces:
    Element, Node, SOAPElement, SOAPFaultElement

    public interface Detail
extends SOAPFaultElement
    A container for DetailEntry objects. DetailEntry objects give detailed error information that is application-specific and related to the SOAPBody object that contains it.

    A Detail object, which is part of a SOAPFault object, can be retrieved using the method SOAPFault.getDetail. The Detail interface provides two methods. One creates a new DetailEntry object and also automatically adds it to the Detail object. The second method gets a list of the DetailEntry objects contained in a Detail object.

    The following code fragment, in which sf is a SOAPFault object, gets its Detail object (d), adds a new DetailEntry object to d, and then gets a list of all the DetailEntry objects in d. The code also creates a Name object to pass to the method addDetailEntry. The variable se, used to create the Name object, is a SOAPEnvelope object.

        Detail d = sf.getDetail();
    Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");
    d.addDetailEntry(name);
    Iterator it = d.getDetailEntries();

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      DetailEntry addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      DetailEntry addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
      Iterator getDetailEntries()
      Gets an Iterator over all of the DetailEntrys in this Detail object.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • addDetailEntry

        DetailEntry addDetailEntry(Name name)
                           throws SOAPException
        Creates a new DetailEntry object with the given name and adds it to this Detail object.
        Parameters:
        name - a Name object identifying the new DetailEntry object
        Throws:
        SOAPException - thrown when there is a problem in adding a DetailEntry object to this Detail object.
        See Also:
        addDetailEntry(QName qname)

      • addDetailEntry

        DetailEntry addDetailEntry(QName qname)
                           throws SOAPException
        Creates a new DetailEntry object with the given QName and adds it to this Detail object. This method is the preferred over the one using Name.
        Parameters:
        qname - a QName object identifying the new DetailEntry object
        Throws:
        SOAPException - thrown when there is a problem in adding a DetailEntry object to this Detail object.
        Since:
        SAAJ 1.3
        See Also:
        addDetailEntry(Name name)

      • getDetailEntries

        Iterator getDetailEntries()
        Gets an Iterator over all of the DetailEntrys in this Detail object.
        Returns:
        an Iterator object over the DetailEntry objects in this Detail object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DetailEntry (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface DetailEntry

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface DetailEntry
extends SOAPElement
    The content for a Detail object, giving details for a SOAPFault object. A DetailEntry object, which carries information about errors related to the SOAPBody object that contains it, is application-specific.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.soap (Java(TM) EE 7 Specification APIs)

javax.xml.soap

Interfaces

  • Detail
  • DetailEntry
  • Name
  • Node
  • SOAPBody
  • SOAPBodyElement
  • SOAPConstants
  • SOAPElement
  • SOAPEnvelope
  • SOAPFault
  • SOAPFaultElement
  • SOAPHeader
  • SOAPHeaderElement
  • Text

Classes

  • AttachmentPart
  • MessageFactory
  • MimeHeader
  • MimeHeaders
  • SAAJMetaFactory
  • SAAJResult
  • SOAPConnection
  • SOAPConnectionFactory
  • SOAPElementFactory
  • SOAPFactory
  • SOAPMessage
  • SOAPPart

Exceptions

  • SOAPException


javax.xml.soap (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.soap

Provides the API for creating and building SOAP messages.

See: Description

  • Interface Summary
    Interface Description
    Detail
    A container for DetailEntry objects.
    DetailEntry
    The content for a Detail object, giving details for a SOAPFault object.
    Name
    A representation of an XML name.
    Node
    A representation of a node (element) in an XML document.
    SOAPBody
    An object that represents the contents of the SOAP body element in a SOAP message.
    SOAPBodyElement
    A SOAPBodyElement object represents the contents in a SOAPBody object.
    SOAPConstants
    The definition of constants pertaining to the SOAP protocol.
    SOAPElement
    An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
    SOAPEnvelope
    The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
    SOAPFault
    An element in the SOAPBody object that contains error and/or status information.
    SOAPFaultElement
    A representation of the contents in a SOAPFault object.
    SOAPHeader
    A representation of the SOAP header element.
    SOAPHeaderElement
    An object representing the contents in the SOAP header part of the SOAP envelope.
    Text
    A representation of a node whose value is text.
  • Class Summary
    Class Description
    AttachmentPart
    A single attachment to a SOAPMessage object.
    MessageFactory
    A factory for creating SOAPMessage objects.
    MimeHeader
    An object that stores a MIME header name and its value.
    MimeHeaders
    A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.
    SAAJMetaFactory
    The access point for the implementation classes of the factories defined in the SAAJ API.
    SAAJResult
    Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree.
    SOAPConnection
    A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).
    SOAPConnectionFactory
    A factory for creating SOAPConnection objects.
    SOAPElementFactory Deprecated
    - Use javax.xml.soap.SOAPFactory for creating SOAPElements.
    SOAPFactory
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
    SOAPMessage
    The root class for all SOAP messages.
    SOAPPart
    The container for the SOAP-specific portion of a SOAPMessage object.
  • Exception Summary
    Exception Description
    SOAPException
    An exception that signals that a SOAP exception has occurred.

Package javax.xml.soap Description

Provides the API for creating and building SOAP messages. This package is defined in the SOAP with Attachments API for JavaTM (SAAJ) 1.3 specification.

The API in the javax.xml.soap package allows you to do the following:

  • create a point-to-point connection to a specified endpoint
  • create a SOAP message
  • create an XML fragment
  • add content to the header of a SOAP message
  • add content to the body of a SOAP message
  • create attachment parts and add content to them
  • access/add/modify parts of a SOAP message
  • create/add/modify SOAP fault information
  • extract content from a SOAP message
  • send a SOAP request-response message

In addition the APIs in the javax.xml.soap package extend their counterparts in the org.w3c.dom package. This means that the SOAPPart of a SOAPMessage is also a DOM Level 2 Document, and can be manipulated as such by applications, tools and libraries that use DOM (see http://www.w3.org/DOM/ for more information). It is important to note that, while it is possible to use DOM APIs to add ordinary DOM nodes to a SAAJ tree, the SAAJ APIs are still required to return SAAJ types when examining or manipulating the tree. In order to accomplish this the SAAJ APIs (specifically SOAPElement.getChildElements()) are allowed to silently replace objects that are incorrectly typed relative to SAAJ requirements with equivalent objects of the required type. These replacements must never cause the logical structure of the tree to change, so from the perspective of the DOM APIs the tree will remain unchanged. However, the physical composition of the tree will have changed so that references to the nodes that were replaced will refer to nodes that are no longer a part of the tree. The SAAJ APIs are not allowed to make these replacements if they are not required so the replacement objects will never subsequently be silently replaced by future calls to the SAAJ API.

What this means in practical terms is that an application that starts to use SAAJ APIs on a tree after manipulating it using DOM APIs must assume that the tree has been translated into an all SAAJ tree and that any references to objects within the tree that were obtained using DOM APIs are no longer valid. Switching from SAAJ APIs to DOM APIs is not allowed to cause invalid references and neither is using SAAJ APIs exclusively. It is only switching from using DOM APIs on a particular SAAJ tree to using SAAJ APIs that causes the risk of invalid references.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.soap Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.soap

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.soap.AttachmentPart
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
      • javax.xml.soap.SAAJResult
    • javax.xml.soap.MessageFactory
    • javax.xml.soap.MimeHeader
    • javax.xml.soap.MimeHeaders
    • javax.xml.soap.SAAJMetaFactory
    • javax.xml.soap.SOAPConnection
    • javax.xml.soap.SOAPConnectionFactory
    • javax.xml.soap.SOAPElementFactory
    • javax.xml.soap.SOAPFactory
    • javax.xml.soap.SOAPMessage
    • javax.xml.soap.SOAPPart (implements org.w3c.dom.Document, javax.xml.soap.Node)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.soap.SOAPException

Interface Hierarchy

  • javax.xml.soap.Name
  • org.w3c.dom.Node
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Text
        • javax.xml.soap.Text (also extends javax.xml.soap.Node)
    • org.w3c.dom.Element
      • javax.xml.soap.SOAPElement (also extends javax.xml.soap.Node)
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.Node
      • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element)
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.Text (also extends org.w3c.dom.Text)
  • javax.xml.soap.SOAPConstants
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MessageFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class MessageFactory

  • java.lang.Object
    • javax.xml.soap.MessageFactory

  • public abstract class MessageFactory
extends Object
    A factory for creating SOAPMessage objects.

    A SAAJ client can create a MessageFactory object using the method newInstance, as shown in the following lines of code.

           MessageFactory mf = MessageFactory.newInstance();
       MessageFactory mf12 = MessageFactory.newInstance(SOAPConstants.SOAP_1_2_PROTOCOL);

    All MessageFactory objects, regardless of how they are created, will produce SOAPMessage objects that have the following elements by default:

    • A SOAPPart object
    • A SOAPEnvelope object
    • A SOAPBody object
    • A SOAPHeader object
    In some cases, specialized MessageFactory objects may be obtained that produce messages prepopulated with additional entries in the SOAPHeader object and the SOAPBody object. The content of a new SOAPMessage object depends on which of the two MessageFactory methods is used to create it.
    • createMessage()
      This is the method clients would normally use to create a request message.
    • createMessage(MimeHeaders, java.io.InputStream) -- message has content from the InputStream object and headers from the MimeHeaders object
      This method can be used internally by a service implementation to create a message that is a response to a request.

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract SOAPMessage createMessage()
      Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
      abstract SOAPMessage createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      static MessageFactory newInstance()
      Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
      static MessageFactory newInstance(String protocol)
      Creates a new MessageFactory object that is an instance of the specified implementation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MessageFactory

        public MessageFactory()

    • Method Detail

      • newInstance

        public static MessageFactory newInstance()
                                  throws SOAPException
        Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load:
        • Use the javax.xml.soap.MessageFactory system property.
        • Use the properties file "lib/jaxm.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
        • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.soap.MessageFactory in jars available to the runtime.
        • Use the SAAJMetaFactory instance to locate the MessageFactory implementation class.
        Returns:
        a new instance of a MessageFactory
        Throws:
        SOAPException - if there was an error in creating the default implementation of the MessageFactory.
        See Also:
        SAAJMetaFactory

      • newInstance

        public static MessageFactory newInstance(String protocol)
                                  throws SOAPException
        Creates a new MessageFactory object that is an instance of the specified implementation. May be a dynamic message factory, a SOAP 1.1 message factory, or a SOAP 1.2 message factory. A dynamic message factory creates messages based on the MIME headers specified as arguments to the createMessage method. This method uses the SAAJMetaFactory to locate the implementation class and create the MessageFactory instance.
        Parameters:
        protocol - a string constant representing the class of the specified message factory implementation. May be either DYNAMIC_SOAP_PROTOCOL, DEFAULT_SOAP_PROTOCOL (which is the same as) SOAP_1_1_PROTOCOL, or SOAP_1_2_PROTOCOL.
        Returns:
        a new instance of a MessageFactory
        Throws:
        SOAPException - if there was an error in creating the specified implementation of MessageFactory.
        Since:
        SAAJ 1.3
        See Also:
        SAAJMetaFactory

      • createMessage

        public abstract SOAPMessage createMessage()
                                   throws SOAPException
        Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects. Profile-specific message factories can choose to prepopulate the SOAPMessage object with profile-specific headers.

        Content can be added to this message's SOAPPart object, and the message can be sent "as is" when a message containing only a SOAP part is sufficient. Otherwise, the SOAPMessage object needs to create one or more AttachmentPart objects and add them to itself. Any content that is not in XML format must be in an AttachmentPart object.

        Returns:
        a new SOAPMessage object
        Throws:
        SOAPException - if a SOAP error occurs
        UnsupportedOperationException - if the protocol of this MessageFactory instance is DYNAMIC_SOAP_PROTOCOL

      • createMessage

        public abstract SOAPMessage createMessage(MimeHeaders headers,
                        InputStream in)
                                   throws IOException,
                                          SOAPException
        Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
        Parameters:
        in - the InputStream object that contains the data for a message
        headers - the transport-specific headers passed to the message in a transport-independent fashion for creation of the message
        Returns:
        a new SOAPMessage object containing the data from the given InputStream object
        Throws:
        IOException - if there is a problem in reading data from the input stream
        SOAPException - may be thrown if the message is invalid
        IllegalArgumentException - if the MessageFactory requires one or more MIME headers to be present in the headers parameter and they are missing. MessageFactory implementations for SOAP_1_1_PROTOCOL or SOAP_1_2_PROTOCOL must not throw IllegalArgumentException for this reason.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MimeHeader (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class MimeHeader

  • java.lang.Object
    • javax.xml.soap.MimeHeader

  • public class MimeHeader
extends Object
    An object that stores a MIME header name and its value. One or more MimeHeader objects may be contained in a MimeHeaders object.
    See Also:
    MimeHeaders

    • Constructor Summary

      Constructors
      Constructor and Description
      MimeHeader(String name, String value)
      Constructs a MimeHeader object initialized with the given name and value.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getName()
      Returns the name of this MimeHeader object.
      String getValue()
      Returns the value of this MimeHeader object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MimeHeader

        public MimeHeader(String name,
          String value)
        Constructs a MimeHeader object initialized with the given name and value.
        Parameters:
        name - a String giving the name of the header
        value - a String giving the value of the header

    • Method Detail

      • getName

        public String getName()
        Returns the name of this MimeHeader object.
        Returns:
        the name of the header as a String

      • getValue

        public String getValue()
        Returns the value of this MimeHeader object.
        Returns:
        the value of the header as a String
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MimeHeaders (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class MimeHeaders

  • java.lang.Object
    • javax.xml.soap.MimeHeaders

  • public class MimeHeaders
extends Object
    A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.

    This class is used primarily when an application wants to retrieve specific attachments based on certain MIME headers and values. This class will most likely be used by implementations of AttachmentPart and other MIME dependent parts of the SAAJ API.

    See Also:
    SOAPMessage.getAttachments(), AttachmentPart

    • Constructor Summary

      Constructors
      Constructor and Description
      MimeHeaders()
      Constructs a default MimeHeaders object initialized with an empty Vector object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addHeader(String name, String value)
      Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.
      Iterator getAllHeaders()
      Returns all the MimeHeaders in this MimeHeaders object.
      String[] getHeader(String name)
      Returns all of the values for the specified header as an array of String objects.
      Iterator getMatchingHeaders(String[] names)
      Returns all the MimeHeader objects whose name matches a name in the given array of names.
      Iterator getNonMatchingHeaders(String[] names)
      Returns all of the MimeHeader objects whose name does not match a name in the given array of names.
      void removeAllHeaders()
      Removes all the header entries from this MimeHeaders object.
      void removeHeader(String name)
      Remove all MimeHeader objects whose name matches the given name.
      void setHeader(String name, String value)
      Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MimeHeaders

        public MimeHeaders()
        Constructs a default MimeHeaders object initialized with an empty Vector object.

    • Method Detail

      • getHeader

        public String[] getHeader(String name)
        Returns all of the values for the specified header as an array of String objects.
        Parameters:
        name - the name of the header for which values will be returned
        Returns:
        a String array with all of the values for the specified header
        See Also:
        setHeader(java.lang.String, java.lang.String)

      • setHeader

        public void setHeader(String name,
             String value)
        Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches. This method also removes all matching headers after the first one.

        Note that RFC822 headers can contain only US-ASCII characters.

        Parameters:
        name - a String with the name of the header for which to search
        value - a String with the value that will replace the current value of the specified header
        Throws:
        IllegalArgumentException - if there was a problem in the mime header name or the value being set
        See Also:
        getHeader(java.lang.String)

      • addHeader

        public void addHeader(String name,
             String value)
        Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.

        Note that RFC822 headers can contain only US-ASCII characters.

        Parameters:
        name - a String with the name of the header to be added
        value - a String with the value of the header to be added
        Throws:
        IllegalArgumentException - if there was a problem in the mime header name or value being added

      • removeHeader

        public void removeHeader(String name)
        Remove all MimeHeader objects whose name matches the given name.
        Parameters:
        name - a String with the name of the header for which to search

      • removeAllHeaders

        public void removeAllHeaders()
        Removes all the header entries from this MimeHeaders object.

      • getAllHeaders

        public Iterator getAllHeaders()
        Returns all the MimeHeaders in this MimeHeaders object.
        Returns:
        an Iterator object over this MimeHeaders object's list of MimeHeader objects

      • getMatchingHeaders

        public Iterator getMatchingHeaders(String[] names)
        Returns all the MimeHeader objects whose name matches a name in the given array of names.
        Parameters:
        names - an array of String objects with the names for which to search
        Returns:
        an Iterator object over the MimeHeader objects whose name matches one of the names in the given list

      • getNonMatchingHeaders

        public Iterator getNonMatchingHeaders(String[] names)
        Returns all of the MimeHeader objects whose name does not match a name in the given array of names.
        Parameters:
        names - an array of String objects with the names for which to search
        Returns:
        an Iterator object over the MimeHeader objects whose name does not match one of the names in the given list
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Name (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface Name

  • public interface Name
    A representation of an XML name. This interface provides methods for getting the local and namespace-qualified names and also for getting the prefix associated with the namespace for the name. It is also possible to get the URI of the namespace.

    The following is an example of a namespace declaration in an element.

       <wombat:GetLastTradePrice xmlns:wombat="http://www.wombat.org/trader">
    ("xmlns" stands for "XML namespace".) The following shows what the methods in the Name interface will return.
    • getQualifiedName will return "prefix:LocalName" = "WOMBAT:GetLastTradePrice"
    • getURI will return "http://www.wombat.org/trader"
    • getLocalName will return "GetLastTracePrice"
    • getPrefix will return "WOMBAT"

    XML namespaces are used to disambiguate SOAP identifiers from application-specific identifiers.

    Name objects are created using the method SOAPEnvelope.createName, which has two versions. One method creates Name objects with a local name, a namespace prefix, and a namespace URI. and the second creates Name objects with just a local name. The following line of code, in which se is a SOAPEnvelope object, creates a new Name object with all three.

         Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");
    The following line of code gives an example of how a Name object can be used. The variable element is a SOAPElement object. This code creates a new SOAPElement object with the given name and adds it to element.
         element.addChildElement(name);

    The Name interface may be deprecated in a future release of SAAJ in favor of javax.xml.namespace.QName

    See Also:
    SOAPEnvelope.createName, SOAPFactory.createName

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getLocalName()
      Gets the local name part of the XML name that this Name object represents.
      String getPrefix()
      Returns the prefix that was specified when this Name object was initialized.
      String getQualifiedName()
      Gets the namespace-qualified name of the XML name that this Name object represents.
      String getURI()
      Returns the URI of the namespace for the XML name that this Name object represents.

    • Method Detail

      • getLocalName

        String getLocalName()
        Gets the local name part of the XML name that this Name object represents.
        Returns:
        a string giving the local name

      • getQualifiedName

        String getQualifiedName()
        Gets the namespace-qualified name of the XML name that this Name object represents.
        Returns:
        the namespace-qualified name as a string

      • getPrefix

        String getPrefix()
        Returns the prefix that was specified when this Name object was initialized. This prefix is associated with the namespace for the XML name that this Name object represents.
        Returns:
        the prefix as a string

      • getURI

        String getURI()
        Returns the URI of the namespace for the XML name that this Name object represents.
        Returns:
        the URI as a string
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Node (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface Node

  • All Superinterfaces:
    Node
    All Known Subinterfaces:
    Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text

    public interface Node
extends Node
    A representation of a node (element) in an XML document. This interface extnends the standard DOM Node interface with methods for getting and setting the value of a node, for getting and setting the parent of a node, and for removing a node.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void detachNode()
      Removes this Node object from the tree.
      SOAPElement getParentElement()
      Returns the parent element of this Node object.
      String getValue()
      Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise.
      void recycleNode()
      Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.
      void setParentElement(SOAPElement parent)
      Sets the parent of this Node object to the given SOAPElement object.
      void setValue(String value)
      If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getValue

        String getValue()
        Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise. If there is an immediate child of this Node that it is a Text node then it's value will be returned. If there is more than one Text node then the value of the first Text Node will be returned. Otherwise null is returned.
        Returns:
        a String with the text of this node if this is a Text node or the text contained by the first immediate child of this Node object that is a Text object if such a child exists; null otherwise.

      • setValue

        void setValue(String value)
        If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node. The value of the immediate child of this node can be set only if, there is one child node and that node is a Text node, or if there are no children in which case a child Text node will be created.
        Throws:
        IllegalStateException - if the node is not a Text node and either has more than one child node or has a child node that is not a Text node.
        Since:
        SAAJ 1.2

      • setParentElement

        void setParentElement(SOAPElement parent)
                      throws SOAPException
        Sets the parent of this Node object to the given SOAPElement object.
        Parameters:
        parent - the SOAPElement object to be set as the parent of this Node object
        Throws:
        SOAPException - if there is a problem in setting the parent to the given element
        See Also:
        getParentElement()

      • getParentElement

        SOAPElement getParentElement()
        Returns the parent element of this Node object. This method can throw an UnsupportedOperationException if the tree is not kept in memory.
        Returns:
        the SOAPElement object that is the parent of this Node object or null if this Node object is root
        Throws:
        UnsupportedOperationException - if the whole tree is not kept in memory
        See Also:
        setParentElement(javax.xml.soap.SOAPElement)

      • detachNode

        void detachNode()
        Removes this Node object from the tree.

      • recycleNode

        void recycleNode()
        Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.

        Calling the method recycleNode implies that the method detachNode has been called previously.

  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SAAJMetaFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SAAJMetaFactory

  • java.lang.Object
    • javax.xml.soap.SAAJMetaFactory

  • public abstract class SAAJMetaFactory
extends Object
    The access point for the implementation classes of the factories defined in the SAAJ API. All of the newInstance methods defined on factories in SAAJ 1.3 defer to instances of this class to do the actual object creation. The implementations of newInstance() methods (in SOAPFactory and MessageFactory) that existed in SAAJ 1.2 have been updated to also delegate to the SAAJMetaFactory when the SAAJ 1.2 defined lookup fails to locate the Factory implementation class name.

    SAAJMetaFactory is a service provider interface. There are no public methods on this class.

    Since:
    SAAJ 1.3
    Author:
    SAAJ RI Development Team

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | SAAJMetaFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      protected abstract MessageFactory newMessageFactory(String protocol)
      Creates a MessageFactory object for the given String protocol.
      protected abstract SOAPFactory newSOAPFactory(String protocol)
      Creates a SOAPFactory object for the given String protocol.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SAAJMetaFactory

        protected SAAJMetaFactory()

    • Method Detail

      • newMessageFactory

        protected abstract MessageFactory newMessageFactory(String protocol)
                                             throws SOAPException
        Creates a MessageFactory object for the given String protocol.
        Parameters:
        protocol - a String indicating the protocol
        Throws:
        SOAPException - if there is an error in creating the MessageFactory
        See Also:
        SOAPConstants.SOAP_1_1_PROTOCOL, SOAPConstants.SOAP_1_2_PROTOCOL, SOAPConstants.DYNAMIC_SOAP_PROTOCOL

      • newSOAPFactory

        protected abstract SOAPFactory newSOAPFactory(String protocol)
                                       throws SOAPException
        Creates a SOAPFactory object for the given String protocol.
        Parameters:
        protocol - a String indicating the protocol
        Throws:
        SOAPException - if there is an error in creating the SOAPFactory
        See Also:
        SOAPConstants.SOAP_1_1_PROTOCOL, SOAPConstants.SOAP_1_2_PROTOCOL, SOAPConstants.DYNAMIC_SOAP_PROTOCOL
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SAAJResult (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SAAJResult

  • java.lang.Object
    • javax.xml.transform.dom.DOMResult
      • javax.xml.soap.SAAJResult
  • All Implemented Interfaces:
    Result

    public class SAAJResult
extends DOMResult
    Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree. These results should be accessed by using the getResult() method. The DOMResult.getNode() method should be avoided in almost all cases.
    Since:
    SAAJ 1.3
    Author:
    XWS-Security Development Team

    • Field Summary

      • Fields inherited from class javax.xml.transform.dom.DOMResult

        FEATURE

      • Fields inherited from interface javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • Constructor Summary

      Constructors
      Constructor and Description
      SAAJResult()
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.
      SAAJResult(SOAPElement rootNode)
      Creates a SAAJResult that will write the results as a child node of the SOAPElement specified.
      SAAJResult(SOAPMessage message)
      Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage.
      SAAJResult(String protocol)
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Node getResult()

      • Methods inherited from class javax.xml.transform.dom.DOMResult

        getNextSibling, getNode, getSystemId, setNextSibling, setNode, setSystemId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SAAJResult

        public SAAJResult()
           throws SOAPException
        Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.

        This kind of SAAJResult is meant for use in situations where the results will be used as a parameter to a method that takes a parameter whose type, such as SOAPElement, is drawn from the SAAJ API. When used in a transformation, the results are populated into the SOAPPart of a SOAPMessage that is created internally. The SOAPPart returned by DOMResult.getNode() is not guaranteed to be well-formed.

        Throws:
        SOAPException - if there is a problem creating a SOAPMessage
        Since:
        SAAJ 1.3

      • SAAJResult

        public SAAJResult(String protocol)
           throws SOAPException
        Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol. The DYNAMIC_SOAP_PROTOCOL is ambiguous in this context and will cause this constructor to throw an UnsupportedOperationException.

        This kind of SAAJResult is meant for use in situations where the results will be used as a parameter to a method that takes a parameter whose type, such as SOAPElement, is drawn from the SAAJ API. When used in a transformation the results are populated into the SOAPPart of a SOAPMessage that is created internally. The SOAPPart returned by DOMResult.getNode() is not guaranteed to be well-formed.

        Parameters:
        protocol - - the name of the SOAP protocol that the resulting SAAJ tree should support
        Throws:
        SOAPException - if a SOAPMessage supporting the specified protocol cannot be created
        Since:
        SAAJ 1.3

      • SAAJResult

        public SAAJResult(SOAPMessage message)
        Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage. In the normal case these results will be written using DOM APIs and, as a result, the finished SOAPPart will not be guaranteed to be well-formed unless the data used to create it is also well formed. When used in a transformation the validity of the SOAPMessage after the transformation can be guaranteed only by means outside SAAJ specification.
        Parameters:
        message - - the message whose SOAPPart will be populated as a result of some transformation or marshalling operation
        Since:
        SAAJ 1.3

      • SAAJResult

        public SAAJResult(SOAPElement rootNode)
        Creates a SAAJResult that will write the results as a child node of the SOAPElement specified. In the normal case these results will be written using DOM APIs and as a result may invalidate the structure of the SAAJ tree. This kind of SAAJResult should only be used when the validity of the incoming data can be guaranteed by means outside of the SAAJ specification.
        Parameters:
        rootNode - - the root to which the results will be appended
        Since:
        SAAJ 1.3

    • Method Detail

      • getResult

        public Node getResult()
        Returns:
        the resulting Tree that was created under the specified root Node.
        Since:
        SAAJ 1.3
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPBody (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPBody

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPBody
extends SOAPElement
    An object that represents the contents of the SOAP body element in a SOAP message. A SOAP body element consists of XML data that affects the way the application-specific content is processed.

    A SOAPBody object contains SOAPBodyElement objects, which have the content for the SOAP body. A SOAPFault object, which carries status and/or error information, is an example of a SOAPBodyElement object.

    See Also:
    SOAPFault

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      SOAPBodyElement addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPBodyElement addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPBodyElement addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.
      SOAPFault addFault()
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      Document extractContentAsDocument()
      Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
      SOAPFault getFault()
      Returns the SOAPFault object in this SOAPBody object.
      boolean hasFault()
      Indicates whether a SOAPFault object exists in this SOAPBody object.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • addFault

        SOAPFault addFault()
                   throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The new SOAPFault will have default values set for the mandatory child elements. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        A SOAPBody may contain at most one SOAPFault child element.

        Returns:
        the new SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error

      • addFault

        SOAPFault addFault(Name faultCode,
                 String faultString,
                 Locale locale)
                   throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        A SOAPBody may contain at most one SOAPFault child element.

        Parameters:
        faultCode - a Name object giving the fault code to be set; must be one of the fault codes defined in the Version of SOAP specification in use
        faultString - a String giving an explanation of the fault
        locale - a Locale object indicating the native language of the faultString
        Returns:
        the new SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.2
        See Also:
        SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

      • addFault

        SOAPFault addFault(QName faultCode,
                 String faultString,
                 Locale locale)
                   throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        A SOAPBody may contain at most one SOAPFault child element.

        Parameters:
        faultCode - a QName object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use.
        faultString - a String giving an explanation of the fault
        locale - a Locale object indicating the native language of the faultString
        Returns:
        the new SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.3
        See Also:
        SOAPFault.setFaultCode(javax.xml.soap.Name),
SOAPFault.setFaultString(java.lang.String),
addFault(Name faultCode, String faultString, Locale locale)

      • addFault

        SOAPFault addFault(Name faultCode,
                 String faultString)
                   throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        In case of a SOAP 1.2 fault, the default value for the mandatory xml:lang attribute on the Fault/Reason/Text element will be set to java.util.Locale.getDefault()

        A SOAPBody may contain at most one SOAPFault child element.

        Parameters:
        faultCode - a Name object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use
        faultString - a String giving an explanation of the fault
        Returns:
        the new SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.2
        See Also:
        SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

      • addFault

        SOAPFault addFault(QName faultCode,
                 String faultString)
                   throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        In case of a SOAP 1.2 fault, the default value for the mandatory xml:lang attribute on the Fault/Reason/Text element will be set to java.util.Locale.getDefault()

        A SOAPBody may contain at most one SOAPFault child element

        Parameters:
        faultCode - a QName object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use
        faultString - a String giving an explanation of the fault
        Returns:
        the new SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.3
        See Also:
        SOAPFault.setFaultCode(javax.xml.soap.Name),
SOAPFault.setFaultString(java.lang.String),
addFault(Name faultCode, String faultString)

      • hasFault

        boolean hasFault()
        Indicates whether a SOAPFault object exists in this SOAPBody object.
        Returns:
        true if a SOAPFault object exists in this SOAPBody object; false otherwise

      • getFault

        SOAPFault getFault()
        Returns the SOAPFault object in this SOAPBody object.
        Returns:
        the SOAPFault object in this SOAPBody object if present, null otherwise.

      • addBodyElement

        SOAPBodyElement addBodyElement(Name name)
                               throws SOAPException
        Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
        Parameters:
        name - a Name object with the name for the new SOAPBodyElement object
        Returns:
        the new SOAPBodyElement object
        Throws:
        SOAPException - if a SOAP error occurs
        See Also:
        addBodyElement(javax.xml.namespace.QName)

      • addBodyElement

        SOAPBodyElement addBodyElement(QName qname)
                               throws SOAPException
        Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
        Parameters:
        qname - a QName object with the qname for the new SOAPBodyElement object
        Returns:
        the new SOAPBodyElement object
        Throws:
        SOAPException - if a SOAP error occurs
        Since:
        SAAJ 1.3
        See Also:
        addBodyElement(Name)

      • addDocument

        SOAPBodyElement addDocument(Document document)
                            throws SOAPException
        Adds the root node of the DOM Document to this SOAPBody object.

        Calling this method invalidates the document parameter. The client application should discard all references to this Document and its contents upon calling addDocument. The behavior of an application that continues to use such references is undefined.

        Parameters:
        document - the Document object whose root node will be added to this SOAPBody.
        Returns:
        the SOAPBodyElement that represents the root node that was added.
        Throws:
        SOAPException - if the Document cannot be added
        Since:
        SAAJ 1.2

      • extractContentAsDocument

        Document extractContentAsDocument()
                                  throws SOAPException
        Creates a new DOM Document and sets the first child of this SOAPBody as it's document element. The child SOAPElement is removed as part of the process.
        Returns:
        the Document representation of the SOAPBody content.
        Throws:
        SOAPException - if there is not exactly one child SOAPElement of the SOAPBody.
        Since:
        SAAJ 1.3
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPBodyElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPBodyElement

  • All Superinterfaces:
    Element, Node, SOAPElement
    All Known Subinterfaces:
    SOAPFault

    public interface SOAPBodyElement
extends SOAPElement
    A SOAPBodyElement object represents the contents in a SOAPBody object. The SOAPFault interface is a SOAPBodyElement object that has been defined.

    A new SOAPBodyElement object can be created and added to a SOAPBody object with the SOAPBody method addBodyElement. In the following line of code, sb is a SOAPBody object, and myName is a Name object.

        SOAPBodyElement sbe = sb.addBodyElement(myName);

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPConnection (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPConnection

  • java.lang.Object
    • javax.xml.soap.SOAPConnection

  • public abstract class SOAPConnection
extends Object
    A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).

    The SOAPConnection class is optional. Some implementations may not implement this interface in which case the call to SOAPConnectionFactory.newInstance() (see below) will throw an UnsupportedOperationException.

    A client can obtain a SOAPConnection object using a SOAPConnectionFactory object as in the following example:

          SOAPConnectionFactory factory = SOAPConnectionFactory.newInstance();
      SOAPConnection con = factory.createConnection();
    A SOAPConnection object can be used to send messages directly to a URL following the request/response paradigm. That is, messages are sent using the method call, which sends the message and then waits until it gets a reply.

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPConnection()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract SOAPMessage call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      abstract void close()
      Closes this SOAPConnection object.
      SOAPMessage get(Object to)
      Gets a message from a specific endpoint and blocks until it receives,

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SOAPConnection

        public SOAPConnection()

    • Method Detail

      • call

        public abstract SOAPMessage call(SOAPMessage request,
               Object to)
                          throws SOAPException
        Sends the given message to the specified endpoint and blocks until it has returned the response.
        Parameters:
        request - the SOAPMessage object to be sent
        to - an Object that identifies where the message should be sent. It is required to support Objects of type java.lang.String, java.net.URL, and when JAXM is present javax.xml.messaging.URLEndpoint
        Returns:
        the SOAPMessage object that is the response to the message that was sent
        Throws:
        SOAPException - if there is a SOAP error

      • get

        public SOAPMessage get(Object to)
                throws SOAPException
        Gets a message from a specific endpoint and blocks until it receives,
        Parameters:
        to - an Object that identifies where the request should be sent. Objects of type java.lang.String and java.net.URL must be supported.
        Returns:
        the SOAPMessage object that is the response to the get message request
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.3

      • close

        public abstract void close()
                    throws SOAPException
        Closes this SOAPConnection object.
        Throws:
        SOAPException - if there is a SOAP error
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPConnectionFactory

  • java.lang.Object
    • javax.xml.soap.SOAPConnectionFactory

  • public abstract class SOAPConnectionFactory
extends Object
    A factory for creating SOAPConnection objects. Implementation of this class is optional. If SOAPConnectionFactory.newInstance() throws an UnsupportedOperationException then the implementation does not support the SAAJ communication infrastructure. Otherwise SOAPConnection objects can be created by calling createConnection() on the newly created SOAPConnectionFactory object.

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPConnectionFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract SOAPConnection createConnection()
      Create a new SOAPConnection.
      static SOAPConnectionFactory newInstance()
      Creates an instance of the default SOAPConnectionFactory object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SOAPConnectionFactory

        public SOAPConnectionFactory()

    • Method Detail

      • newInstance

        public static SOAPConnectionFactory newInstance()
                                         throws SOAPException,
                                                UnsupportedOperationException
        Creates an instance of the default SOAPConnectionFactory object.
        Returns:
        a new instance of a default SOAPConnectionFactory object
        Throws:
        SOAPException - if there was an error creating the SOAPConnectionFactory
        UnsupportedOperationException - if newInstance is not supported.

      • createConnection

        public abstract SOAPConnection createConnection()
                                         throws SOAPException
        Create a new SOAPConnection.
        Returns:
        the new SOAPConnection object.
        Throws:
        SOAPException - if there was an exception creating the SOAPConnection object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPConstants (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPConstants

  • public interface SOAPConstants
    The definition of constants pertaining to the SOAP protocol.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DEFAULT_SOAP_PROTOCOL
      The default protocol: SOAP 1.1 for backwards compatibility.
      static String DYNAMIC_SOAP_PROTOCOL
      Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method.
      static String SOAP_1_1_CONTENT_TYPE
      The media type of the Content-Type MIME header in SOAP 1.1.
      static String SOAP_1_1_PROTOCOL
      Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.1 specification.
      static String SOAP_1_2_CONTENT_TYPE
      The media type of the Content-Type MIME header in SOAP 1.2.
      static String SOAP_1_2_PROTOCOL
      Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.2 specification
      static QName SOAP_DATAENCODINGUNKNOWN_FAULT
      SOAP 1.2 DataEncodingUnknown Fault
      static String SOAP_ENV_PREFIX
      The default namespace prefix for http://www.w3.org/2003/05/soap-envelope
      static QName SOAP_MUSTUNDERSTAND_FAULT
      SOAP 1.2 MustUnderstand Fault
      static QName SOAP_RECEIVER_FAULT
      SOAP 1.2 Receiver Fault
      static QName SOAP_SENDER_FAULT
      SOAP 1.2 Sender Fault
      static QName SOAP_VERSIONMISMATCH_FAULT
      SOAP 1.2 VersionMismatch Fault
      static String URI_NS_SOAP_1_1_ENVELOPE
      The namespace identifier for the SOAP 1.1 envelope.
      static String URI_NS_SOAP_1_2_ENCODING
      The namespace identifier for the SOAP 1.2 encoding.
      static String URI_NS_SOAP_1_2_ENVELOPE
      The namespace identifier for the SOAP 1.2 envelope.
      static String URI_NS_SOAP_ENCODING
      The namespace identifier for the SOAP 1.1 encoding.
      static String URI_NS_SOAP_ENVELOPE
      The namespace identifier for the SOAP 1.1 envelope, All SOAPElements in this namespace are defined by the SOAP 1.1 specification.
      static String URI_SOAP_1_2_ROLE_NEXT
      The URI identifying the next application processing a SOAP request as the intended role for a SOAP 1.2 header entry (see section 2.2 of part 1 of the SOAP 1.2 specification).
      static String URI_SOAP_1_2_ROLE_NONE
      The URI specifying the role None in SOAP 1.2.
      static String URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER
      The URI identifying the ultimate receiver of the SOAP 1.2 message.
      static String URI_SOAP_ACTOR_NEXT
      The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

    • Field Detail

      • DYNAMIC_SOAP_PROTOCOL

        static final String DYNAMIC_SOAP_PROTOCOL
        Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method. If no Content-Type header is passed then the createMessage may throw an IllegalArgumentException or, in the case of the no argument version of createMessage, an UnsupportedOperationException.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_1_1_PROTOCOL

        static final String SOAP_1_1_PROTOCOL
        Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.1 specification.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_1_2_PROTOCOL

        static final String SOAP_1_2_PROTOCOL
        Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.2 specification
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • DEFAULT_SOAP_PROTOCOL

        static final String DEFAULT_SOAP_PROTOCOL
        The default protocol: SOAP 1.1 for backwards compatibility.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_NS_SOAP_1_1_ENVELOPE

        static final String URI_NS_SOAP_1_1_ENVELOPE
        The namespace identifier for the SOAP 1.1 envelope.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_NS_SOAP_1_2_ENVELOPE

        static final String URI_NS_SOAP_1_2_ENVELOPE
        The namespace identifier for the SOAP 1.2 envelope.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_NS_SOAP_ENVELOPE

        static final String URI_NS_SOAP_ENVELOPE
        The namespace identifier for the SOAP 1.1 envelope, All SOAPElements in this namespace are defined by the SOAP 1.1 specification.
        See Also:
        Constant Field Values

      • URI_NS_SOAP_ENCODING

        static final String URI_NS_SOAP_ENCODING
        The namespace identifier for the SOAP 1.1 encoding. An attribute named encodingStyle in the URI_NS_SOAP_ENVELOPE namespace and set to the value URI_NS_SOAP_ENCODING can be added to an element to indicate that it is encoded using the rules in section 5 of the SOAP 1.1 specification.
        See Also:
        Constant Field Values

      • URI_NS_SOAP_1_2_ENCODING

        static final String URI_NS_SOAP_1_2_ENCODING
        The namespace identifier for the SOAP 1.2 encoding.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_1_1_CONTENT_TYPE

        static final String SOAP_1_1_CONTENT_TYPE
        The media type of the Content-Type MIME header in SOAP 1.1.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_1_2_CONTENT_TYPE

        static final String SOAP_1_2_CONTENT_TYPE
        The media type of the Content-Type MIME header in SOAP 1.2.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_SOAP_ACTOR_NEXT

        static final String URI_SOAP_ACTOR_NEXT
        The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

        This value can be passed to
SOAPHeader.examineMustUnderstandHeaderElements(String),
SOAPHeader.examineHeaderElements(String) and
SOAPHeader.extractHeaderElements(String)

        See Also:
        Constant Field Values

      • URI_SOAP_1_2_ROLE_NEXT

        static final String URI_SOAP_1_2_ROLE_NEXT
        The URI identifying the next application processing a SOAP request as the intended role for a SOAP 1.2 header entry (see section 2.2 of part 1 of the SOAP 1.2 specification).
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_SOAP_1_2_ROLE_NONE

        static final String URI_SOAP_1_2_ROLE_NONE
        The URI specifying the role None in SOAP 1.2.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER

        static final String URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER
        The URI identifying the ultimate receiver of the SOAP 1.2 message.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_ENV_PREFIX

        static final String SOAP_ENV_PREFIX
        The default namespace prefix for http://www.w3.org/2003/05/soap-envelope
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_VERSIONMISMATCH_FAULT

        static final QName SOAP_VERSIONMISMATCH_FAULT
        SOAP 1.2 VersionMismatch Fault
        Since:
        SAAJ 1.3

      • SOAP_MUSTUNDERSTAND_FAULT

        static final QName SOAP_MUSTUNDERSTAND_FAULT
        SOAP 1.2 MustUnderstand Fault
        Since:
        SAAJ 1.3

      • SOAP_DATAENCODINGUNKNOWN_FAULT

        static final QName SOAP_DATAENCODINGUNKNOWN_FAULT
        SOAP 1.2 DataEncodingUnknown Fault
        Since:
        SAAJ 1.3

      • SOAP_SENDER_FAULT

        static final QName SOAP_SENDER_FAULT
        SOAP 1.2 Sender Fault
        Since:
        SAAJ 1.3

      • SOAP_RECEIVER_FAULT

        static final QName SOAP_RECEIVER_FAULT
        SOAP 1.2 Receiver Fault
        Since:
        SAAJ 1.3
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPElement

  • All Superinterfaces:
    Element, Node
    All Known Subinterfaces:
    Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement

    public interface SOAPElement
extends Node, Element
    An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification. This interface serves as the base interface for those objects that are specifically prescribed by a SOAP specification.

    Methods in this interface that are required to return SAAJ specific objects may "silently" replace nodes in the tree as required to successfully return objects of the correct type. See getChildElements() and javax.xml.soap for details.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      SOAPElement addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      SOAPElement addChildElement(String localName)
      Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(String localName, String prefix)
      Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
      SOAPElement addNamespaceDeclaration(String prefix, String uri)
      Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
      SOAPElement addTextNode(String text)
      Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
      QName createQName(String localName, String prefix)
      Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
      Iterator getAllAttributes()
      Returns an Iterator over all of the attribute Name objects in this SOAPElement object.
      Iterator getAllAttributesAsQNames()
      Returns an Iterator over all of the attributes in this SOAPElement as QName objects.
      String getAttributeValue(Name name)
      Returns the value of the attribute with the specified name.
      String getAttributeValue(QName qname)
      Returns the value of the attribute with the specified qname.
      Iterator getChildElements()
      Returns an Iterator over all the immediate child Nodes of this element.
      Iterator getChildElements(Name name)
      Returns an Iterator over all the immediate child Nodes of this element with the specified name.
      Iterator getChildElements(QName qname)
      Returns an Iterator over all the immediate child Nodes of this element with the specified qname.
      Name getElementName()
      Returns the name of this SOAPElement object.
      QName getElementQName()
      Returns the qname of this SOAPElement object.
      String getEncodingStyle()
      Returns the encoding style for this SOAPElement object.
      Iterator getNamespacePrefixes()
      Returns an Iterator over the namespace prefix Strings declared by this element.
      String getNamespaceURI(String prefix)
      Returns the URI of the namespace that has the given prefix.
      Iterator getVisibleNamespacePrefixes()
      Returns an Iterator over the namespace prefix Strings visible to this element.
      boolean removeAttribute(Name name)
      Removes the attribute with the specified name.
      boolean removeAttribute(QName qname)
      Removes the attribute with the specified qname.
      void removeContents()
      Detaches all children of this SOAPElement.
      boolean removeNamespaceDeclaration(String prefix)
      Removes the namespace declaration corresponding to the given prefix.
      SOAPElement setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      void setEncodingStyle(String encodingStyle)
      Sets the encoding style for this SOAPElement object to one specified.

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • addChildElement

        SOAPElement addChildElement(Name name)
                            throws SOAPException
        Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.

        This method may be deprecated in a future release of SAAJ in favor of addChildElement(javax.xml.namespace.QName)

        Parameters:
        name - a Name object with the XML name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        See Also:
        addChildElement(javax.xml.namespace.QName)

      • addChildElement

        SOAPElement addChildElement(QName qname)
                            throws SOAPException
        Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object. The namespace, localname and prefix of the new SOAPElement are all taken from the qname argument.
        Parameters:
        qname - a QName object with the XML name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        Since:
        SAAJ 1.3
        See Also:
        addChildElement(Name)

      • addChildElement

        SOAPElement addChildElement(String localName)
                            throws SOAPException
        Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object. The new SOAPElement inherits any in-scope default namespace.
        Parameters:
        localName - a String giving the local name for the element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object

      • addChildElement

        SOAPElement addChildElement(String localName,
                          String prefix)
                            throws SOAPException
        Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
        Parameters:
        localName - a String giving the local name for the new element
        prefix - a String giving the namespace prefix for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if the prefix is not valid in the context of this SOAPElement or if there is an error in creating the SOAPElement object

      • addChildElement

        SOAPElement addChildElement(String localName,
                          String prefix,
                          String uri)
                            throws SOAPException
        Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
        Parameters:
        localName - a String giving the local name for the new element
        prefix - a String giving the namespace prefix for the new element
        uri - a String giving the URI of the namespace to which the new element belongs
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object

      • addChildElement

        SOAPElement addChildElement(SOAPElement element)
                            throws SOAPException
        Add a SOAPElement as a child of this SOAPElement instance. The SOAPElement is expected to be created by a SOAPFactory. Callers should not rely on the element instance being added as is into the XML tree. Implementations could end up copying the content of the SOAPElement passed into an instance of a different SOAPElement implementation. For instance if addChildElement() is called on a SOAPHeader, element will be copied into an instance of a SOAPHeaderElement.

        The fragment rooted in element is either added as a whole or not at all, if there was an error.

        The fragment rooted in element cannot contain elements named "Envelope", "Header" or "Body" and in the SOAP namespace. Any namespace prefixes present in the fragment should be fully resolved using appropriate namespace declarations within the fragment itself.

        Parameters:
        element - the SOAPElement to be added as a new child
        Returns:
        an instance representing the new SOAP element that was actually added to the tree.
        Throws:
        SOAPException - if there was an error in adding this element as a child

      • removeContents

        void removeContents()
        Detaches all children of this SOAPElement.

        This method is useful for rolling back the construction of partially completed SOAPHeaders and SOAPBodys in preparation for sending a fault when an error condition is detected. It is also useful for recycling portions of a document within a SOAP message.

        Since:
        SAAJ 1.2

      • addTextNode

        SOAPElement addTextNode(String text)
                        throws SOAPException
        Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
        Parameters:
        text - a String object with the textual content to be added
        Returns:
        the SOAPElement object into which the new Text object was inserted
        Throws:
        SOAPException - if there is an error in creating the new Text object or if it is not legal to attach it as a child to this SOAPElement

      • addAttribute

        SOAPElement addAttribute(Name name,
                       String value)
                         throws SOAPException
        Adds an attribute with the specified name and value to this SOAPElement object.
        Parameters:
        name - a Name object with the name of the attribute
        value - a String giving the value of the attribute
        Returns:
        the SOAPElement object into which the attribute was inserted
        Throws:
        SOAPException - if there is an error in creating the Attribute, or it is invalid to set an attribute with Name name on this SOAPElement.
        See Also:
        addAttribute(javax.xml.namespace.QName, String)

      • addAttribute

        SOAPElement addAttribute(QName qname,
                       String value)
                         throws SOAPException
        Adds an attribute with the specified name and value to this SOAPElement object.
        Parameters:
        qname - a QName object with the name of the attribute
        value - a String giving the value of the attribute
        Returns:
        the SOAPElement object into which the attribute was inserted
        Throws:
        SOAPException - if there is an error in creating the Attribute, or it is invalid to set an attribute with QName qname on this SOAPElement.
        Since:
        SAAJ 1.3
        See Also:
        addAttribute(Name, String)

      • addNamespaceDeclaration

        SOAPElement addNamespaceDeclaration(String prefix,
                                  String uri)
                                    throws SOAPException
        Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
        Parameters:
        prefix - a String giving the prefix of the namespace
        uri - a String giving the uri of the namespace
        Returns:
        the SOAPElement object into which this namespace declaration was inserted.
        Throws:
        SOAPException - if there is an error in creating the namespace

      • getAttributeValue

        String getAttributeValue(Name name)
        Returns the value of the attribute with the specified name.
        Parameters:
        name - a Name object with the name of the attribute
        Returns:
        a String giving the value of the specified attribute, Null if there is no such attribute
        See Also:
        getAttributeValue(javax.xml.namespace.QName)

      • getAttributeValue

        String getAttributeValue(QName qname)
        Returns the value of the attribute with the specified qname.
        Parameters:
        qname - a QName object with the qname of the attribute
        Returns:
        a String giving the value of the specified attribute, Null if there is no such attribute
        Since:
        SAAJ 1.3
        See Also:
        getAttributeValue(Name)

      • getAllAttributes

        Iterator getAllAttributes()
        Returns an Iterator over all of the attribute Name objects in this SOAPElement object. The iterator can be used to get the attribute names, which can then be passed to the method getAttributeValue to retrieve the value of each attribute.
        Returns:
        an iterator over the names of the attributes
        See Also:
        getAllAttributesAsQNames()

      • getAllAttributesAsQNames

        Iterator getAllAttributesAsQNames()
        Returns an Iterator over all of the attributes in this SOAPElement as QName objects. The iterator can be used to get the attribute QName, which can then be passed to the method getAttributeValue to retrieve the value of each attribute.
        Returns:
        an iterator over the QNames of the attributes
        Since:
        SAAJ 1.3
        See Also:
        getAllAttributes()

      • getNamespaceURI

        String getNamespaceURI(String prefix)
        Returns the URI of the namespace that has the given prefix.
        Parameters:
        prefix - a String giving the prefix of the namespace for which to search
        Returns:
        a String with the uri of the namespace that has the given prefix

      • getNamespacePrefixes

        Iterator getNamespacePrefixes()
        Returns an Iterator over the namespace prefix Strings declared by this element. The prefixes returned by this iterator can be passed to the method getNamespaceURI to retrieve the URI of each namespace.
        Returns:
        an iterator over the namespace prefixes in this SOAPElement object

      • getVisibleNamespacePrefixes

        Iterator getVisibleNamespacePrefixes()
        Returns an Iterator over the namespace prefix Strings visible to this element. The prefixes returned by this iterator can be passed to the method getNamespaceURI to retrieve the URI of each namespace.
        Returns:
        an iterator over the namespace prefixes are within scope of this SOAPElement object
        Since:
        SAAJ 1.2

      • createQName

        QName createQName(String localName,
                String prefix)
                  throws SOAPException
        Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement. The remaining elements of the new QName are taken directly from the parameters, localName and prefix.
        Parameters:
        localName - a String containing the local part of the name.
        prefix - a String containing the prefix for the name.
        Returns:
        a QName with the specified localName and prefix, and with a namespace that is associated with the prefix in the context of this SOAPElement. This namespace will be the same as the one that would be returned by getNamespaceURI(String) if it were given prefix as it's parameter.
        Throws:
        SOAPException - if the QName cannot be created.
        Since:
        SAAJ 1.3

      • getElementName

        Name getElementName()
        Returns the name of this SOAPElement object.
        Returns:
        a Name object with the name of this SOAPElement object

      • getElementQName

        QName getElementQName()
        Returns the qname of this SOAPElement object.
        Returns:
        a QName object with the qname of this SOAPElement object
        Since:
        SAAJ 1.3
        See Also:
        getElementName()

      • setElementQName

        SOAPElement setElementQName(QName newName)
                            throws SOAPException
        Changes the name of this Element to newName if possible. SOAP Defined elements such as SOAPEnvelope, SOAPHeader, SOAPBody etc. cannot have their names changed using this method. Any attempt to do so will result in a SOAPException being thrown.

        Callers should not rely on the element instance being renamed as is. Implementations could end up copying the content of the SOAPElement to a renamed instance.

        Parameters:
        newName - the new name for the Element.
        Returns:
        The renamed Node
        Throws:
        SOAPException - if changing the name of this Element is not allowed.
        Since:
        SAAJ 1.3

      • removeAttribute

        boolean removeAttribute(Name name)
        Removes the attribute with the specified name.
        Parameters:
        name - the Name object with the name of the attribute to be removed
        Returns:
        true if the attribute was removed successfully; false if it was not
        See Also:
        removeAttribute(javax.xml.namespace.QName)

      • removeAttribute

        boolean removeAttribute(QName qname)
        Removes the attribute with the specified qname.
        Parameters:
        qname - the QName object with the qname of the attribute to be removed
        Returns:
        true if the attribute was removed successfully; false if it was not
        Since:
        SAAJ 1.3
        See Also:
        removeAttribute(Name)

      • removeNamespaceDeclaration

        boolean removeNamespaceDeclaration(String prefix)
        Removes the namespace declaration corresponding to the given prefix.
        Parameters:
        prefix - a String giving the prefix for which to search
        Returns:
        true if the namespace declaration was removed successfully; false if it was not

      • getChildElements

        Iterator getChildElements()
        Returns an Iterator over all the immediate child Nodes of this element. This includes javax.xml.soap.Text objects as well as SOAPElement objects.

        Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

        Returns:
        an iterator with the content of this SOAPElement object

      • getChildElements

        Iterator getChildElements(Name name)
        Returns an Iterator over all the immediate child Nodes of this element with the specified name. All of these children will be SOAPElement nodes.

        Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

        Parameters:
        name - a Name object with the name of the child elements to be returned
        Returns:
        an Iterator object over all the elements in this SOAPElement object with the specified name
        See Also:
        getChildElements(javax.xml.namespace.QName)

      • getChildElements

        Iterator getChildElements(QName qname)
        Returns an Iterator over all the immediate child Nodes of this element with the specified qname. All of these children will be SOAPElement nodes.

        Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

        Parameters:
        qname - a QName object with the qname of the child elements to be returned
        Returns:
        an Iterator object over all the elements in this SOAPElement object with the specified qname
        Since:
        SAAJ 1.3
        See Also:
        getChildElements(Name)

      • setEncodingStyle

        void setEncodingStyle(String encodingStyle)
                      throws SOAPException
        Sets the encoding style for this SOAPElement object to one specified.
        Parameters:
        encodingStyle - a String giving the encoding style
        Throws:
        IllegalArgumentException - if there was a problem in the encoding style being set.
        SOAPException - if setting the encodingStyle is invalid for this SOAPElement.
        See Also:
        getEncodingStyle()

      • getEncodingStyle

        String getEncodingStyle()
        Returns the encoding style for this SOAPElement object.
        Returns:
        a String giving the encoding style
        See Also:
        setEncodingStyle(java.lang.String)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPElementFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPElementFactory

  • java.lang.Object
    • javax.xml.soap.SOAPElementFactory
  • Deprecated.
    - Use javax.xml.soap.SOAPFactory for creating SOAPElements.

    public class SOAPElementFactory
extends Object
    SOAPElementFactory is a factory for XML fragments that will eventually end up in the SOAP part. These fragments can be inserted as children of the SOAPHeader or SOAPBody or SOAPEnvelope.

    Elements created using this factory do not have the properties of an element that lives inside a SOAP header document. These elements are copied into the XML document tree when they are inserted.

    See Also:
    SOAPFactory

    • Method Summary

      Methods
      Modifier and Type Method and Description
      SOAPElement create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      SOAPElement create(String localName)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
      SOAPElement create(String localName, String prefix, String uri)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
      static SOAPElementFactory newInstance()
      Deprecated.
      Creates a new instance of SOAPElementFactory.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • create

        public SOAPElement create(Name name)
                   throws SOAPException
        Deprecated. Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
        Create a SOAPElement object initialized with the given Name object.
        Parameters:
        name - a Name object with the XML name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        See Also:
        SOAPFactory.createElement(javax.xml.soap.Name), SOAPFactory.createElement(javax.xml.namespace.QName)

      • create

        public SOAPElement create(String localName)
                   throws SOAPException
        Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
        Create a SOAPElement object initialized with the given local name.
        Parameters:
        localName - a String giving the local name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        See Also:
        SOAPFactory.createElement(java.lang.String)

      • create

        public SOAPElement create(String localName,
                 String prefix,
                 String uri)
                   throws SOAPException
        Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
        Create a new SOAPElement object with the given local name, prefix and uri.
        Parameters:
        localName - a String giving the local name for the new element
        prefix - the prefix for this SOAPElement
        uri - a String giving the URI of the namespace to which the new element belongs
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        See Also:
        SOAPFactory.createElement(java.lang.String, java.lang.String, java.lang.String)

      • newInstance

        public static SOAPElementFactory newInstance()
                                      throws SOAPException
        Deprecated.
        Creates a new instance of SOAPElementFactory.
        Returns:
        a new instance of a SOAPElementFactory
        Throws:
        SOAPException - if there was an error creating the default SOAPElementFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPEnvelope (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPEnvelope

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPEnvelope
extends SOAPElement
    The container for the SOAPHeader and SOAPBody portions of a SOAPPart object. By default, a SOAPMessage object is created with a SOAPPart object that has a SOAPEnvelope object. The SOAPEnvelope object by default has an empty SOAPBody object and an empty SOAPHeader object. The SOAPBody object is required, and the SOAPHeader object, though optional, is used in the majority of cases. If the SOAPHeader object is not needed, it can be deleted, which is shown later.

    A client can access the SOAPHeader and SOAPBody objects by calling the methods SOAPEnvelope.getHeader and SOAPEnvelope.getBody. The following lines of code use these two methods after starting with the SOAPMessage object message to get the SOAPPart object sp, which is then used to get the SOAPEnvelope object se.

         SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     SOAPHeader sh = se.getHeader();
     SOAPBody sb = se.getBody();

    It is possible to change the body or header of a SOAPEnvelope object by retrieving the current one, deleting it, and then adding a new body or header. The javax.xml.soap.Node method deleteNode deletes the XML element (node) on which it is called. For example, the following line of code deletes the SOAPBody object that is retrieved by the method getBody.

          se.getBody().detachNode();
    To create a SOAPHeader object to replace the one that was removed, a client uses the method SOAPEnvelope.addHeader, which creates a new header and adds it to the SOAPEnvelope object. Similarly, the method addBody creates a new SOAPBody object and adds it to the SOAPEnvelope object. The following code fragment retrieves the current header, removes it, and adds a new one. Then it retrieves the current body, removes it, and adds a new one.
         SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     se.getHeader().detachNode();
     SOAPHeader sh = se.addHeader();
     se.getBody().detachNode();
     SOAPBody sb = se.addBody();
    It is an error to add a SOAPBody or SOAPHeader object if one already exists.

    The SOAPEnvelope interface provides three methods for creating Name objects. One method creates Name objects with a local name, a namespace prefix, and a namesapce URI. The second method creates Name objects with a local name and a namespace prefix, and the third creates Name objects with just a local name. The following line of code, in which se is a SOAPEnvelope object, creates a new Name object with all three.

         Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      SOAPBody addBody()
      Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
      SOAPHeader addHeader()
      Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
      Name createName(String localName)
      Creates a new Name object initialized with the given local name.
      Name createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      SOAPBody getBody()
      Returns the SOAPBody object associated with this SOAPEnvelope object.
      SOAPHeader getHeader()
      Returns the SOAPHeader object for this SOAPEnvelope object.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • createName

        Name createName(String localName,
              String prefix,
              String uri)
                throws SOAPException
        Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

        This factory method creates Name objects for use in the SOAP/XML document.

        Parameters:
        localName - a String giving the local name
        prefix - a String giving the prefix of the namespace
        uri - a String giving the URI of the namespace
        Returns:
        a Name object initialized with the given local name, namespace prefix, and namespace URI
        Throws:
        SOAPException - if there is a SOAP error

      • createName

        Name createName(String localName)
                throws SOAPException
        Creates a new Name object initialized with the given local name.

        This factory method creates Name objects for use in the SOAP/XML document.

        Parameters:
        localName - a String giving the local name
        Returns:
        a Name object initialized with the given local name
        Throws:
        SOAPException - if there is a SOAP error

      • getHeader

        SOAPHeader getHeader()
                     throws SOAPException
        Returns the SOAPHeader object for this SOAPEnvelope object.

        A new SOAPMessage object is by default created with a SOAPEnvelope object that contains an empty SOAPHeader object. As a result, the method getHeader will always return a SOAPHeader object unless the header has been removed and a new one has not been added.

        Returns:
        the SOAPHeader object or null if there is none
        Throws:
        SOAPException - if there is a problem obtaining the SOAPHeader object

      • getBody

        SOAPBody getBody()
                 throws SOAPException
        Returns the SOAPBody object associated with this SOAPEnvelope object.

        A new SOAPMessage object is by default created with a SOAPEnvelope object that contains an empty SOAPBody object. As a result, the method getBody will always return a SOAPBody object unless the body has been removed and a new one has not been added.

        Returns:
        the SOAPBody object for this SOAPEnvelope object or null if there is none
        Throws:
        SOAPException - if there is a problem obtaining the SOAPBody object

      • addHeader

        SOAPHeader addHeader()
                     throws SOAPException
        Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.

        It is illegal to add a header when the envelope already contains a header. Therefore, this method should be called only after the existing header has been removed.

        Returns:
        the new SOAPHeader object
        Throws:
        SOAPException - if this SOAPEnvelope object already contains a valid SOAPHeader object

      • addBody

        SOAPBody addBody()
                 throws SOAPException
        Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.

        It is illegal to add a body when the envelope already contains a body. Therefore, this method should be called only after the existing body has been removed.

        Returns:
        the new SOAPBody object
        Throws:
        SOAPException - if this SOAPEnvelope object already contains a valid SOAPBody object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.soap.SOAPException
  • All Implemented Interfaces:
    Serializable

    public class SOAPException
extends Exception
    An exception that signals that a SOAP exception has occurred. A SOAPException object may contain a String that gives the reason for the exception, an embedded Throwable object, or both. This class provides methods for retrieving reason messages and for retrieving the embedded Throwable object.

    Typical reasons for throwing a SOAPException object are problems such as difficulty setting a header, not being able to send a message, and not being able to get a connection with the provider. Reasons for embedding a Throwable object include problems such as input/output errors or a parsing problem, such as an error in parsing a header.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPException()
      Constructs a SOAPException object with no reason or embedded Throwable object.
      SOAPException(String reason)
      Constructs a SOAPException object with the given String as the reason for the exception being thrown.
      SOAPException(String reason, Throwable cause)
      Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.
      SOAPException(Throwable cause)
      Constructs a SOAPException object initialized with the given Throwable object.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the Throwable object embedded in this SOAPException if there is one.
      String getMessage()
      Returns the detail message for this SOAPException object.
      Throwable initCause(Throwable cause)
      Initializes the cause field of this SOAPException object with the given Throwable object.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SOAPException

        public SOAPException()
        Constructs a SOAPException object with no reason or embedded Throwable object.

      • SOAPException

        public SOAPException(String reason)
        Constructs a SOAPException object with the given String as the reason for the exception being thrown.
        Parameters:
        reason - a description of what caused the exception

      • SOAPException

        public SOAPException(String reason,
             Throwable cause)
        Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.
        Parameters:
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this SOAPException object

      • SOAPException

        public SOAPException(Throwable cause)
        Constructs a SOAPException object initialized with the given Throwable object.

    • Method Detail

      • getMessage

        public String getMessage()
        Returns the detail message for this SOAPException object.

        If there is an embedded Throwable object, and if the SOAPException object has no detail message of its own, this method will return the detail message from the embedded Throwable object.

        Overrides:
        getMessage in class Throwable
        Returns:
        the error or warning message for this SOAPException or, if it has none, the message of the embedded Throwable object, if there is one

      • getCause

        public Throwable getCause()
        Returns the Throwable object embedded in this SOAPException if there is one. Otherwise, this method returns null.
        Overrides:
        getCause in class Throwable
        Returns:
        the embedded Throwable object or null if there is none

      • initCause

        public Throwable initCause(Throwable cause)
        Initializes the cause field of this SOAPException object with the given Throwable object.

        This method can be called at most once. It is generally called from within the constructor or immediately after the constructor has returned a new SOAPException object. If this SOAPException object was created with the constructor SOAPException(Throwable) or SOAPException(String,Throwable), meaning that its cause field already has a value, this method cannot be called even once.

        Overrides:
        initCause in class Throwable
        Parameters:
        cause - the Throwable object that caused this SOAPException object to be thrown. The value of this parameter is saved for later retrieval by the getCause() method. A null value is permitted and indicates that the cause is nonexistent or unknown.
        Returns:
        a reference to this SOAPException instance
        Throws:
        IllegalArgumentException - if cause is this Throwable object. (A Throwable object cannot be its own cause.)
        IllegalStateException - if the cause for this SOAPException object has already been initialized
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPFactory (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPFactory

  • java.lang.Object
    • javax.xml.soap.SOAPFactory

  • public abstract class SOAPFactory
extends Object
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree. SOAPFactory can be used to create XML fragments that will eventually end up in the SOAP part. These fragments can be inserted as children of the SOAPHeaderElement or SOAPBodyElement or SOAPEnvelope or other SOAPElement objects. SOAPFactory also has methods to create javax.xml.soap.Detail objects as well as java.xml.soap.Name objects.

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPFactory()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Detail createDetail()
      Creates a new Detail object which serves as a container for DetailEntry objects.
      SOAPElement createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.
      abstract SOAPElement createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      SOAPElement createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPElement createElement(String localName)
      Creates a SOAPElement object initialized with the given local name.
      abstract SOAPElement createElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object with the given local name, prefix and uri.
      abstract SOAPFault createFault()
      Creates a new default SOAPFault object
      abstract SOAPFault createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      abstract Name createName(String localName)
      Creates a new Name object initialized with the given local name.
      abstract Name createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      static SOAPFactory newInstance()
      Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
      static SOAPFactory newInstance(String protocol)
      Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SOAPFactory

        public SOAPFactory()

    • Method Detail

      • createElement

        public SOAPElement createElement(Element domElement)
                          throws SOAPException
        Creates a SOAPElement object from an existing DOM Element. If the DOM Element that is passed in as an argument is already a SOAPElement then this method must return it unmodified without any further work. Otherwise, a new SOAPElement is created and a deep copy is made of the domElement argument. The concrete type of the return value will depend on the name of the domElement argument. If any part of the tree rooted in domElement violates SOAP rules, a SOAPException will be thrown.
        Parameters:
        domElement - - the Element to be copied.
        Returns:
        a new SOAPElement that is a copy of domElement.
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        Since:
        SAAJ 1.3

      • createElement

        public abstract SOAPElement createElement(Name name)
                                   throws SOAPException
        Creates a SOAPElement object initialized with the given Name object. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.
        Parameters:
        name - a Name object with the XML name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        See Also:
        createElement(javax.xml.namespace.QName)

      • createElement

        public SOAPElement createElement(QName qname)
                          throws SOAPException
        Creates a SOAPElement object initialized with the given QName object. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.
        Parameters:
        qname - a QName object with the XML name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        Since:
        SAAJ 1.3
        See Also:
        createElement(Name)

      • createElement

        public abstract SOAPElement createElement(String localName)
                                   throws SOAPException
        Creates a SOAPElement object initialized with the given local name.
        Parameters:
        localName - a String giving the local name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object

      • createElement

        public abstract SOAPElement createElement(String localName,
                        String prefix,
                        String uri)
                                   throws SOAPException
        Creates a new SOAPElement object with the given local name, prefix and uri. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.
        Parameters:
        localName - a String giving the local name for the new element
        prefix - the prefix for this SOAPElement
        uri - a String giving the URI of the namespace to which the new element belongs
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object

      • createDetail

        public abstract Detail createDetail()
                             throws SOAPException
        Creates a new Detail object which serves as a container for DetailEntry objects.

        This factory method creates Detail objects for use in situations where it is not practical to use the SOAPFault abstraction.

        Returns:
        a Detail object
        Throws:
        SOAPException - if there is a SOAP error
        UnsupportedOperationException - if the protocol specified for the SOAPFactory was DYNAMIC_SOAP_PROTOCOL

      • createFault

        public abstract SOAPFault createFault(String reasonText,
                    QName faultCode)
                               throws SOAPException
        Creates a new SOAPFault object initialized with the given reasonText and faultCode
        Parameters:
        reasonText - the ReasonText/FaultString for the fault
        faultCode - the FaultCode for the fault
        Returns:
        a SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.3

      • createFault

        public abstract SOAPFault createFault()
                               throws SOAPException
        Creates a new default SOAPFault object
        Returns:
        a SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.3

      • createName

        public abstract Name createName(String localName,
              String prefix,
              String uri)
                         throws SOAPException
        Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

        This factory method creates Name objects for use in situations where it is not practical to use the SOAPEnvelope abstraction.

        Parameters:
        localName - a String giving the local name
        prefix - a String giving the prefix of the namespace
        uri - a String giving the URI of the namespace
        Returns:
        a Name object initialized with the given local name, namespace prefix, and namespace URI
        Throws:
        SOAPException - if there is a SOAP error

      • createName

        public abstract Name createName(String localName)
                         throws SOAPException
        Creates a new Name object initialized with the given local name.

        This factory method creates Name objects for use in situations where it is not practical to use the SOAPEnvelope abstraction.

        Parameters:
        localName - a String giving the local name
        Returns:
        a Name object initialized with the given local name
        Throws:
        SOAPException - if there is a SOAP error

      • newInstance

        public static SOAPFactory newInstance()
                               throws SOAPException
        Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load:
        • Use the javax.xml.soap.SOAPFactory system property.
        • Use the properties file "lib/jaxm.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
        • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.soap.SOAPFactory in jars available to the runtime.
        • Use the SAAJMetaFactory instance to locate the SOAPFactory implementation class.
        Returns:
        a new instance of a SOAPFactory
        Throws:
        SOAPException - if there was an error creating the default SOAPFactory
        See Also:
        SAAJMetaFactory

      • newInstance

        public static SOAPFactory newInstance(String protocol)
                               throws SOAPException
        Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
        Parameters:
        protocol - a string constant representing the protocol of the specified SOAP factory implementation. May be either DYNAMIC_SOAP_PROTOCOL, DEFAULT_SOAP_PROTOCOL (which is the same as) SOAP_1_1_PROTOCOL, or SOAP_1_2_PROTOCOL.
        Returns:
        a new instance of a SOAPFactory
        Throws:
        SOAPException - if there was an error creating the specified SOAPFactory
        Since:
        SAAJ 1.3
        See Also:
        SAAJMetaFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPFault (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPFault

  • All Superinterfaces:
    Element, Node, SOAPBodyElement, SOAPElement

    public interface SOAPFault
extends SOAPBodyElement
    An element in the SOAPBody object that contains error and/or status information. This information may relate to errors in the SOAPMessage object or to problems that are not related to the content in the message itself. Problems not related to the message itself are generally errors in processing, such as the inability to communicate with an upstream server.

    Depending on the protocol specified while creating the MessageFactory instance, a SOAPFault has sub-elements as defined in the SOAP 1.1/SOAP 1.2 specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Detail addDetail()
      Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
      void addFaultReasonText(String text, Locale locale)
      Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.
      void appendFaultSubcode(QName subcode)
      Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
      Detail getDetail()
      Returns the optional detail element for this SOAPFault object.
      String getFaultActor()
      Gets the fault actor for this SOAPFault object.
      String getFaultCode()
      Gets the fault code for this SOAPFault object.
      Name getFaultCodeAsName()
      Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.
      QName getFaultCodeAsQName()
      Gets the fault code for this SOAPFault object as a QName object.
      String getFaultNode()
      Returns the optional Node element value for this SOAPFault object.
      Iterator getFaultReasonLocales()
      Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.
      String getFaultReasonText(Locale locale)
      Returns the Reason Text associated with the given Locale.
      Iterator getFaultReasonTexts()
      Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
      String getFaultRole()
      Returns the optional Role element value for this SOAPFault object.
      String getFaultString()
      Gets the fault string for this SOAPFault object.
      Locale getFaultStringLocale()
      Gets the locale of the fault string for this SOAPFault object.
      Iterator getFaultSubcodes()
      Gets the Subcodes for this SOAPFault as an iterator over QNames.
      boolean hasDetail()
      Returns true if this SOAPFault has a Detail subelement and false otherwise.
      void removeAllFaultSubcodes()
      Removes any Subcodes that may be contained by this SOAPFault.
      void setFaultActor(String faultActor)
      Sets this SOAPFault object with the given fault actor.
      void setFaultCode(Name faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void setFaultCode(QName faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void setFaultCode(String faultCode)
      Sets this SOAPFault object with the give fault code.
      void setFaultNode(String uri)
      Creates or replaces any existing Node element value for this SOAPFault object.
      void setFaultRole(String uri)
      Creates or replaces any existing Role element value for this SOAPFault object.
      void setFaultString(String faultString)
      Sets the fault string for this SOAPFault object to the given string.
      void setFaultString(String faultString, Locale locale)
      Sets the fault string for this SOAPFault object to the given string and localized to the given locale.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • setFaultCode

        void setFaultCode(Name faultCodeQName)
                  throws SOAPException
        Sets this SOAPFault object with the given fault code.

        Fault codes, which give information about the fault, are defined in the SOAP 1.1 specification. A fault code is mandatory and must be of type Name. This method provides a convenient way to set a fault code. For example,

         SOAPEnvelope se = ...;
 // Create a qualified name in the SOAP namespace with a localName
 // of "Client". Note that prefix parameter is optional and is null
 // here which causes the implementation to use an appropriate prefix.
 Name qname = se.createName("Client", null,
                            SOAPConstants.URI_NS_SOAP_ENVELOPE);
 SOAPFault fault = ...;
 fault.setFaultCode(qname);
        It is preferable to use this method over setFaultCode(String).
        Parameters:
        faultCodeQName - a Name object giving the fault code to be set. It must be namespace qualified.
        Throws:
        SOAPException - if there was an error in adding the faultcode element to the underlying XML tree.
        Since:
        SAAJ 1.2
        See Also:
        getFaultCodeAsName()

      • setFaultCode

        void setFaultCode(QName faultCodeQName)
                  throws SOAPException
        Sets this SOAPFault object with the given fault code. It is preferable to use this method over setFaultCode(Name).
        Parameters:
        faultCodeQName - a QName object giving the fault code to be set. It must be namespace qualified.
        Throws:
        SOAPException - if there was an error in adding the faultcode element to the underlying XML tree.
        Since:
        SAAJ 1.3
        See Also:
        getFaultCodeAsQName(), setFaultCode(Name), getFaultCodeAsQName()

      • setFaultCode

        void setFaultCode(String faultCode)
                  throws SOAPException
        Sets this SOAPFault object with the give fault code.

        Fault codes, which given information about the fault, are defined in the SOAP 1.1 specification. This element is mandatory in SOAP 1.1. Because the fault code is required to be a QName it is preferable to use the setFaultCode(Name) form of this method.

        Parameters:
        faultCode - a String giving the fault code to be set. It must be of the form "prefix:localName" where the prefix has been defined in a namespace declaration.
        Throws:
        SOAPException - if there was an error in adding the faultCode to the underlying XML tree.
        See Also:
        setFaultCode(Name), getFaultCode(), SOAPElement.addNamespaceDeclaration(java.lang.String, java.lang.String)

      • getFaultCodeAsName

        Name getFaultCodeAsName()
        Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object. The SOAP 1.1 specification requires the value of the "faultcode" element to be of type QName. This method returns the content of the element as a QName in the form of a SAAJ Name object. This method should be used instead of the getFaultCode method since it allows applications to easily access the namespace name without additional parsing.
        Returns:
        a Name representing the faultcode
        Since:
        SAAJ 1.2
        See Also:
        setFaultCode(Name)

      • getFaultCodeAsQName

        QName getFaultCodeAsQName()
        Gets the fault code for this SOAPFault object as a QName object.
        Returns:
        a QName representing the faultcode
        Since:
        SAAJ 1.3
        See Also:
        setFaultCode(QName)

      • getFaultSubcodes

        Iterator getFaultSubcodes()
        Gets the Subcodes for this SOAPFault as an iterator over QNames.
        Returns:
        an Iterator that accesses a sequence of QNames. This Iterator should not support the optional remove method. The order in which the Subcodes are returned reflects the hierarchy of Subcodes present in the fault from top to bottom.
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
        Since:
        SAAJ 1.3

      • removeAllFaultSubcodes

        void removeAllFaultSubcodes()
        Removes any Subcodes that may be contained by this SOAPFault. Subsequent calls to getFaultSubcodes will return an empty iterator until a call to appendFaultSubcode is made.
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
        Since:
        SAAJ 1.3

      • appendFaultSubcode

        void appendFaultSubcode(QName subcode)
                        throws SOAPException
        Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault. Subcodes, which were introduced in SOAP 1.2, are represented by a recursive sequence of subelements rooted in the mandatory Code subelement of a SOAP Fault.
        Parameters:
        subcode - a QName containing the Value of the Subcode.
        Throws:
        SOAPException - if there was an error in setting the Subcode
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
        Since:
        SAAJ 1.3

      • getFaultCode

        String getFaultCode()
        Gets the fault code for this SOAPFault object.
        Returns:
        a String with the fault code
        See Also:
        getFaultCodeAsName(), setFaultCode(javax.xml.soap.Name)

      • setFaultActor

        void setFaultActor(String faultActor)
                   throws SOAPException
        Sets this SOAPFault object with the given fault actor.

        The fault actor is the recipient in the message path who caused the fault to happen.

        If this SOAPFault supports SOAP 1.2 then this call is equivalent to setFaultRole(String)

        Parameters:
        faultActor - a String identifying the actor that caused this SOAPFault object
        Throws:
        SOAPException - if there was an error in adding the faultActor to the underlying XML tree.
        See Also:
        getFaultActor()

      • getFaultActor

        String getFaultActor()
        Gets the fault actor for this SOAPFault object.

        If this SOAPFault supports SOAP 1.2 then this call is equivalent to getFaultRole()

        Returns:
        a String giving the actor in the message path that caused this SOAPFault object
        See Also:
        setFaultActor(java.lang.String)

      • setFaultString

        void setFaultString(String faultString)
                    throws SOAPException
        Sets the fault string for this SOAPFault object to the given string.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

              addFaultReasonText(faultString, Locale.getDefault());
        Parameters:
        faultString - a String giving an explanation of the fault
        Throws:
        SOAPException - if there was an error in adding the faultString to the underlying XML tree.
        See Also:
        getFaultString()

      • setFaultString

        void setFaultString(String faultString,
                  Locale locale)
                    throws SOAPException
        Sets the fault string for this SOAPFault object to the given string and localized to the given locale.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

              addFaultReasonText(faultString, locale);
        Parameters:
        faultString - a String giving an explanation of the fault
        locale - a Locale object indicating the native language of the faultString
        Throws:
        SOAPException - if there was an error in adding the faultString to the underlying XML tree.
        Since:
        SAAJ 1.2
        See Also:
        getFaultString()

      • getFaultString

        String getFaultString()
        Gets the fault string for this SOAPFault object.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

            String reason = null;
    try {
        reason = (String) getFaultReasonTexts().next();
    } catch (SOAPException e) {}
    return reason;
        Returns:
        a String giving an explanation of the fault
        See Also:
        setFaultString(String), setFaultString(String, Locale)

      • getFaultStringLocale

        Locale getFaultStringLocale()
        Gets the locale of the fault string for this SOAPFault object.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

            Locale locale = null;
    try {
        locale = (Locale) getFaultReasonLocales().next();
    } catch (SOAPException e) {}
    return locale;
        Returns:
        a Locale object indicating the native language of the fault string or null if no locale was specified
        Since:
        SAAJ 1.2
        See Also:
        setFaultString(String, Locale)

      • hasDetail

        boolean hasDetail()
        Returns true if this SOAPFault has a Detail subelement and false otherwise. Equivalent to (getDetail()!=null).
        Returns:
        true if this SOAPFault has a Detail subelement and false otherwise.
        Since:
        SAAJ 1.3

      • getDetail

        Detail getDetail()
        Returns the optional detail element for this SOAPFault object.

        A Detail object carries application-specific error information, the scope of the error information is restricted to faults in the SOAPBodyElement objects if this is a SOAP 1.1 Fault.

        Returns:
        a Detail object with application-specific error information if present, null otherwise

      • addDetail

        Detail addDetail()
                 throws SOAPException
        Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.

        It is illegal to add a detail when the fault already contains a detail. Therefore, this method should be called only after the existing detail has been removed.

        Returns:
        the new Detail object
        Throws:
        SOAPException - if this SOAPFault object already contains a valid Detail object

      • getFaultReasonLocales

        Iterator getFaultReasonLocales()
                               throws SOAPException
        Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items. Any of these Locales can be used in a call to getFaultReasonText in order to obtain a localized version of the Reason Text string.
        Returns:
        an Iterator over a sequence of Locale objects for which there are associated Reason Text items.
        Throws:
        SOAPException - if there was an error in retrieving the fault Reason locales.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        Since:
        SAAJ 1.3

      • getFaultReasonTexts

        Iterator getFaultReasonTexts()
                             throws SOAPException
        Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
        Returns:
        an Iterator over env:Fault/env:Reason/env:Text items.
        Throws:
        SOAPException - if there was an error in retrieving the fault Reason texts.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        Since:
        SAAJ 1.3

      • getFaultReasonText

        String getFaultReasonText(Locale locale)
                          throws SOAPException
        Returns the Reason Text associated with the given Locale. If more than one such Reason Text exists the first matching Text is returned
        Parameters:
        locale - -- the Locale for which a localized Reason Text is desired
        Returns:
        the Reason Text associated with locale
        Throws:
        SOAPException - if there was an error in retrieving the fault Reason text for the specified locale .
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        Since:
        SAAJ 1.3
        See Also:
        getFaultString()

      • addFaultReasonText

        void addFaultReasonText(String text,
                      Locale locale)
                        throws SOAPException
        Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale. If a Reason Text item with this xml:lang already exists its text value will be replaced with text. The locale parameter should not be null

        Code sample:

         SOAPFault fault = ...;
 fault.addFaultReasonText("Version Mismatch", Locale.ENGLISH);
        Parameters:
        text - -- reason message string
        locale - -- Locale object representing the locale of the message
        Throws:
        SOAPException - if there was an error in adding the Reason text or the locale passed was null.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        Since:
        SAAJ 1.3

      • getFaultNode

        String getFaultNode()
        Returns the optional Node element value for this SOAPFault object. The Node element is optional in SOAP 1.2.
        Returns:
        Content of the env:Fault/env:Node element as a String or null if none
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Node.
        Since:
        SAAJ 1.3

      • setFaultNode

        void setFaultNode(String uri)
                  throws SOAPException
        Creates or replaces any existing Node element value for this SOAPFault object. The Node element is optional in SOAP 1.2.
        Throws:
        SOAPException - if there was an error in setting the Node for this SOAPFault object.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Node.
        Since:
        SAAJ 1.3

      • getFaultRole

        String getFaultRole()
        Returns the optional Role element value for this SOAPFault object. The Role element is optional in SOAP 1.2.
        Returns:
        Content of the env:Fault/env:Role element as a String or null if none
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        Since:
        SAAJ 1.3

      • setFaultRole

        void setFaultRole(String uri)
                  throws SOAPException
        Creates or replaces any existing Role element value for this SOAPFault object. The Role element is optional in SOAP 1.2.
        Parameters:
        uri - - the URI of the Role
        Throws:
        SOAPException - if there was an error in setting the Role for this SOAPFault object.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        Since:
        SAAJ 1.3
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPFaultElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPFaultElement

  • All Superinterfaces:
    Element, Node, SOAPElement
    All Known Subinterfaces:
    Detail

    public interface SOAPFaultElement
extends SOAPElement
    A representation of the contents in a SOAPFault object. The Detail interface is a SOAPFaultElement.

    Content is added to a SOAPFaultElement using the SOAPElement method addTextNode.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPHeader (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPHeader

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPHeader
extends SOAPElement
    A representation of the SOAP header element. A SOAP header element consists of XML data that affects the way the application-specific content is processed by the message provider. For example, transaction semantics, authentication information, and so on, can be specified as the content of a SOAPHeader object.

    A SOAPEnvelope object contains an empty SOAPHeader object by default. If the SOAPHeader object, which is optional, is not needed, it can be retrieved and deleted with the following line of code. The variable se is a SOAPEnvelope object.

          se.getHeader().detachNode();
    A SOAPHeader object is created with the SOAPEnvelope method addHeader. This method, which creates a new header and adds it to the envelope, may be called only after the existing header has been removed.
          se.getHeader().detachNode();
      SOAPHeader sh = se.addHeader();

    A SOAPHeader object can have only SOAPHeaderElement objects as its immediate children. The method addHeaderElement creates a new HeaderElement object and adds it to the SOAPHeader object. In the following line of code, the argument to the method addHeaderElement is a Name object that is the name for the new HeaderElement object.

          SOAPHeaderElement shElement = sh.addHeaderElement(name);
    See Also:
    SOAPHeaderElement

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      SOAPHeaderElement addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPHeaderElement addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement addUpgradeHeaderElement(Iterator supportedSOAPURIs)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
      SOAPHeaderElement addUpgradeHeaderElement(String supportedSoapUri)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
      SOAPHeaderElement addUpgradeHeaderElement(String[] supportedSoapUris)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
      Iterator examineAllHeaderElements()
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
      Iterator examineHeaderElements(String actor)
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor.
      Iterator examineMustUnderstandHeaderElements(String actor)
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.
      Iterator extractAllHeaderElements()
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
      Iterator extractHeaderElements(String actor)
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • addHeaderElement

        SOAPHeaderElement addHeaderElement(Name name)
                                   throws SOAPException
        Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
        Parameters:
        name - a Name object with the name of the new SOAPHeaderElement object
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs
        See Also:
        addHeaderElement(javax.xml.namespace.QName)

      • addHeaderElement

        SOAPHeaderElement addHeaderElement(QName qname)
                                   throws SOAPException
        Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
        Parameters:
        qname - a QName object with the qname of the new SOAPHeaderElement object
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs
        Since:
        SAAJ 1.3
        See Also:
        addHeaderElement(Name)

      • examineMustUnderstandHeaderElements

        Iterator examineMustUnderstandHeaderElements(String actor)
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.

        In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

        Parameters:
        actor - a String giving the URI of the actor / role for which to search
        Returns:
        an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role and are marked as MustUnderstand
        Since:
        SAAJ 1.2
        See Also:
        examineHeaderElements(java.lang.String), extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

      • examineHeaderElements

        Iterator examineHeaderElements(String actor)
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor. An actor is a global attribute that indicates the intermediate parties that should process a message before it reaches its ultimate receiver. An actor receives the message and processes it before sending it on to the next actor. The default actor is the ultimate intended recipient for the message, so if no actor attribute is included in a SOAPHeader object, it is sent to the ultimate receiver along with the message body.

        In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

        Parameters:
        actor - a String giving the URI of the actor / role for which to search
        Returns:
        an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role
        See Also:
        extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

      • extractHeaderElements

        Iterator extractHeaderElements(String actor)
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.

        This method allows an actor to process the parts of the SOAPHeader object that apply to it and to remove them before passing the message on to the next actor.

        In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

        Parameters:
        actor - a String giving the URI of the actor / role for which to search
        Returns:
        an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role
        See Also:
        examineHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

      • addNotUnderstoodHeaderElement

        SOAPHeaderElement addNotUnderstoodHeaderElement(QName name)
                                                throws SOAPException
        Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object. This operation is supported only by SOAP 1.2.
        Parameters:
        name - a QName object with the name of the SOAPHeaderElement object that was not understood.
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs.
        UnsupportedOperationException - if this is a SOAP 1.1 Header.
        Since:
        SAAJ 1.3

      • addUpgradeHeaderElement

        SOAPHeaderElement addUpgradeHeaderElement(Iterator supportedSOAPURIs)
                                          throws SOAPException
        Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.
        Parameters:
        supportedSOAPURIs - an Iterator object with the URIs of SOAP versions supported.
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs.
        Since:
        SAAJ 1.3

      • addUpgradeHeaderElement

        SOAPHeaderElement addUpgradeHeaderElement(String[] supportedSoapUris)
                                          throws SOAPException
        Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.
        Parameters:
        supportedSoapUris - an array of the URIs of SOAP versions supported.
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs.
        Since:
        SAAJ 1.3

      • addUpgradeHeaderElement

        SOAPHeaderElement addUpgradeHeaderElement(String supportedSoapUri)
                                          throws SOAPException
        Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.
        Parameters:
        supportedSoapUri - the URI of SOAP the version that is supported.
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs.
        Since:
        SAAJ 1.3

      • examineAllHeaderElements

        Iterator examineAllHeaderElements()
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
        Returns:
        an Iterator object over all the SOAPHeaderElement objects contained by this SOAPHeader
        Since:
        SAAJ 1.2
        See Also:
        extractAllHeaderElements()

      • extractAllHeaderElements

        Iterator extractAllHeaderElements()
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
        Returns:
        an Iterator object over all the SOAPHeaderElement objects contained by this SOAPHeader
        Since:
        SAAJ 1.2
        See Also:
        examineAllHeaderElements()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPHeaderElement (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPHeaderElement

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPHeaderElement
extends SOAPElement
    An object representing the contents in the SOAP header part of the SOAP envelope. The immediate children of a SOAPHeader object can be represented only as SOAPHeaderElement objects.

    A SOAPHeaderElement object can have other SOAPElement objects as its children.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getActor()
      Returns the uri of the actor attribute of this SOAPHeaderElement.
      boolean getMustUnderstand()
      Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.
      boolean getRelay()
      Returns the boolean value of the relay attribute for this SOAPHeaderElement
      String getRole()
      Returns the value of the Role attribute of this SOAPHeaderElement.
      void setActor(String actorURI)
      Sets the actor associated with this SOAPHeaderElement object to the specified actor.
      void setMustUnderstand(boolean mustUnderstand)
      Sets the mustUnderstand attribute for this SOAPHeaderElement object to be either true or false.
      void setRelay(boolean relay)
      Sets the relay attribute for this SOAPHeaderElement to be either true or false.
      void setRole(String uri)
      Sets the Role associated with this SOAPHeaderElement object to the specified Role.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • setActor

        void setActor(String actorURI)
        Sets the actor associated with this SOAPHeaderElement object to the specified actor. The default value of an actor is: SOAPConstants.URI_SOAP_ACTOR_NEXT

        If this SOAPHeaderElement supports SOAP 1.2 then this call is equivalent to setRole(String)

        Parameters:
        actorURI - a String giving the URI of the actor to set
        Throws:
        IllegalArgumentException - if there is a problem in setting the actor.
        See Also:
        getActor()

      • setRole

        void setRole(String uri)
             throws SOAPException
        Sets the Role associated with this SOAPHeaderElement object to the specified Role.
        Parameters:
        uri - - the URI of the Role
        Throws:
        SOAPException - if there is an error in setting the role
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        Since:
        SAAJ 1.3

      • getActor

        String getActor()
        Returns the uri of the actor attribute of this SOAPHeaderElement.

        If this SOAPHeaderElement supports SOAP 1.2 then this call is equivalent to getRole()

        Returns:
        a String giving the URI of the actor
        See Also:
        setActor(java.lang.String)

      • getRole

        String getRole()
        Returns the value of the Role attribute of this SOAPHeaderElement.
        Returns:
        a String giving the URI of the Role
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        Since:
        SAAJ 1.3

      • setMustUnderstand

        void setMustUnderstand(boolean mustUnderstand)
        Sets the mustUnderstand attribute for this SOAPHeaderElement object to be either true or false.

        If the mustUnderstand attribute is on, the actor who receives the SOAPHeaderElement must process it correctly. This ensures, for example, that if the SOAPHeaderElement object modifies the message, that the message is being modified correctly.

        Parameters:
        mustUnderstand - true to set the mustUnderstand attribute to true; false to set it to false
        Throws:
        IllegalArgumentException - if there is a problem in setting the mustUnderstand attribute
        See Also:
        getMustUnderstand(), setRelay(boolean)

      • getMustUnderstand

        boolean getMustUnderstand()
        Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.
        Returns:
        true if the mustUnderstand attribute of this SOAPHeaderElement object is turned on; false otherwise

      • setRelay

        void setRelay(boolean relay)
              throws SOAPException
        Sets the relay attribute for this SOAPHeaderElement to be either true or false.

        The SOAP relay attribute is set to true to indicate that the SOAP header block must be relayed by any node that is targeted by the header block but not actually process it. This attribute is ignored on header blocks whose mustUnderstand attribute is set to true or that are targeted at the ultimate reciever (which is the default). The default value of this attribute is false.

        Parameters:
        relay - the new value of the relay attribute
        Throws:
        SOAPException - if there is a problem in setting the relay attribute.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Relay attribute.
        Since:
        SAAJ 1.3
        See Also:
        setMustUnderstand(boolean), getRelay()

      • getRelay

        boolean getRelay()
        Returns the boolean value of the relay attribute for this SOAPHeaderElement
        Returns:
        true if the relay attribute is turned on; false otherwise
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Relay attribute.
        Since:
        SAAJ 1.3
        See Also:
        getMustUnderstand(), setRelay(boolean)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPMessage

  • java.lang.Object
    • javax.xml.soap.SOAPMessage

  • public abstract class SOAPMessage
extends Object
    The root class for all SOAP messages. As transmitted on the "wire", a SOAP message is an XML document or a MIME message whose first body part is an XML/SOAP document.

    A SOAPMessage object consists of a SOAP part and optionally one or more attachment parts. The SOAP part for a SOAPMessage object is a SOAPPart object, which contains information used for message routing and identification, and which can contain application-specific content. All data in the SOAP Part of a message must be in XML format.

    A new SOAPMessage object contains the following by default:

    • A SOAPPart object
    • A SOAPEnvelope object
    • A SOAPBody object
    • A SOAPHeader object
    The SOAP part of a message can be retrieved by calling the method SOAPMessage.getSOAPPart(). The SOAPEnvelope object is retrieved from the SOAPPart object, and the SOAPEnvelope object is used to retrieve the SOAPBody and SOAPHeader objects.
         SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     SOAPBody sb = se.getBody();
     SOAPHeader sh = se.getHeader();

    In addition to the mandatory SOAPPart object, a SOAPMessage object may contain zero or more AttachmentPart objects, each of which contains application-specific data. The SOAPMessage interface provides methods for creating AttachmentPart objects and also for adding them to a SOAPMessage object. A party that has received a SOAPMessage object can examine its contents by retrieving individual attachment parts.

    Unlike the rest of a SOAP message, an attachment is not required to be in XML format and can therefore be anything from simple text to an image file. Consequently, any message content that is not in XML format must be in an AttachmentPart object.

    A MessageFactory object may create SOAPMessage objects with behavior that is specialized to a particular implementation or application of SAAJ. For instance, a MessageFactory object may produce SOAPMessage objects that conform to a particular Profile such as ebXML. In this case a MessageFactory object might produce SOAPMessage objects that are initialized with ebXML headers.

    In order to ensure backward source compatibility, methods that are added to this class after version 1.1 of the SAAJ specification are all concrete instead of abstract and they all have default implementations. Unless otherwise noted in the JavaDocs for those methods the default implementations simply throw an UnsupportedOperationException and the SAAJ implementation code must override them with methods that provide the specified behavior. Legacy client code does not have this restriction, however, so long as there is no claim made that it conforms to some later version of the specification than it was originally written for. A legacy class that extends the SOAPMessage class can be compiled and/or run against succeeding versions of the SAAJ API without modification. If such a class was correctly implemented then it will continue to behave correctly relative to the version of the specification against which it was written.

    See Also:
    MessageFactory, AttachmentPart

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CHARACTER_SET_ENCODING
      Specifies the character type encoding for the SOAP Message.
      static String WRITE_XML_DECLARATION
      Specifies whether the SOAP Message will contain an XML declaration when it is sent.

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPMessage()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addAttachmentPart(AttachmentPart AttachmentPart)
      Adds the given AttachmentPart object to this SOAPMessage object.
      abstract int countAttachments()
      Gets a count of the number of attachments in this message.
      abstract AttachmentPart createAttachmentPart()
      Creates a new empty AttachmentPart object.
      AttachmentPart createAttachmentPart(DataHandler dataHandler)
      Creates an AttachmentPart object and populates it using the given DataHandler object.
      AttachmentPart createAttachmentPart(Object content, String contentType)
      Creates an AttachmentPart object and populates it with the specified data of the specified content type.
      abstract AttachmentPart getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      abstract Iterator getAttachments()
      Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.
      abstract Iterator getAttachments(MimeHeaders headers)
      Retrieves all the AttachmentPart objects that have header entries that match the specified headers.
      abstract String getContentDescription()
      Retrieves a description of this SOAPMessage object's content.
      abstract MimeHeaders getMimeHeaders()
      Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
      Object getProperty(String property)
      Retrieves value of the specified property.
      SOAPBody getSOAPBody()
      Gets the SOAP Body contained in this SOAPMessage object.
      SOAPHeader getSOAPHeader()
      Gets the SOAP Header contained in this SOAPMessage object.
      abstract SOAPPart getSOAPPart()
      Gets the SOAP part of this SOAPMessage object.
      abstract void removeAllAttachments()
      Removes all AttachmentPart objects that have been added to this SOAPMessage object.
      abstract void removeAttachments(MimeHeaders headers)
      Removes all the AttachmentPart objects that have header entries that match the specified headers.
      abstract void saveChanges()
      Updates this SOAPMessage object with all the changes that have been made to it.
      abstract boolean saveRequired()
      Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.
      abstract void setContentDescription(String description)
      Sets the description of this SOAPMessage object's content with the given description.
      void setProperty(String property, Object value)
      Associates the specified value with the specified property.
      abstract void writeTo(OutputStream out)
      Writes this SOAPMessage object to the given output stream.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CHARACTER_SET_ENCODING

        public static final String CHARACTER_SET_ENCODING
        Specifies the character type encoding for the SOAP Message. Valid values include "utf-8" and "utf-16". See vendor documentation for additional supported values. The default is "utf-8".
        Since:
        SAAJ 1.2
        See Also:
        SOAPMessage.setProperty, Constant Field Values

      • WRITE_XML_DECLARATION

        public static final String WRITE_XML_DECLARATION
        Specifies whether the SOAP Message will contain an XML declaration when it is sent. The only valid values are "true" and "false". The default is "false".
        Since:
        SAAJ 1.2
        See Also:
        SOAPMessage.setProperty, Constant Field Values

    • Constructor Detail

      • SOAPMessage

        public SOAPMessage()

    • Method Detail

      • setContentDescription

        public abstract void setContentDescription(String description)
        Sets the description of this SOAPMessage object's content with the given description.
        Parameters:
        description - a String describing the content of this message
        See Also:
        getContentDescription()

      • getContentDescription

        public abstract String getContentDescription()
        Retrieves a description of this SOAPMessage object's content.
        Returns:
        a String describing the content of this message or null if no description has been set
        See Also:
        setContentDescription(java.lang.String)

      • getSOAPPart

        public abstract SOAPPart getSOAPPart()
        Gets the SOAP part of this SOAPMessage object.

        SOAPMessage object contains one or more attachments, the SOAP Part must be the first MIME body part in the message.

        Returns:
        the SOAPPart object for this SOAPMessage object

      • getSOAPBody

        public SOAPBody getSOAPBody()
                     throws SOAPException
        Gets the SOAP Body contained in this SOAPMessage object.

        Returns:
        the SOAPBody object contained by this SOAPMessage object
        Throws:
        SOAPException - if the SOAP Body does not exist or cannot be retrieved
        Since:
        SAAJ 1.2

      • getSOAPHeader

        public SOAPHeader getSOAPHeader()
                         throws SOAPException
        Gets the SOAP Header contained in this SOAPMessage object.

        Returns:
        the SOAPHeader object contained by this SOAPMessage object
        Throws:
        SOAPException - if the SOAP Header does not exist or cannot be retrieved
        Since:
        SAAJ 1.2

      • removeAllAttachments

        public abstract void removeAllAttachments()
        Removes all AttachmentPart objects that have been added to this SOAPMessage object.

        This method does not touch the SOAP part.

      • countAttachments

        public abstract int countAttachments()
        Gets a count of the number of attachments in this message. This count does not include the SOAP part.
        Returns:
        the number of AttachmentPart objects that are part of this SOAPMessage object

      • getAttachments

        public abstract Iterator getAttachments()
        Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.
        Returns:
        an iterator over all the attachments in this message

      • getAttachments

        public abstract Iterator getAttachments(MimeHeaders headers)
        Retrieves all the AttachmentPart objects that have header entries that match the specified headers. Note that a returned attachment could have headers in addition to those specified.
        Parameters:
        headers - a MimeHeaders object containing the MIME headers for which to search
        Returns:
        an iterator over all attachments that have a header that matches one of the given headers

      • removeAttachments

        public abstract void removeAttachments(MimeHeaders headers)
        Removes all the AttachmentPart objects that have header entries that match the specified headers. Note that the removed attachment could have headers in addition to those specified.
        Parameters:
        headers - a MimeHeaders object containing the MIME headers for which to search
        Since:
        SAAJ 1.3

      • getAttachment

        public abstract AttachmentPart getAttachment(SOAPElement element)
                                      throws SOAPException
        Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists. References can be made via an href attribute as described in SOAP Messages with Attachments, or via a single Text child node containing a URI as described in the WS-I Attachments Profile 1.0 for elements of schema type ref:swaRef. These two mechanisms must be supported. The support for references via href attribute also implies that this method should also be supported on an element that is an xop:Include element ( XOP). other reference mechanisms may be supported by individual implementations of this standard. Contact your vendor for details.
        Parameters:
        element - The SOAPElement containing the reference to an Attachment
        Returns:
        the referenced AttachmentPart or null if no such AttachmentPart exists or no reference can be found in this SOAPElement.
        Throws:
        SOAPException - if there is an error in the attempt to access the attachment
        Since:
        SAAJ 1.3

      • addAttachmentPart

        public abstract void addAttachmentPart(AttachmentPart AttachmentPart)
        Adds the given AttachmentPart object to this SOAPMessage object. An AttachmentPart object must be created before it can be added to a message.
        Parameters:
        AttachmentPart - an AttachmentPart object that is to become part of this SOAPMessage object
        Throws:
        IllegalArgumentException

      • createAttachmentPart

        public abstract AttachmentPart createAttachmentPart()
        Creates a new empty AttachmentPart object. Note that the method addAttachmentPart must be called with this new AttachmentPart object as the parameter in order for it to become an attachment to this SOAPMessage object.
        Returns:
        a new AttachmentPart object that can be populated and added to this SOAPMessage object

      • createAttachmentPart

        public AttachmentPart createAttachmentPart(DataHandler dataHandler)
        Creates an AttachmentPart object and populates it using the given DataHandler object.
        Parameters:
        dataHandler - the javax.activation.DataHandler object that will generate the content for this SOAPMessage object
        Returns:
        a new AttachmentPart object that contains data generated by the given DataHandler object
        Throws:
        IllegalArgumentException - if there was a problem with the specified DataHandler object
        See Also:
        DataHandler, DataContentHandler

      • getMimeHeaders

        public abstract MimeHeaders getMimeHeaders()
        Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
        Returns:
        a MimeHeaders object containing the MimeHeader objects

      • createAttachmentPart

        public AttachmentPart createAttachmentPart(Object content,
                                  String contentType)
        Creates an AttachmentPart object and populates it with the specified data of the specified content type. The type of the Object should correspond to the value given for the Content-Type.
        Parameters:
        content - an Object containing the content for the AttachmentPart object to be created
        contentType - a String object giving the type of content; examples are "text/xml", "text/plain", and "image/jpeg"
        Returns:
        a new AttachmentPart object that contains the given data
        Throws:
        IllegalArgumentException - may be thrown if the contentType does not match the type of the content object, or if there was no DataContentHandler object for the given content object
        See Also:
        DataHandler, DataContentHandler

      • saveChanges

        public abstract void saveChanges()
                          throws SOAPException
        Updates this SOAPMessage object with all the changes that have been made to it. This method is called automatically when writeTo(OutputStream) is called. However, if changes are made to a message that was received or to one that has already been sent, the method saveChanges needs to be called explicitly in order to save the changes. The method saveChanges also generates any changes that can be read back (for example, a MessageId in profiles that support a message id). All MIME headers in a message that is created for sending purposes are guaranteed to have valid values only after saveChanges has been called.

        In addition, this method marks the point at which the data from all constituent AttachmentPart objects are pulled into the message.

        Throws:
        SOAPException - if there was a problem saving changes to this message.
        SOAPException

      • saveRequired

        public abstract boolean saveRequired()
        Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.
        Returns:
        true if saveChanges needs to be called; false otherwise.

      • writeTo

        public abstract void writeTo(OutputStream out)
                      throws SOAPException,
                             IOException
        Writes this SOAPMessage object to the given output stream. The externalization format is as defined by the SOAP 1.1 with Attachments specification.

        If there are no attachments, just an XML stream is written out. For those messages that have attachments, writeTo writes a MIME-encoded byte stream.

        Note that this method does not write the transport-specific MIME Headers of the Message

        Parameters:
        out - the OutputStream object to which this SOAPMessage object will be written
        Throws:
        IOException - if an I/O error occurs
        SOAPException - if there was a problem in externalizing this SOAP message

      • setProperty

        public void setProperty(String property,
               Object value)
                 throws SOAPException
        Associates the specified value with the specified property. If there was already a value associated with this property, the old value is replaced.

        The valid property names include WRITE_XML_DECLARATION and CHARACTER_SET_ENCODING. All of these standard SAAJ properties are prefixed by "javax.xml.soap". Vendors may also add implementation specific properties. These properties must be prefixed with package names that are unique to the vendor.

        Setting the property WRITE_XML_DECLARATION to "true" will cause an XML Declaration to be written out at the start of the SOAP message. The default value of "false" suppresses this declaration.

        The property CHARACTER_SET_ENCODING defaults to the value "utf-8" which causes the SOAP message to be encoded using UTF-8. Setting CHARACTER_SET_ENCODING to "utf-16" causes the SOAP message to be encoded using UTF-16.

        Some implementations may allow encodings in addition to UTF-8 and UTF-16. Refer to your vendor's documentation for details.

        Parameters:
        property - the property with which the specified value is to be associated.
        value - the value to be associated with the specified property
        Throws:
        SOAPException - if the property name is not recognized.
        Since:
        SAAJ 1.2

      • getProperty

        public Object getProperty(String property)
                   throws SOAPException
        Retrieves value of the specified property.
        Parameters:
        property - the name of the property to retrieve
        Returns:
        the value associated with the named property or null if no such property exists.
        Throws:
        SOAPException - if the property name is not recognized.
        Since:
        SAAJ 1.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPPart (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPPart

  • java.lang.Object
    • javax.xml.soap.SOAPPart
  • All Implemented Interfaces:
    Document, Node

    public abstract class SOAPPart
extends Object
implements Document, Node
    The container for the SOAP-specific portion of a SOAPMessage object. All messages are required to have a SOAP part, so when a SOAPMessage object is created, it will automatically have a SOAPPart object.

    A SOAPPart object is a MIME part and has the MIME headers Content-Id, Content-Location, and Content-Type. Because the value of Content-Type must be "text/xml", a SOAPPart object automatically has a MIME header of Content-Type with its value set to "text/xml". The value must be "text/xml" because content in the SOAP part of a message must be in XML format. Content that is not of type "text/xml" must be in an AttachmentPart object rather than in the SOAPPart object.

    When a message is sent, its SOAP part must have the MIME header Content-Type set to "text/xml". Or, from the other perspective, the SOAP part of any message that is received must have the MIME header Content-Type with a value of "text/xml".

    A client can access the SOAPPart object of a SOAPMessage object by calling the method SOAPMessage.getSOAPPart. The following line of code, in which message is a SOAPMessage object, retrieves the SOAP part of a message.

       SOAPPart soapPart = message.getSOAPPart();

    A SOAPPart object contains a SOAPEnvelope object, which in turn contains a SOAPBody object and a SOAPHeader object. The SOAPPart method getEnvelope can be used to retrieve the SOAPEnvelope object.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPPart()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addMimeHeader(String name, String value)
      Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object.
      abstract Iterator getAllMimeHeaders()
      Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.
      abstract Source getContent()
      Returns the content of the SOAPEnvelope as a JAXP Source object.
      String getContentId()
      Retrieves the value of the MIME header whose name is "Content-Id".
      String getContentLocation()
      Retrieves the value of the MIME header whose name is "Content-Location".
      abstract SOAPEnvelope getEnvelope()
      Gets the SOAPEnvelope object associated with this SOAPPart object.
      abstract Iterator getMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects that match a name in the given array.
      abstract String[] getMimeHeader(String name)
      Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.
      abstract Iterator getNonMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects whose name does not match a name in the given array.
      abstract void removeAllMimeHeaders()
      Removes all the MimeHeader objects for this SOAPEnvelope object.
      abstract void removeMimeHeader(String header)
      Removes all MIME headers that match the given name.
      abstract void setContent(Source source)
      Sets the content of the SOAPEnvelope object with the data from the given Source object.
      void setContentId(String contentId)
      Sets the value of the MIME header named "Content-Id" to the given String.
      void setContentLocation(String contentLocation)
      Sets the value of the MIME header "Content-Location" to the given String.
      abstract void setMimeHeader(String name, String value)
      Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.w3c.dom.Document

        adoptNode, createAttribute, createAttributeNS, createCDATASection, createComment, createDocumentFragment, createElement, createElementNS, createEntityReference, createProcessingInstruction, createTextNode, getDoctype, getDocumentElement, getDocumentURI, getDomConfig, getElementById, getElementsByTagName, getElementsByTagNameNS, getImplementation, getInputEncoding, getStrictErrorChecking, getXmlEncoding, getXmlStandalone, getXmlVersion, importNode, normalizeDocument, renameNode, setDocumentURI, setStrictErrorChecking, setXmlStandalone, setXmlVersion

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Constructor Detail

      • SOAPPart

        public SOAPPart()

    • Method Detail

      • getEnvelope

        public abstract SOAPEnvelope getEnvelope()
                                  throws SOAPException
        Gets the SOAPEnvelope object associated with this SOAPPart object. Once the SOAP envelope is obtained, it can be used to get its contents.
        Returns:
        the SOAPEnvelope object for this SOAPPart object
        Throws:
        SOAPException - if there is a SOAP error

      • getContentId

        public String getContentId()
        Retrieves the value of the MIME header whose name is "Content-Id".
        Returns:
        a String giving the value of the MIME header named "Content-Id"
        See Also:
        setContentId(java.lang.String)

      • getContentLocation

        public String getContentLocation()
        Retrieves the value of the MIME header whose name is "Content-Location".
        Returns:
        a String giving the value of the MIME header whose name is "Content-Location"
        See Also:
        setContentLocation(java.lang.String)

      • setContentId

        public void setContentId(String contentId)
        Sets the value of the MIME header named "Content-Id" to the given String.
        Parameters:
        contentId - a String giving the value of the MIME header "Content-Id"
        Throws:
        IllegalArgumentException - if there is a problem in setting the content id
        See Also:
        getContentId()

      • setContentLocation

        public void setContentLocation(String contentLocation)
        Sets the value of the MIME header "Content-Location" to the given String.
        Parameters:
        contentLocation - a String giving the value of the MIME header "Content-Location"
        Throws:
        IllegalArgumentException - if there is a problem in setting the content location.
        See Also:
        getContentLocation()

      • removeMimeHeader

        public abstract void removeMimeHeader(String header)
        Removes all MIME headers that match the given name.
        Parameters:
        header - a String giving the name of the MIME header(s) to be removed

      • removeAllMimeHeaders

        public abstract void removeAllMimeHeaders()
        Removes all the MimeHeader objects for this SOAPEnvelope object.

      • getMimeHeader

        public abstract String[] getMimeHeader(String name)
        Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.
        Parameters:
        name - the name of the header; example: "Content-Type"
        Returns:
        a String array giving all the values for the specified header
        See Also:
        setMimeHeader(java.lang.String, java.lang.String)

      • setMimeHeader

        public abstract void setMimeHeader(String name,
                 String value)
        Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match. If there is a match, this method clears all existing values for the first header that matches and sets the given value instead. If more than one header has the given name, this method removes all of the matching headers after the first one.

        Note that RFC822 headers can contain only US-ASCII characters.

        Parameters:
        name - a String giving the header name for which to search
        value - a String giving the value to be set. This value will be substituted for the current value(s) of the first header that is a match if there is one. If there is no match, this value will be the value for a new MimeHeader object.
        Throws:
        IllegalArgumentException - if there was a problem with the specified mime header name or value
        See Also:
        getMimeHeader(java.lang.String)

      • addMimeHeader

        public abstract void addMimeHeader(String name,
                 String value)
        Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object. If a MimeHeader with the specified name already exists, this method adds the specified value to the already existing value(s).

        Note that RFC822 headers can contain only US-ASCII characters.

        Parameters:
        name - a String giving the header name
        value - a String giving the value to be set or added
        Throws:
        IllegalArgumentException - if there was a problem with the specified mime header name or value

      • getAllMimeHeaders

        public abstract Iterator getAllMimeHeaders()
        Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.
        Returns:
        an Iterator object with all of the Mime headers for this SOAPPart object

      • getMatchingMimeHeaders

        public abstract Iterator getMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects that match a name in the given array.
        Parameters:
        names - a String array with the name(s) of the MIME headers to be returned
        Returns:
        all of the MIME headers that match one of the names in the given array, returned as an Iterator object

      • getNonMatchingMimeHeaders

        public abstract Iterator getNonMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects whose name does not match a name in the given array.
        Parameters:
        names - a String array with the name(s) of the MIME headers not to be returned
        Returns:
        all of the MIME headers in this SOAPPart object except those that match one of the names in the given array. The nonmatching MIME headers are returned as an Iterator object.

      • setContent

        public abstract void setContent(Source source)
                         throws SOAPException
        Sets the content of the SOAPEnvelope object with the data from the given Source object. This Source must contain a valid SOAP document.
        Parameters:
        source - the javax.xml.transform.Source object with the data to be set
        Throws:
        SOAPException - if there is a problem in setting the source
        See Also:
        getContent()

      • getContent

        public abstract Source getContent()
                           throws SOAPException
        Returns the content of the SOAPEnvelope as a JAXP Source object.
        Returns:
        the content as a javax.xml.transform.Source object
        Throws:
        SOAPException - if the implementation cannot convert the specified Source object
        See Also:
        setContent(javax.xml.transform.Source)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Text (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface Text

  • All Superinterfaces:
    CharacterData, Node, Text

    public interface Text
extends Node, Text
    A representation of a node whose value is text. A Text object may represent text that is content or text that is a comment.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      boolean isComment()
      Retrieves whether this Text object represents a comment.

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Text

        getWholeText, isElementContentWhitespace, replaceWholeText, splitText

      • Methods inherited from interface org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • isComment

        boolean isComment()
        Retrieves whether this Text object represents a comment.
        Returns:
        true if this Text object is a comment; false otherwise
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.soap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.soap

  • Packages that use javax.xml.soap
    Package Description
    javax.xml.rpc.handler.soap
    This package defines APIs for SOAP Message Handlers
    javax.xml.rpc.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
  • Classes in javax.xml.soap used by javax.xml.rpc.handler.soap
    Class and Description
    SOAPMessage
    The root class for all SOAP messages.
  • Classes in javax.xml.soap used by javax.xml.rpc.soap
    Class and Description
    Detail
    A container for DetailEntry objects.
  • Classes in javax.xml.soap used by javax.xml.soap
    Class and Description
    AttachmentPart
    A single attachment to a SOAPMessage object.
    Detail
    A container for DetailEntry objects.
    DetailEntry
    The content for a Detail object, giving details for a SOAPFault object.
    MessageFactory
    A factory for creating SOAPMessage objects.
    MimeHeaders
    A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.
    Name
    A representation of an XML name.
    Node
    A representation of a node (element) in an XML document.
    SOAPBody
    An object that represents the contents of the SOAP body element in a SOAP message.
    SOAPBodyElement
    A SOAPBodyElement object represents the contents in a SOAPBody object.
    SOAPConnection
    A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).
    SOAPConnectionFactory
    A factory for creating SOAPConnection objects.
    SOAPElement
    An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
    SOAPElementFactory
    Deprecated.
    - Use javax.xml.soap.SOAPFactory for creating SOAPElements.
    SOAPEnvelope
    The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
    SOAPException
    An exception that signals that a SOAP exception has occurred.
    SOAPFactory
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
    SOAPFault
    An element in the SOAPBody object that contains error and/or status information.
    SOAPFaultElement
    A representation of the contents in a SOAPFault object.
    SOAPHeader
    A representation of the SOAP header element.
    SOAPHeaderElement
    An object representing the contents in the SOAP header part of the SOAP envelope.
    SOAPMessage
    The root class for all SOAP messages.
    SOAPPart
    The container for the SOAP-specific portion of a SOAPMessage object.
  • Classes in javax.xml.soap used by javax.xml.ws.soap
    Class and Description
    MessageFactory
    A factory for creating SOAPMessage objects.
    SOAPFactory
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
    SOAPFault
    An element in the SOAPBody object that contains error and/or status information.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.AttachmentPart (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.AttachmentPart

  • Packages that use AttachmentPart
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of AttachmentPart in javax.xml.soap

      Methods in javax.xml.soap that return AttachmentPart
      Modifier and Type Method and Description
      abstract AttachmentPart SOAPMessage.createAttachmentPart()
      Creates a new empty AttachmentPart object.
      AttachmentPart SOAPMessage.createAttachmentPart(DataHandler dataHandler)
      Creates an AttachmentPart object and populates it using the given DataHandler object.
      AttachmentPart SOAPMessage.createAttachmentPart(Object content, String contentType)
      Creates an AttachmentPart object and populates it with the specified data of the specified content type.
      abstract AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      Methods in javax.xml.soap with parameters of type AttachmentPart
      Modifier and Type Method and Description
      abstract void SOAPMessage.addAttachmentPart(AttachmentPart AttachmentPart)
      Adds the given AttachmentPart object to this SOAPMessage object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.MessageFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.MessageFactory

  • Packages that use MessageFactory
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of MessageFactory in javax.xml.soap

      Methods in javax.xml.soap that return MessageFactory
      Modifier and Type Method and Description
      static MessageFactory MessageFactory.newInstance()
      Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
      static MessageFactory MessageFactory.newInstance(String protocol)
      Creates a new MessageFactory object that is an instance of the specified implementation.
      protected abstract MessageFactory SAAJMetaFactory.newMessageFactory(String protocol)
      Creates a MessageFactory object for the given String protocol.

    • Uses of MessageFactory in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return MessageFactory
      Modifier and Type Method and Description
      MessageFactory SOAPBinding.getMessageFactory()
      Gets the SAAJ MessageFactory instance used by this SOAP binding.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.MimeHeader (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.MimeHeader

No usage of javax.xml.soap.MimeHeader
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.MimeHeaders (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.MimeHeaders

  • Packages that use MimeHeaders
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of MimeHeaders in javax.xml.soap

      Methods in javax.xml.soap that return MimeHeaders
      Modifier and Type Method and Description
      abstract MimeHeaders SOAPMessage.getMimeHeaders()
      Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
      Methods in javax.xml.soap with parameters of type MimeHeaders
      Modifier and Type Method and Description
      abstract SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      abstract Iterator SOAPMessage.getAttachments(MimeHeaders headers)
      Retrieves all the AttachmentPart objects that have header entries that match the specified headers.
      abstract void SOAPMessage.removeAttachments(MimeHeaders headers)
      Removes all the AttachmentPart objects that have header entries that match the specified headers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.SAAJMetaFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SAAJMetaFactory

No usage of javax.xml.soap.SAAJMetaFactory
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.SAAJResult (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SAAJResult

No usage of javax.xml.soap.SAAJResult
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.SOAPConnection (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPConnection

  • Packages that use SOAPConnection
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPConnection in javax.xml.soap

      Methods in javax.xml.soap that return SOAPConnection
      Modifier and Type Method and Description
      abstract SOAPConnection SOAPConnectionFactory.createConnection()
      Create a new SOAPConnection.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.SOAPConnectionFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPConnectionFactory

  • Packages that use SOAPConnectionFactory
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPConnectionFactory in javax.xml.soap

      Methods in javax.xml.soap that return SOAPConnectionFactory
      Modifier and Type Method and Description
      static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
      Creates an instance of the default SOAPConnectionFactory object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.SOAPElementFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPElementFactory

  • Packages that use SOAPElementFactory
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPElementFactory in javax.xml.soap

      Methods in javax.xml.soap that return SOAPElementFactory
      Modifier and Type Method and Description
      static SOAPElementFactory SOAPElementFactory.newInstance()
      Deprecated.
      Creates a new instance of SOAPElementFactory.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.SOAPException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPException

  • Packages that use SOAPException
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPException in javax.xml.soap

      Methods in javax.xml.soap that throw SOAPException
      Modifier and Type Method and Description
      SOAPElement SOAPElement.addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement SOAPElement.addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPBody SOAPEnvelope.addBody()
      Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
      SOAPBodyElement SOAPBody.addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPBodyElement SOAPBody.addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPElement SOAPElement.addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      SOAPElement SOAPElement.addChildElement(String localName)
      Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix)
      Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
      Detail SOAPFault.addDetail()
      Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
      DetailEntry Detail.addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      DetailEntry Detail.addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
      SOAPBodyElement SOAPBody.addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.
      SOAPFault SOAPBody.addFault()
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      void SOAPFault.addFaultReasonText(String text, Locale locale)
      Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.
      SOAPHeader SOAPEnvelope.addHeader()
      Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPElement SOAPElement.addNamespaceDeclaration(String prefix, String uri)
      Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
      SOAPHeaderElement SOAPHeader.addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPElement SOAPElement.addTextNode(String text)
      Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
      void SOAPFault.appendFaultSubcode(QName subcode)
      Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
      abstract SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      abstract void SOAPConnection.close()
      Closes this SOAPConnection object.
      SOAPElement SOAPElementFactory.create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      SOAPElement SOAPElementFactory.create(String localName)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
      SOAPElement SOAPElementFactory.create(String localName, String prefix, String uri)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
      abstract SOAPConnection SOAPConnectionFactory.createConnection()
      Create a new SOAPConnection.
      abstract Detail SOAPFactory.createDetail()
      Creates a new Detail object which serves as a container for DetailEntry objects.
      SOAPElement SOAPFactory.createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.
      abstract SOAPElement SOAPFactory.createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      SOAPElement SOAPFactory.createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPElement SOAPFactory.createElement(String localName)
      Creates a SOAPElement object initialized with the given local name.
      abstract SOAPElement SOAPFactory.createElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object with the given local name, prefix and uri.
      abstract SOAPFault SOAPFactory.createFault()
      Creates a new default SOAPFault object
      abstract SOAPFault SOAPFactory.createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      abstract SOAPMessage MessageFactory.createMessage()
      Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
      abstract SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      abstract Name SOAPFactory.createName(String localName)
      Creates a new Name object initialized with the given local name.
      Name SOAPEnvelope.createName(String localName)
      Creates a new Name object initialized with the given local name.
      abstract Name SOAPFactory.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      Name SOAPEnvelope.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      QName SOAPElement.createQName(String localName, String prefix)
      Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
      Document SOAPBody.extractContentAsDocument()
      Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
      SOAPMessage SOAPConnection.get(Object to)
      Gets a message from a specific endpoint and blocks until it receives,
      abstract AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      abstract InputStream AttachmentPart.getBase64Content()
      Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
      SOAPBody SOAPEnvelope.getBody()
      Returns the SOAPBody object associated with this SOAPEnvelope object.
      abstract Source SOAPPart.getContent()
      Returns the content of the SOAPEnvelope as a JAXP Source object.
      abstract Object AttachmentPart.getContent()
      Gets the content of this AttachmentPart object as a Java object.
      abstract DataHandler AttachmentPart.getDataHandler()
      Gets the DataHandler object for this AttachmentPart object.
      abstract SOAPEnvelope SOAPPart.getEnvelope()
      Gets the SOAPEnvelope object associated with this SOAPPart object.
      Iterator SOAPFault.getFaultReasonLocales()
      Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.
      String SOAPFault.getFaultReasonText(Locale locale)
      Returns the Reason Text associated with the given Locale.
      Iterator SOAPFault.getFaultReasonTexts()
      Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
      SOAPHeader SOAPEnvelope.getHeader()
      Returns the SOAPHeader object for this SOAPEnvelope object.
      Object SOAPMessage.getProperty(String property)
      Retrieves value of the specified property.
      abstract InputStream AttachmentPart.getRawContent()
      Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract byte[] AttachmentPart.getRawContentBytes()
      Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract int AttachmentPart.getSize()
      Returns the number of bytes in this AttachmentPart object.
      SOAPBody SOAPMessage.getSOAPBody()
      Gets the SOAP Body contained in this SOAPMessage object.
      SOAPHeader SOAPMessage.getSOAPHeader()
      Gets the SOAP Header contained in this SOAPMessage object.
      static SOAPFactory SOAPFactory.newInstance()
      Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
      static SOAPElementFactory SOAPElementFactory.newInstance()
      Deprecated.
      Creates a new instance of SOAPElementFactory.
      static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
      Creates an instance of the default SOAPConnectionFactory object.
      static MessageFactory MessageFactory.newInstance()
      Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
      static SOAPFactory SOAPFactory.newInstance(String protocol)
      Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
      static MessageFactory MessageFactory.newInstance(String protocol)
      Creates a new MessageFactory object that is an instance of the specified implementation.
      protected abstract MessageFactory SAAJMetaFactory.newMessageFactory(String protocol)
      Creates a MessageFactory object for the given String protocol.
      protected abstract SOAPFactory SAAJMetaFactory.newSOAPFactory(String protocol)
      Creates a SOAPFactory object for the given String protocol.
      abstract void SOAPMessage.saveChanges()
      Updates this SOAPMessage object with all the changes that have been made to it.
      abstract void AttachmentPart.setBase64Content(InputStream content, String contentType)
      Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.
      abstract void SOAPPart.setContent(Source source)
      Sets the content of the SOAPEnvelope object with the data from the given Source object.
      SOAPElement SOAPElement.setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      void SOAPElement.setEncodingStyle(String encodingStyle)
      Sets the encoding style for this SOAPElement object to one specified.
      void SOAPFault.setFaultActor(String faultActor)
      Sets this SOAPFault object with the given fault actor.
      void SOAPFault.setFaultCode(Name faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void SOAPFault.setFaultCode(QName faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void SOAPFault.setFaultCode(String faultCode)
      Sets this SOAPFault object with the give fault code.
      void SOAPFault.setFaultNode(String uri)
      Creates or replaces any existing Node element value for this SOAPFault object.
      void SOAPFault.setFaultRole(String uri)
      Creates or replaces any existing Role element value for this SOAPFault object.
      void SOAPFault.setFaultString(String faultString)
      Sets the fault string for this SOAPFault object to the given string.
      void SOAPFault.setFaultString(String faultString, Locale locale)
      Sets the fault string for this SOAPFault object to the given string and localized to the given locale.
      void Node.setParentElement(SOAPElement parent)
      Sets the parent of this Node object to the given SOAPElement object.
      void SOAPMessage.setProperty(String property, Object value)
      Associates the specified value with the specified property.
      abstract void AttachmentPart.setRawContent(InputStream content, String contentType)
      Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.
      abstract void AttachmentPart.setRawContentBytes(byte[] content, int offset, int len, String contentType)
      Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.
      void SOAPHeaderElement.setRelay(boolean relay)
      Sets the relay attribute for this SOAPHeaderElement to be either true or false.
      void SOAPHeaderElement.setRole(String uri)
      Sets the Role associated with this SOAPHeaderElement object to the specified Role.
      abstract void SOAPMessage.writeTo(OutputStream out)
      Writes this SOAPMessage object to the given output stream.
      Constructors in javax.xml.soap that throw SOAPException
      Constructor and Description
      SAAJResult()
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.
      SAAJResult(String protocol)
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.SOAPFactory (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPFactory

  • Packages that use SOAPFactory
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of SOAPFactory in javax.xml.soap

      Methods in javax.xml.soap that return SOAPFactory
      Modifier and Type Method and Description
      static SOAPFactory SOAPFactory.newInstance()
      Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
      static SOAPFactory SOAPFactory.newInstance(String protocol)
      Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
      protected abstract SOAPFactory SAAJMetaFactory.newSOAPFactory(String protocol)
      Creates a SOAPFactory object for the given String protocol.

    • Uses of SOAPFactory in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return SOAPFactory
      Modifier and Type Method and Description
      SOAPFactory SOAPBinding.getSOAPFactory()
      Gets the SAAJ SOAPFactory instance used by this SOAP binding.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.SOAPMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPMessage

  • Packages that use SOAPMessage
    Package Description
    javax.xml.rpc.handler.soap
    This package defines APIs for SOAP Message Handlers
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of SOAPMessage in javax.xml.rpc.handler.soap

      Methods in javax.xml.rpc.handler.soap that return SOAPMessage
      Modifier and Type Method and Description
      SOAPMessage SOAPMessageContext.getMessage()
      Gets the SOAPMessage from this message context
      Methods in javax.xml.rpc.handler.soap with parameters of type SOAPMessage
      Modifier and Type Method and Description
      void SOAPMessageContext.setMessage(SOAPMessage message)
      Sets the SOAPMessage in this message context

    • Uses of SOAPMessage in javax.xml.soap

      Methods in javax.xml.soap that return SOAPMessage
      Modifier and Type Method and Description
      abstract SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      abstract SOAPMessage MessageFactory.createMessage()
      Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
      abstract SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      SOAPMessage SOAPConnection.get(Object to)
      Gets a message from a specific endpoint and blocks until it receives,
      Methods in javax.xml.soap with parameters of type SOAPMessage
      Modifier and Type Method and Description
      abstract SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      Constructors in javax.xml.soap with parameters of type SOAPMessage
      Constructor and Description
      SAAJResult(SOAPMessage message)
      Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage.

    • Uses of SOAPMessage in javax.xml.ws.handler.soap

      Methods in javax.xml.ws.handler.soap that return SOAPMessage
      Modifier and Type Method and Description
      SOAPMessage SOAPMessageContext.getMessage()
      Gets the SOAPMessage from this message context.
      Methods in javax.xml.ws.handler.soap with parameters of type SOAPMessage
      Modifier and Type Method and Description
      void SOAPMessageContext.setMessage(SOAPMessage message)
      Sets the SOAPMessage in this message context
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.soap.SOAPPart (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPPart

  • Packages that use SOAPPart
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPPart in javax.xml.soap

      Methods in javax.xml.soap that return SOAPPart
      Modifier and Type Method and Description
      abstract SOAPPart SOAPMessage.getSOAPPart()
      Gets the SOAP part of this SOAPMessage object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.Detail (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.Detail

  • Packages that use Detail
    Package Description
    javax.xml.rpc.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of Detail in javax.xml.rpc.soap

      Methods in javax.xml.rpc.soap that return Detail
      Modifier and Type Method and Description
      Detail SOAPFaultException.getDetail()
      Gets the detail element.
      Constructors in javax.xml.rpc.soap with parameters of type Detail
      Constructor and Description
      SOAPFaultException(QName faultcode, String faultstring, String faultactor, Detail faultdetail)
      Constructor for the SOAPFaultException

    • Uses of Detail in javax.xml.soap

      Methods in javax.xml.soap that return Detail
      Modifier and Type Method and Description
      Detail SOAPFault.addDetail()
      Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
      abstract Detail SOAPFactory.createDetail()
      Creates a new Detail object which serves as a container for DetailEntry objects.
      Detail SOAPFault.getDetail()
      Returns the optional detail element for this SOAPFault object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.DetailEntry (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.DetailEntry

  • Packages that use DetailEntry
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of DetailEntry in javax.xml.soap

      Methods in javax.xml.soap that return DetailEntry
      Modifier and Type Method and Description
      DetailEntry Detail.addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      DetailEntry Detail.addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.Name (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.Name

  • Packages that use Name
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of Name in javax.xml.soap

      Methods in javax.xml.soap that return Name
      Modifier and Type Method and Description
      abstract Name SOAPFactory.createName(String localName)
      Creates a new Name object initialized with the given local name.
      Name SOAPEnvelope.createName(String localName)
      Creates a new Name object initialized with the given local name.
      abstract Name SOAPFactory.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      Name SOAPEnvelope.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      Name SOAPElement.getElementName()
      Returns the name of this SOAPElement object.
      Name SOAPFault.getFaultCodeAsName()
      Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.
      Methods in javax.xml.soap with parameters of type Name
      Modifier and Type Method and Description
      SOAPElement SOAPElement.addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPBodyElement SOAPBody.addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPElement SOAPElement.addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      DetailEntry Detail.addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPElement SOAPElementFactory.create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      abstract SOAPElement SOAPFactory.createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      String SOAPElement.getAttributeValue(Name name)
      Returns the value of the attribute with the specified name.
      Iterator SOAPElement.getChildElements(Name name)
      Returns an Iterator over all the immediate child Nodes of this element with the specified name.
      boolean SOAPElement.removeAttribute(Name name)
      Removes the attribute with the specified name.
      void SOAPFault.setFaultCode(Name faultCodeQName)
      Sets this SOAPFault object with the given fault code.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.Node (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.Node

  • Packages that use Node
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of Node in javax.xml.soap

      Subinterfaces of Node in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPElement
      An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      interface  Text
      A representation of a node whose value is text.
      Methods in javax.xml.soap that return Node
      Modifier and Type | Method and Description
      Node | SAAJResult.getResult()
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.SOAPBody (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPBody

  • Packages that use SOAPBody
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPBody in javax.xml.soap

      Methods in javax.xml.soap that return SOAPBody
      Modifier and Type Method and Description
      SOAPBody SOAPEnvelope.addBody()
      Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
      SOAPBody SOAPEnvelope.getBody()
      Returns the SOAPBody object associated with this SOAPEnvelope object.
      SOAPBody SOAPMessage.getSOAPBody()
      Gets the SOAP Body contained in this SOAPMessage object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.SOAPBodyElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPBodyElement

  • Packages that use SOAPBodyElement
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPBodyElement in javax.xml.soap

      Subinterfaces of SOAPBodyElement in javax.xml.soap
      Modifier and Type Interface and Description
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      Methods in javax.xml.soap that return SOAPBodyElement
      Modifier and Type Method and Description
      SOAPBodyElement SOAPBody.addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPBodyElement SOAPBody.addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPBodyElement SOAPBody.addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.SOAPConstants (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPConstants

No usage of javax.xml.soap.SOAPConstants
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.SOAPElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPElement

  • Packages that use SOAPElement
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPElement in javax.xml.soap

      Subinterfaces of SOAPElement in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      Methods in javax.xml.soap that return SOAPElement
      Modifier and Type Method and Description
      SOAPElement SOAPElement.addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement SOAPElement.addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      SOAPElement SOAPElement.addChildElement(String localName)
      Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix)
      Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addNamespaceDeclaration(String prefix, String uri)
      Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
      SOAPElement SOAPElement.addTextNode(String text)
      Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
      SOAPElement SOAPElementFactory.create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      SOAPElement SOAPElementFactory.create(String localName)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
      SOAPElement SOAPElementFactory.create(String localName, String prefix, String uri)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
      SOAPElement SOAPFactory.createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.
      abstract SOAPElement SOAPFactory.createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      SOAPElement SOAPFactory.createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPElement SOAPFactory.createElement(String localName)
      Creates a SOAPElement object initialized with the given local name.
      abstract SOAPElement SOAPFactory.createElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object with the given local name, prefix and uri.
      SOAPElement Node.getParentElement()
      Returns the parent element of this Node object.
      SOAPElement SOAPElement.setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      Methods in javax.xml.soap with parameters of type SOAPElement
      Modifier and Type Method and Description
      SOAPElement SOAPElement.addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      abstract AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      void Node.setParentElement(SOAPElement parent)
      Sets the parent of this Node object to the given SOAPElement object.
      Constructors in javax.xml.soap with parameters of type SOAPElement
      Constructor and Description
      SAAJResult(SOAPElement rootNode)
      Creates a SAAJResult that will write the results as a child node of the SOAPElement specified.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.SOAPEnvelope (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPEnvelope

  • Packages that use SOAPEnvelope
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPEnvelope in javax.xml.soap

      Methods in javax.xml.soap that return SOAPEnvelope
      Modifier and Type Method and Description
      abstract SOAPEnvelope SOAPPart.getEnvelope()
      Gets the SOAPEnvelope object associated with this SOAPPart object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.SOAPFault (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPFault

  • Packages that use SOAPFault
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of SOAPFault in javax.xml.soap

      Methods in javax.xml.soap that return SOAPFault
      Modifier and Type Method and Description
      SOAPFault SOAPBody.addFault()
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      abstract SOAPFault SOAPFactory.createFault()
      Creates a new default SOAPFault object
      abstract SOAPFault SOAPFactory.createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      SOAPFault SOAPBody.getFault()
      Returns the SOAPFault object in this SOAPBody object.

    • Uses of SOAPFault in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return SOAPFault
      Modifier and Type Method and Description
      SOAPFault SOAPFaultException.getFault()
      Gets the embedded SOAPFault instance.
      Constructors in javax.xml.ws.soap with parameters of type SOAPFault
      Constructor and Description
      SOAPFaultException(SOAPFault fault)
      Constructor for SOAPFaultException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.SOAPFaultElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPFaultElement

  • Packages that use SOAPFaultElement
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPFaultElement in javax.xml.soap

      Subinterfaces of SOAPFaultElement in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Detail
      A container for DetailEntry objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.SOAPHeader (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPHeader

  • Packages that use SOAPHeader
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPHeader in javax.xml.soap

      Methods in javax.xml.soap that return SOAPHeader
      Modifier and Type Method and Description
      SOAPHeader SOAPEnvelope.addHeader()
      Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
      SOAPHeader SOAPEnvelope.getHeader()
      Returns the SOAPHeader object for this SOAPEnvelope object.
      SOAPHeader SOAPMessage.getSOAPHeader()
      Gets the SOAP Header contained in this SOAPMessage object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.SOAPHeaderElement (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPHeaderElement

  • Packages that use SOAPHeaderElement
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPHeaderElement in javax.xml.soap

      Methods in javax.xml.soap that return SOAPHeaderElement
      Modifier and Type Method and Description
      SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.soap.Text (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.Text

No usage of javax.xml.soap.Text
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Action (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type Action

  • @Documented
@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface Action
    The Action annotation allows explicit association of a WS-Addressing Action message addressing property with input, output, and fault messages of the mapped WSDL operation.

    This annotation can be specified on each method of a service endpoint interface. For such a method, the mapped operation in the generated WSDL's wsam:Action attribute on the WSDL input, output and fault messages of the WSDL operation is based upon which attributes of the Action annotation have been specified. For the exact computation of wsam:Action values for the messages, refer to the algorithm in the JAX-WS specification.

    Example 1: Specify explicit values for Action message addressing property for input and output messages.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(
         input="http://example.com/inputAction",
         output="http://example.com/outputAction")
     public int addNumbers(int number1, int number2) {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         <input message="tns:AddNumbersInput" name="foo"
           wsam:Action="http://example.com/inputAction"/>
         <output message="tns:AddNumbersOutput" name="bar"
           wsam:Action="http://example.com/outputAction"/>
       </operation>
     </portType>
     ...
   </definitions>

    Example 2: Specify explicit value for Action message addressing property for only the input message. The wsam:Action values for the WSDL output message are computed using the algorithm in the JAX-WS specification.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(input="http://example.com/inputAction")
     public int addNumbers(int number1, int number2) {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         <input message="tns:AddNumbersInput" name="foo"
           wsam:Action="http://example.com/inputAction" />
         <output message="tns:AddNumbersOutput" name="bar"
           wsam:Action="http://example.com/numbers/AddNumbersPortType/AddNumbersResponse"/>
       </operation>
     </portType>
     ...
   </definitions>
    It is legitimate to specify an explicit value for Action message addressing property for output message only. In this case, wsam:Action value for the WSDL input message is computed using the algorithm in the JAX-WS specification.

    Example 3: See FaultAction annotation for an example of how to specify an explicit value for Action message addressing property for the fault message.

    Since:
    JAX-WS 2.1
    See Also:
    FaultAction

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      FaultAction[] fault
      Explicit value of the WS-Addressing Action message addressing property for the fault message(s) of the operation.
      String input
      Explicit value of the WS-Addressing Action message addressing property for the input message of the operation.
      String output
      Explicit value of the WS-Addressing Action message addressing property for the output message of the operation.

    • Element Detail

      • input

        public abstract String input
        Explicit value of the WS-Addressing Action message addressing property for the input message of the operation.
        Default:
        ""

      • output

        public abstract String output
        Explicit value of the WS-Addressing Action message addressing property for the output message of the operation.
        Default:
        ""

      • fault

        public abstract FaultAction[] fault
        Explicit value of the WS-Addressing Action message addressing property for the fault message(s) of the operation. Each exception that is mapped to a fault and requires an explicit WS-Addressing Action message addressing property, needs to be specified as a value in this property using FaultAction annotation.
        Default:
        {}
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AsyncHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface AsyncHandler<T>

  • public interface AsyncHandler<T>
    The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
    Since:
    JAX-WS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void handleResponse(Response<T> res)
      Called when the response to an asynchronous operation is available.

    • Method Detail

      • handleResponse

        void handleResponse(Response<T> res)
        Called when the response to an asynchronous operation is available.
        Parameters:
        res - The response to the operation invocation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Binding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface Binding

  • All Known Subinterfaces:
    HTTPBinding, SOAPBinding

    public interface Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    Since:
    JAX-WS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getBindingID()
      Get the URI for this binding instance.
      List<Handler> getHandlerChain()
      Gets a copy of the handler chain for a protocol binding instance.
      void setHandlerChain(List<Handler> chain)
      Sets the handler chain for the protocol binding instance.

    • Method Detail

      • getHandlerChain

        List<Handler> getHandlerChain()
        Gets a copy of the handler chain for a protocol binding instance. If the returned chain is modified a call to setHandlerChain is required to configure the binding instance with the new chain.
        Returns:
        java.util.List<Handler> Handler chain

      • setHandlerChain

        void setHandlerChain(List<Handler> chain)
        Sets the handler chain for the protocol binding instance.
        Parameters:
        chain - A List of handler configuration entries
        Throws:
        WebServiceException - On an error in the configuration of the handler chain
        UnsupportedOperationException - If this operation is not supported. This may be done to avoid any overriding of a pre-configured handler chain.

      • getBindingID

        String getBindingID()
        Get the URI for this binding instance.
        Returns:
        String The binding identifier for the port. Never returns null
        Since:
        JAX-WS 2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BindingProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface BindingProvider

  • All Known Subinterfaces:
    Dispatch<T>

    public interface BindingProvider
    The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
    Since:
    JAX-WS 2.0
    See Also:
    Binding

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ENDPOINT_ADDRESS_PROPERTY
      Standard property: Target service endpoint address.
      static String PASSWORD_PROPERTY
      Standard property: Password for authentication.
      static String SESSION_MAINTAIN_PROPERTY
      Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.
      static String SOAPACTION_URI_PROPERTY
      Standard property for SOAPAction.
      static String SOAPACTION_USE_PROPERTY
      Standard property for SOAPAction.
      static String USERNAME_PROPERTY
      Standard property: User name for authentication.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Binding getBinding()
      Get the Binding for this binding provider.
      EndpointReference getEndpointReference()
      Returns the EndpointReference associated with this BindingProvider instance.
      <T extends EndpointReference>
      T             		getEndpointReference(Class<T> clazz)
      Returns the EndpointReference associated with this BindingProvider instance.
      Map<String,Object> getRequestContext()
      Get the context that is used to initialize the message context for request messages.
      Map<String,Object> getResponseContext()
      Get the context that resulted from processing a response message.

    • Field Detail

      • USERNAME_PROPERTY

        static final String USERNAME_PROPERTY
        Standard property: User name for authentication.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • PASSWORD_PROPERTY

        static final String PASSWORD_PROPERTY
        Standard property: Password for authentication.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • ENDPOINT_ADDRESS_PROPERTY

        static final String ENDPOINT_ADDRESS_PROPERTY
        Standard property: Target service endpoint address. The URI scheme for the endpoint address specification MUST correspond to the protocol/transport binding for the binding in use.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • SESSION_MAINTAIN_PROPERTY

        static final String SESSION_MAINTAIN_PROPERTY
        Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint. If this property is set to true, the service client indicates that it wants the session to be maintained. If set to false, the session is not maintained. The default value for this property is false.

        Type: java.lang.Boolean

        See Also:
        Constant Field Values

      • SOAPACTION_USE_PROPERTY

        static final String SOAPACTION_USE_PROPERTY
        Standard property for SOAPAction. This boolean property indicates whether or not the value of the javax.xml.ws.soap.http.soapaction.uri property is used for the value of the SOAPAction. The default value of this property is false indicating that the javax.xml.ws.soap.http.soapaction.uri property is not used for the value of the SOAPAction, however, if WS-Addressing is enabled, the default value is true.

        Type: java.lang.Boolean

        See Also:
        Constant Field Values

      • SOAPACTION_URI_PROPERTY

        static final String SOAPACTION_URI_PROPERTY
        Standard property for SOAPAction. Indicates the SOAPAction URI if the javax.xml.ws.soap.http.soapaction.use property is set to true. If WS-Addressing is enabled, this value will also be used for the value of the WS-Addressing Action header. If this property is not set, the default SOAPAction and WS-Addressing Action will be sent.

        Type: java.lang.String

        See Also:
        Constant Field Values

    • Method Detail

      • getRequestContext

        Map<String,Object> getRequestContext()
        Get the context that is used to initialize the message context for request messages. Modifications to the request context do not affect the message context of either synchronous or asynchronous operations that have already been started.
        Returns:
        The context that is used in processing request messages.

      • getResponseContext

        Map<String,Object> getResponseContext()
        Get the context that resulted from processing a response message. The returned context is for the most recently completed synchronous operation. Subsequent synchronous operation invocations overwrite the response context. Asynchronous operations return their response context via the Response interface.
        Returns:
        The context that resulted from processing the latest response messages.

      • getBinding

        Binding getBinding()
        Get the Binding for this binding provider.
        Returns:
        The Binding for this binding provider.

      • getEndpointReference

        EndpointReference getEndpointReference()
        Returns the EndpointReference associated with this BindingProvider instance.

        If the Binding for this bindingProvider is either SOAP1.1/HTTP or SOAP1.2/HTTP, then a W3CEndpointReference MUST be returned.

        Returns:
        EndpointReference of the target endpoint associated with this BindingProvider instance.
        Throws:
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        Since:
        JAX-WS 2.1
        See Also:
        W3CEndpointReference

      • getEndpointReference

        <T extends EndpointReference> T getEndpointReference(Class<T> clazz)
        Returns the EndpointReference associated with this BindingProvider instance. The instance returned will be of type clazz.
        Parameters:
        clazz - Specifies the type of EndpointReference that MUST be returned.
        Returns:
        EndpointReference of the target endpoint associated with this BindingProvider instance. MUST be of type clazz.
        Throws:
        WebServiceException - If the Class clazz is not supported by this implementation.
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        Since:
        JAX-WS 2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


BindingType (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type BindingType

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface BindingType
    The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.

    This annotation may be overriden programmatically or via deployment descriptors, depending on the platform in use.

    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String value
      A binding identifier (a URI).

    • Element Detail

      • value

        public abstract String value
        A binding identifier (a URI). If not specified, the default is the SOAP 1.1 / HTTP binding.

        See the SOAPBinding and HTTPBinding for the definition of the standard binding identifiers.

        See Also:
        Binding, SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Dispatch (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface Dispatch<T>

  • All Superinterfaces:
    BindingProvider

    public interface Dispatch<T>
extends BindingProvider
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations. The javax.xml.ws.Service class acts as a factory for the creation of Dispatch instances.
    Since:
    JAX-WS 2.0

    • Field Summary

      • Fields inherited from interface javax.xml.ws.BindingProvider

        ENDPOINT_ADDRESS_PROPERTY, PASSWORD_PROPERTY, SESSION_MAINTAIN_PROPERTY, SOAPACTION_URI_PROPERTY, SOAPACTION_USE_PROPERTY, USERNAME_PROPERTY

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T invoke(T msg)
      Invoke a service operation synchronously.
      Response<T> invokeAsync(T msg)
      Invoke a service operation asynchronously.
      Future<?> invokeAsync(T msg, AsyncHandler<T> handler)
      Invoke a service operation asynchronously.
      void invokeOneWay(T msg)
      Invokes a service operation using the one-way interaction mode.

      • Methods inherited from interface javax.xml.ws.BindingProvider

        getBinding, getEndpointReference, getEndpointReference, getRequestContext, getResponseContext

    • Method Detail

      • invoke

        T invoke(T msg)
        Invoke a service operation synchronously. The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.
        Parameters:
        msg - An object that will form the message or payload of the message used to invoke the operation.
        Returns:
        The response message or message payload to the operation invocation.
        Throws:
        WebServiceException - If a fault occurs during communication with the service
        WebServiceException - If there is any error in the configuration of the Dispatch instance

      • invokeAsync

        Response<T> invokeAsync(T msg)
        Invoke a service operation asynchronously. The method returns without waiting for the response to the operation invocation, the results of the operation are obtained by polling the returned Response.

        The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

        Parameters:
        msg - An object that will form the message or payload of the message used to invoke the operation.
        Returns:
        The response message or message payload to the operation invocation.
        Throws:
        WebServiceException - If there is any error in the configuration of the Dispatch instance

      • invokeAsync

        Future<?> invokeAsync(T msg,
                    AsyncHandler<T> handler)
        Invoke a service operation asynchronously. The method returns without waiting for the response to the operation invocation, the results of the operation are communicated to the client via the passed in handler.

        The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

        Parameters:
        msg - An object that will form the message or payload of the message used to invoke the operation.
        handler - The handler object that will receive the response to the operation invocation.
        Returns:
        A Future object that may be used to check the status of the operation invocation. This object MUST NOT be used to try to obtain the results of the operation - the object returned from Future<?>.get() is implementation dependent and any use of it will result in non-portable behaviour.
        Throws:
        WebServiceException - If there is any error in the configuration of the Dispatch instance

      • invokeOneWay

        void invokeOneWay(T msg)
        Invokes a service operation using the one-way interaction mode. The operation invocation is logically non-blocking, subject to the capabilities of the underlying protocol, no results are returned. When the protocol in use is SOAP/HTTP, this method MUST block until an HTTP response code has been received or an error occurs.

        The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

        Parameters:
        msg - An object that will form the message or payload of the message used to invoke the operation.
        Throws:
        WebServiceException - If there is any error in the configuration of the Dispatch instance or if an error occurs during the invocation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Endpoint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class Endpoint

  • java.lang.Object
    • javax.xml.ws.Endpoint

  • public abstract class Endpoint
extends Object
    A Web service endpoint.

    Endpoints are created using the static methods defined in this class. An endpoint is always tied to one Binding and one implementor, both set at endpoint creation time.

    An endpoint is either in a published or an unpublished state. The publish methods can be used to start publishing an endpoint, at which point it starts accepting incoming requests. Conversely, the stop method can be used to stop accepting incoming requests and take the endpoint down. Once stopped, an endpoint cannot be published again.

    An Executor may be set on the endpoint in order to gain better control over the threads used to dispatch incoming requests. For instance, thread pooling with certain parameters can be enabled by creating a ThreadPoolExecutor and registering it with the endpoint.

    Handler chains can be set using the contained Binding.

    An endpoint may have a list of metadata documents, such as WSDL and XMLSchema documents, bound to it. At publishing time, the JAX-WS implementation will try to reuse as much of that metadata as possible instead of generating new ones based on the annotations present on the implementor.

    Since:
    JAX-WS 2.0
    See Also:
    Binding, BindingType, SOAPBinding, Executor

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String WSDL_PORT
      Standard property: name of WSDL port.
      static String WSDL_SERVICE
      Standard property: name of WSDL service.

    • Constructor Summary

      Constructors
      Constructor and Description
      Endpoint()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Endpoint create(Object implementor)
      Creates an endpoint with the specified implementor object.
      static Endpoint create(Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified implementor object and web service features.
      static Endpoint create(String bindingId, Object implementor)
      Creates an endpoint with the specified binding type and implementor object.
      static Endpoint create(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified binding type, implementor object, and web service features.
      abstract Binding getBinding()
      Returns the binding for this endpoint.
      abstract <T extends EndpointReference>
      T             		getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      abstract EndpointReference getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      abstract Executor getExecutor()
      Returns the executor for this Endpointinstance.
      abstract Object getImplementor()
      Returns the implementation object for this endpoint.
      abstract List<Source> getMetadata()
      Returns a list of metadata documents for the service.
      abstract Map<String,Object> getProperties()
      Returns the property bag for this Endpoint instance.
      abstract boolean isPublished()
      Returns true if the endpoint is in the published state.
      void publish(HttpContext serverContext)
      Publishes this endpoint at the provided server context.
      abstract void publish(Object serverContext)
      Publishes this endpoint at the provided server context.
      abstract void publish(String address)
      Publishes this endpoint at the given address.
      static Endpoint publish(String address, Object implementor)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      static Endpoint publish(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      void setEndpointContext(EndpointContext ctxt)
      By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application.
      abstract void setExecutor(Executor executor)
      Sets the executor for this Endpoint instance.
      abstract void setMetadata(List<Source> metadata)
      Sets the metadata for this endpoint.
      abstract void setProperties(Map<String,Object> properties)
      Sets the property bag for this Endpoint instance.
      abstract void stop()
      Stops publishing this endpoint.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • WSDL_SERVICE

        public static final String WSDL_SERVICE
        Standard property: name of WSDL service.

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

      • WSDL_PORT

        public static final String WSDL_PORT
        Standard property: name of WSDL port.

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

    • Constructor Detail

      • Endpoint

        public Endpoint()

    • Method Detail

      • create

        public static Endpoint create(Object implementor)
        Creates an endpoint with the specified implementor object. If there is a binding specified via a BindingType annotation then it MUST be used else a default of SOAP 1.1 / HTTP binding MUST be used.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        Parameters:
        implementor - The endpoint implementor.
        Returns:
        The newly created endpoint.

      • create

        public static Endpoint create(Object implementor,
              WebServiceFeature... features)
        Creates an endpoint with the specified implementor object and web service features. If there is a binding specified via a BindingType annotation then it MUST be used else a default of SOAP 1.1 / HTTP binding MUST be used.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        Parameters:
        implementor - The endpoint implementor.
        features - A list of WebServiceFeature to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Since:
        JAX-WS 2.2

      • create

        public static Endpoint create(String bindingId,
              Object implementor)
        Creates an endpoint with the specified binding type and implementor object.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        Parameters:
        bindingId - A URI specifying the binding to use. If the bindingID is null and no binding is specified via a BindingType annotation then a default SOAP 1.1 / HTTP binding MUST be used.
        implementor - The endpoint implementor.
        Returns:
        The newly created endpoint.

      • create

        public static Endpoint create(String bindingId,
              Object implementor,
              WebServiceFeature... features)
        Creates an endpoint with the specified binding type, implementor object, and web service features.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        Parameters:
        bindingId - A URI specifying the binding to use. If the bindingID is null and no binding is specified via a BindingType annotation then a default SOAP 1.1 / HTTP binding MUST be used.
        implementor - The endpoint implementor.
        features - A list of WebServiceFeature to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Since:
        JAX-WS 2.2

      • getBinding

        public abstract Binding getBinding()
        Returns the binding for this endpoint.
        Returns:
        The binding for this endpoint

      • getImplementor

        public abstract Object getImplementor()
        Returns the implementation object for this endpoint.
        Returns:
        The implementor for this endpoint

      • publish

        public abstract void publish(String address)
        Publishes this endpoint at the given address. The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the publish(Object) method instead.
        Parameters:
        address - A URI specifying the address to use. The address MUST be compatible with the binding specified at the time the endpoint was created.
        Throws:
        IllegalArgumentException - If the provided address URI is not usable in conjunction with the endpoint's binding.
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.

      • publish

        public static Endpoint publish(String address,
               Object implementor)
        Creates and publishes an endpoint for the specified implementor object at the given address.

        The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the create(String,Object) and publish(Object) methods instead.

        Parameters:
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - The endpoint implementor.
        Returns:
        The newly created endpoint.
        Throws:
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.

      • publish

        public static Endpoint publish(String address,
               Object implementor,
               WebServiceFeature... features)
        Creates and publishes an endpoint for the specified implementor object at the given address. The created endpoint is configured with the web service features.

        The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the create(String,Object) and publish(Object) methods instead.

        Parameters:
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - The endpoint implementor.
        features - A list of WebServiceFeature to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Throws:
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.
        Since:
        JAX-WS 2.2

      • publish

        public abstract void publish(Object serverContext)
        Publishes this endpoint at the provided server context. A server context encapsulates the server infrastructure and addressing information for a particular transport. For a call to this method to succeed, the server context passed as an argument to it MUST be compatible with the endpoint's binding.
        Parameters:
        serverContext - An object representing a server context to be used for publishing the endpoint.
        Throws:
        IllegalArgumentException - If the provided server context is not supported by the implementation or turns out to be unusable in conjunction with the endpoint's binding.
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.

      • publish

        public void publish(HttpContext serverContext)
        Publishes this endpoint at the provided server context. A server context encapsulates the server infrastructure and addressing information for a particular transport. For a call to this method to succeed, the server context passed as an argument to it MUST be compatible with the endpoint's binding.

        This is meant for container developers to publish the the endpoints portably and not intended for the end developers.

        Parameters:
        serverContext - An object representing a server context to be used for publishing the endpoint.
        Throws:
        IllegalArgumentException - If the provided server context is not supported by the implementation or turns out to be unusable in conjunction with the endpoint's binding.
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.
        Since:
        JAX-WS 2.2

      • stop

        public abstract void stop()
        Stops publishing this endpoint. If the endpoint is not in a published state, this method has no effect.

      • isPublished

        public abstract boolean isPublished()
        Returns true if the endpoint is in the published state.
        Returns:
        true if the endpoint is in the published state.

      • getMetadata

        public abstract List<Source> getMetadata()
        Returns a list of metadata documents for the service.
        Returns:
        List<javax.xml.transform.Source> A list of metadata documents for the service

      • setMetadata

        public abstract void setMetadata(List<Source> metadata)
        Sets the metadata for this endpoint.
        Parameters:
        metadata - A list of XML document sources containing metadata information for the endpoint (e.g. WSDL or XML Schema documents)
        Throws:
        IllegalStateException - If the endpoint has already been published.

      • getExecutor

        public abstract Executor getExecutor()
        Returns the executor for this Endpointinstance. The executor is used to dispatch an incoming request to the implementor object.
        Returns:
        The java.util.concurrent.Executor to be used to dispatch a request.
        See Also:
        Executor

      • setExecutor

        public abstract void setExecutor(Executor executor)
        Sets the executor for this Endpoint instance. The executor is used to dispatch an incoming request to the implementor object. If this Endpoint is published using the publish(Object) method and the specified server context defines its own threading behavior, the executor may be ignored.
        Parameters:
        executor - The java.util.concurrent.Executor to be used to dispatch a request.
        Throws:
        SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
        See Also:
        Executor

      • getProperties

        public abstract Map<String,Object> getProperties()
        Returns the property bag for this Endpoint instance.
        Returns:
        Map<String,Object> The property bag associated with this instance.

      • setProperties

        public abstract void setProperties(Map<String,Object> properties)
        Sets the property bag for this Endpoint instance.
        Parameters:
        properties - The property bag associated with this instance.

      • getEndpointReference

        public abstract EndpointReference getEndpointReference(Element... referenceParameters)
        Returns the EndpointReference associated with this Endpoint instance.

        If the Binding for this bindingProvider is either SOAP1.1/HTTP or SOAP1.2/HTTP, then a W3CEndpointReference MUST be returned.

        Parameters:
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        Returns:
        EndpointReference of this Endpoint instance. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        Throws:
        WebServiceException - If any error in the creation of the EndpointReference or if the Endpoint is not in the published state.
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        Since:
        JAX-WS 2.1
        See Also:
        W3CEndpointReference

      • getEndpointReference

        public abstract <T extends EndpointReference> T getEndpointReference(Class<T> clazz,
                                                   Element... referenceParameters)
        Returns the EndpointReference associated with this Endpoint instance.
        Parameters:
        clazz - Specifies the type of EndpointReference that MUST be returned.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        Returns:
        EndpointReference of type clazz of this Endpoint instance. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        Throws:
        WebServiceException - If any error in the creation of the EndpointReference or if the Endpoint is not in the published state or if the clazz is not a supported EndpointReference type.
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        Since:
        JAX-WS 2.1

      • setEndpointContext

        public void setEndpointContext(EndpointContext ctxt)
        By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application. If multiple endpoints share different ports of a WSDL, then the multiple port addresses are patched when the WSDL is accessed.

        This needs to be set before publishing the endpoints.

        Parameters:
        ctxt - that is shared for multiple endpoints
        Throws:
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        Since:
        JAX-WS 2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EndpointContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class EndpointContext

  • java.lang.Object
    • javax.xml.ws.EndpointContext

  • public abstract class EndpointContext
extends Object
    EndpointContext allows multiple endpoints in an application to share any information. For example, servlet application's war may contain multiple endpoints and these endpoints can get addresses of each other by sharing this context. If multiple endpoints share different ports of a WSDL, then the multiple port addresses can be patched when the WSDL is accessed. It also allows all endpoints to share any other runtime information.

    This needs to be set by using Endpoint.setEndpointContext(javax.xml.ws.EndpointContext) before Endpoint.publish(java.lang.String) methods.

    Since:
    JAX-WS 2.2
    Author:
    Jitendra Kotamraju

    • Constructor Summary

      Constructors
      Constructor and Description
      EndpointContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Set<Endpoint> getEndpoints()
      This gives list of endpoints in an application.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • EndpointContext

        public EndpointContext()

    • Method Detail

      • getEndpoints

        public abstract Set<Endpoint> getEndpoints()
        This gives list of endpoints in an application. For e.g in servlet container, a war file may contain multiple endpoints. In case of http, these endpoints are hosted on the same http server.
        Returns:
        list of all endpoints in an application
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EndpointReference (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class EndpointReference

  • java.lang.Object
    • javax.xml.ws.EndpointReference
  • Direct Known Subclasses:
    W3CEndpointReference

    public abstract class EndpointReference
extends Object
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint. See Web Services Addressing 1.0 - Core for more information on WS-Addressing EndpointReferences.

    This class is immutable as the typical web service developer need not be concerned with its contents. The web service developer should use this class strictly as a mechanism to reference a remote web service endpoint. See the Service APIs that clients can use to that utilize an EndpointReference. See the Endpoint, and BindingProvider APIs on how EndpointReferences can be created for published endpoints.

    Concrete implementations of this class will represent an EndpointReference for a particular version of Addressing. For example the W3CEndpointReference is for use with W3C Web Services Addressing 1.0 - Core Recommendation. If JAX-WS implementors need to support different versions of addressing, they should write their own EndpointReference subclass for that version. This will allow a JAX-WS implementation to create a vendor specific EndpointReferences that the vendor can use to flag a different version of addressing.

    Web service developers that wish to pass or return EndpointReference in Java methods in an SEI should use concrete instances of an EndpointReference such as the W3CEndpointReference. This way the schema mapped from the SEI will be more descriptive of the type of endpoint reference being passed.

    JAX-WS implementors are expected to extract the XML infoset from an EndpointReferece using the writeTo(javax.xml.transform.Result) method.

    JAXB will bind this class to xs:anyType. If a better binding is desired, web services developers should use a concrete subclass such as W3CEndpointReference.

    Since:
    JAX-WS 2.1
    See Also:
    W3CEndpointReference, Service

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | EndpointReference()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T> T getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      static EndpointReference readFrom(Source eprInfoset)
      Factory method to read an EndpointReference from the infoset contained in eprInfoset.
      String toString()
      Displays EPR infoset for debugging convenience.
      abstract void writeTo(Result result)
      write this EndpointReference to the specified infoset format

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EndpointReference

        protected EndpointReference()

    • Method Detail

      • readFrom

        public static EndpointReference readFrom(Source eprInfoset)
        Factory method to read an EndpointReference from the infoset contained in eprInfoset. This method delegates to the vendor specific implementation of the Provider.readEndpointReference(javax.xml.transform.Source) method.
        Parameters:
        eprInfoset - The EndpointReference infoset to be unmarshalled
        Returns:
        the EndpointReference unmarshalled from eprInfoset never null
        Throws:
        WebServiceException - if an error occurs while creating the EndpointReference from the eprInfoset
        IllegalArgumentException - if the null eprInfoset value is given.

      • writeTo

        public abstract void writeTo(Result result)
        write this EndpointReference to the specified infoset format
        Parameters:
        result - for writing infoset
        Throws:
        WebServiceException - if there is an error writing the EndpointReference to the specified result.
        IllegalArgumentException - If the null result value is given.

      • getPort

        public <T> T getPort(Class<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. If there are any reference parameters in the EndpointReference instance, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. The EndpointReference instance specifies the endpoint that will be invoked by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL Metadata from this EndpointReference or from annotations on the serviceEndpointInterface. For this method to successfully return a proxy, WSDL metadata MUST be available and the EndpointReference instance MUST contain an implementation understood serviceName metadata.

        Because this port is not created from a Service object, handlers will not automatically be configured, and the HandlerResolver and Executor cannot be get or set for this port. The BindingProvider().getBinding().setHandlerChain() method can be used to manually configure handlers for this port.

        Parameters:
        serviceEndpointInterface - Service endpoint interface
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If this endpointReference is invalid
        • If an illegal serviceEndpointInterface is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        See Also:
        Proxy, WebServiceFeature

      • toString

        public String toString()
        Displays EPR infoset for debugging convenience.
        Overrides:
        toString in class Object
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FaultAction (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type FaultAction

  • @Documented
@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface FaultAction
    The FaultAction annotation is used inside an Action annotation to allow an explicit association of a WS-Addressing Action message addressing property with the fault messages of the WSDL operation mapped from the exception class.

    The wsam:Action attribute value in the fault message in the generated WSDL operation mapped for className class is equal to the corresponding value in the FaultAction. For the exact computation of wsam:Action values for the fault messages, refer to the algorithm in the JAX-WS specification.

    Example 1: Specify explicit values for Action message addressing property for the input, output and fault message if the Java method throws only one service specific exception.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(
         fault = {
             @FaultAction(className=AddNumbersException.class, value="http://example.com/faultAction")
         })
     public int addNumbers(int number1, int number2)
         throws AddNumbersException {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         ...
         <fault message="tns:AddNumbersException" name="AddNumbersException"
           wsam:Action="http://example.com/faultAction"/>
       </operation>
     </portType>
     ...
   </definitions>

    Example 2: Here is an example that shows if the explicit value for Action message addressing property for the service specific exception is not present.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     public int addNumbers(int number1, int number2)
         throws AddNumbersException {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         ...
         <fault message="tns:addNumbersFault" name="InvalidNumbers"
           wsam:Action="http://example.com/numbers/AddNumbersPortType/AddNumbers/Fault/AddNumbersException"/>
       </operation>
     </portType>
     ...
   </definitions>

    Example 3: Here is an example that shows how to specify explicit values for Action message addressing property if the Java method throws more than one service specific exception.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(
         fault = {
             @FaultAction(className=AddNumbersException.class, value="http://example.com/addFaultAction"),
             @FaultAction(className=TooBigNumbersException.class, value="http://example.com/toobigFaultAction")
         })
     public int addNumbers(int number1, int number2)
         throws AddNumbersException, TooBigNumbersException {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         ...
         <fault message="tns:addNumbersFault" name="AddNumbersException"
           wsam:Action="http://example.com/addFaultAction"/>
         <fault message="tns:tooBigNumbersFault" name="TooBigNumbersException"
           wsam:Action="http://example.com/toobigFaultAction"/>
       </operation>
     </portType>
     ...
   </definitions>
    Since:
    JAX-WS 2.1

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<? extends Exception> className
      Name of the exception class

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String value
      Value of WS-Addressing Action message addressing property for the exception

    • Element Detail

      • className

        public abstract Class<? extends Exception> className
        Name of the exception class

      • value

        public abstract String value
        Value of WS-Addressing Action message addressing property for the exception
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Holder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class Holder<T>

  • java.lang.Object
    • javax.xml.ws.Holder<T>
  • All Implemented Interfaces:
    Serializable

    public final class Holder<T>
extends Object
implements Serializable
    Holds a value of type T.
    Since:
    JAX-WS 2.0
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      T value
      The value contained in the holder.

    • Constructor Summary

      Constructors
      Constructor and Description
      Holder()
      Creates a new holder with a null value.
      Holder(T value)
      Create a new holder with the specified value.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public T value
        The value contained in the holder.

    • Constructor Detail

      • Holder

        public Holder()
        Creates a new holder with a null value.

      • Holder

        public Holder(T value)
        Create a new holder with the specified value.
        Parameters:
        value - The value to be stored in the holder.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.ws (Java(TM) EE 7 Specification APIs)

javax.xml.ws

Interfaces

  • AsyncHandler
  • Binding
  • BindingProvider
  • Dispatch
  • LogicalMessage
  • Provider
  • Response
  • WebServiceContext

Classes

  • Endpoint
  • EndpointContext
  • EndpointReference
  • Holder
  • RespectBindingFeature
  • Service
  • WebServiceFeature
  • WebServicePermission

Enums

  • Service.Mode

Exceptions

  • ProtocolException
  • WebServiceException

Annotation Types

  • Action
  • BindingType
  • FaultAction
  • RequestWrapper
  • RespectBinding
  • ResponseWrapper
  • ServiceMode
  • WebEndpoint
  • WebFault
  • WebServiceClient
  • WebServiceProvider
  • WebServiceRef
  • WebServiceRefs


javax.xml.ws (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws

This package contains the core JAX-WS APIs.

See: Description

  • Interface Summary
    Interface Description
    AsyncHandler<T>
    The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    BindingProvider
    The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
    Dispatch<T>
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
    LogicalMessage
    The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
    Provider<T>
    Service endpoints may implement the Provider interface as a dynamic alternative to an SEI.
    Response<T>
    The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.
    WebServiceContext
    A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served.
  • Class Summary
    Class Description
    Endpoint
    A Web service endpoint.
    EndpointContext
    EndpointContext allows multiple endpoints in an application to share any information.
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
    Holder<T>
    Holds a value of type T.
    RespectBindingFeature
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
    Service
    Service objects provide the client view of a Web service.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
    WebServicePermission
    This class defines web service permissions.
  • Enum Summary
    Enum Description
    Service.Mode
    The orientation of a dynamic client or service.
  • Exception Summary
    Exception Description
    ProtocolException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
  • Annotation Types Summary
    Annotation Type Description
    Action
    The Action annotation allows explicit association of a WS-Addressing Action message addressing property with input, output, and fault messages of the mapped WSDL operation.
    BindingType
    The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.
    FaultAction
    The FaultAction annotation is used inside an Action annotation to allow an explicit association of a WS-Addressing Action message addressing property with the fault messages of the WSDL operation mapped from the exception class.
    RequestWrapper
    Used to annotate methods in the Service Endpoint Interface with the request wrapper bean to be used at runtime.
    RespectBinding
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
    ResponseWrapper
    Used to annotate methods in the Service Endpoint Interface with the response wrapper bean to be used at runtime.
    ServiceMode
    Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.
    WebEndpoint
    Used to annotate the getPortName() methods of a generated service interface.
    WebFault
    Used to annotate service specific exception classes to customize to the local and namespace name of the fault element and the name of the fault bean.
    WebServiceClient
    Used to annotate a generated service interface.
    WebServiceProvider
    Used to annotate a Provider implementation class.
    WebServiceRef
    The WebServiceRef annotation is used to define a reference to a web service and (optionally) an injection target for it.
    WebServiceRefs
    The WebServiceRefs annotation allows multiple web service references to be declared at the class level.

Package javax.xml.ws Description

This package contains the core JAX-WS APIs.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.ws Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.Endpoint
    • javax.xml.ws.EndpointContext
    • javax.xml.ws.EndpointReference
    • javax.xml.ws.Holder<T> (implements java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.xml.ws.WebServicePermission
    • javax.xml.ws.Service
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.RespectBindingFeature

Interface Hierarchy

  • javax.xml.ws.AsyncHandler<T>
  • javax.xml.ws.Binding
  • javax.xml.ws.BindingProvider
    • javax.xml.ws.Dispatch<T>
  • java.util.concurrent.Future<V>
    • javax.xml.ws.Response<T>
  • javax.xml.ws.LogicalMessage
  • javax.xml.ws.Provider<T>
  • javax.xml.ws.WebServiceContext

Annotation Type Hierarchy

  • javax.xml.ws.WebServiceRefs (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRef (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceProvider (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceClient (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebFault (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebEndpoint (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ServiceMode (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ResponseWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RespectBinding (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RequestWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.FaultAction (implements java.lang.annotation.Annotation)
  • javax.xml.ws.BindingType (implements java.lang.annotation.Annotation)
  • javax.xml.ws.Action (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.Service.Mode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LogicalMessage (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface LogicalMessage

  • public interface LogicalMessage
    The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
    Since:
    JAX-WS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Source getPayload()
      Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.
      Object getPayload(JAXBContext context)
      Gets the message payload as a JAXB object.
      void setPayload(Object payload, JAXBContext context)
      Sets the message payload
      void setPayload(Source payload)
      Sets the message payload

    • Method Detail

      • getPayload

        Source getPayload()
        Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.

        If the returned Source is an instance of DOMSource, then modifications to the encapsulated DOM tree change the message payload in-place, there is no need to susequently call setPayload. Other types of Source provide only read access to the message payload.

        Returns:
        The contained message payload; returns null if no payload is present in this message.

      • setPayload

        void setPayload(Source payload)
        Sets the message payload
        Parameters:
        payload - message payload
        Throws:
        WebServiceException - If any error during the setting of the payload in this message
        UnsupportedOperationException - If this operation is not supported

      • getPayload

        Object getPayload(JAXBContext context)
        Gets the message payload as a JAXB object. Note that there is no connection between the returned object and the message payload, changes to the payload require calling setPayload.
        Parameters:
        context - The JAXBContext that should be used to unmarshall the message payload
        Returns:
        The contained message payload; returns null if no payload is present in this message
        Throws:
        WebServiceException - If an error occurs when using a supplied JAXBContext to unmarshall the payload. The cause of the WebServiceException is the original JAXBException.

      • setPayload

        void setPayload(Object payload,
              JAXBContext context)
        Sets the message payload
        Parameters:
        payload - message payload
        context - The JAXBContext that should be used to marshall the payload
        Throws:
        UnsupportedOperationException - If this operation is not supported
        WebServiceException - If an error occurs when using the supplied JAXBContext to marshall the payload. The cause of the WebServiceException is the original JAXBException.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ProtocolException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class ProtocolException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    HTTPException, SOAPFaultException

    public class ProtocolException
extends WebServiceException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding. Subclasses are used to communicate protocol level fault information to clients and may be used on the server to control the protocol specific fault representation.
    Since:
    JAX-WS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ProtocolException()
      Constructs a new protocol exception with null as its detail message.
      ProtocolException(String message)
      Constructs a new protocol exception with the specified detail message.
      ProtocolException(String message, Throwable cause)
      Constructs a new runtime exception with the specified detail message and cause.
      ProtocolException(Throwable cause)
      Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ProtocolException

        public ProtocolException()
        Constructs a new protocol exception with null as its detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).

      • ProtocolException

        public ProtocolException(String message)
        Constructs a new protocol exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).
        Parameters:
        message - the detail message. The detail message is saved for later retrieval by the Throwable.getMessage() method.

      • ProtocolException

        public ProtocolException(String message,
                 Throwable cause)
        Constructs a new runtime exception with the specified detail message and cause. Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • ProtocolException

        public ProtocolException(Throwable cause)
        Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause). This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.
        Parameters:
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Provider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface Provider<T>

  • public interface Provider<T>

    Service endpoints may implement the Provider interface as a dynamic alternative to an SEI.

    Implementations are required to support Provider<Source>, Provider<SOAPMessage> and Provider<DataSource>, depending on the binding in use and the service mode.

    The ServiceMode annotation can be used to control whether the Provider instance will receive entire protocol messages or just message payloads.

    Since:
    JAX-WS 2.0
    See Also:
    Source, SOAPMessage, ServiceMode

    • Method Summary

      Methods
      Modifier and Type Method and Description
      T invoke(T request)
      Invokes an operation occording to the contents of the request message.

    • Method Detail

      • invoke

        T invoke(T request)
        Invokes an operation occording to the contents of the request message.
        Parameters:
        request - The request message or message payload.
        Returns:
        The response message or message payload. May be null if there is no response.
        Throws:
        WebServiceException - If there is an error processing request. The cause of the WebServiceException may be set to a subclass of ProtocolException to control the protocol level representation of the exception.
        See Also:
        MessageContext, ProtocolException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RequestWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type RequestWrapper

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
@Documented
public @interface RequestWrapper
    Used to annotate methods in the Service Endpoint Interface with the request wrapper bean to be used at runtime. The default value of the localName is the operationName, as defined in WebMethod annotation and the targetNamespace is the target namespace of the SEI.

    When starting from Java this annotation is used resolve overloading conflicts in document literal mode. Only the className is required in this case.

    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String className
      Request wrapper bean name.
      String localName
      Element's local name.
      String partName
      wsdl:part name for the wrapper part
      String targetNamespace
      Element's namespace name.

    • Element Detail

      • localName

        public abstract String localName
        Element's local name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Element's namespace name.
        Default:
        ""

      • className

        public abstract String className
        Request wrapper bean name.
        Default:
        ""

      • partName

        public abstract String partName
        wsdl:part name for the wrapper part
        Since:
        JAX-WS 2.2
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


RespectBinding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type RespectBinding

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
@WebServiceFeatureAnnotation(id="javax.xml.ws.RespectBindingFeature",
                             bean=RespectBindingFeature.class)
public @interface RespectBinding
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.

    This annotation MUST only be used in conjunction the javax.jws.WebService, WebServiceProvider, WebServiceRef annotations. When used with the javax.jws.WebService annotation this annotation MUST only be used on the service endpoint implementation class. When used with a WebServiceRef annotation, this annotation MUST only be used when a proxy instance is created. The injected SEI proxy, and endpoint MUST honor the values of the RespectBinding annotation.

    This annotation's behaviour is defined by the corresponding feature RespectBindingFeature.

    Since:
    JAX-WS 2.1
    See Also:
    RespectBindingFeature

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean enabled
      Specifies if this feature is enabled or disabled.

    • Element Detail

      • enabled

        public abstract boolean enabled
        Specifies if this feature is enabled or disabled.
        Default:
        true
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


RespectBindingFeature (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class RespectBindingFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.RespectBindingFeature

  • public final class RespectBindingFeature
extends WebServiceFeature
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime. This feature can be used during the creation of SEI proxy, and Dispatch instances on the client side and Endpoint instances on the server side. This feature cannot be used for Service instance creation on the client side.

    This feature is only useful with web services that have an associated WSDL. Enabling this feature requires that a JAX-WS implementation inspect the wsdl:binding for an endpoint at runtime to make sure that all wsdl:extensions that have the required attribute set to true are understood and are being used.

    The following describes the affects of this feature with respect to be enabled or disabled:

    • ENABLED: In this Mode, a JAX-WS runtime MUST assure that all required wsdl:binding extensions(including policies) are either understood and used by the runtime, or explicitly disabled by the web service application. A web service can disable a particular extension if there is a corresponding WebServiceFeature or annotation. Similarly, a web service client can disable particular extension using the corresponding WebServiceFeature while creating a proxy or Dispatch instance. The runtime MUST also make sure that binding of SEI parameters/return values respect the wsdl:binding. With this feature enabled, if a required (wsdl:required="true") wsdl:binding extension is in the WSDL and it is not supported by a JAX-WS runtime and it has not been explicitly turned off by the web service developer, then that JAX-WS runtime MUST behave appropriately based on whether it is on the client or server:
      • Client: runtime MUST throw a WebServiceException no sooner than when one of the methods above is invoked but no later than the first invocation of an endpoint operation.
      • Server: throw a WebServiceException and the endpoint MUST fail to deploy
    • DISABLED: In this Mode, an implementation may choose whether to inspect the wsdl:binding or not and to what degree the wsdl:binding will be inspected. For example, one implementation may choose to behave as if this feature is enabled, another implementation may only choose to verify the SEI's parameter/return type bindings.
    Since:
    JAX-WS 2.1
    See Also:
    AddressingFeature

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ID
      Constant value identifying the RespectBindingFeature

      • Fields inherited from class javax.xml.ws.WebServiceFeature

        enabled

    • Constructor Summary

      Constructors
      Constructor and Description
      RespectBindingFeature()
      Creates an RespectBindingFeature.
      RespectBindingFeature(boolean enabled)
      Creates an RespectBindingFeature

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getID()
      Get the unique identifier for this WebServiceFeature.

      • Methods inherited from class javax.xml.ws.WebServiceFeature

        isEnabled

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ID

        public static final String ID
        Constant value identifying the RespectBindingFeature
        See Also:
        Constant Field Values

    • Constructor Detail

      • RespectBindingFeature

        public RespectBindingFeature()
        Creates an RespectBindingFeature. The instance created will be enabled.

      • RespectBindingFeature

        public RespectBindingFeature(boolean enabled)
        Creates an RespectBindingFeature
        Parameters:
        enabled - specifies whether this feature should be enabled or not.

    • Method Detail

      • getID

        public String getID()
        Get the unique identifier for this WebServiceFeature.
        Specified by:
        getID in class WebServiceFeature
        Returns:
        the unique identifier for this feature.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Response (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface Response<T>

  • All Superinterfaces:
    Future<T>

    public interface Response<T>
extends Future<T>
    The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.

    For asynchronous operation invocations it provides additional methods to check the status of the request. The get(...) methods may throw the standard set of exceptions and their cause may be a RemoteException or a WebServiceException that represents the error that occured during the asynchronous method invocation.

    Since:
    JAX-WS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Map<String,Object> getContext()
      Gets the contained response context.

      • Methods inherited from interface java.util.concurrent.Future

        cancel, get, get, isCancelled, isDone

    • Method Detail

      • getContext

        Map<String,Object> getContext()
        Gets the contained response context.
        Returns:
        The contained response context. May be null if a response is not yet available.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ResponseWrapper (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type ResponseWrapper

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
@Documented
public @interface ResponseWrapper
    Used to annotate methods in the Service Endpoint Interface with the response wrapper bean to be used at runtime. The default value of the localName is the operationName as defined in WebMethod annotation appended with Response and the targetNamespace is the target namespace of the SEI.

    When starting from Java this annotation is used resolve overloading conflicts in document literal mode. Only the className is required in this case.

    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String className
      Response wrapper bean name.
      String localName
      Element's local name.
      String partName
      wsdl:part name for the wrapper part
      String targetNamespace
      Element's namespace name.

    • Element Detail

      • localName

        public abstract String localName
        Element's local name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Element's namespace name.
        Default:
        ""

      • className

        public abstract String className
        Response wrapper bean name.
        Default:
        ""

      • partName

        public abstract String partName
        wsdl:part name for the wrapper part
        Since:
        JAX-WS 2.2
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Service (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class Service

  • java.lang.Object
    • javax.xml.ws.Service

  • public class Service
extends Object
    Service objects provide the client view of a Web service.

    Service acts as a factory of the following:

    • Proxies for a target service endpoint.
    • Instances of Dispatch for dynamic message-oriented invocation of a remote operation.

    The ports available on a service can be enumerated using the getPorts method. Alternatively, you can pass a service endpoint interface to the unary getPort method and let the runtime select a compatible port.

    Handler chains for all the objects created by a Service can be set by means of a HandlerResolver.

    An Executor may be set on the service in order to gain better control over the threads used to dispatch asynchronous callbacks. For instance, thread pooling with certain parameters can be enabled by creating a ThreadPoolExecutor and registering it with the service.

    Since:
    JAX-WS 2.0
    See Also:
    Provider, HandlerResolver, Executor

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  Service.Mode
      The orientation of a dynamic client or service.

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | Service(URL wsdlDocumentLocation, QName serviceName)
      protected | Service(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void addPort(QName portName, String bindingId, String endpointAddress)
      Creates a new port for the service.
      static Service create(QName serviceName)
      Creates a Service instance.
      static Service create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Service create(URL wsdlDocumentLocation, QName serviceName)
      Creates a Service instance.
      static Service create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      <T> Dispatch<T> createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Executor getExecutor()
      Returns the executor for this Serviceinstance.
      HandlerResolver getHandlerResolver()
      Returns the configured handler resolver.
      <T> T getPort(Class<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      <T> T getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T getPort(QName portName, Class<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      <T> T getPort(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      Iterator<QName> getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      QName getServiceName()
      Gets the name of this service.
      URL getWSDLDocumentLocation()
      Gets the location of the WSDL document for this Service.
      void setExecutor(Executor executor)
      Sets the executor for this Service instance.
      void setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Service

        protected Service(URL wsdlDocumentLocation,
       QName serviceName)

      • Service

        protected Service(URL wsdlDocumentLocation,
       QName serviceName,
       WebServiceFeature... features)

    • Method Detail

      • getPort

        public <T> T getPort(QName portName,
            Class<T> serviceEndpointInterface)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        Parameters:
        portName - Qualified name of the service endpoint in the WSDL service description.
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy instance.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface or portName is specified.
        See Also:
        Proxy, InvocationHandler

      • getPort

        public <T> T getPort(QName portName,
            Class<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        Parameters:
        portName - Qualified name of the service endpoint in the WSDL service description.
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy instance.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface or portName is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Proxy, InvocationHandler, WebServiceFeature

      • getPort

        public <T> T getPort(Class<T> serviceEndpointInterface)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        Parameters:
        serviceEndpointInterface - Service endpoint interface.
        Returns:
        Object instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface is specified.

      • getPort

        public <T> T getPort(Class<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        Parameters:
        serviceEndpointInterface - Service endpoint interface.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        WebServiceFeature

      • getPort

        public <T> T getPort(EndpointReference endpointReference,
            Class<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. The parameter endpointReference specifies the endpoint that will be invoked by the returned proxy. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference metadata also has a WSDL, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. The returned proxy should not be reconfigured by the client. If this Service instance has a known proxy port that matches the information contained in the WSDL, then that proxy is returned, otherwise a WebServiceException is thrown.

        Calling this method has the same behavior as the following

         port = service.getPort(portName, serviceEndpointInterface);
        where the portName is retrieved from the metadata of the endpointReference or from the serviceEndpointInterface and the WSDL associated with this Service instance.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned proxy.
        serviceEndpointInterface - Service endpoint interface.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName of this Service instance.
        • If a portName cannot be extracted from the WSDL or endpointReference metadata.
        • If an invalid endpointReference is specified.
        • If an invalid serviceEndpointInterface is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1

      • addPort

        public void addPort(QName portName,
           String bindingId,
           String endpointAddress)
        Creates a new port for the service. Ports created in this way contain no WSDL port type information and can only be used for creating Dispatchinstances.
        Parameters:
        portName - Qualified name for the target service endpoint.
        bindingId - A String identifier of a binding.
        endpointAddress - Address of the target service endpoint as a URI.
        Throws:
        WebServiceException - If any error in the creation of the port.
        See Also:
        SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING

      • createDispatch

        public <T> Dispatch<T> createDispatch(QName portName,
                             Class<T> type,
                             Service.Mode mode)
        Creates a Dispatch instance for use with objects of the client's choosing.
        Parameters:
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source, javax.xml.soap.SOAPMessage and javax.activation.DataSource, depending on the binding in use.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        Returns:
        Dispatch instance.
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object.
        See Also:
        Source, SOAPMessage

      • createDispatch

        public <T> Dispatch<T> createDispatch(QName portName,
                             Class<T> type,
                             Service.Mode mode,
                             WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the client's choosing.
        Parameters:
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance.
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public <T> Dispatch<T> createDispatch(EndpointReference endpointReference,
                             Class<T> type,
                             Service.Mode mode,
                             WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the client's choosing. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behaves the same as calling

         dispatch = service.createDispatch(portName, type, mode, features);
        where the portName is retrieved from the WSDL or EndpointReference metadata.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        type - The class of object used to messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public Dispatch<Object> createDispatch(QName portName,
                              JAXBContext context,
                              Service.Mode mode)
        Creates a Dispatch instance for use with JAXB generated objects.
        Parameters:
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body.
        Returns:
        Dispatch instance.
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object.
        See Also:
        JAXBContext

      • createDispatch

        public Dispatch<Object> createDispatch(QName portName,
                              JAXBContext context,
                              Service.Mode mode,
                              WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects.
        Parameters:
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance.
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        JAXBContext, WebServiceFeature

      • createDispatch

        public Dispatch<Object> createDispatch(EndpointReference endpointReference,
                              JAXBContext context,
                              Service.Mode mode,
                              WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behavies the same as calling

         dispatch = service.createDispatch(portName, context, mode, features);
        where the portName is retrieved from the WSDL or endpointReference metadata.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        JAXBContext, WebServiceFeature

      • getServiceName

        public QName getServiceName()
        Gets the name of this service.
        Returns:
        Qualified name of this service

      • getPorts

        public Iterator<QName> getPorts()
        Returns an Iterator for the list of QNames of service endpoints grouped by this service
        Returns:
        Returns java.util.Iterator with elements of type javax.xml.namespace.QName.
        Throws:
        WebServiceException - If this Service class does not have access to the required WSDL metadata.

      • getWSDLDocumentLocation

        public URL getWSDLDocumentLocation()
        Gets the location of the WSDL document for this Service.
        Returns:
        URL for the location of the WSDL document for this service.

      • getHandlerResolver

        public HandlerResolver getHandlerResolver()
        Returns the configured handler resolver.
        Returns:
        HandlerResolver The HandlerResolver being used by this Service instance, or null if there isn't one.

      • setHandlerResolver

        public void setHandlerResolver(HandlerResolver handlerResolver)
        Sets the HandlerResolver for this Service instance.

        The handler resolver, if present, will be called once for each proxy or dispatch instance that is created, and the handler chain returned by the resolver will be set on the instance.

        Parameters:
        handlerResolver - The HandlerResolver to use for all subsequently created proxy/dispatch objects.
        See Also:
        HandlerResolver

      • getExecutor

        public Executor getExecutor()
        Returns the executor for this Serviceinstance. The executor is used for all asynchronous invocations that require callbacks.
        Returns:
        The java.util.concurrent.Executor to be used to invoke a callback.
        See Also:
        Executor

      • setExecutor

        public void setExecutor(Executor executor)
        Sets the executor for this Service instance. The executor is used for all asynchronous invocations that require callbacks.
        Parameters:
        executor - The java.util.concurrent.Executor to be used to invoke a callback.
        Throws:
        SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
        See Also:
        Executor

      • create

        public static Service create(URL wsdlDocumentLocation,
             QName serviceName)
        Creates a Service instance. The specified WSDL document location and service qualified name MUST uniquely identify a wsdl:service element.
        Parameters:
        wsdlDocumentLocation - URL for the WSDL document location for the service
        serviceName - QName for the service
        Throws:
        WebServiceException - If any error in creation of the specified service.

      • create

        public static Service create(URL wsdlDocumentLocation,
             QName serviceName,
             WebServiceFeature... features)
        Creates a Service instance. The created instance is configured with the web service features. The specified WSDL document location and service qualified name MUST uniquely identify a wsdl:service element.
        Parameters:
        wsdlDocumentLocation - URL for the WSDL document location for the service
        serviceName - QName for the service
        features - Web Service features that must be configured on the service. If the provider doesn't understand a feature, it must throw a WebServiceException.
        Throws:
        WebServiceException - If any error in creation of the specified service.
        Since:
        JAX-WS 2.2

      • create

        public static Service create(QName serviceName)
        Creates a Service instance.
        Parameters:
        serviceName - QName for the service
        Throws:
        WebServiceException - If any error in creation of the specified service

      • create

        public static Service create(QName serviceName,
             WebServiceFeature... features)
        Creates a Service instance. The created instance is configured with the web service features.
        Parameters:
        serviceName - QName for the service
        features - Web Service features that must be configured on the service. If the provider doesn't understand a feature, it must throw a WebServiceException.
        Throws:
        WebServiceException - If any error in creation of the specified service
        Since:
        JAX-WS 2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Service.Mode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.ws

Enum Service.Mode

  • java.lang.Object
    • java.lang.Enum<Service.Mode>
      • javax.xml.ws.Service.Mode
  • All Implemented Interfaces:
    Serializable, Comparable<Service.Mode>
    Enclosing class:
    Service

    public static enum Service.Mode
extends Enum<Service.Mode>
    The orientation of a dynamic client or service. MESSAGE provides access to entire protocol message, PAYLOAD to protocol message payload only.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      MESSAGE
      PAYLOAD

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static Service.Mode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Service.Mode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MESSAGE

        public static final Service.Mode MESSAGE

      • PAYLOAD

        public static final Service.Mode PAYLOAD

    • Method Detail

      • values

        public static Service.Mode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Service.Mode c : Service.Mode.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Service.Mode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


ServiceMode (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type ServiceMode

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Inherited
@Documented
public @interface ServiceMode
    Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.
    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Service.Mode value
      Service mode.

    • Element Detail

      • value

        public abstract Service.Mode value
        Service mode. PAYLOAD indicates that the Provider implementation wishes to work with protocol message payloads only. MESSAGE indicates that the Provider implementation wishes to work with entire protocol messages.
        Default:
        javax.xml.ws.Service.Mode.PAYLOAD
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Package javax.xml.ws (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws

  • Packages that use javax.xml.ws
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.ws used by javax.xml.ws
    Class and Description
    AsyncHandler
    The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    BindingProvider
    The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
    Dispatch
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
    Endpoint
    A Web service endpoint.
    EndpointContext
    EndpointContext allows multiple endpoints in an application to share any information.
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
    Response
    The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.
    Service
    Service objects provide the client view of a Web service.
    Service.Mode
    The orientation of a dynamic client or service.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
  • Classes in javax.xml.ws used by javax.xml.ws.handler
    Class and Description
    LogicalMessage
    The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
  • Classes in javax.xml.ws used by javax.xml.ws.http
    Class and Description
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    ProtocolException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
  • Classes in javax.xml.ws used by javax.xml.ws.soap
    Class and Description
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    ProtocolException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
  • Classes in javax.xml.ws used by javax.xml.ws.spi
    Class and Description
    Dispatch
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
    Endpoint
    A Web service endpoint.
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
    Service
    Service objects provide the client view of a Web service.
    Service.Mode
    The orientation of a dynamic client or service.
    WebServiceContext
    A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
  • Classes in javax.xml.ws used by javax.xml.ws.wsaddressing
    Class and Description
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WebEndpoint (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type WebEndpoint

  • @Target(value=METHOD)
@Retention(value=RUNTIME)
@Documented
public @interface WebEndpoint
    Used to annotate the getPortName() methods of a generated service interface.

    The information specified in this annotation is sufficient to uniquely identify a wsdl:port element inside a wsdl:service. The latter is determined based on the value of the WebServiceClient annotation on the generated service interface itself.

    Since:
    JAX-WS 2.0
    See Also:
    WebServiceClient

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      The local name of the endpoint.

    • Element Detail

      • name

        public abstract String name
        The local name of the endpoint.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebFault (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type WebFault

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebFault
    Used to annotate service specific exception classes to customize to the local and namespace name of the fault element and the name of the fault bean.
    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String faultBean
      Fault bean name.
      String messageName
      wsdl:Message's name.
      String name
      Element's local name.
      String targetNamespace
      Element's namespace name.

    • Element Detail

      • name

        public abstract String name
        Element's local name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Element's namespace name.
        Default:
        ""

      • faultBean

        public abstract String faultBean
        Fault bean name.
        Default:
        ""

      • messageName

        public abstract String messageName
        wsdl:Message's name. Default name is the exception's class name.
        Since:
        JAX-WS 2.2
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebServiceClient (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type WebServiceClient

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceClient
    Used to annotate a generated service interface.

    The information specified in this annotation is sufficient to uniquely identify a wsdl:service element inside a WSDL document. This wsdl:service element represents the Web service for which the generated service interface provides a client view.

    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      The local name of the Web service.
      String targetNamespace
      The namespace for the Web service.
      String wsdlLocation
      The location of the WSDL document for the service (a URL).

    • Element Detail

      • name

        public abstract String name
        The local name of the Web service.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        The namespace for the Web service.
        Default:
        ""

      • wsdlLocation

        public abstract String wsdlLocation
        The location of the WSDL document for the service (a URL).
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebServiceContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface WebServiceContext

  • public interface WebServiceContext
    A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served. Typically a WebServiceContext is injected into an endpoint implementation class using the Resource annotation.
    Since:
    JAX-WS 2.0
    See Also:
    Resource

    • Method Summary

      Methods
      Modifier and Type Method and Description
      <T extends EndpointReference>
      T             		getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this endpoint.
      EndpointReference getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference for this endpoint.
      MessageContext getMessageContext()
      Returns the MessageContext for the request being served at the time this method is called.
      Principal getUserPrincipal()
      Returns the Principal that identifies the sender of the request currently being serviced.
      boolean isUserInRole(String role)
      Returns a boolean indicating whether the authenticated user is included in the specified logical role.

    • Method Detail

      • getMessageContext

        MessageContext getMessageContext()
        Returns the MessageContext for the request being served at the time this method is called. Only properties with APPLICATION scope will be visible to the application.
        Returns:
        MessageContext The message context.
        Throws:
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        See Also:
        MessageContext, MessageContext.Scope, IllegalStateException

      • getUserPrincipal

        Principal getUserPrincipal()
        Returns the Principal that identifies the sender of the request currently being serviced. If the sender has not been authenticated, the method returns null.
        Returns:
        Principal The principal object.
        Throws:
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        See Also:
        Principal, IllegalStateException

      • isUserInRole

        boolean isUserInRole(String role)
        Returns a boolean indicating whether the authenticated user is included in the specified logical role. If the user has not been authenticated, the method returns false.
        Parameters:
        role - A String specifying the name of the role
        Returns:
        a boolean indicating whether the sender of the request belongs to a given role
        Throws:
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.

      • getEndpointReference

        EndpointReference getEndpointReference(Element... referenceParameters)
        Returns the EndpointReference for this endpoint.

        If the Binding for this bindingProvider is either SOAP1.1/HTTP or SOAP1.2/HTTP, then a W3CEndpointReference MUST be returned.

        Parameters:
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        Returns:
        EndpointReference of the endpoint associated with this WebServiceContext. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        Throws:
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        Since:
        JAX-WS 2.1
        See Also:
        W3CEndpointReference

      • getEndpointReference

        <T extends EndpointReference> T getEndpointReference(Class<T> clazz,
                                                   Element... referenceParameters)
        Returns the EndpointReference associated with this endpoint.
        Parameters:
        clazz - The type of EndpointReference that MUST be returned.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        Returns:
        EndpointReference of type clazz of the endpoint associated with this WebServiceContext instance. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        Throws:
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        WebServiceException - If the clazz type of EndpointReference is not supported.
        Since:
        JAX-WS 2.1
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WebServiceException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class WebServiceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ProtocolException

    public class WebServiceException
extends RuntimeException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
    Since:
    JAX-WS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      WebServiceException()
      Constructs a new exception with null as its detail message.
      WebServiceException(String message)
      Constructs a new exception with the specified detail message.
      WebServiceException(String message, Throwable cause)
      Constructs a new exception with the specified detail message and cause.
      WebServiceException(Throwable cause)
      Constructs a new WebServiceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WebServiceException

        public WebServiceException()
        Constructs a new exception with null as its detail message. The cause is not initialized.

      • WebServiceException

        public WebServiceException(String message)
        Constructs a new exception with the specified detail message. The cause is not initialized.
        Parameters:
        message - The detail message which is later retrieved using the getMessage method

      • WebServiceException

        public WebServiceException(String message,
                   Throwable cause)
        Constructs a new exception with the specified detail message and cause.
        Parameters:
        message - The detail message which is later retrieved using the getMessage method
        cause - The cause which is saved for the later retrieval throw by the getCause method

      • WebServiceException

        public WebServiceException(Throwable cause)
        Constructs a new WebServiceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - The cause which is saved for the later retrieval throw by the getCause method. (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WebServiceFeature (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class WebServiceFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
  • Direct Known Subclasses:
    AddressingFeature, MTOMFeature, RespectBindingFeature

    public abstract class WebServiceFeature
extends Object
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.

    The JAX-WS specification will define some standard features and JAX-WS implementors are free to define additional features if necessary. Vendor specific features may not be portable so caution should be used when using them. Each Feature definition MUST define a public static final String ID that can be used in the Feature annotation to refer to the feature. This ID MUST be unique across all features of all vendors. When defining a vendor specific feature ID, use a vendor specific namespace in the ID string.

    Since:
    2.1
    See Also:
    RespectBindingFeature, AddressingFeature, MTOMFeature

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean enabled
      Specifies if the feature is enabled or disabled

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | WebServiceFeature()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract String getID()
      Get the unique identifier for this WebServiceFeature.
      boolean isEnabled()
      Returns true if this feature is enabled.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • enabled

        protected boolean enabled
        Specifies if the feature is enabled or disabled

    • Constructor Detail

      • WebServiceFeature

        protected WebServiceFeature()

    • Method Detail

      • getID

        public abstract String getID()
        Get the unique identifier for this WebServiceFeature.
        Returns:
        the unique identifier for this feature.

      • isEnabled

        public boolean isEnabled()
        Returns true if this feature is enabled.
        Returns:
        true if and only if the feature is enabled .
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WebServicePermission (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class WebServicePermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.xml.ws.WebServicePermission
  • All Implemented Interfaces:
    Serializable, Guard

    public final class WebServicePermission
extends BasicPermission
    This class defines web service permissions.

    Web service Permissions are identified by name (also referred to as a "target name") alone. There are no actions associated with them.

    The following permission target name is defined:

    publishEndpoint

    The publishEndpoint permission allows publishing a web service endpoint using the publish methods defined by the javax.xml.ws.Endpoint class.

    Granting publishEndpoint allows the application to be exposed as a network service. Depending on the security of the runtime and the security of the application, this may introduce a security hole that is remotely exploitable.

    See Also:
    Endpoint, BasicPermission, Permission, Permissions, SecurityManager, SocketPermission, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      WebServicePermission(String name)
      Creates a new permission with the specified name.
      WebServicePermission(String name, String actions)
      Creates a new permission with the specified name and actions.

    • Method Summary

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WebServicePermission

        public WebServicePermission(String name)
        Creates a new permission with the specified name.
        Parameters:
        name - the name of the WebServicePermission

      • WebServicePermission

        public WebServicePermission(String name,
                    String actions)
        Creates a new permission with the specified name and actions. The actions parameter is currently unused and it should be null.
        Parameters:
        name - the name of the WebServicePermission
        actions - should be null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WebServiceProvider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type WebServiceProvider

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceProvider
    Used to annotate a Provider implementation class.
    Since:
    JAX-WS 2.0
    See Also:
    Provider

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String portName
      Port name.
      String serviceName
      Service name.
      String targetNamespace
      Target namespace for the service
      String wsdlLocation
      Location of the WSDL description for the service.

    • Element Detail

      • wsdlLocation

        public abstract String wsdlLocation
        Location of the WSDL description for the service.
        Default:
        ""

      • serviceName

        public abstract String serviceName
        Service name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Target namespace for the service
        Default:
        ""

      • portName

        public abstract String portName
        Port name.
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebServiceRef (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type WebServiceRef

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceRef
    The WebServiceRef annotation is used to define a reference to a web service and (optionally) an injection target for it. It can be used to inject both service and proxy instances. These injected references are not thread safe. If the references are accessed by multiple threads, usual synchronization techinques can be used to support multiple threads.

    Web service references are resources in the Java EE 5 sense. The annotations (for example, Addressing) annotated with meta-annotation WebServiceFeatureAnnotation can be used in conjunction with WebServiceRef. The created reference MUST be configured with annotation's web service feature.

    For example, in the code below, the injected StockQuoteProvider proxy MUST have WS-Addressing enabled as specifed by the Addressing annotation.

    public class MyClient {
       @Addressing
       @WebServiceRef(StockQuoteService.class)
       private StockQuoteProvider stockQuoteProvider;
       ...
    }

    If a JAX-WS implementation encounters an unsupported or unrecognized annotation annotated with the WebServiceFeatureAnnotation that is specified with WebServiceRef, an ERROR MUST be given.

    Since:
    JAX-WS 2.0
    See Also:
    Resource, WebServiceFeatureAnnotation

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String lookup
      A portable JNDI lookup name that resolves to the target web service reference.
      String mappedName
      A product specific name that this resource should be mapped to.
      String name
      The JNDI name of the resource.
      Class<?> type
      The Java type of the resource.
      Class<? extends Service> value
      The service class, alwiays a type extending javax.xml.ws.Service.
      String wsdlLocation
      A URL pointing to the WSDL document for the web service.

    • Element Detail

      • name

        public abstract String name
        The JNDI name of the resource. For field annotations, the default is the field name. For method annotations, the default is the JavaBeans property name corresponding to the method. For class annotations, there is no default and this MUST be specified. The JNDI name can be absolute(with any logical namespace) or relative to JNDI java:comp/env namespace.
        Default:
        ""

      • type

        public abstract Class<?> type
        The Java type of the resource. For field annotations, the default is the type of the field. For method annotations, the default is the type of the JavaBeans property. For class annotations, there is no default and this MUST be specified.
        Default:
        java.lang.Object.class

      • mappedName

        public abstract String mappedName
        A product specific name that this resource should be mapped to. The name of this resource, as defined by the name element or defaulted, is a name that is local to the application component using the resource. (When a relative JNDI name is specified, then it's a name in the JNDI java:comp/env namespace.) Many application servers provide a way to map these local names to names of resources known to the application server. This mapped name is often a global JNDI name, but may be a name of any form.

        Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

        Default:
        ""

      • value

        public abstract Class<? extends Service> value
        The service class, alwiays a type extending javax.xml.ws.Service. This element MUST be specified whenever the type of the reference is a service endpoint interface.
        Default:
        javax.xml.ws.Service.class

      • wsdlLocation

        public abstract String wsdlLocation
        A URL pointing to the WSDL document for the web service. If not specified, the WSDL location specified by annotations on the resource type is used instead.
        Default:
        ""

      • lookup

        public abstract String lookup
        A portable JNDI lookup name that resolves to the target web service reference.
        Since:
        JAX-WS 2.2
        Default:
        ""
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


WebServiceRefs (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws

Annotation Type WebServiceRefs

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface WebServiceRefs
    The WebServiceRefs annotation allows multiple web service references to be declared at the class level.

    It can be used to inject both service and proxy instances. These injected references are not thread safe. If the references are accessed by multiple threads, usual synchronization techinques can be used to support multiple threads.

    There is no way to associate web service features with the injected instances. If an instance needs to be configured with web service features, use @WebServiceRef to inject the resource along with its features.

    Example: The StockQuoteProvider proxy instance, and the StockQuoteService service instance are injected using @WebServiceRefs.

    @WebServiceRefs({@WebServiceRef(name="service/stockquoteservice", value=StockQuoteService.class),
                     @WebServiceRef(name="service/stockquoteprovider", type=StockQuoteProvider.class, value=StockQuoteService.class})
    public class MyClient {
        void init() {
            Context ic = new InitialContext();
            StockQuoteService service = (StockQuoteService) ic.lookup("java:comp/env/service/stockquoteservice");
            StockQuoteProvider port = (StockQuoteProvider) ic.lookup("java:comp/env/service/stockquoteprovider");
            ...
       }
       ...
    }
    Since:
    2.0
    See Also:
    WebServiceRef

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      WebServiceRef[] value
      Array used for multiple web service reference declarations.

    • Element Detail

      • value

        public abstract WebServiceRef[] value
        Array used for multiple web service reference declarations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.xml.ws.Action (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.Action

No usage of javax.xml.ws.Action
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.BindingType (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.BindingType

No usage of javax.xml.ws.BindingType
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.Endpoint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.Endpoint

  • Packages that use Endpoint
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Endpoint in javax.xml.ws

      Methods in javax.xml.ws that return Endpoint
      Modifier and Type Method and Description
      static Endpoint Endpoint.create(Object implementor)
      Creates an endpoint with the specified implementor object.
      static Endpoint Endpoint.create(Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified implementor object and web service features.
      static Endpoint Endpoint.create(String bindingId, Object implementor)
      Creates an endpoint with the specified binding type and implementor object.
      static Endpoint Endpoint.create(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified binding type, implementor object, and web service features.
      static Endpoint Endpoint.publish(String address, Object implementor)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      static Endpoint Endpoint.publish(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      Methods in javax.xml.ws that return types with arguments of type Endpoint
      Modifier and Type Method and Description
      abstract Set<Endpoint> EndpointContext.getEndpoints()
      This gives list of endpoints in an application.

    • Uses of Endpoint in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Endpoint
      Modifier and Type Method and Description
      abstract Endpoint Provider.createAndPublishEndpoint(String address, Object implementor)
      Creates and publishes an endpoint object with the specified address and implementation object.
      Endpoint Provider.createAndPublishEndpoint(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint object with the specified address, implementation object and web service features.
      Endpoint Provider.createEndpoint(String bindingId, Class<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
      abstract Endpoint Provider.createEndpoint(String bindingId, Object implementor)
      Creates an endpoint object with the provided binding and implementation object.
      Endpoint Provider.createEndpoint(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation object and web service features.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.EndpointContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.EndpointContext

  • Packages that use EndpointContext
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of EndpointContext in javax.xml.ws

      Methods in javax.xml.ws with parameters of type EndpointContext
      Modifier and Type Method and Description
      void Endpoint.setEndpointContext(EndpointContext ctxt)
      By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.EndpointReference (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.EndpointReference

  • Packages that use EndpointReference
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of EndpointReference in javax.xml.ws

      Methods in javax.xml.ws with type parameters of type EndpointReference
      Modifier and Type Method and Description
      <T extends EndpointReference>
      T             		BindingProvider.getEndpointReference(Class<T> clazz)
      Returns the EndpointReference associated with this BindingProvider instance.
      <T extends EndpointReference>
      T             		WebServiceContext.getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this endpoint.
      abstract <T extends EndpointReference>
      T             		Endpoint.getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      Methods in javax.xml.ws that return EndpointReference
      Modifier and Type Method and Description
      EndpointReference BindingProvider.getEndpointReference()
      Returns the EndpointReference associated with this BindingProvider instance.
      EndpointReference WebServiceContext.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference for this endpoint.
      abstract EndpointReference Endpoint.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      static EndpointReference EndpointReference.readFrom(Source eprInfoset)
      Factory method to read an EndpointReference from the infoset contained in eprInfoset.
      Methods in javax.xml.ws with parameters of type EndpointReference
      Modifier and Type Method and Description
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> T Service.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.

    • Uses of EndpointReference in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return EndpointReference
      Modifier and Type Method and Description
      abstract EndpointReference Provider.readEndpointReference(Source eprInfoset)
      read an EndpointReference from the infoset contained in eprInfoset.
      Methods in javax.xml.ws.spi with parameters of type EndpointReference
      Modifier and Type Method and Description
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> T ServiceDelegate.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T Provider.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.

    • Uses of EndpointReference in javax.xml.ws.wsaddressing

      Subclasses of EndpointReference in javax.xml.ws.wsaddressing
      Modifier and Type Class and Description
      class  W3CEndpointReference
      This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.FaultAction (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.FaultAction

No usage of javax.xml.ws.FaultAction
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.Holder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.Holder

No usage of javax.xml.ws.Holder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.ProtocolException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.ProtocolException

  • Packages that use ProtocolException
    Package Description
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of ProtocolException in javax.xml.ws.http

      Subclasses of ProtocolException in javax.xml.ws.http
      Modifier and Type Class and Description
      class  HTTPException
      The HTTPException exception represents a XML/HTTP fault.

    • Uses of ProtocolException in javax.xml.ws.soap

      Subclasses of ProtocolException in javax.xml.ws.soap
      Modifier and Type Class and Description
      class  SOAPFaultException
      The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.RequestWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.RequestWrapper

No usage of javax.xml.ws.RequestWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.RespectBinding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.RespectBinding

No usage of javax.xml.ws.RespectBinding
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.RespectBindingFeature (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.RespectBindingFeature

No usage of javax.xml.ws.RespectBindingFeature
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.ResponseWrapper (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.ResponseWrapper

No usage of javax.xml.ws.ResponseWrapper
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.Service (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.Service

  • Packages that use Service
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Service in javax.xml.ws

      Methods in javax.xml.ws that return Service
      Modifier and Type Method and Description
      static Service Service.create(QName serviceName)
      Creates a Service instance.
      static Service Service.create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName)
      Creates a Service instance.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.

    • Uses of Service in javax.xml.ws.spi

      Method parameters in javax.xml.ws.spi with type arguments of type Service
      Modifier and Type Method and Description
      abstract ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.Service.Mode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.Service.Mode

  • Packages that use Service.Mode
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Service.Mode in javax.xml.ws

      Methods in javax.xml.ws that return Service.Mode
      Modifier and Type Method and Description
      static Service.Mode Service.Mode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Service.Mode[] Service.Mode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.xml.ws with parameters of type Service.Mode
      Modifier and Type Method and Description
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.

    • Uses of Service.Mode in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type Service.Mode
      Modifier and Type Method and Description
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.ServiceMode (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.ServiceMode

No usage of javax.xml.ws.ServiceMode
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.WebEndpoint (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebEndpoint

No usage of javax.xml.ws.WebEndpoint
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.WebFault (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebFault

No usage of javax.xml.ws.WebFault
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.WebServiceClient (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceClient

No usage of javax.xml.ws.WebServiceClient
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.WebServiceException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceException

  • Packages that use WebServiceException
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of WebServiceException in javax.xml.ws

      Subclasses of WebServiceException in javax.xml.ws
      Modifier and Type Class and Description
      class  ProtocolException
      The ProtocolException class is a base class for exceptions related to a specific protocol binding.

    • Uses of WebServiceException in javax.xml.ws.http

      Subclasses of WebServiceException in javax.xml.ws.http
      Modifier and Type Class and Description
      class  HTTPException
      The HTTPException exception represents a XML/HTTP fault.

    • Uses of WebServiceException in javax.xml.ws.soap

      Subclasses of WebServiceException in javax.xml.ws.soap
      Modifier and Type Class and Description
      class  SOAPFaultException
      The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.WebServiceFeature (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceFeature

  • Packages that use WebServiceFeature
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of WebServiceFeature in javax.xml.ws

      Subclasses of WebServiceFeature in javax.xml.ws
      Modifier and Type Class and Description
      class  RespectBindingFeature
      This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
      Methods in javax.xml.ws with parameters of type WebServiceFeature
      Modifier and Type Method and Description
      static Endpoint Endpoint.create(Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified implementor object and web service features.
      static Service Service.create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Endpoint Endpoint.create(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified binding type, implementor object, and web service features.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> T Service.getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T EndpointReference.getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T Service.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T Service.getPort(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      static Endpoint Endpoint.publish(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      Constructors in javax.xml.ws with parameters of type WebServiceFeature
      Constructor and Description
      Service(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)

    • Uses of WebServiceFeature in javax.xml.ws.soap

      Subclasses of WebServiceFeature in javax.xml.ws.soap
      Modifier and Type Class and Description
      class  AddressingFeature
      AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
      class  MTOMFeature
      This feature represents the use of MTOM with a web service.

    • Uses of WebServiceFeature in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type WebServiceFeature
      Modifier and Type Method and Description
      Endpoint Provider.createAndPublishEndpoint(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint object with the specified address, implementation object and web service features.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Endpoint Provider.createEndpoint(String bindingId, Class<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
      Endpoint Provider.createEndpoint(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation object and web service features.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
      abstract <T> T ServiceDelegate.getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T ServiceDelegate.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T Provider.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T ServiceDelegate.getPort(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.WebServicePermission (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServicePermission

No usage of javax.xml.ws.WebServicePermission
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.WebServiceProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceProvider

No usage of javax.xml.ws.WebServiceProvider
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.WebServiceRef (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceRef

No usage of javax.xml.ws.WebServiceRef
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.WebServiceRefs (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceRefs

No usage of javax.xml.ws.WebServiceRefs
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.AsyncHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.AsyncHandler

  • Packages that use AsyncHandler
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of AsyncHandler in javax.xml.ws

      Methods in javax.xml.ws with parameters of type AsyncHandler
      Modifier and Type Method and Description
      Future<?> Dispatch.invokeAsync(T msg, AsyncHandler<T> handler)
      Invoke a service operation asynchronously.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.Binding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.Binding

  • Packages that use Binding
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of Binding in javax.xml.ws

      Methods in javax.xml.ws that return Binding
      Modifier and Type Method and Description
      abstract Binding Endpoint.getBinding()
      Returns the binding for this endpoint.
      Binding BindingProvider.getBinding()
      Get the Binding for this binding provider.

    • Uses of Binding in javax.xml.ws.http

      Subinterfaces of Binding in javax.xml.ws.http
      Modifier and Type Interface and Description
      interface  HTTPBinding
      The HTTPBinding interface is an abstraction for the XML/HTTP binding.

    • Uses of Binding in javax.xml.ws.soap

      Subinterfaces of Binding in javax.xml.ws.soap
      Modifier and Type Interface and Description
      interface  SOAPBinding
      The SOAPBinding interface is an abstraction for the SOAP binding.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.BindingProvider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.BindingProvider

  • Packages that use BindingProvider
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of BindingProvider in javax.xml.ws

      Subinterfaces of BindingProvider in javax.xml.ws
      Modifier and Type Interface and Description
      interface  Dispatch<T>
      The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.Dispatch (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.Dispatch

  • Packages that use Dispatch
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Dispatch in javax.xml.ws

      Methods in javax.xml.ws that return Dispatch
      Modifier and Type Method and Description
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.

    • Uses of Dispatch in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Dispatch
      Modifier and Type Method and Description
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.LogicalMessage (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.LogicalMessage

  • Packages that use LogicalMessage
    Package Description
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of LogicalMessage in javax.xml.ws.handler

      Methods in javax.xml.ws.handler that return LogicalMessage
      Modifier and Type Method and Description
      LogicalMessage LogicalMessageContext.getMessage()
      Gets the message from this message context
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.Provider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.Provider

No usage of javax.xml.ws.Provider
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.Response (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.Response

  • Packages that use Response
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of Response in javax.xml.ws

      Methods in javax.xml.ws that return Response
      Modifier and Type Method and Description
      Response<T> Dispatch.invokeAsync(T msg)
      Invoke a service operation asynchronously.
      Methods in javax.xml.ws with parameters of type Response
      Modifier and Type Method and Description
      void AsyncHandler.handleResponse(Response<T> res)
      Called when the response to an asynchronous operation is available.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.WebServiceContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.WebServiceContext

  • Packages that use WebServiceContext
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of WebServiceContext in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type WebServiceContext
      Modifier and Type Method and Description
      abstract void Invoker.inject(WebServiceContext webServiceContext)
      JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Handler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface Handler<C extends MessageContext>

  • All Known Subinterfaces:
    LogicalHandler<C>, SOAPHandler<T>

    public interface Handler<C extends MessageContext>
    The Handler interface is the base interface for JAX-WS handlers.
    Since:
    JAX-WS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void close(MessageContext context)
      Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception.
      boolean handleFault(C context)
      The handleFault method is invoked for fault message processing.
      boolean handleMessage(C context)
      The handleMessage method is invoked for normal processing of inbound and outbound messages.

    • Method Detail

      • handleMessage

        boolean handleMessage(C context)
        The handleMessage method is invoked for normal processing of inbound and outbound messages. Refer to the description of the handler framework in the JAX-WS specification for full details.
        Parameters:
        context - the message context.
        Returns:
        An indication of whether handler processing should continue for the current message
        • Return true to continue processing.
        • Return false to block processing.
        Throws:
        RuntimeException - Causes the JAX-WS runtime to cease handler processing and generate a fault.
        ProtocolException - Causes the JAX-WS runtime to switch to fault message processing.

      • handleFault

        boolean handleFault(C context)
        The handleFault method is invoked for fault message processing. Refer to the description of the handler framework in the JAX-WS specification for full details.
        Parameters:
        context - the message context
        Returns:
        An indication of whether handler fault processing should continue for the current message
        • Return true to continue processing.
        • Return false to block processing.
        Throws:
        RuntimeException - Causes the JAX-WS runtime to cease handler fault processing and dispatch the fault.
        ProtocolException - Causes the JAX-WS runtime to cease handler fault processing and dispatch the fault.

      • close

        void close(MessageContext context)
        Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception. Refer to the description of the handler framework in the JAX-WS specification for full details.
        Parameters:
        context - the message context
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HandlerResolver (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface HandlerResolver

  • public interface HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.

    A HandlerResolver may be set on a Service using the setHandlerResolver method.

    When the runtime invokes a HandlerResolver, it will pass it a PortInfo object containing information about the port that the proxy/dispatch object will be accessing.

    Since:
    JAX-WS 2.0
    See Also:
    Service.setHandlerResolver(javax.xml.ws.handler.HandlerResolver)

    • Method Summary

      Methods
      Modifier and Type Method and Description
      List<Handler> getHandlerChain(PortInfo portInfo)
      Gets the handler chain for the specified port.

    • Method Detail

      • getHandlerChain

        List<Handler> getHandlerChain(PortInfo portInfo)
        Gets the handler chain for the specified port.
        Parameters:
        portInfo - Contains information about the port being accessed.
        Returns:
        java.util.List<Handler> chain
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.ws.handler (Java(TM) EE 7 Specification APIs)

javax.xml.ws.handler

Interfaces

  • Handler
  • HandlerResolver
  • LogicalHandler
  • LogicalMessageContext
  • MessageContext
  • PortInfo

Enums

  • MessageContext.Scope


javax.xml.ws.handler (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.handler

This package defines APIs for message handlers.

See: Description

  • Interface Summary
    Interface Description
    Handler<C extends MessageContext>
    The Handler interface is the base interface for JAX-WS handlers.
    HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
    LogicalHandler<C extends LogicalMessageContext>
    The LogicalHandler extends Handler to provide typesafety for the message context parameter.
    LogicalMessageContext
    The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
    PortInfo
    The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.
  • Enum Summary
    Enum Description
    MessageContext.Scope
    Property scope.

Package javax.xml.ws.handler Description

This package defines APIs for message handlers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.ws.handler Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.handler

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.LogicalHandler<C>
  • javax.xml.ws.handler.HandlerResolver
  • java.util.Map<K,V>
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.LogicalMessageContext
  • javax.xml.ws.handler.PortInfo

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.handler.MessageContext.Scope
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


LogicalHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface LogicalHandler<C extends LogicalMessageContext>

  • All Superinterfaces:
    Handler<C>

    public interface LogicalHandler<C extends LogicalMessageContext>
extends Handler<C>
    The LogicalHandler extends Handler to provide typesafety for the message context parameter.
    Since:
    JAX-WS 2.0

    • Method Summary

      • Methods inherited from interface javax.xml.ws.handler.Handler

        close, handleFault, handleMessage
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LogicalMessageContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface LogicalMessageContext

  • All Superinterfaces:
    Map<String,Object>, MessageContext

    public interface LogicalMessageContext
extends MessageContext
    The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
    Since:
    JAX-WS 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.xml.ws.handler.MessageContext

        MessageContext.Scope

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      • Fields inherited from interface javax.xml.ws.handler.MessageContext

        HTTP_REQUEST_HEADERS, HTTP_REQUEST_METHOD, HTTP_RESPONSE_CODE, HTTP_RESPONSE_HEADERS, INBOUND_MESSAGE_ATTACHMENTS, MESSAGE_OUTBOUND_PROPERTY, OUTBOUND_MESSAGE_ATTACHMENTS, PATH_INFO, QUERY_STRING, REFERENCE_PARAMETERS, SERVLET_CONTEXT, SERVLET_REQUEST, SERVLET_RESPONSE, WSDL_DESCRIPTION, WSDL_INTERFACE, WSDL_OPERATION, WSDL_PORT, WSDL_SERVICE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      LogicalMessage getMessage()
      Gets the message from this message context

      • Methods inherited from interface javax.xml.ws.handler.MessageContext

        getScope, setScope

      • Methods inherited from interface java.util.Map

        clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

    • Method Detail

      • getMessage

        LogicalMessage getMessage()
        Gets the message from this message context
        Returns:
        The contained message; returns null if no message is present in this message context
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface MessageContext

  • All Superinterfaces:
    Map<String,Object>
    All Known Subinterfaces:
    LogicalMessageContext, SOAPMessageContext

    public interface MessageContext
extends Map<String,Object>
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

    The MessageContext interface provides methods to manage a property set. MessageContext properties enable handlers in a handler chain to share processing related state.

    Since:
    JAX-WS 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  MessageContext.Scope
      Property scope.

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String HTTP_REQUEST_HEADERS
      Standard property: HTTP request headers.
      static String HTTP_REQUEST_METHOD
      Standard property: HTTP request method.
      static String HTTP_RESPONSE_CODE
      Standard property: HTTP response status code.
      static String HTTP_RESPONSE_HEADERS
      Standard property: HTTP response headers.
      static String INBOUND_MESSAGE_ATTACHMENTS
      Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.
      static String MESSAGE_OUTBOUND_PROPERTY
      Standard property: message direction, true for outbound messages, false for inbound.
      static String OUTBOUND_MESSAGE_ATTACHMENTS
      Standard property: Map of attachments to a message for the outbound message, key is the MIME Content-ID, value is a DataHandler.
      static String PATH_INFO
      Standard property: Request Path Info
      static String QUERY_STRING
      Standard property: Query string for request.
      static String REFERENCE_PARAMETERS
      Standard property: WS Addressing Reference Parameters.
      static String SERVLET_CONTEXT
      Standard property: servlet context object.
      static String SERVLET_REQUEST
      Standard property: servlet request object.
      static String SERVLET_RESPONSE
      Standard property: servlet response object.
      static String WSDL_DESCRIPTION
      Standard property: input source for WSDL document.
      static String WSDL_INTERFACE
      Standard property: name of wsdl interface (2.0) or port type (1.1).
      static String WSDL_OPERATION
      Standard property: name of WSDL operation.
      static String WSDL_PORT
      Standard property: name of WSDL port.
      static String WSDL_SERVICE
      Standard property: name of WSDL service.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      MessageContext.Scope getScope(String name)
      Gets the scope of a property.
      void setScope(String name, MessageContext.Scope scope)
      Sets the scope of a property.

      • Methods inherited from interface java.util.Map

        clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

    • Field Detail

      • MESSAGE_OUTBOUND_PROPERTY

        static final String MESSAGE_OUTBOUND_PROPERTY
        Standard property: message direction, true for outbound messages, false for inbound.

        Type: boolean

        See Also:
        Constant Field Values

      • INBOUND_MESSAGE_ATTACHMENTS

        static final String INBOUND_MESSAGE_ATTACHMENTS
        Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.

        Type: java.util.Map<String,DataHandler>

        See Also:
        Constant Field Values

      • OUTBOUND_MESSAGE_ATTACHMENTS

        static final String OUTBOUND_MESSAGE_ATTACHMENTS
        Standard property: Map of attachments to a message for the outbound message, key is the MIME Content-ID, value is a DataHandler.

        Type: java.util.Map<String,DataHandler>

        See Also:
        Constant Field Values

      • WSDL_DESCRIPTION

        static final String WSDL_DESCRIPTION
        Standard property: input source for WSDL document.

        Type: org.xml.sax.InputSource

        See Also:
        Constant Field Values

      • WSDL_SERVICE

        static final String WSDL_SERVICE
        Standard property: name of WSDL service.

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

      • WSDL_PORT

        static final String WSDL_PORT
        Standard property: name of WSDL port.

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

      • WSDL_INTERFACE

        static final String WSDL_INTERFACE
        Standard property: name of wsdl interface (2.0) or port type (1.1).

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

      • WSDL_OPERATION

        static final String WSDL_OPERATION
        Standard property: name of WSDL operation.

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

      • HTTP_RESPONSE_CODE

        static final String HTTP_RESPONSE_CODE
        Standard property: HTTP response status code.

        Type: java.lang.Integer

        See Also:
        Constant Field Values

      • HTTP_REQUEST_HEADERS

        static final String HTTP_REQUEST_HEADERS
        Standard property: HTTP request headers.

        Type: java.util.Map<java.lang.String, java.util.List<java.lang.String>>

        See Also:
        Constant Field Values

      • HTTP_RESPONSE_HEADERS

        static final String HTTP_RESPONSE_HEADERS
        Standard property: HTTP response headers.

        Type: java.util.Map<java.lang.String, java.util.List<java.lang.String>>

        See Also:
        Constant Field Values

      • HTTP_REQUEST_METHOD

        static final String HTTP_REQUEST_METHOD
        Standard property: HTTP request method.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • SERVLET_REQUEST

        static final String SERVLET_REQUEST
        Standard property: servlet request object.

        Type: javax.servlet.http.HttpServletRequest

        See Also:
        Constant Field Values

      • SERVLET_RESPONSE

        static final String SERVLET_RESPONSE
        Standard property: servlet response object.

        Type: javax.servlet.http.HttpServletResponse

        See Also:
        Constant Field Values

      • SERVLET_CONTEXT

        static final String SERVLET_CONTEXT
        Standard property: servlet context object.

        Type: javax.servlet.ServletContext

        See Also:
        Constant Field Values

      • QUERY_STRING

        static final String QUERY_STRING
        Standard property: Query string for request.

        Type: String

        See Also:
        Constant Field Values

      • PATH_INFO

        static final String PATH_INFO
        Standard property: Request Path Info

        Type: String

        See Also:
        Constant Field Values

      • REFERENCE_PARAMETERS

        static final String REFERENCE_PARAMETERS
        Standard property: WS Addressing Reference Parameters. The list MUST include all SOAP headers marked with the wsa:IsReferenceParameter="true" attribute.

        Type: List<Element>

        Since:
        JAX-WS 2.1
        See Also:
        Constant Field Values

    • Method Detail

      • setScope

        void setScope(String name,
            MessageContext.Scope scope)
        Sets the scope of a property.
        Parameters:
        name - Name of the property associated with the MessageContext
        scope - Desired scope of the property
        Throws:
        IllegalArgumentException - if an illegal property name is specified

      • getScope

        MessageContext.Scope getScope(String name)
        Gets the scope of a property.
        Parameters:
        name - Name of the property
        Returns:
        Scope of the property
        Throws:
        IllegalArgumentException - if a non-existant property name is specified
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MessageContext.Scope (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.ws.handler

Enum MessageContext.Scope

  • java.lang.Object
    • java.lang.Enum<MessageContext.Scope>
      • javax.xml.ws.handler.MessageContext.Scope
  • All Implemented Interfaces:
    Serializable, Comparable<MessageContext.Scope>
    Enclosing interface:
    MessageContext

    public static enum MessageContext.Scope
extends Enum<MessageContext.Scope>
    Property scope. Properties scoped as APPLICATION are visible to handlers, client applications and service endpoints; properties scoped as HANDLER are only normally visible to handlers.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      APPLICATION
      HANDLER

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static MessageContext.Scope valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static MessageContext.Scope[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • APPLICATION

        public static final MessageContext.Scope APPLICATION

      • HANDLER

        public static final MessageContext.Scope HANDLER

    • Method Detail

      • values

        public static MessageContext.Scope[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (MessageContext.Scope c : MessageContext.Scope.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static MessageContext.Scope valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


PortInfo (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface PortInfo

  • public interface PortInfo
    The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.

    This interface is never implemented by an application, only by a JAX-WS implementation.

    Since:
    JAX-WS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getBindingID()
      Gets the URI identifying the binding used by the port being accessed.
      QName getPortName()
      Gets the qualified name of the WSDL port being accessed.
      QName getServiceName()
      Gets the qualified name of the WSDL service name containing the port being accessed.

    • Method Detail

      • getServiceName

        QName getServiceName()
        Gets the qualified name of the WSDL service name containing the port being accessed.
        Returns:
        javax.xml.namespace.QName The qualified name of the WSDL service.

      • getPortName

        QName getPortName()
        Gets the qualified name of the WSDL port being accessed.
        Returns:
        javax.xml.namespace.QName The qualified name of the WSDL port.

      • getBindingID

        String getBindingID()
        Gets the URI identifying the binding used by the port being accessed.
        Returns:
        String The binding identifier for the port.
        See Also:
        Binding
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.ws.handler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.handler

  • Packages that use javax.xml.ws.handler
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
  • Classes in javax.xml.ws.handler used by javax.xml.ws
    Class and Description
    Handler
    The Handler interface is the base interface for JAX-WS handlers.
    HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Classes in javax.xml.ws.handler used by javax.xml.ws.handler
    Class and Description
    Handler
    The Handler interface is the base interface for JAX-WS handlers.
    LogicalMessageContext
    The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
    MessageContext.Scope
    Property scope.
    PortInfo
    The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.
  • Classes in javax.xml.ws.handler used by javax.xml.ws.handler.soap
    Class and Description
    Handler
    The Handler interface is the base interface for JAX-WS handlers.
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Classes in javax.xml.ws.handler used by javax.xml.ws.spi
    Class and Description
    HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.handler.MessageContext.Scope (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.handler.MessageContext.Scope

  • Packages that use MessageContext.Scope
    Package Description
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of MessageContext.Scope in javax.xml.ws.handler

      Methods in javax.xml.ws.handler that return MessageContext.Scope
      Modifier and Type Method and Description
      MessageContext.Scope MessageContext.getScope(String name)
      Gets the scope of a property.
      static MessageContext.Scope MessageContext.Scope.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static MessageContext.Scope[] MessageContext.Scope.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.xml.ws.handler with parameters of type MessageContext.Scope
      Modifier and Type Method and Description
      void MessageContext.setScope(String name, MessageContext.Scope scope)
      Sets the scope of a property.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.handler.Handler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.Handler

  • Packages that use Handler
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of Handler in javax.xml.ws

      Methods in javax.xml.ws that return types with arguments of type Handler
      Modifier and Type Method and Description
      List<Handler> Binding.getHandlerChain()
      Gets a copy of the handler chain for a protocol binding instance.
      Method parameters in javax.xml.ws with type arguments of type Handler
      Modifier and Type Method and Description
      void Binding.setHandlerChain(List<Handler> chain)
      Sets the handler chain for the protocol binding instance.

    • Uses of Handler in javax.xml.ws.handler

      Subinterfaces of Handler in javax.xml.ws.handler
      Modifier and Type Interface and Description
      interface  LogicalHandler<C extends LogicalMessageContext>
      The LogicalHandler extends Handler to provide typesafety for the message context parameter.
      Methods in javax.xml.ws.handler that return types with arguments of type Handler
      Modifier and Type Method and Description
      List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
      Gets the handler chain for the specified port.

    • Uses of Handler in javax.xml.ws.handler.soap

      Subinterfaces of Handler in javax.xml.ws.handler.soap
      Modifier and Type Interface and Description
      interface  SOAPHandler<T extends SOAPMessageContext>
      The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.handler.HandlerResolver (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.HandlerResolver

  • Packages that use HandlerResolver
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of HandlerResolver in javax.xml.ws

      Methods in javax.xml.ws that return HandlerResolver
      Modifier and Type Method and Description
      HandlerResolver Service.getHandlerResolver()
      Returns the configured handler resolver.
      Methods in javax.xml.ws with parameters of type HandlerResolver
      Modifier and Type Method and Description
      void Service.setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.

    • Uses of HandlerResolver in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return HandlerResolver
      Modifier and Type Method and Description
      abstract HandlerResolver ServiceDelegate.getHandlerResolver()
      Returns the configured handler resolver.
      Methods in javax.xml.ws.spi with parameters of type HandlerResolver
      Modifier and Type Method and Description
      abstract void ServiceDelegate.setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.handler.LogicalHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.LogicalHandler

No usage of javax.xml.ws.handler.LogicalHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.handler.LogicalMessageContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.LogicalMessageContext

  • Packages that use LogicalMessageContext
    Package Description
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of LogicalMessageContext in javax.xml.ws.handler

      Classes in javax.xml.ws.handler with type parameters of type LogicalMessageContext
      Modifier and Type Interface and Description
      interface  LogicalHandler<C extends LogicalMessageContext>
      The LogicalHandler extends Handler to provide typesafety for the message context parameter.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.handler.MessageContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.MessageContext

  • Packages that use MessageContext
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of MessageContext in javax.xml.ws

      Methods in javax.xml.ws that return MessageContext
      Modifier and Type Method and Description
      MessageContext WebServiceContext.getMessageContext()
      Returns the MessageContext for the request being served at the time this method is called.

    • Uses of MessageContext in javax.xml.ws.handler

      Classes in javax.xml.ws.handler with type parameters of type MessageContext
      Modifier and Type Interface and Description
      interface  Handler<C extends MessageContext>
      The Handler interface is the base interface for JAX-WS handlers.
      Subinterfaces of MessageContext in javax.xml.ws.handler
      Modifier and Type Interface and Description
      interface  LogicalMessageContext
      The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
      Methods in javax.xml.ws.handler with parameters of type MessageContext
      Modifier and Type Method and Description
      void Handler.close(MessageContext context)
      Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception.

    • Uses of MessageContext in javax.xml.ws.handler.soap

      Subinterfaces of MessageContext in javax.xml.ws.handler.soap
      Modifier and Type Interface and Description
      interface  SOAPMessageContext
      The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.handler.PortInfo (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.PortInfo

  • Packages that use PortInfo
    Package Description
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of PortInfo in javax.xml.ws.handler

      Methods in javax.xml.ws.handler with parameters of type PortInfo
      Modifier and Type Method and Description
      List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
      Gets the handler chain for the specified port.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.xml.ws.handler.soap (Java(TM) EE 7 Specification APIs)

javax.xml.ws.handler.soap

Interfaces

  • SOAPHandler
  • SOAPMessageContext


javax.xml.ws.handler.soap (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.handler.soap

This package defines APIs for SOAP message handlers.

See: Description

  • Interface Summary
    Interface Description
    SOAPHandler<T extends SOAPMessageContext>
    The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
    SOAPMessageContext
    The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.

Package javax.xml.ws.handler.soap Description

This package defines APIs for SOAP message handlers.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.ws.handler.soap Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.handler.soap

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.soap.SOAPHandler<T>
  • java.util.Map<K,V>
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.soap.SOAPMessageContext
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


SOAPHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler.soap

Interface SOAPHandler<T extends SOAPMessageContext>

  • All Superinterfaces:
    Handler<T>

    public interface SOAPHandler<T extends SOAPMessageContext>
extends Handler<T>
    The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
    Since:
    JAX-WS 2.0

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Set<QName> getHeaders()
      Gets the header blocks that can be processed by this Handler instance.

      • Methods inherited from interface javax.xml.ws.handler.Handler

        close, handleFault, handleMessage

    • Method Detail

      • getHeaders

        Set<QName> getHeaders()
        Gets the header blocks that can be processed by this Handler instance.
        Returns:
        Set of QNames of header blocks processed by this handler instance. QName is the qualified name of the outermost element of the Header block.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPMessageContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler.soap

Interface SOAPMessageContext

  • All Superinterfaces:
    Map<String,Object>, MessageContext

    public interface SOAPMessageContext
extends MessageContext
    The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response. The javax.xml.soap.SOAPMessage specifies the standard Java API for the representation of a SOAP 1.1 message with attachments.
    Since:
    JAX-WS 2.0
    See Also:
    SOAPMessage

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.xml.ws.handler.MessageContext

        MessageContext.Scope

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      • Fields inherited from interface javax.xml.ws.handler.MessageContext

        HTTP_REQUEST_HEADERS, HTTP_REQUEST_METHOD, HTTP_RESPONSE_CODE, HTTP_RESPONSE_HEADERS, INBOUND_MESSAGE_ATTACHMENTS, MESSAGE_OUTBOUND_PROPERTY, OUTBOUND_MESSAGE_ATTACHMENTS, PATH_INFO, QUERY_STRING, REFERENCE_PARAMETERS, SERVLET_CONTEXT, SERVLET_REQUEST, SERVLET_RESPONSE, WSDL_DESCRIPTION, WSDL_INTERFACE, WSDL_OPERATION, WSDL_PORT, WSDL_SERVICE

    • Method Summary

      Methods
      Modifier and Type Method and Description
      Object[] getHeaders(QName header, JAXBContext context, boolean allRoles)
      Gets headers that have a particular qualified name from the message in the message context.
      SOAPMessage getMessage()
      Gets the SOAPMessage from this message context.
      Set<String> getRoles()
      Gets the SOAP actor roles associated with an execution of the handler chain.
      void setMessage(SOAPMessage message)
      Sets the SOAPMessage in this message context

      • Methods inherited from interface javax.xml.ws.handler.MessageContext

        getScope, setScope

      • Methods inherited from interface java.util.Map

        clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

    • Method Detail

      • getMessage

        SOAPMessage getMessage()
        Gets the SOAPMessage from this message context. Modifications to the returned SOAPMessage change the message in-place, there is no need to subsequently call setMessage.
        Returns:
        Returns the SOAPMessage; returns null if no SOAPMessage is present in this message context

      • setMessage

        void setMessage(SOAPMessage message)
        Sets the SOAPMessage in this message context
        Parameters:
        message - SOAP message
        Throws:
        WebServiceException - If any error during the setting of the SOAPMessage in this message context
        UnsupportedOperationException - If this operation is not supported

      • getHeaders

        Object[] getHeaders(QName header,
                  JAXBContext context,
                  boolean allRoles)
        Gets headers that have a particular qualified name from the message in the message context. Note that a SOAP message can contain multiple headers with the same qualified name.
        Parameters:
        header - The XML qualified name of the SOAP header(s).
        context - The JAXBContext that should be used to unmarshall the header
        allRoles - If true then returns headers for all SOAP roles, if false then only returns headers targetted at the roles currently being played by this SOAP node, see getRoles.
        Returns:
        An array of unmarshalled headers; returns an empty array if no message is present in this message context or no headers match the supplied qualified name.
        Throws:
        WebServiceException - If an error occurs when using the supplied JAXBContext to unmarshall. The cause of the WebServiceException is the original JAXBException.

      • getRoles

        Set<String> getRoles()
        Gets the SOAP actor roles associated with an execution of the handler chain. Note that SOAP actor roles apply to the SOAP node and are managed using SOAPBinding.setRoles(java.util.Set<java.lang.String>) and SOAPBinding.getRoles(). Handler instances in the handler chain use this information about the SOAP actor roles to process the SOAP header blocks. Note that the SOAP actor roles are invariant during the processing of SOAP message through the handler chain.
        Returns:
        Array of String for SOAP actor roles
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.ws.handler.soap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.handler.soap

  • Packages that use javax.xml.ws.handler.soap
    Package Description
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
  • Classes in javax.xml.ws.handler.soap used by javax.xml.ws.handler.soap
    Class and Description
    SOAPMessageContext
    The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.handler.soap.SOAPHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.soap.SOAPHandler

No usage of javax.xml.ws.handler.soap.SOAPHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.handler.soap.SOAPMessageContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.soap.SOAPMessageContext

  • Packages that use SOAPMessageContext
    Package Description
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of SOAPMessageContext in javax.xml.ws.handler.soap

      Classes in javax.xml.ws.handler.soap with type parameters of type SOAPMessageContext
      Modifier and Type Interface and Description
      interface  SOAPHandler<T extends SOAPMessageContext>
      The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


HTTPBinding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.http

Interface HTTPBinding

  • All Superinterfaces:
    Binding

    public interface HTTPBinding
extends Binding
    The HTTPBinding interface is an abstraction for the XML/HTTP binding.
    Since:
    JAX-WS 2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String HTTP_BINDING
      A constant representing the identity of the XML/HTTP binding.

    • Method Summary

      • Methods inherited from interface javax.xml.ws.Binding

        getBindingID, getHandlerChain, setHandlerChain

    • Field Detail

      • HTTP_BINDING

        static final String HTTP_BINDING
        A constant representing the identity of the XML/HTTP binding.
        See Also:
        Constant Field Values
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HTTPException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.http

Class HTTPException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException
  • All Implemented Interfaces:
    Serializable

    public class HTTPException
extends ProtocolException
    The HTTPException exception represents a XML/HTTP fault.

    Since there is no standard format for faults or exceptions in XML/HTTP messaging, only the HTTP status code is captured.

    Since:
    JAX-WS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      HTTPException(int statusCode)
      Constructor for the HTTPException

    • Method Summary

      Methods
      Modifier and Type Method and Description
      int getStatusCode()
      Gets the HTTP status code.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • HTTPException

        public HTTPException(int statusCode)
        Constructor for the HTTPException
        Parameters:
        statusCode - int for the HTTP status code

    • Method Detail

      • getStatusCode

        public int getStatusCode()
        Gets the HTTP status code.
        Returns:
        HTTP status code
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.ws.http (Java(TM) EE 7 Specification APIs)

javax.xml.ws.http

Interfaces

  • HTTPBinding

Exceptions

  • HTTPException


javax.xml.ws.http (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.http

This package defines APIs specific to the HTTP binding.

See: Description

  • Interface Summary
    Interface Description
    HTTPBinding
    The HTTPBinding interface is an abstraction for the XML/HTTP binding.
  • Exception Summary
    Exception Description
    HTTPException
    The HTTPException exception represents a XML/HTTP fault.

Package javax.xml.ws.http Description

This package defines APIs specific to the HTTP binding.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.ws.http Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.http

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException

Interface Hierarchy

  • javax.xml.ws.Binding
    • javax.xml.ws.http.HTTPBinding
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.xml.ws.http (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.http

No usage of javax.xml.ws.http
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.http.HTTPException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.http.HTTPException

No usage of javax.xml.ws.http.HTTPException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.http.HTTPBinding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.http.HTTPBinding

No usage of javax.xml.ws.http.HTTPBinding
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Addressing (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws.soap

Annotation Type Addressing

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
@WebServiceFeatureAnnotation(id="http://www.w3.org/2005/08/addressing/module",
                             bean=AddressingFeature.class)
public @interface Addressing
    This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding. Using this annotation with any other binding is undefined.

    This annotation MUST only be used in conjunction with the WebService, WebServiceProvider, and WebServiceRef annotations. When used with a javax.jws.WebService annotation, this annotation MUST only be used on the service endpoint implementation class. When used with a WebServiceRef annotation, this annotation MUST only be used when a proxy instance is created. The injected SEI proxy, and endpoint MUST honor the values of the Addressing annotation.

    This annotation's behaviour is defined by the corresponding feature AddressingFeature.

    Since:
    JAX-WS 2.1

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean enabled
      Specifies if this feature is enabled or disabled.
      boolean required
      If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.
      AddressingFeature.Responses responses
      If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all.

    • Element Detail

      • enabled

        public abstract boolean enabled
        Specifies if this feature is enabled or disabled. If enabled, it means the endpoint supports WS-Addressing but does not require its use. Corresponding 3.1.1 Addressing Assertion must be generated in the generated WSDL.
        Default:
        true

      • required

        public abstract boolean required
        If addressing is enabled, this property determines whether the endpoint requires WS-Addressing. If required is true, the endpoint requires WS-Addressing and WS-Addressing headers MUST be present on incoming messages. A corresponding 3.1.1 Addressing Assertion must be generated in the WSDL.
        Default:
        false

      • responses

        public abstract AddressingFeature.Responses responses
        If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all.

        AddressingFeature.Responses.ALL supports all response types and this is the default value.

        AddressingFeature.Responses.ANONYMOUS requires the use of only anonymous responses. It will result into wsam:AnonymousResponses nested assertion as specified in 3.1.2 AnonymousResponses Assertion in the generated WSDL.

        AddressingFeature.Responses.NON_ANONYMOUS requires the use of only non-anonymous responses. It will result into wsam:NonAnonymousResponses nested assertion as specified in 3.1.3 NonAnonymousResponses Assertion in the generated WSDL.

        Since:
        JAX-WS 2.2
        Default:
        javax.xml.ws.soap.AddressingFeature.Responses.ALL
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


AddressingFeature (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.soap

Class AddressingFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.AddressingFeature

  • public final class AddressingFeature
extends WebServiceFeature
    AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding. Using this feature with any other binding is undefined.

    This feature can be used during the creation of SEI proxy, and Dispatch instances on the client side and Endpoint instances on the server side. This feature cannot be used for Service instance creation on the client side.

    The following describes the effects of this feature with respect to be enabled or disabled:

    • ENABLED: In this Mode, WS-Addressing will be enabled. It means the endpoint supports WS-Addressing but does not require its use. A sender could send messages with WS-Addressing headers or without WS-Addressing headers. But a receiver MUST consume both types of messages.
    • DISABLED: In this Mode, WS-Addressing will be disabled. At runtime, WS-Addressing headers MUST NOT be used by a sender or receiver.

    If the feature is enabled, the required property determines whether the endpoint requires WS-Addressing. If it is set true, WS-Addressing headers MUST be present on incoming and outgoing messages. By default the required property is false.

    If the web service developer has not explicitly enabled this feature, WSDL's wsam:Addressing policy assertion is used to find the use of WS-Addressing. By using the feature explicitly, an application overrides WSDL's indication of the use of WS-Addressing. In some cases, this is really required. For example, if an application has implemented WS-Addressing itself, it can use this feature to disable addressing. That means a JAX-WS implementation doesn't consume or produce WS-Addressing headers.

    If addressing is enabled, a corresponding wsam:Addressing policy assertion must be generated in the WSDL as per 3.1 WS-Policy Assertions

    Example 1: Possible Policy Assertion in the generated WSDL for @Addressing

       <wsam:Addressing wsp:Optional="true">
     <wsp:Policy/>
   </wsam:Addressing>

    Example 2: Possible Policy Assertion in the generated WSDL for @Addressing(required=true)

       <wsam:Addressing>
     <wsp:Policy/>
   </wsam:Addressing>

    Example 3: Possible Policy Assertion in the generated WSDL for @Addressing(required=true, responses=Responses.ANONYMOUS)

       <wsam:Addressing>
      <wsp:Policy>
        <wsam:AnonymousResponses/>
      </wsp:Policy>
   </wsam:Addressing>

    See Web Services Addressing - Core, Web Services Addressing 1.0 - SOAP Binding, and Web Services Addressing 1.0 - Metadata for more information on WS-Addressing.

    Since:
    JAX-WS 2.1
    See Also:
    Addressing

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  AddressingFeature.Responses
      If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ID
      Constant value identifying the AddressingFeature
      protected boolean required
      If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.

      • Fields inherited from class javax.xml.ws.WebServiceFeature

        enabled

    • Constructor Summary

      Constructors
      Constructor and Description
      AddressingFeature()
      Creates and configures an AddressingFeature with the use of addressing requirements.
      AddressingFeature(boolean enabled)
      Creates and configures an AddressingFeature with the use of addressing requirements.
      AddressingFeature(boolean enabled, boolean required)
      Creates and configures an AddressingFeature with the use of addressing requirements.
      AddressingFeature(boolean enabled, boolean required, AddressingFeature.Responses responses)
      Creates and configures an AddressingFeature with the use of addressing requirements.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getID()
      Get the unique identifier for this WebServiceFeature.
      AddressingFeature.Responses getResponses()
      If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.
      boolean isRequired()
      If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.

      • Methods inherited from class javax.xml.ws.WebServiceFeature

        isEnabled

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ID

        public static final String ID
        Constant value identifying the AddressingFeature
        See Also:
        Constant Field Values

      • required

        protected boolean required
        If addressing is enabled, this property determines whether the endpoint requires WS-Addressing. If required is true, WS-Addressing headers MUST be present on incoming and outgoing messages.

    • Constructor Detail

      • AddressingFeature

        public AddressingFeature()
        Creates and configures an AddressingFeature with the use of addressing requirements. The created feature enables ws-addressing i.e. supports ws-addressing but doesn't require its use. It is also configured to accept all the response types.

      • AddressingFeature

        public AddressingFeature(boolean enabled)
        Creates and configures an AddressingFeature with the use of addressing requirements. If enabled is true, it enables ws-addressing i.e. supports ws-addressing but doesn't require its use. It also configures to accept all the response types.
        Parameters:
        enabled - true enables ws-addressing i.e.ws-addressing is supported but doesn't require its use

      • AddressingFeature

        public AddressingFeature(boolean enabled,
                 boolean required)
        Creates and configures an AddressingFeature with the use of addressing requirements. If enabled and required are true, it enables ws-addressing and requires its use. It also configures to accept all the response types.
        Parameters:
        enabled - true enables ws-addressing i.e.ws-addressing is supported but doesn't require its use
        required - true means requires the use of ws-addressing .

      • AddressingFeature

        public AddressingFeature(boolean enabled,
                 boolean required,
                 AddressingFeature.Responses responses)
        Creates and configures an AddressingFeature with the use of addressing requirements. If enabled and required are true, it enables ws-addressing and requires its use. Also, the response types can be configured using responses parameter.
        Parameters:
        enabled - true enables ws-addressing i.e.ws-addressing is supported but doesn't require its use
        required - true means requires the use of ws-addressing .
        responses - specifies what type of responses are required
        Since:
        JAX-WS 2.2

    • Method Detail

      • getID

        public String getID()
        Get the unique identifier for this WebServiceFeature.
        Specified by:
        getID in class WebServiceFeature
        Returns:
        the unique identifier for this feature.

      • isRequired

        public boolean isRequired()
        If addressing is enabled, this property determines whether the endpoint requires WS-Addressing. If required is true, WS-Addressing headers MUST be present on incoming and outgoing messages.
        Returns:
        the current required value

      • getResponses

        public AddressingFeature.Responses getResponses()
        If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.

        Returns:
        AddressingFeature.Responses.ALL when endpoint supports all types of responses, AddressingFeature.Responses.ANONYMOUS when endpoint requires the use of only anonymous responses, AddressingFeature.Responses.NON_ANONYMOUS when endpoint requires the use of only non-anonymous responses
        Since:
        JAX-WS 2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AddressingFeature.Responses (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.ws.soap

Enum AddressingFeature.Responses

  • java.lang.Object
    • java.lang.Enum<AddressingFeature.Responses>
      • javax.xml.ws.soap.AddressingFeature.Responses
  • All Implemented Interfaces:
    Serializable, Comparable<AddressingFeature.Responses>
    Enclosing class:
    AddressingFeature

    public static enum AddressingFeature.Responses
extends Enum<AddressingFeature.Responses>
    If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.

    ALL supports all response types and this is the default value.

    ANONYMOUS requires the use of only anonymous responses. It will result into wsam:AnonymousResponses nested assertion as specified in 3.1.2 AnonymousResponses Assertion in the generated WSDL.

    NON_ANONYMOUS requires the use of only non-anonymous responses. It will result into wsam:NonAnonymousResponses nested assertion as specified in 3.1.3 NonAnonymousResponses Assertion in the generated WSDL.

    Since:
    JAX-WS 2.2

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ALL
      Supports all response types and this is the default
      ANONYMOUS
      Specifies the use of only anonymous responses.
      NON_ANONYMOUS
      Specifies the use of only non-anonymous responses.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      static AddressingFeature.Responses valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AddressingFeature.Responses[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ANONYMOUS

        public static final AddressingFeature.Responses ANONYMOUS
        Specifies the use of only anonymous responses. It will result into wsam:AnonymousResponses nested assertion as specified in 3.1.2 AnonymousResponses Assertion in the generated WSDL.

      • NON_ANONYMOUS

        public static final AddressingFeature.Responses NON_ANONYMOUS
        Specifies the use of only non-anonymous responses. It will result into wsam:NonAnonymousResponses nested assertion as specified in 3.1.3 NonAnonymousResponses Assertion in the generated WSDL.

      • ALL

        public static final AddressingFeature.Responses ALL
        Supports all response types and this is the default

    • Method Detail

      • values

        public static AddressingFeature.Responses[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (AddressingFeature.Responses c : AddressingFeature.Responses.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static AddressingFeature.Responses valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method


javax.xml.ws.soap (Java(TM) EE 7 Specification APIs)

javax.xml.ws.soap

Interfaces

  • SOAPBinding

Classes

  • AddressingFeature
  • MTOMFeature

Enums

  • AddressingFeature.Responses

Exceptions

  • SOAPFaultException

Annotation Types

  • Addressing
  • MTOM


javax.xml.ws.soap (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.soap

This package defines APIs specific to the SOAP binding.

See: Description

  • Interface Summary
    Interface Description
    SOAPBinding
    The SOAPBinding interface is an abstraction for the SOAP binding.
  • Class Summary
    Class Description
    AddressingFeature
    AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
    MTOMFeature
    This feature represents the use of MTOM with a web service.
  • Enum Summary
    Enum Description
    AddressingFeature.Responses
    If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.
  • Exception Summary
    Exception Description
    SOAPFaultException
    The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.
  • Annotation Types Summary
    Annotation Type Description
    Addressing
    This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
    MTOM
    This feature represents the use of MTOM with a web service.

Package javax.xml.ws.soap Description

This package defines APIs specific to the SOAP binding.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.ws.soap Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.soap

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.soap.SOAPFaultException
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.AddressingFeature
      • javax.xml.ws.soap.MTOMFeature

Interface Hierarchy

  • javax.xml.ws.Binding
    • javax.xml.ws.soap.SOAPBinding

Annotation Type Hierarchy

  • javax.xml.ws.soap.MTOM (implements java.lang.annotation.Annotation)
  • javax.xml.ws.soap.Addressing (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.soap.AddressingFeature.Responses
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


MTOM (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws.soap

Annotation Type MTOM

  • @Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
@WebServiceFeatureAnnotation(id="http://www.w3.org/2004/08/soap/features/http-optimization",
                             bean=MTOMFeature.class)
public @interface MTOM
    This feature represents the use of MTOM with a web service.

    This annotation MUST only be used in conjunction the javax.jws.WebService, WebServiceProvider, WebServiceRef annotations. When used with the javax.jws.WebService annotation this annotation MUST only be used on the service endpoint implementation class. When used with a WebServiceRef annotation, this annotation MUST only be used when a proxy instance is created. The injected SEI proxy, and endpoint MUST honor the values of the MTOM annotation.

    This annotation's behaviour is defined by the corresponding feature MTOMFeature.

    Since:
    JAX-WS 2.1

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean enabled
      Specifies if this feature is enabled or disabled.
      int threshold
      Property for MTOM threshold value.

    • Element Detail

      • enabled

        public abstract boolean enabled
        Specifies if this feature is enabled or disabled.
        Default:
        true

      • threshold

        public abstract int threshold
        Property for MTOM threshold value. When MTOM is enabled, binary data above this size in bytes will be XOP encoded or sent as attachment. The value of this property MUST always be >= 0. Default value is 0.
        Default:
        0
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


MTOMFeature (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.soap

Class MTOMFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.MTOMFeature

  • public final class MTOMFeature
extends WebServiceFeature
    This feature represents the use of MTOM with a web service. This feature can be used during the creation of SEI proxy, and Dispatch instances on the client side and Endpoint instances on the server side. This feature cannot be used for Service instance creation on the client side.

    The following describes the affects of this feature with respect to being enabled or disabled:

    • ENABLED: In this Mode, MTOM will be enabled. A receiver MUST accept both a non-optimized and an optimized message, and a sender MAY send an optimized message, or a non-optimized message. The heuristics used by a sender to determine whether to use optimization or not are implementation-specific.
    • DISABLED: In this Mode, MTOM will be disabled

    The threshold property can be used to set the threshold value used to determine when binary data should be XOP encoded.

    Since:
    JAX-WS 2.1

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ID
      Constant value identifying the MTOMFeature
      protected int threshold
      Property for MTOM threshold value.

      • Fields inherited from class javax.xml.ws.WebServiceFeature

        enabled

    • Constructor Summary

      Constructors
      Constructor and Description
      MTOMFeature()
      Create an MTOMFeature.
      MTOMFeature(boolean enabled)
      Creates an MTOMFeature.
      MTOMFeature(boolean enabled, int threshold)
      Creates an MTOMFeature.
      MTOMFeature(int threshold)
      Creates an MTOMFeature.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      String getID()
      Get the unique identifier for this WebServiceFeature.
      int getThreshold()
      Gets the threshold value used to determine when binary data should be sent as an attachment.

      • Methods inherited from class javax.xml.ws.WebServiceFeature

        isEnabled

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ID

        public static final String ID
        Constant value identifying the MTOMFeature
        See Also:
        Constant Field Values

      • threshold

        protected int threshold
        Property for MTOM threshold value. This property serves as a hint when MTOM is enabled, binary data above this size in bytes SHOULD be sent as attachment. The value of this property MUST always be >= 0. Default value is 0.

    • Constructor Detail

      • MTOMFeature

        public MTOMFeature()
        Create an MTOMFeature. The instance created will be enabled.

      • MTOMFeature

        public MTOMFeature(boolean enabled)
        Creates an MTOMFeature.
        Parameters:
        enabled - specifies if this feature should be enabled or not

      • MTOMFeature

        public MTOMFeature(int threshold)
        Creates an MTOMFeature. The instance created will be enabled.
        Parameters:
        threshold - the size in bytes that binary data SHOULD be before being sent as an attachment.
        Throws:
        WebServiceException - if threshold is < 0

      • MTOMFeature

        public MTOMFeature(boolean enabled,
           int threshold)
        Creates an MTOMFeature.
        Parameters:
        enabled - specifies if this feature should be enabled or not
        threshold - the size in bytes that binary data SHOULD be before being sent as an attachment.
        Throws:
        WebServiceException - if threshold is < 0

    • Method Detail

      • getID

        public String getID()
        Get the unique identifier for this WebServiceFeature.
        Specified by:
        getID in class WebServiceFeature
        Returns:
        the unique identifier for this feature.

      • getThreshold

        public int getThreshold()
        Gets the threshold value used to determine when binary data should be sent as an attachment.
        Returns:
        the current threshold size in bytes
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPBinding (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.soap

Interface SOAPBinding

  • All Superinterfaces:
    Binding

    public interface SOAPBinding
extends Binding
    The SOAPBinding interface is an abstraction for the SOAP binding.
    Since:
    JAX-WS 2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String SOAP11HTTP_BINDING
      A constant representing the identity of the SOAP 1.1 over HTTP binding.
      static String SOAP11HTTP_MTOM_BINDING
      A constant representing the identity of the SOAP 1.1 over HTTP binding with MTOM enabled by default.
      static String SOAP12HTTP_BINDING
      A constant representing the identity of the SOAP 1.2 over HTTP binding.
      static String SOAP12HTTP_MTOM_BINDING
      A constant representing the identity of the SOAP 1.2 over HTTP binding with MTOM enabled by default.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      MessageFactory getMessageFactory()
      Gets the SAAJ MessageFactory instance used by this SOAP binding.
      Set<String> getRoles()
      Gets the roles played by the SOAP binding instance.
      SOAPFactory getSOAPFactory()
      Gets the SAAJ SOAPFactory instance used by this SOAP binding.
      boolean isMTOMEnabled()
      Returns true if the use of MTOM is enabled.
      void setMTOMEnabled(boolean flag)
      Enables or disables use of MTOM.
      void setRoles(Set<String> roles)
      Sets the roles played by the SOAP binding instance.

      • Methods inherited from interface javax.xml.ws.Binding

        getBindingID, getHandlerChain, setHandlerChain

    • Field Detail

      • SOAP11HTTP_BINDING

        static final String SOAP11HTTP_BINDING
        A constant representing the identity of the SOAP 1.1 over HTTP binding.
        See Also:
        Constant Field Values

      • SOAP12HTTP_BINDING

        static final String SOAP12HTTP_BINDING
        A constant representing the identity of the SOAP 1.2 over HTTP binding.
        See Also:
        Constant Field Values

      • SOAP11HTTP_MTOM_BINDING

        static final String SOAP11HTTP_MTOM_BINDING
        A constant representing the identity of the SOAP 1.1 over HTTP binding with MTOM enabled by default.
        See Also:
        Constant Field Values

      • SOAP12HTTP_MTOM_BINDING

        static final String SOAP12HTTP_MTOM_BINDING
        A constant representing the identity of the SOAP 1.2 over HTTP binding with MTOM enabled by default.
        See Also:
        Constant Field Values

    • Method Detail

      • getRoles

        Set<String> getRoles()
        Gets the roles played by the SOAP binding instance.
        Returns:
        Set<String> The set of roles played by the binding instance.

      • setRoles

        void setRoles(Set<String> roles)
        Sets the roles played by the SOAP binding instance.
        Parameters:
        roles - The set of roles played by the binding instance.
        Throws:
        WebServiceException - On an error in the configuration of the list of roles.

      • isMTOMEnabled

        boolean isMTOMEnabled()
        Returns true if the use of MTOM is enabled.
        Returns:
        true if and only if the use of MTOM is enabled.

      • setMTOMEnabled

        void setMTOMEnabled(boolean flag)
        Enables or disables use of MTOM.
        Parameters:
        flag - A boolean specifying whether the use of MTOM should be enabled or disabled.
        Throws:
        WebServiceException - If the specified setting is not supported by this binding instance.

      • getSOAPFactory

        SOAPFactory getSOAPFactory()
        Gets the SAAJ SOAPFactory instance used by this SOAP binding.
        Returns:
        SOAPFactory instance used by this SOAP binding.

      • getMessageFactory

        MessageFactory getMessageFactory()
        Gets the SAAJ MessageFactory instance used by this SOAP binding.
        Returns:
        MessageFactory instance used by this SOAP binding.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SOAPFaultException (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.soap

Class SOAPFaultException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.soap.SOAPFaultException
  • All Implemented Interfaces:
    Serializable

    public class SOAPFaultException
extends ProtocolException
    The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.

    A SOAPFaultException wraps a SAAJ SOAPFault that manages the SOAP-specific representation of faults. The createFault method of javax.xml.soap.SOAPFactory may be used to create an instance of javax.xml.soap.SOAPFault for use with the constructor. SOAPBinding contains an accessor for the SOAPFactory used by the binding instance.

    Note that the value of getFault is the only part of the exception used when searializing a SOAP fault.

    Refer to the SOAP specification for a complete description of SOAP faults.

    Since:
    JAX-WS 2.0
    See Also:
    SOAPFault, SOAPBinding.getSOAPFactory(), ProtocolException, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPFaultException(SOAPFault fault)
      Constructor for SOAPFaultException

    • Method Summary

      Methods
      Modifier and Type Method and Description
      SOAPFault getFault()
      Gets the embedded SOAPFault instance.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SOAPFaultException

        public SOAPFaultException(SOAPFault fault)
        Constructor for SOAPFaultException
        Parameters:
        fault - SOAPFault representing the fault
        See Also:
        SOAPFactory.createFault(java.lang.String, javax.xml.namespace.QName)

    • Method Detail

      • getFault

        public SOAPFault getFault()
        Gets the embedded SOAPFault instance.
        Returns:
        javax.xml.soap.SOAPFault SOAP fault element
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.ws.soap (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.soap

  • Packages that use javax.xml.ws.soap
    Package Description
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
  • Classes in javax.xml.ws.soap used by javax.xml.ws.soap
    Class and Description
    AddressingFeature.Responses
    If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.soap.Addressing (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.Addressing

No usage of javax.xml.ws.soap.Addressing
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.soap.AddressingFeature (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.AddressingFeature

No usage of javax.xml.ws.soap.AddressingFeature
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.soap.AddressingFeature.Responses (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.AddressingFeature.Responses

  • Packages that use AddressingFeature.Responses
    Package Description
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of AddressingFeature.Responses in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return AddressingFeature.Responses
      Modifier and Type Method and Description
      AddressingFeature.Responses AddressingFeature.getResponses()
      If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.
      static AddressingFeature.Responses AddressingFeature.Responses.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AddressingFeature.Responses[] AddressingFeature.Responses.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Constructors in javax.xml.ws.soap with parameters of type AddressingFeature.Responses
      Constructor and Description
      AddressingFeature(boolean enabled, boolean required, AddressingFeature.Responses responses)
      Creates and configures an AddressingFeature with the use of addressing requirements.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.soap.MTOM (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.MTOM

No usage of javax.xml.ws.soap.MTOM
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.soap.MTOMFeature (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.MTOMFeature

No usage of javax.xml.ws.soap.MTOMFeature
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.soap.SOAPFaultException (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.SOAPFaultException

No usage of javax.xml.ws.soap.SOAPFaultException
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface javax.xml.ws.soap.SOAPBinding (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.soap.SOAPBinding

No usage of javax.xml.ws.soap.SOAPBinding
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Invoker (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi

Class Invoker

  • java.lang.Object
    • javax.xml.ws.spi.Invoker

  • public abstract class Invoker
extends Object
    Invoker hides the detail of calling into application endpoint implementation. Container hands over an implementation of Invoker to JAX-WS runtime, and jax-ws runtime calls invoke(java.lang.reflect.Method, java.lang.Object...) for a web service invocation. Finally, Invoker does the actual invocation of web service on endpoint instance. Container also injects the provided WebServiceContext and takes care of invoking javax.annotation.PostConstruct methods, if present, on the endpoint implementation.
    Since:
    JAX-WS 2.2
    Author:
    Jitendra Kotamraju
    See Also:
    Provider.createEndpoint(String, Class, Invoker, WebServiceFeature...)

    • Constructor Summary

      Constructors
      Constructor and Description
      Invoker()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void inject(WebServiceContext webServiceContext)
      JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance.
      abstract Object invoke(Method m, Object... args)
      JAX-WS runtime calls this method to do the actual web service invocation on endpoint instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Invoker

        public Invoker()

    • Method Detail

      • inject

        public abstract void inject(WebServiceContext webServiceContext)
                     throws IllegalAccessException,
                            IllegalArgumentException,
                            InvocationTargetException
        JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance. The WebServiceContext object uses thread-local information to return the correct information during the actual endpoint invocation regardless of how many threads are concurrently being used to serve requests.
        Parameters:
        webServiceContext - a holder for MessageContext
        Throws:
        IllegalAccessException - if the injection done by reflection API throws this exception
        IllegalArgumentException - if the injection done by reflection API throws this exception
        InvocationTargetException - if the injection done by reflection API throws this exception

      • invoke

        public abstract Object invoke(Method m,
            Object... args)
                       throws IllegalAccessException,
                              IllegalArgumentException,
                              InvocationTargetException
        JAX-WS runtime calls this method to do the actual web service invocation on endpoint instance. The injected WebServiceContext.getMessageContext() gives the correct information for this invocation.
        Parameters:
        m - Method to be invoked on the service
        args - Method arguments
        Returns:
        return value of the method
        Throws:
        IllegalAccessException - if the invocation done by reflection API throws this exception
        IllegalArgumentException - if the invocation done by reflection API throws this exception
        InvocationTargetException - if the invocation done by reflection API throws this exception
        See Also:
        Method.invoke(java.lang.Object, java.lang.Object...)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.ws.spi (Java(TM) EE 7 Specification APIs)

javax.xml.ws.spi

Classes

  • Invoker
  • Provider
  • ServiceDelegate

Annotation Types

  • WebServiceFeatureAnnotation


javax.xml.ws.spi (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.spi

This package defines SPIs for JAX-WS.

See: Description

  • Class Summary
    Class Description
    Invoker
    Invoker hides the detail of calling into application endpoint implementation.
    Provider
    Service provider for ServiceDelegate and Endpoint objects.
    ServiceDelegate
    Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.
  • Annotation Types Summary
    Annotation Type Description
    WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.

Package javax.xml.ws.spi Description

This package defines SPIs for JAX-WS.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.ws.spi Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.spi.Invoker
    • javax.xml.ws.spi.Provider
    • javax.xml.ws.spi.ServiceDelegate

Annotation Type Hierarchy

  • javax.xml.ws.spi.WebServiceFeatureAnnotation (implements java.lang.annotation.Annotation)
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Provider (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi

Class Provider

  • java.lang.Object
    • javax.xml.ws.spi.Provider

  • public abstract class Provider
extends Object
    Service provider for ServiceDelegate and Endpoint objects.

    Since:
    JAX-WS 2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String JAXWSPROVIDER_PROPERTY
      A constant representing the property used to lookup the name of a Provider implementation class.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Provider()
      Creates a new instance of Provider

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Endpoint createAndPublishEndpoint(String address, Object implementor)
      Creates and publishes an endpoint object with the specified address and implementation object.
      Endpoint createAndPublishEndpoint(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint object with the specified address, implementation object and web service features.
      Endpoint createEndpoint(String bindingId, Class<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
      abstract Endpoint createEndpoint(String bindingId, Object implementor)
      Creates an endpoint object with the provided binding and implementation object.
      Endpoint createEndpoint(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation object and web service features.
      abstract ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
      abstract W3CEndpointReference createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      abstract <T> T getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      static Provider provider()
      Creates a new provider object.
      abstract EndpointReference readEndpointReference(Source eprInfoset)
      read an EndpointReference from the infoset contained in eprInfoset.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • JAXWSPROVIDER_PROPERTY

        public static final String JAXWSPROVIDER_PROPERTY
        A constant representing the property used to lookup the name of a Provider implementation class.
        See Also:
        Constant Field Values

    • Constructor Detail

      • Provider

        protected Provider()
        Creates a new instance of Provider

    • Method Detail

      • provider

        public static Provider provider()
        Creates a new provider object.

        The algorithm used to locate the provider subclass to use consists of the following steps:

        • If a resource with the name of META-INF/services/javax.xml.ws.spi.Provider exists, then its first line, if present, is used as the UTF-8 encoded name of the implementation class.
        • If the $java.home/lib/jaxws.properties file exists and it is readable by the java.util.Properties.load(InputStream) method and it contains an entry whose key is javax.xml.ws.spi.Provider, then the value of that entry is used as the name of the implementation class.
        • If a system property with the name javax.xml.ws.spi.Provider is defined, then its value is used as the name of the implementation class.
        • Finally, a default implementation class name is used.

      • createServiceDelegate

        public abstract ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation,
                                    QName serviceName,
                                    Class<? extends Service> serviceClass)
        Creates a service delegate object.

        Parameters:
        wsdlDocumentLocation - A URL pointing to the WSDL document for the service, or null if there isn't one.
        serviceName - The qualified name of the service.
        serviceClass - The service class, which MUST be either javax.xml.ws.Service or a subclass thereof.
        Returns:
        The newly created service delegate.

      • createServiceDelegate

        public ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation,
                                    QName serviceName,
                                    Class<? extends Service> serviceClass,
                                    WebServiceFeature... features)
        Creates a service delegate object.

        Parameters:
        wsdlDocumentLocation - A URL pointing to the WSDL document for the service, or null if there isn't one.
        serviceName - The qualified name of the service.
        serviceClass - The service class, which MUST be either javax.xml.ws.Service or a subclass thereof.
        features - Web Service features that must be configured on the service. If the provider doesn't understand a feature, it must throw a WebServiceException.
        Returns:
        The newly created service delegate.
        Since:
        JAX-WS 2.2

      • createEndpoint

        public abstract Endpoint createEndpoint(String bindingId,
                      Object implementor)
        Creates an endpoint object with the provided binding and implementation object.
        Parameters:
        bindingId - A URI specifying the desired binding (e.g. SOAP/HTTP)
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        Returns:
        The newly created endpoint.

      • createAndPublishEndpoint

        public abstract Endpoint createAndPublishEndpoint(String address,
                                Object implementor)
        Creates and publishes an endpoint object with the specified address and implementation object.
        Parameters:
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        Returns:
        The newly created endpoint.

      • readEndpointReference

        public abstract EndpointReference readEndpointReference(Source eprInfoset)
        read an EndpointReference from the infoset contained in eprInfoset.
        Parameters:
        eprInfoset - infoset for EndpointReference
        Returns:
        the EndpointReference unmarshalled from eprInfoset. This method never returns null.
        Throws:
        WebServiceException - If there is an error creating the EndpointReference from the specified eprInfoset.
        NullPointerException - If the null eprInfoset value is given.
        Since:
        JAX-WS 2.1

      • getPort

        public abstract <T> T getPort(EndpointReference endpointReference,
            Class<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. The parameter endpointReference specifies the endpoint that will be invoked by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL metadata of the serviceEndpointInterface and the EndpointReference. For this method to successfully return a proxy, WSDL metadata MUST be available and the endpointReference MUST contain an implementation understood serviceName metadata.
        Parameters:
        endpointReference - the EndpointReference that will be invoked by the returned proxy.
        serviceEndpointInterface - Service endpoint interface
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method}
        • If this endpointReference is illegal
        • If an illegal serviceEndpointInterface is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        WebServiceFeature

      • createW3CEndpointReference

        public abstract W3CEndpointReference createW3CEndpointReference(String address,
                                              QName serviceName,
                                              QName portName,
                                              List<Element> metadata,
                                              String wsdlDocumentLocation,
                                              List<Element> referenceParameters)
        Factory method to create a W3CEndpointReference.

        This method can be used to create a W3CEndpointReference for any endpoint by specifying the address property along with any other desired properties. This method can also be used to create a W3CEndpointReference for an endpoint that is published by the same Java EE application. To do so the address property can be provided or this method can automatically determine the address of an endpoint that is published by the same Java EE application and is identified by the serviceName and portName propeties. If the address is null and the serviceName and portName do not identify an endpoint published by the same Java EE application, a javax.lang.IllegalStateException MUST be thrown.

        Parameters:
        address - Specifies the address of the target endpoint
        serviceName - Qualified name of the service in the WSDL.
        portName - Qualified name of the endpoint in the WSDL.
        metadata - A list of elements that should be added to the W3CEndpointReference instances wsa:metadata element.
        wsdlDocumentLocation - URL for the WSDL document location for the service.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        Returns:
        the W3CEndpointReference created from serviceName, portName, metadata, wsdlDocumentLocation and referenceParameters. This method never returns null.
        Throws:
        IllegalStateException -
        • If the address, serviceName and portName are all null.
        • If the serviceName service is null and the portName is NOT null.
        • If the address property is null and the serviceName and portName do not specify a valid endpoint published by the same Java EE application.
        • If the serviceNameis NOT null and is not present in the specified WSDL.
        • If the portName port is not null and it is not present in serviceName service in the WSDL.
        • If the wsdlDocumentLocation is NOT null and does not represent a valid WSDL.
        WebServiceException - If an error occurs while creating the W3CEndpointReference.
        Since:
        JAX-WS 2.1

      • createW3CEndpointReference

        public W3CEndpointReference createW3CEndpointReference(String address,
                                              QName interfaceName,
                                              QName serviceName,
                                              QName portName,
                                              List<Element> metadata,
                                              String wsdlDocumentLocation,
                                              List<Element> referenceParameters,
                                              List<Element> elements,
                                              Map<QName,String> attributes)
        Factory method to create a W3CEndpointReference. Using this method, a W3CEndpointReference instance can be created with extension elements, and attributes. Provider implementations must override the default implementation.

        This method can be used to create a W3CEndpointReference for any endpoint by specifying the address property along with any other desired properties. This method can also be used to create a W3CEndpointReference for an endpoint that is published by the same Java EE application. To do so the address property can be provided or this method can automatically determine the address of an endpoint that is published by the same Java EE application and is identified by the serviceName and portName propeties. If the address is null and the serviceName and portName do not identify an endpoint published by the same Java EE application, a javax.lang.IllegalStateException MUST be thrown.

        Parameters:
        address - Specifies the address of the target endpoint
        interfaceName - the wsam:InterfaceName element in the wsa:Metadata element.
        serviceName - Qualified name of the service in the WSDL.
        portName - Qualified name of the endpoint in the WSDL.
        metadata - A list of elements that should be added to the W3CEndpointReference instances wsa:metadata element.
        wsdlDocumentLocation - URL for the WSDL document location for the service.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        elements - extension elements to be associated with the returned EndpointReference instance.
        attributes - extension attributes to be associated with the returned EndpointReference instance.
        Returns:
        the W3CEndpointReference created from serviceName, portName, metadata, wsdlDocumentLocation and referenceParameters. This method never returns null.
        Throws:
        IllegalStateException -
        • If the address, serviceName and portName are all null.
        • If the serviceName service is null and the portName is NOT null.
        • If the address property is null and the serviceName and portName do not specify a valid endpoint published by the same Java EE application.
        • If the serviceNameis NOT null and is not present in the specified WSDL.
        • If the portName port is not null and it is not present in serviceName service in the WSDL.
        • If the wsdlDocumentLocation is NOT null and does not represent a valid WSDL.
        • If the wsdlDocumentLocation is NOT null but wsdli:wsdlLocation's namespace name cannot be got from the available metadata.
        WebServiceException - If an error occurs while creating the W3CEndpointReference.
        Since:
        JAX-WS 2.2

      • createAndPublishEndpoint

        public Endpoint createAndPublishEndpoint(String address,
                                Object implementor,
                                WebServiceFeature... features)
        Creates and publishes an endpoint object with the specified address, implementation object and web service features. Provider implementations must override the default implementation.
        Parameters:
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        features - A list of WebServiceFeatures to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Since:
        JAX-WS 2.2

      • createEndpoint

        public Endpoint createEndpoint(String bindingId,
                      Object implementor,
                      WebServiceFeature... features)
        Creates an endpoint object with the provided binding, implementation object and web service features. Provider implementations must override the default implementation.
        Parameters:
        bindingId - A URI specifying the desired binding (e.g. SOAP/HTTP)
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        features - A list of WebServiceFeatures to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Since:
        JAX-WS 2.2

      • createEndpoint

        public Endpoint createEndpoint(String bindingId,
                      Class<?> implementorClass,
                      Invoker invoker,
                      WebServiceFeature... features)
        Creates an endpoint object with the provided binding, implementation class, invoker and web service features. Containers typically use this to create Endpoint objects. Provider implementations must override the default implementation.
        Parameters:
        bindingId - A URI specifying the desired binding (e.g. SOAP/HTTP). Can be null.
        implementorClass - A service implementation class that MUST be annotated with all the necessary Web service annotations.
        invoker - that does the actual invocation on the service instance.
        features - A list of WebServiceFeatures to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Since:
        JAX-WS 2.2
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceDelegate (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi

Class ServiceDelegate

  • java.lang.Object
    • javax.xml.ws.spi.ServiceDelegate

  • public abstract class ServiceDelegate
extends Object
    Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.

    Every Service object has its own delegate, created using the Provider.createServiceDelegate(java.net.URL, javax.xml.namespace.QName, java.lang.Class<? extends javax.xml.ws.Service>) method. A Service object delegates all of its instance methods to its delegate.

    Since:
    JAX-WS 2.0
    See Also:
    Service, Provider

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | ServiceDelegate()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addPort(QName portName, String bindingId, String endpointAddress)
      Creates a new port for the service.
      abstract <T> Dispatch<T> createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Executor getExecutor()
      Returns the executor for this Serviceinstance.
      abstract HandlerResolver getHandlerResolver()
      Returns the configured handler resolver.
      abstract <T> T getPort(Class<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      abstract <T> T getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T getPort(QName portName, Class<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      abstract <T> T getPort(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract Iterator<QName> getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      abstract QName getServiceName()
      Gets the name of this service.
      abstract URL getWSDLDocumentLocation()
      Gets the location of the WSDL document for this Service.
      abstract void setExecutor(Executor executor)
      Sets the executor for this Service instance.
      abstract void setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServiceDelegate

        protected ServiceDelegate()

    • Method Detail

      • getPort

        public abstract <T> T getPort(QName portName,
            Class<T> serviceEndpointInterface)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        Parameters:
        portName - Qualified name of the service endpoint in the WSDL service description
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy
        Returns:
        Object Proxy instance that supports the specified service endpoint interface
        Throws:
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface or portName is specified
        See Also:
        Proxy, InvocationHandler

      • getPort

        public abstract <T> T getPort(QName portName,
            Class<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        Parameters:
        portName - Qualified name of the service endpoint in the WSDL service description
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy or instance
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface
        Throws:
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface or portName is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Proxy, InvocationHandler, WebServiceFeature

      • getPort

        public abstract <T> T getPort(EndpointReference endpointReference,
            Class<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. The parameter endpointReference specifies the endpoint that will be invoked by the returned proxy. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference metadata also has a WSDL, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. The returned proxy should not be reconfigured by the client. If this Service instance has a known proxy port that matches the information contained in the WSDL, then that proxy is returned, otherwise a WebServiceException is thrown.

        Calling this method has the same behavior as the following

         port = service.getPort(portName, serviceEndpointInterface);
        where the portName is retrieved from the metadata of the endpointReference or from the serviceEndpointInterface and the WSDL associated with this Service instance.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned proxy.
        serviceEndpointInterface - Service endpoint interface.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName of this Service instance.
        • If a portName cannot be extracted from the WSDL or endpointReference metadata.
        • If an invalid endpointReference is specified.
        • If an invalid serviceEndpointInterface is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1

      • getPort

        public abstract <T> T getPort(Class<T> serviceEndpointInterface)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        Parameters:
        serviceEndpointInterface - Service endpoint interface
        Returns:
        Object instance that supports the specified service endpoint interface
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface is specified

      • getPort

        public abstract <T> T getPort(Class<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        Parameters:
        serviceEndpointInterface - Service endpoint interface
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object instance that supports the specified service endpoint interface
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        WebServiceFeature

      • addPort

        public abstract void addPort(QName portName,
           String bindingId,
           String endpointAddress)
        Creates a new port for the service. Ports created in this way contain no WSDL port type information and can only be used for creating Dispatchinstances.
        Parameters:
        portName - Qualified name for the target service endpoint
        bindingId - A URI identifier of a binding.
        endpointAddress - Address of the target service endpoint as a URI
        Throws:
        WebServiceException - If any error in the creation of the port
        See Also:
        SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING

      • createDispatch

        public abstract <T> Dispatch<T> createDispatch(QName portName,
                             Class<T> type,
                             Service.Mode mode)
        Creates a Dispatch instance for use with objects of the user's choosing.
        Parameters:
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object
        See Also:
        Source, SOAPMessage

      • createDispatch

        public abstract <T> Dispatch<T> createDispatch(QName portName,
                             Class<T> type,
                             Service.Mode mode,
                             WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the user's choosing.
        Parameters:
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public abstract <T> Dispatch<T> createDispatch(EndpointReference endpointReference,
                             Class<T> type,
                             Service.Mode mode,
                             WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the user's choosing. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behaves the same as calling

         dispatch = service.createDispatch(portName, type, mode, features);
        where the portName is retrieved from the WSDL or EndpointReference metadata.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        type - The class of object used to messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public abstract Dispatch<Object> createDispatch(QName portName,
                              JAXBContext context,
                              Service.Mode mode)
        Creates a Dispatch instance for use with JAXB generated objects.
        Parameters:
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object
        See Also:
        JAXBContext

      • createDispatch

        public abstract Dispatch<Object> createDispatch(QName portName,
                              JAXBContext context,
                              Service.Mode mode,
                              WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects.
        Parameters:
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        JAXBContext, WebServiceFeature

      • createDispatch

        public abstract Dispatch<Object> createDispatch(EndpointReference endpointReference,
                              JAXBContext context,
                              Service.Mode mode,
                              WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behavies the same as calling

         dispatch = service.createDispatch(portName, context, mode, features);
        where the portName is retrieved from the WSDL or endpointReference metadata.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        JAXBContext, WebServiceFeature

      • getServiceName

        public abstract QName getServiceName()
        Gets the name of this service.
        Returns:
        Qualified name of this service

      • getPorts

        public abstract Iterator<QName> getPorts()
        Returns an Iterator for the list of QNames of service endpoints grouped by this service
        Returns:
        Returns java.util.Iterator with elements of type javax.xml.namespace.QName
        Throws:
        WebServiceException - If this Service class does not have access to the required WSDL metadata

      • getWSDLDocumentLocation

        public abstract URL getWSDLDocumentLocation()
        Gets the location of the WSDL document for this Service.
        Returns:
        URL for the location of the WSDL document for this service

      • getHandlerResolver

        public abstract HandlerResolver getHandlerResolver()
        Returns the configured handler resolver.
        Returns:
        HandlerResolver The HandlerResolver being used by this Service instance, or null if there isn't one.

      • setHandlerResolver

        public abstract void setHandlerResolver(HandlerResolver handlerResolver)
        Sets the HandlerResolver for this Service instance.

        The handler resolver, if present, will be called once for each proxy or dispatch instance that is created, and the handler chain returned by the resolver will be set on the instance.

        Parameters:
        handlerResolver - The HandlerResolver to use for all subsequently created proxy/dispatch objects.
        See Also:
        HandlerResolver

      • getExecutor

        public abstract Executor getExecutor()
        Returns the executor for this Serviceinstance. The executor is used for all asynchronous invocations that require callbacks.
        Returns:
        The java.util.concurrent.Executor to be used to invoke a callback.
        See Also:
        Executor

      • setExecutor

        public abstract void setExecutor(Executor executor)
        Sets the executor for this Service instance. The executor is used for all asynchronous invocations that require callbacks.
        Parameters:
        executor - The java.util.concurrent.Executor to be used to invoke a callback.
        Throws:
        SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
        See Also:
        Executor
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Package javax.xml.ws.spi (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.spi

  • Packages that use javax.xml.ws.spi
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
  • Classes in javax.xml.ws.spi used by javax.xml.ws
    Class and Description
    WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.
  • Classes in javax.xml.ws.spi used by javax.xml.ws.soap
    Class and Description
    WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.
  • Classes in javax.xml.ws.spi used by javax.xml.ws.spi
    Class and Description
    Invoker
    Invoker hides the detail of calling into application endpoint implementation.
    Provider
    Service provider for ServiceDelegate and Endpoint objects.
    ServiceDelegate
    Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


WebServiceFeatureAnnotation (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element
javax.xml.ws.spi

Annotation Type WebServiceFeatureAnnotation

  • @Target(value=ANNOTATION_TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.

    Each WebServiceFeature annotation annotated with this annotation MUST contain an enabled property of type boolean with a default value of true.

    JAX-WS defines the following WebServiceFeature annotations (Addressing, MTOM, RespectBinding), however, an implementation may define vendors specific annotations for other features.

    Annotations annotated with WebServiceFeatureAnnotation MUST have the same @Target of WebServiceRef annotation, so that the resulting feature annotation can be used in conjunction with the WebServiceRef annotation if necessary.

    If a JAX-WS implementation encounters an annotation annotated with the WebServiceFeatureAnnotation that it does not recognize/support an error MUST be given.

    Since:
    JAX-WS 2.1
    See Also:
    Addressing, MTOM, RespectBinding

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<? extends WebServiceFeature> bean
      The WebServiceFeature bean that is associated with the WebServiceFeature annotation
      String id
      Unique identifier for the WebServiceFeature.

    • Element Detail

      • id

        public abstract String id
        Unique identifier for the WebServiceFeature. This identifier MUST be unique across all implementations of JAX-WS.

      • bean

        public abstract Class<? extends WebServiceFeature> bean
        The WebServiceFeature bean that is associated with the WebServiceFeature annotation
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Required |
  • Optional
  • Detail:
  • Element


Uses of Class javax.xml.ws.spi.Invoker (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.Invoker

  • Packages that use Invoker
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Invoker in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type Invoker
      Modifier and Type Method and Description
      Endpoint Provider.createEndpoint(String bindingId, Class<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.spi.Provider (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.Provider

  • Packages that use Provider
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Provider in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Provider
      Modifier and Type Method and Description
      static Provider Provider.provider()
      Creates a new provider object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.spi.ServiceDelegate (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.ServiceDelegate

  • Packages that use ServiceDelegate
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of ServiceDelegate in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return ServiceDelegate
      Modifier and Type Method and Description
      abstract ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.spi.WebServiceFeatureAnnotation (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.WebServiceFeatureAnnotation

  • Packages that use WebServiceFeatureAnnotation
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of WebServiceFeatureAnnotation in javax.xml.ws

      Classes in javax.xml.ws with annotations of type WebServiceFeatureAnnotation
      Modifier and Type Class and Description
      interface  RespectBinding
      This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.

    • Uses of WebServiceFeatureAnnotation in javax.xml.ws.soap

      Classes in javax.xml.ws.soap with annotations of type WebServiceFeatureAnnotation
      Modifier and Type Class and Description
      interface  Addressing
      This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
      interface  MTOM
      This feature represents the use of MTOM with a web service.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


HttpContext (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi.http

Class HttpContext

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpContext

  • public abstract class HttpContext
extends Object
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.

    Container provides the implementation for this and it matches web service requests to corresponding HttpContext objects.

    Since:
    JAX-WS 2.2
    Author:
    Jitendra Kotamraju

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected HttpHandler | handler

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpContext()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract Object getAttribute(String name)
      Returns an attribute value for container's configuration and other data that can be used by jax-ws runtime.
      abstract Set<String> getAttributeNames()
      Returns all attribute names for container's configuration and other data that can be used by jax-ws runtime.
      abstract String getPath()
      Returns the path for this context.
      void setHandler(HttpHandler handler)
      JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • handler

        protected HttpHandler handler

    • Constructor Detail

      • HttpContext

        public HttpContext()

    • Method Detail

      • setHandler

        public void setHandler(HttpHandler handler)
        JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context. Container or its extensions use this handler to process the requests.
        Parameters:
        handler - the handler to set for this context

      • getPath

        public abstract String getPath()
        Returns the path for this context. This path uniquely identifies an endpoint inside an application and the path is relative to application's context path. Container should give this path based on how it matches request URIs to this HttpContext object.

        For servlet container, this is typically a url-pattern for an endpoint.

        Endpoint's address for this context can be computed as follows:

          HttpExchange exch = ...;
  String endpointAddress =
      exch.getScheme() + "://"
      + exch.getLocalAddress().getHostName()
      + ":" + exch.getLocalAddress().getPort()
      + exch.getContextPath() + getPath();
        Returns:
        this context's path

      • getAttribute

        public abstract Object getAttribute(String name)
        Returns an attribute value for container's configuration and other data that can be used by jax-ws runtime.
        Parameters:
        name - attribute name
        Returns:
        attribute value

      • getAttributeNames

        public abstract Set<String> getAttributeNames()
        Returns all attribute names for container's configuration and other data that can be used by jax-ws runtime.
        Returns:
        set of all attribute names
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpExchange (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi.http

Class HttpExchange

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpExchange

  • public abstract class HttpExchange
extends Object
    This class encapsulates a HTTP request received and a response to be generated in one exchange. It provides methods for examining the request from the client, and for building and sending the response.

    A HttpExchange must be closed to free or reuse underlying resources. The effect of failing to close an exchange is undefined.

    Since:
    JAX-WS 2.2
    Author:
    Jitendra Kotamraju

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String REQUEST_CIPHER_SUITE
      Standard property: cipher suite value when the request is received over HTTPS
      static String REQUEST_KEY_SIZE
      Standard property: bit size of the algorithm when the request is received over HTTPS
      static String REQUEST_X509CERTIFICATE
      Standard property: A SSL certificate, if any, associated with the request

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpExchange()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void addResponseHeader(String name, String value)
      Adds a response header with the given name and value.
      abstract void close()
      This must be called to end an exchange.
      abstract Object getAttribute(String name)
      Returns an attribute that is associated with this HttpExchange.
      abstract Set<String> getAttributeNames()
      Gives all the attribute names that are associated with this HttpExchange.
      abstract String getContextPath()
      Returns the context path of all the endpoints in an application.
      abstract HttpContext getHttpContext()
      Returns a HttpContext for this exchange.
      abstract InetSocketAddress getLocalAddress()
      Returns the unresolved local address on which the request was received.
      abstract String getPathInfo()
      Returns the extra path information that follows the web service path but precedes the query string in the request URI and will start with a "/" character.
      abstract String getProtocol()
      Returns the protocol string from the request in the form protocol/majorVersion.minorVersion.
      abstract String getQueryString()
      Returns the query string that is contained in the request URI after the path.
      abstract InetSocketAddress getRemoteAddress()
      Returns the unresolved address of the remote entity invoking this request.
      abstract InputStream getRequestBody()
      Returns a stream from which the request body can be read.
      abstract String getRequestHeader(String name)
      Returns the value of the specified request header.
      abstract Map<String,List<String>> getRequestHeaders()
      Returns an immutable Map containing the HTTP headers that were included with this request.
      abstract String getRequestMethod()
      Get the HTTP request method
      abstract String getRequestURI()
      Returns the part of the request's URI from the protocol name up to the query string in the first line of the HTTP request.
      abstract OutputStream getResponseBody()
      Returns a stream to which the response body must be written.
      abstract Map<String,List<String>> getResponseHeaders()
      Returns a mutable Map into which the HTTP response headers can be stored and which will be transmitted as part of this response.
      abstract String getScheme()
      Returns the name of the scheme used to make this request, for example: http, or https.
      abstract Principal getUserPrincipal()
      Returns the Principal that represents the authenticated user for this HttpExchange.
      abstract boolean isUserInRole(String role)
      Indicates whether an authenticated user is included in the specified logical "role".
      abstract void setStatus(int status)
      Sets the HTTP status code for the response.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • REQUEST_CIPHER_SUITE

        public static final String REQUEST_CIPHER_SUITE
        Standard property: cipher suite value when the request is received over HTTPS

        Type: String

        See Also:
        Constant Field Values

      • REQUEST_KEY_SIZE

        public static final String REQUEST_KEY_SIZE
        Standard property: bit size of the algorithm when the request is received over HTTPS

        Type: Integer

        See Also:
        Constant Field Values

      • REQUEST_X509CERTIFICATE

        public static final String REQUEST_X509CERTIFICATE
        Standard property: A SSL certificate, if any, associated with the request

        Type: java.security.cert.X509Certificate[] The order of this array is defined as being in ascending order of trust. The first certificate in the chain is the one set by the client, the next is the one used to authenticate the first, and so on.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HttpExchange

        public HttpExchange()

    • Method Detail

      • getRequestHeaders

        public abstract Map<String,List<String>> getRequestHeaders()
        Returns an immutable Map containing the HTTP headers that were included with this request. The keys in this Map will be the header names, while the values will be a List of Strings containing each value that was included (either for a header that was listed several times, or one that accepts a comma-delimited list of values on a single line). In either of these cases, the values for the header name will be presented in the order that they were included in the request.

        The keys in Map are case-insensitive.

        Returns:
        an immutable Map which can be used to access request headers

      • getRequestHeader

        public abstract String getRequestHeader(String name)
        Returns the value of the specified request header. If the request did not include a header of the specified name, this method returns null. If there are multiple headers with the same name, this method returns the first header in the request. The header name is case-insensitive. This is a convienence method to get a header (instead of using the getRequestHeaders()).
        Parameters:
        name - the name of the request header
        Returns:
        returns the value of the requested header, or null if the request does not have a header of that name

      • getResponseHeaders

        public abstract Map<String,List<String>> getResponseHeaders()
        Returns a mutable Map into which the HTTP response headers can be stored and which will be transmitted as part of this response. The keys in the Map will be the header names, while the values must be a List of Strings containing each value that should be included multiple times (in the order that they should be included).

        The keys in Map are case-insensitive.

        Returns:
        a mutable Map which can be used to set response headers.

      • addResponseHeader

        public abstract void addResponseHeader(String name,
                     String value)
        Adds a response header with the given name and value. This method allows a response header to have multiple values. This is a convenience method to add a response header(instead of using the getResponseHeaders()).
        Parameters:
        name - the name of the header
        value - the additional header value. If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
        See Also:
        getResponseHeaders()

      • getRequestURI

        public abstract String getRequestURI()
        Returns the part of the request's URI from the protocol name up to the query string in the first line of the HTTP request. Container doesn't decode this string.
        Returns:
        the request URI

      • getContextPath

        public abstract String getContextPath()
        Returns the context path of all the endpoints in an application. This path is the portion of the request URI that indicates the context of the request. The context path always comes first in a request URI. The path starts with a "/" character but does not end with a "/" character. If this method returns "", the request is for default context. The container does not decode this string.

        Context path is used in computing the endpoint address. See HttpContext.getPath()

        Returns:
        context path of all the endpoints in an application
        See Also:
        HttpContext.getPath()

      • getRequestMethod

        public abstract String getRequestMethod()
        Get the HTTP request method
        Returns:
        the request method

      • getHttpContext

        public abstract HttpContext getHttpContext()
        Returns a HttpContext for this exchange. Container matches the request with the associated Endpoint's HttpContext
        Returns:
        the HttpContext for this exchange

      • close

        public abstract void close()
                    throws IOException
        This must be called to end an exchange. Container takes care of closing request and response streams. This must be called so that the container can free or reuse underlying resources.
        Throws:
        IOException - if any i/o error

      • getRequestBody

        public abstract InputStream getRequestBody()
                                    throws IOException
        Returns a stream from which the request body can be read. Multiple calls to this method will return the same stream.
        Returns:
        the stream from which the request body can be read.
        Throws:
        IOException - if any i/o error during request processing

      • getResponseBody

        public abstract OutputStream getResponseBody()
                                      throws IOException
        Returns a stream to which the response body must be written. setStatus(int)) must be called prior to calling this method. Multiple calls to this method (for the same exchange) will return the same stream.
        Returns:
        the stream to which the response body is written
        Throws:
        IOException - if any i/o error during response processing

      • setStatus

        public abstract void setStatus(int status)
        Sets the HTTP status code for the response.

        This method must be called prior to calling getResponseBody().

        Parameters:
        status - the response code to send
        See Also:
        getResponseBody()

      • getRemoteAddress

        public abstract InetSocketAddress getRemoteAddress()
        Returns the unresolved address of the remote entity invoking this request.
        Returns:
        the InetSocketAddress of the caller

      • getLocalAddress

        public abstract InetSocketAddress getLocalAddress()
        Returns the unresolved local address on which the request was received.
        Returns:
        the InetSocketAddress of the local interface

      • getProtocol

        public abstract String getProtocol()
        Returns the protocol string from the request in the form protocol/majorVersion.minorVersion. For example, "HTTP/1.1"
        Returns:
        the protocol string from the request

      • getScheme

        public abstract String getScheme()
        Returns the name of the scheme used to make this request, for example: http, or https.
        Returns:
        name of the scheme used to make this request

      • getPathInfo

        public abstract String getPathInfo()
        Returns the extra path information that follows the web service path but precedes the query string in the request URI and will start with a "/" character.

        This can be used for MessageContext.PATH_INFO

        Returns:
        decoded extra path information of web service. It is the path that comes after the web service path but before the query string in the request URI null if there is no extra path in the request URI

      • getQueryString

        public abstract String getQueryString()
        Returns the query string that is contained in the request URI after the path.

        This can be used for MessageContext.QUERY_STRING

        Returns:
        undecoded query string of request URI, or null if the request URI doesn't have one

      • getAttribute

        public abstract Object getAttribute(String name)
        Returns an attribute that is associated with this HttpExchange. JAX-WS handlers and endpoints may then access the attribute via MessageContext.

        Servlet containers must expose MessageContext.SERVLET_CONTEXT, MessageContext.SERVLET_REQUEST, and MessageContext.SERVLET_RESPONSE as attributes.

        If the request has been received by the container using HTTPS, the following information must be exposed as attributes. These attributes are REQUEST_CIPHER_SUITE, and REQUEST_KEY_SIZE. If there is a SSL certificate associated with the request, it must be exposed using REQUEST_X509CERTIFICATE

        Parameters:
        name - attribute name
        Returns:
        the attribute value, or null if the attribute doesn't exist

      • getAttributeNames

        public abstract Set<String> getAttributeNames()
        Gives all the attribute names that are associated with this HttpExchange.
        Returns:
        set of all attribute names
        See Also:
        getAttribute(String)

      • getUserPrincipal

        public abstract Principal getUserPrincipal()
        Returns the Principal that represents the authenticated user for this HttpExchange.
        Returns:
        Principal for an authenticated user, or null if not authenticated

      • isUserInRole

        public abstract boolean isUserInRole(String role)
        Indicates whether an authenticated user is included in the specified logical "role".
        Parameters:
        role - specifies the name of the role
        Returns:
        true if the user making this request belongs to a given role
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HttpHandler (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi.http

Class HttpHandler

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpHandler

  • public abstract class HttpHandler
extends Object
    A handler which is invoked to process HTTP requests.

    JAX-WS runtime provides the implementation for this and sets it using HttpContext.setHandler(HttpHandler) during Endpoint.publish(HttpContext)

    Since:
    JAX-WS 2.2
    Author:
    Jitendra Kotamraju

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpHandler()

    • Method Summary

      Methods
      Modifier and Type Method and Description
      abstract void handle(HttpExchange exchange)
      Handles a given request and generates an appropriate response.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HttpHandler

        public HttpHandler()

    • Method Detail

      • handle

        public abstract void handle(HttpExchange exchange)
                     throws IOException
        Handles a given request and generates an appropriate response. See HttpExchange for a description of the steps involved in handling an exchange. Container invokes this method when it receives an incoming request.
        Parameters:
        exchange - the exchange containing the request from the client and used to send the response
        Throws:
        IOException - when an I/O error happens during request handling
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


javax.xml.ws.spi.http (Java(TM) EE 7 Specification APIs)

javax.xml.ws.spi.http

Classes

  • HttpContext
  • HttpExchange
  • HttpHandler


javax.xml.ws.spi.http (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.spi.http

Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

See: Description

  • Class Summary
    Class Description
    HttpContext
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
    HttpExchange
    This class encapsulates a HTTP request received and a response to be generated in one exchange.
    HttpHandler
    A handler which is invoked to process HTTP requests.

Package javax.xml.ws.spi.http Description

Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g. servlet containers). This SPI is not for end developers but provides a way for the container developers to deploy JAX-WS services portably.

The portable deployment is done as below:

  1. Container creates Endpoint objects for an application. The necessary information to create Endpoint objects may be got from web service deployment descriptor files.
  2. Container needs to create HttpContext objects for the deployment. For example, a HttpContext could be created using servlet configuration(for e.g url-pattern) for the web service in servlet container case.
  3. Then publishes all the endpoints using Endpoint.publish(HttpContext). During publish(), JAX-WS runtime registers a HttpHandler callback to handle incoming requests or HttpExchange objects. The HttpExchange object encapsulates a HTTP request and a response.
  Container                               JAX-WS runtime
  ---------                               --------------
  1. Creates Invoker1, ... InvokerN
  2. Provider.createEndpoint(...)     --> 3. creates Endpoint1
     configures Endpoint1
     ...
  4. Provider.createEndpoint(...)     --> 5. creates EndpointN
     configures EndpointN
  6. Creates ApplicationContext
  7. creates HttpContext1, ... HttpContextN
  8. Endpoint1.publish(HttpContext1)  --> 9. creates HttpHandler1
                                          HttpContext1.setHandler(HttpHandler1)
     ...
 10. EndpointN.publish(HttpContextN)  --> 11. creates HttpHandlerN
                                         HttpContextN.setHandler(HttpHandlerN)
The request processing is done as below(for every request):
  Container                               JAX-WS runtime
  ---------                               --------------
  1. Creates a HttpExchange
  2. Gets handler from HttpContext
  3. HttpHandler.handle(HttpExchange) --> 4. reads request from HttpExchange
                                      <-- 5. Calls Invoker
  6. Invokes the actual instance
                                          7. Writes the response to HttpExchange

The portable undeployment is done as below:

  Container
  ---------
  1. @preDestroy on instances
  2. Endpoint1.stop()
  ...
  3. EndpointN.stop()
Since:
JAX-WS 2.2
Author:
Jitendra Kotamraju
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.ws.spi.http Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.spi.http

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpContext
    • javax.xml.ws.spi.http.HttpExchange
    • javax.xml.ws.spi.http.HttpHandler
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.xml.ws.spi.http (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.spi.http

  • Packages that use javax.xml.ws.spi.http
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.
  • Classes in javax.xml.ws.spi.http used by javax.xml.ws
    Class and Description
    HttpContext
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
  • Classes in javax.xml.ws.spi.http used by javax.xml.ws.spi.http
    Class and Description
    HttpContext
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
    HttpExchange
    This class encapsulates a HTTP request received and a response to be generated in one exchange.
    HttpHandler
    A handler which is invoked to process HTTP requests.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.spi.http.HttpContext (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.http.HttpContext

  • Packages that use HttpContext
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

    • Uses of HttpContext in javax.xml.ws

      Methods in javax.xml.ws with parameters of type HttpContext
      Modifier and Type Method and Description
      void Endpoint.publish(HttpContext serverContext)
      Publishes this endpoint at the provided server context.

    • Uses of HttpContext in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that return HttpContext
      Modifier and Type Method and Description
      abstract HttpContext HttpExchange.getHttpContext()
      Returns a HttpContext for this exchange.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.spi.http.HttpExchange (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.http.HttpExchange

  • Packages that use HttpExchange
    Package Description
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

    • Uses of HttpExchange in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http with parameters of type HttpExchange
      Modifier and Type Method and Description
      abstract void HttpHandler.handle(HttpExchange exchange)
      Handles a given request and generates an appropriate response.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.spi.http.HttpHandler (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.http.HttpHandler

  • Packages that use HttpHandler
    Package Description
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

    • Uses of HttpHandler in javax.xml.ws.spi.http

      Fields in javax.xml.ws.spi.http declared as HttpHandler
      Modifier and Type | Field and Description
      protected HttpHandler | HttpContext.handler
      Methods in javax.xml.ws.spi.http with parameters of type HttpHandler
      Modifier and Type Method and Description
      void HttpContext.setHandler(HttpHandler handler)
      JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


javax.xml.ws.wsaddressing (Java(TM) EE 7 Specification APIs)

javax.xml.ws.wsaddressing

Classes

  • W3CEndpointReference
  • W3CEndpointReferenceBuilder


javax.xml.ws.wsaddressing (Java(TM) EE 7 Specification APIs)

  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.wsaddressing

This package defines APIs related to WS-Addressing.

See: Description

  • Class Summary
    Class Description
    W3CEndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
    W3CEndpointReferenceBuilder
    This class is used to build W3CEndpointReference instances.

Package javax.xml.ws.wsaddressing Description

This package defines APIs related to WS-Addressing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Package
  • Next Package
  • Frames
  • No Frames


javax.xml.ws.wsaddressing Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.wsaddressing

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.EndpointReference
      • javax.xml.ws.wsaddressing.W3CEndpointReference
    • javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package javax.xml.ws.wsaddressing (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.wsaddressing

  • Packages that use javax.xml.ws.wsaddressing
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.ws.wsaddressing used by javax.xml.ws.spi
    Class and Description
    W3CEndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
  • Classes in javax.xml.ws.wsaddressing used by javax.xml.ws.wsaddressing
    Class and Description
    W3CEndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
    W3CEndpointReferenceBuilder
    This class is used to build W3CEndpointReference instances.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


W3CEndpointReference (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.wsaddressing

Class W3CEndpointReference

  • java.lang.Object
    • javax.xml.ws.EndpointReference
      • javax.xml.ws.wsaddressing.W3CEndpointReference

  • public final class W3CEndpointReference
extends EndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.

    Developers should use this class in their SEIs if they want to pass/return endpoint references that represent the W3C WS-Addressing recommendation.

    JAXB will use the JAXB annotations and bind this class to XML infoset that is consistent with that defined by WS-Addressing. See WS-Addressing for more information on WS-Addressing EndpointReferences.

    Since:
    JAX-WS 2.1

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected static String | NS

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | W3CEndpointReference()
        W3CEndpointReference(Source source)
      Creates an EPR from infoset representation

    • Method Summary

      Methods
      Modifier and Type Method and Description
      void writeTo(Result result)
      write this EndpointReference to the specified infoset format

      • Methods inherited from class javax.xml.ws.EndpointReference

        getPort, readFrom, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • NS

        protected static final String NS
        See Also:
        Constant Field Values

    • Constructor Detail

      • W3CEndpointReference

        protected W3CEndpointReference()

      • W3CEndpointReference

        public W3CEndpointReference(Source source)
        Creates an EPR from infoset representation
        Parameters:
        source - A source object containing valid XmlInfoset instance consistent with the W3C WS-Addressing Core recommendation.
        Throws:
        WebServiceException - If the source does NOT contain a valid W3C WS-Addressing EndpointReference.
        NullPointerException - If the null source value is given

    • Method Detail

      • writeTo

        public void writeTo(Result result)
        write this EndpointReference to the specified infoset format
        Specified by:
        writeTo in class EndpointReference
        Parameters:
        result - for writing infoset
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


W3CEndpointReferenceBuilder (Java(TM) EE 7 Specification APIs)

  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.wsaddressing

Class W3CEndpointReferenceBuilder

  • java.lang.Object
    • javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

  • public final class W3CEndpointReferenceBuilder
extends Object
    This class is used to build W3CEndpointReference instances. The intended use of this clsss is for an application component, for example a factory component, to create an W3CEndpointReference for a web service endpoint published by the same Java EE application. It can also be used to create W3CEndpointReferences for an Java SE based endpoint by providing the address property.

    When creating a W3CEndpointReference for an endpoint that is not published by the same Java EE application, the address property MUST be specified.

    When creating a W3CEndpointReference for an endpoint published by the same Java EE application, the address property MAY be null but then the serviceName and endpointName MUST specify an endpoint published by the same Java EE application.

    When the wsdlDocumentLocation is specified it MUST refer to a valid WSDL document and the serviceName and endpointName (if specified) MUST match a service and port in the WSDL document.

    Since:
    JAX-WS 2.1

    • Constructor Summary

      Constructors
      Constructor and Description
      W3CEndpointReferenceBuilder()
      Creates a new W3CEndpointReferenceBuilder instance.

    • Method Summary

      Methods
      Modifier and Type Method and Description
      W3CEndpointReferenceBuilder address(String address)
      Sets the address to the W3CEndpointReference instance's wsa:Address.
      W3CEndpointReferenceBuilder attribute(QName name, String value)
      Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReference build()
      Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.
      W3CEndpointReferenceBuilder element(Element element)
      Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder endpointName(QName endpointName)
      Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
      W3CEndpointReferenceBuilder interfaceName(QName interfaceName)
      Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder metadata(Element metadataElement)
      Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
      W3CEndpointReferenceBuilder referenceParameter(Element referenceParameter)
      Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.
      W3CEndpointReferenceBuilder serviceName(QName serviceName)
      Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder wsdlDocumentLocation(String wsdlDocumentLocation)
      Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • W3CEndpointReferenceBuilder

        public W3CEndpointReferenceBuilder()
        Creates a new W3CEndpointReferenceBuilder instance.

    • Method Detail

      • address

        public W3CEndpointReferenceBuilder address(String address)
        Sets the address to the W3CEndpointReference instance's wsa:Address.

        The address MUST be set to a non-null value when building a W3CEndpointReference for a web service endpoint that is not published by the same Java EE application or when running on Java SE.

        Parameters:
        address - The address of the endpoint to be targeted by the returned W3CEndpointReference.
        Returns:
        A W3CEndpointReferenceBuilder instance with the address set to the wsa:Address.

      • interfaceName

        public W3CEndpointReferenceBuilder interfaceName(QName interfaceName)
        Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element. See 2.1 Referencing WSDL Metadata from an EPR for more details.
        Parameters:
        interfaceName - The port type name of the endpoint to be targeted by the returned W3CEndpointReference.
        Returns:
        A W3CEndpointReferenceBuilder instance with the interfaceName as wsam:InterfaceName element added to the wsa:Metadata element

      • serviceName

        public W3CEndpointReferenceBuilder serviceName(QName serviceName)
        Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element. See 2.1 Referencing WSDL Metadata from an EPR for more details.
        Parameters:
        serviceName - The service name of the endpoint to be targeted by the returned W3CEndpointReference. This property may also be used with the endpointName (portName) property to lookup the address of a web service endpoint that is published by the same Java EE application.
        Returns:
        A W3CEndpointReferenceBuilder instance with the serviceName as wsam:ServiceName element added to the wsa:Metadata element

      • endpointName

        public W3CEndpointReferenceBuilder endpointName(QName endpointName)
        Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element. This method can only be called after the serviceName method has been called.

        See 2.1 Referencing WSDL Metadata from an EPR for more details.

        Parameters:
        endpointName - The name of the endpoint to be targeted by the returned W3CEndpointReference. The endpointName (portName) property may also be used with the serviceName property to lookup the address of a web service endpoint published by the same Java EE application.
        Returns:
        A W3CEndpointReferenceBuilder instance with the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
        Throws:
        IllegalStateException, - if the serviceName has not been set.
        IllegalArgumentException, - if the endpointName's Namespace URI doesn't match serviceName's Namespace URI

      • wsdlDocumentLocation

        public W3CEndpointReferenceBuilder wsdlDocumentLocation(String wsdlDocumentLocation)
        Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation. The namespace name for the wsdli:wsdlLocation's value can be taken from the WSDL itself.

        See 2.1 Referencing WSDL Metadata from an EPR for more details.

        Parameters:
        wsdlDocumentLocation - The location of the WSDL document to be referenced in the wsa:Metadata of the W3CEndpointReference.
        Returns:
        A W3CEndpointReferenceBuilder instance with the wsdlDocumentLocation that is to be referenced.

      • referenceParameter

        public W3CEndpointReferenceBuilder referenceParameter(Element referenceParameter)
        Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.
        Parameters:
        referenceParameter - The element to be added to the wsa:ReferenceParameters element.
        Returns:
        A W3CEndpointReferenceBuilder instance with the referenceParameter added to the wsa:ReferenceParameters element.
        Throws:
        IllegalArgumentException - if referenceParameter is null.

      • metadata

        public W3CEndpointReferenceBuilder metadata(Element metadataElement)
        Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
        Parameters:
        metadataElement - The element to be added to the wsa:Metadata element.
        Returns:
        A W3CEndpointReferenceBuilder instance with the metadataElement added to the wsa:Metadata element.
        Throws:
        IllegalArgumentException - if metadataElement is null.

      • element

        public W3CEndpointReferenceBuilder element(Element element)
        Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
        Parameters:
        element - The extension element to be added to the W3CEndpointReference
        Returns:
        A W3CEndpointReferenceBuilder instance with the extension element added to the W3CEndpointReference instance.
        Throws:
        IllegalArgumentException - if element is null.
        Since:
        JAX-WS 2.2

      • attribute

        public W3CEndpointReferenceBuilder attribute(QName name,
                                    String value)
        Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
        Parameters:
        name - The name of the extension attribute to be added to the W3CEndpointReference
        value - extension attribute value
        Returns:
        A W3CEndpointReferenceBuilder instance with the extension attribute added to the W3CEndpointReference instance.
        Throws:
        IllegalArgumentException - if name or value is null.
        Since:
        JAX-WS 2.2

      • build

        public W3CEndpointReference build()
        Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.

        This method can be used to create a W3CEndpointReference for any endpoint by specifying the address property along with any other desired properties. This method can also be used to create a W3CEndpointReference for an endpoint that is published by the same Java EE application. This method can automatically determine the address of an endpoint published by the same Java EE application that is identified by the serviceName and endpointName properties. If the address is null and the serviceName and endpointName do not identify an endpoint published by the same Java EE application, a java.lang.IllegalStateException MUST be thrown.

        Returns:
        W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance. This method never returns null.
        Throws:
        IllegalStateException -
        • If the address, serviceName and endpointName are all null.
        • If the serviceName service is null and the endpointName is NOT null.
        • If the address property is null and the serviceName and endpointName do not specify a valid endpoint published by the same Java EE application.
        • If the serviceName is NOT null and is not present in the specified WSDL.
        • If the endpointName port is not null and it is not present in serviceName service in the WSDL.
        • If the wsdlDocumentLocation is NOT null and does not represent a valid WSDL.
        WebServiceException - If an error occurs while creating the W3CEndpointReference.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class javax.xml.ws.wsaddressing.W3CEndpointReference (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.wsaddressing.W3CEndpointReference

  • Packages that use W3CEndpointReference
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of W3CEndpointReference in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return W3CEndpointReference
      Modifier and Type Method and Description
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.

    • Uses of W3CEndpointReference in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing that return W3CEndpointReference
      Modifier and Type Method and Description
      W3CEndpointReference W3CEndpointReferenceBuilder.build()
      Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

  • Packages that use W3CEndpointReferenceBuilder
    Package Description
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of W3CEndpointReferenceBuilder in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing that return W3CEndpointReferenceBuilder
      Modifier and Type Method and Description
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.address(String address)
      Sets the address to the W3CEndpointReference instance's wsa:Address.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.attribute(QName name, String value)
      Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.element(Element element)
      Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.endpointName(QName endpointName)
      Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.interfaceName(QName interfaceName)
      Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.metadata(Element metadataElement)
      Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.referenceParameter(Element referenceParameter)
      Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.serviceName(QName serviceName)
      Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.wsdlDocumentLocation(String wsdlDocumentLocation)
      Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Constant Field Values (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Constant Field Values

Contents

  • javax.ejb.*
  • javax.el.*
  • javax.enterprise.*
  • javax.faces.*
  • javax.interceptor.*
  • javax.jms.*
  • javax.json.*
  • javax.mail.*
  • javax.persistence.*
  • javax.resource.*
  • javax.security.*
  • javax.servlet.*
  • javax.transaction.*
  • javax.websocket.*
  • javax.ws.*
  • javax.xml.*

javax.ejb.*

  • javax.ejb.embeddable.EJBContainer
    Modifier and Type | Constant Field | Value
    public static final String | APP_NAME | "javax.ejb.embeddable.appName"
    public static final String | MODULES | "javax.ejb.embeddable.modules"
    public static final String | PROVIDER | "javax.ejb.embeddable.provider"

javax.el.*

  • javax.el.ELResolver
    Modifier and Type | Constant Field | Value
    public static final String | RESOLVABLE_AT_DESIGN_TIME | "resolvableAtDesignTime"
    public static final String | TYPE | "type"

javax.enterprise.*

  • javax.enterprise.concurrent.ManagedTask
    Modifier and Type | Constant Field | Value
    public static final String | IDENTITY_NAME | "javax.enterprise.concurrent.IDENTITY_NAME"
    public static final String | LONGRUNNING_HINT | "javax.enterprise.concurrent.LONGRUNNING_HINT"
    public static final String | SUSPEND | "SUSPEND"
    public static final String | TRANSACTION | "javax.enterprise.concurrent.TRANSACTION"
    public static final String | USE_TRANSACTION_OF_EXECUTION_THREAD | "USE_TRANSACTION_OF_EXECUTION_THREAD"

javax.faces.*

  • javax.faces.FactoryFinder
    Modifier and Type | Constant Field | Value
    public static final String | APPLICATION_FACTORY | "javax.faces.application.ApplicationFactory"
    public static final String | CLIENT_WINDOW_FACTORY | "javax.faces.lifecycle.ClientWindowFactory"
    public static final String | EXCEPTION_HANDLER_FACTORY | "javax.faces.context.ExceptionHandlerFactory"
    public static final String | EXTERNAL_CONTEXT_FACTORY | "javax.faces.context.ExternalContextFactory"
    public static final String | FACELET_CACHE_FACTORY | "javax.faces.view.facelets.FaceletCacheFactory"
    public static final String | FACES_CONTEXT_FACTORY | "javax.faces.context.FacesContextFactory"
    public static final String | FLASH_FACTORY | "javax.faces.context.FlashFactory"
    public static final String | FLOW_HANDLER_FACTORY | "javax.faces.flow.FlowHandlerFactory"
    public static final String | LIFECYCLE_FACTORY | "javax.faces.lifecycle.LifecycleFactory"
    public static final String | PARTIAL_VIEW_CONTEXT_FACTORY | "javax.faces.context.PartialViewContextFactory"
    public static final String | RENDER_KIT_FACTORY | "javax.faces.render.RenderKitFactory"
    public static final String | TAG_HANDLER_DELEGATE_FACTORY | "javax.faces.view.facelets.TagHandlerDelegateFactory"
    public static final String | VIEW_DECLARATION_LANGUAGE_FACTORY | "javax.faces.view.ViewDeclarationLanguageFactory"
    public static final String | VISIT_CONTEXT_FACTORY | "javax.faces.component.visit.VisitContextFactory"
  • javax.faces.application.FacesMessage
    Modifier and Type | Constant Field | Value
    public static final String | FACES_MESSAGES | "javax.faces.Messages"
  • javax.faces.application.ProjectStage
    Modifier and Type | Constant Field | Value
    public static final String | PROJECT_STAGE_JNDI_NAME | "java:comp/env/jsf/ProjectStage"
    public static final String | PROJECT_STAGE_PARAM_NAME | "javax.faces.PROJECT_STAGE"
  • javax.faces.application.Resource
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_RESOURCE_KEY | "javax.faces.application.Resource.ComponentResource"
  • javax.faces.application.ResourceHandler
    Modifier and Type | Constant Field | Value
    public static final String | LOCALE_PREFIX | "javax.faces.resource.localePrefix"
    public static final String | RESOURCE_CONTRACT_XML | "javax.faces.contract.xml"
    public static final String | RESOURCE_EXCLUDES_DEFAULT_VALUE | ".class .jsp .jspx .properties .xhtml .groovy"
    public static final String | RESOURCE_EXCLUDES_PARAM_NAME | "javax.faces.RESOURCE_EXCLUDES"
    public static final String | RESOURCE_IDENTIFIER | "/javax.faces.resource"
    public static final String | WEBAPP_CONTRACTS_DIRECTORY_PARAM_NAME | "javax.faces.WEBAPP_CONTRACTS_DIRECTORY"
    public static final String | WEBAPP_RESOURCES_DIRECTORY_PARAM_NAME | "javax.faces.WEBAPP_RESOURCES_DIRECTORY"
  • javax.faces.application.StateManager
    Modifier and Type | Constant Field | Value
    public static final String | FULL_STATE_SAVING_VIEW_IDS_PARAM_NAME | "javax.faces.FULL_STATE_SAVING_VIEW_IDS"
    public static final String | IS_BUILDING_INITIAL_STATE | "javax.faces.IS_BUILDING_INITIAL_STATE"
    public static final String | IS_SAVING_STATE | "javax.faces.IS_SAVING_STATE"
    public static final String | PARTIAL_STATE_SAVING_PARAM_NAME | "javax.faces.PARTIAL_STATE_SAVING"
    public static final String | SERIALIZE_SERVER_STATE_PARAM_NAME | "javax.faces.SERIALIZE_SERVER_STATE"
    public static final String | STATE_SAVING_METHOD_CLIENT | "client"
    public static final String | STATE_SAVING_METHOD_PARAM_NAME | "javax.faces.STATE_SAVING_METHOD"
    public static final String | STATE_SAVING_METHOD_SERVER | "server"
  • javax.faces.application.ViewHandler
    Modifier and Type | Constant Field | Value
    public static final String | CHARACTER_ENCODING_KEY | "javax.faces.request.charset"
    public static final String | DEFAULT_FACELETS_SUFFIX | ".xhtml"
    public static final String | DEFAULT_SUFFIX | ".xhtml .view.xml .jsp"
    public static final String | DEFAULT_SUFFIX_PARAM_NAME | "javax.faces.DEFAULT_SUFFIX"
    public static final String | DISABLE_FACELET_JSF_VIEWHANDLER_PARAM_NAME | "DISABLE_FACELET_JSF_VIEWHANDLER"
    public static final String | FACELETS_BUFFER_SIZE_PARAM_NAME | "javax.faces.FACELETS_BUFFER_SIZE"
    public static final String | FACELETS_DECORATORS_PARAM_NAME | "javax.faces.FACELETS_DECORATORS"
    public static final String | FACELETS_LIBRARIES_PARAM_NAME | "javax.faces.FACELETS_LIBRARIES"
    public static final String | FACELETS_REFRESH_PERIOD_PARAM_NAME | "javax.faces.FACELETS_REFRESH_PERIOD"
    public static final String | FACELETS_SKIP_COMMENTS_PARAM_NAME | "javax.faces.FACELETS_SKIP_COMMENTS"
    public static final String | FACELETS_SUFFIX_PARAM_NAME | "javax.faces.FACELETS_SUFFIX"
    public static final String | FACELETS_VIEW_MAPPINGS_PARAM_NAME | "javax.faces.FACELETS_VIEW_MAPPINGS"
  • javax.faces.component.FacesComponent
    Modifier and Type | Constant Field | Value
    public static final String | NAMESPACE | "http://xmlns.jcp.org/jsf/component"
  • javax.faces.component.NamingContainer
    Modifier and Type | Constant Field | Value
    public static final char | SEPARATOR_CHAR | 58
  • javax.faces.component.UIColumn
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Column"
    public static final String | COMPONENT_TYPE | "javax.faces.Column"
  • javax.faces.component.UICommand
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Command"
    public static final String | COMPONENT_TYPE | "javax.faces.Command"
  • javax.faces.component.UIComponent
    Modifier and Type | Constant Field | Value
    public static final String | ATTRS_WITH_DECLARED_DEFAULT_VALUES | "javax.faces.component.ATTR_NAMES_WITH_DEFAULT_VALUES"
    public static final String | BEANINFO_KEY | "javax.faces.component.BEANINFO_KEY"
    public static final String | COMPOSITE_COMPONENT_TYPE_KEY | "javax.faces.component.COMPOSITE_COMPONENT_TYPE"
    public static final String | COMPOSITE_FACET_NAME | "javax.faces.component.COMPOSITE_FACET_NAME"
    public static final String | CURRENT_COMPONENT | "javax.faces.component.CURRENT_COMPONENT"
    public static final String | CURRENT_COMPOSITE_COMPONENT | "javax.faces.component.CURRENT_COMPOSITE_COMPONENT"
    public static final String | FACETS_KEY | "javax.faces.component.FACETS_KEY"
    public static final String | HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME | "javax.faces.HONOR_CURRENT_COMPONENT_ATTRIBUTES"
    public static final String | VIEW_LOCATION_KEY | "javax.faces.component.VIEW_LOCATION_KEY"
  • javax.faces.component.UIData
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Data"
    public static final String | COMPONENT_TYPE | "javax.faces.Data"
  • javax.faces.component.UIForm
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Form"
    public static final String | COMPONENT_TYPE | "javax.faces.Form"
  • javax.faces.component.UIGraphic
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Graphic"
    public static final String | COMPONENT_TYPE | "javax.faces.Graphic"
  • javax.faces.component.UIInput
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Input"
    public static final String | COMPONENT_TYPE | "javax.faces.Input"
    public static final String | CONVERSION_MESSAGE_ID | "javax.faces.component.UIInput.CONVERSION"
    public static final String | REQUIRED_MESSAGE_ID | "javax.faces.component.UIInput.REQUIRED"
    public static final String | UPDATE_MESSAGE_ID | "javax.faces.component.UIInput.UPDATE"
    public static final String | VALIDATE_EMPTY_FIELDS_PARAM_NAME | "javax.faces.VALIDATE_EMPTY_FIELDS"
  • javax.faces.component.UIMessage
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Message"
    public static final String | COMPONENT_TYPE | "javax.faces.Message"
  • javax.faces.component.UIMessages
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Messages"
    public static final String | COMPONENT_TYPE | "javax.faces.Messages"
  • javax.faces.component.UINamingContainer
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.NamingContainer"
    public static final String | COMPONENT_TYPE | "javax.faces.NamingContainer"
    public static final String | SEPARATOR_CHAR_PARAM_NAME | "javax.faces.SEPARATOR_CHAR"
  • javax.faces.component.UIOutcomeTarget
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.OutcomeTarget"
    public static final String | COMPONENT_TYPE | "javax.faces.OutcomeTarget"
  • javax.faces.component.UIOutput
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Output"
    public static final String | COMPONENT_TYPE | "javax.faces.Output"
  • javax.faces.component.UIPanel
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Panel"
    public static final String | COMPONENT_TYPE | "javax.faces.Panel"
  • javax.faces.component.UIParameter
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.Parameter"
    public static final String | COMPONENT_TYPE | "javax.faces.Parameter"
  • javax.faces.component.UISelectBoolean
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.SelectBoolean"
    public static final String | COMPONENT_TYPE | "javax.faces.SelectBoolean"
  • javax.faces.component.UISelectItem
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.SelectItem"
    public static final String | COMPONENT_TYPE | "javax.faces.SelectItem"
  • javax.faces.component.UISelectItems
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.SelectItems"
    public static final String | COMPONENT_TYPE | "javax.faces.SelectItems"
  • javax.faces.component.UISelectMany
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.SelectMany"
    public static final String | COMPONENT_TYPE | "javax.faces.SelectMany"
    public static final String | INVALID_MESSAGE_ID | "javax.faces.component.UISelectMany.INVALID"
  • javax.faces.component.UISelectOne
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.SelectOne"
    public static final String | COMPONENT_TYPE | "javax.faces.SelectOne"
    public static final String | INVALID_MESSAGE_ID | "javax.faces.component.UISelectOne.INVALID"
  • javax.faces.component.UIViewAction
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.ViewAction"
    public static final String | COMPONENT_TYPE | "javax.faces.ViewAction"
  • javax.faces.component.UIViewParameter
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.ViewParameter"
    public static final String | COMPONENT_TYPE | "javax.faces.ViewParameter"
  • javax.faces.component.UIViewRoot
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_FAMILY | "javax.faces.ViewRoot"
    public static final String | COMPONENT_TYPE | "javax.faces.ViewRoot"
    public static final String | METADATA_FACET_NAME | "javax_faces_metadata"
    public static final String | UNIQUE_ID_PREFIX | "j_id"
    public static final String | VIEW_PARAMETERS_KEY | "javax.faces.component.VIEW_PARAMETERS_KEY"
  • javax.faces.component.behavior.AjaxBehavior
    Modifier and Type | Constant Field | Value
    public static final String | BEHAVIOR_ID | "javax.faces.behavior.Ajax"
  • javax.faces.component.html.HtmlBody
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.OutputBody"
  • javax.faces.component.html.HtmlColumn
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlColumn"
  • javax.faces.component.html.HtmlCommandButton
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlCommandButton"
  • javax.faces.component.html.HtmlCommandLink
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlCommandLink"
  • javax.faces.component.html.HtmlDataTable
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlDataTable"
  • javax.faces.component.html.HtmlDoctype
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.OutputDoctype"
  • javax.faces.component.html.HtmlForm
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlForm"
  • javax.faces.component.html.HtmlGraphicImage
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlGraphicImage"
  • javax.faces.component.html.HtmlHead
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.OutputHead"
  • javax.faces.component.html.HtmlInputFile
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlInputFile"
  • javax.faces.component.html.HtmlInputHidden
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlInputHidden"
  • javax.faces.component.html.HtmlInputSecret
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlInputSecret"
  • javax.faces.component.html.HtmlInputText
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlInputText"
  • javax.faces.component.html.HtmlInputTextarea
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlInputTextarea"
  • javax.faces.component.html.HtmlMessage
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlMessage"
  • javax.faces.component.html.HtmlMessages
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlMessages"
  • javax.faces.component.html.HtmlOutcomeTargetButton
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlOutcomeTargetButton"
  • javax.faces.component.html.HtmlOutcomeTargetLink
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlOutcomeTargetLink"
  • javax.faces.component.html.HtmlOutputFormat
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlOutputFormat"
  • javax.faces.component.html.HtmlOutputLabel
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlOutputLabel"
  • javax.faces.component.html.HtmlOutputLink
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlOutputLink"
  • javax.faces.component.html.HtmlOutputText
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlOutputText"
  • javax.faces.component.html.HtmlPanelGrid
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlPanelGrid"
  • javax.faces.component.html.HtmlPanelGroup
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlPanelGroup"
  • javax.faces.component.html.HtmlSelectBooleanCheckbox
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlSelectBooleanCheckbox"
  • javax.faces.component.html.HtmlSelectManyCheckbox
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlSelectManyCheckbox"
  • javax.faces.component.html.HtmlSelectManyListbox
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlSelectManyListbox"
  • javax.faces.component.html.HtmlSelectManyMenu
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlSelectManyMenu"
  • javax.faces.component.html.HtmlSelectOneListbox
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlSelectOneListbox"
  • javax.faces.component.html.HtmlSelectOneMenu
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlSelectOneMenu"
  • javax.faces.component.html.HtmlSelectOneRadio
    Modifier and Type | Constant Field | Value
    public static final String | COMPONENT_TYPE | "javax.faces.HtmlSelectOneRadio"
  • javax.faces.context.ExternalContext
    Modifier and Type | Constant Field | Value
    public static final String | BASIC_AUTH | "BASIC"
    public static final String | CLIENT_CERT_AUTH | "CLIENT_CERT"
    public static final String | DIGEST_AUTH | "DIGEST"
    public static final String | FORM_AUTH | "FORM"
  • javax.faces.context.Flash
    Modifier and Type | Constant Field | Value
    public static final String | NULL_VALUE | "javax.faces.context.Flash.NULL_VALUE"
  • javax.faces.context.PartialResponseWriter
    Modifier and Type | Constant Field | Value
    public static final String | RENDER_ALL_MARKER | "javax.faces.ViewRoot"
    public static final String | VIEW_STATE_MARKER | "javax.faces.ViewState"
  • javax.faces.context.PartialViewContext
    Modifier and Type | Constant Field | Value
    public static final String | ALL_PARTIAL_PHASE_CLIENT_IDS | "@all"
    public static final String | PARTIAL_EXECUTE_PARAM_NAME | "javax.faces.partial.execute"
    public static final String | PARTIAL_RENDER_PARAM_NAME | "javax.faces.partial.render"
    public static final String | RESET_VALUES_PARAM_NAME | "javax.faces.partial.resetValues"
  • javax.faces.convert.BigDecimalConverter
    Modifier and Type | Constant Field | Value
    public static final String | CONVERTER_ID | "javax.faces.BigDecimal"
    public static final String | DECIMAL_ID | "javax.faces.converter.BigDecimalConverter.DECIMAL"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.convert.BigIntegerConverter
    Modifier and Type | Constant Field | Value
    public static final String | BIGINTEGER_ID | "javax.faces.converter.BigIntegerConverter.BIGINTEGER"
    public static final String | CONVERTER_ID | "javax.faces.BigInteger"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.convert.BooleanConverter
    Modifier and Type | Constant Field | Value
    public static final String | BOOLEAN_ID | "javax.faces.converter.BooleanConverter.BOOLEAN"
    public static final String | CONVERTER_ID | "javax.faces.Boolean"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.convert.ByteConverter
    Modifier and Type | Constant Field | Value
    public static final String | BYTE_ID | "javax.faces.converter.ByteConverter.BYTE"
    public static final String | CONVERTER_ID | "javax.faces.Byte"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.convert.CharacterConverter
    Modifier and Type | Constant Field | Value
    public static final String | CHARACTER_ID | "javax.faces.converter.CharacterConverter.CHARACTER"
    public static final String | CONVERTER_ID | "javax.faces.Character"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.convert.Converter
    Modifier and Type | Constant Field | Value
    public static final String | DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME | "javax.faces.DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE"
  • javax.faces.convert.DateTimeConverter
    Modifier and Type | Constant Field | Value
    public static final String | CONVERTER_ID | "javax.faces.DateTime"
    public static final String | DATE_ID | "javax.faces.converter.DateTimeConverter.DATE"
    public static final String | DATETIME_ID | "javax.faces.converter.DateTimeConverter.DATETIME"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
    public static final String | TIME_ID | "javax.faces.converter.DateTimeConverter.TIME"
  • javax.faces.convert.DoubleConverter
    Modifier and Type | Constant Field | Value
    public static final String | CONVERTER_ID | "javax.faces.Double"
    public static final String | DOUBLE_ID | "javax.faces.converter.DoubleConverter.DOUBLE"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.convert.EnumConverter
    Modifier and Type | Constant Field | Value
    public static final String | CONVERTER_ID | "javax.faces.Enum"
    public static final String | ENUM_ID | "javax.faces.converter.EnumConverter.ENUM"
    public static final String | ENUM_NO_CLASS_ID | "javax.faces.converter.EnumConverter.ENUM_NO_CLASS"
  • javax.faces.convert.FloatConverter
    Modifier and Type | Constant Field | Value
    public static final String | CONVERTER_ID | "javax.faces.Float"
    public static final String | FLOAT_ID | "javax.faces.converter.FloatConverter.FLOAT"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.convert.IntegerConverter
    Modifier and Type | Constant Field | Value
    public static final String | CONVERTER_ID | "javax.faces.Integer"
    public static final String | INTEGER_ID | "javax.faces.converter.IntegerConverter.INTEGER"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.convert.LongConverter
    Modifier and Type | Constant Field | Value
    public static final String | CONVERTER_ID | "javax.faces.Long"
    public static final String | LONG_ID | "javax.faces.converter.LongConverter.LONG"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.convert.NumberConverter
    Modifier and Type | Constant Field | Value
    public static final String | CONVERTER_ID | "javax.faces.Number"
    public static final String | CURRENCY_ID | "javax.faces.converter.NumberConverter.CURRENCY"
    public static final String | NUMBER_ID | "javax.faces.converter.NumberConverter.NUMBER"
    public static final String | PATTERN_ID | "javax.faces.converter.NumberConverter.PATTERN"
    public static final String | PERCENT_ID | "javax.faces.converter.NumberConverter.PERCENT"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.convert.ShortConverter
    Modifier and Type | Constant Field | Value
    public static final String | CONVERTER_ID | "javax.faces.Short"
    public static final String | SHORT_ID | "javax.faces.converter.ShortConverter.SHORT"
    public static final String | STRING_ID | "javax.faces.converter.STRING"
  • javax.faces.event.ActionListener
    Modifier and Type | Constant Field | Value
    public static final String | TO_FLOW_DOCUMENT_ID_ATTR_NAME | "to-flow-document-id"
  • javax.faces.flow.FlowHandler
    Modifier and Type | Constant Field | Value
    public static final String | FLOW_ID_REQUEST_PARAM_NAME | "jffi"
    public static final String | NULL_FLOW | "javax.faces.flow.NullFlow"
    public static final String | TO_FLOW_DOCUMENT_ID_REQUEST_PARAM_NAME | "jftfdi"
  • javax.faces.lifecycle.ClientWindow
    Modifier and Type | Constant Field | Value
    public static final String | CLIENT_WINDOW_MODE_PARAM_NAME | "javax.faces.CLIENT_WINDOW_MODE"
  • javax.faces.lifecycle.LifecycleFactory
    Modifier and Type | Constant Field | Value
    public static final String | DEFAULT_LIFECYCLE | "DEFAULT"
  • javax.faces.render.Renderer
    Modifier and Type | Constant Field | Value
    public static final String | PASSTHROUGH_RENDERER_LOCALNAME_KEY | "elementName"
  • javax.faces.render.RenderKitFactory
    Modifier and Type | Constant Field | Value
    public static final String | HTML_BASIC_RENDER_KIT | "HTML_BASIC"
  • javax.faces.render.ResponseStateManager
    Modifier and Type | Constant Field | Value
    public static final String | CLIENT_WINDOW_PARAM | "javax.faces.ClientWindow"
    public static final String | CLIENT_WINDOW_URL_PARAM | "jfwid"
    public static final String | NON_POSTBACK_VIEW_TOKEN_PARAM | "javax.faces.Token"
    public static final String | RENDER_KIT_ID_PARAM | "javax.faces.RenderKitId"
    public static final String | VIEW_STATE_PARAM | "javax.faces.ViewState"
  • javax.faces.validator.BeanValidator
    Modifier and Type | Constant Field | Value
    public static final String | DISABLE_DEFAULT_BEAN_VALIDATOR_PARAM_NAME | "javax.faces.validator.DISABLE_DEFAULT_BEAN_VALIDATOR"
    public static final String | EMPTY_VALIDATION_GROUPS_PATTERN | "^[\\W,]*$"
    public static final String | MESSAGE_ID | "javax.faces.validator.BeanValidator.MESSAGE"
    public static final String VALIDATION_GROUPS_DELIMITER ","
    public static final String | VALIDATOR_FACTORY_KEY | "javax.faces.validator.beanValidator.ValidatorFactory"
    public static final String | VALIDATOR_ID | "javax.faces.Bean"
  • javax.faces.validator.DoubleRangeValidator
    Modifier and Type | Constant Field | Value
    public static final String | MAXIMUM_MESSAGE_ID | "javax.faces.validator.DoubleRangeValidator.MAXIMUM"
    public static final String | MINIMUM_MESSAGE_ID | "javax.faces.validator.DoubleRangeValidator.MINIMUM"
    public static final String | NOT_IN_RANGE_MESSAGE_ID | "javax.faces.validator.DoubleRangeValidator.NOT_IN_RANGE"
    public static final String | TYPE_MESSAGE_ID | "javax.faces.validator.DoubleRangeValidator.TYPE"
    public static final String | VALIDATOR_ID | "javax.faces.DoubleRange"
  • javax.faces.validator.LengthValidator
    Modifier and Type | Constant Field | Value
    public static final String | MAXIMUM_MESSAGE_ID | "javax.faces.validator.LengthValidator.MAXIMUM"
    public static final String | MINIMUM_MESSAGE_ID | "javax.faces.validator.LengthValidator.MINIMUM"
    public static final String | VALIDATOR_ID | "javax.faces.Length"
  • javax.faces.validator.LongRangeValidator
    Modifier and Type | Constant Field | Value
    public static final String | MAXIMUM_MESSAGE_ID | "javax.faces.validator.LongRangeValidator.MAXIMUM"
    public static final String | MINIMUM_MESSAGE_ID | "javax.faces.validator.LongRangeValidator.MINIMUM"
    public static final String | NOT_IN_RANGE_MESSAGE_ID | "javax.faces.validator.LongRangeValidator.NOT_IN_RANGE"
    public static final String | TYPE_MESSAGE_ID | "javax.faces.validator.LongRangeValidator.TYPE"
    public static final String | VALIDATOR_ID | "javax.faces.LongRange"
  • javax.faces.validator.RegexValidator
    Modifier and Type | Constant Field | Value
    public static final String | MATCH_EXCEPTION_MESSAGE_ID | "javax.faces.validator.RegexValidator.MATCH_EXCEPTION"
    public static final String | NOT_MATCHED_MESSAGE_ID | "javax.faces.validator.RegexValidator.NOT_MATCHED"
    public static final String | PATTERN_NOT_SET_MESSAGE_ID | "javax.faces.validator.RegexValidator.PATTERN_NOT_SET"
    public static final String | VALIDATOR_ID | "javax.faces.RegularExpression"
  • javax.faces.validator.RequiredValidator
    Modifier and Type | Constant Field | Value
    public static final String | VALIDATOR_ID | "javax.faces.Required"
  • javax.faces.validator.Validator
    Modifier and Type | Constant Field | Value
    public static final String | NOT_IN_RANGE_MESSAGE_ID | "javax.faces.validator.NOT_IN_RANGE"
  • javax.faces.view.AttachedObjectTarget
    Modifier and Type | Constant Field | Value
    public static final String | ATTACHED_OBJECT_TARGETS_KEY | "javax.faces.view.AttachedObjectTargets"
  • javax.faces.view.ViewDeclarationLanguage
    Modifier and Type | Constant Field | Value
    public static final String | FACELETS_VIEW_DECLARATION_LANGUAGE_ID | "java.faces.Facelets"
    public static final String | JSP_VIEW_DECLARATION_LANGUAGE_ID | "java.faces.JSP"
  • javax.faces.view.facelets.FaceletContext
    Modifier and Type | Constant Field | Value
    public static final String | FACELET_CONTEXT_KEY | "javax.faces.FACELET_CONTEXT"
  • javax.faces.view.facelets.ResourceResolver
    Modifier and Type | Constant Field | Value
    public static final String | FACELETS_RESOURCE_RESOLVER_PARAM_NAME | "javax.faces.FACELETS_RESOURCE_RESOLVER"
  • javax.faces.webapp.FacesServlet
    Modifier and Type | Constant Field | Value
    public static final String | CONFIG_FILES_ATTR | "javax.faces.CONFIG_FILES"
    public static final String | LIFECYCLE_ID_ATTR | "javax.faces.LIFECYCLE_ID"
  • javax.faces.webapp.UIComponentClassicTagBase
    Modifier and Type | Constant Field | Value
    protected static final String | UNIQUE_ID_PREFIX | "j_id_"

javax.interceptor.*

  • javax.interceptor.Interceptor.Priority
    Modifier and Type | Constant Field | Value
    public static final int | APPLICATION | 2000
    public static final int | LIBRARY_AFTER | 3000
    public static final int | LIBRARY_BEFORE | 1000
    public static final int | PLATFORM_AFTER | 4000
    public static final int | PLATFORM_BEFORE | 0

javax.jms.*

  • javax.jms.DeliveryMode
    Modifier and Type | Constant Field | Value
    public static final int | NON_PERSISTENT | 1
    public static final int | PERSISTENT | 2
  • javax.jms.JMSContext
    Modifier and Type | Constant Field | Value
    public static final int | AUTO_ACKNOWLEDGE | 1
    public static final int | CLIENT_ACKNOWLEDGE | 2
    public static final int | DUPS_OK_ACKNOWLEDGE | 3
    public static final int | SESSION_TRANSACTED | 0
  • javax.jms.Message
    Modifier and Type | Constant Field | Value
    public static final long | DEFAULT_DELIVERY_DELAY | 0L
    public static final int | DEFAULT_DELIVERY_MODE | 2
    public static final int | DEFAULT_PRIORITY | 4
    public static final long | DEFAULT_TIME_TO_LIVE | 0L
  • javax.jms.Session
    Modifier and Type | Constant Field | Value
    public static final int | AUTO_ACKNOWLEDGE | 1
    public static final int | CLIENT_ACKNOWLEDGE | 2
    public static final int | DUPS_OK_ACKNOWLEDGE | 3
    public static final int | SESSION_TRANSACTED | 0

javax.json.*

  • javax.json.stream.JsonGenerator
    Modifier and Type | Constant Field | Value
    public static final String | PRETTY_PRINTING | "javax.json.stream.JsonGenerator.prettyPrinting"

javax.mail.*

  • javax.mail.Folder
    Modifier and Type | Constant Field | Value
    public static final int | HOLDS_FOLDERS | 2
    public static final int | HOLDS_MESSAGES | 1
    public static final int | READ_ONLY | 1
    public static final int | READ_WRITE | 2
  • javax.mail.Part
    Modifier and Type | Constant Field | Value
    public static final String | ATTACHMENT | "attachment"
    public static final String | INLINE | "inline"
  • javax.mail.UIDFolder
    Modifier and Type | Constant Field | Value
    public static final long | LASTUID | -1L
  • javax.mail.event.ConnectionEvent
    Modifier and Type | Constant Field | Value
    public static final int | CLOSED | 3
    public static final int | DISCONNECTED | 2
    public static final int | OPENED | 1
  • javax.mail.event.FolderEvent
    Modifier and Type | Constant Field | Value
    public static final int | CREATED | 1
    public static final int | DELETED | 2
    public static final int | RENAMED | 3
  • javax.mail.event.MessageChangedEvent
    Modifier and Type | Constant Field | Value
    public static final int | ENVELOPE_CHANGED | 2
    public static final int | FLAGS_CHANGED | 1
  • javax.mail.event.MessageCountEvent
    Modifier and Type | Constant Field | Value
    public static final int | ADDED | 1
    public static final int | REMOVED | 2
  • javax.mail.event.StoreEvent
    Modifier and Type | Constant Field | Value
    public static final int | ALERT | 1
    public static final int | NOTICE | 2
  • javax.mail.event.TransportEvent
    Modifier and Type | Constant Field | Value
    public static final int | MESSAGE_DELIVERED | 1
    public static final int | MESSAGE_NOT_DELIVERED | 2
    public static final int | MESSAGE_PARTIALLY_DELIVERED | 3
  • javax.mail.internet.HeaderTokenizer
    Modifier and Type | Constant Field | Value
    public static final String | MIME | "()<>@,;:\\\"\t []/?="
    public static final String | RFC822 | "()<>@,;:\\\"\t .[]"
  • javax.mail.internet.HeaderTokenizer.Token
    Modifier and Type | Constant Field | Value
    public static final int | ATOM | -1
    public static final int | COMMENT | -3
    public static final int | EOF | -4
    public static final int | QUOTEDSTRING | -2
  • javax.mail.internet.MimeUtility
    Modifier and Type | Constant Field | Value
    public static final int | ALL | -1
  • javax.mail.search.ComparisonTerm
    Modifier and Type | Constant Field | Value
    public static final int | EQ | 3
    public static final int | GE | 6
    public static final int | GT | 5
    public static final int | LE | 1
    public static final int | LT | 2
    public static final int | NE | 4

javax.persistence.*

  • javax.persistence.Persistence
    Modifier and Type | Constant Field | Value
    public static final String | PERSISTENCE_PROVIDER | "javax.persistence.spi.PeristenceProvider"

javax.resource.*

  • javax.resource.cci.InteractionSpec
    Modifier and Type | Constant Field | Value
    public static final int | SYNC_RECEIVE | 2
    public static final int | SYNC_SEND | 0
    public static final int | SYNC_SEND_RECEIVE | 1
  • javax.resource.spi.ConnectionEvent
    Modifier and Type | Constant Field | Value
    public static final int | CONNECTION_CLOSED | 1
    public static final int | CONNECTION_ERROR_OCCURRED | 5
    public static final int | LOCAL_TRANSACTION_COMMITTED | 3
    public static final int | LOCAL_TRANSACTION_ROLLEDBACK | 4
    public static final int | LOCAL_TRANSACTION_STARTED | 2
  • javax.resource.spi.work.HintsContext
    Modifier and Type | Constant Field | Value
    public static final String | LONGRUNNING_HINT | "javax.resource.LongRunning"
    public static final String | NAME_HINT | "javax.resource.Name"
  • javax.resource.spi.work.WorkContextErrorCodes
    Modifier and Type | Constant Field | Value
    public static final String | CONTEXT_SETUP_FAILED | "3"
    public static final String | CONTEXT_SETUP_UNSUPPORTED | "4"
    public static final String | DUPLICATE_CONTEXTS | "2"
    public static final String | UNSUPPORTED_CONTEXT_TYPE | "1"
  • javax.resource.spi.work.WorkEvent
    Modifier and Type | Constant Field | Value
    public static final int | WORK_ACCEPTED | 1
    public static final int | WORK_COMPLETED | 4
    public static final int | WORK_REJECTED | 2
    public static final int | WORK_STARTED | 3
  • javax.resource.spi.work.WorkException
    Modifier and Type | Constant Field | Value
    public static final String | INTERNAL | "-1"
    public static final String | START_TIMED_OUT | "1"
    public static final String | TX_CONCURRENT_WORK_DISALLOWED | "2"
    public static final String | TX_RECREATE_FAILED | "3"
    public static final String | UNDEFINED | "0"
  • javax.resource.spi.work.WorkManager
    Modifier and Type | Constant Field | Value
    public static final long | IMMEDIATE | 0L
    public static final long | INDEFINITE | 9223372036854775807L
    public static final long | UNKNOWN | -1L

javax.security.*

  • javax.security.auth.message.MessagePolicy.ProtectionPolicy
    Modifier and Type | Constant Field | Value
    public static final String | AUTHENTICATE_CONTENT | "#authenticateContent"
    public static final String | AUTHENTICATE_RECIPIENT | "#authenticateRecipient"
    public static final String | AUTHENTICATE_SENDER | "#authenticateSender"
  • javax.security.auth.message.config.AuthConfigFactory
    Modifier and Type | Constant Field | Value
    public static final String | DEFAULT_FACTORY_SECURITY_PROPERTY | "authconfigprovider.factory"
    public static final String | GET_FACTORY_PERMISSION_NAME | "getProperty.authconfigprovider.factory"
    public static final String | PROVIDER_REGISTRATION_PERMISSION_NAME | "setProperty.authconfigfactory.provider"
    public static final String | SET_FACTORY_PERMISSION_NAME | "setProperty.authconfigprovider.factory"

javax.servlet.*

  • javax.servlet.AsyncContext
    Modifier and Type | Constant Field | Value
    public static final String | ASYNC_CONTEXT_PATH | "javax.servlet.async.context_path"
    public static final String | ASYNC_PATH_INFO | "javax.servlet.async.path_info"
    public static final String | ASYNC_QUERY_STRING | "javax.servlet.async.query_string"
    public static final String | ASYNC_REQUEST_URI | "javax.servlet.async.request_uri"
    public static final String | ASYNC_SERVLET_PATH | "javax.servlet.async.servlet_path"
  • javax.servlet.RequestDispatcher
    Modifier and Type | Constant Field | Value
    public static final String | ERROR_EXCEPTION | "javax.servlet.error.exception"
    public static final String | ERROR_EXCEPTION_TYPE | "javax.servlet.error.exception_type"
    public static final String | ERROR_MESSAGE | "javax.servlet.error.message"
    public static final String | ERROR_REQUEST_URI | "javax.servlet.error.request_uri"
    public static final String | ERROR_SERVLET_NAME | "javax.servlet.error.servlet_name"
    public static final String | ERROR_STATUS_CODE | "javax.servlet.error.status_code"
    public static final String | FORWARD_CONTEXT_PATH | "javax.servlet.forward.context_path"
    public static final String | FORWARD_PATH_INFO | "javax.servlet.forward.path_info"
    public static final String | FORWARD_QUERY_STRING | "javax.servlet.forward.query_string"
    public static final String | FORWARD_REQUEST_URI | "javax.servlet.forward.request_uri"
    public static final String | FORWARD_SERVLET_PATH | "javax.servlet.forward.servlet_path"
    public static final String | INCLUDE_CONTEXT_PATH | "javax.servlet.include.context_path"
    public static final String | INCLUDE_PATH_INFO | "javax.servlet.include.path_info"
    public static final String | INCLUDE_QUERY_STRING | "javax.servlet.include.query_string"
    public static final String | INCLUDE_REQUEST_URI | "javax.servlet.include.request_uri"
    public static final String | INCLUDE_SERVLET_PATH | "javax.servlet.include.servlet_path"
  • javax.servlet.ServletContext
    Modifier and Type | Constant Field | Value
    public static final String | ORDERED_LIBS | "javax.servlet.context.orderedLibs"
    public static final String | TEMPDIR | "javax.servlet.context.tempdir"
  • javax.servlet.http.HttpServletRequest
    Modifier and Type | Constant Field | Value
    public static final String | BASIC_AUTH | "BASIC"
    public static final String | CLIENT_CERT_AUTH | "CLIENT_CERT"
    public static final String | DIGEST_AUTH | "DIGEST"
    public static final String | FORM_AUTH | "FORM"
  • javax.servlet.http.HttpServletResponse
    Modifier and Type | Constant Field | Value
    public static final int | SC_ACCEPTED | 202
    public static final int | SC_BAD_GATEWAY | 502
    public static final int | SC_BAD_REQUEST | 400
    public static final int | SC_CONFLICT | 409
    public static final int | SC_CONTINUE | 100
    public static final int | SC_CREATED | 201
    public static final int | SC_EXPECTATION_FAILED | 417
    public static final int | SC_FORBIDDEN | 403
    public static final int | SC_FOUND | 302
    public static final int | SC_GATEWAY_TIMEOUT | 504
    public static final int | SC_GONE | 410
    public static final int | SC_HTTP_VERSION_NOT_SUPPORTED | 505
    public static final int | SC_INTERNAL_SERVER_ERROR | 500
    public static final int | SC_LENGTH_REQUIRED | 411
    public static final int | SC_METHOD_NOT_ALLOWED | 405
    public static final int | SC_MOVED_PERMANENTLY | 301
    public static final int | SC_MOVED_TEMPORARILY | 302
    public static final int | SC_MULTIPLE_CHOICES | 300
    public static final int | SC_NO_CONTENT | 204
    public static final int | SC_NON_AUTHORITATIVE_INFORMATION | 203
    public static final int | SC_NOT_ACCEPTABLE | 406
    public static final int | SC_NOT_FOUND | 404
    public static final int | SC_NOT_IMPLEMENTED | 501
    public static final int | SC_NOT_MODIFIED | 304
    public static final int | SC_OK | 200
    public static final int | SC_PARTIAL_CONTENT | 206
    public static final int | SC_PAYMENT_REQUIRED | 402
    public static final int | SC_PRECONDITION_FAILED | 412
    public static final int | SC_PROXY_AUTHENTICATION_REQUIRED | 407
    public static final int | SC_REQUEST_ENTITY_TOO_LARGE | 413
    public static final int | SC_REQUEST_TIMEOUT | 408
    public static final int | SC_REQUEST_URI_TOO_LONG | 414
    public static final int | SC_REQUESTED_RANGE_NOT_SATISFIABLE | 416
    public static final int | SC_RESET_CONTENT | 205
    public static final int | SC_SEE_OTHER | 303
    public static final int | SC_SERVICE_UNAVAILABLE | 503
    public static final int | SC_SWITCHING_PROTOCOLS | 101
    public static final int | SC_TEMPORARY_REDIRECT | 307
    public static final int | SC_UNAUTHORIZED | 401
    public static final int | SC_UNSUPPORTED_MEDIA_TYPE | 415
    public static final int | SC_USE_PROXY | 305
  • javax.servlet.jsp.JspWriter
    Modifier and Type | Constant Field | Value
    public static final int | DEFAULT_BUFFER | -1
    public static final int | NO_BUFFER | 0
    public static final int | UNBOUNDED_BUFFER | -2
  • javax.servlet.jsp.PageContext
    Modifier and Type | Constant Field | Value
    public static final String | APPLICATION | "javax.servlet.jsp.jspApplication"
    public static final int | APPLICATION_SCOPE | 4
    public static final String | CONFIG | "javax.servlet.jsp.jspConfig"
    public static final String | EXCEPTION | "javax.servlet.jsp.jspException"
    public static final String | OUT | "javax.servlet.jsp.jspOut"
    public static final String | PAGE | "javax.servlet.jsp.jspPage"
    public static final int | PAGE_SCOPE | 1
    public static final String | PAGECONTEXT | "javax.servlet.jsp.jspPageContext"
    public static final String | REQUEST | "javax.servlet.jsp.jspRequest"
    public static final int | REQUEST_SCOPE | 2
    public static final String | RESPONSE | "javax.servlet.jsp.jspResponse"
    public static final String | SESSION | "javax.servlet.jsp.jspSession"
    public static final int | SESSION_SCOPE | 3
  • javax.servlet.jsp.jstl.core.Config
    Modifier and Type | Constant Field | Value
    public static final String | FMT_FALLBACK_LOCALE | "javax.servlet.jsp.jstl.fmt.fallbackLocale"
    public static final String | FMT_LOCALE | "javax.servlet.jsp.jstl.fmt.locale"
    public static final String | FMT_LOCALIZATION_CONTEXT | "javax.servlet.jsp.jstl.fmt.localizationContext"
    public static final String | FMT_TIME_ZONE | "javax.servlet.jsp.jstl.fmt.timeZone"
    public static final String | SQL_DATA_SOURCE | "javax.servlet.jsp.jstl.sql.dataSource"
    public static final String | SQL_MAX_ROWS | "javax.servlet.jsp.jstl.sql.maxRows"
  • javax.servlet.jsp.tagext.BodyTag
    Modifier and Type | Constant Field | Value
    public static final int | EVAL_BODY_BUFFERED | 2
    public static final int | EVAL_BODY_TAG | 2
  • javax.servlet.jsp.tagext.IterationTag
    Modifier and Type | Constant Field | Value
    public static final int | EVAL_BODY_AGAIN | 2
  • javax.servlet.jsp.tagext.Tag
    Modifier and Type | Constant Field | Value
    public static final int | EVAL_BODY_INCLUDE | 1
    public static final int | EVAL_PAGE | 6
    public static final int | SKIP_BODY | 0
    public static final int | SKIP_PAGE | 5
  • javax.servlet.jsp.tagext.TagAttributeInfo
    Modifier and Type | Constant Field | Value
    public static final String | ID | "id"
  • javax.servlet.jsp.tagext.TagInfo
    Modifier and Type | Constant Field | Value
    public static final String | BODY_CONTENT_EMPTY | "empty"
    public static final String | BODY_CONTENT_JSP | "JSP"
    public static final String | BODY_CONTENT_SCRIPTLESS | "scriptless"
    public static final String | BODY_CONTENT_TAG_DEPENDENT | "tagdependent"
  • javax.servlet.jsp.tagext.VariableInfo
    Modifier and Type | Constant Field | Value
    public static final int | AT_BEGIN | 1
    public static final int | AT_END | 2
    public static final int | NESTED | 0

javax.transaction.*

  • javax.transaction.Status
    Modifier and Type | Constant Field | Value
    public static final int | STATUS_ACTIVE | 0
    public static final int | STATUS_COMMITTED | 3
    public static final int | STATUS_COMMITTING | 8
    public static final int | STATUS_MARKED_ROLLBACK | 1
    public static final int | STATUS_NO_TRANSACTION | 6
    public static final int | STATUS_PREPARED | 2
    public static final int | STATUS_PREPARING | 7
    public static final int | STATUS_ROLLEDBACK | 4
    public static final int | STATUS_ROLLING_BACK | 9
    public static final int | STATUS_UNKNOWN | 5
  • javax.transaction.xa.XAException
    Modifier and Type | Constant Field | Value
    public static final int | XA_HEURCOM | 7
    public static final int | XA_HEURHAZ | 8
    public static final int | XA_HEURMIX | 5
    public static final int | XA_HEURRB | 6
    public static final int | XA_NOMIGRATE | 9
    public static final int | XA_RBBASE | 100
    public static final int | XA_RBCOMMFAIL | 101
    public static final int | XA_RBDEADLOCK | 102
    public static final int | XA_RBEND | 107
    public static final int | XA_RBINTEGRITY | 103
    public static final int | XA_RBOTHER | 104
    public static final int | XA_RBPROTO | 105
    public static final int | XA_RBROLLBACK | 100
    public static final int | XA_RBTIMEOUT | 106
    public static final int | XA_RBTRANSIENT | 107
    public static final int | XA_RDONLY | 3
    public static final int | XA_RETRY | 4
    public static final int | XAER_ASYNC | -2
    public static final int | XAER_DUPID | -8
    public static final int | XAER_INVAL | -5
    public static final int | XAER_NOTA | -4
    public static final int | XAER_OUTSIDE | -9
    public static final int | XAER_PROTO | -6
    public static final int | XAER_RMERR | -3
    public static final int | XAER_RMFAIL | -7
  • javax.transaction.xa.XAResource
    Modifier and Type | Constant Field | Value
    public static final int | TMENDRSCAN | 8388608
    public static final int | TMFAIL | 536870912
    public static final int | TMJOIN | 2097152
    public static final int | TMNOFLAGS | 0
    public static final int | TMONEPHASE | 1073741824
    public static final int | TMRESUME | 134217728
    public static final int | TMSTARTRSCAN | 16777216
    public static final int | TMSUCCESS | 67108864
    public static final int | TMSUSPEND | 33554432
    public static final int | XA_OK | 0
    public static final int | XA_RDONLY | 3
  • javax.transaction.xa.Xid
    Modifier and Type | Constant Field | Value
    public static final int | MAXBQUALSIZE | 64
    public static final int | MAXGTRIDSIZE | 64

javax.websocket.*

  • javax.websocket.HandshakeResponse
    Modifier and Type | Constant Field | Value
    public static final String | SEC_WEBSOCKET_ACCEPT | "Sec-WebSocket-Accept"
  • javax.websocket.server.HandshakeRequest
    Modifier and Type | Constant Field | Value
    public static final String | SEC_WEBSOCKET_EXTENSIONS | "Sec-WebSocket-Extensions"
    public static final String | SEC_WEBSOCKET_KEY | "Sec-WebSocket-Key"
    public static final String | SEC_WEBSOCKET_PROTOCOL | "Sec-WebSocket-Protocol"
    public static final String | SEC_WEBSOCKET_VERSION | "Sec-WebSocket-Version"

javax.ws.*

  • javax.ws.rs.HttpMethod
    Modifier and Type | Constant Field | Value
    public static final String | DELETE | "DELETE"
    public static final String | GET | "GET"
    public static final String | HEAD | "HEAD"
    public static final String | OPTIONS | "OPTIONS"
    public static final String | POST | "POST"
    public static final String | PUT | "PUT"
  • javax.ws.rs.Priorities
    Modifier and Type | Constant Field | Value
    public static final int | AUTHENTICATION | 1000
    public static final int | AUTHORIZATION | 2000
    public static final int | ENTITY_CODER | 4000
    public static final int | HEADER_DECORATOR | 3000
    public static final int | USER | 5000
  • javax.ws.rs.client.ClientBuilder
    Modifier and Type | Constant Field | Value
    public static final String | JAXRS_DEFAULT_CLIENT_BUILDER_PROPERTY | "javax.ws.rs.client.ClientBuilder"
  • javax.ws.rs.container.AsyncResponse
    Modifier and Type | Constant Field | Value
    public static final long | NO_TIMEOUT | 0L
  • javax.ws.rs.core.Cookie
    Modifier and Type | Constant Field | Value
    public static final int | DEFAULT_VERSION | 1
  • javax.ws.rs.core.HttpHeaders
    Modifier and Type | Constant Field | Value
    public static final String | ACCEPT | "Accept"
    public static final String | ACCEPT_CHARSET | "Accept-Charset"
    public static final String | ACCEPT_ENCODING | "Accept-Encoding"
    public static final String | ACCEPT_LANGUAGE | "Accept-Language"
    public static final String | ALLOW | "Allow"
    public static final String | AUTHORIZATION | "Authorization"
    public static final String | CACHE_CONTROL | "Cache-Control"
    public static final String | CONTENT_DISPOSITION | "Content-Disposition"
    public static final String | CONTENT_ENCODING | "Content-Encoding"
    public static final String | CONTENT_ID | "Content-ID"
    public static final String | CONTENT_LANGUAGE | "Content-Language"
    public static final String | CONTENT_LENGTH | "Content-Length"
    public static final String | CONTENT_LOCATION | "Content-Location"
    public static final String | CONTENT_TYPE | "Content-Type"
    public static final String | COOKIE | "Cookie"
    public static final String | DATE | "Date"
    public static final String | ETAG | "ETag"
    public static final String | EXPIRES | "Expires"
    public static final String | HOST | "Host"
    public static final String | IF_MATCH | "If-Match"
    public static final String | IF_MODIFIED_SINCE | "If-Modified-Since"
    public static final String | IF_NONE_MATCH | "If-None-Match"
    public static final String | IF_UNMODIFIED_SINCE | "If-Unmodified-Since"
    public static final String | LAST_MODIFIED | "Last-Modified"
    public static final String | LINK | "Link"
    public static final String | LOCATION | "Location"
    public static final String | RETRY_AFTER | "Retry-After"
    public static final String | SET_COOKIE | "Set-Cookie"
    public static final String | USER_AGENT | "User-Agent"
    public static final String | VARY | "Vary"
    public static final String | WWW_AUTHENTICATE | "WWW-Authenticate"
  • javax.ws.rs.core.Link
    Modifier and Type | Constant Field | Value
    public static final String | REL | "rel"
    public static final String | TITLE | "title"
    public static final String | TYPE | "type"
  • javax.ws.rs.core.MediaType
    Modifier and Type | Constant Field | Value
    public static final String | APPLICATION_ATOM_XML | "application/atom+xml"
    public static final String | APPLICATION_FORM_URLENCODED | "application/x-www-form-urlencoded"
    public static final String | APPLICATION_JSON | "application/json"
    public static final String | APPLICATION_OCTET_STREAM | "application/octet-stream"
    public static final String | APPLICATION_SVG_XML | "application/svg+xml"
    public static final String | APPLICATION_XHTML_XML | "application/xhtml+xml"
    public static final String | APPLICATION_XML | "application/xml"
    public static final String | CHARSET_PARAMETER | "charset"
    public static final String MEDIA_TYPE_WILDCARD "*"
    public static final String | MULTIPART_FORM_DATA | "multipart/form-data"
    public static final String | TEXT_HTML | "text/html"
    public static final String | TEXT_PLAIN | "text/plain"
    public static final String | TEXT_XML | "text/xml"
    public static final String WILDCARD "*/*"
  • javax.ws.rs.core.NewCookie
    Modifier and Type | Constant Field | Value
    public static final int | DEFAULT_MAX_AGE | -1
  • javax.ws.rs.core.SecurityContext
    Modifier and Type | Constant Field | Value
    public static final String | BASIC_AUTH | "BASIC"
    public static final String | CLIENT_CERT_AUTH | "CLIENT_CERT"
    public static final String | DIGEST_AUTH | "DIGEST"
    public static final String | FORM_AUTH | "FORM"
  • javax.ws.rs.ext.RuntimeDelegate
    Modifier and Type | Constant Field | Value
    public static final String | JAXRS_RUNTIME_DELEGATE_PROPERTY | "javax.ws.rs.ext.RuntimeDelegate"

javax.xml.*

  • javax.xml.bind.JAXBContext
    Modifier and Type | Constant Field | Value
    public static final String | JAXB_CONTEXT_FACTORY | "javax.xml.bind.context.factory"
  • javax.xml.bind.Marshaller
    Modifier and Type | Constant Field | Value
    public static final String | JAXB_ENCODING | "jaxb.encoding"
    public static final String | JAXB_FORMATTED_OUTPUT | "jaxb.formatted.output"
    public static final String | JAXB_FRAGMENT | "jaxb.fragment"
    public static final String | JAXB_NO_NAMESPACE_SCHEMA_LOCATION | "jaxb.noNamespaceSchemaLocation"
    public static final String | JAXB_SCHEMA_LOCATION | "jaxb.schemaLocation"
  • javax.xml.bind.ValidationEvent
    Modifier and Type | Constant Field | Value
    public static final int | ERROR | 1
    public static final int | FATAL_ERROR | 2
    public static final int | WARNING | 0
  • javax.xml.bind.annotation.XmlSchema
    Modifier and Type | Constant Field | Value
    public static final String | NO_LOCATION | "##generate"
  • javax.xml.registry.FindQualifier
    Modifier and Type | Constant Field | Value
    public static final String | AND_ALL_KEYS | "andAllKeys"
    public static final String | CASE_SENSITIVE_MATCH | "caseSensitiveMatch"
    public static final String | COMBINE_CLASSIFICATIONS | "combineClassifications"
    public static final String | EXACT_NAME_MATCH | "exactNameMatch"
    public static final String | OR_ALL_KEYS | "orAllKeys"
    public static final String | OR_LIKE_KEYS | "orLikeKeys"
    public static final String | SERVICE_SUBSET | "serviceSubset"
    public static final String | SORT_BY_DATE_ASC | "sortByDateAsc"
    public static final String | SORT_BY_DATE_DESC | "sortByDateDesc"
    public static final String | SORT_BY_NAME_ASC | "sortByNameAsc"
    public static final String | SORT_BY_NAME_DESC | "sortByNameDesc"
    public static final String | SOUNDEX | "soundex"
  • javax.xml.registry.JAXRResponse
    Modifier and Type | Constant Field | Value
    public static final int | STATUS_FAILURE | 2
    public static final int | STATUS_SUCCESS | 0
    public static final int | STATUS_UNAVAILABLE | 3
    public static final int | STATUS_WARNING | 1
  • javax.xml.registry.LifeCycleManager
    Modifier and Type | Constant Field | Value
    public static final String | ASSOCIATION | "Association"
    public static final String | AUDITABLE_EVENT | "AuditableEvent"
    public static final String | CLASSIFICATION | "Classification"
    public static final String | CLASSIFICATION_SCHEME | "ClassificationScheme"
    public static final String | CONCEPT | "Concept"
    public static final String | EMAIL_ADDRESS | "EmailAddress"
    public static final String | EXTERNAL_IDENTIFIER | "ExternalIdentifier"
    public static final String | EXTERNAL_LINK | "ExternalLink"
    public static final String | EXTRINSIC_OBJECT | "ExtrinsicObject"
    public static final String | INTERNATIONAL_STRING | "InternationalString"
    public static final String | KEY | "Key"
    public static final String | LOCALIZED_STRING | "LocalizedString"
    public static final String | ORGANIZATION | "Organization"
    public static final String | PERSON_NAME | "PersonName"
    public static final String | POSTAL_ADDRESS | "PostalAddress"
    public static final String | REGISTRY_ENTRY | "RegistryEntry"
    public static final String | REGISTRY_PACKAGE | "RegistryPackage"
    public static final String | SERVICE | "Service"
    public static final String | SERVICE_BINDING | "ServiceBinding"
    public static final String | SLOT | "Slot"
    public static final String | SPECIFICATION_LINK | "SpecificationLink"
    public static final String | TELEPHONE_NUMBER | "TelephoneNumber"
    public static final String | USER | "User"
    public static final String | VERSIONABLE | "Versionable"
  • javax.xml.registry.Query
    Modifier and Type | Constant Field | Value
    public static final int | QUERY_TYPE_EBXML_FILTER_QUERY | 2
    public static final int | QUERY_TYPE_SQL | 0
    public static final int | QUERY_TYPE_XQUERY | 1
  • javax.xml.registry.infomodel.AuditableEvent
    Modifier and Type | Constant Field | Value
    public static final int | EVENT_TYPE_CREATED | 0
    public static final int | EVENT_TYPE_DELETED | 1
    public static final int | EVENT_TYPE_DEPRECATED | 2
    public static final int | EVENT_TYPE_UNDEPRECATED | 5
    public static final int | EVENT_TYPE_UPDATED | 3
    public static final int | EVENT_TYPE_VERSIONED | 4
  • javax.xml.registry.infomodel.ClassificationScheme
    Modifier and Type | Constant Field | Value
    public static final int | VALUE_TYPE_EMBEDDED_PATH | 1
    public static final int | VALUE_TYPE_NON_UNIQUE | 2
    public static final int | VALUE_TYPE_UNIQUE | 0
  • javax.xml.registry.infomodel.LocalizedString
    Modifier and Type | Constant Field | Value
    public static final String | DEFAULT_CHARSET_NAME | "UTF-8"
  • javax.xml.registry.infomodel.RegistryEntry
    Modifier and Type | Constant Field | Value
    public static final int | STABILITY_DYNAMIC | 0
    public static final int | STABILITY_DYNAMIC_COMPATIBLE | 1
    public static final int | STABILITY_STATIC | 2
    public static final int | STATUS_APPROVED | 1
    public static final int | STATUS_DEPRECATED | 2
    public static final int | STATUS_SUBMITTED | 0
    public static final int | STATUS_WITHDRAWN | 3
  • javax.xml.registry.infomodel.Slot
    Modifier and Type | Constant Field | Value
    public static final String | ADDRESS_LINES_SLOT | "addressLines"
    public static final String | AUTHORIZED_NAME_SLOT | "authorizedName"
    public static final String | OPERATOR_SLOT | "operator"
    public static final String | SORT_CODE_SLOT | "sortCode"
  • javax.xml.rpc.Call
    Modifier and Type | Constant Field | Value
    public static final String | ENCODINGSTYLE_URI_PROPERTY | "javax.xml.rpc.encodingstyle.namespace.uri"
    public static final String | OPERATION_STYLE_PROPERTY | "javax.xml.rpc.soap.operation.style"
    public static final String | PASSWORD_PROPERTY | "javax.xml.rpc.security.auth.password"
    public static final String | SESSION_MAINTAIN_PROPERTY | "javax.xml.rpc.session.maintain"
    public static final String | SOAPACTION_URI_PROPERTY | "javax.xml.rpc.soap.http.soapaction.uri"
    public static final String | SOAPACTION_USE_PROPERTY | "javax.xml.rpc.soap.http.soapaction.use"
    public static final String | USERNAME_PROPERTY | "javax.xml.rpc.security.auth.username"
  • javax.xml.rpc.NamespaceConstants
    Modifier and Type | Constant Field | Value
    public static final String | NSPREFIX_SCHEMA_XSD | "xsd"
    public static final String | NSPREFIX_SCHEMA_XSI | "xsi"
    public static final String | NSPREFIX_SOAP_ENCODING | "soapenc"
    public static final String | NSPREFIX_SOAP_ENVELOPE | "soapenv"
    public static final String | NSURI_SCHEMA_XSD | "http://www.w3.org/2001/XMLSchema"
    public static final String | NSURI_SCHEMA_XSI | "http://www.w3.org/2001/XMLSchema-instance"
    public static final String | NSURI_SOAP_ENCODING | "http://schemas.xmlsoap.org/soap/encoding/"
    public static final String | NSURI_SOAP_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
    public static final String | NSURI_SOAP_NEXT_ACTOR | "http://schemas.xmlsoap.org/soap/actor/next"
  • javax.xml.rpc.ServiceFactory
    Modifier and Type | Constant Field | Value
    public static final String | SERVICEFACTORY_PROPERTY | "javax.xml.rpc.ServiceFactory"
  • javax.xml.rpc.Stub
    Modifier and Type | Constant Field | Value
    public static final String | ENDPOINT_ADDRESS_PROPERTY | "javax.xml.rpc.service.endpoint.address"
    public static final String | PASSWORD_PROPERTY | "javax.xml.rpc.security.auth.password"
    public static final String | SESSION_MAINTAIN_PROPERTY | "javax.xml.rpc.session.maintain"
    public static final String | USERNAME_PROPERTY | "javax.xml.rpc.security.auth.username"
  • javax.xml.soap.SOAPConstants
    Modifier and Type | Constant Field | Value
    public static final String | DEFAULT_SOAP_PROTOCOL | "SOAP 1.1 Protocol"
    public static final String | DYNAMIC_SOAP_PROTOCOL | "Dynamic Protocol"
    public static final String | SOAP_1_1_CONTENT_TYPE | "text/xml"
    public static final String | SOAP_1_1_PROTOCOL | "SOAP 1.1 Protocol"
    public static final String | SOAP_1_2_CONTENT_TYPE | "application/soap+xml"
    public static final String | SOAP_1_2_PROTOCOL | "SOAP 1.2 Protocol"
    public static final String | SOAP_ENV_PREFIX | "env"
    public static final String | URI_NS_SOAP_1_1_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
    public static final String | URI_NS_SOAP_1_2_ENCODING | "http://www.w3.org/2003/05/soap-encoding"
    public static final String | URI_NS_SOAP_1_2_ENVELOPE | "http://www.w3.org/2003/05/soap-envelope"
    public static final String | URI_NS_SOAP_ENCODING | "http://schemas.xmlsoap.org/soap/encoding/"
    public static final String | URI_NS_SOAP_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
    public static final String | URI_SOAP_1_2_ROLE_NEXT | "http://www.w3.org/2003/05/soap-envelope/role/next"
    public static final String | URI_SOAP_1_2_ROLE_NONE | "http://www.w3.org/2003/05/soap-envelope/role/none"
    public static final String | URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER | "http://www.w3.org/2003/05/soap-envelope/role/ultimateReceiver"
    public static final String | URI_SOAP_ACTOR_NEXT | "http://schemas.xmlsoap.org/soap/actor/next"
  • javax.xml.soap.SOAPMessage
    Modifier and Type | Constant Field | Value
    public static final String | CHARACTER_SET_ENCODING | "javax.xml.soap.character-set-encoding"
    public static final String | WRITE_XML_DECLARATION | "javax.xml.soap.write-xml-declaration"
  • javax.xml.ws.BindingProvider
    Modifier and Type | Constant Field | Value
    public static final String | ENDPOINT_ADDRESS_PROPERTY | "javax.xml.ws.service.endpoint.address"
    public static final String | PASSWORD_PROPERTY | "javax.xml.ws.security.auth.password"
    public static final String | SESSION_MAINTAIN_PROPERTY | "javax.xml.ws.session.maintain"
    public static final String | SOAPACTION_URI_PROPERTY | "javax.xml.ws.soap.http.soapaction.uri"
    public static final String | SOAPACTION_USE_PROPERTY | "javax.xml.ws.soap.http.soapaction.use"
    public static final String | USERNAME_PROPERTY | "javax.xml.ws.security.auth.username"
  • javax.xml.ws.Endpoint
    Modifier and Type | Constant Field | Value
    public static final String | WSDL_PORT | "javax.xml.ws.wsdl.port"
    public static final String | WSDL_SERVICE | "javax.xml.ws.wsdl.service"
  • javax.xml.ws.RespectBindingFeature
    Modifier and Type | Constant Field | Value
    public static final String | ID | "javax.xml.ws.RespectBindingFeature"
  • javax.xml.ws.handler.MessageContext
    Modifier and Type | Constant Field | Value
    public static final String | HTTP_REQUEST_HEADERS | "javax.xml.ws.http.request.headers"
    public static final String | HTTP_REQUEST_METHOD | "javax.xml.ws.http.request.method"
    public static final String | HTTP_RESPONSE_CODE | "javax.xml.ws.http.response.code"
    public static final String | HTTP_RESPONSE_HEADERS | "javax.xml.ws.http.response.headers"
    public static final String | INBOUND_MESSAGE_ATTACHMENTS | "javax.xml.ws.binding.attachments.inbound"
    public static final String | MESSAGE_OUTBOUND_PROPERTY | "javax.xml.ws.handler.message.outbound"
    public static final String | OUTBOUND_MESSAGE_ATTACHMENTS | "javax.xml.ws.binding.attachments.outbound"
    public static final String | PATH_INFO | "javax.xml.ws.http.request.pathinfo"
    public static final String | QUERY_STRING | "javax.xml.ws.http.request.querystring"
    public static final String | REFERENCE_PARAMETERS | "javax.xml.ws.reference.parameters"
    public static final String | SERVLET_CONTEXT | "javax.xml.ws.servlet.context"
    public static final String | SERVLET_REQUEST | "javax.xml.ws.servlet.request"
    public static final String | SERVLET_RESPONSE | "javax.xml.ws.servlet.response"
    public static final String | WSDL_DESCRIPTION | "javax.xml.ws.wsdl.description"
    public static final String | WSDL_INTERFACE | "javax.xml.ws.wsdl.interface"
    public static final String | WSDL_OPERATION | "javax.xml.ws.wsdl.operation"
    public static final String | WSDL_PORT | "javax.xml.ws.wsdl.port"
    public static final String | WSDL_SERVICE | "javax.xml.ws.wsdl.service"
  • javax.xml.ws.http.HTTPBinding
    Modifier and Type | Constant Field | Value
    public static final String | HTTP_BINDING | "http://www.w3.org/2004/08/wsdl/http"
  • javax.xml.ws.soap.AddressingFeature
    Modifier and Type | Constant Field | Value
    public static final String | ID | "http://www.w3.org/2005/08/addressing/module"
  • javax.xml.ws.soap.MTOMFeature
    Modifier and Type | Constant Field | Value
    public static final String | ID | "http://www.w3.org/2004/08/soap/features/http-optimization"
  • javax.xml.ws.soap.SOAPBinding
    Modifier and Type | Constant Field | Value
    public static final String | SOAP11HTTP_BINDING | "http://schemas.xmlsoap.org/wsdl/soap/http"
    public static final String | SOAP11HTTP_MTOM_BINDING | "http://schemas.xmlsoap.org/wsdl/soap/http?mtom=true"
    public static final String | SOAP12HTTP_BINDING | "http://www.w3.org/2003/05/soap/bindings/HTTP/"
    public static final String | SOAP12HTTP_MTOM_BINDING | "http://www.w3.org/2003/05/soap/bindings/HTTP/?mtom=true"
  • javax.xml.ws.spi.Provider
    Modifier and Type | Constant Field | Value
    public static final String | JAXWSPROVIDER_PROPERTY | "javax.xml.ws.spi.Provider"
  • javax.xml.ws.spi.http.HttpExchange
    Modifier and Type | Constant Field | Value
    public static final String | REQUEST_CIPHER_SUITE | "javax.xml.ws.spi.http.request.cipher.suite"
    public static final String | REQUEST_KEY_SIZE | "javax.xml.ws.spi.http.request.key.size"
    public static final String | REQUEST_X509CERTIFICATE | "javax.xml.ws.spi.http.request.cert.X509Certificate"
  • javax.xml.ws.wsaddressing.W3CEndpointReference
    Modifier and Type | Constant Field | Value
    protected static final String | NS | "http://www.w3.org/2005/08/addressing"
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Serialized Form (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Serialized Form

  • Package javax.batch.operations

    • Class javax.batch.operations.BatchRuntimeException extends RuntimeException implements Serializable

      serialVersionUID:
      1L

    • Class javax.batch.operations.JobExecutionAlreadyCompleteException extends BatchRuntimeException implements Serializable

      serialVersionUID:
      1L

    • Class javax.batch.operations.JobExecutionIsRunningException extends BatchRuntimeException implements Serializable

      serialVersionUID:
      1L

    • Class javax.batch.operations.JobExecutionNotMostRecentException extends BatchRuntimeException implements Serializable

      serialVersionUID:
      1L

    • Class javax.batch.operations.JobExecutionNotRunningException extends BatchRuntimeException implements Serializable

      serialVersionUID:
      1L

    • Class javax.batch.operations.JobRestartException extends BatchRuntimeException implements Serializable

      serialVersionUID:
      1L

    • Class javax.batch.operations.JobSecurityException extends BatchRuntimeException implements Serializable

      serialVersionUID:
      1L

    • Class javax.batch.operations.JobStartException extends BatchRuntimeException implements Serializable

      serialVersionUID:
      1L

    • Class javax.batch.operations.NoSuchJobException extends BatchRuntimeException implements Serializable

      serialVersionUID:
      1L

    • Class javax.batch.operations.NoSuchJobExecutionException extends BatchRuntimeException implements Serializable

      serialVersionUID:
      1L

    • Class javax.batch.operations.NoSuchJobInstanceException extends BatchRuntimeException implements Serializable

      serialVersionUID:
      1L

  • Package javax.ejb

    • Class javax.ejb.AccessLocalException extends EJBException implements Serializable

      serialVersionUID:
      -4089104928924996726L

    • Class javax.ejb.ConcurrentAccessException extends EJBException implements Serializable

      serialVersionUID:
      -8980855319866981477L

    • Class javax.ejb.ConcurrentAccessTimeoutException extends ConcurrentAccessException implements Serializable

      serialVersionUID:
      7899534274371798660L

    • Class javax.ejb.CreateException extends Exception implements Serializable

      serialVersionUID:
      6295951740865457514L

    • Class javax.ejb.DuplicateKeyException extends CreateException implements Serializable

      serialVersionUID:
      -7287399994705270076L

    • Class javax.ejb.EJBAccessException extends EJBException implements Serializable

      serialVersionUID:
      4923220329322198628L

    • Class javax.ejb.EJBException extends RuntimeException implements Serializable

      serialVersionUID:
      796770993296843510L

    • Class javax.ejb.EJBTransactionRequiredException extends EJBException implements Serializable

      serialVersionUID:
      8880799605373282306L

    • Class javax.ejb.EJBTransactionRolledbackException extends EJBException implements Serializable

      serialVersionUID:
      -8301720350425840333L

    • Class javax.ejb.FinderException extends Exception implements Serializable

      serialVersionUID:
      8785983102057433621L

    • Class javax.ejb.IllegalLoopbackException extends ConcurrentAccessException implements Serializable

      serialVersionUID:
      -8854624128500916709L

    • Class javax.ejb.NoMoreTimeoutsException extends EJBException implements Serializable

      serialVersionUID:
      1373788283844991998L

    • Class javax.ejb.NoSuchEJBException extends EJBException implements Serializable

      serialVersionUID:
      -4861625171310593950L

    • Class javax.ejb.NoSuchEntityException extends EJBException implements Serializable

      serialVersionUID:
      -4815730078295420703L

    • Class javax.ejb.NoSuchObjectLocalException extends EJBException implements Serializable

      serialVersionUID:
      9151491108833037318L

    • Class javax.ejb.ObjectNotFoundException extends FinderException implements Serializable

      serialVersionUID:
      4624364141026778L

    • Class javax.ejb.RemoveException extends Exception implements Serializable

      serialVersionUID:
      -4581849053220157910L

    • Class javax.ejb.ScheduleExpression extends Object implements Serializable

      serialVersionUID:
      -3813254457230997879L

      • Serialized Fields

        • second_

          String second_

        • minute_

          String minute_

        • hour_

          String hour_

        • dayOfMonth_

          String dayOfMonth_

        • month_

          String month_

        • dayOfWeek_

          String dayOfWeek_

        • year_

          String year_

        • timezoneID_

          String timezoneID_

        • start_

          Date start_

        • end_

          Date end_

    • Class javax.ejb.TransactionRequiredLocalException extends EJBException implements Serializable

      serialVersionUID:
      -3884174204131319153L

    • Class javax.ejb.TransactionRolledbackLocalException extends EJBException implements Serializable

      serialVersionUID:
      2897658132751784821L

  • Package javax.el

    • Class javax.el.ELContextEvent extends EventObject implements Serializable

    • Class javax.el.ELException extends RuntimeException implements Serializable

    • Class javax.el.Expression extends Object implements Serializable

    • Class javax.el.MethodExpression extends Expression implements Serializable

    • Class javax.el.MethodNotFoundException extends ELException implements Serializable

    • Class javax.el.PropertyNotFoundException extends ELException implements Serializable

    • Class javax.el.PropertyNotWritableException extends ELException implements Serializable

    • Class javax.el.ValueExpression extends Expression implements Serializable

    • Class javax.el.ValueReference extends Object implements Serializable

      • Serialized Fields

        • base

          Object base

        • property

          Object property

  • Package javax.enterprise.concurrent

    • Class javax.enterprise.concurrent.AbortedException extends ExecutionException implements Serializable

      serialVersionUID:
      -8248124070283019190L

    • Class javax.enterprise.concurrent.SkippedException extends ExecutionException implements Serializable

      serialVersionUID:
      6296866815328432550L

  • Package javax.enterprise.context

    • Class javax.enterprise.context.BusyConversationException extends ContextException implements Serializable

      serialVersionUID:
      -3599813072560026919L

    • Class javax.enterprise.context.ContextException extends RuntimeException implements Serializable

      serialVersionUID:
      -3599813072560026919L

    • Class javax.enterprise.context.ContextNotActiveException extends ContextException implements Serializable

      serialVersionUID:
      -3599813072560026919L

    • Class javax.enterprise.context.NonexistentConversationException extends ContextException implements Serializable

      serialVersionUID:
      -3599813072560026919L

  • Package javax.enterprise.deploy.model.exceptions

    • Class javax.enterprise.deploy.model.exceptions.DDBeanCreateException extends Exception implements Serializable

  • Package javax.enterprise.deploy.spi.exceptions

    • Class javax.enterprise.deploy.spi.exceptions.BeanNotFoundException extends Exception implements Serializable

    • Class javax.enterprise.deploy.spi.exceptions.ClientExecuteException extends Exception implements Serializable

    • Class javax.enterprise.deploy.spi.exceptions.ConfigurationException extends Exception implements Serializable

    • Class javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException extends Exception implements Serializable

    • Class javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException extends Exception implements Serializable

    • Class javax.enterprise.deploy.spi.exceptions.InvalidModuleException extends Exception implements Serializable

    • Class javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException extends Exception implements Serializable

    • Class javax.enterprise.deploy.spi.exceptions.TargetException extends Exception implements Serializable

  • Package javax.enterprise.deploy.spi.status

    • Class javax.enterprise.deploy.spi.status.ProgressEvent extends EventObject implements Serializable

  • Package javax.enterprise.event

    • Class javax.enterprise.event.ObserverException extends RuntimeException implements Serializable

      serialVersionUID:
      -801836224808304381L

  • Package javax.enterprise.inject

    • Class javax.enterprise.inject.AmbiguousResolutionException extends ResolutionException implements Serializable

      serialVersionUID:
      -2132733164534544788L

    • Class javax.enterprise.inject.CreationException extends InjectionException implements Serializable

      serialVersionUID:
      1002854668862145298L

    • Class javax.enterprise.inject.IllegalProductException extends InjectionException implements Serializable

      serialVersionUID:
      -6280627846071966243L

    • Class javax.enterprise.inject.InjectionException extends RuntimeException implements Serializable

      serialVersionUID:
      -2132733164534544788L

    • Class javax.enterprise.inject.ResolutionException extends InjectionException implements Serializable

      serialVersionUID:
      -6280627846071966243L

    • Class javax.enterprise.inject.UnproxyableResolutionException extends ResolutionException implements Serializable

      serialVersionUID:
      1667539354548135465L

    • Class javax.enterprise.inject.UnsatisfiedResolutionException extends ResolutionException implements Serializable

      serialVersionUID:
      5350603312442756709L

  • Package javax.enterprise.inject.spi

    • Class javax.enterprise.inject.spi.DefinitionException extends RuntimeException implements Serializable

      serialVersionUID:
      -2699170549782567339L

    • Class javax.enterprise.inject.spi.DeploymentException extends RuntimeException implements Serializable

      serialVersionUID:
      2604707587772339984L

  • Package javax.enterprise.util

    • Class javax.enterprise.util.AnnotationLiteral extends Object implements Serializable

      serialVersionUID:
      1L

    • Class javax.enterprise.util.TypeLiteral extends Object implements Serializable

      serialVersionUID:
      1L

  • Package javax.faces

    • Class javax.faces.FacesException extends RuntimeException implements Serializable

      • Serialized Fields

        • cause

          Throwable cause

          The underlying exception that caused this exception.

  • Package javax.faces.application

    • Class javax.faces.application.FacesMessage extends Object implements Serializable

      serialVersionUID:
      -1180773928220076822L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException

          Reconstruct FacesMessage from serialized artifacts.

          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException

          Persist FacesMessage artifacts, including the non serializable Severity.

          Throws:
          IOException

      • Serialized Fields

        • severity

          FacesMessage.Severity severity

        • summary

          String summary

        • detail

          String detail

        • rendered

          boolean rendered

    • Class javax.faces.application.ProtectedViewException extends FacesException implements Serializable

    • Class javax.faces.application.ViewExpiredException extends FacesException implements Serializable

      • Serialized Fields

        • viewId

          String viewId

          The view identifier of the view that could not be restored.

  • Package javax.faces.component

    • Class javax.faces.component.UpdateModelException extends FacesException implements Serializable

      serialVersionUID:
      6081145672680351218L

      • Serialized Fields

        • facesMessage

          FacesMessage facesMessage

  • Package javax.faces.convert

    • Class javax.faces.convert.ConverterException extends FacesException implements Serializable

      • Serialized Fields

        • facesMessage

          FacesMessage facesMessage

  • Package javax.faces.el

    • Class javax.faces.el.EvaluationException extends FacesException implements Serializable

    • Class javax.faces.el.MethodNotFoundException extends EvaluationException implements Serializable

    • Class javax.faces.el.PropertyNotFoundException extends EvaluationException implements Serializable

    • Class javax.faces.el.ReferenceSyntaxException extends EvaluationException implements Serializable

  • Package javax.faces.event

    • Class javax.faces.event.AbortProcessingException extends FacesException implements Serializable

    • Class javax.faces.event.ActionEvent extends FacesEvent implements Serializable

    • Class javax.faces.event.AjaxBehaviorEvent extends BehaviorEvent implements Serializable

    • Class javax.faces.event.BehaviorEvent extends FacesEvent implements Serializable

      • Serialized Fields

        • behavior

          Behavior behavior

    • Class javax.faces.event.ComponentSystemEvent extends SystemEvent implements Serializable

      serialVersionUID:
      -4726746661822507506L

    • Class javax.faces.event.ExceptionQueuedEvent extends SystemEvent implements Serializable

    • Class javax.faces.event.FacesEvent extends EventObject implements Serializable

      • Serialized Fields

        • phaseId

          PhaseId phaseId

    • Class javax.faces.event.PhaseEvent extends EventObject implements Serializable

      • Serialized Fields

        • context

          FacesContext context

        • phaseId

          PhaseId phaseId

    • Class javax.faces.event.PostAddToViewEvent extends ComponentSystemEvent implements Serializable

      serialVersionUID:
      -1113592223476173895L

    • Class javax.faces.event.PostConstructApplicationEvent extends SystemEvent implements Serializable

      serialVersionUID:
      -3918703770970591309L

    • Class javax.faces.event.PostConstructCustomScopeEvent extends SystemEvent implements Serializable

    • Class javax.faces.event.PostConstructViewMapEvent extends ComponentSystemEvent implements Serializable

      serialVersionUID:
      8684338297976265379L

    • Class javax.faces.event.PostKeepFlashValueEvent extends SystemEvent implements Serializable

      serialVersionUID:
      -7137725846753823862L

    • Class javax.faces.event.PostPutFlashValueEvent extends SystemEvent implements Serializable

      serialVersionUID:
      -6422204761759384353L

    • Class javax.faces.event.PostRestoreStateEvent extends ComponentSystemEvent implements Serializable

      serialVersionUID:
      -1007196479122154347L

    • Class javax.faces.event.PostValidateEvent extends ComponentSystemEvent implements Serializable

    • Class javax.faces.event.PreClearFlashEvent extends SystemEvent implements Serializable

      serialVersionUID:
      -6069648757590884651L

    • Class javax.faces.event.PreDestroyApplicationEvent extends SystemEvent implements Serializable

      serialVersionUID:
      8105212785161493162L

    • Class javax.faces.event.PreDestroyCustomScopeEvent extends SystemEvent implements Serializable

    • Class javax.faces.event.PreDestroyViewMapEvent extends ComponentSystemEvent implements Serializable

      serialVersionUID:
      4470489935758914483L

    • Class javax.faces.event.PreRemoveFlashValueEvent extends SystemEvent implements Serializable

      serialVersionUID:
      -82999687346960430L

    • Class javax.faces.event.PreRemoveFromViewEvent extends ComponentSystemEvent implements Serializable

    • Class javax.faces.event.PreRenderComponentEvent extends ComponentSystemEvent implements Serializable

    • Class javax.faces.event.PreRenderViewEvent extends ComponentSystemEvent implements Serializable

    • Class javax.faces.event.PreValidateEvent extends ComponentSystemEvent implements Serializable

    • Class javax.faces.event.SystemEvent extends EventObject implements Serializable

      serialVersionUID:
      2696415667461888462L

    • Class javax.faces.event.ValueChangeEvent extends FacesEvent implements Serializable

      • Serialized Fields

        • oldValue

          Object oldValue

          The previous local value of the source UIComponent.

        • newValue

          Object newValue

          The current local value of the source UIComponent.

  • Package javax.faces.model

    • Class javax.faces.model.DataModelEvent extends EventObject implements Serializable

      • Serialized Fields

        • data

          Object data

        • index

          int index

    • Class javax.faces.model.SelectItem extends Object implements Serializable

      serialVersionUID:
      876782311414654999L

      • Serialized Fields

        • description

          String description

        • disabled

          boolean disabled

        • label

          String label

        • value

          Object value

        • escape

          boolean escape

        • noSelectionOption

          boolean noSelectionOption

    • Class javax.faces.model.SelectItemGroup extends SelectItem implements Serializable

      • Serialized Fields

        • selectItems

          SelectItem[] selectItems

  • Package javax.faces.validator

    • Class javax.faces.validator.ValidatorException extends FacesException implements Serializable

      • Serialized Fields

        • message

          FacesMessage message

        • messages

          Collection<E> messages

  • Package javax.faces.view

    • Class javax.faces.view.Location extends Object implements Serializable

      • Serialized Fields

        • path

          String path

        • line

          int line

        • column

          int column

  • Package javax.faces.view.facelets

    • Class javax.faces.view.facelets.FaceletException extends FacesException implements Serializable

      serialVersionUID:
      1L

    • Class javax.faces.view.facelets.TagAttributeException extends FaceletException implements Serializable

      serialVersionUID:
      1L

    • Class javax.faces.view.facelets.TagException extends FaceletException implements Serializable

      serialVersionUID:
      1L

  • Package javax.faces.webapp

    • Class javax.faces.webapp.AttributeTag extends TagSupport implements Serializable

      serialVersionUID:
      -7782950243436672334L

      • Serialized Fields

        • name

          String name
          Deprecated.

          The name of the attribute to be created, if not already present.

        • value

          String value
          Deprecated.

          The value to be associated with this attribute, if it is created.

    • Class javax.faces.webapp.ConverterELTag extends TagSupport implements Serializable

    • Class javax.faces.webapp.ConverterTag extends TagSupport implements Serializable

      serialVersionUID:
      -5909792518081427720L

      • Serialized Fields

        • converterId

          String converterId
          Deprecated.

          The identifier of the Converter instance to be created.

        • binding

          String binding
          Deprecated.

          The ValueExpression that evaluates to an object that implements Converter.

    • Class javax.faces.webapp.FacetTag extends TagSupport implements Serializable

      • Serialized Fields

        • name

          String name

          The name of this facet. This will be used as the facet name for our UIComponentTag child in our UIComponentTag parent's facet list.

    • Class javax.faces.webapp.ValidatorELTag extends TagSupport implements Serializable

    • Class javax.faces.webapp.ValidatorTag extends TagSupport implements Serializable

      serialVersionUID:
      -5562623615418158868L

      • Serialized Fields

        • validatorId

          String validatorId
          Deprecated.

          The identifier of the Validator instance to be created.

        • binding

          String binding
          Deprecated.

          The ValueExpression that evaluates to an object that implements Validator.

  • Package javax.jms

    • Class javax.jms.IllegalStateException extends JMSException implements Serializable

    • Class javax.jms.IllegalStateRuntimeException extends JMSRuntimeException implements Serializable

    • Class javax.jms.InvalidClientIDException extends JMSException implements Serializable

    • Class javax.jms.InvalidClientIDRuntimeException extends JMSRuntimeException implements Serializable

    • Class javax.jms.InvalidDestinationException extends JMSException implements Serializable

    • Class javax.jms.InvalidDestinationRuntimeException extends JMSRuntimeException implements Serializable

    • Class javax.jms.InvalidSelectorException extends JMSException implements Serializable

    • Class javax.jms.InvalidSelectorRuntimeException extends JMSRuntimeException implements Serializable

    • Class javax.jms.JMSException extends Exception implements Serializable

      • Serialized Fields

        • errorCode

          String errorCode
          Vendor-specific error code.

        • linkedException

          Exception linkedException
          Exception reference.

    • Class javax.jms.JMSRuntimeException extends RuntimeException implements Serializable

      • Serialized Fields

        • errorCode

          String errorCode
          Provider-specific error code.

    • Class javax.jms.JMSSecurityException extends JMSException implements Serializable

    • Class javax.jms.JMSSecurityRuntimeException extends JMSRuntimeException implements Serializable

    • Class javax.jms.MessageEOFException extends JMSException implements Serializable

    • Class javax.jms.MessageFormatException extends JMSException implements Serializable

    • Class javax.jms.MessageFormatRuntimeException extends JMSRuntimeException implements Serializable

    • Class javax.jms.MessageNotReadableException extends JMSException implements Serializable

    • Class javax.jms.MessageNotWriteableException extends JMSException implements Serializable

    • Class javax.jms.MessageNotWriteableRuntimeException extends JMSRuntimeException implements Serializable

    • Class javax.jms.ResourceAllocationException extends JMSException implements Serializable

    • Class javax.jms.ResourceAllocationRuntimeException extends JMSRuntimeException implements Serializable

    • Class javax.jms.TransactionInProgressException extends JMSException implements Serializable

    • Class javax.jms.TransactionInProgressRuntimeException extends JMSRuntimeException implements Serializable

    • Class javax.jms.TransactionRolledBackException extends JMSException implements Serializable

    • Class javax.jms.TransactionRolledBackRuntimeException extends JMSRuntimeException implements Serializable

  • Package javax.json

    • Class javax.json.JsonException extends RuntimeException implements Serializable

  • Package javax.json.stream

    • Class javax.json.stream.JsonGenerationException extends JsonException implements Serializable

    • Class javax.json.stream.JsonParsingException extends JsonException implements Serializable

      • Serialized Fields

        • location

          JsonLocation location

  • Package javax.mail

    • Class javax.mail.Address extends Object implements Serializable

      serialVersionUID:
      -5822459626751992278L

    • Class javax.mail.AuthenticationFailedException extends MessagingException implements Serializable

      serialVersionUID:
      492080754054436511L

    • Class javax.mail.Flags extends Object implements Serializable

      serialVersionUID:
      6243590407214169028L

      • Serialized Fields

        • system_flags

          int system_flags

        • user_flags

          Hashtable<K,V> user_flags

    • Class javax.mail.FolderClosedException extends MessagingException implements Serializable

      serialVersionUID:
      1687879213433302315L

    • Class javax.mail.FolderNotFoundException extends MessagingException implements Serializable

      serialVersionUID:
      472612108891249403L

    • Class javax.mail.IllegalWriteException extends MessagingException implements Serializable

      serialVersionUID:
      3974370223328268013L

    • Class javax.mail.Message.RecipientType extends Object implements Serializable

      serialVersionUID:
      -7479791750606340008L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws ObjectStreamException
          When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class. Subclasses must implement their own readResolve method that checks for their known instances before calling this super method.
          Throws:
          ObjectStreamException

      • Serialized Fields

        • type

          String type
          The type of recipient, usually the name of a corresponding Internet standard header.

    • Class javax.mail.MessageRemovedException extends MessagingException implements Serializable

      serialVersionUID:
      1951292550679528690L

    • Class javax.mail.MessagingException extends Exception implements Serializable

      serialVersionUID:
      -7569192289819959253L

      • Serialized Fields

        • next

          Exception next
          The next exception in the chain.

    • Class javax.mail.MethodNotSupportedException extends MessagingException implements Serializable

      serialVersionUID:
      -3757386618726131322L

    • Class javax.mail.NoSuchProviderException extends MessagingException implements Serializable

      serialVersionUID:
      8058319293154708827L

    • Class javax.mail.ReadOnlyFolderException extends MessagingException implements Serializable

      serialVersionUID:
      5711829372799039325L

    • Class javax.mail.SendFailedException extends MessagingException implements Serializable

      serialVersionUID:
      -6457531621682372913L

    • Class javax.mail.StoreClosedException extends MessagingException implements Serializable

      serialVersionUID:
      -3145392336120082655L

  • Package javax.mail.event

    • Class javax.mail.event.ConnectionEvent extends MailEvent implements Serializable

      serialVersionUID:
      -1855480171284792957L

      • Serialized Fields

        • type

          int type
          The event type.

    • Class javax.mail.event.FolderEvent extends MailEvent implements Serializable

      serialVersionUID:
      5278131310563694307L

      • Serialized Fields

        • type

          int type
          The event type.

    • Class javax.mail.event.MailEvent extends EventObject implements Serializable

      serialVersionUID:
      1846275636325456631L

    • Class javax.mail.event.MessageChangedEvent extends MailEvent implements Serializable

      serialVersionUID:
      -4974972972105535108L

      • Serialized Fields

        • type

          int type
          The event type.

    • Class javax.mail.event.MessageCountEvent extends MailEvent implements Serializable

      serialVersionUID:
      -7447022340837897369L

      • Serialized Fields

        • type

          int type
          The event type.

        • removed

          boolean removed
          If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this. If false, this event is the result of an expunge by external sources.

    • Class javax.mail.event.StoreEvent extends MailEvent implements Serializable

      serialVersionUID:
      1938704919992515330L

      • Serialized Fields

        • type

          int type
          The event type.

        • message

          String message
          The message text to be presented to the user.

    • Class javax.mail.event.TransportEvent extends MailEvent implements Serializable

      serialVersionUID:
      -4729852364684273073L

      • Serialized Fields

        • type

          int type
          The event type.

  • Package javax.mail.internet

    • Class javax.mail.internet.AddressException extends ParseException implements Serializable

      serialVersionUID:
      9134583443539323120L

      • Serialized Fields

        • ref

          String ref
          The string being parsed.

        • pos

          int pos
          The index in the string where the error occurred, or -1 if not known.

    • Class javax.mail.internet.InternetAddress extends Address implements Serializable

      serialVersionUID:
      -7507595530758302903L

      • Serialized Fields

        • address

          String address

        • personal

          String personal
          The personal name.

        • encodedPersonal

          String encodedPersonal
          The RFC 2047 encoded version of the personal name.

          This field and the personal field track each other, so if a subclass sets one of these fields directly, it should set the other to null, so that it is suitably recomputed.

    • Class javax.mail.internet.MailDateFormat extends SimpleDateFormat implements Serializable

      serialVersionUID:
      -8148227605210628779L

    • Class javax.mail.internet.MimeMessage.RecipientType extends Message.RecipientType implements Serializable

      serialVersionUID:
      -5468290701714395543L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws ObjectStreamException
          Throws:
          ObjectStreamException

    • Class javax.mail.internet.NewsAddress extends Address implements Serializable

      serialVersionUID:
      -4203797299824684143L

      • Serialized Fields

        • newsgroup

          String newsgroup

        • host

          String host

    • Class javax.mail.internet.ParseException extends MessagingException implements Serializable

      serialVersionUID:
      7649991205183658089L

  • Package javax.mail.search

    • Class javax.mail.search.AddressStringTerm extends StringTerm implements Serializable

      serialVersionUID:
      3086821234204980368L

    • Class javax.mail.search.AddressTerm extends SearchTerm implements Serializable

      serialVersionUID:
      2005405551929769980L

      • Serialized Fields

        • address

          Address address
          The address.

    • Class javax.mail.search.AndTerm extends SearchTerm implements Serializable

      serialVersionUID:
      -3583274505380989582L

      • Serialized Fields

        • terms

          SearchTerm[] terms
          The array of terms on which the AND operator should be applied.

    • Class javax.mail.search.BodyTerm extends StringTerm implements Serializable

      serialVersionUID:
      -4888862527916911385L

    • Class javax.mail.search.ComparisonTerm extends SearchTerm implements Serializable

      serialVersionUID:
      1456646953666474308L

      • Serialized Fields

        • comparison

          int comparison
          The comparison.

    • Class javax.mail.search.DateTerm extends ComparisonTerm implements Serializable

      serialVersionUID:
      4818873430063720043L

      • Serialized Fields

        • date

          Date date
          The date.

    • Class javax.mail.search.FlagTerm extends SearchTerm implements Serializable

      serialVersionUID:
      -142991500302030647L

      • Serialized Fields

        • set

          boolean set
          Indicates whether to test for the presence or absence of the specified Flag. If true, then test whether all the specified flags are present, else test whether all the specified flags are absent.

        • flags

          Flags flags
          Flags object containing the flags to test.

    • Class javax.mail.search.FromStringTerm extends AddressStringTerm implements Serializable

      serialVersionUID:
      5801127523826772788L

    • Class javax.mail.search.FromTerm extends AddressTerm implements Serializable

      serialVersionUID:
      5214730291502658665L

    • Class javax.mail.search.HeaderTerm extends StringTerm implements Serializable

      serialVersionUID:
      8342514650333389122L

      • Serialized Fields

        • headerName

          String headerName
          The name of the header.

    • Class javax.mail.search.IntegerComparisonTerm extends ComparisonTerm implements Serializable

      serialVersionUID:
      -6963571240154302484L

      • Serialized Fields

        • number

          int number
          The number.

    • Class javax.mail.search.MessageIDTerm extends StringTerm implements Serializable

      serialVersionUID:
      -2121096296454691963L

    • Class javax.mail.search.MessageNumberTerm extends IntegerComparisonTerm implements Serializable

      serialVersionUID:
      -5379625829658623812L

    • Class javax.mail.search.NotTerm extends SearchTerm implements Serializable

      serialVersionUID:
      7152293214217310216L

      • Serialized Fields

        • term

          SearchTerm term
          The search term to negate.

    • Class javax.mail.search.OrTerm extends SearchTerm implements Serializable

      serialVersionUID:
      5380534067523646936L

      • Serialized Fields

        • terms

          SearchTerm[] terms
          The array of terms on which the OR operator should be applied.

    • Class javax.mail.search.ReceivedDateTerm extends DateTerm implements Serializable

      serialVersionUID:
      -2756695246195503170L

    • Class javax.mail.search.RecipientStringTerm extends AddressStringTerm implements Serializable

      serialVersionUID:
      -8293562089611618849L

      • Serialized Fields

        • type

          Message.RecipientType type
          The recipient type.

    • Class javax.mail.search.RecipientTerm extends AddressTerm implements Serializable

      serialVersionUID:
      6548700653122680468L

      • Serialized Fields

        • type

          Message.RecipientType type
          The recipient type.

    • Class javax.mail.search.SearchException extends MessagingException implements Serializable

      serialVersionUID:
      -7092886778226268686L

    • Class javax.mail.search.SearchTerm extends Object implements Serializable

      serialVersionUID:
      -6652358452205992789L

    • Class javax.mail.search.SentDateTerm extends DateTerm implements Serializable

      serialVersionUID:
      5647755030530907263L

    • Class javax.mail.search.SizeTerm extends IntegerComparisonTerm implements Serializable

      serialVersionUID:
      -2556219451005103709L

    • Class javax.mail.search.StringTerm extends SearchTerm implements Serializable

      serialVersionUID:
      1274042129007696269L

      • Serialized Fields

        • pattern

          String pattern
          The pattern.

        • ignoreCase

          boolean ignoreCase
          Ignore case when comparing?

    • Class javax.mail.search.SubjectTerm extends StringTerm implements Serializable

      serialVersionUID:
      7481568618055573432L

  • Package javax.management.j2ee

  • Package javax.persistence

    • Class javax.persistence.EntityExistsException extends PersistenceException implements Serializable

    • Class javax.persistence.EntityNotFoundException extends PersistenceException implements Serializable

    • Class javax.persistence.LockTimeoutException extends PersistenceException implements Serializable

      • Serialized Fields

        • entity

          Object entity
          The object that caused the exception

    • Class javax.persistence.NonUniqueResultException extends PersistenceException implements Serializable

    • Class javax.persistence.NoResultException extends PersistenceException implements Serializable

    • Class javax.persistence.OptimisticLockException extends PersistenceException implements Serializable

      • Serialized Fields

        • entity

          Object entity
          The object that caused the exception

    • Class javax.persistence.PersistenceException extends RuntimeException implements Serializable

    • Class javax.persistence.PessimisticLockException extends PersistenceException implements Serializable

      • Serialized Fields

        • entity

          Object entity
          The object that caused the exception

    • Class javax.persistence.QueryTimeoutException extends PersistenceException implements Serializable

      • Serialized Fields

        • query

          Query query
          The query object that caused the exception

    • Class javax.persistence.RollbackException extends PersistenceException implements Serializable

    • Class javax.persistence.TransactionRequiredException extends PersistenceException implements Serializable

  • Package javax.resource

    • Class javax.resource.NotSupportedException extends ResourceException implements Serializable

    • Class javax.resource.ResourceException extends Exception implements Serializable

      • Serialized Fields

        • errorCode

          String errorCode
          Vendor specific error code

        • linkedException

          Exception linkedException
          reference to another exception

  • Package javax.resource.cci

    • Class javax.resource.cci.ResourceWarning extends ResourceException implements Serializable

  • Package javax.resource.spi

    • Class javax.resource.spi.ApplicationServerInternalException extends ResourceException implements Serializable

    • Class javax.resource.spi.CommException extends ResourceException implements Serializable

    • Class javax.resource.spi.ConnectionEvent extends EventObject implements Serializable

      • Serialized Fields

        • exception

          Exception exception
          Exception associated with the ConnectionEvent instance.

        • id

          int id
          Type of the event

        • connectionHandle

          Object connectionHandle

    • Class javax.resource.spi.EISSystemException extends ResourceException implements Serializable

    • Class javax.resource.spi.IllegalStateException extends ResourceException implements Serializable

    • Class javax.resource.spi.InvalidPropertyException extends ResourceException implements Serializable

      • Serialized Fields

        • invalidProperties

          PropertyDescriptor[] invalidProperties

    • Class javax.resource.spi.LocalTransactionException extends ResourceException implements Serializable

    • Class javax.resource.spi.ResourceAdapterInternalException extends ResourceException implements Serializable

    • Class javax.resource.spi.ResourceAllocationException extends ResourceException implements Serializable

    • Class javax.resource.spi.RetryableUnavailableException extends UnavailableException implements Serializable

      serialVersionUID:
      3730185319227786830L

    • Class javax.resource.spi.SecurityException extends ResourceException implements Serializable

    • Class javax.resource.spi.SharingViolationException extends ResourceException implements Serializable

    • Class javax.resource.spi.UnavailableException extends ResourceException implements Serializable

  • Package javax.resource.spi.security

    • Class javax.resource.spi.security.PasswordCredential extends Object implements Serializable

      • Serialized Fields

        • userName

          String userName

        • password

          char[] password

        • mcf

          ManagedConnectionFactory mcf

  • Package javax.resource.spi.work

    • Class javax.resource.spi.work.HintsContext extends Object implements Serializable

      serialVersionUID:
      7956353628297167255L

      • Serialized Fields

        • description

          String description

        • name

          String name

        • hints

          Map<K,V> hints

    • Class javax.resource.spi.work.RetryableWorkRejectedException extends WorkRejectedException implements Serializable

      serialVersionUID:
      8198870267352154108L

    • Class javax.resource.spi.work.SecurityContext extends Object implements Serializable

      serialVersionUID:
      7730296651802712658L

    • Class javax.resource.spi.work.TransactionContext extends ExecutionContext implements Serializable

      serialVersionUID:
      6205067498708597824L

    • Class javax.resource.spi.work.WorkCompletedException extends WorkException implements Serializable

    • Class javax.resource.spi.work.WorkEvent extends EventObject implements Serializable

      • Serialized Fields

        • type

          int type
          The event type.

        • work

          Work work
          The Work object on which the event occured.

        • exc

          WorkException exc
          The exception that occured during Work processing.

        • startDuration

          long startDuration
          The start delay duration (in milliseconds).

    • Class javax.resource.spi.work.WorkException extends ResourceException implements Serializable

    • Class javax.resource.spi.work.WorkRejectedException extends WorkException implements Serializable

  • Package javax.security.auth.message

    • Class javax.security.auth.message.AuthException extends LoginException implements Serializable

      serialVersionUID:
      -1156951780670243758L

  • Package javax.security.jacc

    • Class javax.security.jacc.EJBMethodPermission extends Permission implements Serializable

      serialVersionUID:
      1L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.
          Throws:
          IOException

      • Serialization Overview

        • The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

      • Serialized Fields

        • actions

          String actions
          the canonicalized actions string (as returned by getActions).

    • Class javax.security.jacc.EJBRoleRefPermission extends Permission implements Serializable

      serialVersionUID:
      1L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.
          Throws:
          IOException

      • Serialization Overview

        • The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

      • Serialized Fields

        • actions

          String actions
          the canonicalized actions string (as returned by getActions).

    • Class javax.security.jacc.PolicyContextException extends Exception implements Serializable

    • Class javax.security.jacc.WebResourcePermission extends Permission implements Serializable

      serialVersionUID:
      1L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.
          Throws:
          IOException

      • Serialization Overview

        • The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

      • Serialized Fields

        • actions

          String actions
          the canonicalized actions string (as returned by getActions).

    • Class javax.security.jacc.WebRoleRefPermission extends Permission implements Serializable

      serialVersionUID:
      1L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.
          Throws:
          IOException

      • Serialization Overview

        • The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

      • Serialized Fields

        • actions

          String actions
          the canonicalized actions string (as returned by getActions).

    • Class javax.security.jacc.WebUserDataPermission extends Permission implements Serializable

      serialVersionUID:
      1L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.
          Throws:
          IOException

      • Serialization Overview

        • The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

      • Serialized Fields

        • actions

          String actions
          the canonicalized actions string (as returned by getActions).

  • Package javax.servlet

    • Class javax.servlet.GenericServlet extends Object implements Serializable

    • Class javax.servlet.ServletContextAttributeEvent extends ServletContextEvent implements Serializable

      serialVersionUID:
      -5804680734245618303L

      • Serialized Fields

        • name

          String name

        • value

          Object value

    • Class javax.servlet.ServletContextEvent extends EventObject implements Serializable

      serialVersionUID:
      -7501701636134222423L

    • Class javax.servlet.ServletException extends Exception implements Serializable

      • Serialized Fields

        • rootCause

          Throwable rootCause

    • Class javax.servlet.ServletRequestAttributeEvent extends ServletRequestEvent implements Serializable

      serialVersionUID:
      -1466635426192317793L

      • Serialized Fields

        • name

          String name

        • value

          Object value

    • Class javax.servlet.ServletRequestEvent extends EventObject implements Serializable

      serialVersionUID:
      -7467864054698729101L

    • Class javax.servlet.UnavailableException extends ServletException implements Serializable

      • Serialized Fields

        • servlet

          Servlet servlet

        • permanent

          boolean permanent

        • seconds

          int seconds

  • Package javax.servlet.http

    • Class javax.servlet.http.Cookie extends Object implements Serializable

      serialVersionUID:
      -6454587001725327448L

      • Serialized Fields

        • name

          String name

        • value

          String value

        • comment

          String comment

        • domain

          String domain

        • maxAge

          int maxAge

        • path

          String path

        • secure

          boolean secure

        • version

          int version

        • isHttpOnly

          boolean isHttpOnly

    • Class javax.servlet.http.HttpServlet extends GenericServlet implements Serializable

    • Class javax.servlet.http.HttpSessionBindingEvent extends HttpSessionEvent implements Serializable

      serialVersionUID:
      7308000419984825907L

      • Serialized Fields

        • name

          String name

        • value

          Object value

    • Class javax.servlet.http.HttpSessionEvent extends EventObject implements Serializable

      serialVersionUID:
      -7622791603672342895L

  • Package javax.servlet.jsp

    • Class javax.servlet.jsp.JspException extends Exception implements Serializable

    • Class javax.servlet.jsp.JspTagException extends JspException implements Serializable

    • Class javax.servlet.jsp.SkipPageException extends JspException implements Serializable

  • Package javax.servlet.jsp.el

    • Class javax.servlet.jsp.el.ELException extends Exception implements Serializable

      • Serialized Fields

        • mRootCause

          Throwable mRootCause
          Deprecated.

    • Class javax.servlet.jsp.el.ELParseException extends ELException implements Serializable

  • Package javax.servlet.jsp.jstl.core

    • Class javax.servlet.jsp.jstl.core.ConditionalTagSupport extends TagSupport implements Serializable

      • Serialized Fields

        • result

          boolean result

        • var

          String var

        • scope

          int scope

    • Class javax.servlet.jsp.jstl.core.IndexedValueExpression extends ValueExpression implements Serializable

      serialVersionUID:
      1L

      • Serialized Fields

        • i

          Integer i

        • orig

          ValueExpression orig

    • Class javax.servlet.jsp.jstl.core.IteratedValueExpression extends ValueExpression implements Serializable

      serialVersionUID:
      1L

      • Serialized Fields

        • i

          int i

        • iteratedExpression

          IteratedExpression iteratedExpression

    • Class javax.servlet.jsp.jstl.core.LoopTagSupport extends TagSupport implements Serializable

      • Serialized Fields

        • begin

          int begin
          Starting index ('begin' attribute)

        • end

          int end
          Ending index of the iteration ('end' attribute). A value of -1 internally indicates 'no end specified', although accessors for the core JSTL tags do not allow this value to be supplied directly by the user.

        • step

          int step
          Iteration step ('step' attribute)

        • beginSpecified

          boolean beginSpecified
          Boolean flag indicating whether 'begin' was specified.

        • endSpecified

          boolean endSpecified
          Boolean flag indicating whether 'end' was specified.

        • stepSpecified

          boolean stepSpecified
          Boolean flag indicating whether 'step' was specified.

        • itemId

          String itemId
          Attribute-exposing control

        • statusId

          String statusId
          Attribute-exposing control

        • deferredExpression

          ValueExpression deferredExpression
          The deferred expression if any

        • oldMappedValue

          ValueExpression oldMappedValue
          A temporary used to hold the previous value (from the enclosing iteration tag) for the EL variable.

        • status

          LoopTagStatus status

        • item

          Object item

        • index

          int index

        • count

          int count

        • last

          boolean last

        • iteratedExpression

          IteratedExpression iteratedExpression

  • Package javax.servlet.jsp.tagext

    • Class javax.servlet.jsp.tagext.BodyTagSupport extends TagSupport implements Serializable

      • Serialized Fields

        • bodyContent

          BodyContent bodyContent
          The current BodyContent for this BodyTag.

    • Class javax.servlet.jsp.tagext.TagSupport extends Object implements Serializable

      • Serialized Fields

        • parent

          Tag parent

        • values

          Hashtable<K,V> values

        • id

          String id
          The value of the id attribute of this tag; or null.

        • pageContext

          PageContext pageContext
          The PageContext.

  • Package javax.transaction

    • Class javax.transaction.HeuristicCommitException extends Exception implements Serializable

    • Class javax.transaction.HeuristicMixedException extends Exception implements Serializable

    • Class javax.transaction.HeuristicRollbackException extends Exception implements Serializable

    • Class javax.transaction.InvalidTransactionException extends RemoteException implements Serializable

    • Class javax.transaction.NotSupportedException extends Exception implements Serializable

    • Class javax.transaction.RollbackException extends Exception implements Serializable

    • Class javax.transaction.SystemException extends Exception implements Serializable

      • Serialized Fields

        • errorCode

          int errorCode
          The error code with which to create the SystemException.
          The error code for the exception

    • Class javax.transaction.TransactionalException extends RuntimeException implements Serializable

    • Class javax.transaction.TransactionRequiredException extends RemoteException implements Serializable

    • Class javax.transaction.TransactionRolledbackException extends RemoteException implements Serializable

  • Package javax.transaction.xa

    • Class javax.transaction.xa.XAException extends Exception implements Serializable

      • Serialized Fields

        • errorCode

          int errorCode
          The error code with which to create the SystemException.
          The error code for the exception.

  • Package javax.validation

    • Class javax.validation.ConstraintDeclarationException extends ValidationException implements Serializable

    • Class javax.validation.ConstraintDefinitionException extends ValidationException implements Serializable

    • Class javax.validation.ConstraintViolationException extends ValidationException implements Serializable

      • Serialized Fields

        • constraintViolations

          Set<E> constraintViolations

    • Class javax.validation.GroupDefinitionException extends ValidationException implements Serializable

    • Class javax.validation.UnexpectedTypeException extends ConstraintDeclarationException implements Serializable

    • Class javax.validation.ValidationException extends RuntimeException implements Serializable

  • Package javax.websocket

    • Class javax.websocket.DecodeException extends Exception implements Serializable

      serialVersionUID:
      6L

      • Serialized Fields

        • bb

          ByteBuffer bb

        • encodedString

          String encodedString

    • Class javax.websocket.DeploymentException extends Exception implements Serializable

    • Class javax.websocket.EncodeException extends Exception implements Serializable

      serialVersionUID:
      6L

      • Serialized Fields

        • object

          Object object

    • Class javax.websocket.SessionException extends Exception implements Serializable

      serialVersionUID:
      12L

      • Serialized Fields

        • session

          Session session

  • Package javax.ws.rs

    • Class javax.ws.rs.BadRequestException extends ClientErrorException implements Serializable

      serialVersionUID:
      7264647684649480265L

    • Class javax.ws.rs.ClientErrorException extends WebApplicationException implements Serializable

      serialVersionUID:
      -4101970664444907990L

    • Class javax.ws.rs.ForbiddenException extends ClientErrorException implements Serializable

      serialVersionUID:
      -2740045367479165061L

    • Class javax.ws.rs.InternalServerErrorException extends ServerErrorException implements Serializable

      serialVersionUID:
      -6515710697540553309L

    • Class javax.ws.rs.NotAcceptableException extends ClientErrorException implements Serializable

      serialVersionUID:
      -1476163816796529078L

    • Class javax.ws.rs.NotAllowedException extends ClientErrorException implements Serializable

      serialVersionUID:
      -586776054369626119L

    • Class javax.ws.rs.NotAuthorizedException extends ClientErrorException implements Serializable

      serialVersionUID:
      -3156040750581929702L

    • Class javax.ws.rs.NotFoundException extends ClientErrorException implements Serializable

      serialVersionUID:
      -6820866117511628388L

    • Class javax.ws.rs.NotSupportedException extends ClientErrorException implements Serializable

      serialVersionUID:
      -8286622745725405656L

    • Class javax.ws.rs.ProcessingException extends RuntimeException implements Serializable

      serialVersionUID:
      -4232431597816056514L

    • Class javax.ws.rs.RedirectionException extends WebApplicationException implements Serializable

      serialVersionUID:
      -2584325408291098012L

    • Class javax.ws.rs.ServerErrorException extends WebApplicationException implements Serializable

      serialVersionUID:
      4730895276505569556L

    • Class javax.ws.rs.ServiceUnavailableException extends ServerErrorException implements Serializable

      serialVersionUID:
      3821068205617492633L

    • Class javax.ws.rs.WebApplicationException extends RuntimeException implements Serializable

      serialVersionUID:
      8273970399584007146L

      • Serialized Fields

        • response

          Response response

  • Package javax.ws.rs.client

    • Class javax.ws.rs.client.ResponseProcessingException extends ProcessingException implements Serializable

      serialVersionUID:
      -4923161617935731839L

      • Serialized Fields

        • response

          Response response

  • Package javax.ws.rs.core

    • Class javax.ws.rs.core.MultivaluedHashMap extends AbstractMultivaluedMap<K,V> implements Serializable

      serialVersionUID:
      -6052320403766368902L

    • Class javax.ws.rs.core.NoContentException extends IOException implements Serializable

      serialVersionUID:
      -3082577759787473245L

    • Class javax.ws.rs.core.UriBuilderException extends RuntimeException implements Serializable

      serialVersionUID:
      956255913370721193L

  • Package javax.xml.bind

    • Class javax.xml.bind.DataBindingException extends RuntimeException implements Serializable

    • Class javax.xml.bind.JAXBElement extends Object implements Serializable

      serialVersionUID:
      1L

      • Serialized Fields

        • name

          QName name
          xml element tag name

        • declaredType

          Class<T> declaredType
          Java datatype binding for xml element declaration's type.

        • scope

          Class<T> scope
          Scope of xml element declaration representing this xml element instance. Can be one of the following values: - JAXBElement.GlobalScope for global xml element declaration. - local element declaration has a scope set to the Java class representation of complex type defintion containing xml element declaration.

        • value

          Object value
          xml element value. Represents content model and attributes of an xml element instance.

        • nil

          boolean nil
          true iff the xml element instance has xsi:nil="true".

    • Class javax.xml.bind.JAXBException extends Exception implements Serializable

      serialVersionUID:
      -5621384651494307979L

      • Serialized Fields

        • errorCode

          String errorCode
          Vendor specific error code

        • linkedException

          Throwable linkedException
          Exception reference

    • Class javax.xml.bind.JAXBPermission extends BasicPermission implements Serializable

      serialVersionUID:
      1L

    • Class javax.xml.bind.MarshalException extends JAXBException implements Serializable

    • Class javax.xml.bind.PropertyException extends JAXBException implements Serializable

    • Class javax.xml.bind.TypeConstraintException extends RuntimeException implements Serializable

      • Serialized Fields

        • errorCode

          String errorCode
          Vendor specific error code

        • linkedException

          Throwable linkedException
          Exception reference

    • Class javax.xml.bind.UnmarshalException extends JAXBException implements Serializable

    • Class javax.xml.bind.ValidationException extends JAXBException implements Serializable

  • Package javax.xml.registry

    • Class javax.xml.registry.DeleteException extends RegistryException implements Serializable

    • Class javax.xml.registry.FindException extends RegistryException implements Serializable

    • Class javax.xml.registry.InvalidRequestException extends JAXRException implements Serializable

    • Class javax.xml.registry.JAXRException extends Exception implements Serializable

      • Serialized Fields

        • cause

          Throwable cause
          The Throwable that caused this JAXRException to occur. This is used when a JAXRException has a nested Throwable.

    • Class javax.xml.registry.RegistryException extends JAXRException implements Serializable

      • Serialized Fields

        • errorObjectKey

          Key errorObjectKey

    • Class javax.xml.registry.SaveException extends RegistryException implements Serializable

    • Class javax.xml.registry.UnexpectedObjectException extends JAXRException implements Serializable

    • Class javax.xml.registry.UnsupportedCapabilityException extends JAXRException implements Serializable

  • Package javax.xml.rpc

    • Class javax.xml.rpc.JAXRPCException extends RuntimeException implements Serializable

      • Serialized Fields

        • cause

          Throwable cause

    • Class javax.xml.rpc.ServiceException extends Exception implements Serializable

      • Serialized Fields

        • cause

          Throwable cause

  • Package javax.xml.rpc.encoding

  • Package javax.xml.rpc.handler

    • Class javax.xml.rpc.handler.HandlerInfo extends Object implements Serializable

      • Serialized Fields

        • handlerClass

          Class<T> handlerClass

        • config

          Map<K,V> config

        • headers

          Vector<E> headers

  • Package javax.xml.rpc.soap

    • Class javax.xml.rpc.soap.SOAPFaultException extends RuntimeException implements Serializable

      • Serialized Fields

        • faultcode

          QName faultcode

        • faultstring

          String faultstring

        • faultactor

          String faultactor

        • detail

          Detail detail

  • Package javax.xml.soap

    • Class javax.xml.soap.SOAPException extends Exception implements Serializable

      • Serialized Fields

        • cause

          Throwable cause

  • Package javax.xml.ws

    • Class javax.xml.ws.Holder extends Object implements Serializable

      serialVersionUID:
      2623699057546497185L

      • Serialized Fields

        • value

          Object value
          The value contained in the holder.

    • Class javax.xml.ws.ProtocolException extends WebServiceException implements Serializable

    • Class javax.xml.ws.WebServiceException extends RuntimeException implements Serializable

    • Class javax.xml.ws.WebServicePermission extends BasicPermission implements Serializable

      serialVersionUID:
      -146474640053770988L

  • Package javax.xml.ws.http

    • Class javax.xml.ws.http.HTTPException extends ProtocolException implements Serializable

      • Serialized Fields

        • statusCode

          int statusCode

  • Package javax.xml.ws.soap

    • Class javax.xml.ws.soap.SOAPFaultException extends ProtocolException implements Serializable

      • Serialized Fields

        • fault

          SOAPFault fault
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


API Help (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

  • Overview

    The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

  • Package

    Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain six categories:

    • Interfaces (italic)
    • Classes
    • Enums
    • Exceptions
    • Errors
    • Annotation Types

  • Class/Interface

    Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

    • Class inheritance diagram
    • Direct Subclasses
    • All Known Subinterfaces
    • All Known Implementing Classes
    • Class/interface declaration
    • Class/interface description
    • Nested Class Summary
    • Field Summary
    • Constructor Summary
    • Method Summary
    • Field Detail
    • Constructor Detail
    • Method Detail

    Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

  • Annotation Type

    Each annotation type has its own separate page with the following sections:

    • Annotation Type declaration
    • Annotation Type description
    • Required Element Summary
    • Optional Element Summary
    • Element Detail

  • Enum

    Each enum has its own separate page with the following sections:

    • Enum declaration
    • Enum description
    • Enum Constant Summary
    • Enum Constant Detail

  • Use

    Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

  • Tree (Class Hierarchy)

    There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.

    • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
    • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

  • Deprecated API

    The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

  • Index

    The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

  • Prev/Next

    These links take you to the next or previous class, interface, package, or related page.

  • Frames/No Frames

    These links show and hide the HTML frames. All pages are available with or without frames.

  • All Classes

    The All Classes link shows all classes and interfaces except non-static nested types.

  • Serialized Form

    Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

  • Constant Field Values

    The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Specification License

 Specification: JSR 342: JavaTM Platform, Enterprise Edition 7 (Java EE 7)
Version: 7.0
Status: Early Draft Review
Release: 25 May 2013

Copyright © 2013 Oracle America, Inc.
500 Oracle Parkway
Redwood City, California 94065, U.S.A.

All rights reserved.

NOTICE
The Specification is protected by copyright and the information described therein may be protected by one or more U.S. patents, foreign patents, or pending applications. Except as provided under the following license, no part of the Specification may be reproduced in any form by any means without the prior written authorization of Oracle America, Inc. ("Oracle") and its licensors, if any. Any use of the Specification and the information described therein will be governed by the terms and conditions of this Agreement.

Subject to the terms and conditions of this license, including your compliance with Paragraphs 1 and 2 below, Oracle hereby grants you a fully-paid, non-exclusive, non-transferable, limited license (without the right to sublicense) under Oracle's intellectual property rights to:
1.Review the Specification for the purposes of evaluation. This includes: (i) developing implementations of the Specification for your internal, non-commercial use; (ii) discussing the Specification with any third party; and (iii) excerpting brief portions of the Specification in oral or written communications which discuss the Specification provided that such excerpts do not in the aggregate constitute a significant portion of the Technology.
2.Distribute implementations of the Specification to third parties for their testing and evaluation use, provided that any such implementation:
(i) does not modify, subset, superset or otherwise extend the Licensor Name Space, or include any public or protected packages, classes, Java interfaces, fields or methods within the Licensor Name Space other than those required/authorized by the Specification or Specifications being implemented;
(ii) is clearly and prominently marked with the word "UNTESTED" or "EARLY ACCESS" or "INCOMPATIBLE" or "UNSTABLE" or "BETA" in any list of available builds and in proximity to every link initiating its download, where the list or link is under Licensee's control; and
(iii) includes the following notice:
"This is an implementation of an early-draft specification developed under the Java Community Process (JCP) and is made available for testing and evaluation purposes only. The code is not compatible with any specification of the JCP."

The grant set forth above concerning your distribution of implementations of the specification is contingent upon your agreement to terminate development and distribution of your "early draft" implementation as soon as feasible following final completion of the specification. If you fail to do so, the foregoing grant shall be considered null and void.

No provision of this Agreement shall be understood to restrict your ability to make and distribute to third parties applications written to the Specification.

Other than this limited license, you acquire no right, title or interest in or to the Specification or any other Oracle intellectual property, and the Specification may only be used in accordance with the license terms set forth herein. This license will expire on the earlier of: (a) two (2) years from the date of Release listed above; (b) the date on which the final version of the Specification is publicly released; or (c) the date on which the Java Specification Request (JSR) to which the Specification corresponds is withdrawn. In addition, this license will terminate immediately without notice from Oracle if you fail to comply with any provision of this license. Upon termination, you must cease use of or destroy the Specification.

"Licensor Name Space" means the public class or interface declarations whose names begin with "java", "javax", "com.oracle" or their equivalents in any subsequent naming convention adopted by Oracle through the Java Community Process, or any recognized successors or replacements thereof

TRADEMARKS
No right, title, or interest in or to any trademarks, service marks, or trade names of Oracle or Oracle's licensors is granted hereunder. Oracle, the Oracle logo, Java are trademarks or registered trademarks of Oracle USA, Inc. in the U.S. and other countries.

DISCLAIMER OF WARRANTIES
THE SPECIFICATION IS PROVIDED "AS IS" AND IS EXPERIMENTAL AND MAY CONTAIN DEFECTS OR DEFICIENCIES WHICH CANNOT OR WILL NOT BE CORRECTED BY ORACLE. ORACLE MAKES NO REPRESENTATIONS OR WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO, WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT THAT THE CONTENTS OF THE SPECIFICATION ARE

SUITABLE FOR ANY PURPOSE OR THAT ANY PRACTICE OR IMPLEMENTATION OF SUCH CONTENTS WILL NOT INFRINGE ANY THIRD PARTY PATENTS, COPYRIGHTS, TRADE SECRETS OR OTHER RIGHTS. This document does not represent any commitment to release or implement any portion of the Specification in any product.

THE SPECIFICATION COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION THEREIN; THESE CHANGES WILL BE INCORPORATED INTO NEW VERSIONS OF THE SPECIFICATION, IF ANY. ORACLE MAY MAKE IMPROVEMENTS AND/OR CHANGES TO THE PRODUCT(S) AND/OR THE PROGRAM(S) DESCRIBED IN THE SPECIFICATION AT ANY TIME. Any use of such changes in the Specification will be governed by the then-current license for the applicable version of the Specification.

LIMITATION OF LIABILITY
TO THE EXTENT NOT PROHIBITED BY LAW, IN NO EVENT WILL ORACLE OR ITS LICENSORS BE LIABLE FOR ANY DAMAGES, INCLUDING WITHOUT LIMITATION, LOST REVENUE, PROFITS OR DATA, OR FOR SPECIAL, INDIRECT, CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF OR RELATED TO ANY FURNISHING, PRACTICING, MODIFYING OR ANY USE OF THE SPECIFICATION, EVEN IF ORACLE AND/OR ITS LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

You will hold Oracle (and its licensors) harmless from any claims based on your use of the Specification for any purposes other than the limited right of evaluation as described above, and from any claims that later versions or releases of any Specification furnished to you are incompatible with the Specification provided to you under this license.

RESTRICTED RIGHTS LEGEND
If this Software is being acquired by or on behalf of the U.S. Government or by a U.S. Government prime contractor or subcontractor (at any tier), then the Government's rights in the Software and accompanying documentation shall be only as set forth in this license; this is in accordance with 48 C.F.R. 227.7201 through 227.7202-4 (for Department of Defense (DoD) acquisitions) and with 48 C.F.R. 2.101 and 12.212 (for non-DoD acquisitions).

REPORT
You may wish to report any ambiguities, inconsistencies or inaccuracies you may find in connection with your evaluation of the Specification ("Feedback"). To the extent that you provide Oracle with any Feedback, you hereby: (i) agree that such Feedback is provided on a non-proprietary and non-confidential basis, and (ii) grant Oracle a perpetual, non-exclusive, worldwide, fully paid-up, irrevocable license, with the right to sublicense through multiple levels of sublicensees, to incorporate, disclose, and use without limitation the Feedback for any purpose related to the Specification and future versions, implementations, and test suites thereof.

GENERAL TERMS
Any action related to this Agreement will be governed by California law and controlling U.S. federal law. The U.N. Convention for the International Sale of Goods and the choice of law rules of any jurisdiction will not apply.

The Specification is subject to U.S. export control laws and may be subject to export or import regulations in other countries. Licensee agrees to comply strictly with all such laws and regulations and acknowledges that it has the responsibility to obtain such licenses to export, re-export or import as may be required after delivery to Licensee.

This Agreement is the parties' entire agreement relating to its subject matter. It supersedes all prior or contemporaneous oral or written communications, proposals, conditions, representations and warranties and prevails over any conflicting or additional terms of any quote, order, acknowledgment, or other communication between the parties relating to its subject matter during the term of this Agreement. No modification to this Agreement will be binding, unless in writing and signed by an authorized representative of each party.


All Classes (Java(TM) EE 7 Specification APIs)

All Classes

  • AbortedException
  • AbortProcessingException
  • AbstractBatchlet
  • AbstractCheckpointAlgorithm
  • AbstractChunkListener
  • AbstractItemProcessListener
  • AbstractItemReader
  • AbstractItemReadListener
  • AbstractItemWriteListener
  • AbstractItemWriter
  • AbstractJobListener
  • AbstractMarshallerImpl
  • AbstractMultivaluedMap
  • AbstractPartitionAnalyzer
  • AbstractPartitionReducer
  • AbstractQuery
  • AbstractStepListener
  • AbstractUnmarshallerImpl
  • Access
  • AccessLocalException
  • AccessTimeout
  • AccessType
  • Action
  • ActionEvent
  • ActionListener
  • ActionListenerWrapper
  • ActionSource
  • ActionSource2
  • ActionSource2AttachedObjectHandler
  • ActionSource2AttachedObjectTarget
  • ActionType
  • Activation
  • ActivationConfigProperty
  • ActivationSpec
  • Address
  • AddressException
  • Addressing
  • AddressingFeature
  • AddressingFeature.Responses
  • AddressStringTerm
  • AddressTerm
  • AdministeredObject
  • AdministeredObjectDefinition
  • AdministeredObjectDefinitions
  • AfterBeanDiscovery
  • AfterBegin
  • AfterCompletion
  • AfterDeploymentValidation
  • AfterTypeDiscovery
  • AjaxBehavior
  • AjaxBehaviorEvent
  • AjaxBehaviorListener
  • AlterableContext
  • Alternative
  • AmbiguousResolutionException
  • AndTerm
  • Annotated
  • AnnotatedCallable
  • AnnotatedConstructor
  • AnnotatedField
  • AnnotatedMember
  • AnnotatedMethod
  • AnnotatedParameter
  • AnnotatedType
  • AnnotationLiteral
  • Any
  • Application
  • Application
  • ApplicationConfigurationPopulator
  • ApplicationException
  • ApplicationFactory
  • ApplicationPath
  • ApplicationScoped
  • ApplicationScoped
  • ApplicationServerInternalException
  • ApplicationWrapper
  • AroundConstruct
  • AroundInvoke
  • AroundTimeout
  • ArrayDataModel
  • ArrayELResolver
  • AssertFalse
  • AssertFalse.List
  • AssertTrue
  • AssertTrue.List
  • Association
  • AssociationOverride
  • AssociationOverrides
  • AsyncContext
  • AsyncEvent
  • AsyncHandler
  • Asynchronous
  • AsyncInvoker
  • AsyncListener
  • AsyncResponse
  • AsyncResult
  • AttachedObjectHandler
  • AttachedObjectTarget
  • AttachmentMarshaller
  • AttachmentPart
  • AttachmentUnmarshaller
  • Attribute
  • Attribute.PersistentAttributeType
  • AttributeConverter
  • AttributeHandler
  • AttributeNode
  • AttributeOverride
  • AttributeOverrides
  • AttributeTag
  • AuditableEvent
  • AuthConfig
  • AuthConfigFactory
  • AuthConfigFactory.RegistrationContext
  • AuthConfigProvider
  • AuthenticationFailedException
  • AuthenticationMechanism
  • AuthenticationMechanism.CredentialInterface
  • Authenticator
  • AuthException
  • AuthStatus
  • BadRequestException
  • Basic
  • BasicType
  • Batchlet
  • BatchProperty
  • BatchRuntime
  • BatchRuntimeException
  • BatchStatus
  • Bean
  • BeanAttributes
  • BeanDescriptor
  • BeanELResolver
  • BeanManager
  • BeanNameELResolver
  • BeanNameResolver
  • BeanNotFoundException
  • BeanParam
  • BeanValidator
  • BeforeBeanDiscovery
  • BeforeCompletion
  • BeforeShutdown
  • Behavior
  • BehaviorBase
  • BehaviorConfig
  • BehaviorEvent
  • BehaviorHandler
  • BehaviorHolderAttachedObjectHandler
  • BehaviorHolderAttachedObjectTarget
  • BehaviorListener
  • BigDecimalConverter
  • BigDecimalHolder
  • BigIntegerConverter
  • BigIntegerHolder
  • Bindable
  • Bindable.BindableType
  • Binder
  • Binding
  • BindingProvider
  • BindingType
  • BodyContent
  • BodyPart
  • BodyTag
  • BodyTagSupport
  • BodyTerm
  • BooleanConverter
  • BooleanHolder
  • BooleanWrapperHolder
  • BootstrapConfiguration
  • BootstrapContext
  • BootstrapState
  • BoundaryStatistic
  • BoundedRangeStatistic
  • BulkResponse
  • BusinessLifeCycleManager
  • BusinessQueryManager
  • BusyConversationException
  • ByteArrayDataSource
  • ByteArrayHolder
  • ByteConverter
  • ByteHolder
  • BytesMessage
  • ByteWrapperHolder
  • Cache
  • Cacheable
  • CacheControl
  • CacheRetrieveMode
  • CacheStoreMode
  • CalendarHolder
  • Call
  • CallerPrincipalCallback
  • CapabilityProfile
  • CascadableDescriptor
  • CascadeType
  • CDI
  • CDIProvider
  • CertStoreCallback
  • CharacterConverter
  • CheckpointAlgorithm
  • ChunkListener
  • Classification
  • ClassificationScheme
  • ClassTransformer
  • Client
  • ClientAuth
  • ClientAuthConfig
  • ClientAuthContext
  • ClientAuthModule
  • ClientBehavior
  • ClientBehaviorBase
  • ClientBehaviorContext
  • ClientBehaviorContext.Parameter
  • ClientBehaviorHint
  • ClientBehaviorHolder
  • ClientBehaviorRenderer
  • ClientBuilder
  • ClientConfiguration
  • ClientEndpoint
  • ClientEndpointConfig
  • ClientEndpointConfig.Builder
  • ClientEndpointConfig.Configurator
  • ClientErrorException
  • ClientExecuteException
  • ClientRequestContext
  • ClientRequestFilter
  • ClientResponseContext
  • ClientResponseFilter
  • ClientWindow
  • ClientWindowFactory
  • ClientWindowWrapper
  • CloseReason
  • CloseReason.CloseCode
  • CloseReason.CloseCodes
  • CollapsedStringAdapter
  • CollectionAttribute
  • CollectionDataModel
  • CollectionJoin
  • CollectionTable
  • Column
  • ColumnResult
  • CommandType
  • CommException
  • CommonAbstractCriteria
  • ComparisonTerm
  • CompletionCallback
  • CompletionListener
  • ComponentConfig
  • ComponentHandler
  • ComponentSystemEvent
  • ComponentSystemEventListener
  • CompositeComponentExpressionHolder
  • CompositeELResolver
  • CompositeFaceletHandler
  • CompoundSelection
  • Concept
  • ConcurrencyManagement
  • ConcurrencyManagementType
  • ConcurrentAccessException
  • ConcurrentAccessTimeoutException
  • ConditionalTagSupport
  • Config
  • ConfigProperty
  • Configurable
  • ConfigurableNavigationHandler
  • ConfigurableNavigationHandlerWrapper
  • Configuration
  • Configuration
  • ConfigurationException
  • ConfigurationState
  • Connection
  • Connection
  • Connection
  • ConnectionAdapter
  • ConnectionCallback
  • ConnectionConsumer
  • ConnectionDefinition
  • ConnectionDefinitions
  • ConnectionEvent
  • ConnectionEvent
  • ConnectionEventListener
  • ConnectionFactory
  • ConnectionFactory
  • ConnectionFactory
  • ConnectionFactoryDefinition
  • ConnectionFactoryDefinitions
  • ConnectionListener
  • ConnectionManager
  • ConnectionMetaData
  • ConnectionMetaData
  • ConnectionRequestInfo
  • ConnectionSpec
  • Connector
  • ConstrainedTo
  • Constraint
  • ConstraintDeclarationException
  • ConstraintDefinitionException
  • ConstraintDescriptor
  • ConstraintMode
  • ConstraintTarget
  • ConstraintValidator
  • ConstraintValidatorContext
  • ConstraintValidatorContext.ConstraintViolationBuilder
  • ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext
  • ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext
  • ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder
  • ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext
  • ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext
  • ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder
  • ConstraintValidatorFactory
  • ConstraintViolation
  • ConstraintViolationException
  • ConstructorDescriptor
  • ConstructorResult
  • Consumes
  • ContainerProvider
  • ContainerRequestContext
  • ContainerRequestFilter
  • ContainerResponseContext
  • ContainerResponseFilter
  • ContentDisposition
  • ContentType
  • Context
  • Context
  • ContextCallback
  • ContextException
  • ContextNotActiveException
  • ContextResolver
  • ContextService
  • Contextual
  • Conversation
  • ConversationScoped
  • Convert
  • Converter
  • Converter
  • ConverterConfig
  • ConverterELTag
  • ConverterException
  • ConverterHandler
  • ConverterTag
  • ConvertGroup
  • ConvertGroup.List
  • Converts
  • Cookie
  • Cookie
  • CookieParam
  • CountStatistic
  • CreateException
  • CreationalContext
  • CreationException
  • CriteriaBuilder
  • CriteriaBuilder.Case
  • CriteriaBuilder.Coalesce
  • CriteriaBuilder.In
  • CriteriaBuilder.SimpleCase
  • CriteriaBuilder.Trimspec
  • CriteriaDelete
  • CriteriaQuery
  • CriteriaUpdate
  • CrossParameterDescriptor
  • CustomScoped
  • DataBindingException
  • DataModel
  • DataModelEvent
  • DataModelListener
  • DataSourceDefinition
  • DataSourceDefinitions
  • DatatypeConverter
  • DatatypeConverterInterface
  • DateTerm
  • DateTimeConverter
  • DConfigBean
  • DConfigBeanRoot
  • DConfigBeanVersionType
  • DConfigBeanVersionUnsupportedException
  • DDBean
  • DDBeanCreateException
  • DDBeanRoot
  • Decider
  • DecimalMax
  • DecimalMax.List
  • DecimalMin
  • DecimalMin.List
  • DeclarativeQueryManager
  • DeclareRoles
  • DecodeException
  • Decoder
  • Decoder.Binary
  • Decoder.BinaryStream
  • Decoder.Text
  • Decoder.TextStream
  • Decorated
  • Decorator
  • Decorator
  • Default
  • Default
  • DefaultValidationEventHandler
  • DefaultValue
  • DefinitionException
  • Delegate
  • DelegatingMetaTagHandler
  • DELETE
  • DeleteException
  • DeliveryMode
  • DenyAll
  • Dependent
  • DependsOn
  • DeployableObject
  • DeploymentConfiguration
  • DeploymentException
  • DeploymentException
  • DeploymentFactory
  • DeploymentFactoryManager
  • DeploymentManager
  • DeploymentManagerCreationException
  • DeploymentStatus
  • DeserializationContext
  • Deserializer
  • DeserializerFactory
  • Destination
  • Destroyed
  • Detail
  • DetailEntry
  • Digits
  • Digits.List
  • DiscriminatorColumn
  • DiscriminatorType
  • DiscriminatorValue
  • Dispatch
  • DispatcherType
  • Disposes
  • DissociatableManagedConnection
  • DistributableWork
  • DistributableWorkManager
  • DomHandler
  • DoubleConverter
  • DoubleHolder
  • DoubleRangeValidator
  • DoubleWrapperHolder
  • DuplicateKeyException
  • DynamicAttributes
  • DynamicFeature
  • EditableValueHolder
  • EditableValueHolderAttachedObjectHandler
  • EditableValueHolderAttachedObjectTarget
  • EISSystemException
  • EJB
  • EJBAccessException
  • EJBContainer
  • EJBContainerProvider
  • EJBContext
  • EJBException
  • EJBHome
  • EJBLocalHome
  • EJBLocalObject
  • EJBMetaData
  • EJBMethodPermission
  • EJBObject
  • EJBRoleRefPermission
  • EJBs
  • EJBStats
  • EJBTransactionRequiredException
  • EJBTransactionRolledbackException
  • ELClass
  • ELContext
  • ELContextEvent
  • ELContextListener
  • Element
  • ElementCollection
  • ElementDescriptor
  • ElementDescriptor.ConstraintFinder
  • ElementKind
  • ELException
  • ELException
  • ELManager
  • ELParseException
  • ELProcessor
  • ELResolver
  • EmailAddress
  • Embeddable
  • EmbeddableType
  • Embedded
  • EmbeddedId
  • Encoded
  • EncodeException
  • Encoder
  • Encoder.Binary
  • Encoder.BinaryStream
  • Encoder.Text
  • Encoder.TextStream
  • EncodingAware
  • Endpoint
  • Endpoint
  • EndpointConfig
  • EndpointContext
  • EndpointReference
  • EnterpriseBean
  • Entity
  • Entity
  • EntityBean
  • EntityBeanStats
  • EntityContext
  • EntityExistsException
  • EntityGraph
  • EntityListeners
  • EntityManager
  • EntityManagerFactory
  • EntityNotFoundException
  • EntityResult
  • EntityTag
  • EntityTransaction
  • EntityType
  • EnumConverter
  • Enumerated
  • EnumType
  • ErrorData
  • EvaluationException
  • EvaluationListener
  • Event
  • EventMetadata
  • ExceptionHandler
  • ExceptionHandlerFactory
  • ExceptionHandlerWrapper
  • ExceptionListener
  • ExceptionMapper
  • ExceptionQueuedEvent
  • ExceptionQueuedEventContext
  • ExcludeClassInterceptors
  • ExcludeDefaultInterceptors
  • ExcludeDefaultListeners
  • ExcludeSuperclassListeners
  • ExecutableDescriptor
  • ExecutableType
  • ExecutableValidator
  • ExecutionContext
  • Expression
  • Expression
  • Expression
  • ExpressionEvaluator
  • ExpressionFactory
  • ExtensibleObject
  • Extension
  • Extension
  • Extension.Parameter
  • ExternalContext
  • ExternalContextFactory
  • ExternalContextWrapper
  • ExternalIdentifier
  • ExternalLink
  • ExtrinsicObject
  • Facelet
  • FaceletCache
  • FaceletCache.MemberFactory
  • FaceletCacheFactory
  • FaceletContext
  • FaceletException
  • FaceletHandler
  • FaceletsAttachedObjectHandler
  • FaceletsResourceResolver
  • FacesBehavior
  • FacesBehaviorRenderer
  • FacesComponent
  • FacesContext
  • FacesContextFactory
  • FacesContextWrapper
  • FacesConverter
  • FacesEvent
  • FacesException
  • FacesListener
  • FacesMessage
  • FacesMessage.Severity
  • FacesRenderer
  • FacesServlet
  • FacesValidator
  • FacesWrapper
  • FacetHandler
  • FacetTag
  • FactoryFinder
  • FaultAction
  • Feature
  • FeatureContext
  • FederatedConnection
  • Fetch
  • FetchParent
  • FetchProfile
  • FetchProfile.Item
  • FetchType
  • FieldResult
  • Filter
  • FilterChain
  • FilterConfig
  • FilterRegistration
  • FilterRegistration.Dynamic
  • FinderException
  • FindException
  • FindQualifier
  • Flags
  • Flags.Flag
  • FlagTerm
  • Flash
  • FlashFactory
  • FlashWrapper
  • FloatConverter
  • FloatHolder
  • FloatWrapperHolder
  • Flow
  • FlowBuilder
  • FlowBuilderParameter
  • FlowCallBuilder
  • FlowCallNode
  • FlowDefinition
  • FlowHandler
  • FlowHandlerFactory
  • FlowHandlerFactoryWrapper
  • FlowNode
  • FlowScoped
  • FlushModeType
  • Folder
  • FolderAdapter
  • FolderClosedException
  • FolderEvent
  • FolderListener
  • FolderNotFoundException
  • ForbiddenException
  • ForeignKey
  • Form
  • FormParam
  • From
  • FromStringTerm
  • FromTerm
  • FunctionInfo
  • FunctionMapper
  • FunctionMapper
  • Future
  • Future.List
  • Generated
  • GeneratedValue
  • GenerationType
  • GenericBootstrap
  • GenericCredential
  • GenericEntity
  • GenericHandler
  • GenericServlet
  • GenericType
  • GET
  • GroupConversionDescriptor
  • GroupDefinitionException
  • GroupPrincipalCallback
  • GroupSequence
  • Handle
  • HandleDelegate
  • Handler
  • Handler
  • HandlerChain
  • HandlerChain
  • HandlerInfo
  • HandlerRegistry
  • HandlerResolver
  • HandlesTypes
  • HandshakeRequest
  • HandshakeResponse
  • HEAD
  • Header
  • HeaderParam
  • HeaderTerm
  • HeaderTokenizer
  • HeaderTokenizer.Token
  • HeuristicCommitException
  • HeuristicMixedException
  • HeuristicRollbackException
  • HexBinaryAdapter
  • HintsContext
  • Holder
  • Holder
  • HomeHandle
  • HtmlBody
  • HtmlBody.PropertyKeys
  • HtmlColumn
  • HtmlColumn.PropertyKeys
  • HtmlCommandButton
  • HtmlCommandButton.PropertyKeys
  • HtmlCommandLink
  • HtmlCommandLink.PropertyKeys
  • HtmlDataTable
  • HtmlDataTable.PropertyKeys
  • HtmlDoctype
  • HtmlDoctype.PropertyKeys
  • HtmlForm
  • HtmlForm.PropertyKeys
  • HtmlGraphicImage
  • HtmlGraphicImage.PropertyKeys
  • HtmlHead
  • HtmlHead.PropertyKeys
  • HtmlInputFile
  • HtmlInputFile.PropertyKeys
  • HtmlInputHidden
  • HtmlInputHidden.PropertyKeys
  • HtmlInputSecret
  • HtmlInputSecret.PropertyKeys
  • HtmlInputText
  • HtmlInputText.PropertyKeys
  • HtmlInputTextarea
  • HtmlInputTextarea.PropertyKeys
  • HtmlMessage
  • HtmlMessage.PropertyKeys
  • HtmlMessages
  • HtmlMessages.PropertyKeys
  • HtmlOutcomeTargetButton
  • HtmlOutcomeTargetButton.PropertyKeys
  • HtmlOutcomeTargetLink
  • HtmlOutcomeTargetLink.PropertyKeys
  • HtmlOutputFormat
  • HtmlOutputFormat.PropertyKeys
  • HtmlOutputLabel
  • HtmlOutputLabel.PropertyKeys
  • HtmlOutputLink
  • HtmlOutputLink.PropertyKeys
  • HtmlOutputText
  • HtmlOutputText.PropertyKeys
  • HtmlPanelGrid
  • HtmlPanelGrid.PropertyKeys
  • HtmlPanelGroup
  • HtmlPanelGroup.PropertyKeys
  • HtmlSelectBooleanCheckbox
  • HtmlSelectBooleanCheckbox.PropertyKeys
  • HtmlSelectManyCheckbox
  • HtmlSelectManyCheckbox.PropertyKeys
  • HtmlSelectManyListbox
  • HtmlSelectManyListbox.PropertyKeys
  • HtmlSelectManyMenu
  • HtmlSelectManyMenu.PropertyKeys
  • HtmlSelectOneListbox
  • HtmlSelectOneListbox.PropertyKeys
  • HtmlSelectOneMenu
  • HtmlSelectOneMenu.PropertyKeys
  • HtmlSelectOneRadio
  • HtmlSelectOneRadio.PropertyKeys
  • HTTPBinding
  • HttpConstraint
  • HttpConstraintElement
  • HttpContext
  • HTTPException
  • HttpExchange
  • HttpHandler
  • HttpHeaders
  • HttpJspPage
  • HttpMethod
  • HttpMethodConstraint
  • HttpMethodConstraintElement
  • HttpServlet
  • HttpServletRequest
  • HttpServletRequestWrapper
  • HttpServletResponse
  • HttpServletResponseWrapper
  • HttpSession
  • HttpSessionActivationListener
  • HttpSessionAttributeListener
  • HttpSessionBindingEvent
  • HttpSessionBindingListener
  • HttpSessionContext
  • HttpSessionEvent
  • HttpSessionIdListener
  • HttpSessionListener
  • HttpUpgradeHandler
  • HttpUtils
  • Id
  • IdClass
  • IdentifiableType
  • IllegalLoopbackException
  • IllegalProductException
  • IllegalStateException
  • IllegalStateException
  • IllegalStateRuntimeException
  • IllegalWriteException
  • ImplicitObjectELResolver
  • ImportHandler
  • Index
  • IndexedRecord
  • IndexedValueExpression
  • Inheritance
  • InheritanceType
  • Init
  • Initialized
  • InitParam
  • Inject
  • InjectionException
  • InjectionPoint
  • InjectionTarget
  • InjectionTargetFactory
  • Instance
  • IntegerComparisonTerm
  • IntegerConverter
  • IntegerWrapperHolder
  • Interaction
  • InteractionSpec
  • Intercepted
  • InterceptionType
  • Interceptor
  • Interceptor
  • Interceptor.Priority
  • InterceptorBinding
  • InterceptorContext
  • Interceptors
  • InternalServerErrorException
  • InternationalString
  • InternetAddress
  • InternetHeaders
  • InternetHeaders.InternetHeader
  • IntHolder
  • InvalidClientIDException
  • InvalidClientIDRuntimeException
  • InvalidDestinationException
  • InvalidDestinationRuntimeException
  • InvalidModuleException
  • InvalidPropertyException
  • InvalidRequestException
  • InvalidSelectorException
  • InvalidSelectorRuntimeException
  • InvalidTransactionException
  • Invocation
  • Invocation.Builder
  • InvocationCallback
  • InvocationContext
  • Invoker
  • ItemProcessListener
  • ItemProcessor
  • ItemReader
  • ItemReadListener
  • ItemWriteListener
  • ItemWriter
  • IteratedExpression
  • IteratedValueExpression
  • IterationTag
  • J2eeApplicationObject
  • JavaMailStats
  • JAXB
  • JAXBContext
  • JAXBElement
  • JAXBElement.GlobalScope
  • JAXBException
  • JAXBIntrospector
  • JAXBPermission
  • JAXBResult
  • JAXBSource
  • JAXRException
  • JAXRPCException
  • JAXRResponse
  • JCAConnectionPoolStats
  • JCAConnectionStats
  • JCAStats
  • JDBCConnectionPoolStats
  • JDBCConnectionStats
  • JDBCStats
  • JMSConnectionFactory
  • JMSConnectionFactoryDefinition
  • JMSConnectionFactoryDefinitions
  • JMSConnectionStats
  • JMSConsumer
  • JMSConsumerStats
  • JMSContext
  • JMSDestinationDefinition
  • JMSDestinationDefinitions
  • JMSEndpointStats
  • JMSException
  • JMSPasswordCredential
  • JMSProducer
  • JMSProducerStats
  • JMSRuntimeException
  • JMSSecurityException
  • JMSSecurityRuntimeException
  • JMSSessionMode
  • JMSSessionStats
  • JMSStats
  • JobContext
  • JobExecution
  • JobExecutionAlreadyCompleteException
  • JobExecutionIsRunningException
  • JobExecutionNotMostRecentException
  • JobExecutionNotRunningException
  • JobInstance
  • JobListener
  • JobOperator
  • JobRestartException
  • JobSecurityException
  • JobStartException
  • Join
  • JoinColumn
  • JoinColumns
  • JoinTable
  • JoinType
  • Json
  • JsonArray
  • JsonArrayBuilder
  • JsonBuilderFactory
  • JsonException
  • JsonGenerationException
  • JsonGenerator
  • JsonGeneratorFactory
  • JsonLocation
  • JsonNumber
  • JsonObject
  • JsonObjectBuilder
  • JsonParser
  • JsonParser.Event
  • JsonParserFactory
  • JsonParsingException
  • JsonProvider
  • JsonReader
  • JsonReaderFactory
  • JsonString
  • JsonStructure
  • JsonValue
  • JsonValue.ValueType
  • JsonWriter
  • JsonWriterFactory
  • JspApplicationContext
  • JspConfigDescriptor
  • JspContext
  • JspEngineInfo
  • JspException
  • JspFactory
  • JspFragment
  • JspIdConsumer
  • JspPage
  • JspPropertyGroupDescriptor
  • JspTag
  • JspTagException
  • JspWriter
  • JTAStats
  • JVMStats
  • Key
  • LambdaExpression
  • LastExecution
  • LazyAssociatableConnectionManager
  • LazyEnlistableConnectionManager
  • LazyEnlistableManagedConnection
  • LengthValidator
  • Lifecycle
  • LifecycleFactory
  • LifeCycleManager
  • LifecycleWrapper
  • Link
  • Link.Builder
  • Link.JaxbAdapter
  • Link.JaxbLink
  • ListAttribute
  • ListDataModel
  • ListELResolver
  • ListenerFor
  • ListenerRegistration
  • ListenersFor
  • ListJoin
  • LoadState
  • Lob
  • Local
  • LocalBean
  • LocaleSupport
  • LocalHome
  • LocalizationContext
  • LocalizedString
  • LocalTransaction
  • LocalTransaction
  • LocalTransactionException
  • Location
  • Lock
  • LockModeType
  • LockTimeoutException
  • LockType
  • LogicalHandler
  • LogicalMessage
  • LogicalMessageContext
  • LongConverter
  • LongHolder
  • LongRangeValidator
  • LongWrapperHolder
  • LoopTag
  • LoopTagStatus
  • LoopTagSupport
  • MailDateFormat
  • MailEvent
  • MailSessionDefinition
  • MailSessionDefinitions
  • ManageableThread
  • ManagedBean
  • ManagedBean
  • ManagedConnection
  • ManagedConnectionFactory
  • ManagedConnectionMetaData
  • ManagedExecutors
  • ManagedExecutorService
  • ManagedProperty
  • ManagedScheduledExecutorService
  • ManagedTask
  • ManagedTaskListener
  • ManagedThreadFactory
  • ManagedType
  • Management
  • ManagementHome
  • ManyToMany
  • ManyToOne
  • MapAttribute
  • MapELResolver
  • MapJoin
  • MapKey
  • MapKeyClass
  • MapKeyColumn
  • MapKeyEnumerated
  • MapKeyJoinColumn
  • MapKeyJoinColumns
  • MapKeyTemporal
  • MapMessage
  • MappedRecord
  • MappedSuperclass
  • MappedSuperclassType
  • MapsId
  • MarshalException
  • Marshaller
  • Marshaller.Listener
  • MatrixParam
  • Max
  • Max.List
  • MediaType
  • Message
  • Message
  • Message.RecipientType
  • MessageAware
  • MessageBodyReader
  • MessageBodyWriter
  • MessageChangedEvent
  • MessageChangedListener
  • MessageConsumer
  • MessageContext
  • MessageContext
  • MessageContext
  • MessageContext.Scope
  • MessageCountAdapter
  • MessageCountEvent
  • MessageCountListener
  • MessageDriven
  • MessageDrivenBean
  • MessageDrivenBeanStats
  • MessageDrivenContext
  • MessageEndpoint
  • MessageEndpointFactory
  • MessageEOFException
  • MessageFactory
  • MessageFormatException
  • MessageFormatRuntimeException
  • MessageHandler
  • MessageHandler.Partial
  • MessageHandler.Whole
  • MessageIDTerm
  • MessageInfo
  • MessageInterpolator
  • MessageInterpolator.Context
  • MessageListener
  • MessageListener
  • MessageNotReadableException
  • MessageNotWriteableException
  • MessageNotWriteableRuntimeException
  • MessageNumberTerm
  • MessagePolicy
  • MessagePolicy.ProtectionPolicy
  • MessagePolicy.Target
  • MessagePolicy.TargetPolicy
  • MessageProducer
  • MessageRemovedException
  • MessagingException
  • Metadata
  • MetadataTarget
  • Metamodel
  • MetaRule
  • MetaRuleset
  • MetaTagHandler
  • MethodBinding
  • MethodCallBuilder
  • MethodCallNode
  • MethodDescriptor
  • MethodExpression
  • MethodExpressionActionListener
  • MethodExpressionValidator
  • MethodExpressionValueChangeListener
  • MethodInfo
  • MethodNotFoundException
  • MethodNotFoundException
  • MethodNotSupportedException
  • MethodType
  • Metric
  • Metric.MetricType
  • MimeBodyPart
  • MimeHeader
  • MimeHeaders
  • MimeMessage
  • MimeMessage.RecipientType
  • MimeMultipart
  • MimePart
  • MimePartDataSource
  • MimeUtility
  • Min
  • Min.List
  • Model
  • ModuleType
  • MTOM
  • MTOMFeature
  • Multipart
  • MultipartConfig
  • MultipartConfigElement
  • MultipartDataSource
  • MultivaluedHashMap
  • MultivaluedMap
  • Name
  • NameBinding
  • Named
  • NamedAttributeNode
  • NamedEntityGraph
  • NamedEntityGraphs
  • NamedEvent
  • NamedNativeQueries
  • NamedNativeQuery
  • NamedQueries
  • NamedQuery
  • NamedStoredProcedureQueries
  • NamedStoredProcedureQuery
  • NamedSubgraph
  • NamespaceConstants
  • NamingContainer
  • NavigationCase
  • NavigationCaseBuilder
  • NavigationCaseWrapper
  • NavigationHandler
  • NavigationHandlerWrapper
  • New
  • NewCookie
  • NewsAddress
  • NoContentException
  • Node
  • NodeBuilder
  • NoMoreTimeoutsException
  • Nonbinding
  • NoneScoped
  • NonexistentConversationException
  • NonUniqueResultException
  • NoResultException
  • NormalizedStringAdapter
  • NormalScope
  • NoSuchEJBException
  • NoSuchEntityException
  • NoSuchJobException
  • NoSuchJobExecutionException
  • NoSuchJobInstanceException
  • NoSuchObjectLocalException
  • NoSuchProviderException
  • NotAcceptableException
  • NotAllowedException
  • NotAuthorizedException
  • NotFoundException
  • NotIdentifiableEvent
  • NotIdentifiableEventImpl
  • NotNull
  • NotNull.List
  • NotSupportedException
  • NotSupportedException
  • NotSupportedException
  • NotTerm
  • Null
  • Null.List
  • NumberConverter
  • ObjectHolder
  • ObjectMessage
  • ObjectNotFoundException
  • ObserverException
  • ObserverMethod
  • Observes
  • OnClose
  • OnError
  • OneToMany
  • OneToOne
  • Oneway
  • OnMessage
  • OnOpen
  • OperationUnsupportedException
  • OptimisticLockException
  • OPTIONS
  • Order
  • OrderBy
  • OrderColumn
  • Organization
  • OrTerm
  • OverridesAttribute
  • OverridesAttribute.List
  • PageContext
  • PageData
  • ParamConverter
  • ParamConverter.Lazy
  • ParamConverterProvider
  • Parameter
  • Parameter
  • ParameterDescriptor
  • ParameterExpression
  • ParameterList
  • ParameterMode
  • ParameterMode
  • ParameterNameProvider
  • ParseConversionEvent
  • ParseConversionEventImpl
  • ParseException
  • Part
  • Part
  • PartialResponseWriter
  • PartialStateHolder
  • PartialViewContext
  • PartialViewContextFactory
  • PartialViewContextWrapper
  • PartitionAnalyzer
  • PartitionCollector
  • PartitionMapper
  • PartitionPlan
  • PartitionPlanImpl
  • PartitionReducer
  • PartitionReducer.PartitionStatus
  • PassivationCapable
  • PasswordAuthentication
  • PasswordCredential
  • PasswordValidationCallback
  • Past
  • Past.List
  • Path
  • Path
  • Path
  • Path.BeanNode
  • Path.ConstructorNode
  • Path.CrossParameterNode
  • Path.MethodNode
  • Path.Node
  • Path.ParameterNode
  • Path.PropertyNode
  • Path.ReturnValueNode
  • PathParam
  • PathParam
  • PathSegment
  • Pattern
  • Pattern.Flag
  • Pattern.List
  • Payload
  • PermitAll
  • PermittedTaglibsTLV
  • Persistence
  • PersistenceContext
  • PersistenceContexts
  • PersistenceContextType
  • PersistenceException
  • PersistenceProperty
  • PersistenceProvider
  • PersistenceProviderResolver
  • PersistenceProviderResolverHolder
  • PersistenceUnit
  • PersistenceUnitInfo
  • PersistenceUnits
  • PersistenceUnitTransactionType
  • PersistenceUnitUtil
  • PersistenceUtil
  • PersonName
  • PessimisticLockException
  • PessimisticLockScope
  • PhaseEvent
  • PhaseId
  • PhaseListener
  • PluralAttribute
  • PluralAttribute.CollectionType
  • PluralJoin
  • PolicyConfiguration
  • PolicyConfigurationFactory
  • PolicyContext
  • PolicyContextException
  • PolicyContextHandler
  • PongMessage
  • PortInfo
  • POST
  • PostActivate
  • PostAddToViewEvent
  • PostalAddress
  • PostConstruct
  • PostConstructApplicationEvent
  • PostConstructCustomScopeEvent
  • PostConstructViewMapEvent
  • PostKeepFlashValueEvent
  • PostLoad
  • PostPersist
  • PostPutFlashValueEvent
  • PostRemove
  • PostRestoreStateEvent
  • PostUpdate
  • PostValidateEvent
  • PreClearFlashEvent
  • PreDestroy
  • PreDestroyApplicationEvent
  • PreDestroyCustomScopeEvent
  • PreDestroyViewMapEvent
  • Predicate
  • Predicate.BooleanOperator
  • PreencodedMimeBodyPart
  • PreJsf2ExceptionHandlerFactory
  • PreMatching
  • PrePassivate
  • PrePersist
  • PreRemove
  • PreRemoveFlashValueEvent
  • PreRemoveFromViewEvent
  • PreRenderComponentEvent
  • PreRenderViewEvent
  • PreUpdate
  • PreValidateEvent
  • PrimaryKeyJoinColumn
  • PrimaryKeyJoinColumns
  • PrintConversionEvent
  • PrintConversionEventImpl
  • Priorities
  • Priority
  • PrivateKeyCallback
  • PrivateKeyCallback.AliasRequest
  • PrivateKeyCallback.DigestRequest
  • PrivateKeyCallback.IssuerSerialNumRequest
  • PrivateKeyCallback.Request
  • PrivateKeyCallback.SubjectKeyIDRequest
  • ProcessAnnotatedType
  • ProcessBean
  • ProcessBeanAttributes
  • ProcessingException
  • ProcessInjectionPoint
  • ProcessInjectionTarget
  • ProcessManagedBean
  • ProcessObserverMethod
  • ProcessProducer
  • ProcessProducerField
  • ProcessProducerMethod
  • ProcessSessionBean
  • ProcessSyntheticAnnotatedType
  • Producer
  • ProducerFactory
  • Produces
  • Produces
  • ProgressEvent
  • ProgressListener
  • ProgressObject
  • ProjectStage
  • PropertyDescriptor
  • PropertyException
  • PropertyNotFoundException
  • PropertyNotFoundException
  • PropertyNotWritableException
  • PropertyResolver
  • ProtectedViewException
  • ProtocolException
  • Provider
  • Provider
  • Provider
  • Provider
  • Provider
  • Provider.Type
  • Providers
  • ProviderSpecificBootstrap
  • ProviderUtil
  • PUT
  • QNameHolder
  • Qualifier
  • Query
  • Query
  • QueryHint
  • QueryManager
  • QueryParam
  • QueryTimeoutException
  • Queue
  • QueueBrowser
  • QueueConnection
  • QueueConnectionFactory
  • QueueReceiver
  • QueueRequestor
  • QueueSender
  • QueueSession
  • Quota
  • Quota.Resource
  • QuotaAwareStore
  • RangeStatistic
  • ReaderInterceptor
  • ReaderInterceptorContext
  • ReadListener
  • ReadOnlyFolderException
  • ReceivedDateTerm
  • Reception
  • RecipientStringTerm
  • RecipientTerm
  • Record
  • RecordFactory
  • RedirectionException
  • Referenceable
  • ReferencedBean
  • ReferenceSyntaxException
  • RegexValidator
  • Registration
  • Registration.Dynamic
  • RegistrationListener
  • RegistryEntry
  • RegistryException
  • RegistryObject
  • RegistryPackage
  • RegistryService
  • Remote
  • RemoteEndpoint
  • RemoteEndpoint.Async
  • RemoteEndpoint.Basic
  • RemoteHome
  • Remove
  • RemoveException
  • Renderer
  • RendererWrapper
  • RenderKit
  • RenderKitFactory
  • RenderKitWrapper
  • ReportAsSingleViolation
  • Request
  • RequestDispatcher
  • RequestScoped
  • RequestScoped
  • RequestWrapper
  • RequiredValidator
  • ResolutionException
  • Resource
  • Resource
  • Resource.AuthenticationType
  • ResourceAdapter
  • ResourceAdapterAssociation
  • ResourceAdapterInternalException
  • ResourceAdapterMetaData
  • ResourceAllocationException
  • ResourceAllocationException
  • ResourceAllocationRuntimeException
  • ResourceBundleELResolver
  • ResourceContext
  • ResourceDependencies
  • ResourceDependency
  • ResourceException
  • ResourceHandler
  • ResourceHandlerWrapper
  • ResourceInfo
  • ResourceResolver
  • Resources
  • ResourceWarning
  • ResourceWrapper
  • RespectBinding
  • RespectBindingFeature
  • Response
  • Response
  • Response.ResponseBuilder
  • Response.Status
  • Response.Status.Family
  • Response.StatusType
  • ResponseProcessingException
  • ResponseStateManager
  • ResponseStream
  • ResponseWrapper
  • ResponseWriter
  • ResponseWriterWrapper
  • Result
  • ResultDataModel
  • ResultSet
  • ResultSetDataModel
  • ResultSetInfo
  • ResultSupport
  • RetryableException
  • RetryableUnavailableException
  • RetryableWorkRejectedException
  • RetryProcessListener
  • RetryReadListener
  • RetryWriteListener
  • ReturnBuilder
  • ReturnNode
  • ReturnValueDescriptor
  • RolesAllowed
  • RollbackException
  • RollbackException
  • Root
  • RunAs
  • RuntimeDelegate
  • RuntimeDelegate.HeaderDelegate
  • RuntimeType
  • SAAJMetaFactory
  • SAAJResult
  • SaveException
  • ScalarDataModel
  • Schedule
  • ScheduleExpression
  • Schedules
  • SchemaOutputResolver
  • Scope
  • Scope
  • ScopeContext
  • ScopedAttributeELResolver
  • ScriptFreeTLV
  • SearchException
  • SearchTerm
  • SecondaryTable
  • SecondaryTables
  • SecretKeyCallback
  • SecretKeyCallback.AliasRequest
  • SecretKeyCallback.Request
  • SecurityContext
  • SecurityContext
  • SecurityException
  • SecurityPermission
  • Selection
  • SelectItem
  • SelectItemGroup
  • SendFailedException
  • SendHandler
  • SendResult
  • SentDateTerm
  • SequenceGenerator
  • SerializationContext
  • Serializer
  • SerializerFactory
  • ServerApplicationConfig
  • ServerAuth
  • ServerAuthConfig
  • ServerAuthContext
  • ServerAuthModule
  • ServerContainer
  • ServerEndpoint
  • ServerEndpointConfig
  • ServerEndpointConfig.Builder
  • ServerEndpointConfig.Configurator
  • ServerErrorException
  • ServerSession
  • ServerSessionPool
  • Service
  • Service
  • Service
  • Service
  • Service.Mode
  • ServiceBinding
  • ServiceDelegate
  • ServiceException
  • ServiceFactory
  • ServiceLifecycle
  • ServiceMode
  • ServiceUnavailableException
  • Servlet
  • ServletConfig
  • ServletContainerInitializer
  • ServletContext
  • ServletContextAttributeEvent
  • ServletContextAttributeListener
  • ServletContextEvent
  • ServletContextListener
  • ServletEndpointContext
  • ServletException
  • ServletInputStream
  • ServletOutputStream
  • ServletRegistration
  • ServletRegistration.Dynamic
  • ServletRequest
  • ServletRequestAttributeEvent
  • ServletRequestAttributeListener
  • ServletRequestEvent
  • ServletRequestListener
  • ServletRequestWrapper
  • ServletResponse
  • ServletResponseWrapper
  • ServletSecurity
  • ServletSecurity.EmptyRoleSemantic
  • ServletSecurity.TransportGuarantee
  • ServletSecurityElement
  • ServletStats
  • Session
  • Session
  • Session
  • SessionBean
  • SessionBeanStats
  • SessionBeanType
  • SessionContext
  • SessionCookieConfig
  • SessionException
  • SessionScoped
  • SessionScoped
  • SessionSynchronization
  • SessionTrackingMode
  • SetAttribute
  • SetJoin
  • SharedByteArrayInputStream
  • SharedCacheMode
  • SharedFileInputStream
  • SharedInputStream
  • SharingViolationException
  • ShortConverter
  • ShortHolder
  • ShortWrapperHolder
  • SimpleTag
  • SimpleTagSupport
  • SingleThreadModel
  • Singleton
  • Singleton
  • SingularAttribute
  • Size
  • Size.List
  • SizeTerm
  • SkipPageException
  • SkippedException
  • SkipProcessListener
  • SkipReadListener
  • SkipWriteListener
  • Slot
  • SOAPBinding
  • SOAPBinding
  • SOAPBinding.ParameterStyle
  • SOAPBinding.Style
  • SOAPBinding.Use
  • SOAPBody
  • SOAPBodyElement
  • SOAPConnection
  • SOAPConnectionFactory
  • SOAPConstants
  • SOAPElement
  • SOAPElementFactory
  • SOAPEnvelope
  • SOAPException
  • SOAPFactory
  • SOAPFault
  • SOAPFaultElement
  • SOAPFaultException
  • SOAPFaultException
  • SOAPHandler
  • SOAPHeader
  • SOAPHeaderElement
  • SOAPMessage
  • SOAPMessageContext
  • SOAPMessageContext
  • SOAPMessageHandler
  • SOAPMessageHandlers
  • SOAPPart
  • Specializes
  • SpecificationLink
  • SQLExecutionTag
  • SqlResultSetMapping
  • SqlResultSetMappings
  • StandardELContext
  • Startup
  • Stateful
  • StatefulSessionBeanStats
  • StatefulTimeout
  • StateHelper
  • StateHolder
  • Stateless
  • StatelessSessionBeanStats
  • StateManagementStrategy
  • StateManager
  • StateManagerWrapper
  • StateType
  • StaticFieldELResolver
  • StaticMetamodel
  • Statistic
  • Stats
  • Status
  • StepContext
  • StepExecution
  • StepListener
  • Stereotype
  • Store
  • StoreClosedException
  • StoredProcedureParameter
  • StoredProcedureQuery
  • StoreEvent
  • StoreListener
  • Streamable
  • StreamingOutput
  • StreamMessage
  • StringHolder
  • StringTerm
  • Stub
  • Subgraph
  • SubjectTerm
  • Subquery
  • SupportedValidationTarget
  • Suspended
  • SwitchBuilder
  • SwitchCase
  • SwitchCaseBuilder
  • SwitchNode
  • Synchronization
  • SynchronizationType
  • SyncInvoker
  • SystemEvent
  • SystemEventListener
  • SystemEventListenerHolder
  • SystemException
  • Table
  • TableGenerator
  • Tag
  • Tag
  • TagAdapter
  • TagAttribute
  • TagAttributeException
  • TagAttributeInfo
  • TagAttributes
  • TagConfig
  • TagData
  • TagDecorator
  • TagException
  • TagExtraInfo
  • TagFileInfo
  • TagHandler
  • TagHandlerDelegate
  • TagHandlerDelegateFactory
  • TagInfo
  • TaglibDescriptor
  • TagLibraryInfo
  • TagLibraryValidator
  • TagSupport
  • TagVariableInfo
  • Target
  • TargetException
  • TargetModuleID
  • TelephoneNumber
  • Temporal
  • TemporalType
  • TemporaryQueue
  • TemporaryTopic
  • Text
  • TextHandler
  • TextMessage
  • TimedObject
  • Timeout
  • TimeoutHandler
  • Timer
  • TimerConfig
  • TimerHandle
  • TimerService
  • TimeStatistic
  • Topic
  • TopicConnection
  • TopicConnectionFactory
  • TopicPublisher
  • TopicRequestor
  • TopicSession
  • TopicSubscriber
  • Transaction
  • Transactional
  • Transactional.TxType
  • TransactionalException
  • TransactionAttribute
  • TransactionAttributeType
  • TransactionContext
  • TransactionInProgressException
  • TransactionInProgressRuntimeException
  • TransactionManagement
  • TransactionManagementType
  • TransactionManager
  • TransactionPhase
  • TransactionRequiredException
  • TransactionRequiredException
  • TransactionRequiredLocalException
  • TransactionRolledBackException
  • TransactionRolledbackException
  • TransactionRolledbackLocalException
  • TransactionRolledBackRuntimeException
  • TransactionScoped
  • TransactionSupport
  • TransactionSupport.TransactionSupportLevel
  • TransactionSynchronizationRegistry
  • Transient
  • TransientReference
  • TransientStateHelper
  • TransientStateHolder
  • Transport
  • TransportAdapter
  • TransportEvent
  • TransportListener
  • TraversableResolver
  • Trigger
  • TrustStoreCallback
  • TryCatchFinally
  • Tuple
  • TupleElement
  • Type
  • Type.PersistenceType
  • TypeConstraintException
  • TypeConverter
  • Typed
  • TypedQuery
  • TypeLiteral
  • TypeMapping
  • TypeMappingRegistry
  • UIColumn
  • UICommand
  • UIComponent
  • UIComponentBase
  • UIComponentBodyTag
  • UIComponentClassicTagBase
  • UIComponentELTag
  • UIComponentTag
  • UIComponentTagBase
  • UIData
  • UIDFolder
  • UIDFolder.FetchProfileItem
  • UIForm
  • UIGraphic
  • UIInput
  • UIMessage
  • UIMessages
  • UINamingContainer
  • UIOutcomeTarget
  • UIOutput
  • UIPanel
  • UIParameter
  • UISelectBoolean
  • UISelectItem
  • UISelectItems
  • UISelectMany
  • UISelectOne
  • UIViewAction
  • UIViewParameter
  • UIViewParameter.Reference
  • UIViewRoot
  • UnavailableException
  • UnavailableException
  • UnexpectedObjectException
  • UnexpectedTypeException
  • UniqueConstraint
  • UniqueIdVendor
  • Unmanaged
  • Unmanaged.UnmanagedInstance
  • UnmarshalException
  • Unmarshaller
  • Unmarshaller.Listener
  • UnmarshallerHandler
  • UnproxyableResolutionException
  • UnsatisfiedResolutionException
  • UnsupportedCapabilityException
  • UpdateModelException
  • UriBuilder
  • UriBuilderException
  • UriInfo
  • URIValidator
  • URLName
  • URLStats
  • User
  • UserTransaction
  • Valid
  • ValidateOnExecution
  • ValidatingManagedConnectionFactory
  • Validation
  • ValidationEvent
  • ValidationEventCollector
  • ValidationEventHandler
  • ValidationEventImpl
  • ValidationEventLocator
  • ValidationEventLocatorImpl
  • ValidationException
  • ValidationException
  • ValidationMessage
  • ValidationMode
  • ValidationProvider
  • ValidationProviderResolver
  • ValidationTarget
  • Validator
  • Validator
  • Validator
  • ValidatorConfig
  • ValidatorContext
  • ValidatorELTag
  • ValidatorException
  • ValidatorFactory
  • ValidatorHandler
  • ValidatorTag
  • ValueBinding
  • ValueChangeEvent
  • ValueChangeListener
  • ValueExpression
  • ValueHolder
  • ValueHolderAttachedObjectHandler
  • ValueHolderAttachedObjectTarget
  • ValueReference
  • VariableInfo
  • VariableMapper
  • VariableResolver
  • VariableResolver
  • Variant
  • Variant.VariantListBuilder
  • Version
  • Versionable
  • Vetoed
  • ViewBuilder
  • ViewDeclarationLanguage
  • ViewDeclarationLanguageFactory
  • ViewDeclarationLanguageWrapper
  • ViewExpiredException
  • ViewHandler
  • ViewHandlerWrapper
  • ViewMapListener
  • ViewMetadata
  • ViewNode
  • ViewResource
  • ViewScoped
  • ViewScoped
  • VisitCallback
  • VisitContext
  • VisitContextFactory
  • VisitContextWrapper
  • VisitHint
  • VisitResult
  • W3CDomHandler
  • W3CEndpointReference
  • W3CEndpointReferenceBuilder
  • WebApplicationException
  • WebConnection
  • WebEndpoint
  • WebFault
  • WebFilter
  • WebInitParam
  • WebListener
  • WebMethod
  • WebParam
  • WebParam.Mode
  • WebResourcePermission
  • WebResult
  • WebRoleRefPermission
  • WebService
  • WebServiceClient
  • WebServiceContext
  • WebServiceException
  • WebServiceFeature
  • WebServiceFeatureAnnotation
  • WebServicePermission
  • WebServiceProvider
  • WebServiceRef
  • WebServiceRefs
  • WebServlet
  • WebSocketContainer
  • WebTarget
  • WebUserDataPermission
  • WithAnnotations
  • Work
  • WorkAdapter
  • WorkCompletedException
  • WorkContext
  • WorkContextErrorCodes
  • WorkContextLifecycleListener
  • WorkContextProvider
  • WorkEvent
  • WorkException
  • WorkListener
  • WorkManager
  • WorkRejectedException
  • WriteListener
  • WriterInterceptor
  • WriterInterceptorContext
  • XAConnection
  • XAConnectionFactory
  • XAException
  • XAJMSContext
  • XAQueueConnection
  • XAQueueConnectionFactory
  • XAQueueSession
  • XAResource
  • XASession
  • XATerminator
  • XATopicConnection
  • XATopicConnectionFactory
  • XATopicSession
  • Xid
  • XmlAccessOrder
  • XmlAccessorOrder
  • XmlAccessorType
  • XmlAccessType
  • XmlAdapter
  • XmlAnyAttribute
  • XmlAnyElement
  • XmlAttachmentRef
  • XmlAttribute
  • XmlElement
  • XmlElement.DEFAULT
  • XmlElementDecl
  • XmlElementDecl.GLOBAL
  • XmlElementRef
  • XmlElementRef.DEFAULT
  • XmlElementRefs
  • XmlElements
  • XmlElementWrapper
  • XmlEnum
  • XmlEnumValue
  • XmlID
  • XmlIDREF
  • XmlInlineBinaryData
  • XmlJavaTypeAdapter
  • XmlJavaTypeAdapter.DEFAULT
  • XmlJavaTypeAdapters
  • XmlList
  • XmlMimeType
  • XmlMixed
  • XmlNs
  • XmlNsForm
  • XmlRegistry
  • XmlRootElement
  • XmlSchema
  • XmlSchemaType
  • XmlSchemaType.DEFAULT
  • XmlSchemaTypes
  • XmlSeeAlso
  • XmlTransient
  • XmlType
  • XMLType
  • XmlType.DEFAULT
  • XmlValue
  • XpathEvent
  • XpathListener


Deprecated List (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Deprecated API

Contents

  • Deprecated Interfaces
  • Deprecated Classes
  • Deprecated Exceptions
  • Deprecated Annotation Types
  • Deprecated Fields
  • Deprecated Methods
  • Deprecated Constructors
  • Deprecated Annotation Type Elements
  • Deprecated Interfaces
    Interface and Description
    javax.servlet.jsp.el.FunctionMapper
    As of JSP 2.1, replaced by FunctionMapper
    javax.resource.spi.security.GenericCredential
    The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.
    javax.servlet.http.HttpSessionContext
    As of Java(tm) Servlet API 2.1 for security reasons, with no replacement. This interface will be removed in a future version of this API.
    javax.servlet.SingleThreadModel
    As of Java Servlet API 2.4, with no direct replacement.
    javax.xml.bind.Validator
    since JAXB 2.0
    javax.servlet.jsp.el.VariableResolver
    As of JSP 2.1, replaced by ELResolver
  • Deprecated Classes
    Class and Description
    javax.faces.webapp.AttributeTag
    The Faces implementation must now provide the implementation for this class.
    javax.faces.webapp.ConverterTag
    This has been partially replaced by ConverterELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ConverterTag.createConverter() method, is now an implementation detail.
    javax.servlet.jsp.el.Expression
    As of JSP 2.1, replaced by ValueExpression
    javax.servlet.jsp.el.ExpressionEvaluator
    As of JSP 2.1, replaced by ExpressionFactory
    javax.servlet.http.HttpUtils
    As of Java(tm) Servlet API 2.3. These methods were only useful with the default encoding and have been moved to the request interfaces.
    javax.faces.el.MethodBinding
    This has been replaced by MethodExpression.
    javax.faces.el.PropertyResolver
    This has been replaced by ELResolver.
    javax.faces.view.facelets.ResourceResolver
    javax.xml.soap.SOAPElementFactory
    - Use javax.xml.soap.SOAPFactory for creating SOAPElements.
    javax.faces.application.StateManager.SerializedView
    This class was not marked Serializable in the 1.0 version of the spec. It was also not a static inner class, so it can't be made to be Serializable. Therefore, it is being deprecated in version 1.2 of the spec. The replacement is to use an implementation dependent Object.
    javax.faces.webapp.UIComponentBodyTag
    All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.
    javax.faces.webapp.UIComponentTag
    Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
    javax.faces.webapp.ValidatorTag
    This has been partially replaced by ValidatorELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ValidatorTag.createValidator() method, is now an implementation detail.
    javax.faces.el.ValueBinding
    This has been replaced by ValueExpression.
    javax.faces.el.VariableResolver
    This has been replaced by ELResolver when operating with a null base argument.
  • Deprecated Exceptions
    Exceptions and Description
    javax.servlet.jsp.el.ELException
    As of JSP 2.1, replaced by ELException
    javax.servlet.jsp.el.ELParseException
    As of JSP 2.1, replaced by ELException
    javax.faces.el.EvaluationException
    This has been replaced by ELException.
    javax.faces.el.MethodNotFoundException
    This has been replaced by MethodNotFoundException.
    javax.faces.el.PropertyNotFoundException
    This has been replaced by PropertyNotFoundException.
    javax.faces.el.ReferenceSyntaxException
    This has been replaced by ELException.
  • Deprecated Annotation Types
    Annotation Type and Description
    javax.jws.soap.InitParam
    javax.jws.soap.SOAPMessageHandler
    javax.jws.soap.SOAPMessageHandlers
  • Deprecated Fields
    Field and Description
    javax.faces.component.UIComponent.bindings
    javax.faces.component.UIComponent.CURRENT_COMPONENT
    javax.faces.component.UIComponent.CURRENT_COMPOSITE_COMPONENT
    javax.servlet.jsp.tagext.BodyTag.EVAL_BODY_TAG
    As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.
    javax.faces.validator.Validator.NOT_IN_RANGE_MESSAGE_ID
    Use DoubleRangeValidator.NOT_IN_RANGE_MESSAGE_ID or LongRangeValidator.NOT_IN_RANGE_MESSAGE_ID instead.
    javax.persistence.Persistence.PERSISTENCE_PROVIDER
    javax.persistence.Persistence.providers
    javax.faces.component.NamingContainer.SEPARATOR_CHAR
    use UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext)
  • Deprecated Methods
    Method and Description
    javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.addNode(String)
    since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.addPropertyNode(String), ConstraintValidatorContext.ConstraintViolationBuilder.addBeanNode() and ConstraintValidatorContext.ConstraintViolationBuilder.addParameterNode(int)
    javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addNode(String)
    since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addPropertyNode(String) and ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addBeanNode()
    javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext.addNode(String)
    since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext.addPropertyNode(String) and ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext.addBeanNode()
    javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addNode(String)
    since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addPropertyNode(String) and ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addBeanNode()
    javax.xml.soap.SOAPElementFactory.create(Name)
    Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
    javax.xml.soap.SOAPElementFactory.create(String)
    Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
    javax.xml.soap.SOAPElementFactory.create(String, String, String)
    Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
    javax.faces.application.ApplicationWrapper.createComponent(ValueBinding, FacesContext, String)
    See superclass for alternative.
    javax.faces.application.Application.createComponent(ValueBinding, FacesContext, String)
    This has been replaced by Application.createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).
    javax.faces.application.ApplicationWrapper.createMethodBinding(String, Class[])
    See superclass for alternative.
    javax.faces.application.Application.createMethodBinding(String, Class[])
    This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>, java.lang.Class<?>[]).
    javax.xml.bind.JAXBContext.createValidator()
    since JAXB2.0
    javax.faces.application.Application.createValueBinding(String)
    This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>).
    javax.enterprise.deploy.spi.DeploymentManager.distribute(Target[], InputStream, InputStream)
    as of Java EE 5, replaced with DeploymentManager.distribute(Target[], ModuleType, InputStream, InputStream)
    javax.faces.webapp.UIComponentClassicTagBase.encodeBegin()
    No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
    javax.faces.webapp.UIComponentClassicTagBase.encodeChildren()
    No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
    javax.faces.webapp.UIComponentClassicTagBase.encodeEnd()
    No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
    javax.servlet.http.HttpServletResponseWrapper.encodeRedirectUrl(String)
    As of version 2.1, use HttpServletResponseWrapper.encodeRedirectURL(String url) instead
    javax.servlet.http.HttpServletResponse.encodeRedirectUrl(String)
    As of version 2.1, use encodeRedirectURL(String url) instead
    javax.servlet.http.HttpServletResponseWrapper.encodeUrl(String)
    As of version 2.1, use HttpServletResponseWrapper.encodeURL(String url) instead
    javax.servlet.http.HttpServletResponse.encodeUrl(String)
    As of version 2.1, use encodeURL(String url) instead
    javax.faces.application.ApplicationWrapper.evaluateExpressionGet(FacesContext, String, Class)
    See superclass for alternative.
    javax.faces.component.UIViewAction.getAction()
    javax.faces.component.UICommand.getAction()
    This has been replaced by UICommand.getActionExpression().
    javax.faces.component.ActionSource.getAction()
    This has been replaced by ActionSource2.getActionExpression().
    javax.faces.component.UIViewAction.getActionListener()
    javax.faces.component.UICommand.getActionListener()
    Use UICommand.getActionListeners() instead.
    javax.faces.component.ActionSource.getActionListener()
    Use ActionSource.getActionListeners() instead.
    javax.ejb.EJBContext.getCallerIdentity()
    Use Principal getCallerPrincipal() instead.
    javax.faces.render.ResponseStateManager.getComponentStateToRestore(FacesContext)
    This method has been replaced by ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
    javax.faces.application.StateManager.getComponentStateToSave(FacesContext)
    the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
    javax.ejb.EJBContext.getEnvironment()
    Use the JNDI naming context java:comp/env to access enterprise bean's environment.
    javax.xml.bind.Validator.getEventHandler()
    since JAXB2.0
    javax.servlet.jsp.JspContext.getExpressionEvaluator()
    As of JSP 2.1, replaced by JspApplicationContext.getExpressionFactory()
    javax.servlet.http.HttpSessionContext.getIds()
    As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.
    javax.resource.ResourceException.getLinkedException()
    J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..
    javax.resource.cci.ResourceWarning.getLinkedWarning()
    J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
    javax.enterprise.deploy.model.DeployableObject.getModuleDTDVersion()
    As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
    javax.enterprise.deploy.model.DDBeanRoot.getModuleDTDVersion()
    As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
    javax.xml.bind.Validator.getProperty(String)
    since JAXB2.0
    javax.faces.application.ApplicationWrapper.getPropertyResolver()
    See superclass for alternative.
    javax.faces.application.Application.getPropertyResolver()
    This has been replaced by Application.getELResolver().
    javax.servlet.ServletRequestWrapper.getRealPath(String)
    As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead
    javax.servlet.ServletRequest.getRealPath(String)
    As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.
    javax.servlet.jsp.JspException.getRootCause()
    As of JSP 2.1, replaced by Throwable.getCause()
    javax.servlet.UnavailableException.getServlet()
    As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.
    javax.servlet.ServletContext.getServlet(String)
    As of Java Servlet API 2.1, with no direct replacement.

    This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

    In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.
    javax.servlet.ServletContext.getServletNames()
    As of Java Servlet API 2.1, with no replacement.

    This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.
    javax.servlet.ServletContext.getServlets()
    As of Java Servlet API 2.0, with no replacement.

    This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.
    javax.servlet.http.HttpSessionContext.getSession(String)
    As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.
    javax.servlet.http.HttpSession.getSessionContext()
    As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.
    javax.faces.render.ResponseStateManager.getTreeStructureToRestore(FacesContext, String)
    This method has been replaced by ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
    javax.faces.application.StateManager.getTreeStructureToSave(FacesContext)
    the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
    javax.faces.component.UIInput.getValidator()
    UIInput.getValidators() should be used instead.
    javax.faces.component.EditableValueHolder.getValidator()
    EditableValueHolder.getValidators() should be used instead.
    javax.servlet.http.HttpSession.getValue(String)
    As of Version 2.2, this method is replaced by HttpSession.getAttribute(java.lang.String).
    javax.faces.component.UISelectMany.getValueBinding(String)
    this has been replaced by UISelectMany.getValueExpression(java.lang.String).
    javax.faces.component.UISelectBoolean.getValueBinding(String)
    This has been replaced by UISelectBoolean.getValueExpression(java.lang.String).
    javax.faces.component.UIGraphic.getValueBinding(String)
    This has been replaced by UIGraphic.getValueExpression(java.lang.String).
    javax.faces.component.UIComponentBase.getValueBinding(String)
    This has been replaced by UIComponent.getValueExpression(java.lang.String).
    javax.faces.component.UIComponent.getValueBinding(String)
    This has been replaced by UIComponent.getValueExpression(java.lang.String).
    javax.faces.component.EditableValueHolder.getValueChangeListener()
    Use EditableValueHolder.getValueChangeListeners() instead.
    javax.servlet.http.HttpSession.getValueNames()
    As of Version 2.2, this method is replaced by HttpSession.getAttributeNames()
    javax.faces.application.ApplicationWrapper.getVariableResolver()
    See superclass for alternative.
    javax.faces.application.Application.getVariableResolver()
    This has been replaced by Application.getELResolver().
    javax.servlet.jsp.JspContext.getVariableResolver()
    As of JSP 2.1, replaced by ELContext.getELResolver(), which can be obtained by jspContext.getELContext().getELResolver().
    javax.ejb.EJBContext.isCallerInRole(Identity)
    Use boolean isCallerInRole(String roleName) instead.
    javax.el.MethodExpression.isParmetersProvided()
    javax.servlet.http.HttpServletRequest.isRequestedSessionIdFromUrl()
    As of Version 2.1 of the Java Servlet API, use HttpServletRequest.isRequestedSessionIdFromURL() instead.
    javax.xml.bind.Unmarshaller.isValidating()
    since JAXB2.0, please see Unmarshaller.getSchema()
    javax.servlet.ServletContext.log(Exception, String)
    As of Java Servlet API 2.1, use ServletContext.log(String message, Throwable throwable) instead.

    This method was originally defined to write an exception's stack trace and an explanatory error message to the servlet log file.
    javax.servlet.http.HttpSession.putValue(String, Object)
    As of Version 2.2, this method is replaced by HttpSession.setAttribute(java.lang.String, java.lang.Object)
    javax.servlet.http.HttpSession.removeValue(String)
    As of Version 2.2, this method is replaced by HttpSession.removeAttribute(java.lang.String)
    javax.faces.application.StateManager.restoreComponentState(FacesContext, UIViewRoot, String)
    the distinction between tree structure and component state is now an implementation detail. The default implementation does nothing.
    javax.faces.application.StateManager.restoreTreeStructure(FacesContext, String, String)
    the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
    javax.faces.application.StateManager.restoreView(FacesContext, String, String)
    javax.faces.application.StateManager.saveSerializedView(FacesContext)
    this has been replaced by StateManager.saveView(javax.faces.context.FacesContext). The default implementation calls saveView and inspects the return. If the return is an Object [], it casts the result to an Object [] wrapping the first and second elements in an instance of StateManager.SerializedView, which it then returns. Otherwise, it returns null
    javax.faces.application.StateManager.saveView(FacesContext)
    javax.faces.component.UIViewAction.setAction(MethodBinding)
    javax.faces.component.UICommand.setAction(MethodBinding)
    This has been replaced by UICommand.setActionExpression(javax.el.MethodExpression).
    javax.faces.component.ActionSource.setAction(MethodBinding)
    This has been replaced by ActionSource2.setActionExpression(javax.el.MethodExpression).
    javax.faces.component.UIViewAction.setActionListener(MethodBinding)
    javax.faces.component.UICommand.setActionListener(MethodBinding)
    This has been replaced by UICommand.addActionListener(javax.faces.event.ActionListener).
    javax.faces.component.ActionSource.setActionListener(MethodBinding)
    This has been replaced by ActionSource.addActionListener(javax.faces.event.ActionListener).
    javax.xml.bind.Validator.setEventHandler(ValidationEventHandler)
    since JAXB2.0
    javax.resource.ResourceException.setLinkedException(Exception)
    J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
    javax.resource.cci.ResourceWarning.setLinkedWarning(ResourceWarning)
    J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
    javax.xml.bind.Validator.setProperty(String, Object)
    since JAXB2.0
    javax.faces.application.ApplicationWrapper.setPropertyResolver(PropertyResolver)
    See superclass for alternative.
    javax.faces.application.Application.setPropertyResolver(PropertyResolver)
    The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called Application.addELResolver(javax.el.ELResolver).
    javax.servlet.http.HttpServletResponseWrapper.setStatus(int, String)
    As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use HttpServletResponseWrapper.setStatus(int), to send an error with a description use HttpServletResponseWrapper.sendError(int, String)
    javax.servlet.http.HttpServletResponse.setStatus(int, String)
    As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String). Sets the status code and message for this response.
    javax.xml.bind.Unmarshaller.setValidating(boolean)
    since JAXB2.0, please see Unmarshaller.setSchema(javax.xml.validation.Schema)
    javax.faces.component.UIInput.setValidator(MethodBinding)
    Use UIInput.addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.
    javax.faces.component.EditableValueHolder.setValidator(MethodBinding)
    Use EditableValueHolder.addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.
    javax.faces.component.UISelectMany.setValueBinding(String, ValueBinding)
    This has been replaced by UISelectMany.setValueExpression(java.lang.String, javax.el.ValueExpression).
    javax.faces.component.UISelectBoolean.setValueBinding(String, ValueBinding)
    This has been replaced by UISelectBoolean.setValueExpression(java.lang.String, javax.el.ValueExpression).
    javax.faces.component.UIGraphic.setValueBinding(String, ValueBinding)
    This has been replaced by UIGraphic.setValueExpression(java.lang.String, javax.el.ValueExpression).
    javax.faces.component.UIData.setValueBinding(String, ValueBinding)
    This has been replaced by UIData.setValueExpression(java.lang.String, javax.el.ValueExpression).
    javax.faces.component.UIComponentBase.setValueBinding(String, ValueBinding)
    This has been replaced by UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).
    javax.faces.component.UIComponent.setValueBinding(String, ValueBinding)
    This has been replaced by UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).
    javax.faces.component.UIInput.setValueChangeListener(MethodBinding)
    Use UIInput.addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.
    javax.faces.component.EditableValueHolder.setValueChangeListener(MethodBinding)
    Use EditableValueHolder.addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.
    javax.faces.application.ApplicationWrapper.setVariableResolver(VariableResolver)
    See superclass for alternative.
    javax.faces.application.Application.setVariableResolver(VariableResolver)
    The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called Application.addELResolver(javax.el.ELResolver).
    javax.xml.bind.Validator.validate(Object)
    since JAXB2.0
    javax.xml.bind.Validator.validateRoot(Object)
    since JAXB2.0
    javax.faces.application.StateManager.writeState(FacesContext, StateManager.SerializedView)
    This method has been replaced by StateManager.writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation calls the non-deprecated variant of the method passing an Object [] as the second argument, where the first element of the array is the return from getStructure() and the second is the return from getState() on the argument state.
    javax.faces.render.ResponseStateManager.writeState(FacesContext, StateManager.SerializedView)
    This method has been replaced by ResponseStateManager.writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation creates a two element Object array with the first element being the return from calling StateManager.SerializedView.getStructure(), and the second being the return from StateManager.SerializedView.getState(). It then passes this Object array to ResponseStateManager.writeState(javax.faces.context.FacesContext, java.lang.Object).
  • Deprecated Constructors
    Constructor and Description
    javax.servlet.UnavailableException(int, Servlet, String)
    As of Java Servlet API 2.2, use UnavailableException.UnavailableException(String, int) instead.
    javax.servlet.UnavailableException(Servlet, String)
    As of Java Servlet API 2.2, use UnavailableException.UnavailableException(String) instead.
  • Deprecated Annotation Type Elements
    Annotation Type Element and Description
    javax.jws.HandlerChain.name
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Java(TM) EE 7 Specification APIs

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client. Link to Non-frame version.


Index (Java(TM) EE 7 Specification APIs)

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

Prev

Next

Frames

No Frames

All Classes

A B C D E F G H I J K L M N O P Q R S T U V W X Y _
A

abandon(long) - Method in interface javax.batch.operations.JobOperator

Set batch status to ABANDONED.

AbortedException - Exception in javax.enterprise.concurrent

Exception indicating that the result of a task cannot be retrieved because the task failed to run for some reason other than being cancelled.

AbortedException() - Constructor for exception javax.enterprise.concurrent.AbortedException

Constructs an AbortedException with null as its detail message.

AbortedException(String, Throwable) - Constructor for exception javax.enterprise.concurrent.AbortedException

Constructs an AbortedException exception with the specified detail message and cause.

AbortedException(String) - Constructor for exception javax.enterprise.concurrent.AbortedException

Constructs an AbortedException exception with the specified detail message.

AbortedException(Throwable) - Constructor for exception javax.enterprise.concurrent.AbortedException

Constructs an AbortedException exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

AbortProcessingException - Exception in javax.faces.event

An exception that may be thrown by event listeners to terminate the processing of the current event.

AbortProcessingException() - Constructor for exception javax.faces.event.AbortProcessingException

Construct a new exception with no detail message or root cause.

AbortProcessingException(String) - Constructor for exception javax.faces.event.AbortProcessingException

Construct a new exception with the specified detail message and no root cause.

AbortProcessingException(Throwable) - Constructor for exception javax.faces.event.AbortProcessingException

Construct a new exception with the specified root cause.

AbortProcessingException(String, Throwable) - Constructor for exception javax.faces.event.AbortProcessingException

Construct a new exception with the specified detail message and root cause.

abortWith(Response) - Method in interface javax.ws.rs.client.ClientRequestContext

Abort the filter chain with a response.

abortWith(Response) - Method in interface javax.ws.rs.container.ContainerRequestContext

Abort the filter chain with a response.

abs(Expression<N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the absolute value of its argument.

AbstractBatchlet - Class in javax.batch.api

The AbstractBatchlet provides default implementations of less commonly implemented methods.

AbstractBatchlet() - Constructor for class javax.batch.api.AbstractBatchlet

AbstractCheckpointAlgorithm - Class in javax.batch.api.chunk

The AbstractCheckpointAlgorithm provides default implementations of less commonly implemented methods.

AbstractCheckpointAlgorithm() - Constructor for class javax.batch.api.chunk.AbstractCheckpointAlgorithm

AbstractChunkListener - Class in javax.batch.api.chunk.listener

The AbstractChunkListener provides default implementations of less commonly implemented methods.

AbstractChunkListener() - Constructor for class javax.batch.api.chunk.listener.AbstractChunkListener

AbstractItemProcessListener - Class in javax.batch.api.chunk.listener

The AbstractItemProcessListener provides default implementations of less commonly implemented methods.

AbstractItemProcessListener() - Constructor for class javax.batch.api.chunk.listener.AbstractItemProcessListener

AbstractItemReader - Class in javax.batch.api.chunk

The AbstractItemReader provides default implementations of less commonly implemented methods.

AbstractItemReader() - Constructor for class javax.batch.api.chunk.AbstractItemReader

AbstractItemReadListener - Class in javax.batch.api.chunk.listener

The AbstractItemReadListener provides default implementations of less commonly implemented methods.

AbstractItemReadListener() - Constructor for class javax.batch.api.chunk.listener.AbstractItemReadListener

AbstractItemWriteListener - Class in javax.batch.api.chunk.listener

The AbstractItemWriteListener provides default implementations of less commonly implemented methods.

AbstractItemWriteListener() - Constructor for class javax.batch.api.chunk.listener.AbstractItemWriteListener

AbstractItemWriter - Class in javax.batch.api.chunk

The AbstractItemWriter provides default implementations of not commonly implemented methods.

AbstractItemWriter() - Constructor for class javax.batch.api.chunk.AbstractItemWriter

AbstractJobListener - Class in javax.batch.api.listener

The AbstractJobListener provides default implementations of less commonly implemented methods.

AbstractJobListener() - Constructor for class javax.batch.api.listener.AbstractJobListener

AbstractMarshallerImpl - Class in javax.xml.bind.helpers

Partial default Marshaller implementation.

AbstractMarshallerImpl() - Constructor for class javax.xml.bind.helpers.AbstractMarshallerImpl

AbstractMultivaluedMap<K,V> - Class in javax.ws.rs.core

Abstract skeleton implementation of a MultivaluedMap that is backed by a [key, multi-value] store represented as a Map<K, List<V>>.

AbstractMultivaluedMap(Map<K, List<V>>) - Constructor for class javax.ws.rs.core.AbstractMultivaluedMap

Initialize the backing store in the abstract parent multivalued map implementation.

AbstractPartitionAnalyzer - Class in javax.batch.api.partition

The AbstractPartitionAnalyzer provides default implementations of less commonly implemented methods.

AbstractPartitionAnalyzer() - Constructor for class javax.batch.api.partition.AbstractPartitionAnalyzer

AbstractPartitionReducer - Class in javax.batch.api.partition

The AbstractBatchlet provides default implementations of less commonly implemented methods.

AbstractPartitionReducer() - Constructor for class javax.batch.api.partition.AbstractPartitionReducer

AbstractQuery<T> - Interface in javax.persistence.criteria

The AbstractQuery interface defines functionality that is common to both top-level queries and subqueries.

AbstractStepListener - Class in javax.batch.api.listener

The AbstractStepListener provides default implementations of less commonly implemented methods.

AbstractStepListener() - Constructor for class javax.batch.api.listener.AbstractStepListener

AbstractUnmarshallerImpl - Class in javax.xml.bind.helpers

Partial default Unmarshaller implementation.

AbstractUnmarshallerImpl() - Constructor for class javax.xml.bind.helpers.AbstractUnmarshallerImpl

accept(String...) - Method in interface javax.ws.rs.client.Invocation.Builder

Add the accepted response media types.

accept(MediaType...) - Method in interface javax.ws.rs.client.Invocation.Builder

Add the accepted response media types.

ACCEPT - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

ACCEPT_CHARSET - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

ACCEPT_ENCODING - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

ACCEPT_LANGUAGE - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

accepted() - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder with an ACCEPTED status.

accepted(Object) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder with an ACCEPTED status that contains a representation.

acceptEncoding(String...) - Method in interface javax.ws.rs.client.Invocation.Builder

Add acceptable encodings.

acceptLanguage(Locale...) - Method in interface javax.ws.rs.client.Invocation.Builder

Add acceptable languages.

acceptLanguage(String...) - Method in interface javax.ws.rs.client.Invocation.Builder

Add acceptable languages.

Access - Annotation Type in javax.persistence

Used to specify an access type to be applied to an entity class, mapped superclass, or embeddable class, or to a specific attribute of such a class.

AccessLocalException - Exception in javax.ejb

An AccessLocalException is thrown to indicate that the caller does not have permission to call the method.

AccessLocalException() - Constructor for exception javax.ejb.AccessLocalException

Constructs an AccessLocalException with no detail message.

AccessLocalException(String) - Constructor for exception javax.ejb.AccessLocalException

Constructs an AccessLocalException with the specified detail message.

AccessLocalException(String, Exception) - Constructor for exception javax.ejb.AccessLocalException

Constructs an AccessLocalException with the specified detail message and a nested exception.

AccessTimeout - Annotation Type in javax.ejb

Specifies the amount of time in a given time unit that a concurrent access attempt should block before timing out.

AccessType - Enum in javax.persistence

Used with the Access annotation to specify an access type to be applied to an entity class, mapped superclass, or embeddable class, or to a specific attribute of such a class.

acknowledge() - Method in interface javax.jms.JMSContext

Acknowledges all messages consumed by the JMSContext's session.

acknowledge() - Method in interface javax.jms.Message

Acknowledges all consumed messages of the session of this consumed message.

Action - Annotation Type in javax.xml.ws

The Action annotation allows explicit association of a WS-Addressing Action message addressing property with input, output, and fault messages of the mapped WSDL operation.

ActionEvent - Class in javax.faces.event

An ActionEvent represents the activation of a user interface component (such as a UICommand).

ActionEvent(UIComponent) - Constructor for class javax.faces.event.ActionEvent

Construct a new event object from the specified source component and action command.

ActionListener - Interface in javax.faces.event

A listener interface for receiving ActionEvents.

ActionListenerWrapper - Class in javax.faces.event

Provides a simple implementation of ActionListener that can be subclassed by developers wishing to provide specialized behavior to an existing ActionListener instance.

ActionListenerWrapper() - Constructor for class javax.faces.event.ActionListenerWrapper

ActionSource - Interface in javax.faces.component

ActionSource is an interface that may be implemented by any concrete UIComponent that wishes to be a source of ActionEvents, including the ability to invoke application actions via the default ActionListener mechanism.

ActionSource2 - Interface in javax.faces.component

ActionSource2 extends ActionSource and provides a JavaBeans property analogous to the "action" property on ActionSource.

ActionSource2AttachedObjectHandler - Interface in javax.faces.view

A VDL handler that exposes ActionListener to a page author.

ActionSource2AttachedObjectTarget - Interface in javax.faces.view

A marker interface for VDL tags that represent <composite:actionSource/> for use by the composite component page author.

ActionType - Class in javax.enterprise.deploy.shared

Class ActionTypes defines enumeration values for the Java EE DeploymentStatus actions.

ActionType(int) - Constructor for class javax.enterprise.deploy.shared.ActionType

Construct a new enumeration value with the given integer value.

Activation - Annotation Type in javax.resource.spi

Designates a JavaBean as an ActivationSpec.

ActivationConfigProperty - Annotation Type in javax.ejb

Used to provide information to the deployer about the configuration of a message driven bean in its operational environment.

ActivationSpec - Interface in javax.resource.spi

This interface serves as a marker.

add(ELResolver) - Method in class javax.el.CompositeELResolver

Adds the given resolver to the list of component resolvers.

add(Serializable, Object) - Method in interface javax.faces.component.StateHelper

Store the specified value in a List that is internal to the StateHelper.

add(Metadata) - Method in class javax.faces.view.facelets.MetaRuleset

Add another Metadata to this ruleset, returning this.

add(JsonValue) - Method in interface javax.json.JsonArrayBuilder

Adds a value to the array.

add(String) - Method in interface javax.json.JsonArrayBuilder

Adds a value to the array as a JsonString.

add(BigDecimal) - Method in interface javax.json.JsonArrayBuilder

Adds a value to the array as a JsonNumber.

add(BigInteger) - Method in interface javax.json.JsonArrayBuilder

Adds a value to the array as a JsonNumber.

add(int) - Method in interface javax.json.JsonArrayBuilder

Adds a value to the array as a JsonNumber.

add(long) - Method in interface javax.json.JsonArrayBuilder

Adds a value to the array as a JsonNumber.

add(double) - Method in interface javax.json.JsonArrayBuilder

Adds a value to the array as a JsonNumber.

add(boolean) - Method in interface javax.json.JsonArrayBuilder

Adds a JsonValue.TRUE or JsonValue.FALSE value to the array.

add(JsonObjectBuilder) - Method in interface javax.json.JsonArrayBuilder

Adds a JsonObject from an object builder to the array.

add(JsonArrayBuilder) - Method in interface javax.json.JsonArrayBuilder

Adds a JsonArray from an array builder to the array.

add(String, JsonValue) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonValue pair to the JSON object associated with this object builder.

add(String, String) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonString pair to the JSON object associated with this object builder.

add(String, BigInteger) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonNumber pair to the JSON object associated with this object builder.

add(String, BigDecimal) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonNumber pair to the JSON object associated with this object builder.

add(String, int) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonNumber pair to the JSON object associated with this object builder.

add(String, long) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonNumber pair to the JSON object associated with this object builder.

add(String, double) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonNumber pair to the JSON object associated with this object builder.

add(String, boolean) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonValue#TRUE or name/JsonValue#FALSE pair to the JSON object associated with this object builder.

add(String, JsonObjectBuilder) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonObject pair to the JSON object associated with this object builder.

add(String, JsonArrayBuilder) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonArray pair to the JSON object associated with this object builder.

add(FetchProfile.Item) - Method in class javax.mail.FetchProfile

Add the given special item as one of the attributes to be prefetched.

add(String) - Method in class javax.mail.FetchProfile

Add the specified header-field to the list of attributes to be prefetched.

add(Flags.Flag) - Method in class javax.mail.Flags

Add the specified system flag to this Flags object.

add(String) - Method in class javax.mail.Flags

Add the specified user flag to this Flags object.

add(Flags) - Method in class javax.mail.Flags

Add all the flags in the given Flags object to this Flags object.

add(K, V) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

Add a value to the current list of values for the supplied key.

add(K, V) - Method in interface javax.ws.rs.core.MultivaluedMap

Add a value to the current list of values for the supplied key.

add() - Method in class javax.ws.rs.core.Variant.VariantListBuilder

Add the current combination of metadata to the list of supported variants, after this method is called the current combination of metadata is emptied.

addActionListener(ActionListener) - Method in interface javax.faces.component.ActionSource

Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.

addActionListener(ActionListener) - Method in class javax.faces.component.UICommand

addActionListener(ActionListener) - Method in class javax.faces.component.UIViewAction

Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.

addAjaxBehaviorListener(AjaxBehaviorListener) - Method in class javax.faces.component.behavior.AjaxBehavior

Add the specified AjaxBehaviorListener to the set of listeners registered to receive event notifications from this AjaxBehavior.

addAll(K, V...) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

Add multiple values to the current list of values for the supplied key.

addAll(K, List<V>) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

Add all the values from the supplied value list to the current list of values for the supplied key.

addAll(K, V...) - Method in interface javax.ws.rs.core.MultivaluedMap

Add multiple values to the current list of values for the supplied key.

addAll(K, List<V>) - Method in interface javax.ws.rs.core.MultivaluedMap

Add all the values from the supplied value list to the current list of values for the supplied key.

addAnnotatedType(AnnotatedType<?>, String) - Method in interface javax.enterprise.inject.spi.AfterTypeDiscovery

Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.

addAnnotatedType(AnnotatedType<?>) - Method in interface javax.enterprise.inject.spi.BeforeBeanDiscovery

Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.

addAnnotatedType(AnnotatedType<?>, String) - Method in interface javax.enterprise.inject.spi.BeforeBeanDiscovery

Adds a given AnnotatedType to the set of types which will be scanned during bean discovery.

addAssociation(Association) - Method in interface javax.xml.registry.infomodel.RegistryObject

Adds specified Association to use this object as source.

addAssociations(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Adds specified Associations to use this object as source.

addAttachmentPart(AttachmentPart) - Method in class javax.xml.soap.SOAPMessage

Adds the given AttachmentPart object to this SOAPMessage object.

addAttribute(Name, String) - Method in interface javax.xml.soap.SOAPElement

Adds an attribute with the specified name and value to this SOAPElement object.

addAttribute(QName, String) - Method in interface javax.xml.soap.SOAPElement

Adds an attribute with the specified name and value to this SOAPElement object.

addAttributeNodes(String...) - Method in interface javax.persistence.EntityGraph

Add one or more attribute nodes to the entity graph.

addAttributeNodes(Attribute<T, ?>...) - Method in interface javax.persistence.EntityGraph

Add one or more attribute nodes to the entity graph.

addAttributeNodes(String...) - Method in interface javax.persistence.Subgraph

Add one or more attribute nodes to the entity graph.

addAttributeNodes(Attribute<T, ?>...) - Method in interface javax.persistence.Subgraph

Add one or more attribute nodes to the entity graph.

addBean(Bean<?>) - Method in interface javax.enterprise.inject.spi.AfterBeanDiscovery

Fires an event of type ProcessBean containing the given Bean and then registers the Bean with the container, thereby making it available for injection into other beans.

addBeanNameResolver(BeanNameResolver) - Method in class javax.el.ELManager

Register a BeanNameResolver.

addBeanNode() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder

Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.

addBeanNode() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext

Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.

addBeanNode() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext

Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.

addBeanNode() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder

Adds a bean node (class-level) to the path the ConstraintViolation will be associated to.

addBehavior(String, String) - Method in class javax.faces.application.Application

Register a new mapping of behavior id to the name of the corresponding Behavior class.

addBehavior(String, String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.addBehavior(String, String) on the wrapped Application object.

addBehaviorListener(BehaviorListener) - Method in class javax.faces.component.behavior.BehaviorBase

Add the specified BehaviorListener to the set of listeners registered to receive event notifications from this Behavior.

addBody() - Method in interface javax.xml.soap.SOAPEnvelope

Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.

addBodyElement(Name) - Method in interface javax.xml.soap.SOAPBody

Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.

addBodyElement(QName) - Method in interface javax.xml.soap.SOAPBody

Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.

addBodyPart(BodyPart) - Method in class javax.mail.internet.MimeMultipart

Adds a Part to the multipart.

addBodyPart(BodyPart, int) - Method in class javax.mail.internet.MimeMultipart

Adds a BodyPart at position index.

addBodyPart(BodyPart) - Method in class javax.mail.Multipart

Adds a Part to the multipart.

addBodyPart(BodyPart, int) - Method in class javax.mail.Multipart

Adds a BodyPart at position index.

addChild(UIComponent) - Method in class javax.faces.webapp.UIComponentClassicTagBase

addChild(UIComponent) - Method in class javax.faces.webapp.UIComponentTagBase

Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.

addChildConcept(Concept) - Method in interface javax.xml.registry.infomodel.ClassificationScheme

Adds a child Concept.

addChildConcept(Concept) - Method in interface javax.xml.registry.infomodel.Concept

Adds a child Concept.

addChildConcepts(Collection) - Method in interface javax.xml.registry.infomodel.ClassificationScheme

Adds a Collection of Concept children.

addChildConcepts(Collection) - Method in interface javax.xml.registry.infomodel.Concept

Adds a Collection of Concept children.

addChildElement(Name) - Method in interface javax.xml.soap.SOAPElement

Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.

addChildElement(QName) - Method in interface javax.xml.soap.SOAPElement

Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.

addChildElement(String) - Method in interface javax.xml.soap.SOAPElement

Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.

addChildElement(String, String) - Method in interface javax.xml.soap.SOAPElement

Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.

addChildElement(String, String, String) - Method in interface javax.xml.soap.SOAPElement

Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.

addChildElement(SOAPElement) - Method in interface javax.xml.soap.SOAPElement

Add a SOAPElement as a child of this SOAPElement instance.

addChildOrganization(Organization) - Method in interface javax.xml.registry.infomodel.Organization

Adds a child Organization.

addChildOrganizations(Collection) - Method in interface javax.xml.registry.infomodel.Organization

Adds a Collection of Organization children.

addClassification(Classification) - Method in interface javax.xml.registry.infomodel.RegistryObject

Adds specified Classification to this object.

addClassifications(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Adds specified Classifications to this object.

addClientBehavior(String, ClientBehavior) - Method in interface javax.faces.component.behavior.ClientBehaviorHolder

Attaches a ClientBehavior to the component implementing this interface for the specified event.

addClientBehavior(String, ClientBehavior) - Method in class javax.faces.component.UIComponentBase

This is a default implementation of ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).

addClientBehaviorRenderer(String, ClientBehaviorRenderer) - Method in class javax.faces.render.RenderKit

Register the specified ClientBehaviorRenderer instance, associated with the specified component type, to the set of ClientBehaviorRenderers registered with this RenderKit, replacing any previously registered ClientBehaviorRenderer for this type.

addClientBehaviorRenderer(String, ClientBehaviorRenderer) - Method in class javax.faces.render.RenderKitWrapper

The default behavior of this method is to call RenderKit.addClientBehaviorRenderer(String, ClientBehaviorRenderer) on the wrapped RenderKit object.

addComponent(String, String) - Method in class javax.faces.application.Application

Register a new mapping of component type to the name of the corresponding UIComponent class.

addComponent(String, String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.addComponent(String, String) on the wrapped Application object.

addComponentResource(FacesContext, UIComponent) - Method in class javax.faces.component.UIViewRoot

Add argument component, which is assumed to represent a resource instance, as a resource to this view.

addComponentResource(FacesContext, UIComponent, String) - Method in class javax.faces.component.UIViewRoot

Add argument component, which is assumed to represent a resource instance, as a resource to this view.

addConnectionEventListener(ConnectionEventListener) - Method in interface javax.resource.spi.ManagedConnection

Adds a connection event listener to the ManagedConnection instance.

addConnectionListener(ConnectionListener) - Method in class javax.mail.Folder

Add a listener for Connection events on this Folder.

addConnectionListener(ConnectionListener) - Method in class javax.mail.Service

Add a listener for Connection events on this service.

addConstraintViolation() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder

Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.

addConstraintViolation() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext

Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.

addConstraintViolation() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext

Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.

addConstraintViolation() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder

Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.

addConstraintViolation() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext

Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.

addConstraintViolation() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext

Adds the new ConstraintViolation to be generated if the constraint validator marks the value as invalid.

addConstraintViolation() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder

Adds the new ConstraintViolation to be generated if the constraint validator mark the value as invalid.

addContext(Context) - Method in interface javax.enterprise.inject.spi.AfterBeanDiscovery

Registers a custom Context object with the container.

addConverter(String, String) - Method in class javax.faces.application.Application

Register a new mapping of converter id to the name of the corresponding Converter class.

addConverter(Class<?>, String) - Method in class javax.faces.application.Application

Register a new converter class that is capable of performing conversions for the specified target class.

addConverter(String, String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.addConverter(String, String) on the wrapped Application object.

addConverter(Class<?>, String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.addConverter(Class, String) on the wrapped Application object.

addCookie(Cookie) - Method in interface javax.servlet.http.HttpServletResponse

Adds the specified cookie to the response.

addCookie(Cookie) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to call addCookie(Cookie cookie) on the wrapped response object.

addDataModelListener(DataModelListener) - Method in class javax.faces.model.DataModel

Add a new DataModelListener to the set interested in notifications from this DataModel.

addDateHeader(String, long) - Method in interface javax.servlet.http.HttpServletResponse

Adds a response header with the given name and date-value.

addDateHeader(String, long) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to call addDateHeader(String name, long date) on the wrapped response object.

addDefaultValidatorId(String) - Method in class javax.faces.application.Application

Register a validator by its id that is applied to all UIInput components in a view.

addDefaultValidatorId(String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.addDefaultValidatorId(String) on the wrapped Application object.

addDefinitionError(Throwable) - Method in interface javax.enterprise.inject.spi.AfterBeanDiscovery

Registers a definition error with the container, causing the container to abort deployment after all observers have been notified.

addDefinitionError(Throwable) - Method in interface javax.enterprise.inject.spi.ProcessBean

Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.

addDefinitionError(Throwable) - Method in interface javax.enterprise.inject.spi.ProcessBeanAttributes

Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.

addDefinitionError(Throwable) - Method in interface javax.enterprise.inject.spi.ProcessInjectionPoint

Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.

addDefinitionError(Throwable) - Method in interface javax.enterprise.inject.spi.ProcessInjectionTarget

Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.

addDefinitionError(Throwable) - Method in interface javax.enterprise.inject.spi.ProcessObserverMethod

Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.

addDefinitionError(Throwable) - Method in interface javax.enterprise.inject.spi.ProcessProducer

Registers a definition error with the container, causing the container to abort deployment after bean discovery is complete.

addDeploymentProblem(Throwable) - Method in interface javax.enterprise.inject.spi.AfterDeploymentValidation

Registers a deployment problem with the container, causing the container to abort deployment after all observers have been notified.

addDetail() - Method in interface javax.xml.soap.SOAPFault

Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.

addDetailEntry(Name) - Method in interface javax.xml.soap.Detail

Creates a new DetailEntry object with the given name and adds it to this Detail object.

addDetailEntry(QName) - Method in interface javax.xml.soap.Detail

Creates a new DetailEntry object with the given QName and adds it to this Detail object.

addDocument(Document) - Method in interface javax.xml.soap.SOAPBody

Adds the root node of the DOM Document to this SOAPBody object.

ADDED - Static variable in class javax.mail.event.MessageCountEvent

The messages were added to their folder

addELContextListener(ELContextListener) - Method in class javax.faces.application.Application

Provide a way for Faces applications to register an ELContextListener that will be notified on creation of ELContext instances.

addELContextListener(ELContextListener) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.addELContextListener(javax.el.ELContextListener) on the wrapped Application object.

addELContextListener(ELContextListener) - Method in interface javax.servlet.jsp.JspApplicationContext

Registers a ELContextListeners so that context objects can be added whenever a new ELContext is created.

addELResolver(ELResolver) - Method in class javax.el.ELManager

Add an user defined ELResolver to the list of ELResolvers.

addELResolver(ELResolver) - Method in class javax.el.StandardELContext

Add a custom ELResolver to the context.

addELResolver(ELResolver) - Method in class javax.faces.application.Application

Cause an the argument resolver to be added to the resolver chain as specified in section JSF.5.5.1 of the JavaServer Faces Specification.

addELResolver(ELResolver) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.addELResolver(javax.el.ELResolver) on the wrapped Application object.

addELResolver(ELResolver) - Method in interface javax.servlet.jsp.JspApplicationContext

Adds an ELResolver to affect the way EL variables and properties are resolved for EL expressions appearing in JSP pages and tag files.

addEndpoint(Class<?>) - Method in interface javax.websocket.server.ServerContainer

Deploys the given annotated endpoint into this ServerContainer during the initialization phase of deploying the application.

addEndpoint(ServerEndpointConfig) - Method in interface javax.websocket.server.ServerContainer

addEvaluationListener(EvaluationListener) - Method in class javax.el.ELContext

Registers an evaluation listener to the ELContext.

addEvaluationListener(EvaluationListener) - Method in class javax.el.ELManager

Register an evaluation listener.

addExternalIdentifier(ExternalIdentifier) - Method in interface javax.xml.registry.infomodel.RegistryObject

Adds specified ExternalIdentifier as an external identifier to this object.

addExternalIdentifiers(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Adds specified ExternalIdentifiers as an external identifiers to this object.

addExternalLink(ExternalLink) - Method in interface javax.xml.registry.infomodel.RegistryObject

Adds specified ExternalLink to this object.

addExternalLinks(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Adds specified ExternalLinks to this object.

addFacesListener(FacesListener) - Method in class javax.faces.component.UIComponent

Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent.

addFacesListener(FacesListener) - Method in class javax.faces.component.UIComponentBase

Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent.

addFacet(String) - Method in class javax.faces.webapp.UIComponentClassicTagBase

addFacet(String) - Method in class javax.faces.webapp.UIComponentTagBase

Add the facet name of the specified facet to the list of facet names created or located by nested UIComponentTags processing this request.

addFault() - Method in interface javax.xml.soap.SOAPBody

Creates a new SOAPFault object and adds it to this SOAPBody object.

addFault(Name, String, Locale) - Method in interface javax.xml.soap.SOAPBody

Creates a new SOAPFault object and adds it to this SOAPBody object.

addFault(QName, String, Locale) - Method in interface javax.xml.soap.SOAPBody

Creates a new SOAPFault object and adds it to this SOAPBody object.

addFault(Name, String) - Method in interface javax.xml.soap.SOAPBody

Creates a new SOAPFault object and adds it to this SOAPBody object.

addFault(QName, String) - Method in interface javax.xml.soap.SOAPBody

Creates a new SOAPFault object and adds it to this SOAPBody object.

addFaultReasonText(String, Locale) - Method in interface javax.xml.soap.SOAPFault

Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.

addFilter(String, String) - Method in interface javax.servlet.ServletContext

Adds the filter with the given name and class name to this servlet context.

addFilter(String, Filter) - Method in interface javax.servlet.ServletContext

Registers the given filter instance with this ServletContext under the given filterName.

addFilter(String, Class<? extends Filter>) - Method in interface javax.servlet.ServletContext

Adds the filter with the given name and class type to this servlet context.

addFirst(K, V) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

Add a value to the first position in the current list of values for the supplied key.

addFirst(K, V) - Method in interface javax.ws.rs.core.MultivaluedMap

Add a value to the first position in the current list of values for the supplied key.

addFirstNull(List<V>) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

Define the behavior for adding a null values to the first position in the value list.

addFlow(FacesContext, Flow) - Method in class javax.faces.flow.FlowHandler

Add the argument Flow to the collection of Flows known to the current application.

addFolderListener(FolderListener) - Method in class javax.mail.Folder

Add a listener for Folder events on this Folder.

addFolderListener(FolderListener) - Method in class javax.mail.Store

Add a listener for Folder events on any Folder object obtained from this Store.

addFrom(Address[]) - Method in class javax.mail.internet.MimeMessage

Add the specified addresses to the existing "From" field.

addFrom(Address[]) - Method in class javax.mail.Message

Add these addresses to the existing "From" attribute

addHeader(String, String) - Method in class javax.mail.internet.InternetHeaders

Add a header with the specified name and value to the header list.

addHeader(String, String) - Method in class javax.mail.internet.MimeBodyPart

Add this value to the existing values for this header_name.

addHeader(String, String) - Method in class javax.mail.internet.MimeMessage

Add this value to the existing values for this header_name.

addHeader(String, String) - Method in interface javax.mail.Part

Add this value to the existing values for this header_name.

addHeader(String, String) - Method in interface javax.servlet.http.HttpServletResponse

Adds a response header with the given name and value.

addHeader(String, String) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to return addHeader(String name, String value) on the wrapped response object.

addHeader(String, String) - Method in class javax.xml.soap.MimeHeaders

Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.

addHeader() - Method in interface javax.xml.soap.SOAPEnvelope

Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.

addHeaderElement(Name) - Method in interface javax.xml.soap.SOAPHeader

Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.

addHeaderElement(QName) - Method in interface javax.xml.soap.SOAPHeader

Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.

addHeaderLine(String) - Method in class javax.mail.internet.InternetHeaders

Add an RFC822 header line to the header store.

addHeaderLine(String) - Method in class javax.mail.internet.MimeBodyPart

Add a header line to this body part

addHeaderLine(String) - Method in class javax.mail.internet.MimeMessage

Add a raw RFC 822 header-line.

addHeaderLine(String) - Method in interface javax.mail.internet.MimePart

Add a raw RFC822 header-line.

addInterceptorBinding(AnnotatedType<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeforeBeanDiscovery

Declares an annotation type as an interceptor binding type.

addInterceptorBinding(Class<? extends Annotation>, Annotation...) - Method in interface javax.enterprise.inject.spi.BeforeBeanDiscovery

Declares an annotation type as an interceptor binding type, and specifies its meta-annotations.

addIntHeader(String, int) - Method in interface javax.servlet.http.HttpServletResponse

Adds a response header with the given name and integer value.

addIntHeader(String, int) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to call addIntHeader(String name, int value) on the wrapped response object.

addKeySubgraph(Attribute<T, X>) - Method in interface javax.persistence.EntityGraph

Add a node to the graph that corresponds to a map key that is a managed type.

addKeySubgraph(Attribute<T, X>, Class<? extends X>) - Method in interface javax.persistence.EntityGraph

Add a node to the graph that corresponds to a map key that is a managed type with inheritance.

addKeySubgraph(String) - Method in interface javax.persistence.EntityGraph

Add a node to the graph that corresponds to a map key that is a managed type.

addKeySubgraph(String, Class<X>) - Method in interface javax.persistence.EntityGraph

Add a node to the graph that corresponds to a map key that is a managed type with inheritance.

addKeySubgraph(Attribute<T, X>) - Method in interface javax.persistence.Subgraph

Add a node to the graph that corresponds to a map key that is a managed type.

addKeySubgraph(Attribute<T, X>, Class<? extends X>) - Method in interface javax.persistence.Subgraph

Add a node to the graph that corresponds to a map key that is a managed type with inheritance.

addKeySubgraph(String) - Method in interface javax.persistence.Subgraph

Add a node to the graph that corresponds to a map key that is a managed type.

addKeySubgraph(String, Class<X>) - Method in interface javax.persistence.Subgraph

Add a node to the graph that corresponds to a map key that is a managed type with inheritance.

addLifecycle(String, Lifecycle) - Method in class javax.faces.lifecycle.LifecycleFactory

Register a new Lifecycle instance, associated with the specified lifecycleId, to be supported by this LifecycleFactory.

addListener(AsyncListener) - Method in interface javax.servlet.AsyncContext

Registers the given AsyncListener with the most recent asynchronous cycle that was started by a call to one of the ServletRequest.startAsync() methods.

addListener(AsyncListener, ServletRequest, ServletResponse) - Method in interface javax.servlet.AsyncContext

Registers the given AsyncListener with the most recent asynchronous cycle that was started by a call to one of the ServletRequest.startAsync() methods.

addListener(String) - Method in interface javax.servlet.ServletContext

Adds the listener with the given class name to this ServletContext.

addListener(T) - Method in interface javax.servlet.ServletContext

Adds the given listener to this ServletContext.

addListener(Class<? extends EventListener>) - Method in interface javax.servlet.ServletContext

Adds a listener of the given class type to this ServletContext.

addLocalizedString(LocalizedString) - Method in interface javax.xml.registry.infomodel.InternationalString

Adds a LocalizedString to this object.

addLocalizedStrings(Collection) - Method in interface javax.xml.registry.infomodel.InternationalString

Adds many LocalizedStrings to this object.

addMapping(String...) - Method in interface javax.servlet.ServletRegistration

Adds a servlet mapping with the given URL patterns for the Servlet represented by this ServletRegistration.

addMapping(InputStream) - Method in interface javax.validation.Configuration

Add a stream describing constraint mapping in the Bean Validation XML format.

addMappingForServletNames(EnumSet<DispatcherType>, boolean, String...) - Method in interface javax.servlet.FilterRegistration

Adds a filter mapping with the given servlet names and dispatcher types for the Filter represented by this FilterRegistration.

addMappingForUrlPatterns(EnumSet<DispatcherType>, boolean, String...) - Method in interface javax.servlet.FilterRegistration

Adds a filter mapping with the given url patterns and dispatcher types for the Filter represented by this FilterRegistration.

addMessage(String, FacesMessage) - Method in class javax.faces.context.FacesContext

Append a FacesMessage to the set of messages associated with the specified client identifier, if clientId is not null.

addMessage(String, FacesMessage) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.addMessage(String, FacesMessage) on the wrapped FacesContext object.

addMessageChangedListener(MessageChangedListener) - Method in class javax.mail.Folder

Add a listener for MessageChanged events on this Folder.

addMessageCountListener(MessageCountListener) - Method in class javax.mail.Folder

Add a listener for MessageCount events on this Folder.

addMessageHandler(MessageHandler) - Method in interface javax.websocket.Session

Register to handle to incoming messages in this conversation.

addMimeHeader(String, String) - Method in class javax.xml.soap.AttachmentPart

Adds a MIME header with the specified name and value to this AttachmentPart object.

addMimeHeader(String, String) - Method in class javax.xml.soap.SOAPPart

Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object.

addMtomAttachment(DataHandler, String, String) - Method in class javax.xml.bind.attachment.AttachmentMarshaller

Consider MIME content data for optimized binary storage as an attachment.

addMtomAttachment(byte[], int, int, String, String, String) - Method in class javax.xml.bind.attachment.AttachmentMarshaller

Consider binary data for optimized binary storage as an attachment.

addNamedEntityGraph(String, EntityGraph<T>) - Method in interface javax.persistence.EntityManagerFactory

Add a named copy of the EntityGraph to the EntityManagerFactory.

addNamedQuery(String, Query) - Method in interface javax.persistence.EntityManagerFactory

Define the query, typed query, or stored procedure query as a named query such that future query objects can be created from it using the createNamedQuery or createNamedStoredProcedureQuery method.

addNamespaceDeclaration(String, String) - Method in interface javax.xml.soap.SOAPElement

Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.

addNode(String) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder

Deprecated.
since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.addPropertyNode(String), ConstraintValidatorContext.ConstraintViolationBuilder.addBeanNode() and ConstraintValidatorContext.ConstraintViolationBuilder.addParameterNode(int)

addNode(String) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext

Deprecated.
since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext.addPropertyNode(String) and ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext.addBeanNode()

addNode(String) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext

Deprecated.
since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addPropertyNode(String) and ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext.addBeanNode()

addNode(String) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder

Deprecated.
since 1.1 - replaced by ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addPropertyNode(String) and ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder.addBeanNode()

addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.j2ee.ListenerRegistration

Add a listener to a registered managed object.

addNotUnderstoodHeaderElement(QName) - Method in interface javax.xml.soap.SOAPHeader

Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.

addNull() - Method in interface javax.json.JsonArrayBuilder

Adds a JsonValue.NULL value to the array.

addNull(String) - Method in interface javax.json.JsonObjectBuilder

Adds a name/JsonValue#NULL pair to the JSON object associated with this object builder where the value is null.

addNull(List<V>) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

Define the behavior for adding a null values to the value list.

addObserverMethod(ObserverMethod<?>) - Method in interface javax.enterprise.inject.spi.AfterBeanDiscovery

Fires an event of type ProcessObserverMethod containing the given ObserverMethod and then registers the ObserverMethod with the container, thereby making it available for event notifications.

addParameter(String, QName, ParameterMode) - Method in interface javax.xml.rpc.Call

Adds a parameter type and mode for a specific operation.

addParameter(String, QName, Class, ParameterMode) - Method in interface javax.xml.rpc.Call

Adds a parameter type and mode for a specific operation.

addParameterNode(int) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder

Adds a method parameter node to the path the ConstraintViolation will be associated to.

addPhaseListener(PhaseListener) - Method in class javax.faces.component.UIViewRoot

Add the argument newPhaseListener to the list of PhaseListeners on this UIViewRoot.

addPhaseListener(PhaseListener) - Method in class javax.faces.lifecycle.Lifecycle

Register a new PhaseListener instance that is interested in being notified before and after the processing for standard phases of the request processing lifecycle.

addPhaseListener(PhaseListener) - Method in class javax.faces.lifecycle.LifecycleWrapper

addPort(QName, String, String) - Method in class javax.xml.ws.Service

Creates a new port for the service.

addPort(QName, String, String) - Method in class javax.xml.ws.spi.ServiceDelegate

Creates a new port for the service.

addProgressListener(ProgressListener) - Method in interface javax.enterprise.deploy.spi.status.ProgressObject

Add a listener to receive Progress events on deployment actions.

addProperty(String, String) - Method in interface javax.validation.Configuration

Adds a provider specific property.

addPropertyChangeListener(PropertyChangeListener) - Method in interface javax.enterprise.deploy.spi.DConfigBean

Register a property listener for this bean.

addPropertyNode(String) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder

Adds a property node to the path the ConstraintViolation will be associated to.

addPropertyNode(String) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext

Adds a property node to the path the ConstraintViolation will be associated to.

addPropertyNode(String) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext

Adds a property node to the path the ConstraintViolation will be associated to.

addPropertyNode(String) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder

Adds a property node to the path the ConstraintViolation will be associated to.

addProtectedView(String) - Method in class javax.faces.application.ViewHandler

Add the argument urlPattern to the thread safe Set of protected views for this application.

addProtectedView(String) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.addProtectedView(java.lang.String) on the wrapped ViewHandler object.

addProvider(Provider) - Method in class javax.mail.Session

Add a provider to the session.

addQualifier(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeforeBeanDiscovery

Declares an annotation type as a Qualifier qualifier type.

addQualifier(AnnotatedType<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeforeBeanDiscovery

Declares an annotation type as a Qualifier qualifier type.

addRecipient(Message.RecipientType, Address) - Method in class javax.mail.Message

Add this recipient address to the existing ones of the given type.

addRecipients(Message.RecipientType, Address[]) - Method in class javax.mail.internet.MimeMessage

Add the given addresses to the specified recipient type.

addRecipients(Message.RecipientType, String) - Method in class javax.mail.internet.MimeMessage

Add the given addresses to the specified recipient type.

addRecipients(Message.RecipientType, Address[]) - Method in class javax.mail.Message

Add these recipient addresses to the existing ones of the given type.

addRegistryObject(RegistryObject) - Method in interface javax.xml.registry.infomodel.RegistryPackage

Adds a child RegistryObject as member.

addRegistryObjects(Collection) - Method in interface javax.xml.registry.infomodel.RegistryPackage

Adds a Collection of RegistryObject children as members.

addRenderer(String, String, Renderer) - Method in class javax.faces.render.RenderKit

Register the specified Renderer instance, associated with the specified component family and rendererType, to the set of Renderers registered with this RenderKit, replacing any previously registered Renderer for this combination of identifiers.

addRenderer(String, String, Renderer) - Method in class javax.faces.render.RenderKitWrapper

The default behavior of this method is to call RenderKit.addRenderer(String, String, Renderer) on the wrapped RenderKit object.

addRenderKit(String, RenderKit) - Method in class javax.faces.render.RenderKitFactory

Register the specified RenderKit instance, associated with the specified renderKitId, to be supported by this RenderKitFactory, replacing any previously registered RenderKit for this identifier.

addResponseCookie(String, String, Map<String, Object>) - Method in class javax.faces.context.ExternalContext

Adds the cookie represented by the arguments to the response.

addResponseCookie(String, String, Map<String, Object>) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.addResponseCookie(String, String, Map) on the wrapped ExternalContext object.

addResponseHeader(String, String) - Method in class javax.faces.context.ExternalContext

Add the given name and value to the response header.

addResponseHeader(String, String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.addResponseHeader(String,String) on the wrapped ExternalContext object.

addResponseHeader(String, String) - Method in class javax.xml.ws.spi.http.HttpExchange

Adds a response header with the given name and value.

Address - Class in javax.mail

This abstract class models the addresses in a message.

Address() - Constructor for class javax.mail.Address

address - Variable in class javax.mail.internet.InternetAddress

address - Variable in class javax.mail.search.AddressTerm

The address.

address(String) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Sets the address to the W3CEndpointReference instance's wsa:Address.

ADDRESS_LINES_SLOT - Static variable in interface javax.xml.registry.infomodel.Slot

Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.

AddressException - Exception in javax.mail.internet

The exception thrown when a wrongly formatted address is encountered.

AddressException() - Constructor for exception javax.mail.internet.AddressException

Constructs an AddressException with no detail message.

AddressException(String) - Constructor for exception javax.mail.internet.AddressException

Constructs an AddressException with the specified detail message.

AddressException(String, String) - Constructor for exception javax.mail.internet.AddressException

Constructs an AddressException with the specified detail message and reference info.

AddressException(String, String, int) - Constructor for exception javax.mail.internet.AddressException

Constructs an AddressException with the specified detail message and reference info.

Addressing - Annotation Type in javax.xml.ws.soap

This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.

AddressingFeature - Class in javax.xml.ws.soap

AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.

AddressingFeature() - Constructor for class javax.xml.ws.soap.AddressingFeature

Creates and configures an AddressingFeature with the use of addressing requirements.

AddressingFeature(boolean) - Constructor for class javax.xml.ws.soap.AddressingFeature

Creates and configures an AddressingFeature with the use of addressing requirements.

AddressingFeature(boolean, boolean) - Constructor for class javax.xml.ws.soap.AddressingFeature

Creates and configures an AddressingFeature with the use of addressing requirements.

AddressingFeature(boolean, boolean, AddressingFeature.Responses) - Constructor for class javax.xml.ws.soap.AddressingFeature

Creates and configures an AddressingFeature with the use of addressing requirements.

AddressingFeature.Responses - Enum in javax.xml.ws.soap

If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.

AddressStringTerm - Class in javax.mail.search

This abstract class implements string comparisons for Message addresses.

AddressStringTerm(String) - Constructor for class javax.mail.search.AddressStringTerm

Constructor.

AddressTerm - Class in javax.mail.search

This class implements Message Address comparisons.

AddressTerm(Address) - Constructor for class javax.mail.search.AddressTerm

addRule(MetaRule) - Method in class javax.faces.view.facelets.MetaRuleset

Add another MetaRule to this ruleset, returning this.

addScope(Class<? extends Annotation>, boolean, boolean) - Method in interface javax.enterprise.inject.spi.BeforeBeanDiscovery

Declares an annotation type as a scope type.

addService(Service) - Method in interface javax.xml.registry.infomodel.Organization

Adds a child Service.

addServiceBinding(ServiceBinding) - Method in interface javax.xml.registry.infomodel.Service

Adds a child ServiceBinding.

addServiceBindings(Collection) - Method in interface javax.xml.registry.infomodel.Service

Adds a Collection of ServiceBinding children.

addServices(Collection) - Method in interface javax.xml.registry.infomodel.Organization

Adds a Collection of Service children.

addServlet(String, String) - Method in interface javax.servlet.ServletContext

Adds the servlet with the given name and class name to this servlet context.

addServlet(String, Servlet) - Method in interface javax.servlet.ServletContext

Registers the given servlet instance with this ServletContext under the given servletName.

addServlet(String, Class<? extends Servlet>) - Method in interface javax.servlet.ServletContext

Adds the servlet with the given name and class type to this servlet context.

addSlot(Slot) - Method in interface javax.xml.registry.infomodel.ExtensibleObject

Adds a Slot to this object.

addSlots(Collection) - Method in interface javax.xml.registry.infomodel.ExtensibleObject

Adds more Slots to this object.

addSpecificationLink(SpecificationLink) - Method in interface javax.xml.registry.infomodel.ServiceBinding

Adds a child SpecificationLink.

addSpecificationLinks(Collection) - Method in interface javax.xml.registry.infomodel.ServiceBinding

Adds a Collection of SpecificationLink children.

addSQLParameter(Object) - Method in interface javax.servlet.jsp.jstl.sql.SQLExecutionTag

Adds a PreparedStatement parameter value.

addStereotype(Class<? extends Annotation>, Annotation...) - Method in interface javax.enterprise.inject.spi.BeforeBeanDiscovery

Declares an annotation type as a stereotype, and specifies its meta-annotations.

addStoreListener(StoreListener) - Method in class javax.mail.Store

Add a listener for StoreEvents on this Store.

addSubclassSubgraph(Class<? extends T>) - Method in interface javax.persistence.EntityGraph

Add additional attributes to this entity graph that correspond to attributes of subclasses of this EntityGraph's entity type.

addSubgraph(Attribute<T, X>) - Method in interface javax.persistence.EntityGraph

Add a node to the graph that corresponds to a managed type.

addSubgraph(Attribute<T, X>, Class<? extends X>) - Method in interface javax.persistence.EntityGraph

Add a node to the graph that corresponds to a managed type with inheritance.

addSubgraph(String) - Method in interface javax.persistence.EntityGraph

Add a node to the graph that corresponds to a managed type.

addSubgraph(String, Class<X>) - Method in interface javax.persistence.EntityGraph

Add a node to the graph that corresponds to a managed type with inheritance.

addSubgraph(Attribute<T, X>) - Method in interface javax.persistence.Subgraph

Add a node to the graph that corresponds to a managed type.

addSubgraph(Attribute<T, X>, Class<? extends X>) - Method in interface javax.persistence.Subgraph

Add a node to the graph that corresponds to a managed type with inheritance.

addSubgraph(String) - Method in interface javax.persistence.Subgraph

Add a node to the graph that corresponds to a managed type.

addSubgraph(String, Class<X>) - Method in interface javax.persistence.Subgraph

Add a node to the graph that corresponds to a managed type with inheritance.

addSwaRefAttachment(DataHandler) - Method in class javax.xml.bind.attachment.AttachmentMarshaller

Add MIME data as an attachment and return attachment's content-id, cid.

addTextNode(String) - Method in interface javax.xml.soap.SOAPElement

Creates a new Text object initialized with the given String and adds it to this SOAPElement object.

addToExcludedPolicy(PermissionCollection) - Method in interface javax.security.jacc.PolicyConfiguration

Used to add excluded policy statements to this PolicyConfiguration.

addToExcludedPolicy(Permission) - Method in interface javax.security.jacc.PolicyConfiguration

Used to add a single excluded policy statement to this PolicyConfiguration.

addToRole(String, PermissionCollection) - Method in interface javax.security.jacc.PolicyConfiguration

Used to add permissions to a named role in this PolicyConfiguration.

addToRole(String, Permission) - Method in interface javax.security.jacc.PolicyConfiguration

Used to add a single permission to a named role in this PolicyConfiguration.

addToUncheckedPolicy(PermissionCollection) - Method in interface javax.security.jacc.PolicyConfiguration

Used to add unchecked policy statements to this PolicyConfiguration.

addToUncheckedPolicy(Permission) - Method in interface javax.security.jacc.PolicyConfiguration

Used to add a single unchecked policy statement to this PolicyConfiguration.

addTransformer(ClassTransformer) - Method in interface javax.persistence.spi.PersistenceUnitInfo

Add a transformer supplied by the provider that will be called for every new class definition or class redefinition that gets loaded by the loader returned by the PersistenceUnitInfo.getClassLoader() method.

addTransportListener(TransportListener) - Method in class javax.mail.Transport

Add a listener for Transport events.

addUpgradeHeaderElement(Iterator) - Method in interface javax.xml.soap.SOAPHeader

Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.

addUpgradeHeaderElement(String[]) - Method in interface javax.xml.soap.SOAPHeader

Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.

addUpgradeHeaderElement(String) - Method in interface javax.xml.soap.SOAPHeader

Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.

addUser(User) - Method in interface javax.xml.registry.infomodel.Organization

Adds a User.

addUsers(Collection) - Method in interface javax.xml.registry.infomodel.Organization

Adds a Collection of Users.

addValidator(String, String) - Method in class javax.faces.application.Application

Register a new mapping of validator id to the name of the corresponding Validator class.

addValidator(String, String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.addValidator(String, String) on the wrapped Application object.

addValidator(Validator) - Method in interface javax.faces.component.EditableValueHolder

Add a Validator instance to the set associated with this component.

addValidator(Validator) - Method in class javax.faces.component.UIInput

Add a Validator instance to the set associated with this UIInput.

addValueChangeListener(ValueChangeListener) - Method in interface javax.faces.component.EditableValueHolder

Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.

addValueChangeListener(ValueChangeListener) - Method in class javax.faces.component.UIInput

Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.

addVerbatimAfterComponent(UIComponentClassicTagBase, UIComponent, UIComponent) - Method in class javax.faces.webapp.UIComponentClassicTagBase

Add verbatim as a sibling of component in component in the parent's child list.

addVerbatimBeforeComponent(UIComponentClassicTagBase, UIComponent, UIComponent) - Method in class javax.faces.webapp.UIComponentClassicTagBase

Add verbatim as a sibling of component in component in the parent's child list.

addXpathListener(String, XpathListener) - Method in interface javax.enterprise.deploy.model.DDBean

Register a listener for a specific XPath.

addXpathListener(ModuleType, String, XpathListener) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject

Register a listener for changes in XPath that are related to this deployableObject.

AdministeredObject - Annotation Type in javax.resource.spi

Designates a JavaBean as an administered object.Administered objects are specific to a messaging style or message provider.

AdministeredObjectDefinition - Annotation Type in javax.resource

Annotation used to define a Connector administered object to be registered in JNDI.

AdministeredObjectDefinitions - Annotation Type in javax.resource

Declares one or more AdministeredObjectDefinition annotations.

AfterBeanDiscovery - Interface in javax.enterprise.inject.spi

The event type of the second event fired by the container when it has fully completed the bean discovery process, validated that there are no definition errors relating to the discovered beans, and registered Bean and ObserverMethod objects for the discovered beans, but before detecting deployment problems.

AfterBegin - Annotation Type in javax.ejb

Designate a stateful session bean method to receive the after begin session synchronization callback.

afterBegin() - Method in interface javax.ejb.SessionSynchronization

The afterBegin method notifies a stateful session bean instance that a new transaction has started, and that the subsequent business methods on the instance will be invoked in the context of the transaction.

afterChunk() - Method in class javax.batch.api.chunk.listener.AbstractChunkListener

Override this method if the ChunkListener will do something after the chunk ends.

afterChunk() - Method in interface javax.batch.api.chunk.listener.ChunkListener

The afterChunk method receives control after processing of the current chunk ends.

AfterCompletion - Annotation Type in javax.ejb

Designate a stateful session bean method to receive the after completion session synchronization callback.

afterCompletion(boolean) - Method in interface javax.ejb.SessionSynchronization

The afterCompletion method notifies a stateful session bean instance that a transaction commit protocol has completed, and tells the instance whether the transaction has been committed or rolled back.

afterCompletion(int) - Method in interface javax.transaction.Synchronization

This method is called by the transaction manager after the transaction is committed or rolled back.

afterDelivery() - Method in interface javax.resource.spi.endpoint.MessageEndpoint

This is called by a resource adapter after a message is delivered.

AfterDeploymentValidation - Interface in javax.enterprise.inject.spi

The event type of the third event fired by the container after it has validated that there are no deployment problems and before creating contexts or processing requests.

afterEvaluation(ELContext, String) - Method in class javax.el.EvaluationListener

Receives notification after an EL expression is evaluated

afterJob() - Method in class javax.batch.api.listener.AbstractJobListener

Override this method if the JobListener will do something after the job ends.

afterJob() - Method in interface javax.batch.api.listener.JobListener

The afterJob method receives control after the job execution ends.

afterMarshal(Object) - Method in class javax.xml.bind.Marshaller.Listener

Callback method invoked after marshalling source to XML.

afterPartitionedStepCompletion(PartitionReducer.PartitionStatus) - Method in class javax.batch.api.partition.AbstractPartitionReducer

Override this method to take action after partitioned step processing ends.

afterPartitionedStepCompletion(PartitionReducer.PartitionStatus) - Method in interface javax.batch.api.partition.PartitionReducer

The afterPartitionedStepCompletion method receives control at the end of a partition processing.

afterPhase(PhaseEvent) - Method in interface javax.faces.event.PhaseListener

Handle a notification that the processing for a particular phase has just been completed.

afterProcess(Object, Object) - Method in class javax.batch.api.chunk.listener.AbstractItemProcessListener

Override this method if the ItemProcessListener will do something after the item is processed.

afterProcess(Object, Object) - Method in interface javax.batch.api.chunk.listener.ItemProcessListener

The afterProcess method receives control after an item processor processes an item.

afterRead(Object) - Method in class javax.batch.api.chunk.listener.AbstractItemReadListener

Override this method if the ItemReadListener will do something after the item is read.

afterRead(Object) - Method in interface javax.batch.api.chunk.listener.ItemReadListener

The afterRead method receives control after an item reader reads an item.

afterResponse(HandshakeResponse) - Method in class javax.websocket.ClientEndpointConfig.Configurator

This method is called by the implementation after it has received a handshake response from the server as a result of a handshake interaction it initiated.

afterStep() - Method in class javax.batch.api.listener.AbstractStepListener

Override this method if the StepListener will do something after the step ends.

afterStep() - Method in interface javax.batch.api.listener.StepListener

The afterStep method receives control after a step execution ends.

AfterTypeDiscovery - Interface in javax.enterprise.inject.spi

This event type is thrown by the container after type discovery is complete.

afterUnmarshal(Object, Object) - Method in class javax.xml.bind.Unmarshaller.Listener

Callback method invoked after unmarshalling XML data into target.

afterWrite(List<Object>) - Method in class javax.batch.api.chunk.listener.AbstractItemWriteListener

Override this method if the ItemWriteListener will do something after the items are written.

afterWrite(List<Object>) - Method in interface javax.batch.api.chunk.listener.ItemWriteListener

The afterWrite method receives control after an item writer writes its items.

AjaxBehavior - Class in javax.faces.component.behavior

An instance of this class is added as a ClientBehavior to a component using the ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior) contract that components implement.

AjaxBehavior() - Constructor for class javax.faces.component.behavior.AjaxBehavior

AjaxBehaviorEvent - Class in javax.faces.event

AjaxBehaviorEvent represents the component behavior specific to Ajax).

AjaxBehaviorEvent(UIComponent, Behavior) - Constructor for class javax.faces.event.AjaxBehaviorEvent

Construct a new event object from the specified source component and Ajax behavior.

AjaxBehaviorListener - Interface in javax.faces.event

By implementing this class, an object indicates that it is a listener for one or more kinds of BehaviorEvents.

ALERT - Static variable in class javax.mail.event.StoreEvent

Indicates that this message is an ALERT.

alias(String, String) - Method in class javax.faces.view.facelets.MetaRuleset

Customize this MetaRuleset by removing the attribute named by argument attribute and re-adding it under the name given by the argument property, returning this.

alias(String) - Method in interface javax.persistence.criteria.Selection

Assigns an alias to the selection item.

ALL - Static variable in class javax.mail.internet.MimeUtility

all(Subquery<Y>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an all expression over the subquery results.

ALL_IDS - Static variable in class javax.faces.component.visit.VisitContext

This unmodifiable Collection is returned by getIdsToVisit() and getSubtreeIdsToVisit() in cases where all ids should be visited.

ALL_PARTIAL_PHASE_CLIENT_IDS - Static variable in class javax.faces.context.PartialViewContext

The value that when used with PartialViewContext.PARTIAL_EXECUTE_PARAM_NAME or PartialViewContext.PARTIAL_RENDER_PARAM_NAME indicates these phases must be skipped.

allocateConnection(ManagedConnectionFactory, ConnectionRequestInfo) - Method in interface javax.resource.spi.ConnectionManager

The method allocateConnection gets called by the resource adapter's connection factory instance.

ALLOW - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

allow(String...) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the list of allowed methods for the resource.

allow(Set<String>) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the list of allowed methods for the resource.

allowEmpty - Variable in class javax.mail.internet.MimeMultipart

Flag corresponding to the "mail.mime.multipart.allowempty" property, set in the MimeMultipart.initializeProperties() method called from constructors and the parse method.

AlterableContext - Interface in javax.enterprise.context.spi

Provides an operation for obtaining and destroying contextual instances with a particular scope of any contextual type.

Alternative - Annotation Type in javax.enterprise.inject

Specifies that a bean is an alternative.

AmbiguousResolutionException - Exception in javax.enterprise.inject

Indicates that multiple beans match a certain combination of required type and required qualifiers and are eligible for injection into a certain class.

AmbiguousResolutionException() - Constructor for exception javax.enterprise.inject.AmbiguousResolutionException

AmbiguousResolutionException(String, Throwable) - Constructor for exception javax.enterprise.inject.AmbiguousResolutionException

AmbiguousResolutionException(String) - Constructor for exception javax.enterprise.inject.AmbiguousResolutionException

AmbiguousResolutionException(Throwable) - Constructor for exception javax.enterprise.inject.AmbiguousResolutionException

analyzeCollectorData(Serializable) - Method in class javax.batch.api.partition.AbstractPartitionAnalyzer

Override this method to analyze PartitionCollector payloads.

analyzeCollectorData(Serializable) - Method in interface javax.batch.api.partition.PartitionAnalyzer

The analyzeCollectorData method receives control each time a Partition collector sends its payload.

analyzeStatus(BatchStatus, String) - Method in class javax.batch.api.partition.AbstractPartitionAnalyzer

Override this method to analyze partition end status.

analyzeStatus(BatchStatus, String) - Method in interface javax.batch.api.partition.PartitionAnalyzer

The analyzeStatus method receives control each time a partition ends.

and(Expression<Boolean>, Expression<Boolean>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a conjunction of the given boolean expressions.

and(Predicate...) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a conjunction of the given restriction predicates.

AND_ALL_KEYS - Static variable in interface javax.xml.registry.FindQualifier

AndTerm - Class in javax.mail.search

This class implements the logical AND operator on individual SearchTerms.

AndTerm(SearchTerm, SearchTerm) - Constructor for class javax.mail.search.AndTerm

Constructor that takes two terms.

AndTerm(SearchTerm[]) - Constructor for class javax.mail.search.AndTerm

Constructor that takes an array of SearchTerms.

Annotated - Interface in javax.enterprise.inject.spi

Represents a Java program element that can be annotated.

AnnotatedCallable<X> - Interface in javax.enterprise.inject.spi

Represents a callable member of a Java type.

AnnotatedConstructor<X> - Interface in javax.enterprise.inject.spi

Represents a constructor of a Java class.

AnnotatedField<X> - Interface in javax.enterprise.inject.spi

Represents a field of a Java class.

AnnotatedMember<X> - Interface in javax.enterprise.inject.spi

Represents a member of a Java type.

AnnotatedMethod<X> - Interface in javax.enterprise.inject.spi

Represents a method of a Java type.

AnnotatedParameter<X> - Interface in javax.enterprise.inject.spi

Represents a parameter of a method or constructor.

AnnotatedType<X> - Interface in javax.enterprise.inject.spi

Represents a Java class or interface.

AnnotationLiteral<T extends Annotation> - Class in javax.enterprise.util

Supports inline instantiation of annotation type instances.

AnnotationLiteral() - Constructor for class javax.enterprise.util.AnnotationLiteral

annotationType() - Method in class javax.enterprise.util.AnnotationLiteral

ANSWERED - Static variable in class javax.mail.Flags.Flag

This message has been answered.

Any - Annotation Type in javax.enterprise.inject

The built-in qualifier type.

any(Subquery<Y>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an any expression over the subquery results.

ANY_PHASE - Static variable in class javax.faces.event.PhaseId

Identifier that indicates an interest in events, no matter which request processing phase is being performed.

APP_NAME - Static variable in class javax.ejb.embeddable.EJBContainer

Standard property name for specifying the application name of the EJB modules executing within the embeddable container.

appendFaultSubcode(QName) - Method in interface javax.xml.soap.SOAPFault

Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.

appendMessages(Message[]) - Method in class javax.mail.Folder

Append given Messages to this folder.

Application - Class in javax.faces.application

Application represents a per-web-application singleton object where applications based on JavaServer Faces (or implementations wishing to provide extended functionality) can register application-wide singletons that provide functionality required by JavaServer Faces.

Application() - Constructor for class javax.faces.application.Application

APPLICATION - Static variable in class javax.interceptor.Interceptor.Priority

Start of range for interceptors defined by applications.

APPLICATION - Static variable in class javax.servlet.jsp.PageContext

Name used to store ServletContext in PageContext name table.

Application - Class in javax.ws.rs.core

Defines the components of a JAX-RS application and supplies additional meta-data.

Application() - Constructor for class javax.ws.rs.core.Application

APPLICATION_ATOM_XML - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""application/atom+xml"" media type.

APPLICATION_ATOM_XML_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""application/atom+xml"" media type.

APPLICATION_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the ApplicationFactory class name.

APPLICATION_FORM_URLENCODED - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""application/x-www-form-urlencoded"" media type.

APPLICATION_FORM_URLENCODED_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""application/x-www-form-urlencoded"" media type.

APPLICATION_JSON - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""application/json"" media type.

APPLICATION_JSON_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""application/json"" media type.

APPLICATION_OCTET_STREAM - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""application/octet-stream"" media type.

APPLICATION_OCTET_STREAM_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""application/octet-stream"" media type.

APPLICATION_SCOPE - Static variable in class javax.servlet.jsp.PageContext

Application scope: named reference remains available in the ServletContext until it is reclaimed.

APPLICATION_SVG_XML - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""application/svg+xml"" media type.

APPLICATION_SVG_XML_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""application/svg+xml"" media type.

APPLICATION_XHTML_XML - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""application/xhtml+xml"" media type.

APPLICATION_XHTML_XML_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""application/xhtml+xml"" media type.

APPLICATION_XML - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""application/xml"" media type.

APPLICATION_XML_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""application/xml"" media type.

ApplicationConfigurationPopulator - Class in javax.faces.application

This class defines a java.util.ServiceLoader service which enables programmatic configuration of the JSF runtime using the existing Application Configuration Resources schema.

ApplicationConfigurationPopulator() - Constructor for class javax.faces.application.ApplicationConfigurationPopulator

ApplicationException - Annotation Type in javax.ejb

Applied to an exception to denote that it is an application exception and should be reported to the client directly (i.e., unwrapped).

ApplicationFactory - Class in javax.faces.application

ApplicationFactory is a factory object that creates (if needed) and returns Application instances.

ApplicationFactory() - Constructor for class javax.faces.application.ApplicationFactory

ApplicationPath - Annotation Type in javax.ws.rs

Identifies the application path that serves as the base URI for all resource URIs provided by Path.

ApplicationScoped - Annotation Type in javax.enterprise.context

Specifies that a bean is application scoped.

ApplicationScoped - Annotation Type in javax.faces.bean

When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>application<managed-bean-scope> element was declared for the corresponding managed bean.

ApplicationServerInternalException - Exception in javax.resource.spi

An ApplicationServerInternalException is thrown by an application server to indicate error conditions specific to an application server.

ApplicationServerInternalException() - Constructor for exception javax.resource.spi.ApplicationServerInternalException

Constructs a new instance with null as its detail message.

ApplicationServerInternalException(String) - Constructor for exception javax.resource.spi.ApplicationServerInternalException

Constructs a new instance with the specified detail message.

ApplicationServerInternalException(Throwable) - Constructor for exception javax.resource.spi.ApplicationServerInternalException

Constructs a new throwable with the specified cause.

ApplicationServerInternalException(String, Throwable) - Constructor for exception javax.resource.spi.ApplicationServerInternalException

Constructs a new throwable with the specified detail message and cause.

ApplicationServerInternalException(String, String) - Constructor for exception javax.resource.spi.ApplicationServerInternalException

Constructs a new throwable with the specified detail message and an error code.

ApplicationWrapper - Class in javax.faces.application

Provides a simple implementation of Application that can be subclassed by developers wishing to provide specialized behavior to an existing Application instance.

ApplicationWrapper() - Constructor for class javax.faces.application.ApplicationWrapper

apply(FaceletContext, UIComponent) - Method in class javax.faces.view.facelets.CompositeFaceletHandler

Calls apply on any child handlers.

apply(FaceletContext, UIComponent) - Method in class javax.faces.view.facelets.DelegatingMetaTagHandler

The default implementation simply calls through to TagHandlerDelegate.apply(javax.faces.view.facelets.FaceletContext, javax.faces.component.UIComponent).

apply(FacesContext, UIComponent) - Method in class javax.faces.view.facelets.Facelet

The passed UIComponent parent will be populated/restored in accordance with the Facelets chapter in the spec prose document.

apply(FaceletContext, UIComponent) - Method in interface javax.faces.view.facelets.FaceletHandler

Process changes on a particular UIComponent

apply(FaceletContext, UIComponent) - Method in class javax.faces.view.facelets.TagHandlerDelegate

Called by classes that implement FaceletHandler in their implementation of apply().

APPLY_REQUEST_VALUES - Static variable in class javax.faces.event.PhaseId

Identifier that indicates an interest in events queued for the Apply Request Values phase of the request processing lifecycle.

applyAttachedObject(FacesContext, UIComponent) - Method in interface javax.faces.view.AttachedObjectHandler

Take the argument parent and apply this attached object to it.

applyAttachedObject(FacesContext, UIComponent) - Method in class javax.faces.view.facelets.FaceletsAttachedObjectHandler

Take the necessary actions to apply the attached object represented by the tag for the concrete subclass of this class to the argument parent.

applyMetadata(FaceletContext, Object) - Method in class javax.faces.view.facelets.Metadata

Take the action prescribed in the JSF specification for this particular VDL element attribute.

applyNextHandler(FaceletContext, UIComponent) - Method in class javax.faces.view.facelets.DelegatingMetaTagHandler

Invoke the apply() method on this instance's TagHandler.nextHandler.

applyRule(String, TagAttribute, MetadataTarget) - Method in class javax.faces.view.facelets.MetaRule

Return an abstraction that takes appropriate action given the kind of rule represented by the argument name, in the context of this particular concrete subclass of MetaRule.

areInterceptorBindingsEquivalent(Annotation, Annotation) - Method in interface javax.enterprise.inject.spi.BeanManager

Determine if two interceptor bindings are considered equivalent for the purposes of typesafe resolution, taking into account any members annotated with Nonbinding.

areQualifiersEquivalent(Annotation, Annotation) - Method in interface javax.enterprise.inject.spi.BeanManager

Determine if two qualifiers are considered equivalent for the purposes of typesafe resolution, taking into account any members annotated with Nonbinding.

AroundConstruct - Annotation Type in javax.interceptor

Designates an interceptor method that receives a callback when the target class constructor is invoked.

AroundInvoke - Annotation Type in javax.interceptor

Defines an interceptor method that interposes on business methods.

aroundReadFrom(ReaderInterceptorContext) - Method in interface javax.ws.rs.ext.ReaderInterceptor

Interceptor method wrapping calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream) method.

AroundTimeout - Annotation Type in javax.interceptor

Defines an interceptor method that interposes on timeout methods.

aroundWriteTo(WriterInterceptorContext) - Method in interface javax.ws.rs.ext.WriterInterceptor

Interceptor method wrapping calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream) method.

array(Selection<?>...) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an array-valued selection item.

ArrayDataModel<E> - Class in javax.faces.model

ArrayDataModel is a convenience implementation of DataModel that wraps an array of Java objects.

ArrayDataModel() - Constructor for class javax.faces.model.ArrayDataModel

Construct a new ArrayDataModel with no specified wrapped data.

ArrayDataModel(E[]) - Constructor for class javax.faces.model.ArrayDataModel

Construct a new ArrayDataModel wrapping the specified array.

ArrayELResolver - Class in javax.el

Defines property resolution behavior on arrays.

ArrayELResolver() - Constructor for class javax.el.ArrayELResolver

Creates a new read/write ArrayELResolver.

ArrayELResolver(boolean) - Constructor for class javax.el.ArrayELResolver

Creates a new ArrayELResolver whose read-only status is determined by the given parameter.

as(Class<X>) - Method in interface javax.persistence.criteria.Expression

Perform a typecast upon the expression, returning a new expression object.

as(Class<T>) - Method in interface javax.validation.Path.Node

Narrows the type of this node down to the given type.

asc(Expression<?>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an ordering by the ascending value of the expression.

asMap() - Method in class javax.ws.rs.core.Form

Returns multivalued map representation of the form.

AssertFalse - Annotation Type in javax.validation.constraints

The annotated element must be false.

AssertFalse.List - Annotation Type in javax.validation.constraints

Defines several AssertFalse annotations on the same element.

AssertTrue - Annotation Type in javax.validation.constraints

The annotated element must be true.

AssertTrue.List - Annotation Type in javax.validation.constraints

Defines several AssertTrue annotations on the same element.

associateConnection(Object, ManagedConnectionFactory, ConnectionRequestInfo) - Method in interface javax.resource.spi.LazyAssociatableConnectionManager

This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.

associateConnection(Object) - Method in interface javax.resource.spi.ManagedConnection

Used typically by the container to change the association of an application-level connection handle with a ManagedConneciton instance.

Association - Interface in javax.xml.registry.infomodel

A RegistryObject instance may be associated with zero or more RegistryObject instances.

ASSOCIATION - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.Association interface.

AssociationOverride - Annotation Type in javax.persistence

Used to override a mapping for an entity relationship.

AssociationOverrides - Annotation Type in javax.persistence

Used to override mappings of multiple relationship properties or fields.

async() - Method in interface javax.ws.rs.client.Invocation.Builder

Access the asynchronous uniform request invocation interface to asynchronously invoke the built request.

ASYNC_CONTEXT_PATH - Static variable in interface javax.servlet.AsyncContext

The name of the request attribute under which the original context path is made available to the target of a AsyncContext.dispatch(String) or AsyncContext.dispatch(ServletContext,String)

ASYNC_PATH_INFO - Static variable in interface javax.servlet.AsyncContext

The name of the request attribute under which the original path info is made available to the target of a AsyncContext.dispatch(String) or AsyncContext.dispatch(ServletContext,String)

ASYNC_QUERY_STRING - Static variable in interface javax.servlet.AsyncContext

The name of the request attribute under which the original query string is made available to the target of a AsyncContext.dispatch(String) or AsyncContext.dispatch(ServletContext,String)

ASYNC_REQUEST_URI - Static variable in interface javax.servlet.AsyncContext

The name of the request attribute under which the original request URI is made available to the target of a AsyncContext.dispatch(String) or AsyncContext.dispatch(ServletContext,String)

ASYNC_SERVLET_PATH - Static variable in interface javax.servlet.AsyncContext

The name of the request attribute under which the original servlet path is made available to the target of a AsyncContext.dispatch(String) or AsyncContext.dispatch(ServletContext,String)

AsyncContext - Interface in javax.servlet

Class representing the execution context for an asynchronous operation that was initiated on a ServletRequest.

AsyncEvent - Class in javax.servlet

Event that gets fired when the asynchronous operation initiated on a ServletRequest (via a call to ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse)) has completed, timed out, or produced an error.

AsyncEvent(AsyncContext) - Constructor for class javax.servlet.AsyncEvent

Constructs an AsyncEvent from the given AsyncContext.

AsyncEvent(AsyncContext, ServletRequest, ServletResponse) - Constructor for class javax.servlet.AsyncEvent

Constructs an AsyncEvent from the given AsyncContext, ServletRequest, and ServletResponse.

AsyncEvent(AsyncContext, Throwable) - Constructor for class javax.servlet.AsyncEvent

Constructs an AsyncEvent from the given AsyncContext and Throwable.

AsyncEvent(AsyncContext, ServletRequest, ServletResponse, Throwable) - Constructor for class javax.servlet.AsyncEvent

Constructs an AsyncEvent from the given AsyncContext, ServletRequest, ServletResponse, and Throwable.

AsyncHandler<T> - Interface in javax.xml.ws

The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.

Asynchronous - Annotation Type in javax.ejb

Used to mark a session bean method as an asynchronous method or to designate all business methods of a session bean class as asynchronous.

AsyncInvoker - Interface in javax.ws.rs.client

Uniform interface for asynchronous invocation of HTTP methods.

AsyncListener - Interface in javax.servlet

Listener that will be notified in the event that an asynchronous operation initiated on a ServletRequest to which the listener had been added has completed, timed out, or resulted in an error.

AsyncResponse - Interface in javax.ws.rs.container

An injectable JAX-RS asynchronous response that provides means for asynchronous server side response processing.

AsyncResult<V> - Class in javax.ejb

Wraps the result of an asynchronous method call as a Future object, preserving compatability with the business interface signature.

AsyncResult(V) - Constructor for class javax.ejb.AsyncResult

Creates a AsyncResult instance to wrap the result of an asynchronous method call

AT_BEGIN - Static variable in class javax.servlet.jsp.tagext.VariableInfo

Scope information that scripting variable is visible after start tag.

AT_END - Static variable in class javax.servlet.jsp.tagext.VariableInfo

Scope information that scripting variable is visible after end tag.

atIndex(Integer) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder

Defines the index the object is into the List or array

atIndex(Integer) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder

Defines the index the object is into the List or array.

atKey(Object) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder

Defines the key the object is into the Map.

atKey(Object) - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder

Defines the key the object is into the Map.

ATOM - Static variable in class javax.mail.internet.HeaderTokenizer.Token

Token type indicating an ATOM.

ATTACHED_OBJECT_TARGETS_KEY - Static variable in interface javax.faces.view.AttachedObjectTarget

The key in the value set of the composite component BeanDescriptor, the value for which is a List<AttachedObjectTarget>.

AttachedObjectHandler - Interface in javax.faces.view

The abstract base interface for a handler representing an attached object in a VDL page.

AttachedObjectTarget - Interface in javax.faces.view

Within the declaration of a composite component, an AttachedObjectTarget allows the composite component author to expose the semantics of an inner component to the page author without exposing the rendering or implementation details of the inner component.

attachFile(File) - Method in class javax.mail.internet.MimeBodyPart

Use the specified file to provide the data for this part.

attachFile(String) - Method in class javax.mail.internet.MimeBodyPart

Use the specified file to provide the data for this part.

attachFile(File, String, String) - Method in class javax.mail.internet.MimeBodyPart

Use the specified file with the specified Content-Type and Content-Transfer-Encoding to provide the data for this part.

attachFile(String, String, String) - Method in class javax.mail.internet.MimeBodyPart

Use the specified file with the specified Content-Type and Content-Transfer-Encoding to provide the data for this part.

ATTACHMENT - Static variable in interface javax.mail.Part

This part should be presented as an attachment.

AttachmentMarshaller - Class in javax.xml.bind.attachment

Enable JAXB marshalling to optimize storage of binary data.

AttachmentMarshaller() - Constructor for class javax.xml.bind.attachment.AttachmentMarshaller

AttachmentPart - Class in javax.xml.soap

A single attachment to a SOAPMessage object.

AttachmentPart() - Constructor for class javax.xml.soap.AttachmentPart

AttachmentUnmarshaller - Class in javax.xml.bind.attachment

Enables JAXB unmarshalling of a root document containing optimized binary data formats.

AttachmentUnmarshaller() - Constructor for class javax.xml.bind.attachment.AttachmentUnmarshaller

attachWindow(FacesContext) - Method in class javax.faces.lifecycle.Lifecycle

Create or restore the ClientWindow to be used to display the UIViewRoot for this run through the lifecycle.

attachWindow(FacesContext) - Method in class javax.faces.lifecycle.LifecycleWrapper

Attribute<X,Y> - Interface in javax.persistence.metamodel

Represents an attribute of a Java type.

attribute(QName, String) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.

Attribute.PersistentAttributeType - Enum in javax.persistence.metamodel

attributeAdded(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionAttributeListener

Receives notification that an attribute has been added to a session.

attributeAdded(ServletContextAttributeEvent) - Method in interface javax.servlet.ServletContextAttributeListener

Receives notification that an attribute has been added to the ServletContext.

attributeAdded(ServletRequestAttributeEvent) - Method in interface javax.servlet.ServletRequestAttributeListener

Receives notification that an attribute has been added to the ServletRequest.

AttributeConverter<X,Y> - Interface in javax.persistence

A class that implements this interface can be used to convert entity attribute state into database column representation and back again.

AttributeHandler - Interface in javax.faces.view.facelets

An interface that allows other code to identify FaceletHandlers that correspond to component attributes.

AttributeNode<T> - Interface in javax.persistence

Represents an attribute node of an entity graph.

AttributeOverride - Annotation Type in javax.persistence

Used to override the mapping of a Basic (whether explicit or default) property or field or Id property or field.

AttributeOverrides - Annotation Type in javax.persistence

Used to override mappings of multiple properties or fields.

attributeRemoved(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionAttributeListener

Receives notification that an attribute has been removed from a session.

attributeRemoved(ServletContextAttributeEvent) - Method in interface javax.servlet.ServletContextAttributeListener

Receives notification that an attribute has been removed from the ServletContext.

attributeRemoved(ServletRequestAttributeEvent) - Method in interface javax.servlet.ServletRequestAttributeListener

Receives notification that an attribute has been removed from the ServletRequest.

attributeReplaced(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionAttributeListener

Receives notification that an attribute has been replaced in a session.

attributeReplaced(ServletContextAttributeEvent) - Method in interface javax.servlet.ServletContextAttributeListener

attributeReplaced(ServletRequestAttributeEvent) - Method in interface javax.servlet.ServletRequestAttributeListener

Receives notification that an attribute has been replaced on the ServletRequest.

AttributeTag - Class in javax.faces.webapp

Deprecated.
The Faces implementation must now provide the implementation for this class.

AttributeTag() - Constructor for class javax.faces.webapp.AttributeTag

Deprecated.

ATTRS_WITH_DECLARED_DEFAULT_VALUES - Static variable in class javax.faces.component.UIComponent

This constant enables one to quickly discover the names of the declared composite component attributes that have been given default values by the composite component author.

AUDITABLE_EVENT - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.AuditableEvent interface.

AuditableEvent - Interface in javax.xml.registry.infomodel

AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject.

AuthConfig - Interface in javax.security.auth.message.config

This interface defines the common functionality implemented by Authentication context configuration objects.

AuthConfigFactory - Class in javax.security.auth.message.config

This class is used to obtain AuthConfigProvider objects that can be used to obtain authentication context configuration objects, that is, ClientAuthConfig and ServerAuthConfig objects.

AuthConfigFactory() - Constructor for class javax.security.auth.message.config.AuthConfigFactory

AuthConfigFactory.RegistrationContext - Interface in javax.security.auth.message.config

Represents the layer identifier, application context identifier, and description components of an AuthConfigProvider registration at the factory.

AuthConfigProvider - Interface in javax.security.auth.message.config

This interface is implemented by objects that can be used to obtain authentication context configuration objects, that is, ClientAuthConfig or ServerAuthConfig objects.

authenticate(HttpServletResponse) - Method in interface javax.servlet.http.HttpServletRequest

Use the container login mechanism configured for the ServletContext to authenticate the user making this request.

authenticate(HttpServletResponse) - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to call authenticate on the wrapped request object.

AUTHENTICATE_CONTENT - Static variable in interface javax.security.auth.message.MessagePolicy.ProtectionPolicy

The identifer for a ProtectionPolicy that indicates that the origin of data within the message is to be authenticated (that is, the message is to be protected such that its recipients can establish who defined the message content).

AUTHENTICATE_RECIPIENT - Static variable in interface javax.security.auth.message.MessagePolicy.ProtectionPolicy

The identifer for a ProtectionPolicy that indicates that the message recipient is to be authenticated.

AUTHENTICATE_SENDER - Static variable in interface javax.security.auth.message.MessagePolicy.ProtectionPolicy

The identifer for a ProtectionPolicy that indicates that the sending entity is to be authenticated.

AUTHENTICATION - Static variable in class javax.ws.rs.Priorities

Security authentication filter/interceptor priority.

AuthenticationFailedException - Exception in javax.mail

This exception is thrown when the connect method on a Store or Transport object fails due to an authentication failure (e.g., bad user name or password).

AuthenticationFailedException() - Constructor for exception javax.mail.AuthenticationFailedException

Constructs an AuthenticationFailedException.

AuthenticationFailedException(String) - Constructor for exception javax.mail.AuthenticationFailedException

Constructs an AuthenticationFailedException with the specified detail message.

AuthenticationFailedException(String, Exception) - Constructor for exception javax.mail.AuthenticationFailedException

Constructs an AuthenticationFailedException with the specified detail message and embedded exception.

AuthenticationMechanism - Annotation Type in javax.resource.spi

AuthenticationMechanism.CredentialInterface - Enum in javax.resource.spi

An enumerated type that represents the various interfaces that a resource adapter may support for the representation of the credentials.

Authenticator - Class in javax.mail

The class Authenticator represents an object that knows how to obtain authentication for a network connection.

Authenticator() - Constructor for class javax.mail.Authenticator

AuthException - Exception in javax.security.auth.message

A generic authentication exception.

AuthException() - Constructor for exception javax.security.auth.message.AuthException

Constructs an AuthException with no detail message.

AuthException(String) - Constructor for exception javax.security.auth.message.AuthException

Constructs an AuthException with the specified detail message.

AUTHORIZATION - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

AUTHORIZATION - Static variable in class javax.ws.rs.Priorities

Security authorization filter/interceptor priority.

AUTHORIZED_NAME_SLOT - Static variable in interface javax.xml.registry.infomodel.Slot

Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.

AuthStatus - Class in javax.security.auth.message

The AuthStatus class is used to represent return values from Authentication modules and Authentication Contexts.

AUTO_ACKNOWLEDGE - Static variable in interface javax.jms.JMSContext

With this session mode, the JMSContext's session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.

AUTO_ACKNOWLEDGE - Static variable in interface javax.jms.Session

With this acknowledgment mode, the session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.

autoFlush - Variable in class javax.servlet.jsp.JspWriter

Whether the JspWriter is autoflushing.

available() - Method in class javax.mail.util.SharedFileInputStream

Returns the number of bytes that can be read from this input stream without blocking.

avg(Expression<N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an aggregate expression applying the avg operation.

B

BadRequestException - Exception in javax.ws.rs

A runtime exception indicating a bad client request.

BadRequestException() - Constructor for exception javax.ws.rs.BadRequestException

Construct a new bad client request exception.

BadRequestException(String) - Constructor for exception javax.ws.rs.BadRequestException

Construct a new bad client request exception.

BadRequestException(Response) - Constructor for exception javax.ws.rs.BadRequestException

Construct a new bad client request exception.

BadRequestException(String, Response) - Constructor for exception javax.ws.rs.BadRequestException

Construct a new bad client request exception.

BadRequestException(Throwable) - Constructor for exception javax.ws.rs.BadRequestException

Construct a new bad client request exception.

BadRequestException(String, Throwable) - Constructor for exception javax.ws.rs.BadRequestException

Construct a new bad client request exception.

BadRequestException(Response, Throwable) - Constructor for exception javax.ws.rs.BadRequestException

Construct a new bad client request exception.

BadRequestException(String, Response, Throwable) - Constructor for exception javax.ws.rs.BadRequestException

Construct a new bad client request exception.

baseUri(URI) - Method in interface javax.ws.rs.core.Link.Builder

Set the base URI for resolution of relative URIs.

baseUri(String) - Method in interface javax.ws.rs.core.Link.Builder

Set the base URI as a string for resolution of relative URIs.

Basic - Annotation Type in javax.persistence

The simplest type of mapping to a database column.

BASIC_AUTH - Static variable in class javax.faces.context.ExternalContext

String identifier for BASIC authentication.

BASIC_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest

String identifier for Basic authentication.

BASIC_AUTH - Static variable in interface javax.ws.rs.core.SecurityContext

String identifier for Basic authentication.

BasicType<X> - Interface in javax.persistence.metamodel

Instances of the type BasicType represent basic types (including temporal and enumerated types).

Batchlet - Interface in javax.batch.api

A batchlet is type of batch step that can be used for any type of background processing that does not explicitly call for a chunk oriented approach.

BatchProperty - Annotation Type in javax.batch.api

BatchRuntime - Class in javax.batch.runtime

BatchRuntime represents the JSR 352 Batch Runtime.

BatchRuntime() - Constructor for class javax.batch.runtime.BatchRuntime

BatchRuntimeException - Exception in javax.batch.operations

BatchRuntimeException() - Constructor for exception javax.batch.operations.BatchRuntimeException

BatchRuntimeException(String) - Constructor for exception javax.batch.operations.BatchRuntimeException

BatchRuntimeException(Throwable) - Constructor for exception javax.batch.operations.BatchRuntimeException

BatchRuntimeException(String, Throwable) - Constructor for exception javax.batch.operations.BatchRuntimeException

BatchStatus - Enum in javax.batch.runtime

BatchStatus enum defines the batch status values possible for a job.

BCC - Static variable in class javax.mail.Message.RecipientType

The "Bcc" (blind carbon copy) recipients.

Bean<T> - Interface in javax.enterprise.inject.spi

Represents an enabled bean.

BEAN_ADDED - Static variable in class javax.enterprise.deploy.model.XpathEvent

Adding a DDBean

BEAN_CHANGED - Static variable in class javax.enterprise.deploy.model.XpathEvent

Changing a DDBean

BEAN_REMOVED - Static variable in class javax.enterprise.deploy.model.XpathEvent

Removing a DDBean

BeanAttributes<T> - Interface in javax.enterprise.inject.spi

The BeanAttributes interface exposes the basic attributes of a bean.

BeanDescriptor - Interface in javax.validation.metadata

Describes a constrained Java Bean and the constraints associated to it.

BeanELResolver - Class in javax.el

Defines property resolution behavior on objects using the JavaBeans component architecture.

BeanELResolver() - Constructor for class javax.el.BeanELResolver

Creates a new read/write BeanELResolver.

BeanELResolver(boolean) - Constructor for class javax.el.BeanELResolver

Creates a new BeanELResolver whose read-only status is determined by the given parameter.

BEANINFO_KEY - Static variable in class javax.faces.component.UIComponent

The value of this constant is used as the key in the component attribute map, the value for which is a java.beans.BeanInfo implementation describing the composite component.

BeanManager - Interface in javax.enterprise.inject.spi

Allows a portable extension to interact directly with the container.

BeanNameELResolver - Class in javax.el

An ELResolver for resolving user or container managed beans.

BeanNameELResolver(BeanNameResolver) - Constructor for class javax.el.BeanNameELResolver

Constructor

BeanNameResolver - Class in javax.el

Resolves a bean by its known name.

BeanNameResolver() - Constructor for class javax.el.BeanNameResolver

BeanNotFoundException - Exception in javax.enterprise.deploy.spi.exceptions

This exception is to report that the bean is not a child of the parent bean.

BeanNotFoundException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.BeanNotFoundException

Creates an new BeanNotFoundException object.

BeanParam - Annotation Type in javax.ws.rs

The annotation that may be used to inject custom JAX-RS "parameter aggregator" value object into a resource class field, property or resource method parameter.

BeanValidator - Class in javax.faces.validator

A Validator that delegates validation of the bean property to the Bean Validation API.

BeanValidator() - Constructor for class javax.faces.validator.BeanValidator

BeforeBeanDiscovery - Interface in javax.enterprise.inject.spi

This event type is thrown by the container before the bean discovery process begins.

beforeChunk() - Method in class javax.batch.api.chunk.listener.AbstractChunkListener

Override this method if the ChunkListener will do something before the chunk begins.

beforeChunk() - Method in interface javax.batch.api.chunk.listener.ChunkListener

The beforeChunk method receives control before processing of the next chunk begins.

BeforeCompletion - Annotation Type in javax.ejb

Designate a stateful session bean method to receive the before completion session synchronization callback.

beforeCompletion() - Method in interface javax.ejb.SessionSynchronization

The beforeCompletion method notifies a stateful session bean instance that a transaction is about to be committed.

beforeCompletion() - Method in interface javax.transaction.Synchronization

The beforeCompletion method is called by the transaction manager prior to the start of the two-phase transaction commit process.

beforeDelivery(Method) - Method in interface javax.resource.spi.endpoint.MessageEndpoint

This is called by a resource adapter before a message is delivered.

beforeEvaluation(ELContext, String) - Method in class javax.el.EvaluationListener

Receives notification before an EL expression is evaluated

beforeJob() - Method in class javax.batch.api.listener.AbstractJobListener

Override this method if the JobListener will do something before the job begins.

beforeJob() - Method in interface javax.batch.api.listener.JobListener

The beforeJob method receives control before the job execution begins.

beforeMarshal(Object) - Method in class javax.xml.bind.Marshaller.Listener

Callback method invoked before marshalling from source to XML.

beforePartitionedStepCompletion() - Method in class javax.batch.api.partition.AbstractPartitionReducer

Override this method to take action before normal partitioned step processing ends.

beforePartitionedStepCompletion() - Method in interface javax.batch.api.partition.PartitionReducer

The beforePartitionedStepCompletion method receives control at the end of partitioned step processing.

beforePhase(PhaseEvent) - Method in interface javax.faces.event.PhaseListener

Handle a notification that the processing for a particular phase of the request processing lifecycle is about to begin.

beforeProcess(Object) - Method in class javax.batch.api.chunk.listener.AbstractItemProcessListener

Override this method if the ItemProcessListener will do something before the item is processed.

beforeProcess(Object) - Method in interface javax.batch.api.chunk.listener.ItemProcessListener

The beforeProcess method receives control before an item processor is called to process the next item.

beforeRead() - Method in class javax.batch.api.chunk.listener.AbstractItemReadListener

Override this method if the ItemReadListener will do something before the item is read.

beforeRead() - Method in interface javax.batch.api.chunk.listener.ItemReadListener

The beforeRead method receives control before an item reader is called to read the next item.

beforeRequest(Map<String, List<String>>) - Method in class javax.websocket.ClientEndpointConfig.Configurator

This method is called by the implementation after it has formulated the handshake request that will be used to initiate the connection to the server, but before it has sent any part of the request.

BeforeShutdown - Interface in javax.enterprise.inject.spi

The type of the final event the container fires after it has finished processing requests and destroyed all contexts.

beforeStep() - Method in class javax.batch.api.listener.AbstractStepListener

Override this method if the StepListener will do something before the step begins.

beforeStep() - Method in interface javax.batch.api.listener.StepListener

The beforeStep method receives control before a step execution begins.

beforeUnmarshal(Object, Object) - Method in class javax.xml.bind.Unmarshaller.Listener

Callback method invoked before unmarshalling into target.

beforeWrite(List<Object>) - Method in class javax.batch.api.chunk.listener.AbstractItemWriteListener

Override this method if the ItemWriteListener will do something before the items are written.

beforeWrite(List<Object>) - Method in interface javax.batch.api.chunk.listener.ItemWriteListener

The beforeWrite method receives control before an item writer is called to write its items.

begin() - Method in interface javax.enterprise.context.Conversation

Mark the current transient conversation long-running.

begin(String) - Method in interface javax.enterprise.context.Conversation

Mark the current transient conversation long-running, with a specified identifier.

begin() - Method in interface javax.persistence.EntityTransaction

Start a resource transaction.

begin() - Method in interface javax.resource.cci.LocalTransaction

Begins a local transaction on an EIS instance.

begin() - Method in interface javax.resource.spi.LocalTransaction

Begin a local transaction

begin - Variable in class javax.servlet.jsp.jstl.core.LoopTagSupport

Starting index ('begin' attribute)

begin() - Method in interface javax.transaction.TransactionManager

Create a new transaction and associate it with the current thread.

begin() - Method in interface javax.transaction.UserTransaction

Create a new transaction and associate it with the current thread.

beginCheckpoint() - Method in class javax.batch.api.chunk.AbstractCheckpointAlgorithm

Override this method for the CheckpointAlgorithm to do something before a checkpoint begins.

beginCheckpoint() - Method in interface javax.batch.api.chunk.CheckpointAlgorithm

The beginCheckpoint method is invoked before the next checkpoint interval begins.

beginPartitionedStep() - Method in class javax.batch.api.partition.AbstractPartitionReducer

Override this method to take action before partitioned step processing begins.

beginPartitionedStep() - Method in interface javax.batch.api.partition.PartitionReducer

The beginPartitionedStep method receives control at the start of partition processing.

beginSpecified - Variable in class javax.servlet.jsp.jstl.core.LoopTagSupport

Boolean flag indicating whether 'begin' was specified.

Behavior - Interface in javax.faces.component.behavior

The Behavior interface is the root API of the component behavior model.

BEHAVIOR_ID - Static variable in class javax.faces.component.behavior.AjaxBehavior

The standard id for this behavior.

BehaviorBase - Class in javax.faces.component.behavior

BehaviorBase is a convenience base class that provides a default implementation of the Behavior contract.

BehaviorBase() - Constructor for class javax.faces.component.behavior.BehaviorBase

BehaviorConfig - Interface in javax.faces.view.facelets

Convey the id of a behavior declared in a view.

BehaviorEvent - Class in javax.faces.event

BehaviorEvent is the event that can be generated from component Behavior.

BehaviorEvent(UIComponent, Behavior) - Constructor for class javax.faces.event.BehaviorEvent

Construct a new event object from the specified source component and behavior.

BehaviorHandler - Class in javax.faces.view.facelets

The FaceletHandler that corresponds to attached objects that represent an instance of ClientBehavior that must be added to the parent component, which must implement ClientBehaviorHolder, with a call to ClientBehaviorHolder.addClientBehavior(java.lang.String, javax.faces.component.behavior.ClientBehavior).

BehaviorHandler(BehaviorConfig) - Constructor for class javax.faces.view.facelets.BehaviorHandler

BehaviorHolderAttachedObjectHandler - Interface in javax.faces.view

Represent an attached object that is a BehaviorHolder in a VDL page.

BehaviorHolderAttachedObjectTarget - Interface in javax.faces.view

Represent a BehaviorHolder attached object target in a VDL page.

BehaviorListener - Interface in javax.faces.event

A generic base interface for event listeners for various types of BehaviorEvents.

between(Expression<? extends Y>, Expression<? extends Y>, Expression<? extends Y>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is between the second and third arguments in value.

between(Expression<? extends Y>, Y, Y) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is between the second and third arguments in value.

BigDecimalConverter - Class in javax.faces.convert

Converter implementation for java.math.BigDecimal values.

BigDecimalConverter() - Constructor for class javax.faces.convert.BigDecimalConverter

BigDecimalHolder - Class in javax.xml.rpc.holders

BigDecimalHolder() - Constructor for class javax.xml.rpc.holders.BigDecimalHolder

BigDecimalHolder(BigDecimal) - Constructor for class javax.xml.rpc.holders.BigDecimalHolder

bigDecimalValue() - Method in interface javax.json.JsonNumber

Returns this JSON number as a BigDecimal object.

BIGINTEGER_ID - Static variable in class javax.faces.convert.BigIntegerConverter

The message identifier of the FacesMessage to be created if the conversion to BigInteger fails.

BigIntegerConverter - Class in javax.faces.convert

Converter implementation for java.math.BigInteger values.

BigIntegerConverter() - Constructor for class javax.faces.convert.BigIntegerConverter

BigIntegerHolder - Class in javax.xml.rpc.holders

BigIntegerHolder() - Constructor for class javax.xml.rpc.holders.BigIntegerHolder

BigIntegerHolder(BigInteger) - Constructor for class javax.xml.rpc.holders.BigIntegerHolder

bigIntegerValue() - Method in interface javax.json.JsonNumber

Returns this JSON number as a BigInteger object.

bigIntegerValueExact() - Method in interface javax.json.JsonNumber

Returns this JSON number as a BigDecimal object.

Bindable<T> - Interface in javax.persistence.metamodel

Instances of the type Bindable represent object or attribute types that can be bound into a Path.

Bindable.BindableType - Enum in javax.persistence.metamodel

Binder<XmlNode> - Class in javax.xml.bind

Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.

Binder() - Constructor for class javax.xml.bind.Binder

Binding - Interface in javax.xml.ws

The Binding interface is the base interface for JAX-WS protocol bindings.

BindingProvider - Interface in javax.xml.ws

The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.

bindings - Variable in class javax.faces.component.UIComponent

Deprecated.

BindingType - Annotation Type in javax.xml.ws

The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.

BODY_CONTENT_EMPTY - Static variable in class javax.servlet.jsp.tagext.TagInfo

Static constant for getBodyContent() when it is empty.

BODY_CONTENT_JSP - Static variable in class javax.servlet.jsp.tagext.TagInfo

Static constant for getBodyContent() when it is JSP.

BODY_CONTENT_SCRIPTLESS - Static variable in class javax.servlet.jsp.tagext.TagInfo

Static constant for getBodyContent() when it is scriptless.

BODY_CONTENT_TAG_DEPENDENT - Static variable in class javax.servlet.jsp.tagext.TagInfo

Static constant for getBodyContent() when it is Tag dependent.

bodyContent - Variable in class javax.faces.webapp.UIComponentClassicTagBase

The bodyContent for this tag handler.

BodyContent - Class in javax.servlet.jsp.tagext

An encapsulation of the evaluation of the body of an action so it is available to a tag handler.

BodyContent(JspWriter) - Constructor for class javax.servlet.jsp.tagext.BodyContent

Protected constructor.

bodyContent - Variable in class javax.servlet.jsp.tagext.BodyTagSupport

The current BodyContent for this BodyTag.

BodyPart - Class in javax.mail

This class models a Part that is contained within a Multipart.

BodyPart() - Constructor for class javax.mail.BodyPart

BodyTag - Interface in javax.servlet.jsp.tagext

The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.

BodyTagSupport - Class in javax.servlet.jsp.tagext

A base class for defining tag handlers implementing BodyTag.

BodyTagSupport() - Constructor for class javax.servlet.jsp.tagext.BodyTagSupport

Default constructor, all subclasses are required to only define a public constructor with the same signature, and to call the superclass constructor.

BodyTerm - Class in javax.mail.search

This class implements searches on a message body.

BodyTerm(String) - Constructor for class javax.mail.search.BodyTerm

Constructor

BOOLEAN_ID - Static variable in class javax.faces.convert.BooleanConverter

The message identifier of the FacesMessage to be created if the conversion to Boolean fails.

BooleanConverter - Class in javax.faces.convert

Converter implementation for java.lang.Boolean (and boolean primitive) values.

BooleanConverter() - Constructor for class javax.faces.convert.BooleanConverter

BooleanHolder - Class in javax.xml.rpc.holders

BooleanHolder() - Constructor for class javax.xml.rpc.holders.BooleanHolder

BooleanHolder(boolean) - Constructor for class javax.xml.rpc.holders.BooleanHolder

BooleanWrapperHolder - Class in javax.xml.rpc.holders

BooleanWrapperHolder() - Constructor for class javax.xml.rpc.holders.BooleanWrapperHolder

BooleanWrapperHolder(Boolean) - Constructor for class javax.xml.rpc.holders.BooleanWrapperHolder

BootstrapConfiguration - Interface in javax.validation

Represents the user specified default configuration in META-INF/validation.xml.

BootstrapContext - Interface in javax.resource.spi

This provides a mechanism to pass a bootstrap context to a resource adapter instance when it is bootstrapped.

BootstrapState - Interface in javax.validation.spi

Defines the state used to bootstrap the Configuration.

BoundaryStatistic - Interface in javax.management.j2ee.statistics

Specifies standard measurements of the upper and lower limits of the value of an attribute.

BoundedRangeStatistic - Interface in javax.management.j2ee.statistics

The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.

broadcast(BehaviorEvent) - Method in interface javax.faces.component.behavior.Behavior

Broadcast the specified BehaviorEvent to all registered event listeners who have expressed an interest in events of this type.

broadcast(BehaviorEvent) - Method in class javax.faces.component.behavior.BehaviorBase

Default implementation of Behavior.broadcast(javax.faces.event.BehaviorEvent).

broadcast(FacesEvent) - Method in class javax.faces.component.UICommand

In addition to to the default UIComponent.broadcast(javax.faces.event.FacesEvent) processing, pass the ActionEvent being broadcast to the method referenced by actionListener (if any), and to the default ActionListener registered on the Application.

broadcast(FacesEvent) - Method in class javax.faces.component.UIComponent

Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type.

broadcast(FacesEvent) - Method in class javax.faces.component.UIComponentBase

broadcast(FacesEvent) - Method in class javax.faces.component.UIData

Override the default UIComponentBase.broadcast(javax.faces.event.FacesEvent) processing to unwrap any wrapped FacesEvent and reset the current row index, before the event is actually broadcast.

broadcast(FacesEvent) - Method in class javax.faces.component.UIViewAction

Enable the method invocation specified by this component instance to return a value that performs navigation, similar in spirit to UICommand.broadcast(javax.faces.event.FacesEvent).

broadcastEvents(FacesContext, PhaseId) - Method in class javax.faces.component.UIViewRoot

Broadcast any events that have been queued.

bufferEntity() - Method in class javax.ws.rs.core.Response

Buffer the message entity data.

bufferSize - Variable in class javax.servlet.jsp.JspWriter

The size of the buffer used by the JspWriter.

bufpos - Variable in class javax.mail.util.SharedFileInputStream

The file offset that corresponds to the first byte in the read buffer.

bufsize - Variable in class javax.mail.util.SharedFileInputStream

The normal size of the read buffer.

build() - Method in interface javax.json.JsonArrayBuilder

Returns the current array.

build() - Method in interface javax.json.JsonObjectBuilder

Returns the JSON object associated with this object builder.

build() - Method in class javax.websocket.ClientEndpointConfig.Builder

Builds a configuration object using the attributes set on this builder.

build() - Method in class javax.websocket.server.ServerEndpointConfig.Builder

Builds the configuration object using the current attributes that have been set on this builder object.

build() - Method in class javax.ws.rs.client.ClientBuilder

Build a new client instance using all the configuration previously specified in this client builder.

build(String) - Method in interface javax.ws.rs.client.Invocation.Builder

Build a request invocation using an arbitrary request method name.

build(String, Entity<?>) - Method in interface javax.ws.rs.client.Invocation.Builder

Build a request invocation using an arbitrary request method name and request entity.

build(Object...) - Method in interface javax.ws.rs.core.Link.Builder

Finish building this link using the supplied values as URI parameters.

build() - Method in class javax.ws.rs.core.Response.ResponseBuilder

Create a Response instance from the current ResponseBuilder.

build(Object...) - Method in class javax.ws.rs.core.UriBuilder

Build a URI, using the supplied values in order to replace any URI template parameters.

build(Object[], boolean) - Method in class javax.ws.rs.core.UriBuilder

Build a URI, using the supplied values in order to replace any URI template parameters.

build() - Method in class javax.ws.rs.core.Variant.VariantListBuilder

Add the current combination of metadata to the list of supported variants (provided the current combination of metadata is not empty) and build a list of representation variants from the current state of the builder.

build() - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.

buildConstraintViolationWithTemplate(String) - Method in interface javax.validation.ConstraintValidatorContext

Returns a constraint violation builder building a violation report allowing to optionally associate it to a sub path.

buildDefaultValidatorFactory() - Static method in class javax.validation.Validation

Builds and returns a ValidatorFactory instance based on the default Bean Validation provider and following the XML configuration.

buildDelete() - Method in interface javax.ws.rs.client.Invocation.Builder

Build a DELETE request invocation.

buildFromEncoded(Object...) - Method in class javax.ws.rs.core.UriBuilder

Build a URI.

buildFromEncodedMap(Map<String, ?>) - Method in class javax.ws.rs.core.UriBuilder

Build a URI.

buildFromMap(Map<String, ?>) - Method in class javax.ws.rs.core.UriBuilder

Build a URI.

buildFromMap(Map<String, ?>, boolean) - Method in class javax.ws.rs.core.UriBuilder

Build a URI.

buildGet() - Method in interface javax.ws.rs.client.Invocation.Builder

Build a GET request invocation.

buildPost(Entity<?>) - Method in interface javax.ws.rs.client.Invocation.Builder

Build a POST request invocation.

buildPut(Entity<?>) - Method in interface javax.ws.rs.client.Invocation.Builder

Build a PUT request invocation.

buildRelativized(URI, Object...) - Method in interface javax.ws.rs.core.Link.Builder

Finish building this link using the supplied values as URI parameters and relativize the result with respect to the supplied URI.

buildValidatorFactory() - Method in interface javax.validation.Configuration

Build a ValidatorFactory implementation.

buildValidatorFactory(ConfigurationState) - Method in interface javax.validation.spi.ValidationProvider

Build a ValidatorFactory using the current provider implementation.

buildView(FacesContext, UIViewRoot) - Method in class javax.faces.view.ViewDeclarationLanguage

Take any actions specific to this VDL implementation to cause the argument UIViewRoot which must have been created via a call to ViewDeclarationLanguage.createView(javax.faces.context.FacesContext, java.lang.String), to be populated with children.

buildView(FacesContext, UIViewRoot) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

BulkResponse - Interface in javax.xml.registry

Contains the response of a method in the API that performs a bulk operation and returns a bulk response.

BusinessLifeCycleManager - Interface in javax.xml.registry

The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API.

BusinessQueryManager - Interface in javax.xml.registry

The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface.

BusyConversationException - Exception in javax.enterprise.context

Indicates that the container has rejected a request because a concurrent request is associated with the same conversation context.

BusyConversationException() - Constructor for exception javax.enterprise.context.BusyConversationException

BusyConversationException(String) - Constructor for exception javax.enterprise.context.BusyConversationException

BusyConversationException(Throwable) - Constructor for exception javax.enterprise.context.BusyConversationException

BusyConversationException(String, Throwable) - Constructor for exception javax.enterprise.context.BusyConversationException

byDefaultProvider() - Static method in class javax.validation.Validation

Builds a Configuration.

byProvider(Class<U>) - Static method in class javax.validation.Validation

Builds a Configuration for a particular provider implementation.

BYTE_ID - Static variable in class javax.faces.convert.ByteConverter

The message identifier of the FacesMessage to be created if the conversion to Byte fails.

ByteArrayDataSource - Class in javax.mail.util

A DataSource backed by a byte array.

ByteArrayDataSource(InputStream, String) - Constructor for class javax.mail.util.ByteArrayDataSource

Create a ByteArrayDataSource with data from the specified InputStream and with the specified MIME type.

ByteArrayDataSource(byte[], String) - Constructor for class javax.mail.util.ByteArrayDataSource

Create a ByteArrayDataSource with data from the specified byte array and with the specified MIME type.

ByteArrayDataSource(String, String) - Constructor for class javax.mail.util.ByteArrayDataSource

Create a ByteArrayDataSource with data from the specified String and with the specified MIME type.

ByteArrayHolder - Class in javax.xml.rpc.holders

ByteArrayHolder() - Constructor for class javax.xml.rpc.holders.ByteArrayHolder

ByteArrayHolder(byte[]) - Constructor for class javax.xml.rpc.holders.ByteArrayHolder

ByteConverter - Class in javax.faces.convert

Converter implementation for java.lang.Byte (and byte primitive) values.

ByteConverter() - Constructor for class javax.faces.convert.ByteConverter

ByteHolder - Class in javax.xml.rpc.holders

ByteHolder() - Constructor for class javax.xml.rpc.holders.ByteHolder

ByteHolder(byte) - Constructor for class javax.xml.rpc.holders.ByteHolder

BytesMessage - Interface in javax.jms

A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.

ByteWrapperHolder - Class in javax.xml.rpc.holders

ByteWrapperHolder() - Constructor for class javax.xml.rpc.holders.ByteWrapperHolder

ByteWrapperHolder(Byte) - Constructor for class javax.xml.rpc.holders.ByteWrapperHolder

C

Cache - Interface in javax.persistence

Interface used to interact with the second-level cache.

CACHE_CONTROL - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

Cacheable - Annotation Type in javax.persistence

Specifies whether an entity should be cached if caching is enabled when the value of the persistence.xml caching element is ENABLE_SELECTIVE or DISABLE_SELECTIVE.

cacheControl(CacheControl) - Method in interface javax.ws.rs.client.Invocation.Builder

Set the cache control data of the message.

CacheControl - Class in javax.ws.rs.core

An abstraction for the value of a HTTP Cache-Control response header.

CacheControl() - Constructor for class javax.ws.rs.core.CacheControl

Create a new instance of CacheControl.

cacheControl(CacheControl) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the cache control data of the message.

cachedContent - Variable in class javax.mail.internet.MimeBodyPart

If our content is a Multipart of Message object, we save it the first time it's created by parsing a stream so that changes to the contained objects will not be lost.

cachedContent - Variable in class javax.mail.internet.MimeMessage

If our content is a Multipart or Message object, we save it the first time it's created by parsing a stream so that changes to the contained objects will not be lost.

CacheRetrieveMode - Enum in javax.persistence

Used as the value of the javax.persistence.cache.retrieveMode property to specify the behavior when data is retrieved by the find methods and by queries.

CacheStoreMode - Enum in javax.persistence

Used as the value of the javax.persistence.cache.storeMode property to specify the behavior when data is read from the database and when data is committed into the database.

calculateCharacterEncoding(FacesContext) - Method in class javax.faces.application.ViewHandler

Returns the correct character encoding to be used for this request.

calculateCharacterEncoding(FacesContext) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.calculateCharacterEncoding(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

calculateLocale(FacesContext) - Method in class javax.faces.application.ViewHandler

Returns an appropriate Locale to use for this and subsequent requests for the current client.

calculateLocale(FacesContext) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.calculateLocale(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

calculateRenderKitId(FacesContext) - Method in class javax.faces.application.ViewHandler

Return an appropriate renderKitId for this and subsequent requests from the current client.

calculateRenderKitId(FacesContext) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

calculateResourceLibraryContracts(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguage

Return the list of resource library contracts that will be made available for use in the view specified by the argument viewId.

calculateResourceLibraryContracts(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

CalendarHolder - Class in javax.xml.rpc.holders

CalendarHolder() - Constructor for class javax.xml.rpc.holders.CalendarHolder

CalendarHolder(Calendar) - Constructor for class javax.xml.rpc.holders.CalendarHolder

Call - Interface in javax.xml.rpc

The javax.xml.rpc.Call interface provides support for the dynamic invocation of a service endpoint.

call(SOAPMessage, Object) - Method in class javax.xml.soap.SOAPConnection

Sends the given message to the specified endpoint and blocks until it has returned the response.

CallerPrincipalCallback - Class in javax.security.auth.message.callback

Callback for setting the container's caller (or Remote user) principal.

CallerPrincipalCallback(Subject, Principal) - Constructor for class javax.security.auth.message.callback.CallerPrincipalCallback

Create a CallerPrincipalCallback to set the container's representation of the caller principal

CallerPrincipalCallback(Subject, String) - Constructor for class javax.security.auth.message.callback.CallerPrincipalCallback

Create a CallerPrincipalCallback to set the container's representation of the caller principal.

canBeRequestTime() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

Whether this attribute has been specified in the TLD as rtexprvalue.

cancel(boolean) - Method in class javax.ejb.AsyncResult

This method should not be called.

cancel() - Method in interface javax.ejb.Timer

Cause the timer and all its associated expiration notifications to be cancelled.

CANCEL - Static variable in class javax.enterprise.deploy.shared.ActionType

A cancel operation is being preformed on the DeploymentManager action command.

cancel() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject

(optional) A cancel request on an in-process operation stops all further processing of the operation and returns the environment to it original state before the operation was executed.

cancel() - Method in interface javax.ws.rs.container.AsyncResponse

Cancel the suspended request processing.

cancel(int) - Method in interface javax.ws.rs.container.AsyncResponse

Cancel the suspended request processing.

cancel(Date) - Method in interface javax.ws.rs.container.AsyncResponse

Cancel the suspended request processing.

canCreateBean(String) - Method in class javax.el.BeanNameResolver

Allow creating a bean of the given name if it does not exist.

CapabilityProfile - Interface in javax.xml.registry

Provides information about the capabilities of a JAXR provider.

CAR - Static variable in class javax.enterprise.deploy.shared.ModuleType

The module is an Client Application archive.

CascadableDescriptor - Interface in javax.validation.metadata

Represents a cascadable element.

CascadeType - Enum in javax.persistence

Defines the set of cascadable operations that are propagated to the associated entity.

CASE_SENSITIVE_MATCH - Static variable in interface javax.xml.registry.FindQualifier

Specifies a hint to queries that they should case-sensitive match when comparing String values.

cause - Variable in exception javax.xml.registry.JAXRException

The Throwable that caused this JAXRException to occur.

CC - Static variable in class javax.mail.Message.RecipientType

The "Cc" (carbon copy) recipients.

CDI<T> - Class in javax.enterprise.inject.spi

Provides access to the current container.

CDI() - Constructor for class javax.enterprise.inject.spi.CDI

CDIProvider - Interface in javax.enterprise.inject.spi

Interface implemented by a CDI provider to provide access to the current container

CertStoreCallback - Class in javax.security.auth.message.callback

Callback for CertStore.

CertStoreCallback() - Constructor for class javax.security.auth.message.callback.CertStoreCallback

Create a CertStoreCallback.

changeSessionId() - Method in interface javax.servlet.http.HttpServletRequest

Change the session id of the current session associated with this request and return the new session id.

changeSessionId() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return changeSessionId() on the wrapped request object.

CHARACTER_ENCODING_KEY - Static variable in class javax.faces.application.ViewHandler

The key, in the session's attribute set, under which the response character encoding may be stored and retrieved.

CHARACTER_ID - Static variable in class javax.faces.convert.CharacterConverter

The message identifier of the FacesMessage to be created if the conversion to Character fails.

CHARACTER_SET_ENCODING - Static variable in class javax.xml.soap.SOAPMessage

Specifies the character type encoding for the SOAP Message.

CharacterConverter - Class in javax.faces.convert

Converter implementation for java.lang.Character (and char primitive) values.

CharacterConverter() - Constructor for class javax.faces.convert.CharacterConverter

CHARSET_PARAMETER - Static variable in class javax.ws.rs.core.MediaType

The media type charset parameter name.

checkOrigin(String) - Method in class javax.websocket.server.ServerEndpointConfig.Configurator

Check the value of the Origin header (See Origin Header) the client passed during the opening handshake.

CheckpointAlgorithm - Interface in javax.batch.api.chunk

CheckpointAlgorithm provides a custom checkpoint policy for chunk steps.

checkpointInfo() - Method in class javax.batch.api.chunk.AbstractItemReader

Override this method if the ItemReader supports checkpoints.

checkpointInfo() - Method in class javax.batch.api.chunk.AbstractItemWriter

Override this method if the ItemWriter supports checkpoints.

checkpointInfo() - Method in interface javax.batch.api.chunk.ItemReader

The checkpointInfo method returns the current checkpoint data for this reader.

checkpointInfo() - Method in interface javax.batch.api.chunk.ItemWriter

The checkpointInfo method returns the current checkpoint data for this writer.

checkpointTimeout() - Method in class javax.batch.api.chunk.AbstractCheckpointAlgorithm

Override this method if the CheckpointAlgorithm establishes a checkpoint timeout.

checkpointTimeout() - Method in interface javax.batch.api.chunk.CheckpointAlgorithm

The checkpointTimeout is invoked at the beginning of a new checkpoint interval for the purpose of establishing the checkpoint timeout.

ChunkListener - Interface in javax.batch.api.chunk.listener

ChunkListener intercepts chunk processing.

Classification - Interface in javax.xml.registry.infomodel

The Classification interface is used to classify RegistryObject instances.

CLASSIFICATION - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.Classification interface.

CLASSIFICATION_SCHEME - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.ClassificationScheme interface.

ClassificationScheme - Interface in javax.xml.registry.infomodel

A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.

ClassTransformer - Interface in javax.persistence.spi

A persistence provider supplies an instance of this interface to the PersistenceUnitInfo.addTransformer method.

cleanSubject(MessageInfo, Subject) - Method in interface javax.security.auth.message.ClientAuth

Remove implementation specific principals and credentials from the subject.

cleanSubject(MessageInfo, Subject) - Method in interface javax.security.auth.message.ServerAuth

Remove method specific principals and credentials from the subject.

cleanup() - Method in interface javax.resource.spi.ManagedConnection

Application server calls this method to force any cleanup on the ManagedConnection instance.

clear() - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.clear() on the wrapped Flash object.

clear() - Method in interface javax.persistence.EntityManager

Clear the persistence context, causing all managed entities to become detached.

clear() - Method in class javax.servlet.jsp.JspWriter

Clear the contents of the buffer.

clear() - Method in class javax.ws.rs.core.AbstractMultivaluedMap

clear() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry

Removes all registered TypeMappings and encodingStyleURIs from this TypeMappingRegistry.

clearBody() - Method in interface javax.jms.Message

Clears out the message body.

clearBody() - Method in class javax.servlet.jsp.tagext.BodyContent

Clear the body without throwing any exceptions.

clearBuffer() - Method in class javax.servlet.jsp.JspWriter

Clears the current contents of the buffer.

clearCachedProviders() - Method in interface javax.persistence.spi.PersistenceProviderResolver

Clear cache of providers.

clearContent() - Method in class javax.xml.soap.AttachmentPart

Clears out the content of this AttachmentPart object.

clearInitialState() - Method in class javax.faces.component.behavior.BehaviorBase

Clears the initial state flag, causing the behavior to revert from partial to full state saving.

clearInitialState() - Method in interface javax.faces.component.PartialStateHolder

Reset the PartialStateHolder to a non-delta tracking state.

clearInitialState() - Method in class javax.faces.component.UIComponent

An implementation of PartialStateHolder.clearInitialState(), this method is called by the runtime to tell the instance to stop tracking state changes.

clearInitialState() - Method in class javax.faces.component.UIComponentBase

For each of the attached objects on this instance that implement PartialStateHolder, call PartialStateHolder.clearInitialState() on the attached object.

clearInitialState() - Method in class javax.faces.component.UIInput

clearInitialState() - Method in class javax.faces.component.UIOutput

clearInitialState() - Method in class javax.faces.convert.DateTimeConverter

clearInitialState() - Method in class javax.faces.convert.EnumConverter

clearInitialState() - Method in class javax.faces.convert.NumberConverter

clearInitialState() - Method in class javax.faces.validator.BeanValidator

clearInitialState() - Method in class javax.faces.validator.DoubleRangeValidator

clearInitialState() - Method in class javax.faces.validator.LengthValidator

clearInitialState() - Method in class javax.faces.validator.LongRangeValidator

clearInitialState() - Method in class javax.faces.validator.RegexValidator

clearPassword() - Method in class javax.security.auth.message.callback.PasswordValidationCallback

Clear the password.

clearProperties() - Method in interface javax.jms.JMSProducer

Clears any message properties set on this JMSProducer

clearProperties() - Method in interface javax.jms.Message

Clears a message's properties.

clearWarnings() - Method in interface javax.resource.cci.Interaction

Clears all the warning reported by this Interaction instance.

Client - Interface in javax.ws.rs.client

Client is the main entry point to the fluent API used to build and execute client requests in order to consume responses returned.

CLIENT_ACKNOWLEDGE - Static variable in interface javax.jms.JMSContext

With this session mode, the client acknowledges a consumed message by calling the message's acknowledge method.

CLIENT_ACKNOWLEDGE - Static variable in interface javax.jms.Session

With this acknowledgment mode, the client acknowledges a consumed message by calling the message's acknowledge method.

CLIENT_CERT_AUTH - Static variable in class javax.faces.context.ExternalContext

String identifier for CLIENT_CERT authentication.

CLIENT_CERT_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest

String identifier for Client Certificate authentication.

CLIENT_CERT_AUTH - Static variable in interface javax.ws.rs.core.SecurityContext

String identifier for Client Certificate authentication.

CLIENT_WINDOW_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the ClientWindowFactory class name.

CLIENT_WINDOW_MODE_PARAM_NAME - Static variable in class javax.faces.lifecycle.ClientWindow

The context-param that controls the operation of the ClientWindow feature.

CLIENT_WINDOW_PARAM - Static variable in class javax.faces.render.ResponseStateManager

The name of the hidden field that refers to the encoded ClientWindow.

CLIENT_WINDOW_URL_PARAM - Static variable in class javax.faces.render.ResponseStateManager

The name of the URL query parameter for transmitting the client window id.

ClientAuth - Interface in javax.security.auth.message

An implementation of this interface is used to secure service request messages, and validate received service response messages.

ClientAuthConfig - Interface in javax.security.auth.message.config

This interface encapsulates the configuration of ClientAuthContext objects for a message layer and application context (for example, the messaging context of a specific application, or set of applications).

ClientAuthContext - Interface in javax.security.auth.message.config

This ClientAuthContext class encapsulates ClientAuthModules that are used to secure service requests made by a client, and to validate any responses received to those requests.

ClientAuthModule - Interface in javax.security.auth.message.module

A ClientAuthModule secures request messages, and validates received response messages.

ClientBehavior - Interface in javax.faces.component.behavior

ClientBehavior is the base contract for Behaviors that attach script content to client-side events exposed by ClientBehaviorHolder components.

ClientBehaviorBase - Class in javax.faces.component.behavior

ClientBehaviorBase is a convenience base class that implements the default concrete behavior of all methods defined by ClientBehavior.

ClientBehaviorBase() - Constructor for class javax.faces.component.behavior.ClientBehaviorBase

ClientBehaviorContext - Class in javax.faces.component.behavior

ClientBehaviorContext provides context information that may be useful to ClientBehavior.getScript(javax.faces.component.behavior.ClientBehaviorContext) implementations.

ClientBehaviorContext() - Constructor for class javax.faces.component.behavior.ClientBehaviorContext

ClientBehaviorContext.Parameter - Class in javax.faces.component.behavior

Parameter instances represent name/value pairs that "submitting" ClientBehavior implementations should include when posting back into the Faces lifecycle.

ClientBehaviorContext.Parameter(String, Object) - Constructor for class javax.faces.component.behavior.ClientBehaviorContext.Parameter

Creates a Parameter instance.

ClientBehaviorHint - Enum in javax.faces.component.behavior

An enum that specifies hints that describes the behavior of ClientBehavior implementations.

ClientBehaviorHolder - Interface in javax.faces.component.behavior

The ClientBehaviorHolder interface may be implemented by any concrete UIComponent that wishes to support client behaviors as defined by ClientBehavior.

ClientBehaviorRenderer - Class in javax.faces.render

A ClientBehaviorRenderer produces the client-side script that implements a ClientBehavior's client-side logic.

ClientBehaviorRenderer() - Constructor for class javax.faces.render.ClientBehaviorRenderer

ClientBuilder - Class in javax.ws.rs.client

Main entry point to the client API used to bootstrap Client instances.

ClientBuilder() - Constructor for class javax.ws.rs.client.ClientBuilder

Allows custom implementations to extend the ClientBuilder class.

ClientConfiguration - Interface in javax.enterprise.deploy.spi.status

The ClientConfiguration object installs, configures and executes an Application Client.

ClientEndpoint - Annotation Type in javax.websocket

The ClientEndpoint annotation a class level annotation is used to denote that a POJO is a web socket client and can be deployed as such.

ClientEndpointConfig - Interface in javax.websocket

The ClientEndpointConfig is a special kind of endpoint configuration object that contains web socket configuration information specific only to client endpoints.

ClientEndpointConfig.Builder - Class in javax.websocket

The ClientEndpointConfig.Builder is a class used for creating ClientEndpointConfig objects for the purposes of deploying a client endpoint.

ClientEndpointConfig.Configurator - Class in javax.websocket

The Configurator class may be extended by developers who want to provide custom configuration algorithms, such as intercepting the opening handshake, or providing arbitrary methods and algorithms that can be accessed from each endpoint instance configured with this configurator.

ClientEndpointConfig.Configurator() - Constructor for class javax.websocket.ClientEndpointConfig.Configurator

ClientErrorException - Exception in javax.ws.rs

A base runtime application exception indicating a client request error (HTTP 4xx status codes).

ClientErrorException(Response.Status) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(String, Response.Status) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(int) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(String, int) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(Response) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(String, Response) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(Response.Status, Throwable) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(String, Response.Status, Throwable) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(int, Throwable) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(String, int, Throwable) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(Response, Throwable) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientErrorException(String, Response, Throwable) - Constructor for exception javax.ws.rs.ClientErrorException

Construct a new client error exception.

ClientExecuteException - Exception in javax.enterprise.deploy.spi.exceptions

This exception reports errors in setting up an application client for execution.

ClientExecuteException() - Constructor for exception javax.enterprise.deploy.spi.exceptions.ClientExecuteException

Creates new ClientExecuteException without detail message.

ClientExecuteException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.ClientExecuteException

Constructs an ClientExecuteException with the specified detail message.

ClientRequestContext - Interface in javax.ws.rs.client

Client request filter context.

ClientRequestFilter - Interface in javax.ws.rs.client

An extension interface implemented by client request filters.

ClientResponseContext - Interface in javax.ws.rs.client

Client response filter context.

ClientResponseFilter - Interface in javax.ws.rs.client

An extension interface implemented by client response filters.

ClientWindow - Class in javax.faces.lifecycle

This class represents a client window, which may be a browser tab, browser window, browser pop-up, portlet, or anything else that can display a UIComponent hierarchy rooted at a UIViewRoot.

ClientWindow() - Constructor for class javax.faces.lifecycle.ClientWindow

ClientWindowFactory - Class in javax.faces.lifecycle

Create ClientWindow instances based on the incoming request.

ClientWindowFactory() - Constructor for class javax.faces.lifecycle.ClientWindowFactory

clientWindowTransition(FacesContext) - Method in class javax.faces.flow.FlowHandler

Allow for flow transitions in the case of components rendered by the renderers from component-family javax.faces.OutcomeTarget.

ClientWindowWrapper - Class in javax.faces.lifecycle

Wrapper for ClientWindow

ClientWindowWrapper() - Constructor for class javax.faces.lifecycle.ClientWindowWrapper

clone() - Method in class javax.mail.Flags

Returns a clone of this Flags object.

clone() - Method in class javax.mail.internet.InternetAddress

Return a copy of this InternetAddress object.

clone() - Method in interface javax.resource.cci.Record

Creates and returns a copy of this object.

clone() - Method in class javax.servlet.http.Cookie

Overrides the standard java.lang.Object.clone method to return a copy of this Cookie.

clone() - Method in class javax.ws.rs.core.Response.ResponseBuilder

clone() - Method in class javax.ws.rs.core.UriBuilder

Create a copy of the UriBuilder preserving its state.

cloneWithWriter(Writer) - Method in class javax.faces.context.ResponseWriter

Create and return a new instance of this ResponseWriter, using the specified Writer as the output destination.

cloneWithWriter(Writer) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.cloneWithWriter(java.io.Writer) on the wrapped ResponseWriter object.

close() - Method in class javax.batch.api.chunk.AbstractItemReader

Override this method if the ItemReader requires any close time processing.

close() - Method in class javax.batch.api.chunk.AbstractItemWriter

Override this method if the ItemWriter requires any close time processing.

close() - Method in interface javax.batch.api.chunk.ItemReader

The close method marks the end of use of the ItemReader.

close() - Method in interface javax.batch.api.chunk.ItemWriter

The close method marks the end of use of the ItemWriter.

close() - Method in class javax.ejb.embeddable.EJBContainer

Shutdown an embeddable EJBContainer instance.

close() - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call Writer.close() on the wrapped ResponseWriter object.

close() - Method in interface javax.jms.Connection

Closes the connection.

close() - Method in interface javax.jms.ConnectionConsumer

Closes the connection consumer.

close() - Method in interface javax.jms.JMSConsumer

Closes the JMSConsumer.

close() - Method in interface javax.jms.JMSContext

Closes the JMSContext

close() - Method in interface javax.jms.MessageConsumer

Closes the message consumer.

close() - Method in interface javax.jms.MessageProducer

Closes the message producer.

close() - Method in interface javax.jms.QueueBrowser

Closes the QueueBrowser.

close() - Method in class javax.jms.QueueRequestor

Closes the QueueRequestor and its session.

close() - Method in interface javax.jms.Session

Closes the session.

close() - Method in class javax.jms.TopicRequestor

Closes the TopicRequestor and its session.

close() - Method in interface javax.json.JsonReader

Closes this reader and frees any resources associated with the reader.

close() - Method in interface javax.json.JsonWriter

Closes this JSON writer and frees any resources associated with the writer.

close() - Method in interface javax.json.stream.JsonGenerator

Closes this generator and frees any resources associated with it.

close() - Method in interface javax.json.stream.JsonParser

Closes this parser and frees any resources associated with the parser.

close(boolean) - Method in class javax.mail.Folder

Close this Folder.

close() - Method in class javax.mail.Service

Close this service and terminate its connection.

close() - Method in class javax.mail.util.SharedFileInputStream

Closes this input stream and releases any system resources associated with the stream.

close() - Method in interface javax.persistence.EntityManager

Close an application-managed entity manager.

close() - Method in interface javax.persistence.EntityManagerFactory

Close the factory, releasing any resources that it holds.

close() - Method in interface javax.resource.cci.Connection

Initiates close of the connection handle at the application level.

close() - Method in interface javax.resource.cci.Interaction

Closes the current Interaction and release all the resources held for this instance by the resource adapter.

close() - Method in class javax.servlet.jsp.JspWriter

Close the stream, flushing it first.

close() - Method in interface javax.validation.ValidatorFactory

Closes the ValidatorFactory instance.

close() - Method in interface javax.websocket.Session

Close the current conversation with a normal status code and no reason phrase.

close(CloseReason) - Method in interface javax.websocket.Session

Close the current conversation, giving a reason for the closure.

close() - Method in interface javax.ws.rs.client.Client

Close client instance and all it's associated resources.

close() - Method in class javax.ws.rs.core.Response

Close the underlying message entity input stream (if available and open) as well as releases any other resources associated with the response (e.g.

close() - Method in interface javax.xml.registry.Connection

Closes a Connection when it is no longer needed.

close() - Method in class javax.xml.soap.SOAPConnection

Closes this SOAPConnection object.

close(MessageContext) - Method in interface javax.xml.ws.handler.Handler

Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception.

close() - Method in class javax.xml.ws.spi.http.HttpExchange

This must be called to end an exchange.

closed(ConnectionEvent) - Method in class javax.mail.event.ConnectionAdapter

CLOSED - Static variable in class javax.mail.event.ConnectionEvent

A connection was closed.

closed(ConnectionEvent) - Method in interface javax.mail.event.ConnectionListener

Invoked when a Store/Folder/Transport is closed.

CloseReason - Class in javax.websocket

A class encapsulating the reason why a web socket has been closed, or why it is being asked to close.

CloseReason(CloseReason.CloseCode, String) - Constructor for class javax.websocket.CloseReason

Creates a reason for closing a web socket connection with the given code and reason phrase.

CloseReason.CloseCode - Interface in javax.websocket

A marker interface for the close codes.

CloseReason.CloseCodes - Enum in javax.websocket

An Enumeration of status codes for a web socket close that are defined in the specification.

coalesce(Expression<? extends Y>, Expression<? extends Y>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.

coalesce(Expression<? extends Y>, Y) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns null if all its arguments evaluate to null, and the value of the first non-null argument otherwise.

coalesce() - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a coalesce expression.

coerceToType(Object, Class<?>) - Method in class javax.el.ExpressionFactory

Coerces an object to a specific type according to the EL type conversion rules.

CollapsedStringAdapter - Class in javax.xml.bind.annotation.adapters

Built-in XmlAdapter to handle xs:token and its derived types.

CollapsedStringAdapter() - Constructor for class javax.xml.bind.annotation.adapters.CollapsedStringAdapter

CollectionAttribute<X,E> - Interface in javax.persistence.metamodel

Instances of the type CollectionAttribute represent persistent java.util.Collection-valued attributes.

CollectionDataModel<E> - Class in javax.faces.model

CollectionDataModel is a convenience implementation of DataModel that wraps an Collection of Java objects.

CollectionDataModel() - Constructor for class javax.faces.model.CollectionDataModel

Construct a new CollectionDataModel with no specified wrapped data.

CollectionDataModel(Collection<E>) - Constructor for class javax.faces.model.CollectionDataModel

Construct a new CollectionDataModel wrapping the specified list.

CollectionJoin<Z,E> - Interface in javax.persistence.criteria

The CollectionJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Collection.

CollectionTable - Annotation Type in javax.persistence

Specifies the table that is used for the mapping of collections of basic or embeddable types.

collectPartitionData() - Method in interface javax.batch.api.partition.PartitionCollector

The collectPartitionData method receives control periodically during partition processing.

Column - Annotation Type in javax.persistence

Specifies the mapped column for a persistent property or field.

ColumnResult - Annotation Type in javax.persistence

Used in conjunction with the SqlResultSetMapping annotation or ConstructorResult annotation to map a column of the SELECT list of a SQL query.

COMBINE_CLASSIFICATIONS - Static variable in interface javax.xml.registry.FindQualifier

Maps to UDDI combineCategoryBags.

combineSegments() - Method in class javax.mail.internet.ParameterList

Normal users of this class will use simple parameter names.

CommandType - Class in javax.enterprise.deploy.shared

Class CommandTypes defines enumeration values for the DeploymentStatus object.

CommandType(int) - Constructor for class javax.enterprise.deploy.shared.CommandType

Construct a new enumeration value with the given integer value.

COMMENT - Static variable in class javax.mail.internet.HeaderTokenizer.Token

Token type indicating a comment.

CommException - Exception in javax.resource.spi

This indicates errors related to failed or interrupted communication with an EIS instance.

CommException() - Constructor for exception javax.resource.spi.CommException

Constructs a new instance with null as its detail message.

CommException(String) - Constructor for exception javax.resource.spi.CommException

Constructs a new instance with the specified detail message.

CommException(Throwable) - Constructor for exception javax.resource.spi.CommException

Constructs a new throwable with the specified cause.

CommException(String, Throwable) - Constructor for exception javax.resource.spi.CommException

Constructs a new throwable with the specified detail message and cause.

CommException(String, String) - Constructor for exception javax.resource.spi.CommException

Constructs a new throwable with the specified detail message and an error code.

commit() - Method in interface javax.jms.JMSContext

Commits all messages done in this transaction and releases any locks currently held.

commit() - Method in interface javax.jms.Session

Commits all messages done in this transaction and releases any locks currently held.

commit() - Method in interface javax.jms.XAJMSContext

Throws a TransactionInProgressRuntimeException, since it should not be called for an XAJMSContext object.

commit() - Method in interface javax.jms.XASession

Throws a TransactionInProgressException, since it should not be called for an XASession object.

commit() - Method in interface javax.persistence.EntityTransaction

Commit the current resource transaction, writing any unflushed changes to the database.

commit() - Method in interface javax.resource.cci.LocalTransaction

Commits the current local transaction and release all locks held by the underlying EIS instance.

commit() - Method in interface javax.resource.spi.LocalTransaction

Commit a local transaction

commit(Xid, boolean) - Method in interface javax.resource.spi.XATerminator

Commits the global transaction specified by xid.

commit() - Method in interface javax.security.jacc.PolicyConfiguration

This method is used to set to "inService" the state of the policy context whose interface is this PolicyConfiguration Object.

commit() - Method in interface javax.transaction.Transaction

Complete the transaction represented by this Transaction object.

commit() - Method in interface javax.transaction.TransactionManager

Complete the transaction associated with the current thread.

commit() - Method in interface javax.transaction.UserTransaction

Complete the transaction associated with the current thread.

commit(Xid, boolean) - Method in interface javax.transaction.xa.XAResource

Commits the global transaction specified by xid.

CommonAbstractCriteria - Interface in javax.persistence.criteria

The CommonAbstractCriteria interface defines functionality that is common to both top-level criteria queries and subqueries as well as to update and delete criteria operations.

compareTo(Object) - Method in class javax.faces.application.FacesMessage.Severity

Compare this FacesMessage.Severity instance to the specified one.

compareTo(Object) - Method in class javax.faces.event.PhaseId

Compare this PhaseId instance to the specified one.

compareValues(Object, Object) - Method in class javax.faces.component.UIInput

Return true if the new value is different from the previous value.

compareValues(Object, Object) - Method in class javax.faces.component.UISelectMany

Return true if the new value is different from the previous value.

comparison - Variable in class javax.mail.search.ComparisonTerm

The comparison.

ComparisonTerm - Class in javax.mail.search

This class models the comparison operator.

ComparisonTerm() - Constructor for class javax.mail.search.ComparisonTerm

complete - Variable in class javax.mail.internet.MimeMultipart

Have we seen the final bounary line?

complete() - Method in interface javax.servlet.AsyncContext

Completes the asynchronous operation that was started on the request that was used to initialze this AsyncContext, closing the response that was used to initialize this AsyncContext.

COMPLETED - Static variable in class javax.enterprise.deploy.shared.StateType

The action operation has completed normally.

completed(RESPONSE) - Method in interface javax.ws.rs.client.InvocationCallback

Called when the invocation was successfully completed.

CompletionCallback - Interface in javax.ws.rs.container

A request processing callback that receives request processing completion events.

CompletionListener - Interface in javax.jms

A CompletionListener is implemented by the application and may be specified when a message is sent asynchronously.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIColumn

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UICommand

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIData

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIForm

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIGraphic

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIInput

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIMessage

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIMessages

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UINamingContainer

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIOutcomeTarget

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIOutput

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIPanel

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIParameter

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UISelectBoolean

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UISelectItem

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UISelectItems

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UISelectMany

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UISelectOne

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIViewAction

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIViewParameter

The standard component family for this component.

COMPONENT_FAMILY - Static variable in class javax.faces.component.UIViewRoot

The standard component family for this component.

COMPONENT_RESOURCE_KEY - Static variable in class javax.faces.application.Resource

This constant is used as the key in the component attribute map of a composite component to associate the component with its Resource instance.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlBody

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlColumn

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlCommandButton

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlCommandLink

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlDataTable

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlDoctype

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlForm

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlGraphicImage

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlHead

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlInputFile

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlInputHidden

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlInputSecret

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlInputText

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlInputTextarea

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlMessage

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlMessages

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlOutcomeTargetButton

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlOutcomeTargetLink

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlOutputFormat

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlOutputLabel

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlOutputLink

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlOutputText

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlPanelGrid

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlPanelGroup

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectBooleanCheckbox

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectManyCheckbox

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectManyListbox

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectManyMenu

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectOneListbox

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectOneMenu

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectOneRadio

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIColumn

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UICommand

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIData

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIForm

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIGraphic

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIInput

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIMessage

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIMessages

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UINamingContainer

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIOutcomeTarget

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIOutput

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIPanel

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIParameter

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UISelectBoolean

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UISelectItem

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UISelectItems

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UISelectMany

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UISelectOne

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIViewAction

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIViewParameter

The standard component type for this component.

COMPONENT_TYPE - Static variable in class javax.faces.component.UIViewRoot

The standard component type for this component.

ComponentConfig - Interface in javax.faces.view.facelets

Passed to the constructor of ComponentHandler.

ComponentHandler - Class in javax.faces.view.facelets

Public base class for markup element instances that map to UIComponent instances in the view.

ComponentHandler(ComponentConfig) - Constructor for class javax.faces.view.facelets.ComponentHandler

Leverage the TagHandlerDelegateFactory provided by the implementation to create an instance of TagHandlerDelegate designed for use with ComponentHandler.

ComponentSystemEvent - Class in javax.faces.event

ComponentSystemEvent is the base class for SystemEvents that are specific to a UIComponent instance.

ComponentSystemEvent(UIComponent) - Constructor for class javax.faces.event.ComponentSystemEvent

Pass the argument component to the superclass constructor.

ComponentSystemEventListener - Interface in javax.faces.event

Implementors of this class do not need an isListenerForSource() method because they are only installed on specific component instances, therefore the isListenerForSource() method is implicit.

COMPOSITE_COMPONENT_TYPE_KEY - Static variable in class javax.faces.component.UIComponent

The value of this constant is used as the key in the composite component BeanDescriptor for a ValueExpression that evaluates to the component-type of the composite component root UIComponent for this composite component, if one was declared by the composite component author.

COMPOSITE_FACET_NAME - Static variable in class javax.faces.component.UIComponent

The value of this constant is used as the key in the Map returned as described in UIComponent.FACETS_KEY for the PropertyDescriptor describing the composite component facet.

CompositeComponentExpressionHolder - Interface in javax.faces.el

This interface must be implemented by the Map returned by the composite component ELResolver, described in section JSF.5.6.2.2 of the specification, when evaluating #{cc.attrs} epressions.

CompositeELResolver - Class in javax.el

Maintains an ordered composite list of child ELResolvers.

CompositeELResolver() - Constructor for class javax.el.CompositeELResolver

CompositeFaceletHandler - Class in javax.faces.view.facelets

A FaceletHandler that is derived of 1 or more, inner FaceletHandlers.

CompositeFaceletHandler(FaceletHandler[]) - Constructor for class javax.faces.view.facelets.CompositeFaceletHandler

CompoundSelection<X> - Interface in javax.persistence.criteria

The CompoundSelection interface defines a compound selection item (tuple, array, or result of constructor).

concat(Expression<String>, Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression for string concatenation.

concat(Expression<String>, String) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression for string concatenation.

concat(String, Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression for string concatenation.

Concept - Interface in javax.xml.registry.infomodel

The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.

CONCEPT - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.Concept interface.

ConcurrencyManagement - Annotation Type in javax.ejb

Declares a singleton session bean's concurrency management type.

ConcurrencyManagementType - Enum in javax.ejb

Used to specify the value of the ConcurrencyManagement annotation for a singleton session bean.

ConcurrentAccessException - Exception in javax.ejb

A ConcurrentAccessException indicates that the client has attempted an invocation on a stateful session bean or singleton bean while another invocation is in progress and such concurrent access is not allowed.

ConcurrentAccessException() - Constructor for exception javax.ejb.ConcurrentAccessException

Constructs an ConcurrentAccessException with no detail message.

ConcurrentAccessException(String) - Constructor for exception javax.ejb.ConcurrentAccessException

Constructs an ConcurrentAccessException with the specified detailed message.

ConcurrentAccessException(String, Exception) - Constructor for exception javax.ejb.ConcurrentAccessException

Constructs an ConcurrentAccessException with the specified detail message and a nested exception.

ConcurrentAccessTimeoutException - Exception in javax.ejb

This exception indicates that an attempt to concurrently access a stateful session or singleton bean method resulted in a timeout.

ConcurrentAccessTimeoutException() - Constructor for exception javax.ejb.ConcurrentAccessTimeoutException

ConcurrentAccessTimeoutException(String) - Constructor for exception javax.ejb.ConcurrentAccessTimeoutException

condition(String) - Method in class javax.faces.flow.builder.NavigationCaseBuilder

Set the if of the current navigation case.

condition(ValueExpression) - Method in class javax.faces.flow.builder.NavigationCaseBuilder

Set the if of the current navigation case.

condition(ValueExpression) - Method in class javax.faces.flow.builder.SwitchCaseBuilder

Set the if in the previously created switch case.

condition(String) - Method in class javax.faces.flow.builder.SwitchCaseBuilder

Set the if in the previously created switch case.

condition() - Method in class javax.servlet.jsp.jstl.core.ConditionalTagSupport

Subclasses implement this method to compute the boolean result of the conditional action.

ConditionalTagSupport - Class in javax.servlet.jsp.jstl.core

Abstract class that facilitates implementation of conditional actions where the boolean result is exposed as a JSP scoped variable.

ConditionalTagSupport() - Constructor for class javax.servlet.jsp.jstl.core.ConditionalTagSupport

Base constructor to initialize local state.

Config - Class in javax.servlet.jsp.jstl.core

Class supporting access to configuration settings.

Config() - Constructor for class javax.servlet.jsp.jstl.core.Config

CONFIG - Static variable in class javax.servlet.jsp.PageContext

Name used to store ServletConfig in PageContext name table.

CONFIG_FILES_ATTR - Static variable in class javax.faces.webapp.FacesServlet

Context initialization parameter name for a comma delimited list of context-relative resource paths (in addition to /WEB-INF/faces-config.xml which is loaded automatically if it exists) containing JavaServer Faces configuration information.

ConfigProperty - Annotation Type in javax.resource.spi

Designates a JavaBean property as a configuration property

Configurable<C extends Configurable> - Interface in javax.ws.rs.core

Represents a client or server-side configurable context in JAX-RS.

ConfigurableNavigationHandler - Class in javax.faces.application

ConfigurableNavigationHandler extends the contract of NavigationHandler to allow runtime inspection of the NavigationCases that make up the rule-base for navigation.

ConfigurableNavigationHandler() - Constructor for class javax.faces.application.ConfigurableNavigationHandler

ConfigurableNavigationHandlerWrapper - Class in javax.faces.application

Provides a simple implementation of ConfigurableNavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ConfigurableNavigationHandler instance.

ConfigurableNavigationHandlerWrapper() - Constructor for class javax.faces.application.ConfigurableNavigationHandlerWrapper

Configuration<T extends Configuration<T>> - Interface in javax.validation

Receives configuration information, selects the appropriate Bean Validation provider and builds the appropriate ValidatorFactory.

Configuration - Interface in javax.ws.rs.core

A configuration state associated with a configurable JAX-RS context.

ConfigurationException - Exception in javax.enterprise.deploy.spi.exceptions

This exception reports errors in generating a configuration bean.

ConfigurationException() - Constructor for exception javax.enterprise.deploy.spi.exceptions.ConfigurationException

Creates new ConfigurationException without detail message.

ConfigurationException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.ConfigurationException

Constructs an ConfigurationException with the specified detail message.

ConfigurationState - Interface in javax.validation.spi

Contract between a Configuration and a ValidationProvider to create a ValidatorFactory.

configurator(ClientEndpointConfig.Configurator) - Method in class javax.websocket.ClientEndpointConfig.Builder

Sets the configurator object for the configuration this builder will build.

configurator(ServerEndpointConfig.Configurator) - Method in class javax.websocket.server.ServerEndpointConfig.Builder

Sets the custom configurator to use on the configuration object built by this builder.

configure() - Method in interface javax.validation.bootstrap.GenericBootstrap

Returns a generic Configuration implementation.

configure() - Method in interface javax.validation.bootstrap.ProviderSpecificBootstrap

Determines the provider implementation suitable for T and delegates the creation of this specific Configuration subclass to the provider.

configure(ResourceInfo, FeatureContext) - Method in interface javax.ws.rs.container.DynamicFeature

A callback method called by the JAX-RS runtime during the application deployment to register provider instances or classes in a runtime configuration scope of a particular resource or sub-resource method; i.e.

configure(FeatureContext) - Method in interface javax.ws.rs.core.Feature

A call-back method called when the feature is to be enabled in a given runtime configuration scope.

configuredProvider - Static variable in class javax.enterprise.inject.spi.CDI

confirmAssociation(Association) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Confirms this Association by the User associated with the caller.

conjunction() - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a conjunction (with zero conjuncts).

connect() - Method in class javax.mail.Service

A generic connect method that takes no parameters.

connect(String, String, String) - Method in class javax.mail.Service

Connect to the specified address.

connect(String, String) - Method in class javax.mail.Service

Connect to the current host using the specified username and password.

connect(String, int, String, String) - Method in class javax.mail.Service

Similar to connect(host, user, password) except a specific port can be specified.

Connection - Interface in javax.jms

A Connection object is a client's active connection to its JMS provider.

Connection - Interface in javax.resource.cci

A Connection represents an application-level handle that is used by a client to access the underlying physical connection.

Connection - Interface in javax.xml.registry

This class represents a connection between a JAXR client and a JAXR provider.

CONNECTION_CLOSED - Static variable in class javax.resource.spi.ConnectionEvent

Event notification that an application component has closed the connection

CONNECTION_ERROR_OCCURRED - Static variable in class javax.resource.spi.ConnectionEvent

Event notification that an error occurred on the connection.

ConnectionAdapter - Class in javax.mail.event

The adapter which receives connection events.

ConnectionAdapter() - Constructor for class javax.mail.event.ConnectionAdapter

ConnectionCallback - Interface in javax.ws.rs.container

Asynchronous request processing lifecycle callback that receives connection related asynchronous response lifecycle events.

connectionClosed(ConnectionEvent) - Method in interface javax.resource.spi.ConnectionEventListener

Notifies that an application component has closed the connection.

ConnectionConsumer - Interface in javax.jms

For application servers, Connection objects provide a special facility for creating a ConnectionConsumer (optional).

ConnectionDefinition - Annotation Type in javax.resource.spi

Defines a set of connection interfaces and classes pertaining to a particular connection type.

ConnectionDefinitions - Annotation Type in javax.resource.spi

Defines a set of connection definitions that the JavaBean, that has been annotated with this annotation, is a part of.

connectionErrorOccurred(ConnectionEvent) - Method in interface javax.resource.spi.ConnectionEventListener

Notifies a connection related error.

ConnectionEvent - Class in javax.mail.event

This class models Connection events.

ConnectionEvent(Object, int) - Constructor for class javax.mail.event.ConnectionEvent

Constructor

ConnectionEvent - Class in javax.resource.spi

The ConnectionEvent class provides information about the source of a connection related event.A ConnectionEvent instance contains the following information: Type of the connection event ManagedConnection instance that generated the connection event.

ConnectionEvent(ManagedConnection, int) - Constructor for class javax.resource.spi.ConnectionEvent

Construct a ConnectionEvent object.

ConnectionEvent(ManagedConnection, int, Exception) - Constructor for class javax.resource.spi.ConnectionEvent

Construct a ConnectionEvent object.

ConnectionEventListener - Interface in javax.resource.spi

The ConnectionEventListener interface provides an event callback mechanism to enable an application server to receive notifications from a ManagedConnection instance.

ConnectionFactory - Interface in javax.jms

A ConnectionFactory object encapsulates a set of connection configuration parameters that has been defined by an administrator.

ConnectionFactory - Interface in javax.resource.cci

ConnectionFactory provides an interface for getting connection to an EIS instance.

ConnectionFactory - Class in javax.xml.registry

This is the abstract base class for factory classes for creating a JAXR connection.

ConnectionFactory() - Constructor for class javax.xml.registry.ConnectionFactory

ConnectionFactoryDefinition - Annotation Type in javax.resource

Annotation used to define a Connector Connection Factory resource to be registered in JNDI.

ConnectionFactoryDefinitions - Annotation Type in javax.resource

Declares one or more ConnectionFactoryDefinition annotations.

ConnectionListener - Interface in javax.mail.event

This is the Listener interface for Connection events.

ConnectionManager - Interface in javax.resource.spi

ConnectionManager interface provides a hook for the resource adapter to pass a connection request to the application server.

ConnectionMetaData - Interface in javax.jms

A ConnectionMetaData object provides information describing the Connection object.

ConnectionMetaData - Interface in javax.resource.cci

The interface ConnectionMetaData provides information about an EIS instance connected through a Connection instance.

ConnectionRequestInfo - Interface in javax.resource.spi

The ConnectionRequestInfo interface enables a resource adapter to pass its own request specific data structure across the connection request flow.

ConnectionSpec - Interface in javax.resource.cci

ConnectionSpec is used by an application component to pass connection request-specific properties to the ConnectionFactory.

Connector - Annotation Type in javax.resource.spi

The Connector annotation is a component-defining annotation and it can be used by the resource adapter developer to specify that the JavaBean is a resource adapter JavaBean.

connectToServer(Object, URI) - Method in interface javax.websocket.WebSocketContainer

Connect the supplied annotated endpoint instance to its server.

connectToServer(Class<?>, URI) - Method in interface javax.websocket.WebSocketContainer

Connect the supplied annotated endpoint to its server.

connectToServer(Endpoint, ClientEndpointConfig, URI) - Method in interface javax.websocket.WebSocketContainer

Connect the supplied programmatic client endpoint instance to its server with the given configuration.

connectToServer(Class<? extends Endpoint>, ClientEndpointConfig, URI) - Method in interface javax.websocket.WebSocketContainer

Connect the supplied programmatic endpoint to its server with the given configuration.

ConstrainedTo - Annotation Type in javax.ws.rs

Indicates the run-time context in which an annotated JAX-RS provider is applicable.

Constraint - Annotation Type in javax.validation

Marks an annotation as being a Bean Validation constraint.

ConstraintDeclarationException - Exception in javax.validation

Exception raised if a constraint declaration is not legal.

ConstraintDeclarationException(String) - Constructor for exception javax.validation.ConstraintDeclarationException

ConstraintDeclarationException() - Constructor for exception javax.validation.ConstraintDeclarationException

ConstraintDeclarationException(String, Throwable) - Constructor for exception javax.validation.ConstraintDeclarationException

ConstraintDeclarationException(Throwable) - Constructor for exception javax.validation.ConstraintDeclarationException

ConstraintDefinitionException - Exception in javax.validation

Exception raised if a constraint definition is not legal.

ConstraintDefinitionException(String) - Constructor for exception javax.validation.ConstraintDefinitionException

ConstraintDefinitionException() - Constructor for exception javax.validation.ConstraintDefinitionException

ConstraintDefinitionException(String, Throwable) - Constructor for exception javax.validation.ConstraintDefinitionException

ConstraintDefinitionException(Throwable) - Constructor for exception javax.validation.ConstraintDefinitionException

ConstraintDescriptor<T extends Annotation> - Interface in javax.validation.metadata

Describes a single constraint and its composing constraints.

ConstraintMode - Enum in javax.persistence

Used to control the application of a constraint.

ConstraintTarget - Enum in javax.validation

Defines the constraint target.

ConstraintValidator<A extends Annotation,T> - Interface in javax.validation

Defines the logic to validate a given constraint A for a given object type T.

ConstraintValidatorContext - Interface in javax.validation

Provides contextual data and operation when applying a given constraint validator.

ConstraintValidatorContext.ConstraintViolationBuilder - Interface in javax.validation

ConstraintViolation builder allowing to optionally associate the violation report to a sub path.

ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext - Interface in javax.validation

Represents a node whose context is configurable (i.e.

ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext - Interface in javax.validation

Represents a node whose context is known (i.e.

ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder - Interface in javax.validation

Represents refinement choices for a node which is in an Iterator or Map.

ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext - Interface in javax.validation

Represents a node whose context is configurable (i.e.

ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext - Interface in javax.validation

Represents a node whose context is known (i.e.

ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder - Interface in javax.validation

Represents refinement choices for a node which is in an Iterator or Map.

constraintValidatorFactory(ConstraintValidatorFactory) - Method in interface javax.validation.Configuration

Defines the constraint validator factory.

ConstraintValidatorFactory - Interface in javax.validation

Instantiates a ConstraintValidator instance based off its class.

constraintValidatorFactory(ConstraintValidatorFactory) - Method in interface javax.validation.ValidatorContext

Defines the constraint validator factory implementation used by the Validator.

ConstraintViolation<T> - Interface in javax.validation

Describes a constraint violation.

ConstraintViolationException - Exception in javax.validation

Reports the result of constraint violations.

ConstraintViolationException(String, Set<? extends ConstraintViolation<?>>) - Constructor for exception javax.validation.ConstraintViolationException

Creates a constraint violation report.

ConstraintViolationException(Set<? extends ConstraintViolation<?>>) - Constructor for exception javax.validation.ConstraintViolationException

Creates a constraint violation report.

construct(Class<Y>, Selection<?>...) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a selection item corresponding to a constructor.

ConstructorDescriptor - Interface in javax.validation.metadata

Describes a validated constructor.

ConstructorResult - Annotation Type in javax.persistence

Used in conjunction with the SqlResultSetMapping annotation to map the SELECT clause of a SQL query to a constructor.

Consumes - Annotation Type in javax.ws.rs

Defines the media types that the methods of a resource class or MessageBodyReader can accept.

ContainerProvider - Class in javax.websocket

Provider class that allows the developer to get a reference to the implementation of the WebSocketContainer.

ContainerProvider() - Constructor for class javax.websocket.ContainerProvider

ContainerRequestContext - Interface in javax.ws.rs.container

Container request filter context.

ContainerRequestFilter - Interface in javax.ws.rs.container

An extension interface implemented by container request filters.

ContainerResponseContext - Interface in javax.ws.rs.container

Container response filter context.

ContainerResponseFilter - Interface in javax.ws.rs.container

An extension interface implemented by container response filters.

contains(FetchProfile.Item) - Method in class javax.mail.FetchProfile

Returns true if the fetch profile contains given special item.

contains(String) - Method in class javax.mail.FetchProfile

Returns true if the fetch profile contains given header name.

contains(Flags.Flag) - Method in class javax.mail.Flags

Check whether the specified system flag is present in this Flags object.

contains(String) - Method in class javax.mail.Flags

Check whether the specified user flag is present in this Flags object.

contains(Flags) - Method in class javax.mail.Flags

Check whether all the flags in the specified Flags object are present in this Flags object.

contains(Class, Object) - Method in interface javax.persistence.Cache

Whether the cache contains data for the given entity.

contains(Object) - Method in interface javax.persistence.EntityManager

Check if the instance is a managed entity instance belonging to the current persistence context.

containsHeader(String) - Method in interface javax.servlet.http.HttpServletResponse

Returns a boolean indicating whether the named response header has already been set.

containsHeader(String) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to call containsHeader(String name) on the wrapped response object.

containsKey(Object) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.containsKey(Object) on the wrapped Flash object.

containsKey(Object) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

containsProperty(String) - Method in interface javax.xml.rpc.handler.MessageContext

Returns true if the MessageContext contains a property with the specified name.

containsValue(Object) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.containsValue(Object) on the wrapped Flash object.

containsValue(Object) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

content - Variable in class javax.mail.internet.MimeBodyPart

Byte array that holds the bytes of the content of this Part.

content - Variable in class javax.mail.internet.MimeMessage

Byte array that holds the bytes of this Message's content.

CONTENT_DISPOSITION - Static variable in interface javax.ws.rs.core.HttpHeaders

See IETF RFC-2183.

CONTENT_ENCODING - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

CONTENT_ID - Static variable in interface javax.ws.rs.core.HttpHeaders

See IETF RFC-2392.

CONTENT_INFO - Static variable in class javax.mail.FetchProfile.Item

This item is for fetching information about the content of the message.

CONTENT_LANGUAGE - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

CONTENT_LENGTH - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

CONTENT_LOCATION - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

CONTENT_TYPE - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

ContentDisposition - Class in javax.mail.internet

This class represents a MIME ContentDisposition value.

ContentDisposition() - Constructor for class javax.mail.internet.ContentDisposition

No-arg Constructor.

ContentDisposition(String, ParameterList) - Constructor for class javax.mail.internet.ContentDisposition

Constructor.

ContentDisposition(String) - Constructor for class javax.mail.internet.ContentDisposition

Constructor that takes a ContentDisposition string.

contentLocation(URI) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the content location.

contentStream - Variable in class javax.mail.internet.MimeBodyPart

If the data for this body part was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this body part.

contentStream - Variable in class javax.mail.internet.MimeMessage

If the data for this message was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this message.

ContentType - Class in javax.mail.internet

This class represents a MIME Content-Type value.

ContentType() - Constructor for class javax.mail.internet.ContentType

No-arg Constructor.

ContentType(String, String, ParameterList) - Constructor for class javax.mail.internet.ContentType

Constructor.

ContentType(String) - Constructor for class javax.mail.internet.ContentType

Constructor that takes a Content-Type string.

contentType - Variable in class javax.mail.Multipart

This field specifies the content-type of this multipart object.

Context - Interface in javax.enterprise.context.spi

Provides an operation for obtaining contextual instances with a particular scope of any contextual type.

Context - Annotation Type in javax.ws.rs.core

This annotation is used to inject information into a class field, bean property or method parameter.

CONTEXT_SETUP_FAILED - Static variable in class javax.resource.spi.work.WorkContextErrorCodes

Indicates a failure in recreating the WorkContext instance.

CONTEXT_SETUP_UNSUPPORTED - Static variable in class javax.resource.spi.work.WorkContextErrorCodes

Indicates that the container cannot support recreating the WorkContext instance.

ContextCallback - Interface in javax.faces.component

A simple callback interace that enables taking action on a specific UIComponent (either facet or child) in the view while preserving any contextual state for that component instance in the view.

contextCreated(ELContextEvent) - Method in interface javax.el.ELContextListener

Invoked when a new ELContext has been created.

contextDestroyed(ServletContextEvent) - Method in interface javax.servlet.ServletContextListener

Receives notification that the ServletContext is about to be shut down.

ContextException - Exception in javax.enterprise.context

Indicates a problem relating to context management.

ContextException() - Constructor for exception javax.enterprise.context.ContextException

ContextException(String) - Constructor for exception javax.enterprise.context.ContextException

ContextException(Throwable) - Constructor for exception javax.enterprise.context.ContextException

ContextException(String, Throwable) - Constructor for exception javax.enterprise.context.ContextException

contextInitialized(ServletContextEvent) - Method in interface javax.servlet.ServletContextListener

Receives notification that the web application initialization process is starting.

ContextNotActiveException - Exception in javax.enterprise.context

Indicates that a context is not active.

ContextNotActiveException() - Constructor for exception javax.enterprise.context.ContextNotActiveException

ContextNotActiveException(String) - Constructor for exception javax.enterprise.context.ContextNotActiveException

ContextNotActiveException(Throwable) - Constructor for exception javax.enterprise.context.ContextNotActiveException

ContextNotActiveException(String, Throwable) - Constructor for exception javax.enterprise.context.ContextNotActiveException

ContextResolver<T> - Interface in javax.ws.rs.ext

Contract for a provider that supplies context information to resource classes and other providers.

ContextService - Interface in javax.enterprise.concurrent

The ContextService provides methods for creating dynamic proxy objects (as defined by java.lang.reflect.Proxy) with the addition of context typically associated with applications executing in a Java™ EE environment.

contextSetupComplete() - Method in interface javax.resource.spi.work.WorkContextLifecycleListener

Invoked when the WorkContext instance was successfully set as the execution context for the Work instance.

contextSetupFailed(String) - Method in interface javax.resource.spi.work.WorkContextLifecycleListener

Invoked when the WorkContext instance was set as the execution context for the Work instance it was associated with.

Contextual<T> - Interface in javax.enterprise.context.spi

Defines operations to create and destroy contextual instances of a certain type.

Conversation - Interface in javax.enterprise.context

Allows the application to manage the conversation context by marking the current conversation as transient or long-running, specifying a conversation identifier, or setting the conversation timeout.

ConversationScoped - Annotation Type in javax.enterprise.context

Specifies that a bean is conversation scoped.

CONVERSION_MESSAGE_ID - Static variable in class javax.faces.component.UIInput

The message identifier of the FacesMessage to be created if a conversion error occurs, and neither the page author nor the ConverterException provides a message.

Convert - Annotation Type in javax.persistence

Specifies the conversion of a Basic field or property.

convertClientId(FacesContext, String) - Method in class javax.faces.render.Renderer

Convert the component generated client id to a form suitable for transmission to the client.

convertClientId(FacesContext, String) - Method in class javax.faces.render.RendererWrapper

Converter - Interface in javax.faces.convert

Converter is an interface describing a Java class that can perform Object-to-String and String-to-Object conversions between model data objects and a String representation of those objects that is suitable for rendering.

Converter - Annotation Type in javax.persistence

Specifies that the annotated class is a converter and defines its scope.

CONVERTER_ID - Static variable in class javax.faces.convert.BigDecimalConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.BigIntegerConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.BooleanConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.ByteConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.CharacterConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.DateTimeConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.DoubleConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.EnumConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.FloatConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.IntegerConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.LongConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.NumberConverter

The standard converter id for this converter.

CONVERTER_ID - Static variable in class javax.faces.convert.ShortConverter

The standard converter id for this converter.

ConverterConfig - Interface in javax.faces.view.facelets

A Facelet version of the JSP ConverterTag.

ConverterELTag - Class in javax.faces.webapp

ConverterELTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentClassicTagBase.

ConverterELTag() - Constructor for class javax.faces.webapp.ConverterELTag

ConverterException - Exception in javax.faces.convert

ConverterException is an exception thrown by the getAsObject() or getAsText() method of a Converter, to indicate that the requested conversion cannot be performed.

ConverterException() - Constructor for exception javax.faces.convert.ConverterException

Construct a new exception with no detail message or root cause.

ConverterException(String) - Constructor for exception javax.faces.convert.ConverterException

Construct a new exception with the specified detail message and no root cause.

ConverterException(Throwable) - Constructor for exception javax.faces.convert.ConverterException

Construct a new exception with the specified root cause.

ConverterException(String, Throwable) - Constructor for exception javax.faces.convert.ConverterException

Construct a new exception with the specified detail message and root cause.

ConverterException(FacesMessage) - Constructor for exception javax.faces.convert.ConverterException

Construct a new exception with the specified detail message and no root cause.

ConverterException(FacesMessage, Throwable) - Constructor for exception javax.faces.convert.ConverterException

Construct a new exception with the specified detail message and root cause.

ConverterHandler - Class in javax.faces.view.facelets

Handles setting a Converter instance on a ValueHolder parent.

ConverterHandler(ConverterConfig) - Constructor for class javax.faces.view.facelets.ConverterHandler

ConverterTag - Class in javax.faces.webapp

Deprecated.
This has been partially replaced by ConverterELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ConverterTag.createConverter() method, is now an implementation detail.

ConverterTag() - Constructor for class javax.faces.webapp.ConverterTag

Deprecated.

ConvertGroup - Annotation Type in javax.validation.groups

Converts group from to group to during cascading.

ConvertGroup.List - Annotation Type in javax.validation.groups

Defines several ConvertGroup annotations on the same element.

Converts - Annotation Type in javax.persistence

Used to group Convert annotations.

convertToDatabaseColumn(X) - Method in interface javax.persistence.AttributeConverter

Converts the value stored in the entity attribute into the data representation to be stored in the database.

convertToEntityAttribute(Y) - Method in interface javax.persistence.AttributeConverter

Converts the data stored in the database column into the value to be stored in the entity attribute.

convertToType(ELContext, Object, Class<?>) - Method in class javax.el.CompositeELResolver

Converts an object to a specific type.

convertToType(Object, Class<?>) - Method in class javax.el.ELContext

Converts an object to a specific type.

convertToType(ELContext, Object, Class<?>) - Method in class javax.el.ELResolver

Converts an object to a specific type.

convertToType(ELContext, Object, Class<?>) - Method in class javax.el.TypeConverter

Converts an object to a specific type.

Cookie - Class in javax.servlet.http

Creates a cookie, a small amount of information sent by a servlet to a Web browser, saved by the browser, and later sent back to the server.

Cookie(String, String) - Constructor for class javax.servlet.http.Cookie

Constructs a cookie with the specified name and value.

cookie(Cookie) - Method in interface javax.ws.rs.client.Invocation.Builder

Add a cookie to be set.

cookie(String, String) - Method in interface javax.ws.rs.client.Invocation.Builder

Add a cookie to be set.

Cookie - Class in javax.ws.rs.core

Represents the value of a HTTP cookie, transferred in a request.

Cookie(String, String, String, String, int) - Constructor for class javax.ws.rs.core.Cookie

Create a new instance.

Cookie(String, String, String, String) - Constructor for class javax.ws.rs.core.Cookie

Create a new instance.

Cookie(String, String) - Constructor for class javax.ws.rs.core.Cookie

Create a new instance.

COOKIE - Static variable in interface javax.ws.rs.core.HttpHeaders

See IETF RFC 2109.

cookie(NewCookie...) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Add cookies to the response message.

CookieParam - Annotation Type in javax.ws.rs

Binds the value of a HTTP cookie to a resource method parameter, resource class field, or resource class bean property.

copyMessages(Message[], Folder) - Method in class javax.mail.Folder

Copy the specified Messages from this Folder into another Folder.

correlate(Root<Y>) - Method in interface javax.persistence.criteria.Subquery

Create a subquery root correlated to a root of the enclosing query.

correlate(Join<X, Y>) - Method in interface javax.persistence.criteria.Subquery

Create a subquery join object correlated to a join object of the enclosing query.

correlate(CollectionJoin<X, Y>) - Method in interface javax.persistence.criteria.Subquery

Create a subquery collection join object correlated to a collection join object of the enclosing query.

correlate(SetJoin<X, Y>) - Method in interface javax.persistence.criteria.Subquery

Create a subquery set join object correlated to a set join object of the enclosing query.

correlate(ListJoin<X, Y>) - Method in interface javax.persistence.criteria.Subquery

Create a subquery list join object correlated to a list join object of the enclosing query.

correlate(MapJoin<X, K, V>) - Method in interface javax.persistence.criteria.Subquery

Create a subquery map join object correlated to a map join object of the enclosing query.

count(Expression<?>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an aggregate expression applying the count operation.

countAttachments() - Method in class javax.xml.soap.SOAPMessage

Gets a count of the number of attachments in this message.

countDistinct(Expression<?>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an aggregate expression applying the count distinct operation.

CountStatistic - Interface in javax.management.j2ee.statistics

Specifies standard count measurements.

create(CreationalContext<T>) - Method in interface javax.enterprise.context.spi.Contextual

Create a new instance of the contextual type.

create(int) - Method in class javax.mail.Folder

Create this folder on the Store.

create() - Method in interface javax.management.j2ee.ManagementHome

Creates an MEJB session object which provides access to the J2EE Management Model

create() - Static method in class javax.websocket.ClientEndpointConfig.Builder

Creates a new builder object with no subprotocols, extensions, encoders, decoders and a null configurator.

create(Class<?>, String) - Static method in class javax.websocket.server.ServerEndpointConfig.Builder

Creates the builder with the mandatory information of the endpoint class (programmatic or annotated), the relative URI or URI-template to use, and with no subprotocols, extensions, encoders, decoders or custom configurator.

create(Name) - Method in class javax.xml.soap.SOAPElementFactory

Deprecated.
Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead

create(String) - Method in class javax.xml.soap.SOAPElementFactory

Deprecated.
Use javax.xml.soap.SOAPFactory.createElement(String localName) instead

create(String, String, String) - Method in class javax.xml.soap.SOAPElementFactory

Deprecated.
Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead

create(Object) - Static method in class javax.xml.ws.Endpoint

Creates an endpoint with the specified implementor object.

create(Object, WebServiceFeature...) - Static method in class javax.xml.ws.Endpoint

Creates an endpoint with the specified implementor object and web service features.

create(String, Object) - Static method in class javax.xml.ws.Endpoint

Creates an endpoint with the specified binding type and implementor object.

create(String, Object, WebServiceFeature...) - Static method in class javax.xml.ws.Endpoint

Creates an endpoint with the specified binding type, implementor object, and web service features.

create(URL, QName) - Static method in class javax.xml.ws.Service

Creates a Service instance.

create(URL, QName, WebServiceFeature...) - Static method in class javax.xml.ws.Service

Creates a Service instance.

create(QName) - Static method in class javax.xml.ws.Service

Creates a Service instance.

create(QName, WebServiceFeature...) - Static method in class javax.xml.ws.Service

Creates a Service instance.

createAndPublishEndpoint(String, Object) - Method in class javax.xml.ws.spi.Provider

Creates and publishes an endpoint object with the specified address and implementation object.

createAndPublishEndpoint(String, Object, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider

Creates and publishes an endpoint object with the specified address, implementation object and web service features.

createAnnotatedType(Class<T>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtain an AnnotatedType that may be used to read the annotations of the given class or interface.

createArrayBuilder() - Static method in class javax.json.Json

Creates a JSON array builder

createArrayBuilder() - Method in interface javax.json.JsonBuilderFactory

Creates a JsonArrayBuilder instance that is used to build JsonArray

createArrayBuilder() - Method in class javax.json.spi.JsonProvider

Creates a JSON array builder

createAssociation(RegistryObject, Concept) - Method in interface javax.xml.registry.LifeCycleManager

Creates an Association instance using the specified parameters.

createAttachmentPart() - Method in class javax.xml.soap.SOAPMessage

Creates a new empty AttachmentPart object.

createAttachmentPart(DataHandler) - Method in class javax.xml.soap.SOAPMessage

Creates an AttachmentPart object and populates it using the given DataHandler object.

createAttachmentPart(Object, String) - Method in class javax.xml.soap.SOAPMessage

Creates an AttachmentPart object and populates it with the specified data of the specified content type.

createBean(BeanAttributes<T>, Class<T>, InjectionTargetFactory<T>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains a Bean for the given BeanAttributes, bean class and InjectionTarget.

createBean(BeanAttributes<T>, Class<X>, ProducerFactory<X>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains a Bean for the given BeanAttributes, bean class and Producer.

createBeanAttributes(AnnotatedType<T>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains a BeanAttributes for the given AnnotatedType.

createBeanAttributes(AnnotatedMember<?>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains a BeanAttributes for the given AnnotatedType.

createBehavior(String) - Method in class javax.faces.application.Application

Instantiate and return a new Behavior instance of the class specified by a previous call to addBehavior() for the specified behavior id.

createBehavior(String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.createBehavior(String) on the wrapped Application object.

createBehaviorHandlerDelegate(BehaviorHandler) - Method in class javax.faces.view.facelets.TagHandlerDelegateFactory

Create and return a TagHandlerDelegate instance designed for use with BehaviorHandler.

createBinder(Class<T>) - Method in class javax.xml.bind.JAXBContext

Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.

createBinder() - Method in class javax.xml.bind.JAXBContext

Creates a Binder for W3C DOM.

createBrowser(Queue) - Method in interface javax.jms.JMSContext

Creates a QueueBrowser object to peek at the messages on the specified queue.

createBrowser(Queue, String) - Method in interface javax.jms.JMSContext

Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.

createBrowser(Queue) - Method in interface javax.jms.QueueSession

Creates a QueueBrowser object to peek at the messages on the specified queue.

createBrowser(Queue, String) - Method in interface javax.jms.QueueSession

Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.

createBrowser(Queue) - Method in interface javax.jms.Session

Creates a QueueBrowser object to peek at the messages on the specified queue.

createBrowser(Queue, String) - Method in interface javax.jms.Session

Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.

createBuilderFactory(Map<String, ?>) - Static method in class javax.json.Json

Creates a builder factory for creating JsonArrayBuilder and JsonObjectBuilder objects.

createBuilderFactory(Map<String, ?>) - Method in class javax.json.spi.JsonProvider

Creates a builder factory for creating JsonArrayBuilder and JsonObjectBuilder objects.

createBytesMessage() - Method in interface javax.jms.JMSContext

Creates a BytesMessage object.

createBytesMessage() - Method in interface javax.jms.Session

Creates a BytesMessage object.

createCalendarTimer(ScheduleExpression) - Method in interface javax.ejb.TimerService

Create a calendar-based timer based on the input schedule expression.

createCalendarTimer(ScheduleExpression, TimerConfig) - Method in interface javax.ejb.TimerService

Create a calendar-based timer based on the input schedule expression.

createCall(QName) - Method in interface javax.xml.rpc.Service

Creates a Call instance.

createCall(QName, QName) - Method in interface javax.xml.rpc.Service

Creates a Call instance.

createCall(QName, String) - Method in interface javax.xml.rpc.Service

Creates a Call instance.

createCall() - Method in interface javax.xml.rpc.Service

Creates a Call object not associated with specific operation or target service endpoint.

createClassification(ClassificationScheme, String, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.

createClassification(ClassificationScheme, InternationalString, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.

createClassification(Concept) - Method in interface javax.xml.registry.LifeCycleManager

Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.

createClassificationScheme(String, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a ClassificationScheme given the specified String parameters.

createClassificationScheme(InternationalString, InternationalString) - Method in interface javax.xml.registry.LifeCycleManager

Creates a ClassificationScheme given the specified InternationalString parameters.

createClassificationScheme(Concept) - Method in interface javax.xml.registry.LifeCycleManager

Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.

createClientBehaviorContext(FacesContext, UIComponent, String, String, Collection<ClientBehaviorContext.Parameter>) - Static method in class javax.faces.component.behavior.ClientBehaviorContext

Creates a ClientBehaviorContext instance.

createComponent(String) - Method in class javax.faces.application.Application

Instantiate and return a new UIComponent instance of the class specified by a previous call to addComponent() for the specified component type.

createComponent(ValueBinding, FacesContext, String) - Method in class javax.faces.application.Application

Deprecated.
This has been replaced by Application.createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).

createComponent(ValueExpression, FacesContext, String) - Method in class javax.faces.application.Application

Call the getValue() method on the specified ValueExpression.

createComponent(ValueExpression, FacesContext, String, String) - Method in class javax.faces.application.Application

Like Application.createComponent(ValueExpression, FacesContext, String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in Application.createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method.

createComponent(FacesContext, String, String) - Method in class javax.faces.application.Application

Like Application.createComponent(String) except the Renderer for the component to be returned must be inspected for the annotations mentioned in Application.createComponent(ValueExpression, FacesContext, String) as specified in the documentation for that method.

createComponent(FacesContext, Resource) - Method in class javax.faces.application.Application

Instantiate and return a new UIComponent instance from the argument Resource.

createComponent(String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.createComponent(String) on the wrapped Application object.

createComponent(ValueBinding, FacesContext, String) - Method in class javax.faces.application.ApplicationWrapper

Deprecated.
See superclass for alternative.

createComponent(ValueExpression, FacesContext, String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String) on the wrapped Application object.

createComponent(ValueExpression, FacesContext, String, String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, String, String) on the wrapped Application object.

createComponent(FacesContext, String, String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, String, String) on the wrapped Application object.

createComponent(FacesContext, Resource) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.createComponent(javax.faces.context.FacesContext, Resource) on the wrapped Application object.

createComponent(FaceletContext) - Method in class javax.faces.view.facelets.ComponentHandler

Subclasses that wish to take over the task of instantiating the UIComponent instance corresponding to this tag handler my override this method to do so.

createComponent(FacesContext, String, String, Map<String, Object>) - Method in class javax.faces.view.ViewDeclarationLanguage

Create a component given a ViewDeclarationLanguage specific tag library URI and tag name.

createComponent(FacesContext, String, String, Map<String, Object>) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

createComponent(FacesContext, String) - Method in class javax.faces.webapp.UIComponentClassicTagBase

Create and return a new child component of the type returned by calling getComponentType().

createComponent(FacesContext, String) - Method in class javax.faces.webapp.UIComponentELTag

Create and return a new child component of the type returned by calling getComponentType().

createComponent(FacesContext, String) - Method in class javax.faces.webapp.UIComponentTag

Deprecated.

Implement createComponent using Faces 1.1 EL API.

createComponentHandlerDelegate(ComponentHandler) - Method in class javax.faces.view.facelets.TagHandlerDelegateFactory

Create and return a TagHandlerDelegate instance designed for use with ComponentHandler.

createConcept(RegistryObject, String, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a Concept instance using the specified parameters, where the name is a String.

createConcept(RegistryObject, InternationalString, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a Concept instance using the specified parameters, where the name is an InternationalString.

createConfiguration(DeployableObject) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Retrieve the object that provides server-specific deployment configuration information for the Java EE deployable component.

createConnection() - Method in interface javax.jms.ConnectionFactory

Creates a connection with the default user identity.

createConnection(String, String) - Method in interface javax.jms.ConnectionFactory

Creates a connection with the specified user identity.

createConnection() - Method in class javax.xml.registry.ConnectionFactory

Create a named connection.

createConnection() - Method in class javax.xml.soap.SOAPConnectionFactory

Create a new SOAPConnection.

createConnectionConsumer(Destination, String, ServerSessionPool, int) - Method in interface javax.jms.Connection

Creates a connection consumer for this connection (optional operation) on the specific destination.

createConnectionConsumer(Queue, String, ServerSessionPool, int) - Method in interface javax.jms.QueueConnection

Creates a connection consumer for this connection (optional operation).

createConnectionConsumer(Topic, String, ServerSessionPool, int) - Method in interface javax.jms.TopicConnection

Creates a connection consumer for this connection (optional operation).

createConnectionFactory(ConnectionManager) - Method in interface javax.resource.spi.ManagedConnectionFactory

Creates a Connection Factory instance.

createConnectionFactory() - Method in interface javax.resource.spi.ManagedConnectionFactory

Creates a Connection Factory instance.

createConsumer(Destination) - Method in interface javax.jms.JMSContext

Creates a JMSConsumer for the specified destination.

createConsumer(Destination, String) - Method in interface javax.jms.JMSContext

Creates a JMSConsumer for the specified destination, using a message selector.

createConsumer(Destination, String, boolean) - Method in interface javax.jms.JMSContext

Creates a JMSConsumer for the specified destination, specifying a message selector and the noLocal parameter.

createConsumer(Destination) - Method in interface javax.jms.Session

Creates a MessageConsumer for the specified destination.

createConsumer(Destination, String) - Method in interface javax.jms.Session

Creates a MessageConsumer for the specified destination, using a message selector.

createConsumer(Destination, String, boolean) - Method in interface javax.jms.Session

Creates a MessageConsumer for the specified destination, specifying a message selector and the noLocal parameter.

createContainerEntityManagerFactory(PersistenceUnitInfo, Map) - Method in interface javax.persistence.spi.PersistenceProvider

Called by the container when an EntityManagerFactory is to be created.

createContext() - Method in interface javax.jms.ConnectionFactory

Creates a JMSContext with the default user identity and an unspecified sessionMode.

createContext(String, String) - Method in interface javax.jms.ConnectionFactory

Creates a JMSContext with the specified user identity and an unspecified sessionMode.

createContext(String, String, int) - Method in interface javax.jms.ConnectionFactory

Creates a JMSContext with the specified user identity and the specified session mode.

createContext(int) - Method in interface javax.jms.ConnectionFactory

Creates a JMSContext with the default user identity and the specified session mode.

createContext(int) - Method in interface javax.jms.JMSContext

Creates a new JMSContext with the specified session mode using the same connection as this JMSContext and creating a new session.

createContextualProxy(T, Class<T>) - Method in interface javax.enterprise.concurrent.ContextService

Creates a new contextual object proxy for the input object instance.

createContextualProxy(Object, Class<?>...) - Method in interface javax.enterprise.concurrent.ContextService

Creates a new contextual object proxy for the input object instance.

createContextualProxy(T, Map<String, String>, Class<T>) - Method in interface javax.enterprise.concurrent.ContextService

Creates a new contextual object proxy for the input object instance.

createContextualProxy(Object, Map<String, String>, Class<?>...) - Method in interface javax.enterprise.concurrent.ContextService

Creates a new contextual object proxy for the input object instance.

createConverter(String) - Method in class javax.faces.application.Application

Instantiate and return a new Converter instance of the class specified by a previous call to addConverter() for the specified converter id.

createConverter(Class<?>) - Method in class javax.faces.application.Application

Instantiate and return a new Converter instance of the class that has registered itself as capable of performing conversions for objects of the specified type.

createConverter(String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.createConverter(String) on the wrapped Application object.

createConverter(Class<?>) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.createConverter(Class) on the wrapped Application object.

createConverter() - Method in class javax.faces.webapp.ConverterELTag

Create and return a new Converter to be registered on our surrounding UIComponent.

createConverter() - Method in class javax.faces.webapp.ConverterTag

Deprecated.

Create and return a new Converter to be registered on our surrounding UIComponent.

createConverterHandlerDelegate(ConverterHandler) - Method in class javax.faces.view.facelets.TagHandlerDelegateFactory

Create and return a TagHandlerDelegate instance designed for use with ConverterHandler.

createCreationalContext(Contextual<T>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtain an instance of a CreationalContext for the given contextual type, or for a non-contextual object.

createCriteriaDelete(Class<T>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a CriteriaDelete query object to perform a bulk delete operation.

createCriteriaUpdate(Class<T>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a CriteriaUpdate query object to perform a bulk update operation.

CREATED - Static variable in class javax.mail.event.FolderEvent

The folder was created.

created(URI) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder for a created resource, set the location header using the supplied value.

createDetail() - Method in class javax.xml.soap.SOAPFactory

Creates a new Detail object which serves as a container for DetailEntry objects.

createDispatch(QName, Class<T>, Service.Mode) - Method in class javax.xml.ws.Service

Creates a Dispatch instance for use with objects of the client's choosing.

createDispatch(QName, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service

Creates a Dispatch instance for use with objects of the client's choosing.

createDispatch(EndpointReference, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service

Creates a Dispatch instance for use with objects of the client's choosing.

createDispatch(QName, JAXBContext, Service.Mode) - Method in class javax.xml.ws.Service

Creates a Dispatch instance for use with JAXB generated objects.

createDispatch(QName, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service

Creates a Dispatch instance for use with JAXB generated objects.

createDispatch(EndpointReference, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service

Creates a Dispatch instance for use with JAXB generated objects.

createDispatch(QName, Class<T>, Service.Mode) - Method in class javax.xml.ws.spi.ServiceDelegate

Creates a Dispatch instance for use with objects of the user's choosing.

createDispatch(QName, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

Creates a Dispatch instance for use with objects of the user's choosing.

createDispatch(EndpointReference, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

Creates a Dispatch instance for use with objects of the user's choosing.

createDispatch(QName, JAXBContext, Service.Mode) - Method in class javax.xml.ws.spi.ServiceDelegate

Creates a Dispatch instance for use with JAXB generated objects.

createDispatch(QName, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

Creates a Dispatch instance for use with JAXB generated objects.

createDispatch(EndpointReference, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

Creates a Dispatch instance for use with JAXB generated objects.

createDurableConnectionConsumer(Topic, String, String, ServerSessionPool, int) - Method in interface javax.jms.Connection

Creates a connection consumer for this connection (optional operation) on the specific topic using an unshared durable subscription with the specified name.

createDurableConnectionConsumer(Topic, String, String, ServerSessionPool, int) - Method in interface javax.jms.TopicConnection

Create a durable connection consumer for this connection (optional operation).

createDurableConsumer(Topic, String) - Method in interface javax.jms.JMSContext

Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.

createDurableConsumer(Topic, String, String, boolean) - Method in interface javax.jms.JMSContext

Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.

createDurableConsumer(Topic, String) - Method in interface javax.jms.Session

Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.

createDurableConsumer(Topic, String, String, boolean) - Method in interface javax.jms.Session

Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.

createDurableSubscriber(Topic, String) - Method in interface javax.jms.Session

Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.

createDurableSubscriber(Topic, String, String, boolean) - Method in interface javax.jms.Session

Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.

createDurableSubscriber(Topic, String) - Method in interface javax.jms.TopicSession

Creates an unshared durable subscription on the specified topic (if one does not already exist) and creates a consumer on that durable subscription.

createDurableSubscriber(Topic, String, String, boolean) - Method in interface javax.jms.TopicSession

Creates an unshared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.

createEJBContainer() - Static method in class javax.ejb.embeddable.EJBContainer

Create and initialize an embeddable EJB container.

createEJBContainer(Map<?, ?>) - Static method in class javax.ejb.embeddable.EJBContainer

Create and initialize an embeddable EJB container with a set of configuration properties.

createEJBContainer(Map<?, ?>) - Method in interface javax.ejb.spi.EJBContainerProvider

Called by the embeddable container bootstrap process to find a suitable embeddable container implementation.

createElement(Element) - Method in class javax.xml.soap.SOAPFactory

Creates a SOAPElement object from an existing DOM Element.

createElement(Name) - Method in class javax.xml.soap.SOAPFactory

Creates a SOAPElement object initialized with the given Name object.

createElement(QName) - Method in class javax.xml.soap.SOAPFactory

Creates a SOAPElement object initialized with the given QName object.

createElement(String) - Method in class javax.xml.soap.SOAPFactory

Creates a SOAPElement object initialized with the given local name.

createElement(String, String, String) - Method in class javax.xml.soap.SOAPFactory

Creates a new SOAPElement object with the given local name, prefix and uri.

createEmailAddress(String) - Method in interface javax.xml.registry.LifeCycleManager

Creates an EmailAddress instance using an address as the parameter.

createEmailAddress(String, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates an EmailAddress instance using both an address and a type as parameters.

createEndpoint(XAResource) - Method in interface javax.resource.spi.endpoint.MessageEndpointFactory

This is used to create a message endpoint.

createEndpoint(XAResource, long) - Method in interface javax.resource.spi.endpoint.MessageEndpointFactory

This is used to create a message endpoint.

createEndpoint(Application, Class<T>) - Method in class javax.ws.rs.ext.RuntimeDelegate

Create a configured instance of the supplied endpoint type.

createEndpoint(String, Object) - Method in class javax.xml.ws.spi.Provider

Creates an endpoint object with the provided binding and implementation object.

createEndpoint(String, Object, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider

Creates an endpoint object with the provided binding, implementation object and web service features.

createEndpoint(String, Class<?>, Invoker, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider

Creates an endpoint object with the provided binding, implementation class, invoker and web service features.

createEntityGraph(Class<T>) - Method in interface javax.persistence.EntityManager

Return a mutable EntityGraph that can be used to dynamically create an EntityGraph.

createEntityGraph(String) - Method in interface javax.persistence.EntityManager

Return a mutable copy of the named EntityGraph.

createEntityManager() - Method in interface javax.persistence.EntityManagerFactory

Create a new application-managed EntityManager.

createEntityManager(Map) - Method in interface javax.persistence.EntityManagerFactory

Create a new application-managed EntityManager with the specified Map of properties.

createEntityManager(SynchronizationType) - Method in interface javax.persistence.EntityManagerFactory

Create a new JTA application-managed EntityManager with the specified synchronization type.

createEntityManager(SynchronizationType, Map) - Method in interface javax.persistence.EntityManagerFactory

Create a new JTA application-managed EntityManager with the specified synchronization type and map of properties.

createEntityManagerFactory(String) - Static method in class javax.persistence.Persistence

Create and return an EntityManagerFactory for the named persistence unit.

createEntityManagerFactory(String, Map) - Static method in class javax.persistence.Persistence

Create and return an EntityManagerFactory for the named persistence unit using the given properties.

createEntityManagerFactory(String, Map) - Method in interface javax.persistence.spi.PersistenceProvider

Called by Persistence class when an EntityManagerFactory is to be created.

CreateException - Exception in javax.ejb

The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise bean's home or local home interface.

CreateException() - Constructor for exception javax.ejb.CreateException

Constructs a CreateException with no detail message.

CreateException(String) - Constructor for exception javax.ejb.CreateException

Constructs a CreateException with the specified detail message.

createExternalIdentifier(ClassificationScheme, String, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.

createExternalIdentifier(ClassificationScheme, InternationalString, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.

createExternalLink(String, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates an ExternalLink instance using the specified parameters, where the description is a String.

createExternalLink(String, InternationalString) - Method in interface javax.xml.registry.LifeCycleManager

Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.

createExtrinsicObject(DataHandler) - Method in interface javax.xml.registry.LifeCycleManager

Creates an ExtrinsicObject instance using the specified parameters.

createFault(String, QName) - Method in class javax.xml.soap.SOAPFactory

Creates a new SOAPFault object initialized with the given reasonText and faultCode

createFault() - Method in class javax.xml.soap.SOAPFactory

Creates a new default SOAPFault object

createFederatedConnection(Collection) - Method in class javax.xml.registry.ConnectionFactory

Create a FederatedConnection.

createFilter(Class<T>) - Method in interface javax.servlet.ServletContext

Instantiates the given Filter class.

createFlowHandler(FacesContext) - Method in class javax.faces.flow.FlowHandlerFactory

Create the singleton instance of FlowHandler.

createFlowHandler(FacesContext) - Method in class javax.faces.flow.FlowHandlerFactoryWrapper

createGenerator(Writer) - Static method in class javax.json.Json

Creates a JSON generator for writing JSON to a character stream.

createGenerator(OutputStream) - Static method in class javax.json.Json

Creates a JSON generator for writing JSON to a byte stream.

createGenerator(Writer) - Method in class javax.json.spi.JsonProvider

Creates a JSON generator for writing JSON text to a character stream.

createGenerator(OutputStream) - Method in class javax.json.spi.JsonProvider

Creates a JSON generator for writing JSON text to a byte stream.

createGenerator(Writer) - Method in interface javax.json.stream.JsonGeneratorFactory

Creates a JSON generator to write JSON text to a character stream.

createGenerator(OutputStream) - Method in interface javax.json.stream.JsonGeneratorFactory

Creates a JSON generator to write JSON text to a byte stream.

createGenerator(OutputStream, Charset) - Method in interface javax.json.stream.JsonGeneratorFactory

Creates a JSON generator to write JSON text to a byte stream.

createGeneratorFactory(Map<String, ?>) - Static method in class javax.json.Json

Creates a generator factory for creating JsonGenerator objects.

createGeneratorFactory(Map<String, ?>) - Method in class javax.json.spi.JsonProvider

Creates a generator factory for creating JsonGenerator instances.

createGenericConfiguration(BootstrapState) - Method in interface javax.validation.spi.ValidationProvider

Returns a Configuration instance.

createHeaderDelegate(Class<T>) - Method in class javax.ws.rs.ext.RuntimeDelegate

Obtain an instance of a RuntimeDelegate.HeaderDelegate for the supplied class.

createIndexedRecord(String) - Method in interface javax.resource.cci.RecordFactory

Creates a IndexedRecord.

createInjectionPoint(AnnotatedField<?>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains a container provided implementation of InjectionPoint for the given AnnotatedField.

createInjectionPoint(AnnotatedParameter<?>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains a container provided implementation of InjectionPoint for the given AnnotatedParameter.

createInjectionTarget(AnnotatedType<T>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains an InjectionTarget for the given AnnotatedType.

createInjectionTarget(Bean<T>) - Method in interface javax.enterprise.inject.spi.InjectionTargetFactory

Create a new injection target for a bean.

createInteraction() - Method in interface javax.resource.cci.Connection

Creates an Interaction associated with this Connection.

createInternationalString() - Method in interface javax.xml.registry.LifeCycleManager

Creates an empty InternationalString instance.

createInternationalString(String) - Method in interface javax.xml.registry.LifeCycleManager

Creates an InternationalString instance using a String parameter and the default Locale.

createInternationalString(Locale, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates an InternationalString instance using the specified Locale and String parameters.

createInternetHeaders(InputStream) - Method in class javax.mail.internet.MimeMessage

Create and return an InternetHeaders object that loads the headers from the given InputStream.

createInternetHeaders(InputStream) - Method in class javax.mail.internet.MimeMultipart

Create and return an InternetHeaders object that loads the headers from the given InputStream.

createIntervalTimer(long, long, TimerConfig) - Method in interface javax.ejb.TimerService

Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.

createIntervalTimer(Date, long, TimerConfig) - Method in interface javax.ejb.TimerService

Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.

createJAXBIntrospector() - Method in class javax.xml.bind.JAXBContext

Creates a JAXBIntrospector object that can be used to introspect JAXB objects.

createKey(String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a Key instance from an ID.

createLinkBuilder() - Method in class javax.ws.rs.ext.RuntimeDelegate

Create a new instance of a Link.Builder.

createListener(Class<T>) - Method in interface javax.servlet.AsyncContext

Instantiates the given AsyncListener class.

createListener(Class<T>) - Method in interface javax.servlet.ServletContext

Instantiates the given EventListener class.

createLocalizedString(Locale, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a LocalizedString instance using the specified Locale and String parameters.

createLocalizedString(Locale, String, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a LocalizedString instance using the specified Locale, String, and character set parameters.

createManagedConnection(Subject, ConnectionRequestInfo) - Method in interface javax.resource.spi.ManagedConnectionFactory

Creates a new physical connection to the underlying EIS resource manager.

createMapMessage() - Method in interface javax.jms.JMSContext

Creates a MapMessage object.

createMapMessage() - Method in interface javax.jms.Session

Creates a MapMessage object.

createMappedRecord(String) - Method in interface javax.resource.cci.RecordFactory

Creates a MappedRecord.

createMarshaller() - Method in class javax.xml.bind.JAXBContext

Create a Marshaller object that can be used to convert a java content tree into XML data.

createMessage() - Method in interface javax.jms.JMSContext

Creates a Message object.

createMessage() - Method in interface javax.jms.Session

Creates a Message object.

createMessage() - Method in class javax.xml.soap.MessageFactory

Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.

createMessage(MimeHeaders, InputStream) - Method in class javax.xml.soap.MessageFactory

Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.

createMetadataView(FacesContext) - Method in class javax.faces.view.ViewMetadata

Creates a new UIViewRoot containing only view parameter metadata.

createMetaRuleset(Class) - Method in class javax.faces.view.facelets.DelegatingMetaTagHandler

The default implementation simply calls through to TagHandlerDelegate.createMetaRuleset(java.lang.Class) and returns the result.

createMetaRuleset(Class) - Method in class javax.faces.view.facelets.MetaTagHandler

Extend this method in order to add your own rules.

createMetaRuleset(Class) - Method in class javax.faces.view.facelets.TagHandlerDelegate

Return a MetaRuleset particular to this kind of tag handler.

createMethodBinding(String, Class<?>[]) - Method in class javax.faces.application.Application

Deprecated.
This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>, java.lang.Class<?>[]).

createMethodBinding(String, Class<?>[]) - Method in class javax.faces.application.ApplicationWrapper

Deprecated.
See superclass for alternative.

createMethodExpression(ELContext, String, Class<?>, Class<?>[]) - Method in class javax.el.ExpressionFactory

Parses an expression into a MethodExpression for later evaluation.

createMimeBodyPart(InternetHeaders, byte[]) - Method in class javax.mail.internet.MimeMultipart

Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.

createMimeBodyPart(InputStream) - Method in class javax.mail.internet.MimeMultipart

Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.

createMimeMessage(Session) - Method in class javax.mail.internet.MimeMessage

Create and return a MimeMessage object.

createName(String, String, String) - Method in interface javax.xml.soap.SOAPEnvelope

Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

createName(String) - Method in interface javax.xml.soap.SOAPEnvelope

Creates a new Name object initialized with the given local name.

createName(String, String, String) - Method in class javax.xml.soap.SOAPFactory

Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

createName(String) - Method in class javax.xml.soap.SOAPFactory

Creates a new Name object initialized with the given local name.

createNamedQuery(String) - Method in interface javax.persistence.EntityManager

Create an instance of Query for executing a named query (in the Java Persistence query language or in native SQL).

createNamedQuery(String, Class<T>) - Method in interface javax.persistence.EntityManager

Create an instance of TypedQuery for executing a Java Persistence query language named query.

createNamedStoredProcedureQuery(String) - Method in interface javax.persistence.EntityManager

Create an instance of StoredProcedureQuery for executing a stored procedure in the database.

createNativeQuery(String) - Method in interface javax.persistence.EntityManager

Create an instance of Query for executing a native SQL statement, e.g., for update or delete.

createNativeQuery(String, Class) - Method in interface javax.persistence.EntityManager

Create an instance of Query for executing a native SQL query.

createNativeQuery(String, String) - Method in interface javax.persistence.EntityManager

Create an instance of Query for executing a native SQL query.

createObject(String) - Method in interface javax.xml.registry.LifeCycleManager

Creates instances of information model interfaces (factory method).

createObjectBuilder() - Static method in class javax.json.Json

Creates a JSON object builder

createObjectBuilder() - Method in interface javax.json.JsonBuilderFactory

Creates a JsonObjectBuilder instance that is used to build JsonObject.

createObjectBuilder() - Method in class javax.json.spi.JsonProvider

Creates a JSON object builder

createObjectMessage() - Method in interface javax.jms.JMSContext

Creates an ObjectMessage object.

createObjectMessage(Serializable) - Method in interface javax.jms.JMSContext

Creates an initialized ObjectMessage object.

createObjectMessage() - Method in interface javax.jms.Session

Creates an ObjectMessage object.

createObjectMessage(Serializable) - Method in interface javax.jms.Session

Creates an initialized ObjectMessage object.

createOrganization(String) - Method in interface javax.xml.registry.LifeCycleManager

Creates an Organization instance using the specified name, where the name is a String.

createOrganization(InternationalString) - Method in interface javax.xml.registry.LifeCycleManager

Creates an Organization instance using the specified name, where the name is an InternationalString.

createOutput(String, String) - Method in class javax.xml.bind.SchemaOutputResolver

Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.

createParser(Reader) - Static method in class javax.json.Json

Creates a JSON parser from a character stream.

createParser(InputStream) - Static method in class javax.json.Json

Creates a JSON parser from a byte stream.

createParser(Reader) - Method in class javax.json.spi.JsonProvider

Creates a JSON parser from a character stream.

createParser(InputStream) - Method in class javax.json.spi.JsonProvider

Creates a JSON parser from the specified byte stream.

createParser(Reader) - Method in interface javax.json.stream.JsonParserFactory

Creates a JSON parser from a character stream.

createParser(InputStream) - Method in interface javax.json.stream.JsonParserFactory

Creates a JSON parser from the specified byte stream.

createParser(InputStream, Charset) - Method in interface javax.json.stream.JsonParserFactory

Creates a JSON parser from the specified byte stream.

createParser(JsonObject) - Method in interface javax.json.stream.JsonParserFactory

Creates a JSON parser from the specified JSON object.

createParser(JsonArray) - Method in interface javax.json.stream.JsonParserFactory

Creates a JSON parser from the specified JSON array.

createParserFactory(Map<String, ?>) - Static method in class javax.json.Json

Creates a parser factory for creating JsonParser objects.

createParserFactory(Map<String, ?>) - Method in class javax.json.spi.JsonProvider

Creates a parser factory for creating JsonParser instances.

createPersonName(String, String, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a PersonName instance using the specified first, middle, and last names.

createPersonName(String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a PersonName instance using the specified full name.

createPostalAddress(String, String, String, String, String, String, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a PostalAddress instance using the specified parameters.

createProducer(Bean<T>) - Method in interface javax.enterprise.inject.spi.ProducerFactory

Create a new producer for a bean.

createProducer() - Method in interface javax.jms.JMSContext

Creates a new JMSProducer object which can be used to configure and send messages

createProducer(Destination) - Method in interface javax.jms.Session

Creates a MessageProducer to send messages to the specified destination.

createPublisher(Topic) - Method in interface javax.jms.TopicSession

Creates a publisher for the specified topic.

createQName(String, String) - Method in interface javax.xml.soap.SOAPElement

Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.

createQuery() - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a CriteriaQuery object.

createQuery(Class<T>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a CriteriaQuery object with the specified result type.

createQuery(String) - Method in interface javax.persistence.EntityManager

Create an instance of Query for executing a Java Persistence query language statement.

createQuery(CriteriaQuery<T>) - Method in interface javax.persistence.EntityManager

Create an instance of TypedQuery for executing a criteria query.

createQuery(CriteriaUpdate) - Method in interface javax.persistence.EntityManager

Create an instance of Query for executing a criteria update query.

createQuery(CriteriaDelete) - Method in interface javax.persistence.EntityManager

Create an instance of Query for executing a criteria delete query.

createQuery(String, Class<T>) - Method in interface javax.persistence.EntityManager

Create an instance of TypedQuery for executing a Java Persistence query language statement.

createQuery(int, String) - Method in interface javax.xml.registry.DeclarativeQueryManager

Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.

createQueue(String) - Method in interface javax.jms.JMSContext

Creates a Queue object which encapsulates a specified provider-specific queue name.

createQueue(String) - Method in interface javax.jms.QueueSession

Creates a queue identity given a Queue name.

createQueue(String) - Method in interface javax.jms.Session

Creates a Queue object which encapsulates a specified provider-specific queue name.

createQueueConnection() - Method in interface javax.jms.QueueConnectionFactory

Creates a queue connection with the default user identity.

createQueueConnection(String, String) - Method in interface javax.jms.QueueConnectionFactory

Creates a queue connection with the specified user identity.

createQueueSession(boolean, int) - Method in interface javax.jms.QueueConnection

Creates a QueueSession object.

createQueueSession(boolean, int) - Method in interface javax.jms.XAQueueConnection

Creates a QueueSession object.

createReader(Reader) - Static method in class javax.json.Json

Creates a JSON reader from a character stream.

createReader(InputStream) - Static method in class javax.json.Json

Creates a JSON reader from a byte stream.

createReader(Reader) - Method in interface javax.json.JsonReaderFactory

Creates a JSON reader from a character stream.

createReader(InputStream) - Method in interface javax.json.JsonReaderFactory

Creates a JSON reader from a byte stream.

createReader(InputStream, Charset) - Method in interface javax.json.JsonReaderFactory

Creates a JSON reader from a byte stream.

createReader(Reader) - Method in class javax.json.spi.JsonProvider

Creates a JSON reader from a character stream.

createReader(InputStream) - Method in class javax.json.spi.JsonProvider

Creates a JSON reader from a byte stream.

createReaderFactory(Map<String, ?>) - Static method in class javax.json.Json

Creates a reader factory for creating JsonReader objects.

createReaderFactory(Map<String, ?>) - Method in class javax.json.spi.JsonProvider

Creates a reader factory for creating JsonReader objects.

createReceiver(Queue) - Method in interface javax.jms.QueueSession

Creates a QueueReceiver object to receive messages from the specified queue.

createReceiver(Queue, String) - Method in interface javax.jms.QueueSession

Creates a QueueReceiver object to receive messages from the specified queue using a message selector.

createRegistryPackage(String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a RegistryPackage instance using the specified name, where the name is a String.

createRegistryPackage(InternationalString) - Method in interface javax.xml.registry.LifeCycleManager

Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.

createResource(String) - Method in class javax.faces.application.ResourceHandler

Create an instance of ViewResource given the argument resourceName.

createResource(String, String) - Method in class javax.faces.application.ResourceHandler

Create an instance of Resource with a resourceName given by the value of the argument resourceName that is a member of the library named by the argument libraryName.

createResource(String, String, String) - Method in class javax.faces.application.ResourceHandler

Create an instance of Resource with a resourceName given by the value of the argument resourceName that is a member of the library named by the argument libraryName that claims to have the content-type given by the argument content-type.

createResource(String) - Method in class javax.faces.application.ResourceHandlerWrapper

The default behavior of this method is to call ResourceHandler.createResource(String) on the wrapped ResourceHandler object.

createResource(String, String) - Method in class javax.faces.application.ResourceHandlerWrapper

The default behavior of this method is to call ResourceHandler.createResource(String, String) on the wrapped ResourceHandler object.

createResource(String, String, String) - Method in class javax.faces.application.ResourceHandlerWrapper

The default behavior of this method is to call ResourceHandler.createResource(String, String, String) on the wrapped ResourceHandler object.

createResourceFromId(String) - Method in class javax.faces.application.ResourceHandler

Create an instance of Resource given the argument resourceId.

createResourceFromId(String) - Method in class javax.faces.application.ResourceHandlerWrapper

The default behavior of this method is to call ResourceHandler.createResourceFromId(String) on the wrapped ResourceHandler object.

createResponseBuilder() - Method in class javax.ws.rs.ext.RuntimeDelegate

Create a new instance of a Response.ResponseBuilder.

createResponseStream(OutputStream) - Method in class javax.faces.render.RenderKit

Use the provided OutputStream to create a new ResponseStream instance.

createResponseStream(OutputStream) - Method in class javax.faces.render.RenderKitWrapper

The default behavior of this method is to call RenderKit.createResponseStream(java.io.OutputStream) on the wrapped RenderKit object.

createResponseWriter(Writer, String, String) - Method in class javax.faces.render.RenderKit

Use the provided Writer to create a new ResponseWriter instance for the specified (optional) content type, and character encoding.

createResponseWriter(Writer, String, String) - Method in class javax.faces.render.RenderKitWrapper

The default behavior of this method is to call RenderKit.createResponseWriter(java.io.Writer, String, String) on the wrapped RenderKit object.

createSender(Queue) - Method in interface javax.jms.QueueSession

Creates a QueueSender object to send messages to the specified queue.

createService(String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a Service instance using the specified name, where the name is a String.

createService(InternationalString) - Method in interface javax.xml.registry.LifeCycleManager

Creates a Service instance using the specified name, where the name is an InternationalString.

createService(URL, QName) - Method in class javax.xml.rpc.ServiceFactory

Create a Service instance.

createService(QName) - Method in class javax.xml.rpc.ServiceFactory

Create a Service instance.

createServiceBinding() - Method in interface javax.xml.registry.LifeCycleManager

Creates an empty ServiceBinding instance.

createServiceDelegate(URL, QName, Class<? extends Service>) - Method in class javax.xml.ws.spi.Provider

Creates a service delegate object.

createServiceDelegate(URL, QName, Class<? extends Service>, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider

Creates a service delegate object.

createServlet(Class<T>) - Method in interface javax.servlet.ServletContext

Instantiates the given Servlet class.

createSession(boolean, int) - Method in interface javax.jms.Connection

Creates a Session object, specifying transacted and acknowledgeMode.

createSession(int) - Method in interface javax.jms.Connection

Creates a Session object, specifying sessionMode.

createSession() - Method in interface javax.jms.Connection

Creates a Session object, specifying no arguments.

createSession(boolean, int) - Method in interface javax.jms.XAConnection

Creates an Session object.

createSharedConnectionConsumer(Topic, String, String, ServerSessionPool, int) - Method in interface javax.jms.Connection

Creates a connection consumer for this connection (optional operation) on the specific topic using a shared non-durable subscription with the specified name.

createSharedConsumer(Topic, String) - Method in interface javax.jms.JMSContext

Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription.

createSharedConsumer(Topic, String, String) - Method in interface javax.jms.JMSContext

Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.

createSharedConsumer(Topic, String) - Method in interface javax.jms.Session

Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) and creates a consumer on that subscription.

createSharedConsumer(Topic, String, String) - Method in interface javax.jms.Session

Creates a shared non-durable subscription with the specified name on the specified topic (if one does not already exist) specifying a message selector, and creates a consumer on that subscription.

createSharedDurableConnectionConsumer(Topic, String, String, ServerSessionPool, int) - Method in interface javax.jms.Connection

Creates a connection consumer for this connection (optional operation) on the specific topic using a shared durable subscription with the specified name.

createSharedDurableConsumer(Topic, String) - Method in interface javax.jms.JMSContext

Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.

createSharedDurableConsumer(Topic, String, String) - Method in interface javax.jms.JMSContext

Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.

createSharedDurableConsumer(Topic, String) - Method in interface javax.jms.Session

Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector and the noLocal parameter, and creates a consumer on that durable subscription.

createSharedDurableConsumer(Topic, String, String) - Method in interface javax.jms.Session

Creates a shared durable subscription on the specified topic (if one does not already exist), specifying a message selector, and creates a consumer on that durable subscription.

createSingleActionTimer(long, TimerConfig) - Method in interface javax.ejb.TimerService

Create a single-action timer that expires after a specified duration.

createSingleActionTimer(Date, TimerConfig) - Method in interface javax.ejb.TimerService

Create a single-action timer that expires at a given point in time.

createSlot(String, String, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a Slot instance using the specified parameters, where the value is a String.

createSlot(String, Collection, String) - Method in interface javax.xml.registry.LifeCycleManager

Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.

createSpecializedConfiguration(BootstrapState) - Method in interface javax.validation.spi.ValidationProvider

Returns a Configuration instance implementing T, the Configuration sub-interface.

createSpecificationLink() - Method in interface javax.xml.registry.LifeCycleManager

Creates an empty SpecificationLink instance.

createStoredProcedureQuery(String) - Method in interface javax.persistence.EntityManager

Create an instance of StoredProcedureQuery for executing a stored procedure in the database.

createStoredProcedureQuery(String, Class...) - Method in interface javax.persistence.EntityManager

Create an instance of StoredProcedureQuery for executing a stored procedure in the database.

createStoredProcedureQuery(String, String...) - Method in interface javax.persistence.EntityManager

Create an instance of StoredProcedureQuery for executing a stored procedure in the database.

createStreamMessage() - Method in interface javax.jms.JMSContext

Creates a StreamMessage object.

createStreamMessage() - Method in interface javax.jms.Session

Creates a StreamMessage object.

createSubscriber(Topic) - Method in interface javax.jms.TopicSession

Creates a nondurable subscriber to the specified topic.

createSubscriber(Topic, String, boolean) - Method in interface javax.jms.TopicSession

Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.

createTelephoneNumber() - Method in interface javax.xml.registry.LifeCycleManager

Creates an empty TelephoneNumber instance.

createTemporaryQueue() - Method in interface javax.jms.JMSContext

Creates a TemporaryQueue object.

createTemporaryQueue() - Method in interface javax.jms.QueueSession

Creates a TemporaryQueue object.

createTemporaryQueue() - Method in interface javax.jms.Session

Creates a TemporaryQueue object.

createTemporaryTopic() - Method in interface javax.jms.JMSContext

Creates a TemporaryTopic object.

createTemporaryTopic() - Method in interface javax.jms.Session

Creates a TemporaryTopic object.

createTemporaryTopic() - Method in interface javax.jms.TopicSession

Creates a TemporaryTopic object.

createTextMessage() - Method in interface javax.jms.JMSContext

Creates a TextMessage object.

createTextMessage(String) - Method in interface javax.jms.JMSContext

Creates an initialized TextMessage object.

createTextMessage() - Method in interface javax.jms.Session

Creates a TextMessage object.

createTextMessage(String) - Method in interface javax.jms.Session

Creates an initialized TextMessage object.

createTimer(long, Serializable) - Method in interface javax.ejb.TimerService

Create a single-action timer that expires after a specified duration.

createTimer(long, long, Serializable) - Method in interface javax.ejb.TimerService

Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.

createTimer(Date, Serializable) - Method in interface javax.ejb.TimerService

Create a single-action timer that expires at a given point in time.

createTimer(Date, long, Serializable) - Method in interface javax.ejb.TimerService

Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.

createTimer() - Method in interface javax.resource.spi.BootstrapContext

Creates a new java.util.Timer instance.

createTopic(String) - Method in interface javax.jms.JMSContext

Creates a Topic object which encapsulates a specified provider-specific topic name.

createTopic(String) - Method in interface javax.jms.Session

Creates a Topic object which encapsulates a specified provider-specific topic name.

createTopic(String) - Method in interface javax.jms.TopicSession

Creates a topic identity given a Topic name.

createTopicConnection() - Method in interface javax.jms.TopicConnectionFactory

Creates a topic connection with the default user identity.

createTopicConnection(String, String) - Method in interface javax.jms.TopicConnectionFactory

Creates a topic connection with the specified user identity.

createTopicSession(boolean, int) - Method in interface javax.jms.TopicConnection

Creates a TopicSession object.

createTopicSession(boolean, int) - Method in interface javax.jms.XATopicConnection

Creates a TopicSession object.

createTupleQuery() - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a CriteriaQuery object that returns a tuple of objects as its result.

createTypeMapping() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry

Creates a new empty TypeMapping object.

createUniqueId(FacesContext, String) - Method in class javax.faces.component.UIData

createUniqueId(FacesContext, String) - Method in class javax.faces.component.UIForm

Generate an identifier for a component.

createUniqueId(FacesContext, String) - Method in class javax.faces.component.UINamingContainer

createUniqueId() - Method in class javax.faces.component.UIViewRoot

Generate an identifier for a component.

createUniqueId(FacesContext, String) - Method in class javax.faces.component.UIViewRoot

Generate an identifier for a component.

createUniqueId(FacesContext, String) - Method in interface javax.faces.component.UniqueIdVendor

Generate an identifier for a component.

createUnmarshalException(SAXException) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Creates an UnmarshalException from a SAXException.

createUnmarshaller(ValidationEventHandler) - Method in interface javax.xml.bind.annotation.DomHandler

When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.

createUnmarshaller(ValidationEventHandler) - Method in class javax.xml.bind.annotation.W3CDomHandler

createUnmarshaller() - Method in class javax.xml.bind.JAXBContext

Create an Unmarshaller object that can be used to convert XML data into a java content tree.

createUriBuilder() - Method in class javax.ws.rs.ext.RuntimeDelegate

Create a new instance of a UriBuilder.

createUser() - Method in interface javax.xml.registry.LifeCycleManager

Creates an empty User instance.

createValidator(String) - Method in class javax.faces.application.Application

Instantiate and return a new Validator instance of the class specified by a previous call to addValidator() for the specified validator id.

createValidator(String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.createValidator(String) on the wrapped Application object.

createValidator() - Method in class javax.faces.webapp.ValidatorELTag

Create and return a new Validator to be registered on our surrounding UIComponent.

createValidator() - Method in class javax.faces.webapp.ValidatorTag

Deprecated.

Create and return a new Validator to be registered on our surrounding UIComponent.

createValidator() - Method in class javax.xml.bind.JAXBContext

Deprecated.
since JAXB2.0

createValidatorHandlerDelegate(ValidatorHandler) - Method in class javax.faces.view.facelets.TagHandlerDelegateFactory

Create and return a TagHandlerDelegate instance designed for use with ValidatorHandler.

createValueBinding(String) - Method in class javax.faces.application.Application

Deprecated.
This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class<?>).

createValueBinding(String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.createValueBinding(String) on the wrapped Application object.

createValueExpression(ELContext, String, Class<?>) - Method in class javax.el.ExpressionFactory

Parses an expression into a ValueExpression for later evaluation.

createValueExpression(Object, Class<?>) - Method in class javax.el.ExpressionFactory

Creates a ValueExpression that wraps an object instance.

createVariantListBuilder() - Method in class javax.ws.rs.ext.RuntimeDelegate

Create a new instance of a Variant.VariantListBuilder.

createVerbatimComponent() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Use the Application instance to create a new component with the following characteristics.

createVerbatimComponentFromBodyContent() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Create a transient UIOutput component from the body content, of this tag instance or return null if there is no body content, the body content is whitespace, or the body content is a comment.

createView(FacesContext, String) - Method in class javax.faces.application.ViewHandler

Create and return a new UIViewRoot instance initialized with information from the argument FacesContext and viewId.

createView(FacesContext, String) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.createView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

createView(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguage

Create a UIViewRoot from the VDL contained in the artifact referenced by the argument viewId.

createView(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

createViewResource(FacesContext, String) - Method in class javax.faces.application.ResourceHandler

Create an instance of Resource given the argument resourceName, which may contain "/" characters.

createViewResource(FacesContext, String) - Method in class javax.faces.application.ResourceHandlerWrapper

The default behavior of this method is to call ResourceHandler.createViewResource(javax.faces.context.FacesContext, java.lang.String) on the wrapped ResourceHandler object.

createVisitContext(FacesContext, Collection<String>, Set<VisitHint>) - Static method in class javax.faces.component.visit.VisitContext

Returns a VisitContext instance that is initialized with the specified ids and hintsfor use with UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback).

createVisitContext(FacesContext) - Static method in class javax.faces.component.visit.VisitContext

Creates a VisitContext instance for use with UIComponent.visitTree().

createW3CEndpointReference(String, QName, QName, List<Element>, String, List<Element>) - Method in class javax.xml.ws.spi.Provider

Factory method to create a W3CEndpointReference.

createW3CEndpointReference(String, QName, QName, QName, List<Element>, String, List<Element>, List<Element>, Map<QName, String>) - Method in class javax.xml.ws.spi.Provider

Factory method to create a W3CEndpointReference.

createWriter(Writer) - Static method in class javax.json.Json

Creates a JSON writer to write a JSON object or array structure to the specified character stream.

createWriter(OutputStream) - Static method in class javax.json.Json

Creates a JSON writer to write a JSON object or array structure to the specified byte stream.

createWriter(Writer) - Method in interface javax.json.JsonWriterFactory

Creates a JSON writer to write a JSON object or array structure to the specified character stream.

createWriter(OutputStream) - Method in interface javax.json.JsonWriterFactory

Creates a JSON writer to write a JSON object or array structure to the specified byte stream.

createWriter(OutputStream, Charset) - Method in interface javax.json.JsonWriterFactory

Creates a JSON writer to write a JSON object or array structure to the specified byte stream.

createWriter(Writer) - Method in class javax.json.spi.JsonProvider

Creates a JSON writer to write a JSON object or array structure to the specified character stream.

createWriter(OutputStream) - Method in class javax.json.spi.JsonProvider

Creates a JSON writer to write a JSON object or array structure to the specified byte stream.

createWriterFactory(Map<String, ?>) - Static method in class javax.json.Json

Creates a writer factory for creating JsonWriter objects.

createWriterFactory(Map<String, ?>) - Method in class javax.json.spi.JsonProvider

Creates a writer factory for creating JsonWriter objects.

createXAConnection() - Method in interface javax.jms.XAConnectionFactory

Creates an XAConnection with the default user identity.

createXAConnection(String, String) - Method in interface javax.jms.XAConnectionFactory

Creates an XAConnection with the specified user identity.

createXAContext() - Method in interface javax.jms.XAConnectionFactory

Creates a XAJMSContext with the default user identity

createXAContext(String, String) - Method in interface javax.jms.XAConnectionFactory

Creates a JMSContext with the specified user identity

createXAQueueConnection() - Method in interface javax.jms.XAQueueConnectionFactory

Creates an XA queue connection with the default user identity.

createXAQueueConnection(String, String) - Method in interface javax.jms.XAQueueConnectionFactory

Creates an XA queue connection with the specified user identity.

createXAQueueSession() - Method in interface javax.jms.XAQueueConnection

Creates an XAQueueSession object.

createXASession() - Method in interface javax.jms.XAConnection

Creates an XASession object.

createXATopicConnection() - Method in interface javax.jms.XATopicConnectionFactory

Creates an XA topic connection with the default user identity.

createXATopicConnection(String, String) - Method in interface javax.jms.XATopicConnectionFactory

Creates an XA topic connection with the specified user identity.

createXATopicSession() - Method in interface javax.jms.XATopicConnection

Creates an XATopicSession object.

CreationalContext<T> - Interface in javax.enterprise.context.spi

Provides operations that are used by the Contextual implementation during instance creation and destruction.

CreationException - Exception in javax.enterprise.inject

Indicates that a checked exception was thrown during creation of a bean.

CreationException() - Constructor for exception javax.enterprise.inject.CreationException

CreationException(String) - Constructor for exception javax.enterprise.inject.CreationException

CreationException(Throwable) - Constructor for exception javax.enterprise.inject.CreationException

CreationException(String, Throwable) - Constructor for exception javax.enterprise.inject.CreationException

CriteriaBuilder - Interface in javax.persistence.criteria

Used to construct criteria queries, compound selections, expressions, predicates, orderings.

CriteriaBuilder.Case<R> - Interface in javax.persistence.criteria

Interface used to build general case expressions.

CriteriaBuilder.Coalesce<T> - Interface in javax.persistence.criteria

Interface used to build coalesce expressions.

CriteriaBuilder.In<T> - Interface in javax.persistence.criteria

Interface used to build in predicates.

CriteriaBuilder.SimpleCase<C,R> - Interface in javax.persistence.criteria

Interface used to build simple case expressions.

CriteriaBuilder.Trimspec - Enum in javax.persistence.criteria

Used to specify how strings are trimmed.

CriteriaDelete<T> - Interface in javax.persistence.criteria

The CriteriaDelete interface defines functionality for performing bulk delete operations using the Criteria API

CriteriaQuery<T> - Interface in javax.persistence.criteria

The CriteriaQuery interface defines functionality that is specific to top-level queries.

CriteriaUpdate<T> - Interface in javax.persistence.criteria

The CriteriaUpdate interface defines functionality for performing bulk update operations using the Criteria API.

CrossParameterDescriptor - Interface in javax.validation.metadata

Describes an element holding cross-parameter constraints of a method or constructor

CURRENCY_ID - Static variable in class javax.faces.convert.NumberConverter

The message identifier of the FacesMessage to be created if the conversion to Number fails.

current() - Static method in class javax.enterprise.inject.spi.CDI

Get the CDI instance that provides access to the current container.

CURRENT_COMPONENT - Static variable in class javax.faces.component.UIComponent

Deprecated.

CURRENT_COMPOSITE_COMPONENT - Static variable in class javax.faces.component.UIComponent

Deprecated.

currentDate() - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to return current date.

currentTime() - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to return current time.

currentTimestamp() - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to return current timestamp.

CustomScoped - Annotation Type in javax.faces.bean

When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>VALUE<managed-bean-scope> element was declared for the corresponding managed bean, where VALUE is the value of the CustomScoped.value() attribute, which must be an EL expression that evaluates to a Map.

D

DataBindingException - Exception in javax.xml.bind

Exception that represents a failure in a JAXB operation.

DataBindingException(String, Throwable) - Constructor for exception javax.xml.bind.DataBindingException

DataBindingException(Throwable) - Constructor for exception javax.xml.bind.DataBindingException

datalen - Variable in class javax.mail.util.SharedFileInputStream

The amount of data in this subset of the file.

DataModel<E> - Class in javax.faces.model

DataModel is an abstraction around arbitrary data binding technologies that can be used to adapt a variety of data sources for use by JavaServer Faces components that support per-row processing for their child components (such as UIData.

DataModel() - Constructor for class javax.faces.model.DataModel

DataModelEvent - Class in javax.faces.model

DataModelEvent represents an event of interest to registered listeners that occurred on the specified DataModel.

DataModelEvent(DataModel, int, Object) - Constructor for class javax.faces.model.DataModelEvent

Construct an event object that is associated with the specified row index and associated data.

DataModelListener - Interface in javax.faces.model

DataModelListener represents an event listener that wishes to be notified of DataModelEvents occurring on a particular DataModel instance.

DataSourceDefinition - Annotation Type in javax.annotation.sql

Annotation used to define a container DataSource and be registered with JNDI.

DataSourceDefinitions - Annotation Type in javax.annotation.sql

Declares one or more DataSourceDefinition annotations.

DatatypeConverter - Class in javax.xml.bind

The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype.

DatatypeConverterInterface - Interface in javax.xml.bind

The DatatypeConverterInterface is for JAXB provider use only.

date - Variable in class javax.mail.search.DateTerm

The date.

DATE - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

DATE_ID - Static variable in class javax.faces.convert.DateTimeConverter

The message identifier of the FacesMessage to be created if the conversion to Date fails.

DateTerm - Class in javax.mail.search

This class implements comparisons for Dates

DateTerm(int, Date) - Constructor for class javax.mail.search.DateTerm

Constructor.

DATETIME_ID - Static variable in class javax.faces.convert.DateTimeConverter

The message identifier of the FacesMessage to be created if the conversion to DateTime fails.

DateTimeConverter - Class in javax.faces.convert

Converter implementation for java.util.Date values.

DateTimeConverter() - Constructor for class javax.faces.convert.DateTimeConverter

DATETIMECONVERTER_DEFAULT_TIMEZONE_IS_SYSTEM_TIMEZONE_PARAM_NAME - Static variable in interface javax.faces.convert.Converter

If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, Application.createConverter() must guarantee that the default for the timezone of all javax.faces.convert.DateTimeConverter instances must be equal to TimeZone.getDefault() instead of "GMT".

dayOfMonth(String) - Method in class javax.ejb.ScheduleExpression

Set the day of the month attribute.

dayOfMonth(int) - Method in class javax.ejb.ScheduleExpression

Set the day of the month attribute.

dayOfWeek(String) - Method in class javax.ejb.ScheduleExpression

Set the day of the week attribute.

dayOfWeek(int) - Method in class javax.ejb.ScheduleExpression

Set the day of the week attribute.

DConfigBean - Interface in javax.enterprise.deploy.spi

The DConfigBean is a deployment configuration bean (DConfigBean) that is associated with one or more deployment descriptor beans, (DDBean).

DConfigBeanRoot - Interface in javax.enterprise.deploy.spi

A Java EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents.

DConfigBeanVersionType - Class in javax.enterprise.deploy.shared

Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.

DConfigBeanVersionType(int) - Constructor for class javax.enterprise.deploy.shared.DConfigBeanVersionType

Construct a new enumeration value with the given integer value.

DConfigBeanVersionUnsupportedException - Exception in javax.enterprise.deploy.spi.exceptions

This exception is to report that there is no support for the DConfigBean version requested.

DConfigBeanVersionUnsupportedException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException

Creates an new DConfigBeanVersionUnsupportedException object.

DDBean - Interface in javax.enterprise.deploy.model

An interface for beans that represent a fragment of a standard deployment descriptor.

DDBeanCreateException - Exception in javax.enterprise.deploy.model.exceptions

This exception reports errors in generating a DDBean.

DDBeanCreateException() - Constructor for exception javax.enterprise.deploy.model.exceptions.DDBeanCreateException

Creates new DDBeanCreateException without detail message.

DDBeanCreateException(String) - Constructor for exception javax.enterprise.deploy.model.exceptions.DDBeanCreateException

Constructs an DDBeanCreateException with the specified detail message.

DDBeanRoot - Interface in javax.enterprise.deploy.model

An interface that represents the root of a standard deployment descriptor.

debug - Variable in class javax.mail.Service

Debug flag for this service.

decide(StepExecution[]) - Method in interface javax.batch.api.Decider

The decide method sets a new exit status for a job.

Decider - Interface in javax.batch.api

A Decider receives control as part of a decision element in a job.

DECIMAL_ID - Static variable in class javax.faces.convert.BigDecimalConverter

The message identifier of the FacesMessage to be created if the conversion to BigDecimal fails.

DecimalMax - Annotation Type in javax.validation.constraints

The annotated element must be a number whose value must be lower or equal to the specified maximum.

DecimalMax.List - Annotation Type in javax.validation.constraints

Defines several DecimalMax annotations on the same element.

DecimalMin - Annotation Type in javax.validation.constraints

The annotated element must be a number whose value must be higher or equal to the specified minimum.

DecimalMin.List - Annotation Type in javax.validation.constraints

Defines several DecimalMin annotations on the same element.

DeclarativeQueryManager - Interface in javax.xml.registry

This interface provides the ability to execute declarative queries (e.g.

declaredOn(ElementType...) - Method in interface javax.validation.metadata.ElementDescriptor.ConstraintFinder

Restricts to the constraints hosted on the listed types for a given element.

declaredType - Variable in class javax.xml.bind.JAXBElement

Java datatype binding for xml element declaration's type.

DeclareRoles - Annotation Type in javax.annotation.security

Used by application to declare roles.

declareRoles(String...) - Method in interface javax.servlet.ServletContext

Declares role names that are tested using isUserInRole.

decode(FacesContext, UIComponent) - Method in interface javax.faces.component.behavior.ClientBehavior

Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.

decode(FacesContext, UIComponent) - Method in class javax.faces.component.behavior.ClientBehaviorBase

Default implementation of of ClientBehavior.decode(javax.faces.context.FacesContext, javax.faces.component.UIComponent).

decode(FacesContext) - Method in class javax.faces.component.UIComponent

Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.

decode(FacesContext) - Method in class javax.faces.component.UIComponentBase

decode(FacesContext) - Method in class javax.faces.component.UIInput

decode(FacesContext) - Method in class javax.faces.component.UIViewAction

Override behavior from the superclass to queue an ActionEvent that may result in the invocation of the action or any actionListeners that may be associated with this instance.

decode(FacesContext) - Method in class javax.faces.component.UIViewParameter

Override behavior from superclass to pull a value from the incoming request parameter map under the name given by UIViewParameter.getName() and store it with a call to UIInput.setSubmittedValue(java.lang.Object).

decode(FacesContext) - Method in class javax.faces.lifecycle.ClientWindow

The implementation is responsible for examining the incoming request and extracting the value that must be returned from the ClientWindow.getId() method.

decode(FacesContext) - Method in class javax.faces.lifecycle.ClientWindowWrapper

decode(FacesContext, UIComponent, ClientBehavior) - Method in class javax.faces.render.ClientBehaviorRenderer

Decode any new state of this ClientBehavior from the request contained in the specified FacesContext.

decode(FacesContext, UIComponent) - Method in class javax.faces.render.Renderer

Decode any new state of the specified UIComponent from the request contained in the specified FacesContext, and store that state on the UIComponent.

decode(FacesContext, UIComponent) - Method in class javax.faces.render.RendererWrapper

decode(InputStream, String) - Static method in class javax.mail.internet.MimeUtility

Decode the given input stream.

decode(ByteBuffer) - Method in interface javax.websocket.Decoder.Binary

Decode the given bytes into an object of type T.

decode(InputStream) - Method in interface javax.websocket.Decoder.BinaryStream

Decode the given bytes read from the input stream into an object of type T.

decode(String) - Method in interface javax.websocket.Decoder.Text

Decode the given String into an object of type T.

decode(Reader) - Method in interface javax.websocket.Decoder.TextStream

Reads the websocket message from the implementation provided Reader and decodes it into an instance of the supplied object type.

DecodeException - Exception in javax.websocket

A general exception that occurs when trying to decode a custom object from a text or binary message.

DecodeException(ByteBuffer, String, Throwable) - Constructor for exception javax.websocket.DecodeException

Constructor with the binary data that could not be decoded, and the reason why it failed to be, and the cause.

DecodeException(String, String, Throwable) - Constructor for exception javax.websocket.DecodeException

Constructor with the text data that could not be decoded, and the reason why it failed to be, and the cause.

DecodeException(ByteBuffer, String) - Constructor for exception javax.websocket.DecodeException

Constructs a DecodedException with the given ByteBuffer that cannot be decoded, and reason why.

DecodeException(String, String) - Constructor for exception javax.websocket.DecodeException

Constructs a DecodedException with the given encoded string that cannot be decoded, and reason why.

Decoder - Interface in javax.websocket

The Decoder interface holds member interfaces that define how a developer can provide the web socket container a way web socket messages into developer defined custom objects.

Decoder.Binary<T> - Interface in javax.websocket

This interface defines how a custom object (of type T) is decoded from a web socket message in the form of a byte buffer.

Decoder.BinaryStream<T> - Interface in javax.websocket

This interface defines how a custom object is decoded from a web socket message in the form of a binary stream.

Decoder.Text<T> - Interface in javax.websocket

This interface defines how a custom object is decoded from a web socket message in the form of a string.

Decoder.TextStream<T> - Interface in javax.websocket

This interface defines how a custom object of type T is decoded from a web socket message in the form of a character stream.

decoders(List<Class<? extends Decoder>>) - Method in class javax.websocket.ClientEndpointConfig.Builder

Assign the list of decoder implementation classes the client will use.

decoders(List<Class<? extends Decoder>>) - Method in class javax.websocket.server.ServerEndpointConfig.Builder

Sets the decoder implementation classes to use in the configuration.

decodeText(String) - Static method in class javax.mail.internet.MimeUtility

Decode "unstructured" headers, that is, headers that are defined as '*text' as per RFC 822.

decodeWord(String) - Static method in class javax.mail.internet.MimeUtility

The string is parsed using the rules in RFC 2047 and RFC 2231 for parsing an "encoded-word".

decorate(Tag) - Method in interface javax.faces.view.facelets.TagDecorator

If handled, return a new Tag instance, otherwise return null

Decorated - Annotation Type in javax.enterprise.inject

A decorator may inject metadata about the bean it is decorating

Decorator - Annotation Type in javax.decorator

Specifies that a class is a decorator.

Decorator<T> - Interface in javax.enterprise.inject.spi

Represents an enabled decorator.

Default - Annotation Type in javax.enterprise.inject

The default qualifier type.

Default - Interface in javax.validation.groups

Default Bean Validation group.

DEFAULT_BUFFER - Static variable in class javax.servlet.jsp.JspWriter

Constant indicating that the Writer is buffered and is using the implementation default buffer size.

DEFAULT_CHARSET_NAME - Static variable in interface javax.xml.registry.infomodel.LocalizedString

The default name returned by getCharsetName if no other name has explicitly been set.

DEFAULT_DELIVERY_DELAY - Static variable in interface javax.jms.Message

The message producer's default delivery delay is zero.

DEFAULT_DELIVERY_MODE - Static variable in interface javax.jms.Message

The message producer's default delivery mode is PERSISTENT.

DEFAULT_FACELETS_SUFFIX - Static variable in class javax.faces.application.ViewHandler

The value to use for the default extension for Facelet based XHTML pages if the webapp is using url extension mapping.

DEFAULT_FACTORY_SECURITY_PROPERTY - Static variable in class javax.security.auth.message.config.AuthConfigFactory

The name of the Security property used to define the default AuthConfigFactory implementation class.

DEFAULT_LIFECYCLE - Static variable in class javax.faces.lifecycle.LifecycleFactory

The lifecycle identifier for the default Lifecycle instance for this JavaServer Faces implementation.

DEFAULT_MAX_AGE - Static variable in class javax.ws.rs.core.NewCookie

Specifies that the cookie expires with the current application/browser session.

DEFAULT_PRIORITY - Static variable in interface javax.jms.Message

The message producer's default priority is 4.

DEFAULT_SOAP_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants

The default protocol: SOAP 1.1 for backwards compatibility.

DEFAULT_SUFFIX - Static variable in class javax.faces.application.ViewHandler

The value to use for the default extension if the webapp is using url extension mapping.

DEFAULT_SUFFIX_PARAM_NAME - Static variable in class javax.faces.application.ViewHandler

Allow the web application to define a list of alternate suffixes for pages containing JSF content.

DEFAULT_TIME_TO_LIVE - Static variable in interface javax.jms.Message

The message producer's default time to live is unlimited; the message never expires.

DEFAULT_VERSION - Static variable in class javax.ws.rs.core.Cookie

Cookies using the default version correspond to RFC 2109.

defaultOutcome(String) - Method in class javax.faces.flow.builder.MethodCallBuilder

If the method is a void method, or the method returns null, this can be used to specify what value should be passed to runtime when the method returns.

defaultOutcome(ValueExpression) - Method in class javax.faces.flow.builder.MethodCallBuilder

If the method is a void method, or the method returns null, this can be used to specify what value should be passed to runtime when the method returns.

defaultOutcome(String) - Method in class javax.faces.flow.builder.SwitchBuilder

Set the default outcome of the current switch.

defaultOutcome(ValueExpression) - Method in class javax.faces.flow.builder.SwitchBuilder

Set the default outcome of the current switch.

DefaultValidationEventHandler - Class in javax.xml.bind.helpers

JAXB 1.0 only default validation event handler.

DefaultValidationEventHandler() - Constructor for class javax.xml.bind.helpers.DefaultValidationEventHandler

DefaultValue - Annotation Type in javax.ws.rs

Defines the default value of request meta-data that is bound using one of the following annotations: PathParam, QueryParam, MatrixParam, CookieParam, FormParam, or HeaderParam.

deferredExpression - Variable in class javax.servlet.jsp.jstl.core.LoopTagSupport

The deferred expression if any

defineBean(String, Object) - Method in class javax.el.ELManager

Define a bean in the local bean repository

defineBean(String, Object) - Method in class javax.el.ELProcessor

Define a bean in a local bean repository, hiding other beans of the same name.

defineFunction(String, String, String, String) - Method in class javax.el.ELProcessor

Define an EL function in the local function mapper.

defineFunction(String, String, Method) - Method in class javax.el.ELProcessor

Define an EL function in the local function mapper.

DefinitionException - Exception in javax.enterprise.inject.spi

Thrown when a definition error occurs.

DefinitionException(String, Throwable) - Constructor for exception javax.enterprise.inject.spi.DefinitionException

DefinitionException(String) - Constructor for exception javax.enterprise.inject.spi.DefinitionException

DefinitionException(Throwable) - Constructor for exception javax.enterprise.inject.spi.DefinitionException

Delegate - Annotation Type in javax.decorator

Identifies the delegate injection point of a decorator.

delegateFactory - Variable in class javax.faces.view.facelets.DelegatingMetaTagHandler

DelegatingMetaTagHandler - Class in javax.faces.view.facelets

Enable the JSF implementation to provide the appropriate behavior for the kind of MetaTagHandler subclass for each kind of element in the view, while providing a base-class from which those wanting to make a Java language custom tag handler can inherit.

DelegatingMetaTagHandler(TagConfig) - Constructor for class javax.faces.view.facelets.DelegatingMetaTagHandler

delete(String) - Method in class javax.faces.context.PartialResponseWriter

Write a delete operation.

delete() - Method in interface javax.jms.TemporaryQueue

Deletes this temporary queue.

delete() - Method in interface javax.jms.TemporaryTopic

Deletes this temporary topic.

delete(boolean) - Method in class javax.mail.Folder

Delete this Folder.

delete() - Method in interface javax.security.jacc.PolicyConfiguration

Causes all policy statements to be deleted from this PolicyConfiguration and sets its internal state such that calling any method, other than delete, getContextID, or inService on the PolicyConfiguration will be rejected and cause an UnsupportedOperationException to be thrown.

delete() - Method in interface javax.servlet.http.Part

Deletes the underlying storage for a file item, including deleting any associated temporary disk file.

delete() - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP DELETE method for the current request asynchronously.

delete(Class<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP DELETE method for the current request asynchronously.

delete(GenericType<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP DELETE method for the current request asynchronously.

delete(InvocationCallback<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP DELETE method for the current request asynchronously.

delete() - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP DELETE method for the current request synchronously.

delete(Class<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP DELETE method for the current request synchronously.

delete(GenericType<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP DELETE method for the current request synchronously.

DELETE - Annotation Type in javax.ws.rs

Indicates that the annotated method responds to HTTP DELETE requests.

DELETE - Static variable in annotation type javax.ws.rs.HttpMethod

HTTP DELETE method.

deleteAssociations(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Deletes the Associations corresponding to the specified Keys.

deleteClassificationSchemes(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Deletes the ClassificationSchemes corresponding to the specified Keys.

deleteConcepts(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Deletes the Concepts corresponding to the specified Keys.

DELETED - Static variable in class javax.mail.event.FolderEvent

The folder was deleted.

DELETED - Static variable in class javax.mail.Flags.Flag

This message is marked deleted.

DeleteException - Exception in javax.xml.registry

A RegistryException that occurs during a delete action.

DeleteException() - Constructor for exception javax.xml.registry.DeleteException

Constructs a JAXRException object with no reason or embedded Throwable.

DeleteException(String) - Constructor for exception javax.xml.registry.DeleteException

Constructs a JAXRException object with the given String as the reason for the exception being thrown.

DeleteException(String, Throwable) - Constructor for exception javax.xml.registry.DeleteException

Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

DeleteException(Throwable) - Constructor for exception javax.xml.registry.DeleteException

Constructs a JAXRException object initialized with the given Throwable object.

deleteObjects(Collection) - Method in interface javax.xml.registry.LifeCycleManager

Deletes one or more previously submitted objects from the registry using the object keys.

deleteObjects(Collection, String) - Method in interface javax.xml.registry.LifeCycleManager

Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.

deleteOrganizations(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Deletes the organizations corresponding to the specified Keys.

deletesAreDetected(int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether or not a visible row delete can be detected by calling ResultSet.rowDeleted.

deleteServiceBindings(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Deletes the ServiceBindings corresponding to the specified Keys.

deleteServices(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Deletes the services corresponding to the specified Keys.

delims - Variable in class javax.servlet.jsp.jstl.core.IteratedExpression

delistResource(XAResource, int) - Method in interface javax.transaction.Transaction

Disassociate the resource specified from the transaction associated with the target Transaction object.

DeliveryMode - Interface in javax.jms

The delivery modes supported by the JMS API are PERSISTENT and NON_PERSISTENT.

DenyAll - Annotation Type in javax.annotation.security

Specifies that no security roles are allowed to invoke the specified method(s) - i.e that the methods are to be excluded from execution in the J2EE container.

Dependent - Annotation Type in javax.enterprise.context

Specifies that a bean belongs to the dependent pseudo-scope.

DependsOn - Annotation Type in javax.ejb

Used to express an initialization dependency between singleton components.

DeployableObject - Interface in javax.enterprise.deploy.model

The DeployableObject interface is an abstract representation of a Java EE deployable module (JAR, WAR, RAR, EAR).

DeploymentConfiguration - Interface in javax.enterprise.deploy.spi

An interface that defines a container for all the server-specific configuration information for a single top-level Java EE module.

DeploymentException - Exception in javax.enterprise.inject.spi

Thrown when a deployment problem occurs.

DeploymentException(String, Throwable) - Constructor for exception javax.enterprise.inject.spi.DeploymentException

DeploymentException(String) - Constructor for exception javax.enterprise.inject.spi.DeploymentException

DeploymentException(Throwable) - Constructor for exception javax.enterprise.inject.spi.DeploymentException

DeploymentException - Exception in javax.websocket

Checked exception indicating some kind of failure either to publish an endpoint on its server, or a failure to connect a client to its server.

DeploymentException(String) - Constructor for exception javax.websocket.DeploymentException

Creates a deployment exception with the given reason for the deployment failure.

DeploymentException(String, Throwable) - Constructor for exception javax.websocket.DeploymentException

Creates a deployment exception with the given reason for the deployment failure and wrapped cause of the failure.

DeploymentFactory - Interface in javax.enterprise.deploy.spi.factories

The DeploymentFactory interface is a deployment driver for a Java EE plaform product.

DeploymentFactoryManager - Class in javax.enterprise.deploy.shared.factories

The DeploymentFactoryManager class is a central registry for Java EE DeploymentFactory objects.

DeploymentManager - Interface in javax.enterprise.deploy.spi

The DeploymentManager object provides the core set of functions a Java EE platform must provide for Java EE application deployment.

DeploymentManagerCreationException - Exception in javax.enterprise.deploy.spi.exceptions

This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.

DeploymentManagerCreationException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException

Creates an new DeploymentManagerCreationException object.

DeploymentStatus - Interface in javax.enterprise.deploy.spi.status

The DeploymentStatus interface provides information about the progress status of a deployment action.

deprecateObjects(Collection) - Method in interface javax.xml.registry.LifeCycleManager

Deprecates one or more previously submitted objects.

deriveLogicalViewId(FacesContext, String) - Method in class javax.faces.application.ViewHandler

Derive and return the viewId from the current request, or the argument input by following the algorithm defined in specification section JSF.7.6.2.

deriveLogicalViewId(FacesContext, String) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.deriveLogicalViewId(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

deriveViewId(FacesContext, String) - Method in class javax.faces.application.ViewHandler

Derive and return the viewId from the current request, or the argument input by following the algorithm defined in specification section JSF.7.6.2.

deriveViewId(FacesContext, String) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.deriveViewId(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

desc(Expression<?>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an ordering by the descending value of the expression.

description - Variable in class javax.resource.spi.work.HintsContext

DeserializationContext - Interface in javax.xml.rpc.encoding

The javax.xml.rpc.encoding.DeserializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner.

Deserializer - Interface in javax.xml.rpc.encoding

The javax.xml.rpc.encoding.Deserializer interface defines a base interface for deserializers.

DeserializerFactory - Interface in javax.xml.rpc.encoding

The javax.xml.rpc.encoding.DeserializerFactory is a factory of deserializers.

Destination - Interface in javax.jms

A Destination object encapsulates a provider-specific address.

destroy(Contextual<?>) - Method in interface javax.enterprise.context.spi.AlterableContext

Destroy the existing contextual instance.

destroy(T, CreationalContext<T>) - Method in interface javax.enterprise.context.spi.Contextual

Destroy an instance of the contextual type.

destroy(T) - Method in interface javax.enterprise.inject.Instance

On Instance.destroy(Object) being called, the container destroys the instance if the active context object for the scope type of the bean supports destroying bean instances.

destroy() - Method in class javax.faces.webapp.FacesServlet

Release all resources acquired at startup time.

destroy() - Method in interface javax.resource.spi.ManagedConnection

Destroys the physical connection to the underlying resource manager.

destroy() - Method in interface javax.servlet.Filter

Called by the web container to indicate to a filter that it is being taken out of service.

destroy() - Method in class javax.servlet.GenericServlet

Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.

destroy() - Method in interface javax.servlet.http.HttpUpgradeHandler

It is called when the client is disconnected.

destroy() - Method in interface javax.servlet.Servlet

Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.

destroy() - Method in interface javax.websocket.Decoder

This method is called when the decoder is about to be removed from service in order that any resources the encoder used may be closed gracefully.

destroy() - Method in interface javax.websocket.Encoder

This method is called when the encoder is about to be removed from service in order that any resources the encoder used may be closed gracefully.

destroy() - Method in class javax.xml.rpc.handler.GenericHandler

The destroy method indicates the end of lifecycle for a Handler instance.

destroy() - Method in interface javax.xml.rpc.handler.Handler

The destroy method indicates the end of lifecycle for a Handler instance.

destroy() - Method in interface javax.xml.rpc.handler.HandlerChain

Indicates the end of lifecycle for a HandlerChain.

destroy() - Method in interface javax.xml.rpc.server.ServiceLifecycle

JAX-RPC runtime system ends the lifecycle of a service endpoint instance by invoking the destroy method.

Destroyed - Annotation Type in javax.enterprise.context

The @Destroyed qualifier.

detach(Object) - Method in interface javax.persistence.EntityManager

Remove the given entity from the persistence context, causing a managed entity to become detached.

detachListener(RegistrationListener, String, String) - Method in class javax.security.auth.message.config.AuthConfigFactory

Disassociate the listener from all the provider registrations whose layer and appContext values are matched by the corresponding arguments to this method.

detachNode() - Method in interface javax.xml.soap.Node

Removes this Node object from the tree.

Detail - Interface in javax.xml.soap

A container for DetailEntry objects.

DetailEntry - Interface in javax.xml.soap

The content for a Detail object, giving details for a SOAPFault object.

dh - Variable in class javax.mail.internet.MimeBodyPart

The DataHandler object representing this Part's content.

dh - Variable in class javax.mail.internet.MimeMessage

The DataHandler object representing this Message's content.

diff(Expression<? extends N>, Expression<? extends N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the difference between its arguments.

diff(Expression<? extends N>, N) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the difference between its arguments.

diff(N, Expression<? extends N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the difference between its arguments.

DIGEST_AUTH - Static variable in class javax.faces.context.ExternalContext

String identifier for DIGEST authentication.

DIGEST_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest

String identifier for Digest authentication.

DIGEST_AUTH - Static variable in interface javax.ws.rs.core.SecurityContext

String identifier for Digest authentication.

Digits - Annotation Type in javax.validation.constraints

The annotated element must be a number within accepted range Supported types are: BigDecimal BigInteger CharSequence byte, short, int, long, and their respective wrapper types
null elements are considered valid.

Digits.List - Annotation Type in javax.validation.constraints

Defines several Digits annotations on the same element.

DISABLE_DEFAULT_BEAN_VALIDATOR_PARAM_NAME - Static variable in class javax.faces.validator.BeanValidator

If this param is defined, and calling toLowerCase().equals(“true”) on a String representation of its value returns true, the runtime must not automatically add the validator with validator-id equal to the value of the symbolic constant BeanValidator.VALIDATOR_ID to the list of default validators.

DISABLE_FACELET_JSF_VIEWHANDLER_PARAM_NAME - Static variable in class javax.faces.application.ViewHandler

If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, the default ViewHandler must behave as specified in the latest 1.2 version of this specification.

disableClientWindowRenderMode(FacesContext) - Method in class javax.faces.lifecycle.ClientWindow

Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first before rendering those URLs.

disableClientWindowRenderMode(FacesContext) - Method in class javax.faces.lifecycle.ClientWindowWrapper

disableDefaultConstraintViolation() - Method in interface javax.validation.ConstraintValidatorContext

Disables the default ConstraintViolation object generation (which is using the message template declared on the constraint).

disconnected(ConnectionEvent) - Method in class javax.mail.event.ConnectionAdapter

DISCONNECTED - Static variable in class javax.mail.event.ConnectionEvent

A connection was disconnected (not currently used).

disconnected(ConnectionEvent) - Method in interface javax.mail.event.ConnectionListener

Invoked when a Store is disconnected.

discoveredProviders - Static variable in class javax.enterprise.inject.spi.CDI

DiscriminatorColumn - Annotation Type in javax.persistence

Specifies the discriminator column for the SINGLE_TABLE and JOINED Inheritance mapping strategies.

DiscriminatorType - Enum in javax.persistence

Defines supported types of the discriminator column.

DiscriminatorValue - Annotation Type in javax.persistence

Specifies the value of the discriminator column for entities of the given type.

disjunction() - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a disjunction (with zero disjuncts).

dispatch(String) - Method in class javax.faces.context.ExternalContext

Dispatch a request to the specified resource to create output for this response.

dispatch(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.dispatch(String) on the wrapped ExternalContext object.

dispatch(Object) - Method in class javax.mail.event.ConnectionEvent

Invokes the appropriate ConnectionListener method

dispatch(Object) - Method in class javax.mail.event.FolderEvent

Invokes the appropriate FolderListener method

dispatch(Object) - Method in class javax.mail.event.MailEvent

This method invokes the appropriate method on a listener for this event.

dispatch(Object) - Method in class javax.mail.event.MessageChangedEvent

Invokes the appropriate MessageChangedListener method.

dispatch(Object) - Method in class javax.mail.event.MessageCountEvent

Invokes the appropriate MessageCountListener method.

dispatch(Object) - Method in class javax.mail.event.StoreEvent

Invokes the appropriate StoreListener method.

dispatch(Object) - Method in class javax.mail.event.TransportEvent

Invokes the appropriate TransportListener method.

dispatch() - Method in interface javax.servlet.AsyncContext

Dispatches the request and response objects of this AsyncContext to the servlet container.

dispatch(String) - Method in interface javax.servlet.AsyncContext

Dispatches the request and response objects of this AsyncContext to the given path.

dispatch(ServletContext, String) - Method in interface javax.servlet.AsyncContext

Dispatches the request and response objects of this AsyncContext to the given path scoped to the given context.

Dispatch<T> - Interface in javax.xml.ws

The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.

DispatcherType - Enum in javax.servlet

Enumeration of filter dispatcher types.

dispose(T) - Method in interface javax.enterprise.inject.spi.Producer

Destroys the instance.

dispose() - Method in class javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance

Dispose of the instance, doing any necessary cleanup

Disposes - Annotation Type in javax.enterprise.inject

Identifies the disposed parameter of a disposer method.

DissociatableManagedConnection - Interface in javax.resource.spi

This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation.

dissociateConnections() - Method in interface javax.resource.spi.DissociatableManagedConnection

This method is called by an application server (that is capable of lazy connection association optimization) in order to dissociate a ManagedConnection instance from all of its connection handles.

distinct(boolean) - Method in interface javax.persistence.criteria.AbstractQuery

Specify whether duplicate query results will be eliminated.

distinct(boolean) - Method in interface javax.persistence.criteria.CriteriaQuery

Specify whether duplicate query results will be eliminated.

distinct(boolean) - Method in interface javax.persistence.criteria.Subquery

Specify whether duplicate query results will be eliminated.

DistributableWork - Interface in javax.resource.spi.work

This models a Work instance that would be distributed by a DistributableWorkManager for execution in a remote DistributableWorkManager

DistributableWorkManager - Interface in javax.resource.spi.work

This interface models a WorkManager that supports distributed execution of Work instances.

DISTRIBUTE - Static variable in class javax.enterprise.deploy.shared.CommandType

The DeploymentManger action operation being processed is distribute.

distribute(Target[], File, File) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.

distribute(Target[], InputStream, InputStream) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Deprecated.
as of Java EE 5, replaced with DeploymentManager.distribute(Target[], ModuleType, InputStream, InputStream)

distribute(Target[], ModuleType, InputStream, InputStream) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.

doAfterBody() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Perform any processing necessary to handle the content implications of CASE 4 in the class description.

doAfterBody() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Continues the iteration when appropriate -- that is, if we (a) have more items and (b) don't run over our 'end' (given our 'step').

doAfterBody() - Method in class javax.servlet.jsp.tagext.BodyTagSupport

After the body evaluation: do not reevaluate and continue with the page.

doAfterBody() - Method in interface javax.servlet.jsp.tagext.IterationTag

Process body (re)evaluation.

doAfterBody() - Method in class javax.servlet.jsp.tagext.TagSupport

Default processing for a body.

doCatch(Throwable) - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Rethrows the given Throwable.

doCatch(Throwable) - Method in interface javax.servlet.jsp.tagext.TryCatchFinally

Invoked if a Throwable occurs while evaluating the BODY inside a tag or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().

doDelete(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet

Called by the server (via the service method) to allow a servlet to handle a DELETE request.

doEndTag() - Method in class javax.faces.webapp.AttributeTag

Deprecated.

doEndTag() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Perform any processing necessary to handle the content implications of CASE 3 in the class description.

doEndTag() - Method in class javax.servlet.jsp.tagext.BodyTagSupport

Default processing of the end tag returning EVAL_PAGE.

doEndTag() - Method in interface javax.servlet.jsp.tagext.Tag

Process the end tag for this instance.

doEndTag() - Method in class javax.servlet.jsp.tagext.TagAdapter

Must not be called.

doEndTag() - Method in class javax.servlet.jsp.tagext.TagSupport

Default processing of the end tag returning EVAL_PAGE.

doFilter(ServletRequest, ServletResponse, FilterChain) - Method in interface javax.servlet.Filter

The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain.

doFilter(ServletRequest, ServletResponse) - Method in interface javax.servlet.FilterChain

Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.

doFinally() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Removes any attributes that this LoopTagSupport set.

doFinally() - Method in interface javax.servlet.jsp.tagext.TryCatchFinally

Invoked in all cases after doEndTag() for any class implementing Tag, IterationTag or BodyTag.

doGet(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet

Called by the server (via the service method) to allow a servlet to handle a GET request.

doHead(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet

Receives an HTTP HEAD request from the protected service method and handles the request.

doInitBody() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Prepare for evaluation of the body.

doInitBody() - Method in interface javax.servlet.jsp.tagext.BodyTag

Prepare for evaluation of the body.

doInitBody() - Method in class javax.servlet.jsp.tagext.BodyTagSupport

Prepare for evaluation of the body just before the first body evaluation: no action.

DomHandler<ElementT,ResultT extends Result> - Interface in javax.xml.bind.annotation

Converts an element (and its descendants) from/to DOM (or similar) representation.

doOptions(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet

Called by the server (via the service method) to allow a servlet to handle a OPTIONS request.

doPost(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet

Called by the server (via the service method) to allow a servlet to handle a POST request.

doPostPhaseActions(FacesContext) - Method in class javax.faces.context.Flash

Called after the execution of every lifecycle phase, this method allows implementations to take the necessary actions to provide the Flash scope contract as it applies to the request procesing lifecycle.

doPostPhaseActions(FacesContext) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Flash.doPostPhaseActions(FacesContext) on the wrapped Flash object.

doPrePhaseActions(FacesContext) - Method in class javax.faces.context.Flash

Called before the execution of every lifecycle phase, this method allows implementations to take the necessary actions to provide the Flash scope contract as it applies to the request procesing lifecycle.

doPrePhaseActions(FacesContext) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Flash.doPrePhaseActions(FacesContext) on the wrapped Flash object.

doPut(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet

Called by the server (via the service method) to allow a servlet to handle a PUT request.

doStartTag() - Method in class javax.faces.webapp.AttributeTag

Deprecated.

Register the specified attribute name and value with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if this UIComponent does not already have a value for the specified attribute name.

doStartTag() - Method in class javax.faces.webapp.ConverterELTag

Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentClassicTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.

doStartTag() - Method in class javax.faces.webapp.ConverterTag

Deprecated.

Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.

doStartTag() - Method in class javax.faces.webapp.FacetTag

Return EVAL_BODY_INCLUDE to cause nested body content to be evaluated.

doStartTag() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Perform any processing necessary to find (or create) the UIComponent instance in the view corresponding to this tag instance in the page and, if and only if a component was created, insert it into the tree at the proper location as expected by the page author.

doStartTag() - Method in class javax.faces.webapp.ValidatorELTag

Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.

doStartTag() - Method in class javax.faces.webapp.ValidatorTag

Deprecated.

Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.

doStartTag() - Method in class javax.servlet.jsp.jstl.core.ConditionalTagSupport

Includes its body if condition() evaluates to true.

doStartTag() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Begins iterating by processing the first item.

doStartTag() - Method in class javax.servlet.jsp.tagext.BodyTagSupport

Default processing of the start tag returning EVAL_BODY_BUFFERED.

doStartTag() - Method in interface javax.servlet.jsp.tagext.Tag

Process the start tag for this instance.

doStartTag() - Method in class javax.servlet.jsp.tagext.TagAdapter

Must not be called.

doStartTag() - Method in class javax.servlet.jsp.tagext.TagSupport

Default processing of the start tag, returning SKIP_BODY.

doTag() - Method in interface javax.servlet.jsp.tagext.SimpleTag

Called by the container to invoke this tag.

doTag() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport

Default processing of the tag does nothing.

doTrace(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet

Called by the server (via the service method) to allow a servlet to handle a TRACE request.

DOUBLE_ID - Static variable in class javax.faces.convert.DoubleConverter

The message identifier of the FacesMessage to be created if the conversion to Double fails.

DoubleConverter - Class in javax.faces.convert

Converter implementation for java.lang.Double (and double primitive) values.

DoubleConverter() - Constructor for class javax.faces.convert.DoubleConverter

DoubleHolder - Class in javax.xml.rpc.holders

DoubleHolder() - Constructor for class javax.xml.rpc.holders.DoubleHolder

DoubleHolder(double) - Constructor for class javax.xml.rpc.holders.DoubleHolder

DoubleRangeValidator - Class in javax.faces.validator

DoubleRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.

DoubleRangeValidator() - Constructor for class javax.faces.validator.DoubleRangeValidator

Construct a Validator with no preconfigured limits.

DoubleRangeValidator(double) - Constructor for class javax.faces.validator.DoubleRangeValidator

Construct a Validator with the specified preconfigured limit.

DoubleRangeValidator(double, double) - Constructor for class javax.faces.validator.DoubleRangeValidator

Construct a Validator with the specified preconfigured limits.

doubleValue() - Method in interface javax.json.JsonNumber

Returns this JSON number as a double.

DoubleWrapperHolder - Class in javax.xml.rpc.holders

DoubleWrapperHolder() - Constructor for class javax.xml.rpc.holders.DoubleWrapperHolder

DoubleWrapperHolder(Double) - Constructor for class javax.xml.rpc.holders.DoubleWrapperHolder

doWork(Work) - Method in interface javax.resource.spi.work.WorkManager

Accepts a Work instance for processing.

doWork(Work, long, ExecutionContext, WorkListener) - Method in interface javax.resource.spi.work.WorkManager

Accepts a Work instance for processing.

DRAFT - Static variable in class javax.mail.Flags.Flag

This message is a draft.

ds - Variable in class javax.mail.internet.MimeMultipart

The DataSource supplying our InputStream.

DUPLICATE_CONTEXTS - Static variable in class javax.resource.spi.work.WorkContextErrorCodes

Indicates that there are more than one instance of a WorkContext type passed in by the Work instance.

DuplicateKeyException - Exception in javax.ejb

The DuplicateKeyException exception is thrown if an entity EJB object or EJB local object cannot be created because an object with the same key already exists.

DuplicateKeyException() - Constructor for exception javax.ejb.DuplicateKeyException

Constructs a DuplicateKeyException with no detail message.

DuplicateKeyException(String) - Constructor for exception javax.ejb.DuplicateKeyException

Constructs a DuplicateKeyException with the specified detail message.

DUPS_OK_ACKNOWLEDGE - Static variable in interface javax.jms.JMSContext

This session mode instructs the JMSContext's session to lazily acknowledge the delivery of messages.

DUPS_OK_ACKNOWLEDGE - Static variable in interface javax.jms.Session

This acknowledgment mode instructs the session to lazily acknowledge the delivery of messages.

DYNAMIC_SOAP_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants

Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method.

DynamicAttributes - Interface in javax.servlet.jsp.tagext

For a tag to declare that it accepts dynamic attributes, it must implement this interface.

DynamicFeature - Interface in javax.ws.rs.container

A JAX-RS meta-provider for dynamic registration of post-matching providers during a JAX-RS application setup at deployment time.

E

EAR - Static variable in class javax.enterprise.deploy.shared.ModuleType

The module is an EAR archive.

EditableValueHolder - Interface in javax.faces.component

EditableValueHolder is an extension of ValueHolder that describes additional features supported by editable components, including ValueChangeEvents and Validators.

EditableValueHolderAttachedObjectHandler - Interface in javax.faces.view

A VDL handler that exposes Validator or ValueChangeListener to a page author.

EditableValueHolderAttachedObjectTarget - Interface in javax.faces.view

A marker interface for VDL tags that represent <composite:editableValueHolder/> for use by the composite component page author.

EISSystemException - Exception in javax.resource.spi

An EISSystemException is used to indicate any EIS specific system-level error conditions.

EISSystemException() - Constructor for exception javax.resource.spi.EISSystemException

Constructs a new instance with null as its detail message.

EISSystemException(String) - Constructor for exception javax.resource.spi.EISSystemException

Constructs a new instance with the specified detail message.

EISSystemException(Throwable) - Constructor for exception javax.resource.spi.EISSystemException

Constructs a new throwable with the specified cause.

EISSystemException(String, Throwable) - Constructor for exception javax.resource.spi.EISSystemException

Constructs a new throwable with the specified detail message and cause.

EISSystemException(String, String) - Constructor for exception javax.resource.spi.EISSystemException

Constructs a new throwable with the specified detail message and an error code.

EJB - Annotation Type in javax.ejb

Indicates a dependency on the local, no-interface, or remote view of an Enterprise JavaBean.

EJB - Static variable in class javax.enterprise.deploy.shared.ModuleType

The module is an Enterprise Java Bean archive.

EJBAccessException - Exception in javax.ejb

This exception indicates that client access to a business method was denied.

EJBAccessException() - Constructor for exception javax.ejb.EJBAccessException

Constructs an EJBAccessException with no detail message.

EJBAccessException(String) - Constructor for exception javax.ejb.EJBAccessException

Constructs an EJBAccessException with the specified detailed message.

ejbActivate() - Method in interface javax.ejb.EntityBean

A container invokes this method when the instance is taken out of the pool of available instances to become associated with a specific EJB object.

ejbActivate() - Method in interface javax.ejb.SessionBean

The activate method is called when a stateful session bean instance is activated from its "passive" state.

EJBContainer - Class in javax.ejb.embeddable

Used to execute an EJB application in an embeddable container.

EJBContainer() - Constructor for class javax.ejb.embeddable.EJBContainer

EJBContainerProvider - Interface in javax.ejb.spi

The EJBContainerProvider SPI is used by the embeddable container bootstrap class to initialize a suitable embeddable container.

EJBContext - Interface in javax.ejb

The EJBContext interface provides an instance with access to the container-provided runtime context of an enterprise bean instance.

EJBException - Exception in javax.ejb

The EJBException is thrown to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g.

EJBException() - Constructor for exception javax.ejb.EJBException

Constructs an EJBException with no detail message.

EJBException(String) - Constructor for exception javax.ejb.EJBException

Constructs an EJBException with the specified detailed message.

EJBException(Exception) - Constructor for exception javax.ejb.EJBException

Constructs an EJBException that embeds the originally thrown exception.

EJBException(String, Exception) - Constructor for exception javax.ejb.EJBException

Constructs an EJBException that embeds the originally thrown exception with the specified detail message.

EJBHome - Interface in javax.ejb

The EJBHome interface must be extended by all enterprise beans' remote home interfaces.

ejbLoad() - Method in interface javax.ejb.EntityBean

A container invokes this method to instruct the instance to synchronize its state by loading it state from the underlying database.

EJBLocalHome - Interface in javax.ejb

The EJBLocalHome interface must be extended by all enterprise beans' local home interfaces.

EJBLocalObject - Interface in javax.ejb

The EJBLocalObject interface must be extended by all enterprise beans' local interfaces.

EJBMetaData - Interface in javax.ejb

The EJBMetaData interface allows a client to obtain the enterprise bean's meta-data information.

EJBMethodPermission - Class in javax.security.jacc

Class for EJB method permissions.

EJBMethodPermission(String, String) - Constructor for class javax.security.jacc.EJBMethodPermission

Creates a new EJBMethodPermission with the specified name and actions.

EJBMethodPermission(String, String, String, String[]) - Constructor for class javax.security.jacc.EJBMethodPermission

Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodName, methodInterface, and methodParams.

EJBMethodPermission(String, String, Method) - Constructor for class javax.security.jacc.EJBMethodPermission

Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodInterface, and the Method object.

EJBObject - Interface in javax.ejb

The EJBObject interface is extended by all enterprise beans' remote interfaces.

ejbPassivate() - Method in interface javax.ejb.EntityBean

A container invokes this method on an instance before the instance becomes disassociated with a specific EJB object.

ejbPassivate() - Method in interface javax.ejb.SessionBean

The passivate method is called before a stateful session bean instance enters the "passive" state.

ejbRemove() - Method in interface javax.ejb.EntityBean

A container invokes this method before it removes the EJB object that is currently associated with the instance.

ejbRemove() - Method in interface javax.ejb.MessageDrivenBean

A container invokes this method before it ends the life of the message-driven object.

ejbRemove() - Method in interface javax.ejb.SessionBean

A container invokes this method before it ends the life of the session object.

EJBRoleRefPermission - Class in javax.security.jacc

Class for EJB isCallerInRole (String reference) permissions.

EJBRoleRefPermission(String, String) - Constructor for class javax.security.jacc.EJBRoleRefPermission

Creates a new EJBRoleRefPermission with the specified name and actions.

EJBs - Annotation Type in javax.ejb

Declares multiple EJB annotations.

EJBStats - Interface in javax.management.j2ee.statistics

Specifies statistics provided by all EJB component types.

ejbStore() - Method in interface javax.ejb.EntityBean

A container invokes this method to instruct the instance to synchronize its state by storing it to the underlying database.

ejbTimeout(Timer) - Method in interface javax.ejb.TimedObject

Invoked by the EJB container upon timer expiration.

EJBTransactionRequiredException - Exception in javax.ejb

This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.

EJBTransactionRequiredException() - Constructor for exception javax.ejb.EJBTransactionRequiredException

Constructs an EJBTransactionRequiredException with no detail message.

EJBTransactionRequiredException(String) - Constructor for exception javax.ejb.EJBTransactionRequiredException

Constructs an EJBTransactionRequiredException with the specified detailed message.

EJBTransactionRolledbackException - Exception in javax.ejb

This exception is thrown to a remote client to indicate that the transaction associated with processing of the request has been rolled back, or marked to roll back.

EJBTransactionRolledbackException() - Constructor for exception javax.ejb.EJBTransactionRolledbackException

Constructs an EJBTransactionRolledbackException with no detail message.

EJBTransactionRolledbackException(String) - Constructor for exception javax.ejb.EJBTransactionRolledbackException

Constructs an EJBTransactionRolledbackException with the specified detailed message.

EJBTransactionRolledbackException(String, Exception) - Constructor for exception javax.ejb.EJBTransactionRolledbackException

Constructs an EJBTransactionRolledbackException with the specified detail message and a nested exception.

ELClass - Class in javax.el

A runtime representation of a Class in the EL expressions.

ELClass(Class<?>) - Constructor for class javax.el.ELClass

Constructor

ELContext - Class in javax.el

Context information for expression parsing and evaluation.

ELContext() - Constructor for class javax.el.ELContext

ELContextEvent - Class in javax.el

An event which indicates that an ELContext has been created.

ELContextEvent(ELContext) - Constructor for class javax.el.ELContextEvent

Constructs an ELContextEvent object to indicate that an ELContext has been created.

ELContextListener - Interface in javax.el

The listener interface for receiving notification when an ELContext is created.

Element - Interface in javax.xml.bind

This is an element marker interface.

element(Element) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.

ElementCollection - Annotation Type in javax.persistence

Specifies a collection of instances of a basic type or embeddable class.

ElementDescriptor - Interface in javax.validation.metadata

Describes a validated element (class, property, method etc.).

ElementDescriptor.ConstraintFinder - Interface in javax.validation.metadata

Declares restrictions on retrieved constraints.

ElementKind - Enum in javax.validation

Enum of possible kinds of elements encountered in Bean Validation.

ELException - Exception in javax.el

Represents any of the exception conditions that can arise during expression evaluation.

ELException() - Constructor for exception javax.el.ELException

Creates an ELException with no detail message.

ELException(String) - Constructor for exception javax.el.ELException

Creates an ELException with the provided detail message.

ELException(Throwable) - Constructor for exception javax.el.ELException

Creates an ELException with the given cause.

ELException(String, Throwable) - Constructor for exception javax.el.ELException

Creates an ELException with the given detail message and root cause.

ELException - Exception in javax.servlet.jsp.el

Deprecated.
As of JSP 2.1, replaced by ELException

ELException() - Constructor for exception javax.servlet.jsp.el.ELException

Deprecated.

Creates an ELException with no detail message.

ELException(String) - Constructor for exception javax.servlet.jsp.el.ELException

Deprecated.

Creates an ELException with the provided detail message.

ELException(Throwable) - Constructor for exception javax.servlet.jsp.el.ELException

Deprecated.

Creates an ELException with the given root cause.

ELException(String, Throwable) - Constructor for exception javax.servlet.jsp.el.ELException

Deprecated.

Creates an ELException with the given detail message and root cause.

ELManager - Class in javax.el

Manages EL parsing and evaluation environment.

ELManager() - Constructor for class javax.el.ELManager

ELParseException - Exception in javax.servlet.jsp.el

Deprecated.
As of JSP 2.1, replaced by ELException

ELParseException() - Constructor for exception javax.servlet.jsp.el.ELParseException

Deprecated.

Creates an ELParseException with no detail message.

ELParseException(String) - Constructor for exception javax.servlet.jsp.el.ELParseException

Deprecated.

Creates an ELParseException with the provided detail message.

ELProcessor - Class in javax.el

Provides an API for using EL in a stand-alone environment.

ELProcessor() - Constructor for class javax.el.ELProcessor

ELResolver - Class in javax.el

Enables customization of variable, property, method call, and type conversion resolution behavior for EL expression evaluation.

ELResolver() - Constructor for class javax.el.ELResolver

EMAIL_ADDRESS - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.EmailAddress interface.

EmailAddress - Interface in javax.xml.registry.infomodel

Represents an email address.

Embeddable - Annotation Type in javax.persistence

Specifies a class whose instances are stored as an intrinsic part of an owning entity and share the identity of the entity.

embeddable(Class<X>) - Method in interface javax.persistence.metamodel.Metamodel

Return the metamodel embeddable type representing the embeddable class.

EmbeddableType<X> - Interface in javax.persistence.metamodel

Instances of the type EmbeddableType represent embeddable types.

Embedded - Annotation Type in javax.persistence

Specifies a persistent field or property of an entity whose value is an instance of an embeddable class.

EmbeddedId - Annotation Type in javax.persistence

Applied to a persistent field or property of an entity class or mapped superclass to denote a composite primary key that is an embeddable class.

EMPTY_VALIDATION_GROUPS_PATTERN - Static variable in class javax.faces.validator.BeanValidator

The regular expression pattern that identifies an empty list of validation groups.

enableClientWindowRenderMode(FacesContext) - Method in class javax.faces.lifecycle.ClientWindow

Components that permit per-use disabling of the appending of the ClientWindow in generated URLs must call this method first after rendering those URLs.

enableClientWindowRenderMode(FacesContext) - Method in class javax.faces.lifecycle.ClientWindowWrapper

enabled - Variable in class javax.xml.ws.WebServiceFeature

Specifies if the feature is enabled or disabled

encode(OutputStream, String) - Static method in class javax.mail.internet.MimeUtility

Wrap an encoder around the given output stream.

encode(OutputStream, String, String) - Static method in class javax.mail.internet.MimeUtility

Wrap an encoder around the given output stream.

encode(T) - Method in interface javax.websocket.Encoder.Binary

Encode the given object into a byte array.

encode(T, OutputStream) - Method in interface javax.websocket.Encoder.BinaryStream

Encode the given object into a binary stream written to the implementation provided OutputStream.

encode(T) - Method in interface javax.websocket.Encoder.Text

Encode the given object into a String.

encode(T, Writer) - Method in interface javax.websocket.Encoder.TextStream

Encode the given object to a character stream writing it to the supplied Writer.

encodeActionURL(String) - Method in class javax.faces.context.ExternalContext

Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable action in the current application.

encodeActionURL(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.encodeActionURL(String) on the wrapped ExternalContext object.

encodeAll(FacesContext) - Method in class javax.faces.component.UIComponent

If this component returns true from UIComponent.isRendered(), take the following action.

encodeAll(FacesContext) - Method in class javax.faces.component.UIViewParameter

Called specially by UIViewRoot.encodeEnd(javax.faces.context.FacesContext), this method simply sets the submitted value to be the return from UIViewParameter.getStringValue(javax.faces.context.FacesContext).

encodeBegin(FacesContext) - Method in class javax.faces.component.UIComponent

If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext.

encodeBegin(FacesContext) - Method in class javax.faces.component.UIComponentBase

encodeBegin(FacesContext) - Method in class javax.faces.component.UIData

In addition to the default behavior, ensure that any saved per-row state for our child input components is discarded unless it is needed to rerender the current page with errors.

encodeBegin(FacesContext) - Method in class javax.faces.component.UIViewRoot

Override the default UIComponentBase.encodeBegin(javax.faces.context.FacesContext) behavior.

encodeBegin(FacesContext, UIComponent) - Method in class javax.faces.render.Renderer

Render the beginning specified UIComponent to the output stream or writer associated with the response we are creating.

encodeBegin(FacesContext, UIComponent) - Method in class javax.faces.render.RendererWrapper

encodeBegin() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Deprecated.
No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.

encodeBookmarkableURL(String, Map<String, List<String>>) - Method in class javax.faces.context.ExternalContext

The purpose of this method is to generate a query string from the collection of Parameter objects provided by the parameters argument and append that query string to the baseUrl.

encodeBookmarkableURL(String, Map<String, List<String>>) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.encodeBookmarkableURL(String, java.util.Map) on the wrapped ExternalContext object.

encodeChildren(FacesContext) - Method in class javax.faces.component.UIComponent

If our rendered property is true, render the child UIComponents of this UIComponent.

encodeChildren(FacesContext) - Method in class javax.faces.component.UIComponentBase

encodeChildren(FacesContext) - Method in class javax.faces.component.UIViewRoot

If PartialViewContext.isAjaxRequest() returns true, perform partial rendering by calling PartialViewContext.processPartial(javax.faces.event.PhaseId) with PhaseId.RENDER_RESPONSE.

encodeChildren(FacesContext, UIComponent) - Method in class javax.faces.render.Renderer

Render the child components of this UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.

encodeChildren(FacesContext, UIComponent) - Method in class javax.faces.render.RendererWrapper

encodeChildren() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Deprecated.
No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.

Encoded - Annotation Type in javax.ws.rs

Disables automatic decoding of parameter values bound using QueryParam, PathParam, FormParam or MatrixParam.

encodedPersonal - Variable in class javax.mail.internet.InternetAddress

The RFC 2047 encoded version of the personal name.

encodeEnd(FacesContext) - Method in class javax.faces.component.UIComponent

If our rendered property is true, render the ending of the current state of this UIComponent.

encodeEnd(FacesContext) - Method in class javax.faces.component.UIComponentBase

encodeEnd(FacesContext) - Method in class javax.faces.component.UIViewRoot

If UIViewRoot.getAfterPhaseListener() returns non-null, invoke it, passing a PhaseEvent for the PhaseId.RENDER_RESPONSE phase.

encodeEnd(FacesContext, UIComponent) - Method in class javax.faces.render.Renderer

Render the ending of the current state of the specified UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.

encodeEnd(FacesContext, UIComponent) - Method in class javax.faces.render.RendererWrapper

encodeEnd() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Deprecated.
No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.

EncodeException - Exception in javax.websocket

A general exception that occurs when trying to encode a custom object to a string or binary message.

EncodeException(Object, String) - Constructor for exception javax.websocket.EncodeException

Constructor with the object being encoded, and the reason why it failed to be.

EncodeException(Object, String, Throwable) - Constructor for exception javax.websocket.EncodeException

Constructor with the object being encoded, and the reason why it failed to be, and the cause.

encodeNamespace(String) - Method in class javax.faces.context.ExternalContext

Return the specified name, after prefixing it with a namespace that ensures that it will be unique within the context of a particular page.

encodeNamespace(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.encodeNamespace(String) on the wrapped ExternalContext object.

encodePartialActionURL(String) - Method in class javax.faces.context.ExternalContext

Return the input URL, after performing any rewriting needed to ensure that it can be used in a partial page submission (ajax request) to correctly identify an addressable action in the current application.

encodePartialActionURL(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.encodePartialActionURL(String) on the wrapped ExternalContext object.

Encoder - Interface in javax.websocket

The Encoder interface defines how developers can provide a way to convert their custom objects into web socket messages.

Encoder.Binary<T> - Interface in javax.websocket

This interface defines how to provide a way to convert a custom object into a binary message.

Encoder.BinaryStream<T> - Interface in javax.websocket

This interface may be implemented by encoding algorithms that want to write the encoded object to a binary stream.

Encoder.Text<T> - Interface in javax.websocket

This interface defines how to provide a way to convert a custom object into a text message.

Encoder.TextStream<T> - Interface in javax.websocket

This interface may be implemented by encoding algorithms that want to write the encoded object to a character stream.

encodeRedirectURL(String, Map<String, List<String>>) - Method in class javax.faces.context.ExternalContext

The purpose of this method is to generate a query string from the collection of Parameter objects provided by the parameters argument and append that query string to the baseUrl.

encodeRedirectURL(String, Map<String, List<String>>) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.encodeRedirectURL(String, java.util.Map) on the wrapped ExternalContext object.

encodeRedirectURL(String) - Method in interface javax.servlet.http.HttpServletResponse

Encodes the specified URL for use in the sendRedirect method or, if encoding is not needed, returns the URL unchanged.

encodeRedirectUrl(String) - Method in interface javax.servlet.http.HttpServletResponse

Deprecated.
As of version 2.1, use encodeRedirectURL(String url) instead

encodeRedirectURL(String) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to return encodeRedirectURL(String url) on the wrapped response object.

encodeRedirectUrl(String) - Method in class javax.servlet.http.HttpServletResponseWrapper

Deprecated.
As of version 2.1, use HttpServletResponseWrapper.encodeRedirectURL(String url) instead

encodeResourceURL(String) - Method in class javax.faces.context.ExternalContext

Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable resource in the current application.

encodeResourceURL(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.encodeResourceURL(String) on the wrapped ExternalContext object.

encoders(List<Class<? extends Encoder>>) - Method in class javax.websocket.ClientEndpointConfig.Builder

Assign the list of encoder implementation classes the client will use.

encoders(List<Class<? extends Encoder>>) - Method in class javax.websocket.server.ServerEndpointConfig.Builder

Sets the list of encoder implementation classes for this builder.

encodeText(String) - Static method in class javax.mail.internet.MimeUtility

Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.

encodeText(String, String, String) - Static method in class javax.mail.internet.MimeUtility

Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.

encodeURL(String) - Method in interface javax.servlet.http.HttpServletResponse

Encodes the specified URL by including the session ID, or, if encoding is not needed, returns the URL unchanged.

encodeUrl(String) - Method in interface javax.servlet.http.HttpServletResponse

Deprecated.
As of version 2.1, use encodeURL(String url) instead

encodeURL(String) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to call encodeURL(String url) on the wrapped response object.

encodeUrl(String) - Method in class javax.servlet.http.HttpServletResponseWrapper

Deprecated.
As of version 2.1, use HttpServletResponseWrapper.encodeURL(String url) instead

encodeWord(String) - Static method in class javax.mail.internet.MimeUtility

Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.

encodeWord(String, String, String) - Static method in class javax.mail.internet.MimeUtility

Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.

encoding(String) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the message entity content encoding.

EncodingAware - Interface in javax.mail

A DataSource that also implements EncodingAware may specify the Content-Transfer-Encoding to use for its data.

encodings(String...) - Static method in class javax.ws.rs.core.Variant

Create a Variant.VariantListBuilder initialized with a set of supported encodings.

encodings(String...) - Method in class javax.ws.rs.core.Variant.VariantListBuilder

Set the encoding(s) for this variant.

ENCODINGSTYLE_URI_PROPERTY - Static variable in interface javax.xml.rpc.Call

Standard property for encoding Style: Encoding style specified as a namespace URI.

end(Date) - Method in class javax.ejb.ScheduleExpression

Set the end date.

end() - Method in interface javax.enterprise.context.Conversation

Marks the current long-running conversation transient.

end - Variable in class javax.servlet.jsp.jstl.core.LoopTagSupport

Ending index of the iteration ('end' attribute).

end(Xid, int) - Method in interface javax.transaction.xa.XAResource

Ends the work performed on behalf of a transaction branch.

endCDATA() - Method in class javax.faces.context.ResponseWriter

Close an XML CDATA block.

endCDATA() - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.endCDATA() on the wrapped ResponseWriter object.

endCheckpoint() - Method in class javax.batch.api.chunk.AbstractCheckpointAlgorithm

Override this method for the CheckpointAlgorithm to do something after a checkpoint ends.

endCheckpoint() - Method in interface javax.batch.api.chunk.CheckpointAlgorithm

The endCheckpoint method is invoked after the current checkpoint ends.

endDocument() - Method in class javax.faces.context.PartialResponseWriter

Write the end of a partial response.

endDocument() - Method in class javax.faces.context.ResponseWriter

Write whatever text should end a response.

endDocument() - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.endDocument() on the wrapped ResponseWriter object.

endElement(String) - Method in class javax.faces.context.ResponseWriter

Write the end of an element, after closing any open element created by a call to startElement().

endElement(String) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.endElement(String) on the wrapped ResponseWriter object.

endError() - Method in class javax.faces.context.PartialResponseWriter

Write the end of an error.

endEval() - Method in class javax.faces.context.PartialResponseWriter

Write the end of an eval operation.

endExtension() - Method in class javax.faces.context.PartialResponseWriter

Write the end of an extension operation.

endInsert() - Method in class javax.faces.context.PartialResponseWriter

Write the end of an insert operation.

Endpoint - Class in javax.websocket

The Web Socket Endpoint represents an object that can handle websocket conversations.

Endpoint() - Constructor for class javax.websocket.Endpoint

Endpoint - Class in javax.xml.ws

A Web service endpoint.

Endpoint() - Constructor for class javax.xml.ws.Endpoint

ENDPOINT_ADDRESS_PROPERTY - Static variable in interface javax.xml.rpc.Stub

Standard property: Target service endpoint address.

ENDPOINT_ADDRESS_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider

Standard property: Target service endpoint address.

endpointActivation(MessageEndpointFactory, ActivationSpec) - Method in interface javax.resource.spi.ResourceAdapter

This is called during the activation of a message endpoint.

EndpointConfig - Interface in javax.websocket

The endpoint configuration contains all the information needed during the handshake process for this end point.

EndpointContext - Class in javax.xml.ws

EndpointContext allows multiple endpoints in an application to share any information.

EndpointContext() - Constructor for class javax.xml.ws.EndpointContext

endpointDeactivation(MessageEndpointFactory, ActivationSpec) - Method in interface javax.resource.spi.ResourceAdapter

This is called when a message endpoint is deactivated.

endpointName(QName) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.

EndpointReference - Class in javax.xml.ws

This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.

EndpointReference() - Constructor for class javax.xml.ws.EndpointReference

endSpecified - Variable in class javax.servlet.jsp.jstl.core.LoopTagSupport

Boolean flag indicating whether 'end' was specified.

endUpdate() - Method in class javax.faces.context.PartialResponseWriter

Write the end of an update operation.

enlistResource(XAResource) - Method in interface javax.transaction.Transaction

Enlist the resource specified with the transaction associated with the target Transaction object.

enterLambdaScope(Map<String, Object>) - Method in class javax.el.ELContext

Installs a Lambda argument map, in preparation for the evaluation of a Lambda expression.

EnterpriseBean - Interface in javax.ejb

The EnterpriseBean interface is a common superinterface for the SessionBean, EntityBean and MessageDrivenBean interfaces.

Entity - Annotation Type in javax.persistence

Specifies that the class is an entity.

entity(Class<X>) - Method in interface javax.persistence.metamodel.Metamodel

Return the metamodel entity type representing the entity.

Entity<T> - Class in javax.ws.rs.client

Encapsulates message entity including the associated variant information.

entity(T, MediaType) - Static method in class javax.ws.rs.client.Entity

Create an entity using a supplied content media type.

entity(T, MediaType, Annotation[]) - Static method in class javax.ws.rs.client.Entity

Create an entity using a supplied content media type.

entity(T, String) - Static method in class javax.ws.rs.client.Entity

Create an entity using a supplied content media type.

entity(T, Variant) - Static method in class javax.ws.rs.client.Entity

Create an entity using a supplied content media type.

entity(T, Variant, Annotation[]) - Static method in class javax.ws.rs.client.Entity

Create an entity using a supplied content media type.

entity(Object) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the response entity in the builder.

entity(Object, Annotation[]) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the response entity in the builder.

ENTITY_CODER - Static variable in class javax.ws.rs.Priorities

Message encoder or decoder filter/interceptor priority.

EntityBean - Interface in javax.ejb

The EntityBean interface is implemented by every entity bean class.

EntityBeanStats - Interface in javax.management.j2ee.statistics

Specifies statistics provided by entity beans.

EntityContext - Interface in javax.ejb

The EntityContext interface provides an instance with access to the container-provided runtime context of an entity bean instance.

EntityExistsException - Exception in javax.persistence

Thrown by the persistence provider when EntityManager.persist(Object) is called and the entity already exists.

EntityExistsException() - Constructor for exception javax.persistence.EntityExistsException

Constructs a new EntityExistsException exception with null as its detail message.

EntityExistsException(String) - Constructor for exception javax.persistence.EntityExistsException

Constructs a new EntityExistsException exception with the specified detail message.

EntityExistsException(String, Throwable) - Constructor for exception javax.persistence.EntityExistsException

Constructs a new EntityExistsException exception with the specified detail message and cause.

EntityExistsException(Throwable) - Constructor for exception javax.persistence.EntityExistsException

Constructs a new EntityExistsException exception with the specified cause.

EntityGraph<T> - Interface in javax.persistence

This type represents the root of an entity graph that will be used as a template to define the attribute nodes and boundaries of a graph of entities and entity relationships.

EntityListeners - Annotation Type in javax.persistence

Specifies the callback listener classes to be used for an entity or mapped superclass.

EntityManager - Interface in javax.persistence

Interface used to interact with the persistence context.

EntityManagerFactory - Interface in javax.persistence

Interface used to interact with the entity manager factory for the persistence unit.

EntityNotFoundException - Exception in javax.persistence

Thrown by the persistence provider when an entity reference obtained by EntityManager.getReference is accessed but the entity does not exist.

EntityNotFoundException() - Constructor for exception javax.persistence.EntityNotFoundException

Constructs a new EntityNotFoundException exception with null as its detail message.

EntityNotFoundException(String) - Constructor for exception javax.persistence.EntityNotFoundException

Constructs a new EntityNotFoundException exception with the specified detail message.

EntityResult - Annotation Type in javax.persistence

Used in conjunction with the SqlResultSetMapping annotation to map the SELECT clause of a SQL query to an entity result.

EntityTag - Class in javax.ws.rs.core

An abstraction for the value of a HTTP Entity Tag, used as the value of an ETag response header.

EntityTag(String) - Constructor for class javax.ws.rs.core.EntityTag

Creates a new instance of a strong EntityTag.

EntityTag(String, boolean) - Constructor for class javax.ws.rs.core.EntityTag

Creates a new instance of an EntityTag.

EntityTransaction - Interface in javax.persistence

Interface used to control transactions on resource-local entity managers.

EntityType<X> - Interface in javax.persistence.metamodel

Instances of the type EntityType represent entity types.

entries() - Method in interface javax.enterprise.deploy.model.DeployableObject

Returns an enumeration of the module file entries.

entry() - Method in interface javax.persistence.criteria.MapJoin

Create an expression that corresponds to the map entry.

entrySet() - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.entrySet() on the wrapped Flash object.

entrySet() - Method in class javax.ws.rs.core.AbstractMultivaluedMap

ENUM_ID - Static variable in class javax.faces.convert.EnumConverter

The message identifier of the FacesMessage to be created if the conversion to Enum fails.

ENUM_NO_CLASS_ID - Static variable in class javax.faces.convert.EnumConverter

The message identifier of the FacesMessage to be created if the conversion to Enum fails and no target class has been provided.

EnumConverter - Class in javax.faces.convert

Converter implementation for java.lang.Enum (and enum primitive) values.

EnumConverter() - Constructor for class javax.faces.convert.EnumConverter

EnumConverter(Class) - Constructor for class javax.faces.convert.EnumConverter

Enumerated - Annotation Type in javax.persistence

Specifies that a persistent property or field should be persisted as a enumerated type.

EnumType - Enum in javax.persistence

Defines mapping for enumerated types.

ENVELOPE - Static variable in class javax.mail.FetchProfile.Item

This is the Envelope item.

ENVELOPE_CHANGED - Static variable in class javax.mail.event.MessageChangedEvent

The message's envelope (headers, but not body) changed.

EOF - Static variable in class javax.mail.internet.HeaderTokenizer.Token

Token type indicating end of input.

EQ - Static variable in class javax.mail.search.ComparisonTerm

equal(Expression<?>, Expression<?>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing the arguments for equality.

equal(Expression<?>, Object) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing the arguments for equality.

equals(Object) - Method in class javax.el.Expression

Determines whether the specified object is equal to this Expression.

equals(Object) - Method in class javax.enterprise.util.AnnotationLiteral

equals(Object) - Method in class javax.enterprise.util.TypeLiteral

equals(Object) - Method in class javax.faces.application.NavigationCase

equals(Object) - Method in class javax.faces.application.NavigationCaseWrapper

equals(Object) - Method in class javax.faces.validator.DoubleRangeValidator

equals(Object) - Method in class javax.faces.validator.LengthValidator

equals(Object) - Method in class javax.faces.validator.LongRangeValidator

equals(Object) - Method in interface javax.json.JsonNumber

Compares the specified object with this JsonNumber object for equality.

equals(Object) - Method in interface javax.json.JsonString

Compares the specified object with this JsonString for equality.

equals(Object) - Method in class javax.mail.Address

The equality operator.

equals(Object) - Method in class javax.mail.Flags

Check whether the two Flags objects are equal.

equals(Object) - Method in class javax.mail.internet.InternetAddress

The equality operator.

equals(Object) - Method in class javax.mail.internet.NewsAddress

The equality operator.

equals(Object) - Method in class javax.mail.search.AddressStringTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.AddressTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.AndTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.BodyTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.ComparisonTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.DateTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.FlagTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.FromStringTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.FromTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.HeaderTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.IntegerComparisonTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.MessageIDTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.MessageNumberTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.NotTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.OrTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.ReceivedDateTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.RecipientStringTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.RecipientTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.SentDateTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.SizeTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.StringTerm

Equality comparison.

equals(Object) - Method in class javax.mail.search.SubjectTerm

Equality comparison.

equals(Object) - Method in class javax.mail.URLName

Compares two URLNames.

equals(Object) - Method in interface javax.resource.cci.Record

Check if this instance is equal to another Record.

equals(Object) - Method in interface javax.resource.spi.ConnectionRequestInfo

Checks whether this instance is equal to another.

equals(Object) - Method in interface javax.resource.spi.ManagedConnectionFactory

Check if this ManagedConnectionFactory is equal to another ManagedConnectionFactory.

equals(Object) - Method in interface javax.resource.spi.security.GenericCredential

Deprecated.

Tests if this GenericCredential instance refers to the same entity as the supplied object.

equals(Object) - Method in class javax.resource.spi.security.PasswordCredential

Compares this PasswordCredential with the specified object for equality.

equals(Object) - Method in class javax.security.jacc.EJBMethodPermission

Checks two EJBMethodPermission objects for equality.

equals(Object) - Method in class javax.security.jacc.EJBRoleRefPermission

Checks two EJBRoleRefPermission objects for equality.

equals(Object) - Method in class javax.security.jacc.WebResourcePermission

Checks two WebResourcePermission objects for equality.

equals(Object) - Method in class javax.security.jacc.WebRoleRefPermission

Checks two WebRoleRefPermission objects for equality.

equals(Object) - Method in class javax.security.jacc.WebUserDataPermission

Checks two WebUserDataPermission objects for equality.

equals(Object) - Method in class javax.servlet.jsp.jstl.core.IndexedValueExpression

equals(Object) - Method in class javax.servlet.jsp.jstl.core.IteratedValueExpression

equals(Object) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

This implementation delegates the method call to to the the underlying [key, multi-value] store.

equals(Object) - Method in class javax.ws.rs.core.CacheControl

Compares object argument to this cache control to see if they are the same considering all property values.

equals(Object) - Method in class javax.ws.rs.core.Cookie

Compare for equality.

equals(Object) - Method in class javax.ws.rs.core.EntityTag

Compares obj to this tag to see if they are the same considering weakness and value.

equals(Object) - Method in class javax.ws.rs.core.GenericEntity

equals(Object) - Method in class javax.ws.rs.core.GenericType

equals(Object) - Method in class javax.ws.rs.core.MediaType

Compares obj to this media type to see if they are the same by comparing type, subtype and parameters.

equals(Object) - Method in class javax.ws.rs.core.NewCookie

Compare for equality.

equals(Object) - Method in class javax.ws.rs.core.Variant

Compares obj to this variant to see if they are the same considering all property values.

equalsIgnoreValueOrder(MultivaluedMap<K, V>) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

equalsIgnoreValueOrder(MultivaluedMap<K, V>) - Method in interface javax.ws.rs.core.MultivaluedMap

Compare the specified map with this map for equality modulo the order of values for each key.

ERROR - Static variable in interface javax.xml.bind.ValidationEvent

Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation

ERROR_EXCEPTION - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the exception object is propagated during an error dispatch

ERROR_EXCEPTION_TYPE - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the type of the exception object is propagated during an error dispatch

ERROR_MESSAGE - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the exception message is propagated during an error dispatch

ERROR_REQUEST_URI - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the request URI whose processing caused the error is propagated during an error dispatch

ERROR_SERVLET_NAME - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the name of the servlet in which the error occurred is propagated during an error dispatch

ERROR_STATUS_CODE - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the response status is propagated during an error dispatch

errorCode - Variable in exception javax.transaction.SystemException

The error code with which to create the SystemException.

errorCode - Variable in exception javax.transaction.xa.XAException

The error code with which to create the SystemException.

ErrorData - Class in javax.servlet.jsp

Contains information about an error, for error pages.

ErrorData(Throwable, int, String, String) - Constructor for class javax.servlet.jsp.ErrorData

Creates a new ErrorData object.

ETAG - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

eval(String) - Method in class javax.el.ELProcessor

Evaluates an EL expression.

eval(Serializable) - Method in interface javax.faces.component.StateHelper

Attempts to find a value associated with the specified key, using the value expression collection from the component if no such value is found.

eval(Serializable, Object) - Method in interface javax.faces.component.StateHelper

Performs the same logic as StateHelper.eval(java.io.Serializable) } but if no value is found, this will return the specified defaultValue

EVAL_BODY_AGAIN - Static variable in interface javax.servlet.jsp.tagext.IterationTag

Request the reevaluation of some body.

EVAL_BODY_BUFFERED - Static variable in interface javax.servlet.jsp.tagext.BodyTag

Request the creation of new buffer, a BodyContent on which to evaluate the body of this tag.

EVAL_BODY_INCLUDE - Static variable in interface javax.servlet.jsp.tagext.Tag

Evaluate body into existing out stream.

EVAL_BODY_TAG - Static variable in interface javax.servlet.jsp.tagext.BodyTag

Deprecated.
As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.

EVAL_PAGE - Static variable in interface javax.servlet.jsp.tagext.Tag

Continue evaluating the page.

evaluate(VariableResolver) - Method in class javax.servlet.jsp.el.Expression

Deprecated.

Evaluates an expression that was previously prepared.

evaluate(String, Class, VariableResolver, FunctionMapper) - Method in class javax.servlet.jsp.el.ExpressionEvaluator

Deprecated.

Evaluates an expression.

evaluateExpressionGet(FacesContext, String, Class<? extends T>) - Method in class javax.faces.application.Application

Get a value by evaluating an expression.

evaluateExpressionGet(FacesContext, String, Class<? extends T>) - Method in class javax.faces.application.ApplicationWrapper

Deprecated.
See superclass for alternative.

evaluatePreconditions(EntityTag) - Method in interface javax.ws.rs.core.Request

Evaluate request preconditions based on the passed in value.

evaluatePreconditions(Date) - Method in interface javax.ws.rs.core.Request

Evaluate request preconditions based on the passed in value.

evaluatePreconditions(Date, EntityTag) - Method in interface javax.ws.rs.core.Request

Evaluate request preconditions based on the passed in value.

evaluatePreconditions() - Method in interface javax.ws.rs.core.Request

Evaluate request preconditions for a resource that does not currently exist.

EvaluationException - Exception in javax.faces.el

Deprecated.
This has been replaced by ELException.

EvaluationException() - Constructor for exception javax.faces.el.EvaluationException

Deprecated.

Construct a new exception with no detail message or root cause.

EvaluationException(String) - Constructor for exception javax.faces.el.EvaluationException

Deprecated.

Construct a new exception with the specified detail message and no root cause.

EvaluationException(Throwable) - Constructor for exception javax.faces.el.EvaluationException

Deprecated.

Construct a new exception with the specified root cause.

EvaluationException(String, Throwable) - Constructor for exception javax.faces.el.EvaluationException

Deprecated.

Construct a new exception with the specified detail message and root cause.

EvaluationListener - Class in javax.el

The listener interface for receiving notification when an EL expression is evaluated.

EvaluationListener() - Constructor for class javax.el.EvaluationListener

Event<T> - Interface in javax.enterprise.event

Allows the application to fire events of a particular type.

EVENT_TYPE_CREATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent

An event where a RegistryObject is created.

EVENT_TYPE_DELETED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent

An event where a RegistryObject is deleted.

EVENT_TYPE_DEPRECATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent

An event where a RegistryObject is deprecated.

EVENT_TYPE_UNDEPRECATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent

An event where a RegistryObject is undeprecated.

EVENT_TYPE_UPDATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent

An event where a RegistryObject is updated.

EVENT_TYPE_VERSIONED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent

An event where a RegistryObject is versioned.

EventMetadata - Interface in javax.enterprise.inject.spi

Provides access to metadata about an observed event payload.

evict(Class, Object) - Method in interface javax.persistence.Cache

Remove the data for the given entity from the cache.

evict(Class) - Method in interface javax.persistence.Cache

Remove the data for entities of the specified class (and its subclasses) from the cache.

evictAll() - Method in interface javax.persistence.Cache

Clear the cache.

EXACT_NAME_MATCH - Static variable in interface javax.xml.registry.FindQualifier

Specifies a hint to queries that they should use exact (case-insensitive) match when comparing String values.

examineAllHeaderElements() - Method in interface javax.xml.soap.SOAPHeader

Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.

examineHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader

Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor.

examineMustUnderstandHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader

Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.

EXCEPTION - Static variable in class javax.servlet.jsp.PageContext

Name used to store uncaught exception in ServletRequest attribute list and PageContext name table.

EXCEPTION_HANDLER_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the ExceptionHandlerFactory class name.

ExceptionHandler - Class in javax.faces.context

ExceptionHandler is the central point for handling unexpected Exceptions that are thrown during the Faces lifecycle.

ExceptionHandler() - Constructor for class javax.faces.context.ExceptionHandler

ExceptionHandlerFactory - Class in javax.faces.context

ExceptionHandlerFactory is a factory object that creates (if needed) and returns a new ExceptionHandler instance.

ExceptionHandlerFactory() - Constructor for class javax.faces.context.ExceptionHandlerFactory

ExceptionHandlerWrapper - Class in javax.faces.context

Provides a simple implementation of ExceptionHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ExceptionHandler instance.

ExceptionHandlerWrapper() - Constructor for class javax.faces.context.ExceptionHandlerWrapper

ExceptionListener - Interface in javax.jms

If a JMS provider detects a serious problem with a Connection object, it informs the Connection object's ExceptionListener, if one has been registered.

ExceptionMapper<E extends Throwable> - Interface in javax.ws.rs.ext

Contract for a provider that maps Java exceptions to Response.

ExceptionQueuedEvent - Class in javax.faces.event

The system event facility will create an instance of this class whenever Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) is called with ExceptionQueuedEvent.class as systemEventClass argument.

ExceptionQueuedEvent(ExceptionQueuedEventContext) - Constructor for class javax.faces.event.ExceptionQueuedEvent

Instantiate a new ExceptionQueuedEvent that indicates the argument ExceptionQueuedEventContext occurred.

ExceptionQueuedEventContext - Class in javax.faces.event

This helper class provides context to the ExceptionQueuedEvent regarding the state of the system at the point in time when the ExceptionQueuedEvent occurs and links the ExceptionQueuedEvent to the ExceptionHandler by virtue of implementing SystemEventListener.

ExceptionQueuedEventContext(FacesContext, Throwable) - Constructor for class javax.faces.event.ExceptionQueuedEventContext

Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred.

ExceptionQueuedEventContext(FacesContext, Throwable, UIComponent) - Constructor for class javax.faces.event.ExceptionQueuedEventContext

Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component.

ExceptionQueuedEventContext(FacesContext, Throwable, UIComponent, PhaseId) - Constructor for class javax.faces.event.ExceptionQueuedEventContext

Instantiate a new ExceptionQueuedEventContext that indicates the argument Throwable just occurred, relevant to the argument component, during the lifecycle phase phaseId.

ExcludeClassInterceptors - Annotation Type in javax.interceptor

Used to exclude class-level interceptors for a lifecycle callback, business, or timeout method of a target class, or a constructor of a target class.

ExcludeDefaultInterceptors - Annotation Type in javax.interceptor

Used to exclude default interceptors for a target class or a lifecycle callback, business, or timeout method of a target class, or a constructor of a target class.

ExcludeDefaultListeners - Annotation Type in javax.persistence

Specifies that the invocation of default listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.

ExcludeSuperclassListeners - Annotation Type in javax.persistence

Specifies that the invocation of superclass listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.

excludeUnlistedClasses() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns whether classes in the root of the persistence unit that have not been explicitly listed are to be included in the set of managed classes.

ExecutableDescriptor - Interface in javax.validation.metadata

Provides the common functionality of MethodDescriptor and ConstructorDescriptor.

ExecutableType - Enum in javax.validation.executable

Defines the types of executables targeted by an operation.

ExecutableValidator - Interface in javax.validation.executable

Validates parameters and return values of methods and constructors.

EXECUTE - Static variable in class javax.enterprise.deploy.shared.ActionType

The DeploymentManager action command is executing.

execute() - Method in interface javax.enterprise.deploy.spi.status.ClientConfiguration

This method performs an exec and starts the application client running in another process.

execute(FacesContext) - Method in class javax.faces.lifecycle.Lifecycle

Execute all of the phases of the request processing lifecycle, up to but not including the Render Response phase, as described in the JavaServer Faces Specification, in the specified order.

execute(FacesContext) - Method in class javax.faces.lifecycle.LifecycleWrapper

execute() - Method in interface javax.persistence.StoredProcedureQuery

Return true if the first result corresponds to a result set, and false if it is an update count or if there are no results other than through INOUT and OUT parameters, if any.

execute(InteractionSpec, Record, Record) - Method in interface javax.resource.cci.Interaction

Executes an interaction represented by the InteractionSpec.

execute(InteractionSpec, Record) - Method in interface javax.resource.cci.Interaction

Executes an interaction represented by the InteractionSpec.

executeQuery(Query) - Method in interface javax.xml.registry.DeclarativeQueryManager

Executes a query as specified by query parameter.

executeUpdate() - Method in interface javax.persistence.Query

Execute an update or delete statement.

executeUpdate() - Method in interface javax.persistence.StoredProcedureQuery

Return the update count of -1 if there is no pending result or if the first result is not an update count.

ExecutionContext - Class in javax.resource.spi.work

This class models an execution context (transaction, security, etc) with which the Work instance must be executed.

ExecutionContext() - Constructor for class javax.resource.spi.work.ExecutionContext

exists() - Method in class javax.mail.Folder

Tests if this folder physically exists on the Store.

exists(Subquery<?>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate testing the existence of a subquery result.

exitLambdaScope() - Method in class javax.el.ELContext

Exits the Lambda expression evaluation.

EXPIRES - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

expires(Date) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the response expiration date.

Expression - Class in javax.el

Base class for the expression subclasses ValueExpression and MethodExpression, implementing characteristics common to both.

Expression() - Constructor for class javax.el.Expression

expression(MethodExpression) - Method in class javax.faces.flow.builder.MethodCallBuilder

Set the method expression of this method call node.

expression(String) - Method in class javax.faces.flow.builder.MethodCallBuilder

Set the method expression of this method call node.

expression(String, Class[]) - Method in class javax.faces.flow.builder.MethodCallBuilder

Set the method expression of this method call node.

Expression<T> - Interface in javax.persistence.criteria

Type for query expressions.

Expression - Class in javax.servlet.jsp.el

Deprecated.
As of JSP 2.1, replaced by ValueExpression

Expression() - Constructor for class javax.servlet.jsp.el.Expression

Deprecated.

ExpressionEvaluator - Class in javax.servlet.jsp.el

Deprecated.
As of JSP 2.1, replaced by ExpressionFactory

ExpressionEvaluator() - Constructor for class javax.servlet.jsp.el.ExpressionEvaluator

Deprecated.

ExpressionFactory - Class in javax.el

Provides an implementation for creating and evaluating EL expressions.

ExpressionFactory() - Constructor for class javax.el.ExpressionFactory

expunge() - Method in class javax.mail.Folder

Expunge (permanently remove) messages marked DELETED.

expunged - Variable in class javax.mail.Message

True if this message has been expunged.

ExtensibleObject - Interface in javax.xml.registry.infomodel

An ExtensibleObject is one that allows itself to be extended by utilizing dynamically added Slots that add arbitrary attributes to the object on a per instance basis.

Extension - Interface in javax.enterprise.inject.spi

Service interface implemented by extensions.

Extension - Interface in javax.websocket

A simple representation of a websocket extension as a name and map of extension parameters.

Extension.Parameter - Interface in javax.websocket

This member interface defines a single websocket extension parameter.

extensions(List<Extension>) - Method in class javax.websocket.ClientEndpointConfig.Builder

Set the extensions for the configuration this builder will build.

extensions(List<Extension>) - Method in class javax.websocket.server.ServerEndpointConfig.Builder

Sets the extensions to use in the configuration.

EXTERNAL_CONTEXT_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the ExternalContextFactory class name.

EXTERNAL_IDENTIFIER - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.ExternalIdentifier interface.

EXTERNAL_LINK - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.ExternalLink interface.

ExternalContext - Class in javax.faces.context

This class allows the Faces API to be unaware of the nature of its containing application environment.

ExternalContext() - Constructor for class javax.faces.context.ExternalContext

ExternalContextFactory - Class in javax.faces.context

ExternalContextFactory is a factory object that creates (if needed) and returns new ExternalContext instances, initialized for the processing of the specified request and response objects.

ExternalContextFactory() - Constructor for class javax.faces.context.ExternalContextFactory

ExternalContextWrapper - Class in javax.faces.context

Provides a simple implementation of ExternalContext that can be subclassed by developers wishing to provide specialized behavior to an existing ExternalContext instance.

ExternalContextWrapper() - Constructor for class javax.faces.context.ExternalContextWrapper

ExternalIdentifier - Interface in javax.xml.registry.infomodel

ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization.

ExternalLink - Interface in javax.xml.registry.infomodel

ExternalLink instances model a named URI to content that may reside outside the registry.

extractAllHeaderElements() - Method in interface javax.xml.soap.SOAPHeader

Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.

extractContentAsDocument() - Method in interface javax.xml.soap.SOAPBody

Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.

extractHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader

Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.

EXTRINSIC_OBJECT - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.ExternalLink interface.

ExtrinsicObject - Interface in javax.xml.registry.infomodel

ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).

F

Facelet - Class in javax.faces.view.facelets

The parent or root object in a FaceletHandler composition.

Facelet() - Constructor for class javax.faces.view.facelets.Facelet

FACELET_CACHE_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the FaceletCacheFactory class name.

FACELET_CONTEXT_KEY - Static variable in class javax.faces.view.facelets.FaceletContext

FaceletCache<V> - Class in javax.faces.view.facelets

This API defines the facility by which the Facelets ViewDeclarationLanguage creates and caches instances of Facelets.

FaceletCache() - Constructor for class javax.faces.view.facelets.FaceletCache

FaceletCache.MemberFactory<V> - Interface in javax.faces.view.facelets

Factory interface for creating Facelet or View Metadata Facelet instances.

FaceletCacheFactory - Class in javax.faces.view.facelets

Allows customization of the implementation of FaceletCache.

FaceletCacheFactory() - Constructor for class javax.faces.view.facelets.FaceletCacheFactory

FaceletContext - Class in javax.faces.view.facelets

Context representative of a single request from a Facelet.

FaceletContext() - Constructor for class javax.faces.view.facelets.FaceletContext

FaceletException - Exception in javax.faces.view.facelets

An Exception from the Facelet implementation

FaceletException() - Constructor for exception javax.faces.view.facelets.FaceletException

Create an empty FaceletException.

FaceletException(String) - Constructor for exception javax.faces.view.facelets.FaceletException

Create a FaceletException with argument message as the message.

FaceletException(Throwable) - Constructor for exception javax.faces.view.facelets.FaceletException

Wrap argument cause within this FaceletException instance.

FaceletException(String, Throwable) - Constructor for exception javax.faces.view.facelets.FaceletException

Wrap argument cause in a FaceletException instance, with a message given by the argument message.

FaceletHandler - Interface in javax.faces.view.facelets

This is the root class for markup elements in Facelets VDL.

FACELETS_BUFFER_SIZE_PARAM_NAME - Static variable in class javax.faces.application.ViewHandler

The buffer size to set on the response when the ResponseWriter is generated.

FACELETS_DECORATORS_PARAM_NAME - Static variable in class javax.faces.application.ViewHandler

A semicolon (;) delimitted list of class names of type javax.faces.view.facelets.TagDecorator, with a no-argument constructor.

FACELETS_LIBRARIES_PARAM_NAME - Static variable in class javax.faces.application.ViewHandler

If this param is set, the runtime must interpret it as a semicolon (;) separated list of paths, starting with "/" (without the quotes).

FACELETS_REFRESH_PERIOD_PARAM_NAME - Static variable in class javax.faces.application.ViewHandler

When a page is requested, what interval in seconds should the compiler check for changes.

FACELETS_RESOURCE_RESOLVER_PARAM_NAME - Static variable in class javax.faces.view.facelets.ResourceResolver

Deprecated.

FACELETS_SKIP_COMMENTS_PARAM_NAME - Static variable in class javax.faces.application.ViewHandler

If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, the runtime must ensure that any XML comments in the Facelets source page are not delivered to the client.

FACELETS_SUFFIX_PARAM_NAME - Static variable in class javax.faces.application.ViewHandler

Allow the web application to define an alternate suffix for Facelet based XHTML pages containing JSF content.

FACELETS_VIEW_DECLARATION_LANGUAGE_ID - Static variable in class javax.faces.view.ViewDeclarationLanguage

Identifier for the Facelets view declaration language.

FACELETS_VIEW_MAPPINGS_PARAM_NAME - Static variable in class javax.faces.application.ViewHandler

Allow the web application to define a semicolon (;) separated list of strings that is used to forcibly declare that certain pages in the application must be interpreted as using Facelets, regardless of their extension.

FaceletsAttachedObjectHandler - Class in javax.faces.view.facelets

Root class for all tag handlers that represent attached objetcts in a Facelets page.

FaceletsAttachedObjectHandler(TagConfig) - Constructor for class javax.faces.view.facelets.FaceletsAttachedObjectHandler

Call through to super

FaceletsResourceResolver - Annotation Type in javax.faces.view.facelets

The presence of this annotation on a class automatically registers the class with the runtime as a ResourceResolver.

FACES_CONTEXT_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the FacesContextFactory class name.

FACES_MESSAGES - Static variable in class javax.faces.application.FacesMessage

ResourceBundle identifier for messages whose message identifiers are defined in the JavaServer Faces specification.

FacesBehavior - Annotation Type in javax.faces.component.behavior

The presence of this annotation on a class automatically registers the class with the runtime as a Behavior.

FacesBehaviorRenderer - Annotation Type in javax.faces.render

The presence of this annotation on a class automatically registers the class with the runtime as a ClientBehaviorRenderer.

FacesComponent - Annotation Type in javax.faces.component

The presence of this annotation on a class that extends UIComponent must cause the runtime to register this class as a component suitable for inclusion in a view.

FacesContext - Class in javax.faces.context

FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.

FacesContext() - Constructor for class javax.faces.context.FacesContext

FacesContextFactory - Class in javax.faces.context

FacesContextFactory is a factory object that creates (if needed) and returns new FacesContext instances, initialized for the processing of the specified request and response objects.

FacesContextFactory() - Constructor for class javax.faces.context.FacesContextFactory

FacesContextWrapper - Class in javax.faces.context

Provides a simple implementation of FacesContext that can be subclassed by developers wishing to provide specialized behavior to an existing FacesContext instance.

FacesContextWrapper() - Constructor for class javax.faces.context.FacesContextWrapper

FacesConverter - Annotation Type in javax.faces.convert

The presence of this annotation on a class automatically registers the class with the runtime as a Converter.

FacesEvent - Class in javax.faces.event

FacesEvent is the base class for user interface and application events that can be fired by UIComponents.

FacesEvent(UIComponent) - Constructor for class javax.faces.event.FacesEvent

Construct a new event object from the specified source component.

FacesException - Exception in javax.faces

This class encapsulates general JavaServer Faces exceptions.

FacesException() - Constructor for exception javax.faces.FacesException

Construct a new exception with no detail message or root cause.

FacesException(String) - Constructor for exception javax.faces.FacesException

Construct a new exception with the specified detail message and no root cause.

FacesException(Throwable) - Constructor for exception javax.faces.FacesException

Construct a new exception with the specified root cause.

FacesException(String, Throwable) - Constructor for exception javax.faces.FacesException

Construct a new exception with the specified detail message and root cause.

FacesListener - Interface in javax.faces.event

A generic base interface for event listeners for various types of FacesEvents.

FacesMessage - Class in javax.faces.application

FacesMessage represents a single validation (or other) message, which is typically associated with a particular component in the view.

FacesMessage() - Constructor for class javax.faces.application.FacesMessage

Construct a new FacesMessage with no initial values.

FacesMessage(String) - Constructor for class javax.faces.application.FacesMessage

Construct a new FacesMessage with just a summary.

FacesMessage(String, String) - Constructor for class javax.faces.application.FacesMessage

Construct a new FacesMessage with the specified initial values.

FacesMessage(FacesMessage.Severity, String, String) - Constructor for class javax.faces.application.FacesMessage

Construct a new FacesMessage with the specified initial values.

FacesMessage.Severity - Class in javax.faces.application

Class used to represent message severity levels in a typesafe enumeration.

FacesRenderer - Annotation Type in javax.faces.render

The presence of this annotation on a class automatically registers the class with the runtime as a Renderer.

FacesServlet - Class in javax.faces.webapp

FacesServlet is a servlet that manages the request processing lifecycle for web applications that are utilizing JavaServer Faces to construct the user interface.

FacesServlet() - Constructor for class javax.faces.webapp.FacesServlet

FacesValidator - Annotation Type in javax.faces.validator

The presence of this annotation on a class automatically registers the class with the runtime as a Validator.

FacesWrapper<T> - Interface in javax.faces

Any wrapper class in JSF that must provide access to the object it wraps must implement this interface.

FacetHandler - Interface in javax.faces.view.facelets

An interface that allows other code to identify FaceletHandlers that correspond to component facets.

FACETS_KEY - Static variable in class javax.faces.component.UIComponent

The value of this constant is used as the key in the composite component BeanDescriptor for the Map<PropertyDescriptor> that contains meta-information for the declared facets for this composite component.

FacetTag - Class in javax.faces.webapp

FacetTag is the JSP mechanism for denoting a UIComponent is to be added as a facet to the component associated with its parent.

FacetTag() - Constructor for class javax.faces.webapp.FacetTag

FactoryFinder - Class in javax.faces

FactoryFinder implements the standard discovery algorithm for all factory objects specified in the JavaServer Faces APIs.

FAILED - Static variable in class javax.enterprise.deploy.shared.StateType

The action operation has failed.

failed(Throwable) - Method in interface javax.ws.rs.client.InvocationCallback

Called when the invocation has failed for any reason.

FAILURE - Static variable in class javax.security.auth.message.AuthStatus

Indicates that the message processing by the authentication module was NOT successful, and that the module replaced the application message with an error message.

FALSE - Static variable in interface javax.json.JsonValue

JSON false value

familyOf(int) - Static method in enum javax.ws.rs.core.Response.Status.Family

Get the response status family for the status code.

FATAL_ERROR - Static variable in interface javax.xml.bind.ValidationEvent

Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation

FaultAction - Annotation Type in javax.xml.ws

The FaultAction annotation is used inside an Action annotation to allow an explicit association of a WS-Addressing Action message addressing property with the fault messages of the WSDL operation mapped from the exception class.

Feature - Interface in javax.ws.rs.core

A feature extension contract.

FeatureContext - Interface in javax.ws.rs.core

A configurable context passed to Feature and DynamicFeature instances by JAX-RS runtime during the phase of their configuration.

FederatedConnection - Interface in javax.xml.registry

Represents a single logical connection to a federation or group of registry providers.

fetch(Message[], FetchProfile) - Method in class javax.mail.Folder

Prefetch the items specified in the FetchProfile for the given Messages.

Fetch<Z,X> - Interface in javax.persistence.criteria

Represents a join-fetched association or attribute.

fetch(SingularAttribute<? super X, Y>) - Method in interface javax.persistence.criteria.FetchParent

Create a fetch join to the specified single-valued attribute using an inner join.

fetch(SingularAttribute<? super X, Y>, JoinType) - Method in interface javax.persistence.criteria.FetchParent

Create a fetch join to the specified single-valued attribute using the given join type.

fetch(PluralAttribute<? super X, ?, Y>) - Method in interface javax.persistence.criteria.FetchParent

Create a fetch join to the specified collection-valued attribute using an inner join.

fetch(PluralAttribute<? super X, ?, Y>, JoinType) - Method in interface javax.persistence.criteria.FetchParent

Create a fetch join to the specified collection-valued attribute using the given join type.

fetch(String) - Method in interface javax.persistence.criteria.FetchParent

Create a fetch join to the specified attribute using an inner join.

fetch(String, JoinType) - Method in interface javax.persistence.criteria.FetchParent

Create a fetch join to the specified attribute using the given join type.

FetchParent<Z,X> - Interface in javax.persistence.criteria

Represents an element of the from clause which may function as the parent of Fetches.

FetchProfile - Class in javax.mail

Clients use a FetchProfile to list the Message attributes that it wishes to prefetch from the server for a range of messages.

FetchProfile() - Constructor for class javax.mail.FetchProfile

Create an empty FetchProfile.

FetchProfile.Item - Class in javax.mail

This inner class is the base class of all items that can be requested in a FetchProfile.

FetchProfile.Item(String) - Constructor for class javax.mail.FetchProfile.Item

Constructor for an item.

FetchType - Enum in javax.persistence

Defines strategies for fetching data from the database.

FieldResult - Annotation Type in javax.persistence

Used in conjunction with the EntityResult annotation to map columns specified in the SELECT list of a SQL query to the properties or fields of an entity class.

Filter - Interface in javax.servlet

A filter is an object that performs filtering tasks on either the request to a resource (a servlet or static content), or on the response from a resource, or both.

filter(ClientRequestContext) - Method in interface javax.ws.rs.client.ClientRequestFilter

Filter method called before a request has been dispatched to a client transport layer.

filter(ClientRequestContext, ClientResponseContext) - Method in interface javax.ws.rs.client.ClientResponseFilter

Filter method called after a response has been provided for a request (either by a request filter or when the HTTP invocation returns.

filter(ContainerRequestContext) - Method in interface javax.ws.rs.container.ContainerRequestFilter

Filter method called before a request has been dispatched to a resource.

filter(ContainerRequestContext, ContainerResponseContext) - Method in interface javax.ws.rs.container.ContainerResponseFilter

Filter method called after a response has been provided for a request (either by a request filter or by a matched resource method.

FilterChain - Interface in javax.servlet

A FilterChain is an object provided by the servlet container to the developer giving a view into the invocation chain of a filtered request for a resource.

FilterConfig - Interface in javax.servlet

A filter configuration object used by a servlet container to pass information to a filter during initialization.

FilterRegistration - Interface in javax.servlet

Interface through which a Filter may be further configured.

FilterRegistration.Dynamic - Interface in javax.servlet

Interface through which a Filter registered via one of the addFilter methods on ServletContext may be further configured.

finalize() - Method in class javax.mail.Folder

finalize() - Method in class javax.mail.Service

Stop the event dispatcher thread so the queue can be garbage collected.

finalize() - Method in class javax.mail.util.SharedFileInputStream

Force this stream to close.

finalizer(MethodExpression) - Method in class javax.faces.flow.builder.FlowBuilder

A MethodExpression that will be invoked when the flow is exited.

finalizer(String) - Method in class javax.faces.flow.builder.FlowBuilder

A MethodExpression that will be invoked when the flow is exited.

find(Class<T>, Object) - Method in interface javax.persistence.EntityManager

Find by primary key.

find(Class<T>, Object, Map<String, Object>) - Method in interface javax.persistence.EntityManager

Find by primary key, using the specified properties.

find(Class<T>, Object, LockModeType) - Method in interface javax.persistence.EntityManager

Find by primary key and lock.

find(Class<T>, Object, LockModeType, Map<String, Object>) - Method in interface javax.persistence.EntityManager

Find by primary key and lock, using the specified properties.

find(PageContext, String) - Static method in class javax.servlet.jsp.jstl.core.Config

Finds the value associated with a specific configuration setting identified by its context initialization parameter name.

findAncestorWithClass(JspTag, Class<?>) - Static method in class javax.servlet.jsp.tagext.SimpleTagSupport

Find the instance of a given class type that is closest to a given instance.

findAncestorWithClass(Tag, Class) - Static method in class javax.servlet.jsp.tagext.TagSupport

Find the instance of a given class type that is closest to a given instance.

findAssociations(Collection, String, String, Collection) - Method in interface javax.xml.registry.BusinessQueryManager

Finds all Association objects that match all of the criteria specified by the parameters of this call.

findAttribute(String) - Method in class javax.servlet.jsp.JspContext

Searches for the named attribute in page, request, session (if valid), and application scope(s) in order and returns the value associated or null.

findCallerAssociations(Collection, Boolean, Boolean, Collection) - Method in interface javax.xml.registry.BusinessQueryManager

Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call.

findClassificationSchemeByName(Collection, String) - Method in interface javax.xml.registry.BusinessQueryManager

Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.

findClassificationSchemes(Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager

Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call.

findComponent(String) - Method in class javax.faces.component.UIComponent

Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.

findComponent(String) - Method in class javax.faces.component.UIComponentBase

findComponent(FacesContext) - Method in class javax.faces.webapp.UIComponentClassicTagBase

Find and return the UIComponent, from the component tree, that corresponds to this tag handler instance.

findConceptByPath(String) - Method in interface javax.xml.registry.BusinessQueryManager

Finds a Concept based on the path specified.

findConcepts(Collection, Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager

Finds all Concept objects that match all of the criteria specified by the parameters of this call.

findConstraints() - Method in interface javax.validation.metadata.ElementDescriptor

Finds constraints and potentially restricts them to certain criteria.

findConstraints() - Method in interface javax.validation.metadata.ExecutableDescriptor

Returns a finder that will always return an empty Set.

FinderException - Exception in javax.ejb

The FinderException exception must be included in the throws clause of every finder method of an entity bean's home or local home interface.

FinderException() - Constructor for exception javax.ejb.FinderException

Constructs an FinderException with no detail message.

FinderException(String) - Constructor for exception javax.ejb.FinderException

Constructs an FinderException with the specified detail message.

FindException - Exception in javax.xml.registry

A RegistryException that occurs during a find action.

FindException() - Constructor for exception javax.xml.registry.FindException

Constructs a JAXRException object with no reason or embedded Throwable.

FindException(String) - Constructor for exception javax.xml.registry.FindException

Constructs a JAXRException object with the given String as the reason for the exception being thrown.

FindException(String, Throwable) - Constructor for exception javax.xml.registry.FindException

Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

FindException(Throwable) - Constructor for exception javax.xml.registry.FindException

Constructs a JAXRException object initialized with the given Throwable object.

findOrganizations(Collection, Collection, Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager

Finds all Organization objects that match all of the criteria specified by the parameters of this call.

FindQualifier - Interface in javax.xml.registry

FindQualifier provides various constants that identify options that effect find method behavior.

findRegistryPackages(Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager

Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call.

findServiceBindings(Key, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager

Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call.

findServices(Key, Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager

Finds all Service objects that match all of the criteria specified by the parameters of this call.

finish() - Method in class javax.faces.view.facelets.MetaRuleset

Take actions to apply the rule.

fire(T) - Method in interface javax.enterprise.event.Event

Fires an event with the specified qualifiers and notifies observers.

fireEvent(Object, Annotation...) - Method in interface javax.enterprise.inject.spi.BeanManager

Fire an event and notify observers.

fireXpathEvent(XpathEvent) - Method in interface javax.enterprise.deploy.model.XpathListener

FLAGGED - Static variable in class javax.mail.Flags.Flag

This message is flagged.

FLAGS - Static variable in class javax.mail.FetchProfile.Item

This is the Flags item.

Flags - Class in javax.mail

The Flags class represents the set of flags on a Message.

Flags() - Constructor for class javax.mail.Flags

Construct an empty Flags object.

Flags(Flags) - Constructor for class javax.mail.Flags

Construct a Flags object initialized with the given flags.

Flags(Flags.Flag) - Constructor for class javax.mail.Flags

Construct a Flags object initialized with the given system flag.

Flags(String) - Constructor for class javax.mail.Flags

Construct a Flags object initialized with the given user flag.

flags - Variable in class javax.mail.internet.MimeMessage

The Flags for this message.

Flags.Flag - Class in javax.mail

This inner class represents an individual system flag.

FLAGS_CHANGED - Static variable in class javax.mail.event.MessageChangedEvent

The message's flags changed.

FlagTerm - Class in javax.mail.search

This class implements comparisons for Message Flags.

FlagTerm(Flags, boolean) - Constructor for class javax.mail.search.FlagTerm

Constructor.

Flash - Class in javax.faces.context

The Flash concept is taken from Ruby on Rails and provides a way to pass temporary objects between the user views generated by the faces lifecycle.

Flash() - Constructor for class javax.faces.context.Flash

FLASH_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the FlashFactory class name.

FlashFactory - Class in javax.faces.context

FlashFactory is a factory object that creates (if needed) and returns Flash instances.

FlashFactory() - Constructor for class javax.faces.context.FlashFactory

FlashWrapper - Class in javax.faces.context

Provides a simple implementation of Flash that can be subclassed by developers wishing to provide specialized behavior to an existing Flash instance.

FlashWrapper() - Constructor for class javax.faces.context.FlashWrapper

FLOAT_ID - Static variable in class javax.faces.convert.FloatConverter

The message identifier of the FacesMessage to be created if the conversion to Float fails.

FloatConverter - Class in javax.faces.convert

Converter implementation for java.lang.Float (and float primitive) values.

FloatConverter() - Constructor for class javax.faces.convert.FloatConverter

FloatHolder - Class in javax.xml.rpc.holders

FloatHolder() - Constructor for class javax.xml.rpc.holders.FloatHolder

FloatHolder(float) - Constructor for class javax.xml.rpc.holders.FloatHolder

FloatWrapperHolder - Class in javax.xml.rpc.holders

FloatWrapperHolder() - Constructor for class javax.xml.rpc.holders.FloatWrapperHolder

FloatWrapperHolder(Float) - Constructor for class javax.xml.rpc.holders.FloatWrapperHolder

Flow - Class in javax.faces.flow

Flow is the runtime representation of a Faces Flow.

Flow() - Constructor for class javax.faces.flow.Flow

FLOW_HANDLER_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the FlowHandlerFactory class name.

FLOW_ID_REQUEST_PARAM_NAME - Static variable in class javax.faces.flow.FlowHandler

Components that are rendered by Renderers of component-family javax.faces.OutcomeTarget must use this constant as the parameter name for a parameter representing the flow id of the flow that this component will cause to be entered.

FlowBuilder - Class in javax.faces.flow.builder

A Java language API for building Flows.

FlowBuilder() - Constructor for class javax.faces.flow.builder.FlowBuilder

FlowBuilderParameter - Annotation Type in javax.faces.flow.builder

The presence of this annotation on a CDI producer method for the FlowDefinition annotation causes the FlowBuilder to be passed to that method.

FlowCallBuilder - Class in javax.faces.flow.builder

Create a flow call node in the current Flow.

FlowCallBuilder() - Constructor for class javax.faces.flow.builder.FlowCallBuilder

flowCallNode(String) - Method in class javax.faces.flow.builder.FlowBuilder

Define a flow call node.

FlowCallNode - Class in javax.faces.flow

FlowCallNode() - Constructor for class javax.faces.flow.FlowCallNode

FlowDefinition - Annotation Type in javax.faces.flow.builder

The presence of this annotation on a CDI producer method indicates that the method will produce a flow.

FlowHandler - Class in javax.faces.flow

FlowHandler is the main entry point that enables the runtime to interact with the faces flows feature.

FlowHandler() - Constructor for class javax.faces.flow.FlowHandler

FlowHandlerFactory - Class in javax.faces.flow

FlowHandlerFactory is used by the Application to create the singleton instance of FlowHandler.

FlowHandlerFactory() - Constructor for class javax.faces.flow.FlowHandlerFactory

FlowHandlerFactoryWrapper - Class in javax.faces.flow

FlowHandlerFactoryWrapper provides a simple implementation of FlowHandlerFactory that can be subclassed by developers wishing to provide specialized behavior to an existing FlowHandlerFactory instance.

FlowHandlerFactoryWrapper() - Constructor for class javax.faces.flow.FlowHandlerFactoryWrapper

FlowNode - Class in javax.faces.flow

FlowNode is the base class for all nodes in a faces flow graph.

FlowNode() - Constructor for class javax.faces.flow.FlowNode

flowReference(String, String) - Method in class javax.faces.flow.builder.FlowCallBuilder

Define the flow reference of the called flow.

FlowScoped - Annotation Type in javax.faces.flow

FlowScoped is a CDI scope that causes the runtime to consider classes with this annotation to be in the scope of the specified Flow.

flush() - Method in class javax.faces.context.ResponseWriter

Flush any ouput buffered by the output method to the underlying Writer or OutputStream.

flush() - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.flush() on the wrapped ResponseWriter object.

flush() - Method in interface javax.json.stream.JsonGenerator

Flushes the underlying output source.

flush() - Method in interface javax.persistence.EntityManager

Synchronize the persistence context to the underlying database.

flush() - Method in class javax.servlet.jsp.JspWriter

Flush the stream.

flush() - Method in class javax.servlet.jsp.tagext.BodyContent

Redefined flush() so it is not legal.

flushBatch() - Method in interface javax.websocket.RemoteEndpoint

This method is only used when batching is allowed for this RemoteEndpint.

flushBuffer() - Method in interface javax.servlet.ServletResponse

Forces any content in the buffer to be written to the client.

flushBuffer() - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to call flushBuffer() on the wrapped response object.

FlushModeType - Enum in javax.persistence

Flush mode setting.

FMT_FALLBACK_LOCALE - Static variable in class javax.servlet.jsp.jstl.core.Config

Name of configuration setting for fallback locale

FMT_LOCALE - Static variable in class javax.servlet.jsp.jstl.core.Config

Name of configuration setting for application- (as opposed to browser-) based preferred locale

FMT_LOCALIZATION_CONTEXT - Static variable in class javax.servlet.jsp.jstl.core.Config

Name of configuration setting for i18n localization context

FMT_TIME_ZONE - Static variable in class javax.servlet.jsp.jstl.core.Config

Name of localization setting for time zone

fold(int, String) - Static method in class javax.mail.internet.MimeUtility

Fold a string at linear whitespace so that each line is no longer than 76 characters, if possible.

folder - Variable in class javax.mail.event.FolderEvent

The folder the event occurred on.

Folder - Class in javax.mail

Folder is an abstract class that represents a folder for mail messages.

Folder(Store) - Constructor for class javax.mail.Folder

Constructor that takes a Store object.

folder - Variable in class javax.mail.Message

The containing folder, if this message is obtained from a folder

FolderAdapter - Class in javax.mail.event

The adapter which receives Folder events.

FolderAdapter() - Constructor for class javax.mail.event.FolderAdapter

FolderClosedException - Exception in javax.mail

This exception is thrown when a method is invoked on a Messaging object and the Folder that owns that object has died due to some reason.

FolderClosedException(Folder) - Constructor for exception javax.mail.FolderClosedException

Constructs a FolderClosedException.

FolderClosedException(Folder, String) - Constructor for exception javax.mail.FolderClosedException

Constructs a FolderClosedException with the specified detail message.

FolderClosedException(Folder, String, Exception) - Constructor for exception javax.mail.FolderClosedException

Constructs a FolderClosedException with the specified detail message and embedded exception.

folderCreated(FolderEvent) - Method in class javax.mail.event.FolderAdapter

folderCreated(FolderEvent) - Method in interface javax.mail.event.FolderListener

Invoked when a Folder is created.

folderDeleted(FolderEvent) - Method in class javax.mail.event.FolderAdapter

folderDeleted(FolderEvent) - Method in interface javax.mail.event.FolderListener

Invoked when a folder is deleted.

FolderEvent - Class in javax.mail.event

This class models Folder existence events.

FolderEvent(Object, Folder, int) - Constructor for class javax.mail.event.FolderEvent

Constructor.

FolderEvent(Object, Folder, Folder, int) - Constructor for class javax.mail.event.FolderEvent

Constructor.

FolderListener - Interface in javax.mail.event

This is the Listener interface for Folder events.

FolderNotFoundException - Exception in javax.mail

This exception is thrown by Folder methods, when those methods are invoked on a non existent folder.

FolderNotFoundException() - Constructor for exception javax.mail.FolderNotFoundException

Constructs a FolderNotFoundException with no detail message.

FolderNotFoundException(Folder) - Constructor for exception javax.mail.FolderNotFoundException

Constructs a FolderNotFoundException.

FolderNotFoundException(Folder, String) - Constructor for exception javax.mail.FolderNotFoundException

Constructs a FolderNotFoundException with the specified detail message.

FolderNotFoundException(Folder, String, Exception) - Constructor for exception javax.mail.FolderNotFoundException

Constructs a FolderNotFoundException with the specified detail message and embedded exception.

FolderNotFoundException(String, Folder) - Constructor for exception javax.mail.FolderNotFoundException

Constructs a FolderNotFoundException with the specified detail message and the specified folder.

folderRenamed(FolderEvent) - Method in class javax.mail.event.FolderAdapter

folderRenamed(FolderEvent) - Method in interface javax.mail.event.FolderListener

Invoked when a folder is renamed.

ForbiddenException - Exception in javax.ws.rs

A runtime exception indicating that an access to a resource requested by a client has been forbidden by the server.

ForbiddenException() - Constructor for exception javax.ws.rs.ForbiddenException

Construct a new "forbidden" exception.

ForbiddenException(String) - Constructor for exception javax.ws.rs.ForbiddenException

Construct a new "forbidden" exception.

ForbiddenException(Response) - Constructor for exception javax.ws.rs.ForbiddenException

Construct a new "forbidden" exception.

ForbiddenException(String, Response) - Constructor for exception javax.ws.rs.ForbiddenException

Construct a new "forbidden" exception.

ForbiddenException(Throwable) - Constructor for exception javax.ws.rs.ForbiddenException

Construct a new "forbidden" exception.

ForbiddenException(String, Throwable) - Constructor for exception javax.ws.rs.ForbiddenException

Construct a new "forbidden" exception.

ForbiddenException(Response, Throwable) - Constructor for exception javax.ws.rs.ForbiddenException

Construct a new "forbidden" exception.

ForbiddenException(String, Response, Throwable) - Constructor for exception javax.ws.rs.ForbiddenException

Construct a new "forbidden" exception.

ForeignKey - Annotation Type in javax.persistence

Used to specify the handling of foreign key constraints when schema generation is in effect.

forExecutables() - Method in interface javax.validation.Validator

Returns the contract for validating parameters and return values of methods and constructors.

forget(Xid) - Method in interface javax.resource.spi.XATerminator

Tells the resource manager to forget about a heuristically completed transaction branch.

forget(Xid) - Method in interface javax.transaction.xa.XAResource

Tells the resource manager to forget about a heuristically completed transaction branch.

form(Form) - Static method in class javax.ws.rs.client.Entity

Create an "application/x-www-form-urlencoded" form entity.

form(MultivaluedMap<String, String>) - Static method in class javax.ws.rs.client.Entity

Create an "application/x-www-form-urlencoded" form entity.

Form - Class in javax.ws.rs.core

Represents the the HTML form data request entity encoded using the "application/x-www-form-urlencoded" content type.

Form() - Constructor for class javax.ws.rs.core.Form

Create a new form data instance.

Form(String, String) - Constructor for class javax.ws.rs.core.Form

Create a new form data instance with a single parameter entry.

Form(MultivaluedMap<String, String>) - Constructor for class javax.ws.rs.core.Form

Create a new form data instance and register a custom underlying parameter store.

FORM_AUTH - Static variable in class javax.faces.context.ExternalContext

String identifier for FORM authentication.

FORM_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest

String identifier for Form authentication.

FORM_AUTH - Static variable in interface javax.ws.rs.core.SecurityContext

String identifier for Form authentication.

format(Date, StringBuffer, FieldPosition) - Method in class javax.mail.internet.MailDateFormat

Formats the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.

FormParam - Annotation Type in javax.ws.rs

Binds the value(s) of a form parameter contained within a request entity body to a resource method parameter.

forward(String) - Method in class javax.servlet.jsp.PageContext

This method is used to re-direct, or "forward" the current ServletRequest and ServletResponse to another active component in the application.

forward(ServletRequest, ServletResponse) - Method in interface javax.servlet.RequestDispatcher

Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server.

FORWARD_CONTEXT_PATH - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the original context path is made available to the target of a forward

FORWARD_PATH_INFO - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the original path info is made available to the target of a forward

FORWARD_QUERY_STRING - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the original query string is made available to the target of a forward

FORWARD_REQUEST_URI - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the original request URI is made available to the target of a forward

FORWARD_SERVLET_PATH - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the original servlet path is made available to the target of a forward

fragment(String) - Method in class javax.ws.rs.core.UriBuilder

Set the URI fragment.

from(Class<X>) - Method in interface javax.persistence.criteria.AbstractQuery

Create and add a query root corresponding to the given entity, forming a cartesian product with any existing roots.

from(EntityType<X>) - Method in interface javax.persistence.criteria.AbstractQuery

Create and add a query root corresponding to the given entity, forming a cartesian product with any existing roots.

from(Class<T>) - Method in interface javax.persistence.criteria.CriteriaDelete

Create and add a query root corresponding to the entity that is the target of the delete.

from(EntityType<T>) - Method in interface javax.persistence.criteria.CriteriaDelete

Create and add a query root corresponding to the entity that is the target of the delete.

from(Class<T>) - Method in interface javax.persistence.criteria.CriteriaUpdate

Create and add a query root corresponding to the entity that is the target of the update.

from(EntityType<T>) - Method in interface javax.persistence.criteria.CriteriaUpdate

Create and add a query root corresponding to the entity that is the target of the update.

From<Z,X> - Interface in javax.persistence.criteria

Represents a bound type, usually an entity that appears in the from clause, but may also be an embeddable belonging to an entity in the from clause.

fromAction(String) - Method in class javax.faces.flow.builder.NavigationCaseBuilder

Set the from-action of the current navigation case.

fromLink(Link) - Static method in class javax.ws.rs.core.Link

Create a new builder instance initialized from another link.

fromLink(Link) - Static method in class javax.ws.rs.core.UriBuilder

Create a new instance initialized from a Link.

fromMethod(Class<?>, String) - Static method in class javax.ws.rs.core.Link

Convenience method to build a link from a resource.

fromMethod(Class<?>, String) - Static method in class javax.ws.rs.core.UriBuilder

Create a new instance representing a relative URI initialized from a Path-annotated method.

fromOutcome(String) - Method in class javax.faces.flow.builder.NavigationCaseBuilder

Set the from-outcome of the current navigation case.

fromOutcome(String) - Method in class javax.faces.flow.builder.ReturnBuilder

Set the outcome of the current return node.

fromOutcome(ValueExpression) - Method in class javax.faces.flow.builder.ReturnBuilder

Set the outcome of the current return node.

fromOutcome(String) - Method in class javax.faces.flow.builder.SwitchCaseBuilder

Set the outcome in the previously created switch case.

fromPath(String) - Static method in class javax.ws.rs.core.Link

Convenience method to build a link from a path.

fromPath(String) - Static method in class javax.ws.rs.core.UriBuilder

Create a new instance representing a relative URI initialized from a URI path.

fromResource(Class<?>) - Static method in class javax.ws.rs.core.Link

Convenience method to build a link from a resource.

fromResource(Class<?>) - Static method in class javax.ws.rs.core.UriBuilder

Create a new instance representing a relative URI initialized from a root resource class.

fromResponse(Response) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder by performing a shallow copy of an existing Response.

fromStatusCode(int) - Static method in enum javax.ws.rs.core.Response.Status

Convert a numerical status code into the corresponding Status.

fromString(String) - Method in interface javax.ws.rs.ext.ParamConverter

Parse the supplied value and create an instance of T.

fromString(String) - Method in interface javax.ws.rs.ext.RuntimeDelegate.HeaderDelegate

Parse the supplied value and create an instance of T.

FromStringTerm - Class in javax.mail.search

This class implements string comparisons for the From Address header.

FromStringTerm(String) - Constructor for class javax.mail.search.FromStringTerm

Constructor.

FromTerm - Class in javax.mail.search

This class implements comparisons for the From Address header.

FromTerm(Address) - Constructor for class javax.mail.search.FromTerm

Constructor

fromUri(URI) - Static method in class javax.ws.rs.core.Link

Create a new builder instance initialized from an existing URI.

fromUri(String) - Static method in class javax.ws.rs.core.Link

Create a new builder instance initialized from an existing URI represented as a string.

fromUri(URI) - Static method in class javax.ws.rs.core.UriBuilder

Create a new instance initialized from an existing URI.

fromUri(String) - Static method in class javax.ws.rs.core.UriBuilder

Create a new instance initialized from an existing URI.

fromUriBuilder(UriBuilder) - Static method in class javax.ws.rs.core.Link

Create a new builder instance initialized from a URI builder.

fromViewId(String) - Method in class javax.faces.flow.builder.NavigationCaseBuilder

Set the from-view-id of the current navigation case.

FULL_STATE_SAVING_VIEW_IDS_PARAM_NAME - Static variable in class javax.faces.application.StateManager

The runtime must interpret the value of this parameter as a comma separated list of view IDs, each of which must have their state saved using the state saving mechanism specified in JSF 1.2.

fullURL - Variable in class javax.mail.URLName

The full version of the URL

function(String, Class<T>, Expression<?>...) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression for the execution of a database function.

FunctionInfo - Class in javax.servlet.jsp.tagext

Information for a function in a Tag Library.

FunctionInfo(String, String, String) - Constructor for class javax.servlet.jsp.tagext.FunctionInfo

Constructor for FunctionInfo.

FunctionMapper - Class in javax.el

The interface to a map between EL function names and methods.

FunctionMapper() - Constructor for class javax.el.FunctionMapper

FunctionMapper - Interface in javax.servlet.jsp.el

Deprecated.
As of JSP 2.1, replaced by FunctionMapper

functions - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo

An array describing the functions that are defined in this tag library.

Future - Annotation Type in javax.validation.constraints

The annotated element must be a date in the future.

Future.List - Annotation Type in javax.validation.constraints

Defines several Future annotations on the same element.

G

GE - Static variable in class javax.mail.search.ComparisonTerm

ge(Expression<? extends Number>, Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is greater than or equal to the second.

ge(Expression<? extends Number>, Number) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is greater than or equal to the second.

Generated - Annotation Type in javax.annotation

The Generated annotation is used to mark source code that has been generated.

GeneratedValue - Annotation Type in javax.persistence

Provides for the specification of generation strategies for the values of primary keys.

generateSchema(String, Map) - Static method in class javax.persistence.Persistence

Create database schemas and/or tables and/or create DDL scripts as determined by the supplied properties.

generateSchema(PersistenceUnitInfo, Map) - Method in interface javax.persistence.spi.PersistenceProvider

Create database schemas and/or tables and/or create DDL scripts as determined by the supplied properties.

generateSchema(String, Map) - Method in interface javax.persistence.spi.PersistenceProvider

Create database schemas and/or tables and/or create DDL scripts as determined by the supplied properties.

generateSchema(SchemaOutputResolver) - Method in class javax.xml.bind.JAXBContext

Generates the schema documents for this context.

generateUniqueId(String) - Method in class javax.faces.view.facelets.FaceletContext

Generate a unique ID for the passed String

GenerationType - Enum in javax.persistence

Defines the types of primary key generation strategies.

GenericBootstrap - Interface in javax.validation.bootstrap

Defines the state used to bootstrap Bean Validation and creates a provider agnostic Configuration.

GenericCredential - Interface in javax.resource.spi.security

Deprecated.
The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.

GenericEntity<T> - Class in javax.ws.rs.core

Represents a message entity of a generic type T.

GenericEntity(T) - Constructor for class javax.ws.rs.core.GenericEntity

Constructs a new generic entity.

GenericEntity(T, Type) - Constructor for class javax.ws.rs.core.GenericEntity

Create a new instance of GenericEntity, supplying the generic type information.

GenericHandler - Class in javax.xml.rpc.handler

The javax.xml.rpc.handler.GenericHandler class implements the Handler interface.

GenericHandler() - Constructor for class javax.xml.rpc.handler.GenericHandler

Default constructor

GenericServlet - Class in javax.servlet

Defines a generic, protocol-independent servlet.

GenericServlet() - Constructor for class javax.servlet.GenericServlet

Does nothing.

GenericType<T> - Class in javax.ws.rs.core

Represents a generic message entity type T.

GenericType() - Constructor for class javax.ws.rs.core.GenericType

Constructs a new generic type, deriving the generic type and class from type parameter.

GenericType(Type) - Constructor for class javax.ws.rs.core.GenericType

Constructs a new generic type, supplying the generic type information and deriving the class.

get() - Method in class javax.ejb.AsyncResult

This method should not be called.

get(long, TimeUnit) - Method in class javax.ejb.AsyncResult

This method should not be called.

get(Contextual<T>, CreationalContext<T>) - Method in interface javax.enterprise.context.spi.Context

Return an existing instance of certain contextual type or create a new instance by calling Contextual.create(CreationalContext) and return the new instance.

get(Contextual<T>) - Method in interface javax.enterprise.context.spi.Context

Return an existing instance of a certain contextual type or a null value.

get() - Method in class javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance

Get the instance

get(Serializable) - Method in interface javax.faces.component.StateHelper

Return the value currently associated with the specified key if any.

get(Object) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.get(Object) on the wrapped Flash object.

get(String) - Method in class javax.faces.view.facelets.TagAttributes

Using no namespace, find the TagAttribute

get(String, String) - Method in class javax.faces.view.facelets.TagAttributes

Find a TagAttribute that matches the passed namespace and local name.

get() - Method in interface javax.inject.Provider

Provides a fully-constructed and injected instance of T.

get(String) - Method in class javax.mail.internet.ParameterList

Returns the value of the specified parameter.

get(SingularAttribute<? super X, Y>) - Method in interface javax.persistence.criteria.Path

Create a path corresponding to the referenced single-valued attribute.

get(PluralAttribute<X, C, E>) - Method in interface javax.persistence.criteria.Path

Create a path corresponding to the referenced collection-valued attribute.

get(MapAttribute<X, K, V>) - Method in interface javax.persistence.criteria.Path

Create a path corresponding to the referenced map-valued attribute.

get(String) - Method in interface javax.persistence.criteria.Path

Create a path corresponding to the referenced attribute.

get(TupleElement<X>) - Method in interface javax.persistence.Tuple

Get the value of the specified tuple element.

get(String, Class<X>) - Method in interface javax.persistence.Tuple

Get the value of the tuple element to which the specified alias has been assigned.

get(String) - Method in interface javax.persistence.Tuple

Get the value of the tuple element to which the specified alias has been assigned.

get(int, Class<X>) - Method in interface javax.persistence.Tuple

Get the value of the element at the specified position in the result tuple.

get(int) - Method in interface javax.persistence.Tuple

Get the value of the element at the specified position in the result tuple.

get(MessageInfo) - Method in interface javax.security.auth.message.MessagePolicy.Target

Get the Object identified by the Target from the MessageInfo.

get(PageContext, String, int) - Static method in class javax.servlet.jsp.jstl.core.Config

Looks up a configuration variable in the given scope.

get(ServletRequest, String) - Static method in class javax.servlet.jsp.jstl.core.Config

Looks up a configuration variable in the "request" scope.

get(HttpSession, String) - Static method in class javax.servlet.jsp.jstl.core.Config

Looks up a configuration variable in the "session" scope.

get(ServletContext, String) - Static method in class javax.servlet.jsp.jstl.core.Config

Looks up a configuration variable in the "application" scope.

get() - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP GET method for the current request asynchronously.

get(Class<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP GET method for the current request asynchronously.

get(GenericType<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP GET method for the current request asynchronously.

get(InvocationCallback<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP GET method for the current request asynchronously.

get() - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP GET method for the current request synchronously.

get(Class<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP GET method for the current request synchronously.

get(GenericType<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP GET method for the current request synchronously.

get(Object) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

GET - Annotation Type in javax.ws.rs

Indicates that the annotated method responds to HTTP GET requests.

GET - Static variable in annotation type javax.ws.rs.HttpMethod

HTTP GET method.

get(Object) - Method in class javax.xml.soap.SOAPConnection

Gets a message from a specific endpoint and blocks until it receives,

GET_FACTORY_PERMISSION_NAME - Static variable in class javax.security.auth.message.config.AuthConfigFactory

The name of the SecurityPermission required to call getFactory

getAbsolutePath() - Method in interface javax.ws.rs.core.UriInfo

Get the absolute path of the request.

getAbsolutePathBuilder() - Method in interface javax.ws.rs.core.UriInfo

Get the absolute path of the request in the form of a UriBuilder.

getAccept() - Method in class javax.faces.component.html.HtmlForm

Return the value of the accept property.

getAcceptableLanguages() - Method in interface javax.ws.rs.client.ClientRequestContext

Get a list of languages that are acceptable for the response.

getAcceptableLanguages() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get a list of languages that are acceptable for the response.

getAcceptableLanguages() - Method in interface javax.ws.rs.core.HttpHeaders

Get a list of languages that are acceptable for the response.

getAcceptableMediaTypes() - Method in interface javax.ws.rs.client.ClientRequestContext

Get a list of media types that are acceptable for the response.

getAcceptableMediaTypes() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get a list of media types that are acceptable for the response.

getAcceptableMediaTypes() - Method in interface javax.ws.rs.core.HttpHeaders

Get a list of media types that are acceptable for the response.

getAcceptcharset() - Method in class javax.faces.component.html.HtmlForm

Return the value of the acceptcharset property.

getAccesskey() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the accesskey property.

getAccesskey() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the accesskey property.

getAccessURI() - Method in interface javax.xml.registry.infomodel.ServiceBinding

Gets the URI that gives access to the service via this binding.

getAcknowledgeMode() - Method in interface javax.jms.Session

Returns the acknowledgement mode of the session.

getAction() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus

Retrieve the deployment ActionType for this event.

getAction() - Method in interface javax.faces.component.ActionSource

Deprecated.
This has been replaced by ActionSource2.getActionExpression().

getAction() - Method in class javax.faces.component.UICommand

Deprecated.
This has been replaced by UICommand.getActionExpression().

getAction() - Method in class javax.faces.component.UIViewAction

Deprecated.

getActionExpression() - Method in interface javax.faces.component.ActionSource2

Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

getActionExpression() - Method in class javax.faces.component.UICommand

getActionExpression() - Method in class javax.faces.component.UIViewAction

Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

getActionListener() - Method in class javax.faces.application.Application

Return the default ActionListener to be registered for all ActionSource components in this application.

getActionListener() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getActionListener() on the wrapped Application object.

getActionListener() - Method in interface javax.faces.component.ActionSource

Deprecated.
Use ActionSource.getActionListeners() instead.

getActionListener() - Method in class javax.faces.component.UICommand

Deprecated.
Use UICommand.getActionListeners() instead.

getActionListener() - Method in class javax.faces.component.UIViewAction

Deprecated.

getActionListeners() - Method in interface javax.faces.component.ActionSource

Return the set of registered ActionListeners for this ActionSource instance.

getActionListeners() - Method in class javax.faces.component.UICommand

getActionListeners() - Method in class javax.faces.component.UIViewAction

Return the set of registered ActionListeners for this ActionSource instance.

getActions() - Method in class javax.security.jacc.EJBMethodPermission

Returns a String containing a canonical representation of the actions of this EJBMethodPermission.

getActions() - Method in class javax.security.jacc.EJBRoleRefPermission

Returns a canonical String representation of the actions of this EJBRoleRefPermission.

getActions() - Method in class javax.security.jacc.WebResourcePermission

Returns a canonical String representation of the actions of this WebResourcePermission.

getActions() - Method in class javax.security.jacc.WebRoleRefPermission

Returns a canonical String representation of the actions of this WebRoleRefPermission.

getActions() - Method in class javax.security.jacc.WebUserDataPermission

Returns a canonical String representation of the actions of this WebUserDataPermission.

getActionType(int) - Static method in class javax.enterprise.deploy.shared.ActionType

Return an object of the specified value.

getActionURL(FacesContext) - Method in class javax.faces.application.NavigationCase

Construct an absolute URL to this NavigationCase instance using ViewHandler.getActionURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.

getActionURL(FacesContext) - Method in class javax.faces.application.NavigationCaseWrapper

getActionURL(FacesContext, String) - Method in class javax.faces.application.ViewHandler

If the value returned from this method is used as the file argument to the four-argument constructor for java.net.URL (assuming appropriate values are used for the first three arguments), then a client making a request to the toExternalForm() of that URL will select the argument viewId for traversing the JSF lifecycle.

getActionURL(FacesContext, String) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.getActionURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

getActivationName() - Method in interface javax.resource.spi.endpoint.MessageEndpointFactory

Returns a unique name for the message endpoint deployment represented by the MessageEndpointFactory.

getActiveCount() - Method in interface javax.management.j2ee.statistics.JTAStats

Number of active transactions.

getActor() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the uri of the actor attribute of this SOAPHeaderElement.

getAdaptee() - Method in class javax.servlet.jsp.tagext.TagAdapter

Gets the tag that is being adapted to the Tag interface.

getAdapter(Class<A>) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getAdapter(Class<A>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getAdapter(Class<A>) - Method in interface javax.xml.bind.Marshaller

Gets the adapter associated with the specified type.

getAdapter(Class<A>) - Method in interface javax.xml.bind.Unmarshaller

Gets the adapter associated with the specified type.

getAdapterName() - Method in interface javax.resource.cci.ResourceAdapterMetaData

Gets a tool displayable name of the resource adapter.

getAdapterShortDescription() - Method in interface javax.resource.cci.ResourceAdapterMetaData

Gets a tool displayable short desription of the resource adapter.

getAdapterVendorName() - Method in interface javax.resource.cci.ResourceAdapterMetaData

Gets the name of the vendor that has provided the resource adapter.

getAdapterVersion() - Method in interface javax.resource.cci.ResourceAdapterMetaData

Gets the version of the resource adapter.

getAddress() - Method in class javax.mail.internet.InternetAddress

Get the email address.

getAddress() - Method in class javax.mail.search.AddressTerm

Return the address to match with.

getAddress() - Method in interface javax.xml.registry.infomodel.EmailAddress

Returns the email address for this object.

getAfterPhaseListener() - Method in class javax.faces.component.UIViewRoot

Return the MethodExpression that will be invoked after this view is rendered.

getAlgorithm() - Method in class javax.security.auth.message.callback.PrivateKeyCallback.DigestRequest

Get the algorithm identifier.

getAlias() - Method in interface javax.persistence.TupleElement

Return the alias assigned to the tuple element or null, if no alias has been assigned.

getAlias() - Method in class javax.security.auth.message.callback.PrivateKeyCallback.AliasRequest

Get the alias.

getAlias() - Method in class javax.security.auth.message.callback.SecretKeyCallback.AliasRequest

Get the alias.

getAll() - Method in class javax.faces.view.facelets.TagAttributes

Return an array of all TagAttributes in this set

getAll(String) - Method in class javax.faces.view.facelets.TagAttributes

Get all TagAttributes for the passed namespace

getAllAttributes() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all of the attribute Name objects in this SOAPElement object.

getAllAttributesAsQNames() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all of the attributes in this SOAPElement as QName objects.

getAllHeaderLines() - Method in class javax.mail.internet.InternetHeaders

Return all the header lines as an Enumeration of Strings.

getAllHeaderLines() - Method in class javax.mail.internet.MimeBodyPart

Get all header lines as an Enumeration of Strings.

getAllHeaderLines() - Method in class javax.mail.internet.MimeMessage

Get all header lines as an Enumeration of Strings.

getAllHeaderLines() - Method in interface javax.mail.internet.MimePart

Get all header lines as an Enumeration of Strings.

getAllHeaders() - Method in class javax.mail.internet.InternetHeaders

Return all the headers as an Enumeration of Header objects.

getAllHeaders() - Method in class javax.mail.internet.MimeBodyPart

Return all the headers from this Message as an Enumeration of Header objects.

getAllHeaders() - Method in class javax.mail.internet.MimeMessage

Return all the headers from this Message as an enumeration of Header objects.

getAllHeaders() - Method in interface javax.mail.Part

Return all the headers from this part as an Enumeration of Header objects.

getAllHeaders() - Method in class javax.xml.soap.MimeHeaders

Returns all the MimeHeaders in this MimeHeaders object.

getAllMimeHeaders() - Method in class javax.xml.soap.AttachmentPart

Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.

getAllMimeHeaders() - Method in class javax.xml.soap.SOAPPart

Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.

getAllowedMethods() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the allowed HTTP methods from the Allow HTTP header.

getAllowedMethods() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the allowed HTTP methods from the Allow HTTP header.

getAllowedMethods() - Method in class javax.ws.rs.core.Response

Get the allowed HTTP methods from the Allow HTTP header.

getAllRecipients() - Method in class javax.mail.internet.MimeMessage

Get all the recipient addresses for the message.

getAllRecipients() - Method in class javax.mail.Message

Get all the recipient addresses for the message.

getAllTimers() - Method in interface javax.ejb.TimerService

Returns all active timers associated with the beans in the same module in which the caller bean is packaged.

getAlt() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the alt property.

getAlt() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the alt property.

getAlt() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the alt property.

getAlt() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the alt property.

getAlt() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the alt property.

getAlt() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the alt property.

getAlternatives() - Method in interface javax.enterprise.inject.spi.AfterTypeDiscovery

getAnnotated() - Method in interface javax.enterprise.inject.spi.InjectionPoint

Obtain an instance of AnnotatedField or AnnotatedParameter, depending upon whether the injection point is an injected field or a constructor/method parameter.

getAnnotated() - Method in interface javax.enterprise.inject.spi.ProcessBean

Returns the AnnotatedType representing the bean class, the AnnotatedMethod representing the producer method, or the AnnotatedField representing the producer field.

getAnnotated() - Method in interface javax.enterprise.inject.spi.ProcessBeanAttributes

getAnnotatedBeanClass() - Method in interface javax.enterprise.inject.spi.ProcessManagedBean

Returns the AnnotatedType representing the bean class.

getAnnotatedDisposedParameter() - Method in interface javax.enterprise.inject.spi.ProcessProducerField

Returns the AnnotatedParameter for any matching injection point of the same type as the producer field return type found on a disposal method.

getAnnotatedDisposedParameter() - Method in interface javax.enterprise.inject.spi.ProcessProducerMethod

Returns the AnnotatedParameter for any matching injection point of the same type as the producer method return type found on a disposal method.

getAnnotatedEndpointClasses(Set<Class<?>>) - Method in interface javax.websocket.server.ServerApplicationConfig

Return a set of annotated endpoint classes that the server container must deploy.

getAnnotatedMember() - Method in interface javax.enterprise.inject.spi.ProcessProducer

Returns the AnnotatedField representing the producer field or the AnnotatedMethod representing the producer method.

getAnnotatedMethod() - Method in interface javax.enterprise.inject.spi.ProcessObserverMethod

The AnnotatedMethod representing the observer method.

getAnnotatedProducerField() - Method in interface javax.enterprise.inject.spi.ProcessProducerField

Returns the AnnotatedField representing the producer field.

getAnnotatedProducerMethod() - Method in interface javax.enterprise.inject.spi.ProcessProducerMethod

Returns the AnnotatedMethod representing the producer method.

getAnnotatedType(Class<T>, String) - Method in interface javax.enterprise.inject.spi.AfterBeanDiscovery

Obtain the AnnotatedType that may be used to read the annotations of the given class or interface as defined during container initialization.

getAnnotatedType() - Method in interface javax.enterprise.inject.spi.ProcessAnnotatedType

Returns the AnnotatedType object that will be used by the container to read the declared annotations.

getAnnotatedType() - Method in interface javax.enterprise.inject.spi.ProcessInjectionTarget

Returns the AnnotatedType representing the managed bean class, session bean class or other Java EE component class supporting injection.

getAnnotatedTypes(Class<T>) - Method in interface javax.enterprise.inject.spi.AfterBeanDiscovery

Obtain the AnnotatedTypes that may be used to read the annotations of the given class or interface as defined during container initialization.

getAnnotation(Class<T>) - Method in interface javax.enterprise.inject.spi.Annotated

Get program element annotation of a certain annotation type.

getAnnotation() - Method in interface javax.validation.metadata.ConstraintDescriptor

Returns the annotation describing the constraint declaration.

getAnnotations() - Method in interface javax.enterprise.inject.spi.Annotated

Get all annotations of the program element.

getAnnotations() - Method in class javax.ws.rs.client.Entity

Get the entity annotations.

getAnnotations() - Method in interface javax.ws.rs.ext.InterceptorContext

Get an array of the annotations formally declared on the artifact that initiated the intercepted entity provider invocation.

getAppContext() - Method in interface javax.security.auth.message.config.AuthConfig

Get the application context identifier of this authentication context configuration object.

getAppContext() - Method in interface javax.security.auth.message.config.AuthConfigFactory.RegistrationContext

Get the application context identifier from the registration context

getApplication() - Method in class javax.faces.application.ApplicationFactory

Create (if needed) and return an Application instance for this web application.

getApplication() - Method in class javax.faces.context.FacesContext

Return the Application instance associated with this web application.

getApplication() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getApplication() on the wrapped FacesContext object.

getApplication() - Method in class javax.faces.event.PostConstructApplicationEvent

The source Application that sent this event.

getApplication() - Method in class javax.faces.event.PreDestroyApplicationEvent

The source Application that sent this event.

getApplicationContextPath() - Method in class javax.faces.context.ExternalContext

Return the name of the container context for this application.

getApplicationContextPath() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getApplicationContextPath() on the wrapped ExternalContext object.

getApplicationData() - Method in interface javax.websocket.PongMessage

The application data inside the pong message from the peer.

getApplicationMap() - Method in class javax.faces.context.ExternalContext

Return a mutable Map representing the application scope attributes for the current application.

getApplicationMap() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getApplicationMap() on the wrapped ExternalContext object.

getAreaCode() - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Gets the area code.

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.BigDecimalConverter

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.BigIntegerConverter

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.BooleanConverter

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.ByteConverter

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.CharacterConverter

getAsObject(FacesContext, UIComponent, String) - Method in interface javax.faces.convert.Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.DateTimeConverter

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.DoubleConverter

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.EnumConverter

Convert the value argument to one of the enum constants of the class provided in our constructor.

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.FloatConverter

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.IntegerConverter

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.LongConverter

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.NumberConverter

getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.ShortConverter

getAssociatedObjects() - Method in interface javax.xml.registry.infomodel.RegistryObject

Returns the collection of RegistryObject instances associated with this object.

getAssociations() - Method in interface javax.xml.registry.infomodel.RegistryObject

Gets all Associations where this object is source.

getAssociationType() - Method in interface javax.xml.registry.infomodel.Association

Gets the association type for this Association.

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.BigDecimalConverter

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.BigIntegerConverter

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.BooleanConverter

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.ByteConverter

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.CharacterConverter

getAsString(FacesContext, UIComponent, Object) - Method in interface javax.faces.convert.Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.DateTimeConverter

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.DoubleConverter

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.EnumConverter

Convert the enum constant given by the value argument into a String.

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.FloatConverter

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.IntegerConverter

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.LongConverter

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.NumberConverter

getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.ShortConverter

getAsync() - Method in interface javax.jms.JMSProducer

If subsequent calls to send on this JMSProducer object have been configured to be asynchronous then this method returns the CompletionListener that has previously been configured.

getAsyncContext() - Method in class javax.servlet.AsyncEvent

Gets the AsyncContext from this AsyncEvent.

getAsyncContext() - Method in interface javax.servlet.ServletRequest

Gets the AsyncContext that was created or reinitialized by the most recent invocation of ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest,ServletResponse) on this request.

getAsyncContext() - Method in class javax.servlet.ServletRequestWrapper

Gets the AsyncContext that was created or reinitialized by the most recent invocation of ServletRequestWrapper.startAsync() or ServletRequestWrapper.startAsync(ServletRequest,ServletResponse) on the wrapped request.

getAsyncRemote() - Method in interface javax.websocket.Session

Return a reference a RemoteEndpoint object representing the peer of this conversation that is able to send messages asynchronously to the peer.

getAttachedObjectHandlerHelper() - Method in class javax.faces.view.facelets.FaceletsAttachedObjectHandler

Return the underlying handler for this tag handler instance.

getAttachment(SOAPElement) - Method in class javax.xml.soap.SOAPMessage

Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.

getAttachmentAsByteArray(String) - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller

Retrieve the attachment identified by content-id, cid, as a byte[]

getAttachmentAsDataHandler(String) - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller

Lookup MIME content by content-id, cid, and return as a DataHandler.

getAttachmentMarshaller() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getAttachmentMarshaller() - Method in interface javax.xml.bind.Marshaller

getAttachments() - Method in class javax.xml.soap.SOAPMessage

Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.

getAttachments(MimeHeaders) - Method in class javax.xml.soap.SOAPMessage

Retrieves all the AttachmentPart objects that have header entries that match the specified headers.

getAttachmentUnmarshaller() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getAttachmentUnmarshaller() - Method in interface javax.xml.bind.Unmarshaller

getAttribute(String) - Method in class javax.faces.view.facelets.FaceletContext

Return an attribute set by a previous call to FaceletContext.setAttribute(java.lang.String, java.lang.Object).

getAttribute(String) - Method in class javax.faces.view.facelets.TagHandler

Utility method for fetching the appropriate TagAttribute

getAttribute(ObjectName, String) - Method in interface javax.management.j2ee.Management

Gets the value of a specific attribute of a named managed object.

getAttribute() - Method in interface javax.persistence.criteria.Fetch

Return the metamodel attribute corresponding to the fetch join.

getAttribute() - Method in interface javax.persistence.criteria.Join

Return the metamodel attribute corresponding to the join.

getAttribute(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the attribute of the managed type that corresponds to the specified name.

getAttribute(String) - Method in interface javax.servlet.http.HttpSession

Returns the object bound with the specified name in this session, or null if no object is bound under the name.

getAttribute(String) - Method in class javax.servlet.jsp.JspContext

Returns the object associated with the name in the page scope or null if not found.

getAttribute(String, int) - Method in class javax.servlet.jsp.JspContext

Return the object associated with the name in the specified scope or null if not found.

getAttribute(String) - Method in class javax.servlet.jsp.tagext.TagData

The value of the attribute.

getAttribute(String) - Method in interface javax.servlet.ServletContext

Returns the servlet container attribute with the given name, or null if there is no attribute by that name.

getAttribute(String) - Method in interface javax.servlet.ServletRequest

Returns the value of the named attribute as an Object, or null if no attribute of the given name exists.

getAttribute(String) - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to call getAttribute(String name) on the wrapped request object.

getAttribute(String) - Method in class javax.xml.ws.spi.http.HttpContext

Returns an attribute value for container's configuration and other data that can be used by jax-ws runtime.

getAttribute(String) - Method in class javax.xml.ws.spi.http.HttpExchange

Returns an attribute that is associated with this HttpExchange.

getAttributeName(FaceletContext) - Method in interface javax.faces.view.facelets.AttributeHandler

Returns the resolved literal String value of the attribute name after evaluating EL.

getAttributeName() - Method in interface javax.persistence.AttributeNode

Return the name of the attribute corresponding to the attribute node.

getAttributeNames() - Method in interface javax.enterprise.deploy.model.DDBean

Returns the list of attribute names associated with the XML element.

getAttributeNames() - Method in interface javax.servlet.http.HttpSession

Returns an Enumeration of String objects containing the names of all the objects bound to this session.

getAttributeNames() - Method in interface javax.servlet.ServletContext

Returns an Enumeration containing the attribute names available within this ServletContext.

getAttributeNames() - Method in interface javax.servlet.ServletRequest

Returns an Enumeration containing the names of the attributes available to this request.

getAttributeNames() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getAttributeNames() on the wrapped request object.

getAttributeNames() - Method in class javax.xml.ws.spi.http.HttpContext

Returns all attribute names for container's configuration and other data that can be used by jax-ws runtime.

getAttributeNames() - Method in class javax.xml.ws.spi.http.HttpExchange

Gives all the attribute names that are associated with this HttpExchange.

getAttributeNamesInScope(int) - Method in class javax.servlet.jsp.JspContext

Enumerate all the attributes in a given scope.

getAttributeNodes() - Method in interface javax.persistence.EntityGraph

Return the attribute nodes of this entity that are included in the entity graph.

getAttributeNodes() - Method in interface javax.persistence.Subgraph

Return the attribute nodes corresponding to the attributes of this managed type that are included in the subgraph.

getAttributes() - Method in class javax.faces.component.UIComponent

Return a mutable Map representing the attributes (and properties, see below) associated wth this UIComponent, keyed by attribute name (which must be a String).

getAttributes() - Method in class javax.faces.component.UIComponentBase

getAttributes() - Method in class javax.faces.context.FacesContext

Return a mutable Map representing the attributes associated wth this FacesContext instance.

getAttributes() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getAttributes() on the wrapped FacesContext object.

getAttributes() - Method in class javax.faces.event.ExceptionQueuedEventContext

A Map of attributes relevant to the context of this ExceptionQueuedEvent.

getAttributes() - Method in class javax.faces.view.facelets.Tag

Return an object encapsulating the TagAttributes specified on this element in the view.

getAttributes(ObjectName, String[]) - Method in interface javax.management.j2ee.Management

Enables the values of several attributes of a named managed object.

getAttributes() - Method in interface javax.persistence.metamodel.ManagedType

Return the attributes of the managed type.

getAttributes() - Method in class javax.servlet.jsp.tagext.TagData

Enumerates the attributes.

getAttributes() - Method in class javax.servlet.jsp.tagext.TagInfo

Attribute information (in the TLD) on this tag.

getAttributes() - Method in interface javax.validation.metadata.ConstraintDescriptor

Returns a map containing the annotation attribute names as keys and the annotation attribute values as value.

getAttributesScope(String) - Method in class javax.servlet.jsp.JspContext

Get the scope where a given attribute is defined.

getAttributeString(String) - Method in class javax.servlet.jsp.tagext.TagData

Get the value for a given attribute.

getAttributeValue(String) - Method in interface javax.enterprise.deploy.model.DDBean

Returns the string value of the named attribute.

getAttributeValue(Name) - Method in interface javax.xml.soap.SOAPElement

Returns the value of the attribute with the specified name.

getAttributeValue(QName) - Method in interface javax.xml.soap.SOAPElement

Returns the value of the attribute with the specified qname.

getAuditTrail() - Method in interface javax.xml.registry.infomodel.RegistryObject

Returns the complete audit trail of all requests that effected a state change in this object as an ordered Collection of AuditableEvent objects.

getAuthContext(String, Subject, Map) - Method in interface javax.security.auth.message.config.ClientAuthConfig

Get a ClientAuthContext instance from this ClientAuthConfig.

getAuthContext(String, Subject, Map) - Method in interface javax.security.auth.message.config.ServerAuthConfig

Get a ServerAuthContext instance from this ServerAuthConfig.

getAuthContextID(MessageInfo) - Method in interface javax.security.auth.message.config.AuthConfig

Get the authentication context identifier corresponding to the request and response objects encapsulated in messageInfo.

getAuthenticationScheme() - Method in interface javax.ws.rs.core.SecurityContext

Returns the string value of the authentication scheme used to protect the resource.

getAuthType() - Method in class javax.faces.context.ExternalContext

Return the name of the authentication scheme used to authenticate the current user, if any; otherwise, return null.

getAuthType() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getAuthType() on the wrapped ExternalContext object.

getAuthType() - Method in interface javax.servlet.http.HttpServletRequest

Returns the name of the authentication scheme used to protect the servlet.

getAuthType() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getAuthType() on the wrapped request object.

getAutocomplete() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the autocomplete property.

getAutocomplete() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the autocomplete property.

getAutocomplete() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the autocomplete property.

getAutoStart() - Method in interface javax.jms.JMSContext

Returns whether the underlying connection used by this JMSContext will be started automatically when a consumer is created.

getAvailableModules(ModuleType, Target[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Retrieve the list of all Java EE application modules running or not running on the identified targets.

getBase() - Method in class javax.el.ValueReference

getBase64Content() - Method in class javax.xml.soap.AttachmentPart

Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.

getBaseType() - Method in interface javax.enterprise.inject.spi.Annotated

Get the type of the annotated program element.

getBaseType() - Method in class javax.mail.internet.ContentType

Return the MIME type string, without the parameters.

getBaseUri() - Method in interface javax.ws.rs.core.UriInfo

Get the base URI of the application.

getBaseUriBuilder() - Method in interface javax.ws.rs.core.UriInfo

Get the base URI of the application in the form of a UriBuilder.

getBasicRemote() - Method in interface javax.websocket.Session

Return a reference a RemoteEndpoint object representing the peer of this conversation that is able to send messages synchronously to the peer.

getBatchingAllowed() - Method in interface javax.websocket.RemoteEndpoint

Return whether the implementation is allowed to batch outgoing messages before sending.

getBatchStatus() - Method in interface javax.batch.runtime.context.JobContext

The getBatchStatus method simply returns the batch status value set by the batch runtime into the job context.

getBatchStatus() - Method in interface javax.batch.runtime.context.StepContext

The getBatchStatus method returns the current batch status of the current step.

getBatchStatus() - Method in interface javax.batch.runtime.JobExecution

Get batch status of this execution.

getBatchStatus() - Method in interface javax.batch.runtime.StepExecution

Get batch status of this step execution.

getBean(String) - Method in class javax.el.BeanNameResolver

Returns the bean known by its name.

getBean() - Method in class javax.enterprise.deploy.model.XpathEvent

The bean being added/removed/changed.

getBean() - Method in interface javax.enterprise.inject.spi.InjectionPoint

Get the Bean object representing the bean that defines the injection point.

getBean() - Method in interface javax.enterprise.inject.spi.ProcessBean

Returns the Bean object that is about to be registered.

getBeanAttributes() - Method in interface javax.enterprise.inject.spi.ProcessBeanAttributes

getBeanClass() - Method in interface javax.enterprise.inject.spi.Bean

The bean class of the managed bean or session bean or of the bean that declares the producer method or field.

getBeanClass() - Method in interface javax.enterprise.inject.spi.ObserverMethod

Obtains the class of the type that declares the observer method.

getBeanManager() - Method in class javax.enterprise.inject.spi.CDI

Get the CDI BeanManager for the current context

getBeans(Type, Annotation...) - Method in interface javax.enterprise.inject.spi.BeanManager

Return the set of beans which have the given required type and qualifiers and are available for injection in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained, according to the rules of typesafe resolution.

getBeans(String) - Method in interface javax.enterprise.inject.spi.BeanManager

Return the set of beans which have the given EL name and are available for injection in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained, according to the rules of EL name resolution.

getBeforePhaseListener() - Method in class javax.faces.component.UIViewRoot

Return the MethodExpression that will be invoked before this view is rendered.

getBegin() - Method in interface javax.servlet.jsp.jstl.core.LoopTagStatus

Returns the value of the 'begin' attribute for the associated tag, or null if no 'begin' attribute was specified.

getBehavior() - Method in class javax.faces.event.BehaviorEvent

Return the source Behavior that sent this event.

getBehaviorId() - Method in interface javax.faces.view.facelets.BehaviorConfig

Return the value of the behavior-id.

getBehaviorId() - Method in class javax.faces.view.facelets.BehaviorHandler

getBehaviorIds() - Method in class javax.faces.application.Application

Return an Iterator over the set of currently registered behavior ids for this Application.

getBehaviorIds() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getBehaviorIds() on the wrapped Application object.

getBgcolor() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the bgcolor property.

getBgcolor() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the bgcolor property.

getBigDecimal() - Method in interface javax.json.stream.JsonParser

Returns a JSON number as a BigDecimal.

getBindableJavaType() - Method in interface javax.persistence.metamodel.Bindable

Return the Java type of the represented object.

getBindableType() - Method in interface javax.persistence.metamodel.Bindable

Return the bindable type of the represented object.

getBinding() - Method in class javax.faces.view.facelets.DelegatingMetaTagHandler

getBinding() - Method in interface javax.xml.ws.BindingProvider

Get the Binding for this binding provider.

getBinding() - Method in class javax.xml.ws.Endpoint

Returns the binding for this endpoint.

getBindingID() - Method in interface javax.xml.ws.Binding

Get the URI for this binding instance.

getBindingID() - Method in interface javax.xml.ws.handler.PortInfo

Gets the URI identifying the binding used by the port being accessed.

getBody(Class<T>) - Method in interface javax.jms.Message

Returns the message body as an object of the specified type.

getBody() - Method in interface javax.xml.soap.SOAPEnvelope

Returns the SOAPBody object associated with this SOAPEnvelope object.

getBodyContent() - Method in class javax.faces.webapp.UIComponentClassicTagBase

getBodyContent() - Method in class javax.servlet.jsp.tagext.BodyTagSupport

Get current bodyContent.

getBodyContent() - Method in class javax.servlet.jsp.tagext.TagInfo

The bodycontent information for this tag.

getBodyLength() - Method in interface javax.jms.BytesMessage

Gets the number of bytes of the message body when the message is in read-only mode.

getBodyPart(int) - Method in class javax.mail.internet.MimeMultipart

Get the specified BodyPart.

getBodyPart(String) - Method in class javax.mail.internet.MimeMultipart

Get the MimeBodyPart referred to by the given ContentID (CID).

getBodyPart(int) - Method in class javax.mail.Multipart

Get the specified Part.

getBodyPart(int) - Method in interface javax.mail.MultipartDataSource

Get the specified Part.

getBodyrows() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the bodyrows property.

getBodyrows() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the bodyrows property.

getBookmarkableURL(FacesContext) - Method in class javax.faces.application.NavigationCase

Construct an absolute URL suitable for a bookmarkable link to this NavigationCase instance using ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url.

getBookmarkableURL(FacesContext) - Method in class javax.faces.application.NavigationCaseWrapper

getBookmarkableURL(FacesContext, String, Map<String, List<String>>, boolean) - Method in class javax.faces.application.ViewHandler

Return a JSF action URL derived from the viewId argument that is suitable to be used as the target of a link in a JSF response.

getBookmarkableURL(FacesContext, String, Map<String, List<String>>, boolean) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.getBookmarkableURL(javax.faces.context.FacesContext, String, java.util.Map, boolean) on the wrapped ViewHandler object.

getBoolean(FaceletContext) - Method in class javax.faces.view.facelets.TagAttribute

If literal, return Boolean.getBoolean(java.lang.String) passing our value, otherwise call getObject(FaceletContext, Class).

getBoolean(String) - Method in interface javax.jms.MapMessage

Returns the boolean value with the specified name.

getBoolean(int) - Method in interface javax.json.JsonArray

Returns the boolean value at the specified position.

getBoolean(int, boolean) - Method in interface javax.json.JsonArray

Returns the boolean value at the specified position.

getBoolean(String) - Method in interface javax.json.JsonObject

Returns the boolean value of the associated mapping for the specified name.

getBoolean(String, boolean) - Method in interface javax.json.JsonObject

Returns the boolean value of the associated mapping for the specified name.

getBooleanProperty(String) - Method in interface javax.jms.JMSProducer

Returns the message property with the specified name that has been set on this JMSProducer, converted to a boolean.

getBooleanProperty(String) - Method in interface javax.jms.Message

Returns the value of the boolean property with the specified name.

getBootstrapConfiguration() - Method in interface javax.validation.Configuration

Returns configuration information stored in the META-INF/validation.xml file.

getBorder() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the border property.

getBorder() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the border property.

getBorder() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the border property.

getBorder() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the border property.

getBranchQualifier() - Method in interface javax.transaction.xa.Xid

Obtain the transaction branch identifier part of XID as an array of bytes.

getBuffer() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the value of the buffer configuration, which specifies the default size of the response buffer for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.

getBufferSize() - Method in class javax.servlet.jsp.JspWriter

This method returns the size of the buffer used by the JspWriter.

getBufferSize() - Method in interface javax.servlet.ServletResponse

Returns the actual buffer size used for the response.

getBufferSize() - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to return getBufferSize() on the wrapped response object.

getBuilder() - Method in class javax.xml.bind.annotation.W3CDomHandler

getBulkResponse(String) - Method in interface javax.xml.registry.RegistryService

Returns the BulkResponse associated with specified requestId.

getBusinessLifeCycleManager() - Method in interface javax.xml.registry.RegistryService

Returns the BusinessLifeCycleManager object implemented by the JAXR provider.

getBusinessObject(Class<T>) - Method in interface javax.ejb.SessionContext

Obtain an object that can be used to invoke the current bean through a particular business interface view or its no-interface view.

getBusinessQueryManager() - Method in interface javax.xml.registry.RegistryService

Returns the BusinessQueryManager object implemented by the JAXR provider.

getByte(String) - Method in interface javax.jms.MapMessage

Returns the byte value with the specified name.

getByteProperty(String) - Method in interface javax.jms.JMSProducer

Returns the message property with the specified name that has been set on this JMSProducer, converted to a String.

getByteProperty(String) - Method in interface javax.jms.Message

Returns the value of the byte property with the specified name.

getBytes(String) - Method in interface javax.jms.MapMessage

Returns the byte array value with the specified name.

getBytes() - Method in exception javax.websocket.DecodeException

Return the ByteBuffer containing either the whole message, or the partial message, that could not be decoded, or null if this exception arose from a failure to decode a text message.

getCache() - Method in interface javax.persistence.EntityManagerFactory

Access the cache that is associated with the entity manager factory (the "second level cache").

getCacheExtension() - Method in class javax.ws.rs.core.CacheControl

Corresponds to a set of extension cache control directives.

getCalledFlowDocumentId(FacesContext) - Method in class javax.faces.flow.FlowCallNode

getCalledFlowId(FacesContext) - Method in class javax.faces.flow.FlowCallNode

getCallerIdentity() - Method in interface javax.ejb.EJBContext

Deprecated.
Use Principal getCallerPrincipal() instead.

getCallerPrincipal() - Method in interface javax.ejb.EJBContext

Obtain the java.security.Principal that identifies the caller.

getCalls(QName) - Method in interface javax.xml.rpc.Service

Gets an array of preconfigured Call objects for invoking operations on the specified port.

getCapabilityLevel() - Method in interface javax.xml.registry.CapabilityProfile

Gets the capability level supported by the JAXR provider.

getCapabilityProfile() - Method in interface javax.xml.registry.RegistryService

Returns the CapabilityProfile for the JAXR provider.

getCaptionClass() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the captionClass property.

getCaptionClass() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the captionClass property.

getCaptionStyle() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the captionStyle property.

getCaptionStyle() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the captionStyle property.

getCases() - Method in class javax.faces.flow.SwitchNode

Return the cases in this switch.

getCause() - Method in exception javax.faces.FacesException

Return the cause of this exception, or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.mail.MessagingException

Overrides the getCause method of Throwable to return the next exception in the chain of nested exceptions.

getCause() - Method in exception javax.xml.bind.JAXBException

getCause() - Method in exception javax.xml.registry.JAXRException

Returns the Throwable embedded in this JAXRException if there is one.

getCause() - Method in exception javax.xml.soap.SOAPException

Returns the Throwable object embedded in this SOAPException if there is one.

getCausedByException() - Method in exception javax.ejb.EJBException

Obtain the exception that caused the EJBException to be thrown.

getCDI() - Method in interface javax.enterprise.inject.spi.CDIProvider

Provides access to the current container

getCellpadding() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the cellpadding property.

getCellpadding() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the cellpadding property.

getCellspacing() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the cellspacing property.

getCellspacing() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the cellspacing property.

getCertStore() - Method in class javax.security.auth.message.callback.CertStoreCallback

Used by the CertStore user to obtain the CertStore set within the Callback.

getChain() - Method in class javax.security.auth.message.callback.PrivateKeyCallback

Used to obtain the certicicate chain set within the Callback.

getChallenges() - Method in exception javax.ws.rs.NotAuthorizedException

Get the list of authorization challenges associated with the exception and applicable to the resource requested by the client.

getChangeEvent() - Method in class javax.enterprise.deploy.model.XpathEvent

getChar(String) - Method in interface javax.jms.MapMessage

Returns the Unicode character value with the specified name.

getCharacterEncoding() - Method in class javax.faces.context.ResponseWriter

Return the character encoding (such as "ISO-8859-1") for this ResponseWriter.

getCharacterEncoding() - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.getCharacterEncoding() on the wrapped ResponseWriter object.

getCharacterEncoding() - Method in interface javax.servlet.ServletRequest

Returns the name of the character encoding used in the body of this request.

getCharacterEncoding() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getCharacterEncoding() on the wrapped request object.

getCharacterEncoding() - Method in interface javax.servlet.ServletResponse

Returns the name of the character encoding (MIME charset) used for the body sent in this response.

getCharacterEncoding() - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to return getCharacterEncoding() on the wrapped response object.

getChars() - Method in interface javax.json.JsonString

Returns the char sequence for the JSON String value

getCharset() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the charset property.

getCharset() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the charset property.

getCharset() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the charset property.

getCharsetName() - Method in interface javax.xml.registry.infomodel.LocalizedString

Gets the canonical name for the charset for this object.

getChildBean(String) - Method in interface javax.enterprise.deploy.model.DDBean

Return a list of DDBeans based upon the XPath.

getChildBean(String) - Method in interface javax.enterprise.deploy.model.DeployableObject

Return an array of standard beans representing the XML content returned based upon the XPath.

getChildBean(ModuleType, String) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject

Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.

getChildConceptCount() - Method in interface javax.xml.registry.infomodel.ClassificationScheme

Gets number of children.

getChildConceptCount() - Method in interface javax.xml.registry.infomodel.Concept

Gets number of children.

getChildCount() - Method in class javax.faces.component.UIComponent

Return the number of child UIComponents that are associated with this UIComponent.

getChildCount() - Method in class javax.faces.component.UIComponentBase

getChildElements() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all the immediate child Nodes of this element.

getChildElements(Name) - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all the immediate child Nodes of this element with the specified name.

getChildElements(QName) - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all the immediate child Nodes of this element with the specified qname.

getChildOrganizationCount() - Method in interface javax.xml.registry.infomodel.Organization

Gets number of children.

getChildOrganizations() - Method in interface javax.xml.registry.infomodel.Organization

Gets all immediate children Organizations.

getChildren() - Method in class javax.faces.component.UIComponent

Return a mutable List representing the child UIComponents associated with this component.

getChildren() - Method in class javax.faces.component.UIComponentBase

getChildrenConcepts() - Method in interface javax.xml.registry.infomodel.ClassificationScheme

Gets all immediate children Concepts.

getChildrenConcepts() - Method in interface javax.xml.registry.infomodel.Concept

Gets all immediate children Concepts.

getChildTargetModuleID() - Method in interface javax.enterprise.deploy.spi.TargetModuleID

Retrieve a list of identifiers of the children of this deployed module.

getCity() - Method in interface javax.xml.registry.infomodel.PostalAddress

Returns the city.

getClasses() - Method in class javax.ws.rs.core.Application

Get a set of root resource, provider and feature classes.

getClasses() - Method in interface javax.ws.rs.core.Configuration

Get the immutable set of registered JAX-RS component (such as provider or feature) classes to be instantiated, injected and utilized in the scope of the configurable instance.

getClassFromScope(String) - Method in interface javax.enterprise.deploy.model.DeployableObject

Retrieve the specified class from this deployable module.

getClassifications() - Method in interface javax.xml.registry.infomodel.RegistryObject

Gets the Classification instances that classify this object.

getClassificationScheme() - Method in interface javax.xml.registry.infomodel.Classification

Gets the ClassificationScheme that is used in classifying the object.

getClassificationScheme() - Method in interface javax.xml.registry.infomodel.Concept

Gets the ClassificationScheme that this Concept is a descendent of.

getClassifiedObject() - Method in interface javax.xml.registry.infomodel.Classification

Gets the Object that is being classified.

getClassLoader() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns ClassLoader that the provider may use to load any classes, resources, or open URLs.

getClassLoader() - Method in interface javax.servlet.ServletContext

Gets the class loader of the web application represented by this ServletContext.

getClassName() - Method in class javax.mail.Provider

Returns name of the class that implements the protocol

getClassName() - Method in class javax.servlet.jsp.tagext.TagVariableInfo

The body of the <variable-class> element.

getClassName() - Method in class javax.servlet.jsp.tagext.VariableInfo

Returns the type of this variable.

getClassName() - Method in interface javax.servlet.Registration

Gets the fully qualified class name of the Servlet or Filter that is represented by this Registration.

getClassType() - Method in interface javax.persistence.Subgraph

Return the type for which this subgraph was defined.

getClient() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the client instance associated with the request.

getClientAuthConfig(String, String, CallbackHandler) - Method in interface javax.security.auth.message.config.AuthConfigProvider

Get an instance of ClientAuthConfig from this provider.

getClientBehaviorRenderer(String) - Method in class javax.faces.render.RenderKit

Return the ClientBehaviorRenderer instance most recently registered for the specified type, if any; otherwise, return null.

getClientBehaviorRenderer(String) - Method in class javax.faces.render.RenderKitWrapper

The default behavior of this method is to call RenderKit.getClientBehaviorRenderer(String) on the wrapped RenderKit object.

getClientBehaviorRendererTypes() - Method in class javax.faces.render.RenderKit

Return an Iterator over the ClientBehaviorRenderer types.

getClientBehaviorRendererTypes() - Method in class javax.faces.render.RenderKitWrapper

The default behavior of this method is to call RenderKit.getClientBehaviorRendererTypes() on the wrapped RenderKit object.

getClientBehaviors() - Method in interface javax.faces.component.behavior.ClientBehaviorHolder

Returns a non-null, unmodifiable Map that contains the the ClientBehaviors that have been attached to the component implementing this interface.

getClientBehaviors() - Method in class javax.faces.component.UIComponentBase

This is a default implementation of ClientBehaviorHolder.getClientBehaviors().

getClientConfiguration(TargetModuleID) - Method in interface javax.enterprise.deploy.spi.status.ProgressObject

Return the ClientConfiguration object associated with the TargetModuleID.

getClientId() - Method in class javax.faces.component.UIComponent

Enable EL to access the clientId of a component.

getClientId(FacesContext) - Method in class javax.faces.component.UIComponent

Return a client-side identifier for this component, generating one if necessary.

getClientId(FacesContext) - Method in class javax.faces.component.UIComponentBase

getClientId(FacesContext) - Method in class javax.faces.component.UIData

Return a client identifier for this component that includes the current value of the rowIndex property, if it is not set to -1.

getClientID() - Method in interface javax.jms.Connection

Gets the client identifier for this connection.

getClientID() - Method in interface javax.jms.JMSContext

Gets the client identifier for the JMSContext's connection.

getClientIdsWithMessages() - Method in class javax.faces.context.FacesContext

Return an Iterator over the client identifiers for which at least one FacesMessage has been queued.

getClientIdsWithMessages() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getClientIdsWithMessages() on the wrapped FacesContext object.

getClientWindow() - Method in class javax.faces.context.ExternalContext

Return the ClientWindow set in a preceding call to ExternalContext.setClientWindow(javax.faces.lifecycle.ClientWindow), or null if no such call has been made.

getClientWindow() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getClientWindow() on the wrapped ExternalContext object.

getClientWindow(FacesContext) - Method in class javax.faces.lifecycle.ClientWindowFactory

The implementation is responsible for creating the ClientWindow instance for this request.

getClientWindowFlowId(ClientWindow) - Method in class javax.faces.flow.Flow

Obtain the current ClientWindow from the ExternalContext.

getCloseCode(int) - Static method in enum javax.websocket.CloseReason.CloseCodes

Creates a CloseCode from the given int code number.

getCloseCode() - Method in class javax.websocket.CloseReason

The Close code associated with this CloseReason.

getCloseCount() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats

The number of connections closed

getCloseCount() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats

Number of connections closed.

getCode() - Method in interface javax.websocket.CloseReason.CloseCode

Returns the code number, for example the integer '1000' for normal closure.

getCode() - Method in enum javax.websocket.CloseReason.CloseCodes

Return the code number of this status code.

getCollection(String, Class<E>) - Method in interface javax.persistence.metamodel.ManagedType

Return the Collection-valued attribute of the managed type that corresponds to the specified name and Java element type.

getCollection(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the Collection-valued attribute of the managed type that corresponds to the specified name.

getCollection() - Method in interface javax.xml.registry.BulkResponse

Get the Collection of objects returned as a response of a bulk operation.

getCollectionType() - Method in interface javax.persistence.metamodel.PluralAttribute

Return the collection type.

getCols() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the cols property.

getColumn() - Method in class javax.faces.view.Location

Return the estimated character column.

getColumnClasses() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the columnClasses property.

getColumnClasses() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the columnClasses property.

getColumnNames() - Method in interface javax.servlet.jsp.jstl.sql.Result

Returns the names of the columns in the result.

getColumnNumber() - Method in interface javax.json.stream.JsonLocation

Return the column number for the current JSON event in the input source.

getColumnNumber() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getColumnNumber() - Method in interface javax.xml.bind.ValidationEventLocator

Return the column number if available

getColumns() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the columns property.

getCommand() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus

Retrieve the deployment CommandType of this event.

getCommandType(int) - Static method in class javax.enterprise.deploy.shared.CommandType

Return an object of the specified value.

getComment() - Method in class javax.servlet.http.Cookie

Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.

getComment() - Method in interface javax.servlet.SessionCookieConfig

Gets the comment that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

getComment() - Method in class javax.ws.rs.core.NewCookie

Get the comment associated with the cookie.

getCommittedCount() - Method in interface javax.management.j2ee.statistics.JTAStats

Number of committed transactions.

getCommonPropertyType(ELContext, Object) - Method in class javax.el.ArrayELResolver

If the base object is a Java language array, returns the most general type that this resolver accepts for the property argument.

getCommonPropertyType(ELContext, Object) - Method in class javax.el.BeanELResolver

If the base object is not null, returns the most general type that this resolver accepts for the property argument.

getCommonPropertyType(ELContext, Object) - Method in class javax.el.BeanNameELResolver

Always returns String.class, since a bean name is a String.

getCommonPropertyType(ELContext, Object) - Method in class javax.el.CompositeELResolver

Returns the most general type that this resolver accepts for the property argument, given a base object.

getCommonPropertyType(ELContext, Object) - Method in class javax.el.ELResolver

Returns the most general type that this resolver accepts for the property argument, given a base object.

getCommonPropertyType(ELContext, Object) - Method in class javax.el.ListELResolver

If the base object is a list, returns the most general type that this resolver accepts for the property argument.

getCommonPropertyType(ELContext, Object) - Method in class javax.el.MapELResolver

If the base object is a map, returns the most general type that this resolver accepts for the property argument.

getCommonPropertyType(ELContext, Object) - Method in class javax.el.ResourceBundleELResolver

If the base object is a ResourceBundle, returns the most general type that this resolver accepts for the property argument.

getCommonPropertyType(ELContext, Object) - Method in class javax.el.StaticFieldELResolver

Returns the type of the property.

getCommonPropertyType(ELContext, Object) - Method in class javax.el.TypeConverter

getCommonPropertyType(ELContext, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver

If the base object is null, returns String.class.

getCommonPropertyType(ELContext, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver

If the base object is null, returns String.class.

getComparison() - Method in class javax.mail.search.DateTerm

Return the type of comparison.

getComparison() - Method in class javax.mail.search.IntegerComparisonTerm

Return the type of comparison.

getComponent() - Method in class javax.faces.component.behavior.ClientBehaviorContext

Returns the UIComponent that is requesting the ClientBehavior script.

getComponent() - Method in class javax.faces.event.ComponentSystemEvent

the source UIComponent that sent this event.

getComponent() - Method in class javax.faces.event.ExceptionQueuedEventContext

Return the UIComponent which was being processed when the exception was thrown.

getComponent() - Method in class javax.faces.event.FacesEvent

Return the source UIComponent that sent this event.

getComponentConfig() - Method in class javax.faces.view.facelets.ComponentHandler

getComponentFamilies() - Method in class javax.faces.render.RenderKit

Return an Iterator over the component-family entries supported by this RenderKit instance.

getComponentFamilies() - Method in class javax.faces.render.RenderKitWrapper

The default behavior of this method is to call RenderKit.getComponentFamilies() on the wrapped RenderKit object.

getComponentInstance() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Return the UIComponent instance that is associated with this tag instance.

getComponentInstance() - Method in class javax.faces.webapp.UIComponentTagBase

Return the UIComponent instance that is associated with this tag instance.

getComponentMetadata(FacesContext, Resource) - Method in class javax.faces.view.ViewDeclarationLanguage

Return a reference to the component metadata for the composite component represented by the argument componentResource, or null if the metadata cannot be found.

getComponentMetadata(FacesContext, Resource) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

getComponentResources(FacesContext, String) - Method in class javax.faces.component.UIViewRoot

Return an unmodifiable List of UIComponents for the provided target agrument.

getComponentStateToRestore(FacesContext) - Method in class javax.faces.render.ResponseStateManager

Deprecated.
This method has been replaced by ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.

getComponentStateToSave(FacesContext) - Method in class javax.faces.application.StateManager

Deprecated.
the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.

getComponentStateToSave(FacesContext) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.getComponentStateToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.

getComponentType() - Method in interface javax.faces.view.facelets.ComponentConfig

ComponentType to pass to the Application.

getComponentType() - Method in class javax.faces.webapp.UIComponentTagBase

Return the component type for the component that is or will be bound to this tag.

getComponentTypes() - Method in class javax.faces.application.Application

Return an Iterator over the set of currently defined component types for this Application.

getComponentTypes() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getComponentTypes() on the wrapped Application object.

getComposingConstraints() - Method in interface javax.validation.metadata.ConstraintDescriptor

Return a set of composing ConstraintDescriptors where each descriptor describes a composing constraint.

getCompositeComponentParent(UIComponent) - Static method in class javax.faces.component.UIComponent

Finds the nearest composite component parent of the specified component.

getCompoundSelectionItems() - Method in interface javax.persistence.criteria.Selection

Return the selection items composing a compound selection.

getConcept() - Method in interface javax.xml.registry.infomodel.Classification

Gets the Concept that is classifying the object.

getCondition(FacesContext) - Method in class javax.faces.application.NavigationCase

Evaluates the <if> for this <navigation-case>, if any.

getCondition(FacesContext) - Method in class javax.faces.application.NavigationCaseWrapper

getCondition(FacesContext) - Method in class javax.faces.flow.SwitchCase

Return true if this case should be taken, false otherwise.

getConfigInUse() - Method in interface javax.json.JsonBuilderFactory

Returns read-only map of supported provider specific configuration properties that are used to configure the created JSON builders.

getConfigInUse() - Method in interface javax.json.JsonReaderFactory

Returns read-only map of supported provider specific configuration properties that are used to configure the created JSON readers.

getConfigInUse() - Method in interface javax.json.JsonWriterFactory

Returns read-only map of supported provider specific configuration properties that are used to configure the created JSON writer objects.

getConfigInUse() - Method in interface javax.json.stream.JsonGeneratorFactory

Returns a read-only map of supported provider specific configuration properties that are used to configure the JSON generators.

getConfigInUse() - Method in interface javax.json.stream.JsonParserFactory

Returns a read-only map of supported provider specific configuration properties that are used to configure the JSON parsers.

getConfigProvider(String, String, RegistrationListener) - Method in class javax.security.auth.message.config.AuthConfigFactory

Get a registered AuthConfigProvider from the factory.

getConfiguration() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the immutable configuration of the request.

getConfiguration() - Method in interface javax.ws.rs.core.Configurable

Get a live view of an internal configuration state of this configurable instance.

getConfigurator() - Method in interface javax.websocket.ClientEndpointConfig

Return the custom configurator for this configuration.

getConfigurator() - Method in interface javax.websocket.server.ServerEndpointConfig

Return the ServerEndpointConfig.Configurator this configuration is using.

getConnection() - Method in interface javax.resource.cci.ConnectionFactory

Gets a connection to an EIS instance.

getConnection(ConnectionSpec) - Method in interface javax.resource.cci.ConnectionFactory

Gets a connection to an EIS instance.

getConnection() - Method in interface javax.resource.cci.Interaction

Gets the Connection associated with the Interaction.

getConnection(Subject, ConnectionRequestInfo) - Method in interface javax.resource.spi.ManagedConnection

Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance.

getConnectionFactory() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats

Returns the associated JCAConnectionFactory OBJECT_NAME

getConnectionHandle() - Method in class javax.resource.spi.ConnectionEvent

Get the connection handle associated with the Managed Connection instance.

getConnectionPools() - Method in interface javax.management.j2ee.statistics.JCAStats

Returns an array of JCAConnectionPool Stats that provide statistics about the connection pools associated with the referencing JCA resource statistics

getConnectionPools() - Method in interface javax.management.j2ee.statistics.JDBCStats

getConnections() - Method in interface javax.management.j2ee.statistics.JCAStats

Returns an array of JCAConnectionStats that provide statistics about the non-pooled connections associated with the referencing JCA resource statistics

getConnections() - Method in interface javax.management.j2ee.statistics.JDBCStats

getConnections() - Method in interface javax.management.j2ee.statistics.JMSStats

Returns an array of JMSConnectionStats that provide statistics about the connections associated with the referencing JMS resource.

getConstrainedConstructors() - Method in interface javax.validation.metadata.BeanDescriptor

Returns a set with descriptors for the constrained constructors of the bean represented by this descriptor.

getConstrainedMethods(MethodType, MethodType...) - Method in interface javax.validation.metadata.BeanDescriptor

Returns a set with descriptors for the constrained methods of the bean represented by this descriptor.

getConstrainedProperties() - Method in interface javax.validation.metadata.BeanDescriptor

Returns a set of property descriptors having at least one constraint defined or marked as cascaded (Valid).

getConstraintDescriptor() - Method in interface javax.validation.ConstraintViolation

Returns the constraint metadata reported to fail.

getConstraintDescriptor() - Method in interface javax.validation.MessageInterpolator.Context

getConstraintDescriptors() - Method in interface javax.validation.metadata.ElementDescriptor.ConstraintFinder

Retrieves the constraint descriptors following the defined restrictions and hosted on the element described by ElementDescriptor.

getConstraintDescriptors() - Method in interface javax.validation.metadata.ElementDescriptor

Returns all constraint descriptors for this element in the class hierarchy or an empty Set if none are present.

getConstraintDescriptors() - Method in interface javax.validation.metadata.ExecutableDescriptor

Returns an empty Set.

getConstraintMappingResourcePaths() - Method in interface javax.validation.BootstrapConfiguration

Returns a set of resource paths pointing to XML constraint mapping files.

getConstraintsForClass(Class<?>) - Method in interface javax.validation.Validator

Returns the descriptor object describing bean constraints.

getConstraintsForConstructor(Class<?>...) - Method in interface javax.validation.metadata.BeanDescriptor

Returns a constructor descriptor for the given constructor.

getConstraintsForMethod(String, Class<?>...) - Method in interface javax.validation.metadata.BeanDescriptor

Returns a method descriptor for the given method.

getConstraintsForProperty(String) - Method in interface javax.validation.metadata.BeanDescriptor

Returns the property descriptor for a given property.

getConstraintValidatorClasses() - Method in interface javax.validation.metadata.ConstraintDescriptor

List of the constraint validation implementation classes.

getConstraintValidatorFactory() - Method in interface javax.validation.spi.ConfigurationState

Returns the constraint validator factory of this configuration.

getConstraintValidatorFactory() - Method in interface javax.validation.ValidatorFactory

Returns the ConstraintValidatorFactory instance configured at initialization time for the ValidatorFactory.

getConstraintValidatorFactoryClassName() - Method in interface javax.validation.BootstrapConfiguration

Class name of the ConstraintValidatorFactory implementation or null if none is specified.

getConstraintViolations() - Method in exception javax.validation.ConstraintViolationException

Set of constraint violations reported during a validation.

getConstructor() - Method in interface javax.interceptor.InvocationContext

Returns the constructor of the target class for which the interceptor was invoked.

getConstructors() - Method in interface javax.enterprise.inject.spi.AnnotatedType

Get the constructors of the type.

getConsumers() - Method in interface javax.management.j2ee.statistics.JMSSessionStats

Returns an array of JMSConsumerStats that provide statistics about the message consumers associated with the referencing JMS session statistics.

getContainer() - Method in class javax.websocket.ContainerProvider

Load the container implementation.

getContainer() - Method in interface javax.websocket.Session

Return the container that this session is part of.

getContainerClientId(FacesContext) - Method in class javax.faces.component.UIComponent

Allow components that implement NamingContainer to selectively disable prepending their clientId to their descendent's clientIds by breaking the prepending logic into a seperately callable method.

getContainerClientId(FacesContext) - Method in class javax.faces.component.UIForm

Override the UIComponent.getContainerClientId(javax.faces.context.FacesContext) to allow users to disable this form from prepending its clientId to its descendent's clientIds depending on the value of this form's UIForm.isPrependId() property.

getContainingQuery() - Method in interface javax.persistence.criteria.Subquery

Return the query of which this is a subquery.

getContent() - Method in class javax.mail.internet.MimeBodyPart

Return the content as a Java object.

getContent() - Method in class javax.mail.internet.MimeMessage

Return the content as a Java object.

getContent() - Method in interface javax.mail.Part

Return the content as a Java object.

getContent() - Method in class javax.xml.soap.AttachmentPart

Gets the content of this AttachmentPart object as a Java object.

getContent() - Method in class javax.xml.soap.SOAPPart

Returns the content of the SOAPEnvelope as a JAXP Source object.

getContentDescription() - Method in class javax.xml.soap.SOAPMessage

Retrieves a description of this SOAPMessage object's content.

getContentID() - Method in class javax.mail.internet.MimeBodyPart

Returns the value of the "Content-ID" header field.

getContentID() - Method in class javax.mail.internet.MimeMessage

Returns the value of the "Content-ID" header field.

getContentID() - Method in interface javax.mail.internet.MimePart

Get the Content-ID of this part.

getContentId() - Method in class javax.xml.soap.AttachmentPart

Gets the value of the MIME header whose name is "Content-ID".

getContentId() - Method in class javax.xml.soap.SOAPPart

Retrieves the value of the MIME header whose name is "Content-Id".

getContentLanguage() - Method in class javax.mail.internet.MimeBodyPart

Get the languages specified in the Content-Language header of this MimePart.

getContentLanguage() - Method in class javax.mail.internet.MimeMessage

Get the languages specified in the "Content-Language" header field of this message.

getContentLanguage() - Method in interface javax.mail.internet.MimePart

Get the language tags specified in the Content-Language header of this MimePart.

getContentLength() - Method in interface javax.servlet.ServletRequest

Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known ir is greater than Integer.MAX_VALUE.

getContentLength() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getContentLength() on the wrapped request object.

getContentLengthLong() - Method in interface javax.servlet.ServletRequest

Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known.

getContentLengthLong() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getContentLengthLong() on the wrapped request object.

getContentLocation() - Method in class javax.xml.soap.AttachmentPart

Gets the value of the MIME header whose name is "Content-Location".

getContentLocation() - Method in class javax.xml.soap.SOAPPart

Retrieves the value of the MIME header whose name is "Content-Location".

getContentMD5() - Method in class javax.mail.internet.MimeBodyPart

Return the value of the "Content-MD5" header field.

getContentMD5() - Method in class javax.mail.internet.MimeMessage

Return the value of the "Content-MD5" header field.

getContentMD5() - Method in interface javax.mail.internet.MimePart

Get the Content-MD5 digest of this part.

getContentStream() - Method in class javax.mail.internet.MimeBodyPart

Produce the raw bytes of the content.

getContentStream() - Method in class javax.mail.internet.MimeMessage

Produce the raw bytes of the content.

getContentType() - Method in class javax.faces.application.Resource

Return the MIME content-type for this resource.

getContentType() - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.getContentType() on the wrapped ResourceHandler object.

getContentType() - Method in class javax.faces.context.ResponseWriter

Return the content type (such as "text/html") for this ResponseWriter.

getContentType() - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.getContentType() on the wrapped ResponseWriter object.

getContentType() - Method in class javax.mail.internet.MimeBodyPart

Returns the value of the RFC 822 "Content-Type" header field.

getContentType() - Method in class javax.mail.internet.MimeMessage

Returns the value of the RFC 822 "Content-Type" header field.

getContentType() - Method in class javax.mail.internet.MimePartDataSource

Returns the content-type of this DataSource.

getContentType() - Method in class javax.mail.Multipart

Return the content-type of this Multipart.

getContentType() - Method in interface javax.mail.Part

Returns the Content-Type of the content of this part.

getContentType() - Method in class javax.mail.util.ByteArrayDataSource

Get the MIME content type of the data.

getContentType() - Method in interface javax.servlet.http.Part

Gets the content type of this part.

getContentType() - Method in interface javax.servlet.ServletRequest

Returns the MIME type of the body of the request, or null if the type is not known.

getContentType() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getContentType() on the wrapped request object.

getContentType() - Method in interface javax.servlet.ServletResponse

Returns the content type used for the MIME body sent in this response.

getContentType() - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to return getContentType() on the wrapped response object.

getContentType() - Method in class javax.xml.soap.AttachmentPart

Gets the value of the MIME header whose name is "Content-Type".

getContext() - Method in class javax.ejb.embeddable.EJBContainer

Retrieve a naming context for looking up references to session beans executing in the embeddable container.

getContext(Class) - Method in class javax.el.ELContext

Returns the context object associated with the given key.

getContext(Class) - Method in class javax.el.StandardELContext

getContext(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains an active context object for the given scope .

getContext() - Method in class javax.faces.context.ExternalContext

Return the application environment object instance for the current appication.

getContext() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getContext() on the wrapped ExternalContext object.

getContext() - Method in class javax.faces.event.ExceptionQueuedEvent

Return the ExceptionQueuedEventContext for this event instance.

getContext() - Method in class javax.faces.event.ExceptionQueuedEventContext

getContext() - Method in class javax.faces.event.PostConstructCustomScopeEvent

Return the ScopeContext for this event.

getContext() - Method in class javax.faces.event.PreDestroyCustomScopeEvent

Return the ScopeContext for this event.

getContext() - Method in interface javax.jms.XAJMSContext

Returns the JMSContext object associated with this XAJMSContext.

getContext(String) - Static method in class javax.security.jacc.PolicyContext

This method may be used by a Policy provider to activate the PolicyContextHandler registered to the context object key and cause it to return the corresponding policy context object from the container.

getContext(String, Object) - Method in interface javax.security.jacc.PolicyContextHandler

This public method is used by the PolicyContext class to activate the handler and obtain from it the context object identified by the (case-sensitive) key.

getContext(String) - Method in interface javax.servlet.ServletContext

Returns a ServletContext object that corresponds to a specified URL on the server.

getContext(Class<?>) - Method in interface javax.ws.rs.ext.ContextResolver

Get a context of type T that is applicable to the supplied type.

getContext() - Method in interface javax.xml.ws.Response

Gets the contained response context.

getContextData() - Method in interface javax.ejb.EJBContext

The getContextData method enables a business method, lifecycle callback method, or timeout method to retrieve any interceptor/webservices context associated with its invocation.

getContextData() - Method in interface javax.interceptor.InvocationContext

Enables an interceptor to retrieve or update the data associated with the invocation by another interceptor, business method,and/or webservices context in the invocation chain.

getContextID() - Method in interface javax.security.jacc.PolicyConfiguration

This method returns this object's policy context identifier.

getContextID() - Static method in class javax.security.jacc.PolicyContext

This static method returns the value of the policy context identifier associated with the thread on which the accessor is called.

getContextName() - Method in class javax.faces.context.ExternalContext

Return the name of the container context for this application.

getContextName() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getContextName() on the wrapped ExternalContext object.

getContextPath() - Method in interface javax.servlet.http.HttpServletRequest

Returns the portion of the request URI that indicates the context of the request.

getContextPath() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getContextPath() on the wrapped request object.

getContextPath() - Method in interface javax.servlet.ServletContext

Returns the context path of the web application.

getContextPath() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the context path of all the endpoints in an application.

getContextResolver(Class<T>, MediaType) - Method in interface javax.ws.rs.ext.Providers

Get a context resolver for a particular type of context and media type.

getContracts(Class<?>) - Method in interface javax.ws.rs.core.Configuration

Get the extension contract registration information for a component of a given class.

getConvertedValue(FacesContext, Object) - Method in class javax.faces.component.UIInput

Convert the submitted value into a "local value" of the appropriate data type, if necessary.

getConvertedValue(FacesContext, Object) - Method in class javax.faces.component.UIViewParameter

Because this class has no Renderer, leverage the one from the standard HTML_BASIC RenderKit with component-family: javax.faces.Input and renderer-type: javax.faces.Text and call its Renderer.getConvertedValue(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object) method.

getConvertedValue(FacesContext, UIComponent, Object) - Method in class javax.faces.render.Renderer

Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one).

getConvertedValue(FacesContext, UIComponent, Object) - Method in class javax.faces.render.RendererWrapper

getConverter() - Method in class javax.faces.component.UIOutput

getConverter() - Method in interface javax.faces.component.ValueHolder

Return the Converter (if any) that is registered for this UIComponent.

getConverter(Class<T>, Type, Annotation[]) - Method in interface javax.ws.rs.ext.ParamConverterProvider

Obtain a ParamConverter that can provide from/to string conversion for an instance of a particular Java type.

getConverterId() - Method in interface javax.faces.view.facelets.ConverterConfig

Return the converter id to be used in instantiating this converter

getConverterId(FaceletContext) - Method in class javax.faces.view.facelets.ConverterHandler

getConverterIds() - Method in class javax.faces.application.Application

Return an Iterator over the set of currently registered converter ids for this Application.

getConverterIds() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getConverterIds() on the wrapped Application object.

getConverterMessage() - Method in class javax.faces.component.UIInput

If there has been a call to UIInput.setConverterMessage(java.lang.String) on this instance, return the message.

getConverterTypes() - Method in class javax.faces.application.Application

Return an Iterator over the set of Class instances for which Converter classes have been explicitly registered.

getConverterTypes() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getConverterTypes() on the wrapped Application object.

getCookies() - Method in interface javax.servlet.http.HttpServletRequest

Returns an array containing all of the Cookie objects the client sent with this request.

getCookies() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getCookies() on the wrapped request object.

getCookies() - Method in interface javax.ws.rs.client.ClientRequestContext

Get any cookies that accompanied the request.

getCookies() - Method in interface javax.ws.rs.client.ClientResponseContext

Get any new cookies set on the response message.

getCookies() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get any cookies that accompanied the request.

getCookies() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get any new cookies set on the response message.

getCookies() - Method in interface javax.ws.rs.core.HttpHeaders

Get any cookies that accompanied the request.

getCookies() - Method in class javax.ws.rs.core.Response

Get any new cookies set on the response message.

getCoords() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the coords property.

getCoords() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the coords property.

getCoords() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the coords property.

getCorrelatedJoins() - Method in interface javax.persistence.criteria.Subquery

Return the correlated joins of the subquery.

getCorrelationParent() - Method in interface javax.persistence.criteria.From

Returns the parent From object from which the correlated From object has been obtained through correlation (use of a Subquery correlate method).

getCount() - Method in class javax.mail.internet.MimeMultipart

Return the number of enclosed BodyPart objects.

getCount() - Method in class javax.mail.Multipart

Return the number of enclosed BodyPart objects.

getCount() - Method in interface javax.mail.MultipartDataSource

Return the number of enclosed BodyPart objects.

getCount() - Method in interface javax.management.j2ee.statistics.CountStatistic

The count since the last reset.

getCount() - Method in interface javax.management.j2ee.statistics.TimeStatistic

Number of times the operation was invoked since the beginning of this measurement.

getCount() - Method in interface javax.servlet.jsp.jstl.core.LoopTagStatus

Retrieves the "count" of the current round of the iteration.

getCountry() - Method in interface javax.xml.registry.infomodel.PostalAddress

Returns the country.

getCountryCode() - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Gets the country code.

getCreateCount() - Method in interface javax.management.j2ee.statistics.EJBStats

Number of times create was called.

getCreateCount() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats

The number of connections created

getCreateCount() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats

Number of connections created.

getCreated() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Return true if we dynamically created a new component instance during execution of this tag.

getCreated() - Method in class javax.faces.webapp.UIComponentTagBase

Return true if we dynamically created a new component instance during execution of this tag.

getCreatedComponents() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Returns the List of UIComponent ids created or located by nested UIComponentTags while processing the current request.

getCreateTime() - Method in interface javax.batch.runtime.JobExecution

Get time execution was created.

getCreationTime() - Method in interface javax.servlet.http.HttpSession

Returns the time when this session was created, measured in milliseconds since midnight January 1, 1970 GMT.

getCredentialData() - Method in interface javax.resource.spi.security.GenericCredential

Deprecated.

Gets security data for a specific security mechanism represented by the GenericCredential.

getCredentials() - Method in interface javax.xml.registry.Connection

Gets the credentials associated with this client.

getCriteriaBuilder() - Method in interface javax.persistence.EntityManager

Return an instance of CriteriaBuilder for the creation of CriteriaQuery objects.

getCriteriaBuilder() - Method in interface javax.persistence.EntityManagerFactory

Return an instance of CriteriaBuilder for the creation of CriteriaQuery objects.

getCrossParameterDescriptor() - Method in interface javax.validation.metadata.ExecutableDescriptor

Returns a descriptor containing the cross-parameter constraints of this executable.

getCryptographicallyStrongTokenFromSession(FacesContext) - Method in class javax.faces.render.ResponseStateManager

Compliant implementations must return a cryptographically strong token for use to protect views in this application.

getCurrencyCode() - Method in class javax.faces.convert.NumberConverter

Return the ISO 4217 currency code used by getAsString() with a type of currency.

getCurrencySymbol() - Method in class javax.faces.convert.NumberConverter

Return the currency symbol used by getAsString() with a type of currency.

getCurrent() - Method in interface javax.management.j2ee.statistics.RangeStatistic

The current value of this attribute.

getCurrent() - Method in interface javax.servlet.jsp.jstl.core.LoopTag

Retrieves the current item in the iteration.

getCurrent() - Method in interface javax.servlet.jsp.jstl.core.LoopTagStatus

Retrieves the current item in the iteration.

getCurrent() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

getCurrentComponent(FacesContext) - Static method in class javax.faces.component.UIComponent

Return the UIComponent instance that is currently processing.

getCurrentCompositeComponent(FacesContext) - Static method in class javax.faces.component.UIComponent

Return the closest ancestor component, relative to the component returned from UIComponent.getCurrentComponent(javax.faces.context.FacesContext), that is a composite component, or null if no such component exists.

getCurrentFlow(FacesContext) - Method in class javax.faces.flow.FlowHandler

Return the currently active Flow for the argument FacesContext, or null if no flow is active.

getCurrentFlow() - Method in class javax.faces.flow.FlowHandler

Convenience overload that calls FacesContext.getCurrentInstance() and then calls through to FlowHandler.getCurrentFlow(javax.faces.context.FacesContext).

getCurrentFlowScope() - Method in class javax.faces.flow.FlowHandler

Return the Map that backs the #{flowScope} EL implicit object or null if no flow is currently active.

getCurrentInstance() - Static method in class javax.faces.context.FacesContext

Return the FacesContext instance for the request that is being processed by the current thread.

getCurrentLocale() - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Returns the active locale this implementation of javax.enterprise.deploy.spi subpackages is running.

getCurrentPhaseId() - Method in class javax.faces.context.FacesContext

Return the value last set on this FacesContext instance when FacesContext.setCurrentPhaseId(javax.faces.event.PhaseId) was called.

getCurrentPhaseId() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getCurrentPhaseId() on the wrapped FacesContext object.

getDataHandler() - Method in class javax.mail.internet.MimeBodyPart

Return a DataHandler for this body part's content.

getDataHandler() - Method in class javax.mail.internet.MimeMessage

Return a DataHandler for this Message's content.

getDataHandler() - Method in interface javax.mail.Part

Return a DataHandler for the content within this part.

getDataHandler() - Method in class javax.xml.soap.AttachmentPart

Gets the DataHandler object for this AttachmentPart object.

getDataModel() - Method in class javax.faces.component.UIData

Return the internal DataModel object representing the data objects that we will iterate over in this component's rendering.

getDataModel() - Method in class javax.faces.model.DataModelEvent

Return the DataModel that fired this event.

getDataModelListeners() - Method in class javax.faces.model.DataModel

Return the set of DataModelListeners interested in notifications from this DataModel.

getDate() - Method in class javax.mail.search.DateTerm

Return the Date to compare with.

getDate() - Method in interface javax.ws.rs.client.ClientRequestContext

Get message date.

getDate() - Method in interface javax.ws.rs.client.ClientResponseContext

Get message date.

getDate() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get message date.

getDate() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get message date.

getDate() - Method in interface javax.ws.rs.core.HttpHeaders

Get message date.

getDate() - Method in class javax.ws.rs.core.Response

Get message date.

getDateHeader(String) - Method in interface javax.servlet.http.HttpServletRequest

Returns the value of the specified request header as a long value that represents a Date object.

getDateHeader(String) - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getDateHeader(String name) on the wrapped request object.

getDateStyle() - Method in class javax.faces.convert.DateTimeConverter

Return the style to be used to format or parse dates.

getDayOfMonth() - Method in class javax.ejb.ScheduleExpression

Return the value of the day of the month attribute.

getDayOfWeek() - Method in class javax.ejb.ScheduleExpression

Return the value of the day of the week attribute.

getDConfigBean(DDBean) - Method in interface javax.enterprise.deploy.spi.DConfigBean

Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.

getDConfigBean(DDBeanRoot) - Method in interface javax.enterprise.deploy.spi.DConfigBeanRoot

Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor.

getDConfigBeanRoot(DDBeanRoot) - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration

Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.

getDConfigBeanVersion() - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Returns the Java EE platform version number for which the configuration beans are provided.

getDConfigBeanVersionType(int) - Static method in class javax.enterprise.deploy.shared.DConfigBeanVersionType

Return an object of the specified value.

getDDBean() - Method in interface javax.enterprise.deploy.spi.DConfigBean

Return the JavaBean containing the deployment descriptor XML text associated with this DConfigBean.

getDDBeanRoot() - Method in interface javax.enterprise.deploy.model.DeployableObject

Return the top level standard bean representing the root of the deployment descriptor.

getDDBeanRoot(String) - Method in interface javax.enterprise.deploy.model.DeployableObject

Returns a DDBeanRoot object for the XML instance document named.

getDDBeanRootVersion() - Method in interface javax.enterprise.deploy.model.DDBeanRoot

Returns the version number of an XML instance document.

getDebug() - Method in class javax.mail.Session

Get the debug setting for this Session.

getDebugOut() - Method in class javax.mail.Session

Returns the stream to be used for debugging output.

getDeclarativeQueryManager() - Method in interface javax.xml.registry.RegistryService

Returns the DeclarativeQueryManager object implemented by the JAXR provider.

getDeclare() - Method in class javax.servlet.jsp.tagext.TagVariableInfo

The body of the <declare> element.

getDeclare() - Method in class javax.servlet.jsp.tagext.VariableInfo

Returns whether this is a new variable.

getDeclaredAttribute(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the attribute declared by the managed type that corresponds to the specified name.

getDeclaredAttributes() - Method in interface javax.persistence.metamodel.ManagedType

Return the attributes declared by the managed type.

getDeclaredCollection(String, Class<E>) - Method in interface javax.persistence.metamodel.ManagedType

Return the Collection-valued attribute declared by the managed type that corresponds to the specified name and Java element type.

getDeclaredCollection(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the Collection-valued attribute declared by the managed type that corresponds to the specified name.

getDeclaredId(Class<Y>) - Method in interface javax.persistence.metamodel.IdentifiableType

Return the attribute that corresponds to the id attribute declared by the entity or mapped superclass.

getDeclaredList(String, Class<E>) - Method in interface javax.persistence.metamodel.ManagedType

Return the List-valued attribute declared by the managed type that corresponds to the specified name and Java element type.

getDeclaredList(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the List-valued attribute declared by the managed type that corresponds to the specified name.

getDeclaredMap(String, Class<K>, Class<V>) - Method in interface javax.persistence.metamodel.ManagedType

Return the Map-valued attribute declared by the managed type that corresponds to the specified name and Java key and value types.

getDeclaredMap(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the Map-valued attribute declared by the managed type that corresponds to the specified name.

getDeclaredPluralAttributes() - Method in interface javax.persistence.metamodel.ManagedType

Return all multi-valued attributes (Collection-, Set-, List-, and Map-valued attributes) declared by the managed type.

getDeclaredSet(String, Class<E>) - Method in interface javax.persistence.metamodel.ManagedType

Return the Set-valued attribute declared by the managed type that corresponds to the specified name and Java element type.

getDeclaredSet(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the Set-valued attribute declared by the managed type that corresponds to the specified name.

getDeclaredSingularAttribute(String, Class<Y>) - Method in interface javax.persistence.metamodel.ManagedType

Return the single-valued attribute declared by the managed type that corresponds to the specified name and Java type.

getDeclaredSingularAttribute(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the single-valued attribute declared by the managed type that corresponds to the specified name.

getDeclaredSingularAttributes() - Method in interface javax.persistence.metamodel.ManagedType

Return the single-valued attributes declared by the managed type.

getDeclaredType() - Method in class javax.xml.bind.JAXBElement

Returns the Java binding of the xml element declaration's type attribute.

getDeclaredVersion(Class<Y>) - Method in interface javax.persistence.metamodel.IdentifiableType

Return the attribute that corresponds to the version attribute declared by the entity or mapped superclass.

getDeclaringCallable() - Method in interface javax.enterprise.inject.spi.AnnotatedParameter

Get the declaring method or constructor.

getDeclaringType() - Method in interface javax.enterprise.inject.spi.AnnotatedMember

Get the type which defines this member.

getDeclaringType() - Method in interface javax.persistence.metamodel.Attribute

Return the managed type representing the type in which the attribute was declared.

getDecoders() - Method in interface javax.websocket.EndpointConfig

Return the Decoder implementation classes configured.

getDecoratedTypes() - Method in interface javax.enterprise.inject.spi.Decorator

Obtains the decorated types.

getDecorators() - Method in interface javax.enterprise.inject.spi.AfterTypeDiscovery

getDefaultAsyncSendTimeout() - Method in interface javax.websocket.WebSocketContainer

Return the number of milliseconds the implementation will timeout attempting to send a websocket message for all RemoteEndpoints associated with this container.

getDefaultConstraintMessageTemplate() - Method in interface javax.validation.ConstraintValidatorContext

getDefaultConstraintValidatorFactory() - Method in interface javax.validation.Configuration

Returns an implementation of the ConstraintValidatorFactory interface following the default ConstraintValidatorFactory defined in the specification: uses the public no-arg constructor of the ConstraintValidator

getDefaultContentType() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the value of the default-content-type configuration, which specifies the default response content type for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.

getDefaultDomain() - Method in interface javax.management.j2ee.Management

Returns the default domain name of this MEJB.

getDefaultEventName() - Method in interface javax.faces.component.behavior.ClientBehaviorHolder

Returns the default event name for this ClientBehaviorHolder implementation.

getDefaultEventName() - Method in class javax.faces.component.html.HtmlBody

getDefaultEventName() - Method in class javax.faces.component.html.HtmlCommandButton

getDefaultEventName() - Method in class javax.faces.component.html.HtmlCommandLink

getDefaultEventName() - Method in class javax.faces.component.html.HtmlDataTable

getDefaultEventName() - Method in class javax.faces.component.html.HtmlForm

getDefaultEventName() - Method in class javax.faces.component.html.HtmlGraphicImage

getDefaultEventName() - Method in class javax.faces.component.html.HtmlInputFile

getDefaultEventName() - Method in class javax.faces.component.html.HtmlInputSecret

getDefaultEventName() - Method in class javax.faces.component.html.HtmlInputText

getDefaultEventName() - Method in class javax.faces.component.html.HtmlInputTextarea

getDefaultEventName() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

getDefaultEventName() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

getDefaultEventName() - Method in class javax.faces.component.html.HtmlOutputLabel

getDefaultEventName() - Method in class javax.faces.component.html.HtmlOutputLink

getDefaultEventName() - Method in class javax.faces.component.html.HtmlPanelGrid

getDefaultEventName() - Method in class javax.faces.component.html.HtmlPanelGroup

getDefaultEventName() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

getDefaultEventName() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

getDefaultEventName() - Method in class javax.faces.component.html.HtmlSelectManyListbox

getDefaultEventName() - Method in class javax.faces.component.html.HtmlSelectManyMenu

getDefaultEventName() - Method in class javax.faces.component.html.HtmlSelectOneListbox

getDefaultEventName() - Method in class javax.faces.component.html.HtmlSelectOneMenu

getDefaultEventName() - Method in class javax.faces.component.html.HtmlSelectOneRadio

getDefaultEventName() - Method in class javax.faces.component.UIComponentBase

This is a default implementation of ClientBehaviorHolder.getDefaultEventName().

getDefaultFactory() - Static method in class javax.servlet.jsp.JspFactory

Returns the default factory for this implementation.

getDefaultFolder() - Method in class javax.mail.Store

Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.

getDefaultInstance(Properties, Authenticator) - Static method in class javax.mail.Session

Get the default Session object.

getDefaultInstance(Properties) - Static method in class javax.mail.Session

Get the default Session object.

getDefaultJavaCharset() - Static method in class javax.mail.internet.MimeUtility

Get the default charset corresponding to the system's current default locale.

getDefaultLocale() - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Returns the default locale supported by this implementation of javax.enterprise.deploy.spi subpackages.

getDefaultLocale() - Method in class javax.faces.application.Application

Return the default Locale for this application.

getDefaultLocale() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getDefaultLocale() on the wrapped Application object.

getDefaultMaxBinaryMessageBufferSize() - Method in interface javax.websocket.WebSocketContainer

Returns the default maximum size of incoming binary message that this container will buffer.

getDefaultMaxSessionIdleTimeout() - Method in interface javax.websocket.WebSocketContainer

Return the default time in milliseconds after which any web socket sessions in this container will be closed if it has been inactive.

getDefaultMaxTextMessageBufferSize() - Method in interface javax.websocket.WebSocketContainer

Returns the default maximum size of incoming text message that this container will buffer.

getDefaultMessageInterpolator() - Method in interface javax.validation.Configuration

Returns an implementation of the MessageInterpolator interface following the default MessageInterpolator defined in the specification: use the ValidationMessages resource bundle to load keys use Locale.getDefault()

getDefaultOutcome(FacesContext) - Method in class javax.faces.flow.SwitchNode

Return the default outcome in this switch.

getDefaultParameterNameProvider() - Method in interface javax.validation.Configuration

Returns an implementation of the ParameterNameProvider interface following the default ParameterNameProvider defined in the specification: returns names in the form arg&lt;PARAMETER_INDEX&gt; where PARAMETER_INDEX starts at 0 for the first parameter, e.g.

getDefaultPostalScheme() - Method in interface javax.xml.registry.RegistryService

Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.

getDefaultProviderClassName() - Method in interface javax.validation.BootstrapConfiguration

Class name of the ValidationProvider implementation or null if none is specified.

getDefaultRenderKitId() - Method in class javax.faces.application.Application

Return the renderKitId to be used for rendering this application.

getDefaultRenderKitId() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getDefaultRenderKitId() on the wrapped Application object.

getDefaultSessionTrackingModes() - Method in interface javax.servlet.ServletContext

Gets the session tracking modes that are supported by default for this ServletContext.

getDefaultTraversableResolver() - Method in interface javax.validation.Configuration

Returns an implementation of the TraversableResolver interface following the default TraversableResolver defined in the specification: if Java Persistence is available in the runtime environment, a property is considered reachable if Java Persistence considers the property as loaded if Java Persistence is not available in the runtime environment, all properties are considered reachable all properties are considered cascadable.

getDefaultTypeMapping() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry

Gets the registered default TypeMapping instance.

getDefaultUserName() - Method in class javax.mail.Authenticator

getDefaultValidatedExecutableTypes() - Method in interface javax.validation.BootstrapConfiguration

Returns the set of executable types that should be considered unless explicitly overridden via ValidateOnExecution
Returns a set containing ExecutableType.CONSTRUCTORS and ExecutableType.NON_GETTER_METHODS if unspecified in the configuration.

getDefaultValidationProviderResolver() - Method in interface javax.validation.spi.BootstrapState

Specification default ValidationProviderResolver strategy instance.

getDefaultValidatorInfo() - Method in class javax.faces.application.Application

Return an immutable Map over the set of currently registered default validator IDs and their class name for this Application.

getDefaultValidatorInfo() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getDefaultValidatorInfo() on the wrapped Application object.

getDeferredSyntaxAllowedAsLiteral() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the value of the deferred-syntax-allowed-as-literal configuration, which specifies whether the character sequence "#{", which is normally reserved for Expression Language (EL) expressions, will cause a translation error if it appears as a String literal in any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.

getDefiningDocumentId() - Method in class javax.faces.flow.Flow

Return the immutable application unique identifier for the document in which the argument flow is defined.

getDelay() - Method in class javax.faces.component.behavior.AjaxBehavior

Returns the delay value, or null if no value was set.

getDelegate() - Method in interface javax.persistence.EntityManager

Return the underlying provider object for the EntityManager, if available.

getDelegateQualifiers() - Method in interface javax.enterprise.inject.spi.Decorator

Obtains the qualifiers of the delegate injection point.

getDelegateType() - Method in interface javax.enterprise.inject.spi.Decorator

Obtains the type of the delegate injection point.

getDeletedMessageCount() - Method in class javax.mail.Folder

Get the number of deleted messages in this Folder.

getDelims() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

getDeliveryDelay() - Method in interface javax.jms.JMSProducer

Gets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.

getDeliveryDelay() - Method in interface javax.jms.MessageProducer

Gets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.

getDeliveryMode() - Method in interface javax.jms.JMSProducer

Returns the delivery mode of messages that are sent using this JMSProducer

getDeliveryMode() - Method in interface javax.jms.MessageProducer

Gets the producer's default delivery mode.

getDeployableObject() - Method in interface javax.enterprise.deploy.model.DDBeanRoot

Return the containing DeployableObject

getDeployableObject(String) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject

Return the DeployableObject of the specified URI designator.

getDeployableObject() - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration

Returns an object that provides access to the deployment descriptor data and classes of a Java EE module.

getDeployableObjects(ModuleType) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject

Return the all DeployableObjects of the specified type.

getDeployableObjects() - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject

Return the all DeployableObjects in this application.

getDeploymentFactories() - Method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager

Retrieve the lists of currently registered DeploymentFactories.

getDeploymentManager(String, String, String) - Method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager

Retrieves a DeploymentManager instance to use for deployment.

getDeploymentManager(String, String, String) - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory

Return a connected DeploymentManager instance.

getDeploymentStatus() - Method in class javax.enterprise.deploy.spi.status.ProgressEvent

Retrieve the status information.

getDeploymentStatus() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject

Retrieve the status of this activity.

getDescendantConcepts() - Method in interface javax.xml.registry.infomodel.ClassificationScheme

Gets all descendant Concepts.

getDescendantConcepts() - Method in interface javax.xml.registry.infomodel.Concept

Gets all descendant Concepts.

getDescendantOrganizations() - Method in interface javax.xml.registry.infomodel.Organization

Gets all descendant Organizations.

getDescription() - Method in interface javax.enterprise.deploy.spi.Target

Retrieve other descriptive information about the target.

getDescription() - Method in class javax.faces.model.SelectItem

Return a description of this item, for use in development tools.

getDescription() - Method in class javax.mail.internet.MimeBodyPart

Returns the "Content-Description" header field of this body part.

getDescription() - Method in class javax.mail.internet.MimeMessage

Returns the "Content-Description" header field of this Message.

getDescription() - Method in interface javax.mail.Part

Return a description String for this part.

getDescription() - Method in interface javax.management.j2ee.statistics.Statistic

A human-readable description of the Statistic.

getDescription() - Method in class javax.resource.spi.work.HintsContext

Get the brief description of the role played by the WorkContext and any other related debugging information.

getDescription() - Method in class javax.resource.spi.work.SecurityContext

Get the brief description of the role played by the WorkContext and any other related debugging information.

getDescription() - Method in class javax.resource.spi.work.TransactionContext

Get the brief description of the role played by the WorkContext and any other related debugging information.

getDescription() - Method in interface javax.resource.spi.work.WorkContext

Get the brief description of the role played by the WorkContext and any other related debugging information.

getDescription() - Method in interface javax.security.auth.message.config.AuthConfigFactory.RegistrationContext

Get the description from the registration context

getDescription() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

Gets the description string of this tag attribute.

getDescription() - Method in interface javax.xml.registry.infomodel.RegistryObject

Gets the textual description for this object.

getDeserializer(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping

Gets the DeserializerFactory registered for the specified pair of Java type and XML data type.

getDeserializerAs(String) - Method in interface javax.xml.rpc.encoding.DeserializerFactory

Returns a Deserializer for the specified XML processing mechanism type.

getDestination() - Method in interface javax.jms.MessageProducer

Gets the destination associated with this MessageProducer.

getDestination() - Method in interface javax.management.j2ee.statistics.JMSProducerStats

Returns a string that encapsulates the identity of the message destination

getDetail() - Method in class javax.faces.application.FacesMessage

Return the localized detail text.

getDetail() - Method in exception javax.xml.rpc.soap.SOAPFaultException

Gets the detail element.

getDetail() - Method in interface javax.xml.soap.SOAPFault

Returns the optional detail element for this SOAPFault object.

getDetailEntries() - Method in interface javax.xml.soap.Detail

Gets an Iterator over all of the DetailEntrys in this Detail object.

getDigest() - Method in class javax.security.auth.message.callback.PrivateKeyCallback.DigestRequest

Get the digest value.

getDir() - Method in class javax.faces.component.html.HtmlBody

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlForm

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlHead

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlOutputFormat

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlOutputText

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the dir property.

getDir() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the dir property.

getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the disabledClass property.

getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the disabledClass property.

getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the disabledClass property.

getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the disabledClass property.

getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the disabledClass property.

getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the disabledClass property.

getDisableMessageID() - Method in interface javax.jms.JMSProducer

Gets an indication of whether message IDs are disabled.

getDisableMessageID() - Method in interface javax.jms.MessageProducer

Gets an indication of whether message IDs are disabled.

getDisableMessageTimestamp() - Method in interface javax.jms.JMSProducer

Gets an indication of whether message timestamps are disabled.

getDisableMessageTimestamp() - Method in interface javax.jms.MessageProducer

Gets an indication of whether message timestamps are disabled.

getDisconnectedDeploymentManager(String) - Method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager

Return a disconnected DeploymentManager instance.

getDisconnectedDeploymentManager(String) - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory

Return a disconnected DeploymentManager instance.

getDispatcherType() - Method in interface javax.servlet.ServletRequest

Gets the dispatcher type of this request.

getDispatcherType() - Method in class javax.servlet.ServletRequestWrapper

Gets the dispatcher type of the wrapped request.

getDisplayName() - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory

Provide a string with the name of this vendor's DeploymentManager.

getDisplayName() - Method in class javax.servlet.jsp.tagext.TagInfo

Get the displayName.

getDisposition() - Method in class javax.mail.internet.ContentDisposition

Return the disposition value.

getDisposition() - Method in class javax.mail.internet.MimeBodyPart

Returns the value of the "Content-Disposition" header field.

getDisposition() - Method in class javax.mail.internet.MimeMessage

Returns the value of the "Content-Disposition" header field.

getDisposition() - Method in interface javax.mail.Part

Return the disposition of this part.

getDoAfterBodyValue() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Return the flag value that should be returned from the doAfterBody() method when it is called.

getDoEndValue() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Return the flag value that should be returned from the doEnd() method when it is called.

getDomain() - Method in class javax.servlet.http.Cookie

Gets the domain name of this Cookie.

getDomain() - Method in interface javax.servlet.SessionCookieConfig

Gets the domain name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

getDomain() - Method in class javax.ws.rs.core.Cookie

Get the domain of the cookie.

getDoStartValue() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Return the flag value that should be returned from the doStart() method when it is called.

getDouble(String) - Method in interface javax.jms.MapMessage

Returns the double value with the specified name.

getDoubleProperty(String) - Method in interface javax.jms.JMSProducer

Returns the message property with the specified name that has been set on this JMSProducer, converted to a double.

getDoubleProperty(String) - Method in interface javax.jms.Message

Returns the value of the double property with the specified name.

getDurableSubscriptionCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats

Number of durable subscriptions.

getEffectiveMajorVersion() - Method in interface javax.servlet.ServletContext

Gets the major version of the Servlet specification that the application represented by this ServletContext is based on.

getEffectiveMinorVersion() - Method in interface javax.servlet.ServletContext

Gets the minor version of the Servlet specification that the application represented by this ServletContext is based on.

getEffectiveSessionTrackingModes() - Method in interface javax.servlet.ServletContext

Gets the session tracking modes that are in effect for this ServletContext.

getEISProductName() - Method in interface javax.resource.cci.ConnectionMetaData

Returns product name of the underlying EIS instance connected through the Connection that produced this metadata.

getEISProductName() - Method in interface javax.resource.spi.ManagedConnectionMetaData

Returns Product name of the underlying EIS instance connected through the ManagedConnection.

getEISProductVersion() - Method in interface javax.resource.cci.ConnectionMetaData

Returns product version of the underlying EIS instance.

getEISProductVersion() - Method in interface javax.resource.spi.ManagedConnectionMetaData

Returns product version of the underlying EIS instance connected through the ManagedConnection.

getEJBHome() - Method in interface javax.ejb.EJBContext

Obtain the enterprise bean's remote home interface.

getEJBHome() - Method in interface javax.ejb.EJBMetaData

Obtain the remote home interface of the enterprise bean.

getEJBHome() - Method in interface javax.ejb.EJBObject

Obtain the enterprise bean's remote home interface.

getEJBHome() - Method in interface javax.ejb.HomeHandle

Obtain the home object represented by this handle.

getEJBLocalHome() - Method in interface javax.ejb.EJBContext

Obtain the enterprise bean's local home interface.

getEJBLocalHome() - Method in interface javax.ejb.EJBLocalObject

Obtain the enterprise bean's local home interface.

getEJBLocalObject() - Method in interface javax.ejb.EntityContext

Obtain a reference to the EJB local object that is currently associated with the instance.

getEJBLocalObject() - Method in interface javax.ejb.SessionContext

Obtain a reference to the EJB local object that is associated with the instance.

getEJBMetaData() - Method in interface javax.ejb.EJBHome

Obtain the EJBMetaData interface for the enterprise bean.

getEjbName() - Method in interface javax.enterprise.inject.spi.ProcessSessionBean

Returns the EJB name of the session bean.

getEJBObject() - Method in interface javax.ejb.EntityContext

Obtain a reference to the EJB object that is currently associated with the instance.

getEJBObject() - Method in interface javax.ejb.Handle

Obtain the EJB object reference represented by this handle.

getEJBObject() - Method in interface javax.ejb.SessionContext

Obtain a reference to the EJB object that is currently associated with the instance.

getELContext() - Method in class javax.el.ELContextEvent

Returns the ELContext that was created.

getELContext() - Method in class javax.el.ELManager

Return the ELContext used for parsing and evaluating EL expressions.

getELContext() - Method in class javax.faces.context.FacesContext

Return the ELContext instance for this FacesContext instance.

getELContext() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getELContext() on the wrapped FacesContext object.

getELContext() - Method in class javax.faces.webapp.UIComponentELTag

Return the ELContext for the FacesContext for this request.

getELContext() - Method in class javax.faces.webapp.UIComponentTagBase

Return the ELContext for the FacesContext for this request.

getELContext() - Method in class javax.servlet.jsp.JspContext

Returns the ELContext associated with this JspContext.

getELContextListeners() - Method in class javax.faces.application.Application

If no calls have been made to Application.addELContextListener(javax.el.ELContextListener), this method must return an empty array.

getELContextListeners() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getELContextListeners() on the wrapped Application object.

getElement(ResultT) - Method in interface javax.xml.bind.annotation.DomHandler

Once the portion is sent to the Result.

getElement(DOMResult) - Method in class javax.xml.bind.annotation.W3CDomHandler

getElementClass() - Method in interface javax.validation.metadata.CrossParameterDescriptor

getElementClass() - Method in interface javax.validation.metadata.ElementDescriptor

getElementName(Object) - Method in class javax.xml.bind.JAXBIntrospector

Get xml element qname for jaxbElement.

getElementName() - Method in interface javax.xml.soap.SOAPElement

Returns the name of this SOAPElement object.

getElementQName() - Method in interface javax.xml.soap.SOAPElement

Returns the qname of this SOAPElement object.

getElements() - Method in interface javax.persistence.Tuple

Return the tuple elements.

getElementType() - Method in interface javax.persistence.metamodel.PluralAttribute

Return the type representing the element type of the collection.

getElIgnored() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the value of the el-ignored configuration, which specifies whether Expression Language (EL) evaluation is enabled for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.

getELManager() - Method in class javax.el.ELProcessor

Return the ELManager used for EL processing.

getELResolver() - Method in class javax.el.ELContext

Retrieves the ELResolver associated with this context.

getELResolver() - Method in class javax.el.StandardELContext

Construct (if needed) and return a default ELResolver.

getELResolver() - Method in interface javax.enterprise.inject.spi.BeanManager

Returns a ELResolver that resolves beans by EL name.

getELResolver() - Method in class javax.faces.application.Application

Return the singleton ELResolver instance to be used for all EL resolution.

getELResolver() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getELResolver() on the wrapped Application object.

getEmailAddresses() - Method in interface javax.xml.registry.infomodel.User

Gets the email addresses for this User.

getEmbeddables() - Method in interface javax.persistence.metamodel.Metamodel

Return the metamodel embeddable types.

getEmptyRoleSemantic() - Method in class javax.servlet.HttpConstraintElement

Gets the default authorization semantic.

getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the enabledClass property.

getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the enabledClass property.

getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the enabledClass property.

getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the enabledClass property.

getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the enabledClass property.

getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the enabledClass property.

getEnclosingWriter() - Method in class javax.servlet.jsp.tagext.BodyContent

Get the enclosing JspWriter.

getEncoders() - Method in interface javax.websocket.EndpointConfig

Return the Encoder implementation classes configured.

getEncoding() - Method in interface javax.mail.EncodingAware

Return the MIME Content-Transfer-Encoding to use for this data, or null to indicate that an appropriate value should be chosen by the caller.

getEncoding() - Method in class javax.mail.internet.MimeBodyPart

Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.

getEncoding() - Method in class javax.mail.internet.MimeMessage

Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.

getEncoding() - Method in interface javax.mail.internet.MimePart

Get the transfer encoding of this part.

getEncoding(DataSource) - Static method in class javax.mail.internet.MimeUtility

Get the Content-Transfer-Encoding that should be applied to the input stream of this DataSource, to make it mail-safe.

getEncoding(DataHandler) - Static method in class javax.mail.internet.MimeUtility

Same as getEncoding(DataSource) except that instead of reading the data from an InputStream it uses the writeTo method to examine the data.

getEncoding() - Method in class javax.mail.internet.PreencodedMimeBodyPart

Returns the content transfer encoding specified when this object was created.

getEncoding() - Method in class javax.ws.rs.client.Entity

Get entity encoding.

getEncoding() - Method in class javax.ws.rs.core.Variant

Get the encoding of the variant.

getEncoding() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the current output encoding.

getEncodingStyle() - Method in interface javax.xml.soap.SOAPElement

Returns the encoding style for this SOAPElement object.

getEnctype() - Method in class javax.faces.component.html.HtmlForm

Return the value of the enctype property.

getEnd() - Method in class javax.ejb.ScheduleExpression

Return the end date, if set; otherwise null.

getEnd() - Method in interface javax.servlet.jsp.jstl.core.LoopTagStatus

Returns the value of the 'end' attribute for the associated tag, or null if no 'end' attribute was specified.

getEndpointClass() - Method in interface javax.resource.spi.endpoint.MessageEndpointFactory

Return the Class object corresponding to the message endpoint class.

getEndpointClass() - Method in interface javax.websocket.server.ServerEndpointConfig

Returns the Class of the endpoint this configuration is configuring.

getEndpointConfigs(Set<Class<? extends Endpoint>>) - Method in interface javax.websocket.server.ServerApplicationConfig

Return a set of ServerEndpointConfig instances that the server container will use to deploy the programmatic endpoints.

getEndpointInstance(Class<T>) - Method in class javax.websocket.server.ServerEndpointConfig.Configurator

This method is called by the container each time a new client connects to the logical endpoint this configurator configures.

getEndpointReference() - Method in interface javax.xml.ws.BindingProvider

Returns the EndpointReference associated with this BindingProvider instance.

getEndpointReference(Class<T>) - Method in interface javax.xml.ws.BindingProvider

Returns the EndpointReference associated with this BindingProvider instance.

getEndpointReference(Element...) - Method in class javax.xml.ws.Endpoint

Returns the EndpointReference associated with this Endpoint instance.

getEndpointReference(Class<T>, Element...) - Method in class javax.xml.ws.Endpoint

Returns the EndpointReference associated with this Endpoint instance.

getEndpointReference(Element...) - Method in interface javax.xml.ws.WebServiceContext

Returns the EndpointReference for this endpoint.

getEndpointReference(Class<T>, Element...) - Method in interface javax.xml.ws.WebServiceContext

Returns the EndpointReference associated with this endpoint.

getEndpoints() - Method in class javax.xml.ws.EndpointContext

This gives list of endpoints in an application.

getEndTime() - Method in interface javax.batch.runtime.JobExecution

Get time execution entered end status: COMPLETED, STOPPED, FAILED

getEndTime() - Method in interface javax.batch.runtime.StepExecution

Get time this step ended.

getEngineInfo() - Method in class javax.servlet.jsp.JspFactory

called to get implementation-specific information on the current JSP engine.

getEntities() - Method in interface javax.persistence.metamodel.Metamodel

Return the metamodel entity types.

getEntity() - Method in exception javax.persistence.OptimisticLockException

Returns the entity that caused this exception.

getEntity() - Method in exception javax.persistence.PessimisticLockException

Returns the entity that caused this exception.

getEntity() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the message entity Java instance.

getEntity() - Method in class javax.ws.rs.client.Entity

Get entity data.

getEntity() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the message entity Java instance.

getEntity() - Method in class javax.ws.rs.core.GenericEntity

Get the enclosed entity.

getEntity() - Method in class javax.ws.rs.core.Response

Get the message entity Java instance.

getEntity() - Method in interface javax.ws.rs.ext.WriterInterceptorContext

Get object to be written as HTTP entity.

getEntityAnnotations() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the annotations attached to the entity instance.

getEntityAnnotations() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the annotations attached to the entity instance.

getEntityClass() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the raw entity type information.

getEntityClass() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the raw entity type information.

getEntityGraph(String) - Method in interface javax.persistence.EntityManager

Return a named EntityGraph.

getEntityGraphs(Class<T>) - Method in interface javax.persistence.EntityManager

Return all named EntityGraphs that have been defined for the provided class type.

getEntityManagerFactory() - Method in interface javax.persistence.EntityManager

Return the entity manager factory for the entity manager.

getEntityStream() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the entity output stream.

getEntityStream() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the entity input stream.

getEntityStream() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get the entity input stream.

getEntityStream() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the entity output stream.

getEntityTag() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the entity tag.

getEntityTag() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the entity tag.

getEntityTag() - Method in class javax.ws.rs.core.Response

Get the entity tag.

getEntityType() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the generic entity type information.

getEntityType() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the generic entity type information.

getEntry(String) - Method in interface javax.enterprise.deploy.model.DeployableObject

Returns the InputStream for the given entry name The file name must be relative to the root of the module.

getEnumeration() - Method in interface javax.jms.QueueBrowser

Gets an enumeration for browsing the current queue messages in the order they would be received.

getEnumValueTable() - Method in class javax.enterprise.deploy.shared.ActionType

Returns the enumeration value table for class ActionType

getEnumValueTable() - Method in class javax.enterprise.deploy.shared.CommandType

Returns the enumeration value table for class CommandType

getEnumValueTable() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType

Returns the enumeration value table for class DConfigBeanVersionType

getEnumValueTable() - Method in class javax.enterprise.deploy.shared.ModuleType

Returns the enumeration value table for class ModuleType

getEnumValueTable() - Method in class javax.enterprise.deploy.shared.StateType

Returns the enumeration value table for class StateType

getEnvelope() - Method in class javax.xml.soap.SOAPPart

Gets the SOAPEnvelope object associated with this SOAPPart object.

getEnvironment() - Method in interface javax.ejb.EJBContext

Deprecated.
Use the JNDI naming context java:comp/env to access enterprise bean's environment.

getErrorClass() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the errorClass property.

getErrorClass() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the errorClass property.

getErrorCode() - Method in exception javax.jms.JMSException

Gets the vendor-specific error code.

getErrorCode() - Method in exception javax.jms.JMSRuntimeException

Returns the vendor-specific error code.

getErrorCode() - Method in exception javax.resource.ResourceException

Get the error code.

getErrorCode() - Method in exception javax.xml.bind.JAXBException

Get the vendor specific error code

getErrorCode() - Method in exception javax.xml.bind.TypeConstraintException

Get the vendor specific error code

getErrorData() - Method in class javax.servlet.jsp.PageContext

Provides convenient access to error information.

getErrorObjectKey() - Method in exception javax.xml.registry.RegistryException

Gets the Key to the first object that encountered an error in the registry.

getErrorOnUndeclaredNamespace() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the value of the error-on-undeclared-namespace configuration, which specifies whether an error will be raised at translation time if tag with an undeclared namespace is used in any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.

getErrorStyle() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the errorStyle property.

getErrorStyle() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the errorStyle property.

getEvaluationListeners() - Method in class javax.el.ELContext

Returns the list of registered evaluation listeners.

getEvent() - Method in class javax.faces.view.facelets.BehaviorHandler

getEventHandler() - Method in class javax.xml.bind.Binder

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getEventHandler() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in interface javax.xml.bind.Marshaller

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in interface javax.xml.bind.Unmarshaller

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

getEventName() - Method in class javax.faces.component.behavior.ClientBehaviorContext

Returns the name of the behavior event for which the ClientBehavior script is being requested.

getEventName() - Method in interface javax.faces.view.BehaviorHolderAttachedObjectHandler

Return the client event name to which this behavior applies.

getEventName() - Method in class javax.faces.view.facelets.BehaviorHandler

getEventNames() - Method in interface javax.faces.component.behavior.ClientBehaviorHolder

Returns a non-null, unmodifiable Collection containing the names of the logical events supported by the component implementing this interface.

getEventNames() - Method in class javax.faces.component.html.HtmlBody

getEventNames() - Method in class javax.faces.component.html.HtmlCommandButton

getEventNames() - Method in class javax.faces.component.html.HtmlCommandLink

getEventNames() - Method in class javax.faces.component.html.HtmlDataTable

getEventNames() - Method in class javax.faces.component.html.HtmlForm

getEventNames() - Method in class javax.faces.component.html.HtmlGraphicImage

getEventNames() - Method in class javax.faces.component.html.HtmlInputFile

getEventNames() - Method in class javax.faces.component.html.HtmlInputSecret

getEventNames() - Method in class javax.faces.component.html.HtmlInputText

getEventNames() - Method in class javax.faces.component.html.HtmlInputTextarea

getEventNames() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

getEventNames() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

getEventNames() - Method in class javax.faces.component.html.HtmlOutputLabel

getEventNames() - Method in class javax.faces.component.html.HtmlOutputLink

getEventNames() - Method in class javax.faces.component.html.HtmlPanelGrid

getEventNames() - Method in class javax.faces.component.html.HtmlPanelGroup

getEventNames() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

getEventNames() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

getEventNames() - Method in class javax.faces.component.html.HtmlSelectManyListbox

getEventNames() - Method in class javax.faces.component.html.HtmlSelectManyMenu

getEventNames() - Method in class javax.faces.component.html.HtmlSelectOneListbox

getEventNames() - Method in class javax.faces.component.html.HtmlSelectOneMenu

getEventNames() - Method in class javax.faces.component.html.HtmlSelectOneRadio

getEventNames() - Method in class javax.faces.component.UIComponentBase

This is a default implementation of ClientBehaviorHolder.getEventNames().

getEvents() - Method in class javax.xml.bind.util.ValidationEventCollector

Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.

getEventType() - Method in interface javax.xml.registry.infomodel.AuditableEvent

Gets the type of this event.

getException() - Method in interface javax.batch.runtime.context.StepContext

The getException method returns the last exception thrown from a step level batch artifact to the batch runtime.

getException() - Method in class javax.faces.event.ExceptionQueuedEventContext

Return the exception property.

getException() - Method in class javax.resource.spi.ConnectionEvent

Get the exception.

getException() - Method in class javax.resource.spi.work.WorkEvent

Return the WorkException.

getException() - Method in class javax.servlet.jsp.PageContext

The current value of the exception object (an Exception).

getException() - Method in class javax.websocket.SendResult

The problem sending the message.

getExceptionHandler() - Method in class javax.faces.context.ExceptionHandlerFactory

Create and return a A new ExceptionHandler instance.

getExceptionHandler() - Method in class javax.faces.context.FacesContext

Return the ExceptionHandler for this request.

getExceptionHandler() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getExceptionHandler() on the wrapped FacesContext object.

getExceptionHandler() - Method in class javax.faces.webapp.PreJsf2ExceptionHandlerFactory

getExceptionListener() - Method in interface javax.jms.Connection

Gets the ExceptionListener object for this connection.

getExceptionListener() - Method in interface javax.jms.JMSContext

Gets the ExceptionListener object for the JMSContext's connection.

getExceptionMapper(Class<T>) - Method in interface javax.ws.rs.ext.Providers

Get an exception mapping provider for a particular class of exception.

getExceptions() - Method in interface javax.xml.registry.BulkResponse

Get the Collection of RegistryException instances in case of partial commit.

getExecutableParameters() - Method in interface javax.validation.ConstraintViolation

Returns an Object[] representing the constructor or method invocation arguments if the ConstraintViolation is returned after validating the method or constructor parameters.

getExecutableReturnValue() - Method in interface javax.validation.ConstraintViolation

Returns the return value of the constructor or method invocation if the ConstraintViolation is returned after validating the method or constructor return value.

getExecute() - Method in class javax.faces.component.behavior.AjaxBehavior

Return a non-empty Collection<String> of component identifiers that will be used to identify components that should be processed during the execute phase of the request processing lifecycle.

getExecuteIds() - Method in class javax.faces.context.PartialViewContext

Return a Collection of client identifiers from the current request with the request parameter name PartialViewContext.PARTIAL_EXECUTE_PARAM_NAME.

getExecuteIds() - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.getExecuteIds() on the wrapped PartialViewContext object.

getExecutionId() - Method in interface javax.batch.runtime.context.JobContext

The getExecutionId method returns the current job's current execution id.

getExecutionId() - Method in interface javax.batch.runtime.JobExecution

Get unique id for this JobExecution.

getExecutionProperties(Object) - Method in interface javax.enterprise.concurrent.ContextService

Gets the current execution properties on the context proxy instance.

getExecutionProperties() - Method in interface javax.enterprise.concurrent.ManagedTask

Provides additional information to the ManagedExecutorService or ManagedScheduledExecutorService when executing this task.

getExecutor() - Method in class javax.xml.ws.Endpoint

Returns the executor for this Endpointinstance.

getExecutor() - Method in class javax.xml.ws.Service

Returns the executor for this Serviceinstance.

getExecutor() - Method in class javax.xml.ws.spi.ServiceDelegate

Returns the executor for this Serviceinstance.

getExitStatus() - Method in interface javax.batch.runtime.context.JobContext

The getExitStatus method simply returns the exit status value stored into the job context through the setExitStatus method or null.

getExitStatus() - Method in interface javax.batch.runtime.context.StepContext

The getExitStatus method simply returns the exit status value stored into the step context through the setExitStatus method or null.

getExitStatus() - Method in interface javax.batch.runtime.JobExecution

Get execution exit status.

getExitStatus() - Method in interface javax.batch.runtime.StepExecution

Get exit status of step.

getExpectedType() - Method in class javax.el.ValueExpression

Returns the type the result of the expression will be coerced to after evaluation.

getExpectedType() - Method in class javax.servlet.jsp.jstl.core.IndexedValueExpression

getExpectedType() - Method in class javax.servlet.jsp.jstl.core.IteratedValueExpression

getExpectedTypeName() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

Returns the name of the expected type (as a String) of this deferred value attribute.

getExpiration() - Method in interface javax.xml.registry.infomodel.RegistryEntry

Gets expirationDate attribute of the RegistryEntry within the Registry.

getExpiredMessageCount() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats

Number of messages that expired before delivery.

getExpiredMessageCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats

Number of expired messages.

getExpiry() - Method in class javax.ws.rs.core.NewCookie

Get the cookie expiry date.

getExpression(String) - Method in interface javax.faces.el.CompositeComponentExpressionHolder

getExpression() - Method in interface javax.persistence.criteria.CriteriaBuilder.In

Return the expression to be tested against the list of values.

getExpression() - Method in interface javax.persistence.criteria.CriteriaBuilder.SimpleCase

Return the expression to be tested against the conditions.

getExpression() - Method in interface javax.persistence.criteria.Order

Return the expression that is used for ordering.

getExpressionEvaluator() - Method in class javax.servlet.jsp.JspContext

Deprecated.
As of JSP 2.1, replaced by JspApplicationContext.getExpressionFactory()

getExpressionFactory() - Static method in class javax.el.ELManager

Return the ExpressionFactory instance used for EL evaluations.

getExpressionFactory() - Method in class javax.faces.application.Application

Return the ExpressionFactory instance for this application.

getExpressionFactory() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getExpressionFactory() on the wrapped Application object.

getExpressionFactory() - Method in class javax.faces.view.facelets.FaceletContext

The ExpressionFactory to use within the Facelet this context is executing upon.

getExpressionFactory() - Method in interface javax.servlet.jsp.JspApplicationContext

Returns a factory used to create ValueExpressions and MethodExpressions so that EL expressions can be parsed and evaluated.

getExpressions() - Method in interface javax.persistence.criteria.Predicate

Return the top-level conjuncts or disjuncts of the predicate.

getExpressionString() - Method in class javax.el.Expression

Returns the original String used to create this Expression, unmodified.

getExpressionString() - Method in class javax.faces.el.MethodBinding

Deprecated.

Return the (possibly null) expression String, with leading and trailing delimiters, from which this MethodBinding was built.

getExpressionString() - Method in class javax.faces.el.ValueBinding

Deprecated.

Return the (possibly null) expression String, including the delimiters, from which this ValueBinding was built.

getExpressionString() - Method in class javax.servlet.jsp.jstl.core.IndexedValueExpression

getExpressionString() - Method in class javax.servlet.jsp.jstl.core.IteratedValueExpression

getExtension(Class<T>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains the container's instance of an Extension class declared in META-INF/services.

getExtension() - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Gets the internal extension.

getExtensions() - Method in interface javax.websocket.ClientEndpointConfig

Return the extensions, in order of preference, favorite first, that this client would like to use for its sessions.

getExtensions() - Method in interface javax.websocket.server.ServerEndpointConfig

Return the websocket extensions configured.

getExternalContext(Object, Object, Object) - Method in class javax.faces.context.ExternalContextFactory

Create (if needed) and return an ExternalContext instance that is initialized for the processing of the specified request and response objects, for this web application.

getExternalContext() - Method in class javax.faces.context.FacesContext

Return the ExternalContext instance for this FacesContext instance.

getExternalContext() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getExternalContext() on the wrapped FacesContext object.

getExternalIdentifiers() - Method in interface javax.xml.registry.infomodel.RegistryObject

Returns the ExternalIdentifiers associated with this object that are external identifiers for this object.

getExternalLinks() - Method in interface javax.xml.registry.infomodel.RegistryObject

Returns the ExternalLinks associated with this object.

getExternalURI() - Method in interface javax.xml.registry.infomodel.ExternalLink

Gets URI to the an external resource.

getFacelet(URL) - Method in class javax.faces.view.facelets.FaceletCache

Returns a cached Facelet instance.

getFaceletCache() - Method in class javax.faces.view.facelets.FaceletCacheFactory

getFacesContext() - Method in class javax.faces.component.behavior.ClientBehaviorContext

Returns the FacesContext for the current request.

getFacesContext() - Method in class javax.faces.component.UIComponent

Convenience method to return the FacesContext instance for the current request.

getFacesContext() - Method in class javax.faces.component.UIComponentBase

getFacesContext() - Method in class javax.faces.component.visit.VisitContext

Returns the FacesContext for the current request.

getFacesContext() - Method in class javax.faces.component.visit.VisitContextWrapper

getFacesContext(Object, Object, Object, Lifecycle) - Method in class javax.faces.context.FacesContextFactory

Create (if needed) and return a FacesContext instance that is initialized for the processing of the specified request and response objects, utilizing the specified Lifecycle instance, for this web application.

getFacesContext() - Method in class javax.faces.event.PhaseEvent

Return the FacesContext for the request being processed.

getFacesContext() - Method in class javax.faces.view.facelets.FaceletContext

The current FacesContext bound to this "request".

getFacesContext() - Method in class javax.faces.webapp.UIComponentClassicTagBase

getFacesContext() - Method in class javax.faces.webapp.UIComponentTagBase

Return the FacesContext instance for the current request.

getFacesJspId() - Method in class javax.faces.webapp.UIComponentClassicTagBase

If this method has been called before on this tag's useful lifetime (before UIComponentClassicTagBase.release() was called), return the previously returned value.

getFacesListeners(Class) - Method in class javax.faces.component.UIComponent

Return an array of registered FacesListeners that are instances of the specified class.

getFacesListeners(Class) - Method in class javax.faces.component.UIComponentBase

getFacesMessage() - Method in exception javax.faces.component.UpdateModelException

Return the FacesMessage passed to the constructor.

getFacesMessage() - Method in exception javax.faces.convert.ConverterException

Returns the FacesMessage associated with this exception; this will only be available if the converter that thew this exception instance placed it there.

getFacesMessage() - Method in exception javax.faces.validator.ValidatorException

Returns the FacesMessage associated with the exception.

getFacesMessages() - Method in exception javax.faces.validator.ValidatorException

If this instance was created with a constructor that takes Collection<FacesMessage>, this method returns the passed collection, otherwise this method returns null.

getFacet(String) - Method in class javax.faces.component.UIComponent

Convenience method to return the named facet, if it exists, or null otherwise.

getFacet(String) - Method in class javax.faces.component.UIComponentBase

getFacetCount() - Method in class javax.faces.component.UIComponent

Return the number of facet UIComponents that are associated with this UIComponent.

getFacetCount() - Method in class javax.faces.component.UIComponentBase

getFacetName(FaceletContext) - Method in interface javax.faces.view.facelets.FacetHandler

Returns the resolved literal String value of the facet name after evaluating EL.

getFacetName() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Return the facet name that we should be stored under, if any; otherwise, return null (indicating that we will be a child component).

getFacets() - Method in class javax.faces.component.UIComponent

Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String).

getFacets() - Method in class javax.faces.component.UIComponentBase

getFacetsAndChildren() - Method in class javax.faces.component.UIComponent

Return an Iterator over the facet followed by child UIComponents of this UIComponent.

getFacetsAndChildren() - Method in class javax.faces.component.UIComponentBase

getFactory(String) - Static method in class javax.faces.FactoryFinder

Create (if necessary) and return a per-web-application instance of the appropriate implementation class for the specified JavaServer Faces factory class, based on the discovery algorithm described in the class description.

getFactory() - Static method in class javax.security.auth.message.config.AuthConfigFactory

Get the system-wide AuthConfigFactory implementation.

getFactorySecurityPermission - Static variable in class javax.security.auth.message.config.AuthConfigFactory

The SecurityPermission, with name AuthConfigFactory.GET_FACTORY_PERMISSION_NAME, that is used to authorize access to the getFactory method.

getFamily() - Method in class javax.faces.component.UIColumn

getFamily() - Method in class javax.faces.component.UICommand

getFamily() - Method in class javax.faces.component.UIComponent

Return the identifier of the component family to which this component belongs.

getFamily() - Method in class javax.faces.component.UIData

getFamily() - Method in class javax.faces.component.UIForm

getFamily() - Method in class javax.faces.component.UIGraphic

getFamily() - Method in class javax.faces.component.UIInput

getFamily() - Method in class javax.faces.component.UIMessage

getFamily() - Method in class javax.faces.component.UIMessages

getFamily() - Method in class javax.faces.component.UINamingContainer

getFamily() - Method in class javax.faces.component.UIOutcomeTarget

getFamily() - Method in class javax.faces.component.UIOutput

getFamily() - Method in class javax.faces.component.UIPanel

getFamily() - Method in class javax.faces.component.UIParameter

getFamily() - Method in class javax.faces.component.UISelectBoolean

getFamily() - Method in class javax.faces.component.UISelectItem

getFamily() - Method in class javax.faces.component.UISelectItems

getFamily() - Method in class javax.faces.component.UISelectMany

getFamily() - Method in class javax.faces.component.UISelectOne

getFamily() - Method in class javax.faces.component.UIViewAction

getFamily() - Method in class javax.faces.component.UIViewParameter

getFamily() - Method in class javax.faces.component.UIViewRoot

getFamily() - Method in enum javax.ws.rs.core.Response.Status

Get the class of status code.

getFamily() - Method in interface javax.ws.rs.core.Response.StatusType

Get the class of status code.

getFatalClass() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the fatalClass property.

getFatalClass() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the fatalClass property.

getFatalStyle() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the fatalStyle property.

getFatalStyle() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the fatalStyle property.

getFault() - Method in interface javax.xml.soap.SOAPBody

Returns the SOAPFault object in this SOAPBody object.

getFault() - Method in exception javax.xml.ws.soap.SOAPFaultException

Gets the embedded SOAPFault instance.

getFaultActor() - Method in exception javax.xml.rpc.soap.SOAPFaultException

Gets the faultactor element.

getFaultActor() - Method in interface javax.xml.soap.SOAPFault

Gets the fault actor for this SOAPFault object.

getFaultCode() - Method in exception javax.xml.rpc.soap.SOAPFaultException

Gets the faultcode element.

getFaultCode() - Method in interface javax.xml.soap.SOAPFault

Gets the fault code for this SOAPFault object.

getFaultCodeAsName() - Method in interface javax.xml.soap.SOAPFault

Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.

getFaultCodeAsQName() - Method in interface javax.xml.soap.SOAPFault

Gets the fault code for this SOAPFault object as a QName object.

getFaultNode() - Method in interface javax.xml.soap.SOAPFault

Returns the optional Node element value for this SOAPFault object.

getFaultReasonLocales() - Method in interface javax.xml.soap.SOAPFault

Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.

getFaultReasonText(Locale) - Method in interface javax.xml.soap.SOAPFault

Returns the Reason Text associated with the given Locale.

getFaultReasonTexts() - Method in interface javax.xml.soap.SOAPFault

Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.

getFaultRole() - Method in interface javax.xml.soap.SOAPFault

Returns the optional Role element value for this SOAPFault object.

getFaultString() - Method in exception javax.xml.rpc.soap.SOAPFaultException

Gets the faultstring element.

getFaultString() - Method in interface javax.xml.soap.SOAPFault

Gets the fault string for this SOAPFault object.

getFaultStringLocale() - Method in interface javax.xml.soap.SOAPFault

Gets the locale of the fault string for this SOAPFault object.

getFaultSubcodes() - Method in interface javax.xml.soap.SOAPFault

Gets the Subcodes for this SOAPFault as an iterator over QNames.

getFeatureDescriptors(ELContext, Object) - Method in class javax.el.ArrayELResolver

Always returns null, since there is no reason to iterate through set set of all integers.

getFeatureDescriptors(ELContext, Object) - Method in class javax.el.BeanELResolver

If the base object is not null, returns an Iterator containing the set of JavaBeans properties available on the given object.

getFeatureDescriptors(ELContext, Object) - Method in class javax.el.BeanNameELResolver

Always returns null, since there is no reason to iterate through a list of one element: bean name.

getFeatureDescriptors(ELContext, Object) - Method in class javax.el.CompositeELResolver

Returns information about the set of variables or properties that can be resolved for the given base object.

getFeatureDescriptors(ELContext, Object) - Method in class javax.el.ELResolver

Returns information about the set of variables or properties that can be resolved for the given base object.

getFeatureDescriptors(ELContext, Object) - Method in class javax.el.ListELResolver

Always returns null, since there is no reason to iterate through set set of all integers.

getFeatureDescriptors(ELContext, Object) - Method in class javax.el.MapELResolver

If the base object is a map, returns an Iterator containing the set of keys available in the Map.

getFeatureDescriptors(ELContext, Object) - Method in class javax.el.ResourceBundleELResolver

If the base object is a ResourceBundle, returns an Iterator containing the set of keys available in the ResourceBundle.

getFeatureDescriptors(ELContext, Object) - Method in class javax.el.StaticFieldELResolver

Returns the properties that can be resolved.

getFeatureDescriptors(ELContext, Object) - Method in class javax.el.TypeConverter

getFeatureDescriptors(ELContext, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver

If the base object is null, and the property matches the name of a JSP implicit object, returns an Iterator containing FeatureDescriptor objects with information about each JSP implicit object resolved by this resolver.

getFeatureDescriptors(ELContext, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver

If the base object is null, returns an Iterator containing FeatureDescriptor objects with information about each scoped attribute resolved by this resolver.

getFetches() - Method in interface javax.persistence.criteria.FetchParent

Return the fetch joins that have been made from this type.

getFields() - Method in interface javax.enterprise.inject.spi.AnnotatedType

Get the fields of the type.

getFile() - Method in class javax.mail.URLName

Returns the file name of this URLName.

getFilename() - Method in interface javax.enterprise.deploy.model.DDBeanRoot

Returns the filename relative to the root of the module of the XML instance document this DDBeanRoot represents.

getFileName() - Method in class javax.mail.internet.MimeBodyPart

Get the filename associated with this body part.

getFileName() - Method in class javax.mail.internet.MimeMessage

Get the filename associated with this Message.

getFileName() - Method in interface javax.mail.Part

Get the filename associated with this part, if possible.

getFileSizeThreshold() - Method in class javax.servlet.MultipartConfigElement

Gets the size threshold after which files will be written to disk.

getFilterName() - Method in interface javax.servlet.FilterConfig

Returns the filter-name of this filter as defined in the deployment descriptor.

getFilterRegistration(String) - Method in interface javax.servlet.ServletContext

Gets the FilterRegistration corresponding to the filter with the given filterName.

getFilterRegistrations() - Method in interface javax.servlet.ServletContext

Gets a (possibly empty) Map of the FilterRegistration objects (keyed by filter name) corresponding to all filters registered with this ServletContext.

getFinalizer() - Method in class javax.faces.flow.Flow

Return the MethodExpression that must be called by the runtime as the last thing that happens before exiting this flow.

getFirst() - Method in class javax.faces.component.UIData

Return the zero-relative row number of the first row to be displayed.

getFirst(K) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

getFirst(K) - Method in interface javax.ws.rs.core.MultivaluedMap

A shortcut to get the first value of the supplied key.

getFirstName() - Method in interface javax.xml.registry.infomodel.PersonName

Gets the first name for this Person.

getFirstResult() - Method in interface javax.persistence.Query

The position of the first result the query object was set to retrieve.

getFlags() - Method in class javax.mail.internet.MimeMessage

Return a Flags object containing the flags for this message.

getFlags() - Method in class javax.mail.Message

Returns a Flags object containing the flags for this message.

getFlags() - Method in class javax.mail.search.FlagTerm

Return the Flags to test.

getFlash() - Method in class javax.faces.context.ExternalContext

Return the threadsafe Flash for this application.

getFlash() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getFlash() on the wrapped ExternalContext object.

getFlash(boolean) - Method in class javax.faces.context.FlashFactory

Create (if needed) and return a Flash instance for this web application.

getFloat(String) - Method in interface javax.jms.MapMessage

Returns the float value with the specified name.

getFloatProperty(String) - Method in interface javax.jms.JMSProducer

Returns the message property with the specified name that has been set on this JMSProducer, converted to a float.

getFloatProperty(String) - Method in interface javax.jms.Message

Returns the value of the float property with the specified name.

getFlow() - Method in class javax.faces.flow.builder.FlowBuilder

Called as the last step in flow definition, this method must perform any implementation specific initialization and return the built Flow.

getFlow(FacesContext, String, String) - Method in class javax.faces.flow.FlowHandler

Return the Flow whose id is equivalent to the argument id, within the scope of the argument definingDocument.

getFlowCall(Flow) - Method in class javax.faces.flow.Flow

Return the FlowCallNode that represents calling the targetFlow from this flow, or null if targetFlow cannot be reached from this flow.

getFlowCalls() - Method in class javax.faces.flow.Flow

Return an immutable data structure containing all the flow call nodes declared for this flow.

getFlowHandler() - Method in class javax.faces.application.Application

Return the thread-safe singleton FlowHandler for this application.

getFlowHandler() - Method in class javax.faces.application.ApplicationWrapper

getFlushMode() - Method in interface javax.persistence.EntityManager

Get the flush mode that applies to all objects contained in the persistence context.

getFlushMode() - Method in interface javax.persistence.Query

Get the flush mode in effect for the query execution.

getFolder() - Method in class javax.mail.event.FolderEvent

Return the affected folder.

getFolder(String) - Method in class javax.mail.Folder

Return the Folder object corresponding to the given name.

getFolder() - Method in exception javax.mail.FolderClosedException

Returns the dead Folder object

getFolder() - Method in exception javax.mail.FolderNotFoundException

Returns the offending Folder object.

getFolder() - Method in class javax.mail.Message

Get the folder from which this message was obtained.

getFolder() - Method in exception javax.mail.ReadOnlyFolderException

Returns the dead Folder object.

getFolder(URLName) - Method in class javax.mail.Session

Get a closed Folder object for the given URLName.

getFolder(String) - Method in class javax.mail.Store

Return the Folder object corresponding to the given name.

getFolder(URLName) - Method in class javax.mail.Store

Return a closed Folder object, corresponding to the given URLName.

getFooter() - Method in class javax.faces.component.UIColumn

Return the footer facet of the column (if any).

getFooter() - Method in class javax.faces.component.UIData

Return the footer facet of this component (if any).

getFooterClass() - Method in class javax.faces.component.html.HtmlColumn

Return the value of the footerClass property.

getFooterClass() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the footerClass property.

getFooterClass() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the footerClass property.

getFor() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the for property.

getFor() - Method in class javax.faces.component.UIMessage

Return the Identifier of the component for which to render error messages.

getFor() - Method in class javax.faces.component.UIMessages

Return the client identifier of the component for which this component represents associated message(s) (if any).

getFor() - Method in interface javax.faces.view.AttachedObjectHandler

Return the value of the "for" attribute specified by the page author on the tag for this AttachedObjectHandler.

getFor() - Method in class javax.faces.view.facelets.FaceletsAttachedObjectHandler

Return the value of the "for" attribute.

getFormatId() - Method in interface javax.transaction.xa.Xid

Obtain the format identifier part of the XID.

getFragment() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the fragment property.

getFrame() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the frame property.

getFrame() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the frame property.

getFreePoolSize() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats

The number of free connections in the pool

getFreePoolSize() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats

Number of free connections in the pool.

getFrom() - Method in class javax.mail.internet.MimeMessage

Returns the value of the RFC 822 "From" header fields.

getFrom() - Method in class javax.mail.Message

Returns the "From" attribute.

getFrom() - Method in interface javax.validation.metadata.GroupConversionDescriptor

Returns the source group of this conversion rule.

getFromAction() - Method in class javax.faces.application.NavigationCase

Return the <from-action> for this <navigation-case>

getFromAction() - Method in class javax.faces.application.NavigationCaseWrapper

getFromOutcome() - Method in class javax.faces.application.NavigationCase

Return the <from-outcome> for this <navigation-case>

getFromOutcome() - Method in class javax.faces.application.NavigationCaseWrapper

getFromOutcome(FacesContext) - Method in class javax.faces.flow.ReturnNode

Return the fromOutcome to be used when control passes to this return node.

getFromOutcome() - Method in class javax.faces.flow.SwitchCase

Return the outcome to be used if SwitchCase.getCondition(javax.faces.context.FacesContext) return true.

getFromViewId() - Method in class javax.faces.application.NavigationCase

Return the <from-view-id> of the <navigation-rule> inside which this <navigation-case> is nested.

getFromViewId() - Method in class javax.faces.application.NavigationCaseWrapper

getFullName() - Method in class javax.mail.Folder

Returns the full name of this Folder.

getFullName() - Method in interface javax.xml.registry.infomodel.PersonName

Gets the fully formatted name for this person.

getFunction(String) - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

Get the FunctionInfo for a given function name, looking through all the functions in this tag library.

getFunctionClass() - Method in class javax.servlet.jsp.tagext.FunctionInfo

The class of the function.

getFunctionMapper() - Method in class javax.el.ELContext

Retrieves the FunctionMapper associated with this ELContext.

getFunctionMapper() - Method in class javax.el.StandardELContext

Construct (if needed) and return a default FunctionMapper.

getFunctions() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

An array describing the functions that are defined in this tag library.

getFunctionSignature() - Method in class javax.servlet.jsp.tagext.FunctionInfo

The signature of the function.

getGenericType() - Method in interface javax.ws.rs.ext.InterceptorContext

Get the type of the object to be produced or written.

getGlobalTransactionId() - Method in interface javax.transaction.xa.Xid

Obtain the global transaction identifier part of XID as an array of bytes.

getGroup(boolean) - Method in class javax.mail.internet.InternetAddress

Return the members of a group address.

getGroupConversions() - Method in interface javax.validation.metadata.CascadableDescriptor

Returns the group conversions configured for this element.

getGroupList() - Method in interface javax.persistence.criteria.AbstractQuery

Return a list of the grouping expressions.

getGroupRestriction() - Method in interface javax.persistence.criteria.AbstractQuery

Return the predicate that corresponds to the restriction(s) over the grouping items, or null if no restrictions have been specified.

getGroups() - Method in class javax.security.auth.message.callback.GroupPrincipalCallback

Get the array of group names.

getGroups() - Method in interface javax.validation.metadata.ConstraintDescriptor

The set of groups the constraint is applied on.

getHandle() - Method in interface javax.ejb.EJBObject

Obtain a handle for the EJB object.

getHandle() - Method in interface javax.ejb.Timer

Get a serializable handle to the timer.

getHandledExceptionQueuedEvent() - Method in class javax.faces.context.ExceptionHandler

Return the first ExceptionQueuedEvent handled by this handler.

getHandledExceptionQueuedEvent() - Method in class javax.faces.context.ExceptionHandlerWrapper

The default behavior of this method is to call ExceptionHandler.getHandledExceptionQueuedEvent() on the wrapped ExceptionHandler object.

getHandledExceptionQueuedEvents() - Method in class javax.faces.context.ExceptionHandler

The default implementation must return an Iterable over all ExceptionQueuedEvents that have been handled by the ExceptionHandler.handle() method.

getHandledExceptionQueuedEvents() - Method in class javax.faces.context.ExceptionHandlerWrapper

The default behavior of this method is to call ExceptionHandler.getHandledExceptionQueuedEvents() on the wrapped ExceptionHandler object.

getHandlerChain(QName) - Method in interface javax.xml.rpc.handler.HandlerRegistry

Gets the handler chain for the specified service endpoint.

getHandlerChain() - Method in interface javax.xml.ws.Binding

Gets a copy of the handler chain for a protocol binding instance.

getHandlerChain(PortInfo) - Method in interface javax.xml.ws.handler.HandlerResolver

Gets the handler chain for the specified port.

getHandlerClass() - Method in class javax.xml.rpc.handler.HandlerInfo

Gets the Handler class

getHandlerConfig() - Method in class javax.xml.rpc.handler.HandlerInfo

Gets the Handler configuration

getHandlerKeys() - Static method in class javax.security.jacc.PolicyContext

This method may be used to obtain the keys that identify the container specific context handlers registered by the container.

getHandlerRegistry() - Method in interface javax.xml.rpc.Service

Returns the configured HandlerRegistry instance for this Service instance.

getHandlerResolver() - Method in class javax.xml.ws.Service

Returns the configured handler resolver.

getHandlerResolver() - Method in class javax.xml.ws.spi.ServiceDelegate

Returns the configured handler resolver.

getHandlers() - Method in class javax.faces.view.facelets.CompositeFaceletHandler

Returns the array of child handlers contained by this handler.

getHeader() - Method in class javax.faces.component.UIColumn

Return the header facet of the column (if any).

getHeader() - Method in class javax.faces.component.UIData

Return the header facet of this component (if any).

getHeader(String) - Method in class javax.mail.internet.InternetHeaders

Return all the values for the specified header.

getHeader(String, String) - Method in class javax.mail.internet.InternetHeaders

Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.

getHeader(String) - Method in class javax.mail.internet.MimeBodyPart

Get all the headers for this header_name.

getHeader(String, String) - Method in class javax.mail.internet.MimeBodyPart

Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.

getHeader(String) - Method in class javax.mail.internet.MimeMessage

Get all the headers for this header_name.

getHeader(String, String) - Method in class javax.mail.internet.MimeMessage

Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.

getHeader(String, String) - Method in interface javax.mail.internet.MimePart

Get the values of all header fields available for this header, returned as a single String, with the values separated by the delimiter.

getHeader(String) - Method in interface javax.mail.Part

Get all the headers for this header name.

getHeader(String) - Method in interface javax.servlet.http.HttpServletRequest

Returns the value of the specified request header as a String.

getHeader(String) - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getHeader(String name) on the wrapped request object.

getHeader(String) - Method in interface javax.servlet.http.HttpServletResponse

Gets the value of the response header with the given name.

getHeader(String) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behaviour of this method is to call HttpServletResponse.getHeader(java.lang.String) on the wrapped response object.

getHeader(String) - Method in interface javax.servlet.http.Part

Returns the value of the specified mime header as a String.

getHeader(String) - Method in class javax.xml.soap.MimeHeaders

Returns all of the values for the specified header as an array of String objects.

getHeader() - Method in interface javax.xml.soap.SOAPEnvelope

Returns the SOAPHeader object for this SOAPEnvelope object.

getHeaderClass() - Method in class javax.faces.component.html.HtmlColumn

Return the value of the headerClass property.

getHeaderClass() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the headerClass property.

getHeaderClass() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the headerClass property.

getHeaderName() - Method in class javax.mail.search.HeaderTerm

Return the name of the header to compare with.

getHeaderNames() - Method in class javax.mail.FetchProfile

Get the names of the header-fields set in this profile.

getHeaderNames() - Method in interface javax.servlet.http.HttpServletRequest

Returns an enumeration of all the header names this request contains.

getHeaderNames() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getHeaderNames() on the wrapped request object.

getHeaderNames() - Method in interface javax.servlet.http.HttpServletResponse

Gets the names of the headers of this response.

getHeaderNames() - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behaviour of this method is to call HttpServletResponse.getHeaderNames() on the wrapped response object.

getHeaderNames() - Method in interface javax.servlet.http.Part

Gets the header names of this Part.

getHeaders(String) - Method in interface javax.servlet.http.HttpServletRequest

Returns all the values of the specified request header as an Enumeration of String objects.

getHeaders(String) - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getHeaders(String name) on the wrapped request object.

getHeaders(String) - Method in interface javax.servlet.http.HttpServletResponse

Gets the values of the response header with the given name.

getHeaders(String) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behaviour of this method is to call HttpServletResponse.getHeaders(java.lang.String) on the wrapped response object.

getHeaders(String) - Method in interface javax.servlet.http.Part

Gets the values of the Part header with the given name.

getHeaders() - Method in interface javax.websocket.HandshakeResponse

Return the list of Http headers sent by the web socket server.

getHeaders() - Method in interface javax.websocket.server.HandshakeRequest

Return the read only Map of Http Headers that came with the handshake request.

getHeaders() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the mutable request headers multivalued map.

getHeaders() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the mutable response headers multivalued map.

getHeaders() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get the mutable request headers multivalued map.

getHeaders() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the mutable response headers multivalued map.

getHeaders() - Method in class javax.ws.rs.core.Response

Get view of the response headers and their object values.

getHeaders() - Method in interface javax.ws.rs.ext.ReaderInterceptorContext

Get mutable map of HTTP headers.

getHeaders() - Method in interface javax.ws.rs.ext.WriterInterceptorContext

Get mutable map of HTTP headers.

getHeaders() - Method in class javax.xml.rpc.handler.GenericHandler

Gets the header blocks processed by this Handler instance.

getHeaders() - Method in interface javax.xml.rpc.handler.Handler

Gets the header blocks that can be processed by this Handler instance.

getHeaders() - Method in class javax.xml.rpc.handler.HandlerInfo

Gets the header blocks processed by this Handler.

getHeaders() - Method in interface javax.xml.ws.handler.soap.SOAPHandler

Gets the header blocks that can be processed by this Handler instance.

getHeaders(QName, JAXBContext, boolean) - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Gets headers that have a particular qualified name from the message in the message context.

getHeaderString(String) - Method in interface javax.ws.rs.client.ClientRequestContext

Get a message header as a single string value.

getHeaderString(String) - Method in interface javax.ws.rs.client.ClientResponseContext

Get a message header as a single string value.

getHeaderString(String) - Method in interface javax.ws.rs.container.ContainerRequestContext

Get a message header as a single string value.

getHeaderString(String) - Method in interface javax.ws.rs.container.ContainerResponseContext

Get a message header as a single string value.

getHeaderString(String) - Method in interface javax.ws.rs.core.HttpHeaders

Get a HTTP header as a single string value.

getHeaderString(String) - Method in class javax.ws.rs.core.Response

Get a message header as a single string value.

getHeapSize() - Method in interface javax.management.j2ee.statistics.JVMStats

Size of the JVM's heap.

getHeight() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the height property.

getHighWaterMark() - Method in interface javax.management.j2ee.statistics.RangeStatistic

The highest value this attribute has held since the beginning of the measurement.

getHints() - Method in class javax.faces.component.behavior.AjaxBehavior

This method returns an unmodifiable Set containing the ClientBehaviorHint SUBMITTING.

getHints() - Method in interface javax.faces.component.behavior.ClientBehavior

Returns hints that describe the behavior of the ClientBehavior implementation.

getHints() - Method in class javax.faces.component.behavior.ClientBehaviorBase

Default implementation of ClientBehavior.getHints().

getHints() - Method in class javax.faces.component.visit.VisitContext

Returns hints that influence the behavior of the tree visit.

getHints() - Method in class javax.faces.component.visit.VisitContextWrapper

getHints() - Method in interface javax.persistence.Query

Get the properties and hints and associated values that are in effect for the query instance.

getHints() - Method in class javax.resource.spi.work.HintsContext

getHomeHandle() - Method in interface javax.ejb.EJBHome

Obtain a handle for the remote home object.

getHomeInterfaceClass() - Method in interface javax.ejb.EJBMetaData

Obtain the class object for the enterprise bean's remote home interface.

getHost() - Method in class javax.mail.internet.NewsAddress

Get the host.

getHost() - Method in class javax.mail.URLName

Returns the host of this URLName.

getHostnameVerifier() - Method in interface javax.ws.rs.client.Client

Get the hostname verifier configured in the client or null in case no hostname verifier has been configured.

getHour() - Method in class javax.ejb.ScheduleExpression

Return the value of the hour attribute.

getHreflang() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the hreflang property.

getHreflang() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the hreflang property.

getHreflang() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the hreflang property.

getHttpContext() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a HttpContext for this exchange.

getHttpMethodConstraints() - Method in class javax.servlet.ServletSecurityElement

Gets the (possibly empty) collection of HTTP Method specific constraint elements.

getHttpSession() - Method in interface javax.websocket.server.HandshakeRequest

Return a reference to the HttpSession that the web socket handshake that started this conversation was part of, if the implementation is part of a Java EE web container.

getHttpSession() - Method in interface javax.xml.rpc.server.ServletEndpointContext

The getHttpSession method returns the current HTTP session (as a javax.servlet.http.HTTPSession).

getId() - Method in interface javax.enterprise.context.Conversation

Get the identifier of the current long-running conversation.

getId() - Method in interface javax.enterprise.deploy.model.DDBean

Returns a tool-specific reference for attribute ID on an element in the deployment descriptor.

getId() - Method in interface javax.enterprise.inject.spi.PassivationCapable

A string that uniquely identifies the instance of Bean or Contextual.

getId() - Method in class javax.faces.component.UIComponent

Return the component identifier of this UIComponent.

getId() - Method in class javax.faces.component.UIComponentBase

getId() - Method in class javax.faces.flow.Flow

Return the immutable id for this Flow.

getId() - Method in class javax.faces.flow.FlowNode

getId() - Method in class javax.faces.lifecycle.ClientWindow

Return a String value that uniquely identifies this ClientWindow within the scope of the current session.

getId() - Method in class javax.faces.lifecycle.ClientWindowWrapper

getId() - Method in class javax.faces.view.ViewDeclarationLanguage

Returns a non-null String that can be used to identify this view declaration language.

getId() - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

getId() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Return the id value assigned by the page author.

getId(Class<Y>) - Method in interface javax.persistence.metamodel.IdentifiableType

Return the attribute that corresponds to the id attribute of the entity or mapped superclass.

getId() - Method in class javax.resource.spi.ConnectionEvent

Get the type of event

getID() - Method in interface javax.security.auth.message.MessagePolicy.ProtectionPolicy

Get the ProtectionPolicy identifier.

getId() - Method in interface javax.servlet.http.HttpSession

Returns a string containing the unique identifier assigned to this session.

getId() - Method in class javax.servlet.jsp.tagext.TagData

The value of the tag's id attribute.

getId() - Method in class javax.servlet.jsp.tagext.TagSupport

The value of the id attribute of this tag; or null.

getId() - Method in class javax.servlet.jsp.tagext.ValidationMessage

Get the jsp:id.

getId() - Method in interface javax.websocket.Session

Returns a string containing the unique identifier assigned to this session.

getId() - Method in interface javax.xml.registry.infomodel.Key

Returns the unique Id of this key.

getID() - Method in class javax.xml.ws.RespectBindingFeature

Get the unique identifier for this WebServiceFeature.

getID() - Method in class javax.xml.ws.soap.AddressingFeature

Get the unique identifier for this WebServiceFeature.

getID() - Method in class javax.xml.ws.soap.MTOMFeature

Get the unique identifier for this WebServiceFeature.

getID() - Method in class javax.xml.ws.WebServiceFeature

Get the unique identifier for this WebServiceFeature.

getIdAttribute(TagAttributeInfo[]) - Static method in class javax.servlet.jsp.tagext.TagAttributeInfo

Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".

getIdClassAttributes() - Method in interface javax.persistence.metamodel.IdentifiableType

Return the attributes corresponding to the id class of the identifiable type.

getIdentificationScheme() - Method in interface javax.xml.registry.infomodel.ExternalIdentifier

Gets the ClassificationScheme that is used as the identification scheme for identifying this object.

getIdentifier(Object) - Method in interface javax.persistence.PersistenceUnitUtil

Return the id of the entity.

getIdentityName() - Method in interface javax.enterprise.concurrent.LastExecution

The name or ID of the identifiable object, as specified in the ManagedTask.IDENTITY_NAME execution property of the task if it also implements the ManagedTask interface.

getIds() - Method in interface javax.servlet.http.HttpSessionContext

Deprecated.
As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.

getIdsToVisit() - Method in class javax.faces.component.visit.VisitContext

Returns the ids of the components to visit.

getIdsToVisit() - Method in class javax.faces.component.visit.VisitContextWrapper

getIdType() - Method in interface javax.persistence.metamodel.IdentifiableType

Return the type that represents the type of the id.

getIgnoreCase() - Method in class javax.mail.search.StringTerm

Return true if we should ignore case when matching.

getImage() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the image property.

getImage() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the image property.

getImplementor() - Method in class javax.xml.ws.Endpoint

Returns the implementation object for this endpoint.

getImportHandler() - Method in class javax.el.ELContext

Retrieves the ImportHandler associated with this ELContext.

getInboundParameters() - Method in class javax.faces.flow.Flow

Return an immutable data structure containing the inbound parameters that have been declared for this flow.

getIncludeCodas() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the include-coda configuration of the JSP property group represented by this JspPropertyGroupDescriptor.

getIncludePreludes() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the include-prelude configuration of the JSP property group represented by this JspPropertyGroupDescriptor.

getIndex() - Method in interface javax.servlet.jsp.jstl.core.LoopTagStatus

Retrieves the index of the current round of the iteration.

getIndex() - Method in interface javax.validation.metadata.ParameterDescriptor

Returns this parameter's index within the parameter array of the method or constructor holding it.

getIndex() - Method in interface javax.validation.Path.Node

getIndexOfNextChildTag() - Method in class javax.faces.webapp.UIComponentClassicTagBase

getIndexOfNextChildTag() - Method in class javax.faces.webapp.UIComponentTagBase

Return the index of the next child to be added as a child of this tag.

getInfo() - Method in interface javax.ejb.Timer

Get the information associated with the timer at the time of creation.

getInfo() - Method in class javax.ejb.TimerConfig

Return the info object made available to timer callbacks.

getInfoClass() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the infoClass property.

getInfoClass() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the infoClass property.

getInfoString() - Method in class javax.servlet.jsp.tagext.TagInfo

The information string for the tag.

getInfoString() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

Information (documentation) for this TLD.

getInfoStyle() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the infoStyle property.

getInfoStyle() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the infoStyle property.

getInitFunctionMap() - Method in class javax.el.ExpressionFactory

Retrieve a function map containing a pre-configured function mapping.

getInitializer() - Method in class javax.faces.flow.Flow

Return the MethodExpression that must be called by the runtime immediately after activating any FlowScoped beans declared for this flow.

getInitParameter(String) - Method in class javax.faces.context.ExternalContext

Return the value of the specified application initialization parameter (if any).

getInitParameter(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getInitParameter(String) on the wrapped ExternalContext object.

getInitParameter(String) - Method in interface javax.servlet.FilterConfig

Returns a String containing the value of the named initialization parameter, or null if the initialization parameter does not exist.

getInitParameter(String) - Method in class javax.servlet.GenericServlet

Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.

getInitParameter(String) - Method in interface javax.servlet.Registration

Gets the value of the initialization parameter with the given name that will be used to initialize the Servlet or Filter represented by this Registration object.

getInitParameter(String) - Method in interface javax.servlet.ServletConfig

Gets the value of the initialization parameter with the given name.

getInitParameter(String) - Method in interface javax.servlet.ServletContext

Returns a String containing the value of the named context-wide initialization parameter, or null if the parameter does not exist.

getInitParameterMap() - Method in class javax.faces.context.ExternalContext

Return an immutable Map whose keys are the set of application initialization parameter names configured for this application, and whose values are the corresponding parameter values.

getInitParameterMap() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getInitParameterMap() on the wrapped ExternalContext object.

getInitParameterNames() - Method in interface javax.servlet.FilterConfig

Returns the names of the filter's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the filter has no initialization parameters.

getInitParameterNames() - Method in class javax.servlet.GenericServlet

Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.

getInitParameterNames() - Method in interface javax.servlet.ServletConfig

Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.

getInitParameterNames() - Method in interface javax.servlet.ServletContext

Returns the names of the context's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the context has no initialization parameters.

getInitParameters() - Method in class javax.servlet.jsp.tagext.TagLibraryValidator

Get the init parameters data as an immutable Map.

getInitParameters() - Method in interface javax.servlet.Registration

Gets an immutable (and possibly empty) Map containing the currently available initialization parameters that will be used to initialize the Servlet or Filter represented by this Registration object.

getInjectableReference(InjectionPoint, CreationalContext<?>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains an injectable reference for a certain injection point.

getInjectionPoint() - Method in interface javax.enterprise.inject.spi.EventMetadata

Get the InjectionPoint representing the injected Event instance which fired the event, or null if it was fired from BeanManager.fireEvent(Object, Annotation...);

getInjectionPoint() - Method in interface javax.enterprise.inject.spi.ProcessInjectionPoint

getInjectionPoints() - Method in interface javax.enterprise.inject.spi.Bean

Obtains the InjectionPoint objects representing injection points of the bean, that will be validated by the container at initialization time.

getInjectionPoints() - Method in interface javax.enterprise.inject.spi.Producer

Returns the set of all InjectionPoints.

getInjectionTarget() - Method in interface javax.enterprise.inject.spi.ProcessInjectionTarget

Returns the InjectionTarget object that will be used by the container to perform injection.

getInjectionTargetFactory(AnnotatedType<T>) - Method in interface javax.enterprise.inject.spi.BeanManager

An implementation of InjectionTargetFactory that provides container created InjectionTarget instances.

getInputStream() - Method in class javax.faces.application.Resource

If the current request is a resource request, (that is, ResourceHandler.isResourceRequest(javax.faces.context.FacesContext) returns true), return an InputStream containing the bytes of the resource.

getInputStream() - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.getInputStream() on the wrapped ResourceHandler object.

getInputStream() - Method in class javax.mail.internet.MimeBodyPart

Return a decoded input stream for this body part's "content".

getInputStream() - Method in class javax.mail.internet.MimeMessage

Return a decoded input stream for this Message's "content".

getInputStream() - Method in class javax.mail.internet.MimePartDataSource

Returns an input stream from this MimePart.

getInputStream() - Method in interface javax.mail.Part

Return an input stream for this part's "content".

getInputStream() - Method in class javax.mail.util.ByteArrayDataSource

Return an InputStream for the data.

getInputStream() - Method in interface javax.servlet.http.Part

Gets the content of this part as an InputStream

getInputStream() - Method in interface javax.servlet.http.WebConnection

Returns an input stream for this web connection.

getInputStream() - Method in class javax.servlet.jsp.tagext.PageData

Returns an input stream on the XML view of a JSP page.

getInputStream() - Method in interface javax.servlet.ServletRequest

Retrieves the body of the request as binary data using a ServletInputStream.

getInputStream() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getInputStream() on the wrapped request object.

getInputStream() - Method in interface javax.ws.rs.ext.ReaderInterceptorContext

Get the input stream of the object to be read.

getInstalledExtensions() - Method in interface javax.websocket.WebSocketContainer

Return the set of Extensions installed in the container.

getInstance() - Static method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager

Retrieve the Singleton DeploymentFactoryManager

getInstance(Properties, Authenticator) - Static method in class javax.mail.Session

Get a new Session object.

getInstance(Properties) - Static method in class javax.mail.Session

Get a new Session object.

getInstance(Class<T>) - Method in interface javax.validation.ConstraintValidatorFactory

getInstance() - Static method in class javax.ws.rs.ext.RuntimeDelegate

Obtain a RuntimeDelegate instance.

getInstanceId() - Method in interface javax.batch.runtime.context.JobContext

The getInstanceId method returns the current job's instance id.

getInstanceId() - Method in interface javax.batch.runtime.JobInstance

Get unique id for this JobInstance.

getInstances() - Method in interface javax.ws.rs.core.Configuration

Get the immutable set of registered JAX-RS component (such as provider or feature) instances to be utilized by the configurable instance.

getInt(FaceletContext) - Method in class javax.faces.view.facelets.TagAttribute

If literal, call Integer.parseInt(String), otherwise call getObject(FaceletContext, Class).

getInt(String) - Method in interface javax.jms.MapMessage

Returns the int value with the specified name.

getInt(int) - Method in interface javax.json.JsonArray

A convenience method for getJsonNumber(index).intValue().

getInt(int, int) - Method in interface javax.json.JsonArray

Returns the int value of the JsonNumber at the specified position.

getInt(String) - Method in interface javax.json.JsonObject

A convenience method for getJsonNumber(name).intValue()

getInt(String, int) - Method in interface javax.json.JsonObject

Returns the int value of the associated JsonNumber mapping for the specified name.

getInt() - Method in interface javax.json.stream.JsonParser

Returns a JSON number as an integer.

getInteractionSpecsSupported() - Method in interface javax.resource.cci.ResourceAdapterMetaData

Returns an array of fully-qualified names of InteractionSpec types supported by the CCI implementation for this resource adapter.

getInterceptorBindingDefinition(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains the set of meta-annotations for a certain interceptor binding type .

getInterceptorBindingHashCode(Annotation) - Method in interface javax.enterprise.inject.spi.BeanManager

Determine the hash code of an interceptor binding, using the JDK algorithm for determining an annotation hash code, ignoring any members annotated with Nonbinding.

getInterceptorBindings() - Method in interface javax.enterprise.inject.spi.Interceptor

Obtains the interceptor bindings of the interceptor.

getInterceptors() - Method in interface javax.enterprise.inject.spi.AfterTypeDiscovery

getIntHeader(String) - Method in interface javax.servlet.http.HttpServletRequest

Returns the value of the specified request header as an int.

getIntHeader(String) - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getIntHeader(String name) on the wrapped request object.

getIntProperty(String) - Method in interface javax.jms.JMSProducer

Returns the message property with the specified name that has been set on this JMSProducer, converted to a int.

getIntProperty(String) - Method in interface javax.jms.Message

Returns the value of the int property with the specified name.

getInvalidAddresses() - Method in class javax.mail.event.TransportEvent

Return the addresses to which this message could not be sent.

getInvalidAddresses() - Method in exception javax.mail.SendFailedException

Return the addresses to which this message could not be sent.

getInvalidConnections(Set) - Method in interface javax.resource.spi.ValidatingManagedConnectionFactory

This method returns a set of invalid ManagedConnection objects chosen from a specified set of ManagedConnection objects.

getInvalidPropertyDescriptors() - Method in exception javax.resource.spi.InvalidPropertyException

Get the list of invalid properties.

getInvalidValue() - Method in interface javax.validation.ConstraintViolation

Returns the value failing to pass the constraint.

getInvokedBusinessInterface() - Method in interface javax.ejb.SessionContext

Obtain the business interface or no-interface view type through which the current business method invocation was made.

getIssuer() - Method in class javax.security.auth.message.callback.PrivateKeyCallback.IssuerSerialNumRequest

Get the issuer.

getIsXml() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the value of the is-xml configuration, which specifies whether any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor will be treated as JSP documents (XML syntax).

getItem(ELContext, int) - Method in class javax.servlet.jsp.jstl.core.IteratedExpression

Evaluates the stored ValueExpression and return the indexed item.

getItemDescription() - Method in class javax.faces.component.UISelectItem

Return the description for this selection item.

getItemLabel() - Method in class javax.faces.component.UISelectItem

Return the localized label for this selection item.

getItems() - Method in class javax.mail.FetchProfile

Get the items set in this profile.

getItemValue() - Method in class javax.faces.component.UISelectItem

Return the server value for this selection item.

getJarFileUrls() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns a list of URLs for the jar files or exploded jar file directories that the persistence provider must examine for managed classes of the persistence unit.

getJavaClass() - Method in interface javax.enterprise.inject.spi.AnnotatedType

Get the underlying Class.

getJavaEncoding(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Gets the corresponding Java encoding name from an IANA name.

getJavaMember() - Method in interface javax.enterprise.inject.spi.AnnotatedConstructor

Get the underlying Constructor.

getJavaMember() - Method in interface javax.enterprise.inject.spi.AnnotatedField

Get the underlying Field.

getJavaMember() - Method in interface javax.enterprise.inject.spi.AnnotatedMember

Get the underlying Member.

getJavaMember() - Method in interface javax.enterprise.inject.spi.AnnotatedMethod

Get the underlying Method.

getJavaMember() - Method in interface javax.persistence.metamodel.Attribute

Return the java.lang.reflect.Member for the represented attribute.

getJavaType() - Method in interface javax.persistence.metamodel.Attribute

Return the Java type of the represented attribute.

getJavaType() - Method in interface javax.persistence.metamodel.Type

Return the represented Java type.

getJavaType() - Method in interface javax.persistence.TupleElement

Return the Java type of the tuple element.

getJAXBNode(XmlNode) - Method in class javax.xml.bind.Binder

Gets the JAXB object associated with the given XML element.

getJdbcDataSource() - Method in interface javax.management.j2ee.statistics.JDBCConnectionStats

Identifies the JDBC driver for the corresponding JDBCConnection.

getJMSCorrelationID() - Method in interface javax.jms.JMSProducer

Returns the JMSCorrelationID header value that has been set on this JMSProducer, as a String.

getJMSCorrelationID() - Method in interface javax.jms.Message

Gets the correlation ID for the message.

getJMSCorrelationIDAsBytes() - Method in interface javax.jms.JMSProducer

Returns the JMSCorrelationID header value that has been set on this JMSProducer, as an array of bytes.

getJMSCorrelationIDAsBytes() - Method in interface javax.jms.Message

Gets the correlation ID as an array of bytes for the message.

getJMSDeliveryMode() - Method in interface javax.jms.Message

Gets the DeliveryMode value specified for this message.

getJMSDeliveryTime() - Method in interface javax.jms.Message

Gets the message's delivery time value.

getJMSDestination() - Method in interface javax.jms.Message

Gets the Destination object for this message.

getJMSExpiration() - Method in interface javax.jms.Message

Gets the message's expiration time.

getJMSMajorVersion() - Method in interface javax.jms.ConnectionMetaData

Gets the JMS major version number.

getJMSMessageID() - Method in interface javax.jms.Message

Gets the message ID.

getJMSMinorVersion() - Method in interface javax.jms.ConnectionMetaData

Gets the JMS minor version number.

getJMSPriority() - Method in interface javax.jms.Message

Gets the message priority level.

getJMSProviderName() - Method in interface javax.jms.ConnectionMetaData

Gets the JMS provider name.

getJMSRedelivered() - Method in interface javax.jms.Message

Gets an indication of whether this message is being redelivered.

getJMSReplyTo() - Method in interface javax.jms.JMSProducer

Returns the JMSReplyTo header value that has been set on this JMSProducer.

getJMSReplyTo() - Method in interface javax.jms.Message

Gets the Destination object to which a reply to this message should be sent.

getJMSTimestamp() - Method in interface javax.jms.Message

Gets the message timestamp.

getJMSType() - Method in interface javax.jms.JMSProducer

Returns the JMSType header value that has been set on this JMSProducer.

getJMSType() - Method in interface javax.jms.Message

Gets the message type identifier supplied by the client when the message was sent.

getJMSVersion() - Method in interface javax.jms.ConnectionMetaData

Gets the JMS API version.

getJMSXPropertyNames() - Method in interface javax.jms.ConnectionMetaData

Gets an enumeration of the JMSX property names.

getJobExecution(long) - Method in interface javax.batch.operations.JobOperator

Return job execution for specified execution id

getJobExecutions(JobInstance) - Method in interface javax.batch.operations.JobOperator

Return all job executions belonging to the specified job instance.

getJobInstance(long) - Method in interface javax.batch.operations.JobOperator

Return the job instance for the specified execution id.

getJobInstanceCount(String) - Method in interface javax.batch.operations.JobOperator

Returns number of instances of a job with a particular name.

getJobInstances(String, int, int) - Method in interface javax.batch.operations.JobOperator

Returns all JobInstances belonging to a job with a particular name in reverse chronological order.

getJobName() - Method in interface javax.batch.runtime.context.JobContext

Get job name

getJobName() - Method in interface javax.batch.runtime.JobExecution

Get job name.

getJobName() - Method in interface javax.batch.runtime.JobInstance

Get job name.

getJobNames() - Method in interface javax.batch.operations.JobOperator

Returns a set of all job names known to the batch runtime.

getJobOperator() - Static method in class javax.batch.runtime.BatchRuntime

The getJobOperator factory method returns an instance of the JobOperator interface.

getJobParameters() - Method in interface javax.batch.runtime.JobExecution

Get job parameters for this execution.

getJoins() - Method in interface javax.persistence.criteria.From

Return the joins that have been made from this bound type.

getJoinType() - Method in interface javax.persistence.criteria.Fetch

Return the join type used in the fetch join.

getJoinType() - Method in interface javax.persistence.criteria.Join

Return the join type.

getJsonArray(int) - Method in interface javax.json.JsonArray

Returns the array value at the specified position in this array.

getJsonArray(String) - Method in interface javax.json.JsonObject

Returns the array value to which the specified name is mapped.

getJsonNumber(int) - Method in interface javax.json.JsonArray

Returns the number value at the specified position in this array.

getJsonNumber(String) - Method in interface javax.json.JsonObject

Returns the number value to which the specified name is mapped.

getJsonObject(int) - Method in interface javax.json.JsonArray

Returns the object value at the specified position in this array.

getJsonObject(String) - Method in interface javax.json.JsonObject

Returns the object value to which the specified name is mapped.

getJsonString(int) - Method in interface javax.json.JsonArray

Returns the string value at ths specified position in this array.

getJsonString(String) - Method in interface javax.json.JsonObject

Returns the string value to which the specified name is mapped.

getJspApplicationContext(ServletContext) - Method in class javax.servlet.jsp.JspFactory

Obtains the JspApplicationContext instance associated with the web application for the given ServletContext.

getJspBody() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport

Returns the body passed in by the container via setJspBody.

getJspConfigDescriptor() - Method in interface javax.servlet.ServletContext

Gets the <jsp-config> related configuration that was aggregated from the web.xml and web-fragment.xml descriptor files of the web application represented by this ServletContext.

getJspContext() - Method in class javax.servlet.jsp.tagext.JspFragment

Returns the JspContext that is bound to this JspFragment.

getJspContext() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport

Returns the page context passed in by the container via setJspContext.

getJspId() - Method in class javax.faces.webapp.UIComponentClassicTagBase

getJspPropertyGroups() - Method in interface javax.servlet.descriptor.JspConfigDescriptor

Gets the <jsp-property-group> child elements of the <jsp-config> element represented by this JspConfigDescriptor.

getJtaDataSource() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the JTA-enabled data source to be used by the persistence provider.

getKey() - Method in class javax.faces.event.PostKeepFlashValueEvent

getKey() - Method in class javax.faces.event.PostPutFlashValueEvent

getKey() - Method in class javax.faces.event.PreRemoveFlashValueEvent

getKey() - Method in class javax.security.auth.message.callback.PrivateKeyCallback

Used to obtain the private key set within the Callback.

getKey() - Method in class javax.security.auth.message.callback.SecretKeyCallback

Used to obtain the secret key set within the Callback.

getKey() - Method in interface javax.validation.Path.Node

getKey() - Method in interface javax.xml.registry.infomodel.RegistryObject

Gets the key representing the universally unique ID (UUID) for this object.

getKeyJavaType() - Method in interface javax.persistence.metamodel.MapAttribute

Return the Java type of the map key.

getKeys() - Method in interface javax.security.jacc.PolicyContextHandler

This public method returns the keys identifying the context objects supported by the handler.

getKeySubgraphs() - Method in interface javax.persistence.AttributeNode

Return the Map<Class, Subgraph> of subgraphs associated with this attribute node's map key.

getKeyType() - Method in interface javax.persistence.metamodel.MapAttribute

Return the type representing the key type of the map.

getKind() - Method in interface javax.validation.Path.Node

The kind of element represented by the node.

getKlass() - Method in class javax.el.ELClass

Returns the Class instance

getLabel() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the label property.

getLabel() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the label property.

getLabel() - Method in class javax.faces.model.SelectItem

Return the label of this item, to be rendered visibly for the user.

getLambdaArgument(String) - Method in class javax.el.ELContext

Retrieves the Lambda argument associated with a formal parameter.

getLang() - Method in class javax.faces.component.html.HtmlBody

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlForm

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlHead

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlOutputFormat

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlOutputText

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the lang property.

getLang() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the lang property.

getLanguage() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the language of the entity.

getLanguage() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the language of the entity.

getLanguage() - Method in class javax.ws.rs.client.Entity

Get entity language.

getLanguage() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get the language of the entity.

getLanguage() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the language of the entity.

getLanguage() - Method in interface javax.ws.rs.core.HttpHeaders

Get the language of the request entity.

getLanguage() - Method in class javax.ws.rs.core.Response

Get the language of the message entity.

getLanguage() - Method in class javax.ws.rs.core.Variant

Get the language of the variant.

getLanguageString() - Method in class javax.ws.rs.core.Variant

Get the string representation of the variant language, or null if no language has been set.

getLargeIcon() - Method in class javax.servlet.jsp.tagext.TagInfo

Get the path to the large icon.

getLastAccessedTime() - Method in interface javax.servlet.http.HttpSession

Returns the last time the client sent a request associated with this session, as the number of milliseconds since midnight January 1, 1970 GMT, and marked by the time the container received the request.

getLastDisplayedViewId(FacesContext) - Method in class javax.faces.flow.FlowHandler

Return the last displayed viewId for the current flow, as returned by FlowHandler.getCurrentFlow(javax.faces.context.FacesContext), or null if there is no current flow.

getLastModified(HttpServletRequest) - Method in class javax.servlet.http.HttpServlet

Returns the time the HttpServletRequest object was last modified, in milliseconds since midnight January 1, 1970 GMT.

getLastModified() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the last modified date.

getLastModified() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the last modified date.

getLastModified() - Method in class javax.ws.rs.core.Response

Get the last modified date.

getLastName() - Method in interface javax.xml.registry.infomodel.PersonName

Gets the last name (surname) for this Person.

getLastSampleTime() - Method in interface javax.management.j2ee.statistics.Statistic

The time of the last measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.

getLastUpdatedTime() - Method in interface javax.batch.runtime.JobExecution

Get time execution was last updated updated.

getLayout() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the layout property.

getLayout() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the layout property.

getLayout() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the layout property.

getLayout() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the layout property.

getLeafBean() - Method in interface javax.validation.ConstraintViolation

Returns: the bean instance the constraint is applied on if it is a bean constraint the bean instance hosting the property the constraint is applied on if it is a property constraint null when the ConstraintViolation is returned after calling Validator.validateValue(Class, String, Object, Class[]) the object the method is executed on if it is a method parameter, cross-parameter or return value constraint null if it is a constructor parameter or cross-parameter constraint the object the constructor has created if it is a constructor return value constraint

getLength() - Method in interface javax.ws.rs.client.ClientResponseContext

Get Content-Length value.

getLength() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get Content-Length value.

getLength() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get Content-Length value.

getLength() - Method in interface javax.ws.rs.core.HttpHeaders

Get Content-Length value.

getLength() - Method in class javax.ws.rs.core.Response

Get Content-Length value.

getLibraryName() - Method in class javax.faces.application.Resource

Return the libraryName for this resource.

getLibraryName() - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.getLibraryName() on the wrapped ResourceHandler object.

getLifecycle(String) - Method in class javax.faces.lifecycle.LifecycleFactory

Create (if needed) and return a Lifecycle instance for the specified lifecycle identifier.

getLifecycleIds() - Method in class javax.faces.lifecycle.LifecycleFactory

Return an Iterator over the set of lifecycle identifiers supported by this factory.

getLifeCycleManager() - Method in interface javax.xml.registry.infomodel.RegistryObject

Returns the LifeCycleManager that created this object.

getLine() - Method in class javax.faces.view.Location

Return the line number in the page for this location.

getLineCount() - Method in class javax.mail.internet.MimeBodyPart

Return the number of lines for the content of this Part.

getLineCount() - Method in class javax.mail.internet.MimeMessage

Return the number of lines for the content of this message.

getLineCount() - Method in interface javax.mail.Part

Return the number of lines in the content of this part.

getLineNumber() - Method in interface javax.json.stream.JsonLocation

Return the line number for the current JSON event in the input source.

getLineNumber() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getLineNumber() - Method in interface javax.xml.bind.ValidationEventLocator

Return the line number if available

getLink(String) - Method in interface javax.ws.rs.client.ClientResponseContext

Get the link for the relation.

getLink(String) - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the link for the relation.

getLink(String) - Method in class javax.ws.rs.core.Response

Get the link for the relation.

getLinkBuilder(String) - Method in interface javax.ws.rs.client.ClientResponseContext

Convenience method that returns a Link.Builder for the relation.

getLinkBuilder(String) - Method in interface javax.ws.rs.container.ContainerResponseContext

Convenience method that returns a Link.Builder for the relation.

getLinkBuilder(String) - Method in class javax.ws.rs.core.Response

Convenience method that returns a Link.Builder for the relation.

getLinkedCause() - Method in exception javax.xml.rpc.JAXRPCException

Gets the Linked cause

getLinkedCause() - Method in exception javax.xml.rpc.ServiceException

Gets the Linked cause

getLinkedException() - Method in exception javax.jms.JMSException

Gets the exception linked to this one.

getLinkedException() - Method in exception javax.resource.ResourceException

Deprecated.
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..

getLinkedException() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getLinkedException() - Method in exception javax.xml.bind.JAXBException

Get the linked exception

getLinkedException() - Method in exception javax.xml.bind.TypeConstraintException

Get the linked exception

getLinkedException() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the linked exception for this warning/error.

getLinkedObjects() - Method in interface javax.xml.registry.infomodel.ExternalLink

Gets the collection of RegistryObjects that are annotated by this ExternalLink.

getLinkedWarning() - Method in exception javax.resource.cci.ResourceWarning

Deprecated.
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

getLinks() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the links attached to the message as header.

getLinks() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the links attached to the message as header.

getLinks() - Method in class javax.ws.rs.core.Response

Get the links attached to the message as headers.

getList(String, Class<E>) - Method in interface javax.persistence.metamodel.ManagedType

Return the List-valued attribute of the managed type that corresponds to the specified name and Java element type.

getList(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the List-valued attribute of the managed type that corresponds to the specified name.

getListener() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getListener() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getListener() - Method in interface javax.xml.bind.Marshaller

Return Marshaller.Listener registered with this Marshaller.

getListener() - Method in interface javax.xml.bind.Unmarshaller

Return Unmarshaller.Listener registered with this Unmarshaller.

getListenerRegistry() - Method in interface javax.management.j2ee.Management

Returns the listener registry implementation for this MEJB.

getListenersForEventClass(Class<? extends SystemEvent>) - Method in class javax.faces.component.UIComponent

This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

getListenersForEventClass(Class<? extends SystemEvent>) - Method in class javax.faces.component.UIComponentBase

Return the SystemEventListener instances registered on this UIComponent instance that are interested in events of type eventClass.

getListenersForEventClass(Class<? extends SystemEvent>) - Method in class javax.faces.event.ExceptionQueuedEventContext

Return a List that contains a single entry, the ExceptionHandler for the current request.

getListenersForEventClass(Class<? extends SystemEvent>) - Method in interface javax.faces.event.SystemEventListenerHolder

getLocalAddr() - Method in interface javax.servlet.ServletRequest

Returns the Internet Protocol (IP) address of the interface on which the request was received.

getLocalAddr() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getLocalAddr() on the wrapped request object.

getLocalAddress(Session) - Static method in class javax.mail.internet.InternetAddress

Return an InternetAddress object representing the current user.

getLocalAddress() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the unresolved local address on which the request was received.

getLocale() - Method in class javax.el.ELContext

Get the Locale stored by a previous invocation to ELContext.setLocale(java.util.Locale).

getLocale() - Method in class javax.faces.component.UIViewRoot

Return the Locale to be used in localizing the response being created for this view.

getLocale() - Method in class javax.faces.convert.DateTimeConverter

Return the Locale to be used when parsing or formatting dates and times.

getLocale() - Method in class javax.faces.convert.NumberConverter

Return the Locale to be used when parsing numbers.

getLocale() - Method in class javax.servlet.jsp.jstl.fmt.LocalizationContext

Gets the locale of this I18N localization context.

getLocale() - Method in interface javax.servlet.ServletRequest

Returns the preferred Locale that the client will accept content in, based on the Accept-Language header.

getLocale() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getLocale() on the wrapped request object.

getLocale() - Method in interface javax.servlet.ServletResponse

Returns the locale specified for this response using the ServletResponse.setLocale(java.util.Locale) method.

getLocale() - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to return getLocale() on the wrapped response object.

getLocale() - Method in interface javax.xml.registry.infomodel.LocalizedString

Get the Locale for this object.

getLocales() - Method in interface javax.servlet.ServletRequest

Returns an Enumeration of Locale objects indicating, in decreasing order starting with the preferred locale, the locales that are acceptable to the client based on the Accept-Language header.

getLocales() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getLocales() on the wrapped request object.

getLocalizedMessage(PageContext, String) - Static method in class javax.servlet.jsp.jstl.fmt.LocaleSupport

Retrieves the localized message corresponding to the given key.

getLocalizedMessage(PageContext, String, String) - Static method in class javax.servlet.jsp.jstl.fmt.LocaleSupport

Retrieves the localized message corresponding to the given key.

getLocalizedMessage(PageContext, String, Object[]) - Static method in class javax.servlet.jsp.jstl.fmt.LocaleSupport

Retrieves the localized message corresponding to the given key, and performs parametric replacement using the arguments specified via args.

getLocalizedMessage(PageContext, String, Object[], String) - Static method in class javax.servlet.jsp.jstl.fmt.LocaleSupport

Retrieves the localized message corresponding to the given key, and performs parametric replacement using the arguments specified via args.

getLocalizedString(Locale, String) - Method in interface javax.xml.registry.infomodel.InternationalString

Gets the LocalizedString for the specified Locale and charsetName.

getLocalizedStrings() - Method in interface javax.xml.registry.infomodel.InternationalString

Returns the LocalizedStrings associated with this object.

getLocalName() - Method in class javax.faces.view.facelets.Tag

Return the XML local name of the tag.

getLocalName() - Method in class javax.faces.view.facelets.TagAttribute

Local name of this attribute

getLocalName() - Method in interface javax.servlet.ServletRequest

Returns the host name of the Internet Protocol (IP) interface on which the request was received.

getLocalName() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getLocalName() on the wrapped request object.

getLocalName() - Method in interface javax.xml.soap.Name

Gets the local name part of the XML name that this Name object represents.

getLocalPort() - Method in interface javax.servlet.ServletRequest

Returns the Internet Protocol (IP) port number of the interface on which the request was received.

getLocalPort() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getLocalPort() on the wrapped request object.

getLocalTransaction() - Method in interface javax.resource.cci.Connection

Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection.

getLocalTransaction() - Method in interface javax.resource.spi.ManagedConnection

Returns an javax.resource.spi.LocalTransaction instance.

getLocalValue() - Method in class javax.faces.component.UIOutput

getLocalValue() - Method in interface javax.faces.component.ValueHolder

Return the local value of this UIComponent (if any), without evaluating any associated ValueExpression.

getLocation() - Method in class javax.faces.view.facelets.Tag

Return the Location of this Tag instance in the Facelet view.

getLocation() - Method in class javax.faces.view.facelets.TagAttribute

The location of this attribute in the FaceletContext

getLocation() - Method in interface javax.json.stream.JsonParser

Return the location that corresponds to the parser's current state in the JSON input source.

getLocation() - Method in exception javax.json.stream.JsonParsingException

Return the location of the incorrect JSON.

getLocation() - Method in class javax.servlet.MultipartConfigElement

Gets the directory location where files will be stored.

getLocation() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the location.

getLocation() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the location.

getLocation() - Method in class javax.ws.rs.core.Response

Get the location.

getLocation() - Method in exception javax.ws.rs.RedirectionException

Get the redirection response location.

getLocator() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getLocator() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the locator for this warning/error.

getLockMode(Object) - Method in interface javax.persistence.EntityManager

Get the current lock mode for the entity instance.

getLockMode() - Method in interface javax.persistence.Query

Get the current lock mode for the query.

getLogWriter() - Method in interface javax.resource.spi.ManagedConnection

Gets the log writer for this ManagedConnection instance.

getLogWriter() - Method in interface javax.resource.spi.ManagedConnectionFactory

Get the log writer for this ManagedConnectionFactory instance.

getLong(String) - Method in interface javax.jms.MapMessage

Returns the long value with the specified name.

getLong() - Method in interface javax.json.stream.JsonParser

Returns a JSON number as a long.

getLongdesc() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the longdesc property.

getLongProperty(String) - Method in interface javax.jms.JMSProducer

Returns the message property with the specified name that has been set on this JMSProducer, converted to a long.

getLongProperty(String) - Method in interface javax.jms.Message

Returns the value of the long property with the specified name.

getLoopStatus() - Method in interface javax.servlet.jsp.jstl.core.LoopTag

Retrieves a 'status' object to provide information about the current round of the iteration.

getLoopStatus() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

getLowerBound() - Method in interface javax.management.j2ee.statistics.BoundaryStatistic

The lower limit of the value of this attribute.The upper limit of the value of this attribute.

getLowWaterMark() - Method in interface javax.management.j2ee.statistics.RangeStatistic

The lowest value this attribute has held since the beginning of the measurement.

getMajorVersion() - Method in interface javax.servlet.ServletContext

Returns the major version of the Servlet API that this servlet container supports.

getMajorVersion() - Method in interface javax.xml.registry.infomodel.Versionable

Gets the major revision number for this version of the Versionable object.

getManagedClassNames() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the list of the names of the classes that the persistence provider must add to its set of managed classes.

getManagedConnectionFactory() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats

Returns the associated JCAManagedConnectionFactory OBJECT_NAME

getManagedConnectionFactory() - Method in class javax.resource.spi.security.PasswordCredential

Gets the target ManagedConnectionFactory for which the user name and password has been set by the application server.

getManagedTaskListener() - Method in interface javax.enterprise.concurrent.ManagedTask

The ManagedTaskListener to receive notification of lifecycle events of this task.

getManagedTypes() - Method in interface javax.persistence.metamodel.Metamodel

Return the metamodel managed types.

getMap(String, Class<K>, Class<V>) - Method in interface javax.persistence.metamodel.ManagedType

Return the Map-valued attribute of the managed type that corresponds to the specified name and Java key and value types.

getMap(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the Map-valued attribute of the managed type that corresponds to the specified name.

getMap() - Method in interface javax.security.auth.message.MessageInfo

Get (a reference to) the Map object of this MessageInfo.

getMapNames() - Method in interface javax.jms.MapMessage

Returns an Enumeration of all the names in the MapMessage object.

getMappingFileNames() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the list of the names of the mapping files that the persistence provider must load to determine the mappings for the entity classes.

getMappings() - Method in interface javax.servlet.ServletRegistration

Gets the currently available mappings of the Servlet represented by this ServletRegistration.

getMappingStreams() - Method in interface javax.validation.spi.ConfigurationState

Returns a set of configuration streams.

getMatchedResources() - Method in interface javax.ws.rs.core.UriInfo

Get a read-only list of the currently matched resource class instances.

getMatchedURIs() - Method in interface javax.ws.rs.core.UriInfo

Get a read-only list of URIs for matched resources.

getMatchedURIs(boolean) - Method in interface javax.ws.rs.core.UriInfo

Get a read-only list of URIs for matched resources.

getMatchingHeaderLines(String[]) - Method in class javax.mail.internet.InternetHeaders

Return all matching header lines as an Enumeration of Strings.

getMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeBodyPart

Get matching header lines as an Enumeration of Strings.

getMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeMessage

Get matching header lines as an Enumeration of Strings.

getMatchingHeaderLines(String[]) - Method in interface javax.mail.internet.MimePart

Get matching header lines as an Enumeration of Strings.

getMatchingHeaders(String[]) - Method in class javax.mail.internet.InternetHeaders

Return all matching Header objects.

getMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeBodyPart

Return matching headers from this Message as an Enumeration of Header objects.

getMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeMessage

Return matching headers from this Message as an Enumeration of Header objects.

getMatchingHeaders(String[]) - Method in interface javax.mail.Part

Return matching headers from this part as an Enumeration of Header objects.

getMatchingHeaders(String[]) - Method in class javax.xml.soap.MimeHeaders

Returns all the MimeHeader objects whose name matches a name in the given array of names.

getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.AttachmentPart

Retrieves all MimeHeader objects that match a name in the given array.

getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.SOAPPart

Retrieves all MimeHeader objects that match a name in the given array.

getMatrixParameters() - Method in interface javax.ws.rs.core.PathSegment

Get a map of the matrix parameters associated with the path segment.

getMaxAge() - Method in class javax.servlet.http.Cookie

Gets the maximum age in seconds of this Cookie.

getMaxAge() - Method in interface javax.servlet.SessionCookieConfig

Gets the lifetime (in seconds) of the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

getMaxAge() - Method in class javax.ws.rs.core.CacheControl

Corresponds to the max-age cache control directive.

getMaxAge() - Method in class javax.ws.rs.core.NewCookie

Get the maximum age of the the cookie in seconds.

getMaxBinaryMessageBufferSize() - Method in interface javax.websocket.Session

The maximum length of incoming binary messages that this Session can buffer.

getMaxConnections() - Method in interface javax.resource.spi.ManagedConnectionMetaData

Returns maximum limit on number of active concurrent connections that an EIS instance can support across client processes.

getMaxFileSize() - Method in class javax.servlet.MultipartConfigElement

Gets the maximum size allowed for uploaded files.

getMaxFractionDigits() - Method in class javax.faces.convert.NumberConverter

Return the maximum number of digits getAsString() should render in the fraction portion of the result.

getMaxIdleTimeout() - Method in interface javax.websocket.Session

Return the number of milliseconds before this conversation may be closed by the container if it is inactive, i.e.

getMaximum() - Method in class javax.faces.validator.DoubleRangeValidator

Return the maximum value to be enforced by this Validator or Double.MAX_VALUE if it has not been set.

getMaximum() - Method in class javax.faces.validator.LengthValidator

Return the maximum length to be enforced by this Validator, or 0 if the maximum has not been set.

getMaximum() - Method in class javax.faces.validator.LongRangeValidator

Return the maximum value to be enforced by this Validator.

getMaximumSeverity() - Method in class javax.faces.context.FacesContext

Return the maximum severity level recorded on any FacesMessages that has been queued, whether or not they are associated with any specific UIComponent.

getMaximumSeverity() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getMaximumSeverity() on the wrapped FacesContext object.

getMaxInactiveInterval() - Method in interface javax.servlet.http.HttpSession

Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses.

getMaxIntegerDigits() - Method in class javax.faces.convert.NumberConverter

Return the maximum number of digits getAsString() should render in the integer portion of the result.

getMaxlength() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the maxlength property.

getMaxlength() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the maxlength property.

getMaxlength() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the maxlength property.

getMaxRequestSize() - Method in class javax.servlet.MultipartConfigElement

Gets the maximum size allowed for multipart/form-data requests.

getMaxResults() - Method in interface javax.persistence.Query

The maximum number of results the query object was set to retrieve.

getMaxTextMessageBufferSize() - Method in interface javax.websocket.Session

The maximum length of incoming text messages that this Session can buffer.

getMaxTime() - Method in interface javax.management.j2ee.statistics.TimeStatistic

The maximum amount of time taken to complete one invocation of this operation since the beginning of this measurement.

getMBeanCount() - Method in interface javax.management.j2ee.Management

Returns the number of managed objects registered in the MEJB.

getMBeanInfo(ObjectName) - Method in interface javax.management.j2ee.Management

This method discovers the attributes and operations that a managed object exposes for management.

getMechanismType() - Method in interface javax.xml.rpc.encoding.Deserializer

Gets the type of the XML processing mechanism and representation used by this Deserializer.

getMechanismType() - Method in interface javax.xml.rpc.encoding.Serializer

Gets the type of the XML processing mechanism and representation used by this Serializer.

getMechType() - Method in interface javax.resource.spi.security.GenericCredential

Deprecated.

Returns the mechanism type for the GenericCredential instance.

getMediaType() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the media type of the entity.

getMediaType() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the media type of the entity.

getMediaType() - Method in class javax.ws.rs.client.Entity

Get entity media type.

getMediaType() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get the media type of the entity.

getMediaType() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the media type of the entity.

getMediaType() - Method in interface javax.ws.rs.core.HttpHeaders

Get the media type of the request entity.

getMediaType() - Method in class javax.ws.rs.core.Response

Get the media type of the message entity.

getMediaType() - Method in class javax.ws.rs.core.Variant

Get the media type of the variant.

getMediaType() - Method in interface javax.ws.rs.ext.InterceptorContext

Get media type of HTTP entity.

getMember() - Method in interface javax.enterprise.inject.spi.InjectionPoint

Get the Field object in the case of field injection, the Method object in the case of method parameter injection or the Constructor object in the case of constructor parameter injection.

getMemberFactory() - Method in class javax.faces.view.facelets.FaceletCache

Returns the FaceletCache.MemberFactory passed to FaceletCache.setMemberFactories(javax.faces.view.facelets.FaceletCache.MemberFactory<V>, javax.faces.view.facelets.FaceletCache.MemberFactory<V>) for the purpose of creating Facelet instance.

getMessage() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus

Retrieve any additional information about the status of this event.

getMessage() - Method in exception javax.faces.application.ViewExpiredException

Return the message for this exception prepended with the view identifier if the view identifier is not null, otherwise, return the message.

getMessage() - Method in class javax.mail.event.MessageChangedEvent

Return the changed Message.

getMessage() - Method in class javax.mail.event.StoreEvent

Get the message from the Store.

getMessage() - Method in class javax.mail.event.TransportEvent

Get the Message object associated with this Transport Event.

getMessage(int) - Method in class javax.mail.Folder

Get the Message object corresponding to the given message number.

getMessage() - Method in class javax.mail.MessageContext

Return the Message that contains the content.

getMessage() - Method in exception javax.resource.ResourceException

Returns a detailed message string describing this exception.

getMessage() - Method in class javax.servlet.jsp.tagext.ValidationMessage

Get the localized validation message.

getMessage() - Method in interface javax.validation.ConstraintViolation

getMessage() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getMessage() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the text message for this warning/error.

getMessage() - Method in exception javax.xml.registry.JAXRException

Returns the detail message for this JAXRException object.

getMessage() - Method in interface javax.xml.rpc.handler.soap.SOAPMessageContext

Gets the SOAPMessage from this message context

getMessage() - Method in exception javax.xml.soap.SOAPException

Returns the detail message for this SOAPException object.

getMessage() - Method in interface javax.xml.ws.handler.LogicalMessageContext

Gets the message from this message context

getMessage() - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Gets the SOAPMessage from this message context.

getMessageBodyReader(Class<T>, Type, Annotation[], MediaType) - Method in interface javax.ws.rs.ext.Providers

Get a message body reader that matches a set of criteria.

getMessageBodyWriter(Class<T>, Type, Annotation[], MediaType) - Method in interface javax.ws.rs.ext.Providers

Get a message body writer that matches a set of criteria.

getMessageBundle() - Method in class javax.faces.application.Application

Return the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application.

getMessageBundle() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getMessageBundle() on the wrapped Application object.

getMessageByUID(long) - Method in interface javax.mail.UIDFolder

Get the Message corresponding to the given UID.

getMessageChangeType() - Method in class javax.mail.event.MessageChangedEvent

Return the type of this event.

getMessageContext() - Method in interface javax.ejb.SessionContext

Obtain a reference to the JAX-RPC MessageContext.

getMessageContext() - Method in class javax.mail.internet.MimePartDataSource

Return the MessageContext for the current part.

getMessageContext() - Method in interface javax.mail.MessageAware

Return the message context.

getMessageContext() - Method in interface javax.xml.rpc.server.ServletEndpointContext

The method getMessageContext returns the MessageContext targeted for this endpoint instance.

getMessageContext() - Method in interface javax.xml.ws.WebServiceContext

Returns the MessageContext for the request being served at the time this method is called.

getMessageCount() - Method in class javax.mail.Folder

Get total number of messages in this Folder.

getMessageCount() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats

Number of messages sent or received.

getMessageCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats

Number of messages exchanged.

getMessageCount() - Method in interface javax.management.j2ee.statistics.MessageDrivenBeanStats

Number of messages received.

getMessageFactory() - Method in interface javax.xml.ws.soap.SOAPBinding

Gets the SAAJ MessageFactory instance used by this SOAP binding.

getMessageHandlers() - Method in interface javax.websocket.Session

Return an unmodifiable copy of the set of MessageHandlers for this Session.

getMessageID() - Method in class javax.mail.internet.MimeMessage

Returns the value of the "Message-ID" header field.

getMessageInterpolator() - Method in interface javax.validation.spi.ConfigurationState

Returns the message interpolator of this configuration.

getMessageInterpolator() - Method in interface javax.validation.ValidatorFactory

Returns the MessageInterpolator instance configured at initialization time for the ValidatorFactory.

getMessageInterpolatorClassName() - Method in interface javax.validation.BootstrapConfiguration

Class name of the MessageInterpolator implementation or null if none is specified.

getMessageLayer() - Method in interface javax.security.auth.message.config.AuthConfig

Get the message layer name of this authentication context configuration object.

getMessageLayer() - Method in interface javax.security.auth.message.config.AuthConfigFactory.RegistrationContext

Get the layer name from the registration context

getMessageList() - Method in class javax.faces.context.FacesContext

Like FacesContext.getMessages(), but returns a List<FacesMessage>, enabling use from EL expressions.

getMessageList(String) - Method in class javax.faces.context.FacesContext

Like FacesContext.getMessages(java.lang.String), but returns a List<FacesMessage> of messages for the component with client id matching argument clientId.

getMessageList() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getMessageList() on the wrapped FacesContext object.

getMessageList(String) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getMessageList(String) on the wrapped FacesContext object.

getMessageListener() - Method in interface javax.jms.JMSConsumer

Gets the JMSConsumer's MessageListener.

getMessageListener() - Method in interface javax.jms.MessageConsumer

Gets the MessageConsumer's MessageListener.

getMessageListener() - Method in interface javax.jms.Session

Returns the session's distinguished message listener (optional).

getMessageNumber() - Method in class javax.mail.Message

Get the Message number for this Message.

getMessages() - Method in class javax.faces.context.FacesContext

Return an Iterator over the FacesMessages that have been queued, whether or not they are associated with any specific client identifier.

getMessages(String) - Method in class javax.faces.context.FacesContext

Return an Iterator over the FacesMessages that have been queued that are associated with the specified client identifier (if clientId is not null), or over the FacesMessages that have been queued that are not associated with any specific client identifier (if clientId is null).

getMessages() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getMessages() on the wrapped FacesContext object.

getMessages(String) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getMessages(String) on the wrapped FacesContext object.

getMessages() - Method in class javax.mail.event.MessageCountEvent

Return the array of messages added or removed.

getMessages(int, int) - Method in class javax.mail.Folder

Get the Message objects for message numbers ranging from start through end, both start and end inclusive.

getMessages(int[]) - Method in class javax.mail.Folder

Get the Message objects for message numbers specified in the array.

getMessages() - Method in class javax.mail.Folder

Get all Message objects from this Folder.

getMessagesByUID(long, long) - Method in interface javax.mail.UIDFolder

Get the Messages specified by the given range.

getMessagesByUID(long[]) - Method in interface javax.mail.UIDFolder

Get the Messages specified by the given array of UIDs.

getMessageSelector() - Method in interface javax.jms.JMSConsumer

Gets this JMSConsumer's message selector expression.

getMessageSelector() - Method in interface javax.jms.MessageConsumer

Gets this message consumer's message selector expression.

getMessageSelector() - Method in interface javax.jms.QueueBrowser

Gets this queue browser's message selector expression.

getMessageTemplate() - Method in interface javax.validation.ConstraintViolation

getMessageTemplate() - Method in interface javax.validation.metadata.ConstraintDescriptor

The non-interpolated error message

getMessageType() - Method in class javax.mail.event.StoreEvent

Return the type of this event.

getMessageWaitTime() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats

Time spent by a message before being delivered.

getMessageWaitTime() - Method in interface javax.management.j2ee.statistics.JMSSessionStats

Time spent by a message before being delivered.

getMetaData() - Method in interface javax.jms.Connection

Gets the metadata for this connection.

getMetaData() - Method in interface javax.jms.JMSContext

Gets the connection metadata for the JMSContext's connection.

getMetaData() - Method in interface javax.resource.cci.Connection

Gets the information on the underlying EIS instance represented through an active connection.

getMetaData() - Method in interface javax.resource.cci.ConnectionFactory

Gets metadata for the Resource Adapter.

getMetaData() - Method in interface javax.resource.spi.ManagedConnection

Gets the metadata information for this connection's underlying EIS resource manager instance.

getMetadata() - Method in class javax.ws.rs.core.Response

See Response.getHeaders().

getMetadata() - Method in class javax.xml.ws.Endpoint

Returns a list of metadata documents for the service.

getMetadataMemberFactory() - Method in class javax.faces.view.facelets.FaceletCache

Returns the FaceletCache.MemberFactory passed to FaceletCache.setMemberFactories(javax.faces.view.facelets.FaceletCache.MemberFactory<V>, javax.faces.view.facelets.FaceletCache.MemberFactory<V>) for the purpose of creating View Metadata Facelet instance.

getMetamodel() - Method in interface javax.persistence.EntityManager

Return an instance of Metamodel interface for access to the metamodel of the persistence unit.

getMetamodel() - Method in interface javax.persistence.EntityManagerFactory

Return an instance of Metamodel interface for access to the metamodel of the persistence unit.

getMethod() - Method in interface javax.interceptor.InvocationContext

Returns the method of the target class for which the interceptor was invoked.

getMethod() - Method in interface javax.servlet.http.HttpServletRequest

Returns the name of the HTTP method with which this request was made, for example, GET, POST, or PUT.

getMethod() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getMethod() on the wrapped request object.

getMethod() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the request method.

getMethod() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get the request method.

getMethod() - Method in interface javax.ws.rs.core.Request

Get the request method, e.g.

getMethodCalls() - Method in class javax.faces.flow.Flow

Return an immutable data structure containing all the method call nodes declared for this flow.

getMethodExpression() - Method in class javax.faces.flow.MethodCallNode

Return the MethodExpression to be invoked to when control passes to this node.

getMethodExpression(FaceletContext, Class, Class[]) - Method in class javax.faces.view.facelets.TagAttribute

Create a MethodExpression, using this attribute's value as the expression String.

getMethodInfo(ELContext) - Method in class javax.el.MethodExpression

Evaluates the expression relative to the provided context, and returns information about the actual referenced method.

getMethodName() - Method in class javax.servlet.HttpMethodConstraintElement

Gets the HTTP method name.

getMethodNames() - Method in class javax.servlet.ServletSecurityElement

Gets the set of HTTP method names named by the HttpMethodConstraints.

getMethodReadyCount() - Method in interface javax.management.j2ee.statistics.SessionBeanStats

Number of beans in the method-ready state.

getMethods() - Method in interface javax.enterprise.inject.spi.AnnotatedType

Get the methods of the type.

getMethodSignature() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

Returns the expected method signature of this deferred method attribute.

getMetrics() - Method in interface javax.batch.runtime.context.StepContext

The getMetrics method returns an array of step level metrics.

getMetrics() - Method in interface javax.batch.runtime.StepExecution

Get step metrics

getMiddleName() - Method in interface javax.xml.registry.infomodel.PersonName

Gets the middle name for this Person.

getMimeHeader(String) - Method in class javax.xml.soap.AttachmentPart

Gets all the values of the header identified by the given String.

getMimeHeader(String) - Method in class javax.xml.soap.SOAPPart

Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.

getMimeHeaders() - Method in class javax.xml.soap.SOAPMessage

Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.

getMimeType(String) - Method in class javax.faces.context.ExternalContext

Returns the MIME type of the specified file or null if the MIME type is not known.

getMimeType(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getMimeType(String) on the wrapped ExternalContext object.

getMimeType(String) - Method in interface javax.servlet.ServletContext

Returns the MIME type of the specified file, or null if the MIME type is not known.

getMimeType() - Method in interface javax.xml.registry.infomodel.ExtrinsicObject

Gets the mime type associated with this object.

getMinFractionDigits() - Method in class javax.faces.convert.NumberConverter

Return the minimum number of digits getAsString() should render in the fraction portion of the result.

getMinimum() - Method in class javax.faces.validator.DoubleRangeValidator

Return the minimum value to be enforced by this Validator, or Double.MIN_VALUE if it has not been set.

getMinimum() - Method in class javax.faces.validator.LengthValidator

Return the minimum length to be enforced by this Validator, or 0 if the minimum has not been set.

getMinimum() - Method in class javax.faces.validator.LongRangeValidator

Return the minimum value to be enforced by this Validator.

getMinIntegerDigits() - Method in class javax.faces.convert.NumberConverter

Return the minimum number of digits getAsString() should render in the integer portion of the result.

getMinorVersion() - Method in interface javax.servlet.ServletContext

Returns the minor version of the Servlet API that this servlet container supports.

getMinorVersion() - Method in interface javax.xml.registry.infomodel.Versionable

Gets the minor revision number for this version of the Versionable object.

getMinTime() - Method in interface javax.management.j2ee.statistics.TimeStatistic

The minimum amount of time taken to complete one invocation of this operation since the beginning of this measurement.

getMinute() - Method in class javax.ejb.ScheduleExpression

Return the value of the minute attribute.

getMode() - Method in class javax.mail.Folder

Return the open mode of this folder.

getModel() - Method in interface javax.persistence.criteria.CollectionJoin

Return the metamodel representation for the collection attribute.

getModel() - Method in interface javax.persistence.criteria.ListJoin

Return the metamodel representation for the list attribute.

getModel() - Method in interface javax.persistence.criteria.MapJoin

Return the metamodel representation for the map attribute.

getModel() - Method in interface javax.persistence.criteria.Path

Return the bindable object that corresponds to the path expression.

getModel() - Method in interface javax.persistence.criteria.PluralJoin

Return the metamodel representation for the collection-valued attribute corresponding to the join.

getModel() - Method in interface javax.persistence.criteria.Root

Return the metamodel entity corresponding to the root.

getModel() - Method in interface javax.persistence.criteria.SetJoin

Return the metamodel representation for the set attribute.

getModuleDTDVersion() - Method in interface javax.enterprise.deploy.model.DDBeanRoot

Deprecated.
As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()

getModuleDTDVersion() - Method in interface javax.enterprise.deploy.model.DeployableObject

Deprecated.
As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()

getModuleExtension() - Method in class javax.enterprise.deploy.shared.ModuleType

Return the file extension string for this enumeration.

getModuleID() - Method in interface javax.enterprise.deploy.spi.TargetModuleID

Retrieve the id assigned to represent the deployed module.

getModuleType(int) - Static method in class javax.enterprise.deploy.shared.ModuleType

Return an object of the specified value.

getModuleUris(ModuleType) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject

Return the list of URIs of the designated module type.

getModuleUris() - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject

Return the list of URIs for all modules in the application.

getMonth() - Method in class javax.ejb.ScheduleExpression

Return the value of the month attribute.

getMustUnderstand() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.

getName() - Method in class javax.el.MethodInfo

Returns the name of the method

getName() - Method in interface javax.enterprise.deploy.spi.Target

Retrieve the name of the target server.

getName() - Method in interface javax.enterprise.inject.spi.BeanAttributes

Obtains the EL name of a bean, if it has one.

getName() - Method in class javax.faces.component.behavior.ClientBehaviorContext.Parameter

Returns the Parameter's name.

getName() - Method in class javax.faces.component.UIParameter

Return the optional parameter name for this parameter.

getName() - Method in class javax.faces.component.UIViewParameter

Return the request parameter name from which the value is retrieved.

getName() - Method in class javax.faces.event.PhaseId

Return the name of this phase.

getName() - Method in class javax.faces.flow.Parameter

Return the name of the parameter

getName() - Method in interface javax.faces.view.AttachedObjectTarget

Returns the name by which this attached object target is exposed to the page author.

getName() - Method in class javax.faces.webapp.FacetTag

Return the name to be assigned to this facet.

getName() - Method in class javax.mail.Folder

Returns the name of this Folder.

getName() - Method in class javax.mail.Header

Returns the name of this header.

getName() - Method in class javax.mail.internet.MimePartDataSource

DataSource method to return a name.

getName() - Method in class javax.mail.util.ByteArrayDataSource

Get the name of the data.

getName() - Method in interface javax.management.j2ee.statistics.Statistic

The name of this Statistic.

getName() - Method in interface javax.persistence.EntityGraph

Return the name of a named EntityGraph (an entity graph defined by means of the NamedEntityGraph annotation, XML descriptor element, or added by means of the addNamedEntityGraph method.

getName() - Method in interface javax.persistence.metamodel.Attribute

Return the name of the attribute.

getName() - Method in interface javax.persistence.metamodel.EntityType

Return the entity name.

getName() - Method in interface javax.persistence.Parameter

Return the parameter name, or null if the parameter is not a named parameter or no name has been assigned.

getName() - Method in interface javax.resource.spi.security.GenericCredential

Deprecated.

Returns the name of the resource principal associated with a GenericCredential instance.

getName() - Method in class javax.resource.spi.work.HintsContext

Get the associated name of the WorkContext.

getName() - Method in class javax.resource.spi.work.SecurityContext

Get the associated name of the WorkContext.

getName() - Method in class javax.resource.spi.work.TransactionContext

Get the associated name of the WorkContext.

getName() - Method in interface javax.resource.spi.work.WorkContext

Get the associated name of the WorkContext.

getName() - Method in class javax.security.auth.message.callback.CallerPrincipalCallback

Get the caller principal name.

getName() - Method in class javax.servlet.http.Cookie

Returns the name of the cookie.

getName() - Method in class javax.servlet.http.HttpSessionBindingEvent

Returns the name with which the attribute is bound to or unbound from the session.

getName() - Method in interface javax.servlet.http.Part

Gets the name of this part

getName() - Method in class javax.servlet.jsp.tagext.FunctionInfo

The name of the function.

getName() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

The name of this attribute.

getName() - Method in class javax.servlet.jsp.tagext.TagFileInfo

The unique action name of this tag.

getName() - Method in interface javax.servlet.Registration

Gets the name of the Servlet or Filter that is represented by this Registration.

getName() - Method in class javax.servlet.ServletContextAttributeEvent

Gets the name of the ServletContext attribute that changed.

getName() - Method in class javax.servlet.ServletRequestAttributeEvent

Return the name of the attribute that changed on the ServletRequest.

getName() - Method in interface javax.servlet.SessionCookieConfig

Gets the name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

getName() - Method in interface javax.validation.metadata.ExecutableDescriptor

Returns the method name in case this descriptor represents a method or the non-qualified name of the declaring class in case this descriptor represents a constructor.

getName() - Method in interface javax.validation.metadata.ParameterDescriptor

Returns this parameter's name as retrieved by the current parameter name resolver.

getName() - Method in interface javax.validation.Path.Node

Returns the name of the element which the node represents: null if it is a leaf node which represents an entity / bean.

getName() - Method in interface javax.websocket.Extension

The name of the extension.

getName() - Method in interface javax.websocket.Extension.Parameter

Return the name of the extension parameter.

getName() - Method in class javax.ws.rs.core.Cookie

Get the name of the cookie.

getName() - Method in class javax.xml.bind.JAXBElement

Returns the xml element tag name.

getName() - Method in interface javax.xml.registry.infomodel.RegistryObject

Gets the user-friendly name of this object.

getName() - Method in interface javax.xml.registry.infomodel.Slot

Gets the name for this Slot.

getName() - Method in class javax.xml.soap.MimeHeader

Returns the name of this MimeHeader object.

getNamedDispatcher(String) - Method in interface javax.servlet.ServletContext

Returns a RequestDispatcher object that acts as a wrapper for the named servlet.

getNameFromAttribute() - Method in class javax.servlet.jsp.tagext.TagVariableInfo

The body of the <name-from-attribute> element.

getNameGiven() - Method in class javax.servlet.jsp.tagext.TagVariableInfo

The body of the <name-given> element.

getNames() - Method in class javax.mail.internet.ParameterList

Return an enumeration of the names of all parameters in this list.

getNamespace() - Method in class javax.faces.view.facelets.Tag

Return the resolved XML Namespace for this tag in the Facelets view.

getNamespace() - Method in class javax.faces.view.facelets.TagAttribute

The resolved Namespace for this attribute

getNamespacePrefixes() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over the namespace prefix Strings declared by this element.

getNamespaces() - Method in class javax.faces.view.facelets.TagAttributes

A list of Namespaces found in this set

getNamespaceURI(String) - Method in interface javax.xml.soap.SOAPElement

Returns the URI of the namespace that has the given prefix.

getNamingContainer() - Method in class javax.faces.component.UIComponent

Starting with "this", return the closest component in the ancestry that is a NamingContainer or null if none can be found.

getNamingContainerSeparatorChar() - Method in class javax.faces.context.FacesContext

Return the result of calling UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext), passing this as the argument.

getNamingContainerSeparatorChar() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getNamingContainerSeparatorChar() on the wrapped FacesContext object.

getNavigationCase(FacesContext, String, String) - Method in class javax.faces.application.ConfigurableNavigationHandler

Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.

getNavigationCase(FacesContext, String, String, String) - Method in class javax.faces.application.ConfigurableNavigationHandler

Return the NavigationCase representing the navigation that would be taken had NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) been called with the same arguments or null if there is no such case.

getNavigationCase(FacesContext, String, String) - Method in class javax.faces.application.ConfigurableNavigationHandlerWrapper

getNavigationCase(FacesContext, String, String, String) - Method in class javax.faces.application.ConfigurableNavigationHandlerWrapper

getNavigationCases() - Method in class javax.faces.application.ConfigurableNavigationHandler

Return a Map<String, Set<NavigationCase>> where the keys are <from-view-id> values and the values are Set<NavigationCase> where each element in the Set is a NavigationCase that applies to that <from-view-id>.

getNavigationCases() - Method in class javax.faces.application.ConfigurableNavigationHandlerWrapper

getNavigationCases() - Method in class javax.faces.flow.Flow

getNavigationHandler() - Method in class javax.faces.application.Application

Return the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.

getNavigationHandler() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getNavigationHandler() on the wrapped Application object.

getNegotiatedExtensions(List<Extension>, List<Extension>) - Method in class javax.websocket.server.ServerEndpointConfig.Configurator

Return the ordered list of extensions that t server endpoint will support given the requested extension list passed in, the empty list if none.

getNegotiatedExtensions() - Method in interface javax.websocket.Session

Return the list of extensions currently in use for this conversation.

getNegotiatedSubprotocol(List<String>, List<String>) - Method in class javax.websocket.server.ServerEndpointConfig.Configurator

Return the subprotocol the server endpoint has chosen from the requested list supplied by a client who wishes to connect, or none if there wasn't one this server endpoint liked.

getNegotiatedSubprotocol() - Method in interface javax.websocket.Session

Return the sub protocol agreed during the websocket handshake for this conversation.

getNewFolder() - Method in class javax.mail.event.FolderEvent

If this event indicates that a folder is renamed, (i.e, the event type is RENAMED), then this method returns the Folder object representing the new name.

getNewMessageCount() - Method in class javax.mail.Folder

Get the number of new messages in this Folder.

getNewsgroup() - Method in class javax.mail.internet.NewsAddress

Get the newsgroup.

getNewTempClassLoader() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Return a new instance of a ClassLoader that the provider may use to temporarily load any classes, resources, or open URLs.

getNewValue() - Method in class javax.faces.event.ValueChangeEvent

Return the current local value of the source UIComponent.

getNextException() - Method in exception javax.mail.MessagingException

Get the next exception chained to this one.

getNextHandler() - Method in interface javax.faces.view.facelets.TagConfig

The next FaceletHandler (child or children) to be applied.

getNextRunTime(LastExecution, Date) - Method in interface javax.enterprise.concurrent.Trigger

Retrieve the next time that the task should run after.

getNextTimeout() - Method in interface javax.ejb.Timer

Get the point in time at which the next timer expiration is scheduled to occur.

getNoCacheFields() - Method in class javax.ws.rs.core.CacheControl

Corresponds to the value of the no-cache cache control directive.

getNode(String) - Method in class javax.faces.flow.Flow

getNode(Object) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

By default, the getNode method is unsupported and throw an UnsupportedOperationException.

getNode() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getNode(Object) - Method in interface javax.xml.bind.Marshaller

Get a DOM tree view of the content tree(Optional).

getNode() - Method in interface javax.xml.bind.ValidationEventLocator

Return a reference to the DOM Node if available

getNoLocal() - Method in interface javax.jms.TopicSubscriber

Gets the NoLocal attribute for this subscriber.

getNonJtaDataSource() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the non-JTA-enabled data source to be used by the persistence provider for accessing data outside a JTA transaction.

getNonMatchingHeaderLines(String[]) - Method in class javax.mail.internet.InternetHeaders

Return all non-matching header lines

getNonMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeBodyPart

Get non-matching header lines as an Enumeration of Strings.

getNonMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeMessage

Get non-matching header lines as an Enumeration of Strings.

getNonMatchingHeaderLines(String[]) - Method in interface javax.mail.internet.MimePart

Get non-matching header lines as an Enumeration of Strings.

getNonMatchingHeaders(String[]) - Method in class javax.mail.internet.InternetHeaders

Return all non-matching Header objects.

getNonMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeBodyPart

Return non-matching headers from this Message as an Enumeration of Header objects.

getNonMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeMessage

Return non-matching headers from this Message as an Enumeration of Header objects.

getNonMatchingHeaders(String[]) - Method in interface javax.mail.Part

Return non-matching headers from this envelope as an Enumeration of Header objects.

getNonMatchingHeaders(String[]) - Method in class javax.xml.soap.MimeHeaders

Returns all of the MimeHeader objects whose name does not match a name in the given array of names.

getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.AttachmentPart

Retrieves all MimeHeader objects whose name does not match a name in the given array.

getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.SOAPPart

Retrieves all MimeHeader objects whose name does not match a name in the given array.

getNonRunningModules(ModuleType, Target[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Retrieve the list of Java EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.

getNoNSSchemaLocation() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the current noNamespaceSchemaLocation.

getNumber() - Method in class javax.mail.search.IntegerComparisonTerm

Return the number to compare with.

getNumber() - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Gets the telephone number suffix, not including the country or area code.

getObject(FaceletContext) - Method in class javax.faces.view.facelets.TagAttribute

Delegates to getObject with Object.class as a param

getObject(FaceletContext, Class) - Method in class javax.faces.view.facelets.TagAttribute

If literal, simply coerce our String literal value using an ExpressionFactory, otherwise create a ValueExpression and evaluate it.

getObject(String) - Method in interface javax.jms.MapMessage

Returns the value of the object with the specified name.

getObject() - Method in interface javax.jms.ObjectMessage

Gets the serializable object containing this message's data.

getObject() - Method in exception javax.persistence.LockTimeoutException

Returns the object that caused this exception.

getObject() - Method in exception javax.websocket.EncodeException

Return the Object that could not be encoded.

getObject() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getObject() - Method in interface javax.xml.bind.ValidationEventLocator

Return a reference to the object in the Java content tree if available

getObjectProperty(String) - Method in interface javax.jms.JMSProducer

Returns the message property with the specified name that has been set on this JMSProducer, converted to objectified format.

getObjectProperty(String) - Method in interface javax.jms.Message

Returns the value of the Java object property with the specified name.

getObjectType() - Method in interface javax.xml.registry.infomodel.RegistryObject

Gets the object type that best describes the RegistryObject.

getObservedQualifiers() - Method in interface javax.enterprise.inject.spi.ObserverMethod

Obtains the set of observed event qualifiers.

getObservedType() - Method in interface javax.enterprise.inject.spi.ObserverMethod

Obtains the observed event type.

getObserverMethod() - Method in interface javax.enterprise.inject.spi.ProcessObserverMethod

The ObserverMethod object that will be used by the container to invoke the observer when a matching event is fired.

getOffset() - Method in class javax.enterprise.deploy.shared.ActionType

Returns the lowest integer value used by this enumeration value's enumeration class.

getOffset() - Method in class javax.enterprise.deploy.shared.CommandType

Returns the lowest integer value used by this enumeration value's enumeration class.

getOffset() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType

Returns the lowest integer value used by this enumeration value's enumeration class.

getOffset() - Method in class javax.enterprise.deploy.shared.ModuleType

Returns the lowest integer value used by this enumeration value's enumeration class.

getOffset() - Method in class javax.enterprise.deploy.shared.StateType

Returns the lowest integer value used by this enumeration value's enumeration class.

getOffset() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getOffset() - Method in interface javax.xml.bind.ValidationEventLocator

Return the byte offset if available

getOldValue() - Method in class javax.faces.event.ValueChangeEvent

Return the previous local value of the source UIComponent.

getOn() - Method in interface javax.persistence.criteria.Join

Return the predicate that corresponds to the ON restriction(s) on the join, or null if no ON condition has been specified.

getOnblur() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onblur property.

getOnblur() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onblur property.

getOnchange() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onchange property.

getOnchange() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onchange property.

getOnclick() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onclick property.

getOnclick() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlBody

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlForm

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the ondblclick property.

getOndblclick() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the ondblclick property.

getOnerror() - Method in class javax.faces.component.behavior.AjaxBehavior

Return the String of JavaScript function name that will be used to identify the client callback function that should be run in the event of an error.

getOnevent() - Method in class javax.faces.component.behavior.AjaxBehavior

Return the String of JavaScript function name that will be used to identify the client callback function that should be run on the occurance of a client-side event.

getOnfocus() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onfocus property.

getOnfocus() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onfocus property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onkeydown property.

getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onkeydown property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onkeypress property.

getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onkeypress property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onkeyup property.

getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onkeyup property.

getOnload() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onload property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onmousedown property.

getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onmousedown property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onmousemove property.

getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onmousemove property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onmouseout property.

getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onmouseout property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onmouseover property.

getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onmouseover property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onmouseup property.

getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onmouseup property.

getOnreset() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onreset property.

getOnselect() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the onselect property.

getOnselect() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the onselect property.

getOnsubmit() - Method in class javax.faces.component.html.HtmlForm

Return the value of the onsubmit property.

getOnunload() - Method in class javax.faces.component.html.HtmlBody

Return the value of the onunload property.

getOpenSessions() - Method in interface javax.websocket.Session

Return a copy of the Set of all the open web socket sessions that represent connections to the same endpoint to which this session represents a connection.

getOperationName() - Method in interface javax.xml.rpc.Call

Gets the name of the operation to be invoked using this Call instance.

getOperator() - Method in interface javax.persistence.criteria.Predicate

Return the boolean operator for the predicate.

getOrderList() - Method in interface javax.persistence.criteria.CriteriaQuery

Return the ordering expressions in order of precedence.

getOrdinal() - Method in class javax.faces.application.FacesMessage.Severity

Return the ordinal value of this FacesMessage.Severity instance.

getOrdinal() - Method in class javax.faces.event.PhaseId

Return the ordinal value of this PhaseId instance.

getOrganization() - Method in interface javax.xml.registry.infomodel.User

Gets the Organization that this User is affiliated with.

getOrigin() - Method in interface javax.management.j2ee.statistics.JMSConsumerStats

Returns a string that encapsulates the identity of a message origin

getOut() - Method in class javax.servlet.jsp.JspContext

The current value of the out object (a JspWriter).

getOutboundParameters() - Method in class javax.faces.flow.FlowCallNode

getOutcome() - Method in class javax.faces.component.UIOutcomeTarget

Returns the outcome property of the UIOutcomeTarget.

getOutcome() - Method in class javax.faces.flow.MethodCallNode

Return the outcome to be used in the event of a null return from the method.

getOutputParameterValue(int) - Method in interface javax.persistence.StoredProcedureQuery

Retrieve a value passed back from the procedure through an INOUT or OUT parameter.

getOutputParameterValue(String) - Method in interface javax.persistence.StoredProcedureQuery

Retrieve a value passed back from the procedure through an INOUT or OUT parameter.

getOutputParams() - Method in interface javax.xml.rpc.Call

Returns a Map of {name, value} for the output parameters of the last invoked operation.

getOutputStream() - Method in class javax.mail.internet.MimePartDataSource

DataSource method to return an output stream.

getOutputStream() - Method in class javax.mail.util.ByteArrayDataSource

Return an OutputStream for the data.

getOutputStream() - Method in interface javax.servlet.http.WebConnection

Returns an output stream for this web connection.

getOutputStream() - Method in interface javax.servlet.ServletResponse

Returns a ServletOutputStream suitable for writing binary data in the response.

getOutputStream() - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to return getOutputStream() on the wrapped response object.

getOutputStream() - Method in interface javax.ws.rs.ext.WriterInterceptorContext

Get the output stream for the object to be written.

getOutputValues() - Method in interface javax.xml.rpc.Call

Returns a List values for the output parameters of the last invoked operation.

getPage() - Method in class javax.servlet.jsp.PageContext

The current value of the page object (In a Servlet environment, this is an instance of javax.servlet.Servlet).

getPageContext(Servlet, ServletRequest, ServletResponse, String, boolean, int, boolean) - Method in class javax.servlet.jsp.JspFactory

obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.

getPageEncoding() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the value of the page-encoding configuration, which specifies the default page encoding for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.

getParameter(String) - Method in class javax.mail.internet.ContentDisposition

Return the specified parameter value.

getParameter(String) - Method in class javax.mail.internet.ContentType

Return the specified parameter value.

getParameter(String) - Method in interface javax.persistence.Query

Get the parameter object corresponding to the declared parameter of the given name.

getParameter(String, Class<T>) - Method in interface javax.persistence.Query

Get the parameter object corresponding to the declared parameter of the given name and type.

getParameter(int) - Method in interface javax.persistence.Query

Get the parameter object corresponding to the declared positional parameter with the given position.

getParameter(int, Class<T>) - Method in interface javax.persistence.Query

Get the parameter object corresponding to the declared positional parameter with the given position and type.

getParameter(String) - Method in interface javax.servlet.ServletRequest

Returns the value of a request parameter as a String, or null if the parameter does not exist.

getParameter(String) - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getParameter(String name) on the wrapped request object.

getParameterDescriptors() - Method in interface javax.validation.metadata.ExecutableDescriptor

Returns a list of descriptors representing this executable's parameters, in the order of their declaration, including synthetic parameters.

getParameterIndex() - Method in interface javax.validation.Path.ParameterNode

getParameterList() - Method in class javax.mail.internet.ContentDisposition

Return a ParameterList object that holds all the available parameters.

getParameterList() - Method in class javax.mail.internet.ContentType

Return a ParameterList object that holds all the available parameters.

getParameterMap() - Method in interface javax.servlet.ServletRequest

Returns a java.util.Map of the parameters of this request.

getParameterMap() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getParameterMap() on the wrapped request object.

getParameterMap() - Method in interface javax.websocket.server.HandshakeRequest

Return the request parameters associated with the request.

getParameterNameProvider() - Method in interface javax.validation.spi.ConfigurationState

Returns the parameter name provider for this configuration.

getParameterNameProvider() - Method in interface javax.validation.ValidatorFactory

Returns the ParameterNameProvider instance configured at initialization time for the ValidatorFactory.

getParameterNameProviderClassName() - Method in interface javax.validation.BootstrapConfiguration

Class name of the ParameterNameProvider implementation or null if none is specified.

getParameterNames() - Method in interface javax.servlet.ServletRequest

Returns an Enumeration of String objects containing the names of the parameters contained in this request.

getParameterNames() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getParameterNames() on the wrapped request object.

getParameterNames(Constructor<?>) - Method in interface javax.validation.ParameterNameProvider

Returns the names of the parameters of the given constructor.

getParameterNames(Method) - Method in interface javax.validation.ParameterNameProvider

Returns the names of the parameters of the given method.

getParameters(long) - Method in interface javax.batch.operations.JobOperator

Returns job parameters for a specified job instance.

getParameters() - Method in interface javax.enterprise.inject.spi.AnnotatedCallable

Get the parameters of the callable member.

getParameters() - Method in class javax.faces.application.NavigationCase

Return the parameters to be included for navigation cases requiring a redirect.

getParameters() - Method in class javax.faces.application.NavigationCaseWrapper

getParameters() - Method in class javax.faces.component.behavior.ClientBehaviorContext

Returns parameters that "submitting" ClientBehavior implementations should include when posting back data into the Faces lifecycle.

getParameters() - Method in class javax.faces.flow.MethodCallNode

Return the parameters to be passed to the method.

getParameters() - Method in interface javax.interceptor.InvocationContext

Returns the parameter values that will be passed to the method or constructor of the target class.

getParameters() - Method in interface javax.persistence.criteria.CriteriaQuery

Return the parameters of the query.

getParameters() - Method in interface javax.persistence.Query

Get the parameter objects corresponding to the declared parameters of the query.

getParameters() - Method in interface javax.websocket.Extension

The extension parameters for this extension in the order they appear in the http headers.

getParameters() - Method in class javax.ws.rs.core.MediaType

Getter for a read-only parameter map.

getParameterType() - Method in interface javax.persistence.Parameter

Return the Java type of the parameter.

getParameterTypeByName(String) - Method in interface javax.xml.rpc.Call

Gets the XML type of a parameter by name

getParameterTypes() - Method in interface javax.validation.Path.ConstructorNode

getParameterTypes() - Method in interface javax.validation.Path.MethodNode

getParameterValue(Parameter<T>) - Method in interface javax.persistence.Query

Return the input value bound to the parameter.

getParameterValue(String) - Method in interface javax.persistence.Query

Return the input value bound to the named parameter.

getParameterValue(int) - Method in interface javax.persistence.Query

Return the input value bound to the positional parameter.

getParameterValues(String) - Method in interface javax.servlet.ServletRequest

Returns an array of String objects containing all of the values the given request parameter has, or null if the parameter does not exist.

getParameterValues(String) - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getParameterValues(String name) on the wrapped request object.

getParams() - Method in class javax.ws.rs.core.Link

Returns an immutable map that includes all the link parameters defined on this link.

getParams() - Method in class javax.ws.rs.core.Link.JaxbLink

Get the parameter map for this link.

getParamTypes() - Method in class javax.el.MethodInfo

Returns the parameter types of the method

getParent() - Method in class javax.faces.component.UIComponent

Return the parent UIComponent of this UIComponent, if any.

getParent() - Method in class javax.faces.component.UIComponentBase

getParent() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Return the Tag that is the parent of this instance.

getParent() - Method in class javax.mail.BodyPart

Return the containing Multipart object, or null if not known.

getParent() - Method in class javax.mail.Folder

Returns the parent folder of this folder.

getParent() - Method in class javax.mail.Multipart

Return the Part that contains this Multipart object, or null if not known.

getParent() - Method in interface javax.persistence.criteria.Fetch

Return the parent of the fetched item.

getParent() - Method in interface javax.persistence.criteria.Join

Return the parent of the join.

getParent() - Method in interface javax.persistence.criteria.Subquery

Return the query of which this is a subquery.

getParent() - Method in interface javax.servlet.jsp.tagext.SimpleTag

Returns the parent of this tag, for collaboration purposes.

getParent() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport

Returns the parent of this tag, for collaboration purposes.

getParent() - Method in interface javax.servlet.jsp.tagext.Tag

Get the parent (closest enclosing tag handler) for this tag handler.

getParent() - Method in class javax.servlet.jsp.tagext.TagAdapter

Returns the parent of this tag, which is always getAdaptee().getParent().

getParent() - Method in class javax.servlet.jsp.tagext.TagSupport

The Tag instance most closely enclosing this tag instance.

getParent() - Method in interface javax.xml.registry.infomodel.Concept

Gets the parent Concept or ClassificationScheme for this object.

getParentConcept() - Method in interface javax.xml.registry.infomodel.Concept

Gets the parent Concept or null if parent is a ClassificationScheme.

getParentElement() - Method in interface javax.xml.soap.Node

Returns the parent element of this Node object.

getParentOrganization() - Method in interface javax.xml.registry.infomodel.Organization

Gets the parent (container) organization.

getParentPath() - Method in interface javax.persistence.criteria.Path

Return the parent "node" in the path or null if no parent.

getParentTargetModuleID() - Method in interface javax.enterprise.deploy.spi.TargetModuleID

Retrieve the identifier of the parent object of this deployed module.

getParentUIComponentClassicTagBase(PageContext) - Static method in class javax.faces.webapp.UIComponentClassicTagBase

Locate and return the nearest enclosing UIComponentClassicTagBase if any; otherwise, return null.

getParentUIComponentTag(PageContext) - Static method in class javax.faces.webapp.UIComponentTag

Deprecated.

Locate and return the nearest enclosing UIComponentTag if any; otherwise, return null.

getPart() - Method in class javax.mail.MessageContext

Return the Part that contains the content.

getPart(String) - Method in interface javax.servlet.http.HttpServletRequest

Gets the Part with the given name.

getPart(String) - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to call getPart on the wrapped request object.

getPartialResponseWriter() - Method in class javax.faces.context.PartialViewContext

Return the ResponseWriter to which components should direct their output for partial view rendering.

getPartialResponseWriter() - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.getPartialResponseWriter() on the wrapped PartialViewContext object.

getPartialViewContext() - Method in class javax.faces.context.FacesContext

Return the PartialViewContext for this request.

getPartialViewContext() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getPartialViewContext() ()} on the wrapped FacesContext object.

getPartialViewContext(FacesContext) - Method in class javax.faces.context.PartialViewContextFactory

Create (if needed) and return a PartialViewContext instance that is initialized using the current FacesContext instance.

getPartitionProperties() - Method in interface javax.batch.api.partition.PartitionPlan

Gets array of Partition Properties objects for Partitions.

getPartitionProperties() - Method in class javax.batch.api.partition.PartitionPlanImpl

getPartitions() - Method in interface javax.batch.api.partition.PartitionPlan

Gets count of Partitions.

getPartitions() - Method in class javax.batch.api.partition.PartitionPlanImpl

getPartitionsOverride() - Method in interface javax.batch.api.partition.PartitionPlan

Return current value of partition override setting.

getPartitionsOverride() - Method in class javax.batch.api.partition.PartitionPlanImpl

getParts() - Method in interface javax.servlet.http.HttpServletRequest

Gets all the Part components of this request, provided that it is of type multipart/form-data.

getParts() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to call getParts on the wrapped request object.

getPassivationCapableBean(String) - Method in interface javax.enterprise.inject.spi.BeanManager

Returns the PassivationCapable bean with the given identifier.

getPassiveCount() - Method in interface javax.management.j2ee.statistics.StatefulSessionBeanStats

Number of beans that are in the passive state.

getPassThroughAttributes() - Method in class javax.faces.component.UIComponent

This is a convenience method that simply calls UIComponent.getPassThroughAttributes(boolean), passing true as the argument.

getPassThroughAttributes(boolean) - Method in class javax.faces.component.UIComponent

This method has the same specification as UIComponent.getPassThroughAttributes() except that it is allowed to return null if and only if the argument create is false and no pass through attribute data structure exists for this instance.

getPassThroughAttributes(boolean) - Method in class javax.faces.component.UIComponentBase

getPassword() - Method in class javax.mail.PasswordAuthentication

getPassword() - Method in class javax.mail.URLName

Returns the password of this URLName.

getPassword() - Method in class javax.resource.spi.security.PasswordCredential

Returns the user password.

getPassword() - Method in class javax.security.auth.message.callback.PasswordValidationCallback

Get the password.

getPasswordAuthentication() - Method in class javax.mail.Authenticator

Called when password authentication is needed.

getPasswordAuthentication(URLName) - Method in class javax.mail.Session

Return any saved PasswordAuthentication for this (store or transport) URLName.

getPath() - Method in class javax.faces.view.Location

Return the file path to the page represented by this location.

getPath() - Method in class javax.servlet.http.Cookie

Returns the path on the server to which the browser returns this cookie.

getPath() - Method in class javax.servlet.jsp.tagext.TagFileInfo

Where to find the .tag file implementing this action.

getPath() - Method in interface javax.servlet.SessionCookieConfig

Gets the path that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

getPath() - Method in interface javax.websocket.server.ServerEndpointConfig

Return the path for this endpoint configuration.

getPath() - Method in class javax.ws.rs.core.Cookie

Get the path of the cookie.

getPath() - Method in interface javax.ws.rs.core.PathSegment

Get the path segment.

getPath() - Method in interface javax.ws.rs.core.UriInfo

Get the path of the current request relative to the base URI as a string.

getPath(boolean) - Method in interface javax.ws.rs.core.UriInfo

Get the path of the current request relative to the base URI as a string.

getPath() - Method in interface javax.xml.registry.infomodel.Concept

Gets the canonical path representation for this Concept.

getPath() - Method in class javax.xml.ws.spi.http.HttpContext

Returns the path for this context.

getPathInfo() - Method in interface javax.servlet.http.HttpServletRequest

Returns any extra path information associated with the URL the client sent when it made this request.

getPathInfo() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getPathInfo() on the wrapped request object.

getPathInfo() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the extra path information that follows the web service path but precedes the query string in the request URI and will start with a "/" character.

getPathParameters() - Method in interface javax.websocket.Session

Return a map of the path parameter names and values used associated with the request this session was opened under.

getPathParameters() - Method in interface javax.ws.rs.core.UriInfo

Get the values of any embedded URI template parameters.

getPathParameters(boolean) - Method in interface javax.ws.rs.core.UriInfo

Get the values of any embedded URI template parameters.

getPathSegments() - Method in interface javax.ws.rs.core.UriInfo

Get the path of the current request relative to the base URI as a list of PathSegment.

getPathSegments(boolean) - Method in interface javax.ws.rs.core.UriInfo

Get the path of the current request relative to the base URI as a list of PathSegment.

getPathTranslated() - Method in interface javax.servlet.http.HttpServletRequest

Returns any extra path information after the servlet name but before the query string, and translates it to a real path.

getPathTranslated() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getPathTranslated() on the wrapped request object.

getPattern() - Method in class javax.faces.convert.DateTimeConverter

Return the format pattern to be used when formatting and parsing dates and times.

getPattern() - Method in class javax.faces.convert.NumberConverter

Return the format pattern to be used when formatting and parsing numbers.

getPattern() - Method in class javax.faces.validator.RegexValidator

Return the ValueExpression that yields the regular expression pattern when evaluated.

getPattern() - Method in class javax.mail.search.StringTerm

Return the string to match with.

getPayload() - Method in interface javax.validation.metadata.ConstraintDescriptor

The set of payload the constraint hosts.

getPayload() - Method in interface javax.xml.ws.LogicalMessage

Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.

getPayload(JAXBContext) - Method in interface javax.xml.ws.LogicalMessage

Gets the message payload as a JAXB object.

getPendingMessageCount() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats

Number of pending messages.

getPendingMessageCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats

Number of pending messages.

getPermanentFlags() - Method in class javax.mail.Folder

Get the permanent flags supported by this Folder.

getPersistenceProviderClassName() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the fully qualified name of the persistence provider implementation class.

getPersistenceProviderResolver() - Static method in class javax.persistence.spi.PersistenceProviderResolverHolder

Returns the current persistence provider resolver.

getPersistenceProviders() - Method in interface javax.persistence.spi.PersistenceProviderResolver

Returns a list of the PersistenceProvider implementations available in the runtime environment.

getPersistenceType() - Method in interface javax.persistence.metamodel.Type

Return the persistence type.

getPersistenceUnitName() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the name of the persistence unit.

getPersistenceUnitRootUrl() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the URL for the jar file or directory that is the root of the persistence unit.

getPersistenceUnitUtil() - Method in interface javax.persistence.EntityManagerFactory

Return interface providing access to utility methods for the persistence unit.

getPersistenceUtil() - Static method in class javax.persistence.Persistence

Return the PersistenceUtil instance

getPersistenceXMLSchemaVersion() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the schema version of the persistence.xml file.

getPersistentAttributeType() - Method in interface javax.persistence.metamodel.Attribute

Return the persistent attribute type for the attribute.

getPersistentUserData() - Method in interface javax.batch.runtime.context.StepContext

The getPersistentUserData method returns a persistent data object belonging to the current step.

getPersistentUserData() - Method in interface javax.batch.runtime.StepExecution

Get user persistent data

getPersonal() - Method in class javax.mail.internet.InternetAddress

Get the personal name.

getPersonalNamespaces() - Method in class javax.mail.Store

Return a set of folders representing the personal namespaces for the current user.

getPersonName() - Method in interface javax.xml.registry.infomodel.User

Returns the name of this User.

getPhase() - Method in class javax.faces.component.UIViewAction

Returns the name of the lifecycle phase in which the action is to be queued.

getPhaseId() - Method in class javax.faces.event.ExceptionQueuedEventContext

Return the PhaseId which was being processed when the exception was thrown.

getPhaseId() - Method in class javax.faces.event.FacesEvent

Return the identifier of the request processing phase during which this event should be delivered.

getPhaseId() - Method in class javax.faces.event.PhaseEvent

Return the PhaseId representing the current request processing lifecycle phase.

getPhaseId() - Method in interface javax.faces.event.PhaseListener

Return the identifier of the request processing phase during which this listener is interested in processing PhaseEvent events.

getPhaseListeners() - Method in class javax.faces.component.UIViewRoot

Return an unmodifiable list of the PhaseListener instances attached to this UIViewRoot instance.

getPhaseListeners() - Method in class javax.faces.lifecycle.Lifecycle

Return the set of registered PhaseListeners for this Lifecycle instance.

getPhaseListeners() - Method in class javax.faces.lifecycle.LifecycleWrapper

getPluralAttributes() - Method in interface javax.persistence.metamodel.ManagedType

Return all multi-valued attributes (Collection-, Set-, List-, and Map-valued attributes) of the managed type.

getPolicyConfiguration(String, boolean) - Method in class javax.security.jacc.PolicyConfigurationFactory

This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider.

getPolicyConfigurationFactory() - Static method in class javax.security.jacc.PolicyConfigurationFactory

This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class.

getPooledCount() - Method in interface javax.management.j2ee.statistics.EntityBeanStats

Number of beans in the pooled state.

getPoolSize() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats

The size of the connection pool

getPoolSize() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats

Size of the connection pool.

getPort() - Method in class javax.mail.URLName

Returns the port number of this URLName.

getPort(QName, Class) - Method in interface javax.xml.rpc.Service

The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.

getPort(Class) - Method in interface javax.xml.rpc.Service

The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.EndpointReference

The getPort method returns a proxy.

getPort(QName, Class<T>) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(QName, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(Class<T>) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider

The getPort method returns a proxy.

getPort(QName, Class<T>) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(QName, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(Class<T>) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPortName() - Method in interface javax.xml.ws.handler.PortInfo

Gets the qualified name of the WSDL port being accessed.

getPorts() - Method in interface javax.xml.rpc.Service

Returns an Iterator for the list of QNames of service endpoints grouped by this service

getPorts() - Method in class javax.xml.ws.Service

Returns an Iterator for the list of QNames of service endpoints grouped by this service

getPorts() - Method in class javax.xml.ws.spi.ServiceDelegate

Returns an Iterator for the list of QNames of service endpoints grouped by this service

getPortTypeName() - Method in interface javax.xml.rpc.Call

Gets the qualified name of the port type.

getPos() - Method in exception javax.mail.internet.AddressException

Get the position with the reference string where the error was detected (-1 if not relevant).

getPosition() - Method in interface javax.enterprise.inject.spi.AnnotatedParameter

Get the position of the parameter in the method or constructor argument list.

getPosition() - Method in interface javax.mail.internet.SharedInputStream

Return the current position in the InputStream, as an offset from the beginning of the InputStream.

getPosition() - Method in class javax.mail.util.SharedByteArrayInputStream

Return the current position in the InputStream, as an offset from the beginning of the InputStream.

getPosition() - Method in class javax.mail.util.SharedFileInputStream

Return the current position in the InputStream, as an offset from the beginning of the InputStream.

getPosition() - Method in interface javax.persistence.Parameter

Return the parameter position, or null if the parameter is not a positional parameter.

getPostalAddress() - Method in interface javax.xml.registry.infomodel.Organization

Gets the Address for this Organization.

getPostalAddresses() - Method in interface javax.xml.registry.infomodel.User

Gets the postal address for this User.

getPostalCode() - Method in interface javax.xml.registry.infomodel.PostalAddress

Returns the postal or zip code.

getPostalScheme() - Method in interface javax.xml.registry.infomodel.PostalAddress

Returns a user-defined postal scheme for codifying the attributes of PostalAddress.

getPreamble() - Method in class javax.mail.internet.MimeMultipart

Get the preamble text, if any, that appears before the first body part of this multipart.

getPreferredSubprotocols() - Method in interface javax.websocket.ClientEndpointConfig

Return the ordered list of sub protocols a client endpoint would like to use, in order of preference, favorite first that this client would like to use for its sessions.

getPrefix() - Method in interface javax.xml.soap.Name

Returns the prefix that was specified when this Name object was initialized.

getPrefixString() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

The prefix assigned to this taglib from the taglib directive

getPreviousOut() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Get the JspWriter from our BodyContent.

getPreviousOut() - Method in class javax.servlet.jsp.tagext.BodyTagSupport

Get surrounding out JspWriter.

getPrimaryContact() - Method in interface javax.xml.registry.infomodel.Organization

Gets the primary Contact for this Organization.

getPrimaryKey() - Method in interface javax.ejb.EJBLocalObject

Obtain the primary key of the EJB local object.

getPrimaryKey() - Method in interface javax.ejb.EJBObject

Obtain the primary key of the EJB object.

getPrimaryKey() - Method in interface javax.ejb.EntityContext

Obtain the primary key of the EJB object that is currently associated with this instance.

getPrimaryKeyClass() - Method in interface javax.ejb.EJBMetaData

Obtain the class object for the enterprise bean's primary key class.

getPrimaryType() - Method in class javax.mail.internet.ContentType

Return the primary type.

getPrincipal() - Method in class javax.security.auth.message.callback.CallerPrincipalCallback

Get the caller principal.

getPriority() - Method in interface javax.jms.JMSProducer

Return the priority of messages that are sent using this JMSProducer

getPriority() - Method in interface javax.jms.MessageProducer

Gets the producer's default priority.

getPrivateFields() - Method in class javax.ws.rs.core.CacheControl

Corresponds to the value of the private cache control directive.

getProducer() - Method in interface javax.enterprise.inject.spi.ProcessProducer

Returns the Producer object that will be used by the container to call the producer method or read the producer field.

getProducerFactory(AnnotatedField<? super X>, Bean<X>) - Method in interface javax.enterprise.inject.spi.BeanManager

An implementation of ProducerFactory that provides container created Producer instances for the given field.

getProducerFactory(AnnotatedMethod<? super X>, Bean<X>) - Method in interface javax.enterprise.inject.spi.BeanManager

An implementation of ProducerFactory that provides container created Producer instances for the given method.

getProducers() - Method in interface javax.management.j2ee.statistics.JMSSessionStats

Returns an array of JMSProducerStats that provide statistics about the message producers associated with the referencing JMS session statistics.

getProductVersion() - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory

Provide a string identifying version of this vendor's DeploymentManager.

getProjectStage() - Method in class javax.faces.application.Application

Return the project stage for the currently running application instance.

getProjectStage() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getProjectStage() on the wrapped Application object.

getProperties() - Method in interface javax.batch.runtime.context.JobContext

The getProperties method returns the job level properties specified in a job definition.

getProperties() - Method in interface javax.batch.runtime.context.StepContext

The getProperties method returns the step level properties specified in a job definition.

getProperties() - Method in class javax.mail.Session

Returns the Properties object associated with this Session

getProperties() - Method in interface javax.persistence.EntityManager

Get the properties and hints and associated values that are in effect for the entity manager.

getProperties() - Method in interface javax.persistence.EntityManagerFactory

Get the properties and associated values that are in effect for the entity manager factory.

getProperties() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns a properties object.

getProperties() - Method in interface javax.validation.BootstrapConfiguration

Returns properties as a map of string based key/value pairs.

getProperties() - Method in interface javax.validation.spi.ConfigurationState

Returns a map of non type-safe custom properties.

getProperties() - Method in class javax.ws.rs.core.Application

Get a map of custom application-wide properties.

getProperties() - Method in interface javax.ws.rs.core.Configuration

Get the immutable bag of configuration properties.

getProperties() - Method in class javax.xml.registry.ConnectionFactory

Gets the Properties used during createConnection and createFederatedConnection calls.

getProperties() - Method in class javax.xml.ws.Endpoint

Returns the property bag for this Endpoint instance.

getProperty() - Method in class javax.el.ValueReference

getProperty(String) - Method in class javax.faces.view.facelets.MetadataTarget

Return a beans PropertyDescriptor for the property with name given by argument name.

getProperty(String) - Method in class javax.mail.Session

Returns the value of the specified property.

getProperty(String) - Method in interface javax.ws.rs.client.ClientRequestContext

Returns the property with the given name registered in the current request/response exchange context, or null if there is no property by that name.

getProperty(String) - Method in interface javax.ws.rs.container.ContainerRequestContext

Returns the property with the given name registered in the current request/response exchange context, or null if there is no property by that name.

getProperty(String) - Method in interface javax.ws.rs.core.Configuration

Get the value for the property with a given name.

getProperty(String) - Method in interface javax.ws.rs.ext.InterceptorContext

Returns the property with the given name registered in the current request/response exchange context, or null if there is no property by that name.

getProperty(String) - Method in class javax.xml.bind.Binder

Get the particular property in the underlying implementation of Binder.

getProperty(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Default implementation of the getProperty method handles the four defined properties in Marshaller.

getProperty(String) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Default implementation of the getProperty method always throws PropertyException since there are no required properties.

getProperty(String) - Method in interface javax.xml.bind.Marshaller

Get the particular property in the underlying implementation of Marshaller.

getProperty(String) - Method in interface javax.xml.bind.Unmarshaller

Get the particular property in the underlying implementation of Unmarshaller.

getProperty(String) - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

getProperty(String) - Method in interface javax.xml.rpc.Call

Gets the value of a named property.

getProperty(String) - Method in interface javax.xml.rpc.handler.MessageContext

Gets the value of a specific property from the MessageContext

getProperty(String) - Method in class javax.xml.soap.SOAPMessage

Retrieves value of the specified property.

getPropertyName() - Method in interface javax.validation.metadata.PropertyDescriptor

Name of the property according to the Java Bean specification.

getPropertyNames() - Method in interface javax.jms.JMSProducer

Returns an unmodifiable Set view of the names of all the message properties that have been set on this JMSProducer.

getPropertyNames() - Method in interface javax.jms.Message

Returns an Enumeration of all the property names.

getPropertyNames() - Method in interface javax.ws.rs.client.ClientRequestContext

Returns an immutable collection containing the property names available within the context of the current request/response exchange context.

getPropertyNames() - Method in interface javax.ws.rs.container.ContainerRequestContext

Returns an immutable collection containing the property names available within the context of the current request/response exchange context.

getPropertyNames() - Method in interface javax.ws.rs.core.Configuration

Returns an immutable collection containing the property names available within the context of the current configuration instance.

getPropertyNames() - Method in interface javax.ws.rs.ext.InterceptorContext

Returns an immutable collection containing the property names available within the context of the current request/response exchange context.

getPropertyNames() - Method in interface javax.xml.rpc.Call

Gets the names of configurable properties supported by this Call object.

getPropertyNames() - Method in interface javax.xml.rpc.handler.MessageContext

Returns an Iterator view of the names of the properties in this MessageContext

getPropertyPath() - Method in interface javax.validation.ConstraintViolation

getPropertyResolver() - Method in class javax.faces.application.Application

Deprecated.
This has been replaced by Application.getELResolver().

getPropertyResolver() - Method in class javax.faces.application.ApplicationWrapper

Deprecated.
See superclass for alternative.

getPropertyType(String) - Method in class javax.faces.view.facelets.MetadataTarget

Return a Class for the property with name given by argument name.

getProtectedViewsUnmodifiable() - Method in class javax.faces.application.ViewHandler

Return an unmodifiable Set of the protected views currently known to this ViewHandler instance.

getProtectedViewsUnmodifiable() - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.getProtectedViewsUnmodifiable() on the wrapped ViewHandler object.

getProtectionPolicy() - Method in class javax.security.auth.message.MessagePolicy.TargetPolicy

Get the ProtectionPolicy that applies to the targets.

getProtocol() - Method in class javax.mail.Provider

Returns the protocol supported by this Provider

getProtocol() - Method in class javax.mail.URLName

Returns the protocol of this URLName.

getProtocol() - Method in interface javax.servlet.ServletRequest

Returns the name and version of the protocol the request uses in the form protocol/majorVersion.minorVersion, for example, HTTP/1.1.

getProtocol() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getProtocol() on the wrapped request object.

getProtocol() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the protocol string from the request in the form protocol/majorVersion.minorVersion.

getProtocolVersion() - Method in interface javax.websocket.Session

Returns the version of the websocket protocol currently being used.

getProvider(String) - Method in class javax.mail.Session

Returns the default Provider for the protocol specified.

getProviderMajorVersion() - Method in interface javax.jms.ConnectionMetaData

Gets the JMS provider major version number.

getProviderMinorVersion() - Method in interface javax.jms.ConnectionMetaData

Gets the JMS provider minor version number.

getProviders() - Method in class javax.mail.Session

This method returns an array of all the implementations installed via the javamail.[default.]providers files that can be loaded using the ClassLoader available to this application.

getProviderUtil() - Method in interface javax.persistence.spi.PersistenceProvider

Return the utility interface implemented by the persistence provider.

getProviderVersion() - Method in interface javax.jms.ConnectionMetaData

Gets the JMS provider version.

getProvidingOrganization() - Method in interface javax.xml.registry.infomodel.Service

Gets the Organization that provides this service.

getPublic() - Method in class javax.faces.component.html.HtmlDoctype

Return the value of the public property.

getQName() - Method in class javax.faces.view.facelets.Tag

Return the XML qualified name for this tag.

getQName() - Method in class javax.faces.view.facelets.TagAttribute

The qualified name for this attribute

getQualifiedName() - Method in interface javax.xml.soap.Name

Gets the namespace-qualified name of the XML name that this Name object represents.

getQualifierHashCode(Annotation) - Method in interface javax.enterprise.inject.spi.BeanManager

Determine the hash code of a qualifier, using the JDK algorithm for determining an annotation hash code, ignoring any members annotated with Nonbinding.

getQualifiers() - Method in interface javax.enterprise.inject.spi.BeanAttributes

Obtains the qualifiers of the bean.

getQualifiers() - Method in interface javax.enterprise.inject.spi.EventMetadata

Get the qualifiers for which event payload was fired.

getQualifiers() - Method in interface javax.enterprise.inject.spi.InjectionPoint

Get the required qualifiers of the injection point.

getQuery() - Method in exception javax.persistence.QueryTimeoutException

Returns the query that caused this exception.

getQueryParameters() - Method in interface javax.ws.rs.core.UriInfo

Get the URI query parameters of the current request.

getQueryParameters(boolean) - Method in interface javax.ws.rs.core.UriInfo

Get the URI query parameters of the current request.

getQueryString() - Method in interface javax.servlet.http.HttpServletRequest

Returns the query string that is contained in the request URL after the path.

getQueryString() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getQueryString() on the wrapped request object.

getQueryString() - Method in interface javax.websocket.server.HandshakeRequest

Return the query string associated with the request.

getQueryString() - Method in interface javax.websocket.Session

Return the query string associated with the request this session was opened under.

getQueryString() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the query string that is contained in the request URI after the path.

getQueryURLParameters(FacesContext) - Method in class javax.faces.lifecycle.ClientWindow

This method will be called whenever a URL is generated by the runtime where client window related parameters need to be inserted into the URL.

getQueryURLParameters(FacesContext) - Method in class javax.faces.lifecycle.ClientWindowWrapper

getQueue() - Method in interface javax.jms.QueueBrowser

Gets the queue associated with this queue browser.

getQueue() - Method in interface javax.jms.QueueReceiver

Gets the Queue associated with this queue receiver.

getQueue() - Method in interface javax.jms.QueueSender

Gets the queue associated with this QueueSender.

getQueueName() - Method in interface javax.jms.Queue

Gets the name of this queue.

getQueueSession() - Method in interface javax.jms.XAQueueSession

Gets the queue session associated with this XAQueueSession.

getQuota(String) - Method in interface javax.mail.QuotaAwareStore

Get the quotas for the named folder.

getRawContent() - Method in class javax.xml.soap.AttachmentPart

Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

getRawContentBytes() - Method in class javax.xml.soap.AttachmentPart

Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

getRawInputStream() - Method in class javax.mail.internet.MimeBodyPart

Return an InputStream to the raw data with any Content-Transfer-Encoding intact.

getRawInputStream() - Method in class javax.mail.internet.MimeMessage

Return an InputStream to the raw data with any Content-Transfer-Encoding intact.

getRawType() - Method in class javax.enterprise.util.TypeLiteral

getRawType() - Method in class javax.ws.rs.core.GenericEntity

Gets the raw type of the enclosed entity.

getRawType() - Method in class javax.ws.rs.core.GenericType

Returns the object representing the class or interface that declared the type represented by this generic type instance.

getReader() - Method in class javax.servlet.jsp.tagext.BodyContent

Return the value of this BodyContent as a Reader.

getReader() - Method in interface javax.servlet.ServletRequest

Retrieves the body of the request as character data using a BufferedReader.

getReader() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getReader() on the wrapped request object.

getReadMethod(String) - Method in class javax.faces.view.facelets.MetadataTarget

Return a Method for the getter of the property with name given by argument name.

getReadyCount() - Method in interface javax.management.j2ee.statistics.EntityBeanStats

Number of beans in the ready state.

getRealPath(String) - Method in class javax.faces.context.ExternalContext

Returns a String containing the real path for a given virtual path.

getRealPath(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRealPath(String) on the wrapped ExternalContext object.

getRealPath(String) - Method in interface javax.servlet.ServletContext

Gets the real path corresponding to the given virtual path.

getRealPath(String) - Method in interface javax.servlet.ServletRequest

Deprecated.
As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.

getRealPath(String) - Method in class javax.servlet.ServletRequestWrapper

Deprecated.
As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead

getReasonPhrase() - Method in class javax.websocket.CloseReason

The reason phrase associated with this CloseReason.

getReasonPhrase() - Method in enum javax.ws.rs.core.Response.Status

Get the reason phrase.

getReasonPhrase() - Method in interface javax.ws.rs.core.Response.StatusType

Get the reason phrase.

getReceivedDate() - Method in class javax.mail.internet.MimeMessage

Returns the Date on this message was received.

getReceivedDate() - Method in class javax.mail.Message

Get the date this message was received.

getReception() - Method in interface javax.enterprise.inject.spi.ObserverMethod

Obtains the specified Reception for the observer method.

getRecipients(Message.RecipientType) - Method in class javax.mail.internet.MimeMessage

Returns the recepients specified by the type.

getRecipients(Message.RecipientType) - Method in class javax.mail.Message

Get all the recipient addresses of the given type.

getRecipientType() - Method in class javax.mail.search.RecipientStringTerm

Return the type of recipient to match with.

getRecipientType() - Method in class javax.mail.search.RecipientTerm

Return the type of recipient to match with.

getRecordFactory() - Method in interface javax.resource.cci.ConnectionFactory

Gets a RecordFactory instance.

getRecordName() - Method in interface javax.resource.cci.Record

Gets the name of the Record.

getRecordShortDescription() - Method in interface javax.resource.cci.Record

Gets a short description string for the Record.

getRedirectURL(FacesContext) - Method in class javax.faces.application.NavigationCase

Construct an absolute URL suitable for a "redirect" to this NavigationCase instance using ViewHandler.getRedirectURL(javax.faces.context.FacesContext, java.lang.String, java.util.Map<java.lang.String, java.util.List<java.lang.String>>, boolean) on the path portion of the url.

getRedirectURL(FacesContext) - Method in class javax.faces.application.NavigationCaseWrapper

getRedirectURL(FacesContext, String, Map<String, List<String>>, boolean) - Method in class javax.faces.application.ViewHandler

Return a JSF action URL derived from the viewId argument that is suitable to be used by the NavigationHandler to issue a redirect request to the URL using a NonFaces request.

getRedirectURL(FacesContext, String, Map<String, List<String>>, boolean) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.getRedirectURL(javax.faces.context.FacesContext, String, java.util.Map, boolean) on the wrapped ViewHandler object.

getRef() - Method in exception javax.mail.internet.AddressException

Get the string that was being parsed when the error was detected (null if not relevant).

getRef() - Method in class javax.mail.URLName

Returns the reference of this URLName.

getReference(Bean<?>, Type, CreationalContext<?>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains a contextual reference for a certain bean and a certain bean type of the bean.

getReference(Class<T>, Object) - Method in interface javax.persistence.EntityManager

Get an instance, whose state may be lazily fetched.

getRegisteredEncodingStyleURIs() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry

Returns a list of registered encodingStyle URIs in this TypeMappingRegistry instance.

getRegistrationContext(String) - Method in class javax.security.auth.message.config.AuthConfigFactory

Get the the registration context for the identified registration.

getRegistrationIDs(AuthConfigProvider) - Method in class javax.security.auth.message.config.AuthConfigFactory

Get the registration identifiers for all registrations of the provider instance at the factory.

getRegistryObject() - Method in interface javax.xml.registry.infomodel.AuditableEvent

Gets the RegistryObject associated with this AuditableEvent.

getRegistryObject() - Method in interface javax.xml.registry.infomodel.ExternalIdentifier

Gets the parent RegistryObject for this ExternalIdentifier.

getRegistryObject(String, String) - Method in interface javax.xml.registry.QueryManager

Gets the RegistryObject specified by the Id and type of object.

getRegistryObject(String) - Method in interface javax.xml.registry.QueryManager

Gets the RegistryObject specified by the Id.

getRegistryObjects() - Method in interface javax.xml.registry.infomodel.RegistryPackage

Gets the collection of member RegistryObjects of this RegistryPackage.

getRegistryObjects(Collection) - Method in interface javax.xml.registry.QueryManager

Gets the specified RegistryObjects.

getRegistryObjects(Collection, String) - Method in interface javax.xml.registry.QueryManager

Gets the specified RegistryObjects.

getRegistryObjects() - Method in interface javax.xml.registry.QueryManager

Gets the RegistryObjects owned by the caller.

getRegistryObjects(String) - Method in interface javax.xml.registry.QueryManager

Gets the RegistryObjects owned by the caller, that are of the specified type.

getRegistryPackages() - Method in interface javax.xml.registry.infomodel.RegistryObject

Returns the Package associated with this object.

getRegistryService() - Method in interface javax.xml.registry.Connection

Gets the RegistryService interface associated with the Connection.

getRegistryService() - Method in interface javax.xml.registry.LifeCycleManager

Returns the parent RegistryService that created this object.

getRegistryService() - Method in interface javax.xml.registry.QueryManager

Returns the parent RegistryService that created this object.

getRel() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the rel property.

getRel() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the rel property.

getRel() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the rel property.

getRel() - Method in class javax.ws.rs.core.Link

Returns the value associated with the link rel param, or null if this param is not specified.

getRelay() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the boolean value of the relay attribute for this SOAPHeaderElement

getReliableURN() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

The "reliable" URN indicated in the TLD (the uri element).

getRels() - Method in class javax.ws.rs.core.Link

Returns the value associated with the link rel param as a list of strings or the empty list if rel is not defined.

getRemainder() - Method in class javax.mail.internet.HeaderTokenizer

Return the rest of the Header.

getRemaining() - Method in class javax.servlet.jsp.JspWriter

This method returns the number of unused bytes in the buffer.

getRemoteAddr() - Method in interface javax.servlet.ServletRequest

Returns the Internet Protocol (IP) address of the client or last proxy that sent the request.

getRemoteAddr() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getRemoteAddr() on the wrapped request object.

getRemoteAddress() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the unresolved address of the remote entity invoking this request.

getRemoteHost() - Method in interface javax.servlet.ServletRequest

Returns the fully qualified name of the client or the last proxy that sent the request.

getRemoteHost() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getRemoteHost() on the wrapped request object.

getRemoteInterfaceClass() - Method in interface javax.ejb.EJBMetaData

Obtain the class object for the enterprise bean's remote interface.

getRemotePort() - Method in interface javax.servlet.ServletRequest

Returns the Internet Protocol (IP) source port of the client or last proxy that sent the request.

getRemotePort() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getRemotePort() on the wrapped request object.

getRemoteUser() - Method in class javax.faces.context.ExternalContext

Return the login name of the user making the current request if any; otherwise, return null.

getRemoteUser() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRemoteUser() on the wrapped ExternalContext object.

getRemoteUser() - Method in interface javax.servlet.http.HttpServletRequest

Returns the login of the user making this request, if the user has been authenticated, or null if the user has not been authenticated.

getRemoteUser() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getRemoteUser() on the wrapped request object.

getRemoveCount() - Method in interface javax.management.j2ee.statistics.EJBStats

Number of times remove was called.

getRender() - Method in class javax.faces.component.behavior.AjaxBehavior

Return a non-empty Collection<String> of component identifiers that will be used to identify components that should be processed during the render phase of the request processing lifecycle.

getRenderer(FacesContext) - Method in class javax.faces.component.behavior.ClientBehaviorBase

Convenience method to return the ClientBehaviorRenderer instance associated with this ClientBehavior, if any; otherwise, return null.

getRenderer(FacesContext) - Method in class javax.faces.component.UIComponent

Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.

getRenderer(FacesContext) - Method in class javax.faces.component.UIComponentBase

getRenderer(String, String) - Method in class javax.faces.render.RenderKit

Return the Renderer instance most recently registered for the specified component family and rendererType, if any; otherwise, return null.

getRenderer(String, String) - Method in class javax.faces.render.RenderKitWrapper

The default behavior of this method is to call RenderKit.getRenderer(String, String) on the wrapped RenderKit object.

getRendererType() - Method in class javax.faces.component.behavior.AjaxBehavior

getRendererType() - Method in class javax.faces.component.behavior.ClientBehaviorBase

Returns the renderer type of the ClientBehaviorRenderer to use for the behavior.

getRendererType() - Method in class javax.faces.component.UIComponent

Return the Renderer type for this UIComponent (if any).

getRendererType() - Method in class javax.faces.component.UIComponentBase

getRendererType() - Method in interface javax.faces.view.facelets.ComponentConfig

RendererType to set on created UIComponent instances.

getRendererType() - Method in class javax.faces.webapp.UIComponentTagBase

Return the rendererType property that selects the Renderer to be used for encoding this component, or null to ask the component to render itself directly.

getRendererTypeForResourceName(String) - Method in class javax.faces.application.ResourceHandler

Return the renderer-type for a Renderer that is capable of rendering this resource.

getRendererTypeForResourceName(String) - Method in class javax.faces.application.ResourceHandlerWrapper

The default behavior of this method is to call ResourceHandler.getRendererTypeForResourceName(String) on the wrapped ResourceHandler object.

getRendererTypes(String) - Method in class javax.faces.render.RenderKit

Return an Iterator over the renderer-type entries for the given component-family.

getRendererTypes(String) - Method in class javax.faces.render.RenderKitWrapper

The default behavior of this method is to call RenderKit.getRendererTypes(String) on the wrapped RenderKit object.

getRenderIds() - Method in class javax.faces.context.PartialViewContext

Return a Collection of client identifiers from the current request with the request parameter name PartialViewContext.PARTIAL_RENDER_PARAM_NAME.

getRenderIds() - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.getRenderIds() on the wrapped PartialViewContext object.

getRenderKit() - Method in class javax.faces.context.FacesContext

Return the RenderKit instance for the render kit identifier specified on our UIViewRoot, if there is one.

getRenderKit() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getRenderKit() on the wrapped FacesContext object.

getRenderKit(FacesContext, String) - Method in class javax.faces.render.RenderKitFactory

Return a RenderKit instance for the specified render kit identifier, possibly customized based on dynamic characteristics of the specified FacesContext, if non-null.

getRenderKitId() - Method in class javax.faces.component.UIViewRoot

Return the render kit identifier of the RenderKit associated with this view.

getRenderKitIds() - Method in class javax.faces.render.RenderKitFactory

Return an Iterator over the set of render kit identifiers registered with this factory.

getRenderResponse() - Method in class javax.faces.context.FacesContext

Return true if the renderResponse() method has been called for the current request.

getRenderResponse() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getRenderResponse() on the wrapped FacesContext object.

getRendersChildren() - Method in class javax.faces.component.UIComponent

Return a flag indicating whether this component is responsible for rendering its child components.

getRendersChildren() - Method in class javax.faces.component.UIComponentBase

getRendersChildren() - Method in class javax.faces.component.UIViewRoot

Call UIComponentBase.getRendersChildren() If PartialViewContext.isAjaxRequest() returns true this method must return true.

getRendersChildren() - Method in class javax.faces.render.Renderer

Return a flag indicating whether this Renderer is responsible for rendering the children the component it is asked to render.

getRendersChildren() - Method in class javax.faces.render.RendererWrapper

getReplyTo() - Method in class javax.mail.internet.MimeMessage

Return the value of the RFC 822 "Reply-To" header field.

getReplyTo() - Method in class javax.mail.Message

Get the addresses to which replies should be directed.

getRepositoryItem() - Method in interface javax.xml.registry.infomodel.ExtrinsicObject

Gets the repository item for this object.

getRequest() - Method in class javax.faces.context.ExternalContext

Return the environment-specific object instance for the current request.

getRequest() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequest() on the wrapped ExternalContext object.

getRequest() - Method in class javax.security.auth.message.callback.PrivateKeyCallback

Used by the CallbackHandler to get the Request object that identifies the private key to be returned.

getRequest() - Method in class javax.security.auth.message.callback.SecretKeyCallback

Used by the CallbackHandler to get the Request object which identifies the secret key to be returned.

getRequest() - Method in interface javax.servlet.AsyncContext

Gets the request that was used to initialize this AsyncContext by calling ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse).

getRequest() - Method in class javax.servlet.jsp.PageContext

The current value of the request object (a ServletRequest).

getRequest() - Method in class javax.servlet.ServletRequestWrapper

Return the wrapped request object.

getRequest() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get the injectable request information.

getRequestBody() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a stream from which the request body can be read.

getRequestCharacterEncoding() - Method in class javax.faces.context.ExternalContext

Return the character encoding currently being used to interpret this request.

getRequestCharacterEncoding() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestCharacterEncoding() on the wrapped ExternalContext object.

getRequestContentLength() - Method in class javax.faces.context.ExternalContext

Return the result of calling getContentLenth() on the ServletRequest instance for this request.

getRequestContentLength() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestContentLength() on the wrapped ExternalContext object.

getRequestContentType() - Method in class javax.faces.context.ExternalContext

Return the MIME Content-Type for this request.

getRequestContentType() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestContentType() on the wrapped ExternalContext object.

getRequestContext() - Method in interface javax.xml.ws.BindingProvider

Get the context that is used to initialize the message context for request messages.

getRequestContextPath() - Method in class javax.faces.context.ExternalContext

Return the portion of the request URI that identifies the web application context for this request.

getRequestContextPath() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestContextPath() on the wrapped ExternalContext object.

getRequestCookieMap() - Method in class javax.faces.context.ExternalContext

Return an immutable Map whose keys are the set of cookie names included in the current request, and whose values (of type javax.servlet.http.Cookie) are the first (or only) cookie for each cookie name returned by the underlying request.

getRequestCookieMap() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestCookieMap() on the wrapped ExternalContext object.

getRequestDispatcher(String) - Method in interface javax.servlet.ServletContext

Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.

getRequestDispatcher(String) - Method in interface javax.servlet.ServletRequest

Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.

getRequestDispatcher(String) - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getRequestDispatcher(String path) on the wrapped request object.

getRequestedSessionId() - Method in interface javax.servlet.http.HttpServletRequest

Returns the session ID specified by the client.

getRequestedSessionId() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getRequestedSessionId() on the wrapped request object.

getRequestHeader(String) - Method in interface javax.ws.rs.core.HttpHeaders

Get the values of a HTTP request header.

getRequestHeader(String) - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the value of the specified request header.

getRequestHeaderMap() - Method in class javax.faces.context.ExternalContext

Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String) are the first (or only) value for each header name returned by the underlying request.

getRequestHeaderMap() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestHeaderMap() on the wrapped ExternalContext object.

getRequestHeaders() - Method in interface javax.ws.rs.core.HttpHeaders

Get the values of HTTP request headers.

getRequestHeaders() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns an immutable Map containing the HTTP headers that were included with this request.

getRequestHeaderValuesMap() - Method in class javax.faces.context.ExternalContext

Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String[]) are all of the value for each header name returned by the underlying request.

getRequestHeaderValuesMap() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestHeaderValuesMap() on the wrapped ExternalContext object.

getRequestId() - Method in exception javax.xml.registry.JAXRException

getRequestId() - Method in interface javax.xml.registry.JAXRResponse

Returns the unique id for the request that generated this response.

getRequestingPort() - Method in class javax.mail.Authenticator

getRequestingPrompt() - Method in class javax.mail.Authenticator

getRequestingProtocol() - Method in class javax.mail.Authenticator

Give the protocol that's requesting the connection.

getRequestingSite() - Method in class javax.mail.Authenticator

getRequestLocale() - Method in class javax.faces.context.ExternalContext

Return the preferred Locale in which the client will accept content.

getRequestLocale() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestLocale() on the wrapped ExternalContext object.

getRequestLocales() - Method in class javax.faces.context.ExternalContext

Return an Iterator over the preferred Locales specified in the request, in decreasing order of preference.

getRequestLocales() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestLocales() on the wrapped ExternalContext object.

getRequestMap() - Method in class javax.faces.context.ExternalContext

Return a mutable Map representing the request scope attributes for the current application.

getRequestMap() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestMap() on the wrapped ExternalContext object.

getRequestMessage() - Method in interface javax.security.auth.message.MessageInfo

Get the request message object from this MessageInfo.

getRequestMethod() - Method in class javax.xml.ws.spi.http.HttpExchange

Get the HTTP request method

getRequestParameterMap() - Method in class javax.faces.context.ExternalContext

Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String) are the first (or only) value for each parameter name returned by the underlying request.

getRequestParameterMap() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestParameterMap() on the wrapped ExternalContext object.

getRequestParameterMap() - Method in interface javax.websocket.Session

Return the request parameters associated with the request this session was opened under.

getRequestParameterNames() - Method in class javax.faces.context.ExternalContext

Return an Iterator over the names of all request parameters included in the current request.

getRequestParameterNames() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestParameterNames() on the wrapped ExternalContext object.

getRequestParameterValuesMap() - Method in class javax.faces.context.ExternalContext

Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String[]) are all of the values for each parameter name returned by the underlying request.

getRequestParameterValuesMap() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestParameterValuesMap() on the wrapped ExternalContext object.

getRequestPath() - Method in class javax.faces.application.Resource

Return a path to this resource such that, when the browser resolves it against the base URI for the view that includes the resource, and issues a GET request to the resultant fully qualified URL, the bytes of the resource are returned in response.

getRequestPath() - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.getRequestPath() on the wrapped ResourceHandler object.

getRequestPathInfo() - Method in class javax.faces.context.ExternalContext

Return the extra path information (if any) included in the request URI; otherwise, return null.

getRequestPathInfo() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestPathInfo() on the wrapped ExternalContext object.

getRequestScheme() - Method in class javax.faces.context.ExternalContext

Returns the name of the scheme used to make this request, for example, http, https, or ftp.

getRequestScheme() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestScheme() on the wrapped ExternalContext object.

getRequestServerName() - Method in class javax.faces.context.ExternalContext

Returns the host name of the server to which the request was sent.

getRequestServerName() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestServerName() on the wrapped ExternalContext object.

getRequestServerPort() - Method in class javax.faces.context.ExternalContext

Returns the port number to which the request was sent.

getRequestServerPort() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestServerPort() on the wrapped ExternalContext object.

getRequestServletPath() - Method in class javax.faces.context.ExternalContext

Return the servlet path information (if any) included in the request URI; otherwise, return null.

getRequestServletPath() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getRequestServletPath() on the wrapped ExternalContext object.

getRequestURI() - Method in interface javax.servlet.http.HttpServletRequest

Returns the part of this request's URL from the protocol name up to the query string in the first line of the HTTP request.

getRequestURI() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getRequestURI() on the wrapped request object.

getRequestURI() - Method in class javax.servlet.jsp.ErrorData

Returns the request URI.

getRequestURI() - Method in interface javax.websocket.server.HandshakeRequest

Return the request URI of the handshake request.

getRequestURI() - Method in interface javax.websocket.Session

Return the URI under which this session was opened, including the query string if there is one.

getRequestUri() - Method in interface javax.ws.rs.core.UriInfo

Get the absolute request URI including any query parameters.

getRequestURI() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the part of the request's URI from the protocol name up to the query string in the first line of the HTTP request.

getRequestUriBuilder() - Method in interface javax.ws.rs.core.UriInfo

Get the absolute request URI in the form of a UriBuilder.

getRequestURL() - Method in interface javax.servlet.http.HttpServletRequest

Reconstructs the URL the client used to make the request.

getRequestURL() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getRequestURL() on the wrapped request object.

getRequestURL(HttpServletRequest) - Static method in class javax.servlet.http.HttpUtils

Deprecated.

Reconstructs the URL the client used to make the request, using information in the HttpServletRequest object.

getRequiredAttribute(String) - Method in class javax.faces.view.facelets.TagHandler

Utility method for fetching a required TagAttribute

getRequiredMessage() - Method in class javax.faces.component.UIInput

If there has been a call to UIInput.setRequiredMessage(java.lang.String) on this instance, return the message.

getRequiredVersion() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

A string describing the required version of the JSP container.

getResource(String) - Method in class javax.faces.context.ExternalContext

Return a URL for the application resource mapped to the specified path, if it exists; otherwise, return null.

getResource(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getResource(String) on the wrapped ExternalContext object.

getResource(String) - Method in interface javax.servlet.ServletContext

Returns a URL to the resource that is mapped to the given path.

getResource(Object) - Method in interface javax.transaction.TransactionSynchronizationRegistry

Get an object from the Map of resources being managed for the transaction bound to the current thread at the time this method is called.

getResource(Class<T>) - Method in interface javax.ws.rs.container.ResourceContext

Get a resolved instance of a resource or sub-resource class.

getResourceAdapter() - Method in interface javax.resource.spi.ResourceAdapterAssociation

Get the associated ResourceAdapter object.

getResourceAsStream(String) - Method in class javax.faces.context.ExternalContext

Return an InputStream for an application resource mapped to the specified path, if it exists; otherwise, return null.

getResourceAsStream(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getResourceAsStream(String) on the wrapped ExternalContext object.

getResourceAsStream(String) - Method in interface javax.servlet.ServletContext

Returns the resource located at the named path as an InputStream object.

getResourceBundle(FacesContext, String) - Method in class javax.faces.application.Application

Find a ResourceBundle as defined in the application configuration resources under the specified name.

getResourceBundle(FacesContext, String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getResourceBundle(javax.faces.context.FacesContext, String) on the wrapped Application object.

getResourceBundle() - Method in class javax.servlet.jsp.jstl.fmt.LocalizationContext

Gets the resource bundle of this I18N localization context.

getResourceBundleMap() - Method in class javax.faces.component.UIComponent

Return a Map<String,String> of the ResourceBundle for this component.

getResourceClass() - Method in interface javax.ws.rs.container.ResourceInfo

Get the resource class that is the target of a request, or null if this information is not available.

getResourceHandler() - Method in class javax.faces.application.Application

Return the singleton, stateless, thread-safe ResourceHandler for this application.

getResourceHandler() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getResourceHandler() on the wrapped Application object.

getResourceLibraryContracts() - Method in class javax.faces.context.FacesContext

Return the list of resource library contracts that have been calculated to be appropriate for use with this view, or an empty list if there are no such resource library contracts.

getResourceLibraryContracts() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getResourceLibraryContracts() on the wrapped FacesContext object.

getResourceMethod() - Method in interface javax.ws.rs.container.ResourceInfo

Get the resource method that is the target of a request, or null if this information is not available.

getResourceName() - Method in class javax.faces.application.Resource

Return the resourceName for this resource.

getResourceName() - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.getResourceName() on the wrapped ResourceHandler object.

getResourcePaths(String) - Method in class javax.faces.context.ExternalContext

Return the Set of resource paths for all application resources whose resource path starts with the specified argument.

getResourcePaths(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getResourcePaths(String) on the wrapped ExternalContext object.

getResourcePaths(String) - Method in interface javax.servlet.ServletContext

Returns a directory-like listing of all the paths to resources within the web application whose longest sub-path matches the supplied path argument.

getResourceURL(FacesContext) - Method in class javax.faces.application.NavigationCase

Construct an absolute URL to this NavigationCase instance using ViewHandler.getResourceURL(javax.faces.context.FacesContext, java.lang.String) on the path portion of the url.

getResourceURL(FacesContext) - Method in class javax.faces.application.NavigationCaseWrapper

getResourceURL(FacesContext, String) - Method in class javax.faces.application.ViewHandler

If the value returned from this method is used as the file argument to the four-argument constructor for java.net.URL (assuming appropriate values are used for the first three arguments), then a client making a request to the toExternalForm() of that URL will select the argument path for direct rendering.

getResourceURL(FacesContext, String) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.getResourceURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

getResponse() - Method in class javax.faces.context.ExternalContext

Return the environment-specific object instance for the current response.

getResponse() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getResponse() on the wrapped ExternalContext object.

getResponse() - Method in interface javax.servlet.AsyncContext

Gets the response that was used to initialize this AsyncContext by calling ServletRequest.startAsync() or ServletRequest.startAsync(ServletRequest, ServletResponse).

getResponse() - Method in class javax.servlet.jsp.PageContext

The current value of the response object (a ServletResponse).

getResponse() - Method in class javax.servlet.ServletResponseWrapper

Return the wrapped ServletResponse object.

getResponse() - Method in exception javax.ws.rs.client.ResponseProcessingException

Get the HTTP response for which the processing has failed.

getResponse() - Method in exception javax.ws.rs.WebApplicationException

Get the HTTP response.

getResponseBody() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a stream to which the response body must be written.

getResponseBufferSize() - Method in class javax.faces.context.ExternalContext

Return the buffer size for the current response.

getResponseBufferSize() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getResponseBufferSize() on the wrapped ExternalContext object.

getResponseCharacterEncoding() - Method in class javax.faces.context.ExternalContext

Returns the name of the character encoding (MIME charset) used for the body sent in this response.

getResponseCharacterEncoding() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getResponseCharacterEncoding() on the wrapped ExternalContext object.

getResponseComplete() - Method in class javax.faces.context.FacesContext

Return true if the responseComplete() method has been called for the current request.

getResponseComplete() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getResponseComplete() on the wrapped FacesContext object.

getResponseContentType() - Method in class javax.faces.context.ExternalContext

Return the MIME Content-Type for this response.

getResponseContentType() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getResponseContentType() on the wrapped ExternalContext object.

getResponseContext() - Method in interface javax.xml.ws.BindingProvider

Get the context that resulted from processing a response message.

getResponseHeaders() - Method in class javax.faces.application.Resource

Returns a mutable Map<String, String> whose entries will be sent as response headers during ResourceHandler.handleResourceRequest(javax.faces.context.FacesContext).

getResponseHeaders() - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.getResponseHeaders() on the wrapped ResourceHandler object.

getResponseHeaders() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a mutable Map into which the HTTP response headers can be stored and which will be transmitted as part of this response.

getResponseMessage() - Method in interface javax.security.auth.message.MessageInfo

Get the response message object from this MessageInfo.

getResponseOutputStream() - Method in class javax.faces.context.ExternalContext

Returns an OutputStream suitable for writing binary data to the user-agent.

getResponseOutputStream() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getResponseOutputStream() on the wrapped ExternalContext object.

getResponseOutputWriter() - Method in class javax.faces.context.ExternalContext

Returns a Writer suitable for writing character data to the user-agent.

getResponseOutputWriter() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getResponseOutputWriter() on the wrapped ExternalContext object.

getResponses() - Method in class javax.xml.ws.soap.AddressingFeature

If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.

getResponseStateManager() - Method in class javax.faces.render.RenderKit

Return an instance of ResponseStateManager to handle rendering technology specific state management decisions.

getResponseStateManager() - Method in class javax.faces.render.RenderKitWrapper

The default behavior of this method is to call RenderKit.getResponseStateManager() on the wrapped RenderKit object.

getResponseStream() - Method in class javax.faces.context.FacesContext

Return the ResponseStream to which components should direct their binary output.

getResponseStream() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getResponseStream() on the wrapped FacesContext object.

getResponseWriter() - Method in class javax.faces.context.FacesContext

Return the ResponseWriter to which components should direct their character-based output.

getResponseWriter() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getResponseWriter() on the wrapped FacesContext object.

getRestriction() - Method in interface javax.persistence.criteria.CommonAbstractCriteria

Return the predicate that corresponds to the where clause restriction(s), or null if no restrictions have been specified.

getResult() - Method in interface javax.enterprise.concurrent.LastExecution

Result of the last execution.

getResult() - Method in class javax.security.auth.message.callback.PasswordValidationCallback

Get the authentication result.

getResult() - Method in interface javax.xml.bind.UnmarshallerHandler

Obtains the unmarshalled result.

getResult() - Method in class javax.xml.bind.util.JAXBResult

Gets the unmarshalled object created by the transformation.

getResult() - Method in class javax.xml.soap.SAAJResult

getResultList() - Method in interface javax.persistence.Query

Execute a SELECT query and return the query results as an untyped List.

getResultList() - Method in interface javax.persistence.StoredProcedureQuery

Retrieve the list of results from the next result set.

getResultList() - Method in interface javax.persistence.TypedQuery

Execute a SELECT query and return the query results as a typed List.

getResultSetInfo() - Method in interface javax.resource.cci.Connection

Gets the information on the ResultSet functionality supported by a connected EIS instance.

getResultTargetModuleIDs() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject

Retrieve the list of TargetModuleIDs successfully processed or created by the associated DeploymentManager operation.

getResultType() - Method in interface javax.persistence.criteria.AbstractQuery

Return the result type of the query or subquery.

getRetryTime(Date) - Method in exception javax.ws.rs.ServiceUnavailableException

Get the retry time for the failed request.

getReturns() - Method in class javax.faces.flow.Flow

Return an immutable data structure containing all of the return nodes declared for this flow.

getReturnType() - Method in class javax.el.MethodInfo

Returns the return type of the method

getReturnType() - Method in interface javax.xml.rpc.Call

Gets the return type for a specific operation

getReturnValueDescriptor() - Method in interface javax.validation.metadata.ExecutableDescriptor

Returns a descriptor for this executable's return value.

getRev() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the rev property.

getRev() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the rev property.

getRev() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the rev property.

getRole() - Method in class javax.faces.component.html.HtmlBody

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlForm

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlOutputFormat

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlOutputText

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the role property.

getRole() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the role property.

getRole() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the value of the Role attribute of this SOAPHeaderElement.

getRoles() - Method in interface javax.xml.rpc.handler.HandlerChain

Gets SOAP actor roles registered for this HandlerChain at this SOAP node.

getRoles() - Method in interface javax.xml.rpc.handler.soap.SOAPMessageContext

Gets the SOAP actor roles associated with an execution of the HandlerChain and its contained Handler instances.

getRoles() - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Gets the SOAP actor roles associated with an execution of the handler chain.

getRoles() - Method in interface javax.xml.ws.soap.SOAPBinding

Gets the roles played by the SOAP binding instance.

getRolesAllowed() - Method in class javax.servlet.HttpConstraintElement

Gets the names of the authorized roles.

getRollbackOnly() - Method in interface javax.ejb.EJBContext

Test if the transaction has been marked for rollback only.

getRollbackOnly() - Method in interface javax.persistence.EntityTransaction

Determine whether the current resource transaction has been marked for rollback.

getRollbackOnly() - Method in interface javax.transaction.TransactionSynchronizationRegistry

Get the rollbackOnly status of the transaction bound to the current thread at the time this method is called.

getRolledbackCount() - Method in interface javax.management.j2ee.statistics.JTAStats

Number of rolled-back transactions.

getRoot() - Method in interface javax.enterprise.deploy.model.DDBean

Return the root element for this DDBean.

getRoot() - Method in interface javax.persistence.criteria.CriteriaDelete

Return the query root.

getRoot() - Method in interface javax.persistence.criteria.CriteriaUpdate

Return the query root.

getRootBean() - Method in interface javax.validation.ConstraintViolation

Returns the root bean being validated.

getRootBeanClass() - Method in interface javax.validation.ConstraintViolation

Returns the class of the root bean being validated.

getRootCause(Throwable) - Method in class javax.faces.context.ExceptionHandler

Unwrap the argument t until the unwrapping encounters an Object whose getClass() is not equal to FacesException.class or javax.el.ELException.class.

getRootCause(Throwable) - Method in class javax.faces.context.ExceptionHandlerWrapper

The default behavior of this method is to call ExceptionHandler.getRootCause(Throwable) on the wrapped ExceptionHandler object.

getRootCause() - Method in exception javax.servlet.jsp.el.ELException

Deprecated.

Returns the root cause.

getRootCause() - Method in exception javax.servlet.jsp.JspException

Deprecated.
As of JSP 2.1, replaced by Throwable.getCause()

getRootCause() - Method in exception javax.servlet.ServletException

Returns the exception that caused this servlet exception.

getRootElement() - Method in class javax.faces.component.html.HtmlDoctype

Return the value of the rootElement property.

getRootOrganization() - Method in interface javax.xml.registry.infomodel.Organization

Gets the root organization.

getRoots() - Method in interface javax.persistence.criteria.AbstractQuery

Return the query roots.

getRowClasses() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the rowClasses property.

getRowClasses() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the rowClasses property.

getRowCount() - Method in class javax.faces.component.UIData

Return the number of rows in the underlying data model.

getRowCount() - Method in class javax.faces.model.ArrayDataModel

If there is wrappedData available, return the length of the array.

getRowCount() - Method in class javax.faces.model.CollectionDataModel

If there is wrappedData available, return the length of the list.

getRowCount() - Method in class javax.faces.model.DataModel

Return the number of rows of data objects represented by this DataModel.

getRowCount() - Method in class javax.faces.model.ListDataModel

If there is wrappedData available, return the length of the list.

getRowCount() - Method in class javax.faces.model.ResultDataModel

If there is wrappedData available, return the length of the array returned by calling getRows() on the underlying Result.

getRowCount() - Method in class javax.faces.model.ResultSetDataModel

Return -1, since ResultSet does not provide a standard way to determine the number of available rows without scrolling through the entire ResultSet, and this can be very expensive if the number of rows is large.

getRowCount() - Method in class javax.faces.model.ScalarDataModel

If there is wrappedData available, return 1.

getRowCount() - Method in interface javax.servlet.jsp.jstl.sql.Result

Returns the number of rows in the cached ResultSet

getRowData() - Method in class javax.faces.component.UIData

Return the data object representing the data for the currently selected row index, if any.

getRowData() - Method in class javax.faces.model.ArrayDataModel

If row data is available, return the array element at the index specified by rowIndex.

getRowData() - Method in class javax.faces.model.CollectionDataModel

If row data is available, return the array element at the index specified by rowIndex.

getRowData() - Method in class javax.faces.model.DataModel

Return an object representing the data for the currenty selected row index.

getRowData() - Method in class javax.faces.model.DataModelEvent

Return the object representing the data for the specified row index, or null for no associated row data.

getRowData() - Method in class javax.faces.model.ListDataModel

If row data is available, return the array element at the index specified by rowIndex.

getRowData() - Method in class javax.faces.model.ResultDataModel

If row data is available, return the SortedMap array element at the index specified by rowIndex of the array returned by calling getRows() on the underlying Result.

getRowData() - Method in class javax.faces.model.ResultSetDataModel

If row data is available, return a Map representing the values of the columns for the row specified by rowIndex, keyed by the corresponding column names.

getRowData() - Method in class javax.faces.model.ScalarDataModel

If wrapped data is available, return the wrapped data instance.

getRowIndex() - Method in class javax.faces.component.UIData

Return the zero-relative index of the currently selected row.

getRowIndex() - Method in class javax.faces.model.ArrayDataModel

getRowIndex() - Method in class javax.faces.model.CollectionDataModel

getRowIndex() - Method in class javax.faces.model.DataModel

Return the zero-relative index of the currently selected row.

getRowIndex() - Method in class javax.faces.model.DataModelEvent

Return the row index for this event, or -1 for no specific row.

getRowIndex() - Method in class javax.faces.model.ListDataModel

getRowIndex() - Method in class javax.faces.model.ResultDataModel

getRowIndex() - Method in class javax.faces.model.ResultSetDataModel

getRowIndex() - Method in class javax.faces.model.ScalarDataModel

getRows() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the rows property.

getRows() - Method in class javax.faces.component.UIData

Return the number of rows to be displayed, or zero for all remaining rows in the table.

getRows() - Method in interface javax.servlet.jsp.jstl.sql.Result

Returns the result of the query as an array of SortedMap objects.

getRowsByIndex() - Method in interface javax.servlet.jsp.jstl.sql.Result

Returns the result of the query as an array of arrays.

getRules() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the rules property.

getRules() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the rules property.

getRunAsRole() - Method in interface javax.servlet.ServletRegistration

Gets the name of the runAs role of the Servlet represented by this ServletRegistration.

getRunEnd() - Method in interface javax.enterprise.concurrent.LastExecution

The last time in which the task was completed.

getRunningExecutions(String) - Method in interface javax.batch.operations.JobOperator

Returns execution ids for job instances with the specified name that have running executions.

getRunningModules(ModuleType, Target[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Retrieve the list of Java EE application modules distributed to the identified targets and that are currently running on the associated server or servers.

getRunStart() - Method in interface javax.enterprise.concurrent.LastExecution

The last time in which the task started running.

getRuntimeType() - Method in interface javax.ws.rs.core.Configuration

Get the runtime type of this configuration context.

getSchedule() - Method in interface javax.ejb.Timer

Get the schedule expression corresponding to this timer.

getScheduledStart() - Method in interface javax.enterprise.concurrent.LastExecution

The last time in which task was scheduled to run.

getSchema() - Method in class javax.xml.bind.Binder

Gets the last Schema object (including null) set by the Binder.setSchema(Schema) method.

getSchema() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getSchema() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getSchema() - Method in interface javax.xml.bind.Marshaller

Get the JAXP 1.3 Schema object being used to perform marshal-time validation.

getSchema() - Method in interface javax.xml.bind.Unmarshaller

Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.

getSchemaLocation() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the current schemaLocation.

getScheme() - Method in interface javax.servlet.ServletRequest

Returns the name of the scheme used to make this request, for example, http, https, or ftp.

getScheme() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getScheme() on the wrapped request object.

getScheme() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the name of the scheme used to make this request, for example: http, or https.

getScope() - Method in interface javax.enterprise.context.spi.Context

Get the scope type of the context object.

getScope() - Method in interface javax.enterprise.inject.spi.BeanAttributes

Obtains the scope of the bean.

getScope() - Method in class javax.faces.event.ScopeContext

Return the scope itself, exposed as a Map.

getScope() - Method in class javax.servlet.jsp.tagext.TagVariableInfo

The body of the <scope> element.

getScope() - Method in class javax.servlet.jsp.tagext.VariableInfo

Returns the lexical scope of the variable.

getScope() - Method in class javax.xml.bind.JAXBElement

Returns scope of xml element declaration.

getScope(String) - Method in interface javax.xml.ws.handler.MessageContext

Gets the scope of a property.

getScopeName() - Method in class javax.faces.event.ScopeContext

Return the name of this custom scope.

getScript(ClientBehaviorContext) - Method in interface javax.faces.component.behavior.ClientBehavior

Return the script that implements this ClientBehavior's client-side logic.

getScript(ClientBehaviorContext) - Method in class javax.faces.component.behavior.ClientBehaviorBase

Default implementation of of ClientBehavior.getScript(javax.faces.component.behavior.ClientBehaviorContext).

getScript(ClientBehaviorContext, ClientBehavior) - Method in class javax.faces.render.ClientBehaviorRenderer

Return the script that implements this ClientBehavior's client-side logic.

getScriptComponentResource(FacesContext, Resource) - Method in class javax.faces.view.ViewDeclarationLanguage

Take implementation specific action to discover a Resource given the argument componentResource.

getScriptComponentResource(FacesContext, Resource) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

getScriptingInvalid() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the value of the scripting-invalid configuration, which specifies whether scripting is enabled for any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.

getSecond() - Method in class javax.ejb.ScheduleExpression

Return the value of the second attribute.

getSecure() - Method in class javax.servlet.http.Cookie

Returns true if the browser is sending cookies only over a secure protocol, or false if the browser can send cookies using any protocol.

getSecurityContext() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get the injectable security context information for the current request.

getSelectedClass() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the selectedClass property.

getSelectedValues() - Method in class javax.faces.component.UISelectMany

Return the currently selected values, or null if there are no currently selected values.

getSelection() - Method in interface javax.persistence.criteria.AbstractQuery

Return the selection of the query, or null if no selection has been set.

getSelection() - Method in interface javax.persistence.criteria.Subquery

Return the selection expression.

getSelectItems() - Method in class javax.faces.model.SelectItemGroup

Return the set of subordinate SelectItems for this group.

getSender() - Method in class javax.mail.internet.MimeMessage

Returns the value of the RFC 822 "Sender" header field.

getSendStream() - Method in interface javax.websocket.RemoteEndpoint.Basic

Opens an output stream on which a binary message may be sent.

getSendTimeout() - Method in interface javax.websocket.RemoteEndpoint.Async

Return the number of milliseconds the implementation will timeout attempting to send a websocket message.

getSendWriter() - Method in interface javax.websocket.RemoteEndpoint.Basic

Opens an character stream on which a text message may be sent.

getSentDate() - Method in class javax.mail.internet.MimeMessage

Returns the value of the RFC 822 "Date" field.

getSentDate() - Method in class javax.mail.Message

Get the date this message was sent.

getSentMailCount() - Method in interface javax.management.j2ee.statistics.JavaMailStats

The number of mail messages sent.

getSeparator() - Method in class javax.mail.Folder

Return the delimiter character that separates this Folder's pathname from the names of immediate subfolders.

getSeparatorChar(FacesContext) - Static method in class javax.faces.component.UINamingContainer

Return the character used to separate segments of a clientId.

getSerializer(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping

Gets the SerializerFactory registered for the specified pair of Java type and XML data type.

getSerializerAs(String) - Method in interface javax.xml.rpc.encoding.SerializerFactory

Returns a Serializer for the specified XML processing mechanism type.

getSerialNum() - Method in class javax.security.auth.message.callback.PrivateKeyCallback.IssuerSerialNumRequest

Get the serial number.

getServerAuthConfig(String, String, CallbackHandler) - Method in interface javax.security.auth.message.config.AuthConfigProvider

Get an instance of ServerAuthConfig from this provider.

getServerInfo() - Method in interface javax.servlet.ServletContext

Returns the name and version of the servlet container on which the servlet is running.

getServerName() - Method in interface javax.servlet.ServletRequest

Returns the host name of the server to which the request was sent.

getServerName() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getServerName() on the wrapped request object.

getServerPort() - Method in interface javax.servlet.ServletRequest

Returns the port number to which the request was sent.

getServerPort() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return getServerPort() on the wrapped request object.

getServerSession() - Method in interface javax.jms.ServerSessionPool

Return a server session from the pool.

getServerSessionPool() - Method in interface javax.jms.ConnectionConsumer

Gets the server session pool associated with this connection consumer.

getService() - Method in interface javax.xml.registry.infomodel.ServiceBinding

Gets the parent service for which this is a binding.

getServiceBinding() - Method in interface javax.xml.registry.infomodel.SpecificationLink

Gets the parent ServiceBinding for this SpecificationLink.

getServiceBindings() - Method in interface javax.xml.registry.infomodel.Service

Gets all children ServiceBindings.

getServiceName() - Method in interface javax.xml.rpc.Service

Gets the name of this service.

getServiceName() - Method in interface javax.xml.ws.handler.PortInfo

Gets the qualified name of the WSDL service name containing the port being accessed.

getServiceName() - Method in class javax.xml.ws.Service

Gets the name of this service.

getServiceName() - Method in class javax.xml.ws.spi.ServiceDelegate

Gets the name of this service.

getServices() - Method in interface javax.xml.registry.infomodel.Organization

Gets all children Services.

getServiceTime() - Method in interface javax.management.j2ee.statistics.ServletStats

Execution times for the methods.

getServlet(String) - Method in interface javax.servlet.ServletContext

Deprecated.
As of Java Servlet API 2.1, with no direct replacement.
This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.
In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.

getServlet() - Method in exception javax.servlet.UnavailableException

Deprecated.
As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.

getServletConfig() - Method in class javax.faces.webapp.FacesServlet

Return the ServletConfig instance for this servlet.

getServletConfig() - Method in class javax.servlet.GenericServlet

Returns this servlet's ServletConfig object.

getServletConfig() - Method in class javax.servlet.jsp.PageContext

The ServletConfig instance.

getServletConfig() - Method in interface javax.servlet.Servlet

Returns a ServletConfig object, which contains initialization and startup parameters for this servlet.

getServletContext() - Method in interface javax.servlet.FilterConfig

Returns a reference to the ServletContext in which the caller is executing.

getServletContext() - Method in class javax.servlet.GenericServlet

Returns a reference to the ServletContext in which this servlet is running.

getServletContext() - Method in interface javax.servlet.http.HttpSession

Returns the ServletContext to which this session belongs.

getServletContext() - Method in class javax.servlet.jsp.PageContext

The ServletContext instance.

getServletContext() - Method in interface javax.servlet.ServletConfig

Returns a reference to the ServletContext in which the caller is executing.

getServletContext() - Method in class javax.servlet.ServletContextEvent

Return the ServletContext that changed.

getServletContext() - Method in interface javax.servlet.ServletRequest

Gets the servlet context to which this ServletRequest was last dispatched.

getServletContext() - Method in class javax.servlet.ServletRequestEvent

Returns the ServletContext of this web application.

getServletContext() - Method in class javax.servlet.ServletRequestWrapper

Gets the servlet context to which the wrapped servlet request was last dispatched.

getServletContext() - Method in interface javax.xml.rpc.server.ServletEndpointContext

The method getServletContext returns the ServletContext associated with the web application that contain this endpoint.

getServletContextName() - Method in interface javax.servlet.ServletContext

Returns the name of this web application corresponding to this ServletContext as specified in the deployment descriptor for this web application by the display-name element.

getServletInfo() - Method in class javax.faces.webapp.FacesServlet

Return information about this Servlet.

getServletInfo() - Method in class javax.servlet.GenericServlet

Returns information about the servlet, such as author, version, and copyright.

getServletInfo() - Method in interface javax.servlet.Servlet

Returns information about the servlet, such as author, version, and copyright.

getServletName() - Method in class javax.servlet.GenericServlet

Returns the name of this servlet instance.

getServletName() - Method in class javax.servlet.jsp.ErrorData

Returns the name of the servlet invoked.

getServletName() - Method in interface javax.servlet.ServletConfig

Returns the name of this servlet instance.

getServletNameMappings() - Method in interface javax.servlet.FilterRegistration

Gets the currently available servlet name mappings of the Filter represented by this FilterRegistration.

getServletNames() - Method in interface javax.servlet.ServletContext

Deprecated.
As of Java Servlet API 2.1, with no replacement.
This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

getServletPath() - Method in interface javax.servlet.http.HttpServletRequest

Returns the part of this request's URL that calls the servlet.

getServletPath() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getServletPath() on the wrapped request object.

getServletRegistration(String) - Method in interface javax.servlet.ServletContext

Gets the ServletRegistration corresponding to the servlet with the given servletName.

getServletRegistrations() - Method in interface javax.servlet.ServletContext

Gets a (possibly empty) Map of the ServletRegistration objects (keyed by servlet name) corresponding to all servlets registered with this ServletContext.

getServletRequest() - Method in class javax.servlet.ServletRequestEvent

Returns the ServletRequest that is changing.

getServlets() - Method in interface javax.servlet.ServletContext

Deprecated.
As of Java Servlet API 2.0, with no replacement.
This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

getSession(boolean) - Method in class javax.faces.context.ExternalContext

If the create parameter is true, create (if necessary) and return a session instance associated with the current request.

getSession(boolean) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getSession(boolean) on the wrapped ExternalContext object.

getSession() - Method in interface javax.jms.ServerSession

Return the ServerSession's Session.

getSession() - Method in interface javax.jms.XASession

Gets the session associated with this XASession.

getSession() - Method in class javax.mail.Message

Return the Session used when this message was created.

getSession() - Method in class javax.mail.MessageContext

Return the Session we're operating in.

getSession(boolean) - Method in interface javax.servlet.http.HttpServletRequest

Returns the current HttpSession associated with this request or, if there is no current session and create is true, returns a new session.

getSession() - Method in interface javax.servlet.http.HttpServletRequest

Returns the current session associated with this request, or if the request does not have a session, creates one.

getSession(boolean) - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getSession(boolean create) on the wrapped request object.

getSession() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getSession() on the wrapped request object.

getSession() - Method in class javax.servlet.http.HttpSessionBindingEvent

Return the session that changed.

getSession(String) - Method in interface javax.servlet.http.HttpSessionContext

Deprecated.
As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.

getSession() - Method in class javax.servlet.http.HttpSessionEvent

Return the session that changed.

getSession() - Method in class javax.servlet.jsp.PageContext

The current value of the session object (an HttpSession).

getSession() - Method in exception javax.websocket.SessionException

Return the Session on which the problem occurred.

getSessionBeanType() - Method in interface javax.enterprise.inject.spi.ProcessSessionBean

Returns a SessionBeanType representing the kind of session bean.

getSessionContext() - Method in interface javax.servlet.http.HttpSession

Deprecated.
As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.

getSessionCookieConfig() - Method in interface javax.servlet.ServletContext

Gets the SessionCookieConfig object through which various properties of the session tracking cookies created on behalf of this ServletContext may be configured.

getSessionId(boolean) - Method in class javax.faces.context.ExternalContext

Return the id of the current session or the empty string if no session has been created and the create parameter is false.

getSessionId(boolean) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getSessionId(boolean) on the wrapped ExternalContext object.

getSessionMap() - Method in class javax.faces.context.ExternalContext

Return a mutable Map representing the session scope attributes for the current application.

getSessionMap() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getSessionMap() on the wrapped ExternalContext object.

getSessionMaxInactiveInterval() - Method in class javax.faces.context.ExternalContext

Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses.

getSessionMaxInactiveInterval() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getSessionMaxInactiveInterval() on the wrapped ExternalContext object.

getSessionMode() - Method in interface javax.jms.JMSContext

Returns the session mode of the JMSContext's session.

getSessions() - Method in interface javax.management.j2ee.statistics.JMSConnectionStats

Returns an array of JMSSessionStats that provide statistics about the sessions associated with the referencing JMSConnectionStats.

getSet(String, Class<E>) - Method in interface javax.persistence.metamodel.ManagedType

Return the Set-valued attribute of the managed type that corresponds to the specified name and Java element type.

getSet(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the Set-valued attribute of the managed type that corresponds to the specified name.

getSeverity() - Method in class javax.faces.application.FacesMessage

Return the severity level.

getSeverity() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getSeverity() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the severity code for this warning/error.

getShape() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the shape property.

getShape() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the shape property.

getShape() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the shape property.

getSharedCacheMode() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the specification of how the provider must use a second-level cache for the persistence unit.

getSharedNamespaces() - Method in class javax.mail.Store

Return a set of folders representing the shared namespaces.

getShort(String) - Method in interface javax.jms.MapMessage

Returns the short value with the specified name.

getShortName() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

The preferred short name (prefix) as indicated in the TLD.

getShortProperty(String) - Method in interface javax.jms.JMSProducer

Returns the message property with the specified name that has been set on this JMSProducer, converted to a short.

getShortProperty(String) - Method in interface javax.jms.Message

Returns the value of the short property with the specified name.

getSingleResult() - Method in interface javax.persistence.Query

Execute a SELECT query that returns a single untyped result.

getSingleResult() - Method in interface javax.persistence.StoredProcedureQuery

Retrieve a single result from the next result set.

getSingleResult() - Method in interface javax.persistence.TypedQuery

Execute a SELECT query that returns a single result.

getSingletons() - Method in class javax.ws.rs.core.Application

Get a set of root resource, provider and feature instances.

getSingularAttribute(String, Class<Y>) - Method in interface javax.persistence.metamodel.ManagedType

Return the single-valued attribute of the managed type that corresponds to the specified name and Java type.

getSingularAttribute(String) - Method in interface javax.persistence.metamodel.ManagedType

Return the single-valued attribute of the managed type that corresponds to the specified name.

getSingularAttributes() - Method in interface javax.persistence.metamodel.ManagedType

Return the single-valued attributes of the managed type.

getSize() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the size property.

getSize() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the size property.

getSize() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the size property.

getSize() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the size property.

getSize() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the size property.

getSize() - Method in class javax.mail.internet.MimeBodyPart

Return the size of the content of this body part in bytes.

getSize() - Method in class javax.mail.internet.MimeMessage

Return the size of the content of this message in bytes.

getSize() - Method in interface javax.mail.Part

Return the size of the content of this part in bytes.

getSize() - Method in interface javax.servlet.http.Part

Returns the size of this fille.

getSize(T, Class<?>, Type, Annotation[], MediaType) - Method in interface javax.ws.rs.ext.MessageBodyWriter

Originally, the method has been called before writeTo to ascertain the length in bytes of the serialized form of t.

getSize() - Method in class javax.xml.soap.AttachmentPart

Returns the number of bytes in this AttachmentPart object.

getSlot(String) - Method in interface javax.xml.registry.infomodel.ExtensibleObject

Gets the slot specified by slotName.

getSlots() - Method in interface javax.xml.registry.infomodel.ExtensibleObject

Returns the Slots associated with this object.

getSlotType() - Method in interface javax.xml.registry.infomodel.Slot

Gets the slotType for this Slot.

getSmallIcon() - Method in class javax.servlet.jsp.tagext.TagInfo

Get the path to the small icon.

getSMaxAge() - Method in class javax.ws.rs.core.CacheControl

Corresponds to the s-maxage cache control directive.

getSOAPBody() - Method in class javax.xml.soap.SOAPMessage

Gets the SOAP Body contained in this SOAPMessage object.

getSOAPFactory() - Method in interface javax.xml.ws.soap.SOAPBinding

Gets the SAAJ SOAPFactory instance used by this SOAP binding.

getSOAPHeader() - Method in class javax.xml.soap.SOAPMessage

Gets the SOAP Header contained in this SOAPMessage object.

getSOAPPart() - Method in class javax.xml.soap.SOAPMessage

Gets the SOAP part of this SOAPMessage object.

getSource() - Method in interface javax.enterprise.inject.spi.ProcessSyntheticAnnotatedType

Get the extension instance which added the AnnotatedType for which this event is being fired.

getSourceId() - Method in class javax.faces.component.behavior.ClientBehaviorContext

Returns an id for use as the ClientBehavior source.

getSourceObject() - Method in interface javax.xml.registry.infomodel.Association

Gets the Object that is the source of this Association.

getSpecificationLinks() - Method in interface javax.xml.registry.infomodel.ServiceBinding

Gets all children SpecificationLinks.

getSpecificationObject() - Method in interface javax.xml.registry.infomodel.SpecificationLink

Gets the specification object for this object.

getSpecificationVersion() - Method in class javax.servlet.jsp.JspEngineInfo

Return the version number of the JSP specification that is supported by this JSP engine.

getSpecVersion() - Method in interface javax.resource.cci.ResourceAdapterMetaData

Returns a string representation of the version of the connector architecture specification that is supported by the resource adapter.

getSslContext() - Method in interface javax.ws.rs.client.Client

Get the SSL context configured to be used with the current client run-time.

getStability() - Method in interface javax.xml.registry.infomodel.RegistryEntry

Gets the stability indicator for the RegistryEntry within the Registry.

getStart() - Method in class javax.ejb.ScheduleExpression

Return the start date, if set; otherwise null.

getStartDuration() - Method in class javax.resource.spi.work.WorkEvent

Return the start interval duration.

getStartNodeId() - Method in class javax.faces.flow.Flow

Return the immutable id for the default node that should be activated when this flow is entered.

getStartTime() - Method in interface javax.batch.runtime.JobExecution

Get time execution entered STARTED status.

getStartTime() - Method in interface javax.batch.runtime.StepExecution

Get time this step started.

getStartTime() - Method in interface javax.management.j2ee.statistics.Statistic

The time of the first measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.

getState() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus

Retrieve the StateType value.

getState() - Method in class javax.faces.application.StateManager.SerializedView

Deprecated.

getState(FacesContext, String) - Method in class javax.faces.render.ResponseStateManager

The implementation must inspect the current request and return an Object representing the tree structure and component state passed in to a previous invocation of ResponseStateManager.writeState(javax.faces.context.FacesContext,java.lang.Object).

getStateHelper() - Method in class javax.faces.component.UIComponent

Return the StateHelper instance used to help this component implement PartialStateHolder.

getStateHelper(boolean) - Method in class javax.faces.component.UIComponent

Like UIComponent.getStateHelper(), but only create a state helper instance if the argument creat is true.

getStateManagementStrategy(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguage

For implementations that want to control the implementation of state saving and restoring, the StateManagementStrategy allows them to do so.

getStateManagementStrategy(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

getStateManager() - Method in class javax.faces.application.Application

Return the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.

getStateManager() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getStateManager() on the wrapped Application object.

getStateOrProvince() - Method in interface javax.xml.registry.infomodel.PostalAddress

Returns the state or province.

getStateType(int) - Static method in class javax.enterprise.deploy.shared.StateType

Return an object of the specified value.

getStatistic(String) - Method in interface javax.management.j2ee.statistics.Stats

Get a Statistic by name.

getStatisticNames() - Method in interface javax.management.j2ee.statistics.Stats

Returns an array of Strings which are the names of the attributes from the specific Stats submodel that this object supports.

getStatistics() - Method in interface javax.management.j2ee.statistics.Stats

Returns an array containing all of the Statistic objects supported by this Stats object.

getStatus() - Method in interface javax.servlet.http.HttpServletResponse

Gets the current status code of this response.

getStatus() - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behaviour of this method is to call HttpServletResponse.getStatus() on the wrapped response object.

getStatus() - Method in interface javax.transaction.Transaction

Obtain the status of the transaction associated with the target Transaction object.

getStatus() - Method in interface javax.transaction.TransactionManager

Obtain the status of the transaction associated with the current thread.

getStatus() - Method in interface javax.transaction.UserTransaction

Obtain the status of the transaction associated with the current thread.

getStatus() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the status code associated with the response.

getStatus() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the status code associated with the response.

getStatus() - Method in class javax.ws.rs.core.Response

Get the status code associated with the response.

getStatus() - Method in interface javax.xml.registry.infomodel.RegistryEntry

Gets the life cycle status of the RegistryEntry within the registry.

getStatus() - Method in exception javax.xml.registry.JAXRException

getStatus() - Method in interface javax.xml.registry.JAXRResponse

Returns the status for this response.

getStatusCode() - Method in class javax.servlet.jsp.ErrorData

Returns the status code of the error.

getStatusCode() - Method in enum javax.ws.rs.core.Response.Status

Get the associated status code.

getStatusCode() - Method in interface javax.ws.rs.core.Response.StatusType

Get the associated status code.

getStatusCode() - Method in exception javax.xml.ws.http.HTTPException

Gets the HTTP status code.

getStatusInfo() - Method in interface javax.ws.rs.client.ClientResponseContext

Get the complete status information associated with the response.

getStatusInfo() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get the complete status information associated with the response.

getStatusInfo() - Method in class javax.ws.rs.core.Response

Get the complete status information associated with the response.

getStep() - Method in interface javax.servlet.jsp.jstl.core.LoopTagStatus

Returns the value of the 'step' attribute for the associated tag, or null if no 'step' attribute was specified.

getStepExecutionId() - Method in interface javax.batch.runtime.context.StepContext

The getStepExecutionId method returns the current step's execution id.

getStepExecutionId() - Method in interface javax.batch.runtime.StepExecution

Get unique id for this StepExecution.

getStepExecutions(long) - Method in interface javax.batch.operations.JobOperator

Return StepExecutions for specified execution id.

getStepName() - Method in interface javax.batch.runtime.context.StepContext

Get step name

getStepName() - Method in interface javax.batch.runtime.StepExecution

Get step name.

getStereotypeDefinition(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeanManager

Obtains meta-annotations for a certain stereotype.

getStereotypes() - Method in interface javax.enterprise.inject.spi.BeanAttributes

Obtains the stereotypes of the bean.

getStore() - Method in class javax.mail.Folder

Returns the Store that owns this Folder object.

getStore() - Method in class javax.mail.Session

Get a Store object that implements this user's desired Store protocol.

getStore(String) - Method in class javax.mail.Session

Get a Store object that implements the specified protocol.

getStore(URLName) - Method in class javax.mail.Session

Get a Store object for the given URLName.

getStore(Provider) - Method in class javax.mail.Session

Get an instance of the store specified by Provider.

getStore() - Method in exception javax.mail.StoreClosedException

Returns the dead Store object

getStreamELResolver() - Method in class javax.el.ExpressionFactory

Retrieves an ELResolver that implements the operations in collections.

getStreamOffset() - Method in interface javax.json.stream.JsonLocation

Return the stream offset into the input source this location is pointing to.

getStreet() - Method in interface javax.xml.registry.infomodel.PostalAddress

Returns the street name.

getStreetNumber() - Method in interface javax.xml.registry.infomodel.PostalAddress

Returns the street number.

getString(String) - Method in interface javax.jms.MapMessage

Returns the String value with the specified name.

getString(int) - Method in interface javax.json.JsonArray

A convenience method for getJsonString(index).getString().

getString(int, String) - Method in interface javax.json.JsonArray

Returns the String value of JsonString at the specified position in this JSON array values.

getString(String) - Method in interface javax.json.JsonObject

A convenience method for getJsonString(name).getString()

getString(String, String) - Method in interface javax.json.JsonObject

Returns the string value of the associated JsonString mapping for the specified name.

getString() - Method in interface javax.json.JsonString

Returns the JSON string value.

getString() - Method in interface javax.json.stream.JsonParser

Returns a String for the name in a name/value pair, for a string value or a number value.

getString() - Method in class javax.servlet.jsp.tagext.BodyContent

Return the value of the BodyContent as a String.

getStringHeaders() - Method in interface javax.ws.rs.client.ClientRequestContext

Get a string view of header values associated with the message.

getStringHeaders() - Method in interface javax.ws.rs.container.ContainerResponseContext

Get a string view of header values associated with the message.

getStringHeaders() - Method in class javax.ws.rs.core.Response

Get view of the response headers and their string values.

getStringProperty(String) - Method in interface javax.jms.JMSProducer

Returns the message property with the specified name that has been set on this JMSProducer, converted to a String.

getStringProperty(String) - Method in interface javax.jms.Message

Returns the value of the String property with the specified name.

getStringTable() - Method in class javax.enterprise.deploy.shared.ActionType

Returns the string table for class ActionType

getStringTable() - Method in class javax.enterprise.deploy.shared.CommandType

Returns the string table for class CommandType

getStringTable() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType

Returns the string table for class DConfigBeanVersionType

getStringTable() - Method in class javax.enterprise.deploy.shared.ModuleType

Returns the string table for class ModuleType

getStringTable() - Method in class javax.enterprise.deploy.shared.StateType

Returns the string table for class StateType

getStringValue(FacesContext) - Method in class javax.faces.component.UIViewParameter

If the value of this parameter comes from a ValueExpression return the value of the expression, otherwise, return the local value.

getStringValueFromModel(FacesContext) - Method in class javax.faces.component.UIViewParameter

Manually perform standard conversion steps to get a string value from the value expression.

getStructure() - Method in class javax.faces.application.StateManager.SerializedView

Deprecated.

getStyle() - Method in class javax.faces.component.html.HtmlBody

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlForm

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlOutputFormat

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlOutputText

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the style property.

getStyle() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the style property.

getStyleClass() - Method in class javax.faces.component.html.HtmlBody

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlForm

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlOutputFormat

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlOutputText

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlPanelGroup

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the styleClass property.

getStyleClass() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the styleClass property.

getSubgraphs() - Method in interface javax.persistence.AttributeNode

Return the Map<Class, Subgraph> of subgraphs associated with this attribute node.

getSubject() - Method in class javax.mail.internet.MimeMessage

Returns the value of the "Subject" header field.

getSubject() - Method in class javax.mail.Message

Get the subject of this message.

getSubject() - Method in class javax.security.auth.message.callback.CallerPrincipalCallback

Get the Subject in which the handler will distinguish the caller principal

getSubject() - Method in class javax.security.auth.message.callback.GroupPrincipalCallback

Get the Subject in which the handler will establish the group principals.

getSubject() - Method in class javax.security.auth.message.callback.PasswordValidationCallback

Get the subject.

getSubjectKeyID() - Method in class javax.security.auth.message.callback.PrivateKeyCallback.SubjectKeyIDRequest

Get the subjectKeyID.

getSubmittedFileName() - Method in interface javax.servlet.http.Part

Gets the file name specified by the client

getSubmittedValue() - Method in interface javax.faces.component.EditableValueHolder

Return the submittedValue value of this component.

getSubmittedValue() - Method in class javax.faces.component.UIInput

Return the submittedValue value of this UIInput component.

getSubmittedValue() - Method in class javax.faces.component.UIViewParameter

Assume that the submitted value is always a string, but the return type from this method is Object..

getSubmittingOrganization() - Method in interface javax.xml.registry.infomodel.RegistryObject

Gets the Organization that submitted this RegistryObject.

getSubprotocols() - Method in interface javax.websocket.server.ServerEndpointConfig

Return the websocket subprotocols configured.

getSubtreeIdsToVisit(UIComponent) - Method in class javax.faces.component.visit.VisitContext

Given a NamingContainer component, returns the client ids of any components underneath the NamingContainer that should be visited.

getSubtreeIdsToVisit(UIComponent) - Method in class javax.faces.component.visit.VisitContextWrapper

getSubType() - Method in class javax.mail.internet.ContentType

Return the subType.

getSubtype() - Method in class javax.ws.rs.core.MediaType

Getter for subtype.

getSummary() - Method in class javax.faces.application.FacesMessage

Return the localized summary text.

getSummary() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the summary property.

getSummary() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the summary property.

getSupertype() - Method in interface javax.persistence.metamodel.IdentifiableType

Return the identifiable type that corresponds to the most specific mapped superclass or entity extended by the entity or mapped superclass.

getSuppliedRequest() - Method in class javax.servlet.AsyncEvent

Gets the ServletRequest from this AsyncEvent.

getSuppliedResponse() - Method in class javax.servlet.AsyncEvent

Gets the ServletResponse from this AsyncEvent.

getSupportedEncodings() - Method in interface javax.xml.rpc.encoding.TypeMapping

Returns the encodingStyle URIs (as String[]) supported by this TypeMapping instance.

getSupportedLocales() - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Returns an array of supported locales for this implementation.

getSupportedLocales() - Method in class javax.faces.application.Application

Return an Iterator over the supported Locales for this appication.

getSupportedLocales() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getSupportedLocales() on the wrapped Application object.

getSupportedMechanismTypes() - Method in interface javax.xml.rpc.encoding.DeserializerFactory

Returns a list of all XML processing mechanism types supported by this DeserializerFactory.

getSupportedMechanismTypes() - Method in interface javax.xml.rpc.encoding.SerializerFactory

Returns a list of all XML processing mechanism types supported by this SerializerFactory.

getSupportedMessageTypes() - Method in interface javax.security.auth.message.module.ClientAuthModule

Get the one or more Class objects representing the message types supported by the module.

getSupportedMessageTypes() - Method in interface javax.security.auth.message.module.ServerAuthModule

Get the one or more Class objects representing the message types supported by the module.

getSwitches() - Method in class javax.faces.flow.Flow

Return an immutable data structure containing all of the switch nodes declared for this flow.

getSystem() - Method in class javax.faces.component.html.HtmlDoctype

Return the value of the system property.

getSystemFlags() - Method in class javax.mail.Flags

Return all the system flags in this Flags object.

getTabindex() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the tabindex property.

getTabindex() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the tabindex property.

getTag() - Method in class javax.faces.view.facelets.DelegatingMetaTagHandler

getTag() - Method in class javax.faces.view.facelets.TagAttribute

A reference to the Tag for which this class represents the attributes.

getTag() - Method in class javax.faces.view.facelets.TagAttributes

A reference to the Tag for which this class represents the attributes.

getTag() - Method in interface javax.faces.view.facelets.TagConfig

Return the Tag representing this handler.

getTag(String) - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

Get the TagInfo for a given tag name, looking through all the tags in this tag library.

getTagAttribute(String) - Method in class javax.faces.view.facelets.DelegatingMetaTagHandler

getTagClassName() - Method in class javax.servlet.jsp.tagext.TagInfo

Name of the class that provides the handler for this tag.

getTagExtraInfo() - Method in class javax.servlet.jsp.tagext.TagInfo

The instance (if any) for extra tag information.

getTagFile(String) - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

Get the TagFileInfo for a given tag name, looking through all the tag files in this tag library.

getTagFiles() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

An array describing the tag files that are defined in this tag library.

getTagHandlerDelegate() - Method in class javax.faces.view.facelets.BehaviorHandler

getTagHandlerDelegate() - Method in class javax.faces.view.facelets.ComponentHandler

getTagHandlerDelegate() - Method in class javax.faces.view.facelets.ConverterHandler

getTagHandlerDelegate() - Method in class javax.faces.view.facelets.DelegatingMetaTagHandler

getTagHandlerDelegate() - Method in class javax.faces.view.facelets.ValidatorHandler

Return the implementation specific delegate instance that provides the bulk of the work for this handler instance.

getTagId() - Method in class javax.faces.view.facelets.DelegatingMetaTagHandler

getTagId() - Method in interface javax.faces.view.facelets.TagConfig

A document-unique id, follows the convention "_tagId##"

getTagInfo() - Method in class javax.servlet.jsp.tagext.TagExtraInfo

Get the TagInfo for this class.

getTagInfo() - Method in class javax.servlet.jsp.tagext.TagFileInfo

Returns information about this tag, parsed from the directives in the tag file.

getTaglibLocation() - Method in interface javax.servlet.descriptor.TaglibDescriptor

Gets the location of the tag library represented by this TaglibDescriptor.

getTagLibrary() - Method in class javax.servlet.jsp.tagext.TagInfo

The instance of TabLibraryInfo we belong to.

getTagLibraryInfos() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

Returns an array of TagLibraryInfo objects representing the entire set of tag libraries (including this TagLibraryInfo) imported by taglib directives in the translation unit that references this TagLibraryInfo.

getTaglibs() - Method in interface javax.servlet.descriptor.JspConfigDescriptor

Gets the <taglib> child elements of the <jsp-config> element represented by this JspConfigDescriptor.

getTaglibURI() - Method in interface javax.servlet.descriptor.TaglibDescriptor

Gets the unique identifier of the tag library represented by this TaglibDescriptor.

getTagName() - Method in class javax.servlet.jsp.tagext.TagInfo

The name of the Tag.

getTags() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

An array describing the tags that are defined in this tag library.

getTagVariableInfos() - Method in class javax.servlet.jsp.tagext.TagInfo

Get TagVariableInfo objects associated with this TagInfo.

getTarget() - Method in interface javax.enterprise.deploy.spi.TargetModuleID

Retrieve the name of the target server.

getTarget() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the target property.

getTarget() - Method in class javax.faces.component.html.HtmlForm

Return the value of the target property.

getTarget() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the target property.

getTarget() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the target property.

getTarget() - Method in interface javax.interceptor.InvocationContext

Returns the target instance.

getTargetBinding() - Method in interface javax.xml.registry.infomodel.ServiceBinding

Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.

getTargetClass() - Method in class javax.faces.view.facelets.MetadataTarget

Return the Class of the metadata target.

getTargetEndpointAddress() - Method in interface javax.xml.rpc.Call

Gets the address of a target service endpoint.

getTargetModuleID() - Method in class javax.enterprise.deploy.spi.status.ProgressEvent

Retrieve the TargetModuleID for this event

getTargetObject() - Method in interface javax.xml.registry.infomodel.Association

Gets the Object that is the target of this Association.

getTargetPolicies() - Method in class javax.security.auth.message.MessagePolicy

Get the target policies that comprise the authentication policy.

getTargets() - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Retrieve the list of deployment targets supported by this DeploymentManager.

getTargets(UIComponent) - Method in interface javax.faces.view.AttachedObjectTarget

Returns the List<UIComponent> that this AttachedObjectTarget exposes.

getTargets() - Method in class javax.security.auth.message.MessagePolicy.TargetPolicy

Get the array of layer-specific target descriptors that identify the one or more message parts to which the specified message protection policy applies.

getTelephoneNumbers(String) - Method in interface javax.xml.registry.infomodel.Organization

Gets the telephone numbers for this User that match the specified telephone number type.

getTelephoneNumbers(String) - Method in interface javax.xml.registry.infomodel.User

Gets the telephone numbers for this User that match the specified telephone number type.

getTerm() - Method in class javax.mail.search.NotTerm

Return the term to negate.

getTerms() - Method in class javax.mail.search.AndTerm

Return the search terms.

getTerms() - Method in class javax.mail.search.OrTerm

Return the search terms.

getTestSet() - Method in class javax.mail.search.FlagTerm

Return true if testing whether the flags are set.

getText() - Method in interface javax.enterprise.deploy.model.DDBean

Returns the XML text for by this bean.

getText(String) - Method in interface javax.enterprise.deploy.model.DDBean

Return a list of text values for a given XPath in the deployment descriptor.

getText(String) - Method in interface javax.enterprise.deploy.model.DeployableObject

Return the XML content associated with the XPath from a deployment descriptor.

getText(ModuleType, String) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject

Return the text value from the XPath; search only the deployment descriptors of the specified type.

getText() - Method in interface javax.faces.view.facelets.TextHandler

Returns the literal String value of the contained text.

getText(FaceletContext) - Method in interface javax.faces.view.facelets.TextHandler

Returns the resolved literal String value of the contained text after evaluating EL.

getText() - Method in interface javax.jms.TextMessage

Gets the string containing this message's data.

getText() - Method in exception javax.websocket.DecodeException

Return the encoded string that is either the whole message, or the partial message that could not be decoded, or null if this exception arose from a failure to decode a binary message..

getThreads() - Method in interface javax.batch.api.partition.PartitionPlan

Gets count of threads.

getThreads() - Method in class javax.batch.api.partition.PartitionPlanImpl

getThreshold() - Method in class javax.xml.ws.soap.MTOMFeature

Gets the threshold value used to determine when binary data should be sent as an attachment.

getThrowable() - Method in class javax.servlet.AsyncEvent

Gets the Throwable from this AsyncEvent.

getThrowable() - Method in class javax.servlet.jsp.ErrorData

Returns the Throwable that caused the error.

getTimeout() - Method in interface javax.enterprise.context.Conversation

Get the timeout of the current conversation.

getTimeout() - Method in interface javax.servlet.AsyncContext

Gets the timeout (in milliseconds) for this AsyncContext.

getTimer() - Method in interface javax.ejb.TimerHandle

Obtain a reference to the timer represented by this handle.

getTimer() - Method in interface javax.interceptor.InvocationContext

Returns the timer object associated with a timeout method invocation on the target class, or a null value for method and lifecycle callback interceptor methods.

getTimeRemaining() - Method in interface javax.ejb.Timer

Get the number of milliseconds that will elapse before the next scheduled timer expiration.

getTimers() - Method in interface javax.ejb.TimerService

Returns all active timers associated with this bean.

getTimerService() - Method in interface javax.ejb.EJBContext

Get access to the EJB Timer Service.

getTimestamp() - Method in interface javax.xml.registry.infomodel.AuditableEvent

Gets the Timestamp for when this event occurred.

getTimeStyle() - Method in class javax.faces.convert.DateTimeConverter

Return the style to be used to format or parse times.

getTimeToLive() - Method in interface javax.jms.JMSProducer

Returns the time to live of messages that are sent using this JMSProducer.

getTimeToLive() - Method in interface javax.jms.MessageProducer

Gets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.

getTimezone() - Method in class javax.ejb.ScheduleExpression

Return the timezone, if set; otherwise null.

getTimeZone() - Method in class javax.faces.convert.DateTimeConverter

Return the TimeZone used to interpret a time value.

getTitle() - Method in class javax.faces.component.html.HtmlBody

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlForm

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlOutputFormat

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlOutputText

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the title property.

getTitle() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the title property.

getTitle() - Method in class javax.ws.rs.core.Link

Returns the value associated with the link title param, or null if this param is not specified.

getTo() - Method in interface javax.validation.metadata.GroupConversionDescriptor

Returns the target group of this conversion rule.

getToFlowDocumentId() - Method in class javax.faces.application.NavigationCase

If this navigation case represents a flow invocation, this property is the documentId in which the flow whose id is given by the return from NavigationCase.getFromOutcome() is defined.

getToFlowDocumentId() - Method in class javax.faces.application.NavigationCaseWrapper

getTopic() - Method in interface javax.jms.TopicPublisher

Gets the topic associated with this TopicPublisher.

getTopic() - Method in interface javax.jms.TopicSubscriber

Gets the Topic associated with this subscriber.

getTopicName() - Method in interface javax.jms.Topic

Gets the name of this topic.

getTopicSession() - Method in interface javax.jms.XATopicSession

Gets the topic session associated with this XATopicSession.

getTotalTime() - Method in interface javax.management.j2ee.statistics.TimeStatistic

This is the sum total of time taken to complete every invocation of this operation since the beginning of this measurement.

getToViewId(FacesContext) - Method in class javax.faces.application.NavigationCase

Evaluates the <to-view-id> for this <navigation-case>

getToViewId(FacesContext) - Method in class javax.faces.application.NavigationCaseWrapper

getTransacted() - Method in interface javax.jms.JMSContext

Indicates whether the JMSContext's session is in transacted mode.

getTransacted() - Method in interface javax.jms.Session

Indicates whether the session is in transacted mode.

getTransacted() - Method in interface javax.jms.XAJMSContext

Returns whether the session is in transacted mode; this method always returns true.

getTransacted() - Method in interface javax.jms.XASession

Indicates whether the session is in transacted mode.

getTransaction() - Method in interface javax.persistence.EntityManager

Return the resource-level EntityTransaction object.

getTransaction() - Method in interface javax.transaction.TransactionManager

Get the transaction object that represents the transaction context of the calling thread.

getTransactionKey() - Method in interface javax.transaction.TransactionSynchronizationRegistry

Return an opaque object to represent the transaction bound to the current thread at the time this method is called.

getTransactionPhase() - Method in interface javax.enterprise.inject.spi.ObserverMethod

Obtains the specified TransactionPhase for the observer method.

getTransactionStatus() - Method in interface javax.transaction.TransactionSynchronizationRegistry

Return the status of the transaction bound to the current thread at the time this method is called.

getTransactionSupport() - Method in interface javax.resource.spi.TransactionSupport

Get the level of transaction support, supported by the ManagedConnectionFactory.

getTransactionSynchronizationRegistry() - Method in interface javax.resource.spi.BootstrapContext

Provides a handle to a TransactionSynchronization instance.

getTransactionTimeout() - Method in class javax.resource.spi.work.ExecutionContext

Get the transaction timeout value for a imported transaction.

getTransactionTimeout() - Method in interface javax.transaction.xa.XAResource

Obtains the current transaction timeout value set for this XAResource instance.

getTransactionType() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the transaction type of the entity managers created by the EntityManagerFactory.

getTransient(Object) - Method in interface javax.faces.component.TransientStateHelper

Return the value currently associated with the specified key if any.

getTransient(Object, Object) - Method in interface javax.faces.component.TransientStateHelper

Performs the same logic as TransientStateHelper.getTransient(java.lang.Object) } but if no value is found, this will return the specified defaultValue

getTransientStateHelper() - Method in class javax.faces.component.UIComponent

Return the TransientStateHelper instance for this UIComponent instance.

getTransientStateHelper(boolean) - Method in class javax.faces.component.UIComponent

Return the TransientStateHelper instance for this UIComponent instance.

getTransientUserData() - Method in interface javax.batch.runtime.context.JobContext

The getTransientUserData method returns a transient data object belonging to the current Job XML execution element.

getTransientUserData() - Method in interface javax.batch.runtime.context.StepContext

The getTransientUserData method returns a transient data object belonging to the current Job XML execution element.

getTransport() - Method in class javax.mail.Session

Get a Transport object that implements this user's desired Transport protcol.

getTransport(String) - Method in class javax.mail.Session

Get a Transport object that implements the specified protocol.

getTransport(URLName) - Method in class javax.mail.Session

Get a Transport object for the given URLName.

getTransport(Provider) - Method in class javax.mail.Session

Get an instance of the transport specified in the Provider.

getTransport(Address) - Method in class javax.mail.Session

Get a Transport object that can transport a Message of the specified address type.

getTransportGuarantee() - Method in class javax.servlet.HttpConstraintElement

Gets the data protection requirement (i.e., whether or not SSL/TLS is required) that must be satisfied by the transport connection.

getTraversableResolver() - Method in interface javax.validation.spi.ConfigurationState

Returns the traversable resolver for this configuration.

getTraversableResolver() - Method in interface javax.validation.ValidatorFactory

Returns the TraversableResolver instance configured at initialization time for the ValidatorFactory.

getTraversableResolverClassName() - Method in interface javax.validation.BootstrapConfiguration

Class name of the TraversableResolver implementation or null if none is specified.

getTreeStructureToRestore(FacesContext, String) - Method in class javax.faces.render.ResponseStateManager

Deprecated.
This method has been replaced by ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.

getTreeStructureToSave(FacesContext) - Method in class javax.faces.application.StateManager

Deprecated.
the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.

getTreeStructureToSave(FacesContext) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.getTreeStructureToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.

getTrimDirectiveWhitespaces() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the value of the trim-directive-whitespaces configuration, which specifies whether template text containing only whitespaces must be removed from the response output of any JSP pages mapped to the JSP property group represented by this JspPropertyGroupDescriptor.

getTrustStore() - Method in class javax.security.auth.message.callback.TrustStoreCallback

Used by the TrustStore user to obtain the TrustStore set within the Callback.

getType() - Method in interface javax.batch.runtime.Metric

The getName method returns the metric type.

getType(ELContext, Object, Object) - Method in class javax.el.ArrayELResolver

If the base object is an array, returns the most general acceptable type for a value in this array.

getType(ELContext, Object, Object) - Method in class javax.el.BeanELResolver

If the base object is not null, returns the most general acceptable type that can be set on this bean property.

getType(ELContext, Object, Object) - Method in class javax.el.BeanNameELResolver

If the base is null and the property is a name resolvable by the BeanNameResolver, return the type of the bean.

getType(ELContext, Object, Object) - Method in class javax.el.CompositeELResolver

For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the CompositeELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.

getType(ELContext, Object, Object) - Method in class javax.el.ELResolver

For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.

getType(ELContext, Object, Object) - Method in class javax.el.ListELResolver

If the base object is a list, returns the most general acceptable type for a value in this list.

getType(ELContext, Object, Object) - Method in class javax.el.MapELResolver

If the base object is a map, returns the most general acceptable type for a value in this map.

getType(ELContext, Object, Object) - Method in class javax.el.ResourceBundleELResolver

If the base object is an instance of ResourceBundle, return null, since the resolver is read only.

getType(ELContext, Object, Object) - Method in class javax.el.StaticFieldELResolver

Returns the type of a static field.

getType(ELContext, Object, Object) - Method in class javax.el.TypeConverter

getType(ELContext) - Method in class javax.el.ValueExpression

Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ValueExpression.setValue(javax.el.ELContext, java.lang.Object) method.

getType() - Method in interface javax.enterprise.deploy.model.DDBeanRoot

Return the ModuleType of deployment descriptor.

getType() - Method in interface javax.enterprise.deploy.model.DeployableObject

Return the ModuleType of deployment descriptor (i.e., EAR, JAR, WAR, RAR) this deployable object represents.

getType() - Method in interface javax.enterprise.inject.spi.EventMetadata

Get the type representing runtime class of the event object with type variables resolved.

getType() - Method in interface javax.enterprise.inject.spi.InjectionPoint

Get the required type of injection point.

getType() - Method in class javax.enterprise.util.TypeLiteral

getType() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the type property.

getType() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the type property.

getType() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the type property.

getType() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the type property.

getType() - Method in class javax.faces.convert.DateTimeConverter

Return the type of value to be formatted or parsed.

getType() - Method in class javax.faces.convert.NumberConverter

Return the number type to be used when formatting and parsing numbers.

getType(FacesContext) - Method in class javax.faces.el.MethodBinding

Deprecated.

Return the Java class representing the return type from the method identified by this method binding expression.

getType(Object, Object) - Method in class javax.faces.el.PropertyResolver

Deprecated.

Return the java.lang.Class representing the type of the specified property.

getType(Object, int) - Method in class javax.faces.el.PropertyResolver

Deprecated.

Return the java.lang.Class representing the type of the specified index.

getType(FacesContext) - Method in class javax.faces.el.ValueBinding

Deprecated.

Return the type of the property represented by this ValueBinding, relative to the specified FacesContext.

getType() - Method in class javax.mail.Address

Return a type string that identifies this address type.

getType() - Method in class javax.mail.event.ConnectionEvent

Return the type of this event

getType() - Method in class javax.mail.event.FolderEvent

Return the type of this event.

getType() - Method in class javax.mail.event.MessageCountEvent

Return the type of this event.

getType() - Method in class javax.mail.event.TransportEvent

Return the type of this event.

getType() - Method in class javax.mail.Folder

Returns the type of this Folder, that is, whether this folder can hold messages or subfolders or both.

getType() - Method in class javax.mail.internet.HeaderTokenizer.Token

Return the type of the token.

getType() - Method in class javax.mail.internet.InternetAddress

Return the type of this address.

getType() - Method in class javax.mail.internet.NewsAddress

Return the type of this address.

getType() - Method in class javax.mail.Provider

Returns the type of this Provider

getType() - Method in interface javax.persistence.metamodel.SingularAttribute

Return the type that represents the type of the attribute.

getType() - Method in class javax.resource.spi.work.WorkEvent

Return the type of this event.

getType(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver

If the base object is null, and the property matches the name of a JSP implicit object, returns null to indicate that no types are ever accepted to setValue().

getType(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver

If the base object is null, returns Object.class to indicate that any type is valid to set for a scoped attribute.

getType(ELContext) - Method in class javax.servlet.jsp.jstl.core.IndexedValueExpression

getType(ELContext) - Method in class javax.servlet.jsp.jstl.core.IteratedValueExpression

getType() - Method in class javax.ws.rs.core.GenericEntity

Gets underlying Type instance.

getType() - Method in class javax.ws.rs.core.GenericType

Retrieve the type represented by the generic type instance.

getType() - Method in class javax.ws.rs.core.Link

Returns the value associated with the link type param, or null if this param is not specified.

getType() - Method in class javax.ws.rs.core.MediaType

Getter for primary type.

getType() - Method in interface javax.ws.rs.ext.InterceptorContext

Get Java type supported by corresponding message body provider.

getType() - Method in interface javax.xml.registry.infomodel.EmailAddress

Gets the type for this object.

getType() - Method in interface javax.xml.registry.infomodel.PostalAddress

Returns the type of address (for example, "headquarters") as a String.

getType() - Method in interface javax.xml.registry.infomodel.TelephoneNumber

The type of telephone number (for example, "fax").

getType() - Method in interface javax.xml.registry.infomodel.User

Gets the type for this User.

getType() - Method in interface javax.xml.registry.Query

Gets the type of Query (for example, QUERY_TYPE_SQL).

getTypeClosure() - Method in interface javax.enterprise.inject.spi.Annotated

Get all types to which the base type should be considered assignable.

getTypeMapping(String) - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry

Returns the registered TypeMapping for the specified encodingStyle URI.

getTypeMappingRegistry() - Method in interface javax.xml.rpc.Service

Gets the TypeMappingRegistry for this Service object.

getTypeName() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

The type (as a String) of this attribute.

getTypes() - Method in interface javax.enterprise.inject.spi.BeanAttributes

Obtains the bean types of the bean.

getUID(Message) - Method in interface javax.mail.UIDFolder

Get the UID for the specified message.

getUIDValidity() - Method in interface javax.mail.UIDFolder

Returns the UIDValidity value associated with this folder.

getUIViewParameter(FacesContext) - Method in class javax.faces.component.UIViewParameter.Reference

Return the UIViewParameter to which this instance refers.

getUnavailableSeconds() - Method in exception javax.servlet.UnavailableException

Returns the number of seconds the servlet expects to be temporarily unavailable.

getUnhandledExceptionQueuedEvents() - Method in class javax.faces.context.ExceptionHandler

Return an Iterable over all ExceptionQueuedEvents that have not yet been handled by the ExceptionHandler.handle() method.

getUnhandledExceptionQueuedEvents() - Method in class javax.faces.context.ExceptionHandlerWrapper

The default behavior of this method is to call ExceptionHandler.getUnhandledExceptionQueuedEvents() on the wrapped ExceptionHandler object.

getUnit() - Method in interface javax.management.j2ee.statistics.Statistic

The unit of measurement for this Statistic.

getUnmarshallerHandler() - Method in interface javax.xml.bind.Unmarshaller

Get an unmarshaller handler object that can be used as a component in an XML pipeline.

getUnreadMessageCount() - Method in class javax.mail.Folder

Get the total number of unread messages in this Folder.

getUnselectedClass() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the unselectedClass property.

getUpdateCount() - Method in interface javax.persistence.StoredProcedureQuery

Return the update count or -1 if there is no pending result or if the next result is not an update count.

getUpperBound() - Method in interface javax.management.j2ee.statistics.BoundaryStatistic

The upper limit of the value of this attribute.

getUpTime() - Method in interface javax.management.j2ee.statistics.JVMStats

Amount of time the JVM has been running.

getURI() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo

The value of the uri attribute from the taglib directive for this library.

getUri() - Method in interface javax.ws.rs.client.ClientRequestContext

Get the request URI.

getUri() - Method in interface javax.ws.rs.client.WebTarget

Get the URI identifying the resource.

getUri() - Method in class javax.ws.rs.core.Link

Returns the underlying URI associated with this link.

getUri() - Method in class javax.ws.rs.core.Link.JaxbLink

Get the underlying URI for this link.

getURI() - Method in interface javax.xml.soap.Name

Returns the URI of the namespace for the XML name that this Name object represents.

getUriBuilder() - Method in interface javax.ws.rs.client.WebTarget

Get the URI builder initialized with the URI of the current resource target.

getUriBuilder() - Method in class javax.ws.rs.core.Link

Convenience method that returns a UriBuilder initialized with this link's underlying URI.

getUriInfo() - Method in interface javax.ws.rs.container.ContainerRequestContext

Get request URI information.

getURL() - Method in class javax.faces.application.Resource

Return an actual URL instance that refers to this resource instance.

getURL() - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.getURL() on the wrapped ResourceHandler object.

getURL() - Method in class javax.faces.application.ViewResource

Return an actual URL instance that refers to this resource instance.

getUrl() - Method in class javax.faces.component.UIGraphic

Return the image URL for this UIGraphic.

getURL() - Method in class javax.mail.URLName

Constructs a URL from the URLName.

getURL() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getURL() - Method in interface javax.xml.bind.ValidationEventLocator

Return the name of the XML source as a URL if available

getUrl() - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Gets the URL that can dial this number electronically.

getUrl() - Method in interface javax.xml.registry.infomodel.User

Gets the URL to the web page for this User.

getURLName() - Method in class javax.mail.Folder

Return a URLName representing this folder.

getURLName() - Method in class javax.mail.Service

Return a URLName representing this service.

getUrlPatternMappings() - Method in interface javax.servlet.FilterRegistration

Gets the currently available URL pattern mappings of the Filter represented by this FilterRegistration.

getUrlPatterns() - Method in interface javax.servlet.descriptor.JspPropertyGroupDescriptor

Gets the URL patterns of the JSP property group represented by this JspPropertyGroupDescriptor.

getUsageDescription() - Method in interface javax.xml.registry.infomodel.SpecificationLink

Gets the description of usage parameters.

getUsageParameters() - Method in interface javax.xml.registry.infomodel.SpecificationLink

Gets any usage parameters.

getUsemap() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the usemap property.

getUser() - Method in interface javax.xml.registry.infomodel.AuditableEvent

Gets the User associated with this object.

getUserFlags() - Method in class javax.mail.Flags

Return all the user flags in this Flags object.

getUserName() - Method in class javax.mail.PasswordAuthentication

getUsername() - Method in class javax.mail.URLName

Returns the user name of this URLName.

getUserName() - Method in interface javax.resource.cci.ConnectionMetaData

Returns the user name for an active connection as known to the underlying EIS instance.

getUserName() - Method in interface javax.resource.spi.ManagedConnectionMetaData

Returns name of the user associated with the ManagedConnection instance.

getUserName() - Method in class javax.resource.spi.security.PasswordCredential

Returns the user name.

getUsername() - Method in class javax.security.auth.message.callback.PasswordValidationCallback

Get the username.

getUserNamespaces(String) - Method in class javax.mail.Store

Return a set of folders representing the namespaces for user.

getUserPrincipal() - Method in class javax.faces.context.ExternalContext

Return the Principal object containing the name of the current authenticated user, if any; otherwise, return null.

getUserPrincipal() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getUserPrincipal() on the wrapped ExternalContext object.

getUserPrincipal() - Method in interface javax.servlet.http.HttpServletRequest

Returns a java.security.Principal object containing the name of the current authenticated user.

getUserPrincipal() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return getUserPrincipal() on the wrapped request object.

getUserPrincipal() - Method in interface javax.websocket.server.HandshakeRequest

Return the authenticated user or null if no user is authenticated for this handshake.

getUserPrincipal() - Method in interface javax.websocket.Session

Return the authenticated user for this Session or null if no user is authenticated for this session.

getUserPrincipal() - Method in interface javax.ws.rs.core.SecurityContext

Returns a java.security.Principal object containing the name of the current authenticated user.

getUserPrincipal() - Method in interface javax.xml.rpc.server.ServletEndpointContext

Returns a java.security.Principal instance that contains the name of the authenticated user for the current method invocation on the endpoint instance.

getUserPrincipal() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the Principal that represents the authenticated user for this HttpExchange.

getUserPrincipal() - Method in interface javax.xml.ws.WebServiceContext

Returns the Principal that identifies the sender of the request currently being serviced.

getUserProperties() - Method in interface javax.websocket.EndpointConfig

This method returns a modifiable Map that the developer may use to store application specific information relating to the endpoint that uses this configuration instance.

getUserProperties() - Method in interface javax.websocket.Session

While the session is open, this method returns a Map that the developer may use to store application specific information relating to this session instance.

getUsers() - Method in interface javax.xml.registry.infomodel.Organization

Gets the Collection of Users affiliated with this Organization.

getUserTransaction() - Method in interface javax.ejb.EJBContext

Obtain the transaction demarcation interface.

getUserVersion() - Method in interface javax.xml.registry.infomodel.Versionable

Gets the user-specified revision number for this version of the Versionable object.

getUseTime() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats

Returns the time spent using a connection

getUseTime() - Method in interface javax.management.j2ee.statistics.JDBCConnectionStats

Time spent using a connection.

getValidatedValue() - Method in interface javax.validation.MessageInterpolator.Context

getValidateURI() - Method in interface javax.xml.registry.infomodel.URIValidator

Gets whether to do URI validation for this object.

getValidationAppliesTo() - Method in interface javax.validation.metadata.ConstraintDescriptor

The ConstraintTarget value of validationAppliesTo if the constraint hosts it or null otherwise.

getValidationGroups() - Method in class javax.faces.validator.BeanValidator

Return the validation groups passed to the Validation API when checking constraints.

getValidationMode() - Method in interface javax.persistence.spi.PersistenceUnitInfo

Returns the validation mode to be used by the persistence provider for the persistence unit.

getValidationProviderResolver() - Method in interface javax.validation.spi.BootstrapState

User defined ValidationProviderResolver strategy instance or null if undefined.

getValidationProviders() - Method in interface javax.validation.ValidationProviderResolver

Returns a list of ValidationProvider available in the runtime environment.

getValidator() - Method in interface javax.faces.component.EditableValueHolder

Deprecated.
EditableValueHolder.getValidators() should be used instead.

getValidator() - Method in class javax.faces.component.UIInput

Deprecated.
UIInput.getValidators() should be used instead.

getValidator() - Method in interface javax.validation.ValidatorContext

Returns an initialized Validator instance respecting the defined state.

getValidator() - Method in interface javax.validation.ValidatorFactory

Returns an initialized Validator instance using the factory defaults for message interpolator, traversable resolver and constraint validator factory.

getValidatorConfig() - Method in class javax.faces.view.facelets.ValidatorHandler

Return the TagConfig subclass used to configure this handler instance.

getValidatorId() - Method in interface javax.faces.view.facelets.ValidatorConfig

Return the validator-id associated with a particular validator in your faces-config

getValidatorId(FaceletContext) - Method in class javax.faces.view.facelets.ValidatorHandler

Retrieve the id of the validator that is to be created and added to the parent EditableValueHolder.

getValidatorIds() - Method in class javax.faces.application.Application

Return an Iterator over the set of currently registered validator ids for this Application.

getValidatorIds() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getValidatorIds() on the wrapped Application object.

getValidatorMessage() - Method in class javax.faces.component.UIInput

If there has been a call to UIInput.setValidatorMessage(java.lang.String) on this instance, return the message.

getValidators() - Method in interface javax.faces.component.EditableValueHolder

Return the set of registered Validators for this component instance.

getValidators() - Method in class javax.faces.component.UIInput

Return the set of registered Validators for this UIInput instance.

getValidSentAddresses() - Method in class javax.mail.event.TransportEvent

Return the addresses to which this message was sent succesfully.

getValidSentAddresses() - Method in exception javax.mail.SendFailedException

Return the addresses to which this message was sent succesfully.

getValidUnsentAddresses() - Method in class javax.mail.event.TransportEvent

Return the addresses that are valid but to which this message was not sent.

getValidUnsentAddresses() - Method in exception javax.mail.SendFailedException

Return the addresses that are valid but to which this message was not sent.

getValue() - Method in interface javax.batch.runtime.Metric

The getValue method returns the metric value.

getValue(ELContext, Object, Object) - Method in class javax.el.ArrayELResolver

If the base object is a Java language array, returns the value at the given index.

getValue(ELContext, Object, Object) - Method in class javax.el.BeanELResolver

If the base object is not null, returns the current value of the given property on this bean.

getValue(ELContext, Object, Object) - Method in class javax.el.BeanNameELResolver

If the base object is null and the property is a name that is resolvable by the BeanNameResolver, returns the value resolved by the BeanNameResolver.

getValue(ELContext, Object, Object) - Method in class javax.el.CompositeELResolver

Attempts to resolve the given property object on the given base object by querying all component resolvers.

getValue(String, Class<?>) - Method in class javax.el.ELProcessor

Evaluates an EL expression, and coerces the result to the specified type.

getValue(ELContext, Object, Object) - Method in class javax.el.ELResolver

Attempts to resolve the given property object on the given base object.

getValue(ELContext, Object, Object) - Method in class javax.el.ListELResolver

If the base object is a list, returns the value at the given index.

getValue(ELContext, Object, Object) - Method in class javax.el.MapELResolver

If the base object is a map, returns the value associated with the given key, as specified by the property argument.

getValue(ELContext, Object, Object) - Method in class javax.el.ResourceBundleELResolver

If the base object is an instance of ResourceBundle, the provided property will first be coerced to a String.

getValue(ELContext, Object, Object) - Method in class javax.el.StaticFieldELResolver

Returns the value of a static field.

getValue(ELContext, Object, Object) - Method in class javax.el.TypeConverter

getValue(ELContext) - Method in class javax.el.ValueExpression

Evaluates the expression relative to the provided context, and returns the resulting value.

getValue() - Method in class javax.enterprise.deploy.shared.ActionType

Returns this enumeration value's integer value.

getValue() - Method in class javax.enterprise.deploy.shared.CommandType

Returns this enumeration value's integer value.

getValue() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType

Returns this enumeration value's integer value.

getValue() - Method in class javax.enterprise.deploy.shared.ModuleType

Returns this enumeration value's integer value.

getValue() - Method in class javax.enterprise.deploy.shared.StateType

Returns this enumeration value's integer value.

getValue() - Method in class javax.faces.component.behavior.ClientBehaviorContext.Parameter

Returns the Parameter's value.

getValue() - Method in class javax.faces.component.UICommand

Returns the value property of the UICommand.

getValue() - Method in class javax.faces.component.UIData

Return the value of the UIData.

getValue() - Method in class javax.faces.component.UIGraphic

Returns the value property of the UIGraphic.

getValue() - Method in class javax.faces.component.UIInput

If there is a local value, return it, otherwise return the result of calling super.getVaue().

getValue() - Method in class javax.faces.component.UIOutput

Return the value property.

getValue() - Method in class javax.faces.component.UIParameter

Returns the value property of the UIParameter.

getValue() - Method in class javax.faces.component.UISelectItem

Returns the value property of the UISelectItem.

getValue() - Method in class javax.faces.component.UISelectItems

Returns the value property of the UISelectItems.

getValue() - Method in interface javax.faces.component.ValueHolder

Gets the value of this UIComponent.

getValue(Object, Object) - Method in class javax.faces.el.PropertyResolver

Deprecated.

Return the value of the specified property from the specified base object.

getValue(Object, int) - Method in class javax.faces.el.PropertyResolver

Deprecated.

Return the value at the specified index of the specified base object.

getValue(FacesContext) - Method in class javax.faces.el.ValueBinding

Deprecated.

Return the value of the property represented by this ValueBinding, relative to the specified FacesContext.

getValue() - Method in class javax.faces.flow.Parameter

Return a ValueExpression for the value of the parameter.

getValue() - Method in class javax.faces.model.SelectItem

Return the value of this item, to be delivered to the model if this item is selected by the user.

getValue() - Method in class javax.faces.view.facelets.TagAttribute

Return the literal value of this attribute

getValue(FaceletContext) - Method in class javax.faces.view.facelets.TagAttribute

If literal, then return our value, otherwise delegate to getObject, passing String.class.

getValue() - Method in class javax.mail.Header

Returns the value of this header.

getValue() - Method in class javax.mail.internet.HeaderTokenizer.Token

Returns the value of the token just read.

getValue() - Method in class javax.mail.internet.InternetHeaders.InternetHeader

Return the "value" part of the header line.

getValue() - Method in class javax.servlet.http.Cookie

Gets the current value of this Cookie.

getValue(String) - Method in interface javax.servlet.http.HttpSession

Deprecated.
As of Version 2.2, this method is replaced by HttpSession.getAttribute(java.lang.String).

getValue() - Method in class javax.servlet.http.HttpSessionBindingEvent

Returns the value of the attribute that has been added, removed or replaced.

getValue(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver

If the base object is null, and the property matches the name of a JSP implicit object, returns the implicit object.

getValue(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver

If the base object is null, searches the page, request, session and application scopes for an attribute with the given name and returns it, or null if no attribute exists with the current name.

getValue(ELContext) - Method in class javax.servlet.jsp.jstl.core.IndexedValueExpression

getValue(ELContext) - Method in class javax.servlet.jsp.jstl.core.IteratedValueExpression

getValue(String) - Method in class javax.servlet.jsp.tagext.TagSupport

Get a the value associated with a key.

getValue() - Method in class javax.servlet.ServletContextAttributeEvent

Gets the value of the ServletContext attribute that changed.

getValue() - Method in class javax.servlet.ServletRequestAttributeEvent

Returns the value of the attribute that has been added, removed or replaced.

getValue() - Method in enum javax.validation.constraints.Pattern.Flag

getValue() - Method in interface javax.websocket.Extension.Parameter

Return the value of the extension parameter.

getValue() - Method in class javax.ws.rs.core.Cookie

Get the value of the cookie.

getValue() - Method in class javax.ws.rs.core.EntityTag

Get the value of an EntityTag.

getValue() - Method in class javax.xml.bind.JAXBElement

Return the content model and attribute values for this element.

getValue(Object) - Static method in class javax.xml.bind.JAXBIntrospector

Get the element value of a JAXB element.

getValue() - Method in interface javax.xml.registry.infomodel.Classification

Gets the taxonomy value for this Classification.

getValue() - Method in interface javax.xml.registry.infomodel.Concept

Gets the value (usually a code in a taxonomy) associated with this Concept.

getValue() - Method in interface javax.xml.registry.infomodel.ExternalIdentifier

Gets the value of an ExternalIdentifier.

getValue() - Method in interface javax.xml.registry.infomodel.InternationalString

Gets the String value for the Locale returned by Locale.getDefault().

getValue(Locale) - Method in interface javax.xml.registry.infomodel.InternationalString

Gets the String value for the specified Locale.

getValue() - Method in interface javax.xml.registry.infomodel.LocalizedString

Get the String value for this object.

getValue() - Method in class javax.xml.soap.MimeHeader

Returns the value of this MimeHeader object.

getValue() - Method in interface javax.xml.soap.Node

Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise.

getValueBinding(String) - Method in class javax.faces.component.UIComponent

Deprecated.
This has been replaced by UIComponent.getValueExpression(java.lang.String).

getValueBinding(String) - Method in class javax.faces.component.UIComponentBase

Deprecated.
This has been replaced by UIComponent.getValueExpression(java.lang.String).

getValueBinding(String) - Method in class javax.faces.component.UIGraphic

Deprecated.
This has been replaced by UIGraphic.getValueExpression(java.lang.String).

getValueBinding(String) - Method in class javax.faces.component.UISelectBoolean

Deprecated.
This has been replaced by UISelectBoolean.getValueExpression(java.lang.String).

getValueBinding(String) - Method in class javax.faces.component.UISelectMany

Deprecated.
this has been replaced by UISelectMany.getValueExpression(java.lang.String).

getValueChangeListener() - Method in interface javax.faces.component.EditableValueHolder

Deprecated.
Use EditableValueHolder.getValueChangeListeners() instead.

getValueChangeListener() - Method in class javax.faces.component.UIInput

getValueChangeListeners() - Method in interface javax.faces.component.EditableValueHolder

Return the set of registered ValueChangeListeners for this component instance.

getValueChangeListeners() - Method in class javax.faces.component.UIInput

Return the set of registered ValueChangeListeners for this UIInput instance.

getValueExpression(String) - Method in class javax.faces.component.behavior.AjaxBehavior

Returns the ValueExpression used to calculate the value for the specified property name, if any.

getValueExpression(String) - Method in class javax.faces.component.UIComponent

Return the ValueExpression used to calculate the value for the specified attribute or property name, if any.

getValueExpression(String) - Method in class javax.faces.component.UIGraphic

Return any ValueExpression set for value if a ValueExpression for url is requested; otherwise, perform the default superclass processing for this method.

getValueExpression(String) - Method in class javax.faces.component.UISelectBoolean

Return any ValueExpression set for value if a ValueExpression for selected is requested; otherwise, perform the default superclass processing for this method.

getValueExpression(String) - Method in class javax.faces.component.UISelectMany

Return any ValueExpression set for value if a ValueExpression for selectedValues is requested; otherwise, perform the default superclass processing for this method.

getValueExpression(FaceletContext, Class) - Method in class javax.faces.view.facelets.TagAttribute

Create a ValueExpression, using this attribute's literal value and the passed expected type.

getValueExpression() - Method in class javax.servlet.jsp.jstl.core.IteratedExpression

getValueNames() - Method in interface javax.servlet.http.HttpSession

Deprecated.
As of Version 2.2, this method is replaced by HttpSession.getAttributeNames()

getValueReference(ELContext) - Method in class javax.el.ValueExpression

Returns a ValueReference for this expression instance.

getValues() - Method in class javax.servlet.jsp.tagext.TagSupport

Enumerate the keys for the values kept by this tag handler.

getValues(K) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

Return a non-null list of values for a given key.

getValues() - Method in interface javax.xml.registry.infomodel.Slot

Gets the values for this Slot.

getValuesAs(Class<T>) - Method in interface javax.json.JsonArray

Returns a list a view of the specified type for the array.

getValueType() - Method in interface javax.json.JsonValue

Returns the value type of this JSON value.

getValueType() - Method in interface javax.xml.registry.infomodel.ClassificationScheme

Gets the value type for this object.

getVar() - Method in class javax.faces.component.UIData

Return the request-scope attribute under which the data object for the current row will be exposed when iterating.

getVariableInfo(TagData) - Method in class javax.servlet.jsp.tagext.TagExtraInfo

information on scripting variables defined by the tag associated with this TagExtraInfo instance.

getVariableInfo(TagData) - Method in class javax.servlet.jsp.tagext.TagInfo

Information on the scripting objects created by this tag at runtime.

getVariableMapper() - Method in class javax.el.ELContext

Retrieves the VariableMapper associated with this ELContext.

getVariableMapper() - Method in class javax.el.StandardELContext

Construct (if needed) and return a default VariableMapper() {

getVariableResolver() - Method in class javax.faces.application.Application

Deprecated.
This has been replaced by Application.getELResolver().

getVariableResolver() - Method in class javax.faces.application.ApplicationWrapper

Deprecated.
See superclass for alternative.

getVariableResolver() - Method in class javax.servlet.jsp.JspContext

Deprecated.
As of JSP 2.1, replaced by ELContext.getELResolver(), which can be obtained by jspContext.getELContext().getELResolver().

getVariant() - Method in class javax.ws.rs.client.Entity

Get entity variant information.

getVarName() - Method in class javax.servlet.jsp.tagext.VariableInfo

Returns the name of the scripting variable.

getVdlDocumentId() - Method in class javax.faces.flow.ViewNode

Return the immutable VDL document id for this view node.

getVendor() - Method in class javax.mail.Provider

Returns name of vendor associated with this implementation or null

getVersion() - Method in class javax.mail.Provider

Returns version of this implementation or null if no version

getVersion(Class<Y>) - Method in interface javax.persistence.metamodel.IdentifiableType

Return the attribute that corresponds to the version attribute of the entity or mapped superclass.

getVersion() - Method in class javax.servlet.http.Cookie

Returns the version of the protocol this cookie complies with.

getVersion() - Method in class javax.ws.rs.core.Cookie

Get the version of the cookie.

getVersion() - Method in interface javax.xml.registry.CapabilityProfile

Gets the JAXR specification version supported by the JAXR provider.

getViewActions(UIViewRoot) - Static method in class javax.faces.view.ViewMetadata

Utility method to extract view metadata from the provided UIViewRoot.

getViewDeclarationLanguage(FacesContext, String) - Method in class javax.faces.application.ViewHandler

Return the ViewDeclarationLanguage instance used for this ViewHandler instance.

getViewDeclarationLanguage(FacesContext, String) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.getViewDeclarationLanguage(javax.faces.context.FacesContext, java.lang.String) on the wrapped ViewHandler object.

getViewDeclarationLanguage(String) - Method in class javax.faces.view.ViewDeclarationLanguageFactory

Return the ViewDeclarationLanguage instance suitable for handling the VDL contained in the page referenced by the argument viewId.

getViewHandler() - Method in class javax.faces.application.Application

Return the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.

getViewHandler() - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.getViewHandler() on the wrapped Application object.

getViewId() - Method in exception javax.faces.application.ViewExpiredException

Return the view identifier of this exception, or null if the view identifier is nonexistent or unknown.

getViewId() - Method in class javax.faces.component.UIViewRoot

Return the view identifier for this view.

getViewId() - Method in class javax.faces.view.ViewMetadata

getViewListenersForEventClass(Class<? extends SystemEvent>) - Method in class javax.faces.component.UIViewRoot

Return the SystemEventListener instances registered on this UIComponent instance that are interested in events of type eventClass.

getViewMap() - Method in class javax.faces.component.UIViewRoot

This implementation simply calls through to UIViewRoot.getViewMap(boolean), passing true as the argument, and returns the result.

getViewMap(boolean) - Method in class javax.faces.component.UIViewRoot

Returns a Map that acts as the interface to the data store that is the "view scope", or, if this instance does not have such a Map and the create argument is true, creates one and returns it.

getViewMetadata(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguage

Return a reference to the view metadata for the view represented by the argument viewId, or null if the metadata cannot be found.

getViewMetadata(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

getViewMetadataFacelet(URL) - Method in class javax.faces.view.facelets.FaceletCache

Returns a cached View Metadata Facelet instance.

getViewParameters(UIViewRoot) - Static method in class javax.faces.view.ViewMetadata

Utility method to extract view metadata from the provided UIViewRoot.

getViewRoot() - Method in class javax.faces.context.FacesContext

Return the root component that is associated with the this request.

getViewRoot() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.getViewRoot() on the wrapped FacesContext object.

getViews() - Method in class javax.faces.flow.Flow

Return an immutable data structure containing all of the view nodes declared for this flow.

getViewState(FacesContext) - Method in class javax.faces.application.StateManager

Convenience method to return the view state as a String with no RenderKit specific markup.

getViewState(FacesContext) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.getViewState(javax.faces.context.FacesContext) on the wrapped StateManager object.

getViewState(FacesContext, Object) - Method in class javax.faces.render.ResponseStateManager

Return the specified state as a String without any markup related to the rendering technology supported by this ResponseStateManager.

getVirtualServerName() - Method in interface javax.servlet.ServletContext

Returns the configuration name of the logical host on which the ServletContext is deployed.

getVisibleNamespacePrefixes() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over the namespace prefix Strings visible to this element.

getVisitContext(FacesContext, Collection<String>, Set<VisitHint>) - Method in class javax.faces.component.visit.VisitContextFactory

Return a new VisitContext instance.

getWaitingThreadCount() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats

The number of threads waiting for a connection

getWaitingThreadCount() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats

Number of threads waiting for a connection.

getWaitTime() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats

Returns the time spent waiting for a connection to be available

getWaitTime() - Method in interface javax.management.j2ee.statistics.JDBCConnectionStats

Time spent waiting for a connection to be available.

getWarnClass() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the warnClass property.

getWarnClass() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the warnClass property.

getWarnings() - Method in interface javax.resource.cci.Interaction

Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.

getWarnStyle() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the warnStyle property.

getWarnStyle() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the warnStyle property.

getWebSocketContainer() - Static method in class javax.websocket.ContainerProvider

Obtain a new instance of a WebSocketContainer.

getWebURL() - Method in interface javax.enterprise.deploy.spi.TargetModuleID

If this TargetModulID represents a web module retrieve the URL for it.

getWidth() - Method in class javax.faces.component.html.HtmlDataTable

Return the value of the width property.

getWidth() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the width property.

getWidth() - Method in class javax.faces.component.html.HtmlPanelGrid

Return the value of the width property.

getWork() - Method in class javax.resource.spi.work.WorkEvent

Return the Work instance which is the cause of the event.

getWorkContexts() - Method in interface javax.resource.spi.work.WorkContextProvider

Gets an list of WorkContexts that needs to be used by the WorkManager to set up the execution context while executing a Work instance.

getWorkManager() - Method in interface javax.resource.spi.BootstrapContext

Provides a handle to a WorkManager instance.

getWrapped() - Method in class javax.faces.application.ApplicationFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.application.ApplicationWrapper

getWrapped() - Method in class javax.faces.application.ConfigurableNavigationHandlerWrapper

getWrapped() - Method in class javax.faces.application.NavigationCaseWrapper

getWrapped() - Method in class javax.faces.application.NavigationHandlerWrapper

getWrapped() - Method in class javax.faces.application.ResourceHandlerWrapper

getWrapped() - Method in class javax.faces.application.ResourceWrapper

getWrapped() - Method in class javax.faces.application.StateManagerWrapper

getWrapped() - Method in class javax.faces.application.ViewHandlerWrapper

getWrapped() - Method in class javax.faces.component.visit.VisitContextFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.component.visit.VisitContextWrapper

getWrapped() - Method in class javax.faces.context.ExceptionHandlerFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.context.ExceptionHandlerWrapper

getWrapped() - Method in class javax.faces.context.ExternalContextFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.context.ExternalContextWrapper

getWrapped() - Method in class javax.faces.context.FacesContextFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.context.FacesContextWrapper

getWrapped() - Method in class javax.faces.context.FlashFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.context.FlashWrapper

getWrapped() - Method in class javax.faces.context.PartialResponseWriter

Return the wrapped ResponseWriter instance.

getWrapped() - Method in class javax.faces.context.PartialViewContextFactory

getWrapped() - Method in class javax.faces.context.PartialViewContextWrapper

getWrapped() - Method in class javax.faces.context.ResponseWriterWrapper

Return the instance that we are wrapping.

getWrapped() - Method in class javax.faces.event.ActionListenerWrapper

getWrapped() - Method in interface javax.faces.FacesWrapper

A class that implements this interface uses this method to return an instance of the class being wrapped.

getWrapped() - Method in class javax.faces.flow.FlowHandlerFactoryWrapper

A class that implements this interface uses this method to return an instance of the class being wrapped.

getWrapped() - Method in class javax.faces.lifecycle.ClientWindowFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.lifecycle.ClientWindowWrapper

getWrapped() - Method in class javax.faces.lifecycle.LifecycleFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.lifecycle.LifecycleWrapper

getWrapped() - Method in class javax.faces.render.RendererWrapper

getWrapped() - Method in class javax.faces.render.RenderKitFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.render.RenderKitWrapper

getWrapped() - Method in class javax.faces.view.facelets.FaceletCacheFactory

getWrapped() - Method in class javax.faces.view.facelets.TagHandlerDelegateFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.view.ViewDeclarationLanguageFactory

If this factory has been decorated, the implementation doing the decorating may override this method to provide access to the implementation being wrapped.

getWrapped() - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

getWrappedData() - Method in class javax.faces.model.ArrayDataModel

getWrappedData() - Method in class javax.faces.model.CollectionDataModel

getWrappedData() - Method in class javax.faces.model.DataModel

Return the object representing the data wrapped by this DataModel, if any.

getWrappedData() - Method in class javax.faces.model.ListDataModel

getWrappedData() - Method in class javax.faces.model.ResultDataModel

getWrappedData() - Method in class javax.faces.model.ResultSetDataModel

getWrappedData() - Method in class javax.faces.model.ScalarDataModel

getWriteMethod(String) - Method in class javax.faces.view.facelets.MetadataTarget

Return a Method for the setter of the property with name given by argument name.

getWriter() - Method in interface javax.servlet.ServletResponse

Returns a PrintWriter object that can send character text to the client.

getWriter() - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to return getWriter() on the wrapped response object.

getWSDLDocumentLocation() - Method in interface javax.xml.rpc.Service

Gets the location of the WSDL document for this Service.

getWSDLDocumentLocation() - Method in class javax.xml.ws.Service

Gets the location of the WSDL document for this Service.

getWSDLDocumentLocation() - Method in class javax.xml.ws.spi.ServiceDelegate

Gets the location of the WSDL document for this Service.

getXAResource() - Method in interface javax.jms.XAJMSContext

Returns an XAResource to the caller.

getXAResource() - Method in interface javax.jms.XASession

Returns an XA resource to the caller.

getXAResource() - Method in interface javax.resource.spi.ManagedConnection

Returns an javax.transaction.xa.XAresource instance.

getXAResources(ActivationSpec[]) - Method in interface javax.resource.spi.ResourceAdapter

This method is called by the application server during crash recovery.

getXATerminator() - Method in interface javax.resource.spi.BootstrapContext

Provides a handle to a XATerminator instance.

getXid() - Method in class javax.resource.spi.work.ExecutionContext

getXMLNode(Object) - Method in class javax.xml.bind.Binder

Gets the XML element associated with the given JAXB object.

getXmlns() - Method in class javax.faces.component.html.HtmlBody

Return the value of the xmlns property.

getXmlns() - Method in class javax.faces.component.html.HtmlHead

Return the value of the xmlns property.

getXMLReader() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Obtains a configured XMLReader.

getXpath() - Method in interface javax.enterprise.deploy.model.DDBean

Returns the original xpath string provided by the DConfigBean.

getXpath() - Method in interface javax.enterprise.deploy.model.DDBeanRoot

Return the XPath for this standard bean.

getXpaths() - Method in interface javax.enterprise.deploy.spi.DConfigBean

Return a list of XPaths designating the deployment descriptor information this DConfigBean requires.

getYear() - Method in class javax.ejb.ScheduleExpression

Return the value of the year attribute.

greaterThan(Expression<? extends Y>, Expression<? extends Y>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is greater than the second.

greaterThan(Expression<? extends Y>, Y) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is greater than the second.

greaterThanOrEqualTo(Expression<? extends Y>, Expression<? extends Y>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is greater than or equal to the second.

greaterThanOrEqualTo(Expression<? extends Y>, Y) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is greater than or equal to the second.

greatest(Expression<X>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an aggregate expression for finding the greatest of the values (strings, dates, etc).

groupBy(Expression<?>...) - Method in interface javax.persistence.criteria.AbstractQuery

Specify the expressions that are used to form groups over the query results.

groupBy(List<Expression<?>>) - Method in interface javax.persistence.criteria.AbstractQuery

Specify the expressions that are used to form groups over the query results.

groupBy(Expression<?>...) - Method in interface javax.persistence.criteria.CriteriaQuery

Specify the expressions that are used to form groups over the query results.

groupBy(List<Expression<?>>) - Method in interface javax.persistence.criteria.CriteriaQuery

Specify the expressions that are used to form groups over the query results.

groupBy(Expression<?>...) - Method in interface javax.persistence.criteria.Subquery

Specify the expressions that are used to form groups over the subquery results.

groupBy(List<Expression<?>>) - Method in interface javax.persistence.criteria.Subquery

Specify the expressions that are used to form groups over the subquery results.

GroupConversionDescriptor - Interface in javax.validation.metadata

A group conversion rule to be applied during cascaded validation.

GroupDefinitionException - Exception in javax.validation

Exception raised if a group definition is not legal.

GroupDefinitionException(String) - Constructor for exception javax.validation.GroupDefinitionException

GroupDefinitionException() - Constructor for exception javax.validation.GroupDefinitionException

GroupDefinitionException(String, Throwable) - Constructor for exception javax.validation.GroupDefinitionException

GroupDefinitionException(Throwable) - Constructor for exception javax.validation.GroupDefinitionException

GroupPrincipalCallback - Class in javax.security.auth.message.callback

Callback establishing group principals within the argument subject.

GroupPrincipalCallback(Subject, String[]) - Constructor for class javax.security.auth.message.callback.GroupPrincipalCallback

Create a GroupPrincipalCallback to establish the container's representation of the corresponding group principals within the Subject.

GroupSequence - Annotation Type in javax.validation

Defines group sequence.

GT - Static variable in class javax.mail.search.ComparisonTerm

gt(Expression<? extends Number>, Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is greater than the second.

gt(Expression<? extends Number>, Number) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is greater than the second.

H

Handle - Interface in javax.ejb

The Handle interface is implemented by all EJB object handles.

handle() - Method in class javax.faces.context.ExceptionHandler

Take action to handle the Exception instances residing inside the ExceptionQueuedEvent instances that have been queued by calls to Application().publishEvent(ExceptionQueuedEvent.class, eventContext).

handle() - Method in class javax.faces.context.ExceptionHandlerWrapper

The default behavior of this method is to call ExceptionHandler.handle() on the wrapped ExceptionHandler object.

handle(HttpExchange) - Method in class javax.xml.ws.spi.http.HttpHandler

Handles a given request and generates an appropriate response.

HandleDelegate - Interface in javax.ejb.spi

The HandleDelegate interface is implemented by the EJB container.

handleEvent(ValidationEvent) - Method in class javax.xml.bind.helpers.DefaultValidationEventHandler

handleEvent(ValidationEvent) - Method in class javax.xml.bind.util.ValidationEventCollector

handleEvent(ValidationEvent) - Method in interface javax.xml.bind.ValidationEventHandler

Receive notification of a validation warning or error.

handleFault(MessageContext) - Method in class javax.xml.rpc.handler.GenericHandler

The handleFault method processes the SOAP faults based on the SOAP message processing model.

handleFault(MessageContext) - Method in interface javax.xml.rpc.handler.Handler

The handleFault method processes the SOAP faults based on the SOAP message processing model.

handleFault(MessageContext) - Method in interface javax.xml.rpc.handler.HandlerChain

The handleFault method initiates the SOAP fault processing for this handler chain.

handleFault(C) - Method in interface javax.xml.ws.handler.Handler

The handleFault method is invoked for fault message processing.

handleMessage(C) - Method in interface javax.xml.ws.handler.Handler

The handleMessage method is invoked for normal processing of inbound and outbound messages.

handleNavigation(FacesContext, String, String) - Method in class javax.faces.application.ConfigurableNavigationHandlerWrapper

handleNavigation(FacesContext, String, String) - Method in class javax.faces.application.NavigationHandler

Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.

handleNavigation(FacesContext, String, String, String) - Method in class javax.faces.application.NavigationHandler

Overloaded variant of NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) that allows the caller to provide the defining document id for a flow to be entered by this navigation.

handleNavigation(FacesContext, String, String) - Method in class javax.faces.application.NavigationHandlerWrapper

handleNavigation(FacesContext, String, String, String) - Method in class javax.faces.application.NavigationHandlerWrapper

handlePageException(Exception) - Method in class javax.servlet.jsp.PageContext

This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.

handlePageException(Throwable) - Method in class javax.servlet.jsp.PageContext

This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.

handleProgressEvent(ProgressEvent) - Method in interface javax.enterprise.deploy.spi.status.ProgressListener

Invoked when a deployment progress event occurs.

Handler - Interface in javax.xml.rpc.handler

The javax.xml.rpc.handler.Handler interface is required to be implemented by a SOAP message handler.

Handler<C extends MessageContext> - Interface in javax.xml.ws.handler

The Handler interface is the base interface for JAX-WS handlers.

handler - Variable in class javax.xml.ws.spi.http.HttpContext

HandlerChain - Annotation Type in javax.jws

HandlerChain - Interface in javax.xml.rpc.handler

The javax.xml.rpc.handler.HandlerChain represents a list of handlers.

handleRequest(MessageContext) - Method in class javax.xml.rpc.handler.GenericHandler

The handleRequest method processes the request SOAP message.

handleRequest(MessageContext) - Method in interface javax.xml.rpc.handler.Handler

The handleRequest method processes the request message.

handleRequest(MessageContext) - Method in interface javax.xml.rpc.handler.HandlerChain

The handleRequest method initiates the request processing for this handler chain.

handleResourceRequest(FacesContext) - Method in class javax.faces.application.ResourceHandler

This method specifies the contract for satisfying resource requests.

handleResourceRequest(FacesContext) - Method in class javax.faces.application.ResourceHandlerWrapper

The default behavior of this method is to call ResourceHandler.handleResourceRequest(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.

handleResponse(MessageContext) - Method in class javax.xml.rpc.handler.GenericHandler

The handleResponse method processes the response message.

handleResponse(MessageContext) - Method in interface javax.xml.rpc.handler.Handler

The handleResponse method processes the response SOAP message.

handleResponse(MessageContext) - Method in interface javax.xml.rpc.handler.HandlerChain

The handleResponse method initiates the response processing for this handler chain.

handleResponse(Response<T>) - Method in interface javax.xml.ws.AsyncHandler

Called when the response to an asynchronous operation is available.

HandlerInfo - Class in javax.xml.rpc.handler

The javax.xml.rpc.handler.HandlerInfo represents information about a handler in the HandlerChain.

HandlerInfo() - Constructor for class javax.xml.rpc.handler.HandlerInfo

Default constructor

HandlerInfo(Class, Map, QName[]) - Constructor for class javax.xml.rpc.handler.HandlerInfo

Constructor for HandlerInfo

HandlerRegistry - Interface in javax.xml.rpc.handler

The javax.xml.rpc.handler.HandlerRegistry provides support for the programmatic configuration of handlers in a HandlerRegistry.

HandlerResolver - Interface in javax.xml.ws.handler

HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.

HandlesTypes - Annotation Type in javax.servlet.annotation

This annotation is used to declare the class types that a ServletContainerInitializer can handle.

handlesURI(String) - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory

Tests whether this factory can create a DeploymentManager object based on the specificed URI.

handleTimeout(AsyncResponse) - Method in interface javax.ws.rs.container.TimeoutHandler

Invoked when the suspended asynchronous response is about to time out.

HandshakeRequest - Interface in javax.websocket.server

The handshake request represents the web socket defined Http GET request for the opening handshake of a web socket session.

HandshakeResponse - Interface in javax.websocket

The handshake response represents the web socket-defined Http response that is the response to the opening handshake request.

hasBinding() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Return true if this component has a non-null binding attribute.

hasBinding() - Method in class javax.faces.webapp.UIComponentELTag

hasBinding() - Method in class javax.faces.webapp.UIComponentTag

Deprecated.

hasCondition() - Method in class javax.faces.application.NavigationCase

Test if this navigation case has an associated <if> element.

hasCondition() - Method in class javax.faces.application.NavigationCaseWrapper

hasConstrainedParameters() - Method in interface javax.validation.metadata.ExecutableDescriptor

Returns true if the executable parameters are constrained either: because of a constraint on at least one of the parameters because of a cascade on at least one of the parameters (via Valid) because of at least one cross-parameter constraint
Also returns false if there is no parameter.

hasConstrainedReturnValue() - Method in interface javax.validation.metadata.ExecutableDescriptor

Returns true if the executable return value is constrained either: because of a constraint on the return value because validation is cascaded on the return value (via Valid)
Also returns false if there is no return value.

hasConstraints() - Method in interface javax.validation.metadata.ElementDescriptor.ConstraintFinder

Returns true if at least one constraint declaration matching the restrictions is present on the element, false otherwise.

hasConstraints() - Method in interface javax.validation.metadata.ElementDescriptor

hasConstraints() - Method in interface javax.validation.metadata.ExecutableDescriptor

Returns false.

hasDetail() - Method in interface javax.xml.soap.SOAPFault

Returns true if this SOAPFault has a Detail subelement and false otherwise.

hasDynamicAttributes() - Method in class javax.servlet.jsp.tagext.TagInfo

Get dynamicAttributes associated with this TagInfo.

hasEntity() - Method in interface javax.ws.rs.client.ClientRequestContext

Check if there is an entity available in the request.

hasEntity() - Method in interface javax.ws.rs.client.ClientResponseContext

Check if there is a non-empty entity input stream is available in the response message.

hasEntity() - Method in interface javax.ws.rs.container.ContainerRequestContext

Check if there is a non-empty entity input stream available in the request message.

hasEntity() - Method in interface javax.ws.rs.container.ContainerResponseContext

Check if there is an entity available in the response.

hasEntity() - Method in class javax.ws.rs.core.Response

Check if there is an entity available in the response.

hasEvents() - Method in class javax.xml.bind.util.ValidationEventCollector

Returns true if this event collector contains at least one ValidationEvent.

hasFault() - Method in interface javax.xml.soap.SOAPBody

Indicates whether a SOAPFault object exists in this SOAPBody object.

hashCode() - Method in class javax.el.Expression

Returns the hash code for this Expression.

hashCode() - Method in class javax.enterprise.util.AnnotationLiteral

hashCode() - Method in class javax.enterprise.util.TypeLiteral

hashCode() - Method in class javax.faces.application.NavigationCase

hashCode() - Method in class javax.faces.application.NavigationCaseWrapper

hashCode() - Method in class javax.faces.validator.DoubleRangeValidator

hashCode() - Method in class javax.faces.validator.LengthValidator

hashCode() - Method in class javax.faces.validator.LongRangeValidator

hashCode() - Method in interface javax.json.JsonNumber

Returns the hash code value for this JsonNumber object.

hashCode() - Method in interface javax.json.JsonString

Returns the hash code value for this JsonString object.

hashCode() - Method in class javax.mail.Flags

Compute a hash code for this Flags object.

hashCode() - Method in class javax.mail.internet.InternetAddress

Compute a hash code for the address.

hashCode() - Method in class javax.mail.internet.NewsAddress

Compute a hash code for the address.

hashCode() - Method in class javax.mail.search.AddressTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.AndTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.ComparisonTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.DateTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.FlagTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.HeaderTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.IntegerComparisonTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.NotTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.OrTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.RecipientStringTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.RecipientTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.search.StringTerm

Compute a hashCode for this object.

hashCode() - Method in class javax.mail.URLName

Compute the hash code for this URLName.

hashCode() - Method in interface javax.resource.cci.Record

Returns the hash code for the Record instance.

hashCode() - Method in interface javax.resource.spi.ConnectionRequestInfo

Returns the hashCode of the ConnectionRequestInfo.

hashCode() - Method in interface javax.resource.spi.ManagedConnectionFactory

Returns the hash code for the ManagedConnectionFactory

hashCode() - Method in interface javax.resource.spi.security.GenericCredential

Deprecated.

Returns the hash code for this GenericCredential

hashCode() - Method in class javax.resource.spi.security.PasswordCredential

Returns the hash code for this PasswordCredential

hashCode() - Method in class javax.security.jacc.EJBMethodPermission

Returns the hash code value for this EJBMethodPermission.

hashCode() - Method in class javax.security.jacc.EJBRoleRefPermission

Returns the hash code value for this EJBRoleRefPermission.

hashCode() - Method in class javax.security.jacc.WebResourcePermission

Returns the hash code value for this WebResourcePermission.

hashCode() - Method in class javax.security.jacc.WebRoleRefPermission

Returns the hash code value for this WebRoleRefPermission.

hashCode() - Method in class javax.security.jacc.WebUserDataPermission

Returns the hash code value for this WebUserDataPermission.

hashCode() - Method in class javax.servlet.jsp.jstl.core.IndexedValueExpression

hashCode() - Method in class javax.servlet.jsp.jstl.core.IteratedValueExpression

hashCode() - Method in class javax.ws.rs.core.AbstractMultivaluedMap

This implementation delegates the method call to to the the underlying [key, multi-value] store.

hashCode() - Method in class javax.ws.rs.core.CacheControl

Generate hash code from cache control properties.

hashCode() - Method in class javax.ws.rs.core.Cookie

Generate a hash code by hashing all of the cookies properties.

hashCode() - Method in class javax.ws.rs.core.EntityTag

Generate hashCode based on value and weakness.

hashCode() - Method in class javax.ws.rs.core.GenericEntity

hashCode() - Method in class javax.ws.rs.core.GenericType

hashCode() - Method in class javax.ws.rs.core.MediaType

Generate a hash code from the type, subtype and parameters.

hashCode() - Method in class javax.ws.rs.core.NewCookie

Generate a hash code by hashing all of the properties.

hashCode() - Method in class javax.ws.rs.core.Variant

Generate hash code from variant properties.

hasLink(String) - Method in interface javax.ws.rs.client.ClientResponseContext

Check if link for relation exists.

hasLink(String) - Method in interface javax.ws.rs.container.ContainerResponseContext

Check if link for relation exists.

hasLink(String) - Method in class javax.ws.rs.core.Response

Check if link for relation exists.

hasMetadata(UIViewRoot) - Static method in class javax.faces.view.ViewMetadata

Utility method to determine if the the provided UIViewRoot has metadata.

hasMoreResults() - Method in interface javax.persistence.StoredProcedureQuery

Return true if the next result corresponds to a result set, and false if it is an update count or if there are no results other than through INOUT and OUT parameters, if any.

hasNewMessages() - Method in class javax.mail.Folder

Returns true if this Folder has new messages since the last time this indication was reset.

hasNext() - Method in interface javax.json.stream.JsonParser

Returns true if there are more parsing states.

hasNext() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Returns information concerning the availability of more items over which to iterate.

hasOriginalRequestAndResponse() - Method in interface javax.servlet.AsyncContext

Checks if this AsyncContext was initialized with the original or application-wrapped request and response objects.

hasRetryAfter() - Method in exception javax.ws.rs.ServiceUnavailableException

Check if the underlying response contains the information on when is it possible to retry the request.

hasSingleIdAttribute() - Method in interface javax.persistence.metamodel.IdentifiableType

Whether the identifiable type has a single id attribute.

hasVersionAttribute() - Method in interface javax.persistence.metamodel.IdentifiableType

Whether the identifiable type has a version attribute.

having(Expression<Boolean>) - Method in interface javax.persistence.criteria.AbstractQuery

Specify a restriction over the groups of the query.

having(Predicate...) - Method in interface javax.persistence.criteria.AbstractQuery

Specify restrictions over the groups of the query according the conjunction of the specified restriction predicates.

having(Expression<Boolean>) - Method in interface javax.persistence.criteria.CriteriaQuery

Specify a restriction over the groups of the query.

having(Predicate...) - Method in interface javax.persistence.criteria.CriteriaQuery

Specify restrictions over the groups of the query according the conjunction of the specified restriction predicates.

having(Expression<Boolean>) - Method in interface javax.persistence.criteria.Subquery

Specify a restriction over the groups of the subquery.

having(Predicate...) - Method in interface javax.persistence.criteria.Subquery

Specify restrictions over the groups of the subquery according the conjunction of the specified restriction predicates.

head() - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP HEAD method for the current request asynchronously.

head(InvocationCallback<Response>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP HEAD method for the current request asynchronously.

head() - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP HEAD method for the current request synchronously.

HEAD - Annotation Type in javax.ws.rs

Indicates that the annotated method responds to HTTP HEAD requests.

HEAD - Static variable in annotation type javax.ws.rs.HttpMethod

HTTP HEAD method.

Header - Class in javax.mail

The Header class stores a name/value pair to represent headers.

Header(String, String) - Constructor for class javax.mail.Header

Construct a Header object.

header(String, Object) - Method in interface javax.ws.rs.client.Invocation.Builder

Add an arbitrary header.

header(String, Object) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Add an arbitrary header.

HEADER_DECORATOR - Static variable in class javax.ws.rs.Priorities

Header decorator filter/interceptor priority.

HeaderParam - Annotation Type in javax.ws.rs

Binds the value(s) of a HTTP header to a resource method parameter, resource class field, or resource class bean property.

headers - Variable in class javax.mail.internet.InternetHeaders

The actual list of Headers, including placeholder entries.

headers - Variable in class javax.mail.internet.MimeBodyPart

The InternetHeaders object that stores all the headers of this body part.

headers - Variable in class javax.mail.internet.MimeMessage

The InternetHeaders object that stores the header of this message.

headers(MultivaluedMap<String, Object>) - Method in interface javax.ws.rs.client.Invocation.Builder

Replaces all existing headers with the newly supplied headers.

HeaderTerm - Class in javax.mail.search

This class implements comparisons for Message headers.

HeaderTerm(String, String) - Constructor for class javax.mail.search.HeaderTerm

Constructor.

HeaderTokenizer - Class in javax.mail.internet

This class tokenizes RFC822 and MIME headers into the basic symbols specified by RFC822 and MIME.

HeaderTokenizer(String, String, boolean) - Constructor for class javax.mail.internet.HeaderTokenizer

Constructor that takes a rfc822 style header.

HeaderTokenizer(String, String) - Constructor for class javax.mail.internet.HeaderTokenizer

Constructor.

HeaderTokenizer(String) - Constructor for class javax.mail.internet.HeaderTokenizer

Constructor.

HeaderTokenizer.Token - Class in javax.mail.internet

The Token class represents tokens returned by the HeaderTokenizer.

HeaderTokenizer.Token(int, String) - Constructor for class javax.mail.internet.HeaderTokenizer.Token

Constructor.

HeuristicCommitException - Exception in javax.transaction

This exception is thrown by the rollback operation on a resource to report that a heuristic decision was made and that all relevant updates have been committed.

HeuristicCommitException() - Constructor for exception javax.transaction.HeuristicCommitException

HeuristicCommitException(String) - Constructor for exception javax.transaction.HeuristicCommitException

HeuristicMixedException - Exception in javax.transaction

This exception is thrown to report that a heuristic decision was made and that some relevant updates have been committed and others have been rolled back.

HeuristicMixedException() - Constructor for exception javax.transaction.HeuristicMixedException

HeuristicMixedException(String) - Constructor for exception javax.transaction.HeuristicMixedException

HeuristicRollbackException - Exception in javax.transaction

This exception is thrown by the commit operation to report that a heuristic decision was made and that all relevant updates have been rolled back.

HeuristicRollbackException() - Constructor for exception javax.transaction.HeuristicRollbackException

HeuristicRollbackException(String) - Constructor for exception javax.transaction.HeuristicRollbackException

HexBinaryAdapter - Class in javax.xml.bind.annotation.adapters

XmlAdapter for xs:hexBinary.

HexBinaryAdapter() - Constructor for class javax.xml.bind.annotation.adapters.HexBinaryAdapter

HintsContext - Class in javax.resource.spi.work

A standard WorkContext that allows a Work instance to propagate quality-of-service (QoS) hints about the Work to the WorkManager.

HintsContext() - Constructor for class javax.resource.spi.work.HintsContext

Holder - Interface in javax.xml.rpc.holders

The java.xml.rpc.holders.Holder interface represents the base interface for both standard and generated Holder classes.

Holder<T> - Class in javax.xml.ws

Holds a value of type T.

Holder() - Constructor for class javax.xml.ws.Holder

Creates a new holder with a null value.

Holder(T) - Constructor for class javax.xml.ws.Holder

Create a new holder with the specified value.

HOLDS_FOLDERS - Static variable in class javax.mail.Folder

This folder can contain other folders

HOLDS_MESSAGES - Static variable in class javax.mail.Folder

This folder can contain messages

HomeHandle - Interface in javax.ejb

The HomeHandle interface is implemented by all home object handles.

HONOR_CURRENT_COMPONENT_ATTRIBUTES_PARAM_NAME - Static variable in class javax.faces.component.UIComponent

The ServletContext init parameter consulted by the UIComponent to tell whether or not the UIComponent.CURRENT_COMPONENT and UIComponent.CURRENT_COMPOSITE_COMPONENT attribute keys should be honored as specified.

host - Variable in class javax.mail.internet.NewsAddress

HOST - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

host(String) - Method in class javax.ws.rs.core.UriBuilder

Set the URI host.

hostnameVerifier(HostnameVerifier) - Method in class javax.ws.rs.client.ClientBuilder

Set the hostname verifier to be used by the client to verify the endpoint's hostname against it's identification information.

hour(String) - Method in class javax.ejb.ScheduleExpression

Set the hour attribute.

hour(int) - Method in class javax.ejb.ScheduleExpression

Set the hour attribute.

html(T) - Static method in class javax.ws.rs.client.Entity

Create a "text/html" entity.

HTML_BASIC_RENDER_KIT - Static variable in class javax.faces.render.RenderKitFactory

The render kit identifier of the default RenderKit instance for this JavaServer Faces implementation.

HtmlBody - Class in javax.faces.component.html

NONE

HtmlBody() - Constructor for class javax.faces.component.html.HtmlBody

HtmlBody.PropertyKeys - Enum in javax.faces.component.html

HtmlColumn - Class in javax.faces.component.html

Represents a column that will be rendered in an HTML table element.

HtmlColumn() - Constructor for class javax.faces.component.html.HtmlColumn

HtmlColumn.PropertyKeys - Enum in javax.faces.component.html

HtmlCommandButton - Class in javax.faces.component.html

Represents an HTML input element for a button of type submit or reset.

HtmlCommandButton() - Constructor for class javax.faces.component.html.HtmlCommandButton

HtmlCommandButton.PropertyKeys - Enum in javax.faces.component.html

HtmlCommandLink - Class in javax.faces.component.html

Represents an HTML a element for a hyperlink that acts like a submit button.

HtmlCommandLink() - Constructor for class javax.faces.component.html.HtmlCommandLink

HtmlCommandLink.PropertyKeys - Enum in javax.faces.component.html

HtmlDataTable - Class in javax.faces.component.html

Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.

HtmlDataTable() - Constructor for class javax.faces.component.html.HtmlDataTable

HtmlDataTable.PropertyKeys - Enum in javax.faces.component.html

HtmlDoctype - Class in javax.faces.component.html

NONE

HtmlDoctype() - Constructor for class javax.faces.component.html.HtmlDoctype

HtmlDoctype.PropertyKeys - Enum in javax.faces.component.html

HtmlForm - Class in javax.faces.component.html

Represents an HTML form element.

HtmlForm() - Constructor for class javax.faces.component.html.HtmlForm

HtmlForm.PropertyKeys - Enum in javax.faces.component.html

HtmlGraphicImage - Class in javax.faces.component.html

Represents an HTML img element, used to retrieve and render a graphical image.

HtmlGraphicImage() - Constructor for class javax.faces.component.html.HtmlGraphicImage

HtmlGraphicImage.PropertyKeys - Enum in javax.faces.component.html

HtmlHead - Class in javax.faces.component.html

NONE

HtmlHead() - Constructor for class javax.faces.component.html.HtmlHead

HtmlHead.PropertyKeys - Enum in javax.faces.component.html

HtmlInputFile - Class in javax.faces.component.html

Represents an HTML input element of type file.

HtmlInputFile() - Constructor for class javax.faces.component.html.HtmlInputFile

HtmlInputFile.PropertyKeys - Enum in javax.faces.component.html

HtmlInputHidden - Class in javax.faces.component.html

Represents an HTML input element of type hidden.

HtmlInputHidden() - Constructor for class javax.faces.component.html.HtmlInputHidden

HtmlInputHidden.PropertyKeys - Enum in javax.faces.component.html

HtmlInputSecret - Class in javax.faces.component.html

Represents an HTML input element of type password.

HtmlInputSecret() - Constructor for class javax.faces.component.html.HtmlInputSecret

HtmlInputSecret.PropertyKeys - Enum in javax.faces.component.html

HtmlInputText - Class in javax.faces.component.html

Represents an HTML input element of type text.

HtmlInputText() - Constructor for class javax.faces.component.html.HtmlInputText

HtmlInputText.PropertyKeys - Enum in javax.faces.component.html

HtmlInputTextarea - Class in javax.faces.component.html

Represents an HTML textarea element.

HtmlInputTextarea() - Constructor for class javax.faces.component.html.HtmlInputTextarea

HtmlInputTextarea.PropertyKeys - Enum in javax.faces.component.html

HtmlMessage - Class in javax.faces.component.html

By default, the rendererType property must be set to "javax.faces.Message".

HtmlMessage() - Constructor for class javax.faces.component.html.HtmlMessage

HtmlMessage.PropertyKeys - Enum in javax.faces.component.html

HtmlMessages - Class in javax.faces.component.html

By default, the rendererType property must be set to "javax.faces.Messages".

HtmlMessages() - Constructor for class javax.faces.component.html.HtmlMessages

HtmlMessages.PropertyKeys - Enum in javax.faces.component.html

HtmlOutcomeTargetButton - Class in javax.faces.component.html

Represents an HTML input element of type "button" or image that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.

HtmlOutcomeTargetButton() - Constructor for class javax.faces.component.html.HtmlOutcomeTargetButton

HtmlOutcomeTargetButton.PropertyKeys - Enum in javax.faces.component.html

HtmlOutcomeTargetLink - Class in javax.faces.component.html

Represents an HTML a (hyperlink) element that may be used to link to a URL handled by the Faces Servlet resolved preemptively using the logical outcome defined by the outcome property.

HtmlOutcomeTargetLink() - Constructor for class javax.faces.component.html.HtmlOutcomeTargetLink

HtmlOutcomeTargetLink.PropertyKeys - Enum in javax.faces.component.html

HtmlOutputFormat - Class in javax.faces.component.html

Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.

HtmlOutputFormat() - Constructor for class javax.faces.component.html.HtmlOutputFormat

HtmlOutputFormat.PropertyKeys - Enum in javax.faces.component.html

HtmlOutputLabel - Class in javax.faces.component.html

Represents an HTML label element, used to define an accessible label for a corresponding input element.

HtmlOutputLabel() - Constructor for class javax.faces.component.html.HtmlOutputLabel

HtmlOutputLabel.PropertyKeys - Enum in javax.faces.component.html

HtmlOutputLink - Class in javax.faces.component.html

Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.

HtmlOutputLink() - Constructor for class javax.faces.component.html.HtmlOutputLink

HtmlOutputLink.PropertyKeys - Enum in javax.faces.component.html

HtmlOutputText - Class in javax.faces.component.html

Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.

HtmlOutputText() - Constructor for class javax.faces.component.html.HtmlOutputText

HtmlOutputText.PropertyKeys - Enum in javax.faces.component.html

HtmlPanelGrid - Class in javax.faces.component.html

Renders child components in a table, starting a new row after the specified number of columns.

HtmlPanelGrid() - Constructor for class javax.faces.component.html.HtmlPanelGrid

HtmlPanelGrid.PropertyKeys - Enum in javax.faces.component.html

HtmlPanelGroup - Class in javax.faces.component.html

Causes all child components of this component to be rendered.

HtmlPanelGroup() - Constructor for class javax.faces.component.html.HtmlPanelGroup

HtmlPanelGroup.PropertyKeys - Enum in javax.faces.component.html

HtmlSelectBooleanCheckbox - Class in javax.faces.component.html

Represents an HTML input element of type checkbox.

HtmlSelectBooleanCheckbox() - Constructor for class javax.faces.component.html.HtmlSelectBooleanCheckbox

HtmlSelectBooleanCheckbox.PropertyKeys - Enum in javax.faces.component.html

HtmlSelectManyCheckbox - Class in javax.faces.component.html

Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.

HtmlSelectManyCheckbox() - Constructor for class javax.faces.component.html.HtmlSelectManyCheckbox

HtmlSelectManyCheckbox.PropertyKeys - Enum in javax.faces.component.html

HtmlSelectManyListbox - Class in javax.faces.component.html

Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.

HtmlSelectManyListbox() - Constructor for class javax.faces.component.html.HtmlSelectManyListbox

HtmlSelectManyListbox.PropertyKeys - Enum in javax.faces.component.html

HtmlSelectManyMenu - Class in javax.faces.component.html

Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.

HtmlSelectManyMenu() - Constructor for class javax.faces.component.html.HtmlSelectManyMenu

HtmlSelectManyMenu.PropertyKeys - Enum in javax.faces.component.html

HtmlSelectOneListbox - Class in javax.faces.component.html

Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.

HtmlSelectOneListbox() - Constructor for class javax.faces.component.html.HtmlSelectOneListbox

HtmlSelectOneListbox.PropertyKeys - Enum in javax.faces.component.html

HtmlSelectOneMenu - Class in javax.faces.component.html

Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.

HtmlSelectOneMenu() - Constructor for class javax.faces.component.html.HtmlSelectOneMenu

HtmlSelectOneMenu.PropertyKeys - Enum in javax.faces.component.html

HtmlSelectOneRadio - Class in javax.faces.component.html

Represents a single-selection component that is rendered as a set of HTML input elements of type radio.

HtmlSelectOneRadio() - Constructor for class javax.faces.component.html.HtmlSelectOneRadio

HtmlSelectOneRadio.PropertyKeys - Enum in javax.faces.component.html

HTTP_BINDING - Static variable in interface javax.xml.ws.http.HTTPBinding

A constant representing the identity of the XML/HTTP binding.

HTTP_REQUEST_HEADERS - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: HTTP request headers.

HTTP_REQUEST_METHOD - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: HTTP request method.

HTTP_RESPONSE_CODE - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: HTTP response status code.

HTTP_RESPONSE_HEADERS - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: HTTP response headers.

HTTPBinding - Interface in javax.xml.ws.http

The HTTPBinding interface is an abstraction for the XML/HTTP binding.

HttpConstraint - Annotation Type in javax.servlet.annotation

This annotation is used within the ServletSecurity annotation to represent the security constraints to be applied to all HTTP protocol methods for which a corresponding HttpMethodConstraint element does NOT occur within the ServletSecurity annotation.

HttpConstraintElement - Class in javax.servlet

Java Class representation of an HttpConstraint annotation value.

HttpConstraintElement() - Constructor for class javax.servlet.HttpConstraintElement

Constructs a default HTTP constraint element

HttpConstraintElement(ServletSecurity.EmptyRoleSemantic) - Constructor for class javax.servlet.HttpConstraintElement

Convenience constructor to establish EmptyRoleSemantic.DENY

HttpConstraintElement(ServletSecurity.TransportGuarantee, String...) - Constructor for class javax.servlet.HttpConstraintElement

Constructor to establish non-empty getRolesAllowed and/or TransportGuarantee.CONFIDENTIAL.

HttpConstraintElement(ServletSecurity.EmptyRoleSemantic, ServletSecurity.TransportGuarantee, String...) - Constructor for class javax.servlet.HttpConstraintElement

Constructor to establish all of getEmptyRoleSemantic, getRolesAllowed, and getTransportGuarantee.

HttpContext - Class in javax.xml.ws.spi.http

HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.

HttpContext() - Constructor for class javax.xml.ws.spi.http.HttpContext

HTTPException - Exception in javax.xml.ws.http

The HTTPException exception represents a XML/HTTP fault.

HTTPException(int) - Constructor for exception javax.xml.ws.http.HTTPException

Constructor for the HTTPException

HttpExchange - Class in javax.xml.ws.spi.http

This class encapsulates a HTTP request received and a response to be generated in one exchange.

HttpExchange() - Constructor for class javax.xml.ws.spi.http.HttpExchange

HttpHandler - Class in javax.xml.ws.spi.http

A handler which is invoked to process HTTP requests.

HttpHandler() - Constructor for class javax.xml.ws.spi.http.HttpHandler

HttpHeaders - Interface in javax.ws.rs.core

An injectable interface that provides access to HTTP header information.

HttpJspPage - Interface in javax.servlet.jsp

The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.

HttpMethod - Annotation Type in javax.ws.rs

Associates the name of a HTTP method with an annotation.

HttpMethodConstraint - Annotation Type in javax.servlet.annotation

This annotation is used within the ServletSecurity annotation to represent security constraints on specific HTTP protocol messages.

HttpMethodConstraintElement - Class in javax.servlet

Java Class represntation of an HttpMethodConstraint annotation value.

HttpMethodConstraintElement(String) - Constructor for class javax.servlet.HttpMethodConstraintElement

Constructs an instance with default HttpConstraintElement value.

HttpMethodConstraintElement(String, HttpConstraintElement) - Constructor for class javax.servlet.HttpMethodConstraintElement

Constructs an instance with specified HttpConstraintElement value.

HttpServlet - Class in javax.servlet.http

Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site.

HttpServlet() - Constructor for class javax.servlet.http.HttpServlet

Does nothing, because this is an abstract class.

HttpServletRequest - Interface in javax.servlet.http

Extends the ServletRequest interface to provide request information for HTTP servlets.

HttpServletRequestWrapper - Class in javax.servlet.http

Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.

HttpServletRequestWrapper(HttpServletRequest) - Constructor for class javax.servlet.http.HttpServletRequestWrapper

Constructs a request object wrapping the given request.

HttpServletResponse - Interface in javax.servlet.http

Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response.

HttpServletResponseWrapper - Class in javax.servlet.http

Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.

HttpServletResponseWrapper(HttpServletResponse) - Constructor for class javax.servlet.http.HttpServletResponseWrapper

Constructs a response adaptor wrapping the given response.

HttpSession - Interface in javax.servlet.http

Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.

HttpSessionActivationListener - Interface in javax.servlet.http

Objects that are bound to a session may listen to container events notifying them that sessions will be passivated and that session will be activated.

HttpSessionAttributeListener - Interface in javax.servlet.http

Interface for receiving notification events about HttpSession attribute changes.

HttpSessionBindingEvent - Class in javax.servlet.http

Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.

HttpSessionBindingEvent(HttpSession, String) - Constructor for class javax.servlet.http.HttpSessionBindingEvent

Constructs an event that notifies an object that it has been bound to or unbound from a session.

HttpSessionBindingEvent(HttpSession, String, Object) - Constructor for class javax.servlet.http.HttpSessionBindingEvent

Constructs an event that notifies an object that it has been bound to or unbound from a session.

HttpSessionBindingListener - Interface in javax.servlet.http

Causes an object to be notified when it is bound to or unbound from a session.

HttpSessionContext - Interface in javax.servlet.http

Deprecated.
As of Java(tm) Servlet API 2.1 for security reasons, with no replacement. This interface will be removed in a future version of this API.

HttpSessionEvent - Class in javax.servlet.http

This is the class representing event notifications for changes to sessions within a web application.

HttpSessionEvent(HttpSession) - Constructor for class javax.servlet.http.HttpSessionEvent

Construct a session event from the given source.

HttpSessionIdListener - Interface in javax.servlet.http

Interface for receiving notification events about HttpSession id changes.

HttpSessionListener - Interface in javax.servlet.http

Interface for receiving notification events about HttpSession lifecycle changes.

HttpUpgradeHandler - Interface in javax.servlet.http

This interface encapsulates the upgrade protocol processing.

HttpUtils - Class in javax.servlet.http

Deprecated.
As of Java(tm) Servlet API 2.3. These methods were only useful with the default encoding and have been moved to the request interfaces.

HttpUtils() - Constructor for class javax.servlet.http.HttpUtils

Deprecated.

Constructs an empty HttpUtils object.

I

i - Variable in class javax.servlet.jsp.jstl.core.IndexedValueExpression

i - Variable in class javax.servlet.jsp.jstl.core.IteratedValueExpression

id(String, String) - Method in class javax.faces.flow.builder.FlowBuilder

Set the defining document id and flow id of this flow.

Id - Annotation Type in javax.persistence

Specifies the primary key of an entity.

id - Variable in class javax.resource.spi.ConnectionEvent

Type of the event

ID - Static variable in class javax.servlet.jsp.tagext.TagAttributeInfo

"id" is wired in to be ID.

id - Variable in class javax.servlet.jsp.tagext.TagSupport

The value of the id attribute of this tag; or null.

ID - Static variable in class javax.xml.ws.RespectBindingFeature

Constant value identifying the RespectBindingFeature

ID - Static variable in class javax.xml.ws.soap.AddressingFeature

Constant value identifying the AddressingFeature

ID - Static variable in class javax.xml.ws.soap.MTOMFeature

Constant value identifying the MTOMFeature

IdClass - Annotation Type in javax.persistence

Specifies a composite primary key class that is mapped to multiple fields or properties of the entity.

IdentifiableType<X> - Interface in javax.persistence.metamodel

Instances of the type IdentifiableType represent entity or mapped superclass types.

IDENTITY_NAME - Static variable in interface javax.enterprise.concurrent.ManagedTask

Execution property to be returned in ManagedTask.getExecutionProperties() or ContextService.createContextualProxy() to provide a String that identifies the task.

IF_MATCH - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

IF_MODIFIED_SINCE - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

IF_NONE_MATCH - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

IF_UNMODIFIED_SINCE - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

ignore(String) - Method in class javax.faces.view.facelets.MetaRuleset

Customize this MetaRuleset instance to advise it to ignore the attribute named by the attribute argument, returning this.

ignoreAll() - Method in class javax.faces.view.facelets.MetaRuleset

Customize this MetaRuleset instance to advise it to ignore all attributes, returning this.

ignoreCase - Variable in class javax.mail.search.StringTerm

Ignore case when comparing?

ignoreExistingBoundaryParameter - Variable in class javax.mail.internet.MimeMultipart

Flag corresponding to the "mail.mime.multipart.ignoreexistingboundaryparameter" property, set in the MimeMultipart.initializeProperties() method called from constructors and the parse method.

ignoreMissingBoundaryParameter - Variable in class javax.mail.internet.MimeMultipart

Flag corresponding to the "mail.mime.multipart.ignoremissingboundaryparameter" property, set in the MimeMultipart.initializeProperties() method called from constructors and the parse method.

ignoreMissingEndBoundary - Variable in class javax.mail.internet.MimeMultipart

Flag corresponding to the "mail.mime.multipart.ignoremissingendboundary" property, set in the MimeMultipart.initializeProperties() method called from constructors and the parse method.

ignoreXmlConfiguration() - Method in interface javax.validation.Configuration

Ignores data from the META-INF/validation.xml file if this method is called.

IllegalLoopbackException - Exception in javax.ejb

This exception indicates that an attempt was made to perform an illegal loopback invocation.

IllegalLoopbackException() - Constructor for exception javax.ejb.IllegalLoopbackException

IllegalLoopbackException(String) - Constructor for exception javax.ejb.IllegalLoopbackException

IllegalProductException - Exception in javax.enterprise.inject

Indicates that a producer method returned a null value or a producer field contained a null value, and the scope of the producer method or field was not Dependent.

IllegalProductException() - Constructor for exception javax.enterprise.inject.IllegalProductException

IllegalProductException(String, Throwable) - Constructor for exception javax.enterprise.inject.IllegalProductException

IllegalProductException(String) - Constructor for exception javax.enterprise.inject.IllegalProductException

IllegalProductException(Throwable) - Constructor for exception javax.enterprise.inject.IllegalProductException

IllegalStateException - Exception in javax.jms

This exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation.

IllegalStateException(String, String) - Constructor for exception javax.jms.IllegalStateException

Constructs an IllegalStateException with the specified reason and error code.

IllegalStateException(String) - Constructor for exception javax.jms.IllegalStateException

Constructs an IllegalStateException with the specified reason.

IllegalStateException - Exception in javax.resource.spi

An IllegalStateException is thrown from a method if the callee (resource adapter or application server for system contracts) is in an illegal or inappropriate state for the method invocation.

IllegalStateException() - Constructor for exception javax.resource.spi.IllegalStateException

Constructs a new instance with null as its detail message.

IllegalStateException(String) - Constructor for exception javax.resource.spi.IllegalStateException

Constructs a new instance with the specified detail message.

IllegalStateException(Throwable) - Constructor for exception javax.resource.spi.IllegalStateException

Constructs a new throwable with the specified cause.

IllegalStateException(String, Throwable) - Constructor for exception javax.resource.spi.IllegalStateException

Constructs a new throwable with the specified detail message and cause.

IllegalStateException(String, String) - Constructor for exception javax.resource.spi.IllegalStateException

Constructs a new throwable with the specified detail message and an error code.

IllegalStateRuntimeException - Exception in javax.jms

This unchecked exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation, and the method signature does not permit a IllegalStateRuntimeException to be thrown.

IllegalStateRuntimeException(String) - Constructor for exception javax.jms.IllegalStateRuntimeException

Constructs a IllegalStateRuntimeException with the specified detail message

IllegalStateRuntimeException(String, String) - Constructor for exception javax.jms.IllegalStateRuntimeException

Constructs a IllegalStateRuntimeException with the specified detail message and error code.

IllegalStateRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.IllegalStateRuntimeException

Constructs a IllegalStateRuntimeException with the specified detail message, error code and cause

IllegalWriteException - Exception in javax.mail

The exception thrown when a write is attempted on a read-only attribute of any Messaging object.

IllegalWriteException() - Constructor for exception javax.mail.IllegalWriteException

Constructs an IllegalWriteException with no detail message.

IllegalWriteException(String) - Constructor for exception javax.mail.IllegalWriteException

Constructs an IllegalWriteException with the specified detail message.

IllegalWriteException(String, Exception) - Constructor for exception javax.mail.IllegalWriteException

Constructs an IllegalWriteException with the specified detail message and embedded exception.

IMMEDIATE - Static variable in interface javax.resource.spi.work.WorkManager

A constant to indicate timeout duration.

ImplicitObjectELResolver - Class in javax.servlet.jsp.el

Defines variable resolution behavior for the EL implicit objects defined in the JSP specification.

ImplicitObjectELResolver() - Constructor for class javax.servlet.jsp.el.ImplicitObjectELResolver

implies(Permission) - Method in class javax.security.jacc.EJBMethodPermission

Determines if the argument Permission is "implied by" this EJBMethodPermission.

implies(Permission) - Method in class javax.security.jacc.EJBRoleRefPermission

Determines if the argument Permission is "implied by" this EJBRoleRefPermission.

implies(Permission) - Method in class javax.security.jacc.WebResourcePermission

Determines if the argument Permission is "implied by" this WebResourcePermission.

implies(Permission) - Method in class javax.security.jacc.WebRoleRefPermission

Determines if the argument Permission is "implied by" this WebRoleRefPermission.

implies(Permission) - Method in class javax.security.jacc.WebUserDataPermission

Determines if the argument Permission is "implied by" this WebUserDataPermission.

importClass(String) - Method in class javax.el.ELManager

Import a class.

importClass(String) - Method in class javax.el.ImportHandler

Import a class.

ImportHandler - Class in javax.el

Handles imports of class names and package names.

ImportHandler() - Constructor for class javax.el.ImportHandler

importPackage(String) - Method in class javax.el.ELManager

Import a package.

importPackage(String) - Method in class javax.el.ImportHandler

Import all the classes in a package.

importStatic(String) - Method in class javax.el.ELManager

Import a static field or method.

importStatic(String) - Method in class javax.el.ImportHandler

Import a static field or method.

in - Variable in class javax.mail.util.SharedFileInputStream

The file containing the data.

in(Expression<? extends T>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create predicate to test whether given expression is contained in a list of values.

in(Object...) - Method in interface javax.persistence.criteria.Expression

Create a predicate to test whether the expression is a member of the argument list.

in(Expression<?>...) - Method in interface javax.persistence.criteria.Expression

Create a predicate to test whether the expression is a member of the argument list.

in(Collection<?>) - Method in interface javax.persistence.criteria.Expression

Create a predicate to test whether the expression is a member of the collection.

in(Expression<Collection<?>>) - Method in interface javax.persistence.criteria.Expression

Create a predicate to test whether the expression is a member of the collection.

IN - Static variable in class javax.xml.rpc.ParameterMode

IN mode for parameter passing

IN_AFTER_PHASE_KEY - Static variable in class javax.faces.event.ExceptionQueuedEventContext

The presence of an entry under this key in the Map returned from ExceptionQueuedEventContext.getAttributes() indicates the event occurred during the “after phase” part of the current lifecycle phase.

IN_BEFORE_PHASE_KEY - Static variable in class javax.faces.event.ExceptionQueuedEventContext

The presence of an entry under this key in the Map returned from ExceptionQueuedEventContext.getAttributes() indicates the event occurred during the “before phase” part of the current lifecycle phase.

inactiveConnectionClosed(Object, ManagedConnectionFactory) - Method in interface javax.resource.spi.LazyAssociatableConnectionManager

This method is called by the resource adapter (that is capable of lazy connection association optimization) in order to notify the application server that a disassociated connection handle is closed.

inAfterPhase() - Method in class javax.faces.event.ExceptionQueuedEventContext

inBeforePhase() - Method in class javax.faces.event.ExceptionQueuedEventContext

INBOUND_MESSAGE_ATTACHMENTS - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.

inboundParameter(String, ValueExpression) - Method in class javax.faces.flow.builder.FlowBuilder

A parameter that will be populated with the value from a correspondingly named outbound parameter from another flow when this flow is entered from that flow.

inboundParameter(String, String) - Method in class javax.faces.flow.builder.FlowBuilder

A parameter that will be populated with the value from a correspondingly named outbound parameter from another flow when this flow is entered from that flow.

include(String) - Method in class javax.servlet.jsp.PageContext

Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.

include(String, boolean) - Method in class javax.servlet.jsp.PageContext

Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.

include(ServletRequest, ServletResponse) - Method in interface javax.servlet.RequestDispatcher

Includes the content of a resource (servlet, JSP page, HTML file) in the response.

INCLUDE_CONTEXT_PATH - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the context path of the target of an include is stored

INCLUDE_PATH_INFO - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the path info of the target of an include is stored

INCLUDE_QUERY_STRING - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the query string of the target of an include is stored

INCLUDE_REQUEST_URI - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the request URI of the target of an include is stored

INCLUDE_SERVLET_PATH - Static variable in interface javax.servlet.RequestDispatcher

The name of the request attribute under which the servlet path of the target of an include is stored

includeFacelet(UIComponent, String) - Method in class javax.faces.view.facelets.FaceletContext

Include another Facelet defined at some path, relative to the executing context, not the current Facelet (same as include directive in JSP)

includeFacelet(UIComponent, URL) - Method in class javax.faces.view.facelets.FaceletContext

Include another Facelet defined at some path, absolute to this ClassLoader/OS

includeViewParams() - Method in class javax.faces.flow.builder.NavigationCaseBuilder.RedirectBuilder

Indicates the current redirect should include view parameters.

INDEFINITE - Static variable in interface javax.resource.spi.work.WorkManager

A constant to indicate timeout duration.

index() - Method in interface javax.persistence.criteria.ListJoin

Create an expression that corresponds to the index of the object in the referenced association or element collection.

Index - Annotation Type in javax.persistence

Used in schema generation to specify creation of an index.

IndexedRecord - Interface in javax.resource.cci

IndexedRecord represents an ordered collection of record elements based on the java.util.List interface.

IndexedValueExpression - Class in javax.servlet.jsp.jstl.core

IndexedValueExpression(ValueExpression, int) - Constructor for class javax.servlet.jsp.jstl.core.IndexedValueExpression

info - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo

Information (documentation) for this TLD.

Inheritance - Annotation Type in javax.persistence

Specifies the inheritance strategy to be used for an entity class hierarchy.

InheritanceType - Enum in javax.persistence

Defines inheritance strategy options.

Init - Annotation Type in javax.ejb

Designates a method of a session bean that corresponds to a create<METHOD> method of an adapted home or local home interface (an interface that adapts an EJB 2.1 or earlier EJBHome or EJBLocalHome client view respectively).

init(ServletConfig) - Method in class javax.faces.webapp.FacesServlet

Acquire the factory instances we will require.

init(FilterConfig) - Method in interface javax.servlet.Filter

Called by the web container to indicate to a filter that it is being placed into service.

init(ServletConfig) - Method in class javax.servlet.GenericServlet

Called by the servlet container to indicate to a servlet that the servlet is being placed into service.

init() - Method in class javax.servlet.GenericServlet

A convenience method which can be overridden so that there's no need to call super.init(config).

init(WebConnection) - Method in interface javax.servlet.http.HttpUpgradeHandler

It is called once the HTTP Upgrade process has been completed and the upgraded connection is ready to start using the new protocol.

init(ServletConfig) - Method in interface javax.servlet.Servlet

Called by the servlet container to indicate to a servlet that the servlet is being placed into service.

init(EndpointConfig) - Method in interface javax.websocket.Decoder

This method is called with the endpoint configuration object of the endpoint this decoder is intended for when it is about to be brought into service.

init(EndpointConfig) - Method in interface javax.websocket.Encoder

This method is called with the endpoint configuration object of the endpoint this encoder is intended for when it is about to be brought into service.

init(HandlerInfo) - Method in class javax.xml.rpc.handler.GenericHandler

The init method to enable the Handler instance to initialize itself.

init(HandlerInfo) - Method in interface javax.xml.rpc.handler.Handler

The init method enables the Handler instance to initialize itself.

init(Map) - Method in interface javax.xml.rpc.handler.HandlerChain

Initializes the configuration for a HandlerChain.

init(Object) - Method in interface javax.xml.rpc.server.ServiceLifecycle

Used for initialization of a service endpoint.

initCause(Throwable) - Method in exception javax.xml.registry.JAXRException

Initializes the cause of this throwable to the specified value.

initCause(Throwable) - Method in exception javax.xml.soap.SOAPException

Initializes the cause field of this SOAPException object with the given Throwable object.

inIterable() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext

Marks the node as being in an Iterable or a Map.

inIterable() - Method in interface javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext

Marks the node as being in an Iterable or a Map.

initialize(MessagePolicy, MessagePolicy, CallbackHandler, Map) - Method in interface javax.security.auth.message.module.ClientAuthModule

Initialize this module with request and response message policies to enforce, a CallbackHandler, and any module-specific configuration properties.

initialize(MessagePolicy, MessagePolicy, CallbackHandler, Map) - Method in interface javax.security.auth.message.module.ServerAuthModule

Initialize this module with request and response message policies to enforce, a CallbackHandler, and any module-specific configuration properties.

initialize(Servlet, ServletRequest, ServletResponse, String, boolean, int, boolean) - Method in class javax.servlet.jsp.PageContext

The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.

initialize(A) - Method in interface javax.validation.ConstraintValidator

Initializes the validator in preparation for ConstraintValidator.isValid(Object, ConstraintValidatorContext) calls.

Initialized - Annotation Type in javax.enterprise.context

The @Initialized qualifier.

initializeProperties() - Method in class javax.mail.internet.MimeMultipart

Initialize flags that control parsing behavior, based on System properties described above in the class documentation.

initializer(MethodExpression) - Method in class javax.faces.flow.builder.FlowBuilder

A MethodExpression that will be invoked when the flow is entered.

initializer(String) - Method in class javax.faces.flow.builder.FlowBuilder

A MethodExpression that will be invoked when the flow is entered.

initialStateMarked() - Method in class javax.faces.component.behavior.BehaviorBase

Implementation of PartialStateHolder.initialStateMarked().

initialStateMarked() - Method in interface javax.faces.component.PartialStateHolder

Return true if delta state changes are being tracked, otherwise false

initialStateMarked() - Method in class javax.faces.component.UIComponent

An implementation of PartialStateHolder.initialStateMarked(), this method is called by the runtime to test if the PartialStateHolder.markInitialState() method was called.

initialStateMarked() - Method in class javax.faces.convert.DateTimeConverter

initialStateMarked() - Method in class javax.faces.convert.EnumConverter

initialStateMarked() - Method in class javax.faces.convert.NumberConverter

initialStateMarked() - Method in class javax.faces.validator.BeanValidator

initialStateMarked() - Method in class javax.faces.validator.DoubleRangeValidator

initialStateMarked() - Method in class javax.faces.validator.LengthValidator

initialStateMarked() - Method in class javax.faces.validator.LongRangeValidator

initialStateMarked() - Method in class javax.faces.validator.RegexValidator

InitParam - Annotation Type in javax.jws.soap

Deprecated.

initResource(T) - Method in interface javax.ws.rs.container.ResourceContext

Initialize the resource or sub-resource instance.

initView(FacesContext) - Method in class javax.faces.application.ViewHandler

Initialize the view for the request processing lifecycle.

initView(FacesContext) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.initView(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

inject(T, CreationalContext<T>) - Method in interface javax.enterprise.inject.spi.InjectionTarget

Performs dependency injection upon the given object.

inject() - Method in class javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance

Inject the instance

Inject - Annotation Type in javax.inject

Identifies injectable constructors, methods, and fields.

inject(WebServiceContext) - Method in class javax.xml.ws.spi.Invoker

JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance.

InjectionException - Exception in javax.enterprise.inject

Indicates a problem relating to dependency injection.

InjectionException() - Constructor for exception javax.enterprise.inject.InjectionException

InjectionException(String, Throwable) - Constructor for exception javax.enterprise.inject.InjectionException

InjectionException(String) - Constructor for exception javax.enterprise.inject.InjectionException

InjectionException(Throwable) - Constructor for exception javax.enterprise.inject.InjectionException

InjectionPoint - Interface in javax.enterprise.inject.spi

Provides access to metadata about an injection point.

InjectionTarget<T> - Interface in javax.enterprise.inject.spi

Provides operations for performing dependency injection and lifecycle callbacks on an instance of a type.

InjectionTargetFactory<T> - Interface in javax.enterprise.inject.spi

An InjectionTargetFactory can create an InjectionTarget for a given bean.

INLINE - Static variable in interface javax.mail.Part

This part should be presented inline.

INOUT - Static variable in class javax.xml.rpc.ParameterMode

INOUT mode for parameter passing

insertsAreDetected(int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether or not a visible row insert can be detected by calling ResultSet.rowInserted.

inService() - Method in interface javax.security.jacc.PolicyConfiguration

This method is used to determine if the policy context whose interface is this PolicyConfiguration Object is in the "inService" state.

inService(String) - Method in class javax.security.jacc.PolicyConfigurationFactory

This method determines if the identified policy context exists with state "inService" in the Policy provider associated with the factory.

inspectFlow(FacesContext, Flow) - Method in class javax.faces.application.ConfigurableNavigationHandler

Called by the flow system to cause the flow to be inspected for navigation rules.

inspectFlow(FacesContext, Flow) - Method in class javax.faces.application.ConfigurableNavigationHandlerWrapper

Instance<T> - Interface in javax.enterprise.inject

Allows the application to dynamically obtain instances of beans with a specified combination of required type and qualifiers.

INTEGER_ID - Static variable in class javax.faces.convert.IntegerConverter

The message identifier of the FacesMessage to be created if the conversion to Integer fails.

IntegerComparisonTerm - Class in javax.mail.search

This class implements comparisons for integers.

IntegerComparisonTerm(int, int) - Constructor for class javax.mail.search.IntegerComparisonTerm

IntegerConverter - Class in javax.faces.convert

Converter implementation for java.lang.Integer (and int primitive) values.

IntegerConverter() - Constructor for class javax.faces.convert.IntegerConverter

IntegerWrapperHolder - Class in javax.xml.rpc.holders

IntegerWrapperHolder() - Constructor for class javax.xml.rpc.holders.IntegerWrapperHolder

IntegerWrapperHolder(Integer) - Constructor for class javax.xml.rpc.holders.IntegerWrapperHolder

Interaction - Interface in javax.resource.cci

The javax.resource.cci.Interaction enables a component to execute EIS functions.

InteractionSpec - Interface in javax.resource.cci

An InteractionSpec holds properties for driving an Interaction with an EIS instance.

intercept(InterceptionType, T, InvocationContext) - Method in interface javax.enterprise.inject.spi.Interceptor

Invokes the specified kind of lifecycle callback or method invocation interception upon the given interceptor instance.

Intercepted - Annotation Type in javax.enterprise.inject

An interceptor may inject metadata about the bean it is intercepting.

InterceptionType - Enum in javax.enterprise.inject.spi

Identifies the kind of lifecycle callback, EJB timeout method or business method interception.

Interceptor<T> - Interface in javax.enterprise.inject.spi

Represents an enabled interceptor.

Interceptor - Annotation Type in javax.interceptor

Specifies that a class is an interceptor.

Interceptor.Priority - Class in javax.interceptor

Priorities that define the order in which interceptors are invoked.

InterceptorBinding - Annotation Type in javax.interceptor

Specifies that an annotation type is an interceptor binding type.

InterceptorContext - Interface in javax.ws.rs.ext

Context shared by message body interceptors that can be used to wrap calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream) and MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream).

Interceptors - Annotation Type in javax.interceptor

Declares an ordered list of interceptors for a target class, a method or a constructor of a target class.

intercepts(InterceptionType) - Method in interface javax.enterprise.inject.spi.Interceptor

Determines if the interceptor intercepts the specified kind of lifecycle callback or method invocation.

interfaceName(QName) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.

INTERNAL - Static variable in exception javax.resource.spi.work.WorkException

Indicates an internal error condition.

InternalServerErrorException - Exception in javax.ws.rs

A runtime exception indicating an internal server error.

InternalServerErrorException() - Constructor for exception javax.ws.rs.InternalServerErrorException

Construct a new internal server error exception.

InternalServerErrorException(String) - Constructor for exception javax.ws.rs.InternalServerErrorException

Construct a new internal server error exception.

InternalServerErrorException(Response) - Constructor for exception javax.ws.rs.InternalServerErrorException

Construct a new internal server error exception.

InternalServerErrorException(String, Response) - Constructor for exception javax.ws.rs.InternalServerErrorException

Construct a new internal server error exception.

InternalServerErrorException(Throwable) - Constructor for exception javax.ws.rs.InternalServerErrorException

Construct a new internal server error exception.

InternalServerErrorException(String, Throwable) - Constructor for exception javax.ws.rs.InternalServerErrorException

Construct a new internal server error exception.

InternalServerErrorException(Response, Throwable) - Constructor for exception javax.ws.rs.InternalServerErrorException

Construct a new internal server error exception.

InternalServerErrorException(String, Response, Throwable) - Constructor for exception javax.ws.rs.InternalServerErrorException

Construct a new internal server error exception.

INTERNATIONAL_STRING - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.InternationalString interface.

InternationalString - Interface in javax.xml.registry.infomodel

This interface represents a String that has been internationalized into several Locales.

InternetAddress - Class in javax.mail.internet

This class represents an Internet email address using the syntax of RFC822.

InternetAddress() - Constructor for class javax.mail.internet.InternetAddress

Default constructor.

InternetAddress(String) - Constructor for class javax.mail.internet.InternetAddress

Constructor.

InternetAddress(String, boolean) - Constructor for class javax.mail.internet.InternetAddress

Parse the given string and create an InternetAddress.

InternetAddress(String, String) - Constructor for class javax.mail.internet.InternetAddress

Construct an InternetAddress given the address and personal name.

InternetAddress(String, String, String) - Constructor for class javax.mail.internet.InternetAddress

Construct an InternetAddress given the address and personal name.

InternetHeaders - Class in javax.mail.internet

InternetHeaders is a utility class that manages RFC822 style headers.

InternetHeaders() - Constructor for class javax.mail.internet.InternetHeaders

Create an empty InternetHeaders object.

InternetHeaders(InputStream) - Constructor for class javax.mail.internet.InternetHeaders

Read and parse the given RFC822 message stream till the blank line separating the header from the body.

InternetHeaders.InternetHeader - Class in javax.mail.internet

An individual internet header.

InternetHeaders.InternetHeader(String) - Constructor for class javax.mail.internet.InternetHeaders.InternetHeader

Constructor that takes a line and splits out the header name.

InternetHeaders.InternetHeader(String, String) - Constructor for class javax.mail.internet.InternetHeaders.InternetHeader

Constructor that takes a header name and value.

interpolate(String, MessageInterpolator.Context) - Method in interface javax.validation.MessageInterpolator

Interpolates the message template based on the constraint validation context.

interpolate(String, MessageInterpolator.Context, Locale) - Method in interface javax.validation.MessageInterpolator

Interpolates the message template based on the constraint validation context.

IntHolder - Class in javax.xml.rpc.holders

IntHolder() - Constructor for class javax.xml.rpc.holders.IntHolder

IntHolder(int) - Constructor for class javax.xml.rpc.holders.IntHolder

intValue() - Method in interface javax.json.JsonNumber

Returns this JSON number as an int.

intValueExact() - Method in interface javax.json.JsonNumber

Returns this JSON number as an int.

invalid - Variable in class javax.mail.event.TransportEvent

invalid - Variable in exception javax.mail.SendFailedException

INVALID_MESSAGE_ID - Static variable in class javax.faces.component.UISelectMany

The message identifier of the FacesMessage to be created if a value not matching the available options is specified.

INVALID_MESSAGE_ID - Static variable in class javax.faces.component.UISelectOne

The message identifier of the FacesMessage to be created if a value not matching the available options is specified.

invalidate() - Method in interface javax.servlet.http.HttpSession

Invalidates this session then unbinds any objects bound to it.

invalidateSession() - Method in class javax.faces.context.ExternalContext

Invalidates this session then unbinds any objects bound to it.

invalidateSession() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.invalidateSession() on the wrapped ExternalContext object.

InvalidClientIDException - Exception in javax.jms

This exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider.

InvalidClientIDException(String, String) - Constructor for exception javax.jms.InvalidClientIDException

Constructs an InvalidClientIDException with the specified reason and error code.

InvalidClientIDException(String) - Constructor for exception javax.jms.InvalidClientIDException

Constructs an InvalidClientIDException with the specified reason.

InvalidClientIDRuntimeException - Exception in javax.jms

This unchecked exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider, and the method signature does not permit a InvalidClientIDException to be thrown.

InvalidClientIDRuntimeException(String) - Constructor for exception javax.jms.InvalidClientIDRuntimeException

Constructs a InvalidClientIDRuntimeException with the specified detail message

InvalidClientIDRuntimeException(String, String) - Constructor for exception javax.jms.InvalidClientIDRuntimeException

Constructs a InvalidClientIDRuntimeException with the specified detail message and error code.

InvalidClientIDRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.InvalidClientIDRuntimeException

Constructs a InvalidClientIDRuntimeException with the specified detail message, error code and cause

InvalidDestinationException - Exception in javax.jms

This exception must be thrown when a destination either is not understood by a provider or is no longer valid.

InvalidDestinationException(String, String) - Constructor for exception javax.jms.InvalidDestinationException

Constructs an InvalidDestinationException with the specified reason and error code.

InvalidDestinationException(String) - Constructor for exception javax.jms.InvalidDestinationException

Constructs an InvalidDestinationException with the specified reason.

InvalidDestinationRuntimeException - Exception in javax.jms

This unchecked exception must be thrown when a destination either is not understood by a provider or is no longer valid, and the method signature does not permit a InvalidDestinationException to be thrown.

InvalidDestinationRuntimeException(String) - Constructor for exception javax.jms.InvalidDestinationRuntimeException

Constructs a InvalidDestinationRuntimeException with the specified detail message

InvalidDestinationRuntimeException(String, String) - Constructor for exception javax.jms.InvalidDestinationRuntimeException

Constructs a InvalidDestinationRuntimeException with the specified detail message and error code.

InvalidDestinationRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.InvalidDestinationRuntimeException

Constructs a InvalidDestinationRuntimeException with the specified detail message, error code and cause

InvalidModuleException - Exception in javax.enterprise.deploy.spi.exceptions

This exception is to report an invalid Java EE deployment module type.

InvalidModuleException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.InvalidModuleException

Creates an new InvalidModuleException object.

InvalidPropertyException - Exception in javax.resource.spi

This exception is thrown to indicate invalid configuration property settings.

InvalidPropertyException() - Constructor for exception javax.resource.spi.InvalidPropertyException

Create a InvalidPropertyException.

InvalidPropertyException(String) - Constructor for exception javax.resource.spi.InvalidPropertyException

Create a InvalidPropertyException.

InvalidPropertyException(Throwable) - Constructor for exception javax.resource.spi.InvalidPropertyException

Constructs a new throwable with the specified cause.

InvalidPropertyException(String, Throwable) - Constructor for exception javax.resource.spi.InvalidPropertyException

Constructs a new throwable with the specified detail message and cause.

InvalidPropertyException(String, String) - Constructor for exception javax.resource.spi.InvalidPropertyException

Constructs a new throwable with the specified detail message and an error code.

InvalidRequestException - Exception in javax.xml.registry

This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.

InvalidRequestException() - Constructor for exception javax.xml.registry.InvalidRequestException

Constructs a JAXRException object with no reason or embedded Throwable.

InvalidRequestException(String) - Constructor for exception javax.xml.registry.InvalidRequestException

Constructs a JAXRException object with the given String as the reason for the exception being thrown.

InvalidRequestException(String, Throwable) - Constructor for exception javax.xml.registry.InvalidRequestException

Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

InvalidRequestException(Throwable) - Constructor for exception javax.xml.registry.InvalidRequestException

Constructs a JAXRException object initialized with the given Throwable object.

InvalidSelectorException - Exception in javax.jms

This exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax.

InvalidSelectorException(String, String) - Constructor for exception javax.jms.InvalidSelectorException

Constructs an InvalidSelectorException with the specified reason and error code.

InvalidSelectorException(String) - Constructor for exception javax.jms.InvalidSelectorException

Constructs an InvalidSelectorException with the specified reason.

InvalidSelectorRuntimeException - Exception in javax.jms

This unchecked exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax, and the method signature does not permit a InvalidSelectorException to be thrown.

InvalidSelectorRuntimeException(String) - Constructor for exception javax.jms.InvalidSelectorRuntimeException

Constructs a InvalidSelectorRuntimeException with the specified detail message

InvalidSelectorRuntimeException(String, String) - Constructor for exception javax.jms.InvalidSelectorRuntimeException

Constructs a InvalidSelectorRuntimeException with the specified detail message and error code.

InvalidSelectorRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.InvalidSelectorRuntimeException

Constructs a InvalidSelectorRuntimeException with the specified detail message, error code and cause

InvalidTransactionException - Exception in javax.transaction

This exception indicates that the request carried an invalid transaction context.

InvalidTransactionException() - Constructor for exception javax.transaction.InvalidTransactionException

InvalidTransactionException(String) - Constructor for exception javax.transaction.InvalidTransactionException

invocation(Link) - Method in interface javax.ws.rs.client.Client

Build an invocation builder from a link.

Invocation - Interface in javax.ws.rs.client

A client request invocation.

Invocation.Builder - Interface in javax.ws.rs.client

A client request invocation builder.

InvocationCallback<RESPONSE> - Interface in javax.ws.rs.client

Callback that can be implemented to receive the asynchronous processing events from the invocation processing.

InvocationContext - Interface in javax.interceptor

Exposes context information about the intercepted invocation and operations that enable interceptor methods to control the behavior of the invocation chain.

invoke(ELContext, Object, Object, Class<?>[], Object[]) - Method in class javax.el.BeanELResolver

If the base object is not null, invoke the method, with the given parameters on this bean.

invoke(ELContext, Object, Object, Class<?>[], Object[]) - Method in class javax.el.CompositeELResolver

Attemps to resolve and invoke the given method on the given base object by querying all component resolvers.

invoke(ELContext, Object, Object, Class<?>[], Object[]) - Method in class javax.el.ELResolver

Attempts to resolve and invoke the given method on the given base object.

invoke(ELContext, Object...) - Method in class javax.el.LambdaExpression

Invoke the encapsulated Lambda expression.

invoke(Object...) - Method in class javax.el.LambdaExpression

Invoke the encapsulated Lambda expression.

invoke(ELContext, Object[]) - Method in class javax.el.MethodExpression

If a String literal is specified as the expression, returns the String literal coerced to the expected return type of the method signature.

invoke(ELContext, Object, Object, Class<?>[], Object[]) - Method in class javax.el.StaticFieldELResolver

Invokes a public static method or the constructor for a class.

invoke(FacesContext, Object[]) - Method in class javax.faces.el.MethodBinding

Deprecated.

Return the return value (if any) resulting from a call to the method identified by this method binding expression, passing it the specified parameters, relative to the specified FacesContext.

invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management.j2ee.Management

Invokes an operation on a managed object.

invoke(Writer) - Method in class javax.servlet.jsp.tagext.JspFragment

Executes the fragment and directs all output to the given Writer, or the JspWriter returned by the getOut() method of the JspContext associated with the fragment if out is null.

invoke() - Method in interface javax.ws.rs.client.Invocation

Synchronously invoke the request and receive a response back.

invoke(Class<T>) - Method in interface javax.ws.rs.client.Invocation

Synchronously invoke the request and receive a response of the specified type back.

invoke(GenericType<T>) - Method in interface javax.ws.rs.client.Invocation

Synchronously invoke the request and receive a response of the specified generic type back.

invoke(Object[]) - Method in interface javax.xml.rpc.Call

Invokes a specific operation using a synchronous request-response interaction mode.

invoke(QName, Object[]) - Method in interface javax.xml.rpc.Call

Invokes a specific operation using a synchronous request-response interaction mode.

invoke(T) - Method in interface javax.xml.ws.Dispatch

Invoke a service operation synchronously.

invoke(T) - Method in interface javax.xml.ws.Provider

Invokes an operation occording to the contents of the request message.

invoke(Method, Object...) - Method in class javax.xml.ws.spi.Invoker

JAX-WS runtime calls this method to do the actual web service invocation on endpoint instance.

INVOKE_APPLICATION - Static variable in class javax.faces.event.PhaseId

Identifier that indicates an interest in events queued for the Invoke Application phase of the request processing lifecycle.

invokeAsync(T) - Method in interface javax.xml.ws.Dispatch

Invoke a service operation asynchronously.

invokeAsync(T, AsyncHandler<T>) - Method in interface javax.xml.ws.Dispatch

Invoke a service operation asynchronously.

invokeContextCallback(FacesContext, UIComponent) - Method in interface javax.faces.component.ContextCallback

This method will be called by an implementation of UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) and must be passed the component with the clientId given as an argument to invokeOnComponent.

invokeOnComponent(FacesContext, String, ContextCallback) - Method in class javax.faces.component.UIComponent

Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.

invokeOnComponent(FacesContext, String, ContextCallback) - Method in class javax.faces.component.UIComponentBase

Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.

invokeOnComponent(FacesContext, String, ContextCallback) - Method in class javax.faces.component.UIData

Override behavior from UIComponentBase.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) to provide special care for positioning the data properly before finding the component and invoking the callback on it.

invokeOneWay(Object[]) - Method in interface javax.xml.rpc.Call

Invokes a remote method using the one-way interaction mode.

invokeOneWay(T) - Method in interface javax.xml.ws.Dispatch

Invokes a service operation using the one-way interaction mode.

Invoker - Class in javax.xml.ws.spi

Invoker hides the detail of calling into application endpoint implementation.

Invoker() - Constructor for class javax.xml.ws.spi.Invoker

invokeVisitCallback(UIComponent, VisitCallback) - Method in class javax.faces.component.visit.VisitContext

Called by UIComponent.visitTree() to visit a single component.

invokeVisitCallback(UIComponent, VisitCallback) - Method in class javax.faces.component.visit.VisitContextWrapper

IS_BUILDING_INITIAL_STATE - Static variable in class javax.faces.application.StateManager

Marker within the FacesContext attributes map to indicate we are marking initial state, so the markInitialState() method of iterating components such as UIData could recognize this fact and save the initial state of descendents.

IS_SAVING_STATE - Static variable in class javax.faces.application.StateManager

Marker within the FacesContext attributes map to indicate we are saving state.

isActive() - Method in interface javax.enterprise.context.spi.Context

Determines if the context object is active.

isActive(FacesContext, String, String) - Method in class javax.faces.flow.FlowHandler

Return true if and only if the flow referenced by the argument definingDocument and id is currently active.

isActive() - Method in interface javax.persistence.EntityTransaction

Indicate whether a resource transaction is in progress.

isAddEvent() - Method in class javax.enterprise.deploy.model.XpathEvent

Is this an add event?

isAjaxRequest() - Method in class javax.faces.context.PartialViewContext

Return true if the request header Faces-Request is present with the value partial/ajax.

isAjaxRequest() - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.isAjaxRequest() on the wrapped PartialViewContext object.

isAlternative() - Method in interface javax.enterprise.inject.spi.BeanAttributes

Determines if the bean is an alternative.

isAmbiguous() - Method in interface javax.enterprise.inject.Instance

Determines if there is more than one bean that matches the required type and qualifiers and is eligible for injection into the class into which the parent Instance was injected.

isAnnotationPresent(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.Annotated

Determine if the program element has an annotation of a certain annotation type.

isAppropriateListener(FacesListener) - Method in class javax.faces.event.ActionEvent

isAppropriateListener(FacesListener) - Method in class javax.faces.event.AjaxBehaviorEvent

Return true if this FacesListener is an instance of a the appropriate listener class that this event supports.

isAppropriateListener(FacesListener) - Method in class javax.faces.event.ComponentSystemEvent

Return true if the argument FacesListener is an instance of the appropriate listener class that this event supports.

isAppropriateListener(FacesListener) - Method in class javax.faces.event.FacesEvent

Return true if this FacesListener is an instance of a listener class that this event supports.

isAppropriateListener(FacesListener) - Method in class javax.faces.event.PostAddToViewEvent

Returns true if and only if the argument listener is an instance of SystemEventListener.

isAppropriateListener(FacesListener) - Method in class javax.faces.event.PreRemoveFromViewEvent

Returns true if and only if the argument listener is an instance of SystemEventListener.

isAppropriateListener(FacesListener) - Method in class javax.faces.event.SystemEvent

Return true if this FacesListener is an instance of a the appropriate listener class that this event supports.

isAppropriateListener(FacesListener) - Method in class javax.faces.event.ValueChangeEvent

isAscending() - Method in interface javax.persistence.criteria.Order

Whether ascending ordering is in effect.

isAssociation() - Method in interface javax.persistence.metamodel.Attribute

Is the attribute an association.

isAsyncStarted() - Method in interface javax.servlet.ServletRequest

Checks if this request has been put into asynchronous mode.

isAsyncStarted() - Method in class javax.servlet.ServletRequestWrapper

Checks if the wrapped request has been put into asynchronous mode.

isAsyncSupported() - Method in interface javax.servlet.ServletRequest

Checks if this request supports asynchronous operation.

isAsyncSupported() - Method in class javax.servlet.ServletRequestWrapper

Checks if the wrapped request supports asynchronous operation.

isAutoFlush() - Method in class javax.servlet.jsp.JspWriter

This method indicates whether the JspWriter is autoFlushing.

isAvailable() - Method in exception javax.xml.registry.JAXRException

Returns true if a response is available, false otherwise.

isAvailable() - Method in interface javax.xml.registry.JAXRResponse

Returns true if a response is available, false otherwise.

isBeanConstrained() - Method in interface javax.validation.metadata.BeanDescriptor

Returns true if the bean involves validation: a constraint is hosted on the bean itself a constraint is hosted on one of the bean properties or a bean property is marked for cascaded validation (Valid)
Constrained methods and constructors are ignored.

isBodyAssignableTo(Class) - Method in interface javax.jms.Message

Returns whether the message body is capable of being assigned to the specified type.

isBound(Parameter<?>) - Method in interface javax.persistence.Query

Return a boolean indicating whether a value has been bound to the parameter.

isCalendarTimer() - Method in interface javax.ejb.Timer

Return whether this timer is a calendar-based timer.

isCallerInRole(Identity) - Method in interface javax.ejb.EJBContext

Deprecated.
Use boolean isCallerInRole(String roleName) instead.

isCallerInRole(String) - Method in interface javax.ejb.EJBContext

Test if the caller has a given security role.

isCancelled() - Method in class javax.ejb.AsyncResult

This method should not be called.

isCancelled() - Method in interface javax.ws.rs.container.AsyncResponse

Check if the asynchronous response instance has been cancelled.

isCancelSupported() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject

Tests whether the vendor supports a cancel opertation for deployment activities.

isCascadable(Object, Path.Node, Class<?>, Path, ElementType) - Method in interface javax.validation.TraversableResolver

Determines if the Bean Validation provider is allowed to cascade validation on the bean instance returned by the property value marked as @Valid.

isCascaded() - Method in interface javax.validation.metadata.CascadableDescriptor

Whether this element is marked for cascaded validation or not.

isChangeEvent() - Method in class javax.enterprise.deploy.model.XpathEvent

Is this a change event?

isClientWindowRenderModeEnabled(FacesContext) - Method in class javax.faces.lifecycle.ClientWindow

Methods that append the ClientWindow to generated URLs must call this method to see if they are permitted to do so.

isClientWindowRenderModeEnabled(FacesContext) - Method in class javax.faces.lifecycle.ClientWindowWrapper

isClosed() - Method in interface javax.xml.registry.Connection

Indicated whether this Connection has been closed or not.

isCollection() - Method in interface javax.persistence.metamodel.Attribute

Is the attribute collection-valued (represents a Collection, Set, List, or Map).

isComment() - Method in interface javax.xml.soap.Text

Retrieves whether this Text object represents a comment.

isCommitted() - Method in interface javax.servlet.ServletResponse

Returns a boolean indicating if the response has been committed.

isCommitted() - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to return isCommitted() on the wrapped response object.

isCompatible(MediaType) - Method in class javax.ws.rs.core.MediaType

Check if this media type is compatible with another media type.

isComplete() - Method in class javax.mail.internet.MimeMultipart

Return true if the final boundary line for this multipart was seen.

isCompleted() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus

A convience method to report if the operation is in the completed state.

isCompositeComponent(UIComponent) - Static method in class javax.faces.component.UIComponent

Return true if component is a composite component, otherwise false.

isCompoundSelection() - Method in interface javax.persistence.criteria.Selection

Whether the selection item is a compound selection.

isConfirmed() - Method in interface javax.xml.registry.infomodel.Association

Determines whether an Association has been confirmed completely.

isConfirmedBySourceOwner() - Method in interface javax.xml.registry.infomodel.Association

Determines whether an Association has been confirmed by the owner of the source object.

isConfirmedByTargetOwner() - Method in interface javax.xml.registry.infomodel.Association

Determines whether an Association has been confirmed by the owner of the target object.

isConnected() - Method in class javax.mail.Service

Is this service currently connected?

isContextSupported(Class<? extends WorkContext>) - Method in interface javax.resource.spi.BootstrapContext

A resource adapter can check an application server's support for a particular WorkContext type through this method.

isCorrelated() - Method in interface javax.persistence.criteria.From

Whether the From object has been obtained as a result of correlation (use of a Subquery correlate method).

isCurrentThreadShutdown() - Static method in class javax.enterprise.concurrent.ManagedExecutors

Utility method for checking the isShutdown() value of the current thread if it is a ManageableThread created from ManagedThreadFactory.newThread() .

isDConfigBeanVersionSupported(DConfigBeanVersionType) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Returns 'true' if the configuration beans support the Java EE platform version specified.

isDefaultEvent() - Method in interface javax.faces.view.BehaviorHolderAttachedObjectTarget

isDeferredMethod() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

Returns true if this attribute is to be passed a MethodExpression so that expression evaluation can be deferred.

isDeferredValue() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

Returns true if this attribute is to be passed a ValueExpression so that expression evaluation can be deferred.

isDelegate() - Method in interface javax.enterprise.inject.spi.InjectionPoint

Determines if the injection point is a decorator delegate injection point.

isDeliveryTransacted(Method) - Method in interface javax.resource.spi.endpoint.MessageEndpointFactory

This is used to find out whether message deliveries to a target method on a message listener interface that is implemented by a message endpoint or a target method in the Class returned by the getBeanClass method, will be transacted or not.

isDisable() - Method in class javax.faces.component.UIParameter

Return the value of the disable directive for this component.

isDisableClientWindow() - Method in class javax.faces.component.UIOutcomeTarget

Return whether or not the client window should be encoded into the target url.

isDisabled() - Method in class javax.faces.component.behavior.AjaxBehavior

Return the disabled status of this behavior.

isDisabled() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlCommandLink

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlOutputLink

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the disabled property.

isDisabled() - Method in class javax.faces.model.SelectItem

Return the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.

isDisabled(FaceletContext) - Method in class javax.faces.view.facelets.DelegatingMetaTagHandler

isDistinct() - Method in interface javax.persistence.criteria.AbstractQuery

Return whether duplicate query results must be eliminated or retained.

isDone() - Method in class javax.ejb.AsyncResult

This method should not be called.

isDone() - Method in interface javax.ws.rs.container.AsyncResponse

Check if the processing of a request this asynchronous response instance belongs to has finished.

isElement(Object) - Method in class javax.xml.bind.JAXBIntrospector

Return true if object represents a JAXB element.

isEmpty(Object) - Static method in class javax.faces.component.UIInput

isEmpty() - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.isEmpty() on the wrapped Flash object.

isEmpty(Expression<C>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate that tests whether a collection is empty.

isEmpty() - Method in class javax.ws.rs.core.AbstractMultivaluedMap

isEnabled(Feature) - Method in interface javax.ws.rs.core.Configuration

Check if a particular feature instance has been previously enabled in the runtime configuration context.

isEnabled(Class<? extends Feature>) - Method in interface javax.ws.rs.core.Configuration

Check if a feature instance of featureClass class has been previously enabled in the runtime configuration context.

isEnabled() - Method in class javax.xml.ws.WebServiceFeature

Returns true if this feature is enabled.

isEscape() - Method in class javax.faces.component.html.HtmlOutputFormat

Return the value of the escape property.

isEscape() - Method in class javax.faces.component.html.HtmlOutputLabel

Return the value of the escape property.

isEscape() - Method in class javax.faces.component.html.HtmlOutputText

Return the value of the escape property.

isEscape() - Method in class javax.faces.model.SelectItem

If and only if this returns true, the code that renders this select item must escape the label using escaping syntax appropriate to the content type being rendered.

isExecutableValidationEnabled() - Method in interface javax.validation.BootstrapConfiguration

Returns true if the validation execution is explicitly marked as enabled or if it is left undefined.

isExecuteAll() - Method in class javax.faces.context.PartialViewContext

Return true if PartialViewContext.isAjaxRequest() returns true and PartialViewContext.PARTIAL_EXECUTE_PARAM_NAME is present in the current request with the value PartialViewContext.ALL_PARTIAL_PHASE_CLIENT_IDS.

isExecuteAll() - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.isExecuteAll() on the wrapped PartialViewContext object.

isExpunged() - Method in class javax.mail.Message

Checks whether this message is expunged.

isExternal() - Method in interface javax.xml.registry.infomodel.Classification

Returns true if this is an external classification.

isExternal() - Method in interface javax.xml.registry.infomodel.ClassificationScheme

Determines whether this ClassificationScheme is an external ClassificationScheme or an internal ClassificationScheme.

isExtramural() - Method in interface javax.xml.registry.infomodel.Association

Determines whether an Association is extramural or not.

isFaceletCached(URL) - Method in class javax.faces.view.facelets.FaceletCache

Determines whether a cached Facelet instance exists for this URL.

isFailed() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus

A convience method to report if the operation is in the failed state.

isFalse(Expression<Boolean>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate testing for a false value.

isFinished() - Method in class javax.servlet.ServletInputStream

Returns true when all the data from the stream has been read else it returns false.

isFirst() - Method in interface javax.servlet.jsp.jstl.core.LoopTagStatus

Returns information about whether the current round of the iteration is the first one.

isFormattedOutput() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the formatted output flag.

isFragment() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

Whether this attribute is of type JspFragment.

isFragment() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the fragment flag.

isGlobalOnly() - Method in class javax.faces.component.UIMessages

Return the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered.

isGlobalScope() - Method in class javax.xml.bind.JAXBElement

Returns true iff this xml element declaration is global.

isGroup() - Method in class javax.mail.internet.InternetAddress

Indicates whether this address is an RFC 822 group address.

isGroupingUsed() - Method in class javax.faces.convert.NumberConverter

Return true if getAsString should include grouping separators if necessary.

isHttpOnly() - Method in class javax.servlet.http.Cookie

Checks whether this Cookie has been marked as HttpOnly.

isHttpOnly() - Method in interface javax.servlet.SessionCookieConfig

Checks if the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired will be marked as HttpOnly.

isHttpOnly() - Method in class javax.ws.rs.core.NewCookie

Returns true if this cookie contains the HttpOnly attribute.

isId() - Method in interface javax.persistence.metamodel.SingularAttribute

Is the attribute an id attribute.

isIdentical(EJBLocalObject) - Method in interface javax.ejb.EJBLocalObject

Test if a given EJB local object is identical to the invoked EJB local object.

isIdentical(EJBObject) - Method in interface javax.ejb.EJBObject

Test if a given EJB object is identical to the invoked EJB object.

isIgnoreXmlConfiguration() - Method in interface javax.validation.spi.ConfigurationState

Returns true if Configuration.ignoreXmlConfiguration() has been called.

isImmediate() - Method in interface javax.faces.component.ActionSource

Return a flag indicating that the default ActionListener provided by the JavaServer Faces implementation should be executed immediately (that is, during Apply Request Values phase of the request processing lifecycle), rather than waiting until the Invoke Application phase.

isImmediate() - Method in class javax.faces.component.behavior.AjaxBehavior

Return the immediate status of this behavior.

isImmediate() - Method in interface javax.faces.component.EditableValueHolder

Return the "immediate" state for this component.

isImmediate() - Method in class javax.faces.component.UICommand

The immediate flag.

isImmediate() - Method in class javax.faces.component.UIInput

isImmediate() - Method in class javax.faces.component.UIViewAction

If the value of the component's immediate attribute is true, the action will be invoked during the Apply Request Values JSF lifecycle phase.

isImmediate() - Method in class javax.faces.component.UIViewParameter

Return false.

isImmediateSet() - Method in class javax.faces.component.behavior.AjaxBehavior

Tests whether the immediate attribute is specified.

isIncludeViewParams() - Method in class javax.faces.application.NavigationCase

Return the <redirect> value for this <navigation-case>.

isIncludeViewParams() - Method in class javax.faces.application.NavigationCaseWrapper

isIncludeViewParams() - Method in class javax.faces.component.UIOutcomeTarget

Return whether or not the view parameters should be encoded into the target url.

isInIterable() - Method in interface javax.validation.Path.Node

isIntegerOnly() - Method in class javax.faces.convert.NumberConverter

Return true if only the integer portion of the given value should be returned from getAsObject().

isIntegral() - Method in interface javax.json.JsonNumber

Returns true if this JSON number is a integral number.

isIntegralNumber() - Method in interface javax.json.stream.JsonParser

Returns true if the JSON number at the current parser state is a integral number.

isInterceptorBinding(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeanManager

Test the given annotation type to determine if it is an interceptor binding type .

isInView() - Method in class javax.faces.component.UIComponent

Return true if this component is within the view hierarchy otherwise false

isInView() - Method in class javax.faces.component.UIViewRoot

Override superclass method to always return true because a UIViewRoot is defined to always be in a view.

isIsmap() - Method in class javax.faces.component.html.HtmlGraphicImage

Return the value of the ismap property.

isItemDisabled() - Method in class javax.faces.component.UISelectItem

Return the disabled setting for this selection item.

isItemEscaped() - Method in class javax.faces.component.UISelectItem

Return the escape setting for the label of this selection item.

isJoinedToTransaction() - Method in interface javax.persistence.EntityManager

Determine whether the entity manager is joined to the current transaction.

isKeepMessages() - Method in class javax.faces.context.Flash

Return the value of this JavaBeans property for the flash for this session.

isKeepMessages() - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Flash.isKeepMessages() on the wrapped Flash object.

isLambdaArgument(String) - Method in class javax.el.ELContext

Inquires if the name is a LambdaArgument

isLast() - Method in interface javax.servlet.jsp.jstl.core.LoopTagStatus

Returns information about whether the current round of the iteration is the last one.

isLimitedByMaxRows() - Method in interface javax.servlet.jsp.jstl.sql.Result

Returns true if the query was limited by a maximum row setting

isListenerForSource(Object) - Method in class javax.faces.context.ExceptionHandler

This method must return true if and only if this listener instance is interested in receiving events from the instance referenced by the source parameter.

isListenerForSource(Object) - Method in class javax.faces.context.ExceptionHandlerWrapper

The default behavior of this method is to call ExceptionHandler.isListenerForSource(Object) on the wrapped ExceptionHandler object.

isListenerForSource(Object) - Method in interface javax.faces.event.SystemEventListener

This method must return true if and only if this listener instance is interested in receiving events from the instance referenced by the source parameter.

isLiteral() - Method in class javax.faces.view.facelets.TagAttribute

If this TagAttribute is literal (not #{..} or ${..})

isLiteralText() - Method in class javax.el.Expression

Returns whether this expression was created from only literal text.

isLiteralText() - Method in class javax.servlet.jsp.jstl.core.IndexedValueExpression

isLiteralText() - Method in class javax.servlet.jsp.jstl.core.IteratedValueExpression

isLoaded(Object, String) - Method in interface javax.persistence.PersistenceUnitUtil

Determine the load state of a given persistent attribute of an entity belonging to the persistence unit.

isLoaded(Object) - Method in interface javax.persistence.PersistenceUnitUtil

Determine the load state of an entity belonging to the persistence unit.

isLoaded(Object, String) - Method in interface javax.persistence.PersistenceUtil

Determine the load state of a given persistent attribute.

isLoaded(Object) - Method in interface javax.persistence.PersistenceUtil

Determine the load state of an entity.

isLoaded(Object) - Method in interface javax.persistence.spi.ProviderUtil

If the provider determines that the entity has been provided by itself and that the state of all attributes for which FetchType.EAGER has been specified have been loaded, this method returns LoadState.LOADED.

isLoadedWithoutReference(Object, String) - Method in interface javax.persistence.spi.ProviderUtil

If the provider determines that the entity has been provided by itself and that the state of the specified attribute has been loaded, this method returns LoadState.LOADED.

isLoadedWithReference(Object, String) - Method in interface javax.persistence.spi.ProviderUtil

If the provider determines that the entity has been provided by itself and that the state of the specified attribute has been loaded, this method returns LoadState.LOADED.

isLocaleSupported(Locale) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Reports if this implementation supports the designated locale.

isLocalValueSet() - Method in interface javax.faces.component.EditableValueHolder

Return the "local value set" state for this component.

isLocalValueSet() - Method in class javax.faces.component.UIInput

Return the "local value set" state for this component.

isMandatory() - Method in class javax.security.auth.message.MessagePolicy

Get the MessagePolicy modifier.

isMember(Expression<E>, Expression<C>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate that tests whether an element is a member of a collection.

isMember(E, Expression<C>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate that tests whether an element is a member of a collection.

isMimeType(String) - Method in class javax.mail.internet.MimeBodyPart

Is this Part of the specified MIME type? This method compares only the primaryType and subType.

isMimeType(String) - Method in class javax.mail.internet.MimeMessage

Is this Part of the specified MIME type? This method compares only the primaryType and subType.

isMimeType(String) - Method in interface javax.mail.Part

Is this Part of the specified MIME type? This method compares only the primaryType and subType.

isMTOMEnabled() - Method in interface javax.xml.ws.soap.SOAPBinding

Returns true if the use of MTOM is enabled.

isMustRevalidate() - Method in class javax.ws.rs.core.CacheControl

Corresponds to the must-revalidate cache control directive.

isNameResolved(String) - Method in class javax.el.BeanNameResolver

Returns whether the given name is resolved by the BeanNameResolver

isNegated() - Method in interface javax.persistence.criteria.Predicate

Whether the predicate has been created from another predicate by applying the Predicate.not() method or the CriteriaBuilder.not() method.

isNew(UIComponent) - Static method in class javax.faces.view.facelets.ComponentHandler

Determine if the passed component is not null and if it's new to the tree.

isNew() - Method in interface javax.servlet.http.HttpSession

Returns true if the client does not yet know about the session or if the client chooses not to join the session.

isNil() - Method in class javax.xml.bind.JAXBElement

Returns true iff this element instance content model is nil.

isNoCache() - Method in class javax.ws.rs.core.CacheControl

Corresponds to the no-cache cache control directive.

isNormalScope(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeanManager

Test the given annotation type to determine if it is a normal scope type.

isNoSelectionOption() - Method in class javax.faces.component.UISelectItem

Return the value of the noSelectionOption property.

isNoSelectionOption() - Method in class javax.faces.model.SelectItem

Return the value of the noSelectionOption property.

isNoStore() - Method in class javax.ws.rs.core.CacheControl

Corresponds to the no-store cache control directive.

isNotEmpty(Expression<C>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate that tests whether a collection is not empty.

isNotMember(Expression<E>, Expression<C>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate that tests whether an element is not a member of a collection.

isNotMember(E, Expression<C>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate that tests whether an element is not a member of a collection.

isNotNull(Expression<?>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate to test whether the expression is not null.

isNotNull() - Method in interface javax.persistence.criteria.Expression

Create a predicate to test whether the expression is not null.

isNoTransform() - Method in class javax.ws.rs.core.CacheControl

Corresponds to the no-transform cache control directive.

isNull(int) - Method in interface javax.json.JsonArray

Returns true if the value at the specified location in this array is JsonValue.NULL.

isNull(String) - Method in interface javax.json.JsonObject

Returns true if the associated value for the specified name is JsonValue.NULL.

isNull(Expression<?>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate to test whether the expression is null.

isNull() - Method in interface javax.persistence.criteria.Expression

Create a predicate to test whether the expression is null.

isNullable() - Method in interface javax.enterprise.inject.spi.Bean

Determines if Contextual.create(CreationalContext) sometimes return a null value.

isOK() - Method in class javax.websocket.SendResult

Determines if this result is ok or not.

isOnPostback() - Method in class javax.faces.component.UIViewAction

If true this component will operate on postback.

isOpaque() - Method in interface javax.xml.registry.infomodel.ExtrinsicObject

Determines whether the ExtrinsicObject is opaque (not readable) by the registry operator.

isOpen() - Method in class javax.mail.Folder

Indicates whether this Folder is in the 'open' state.

isOpen() - Method in interface javax.persistence.EntityManager

Determine whether the entity manager is open.

isOpen() - Method in interface javax.persistence.EntityManagerFactory

Indicates whether the factory is open.

isOpen() - Method in interface javax.websocket.Session

Return true if and only if the underlying socket is open.

isOptional() - Method in interface javax.persistence.metamodel.SingularAttribute

Can the attribute be null.

isParameterAndReturnSpecRequired(QName) - Method in interface javax.xml.rpc.Call

Indicates whether addParameter and setReturnType methods are to be invoked to specify the parameter and return type specification for a specific operation.

isParametersProvided() - Method in class javax.el.MethodExpression

Return whether this MethodExpression was created with parameters.

isParmetersProvided() - Method in class javax.el.MethodExpression

Deprecated.

isPartialRequest() - Method in class javax.faces.context.PartialViewContext

Return true PartialViewContext.isAjaxRequest() returns true or if the request header Faces-Request is present with the value partial/process.

isPartialRequest() - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.isPartialRequest() on the wrapped PartialViewContext object.

isPartialResponse() - Method in interface javax.xml.registry.BulkResponse

Determines whether the response is a partial response due to large result set.

isPassivatingScope(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeanManager

Test the given annotation type to determine if it is a passivating scope type.

isPermanent() - Method in exception javax.servlet.UnavailableException

Returns a boolean indicating whether the servlet is permanently unavailable.

isPersistent() - Method in interface javax.ejb.Timer

Return whether this timer has persistent semantics.

isPersistent() - Method in class javax.ejb.TimerConfig

Return whether the timer is persistent.

isPersistent() - Method in interface javax.security.auth.message.config.AuthConfigFactory.RegistrationContext

Get the persisted status from the registration context.

isPostback() - Method in class javax.faces.context.FacesContext

This utility method simply returns the result of ResponseStateManager.isPostback(FacesContext).

isPostback() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.isPostback() on the wrapped FacesContext object.

isPostback(FacesContext) - Method in class javax.faces.render.ResponseStateManager

Return true if the current request is a postback.

isPrependId() - Method in class javax.faces.component.UIForm

The prependId flag.

isPrivate() - Method in class javax.ws.rs.core.CacheControl

Corresponds to the private cache control directive.

isProcessingBroadcast(FacesContext) - Static method in class javax.faces.component.UIViewAction

Returns true if the current request processing lifecycle is in the midst of processing the broadcast of an event queued during a call to UIViewAction.decode(javax.faces.context.FacesContext).

isProcessingEvents() - Method in class javax.faces.context.FacesContext

Returns a flag indicating whether or not the runtime should publish events when asked to do so.

isProcessingEvents() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.isProcessingEvents() on the wrapped FacesContext object.

isProjectStage(ProjectStage) - Method in class javax.faces.context.FacesContext

Return true if the current ProjectStage as returned by the Application instance is equal to stage, otherwise return false

isProjectStage(ProjectStage) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.isProjectStage(javax.faces.application.ProjectStage) on the wrapped FacesContext object.

isPropertyResolved() - Method in class javax.el.ELContext

Returns whether an ELResolver has successfully resolved a given (base, property) pair.

isProtected() - Method in interface javax.security.auth.message.config.AuthConfig

Used to determine whether the authentication context configuration object encapsulates any protected authentication contexts.

isProxyRevalidate() - Method in class javax.ws.rs.core.CacheControl

Corresponds to the proxy-revalidate cache control directive.

isPublished() - Method in class javax.xml.ws.Endpoint

Returns true if the endpoint is in the published state.

isQualifier(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeanManager

Test the given annotation type to determine if it is a qualifier type.

isReachable(Object, Path.Node, Class<?>, Path, ElementType) - Method in interface javax.validation.TraversableResolver

Determines if the Bean Validation provider is allowed to reach the property state.

isReadable(Class<?>, Type, Annotation[], MediaType) - Method in interface javax.ws.rs.ext.MessageBodyReader

Ascertain if the MessageBodyReader can produce an instance of a particular type.

isReadOnly(ELContext, Object, Object) - Method in class javax.el.ArrayELResolver

If the base object is a Java language array, returns whether a call to ArrayELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

isReadOnly(ELContext, Object, Object) - Method in class javax.el.BeanELResolver

If the base object is not null, returns whether a call to BeanELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

isReadOnly(ELContext, Object, Object) - Method in class javax.el.BeanNameELResolver

If the base is null and the property is a name resolvable by the BeanNameResolver, attempts to determine if the bean is writable.

isReadOnly(String) - Method in class javax.el.BeanNameResolver

Indicates if the bean of the given name is read-only or writable

isReadOnly(ELContext, Object, Object) - Method in class javax.el.CompositeELResolver

For a given base and property, attempts to determine whether a call to CompositeELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

isReadOnly(ELContext, Object, Object) - Method in class javax.el.ELResolver

For a given base and property, attempts to determine whether a call to ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

isReadOnly(ELContext, Object, Object) - Method in class javax.el.ListELResolver

If the base object is a list, returns whether a call to ListELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

isReadOnly(ELContext, Object, Object) - Method in class javax.el.MapELResolver

If the base object is a map, returns whether a call to MapELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

isReadOnly(ELContext, Object, Object) - Method in class javax.el.ResourceBundleELResolver

If the base object is not null and an instanceof ResourceBundle, return true.

isReadOnly(ELContext, Object, Object) - Method in class javax.el.StaticFieldELResolver

Inquires whether the static field is writable.

isReadOnly(ELContext, Object, Object) - Method in class javax.el.TypeConverter

isReadOnly(ELContext) - Method in class javax.el.ValueExpression

Evaluates the expression relative to the provided context, and returns true if a call to ValueExpression.setValue(javax.el.ELContext, java.lang.Object) will always fail.

isReadonly() - Method in class javax.faces.component.html.HtmlCommandButton

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlInputFile

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlInputText

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlInputTextarea

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlSelectManyListbox

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlSelectManyMenu

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlSelectOneListbox

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlSelectOneMenu

Return the value of the readonly property.

isReadonly() - Method in class javax.faces.component.html.HtmlSelectOneRadio

Return the value of the readonly property.

isReadOnly(Object, Object) - Method in class javax.faces.el.PropertyResolver

Deprecated.

Checks if the specified property is read-only.

isReadOnly(Object, int) - Method in class javax.faces.el.PropertyResolver

Deprecated.

Checks if the specified index is read-only.

isReadOnly(FacesContext) - Method in class javax.faces.el.ValueBinding

Deprecated.

Return true if the specified property of the specified property is known to be immutable; otherwise, return false.

isReadOnly(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver

If the base object is null, and the property matches the name of a JSP implicit object, returns true to indicate that implicit objects cannot be overwritten.

isReadOnly(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver

If the base object is null, returns false to indicate that scoped attributes are never read-only.

isReadOnly(ELContext) - Method in class javax.servlet.jsp.jstl.core.IndexedValueExpression

isReadOnly(ELContext) - Method in class javax.servlet.jsp.jstl.core.IteratedValueExpression

isReady() - Method in class javax.servlet.ServletInputStream

Returns true if data can be read without blocking else returns false.

isReady() - Method in class javax.servlet.ServletOutputStream

This method can be used to determine if data can be written without blocking.

isReadyToCheckpoint() - Method in class javax.batch.api.chunk.AbstractCheckpointAlgorithm

Implement logic in this method to decide if a checkpoint should be taken now.

isReadyToCheckpoint() - Method in interface javax.batch.api.chunk.CheckpointAlgorithm

The isReadyToCheckpoint method is invoked by the batch runtime after each item processed to determine if now is the time to checkpoint the current chunk.

isRedeploySupported() - Method in interface javax.enterprise.deploy.spi.DeploymentManager

This method designates whether this platform vendor provides application redeployment functionality.

isRedirect() - Method in class javax.faces.application.NavigationCase

Return the <redirect> value for this <navigation-case>.

isRedirect() - Method in class javax.faces.application.NavigationCaseWrapper

isRedirect() - Method in class javax.faces.context.Flash

Return the value of this property for the flash for this session.

isRedirect() - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Flash.isRedirect() on the wrapped Flash object.

isRedisplay() - Method in class javax.faces.component.html.HtmlInputSecret

Return the value of the redisplay property.

isRedisplay() - Method in class javax.faces.component.UIMessage

isRedisplay() - Method in class javax.faces.component.UIMessages

isRegistered(ObjectName) - Method in interface javax.management.j2ee.Management

Checks whether a managed object, identified by its object name, is already registered with the MEJB.

isRegistered(Object) - Method in interface javax.ws.rs.core.Configuration

Check if a particular JAX-RS component instance (such as providers or features) has been previously registered in the runtime configuration context.

isRegistered(Class<?>) - Method in interface javax.ws.rs.core.Configuration

Check if a JAX-RS component of the supplied componentClass class has been previously registered in the runtime configuration context.

isRegistered(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping

Checks whether or not type mapping between specified XML type and Java type is registered.

isReleased() - Method in class javax.faces.context.FacesContext

Return a flag indicating if the resources associated with this FacesContext instance have been released.

isReleased() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.isReleased() on the wrapped FacesContext object.

isRemoved() - Method in class javax.mail.event.MessageCountEvent

Indicates whether this event is the result of an explicit expunge by this client, or due to an expunge from external sources.

isRemoveEvent() - Method in class javax.enterprise.deploy.model.XpathEvent

Is this a remove event?

isRenderAll() - Method in class javax.faces.context.PartialViewContext

Return true if PartialViewContext.isAjaxRequest() returns true and PartialViewContext.PARTIAL_RENDER_PARAM_NAME is present in the current request with the value PartialViewContext.ALL_PARTIAL_PHASE_CLIENT_IDS.

isRenderAll() - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.isRenderAll() on the wrapped PartialViewContext object.

isRendered() - Method in class javax.faces.application.FacesMessage

isRendered() - Method in class javax.faces.component.UIComponent

Return true if this component (and its children) should be rendered during the Render Response phase of the request processing lifecycle.

isRendered() - Method in class javax.faces.component.UIComponentBase

isRendered() - Method in class javax.faces.component.UIViewAction

Return true if this component should take the actions specified in the UIViewAction.decode(javax.faces.context.FacesContext) method.

isReportAsSingleViolation() - Method in interface javax.validation.metadata.ConstraintDescriptor

isRequestedSessionIdFromCookie() - Method in interface javax.servlet.http.HttpServletRequest

Checks whether the requested session ID came in as a cookie.

isRequestedSessionIdFromCookie() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return isRequestedSessionIdFromCookie() on the wrapped request object.

isRequestedSessionIdFromURL() - Method in interface javax.servlet.http.HttpServletRequest

Checks whether the requested session ID came in as part of the request URL.

isRequestedSessionIdFromUrl() - Method in interface javax.servlet.http.HttpServletRequest

Deprecated.
As of Version 2.1 of the Java Servlet API, use HttpServletRequest.isRequestedSessionIdFromURL() instead.

isRequestedSessionIdFromURL() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return isRequestedSessionIdFromURL() on the wrapped request object.

isRequestedSessionIdFromUrl() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return isRequestedSessionIdFromUrl() on the wrapped request object.

isRequestedSessionIdValid() - Method in interface javax.servlet.http.HttpServletRequest

Checks whether the requested session ID is still valid.

isRequestedSessionIdValid() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return isRequestedSessionIdValid() on the wrapped request object.

isRequired() - Method in interface javax.faces.component.EditableValueHolder

Return the "required field" state for this component.

isRequired() - Method in class javax.faces.component.UIInput

Return the "required field" state for this component.

isRequired() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

Whether this attribute is required.

isRequired() - Method in class javax.xml.ws.soap.AddressingFeature

If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.

isResetValues() - Method in class javax.faces.component.behavior.AjaxBehavior

Return the resetValues status of this behavior.

isResetValues() - Method in class javax.faces.context.PartialViewContext

Return true if the incoming request has a parameter named by the value of PartialViewContext.RESET_VALUES_PARAM_NAME and that value is true.

isResetValues() - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.isResetValues() on the wrapped PartialViewContext object.

isResetValuesSet() - Method in class javax.faces.component.behavior.AjaxBehavior

Tests whether the resetValues attribute is specified.

isResourceRequest(FacesContext) - Method in class javax.faces.application.ResourceHandler

Return true if the current request is a resource request.

isResourceRequest(FacesContext) - Method in class javax.faces.application.ResourceHandlerWrapper

The default behavior of this method is to call ResourceHandler.isResourceRequest(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.

isResourceURL(String) - Method in class javax.faces.application.ResourceHandler

Return true if the argument url contains the string given by the value of the constant ResourceHandler.RESOURCE_IDENTIFIER, false otherwise.

isResourceURL(String) - Method in class javax.faces.application.ResourceHandlerWrapper

The default behavior of this method is to call ResourceHandler.isResourceURL(java.lang.String) on the wrapped ResourceHandler object.

isResponseCommitted() - Method in class javax.faces.context.ExternalContext

Check if the current response has been committed.

isResponseCommitted() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.isResponseCommitted() on the wrapped ExternalContext object.

isRowAvailable() - Method in class javax.faces.component.UIData

Return a flag indicating whether there is rowData available at the current rowIndex.

isRowAvailable() - Method in class javax.faces.model.ArrayDataModel

Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array.

isRowAvailable() - Method in class javax.faces.model.CollectionDataModel

Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the size of the list.

isRowAvailable() - Method in class javax.faces.model.DataModel

Return a flag indicating whether there is rowData available at the current rowIndex.

isRowAvailable() - Method in class javax.faces.model.ListDataModel

Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the size of the list.

isRowAvailable() - Method in class javax.faces.model.ResultDataModel

Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array returned by calling getRows() on the underlying Result.

isRowAvailable() - Method in class javax.faces.model.ResultSetDataModel

Return true if there is wrappedData available, and the result of calling absolute() on the underlying ResultSet, passing the current value of rowIndex plus one (to account for the fact that ResultSet uses one-relative indexing), returns true.

isRowAvailable() - Method in class javax.faces.model.ScalarDataModel

Return true if there is wrappedData available, and the current value of rowIndex is zero.

isRowHeader() - Method in class javax.faces.component.html.HtmlColumn

Return the value of the rowHeader property.

isRowStatePreserved() - Method in class javax.faces.component.UIData

Return the value of the rowStatePreserved JavaBeans property.

isRunning() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus

A convience method to report if the operation is in the running state.

isSameRM(XAResource) - Method in interface javax.transaction.xa.XAResource

This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.

isSavingStateInClient(FacesContext) - Method in class javax.faces.application.StateManager

isSavingStateInClient(FacesContext) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.isSavingStateInClient(javax.faces.context.FacesContext) on the wrapped StateManager object.

isScope(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeanManager

Test the given annotation type to determine if it is a scope type.

isSecure() - Method in class javax.faces.context.ExternalContext

Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.

isSecure() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.isSecure() on the wrapped ExternalContext object.

isSecure() - Method in interface javax.servlet.ServletRequest

Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.

isSecure() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return isSecure() on the wrapped request object.

isSecure() - Method in interface javax.servlet.SessionCookieConfig

Checks if the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired will be marked as secure even if the request that initiated the corresponding session is using plain HTTP instead of HTTPS.

isSecure() - Method in interface javax.websocket.Session

Return true if and only if the underlying socket is using a secure transport.

isSecure() - Method in class javax.ws.rs.core.NewCookie

Whether the cookie will only be sent over a secure connection.

isSecure() - Method in interface javax.ws.rs.core.SecurityContext

Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.

isSelected() - Method in class javax.faces.component.UISelectBoolean

Return the local value of the selected state of this component.

isSession() - Method in interface javax.ejb.EJBMetaData

Test if the enterprise bean's type is "session".

isSet(Flags.Flag) - Method in class javax.mail.internet.MimeMessage

Check whether the flag specified in the flag argument is set in this message.

isSet(Flags.Flag) - Method in class javax.mail.Message

Check whether the flag specified in the flag argument is set in this message.

isShowDetail() - Method in class javax.faces.component.UIMessage

Return the flag indicating whether the detail property of the associated message(s) should be displayed.

isShowDetail() - Method in class javax.faces.component.UIMessages

Return the flag indicating whether the detail property of the associated message(s) should be displayed.

isShowSummary() - Method in class javax.faces.component.UIMessage

Return the flag indicating whether the summary property of the associated message(s) should be displayed.

isShowSummary() - Method in class javax.faces.component.UIMessages

Return the flag indicating whether the summary property of the associated message(s) should be displayed.

isShutdown() - Method in interface javax.enterprise.concurrent.ManageableThread

This method is used by the application component provider to check whether a thread created by the newThread method of ManagedThreadFactory has been marked for shut down.

isStateless(FacesContext, String) - Method in class javax.faces.render.ResponseStateManager

If the preceding call to ResponseStateManager.writeState(javax.faces.context.FacesContext, java.lang.Object) was stateless, return true.

isStatelessSession() - Method in interface javax.ejb.EJBMetaData

Test if the enterprise bean's type is "stateless session".

isStatic() - Method in interface javax.enterprise.inject.spi.AnnotatedMember

Determines if the member is static.

isStereotype(Class<? extends Annotation>) - Method in interface javax.enterprise.inject.spi.BeanManager

Test the given annotation type to determine if it is a stereotype.

isStopSupported() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject

Tests whether the vendor supports a stop opertation for deployment activities.

isSubmitted() - Method in class javax.faces.component.UIForm

Returns the current value of the submitted property.

isSubscribed() - Method in class javax.mail.Folder

Returns true if this Folder is subscribed.

isSuppressed() - Method in class javax.faces.webapp.UIComponentTag

Deprecated.

isSuspended() - Method in interface javax.ws.rs.container.AsyncResponse

Check if the asynchronous response instance is in a suspended state.

isSynchronous() - Method in interface javax.xml.registry.Connection

Indicates whether a client uses synchronous communication with JAXR provider or not.

isTargetInstanceOf(Class) - Method in class javax.faces.view.facelets.MetadataTarget

Return true if the target for this metadata element is an instance of the argument type.

isTooltip() - Method in class javax.faces.component.html.HtmlMessage

Return the value of the tooltip property.

isTooltip() - Method in class javax.faces.component.html.HtmlMessages

Return the value of the tooltip property.

isTransactional() - Method in interface javax.management.j2ee.statistics.JMSConnectionStats

Returns the transactional state of this JMS connection.

isTransient() - Method in interface javax.enterprise.context.Conversation

Determine if the conversation is marked transient or long-running.

isTransient() - Method in interface javax.enterprise.inject.spi.InjectionPoint

Determines if the injection is a transient field.

isTransient() - Method in class javax.faces.component.behavior.BehaviorBase

Implementation of StateHolder.isTransient().

isTransient() - Method in interface javax.faces.component.StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

isTransient() - Method in class javax.faces.component.UIComponentBase

isTransient() - Method in class javax.faces.convert.DateTimeConverter

isTransient() - Method in class javax.faces.convert.EnumConverter

isTransient() - Method in class javax.faces.convert.NumberConverter

isTransient() - Method in class javax.faces.event.MethodExpressionActionListener

isTransient() - Method in class javax.faces.event.MethodExpressionValueChangeListener

isTransient() - Method in class javax.faces.validator.BeanValidator

isTransient() - Method in class javax.faces.validator.DoubleRangeValidator

isTransient() - Method in class javax.faces.validator.LengthValidator

isTransient() - Method in class javax.faces.validator.LongRangeValidator

isTransient() - Method in class javax.faces.validator.MethodExpressionValidator

isTransient() - Method in class javax.faces.validator.RegexValidator

isTrue(Expression<Boolean>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate testing for a true value.

isTypeSubstituted() - Method in class javax.xml.bind.JAXBElement

Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.

isUnsatisfied() - Method in interface javax.enterprise.inject.Instance

Determines if there is no bean that matches the required type and qualifiers and is eligible for injection into the class into which the parent Instance was injected.

isUserInRole(String) - Method in class javax.faces.context.ExternalContext

Return true if the currently authenticated user is included in the specified role.

isUserInRole(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.isUserInRole(String) on the wrapped ExternalContext object.

isUserInRole(String) - Method in interface javax.servlet.http.HttpServletRequest

Returns a boolean indicating whether the authenticated user is included in the specified logical "role".

isUserInRole(String) - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to return isUserInRole(String role) on the wrapped request object.

isUserInRole(String) - Method in interface javax.websocket.server.HandshakeRequest

Checks whether the current user is in the given role.

isUserInRole(String) - Method in interface javax.ws.rs.core.SecurityContext

Returns a boolean indicating whether the authenticated user is included in the specified logical "role".

isUserInRole(String) - Method in interface javax.xml.rpc.server.ServletEndpointContext

Returns a boolean indicating whether the authenticated user for the current method invocation on the endpoint instance is included in the specified logical "role".

isUserInRole(String) - Method in class javax.xml.ws.spi.http.HttpExchange

Indicates whether an authenticated user is included in the specified logical "role".

isUserInRole(String) - Method in interface javax.xml.ws.WebServiceContext

Returns a boolean indicating whether the authenticated user is included in the specified logical role.

isValid() - Method in interface javax.faces.component.EditableValueHolder

Return a flag indicating whether the local value of this component is valid (no conversion error has occurred).

isValid() - Method in class javax.faces.component.UIInput

isValid(TagData) - Method in class javax.servlet.jsp.tagext.TagExtraInfo

Translation-time validation of the attributes.

isValid(TagData) - Method in class javax.servlet.jsp.tagext.TagInfo

Translation-time validation of the attributes.

isValid(T, ConstraintValidatorContext) - Method in interface javax.validation.ConstraintValidator

Implements the validation logic.

isValidating() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.

isValidating() - Method in interface javax.xml.bind.Unmarshaller

Deprecated.
since JAXB2.0, please see Unmarshaller.getSchema()

isValidationFailed() - Method in class javax.faces.context.FacesContext

Return true if the validationFailed() method has been called for the current request.

isValidationFailed() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.isValidationFailed() on the wrapped FacesContext object.

isValueReference(String) - Static method in class javax.faces.webapp.UIComponentTag

Deprecated.

Return true if the specified value conforms to the syntax requirements of a value binding expression.

isVersion() - Method in interface javax.persistence.metamodel.SingularAttribute

Is the attribute a version attribute.

isViewMetadataFaceletCached(URL) - Method in class javax.faces.view.facelets.FaceletCache

Determines whether a cached View Metadata Facelet instance exists for this URL.

isVisitable(VisitContext) - Method in class javax.faces.component.UIComponent

Return true if this component should be visited, false otherwise.

isWeak() - Method in class javax.ws.rs.core.EntityTag

Check the strength of an EntityTag.

isWhiteSpace(char) - Static method in class javax.xml.bind.annotation.adapters.CollapsedStringAdapter

returns true if the specified char is a white space character.

isWhiteSpaceExceptSpace(char) - Static method in class javax.xml.bind.annotation.adapters.NormalizedStringAdapter

Returns true if the specified char is a white space character but not 0x20.

isWildcardSubtype() - Method in class javax.ws.rs.core.MediaType

Checks if the subtype is a wildcard.

isWildcardType() - Method in class javax.ws.rs.core.MediaType

Checks if the primary type is a wildcard.

isWrapperFor(ServletRequest) - Method in class javax.servlet.ServletRequestWrapper

Checks (recursively) if this ServletRequestWrapper wraps the given ServletRequest instance.

isWrapperFor(Class<?>) - Method in class javax.servlet.ServletRequestWrapper

Checks (recursively) if this ServletRequestWrapper wraps a ServletRequest of the given class type.

isWrapperFor(ServletResponse) - Method in class javax.servlet.ServletResponseWrapper

Checks (recursively) if this ServletResponseWrapper wraps the given ServletResponse instance.

isWrapperFor(Class<?>) - Method in class javax.servlet.ServletResponseWrapper

Checks (recursively) if this ServletResponseWrapper wraps a ServletResponse of the given class type.

isWriteable(Class<?>, Type, Annotation[], MediaType) - Method in interface javax.ws.rs.ext.MessageBodyWriter

Ascertain if the MessageBodyWriter supports a particular type.

isXOPPackage() - Method in class javax.xml.bind.attachment.AttachmentMarshaller

Read-only property that returns true if JAXB marshaller should enable XOP creation.

isXOPPackage() - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller

Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.

itemExists(String) - Method in interface javax.jms.MapMessage

Indicates whether an item exists in this MapMessage object.

itemId - Variable in class javax.servlet.jsp.jstl.core.LoopTagSupport

Attribute-exposing control

ItemProcessListener - Interface in javax.batch.api.chunk.listener

ItemProcessListener intercepts item processing.

ItemProcessor - Interface in javax.batch.api.chunk

ItemProcessor is used in chunk processing to operate on an input item and produce an output item.

ItemReader - Interface in javax.batch.api.chunk

ItemReader defines the batch artifact that reads items for chunk processing.

ItemReadListener - Interface in javax.batch.api.chunk.listener

ItemReadListener intercepts item reader processing.

ItemWriteListener - Interface in javax.batch.api.chunk.listener

ItemWriteListener intercepts item writer processing.

ItemWriter - Interface in javax.batch.api.chunk

ItemWriter defines the batch artifact that writes to a list of items for chunk processing.

IteratedExpression - Class in javax.servlet.jsp.jstl.core

IteratedExpression(ValueExpression, String) - Constructor for class javax.servlet.jsp.jstl.core.IteratedExpression

iteratedExpression - Variable in class javax.servlet.jsp.jstl.core.IteratedValueExpression

IteratedValueExpression - Class in javax.servlet.jsp.jstl.core

IteratedValueExpression(IteratedExpression, int) - Constructor for class javax.servlet.jsp.jstl.core.IteratedValueExpression

IterationTag - Interface in javax.servlet.jsp.tagext

The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.

iterator() - Method in class javax.faces.model.DataModel

Return a read-only Iterator over the row data for this model.

J

J2eeApplicationObject - Interface in javax.enterprise.deploy.model

J2eeApplicationObject is an interface that represents a Java EE application (EAR); it maintains a DeployableObject for each module in the archive.

javaCharset(String) - Static method in class javax.mail.internet.MimeUtility

Convert a MIME charset name into a valid Java charset name.

JavaMailStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JavaMail resource.

javax.annotation - package javax.annotation

This package defines the common annotations.

javax.annotation.security - package javax.annotation.security

This package contains the security common annotations.

javax.annotation.sql - package javax.annotation.sql

javax.batch.api - package javax.batch.api

Provides APIs used by Batch artifacts.

javax.batch.api.chunk - package javax.batch.api.chunk

Provides APIs used by artifacts in a Batch chunk step.

javax.batch.api.chunk.listener - package javax.batch.api.chunk.listener

Provides APIs defining listener artifacts for a Batch chunk step.

javax.batch.api.listener - package javax.batch.api.listener

Provides APIs defining Batch job-level and step-level listener artifacts.

javax.batch.api.partition - package javax.batch.api.partition

Provides APIs for artifacts specific to a Batch partitioned step.

javax.batch.operations - package javax.batch.operations

Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.

javax.batch.runtime - package javax.batch.runtime

Provides APIs for viewing the detailed outcomes and metrics of Batch job executions.

javax.batch.runtime.context - package javax.batch.runtime.context

Provides APIs for context classes allowing data sharing across Batch artifacts within a job instance and within a step.

javax.decorator - package javax.decorator

Annotations relating to decorators.

javax.ejb - package javax.ejb

Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

javax.ejb.embeddable - package javax.ejb.embeddable

Defines the classes for the EJB Embeddable API.

javax.ejb.spi - package javax.ejb.spi

Defines interfaces that are implemented by the EJB container.

javax.el - package javax.el

Provides the API for the Unified Expression Language 3.0

javax.enterprise.concurrent - package javax.enterprise.concurrent

Classes and interfaces for concurrent programming in Java EE™ applications.

javax.enterprise.context - package javax.enterprise.context

Annotations and interfaces relating to scopes and contexts.

javax.enterprise.context.spi - package javax.enterprise.context.spi

The custom context SPI.

javax.enterprise.deploy.model - package javax.enterprise.deploy.model

Provides Tool Vendor implementation classes.

javax.enterprise.deploy.model.exceptions - package javax.enterprise.deploy.model.exceptions

Provides Tool Vendor exception implementation classes.

javax.enterprise.deploy.shared - package javax.enterprise.deploy.shared

Provides shared objects for Tool Vendor and Product Vendor implementation classes.

javax.enterprise.deploy.shared.factories - package javax.enterprise.deploy.shared.factories

Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.

javax.enterprise.deploy.spi - package javax.enterprise.deploy.spi

Provides J2EE Product Vendor implementation classes.

javax.enterprise.deploy.spi.exceptions - package javax.enterprise.deploy.spi.exceptions

Provides J2EE Product Vendor deployment exception implementation classes.

javax.enterprise.deploy.spi.factories - package javax.enterprise.deploy.spi.factories

Provides J2EE Product Vendor deployment factory implementation classes.

javax.enterprise.deploy.spi.status - package javax.enterprise.deploy.spi.status

Provides J2EE Product Vendor deployment status implementation classes.

javax.enterprise.event - package javax.enterprise.event

Annotations and interfaces relating to events.

javax.enterprise.inject - package javax.enterprise.inject

Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.

javax.enterprise.inject.spi - package javax.enterprise.inject.spi

The portable extension integration SPI.

javax.enterprise.util - package javax.enterprise.util

Contains shared, general-purpose helper classes and annotations.

javax.faces - package javax.faces

Top level classes for the JavaServer(tm) Faces API.

javax.faces.application - package javax.faces.application

APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

javax.faces.bean - package javax.faces.bean

These javadoc files constitute the “Faces Managed Bean Annotation Specification for Containers Conforming to Servlet 2.5 and Beyond”

javax.faces.component - package javax.faces.component

Fundamental APIs for user interface components.

javax.faces.component.behavior - package javax.faces.component.behavior

APIs for attaching additional behavior to user interface components.

javax.faces.component.html - package javax.faces.component.html

Specialized user interface component classes for HTML.

javax.faces.component.visit - package javax.faces.component.visit

APIs for traversing a user interface component view.

javax.faces.context - package javax.faces.context

Classes and interfaces defining per-request state information.

javax.faces.convert - package javax.faces.convert

Contains classes and interfaces defining converters.

javax.faces.el - package javax.faces.el

DEPRECATED Classes and interfaces for evaluating and processing reference expressions.

javax.faces.event - package javax.faces.event

Interfaces describing events and event listeners, and concrete event implementation classes.

javax.faces.flow - package javax.faces.flow

The runtime API for Faces Flows.

javax.faces.flow.builder - package javax.faces.flow.builder

Classes for declaring a Faces Flow.

javax.faces.lifecycle - package javax.faces.lifecycle

Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.

javax.faces.model - package javax.faces.model

Standard model data beans for JavaServer Faces.

javax.faces.render - package javax.faces.render

Classes and interfaces defining the rendering model.

javax.faces.validator - package javax.faces.validator

Interface defining the validator model, and concrete validator implementation classes.

javax.faces.view - package javax.faces.view

Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.

javax.faces.view.facelets - package javax.faces.view.facelets

This package contains public classes for the Java code API of Facelets.

javax.faces.webapp - package javax.faces.webapp

Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

javax.inject - package javax.inject

This package specifies a means for obtaining objects in such a way as to maximize reusability, testability and maintainability compared to traditional approaches such as constructors, factories, and service locators (e.g., JNDI). This process, known as dependency injection, is beneficial to most nontrivial applications.

javax.interceptor - package javax.interceptor

Contains annotations and interfaces for defining interceptor methods, interceptor classes and for binding interceptor classes to target classes.

javax.jms - package javax.jms

The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

javax.json - package javax.json

Provides an object model API to process JSON.

javax.json.spi - package javax.json.spi

Service Provider Interface (SPI) to plug in implementations for JSON processing objects.

javax.json.stream - package javax.json.stream

Provides a streaming API to parse and generate JSON.

javax.jws - package javax.jws

javax.jws.soap - package javax.jws.soap

javax.mail - package javax.mail

The JavaMailTM API provides classes that model a mail system.

javax.mail.event - package javax.mail.event

Listeners and events for the JavaMail API.

javax.mail.internet - package javax.mail.internet

Classes specific to Internet mail systems.

javax.mail.search - package javax.mail.search

Message search terms for the JavaMail API.

javax.mail.util - package javax.mail.util

JavaMail API utility classes.

javax.management.j2ee - package javax.management.j2ee

Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

javax.management.j2ee.statistics - package javax.management.j2ee.statistics

Provides the standard interfaces for accessing performance data from J2EE managed objects

javax.persistence - package javax.persistence

Java Persistence is the API for the management for persistence and object/relational mapping.

javax.persistence.criteria - package javax.persistence.criteria

Java Persistence Criteria API

javax.persistence.metamodel - package javax.persistence.metamodel

Java Persistence Metamodel API

javax.persistence.spi - package javax.persistence.spi

SPI for Java Persistence providers

javax.resource - package javax.resource

The javax.resource package is the top-level package for the Java EE Connector API specification.

javax.resource.cci - package javax.resource.cci

The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

javax.resource.spi - package javax.resource.spi

The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.

javax.resource.spi.endpoint - package javax.resource.spi.endpoint

This package contains system contracts for service endpoint interactions.

javax.resource.spi.security - package javax.resource.spi.security

The javax.resource.spi.security package contains APIs for the security management contract.

javax.resource.spi.work - package javax.resource.spi.work

This package contains APIs for the Work Management, Generic and Security Work Context contracts.

javax.security.auth.message - package javax.security.auth.message

This package defines the core interfaces of the JSR 196 message authentication SPI.

javax.security.auth.message.callback - package javax.security.auth.message.callback

This package defines callback interfaces that may be used by a pluggable message authentication module to interact with the message processing runtime that invoked the module.

javax.security.auth.message.config - package javax.security.auth.message.config

This package defines the interfaces implemented by JSR 196 compatible configuration systems.

javax.security.auth.message.module - package javax.security.auth.message.module

This package defines the interfaces implemented by JSR 196 compatible authentication modules.

javax.security.jacc - package javax.security.jacc

This package contains the Java Authorization Contract for Containers API

javax.servlet - package javax.servlet

The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

javax.servlet.annotation - package javax.servlet.annotation

The javax.servlet.annotation package contains a number of annotations that allow users to use annotations to declare servlets, filters, listeners and specify the metadata for the declared component.

javax.servlet.descriptor - package javax.servlet.descriptor

Provides programmatic access to a web application's configuration information that was aggregated from the web.xml and web-fragment.xml descriptors.

javax.servlet.http - package javax.servlet.http

The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

javax.servlet.jsp - package javax.servlet.jsp

Classes and interfaces for the Core JSP 2.3 API.

javax.servlet.jsp.el - package javax.servlet.jsp.el

Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.

javax.servlet.jsp.jstl.core - package javax.servlet.jsp.jstl.core

Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).

javax.servlet.jsp.jstl.fmt - package javax.servlet.jsp.jstl.fmt

Classes and interfaces related to the locale sensitive formatting tag library component of the JavaServer Pages Standard Tag Library (JSTL).

javax.servlet.jsp.jstl.sql - package javax.servlet.jsp.jstl.sql

Classes and interfaces related to the sql tag library component of the JavaServer Pages Standard Tag Library (JSTL).

javax.servlet.jsp.jstl.tlv - package javax.servlet.jsp.jstl.tlv

Reusable Tag Library Validator (TLV) classes provided by the JavaServer Pages Standard Tag Library (JSTL).

javax.servlet.jsp.tagext - package javax.servlet.jsp.tagext

Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

javax.transaction - package javax.transaction

Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

javax.transaction.xa - package javax.transaction.xa

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

javax.validation - package javax.validation

Top level package of the Bean Validation API.

javax.validation.bootstrap - package javax.validation.bootstrap

Package containing bootstrap specific objects.

javax.validation.constraints - package javax.validation.constraints

Contains all the Bean Validation provided constraints also called built-in constraints.

javax.validation.constraintvalidation - package javax.validation.constraintvalidation

Package containing constructs specific to constraint validators In particular SupportedValidationTarget is used to refine the validation target of a ConstraintValidator.

javax.validation.executable - package javax.validation.executable

Package related to the control and execution of executable validation.

javax.validation.groups - package javax.validation.groups

A group defines a subset of constraints.

javax.validation.metadata - package javax.validation.metadata

Package containing all objects specifically used and returned by the metadata API.

javax.validation.spi - package javax.validation.spi

Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.

javax.websocket - package javax.websocket

This package contains all the WebSocket APIs common to both the client and server side.

javax.websocket.server - package javax.websocket.server

This package contains all the WebSocket APIs used only by server side applications.

javax.ws.rs - package javax.ws.rs

High-level interfaces and annotations used to create RESTful service resources.

javax.ws.rs.client - package javax.ws.rs.client

The JAX-RS client API

javax.ws.rs.container - package javax.ws.rs.container

Container-specific JAX-RS API.

javax.ws.rs.core - package javax.ws.rs.core

Low-level interfaces and annotations used to create RESTful service resources.

javax.ws.rs.ext - package javax.ws.rs.ext

APIs that provide extensions to the types supported by the JAX-RS API.

javax.xml.bind - package javax.xml.bind

Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

javax.xml.bind.annotation - package javax.xml.bind.annotation

Defines annotations for customizing Java program elements to XML Schema mapping.

javax.xml.bind.annotation.adapters - package javax.xml.bind.annotation.adapters

XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.

javax.xml.bind.attachment - package javax.xml.bind.attachment

This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.

javax.xml.bind.helpers - package javax.xml.bind.helpers

JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

javax.xml.bind.util - package javax.xml.bind.util

Useful client utility classes.

javax.xml.registry - package javax.xml.registry

This package defines APIs to access and programatically interact with metadata registries.

javax.xml.registry.infomodel - package javax.xml.registry.infomodel

This package defines interfaces that define the information model for metadata registries.

javax.xml.rpc - package javax.xml.rpc

This package contains the core JAX-RPC APIs for the client programming model.

javax.xml.rpc.encoding - package javax.xml.rpc.encoding

This package defines APIs for the extensible type mapping framework.

javax.xml.rpc.handler - package javax.xml.rpc.handler

This package defines APIs for SOAP Message Handlers

javax.xml.rpc.handler.soap - package javax.xml.rpc.handler.soap

This package defines APIs for SOAP Message Handlers

javax.xml.rpc.holders - package javax.xml.rpc.holders

This package contains the standard Java Holder classes.

javax.xml.rpc.server - package javax.xml.rpc.server

This package defines APIs for the servlet based JAX-RPC endpoint model.

javax.xml.rpc.soap - package javax.xml.rpc.soap

This package defines APIs specific to the SOAP binding.

javax.xml.soap - package javax.xml.soap

Provides the API for creating and building SOAP messages.

javax.xml.ws - package javax.xml.ws

This package contains the core JAX-WS APIs.

javax.xml.ws.handler - package javax.xml.ws.handler

This package defines APIs for message handlers.

javax.xml.ws.handler.soap - package javax.xml.ws.handler.soap

This package defines APIs for SOAP message handlers.

javax.xml.ws.http - package javax.xml.ws.http

This package defines APIs specific to the HTTP binding.

javax.xml.ws.soap - package javax.xml.ws.soap

This package defines APIs specific to the SOAP binding.

javax.xml.ws.spi - package javax.xml.ws.spi

This package defines SPIs for JAX-WS.

javax.xml.ws.spi.http - package javax.xml.ws.spi.http

Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

javax.xml.ws.wsaddressing - package javax.xml.ws.wsaddressing

This package defines APIs related to WS-Addressing.

JAXB - Class in javax.xml.bind

Class that defines convenience methods for common, simple use of JAXB.

JAXB_CONTEXT_FACTORY - Static variable in class javax.xml.bind.JAXBContext

The name of the property that contains the name of the class capable of creating new JAXBContext objects.

JAXB_ENCODING - Static variable in interface javax.xml.bind.Marshaller

The name of the property used to specify the output encoding in the marshalled XML data.

JAXB_FORMATTED_OUTPUT - Static variable in interface javax.xml.bind.Marshaller

The name of the property used to specify whether or not the marshalled XML data is formatted with linefeeds and indentation.

JAXB_FRAGMENT - Static variable in interface javax.xml.bind.Marshaller

The name of the property used to specify whether or not the marshaller will generate document level events (ie calling startDocument or endDocument).

JAXB_NO_NAMESPACE_SCHEMA_LOCATION - Static variable in interface javax.xml.bind.Marshaller

The name of the property used to specify the xsi:noNamespaceSchemaLocation attribute value to place in the marshalled XML output.

JAXB_SCHEMA_LOCATION - Static variable in interface javax.xml.bind.Marshaller

The name of the property used to specify the xsi:schemaLocation attribute value to place in the marshalled XML output.

JAXBContext - Class in javax.xml.bind

The JAXBContext class provides the client's entry point to the JAXB API.

JAXBContext() - Constructor for class javax.xml.bind.JAXBContext

JAXBElement<T> - Class in javax.xml.bind

JAXB representation of an Xml Element.

JAXBElement(QName, Class<T>, Class, T) - Constructor for class javax.xml.bind.JAXBElement

Construct an xml element instance.

JAXBElement(QName, Class<T>, T) - Constructor for class javax.xml.bind.JAXBElement

Construct an xml element instance.

JAXBElement.GlobalScope - Class in javax.xml.bind

Designates global scope for an xml element.

JAXBElement.GlobalScope() - Constructor for class javax.xml.bind.JAXBElement.GlobalScope

JAXBException - Exception in javax.xml.bind

This is the root exception class for all JAXB exceptions.

JAXBException(String) - Constructor for exception javax.xml.bind.JAXBException

Construct a JAXBException with the specified detail message.

JAXBException(String, String) - Constructor for exception javax.xml.bind.JAXBException

Construct a JAXBException with the specified detail message and vendor specific errorCode.

JAXBException(Throwable) - Constructor for exception javax.xml.bind.JAXBException

Construct a JAXBException with a linkedException.

JAXBException(String, Throwable) - Constructor for exception javax.xml.bind.JAXBException

Construct a JAXBException with the specified detail message and linkedException.

JAXBException(String, String, Throwable) - Constructor for exception javax.xml.bind.JAXBException

Construct a JAXBException with the specified detail message, vendor specific errorCode, and linkedException.

JAXBIntrospector - Class in javax.xml.bind

Provide access to JAXB xml binding data for a JAXB object.

JAXBIntrospector() - Constructor for class javax.xml.bind.JAXBIntrospector

JAXBPermission - Class in javax.xml.bind

This class is for JAXB permissions.

JAXBPermission(String) - Constructor for class javax.xml.bind.JAXBPermission

Creates a new JAXBPermission with the specified name.

JAXBResult - Class in javax.xml.bind.util

JAXP Result implementation that unmarshals a JAXB object.

JAXBResult(JAXBContext) - Constructor for class javax.xml.bind.util.JAXBResult

Creates a new instance that uses the specified JAXBContext to unmarshal.

JAXBResult(Unmarshaller) - Constructor for class javax.xml.bind.util.JAXBResult

Creates a new instance that uses the specified Unmarshaller to unmarshal an object.

JAXBSource - Class in javax.xml.bind.util

JAXP Source implementation that marshals a JAXB-generated object.

JAXBSource(JAXBContext, Object) - Constructor for class javax.xml.bind.util.JAXBSource

Creates a new Source for the given content object.

JAXBSource(Marshaller, Object) - Constructor for class javax.xml.bind.util.JAXBSource

Creates a new Source for the given content object.

JAXRException - Exception in javax.xml.registry

Signals that a JAXR exception has occurred.

JAXRException() - Constructor for exception javax.xml.registry.JAXRException

Constructs a JAXRException object with no reason or embedded Throwable.

JAXRException(String) - Constructor for exception javax.xml.registry.JAXRException

Constructs a JAXRException object with the given String as the reason for the exception being thrown.

JAXRException(String, Throwable) - Constructor for exception javax.xml.registry.JAXRException

Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

JAXRException(Throwable) - Constructor for exception javax.xml.registry.JAXRException

Constructs a JAXRException object initialized with the given Throwable object.

JAXRPCException - Exception in javax.xml.rpc

The javax.xml.rpc.JAXRPCException is thrown from the core JAX-RPC APIs to indicate an exception related to the JAX-RPC runtime mechanisms.

JAXRPCException() - Constructor for exception javax.xml.rpc.JAXRPCException

Constructs a new exception with null as its detail message.

JAXRPCException(String) - Constructor for exception javax.xml.rpc.JAXRPCException

Constructs a new exception with the specified detail message.

JAXRPCException(String, Throwable) - Constructor for exception javax.xml.rpc.JAXRPCException

Constructs a new exception with the specified detail message and cause.

JAXRPCException(Throwable) - Constructor for exception javax.xml.rpc.JAXRPCException

Constructs a new JAXRPCException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

JAXRResponse - Interface in javax.xml.registry

A JAXR requests' response.

JAXRS_DEFAULT_CLIENT_BUILDER_PROPERTY - Static variable in class javax.ws.rs.client.ClientBuilder

Name of the property identifying the ClientBuilder implementation to be returned from ClientBuilder.newBuilder().

JAXRS_RUNTIME_DELEGATE_PROPERTY - Static variable in class javax.ws.rs.ext.RuntimeDelegate

Name of the property identifying the RuntimeDelegate implementation to be returned from RuntimeDelegate.getInstance().

JAXWSPROVIDER_PROPERTY - Static variable in class javax.xml.ws.spi.Provider

A constant representing the property used to lookup the name of a Provider implementation class.

JCAConnectionPoolStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JCA Connection Pool

JCAConnectionStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JCA connection

JCAStats - Interface in javax.management.j2ee.statistics

Specifies statistics provided by a JCA resource

JDBCConnectionPoolStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JDBC connection pool.

JDBCConnectionStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by all (pooled and non-pooled) JDBC connections.

JDBCStats - Interface in javax.management.j2ee.statistics

Statistics provided by a JDBC resource

JMSConnectionFactory - Annotation Type in javax.jms

This annotation may be used to specify the JNDI lookup name of a javax.jms.ConnectionFactory to be used when injecting a javax.jms.JMSContext object.

JMSConnectionFactoryDefinition - Annotation Type in javax.jms

An application may use this annotation to specify a JMS ConnectionFactory resource that it requires in its operational environment.

JMSConnectionFactoryDefinitions - Annotation Type in javax.jms

Specifies one or more JMSConnectionFactoryDefinition annotations.

JMSConnectionStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JMS connection

JMSConsumer - Interface in javax.jms

A client using the simplified JMS API introduced for JMS 2.0 uses a JMSConsumer object to receive messages from a queue or topic.

JMSConsumerStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JMS message consumer

JMSContext - Interface in javax.jms

A JMSContext is the main interface in the simplified JMS API introduced for JMS 2.0.

JMSDestinationDefinition - Annotation Type in javax.jms

An application may use this annotation to specify a JMS Destination resource that it requires in its operational environment.

JMSDestinationDefinitions - Annotation Type in javax.jms

Specifies one or more JMSDestinationDefinition annotations.

JMSEndpointStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JMS message producer or a JMS message consumer.

JMSException - Exception in javax.jms

This is the root class of all checked exceptions in the JMS API.

JMSException(String, String) - Constructor for exception javax.jms.JMSException

Constructs a JMSException with the specified reason and error code.

JMSException(String) - Constructor for exception javax.jms.JMSException

Constructs a JMSException with the specified reason and with the error code defaulting to null.

JMSPasswordCredential - Annotation Type in javax.jms

This annotation may be used to specify the userName and password to be used when injecting a javax.jms.JMSContext object.

JMSProducer - Interface in javax.jms

A JMSProducer is a simple object used to send messages on behalf of a JMSContext.

JMSProducerStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JMS message producer

JMSRuntimeException - Exception in javax.jms

This is the root class of all unchecked exceptions in the JMS API.

JMSRuntimeException(String, String) - Constructor for exception javax.jms.JMSRuntimeException

Constructs a JMSRuntimeException with the specified detail message and error code.

JMSRuntimeException(String) - Constructor for exception javax.jms.JMSRuntimeException

Constructs a JMSRuntimeException with the specified detail message

JMSRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.JMSRuntimeException

Constructs a JMSRuntimeException with the specified detail message, error code and cause

JMSSecurityException - Exception in javax.jms

This exception must be thrown when a provider rejects a user name/password submitted by a client.

JMSSecurityException(String, String) - Constructor for exception javax.jms.JMSSecurityException

Constructs a JMSSecurityException with the specified reason and error code.

JMSSecurityException(String) - Constructor for exception javax.jms.JMSSecurityException

Constructs a JMSSecurityException with the specified reason.

JMSSecurityRuntimeException - Exception in javax.jms

This unchecked exception must be thrown when a provider rejects a user name/password submitted by a client, or for any case where a security restriction prevents a method from completing, and the method signature does not permit a JMSSecurityException to be thrown.

JMSSecurityRuntimeException(String) - Constructor for exception javax.jms.JMSSecurityRuntimeException

Constructs a JMSSecurityRuntimeException with the specified detail message

JMSSecurityRuntimeException(String, String) - Constructor for exception javax.jms.JMSSecurityRuntimeException

Constructs a JMSSecurityRuntimeException with the specified detail message and error code.

JMSSecurityRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.JMSSecurityRuntimeException

Constructs a JMSSecurityRuntimeException with the specified detail message, error code and cause

JMSSessionMode - Annotation Type in javax.jms

This annotation may be used to specify the session mode to be used when injecting a javax.jms.JMSContext object.

JMSSessionStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JMS session.

JMSStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JMS Resource

JobContext - Interface in javax.batch.runtime.context

JobExecution - Interface in javax.batch.runtime

JobExecutionAlreadyCompleteException - Exception in javax.batch.operations

JobExecutionAlreadyCompleteException() - Constructor for exception javax.batch.operations.JobExecutionAlreadyCompleteException

JobExecutionAlreadyCompleteException(String) - Constructor for exception javax.batch.operations.JobExecutionAlreadyCompleteException

JobExecutionAlreadyCompleteException(Throwable) - Constructor for exception javax.batch.operations.JobExecutionAlreadyCompleteException

JobExecutionAlreadyCompleteException(String, Throwable) - Constructor for exception javax.batch.operations.JobExecutionAlreadyCompleteException

JobExecutionIsRunningException - Exception in javax.batch.operations

JobExecutionIsRunningException() - Constructor for exception javax.batch.operations.JobExecutionIsRunningException

JobExecutionIsRunningException(String) - Constructor for exception javax.batch.operations.JobExecutionIsRunningException

JobExecutionIsRunningException(Throwable) - Constructor for exception javax.batch.operations.JobExecutionIsRunningException

JobExecutionIsRunningException(String, Throwable) - Constructor for exception javax.batch.operations.JobExecutionIsRunningException

JobExecutionNotMostRecentException - Exception in javax.batch.operations

JobExecutionNotMostRecentException() - Constructor for exception javax.batch.operations.JobExecutionNotMostRecentException

JobExecutionNotMostRecentException(String) - Constructor for exception javax.batch.operations.JobExecutionNotMostRecentException

JobExecutionNotMostRecentException(Throwable) - Constructor for exception javax.batch.operations.JobExecutionNotMostRecentException

JobExecutionNotMostRecentException(String, Throwable) - Constructor for exception javax.batch.operations.JobExecutionNotMostRecentException

JobExecutionNotRunningException - Exception in javax.batch.operations

JobExecutionNotRunningException() - Constructor for exception javax.batch.operations.JobExecutionNotRunningException

JobExecutionNotRunningException(String) - Constructor for exception javax.batch.operations.JobExecutionNotRunningException

JobExecutionNotRunningException(Throwable) - Constructor for exception javax.batch.operations.JobExecutionNotRunningException

JobExecutionNotRunningException(String, Throwable) - Constructor for exception javax.batch.operations.JobExecutionNotRunningException

JobInstance - Interface in javax.batch.runtime

JobListener - Interface in javax.batch.api.listener

JobListener intercepts job execution.

JobOperator - Interface in javax.batch.operations

JobOperator provide the interface for operating on batch jobs.

JobRestartException - Exception in javax.batch.operations

JobRestartException() - Constructor for exception javax.batch.operations.JobRestartException

JobRestartException is thrown when an error occurs during the JobOperator restart operation.

JobRestartException(String) - Constructor for exception javax.batch.operations.JobRestartException

JobRestartException(Throwable) - Constructor for exception javax.batch.operations.JobRestartException

JobRestartException(String, Throwable) - Constructor for exception javax.batch.operations.JobRestartException

JobSecurityException - Exception in javax.batch.operations

JobSecurityException() - Constructor for exception javax.batch.operations.JobSecurityException

SecurityException is thrown when an user is not authorized to run a JobOperator method, such as restart, stop, abandon, any getters, etc

JobSecurityException(String) - Constructor for exception javax.batch.operations.JobSecurityException

JobSecurityException(Throwable) - Constructor for exception javax.batch.operations.JobSecurityException

JobSecurityException(String, Throwable) - Constructor for exception javax.batch.operations.JobSecurityException

JobStartException - Exception in javax.batch.operations

JobStartException() - Constructor for exception javax.batch.operations.JobStartException

JobStartException is thrown when an error occurs during the JobOperator start operation.

JobStartException(String) - Constructor for exception javax.batch.operations.JobStartException

JobStartException(Throwable) - Constructor for exception javax.batch.operations.JobStartException

JobStartException(String, Throwable) - Constructor for exception javax.batch.operations.JobStartException

join(SingularAttribute<? super X, Y>) - Method in interface javax.persistence.criteria.From

Create an inner join to the specified single-valued attribute.

join(SingularAttribute<? super X, Y>, JoinType) - Method in interface javax.persistence.criteria.From

Create a join to the specified single-valued attribute using the given join type.

join(CollectionAttribute<? super X, Y>) - Method in interface javax.persistence.criteria.From

Create an inner join to the specified Collection-valued attribute.

join(SetAttribute<? super X, Y>) - Method in interface javax.persistence.criteria.From

Create an inner join to the specified Set-valued attribute.

join(ListAttribute<? super X, Y>) - Method in interface javax.persistence.criteria.From

Create an inner join to the specified List-valued attribute.

join(MapAttribute<? super X, K, V>) - Method in interface javax.persistence.criteria.From

Create an inner join to the specified Map-valued attribute.

join(CollectionAttribute<? super X, Y>, JoinType) - Method in interface javax.persistence.criteria.From

Create a join to the specified Collection-valued attribute using the given join type.

join(SetAttribute<? super X, Y>, JoinType) - Method in interface javax.persistence.criteria.From

Create a join to the specified Set-valued attribute using the given join type.

join(ListAttribute<? super X, Y>, JoinType) - Method in interface javax.persistence.criteria.From

Create a join to the specified List-valued attribute using the given join type.

join(MapAttribute<? super X, K, V>, JoinType) - Method in interface javax.persistence.criteria.From

Create a join to the specified Map-valued attribute using the given join type.

join(String) - Method in interface javax.persistence.criteria.From

Create an inner join to the specified attribute.

join(String, JoinType) - Method in interface javax.persistence.criteria.From

Create a join to the specified attribute using the given join type.

Join<Z,X> - Interface in javax.persistence.criteria

A join to an entity, embeddable, or basic type.

joinCollection(String) - Method in interface javax.persistence.criteria.From

Create an inner join to the specified Collection-valued attribute.

joinCollection(String, JoinType) - Method in interface javax.persistence.criteria.From

Create a join to the specified Collection-valued attribute using the given join type.

JoinColumn - Annotation Type in javax.persistence

Specifies a column for joining an entity association or element collection.

JoinColumns - Annotation Type in javax.persistence

Specifies the mapping for composite foreign keys.

joinList(String) - Method in interface javax.persistence.criteria.From

Create an inner join to the specified List-valued attribute.

joinList(String, JoinType) - Method in interface javax.persistence.criteria.From

Create a join to the specified List-valued attribute using the given join type.

joinMap(String) - Method in interface javax.persistence.criteria.From

Create an inner join to the specified Map-valued attribute.

joinMap(String, JoinType) - Method in interface javax.persistence.criteria.From

Create a join to the specified Map-valued attribute using the given join type.

joinSet(String) - Method in interface javax.persistence.criteria.From

Create an inner join to the specified Set-valued attribute.

joinSet(String, JoinType) - Method in interface javax.persistence.criteria.From

Create a join to the specified Set-valued attribute using the given join type.

JoinTable - Annotation Type in javax.persistence

Specifies the mapping of associations.

joinTransaction() - Method in interface javax.persistence.EntityManager

Indicate to the entity manager that a JTA transaction is active and join the persistence context to it.

JoinType - Enum in javax.persistence.criteria

Defines the three types of joins.

Json - Class in javax.json

Factory class for creating JSON processing objects.

json(T) - Static method in class javax.ws.rs.client.Entity

Create an "application/json" entity.

JsonArray - Interface in javax.json

JsonArray represents an immutable JSON array (an ordered sequence of zero or more values).

JsonArrayBuilder - Interface in javax.json

A builder for creating JsonArray models from scratch.

JsonBuilderFactory - Interface in javax.json

Factory to create JsonObjectBuilder and JsonArrayBuilder instances.

JsonException - Exception in javax.json

JsonException indicates that some exception happened during JSON processing.

JsonException(String) - Constructor for exception javax.json.JsonException

Constructs a new runtime exception with the specified detail message.

JsonException(String, Throwable) - Constructor for exception javax.json.JsonException

Constructs a new runtime exception with the specified detail message and cause.

JsonGenerationException - Exception in javax.json.stream

JsonGenerationException indicates an incorrect JSON is being generated.

JsonGenerationException(String) - Constructor for exception javax.json.stream.JsonGenerationException

Constructs a new runtime exception with the specified detail message.

JsonGenerationException(String, Throwable) - Constructor for exception javax.json.stream.JsonGenerationException

Constructs a new runtime exception with the specified detail message and cause.

JsonGenerator - Interface in javax.json.stream

Writes JSON data to an output source in a streaming way.

JsonGeneratorFactory - Interface in javax.json.stream

Factory to create JsonGenerator instances.

JsonLocation - Interface in javax.json.stream

Provides the location information of a JSON event in an input source.

JsonNumber - Interface in javax.json

An immutable JSON number value.

JsonObject - Interface in javax.json

JsonObject class represents an immutable JSON object value (an unordered collection of zero or more name/value pairs).

JsonObjectBuilder - Interface in javax.json

A builder for creating JsonObject models from scratch.

JsonParser - Interface in javax.json.stream

Provides forward, read-only access to JSON data in a streaming way.

JsonParser.Event - Enum in javax.json.stream

An event from JsonParser.

JsonParserFactory - Interface in javax.json.stream

Factory for creating JsonParser instances.

JsonParsingException - Exception in javax.json.stream

JsonParsingException is used when an incorrect JSON is being parsed.

JsonParsingException(String, JsonLocation) - Constructor for exception javax.json.stream.JsonParsingException

Constructs a new runtime exception with the specified detail message.

JsonParsingException(String, Throwable, JsonLocation) - Constructor for exception javax.json.stream.JsonParsingException

Constructs a new runtime exception with the specified detail message and cause.

JsonProvider - Class in javax.json.spi

Service provider for JSON processing objects.

JsonProvider() - Constructor for class javax.json.spi.JsonProvider

JsonReader - Interface in javax.json

Reads a JSON object or an array structure from an input source.

JsonReaderFactory - Interface in javax.json

Factory to create JsonReader instances.

JsonString - Interface in javax.json

An immutable JSON string value.

JsonStructure - Interface in javax.json

Super type for the two structured types in JSON (objects and arrays).

JsonValue - Interface in javax.json

JsonValue represents an immutable JSON value.

JsonValue.ValueType - Enum in javax.json

Indicates the type of a JsonValue object.

JsonWriter - Interface in javax.json

Writes a JSON object or array structure to an output source.

JsonWriterFactory - Interface in javax.json

Factory to create JsonWriter instances.

JSP_VIEW_DECLARATION_LANGUAGE_ID - Static variable in class javax.faces.view.ViewDeclarationLanguage

Identifier for the JSP view declaration language.

JspApplicationContext - Interface in javax.servlet.jsp

Stores application-scoped information relevant to JSP containers.

JspConfigDescriptor - Interface in javax.servlet.descriptor

This interface provides access to the <jsp-config> related configuration of a web application.

JspContext - Class in javax.servlet.jsp

JspContext serves as the base class for the PageContext class and abstracts all information that is not specific to servlets.

JspContext() - Constructor for class javax.servlet.jsp.JspContext

Sole constructor.

jspDestroy() - Method in interface javax.servlet.jsp.JspPage

The jspDestroy() method is invoked when the JSP page is about to be destroyed.

JspEngineInfo - Class in javax.servlet.jsp

The JspEngineInfo is an abstract class that provides information on the current JSP engine.

JspEngineInfo() - Constructor for class javax.servlet.jsp.JspEngineInfo

Sole constructor.

JspException - Exception in javax.servlet.jsp

A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.

JspException() - Constructor for exception javax.servlet.jsp.JspException

Construct a JspException.

JspException(String) - Constructor for exception javax.servlet.jsp.JspException

Constructs a new JSP exception with the specified message.

JspException(String, Throwable) - Constructor for exception javax.servlet.jsp.JspException

Constructs a new JspException with the specified detail message and cause.

JspException(Throwable) - Constructor for exception javax.servlet.jsp.JspException

Constructs a new JspException with the specified cause.

JspFactory - Class in javax.servlet.jsp

The JspFactory is an abstract class that defines a number of factory methods available to a JSP page at runtime for the purposes of creating instances of various interfaces and classes used to support the JSP implementation.

JspFactory() - Constructor for class javax.servlet.jsp.JspFactory

Sole constructor.

JspFragment - Class in javax.servlet.jsp.tagext

Encapsulates a portion of JSP code in an object that can be invoked as many times as needed.

JspFragment() - Constructor for class javax.servlet.jsp.tagext.JspFragment

JspIdConsumer - Interface in javax.servlet.jsp.tagext

This interface indicates to the container that a tag handler wishes to be provided with a compiler generated ID.

jspInit() - Method in interface javax.servlet.jsp.JspPage

The jspInit() method is invoked when the JSP page is initialized.

JspPage - Interface in javax.servlet.jsp

The JspPage interface describes the generic interaction that a JSP Page Implementation class must satisfy; pages that use the HTTP protocol are described by the HttpJspPage interface.

JspPropertyGroupDescriptor - Interface in javax.servlet.descriptor

This interface provides access to the <jsp-property-group> related configuration of a web application.

JspTag - Interface in javax.servlet.jsp.tagext

Serves as a base class for Tag and SimpleTag.

JspTagException - Exception in javax.servlet.jsp

Exception to be used by a Tag Handler to indicate some unrecoverable error.

JspTagException(String) - Constructor for exception javax.servlet.jsp.JspTagException

Constructs a new JspTagException with the specified message.

JspTagException() - Constructor for exception javax.servlet.jsp.JspTagException

Constructs a new JspTagException with no message.

JspTagException(String, Throwable) - Constructor for exception javax.servlet.jsp.JspTagException

Constructs a new JspTagException when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.

JspTagException(Throwable) - Constructor for exception javax.servlet.jsp.JspTagException

Constructs a new JSP Tag exception when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.

jspversion - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo

The version of the JSP specification this tag library is written to.

JspWriter - Class in javax.servlet.jsp

The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.

JspWriter(int, boolean) - Constructor for class javax.servlet.jsp.JspWriter

Protected constructor.

JTAStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a JTA resource.

JVMStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a Java VM.

K

keep(String) - Method in class javax.faces.context.Flash

Causes a value stored with a previous call to Flash.putNow(java.lang.String, java.lang.Object), its EL equivalent, or to the request Map, to be promoted to the flash so that is available on the next traversal through the lifecycle on this session.

keep(String) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Flash.keep(String) on the wrapped Flash object.

key() - Method in interface javax.persistence.criteria.MapJoin

Create a path expression that corresponds to the map key.

Key - Interface in javax.xml.registry.infomodel

Represents a unique key that identifies a RegistryObject.

KEY - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.Key interface.

keys(M) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the keys of a map.

keySet() - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.keySet() on the wrapped Flash object.

keySet() - Method in class javax.ws.rs.core.AbstractMultivaluedMap

keyStore(KeyStore, char[]) - Method in class javax.ws.rs.client.ClientBuilder

Set the client-side key store.

keyStore(KeyStore, String) - Method in class javax.ws.rs.client.ClientBuilder

Set the client-side key store.

L

LambdaExpression - Class in javax.el

Encapsulates a parameterized ValueExpression.

LambdaExpression(List<String>, ValueExpression) - Constructor for class javax.el.LambdaExpression

Creates a new LambdaExpression.

language(String) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the message entity language.

language(Locale) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the message entity language.

languages(Locale...) - Static method in class javax.ws.rs.core.Variant

Create a Variant.VariantListBuilder initialized with a set of supported languages.

languages(Locale...) - Method in class javax.ws.rs.core.Variant.VariantListBuilder

Set the language(s) for this variant.

LAST_MODIFIED - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

LastExecution - Interface in javax.enterprise.concurrent

Contains information about the last execution of a task.

lastModified(Date) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the response entity last modification date.

LASTUID - Static variable in interface javax.mail.UIDFolder

This is a special value that can be used as the end parameter in getMessagesByUID(start, end), to denote the UID of the last message in the folder.

LazyAssociatableConnectionManager - Interface in javax.resource.spi

This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation.

lazyEnlist(ManagedConnection) - Method in interface javax.resource.spi.LazyEnlistableConnectionManager

This method is called by a resource adapter (that is capable of lazy transaction enlistment optimization) in order to lazily enlist a connection object with a XA transaction.

LazyEnlistableConnectionManager - Interface in javax.resource.spi

This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation.

LazyEnlistableManagedConnection - Interface in javax.resource.spi

This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation.

LE - Static variable in class javax.mail.search.ComparisonTerm

le(Expression<? extends Number>, Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is less than or equal to the second.

le(Expression<? extends Number>, Number) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is less than or equal to the second.

least(Expression<X>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an aggregate expression for finding the least of the values (strings, dates, etc).

length(Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to return length of a string.

LengthValidator - Class in javax.faces.validator

LengthValidator is a Validator that checks the number of characters in the String representation of the value of the associated component.

LengthValidator() - Constructor for class javax.faces.validator.LengthValidator

Construct a Validator with no preconfigured limits.

LengthValidator(int) - Constructor for class javax.faces.validator.LengthValidator

Construct a Validator with the specified preconfigured limit.

LengthValidator(int, int) - Constructor for class javax.faces.validator.LengthValidator

Construct a Validator with the specified preconfigured limits.

lessThan(Expression<? extends Y>, Expression<? extends Y>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is less than the second.

lessThan(Expression<? extends Y>, Y) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is less than the second.

lessThanOrEqualTo(Expression<? extends Y>, Expression<? extends Y>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is less than or equal to the second.

lessThanOrEqualTo(Expression<? extends Y>, Y) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is less than or equal to the second.

LIBRARY_AFTER - Static variable in class javax.interceptor.Interceptor.Priority

Start of range for late interceptors defined by extension libraries.

LIBRARY_BEFORE - Static variable in class javax.interceptor.Interceptor.Priority

Start of range for early interceptors defined by extension libraries.

libraryExists(String) - Method in class javax.faces.application.ResourceHandler

Return true if the resource library named by the argument libraryName can be found.

libraryExists(String) - Method in class javax.faces.application.ResourceHandlerWrapper

The default behavior of this method is to call ResourceHandler.libraryExists(String) on the wrapped ResourceHandler object.

Lifecycle - Class in javax.faces.lifecycle

Lifecycle manages the processing of the entire lifecycle of a particular JavaServer Faces request.

Lifecycle() - Constructor for class javax.faces.lifecycle.Lifecycle

LIFECYCLE_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the LifecycleFactory class name.

LIFECYCLE_ID_ATTR - Static variable in class javax.faces.webapp.FacesServlet

Context initialization parameter name for the lifecycle identifier of the Lifecycle instance to be utilized.

LifecycleFactory - Class in javax.faces.lifecycle

LifecycleFactory is a factory object that creates (if needed) and returns Lifecycle instances.

LifecycleFactory() - Constructor for class javax.faces.lifecycle.LifecycleFactory

LifeCycleManager - Interface in javax.xml.registry

The LifeCycleManager interface is the main interface in the API for managing life cycle operations on objects defined by the information model.

LifecycleWrapper - Class in javax.faces.lifecycle

Provides a simple implementation of Lifecycle that can be subclassed by developers wishing to provide specialized behavior to an existing Lifecycle instance.

LifecycleWrapper() - Constructor for class javax.faces.lifecycle.LifecycleWrapper

like(Expression<String>, Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression satisfies the given pattern.

like(Expression<String>, String) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression satisfies the given pattern.

like(Expression<String>, Expression<String>, Expression<Character>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression satisfies the given pattern.

like(Expression<String>, Expression<String>, char) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression satisfies the given pattern.

like(Expression<String>, String, Expression<Character>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression satisfies the given pattern.

like(Expression<String>, String, char) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression satisfies the given pattern.

limit - Variable in class javax.mail.Quota.Resource

The usage limit for the resource.

LINK - Static variable in interface javax.ws.rs.core.HttpHeaders

See Web Linking (IETF RFC-5988) documentation.

Link - Class in javax.ws.rs.core

Class representing hypermedia links.

Link() - Constructor for class javax.ws.rs.core.Link

link(Link) - Method in interface javax.ws.rs.core.Link.Builder

Initialize builder using another link.

link(String) - Method in interface javax.ws.rs.core.Link.Builder

Initialize builder using another link represented as a string.

link(URI, String) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Add a link header.

link(String, String) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Add a link header.

Link.Builder - Interface in javax.ws.rs.core

Builder class for hypermedia links.

Link.JaxbAdapter - Class in javax.ws.rs.core

An implementation of JAXB XmlAdapter that maps the JAX-RS Link type to a value that can be marshalled and unmarshalled by JAXB.

Link.JaxbAdapter() - Constructor for class javax.ws.rs.core.Link.JaxbAdapter

Link.JaxbLink - Class in javax.ws.rs.core

Value type for Link that can be marshalled and unmarshalled by JAXB.

Link.JaxbLink() - Constructor for class javax.ws.rs.core.Link.JaxbLink

Default constructor needed during unmarshalling.

Link.JaxbLink(URI) - Constructor for class javax.ws.rs.core.Link.JaxbLink

Construct an instance from a URI and no parameters.

Link.JaxbLink(URI, Map<QName, Object>) - Constructor for class javax.ws.rs.core.Link.JaxbLink

Construct an instance from a URI and some parameters.

linkConfiguration(PolicyConfiguration) - Method in interface javax.security.jacc.PolicyConfiguration

Creates a relationship between this configuration and another such that they share the same principal-to-role mappings.

links(Link...) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Add one or more link headers.

list(String) - Method in class javax.mail.Folder

Returns a list of Folders belonging to this Folder's namespace that match the specified pattern.

list() - Method in class javax.mail.Folder

Convenience method that returns the list of folders under this Folder.

ListAttribute<X,E> - Interface in javax.persistence.metamodel

Instances of the type ListAttribute represent persistent javax.util.List-valued attributes.

ListDataModel<E> - Class in javax.faces.model

ListDataModel is a convenience implementation of DataModel that wraps an List of Java objects.

ListDataModel() - Constructor for class javax.faces.model.ListDataModel

Construct a new ListDataModel with no specified wrapped data.

ListDataModel(List<E>) - Constructor for class javax.faces.model.ListDataModel

Construct a new ListDataModel wrapping the specified list.

ListELResolver - Class in javax.el

Defines property resolution behavior on instances of List.

ListELResolver() - Constructor for class javax.el.ListELResolver

Creates a new read/write ListELResolver.

ListELResolver(boolean) - Constructor for class javax.el.ListELResolver

Creates a new ListELResolver whose read-only status is determined by the given parameter.

ListenerFor - Annotation Type in javax.faces.event

Classes tagged with this annotation are installed as listeners using the method Application.subscribeToEvent(java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Class<?>, javax.faces.event.SystemEventListener) or UIComponent.subscribeToEvent(java.lang.Class<? extends javax.faces.event.SystemEvent>, javax.faces.event.ComponentSystemEventListener) (depending on the circumstances, described below).

ListenerRegistration - Interface in javax.management.j2ee

ListenerRegistration defines the methods which clients of the MEJB use to add and remove event listeners.

ListenersFor - Annotation Type in javax.faces.event

Container annotation to specify multiple ListenerFor annotations on a single class.

ListJoin<Z,E> - Interface in javax.persistence.criteria

The ListJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.List.

listSubscribed(String) - Method in class javax.mail.Folder

Returns a list of subscribed Folders belonging to this Folder's namespace that match the specified pattern.

listSubscribed() - Method in class javax.mail.Folder

Convenience method that returns the list of subscribed folders under this Folder.

literal(T) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression for a literal.

load(InputStream) - Method in class javax.mail.internet.InternetHeaders

Read and parse the given RFC822 message stream till the blank line separating the header from the body.

loadService(Class) - Method in class javax.xml.rpc.ServiceFactory

Create an instance of the generated service implementation class for a given service interface, if available.

loadService(URL, Class, Properties) - Method in class javax.xml.rpc.ServiceFactory

Create an instance of the generated service implementation class for a given service interface, if available.

loadService(URL, QName, Properties) - Method in class javax.xml.rpc.ServiceFactory

Create an instance of the generated service implementation class for a given service, if available.

LoadState - Enum in javax.persistence.spi

Load states returned by the ProviderUtil SPI methods.

Lob - Annotation Type in javax.persistence

Specifies that a persistent property or field should be persisted as a large object to a database-supported large object type.

Local - Annotation Type in javax.ejb

Declares the local business interface(s) for a session bean.

LOCAL_TRANSACTION_COMMITTED - Static variable in class javax.resource.spi.ConnectionEvent

Event notification that a Resource Manager Local Transaction was committed on the connection

LOCAL_TRANSACTION_ROLLEDBACK - Static variable in class javax.resource.spi.ConnectionEvent

Event notification that a Resource Manager Local Transaction was rolled back on the connection

LOCAL_TRANSACTION_STARTED - Static variable in class javax.resource.spi.ConnectionEvent

Event notification that a Resource Manager Local Transaction was started on the connection

LocalBean - Annotation Type in javax.ejb

Designates that a session bean exposes a no-interface view.

LOCALE_PREFIX - Static variable in class javax.faces.application.ResourceHandler

The name of a key within the application message bundle named by the return from Application.getMessageBundle() whose value is the locale prefix used to find a packaged resource to return from ResourceHandler.createResource(java.lang.String) (or one of its variants).

LocaleSupport - Class in javax.servlet.jsp.jstl.fmt

Class which exposes the locale-determination logic for resource bundles through convenience methods.

LocaleSupport() - Constructor for class javax.servlet.jsp.jstl.fmt.LocaleSupport

LocalHome - Annotation Type in javax.ejb

Declares the local home or adapted local home interface for a session bean.

LocalizationContext - Class in javax.servlet.jsp.jstl.fmt

Class representing an I18N localization context.

LocalizationContext() - Constructor for class javax.servlet.jsp.jstl.fmt.LocalizationContext

Constructs an empty I18N localization context.

LocalizationContext(ResourceBundle, Locale) - Constructor for class javax.servlet.jsp.jstl.fmt.LocalizationContext

Constructs an I18N localization context from the given resource bundle and locale.

LocalizationContext(ResourceBundle) - Constructor for class javax.servlet.jsp.jstl.fmt.LocalizationContext

Constructs an I18N localization context from the given resource bundle.

LOCALIZED_STRING - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.LocalizedString interface.

LocalizedString - Interface in javax.xml.registry.infomodel

This interface is used as a simple wrapper interface that associates a String with its Locale.

LocalTransaction - Interface in javax.resource.cci

The LocalTransaction defines a transaction demarcation interface for resource manager local transactions.

LocalTransaction - Interface in javax.resource.spi

LocalTransaction interface provides support for transactions that are managed internal to an EIS resource manager, and do not require an external transaction manager.

localTransactionCommitted(ConnectionEvent) - Method in interface javax.resource.spi.ConnectionEventListener

Notifies that a Resource Manager Local Transaction was committed on the ManagedConnection instance.

LocalTransactionException - Exception in javax.resource.spi

A LocalTransactionException represents various error conditions related to the local transaction management contract.

LocalTransactionException() - Constructor for exception javax.resource.spi.LocalTransactionException

Constructs a new instance with null as its detail message.

LocalTransactionException(String) - Constructor for exception javax.resource.spi.LocalTransactionException

Constructs a new instance with the specified detail message.

LocalTransactionException(Throwable) - Constructor for exception javax.resource.spi.LocalTransactionException

Constructs a new throwable with the specified cause.

LocalTransactionException(String, Throwable) - Constructor for exception javax.resource.spi.LocalTransactionException

Constructs a new throwable with the specified detail message and cause.

LocalTransactionException(String, String) - Constructor for exception javax.resource.spi.LocalTransactionException

Constructs a new throwable with the specified detail message and an error code.

localTransactionRolledback(ConnectionEvent) - Method in interface javax.resource.spi.ConnectionEventListener

Notifies that a Resource Manager Local Transaction was rolled back on the ManagedConnection instance.

localTransactionStarted(ConnectionEvent) - Method in interface javax.resource.spi.ConnectionEventListener

Notifies that a Resource Manager Local Transaction was started on the ManagedConnection instance.

locate(Expression<String>, Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to locate the position of one string within another, returning position of first character if found.

locate(Expression<String>, String) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to locate the position of one string within another, returning position of first character if found.

locate(Expression<String>, Expression<String>, Expression<Integer>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to locate the position of one string within another, returning position of first character if found.

locate(Expression<String>, String, int) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to locate the position of one string within another, returning position of first character if found.

Location - Class in javax.faces.view

An object that represents the Location of a tag or attribute of a tag in a View Declaration Language file.

Location(String, int, int) - Constructor for class javax.faces.view.Location

LOCATION - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

location(URI) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the location.

Lock - Annotation Type in javax.ejb

Declares a concurrency lock for a singleton session bean with container managed concurrency.

lock(Object, LockModeType) - Method in interface javax.persistence.EntityManager

Lock an entity instance that is contained in the persistence context with the specified lock mode type.

lock(Object, LockModeType, Map<String, Object>) - Method in interface javax.persistence.EntityManager

Lock an entity instance that is contained in the persistence context with the specified lock mode type and with specified properties.

LockModeType - Enum in javax.persistence

Lock modes can be specified by means of passing a LockModeType argument to one of the EntityManager methods that take locks (lock, find, or refresh) or to the Query.setLockMode() or TypedQuery.setLockMode() method.

LockTimeoutException - Exception in javax.persistence

Thrown by the persistence provider when an pessimistic locking conflict occurs that does not result in transaction rollback.

LockTimeoutException() - Constructor for exception javax.persistence.LockTimeoutException

Constructs a new LockTimeoutException exception with null as its detail message.

LockTimeoutException(String) - Constructor for exception javax.persistence.LockTimeoutException

Constructs a new LockTimeoutException exception with the specified detail message.

LockTimeoutException(String, Throwable) - Constructor for exception javax.persistence.LockTimeoutException

Constructs a new LockTimeoutException exception with the specified detail message and cause.

LockTimeoutException(Throwable) - Constructor for exception javax.persistence.LockTimeoutException

Constructs a new LockTimeoutException exception with the specified cause.

LockTimeoutException(Object) - Constructor for exception javax.persistence.LockTimeoutException

Constructs a new LockTimeoutException exception with the specified object.

LockTimeoutException(String, Throwable, Object) - Constructor for exception javax.persistence.LockTimeoutException

Constructs a new LockTimeoutException exception with the specified detail message, cause, and entity.

LockType - Enum in javax.ejb

Concurrency lock type for singleton beans with container-managed concurrency.

log(String) - Method in class javax.faces.context.ExternalContext

Log the specified message to the application object.

log(String, Throwable) - Method in class javax.faces.context.ExternalContext

Log the specified message and exception to the application object.

log(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.log(String) on the wrapped ExternalContext object.

log(String, Throwable) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.log(String, Throwable) on the wrapped ExternalContext object.

log - Static variable in class javax.faces.webapp.UIComponentTagBase

log(String) - Method in class javax.servlet.GenericServlet

Writes the specified message to a servlet log file, prepended by the servlet's name.

log(String, Throwable) - Method in class javax.servlet.GenericServlet

Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file, prepended by the servlet's name.

log(String) - Method in interface javax.servlet.ServletContext

Writes the specified message to a servlet log file, usually an event log.

log(Exception, String) - Method in interface javax.servlet.ServletContext

Deprecated.
As of Java Servlet API 2.1, use ServletContext.log(String message, Throwable throwable) instead.
This method was originally defined to write an exception's stack trace and an explanatory error message to the servlet log file.

log(String, Throwable) - Method in interface javax.servlet.ServletContext

Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file.

LogicalHandler<C extends LogicalMessageContext> - Interface in javax.xml.ws.handler

The LogicalHandler extends Handler to provide typesafety for the message context parameter.

LogicalMessage - Interface in javax.xml.ws

The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.

LogicalMessageContext - Interface in javax.xml.ws.handler

The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage

login(String, String) - Method in interface javax.servlet.http.HttpServletRequest

Validate the provided username and password in the password validation realm used by the web container login mechanism configured for the ServletContext.

login(String, String) - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to call login on the wrapped request object.

logout() - Method in interface javax.servlet.http.HttpServletRequest

Establish null as the value returned when getUserPrincipal, getRemoteUser, and getAuthType is called on the request.

logout() - Method in class javax.servlet.http.HttpServletRequestWrapper

The default behavior of this method is to call login on the wrapped request object.

LONG_ID - Static variable in class javax.faces.convert.LongConverter

The message identifier of the FacesMessage to be created if the conversion to Long fails.

LongConverter - Class in javax.faces.convert

Converter implementation for java.lang.Long (and long primitive) values.

LongConverter() - Constructor for class javax.faces.convert.LongConverter

LongHolder - Class in javax.xml.rpc.holders

LongHolder() - Constructor for class javax.xml.rpc.holders.LongHolder

LongHolder(long) - Constructor for class javax.xml.rpc.holders.LongHolder

LongRangeValidator - Class in javax.faces.validator

LongRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.

LongRangeValidator() - Constructor for class javax.faces.validator.LongRangeValidator

Construct a Validator with no preconfigured limits.

LongRangeValidator(long) - Constructor for class javax.faces.validator.LongRangeValidator

Construct a Validator with the specified preconfigured limit.

LongRangeValidator(long, long) - Constructor for class javax.faces.validator.LongRangeValidator

Construct a Validator with the specified preconfigured limits.

LONGRUNNING_HINT - Static variable in interface javax.enterprise.concurrent.ManagedTask

Execution property to be returned in ManagedTask.getExecutionProperties() or ContextService.createContextualProxy() to provide hint about whether the task could take a long time to complete.

LONGRUNNING_HINT - Static variable in class javax.resource.spi.work.HintsContext

longValue() - Method in interface javax.json.JsonNumber

Returns this JSON number as a long.

longValueExact() - Method in interface javax.json.JsonNumber

Returns this JSON number as a long.

LongWrapperHolder - Class in javax.xml.rpc.holders

LongWrapperHolder() - Constructor for class javax.xml.rpc.holders.LongWrapperHolder

LongWrapperHolder(Long) - Constructor for class javax.xml.rpc.holders.LongWrapperHolder

lookingAt(Scope) - Method in interface javax.validation.metadata.ElementDescriptor.ConstraintFinder

Restricts to the constraints matching the provided scope for this element.

lookup(String) - Method in interface javax.ejb.EJBContext

Lookup a resource within the java: namespace.

LoopTag - Interface in javax.servlet.jsp.jstl.core

JSTL allows developers to write custom iteration tags by implementing the LoopTag interface.

LoopTagStatus - Interface in javax.servlet.jsp.jstl.core

Exposes the current status of an iteration.

LoopTagSupport - Class in javax.servlet.jsp.jstl.core

Base support class to facilitate implementation of iteration tags.

LoopTagSupport() - Constructor for class javax.servlet.jsp.jstl.core.LoopTagSupport

Constructs a new LoopTagSupport.

lower(Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression for converting a string to lowercase.

LT - Static variable in class javax.mail.search.ComparisonTerm

lt(Expression<? extends Number>, Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is less than the second.

lt(Expression<? extends Number>, Number) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the first argument is less than the second.

M

MailDateFormat - Class in javax.mail.internet

Formats and parses date specification based on the draft-ietf-drums-msg-fmt-08 dated January 26, 2000.

MailDateFormat() - Constructor for class javax.mail.internet.MailDateFormat

MailEvent - Class in javax.mail.event

Common base class for mail events, defining the dispatch method.

MailEvent(Object) - Constructor for class javax.mail.event.MailEvent

MailSessionDefinition - Annotation Type in javax.mail

Annotation used by Java EE applications to define a MailSession to be registered with JNDI.

MailSessionDefinitions - Annotation Type in javax.mail

Declares one or more MailSessionDefinition annotations.

makeRegistrySpecificRequest(String) - Method in interface javax.xml.registry.RegistryService

Takes a String that is an XML request in a registry-specific format, sends the request to the registry, and returns a String that is the registry-specific XML response.

ManageableThread - Interface in javax.enterprise.concurrent

Interface to be implemented by the Java™ EE product providers on threads that are created by calling ThreadFactory.newThread(java.lang.Runnable).

ManagedBean - Annotation Type in javax.annotation

The ManagedBean annotation marks a POJO (Plain Old Java Object) as a ManagedBean.A ManagedBean supports a small set of basic services such as resource injection, lifecycle callbacks and interceptors.

ManagedBean - Annotation Type in javax.faces.bean

The presence of this annotation on a class automatically registers the class with the runtime as a managed bean class.

ManagedConnection - Interface in javax.resource.spi

ManagedConnection instance represents a physical connection to the underlying EIS.

ManagedConnectionFactory - Interface in javax.resource.spi

ManagedConnectionFactory instance is a factory of both ManagedConnection and EIS-specific connection factory instances.

ManagedConnectionMetaData - Interface in javax.resource.spi

The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with a ManagedConnection instance.

ManagedExecutors - Class in javax.enterprise.concurrent

Utility methods for classes defined in this package.

ManagedExecutorService - Interface in javax.enterprise.concurrent

A manageable version of a ExecutorService.

ManagedProperty - Annotation Type in javax.faces.bean

The presence of this annotation on a field of a class annotated with ManagedBean instructs the system to inject a value into this property as described in section JSF.5.3 of the spec prose document in the <managed-property> subsection.

ManagedScheduledExecutorService - Interface in javax.enterprise.concurrent

A manageable version of a ScheduledExecutorService.

managedTask(Runnable, ManagedTaskListener) - Static method in class javax.enterprise.concurrent.ManagedExecutors

Returns a Runnable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.

managedTask(Runnable, Map<String, String>, ManagedTaskListener) - Static method in class javax.enterprise.concurrent.ManagedExecutors

Returns a Runnable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener and to provide additional execution properties when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.

managedTask(Callable<V>, ManagedTaskListener) - Static method in class javax.enterprise.concurrent.ManagedExecutors

Returns a Callable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.

managedTask(Callable<V>, Map<String, String>, ManagedTaskListener) - Static method in class javax.enterprise.concurrent.ManagedExecutors

Returns a Callable object that also implements ManagedTask interface so it can receive notification of lifecycle events with the provided ManagedTaskListener and to provide additional execution properties when the task is submitted to a ManagedExecutorService or a ManagedScheduledExecutorService.

ManagedTask - Interface in javax.enterprise.concurrent

A task submitted to an ManagedExecutorService or ManagedScheduledExecutorService can optionally implement this interface to provide identifying information about the task, to provide a ManagedTaskListener to get notification of lifecycle events of the task, or to provide additional execution properties.

ManagedTaskListener - Interface in javax.enterprise.concurrent

A ManagedTaskListener is used to monitor the state of a task's Future.

ManagedThreadFactory - Interface in javax.enterprise.concurrent

A manageable version of a ThreadFactory.

ManagedType<X> - Interface in javax.persistence.metamodel

Instances of the type ManagedType represent entity, mapped superclass, and embeddable types.

managedType(Class<X>) - Method in interface javax.persistence.metamodel.Metamodel

Return the metamodel managed type representing the entity, mapped superclass, or embeddable class.

Management - Interface in javax.management.j2ee

The Management interface provides the APIs to navigate and manipulate managed objects.

ManagementHome - Interface in javax.management.j2ee

The required home interface for the J2EE Management EJB component (MEJB).

ManyToMany - Annotation Type in javax.persistence

Specifies a many-valued association with many-to-many multiplicity.

ManyToOne - Annotation Type in javax.persistence

Specifies a single-valued association to another entity class that has many-to-one multiplicity.

MapAttribute<X,K,V> - Interface in javax.persistence.metamodel

Instances of the type MapAttribute represent persistent java.util.Map-valued attributes.

MapELResolver - Class in javax.el

Defines property resolution behavior on instances of Map.

MapELResolver() - Constructor for class javax.el.MapELResolver

Creates a new read/write MapELResolver.

MapELResolver(boolean) - Constructor for class javax.el.MapELResolver

Creates a new MapELResolver whose read-only status is determined by the given parameter.

mapFunction(String, String, Method) - Method in class javax.el.ELManager

Maps a static method to an EL function.

mapFunction(String, String, Method) - Method in class javax.el.FunctionMapper

Adds a static method that can be used as a function.

MapJoin<Z,K,V> - Interface in javax.persistence.criteria

The MapJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Map.

MapKey - Annotation Type in javax.persistence

Specifies the map key for associations of type java.util.Map when the map key is itself the primary key or a persistent field or property of the entity that is the value of the map.

MapKeyClass - Annotation Type in javax.persistence

Specifies the type of the map key for associations of type java.util.Map.

MapKeyColumn - Annotation Type in javax.persistence

Specifies the mapping for the key column of a map whose map key is a basic type.

MapKeyEnumerated - Annotation Type in javax.persistence

Specifies the enum type for a map key whose basic type is an enumerated type.

MapKeyJoinColumn - Annotation Type in javax.persistence

Specifies a mapping to an entity that is a map key.

MapKeyJoinColumns - Annotation Type in javax.persistence

Supports composite map keys that reference entities.

MapKeyTemporal - Annotation Type in javax.persistence

This annotation must be specified for persistent map keys of type Date and Calendar.

MapMessage - Interface in javax.jms

A MapMessage object is used to send a set of name-value pairs.

mapPartitions() - Method in interface javax.batch.api.partition.PartitionMapper

The mapPartitions method that receives control at the start of partitioned step processing.

MappedRecord - Interface in javax.resource.cci

The interface javax.resource.cci.MappedRecord is used for key-value map based representation of record elements.

MappedSuperclass - Annotation Type in javax.persistence

Designates a class whose mapping information is applied to the entities that inherit from it.

MappedSuperclassType<X> - Interface in javax.persistence.metamodel

Instances of the type MappedSuperclassType represent mapped superclass types.

MapsId - Annotation Type in javax.persistence

Designates a ManyToOne or OneToOne relationship attribute that provides the mapping for an EmbeddedId primary key, an attribute within an EmbeddedId primary key, or a simple primary key of the parent entity.

mark(int) - Method in class javax.mail.util.SharedFileInputStream

See the general contract of the mark method of InputStream.

markAsStartNode() - Method in class javax.faces.flow.builder.FlowCallBuilder

markAsStartNode() - Method in class javax.faces.flow.builder.MethodCallBuilder

markAsStartNode() - Method in interface javax.faces.flow.builder.NodeBuilder

Mark this node as the start node in the flow.

markAsStartNode() - Method in class javax.faces.flow.builder.ReturnBuilder

markAsStartNode() - Method in class javax.faces.flow.builder.SwitchBuilder

markAsStartNode() - Method in class javax.faces.flow.builder.ViewBuilder

markInitialState() - Method in class javax.faces.component.behavior.BehaviorBase

Implementation of PartialStateHolder.markInitialState().

markInitialState() - Method in interface javax.faces.component.PartialStateHolder

The runtime must ensure that the PartialStateHolder.markInitialState() method is called on each instance of this interface in the view at the appropriate time to indicate the component is in its initial state.

markInitialState() - Method in class javax.faces.component.UIComponent

An implementation of PartialStateHolder.markInitialState(), this method is called by the runtime to indicate that the instance should start tracking changes to its state.

markInitialState() - Method in class javax.faces.component.UIComponentBase

For each of the attached objects on this instance that implement PartialStateHolder, call PartialStateHolder.markInitialState() on the attached object.

markInitialState() - Method in class javax.faces.component.UIData

Override the base class method to take special action if the method is being invoked when StateManager.IS_BUILDING_INITIAL_STATE is true and the rowStatePreserved JavaBeans property for this instance is true.

markInitialState() - Method in class javax.faces.component.UIInput

In addition to the actions taken in UIOutput when PartialStateHolder.markInitialState() is called, check if any of the installed Validators are PartialStateHolders and if so, call PartialStateHolder.markInitialState() as appropriate.

markInitialState() - Method in class javax.faces.component.UIOutput

In addition to the actions taken in UIComponentBase when PartialStateHolder.markInitialState() is called, check if the installed Converter is a PartialStateHolder and if it is, call PartialStateHolder.markInitialState() on it.

markInitialState() - Method in class javax.faces.convert.DateTimeConverter

markInitialState() - Method in class javax.faces.convert.EnumConverter

markInitialState() - Method in class javax.faces.convert.NumberConverter

markInitialState() - Method in class javax.faces.validator.BeanValidator

markInitialState() - Method in class javax.faces.validator.DoubleRangeValidator

markInitialState() - Method in class javax.faces.validator.LengthValidator

markInitialState() - Method in class javax.faces.validator.LongRangeValidator

markInitialState() - Method in class javax.faces.validator.RegexValidator

markSupported() - Method in class javax.mail.util.SharedFileInputStream

Tests if this input stream supports the mark and reset methods.

marshal(Link) - Method in class javax.ws.rs.core.Link.JaxbAdapter

Convert a Link into a Link.JaxbLink.

marshal(String) - Method in class javax.xml.bind.annotation.adapters.CollapsedStringAdapter

No-op.

marshal(byte[]) - Method in class javax.xml.bind.annotation.adapters.HexBinaryAdapter

marshal(String) - Method in class javax.xml.bind.annotation.adapters.NormalizedStringAdapter

No-op.

marshal(BoundType) - Method in class javax.xml.bind.annotation.adapters.XmlAdapter

Convert a bound type to a value type.

marshal(ElementT, ValidationEventHandler) - Method in interface javax.xml.bind.annotation.DomHandler

This method is called when a JAXB provider needs to marshal an element to XML.

marshal(Element, ValidationEventHandler) - Method in class javax.xml.bind.annotation.W3CDomHandler

marshal(Object, XmlNode) - Method in class javax.xml.bind.Binder

Marshal a JAXB object tree to a new XML document.

marshal(Object, OutputStream) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

marshal(Object, File) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

marshal(Object, Writer) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

marshal(Object, ContentHandler) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

marshal(Object, Node) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

marshal(Object, XMLEventWriter) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

marshal(Object, XMLStreamWriter) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

marshal(Object, File) - Static method in class javax.xml.bind.JAXB

Writes a Java object tree to XML and store it to the specified location.

marshal(Object, URL) - Static method in class javax.xml.bind.JAXB

Writes a Java object tree to XML and store it to the specified location.

marshal(Object, URI) - Static method in class javax.xml.bind.JAXB

Writes a Java object tree to XML and store it to the specified location.

marshal(Object, String) - Static method in class javax.xml.bind.JAXB

Writes a Java object tree to XML and store it to the specified location.

marshal(Object, OutputStream) - Static method in class javax.xml.bind.JAXB

Writes a Java object tree to XML and store it to the specified location.

marshal(Object, Writer) - Static method in class javax.xml.bind.JAXB

Writes a Java object tree to XML and store it to the specified location.

marshal(Object, Result) - Static method in class javax.xml.bind.JAXB

Writes a Java object tree to XML and store it to the specified location.

marshal(Object, Result) - Method in interface javax.xml.bind.Marshaller

Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.

marshal(Object, OutputStream) - Method in interface javax.xml.bind.Marshaller

Marshal the content tree rooted at jaxbElement into an output stream.

marshal(Object, File) - Method in interface javax.xml.bind.Marshaller

Marshal the content tree rooted at jaxbElement into a file.

marshal(Object, Writer) - Method in interface javax.xml.bind.Marshaller

Marshal the content tree rooted at jaxbElement into a Writer.

marshal(Object, ContentHandler) - Method in interface javax.xml.bind.Marshaller

Marshal the content tree rooted at jaxbElement into SAX2 events.

marshal(Object, Node) - Method in interface javax.xml.bind.Marshaller

Marshal the content tree rooted at jaxbElement into a DOM tree.

marshal(Object, XMLStreamWriter) - Method in interface javax.xml.bind.Marshaller

Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.

marshal(Object, XMLEventWriter) - Method in interface javax.xml.bind.Marshaller

Marshal the content tree rooted at jaxbElement into a XMLEventWriter.

MarshalException - Exception in javax.xml.bind

This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.

MarshalException(String) - Constructor for exception javax.xml.bind.MarshalException

Construct a MarshalException with the specified detail message.

MarshalException(String, String) - Constructor for exception javax.xml.bind.MarshalException

Construct a MarshalException with the specified detail message and vendor specific errorCode.

MarshalException(Throwable) - Constructor for exception javax.xml.bind.MarshalException

Construct a MarshalException with a linkedException.

MarshalException(String, Throwable) - Constructor for exception javax.xml.bind.MarshalException

Construct a MarshalException with the specified detail message and linkedException.

MarshalException(String, String, Throwable) - Constructor for exception javax.xml.bind.MarshalException

Construct a MarshalException with the specified detail message, vendor specific errorCode, and linkedException.

Marshaller - Interface in javax.xml.bind

The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.

Marshaller.Listener - Class in javax.xml.bind

Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.

Marshaller.Listener() - Constructor for class javax.xml.bind.Marshaller.Listener

match(ContentType) - Method in class javax.mail.internet.ContentType

Match with the specified ContentType object.

match(String) - Method in class javax.mail.internet.ContentType

Match with the specified content-type string.

match(SearchTerm) - Method in class javax.mail.Message

Apply the specified Search criterion to this message.

match(Address) - Method in class javax.mail.search.AddressStringTerm

Check whether the address pattern specified in the constructor is a substring of the string representation of the given Address object.

match(Address) - Method in class javax.mail.search.AddressTerm

Match against the argument Address.

match(Message) - Method in class javax.mail.search.AndTerm

The AND operation.

match(Message) - Method in class javax.mail.search.BodyTerm

The match method.

match(Date) - Method in class javax.mail.search.DateTerm

The date comparison method.

match(Message) - Method in class javax.mail.search.FlagTerm

The comparison method.

match(Message) - Method in class javax.mail.search.FromStringTerm

Check whether the address string specified in the constructor is a substring of the From address of this Message.

match(Message) - Method in class javax.mail.search.FromTerm

The address comparator.

match(Message) - Method in class javax.mail.search.HeaderTerm

The header match method.

match(int) - Method in class javax.mail.search.IntegerComparisonTerm

match(Message) - Method in class javax.mail.search.MessageIDTerm

The match method.

match(Message) - Method in class javax.mail.search.MessageNumberTerm

The match method.

match(Message) - Method in class javax.mail.search.NotTerm

match(Message) - Method in class javax.mail.search.OrTerm

The OR operation.

match(Message) - Method in class javax.mail.search.ReceivedDateTerm

The match method.

match(Message) - Method in class javax.mail.search.RecipientStringTerm

Check whether the address specified in the constructor is a substring of the recipient address of this Message.

match(Message) - Method in class javax.mail.search.RecipientTerm

The match method.

match(Message) - Method in class javax.mail.search.SearchTerm

This method applies a specific match criterion to the given message and returns the result.

match(Message) - Method in class javax.mail.search.SentDateTerm

The match method.

match(Message) - Method in class javax.mail.search.SizeTerm

The match method.

match(String) - Method in class javax.mail.search.StringTerm

match(Message) - Method in class javax.mail.search.SubjectTerm

The match method.

MATCH_EXCEPTION_MESSAGE_ID - Static variable in class javax.faces.validator.RegexValidator

The message identifier of the FacesMessage to be created if the act of matching the value against the pattern returned from RegexValidator.getPattern() fails because of a PatternSyntaxException.

matchManagedConnections(Set, Subject, ConnectionRequestInfo) - Method in interface javax.resource.spi.ManagedConnectionFactory

Returns a matched connection from the candidate set of connections.

matrixParam(String, Object...) - Method in interface javax.ws.rs.client.WebTarget

Create a new WebTarget instance by appending a matrix parameter to the existing set of matrix parameters of the current final segment of the URI of the current target instance.

matrixParam(String, Object...) - Method in class javax.ws.rs.core.UriBuilder

Append a matrix parameter to the existing set of matrix parameters of the current final segment of the URI path.

MatrixParam - Annotation Type in javax.ws.rs

Binds the value(s) of a URI matrix parameter to a resource method parameter, resource class field, or resource class bean property.

max(Expression<N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an aggregate expression applying the numerical max operation.

Max - Annotation Type in javax.validation.constraints

The annotated element must be a number whose value must be lower or equal to the specified maximum.

Max.List - Annotation Type in javax.validation.constraints

Defines several Max annotations on the same element.

MAXBQUALSIZE - Static variable in interface javax.transaction.xa.Xid

Maximum number of bytes returned by getBqual.

MAXGTRIDSIZE - Static variable in interface javax.transaction.xa.Xid

Maximum number of bytes returned by getGtrid.

MAXIMUM_MESSAGE_ID - Static variable in class javax.faces.validator.DoubleRangeValidator

The message identifier of the FacesMessage to be created if the maximum value check fails.

MAXIMUM_MESSAGE_ID - Static variable in class javax.faces.validator.LengthValidator

The message identifier of the FacesMessage to be created if the maximum length check fails.

MAXIMUM_MESSAGE_ID - Static variable in class javax.faces.validator.LongRangeValidator

The message identifier of the FacesMessage to be created if the maximum value check fails.

MEDIA_TYPE_WILDCARD - Static variable in class javax.ws.rs.core.MediaType

The value of a type or subtype wildcard ""*"".

MediaType - Class in javax.ws.rs.core

An abstraction for a media type.

MediaType(String, String, Map<String, String>) - Constructor for class javax.ws.rs.core.MediaType

Creates a new instance of MediaType with the supplied type, subtype and parameters.

MediaType(String, String) - Constructor for class javax.ws.rs.core.MediaType

Creates a new instance of MediaType with the supplied type and subtype.

MediaType(String, String, String) - Constructor for class javax.ws.rs.core.MediaType

Creates a new instance of MediaType with the supplied type, subtype and ""charset"" parameter.

MediaType() - Constructor for class javax.ws.rs.core.MediaType

Creates a new instance of MediaType, both type and subtype are wildcards.

mediaTypes(MediaType...) - Static method in class javax.ws.rs.core.Variant

Create a Variant.VariantListBuilder initialized with a set of supported media types.

mediaTypes(MediaType...) - Method in class javax.ws.rs.core.Variant.VariantListBuilder

Set the media type(s) for this variant.

merge(T) - Method in interface javax.persistence.EntityManager

Merge the state of the given entity into the current persistence context.

Message - Interface in javax.jms

The Message interface is the root interface of all JMS messages.

message - Variable in class javax.mail.event.StoreEvent

The message text to be presented to the user.

Message - Class in javax.mail

This class models an email message.

Message() - Constructor for class javax.mail.Message

No-arg version of the constructor.

Message(Folder, int) - Constructor for class javax.mail.Message

Constructor that takes a Folder and a message number.

Message(Session) - Constructor for class javax.mail.Message

Constructor that takes a Session.

Message.RecipientType - Class in javax.mail

This inner class defines the types of recipients allowed by the Message class.

Message.RecipientType(String) - Constructor for class javax.mail.Message.RecipientType

Constructor for use by subclasses.

MESSAGE_DELIVERED - Static variable in class javax.mail.event.TransportEvent

Message has been successfully delivered to all recipients by the transport firing this event.

MESSAGE_ID - Static variable in class javax.faces.validator.BeanValidator

The message identifier of the FacesMessage to be created if a constraint failure is found.

MESSAGE_NOT_DELIVERED - Static variable in class javax.mail.event.TransportEvent

Message was not sent for some reason.

MESSAGE_OUTBOUND_PROPERTY - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: message direction, true for outbound messages, false for inbound.

MESSAGE_PARTIALLY_DELIVERED - Static variable in class javax.mail.event.TransportEvent

Message was successfully sent to some recipients but not to all.

MessageAware - Interface in javax.mail

An interface optionally implemented by DataSources to supply information to a DataContentHandler about the message context in which the data content object is operating.

MessageBodyReader<T> - Interface in javax.ws.rs.ext

Contract for a provider that supports the conversion of a stream to a Java type.

MessageBodyWriter<T> - Interface in javax.ws.rs.ext

Contract for a provider that supports the conversion of a Java type to a stream.

messageChanged(MessageChangedEvent) - Method in interface javax.mail.event.MessageChangedListener

Invoked when a message is changed.

MessageChangedEvent - Class in javax.mail.event

This class models Message change events.

MessageChangedEvent(Object, int, Message) - Constructor for class javax.mail.event.MessageChangedEvent

Constructor.

MessageChangedListener - Interface in javax.mail.event

This is the Listener interface for MessageChanged events

MessageConsumer - Interface in javax.jms

A client uses a MessageConsumer object to receive messages from a destination.

MessageContext - Class in javax.mail

The context in which a piece of Message content is contained.

MessageContext(Part) - Constructor for class javax.mail.MessageContext

Create a MessageContext object describing the context of the given Part.

MessageContext - Interface in javax.xml.rpc.handler

The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

MessageContext - Interface in javax.xml.ws.handler

The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

MessageContext.Scope - Enum in javax.xml.ws.handler

Property scope.

MessageCountAdapter - Class in javax.mail.event

The adapter which receives MessageCount events.

MessageCountAdapter() - Constructor for class javax.mail.event.MessageCountAdapter

MessageCountEvent - Class in javax.mail.event

This class notifies changes in the number of messages in a folder.

MessageCountEvent(Folder, int, boolean, Message[]) - Constructor for class javax.mail.event.MessageCountEvent

Constructor.

MessageCountListener - Interface in javax.mail.event

This is the Listener interface for MessageCount events.

messageDelivered(TransportEvent) - Method in class javax.mail.event.TransportAdapter

messageDelivered(TransportEvent) - Method in interface javax.mail.event.TransportListener

Invoked when a Message is succesfully delivered.

MessageDriven - Annotation Type in javax.ejb

Component-defining annotation for a message driven bean.

MessageDrivenBean - Interface in javax.ejb

The MessageDrivenBean interface defines methods that the EJB container uses to notify a message driven bean instance of the instance's life cycle events.

MessageDrivenBeanStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a message driven bean.

MessageDrivenContext - Interface in javax.ejb

The MessageDrivenContext interface provides access to the runtime message-driven context that the container provides for a message-driven bean instance.

MessageEndpoint - Interface in javax.resource.spi.endpoint

This defines a contract for a message endpoint.

MessageEndpointFactory - Interface in javax.resource.spi.endpoint

This serves as a factory for creating message endpoints.

MessageEOFException - Exception in javax.jms

This exception must be thrown when an unexpected end of stream has been reached when a StreamMessage or BytesMessage is being read.

MessageEOFException(String, String) - Constructor for exception javax.jms.MessageEOFException

Constructs a MessageEOFException with the specified reason and error code.

MessageEOFException(String) - Constructor for exception javax.jms.MessageEOFException

Constructs a MessageEOFException with the specified reason.

MessageFactory - Class in javax.xml.soap

A factory for creating SOAPMessage objects.

MessageFactory() - Constructor for class javax.xml.soap.MessageFactory

MessageFormatException - Exception in javax.jms

This exception must be thrown when a JMS client attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type.

MessageFormatException(String, String) - Constructor for exception javax.jms.MessageFormatException

Constructs a MessageFormatException with the specified reason and error code.

MessageFormatException(String) - Constructor for exception javax.jms.MessageFormatException

Constructs a MessageFormatException with the specified reason.

MessageFormatRuntimeException - Exception in javax.jms

This unchecked exception must be thrown when a JMS application attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type, and the method signature does not permit a MessageFormatException to be thrown.

MessageFormatRuntimeException(String) - Constructor for exception javax.jms.MessageFormatRuntimeException

Constructs a MessageFormatRuntimeException with the specified detail message

MessageFormatRuntimeException(String, String) - Constructor for exception javax.jms.MessageFormatRuntimeException

Constructs a MessageFormatRuntimeException with the specified detail message and error code.

MessageFormatRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.MessageFormatRuntimeException

Constructs a MessageFormatRuntimeException with the specified detail message, error code and cause

MessageHandler - Interface in javax.websocket

Developers implement MessageHandlers in order to receive incoming messages during a web socket conversation.

MessageHandler.Partial<T> - Interface in javax.websocket

This kind of handler is notified by the implementation as it becomes ready to deliver parts of a whole message.

MessageHandler.Whole<T> - Interface in javax.websocket

This kind of handler is notified by the container on arrival of a complete message.

MessageIDTerm - Class in javax.mail.search

This term models the RFC822 "MessageId" - a message-id for Internet messages that is supposed to be unique per message.

MessageIDTerm(String) - Constructor for class javax.mail.search.MessageIDTerm

Constructor.

MessageInfo - Interface in javax.security.auth.message

A message processing runtime uses this interface to pass messages and message processing state to authentication contexts for processing by authentication modules.

messageInterpolator(MessageInterpolator) - Method in interface javax.validation.Configuration

Defines the message interpolator used.

MessageInterpolator - Interface in javax.validation

Interpolates a given constraint violation message.

messageInterpolator(MessageInterpolator) - Method in interface javax.validation.ValidatorContext

Defines the message interpolator implementation used by the Validator.

MessageInterpolator.Context - Interface in javax.validation

Information related to the interpolation context.

MessageListener - Interface in javax.jms

A MessageListener object is used to receive asynchronously delivered messages.

MessageListener - Interface in javax.resource.cci

This serves as a request-response message listener type that message endpoints (message-driven beans) may implement.

messageNotDelivered(TransportEvent) - Method in class javax.mail.event.TransportAdapter

messageNotDelivered(TransportEvent) - Method in interface javax.mail.event.TransportListener

Invoked when a Message is not delivered.

MessageNotReadableException - Exception in javax.jms

This exception must be thrown when a JMS client attempts to read a write-only message.

MessageNotReadableException(String, String) - Constructor for exception javax.jms.MessageNotReadableException

Constructs a MessageNotReadableException with the specified reason and error code.

MessageNotReadableException(String) - Constructor for exception javax.jms.MessageNotReadableException

Constructs a MessageNotReadableException with the specified reason.

MessageNotWriteableException - Exception in javax.jms

This exception must be thrown when a JMS client attempts to write to a read-only message.

MessageNotWriteableException(String, String) - Constructor for exception javax.jms.MessageNotWriteableException

Constructs a MessageNotWriteableException with the specified reason and error code.

MessageNotWriteableException(String) - Constructor for exception javax.jms.MessageNotWriteableException

Constructs a MessageNotWriteableException with the specified reason.

MessageNotWriteableRuntimeException - Exception in javax.jms

This unchecked exception must be thrown when a JMS client attempts to write to a read-only message.

MessageNotWriteableRuntimeException(String, String) - Constructor for exception javax.jms.MessageNotWriteableRuntimeException

Constructs a MessageNotWriteableRuntimeException with the specified reason and error code.

MessageNotWriteableRuntimeException(String) - Constructor for exception javax.jms.MessageNotWriteableRuntimeException

Constructs a MessageNotWriteableRuntimeException with the specified reason.

MessageNotWriteableRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.MessageNotWriteableRuntimeException

Constructs a MessageNotWriteableRuntimeException with the specified detail message, error code and cause

MessageNumberTerm - Class in javax.mail.search

This class implements comparisons for Message numbers.

MessageNumberTerm(int) - Constructor for class javax.mail.search.MessageNumberTerm

Constructor.

messagePartiallyDelivered(TransportEvent) - Method in class javax.mail.event.TransportAdapter

messagePartiallyDelivered(TransportEvent) - Method in interface javax.mail.event.TransportListener

Invoked when a Message is partially delivered.

MessagePolicy - Class in javax.security.auth.message

This class defines a message authentication policy.

MessagePolicy(MessagePolicy.TargetPolicy[], boolean) - Constructor for class javax.security.auth.message.MessagePolicy

Create a MessagePolicy instance with an array of target policies.

MessagePolicy.ProtectionPolicy - Interface in javax.security.auth.message

This interface is used to represent message authentication policy.

MessagePolicy.Target - Interface in javax.security.auth.message

This interface is used to represent and perform message targeting.

MessagePolicy.TargetPolicy - Class in javax.security.auth.message

This class defines the message protection policies for specific Targets.

MessagePolicy.TargetPolicy(MessagePolicy.Target[], MessagePolicy.ProtectionPolicy) - Constructor for class javax.security.auth.message.MessagePolicy.TargetPolicy

Create a TargetPolicy instance with an array of Targets and with a ProtectionPolicy.

MessageProducer - Interface in javax.jms

A client uses a MessageProducer object to send messages to a destination.

MessageRemovedException - Exception in javax.mail

The exception thrown when an invalid method is invoked on an expunged Message.

MessageRemovedException() - Constructor for exception javax.mail.MessageRemovedException

Constructs a MessageRemovedException with no detail message.

MessageRemovedException(String) - Constructor for exception javax.mail.MessageRemovedException

Constructs a MessageRemovedException with the specified detail message.

MessageRemovedException(String, Exception) - Constructor for exception javax.mail.MessageRemovedException

Constructs a MessageRemovedException with the specified detail message and embedded exception.

messagesAdded(MessageCountEvent) - Method in class javax.mail.event.MessageCountAdapter

messagesAdded(MessageCountEvent) - Method in interface javax.mail.event.MessageCountListener

Invoked when messages are added into a folder.

messagesRemoved(MessageCountEvent) - Method in class javax.mail.event.MessageCountAdapter

messagesRemoved(MessageCountEvent) - Method in interface javax.mail.event.MessageCountListener

Invoked when messages are removed (expunged) from a folder.

MessagingException - Exception in javax.mail

The base class for all exceptions thrown by the Messaging classes

MessagingException() - Constructor for exception javax.mail.MessagingException

Constructs a MessagingException with no detail message.

MessagingException(String) - Constructor for exception javax.mail.MessagingException

Constructs a MessagingException with the specified detail message.

MessagingException(String, Exception) - Constructor for exception javax.mail.MessagingException

Constructs a MessagingException with the specified Exception and detail message.

Metadata - Class in javax.faces.view.facelets

There are concrete subclasses within the implementation that map concepts in the Facelet VDL page to JSF Java API calls the appropriate instances.

Metadata() - Constructor for class javax.faces.view.facelets.Metadata

metadata(Element) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.

METADATA_FACET_NAME - Static variable in class javax.faces.component.UIViewRoot

MetadataTarget - Class in javax.faces.view.facelets

Information used with MetaRule for determining how and what Metadata should be wired.

MetadataTarget() - Constructor for class javax.faces.view.facelets.MetadataTarget

Metamodel - Interface in javax.persistence.metamodel

Provides access to the metamodel of persistent entities in the persistence unit.

MetaRule - Class in javax.faces.view.facelets

The root class of the abstraction that dictates how attributes on a markup element in a Facelets VDL page are wired to the JSF API object instance associated with that element.

MetaRule() - Constructor for class javax.faces.view.facelets.MetaRule

MetaRuleset - Class in javax.faces.view.facelets

A mutable set of rules to be used in auto-wiring state to a particular object instance.

MetaRuleset() - Constructor for class javax.faces.view.facelets.MetaRuleset

MetaTagHandler - Class in javax.faces.view.facelets

Every kind of markup element in Facelets VDL that has attributes that need to take action on a JSF Java API artifact is associated with an instance of this class.

MetaTagHandler(TagConfig) - Constructor for class javax.faces.view.facelets.MetaTagHandler

method(String) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke an arbitrary method for the current request asynchronously.

method(String, Class<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke an arbitrary method for the current request asynchronously.

method(String, GenericType<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke an arbitrary method for the current request asynchronously.

method(String, InvocationCallback<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke an arbitrary method for the current request asynchronously.

method(String, Entity<?>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke an arbitrary method for the current request asynchronously.

method(String, Entity<?>, Class<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke an arbitrary method for the current request asynchronously.

method(String, Entity<?>, GenericType<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke an arbitrary method for the current request asynchronously.

method(String, Entity<?>, InvocationCallback<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke an arbitrary method for the current request asynchronously.

method(String) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke an arbitrary method for the current request synchronously.

method(String, Class<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke an arbitrary method for the current request synchronously.

method(String, GenericType<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke an arbitrary method for the current request synchronously.

method(String, Entity<?>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke an arbitrary method for the current request synchronously.

method(String, Entity<?>, Class<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke an arbitrary method for the current request synchronously.

method(String, Entity<?>, GenericType<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke an arbitrary method for the current request synchronously.

MethodBinding - Class in javax.faces.el

Deprecated.
This has been replaced by MethodExpression.

MethodBinding() - Constructor for class javax.faces.el.MethodBinding

Deprecated.

MethodCallBuilder - Class in javax.faces.flow.builder

Create a method call node in the current Flow.

MethodCallBuilder() - Constructor for class javax.faces.flow.builder.MethodCallBuilder

methodCallNode(String) - Method in class javax.faces.flow.builder.FlowBuilder

Define a method call node.

MethodCallNode - Class in javax.faces.flow

Represents a method call node in the flow graph.

MethodCallNode() - Constructor for class javax.faces.flow.MethodCallNode

MethodDescriptor - Interface in javax.validation.metadata

Describes a validated method.

MethodExpression - Class in javax.el

An Expression that refers to a method on an object.

MethodExpression() - Constructor for class javax.el.MethodExpression

MethodExpressionActionListener - Class in javax.faces.event

MethodExpressionActionListener is an ActionListener that wraps a MethodExpression.

MethodExpressionActionListener() - Constructor for class javax.faces.event.MethodExpressionActionListener

MethodExpressionActionListener(MethodExpression) - Constructor for class javax.faces.event.MethodExpressionActionListener

Construct a ValueChangeListener that contains a MethodExpression.

MethodExpressionActionListener(MethodExpression, MethodExpression) - Constructor for class javax.faces.event.MethodExpressionActionListener

MethodExpressionValidator - Class in javax.faces.validator

MethodExpressionValidator is a Validator that wraps a MethodExpression, and it performs validation by executing a method on an object identified by the MethodExpression.

MethodExpressionValidator() - Constructor for class javax.faces.validator.MethodExpressionValidator

MethodExpressionValidator(MethodExpression) - Constructor for class javax.faces.validator.MethodExpressionValidator

Construct a Validator that contains a MethodExpression.

MethodExpressionValueChangeListener - Class in javax.faces.event

MethodExpressionValueChangeListener is a ValueChangeListener that wraps a MethodExpression.

MethodExpressionValueChangeListener() - Constructor for class javax.faces.event.MethodExpressionValueChangeListener

MethodExpressionValueChangeListener(MethodExpression) - Constructor for class javax.faces.event.MethodExpressionValueChangeListener

Construct a ValueChangeListener that contains a MethodExpression.To accomodate method expression targets that take no arguments instead of taking a ValueChangeEvent argument, the implementation of this class must take the argument methodExpressionOneArg, extract its expression string, and create another MethodExpression whose expected param types match those of a zero argument method.

MethodExpressionValueChangeListener(MethodExpression, MethodExpression) - Constructor for class javax.faces.event.MethodExpressionValueChangeListener

Construct a ValueChangeListener that contains a MethodExpression.

MethodInfo - Class in javax.el

Holds information about a method that a MethodExpression evaluated to.

MethodInfo(String, Class<?>, Class<?>[]) - Constructor for class javax.el.MethodInfo

Creates a new instance of MethodInfo with the given information.

MethodNotFoundException - Exception in javax.el

Thrown when a method could not be found while evaluating a MethodExpression.

MethodNotFoundException() - Constructor for exception javax.el.MethodNotFoundException

Creates a MethodNotFoundException with no detail message.

MethodNotFoundException(String) - Constructor for exception javax.el.MethodNotFoundException

Creates a MethodNotFoundException with the provided detail message.

MethodNotFoundException(Throwable) - Constructor for exception javax.el.MethodNotFoundException

Creates a MethodNotFoundException with the given root cause.

MethodNotFoundException(String, Throwable) - Constructor for exception javax.el.MethodNotFoundException

Creates a MethodNotFoundException with the given detail message and root cause.

MethodNotFoundException - Exception in javax.faces.el

Deprecated.
This has been replaced by MethodNotFoundException.

MethodNotFoundException() - Constructor for exception javax.faces.el.MethodNotFoundException

Deprecated.

Construct a new exception with no detail message or root cause.

MethodNotFoundException(String) - Constructor for exception javax.faces.el.MethodNotFoundException

Deprecated.

Construct a new exception with the specified detail message and no root cause.

MethodNotFoundException(Throwable) - Constructor for exception javax.faces.el.MethodNotFoundException

Deprecated.

Construct a new exception with the specified root cause.

MethodNotFoundException(String, Throwable) - Constructor for exception javax.faces.el.MethodNotFoundException

Deprecated.

Construct a new exception with the specified detail message and root cause.

MethodNotSupportedException - Exception in javax.mail

The exception thrown when a method is not supported by the implementation

MethodNotSupportedException() - Constructor for exception javax.mail.MethodNotSupportedException

Constructs a MethodNotSupportedException with no detail message.

MethodNotSupportedException(String) - Constructor for exception javax.mail.MethodNotSupportedException

Constructs a MethodNotSupportedException with the specified detail message.

MethodNotSupportedException(String, Exception) - Constructor for exception javax.mail.MethodNotSupportedException

Constructs a MethodNotSupportedException with the specified detail message and embedded exception.

MethodType - Enum in javax.validation.metadata

Represents the type of a method: getter or non getter.

Metric - Interface in javax.batch.runtime

The Metric interface defines job metrics recorded by the batch runtime.

Metric.MetricType - Enum in javax.batch.runtime

MIME - Static variable in class javax.mail.internet.HeaderTokenizer

MIME specials

MimeBodyPart - Class in javax.mail.internet

This class represents a MIME body part.

MimeBodyPart() - Constructor for class javax.mail.internet.MimeBodyPart

An empty MimeBodyPart object is created.

MimeBodyPart(InputStream) - Constructor for class javax.mail.internet.MimeBodyPart

Constructs a MimeBodyPart by reading and parsing the data from the specified input stream.

MimeBodyPart(InternetHeaders, byte[]) - Constructor for class javax.mail.internet.MimeBodyPart

Constructs a MimeBodyPart using the given header and content bytes.

mimeCharset(String) - Static method in class javax.mail.internet.MimeUtility

Convert a java charset into its MIME charset name.

MimeHeader - Class in javax.xml.soap

An object that stores a MIME header name and its value.

MimeHeader(String, String) - Constructor for class javax.xml.soap.MimeHeader

Constructs a MimeHeader object initialized with the given name and value.

MimeHeaders - Class in javax.xml.soap

A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.

MimeHeaders() - Constructor for class javax.xml.soap.MimeHeaders

Constructs a default MimeHeaders object initialized with an empty Vector object.

MimeMessage - Class in javax.mail.internet

This class represents a MIME style email message.

MimeMessage(Session) - Constructor for class javax.mail.internet.MimeMessage

Default constructor.

MimeMessage(Session, InputStream) - Constructor for class javax.mail.internet.MimeMessage

Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.

MimeMessage(MimeMessage) - Constructor for class javax.mail.internet.MimeMessage

Constructs a new MimeMessage with content initialized from the source MimeMessage.

MimeMessage(Folder, int) - Constructor for class javax.mail.internet.MimeMessage

Constructs an empty MimeMessage object with the given Folder and message number.

MimeMessage(Folder, InputStream, int) - Constructor for class javax.mail.internet.MimeMessage

Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.

MimeMessage(Folder, InternetHeaders, byte[], int) - Constructor for class javax.mail.internet.MimeMessage

Constructs a MimeMessage from the given InternetHeaders object and content.

MimeMessage.RecipientType - Class in javax.mail.internet

This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes.

MimeMessage.RecipientType(String) - Constructor for class javax.mail.internet.MimeMessage.RecipientType

MimeMultipart - Class in javax.mail.internet

The MimeMultipart class is an implementation of the abstract Multipart class that uses MIME conventions for the multipart data.

MimeMultipart() - Constructor for class javax.mail.internet.MimeMultipart

Default constructor.

MimeMultipart(String) - Constructor for class javax.mail.internet.MimeMultipart

Construct a MimeMultipart object of the given subtype.

MimeMultipart(BodyPart...) - Constructor for class javax.mail.internet.MimeMultipart

Construct a MimeMultipart object of the default "mixed" subtype, and with the given body parts.

MimeMultipart(String, BodyPart...) - Constructor for class javax.mail.internet.MimeMultipart

Construct a MimeMultipart object of the given subtype and with the given body parts.

MimeMultipart(DataSource) - Constructor for class javax.mail.internet.MimeMultipart

Constructs a MimeMultipart object and its bodyparts from the given DataSource.

MimePart - Interface in javax.mail.internet

The MimePart interface models an Entity as defined by MIME (RFC2045, Section 2.4).

MimePartDataSource - Class in javax.mail.internet

A utility class that implements a DataSource out of a MimePart.

MimePartDataSource(MimePart) - Constructor for class javax.mail.internet.MimePartDataSource

Constructor, that constructs a DataSource from a MimePart.

MimeUtility - Class in javax.mail.internet

This is a utility class that provides various MIME related functionality.

min(Expression<N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an aggregate expression applying the numerical min operation.

Min - Annotation Type in javax.validation.constraints

The annotated element must be a number whose value must be higher or equal to the specified minimum.

Min.List - Annotation Type in javax.validation.constraints

Defines several Min annotations on the same element.

MINIMUM_MESSAGE_ID - Static variable in class javax.faces.validator.DoubleRangeValidator

The message identifier of the FacesMessage to be created if the minimum value check fails.

MINIMUM_MESSAGE_ID - Static variable in class javax.faces.validator.LengthValidator

The message identifier of the FacesMessage to be created if the minimum length check fails.

MINIMUM_MESSAGE_ID - Static variable in class javax.faces.validator.LongRangeValidator

The message identifier of the FacesMessage to be created if the minimum value check fails.

minute(String) - Method in class javax.ejb.ScheduleExpression

Set the minute attribute.

minute(int) - Method in class javax.ejb.ScheduleExpression

Set the minute attribute.

mod(Expression<Integer>, Expression<Integer>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the modulus of its arguments.

mod(Expression<Integer>, Integer) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the modulus of its arguments.

mod(Integer, Expression<Integer>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the modulus of its arguments.

mode - Variable in class javax.mail.Folder

The open mode of this folder.

Model - Annotation Type in javax.enterprise.inject

The built-in stereotype intended for use with beans that define the model layer of an MVC web application architecture such as JSF.

modified - Variable in class javax.mail.internet.MimeMessage

A flag indicating whether the message has been modified.

modifyHandshake(ServerEndpointConfig, HandshakeRequest, HandshakeResponse) - Method in class javax.websocket.server.ServerEndpointConfig.Configurator

Called by the container after it has formulated a handshake response resulting from a well-formed handshake request.

MODULES - Static variable in class javax.ejb.embeddable.EJBContainer

Standard property name for specifying the set of modules to be initialized.

ModuleType - Class in javax.enterprise.deploy.shared

Class ModuleTypes defines enumeration values for the Java EE module types.

ModuleType(int) - Constructor for class javax.enterprise.deploy.shared.ModuleType

Construct a new enumeration value with the given integer value.

month(String) - Method in class javax.ejb.ScheduleExpression

Set the month attribute.

month(int) - Method in class javax.ejb.ScheduleExpression

Set the month attribute.

msg - Variable in class javax.mail.event.MessageChangedEvent

The message that changed.

msg - Variable in class javax.mail.event.TransportEvent

msgnum - Variable in class javax.mail.Message

The number of this message within its folder, or zero if the message was not retrieved from a folder.

msgs - Variable in class javax.mail.event.MessageCountEvent

The messages.

MTOM - Annotation Type in javax.xml.ws.soap

This feature represents the use of MTOM with a web service.

MTOMFeature - Class in javax.xml.ws.soap

This feature represents the use of MTOM with a web service.

MTOMFeature() - Constructor for class javax.xml.ws.soap.MTOMFeature

Create an MTOMFeature.

MTOMFeature(boolean) - Constructor for class javax.xml.ws.soap.MTOMFeature

Creates an MTOMFeature.

MTOMFeature(int) - Constructor for class javax.xml.ws.soap.MTOMFeature

Creates an MTOMFeature.

MTOMFeature(boolean, int) - Constructor for class javax.xml.ws.soap.MTOMFeature

Creates an MTOMFeature.

Multipart - Class in javax.mail

Multipart is a container that holds multiple body parts.

Multipart() - Constructor for class javax.mail.Multipart

Default constructor.

MULTIPART_FORM_DATA - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""multipart/form-data"" media type.

MULTIPART_FORM_DATA_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""multipart/form-data"" media type.

MultipartConfig - Annotation Type in javax.servlet.annotation

Annotation that may be specified on a Servlet class, indicating that instances of the Servlet expect requests that conform to the multipart/form-data MIME type.

MultipartConfigElement - Class in javax.servlet

Java Class represntation of an MultipartConfig annotation value.

MultipartConfigElement(String) - Constructor for class javax.servlet.MultipartConfigElement

Constructs an instance with defaults for all but location.

MultipartConfigElement(String, long, long, int) - Constructor for class javax.servlet.MultipartConfigElement

Constructs an instance with all values specified.

MultipartConfigElement(MultipartConfig) - Constructor for class javax.servlet.MultipartConfigElement

Constructs an instance from a MultipartConfig annotation value.

MultipartDataSource - Interface in javax.mail

MultipartDataSource is a DataSource that contains body parts.

multiselect(Selection<?>...) - Method in interface javax.persistence.criteria.CriteriaQuery

Specify the selection items that are to be returned in the query result.

multiselect(List<Selection<?>>) - Method in interface javax.persistence.criteria.CriteriaQuery

Specify the selection items that are to be returned in the query result.

MultivaluedHashMap<K,V> - Class in javax.ws.rs.core

A hash table based implementation of MultivaluedMap interface.

MultivaluedHashMap() - Constructor for class javax.ws.rs.core.MultivaluedHashMap

Constructs an empty multivalued hash map with the default initial capacity (16) and the default load factor (0.75).

MultivaluedHashMap(int) - Constructor for class javax.ws.rs.core.MultivaluedHashMap

Constructs an empty multivalued hash map with the specified initial capacity and the default load factor (0.75).

MultivaluedHashMap(int, float) - Constructor for class javax.ws.rs.core.MultivaluedHashMap

Constructs an empty multivalued hash map with the specified initial capacity and load factor.

MultivaluedHashMap(MultivaluedMap<? extends K, ? extends V>) - Constructor for class javax.ws.rs.core.MultivaluedHashMap

Constructs a new multivalued hash map with the same mappings as the specified MultivaluedMap.

MultivaluedHashMap(Map<? extends K, ? extends V>) - Constructor for class javax.ws.rs.core.MultivaluedHashMap

Constructs a new multivalued hash map with the same mappings as the specified single-valued Map.

MultivaluedMap<K,V> - Interface in javax.ws.rs.core

A map of key-values pairs.

N

name - Variable in class javax.mail.Header

The name of the header.

name - Variable in class javax.mail.Quota.Resource

The name of the resource.

name - Variable in class javax.resource.spi.work.HintsContext

name - Variable in class javax.xml.bind.JAXBElement

xml element tag name

Name - Interface in javax.xml.soap

A representation of an XML name.

NAME_HINT - Static variable in class javax.resource.spi.work.HintsContext

NameBinding - Annotation Type in javax.ws.rs

Meta-annotation used to create name binding annotations for filters and interceptors.

Named - Annotation Type in javax.inject

String-based qualifier.

NamedAttributeNode - Annotation Type in javax.persistence

A NamedAttributeNode is a member element of a NamedEntityGraph.

NamedEntityGraph - Annotation Type in javax.persistence

Used to specify the path and boundaries for a find operation or query.

NamedEntityGraphs - Annotation Type in javax.persistence

Used to group NamedEntityGraph annotations.

NamedEvent - Annotation Type in javax.faces.event

The presence of this annotation on a class automatically registers the class with the runtime as a ComponentSystemEvent for use with the <f:event /> tag in a page.

NamedNativeQueries - Annotation Type in javax.persistence

Specifies multiple native SQL named queries.

NamedNativeQuery - Annotation Type in javax.persistence

Specifies a named native SQL query.

NamedQueries - Annotation Type in javax.persistence

Specifies multiple named Java Persistence query language queries.

NamedQuery - Annotation Type in javax.persistence

Specifies a static, named query in the Java Persistence query language.

NamedStoredProcedureQueries - Annotation Type in javax.persistence

Specifies multiple named stored procedure queries.

NamedStoredProcedureQuery - Annotation Type in javax.persistence

Specifies and names a stored procedure, its parameters, and its result type.

NamedSubgraph - Annotation Type in javax.persistence

A NamedSubgraph is a member element of a NamedEntityGraph.

NAMESPACE - Static variable in annotation type javax.faces.component.FacesComponent

Components that declare a createTag = true attribute will be placed into this tag namespace if the namespace attribute is omitted.

NamespaceConstants - Class in javax.xml.rpc

Constants used in JAX-RPC for namespace prefixes and URIs

NamespaceConstants() - Constructor for class javax.xml.rpc.NamespaceConstants

NamingContainer - Interface in javax.faces.component

NamingContainer is an interface that must be implemented by any UIComponent that wants to be a naming container.

NavigationCase - Class in javax.faces.application

NavigationCase represents a <navigation-case> in the navigation rule base, as well as the <from-view-id> with which this <navigation-case> is a sibling.

NavigationCase(String, String, String, String, String, Map<String, List<String>>, boolean, boolean) - Constructor for class javax.faces.application.NavigationCase

Construct a new NavigationCase based on the provided arguments.

NavigationCase(String, String, String, String, String, String, Map<String, List<String>>, boolean, boolean) - Constructor for class javax.faces.application.NavigationCase

Construct a new NavigationCase based on the provided arguments.

navigationCase() - Method in class javax.faces.flow.builder.FlowBuilder

Define a particular combination of conditions that must match for this case to be executed, and the view id of the component tree that should be selected next.

NavigationCaseBuilder - Class in javax.faces.flow.builder

Create a navigation case in the current Flow.

NavigationCaseBuilder() - Constructor for class javax.faces.flow.builder.NavigationCaseBuilder

NavigationCaseBuilder.RedirectBuilder - Class in javax.faces.flow.builder

Allows populating the redirect with parameters and setting the includeViewParams option.

NavigationCaseBuilder.RedirectBuilder() - Constructor for class javax.faces.flow.builder.NavigationCaseBuilder.RedirectBuilder

NavigationCaseWrapper - Class in javax.faces.application

Provides a simple implementation of NavigationCase that can be subclassed by developers wishing to provide specialized behavior to an existing NavigationCase instance.

NavigationCaseWrapper() - Constructor for class javax.faces.application.NavigationCaseWrapper

NavigationHandler - Class in javax.faces.application

A NavigationHandler is passed the outcome string returned by an application action invoked for this application, and will use this (along with related state information) to choose the view to be displayed next.

NavigationHandler() - Constructor for class javax.faces.application.NavigationHandler

NavigationHandlerWrapper - Class in javax.faces.application

NavigationHandlerWrapper provides a simple implementation of NavigationHandler that can be subclassed by developers wishing to provide specialized behavior to an existing NavigationHandler instance.

NavigationHandlerWrapper() - Constructor for class javax.faces.application.NavigationHandlerWrapper

NE - Static variable in class javax.mail.search.ComparisonTerm

neg(Expression<N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the arithmetic negation of its argument.

NESTED - Static variable in class javax.servlet.jsp.tagext.VariableInfo

Scope information that scripting variable is visible only within the start/end tags.

New - Annotation Type in javax.enterprise.inject

The New qualifier was deprecated in CDI 1.1.

newBuilder() - Static method in class javax.ws.rs.client.ClientBuilder

Create a new ClientBuilder instance using the default client builder implementation class provided by the JAX-RS implementation provider.

newClient() - Static method in class javax.ws.rs.client.ClientBuilder

Create a new Client instance using the default client builder implementation class provided by the JAX-RS implementation provider.

newClient(Configuration) - Static method in class javax.ws.rs.client.ClientBuilder

Create a new custom-configured Client instance using the default client builder implementation class provided by the JAX-RS implementation provider.

NewCookie - Class in javax.ws.rs.core

Used to create a new HTTP cookie, transferred in a response.

NewCookie(String, String) - Constructor for class javax.ws.rs.core.NewCookie

Create a new instance.

NewCookie(String, String, String, String, String, int, boolean) - Constructor for class javax.ws.rs.core.NewCookie

Create a new instance.

NewCookie(String, String, String, String, String, int, boolean, boolean) - Constructor for class javax.ws.rs.core.NewCookie

Create a new instance.

NewCookie(String, String, String, String, int, String, int, boolean) - Constructor for class javax.ws.rs.core.NewCookie

Create a new instance.

NewCookie(String, String, String, String, int, String, int, Date, boolean, boolean) - Constructor for class javax.ws.rs.core.NewCookie

Create a new instance.

NewCookie(Cookie) - Constructor for class javax.ws.rs.core.NewCookie

Create a new instance copying the information in the supplied cookie.

NewCookie(Cookie, String, int, boolean) - Constructor for class javax.ws.rs.core.NewCookie

Create a new instance supplementing the information in the supplied cookie.

NewCookie(Cookie, String, int, Date, boolean, boolean) - Constructor for class javax.ws.rs.core.NewCookie

Create a new instance supplementing the information in the supplied cookie.

newFolder - Variable in class javax.mail.event.FolderEvent

The folder that represents the new name, in case of a RENAMED event.

newInstance() - Static method in class javax.el.ExpressionFactory

Creates a new instance of a ExpressionFactory.

newInstance(Properties) - Static method in class javax.el.ExpressionFactory

Create a new instance of a ExpressionFactory, with optional properties.

newInstance() - Method in class javax.enterprise.inject.spi.Unmanaged

newInstance(URL) - Method in interface javax.faces.view.facelets.FaceletCache.MemberFactory

Create a Facelet or View Metadata Facelet (depending on the type of factory this is) for the argument URL.

newInstance() - Static method in class javax.ws.rs.core.Response.ResponseBuilder

Create a new builder instance.

newInstance() - Static method in class javax.ws.rs.core.UriBuilder

Creates a new instance of UriBuilder.

newInstance() - Static method in class javax.ws.rs.core.Variant.VariantListBuilder

Create a new builder instance.

newInstance(String) - Static method in class javax.xml.bind.JAXBContext

Obtain a new instance of a JAXBContext class.

newInstance(String, ClassLoader) - Static method in class javax.xml.bind.JAXBContext

Obtain a new instance of a JAXBContext class.

newInstance(String, ClassLoader, Map<String, ?>) - Static method in class javax.xml.bind.JAXBContext

Obtain a new instance of a JAXBContext class.

newInstance(Class...) - Static method in class javax.xml.bind.JAXBContext

Obtain a new instance of a JAXBContext class.

newInstance(Class[], Map<String, ?>) - Static method in class javax.xml.bind.JAXBContext

Obtain a new instance of a JAXBContext class.

newInstance() - Static method in class javax.xml.registry.ConnectionFactory

Creates a default ConnectionFactory object.

newInstance() - Static method in class javax.xml.rpc.ServiceFactory

Gets an instance of the ServiceFactory

newInstance() - Static method in class javax.xml.soap.MessageFactory

Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.

newInstance(String) - Static method in class javax.xml.soap.MessageFactory

Creates a new MessageFactory object that is an instance of the specified implementation.

newInstance() - Static method in class javax.xml.soap.SOAPConnectionFactory

Creates an instance of the default SOAPConnectionFactory object.

newInstance() - Static method in class javax.xml.soap.SOAPElementFactory

Deprecated.

Creates a new instance of SOAPElementFactory.

newInstance() - Static method in class javax.xml.soap.SOAPFactory

Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.

newInstance(String) - Static method in class javax.xml.soap.SOAPFactory

Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.

newLine() - Method in class javax.servlet.jsp.JspWriter

Write a line separator.

newMessageFactory(String) - Method in class javax.xml.soap.SAAJMetaFactory

Creates a MessageFactory object for the given String protocol.

NewsAddress - Class in javax.mail.internet

This class models an RFC1036 newsgroup address.

NewsAddress() - Constructor for class javax.mail.internet.NewsAddress

Default constructor.

NewsAddress(String) - Constructor for class javax.mail.internet.NewsAddress

Construct a NewsAddress with the given newsgroup.

NewsAddress(String, String) - Constructor for class javax.mail.internet.NewsAddress

Construct a NewsAddress with the given newsgroup and host.

newsgroup - Variable in class javax.mail.internet.NewsAddress

NEWSGROUPS - Static variable in class javax.mail.internet.MimeMessage.RecipientType

The "Newsgroup" (Usenet news) recipients.

newSOAPFactory(String) - Method in class javax.xml.soap.SAAJMetaFactory

Creates a SOAPFactory object for the given String protocol.

newStream(long, long) - Method in interface javax.mail.internet.SharedInputStream

Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive).

newStream(long, long) - Method in class javax.mail.util.SharedByteArrayInputStream

Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive).

newStream(long, long) - Method in class javax.mail.util.SharedFileInputStream

Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive).

next() - Method in interface javax.json.stream.JsonParser

Returns the event for the next parsing state.

next() - Method in class javax.mail.internet.HeaderTokenizer

Parses the next token from this String.

next(char) - Method in class javax.mail.internet.HeaderTokenizer

Parses the next token from this String.

next(char, boolean) - Method in class javax.mail.internet.HeaderTokenizer

Parses the next token from this String.

next() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Returns the next object over which the tag should iterate.

nextHandler - Variable in class javax.faces.view.facelets.TagHandler

A reference to the FaceletHandler that represents the first nested child of this TagHandler instance.

nil - Variable in class javax.xml.bind.JAXBElement

true iff the xml element instance has xsi:nil="true".

NO_BUFFER - Static variable in class javax.servlet.jsp.JspWriter

Constant indicating that the Writer is not buffering output.

NO_LOCATION - Static variable in annotation type javax.xml.bind.annotation.XmlSchema

The default value of the XmlSchema.location() attribute, which indicates that the schema generator will generate components in this namespace.

NO_TIMEOUT - Static variable in interface javax.ws.rs.container.AsyncResponse

Constant specifying no suspend timeout value.

noContent() - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder for an empty response.

NoContentException - Exception in javax.ws.rs.core

An I/O exception thrown by MessageBodyReader implementations when reading a zero-length message content to indicate that the message body reader is not able to produce an instance representing an zero-length message content.

NoContentException(String) - Constructor for exception javax.ws.rs.core.NoContentException

Construct a new NoContentException instance.

NoContentException(String, Throwable) - Constructor for exception javax.ws.rs.core.NoContentException

Construct a new NoContentException instance.

NoContentException(Throwable) - Constructor for exception javax.ws.rs.core.NoContentException

Construct a new NoContentException instance.

Node - Interface in javax.xml.soap

A representation of a node (element) in an XML document.

NodeBuilder - Interface in javax.faces.flow.builder

Base interface for building all kinds of flow nodes.

NoMoreTimeoutsException - Exception in javax.ejb

This exception indicates that a calendar-based timer will not result in any more timeouts.

NoMoreTimeoutsException() - Constructor for exception javax.ejb.NoMoreTimeoutsException

NoMoreTimeoutsException(String) - Constructor for exception javax.ejb.NoMoreTimeoutsException

NON_PERSISTENT - Static variable in interface javax.jms.DeliveryMode

This is the lowest-overhead delivery mode because it does not require that the message be logged to stable storage.

NON_POSTBACK_VIEW_TOKEN_PARAM - Static variable in class javax.faces.render.ResponseStateManager

The value of this constant is taken to be the name of a request parameter whose value is inspected to verify the safety of an incoming non-postback request with respect to the currently configured Set of protected views for this application.

Nonbinding - Annotation Type in javax.enterprise.util

Excludes a member of an annotation type (such as a qualifier type or interceptor binding type) from consideration when the container compares two annotation instances.

NoneScoped - Annotation Type in javax.faces.bean

When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>none<managed-bean-scope> element was declared for the corresponding managed bean.

NonexistentConversationException - Exception in javax.enterprise.context

Indicates that the conversation context could not be restored.

NonexistentConversationException() - Constructor for exception javax.enterprise.context.NonexistentConversationException

NonexistentConversationException(String) - Constructor for exception javax.enterprise.context.NonexistentConversationException

NonexistentConversationException(Throwable) - Constructor for exception javax.enterprise.context.NonexistentConversationException

NonexistentConversationException(String, Throwable) - Constructor for exception javax.enterprise.context.NonexistentConversationException

NonUniqueResultException - Exception in javax.persistence

Thrown by the persistence provider when Query.getSingleResult() or TypedQuery.getSingleResult() is executed on a query and there is more than one result from the query.

NonUniqueResultException() - Constructor for exception javax.persistence.NonUniqueResultException

Constructs a new NonUniqueResultException exception with null as its detail message.

NonUniqueResultException(String) - Constructor for exception javax.persistence.NonUniqueResultException

Constructs a new NonUniqueResultException exception with the specified detail message.

NoResultException - Exception in javax.persistence

Thrown by the persistence provider when Query.getSingleResult() or TypedQuery.getSingleResult()is executed on a query and there is no result to return.

NoResultException() - Constructor for exception javax.persistence.NoResultException

Constructs a new NoResultException exception with null as its detail message.

NoResultException(String) - Constructor for exception javax.persistence.NoResultException

Constructs a new NoResultException exception with the specified detail message.

NormalizedStringAdapter - Class in javax.xml.bind.annotation.adapters

XmlAdapter to handle xs:normalizedString.

NormalizedStringAdapter() - Constructor for class javax.xml.bind.annotation.adapters.NormalizedStringAdapter

NormalScope - Annotation Type in javax.enterprise.context

Specifies that an annotation type is a normal scope type.

NoSuchEJBException - Exception in javax.ejb

A NoSuchEJBException is thrown if an attempt is made to invoke a business method on a stateful session or singleton object that no longer exists.

NoSuchEJBException() - Constructor for exception javax.ejb.NoSuchEJBException

Constructs a NoSuchEJBException with no detail message.

NoSuchEJBException(String) - Constructor for exception javax.ejb.NoSuchEJBException

Constructs a NoSuchEJBException with the specified detail message.

NoSuchEJBException(String, Exception) - Constructor for exception javax.ejb.NoSuchEJBException

Constructs a NoSuchEJBException with the specified detail message and a nested exception.

NoSuchEntityException - Exception in javax.ejb

The NoSuchEntityException exception is thrown by an entity bean instance to its container to report that the invoked business method or callback method could not be completed because of the underlying entity was removed from the database.

NoSuchEntityException() - Constructor for exception javax.ejb.NoSuchEntityException

Constructs a NoSuchEntityException with no detail message.

NoSuchEntityException(String) - Constructor for exception javax.ejb.NoSuchEntityException

Constructs a NoSuchEntityException with the specified detailed message.

NoSuchEntityException(Exception) - Constructor for exception javax.ejb.NoSuchEntityException

Constructs a NoSuchEntityException that embeds the originally thrown exception.

NoSuchJobException - Exception in javax.batch.operations

NoSuchJobException() - Constructor for exception javax.batch.operations.NoSuchJobException

NoSuchJobException(String) - Constructor for exception javax.batch.operations.NoSuchJobException

NoSuchJobException(Throwable) - Constructor for exception javax.batch.operations.NoSuchJobException

NoSuchJobException(String, Throwable) - Constructor for exception javax.batch.operations.NoSuchJobException

NoSuchJobExecutionException - Exception in javax.batch.operations

NoSuchJobExecutionException() - Constructor for exception javax.batch.operations.NoSuchJobExecutionException

NoSuchJobExecutionException(String) - Constructor for exception javax.batch.operations.NoSuchJobExecutionException

NoSuchJobExecutionException(Throwable) - Constructor for exception javax.batch.operations.NoSuchJobExecutionException

NoSuchJobExecutionException(String, Throwable) - Constructor for exception javax.batch.operations.NoSuchJobExecutionException

NoSuchJobInstanceException - Exception in javax.batch.operations

NoSuchJobInstanceException() - Constructor for exception javax.batch.operations.NoSuchJobInstanceException

NoSuchJobInstanceException(String) - Constructor for exception javax.batch.operations.NoSuchJobInstanceException

NoSuchJobInstanceException(Throwable) - Constructor for exception javax.batch.operations.NoSuchJobInstanceException

NoSuchJobInstanceException(String, Throwable) - Constructor for exception javax.batch.operations.NoSuchJobInstanceException

NoSuchObjectLocalException - Exception in javax.ejb

A NoSuchObjectLocalException is thrown if an attempt is made to invoke a method on a local object (local EJB object or timer) that no longer exists.

NoSuchObjectLocalException() - Constructor for exception javax.ejb.NoSuchObjectLocalException

Constructs a NoSuchObjectLocalException with no detail message.

NoSuchObjectLocalException(String) - Constructor for exception javax.ejb.NoSuchObjectLocalException

Constructs a NoSuchObjectLocalException with the specified detail message.

NoSuchObjectLocalException(String, Exception) - Constructor for exception javax.ejb.NoSuchObjectLocalException

Constructs a NoSuchObjectLocalException with the specified detail message and a nested exception.

NoSuchProviderException - Exception in javax.mail

This exception is thrown when Session attempts to instantiate a Provider that doesn't exist.

NoSuchProviderException() - Constructor for exception javax.mail.NoSuchProviderException

Constructs a NoSuchProviderException with no detail message.

NoSuchProviderException(String) - Constructor for exception javax.mail.NoSuchProviderException

Constructs a NoSuchProviderException with the specified detail message.

NoSuchProviderException(String, Exception) - Constructor for exception javax.mail.NoSuchProviderException

Constructs a NoSuchProviderException with the specified detail message and embedded exception.

not(Expression<Boolean>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a negation of the given restriction.

not() - Method in interface javax.persistence.criteria.Predicate

Create a negation of the predicate.

NOT_IN_RANGE_MESSAGE_ID - Static variable in class javax.faces.validator.DoubleRangeValidator

The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set.

NOT_IN_RANGE_MESSAGE_ID - Static variable in class javax.faces.validator.LongRangeValidator

The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set.

NOT_IN_RANGE_MESSAGE_ID - Static variable in interface javax.faces.validator.Validator

Deprecated.
Use DoubleRangeValidator.NOT_IN_RANGE_MESSAGE_ID or LongRangeValidator.NOT_IN_RANGE_MESSAGE_ID instead.

NOT_MATCHED_MESSAGE_ID - Static variable in class javax.faces.validator.RegexValidator

The message identifier of the FacesMessage to be created if the act of matching the value against the pattern returned from RegexValidator.getPattern() fails because the value does not match the pattern.

notAcceptable(List<Variant>) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder for a not acceptable response.

NotAcceptableException - Exception in javax.ws.rs

A runtime exception indicating that a client request is not acceptable by the server.

NotAcceptableException() - Constructor for exception javax.ws.rs.NotAcceptableException

Construct a new "request not acceptable" exception.

NotAcceptableException(String) - Constructor for exception javax.ws.rs.NotAcceptableException

Construct a new "request not acceptable" exception.

NotAcceptableException(Response) - Constructor for exception javax.ws.rs.NotAcceptableException

Construct a new "request not acceptable" exception.

NotAcceptableException(String, Response) - Constructor for exception javax.ws.rs.NotAcceptableException

Construct a new "request not acceptable" exception.

NotAcceptableException(Throwable) - Constructor for exception javax.ws.rs.NotAcceptableException

Construct a new "request not acceptable" exception.

NotAcceptableException(String, Throwable) - Constructor for exception javax.ws.rs.NotAcceptableException

Construct a new "request not acceptable" exception.

NotAcceptableException(Response, Throwable) - Constructor for exception javax.ws.rs.NotAcceptableException

Construct a new "request not acceptable" exception.

NotAcceptableException(String, Response, Throwable) - Constructor for exception javax.ws.rs.NotAcceptableException

Construct a new "request not acceptable" exception.

NotAllowedException - Exception in javax.ws.rs

A runtime exception indicating a client requesting a resource method that is not allowed.

NotAllowedException(String, String...) - Constructor for exception javax.ws.rs.NotAllowedException

Construct a new method not allowed exception.

NotAllowedException(String, String, String...) - Constructor for exception javax.ws.rs.NotAllowedException

Construct a new method not allowed exception.

NotAllowedException(Response) - Constructor for exception javax.ws.rs.NotAllowedException

Construct a new method not allowed exception.

NotAllowedException(String, Response) - Constructor for exception javax.ws.rs.NotAllowedException

Construct a new method not allowed exception.

NotAllowedException(Throwable, String...) - Constructor for exception javax.ws.rs.NotAllowedException

Construct a new method not allowed exception.

NotAllowedException(String, Throwable, String...) - Constructor for exception javax.ws.rs.NotAllowedException

Construct a new method not allowed exception.

NotAllowedException(Response, Throwable) - Constructor for exception javax.ws.rs.NotAllowedException

Construct a new method not allowed exception.

NotAllowedException(String, Response, Throwable) - Constructor for exception javax.ws.rs.NotAllowedException

Construct a new method not allowed exception.

NotAuthorizedException - Exception in javax.ws.rs

A runtime exception indicating request authorization failure caused by one of the following scenarios: a client did not send the required authorization credentials to access the requested resource, i.e.

NotAuthorizedException(Object, Object...) - Constructor for exception javax.ws.rs.NotAuthorizedException

Construct a new "not authorized" exception.

NotAuthorizedException(String, Object, Object...) - Constructor for exception javax.ws.rs.NotAuthorizedException

Construct a new "not authorized" exception.

NotAuthorizedException(Response) - Constructor for exception javax.ws.rs.NotAuthorizedException

Construct a new "not authorized" exception.

NotAuthorizedException(String, Response) - Constructor for exception javax.ws.rs.NotAuthorizedException

Construct a new "not authorized" exception.

NotAuthorizedException(Throwable, Object, Object...) - Constructor for exception javax.ws.rs.NotAuthorizedException

Construct a new "not authorized" exception.

NotAuthorizedException(String, Throwable, Object, Object...) - Constructor for exception javax.ws.rs.NotAuthorizedException

Construct a new "not authorized" exception.

NotAuthorizedException(Response, Throwable) - Constructor for exception javax.ws.rs.NotAuthorizedException

Construct a new "not authorized" exception.

NotAuthorizedException(String, Response, Throwable) - Constructor for exception javax.ws.rs.NotAuthorizedException

Construct a new "not authorized" exception.

notEqual(Expression<?>, Expression<?>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing the arguments for inequality.

notEqual(Expression<?>, Object) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing the arguments for inequality.

NotFoundException - Exception in javax.ws.rs

A runtime exception indicating a resource requested by a client was not found on the server.

NotFoundException() - Constructor for exception javax.ws.rs.NotFoundException

Construct a new "not found" exception.

NotFoundException(String) - Constructor for exception javax.ws.rs.NotFoundException

Construct a new "not found" exception.

NotFoundException(Response) - Constructor for exception javax.ws.rs.NotFoundException

Construct a new "not found" exception.

NotFoundException(String, Response) - Constructor for exception javax.ws.rs.NotFoundException

Construct a new "not found" exception.

NotFoundException(Throwable) - Constructor for exception javax.ws.rs.NotFoundException

Construct a new "not found" exception.

NotFoundException(String, Throwable) - Constructor for exception javax.ws.rs.NotFoundException

Construct a new "not found" exception.

NotFoundException(Response, Throwable) - Constructor for exception javax.ws.rs.NotFoundException

Construct a new "not found" exception.

NotFoundException(String, Response, Throwable) - Constructor for exception javax.ws.rs.NotFoundException

Construct a new "not found" exception.

NOTICE - Static variable in class javax.mail.event.StoreEvent

Indicates that this message is a NOTICE.

NotIdentifiableEvent - Interface in javax.xml.bind

This event indicates that a problem was encountered resolving an ID/IDREF.

NotIdentifiableEventImpl - Class in javax.xml.bind.helpers

Default implementation of the NotIdentifiableEvent interface.

NotIdentifiableEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers.NotIdentifiableEventImpl

Create a new NotIdentifiableEventImpl.

NotIdentifiableEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers.NotIdentifiableEventImpl

Create a new NotIdentifiableEventImpl.

notification(StoreEvent) - Method in interface javax.mail.event.StoreListener

Invoked when the Store generates a notification event.

notify(T) - Method in interface javax.enterprise.inject.spi.ObserverMethod

Calls the observer method, passing the given event object.

notify(String, String) - Method in interface javax.security.auth.message.config.RegistrationListener

Notify the listener that a registration with which it was associated was replaced or unregistered.

notifyAfterEvaluation(String) - Method in class javax.el.ELContext

Notifies the listeners after an EL expression is evaluated

notifyBeforeEvaluation(String) - Method in class javax.el.ELContext

Notifies the listeners before an EL expression is evaluated

notifyConnectionListeners(int) - Method in class javax.mail.Folder

Notify all ConnectionListeners.

notifyConnectionListeners(int) - Method in class javax.mail.Service

Notify all ConnectionListeners.

notifyDDChange(XpathEvent) - Method in interface javax.enterprise.deploy.spi.DConfigBean

A notification that the DDBean provided in the event has changed and this bean or its child beans need to reevaluate themselves.

notifyFolderListeners(int) - Method in class javax.mail.Folder

Notify all FolderListeners registered on this Folder and this folder's Store.

notifyFolderListeners(int, Folder) - Method in class javax.mail.Store

Notify all FolderListeners.

notifyFolderRenamedListeners(Folder) - Method in class javax.mail.Folder

Notify all FolderListeners registered on this Folder and this folder's Store about the renaming of this folder.

notifyFolderRenamedListeners(Folder, Folder) - Method in class javax.mail.Store

Notify all FolderListeners about the renaming of a folder.

notifyMessageAddedListeners(Message[]) - Method in class javax.mail.Folder

Notify all MessageCountListeners about the addition of messages into this folder.

notifyMessageChangedListeners(int, Message) - Method in class javax.mail.Folder

Notify all MessageChangedListeners.

notifyMessageRemovedListeners(boolean, Message[]) - Method in class javax.mail.Folder

Notify all MessageCountListeners about the removal of messages from this Folder.

notifyPropertyResolved(Object, Object) - Method in class javax.el.ELContext

Notifies the listeners when the (base, property) pair is resolved

notifyStoreListeners(int, String) - Method in class javax.mail.Store

Notify all StoreListeners.

notifyTransportListeners(int, Address[], Address[], Address[], Message) - Method in class javax.mail.Transport

Notify all TransportListeners.

notLike(Expression<String>, Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression does not satisfy the given pattern.

notLike(Expression<String>, String) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression does not satisfy the given pattern.

notLike(Expression<String>, Expression<String>, Expression<Character>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression does not satisfy the given pattern.

notLike(Expression<String>, Expression<String>, char) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression does not satisfy the given pattern.

notLike(Expression<String>, String, Expression<Character>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression does not satisfy the given pattern.

notLike(Expression<String>, String, char) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a predicate for testing whether the expression does not satisfy the given pattern.

notModified() - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder with a not-modified status.

notModified(EntityTag) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder with a not-modified status.

notModified(String) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder with a not-modified status and a strong entity tag.

NotNull - Annotation Type in javax.validation.constraints

The annotated element must not be null.

NotNull.List - Annotation Type in javax.validation.constraints

Defines several NotNull annotations on the same element.

NotSupportedException - Exception in javax.resource

A NotSupportedException is thrown to indicate that callee (resource adapter or application server for system contracts) cannot execute an operation because the operation is not a supported feature.

NotSupportedException() - Constructor for exception javax.resource.NotSupportedException

Constructs a new instance with null as its detail message.

NotSupportedException(String) - Constructor for exception javax.resource.NotSupportedException

Constructs a new instance with the specified detail message.

NotSupportedException(Throwable) - Constructor for exception javax.resource.NotSupportedException

Constructs a new throwable with the specified cause.

NotSupportedException(String, Throwable) - Constructor for exception javax.resource.NotSupportedException

Constructs a new throwable with the specified detail message and cause.

NotSupportedException(String, String) - Constructor for exception javax.resource.NotSupportedException

Constructs a new throwable with the specified detail message and error code.

NotSupportedException - Exception in javax.transaction

NotSupportedException exception indicates that the request cannot be executed because the operation is not a supported feature.

NotSupportedException() - Constructor for exception javax.transaction.NotSupportedException

NotSupportedException(String) - Constructor for exception javax.transaction.NotSupportedException

NotSupportedException - Exception in javax.ws.rs

A runtime exception indicating that the client request entity media type is not supported.

NotSupportedException() - Constructor for exception javax.ws.rs.NotSupportedException

Construct a new unsupported media type exception.

NotSupportedException(String) - Constructor for exception javax.ws.rs.NotSupportedException

Construct a new unsupported media type exception.

NotSupportedException(Response) - Constructor for exception javax.ws.rs.NotSupportedException

Construct a new unsupported media type exception.

NotSupportedException(String, Response) - Constructor for exception javax.ws.rs.NotSupportedException

Construct a new unsupported media type exception.

NotSupportedException(Throwable) - Constructor for exception javax.ws.rs.NotSupportedException

Construct a new unsupported media type exception.

NotSupportedException(String, Throwable) - Constructor for exception javax.ws.rs.NotSupportedException

Construct a new unsupported media type exception.

NotSupportedException(Response, Throwable) - Constructor for exception javax.ws.rs.NotSupportedException

Construct a new unsupported media type exception.

NotSupportedException(String, Response, Throwable) - Constructor for exception javax.ws.rs.NotSupportedException

Construct a new unsupported media type exception.

NotTerm - Class in javax.mail.search

This class implements the logical NEGATION operator.

NotTerm(SearchTerm) - Constructor for class javax.mail.search.NotTerm

NS - Static variable in class javax.xml.ws.wsaddressing.W3CEndpointReference

NSPREFIX_SCHEMA_XSD - Static variable in class javax.xml.rpc.NamespaceConstants

Namespace prefix for XML schema XSD

NSPREFIX_SCHEMA_XSI - Static variable in class javax.xml.rpc.NamespaceConstants

Namespace prefix for XML Schema XSI

NSPREFIX_SOAP_ENCODING - Static variable in class javax.xml.rpc.NamespaceConstants

Namespace prefix for SOAP Encoding

NSPREFIX_SOAP_ENVELOPE - Static variable in class javax.xml.rpc.NamespaceConstants

Namespace prefix for SOAP Envelope

NSURI_SCHEMA_XSD - Static variable in class javax.xml.rpc.NamespaceConstants

Namespace URI for XML Schema XSD

NSURI_SCHEMA_XSI - Static variable in class javax.xml.rpc.NamespaceConstants

Namespace URI for XML Schema XSI

NSURI_SOAP_ENCODING - Static variable in class javax.xml.rpc.NamespaceConstants

Nameapace URI for SOAP 1.1 Encoding

NSURI_SOAP_ENVELOPE - Static variable in class javax.xml.rpc.NamespaceConstants

Nameapace URI for SOAP 1.1 Envelope

NSURI_SOAP_NEXT_ACTOR - Static variable in class javax.xml.rpc.NamespaceConstants

Nameapace URI for SOAP 1.1 next actor role

NULL - Static variable in interface javax.json.JsonValue

JSON null value.

Null - Annotation Type in javax.validation.constraints

The annotated element must be null.

Null.List - Annotation Type in javax.validation.constraints

Defines several Null annotations on the same element.

NULL_FLOW - Static variable in class javax.faces.flow.FlowHandler

Components that are rendered by Renderers of component-family javax.faces.OutcomeTarget must use this constant as the value of the parameter named by FlowHandler.TO_FLOW_DOCUMENT_ID_REQUEST_PARAM_NAME when returning from a flow (without entering another flow) using such a component.

NULL_VALUE - Static variable in class javax.faces.context.Flash

Because null values are not allowed as the source for subclasses of EventObject, such as PostKeepFlashValueEvent and PostPutFlashValueEvent, this value is substituted for null as the source in the case when a null value is put to or kept in the flash.

nullif(Expression<Y>, Expression<?>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.

nullif(Expression<Y>, Y) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that tests whether its argument are equal, returning null if they are and the value of the first expression if they are not.

nullLiteral(Class<T>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression for a null literal with the given type.

number - Variable in class javax.mail.search.IntegerComparisonTerm

The number.

NUMBER_ID - Static variable in class javax.faces.convert.NumberConverter

The message identifier of the FacesMessage to be created if the conversion to Number fails.

NumberConverter - Class in javax.faces.convert

Converter implementation for java.lang.Number values.

NumberConverter() - Constructor for class javax.faces.convert.NumberConverter

O

ObjectHolder - Class in javax.xml.rpc.holders

ObjectHolder() - Constructor for class javax.xml.rpc.holders.ObjectHolder

ObjectHolder(Object) - Constructor for class javax.xml.rpc.holders.ObjectHolder

ObjectMessage - Interface in javax.jms

An ObjectMessage object is used to send a message that contains a serializable object in the Java programming language ("Java object").

ObjectNotFoundException - Exception in javax.ejb

The ObjectNotFoundException exception is thrown by a finder or select method to indicate that the specified EJB object or local object does not exist.

ObjectNotFoundException() - Constructor for exception javax.ejb.ObjectNotFoundException

Constructs an ObjectNotFoundException with no detail message.

ObjectNotFoundException(String) - Constructor for exception javax.ejb.ObjectNotFoundException

Constructs an ObjectNotFoundException with the specified detail message.

ObserverException - Exception in javax.enterprise.event

Indicates that a checked exception was thrown by an observer method during event notification.

ObserverException() - Constructor for exception javax.enterprise.event.ObserverException

ObserverException(String) - Constructor for exception javax.enterprise.event.ObserverException

ObserverException(Throwable) - Constructor for exception javax.enterprise.event.ObserverException

ObserverException(String, Throwable) - Constructor for exception javax.enterprise.event.ObserverException

ObserverMethod<T> - Interface in javax.enterprise.inject.spi

Represents an observer method of an enabled bean.

Observes - Annotation Type in javax.enterprise.event

Identifies the event parameter of an observer method.

ok() - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder with an OK status.

ok(Object) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder that contains a representation.

ok(Object, MediaType) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder that contains a representation.

ok(Object, String) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder that contains a representation.

ok(Object, Variant) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder that contains a representation.

on(Expression<Boolean>) - Method in interface javax.persistence.criteria.CollectionJoin

Modify the join to restrict the result according to the specified ON condition and return the join object.

on(Predicate...) - Method in interface javax.persistence.criteria.CollectionJoin

Modify the join to restrict the result according to the specified ON condition and return the join object.

on(Expression<Boolean>) - Method in interface javax.persistence.criteria.Join

Modify the join to restrict the result according to the specified ON condition and return the join object.

on(Predicate...) - Method in interface javax.persistence.criteria.Join

Modify the join to restrict the result according to the specified ON condition and return the join object.

on(Expression<Boolean>) - Method in interface javax.persistence.criteria.ListJoin

Modify the join to restrict the result according to the specified ON condition and return the join object.

on(Predicate...) - Method in interface javax.persistence.criteria.ListJoin

Modify the join to restrict the result according to the specified ON condition and return the join object.

on(Expression<Boolean>) - Method in interface javax.persistence.criteria.MapJoin

Modify the join to restrict the result according to the specified ON condition and return the join object.

on(Predicate...) - Method in interface javax.persistence.criteria.MapJoin

Modify the join to restrict the result according to the specified ON condition and return the join object.

on(Expression<Boolean>) - Method in interface javax.persistence.criteria.SetJoin

Modify the join to restrict the result according to the specified ON condition and return the join object.

on(Predicate...) - Method in interface javax.persistence.criteria.SetJoin

Modify the join to restrict the result according to the specified ON condition and return the join object.

onAllDataRead() - Method in interface javax.servlet.ReadListener

Invoked when all data for the current request has been read.

onClose(Session, CloseReason) - Method in class javax.websocket.Endpoint

This method is called immediately prior to the session with the remote peer being closed.

OnClose - Annotation Type in javax.websocket

This method level annotation can be used to decorate a Java method that wishes to be called when a web socket session is closing.

onComplete(AsyncEvent) - Method in interface javax.servlet.AsyncListener

Notifies this AsyncListener that an asynchronous operation has been completed.

onComplete(Throwable) - Method in interface javax.ws.rs.container.CompletionCallback

A completion callback notification method that will be invoked when the request processing is finished, after a response is processed and is sent back to the client or when an unmapped throwable has been propagated to the hosting I/O container.

onCompletion(Message) - Method in interface javax.jms.CompletionListener

Notifies the application that the message has been successfully sent

onComponentCreated(FaceletContext, UIComponent, UIComponent) - Method in class javax.faces.view.facelets.ComponentHandler

This method is guaranteed to be called after the component has been created but before it has been populated with children.

onComponentPopulated(FaceletContext, UIComponent, UIComponent) - Method in class javax.faces.view.facelets.ComponentHandler

This method is guaranteed to be called after the component has been populated with children.

onDataAvailable() - Method in interface javax.servlet.ReadListener

When an instance of the ReadListener is registered with a ServletInputStream, this method will be invoked by the container the first time when it is possible to read data.

onDisconnect(AsyncResponse) - Method in interface javax.ws.rs.container.ConnectionCallback

This callback notification method is invoked in case the container detects that the remote client connection associated with the asynchronous response has been disconnected.

onError(Exception) - Method in class javax.batch.api.chunk.listener.AbstractChunkListener

Override this method if the ChunkListener will do something before the chunk transaction is rolled back.

onError(Exception) - Method in interface javax.batch.api.chunk.listener.ChunkListener

The onError method receives control before the chunk transaction is rolled back.

onError(AsyncEvent) - Method in interface javax.servlet.AsyncListener

Notifies this AsyncListener that an asynchronous operation has failed to complete.

onError(Throwable) - Method in interface javax.servlet.ReadListener

Invoked when an error occurs processing the request.

onError(Throwable) - Method in interface javax.servlet.WriteListener

Invoked when an error occurs writing data using the non-blocking APIs.

onError(Session, Throwable) - Method in class javax.websocket.Endpoint

Developers may implement this method when the web socket session creates some kind of error that is not modeled in the web socket protocol.

OnError - Annotation Type in javax.websocket

This method level annotation can be used to decorate a Java method that wishes to be called in order to handle errors.

OneToMany - Annotation Type in javax.persistence

Specifies a many-valued association with one-to-many multiplicity.

OneToOne - Annotation Type in javax.persistence

Specifies a single-valued association to another entity that has one-to-one multiplicity.

Oneway - Annotation Type in javax.jws

onException(Message, Exception) - Method in interface javax.jms.CompletionListener

Notifies user that the specified exception was thrown while attempting to send the specified message.

onException(JMSException) - Method in interface javax.jms.ExceptionListener

Notifies user of a JMS exception.

onMessage(Message) - Method in interface javax.jms.MessageListener

Passes a message to the listener.

onMessage(Record) - Method in interface javax.resource.cci.MessageListener

This method allows an EIS to call a message endpoint using a request-response style communication.

onMessage(T, boolean) - Method in interface javax.websocket.MessageHandler.Partial

Called when the next part of a message has been fully received.

onMessage(T) - Method in interface javax.websocket.MessageHandler.Whole

Called when the message has been fully received.

OnMessage - Annotation Type in javax.websocket

This method level annotation can be used to make a Java method receive incoming web socket messages.

onOpen(Session, EndpointConfig) - Method in class javax.websocket.Endpoint

Developers must implement this method to be notified when a new conversation has just begun.

OnOpen - Annotation Type in javax.websocket

This method level annotation can be used to decorate a Java method that wishes to be called when a new web socket session is open.

onProcessError(Object, Exception) - Method in class javax.batch.api.chunk.listener.AbstractItemProcessListener

Override this method if the ItemProcessListener will do something when the ItemProcessor processItem method throws an exception.

onProcessError(Object, Exception) - Method in interface javax.batch.api.chunk.listener.ItemProcessListener

The afterProcess method receives control after an item processor processes an item.

onReadError(Exception) - Method in class javax.batch.api.chunk.listener.AbstractItemReadListener

Override this method if the ItemReadListener will do something when the ItemReader readItem method throws an exception.

onReadError(Exception) - Method in interface javax.batch.api.chunk.listener.ItemReadListener

The onReadError method receives control after an item reader throws an exception in the readItem method.

onResult(SendResult) - Method in interface javax.websocket.SendHandler

Called once the message has been transmitted.

onRetryProcessException(Object, Exception) - Method in interface javax.batch.api.chunk.listener.RetryProcessListener

The onRetryProcessException method receives control when a retryable exception is thrown from an ItemProcessor processItem method.

onRetryReadException(Exception) - Method in interface javax.batch.api.chunk.listener.RetryReadListener

The onRetryReadException method receives control when a retryable exception is thrown from an ItemReader readItem method.

onRetryWriteException(List<Object>, Exception) - Method in interface javax.batch.api.chunk.listener.RetryWriteListener

The onRetryWriteException method receives control when a retryable exception is thrown from an ItemWriter writeItems method.

onSkipProcessItem(Object, Exception) - Method in interface javax.batch.api.chunk.listener.SkipProcessListener

The onSkipProcessItem method receives control when a skippable exception is thrown from an ItemProcess processItem method.

onSkipReadItem(Exception) - Method in interface javax.batch.api.chunk.listener.SkipReadListener

The onSkipReadItem method receives control when a skippable exception is thrown from an ItemReader readItem method.

onSkipWriteItem(List<Object>, Exception) - Method in interface javax.batch.api.chunk.listener.SkipWriteListener

The onSkipWriteItems method receives control when a skippable exception is thrown from an ItemWriter writeItems method.

onStartAsync(AsyncEvent) - Method in interface javax.servlet.AsyncListener

Notifies this AsyncListener that a new asynchronous cycle is being initiated via a call to one of the ServletRequest.startAsync() methods.

onStartup(Set<Class<?>>, ServletContext) - Method in interface javax.servlet.ServletContainerInitializer

Notifies this ServletContainerInitializer of the startup of the application represented by the given ServletContext.

onTimeout(AsyncEvent) - Method in interface javax.servlet.AsyncListener

Notifies this AsyncListener that an asynchronous operation has timed out.

onWriteError(List<Object>, Exception) - Method in class javax.batch.api.chunk.listener.AbstractItemWriteListener

Override this method if the ItemWriteListener will do something when the ItemWriter writeItems method throws an exception.

onWriteError(List<Object>, Exception) - Method in interface javax.batch.api.chunk.listener.ItemWriteListener

The onWriteError method receives control after an item writer writeItems throws an exception.

onWritePossible() - Method in interface javax.servlet.WriteListener

When an instance of the WriteListener is registered with a ServletOutputStream, this method will be invoked by the container the first time when it is possible to write data.

open(Serializable) - Method in class javax.batch.api.chunk.AbstractItemReader

Override this method if the ItemReader requires any open time processing.

open(Serializable) - Method in class javax.batch.api.chunk.AbstractItemWriter

Override this method if the ItemWriter requires any open time processing.

open(Serializable) - Method in interface javax.batch.api.chunk.ItemReader

The open method prepares the reader to read items.

open(Serializable) - Method in interface javax.batch.api.chunk.ItemWriter

The open method prepares the writer to write items.

open(int) - Method in class javax.mail.Folder

Open this Folder.

opened(ConnectionEvent) - Method in class javax.mail.event.ConnectionAdapter

OPENED - Static variable in class javax.mail.event.ConnectionEvent

A connection was opened.

opened(ConnectionEvent) - Method in interface javax.mail.event.ConnectionListener

Invoked when a Store/Folder/Transport is opened.

OPERATION_STYLE_PROPERTY - Static variable in interface javax.xml.rpc.Call

Standard property for operation style.

OperationUnsupportedException - Exception in javax.enterprise.deploy.spi.exceptions

This exception is to report that the method called is not supported by this implementation.

OperationUnsupportedException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException

Creates an new OperationUnsupportedException object.

OPERATOR_SLOT - Static variable in interface javax.xml.registry.infomodel.Slot

Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.

OptimisticLockException - Exception in javax.persistence

Thrown by the persistence provider when an optimistic locking conflict occurs.

OptimisticLockException() - Constructor for exception javax.persistence.OptimisticLockException

Constructs a new OptimisticLockException exception with null as its detail message.

OptimisticLockException(String) - Constructor for exception javax.persistence.OptimisticLockException

Constructs a new OptimisticLockException exception with the specified detail message.

OptimisticLockException(String, Throwable) - Constructor for exception javax.persistence.OptimisticLockException

Constructs a new OptimisticLockException exception with the specified detail message and cause.

OptimisticLockException(Throwable) - Constructor for exception javax.persistence.OptimisticLockException

Constructs a new OptimisticLockException exception with the specified cause.

OptimisticLockException(Object) - Constructor for exception javax.persistence.OptimisticLockException

Constructs a new OptimisticLockException exception with the specified entity.

OptimisticLockException(String, Throwable, Object) - Constructor for exception javax.persistence.OptimisticLockException

Constructs a new OptimisticLockException exception with the specified detail message, cause, and entity.

options() - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP OPTIONS method for the current request asynchronously.

options(Class<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP OPTIONS method for the current request asynchronously.

options(GenericType<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP OPTIONS method for the current request asynchronously.

options(InvocationCallback<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP OPTIONS method for the current request asynchronously.

options() - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP OPTIONS method for the current request synchronously.

options(Class<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP OPTIONS method for the current request synchronously.

options(GenericType<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP OPTIONS method for the current request synchronously.

OPTIONS - Static variable in annotation type javax.ws.rs.HttpMethod

HTTP OPTIONS method.

OPTIONS - Annotation Type in javax.ws.rs

Indicates that the annotated method responds to HTTP OPTIONS requests.

or(Expression<Boolean>, Expression<Boolean>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a disjunction of the given boolean expressions.

or(Predicate...) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a disjunction of the given restriction predicates.

OR_ALL_KEYS - Static variable in interface javax.xml.registry.FindQualifier

Specifies a hint to queries that the candidate set of objects matching the query should include any object that is classified by any one of the taxonomy values specified in any of the Classification for the query.

OR_LIKE_KEYS - Static variable in interface javax.xml.registry.FindQualifier

Specifies a hint to queries that when multiple taxonomy values from the same ClassificationScheme are specified in the Classifications for the query then the candidate set of objects matching the query should include any object that is classified by any one of the taxonomy values.

Order - Interface in javax.persistence.criteria

An object that defines an ordering over the query results.

orderBy(Order...) - Method in interface javax.persistence.criteria.CriteriaQuery

Specify the ordering expressions that are used to order the query results.

orderBy(List<Order>) - Method in interface javax.persistence.criteria.CriteriaQuery

Specify the ordering expressions that are used to order the query results.

OrderBy - Annotation Type in javax.persistence

Specifies the ordering of the elements of a collection valued association or element collection at the point when the association or collection is retrieved.

OrderColumn - Annotation Type in javax.persistence

Specifies a column that is used to maintain the persistent order of a list.

ORDERED_LIBS - Static variable in interface javax.servlet.ServletContext

The name of the ServletContext attribute whose value (of type java.util.List<java.lang.String>) contains the list of names of JAR files in WEB-INF/lib ordered by their web fragment names (with possible exclusions if <absolute-ordering> without any <others/> is being used), or null if no absolute or relative ordering has been specified

Organization - Interface in javax.xml.registry.infomodel

Organization instances provide information on organizations such as a Submitting Organization.

ORGANIZATION - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.Organization interface.

orig - Variable in class javax.servlet.jsp.jstl.core.IndexedValueExpression

orig - Variable in class javax.servlet.jsp.jstl.core.IteratedExpression

OrTerm - Class in javax.mail.search

This class implements the logical OR operator on individual SearchTerms.

OrTerm(SearchTerm, SearchTerm) - Constructor for class javax.mail.search.OrTerm

Constructor that takes two operands.

OrTerm(SearchTerm[]) - Constructor for class javax.mail.search.OrTerm

Constructor that takes an array of SearchTerms.

othersDeletesAreVisible(int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether deletes made by others are visible.

othersInsertsAreVisible(int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether inserts made by others are visible.

othersUpdatesAreVisible(int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether updates made by others are visible.

otherwise(R) - Method in interface javax.persistence.criteria.CriteriaBuilder.Case

Add an "else" clause to the case expression.

otherwise(Expression<? extends R>) - Method in interface javax.persistence.criteria.CriteriaBuilder.Case

Add an "else" clause to the case expression.

otherwise(R) - Method in interface javax.persistence.criteria.CriteriaBuilder.SimpleCase

Add an "else" clause to the case expression.

otherwise(Expression<? extends R>) - Method in interface javax.persistence.criteria.CriteriaBuilder.SimpleCase

Add an "else" clause to the case expression.

OUT - Static variable in class javax.servlet.jsp.PageContext

Name used to store current JspWriter in PageContext name table.

OUT - Static variable in class javax.xml.rpc.ParameterMode

OUT mode for parameter passing

OUTBOUND_MESSAGE_ATTACHMENTS - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: Map of attachments to a message for the outbound message, key is the MIME Content-ID, value is a DataHandler.

outboundParameter(String, ValueExpression) - Method in class javax.faces.flow.builder.FlowCallBuilder

Define an outbound parameter for the flow call.

outboundParameter(String, String) - Method in class javax.faces.flow.builder.FlowCallBuilder

Define an outbound parameter for the flow call.

OverridesAttribute - Annotation Type in javax.validation

Marks an attribute as overriding the attribute of a composing constraint.

OverridesAttribute.List - Annotation Type in javax.validation

Defines several OverridesAttribute annotations on the same element

ownDeletesAreVisible(int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether a ResultSet's own deletes are visible.

ownInsertsAreVisible(int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether a ResultSet's own inserts are visible.

ownUpdatesAreVisible(int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether a ResultSet's own updates are visible.

P

PAGE - Static variable in class javax.servlet.jsp.PageContext

Name used to store the Servlet in this PageContext's nametables.

PAGE_SCOPE - Static variable in class javax.servlet.jsp.PageContext

Page scope: (this is the default) the named reference remains available in this PageContext until the return from the current Servlet.service() invocation.

pageContext - Variable in class javax.faces.webapp.UIComponentClassicTagBase

The JSP PageContext for the page we are embedded in.

PageContext - Class in javax.servlet.jsp

PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.

PageContext() - Constructor for class javax.servlet.jsp.PageContext

Sole constructor.

PAGECONTEXT - Static variable in class javax.servlet.jsp.PageContext

Name used to store this PageContext in it's own name table.

pageContext - Variable in class javax.servlet.jsp.tagext.TagSupport

The PageContext.

PageData - Class in javax.servlet.jsp.tagext

Translation-time information on a JSP page.

PageData() - Constructor for class javax.servlet.jsp.tagext.PageData

Sole constructor.

param(String, String) - Method in class javax.ws.rs.core.Form

Adds a new value to the specified form parameter.

param(String, String) - Method in interface javax.ws.rs.core.Link.Builder

Set an arbitrary parameter on this link.

ParamConverter<T> - Interface in javax.ws.rs.ext

Defines a contract for a delegate responsible for converting between a String form of a message parameter value and the corresponding custom Java type T.

ParamConverter.Lazy - Annotation Type in javax.ws.rs.ext

Mandates that a conversion of any default value delegated to a parameter converter annotated with @Lazy annotation SHOULD occur only once the value is actually required (e.g.

ParamConverterProvider - Interface in javax.ws.rs.ext

Contract for a provider of ParamConverter instances.

parameter(String, String) - Method in class javax.faces.flow.builder.NavigationCaseBuilder.RedirectBuilder

Add a parameter to the redirect.

Parameter - Class in javax.faces.flow

Represents a parameter in any of several places where parameters are needed when processing flows.

Parameter() - Constructor for class javax.faces.flow.Parameter

parameter(Class<T>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a parameter expression.

parameter(Class<T>, String) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a parameter expression with the given name.

Parameter<T> - Interface in javax.persistence

Type for query parameter objects.

ParameterDescriptor - Interface in javax.validation.metadata

Describes a validated method or constructor parameter.

ParameterExpression<T> - Interface in javax.persistence.criteria

Type of criteria query parameter expressions.

ParameterList - Class in javax.mail.internet

This class holds MIME parameters (attribute-value pairs).

ParameterList() - Constructor for class javax.mail.internet.ParameterList

No-arg Constructor.

ParameterList(String) - Constructor for class javax.mail.internet.ParameterList

Constructor that takes a parameter-list string.

ParameterMode - Enum in javax.persistence

Specifies the mode of a parameter of a stored procedure query.

ParameterMode - Class in javax.xml.rpc

The javax.xml.rpc.ParameterMode is a type-safe enumeration for parameter mode.

parameterNameProvider(ParameterNameProvider) - Method in interface javax.validation.Configuration

Defines the parameter name provider.

ParameterNameProvider - Interface in javax.validation

Provides names for method and constructor parameters.

parameterNameProvider(ParameterNameProvider) - Method in interface javax.validation.ValidatorContext

Defines the parameter name provider implementation used by the Validator.

parameters(List<Parameter>) - Method in class javax.faces.flow.builder.MethodCallBuilder

Set the parameters of the method call node.

parent - Variable in class javax.mail.BodyPart

The Multipart object containing this BodyPart, if known.

parent - Variable in class javax.mail.Multipart

The Part containing this Multipart, if known.

parse(String) - Static method in class javax.mail.internet.InternetAddress

Parse the given comma separated sequence of addresses into InternetAddress objects.

parse(String, boolean) - Static method in class javax.mail.internet.InternetAddress

Parse the given sequence of addresses into InternetAddress objects.

parse(String, ParsePosition) - Method in class javax.mail.internet.MailDateFormat

Parses the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.

parse(InputStream) - Method in class javax.mail.internet.MimeMessage

Parse the InputStream setting the headers and content fields appropriately.

parse() - Method in class javax.mail.internet.MimeMultipart

Parse the InputStream from our DataSource, constructing the appropriate MimeBodyParts.

parse(String) - Static method in class javax.mail.internet.NewsAddress

Parse the given comma separated sequence of newsgroup into NewsAddress objects.

parseAnySimpleType(String) - Static method in class javax.xml.bind.DatatypeConverter

Return a string containing the lexical representation of the simple type.

parseAnySimpleType(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Return a string containing the lexical representation of the simple type.

parseBase64Binary(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into an array of bytes.

parseBase64Binary(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into an array of bytes.

parseBoolean(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a boolean value.

parseBoolean(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a boolean value.

parseByte(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a byte value.

parseByte(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a byte value.

ParseConversionEvent - Interface in javax.xml.bind

This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.

ParseConversionEventImpl - Class in javax.xml.bind.helpers

Default implementation of the ParseConversionEvent interface.

ParseConversionEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers.ParseConversionEventImpl

Create a new ParseConversionEventImpl.

ParseConversionEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers.ParseConversionEventImpl

Create a new ParseConversionEventImpl.

parsed - Variable in class javax.mail.internet.MimeMultipart

Have we parsed the data from our InputStream yet? Defaults to true; set to false when our constructor is given a DataSource with an InputStream that we need to parse.

parseDate(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a Calendar value.

parseDate(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a Calendar value.

parseDateTime(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a Calendar value.

parseDateTime(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a Calendar value.

parseDecimal(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a BigDecimal value.

parseDecimal(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a BigDecimal value.

parseDouble(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a double value.

parseDouble(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a double value.

ParseException - Exception in javax.mail.internet

The exception thrown due to an error in parsing RFC822 or MIME headers

ParseException() - Constructor for exception javax.mail.internet.ParseException

Constructs a ParseException with no detail message.

ParseException(String) - Constructor for exception javax.mail.internet.ParseException

Constructs a ParseException with the specified detail message.

parseExpression(String, Class, FunctionMapper) - Method in class javax.servlet.jsp.el.ExpressionEvaluator

Deprecated.

Prepare an expression for later evaluation.

parseFloat(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a float value.

parseFloat(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a float value.

parseHeader(String, boolean) - Static method in class javax.mail.internet.InternetAddress

Parse the given sequence of addresses into InternetAddress objects.

parseHexBinary(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into an array of bytes.

parseHexBinary(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into an array of bytes.

parseInt(String) - Static method in class javax.xml.bind.DatatypeConverter

Convert the string argument into an int value.

parseInt(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Convert the string argument into an int value.

parseInteger(String) - Static method in class javax.xml.bind.DatatypeConverter

Convert the string argument into a BigInteger value.

parseInteger(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Convert the string argument into a BigInteger value.

parseLong(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a long value.

parseLong(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a long value.

parsePostData(int, ServletInputStream) - Static method in class javax.servlet.http.HttpUtils

Deprecated.

Parses data from an HTML form that the client sends to the server using the HTTP POST method and the application/x-www-form-urlencoded MIME type.

parseQName(String, NamespaceContext) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a byte value.

parseQName(String, NamespaceContext) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a QName value.

parseQueryString(String) - Static method in class javax.servlet.http.HttpUtils

Deprecated.

Parses a query string passed from the client to the server and builds a HashTable object with key-value pairs.

parseShort(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a short value.

parseShort(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a short value.

parseString(String) - Method in class javax.mail.URLName

Method which does all of the work of parsing the string.

parseString(String) - Static method in class javax.xml.bind.DatatypeConverter

Convert the lexical XSD string argument into a String value.

parseString(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Convert the string argument into a string.

parseTime(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a Calendar value.

parseTime(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a Calendar value.

parseUnsignedInt(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a long value.

parseUnsignedInt(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a long value.

parseUnsignedShort(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into an int value.

parseUnsignedShort(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into an int value.

part - Variable in class javax.mail.internet.MimePartDataSource

The MimePart that provides the data for this DataSource.

Part - Interface in javax.mail

The Part interface is the common base interface for Messages and BodyParts.

Part - Interface in javax.servlet.http

This class represents a part or form item that was received within a multipart/form-data POST request.

PARTIAL_EXECUTE_PARAM_NAME - Static variable in class javax.faces.context.PartialViewContext

The request parameter name whose request parameter value is a Collection of client identifiers identifying the components that must be processed during the Apply Request Values, Process Validations, and Update Model Values phases of the request processing lifecycle.

PARTIAL_RENDER_PARAM_NAME - Static variable in class javax.faces.context.PartialViewContext

The request parameter name whose request parameter value is a Collection of client identifiers identifying the components that must be processed during the Render Response phase of the request processing lifecycle.

PARTIAL_STATE_SAVING_PARAM_NAME - Static variable in class javax.faces.application.StateManager

The ServletContext init parameter consulted by the runtime to determine if the partial state saving mechanism should be used.

PARTIAL_VIEW_CONTEXT_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the PartialViewContextFactory class name.

PartialResponseWriter - Class in javax.faces.context

PartialResponseWriter decorates an existing ResponseWriter to support the generation of a partial response suitable for Ajax operations.

PartialResponseWriter(ResponseWriter) - Constructor for class javax.faces.context.PartialResponseWriter

Create a PartialResponseWriter.

PartialStateHolder - Interface in javax.faces.component

Components that want to leverage the partial state saving feature must implement this interface instead of implementing StateHolder, from which this interface inherits.

PartialViewContext - Class in javax.faces.context

PartialViewContext contains methods and properties that pertain to partial request processing and partial response rendering on a view.

PartialViewContext() - Constructor for class javax.faces.context.PartialViewContext

PartialViewContextFactory - Class in javax.faces.context

PartialViewContextFactory is a factory object that creates (if needed) and returns new PartialViewContext instances.

PartialViewContextFactory() - Constructor for class javax.faces.context.PartialViewContextFactory

PartialViewContextWrapper - Class in javax.faces.context

Provides a simple implementation of PartialViewContext that can be subclassed by developers wishing to provide specialized behavior to an existing PartialViewContext instance.

PartialViewContextWrapper() - Constructor for class javax.faces.context.PartialViewContextWrapper

PartitionAnalyzer - Interface in javax.batch.api.partition

PartitionAnalyzer receives control to process data and final results from each partition.

PartitionCollector - Interface in javax.batch.api.partition

PartitionCollector provides a way to pass data from individual partitions to a single point of control running on the step's parent thread.

PartitionMapper - Interface in javax.batch.api.partition

PartitionMapper receives control at the start of a partitioned execution.

PartitionPlan - Interface in javax.batch.api.partition

PartitionPlanImpl - Class in javax.batch.api.partition

The PartitionPlanImpl class provides a basic implementation of the PartitionPlan interface.

PartitionPlanImpl() - Constructor for class javax.batch.api.partition.PartitionPlanImpl

PartitionReducer - Interface in javax.batch.api.partition

PartitionReducer provides unit of work demarcation across partitions.

PartitionReducer.PartitionStatus - Enum in javax.batch.api.partition

parts - Variable in class javax.mail.Multipart

Vector of BodyPart objects.

PassivationCapable - Interface in javax.enterprise.inject.spi

Indicates that a custom implementation of Bean or Contextual is passivation capable.

PASSTHROUGH_RENDERER_LOCALNAME_KEY - Static variable in class javax.faces.render.Renderer

The key in the component passthrough attributes Map for the localName of the element corresponding to the component.

PASSWORD_PROPERTY - Static variable in interface javax.xml.rpc.Call

Standard property: Password for authentication

PASSWORD_PROPERTY - Static variable in interface javax.xml.rpc.Stub

Standard property: Password for authentication.

PASSWORD_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider

Standard property: Password for authentication.

PasswordAuthentication - Class in javax.mail

The class PasswordAuthentication is a data holder that is used by Authenticator.

PasswordAuthentication(String, String) - Constructor for class javax.mail.PasswordAuthentication

Initialize a new PasswordAuthentication

PasswordCredential - Class in javax.resource.spi.security

The class PasswordCredential acts as a holder for username and password.

PasswordCredential(String, char[]) - Constructor for class javax.resource.spi.security.PasswordCredential

Creates a new PasswordCredential object from the given user name and password.

PasswordValidationCallback - Class in javax.security.auth.message.callback

Callback for PasswordValidation.

PasswordValidationCallback(Subject, String, char[]) - Constructor for class javax.security.auth.message.callback.PasswordValidationCallback

Create a PasswordValidationCallback.

Past - Annotation Type in javax.validation.constraints

The annotated element must be a date in the past.

Past.List - Annotation Type in javax.validation.constraints

Defines several Past annotations on the same element.

Path<X> - Interface in javax.persistence.criteria

Represents a simple or compound attribute path from a bound type or collection, and is a "primitive" expression.

Path - Interface in javax.validation

Represents the navigation path from an object to another in an object graph.

path(String) - Method in interface javax.ws.rs.client.WebTarget

Create a new WebTarget instance by appending path to the URI of the current target instance.

path(String) - Method in class javax.ws.rs.core.UriBuilder

Append path to the existing path.

path(Class) - Method in class javax.ws.rs.core.UriBuilder

Append the path from a Path-annotated class to the existing path.

path(Class, String) - Method in class javax.ws.rs.core.UriBuilder

Append the path from a Path-annotated method to the existing path.

path(Method) - Method in class javax.ws.rs.core.UriBuilder

Append the path from a Path-annotated method to the existing path.

Path - Annotation Type in javax.ws.rs

Identifies the URI path that a resource class or class method will serve requests for.

Path.BeanNode - Interface in javax.validation

Node representing a bean.

Path.ConstructorNode - Interface in javax.validation

Node representing a constructor.

Path.CrossParameterNode - Interface in javax.validation

Node representing the element holding cross-parameter constraints of a method or constructor.

Path.MethodNode - Interface in javax.validation

Node representing a method.

Path.Node - Interface in javax.validation

Represents an element of a navigation path.

Path.ParameterNode - Interface in javax.validation

Node representing a parameter of a method or constructor.

Path.PropertyNode - Interface in javax.validation

Node representing a property.

Path.ReturnValueNode - Interface in javax.validation

Node representing the return value of a method or constructor.

PATH_INFO - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: Request Path Info

PathParam - Annotation Type in javax.websocket.server

This annotation may be used to annotate method parameters on server endpoints where a URI-template has been used in the path-mapping of the ServerEndpoint annotation.

PathParam - Annotation Type in javax.ws.rs

Binds the value of a URI template parameter or a path segment containing the template parameter to a resource method parameter, resource class field, or resource class bean property.

PathSegment - Interface in javax.ws.rs.core

Represents a URI path segment and any associated matrix parameters.

pattern - Variable in class javax.mail.search.StringTerm

The pattern.

Pattern - Annotation Type in javax.validation.constraints

The annotated CharSequence must match the specified regular expression.

Pattern.Flag - Enum in javax.validation.constraints

Possible Regexp flags.

Pattern.List - Annotation Type in javax.validation.constraints

Defines several Pattern annotations on the same element.

PATTERN_ID - Static variable in class javax.faces.convert.NumberConverter

The message identifier of the FacesMessage to be created if the conversion to Number fails.

PATTERN_NOT_SET_MESSAGE_ID - Static variable in class javax.faces.validator.RegexValidator

The message identifier of the FacesMessage to be created if the value returned from RegexValidator.getPattern() is null or the empty String.

Payload - Interface in javax.validation

Payload type that can be attached to a given constraint declaration.

peek() - Method in class javax.mail.internet.HeaderTokenizer

Peek at the next token, without actually removing the token from the parse stream.

PERCENT_ID - Static variable in class javax.faces.convert.NumberConverter

The message identifier of the FacesMessage to be created if the conversion to Number fails.

performNavigation(String) - Method in class javax.faces.application.ConfigurableNavigationHandler

A convenience method to signal the JavaServer Faces implementation to perform navigation with the provided outcome.

performNavigation(String) - Method in class javax.faces.application.ConfigurableNavigationHandlerWrapper

PermitAll - Annotation Type in javax.annotation.security

Specifies that all security roles are allowed to invoke the specified method(s) i.e that the specified method(s) are "unchecked".

PermittedTaglibsTLV - Class in javax.servlet.jsp.jstl.tlv

A TagLibraryValidator class to allow a TLD to restrict what taglibs (in addition to itself) may be imported on a page where it's used.

PermittedTaglibsTLV() - Constructor for class javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV

persist(Object) - Method in interface javax.persistence.EntityManager

Make an instance managed and persistent.

Persistence - Class in javax.persistence

Bootstrap class that is used to obtain an EntityManagerFactory in Java SE environments.

Persistence() - Constructor for class javax.persistence.Persistence

PERSISTENCE_PROVIDER - Static variable in class javax.persistence.Persistence

Deprecated.

PersistenceContext - Annotation Type in javax.persistence

Expresses a dependency on a container-managed EntityManager and its associated persistence context.

PersistenceContexts - Annotation Type in javax.persistence

Declares one or more PersistenceContext annotations.

PersistenceContextType - Enum in javax.persistence

Specifies whether a transaction-scoped or extended persistence context is to be used in PersistenceContext.

PersistenceException - Exception in javax.persistence

Thrown by the persistence provider when a problem occurs.

PersistenceException() - Constructor for exception javax.persistence.PersistenceException

Constructs a new PersistenceException exception with null as its detail message.

PersistenceException(String) - Constructor for exception javax.persistence.PersistenceException

Constructs a new PersistenceException exception with the specified detail message.

PersistenceException(String, Throwable) - Constructor for exception javax.persistence.PersistenceException

Constructs a new PersistenceException exception with the specified detail message and cause.

PersistenceException(Throwable) - Constructor for exception javax.persistence.PersistenceException

Constructs a new PersistenceException exception with the specified cause.

PersistenceProperty - Annotation Type in javax.persistence

Describes a single container or persistence provider property.

PersistenceProvider - Interface in javax.persistence.spi

Interface implemented by the persistence provider.

PersistenceProviderResolver - Interface in javax.persistence.spi

Determine the list of persistence providers available in the runtime environment.

PersistenceProviderResolverHolder - Class in javax.persistence.spi

Holds the global PersistenceProviderResolver instance.

PersistenceProviderResolverHolder() - Constructor for class javax.persistence.spi.PersistenceProviderResolverHolder

PersistenceUnit - Annotation Type in javax.persistence

Expresses a dependency on an EntityManagerFactory and its associated persistence unit.

PersistenceUnitInfo - Interface in javax.persistence.spi

Interface implemented by the container and used by the persistence provider when creating an EntityManagerFactory.

PersistenceUnits - Annotation Type in javax.persistence

Declares one or more PersistenceUnit annotations.

PersistenceUnitTransactionType - Enum in javax.persistence.spi

Specifies whether entity managers created by the EntityManagerFactory will be JTA or resource-local entity managers.

PersistenceUnitUtil - Interface in javax.persistence

Utility interface between the application and the persistence provider managing the persistence unit.

PersistenceUtil - Interface in javax.persistence

Utility interface between the application and the persistence provider(s).

PERSISTENT - Static variable in interface javax.jms.DeliveryMode

This delivery mode instructs the JMS provider to log the message to stable storage as part of the client's send operation.

PERSON_NAME - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.PersonName interface.

personal - Variable in class javax.mail.internet.InternetAddress

The personal name.

PersonName - Interface in javax.xml.registry.infomodel

Represents a person's name.

PessimisticLockException - Exception in javax.persistence

Thrown by the persistence provider when an pessimistic locking conflict occurs.

PessimisticLockException() - Constructor for exception javax.persistence.PessimisticLockException

Constructs a new PessimisticLockException exception with null as its detail message.

PessimisticLockException(String) - Constructor for exception javax.persistence.PessimisticLockException

Constructs a new PessimisticLockException exception with the specified detail message.

PessimisticLockException(String, Throwable) - Constructor for exception javax.persistence.PessimisticLockException

Constructs a new PessimisticLockException exception with the specified detail message and cause.

PessimisticLockException(Throwable) - Constructor for exception javax.persistence.PessimisticLockException

Constructs a new PessimisticLockException exception with the specified cause.

PessimisticLockException(Object) - Constructor for exception javax.persistence.PessimisticLockException

Constructs a new PessimisticLockException exception with the specified entity.

PessimisticLockException(String, Throwable, Object) - Constructor for exception javax.persistence.PessimisticLockException

Constructs a new PessimisticLockException exception with the specified detail message, cause, and entity.

PessimisticLockScope - Enum in javax.persistence

Defines the values of the javax.persistence.lock.scope property for pessimistic locking.

PhaseEvent - Class in javax.faces.event

PhaseEvent represents the beginning or ending of processing for a particular phase of the request processing lifecycle, for the request encapsulated by the specified FacesContext.

PhaseEvent(FacesContext, PhaseId, Lifecycle) - Constructor for class javax.faces.event.PhaseEvent

Construct a new event object from the specified parameters.

PhaseId - Class in javax.faces.event

Typesafe enumeration of the legal values that may be returned by the getPhaseId() method of the FacesEvent interface.

phaseIdValueOf(String) - Static method in class javax.faces.event.PhaseId

Return a PhaseId representation of the arcument phase.

PhaseListener - Interface in javax.faces.event

An interface implemented by objects that wish to be notified at the beginning and ending of processing for each standard phase of the request processing lifecycle.

PLATFORM_AFTER - Static variable in class javax.interceptor.Interceptor.Priority

Start of range for late interceptors defined by platform specifications.

PLATFORM_BEFORE - Static variable in class javax.interceptor.Interceptor.Priority

Start of range for early interceptors defined by platform specifications.

PluralAttribute<X,C,E> - Interface in javax.persistence.metamodel

Instances of the type PluralAttribute represent persistent collection-valued attributes.

PluralAttribute.CollectionType - Enum in javax.persistence.metamodel

PluralJoin<Z,C,E> - Interface in javax.persistence.criteria

The PluralJoin interface defines functionality that is common to joins to all collection types.

PolicyConfiguration - Interface in javax.security.jacc

The methods of this interface are used by containers to create policy statements in a Policy provider.

PolicyConfigurationFactory - Class in javax.security.jacc

Abstract factory and finder class for obtaining the instance of the class that implements the PolicyConfigurationFactory of a provider.

PolicyConfigurationFactory() - Constructor for class javax.security.jacc.PolicyConfigurationFactory

PolicyContext - Class in javax.security.jacc

This utility class is used by containers to communicate policy context identifiers and other policy relevant context to Policy providers.

PolicyContextException - Exception in javax.security.jacc

This checked exception is thrown by implementations of the javax.security.jacc.PolicyConfiguration Interface, the javax.security.jacc.PolicyConfigurationFactory abstract class, the javax.security.jacc.PolicyContext utility class, and implementations of the javax.security.jacc.PolicyContextException Interface.

PolicyContextException() - Constructor for exception javax.security.jacc.PolicyContextException

Constructs a new PolicyContextException with null as its detail message.

PolicyContextException(String) - Constructor for exception javax.security.jacc.PolicyContextException

Constructs a new PolicyContextException with the specified detail message

PolicyContextException(String, Throwable) - Constructor for exception javax.security.jacc.PolicyContextException

Constructs a new PolicyContextException with the specified detail message and cause.

PolicyContextException(Throwable) - Constructor for exception javax.security.jacc.PolicyContextException

Constructs a new PolicyContextException with the specified cause.

PolicyContextHandler - Interface in javax.security.jacc

This interface defines the methods that must be implemented by handlers that are to be registered and activated by the PolicyContext class.

PongMessage - Interface in javax.websocket

The PongMessage interface represents a web socket pong.

popBody() - Method in class javax.servlet.jsp.JspContext

Return the previous JspWriter "out" saved by the matching pushBody(), and update the value of the "out" attribute in the page scope attribute namespace of the JspContext.

popComponentFromEL(FacesContext) - Method in class javax.faces.component.UIComponent

Pop the current UIComponent from the FacesContext attributes map so that the previous UIComponent, if any, becomes the current component.

popReturnMode(FacesContext) - Method in class javax.faces.flow.FlowHandler

Enable the correct handling of navigation when processing a return node.

populateApplicationConfiguration(Document) - Method in class javax.faces.application.ApplicationConfigurationPopulator

Service providers that implement this service must be called by the JSF runtime exactly once for each implementation, at startup, before any requests have been serviced.

port(int) - Method in class javax.ws.rs.core.UriBuilder

Set the URI port.

PortInfo - Interface in javax.xml.ws.handler

The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.

pos - Variable in exception javax.mail.internet.AddressException

The index in the string where the error occurred, or -1 if not known.

post(Entity<?>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP POST method for the current request asynchronously.

post(Entity<?>, Class<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP POST method for the current request asynchronously.

post(Entity<?>, GenericType<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP POST method for the current request asynchronously.

post(Entity<?>, InvocationCallback<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP POST method for the current request asynchronously.

post(Entity<?>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP POST method for the current request synchronously.

post(Entity<?>, Class<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP POST method for the current request synchronously.

post(Entity<?>, GenericType<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP POST method for the current request synchronously.

POST - Static variable in annotation type javax.ws.rs.HttpMethod

HTTP POST method.

POST - Annotation Type in javax.ws.rs

Indicates that the annotated method responds to HTTP POST requests.

PostActivate - Annotation Type in javax.ejb

Designates a method to receive a callback after a stateful session bean has been activated.

PostAddToViewEvent - Class in javax.faces.event

When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is a UIComponent instance and that either that instance or an ancestor of that instance was just added to the view.

PostAddToViewEvent(UIComponent) - Constructor for class javax.faces.event.PostAddToViewEvent

Instantiate a new PostAddToViewEvent that indicates the argument component was just added to the view.

POSTAL_ADDRESS - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.PostalAddress interface.

PostalAddress - Interface in javax.xml.registry.infomodel

PostalAddress is a simple re-usable entity class that defines attributes of a postal Address.

PostConstruct - Annotation Type in javax.annotation

The PostConstruct annotation is used on a method that needs to be executed after dependency injection is done to perform any initialization.

postConstruct(T) - Method in interface javax.enterprise.inject.spi.InjectionTarget

Calls the PostConstruct callback, if it exists, according to the semantics required by the Java EE platform specification.

postConstruct() - Method in class javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance

Call the @PostConstruct callback

PostConstructApplicationEvent - Class in javax.faces.event

This event must be published by the runtime after all configuration resources have been parsed and processed.

PostConstructApplicationEvent(Application) - Constructor for class javax.faces.event.PostConstructApplicationEvent

Constructs a new AppliationPostConstructEvent for this application.

PostConstructCustomScopeEvent - Class in javax.faces.event

This class is provided to allow custom scopes to publish a "post construct" event in the same way that other scopes do to let the application become aware of the beginning of the scope.

PostConstructCustomScopeEvent(ScopeContext) - Constructor for class javax.faces.event.PostConstructCustomScopeEvent

An instance of this event indicates that the custom scope enclosed within the argument scopeContext was just created.

PostConstructViewMapEvent - Class in javax.faces.event

This event must be published by a call to {javax.faces.application.Application#publishEvent} when the view map is first created.

PostConstructViewMapEvent(UIViewRoot) - Constructor for class javax.faces.event.PostConstructViewMapEvent

Instantiate a new PostConstructViewMapEvent that indicates the argument root was just associated with its view map.

PostKeepFlashValueEvent - Class in javax.faces.event

This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is kept in the flash.

PostKeepFlashValueEvent(String) - Constructor for class javax.faces.event.PostKeepFlashValueEvent

Instantiate a new PostKeepFlashValueEvent that indicates the argument key was just kept in the flash.

PostLoad - Annotation Type in javax.persistence

Specifies a callback method for the corresponding lifecycle event.

PostPersist - Annotation Type in javax.persistence

Specifies a callback method for the corresponding lifecycle event.

PostPutFlashValueEvent - Class in javax.faces.event

This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is stored in the flash.

PostPutFlashValueEvent(String) - Constructor for class javax.faces.event.PostPutFlashValueEvent

Instantiate a new PostPutFlashValueEvent that indicates the argument key was just put to the flash.

PostRemove - Annotation Type in javax.persistence

Specifies a callback method for the corresponding lifecycle event.

PostRestoreStateEvent - Class in javax.faces.event

When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is in a tree that has just had its state restored.

PostRestoreStateEvent(UIComponent) - Constructor for class javax.faces.event.PostRestoreStateEvent

Instantiate a new PostRestoreStateEvent that indicates the argument component just had its state restored.

PostUpdate - Annotation Type in javax.persistence

Specifies a callback method for the corresponding lifecycle event.

PostValidateEvent - Class in javax.faces.event

When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is that has just been validated.

PostValidateEvent(UIComponent) - Constructor for class javax.faces.event.PostValidateEvent

preamble - Variable in class javax.mail.internet.MimeMultipart

The MIME multipart preamble text, the text that occurs before the first boundary line.

PreClearFlashEvent - Class in javax.faces.event

This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) before the flash is cleared.

PreClearFlashEvent(Map<String, Object>) - Constructor for class javax.faces.event.PreClearFlashEvent

Instantiate a new PreClearFlashEvent that indicates the argument key was just put to the flash.

PreDestroy - Annotation Type in javax.annotation

The PreDestroy annotation is used on methods as a callback notification to signal that the instance is in the process of being removed by the container.

preDestroy(T) - Method in interface javax.enterprise.inject.spi.InjectionTarget

Calls the PreDestroy callback, if it exists, according to the semantics required by the Java EE platform specification.

preDestroy() - Method in class javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance

Call the @PreDestroy callback

PreDestroyApplicationEvent - Class in javax.faces.event

This event must be published by the runtime before the factories associated with this Application are released.

PreDestroyApplicationEvent(Application) - Constructor for class javax.faces.event.PreDestroyApplicationEvent

Constructs a new PreDestroyApplicationEvent for this application.

PreDestroyCustomScopeEvent - Class in javax.faces.event

This class is provided to allow custom scopes to publish a "pre construct" event in the same way that other scopes do to let the application become aware of the beginning of the scope.

PreDestroyCustomScopeEvent(ScopeContext) - Constructor for class javax.faces.event.PreDestroyCustomScopeEvent

An instance of this event indicates that the custom scope enclosed within the argument scopeContext is about to end.

PreDestroyViewMapEvent - Class in javax.faces.event

This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when the clear method is called on the map returned from UIViewRoot.getViewMap().

PreDestroyViewMapEvent(UIViewRoot) - Constructor for class javax.faces.event.PreDestroyViewMapEvent

Instantiate a new ViewMapDestroydEvent that indicates the argument root just had its associated view map destroyed.

Predicate - Interface in javax.persistence.criteria

The type of a simple or compound predicate: a conjunction or disjunction of restrictions.

Predicate.BooleanOperator - Enum in javax.persistence.criteria

PreencodedMimeBodyPart - Class in javax.mail.internet

A MimeBodyPart that handles data that has already been encoded.

PreencodedMimeBodyPart(String) - Constructor for class javax.mail.internet.PreencodedMimeBodyPart

Create a PreencodedMimeBodyPart that assumes the data is encoded using the specified encoding.

preferredSubprotocols(List<String>) - Method in class javax.websocket.ClientEndpointConfig.Builder

Set the preferred sub protocols for the configuration this builder will build.

prefix - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo

The prefix assigned to this taglib from the taglib directive.

PreJsf2ExceptionHandlerFactory - Class in javax.faces.webapp

This ExceptionHandlerFactory instance produces JSF 1.2 compatible ExceptionHandler instances.

PreJsf2ExceptionHandlerFactory() - Constructor for class javax.faces.webapp.PreJsf2ExceptionHandlerFactory

PreMatching - Annotation Type in javax.ws.rs.container

Global binding annotation that can be applied to a container request filter to indicate that such filter should be applied globally on all resources in the application before the actual resource matching occurs.

prepare(Xid) - Method in interface javax.resource.spi.XATerminator

Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.

prepare() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Prepares for a single tag invocation.

prepare(Xid) - Method in interface javax.transaction.xa.XAResource

Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.

PrePassivate - Annotation Type in javax.ejb

Designates a method to receive a callback before a stateful session bean is passivated.

PrePersist - Annotation Type in javax.persistence

Specifies a callback method for the corresponding lifecycle event.

PreRemove - Annotation Type in javax.persistence

Specifies a callback method for the corresponding lifecycle event.

PreRemoveFlashValueEvent - Class in javax.faces.event

This event must be published by a call to Application.publishEvent(javax.faces.context.FacesContext, java.lang.Class<? extends javax.faces.event.SystemEvent>, java.lang.Object) when a value is removed from the flash.

PreRemoveFlashValueEvent(String) - Constructor for class javax.faces.event.PreRemoveFlashValueEvent

Instantiate a new PreRemoveFlashValueEvent that indicates the argument key will be removed from the flash.

PreRemoveFromViewEvent - Class in javax.faces.event

When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is a UIComponent instance that is about to be removed from the view.

PreRemoveFromViewEvent(UIComponent) - Constructor for class javax.faces.event.PreRemoveFromViewEvent

Instantiate a new BeforeRemoveFromView that indicates the argument component is about to be removed from the view.

PreRenderComponentEvent - Class in javax.faces.event

When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is about to be rendered and that it is safe to call UIComponent.getParent(), UIComponent.getClientId(), and other methods that depend upon the component instance being in the view.

PreRenderComponentEvent(UIComponent) - Constructor for class javax.faces.event.PreRenderComponentEvent

Instantiate a new PreRenderComponentEvent that indicates the argument component is about to be rendered.

PreRenderViewEvent - Class in javax.faces.event

When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIViewRoot instance that is about to be rendered.

PreRenderViewEvent(UIViewRoot) - Constructor for class javax.faces.event.PreRenderViewEvent

Instantiate a new PreRenderViewEvent that indicates the argument root is about to be rendered.

PRETTY_PRINTING - Static variable in interface javax.json.stream.JsonGenerator

Configuration property to generate JSON prettily.

PreUpdate - Annotation Type in javax.persistence

Specifies a callback method for the corresponding lifecycle event.

PreValidateEvent - Class in javax.faces.event

When an instance of this event is passed to SystemEventListener.processEvent(javax.faces.event.SystemEvent) or ComponentSystemEventListener.processEvent(javax.faces.event.ComponentSystemEvent), the listener implementation may assume that the source of this event instance is the UIComponent instance that is about to be validated.

PreValidateEvent(UIComponent) - Constructor for class javax.faces.event.PreValidateEvent

PrimaryKeyJoinColumn - Annotation Type in javax.persistence

Specifies a primary key column that is used as a foreign key to join to another table.

PrimaryKeyJoinColumns - Annotation Type in javax.persistence

Groups PrimaryKeyJoinColumn annotations.

print(boolean) - Method in class javax.servlet.jsp.JspWriter

Print a boolean value.

print(char) - Method in class javax.servlet.jsp.JspWriter

Print a character.

print(int) - Method in class javax.servlet.jsp.JspWriter

Print an integer.

print(long) - Method in class javax.servlet.jsp.JspWriter

Print a long integer.

print(float) - Method in class javax.servlet.jsp.JspWriter

Print a floating-point number.

print(double) - Method in class javax.servlet.jsp.JspWriter

Print a double-precision floating-point number.

print(char[]) - Method in class javax.servlet.jsp.JspWriter

Print an array of characters.

print(String) - Method in class javax.servlet.jsp.JspWriter

Print a string.

print(Object) - Method in class javax.servlet.jsp.JspWriter

Print an object.

print(String) - Method in class javax.servlet.ServletOutputStream

Writes a String to the client, without a carriage return-line feed (CRLF) character at the end.

print(boolean) - Method in class javax.servlet.ServletOutputStream

Writes a boolean value to the client, with no carriage return-line feed (CRLF) character at the end.

print(char) - Method in class javax.servlet.ServletOutputStream

Writes a character to the client, with no carriage return-line feed (CRLF) at the end.

print(int) - Method in class javax.servlet.ServletOutputStream

Writes an int to the client, with no carriage return-line feed (CRLF) at the end.

print(long) - Method in class javax.servlet.ServletOutputStream

Writes a long value to the client, with no carriage return-line feed (CRLF) at the end.

print(float) - Method in class javax.servlet.ServletOutputStream

Writes a float value to the client, with no carriage return-line feed (CRLF) at the end.

print(double) - Method in class javax.servlet.ServletOutputStream

Writes a double value to the client, with no carriage return-line feed (CRLF) at the end.

printAnySimpleType(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts a string value into a string.

printAnySimpleType(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a string value into a string.

printBase64Binary(byte[]) - Static method in class javax.xml.bind.DatatypeConverter

Converts an array of bytes into a string.

printBase64Binary(byte[]) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts an array of bytes into a string.

printBoolean(boolean) - Static method in class javax.xml.bind.DatatypeConverter

Converts a boolean value into a string.

printBoolean(boolean) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a boolean value into a string.

printByte(byte) - Static method in class javax.xml.bind.DatatypeConverter

Converts a byte value into a string.

printByte(byte) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a byte value into a string.

PrintConversionEvent - Interface in javax.xml.bind

This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.

PrintConversionEventImpl - Class in javax.xml.bind.helpers

Default implementation of the PrintConversionEvent interface.

PrintConversionEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers.PrintConversionEventImpl

Create a new PrintConversionEventImpl.

PrintConversionEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers.PrintConversionEventImpl

Create a new PrintConversionEventImpl.

printDate(Calendar) - Static method in class javax.xml.bind.DatatypeConverter

Converts a Calendar value into a string.

printDate(Calendar) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a Calendar value into a string.

printDateTime(Calendar) - Static method in class javax.xml.bind.DatatypeConverter

Converts a Calendar value into a string.

printDateTime(Calendar) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a Calendar value into a string.

printDecimal(BigDecimal) - Static method in class javax.xml.bind.DatatypeConverter

Converts a BigDecimal value into a string.

printDecimal(BigDecimal) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a BigDecimal value into a string.

printDouble(double) - Static method in class javax.xml.bind.DatatypeConverter

Converts a double value into a string.

printDouble(double) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a double value into a string.

printFloat(float) - Static method in class javax.xml.bind.DatatypeConverter

Converts a float value into a string.

printFloat(float) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a float value into a string.

printHexBinary(byte[]) - Static method in class javax.xml.bind.DatatypeConverter

Converts an array of bytes into a string.

printHexBinary(byte[]) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts an array of bytes into a string.

printInt(int) - Static method in class javax.xml.bind.DatatypeConverter

Converts an int value into a string.

printInt(int) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts an int value into a string.

printInteger(BigInteger) - Static method in class javax.xml.bind.DatatypeConverter

Converts a BigInteger value into a string.

printInteger(BigInteger) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a BigInteger value into a string.

println() - Method in class javax.servlet.jsp.JspWriter

Terminate the current line by writing the line separator string.

println(boolean) - Method in class javax.servlet.jsp.JspWriter

Print a boolean value and then terminate the line.

println(char) - Method in class javax.servlet.jsp.JspWriter

Print a character and then terminate the line.

println(int) - Method in class javax.servlet.jsp.JspWriter

Print an integer and then terminate the line.

println(long) - Method in class javax.servlet.jsp.JspWriter

Print a long integer and then terminate the line.

println(float) - Method in class javax.servlet.jsp.JspWriter

Print a floating-point number and then terminate the line.

println(double) - Method in class javax.servlet.jsp.JspWriter

Print a double-precision floating-point number and then terminate the line.

println(char[]) - Method in class javax.servlet.jsp.JspWriter

Print an array of characters and then terminate the line.

println(String) - Method in class javax.servlet.jsp.JspWriter

Print a String and then terminate the line.

println(Object) - Method in class javax.servlet.jsp.JspWriter

Print an Object and then terminate the line.

println() - Method in class javax.servlet.ServletOutputStream

Writes a carriage return-line feed (CRLF) to the client.

println(String) - Method in class javax.servlet.ServletOutputStream

Writes a String to the client, followed by a carriage return-line feed (CRLF).

println(boolean) - Method in class javax.servlet.ServletOutputStream

Writes a boolean value to the client, followed by a carriage return-line feed (CRLF).

println(char) - Method in class javax.servlet.ServletOutputStream

Writes a character to the client, followed by a carriage return-line feed (CRLF).

println(int) - Method in class javax.servlet.ServletOutputStream

Writes an int to the client, followed by a carriage return-line feed (CRLF) character.

println(long) - Method in class javax.servlet.ServletOutputStream

Writes a long value to the client, followed by a carriage return-line feed (CRLF).

println(float) - Method in class javax.servlet.ServletOutputStream

Writes a float value to the client, followed by a carriage return-line feed (CRLF).

println(double) - Method in class javax.servlet.ServletOutputStream

Writes a double value to the client, followed by a carriage return-line feed (CRLF).

printLong(long) - Static method in class javax.xml.bind.DatatypeConverter

Converts A long value into a string.

printLong(long) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a long value into a string.

printQName(QName, NamespaceContext) - Static method in class javax.xml.bind.DatatypeConverter

Converts a QName instance into a string.

printQName(QName, NamespaceContext) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a QName instance into a string.

printShort(short) - Static method in class javax.xml.bind.DatatypeConverter

Converts a short value into a string.

printShort(short) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a short value into a string.

printStackTrace(PrintStream) - Method in exception javax.xml.bind.JAXBException

Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.

printStackTrace() - Method in exception javax.xml.bind.JAXBException

Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.

printStackTrace(PrintWriter) - Method in exception javax.xml.bind.JAXBException

Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintWriter.

printStackTrace(PrintStream) - Method in exception javax.xml.bind.TypeConstraintException

Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.

printStackTrace() - Method in exception javax.xml.bind.TypeConstraintException

Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.

printString(String) - Static method in class javax.xml.bind.DatatypeConverter

Converts the string argument into a string.

printString(String) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts the string argument into a string.

printTime(Calendar) - Static method in class javax.xml.bind.DatatypeConverter

Converts a Calendar value into a string.

printTime(Calendar) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a Calendar value into a string.

printUnsignedInt(long) - Static method in class javax.xml.bind.DatatypeConverter

Converts a long value into a string.

printUnsignedInt(long) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts a long value into a string.

printUnsignedShort(int) - Static method in class javax.xml.bind.DatatypeConverter

Converts an int value into a string.

printUnsignedShort(int) - Method in interface javax.xml.bind.DatatypeConverterInterface

Converts an int value into a string.

Priorities - Class in javax.ws.rs

A collection of built-in priority constants for the JAX-RS components that are supposed to be ordered based on their javax.annotation.Priority class-level annotation value when used or applied by JAX-RS runtime.

Priority - Annotation Type in javax.annotation

The Priority annotation can be applied to classes to indicate in what order the classes should be used.

PrivateKeyCallback - Class in javax.security.auth.message.callback

Callback for acquiring a Public Key Infrastructure (PKI) private key and its corresponding certificate chain.

PrivateKeyCallback(PrivateKeyCallback.Request) - Constructor for class javax.security.auth.message.callback.PrivateKeyCallback

Constructs this PrivateKeyCallback with a private key Request object.

PrivateKeyCallback.AliasRequest - Class in javax.security.auth.message.callback

Request type for private keys that are identified using an alias.

PrivateKeyCallback.AliasRequest(String) - Constructor for class javax.security.auth.message.callback.PrivateKeyCallback.AliasRequest

Construct an AliasRequest with an alias.

PrivateKeyCallback.DigestRequest - Class in javax.security.auth.message.callback

Request type for private keys that are identified using a certificate digest or thumbprint.

PrivateKeyCallback.DigestRequest(byte[], String) - Constructor for class javax.security.auth.message.callback.PrivateKeyCallback.DigestRequest

Constructs a DigestRequest with a digest value and algorithm identifier.

PrivateKeyCallback.IssuerSerialNumRequest - Class in javax.security.auth.message.callback

Request type for private keys that are identified using an issuer/serial number.

PrivateKeyCallback.IssuerSerialNumRequest(X500Principal, BigInteger) - Constructor for class javax.security.auth.message.callback.PrivateKeyCallback.IssuerSerialNumRequest

Constructs a IssuerSerialNumRequest with an issuer/serial number.

PrivateKeyCallback.Request - Interface in javax.security.auth.message.callback

Marker interface for private key request types.

PrivateKeyCallback.SubjectKeyIDRequest - Class in javax.security.auth.message.callback

Request type for private keys that are identified using a SubjectKeyID

PrivateKeyCallback.SubjectKeyIDRequest(byte[]) - Constructor for class javax.security.auth.message.callback.PrivateKeyCallback.SubjectKeyIDRequest

Construct a SubjectKeyIDRequest with an subjectKeyID.

proceed() - Method in interface javax.interceptor.InvocationContext

Proceed to the next interceptor in the interceptor chain.

proceed() - Method in interface javax.ws.rs.ext.ReaderInterceptorContext

Proceed to the next interceptor in the chain.

proceed() - Method in interface javax.ws.rs.ext.WriterInterceptorContext

Proceed to the next interceptor in the chain.

process() - Method in class javax.batch.api.AbstractBatchlet

Implement process logic for the Batchlet in this method.

process() - Method in interface javax.batch.api.Batchlet

The process method does the work of the batchlet.

PROCESS_VALIDATIONS - Static variable in class javax.faces.event.PhaseId

Identifier that indicates an interest in events queued for the Process Validations phase of the request processing lifecycle.

processAction(ActionEvent) - Method in interface javax.faces.event.ActionListener

Invoked when the action described by the specified ActionEvent occurs.

processAction(ActionEvent) - Method in class javax.faces.event.ActionListenerWrapper

processAction(ActionEvent) - Method in class javax.faces.event.MethodExpressionActionListener

Call through to the MethodExpression passed in our constructor.

processAjaxBehavior(AjaxBehaviorEvent) - Method in interface javax.faces.event.AjaxBehaviorListener

ProcessAnnotatedType<X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for each Java class or interface it discovers in a bean archive, before it reads the declared annotations.

processApplication(FacesContext) - Method in class javax.faces.component.UIViewRoot

Broadcast any events that have been queued for the Invoke Application phase of the request processing lifecycle and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.

ProcessBean<X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for each enabled bean, interceptor or decorator deployed in a bean archive, before registering the Bean object.

ProcessBeanAttributes<T> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for each enabled bean, interceptor or decorator deployed in a bean archive before registering the Bean object.

processDecodes(FacesContext) - Method in class javax.faces.component.UIComponent

Perform the component tree processing required by the Apply Request Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

processDecodes(FacesContext) - Method in class javax.faces.component.UIComponentBase

processDecodes(FacesContext) - Method in class javax.faces.component.UIData

Override the default UIComponentBase.processDecodes(javax.faces.context.FacesContext) processing to perform the following steps.

processDecodes(FacesContext) - Method in class javax.faces.component.UIForm

Override UIComponent.processDecodes(javax.faces.context.FacesContext) to ensure that the form is decoded before its children.

processDecodes(FacesContext) - Method in class javax.faces.component.UIInput

Specialized decode behavior on top of that provided by the superclass.

processDecodes(FacesContext) - Method in class javax.faces.component.UIViewRoot

processEvent(ComponentSystemEvent) - Method in class javax.faces.component.UIComponent

The default implementation performs the following action.

processEvent(SystemEvent) - Method in class javax.faces.context.ExceptionHandler

When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

processEvent(SystemEvent) - Method in class javax.faces.context.ExceptionHandlerWrapper

The default behavior of this method is to call ExceptionHandler.processEvent(javax.faces.event.SystemEvent) on the wrapped ExceptionHandler object.

processEvent(ComponentSystemEvent) - Method in interface javax.faces.event.ComponentSystemEventListener

When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

processEvent(SystemEvent) - Method in interface javax.faces.event.SystemEventListener

When called, the listener can assume that any guarantees given in the javadoc for the specific SystemEvent subclass are true.

ProcessingException - Exception in javax.ws.rs

A base JAX-RS runtime processing exception.

ProcessingException(Throwable) - Constructor for exception javax.ws.rs.ProcessingException

Constructs a new JAX-RS runtime processing exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

ProcessingException(String, Throwable) - Constructor for exception javax.ws.rs.ProcessingException

Constructs a new JAX-RS runtime processing exception with the specified detail message and cause.

ProcessingException(String) - Constructor for exception javax.ws.rs.ProcessingException

Constructs a new JAX-RS runtime processing exception with the specified detail message.

ProcessInjectionPoint<T,X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for every injection point of every Java EE component class supporting injection that may be instantiated by the container at runtime, including every managed bean declared using javax.annotation.ManagedBean, EJB session or message-driven bean, enabled bean, enabled interceptor or enabled decorator.

ProcessInjectionTarget<X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for every Java EE component class supporting injection that may be instantiated by the container at runtime, including every managed bean declared using javax.annotation.ManagedBean, EJB session or message-driven bean, enabled bean, enabled interceptor or enabled decorator.

processItem(Object) - Method in interface javax.batch.api.chunk.ItemProcessor

The processItem method is part of a chunk step.

processListener(FacesListener) - Method in class javax.faces.event.ActionEvent

processListener(FacesListener) - Method in class javax.faces.event.AjaxBehaviorEvent

Broadcast this event instance to the specified FacesListener, by whatever mechanism is appropriate.

processListener(FacesListener) - Method in class javax.faces.event.ComponentSystemEvent

Broadcast this event instance to the specified FacesListener by calling the superclass's processListener() implementation.

processListener(FacesListener) - Method in class javax.faces.event.FacesEvent

Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate.

processListener(FacesListener) - Method in class javax.faces.event.SystemEvent

Broadcast this event instance to the specified FacesListener, by whatever mechanism is appropriate.

processListener(FacesListener) - Method in class javax.faces.event.ValueChangeEvent

ProcessManagedBean<X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for each enabled managed bean, before registering the Bean object.

ProcessObserverMethod<T,X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for each observer method of each enabled bean, before registering the ObserverMethod object.

processPartial(PhaseId) - Method in class javax.faces.context.PartialViewContext

Perform lifecycle processing on components during the indicated phaseId.

processPartial(PhaseId) - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.processPartial(PhaseId) on the wrapped PartialViewContext object.

ProcessProducer<T,X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for each producer method or field of each enabled bean, including resources.

ProcessProducerField<T,X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for each enabled producer field, before registering the Bean object.

ProcessProducerMethod<T,X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for each enabled producer method, before registering the Bean object.

processRestoreState(FacesContext, Object) - Method in class javax.faces.component.UIComponent

Perform the component tree processing required by the Restore View phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

processRestoreState(FacesContext, Object) - Method in class javax.faces.component.UIComponentBase

processRestoreState(FacesContext, Object) - Method in class javax.faces.component.UIViewRoot

The default implementation must call UIComponentBase.processRestoreState(javax.faces.context.FacesContext, java.lang.Object) from within a try block.

processSaveState(FacesContext) - Method in class javax.faces.component.UIComponent

Perform the component tree processing required by the state saving portion of the Render Response phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

processSaveState(FacesContext) - Method in class javax.faces.component.UIComponentBase

ProcessSessionBean<X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for each enabled session bean, before registering the Bean object.

ProcessSyntheticAnnotatedType<X> - Interface in javax.enterprise.inject.spi

The container fires an event of this type for each Java class or interface added by BeforeBeanDiscovery.addAnnotatedType(AnnotatedType).

processUpdates(FacesContext) - Method in class javax.faces.component.UIComponent

Perform the component tree processing required by the Update Model Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

processUpdates(FacesContext) - Method in class javax.faces.component.UIComponentBase

processUpdates(FacesContext) - Method in class javax.faces.component.UIData

Override the default UIComponentBase.processUpdates(javax.faces.context.FacesContext) processing to perform the following steps.

processUpdates(FacesContext) - Method in class javax.faces.component.UIForm

Override UIComponent.processUpdates(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if UIForm.isSubmitted() returns true.

processUpdates(FacesContext) - Method in class javax.faces.component.UIInput

In addition to the standard processUpdates behavior inherited from UIComponentBase, calls updateModel().

processUpdates(FacesContext) - Method in class javax.faces.component.UIViewRoot

processValidators(FacesContext) - Method in class javax.faces.component.UIComponent

Perform the component tree processing required by the Process Validations phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

processValidators(FacesContext) - Method in class javax.faces.component.UIComponentBase

processValidators(FacesContext) - Method in class javax.faces.component.UIData

Override the default UIComponentBase.processValidators(javax.faces.context.FacesContext) processing to perform the following steps.

processValidators(FacesContext) - Method in class javax.faces.component.UIForm

Override UIComponent.processValidators(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if UIForm.isSubmitted() returns true.

processValidators(FacesContext) - Method in class javax.faces.component.UIInput

In addition to the standard processValidators behavior inherited from UIComponentBase, calls validate() if the immediate property is false (which is the default); if the component is invalid afterwards, calls FacesContext.renderResponse().

processValidators(FacesContext) - Method in class javax.faces.component.UIViewParameter

Specialize superclass behavior to treat null differently.

processValidators(FacesContext) - Method in class javax.faces.component.UIViewRoot

processValueChange(ValueChangeEvent) - Method in class javax.faces.event.MethodExpressionValueChangeListener

Call through to the MethodExpression passed in our constructor.

processValueChange(ValueChangeEvent) - Method in interface javax.faces.event.ValueChangeListener

Invoked when the value change described by the specified ValueChangeEvent occurs.

prod(Expression<? extends N>, Expression<? extends N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the product of its arguments.

prod(Expression<? extends N>, N) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the product of its arguments.

prod(N, Expression<? extends N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the product of its arguments.

produce(CreationalContext<T>) - Method in interface javax.enterprise.inject.spi.Producer

Causes an instance to be produced via the Producer.

produce() - Method in class javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance

Create the instance

Producer<T> - Interface in javax.enterprise.inject.spi

Provides a generic operation for producing an instance of a type.

ProducerFactory<X> - Interface in javax.enterprise.inject.spi

An ProducerFactory can create an Producer for a given bean.

Produces - Annotation Type in javax.enterprise.inject

Identifies a producer method or field.

Produces - Annotation Type in javax.ws.rs

Defines the media type(s) that the methods of a resource class or MessageBodyWriter can produce.

ProgressEvent - Class in javax.enterprise.deploy.spi.status

An event which indicates that a deployment status change has occurred.

ProgressEvent(Object, TargetModuleID, DeploymentStatus) - Constructor for class javax.enterprise.deploy.spi.status.ProgressEvent

Creates a new object representing a deployment progress event.

ProgressListener - Interface in javax.enterprise.deploy.spi.status

The listener interface for receiving deployment progress events.

ProgressObject - Interface in javax.enterprise.deploy.spi.status

The ProgressObject interface tracks and reports the progress of the deployment activities, distribute, start, stop, undeploy.

PROJECT_STAGE_JNDI_NAME - Static variable in enum javax.faces.application.ProjectStage

The value of this constant is the name used for JNDI lookups for setting the current value to be returned by Application.getProjectStage().

PROJECT_STAGE_PARAM_NAME - Static variable in enum javax.faces.application.ProjectStage

The value of this constant is the value of the param-name for setting the current value to be returned by Application.getProjectStage().

ProjectStage - Enum in javax.faces.application

This class enables a feature similar to the RAILS_ENV feature of the Ruby on Rails web framework.

property(String, Object) - Method in interface javax.ws.rs.client.Invocation.Builder

Set a new property in the context of a request represented by this invocation builder.

property(String, Object) - Method in interface javax.ws.rs.client.Invocation

Set a new property in the context of a request represented by this invocation.

property(String, Object) - Method in interface javax.ws.rs.core.Configurable

Set the new configuration property, if already set, the existing value of the property will be updated.

PropertyDescriptor - Interface in javax.validation.metadata

Describes a Java Bean property hosting validation constraints.

PropertyException - Exception in javax.xml.bind

This exception indicates that an error was encountered while getting or setting a property.

PropertyException(String) - Constructor for exception javax.xml.bind.PropertyException

Construct a PropertyException with the specified detail message.

PropertyException(String, String) - Constructor for exception javax.xml.bind.PropertyException

Construct a PropertyException with the specified detail message and vendor specific errorCode.

PropertyException(Throwable) - Constructor for exception javax.xml.bind.PropertyException

Construct a PropertyException with a linkedException.

PropertyException(String, Throwable) - Constructor for exception javax.xml.bind.PropertyException

Construct a PropertyException with the specified detail message and linkedException.

PropertyException(String, String, Throwable) - Constructor for exception javax.xml.bind.PropertyException

Construct a PropertyException with the specified detail message, vendor specific errorCode, and linkedException.

PropertyException(String, Object) - Constructor for exception javax.xml.bind.PropertyException

Construct a PropertyException whose message field is set based on the name of the property and value.toString().

propertyExists(String) - Method in interface javax.jms.JMSProducer

Indicates whether a message property with the specified name has been set on this JMSProducer

propertyExists(String) - Method in interface javax.jms.Message

Indicates whether a property value exists.

PropertyNotFoundException - Exception in javax.el

Thrown when a property could not be found while evaluating a ValueExpression or MethodExpression.

PropertyNotFoundException() - Constructor for exception javax.el.PropertyNotFoundException

Creates a PropertyNotFoundException with no detail message.

PropertyNotFoundException(String) - Constructor for exception javax.el.PropertyNotFoundException

Creates a PropertyNotFoundException with the provided detail message.

PropertyNotFoundException(Throwable) - Constructor for exception javax.el.PropertyNotFoundException

Creates a PropertyNotFoundException with the given root cause.

PropertyNotFoundException(String, Throwable) - Constructor for exception javax.el.PropertyNotFoundException

Creates a PropertyNotFoundException with the given detail message and root cause.

PropertyNotFoundException - Exception in javax.faces.el

Deprecated.
This has been replaced by PropertyNotFoundException.

PropertyNotFoundException() - Constructor for exception javax.faces.el.PropertyNotFoundException

Deprecated.

Construct a new exception with no detail message or root cause.

PropertyNotFoundException(String) - Constructor for exception javax.faces.el.PropertyNotFoundException

Deprecated.

Construct a new exception with the specified detail message and no root cause.

PropertyNotFoundException(Throwable) - Constructor for exception javax.faces.el.PropertyNotFoundException

Deprecated.

Construct a new exception with the specified root cause.

PropertyNotFoundException(String, Throwable) - Constructor for exception javax.faces.el.PropertyNotFoundException

Deprecated.

Construct a new exception with the specified detail message and root cause.

PropertyNotWritableException - Exception in javax.el

Thrown when a property could not be written to while setting the value on a ValueExpression.

PropertyNotWritableException() - Constructor for exception javax.el.PropertyNotWritableException

Creates a PropertyNotWritableException with no detail message.

PropertyNotWritableException(String) - Constructor for exception javax.el.PropertyNotWritableException

Creates a PropertyNotWritableException with the provided detail message.

PropertyNotWritableException(Throwable) - Constructor for exception javax.el.PropertyNotWritableException

Creates a PropertyNotWritableException with the given root cause.

PropertyNotWritableException(String, Throwable) - Constructor for exception javax.el.PropertyNotWritableException

Creates a PropertyNotWritableException with the given detail message and root cause.

propertyResolved(ELContext, Object, Object) - Method in class javax.el.EvaluationListener

Receives notification when the (base, property) pair is resolved

PropertyResolver - Class in javax.faces.el

Deprecated.
This has been replaced by ELResolver.

PropertyResolver() - Constructor for class javax.faces.el.PropertyResolver

Deprecated.

ProtectedViewException - Exception in javax.faces.application

This exception is thrown by the runtime when a violation of the view protection mechanism is encountered.

ProtectedViewException(Throwable) - Constructor for exception javax.faces.application.ProtectedViewException

ProtectedViewException(String, Throwable) - Constructor for exception javax.faces.application.ProtectedViewException

ProtectedViewException(String) - Constructor for exception javax.faces.application.ProtectedViewException

ProtectedViewException() - Constructor for exception javax.faces.application.ProtectedViewException

protocolConnect(String, int, String, String) - Method in class javax.mail.Service

The service implementation should override this method to perform the actual protocol-specific connection attempt.

ProtocolException - Exception in javax.xml.ws

The ProtocolException class is a base class for exceptions related to a specific protocol binding.

ProtocolException() - Constructor for exception javax.xml.ws.ProtocolException

Constructs a new protocol exception with null as its detail message.

ProtocolException(String) - Constructor for exception javax.xml.ws.ProtocolException

Constructs a new protocol exception with the specified detail message.

ProtocolException(String, Throwable) - Constructor for exception javax.xml.ws.ProtocolException

Constructs a new runtime exception with the specified detail message and cause.

ProtocolException(Throwable) - Constructor for exception javax.xml.ws.ProtocolException

Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

PROVIDER - Static variable in class javax.ejb.embeddable.EJBContainer

Standard property name for specifying the embeddable container implementation bootstrap class.

Provider<T> - Interface in javax.inject

Provides instances of T.

provider() - Static method in class javax.json.spi.JsonProvider

Creates a JSON provider object.

Provider - Class in javax.mail

The Provider is a class that describes a protocol implementation.

Provider(Provider.Type, String, String, String, String) - Constructor for class javax.mail.Provider

Create a new provider of the specified type for the specified protocol.

Provider - Annotation Type in javax.ws.rs.ext

Marks an implementation of an extension interface that should be discoverable by JAX-RS runtime during a provider scanning phase.

Provider<T> - Interface in javax.xml.ws

Service endpoints may implement the Provider interface as a dynamic alternative to an SEI.

Provider - Class in javax.xml.ws.spi

Service provider for ServiceDelegate and Endpoint objects.

Provider() - Constructor for class javax.xml.ws.spi.Provider

Creates a new instance of Provider

provider() - Static method in class javax.xml.ws.spi.Provider

Creates a new provider object.

Provider.Type - Class in javax.mail

This inner class defines the Provider type.

PROVIDER_REGISTRATION_PERMISSION_NAME - Static variable in class javax.security.auth.message.config.AuthConfigFactory

The name of the SecurityPermission to be used to authorize access to the update methods of the factory implementation class.

providerRegistrationSecurityPermission - Static variable in class javax.security.auth.message.config.AuthConfigFactory

An instance of the SecurityPermission (with name AuthConfigFactory.PROVIDER_REGISTRATION_PERMISSION_NAME) for use in authorizing access to the update methods of the factory implementation class.

providerResolver(ValidationProviderResolver) - Method in interface javax.validation.bootstrap.GenericBootstrap

Defines the provider resolution strategy.

providerResolver(ValidationProviderResolver) - Method in interface javax.validation.bootstrap.ProviderSpecificBootstrap

Optionally defines the provider resolver implementation used.

providers - Static variable in class javax.persistence.Persistence

Deprecated.

Providers - Interface in javax.ws.rs.ext

An injectable interface providing runtime lookup of provider instances.

ProviderSpecificBootstrap<T extends Configuration<T>> - Interface in javax.validation.bootstrap

Defines the state used to bootstrap Bean Validation and creates a provider specific Configuration of type T.

ProviderUtil - Interface in javax.persistence.spi

Utility interface implemented by the persistence provider.

publish(Message) - Method in interface javax.jms.TopicPublisher

Publishes a message to the topic.

publish(Message, int, int, long) - Method in interface javax.jms.TopicPublisher

Publishes a message to the topic, specifying delivery mode, priority, and time to live.

publish(Topic, Message) - Method in interface javax.jms.TopicPublisher

Publishes a message to a topic for an unidentified message producer.

publish(Topic, Message, int, int, long) - Method in interface javax.jms.TopicPublisher

Publishes a message to a topic for an unidentified message producer, specifying delivery mode, priority and time to live.

publish(String) - Method in class javax.xml.ws.Endpoint

Publishes this endpoint at the given address.

publish(String, Object) - Static method in class javax.xml.ws.Endpoint

Creates and publishes an endpoint for the specified implementor object at the given address.

publish(String, Object, WebServiceFeature...) - Static method in class javax.xml.ws.Endpoint

Creates and publishes an endpoint for the specified implementor object at the given address.

publish(Object) - Method in class javax.xml.ws.Endpoint

Publishes this endpoint at the provided server context.

publish(HttpContext) - Method in class javax.xml.ws.Endpoint

Publishes this endpoint at the provided server context.

publishEvent(FacesContext, Class<? extends SystemEvent>, Object) - Method in class javax.faces.application.Application

If FacesContext.isProcessingEvents() is true and there are one or more listeners for events of the type represented by systemEventClass, call those listeners, passing source as the source of the event.

publishEvent(FacesContext, Class<? extends SystemEvent>, Class<?>, Object) - Method in class javax.faces.application.Application

This method functions exactly like Application.publishEvent(FacesContext,Class,Object), except the run-time must use the argument sourceBaseType to find the matching listener instead of using the Class of the source argument.

publishEvent(FacesContext, Class<? extends SystemEvent>, Object) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.publishEvent(javax.faces.context.FacesContext, Class, Object) on the wrapped Application object.

publishEvent(FacesContext, Class<? extends SystemEvent>, Class<?>, Object) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.publishEvent(javax.faces.context.FacesContext, Class, Class, Object) on the wrapped Application object.

push(T) - Method in interface javax.enterprise.context.spi.CreationalContext

Registers an incompletely initialized contextual instance the with the container.

pushBody(Writer) - Method in class javax.servlet.jsp.JspContext

Return a new JspWriter object that sends output to the provided Writer.

pushBody() - Method in class javax.servlet.jsp.PageContext

Return a new BodyContent object, save the current "out" JspWriter, and update the value of the "out" attribute in the page scope attribute namespace of the PageContext.

pushComponentToEL(FacesContext, UIComponent) - Method in class javax.faces.component.UIComponent

Push the current UIComponent this to the FacesContext attribute map using the key UIComponent.CURRENT_COMPONENT saving the previous UIComponent associated with UIComponent.CURRENT_COMPONENT for a subsequent call to UIComponent.popComponentFromEL(javax.faces.context.FacesContext).

pushReturnMode(FacesContext) - Method in class javax.faces.flow.FlowHandler

Enable the correct handling of navigation when processing a return node.

put(Serializable, Object) - Method in interface javax.faces.component.StateHelper

Return the previously stored value and store the specified key/value pair.

put(Serializable, String, Object) - Method in interface javax.faces.component.StateHelper

Store the specified mapKey/value in a Map that is internal to the helper, and return the previously stored value.

put(String, Object) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.put(K, V) on the wrapped Flash object.

put(MessageInfo, Object) - Method in interface javax.security.auth.message.MessagePolicy.Target

Put the Object into the MessageInfo at the location identified by the target.

put(Entity<?>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP PUT method for the current request asynchronously.

put(Entity<?>, Class<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP PUT method for the current request asynchronously.

put(Entity<?>, GenericType<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP PUT method for the current request asynchronously.

put(Entity<?>, InvocationCallback<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP PUT method for the current request asynchronously.

put(Entity<?>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP PUT method for the current request synchronously.

put(Entity<?>, Class<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP PUT method for the current request synchronously.

put(Entity<?>, GenericType<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP PUT method for the current request synchronously.

put(K, List<V>) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

PUT - Static variable in annotation type javax.ws.rs.HttpMethod

HTTP PUT method.

PUT - Annotation Type in javax.ws.rs

Indicates that the annotated method responds to HTTP PUT requests.

putAll(Map<? extends String, ? extends Object>) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.putAll(Map) on the wrapped Flash object.

putAll(Map<? extends K, ? extends List<V>>) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

putContext(Class, Object) - Method in class javax.el.ELContext

Associates a context object with this ELContext.

putContext(Class, Object) - Method in class javax.el.StandardELContext

putNow(String, Object) - Method in class javax.faces.context.Flash

Puts a value in the flash so that it can be accessed on this traversal of the lifecycle, rather than on the next traversal.

putNow(String, Object) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Flash.putNow(String, Object) on the wrapped Flash object.

putResource(Object, Object) - Method in interface javax.transaction.TransactionSynchronizationRegistry

Add or replace an object in the Map of resources being managed for the transaction bound to the current thread at the time this method is called.

putSingle(K, V) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

Set the value for the key to be a one item list consisting of the supplied value.

putSingle(K, V) - Method in interface javax.ws.rs.core.MultivaluedMap

Set the key's value to be a one item list consisting of the supplied value.

putTransient(Object, Object) - Method in interface javax.faces.component.TransientStateHelper

Return the previously stored value and store the specified key/value pair.

putValue(String, Object) - Method in interface javax.servlet.http.HttpSession

Deprecated.
As of Version 2.2, this method is replaced by HttpSession.setAttribute(java.lang.String, java.lang.Object)

Q

QNameHolder - Class in javax.xml.rpc.holders

QNameHolder() - Constructor for class javax.xml.rpc.holders.QNameHolder

QNameHolder(QName) - Constructor for class javax.xml.rpc.holders.QNameHolder

Qualifier - Annotation Type in javax.inject

Identifies qualifier annotations.

Query - Interface in javax.persistence

Interface used to control query execution.

Query - Interface in javax.xml.registry

The Query interface encapsulates a query in a declarative query language.

QUERY_STRING - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: Query string for request.

QUERY_TYPE_EBXML_FILTER_QUERY - Static variable in interface javax.xml.registry.Query

An OASIS ebXML Registry XML Filter Query type.

QUERY_TYPE_SQL - Static variable in interface javax.xml.registry.Query

An SQL query type.

QUERY_TYPE_XQUERY - Static variable in interface javax.xml.registry.Query

A W3C XQuery type.

QueryHint - Annotation Type in javax.persistence

Used to supply a query property or hint to the NamedQuery or NamedNativeQuery annotation.

QueryManager - Interface in javax.xml.registry

This is the common base interface for all QueryManagers in the API.

queryNames(ObjectName, QueryExp) - Method in interface javax.management.j2ee.Management

Gets the names of managed objects controlled by the MEJB.

queryParam(String, Object...) - Method in interface javax.ws.rs.client.WebTarget

Create a new WebTarget instance by configuring a query parameter on the URI of the current target instance.

queryParam(String, Object...) - Method in class javax.ws.rs.core.UriBuilder

Append a query parameter to the existing set of query parameters.

QueryParam - Annotation Type in javax.ws.rs

Binds the value(s) of a HTTP query parameter to a resource method parameter, resource class field, or resource class bean property.

QueryTimeoutException - Exception in javax.persistence

Thrown by the persistence provider when a query times out and only the statement is rolled back.

QueryTimeoutException() - Constructor for exception javax.persistence.QueryTimeoutException

Constructs a new QueryTimeoutException exception with null as its detail message.

QueryTimeoutException(String) - Constructor for exception javax.persistence.QueryTimeoutException

Constructs a new QueryTimeoutException exception with the specified detail message.

QueryTimeoutException(String, Throwable) - Constructor for exception javax.persistence.QueryTimeoutException

Constructs a new QueryTimeoutException exception with the specified detail message and cause.

QueryTimeoutException(Throwable) - Constructor for exception javax.persistence.QueryTimeoutException

Constructs a new QueryTimeoutException exception with the specified cause.

QueryTimeoutException(Query) - Constructor for exception javax.persistence.QueryTimeoutException

Constructs a new QueryTimeoutException exception with the specified query.

QueryTimeoutException(String, Throwable, Query) - Constructor for exception javax.persistence.QueryTimeoutException

Constructs a new QueryTimeoutException exception with the specified detail message, cause, and query.

queue() - Method in class javax.faces.event.FacesEvent

Convenience method to queue this event for broadcast at the end of the current request processing lifecycle phase.

Queue - Interface in javax.jms

A Queue object encapsulates a provider-specific queue name.

QueueBrowser - Interface in javax.jms

A client uses a QueueBrowser object to look at messages on a queue without removing them.

QueueConnection - Interface in javax.jms

A QueueConnection object is an active connection to a point-to-point JMS provider.

QueueConnectionFactory - Interface in javax.jms

A client uses a QueueConnectionFactory object to create QueueConnection objects with a point-to-point JMS provider.

queueEvent(FacesEvent) - Method in class javax.faces.component.UICommand

Intercept queueEvent and take the following action.

queueEvent(FacesEvent) - Method in class javax.faces.component.UIComponent

Queue an event for broadcast at the end of the current request processing lifecycle phase.

queueEvent(FacesEvent) - Method in class javax.faces.component.UIComponentBase

queueEvent(FacesEvent) - Method in class javax.faces.component.UIData

Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) processing to wrap any queued events in a wrapper so that we can reset the current row index in broadcast().

queueEvent(FacesEvent) - Method in class javax.faces.component.UIViewRoot

Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) behavior to accumulate the queued events for later broadcasting.

queueEvent(MailEvent, Vector) - Method in class javax.mail.Service

Add the event and vector of listeners to the queue to be delivered.

QueueReceiver - Interface in javax.jms

A client uses a QueueReceiver object to receive messages that have been delivered to a queue.

QueueRequestor - Class in javax.jms

The QueueRequestor helper class simplifies making service requests.

QueueRequestor(QueueSession, Queue) - Constructor for class javax.jms.QueueRequestor

Constructor for the QueueRequestor class.

QueueSender - Interface in javax.jms

A client uses a QueueSender object to send messages to a queue.

QueueSession - Interface in javax.jms

A QueueSession object provides methods for creating QueueReceiver, QueueSender, QueueBrowser, and TemporaryQueue objects.

quot(Expression<? extends Number>, Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the quotient of its arguments.

quot(Expression<? extends Number>, Number) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the quotient of its arguments.

quot(Number, Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the quotient of its arguments.

Quota - Class in javax.mail

This class represents a set of quotas for a given quota root.

Quota(String) - Constructor for class javax.mail.Quota

Create a Quota object for the named quotaroot with no associated resources.

Quota.Resource - Class in javax.mail

An individual resource in a quota root.

Quota.Resource(String, long, long) - Constructor for class javax.mail.Quota.Resource

Construct a Resource object with the given name, usage, and limit.

QuotaAwareStore - Interface in javax.mail

An interface implemented by Stores that support quotas.

quotaRoot - Variable in class javax.mail.Quota

The name of the quota root.

quote(String, String) - Static method in class javax.mail.internet.MimeUtility

A utility method to quote a word, if the word contains any characters from the specified 'specials' list.

QUOTEDSTRING - Static variable in class javax.mail.internet.HeaderTokenizer.Token

Token type indicating a quoted string.

R

RangeStatistic - Interface in javax.management.j2ee.statistics

Specifies standard measurements of the lowest and highest values an attribute has held as well as its current value.

RAR - Static variable in class javax.enterprise.deploy.shared.ModuleType

The module is an Connector archive.

read() - Method in interface javax.json.JsonReader

Returns a JSON array or object that is represented in the input source.

read() - Method in class javax.mail.util.SharedFileInputStream

See the general contract of the read method of InputStream.

read(byte[], int, int) - Method in class javax.mail.util.SharedFileInputStream

Reads bytes from this stream into the specified byte array, starting at the given offset.

read(InputStream) - Method in interface javax.resource.cci.Streamable

Read data from an InputStream and initialize fields of a Streamable object.

READ_ONLY - Static variable in class javax.mail.Folder

The Folder is read only.

READ_WRITE - Static variable in class javax.mail.Folder

The state and contents of this folder can be modified.

readArray() - Method in interface javax.json.JsonReader

Returns a JSON array that is represented in the input source.

readBoolean() - Method in interface javax.jms.BytesMessage

Reads a boolean from the bytes message stream.

readBoolean() - Method in interface javax.jms.StreamMessage

Reads a boolean from the stream message.

readByte() - Method in interface javax.jms.BytesMessage

Reads a signed 8-bit value from the bytes message stream.

readByte() - Method in interface javax.jms.StreamMessage

Reads a byte value from the stream message.

readBytes(byte[]) - Method in interface javax.jms.BytesMessage

Reads a byte array from the bytes message stream.

readBytes(byte[], int) - Method in interface javax.jms.BytesMessage

Reads a portion of the bytes message stream.

readBytes(byte[]) - Method in interface javax.jms.StreamMessage

Reads a byte array field from the stream message into the specified byte[] object (the read buffer).

readChar() - Method in interface javax.jms.BytesMessage

Reads a Unicode character value from the bytes message stream.

readChar() - Method in interface javax.jms.StreamMessage

Reads a Unicode character value from the stream message.

readDouble() - Method in interface javax.jms.BytesMessage

Reads a double from the bytes message stream.

readDouble() - Method in interface javax.jms.StreamMessage

Reads a double from the stream message.

readEJBHome(ObjectInputStream) - Method in interface javax.ejb.spi.HandleDelegate

Deserialize the EJBHome reference corresponding to a HomeHandle.

readEJBObject(ObjectInputStream) - Method in interface javax.ejb.spi.HandleDelegate

Deserialize the EJBObject reference corresponding to a Handle.

readEndpointReference(Source) - Method in class javax.xml.ws.spi.Provider

read an EndpointReference from the infoset contained in eprInfoset.

readEntity(Class<T>) - Method in class javax.ws.rs.core.Response

Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.

readEntity(GenericType<T>) - Method in class javax.ws.rs.core.Response

Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.

readEntity(Class<T>, Annotation[]) - Method in class javax.ws.rs.core.Response

Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.

readEntity(GenericType<T>, Annotation[]) - Method in class javax.ws.rs.core.Response

Read the message entity input stream as an instance of specified Java type using a MessageBodyReader that supports mapping the message entity stream onto the requested type.

ReaderInterceptor - Interface in javax.ws.rs.ext

Interface for message body reader interceptors that wrap around calls to MessageBodyReader.readFrom(java.lang.Class<T>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.String>, java.io.InputStream).

ReaderInterceptorContext - Interface in javax.ws.rs.ext

Context class used by ReaderInterceptor to intercept calls to (@link javax.ws.rs.ext.MessageBodyReader#readFrom}.

readFloat() - Method in interface javax.jms.BytesMessage

Reads a float from the bytes message stream.

readFloat() - Method in interface javax.jms.StreamMessage

Reads a float from the stream message.

readFrom(Class<T>, Type, Annotation[], MediaType, MultivaluedMap<String, String>, InputStream) - Method in interface javax.ws.rs.ext.MessageBodyReader

Read a type from the InputStream.

readFrom(Source) - Static method in class javax.xml.ws.EndpointReference

Factory method to read an EndpointReference from the infoset contained in eprInfoset.

readInt() - Method in interface javax.jms.BytesMessage

Reads a signed 32-bit integer from the bytes message stream.

readInt() - Method in interface javax.jms.StreamMessage

Reads a 32-bit integer from the stream message.

readItem() - Method in class javax.batch.api.chunk.AbstractItemReader

Implement read logic for the ItemReader in this method.

readItem() - Method in interface javax.batch.api.chunk.ItemReader

The readItem method returns the next item for chunk processing.

readLine(byte[], int, int) - Method in class javax.servlet.ServletInputStream

Reads the input stream, one line at a time.

ReadListener - Interface in javax.servlet

This class represents a call-back mechanism that will notify implementations as HTTP request data becomes available to be read without blocking.

readLong() - Method in interface javax.jms.BytesMessage

Reads a signed 64-bit integer from the bytes message stream.

readLong() - Method in interface javax.jms.StreamMessage

Reads a 64-bit integer from the stream message.

readObject() - Method in interface javax.jms.StreamMessage

Reads an object from the stream message.

readObject() - Method in interface javax.json.JsonReader

Returns a JSON object that is represented in the input source.

ReadOnlyFolderException - Exception in javax.mail

This exception is thrown when an attempt is made to open a folder read-write access when the folder is marked read-only.

ReadOnlyFolderException(Folder) - Constructor for exception javax.mail.ReadOnlyFolderException

Constructs a ReadOnlyFolderException with the specified folder and no detail message.

ReadOnlyFolderException(Folder, String) - Constructor for exception javax.mail.ReadOnlyFolderException

Constructs a ReadOnlyFolderException with the specified detail message.

ReadOnlyFolderException(Folder, String, Exception) - Constructor for exception javax.mail.ReadOnlyFolderException

Constructs a ReadOnlyFolderException with the specified detail message and embedded exception.

readResolve() - Method in class javax.mail.internet.MimeMessage.RecipientType

readResolve() - Method in class javax.mail.Message.RecipientType

When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class.

readShort() - Method in interface javax.jms.BytesMessage

Reads a signed 16-bit number from the bytes message stream.

readShort() - Method in interface javax.jms.StreamMessage

Reads a 16-bit integer from the stream message.

readString() - Method in interface javax.jms.StreamMessage

Reads a String from the stream message.

readUnsignedByte() - Method in interface javax.jms.BytesMessage

Reads an unsigned 8-bit number from the bytes message stream.

readUnsignedShort() - Method in interface javax.jms.BytesMessage

Reads an unsigned 16-bit number from the bytes message stream.

readUTF() - Method in interface javax.jms.BytesMessage

Reads a string that has been encoded using a modified UTF-8 format from the bytes message stream.

receive() - Method in interface javax.jms.JMSConsumer

Receives the next message produced for this JMSConsumer.

receive(long) - Method in interface javax.jms.JMSConsumer

Receives the next message that arrives within the specified timeout interval.

receive() - Method in interface javax.jms.MessageConsumer

Receives the next message produced for this message consumer.

receive(long) - Method in interface javax.jms.MessageConsumer

Receives the next message that arrives within the specified timeout interval.

receiveBody(Class<T>) - Method in interface javax.jms.JMSConsumer

Receives the next message produced for this JMSConsumer and returns its body as an object of the specified type.

receiveBody(Class<T>, long) - Method in interface javax.jms.JMSConsumer

Receives the next message produced for this JMSConsumer that arrives within the specified timeout period and returns its body as an object of the specified type.

receiveBodyNoWait(Class<T>) - Method in interface javax.jms.JMSConsumer

Receives the next message produced for this JMSConsumer if one is immediately available and returns its body as an object of the specified type.

ReceivedDateTerm - Class in javax.mail.search

This class implements comparisons for the Message Received date

ReceivedDateTerm(int, Date) - Constructor for class javax.mail.search.ReceivedDateTerm

Constructor.

receiveNoWait() - Method in interface javax.jms.JMSConsumer

Receives the next message if one is immediately available.

receiveNoWait() - Method in interface javax.jms.MessageConsumer

Receives the next message if one is immediately available.

RECENT - Static variable in class javax.mail.Flags.Flag

This message is recent.

Reception - Enum in javax.enterprise.event

Distinguishes conditional observer methods from observer methods which are always notified.

RecipientStringTerm - Class in javax.mail.search

This class implements string comparisons for the Recipient Address headers.

RecipientStringTerm(Message.RecipientType, String) - Constructor for class javax.mail.search.RecipientStringTerm

Constructor.

RecipientTerm - Class in javax.mail.search

This class implements comparisons for the Recipient Address headers.

RecipientTerm(Message.RecipientType, Address) - Constructor for class javax.mail.search.RecipientTerm

Constructor.

Record - Interface in javax.resource.cci

The javax.resource.cci.Record interface is the base interface for the representation of an input or output to the execute methods defined on an Interaction.

RecordFactory - Interface in javax.resource.cci

The RecordFactory interface is used for creating MappedRecord and IndexedRecord instances.

recover() - Method in interface javax.jms.JMSContext

Stops message delivery in the JMSContext's session, and restarts message delivery with the oldest unacknowledged message.

recover() - Method in interface javax.jms.Session

Stops message delivery in this session, and restarts message delivery with the oldest unacknowledged message.

recover(int) - Method in interface javax.resource.spi.XATerminator

Obtains a list of prepared transaction branches from a resource manager.

recover(int) - Method in interface javax.transaction.xa.XAResource

Obtains a list of prepared transaction branches from a resource manager.

recycleNode() - Method in interface javax.xml.soap.Node

Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.

REDEPLOY - Static variable in class javax.enterprise.deploy.shared.CommandType

The DeploymentManger action operation being processed is redeploy.

redeploy(TargetModuleID[], File, File) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

(optional) The redeploy method provides a means for updating currently deployed Java EE applications.

redeploy(TargetModuleID[], InputStream, InputStream) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

(optional) The redeploy method provides a means for updating currently deployed Java EE applications.

redirect(String) - Method in class javax.faces.context.ExternalContext

Redirect a request to the specified URL, and cause the responseComplete() method to be called on the FacesContext instance for the current request.

redirect(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.redirect(String) on the wrapped ExternalContext object.

redirect(String) - Method in class javax.faces.context.PartialResponseWriter

Write a redirect operation.

redirect() - Method in class javax.faces.flow.builder.NavigationCaseBuilder

Create a redirect within this navigation case.

RedirectionException - Exception in javax.ws.rs

A runtime application exception indicating a request redirection (HTTP 3xx status codes).

RedirectionException(Response.Status, URI) - Constructor for exception javax.ws.rs.RedirectionException

Construct a new redirection exception.

RedirectionException(String, Response.Status, URI) - Constructor for exception javax.ws.rs.RedirectionException

Construct a new redirection exception.

RedirectionException(int, URI) - Constructor for exception javax.ws.rs.RedirectionException

Construct a new redirection exception.

RedirectionException(String, int, URI) - Constructor for exception javax.ws.rs.RedirectionException

Construct a new redirection exception.

RedirectionException(Response) - Constructor for exception javax.ws.rs.RedirectionException

Construct a new redirection exception.

RedirectionException(String, Response) - Constructor for exception javax.ws.rs.RedirectionException

Construct a new redirection exception.

ref - Variable in exception javax.mail.internet.AddressException

The string being parsed.

REFERENCE_PARAMETERS - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: WS Addressing Reference Parameters.

Referenceable - Interface in javax.resource

The Referenceable interface extends the javax.naming.Referenceable interface.

ReferencedBean - Annotation Type in javax.faces.bean

The presence of this annotation on a class is equivalent to the referenced-bean element in the application configuration resources.

referenceParameter(Element) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.

ReferenceSyntaxException - Exception in javax.faces.el

Deprecated.
This has been replaced by ELException.

ReferenceSyntaxException() - Constructor for exception javax.faces.el.ReferenceSyntaxException

Deprecated.

Construct a new exception with no detail message or root cause.

ReferenceSyntaxException(String) - Constructor for exception javax.faces.el.ReferenceSyntaxException

Deprecated.

Construct a new exception with the specified detail message and no root cause.

ReferenceSyntaxException(Throwable) - Constructor for exception javax.faces.el.ReferenceSyntaxException

Deprecated.

Construct a new exception with the specified root cause.

ReferenceSyntaxException(String, Throwable) - Constructor for exception javax.faces.el.ReferenceSyntaxException

Deprecated.

Construct a new exception with the specified detail message and root cause.

refresh(Object) - Method in interface javax.persistence.EntityManager

Refresh the state of the instance from the database, overwriting changes made to the entity, if any.

refresh(Object, Map<String, Object>) - Method in interface javax.persistence.EntityManager

Refresh the state of the instance from the database, using the specified properties, and overwriting changes made to the entity, if any.

refresh(Object, LockModeType) - Method in interface javax.persistence.EntityManager

Refresh the state of the instance from the database, overwriting changes made to the entity, if any, and lock it with respect to given lock mode type.

refresh(Object, LockModeType, Map<String, Object>) - Method in interface javax.persistence.EntityManager

Refresh the state of the instance from the database, overwriting changes made to the entity, if any, and lock it with respect to given lock mode type and with specified properties.

refresh() - Method in interface javax.security.auth.message.config.AuthConfig

Causes a dynamic authentication context configuration object to update the internal state that it uses to process calls to its getAuthContext method.

refresh() - Method in class javax.security.auth.message.config.AuthConfigFactory

Cause the factory to reprocess its persistent declarative representation of provider registrations.

refresh() - Method in interface javax.security.auth.message.config.AuthConfigProvider

Causes a dynamic configuration provider to update its internal state such that any resulting change to its state is reflected in the corresponding authentication context configuration objects previously created by the provider within the current process context.

RegexValidator - Class in javax.faces.validator

A Validator that checks against a Regular Expression (which is the pattern property).

RegexValidator() - Constructor for class javax.faces.validator.RegexValidator

register(Class<?>) - Method in interface javax.ws.rs.container.AsyncResponse

Register an asynchronous processing lifecycle callback class to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.

register(Class<?>, Class<?>...) - Method in interface javax.ws.rs.container.AsyncResponse

Register asynchronous processing lifecycle callback classes to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.

register(Object) - Method in interface javax.ws.rs.container.AsyncResponse

Register an asynchronous processing lifecycle callback instance to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.

register(Object, Object...) - Method in interface javax.ws.rs.container.AsyncResponse

Register an asynchronous processing lifecycle callback instances to receive lifecycle events for the asynchronous response based on the implemented callback interfaces.

register(Class<?>) - Method in interface javax.ws.rs.core.Configurable

Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

register(Class<?>, int) - Method in interface javax.ws.rs.core.Configurable

Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

register(Class<?>, Class<?>...) - Method in interface javax.ws.rs.core.Configurable

Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

register(Class<?>, Map<Class<?>, Integer>) - Method in interface javax.ws.rs.core.Configurable

Register a class of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

register(Object) - Method in interface javax.ws.rs.core.Configurable

Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

register(Object, int) - Method in interface javax.ws.rs.core.Configurable

Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

register(Object, Class<?>...) - Method in interface javax.ws.rs.core.Configurable

Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

register(Object, Map<Class<?>, Integer>) - Method in interface javax.ws.rs.core.Configurable

Register an instance of a custom JAX-RS component (such as an extension provider or a feature meta-provider) to be instantiated and used in the scope of this configurable context.

register(Class, QName, SerializerFactory, DeserializerFactory) - Method in interface javax.xml.rpc.encoding.TypeMapping

Registers SerializerFactory and DeserializerFactory for a specific type mapping between an XML type and Java type.

register(String, TypeMapping) - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry

Registers a TypeMapping instance with the TypeMappingRegistry.

registerConfigProvider(String, Map, String, String, String) - Method in class javax.security.auth.message.config.AuthConfigFactory

Registers within the factory and records within the factory's persistent declarative representation of provider registrations a provider of ServerAuthConfig and/or ClientAuthConfig objects for a message layer and application context identifier.

registerConfigProvider(AuthConfigProvider, String, String, String) - Method in class javax.security.auth.message.config.AuthConfigFactory

Registers within the (in-memory) factory, a provider of ServerAuthConfig and/or ClientAuthConfig objects for a message layer and application context identifier.

registerDefault(TypeMapping) - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry

Registers the TypeMapping instance that is default for all encoding styles supported by the TypeMappingRegistry.

registerDeploymentFactory(DeploymentFactory) - Method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager

Registers a DeploymentFactory so it will be able to handle requests.

registerHandler(String, PolicyContextHandler, boolean) - Static method in class javax.security.jacc.PolicyContext

Authorization protected method used to register a container specific PolicyContext handler.

registerInterposedSynchronization(Synchronization) - Method in interface javax.transaction.TransactionSynchronizationRegistry

Register a Synchronization instance with special ordering semantics.

registerStoredProcedureParameter(int, Class, ParameterMode) - Method in interface javax.persistence.StoredProcedureQuery

Register a positional parameter.

registerStoredProcedureParameter(String, Class, ParameterMode) - Method in interface javax.persistence.StoredProcedureQuery

Register a named parameter.

registerSynchronization(Synchronization) - Method in interface javax.transaction.Transaction

Register a synchronization object for the transaction currently associated with the target object.

Registration - Interface in javax.servlet

Interface through which a Servlet or Filter may be further configured.

Registration.Dynamic - Interface in javax.servlet

Interface through which a Servlet or Filter registered via one of the addServlet or addFilter methods, respectively, on ServletContext may be further configured.

RegistrationListener - Interface in javax.security.auth.message.config

An implementation of this interface may be associated with an AuthConfigProvider registration at an AuthConfigFactory at the time the AuthConfigProvider is obtained for use from the factory.

REGISTRY_ENTRY - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.RegistryEntry interface.

REGISTRY_PACKAGE - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.RegistryPackage interface.

RegistryEntry - Interface in javax.xml.registry.infomodel

The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface.

RegistryException - Exception in javax.xml.registry

This is the common base class for all Exceptions that are detected on the registry provider side rather than the JAXR client side.

RegistryException() - Constructor for exception javax.xml.registry.RegistryException

Constructs a JAXRException object with no reason or embedded Throwable.

RegistryException(String) - Constructor for exception javax.xml.registry.RegistryException

Constructs a JAXRException object with the given String as the reason for the exception being thrown.

RegistryException(String, Throwable) - Constructor for exception javax.xml.registry.RegistryException

Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

RegistryException(Throwable) - Constructor for exception javax.xml.registry.RegistryException

Constructs a JAXRException object initialized with the given Throwable object.

RegistryObject - Interface in javax.xml.registry.infomodel

The RegistryObject class is an abstract base class used by most classes in the model.

RegistryPackage - Interface in javax.xml.registry.infomodel

RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together.

RegistryService - Interface in javax.xml.registry

This is the principal interface implemented by a JAXR provider.

rel(String) - Method in interface javax.ws.rs.core.Link.Builder

Convenience method to set a link relation.

REL - Static variable in class javax.ws.rs.core.Link

Rel link param from RFC 5988.

relativize(URI) - Method in interface javax.ws.rs.core.UriInfo

Relativize a URI with respect to the current request URI.

release() - Method in interface javax.enterprise.context.spi.CreationalContext

Destroys all dependent objects of the instance which is being destroyed, by passing each dependent object to Contextual.destroy(Object, CreationalContext) .

release() - Method in interface javax.enterprise.deploy.spi.DeploymentManager

The release method is the mechanism by which the tool signals to the DeploymentManager that the tool does not need it to continue running connected to the platform.

release() - Method in class javax.faces.context.FacesContext

Release any resources associated with this FacesContext instance.

release() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.release() on the wrapped FacesContext object.

release() - Method in class javax.faces.context.PartialViewContext

Release any resources associated with this PartialViewContext instance.

release() - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.release() on the wrapped PartialViewContext object.

release() - Method in class javax.faces.webapp.AttributeTag

Deprecated.

Release references to any acquired resources.

release() - Method in class javax.faces.webapp.ConverterTag

Deprecated.

Release references to any acquired resources.

release() - Method in class javax.faces.webapp.FacetTag

Release any resources allocated by this tag instance.

release() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Release any resources allocated during the execution of this tag handler.

release() - Method in class javax.faces.webapp.UIComponentELTag

Release any resources allocated during the execution of this tag handler.

release() - Method in class javax.faces.webapp.UIComponentTag

Deprecated.

Release any resources allocated during the execution of this tag handler.

release() - Method in class javax.faces.webapp.ValidatorTag

Deprecated.

Release references to any acquired resources.

release() - Method in interface javax.resource.spi.endpoint.MessageEndpoint

This method may be called by the resource adapter to indicate that it no longer needs a proxy endpoint instance.

release() - Method in interface javax.resource.spi.work.Work

The WorkManager might call this method to hint the active Work instance to complete execution as soon as possible.

release() - Method in class javax.servlet.jsp.jstl.core.ConditionalTagSupport

Releases any resources this ConditionalTagSupport may have (or inherit).

release() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Releases any resources this LoopTagSupport may have (or inherit).

release() - Method in class javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV

release() - Method in class javax.servlet.jsp.PageContext

This method shall "reset" the internal state of a PageContext, releasing all internal references, and preparing the PageContext for potential reuse by a later invocation of initialize().

release() - Method in class javax.servlet.jsp.tagext.BodyTagSupport

Release state.

release() - Method in interface javax.servlet.jsp.tagext.Tag

Called on a Tag handler to release state.

release() - Method in class javax.servlet.jsp.tagext.TagAdapter

Must not be called.

release() - Method in class javax.servlet.jsp.tagext.TagLibraryValidator

Release any data kept by this instance for validation purposes.

release() - Method in class javax.servlet.jsp.tagext.TagSupport

Release state.

RELEASED - Static variable in class javax.enterprise.deploy.shared.StateType

The DeploymentManager is running in discommected mode.

releaseFactories() - Static method in class javax.faces.FactoryFinder

Release any references to factory instances associated with the class loader for the calling web application.

releaseInstance(ConstraintValidator<?, ?>) - Method in interface javax.validation.ConstraintValidatorFactory

Signals ConstraintValidatorFactory that the instance is no longer being used by the Bean Validation provider.

releasePageContext(PageContext) - Method in class javax.servlet.jsp.JspFactory

called to release a previously allocated PageContext object.

Remote - Annotation Type in javax.ejb

Declares the remote business interface(s) for a session bean.

RemoteEndpoint - Interface in javax.websocket

The RemoteEndpoint object is supplied by the container and represents the 'other end' or peer of the Web Socket conversation.

RemoteEndpoint.Async - Interface in javax.websocket

This representation of the peer of a web socket conversation has the ability to send messages asynchronously.

RemoteEndpoint.Basic - Interface in javax.websocket

This representation of the peer of a web socket conversation has the ability to send messages synchronously.

RemoteHome - Annotation Type in javax.ejb

Declares the remote home interface or adapted remote home interface for a session bean.

remove(Handle) - Method in interface javax.ejb.EJBHome

Remove an EJB object identified by its handle.

remove(Object) - Method in interface javax.ejb.EJBHome

Remove an EJB object identified by its primary key.

remove(Object) - Method in interface javax.ejb.EJBLocalHome

Remove an EJB object identified by its primary key.

remove() - Method in interface javax.ejb.EJBLocalObject

Remove the EJB local object.

remove() - Method in interface javax.ejb.EJBObject

Remove the EJB object.

Remove - Annotation Type in javax.ejb

Applied to a business method of a stateful session bean class to indicate to the container that the stateful session bean is to be removed by the container after completion of the method.

remove(Serializable) - Method in interface javax.faces.component.StateHelper

Remove the key/value pair from the helper, returning the value previously stored under this key.

remove(Serializable, Object) - Method in interface javax.faces.component.StateHelper

Remove a value from the inner data structure.

remove(Object) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.remove(Object) on the wrapped Flash object.

remove(Flags.Flag) - Method in class javax.mail.Flags

Remove the specified system flag from this Flags object.

remove(String) - Method in class javax.mail.Flags

Remove the specified user flag from this Flags object.

remove(Flags) - Method in class javax.mail.Flags

Remove all flags in the given Flags object from this Flags object.

remove(String) - Method in class javax.mail.internet.ParameterList

Removes the specified parameter from this ParameterList.

remove(Object) - Method in interface javax.persistence.EntityManager

Remove the entity instance.

remove(MessageInfo) - Method in interface javax.security.auth.message.MessagePolicy.Target

Remove the Object identified by the Target from the MessageInfo.

remove(PageContext, String, int) - Static method in class javax.servlet.jsp.jstl.core.Config

Removes a configuration variable from the given scope.

remove(ServletRequest, String) - Static method in class javax.servlet.jsp.jstl.core.Config

Removes a configuration variable from the "request" scope.

remove(HttpSession, String) - Static method in class javax.servlet.jsp.jstl.core.Config

Removes a configuration variable from the "session" scope.

remove(ServletContext, String) - Static method in class javax.servlet.jsp.jstl.core.Config

Removes a configuration variable from the "application" scope.

remove(Object) - Method in class javax.ws.rs.core.AbstractMultivaluedMap

removeActionListener(ActionListener) - Method in interface javax.faces.component.ActionSource

Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.

removeActionListener(ActionListener) - Method in class javax.faces.component.UICommand

removeActionListener(ActionListener) - Method in class javax.faces.component.UIViewAction

Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.

removeAjaxBehaviorListener(AjaxBehaviorListener) - Method in class javax.faces.component.behavior.AjaxBehavior

Remove the specified AjaxBehaviorListener from the set of listeners registered to receive event notifications from this AjaxBehavior.

removeAllAttachments() - Method in class javax.xml.soap.SOAPMessage

Removes all AttachmentPart objects that have been added to this SOAPMessage object.

removeAllFaultSubcodes() - Method in interface javax.xml.soap.SOAPFault

Removes any Subcodes that may be contained by this SOAPFault.

removeAllHeaders() - Method in class javax.xml.soap.MimeHeaders

Removes all the header entries from this MimeHeaders object.

removeAllMimeHeaders() - Method in class javax.xml.soap.AttachmentPart

Removes all the MIME header entries.

removeAllMimeHeaders() - Method in class javax.xml.soap.SOAPPart

Removes all the MimeHeader objects for this SOAPEnvelope object.

removeAllParameters() - Method in interface javax.xml.rpc.Call

Removes all specified parameters from this Call instance.

removeAssociation(Association) - Method in interface javax.xml.registry.infomodel.RegistryObject

Removes specified Association from this object.

removeAssociations(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Removes specified Associations from this object.

removeAttachments(MimeHeaders) - Method in class javax.xml.soap.SOAPMessage

Removes all the AttachmentPart objects that have header entries that match the specified headers.

removeAttribute(String) - Method in interface javax.servlet.http.HttpSession

Removes the object bound with the specified name from this session.

removeAttribute(String) - Method in class javax.servlet.jsp.JspContext

Remove the object reference associated with the given name from all scopes.

removeAttribute(String, int) - Method in class javax.servlet.jsp.JspContext

Remove the object reference associated with the specified name in the given scope.

removeAttribute(String) - Method in interface javax.servlet.ServletContext

Removes the attribute with the given name from this ServletContext.

removeAttribute(String) - Method in interface javax.servlet.ServletRequest

Removes an attribute from this request.

removeAttribute(String) - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to call removeAttribute(String name) on the wrapped request object.

removeAttribute(Name) - Method in interface javax.xml.soap.SOAPElement

Removes the attribute with the specified name.

removeAttribute(QName) - Method in interface javax.xml.soap.SOAPElement

Removes the attribute with the specified qname.

removeBehaviorListener(BehaviorListener) - Method in class javax.faces.component.behavior.BehaviorBase

Remove the specified BehaviorListener from the set of listeners registered to receive event notifications from this Behavior.

removeBodyPart(BodyPart) - Method in class javax.mail.internet.MimeMultipart

Remove the specified part from the multipart message.

removeBodyPart(int) - Method in class javax.mail.internet.MimeMultipart

Remove the part at specified location (starting from 0).

removeBodyPart(BodyPart) - Method in class javax.mail.Multipart

Remove the specified part from the multipart message.

removeBodyPart(int) - Method in class javax.mail.Multipart

Remove the part at specified location (starting from 0).

removeChildConcept(Concept) - Method in interface javax.xml.registry.infomodel.ClassificationScheme

Removes a child Concept.

removeChildConcept(Concept) - Method in interface javax.xml.registry.infomodel.Concept

Removes a child Concept.

removeChildConcepts(Collection) - Method in interface javax.xml.registry.infomodel.ClassificationScheme

Removes a Collection of children Concepts.

removeChildConcepts(Collection) - Method in interface javax.xml.registry.infomodel.Concept

Removes a Collection of children Concepts.

removeChildOrganization(Organization) - Method in interface javax.xml.registry.infomodel.Organization

Removes a child Organization.

removeChildOrganizations(Collection) - Method in interface javax.xml.registry.infomodel.Organization

Removes a Collection of children Organizations.

removeClassification(Classification) - Method in interface javax.xml.registry.infomodel.RegistryObject

Removes specified Classification from this object.

removeClassifications(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Removes specified Classifications from this object.

removeComponentResource(FacesContext, UIComponent) - Method in class javax.faces.component.UIViewRoot

Remove argument component, which is assumed to represent a resource instance, as a resource to this view.

removeComponentResource(FacesContext, UIComponent, String) - Method in class javax.faces.component.UIViewRoot

Remove argument component, which is assumed to represent a resource instance, as a resource to this view.

removeConnectionEventListener(ConnectionEventListener) - Method in interface javax.resource.spi.ManagedConnection

Removes an already registered connection event listener from the ManagedConnection instance.

removeConnectionListener(ConnectionListener) - Method in class javax.mail.Folder

Remove a Connection event listener.

removeConnectionListener(ConnectionListener) - Method in class javax.mail.Service

Remove a Connection event listener.

removeContents() - Method in interface javax.xml.soap.SOAPElement

Detaches all children of this SOAPElement.

REMOVED - Static variable in class javax.mail.event.MessageCountEvent

The messages were removed from their folder

removed - Variable in class javax.mail.event.MessageCountEvent

If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this.

removeDataModelListener(DataModelListener) - Method in class javax.faces.model.DataModel

Remove an existing DataModelListener from the set interested in notifications from this DataModel.

removeDConfigBean(DConfigBean) - Method in interface javax.enterprise.deploy.spi.DConfigBean

Remove a child DConfigBean from this bean.

removeDConfigBean(DConfigBeanRoot) - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration

Remove the root DConfigBean and all its children.

removeDeserializer(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping

Removes the DeserializerFactory registered for the specified pair of Java type and XML data type.

removeELContextListener(ELContextListener) - Method in class javax.faces.application.Application

Remove the argument listener from the list of ELContextListeners.

removeELContextListener(ELContextListener) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.removeELContextListener(javax.el.ELContextListener) on the wrapped Application object.

RemoveException - Exception in javax.ejb

The RemoveException is thrown at an attempt to remove an EJB object or local EJB object when the enterprise bean or the container does not allow the EJB object to be removed.

RemoveException() - Constructor for exception javax.ejb.RemoveException

Constructs an RemoveException with no detail message.

RemoveException(String) - Constructor for exception javax.ejb.RemoveException

Constructs an RemoveException with the specified detail message.

removeExcludedPolicy() - Method in interface javax.security.jacc.PolicyConfiguration

Used to remove any excluded policy statements from this PolicyConfiguration.

removeExternalIdentifier(ExternalIdentifier) - Method in interface javax.xml.registry.infomodel.RegistryObject

Removes specified ExternalIdentifier as an external identifier from this object.

removeExternalIdentifiers(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Removes specified ExternalIdentifiers as an external identifiers from this object.

removeExternalLink(ExternalLink) - Method in interface javax.xml.registry.infomodel.RegistryObject

Removes specified ExternalLink from this object.

removeExternalLinks(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Removes specified ExternalLinks from this object.

removeFacesListener(FacesListener) - Method in class javax.faces.component.UIComponent

Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.

removeFacesListener(FacesListener) - Method in class javax.faces.component.UIComponentBase

Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.

removeFolderListener(FolderListener) - Method in class javax.mail.Folder

Remove a Folder event listener.

removeFolderListener(FolderListener) - Method in class javax.mail.Store

Remove a listener for Folder events.

removeHeader(String) - Method in class javax.mail.internet.InternetHeaders

Remove all header entries that match the given name

removeHeader(String) - Method in class javax.mail.internet.MimeBodyPart

Remove all headers with this name.

removeHeader(String) - Method in class javax.mail.internet.MimeMessage

Remove all headers with this name.

removeHeader(String) - Method in interface javax.mail.Part

Remove all headers with this name.

removeHeader(String) - Method in class javax.xml.soap.MimeHeaders

Remove all MimeHeader objects whose name matches the given name.

removeLocalizedString(LocalizedString) - Method in interface javax.xml.registry.infomodel.InternationalString

Removes a LocalizedString from this object.

removeLocalizedStrings(Collection) - Method in interface javax.xml.registry.infomodel.InternationalString

Removes specified LocalizedStrings to this object.

removeMessageChangedListener(MessageChangedListener) - Method in class javax.mail.Folder

Remove a MessageChanged listener.

removeMessageCountListener(MessageCountListener) - Method in class javax.mail.Folder

Remove a MessageCount listener.

removeMessageHandler(MessageHandler) - Method in interface javax.websocket.Session

Remove the given MessageHandler from the set belonging to this session.

removeMimeHeader(String) - Method in class javax.xml.soap.AttachmentPart

Removes all MIME headers that match the given name.

removeMimeHeader(String) - Method in class javax.xml.soap.SOAPPart

Removes all MIME headers that match the given name.

removeNamespaceDeclaration(String) - Method in interface javax.xml.soap.SOAPElement

Removes the namespace declaration corresponding to the given prefix.

removeNotificationListener(ObjectName, NotificationListener) - Method in interface javax.management.j2ee.ListenerRegistration

Remove a listener from a registered managed object.

removePhaseListener(PhaseListener) - Method in class javax.faces.component.UIViewRoot

If the argument toRemove is in the list of PhaseListeners for this instance, it must be removed.

removePhaseListener(PhaseListener) - Method in class javax.faces.lifecycle.Lifecycle

Deregister an existing PhaseListener instance that is no longer interested in being notified before and after the processing for standard phases of the request processing lifecycle.

removePhaseListener(PhaseListener) - Method in class javax.faces.lifecycle.LifecycleWrapper

removeProgressListener(ProgressListener) - Method in interface javax.enterprise.deploy.spi.status.ProgressObject

Remove a ProgressObject listener.

removeProperty(String) - Method in interface javax.ws.rs.client.ClientRequestContext

Removes a property with the given name from the current request/response exchange context.

removeProperty(String) - Method in interface javax.ws.rs.container.ContainerRequestContext

Removes a property with the given name from the current request/response exchange context.

removeProperty(String) - Method in interface javax.ws.rs.ext.InterceptorContext

Removes a property with the given name from the current request/response exchange context.

removeProperty(String) - Method in interface javax.xml.rpc.Call

Removes a named property.

removeProperty(String) - Method in interface javax.xml.rpc.handler.MessageContext

Removes a property (name-value pair) from the MessageContext

removePropertyChangeListener(PropertyChangeListener) - Method in interface javax.enterprise.deploy.spi.DConfigBean

Unregister a property listener for this bean.

removeProtectedView(String) - Method in class javax.faces.application.ViewHandler

Remove the argument urlPattern from the thread safe Set of protected views for this application, if present in the Set.

removeProtectedView(String) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.removeProtectedView(java.lang.String) on the wrapped ViewHandler object.

removeRegistration(String) - Method in class javax.security.auth.message.config.AuthConfigFactory

Remove the identified provider registration from the factory (and from the persistent declarative representation of provider registrations, if appropriate) and invoke any listeners associated with the removed registration.

removeRegistryObject(RegistryObject) - Method in interface javax.xml.registry.infomodel.RegistryPackage

Removes a child RegistryObject from membership.

removeRegistryObjects(Collection) - Method in interface javax.xml.registry.infomodel.RegistryPackage

Removes a Collection of children RegistryObjects from membership.

removeRole(String) - Method in interface javax.security.jacc.PolicyConfiguration

Used to remove a role and all its permissions from this PolicyConfiguration.

removeSerializer(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping

Removes the SerializerFactory registered for the specified pair of Java type and XML data type.

removeService(Service) - Method in interface javax.xml.registry.infomodel.Organization

Removes a Service from this object.

removeServiceBinding(ServiceBinding) - Method in interface javax.xml.registry.infomodel.Service

Removes a child ServiceBinding.

removeServiceBindings(Collection) - Method in interface javax.xml.registry.infomodel.Service

Removes a Collection of children ServiceBindings.

removeServices(Collection) - Method in interface javax.xml.registry.infomodel.Organization

Removes a Collection of children Services from this object.

removeSlot(String) - Method in interface javax.xml.registry.infomodel.ExtensibleObject

Removes a Slot from this object.

removeSlots(Collection) - Method in interface javax.xml.registry.infomodel.ExtensibleObject

Removes specified Slots from this object.

removeSpecificationLink(SpecificationLink) - Method in interface javax.xml.registry.infomodel.ServiceBinding

Removes a child SpecificationLink.

removeSpecificationLinks(Collection) - Method in interface javax.xml.registry.infomodel.ServiceBinding

Removes a Collection of children SpecificationLinks.

removeStoreListener(StoreListener) - Method in class javax.mail.Store

Remove a listener for Store events.

removeTransportListener(TransportListener) - Method in class javax.mail.Transport

Remove a listener for Transport events.

removeTypeMapping(TypeMapping) - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry

Removes a TypeMapping from the TypeMappingRegistry.

removeUncheckedPolicy() - Method in interface javax.security.jacc.PolicyConfiguration

Used to remove any unchecked policy statements from this PolicyConfiguration.

removeUser(User) - Method in interface javax.xml.registry.infomodel.Organization

Removes a User.

removeUsers(Collection) - Method in interface javax.xml.registry.infomodel.Organization

Removes a Collection of Users.

removeValidator(Validator) - Method in interface javax.faces.component.EditableValueHolder

Remove a Validator instance from the set associated with this component, if it was previously associated.

removeValidator(Validator) - Method in class javax.faces.component.UIInput

Remove a Validator instance from the set associated with this UIInput, if it was previously associated.

removeValue(String) - Method in interface javax.servlet.http.HttpSession

Deprecated.
As of Version 2.2, this method is replaced by HttpSession.removeAttribute(java.lang.String)

removeValue(String) - Method in class javax.servlet.jsp.tagext.TagSupport

Remove a value associated with a key.

removeValueChangeListener(ValueChangeListener) - Method in interface javax.faces.component.EditableValueHolder

Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.

removeValueChangeListener(ValueChangeListener) - Method in class javax.faces.component.UIInput

Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.

removeXpathListener(String, XpathListener) - Method in interface javax.enterprise.deploy.model.DDBean

Unregister a listener for a specific XPath.

removeXpathListener(ModuleType, String, XpathListener) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject

Unregister the listener for an XPath.

RENAMED - Static variable in class javax.mail.event.FolderEvent

The folder was renamed.

renameTo(Folder) - Method in class javax.mail.Folder

Rename this Folder.

render(FacesContext) - Method in class javax.faces.lifecycle.Lifecycle

Execute the Render Response phase of the request processing lifecycle, unless the responseComplete() method has been called on the FacesContext instance associated with the current request.

render(FacesContext) - Method in class javax.faces.lifecycle.LifecycleWrapper

RENDER_ALL_MARKER - Static variable in class javax.faces.context.PartialResponseWriter

Reserved ID value to indicate entire ViewRoot.

RENDER_KIT_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the RenderKitFactory class name.

RENDER_KIT_ID_PARAM - Static variable in class javax.faces.render.ResponseStateManager

The name of the request parameter used by the default implementation of ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) to derive a RenderKit ID.

RENDER_RESPONSE - Static variable in class javax.faces.event.PhaseId

Identifier for the Render Response phase of the request processing lifecycle.

rendered() - Method in class javax.faces.application.FacesMessage

Marks this message as having been rendered to the client.

Renderer - Class in javax.faces.render

A Renderer converts the internal representation of UIComponents into the output stream (or writer) associated with the response we are creating for a particular request.

Renderer() - Constructor for class javax.faces.render.Renderer

RendererWrapper - Class in javax.faces.render

Provides a simple implementation of Renderer that can be subclassed by developers wishing to provide specialized behavior to an existing Renderer instance.

RendererWrapper() - Constructor for class javax.faces.render.RendererWrapper

RenderKit - Class in javax.faces.render

RenderKit represents a collection of Renderer instances that, together, know how to render JavaServer Faces UIComponent instances for a specific client.

RenderKit() - Constructor for class javax.faces.render.RenderKit

RenderKitFactory - Class in javax.faces.render

RenderKitFactory is a factory object that registers and returns RenderKit instances.

RenderKitFactory() - Constructor for class javax.faces.render.RenderKitFactory

RenderKitWrapper - Class in javax.faces.render

Provides a simple implementation of RenderKit that can be subclassed by developers wishing to provide specialized behavior to an existing RenderKit instance.

RenderKitWrapper() - Constructor for class javax.faces.render.RenderKitWrapper

renderResponse() - Method in class javax.faces.context.FacesContext

Signal the JavaServer faces implementation that, as soon as the current phase of the request processing lifecycle has been completed, control should be passed to the Render Response phase, bypassing any phases that have not been executed yet.

renderResponse() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.renderResponse() on the wrapped FacesContext object.

renderView(FacesContext, UIViewRoot) - Method in class javax.faces.application.ViewHandler

Perform whatever actions are required to render the response view to the response object associated with the current FacesContext.

renderView(FacesContext, UIViewRoot) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) on the wrapped ViewHandler object.

renderView(FacesContext, UIViewRoot) - Method in class javax.faces.view.ViewDeclarationLanguage

Render a view rooted at argumentview.

renderView(FacesContext, UIViewRoot) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

replaceAll(MultivaluedMap<String, Object>) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Replaces all existing headers with the newly supplied headers.

replaceMatrix(String) - Method in class javax.ws.rs.core.UriBuilder

Set the matrix parameters of the current final segment of the current URI path.

replaceMatrixParam(String, Object...) - Method in class javax.ws.rs.core.UriBuilder

Replace the existing value(s) of a matrix parameter on the current final segment of the URI path.

replacePath(String) - Method in class javax.ws.rs.core.UriBuilder

Set the URI path.

replaceQuery(String) - Method in class javax.ws.rs.core.UriBuilder

Set the URI query string.

replaceQueryParam(String, Object...) - Method in class javax.ws.rs.core.UriBuilder

Replace the existing value(s) of a query parameter.

reply(boolean) - Method in class javax.mail.internet.MimeMessage

Get a new Message suitable for a reply to this message.

reply(boolean, boolean) - Method in class javax.mail.internet.MimeMessage

Get a new Message suitable for a reply to this message.

reply(boolean) - Method in class javax.mail.Message

Get a new Message suitable for a reply to this message.

ReportAsSingleViolation - Annotation Type in javax.validation

A constraint annotation hosting this annotation will return the composed annotation error report if any of the composing annotations fail.

request(Message) - Method in class javax.jms.QueueRequestor

Sends a request and waits for a reply.

request(Message) - Method in class javax.jms.TopicRequestor

Sends a request and waits for a reply.

REQUEST - Static variable in class javax.servlet.jsp.PageContext

Name used to store ServletRequest in PageContext name table.

request() - Method in interface javax.ws.rs.client.WebTarget

Start building a request to the targeted web resource.

request(String...) - Method in interface javax.ws.rs.client.WebTarget

Start building a request to the targeted web resource and define the accepted response media types.

request(MediaType...) - Method in interface javax.ws.rs.client.WebTarget

Start building a request to the targeted web resource and define the accepted response media types.

Request - Interface in javax.ws.rs.core

An injectable helper for request processing, all methods throw an IllegalStateException if called outside the scope of a request (e.g.

REQUEST_CIPHER_SUITE - Static variable in class javax.xml.ws.spi.http.HttpExchange

Standard property: cipher suite value when the request is received over HTTPS

REQUEST_KEY_SIZE - Static variable in class javax.xml.ws.spi.http.HttpExchange

Standard property: bit size of the algorithm when the request is received over HTTPS

REQUEST_SCOPE - Static variable in class javax.servlet.jsp.PageContext

Request scope: the named reference remains available from the ServletRequest associated with the Servlet until the current request is completed.

REQUEST_TIME_VALUE - Static variable in class javax.servlet.jsp.tagext.TagData

Distinguished value for an attribute to indicate its value is a request-time expression (which is not yet available because TagData instances are used at translation-time).

REQUEST_X509CERTIFICATE - Static variable in class javax.xml.ws.spi.http.HttpExchange

Standard property: A SSL certificate, if any, associated with the request

requestDestroyed(ServletRequestEvent) - Method in interface javax.servlet.ServletRequestListener

Receives notification that a ServletRequest is about to go out of scope of the web application.

RequestDispatcher - Interface in javax.servlet

Defines an object that receives requests from the client and sends them to any resource (such as a servlet, HTML file, or JSP file) on the server.

requestInitialized(ServletRequestEvent) - Method in interface javax.servlet.ServletRequestListener

Receives notification that a ServletRequest is about to come into scope of the web application.

requestPasswordAuthentication(InetAddress, int, String, String, String) - Method in class javax.mail.Session

Call back to the application to get the needed user name and password.

RequestScoped - Annotation Type in javax.enterprise.context

Specifies that a bean is request scoped.

RequestScoped - Annotation Type in javax.faces.bean

When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>request<managed-bean-scope> element was declared for the corresponding managed bean.

RequestWrapper - Annotation Type in javax.xml.ws

Used to annotate methods in the Service Endpoint Interface with the request wrapper bean to be used at runtime.

required - Variable in class javax.xml.ws.soap.AddressingFeature

If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.

REQUIRED_MESSAGE_ID - Static variable in class javax.faces.component.UIInput

The message identifier of the FacesMessage to be created if a required check fails.

RequiredValidator - Class in javax.faces.validator

A Validator that checks for an empty value in the same way that UIInput checks for a value.

RequiredValidator() - Constructor for class javax.faces.validator.RequiredValidator

reset() - Method in interface javax.jms.BytesMessage

Puts the message body in read-only mode and repositions the stream of bytes to the beginning.

reset() - Method in interface javax.jms.StreamMessage

Puts the message body in read-only mode and repositions the stream to the beginning.

reset() - Method in class javax.mail.util.SharedFileInputStream

See the general contract of the reset method of InputStream.

reset() - Method in interface javax.servlet.ServletResponse

Clears any data that exists in the buffer as well as the status code, headers.

reset() - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to call reset() on the wrapped response object.

reset() - Method in class javax.xml.bind.util.ValidationEventCollector

Clear all collected errors and warnings.

RESET_VALUES_PARAM_NAME - Static variable in class javax.faces.context.PartialViewContext

If the request parameter named by the value of this constant has a parameter value of true, the implementation must return true from PartialViewContext.isResetValues().

resetBuffer() - Method in interface javax.servlet.ServletResponse

Clears the content of the underlying buffer in the response without clearing headers or status code.

resetBuffer() - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to call resetBuffer() on the wrapped response object.

resetValue() - Method in interface javax.faces.component.EditableValueHolder

Convenience method to reset this component's value to the un-initialized state.

resetValue() - Method in class javax.faces.component.UIInput

Convenience method to reset this component's value to the un-initialized state.

resetValue() - Method in class javax.faces.component.UIOutput

Convenience method to reset this component's value to the un-initialized state.

resetValues(FacesContext, Collection<String>) - Method in class javax.faces.component.UIViewRoot

Visit the clientIds and, if the component is an instance of EditableValueHolder, call its EditableValueHolder.resetValue() method.

ResolutionException - Exception in javax.enterprise.inject

Indicates a problem relating to typesafe resolution.

ResolutionException() - Constructor for exception javax.enterprise.inject.ResolutionException

ResolutionException(String, Throwable) - Constructor for exception javax.enterprise.inject.ResolutionException

ResolutionException(String) - Constructor for exception javax.enterprise.inject.ResolutionException

ResolutionException(Throwable) - Constructor for exception javax.enterprise.inject.ResolutionException

RESOLVABLE_AT_DESIGN_TIME - Static variable in class javax.el.ELResolver

The attribute name of the named attribute in the FeatureDescriptor that specifies whether the variable or property can be resolved at runtime.

resolve(Set<Bean<? extends X>>) - Method in interface javax.enterprise.inject.spi.BeanManager

Apply the ambiguous dependency resolution rules to a set of beans.

resolve(URI) - Method in interface javax.ws.rs.core.UriInfo

Resolve a relative URI with respect to the base URI of the application.

resolveClass(String) - Method in class javax.el.ImportHandler

Resolve a class name.

resolveDecorators(Set<Type>, Annotation...) - Method in interface javax.enterprise.inject.spi.BeanManager

Return an ordered list of decorators for a set of bean types and a set of qualifiers and which are enabled in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained.

resolveFunction(String, String) - Method in class javax.el.FunctionMapper

Resolves the specified prefix and local name into a java.lang.Method.

resolveFunction(String, String) - Method in interface javax.servlet.jsp.el.FunctionMapper

Deprecated.

Resolves the specified local name and prefix into a Java.lang.Method.

resolveInterceptors(InterceptionType, Annotation...) - Method in interface javax.enterprise.inject.spi.BeanManager

Return an ordered list of enabled interceptors for a set of interceptor bindings and a type of interception and which are enabled in the module or library containing the class into which the BeanManager was injected or the Java EE component from whose JNDI environment namespace the BeanManager was obtained.

resolveObserverMethods(T, Annotation...) - Method in interface javax.enterprise.inject.spi.BeanManager

Return the set of observers for an event.

resolveStatic(String) - Method in class javax.el.ImportHandler

Resolve a static field or method name.

resolveTemplate(String, Object) - Method in interface javax.ws.rs.client.WebTarget

Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied value.

resolveTemplate(String, Object, boolean) - Method in interface javax.ws.rs.client.WebTarget

Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied value.

resolveTemplate(String, Object) - Method in class javax.ws.rs.core.UriBuilder

Resolve a URI template with a given name in this UriBuilder instance using a supplied value.

resolveTemplate(String, Object, boolean) - Method in class javax.ws.rs.core.UriBuilder

Resolve a URI template with a given name in this UriBuilder instance using a supplied value.

resolveTemplateFromEncoded(String, Object) - Method in interface javax.ws.rs.client.WebTarget

Create a new WebTarget instance by resolving a URI template with a given name in the URI of the current target instance using a supplied encoded value.

resolveTemplateFromEncoded(String, Object) - Method in class javax.ws.rs.core.UriBuilder

Resolve a URI template with a given name in this UriBuilder instance using a supplied encoded value.

resolveTemplates(Map<String, Object>) - Method in interface javax.ws.rs.client.WebTarget

Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-value pairs.

resolveTemplates(Map<String, Object>, boolean) - Method in interface javax.ws.rs.client.WebTarget

Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-value pairs.

resolveTemplates(Map<String, Object>) - Method in class javax.ws.rs.core.UriBuilder

Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs.

resolveTemplates(Map<String, Object>, boolean) - Method in class javax.ws.rs.core.UriBuilder

Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs.

resolveTemplatesFromEncoded(Map<String, Object>) - Method in interface javax.ws.rs.client.WebTarget

Create a new WebTarget instance by resolving one or more URI templates in the URI of the current target instance using supplied name-encoded value pairs.

resolveTemplatesFromEncoded(Map<String, Object>) - Method in class javax.ws.rs.core.UriBuilder

Resolve one or more URI templates in this UriBuilder instance using supplied name-value pairs.

resolveUrl(String) - Method in class javax.faces.view.facelets.ResourceResolver

Deprecated.

Returns the URL of a Facelet template file.

resolveVariable(String) - Method in class javax.el.VariableMapper

resolveVariable(FacesContext, String) - Method in class javax.faces.el.VariableResolver

Deprecated.

Resolve the specified variable name, and return the corresponding object, if any; otherwise, return null.

resolveVariable(String) - Method in interface javax.servlet.jsp.el.VariableResolver

Deprecated.

Resolves the specified variable.

Resource - Annotation Type in javax.annotation

The Resource annotation marks a resource that is needed by the application.

Resource - Class in javax.faces.application

An instance of Resource is a Java object representation of the artifact that is served up in response to a resource request from the client.

Resource() - Constructor for class javax.faces.application.Resource

Resource.AuthenticationType - Enum in javax.annotation

The two possible authentication types for a resource.

RESOURCE_CONTRACT_XML - Static variable in class javax.faces.application.ResourceHandler

The name of the marker file that the implementation must scan for, within sub-directories META-INF/contracts, to identify the set of available resource library contracts.

RESOURCE_EXCLUDES_DEFAULT_VALUE - Static variable in class javax.faces.application.ResourceHandler

The default value for the ResourceHandler.RESOURCE_EXCLUDES_PARAM_NAME init param.

RESOURCE_EXCLUDES_PARAM_NAME - Static variable in class javax.faces.application.ResourceHandler

The ServletContext init parameter consulted by the ResourceHandler.handleResourceRequest(javax.faces.context.FacesContext) to tell which kinds of resources must never be served up in response to a resource request.

RESOURCE_IDENTIFIER - Static variable in class javax.faces.application.ResourceHandler

Resource.getRequestPath() returns the value of this constant as the prefix of the URI.

ResourceAdapter - Interface in javax.resource.spi

This represents a resource adapter instance and contains operations for lifecycle management and message endpoint setup.

ResourceAdapterAssociation - Interface in javax.resource.spi

This interface specifies the methods to associate a ResourceAdapter object with other objects that implement this interface like ManagedConnectionFactory and ActivationSpec.

ResourceAdapterInternalException - Exception in javax.resource.spi

A ResourceAdapterInternalException indicates any system-level error conditions related to a resource adapter.

ResourceAdapterInternalException() - Constructor for exception javax.resource.spi.ResourceAdapterInternalException

Constructs a new instance with null as its detail message.

ResourceAdapterInternalException(String) - Constructor for exception javax.resource.spi.ResourceAdapterInternalException

Constructs a new instance with the specified detail message.

ResourceAdapterInternalException(Throwable) - Constructor for exception javax.resource.spi.ResourceAdapterInternalException

Constructs a new throwable with the specified cause.

ResourceAdapterInternalException(String, Throwable) - Constructor for exception javax.resource.spi.ResourceAdapterInternalException

Constructs a new throwable with the specified detail message and cause.

ResourceAdapterInternalException(String, String) - Constructor for exception javax.resource.spi.ResourceAdapterInternalException

Constructs a new throwable with the specified detail message and an error code.

ResourceAdapterMetaData - Interface in javax.resource.cci

The interface javax.resource.cci.ResourceAdapterMetaData provides information about capabilities of a resource adapter implementation.

ResourceAllocationException - Exception in javax.jms

This exception is thrown when a provider is unable to allocate the resources required by a method.

ResourceAllocationException(String, String) - Constructor for exception javax.jms.ResourceAllocationException

Constructs a ResourceAllocationException with the specified reason and error code.

ResourceAllocationException(String) - Constructor for exception javax.jms.ResourceAllocationException

Constructs a ResourceAllocationException with the specified reason.

ResourceAllocationException - Exception in javax.resource.spi

A ResourceAllocationException can be thrown by an application server or resource adapter to indicate any failure to allocate system resources (example: threads, physical connections).

ResourceAllocationException() - Constructor for exception javax.resource.spi.ResourceAllocationException

Constructs a new instance with null as its detail message.

ResourceAllocationException(String) - Constructor for exception javax.resource.spi.ResourceAllocationException

Constructs a new instance with the specified detail message.

ResourceAllocationException(Throwable) - Constructor for exception javax.resource.spi.ResourceAllocationException

Constructs a new throwable with the specified cause.

ResourceAllocationException(String, Throwable) - Constructor for exception javax.resource.spi.ResourceAllocationException

Constructs a new throwable with the specified detail message and cause.

ResourceAllocationException(String, String) - Constructor for exception javax.resource.spi.ResourceAllocationException

Constructs a new throwable with the specified detail message and an error code.

ResourceAllocationRuntimeException - Exception in javax.jms

This unchecked exception is thrown when a provider is unable to allocate the resources required by a method.

ResourceAllocationRuntimeException(String, String) - Constructor for exception javax.jms.ResourceAllocationRuntimeException

Constructs a ResourceAllocationRuntimeException with the specified reason and error code.

ResourceAllocationRuntimeException(String) - Constructor for exception javax.jms.ResourceAllocationRuntimeException

Constructs a ResourceAllocationRuntimeException with the specified reason.

ResourceAllocationRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.ResourceAllocationRuntimeException

Constructs a ResourceAllocationRuntimeException with the specified detail message, error code and cause

ResourceBundleELResolver - Class in javax.el

Defines property resolution behavior on instances of ResourceBundle.

ResourceBundleELResolver() - Constructor for class javax.el.ResourceBundleELResolver

ResourceContext - Interface in javax.ws.rs.container

The resource context provides access to instances of resource classes.

ResourceDependencies - Annotation Type in javax.faces.application

Container annotation to specify multiple ResourceDependency annotations on a single class.

ResourceDependency - Annotation Type in javax.faces.application

Instances of UIComponent or Renderer that have this annotation (or ResourceDependencies attached at the class level will automatically have a resource dependency added so that the named resource will be present in user agent's view of the UIViewRoot in which this component or renderer is used.

ResourceException - Exception in javax.resource

This is the root interface of the exception hierarchy defined for the Connector architecture.

ResourceException() - Constructor for exception javax.resource.ResourceException

Constructs a new instance with null as its detail message.

ResourceException(String) - Constructor for exception javax.resource.ResourceException

Constructs a new instance with the specified detail message.

ResourceException(Throwable) - Constructor for exception javax.resource.ResourceException

Constructs a new throwable with the specified cause.

ResourceException(String, Throwable) - Constructor for exception javax.resource.ResourceException

Constructs a new throwable with the specified detail message and cause.

ResourceException(String, String) - Constructor for exception javax.resource.ResourceException

Create a new throwable with the specified message and error code.

ResourceHandler - Class in javax.faces.application

ResourceHandler is the run-time API by which UIComponent and Renderer instances, and the ViewDeclarationLanguage can reference Resource instances. An implementation of this class must be thread-safe.

ResourceHandler() - Constructor for class javax.faces.application.ResourceHandler

ResourceHandlerWrapper - Class in javax.faces.application

Provides a simple implementation of ResourceHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ResourceHandler instance.

ResourceHandlerWrapper() - Constructor for class javax.faces.application.ResourceHandlerWrapper

ResourceInfo - Interface in javax.ws.rs.container

An injectable class to access the resource class and resource method matched by the current request.

ResourceResolver - Class in javax.faces.view.facelets

Deprecated.

ResourceResolver() - Constructor for class javax.faces.view.facelets.ResourceResolver

Deprecated.

Resources - Annotation Type in javax.annotation

This class is used to allow multiple resources declarations.

resources - Variable in class javax.mail.Quota

The set of resources associated with this quota root.

ResourceWarning - Exception in javax.resource.cci

A ResourceWarning provides information on warnings related to execution of an interaction with an EIS.

ResourceWarning() - Constructor for exception javax.resource.cci.ResourceWarning

Constructs a new instance with null as its detail message.

ResourceWarning(String) - Constructor for exception javax.resource.cci.ResourceWarning

Constructs a new instance with the specified detail message.

ResourceWarning(Throwable) - Constructor for exception javax.resource.cci.ResourceWarning

Constructs a new throwable with the specified cause.

ResourceWarning(String, Throwable) - Constructor for exception javax.resource.cci.ResourceWarning

Constructs a new throwable with the specified detail message and cause.

ResourceWarning(String, String) - Constructor for exception javax.resource.cci.ResourceWarning

Constructs a new throwable with the specified detail message and an error code.

ResourceWrapper - Class in javax.faces.application

Provides a simple implementation of Resource that can be subclassed by developers wishing to provide specialized behavior to an existing Resource instance.

ResourceWrapper() - Constructor for class javax.faces.application.ResourceWrapper

RespectBinding - Annotation Type in javax.xml.ws

This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.

RespectBindingFeature - Class in javax.xml.ws

This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.

RespectBindingFeature() - Constructor for class javax.xml.ws.RespectBindingFeature

Creates an RespectBindingFeature.

RespectBindingFeature(boolean) - Constructor for class javax.xml.ws.RespectBindingFeature

Creates an RespectBindingFeature

RESPONSE - Static variable in class javax.servlet.jsp.PageContext

Name used to store ServletResponse in PageContext name table.

Response - Class in javax.ws.rs.core

Defines the contract between a returned instance and the runtime when an application needs to provide meta-data to the runtime.

Response() - Constructor for class javax.ws.rs.core.Response

Protected constructor, use one of the static methods to obtain a Response.ResponseBuilder instance and obtain a Response from that.

Response<T> - Interface in javax.xml.ws

The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.

Response.ResponseBuilder - Class in javax.ws.rs.core

A class used to build Response instances that contain metadata instead of or in addition to an entity.

Response.ResponseBuilder() - Constructor for class javax.ws.rs.core.Response.ResponseBuilder

Protected constructor, use one of the static methods of Response to obtain an instance.

Response.Status - Enum in javax.ws.rs.core

Commonly used status codes defined by HTTP, see HTTP/1.1 documentation for the complete list.

Response.Status.Family - Enum in javax.ws.rs.core

An enumeration representing the class of status code.

Response.StatusType - Interface in javax.ws.rs.core

Base interface for statuses used in responses.

responseComplete() - Method in class javax.faces.context.FacesContext

Signal the JavaServer Faces implementation that the HTTP response for this request has already been generated (such as an HTTP redirect), and that the request processing lifecycle should be terminated as soon as the current phase is completed.

responseComplete() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.responseComplete() on the wrapped FacesContext object.

responseFlushBuffer() - Method in class javax.faces.context.ExternalContext

Flushes the buffered response content to the client.

responseFlushBuffer() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.responseFlushBuffer() on the wrapped ExternalContext object.

ResponseProcessingException - Exception in javax.ws.rs.client

JAX-RS client-side runtime processing exception thrown to indicate that response processing has failed (e.g.

ResponseProcessingException(Response, Throwable) - Constructor for exception javax.ws.rs.client.ResponseProcessingException

Constructs a new JAX-RS runtime response processing exception for a specific response with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

ResponseProcessingException(Response, String, Throwable) - Constructor for exception javax.ws.rs.client.ResponseProcessingException

Constructs a new JAX-RS runtime response processing exception with the specified detail message and cause.

ResponseProcessingException(Response, String) - Constructor for exception javax.ws.rs.client.ResponseProcessingException

Constructs a new JAX-RS runtime processing exception with the specified detail message.

responseReset() - Method in class javax.faces.context.ExternalContext

Resets the current response.

responseReset() - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.responseReset() on the wrapped ExternalContext object.

responseSendError(int, String) - Method in class javax.faces.context.ExternalContext

Sends an HTTP status code with message.

responseSendError(int, String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.responseSendError(int,String) on the wrapped ExternalContext object.

ResponseStateManager - Class in javax.faces.render

ResponseStateManager is the helper class to StateManager that knows the specific rendering technology being used to generate the response.

ResponseStateManager() - Constructor for class javax.faces.render.ResponseStateManager

ResponseStream - Class in javax.faces.context

ResponseStream is an interface describing an adapter to an underlying output mechanism for binary output.

ResponseStream() - Constructor for class javax.faces.context.ResponseStream

ResponseWrapper - Annotation Type in javax.xml.ws

Used to annotate methods in the Service Endpoint Interface with the response wrapper bean to be used at runtime.

ResponseWriter - Class in javax.faces.context

ResponseWriter is an abstract class describing an adapter to an underlying output mechanism for character-based output.

ResponseWriter() - Constructor for class javax.faces.context.ResponseWriter

ResponseWriterWrapper - Class in javax.faces.context

Provides a simple implementation of ResponseWriter that can be subclassed by developers wishing to provide specialized behavior to an existing ResponseWriter instance.

ResponseWriterWrapper() - Constructor for class javax.faces.context.ResponseWriterWrapper

restart(long, Properties) - Method in interface javax.batch.operations.JobOperator

Restarts a failed or stopped job instance.

restore(InputStream) - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration

Restore from disk to a full set of configuration beans previously stored.

RESTORE_VIEW - Static variable in class javax.faces.event.PhaseId

Identifier that indicates an interest in events queued for the Restore View phase of the request processing lifecycle.

restoreAttachedState(FacesContext, Object) - Static method in class javax.faces.component.UIComponentBase

This method is called by UIComponent subclasses that need to restore the objects they saved using UIComponentBase.saveAttachedState(javax.faces.context.FacesContext, java.lang.Object).

restoreComponentState(FacesContext, UIViewRoot, String) - Method in class javax.faces.application.StateManager

Deprecated.
the distinction between tree structure and component state is now an implementation detail. The default implementation does nothing.

restoreComponentState(FacesContext, UIViewRoot, String) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, String) on the wrapped StateManager object.

restoreDConfigBean(InputStream, DDBeanRoot) - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration

Restore from disk to instantated objects all the DConfigBeans associated with a specific deployment descriptor.

restoreState(FacesContext, Object) - Method in class javax.faces.component.behavior.AjaxBehavior

restoreState(FacesContext, Object) - Method in class javax.faces.component.behavior.BehaviorBase

Implementation of StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object).

restoreState(FacesContext, Object) - Method in interface javax.faces.component.StateHolder

Perform any processing required to restore the state from the entries in the state Object.

restoreState(FacesContext, Object) - Method in class javax.faces.component.UIComponentBase

restoreState(FacesContext, Object) - Method in class javax.faces.component.UIData

restoreState(FacesContext, Object) - Method in class javax.faces.component.UIInput

restoreState(FacesContext, Object) - Method in class javax.faces.component.UIOutput

restoreState(FacesContext, Object) - Method in class javax.faces.component.UIViewRoot

restoreState(FacesContext, Object) - Method in class javax.faces.convert.DateTimeConverter

restoreState(FacesContext, Object) - Method in class javax.faces.convert.EnumConverter

restoreState(FacesContext, Object) - Method in class javax.faces.convert.NumberConverter

restoreState(FacesContext, Object) - Method in class javax.faces.event.MethodExpressionActionListener

Both MethodExpression instances described in the constructor must be restored.

restoreState(FacesContext, Object) - Method in class javax.faces.event.MethodExpressionValueChangeListener

Both MethodExpression instances described in the constructor must be restored.

restoreState(FacesContext, Object) - Method in class javax.faces.validator.BeanValidator

restoreState(FacesContext, Object) - Method in class javax.faces.validator.DoubleRangeValidator

restoreState(FacesContext, Object) - Method in class javax.faces.validator.LengthValidator

restoreState(FacesContext, Object) - Method in class javax.faces.validator.LongRangeValidator

restoreState(FacesContext, Object) - Method in class javax.faces.validator.MethodExpressionValidator

restoreState(FacesContext, Object) - Method in class javax.faces.validator.RegexValidator

restoreTransientState(FacesContext, Object) - Method in interface javax.faces.component.TransientStateHolder

Restore the "transient state" using the object passed as state.

restoreTransientState(FacesContext, Object) - Method in class javax.faces.component.UIComponent

For components that need to support the concept of transient state, this method will restore any state saved on a prior call to UIComponent.saveTransientState(javax.faces.context.FacesContext).

restoreTreeStructure(FacesContext, String, String) - Method in class javax.faces.application.StateManager

Deprecated.
the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.

restoreTreeStructure(FacesContext, String, String) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.restoreTreeStructure(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.

restoreView(FacesContext, String, String) - Method in class javax.faces.application.StateManager

Deprecated.

restoreView(FacesContext, String, String) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.restoreView(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.

restoreView(FacesContext, String) - Method in class javax.faces.application.ViewHandler

Perform whatever actions are required to restore the view associated with the specified FacesContext and viewId.

restoreView(FacesContext, String) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.restoreView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

restoreView(FacesContext, String, String) - Method in class javax.faces.view.StateManagementStrategy

Restore the state of the view with information in the request.

restoreView(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguage

Restore a UIViewRoot from a previously created view.

restoreView(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

restoreViewScopeState(FacesContext, Object) - Method in class javax.faces.component.UIViewRoot

Restore ViewScope state.

Result - Interface in javax.servlet.jsp.jstl.sql

This interface represents the result of a <sql:query> action.

ResultDataModel - Class in javax.faces.model

ResultDataModel is a convenience implementation of DataModel that wraps a JSTL Result object, typically representing the results of executing an SQL query via JSTL tags.

ResultDataModel() - Constructor for class javax.faces.model.ResultDataModel

Construct a new ResultDataModel with no specified wrapped data.

ResultDataModel(Result) - Constructor for class javax.faces.model.ResultDataModel

Construct a new ResultDataModel wrapping the specified Result.

ResultSet - Interface in javax.resource.cci

A ResultSet represents tabular data that is retrieved from an EIS instance by the execution of an Interaction..

ResultSetDataModel - Class in javax.faces.model

ResultSetDataModel is a convenience implementation of DataModel that wraps a ResultSet of Java objects.

ResultSetDataModel() - Constructor for class javax.faces.model.ResultSetDataModel

Construct a new ResultSetDataModel with no specified wrapped data.

ResultSetDataModel(ResultSet) - Constructor for class javax.faces.model.ResultSetDataModel

Construct a new ResultSetDataModel wrapping the specified ResultSet.

ResultSetInfo - Interface in javax.resource.cci

The interface javax.resource.cci.ResultSetInfo provides information on the support provided for ResultSet by a connected EIS instance.

ResultSupport - Class in javax.servlet.jsp.jstl.sql

Supports the creation of a javax.servlet.jsp.jstl.sql.Result object from a source java.sql.ResultSet object.

ResultSupport() - Constructor for class javax.servlet.jsp.jstl.sql.ResultSupport

resume(Transaction) - Method in interface javax.transaction.TransactionManager

Resume the transaction context association of the calling thread with the transaction represented by the supplied Transaction object.

resume(Object) - Method in interface javax.ws.rs.container.AsyncResponse

Resume the suspended request processing using the provided response data.

resume(Throwable) - Method in interface javax.ws.rs.container.AsyncResponse

Resume the suspended request processing using the provided throwable.

retargetAttachedObjects(FacesContext, UIComponent, List<AttachedObjectHandler>) - Method in class javax.faces.view.ViewDeclarationLanguage

Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting attached objects from the top level composite component to the individual AttachedObjectTarget instances inside the composite component.

retargetAttachedObjects(FacesContext, UIComponent, List<AttachedObjectHandler>) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

retargetMethodExpressions(FacesContext, UIComponent) - Method in class javax.faces.view.ViewDeclarationLanguage

Assuming the component metadata for argument topLevelComponent has been made available by an earlier call to ViewDeclarationLanguage.getComponentMetadata(javax.faces.context.FacesContext, javax.faces.application.Resource), leverage the component metadata for the purpose of re-targeting any method expressions from the top level component to the appropriate inner component.

retargetMethodExpressions(FacesContext, UIComponent) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

RETRY_AFTER - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

RetryableException - Interface in javax.resource.spi

A marker interface indicating that the Exception is transient.

RetryableUnavailableException - Exception in javax.resource.spi

A subclass of the UnavailableException that indicates that the rejection of the work submission is transient.

RetryableUnavailableException() - Constructor for exception javax.resource.spi.RetryableUnavailableException

Constructs a new instance with null as its detail message.

RetryableUnavailableException(String) - Constructor for exception javax.resource.spi.RetryableUnavailableException

Constructs a new instance with the specified detail message.

RetryableUnavailableException(Throwable) - Constructor for exception javax.resource.spi.RetryableUnavailableException

Constructs a new throwable with the specified cause.

RetryableUnavailableException(String, Throwable) - Constructor for exception javax.resource.spi.RetryableUnavailableException

Constructs a new throwable with the specified detail message and cause.

RetryableUnavailableException(String, String) - Constructor for exception javax.resource.spi.RetryableUnavailableException

Constructs a new throwable with the specified detail message and an error code.

RetryableWorkRejectedException - Exception in javax.resource.spi.work

A subclass of the WorkRejectedException that indicates that the the service unavailability is transient.

RetryableWorkRejectedException() - Constructor for exception javax.resource.spi.work.RetryableWorkRejectedException

Constructs a new instance with null as its detail message.

RetryableWorkRejectedException(String) - Constructor for exception javax.resource.spi.work.RetryableWorkRejectedException

Constructs a new instance with the specified detail message.

RetryableWorkRejectedException(Throwable) - Constructor for exception javax.resource.spi.work.RetryableWorkRejectedException

Constructs a new throwable with the specified cause.

RetryableWorkRejectedException(String, Throwable) - Constructor for exception javax.resource.spi.work.RetryableWorkRejectedException

Constructs a new throwable with the specified detail message and cause.

RetryableWorkRejectedException(String, String) - Constructor for exception javax.resource.spi.work.RetryableWorkRejectedException

Constructs a new throwable with the specified detail message and an error code.

RetryProcessListener - Interface in javax.batch.api.chunk.listener

RetryProcessListener intercepts retry processing for an ItemProcessor.

RetryReadListener - Interface in javax.batch.api.chunk.listener

RetryReadListener intercepts retry processing for an ItemReader.

RetryWriteListener - Interface in javax.batch.api.chunk.listener

RetryWriteListener intercepts retry processing for an ItemWriter.

ReturnBuilder - Class in javax.faces.flow.builder

Create a return node in the current Flow.

ReturnBuilder() - Constructor for class javax.faces.flow.builder.ReturnBuilder

returnNode(String) - Method in class javax.faces.flow.builder.FlowBuilder

Define a return node.

ReturnNode - Class in javax.faces.flow

Represents a return node in the flow graph.

ReturnNode() - Constructor for class javax.faces.flow.ReturnNode

ReturnValueDescriptor - Interface in javax.validation.metadata

Describes a validated return value of a method or constructor.

reverse() - Method in interface javax.persistence.criteria.Order

Switch the ordering.

RFC822 - Static variable in class javax.mail.internet.HeaderTokenizer

RFC822 specials

RolesAllowed - Annotation Type in javax.annotation.security

Specifies the list of roles permitted to access method(s) in an application.

rollback() - Method in interface javax.jms.JMSContext

Rolls back any messages done in this transaction and releases any locks currently held.

rollback() - Method in interface javax.jms.Session

Rolls back any messages done in this transaction and releases any locks currently held.

rollback() - Method in interface javax.jms.XAJMSContext

Throws a TransactionInProgressRuntimeException, since it should not be called for an XAJMSContext object.

rollback() - Method in interface javax.jms.XASession

Throws a TransactionInProgressException, since it should not be called for an XASession object.

rollback() - Method in interface javax.persistence.EntityTransaction

Roll back the current resource transaction.

rollback() - Method in interface javax.resource.cci.LocalTransaction

Rollbacks the current resource manager local transaction.

rollback() - Method in interface javax.resource.spi.LocalTransaction

Rollback a local transaction

rollback(Xid) - Method in interface javax.resource.spi.XATerminator

Informs the resource manager to roll back work done on behalf of a transaction branch.

rollback() - Method in interface javax.transaction.Transaction

Rollback the transaction represented by this Transaction object.

rollback() - Method in interface javax.transaction.TransactionManager

Roll back the transaction associated with the current thread.

rollback() - Method in interface javax.transaction.UserTransaction

Roll back the transaction associated with the current thread.

rollback(Xid) - Method in interface javax.transaction.xa.XAResource

Informs the resource manager to roll back work done on behalf of a transaction branch.

RollbackException - Exception in javax.persistence

Thrown by the persistence provider when EntityTransaction.commit() fails.

RollbackException() - Constructor for exception javax.persistence.RollbackException

Constructs a new RollbackException exception with null as its detail message.

RollbackException(String) - Constructor for exception javax.persistence.RollbackException

Constructs a new RollbackException exception with the specified detail message.

RollbackException(String, Throwable) - Constructor for exception javax.persistence.RollbackException

Constructs a new RollbackException exception with the specified detail message and cause.

RollbackException(Throwable) - Constructor for exception javax.persistence.RollbackException

Constructs a new RollbackException exception with the specified cause.

RollbackException - Exception in javax.transaction

RollbackException exception is thrown when the transaction has been marked for rollback only or the transaction has been rolled back instead of committed.

RollbackException() - Constructor for exception javax.transaction.RollbackException

RollbackException(String) - Constructor for exception javax.transaction.RollbackException

rollbackPartitionedStep() - Method in class javax.batch.api.partition.AbstractPartitionReducer

Override this method to take action when a partitioned step is rolling back.

rollbackPartitionedStep() - Method in interface javax.batch.api.partition.PartitionReducer

The rollbackPartitionedStep method receives control if the runtime is rolling back a partitioned step.

Root<X> - Interface in javax.persistence.criteria

A root type in the from clause.

rowSelected(DataModelEvent) - Method in interface javax.faces.model.DataModelListener

Notification that a particular row index, with the associated row data, has been selected for processing.

run() - Method in interface javax.jms.Session

Optional operation, intended to be used only by Application Servers, not by ordinary JMS clients.

RunAs - Annotation Type in javax.annotation.security

Defines the identity of the application during execution in a J2EE container.

RUNNING - Static variable in class javax.enterprise.deploy.shared.StateType

The action operation is running normally.

RuntimeDelegate - Class in javax.ws.rs.ext

Implementations of JAX-RS provide a concrete subclass of RuntimeDelegate and various JAX-RS API methods defer to methods of RuntimeDelegate for their functionality.

RuntimeDelegate() - Constructor for class javax.ws.rs.ext.RuntimeDelegate

Allows custom implementations to extend the RuntimeDelegate class.

RuntimeDelegate.HeaderDelegate<T> - Interface in javax.ws.rs.ext

Defines the contract for a delegate that is responsible for converting between the String form of a HTTP header and the corresponding JAX-RS type T.

RuntimeType - Enum in javax.ws.rs

Enumeration of JAX-RS runtime types.

S

SAAJMetaFactory - Class in javax.xml.soap

The access point for the implementation classes of the factories defined in the SAAJ API.

SAAJMetaFactory() - Constructor for class javax.xml.soap.SAAJMetaFactory

SAAJResult - Class in javax.xml.soap

Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree.

SAAJResult() - Constructor for class javax.xml.soap.SAAJResult

Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.

SAAJResult(String) - Constructor for class javax.xml.soap.SAAJResult

Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol.

SAAJResult(SOAPMessage) - Constructor for class javax.xml.soap.SAAJResult

Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage.

SAAJResult(SOAPElement) - Constructor for class javax.xml.soap.SAAJResult

Creates a SAAJResult that will write the results as a child node of the SOAPElement specified.

save(OutputStream) - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration

Save to disk the current set configuration beans created for this deployable module.

saveAssociations(Collection, boolean) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Saves the specified Association instances.

saveAttachedState(FacesContext, Object) - Static method in class javax.faces.component.UIComponentBase

This method is called by UIComponent subclasses that want to save one or more attached objects.

saveChanges() - Method in class javax.mail.internet.MimeMessage

Updates the appropriate header fields of this message to be consistent with the message's contents.

saveChanges() - Method in class javax.mail.Message

Save any changes made to this message into the message-store when the containing folder is closed, if the message is contained in a folder.

saveChanges() - Method in class javax.xml.soap.SOAPMessage

Updates this SOAPMessage object with all the changes that have been made to it.

saveClassificationSchemes(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Saves the specified ClassificationScheme instances.

saveConcepts(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Saves the specified Concepts.

saved - Variable in class javax.mail.internet.MimeMessage

Does the saveChanges method need to be called on this message? This flag is set to false by the public constructor and set to true by the saveChanges method.

saveDConfigBean(OutputStream, DConfigBeanRoot) - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration

Save to disk all the configuration beans associated with a particular deployment descriptor file.

SaveException - Exception in javax.xml.registry

A RegistryException that occurs during a save action.

SaveException() - Constructor for exception javax.xml.registry.SaveException

Constructs a JAXRException object with no reason or embedded Throwable.

SaveException(String) - Constructor for exception javax.xml.registry.SaveException

Constructs a JAXRException object with the given String as the reason for the exception being thrown.

SaveException(String, Throwable) - Constructor for exception javax.xml.registry.SaveException

Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

SaveException(Throwable) - Constructor for exception javax.xml.registry.SaveException

Constructs a JAXRException object initialized with the given Throwable object.

saveFile(File) - Method in class javax.mail.internet.MimeBodyPart

Save the contents of this part in the specified file.

saveFile(String) - Method in class javax.mail.internet.MimeBodyPart

Save the contents of this part in the specified file.

saveObjects(Collection) - Method in interface javax.xml.registry.LifeCycleManager

Saves one or more Objects to the registry.

saveOrganizations(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Saves the specified Organizations.

saveRequired() - Method in class javax.xml.soap.SOAPMessage

Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.

saveSerializedView(FacesContext) - Method in class javax.faces.application.StateManager

Deprecated.
this has been replaced by StateManager.saveView(javax.faces.context.FacesContext). The default implementation calls saveView and inspects the return. If the return is an Object [], it casts the result to an Object [] wrapping the first and second elements in an instance of StateManager.SerializedView, which it then returns. Otherwise, it returns null

saveSerializedView(FacesContext) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.saveSerializedView(javax.faces.context.FacesContext) on the wrapped StateManager object.

saveServiceBindings(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Saves the specified ServiceBindings.

saveServices(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Saves the specified Services.

saveState(FacesContext) - Method in class javax.faces.component.behavior.AjaxBehavior

saveState(FacesContext) - Method in class javax.faces.component.behavior.BehaviorBase

Implementation of StateHolder.saveState(javax.faces.context.FacesContext).

saveState(FacesContext) - Method in interface javax.faces.component.StateHolder

Gets the state of the instance as a Serializable Object.

saveState(FacesContext) - Method in class javax.faces.component.UIComponentBase

saveState(FacesContext) - Method in class javax.faces.component.UIData

saveState(FacesContext) - Method in class javax.faces.component.UIInput

saveState(FacesContext) - Method in class javax.faces.component.UIOutput

saveState(FacesContext) - Method in class javax.faces.component.UIViewRoot

saveState(FacesContext) - Method in class javax.faces.convert.DateTimeConverter

saveState(FacesContext) - Method in class javax.faces.convert.EnumConverter

saveState(FacesContext) - Method in class javax.faces.convert.NumberConverter

saveState(FacesContext) - Method in class javax.faces.event.MethodExpressionActionListener

Both MethodExpression instances described in the constructor must be saved.

saveState(FacesContext) - Method in class javax.faces.event.MethodExpressionValueChangeListener

Both MethodExpression instances described in the constructor must be saved.

saveState(FacesContext) - Method in class javax.faces.validator.BeanValidator

saveState(FacesContext) - Method in class javax.faces.validator.DoubleRangeValidator

saveState(FacesContext) - Method in class javax.faces.validator.LengthValidator

saveState(FacesContext) - Method in class javax.faces.validator.LongRangeValidator

saveState(FacesContext) - Method in class javax.faces.validator.MethodExpressionValidator

saveState(FacesContext) - Method in class javax.faces.validator.RegexValidator

saveTransientState(FacesContext) - Method in interface javax.faces.component.TransientStateHolder

Return the object containing related "transient states".

saveTransientState(FacesContext) - Method in class javax.faces.component.UIComponent

For components that need to support the concept of transient state, this method will save any state that is known to be transient in nature.

saveView(FacesContext) - Method in class javax.faces.application.StateManager

Deprecated.

saveView(FacesContext) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.saveView(javax.faces.context.FacesContext) on the wrapped StateManager object.

saveView(FacesContext) - Method in class javax.faces.view.StateManagementStrategy

Return the state of the current view in an Object that implements Serializable and can be passed to java.io.ObjectOutputStream.writeObject() without causing a java.io.NotSerializableException to be thrown. The default implementation must perform the following algorithm or its semantic equivalent, explicitly performing all the steps listed here.

SC_ACCEPTED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (202) indicating that a request was accepted for processing, but was not completed.

SC_BAD_GATEWAY - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (502) indicating that the HTTP server received an invalid response from a server it consulted when acting as a proxy or gateway.

SC_BAD_REQUEST - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (400) indicating the request sent by the client was syntactically incorrect.

SC_CONFLICT - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (409) indicating that the request could not be completed due to a conflict with the current state of the resource.

SC_CONTINUE - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (100) indicating the client can continue.

SC_CREATED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (201) indicating the request succeeded and created a new resource on the server.

SC_EXPECTATION_FAILED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (417) indicating that the server could not meet the expectation given in the Expect request header.

SC_FORBIDDEN - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (403) indicating the server understood the request but refused to fulfill it.

SC_FOUND - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (302) indicating that the resource reside temporarily under a different URI.

SC_GATEWAY_TIMEOUT - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (504) indicating that the server did not receive a timely response from the upstream server while acting as a gateway or proxy.

SC_GONE - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (410) indicating that the resource is no longer available at the server and no forwarding address is known.

SC_HTTP_VERSION_NOT_SUPPORTED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (505) indicating that the server does not support or refuses to support the HTTP protocol version that was used in the request message.

SC_INTERNAL_SERVER_ERROR - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (500) indicating an error inside the HTTP server which prevented it from fulfilling the request.

SC_LENGTH_REQUIRED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (411) indicating that the request cannot be handled without a defined Content-Length.

SC_METHOD_NOT_ALLOWED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (405) indicating that the method specified in the Request-Line is not allowed for the resource identified by the Request-URI.

SC_MOVED_PERMANENTLY - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (301) indicating that the resource has permanently moved to a new location, and that future references should use a new URI with their requests.

SC_MOVED_TEMPORARILY - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (302) indicating that the resource has temporarily moved to another location, but that future references should still use the original URI to access the resource.

SC_MULTIPLE_CHOICES - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (300) indicating that the requested resource corresponds to any one of a set of representations, each with its own specific location.

SC_NO_CONTENT - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (204) indicating that the request succeeded but that there was no new information to return.

SC_NON_AUTHORITATIVE_INFORMATION - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (203) indicating that the meta information presented by the client did not originate from the server.

SC_NOT_ACCEPTABLE - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (406) indicating that the resource identified by the request is only capable of generating response entities which have content characteristics not acceptable according to the accept headers sent in the request.

SC_NOT_FOUND - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (404) indicating that the requested resource is not available.

SC_NOT_IMPLEMENTED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (501) indicating the HTTP server does not support the functionality needed to fulfill the request.

SC_NOT_MODIFIED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (304) indicating that a conditional GET operation found that the resource was available and not modified.

SC_OK - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (200) indicating the request succeeded normally.

SC_PARTIAL_CONTENT - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (206) indicating that the server has fulfilled the partial GET request for the resource.

SC_PAYMENT_REQUIRED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (402) reserved for future use.

SC_PRECONDITION_FAILED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (412) indicating that the precondition given in one or more of the request-header fields evaluated to false when it was tested on the server.

SC_PROXY_AUTHENTICATION_REQUIRED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (407) indicating that the client MUST first authenticate itself with the proxy.

SC_REQUEST_ENTITY_TOO_LARGE - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (413) indicating that the server is refusing to process the request because the request entity is larger than the server is willing or able to process.

SC_REQUEST_TIMEOUT - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (408) indicating that the client did not produce a request within the time that the server was prepared to wait.

SC_REQUEST_URI_TOO_LONG - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (414) indicating that the server is refusing to service the request because the Request-URI is longer than the server is willing to interpret.

SC_REQUESTED_RANGE_NOT_SATISFIABLE - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (416) indicating that the server cannot serve the requested byte range.

SC_RESET_CONTENT - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (205) indicating that the agent SHOULD reset the document view which caused the request to be sent.

SC_SEE_OTHER - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (303) indicating that the response to the request can be found under a different URI.

SC_SERVICE_UNAVAILABLE - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (503) indicating that the HTTP server is temporarily overloaded, and unable to handle the request.

SC_SWITCHING_PROTOCOLS - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (101) indicating the server is switching protocols according to Upgrade header.

SC_TEMPORARY_REDIRECT - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (307) indicating that the requested resource resides temporarily under a different URI.

SC_UNAUTHORIZED - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (401) indicating that the request requires HTTP authentication.

SC_UNSUPPORTED_MEDIA_TYPE - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (415) indicating that the server is refusing to service the request because the entity of the request is in a format not supported by the requested resource for the requested method.

SC_USE_PROXY - Static variable in interface javax.servlet.http.HttpServletResponse

Status code (305) indicating that the requested resource MUST be accessed through the proxy given by the Location field.

ScalarDataModel<E> - Class in javax.faces.model

ScalarDataModel is a convenience implementation of DataModel that wraps an individual Java object.

ScalarDataModel() - Constructor for class javax.faces.model.ScalarDataModel

Construct a new ScalarDataModel with no specified wrapped data.

ScalarDataModel(E) - Constructor for class javax.faces.model.ScalarDataModel

Construct a new ScalarDataModel wrapping the specified scalar object.

Schedule - Annotation Type in javax.ejb

Schedule a timer for automatic creation with a timeout schedule based on a cron-like time expression.

schedule(Runnable, Trigger) - Method in interface javax.enterprise.concurrent.ManagedScheduledExecutorService

Creates and executes a task based on a Trigger.

schedule(Callable<V>, Trigger) - Method in interface javax.enterprise.concurrent.ManagedScheduledExecutorService

Creates and executes a task based on a Trigger.

ScheduleExpression - Class in javax.ejb

A calendar-based timeout expression for an enterprise bean timer.

ScheduleExpression() - Constructor for class javax.ejb.ScheduleExpression

Create a schedule with the default values.

Schedules - Annotation Type in javax.ejb

Applied to a timer callback method to schedule multiple calendar-based timers for the method.

scheduleWork(Work) - Method in interface javax.resource.spi.work.WorkManager

Accepts a Work instance for processing.

scheduleWork(Work, long, ExecutionContext, WorkListener) - Method in interface javax.resource.spi.work.WorkManager

Accepts a Work instance for processing.

SchemaOutputResolver - Class in javax.xml.bind

Controls where a JAXB implementation puts the generates schema files.

SchemaOutputResolver() - Constructor for class javax.xml.bind.SchemaOutputResolver

scheme(String) - Method in class javax.ws.rs.core.UriBuilder

Set the URI scheme.

schemeSpecificPart(String) - Method in class javax.ws.rs.core.UriBuilder

Set the URI scheme-specific-part (see URI).

Scope - Annotation Type in javax.inject

Identifies scope annotations.

Scope - Enum in javax.validation.metadata

Scope looked at when discovering constraints.

scope - Variable in class javax.xml.bind.JAXBElement

Scope of xml element declaration representing this xml element instance.

ScopeContext - Class in javax.faces.event

A structure that contains the name of the scope and the scope itself exposed as a Map<String, Object>.

ScopeContext(String, Map<String, Object>) - Constructor for class javax.faces.event.ScopeContext

Construct this structure with the supplied arguments.

ScopedAttributeELResolver - Class in javax.servlet.jsp.el

Defines variable resolution behavior for scoped attributes.

ScopedAttributeELResolver() - Constructor for class javax.servlet.jsp.el.ScopedAttributeELResolver

ScriptFreeTLV - Class in javax.servlet.jsp.jstl.tlv

A TagLibraryValidator for enforcing restrictions against the use of JSP scripting elements.

ScriptFreeTLV() - Constructor for class javax.servlet.jsp.jstl.tlv.ScriptFreeTLV

Constructs a new validator instance.

search(SearchTerm) - Method in class javax.mail.Folder

Search this Folder for messages matching the specified search criterion.

search(SearchTerm, Message[]) - Method in class javax.mail.Folder

Search the given array of messages for those that match the specified search criterion.

SearchException - Exception in javax.mail.search

The exception thrown when a Search expression could not be handled.

SearchException() - Constructor for exception javax.mail.search.SearchException

Constructs a SearchException with no detail message.

SearchException(String) - Constructor for exception javax.mail.search.SearchException

Constructs a SearchException with the specified detail message.

SearchTerm - Class in javax.mail.search

Search criteria are expressed as a tree of search-terms, forming a parse-tree for the search expression.

SearchTerm() - Constructor for class javax.mail.search.SearchTerm

SEC_WEBSOCKET_ACCEPT - Static variable in interface javax.websocket.HandshakeResponse

The Sec-WebSocket-Accept header name.

SEC_WEBSOCKET_EXTENSIONS - Static variable in interface javax.websocket.server.HandshakeRequest

The Sec-WebSocket-Extensions header name

SEC_WEBSOCKET_KEY - Static variable in interface javax.websocket.server.HandshakeRequest

The Sec-WebSocket-Key header name

SEC_WEBSOCKET_PROTOCOL - Static variable in interface javax.websocket.server.HandshakeRequest

The Sec-WebSocket-Protocol header name

SEC_WEBSOCKET_VERSION - Static variable in interface javax.websocket.server.HandshakeRequest

The Sec-WebSocket-Version header name

second(String) - Method in class javax.ejb.ScheduleExpression

Set the second attribute.

second(int) - Method in class javax.ejb.ScheduleExpression

Set the second attribute.

SecondaryTable - Annotation Type in javax.persistence

Specifies a secondary table for the annotated entity class.

SecondaryTables - Annotation Type in javax.persistence

Specifies multiple secondary tables for an entity.

SecretKeyCallback - Class in javax.security.auth.message.callback

Callback for acquiring a shared secret from a key repository.

SecretKeyCallback(SecretKeyCallback.Request) - Constructor for class javax.security.auth.message.callback.SecretKeyCallback

Constructs this SecretKeyCallback with a secret key Request object.

SecretKeyCallback.AliasRequest - Class in javax.security.auth.message.callback

Request type for secret keys that are identified using an alias.

SecretKeyCallback.AliasRequest(String) - Constructor for class javax.security.auth.message.callback.SecretKeyCallback.AliasRequest

Construct an AliasRequest with an alias.

SecretKeyCallback.Request - Interface in javax.security.auth.message.callback

Marker interface for secret key request types.

secureRequest(MessageInfo, Subject) - Method in interface javax.security.auth.message.ClientAuth

Secure a service request message before sending it to the service.

secureResponse(MessageInfo, Subject) - Method in interface javax.security.auth.message.ServerAuth

Secure a service response before sending it to the client.

SecurityContext - Class in javax.resource.spi.work

A standard WorkContext that allows a Work instance to propagate security related context information from an EIS to an application server.

SecurityContext() - Constructor for class javax.resource.spi.work.SecurityContext

SecurityContext - Interface in javax.ws.rs.core

An injectable interface that provides access to security related information.

SecurityException - Exception in javax.resource.spi

A SecurityException indicates error conditions related to the security contract between an application server and resource adapter.

SecurityException() - Constructor for exception javax.resource.spi.SecurityException

Constructs a new instance with null as its detail message.

SecurityException(String) - Constructor for exception javax.resource.spi.SecurityException

Constructs a new instance with the specified detail message.

SecurityException(Throwable) - Constructor for exception javax.resource.spi.SecurityException

Constructs a new throwable with the specified cause.

SecurityException(String, Throwable) - Constructor for exception javax.resource.spi.SecurityException

Constructs a new throwable with the specified detail message and cause.

SecurityException(String, String) - Constructor for exception javax.resource.spi.SecurityException

Constructs a new throwable with the specified detail message and an error code.

SecurityPermission - Annotation Type in javax.resource.spi

The SecurityPermission annotation can be used by the developer, as part of the Connector annotation, to specify the extended security permissions required by the resource adapter

SEEN - Static variable in class javax.mail.Flags.Flag

This message is seen.

seeOther(URI) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder for a redirection.

segment(String...) - Method in class javax.ws.rs.core.UriBuilder

Append path segments to the existing path.

select(Annotation...) - Method in interface javax.enterprise.event.Event

Obtains a child Event for the given additional required qualifiers.

select(Class<U>, Annotation...) - Method in interface javax.enterprise.event.Event

Obtains a child Event for the given required type and additional required qualifiers.

select(TypeLiteral<U>, Annotation...) - Method in interface javax.enterprise.event.Event

Obtains a child Event for the given required type and additional required qualifiers.

select(Annotation...) - Method in interface javax.enterprise.inject.Instance

Obtains a child Instance for the given additional required qualifiers.

select(Class<U>, Annotation...) - Method in interface javax.enterprise.inject.Instance

Obtains a child Instance for the given required type and additional required qualifiers.

select(TypeLiteral<U>, Annotation...) - Method in interface javax.enterprise.inject.Instance

Obtains a child Instance for the given required type and additional required qualifiers.

select(Selection<? extends T>) - Method in interface javax.persistence.criteria.CriteriaQuery

Specify the item that is to be returned in the query result.

select(Expression<T>) - Method in interface javax.persistence.criteria.Subquery

Specify the item that is to be returned as the subquery result.

selectCase(Expression<? extends C>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a simple case expression.

selectCase() - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a general case expression.

Selection<X> - Interface in javax.persistence.criteria

The Selection interface defines an item that is to be returned in a query result.

SelectItem - Class in javax.faces.model

SelectItem represents a single item in the list of supported items associated with a UISelectMany or UISelectOne component.

SelectItem() - Constructor for class javax.faces.model.SelectItem

Construct a SelectItem with no initialized property values.

SelectItem(Object) - Constructor for class javax.faces.model.SelectItem

Construct a SelectItem with the specified value.

SelectItem(Object, String) - Constructor for class javax.faces.model.SelectItem

Construct a SelectItem with the specified value and label.

SelectItem(Object, String, String) - Constructor for class javax.faces.model.SelectItem

Construct a SelectItem instance with the specified value, label and description.

SelectItem(Object, String, String, boolean) - Constructor for class javax.faces.model.SelectItem

Construct a SelectItem instance with the specified property values.

SelectItem(Object, String, String, boolean, boolean) - Constructor for class javax.faces.model.SelectItem

Construct a SelectItem instance with the specified property values.

SelectItem(Object, String, String, boolean, boolean, boolean) - Constructor for class javax.faces.model.SelectItem

Construct a SelectItem instance with the specified property values.

SelectItemGroup - Class in javax.faces.model

SelectItemGroup is a subclass of SelectItem that identifies a set of options that will be made available as a subordinate "submenu" or "options list", depending upon the requirements of the UISelectMany or UISelectOne renderer that is actually used.

SelectItemGroup() - Constructor for class javax.faces.model.SelectItemGroup

Construct a SelectItemGroup with no initialized property values.

SelectItemGroup(String) - Constructor for class javax.faces.model.SelectItemGroup

Construct a SelectItemGroup with the specified label and no associated selectItems.

SelectItemGroup(String, String, boolean, SelectItem[]) - Constructor for class javax.faces.model.SelectItemGroup

Construct a SelectItemGroup with the specified properties.

selectVariant(List<Variant>) - Method in interface javax.ws.rs.core.Request

Select the representation variant that best matches the request.

send(Destination, Message) - Method in interface javax.jms.JMSProducer

Sends a message to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.

send(Destination, String) - Method in interface javax.jms.JMSProducer

Send a TextMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.

send(Destination, Map<String, Object>) - Method in interface javax.jms.JMSProducer

Send a MapMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.

send(Destination, byte[]) - Method in interface javax.jms.JMSProducer

Send a BytesMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.

send(Destination, Serializable) - Method in interface javax.jms.JMSProducer

Send an ObjectMessage with the specified body to the specified destination, using any send options, message properties and message headers that have been defined on this JMSProducer.

send(Message) - Method in interface javax.jms.MessageProducer

Sends a message using the MessageProducer's default delivery mode, priority, and time to live.

send(Message, int, int, long) - Method in interface javax.jms.MessageProducer

Sends a message, specifying delivery mode, priority, and time to live.

send(Destination, Message) - Method in interface javax.jms.MessageProducer

Sends a message to a destination for an unidentified message producer using the MessageProducer's default delivery mode, priority, and time to live.

send(Destination, Message, int, int, long) - Method in interface javax.jms.MessageProducer

Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live.

send(Message, CompletionListener) - Method in interface javax.jms.MessageProducer

Sends a message using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.

send(Message, int, int, long, CompletionListener) - Method in interface javax.jms.MessageProducer

Sends a message, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.

send(Destination, Message, CompletionListener) - Method in interface javax.jms.MessageProducer

Sends a message to a destination for an unidentified message producer, using the MessageProducer's default delivery mode, priority, and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.

send(Destination, Message, int, int, long, CompletionListener) - Method in interface javax.jms.MessageProducer

Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live, performing part of the work involved in sending the message in a separate thread and notifying the specified CompletionListener when the operation has completed.

send(Message) - Method in interface javax.jms.QueueSender

Sends a message to the queue.

send(Message, int, int, long) - Method in interface javax.jms.QueueSender

Sends a message to the queue, specifying delivery mode, priority, and time to live.

send(Queue, Message) - Method in interface javax.jms.QueueSender

Sends a message to a queue for an unidentified message producer.

send(Queue, Message, int, int, long) - Method in interface javax.jms.QueueSender

Sends a message to a queue for an unidentified message producer, specifying delivery mode, priority and time to live.

send(Message) - Static method in class javax.mail.Transport

Send a message.

send(Message, Address[]) - Static method in class javax.mail.Transport

Send the message to the specified addresses, ignoring any recipients specified in the message itself.

send(Message, String, String) - Static method in class javax.mail.Transport

Send a message.

send(Message, Address[], String, String) - Static method in class javax.mail.Transport

Send the message to the specified addresses, ignoring any recipients specified in the message itself.

SEND_CONTINUE - Static variable in class javax.security.auth.message.AuthStatus

Indicates the message processing by the authentication module is NOT complete, that the module replaced the application message with a security message, and that the runtime is to proceed by sending the security message.

SEND_FAILURE - Static variable in class javax.security.auth.message.AuthStatus

Indicates that the message processing by the authentication module was NOT successful, that the module replaced the application message with an error message, and that the runtime is to proceed by sending the error message.

SEND_SUCCESS - Static variable in class javax.security.auth.message.AuthStatus

Indicates that the message processing by the authentication module was successful and that the runtime is to proceed by sending a message returned by the authentication module.

sendBinary(ByteBuffer) - Method in interface javax.websocket.RemoteEndpoint.Async

Initiates the asynchronous transmission of a binary message.

sendBinary(ByteBuffer, SendHandler) - Method in interface javax.websocket.RemoteEndpoint.Async

Initiates the asynchronous transmission of a binary message.

sendBinary(ByteBuffer) - Method in interface javax.websocket.RemoteEndpoint.Basic

Send a binary message, returning when all of the message has been transmitted.

sendBinary(ByteBuffer, boolean) - Method in interface javax.websocket.RemoteEndpoint.Basic

Send a binary message in parts, blocking until all of the message has been transmitted.

sendError(int, String) - Method in interface javax.servlet.http.HttpServletResponse

Sends an error response to the client using the specified status and clears the buffer.

sendError(int) - Method in interface javax.servlet.http.HttpServletResponse

Sends an error response to the client using the specified status code and clears the buffer.

sendError(int, String) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to call sendError(int sc, String msg) on the wrapped response object.

sendError(int) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to call sendError(int sc) on the wrapped response object.

SendFailedException - Exception in javax.mail

This exception is thrown when the message cannot be sent.

SendFailedException() - Constructor for exception javax.mail.SendFailedException

Constructs a SendFailedException with no detail message.

SendFailedException(String) - Constructor for exception javax.mail.SendFailedException

Constructs a SendFailedException with the specified detail message.

SendFailedException(String, Exception) - Constructor for exception javax.mail.SendFailedException

Constructs a SendFailedException with the specified Exception and detail message.

SendFailedException(String, Exception, Address[], Address[], Address[]) - Constructor for exception javax.mail.SendFailedException

Constructs a SendFailedException with the specified string and the specified address objects.

SendHandler - Interface in javax.websocket

A simple callback object for asynchronous sending of web socket messages.

sendMessage(Message, Address[]) - Method in class javax.mail.Transport

Send the Message to the specified list of addresses.

sendObject(Object) - Method in interface javax.websocket.RemoteEndpoint.Async

Initiates the asynchronous transmission of a custom developer object.

sendObject(Object, SendHandler) - Method in interface javax.websocket.RemoteEndpoint.Async

Initiates the asynchronous transmission of a custom developer object.

sendObject(Object) - Method in interface javax.websocket.RemoteEndpoint.Basic

Sends a custom developer object, blocking until it has been transmitted.

sendPing(ByteBuffer) - Method in interface javax.websocket.RemoteEndpoint

Send a Ping message containing the given application data to the remote endpoint.

sendPong(ByteBuffer) - Method in interface javax.websocket.RemoteEndpoint

Allows the developer to send an unsolicited Pong message containing the given application data in order to serve as a unidirectional heartbeat for the session.

sendRedirect(String) - Method in interface javax.servlet.http.HttpServletResponse

Sends a temporary redirect response to the client using the specified redirect location URL and clears the buffer.

sendRedirect(String) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to return sendRedirect(String location) on the wrapped response object.

SendResult - Class in javax.websocket

The result of asynchronously sending a web socket message.

SendResult(Throwable) - Constructor for class javax.websocket.SendResult

Construct a SendResult carrying an exception.

SendResult() - Constructor for class javax.websocket.SendResult

Construct a SendResult signifying a successful send carrying no exception.

sendText(String, SendHandler) - Method in interface javax.websocket.RemoteEndpoint.Async

Initiates the asynchronous transmission of a text message.

sendText(String) - Method in interface javax.websocket.RemoteEndpoint.Async

Initiates the asynchronous transmission of a text message.

sendText(String) - Method in interface javax.websocket.RemoteEndpoint.Basic

Send a text message, blocking until all of the message has been transmitted.

sendText(String, boolean) - Method in interface javax.websocket.RemoteEndpoint.Basic

Send a text message in parts, blocking until all of the message has been transmitted.

SentDateTerm - Class in javax.mail.search

This class implements comparisons for the Message SentDate.

SentDateTerm(int, Date) - Constructor for class javax.mail.search.SentDateTerm

Constructor.

SEPARATOR_CHAR - Static variable in interface javax.faces.component.NamingContainer

Deprecated.
use UINamingContainer.getSeparatorChar(javax.faces.context.FacesContext)

SEPARATOR_CHAR_PARAM_NAME - Static variable in class javax.faces.component.UINamingContainer

The context-param that allows the separator char for clientId strings to be set on a per-web application basis.

SequenceGenerator - Annotation Type in javax.persistence

Defines a primary key generator that may be referenced by name when a generator element is specified for the GeneratedValue annotation.

SerializationContext - Interface in javax.xml.rpc.encoding

The javax.xml.rpc.encoding.SerializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner.

SERIALIZE_SERVER_STATE_PARAM_NAME - Static variable in class javax.faces.application.StateManager

If this param is set, and calling toLowerCase().equals("true") on a String representation of its value returns true, and the javax.faces.STATE_SAVING_METHOD is set to "server" (as indicated below), the server state must be guaranteed to be Serializable such that the aggregate state implements java.io.Serializable.

Serializer - Interface in javax.xml.rpc.encoding

The javax.xml.rpc.encoding.Serializer interface defines the base interface for serializers.

SerializerFactory - Interface in javax.xml.rpc.encoding

The javax.xml.rpc.encoding.SerializerFactory is a factory of the serializers.

ServerApplicationConfig - Interface in javax.websocket.server

Developers include implementations of ServerApplicationConfig in an archive containing websocket endpoints (WAR file, or JAR file within the WAR file) in order to specify the websocket endpoints within the archive the implementation must deploy.

ServerAuth - Interface in javax.security.auth.message

An implementation of this interface is used to validate received service request messages, and to secure service response messages.

ServerAuthConfig - Interface in javax.security.auth.message.config

This interface describes a configuration of ServerAuthConfiguration objects for a message layer and application context (for example, the messaging context of a specific application, or set of applications).

ServerAuthContext - Interface in javax.security.auth.message.config

This ServerAuthContext class encapsulates ServerAuthModules that are used to validate service requests received from clients, and to secure any response returned for those requests.

ServerAuthModule - Interface in javax.security.auth.message.module

A ServerAuthModule validates client requests and secures responses to the client.

ServerContainer - Interface in javax.websocket.server

The ServerContainer is the specialized view of the WebSocketContainer available in server-side deployments.

ServerEndpoint - Annotation Type in javax.websocket.server

This class level annotation declares that the class it decorates is a web socket endpoint that will be deployed and made available in the URI-space of a web socket server.

ServerEndpointConfig - Interface in javax.websocket.server

The ServerEndpointConfig is a special kind of endpoint configuration object that contains web socket configuration information specific only to server endpoints.

ServerEndpointConfig.Builder - Class in javax.websocket.server

The ServerEndpointConfig.Builder is a class used for creating ServerEndpointConfig.Builder objects for the purposes of deploying a server endpoint.

ServerEndpointConfig.Configurator - Class in javax.websocket.server

The ServerEndpointConfig.Configurator class may be extended by developers who want to provide custom configuration algorithms, such as intercepting the opening handshake, or providing arbitrary methods and algorithms that can be accessed from each endpoint instance configured with this configurator.

ServerEndpointConfig.Configurator() - Constructor for class javax.websocket.server.ServerEndpointConfig.Configurator

serverError() - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder with an server error status.

ServerErrorException - Exception in javax.ws.rs

A base runtime application exception indicating a server error (HTTP 5xx status codes).

ServerErrorException(Response.Status) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(String, Response.Status) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(int) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(String, int) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(Response) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(String, Response) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(Response.Status, Throwable) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(String, Response.Status, Throwable) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(int, Throwable) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(String, int, Throwable) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(Response, Throwable) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerErrorException(String, Response, Throwable) - Constructor for exception javax.ws.rs.ServerErrorException

Construct a new server error exception.

ServerSession - Interface in javax.jms

A ServerSession object is an application server object that is used by a server to associate a thread with a JMS session (optional).

ServerSessionPool - Interface in javax.jms

A ServerSessionPool object is an object implemented by an application server to provide a pool of ServerSession objects for processing the messages of a ConnectionConsumer (optional).

service(ServletRequest, ServletResponse) - Method in class javax.faces.webapp.FacesServlet

Process an incoming request, and create the corresponding response according to the following specification.

Service - Class in javax.mail

An abstract class that contains the functionality common to messaging services, such as stores and transports.

Service(Session, URLName) - Constructor for class javax.mail.Service

Constructor.

service(ServletRequest, ServletResponse) - Method in class javax.servlet.GenericServlet

Called by the servlet container to allow the servlet to respond to a request.

service(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet

Receives standard HTTP requests from the public service method and dispatches them to the do XXX methods defined in this class.

service(ServletRequest, ServletResponse) - Method in class javax.servlet.http.HttpServlet

Dispatches client requests to the protected service method.

service(ServletRequest, ServletResponse) - Method in interface javax.servlet.Servlet

Called by the servlet container to allow the servlet to respond to a request.

Service - Interface in javax.xml.registry.infomodel

Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization.

SERVICE - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.Service interface.

Service - Interface in javax.xml.rpc

Service class acts as a factory of the following: Dynamic proxy for the target service endpoint.

Service - Class in javax.xml.ws

Service objects provide the client view of a Web service.

Service(URL, QName) - Constructor for class javax.xml.ws.Service

Service(URL, QName, WebServiceFeature...) - Constructor for class javax.xml.ws.Service

Service.Mode - Enum in javax.xml.ws

The orientation of a dynamic client or service.

SERVICE_BINDING - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.ServiceBinding interface.

SERVICE_SUBSET - Static variable in interface javax.xml.registry.FindQualifier

Maps to UDDI serviceSubset.

ServiceBinding - Interface in javax.xml.registry.infomodel

ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance.

ServiceDelegate - Class in javax.xml.ws.spi

Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.

ServiceDelegate() - Constructor for class javax.xml.ws.spi.ServiceDelegate

ServiceException - Exception in javax.xml.rpc

The javax.xml.rpc.ServiceException is thrown from the methods in the javax.xml.rpc.Service interface and ServiceFactory class.

ServiceException() - Constructor for exception javax.xml.rpc.ServiceException

Constructs a new exception with null as its detail message.

ServiceException(String) - Constructor for exception javax.xml.rpc.ServiceException

Constructs a new exception with the specified detail message.

ServiceException(String, Throwable) - Constructor for exception javax.xml.rpc.ServiceException

Constructs a new exception with the specified detail message and cause.

ServiceException(Throwable) - Constructor for exception javax.xml.rpc.ServiceException

Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

ServiceFactory - Class in javax.xml.rpc

The javax.xml.rpc.ServiceFactory is an abstract class that provides a factory for the creation of instances of the type javax.xml.rpc.Service.

ServiceFactory() - Constructor for class javax.xml.rpc.ServiceFactory

SERVICEFACTORY_PROPERTY - Static variable in class javax.xml.rpc.ServiceFactory

A constant representing the property used to lookup the name of a ServiceFactory implementation class.

ServiceLifecycle - Interface in javax.xml.rpc.server

The javax.xml.rpc.server.ServiceLifecycle defines a lifecycle interface for a JAX-RPC service endpoint.

ServiceMode - Annotation Type in javax.xml.ws

Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.

serviceName(QName) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element.

ServiceUnavailableException - Exception in javax.ws.rs

A runtime exception indicating that the requested resource cannot be served.

ServiceUnavailableException() - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception without any "Retry-After" information specified for the failed request.

ServiceUnavailableException(String) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception without any "Retry-After" information specified for the failed request.

ServiceUnavailableException(Long) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.

ServiceUnavailableException(String, Long) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.

ServiceUnavailableException(Date) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.

ServiceUnavailableException(String, Date) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request.

ServiceUnavailableException(Response) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception.

ServiceUnavailableException(String, Response) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception.

ServiceUnavailableException(Date, Throwable) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception with a date specifying the "Retry-After" information for the failed request and an underlying request failure cause.

ServiceUnavailableException(String, Date, Throwable) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception with a date specifying the "Retry-After" information for the failed request and an underlying request failure cause.

ServiceUnavailableException(Long, Throwable) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request and an underlying request failure cause.

ServiceUnavailableException(String, Long, Throwable) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception with an interval specifying the "Retry-After" information for the failed request and an underlying request failure cause.

ServiceUnavailableException(Response, Throwable) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception.

ServiceUnavailableException(String, Response, Throwable) - Constructor for exception javax.ws.rs.ServiceUnavailableException

Construct a new "service unavailable" exception.

Servlet - Interface in javax.servlet

Defines methods that all servlets must implement.

SERVLET_CONTEXT - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: servlet context object.

SERVLET_REQUEST - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: servlet request object.

SERVLET_RESPONSE - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: servlet response object.

ServletConfig - Interface in javax.servlet

A servlet configuration object used by a servlet container to pass information to a servlet during initialization.

ServletContainerInitializer - Interface in javax.servlet

Interface which allows a library/runtime to be notified of a web application's startup phase and perform any required programmatic registration of servlets, filters, and listeners in response to it.

ServletContext - Interface in javax.servlet

Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.

ServletContextAttributeEvent - Class in javax.servlet

Event class for notifications about changes to the attributes of the ServletContext of a web application.

ServletContextAttributeEvent(ServletContext, String, Object) - Constructor for class javax.servlet.ServletContextAttributeEvent

Constructs a ServletContextAttributeEvent from the given ServletContext, attribute name, and attribute value.

ServletContextAttributeListener - Interface in javax.servlet

Interface for receiving notification events about ServletContext attribute changes.

ServletContextEvent - Class in javax.servlet

This is the event class for notifications about changes to the servlet context of a web application.

ServletContextEvent(ServletContext) - Constructor for class javax.servlet.ServletContextEvent

Construct a ServletContextEvent from the given context.

ServletContextListener - Interface in javax.servlet

Interface for receiving notification events about ServletContext lifecycle changes.

ServletEndpointContext - Interface in javax.xml.rpc.server

The ServletEndpointContext provides an endpoint context maintained by the underlying servlet container based JAX-RPC runtime system.

ServletException - Exception in javax.servlet

Defines a general exception a servlet can throw when it encounters difficulty.

ServletException() - Constructor for exception javax.servlet.ServletException

Constructs a new servlet exception.

ServletException(String) - Constructor for exception javax.servlet.ServletException

Constructs a new servlet exception with the specified message.

ServletException(String, Throwable) - Constructor for exception javax.servlet.ServletException

Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.

ServletException(Throwable) - Constructor for exception javax.servlet.ServletException

Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.

ServletInputStream - Class in javax.servlet

Provides an input stream for reading binary data from a client request, including an efficient readLine method for reading data one line at a time.

ServletInputStream() - Constructor for class javax.servlet.ServletInputStream

Does nothing, because this is an abstract class.

ServletOutputStream - Class in javax.servlet

Provides an output stream for sending binary data to the client.

ServletOutputStream() - Constructor for class javax.servlet.ServletOutputStream

Does nothing, because this is an abstract class.

ServletRegistration - Interface in javax.servlet

Interface through which a Servlet may be further configured.

ServletRegistration.Dynamic - Interface in javax.servlet

Interface through which a Servlet registered via one of the addServlet methods on ServletContext may be further configured.

ServletRequest - Interface in javax.servlet

Defines an object to provide client request information to a servlet.

ServletRequestAttributeEvent - Class in javax.servlet

This is the event class for notifications of changes to the attributes of the servlet request in an application.

ServletRequestAttributeEvent(ServletContext, ServletRequest, String, Object) - Constructor for class javax.servlet.ServletRequestAttributeEvent

Construct a ServletRequestAttributeEvent giving the servlet context of this web application, the ServletRequest whose attributes are changing and the name and value of the attribute.

ServletRequestAttributeListener - Interface in javax.servlet

Interface for receiving notification events about ServletRequest attribute changes.

ServletRequestEvent - Class in javax.servlet

Events of this kind indicate lifecycle events for a ServletRequest.

ServletRequestEvent(ServletContext, ServletRequest) - Constructor for class javax.servlet.ServletRequestEvent

Construct a ServletRequestEvent for the given ServletContext and ServletRequest.

ServletRequestListener - Interface in javax.servlet

Interface for receiving notification events about requests coming into and going out of scope of a web application.

ServletRequestWrapper - Class in javax.servlet

Provides a convenient implementation of the ServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.

ServletRequestWrapper(ServletRequest) - Constructor for class javax.servlet.ServletRequestWrapper

Creates a ServletRequest adaptor wrapping the given request object.

ServletResponse - Interface in javax.servlet

Defines an object to assist a servlet in sending a response to the client.

ServletResponseWrapper - Class in javax.servlet

Provides a convenient implementation of the ServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.

ServletResponseWrapper(ServletResponse) - Constructor for class javax.servlet.ServletResponseWrapper

Creates a ServletResponse adaptor wrapping the given response object.

ServletSecurity - Annotation Type in javax.servlet.annotation

This annotation is used on a Servlet implementation class to specify security constraints to be enforced by a Servlet container on HTTP protocol messages.

ServletSecurity.EmptyRoleSemantic - Enum in javax.servlet.annotation

Defines the access semantic to be applied to an empty rolesAllowed array.

ServletSecurity.TransportGuarantee - Enum in javax.servlet.annotation

Defines the data protection requirements that must be satisfied by the transport

ServletSecurityElement - Class in javax.servlet

Java Class represntation of a ServletSecurity annotation value.

ServletSecurityElement() - Constructor for class javax.servlet.ServletSecurityElement

Constructs an instance using the default HttpConstraintElement value as the default Constraint element and with no HTTP Method specific constraint elements.

ServletSecurityElement(HttpConstraintElement) - Constructor for class javax.servlet.ServletSecurityElement

Constructs an instance with a default Constraint element and with no HTTP Method specific constraint elements.

ServletSecurityElement(Collection<HttpMethodConstraintElement>) - Constructor for class javax.servlet.ServletSecurityElement

Constructs an instance using the default HttpConstraintElement value as the default Constraint element and with a collection of HTTP Method specific constraint elements.

ServletSecurityElement(HttpConstraintElement, Collection<HttpMethodConstraintElement>) - Constructor for class javax.servlet.ServletSecurityElement

Constructs an instance with a default Constraint element and with a collection of HTTP Method specific constraint elements.

ServletSecurityElement(ServletSecurity) - Constructor for class javax.servlet.ServletSecurityElement

Constructs an instance from a ServletSecurity annotation value.

ServletStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a Servlet.

Session - Interface in javax.jms

A Session object is a single-threaded context for producing and consuming messages.

session - Variable in class javax.mail.Message

The Session object for this Message

session - Variable in class javax.mail.Service

The session from which this service was created.

Session - Class in javax.mail

The Session class represents a mail session and is not subclassed.

SESSION - Static variable in class javax.servlet.jsp.PageContext

Name used to store HttpSession in PageContext name table.

Session - Interface in javax.websocket

A Web Socket session represents a conversation between two web socket endpoints.

SESSION_MAINTAIN_PROPERTY - Static variable in interface javax.xml.rpc.Call

Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.

SESSION_MAINTAIN_PROPERTY - Static variable in interface javax.xml.rpc.Stub

Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.

SESSION_MAINTAIN_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider

Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.

SESSION_SCOPE - Static variable in class javax.servlet.jsp.PageContext

Session scope (only valid if this page participates in a session): the named reference remains available from the HttpSession (if any) associated with the Servlet until the HttpSession is invalidated.

SESSION_TRANSACTED - Static variable in interface javax.jms.JMSContext

This session mode instructs the JMSContext's session to deliver and consume messages in a local transaction which will be subsequently committed by calling commit or rolled back by calling rollback.

SESSION_TRANSACTED - Static variable in interface javax.jms.Session

This value may be passed as the argument to the method createSession(int sessionMode) on the Connection object to specify that the session should use a local transaction.

SessionBean - Interface in javax.ejb

The SessionBean interface defines methods that the EJB container uses to notify a session bean instance of the instance's life cycle events.

SessionBeanStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by session beans of both stateful and stateless types.

SessionBeanType - Enum in javax.enterprise.inject.spi

Identifies the kind of EJB session bean.

SessionContext - Interface in javax.ejb

The SessionContext interface provides access to the runtime session context that the container provides for a session bean instance.

SessionCookieConfig - Interface in javax.servlet

Class that may be used to configure various properties of cookies used for session tracking purposes.

sessionCreated(HttpSessionEvent) - Method in interface javax.servlet.http.HttpSessionListener

Receives notification that a session has been created.

sessionDestroyed(HttpSessionEvent) - Method in interface javax.servlet.http.HttpSessionListener

Receives notification that a session is about to be invalidated.

sessionDidActivate(HttpSessionEvent) - Method in interface javax.servlet.http.HttpSessionActivationListener

Notification that the session has just been activated.

SessionException - Exception in javax.websocket

A SessionException represents a general exception type reporting problems occurring on a websocket session.

SessionException(String, Throwable, Session) - Constructor for exception javax.websocket.SessionException

Creates a new instance of this exception with the given message, the wrapped cause of the exception and the session with which the problem is associated.

sessionIdChanged(HttpSessionEvent, String) - Method in interface javax.servlet.http.HttpSessionIdListener

Receives notification that session id has been changed in a session.

SessionScoped - Annotation Type in javax.enterprise.context

Specifies that a bean is session scoped.

SessionScoped - Annotation Type in javax.faces.bean

When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>session<managed-bean-scope> element was declared for the corresponding managed bean.

SessionSynchronization - Interface in javax.ejb

The SessionSynchronization interface allows a stateful session bean instance to be notified by its container of transaction boundaries.

SessionTrackingMode - Enum in javax.servlet

Enumeration of session tracking modes.

sessionWillPassivate(HttpSessionEvent) - Method in interface javax.servlet.http.HttpSessionActivationListener

Notification that the session is about to be passivated.

set(String, String) - Method in class javax.mail.internet.ParameterList

Set a parameter.

set(String, String, String) - Method in class javax.mail.internet.ParameterList

Set a parameter.

set(SingularAttribute<? super T, Y>, X) - Method in interface javax.persistence.criteria.CriteriaUpdate

Update the value of the specified attribute.

set(SingularAttribute<? super T, Y>, Expression<? extends Y>) - Method in interface javax.persistence.criteria.CriteriaUpdate

Update the value of the specified attribute.

set(Path<Y>, X) - Method in interface javax.persistence.criteria.CriteriaUpdate

Update the value of the specified attribute.

set(Path<Y>, Expression<? extends Y>) - Method in interface javax.persistence.criteria.CriteriaUpdate

Update the value of the specified attribute.

set(String, Object) - Method in interface javax.persistence.criteria.CriteriaUpdate

Update the value of the specified attribute.

set(PageContext, String, Object, int) - Static method in class javax.servlet.jsp.jstl.core.Config

Sets the value of a configuration variable in the given scope.

set(ServletRequest, String, Object) - Static method in class javax.servlet.jsp.jstl.core.Config

Sets the value of a configuration variable in the "request" scope.

set(HttpSession, String, Object) - Static method in class javax.servlet.jsp.jstl.core.Config

Sets the value of a configuration variable in the "session" scope.

set(ServletContext, String, Object) - Static method in class javax.servlet.jsp.jstl.core.Config

Sets the value of a configuration variable in the "application" scope.

SET_COOKIE - Static variable in interface javax.ws.rs.core.HttpHeaders

See IETF RFC 2109.

SET_FACTORY_PERMISSION_NAME - Static variable in class javax.security.auth.message.config.AuthConfigFactory

The name of the SecurityPermission required to call setFactory

setAccept(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the accept property.

setAcceptcharset(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the acceptcharset property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the accesskey property.

setAccesskey(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the accesskey property.

setAccessURI(String) - Method in interface javax.xml.registry.infomodel.ServiceBinding

Sets the URI that gives access to the service via this binding.

setAction(MethodBinding) - Method in interface javax.faces.component.ActionSource

Deprecated.
This has been replaced by ActionSource2.setActionExpression(javax.el.MethodExpression).

setAction(MethodBinding) - Method in class javax.faces.component.UICommand

Deprecated.
This has been replaced by UICommand.setActionExpression(javax.el.MethodExpression).

setAction(MethodBinding) - Method in class javax.faces.component.UIViewAction

Deprecated.

setActionExpression(MethodExpression) - Method in interface javax.faces.component.ActionSource2

Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

setActionExpression(MethodExpression) - Method in class javax.faces.component.UICommand

setActionExpression(MethodExpression) - Method in class javax.faces.component.UIViewAction

Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

setActionListener(ActionListener) - Method in class javax.faces.application.Application

Set the default ActionListener to be registered for all ActionSource components.

setActionListener(ActionListener) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.setActionListener(javax.faces.event.ActionListener) on the wrapped Application object.

setActionListener(MethodBinding) - Method in interface javax.faces.component.ActionSource

Deprecated.
This has been replaced by ActionSource.addActionListener(javax.faces.event.ActionListener).

setActionListener(MethodBinding) - Method in class javax.faces.component.UICommand

Deprecated.
This has been replaced by UICommand.addActionListener(javax.faces.event.ActionListener).

setActionListener(MethodBinding) - Method in class javax.faces.component.UIViewAction

Deprecated.

setActor(String) - Method in interface javax.xml.soap.SOAPHeaderElement

Sets the actor associated with this SOAPHeaderElement object to the specified actor.

setAdapter(XmlAdapter) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setAdapter(Class<A>, A) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setAdapter(XmlAdapter) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

setAdapter(Class<A>, A) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

setAdapter(XmlAdapter) - Method in interface javax.xml.bind.Marshaller

Associates a configured instance of XmlAdapter with this marshaller.

setAdapter(Class<A>, A) - Method in interface javax.xml.bind.Marshaller

Associates a configured instance of XmlAdapter with this marshaller.

setAdapter(XmlAdapter) - Method in interface javax.xml.bind.Unmarshaller

Associates a configured instance of XmlAdapter with this unmarshaller.

setAdapter(Class<A>, A) - Method in interface javax.xml.bind.Unmarshaller

Associates a configured instance of XmlAdapter with this unmarshaller.

setAddress(String) - Method in class javax.mail.internet.InternetAddress

Set the email address.

setAddress(String) - Method in interface javax.xml.registry.infomodel.EmailAddress

Sets the email address for this object.

setAfterPhaseListener(MethodExpression) - Method in class javax.faces.component.UIViewRoot

Allow an arbitrary method to be called for the "afterPhase" event as the UIViewRoot runs through its lifecycle.

setAlt(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the alt property.

setAlt(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the alt property.

setAlt(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the alt property.

setAlt(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the alt property.

setAlt(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the alt property.

setAlt(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the alt property.

setAnnotatedType(AnnotatedType<X>) - Method in interface javax.enterprise.inject.spi.ProcessAnnotatedType

Replaces the AnnotatedType.

setAnnotations(Annotation[]) - Method in interface javax.ws.rs.ext.InterceptorContext

Update annotations on the formal declaration of the artifact that initiated the intercepted entity provider invocation.

setApplication(Application) - Method in class javax.faces.application.ApplicationFactory

Replace the Application instance that will be returned for this web application.

setAreaCode(String) - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Sets the area code.

setAssociations(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Replaces all previous Associations from this object with specified Associations.

setAssociationType(Concept) - Method in interface javax.xml.registry.infomodel.Association

Sets the association type for this Association.

setAsync(CompletionListener) - Method in interface javax.jms.JMSProducer

Specifies whether subsequent calls to send on this JMSProducer object should be synchronous or asynchronous.

setAsyncSendTimeout(long) - Method in interface javax.websocket.WebSocketContainer

Sets the number of milliseconds the implementation will timeout attempting to send a websocket message for all RemoteEndpoints associated with this container.

setAsyncSupported(boolean) - Method in interface javax.servlet.Registration.Dynamic

Configures the Servlet or Filter represented by this dynamic Registration as supporting asynchronous operations or not.

setAttachmentMarshaller(AttachmentMarshaller) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setAttachmentMarshaller(AttachmentMarshaller) - Method in interface javax.xml.bind.Marshaller

Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.

setAttachmentUnmarshaller(AttachmentUnmarshaller) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

setAttachmentUnmarshaller(AttachmentUnmarshaller) - Method in interface javax.xml.bind.Unmarshaller

Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

setAttribute(String, Object) - Method in class javax.faces.view.facelets.FaceletContext

Support method which is backed by the current VariableMapper.

setAttribute(ObjectName, Attribute) - Method in interface javax.management.j2ee.Management

Sets the value of a specific attribute of a named managed object.

SetAttribute<X,E> - Interface in javax.persistence.metamodel

Instances of the type SetAttribute represent persistent java.util.Set-valued attributes.

setAttribute(String, Object) - Method in interface javax.servlet.http.HttpSession

Binds an object to this session, using the name specified.

setAttribute(String, Object) - Method in class javax.servlet.jsp.JspContext

Register the name and value specified with page scope semantics.

setAttribute(String, Object, int) - Method in class javax.servlet.jsp.JspContext

Register the name and value specified with appropriate scope semantics.

setAttribute(String, Object) - Method in class javax.servlet.jsp.tagext.TagData

Set the value of an attribute.

setAttribute(String, Object) - Method in interface javax.servlet.ServletContext

Binds an object to a given attribute name in this ServletContext.

setAttribute(String, Object) - Method in interface javax.servlet.ServletRequest

Stores an attribute in this request.

setAttribute(String, Object) - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to return setAttribute(String name, Object o) on the wrapped request object.

setAttributes(FaceletContext, Object) - Method in class javax.faces.view.facelets.DelegatingMetaTagHandler

setAttributes(FaceletContext, Object) - Method in class javax.faces.view.facelets.MetaTagHandler

Invoking/extending this method will cause the results of the created MetaRuleset to auto-wire state to the passed instance.

setAttributes(ObjectName, AttributeList) - Method in interface javax.management.j2ee.Management

Sets the values of several attributes of a named managed object.

setAutocomplete(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the autocomplete property.

setAutocomplete(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the autocomplete property.

setAutocomplete(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the autocomplete property.

setAutoStart(boolean) - Method in interface javax.jms.JMSContext

Specifies whether the underlying connection used by this JMSContext will be started automatically when a consumer is created.

setBase64Content(InputStream, String) - Method in class javax.xml.soap.AttachmentPart

Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.

setBatchingAllowed(boolean) - Method in interface javax.websocket.RemoteEndpoint

Indicate to the implementation that it is allowed to batch outgoing messages before sending.

setBeanAttributes(BeanAttributes<T>) - Method in interface javax.enterprise.inject.spi.ProcessBeanAttributes

Replaces the BeanAttributes.

setBeanValue(String, Object) - Method in class javax.el.BeanNameResolver

Sets a value to a bean of the given name.

setBeforePhaseListener(MethodExpression) - Method in class javax.faces.component.UIViewRoot

Allow an arbitrary method to be called for the "beforePhase" event as the UIViewRoot runs through its lifecycle.

setBgcolor(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the bgcolor property.

setBgcolor(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the bgcolor property.

setBinding(String) - Method in class javax.faces.webapp.ConverterTag

Deprecated.

Set the expression that will be used to create a ValueExpression that references a backing bean property of the Converter instance to be created.

setBinding(ValueExpression) - Method in class javax.faces.webapp.UIComponentELTag

Set the value expression for our component.

setBinding(String) - Method in class javax.faces.webapp.UIComponentTag

Deprecated.

Set the value binding expression for our component.

setBinding(String) - Method in class javax.faces.webapp.ValidatorTag

Deprecated.

Set the expression that will be used to create a ValueExpression that references a backing bean property of the Validator instance to be created.

setBodyContent(BodyContent) - Method in class javax.faces.webapp.UIComponentClassicTagBase

Set the bodyContent for this tag handler.

setBodyContent(BodyContent) - Method in interface javax.servlet.jsp.tagext.BodyTag

Set the bodyContent property.

setBodyContent(BodyContent) - Method in class javax.servlet.jsp.tagext.BodyTagSupport

Prepare for evaluation of the body: stash the bodyContent away.

setBodyrows(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the bodyrows property.

setBodyrows(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the bodyrows property.

setBoolean(String, boolean) - Method in interface javax.jms.MapMessage

Sets a boolean value with the specified name into the Map.

setBooleanProperty(String, boolean) - Method in interface javax.jms.Message

Sets a boolean property value with the specified name into the message.

setBorder(int) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the border property.

setBorder(int) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the border property.

setBorder(int) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the border property.

setBorder(int) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the border property.

setBufferSize(int) - Method in interface javax.servlet.ServletResponse

Sets the preferred buffer size for the body of the response.

setBufferSize(int) - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to call setBufferSize(int size) on the wrapped response object.

setBuilder(DocumentBuilder) - Method in class javax.xml.bind.annotation.W3CDomHandler

setByte(String, byte) - Method in interface javax.jms.MapMessage

Sets a byte value with the specified name into the Map.

setByteProperty(String, byte) - Method in interface javax.jms.Message

Sets a byte property value with the specified name into the message.

setBytes(String, byte[]) - Method in interface javax.jms.MapMessage

Sets a byte array value with the specified name into the Map.

setBytes(String, byte[], int, int) - Method in interface javax.jms.MapMessage

Sets a portion of the byte array value with the specified name into the Map.

setCalendar(Calendar) - Method in class javax.mail.internet.MailDateFormat

Don't allow setting the calendar

setCaptionClass(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the captionClass property.

setCaptionClass(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the captionClass property.

setCaptionStyle(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the captionStyle property.

setCaptionStyle(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the captionStyle property.

setCDIProvider(CDIProvider) - Static method in class javax.enterprise.inject.spi.CDI

Set the CDIProvider to use.

setCellpadding(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the cellpadding property.

setCellpadding(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the cellpadding property.

setCellspacing(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the cellspacing property.

setCellspacing(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the cellspacing property.

setCertStore(CertStore) - Method in class javax.security.auth.message.callback.CertStoreCallback

Used by the CallbackHandler to set the CertStore within the Callback.

setChangeEvent(PropertyChangeEvent) - Method in class javax.enterprise.deploy.model.XpathEvent

setChar(String, char) - Method in interface javax.jms.MapMessage

Sets a Unicode character value with the specified name into the Map.

setCharacterEncoding(String) - Method in interface javax.servlet.ServletRequest

Overrides the name of the character encoding used in the body of this request.

setCharacterEncoding(String) - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to set the character encoding on the wrapped request object.

setCharacterEncoding(String) - Method in interface javax.servlet.ServletResponse

Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8.

setCharacterEncoding(String) - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to call setCharacterEncoding(String charset) on the wrapped response object.

setCharset(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the charset property.

setCharset(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the charset property.

setCharset(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the charset property.

setCharsetName(String) - Method in interface javax.xml.registry.infomodel.LocalizedString

Set the canonical name for the charset for this object.

setCity(String) - Method in interface javax.xml.registry.infomodel.PostalAddress

Sets the city.

setClassifications(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Replaces all previous Classifications with specified Classifications.

setClassificationScheme(ClassificationScheme) - Method in interface javax.xml.registry.infomodel.Classification

Sets the ClassificationScheme for this external classification.

setClassifiedObject(RegistryObject) - Method in interface javax.xml.registry.infomodel.Classification

Sets the object that is being classified.

setClientID(String) - Method in interface javax.jms.Connection

Sets the client identifier for this connection.

setClientID(String) - Method in interface javax.jms.JMSContext

Sets the client identifier for the JMSContext's connection.

setClientWindow(ClientWindow) - Method in class javax.faces.context.ExternalContext

Associate this instance with a ClientWindow.

setClientWindow(ClientWindow) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.setClientWindow(javax.faces.lifecycle.ClientWindow) on the wrapped ExternalContext object.

setCols(int) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the cols property.

setColumnClasses(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the columnClasses property.

setColumnClasses(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the columnClasses property.

setColumnNumber(int) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the columnNumber field on this event locator.

setColumns(int) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the columns property.

setComment(String) - Method in class javax.servlet.http.Cookie

Specifies a comment that describes a cookie's purpose.

setComment(String) - Method in interface javax.servlet.SessionCookieConfig

Sets the comment that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

setComponent(UIComponent) - Method in class javax.faces.event.PostRestoreStateEvent

setConcept(Concept) - Method in interface javax.xml.registry.infomodel.Classification

Sets the concept for this internal classification.

setConnected(boolean) - Method in class javax.mail.Service

Set the connection state of this service.

setConnectionHandle(Object) - Method in class javax.resource.spi.ConnectionEvent

Set the connection handle.

setContent(Object, String) - Method in class javax.mail.internet.MimeBodyPart

A convenience method for setting this body part's content.

setContent(Multipart) - Method in class javax.mail.internet.MimeBodyPart

This method sets the body part's content to a Multipart object.

setContent(Object, String) - Method in class javax.mail.internet.MimeMessage

A convenience method for setting this Message's content.

setContent(Multipart) - Method in class javax.mail.internet.MimeMessage

This method sets the Message's content to a Multipart object.

setContent(Object, String) - Method in interface javax.mail.Part

A convenience method for setting this part's content.

setContent(Multipart) - Method in interface javax.mail.Part

This method sets the given Multipart object as this message's content.

setContent(Object, String) - Method in class javax.xml.soap.AttachmentPart

Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type.

setContent(Source) - Method in class javax.xml.soap.SOAPPart

Sets the content of the SOAPEnvelope object with the data from the given Source object.

setContentDescription(String) - Method in class javax.xml.soap.SOAPMessage

Sets the description of this SOAPMessage object's content with the given description.

setContentID(String) - Method in class javax.mail.internet.MimeBodyPart

Set the "Content-ID" header field of this body part.

setContentID(String) - Method in class javax.mail.internet.MimeMessage

Set the "Content-ID" header field of this Message.

setContentId(String) - Method in class javax.xml.soap.AttachmentPart

Sets the MIME header whose name is "Content-ID" with the given value.

setContentId(String) - Method in class javax.xml.soap.SOAPPart

Sets the value of the MIME header named "Content-Id" to the given String.

setContentLanguage(String[]) - Method in class javax.mail.internet.MimeBodyPart

Set the Content-Language header of this MimePart.

setContentLanguage(String[]) - Method in class javax.mail.internet.MimeMessage

Set the "Content-Language" header of this MimePart.

setContentLanguage(String[]) - Method in interface javax.mail.internet.MimePart

Set the Content-Language header of this MimePart.

setContentLength(int) - Method in interface javax.servlet.ServletResponse

Sets the length of the content body in the response In HTTP servlets, this method sets the HTTP Content-Length header.

setContentLength(int) - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to call setContentLength(int len) on the wrapped response object.

setContentLengthLong(long) - Method in interface javax.servlet.ServletResponse

Sets the length of the content body in the response In HTTP servlets, this method sets the HTTP Content-Length header.

setContentLengthLong(long) - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to call setContentLengthLong(long len) on the wrapped response object.

setContentLocation(String) - Method in class javax.xml.soap.AttachmentPart

Sets the MIME header whose name is "Content-Location" with the given value.

setContentLocation(String) - Method in class javax.xml.soap.SOAPPart

Sets the value of the MIME header "Content-Location" to the given String.

setContentMD5(String) - Method in class javax.mail.internet.MimeBodyPart

Set the "Content-MD5" header field of this body part.

setContentMD5(String) - Method in class javax.mail.internet.MimeMessage

Set the "Content-MD5" header field of this Message.

setContentMD5(String) - Method in interface javax.mail.internet.MimePart

Set the Content-MD5 of this part.

setContentType(String) - Method in class javax.faces.application.Resource

Set the MIME content-type for this resource.

setContentType(String) - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.setContentType(String) on the wrapped ResourceHandler object.

setContentType(String) - Method in interface javax.servlet.ServletResponse

Sets the content type of the response being sent to the client, if the response has not been committed yet.

setContentType(String) - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to call setContentType(String type) on the wrapped response object.

setContentType(String) - Method in class javax.xml.soap.AttachmentPart

Sets the MIME header whose name is "Content-Type" with the given value.

setContextID(String) - Static method in class javax.security.jacc.PolicyContext

Authorization protected method used to modify the value of the policy context identifier associated with the thread on which this method is called.

setConverter(Converter) - Method in class javax.faces.component.UIOutput

setConverter(Converter) - Method in interface javax.faces.component.ValueHolder

Set the Converter (if any) that is registered for this UIComponent.

setConverterId(String) - Method in class javax.faces.webapp.ConverterTag

Deprecated.

Set the identifer of the Converter instance to be created.

setConverterMessage(String) - Method in class javax.faces.component.UIInput

Override any ValueExpression set for the "converterMessage" with the literal argument provided to this method.

setCoords(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the coords property.

setCoords(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the coords property.

setCoords(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the coords property.

setCountry(String) - Method in interface javax.xml.registry.infomodel.PostalAddress

Sets the country.

setCountryCode(String) - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Sets country code.

setCredentials(Set) - Method in interface javax.xml.registry.Connection

Sets the Credentials associated with this client.

setCurrencyCode(String) - Method in class javax.faces.convert.NumberConverter

Set the ISO 4217 currency code used by getAsString() with a type of currency.

setCurrencySymbol(String) - Method in class javax.faces.convert.NumberConverter

Set the currency symbol used by getAsString() with a type of currency.

setCurrentInstance(FacesContext) - Static method in class javax.faces.context.FacesContext

Set the FacesContext instance for the request that is being processed by the current thread.

setCurrentPhaseId(PhaseId) - Method in class javax.faces.context.FacesContext

The implementation must call this method at the earliest possble point in time after entering into a new phase in the request processing lifecycle.

setCurrentPhaseId(PhaseId) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.setCurrentPhaseId(PhaseId) on the wrapped FacesContext object.

setDataHandler(DataHandler) - Method in class javax.mail.internet.MimeBodyPart

This method provides the mechanism to set this body part's content.

setDataHandler(DataHandler) - Method in class javax.mail.internet.MimeMessage

This method provides the mechanism to set this part's content.

setDataHandler(DataHandler) - Method in interface javax.mail.Part

This method provides the mechanism to set this part's content.

setDataHandler(DataHandler) - Method in class javax.xml.soap.AttachmentPart

Sets the given DataHandler object as the data handler for this AttachmentPart object.

setDataModel(DataModel) - Method in class javax.faces.component.UIData

Set the internal DataModel.

setDatatypeConverter(DatatypeConverterInterface) - Static method in class javax.xml.bind.DatatypeConverter

This method is for JAXB provider use only.

setDateHeader(String, long) - Method in interface javax.servlet.http.HttpServletResponse

Sets a response header with the given name and date-value.

setDateHeader(String, long) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to call setDateHeader(String name, long date) on the wrapped response object.

setDateStyle(String) - Method in class javax.faces.convert.DateTimeConverter

Set the style to be used to format or parse dates.

setDConfigBeanVersion(DConfigBeanVersionType) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Set the configuration beans to be used to the Java EE platform version specificed.

setDebug(boolean) - Method in class javax.mail.Session

Set the debug setting for this Session.

setDebugOut(PrintStream) - Method in class javax.mail.Session

Set the stream to be used for debugging output for this session.

setDefaultFactory(JspFactory) - Static method in class javax.servlet.jsp.JspFactory

set the default factory for this implementation.

setDefaultLocale(Locale) - Method in class javax.faces.application.Application

Set the default Locale for this application.

setDefaultLocale(Locale) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.setDefaultLocale(java.util.Locale) on the wrapped Application object.

setDefaultMaxBinaryMessageBufferSize(int) - Method in interface javax.websocket.WebSocketContainer

Sets the default maximum size of incoming binary message that this container will buffer.

setDefaultMaxSessionIdleTimeout(long) - Method in interface javax.websocket.WebSocketContainer

Sets the default time in milliseconds after which any web socket sessions in this container will be closed if it has been inactive.

setDefaultMaxTextMessageBufferSize(int) - Method in interface javax.websocket.WebSocketContainer

Sets the maximum size of incoming text message that this container will buffer.

setDefaultRenderKitId(String) - Method in class javax.faces.application.Application

Set the renderKitId to be used to render this application.

setDefaultRenderKitId(String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.setDefaultRenderKitId(String) on the wrapped Application object.

setDelay(String) - Method in class javax.faces.component.behavior.AjaxBehavior

If less than delay milliseconds elapses between calls to request() only the most recent one is sent and all other requests are discarded.

setDeliveryDelay(long) - Method in interface javax.jms.JMSProducer

Sets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.

setDeliveryDelay(long) - Method in interface javax.jms.MessageProducer

Sets the minimum length of time in milliseconds that must elapse after a message is sent before the JMS provider may deliver the message to a consumer.

setDeliveryMode(int) - Method in interface javax.jms.JMSProducer

Specifies the delivery mode of messages that are sent using this JMSProducer

setDeliveryMode(int) - Method in interface javax.jms.MessageProducer

Sets the producer's default delivery mode.

setDescription(String) - Method in class javax.faces.model.SelectItem

Set the description of this item, for use in development tools.

setDescription(String) - Method in class javax.mail.internet.MimeBodyPart

Set the "Content-Description" header field for this body part.

setDescription(String, String) - Method in class javax.mail.internet.MimeBodyPart

Set the "Content-Description" header field for this body part.

setDescription(String) - Method in class javax.mail.internet.MimeMessage

Set the "Content-Description" header field for this Message.

setDescription(String, String) - Method in class javax.mail.internet.MimeMessage

Set the "Content-Description" header field for this Message.

setDescription(String) - Method in interface javax.mail.Part

Set a description String for this part.

setDescription(String) - Method in class javax.resource.spi.work.HintsContext

Set a brief description of the role played by the instance of HintsContext and any other related debugging information.

setDescription(InternationalString) - Method in interface javax.xml.registry.infomodel.RegistryObject

Sets the context independent textual description for this object.

setDetail(String) - Method in class javax.faces.application.FacesMessage

Set the localized detail text.

setDir(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlHead

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlOutputFormat

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlOutputText

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the dir property.

setDir(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the dir property.

setDisable(boolean) - Method in class javax.faces.component.UIParameter

Sets the disable property of the UIParameter.

setDisableClientWindow(boolean) - Method in class javax.faces.component.UIOutcomeTarget

Set whether or not the client window should be encoded into the target url.

setDisabled(boolean) - Method in class javax.faces.component.behavior.AjaxBehavior

Sets the disabled status of this behavior.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the disabled property.

setDisabled(boolean) - Method in class javax.faces.model.SelectItem

Set the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.

setDisabledClass(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the disabledClass property.

setDisabledClass(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the disabledClass property.

setDisabledClass(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the disabledClass property.

setDisabledClass(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the disabledClass property.

setDisabledClass(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the disabledClass property.

setDisabledClass(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the disabledClass property.

setDisableMessageID(boolean) - Method in interface javax.jms.JMSProducer

Specifies whether message IDs may be disabled for messages that are sent using this JMSProducer

setDisableMessageID(boolean) - Method in interface javax.jms.MessageProducer

Specify whether message IDs may be disabled.

setDisableMessageTimestamp(boolean) - Method in interface javax.jms.JMSProducer

Specifies whether message timestamps may be disabled for messages that are sent using this JMSProducer.

setDisableMessageTimestamp(boolean) - Method in interface javax.jms.MessageProducer

Specify whether message timestamps may be disabled.

setDisposition(String) - Method in class javax.mail.internet.ContentDisposition

Set the disposition.

setDisposition(String) - Method in class javax.mail.internet.MimeBodyPart

Set the "Content-Disposition" header field of this body part.

setDisposition(String) - Method in class javax.mail.internet.MimeMessage

Set the "Content-Disposition" header field of this Message.

setDisposition(String) - Method in interface javax.mail.Part

Set the disposition of this part.

setDomain(String) - Method in class javax.servlet.http.Cookie

Specifies the domain within which this cookie should be presented.

setDomain(String) - Method in interface javax.servlet.SessionCookieConfig

Sets the domain name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

setDouble(String, double) - Method in interface javax.jms.MapMessage

Sets a double value with the specified name into the Map.

setDoubleProperty(String, double) - Method in interface javax.jms.Message

Sets a double property value with the specified name into the message.

setDynamicAttribute(String, String, Object) - Method in interface javax.servlet.jsp.tagext.DynamicAttributes

Called when a tag declared to accept dynamic attributes is passed an attribute that is not declared in the Tag Library Descriptor.

setELContext(ELContext) - Method in class javax.el.ELManager

Set the ELContext used for parsing and evaluating EL expressions.

setELContext(ELContext) - Method in class javax.el.LambdaExpression

Set the ELContext to use in evaluating the LambdaExpression.

setElementQName(QName) - Method in interface javax.xml.soap.SOAPElement

Changes the name of this Element to newName if possible.

setEmailAddresses(Collection) - Method in interface javax.xml.registry.infomodel.User

Sets the Collection of EmailAddress instances for this User.

setEnabledClass(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the enabledClass property.

setEnabledClass(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the enabledClass property.

setEnabledClass(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the enabledClass property.

setEnabledClass(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the enabledClass property.

setEnabledClass(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the enabledClass property.

setEnabledClass(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the enabledClass property.

setEncoding(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for setting the output encoding.

setEncodingStyle(String) - Method in interface javax.xml.soap.SOAPElement

Sets the encoding style for this SOAPElement object to one specified.

setEnctype(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the enctype property.

setEndpointContext(EndpointContext) - Method in class javax.xml.ws.Endpoint

By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application.

setEntity(Object) - Method in interface javax.ws.rs.client.ClientRequestContext

Set a new message entity.

setEntity(Object, Annotation[], MediaType) - Method in interface javax.ws.rs.client.ClientRequestContext

Set a new message entity, including the attached annotations and the media type.

setEntity(Object) - Method in interface javax.ws.rs.container.ContainerResponseContext

Set a new message entity.

setEntity(Object, Annotation[], MediaType) - Method in interface javax.ws.rs.container.ContainerResponseContext

Set a new message entity, including the attached annotations and the media type.

setEntity(Object) - Method in interface javax.ws.rs.ext.WriterInterceptorContext

Update object to be written as HTTP entity.

setEntityContext(EntityContext) - Method in interface javax.ejb.EntityBean

Set the associated entity context.

setEntityStream(OutputStream) - Method in interface javax.ws.rs.client.ClientRequestContext

Set a new entity output stream.

setEntityStream(InputStream) - Method in interface javax.ws.rs.client.ClientResponseContext

Set a new entity input stream.

setEntityStream(InputStream) - Method in interface javax.ws.rs.container.ContainerRequestContext

Set a new entity input stream.

setEntityStream(OutputStream) - Method in interface javax.ws.rs.container.ContainerResponseContext

Set a new entity output stream.

setErrorClass(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the errorClass property.

setErrorClass(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the errorClass property.

setErrorCode(String) - Method in exception javax.resource.ResourceException

Set the error code.

setErrorObjectKey(Key) - Method in exception javax.xml.registry.RegistryException

Sets the Key to the first object that encountered an error in the registry.

setErrorStyle(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the errorStyle property.

setErrorStyle(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the errorStyle property.

setEscape(boolean) - Method in class javax.faces.component.html.HtmlOutputFormat

Set the value of the escape property.

setEscape(boolean) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the escape property.

setEscape(boolean) - Method in class javax.faces.component.html.HtmlOutputText

Set the value of the escape property.

setEscape(boolean) - Method in class javax.faces.model.SelectItem

Set the value of the escape property.

setEventHandler(ValidationEventHandler) - Method in class javax.xml.bind.Binder

Allow an application to register a ValidationEventHandler.

setEventHandler(ValidationEventHandler) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setEventHandler(ValidationEventHandler) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Allow an application to register a validation event handler.

setEventHandler(ValidationEventHandler) - Method in interface javax.xml.bind.Marshaller

Allow an application to register a validation event handler.

setEventHandler(ValidationEventHandler) - Method in interface javax.xml.bind.Unmarshaller

Allow an application to register a ValidationEventHandler.

setEventHandler(ValidationEventHandler) - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

setExceptionHandler(ExceptionHandler) - Method in class javax.faces.context.FacesContext

Set the ExceptionHandler for this request.

setExceptionHandler(ExceptionHandler) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.setExceptionHandler(ExceptionHandler) on the wrapped FacesContext object.

setExceptionListener(ExceptionListener) - Method in interface javax.jms.Connection

Sets an exception listener for this connection.

setExceptionListener(ExceptionListener) - Method in interface javax.jms.JMSContext

Sets an exception listener for the JMSContext's connection.

setExecute(Collection<String>) - Method in class javax.faces.component.behavior.AjaxBehavior

Sets the component identifiers that will be used to identify components that should be processed during the execute phase of the request processing lifecycle.

setExecutor(Executor) - Method in class javax.xml.ws.Endpoint

Sets the executor for this Endpoint instance.

setExecutor(Executor) - Method in class javax.xml.ws.Service

Sets the executor for this Service instance.

setExecutor(Executor) - Method in class javax.xml.ws.spi.ServiceDelegate

Sets the executor for this Service instance.

setExitStatus(String) - Method in interface javax.batch.runtime.context.JobContext

The setExitStatus method assigns the user-specified exit status for the current job.

setExitStatus(String) - Method in interface javax.batch.runtime.context.StepContext

The setExitStatus method assigns the user-specified exit status for the current step.

setExpiration(Date) - Method in interface javax.xml.registry.infomodel.RegistryEntry

Sets the expirationDate.

setExpunged(boolean) - Method in class javax.mail.Message

Sets the expunged flag for this Message.

setExtension(String) - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Sets the internal extension.

setExternalIdentifiers(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Replaces all previous external identifiers with specified Collection of ExternalIdentifiers as an external identifier.

setExternalLinks(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject

Replaces all previous ExternalLinks with specified ExternalLinks.

setExternalURI(String) - Method in interface javax.xml.registry.infomodel.ExternalLink

Sets URI for an external resource.

setFactory(String, String) - Static method in class javax.faces.FactoryFinder

This method will store the argument factoryName/implName mapping in such a way that FactoryFinder.getFactory(java.lang.String) will find this mapping when searching for a match.

setFactory(AuthConfigFactory) - Static method in class javax.security.auth.message.config.AuthConfigFactory

Set the system-wide AuthConfigFactory implementation.

setFactorySecurityPermission - Static variable in class javax.security.auth.message.config.AuthConfigFactory

The SecurityPermission, with name AuthConfigFactory.SET_FACTORY_PERMISSION_NAME, that is used to authorize access to the setFactory method.

setFatalClass(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the fatalClass property.

setFatalClass(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the fatalClass property.

setFatalStyle(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the fatalStyle property.

setFatalStyle(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the fatalStyle property.

setFaultActor(String) - Method in interface javax.xml.soap.SOAPFault

Sets this SOAPFault object with the given fault actor.

setFaultCode(Name) - Method in interface javax.xml.soap.SOAPFault

Sets this SOAPFault object with the given fault code.

setFaultCode(QName) - Method in interface javax.xml.soap.SOAPFault

Sets this SOAPFault object with the given fault code.

setFaultCode(String) - Method in interface javax.xml.soap.SOAPFault

Sets this SOAPFault object with the give fault code.

setFaultNode(String) - Method in interface javax.xml.soap.SOAPFault

Creates or replaces any existing Node element value for this SOAPFault object.

setFaultRole(String) - Method in interface javax.xml.soap.SOAPFault

Creates or replaces any existing Role element value for this SOAPFault object.

setFaultString(String) - Method in interface javax.xml.soap.SOAPFault

Sets the fault string for this SOAPFault object to the given string.

setFaultString(String, Locale) - Method in interface javax.xml.soap.SOAPFault

Sets the fault string for this SOAPFault object to the given string and localized to the given locale.

setFileName(String) - Method in class javax.mail.internet.MimeBodyPart

Set the filename associated with this body part, if possible.

setFileName(String) - Method in class javax.mail.internet.MimeMessage

Set the filename associated with this part, if possible.

setFileName(String) - Method in interface javax.mail.Part

Set the filename associated with this part, if possible.

setFirst(int) - Method in class javax.faces.component.UIData

Set the zero-relative row number of the first row to be displayed.

setFirstName(String) - Method in interface javax.xml.registry.infomodel.PersonName

Sets the first name for this Person.

setFirstResult(int) - Method in interface javax.persistence.Query

Set the position of the first result to retrieve.

setFirstResult(int) - Method in interface javax.persistence.TypedQuery

Set the position of the first result to retrieve.

setFlag(Flags.Flag, boolean) - Method in class javax.mail.Message

Set the specified flag on this message to the specified value.

setFlags(Message[], Flags, boolean) - Method in class javax.mail.Folder

Set the specified flags on the messages specified in the array.

setFlags(int, int, Flags, boolean) - Method in class javax.mail.Folder

Set the specified flags on the messages numbered from start through end, both start and end inclusive.

setFlags(int[], Flags, boolean) - Method in class javax.mail.Folder

Set the specified flags on the messages whose message numbers are in the array.

setFlags(Flags, boolean) - Method in class javax.mail.internet.MimeMessage

Set the flags for this message.

setFlags(Flags, boolean) - Method in class javax.mail.Message

Set the specified flags on this message to the specified value.

setFloat(String, float) - Method in interface javax.jms.MapMessage

Sets a float value with the specified name into the Map.

setFloatProperty(String, float) - Method in interface javax.jms.Message

Sets a float property value with the specified name into the message.

setFlowHandler(FlowHandler) - Method in class javax.faces.application.Application

Set the FlowHandler instance used by the NavigationHandler to satisfy the requirements of the faces flows feature.

setFlowHandler(FlowHandler) - Method in class javax.faces.application.ApplicationWrapper

setFlushMode(FlushModeType) - Method in interface javax.persistence.EntityManager

Set the flush mode that applies to all objects contained in the persistence context.

setFlushMode(FlushModeType) - Method in interface javax.persistence.Query

Set the flush mode type to be used for the query execution.

setFlushMode(FlushModeType) - Method in interface javax.persistence.StoredProcedureQuery

Set the flush mode type to be used for the query execution.

setFlushMode(FlushModeType) - Method in interface javax.persistence.TypedQuery

Set the flush mode type to be used for the query execution.

setFooter(UIComponent) - Method in class javax.faces.component.UIColumn

Set the footer facet of the column.

setFooter(UIComponent) - Method in class javax.faces.component.UIData

Set the footer facet of this component.

setFooterClass(String) - Method in class javax.faces.component.html.HtmlColumn

Set the value of the footerClass property.

setFooterClass(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the footerClass property.

setFooterClass(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the footerClass property.

setFor(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the for property.

setFor(String) - Method in class javax.faces.component.UIMessage

Set the identifier of the component for which this component represents associated message(s) (if any).

setFor(String) - Method in class javax.faces.component.UIMessages

Set the client identifier of the component for which this component represents associated message(s) (if any).

setFormattedOutput(boolean) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for setting the formatted output flag.

setFragment(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the fragment property.

setFragment(boolean) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for setting the fragment flag.

setFrame(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the frame property.

setFrame(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the frame property.

setFrom(Address) - Method in class javax.mail.internet.MimeMessage

Set the RFC 822 "From" header field.

setFrom(String) - Method in class javax.mail.internet.MimeMessage

Set the RFC 822 "From" header field.

setFrom() - Method in class javax.mail.internet.MimeMessage

Set the RFC 822 "From" header field using the value of the InternetAddress.getLocalAddress method.

setFrom() - Method in class javax.mail.Message

Set the "From" attribute in this Message.

setFrom(Address) - Method in class javax.mail.Message

Set the "From" attribute in this Message.

setFullName(String) - Method in interface javax.xml.registry.infomodel.PersonName

Sets the fully formatted name for this person.

setFunctionMapper(FunctionMapper) - Method in class javax.faces.view.facelets.FaceletContext

Set the FunctionMapper to use in EL evaluation/creation.

setGenericType(Type) - Method in interface javax.ws.rs.ext.InterceptorContext

Update type of the object to be produced or written.

setGlobalOnly(boolean) - Method in class javax.faces.component.UIMessages

Set the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered.

setGroupingUsed(boolean) - Method in class javax.faces.convert.NumberConverter

Set the flag indicating whether getAsString() should include grouping separators if necessary.

setHandler(HttpHandler) - Method in class javax.xml.ws.spi.http.HttpContext

JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context.

setHandlerChain(QName, List) - Method in interface javax.xml.rpc.handler.HandlerRegistry

Sets the handler chain for the specified service endpoint as a java.util.List.

setHandlerChain(List<Handler>) - Method in interface javax.xml.ws.Binding

Sets the handler chain for the protocol binding instance.

setHandlerClass(Class) - Method in class javax.xml.rpc.handler.HandlerInfo

Sets the Handler class

setHandlerConfig(Map) - Method in class javax.xml.rpc.handler.HandlerInfo

Sets the Handler configuration as java.util.Map

setHandlerData(Object) - Static method in class javax.security.jacc.PolicyContext

Authorization protected method that may be used to associate a thread-scoped handler data object with the PolicyContext.

setHandlerResolver(HandlerResolver) - Method in class javax.xml.ws.Service

Sets the HandlerResolver for this Service instance.

setHandlerResolver(HandlerResolver) - Method in class javax.xml.ws.spi.ServiceDelegate

Sets the HandlerResolver for this Service instance.

setHeader(UIComponent) - Method in class javax.faces.component.UIColumn

Set the header facet of the column.

setHeader(UIComponent) - Method in class javax.faces.component.UIData

Set the header facet of this component.

setHeader(String, String) - Method in class javax.mail.internet.InternetHeaders

Change the first header line that matches name to have value, adding a new header if no existing header matches.

setHeader(String, String) - Method in class javax.mail.internet.MimeBodyPart

Set the value for this header_name.

setHeader(String, String) - Method in class javax.mail.internet.MimeMessage

Set the value for this header_name.

setHeader(String, String) - Method in interface javax.mail.Part

Set the value for this header_name.

setHeader(String, String) - Method in interface javax.servlet.http.HttpServletResponse

Sets a response header with the given name and value.

setHeader(String, String) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to return setHeader(String name, String value) on the wrapped response object.

setHeader(String, String) - Method in class javax.xml.soap.MimeHeaders

Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches.

setHeaderClass(String) - Method in class javax.faces.component.html.HtmlColumn

Set the value of the headerClass property.

setHeaderClass(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the headerClass property.

setHeaderClass(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the headerClass property.

setHeaders(QName[]) - Method in class javax.xml.rpc.handler.HandlerInfo

Sets the header blocks processed by this Handler.

setHeight(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the height property.

setHint(String, Object) - Method in interface javax.persistence.Query

Set a query property or hint.

setHint(String, Object) - Method in interface javax.persistence.StoredProcedureQuery

Set a query property or hint.

setHint(String, Object) - Method in interface javax.persistence.TypedQuery

Set a query property or hint.

setHint(String, Serializable) - Method in class javax.resource.spi.work.HintsContext

Set a Hint and a related value.

setHost(String) - Method in class javax.mail.internet.NewsAddress

Set the host.

setHreflang(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the hreflang property.

setHreflang(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the hreflang property.

setHreflang(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the hreflang property.

setHttpOnly(boolean) - Method in class javax.servlet.http.Cookie

Marks or unmarks this Cookie as HttpOnly.

setHttpOnly(boolean) - Method in interface javax.servlet.SessionCookieConfig

Marks or unmarks the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired as HttpOnly.

setId(String) - Method in class javax.faces.component.UIComponent

Set the component identifier of this UIComponent (if any).

setId(String) - Method in class javax.faces.component.UIComponentBase

setId(String) - Method in class javax.faces.webapp.UIComponentClassicTagBase

Set the component identifier for our component.

setId(String) - Method in class javax.faces.webapp.UIComponentTagBase

Set the component identifier for the component corresponding to this tag instance.

setId(String) - Method in class javax.servlet.jsp.tagext.TagSupport

Set the id attribute for this tag.

setId(String) - Method in interface javax.xml.registry.infomodel.Key

Sets the unique id associated with this key.

setIdentificationScheme(ClassificationScheme) - Method in interface javax.xml.registry.infomodel.ExternalIdentifier

Sets the ClassificationScheme that is used as the identification scheme for identifying this object.

setImage(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the image property.

setImage(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the image property.

setImmediate(boolean) - Method in interface javax.faces.component.ActionSource

Set the "immediate execution" flag for this UIComponent.

setImmediate(boolean) - Method in class javax.faces.component.behavior.AjaxBehavior

Sets the immediate status of this behavior.

setImmediate(boolean) - Method in interface javax.faces.component.EditableValueHolder

Set the "immediate" state for this component.

setImmediate(boolean) - Method in class javax.faces.component.UICommand

setImmediate(boolean) - Method in class javax.faces.component.UIInput

setImmediate(boolean) - Method in class javax.faces.component.UIViewAction

Set the "immediate execution" flag for this UIComponent.

setIncludeViewParams(boolean) - Method in class javax.faces.component.UIOutcomeTarget

Set whether or not the page parameters should be encoded into the target url.

setInfo(Serializable) - Method in class javax.ejb.TimerConfig

Set the info object made available to timer callbacks.

setInfoClass(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the infoClass property.

setInfoClass(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the infoClass property.

setInfoStyle(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the infoStyle property.

setInfoStyle(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the infoStyle property.

setInitParameter(String, String) - Method in interface javax.servlet.Registration

Sets the initialization parameter with the given name and value on the Servlet or Filter that is represented by this Registration.

setInitParameter(String, String) - Method in interface javax.servlet.ServletContext

Sets the context initialization parameter with the given name and value on this ServletContext.

setInitParameters(Map<String, Object>) - Method in class javax.servlet.jsp.jstl.tlv.ScriptFreeTLV

Sets the values of the initialization parameters, as supplied in the TLD.

setInitParameters(Map<String, Object>) - Method in class javax.servlet.jsp.tagext.TagLibraryValidator

Set the init data in the TLD for this validator.

setInitParameters(Map<String, String>) - Method in interface javax.servlet.Registration

Sets the given initialization parameters on the Servlet or Filter that is represented by this Registration.

setInjectionPoint(InjectionPoint) - Method in interface javax.enterprise.inject.spi.ProcessInjectionPoint

Replaces the InjectionPoint.

setInjectionTarget(InjectionTarget<X>) - Method in interface javax.enterprise.inject.spi.ProcessInjectionTarget

Replaces the InjectionTarget which performs injection for this target.

setInputStream(InputStream) - Method in interface javax.ws.rs.ext.ReaderInterceptorContext

Set the input stream of the object to be read.

setInstance(RuntimeDelegate) - Static method in class javax.ws.rs.ext.RuntimeDelegate

Set the runtime delegate that will be used by JAX-RS classes.

setInt(String, int) - Method in interface javax.jms.MapMessage

Sets an int value with the specified name into the Map.

setIntegerOnly(boolean) - Method in class javax.faces.convert.NumberConverter

Set to true if only the integer portion of the given value should be returned from getAsObject().

setIntHeader(String, int) - Method in interface javax.servlet.http.HttpServletResponse

Sets a response header with the given name and integer value.

setIntHeader(String, int) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to call setIntHeader(String name, int value) on the wrapped response object.

setIntProperty(String, int) - Method in interface javax.jms.Message

Sets an int property value with the specified name into the message.

setInvalidPropertyDescriptors(PropertyDescriptor[]) - Method in exception javax.resource.spi.InvalidPropertyException

Set a list of invalid properties.

setInView(boolean) - Method in class javax.faces.component.UIComponent

Updates the status as to whether or not this component is currently within the view hierarchy.

setInView(boolean) - Method in class javax.faces.component.UIViewRoot

Overridden to take no action.

setIsmap(boolean) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the ismap property.

setItemDescription(String) - Method in class javax.faces.component.UISelectItem

Set the description for this selection item.

setItemDisabled(boolean) - Method in class javax.faces.component.UISelectItem

Set the disabled value for this selection item.

setItemEscaped(boolean) - Method in class javax.faces.component.UISelectItem

Set the escape value for the label of this selection item.

setItemLabel(String) - Method in class javax.faces.component.UISelectItem

Set the localized label for this selection item.

setItemValue(Object) - Method in class javax.faces.component.UISelectItem

Set the server value for this selection item.

setJMSCorrelationID(String) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have their JMSCorrelationID header value set to the specified correlation ID, where correlation ID is specified as a String.

setJMSCorrelationID(String) - Method in interface javax.jms.Message

Sets the correlation ID for the message.

setJMSCorrelationIDAsBytes(byte[]) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have their JMSCorrelationID header value set to the specified correlation ID, where correlation ID is specified as an array of bytes.

setJMSCorrelationIDAsBytes(byte[]) - Method in interface javax.jms.Message

Sets the correlation ID as an array of bytes for the message.

setJMSDeliveryMode(int) - Method in interface javax.jms.Message

Sets the DeliveryMode value for this message.

setJMSDeliveryTime(long) - Method in interface javax.jms.Message

Sets the message's delivery time value.

setJMSDestination(Destination) - Method in interface javax.jms.Message

Sets the Destination object for this message.

setJMSExpiration(long) - Method in interface javax.jms.Message

Sets the message's expiration value.

setJMSMessageID(String) - Method in interface javax.jms.Message

Sets the message ID.

setJMSPriority(int) - Method in interface javax.jms.Message

Sets the priority level for this message.

setJMSRedelivered(boolean) - Method in interface javax.jms.Message

Specifies whether this message is being redelivered.

setJMSReplyTo(Destination) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have their JMSReplyTo header value set to the specified Destination object.

setJMSReplyTo(Destination) - Method in interface javax.jms.Message

Sets the Destination object to which a reply to this message should be sent.

setJMSTimestamp(long) - Method in interface javax.jms.Message

Sets the message timestamp.

setJMSType(String) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have their JMSType header value set to the specified message type.

setJMSType(String) - Method in interface javax.jms.Message

Sets the message type.

SetJoin<Z,E> - Interface in javax.persistence.criteria

The SetJoin interface is the type of the result of joining to a collection over an association or element collection that has been specified as a java.util.Set.

setJspBody(JspFragment) - Method in interface javax.servlet.jsp.tagext.SimpleTag

Provides the body of this tag as a JspFragment object, able to be invoked zero or more times by the tag handler.

setJspBody(JspFragment) - Method in class javax.servlet.jsp.tagext.SimpleTagSupport

Stores the provided JspFragment.

setJspContext(JspContext) - Method in interface javax.servlet.jsp.tagext.SimpleTag

Called by the container to provide this tag handler with the JspContext for this invocation.

setJspContext(JspContext) - Method in class javax.servlet.jsp.tagext.SimpleTagSupport

Stores the provided JSP context in the private jspContext field.

setJspId(String) - Method in class javax.faces.webapp.UIComponentClassicTagBase

Defined on JspIdConsumer.

setJspId(String) - Method in interface javax.servlet.jsp.tagext.JspIdConsumer

Called by the container generated code to set a value for the jspId attribute.

setKeepMessages(boolean) - Method in class javax.faces.context.Flash

Setter for keepMessages JavaBeans property.

setKeepMessages(boolean) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Flash.setKeepMessages(boolean) on the wrapped Flash object.

setKey(PrivateKey, Certificate[]) - Method in class javax.security.auth.message.callback.PrivateKeyCallback

Used by the CallbackHandler to set the requested private key and the corresponding certificate chain within the Callback.

setKey(SecretKey) - Method in class javax.security.auth.message.callback.SecretKeyCallback

Used by the CallbackHandler to set the requested secret key within the Callback.

setKey(Key) - Method in interface javax.xml.registry.infomodel.RegistryObject

Sets the key representing the universally unique ID (UUID) for this object.

setLabel(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the label property.

setLabel(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the label property.

setLabel(String) - Method in class javax.faces.model.SelectItem

Set the label of this item, to be rendered visibly for the user.

setLang(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlHead

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlOutputFormat

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlOutputText

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the lang property.

setLang(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the lang property.

setLastName(String) - Method in interface javax.xml.registry.infomodel.PersonName

Sets the last name (surname) for this Person.

setLayout(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the layout property.

setLayout(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the layout property.

setLayout(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the layout property.

setLayout(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the layout property.

setLibraryName(String) - Method in class javax.faces.application.Resource

Set the libraryName for this resource.

setLibraryName(String) - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.setLibraryName(String) on the wrapped ResourceHandler object.

setLineNumber(int) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the lineNumber field on this event locator.

setLinkedException(Exception) - Method in exception javax.jms.JMSException

Adds a linked Exception.

setLinkedException(Exception) - Method in exception javax.resource.ResourceException

Deprecated.
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

setLinkedException(Throwable) - Method in class javax.xml.bind.helpers.ValidationEventImpl

Set the linked exception field of this event.

setLinkedException(Throwable) - Method in exception javax.xml.bind.JAXBException

Add a linked Exception.

setLinkedException(Throwable) - Method in exception javax.xml.bind.TypeConstraintException

Add a linked Exception.

setLinkedWarning(ResourceWarning) - Method in exception javax.resource.cci.ResourceWarning

Deprecated.
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

setListener(Marshaller.Listener) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setListener(Unmarshaller.Listener) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

setListener(Marshaller.Listener) - Method in interface javax.xml.bind.Marshaller

Register marshal event callback Marshaller.Listener with this Marshaller.

setListener(Unmarshaller.Listener) - Method in interface javax.xml.bind.Unmarshaller

Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

setLoadOnStartup(int) - Method in interface javax.servlet.ServletRegistration.Dynamic

Sets the loadOnStartup priority on the Servlet represented by this dynamic ServletRegistration.

setLocale(Locale) - Method in class javax.el.ELContext

Sets the Locale for this instance.

setLocale(Locale) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Set the active locale for this implementation of javax.enterprise.deploy.spi subpackages to run.

setLocale(Locale) - Method in class javax.faces.component.UIViewRoot

Set the Locale to be used in localizing the response being created for this view.

setLocale(Locale) - Method in class javax.faces.convert.DateTimeConverter

Set the Locale to be used when parsing or formatting dates and times.

setLocale(Locale) - Method in class javax.faces.convert.NumberConverter

Set the Locale to be used when parsing numbers.

setLocale(Locale) - Method in interface javax.servlet.ServletResponse

Sets the locale of the response, if the response has not been committed yet.

setLocale(Locale) - Method in class javax.servlet.ServletResponseWrapper

The default behavior of this method is to call setLocale(Locale loc) on the wrapped response object.

setLocale(Locale) - Method in interface javax.xml.registry.infomodel.LocalizedString

Set the Locale for this object.

setLocalValueSet(boolean) - Method in interface javax.faces.component.EditableValueHolder

Sets the "local value set" state for this component.

setLocalValueSet(boolean) - Method in class javax.faces.component.UIInput

Sets the "local value set" state for this component.

setLocator(ValidationEventLocator) - Method in class javax.xml.bind.helpers.ValidationEventImpl

Set the locator object for this event.

setLockMode(LockModeType) - Method in interface javax.persistence.Query

Set the lock mode type to be used for the query execution.

setLockMode(LockModeType) - Method in interface javax.persistence.TypedQuery

Set the lock mode type to be used for the query execution.

setLogWriter(PrintWriter) - Method in interface javax.resource.spi.ManagedConnection

Sets the log writer for this ManagedConnection instance.

setLogWriter(PrintWriter) - Method in interface javax.resource.spi.ManagedConnectionFactory

Set the log writer for this ManagedConnectionFactory instance.

setLong(String, long) - Method in interface javax.jms.MapMessage

Sets a long value with the specified name into the Map.

setLongdesc(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the longdesc property.

setLongProperty(String, long) - Method in interface javax.jms.Message

Sets a long property value with the specified name into the message.

setMajorVersion(int) - Method in interface javax.xml.registry.infomodel.Versionable

Sets the major revision number for this version of the Versionable object.

setManagedConnectionFactory(ManagedConnectionFactory) - Method in class javax.resource.spi.security.PasswordCredential

Sets the target ManagedConenctionFactory instance for which the user name and password has been set by the application server.

setMaxAge(int) - Method in class javax.servlet.http.Cookie

Sets the maximum age in seconds for this Cookie.

setMaxAge(int) - Method in interface javax.servlet.SessionCookieConfig

Sets the lifetime (in seconds) for the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

setMaxAge(int) - Method in class javax.ws.rs.core.CacheControl

Corresponds to the max-age cache control directive.

setMaxBinaryMessageBufferSize(int) - Method in interface javax.websocket.Session

Sets the maximum length of incoming binary messages that this Session can buffer.

setMaxFractionDigits(int) - Method in class javax.faces.convert.NumberConverter

Set the maximum number of digits getAsString() should render in the fraction portion of the result.

setMaxIdleTimeout(long) - Method in interface javax.websocket.Session

Set the non-zero number of milliseconds before this session will be closed by the container if it is inactive, ie no messages are either sent or received.

setMaximum(double) - Method in class javax.faces.validator.DoubleRangeValidator

Set the maximum value to be enforced by this Validator.

setMaximum(int) - Method in class javax.faces.validator.LengthValidator

Set the maximum length to be enforced by this Validator.

setMaximum(long) - Method in class javax.faces.validator.LongRangeValidator

Set the maximum value to be enforced by this Validator.

setMaxInactiveInterval(int) - Method in interface javax.servlet.http.HttpSession

Specifies the time, in seconds, between client requests before the servlet container will invalidate this session.

setMaxIntegerDigits(int) - Method in class javax.faces.convert.NumberConverter

Set the maximum number of digits getAsString() should render in the integer portion of the result.

setMaxlength(int) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the maxlength property.

setMaxlength(int) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the maxlength property.

setMaxlength(int) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the maxlength property.

setMaxResults(int) - Method in interface javax.persistence.Query

Set the maximum number of results to retrieve.

setMaxResults(int) - Method in interface javax.persistence.TypedQuery

Set the maximum number of results to retrieve.

setMaxTextMessageBufferSize(int) - Method in interface javax.websocket.Session

Sets the maximum length of incoming text messages that this Session can buffer.

setMediaType(MediaType) - Method in interface javax.ws.rs.ext.InterceptorContext

Update media type of HTTP entity.

setMemberFactories(FaceletCache.MemberFactory<V>, FaceletCache.MemberFactory<V>) - Method in class javax.faces.view.facelets.FaceletCache

This must be called by the runtime at startup time, before any requests are serviced, and allows for the FaceletCache implementation to provide the FaceletCache.MemberFactory instances that will be used to create instances of Facelets and View Metadata Facelets.

setMessage(String) - Method in class javax.xml.bind.helpers.ValidationEventImpl

Set the message field of this event.

setMessage(SOAPMessage) - Method in interface javax.xml.rpc.handler.soap.SOAPMessageContext

Sets the SOAPMessage in this message context

setMessage(SOAPMessage) - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Sets the SOAPMessage in this message context

setMessageBundle(String) - Method in class javax.faces.application.Application

Set the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application.

setMessageBundle(String) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.setMessageBundle(String) on the wrapped Application object.

setMessageDrivenContext(MessageDrivenContext) - Method in interface javax.ejb.MessageDrivenBean

Set the associated message-driven context.

setMessageListener(MessageListener) - Method in interface javax.jms.JMSConsumer

Sets the JMSConsumer's MessageListener.

setMessageListener(MessageListener) - Method in interface javax.jms.MessageConsumer

Sets the MessageConsumer's MessageListener.

setMessageListener(MessageListener) - Method in interface javax.jms.Session

Sets the session's distinguished message listener (optional).

setMessageNumber(int) - Method in class javax.mail.Message

Set the Message number for this Message.

setMetadata(List<Source>) - Method in class javax.xml.ws.Endpoint

Sets the metadata for this endpoint.

setMethod(String) - Method in interface javax.ws.rs.client.ClientRequestContext

Set the request method.

setMethod(String) - Method in interface javax.ws.rs.container.ContainerRequestContext

Set the request method.

setMiddleName(String) - Method in interface javax.xml.registry.infomodel.PersonName

Sets the middle name for this Person.

setMimeHeader(String, String) - Method in class javax.xml.soap.AttachmentPart

Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches.

setMimeHeader(String, String) - Method in class javax.xml.soap.SOAPPart

Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match.

setMimeType(String) - Method in interface javax.xml.registry.infomodel.ExtrinsicObject

Sets the mime type associated with this object.

setMinFractionDigits(int) - Method in class javax.faces.convert.NumberConverter

Set the minimum number of digits getAsString() should render in the fraction portion of the result.

setMinimum(double) - Method in class javax.faces.validator.DoubleRangeValidator

Set the minimum value to be enforced by this Validator.

setMinimum(int) - Method in class javax.faces.validator.LengthValidator

Set the minimum length to be enforced by this Validator.

setMinimum(long) - Method in class javax.faces.validator.LongRangeValidator

Set the minimum value to be enforced by this Validator.

setMinIntegerDigits(int) - Method in class javax.faces.convert.NumberConverter

Set the minimum number of digits getAsString() should render in the integer portion of the result.

setMinorVersion(int) - Method in interface javax.xml.registry.infomodel.Versionable

Sets the minor revision number for this version of the Versionable object.

setMTOMEnabled(boolean) - Method in interface javax.xml.ws.soap.SOAPBinding

Enables or disables use of MTOM.

setMultipartConfig(MultipartConfigElement) - Method in interface javax.servlet.ServletRegistration.Dynamic

Sets the MultipartConfigElement to be applied to the mappings defined for this ServletRegistration.

setMultipartDataSource(MultipartDataSource) - Method in class javax.mail.Multipart

Setup this Multipart object from the given MultipartDataSource.

setMustRevalidate(boolean) - Method in class javax.ws.rs.core.CacheControl

Corresponds to the must-revalidate cache control directive.

setMustUnderstand(boolean) - Method in interface javax.xml.soap.SOAPHeaderElement

Sets the mustUnderstand attribute for this SOAPHeaderElement object to be either true or false.

setName(String) - Method in class javax.faces.component.UIParameter

Set the optional parameter name for this parameter.

setName(String) - Method in class javax.faces.component.UIViewParameter

Set the request parameter name from which the value is retrieved.

setName(String) - Method in class javax.faces.webapp.AttributeTag

Deprecated.

Set the attribute name.

setName(String) - Method in class javax.faces.webapp.FacetTag

Set the name to be assigned to this facet.

setName(String) - Method in class javax.mail.util.ByteArrayDataSource

Set the name of the data.

setName(String) - Method in class javax.resource.spi.work.HintsContext

Set the associated name of the HintsContext.

setName(String) - Method in interface javax.servlet.SessionCookieConfig

Sets the name that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

setName(InternationalString) - Method in interface javax.xml.registry.infomodel.RegistryObject

Sets user-friendly name of object in repository.

setName(String) - Method in interface javax.xml.registry.infomodel.Slot

Sets the name for this Slot.

setNavigationHandler(NavigationHandler) - Method in class javax.faces.application.Application

Set the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.

setNavigationHandler(NavigationHandler) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.setNavigationHandler(NavigationHandler) on the wrapped Application object.

setNewsgroup(String) - Method in class javax.mail.internet.NewsAddress

Set the newsgroup.

setNextException(Exception) - Method in exception javax.mail.MessagingException

Add an exception to the end of the chain.

setNil(boolean) - Method in class javax.xml.bind.JAXBElement

Set whether this element has nil content.

setNoCache(boolean) - Method in class javax.ws.rs.core.CacheControl

Corresponds to the no-cache cache control directive.

setNode(Node) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the Node field on this event locator.

setNoNSSchemaLocation(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for setting the noNamespaceSchemaLocation.

setNoSelectionOption(boolean) - Method in class javax.faces.component.UISelectItem

Set the value of the noSelectionOption property.

setNoSelectionOption(boolean) - Method in class javax.faces.model.SelectItem

Set the value of the noSelectionOption property.

setNoStore(boolean) - Method in class javax.ws.rs.core.CacheControl

Corresponds to the no-store cache control directive.

setNoTransform(boolean) - Method in class javax.ws.rs.core.CacheControl

Corresponds to the no-transform cache control directive.

setNumber(String) - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Sets the telephone number suffix, not including the country or area code.

setNumberFormat(NumberFormat) - Method in class javax.mail.internet.MailDateFormat

Don't allow setting the NumberFormat

setObject(String, Object) - Method in interface javax.jms.MapMessage

Sets an object value with the specified name into the Map.

setObject(Serializable) - Method in interface javax.jms.ObjectMessage

Sets the serializable object containing this message's data.

setObject(Object) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the Object field on this event locator.

setObjectProperty(String, Object) - Method in interface javax.jms.Message

Sets a Java object property value with the specified name into the message.

setOffset(int) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the offset field on this event locator.

setOnblur(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onblur property.

setOnblur(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onblur property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onchange property.

setOnchange(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onchange property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onclick property.

setOnclick(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the ondblclick property.

setOndblclick(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the ondblclick property.

setOnerror(String) - Method in class javax.faces.component.behavior.AjaxBehavior

Sets the JavaScript function name that will be used to identify the client callback function that should be run in the event of an error.

setOnevent(String) - Method in class javax.faces.component.behavior.AjaxBehavior

Sets the JavaScript function name that will be used to identify the client callback function that should be run in response to event activity.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onfocus property.

setOnfocus(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onfocus property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onkeydown property.

setOnkeydown(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onkeydown property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onkeypress property.

setOnkeypress(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onkeypress property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onkeyup property.

setOnkeyup(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onkeyup property.

setOnload(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onload property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onmousedown property.

setOnmousedown(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onmousedown property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onmousemove property.

setOnmousemove(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onmousemove property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onmouseout property.

setOnmouseout(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onmouseout property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onmouseover property.

setOnmouseover(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onmouseover property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onmouseup property.

setOnmouseup(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onmouseup property.

setOnPostback(boolean) - Method in class javax.faces.component.UIViewAction

Controls whether or not this component operates on postback.

setOnreset(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onreset property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the onselect property.

setOnselect(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the onselect property.

setOnsubmit(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the onsubmit property.

setOnunload(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the onunload property.

setOpaque(boolean) - Method in interface javax.xml.registry.infomodel.ExtrinsicObject

Sets whether the ExtrinsicObject is opaque (not readable) by the registry.

setOperationName(QName) - Method in interface javax.xml.rpc.Call

Sets the name of the operation to be invoked using this Call instance.

setOutcome(String) - Method in class javax.faces.component.UIOutcomeTarget

Sets the outcome property of the UIOutcomeTarget.

setOutputStream(OutputStream) - Method in interface javax.ws.rs.ext.WriterInterceptorContext

Set a new output stream for the object to be written.

setPageContext(PageContext) - Method in class javax.faces.webapp.UIComponentClassicTagBase

Set the PageContext of the page containing this tag instance.

setPageContext(PageContext) - Method in interface javax.servlet.jsp.tagext.Tag

Set the current page context.

setPageContext(PageContext) - Method in class javax.servlet.jsp.tagext.TagAdapter

Must not be called.

setPageContext(PageContext) - Method in class javax.servlet.jsp.tagext.TagSupport

Set the page context.

setParameter(String, String) - Method in class javax.mail.internet.ContentDisposition

Set the specified parameter.

setParameter(String, String) - Method in class javax.mail.internet.ContentType

Set the specified parameter.

setParameter(Parameter<T>, T) - Method in interface javax.persistence.Query

Bind the value of a Parameter object.

setParameter(Parameter<Calendar>, Calendar, TemporalType) - Method in interface javax.persistence.Query

Bind an instance of java.util.Calendar to a Parameter object.

setParameter(Parameter<Date>, Date, TemporalType) - Method in interface javax.persistence.Query

Bind an instance of java.util.Date to a Parameter object.

setParameter(String, Object) - Method in interface javax.persistence.Query

Bind an argument value to a named parameter.

setParameter(String, Calendar, TemporalType) - Method in interface javax.persistence.Query

Bind an instance of java.util.Calendar to a named parameter.

setParameter(String, Date, TemporalType) - Method in interface javax.persistence.Query

Bind an instance of java.util.Date to a named parameter.

setParameter(int, Object) - Method in interface javax.persistence.Query

Bind an argument value to a positional parameter.

setParameter(int, Calendar, TemporalType) - Method in interface javax.persistence.Query

Bind an instance of java.util.Calendar to a positional parameter.

setParameter(int, Date, TemporalType) - Method in interface javax.persistence.Query

Bind an instance of java.util.Date to a positional parameter.

setParameter(Parameter<T>, T) - Method in interface javax.persistence.StoredProcedureQuery

Bind the value of a Parameter object.

setParameter(Parameter<Calendar>, Calendar, TemporalType) - Method in interface javax.persistence.StoredProcedureQuery

Bind an instance of java.util.Calendar to a Parameter object.

setParameter(Parameter<Date>, Date, TemporalType) - Method in interface javax.persistence.StoredProcedureQuery

Bind an instance of java.util.Date to a Parameter object.

setParameter(String, Object) - Method in interface javax.persistence.StoredProcedureQuery

Bind an argument value to a named parameter.

setParameter(String, Calendar, TemporalType) - Method in interface javax.persistence.StoredProcedureQuery

Bind an instance of java.util.Calendar to a named parameter.

setParameter(String, Date, TemporalType) - Method in interface javax.persistence.StoredProcedureQuery

Bind an instance of java.util.Date to a named parameter.

setParameter(int, Object) - Method in interface javax.persistence.StoredProcedureQuery

Bind an argument value to a positional parameter.

setParameter(int, Calendar, TemporalType) - Method in interface javax.persistence.StoredProcedureQuery

Bind an instance of java.util.Calendar to a positional parameter.

setParameter(int, Date, TemporalType) - Method in interface javax.persistence.StoredProcedureQuery

Bind an instance of java.util.Date to a positional parameter.

setParameter(Parameter<T>, T) - Method in interface javax.persistence.TypedQuery

Bind the value of a Parameter object.

setParameter(Parameter<Calendar>, Calendar, TemporalType) - Method in interface javax.persistence.TypedQuery

Bind an instance of java.util.Calendar to a Parameter object.

setParameter(Parameter<Date>, Date, TemporalType) - Method in interface javax.persistence.TypedQuery

Bind an instance of java.util.Date to a Parameter object.

setParameter(String, Object) - Method in interface javax.persistence.TypedQuery

Bind an argument value to a named parameter.

setParameter(String, Calendar, TemporalType) - Method in interface javax.persistence.TypedQuery

Bind an instance of java.util.Calendar to a named parameter.

setParameter(String, Date, TemporalType) - Method in interface javax.persistence.TypedQuery

Bind an instance of java.util.Date to a named parameter.

setParameter(int, Object) - Method in interface javax.persistence.TypedQuery

Bind an argument value to a positional parameter.

setParameter(int, Calendar, TemporalType) - Method in interface javax.persistence.TypedQuery

Bind an instance of java.util.Calendar to a positional parameter.

setParameter(int, Date, TemporalType) - Method in interface javax.persistence.TypedQuery

Bind an instance of java.util.Date to a positional parameter.

setParameterList(ParameterList) - Method in class javax.mail.internet.ContentDisposition

Set a new ParameterList.

setParameterList(ParameterList) - Method in class javax.mail.internet.ContentType

Set a new ParameterList.

setParameters(Object[]) - Method in interface javax.interceptor.InvocationContext

Sets the parameter values that will be passed to the method or constructor of the target class.

setParent(UIComponent) - Method in class javax.faces.component.UIComponent

Set the parent UIComponent of this UIComponent.

setParent(UIComponent) - Method in class javax.faces.component.UIComponentBase

setParent(Tag) - Method in class javax.faces.webapp.UIComponentClassicTagBase

Set the Tag that is the parent of this instance.

setParent(Part) - Method in class javax.mail.Multipart

Set the parent of this Multipart to be the specified Part.

setParent(JspTag) - Method in interface javax.servlet.jsp.tagext.SimpleTag

Sets the parent of this tag, for collaboration purposes.

setParent(JspTag) - Method in class javax.servlet.jsp.tagext.SimpleTagSupport

Sets the parent of this tag, for collaboration purposes.

setParent(Tag) - Method in interface javax.servlet.jsp.tagext.Tag

Set the parent (closest enclosing tag handler) of this tag handler.

setParent(Tag) - Method in class javax.servlet.jsp.tagext.TagAdapter

Must not be called.

setParent(Tag) - Method in class javax.servlet.jsp.tagext.TagSupport

Set the nesting tag of this tag.

setParentElement(SOAPElement) - Method in interface javax.xml.soap.Node

Sets the parent of this Node object to the given SOAPElement object.

setPartialRequest(boolean) - Method in class javax.faces.context.PartialViewContext

Dynamically indicate that this is a partial request.

setPartialRequest(boolean) - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.setPartialRequest(boolean) on the wrapped PartialViewContext object.

setPartitionProperties(Properties[]) - Method in interface javax.batch.api.partition.PartitionPlan

Sets array of substitution Properties objects for the set of Partitions.

setPartitionProperties(Properties[]) - Method in class javax.batch.api.partition.PartitionPlanImpl

setPartitions(int) - Method in interface javax.batch.api.partition.PartitionPlan

Set number of partitions.

setPartitions(int) - Method in class javax.batch.api.partition.PartitionPlanImpl

setPartitionsOverride(boolean) - Method in interface javax.batch.api.partition.PartitionPlan

Specify whether or not to override the partition count from the previous job execution.

setPartitionsOverride(boolean) - Method in class javax.batch.api.partition.PartitionPlanImpl

setPasswordAuthentication(URLName, PasswordAuthentication) - Method in class javax.mail.Session

Save a PasswordAuthentication for this (store or transport) URLName.

setPath(String) - Method in class javax.servlet.http.Cookie

Specifies a path for the cookie to which the client should return the cookie.

setPath(String) - Method in interface javax.servlet.SessionCookieConfig

Sets the path that will be assigned to any session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired.

setPattern(String) - Method in class javax.faces.convert.DateTimeConverter

Set the format pattern to be used when formatting and parsing dates and times.

setPattern(String) - Method in class javax.faces.convert.NumberConverter

Set the format pattern to be used when formatting and parsing numbers.

setPattern(String) - Method in class javax.faces.validator.RegexValidator

The Regular Expression property to validate against.

setPayload(Source) - Method in interface javax.xml.ws.LogicalMessage

Sets the message payload

setPayload(Object, JAXBContext) - Method in interface javax.xml.ws.LogicalMessage

Sets the message payload

setPersistenceProviderResolver(PersistenceProviderResolver) - Static method in class javax.persistence.spi.PersistenceProviderResolverHolder

Defines the persistence provider resolver used.

setPersistent(boolean) - Method in class javax.ejb.TimerConfig

Specify whether the timer is persistent.

setPersistentUserData(Serializable) - Method in interface javax.batch.runtime.context.StepContext

The setPersistentUserData method stores a persistent data object into the current step.

setPersonal(String, String) - Method in class javax.mail.internet.InternetAddress

Set the personal name.

setPersonal(String) - Method in class javax.mail.internet.InternetAddress

Set the personal name.

setPersonName(PersonName) - Method in interface javax.xml.registry.infomodel.User

Sets the name of this User.

setPhase(String) - Method in class javax.faces.component.UIViewAction

Attempt to set the lifecycle phase in which this instance will queue its ActionEvent.

setPhaseId(PhaseId) - Method in class javax.faces.event.FacesEvent

Set the PhaseId during which this event will be delivered.

setPortTypeName(QName) - Method in interface javax.xml.rpc.Call

Sets the qualified name of the port type.

setPostalAddress(PostalAddress) - Method in interface javax.xml.registry.infomodel.Organization

Sets the address for this Organization.

setPostalAddresses(Collection) - Method in interface javax.xml.registry.infomodel.User

Sets the addresses for this User.

setPostalCode(String) - Method in interface javax.xml.registry.infomodel.PostalAddress

Sets the postal or zip code.

setPostalScheme(ClassificationScheme) - Method in interface javax.xml.registry.infomodel.PostalAddress

Sets a user-defined postal scheme for codifying the attributes of PostalAddress.

setPreamble(String) - Method in class javax.mail.internet.MimeMultipart

Set the preamble text to be included before the first body part.

setPrependId(boolean) - Method in class javax.faces.component.UIForm

setPrimaryContact(User) - Method in interface javax.xml.registry.infomodel.Organization

Sets the primary contact for this Organization.

setPrimaryType(String) - Method in class javax.mail.internet.ContentType

Set the primary type.

setPriority(int) - Method in interface javax.jms.JMSProducer

Specifies the priority of messages that are sent using this JMSProducer

setPriority(int) - Method in interface javax.jms.MessageProducer

Sets the producer's default priority.

setPrivate(boolean) - Method in class javax.ws.rs.core.CacheControl

Corresponds to the private cache control directive.

setProcessingEvents(boolean) - Method in class javax.faces.context.FacesContext

Allows control of wheter or not the runtime will publish events when Application.publishEvent(FacesContext, Class, Object) or Application.publishEvent(FacesContext, Class, Class, Object) is called.

setProcessingEvents(boolean) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.setProcessingEvents(boolean) on the wrapped FacesContext object.

setProducer(Producer<X>) - Method in interface javax.enterprise.inject.spi.ProcessProducer

Replaces the Producer object that will be used by the container to call the producer method or read the producer field.

setProperties(UIComponent) - Method in class javax.faces.webapp.UIComponentClassicTagBase

Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set.

setProperties(UIComponent) - Method in class javax.faces.webapp.UIComponentELTag

Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set.

setProperties(UIComponent) - Method in class javax.faces.webapp.UIComponentTag

Deprecated.

setProperties(Properties) - Method in class javax.xml.registry.ConnectionFactory

Sets the Properties used during createConnection and createFederatedConnection calls.

setProperties(Map<String, Object>) - Method in class javax.xml.ws.Endpoint

Sets the property bag for this Endpoint instance.

setProperty(String, boolean) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have the specified property set to the specified boolean value.

setProperty(String, byte) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have the specified property set to the specified byte value.

setProperty(String, short) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have the specified property set to the specified short value.

setProperty(String, int) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have the specified property set to the specified int value.

setProperty(String, long) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have the specified property set to the specified long value.

setProperty(String, float) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have the specified property set to the specified float value.

setProperty(String, double) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have the specified property set to the specified double value.

setProperty(String, String) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have the specified property set to the specified String value.

setProperty(String, Object) - Method in interface javax.jms.JMSProducer

Specifies that messages sent using this JMSProducer will have the specified property set to the specified Java object value.

setProperty(String, Object) - Method in interface javax.persistence.EntityManager

Set an entity manager property or hint.

setProperty(String, Object) - Method in interface javax.ws.rs.client.ClientRequestContext

Binds an object to a given property name in the current request/response exchange context.

setProperty(String, Object) - Method in interface javax.ws.rs.container.ContainerRequestContext

Binds an object to a given property name in the current request/response exchange context.

setProperty(String, Object) - Method in interface javax.ws.rs.ext.InterceptorContext

Binds an object to a given property name in the current request/response exchange context.

setProperty(String, Object) - Method in class javax.xml.bind.Binder

Set the particular property in the underlying implementation of Binder.

setProperty(String, Object) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Default implementation of the setProperty method handles the four defined properties in Marshaller.

setProperty(String, Object) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Default implementation of the setProperty method always throws PropertyException since there are no required properties.

setProperty(String, Object) - Method in interface javax.xml.bind.Marshaller

Set the particular property in the underlying implementation of Marshaller.

setProperty(String, Object) - Method in interface javax.xml.bind.Unmarshaller

Set the particular property in the underlying implementation of Unmarshaller.

setProperty(String, Object) - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

setProperty(String, Object) - Method in interface javax.xml.rpc.Call

Sets the value for a named property.

setProperty(String, Object) - Method in interface javax.xml.rpc.handler.MessageContext

Sets the name and value of a property associated with the MessageContext.

setProperty(String, Object) - Method in class javax.xml.soap.SOAPMessage

Associates the specified value with the specified property.

setPropertyResolved(boolean) - Method in class javax.el.ELContext

Called to indicate that a ELResolver has successfully resolved a given (base, property) pair.

setPropertyResolved(Object, Object) - Method in class javax.el.ELContext

Called to indicate that a ELResolver has successfully resolved a given (base, property) pair and to notify the EvaluationListeners.

setPropertyResolver(PropertyResolver) - Method in class javax.faces.application.Application

Deprecated.
The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called Application.addELResolver(javax.el.ELResolver).

setPropertyResolver(PropertyResolver) - Method in class javax.faces.application.ApplicationWrapper

Deprecated.
See superclass for alternative.

setProtocolForAddress(String, String) - Method in class javax.mail.Session

Set the default transport protocol to use for addresses of the specified type.

setProvider(Provider) - Method in class javax.mail.Session

Set the passed Provider to be the default implementation for the protocol in Provider.protocol overriding any previous values.

setProvidingOrganization(Organization) - Method in interface javax.xml.registry.infomodel.Service

Sets the Organization that provides this service.

setProxyRevalidate(boolean) - Method in class javax.ws.rs.core.CacheControl

Corresponds to the must-revalidate cache control directive.

setPublic(String) - Method in class javax.faces.component.html.HtmlDoctype

Set the value of the public property.

setQuota(Quota) - Method in interface javax.mail.QuotaAwareStore

Set the quotas for the quota root specified in the quota argument.

setRawContent(InputStream, String) - Method in class javax.xml.soap.AttachmentPart

Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.

setRawContentBytes(byte[], int, int, String) - Method in class javax.xml.soap.AttachmentPart

Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.

setReadListener(ReadListener) - Method in class javax.servlet.ServletInputStream

Instructs the ServletInputStream to invoke the provided ReadListener when it is possible to read

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the readonly property.

setReadonly(boolean) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the readonly property.

setRecipient(Message.RecipientType, Address) - Method in class javax.mail.Message

Set the recipient address.

setRecipients(Message.RecipientType, Address[]) - Method in class javax.mail.internet.MimeMessage

Set the specified recipient type to the given addresses.

setRecipients(Message.RecipientType, String) - Method in class javax.mail.internet.MimeMessage

Set the specified recipient type to the given addresses.

setRecipients(Message.RecipientType, Address[]) - Method in class javax.mail.Message

Set the recipient addresses.

setRecordName(String) - Method in interface javax.resource.cci.Record

Sets the name of the Record.

setRecordShortDescription(String) - Method in interface javax.resource.cci.Record

Sets a short description string for the Record.

setRedirect(boolean) - Method in class javax.faces.context.Flash

Setting this property to true indicates that the next request on this session will be a redirect.

setRedirect(boolean) - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Flash.setRedirect(boolean) on the wrapped Flash object.

setRedisplay(boolean) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the redisplay property.

setRedisplay(boolean) - Method in class javax.faces.component.UIMessage

Set the flag indicating whether the detail property of the associated message(s) should be displayed.

setRedisplay(boolean) - Method in class javax.faces.component.UIMessages

Set the flag indicating whether the detail property of the associated message(s) should be displayed.

setReference(Reference) - Method in interface javax.resource.Referenceable

Sets the Reference instance.

setRel(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the rel property.

setRel(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the rel property.

setRel(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the rel property.

setRelay(boolean) - Method in interface javax.xml.soap.SOAPHeaderElement

Sets the relay attribute for this SOAPHeaderElement to be either true or false.

setRender(Collection<String>) - Method in class javax.faces.component.behavior.AjaxBehavior

Sets the component identifiers that will be used to identify components that should be processed during the render phase of the request processing lifecycle.

setRenderAll(boolean) - Method in class javax.faces.context.PartialViewContext

Indicate the entire view must be rendered if renderAll is true.

setRenderAll(boolean) - Method in class javax.faces.context.PartialViewContextWrapper

The default behavior of this method is to call PartialViewContext.setRenderAll(boolean) on the wrapped PartialViewContext object.

setRendered(boolean) - Method in class javax.faces.component.UIComponent

Set the rendered property of this UIComponent.

setRendered(boolean) - Method in class javax.faces.component.UIComponentBase

setRendered(boolean) - Method in class javax.faces.component.UIViewAction

Sets the if property of this component.

setRendered(ValueExpression) - Method in class javax.faces.webapp.UIComponentELTag

Set an override for the rendered attribute.

setRendered(String) - Method in class javax.faces.webapp.UIComponentTag

Deprecated.

Set an override for the rendered attribute.

setRendererType(String) - Method in class javax.faces.component.UIComponent

Set the Renderer type for this UIComponent, or null for components that render themselves.

setRendererType(String) - Method in class javax.faces.component.UIComponentBase

setRenderKitId(String) - Method in class javax.faces.component.UIViewRoot

Set the render kit identifier of the RenderKit associated with this view.

setReplyTo(Address[]) - Method in class javax.mail.internet.MimeMessage

Set the RFC 822 "Reply-To" header field.

setReplyTo(Address[]) - Method in class javax.mail.Message

Set the addresses to which replies should be directed.

setRepositoryItem(DataHandler) - Method in interface javax.xml.registry.infomodel.ExtrinsicObject

Sets the repository item for this object.

setRequest(Object) - Method in class javax.faces.context.ExternalContext

Set the environment-specific request to be returned by subsequent calls to ExternalContext.getRequest().

setRequest(Object) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.setRequest(Object) on the wrapped ExternalContext object.

setRequest(ServletRequest) - Method in class javax.servlet.ServletRequestWrapper

Sets the request object being wrapped.

setRequestCharacterEncoding(String) - Method in class javax.faces.context.ExternalContext

Overrides the name of the character encoding used in the body of this request.

setRequestCharacterEncoding(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.setRequestCharacterEncoding(String) on the wrapped ExternalContext object.

setRequestMessage(Object) - Method in interface javax.security.auth.message.MessageInfo

Set the request message object in this MessageInfo.

setRequestUri(URI) - Method in interface javax.ws.rs.container.ContainerRequestContext

Set a new request URI using the current base URI of the application to resolve the application-specific request URI part.

setRequestUri(URI, URI) - Method in interface javax.ws.rs.container.ContainerRequestContext

Set a new request URI using a new base URI to resolve the application-specific request URI part.

setRequired(boolean) - Method in interface javax.faces.component.EditableValueHolder

Set the "required field" state for this component.

setRequired(boolean) - Method in class javax.faces.component.UIInput

Set the "required field" state for this component.

setRequiredMessage(String) - Method in class javax.faces.component.UIInput

Override any ValueExpression set for the "requiredMessage" with the literal argument provided to this method.

setResetValues(boolean) - Method in class javax.faces.component.behavior.AjaxBehavior

Set the resetValues status of this behavior.

setResourceAdapter(ResourceAdapter) - Method in interface javax.resource.spi.ResourceAdapterAssociation

Associate this object with a ResourceAdapter object.

setResourceHandler(ResourceHandler) - Method in class javax.faces.application.Application

Set the ResourceHandler instance that will be utilized for rendering the markup for resources, and for satisfying client requests to serve up resources.

setResourceHandler(ResourceHandler) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.setResourceHandler(ResourceHandler) on the wrapped Application object.

setResourceLibraryContracts(List<String>) - Method in class javax.faces.context.FacesContext

Set the resource library contracts calculated as valid to use with this view.

setResourceLibraryContracts(List<String>) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.setResourceLibraryContracts(java.util.List<java.lang.String>) on the wrapped FacesContext object.

setResourceLimit(String, long) - Method in class javax.mail.Quota

Set a resource limit for this quota root.

setResourceName(String) - Method in class javax.faces.application.Resource

Set the resourceName for this resource.

setResourceName(String) - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.setResourceName(String) on the wrapped ResourceHandler object.

setResponse(Object) - Method in class javax.faces.context.ExternalContext

Set the environment-specific response to be returned by subsequent calls to ExternalContext.getResponse().

setResponse(Object) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.setResponse(Object) on the wrapped ExternalContext object.

setResponse(ServletResponse) - Method in class javax.servlet.ServletResponseWrapper

Sets the response being wrapped.

setResponseBufferSize(int) - Method in class javax.faces.context.ExternalContext

Set the buffer size for the current response.

setResponseBufferSize(int) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.setResponseBufferSize(int) on the wrapped ExternalContext object.

setResponseCharacterEncoding(String) - Method in class javax.faces.context.ExternalContext

Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8.

setResponseCharacterEncoding(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.getResponseCharacterEncoding() on the wrapped ExternalContext object.

setResponseContentLength(int) - Method in class javax.faces.context.ExternalContext

Set the content length of the response.

setResponseContentLength(int) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.setResponseContentLength(int) on the wrapped ExternalContext object.

setResponseContentType(String) - Method in class javax.faces.context.ExternalContext

Sets the content type of the response being sent to the client, if the response has not been committed yet.

setResponseContentType(String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.setResponseContentType(String) on the wrapped ExternalContext object.

setResponseHeader(String, String) - Method in class javax.faces.context.ExternalContext

Set the response header with the given name and value.

setResponseHeader(String, String) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.setResponseHeader(String,String) on the wrapped ExternalContext object.

setResponseMessage(Object) - Method in interface javax.security.auth.message.MessageInfo

Set the response message object in this MessageInfo.

setResponseStatus(int) - Method in class javax.faces.context.ExternalContext

Sets the HTTP status code for the response.

setResponseStatus(int) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.setResponseStatus(int) on the wrapped ExternalContext object.

setResponseStream(ResponseStream) - Method in class javax.faces.context.FacesContext

Set the ResponseStream to which components should direct their binary output.

setResponseStream(ResponseStream) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.setResponseStream(ResponseStream) on the wrapped FacesContext object.

setResponseWriter(ResponseWriter) - Method in class javax.faces.context.FacesContext

Set the ResponseWriter to which components should direct their character-based output.

setResponseWriter(ResponseWriter) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.setResponseWriter(ResponseWriter) on the wrapped FacesContext object.

setResult(boolean) - Method in class javax.security.auth.message.callback.PasswordValidationCallback

Set the authentication result.

setReturnType(QName) - Method in interface javax.xml.rpc.Call

Sets the return type for a specific operation.

setReturnType(QName, Class) - Method in interface javax.xml.rpc.Call

Sets the return type for a specific operation.

setRev(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the rev property.

setRev(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the rev property.

setRev(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the rev property.

setRole(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlOutputFormat

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlOutputText

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the role property.

setRole(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the role property.

setRole(String) - Method in interface javax.xml.soap.SOAPHeaderElement

Sets the Role associated with this SOAPHeaderElement object to the specified Role.

setRoles(String[]) - Method in interface javax.xml.rpc.handler.HandlerChain

Sets SOAP Actor roles for this HandlerChain.

setRoles(Set<String>) - Method in interface javax.xml.ws.soap.SOAPBinding

Sets the roles played by the SOAP binding instance.

setRollbackOnly() - Method in interface javax.ejb.EJBContext

Mark the current transaction for rollback.

setRollbackOnly() - Method in interface javax.persistence.EntityTransaction

Mark the current resource transaction so that the only possible outcome of the transaction is for the transaction to be rolled back.

setRollbackOnly() - Method in interface javax.transaction.Transaction

Modify the transaction associated with the target object such that the only possible outcome of the transaction is to roll back the transaction.

setRollbackOnly() - Method in interface javax.transaction.TransactionManager

Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.

setRollbackOnly() - Method in interface javax.transaction.TransactionSynchronizationRegistry

Set the rollbackOnly status of the transaction bound to the current thread at the time this method is called.

setRollbackOnly() - Method in interface javax.transaction.UserTransaction

Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.

setRootElement(String) - Method in class javax.faces.component.html.HtmlDoctype

Set the value of the rootElement property.

setRowClasses(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the rowClasses property.

setRowClasses(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the rowClasses property.

setRowHeader(boolean) - Method in class javax.faces.component.html.HtmlColumn

Set the value of the rowHeader property.

setRowIndex(int) - Method in class javax.faces.component.UIData

Set the zero relative index of the current row, or -1 to indicate that no row is currently selected, by implementing the following algorithm.

setRowIndex(int) - Method in class javax.faces.model.ArrayDataModel

setRowIndex(int) - Method in class javax.faces.model.CollectionDataModel

setRowIndex(int) - Method in class javax.faces.model.DataModel

Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.

setRowIndex(int) - Method in class javax.faces.model.ListDataModel

setRowIndex(int) - Method in class javax.faces.model.ResultDataModel

setRowIndex(int) - Method in class javax.faces.model.ResultSetDataModel

setRowIndex(int) - Method in class javax.faces.model.ScalarDataModel

setRows(int) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the rows property.

setRows(int) - Method in class javax.faces.component.UIData

Set the number of rows to be displayed, or zero for all remaining rows in the table.

setRowStatePreserved(boolean) - Method in class javax.faces.component.UIData

If this property is set to true, the UIData must take steps to ensure that modifications to its iterated children will be preserved on a per-row basis.

setRules(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the rules property.

setRules(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the rules property.

setRunAsRole(String) - Method in interface javax.servlet.ServletRegistration.Dynamic

Sets the name of the runAs role for this ServletRegistration.

setSchema(Schema) - Method in class javax.xml.bind.Binder

Specifies whether marshal, unmarshal and update methods performs validation on their XML content.

setSchema(Schema) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setSchema(Schema) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

setSchema(Schema) - Method in interface javax.xml.bind.Marshaller

Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.

setSchema(Schema) - Method in interface javax.xml.bind.Unmarshaller

Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.

setSchemaLocation(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for setting the schemaLocation.

setScope(String) - Method in class javax.servlet.jsp.jstl.core.ConditionalTagSupport

Sets the 'scope' attribute.

setScope(String, MessageContext.Scope) - Method in interface javax.xml.ws.handler.MessageContext

Sets the scope of a property.

setSecure(boolean) - Method in class javax.servlet.http.Cookie

Indicates to the browser whether the cookie should only be sent using a secure protocol, such as HTTPS or SSL.

setSecure(boolean) - Method in interface javax.servlet.SessionCookieConfig

Marks or unmarks the session tracking cookies created on behalf of the application represented by the ServletContext from which this SessionCookieConfig was acquired as secure.

setSecurityContext(SecurityContext) - Method in interface javax.ws.rs.container.ContainerRequestContext

Set a new injectable security context information for the current request.

setSelected(boolean) - Method in class javax.faces.component.UISelectBoolean

Set the local value of the selected state of this component.

setSelectedClass(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the selectedClass property.

setSelectedValues(Object[]) - Method in class javax.faces.component.UISelectMany

Set the currently selected values, or null to indicate that there are no currently selected values.

setSelectItems(SelectItem[]) - Method in class javax.faces.model.SelectItemGroup

Set the set of subordinate SelectItems for this group.

setSender(Address) - Method in class javax.mail.internet.MimeMessage

Set the RFC 822 "Sender" header field.

setSendTimeout(long) - Method in interface javax.websocket.RemoteEndpoint.Async

Sets the number of milliseconds the implementation will timeout attempting to send a websocket message.

setSentDate(Date) - Method in class javax.mail.internet.MimeMessage

Set the RFC 822 "Date" header field.

setSentDate(Date) - Method in class javax.mail.Message

Set the sent date of this message.

setServletSecurity(ServletSecurityElement) - Method in interface javax.servlet.ServletRegistration.Dynamic

Sets the ServletSecurityElement to be applied to the mappings defined for this ServletRegistration.

setSessionContext(SessionContext) - Method in interface javax.ejb.SessionBean

Set the associated session context.

setSessionMaxInactiveInterval(int) - Method in class javax.faces.context.ExternalContext

Specifies the time, in seconds, between client requests before the servlet container will invalidate this session.

setSessionMaxInactiveInterval(int) - Method in class javax.faces.context.ExternalContextWrapper

The default behavior of this method is to call ExternalContext.setSessionMaxInactiveInterval(int) on the wrapped ExternalContext object.

setSessionTrackingModes(Set<SessionTrackingMode>) - Method in interface javax.servlet.ServletContext

Sets the session tracking modes that are to become effective for this ServletContext.

setSeverity(FacesMessage.Severity) - Method in class javax.faces.application.FacesMessage

Set the severity level.

setSeverity(int) - Method in class javax.xml.bind.helpers.ValidationEventImpl

Set the severity field of this event.

setShape(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the shape property.

setShape(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the shape property.

setShape(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the shape property.

setShort(String, short) - Method in interface javax.jms.MapMessage

Sets a short value with the specified name into the Map.

setShortProperty(String, short) - Method in interface javax.jms.Message

Sets a short property value with the specified name into the message.

setShowDetail(boolean) - Method in class javax.faces.component.UIMessage

Set the flag indicating whether the detail property of the associated message(s) should be displayed.

setShowDetail(boolean) - Method in class javax.faces.component.UIMessages

Set the flag indicating whether the detail property of the associated message(s) should be displayed.

setShowSummary(boolean) - Method in class javax.faces.component.UIMessage

Set the flag indicating whether the summary property of the associated message(s) should be displayed.

setShowSummary(boolean) - Method in class javax.faces.component.UIMessages

Set the flag indicating whether the summary property of the associated message(s) should be displayed.

setSize(int) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the size property.

setSize(int) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the size property.

setSize(int) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the size property.

setSize(int) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the size property.

setSize(int) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the size property.

setSlotType(String) - Method in interface javax.xml.registry.infomodel.Slot

Sets the slotType for this Slot.

setSMaxAge(int) - Method in class javax.ws.rs.core.CacheControl

Corresponds to the s-maxage cache control directive.

setSourceObject(RegistryObject) - Method in interface javax.xml.registry.infomodel.Association

Sets the Object that is the source of this Association.

setSpecificationObject(RegistryObject) - Method in interface javax.xml.registry.infomodel.SpecificationLink

Sets the specification object for this object.

setStability(int) - Method in interface javax.xml.registry.infomodel.RegistryEntry

Sets the stability indicator for the RegistryEntry.

setStateManager(StateManager) - Method in class javax.faces.application.Application

Set the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.

setStateManager(StateManager) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.setStateManager(StateManager) on the wrapped Application object.

setStateOrProvince(String) - Method in interface javax.xml.registry.infomodel.PostalAddress

Sets the state or province.

setStatus(int) - Method in interface javax.servlet.http.HttpServletResponse

Sets the status code for this response.

setStatus(int, String) - Method in interface javax.servlet.http.HttpServletResponse

Deprecated.
As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String). Sets the status code and message for this response.

setStatus(int) - Method in class javax.servlet.http.HttpServletResponseWrapper

The default behavior of this method is to call setStatus(int sc) on the wrapped response object.

setStatus(int, String) - Method in class javax.servlet.http.HttpServletResponseWrapper

Deprecated.
As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use HttpServletResponseWrapper.setStatus(int), to send an error with a description use HttpServletResponseWrapper.sendError(int, String)

setStatus(int) - Method in interface javax.ws.rs.client.ClientResponseContext

Set a new response status code.

setStatus(int) - Method in interface javax.ws.rs.container.ContainerResponseContext

Set a new response status code.

setStatus(int) - Method in class javax.xml.ws.spi.http.HttpExchange

Sets the HTTP status code for the response.

setStatusInfo(Response.StatusType) - Method in interface javax.ws.rs.client.ClientResponseContext

Set the complete status information (status code and reason phrase) associated with the response.

setStatusInfo(Response.StatusType) - Method in interface javax.ws.rs.container.ContainerResponseContext

Set the complete status information (status code and reason phrase) associated with the response.

setStreet(String) - Method in interface javax.xml.registry.infomodel.PostalAddress

Sets the street name.

setStreetNumber(String) - Method in interface javax.xml.registry.infomodel.PostalAddress

Sets the street number.

setString(String, String) - Method in interface javax.jms.MapMessage

Sets a String value with the specified name into the Map.

setStringProperty(String, String) - Method in interface javax.jms.Message

Sets a String property value with the specified name into the message.

setStyle(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlOutputFormat

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlOutputText

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the style property.

setStyle(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the style property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlOutputFormat

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlOutputText

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlPanelGroup

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the styleClass property.

setStyleClass(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the styleClass property.

setSubject(String) - Method in class javax.mail.internet.MimeMessage

Set the "Subject" header field.

setSubject(String, String) - Method in class javax.mail.internet.MimeMessage

Set the "Subject" header field.

setSubject(String) - Method in class javax.mail.Message

Set the subject of this message.

setSubmitted(boolean) - Method in class javax.faces.component.UIForm

If this UIForm instance (as opposed to other forms in the page) is experiencing a submit during this request processing lifecycle, this method must be called, with true as the argument, during the UIComponent.decode(javax.faces.context.FacesContext) for this UIForm instance.

setSubmittedValue(Object) - Method in interface javax.faces.component.EditableValueHolder

Set the submittedValue value of this component.

setSubmittedValue(Object) - Method in class javax.faces.component.UIInput

Set the submittedValue value of this UIInput component.

setSubmittedValue(Object) - Method in class javax.faces.component.UIViewParameter

PENDING (docs) Interesting that submitted value isn't saved by the parent

setSubscribed(boolean) - Method in class javax.mail.Folder

Subscribe or unsubscribe this Folder.

setSubType(String) - Method in class javax.mail.internet.ContentType

Set the subType.

setSubType(String) - Method in class javax.mail.internet.MimeMultipart

Set the subtype.

setSummary(String) - Method in class javax.faces.application.FacesMessage

Set the localized summary text.

setSummary(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the summary property.

setSummary(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the summary property.

setSupportedEncodings(String[]) - Method in interface javax.xml.rpc.encoding.TypeMapping

Sets the encodingStyle URIs supported by this TypeMapping instance.

setSupportedLocales(Collection<Locale>) - Method in class javax.faces.application.Application

Set the Locale instances representing the supported Locales for this application.

setSupportedLocales(Collection<Locale>) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.setSupportedLocales(java.util.Collection) on the wrapped Application object.

setSynchronous(boolean) - Method in interface javax.xml.registry.Connection

Sets whether the client uses synchronous communication or not.

setSystem(String) - Method in class javax.faces.component.html.HtmlDoctype

Set the value of the system property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the tabindex property.

setTabindex(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the tabindex property.

setTag(Tag) - Method in class javax.faces.view.facelets.TagAttribute

Set a reference to the Tag for which this class represents the attributes.

setTag(Tag) - Method in class javax.faces.view.facelets.TagAttributes

Set a reference to the Tag for which this class represents the attributes.

setTagExtraInfo(TagExtraInfo) - Method in class javax.servlet.jsp.tagext.TagInfo

Set the instance for extra tag information.

setTagInfo(TagInfo) - Method in class javax.servlet.jsp.tagext.TagExtraInfo

Set the TagInfo for this class.

setTagLibrary(TagLibraryInfo) - Method in class javax.servlet.jsp.tagext.TagInfo

Set the TagLibraryInfo property.

setTarget(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the target property.

setTarget(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the target property.

setTarget(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the target property.

setTarget(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the target property.

setTargetBinding(ServiceBinding) - Method in interface javax.xml.registry.infomodel.ServiceBinding

Sets the next ServiceBinding in case there is a redirection.

setTargetEndpointAddress(String) - Method in interface javax.xml.rpc.Call

Sets the address of the target service endpoint.

setTargetObject(RegistryObject) - Method in interface javax.xml.registry.infomodel.Association

Sets the Object that is the target of this Association.

setTelephoneNumbers(Collection) - Method in interface javax.xml.registry.infomodel.Organization

Sets the various telephone numbers for this user.

setTelephoneNumbers(Collection) - Method in interface javax.xml.registry.infomodel.User

Sets the various telephone numbers for this user.

setText(String) - Method in interface javax.jms.TextMessage

Sets the string containing this message's data.

setText(String) - Method in class javax.mail.internet.MimeBodyPart

Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".

setText(String, String) - Method in class javax.mail.internet.MimeBodyPart

Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.

setText(String, String, String) - Method in class javax.mail.internet.MimeBodyPart

Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.

setText(String) - Method in class javax.mail.internet.MimeMessage

Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".

setText(String, String) - Method in class javax.mail.internet.MimeMessage

Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.

setText(String, String, String) - Method in class javax.mail.internet.MimeMessage

Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.

setText(String) - Method in interface javax.mail.internet.MimePart

Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".

setText(String, String) - Method in interface javax.mail.internet.MimePart

Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.

setText(String, String, String) - Method in interface javax.mail.internet.MimePart

Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.

setText(String) - Method in interface javax.mail.Part

A convenience method that sets the given String as this part's content with a MIME type of "text/plain".

setThreads(int) - Method in interface javax.batch.api.partition.PartitionPlan

Set number of threads.

setThreads(int) - Method in class javax.batch.api.partition.PartitionPlanImpl

setTimeout(long) - Method in interface javax.enterprise.context.Conversation

Set the timeout of the current conversation.

setTimeout(long) - Method in interface javax.servlet.AsyncContext

Sets the timeout (in milliseconds) for this AsyncContext.

setTimeout(long, TimeUnit) - Method in interface javax.ws.rs.container.AsyncResponse

Set/update the suspend timeout.

setTimeoutHandler(TimeoutHandler) - Method in interface javax.ws.rs.container.AsyncResponse

Set/replace a time-out handler for the suspended asynchronous response.

setTimeStyle(String) - Method in class javax.faces.convert.DateTimeConverter

Set the style to be used to format or parse times.

setTimeToLive(long) - Method in interface javax.jms.JMSProducer

Specifies the time to live of messages that are sent using this JMSProducer.

setTimeToLive(long) - Method in interface javax.jms.MessageProducer

Sets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.

setTimeZone(TimeZone) - Method in class javax.faces.convert.DateTimeConverter

Set the TimeZone used to interpret a time value.

setTitle(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlForm

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlInputFile

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlInputSecret

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlInputText

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlInputTextarea

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetButton

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlOutputFormat

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlOutputLabel

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlOutputText

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlSelectManyListbox

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlSelectManyMenu

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlSelectOneListbox

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlSelectOneMenu

Set the value of the title property.

setTitle(String) - Method in class javax.faces.component.html.HtmlSelectOneRadio

Set the value of the title property.

setTooltip(boolean) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the tooltip property.

setTooltip(boolean) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the tooltip property.

setTransactionTimeout(long) - Method in class javax.resource.spi.work.ExecutionContext

Set the transaction timeout value for a imported transaction.

setTransactionTimeout(int) - Method in interface javax.transaction.TransactionManager

Modify the timeout value that is associated with transactions started by the current thread with the begin method.

setTransactionTimeout(int) - Method in interface javax.transaction.UserTransaction

Modify the timeout value that is associated with transactions started by the current thread with the begin method.

setTransactionTimeout(int) - Method in interface javax.transaction.xa.XAResource

Sets the current transaction timeout value for this XAResource instance.

setTransient(boolean) - Method in class javax.faces.component.behavior.BehaviorBase

Implementation of StateHolder.setTransient(boolean).

setTransient(boolean) - Method in interface javax.faces.component.StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

setTransient(boolean) - Method in class javax.faces.component.UIComponentBase

setTransient(boolean) - Method in class javax.faces.convert.DateTimeConverter

setTransient(boolean) - Method in class javax.faces.convert.EnumConverter

setTransient(boolean) - Method in class javax.faces.convert.NumberConverter

setTransient(boolean) - Method in class javax.faces.event.MethodExpressionActionListener

setTransient(boolean) - Method in class javax.faces.event.MethodExpressionValueChangeListener

setTransient(boolean) - Method in class javax.faces.validator.BeanValidator

setTransient(boolean) - Method in class javax.faces.validator.DoubleRangeValidator

setTransient(boolean) - Method in class javax.faces.validator.LengthValidator

setTransient(boolean) - Method in class javax.faces.validator.LongRangeValidator

setTransient(boolean) - Method in class javax.faces.validator.MethodExpressionValidator

setTransient(boolean) - Method in class javax.faces.validator.RegexValidator

setTransientUserData(Object) - Method in interface javax.batch.runtime.context.JobContext

The setTransientUserData method stores a transient data object into the current batch context.

setTransientUserData(Object) - Method in interface javax.batch.runtime.context.StepContext

The setTransientUserData method stores a transient data object into the current batch context.

setTrustStore(KeyStore) - Method in class javax.security.auth.message.callback.TrustStoreCallback

Used by the CallbackHandler to set the trusted certificate keystore within the Callback.

setType(String) - Method in class javax.faces.component.html.HtmlCommandButton

Set the value of the type property.

setType(String) - Method in class javax.faces.component.html.HtmlCommandLink

Set the value of the type property.

setType(String) - Method in class javax.faces.component.html.HtmlOutcomeTargetLink

Set the value of the type property.

setType(String) - Method in class javax.faces.component.html.HtmlOutputLink

Set the value of the type property.

setType(String) - Method in class javax.faces.convert.DateTimeConverter

Set the type of value to be formatted or parsed.

setType(String) - Method in class javax.faces.convert.NumberConverter

Set the number type to be used when formatting and parsing numbers.

setType(Class<?>) - Method in interface javax.ws.rs.ext.InterceptorContext

Update Java type before calling message body provider.

setType(String) - Method in interface javax.xml.registry.infomodel.EmailAddress

Sets the type for this object.

setType(String) - Method in interface javax.xml.registry.infomodel.PostalAddress

Sets the type of address (for example, "headquarters") as a String.

setType(String) - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Sets the type of telephone number (for example, "fax").

setType(String) - Method in interface javax.xml.registry.infomodel.User

Sets the type for this User.

setUnselectedClass(String) - Method in class javax.faces.component.html.HtmlSelectManyCheckbox

Set the value of the unselectedClass property.

setupResponseWriter() - Method in class javax.faces.webapp.UIComponentClassicTagBase

Set up the ResponseWriter for the current response, if this has not been done already.

setupSecurityContext(CallbackHandler, Subject, Subject) - Method in class javax.resource.spi.work.SecurityContext

The container calls this method to set up the security Context for the Work instance.

setUri(URI) - Method in interface javax.ws.rs.client.ClientRequestContext

Set a new request URI.

setUrl(String) - Method in class javax.faces.component.UIGraphic

Set the image URL for this UIGraphic.

setURL(URL) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the URL field on this event locator.

setUrl(String) - Method in interface javax.xml.registry.infomodel.TelephoneNumber

Sets the URL that can dial this number electronically.

setUrl(URL) - Method in interface javax.xml.registry.infomodel.User

Sets the URL to the web page for this User.

setURLName(URLName) - Method in class javax.mail.Service

Set the URLName representing this service.

setUsageDescription(InternationalString) - Method in interface javax.xml.registry.infomodel.SpecificationLink

Sets the description of usage parameters.

setUsageParameters(Collection) - Method in interface javax.xml.registry.infomodel.SpecificationLink

Sets any usage parameters.

setUsemap(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the usemap property.

setUserVersion(String) - Method in interface javax.xml.registry.infomodel.Versionable

Sets the user specified revision number for this version of the Versionable object.

setValid(boolean) - Method in interface javax.faces.component.EditableValueHolder

Set a flag indicating whether the local value of this component is valid (no conversion error has occurred).

setValid(boolean) - Method in class javax.faces.component.UIInput

setValidateURI(boolean) - Method in interface javax.xml.registry.infomodel.URIValidator

Sets whether to do URI validation for this object.

setValidating(boolean) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Specifies whether or not the Unmarshaller should validate during unmarshal operations.

setValidating(boolean) - Method in interface javax.xml.bind.Unmarshaller

Deprecated.
since JAXB2.0, please see Unmarshaller.setSchema(javax.xml.validation.Schema)

setValidationGroups(String) - Method in class javax.faces.validator.BeanValidator

A comma-separated list of validation groups which are used to filter which validations get checked by this validator.

setValidator(MethodBinding) - Method in interface javax.faces.component.EditableValueHolder

Deprecated.
Use EditableValueHolder.addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.

setValidator(MethodBinding) - Method in class javax.faces.component.UIInput

Deprecated.
Use UIInput.addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.

setValidatorId(String) - Method in class javax.faces.webapp.ValidatorTag

Deprecated.

Set the identifer of the Validator instance to be created.

setValidatorMessage(String) - Method in class javax.faces.component.UIInput

Override any ValueExpression set for the "validatorMessage" with the literal argument provided to this method.

setValue(ELContext, Object, Object, Object) - Method in class javax.el.ArrayELResolver

If the base object is a Java language array, attempts to set the value at the given index with the given value.

setValue(ELContext, Object, Object, Object) - Method in class javax.el.BeanELResolver

If the base object is not null, attempts to set the value of the given property on this bean.

setValue(ELContext, Object, Object, Object) - Method in class javax.el.BeanNameELResolver

If the base is null and the property is a name that is resolvable by the BeanNameResolver, the bean in the BeanNameResolver is set to the given value.

setValue(ELContext, Object, Object, Object) - Method in class javax.el.CompositeELResolver

Attempts to set the value of the given property object on the given base object.

setValue(String, Object) - Method in class javax.el.ELProcessor

Sets an expression with a new value.

setValue(ELContext, Object, Object, Object) - Method in class javax.el.ELResolver

Attempts to set the value of the given property object on the given base object.

setValue(ELContext, Object, Object, Object) - Method in class javax.el.ListELResolver

If the base object is a list, attempts to set the value at the given index with the given value.

setValue(ELContext, Object, Object, Object) - Method in class javax.el.MapELResolver

If the base object is a map, attempts to set the value associated with the given key, as specified by the property argument.

setValue(ELContext, Object, Object, Object) - Method in class javax.el.ResourceBundleELResolver

If the base object is a ResourceBundle, throw a PropertyNotWritableException.

setValue(ELContext, Object, Object, Object) - Method in class javax.el.StaticFieldELResolver

Attempts to write to a static field.

setValue(ELContext, Object, Object, Object) - Method in class javax.el.TypeConverter

setValue(ELContext, Object) - Method in class javax.el.ValueExpression

Evaluates the expression relative to the provided context, and sets the result to the provided value.

setValue(Object) - Method in class javax.faces.component.UICommand

Sets the value property of the UICommand.

setValue(Object) - Method in class javax.faces.component.UIData

Set the value of the UIData.

setValue(Object) - Method in class javax.faces.component.UIGraphic

Sets the value property of the UIGraphic.

setValue(Object) - Method in class javax.faces.component.UIInput

setValue(Object) - Method in class javax.faces.component.UIOutput

setValue(Object) - Method in class javax.faces.component.UIParameter

Sets the value property of the\ UIParameter.

setValue(Object) - Method in class javax.faces.component.UISelectItem

Sets the value property of the UISelectItem.

setValue(Object) - Method in class javax.faces.component.UISelectItems

Sets the value property of the UISelectItems.

setValue(Object) - Method in interface javax.faces.component.ValueHolder

Set the value of this UIComponent (if any).

setValue(Object, Object, Object) - Method in class javax.faces.el.PropertyResolver

Deprecated.

Set the specified value of the specified property on the specified base object.

setValue(Object, int, Object) - Method in class javax.faces.el.PropertyResolver

Deprecated.

Set the value at the specified index of the specified base object.

setValue(FacesContext, Object) - Method in class javax.faces.el.ValueBinding

Deprecated.

Set the value of the property represented by this ValueBinding, relative to the specified FacesContext.

setValue(Object) - Method in class javax.faces.model.SelectItem

Set the value of this item, to be delivered to the model if this item is selected by this user.

setValue(String) - Method in class javax.faces.webapp.AttributeTag

Deprecated.

Set the attribute value.

setValue(String) - Method in class javax.servlet.http.Cookie

Assigns a new value to this Cookie.

setValue(ELContext, Object, Object, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver

If the base object is null, and the property matches the name of a JSP implicit object, throws PropertyNotWritableException to indicate that implicit objects cannot be overwritten.

setValue(ELContext, Object, Object, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver

If the base object is null, sets an existing scoped attribute to the new value, or creates a new scoped attribute if one does not exist by this name.

setValue(ELContext, Object) - Method in class javax.servlet.jsp.jstl.core.IndexedValueExpression

setValue(ELContext, Object) - Method in class javax.servlet.jsp.jstl.core.IteratedValueExpression

setValue(String, Object) - Method in class javax.servlet.jsp.tagext.TagSupport

Associate a value with a String key.

setValue(T) - Method in class javax.xml.bind.JAXBElement

Set the content model and attributes of this xml element.

setValue(String) - Method in interface javax.xml.registry.infomodel.Classification

Sets the taxonomy value for this external Classification.

setValue(String) - Method in interface javax.xml.registry.infomodel.Concept

Sets the value (usually a taxonomy value) associated with this Concept.

setValue(String) - Method in interface javax.xml.registry.infomodel.ExternalIdentifier

Sets the value of an ExternalIdentifier.

setValue(String) - Method in interface javax.xml.registry.infomodel.InternationalString

Sets the String value for the Locale returned by Locale.getDefault().

setValue(Locale, String) - Method in interface javax.xml.registry.infomodel.InternationalString

Sets the String value for the specified Locale.

setValue(String) - Method in interface javax.xml.registry.infomodel.LocalizedString

Set the String value for the specified object.

setValue(String) - Method in interface javax.xml.soap.Node

If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node.

setValueBinding(String, ValueBinding) - Method in class javax.faces.component.UIComponent

Deprecated.
This has been replaced by UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).

setValueBinding(String, ValueBinding) - Method in class javax.faces.component.UIComponentBase

Deprecated.
This has been replaced by UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).

setValueBinding(String, ValueBinding) - Method in class javax.faces.component.UIData

Deprecated.
This has been replaced by UIData.setValueExpression(java.lang.String, javax.el.ValueExpression).

setValueBinding(String, ValueBinding) - Method in class javax.faces.component.UIGraphic

Deprecated.
This has been replaced by UIGraphic.setValueExpression(java.lang.String, javax.el.ValueExpression).

setValueBinding(String, ValueBinding) - Method in class javax.faces.component.UISelectBoolean

Deprecated.
This has been replaced by UISelectBoolean.setValueExpression(java.lang.String, javax.el.ValueExpression).

setValueBinding(String, ValueBinding) - Method in class javax.faces.component.UISelectMany

Deprecated.
This has been replaced by UISelectMany.setValueExpression(java.lang.String, javax.el.ValueExpression).

setValueChangeListener(MethodBinding) - Method in interface javax.faces.component.EditableValueHolder

Deprecated.
Use EditableValueHolder.addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.

setValueChangeListener(MethodBinding) - Method in class javax.faces.component.UIInput

Deprecated.
Use UIInput.addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.

setValueExpression(String, ValueExpression) - Method in class javax.faces.component.behavior.AjaxBehavior

Sets the ValueExpression used to calculate the value for the specified property name.

setValueExpression(String, ValueExpression) - Method in class javax.faces.component.UIComponent

Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.

setValueExpression(String, ValueExpression) - Method in class javax.faces.component.UIData

Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.

setValueExpression(String, ValueExpression) - Method in class javax.faces.component.UIGraphic

Store any ValueExpression specified for url under value instead; otherwise, perform the default superclass processing for this method.

setValueExpression(String, ValueExpression) - Method in class javax.faces.component.UISelectBoolean

Store any ValueExpression specified for selected under value instead; otherwise, perform the default superclass processing for this method.

setValueExpression(String, ValueExpression) - Method in class javax.faces.component.UISelectMany

Store any ValueExpression specified for selectedValues under value instead; otherwise, perform the default superclass processing for this method.

setValues(Collection) - Method in interface javax.xml.registry.infomodel.Slot

Sets the values for this Slot.

setValueType(int) - Method in interface javax.xml.registry.infomodel.ClassificationScheme

Sets the value type for this object.

setVar(String) - Method in class javax.faces.component.UIData

Set the request-scope attribute under which the data object for the current row wil be exposed when iterating.

setVar(String) - Method in class javax.servlet.jsp.jstl.core.ConditionalTagSupport

Sets the 'var' attribute.

setVar(String) - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Sets the 'var' attribute.

setVariable(String, ValueExpression) - Method in class javax.el.ELManager

Assign a ValueExpression to an EL variable, replacing any previous assignment to the same variable.

setVariable(String, String) - Method in class javax.el.ELProcessor

Assign an EL expression to an EL variable.

setVariable(String, ValueExpression) - Method in class javax.el.VariableMapper

Assign a ValueExpression to an EL variable, replacing any previously assignment to the same variable.

setVariableMapper(VariableMapper) - Method in class javax.faces.view.facelets.FaceletContext

Set the VariableMapper to use in EL evaluation/creation.

setVariableResolver(VariableResolver) - Method in class javax.faces.application.Application

Deprecated.
The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called Application.addELResolver(javax.el.ELResolver).

setVariableResolver(VariableResolver) - Method in class javax.faces.application.ApplicationWrapper

Deprecated.
See superclass for alternative.

setVarStatus(String) - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Sets the 'varStatus' attribute.

setVersion(int) - Method in class javax.servlet.http.Cookie

Sets the version of the cookie protocol that this Cookie complies with.

setViewHandler(ViewHandler) - Method in class javax.faces.application.Application

Set the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.

setViewHandler(ViewHandler) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.setViewHandler(ViewHandler) on the wrapped Application object.

setViewId(String) - Method in class javax.faces.component.UIViewRoot

Set the view identifier for this view.

setViewRoot(UIViewRoot) - Method in class javax.faces.context.FacesContext

Set the root component that is associated with this request.

setViewRoot(UIViewRoot) - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.setViewRoot(UIViewRoot) on the wrapped FacesContext object.

setWarnClass(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the warnClass property.

setWarnClass(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the warnClass property.

setWarnStyle(String) - Method in class javax.faces.component.html.HtmlMessage

Set the value of the warnStyle property.

setWarnStyle(String) - Method in class javax.faces.component.html.HtmlMessages

Set the value of the warnStyle property.

setWidth(String) - Method in class javax.faces.component.html.HtmlDataTable

Set the value of the width property.

setWidth(String) - Method in class javax.faces.component.html.HtmlGraphicImage

Set the value of the width property.

setWidth(String) - Method in class javax.faces.component.html.HtmlPanelGrid

Set the value of the width property.

setWrappedData(Object) - Method in class javax.faces.model.ArrayDataModel

setWrappedData(Object) - Method in class javax.faces.model.CollectionDataModel

Set the wrapped data.

setWrappedData(Object) - Method in class javax.faces.model.DataModel

Set the object representing the data collection wrapped by this DataModel.

setWrappedData(Object) - Method in class javax.faces.model.ListDataModel

setWrappedData(Object) - Method in class javax.faces.model.ResultDataModel

setWrappedData(Object) - Method in class javax.faces.model.ResultSetDataModel

setWrappedData(Object) - Method in class javax.faces.model.ScalarDataModel

setWriteListener(WriteListener) - Method in class javax.servlet.ServletOutputStream

Instructs the ServletOutputStream to invoke the provided WriteListener when it is possible to write

setXid(Xid) - Method in class javax.resource.spi.work.ExecutionContext

set a transaction context.

setXmlns(String) - Method in class javax.faces.component.html.HtmlBody

Set the value of the xmlns property.

setXmlns(String) - Method in class javax.faces.component.html.HtmlHead

Set the value of the xmlns property.

SEVERITY_ERROR - Static variable in class javax.faces.application.FacesMessage

Message severity level indicating that an error has occurred.

SEVERITY_FATAL - Static variable in class javax.faces.application.FacesMessage

Message severity level indicating that a serious error has occurred.

SEVERITY_INFO - Static variable in class javax.faces.application.FacesMessage

Message severity level indicating an informational message rather than an error.

SEVERITY_WARN - Static variable in class javax.faces.application.FacesMessage

Message severity level indicating that an error might have occurred.

SharedByteArrayInputStream - Class in javax.mail.util

A ByteArrayInputStream that implements the SharedInputStream interface, allowing the underlying byte array to be shared between multiple readers.

SharedByteArrayInputStream(byte[]) - Constructor for class javax.mail.util.SharedByteArrayInputStream

Create a SharedByteArrayInputStream representing the entire byte array.

SharedByteArrayInputStream(byte[], int, int) - Constructor for class javax.mail.util.SharedByteArrayInputStream

Create a SharedByteArrayInputStream representing the part of the byte array from offset for length bytes.

SharedCacheMode - Enum in javax.persistence

Specifies how the provider must use a second-level cache for the persistence unit.

SharedFileInputStream - Class in javax.mail.util

A SharedFileInputStream is a BufferedInputStream that buffers data from the file and supports the mark and reset methods.

SharedFileInputStream(File) - Constructor for class javax.mail.util.SharedFileInputStream

Creates a SharedFileInputStream for the file.

SharedFileInputStream(String) - Constructor for class javax.mail.util.SharedFileInputStream

Creates a SharedFileInputStream for the named file

SharedFileInputStream(File, int) - Constructor for class javax.mail.util.SharedFileInputStream

Creates a SharedFileInputStream with the specified buffer size.

SharedFileInputStream(String, int) - Constructor for class javax.mail.util.SharedFileInputStream

Creates a SharedFileInputStream with the specified buffer size.

SharedInputStream - Interface in javax.mail.internet

An InputStream that is backed by data that can be shared by multiple readers may implement this interface.

SharingViolationException - Exception in javax.resource.spi

This is thrown to indicate a connection sharing violation.

SharingViolationException() - Constructor for exception javax.resource.spi.SharingViolationException

Constructs a new instance with null as its detail message.

SharingViolationException(String) - Constructor for exception javax.resource.spi.SharingViolationException

Constructs a new instance with the specified detail message.

SharingViolationException(Throwable) - Constructor for exception javax.resource.spi.SharingViolationException

Constructs a new throwable with the specified cause.

SharingViolationException(String, Throwable) - Constructor for exception javax.resource.spi.SharingViolationException

Constructs a new throwable with the specified detail message and cause.

SharingViolationException(String, String) - Constructor for exception javax.resource.spi.SharingViolationException

Constructs a new throwable with the specified detail message and error code.

SHORT_ID - Static variable in class javax.faces.convert.ShortConverter

The message identifier of the FacesMessage to be created if the conversion to Short fails.

ShortConverter - Class in javax.faces.convert

Converter implementation for java.lang.Short (and short primitive) values.

ShortConverter() - Constructor for class javax.faces.convert.ShortConverter

ShortHolder - Class in javax.xml.rpc.holders

ShortHolder() - Constructor for class javax.xml.rpc.holders.ShortHolder

ShortHolder(short) - Constructor for class javax.xml.rpc.holders.ShortHolder

shortname - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo

The preferred short name (prefix) as indicated in the TLD.

ShortWrapperHolder - Class in javax.xml.rpc.holders

ShortWrapperHolder() - Constructor for class javax.xml.rpc.holders.ShortWrapperHolder

ShortWrapperHolder(Short) - Constructor for class javax.xml.rpc.holders.ShortWrapperHolder

SimpleTag - Interface in javax.servlet.jsp.tagext

Interface for defining Simple Tag Handlers.

SimpleTagSupport - Class in javax.servlet.jsp.tagext

A base class for defining tag handlers implementing SimpleTag.

SimpleTagSupport() - Constructor for class javax.servlet.jsp.tagext.SimpleTagSupport

Sole constructor.

SingleThreadModel - Interface in javax.servlet

Deprecated.
As of Java Servlet API 2.4, with no direct replacement.

Singleton - Annotation Type in javax.ejb

Component-defining annotation for a singleton session bean.

Singleton - Annotation Type in javax.inject

Identifies a type that the injector only instantiates once.

SingularAttribute<X,T> - Interface in javax.persistence.metamodel

Instances of the type SingularAttribute represents persistent single-valued properties or fields.

size() - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.size() on the wrapped Flash object.

SIZE - Static variable in class javax.mail.FetchProfile.Item

SIZE is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder.

size() - Method in class javax.mail.internet.ParameterList

Return the number of parameters in this list.

size(Expression<C>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that tests the size of a collection.

size(C) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that tests the size of a collection.

Size - Annotation Type in javax.validation.constraints

The annotated element size must be between the specified boundaries (included).

size() - Method in class javax.ws.rs.core.AbstractMultivaluedMap

Size.List - Annotation Type in javax.validation.constraints

Defines several Size annotations on the same element.

SizeTerm - Class in javax.mail.search

This class implements comparisons for Message sizes.

SizeTerm(int, int) - Constructor for class javax.mail.search.SizeTerm

Constructor.

skip(long) - Method in class javax.mail.util.SharedFileInputStream

See the general contract of the skip method of InputStream.

SKIP_BODY - Static variable in interface javax.servlet.jsp.tagext.Tag

Skip body evaluation.

SKIP_PAGE - Static variable in interface javax.servlet.jsp.tagext.Tag

Skip the rest of the page.

SkipPageException - Exception in javax.servlet.jsp

Exception to indicate the calling page must cease evaluation.

SkipPageException() - Constructor for exception javax.servlet.jsp.SkipPageException

Creates a SkipPageException with no message.

SkipPageException(String) - Constructor for exception javax.servlet.jsp.SkipPageException

Creates a SkipPageException with the provided message.

SkipPageException(String, Throwable) - Constructor for exception javax.servlet.jsp.SkipPageException

Creates a SkipPageException with the provided message and root cause.

SkipPageException(Throwable) - Constructor for exception javax.servlet.jsp.SkipPageException

Creates a SkipPageException with the provided root cause.

SkippedException - Exception in javax.enterprise.concurrent

Exception indicating that the result of a value-producing task cannot be retrieved because the task run was skipped.

SkippedException() - Constructor for exception javax.enterprise.concurrent.SkippedException

Constructs an SkippedException with null as its detail message.

SkippedException(String) - Constructor for exception javax.enterprise.concurrent.SkippedException

Constructs an SkippedException exception with the specified detail message.

SkippedException(String, Throwable) - Constructor for exception javax.enterprise.concurrent.SkippedException

Constructs an SkippedException exception with the specified detail message and cause.

SkippedException(Throwable) - Constructor for exception javax.enterprise.concurrent.SkippedException

Constructs an SkippedException exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

SkipProcessListener - Interface in javax.batch.api.chunk.listener

SkipProcessListener intercepts skippable itemProcess exception handling.

SkipReadListener - Interface in javax.batch.api.chunk.listener

SkipReadListener intercepts skippable itemReader exception handling.

skipRun(LastExecution, Date) - Method in interface javax.enterprise.concurrent.Trigger

Return true if this run instance should be skipped.

SkipWriteListener - Interface in javax.batch.api.chunk.listener

SkipWriteListener intercepts skippable itemWriter exception handling.

Slot - Interface in javax.xml.registry.infomodel

Slot instances provide a dynamic way to add arbitrary attributes to RegistryObject instances.

SLOT - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.Slot interface.

SOAP11HTTP_BINDING - Static variable in interface javax.xml.ws.soap.SOAPBinding

A constant representing the identity of the SOAP 1.1 over HTTP binding.

SOAP11HTTP_MTOM_BINDING - Static variable in interface javax.xml.ws.soap.SOAPBinding

A constant representing the identity of the SOAP 1.1 over HTTP binding with MTOM enabled by default.

SOAP12HTTP_BINDING - Static variable in interface javax.xml.ws.soap.SOAPBinding

A constant representing the identity of the SOAP 1.2 over HTTP binding.

SOAP12HTTP_MTOM_BINDING - Static variable in interface javax.xml.ws.soap.SOAPBinding

A constant representing the identity of the SOAP 1.2 over HTTP binding with MTOM enabled by default.

SOAP_1_1_CONTENT_TYPE - Static variable in interface javax.xml.soap.SOAPConstants

The media type of the Content-Type MIME header in SOAP 1.1.

SOAP_1_1_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants

Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.1 specification.

SOAP_1_2_CONTENT_TYPE - Static variable in interface javax.xml.soap.SOAPConstants

The media type of the Content-Type MIME header in SOAP 1.2.

SOAP_1_2_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants

Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.2 specification

SOAP_ARRAY - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the SOAP-ENC:Array type.

SOAP_BASE64 - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the SOAP-ENC:base64 type.

SOAP_BOOLEAN - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the SOAP-ENC:boolean type.

SOAP_BYTE - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the SOAP-ENC:byte type.

SOAP_DATAENCODINGUNKNOWN_FAULT - Static variable in interface javax.xml.soap.SOAPConstants

SOAP 1.2 DataEncodingUnknown Fault

SOAP_DOUBLE - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the SOAP-ENC:double type.

SOAP_ENV_PREFIX - Static variable in interface javax.xml.soap.SOAPConstants

The default namespace prefix for http://www.w3.org/2003/05/soap-envelope

SOAP_FLOAT - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the SOAP-ENC:float type.

SOAP_INT - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the SOAP-ENC:int type.

SOAP_LONG - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the SOAP-ENC:long type.

SOAP_MUSTUNDERSTAND_FAULT - Static variable in interface javax.xml.soap.SOAPConstants

SOAP 1.2 MustUnderstand Fault

SOAP_RECEIVER_FAULT - Static variable in interface javax.xml.soap.SOAPConstants

SOAP 1.2 Receiver Fault

SOAP_SENDER_FAULT - Static variable in interface javax.xml.soap.SOAPConstants

SOAP 1.2 Sender Fault

SOAP_SHORT - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the SOAP-ENC:short type.

SOAP_STRING - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the SOAP-ENC:string type.

SOAP_VERSIONMISMATCH_FAULT - Static variable in interface javax.xml.soap.SOAPConstants

SOAP 1.2 VersionMismatch Fault

SOAPACTION_URI_PROPERTY - Static variable in interface javax.xml.rpc.Call

Standard property for SOAPAction.

SOAPACTION_URI_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider

Standard property for SOAPAction.

SOAPACTION_USE_PROPERTY - Static variable in interface javax.xml.rpc.Call

Standard property for SOAPAction.

SOAPACTION_USE_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider

Standard property for SOAPAction.

SOAPBinding - Annotation Type in javax.jws.soap

SOAPBinding - Interface in javax.xml.ws.soap

The SOAPBinding interface is an abstraction for the SOAP binding.

SOAPBinding.ParameterStyle - Enum in javax.jws.soap

SOAPBinding.Style - Enum in javax.jws.soap

SOAPBinding.Use - Enum in javax.jws.soap

SOAPBody - Interface in javax.xml.soap

An object that represents the contents of the SOAP body element in a SOAP message.

SOAPBodyElement - Interface in javax.xml.soap

A SOAPBodyElement object represents the contents in a SOAPBody object.

SOAPConnection - Class in javax.xml.soap

A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).

SOAPConnection() - Constructor for class javax.xml.soap.SOAPConnection

SOAPConnectionFactory - Class in javax.xml.soap

A factory for creating SOAPConnection objects.

SOAPConnectionFactory() - Constructor for class javax.xml.soap.SOAPConnectionFactory

SOAPConstants - Interface in javax.xml.soap

The definition of constants pertaining to the SOAP protocol.

SOAPElement - Interface in javax.xml.soap

An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.

SOAPElementFactory - Class in javax.xml.soap

Deprecated.
- Use javax.xml.soap.SOAPFactory for creating SOAPElements.

SOAPEnvelope - Interface in javax.xml.soap

The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.

SOAPException - Exception in javax.xml.soap

An exception that signals that a SOAP exception has occurred.

SOAPException() - Constructor for exception javax.xml.soap.SOAPException

Constructs a SOAPException object with no reason or embedded Throwable object.

SOAPException(String) - Constructor for exception javax.xml.soap.SOAPException

Constructs a SOAPException object with the given String as the reason for the exception being thrown.

SOAPException(String, Throwable) - Constructor for exception javax.xml.soap.SOAPException

Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.

SOAPException(Throwable) - Constructor for exception javax.xml.soap.SOAPException

Constructs a SOAPException object initialized with the given Throwable object.

SOAPFactory - Class in javax.xml.soap

SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.

SOAPFactory() - Constructor for class javax.xml.soap.SOAPFactory

SOAPFault - Interface in javax.xml.soap

An element in the SOAPBody object that contains error and/or status information.

SOAPFaultElement - Interface in javax.xml.soap

A representation of the contents in a SOAPFault object.

SOAPFaultException - Exception in javax.xml.rpc.soap

The SOAPFaultException exception represents a SOAP fault.

SOAPFaultException(QName, String, String, Detail) - Constructor for exception javax.xml.rpc.soap.SOAPFaultException

Constructor for the SOAPFaultException

SOAPFaultException - Exception in javax.xml.ws.soap

The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.

SOAPFaultException(SOAPFault) - Constructor for exception javax.xml.ws.soap.SOAPFaultException

Constructor for SOAPFaultException

SOAPHandler<T extends SOAPMessageContext> - Interface in javax.xml.ws.handler.soap

The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.

SOAPHeader - Interface in javax.xml.soap

A representation of the SOAP header element.

SOAPHeaderElement - Interface in javax.xml.soap

An object representing the contents in the SOAP header part of the SOAP envelope.

SOAPMessage - Class in javax.xml.soap

The root class for all SOAP messages.

SOAPMessage() - Constructor for class javax.xml.soap.SOAPMessage

SOAPMessageContext - Interface in javax.xml.rpc.handler.soap

The interface javax.xml.rpc.soap.SOAPMessageContext provides access to the SOAP message for either RPC request or response.

SOAPMessageContext - Interface in javax.xml.ws.handler.soap

The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.

SOAPMessageHandler - Annotation Type in javax.jws.soap

Deprecated.

SOAPMessageHandlers - Annotation Type in javax.jws.soap

Deprecated.

SOAPPart - Class in javax.xml.soap

The container for the SOAP-specific portion of a SOAPMessage object.

SOAPPart() - Constructor for class javax.xml.soap.SOAPPart

some(Subquery<Y>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a some expression over the subquery results.

SORT_BY_DATE_ASC - Static variable in interface javax.xml.registry.FindQualifier

Specifies a hint to queries that they should sort results by creation/modification date in ascending order.

SORT_BY_DATE_DESC - Static variable in interface javax.xml.registry.FindQualifier

Specifies a hint to queries that they should sort results by creation/modification date in descending order.

SORT_BY_NAME_ASC - Static variable in interface javax.xml.registry.FindQualifier

Specifies a hint to queries that they should sort results by Name in ascending alpha-numeric order.

SORT_BY_NAME_DESC - Static variable in interface javax.xml.registry.FindQualifier

Specifies a hint to queries that they should sort results by Name in descending alpha-numeric order.

SORT_CODE_SLOT - Static variable in interface javax.xml.registry.infomodel.Slot

Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.

SOUNDEX - Static variable in interface javax.xml.registry.FindQualifier

Optional qualifier that allows matching strings by their sounds.

Specializes - Annotation Type in javax.enterprise.inject

Indicates that a bean directly specializes another bean.

SPECIFICATION_LINK - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.SpecificationLink interface.

SpecificationLink - Interface in javax.xml.registry.infomodel

A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding.

SQL_DATA_SOURCE - Static variable in class javax.servlet.jsp.jstl.core.Config

Name of configuration setting for SQL data source

SQL_MAX_ROWS - Static variable in class javax.servlet.jsp.jstl.core.Config

Name of configuration setting for maximum number of rows to be included in SQL query result

SQLExecutionTag - Interface in javax.servlet.jsp.jstl.sql

This interface allows tag handlers implementing it to receive values for parameter markers in their SQL statements.

SqlResultSetMapping - Annotation Type in javax.persistence

Specifies the mapping of the result of a native SQL query or stored procedure.

SqlResultSetMappings - Annotation Type in javax.persistence

Is used to define one or more SqlResultSetMapping annotations.

sqrt(Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the square root of its argument.

sslContext(SSLContext) - Method in class javax.ws.rs.client.ClientBuilder

Set the SSL context that will be used when creating secured transport connections to server endpoints from web targets created by the client instance that is using this SSL context.

STABILITY_DYNAMIC - Static variable in interface javax.xml.registry.infomodel.RegistryEntry

RegistryEntry may change at any time.

STABILITY_DYNAMIC_COMPATIBLE - Static variable in interface javax.xml.registry.infomodel.RegistryEntry

RegistryEntry may change at any time, however the changes will be backward compatible.

STABILITY_STATIC - Static variable in interface javax.xml.registry.infomodel.RegistryEntry

RegistryEntry will not change.

StandardELContext - Class in javax.el

A standard ELContext suitable for use in a stand alone environment.

StandardELContext(ExpressionFactory) - Constructor for class javax.el.StandardELContext

Construct a default ELContext for a stand-alone environment.

StandardELContext(ELContext) - Constructor for class javax.el.StandardELContext

Construct a StandardELContext from another ELContext.

start(String, Properties) - Method in interface javax.batch.operations.JobOperator

Creates a new job instance and starts the first execution of that instance.

start(Date) - Method in class javax.ejb.ScheduleExpression

Set the start date.

START - Static variable in class javax.enterprise.deploy.shared.CommandType

The DeploymentManger action operation being processed is start.

start(TargetModuleID[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Start the application running.

start() - Method in interface javax.jms.Connection

Starts (or restarts) a connection's delivery of incoming messages.

start() - Method in interface javax.jms.JMSContext

Starts (or restarts) delivery of incoming messages by the JMSContext's connection.

start() - Method in interface javax.jms.ServerSession

Cause the Session's run method to be called to process messages that were just assigned to it.

start - Variable in class javax.mail.util.SharedByteArrayInputStream

Position within shared buffer that this stream starts at.

start - Variable in class javax.mail.util.SharedFileInputStream

The file offset of the start of data in this subset of the file.

start(BootstrapContext) - Method in interface javax.resource.spi.ResourceAdapter

This is called when a resource adapter instance is bootstrapped.

start(Runnable) - Method in interface javax.servlet.AsyncContext

Causes the container to dispatch a thread, possibly from a managed thread pool, to run the specified Runnable.

start(Xid, int) - Method in interface javax.transaction.xa.XAResource

Starts work on behalf of a transaction branch specified in xid.

START_TIMED_OUT - Static variable in exception javax.resource.spi.work.WorkException

Indicates start timeout expiration.

startAsync() - Method in interface javax.servlet.ServletRequest

Puts this request into asynchronous mode, and initializes its AsyncContext with the original (unwrapped) ServletRequest and ServletResponse objects.

startAsync(ServletRequest, ServletResponse) - Method in interface javax.servlet.ServletRequest

Puts this request into asynchronous mode, and initializes its AsyncContext with the given request and response objects.

startAsync() - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to invoke ServletRequest.startAsync() on the wrapped request object.

startAsync(ServletRequest, ServletResponse) - Method in class javax.servlet.ServletRequestWrapper

The default behavior of this method is to invoke ServletRequest.startAsync(ServletRequest, ServletResponse) on the wrapped request object.

startCDATA() - Method in class javax.faces.context.ResponseWriter

Open an XML CDATA block.

startCDATA() - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.startCDATA() on the wrapped ResponseWriter object.

startDocument() - Method in class javax.faces.context.PartialResponseWriter

Write the start of a partial response.

startDocument() - Method in class javax.faces.context.ResponseWriter

Write whatever text should begin a response.

startDocument() - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.startDocument() on the wrapped ResponseWriter object.

startElement(String, UIComponent) - Method in class javax.faces.context.ResponseWriter

Write the start of an element, up to and including the element name.

startElement(String, UIComponent) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.startElement(String, javax.faces.component.UIComponent) on the wrapped ResponseWriter object.

startError(String) - Method in class javax.faces.context.PartialResponseWriter

Write the start of an error.

startEval() - Method in class javax.faces.context.PartialResponseWriter

Write the start of an eval operation.

startExtension(Map<String, String>) - Method in class javax.faces.context.PartialResponseWriter

Write the start of an extension operation.

startInsertAfter(String) - Method in class javax.faces.context.PartialResponseWriter

Write the start of an insert operation where the contents will be inserted after the specified target node.

startInsertBefore(String) - Method in class javax.faces.context.PartialResponseWriter

Write the start of an insert operation where the contents will be inserted before the specified target node.

Startup - Annotation Type in javax.ejb

Mark a singleton bean for eager initialization during the application startup sequence.

startUpdate(String) - Method in class javax.faces.context.PartialResponseWriter

Write the start of an update operation.

startWork(Work) - Method in interface javax.resource.spi.work.WorkManager

Accepts a Work instance for processing.

startWork(Work, long, ExecutionContext, WorkListener) - Method in interface javax.resource.spi.work.WorkManager

Accepts a Work instance for processing.

STATE_SAVING_METHOD_CLIENT - Static variable in class javax.faces.application.StateManager

Constant value for the initialization parameter named by the STATE_SAVING_METHOD_PARAM_NAME that indicates state saving should take place on the client.

STATE_SAVING_METHOD_PARAM_NAME - Static variable in class javax.faces.application.StateManager

The ServletContext init parameter consulted by the StateManager to tell where the state should be saved.

STATE_SAVING_METHOD_SERVER - Static variable in class javax.faces.application.StateManager

Constant value for the initialization parameter named by the STATE_SAVING_METHOD_PARAM_NAME that indicates state saving should take place on the server.

Stateful - Annotation Type in javax.ejb

Component-defining annotation for a stateful session bean.

StatefulSessionBeanStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a stateful session bean.

StatefulTimeout - Annotation Type in javax.ejb

Specifies the amount of time a stateful session bean can be idle (not receive any client invocations) before it is eligible for removal by the container.

StateHelper - Interface in javax.faces.component

Define a Map-like contract that makes it easier for components to implement PartialStateHolder.

StateHolder - Interface in javax.faces.component

This interface is implemented by classes that need to save their state between requests.

Stateless - Annotation Type in javax.ejb

Component-defining annotation for a stateless session bean.

StatelessSessionBeanStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a stateless session bean.

StateManagementStrategy - Class in javax.faces.view

Encapsulate the saving and restoring of the view to enable the VDL to take over the responsibility for handling this feature.

StateManagementStrategy() - Constructor for class javax.faces.view.StateManagementStrategy

StateManager - Class in javax.faces.application

StateManager directs the process of saving and restoring the view between requests.

StateManager() - Constructor for class javax.faces.application.StateManager

StateManager.SerializedView - Class in javax.faces.application

Deprecated.
This class was not marked Serializable in the 1.0 version of the spec. It was also not a static inner class, so it can't be made to be Serializable. Therefore, it is being deprecated in version 1.2 of the spec. The replacement is to use an implementation dependent Object.

StateManager.SerializedView(Object, Object) - Constructor for class javax.faces.application.StateManager.SerializedView

Deprecated.

StateManagerWrapper - Class in javax.faces.application

Provides a simple implementation of StateManager that can be subclassed by developers wishing to provide specialized behavior to an existing StateManager instance.

StateManagerWrapper() - Constructor for class javax.faces.application.StateManagerWrapper

StateType - Class in javax.enterprise.deploy.shared

Class StateTypes defines enumeration values for the DeploymentStatus object.

StateType(int) - Constructor for class javax.enterprise.deploy.shared.StateType

Construct a new enumeration value with the given integer value.

StaticFieldELResolver - Class in javax.el

An ELResolver for resolving static fields, enum constants and static methods.

StaticFieldELResolver() - Constructor for class javax.el.StaticFieldELResolver

StaticMetamodel - Annotation Type in javax.persistence.metamodel

The StaticMetamodel annotation specifies that the class is a metamodel class that represents the entity, mapped superclass, or embeddable class designated by the value element.

Statistic - Interface in javax.management.j2ee.statistics

The Statistic model and its sub-models specify the data models which are requried to be used to provide the performance data described by the specific attributes in the Stats models.

Stats - Interface in javax.management.j2ee.statistics

The Stats model and its submodels specify performance data attributes for each of the specific managed object types.

Status - Interface in javax.transaction

The Status interface defines static variables used for transaction status codes.

status(int) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the status on the ResponseBuilder.

status(Response.StatusType) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the status on the ResponseBuilder.

status(Response.Status) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the status on the ResponseBuilder.

status(Response.StatusType) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder with the supplied status.

status(Response.Status) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder with the supplied status.

status(int) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder with the supplied status.

STATUS_ACTIVE - Static variable in interface javax.transaction.Status

A transaction is associated with the target object and it is in the active state.

STATUS_APPROVED - Static variable in interface javax.xml.registry.infomodel.RegistryEntry

RegistryEntry has been submitted and approved.

STATUS_COMMITTED - Static variable in interface javax.transaction.Status

A transaction is associated with the target object and it has been committed.

STATUS_COMMITTING - Static variable in interface javax.transaction.Status

A transaction is associated with the target object and it is in the process of committing.

STATUS_DEPRECATED - Static variable in interface javax.xml.registry.infomodel.RegistryEntry

RegistryEntry has been deprecated.

STATUS_FAILURE - Static variable in interface javax.xml.registry.JAXRResponse

Status indicating a failure response.

STATUS_MARKED_ROLLBACK - Static variable in interface javax.transaction.Status

A transaction is associated with the target object and it has been marked for rollback, perhaps as a result of a setRollbackOnly operation.

STATUS_NO_TRANSACTION - Static variable in interface javax.transaction.Status

No transaction is currently associated with the target object.

STATUS_PREPARED - Static variable in interface javax.transaction.Status

A transaction is associated with the target object and it has been prepared.

STATUS_PREPARING - Static variable in interface javax.transaction.Status

A transaction is associated with the target object and it is in the process of preparing.

STATUS_ROLLEDBACK - Static variable in interface javax.transaction.Status

A transaction is associated with the target object and the outcome has been determined to be rollback.

STATUS_ROLLING_BACK - Static variable in interface javax.transaction.Status

A transaction is associated with the target object and it is in the process of rolling back.

STATUS_SUBMITTED - Static variable in interface javax.xml.registry.infomodel.RegistryEntry

RegistryEntry has been submitted.

STATUS_SUCCESS - Static variable in interface javax.xml.registry.JAXRResponse

Status indicating a successful response.

STATUS_UNAVAILABLE - Static variable in interface javax.xml.registry.JAXRResponse

Status indicating that the results are currently unavailable.

STATUS_UNKNOWN - Static variable in interface javax.transaction.Status

A transaction is associated with the target object but its current status cannot be determined.

STATUS_WARNING - Static variable in interface javax.xml.registry.JAXRResponse

Status indicating a successful response that included at least one warning.

STATUS_WITHDRAWN - Static variable in interface javax.xml.registry.infomodel.RegistryEntry

RegistryEntry has been withdrawn by the submitter.

statusId - Variable in class javax.servlet.jsp.jstl.core.LoopTagSupport

Attribute-exposing control

step - Variable in class javax.servlet.jsp.jstl.core.LoopTagSupport

Iteration step ('step' attribute)

StepContext - Interface in javax.batch.runtime.context

StepExecution - Interface in javax.batch.runtime

StepListener - Interface in javax.batch.api.listener

StepListener intercepts step execution.

stepSpecified - Variable in class javax.servlet.jsp.jstl.core.LoopTagSupport

Boolean flag indicating whether 'step' was specified.

Stereotype - Annotation Type in javax.enterprise.inject

Specifies that an annotation type is a stereotype.

stop() - Method in class javax.batch.api.AbstractBatchlet

Override this method if the Batchlet will end in response to the JobOperator.stop() operation.

stop() - Method in interface javax.batch.api.Batchlet

The stop method is invoked by the batch runtime as part of JobOperator.stop() method processing.

stop(long) - Method in interface javax.batch.operations.JobOperator

Request a running job execution stops.

STOP - Static variable in class javax.enterprise.deploy.shared.ActionType

A stop operation is being preformed on the DeploymentManager action command.

STOP - Static variable in class javax.enterprise.deploy.shared.CommandType

The DeploymentManger action operation being processed is stop.

stop(TargetModuleID[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Stop the application running.

stop() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject

(optional) A stop request on an in-process operation allows the operation on the current TargetModuleID to run to completion but does not process any of the remaining unprocessed TargetModuleID objects.

stop() - Method in interface javax.jms.Connection

Temporarily stops a connection's delivery of incoming messages.

stop() - Method in interface javax.jms.JMSContext

Temporarily stops the delivery of incoming messages by the JMSContext's connection.

stop() - Method in interface javax.resource.spi.ResourceAdapter

This is called when a resource adapter instance is undeployed or during application server shutdown.

stop() - Method in class javax.xml.ws.Endpoint

Stops publishing this endpoint.

store - Variable in class javax.mail.Folder

The parent store.

STORE - Static variable in class javax.mail.Provider.Type

Store - Class in javax.mail

An abstract class that models a message store and its access protocol, for storing and retrieving messages.

Store(Session, URLName) - Constructor for class javax.mail.Store

Constructor.

store - Variable in class javax.ws.rs.core.AbstractMultivaluedMap

Backing store for the [key, multi-value] pairs.

StoreClosedException - Exception in javax.mail

This exception is thrown when a method is invoked on a Messaging object and the Store that owns that object has died due to some reason.

StoreClosedException(Store) - Constructor for exception javax.mail.StoreClosedException

Constructs a StoreClosedException with no detail message.

StoreClosedException(Store, String) - Constructor for exception javax.mail.StoreClosedException

Constructs a StoreClosedException with the specified detail message.

StoreClosedException(Store, String, Exception) - Constructor for exception javax.mail.StoreClosedException

Constructs a StoreClosedException with the specified detail message and embedded exception.

StoredProcedureParameter - Annotation Type in javax.persistence

Specifies a parameter of a named stored procedure query.

StoredProcedureQuery - Interface in javax.persistence

Interface used to control stored procedure query execution.

StoreEvent - Class in javax.mail.event

This class models notifications from the Store connection.

StoreEvent(Store, int, String) - Constructor for class javax.mail.event.StoreEvent

Constructor.

StoreListener - Interface in javax.mail.event

This is the Listener interface for Store Notifications.

Streamable - Interface in javax.resource.cci

Streamable interface enables a resource adapter to extract data from an input Record or set data into an output Record as a stream of bytes.

StreamingOutput - Interface in javax.ws.rs.core

A type that may be used as a resource method return value or as the entity in a Response when the application wishes to stream the output.

StreamMessage - Interface in javax.jms

A StreamMessage object is used to send a stream of primitive types in the Java programming language.

STRING_ID - Static variable in class javax.faces.convert.BigDecimalConverter

The message identifier of the FacesMessage to be created if the conversion of the BigDecimal value to String fails.

STRING_ID - Static variable in class javax.faces.convert.BigIntegerConverter

The message identifier of the FacesMessage to be created if the conversion of the BigInteger value to String fails.

STRING_ID - Static variable in class javax.faces.convert.BooleanConverter

The message identifier of the FacesMessage to be created if the conversion of the Boolean value to String fails.

STRING_ID - Static variable in class javax.faces.convert.ByteConverter

The message identifier of the FacesMessage to be created if the conversion of the Byte value to String fails.

STRING_ID - Static variable in class javax.faces.convert.CharacterConverter

The message identifier of the FacesMessage to be created if the conversion of the Character value to String fails.

STRING_ID - Static variable in class javax.faces.convert.DateTimeConverter

The message identifier of the FacesMessage to be created if the conversion of the DateTime value to String fails.

STRING_ID - Static variable in class javax.faces.convert.DoubleConverter

The message identifier of the FacesMessage to be created if the conversion of the Double value to String fails.

STRING_ID - Static variable in class javax.faces.convert.FloatConverter

The message identifier of the FacesMessage to be created if the conversion of the Float value to String fails.

STRING_ID - Static variable in class javax.faces.convert.IntegerConverter

The message identifier of the FacesMessage to be created if the conversion of the Integer value to String fails.

STRING_ID - Static variable in class javax.faces.convert.LongConverter

The message identifier of the FacesMessage to be created if the conversion of the Long value to String fails.

STRING_ID - Static variable in class javax.faces.convert.NumberConverter

The message identifier of the FacesMessage to be created if the conversion of the Number value to String fails.

STRING_ID - Static variable in class javax.faces.convert.ShortConverter

The message identifier of the FacesMessage to be created if the conversion of the Short value to String fails.

StringHolder - Class in javax.xml.rpc.holders

StringHolder() - Constructor for class javax.xml.rpc.holders.StringHolder

StringHolder(String) - Constructor for class javax.xml.rpc.holders.StringHolder

StringTerm - Class in javax.mail.search

This class implements the match method for Strings.

StringTerm(String) - Constructor for class javax.mail.search.StringTerm

StringTerm(String, boolean) - Constructor for class javax.mail.search.StringTerm

Stub - Interface in javax.xml.rpc

The interface javax.xml.rpc.Stub is the common base interface for the stub classes.

Subgraph<T> - Interface in javax.persistence

This type represents a subgraph for an attribute node that corresponds to a Managed Type.

SubjectTerm - Class in javax.mail.search

This class implements comparisons for the message Subject header.

SubjectTerm(String) - Constructor for class javax.mail.search.SubjectTerm

Constructor.

submit() - Method in interface javax.ws.rs.client.Invocation

Submit the request for an asynchronous invocation and receive a future response back.

submit(Class<T>) - Method in interface javax.ws.rs.client.Invocation

Submit the request for an asynchronous invocation and receive a future response of the specified type back.

submit(GenericType<T>) - Method in interface javax.ws.rs.client.Invocation

Submit the request for an asynchronous invocation and receive a future response of the specified generic type back.

submit(InvocationCallback<T>) - Method in interface javax.ws.rs.client.Invocation

Submit the request for an asynchronous invocation and register an InvocationCallback to process the future result of the invocation.

subprotocols(List<String>) - Method in class javax.websocket.server.ServerEndpointConfig.Builder

Sets the subprotocols to use in the configuration.

subquery(Class<U>) - Method in interface javax.persistence.criteria.CommonAbstractCriteria

Create a subquery of the query.

Subquery<T> - Interface in javax.persistence.criteria

The Subquery interface defines functionality that is specific to subqueries.

subscribeToEvent(Class<? extends SystemEvent>, Class<?>, SystemEventListener) - Method in class javax.faces.application.Application

Install the listener instance referenced by argument listener into the application as a listener for events of type systemEventClass that originate from objects of type sourceClass.

subscribeToEvent(Class<? extends SystemEvent>, SystemEventListener) - Method in class javax.faces.application.Application

Install the listener instance referenced by argument listener into application as a listener for events of type systemEventClass.

subscribeToEvent(Class<? extends SystemEvent>, Class<?>, SystemEventListener) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.subscribeToEvent(Class, Class, javax.faces.event.SystemEventListener) on the wrapped Application object.

subscribeToEvent(Class<? extends SystemEvent>, SystemEventListener) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.subscribeToEvent(Class, javax.faces.event.SystemEventListener) on the wrapped Application object.

subscribeToEvent(Class<? extends SystemEvent>, ComponentSystemEventListener) - Method in class javax.faces.component.UIComponent

This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

subscribeToEvent(Class<? extends SystemEvent>, ComponentSystemEventListener) - Method in class javax.faces.component.UIComponentBase

Install the listener instance referenced by argument componentListener as a listener for events of type eventClass originating from this specific instance of UIComponent.

subscribeToViewEvent(Class<? extends SystemEvent>, SystemEventListener) - Method in class javax.faces.component.UIViewRoot

Install the listener instance referenced by argument listener into the UIViewRoot as a listener for events of type systemEventClass.

substring(Expression<String>, Expression<Integer>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression for substring extraction.

substring(Expression<String>, int) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression for substring extraction.

substring(Expression<String>, Expression<Integer>, Expression<Integer>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression for substring extraction.

substring(Expression<String>, int, int) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression for substring extraction.

SUCCESS - Static variable in class javax.security.auth.message.AuthStatus

Indicates that the message processing by the authentication module was successful and that the runtime is to proceed with its normal processing of the resulting message.

sum(Expression<N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an aggregate expression applying the sum operation.

sum(Expression<? extends N>, Expression<? extends N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the sum of its arguments.

sum(Expression<? extends N>, N) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the sum of its arguments.

sum(N, Expression<? extends N>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the sum of its arguments.

sumAsDouble(Expression<Float>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an aggregate expression applying the sum operation to a Float-valued expression, returning a Double result.

sumAsLong(Expression<Integer>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an aggregate expression applying the sum operation to an Integer-valued expression, returning a Long result.

SupportedValidationTarget - Annotation Type in javax.validation.constraintvalidation

Defines the target(s) a ConstraintValidator can validate.

supports(String) - Method in interface javax.security.jacc.PolicyContextHandler

This public method returns a boolean result indicating whether or not the handler supports the context object identified by the (case-sensitive) key value.

supportsExecuteWithInputAndOutputRecord() - Method in interface javax.resource.cci.ResourceAdapterMetaData

Returns true if the implementation class for the Interaction interface implements public boolean execute(InteractionSpec ispec, Record input, Record output) method; otherwise the method returns false.

supportsExecuteWithInputRecordOnly() - Method in interface javax.resource.cci.ResourceAdapterMetaData

Returns true if the implementation class for the Interaction interface implements public Record execute(InteractionSpec ispec, Record input) method; otherwise the method returns false.

supportsLocalTransactionDemarcation() - Method in interface javax.resource.cci.ResourceAdapterMetaData

Returns true if the resource adapter implements the LocalTransaction interface and supports local transaction demarcation on the underlying EIS instance through the LocalTransaction interface.

supportsResultSetType(int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether or not a resource adapter supports a type of ResultSet.

supportsResultTypeConcurrency(int, int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether or not a resource adapter supports the concurrency type in combination with the given ResultSet type/

SUSPEND - Static variable in interface javax.enterprise.concurrent.ManagedTask

Constant for the "SUSPEND" value of the TRANSACTION execution property.

suspend() - Method in interface javax.transaction.TransactionManager

Suspend the transaction currently associated with the calling thread and return a Transaction object that represents the transaction context being suspended.

Suspended - Annotation Type in javax.ws.rs.container

Inject a suspended AsyncResponse into a parameter of an invoked JAX-RS resource or sub-resource method.

SwitchBuilder - Class in javax.faces.flow.builder

Create a switch node in the current Flow.

SwitchBuilder() - Constructor for class javax.faces.flow.builder.SwitchBuilder

switchCase() - Method in class javax.faces.flow.builder.SwitchBuilder

Create a switch case in the current switch.

switchCase() - Method in class javax.faces.flow.builder.SwitchCaseBuilder

Create a new case in the current switch.

SwitchCase - Class in javax.faces.flow

Represents a case within a switch node in the flow graph.

SwitchCase() - Constructor for class javax.faces.flow.SwitchCase

SwitchCaseBuilder - Class in javax.faces.flow.builder

Create a case in the current switch.

SwitchCaseBuilder() - Constructor for class javax.faces.flow.builder.SwitchCaseBuilder

switchNode(String) - Method in class javax.faces.flow.builder.FlowBuilder

Define a particular list of cases that will be inspected in the order they are defined to determine where to go next in the flow graph.

SwitchNode - Class in javax.faces.flow

Represents a switch node in the flow graph.

SwitchNode() - Constructor for class javax.faces.flow.SwitchNode

SYNC_RECEIVE - Static variable in interface javax.resource.cci.InteractionSpec

The execution of an Interaction results in a synchronous receive of an output Record.

SYNC_SEND - Static variable in interface javax.resource.cci.InteractionSpec

Interaction Verb type: The execution of an Interaction does only a send to the target EIS instance.

SYNC_SEND_RECEIVE - Static variable in interface javax.resource.cci.InteractionSpec

Interaction Verb type: The execution of an Interaction sends a request to the EIS instance and receives response synchronously.

Synchronization - Interface in javax.transaction

The transaction manager supports a synchronization mechanism that allows the interested party to be notified before and after the transaction completes.

SynchronizationType - Enum in javax.persistence

Specifies whether the persistence context is always automatically synchronized with the current transaction or whether the persistence context must be explicitly joined to the current transaction by means of the EntityManager.joinTransaction() method.

SyncInvoker - Interface in javax.ws.rs.client

Uniform interface for synchronous invocation of HTTP methods.

SystemEvent - Class in javax.faces.event

SystemEvent is the base class for non-application specific events that can be fired by arbitrary objects.

SystemEvent(Object) - Constructor for class javax.faces.event.SystemEvent

Pass the argument source to the superclass constructor.

SystemEventListener - Interface in javax.faces.event

By implementing this class, an object indicates that it is a listener for one or more kinds of SystemEvents.

SystemEventListenerHolder - Interface in javax.faces.event

Classes that implement this interface agree to maintain a list of SystemEventListener instances for each kind of SystemEvent they can generate.

SystemException - Exception in javax.transaction

The SystemException is thrown by the transaction manager to indicate that it has encountered an unexpected error condition that prevents future transaction services from proceeding.

SystemException() - Constructor for exception javax.transaction.SystemException

SystemException(String) - Constructor for exception javax.transaction.SystemException

Create a SystemException with a given string.

SystemException(int) - Constructor for exception javax.transaction.SystemException

Create a SystemException with a given error code.

T

Table - Annotation Type in javax.persistence

Specifies the primary table for the annotated entity.

TableGenerator - Annotation Type in javax.persistence

Defines a primary key generator that may be referenced by name when a generator element is specified for the GeneratedValue annotation.

Tag - Class in javax.faces.view.facelets

The runtime must create an instance of this class for each element in the Facelets XHTML view.

Tag(Location, String, String, String, TagAttributes) - Constructor for class javax.faces.view.facelets.Tag

Tag(Tag, TagAttributes) - Constructor for class javax.faces.view.facelets.Tag

tag - Variable in class javax.faces.view.facelets.TagHandler

A reference to the Tag instance corresponding to this TagHandler instance.

Tag - Interface in javax.servlet.jsp.tagext

The interface of a classic tag handler that does not want to manipulate its body.

tag(EntityTag) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set a response entity tag.

tag(String) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set a strong response entity tag.

TAG_HANDLER_DELEGATE_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the TagHandlerDelegate class name.

TagAdapter - Class in javax.servlet.jsp.tagext

Wraps any SimpleTag and exposes it using a Tag interface.

TagAdapter(SimpleTag) - Constructor for class javax.servlet.jsp.tagext.TagAdapter

Creates a new TagAdapter that wraps the given SimpleTag and returns the parent tag when getParent() is called.

TagAttribute - Class in javax.faces.view.facelets

Representation of an XML attribute name=value pair on an XML element in a Facelet file.

TagAttribute() - Constructor for class javax.faces.view.facelets.TagAttribute

TagAttributeException - Exception in javax.faces.view.facelets

An Exception caused by a TagAttribute

TagAttributeException(TagAttribute) - Constructor for exception javax.faces.view.facelets.TagAttributeException

TagAttributeException(TagAttribute, String) - Constructor for exception javax.faces.view.facelets.TagAttributeException

TagAttributeException(TagAttribute, Throwable) - Constructor for exception javax.faces.view.facelets.TagAttributeException

TagAttributeException(TagAttribute, String, Throwable) - Constructor for exception javax.faces.view.facelets.TagAttributeException

TagAttributeException(Tag, TagAttribute) - Constructor for exception javax.faces.view.facelets.TagAttributeException

TagAttributeException(Tag, TagAttribute, String) - Constructor for exception javax.faces.view.facelets.TagAttributeException

TagAttributeException(Tag, TagAttribute, Throwable) - Constructor for exception javax.faces.view.facelets.TagAttributeException

TagAttributeException(Tag, TagAttribute, String, Throwable) - Constructor for exception javax.faces.view.facelets.TagAttributeException

TagAttributeInfo - Class in javax.servlet.jsp.tagext

Information on the attributes of a Tag, available at translation time.

TagAttributeInfo(String, boolean, String, boolean) - Constructor for class javax.servlet.jsp.tagext.TagAttributeInfo

Constructor for TagAttributeInfo.

TagAttributeInfo(String, boolean, String, boolean, boolean) - Constructor for class javax.servlet.jsp.tagext.TagAttributeInfo

JSP 2.0 Constructor for TagAttributeInfo.

TagAttributeInfo(String, boolean, String, boolean, boolean, String, boolean, boolean, String, String) - Constructor for class javax.servlet.jsp.tagext.TagAttributeInfo

JSP 2.1 Constructor for TagAttributeInfo.

TagAttributes - Class in javax.faces.view.facelets

A set of TagAttributes, usually representing all attributes on a Tag.

TagAttributes() - Constructor for class javax.faces.view.facelets.TagAttributes

TagConfig - Interface in javax.faces.view.facelets

Passed to the constructor of TagHandler subclass, it defines the document definition of the handler we are instantiating.

TagData - Class in javax.servlet.jsp.tagext

The (translation-time only) attribute/value information for a tag instance.

TagData(Object[][]) - Constructor for class javax.servlet.jsp.tagext.TagData

Constructor for TagData.

TagData(Hashtable<String, Object>) - Constructor for class javax.servlet.jsp.tagext.TagData

Constructor for a TagData.

TagDecorator - Interface in javax.faces.view.facelets

Provides the ability to completely change the Tag before it's processed for compiling with the associated TagHandler.

TagException - Exception in javax.faces.view.facelets

An Exception caused by a Tag

TagException(Tag) - Constructor for exception javax.faces.view.facelets.TagException

Wrap the argument tag so the exception can reference its information.

TagException(Tag, String) - Constructor for exception javax.faces.view.facelets.TagException

Wrap the argument tag so the exception can reference its information.

TagException(Tag, Throwable) - Constructor for exception javax.faces.view.facelets.TagException

Wrap the argument tag so the exception can reference its information.

TagException(Tag, String, Throwable) - Constructor for exception javax.faces.view.facelets.TagException

Wrap the argument tag so the exception can reference its information.

TagExtraInfo - Class in javax.servlet.jsp.tagext

Optional class provided by the tag library author to describe additional translation-time information not described in the TLD.

TagExtraInfo() - Constructor for class javax.servlet.jsp.tagext.TagExtraInfo

Sole constructor.

TagFileInfo - Class in javax.servlet.jsp.tagext

Tag information for a tag file in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.

TagFileInfo(String, String, TagInfo) - Constructor for class javax.servlet.jsp.tagext.TagFileInfo

Constructor for TagFileInfo from data in the JSP 2.0 format for TLD.

tagFiles - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo

An array describing the tag files that are defined in this tag library.

TagHandler - Class in javax.faces.view.facelets

Foundation class for FaceletHandlers associated with a markup element in a Facelet document.

TagHandler(TagConfig) - Constructor for class javax.faces.view.facelets.TagHandler

Every TagHandler instance is associated with a Tag.

TagHandlerDelegate - Class in javax.faces.view.facelets

Abstract class that defines methods relating to helping tag handler instances.

TagHandlerDelegate() - Constructor for class javax.faces.view.facelets.TagHandlerDelegate

TagHandlerDelegateFactory - Class in javax.faces.view.facelets

Abstract factory for creating instances of TagHandlerDelegate.

TagHandlerDelegateFactory() - Constructor for class javax.faces.view.facelets.TagHandlerDelegateFactory

tagId - Variable in class javax.faces.view.facelets.TagHandler

See TagConfig.getTagId().

TagInfo - Class in javax.servlet.jsp.tagext

Tag information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.

TagInfo(String, String, String, String, TagLibraryInfo, TagExtraInfo, TagAttributeInfo[]) - Constructor for class javax.servlet.jsp.tagext.TagInfo

Constructor for TagInfo from data in the JSP 1.1 format for TLD.

TagInfo(String, String, String, String, TagLibraryInfo, TagExtraInfo, TagAttributeInfo[], String, String, String, TagVariableInfo[]) - Constructor for class javax.servlet.jsp.tagext.TagInfo

Constructor for TagInfo from data in the JSP 1.2 format for TLD.

TagInfo(String, String, String, String, TagLibraryInfo, TagExtraInfo, TagAttributeInfo[], String, String, String, TagVariableInfo[], boolean) - Constructor for class javax.servlet.jsp.tagext.TagInfo

Constructor for TagInfo from data in the JSP 2.0 format for TLD.

TaglibDescriptor - Interface in javax.servlet.descriptor

This interface provides access to the <taglib> related configuration of a web application.

TagLibraryInfo - Class in javax.servlet.jsp.tagext

Translation-time information associated with a taglib directive, and its underlying TLD file.

TagLibraryInfo(String, String) - Constructor for class javax.servlet.jsp.tagext.TagLibraryInfo

Constructor.

TagLibraryValidator - Class in javax.servlet.jsp.tagext

Translation-time validator class for a JSP page.

TagLibraryValidator() - Constructor for class javax.servlet.jsp.tagext.TagLibraryValidator

Sole constructor.

tags - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo

An array describing the tags that are defined in this tag library.

TagSupport - Class in javax.servlet.jsp.tagext

A base class for defining new tag handlers implementing Tag.

TagSupport() - Constructor for class javax.servlet.jsp.tagext.TagSupport

Default constructor, all subclasses are required to define only a public constructor with the same signature, and to call the superclass constructor.

TagVariableInfo - Class in javax.servlet.jsp.tagext

Variable information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.

TagVariableInfo(String, String, String, boolean, int) - Constructor for class javax.servlet.jsp.tagext.TagVariableInfo

Constructor for TagVariableInfo.

Target - Interface in javax.enterprise.deploy.spi

A Target interface represents a single logical core server of one instance of a Java EE platform product.

target(String) - Method in interface javax.ws.rs.client.Client

Build a new web resource target.

target(URI) - Method in interface javax.ws.rs.client.Client

Build a new web resource target.

target(UriBuilder) - Method in interface javax.ws.rs.client.Client

Build a new web resource target.

target(Link) - Method in interface javax.ws.rs.client.Client

Build a new web resource target.

TargetException - Exception in javax.enterprise.deploy.spi.exceptions

This exception is to report bad target designators.

TargetException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.TargetException

Creates an new TargetException object.

TargetModuleID - Interface in javax.enterprise.deploy.spi

A TargetModuleID interface represents a unique identifier for a deployed application module.

taskAborted(Future<?>, ManagedExecutorService, Object, Throwable) - Method in interface javax.enterprise.concurrent.ManagedTaskListener

Called when a task's Future has been cancelled anytime during the life of a task.

taskDone(Future<?>, ManagedExecutorService, Object, Throwable) - Method in interface javax.enterprise.concurrent.ManagedTaskListener

Called when a submitted task has completed running, either successfully or failed due to any exception thrown from the task, task being cancelled, rejected, or aborted.

taskStarting(Future<?>, ManagedExecutorService, Object) - Method in interface javax.enterprise.concurrent.ManagedTaskListener

This method is called before the task is about to start.

taskSubmitted(Future<?>, ManagedExecutorService, Object) - Method in interface javax.enterprise.concurrent.ManagedTaskListener

Called after the task has been submitted to the Executor.

TELEPHONE_NUMBER - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.TelephoneNumber interface.

TelephoneNumber - Interface in javax.xml.registry.infomodel

A simple re-usable entity class that defines attributes of a telephone number.

TEMPDIR - Static variable in interface javax.servlet.ServletContext

The name of the ServletContext attribute which stores the private temporary directory (of type java.io.File) provided by the servlet container for the ServletContext

Temporal - Annotation Type in javax.persistence

This annotation must be specified for persistent fields or properties of type java.util.Date and java.util.Calendar.

TemporalType - Enum in javax.persistence

Type used to indicate a specific mapping of java.util.Date or java.util.Calendar.

TemporaryQueue - Interface in javax.jms

A TemporaryQueue object is a unique Queue object created for the duration of a Connection.

temporaryRedirect(URI) - Static method in class javax.ws.rs.core.Response

Create a new ResponseBuilder for a temporary redirection.

TemporaryTopic - Interface in javax.jms

A TemporaryTopic object is a unique Topic object created for the duration of a Connection.

text(T) - Static method in class javax.ws.rs.client.Entity

Create a "text/plain" entity.

Text - Interface in javax.xml.soap

A representation of a node whose value is text.

TEXT_HTML - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""text/html"" media type.

TEXT_HTML_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""text/html"" media type.

TEXT_PLAIN - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""text/plain"" media type.

TEXT_PLAIN_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""text/plain"" media type.

TEXT_XML - Static variable in class javax.ws.rs.core.MediaType

A String constant representing ""text/xml"" media type.

TEXT_XML_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing ""text/xml"" media type.

TextHandler - Interface in javax.faces.view.facelets

An interface that allows other code to identify FaceletHandlers that may provide text (String) content.

TextMessage - Interface in javax.jms

A TextMessage object is used to send a message containing a java.lang.String.

threshold - Variable in class javax.xml.ws.soap.MTOMFeature

Property for MTOM threshold value.

TIME_ID - Static variable in class javax.faces.convert.DateTimeConverter

The message identifier of the FacesMessage to be created if the conversion to Time fails.

TimedObject - Interface in javax.ejb

The TimedObject interface contains a callback method that is used to deliver timer expiration notifications.

Timeout - Annotation Type in javax.ejb

Designates a method on a stateless session bean class, a singleton session bean class, a message driven bean class, or an EJB 2.x entity bean class that should receive EJB timer expirations for that bean.

TimeoutHandler - Interface in javax.ws.rs.container

Asynchronous response suspend time-out handler.

Timer - Interface in javax.ejb

The Timer interface contains information about a timer that was created through the EJB Timer Service.

TimerConfig - Class in javax.ejb

TimerConfig is used to specify additional timer configuration settings during timer creation.

TimerConfig() - Constructor for class javax.ejb.TimerConfig

TimerConfig(Serializable, boolean) - Constructor for class javax.ejb.TimerConfig

TimerHandle - Interface in javax.ejb

The TimerHandle interface allows the bean provider to obtain a serializable timer handle that may be persisted.

TimerService - Interface in javax.ejb

The TimerService interface provides enterprise bean components with access to the container-provided Timer Service.

TimeStatistic - Interface in javax.management.j2ee.statistics

Specifies standard timing measurements.

timezone(String) - Method in class javax.ejb.ScheduleExpression

Set the timezone.

title(String) - Method in interface javax.ws.rs.core.Link.Builder

Convenience method to set a title on this link.

TITLE - Static variable in class javax.ws.rs.core.Link

Title link param from RFC 5988.

tlibversion - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo

The version of the tag library.

TMENDRSCAN - Static variable in interface javax.transaction.xa.XAResource

Ends a recovery scan.

TMFAIL - Static variable in interface javax.transaction.xa.XAResource

Disassociates the caller and marks the transaction branch rollback-only.

TMJOIN - Static variable in interface javax.transaction.xa.XAResource

Caller is joining existing transaction branch.

TMNOFLAGS - Static variable in interface javax.transaction.xa.XAResource

Use TMNOFLAGS to indicate no flags value is selected.

TMONEPHASE - Static variable in interface javax.transaction.xa.XAResource

Caller is using one-phase optimization.

TMRESUME - Static variable in interface javax.transaction.xa.XAResource

Caller is resuming association with a suspended transaction branch.

TMSTARTRSCAN - Static variable in interface javax.transaction.xa.XAResource

Starts a recovery scan.

TMSUCCESS - Static variable in interface javax.transaction.xa.XAResource

Disassociates caller from a transaction branch.

TMSUSPEND - Static variable in interface javax.transaction.xa.XAResource

Caller is suspending (not ending) its association with a transaction branch.

TO - Static variable in class javax.mail.Message.RecipientType

The "To" (primary) recipients.

TO_FLOW_DOCUMENT_ID_ATTR_NAME - Static variable in interface javax.faces.event.ActionListener

The presence of this component attribute on an ActionSource component will cause the default ActionListener to interpret the value of the attribute as the toFlowDocumentId value to pass to NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String, java.lang.String).

TO_FLOW_DOCUMENT_ID_REQUEST_PARAM_NAME - Static variable in class javax.faces.flow.FlowHandler

Components that are rendered by Renderers of component-family javax.faces.OutcomeTarget must use this constant as the parameter name for a parameter representing the defining document id of the flow that this component will cause to be entered.

toArray() - Method in interface javax.persistence.Tuple

Return the values of the result tuple elements as an array.

toBigDecimal(Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Typecast.

toBigInteger(Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Typecast.

toCookie() - Method in class javax.ws.rs.core.NewCookie

Obtain a new instance of a Cookie with the same name, value, path, domain and version as this NewCookie.

toDouble(Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Typecast.

toFloat(Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Typecast.

toFlowDocumentId(String) - Method in class javax.faces.flow.builder.NavigationCaseBuilder

Set the to-flow-document-id of the current navigation case.

toInteger(Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Typecast.

toLong(Expression<? extends Number>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Typecast.

Topic - Interface in javax.jms

A Topic object encapsulates a provider-specific topic name.

TopicConnection - Interface in javax.jms

A TopicConnection object is an active connection to a publish/subscribe JMS provider.

TopicConnectionFactory - Interface in javax.jms

A client uses a TopicConnectionFactory object to create TopicConnection objects with a publish/subscribe JMS provider.

TopicPublisher - Interface in javax.jms

A client uses a TopicPublisher object to publish messages on a topic.

TopicRequestor - Class in javax.jms

The TopicRequestor helper class simplifies making service requests.

TopicRequestor(TopicSession, Topic) - Constructor for class javax.jms.TopicRequestor

Constructor for the TopicRequestor class.

TopicSession - Interface in javax.jms

A TopicSession object provides methods for creating TopicPublisher, TopicSubscriber, and TemporaryTopic objects.

TopicSubscriber - Interface in javax.jms

A client uses a TopicSubscriber object to receive messages that have been published to a topic.

toResponse(E) - Method in interface javax.ws.rs.ext.ExceptionMapper

Map an exception to a Response.

toResult(ResultSet) - Static method in class javax.servlet.jsp.jstl.sql.ResultSupport

Converts a ResultSet object to a Result object.

toResult(ResultSet, int) - Static method in class javax.servlet.jsp.jstl.sql.ResultSupport

Converts maxRows of a ResultSet object to a Result object.

toString() - Method in class javax.ejb.ScheduleExpression

toString() - Method in class javax.ejb.TimerConfig

toString() - Method in class javax.enterprise.deploy.shared.ActionType

Return the string name of this ActionType or the integer value if outside the bounds of the table

toString() - Method in class javax.enterprise.deploy.shared.CommandType

Return the string name of this CommandType or the integer value if outside the bounds of the table

toString() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType

Return the string name of this DConfigBeanVersionType or the integer value if outside the bounds of the table

toString() - Method in class javax.enterprise.deploy.shared.ModuleType

Return the string name of this ModuleType or the integer value if outside the bounds of the table

toString() - Method in class javax.enterprise.deploy.shared.StateType

Return the string name of this StateType or the integer value if outside the bounds of the table

toString() - Method in interface javax.enterprise.deploy.spi.TargetModuleID

Retrieve the identifier representing the deployed module.

toString() - Method in class javax.enterprise.util.AnnotationLiteral

toString() - Method in class javax.enterprise.util.TypeLiteral

toString() - Method in class javax.faces.application.FacesMessage.Severity

Return a String representation of this FacesMessage.Severity instance.

toString() - Method in class javax.faces.application.NavigationCase

toString() - Method in class javax.faces.application.NavigationCaseWrapper

toString() - Method in class javax.faces.application.Resource

Call through to Resource.getRequestPath() and return the result.

toString() - Method in enum javax.faces.component.html.HtmlBody.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlColumn.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlCommandButton.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlCommandLink.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlDataTable.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlDoctype.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlForm.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlGraphicImage.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlHead.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlInputFile.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlInputHidden.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlInputSecret.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlInputText.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlInputTextarea.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlMessage.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlMessages.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlOutcomeTargetButton.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlOutcomeTargetLink.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlOutputFormat.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlOutputLabel.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlOutputLink.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlOutputText.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlPanelGrid.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlPanelGroup.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlSelectBooleanCheckbox.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlSelectManyCheckbox.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlSelectManyListbox.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlSelectManyMenu.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlSelectOneListbox.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlSelectOneMenu.PropertyKeys

toString() - Method in enum javax.faces.component.html.HtmlSelectOneRadio.PropertyKeys

toString() - Method in class javax.faces.event.PhaseId

Return a String representation of this PhaseId instance.

toString() - Method in class javax.faces.view.facelets.Tag

toString() - Method in class javax.faces.view.facelets.TagHandler

toString() - Method in class javax.faces.view.Location

toString() - Method in interface javax.jms.Queue

Returns a string representation of this object.

toString() - Method in interface javax.jms.Topic

Returns a string representation of this object.

toString() - Method in interface javax.json.JsonNumber

Returns a JSON text representation of the JSON number.

toString() - Method in interface javax.json.JsonValue

Returns JSON text for this JSON value.

toString() - Method in class javax.mail.Address

Return a String representation of this address object.

toString() - Method in class javax.mail.FetchProfile.Item

Include the name in the toString return value for debugging.

toString() - Method in class javax.mail.Folder

override the default toString(), it will return the String from Folder.getFullName() or if that is null, it will use the default toString() behavior.

toString() - Method in exception javax.mail.internet.AddressException

toString() - Method in class javax.mail.internet.ContentDisposition

Retrieve a RFC2045 style string representation of this ContentDisposition.

toString() - Method in class javax.mail.internet.ContentType

Retrieve a RFC2045 style string representation of this Content-Type.

toString() - Method in class javax.mail.internet.InternetAddress

Convert this address into a RFC 822 / RFC 2047 encoded address.

toString(Address[]) - Static method in class javax.mail.internet.InternetAddress

Convert the given array of InternetAddress objects into a comma separated sequence of address strings.

toString(Address[], int) - Static method in class javax.mail.internet.InternetAddress

Convert the given array of InternetAddress objects into a comma separated sequence of address strings.

toString() - Method in class javax.mail.internet.NewsAddress

Convert this address into a RFC 1036 address.

toString(Address[]) - Static method in class javax.mail.internet.NewsAddress

Convert the given array of NewsAddress objects into a comma separated sequence of address strings.

toString() - Method in class javax.mail.internet.ParameterList

Convert this ParameterList into a MIME String.

toString(int) - Method in class javax.mail.internet.ParameterList

Convert this ParameterList into a MIME String.

toString() - Method in class javax.mail.Message.RecipientType

toString() - Method in exception javax.mail.MessagingException

Override toString method to provide information on nested exceptions.

toString() - Method in class javax.mail.Provider

Overrides Object.toString()

toString() - Method in class javax.mail.Provider.Type

toString() - Method in class javax.mail.Service

Return getURLName.toString() if this service has a URLName, otherwise it will return the default toString.

toString() - Method in class javax.mail.URLName

Constructs a string representation of this URLName.

toString(Expression<Character>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Typecast.

toString() - Method in class javax.security.auth.message.AuthStatus

toString() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo

Returns a String representation of this TagAttributeInfo, suitable for debugging purposes.

toString() - Method in class javax.websocket.CloseReason

Converts the CloseReason to a debug-friendly string.

toString() - Method in class javax.ws.rs.core.AbstractMultivaluedMap

toString() - Method in class javax.ws.rs.core.CacheControl

Convert the cache control to a string suitable for use as the value of the corresponding HTTP header.

toString() - Method in class javax.ws.rs.core.Cookie

Convert the cookie to a string suitable for use as the value of the corresponding HTTP header.

toString() - Method in class javax.ws.rs.core.EntityTag

Convert the entity tag to a string suitable for use as the value of the corresponding HTTP header.

toString() - Method in class javax.ws.rs.core.GenericEntity

toString() - Method in class javax.ws.rs.core.GenericType

toString() - Method in class javax.ws.rs.core.Link

Returns a string representation as a link header (RFC 5988).

toString() - Method in class javax.ws.rs.core.MediaType

Convert the media type to a string suitable for use as the value of a corresponding HTTP header.

toString() - Method in class javax.ws.rs.core.NewCookie

Convert the cookie to a string suitable for use as the value of the corresponding HTTP header.

toString() - Method in enum javax.ws.rs.core.Response.Status

Get the reason phrase.

toString() - Method in class javax.ws.rs.core.Variant

toString(T) - Method in interface javax.ws.rs.ext.ParamConverter

Convert the supplied value to a String.

toString(T) - Method in interface javax.ws.rs.ext.RuntimeDelegate.HeaderDelegate

Convert the supplied value to a String.

toString() - Method in class javax.xml.bind.helpers.ValidationEventImpl

Returns a string representation of this object in a format helpful to debugging.

toString() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Returns a string representation of this object in a format helpful to debugging.

toString() - Method in exception javax.xml.bind.JAXBException

Returns a short description of this JAXBException.

toString() - Method in exception javax.xml.bind.TypeConstraintException

Returns a short description of this TypeConstraintException.

toString() - Method in interface javax.xml.registry.Query

Returns the String representing the query.

toString() - Method in class javax.xml.rpc.ParameterMode

Returns a String describing this ParameterMode object.

toString() - Method in class javax.xml.ws.EndpointReference

Displays EPR infoset for debugging convenience.

toTemplate() - Method in class javax.ws.rs.core.UriBuilder

Get the URI template string represented by this URI builder.

toUnicodeString() - Method in class javax.mail.internet.InternetAddress

Returns a properly formatted address (RFC 822 syntax) of Unicode characters.

toViewId(String) - Method in class javax.faces.flow.builder.NavigationCaseBuilder

Set the to-view-id of the current navigation case.

toXML() - Method in interface javax.xml.registry.infomodel.RegistryObject

Returns a registry provider specific XML representation of this Object.

trace() - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP TRACE method for the current request asynchronously.

trace(Class<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP TRACE method for the current request asynchronously.

trace(GenericType<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP TRACE method for the current request asynchronously.

trace(InvocationCallback<T>) - Method in interface javax.ws.rs.client.AsyncInvoker

Invoke HTTP TRACE method for the current request asynchronously.

trace() - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP TRACE method for the current request synchronously.

trace(Class<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP TRACE method for the current request synchronously.

trace(GenericType<T>) - Method in interface javax.ws.rs.client.SyncInvoker

Invoke HTTP TRACE method for the current request synchronously.

TRANSACTION - Static variable in interface javax.enterprise.concurrent.ManagedTask

Execution property to be returned in ManagedTask.getExecutionProperties() or ContextService.createContextualProxy() to inform the Java™ EE Product Provider under which transaction should the task or proxy method of contextual proxy object be executed in.

Transaction - Interface in javax.transaction

The Transaction interface allows operations to be performed against the transaction in the target Transaction object.

Transactional - Annotation Type in javax.transaction

The javax.transaction.Transactional annotation provides the application the ability to declaratively control transaction boundaries on CDI managed beans, as well as classes defined as managed beans by the Java EE specification, at both the class and method level where method level annotations override those at the class level.

Transactional.TxType - Enum in javax.transaction

The TxType element of the annotation indicates whether a bean method is to be executed within a transaction context where the values provide the following corresponding behavior.

TransactionalException - Exception in javax.transaction

The TransactionalException thrown from the Transactional interceptors implementation contains the original exception as its nested exception and is a RuntimeException, therefore, by default any transaction that was started as a result of a Transactional annotation earlier in the call stream will be marked for rollback as a result of the TransactionalException being thrown by the Transactional interceptor of the second bean.

TransactionalException(String, Throwable) - Constructor for exception javax.transaction.TransactionalException

TransactionAttribute - Annotation Type in javax.ejb

The TransactionAttribute annotation specifies whether the container is to invoke a business method within a transaction context.

TransactionAttributeType - Enum in javax.ejb

The enum TransactionAttributeType is used with the TransactionAttribute annotation to specify whether the methods of a session bean or message driven bean are called with a valid transaction context.

TransactionContext - Class in javax.resource.spi.work

A standard WorkContext that allows a Work instance to propagate transaction related context information from an EIS to an application server.

TransactionContext() - Constructor for class javax.resource.spi.work.TransactionContext

TransactionInProgressException - Exception in javax.jms

This exception is thrown when an operation is invalid because a transaction is in progress.

TransactionInProgressException(String, String) - Constructor for exception javax.jms.TransactionInProgressException

Constructs a TransactionInProgressException with the specified reason and error code.

TransactionInProgressException(String) - Constructor for exception javax.jms.TransactionInProgressException

Constructs a TransactionInProgressException with the specified reason.

TransactionInProgressRuntimeException - Exception in javax.jms

This unchecked exception is thrown when an operation is invalid because a transaction is in progress.

TransactionInProgressRuntimeException(String) - Constructor for exception javax.jms.TransactionInProgressRuntimeException

Constructs a TransactionInProgressRuntimeException with the specified detail message

TransactionInProgressRuntimeException(String, String) - Constructor for exception javax.jms.TransactionInProgressRuntimeException

Constructs a TransactionInProgressRuntimeException with the specified detail message and error code.

TransactionInProgressRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.TransactionInProgressRuntimeException

Constructs a TransactionInProgressRuntimeException with the specified detail message, error code and cause

TransactionManagement - Annotation Type in javax.ejb

Specifies whether a session bean or message driven bean has container managed transactions or bean managed transactions.

TransactionManagementType - Enum in javax.ejb

The enum TransactionManagementType is used with the TransactionManagement annotation to specify whether container-managed or bean-managed transaction management is used.

TransactionManager - Interface in javax.transaction

The TransactionManager interface defines the methods that allow an application server to manage transaction boundaries.

TransactionPhase - Enum in javax.enterprise.event

Distinguishes the various kinds of transactional observer methods from regular observer methods which are notified immediately.

TransactionRequiredException - Exception in javax.persistence

Thrown by the persistence provider when a transaction is required but is not active.

TransactionRequiredException() - Constructor for exception javax.persistence.TransactionRequiredException

Constructs a new TransactionRequiredException exception with null as its detail message.

TransactionRequiredException(String) - Constructor for exception javax.persistence.TransactionRequiredException

Constructs a new TransactionRequiredException exception with the specified detail message.

TransactionRequiredException - Exception in javax.transaction

This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.

TransactionRequiredException() - Constructor for exception javax.transaction.TransactionRequiredException

TransactionRequiredException(String) - Constructor for exception javax.transaction.TransactionRequiredException

TransactionRequiredLocalException - Exception in javax.ejb

This exception is thrown to a local client to indicate that a request carried a null transaction context, but the target object requires an active transaction.

TransactionRequiredLocalException() - Constructor for exception javax.ejb.TransactionRequiredLocalException

Constructs a TransactionRequiredLocalException with no detail message.

TransactionRequiredLocalException(String) - Constructor for exception javax.ejb.TransactionRequiredLocalException

Constructs an TransactionRequiredLocalException with the specified detailed message.

TransactionRolledBackException - Exception in javax.jms

This exception must be thrown when a call to Session.commit results in a rollback of the current transaction.

TransactionRolledBackException(String, String) - Constructor for exception javax.jms.TransactionRolledBackException

Constructs a TransactionRolledBackException with the specified reason and error code.

TransactionRolledBackException(String) - Constructor for exception javax.jms.TransactionRolledBackException

Constructs a TransactionRolledBackException with the specified reason.

TransactionRolledbackException - Exception in javax.transaction

This exception indicates that the transaction associated with processing of the request has been rolled back, or it has been marked to roll back.

TransactionRolledbackException() - Constructor for exception javax.transaction.TransactionRolledbackException

TransactionRolledbackException(String) - Constructor for exception javax.transaction.TransactionRolledbackException

TransactionRolledbackLocalException - Exception in javax.ejb

This exception is thrown to a local client to indicate that the transaction associated with processing of the request has been rolled back, or marked to roll back.

TransactionRolledbackLocalException() - Constructor for exception javax.ejb.TransactionRolledbackLocalException

Constructs a TransactionRolledbackLocalException with no detail message.

TransactionRolledbackLocalException(String) - Constructor for exception javax.ejb.TransactionRolledbackLocalException

Constructs a TransactionRolledbackLocalException with the specified detailed message.

TransactionRolledbackLocalException(String, Exception) - Constructor for exception javax.ejb.TransactionRolledbackLocalException

Constructs a TransactionRolledbackLocalException with the specified detail message and a nested exception.

TransactionRolledBackRuntimeException - Exception in javax.jms

This unchecked exception must be thrown when a call to JMSContext.commit results in a rollback of the current transaction.

TransactionRolledBackRuntimeException(String) - Constructor for exception javax.jms.TransactionRolledBackRuntimeException

Constructs a TransactionRolledBackRuntimeException with the specified detail message

TransactionRolledBackRuntimeException(String, String) - Constructor for exception javax.jms.TransactionRolledBackRuntimeException

Constructs a TransactionRolledBackRuntimeException with the specified detail message and error code.

TransactionRolledBackRuntimeException(String, String, Throwable) - Constructor for exception javax.jms.TransactionRolledBackRuntimeException

Constructs a TransactionRolledBackRuntimeException with the specified detail message, error code and cause

TransactionScoped - Annotation Type in javax.transaction

The javax.transaction.TransactionScoped annotation provides the ability to specify a standard CDI scope to define bean instances whose lifecycle is scoped to the currently active JTA transaction.

TransactionSupport - Interface in javax.resource.spi

This interface may be optionally implemented by a ManagedConnectionFactory to provide its level of transaction support at runtime.

TransactionSupport.TransactionSupportLevel - Enum in javax.resource.spi

An enumerated type that represents the levels of transaction support a resource adapter may support.

TransactionSynchronizationRegistry - Interface in javax.transaction

This interface is intended for use by system level application server components such as persistence managers, resource adapters, as well as EJB and Web application components.

transform(ClassLoader, String, Class<?>, ProtectionDomain, byte[]) - Method in interface javax.persistence.spi.ClassTransformer

Invoked when a class is being loaded or redefined.

Transient - Annotation Type in javax.persistence

Specifies that the property or field is not persistent.

TransientReference - Annotation Type in javax.enterprise.inject

If a parameter annotated with @TransientReference resolves to a dependent scoped bean, then the bean will be destroyed after the invocation completes.

TransientStateHelper - Interface in javax.faces.component

Define a Map-like contract that makes it easier for components to implement TransientStateHolder.

TransientStateHolder - Interface in javax.faces.component

This interface is implemented by classes that need to save state that is expected to be available only within the scope of the current request.

transition(FacesContext, Flow, Flow, FlowCallNode, String) - Method in class javax.faces.flow.FlowHandler

Perform a transition in the flow graph for the current user's ClientWindow.

TRANSPORT - Static variable in class javax.mail.Provider.Type

Transport - Class in javax.mail

An abstract class that models a message transport.

Transport(Session, URLName) - Constructor for class javax.mail.Transport

Constructor.

TransportAdapter - Class in javax.mail.event

The adapter which receives Transport events.

TransportAdapter() - Constructor for class javax.mail.event.TransportAdapter

TransportEvent - Class in javax.mail.event

This class models Transport events.

TransportEvent(Transport, int, Address[], Address[], Address[], Message) - Constructor for class javax.mail.event.TransportEvent

Constructor.

TransportListener - Interface in javax.mail.event

This is the Listener interface for Transport events

traversableResolver(TraversableResolver) - Method in interface javax.validation.Configuration

Defines the traversable resolver used.

TraversableResolver - Interface in javax.validation

Contract determining if a property can be accessed by the Bean Validation provider.

traversableResolver(TraversableResolver) - Method in interface javax.validation.ValidatorContext

Defines the traversable resolver implementation used by the Validator.

treat(Join<X, T>, Class<V>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Downcast Join object to the specified type.

treat(CollectionJoin<X, T>, Class<E>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Downcast CollectionJoin object to the specified type.

treat(SetJoin<X, T>, Class<E>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Downcast SetJoin object to the specified type.

treat(ListJoin<X, T>, Class<E>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Downcast ListJoin object to the specified type.

treat(MapJoin<X, K, T>, Class<V>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Downcast MapJoin object to the specified type.

treat(Path<X>, Class<T>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Downcast Path object to the specified type.

treat(Root<X>, Class<T>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Downcast Root object to the specified type.

Trigger - Interface in javax.enterprise.concurrent

Triggers allow application developers to plug in rules for when and how often a task should run.

trim(Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to trim blanks from both ends of a string.

trim(CriteriaBuilder.Trimspec, Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to trim blanks from a string.

trim(Expression<Character>, Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to trim character from both ends of a string.

trim(CriteriaBuilder.Trimspec, Expression<Character>, Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to trim character from a string.

trim(char, Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to trim character from both ends of a string.

trim(CriteriaBuilder.Trimspec, char, Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression to trim character from a string.

TRUE - Static variable in interface javax.json.JsonValue

JSON true value.

trustStore(KeyStore) - Method in class javax.ws.rs.client.ClientBuilder

Set the client-side trust store.

TrustStoreCallback - Class in javax.security.auth.message.callback

Callback for trusted certificate KeyStore.

TrustStoreCallback() - Constructor for class javax.security.auth.message.callback.TrustStoreCallback

Create a TrustStoreCallback.

TryCatchFinally - Interface in javax.servlet.jsp.tagext

The auxiliary interface of a Tag, IterationTag or BodyTag tag handler that wants additional hooks for managing resources.

tuple(Selection<?>...) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create a tuple-valued selection item.

Tuple - Interface in javax.persistence

Interface for extracting the elements of a query result tuple.

TupleElement<X> - Interface in javax.persistence

The TupleElement interface defines an element that is returned in a query result tuple.

TX_CONCURRENT_WORK_DISALLOWED - Static variable in exception javax.resource.spi.work.WorkException

Indicates that concurrent work within a transaction is disallowed.

TX_RECREATE_FAILED - Static variable in exception javax.resource.spi.work.WorkException

Indicates a failure in recreating the specified transaction context.

TYPE - Static variable in class javax.el.ELResolver

The attribute name of the named attribute in the FeatureDescriptor that specifies the runtime type of the variable or property.

type - Variable in class javax.mail.event.ConnectionEvent

The event type.

type - Variable in class javax.mail.event.FolderEvent

The event type.

type - Variable in class javax.mail.event.MessageChangedEvent

The event type.

type - Variable in class javax.mail.event.MessageCountEvent

The event type.

type - Variable in class javax.mail.event.StoreEvent

The event type.

type - Variable in class javax.mail.event.TransportEvent

The event type.

type - Variable in class javax.mail.Message.RecipientType

The type of recipient, usually the name of a corresponding Internet standard header.

type() - Method in interface javax.persistence.criteria.Path

Create an expression corresponding to the type of the path.

Type<X> - Interface in javax.persistence.metamodel

Instances of the type Type represent persistent object or attribute types.

type(String) - Method in interface javax.ws.rs.core.Link.Builder

Convenience method to set a type on this link.

TYPE - Static variable in class javax.ws.rs.core.Link

Type link param from RFC 5988.

type(MediaType) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the message entity media type.

type(String) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set the message entity media type.

Type.PersistenceType - Enum in javax.persistence.metamodel

TYPE_MESSAGE_ID - Static variable in class javax.faces.validator.DoubleRangeValidator

The message identifier of the FacesMessage to be created if the current value of this component is not of the correct type.

TYPE_MESSAGE_ID - Static variable in class javax.faces.validator.LongRangeValidator

The message identifier of the FacesMessage to be created if the current value of this component is not of the correct type.

TypeConstraintException - Exception in javax.xml.bind

This exception indicates that a violation of a dynamically checked type constraint was detected.

TypeConstraintException(String) - Constructor for exception javax.xml.bind.TypeConstraintException

Construct a TypeConstraintException with the specified detail message.

TypeConstraintException(String, String) - Constructor for exception javax.xml.bind.TypeConstraintException

Construct a TypeConstraintException with the specified detail message and vendor specific errorCode.

TypeConstraintException(Throwable) - Constructor for exception javax.xml.bind.TypeConstraintException

Construct a TypeConstraintException with a linkedException.

TypeConstraintException(String, Throwable) - Constructor for exception javax.xml.bind.TypeConstraintException

Construct a TypeConstraintException with the specified detail message and linkedException.

TypeConstraintException(String, String, Throwable) - Constructor for exception javax.xml.bind.TypeConstraintException

Construct a TypeConstraintException with the specified detail message, vendor specific errorCode, and linkedException.

TypeConverter - Class in javax.el

A convenient class for writing an ELResolver to do custom type conversions.

TypeConverter() - Constructor for class javax.el.TypeConverter

Typed - Annotation Type in javax.enterprise.inject

Restricts the bean types of a bean.

TypedQuery<X> - Interface in javax.persistence

Interface used to control the execution of typed queries.

TypeLiteral<T> - Class in javax.enterprise.util

Supports inline instantiation of objects that represent parameterized types with actual type parameters.

TypeLiteral() - Constructor for class javax.enterprise.util.TypeLiteral

TypeMapping - Interface in javax.xml.rpc.encoding

The javax.xml.rpc.encoding.TypeMapping is the base interface for the representation of a type mapping.

TypeMappingRegistry - Interface in javax.xml.rpc.encoding

The interface javax.xml.rpc.encoding.TypeMappingRegistry defines a registry of TypeMapping instances for various encoding styles.

U

UIColumn - Class in javax.faces.component

UIColumn is a UIComponent that represents a single column of data within a parent UIData component.

UIColumn() - Constructor for class javax.faces.component.UIColumn

Create a new UIColumn instance with default property values.

UICommand - Class in javax.faces.component

UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".

UICommand() - Constructor for class javax.faces.component.UICommand

Create a new UICommand instance with default property values.

UIComponent - Class in javax.faces.component

UIComponent is the base class for all user interface components in JavaServer Faces.

UIComponent() - Constructor for class javax.faces.component.UIComponent

UIComponentBase - Class in javax.faces.component

UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.

UIComponentBase() - Constructor for class javax.faces.component.UIComponentBase

UIComponentBodyTag - Class in javax.faces.webapp

Deprecated.
All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.

UIComponentBodyTag() - Constructor for class javax.faces.webapp.UIComponentBodyTag

Deprecated.

UIComponentClassicTagBase - Class in javax.faces.webapp

UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view.

UIComponentClassicTagBase() - Constructor for class javax.faces.webapp.UIComponentClassicTagBase

UIComponentELTag - Class in javax.faces.webapp

UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.

UIComponentELTag() - Constructor for class javax.faces.webapp.UIComponentELTag

UIComponentTag - Class in javax.faces.webapp

Deprecated.
Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.

UIComponentTag() - Constructor for class javax.faces.webapp.UIComponentTag

Deprecated.

UIComponentTagBase - Class in javax.faces.webapp

UIComponentTagBase is the base class for all JSP tags that correspond to a UIComponent instance in the view.

UIComponentTagBase() - Constructor for class javax.faces.webapp.UIComponentTagBase

UID - Static variable in class javax.mail.UIDFolder.FetchProfileItem

UID is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder.

UIData - Class in javax.faces.component

UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).

UIData() - Constructor for class javax.faces.component.UIData

Create a new UIData instance with default property values.

UIDFolder - Interface in javax.mail

The UIDFolder interface is implemented by Folders that can support the "disconnected" mode of operation, by providing unique-ids for messages in the folder.

UIDFolder.FetchProfileItem - Class in javax.mail

A fetch profile item for fetching UIDs.

UIDFolder.FetchProfileItem(String) - Constructor for class javax.mail.UIDFolder.FetchProfileItem

UIForm - Class in javax.faces.component

UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.

UIForm() - Constructor for class javax.faces.component.UIForm

Create a new UIForm instance with default property values.

UIGraphic - Class in javax.faces.component

UIGraphic is a UIComponent that displays a graphical image to the user.

UIGraphic() - Constructor for class javax.faces.component.UIGraphic

Create a new UIGraphic instance with default property values.

UIInput - Class in javax.faces.component

UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.

UIInput() - Constructor for class javax.faces.component.UIInput

Create a new UIInput instance with default property values.

UIMessage - Class in javax.faces.component

This component is responsible for displaying messages for a specific UIComponent, identified by a clientId or component id relative to the closest ancestor NamingContainer.

UIMessage() - Constructor for class javax.faces.component.UIMessage

Create a new UIMessage instance with default property values.

UIMessages - Class in javax.faces.component

The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.

UIMessages() - Constructor for class javax.faces.component.UIMessages

Create a new UIMessages instance with default property values.

UINamingContainer - Class in javax.faces.component

UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.

UINamingContainer() - Constructor for class javax.faces.component.UINamingContainer

Create a new UINamingContainer instance with default property values.

UIOutcomeTarget - Class in javax.faces.component

This component is paired with the javax.faces.Button or javax.faces.Link renderers and encapsulates properties relating to the rendering of outcomes directly to the response.

UIOutcomeTarget() - Constructor for class javax.faces.component.UIOutcomeTarget

Create a new UIOutcomeTarget instance with default property values.

UIOutput - Class in javax.faces.component

UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.

UIOutput() - Constructor for class javax.faces.component.UIOutput

Create a new UIOutput instance with default property values.

UIPanel - Class in javax.faces.component

UIPanel is a UIComponent that manages the layout of its child components.

UIPanel() - Constructor for class javax.faces.component.UIPanel

Create a new UIPanel instance with default property values.

UIParameter - Class in javax.faces.component

UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.

UIParameter() - Constructor for class javax.faces.component.UIParameter

Create a new UIParameter instance with default property values.

UISelectBoolean - Class in javax.faces.component

UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.

UISelectBoolean() - Constructor for class javax.faces.component.UISelectBoolean

Create a new UISelectBoolean instance with default property values.

UISelectItem - Class in javax.faces.component

UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.

UISelectItem() - Constructor for class javax.faces.component.UISelectItem

Create a new UISelectItem instance with default property values.

UISelectItems - Class in javax.faces.component

UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.

UISelectItems() - Constructor for class javax.faces.component.UISelectItems

Create a new UISelectItems instance with default property values.

UISelectMany - Class in javax.faces.component

UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.

UISelectMany() - Constructor for class javax.faces.component.UISelectMany

Create a new UISelectMany instance with default property values.

UISelectOne - Class in javax.faces.component

UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.

UISelectOne() - Constructor for class javax.faces.component.UISelectOne

Create a new UISelectOne instance with default property values.

UIViewAction - Class in javax.faces.component

UIViewAction represents a method invocation that occurs during the request processing lifecycle, usually in response to an initial request, as opposed to a postback.

UIViewAction() - Constructor for class javax.faces.component.UIViewAction

Create a new UIViewAction instance with default property values.

UIViewParameter - Class in javax.faces.component

UIViewParameter represents a binding between a request parameter and a model property or UIViewRoot property.

UIViewParameter() - Constructor for class javax.faces.component.UIViewParameter

Create a new UIViewParameter instance with default property values.

UIViewParameter.Reference - Class in javax.faces.component

Inner class to encapsulate a UIViewParameter instance so that it may be safely referenced regardless of whether or not the current view is the same as the view in which this UIViewParameter resides.

UIViewParameter.Reference(FacesContext, UIViewParameter, int, String) - Constructor for class javax.faces.component.UIViewParameter.Reference

Construct a reference to a UIViewParameter.

UIViewRoot - Class in javax.faces.component

UIViewRoot is the UIComponent that represents the root of the UIComponent tree.

UIViewRoot() - Constructor for class javax.faces.component.UIViewRoot

Create a new UIViewRoot instance with default property values.

UnavailableException - Exception in javax.resource.spi

This is thrown to indicate that a service is unavailable.

UnavailableException() - Constructor for exception javax.resource.spi.UnavailableException

Constructs a new instance with null as its detail message.

UnavailableException(String) - Constructor for exception javax.resource.spi.UnavailableException

Constructs a new instance with the specified detail message.

UnavailableException(Throwable) - Constructor for exception javax.resource.spi.UnavailableException

Constructs a new throwable with the specified cause.

UnavailableException(String, Throwable) - Constructor for exception javax.resource.spi.UnavailableException

Constructs a new throwable with the specified detail message and cause.

UnavailableException(String, String) - Constructor for exception javax.resource.spi.UnavailableException

Constructs a new throwable with the specified detail message and an error code.

UnavailableException - Exception in javax.servlet

Defines an exception that a servlet or filter throws to indicate that it is permanently or temporarily unavailable.

UnavailableException(Servlet, String) - Constructor for exception javax.servlet.UnavailableException

Deprecated.
As of Java Servlet API 2.2, use UnavailableException.UnavailableException(String) instead.

UnavailableException(int, Servlet, String) - Constructor for exception javax.servlet.UnavailableException

Deprecated.
As of Java Servlet API 2.2, use UnavailableException.UnavailableException(String, int) instead.

UnavailableException(String) - Constructor for exception javax.servlet.UnavailableException

Constructs a new exception with a descriptive message indicating that the servlet is permanently unavailable.

UnavailableException(String, int) - Constructor for exception javax.servlet.UnavailableException

Constructs a new exception with a descriptive message indicating that the servlet is temporarily unavailable and giving an estimate of how long it will be unavailable.

UNBOUNDED_BUFFER - Static variable in class javax.servlet.jsp.JspWriter

Constant indicating that the Writer is buffered and is unbounded; this is used in BodyContent.

unConfirmAssociation(Association) - Method in interface javax.xml.registry.BusinessLifeCycleManager

Undoes a previous confirmation of this Association by the User associated with the caller.

UNDEFINED - Static variable in exception javax.resource.spi.work.WorkException

Undefined error code.

UNDEPLOY - Static variable in class javax.enterprise.deploy.shared.CommandType

The DeploymentManger action operation being processed is undeploy.

undeploy(TargetModuleID[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager

Remove the application from the target server.

unDeprecateObjects(Collection) - Method in interface javax.xml.registry.LifeCycleManager

Undeprecates one or more previously deprecated objects.

UnexpectedObjectException - Exception in javax.xml.registry

This exception is thrown when the JAXR provider finds a Object that is out-of-place or of the wrong type within the context of a user request.

UnexpectedObjectException() - Constructor for exception javax.xml.registry.UnexpectedObjectException

Constructs a JAXRException object with no reason or embedded Throwable.

UnexpectedObjectException(String) - Constructor for exception javax.xml.registry.UnexpectedObjectException

Constructs a JAXRException object with the given String as the reason for the exception being thrown.

UnexpectedObjectException(String, Throwable) - Constructor for exception javax.xml.registry.UnexpectedObjectException

Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

UnexpectedObjectException(Throwable) - Constructor for exception javax.xml.registry.UnexpectedObjectException

Constructs a JAXRException object initialized with the given Throwable object.

UnexpectedTypeException - Exception in javax.validation

Exception raised in the case that the constraint validator resolution cannot determine a suitable validator for a given type.

UnexpectedTypeException(String) - Constructor for exception javax.validation.UnexpectedTypeException

UnexpectedTypeException() - Constructor for exception javax.validation.UnexpectedTypeException

UnexpectedTypeException(String, Throwable) - Constructor for exception javax.validation.UnexpectedTypeException

UnexpectedTypeException(Throwable) - Constructor for exception javax.validation.UnexpectedTypeException

unfold(String) - Static method in class javax.mail.internet.MimeUtility

Unfold a folded header.

UNIQUE_ID_PREFIX - Static variable in class javax.faces.component.UIViewRoot

The prefix that will be used for identifiers generated by the createUniqueId() method.

UNIQUE_ID_PREFIX - Static variable in class javax.faces.webapp.UIComponentClassicTagBase

Used as the prefix for ids.

UniqueConstraint - Annotation Type in javax.persistence

Specifies that a unique constraint is to be included in the generated DDL for a primary or secondary table.

UniqueIdVendor - Interface in javax.faces.component

UniqueIdVendor is an interface implemented by UIComponents that also implement NamingContainer so that they can provide unique ids based on their own clientId.

UNKNOWN - Static variable in interface javax.resource.spi.work.WorkManager

A constant to indicate an unknown start delay duration or other unknown values.

Unmanaged<T> - Class in javax.enterprise.inject.spi

Helper class for injecting and calling lifecycle callbacks unmanaged instances for use by framework and library integrators.

Unmanaged(BeanManager, Class<T>) - Constructor for class javax.enterprise.inject.spi.Unmanaged

Create an injector for the given class

Unmanaged(Class<T>) - Constructor for class javax.enterprise.inject.spi.Unmanaged

Create an injector for the given class, using the current bean manager

Unmanaged.UnmanagedInstance<T> - Class in javax.enterprise.inject.spi

Represents a non-contextual instance.

unmarshal(Link.JaxbLink) - Method in class javax.ws.rs.core.Link.JaxbAdapter

Convert a Link.JaxbLink into a Link.

unmarshal(String) - Method in class javax.xml.bind.annotation.adapters.CollapsedStringAdapter

Removes leading and trailing whitespaces of the string given as the parameter, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.

unmarshal(String) - Method in class javax.xml.bind.annotation.adapters.HexBinaryAdapter

unmarshal(String) - Method in class javax.xml.bind.annotation.adapters.NormalizedStringAdapter

Replace any tab, CR, and LF by a whitespace character ' ', as specified in the whitespace facet 'replace'

unmarshal(ValueType) - Method in class javax.xml.bind.annotation.adapters.XmlAdapter

Convert a value type to a bound type.

unmarshal(XmlNode) - Method in class javax.xml.bind.Binder

Unmarshal XML infoset view to a JAXB object tree.

unmarshal(XmlNode, Class<T>) - Method in class javax.xml.bind.Binder

Unmarshal XML root element by provided declaredType to a JAXB object tree.

unmarshal(Source) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(XMLReader, InputSource) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Unmarshals an object by using the specified XMLReader and the InputSource.

unmarshal(InputSource) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(URL) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(File) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(InputStream) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(Reader) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(XMLEventReader) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(XMLStreamReader) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(Node, Class<T>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(Source, Class<T>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(XMLStreamReader, Class<T>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(XMLEventReader, Class<T>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

unmarshal(File, Class<T>) - Static method in class javax.xml.bind.JAXB

Reads in a Java object tree from the given XML input.

unmarshal(URL, Class<T>) - Static method in class javax.xml.bind.JAXB

Reads in a Java object tree from the given XML input.

unmarshal(URI, Class<T>) - Static method in class javax.xml.bind.JAXB

Reads in a Java object tree from the given XML input.

unmarshal(String, Class<T>) - Static method in class javax.xml.bind.JAXB

Reads in a Java object tree from the given XML input.

unmarshal(InputStream, Class<T>) - Static method in class javax.xml.bind.JAXB

Reads in a Java object tree from the given XML input.

unmarshal(Reader, Class<T>) - Static method in class javax.xml.bind.JAXB

Reads in a Java object tree from the given XML input.

unmarshal(Source, Class<T>) - Static method in class javax.xml.bind.JAXB

Reads in a Java object tree from the given XML input.

unmarshal(File) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal XML data from the specified file and return the resulting content tree.

unmarshal(InputStream) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal XML data from the specified InputStream and return the resulting content tree.

unmarshal(Reader) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal XML data from the specified Reader and return the resulting content tree.

unmarshal(URL) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal XML data from the specified URL and return the resulting content tree.

unmarshal(InputSource) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

unmarshal(Node) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal global XML data from the specified DOM tree and return the resulting content tree.

unmarshal(Node, Class<T>) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

unmarshal(Source) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal XML data from the specified XML Source and return the resulting content tree.

unmarshal(Source, Class<T>) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.

unmarshal(XMLStreamReader) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal XML data from the specified pull parser and return the resulting content tree.

unmarshal(XMLStreamReader, Class<T>) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

unmarshal(XMLEventReader) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal XML data from the specified pull parser and return the resulting content tree.

unmarshal(XMLEventReader, Class<T>) - Method in interface javax.xml.bind.Unmarshaller

Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

UnmarshalException - Exception in javax.xml.bind

This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.

UnmarshalException(String) - Constructor for exception javax.xml.bind.UnmarshalException

Construct an UnmarshalException with the specified detail message.

UnmarshalException(String, String) - Constructor for exception javax.xml.bind.UnmarshalException

Construct an UnmarshalException with the specified detail message and vendor specific errorCode.

UnmarshalException(Throwable) - Constructor for exception javax.xml.bind.UnmarshalException

Construct an UnmarshalException with a linkedException.

UnmarshalException(String, Throwable) - Constructor for exception javax.xml.bind.UnmarshalException

Construct an UnmarshalException with the specified detail message and linkedException.

UnmarshalException(String, String, Throwable) - Constructor for exception javax.xml.bind.UnmarshalException

Construct an UnmarshalException with the specified detail message, vendor specific errorCode, and linkedException.

Unmarshaller - Interface in javax.xml.bind

The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.

Unmarshaller.Listener - Class in javax.xml.bind

Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

Unmarshaller.Listener() - Constructor for class javax.xml.bind.Unmarshaller.Listener

UnmarshallerHandler - Interface in javax.xml.bind

Unmarshaller implemented as SAX ContentHandler.

unorderedAndMatchingGroups(Class<?>...) - Method in interface javax.validation.metadata.ElementDescriptor.ConstraintFinder

Restricts to the constraints matching a given set of groups for this element.

UnproxyableResolutionException - Exception in javax.enterprise.inject

Indicates that a contextual reference for a bean with a normal scope and a certain bean type cannot be obtained because the bean type cannot be proxied by the container.

UnproxyableResolutionException() - Constructor for exception javax.enterprise.inject.UnproxyableResolutionException

UnproxyableResolutionException(String, Throwable) - Constructor for exception javax.enterprise.inject.UnproxyableResolutionException

UnproxyableResolutionException(String) - Constructor for exception javax.enterprise.inject.UnproxyableResolutionException

UnproxyableResolutionException(Throwable) - Constructor for exception javax.enterprise.inject.UnproxyableResolutionException

unregisterTypeMapping(String) - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry

Unregisters a TypeMapping instance, if present, from the specified encodingStyleURI.

UnsatisfiedResolutionException - Exception in javax.enterprise.inject

Indicates that no bean matches a certain combination of required type and required qualifiers and is eligible for injection into a certain class.

UnsatisfiedResolutionException() - Constructor for exception javax.enterprise.inject.UnsatisfiedResolutionException

UnsatisfiedResolutionException(String, Throwable) - Constructor for exception javax.enterprise.inject.UnsatisfiedResolutionException

UnsatisfiedResolutionException(String) - Constructor for exception javax.enterprise.inject.UnsatisfiedResolutionException

UnsatisfiedResolutionException(Throwable) - Constructor for exception javax.enterprise.inject.UnsatisfiedResolutionException

unsetEntityContext() - Method in interface javax.ejb.EntityBean

Unset the associated entity context.

unsubscribe(String) - Method in interface javax.jms.JMSContext

Unsubscribes a durable subscription that has been created by a client.

unsubscribe(String) - Method in interface javax.jms.Session

Unsubscribes a durable subscription that has been created by a client.

unsubscribe(String) - Method in interface javax.jms.TopicSession

Unsubscribes a durable subscription that has been created by a client.

unsubscribeFromEvent(Class<? extends SystemEvent>, Class<?>, SystemEventListener) - Method in class javax.faces.application.Application

Remove the listener instance referenced by argument listener from the application as a listener for events of type systemEventClass that originate from objects of type sourceClass.

unsubscribeFromEvent(Class<? extends SystemEvent>, SystemEventListener) - Method in class javax.faces.application.Application

Remove the listener instance referenced by argument listener from the application as a listener for events of type systemEventClass.

unsubscribeFromEvent(Class<? extends SystemEvent>, Class<?>, SystemEventListener) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.unsubscribeFromEvent(Class, Class, javax.faces.event.SystemEventListener) on the wrapped Application object.

unsubscribeFromEvent(Class<? extends SystemEvent>, SystemEventListener) - Method in class javax.faces.application.ApplicationWrapper

The default behavior of this method is to call Application.unsubscribeFromEvent(Class, javax.faces.event.SystemEventListener) on the wrapped Application object.

unsubscribeFromEvent(Class<? extends SystemEvent>, ComponentSystemEventListener) - Method in class javax.faces.component.UIComponent

This implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

unsubscribeFromEvent(Class<? extends SystemEvent>, ComponentSystemEventListener) - Method in class javax.faces.component.UIComponentBase

Remove the listener instance referenced by argument componentListener as a listener for events of type eventClass originating from this specific instance of UIComponent.

unsubscribeFromViewEvent(Class<? extends SystemEvent>, SystemEventListener) - Method in class javax.faces.component.UIViewRoot

Remove the listener instance referenced by argument listener from the UIViewRoot as a listener for events of type systemEventClass.

UNSUPPORTED_CONTEXT_TYPE - Static variable in class javax.resource.spi.work.WorkContextErrorCodes

Indicates that a WorkContext type, that was not specified as optional, passed in by the Work instance is not supported by the container.

UnsupportedCapabilityException - Exception in javax.xml.registry

This exception must be thrown when a JAXR client attempts to invoke an API method that is not supported by the capability profile that is supported by the JAXR provider.

UnsupportedCapabilityException() - Constructor for exception javax.xml.registry.UnsupportedCapabilityException

Constructs a JAXRException object with no reason or embedded Throwable.

UnsupportedCapabilityException(String) - Constructor for exception javax.xml.registry.UnsupportedCapabilityException

Constructs a JAXRException object with the given String as the reason for the exception being thrown.

UnsupportedCapabilityException(String, Throwable) - Constructor for exception javax.xml.registry.UnsupportedCapabilityException

Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

UnsupportedCapabilityException(Throwable) - Constructor for exception javax.xml.registry.UnsupportedCapabilityException

Constructs a JAXRException object initialized with the given Throwable object.

unwrap(Class<T>) - Method in interface javax.persistence.Cache

Return an object of the specified type to allow access to the provider-specific API.

unwrap(Class<T>) - Method in interface javax.persistence.EntityManager

Return an object of the specified type to allow access to the provider-specific API.

unwrap(Class<T>) - Method in interface javax.persistence.EntityManagerFactory

Return an object of the specified type to allow access to the provider-specific API.

unwrap(Class<T>) - Method in interface javax.persistence.Query

Return an object of the specified type to allow access to the provider-specific API.

unwrap(Class<T>) - Method in interface javax.validation.ConstraintValidatorContext

Returns an instance of the specified type allowing access to provider-specific APIs.

unwrap(Class<U>) - Method in interface javax.validation.ConstraintViolation

Returns an instance of the specified type allowing access to provider-specific APIs.

unwrap(Class<T>) - Method in interface javax.validation.MessageInterpolator.Context

Returns an instance of the specified type allowing access to provider-specific APIs.

unwrap(Class<T>) - Method in interface javax.validation.Validator

Returns an instance of the specified type allowing access to provider-specific APIs.

unwrap(Class<T>) - Method in interface javax.validation.ValidatorFactory

Returns an instance of the specified type allowing access to provider-specific APIs.

UPDATE_MESSAGE_ID - Static variable in class javax.faces.component.UIInput

The message identifier of the FacesMessage to be created if a model update error occurs, and the thrown exception has no message.

UPDATE_MODEL_VALUES - Static variable in class javax.faces.event.PhaseId

Identifier that indicates an interest in events queued for the Update Model Values phase of the request processing lifecycle.

updateAttributes(String, Map<String, String>) - Method in class javax.faces.context.PartialResponseWriter

Write an attribute update operation.

updateHeaders() - Method in class javax.mail.internet.MimeBodyPart

Examine the content of this body part and update the appropriate MIME headers.

updateHeaders() - Method in class javax.mail.internet.MimeMessage

Called by the saveChanges method to actually update the MIME headers.

updateHeaders() - Method in class javax.mail.internet.MimeMultipart

Update headers.

updateHeaders() - Method in class javax.mail.internet.PreencodedMimeBodyPart

Force the Content-Transfer-Encoding header to use the encoding that was specified when this object was created.

updateJAXB(XmlNode) - Method in class javax.xml.bind.Binder

Takes an XML node and updates its associated JAXB object and its descendants.

updateMessageID() - Method in class javax.mail.internet.MimeMessage

Update the Message-ID header.

updateModel(FacesContext) - Method in class javax.faces.component.UIInput

Perform the following algorithm to update the model data associated with this UIInput, if any, as appropriate.

updateModel(FacesContext) - Method in class javax.faces.component.UIViewParameter

Call through to superclass UIInput.updateModel(javax.faces.context.FacesContext) then take the additional action of pushing the value into request scope if and only if the value is not a value expression, is valid, and the local value was set on this lifecycle execution.

UpdateModelException - Exception in javax.faces.component

This exception indicates a failure to update the model and is created to wrap any exception that occurs during UIInput.updateModel(javax.faces.context.FacesContext).

UpdateModelException(FacesMessage, Throwable) - Constructor for exception javax.faces.component.UpdateModelException

Store the argument facesMessage so it may be returned from UpdateModelException.getFacesMessage() and pass the argument cause to the super constructor.

updatesAreDetected(int) - Method in interface javax.resource.cci.ResultSetInfo

Indicates whether or not a visible row update can be detected by calling the method ResultSet.rowUpdated.

updateXML(Object) - Method in class javax.xml.bind.Binder

Takes an JAXB object and updates its associated XML node and its descendants.

updateXML(Object, XmlNode) - Method in class javax.xml.bind.Binder

Changes in JAXB object tree are updated in its associated XML parse tree.

upgrade(Class<T>) - Method in interface javax.servlet.http.HttpServletRequest

Create an instance of HttpUpgradeHandler for an given class and uses it for the http protocol upgrade processing.

upgrade(Class<T>) - Method in class javax.servlet.http.HttpServletRequestWrapper

Create an instance of HttpUpgradeHandler for an given class and uses it for the http protocol upgrade processing.

upper(Expression<String>) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create expression for converting a string to uppercase.

uri - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo

The value of the uri attribute from the taglib directive for this library.

uri(URI) - Method in interface javax.ws.rs.core.Link.Builder

Set underlying URI template for the link being constructed.

uri(String) - Method in interface javax.ws.rs.core.Link.Builder

Set underlying string representing URI template for the link being constructed.

uri(URI) - Method in class javax.ws.rs.core.UriBuilder

Copies the non-null components of the supplied URI to the UriBuilder replacing any existing values for those components.

uri(String) - Method in class javax.ws.rs.core.UriBuilder

Parses the uriTemplate string and copies the parsed components of the supplied URI to the UriBuilder replacing any existing values for those components.

URI_NS_SOAP_1_1_ENVELOPE - Static variable in interface javax.xml.soap.SOAPConstants

The namespace identifier for the SOAP 1.1 envelope.

URI_NS_SOAP_1_2_ENCODING - Static variable in interface javax.xml.soap.SOAPConstants

The namespace identifier for the SOAP 1.2 encoding.

URI_NS_SOAP_1_2_ENVELOPE - Static variable in interface javax.xml.soap.SOAPConstants

The namespace identifier for the SOAP 1.2 envelope.

URI_NS_SOAP_ENCODING - Static variable in interface javax.xml.soap.SOAPConstants

The namespace identifier for the SOAP 1.1 encoding.

URI_NS_SOAP_ENVELOPE - Static variable in interface javax.xml.soap.SOAPConstants

The namespace identifier for the SOAP 1.1 envelope, All SOAPElements in this namespace are defined by the SOAP 1.1 specification.

URI_SOAP_1_2_ROLE_NEXT - Static variable in interface javax.xml.soap.SOAPConstants

The URI identifying the next application processing a SOAP request as the intended role for a SOAP 1.2 header entry (see section 2.2 of part 1 of the SOAP 1.2 specification).

URI_SOAP_1_2_ROLE_NONE - Static variable in interface javax.xml.soap.SOAPConstants

The URI specifying the role None in SOAP 1.2.

URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER - Static variable in interface javax.xml.soap.SOAPConstants

The URI identifying the ultimate receiver of the SOAP 1.2 message.

URI_SOAP_ACTOR_NEXT - Static variable in interface javax.xml.soap.SOAPConstants

The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

uriBuilder(UriBuilder) - Method in interface javax.ws.rs.core.Link.Builder

Set underlying URI builder representing the URI template for the link being constructed.

UriBuilder - Class in javax.ws.rs.core

URI template-aware utility class for building URIs from their components.

UriBuilder() - Constructor for class javax.ws.rs.core.UriBuilder

Protected constructor, use one of the static fromXxx(...) methods to obtain an instance.

UriBuilderException - Exception in javax.ws.rs.core

A runtime exception thrown by UriBuilder.build(Object...) methods when a URI cannot be constructed based on the current state of the builder.

UriBuilderException() - Constructor for exception javax.ws.rs.core.UriBuilderException

Creates a new instance of UriBuilderException without detail message.

UriBuilderException(String) - Constructor for exception javax.ws.rs.core.UriBuilderException

Constructs an instance of UriBuilderException with the specified detail message.

UriBuilderException(String, Throwable) - Constructor for exception javax.ws.rs.core.UriBuilderException

Constructs an instance of UriBuilderException with the specified detail message and cause.

UriBuilderException(Throwable) - Constructor for exception javax.ws.rs.core.UriBuilderException

Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

UriInfo - Interface in javax.ws.rs.core

An injectable interface that provides access to application and request URI information.

URIValidator - Interface in javax.xml.registry.infomodel

Defines common behavior expected of any class that validates URIs.

url - Variable in class javax.mail.Service

The URLName of this service.

URLName - Class in javax.mail

The name of a URL.

URLName(String, String, int, String, String, String) - Constructor for class javax.mail.URLName

Creates a URLName object from the specified protocol, host, port number, file, username, and password.

URLName(URL) - Constructor for class javax.mail.URLName

Construct a URLName from a java.net.URL object.

URLName(String) - Constructor for class javax.mail.URLName

Construct a URLName from the string.

URLStats - Interface in javax.management.j2ee.statistics

Specifies the statistics provided by a URL resource.

urn - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo

The "reliable" URN indicated in the TLD.

usage - Variable in class javax.mail.Quota.Resource

The current usage of the resource.

USE_TRANSACTION_OF_EXECUTION_THREAD - Static variable in interface javax.enterprise.concurrent.ManagedTask

Constant for the "USE_TRANSACTION_OF_EXECUTION_THREAD" value of the TRANSACTION execution property.

USER - Static variable in class javax.mail.Flags.Flag

A special flag that indicates that this folder supports user defined flags.

USER - Static variable in class javax.ws.rs.Priorities

User-level filter/interceptor priority.

User - Interface in javax.xml.registry.infomodel

User instances are RegistryObjects that are used to provide information about registered users within the registry.

USER - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.User interface.

USER_AGENT - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

userAgentNeedsUpdate(FacesContext) - Method in class javax.faces.application.Resource

Return true if the user-agent requesting this resource needs an update.

userAgentNeedsUpdate(FacesContext) - Method in class javax.faces.application.ResourceWrapper

The default behavior of this method is to call Resource.userAgentNeedsUpdate(javax.faces.context.FacesContext) on the wrapped ResourceHandler object.

userInfo(String) - Method in class javax.ws.rs.core.UriBuilder

Set the URI user-info.

USERNAME_PROPERTY - Static variable in interface javax.xml.rpc.Call

Standard property: User name for authentication

USERNAME_PROPERTY - Static variable in interface javax.xml.rpc.Stub

Standard property: User name for authentication.

USERNAME_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider

Standard property: User name for authentication.

UserTransaction - Interface in javax.transaction

The UserTransaction interface defines the methods that allow an application to explicitly manage transaction boundaries.

usingContext() - Method in interface javax.validation.ValidatorFactory

Defines a new validator context and returns a Validator compliant this new context.

V

V1_3 - Static variable in class javax.enterprise.deploy.shared.DConfigBeanVersionType

J2EE Platform version 1.3

V1_3_1 - Static variable in class javax.enterprise.deploy.shared.DConfigBeanVersionType

J2EE Platform version 1.3.1 THIS CONSTANT SHOULD NEVER BE USED.

V1_4 - Static variable in class javax.enterprise.deploy.shared.DConfigBeanVersionType

J2EE Platform version 1.4

V5 - Static variable in class javax.enterprise.deploy.shared.DConfigBeanVersionType

Java EE Platform version 5

Valid - Annotation Type in javax.validation

Marks a property, method parameter or method return type for validation cascading.

validate(InjectionPoint) - Method in interface javax.enterprise.inject.spi.BeanManager

Validate a certain injection point.

validate(FacesContext) - Method in class javax.faces.component.UIInput

Perform the following algorithm to validate the local value of this UIInput.

validate(FacesContext, UIComponent, Object) - Method in class javax.faces.validator.BeanValidator

Verify that the value is valid according to the Bean Validation constraints.

validate(FacesContext, UIComponent, Object) - Method in class javax.faces.validator.DoubleRangeValidator

validate(FacesContext, UIComponent, Object) - Method in class javax.faces.validator.LengthValidator

validate(FacesContext, UIComponent, Object) - Method in class javax.faces.validator.LongRangeValidator

validate(FacesContext, UIComponent, Object) - Method in class javax.faces.validator.MethodExpressionValidator

validate(FacesContext, UIComponent, Object) - Method in class javax.faces.validator.RegexValidator

Validate a String against a regular expression pattern.

validate(FacesContext, UIComponent, Object) - Method in class javax.faces.validator.RequiredValidator

Verify that the converted object value is not null.

validate(FacesContext, UIComponent, Object) - Method in interface javax.faces.validator.Validator

Perform the correctness checks implemented by this Validator against the specified UIComponent.

validate() - Method in class javax.mail.internet.InternetAddress

Validate that this address conforms to the syntax rules of RFC 822.

validate() - Method in interface javax.resource.spi.ActivationSpec

This method may be called by a deployment tool to validate the overall activation configuration information provided by the endpoint deployer.

validate(String, String, PageData) - Method in class javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV

validate(String, String, PageData) - Method in class javax.servlet.jsp.jstl.tlv.ScriptFreeTLV

Validates a single JSP page.

validate(TagData) - Method in class javax.servlet.jsp.tagext.TagExtraInfo

Translation-time validation of the attributes.

validate(TagData) - Method in class javax.servlet.jsp.tagext.TagInfo

Translation-time validation of the attributes.

validate(String, String, PageData) - Method in class javax.servlet.jsp.tagext.TagLibraryValidator

Validate a JSP page.

validate(T, Class<?>...) - Method in interface javax.validation.Validator

Validates all constraints on object.

validate(Object) - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

VALIDATE_EMPTY_FIELDS_PARAM_NAME - Static variable in class javax.faces.component.UIInput

The name of an application parameter that indicates how empty values should be handled with respect to validation.

validateBegin() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Ensures the "begin" property is sensible, throwing an exception expected to propagate up if it isn't

validateConstructorParameters(Constructor<? extends T>, Object[], Class<?>...) - Method in interface javax.validation.executable.ExecutableValidator

Validates all constraints placed on the parameters of the given constructor.

validateConstructorReturnValue(Constructor<? extends T>, T, Class<?>...) - Method in interface javax.validation.executable.ExecutableValidator

Validates all return value constraints of the given constructor.

validateEnd() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Ensures the "end" property is sensible, throwing an exception expected to propagate up if it isn't

ValidateOnExecution - Annotation Type in javax.validation.executable

Expresses which executables (methods or constructors) should have their parameters and return value validated upon execution.

validateParameters(T, Method, Object[], Class<?>...) - Method in interface javax.validation.executable.ExecutableValidator

Validates all constraints placed on the parameters of the given method.

validateProperty(T, String, Class<?>...) - Method in interface javax.validation.Validator

Validates all constraints placed on the property of object named propertyName.

validateRequest(MessageInfo, Subject, Subject) - Method in interface javax.security.auth.message.ServerAuth

Authenticate a received service request.

validateResponse(MessageInfo, Subject, Subject) - Method in interface javax.security.auth.message.ClientAuth

Validate a received service response.

validateReturnValue(T, Method, Object, Class<?>...) - Method in interface javax.validation.executable.ExecutableValidator

Validates all return value constraints of the given method.

validateRoot(Object) - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

validateStep() - Method in class javax.servlet.jsp.jstl.core.LoopTagSupport

Ensures the "step" property is sensible, throwing an exception expected to propagate up if it isn't

validateValue(FacesContext, Object) - Method in class javax.faces.component.UIInput

Set the "valid" property according to the below algorithm.

validateValue(FacesContext, Object) - Method in class javax.faces.component.UISelectMany

In addition to the standard validation behavior inherited from UIInput, ensure that any specified values are equal to one of the available options.

validateValue(FacesContext, Object) - Method in class javax.faces.component.UISelectOne

In addition to the standard validation behavior inherited from UIInput, ensure that any specified value is equal to one of the available options.

validateValue(Class<T>, String, Object, Class<?>...) - Method in interface javax.validation.Validator

Validates all constraints placed on the property named propertyName of the class beanType would the property value be value.

validating - Variable in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

whether or not the unmarshaller will validate

ValidatingManagedConnectionFactory - Interface in javax.resource.spi

This interface is implemented by a ManagedConnectionFactory instance that supports the ability to validate ManagedConnection objects.

Validation - Class in javax.validation

This class is the entry point for Bean Validation.

Validation() - Constructor for class javax.validation.Validation

VALIDATION_GROUPS_DELIMITER - Static variable in class javax.faces.validator.BeanValidator

The delimiter that is used to separate the list of fully-qualified group names as strings.

ValidationEvent - Interface in javax.xml.bind

This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.

ValidationEventCollector - Class in javax.xml.bind.util

ValidationEventHandler implementation that collects all events.

ValidationEventCollector() - Constructor for class javax.xml.bind.util.ValidationEventCollector

ValidationEventHandler - Interface in javax.xml.bind

A basic event handler interface for validation errors.

ValidationEventImpl - Class in javax.xml.bind.helpers

Default implementation of the ValidationEvent interface.

ValidationEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers.ValidationEventImpl

Create a new ValidationEventImpl.

ValidationEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers.ValidationEventImpl

Create a new ValidationEventImpl.

ValidationEventLocator - Interface in javax.xml.bind

Encapsulate the location of a ValidationEvent.

ValidationEventLocatorImpl - Class in javax.xml.bind.helpers

Default implementation of the ValidationEventLocator interface.

ValidationEventLocatorImpl() - Constructor for class javax.xml.bind.helpers.ValidationEventLocatorImpl

Creates an object with all fields unavailable.

ValidationEventLocatorImpl(Locator) - Constructor for class javax.xml.bind.helpers.ValidationEventLocatorImpl

Constructs an object from an org.xml.sax.Locator.

ValidationEventLocatorImpl(SAXParseException) - Constructor for class javax.xml.bind.helpers.ValidationEventLocatorImpl

Constructs an object from the location information of a SAXParseException.

ValidationEventLocatorImpl(Node) - Constructor for class javax.xml.bind.helpers.ValidationEventLocatorImpl

Constructs an object that points to a DOM Node.

ValidationEventLocatorImpl(Object) - Constructor for class javax.xml.bind.helpers.ValidationEventLocatorImpl

Constructs an object that points to a JAXB content object.

ValidationException - Exception in javax.validation

Base exception of all Bean Validation "unexpected" problems.

ValidationException(String) - Constructor for exception javax.validation.ValidationException

ValidationException() - Constructor for exception javax.validation.ValidationException

ValidationException(String, Throwable) - Constructor for exception javax.validation.ValidationException

ValidationException(Throwable) - Constructor for exception javax.validation.ValidationException

ValidationException - Exception in javax.xml.bind

This exception indicates that an error has occurred while performing a validate operation.

ValidationException(String) - Constructor for exception javax.xml.bind.ValidationException

Construct an ValidationException with the specified detail message.

ValidationException(String, String) - Constructor for exception javax.xml.bind.ValidationException

Construct an ValidationException with the specified detail message and vendor specific errorCode.

ValidationException(Throwable) - Constructor for exception javax.xml.bind.ValidationException

Construct an ValidationException with a linkedException.

ValidationException(String, Throwable) - Constructor for exception javax.xml.bind.ValidationException

Construct an ValidationException with the specified detail message and linkedException.

ValidationException(String, String, Throwable) - Constructor for exception javax.xml.bind.ValidationException

Construct an ValidationException with the specified detail message, vendor specific errorCode, and linkedException.

validationFailed() - Method in class javax.faces.context.FacesContext

Sets a flag which indicates that a conversion or validation error occurred while processing the inputs.

validationFailed() - Method in class javax.faces.context.FacesContextWrapper

The default behavior of this method is to call FacesContext.validationFailed() on the wrapped FacesContext object.

ValidationMessage - Class in javax.servlet.jsp.tagext

A validation message from either TagLibraryValidator or TagExtraInfo.

ValidationMessage(String, String) - Constructor for class javax.servlet.jsp.tagext.ValidationMessage

Create a ValidationMessage.

ValidationMode - Enum in javax.persistence

The validation mode to be used by the provider for the persistence unit.

ValidationProvider<T extends Configuration<T>> - Interface in javax.validation.spi

Contract between the validation bootstrap mechanism and the provider engine.

ValidationProviderResolver - Interface in javax.validation

Determines the list of Bean Validation providers available in the runtime environment
Bean Validation providers are identified by the presence of META-INF/services/javax.validation.spi.ValidationProvider files following the Service Provider pattern described here.

ValidationTarget - Enum in javax.validation.constraintvalidation

List of possible targets for a ConstraintValidator.

Validator - Interface in javax.faces.validator

A Validator implementation is a class that can perform validation (correctness checks) on a EditableValueHolder.

Validator - Interface in javax.validation

Validates bean instances.

Validator - Interface in javax.xml.bind

Deprecated.
since JAXB 2.0

VALIDATOR_FACTORY_KEY - Static variable in class javax.faces.validator.BeanValidator

The name of the servlet context attribute which holds the object used by JSF to obtain Validator instances.

VALIDATOR_ID - Static variable in class javax.faces.validator.BeanValidator

The standard validator id for this validator, as defined by the JSF specification.

VALIDATOR_ID - Static variable in class javax.faces.validator.DoubleRangeValidator

The standard converter id for this converter.

VALIDATOR_ID - Static variable in class javax.faces.validator.LengthValidator

The standard validator id for this validator.

VALIDATOR_ID - Static variable in class javax.faces.validator.LongRangeValidator

The standard converter id for this converter.

VALIDATOR_ID - Static variable in class javax.faces.validator.RegexValidator

The standard converter id for this converter.

VALIDATOR_ID - Static variable in class javax.faces.validator.RequiredValidator

The standard converter id for this converter.

ValidatorConfig - Interface in javax.faces.view.facelets

Used in creating ValidatorHandler and all implementations.

ValidatorContext - Interface in javax.validation

Represents the context that is used to create Validator instances.

ValidatorELTag - Class in javax.faces.webapp

ValidatorELTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag.

ValidatorELTag() - Constructor for class javax.faces.webapp.ValidatorELTag

ValidatorException - Exception in javax.faces.validator

A ValidatorException is an exception thrown by the validate() method of a Validator to indicate that validation failed.

ValidatorException(FacesMessage) - Constructor for exception javax.faces.validator.ValidatorException

Construct a new exception with the specified message and no root cause.

ValidatorException(Collection<FacesMessage>) - Constructor for exception javax.faces.validator.ValidatorException

Allow this one exception to contain multiple messages.

ValidatorException(FacesMessage, Throwable) - Constructor for exception javax.faces.validator.ValidatorException

Construct a new exception with the specified detail message and root cause.

ValidatorException(Collection<FacesMessage>, Throwable) - Constructor for exception javax.faces.validator.ValidatorException

Allow this one exception to contain multiple messages, while passing on the root cause to the superclass

ValidatorFactory - Interface in javax.validation

Factory returning initialized Validator instances.

ValidatorHandler - Class in javax.faces.view.facelets

Handles setting a Validator instance on an EditableValueHolder parent.

ValidatorHandler(ValidatorConfig) - Constructor for class javax.faces.view.facelets.ValidatorHandler

Construct this instance around the configuration information in argument config

ValidatorTag - Class in javax.faces.webapp

Deprecated.
This has been partially replaced by ValidatorELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ValidatorTag.createValidator() method, is now an implementation detail.

ValidatorTag() - Constructor for class javax.faces.webapp.ValidatorTag

Deprecated.

validSent - Variable in class javax.mail.event.TransportEvent

validSent - Variable in exception javax.mail.SendFailedException

validUnsent - Variable in class javax.mail.event.TransportEvent

validUnsent - Variable in exception javax.mail.SendFailedException

value - Variable in class javax.mail.Header

The value of the header.

value(T) - Method in interface javax.persistence.criteria.CriteriaBuilder.Coalesce

Add an argument to the coalesce expression.

value(Expression<? extends T>) - Method in interface javax.persistence.criteria.CriteriaBuilder.Coalesce

Add an argument to the coalesce expression.

value(T) - Method in interface javax.persistence.criteria.CriteriaBuilder.In

Add to list of values to be tested against.

value(Expression<? extends T>) - Method in interface javax.persistence.criteria.CriteriaBuilder.In

Add to list of values to be tested against.

value() - Method in interface javax.persistence.criteria.MapJoin

Create a path expression that corresponds to the map value.

value - Variable in class javax.xml.bind.JAXBElement

xml element value.

value - Variable in class javax.xml.rpc.holders.BigDecimalHolder

value - Variable in class javax.xml.rpc.holders.BigIntegerHolder

value - Variable in class javax.xml.rpc.holders.BooleanHolder

value - Variable in class javax.xml.rpc.holders.BooleanWrapperHolder

value - Variable in class javax.xml.rpc.holders.ByteArrayHolder

value - Variable in class javax.xml.rpc.holders.ByteHolder

value - Variable in class javax.xml.rpc.holders.ByteWrapperHolder

value - Variable in class javax.xml.rpc.holders.CalendarHolder

value - Variable in class javax.xml.rpc.holders.DoubleHolder

value - Variable in class javax.xml.rpc.holders.DoubleWrapperHolder

value - Variable in class javax.xml.rpc.holders.FloatHolder

value - Variable in class javax.xml.rpc.holders.FloatWrapperHolder

value - Variable in class javax.xml.rpc.holders.IntegerWrapperHolder

value - Variable in class javax.xml.rpc.holders.IntHolder

value - Variable in class javax.xml.rpc.holders.LongHolder

value - Variable in class javax.xml.rpc.holders.LongWrapperHolder

value - Variable in class javax.xml.rpc.holders.ObjectHolder

value - Variable in class javax.xml.rpc.holders.QNameHolder

value - Variable in class javax.xml.rpc.holders.ShortHolder

value - Variable in class javax.xml.rpc.holders.ShortWrapperHolder

value - Variable in class javax.xml.rpc.holders.StringHolder

value - Variable in class javax.xml.ws.Holder

The value contained in the holder.

VALUE_TYPE_EMBEDDED_PATH - Static variable in interface javax.xml.registry.infomodel.ClassificationScheme

Each taxonomy value in ClassificationScheme embeds the full path from scheme to that Concept.

VALUE_TYPE_NON_UNIQUE - Static variable in interface javax.xml.registry.infomodel.ClassificationScheme

Taxonomy values in ClassificationScheme may be repeated within the same scheme.

VALUE_TYPE_UNIQUE - Static variable in interface javax.xml.registry.infomodel.ClassificationScheme

Each taxonomy value in ClassificationScheme is unique.

ValueBinding - Class in javax.faces.el

Deprecated.
This has been replaced by ValueExpression.

ValueBinding() - Constructor for class javax.faces.el.ValueBinding

Deprecated.

valueBound(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionBindingListener

Notifies the object that it is being bound to a session and identifies the session.

ValueChangeEvent - Class in javax.faces.event

A ValueChangeEvent is a notification that the local value of the source component has been change as a result of user interface activity.

ValueChangeEvent(UIComponent, Object, Object) - Constructor for class javax.faces.event.ValueChangeEvent

Construct a new event object from the specified source component, old value, and new value.

ValueChangeListener - Interface in javax.faces.event

A listener interface for receiving ValueChangeEvents.

ValueExpression - Class in javax.el

An Expression that can get or set a value.

ValueExpression() - Constructor for class javax.el.ValueExpression

ValueHolder - Interface in javax.faces.component

ValueHolder is an interface that may be implemented by any concrete UIComponent that wishes to support a local value, as well as access data in the model tier via a value expression, and support conversion between String and the model tier data's native data type.

ValueHolderAttachedObjectHandler - Interface in javax.faces.view

A VDL handler that exposes Converter to a page author.

ValueHolderAttachedObjectTarget - Interface in javax.faces.view

A marker interface for VDL tags that represent <composite:valueHolder/> for use by the composite component page author.

valueOf(String) - Static method in enum javax.annotation.Resource.AuthenticationType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.batch.api.partition.PartitionReducer.PartitionStatus

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.batch.runtime.BatchStatus

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.batch.runtime.Metric.MetricType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.ejb.ConcurrencyManagementType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.ejb.LockType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.ejb.TransactionAttributeType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.ejb.TransactionManagementType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.enterprise.event.Reception

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.enterprise.event.TransactionPhase

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.enterprise.inject.spi.InterceptionType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.enterprise.inject.spi.SessionBeanType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.application.ProjectStage

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.behavior.ClientBehaviorHint

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlBody.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlColumn.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlCommandButton.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlCommandLink.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlDataTable.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlDoctype.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlForm.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlGraphicImage.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlHead.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlInputFile.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlInputHidden.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlInputSecret.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlInputText.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlInputTextarea.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlMessage.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlMessages.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlOutcomeTargetButton.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlOutcomeTargetLink.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlOutputFormat.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlOutputLabel.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlOutputLink.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlOutputText.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlPanelGrid.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlPanelGroup.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlSelectBooleanCheckbox.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlSelectManyCheckbox.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlSelectManyListbox.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlSelectManyMenu.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlSelectOneListbox.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlSelectOneMenu.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.html.HtmlSelectOneRadio.PropertyKeys

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.visit.VisitHint

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.faces.component.visit.VisitResult

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.json.JsonValue.ValueType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.json.stream.JsonParser.Event

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.jws.soap.SOAPBinding.ParameterStyle

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.jws.soap.SOAPBinding.Style

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.jws.soap.SOAPBinding.Use

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.jws.WebParam.Mode

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.AccessType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.CacheRetrieveMode

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.CacheStoreMode

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.CascadeType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.ConstraintMode

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.criteria.CriteriaBuilder.Trimspec

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.criteria.JoinType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.criteria.Predicate.BooleanOperator

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.DiscriminatorType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.EnumType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.FetchType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.FlushModeType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.GenerationType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.InheritanceType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.LockModeType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.metamodel.Attribute.PersistentAttributeType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.metamodel.Bindable.BindableType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.metamodel.PluralAttribute.CollectionType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.metamodel.Type.PersistenceType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.ParameterMode

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.PersistenceContextType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.PessimisticLockScope

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.SharedCacheMode

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.spi.LoadState

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.spi.PersistenceUnitTransactionType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.SynchronizationType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.TemporalType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.persistence.ValidationMode

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.resource.spi.AuthenticationMechanism.CredentialInterface

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.resource.spi.TransactionSupport.TransactionSupportLevel

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.servlet.annotation.ServletSecurity.EmptyRoleSemantic

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.servlet.annotation.ServletSecurity.TransportGuarantee

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.servlet.DispatcherType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.servlet.SessionTrackingMode

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.transaction.Transactional.TxType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.validation.constraints.Pattern.Flag

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.validation.ConstraintTarget

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.validation.constraintvalidation.ValidationTarget

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.validation.ElementKind

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.validation.executable.ExecutableType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.validation.metadata.MethodType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.validation.metadata.Scope

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.websocket.CloseReason.CloseCodes

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in class javax.ws.rs.core.CacheControl

Creates a new instance of CacheControl by parsing the supplied string.

valueOf(String) - Static method in class javax.ws.rs.core.Cookie

Creates a new instance of Cookie by parsing the supplied string.

valueOf(String) - Static method in class javax.ws.rs.core.EntityTag

Creates a new instance of EntityTag by parsing the supplied string.

valueOf(String) - Static method in class javax.ws.rs.core.Link

Simple parser to convert link header string representations into a link.

valueOf(String) - Static method in class javax.ws.rs.core.MediaType

Creates a new instance of MediaType by parsing the supplied string.

valueOf(String) - Static method in class javax.ws.rs.core.NewCookie

Creates a new instance of NewCookie by parsing the supplied string.

valueOf(String) - Static method in enum javax.ws.rs.core.Response.Status.Family

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.ws.rs.core.Response.Status

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.ws.rs.RuntimeType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.xml.bind.annotation.XmlAccessOrder

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.xml.bind.annotation.XmlAccessType

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.xml.bind.annotation.XmlNsForm

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.xml.ws.handler.MessageContext.Scope

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.xml.ws.Service.Mode

Returns the enum constant of this type with the specified name.

valueOf(String) - Static method in enum javax.xml.ws.soap.AddressingFeature.Responses

Returns the enum constant of this type with the specified name.

ValueReference - Class in javax.el

This encapsulates a base model object and one of its properties.

ValueReference(Object, Object) - Constructor for class javax.el.ValueReference

values() - Static method in enum javax.annotation.Resource.AuthenticationType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.batch.api.partition.PartitionReducer.PartitionStatus

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.batch.runtime.BatchStatus

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.batch.runtime.Metric.MetricType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.ejb.ConcurrencyManagementType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.ejb.LockType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.ejb.TransactionAttributeType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.ejb.TransactionManagementType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.enterprise.event.Reception

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.enterprise.event.TransactionPhase

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.enterprise.inject.spi.InterceptionType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.enterprise.inject.spi.SessionBeanType

Returns an array containing the constants of this enum type, in the order they are declared.

VALUES - Static variable in class javax.faces.application.FacesMessage

Immutable List of valid FacesMessage.Severity instances, in ascending order of their ordinal value.

values() - Static method in enum javax.faces.application.ProjectStage

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.behavior.ClientBehaviorHint

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlBody.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlColumn.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlCommandButton.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlCommandLink.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlDataTable.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlDoctype.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlForm.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlGraphicImage.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlHead.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlInputFile.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlInputHidden.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlInputSecret.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlInputText.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlInputTextarea.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlMessage.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlMessages.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlOutcomeTargetButton.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlOutcomeTargetLink.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlOutputFormat.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlOutputLabel.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlOutputLink.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlOutputText.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlPanelGrid.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlPanelGroup.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlSelectBooleanCheckbox.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlSelectManyCheckbox.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlSelectManyListbox.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlSelectManyMenu.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlSelectOneListbox.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlSelectOneMenu.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.html.HtmlSelectOneRadio.PropertyKeys

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.visit.VisitHint

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.faces.component.visit.VisitResult

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Method in class javax.faces.context.FlashWrapper

The default behavior of this method is to call Map.values() on the wrapped Flash object.

VALUES - Static variable in class javax.faces.event.PhaseId

List of valid PhaseId instances, in ascending order of their ordinal value.

values() - Static method in enum javax.json.JsonValue.ValueType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.json.stream.JsonParser.Event

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.jws.soap.SOAPBinding.ParameterStyle

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.jws.soap.SOAPBinding.Style

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.jws.soap.SOAPBinding.Use

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.jws.WebParam.Mode

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.AccessType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.CacheRetrieveMode

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.CacheStoreMode

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.CascadeType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.ConstraintMode

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.criteria.CriteriaBuilder.Trimspec

Returns an array containing the constants of this enum type, in the order they are declared.

values(M) - Method in interface javax.persistence.criteria.CriteriaBuilder

Create an expression that returns the values of a map.

values() - Static method in enum javax.persistence.criteria.JoinType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.criteria.Predicate.BooleanOperator

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.DiscriminatorType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.EnumType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.FetchType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.FlushModeType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.GenerationType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.InheritanceType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.LockModeType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.metamodel.Attribute.PersistentAttributeType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.metamodel.Bindable.BindableType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.metamodel.PluralAttribute.CollectionType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.metamodel.Type.PersistenceType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.ParameterMode

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.PersistenceContextType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.PessimisticLockScope

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.SharedCacheMode

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.spi.LoadState

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.spi.PersistenceUnitTransactionType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.SynchronizationType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.TemporalType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.persistence.ValidationMode

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.resource.spi.AuthenticationMechanism.CredentialInterface

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.resource.spi.TransactionSupport.TransactionSupportLevel

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.servlet.annotation.ServletSecurity.EmptyRoleSemantic

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.servlet.annotation.ServletSecurity.TransportGuarantee

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.servlet.DispatcherType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.servlet.SessionTrackingMode

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.transaction.Transactional.TxType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.validation.constraints.Pattern.Flag

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.validation.ConstraintTarget

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.validation.constraintvalidation.ValidationTarget

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.validation.ElementKind

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.validation.executable.ExecutableType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.validation.metadata.MethodType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.validation.metadata.Scope

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.websocket.CloseReason.CloseCodes

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Method in class javax.ws.rs.core.AbstractMultivaluedMap

values() - Static method in enum javax.ws.rs.core.Response.Status.Family

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.ws.rs.core.Response.Status

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.ws.rs.RuntimeType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.xml.bind.annotation.XmlAccessOrder

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.xml.bind.annotation.XmlAccessType

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.xml.bind.annotation.XmlNsForm

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.xml.ws.handler.MessageContext.Scope

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.xml.ws.Service.Mode

Returns an array containing the constants of this enum type, in the order they are declared.

values() - Static method in enum javax.xml.ws.soap.AddressingFeature.Responses

Returns an array containing the constants of this enum type, in the order they are declared.

VALUES_MAP - Static variable in class javax.faces.application.FacesMessage

Immutable Map of valid FacesMessage.Severity instances, keyed by name.

valueUnbound(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionBindingListener

Notifies the object that it is being unbound from a session and identifies the session.

VariableInfo - Class in javax.servlet.jsp.tagext

Information on the scripting variables that are created/modified by a tag (at run-time).

VariableInfo(String, String, boolean, int) - Constructor for class javax.servlet.jsp.tagext.VariableInfo

Constructor These objects can be created (at translation time) by the TagExtraInfo instances.

VariableMapper - Class in javax.el

The interface to a map between EL variables and the EL expressions they are associated with.

VariableMapper() - Constructor for class javax.el.VariableMapper

VariableResolver - Class in javax.faces.el

Deprecated.
This has been replaced by ELResolver when operating with a null base argument.

VariableResolver() - Constructor for class javax.faces.el.VariableResolver

Deprecated.

VariableResolver - Interface in javax.servlet.jsp.el

Deprecated.
As of JSP 2.1, replaced by ELResolver

variant(Variant) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Set message entity representation metadata.

Variant - Class in javax.ws.rs.core

Abstraction for a resource representation variant.

Variant(MediaType, String, String) - Constructor for class javax.ws.rs.core.Variant

Create a new instance of Variant.

Variant(MediaType, String, String, String) - Constructor for class javax.ws.rs.core.Variant

Create a new instance of Variant.

Variant(MediaType, String, String, String, String) - Constructor for class javax.ws.rs.core.Variant

Create a new instance of Variant.

Variant(MediaType, Locale, String) - Constructor for class javax.ws.rs.core.Variant

Create a new instance of Variant.

Variant.VariantListBuilder - Class in javax.ws.rs.core

A builder for a list of representation variants.

Variant.VariantListBuilder() - Constructor for class javax.ws.rs.core.Variant.VariantListBuilder

Protected constructor, use the static newInstance method to obtain an instance.

variants(Variant...) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Add a Vary header that lists the available variants.

variants(List<Variant>) - Method in class javax.ws.rs.core.Response.ResponseBuilder

Add a Vary header that lists the available variants.

VARY - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

Version - Annotation Type in javax.persistence

Specifies the version field or property of an entity class that serves as its optimistic lock value.

Versionable - Interface in javax.xml.registry.infomodel

The Versionable interface defines the behavior common to classes that are capable of creating versions of their instances.

VERSIONABLE - Static variable in interface javax.xml.registry.LifeCycleManager

Constant representing the javax.xml.registry.infomodel.Versionable interface.

veto() - Method in interface javax.enterprise.inject.spi.ProcessAnnotatedType

Forces the container to ignore this type.

veto() - Method in interface javax.enterprise.inject.spi.ProcessBeanAttributes

Forces the container to ignore the bean.

Vetoed - Annotation Type in javax.enterprise.inject

Veto the processing of the class.

VIEW_DECLARATION_LANGUAGE_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the ViewDeclarationLanguage class name.

VIEW_LOCATION_KEY - Static variable in class javax.faces.component.UIComponent

The value of this constant is used as the key in the component attributes Map for the Location in the view at which this component instance resides.

VIEW_PARAMETERS_KEY - Static variable in class javax.faces.component.UIViewRoot

The key in the value set of the view metadata BeanDescriptor, the value of which is a List<UIViewParameter.Reference>.

VIEW_STATE_MARKER - Static variable in class javax.faces.context.PartialResponseWriter

Reserved ID value to indicate serialized ViewState.

VIEW_STATE_PARAM - Static variable in class javax.faces.render.ResponseStateManager

Implementations must use this constant field value as the name of the client parameter in which to save the state between requests.

ViewBuilder - Class in javax.faces.flow.builder

Create a view node in the current Flow.

ViewBuilder() - Constructor for class javax.faces.flow.builder.ViewBuilder

ViewDeclarationLanguage - Class in javax.faces.view

The contract that a view declaration language must implement to interact with the JSF runtime.

ViewDeclarationLanguage() - Constructor for class javax.faces.view.ViewDeclarationLanguage

ViewDeclarationLanguageFactory - Class in javax.faces.view

ViewDeclarationLanguageFactory is a factory object that creates (if needed) and returns a new ViewDeclarationLanguage instance based on the VDL found in a specific view.

ViewDeclarationLanguageFactory() - Constructor for class javax.faces.view.ViewDeclarationLanguageFactory

ViewDeclarationLanguageWrapper - Class in javax.faces.view

Provides a simple implementation of ViewDeclarationLanguage that can be subclassed by developers wishing to provide specialized behavior to an existing ViewDeclarationLanguage instance.

ViewDeclarationLanguageWrapper() - Constructor for class javax.faces.view.ViewDeclarationLanguageWrapper

viewExists(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguage

Tests whether a physical resource corresponding to the specified viewId exists.

viewExists(FacesContext, String) - Method in class javax.faces.view.ViewDeclarationLanguageWrapper

ViewExpiredException - Exception in javax.faces.application

Implementations must throw this FacesException when attempting to restore the view StateManager.restoreView(javax.faces.context.FacesContext, String, String) results in failure on postback.

ViewExpiredException() - Constructor for exception javax.faces.application.ViewExpiredException

Construct a new exception with no detail message or root cause.

ViewExpiredException(String) - Constructor for exception javax.faces.application.ViewExpiredException

Construct a new exception with the specified view identifier.

ViewExpiredException(String, String) - Constructor for exception javax.faces.application.ViewExpiredException

Construct a new exception with the specified detail message and no root cause.

ViewExpiredException(Throwable, String) - Constructor for exception javax.faces.application.ViewExpiredException

Construct a new exception with the specified root cause.

ViewExpiredException(String, Throwable, String) - Constructor for exception javax.faces.application.ViewExpiredException

Construct a new exception with the specified detail message and root cause.

ViewHandler - Class in javax.faces.application

ViewHandler is the pluggablity mechanism for allowing implementations of or applications using the JavaServer Faces specification to provide their own handling of the activities in the Render Response and Restore View phases of the request processing lifecycle.

ViewHandler() - Constructor for class javax.faces.application.ViewHandler

ViewHandlerWrapper - Class in javax.faces.application

Provides a simple implementation of ViewHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ViewHandler instance.

ViewHandlerWrapper() - Constructor for class javax.faces.application.ViewHandlerWrapper

ViewMapListener - Interface in javax.faces.event

Marker interface for SystemEvents that indicate the view map has been created (PostConstructViewMapEvent, or destroyed (PreDestroyViewMapEvent).

ViewMetadata - Class in javax.faces.view

ViewMetadata is reponsible for extracting and providing view parameter metadata from VDL views.

ViewMetadata() - Constructor for class javax.faces.view.ViewMetadata

viewNode(String, String) - Method in class javax.faces.flow.builder.FlowBuilder

Define a view node in a flow graph.

ViewNode - Class in javax.faces.flow

ViewNode is the class that represents a VDL view in a faces flow graph.

ViewNode() - Constructor for class javax.faces.flow.ViewNode

ViewResource - Class in javax.faces.application

Superclass of Resource that is only for use with views.

ViewResource() - Constructor for class javax.faces.application.ViewResource

ViewScoped - Annotation Type in javax.faces.bean

When this annotation, along with ManagedBean is found on a class, the runtime must act as if a <managed-bean-scope>view<managed-bean-scope> element was declared for the corresponding managed bean.

ViewScoped - Annotation Type in javax.faces.view

When this annotation, along with javax.inject.Named is found on a class, the runtime must place the bean in a CDI scope such that it remains active as long as NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) does not cause a navigation to a view with a viewId that is different than the viewId of the current view.

visit(VisitContext, UIComponent) - Method in interface javax.faces.component.visit.VisitCallback

This method is called during component tree visits by VisitContext.invokeVisitCallback() to visit the specified component.

VISIT_CONTEXT_FACTORY - Static variable in class javax.faces.FactoryFinder

The property name for the VisitContextFactory class name.

VisitCallback - Interface in javax.faces.component.visit

A simple callback interface that enables taking action on a specific UIComponent (either facet or child) during a component tree visit.

VisitContext - Class in javax.faces.component.visit

A context object that is used to hold state relating to performing a component tree visit.

VisitContext() - Constructor for class javax.faces.component.visit.VisitContext

VisitContextFactory - Class in javax.faces.component.visit

Provide for separation of interface and implementation for the VisitContext contract.

VisitContextFactory() - Constructor for class javax.faces.component.visit.VisitContextFactory

VisitContextWrapper - Class in javax.faces.component.visit

Provides a simple implementation of VisitContext that can be subclassed by developers wishing to provide specialized behavior to an existing VisitContext instance.

VisitContextWrapper() - Constructor for class javax.faces.component.visit.VisitContextWrapper

VisitHint - Enum in javax.faces.component.visit

An enum that specifies hints that impact the behavior of a component tree visit.

VisitResult - Enum in javax.faces.component.visit

An enum that specifies the possible results of a call to VisitCallback.visit(javax.faces.component.visit.VisitContext, javax.faces.component.UIComponent).

visitTree(VisitContext, VisitCallback) - Method in class javax.faces.component.UIComponent

Perform a tree visit starting at this node in the tree.

visitTree(VisitContext, VisitCallback) - Method in class javax.faces.component.UIData

Override the behavior in UIComponent.visitTree(javax.faces.component.visit.VisitContext, javax.faces.component.visit.VisitCallback) to handle iteration correctly.

visitTree(VisitContext, VisitCallback) - Method in class javax.faces.component.UIForm

visitTree(VisitContext, VisitCallback) - Method in class javax.faces.component.UINamingContainer

W

W3CDomHandler - Class in javax.xml.bind.annotation

DomHandler implementation for W3C DOM (org.w3c.dom package.)

W3CDomHandler() - Constructor for class javax.xml.bind.annotation.W3CDomHandler

Default constructor.

W3CDomHandler(DocumentBuilder) - Constructor for class javax.xml.bind.annotation.W3CDomHandler

Constructor that allows applications to specify which DOM implementation to be used.

W3CEndpointReference - Class in javax.xml.ws.wsaddressing

This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.

W3CEndpointReference() - Constructor for class javax.xml.ws.wsaddressing.W3CEndpointReference

W3CEndpointReference(Source) - Constructor for class javax.xml.ws.wsaddressing.W3CEndpointReference

Creates an EPR from infoset representation

W3CEndpointReferenceBuilder - Class in javax.xml.ws.wsaddressing

This class is used to build W3CEndpointReference instances.

W3CEndpointReferenceBuilder() - Constructor for class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Creates a new W3CEndpointReferenceBuilder instance.

WAR - Static variable in class javax.enterprise.deploy.shared.ModuleType

The module is an Web Application archive.

WARNING - Static variable in interface javax.xml.bind.ValidationEvent

Conditions that are not errors or fatal errors as defined by the XML 1.0 recommendation

wasCancelCalled() - Method in interface javax.ejb.SessionContext

Check whether a client invoked the cancel method on the client Future object corresponding to the currently executing asynchronous business method.

WEBAPP_CONTRACTS_DIRECTORY_PARAM_NAME - Static variable in class javax.faces.application.ResourceHandler

If a <context-param> with the param name equal to the value of ResourceHandler.WEBAPP_CONTRACTS_DIRECTORY_PARAM_NAME exists, the runtime must interpret its value as a path, relative to the web app root, where resource library contracts are to be located.

WEBAPP_RESOURCES_DIRECTORY_PARAM_NAME - Static variable in class javax.faces.application.ResourceHandler

If a <context-param> with the param name equal to the value of ResourceHandler.WEBAPP_RESOURCES_DIRECTORY_PARAM_NAME exists, the runtime must interpret its value as a path, relative to the web app root, where resources are to be located.

WebApplicationException - Exception in javax.ws.rs

Runtime exception for applications.

WebApplicationException() - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and default HTTP status code of 500.

WebApplicationException(String) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and default HTTP status code of 500.

WebApplicationException(Response) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance using the supplied response.

WebApplicationException(String, Response) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance using the supplied response.

WebApplicationException(int) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and specified HTTP status code.

WebApplicationException(String, int) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and specified HTTP status code.

WebApplicationException(Response.Status) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and specified HTTP status code.

WebApplicationException(String, Response.Status) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and specified HTTP status code.

WebApplicationException(Throwable) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and default HTTP status code of 500.

WebApplicationException(String, Throwable) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and default HTTP status code of 500.

WebApplicationException(Throwable, Response) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance using the supplied response.

WebApplicationException(String, Throwable, Response) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance using the supplied response.

WebApplicationException(Throwable, int) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and specified HTTP status code.

WebApplicationException(String, Throwable, int) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and specified HTTP status code.

WebApplicationException(Throwable, Response.Status) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and specified HTTP status code.

WebApplicationException(String, Throwable, Response.Status) - Constructor for exception javax.ws.rs.WebApplicationException

Construct a new instance with a blank message and specified HTTP status code.

WebConnection - Interface in javax.servlet.http

This interface encapsulates the connection for an upgrade request.

WebEndpoint - Annotation Type in javax.xml.ws

Used to annotate the getPortName() methods of a generated service interface.

WebFault - Annotation Type in javax.xml.ws

Used to annotate service specific exception classes to customize to the local and namespace name of the fault element and the name of the fault bean.

WebFilter - Annotation Type in javax.servlet.annotation

Annotation used to declare a servlet filter.

WebInitParam - Annotation Type in javax.servlet.annotation

This annotation is used on a Servlet or Filter implementation class to specify an initialization parameter.

WebListener - Annotation Type in javax.servlet.annotation

This annotation is used to declare a WebListener.

WebMethod - Annotation Type in javax.jws

WebParam - Annotation Type in javax.jws

WebParam.Mode - Enum in javax.jws

WebResourcePermission - Class in javax.security.jacc

Class for Servlet web resource permissions.

WebResourcePermission(String, String) - Constructor for class javax.security.jacc.WebResourcePermission

Creates a new WebResourcePermission with the specified name and actions.

WebResourcePermission(String, String[]) - Constructor for class javax.security.jacc.WebResourcePermission

Creates a new WebResourcePermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods.

WebResourcePermission(HttpServletRequest) - Constructor for class javax.security.jacc.WebResourcePermission

Creates a new WebResourcePermission from the HttpServletRequest object.

WebResult - Annotation Type in javax.jws

WebRoleRefPermission - Class in javax.security.jacc

Class for Servlet isUserInRole (String reference) permissions.

WebRoleRefPermission(String, String) - Constructor for class javax.security.jacc.WebRoleRefPermission

Creates a new WebRoleRefPermission with the specified name and actions.

WebService - Annotation Type in javax.jws

WebServiceClient - Annotation Type in javax.xml.ws

Used to annotate a generated service interface.

WebServiceContext - Interface in javax.xml.ws

A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served.

WebServiceException - Exception in javax.xml.ws

The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.

WebServiceException() - Constructor for exception javax.xml.ws.WebServiceException

Constructs a new exception with null as its detail message.

WebServiceException(String) - Constructor for exception javax.xml.ws.WebServiceException

Constructs a new exception with the specified detail message.

WebServiceException(String, Throwable) - Constructor for exception javax.xml.ws.WebServiceException

Constructs a new exception with the specified detail message and cause.

WebServiceException(Throwable) - Constructor for exception javax.xml.ws.WebServiceException

Constructs a new WebServiceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

WebServiceFeature - Class in javax.xml.ws

A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.

WebServiceFeature() - Constructor for class javax.xml.ws.WebServiceFeature

WebServiceFeatureAnnotation - Annotation Type in javax.xml.ws.spi

Annotation used to identify other annotations as a WebServiceFeature.

WebServicePermission - Class in javax.xml.ws

This class defines web service permissions.

WebServicePermission(String) - Constructor for class javax.xml.ws.WebServicePermission

Creates a new permission with the specified name.

WebServicePermission(String, String) - Constructor for class javax.xml.ws.WebServicePermission

Creates a new permission with the specified name and actions.

WebServiceProvider - Annotation Type in javax.xml.ws

Used to annotate a Provider implementation class.

WebServiceRef - Annotation Type in javax.xml.ws

The WebServiceRef annotation is used to define a reference to a web service and (optionally) an injection target for it.

WebServiceRefs - Annotation Type in javax.xml.ws

The WebServiceRefs annotation allows multiple web service references to be declared at the class level.

WebServlet - Annotation Type in javax.servlet.annotation

Annotation used to declare a servlet.

WebSocketContainer - Interface in javax.websocket

A WebSocketContainer is an implementation provided object that provides applications a view on the container running it.

WebTarget - Interface in javax.ws.rs.client

A resource target identified by the resource URI.

WebUserDataPermission - Class in javax.security.jacc

Class for Servlet Web user data permissions.

WebUserDataPermission(String, String) - Constructor for class javax.security.jacc.WebUserDataPermission

Creates a new WebUserDataPermission with the specified name and actions.

WebUserDataPermission(String, String[], String) - Constructor for class javax.security.jacc.WebUserDataPermission

Creates a new WebUserDataPermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods and the transport type.

WebUserDataPermission(HttpServletRequest) - Constructor for class javax.security.jacc.WebUserDataPermission

Creates a new WebUserDataPermission from the HttpServletRequest object.

when(Expression<Boolean>, R) - Method in interface javax.persistence.criteria.CriteriaBuilder.Case

Add a when/then clause to the case expression.

when(Expression<Boolean>, Expression<? extends R>) - Method in interface javax.persistence.criteria.CriteriaBuilder.Case

Add a when/then clause to the case expression.

when(C, R) - Method in interface javax.persistence.criteria.CriteriaBuilder.SimpleCase

Add a when/then clause to the case expression.

when(C, Expression<? extends R>) - Method in interface javax.persistence.criteria.CriteriaBuilder.SimpleCase

Add a when/then clause to the case expression.

where(Expression<Boolean>) - Method in interface javax.persistence.criteria.AbstractQuery

Modify the query to restrict the query results according to the specified boolean expression.

where(Predicate...) - Method in interface javax.persistence.criteria.AbstractQuery

Modify the query to restrict the query results according to the conjunction of the specified restriction predicates.

where(Expression<Boolean>) - Method in interface javax.persistence.criteria.CriteriaDelete

Modify the delete query to restrict the target of the deletion according to the specified boolean expression.

where(Predicate...) - Method in interface javax.persistence.criteria.CriteriaDelete

Modify the delete query to restrict the target of the deletion according to the conjunction of the specified restriction predicates.

where(Expression<Boolean>) - Method in interface javax.persistence.criteria.CriteriaQuery

Modify the query to restrict the query result according to the specified boolean expression.

where(Predicate...) - Method in interface javax.persistence.criteria.CriteriaQuery

Modify the query to restrict the query result according to the conjunction of the specified restriction predicates.

where(Expression<Boolean>) - Method in interface javax.persistence.criteria.CriteriaUpdate

Modify the update query to restrict the target of the update according to the specified boolean expression.

where(Predicate...) - Method in interface javax.persistence.criteria.CriteriaUpdate

Modify the update query to restrict the target of the update according to the conjunction of the specified restriction predicates.

where(Expression<Boolean>) - Method in interface javax.persistence.criteria.Subquery

Modify the subquery to restrict the result according to the specified boolean expression.

where(Predicate...) - Method in interface javax.persistence.criteria.Subquery

Modify the subquery to restrict the result according to the conjunction of the specified restriction predicates.

WILDCARD - Static variable in class javax.ws.rs.core.MediaType

A String constant representing wildcard ""*/*"" media type .

WILDCARD_TYPE - Static variable in class javax.ws.rs.core.MediaType

A MediaType constant representing wildcard ""*/*"" media type.

willDecode(ByteBuffer) - Method in interface javax.websocket.Decoder.Binary

Answer whether the given bytes can be decoded into an object of type T.

willDecode(String) - Method in interface javax.websocket.Decoder.Text

Answer whether the given String can be decoded into an object of type T.

WithAnnotations - Annotation Type in javax.enterprise.inject.spi

WithAnnotations may be applied to any portable extension observer method with an event parameter type of ProcessAnnotatedType to filter the events delivered.

withCharset(String) - Method in class javax.ws.rs.core.MediaType

Create a new MediaType instance with the same type, subtype and parameters copied from the original instance and the supplied ""charset"" parameter.

withConfig(Configuration) - Method in class javax.ws.rs.client.ClientBuilder

Set the internal configuration state to an externally provided configuration state.

Work - Interface in javax.resource.spi.work

This models a Work instance that would be executed by a WorkManager upon submission.

WORK_ACCEPTED - Static variable in class javax.resource.spi.work.WorkEvent

Indicates Work instance has been accepted.

WORK_COMPLETED - Static variable in class javax.resource.spi.work.WorkEvent

Indicates Work instance has completed execution.

WORK_REJECTED - Static variable in class javax.resource.spi.work.WorkEvent

Indicates Work instance has been rejected.

WORK_STARTED - Static variable in class javax.resource.spi.work.WorkEvent

Indicates Work instance has started execution.

workAccepted(WorkEvent) - Method in class javax.resource.spi.work.WorkAdapter

Invoked when a Work instance has been accepted.

workAccepted(WorkEvent) - Method in interface javax.resource.spi.work.WorkListener

Invoked when a Work instance has been accepted.

WorkAdapter - Class in javax.resource.spi.work

This class is provided as a convenience for easily creating WorkListener instances by extending this class and overriding only those methods of interest.

WorkAdapter() - Constructor for class javax.resource.spi.work.WorkAdapter

workCompleted(WorkEvent) - Method in class javax.resource.spi.work.WorkAdapter

Invoked when a Work instance has completed execution.

workCompleted(WorkEvent) - Method in interface javax.resource.spi.work.WorkListener

Invoked when a Work instance has completed execution.

WorkCompletedException - Exception in javax.resource.spi.work

This exception is thrown by a WorkManager to indicate that a submitted Work instance has completed with an exception.

WorkCompletedException() - Constructor for exception javax.resource.spi.work.WorkCompletedException

Constructs a new instance with null as its detail message.

WorkCompletedException(String) - Constructor for exception javax.resource.spi.work.WorkCompletedException

Constructs a new instance with the specified detail message.

WorkCompletedException(Throwable) - Constructor for exception javax.resource.spi.work.WorkCompletedException

Constructs a new throwable with the specified cause.

WorkCompletedException(String, Throwable) - Constructor for exception javax.resource.spi.work.WorkCompletedException

Constructs a new throwable with the specified detail message and cause.

WorkCompletedException(String, String) - Constructor for exception javax.resource.spi.work.WorkCompletedException

Constructs a new throwable with the specified detail message and an error code.

WorkContext - Interface in javax.resource.spi.work

This class serves as a standard mechanism for a resource adapter to propagate an imported context from an enterprise information system to an application server.

WorkContextErrorCodes - Class in javax.resource.spi.work

This class models the possible error conditions that might occur during associating an WorkContext with a Work instance.

WorkContextErrorCodes() - Constructor for class javax.resource.spi.work.WorkContextErrorCodes

WorkContextLifecycleListener - Interface in javax.resource.spi.work

This class models the various events that occur during the processing of the WorkContexts associated with a Work instance.

WorkContextProvider - Interface in javax.resource.spi.work

This interface specifies the methods a Work instance uses to associate a List of WorkContext instances to be set when the Work instance gets executed by a WorkManager.

WorkEvent - Class in javax.resource.spi.work

This class models the various events that occur during the processing of a Work instance.

WorkEvent(Object, int, Work, WorkException) - Constructor for class javax.resource.spi.work.WorkEvent

Constructor.

WorkEvent(Object, int, Work, WorkException, long) - Constructor for class javax.resource.spi.work.WorkEvent

Constructor.

WorkException - Exception in javax.resource.spi.work

A common base class for all Work processing related exceptions.

WorkException() - Constructor for exception javax.resource.spi.work.WorkException

Constructs a new instance with null as its detail message.

WorkException(String) - Constructor for exception javax.resource.spi.work.WorkException

Constructs a new instance with the specified detail message.

WorkException(Throwable) - Constructor for exception javax.resource.spi.work.WorkException

Constructs a new throwable with the specified cause.

WorkException(String, Throwable) - Constructor for exception javax.resource.spi.work.WorkException

Constructs a new throwable with the specified detail message and cause.

WorkException(String, String) - Constructor for exception javax.resource.spi.work.WorkException

Constructs a new throwable with the specified detail message and an error code.

WorkListener - Interface in javax.resource.spi.work

This models a WorkListener instance which would be notified by the WorkManager when the various Work processing events (work accepted, work rejected, work started, work completed) occur.

WorkManager - Interface in javax.resource.spi.work

This interface models a WorkManager which provides a facility to submit Work instances for execution.

workRejected(WorkEvent) - Method in class javax.resource.spi.work.WorkAdapter

Invoked when a Work instance has been rejected.

workRejected(WorkEvent) - Method in interface javax.resource.spi.work.WorkListener

Invoked when a Work instance has been rejected.

WorkRejectedException - Exception in javax.resource.spi.work

This exception is thrown by a WorkManager to indicate that a submitted Work instance has been rejected.

WorkRejectedException() - Constructor for exception javax.resource.spi.work.WorkRejectedException

Constructs a new instance with null as its detail message.

WorkRejectedException(String) - Constructor for exception javax.resource.spi.work.WorkRejectedException

Constructs a new instance with the specified detail message.

WorkRejectedException(Throwable) - Constructor for exception javax.resource.spi.work.WorkRejectedException

Constructs a new throwable with the specified cause.

WorkRejectedException(String, Throwable) - Constructor for exception javax.resource.spi.work.WorkRejectedException

Constructs a new throwable with the specified detail message and cause.

WorkRejectedException(String, String) - Constructor for exception javax.resource.spi.work.WorkRejectedException

Constructs a new throwable with the specified detail message and an error code.

workStarted(WorkEvent) - Method in class javax.resource.spi.work.WorkAdapter

Invoked when a Work instance has started execution.

workStarted(WorkEvent) - Method in interface javax.resource.spi.work.WorkListener

Invoked when a Work instance has started execution.

wrapExpressionFactory(ExpressionFactory) - Method in interface javax.enterprise.inject.spi.BeanManager

Returns a wrapper ExpressionFactory that delegates MethodExpression and ValueExpression creation to the given ExpressionFactory.

write(char[], int, int) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call Writer.write(char[], int, int) on the wrapped ResponseWriter object.

write(JsonStructure) - Method in interface javax.json.JsonWriter

Writes the specified JSON object or array to the output source.

write(String, JsonValue) - Method in interface javax.json.stream.JsonGenerator

Writes a JSON name/value pair in the current object context.

write(String, String) - Method in interface javax.json.stream.JsonGenerator

Writes a JSON name/string value pair in the current object context.

write(String, BigInteger) - Method in interface javax.json.stream.JsonGenerator

Writes a JSON name/number value pair in the current object context.

write(String, BigDecimal) - Method in interface javax.json.stream.JsonGenerator

Writes a JSON name/number value pair in the current object context.

write(String, int) - Method in interface javax.json.stream.JsonGenerator

Writes a JSON name/number value pair in the current object context.

write(String, long) - Method in interface javax.json.stream.JsonGenerator

Writes a JSON name/number value pair in the current object context.

write(String, double) - Method in interface javax.json.stream.JsonGenerator

Writes a JSON name/number value pair in the current object context.

write(String, boolean) - Method in interface javax.json.stream.JsonGenerator

Writes a JSON name/boolean value pair in the current object context.

write(JsonValue) - Method in interface javax.json.stream.JsonGenerator

Writes the specified value as a JSON value within the current array context.

write(String) - Method in interface javax.json.stream.JsonGenerator

Writes the specified value as a JSON string value within the current array context.

write(BigDecimal) - Method in interface javax.json.stream.JsonGenerator

Writes the specified value as a JSON number value within the current array context.

write(BigInteger) - Method in interface javax.json.stream.JsonGenerator

Writes the specified value as a JSON number value within the current array context.

write(int) - Method in interface javax.json.stream.JsonGenerator

Writes the specified value as a JSON number value within the current array context.

write(long) - Method in interface javax.json.stream.JsonGenerator

Writes the specified value as a JSON number value within the current array context.

write(double) - Method in interface javax.json.stream.JsonGenerator

Writes the specified value as a JSON number value within the current array context.

write(boolean) - Method in interface javax.json.stream.JsonGenerator

Writes a JSON true or false value within the current array context.

write(OutputStream) - Method in interface javax.resource.cci.Streamable

Write fields of a Streamable object to an OutputStream

write(String) - Method in interface javax.servlet.http.Part

A convenience method to write this uploaded item to disk.

write(OutputStream) - Method in interface javax.ws.rs.core.StreamingOutput

Called to write the message body.

WRITE_XML_DECLARATION - Static variable in class javax.xml.soap.SOAPMessage

Specifies whether the SOAP Message will contain an XML declaration when it is sent.

writeArray(JsonArray) - Method in interface javax.json.JsonWriter

Writes the specified JSON array to the output source.

writeAttribute(String, Object, String) - Method in class javax.faces.context.ResponseWriter

Write an attribute name and corresponding value, after converting that text to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.

writeAttribute(String, Object, String) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.writeAttribute(String, Object, String) on the wrapped ResponseWriter object.

writeBoolean(boolean) - Method in interface javax.jms.BytesMessage

Writes a boolean to the bytes message stream as a 1-byte value.

writeBoolean(boolean) - Method in interface javax.jms.StreamMessage

Writes a boolean to the stream message.

writeByte(byte) - Method in interface javax.jms.BytesMessage

Writes a byte to the bytes message stream as a 1-byte value.

writeByte(byte) - Method in interface javax.jms.StreamMessage

Writes a byte to the stream message.

writeBytes(byte[]) - Method in interface javax.jms.BytesMessage

Writes a byte array to the bytes message stream.

writeBytes(byte[], int, int) - Method in interface javax.jms.BytesMessage

Writes a portion of a byte array to the bytes message stream.

writeBytes(byte[]) - Method in interface javax.jms.StreamMessage

Writes a byte array field to the stream message.

writeBytes(byte[], int, int) - Method in interface javax.jms.StreamMessage

Writes a portion of a byte array as a byte array field to the stream message.

writeChar(char) - Method in interface javax.jms.BytesMessage

Writes a char to the bytes message stream as a 2-byte value, high byte first.

writeChar(char) - Method in interface javax.jms.StreamMessage

Writes a char to the stream message.

writeComment(Object) - Method in class javax.faces.context.ResponseWriter

Write a comment containing the specified text, after converting that text to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.

writeComment(Object) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.writeComment(Object) on the wrapped ResponseWriter object.

writeDoctype(String) - Method in class javax.faces.context.ResponseWriter

Write a string containing the markup specific doctype.

writeDoctype(String) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.writeDoctype(java.lang.String) on the wrapped ResponseWriter object.

writeDouble(double) - Method in interface javax.jms.BytesMessage

Converts the double argument to a long using the doubleToLongBits method in class Double, and then writes that long value to the bytes message stream as an 8-byte quantity, high byte first.

writeDouble(double) - Method in interface javax.jms.StreamMessage

Writes a double to the stream message.

writeEJBHome(EJBHome, ObjectOutputStream) - Method in interface javax.ejb.spi.HandleDelegate

Serialize the EJBHome reference corresponding to a HomeHandle.

writeEJBObject(EJBObject, ObjectOutputStream) - Method in interface javax.ejb.spi.HandleDelegate

Serialize the EJBObject reference corresponding to a Handle.

writeEnd() - Method in interface javax.json.stream.JsonGenerator

Writes the end of the current context.

writeFloat(float) - Method in interface javax.jms.BytesMessage

Converts the float argument to an int using the floatToIntBits method in class Float, and then writes that int value to the bytes message stream as a 4-byte quantity, high byte first.

writeFloat(float) - Method in interface javax.jms.StreamMessage

Writes a float to the stream message.

writeInt(int) - Method in interface javax.jms.BytesMessage

Writes an int to the bytes message stream as four bytes, high byte first.

writeInt(int) - Method in interface javax.jms.StreamMessage

Writes an int to the stream message.

writeItems(List<Object>) - Method in class javax.batch.api.chunk.AbstractItemWriter

Implement write logic for the ItemWriter in this method.

writeItems(List<Object>) - Method in interface javax.batch.api.chunk.ItemWriter

The writeItems method writes a list of item for the current chunk.

WriteListener - Interface in javax.servlet

Callback notification mechanism that signals to the developer it's possible to write content without blocking.

writeLong(long) - Method in interface javax.jms.BytesMessage

Writes a long to the bytes message stream as eight bytes, high byte first.

writeLong(long) - Method in interface javax.jms.StreamMessage

Writes a long to the stream message.

writeNull(String) - Method in interface javax.json.stream.JsonGenerator

Writes a JSON name/null value pair in an current object context.

writeNull() - Method in interface javax.json.stream.JsonGenerator

Writes a JSON null value within the current array context.

writeObject(Object) - Method in interface javax.jms.BytesMessage

Writes an object to the bytes message stream.

writeObject(Object) - Method in interface javax.jms.StreamMessage

Writes an object to the stream message.

writeObject(JsonObject) - Method in interface javax.json.JsonWriter

Writes the specified JSON object to the output source.

writeOut(Writer) - Method in class javax.servlet.jsp.tagext.BodyContent

Write the contents of this BodyContent into a Writer.

writePreamble(String) - Method in class javax.faces.context.ResponseWriter

Write a string containing the markup specific preamble.

writePreamble(String) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.writePreamble(java.lang.String) on the wrapped ResponseWriter object.

WriterInterceptor - Interface in javax.ws.rs.ext

Interface for message body writer interceptors that wrap around calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream).

WriterInterceptorContext - Interface in javax.ws.rs.ext

Context class used by WriterInterceptor to intercept calls to MessageBodyWriter.writeTo(T, java.lang.Class<?>, java.lang.reflect.Type, java.lang.annotation.Annotation[], javax.ws.rs.core.MediaType, javax.ws.rs.core.MultivaluedMap<java.lang.String, java.lang.Object>, java.io.OutputStream).

writeShort(short) - Method in interface javax.jms.BytesMessage

Writes a short to the bytes message stream as two bytes, high byte first.

writeShort(short) - Method in interface javax.jms.StreamMessage

Writes a short to the stream message.

writeStartArray() - Method in interface javax.json.stream.JsonGenerator

Writes the JSON start array character.

writeStartArray(String) - Method in interface javax.json.stream.JsonGenerator

Writes the JSON name/start array character pair with in the current object context.

writeStartObject() - Method in interface javax.json.stream.JsonGenerator

Writes the JSON start object character.

writeStartObject(String) - Method in interface javax.json.stream.JsonGenerator

Writes the JSON name/start object character pair in the current object context.

writeState(FacesContext, Object) - Method in class javax.faces.application.StateManager

Save the state represented in the specified state Object instance, in an implementation dependent manner.

writeState(FacesContext, StateManager.SerializedView) - Method in class javax.faces.application.StateManager

Deprecated.
This method has been replaced by StateManager.writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation calls the non-deprecated variant of the method passing an Object [] as the second argument, where the first element of the array is the return from getStructure() and the second is the return from getState() on the argument state.

writeState(FacesContext, Object) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object) on the wrapped StateManager object.

writeState(FacesContext, StateManager.SerializedView) - Method in class javax.faces.application.StateManagerWrapper

The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView) on the wrapped StateManager object.

writeState(FacesContext) - Method in class javax.faces.application.ViewHandler

Take any appropriate action to either immediately write out the current state information (by calling StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object), or noting where state information should later be written.

writeState(FacesContext) - Method in class javax.faces.application.ViewHandlerWrapper

The default behavior of this method is to call ViewHandler.writeState(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

writeState(FacesContext, Object) - Method in class javax.faces.render.ResponseStateManager

Take the argument state and write it into the output using the current ResponseWriter, which must be correctly positioned already.

writeState(FacesContext, StateManager.SerializedView) - Method in class javax.faces.render.ResponseStateManager

Deprecated.
This method has been replaced by ResponseStateManager.writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation creates a two element Object array with the first element being the return from calling StateManager.SerializedView.getStructure(), and the second being the return from StateManager.SerializedView.getState(). It then passes this Object array to ResponseStateManager.writeState(javax.faces.context.FacesContext, java.lang.Object).

writeString(String) - Method in interface javax.jms.StreamMessage

Writes a String to the stream message.

writeText(Object, String) - Method in class javax.faces.context.ResponseWriter

Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.

writeText(Object, UIComponent, String) - Method in class javax.faces.context.ResponseWriter

Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.

writeText(char[], int, int) - Method in class javax.faces.context.ResponseWriter

Write text from a character array, after any performing any escaping appropriate for the markup language being rendered.

writeText(Object, String) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.writeText(Object, String) on the wrapped ResponseWriter object.

writeText(Object, UIComponent, String) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.writeText(Object, UIComponent, String) on the wrapped ResponseWriter object.

writeText(char[], int, int) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.writeText(char[], int, int) on the wrapped ResponseWriter object.

writeTo(OutputStream) - Method in class javax.mail.internet.MimeBodyPart

Output the body part as an RFC 822 format stream.

writeTo(OutputStream) - Method in class javax.mail.internet.MimeMessage

Output the message as an RFC 822 format stream.

writeTo(OutputStream, String[]) - Method in class javax.mail.internet.MimeMessage

Output the message as an RFC 822 format stream, without specified headers.

writeTo(OutputStream) - Method in class javax.mail.internet.MimeMultipart

Iterates through all the parts and outputs each MIME part separated by a boundary.

writeTo(OutputStream) - Method in class javax.mail.internet.PreencodedMimeBodyPart

Output the body part as an RFC 822 format stream.

writeTo(OutputStream) - Method in class javax.mail.Multipart

Output an appropriately encoded bytestream to the given OutputStream.

writeTo(OutputStream) - Method in interface javax.mail.Part

Output a bytestream for this Part.

writeTo(T, Class<?>, Type, Annotation[], MediaType, MultivaluedMap<String, Object>, OutputStream) - Method in interface javax.ws.rs.ext.MessageBodyWriter

Write a type to an HTTP message.

writeTo(OutputStream) - Method in class javax.xml.soap.SOAPMessage

Writes this SOAPMessage object to the given output stream.

writeTo(Result) - Method in class javax.xml.ws.EndpointReference

write this EndpointReference to the specified infoset format

writeTo(Result) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReference

write this EndpointReference to the specified infoset format

writeURIAttribute(String, Object, String) - Method in class javax.faces.context.ResponseWriter

Write a URI attribute name and corresponding value, after converting that text to a String (if necessary), and after performing any encoding or escaping appropriate to the markup language being rendered.

writeURIAttribute(String, Object, String) - Method in class javax.faces.context.ResponseWriterWrapper

The default behavior of this method is to call ResponseWriter.writeURIAttribute(String, Object, String) on the wrapped ResponseWriter object.

writeUTF(String) - Method in interface javax.jms.BytesMessage

Writes a string to the bytes message stream using UTF-8 encoding in a machine-independent manner.

WSDL_DESCRIPTION - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: input source for WSDL document.

WSDL_INTERFACE - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: name of wsdl interface (2.0) or port type (1.1).

WSDL_OPERATION - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: name of WSDL operation.

WSDL_PORT - Static variable in class javax.xml.ws.Endpoint

Standard property: name of WSDL port.

WSDL_PORT - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: name of WSDL port.

WSDL_SERVICE - Static variable in class javax.xml.ws.Endpoint

Standard property: name of WSDL service.

WSDL_SERVICE - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: name of WSDL service.

wsdlDocumentLocation(String) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation.

WWW_AUTHENTICATE - Static variable in interface javax.ws.rs.core.HttpHeaders

See HTTP/1.1 documentation.

X

XA_HEURCOM - Static variable in exception javax.transaction.xa.XAException

The transaction branch has been heuristically committed.

XA_HEURHAZ - Static variable in exception javax.transaction.xa.XAException

The transaction branch may have been heuristically completed.

XA_HEURMIX - Static variable in exception javax.transaction.xa.XAException

The transaction branch has been heuristically committed and rolled back.

XA_HEURRB - Static variable in exception javax.transaction.xa.XAException

The transaction branch has been heuristically rolled back.

XA_NOMIGRATE - Static variable in exception javax.transaction.xa.XAException

Resumption must occur where the suspension occurred.

XA_OK - Static variable in interface javax.transaction.xa.XAResource

The transaction work has been prepared normally.

XA_RBBASE - Static variable in exception javax.transaction.xa.XAException

The inclusive lower bound of the rollback codes.

XA_RBCOMMFAIL - Static variable in exception javax.transaction.xa.XAException

Indicates that the rollback was caused by a communication failure.

XA_RBDEADLOCK - Static variable in exception javax.transaction.xa.XAException

A deadlock was detected.

XA_RBEND - Static variable in exception javax.transaction.xa.XAException

The inclusive upper bound of the rollback error code.

XA_RBINTEGRITY - Static variable in exception javax.transaction.xa.XAException

A condition that violates the integrity of the resource was detected.

XA_RBOTHER - Static variable in exception javax.transaction.xa.XAException

The resource manager rolled back the transaction branch for a reason not on this list.

XA_RBPROTO - Static variable in exception javax.transaction.xa.XAException

A protocol error occurred in the resource manager.

XA_RBROLLBACK - Static variable in exception javax.transaction.xa.XAException

Indicates that the rollback was caused by an unspecified reason.

XA_RBTIMEOUT - Static variable in exception javax.transaction.xa.XAException

A transaction branch took too long.

XA_RBTRANSIENT - Static variable in exception javax.transaction.xa.XAException

May retry the transaction branch.

XA_RDONLY - Static variable in exception javax.transaction.xa.XAException

The transaction branch was read-only and has been committed.

XA_RDONLY - Static variable in interface javax.transaction.xa.XAResource

The transaction branch has been read-only and has been committed.

XA_RETRY - Static variable in exception javax.transaction.xa.XAException

Routine returned with no effect and may be reissued.

XAConnection - Interface in javax.jms

The XAConnection interface extends the capability of Connection by providing an XASession (optional).

XAConnectionFactory - Interface in javax.jms

The XAConnectionFactory interface is a base interface for the XAQueueConnectionFactory and XATopicConnectionFactory interfaces.

XAER_ASYNC - Static variable in exception javax.transaction.xa.XAException

There is an asynchronous operation already outstanding.

XAER_DUPID - Static variable in exception javax.transaction.xa.XAException

The XID already exists.

XAER_INVAL - Static variable in exception javax.transaction.xa.XAException

Invalid arguments were given.

XAER_NOTA - Static variable in exception javax.transaction.xa.XAException

The XID is not valid.

XAER_OUTSIDE - Static variable in exception javax.transaction.xa.XAException

The resource manager is doing work outside a global transaction.

XAER_PROTO - Static variable in exception javax.transaction.xa.XAException

Routine was invoked in an improper context.

XAER_RMERR - Static variable in exception javax.transaction.xa.XAException

A resource manager error has occurred in the transaction branch.

XAER_RMFAIL - Static variable in exception javax.transaction.xa.XAException

Resource manager is unavailable.

XAException - Exception in javax.transaction.xa

The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.

XAException() - Constructor for exception javax.transaction.xa.XAException

Create an XAException.

XAException(String) - Constructor for exception javax.transaction.xa.XAException

Create an XAException with a given string.

XAException(int) - Constructor for exception javax.transaction.xa.XAException

Create an XAException with a given error code.

XAJMSContext - Interface in javax.jms

The XAJMSContext interface extends the capability of JMSContext by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional).

XAQueueConnection - Interface in javax.jms

An XAQueueConnection provides the same create options as QueueConnection (optional).

XAQueueConnectionFactory - Interface in javax.jms

An XAQueueConnectionFactory provides the same create options as a QueueConnectionFactory (optional).

XAQueueSession - Interface in javax.jms

An XAQueueSession provides a regular QueueSession, which can be used to create QueueReceiver, QueueSender, and QueueBrowser objects (optional).

XAResource - Interface in javax.transaction.xa

The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).

XASession - Interface in javax.jms

The XASession interface extends the capability of Session by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional).

XATerminator - Interface in javax.resource.spi

The XATerminator interface is used for transaction completion and crash recovery flows.

XATopicConnection - Interface in javax.jms

An XATopicConnection provides the same create options as TopicConnection (optional).

XATopicConnectionFactory - Interface in javax.jms

An XATopicConnectionFactory provides the same create options as a TopicConnectionFactory (optional).

XATopicSession - Interface in javax.jms

An XATopicSession provides a regular TopicSession.

xhtml(T) - Static method in class javax.ws.rs.client.Entity

Create an "application/xhtml+xml" entity.

Xid - Interface in javax.transaction.xa

The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.

xml(T) - Static method in class javax.ws.rs.client.Entity

Create an "application/xml" entity.

XmlAccessOrder - Enum in javax.xml.bind.annotation

Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.

XmlAccessorOrder - Annotation Type in javax.xml.bind.annotation

Controls the ordering of fields and properties in a class.

XmlAccessorType - Annotation Type in javax.xml.bind.annotation

Controls whether fields or Javabean properties are serialized by default.

XmlAccessType - Enum in javax.xml.bind.annotation

Used by XmlAccessorType to control serialization of fields or properties.

XmlAdapter<ValueType,BoundType> - Class in javax.xml.bind.annotation.adapters

Adapts a Java type for custom marshaling.

XmlAdapter() - Constructor for class javax.xml.bind.annotation.adapters.XmlAdapter

Do-nothing constructor for the derived classes.

XmlAnyAttribute - Annotation Type in javax.xml.bind.annotation

Maps a JavaBean property to a map of wildcard attributes.

XmlAnyElement - Annotation Type in javax.xml.bind.annotation

Maps a JavaBean property to XML infoset representation and/or JAXB element.

XmlAttachmentRef - Annotation Type in javax.xml.bind.annotation

Marks a field/property that its XML form is a uri reference to mime content.

XmlAttribute - Annotation Type in javax.xml.bind.annotation

Maps a JavaBean property to a XML attribute.

XmlElement - Annotation Type in javax.xml.bind.annotation

Maps a JavaBean property to a XML element derived from property name.

XmlElement.DEFAULT - Class in javax.xml.bind.annotation

Used in XmlElement.type() to signal that the type be inferred from the signature of the property.

XmlElement.DEFAULT() - Constructor for class javax.xml.bind.annotation.XmlElement.DEFAULT

XmlElementDecl - Annotation Type in javax.xml.bind.annotation

Maps a factory method to a XML element.

XmlElementDecl.GLOBAL - Class in javax.xml.bind.annotation

Used in XmlElementDecl.scope() to signal that the declaration is in the global scope.

XmlElementDecl.GLOBAL() - Constructor for class javax.xml.bind.annotation.XmlElementDecl.GLOBAL

XmlElementRef - Annotation Type in javax.xml.bind.annotation

Maps a JavaBean property to a XML element derived from property's type.

XmlElementRef.DEFAULT - Class in javax.xml.bind.annotation

Used in XmlElementRef.type() to signal that the type be inferred from the signature of the property.

XmlElementRef.DEFAULT() - Constructor for class javax.xml.bind.annotation.XmlElementRef.DEFAULT

XmlElementRefs - Annotation Type in javax.xml.bind.annotation

Marks a property that refers to classes with XmlElement or JAXBElement.

XmlElements - Annotation Type in javax.xml.bind.annotation

A container for multiple @XmlElement annotations.

XmlElementWrapper - Annotation Type in javax.xml.bind.annotation

Generates a wrapper element around XML representation.

XmlEnum - Annotation Type in javax.xml.bind.annotation

Maps an enum type Enum to XML representation.

XmlEnumValue - Annotation Type in javax.xml.bind.annotation

Maps an enum constant in Enum type to XML representation.

XmlID - Annotation Type in javax.xml.bind.annotation

Maps a JavaBean property to XML ID.

XmlIDREF - Annotation Type in javax.xml.bind.annotation

Maps a JavaBean property to XML IDREF.

XmlInlineBinaryData - Annotation Type in javax.xml.bind.annotation

Disable consideration of XOP encoding for datatypes that are bound to base64-encoded binary data in XML.

XmlJavaTypeAdapter - Annotation Type in javax.xml.bind.annotation.adapters

Use an adapter that implements XmlAdapter for custom marshaling.

XmlJavaTypeAdapter.DEFAULT - Class in javax.xml.bind.annotation.adapters

Used in XmlJavaTypeAdapter.type() to signal that the type be inferred from the signature of the field, property, parameter or the class.

XmlJavaTypeAdapter.DEFAULT() - Constructor for class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT

XmlJavaTypeAdapters - Annotation Type in javax.xml.bind.annotation.adapters

A container for multiple @XmlJavaTypeAdapter annotations.

XmlList - Annotation Type in javax.xml.bind.annotation

Used to map a property to a list simple type.

XmlMimeType - Annotation Type in javax.xml.bind.annotation

Associates the MIME type that controls the XML representation of the property.

XmlMixed - Annotation Type in javax.xml.bind.annotation

Annotate a JavaBean multi-valued property to support mixed content.

XmlNs - Annotation Type in javax.xml.bind.annotation

Associates a namespace prefix with a XML namespace URI.

XmlNsForm - Enum in javax.xml.bind.annotation

Enumeration of XML Schema namespace qualifications.

XmlRegistry - Annotation Type in javax.xml.bind.annotation

Marks a class that has XmlElementDecls.

XmlRootElement - Annotation Type in javax.xml.bind.annotation

Maps a class or an enum type to an XML element.

XmlSchema - Annotation Type in javax.xml.bind.annotation

Maps a package name to a XML namespace.

XmlSchemaType - Annotation Type in javax.xml.bind.annotation

Maps a Java type to a simple schema built-in type.

XmlSchemaType.DEFAULT - Class in javax.xml.bind.annotation

Used in XmlSchemaType.type() to signal that the type be inferred from the signature of the property.

XmlSchemaType.DEFAULT() - Constructor for class javax.xml.bind.annotation.XmlSchemaType.DEFAULT

XmlSchemaTypes - Annotation Type in javax.xml.bind.annotation

A container for multiple @XmlSchemaType annotations.

XmlSeeAlso - Annotation Type in javax.xml.bind.annotation

Instructs JAXB to also bind other classes when binding this class.

XmlTransient - Annotation Type in javax.xml.bind.annotation

Prevents the mapping of a JavaBean property/type to XML representation.

XmlType - Annotation Type in javax.xml.bind.annotation

Maps a class or an enum type to a XML Schema type.

XMLType - Class in javax.xml.rpc.encoding

Constants for common XML Schema and SOAP 1.1 types.

XMLType() - Constructor for class javax.xml.rpc.encoding.XMLType

XmlType.DEFAULT - Class in javax.xml.bind.annotation

Used in XmlType.factoryClass() to signal that either factory mehod is not used or that it's in the class with this XmlType itself.

XmlType.DEFAULT() - Constructor for class javax.xml.bind.annotation.XmlType.DEFAULT

XmlValue - Annotation Type in javax.xml.bind.annotation

Enables mapping a class to a XML Schema complex type with a simpleContent or a XML Schema simple type.

XpathEvent - Class in javax.enterprise.deploy.model

An Event class describing ConfigBeans being added/subtracted from a server configuration.

XpathEvent(DDBean, Object) - Constructor for class javax.enterprise.deploy.model.XpathEvent

A description of a change in the ConfigBean tree.

XpathListener - Interface in javax.enterprise.deploy.model

The listener interface for receiving XpathEvents

XSD_BASE64 - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:base64Binary type.

XSD_BOOLEAN - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:boolean type.

XSD_BYTE - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:byte type.

XSD_DATETIME - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:dateTime type.

XSD_DECIMAL - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:decimal type.

XSD_DOUBLE - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:double type.

XSD_FLOAT - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:float type.

XSD_HEXBINARY - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:hexBinary type.

XSD_INT - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:int type.

XSD_INTEGER - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:integer type.

XSD_LONG - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:long type.

XSD_QNAME - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:QName type.

XSD_SHORT - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:short type.

XSD_STRING - Static variable in class javax.xml.rpc.encoding.XMLType

The name of the xsd:string type.

Y

year(String) - Method in class javax.ejb.ScheduleExpression

Set the year attribute.

year(int) - Method in class javax.ejb.ScheduleExpression

Set the year attribute.

_

_getProperty(String) - Method in interface javax.xml.rpc.Stub

Gets the value of a specific configuration property.

_getPropertyNames() - Method in interface javax.xml.rpc.Stub

Returns an Iterato view of the names of the properties that can be configured on this stub instance.

_jspService(HttpServletRequest, HttpServletResponse) - Method in interface javax.servlet.jsp.HttpJspPage

The _jspService()method corresponds to the body of the JSP page.

_setProperty(String, Object) - Method in interface javax.xml.rpc.Stub

Sets the name and value of a configuration property for this Stub instance.

A B C D E F G H I J K L M N O P Q R S T U V W X Y _

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

Prev

Next

Frames

No Frames

All Classes


Overview List (Java(TM) EE 7 Specification APIs)

All Classes

Packages

  • javax.annotation
  • javax.annotation.security
  • javax.annotation.sql
  • javax.batch.api
  • javax.batch.api.chunk
  • javax.batch.api.chunk.listener
  • javax.batch.api.listener
  • javax.batch.api.partition
  • javax.batch.operations
  • javax.batch.runtime
  • javax.batch.runtime.context
  • javax.decorator
  • javax.ejb
  • javax.ejb.embeddable
  • javax.ejb.spi
  • javax.el
  • javax.enterprise.concurrent
  • javax.enterprise.context
  • javax.enterprise.context.spi
  • javax.enterprise.deploy.model
  • javax.enterprise.deploy.model.exceptions
  • javax.enterprise.deploy.shared
  • javax.enterprise.deploy.shared.factories
  • javax.enterprise.deploy.spi
  • javax.enterprise.deploy.spi.exceptions
  • javax.enterprise.deploy.spi.factories
  • javax.enterprise.deploy.spi.status
  • javax.enterprise.event
  • javax.enterprise.inject
  • javax.enterprise.inject.spi
  • javax.enterprise.util
  • javax.faces
  • javax.faces.application
  • javax.faces.bean
  • javax.faces.component
  • javax.faces.component.behavior
  • javax.faces.component.html
  • javax.faces.component.visit
  • javax.faces.context
  • javax.faces.convert
  • javax.faces.el
  • javax.faces.event
  • javax.faces.flow
  • javax.faces.flow.builder
  • javax.faces.lifecycle
  • javax.faces.model
  • javax.faces.render
  • javax.faces.validator
  • javax.faces.view
  • javax.faces.view.facelets
  • javax.faces.webapp
  • javax.inject
  • javax.interceptor
  • javax.jms
  • javax.json
  • javax.json.spi
  • javax.json.stream
  • javax.jws
  • javax.jws.soap
  • javax.mail
  • javax.mail.event
  • javax.mail.internet
  • javax.mail.search
  • javax.mail.util
  • javax.management.j2ee
  • javax.management.j2ee.statistics
  • javax.persistence
  • javax.persistence.criteria
  • javax.persistence.metamodel
  • javax.persistence.spi
  • javax.resource
  • javax.resource.cci
  • javax.resource.spi
  • javax.resource.spi.endpoint
  • javax.resource.spi.security
  • javax.resource.spi.work
  • javax.security.auth.message
  • javax.security.auth.message.callback
  • javax.security.auth.message.config
  • javax.security.auth.message.module
  • javax.security.jacc
  • javax.servlet
  • javax.servlet.annotation
  • javax.servlet.descriptor
  • javax.servlet.http
  • javax.servlet.jsp
  • javax.servlet.jsp.el
  • javax.servlet.jsp.jstl.core
  • javax.servlet.jsp.jstl.fmt
  • javax.servlet.jsp.jstl.sql
  • javax.servlet.jsp.jstl.tlv
  • javax.servlet.jsp.tagext
  • javax.transaction
  • javax.transaction.xa
  • javax.validation
  • javax.validation.bootstrap
  • javax.validation.constraints
  • javax.validation.constraintvalidation
  • javax.validation.executable
  • javax.validation.groups
  • javax.validation.metadata
  • javax.validation.spi
  • javax.websocket
  • javax.websocket.server
  • javax.ws.rs
  • javax.ws.rs.client
  • javax.ws.rs.container
  • javax.ws.rs.core
  • javax.ws.rs.ext
  • javax.xml.bind
  • javax.xml.bind.annotation
  • javax.xml.bind.annotation.adapters
  • javax.xml.bind.attachment
  • javax.xml.bind.helpers
  • javax.xml.bind.util
  • javax.xml.registry
  • javax.xml.registry.infomodel
  • javax.xml.rpc
  • javax.xml.rpc.encoding
  • javax.xml.rpc.handler
  • javax.xml.rpc.handler.soap
  • javax.xml.rpc.holders
  • javax.xml.rpc.server
  • javax.xml.rpc.soap
  • javax.xml.soap
  • javax.xml.ws
  • javax.xml.ws.handler
  • javax.xml.ws.handler.soap
  • javax.xml.ws.http
  • javax.xml.ws.soap
  • javax.xml.ws.spi
  • javax.xml.ws.spi.http
  • javax.xml.ws.wsaddressing


Overview (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Java(TM) EE 7 Specification APIs

Packages
Package | Description
javax.annotation | This package defines the common annotations.
javax.annotation.security | This package contains the security common annotations.
javax.annotation.sql |
javax.batch.api | Provides APIs used by Batch artifacts.
javax.batch.api.chunk | Provides APIs used by artifacts in a Batch chunk step.
javax.batch.api.chunk.listener | Provides APIs defining listener artifacts for a Batch chunk step.
javax.batch.api.listener | Provides APIs defining Batch job-level and step-level listener artifacts.
javax.batch.api.partition | Provides APIs for artifacts specific to a Batch partitioned step.
javax.batch.operations | Provides APIs for starting, managing, and viewing results of Batch job executions, along with a set of exceptions.
javax.batch.runtime | Provides APIs for viewing the detailed outcomes and metrics of Batch job executions.
javax.batch.runtime.context | Provides APIs for context classes allowing data sharing across Batch artifacts within a job instance and within a step.
javax.decorator | Annotations relating to decorators.
javax.ejb | Contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
javax.ejb.embeddable | Defines the classes for the EJB Embeddable API.
javax.ejb.spi | Defines interfaces that are implemented by the EJB container.
javax.el | Provides the API for the Unified Expression Language 3.0
javax.enterprise.concurrent | Classes and interfaces for concurrent programming in Java EE™ applications.
javax.enterprise.context | Annotations and interfaces relating to scopes and contexts.
javax.enterprise.context.spi | The custom context SPI.
javax.enterprise.deploy.model | Provides Tool Vendor implementation classes.
javax.enterprise.deploy.model.exceptions | Provides Tool Vendor exception implementation classes.
javax.enterprise.deploy.shared | Provides shared objects for Tool Vendor and Product Vendor implementation classes.
javax.enterprise.deploy.shared.factories | Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
javax.enterprise.deploy.spi | Provides J2EE Product Vendor implementation classes.
javax.enterprise.deploy.spi.exceptions | Provides J2EE Product Vendor deployment exception implementation classes.
javax.enterprise.deploy.spi.factories | Provides J2EE Product Vendor deployment factory implementation classes.
javax.enterprise.deploy.spi.status | Provides J2EE Product Vendor deployment status implementation classes.
javax.enterprise.event | Annotations and interfaces relating to events.
javax.enterprise.inject | Annotations relating to bean and stereotype definition, built-in qualifiers, and interfaces and classes relating to programmatic lookup.
javax.enterprise.inject.spi | The portable extension integration SPI.
javax.enterprise.util | Contains shared, general-purpose helper classes and annotations.
javax.faces | Top level classes for the JavaServer(tm) Faces API.
javax.faces.application | APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
javax.faces.bean | These javadoc files constitute the “Faces Managed Bean Annotation Specification for Containers Conforming to Servlet 2.5 and Beyond”
javax.faces.component | Fundamental APIs for user interface components.
javax.faces.component.behavior | APIs for attaching additional behavior to user interface components.
javax.faces.component.html | Specialized user interface component classes for HTML.
javax.faces.component.visit | APIs for traversing a user interface component view.
javax.faces.context | Classes and interfaces defining per-request state information.
javax.faces.convert | Contains classes and interfaces defining converters.
javax.faces.el | DEPRECATED Classes and interfaces for evaluating and processing reference expressions.
javax.faces.event | Interfaces describing events and event listeners, and concrete event implementation classes.
javax.faces.flow | The runtime API for Faces Flows.
javax.faces.flow.builder | Classes for declaring a Faces Flow.
javax.faces.lifecycle | Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.
javax.faces.model | Standard model data beans for JavaServer Faces.
javax.faces.render | Classes and interfaces defining the rendering model.
javax.faces.validator | Interface defining the validator model, and concrete validator implementation classes.
javax.faces.view | Classes for defining a View Declaration Language (VDL) for authoring JavaServer Faces user interfaces.
javax.faces.view.facelets | This package contains public classes for the Java code API of Facelets.
javax.faces.webapp | Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
javax.inject | This package specifies a means for obtaining objects in such a way as to maximize reusability, testability and maintainability compared to traditional approaches such as constructors, factories, and service locators (e.g., JNDI). This process, known as dependency injection, is beneficial to most nontrivial applications.
javax.interceptor | Contains annotations and interfaces for defining interceptor methods, interceptor classes and for binding interceptor classes to target classes.
javax.jms | The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.
javax.json | Provides an object model API to process JSON.
javax.json.spi | Service Provider Interface (SPI) to plug in implementations for JSON processing objects.
javax.json.stream | Provides a streaming API to parse and generate JSON.
javax.jws |
javax.jws.soap |
javax.mail | The JavaMailTM API provides classes that model a mail system.
javax.mail.event | Listeners and events for the JavaMail API.
javax.mail.internet | Classes specific to Internet mail systems.
javax.mail.search | Message search terms for the JavaMail API.
javax.mail.util | JavaMail API utility classes.
javax.management.j2ee | Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.
javax.management.j2ee.statistics | Provides the standard interfaces for accessing performance data from J2EE managed objects
javax.persistence | Java Persistence is the API for the management for persistence and object/relational mapping.
javax.persistence.criteria | Java Persistence Criteria API
javax.persistence.metamodel | Java Persistence Metamodel API
javax.persistence.spi | SPI for Java Persistence providers
javax.resource | The javax.resource package is the top-level package for the Java EE Connector API specification.
javax.resource.cci | The javax.resource.cci package contains API specification for the Common Client Interface (CCI).
javax.resource.spi | The javax.resource.spi package contains APIs for the system contracts defined in the Java EE Connector Architecture specification.
javax.resource.spi.endpoint | This package contains system contracts for service endpoint interactions.
javax.resource.spi.security | The javax.resource.spi.security package contains APIs for the security management contract.
javax.resource.spi.work | This package contains APIs for the Work Management, Generic and Security Work Context contracts.
javax.security.auth.message | This package defines the core interfaces of the JSR 196 message authentication SPI.
javax.security.auth.message.callback | This package defines callback interfaces that may be used by a pluggable message authentication module to interact with the message processing runtime that invoked the module.
javax.security.auth.message.config | This package defines the interfaces implemented by JSR 196 compatible configuration systems.
javax.security.auth.message.module | This package defines the interfaces implemented by JSR 196 compatible authentication modules.
javax.security.jacc | This package contains the Java Authorization Contract for Containers API
javax.servlet | The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.
javax.servlet.annotation | The javax.servlet.annotation package contains a number of annotations that allow users to use annotations to declare servlets, filters, listeners and specify the metadata for the declared component.
javax.servlet.descriptor | Provides programmatic access to a web application's configuration information that was aggregated from the web.xml and web-fragment.xml descriptors.
javax.servlet.http | The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.
javax.servlet.jsp | Classes and interfaces for the Core JSP 2.3 API.
javax.servlet.jsp.el | Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.
javax.servlet.jsp.jstl.core | Classes and interfaces related to the core tag library component of the JavaServer Pages Standard Tag Library (JSTL).
javax.servlet.jsp.jstl.fmt | Classes and interfaces related to the locale sensitive formatting tag library component of the JavaServer Pages Standard Tag Library (JSTL).
javax.servlet.jsp.jstl.sql | Classes and interfaces related to the sql tag library component of the JavaServer Pages Standard Tag Library (JSTL).
javax.servlet.jsp.jstl.tlv | Reusable Tag Library Validator (TLV) classes provided by the JavaServer Pages Standard Tag Library (JSTL).
javax.servlet.jsp.tagext | Classes and interfaces for the definition of JavaServer Pages Tag Libraries.
javax.transaction | Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.
javax.transaction.xa | Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.
javax.validation | Top level package of the Bean Validation API.
javax.validation.bootstrap | Package containing bootstrap specific objects.
javax.validation.constraints | Contains all the Bean Validation provided constraints also called built-in constraints.
javax.validation.constraintvalidation | Package containing constructs specific to constraint validators In particular SupportedValidationTarget is used to refine the validation target of a ConstraintValidator.
javax.validation.executable | Package related to the control and execution of executable validation.
javax.validation.groups | A group defines a subset of constraints.
javax.validation.metadata | Package containing all objects specifically used and returned by the metadata API.
javax.validation.spi | Package containing objects specific to the interaction between the Bean Validation bootstrapping process and Bean Validation providers.
javax.websocket | This package contains all the WebSocket APIs common to both the client and server side.
javax.websocket.server | This package contains all the WebSocket APIs used only by server side applications.
javax.ws.rs | High-level interfaces and annotations used to create RESTful service resources.
javax.ws.rs.client | The JAX-RS client API
javax.ws.rs.container | Container-specific JAX-RS API.
javax.ws.rs.core | Low-level interfaces and annotations used to create RESTful service resources.
javax.ws.rs.ext | APIs that provide extensions to the types supported by the JAX-RS API.
javax.xml.bind | Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
javax.xml.bind.annotation | Defines annotations for customizing Java program elements to XML Schema mapping.
javax.xml.bind.annotation.adapters | XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.
javax.xml.bind.attachment | This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.
javax.xml.bind.helpers | JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
javax.xml.bind.util | Useful client utility classes.
javax.xml.registry | This package defines APIs to access and programatically interact with metadata registries.
javax.xml.registry.infomodel | This package defines interfaces that define the information model for metadata registries.
javax.xml.rpc | This package contains the core JAX-RPC APIs for the client programming model.
javax.xml.rpc.encoding | This package defines APIs for the extensible type mapping framework.
javax.xml.rpc.handler | This package defines APIs for SOAP Message Handlers
javax.xml.rpc.handler.soap | This package defines APIs for SOAP Message Handlers
javax.xml.rpc.holders | This package contains the standard Java Holder classes.
javax.xml.rpc.server | This package defines APIs for the servlet based JAX-RPC endpoint model.
javax.xml.rpc.soap | This package defines APIs specific to the SOAP binding.
javax.xml.soap | Provides the API for creating and building SOAP messages.
javax.xml.ws | This package contains the core JAX-WS APIs.
javax.xml.ws.handler | This package defines APIs for message handlers.
javax.xml.ws.handler.soap | This package defines APIs for SOAP message handlers.
javax.xml.ws.http | This package defines APIs specific to the HTTP binding.
javax.xml.ws.soap | This package defines APIs specific to the SOAP binding.
javax.xml.ws.spi | This package defines SPIs for JAX-WS.
javax.xml.ws.spi.http | Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.
javax.xml.ws.wsaddressing | This package defines APIs related to WS-Addressing.
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames


Class Hierarchy (Java(TM) EE 7 Specification APIs)

  • Next
  • No Frames
  • All Classes

Hierarchy For All Packages

Package Hierarchies:
  • javax.annotation,
  • javax.annotation.security,
  • javax.annotation.sql,
  • javax.batch.api,
  • javax.batch.api.chunk,
  • javax.batch.api.chunk.listener,
  • javax.batch.api.listener,
  • javax.batch.api.partition,
  • javax.batch.operations,
  • javax.batch.runtime,
  • javax.batch.runtime.context,
  • javax.decorator,
  • javax.ejb,
  • javax.ejb.embeddable,
  • javax.ejb.spi,
  • javax.el,
  • javax.enterprise.concurrent,
  • javax.enterprise.context,
  • javax.enterprise.context.spi,
  • javax.enterprise.deploy.model,
  • javax.enterprise.deploy.model.exceptions,
  • javax.enterprise.deploy.shared,
  • javax.enterprise.deploy.shared.factories,
  • javax.enterprise.deploy.spi,
  • javax.enterprise.deploy.spi.exceptions,
  • javax.enterprise.deploy.spi.factories,
  • javax.enterprise.deploy.spi.status,
  • javax.enterprise.event,
  • javax.enterprise.inject,
  • javax.enterprise.inject.spi,
  • javax.enterprise.util,
  • javax.faces,
  • javax.faces.application,
  • javax.faces.bean,
  • javax.faces.component,
  • javax.faces.component.behavior,
  • javax.faces.component.html,
  • javax.faces.component.visit,
  • javax.faces.context,
  • javax.faces.convert,
  • javax.faces.el,
  • javax.faces.event,
  • javax.faces.flow,
  • javax.faces.flow.builder,
  • javax.faces.lifecycle,
  • javax.faces.model,
  • javax.faces.render,
  • javax.faces.validator,
  • javax.faces.view,
  • javax.faces.view.facelets,
  • javax.faces.webapp,
  • javax.inject,
  • javax.interceptor,
  • javax.jms,
  • javax.json,
  • javax.json.spi,
  • javax.json.stream,
  • javax.jws,
  • javax.jws.soap,
  • javax.mail,
  • javax.mail.event,
  • javax.mail.internet,
  • javax.mail.search,
  • javax.mail.util,
  • javax.management.j2ee,
  • javax.management.j2ee.statistics,
  • javax.persistence,
  • javax.persistence.criteria,
  • javax.persistence.metamodel,
  • javax.persistence.spi,
  • javax.resource,
  • javax.resource.cci,
  • javax.resource.spi,
  • javax.resource.spi.endpoint,
  • javax.resource.spi.security,
  • javax.resource.spi.work,
  • javax.security.auth.message,
  • javax.security.auth.message.callback,
  • javax.security.auth.message.config,
  • javax.security.auth.message.module,
  • javax.security.jacc,
  • javax.servlet,
  • javax.servlet.annotation,
  • javax.servlet.descriptor,
  • javax.servlet.http,
  • javax.servlet.jsp,
  • javax.servlet.jsp.el,
  • javax.servlet.jsp.jstl.core,
  • javax.servlet.jsp.jstl.fmt,
  • javax.servlet.jsp.jstl.sql,
  • javax.servlet.jsp.jstl.tlv,
  • javax.servlet.jsp.tagext,
  • javax.transaction,
  • javax.transaction.xa,
  • javax.validation,
  • javax.validation.bootstrap,
  • javax.validation.constraints,
  • javax.validation.constraintvalidation,
  • javax.validation.executable,
  • javax.validation.groups,
  • javax.validation.metadata,
  • javax.validation.spi,
  • javax.websocket,
  • javax.websocket.server,
  • javax.ws.rs,
  • javax.ws.rs.client,
  • javax.ws.rs.container,
  • javax.ws.rs.core,
  • javax.ws.rs.ext,
  • javax.xml.bind,
  • javax.xml.bind.annotation,
  • javax.xml.bind.annotation.adapters,
  • javax.xml.bind.attachment,
  • javax.xml.bind.helpers,
  • javax.xml.bind.util,
  • javax.xml.registry,
  • javax.xml.registry.infomodel,
  • javax.xml.rpc,
  • javax.xml.rpc.encoding,
  • javax.xml.rpc.handler,
  • javax.xml.rpc.handler.soap,
  • javax.xml.rpc.holders,
  • javax.xml.rpc.server,
  • javax.xml.rpc.soap,
  • javax.xml.soap,
  • javax.xml.ws,
  • javax.xml.ws.handler,
  • javax.xml.ws.handler.soap,
  • javax.xml.ws.http,
  • javax.xml.ws.soap,
  • javax.xml.ws.spi,
  • javax.xml.ws.spi.http,
  • javax.xml.ws.wsaddressing

Class Hierarchy

  • java.lang.Object
    • javax.batch.api.AbstractBatchlet (implements javax.batch.api.Batchlet)
    • javax.batch.api.chunk.AbstractCheckpointAlgorithm (implements javax.batch.api.chunk.CheckpointAlgorithm)
    • javax.batch.api.chunk.listener.AbstractChunkListener (implements javax.batch.api.chunk.listener.ChunkListener)
    • javax.batch.api.chunk.listener.AbstractItemProcessListener (implements javax.batch.api.chunk.listener.ItemProcessListener)
    • javax.batch.api.chunk.AbstractItemReader (implements javax.batch.api.chunk.ItemReader)
    • javax.batch.api.chunk.listener.AbstractItemReadListener (implements javax.batch.api.chunk.listener.ItemReadListener)
    • javax.batch.api.chunk.listener.AbstractItemWriteListener (implements javax.batch.api.chunk.listener.ItemWriteListener)
    • javax.batch.api.chunk.AbstractItemWriter (implements javax.batch.api.chunk.ItemWriter)
    • javax.batch.api.listener.AbstractJobListener (implements javax.batch.api.listener.JobListener)
    • javax.xml.bind.helpers.AbstractMarshallerImpl (implements javax.xml.bind.Marshaller)
    • javax.ws.rs.core.AbstractMultivaluedMap<K,V> (implements javax.ws.rs.core.MultivaluedMap<K,V>)
      • javax.ws.rs.core.MultivaluedHashMap<K,V> (implements java.io.Serializable)
    • javax.batch.api.partition.AbstractPartitionAnalyzer (implements javax.batch.api.partition.PartitionAnalyzer)
    • javax.batch.api.partition.AbstractPartitionReducer (implements javax.batch.api.partition.PartitionReducer)
    • javax.batch.api.listener.AbstractStepListener (implements javax.batch.api.listener.StepListener)
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl (implements javax.xml.bind.Unmarshaller)
    • javax.faces.event.ActionListenerWrapper (implements javax.faces.event.ActionListener, javax.faces.FacesWrapper<T>)
    • javax.enterprise.deploy.shared.ActionType
    • javax.mail.Address (implements java.io.Serializable)
      • javax.mail.internet.InternetAddress (implements java.lang.Cloneable)
      • javax.mail.internet.NewsAddress
    • javax.enterprise.util.AnnotationLiteral<T> (implements java.lang.annotation.Annotation, java.io.Serializable)
    • javax.faces.application.Application
      • javax.faces.application.ApplicationWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.ws.rs.core.Application
    • javax.faces.application.ApplicationConfigurationPopulator
    • javax.faces.application.ApplicationFactory (implements javax.faces.FacesWrapper<T>)
    • javax.servlet.AsyncEvent
    • javax.ejb.AsyncResult<V> (implements java.util.concurrent.Future<V>)
    • javax.xml.bind.attachment.AttachmentMarshaller
    • javax.xml.soap.AttachmentPart
    • javax.xml.bind.attachment.AttachmentUnmarshaller
    • javax.security.auth.message.config.AuthConfigFactory
    • javax.mail.Authenticator
    • javax.security.auth.message.AuthStatus
    • javax.batch.runtime.BatchRuntime
    • javax.el.BeanNameResolver
    • javax.faces.validator.BeanValidator (implements javax.faces.component.PartialStateHolder, javax.faces.validator.Validator)
    • javax.faces.component.behavior.BehaviorBase (implements javax.faces.component.behavior.Behavior, javax.faces.component.PartialStateHolder)
      • javax.faces.component.behavior.ClientBehaviorBase (implements javax.faces.component.behavior.ClientBehavior)
        • javax.faces.component.behavior.AjaxBehavior
    • javax.faces.convert.BigDecimalConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.BigDecimalHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.convert.BigIntegerConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.BigIntegerHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.bind.Binder<XmlNode>
    • javax.mail.BodyPart (implements javax.mail.Part)
      • javax.mail.internet.MimeBodyPart (implements javax.mail.internet.MimePart)
        • javax.mail.internet.PreencodedMimeBodyPart
    • javax.faces.convert.BooleanConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.BooleanHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.BooleanWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.mail.util.ByteArrayDataSource (implements javax.activation.DataSource)
    • javax.xml.rpc.holders.ByteArrayHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.convert.ByteConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.ByteHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ByteWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.ws.rs.core.CacheControl
    • javax.xml.rpc.holders.CalendarHolder (implements javax.xml.rpc.holders.Holder)
    • javax.security.auth.message.callback.CallerPrincipalCallback (implements javax.security.auth.callback.Callback)
    • javax.enterprise.inject.spi.CDI<T> (implements javax.enterprise.inject.Instance<T>)
    • javax.security.auth.message.callback.CertStoreCallback (implements javax.security.auth.callback.Callback)
    • javax.faces.convert.CharacterConverter (implements javax.faces.convert.Converter)
    • javax.faces.component.behavior.ClientBehaviorContext
    • javax.faces.component.behavior.ClientBehaviorContext.Parameter
    • javax.faces.render.ClientBehaviorRenderer
    • javax.ws.rs.client.ClientBuilder (implements javax.ws.rs.core.Configurable<C>)
    • javax.websocket.ClientEndpointConfig.Builder
    • javax.websocket.ClientEndpointConfig.Configurator
    • javax.faces.lifecycle.ClientWindow
      • javax.faces.lifecycle.ClientWindowWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.lifecycle.ClientWindowFactory (implements javax.faces.FacesWrapper<T>)
    • javax.websocket.CloseReason
    • javax.enterprise.deploy.shared.CommandType
    • javax.faces.view.facelets.CompositeFaceletHandler (implements javax.faces.view.facelets.FaceletHandler)
    • javax.servlet.jsp.jstl.core.Config
    • javax.mail.event.ConnectionAdapter (implements javax.mail.event.ConnectionListener)
    • javax.xml.registry.ConnectionFactory
    • javax.websocket.ContainerProvider
    • javax.mail.internet.ContentDisposition
    • javax.mail.internet.ContentType
    • javax.servlet.http.Cookie (implements java.lang.Cloneable, java.io.Serializable)
    • javax.ws.rs.core.Cookie
      • javax.ws.rs.core.NewCookie
    • javax.faces.model.DataModel<E> (implements java.lang.Iterable<T>)
      • javax.faces.model.ArrayDataModel<E>
      • javax.faces.model.CollectionDataModel<E>
      • javax.faces.model.ListDataModel<E>
      • javax.faces.model.ResultDataModel
      • javax.faces.model.ResultSetDataModel
      • javax.faces.model.ScalarDataModel<E>
    • javax.xml.bind.DatatypeConverter
    • javax.faces.convert.DateTimeConverter (implements javax.faces.convert.Converter, javax.faces.component.PartialStateHolder)
    • javax.enterprise.deploy.shared.DConfigBeanVersionType
    • javax.xml.bind.helpers.DefaultValidationEventHandler (implements javax.xml.bind.ValidationEventHandler)
    • javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
      • javax.xml.soap.SAAJResult
    • javax.faces.convert.DoubleConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.DoubleHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.validator.DoubleRangeValidator (implements javax.faces.component.PartialStateHolder, javax.faces.validator.Validator)
    • javax.xml.rpc.holders.DoubleWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.ejb.embeddable.EJBContainer (implements java.lang.AutoCloseable)
    • javax.el.ELClass
    • javax.el.ELContext
      • javax.faces.view.facelets.FaceletContext
      • javax.el.StandardELContext
    • javax.el.ELManager
    • javax.el.ELProcessor
    • javax.el.ELResolver
      • javax.el.ArrayELResolver
      • javax.el.BeanELResolver
      • javax.el.BeanNameELResolver
      • javax.el.CompositeELResolver
      • javax.servlet.jsp.el.ImplicitObjectELResolver
      • javax.el.ListELResolver
      • javax.el.MapELResolver
      • javax.el.ResourceBundleELResolver
      • javax.servlet.jsp.el.ScopedAttributeELResolver
      • javax.el.StaticFieldELResolver
      • javax.el.TypeConverter
    • javax.websocket.Endpoint
    • javax.xml.ws.Endpoint
    • javax.xml.ws.EndpointContext
    • javax.xml.ws.EndpointReference
      • javax.xml.ws.wsaddressing.W3CEndpointReference
    • javax.ws.rs.client.Entity<T>
    • javax.ws.rs.core.EntityTag
    • javax.faces.convert.EnumConverter (implements javax.faces.convert.Converter, javax.faces.component.PartialStateHolder)
    • javax.servlet.jsp.ErrorData
    • javax.el.EvaluationListener
    • java.util.EventObject (implements java.io.Serializable)
      • javax.resource.spi.ConnectionEvent
      • javax.faces.model.DataModelEvent
      • javax.el.ELContextEvent
      • javax.faces.event.FacesEvent
        • javax.faces.event.ActionEvent
        • javax.faces.event.BehaviorEvent
          • javax.faces.event.AjaxBehaviorEvent
        • javax.faces.event.ValueChangeEvent
      • javax.servlet.http.HttpSessionEvent
        • javax.servlet.http.HttpSessionBindingEvent
      • javax.mail.event.MailEvent
        • javax.mail.event.ConnectionEvent
        • javax.mail.event.FolderEvent
        • javax.mail.event.MessageChangedEvent
        • javax.mail.event.MessageCountEvent
        • javax.mail.event.StoreEvent
        • javax.mail.event.TransportEvent
      • javax.faces.event.PhaseEvent
      • javax.enterprise.deploy.spi.status.ProgressEvent
      • javax.servlet.ServletContextEvent
        • javax.servlet.ServletContextAttributeEvent
      • javax.servlet.ServletRequestEvent
        • javax.servlet.ServletRequestAttributeEvent
      • javax.faces.event.SystemEvent
        • javax.faces.event.ComponentSystemEvent
          • javax.faces.event.PostAddToViewEvent
          • javax.faces.event.PostConstructViewMapEvent
          • javax.faces.event.PostRestoreStateEvent
          • javax.faces.event.PostValidateEvent
          • javax.faces.event.PreDestroyViewMapEvent
          • javax.faces.event.PreRemoveFromViewEvent
          • javax.faces.event.PreRenderComponentEvent
          • javax.faces.event.PreRenderViewEvent
          • javax.faces.event.PreValidateEvent
        • javax.faces.event.ExceptionQueuedEvent
        • javax.faces.event.PostConstructApplicationEvent
        • javax.faces.event.PostConstructCustomScopeEvent
        • javax.faces.event.PostKeepFlashValueEvent
        • javax.faces.event.PostPutFlashValueEvent
        • javax.faces.event.PreClearFlashEvent
        • javax.faces.event.PreDestroyApplicationEvent
        • javax.faces.event.PreDestroyCustomScopeEvent
        • javax.faces.event.PreRemoveFlashValueEvent
      • javax.resource.spi.work.WorkEvent
    • javax.faces.context.ExceptionHandler (implements javax.faces.event.SystemEventListener)
      • javax.faces.context.ExceptionHandlerWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.ExceptionHandlerFactory (implements javax.faces.FacesWrapper<T>)
      • javax.faces.webapp.PreJsf2ExceptionHandlerFactory
    • javax.faces.event.ExceptionQueuedEventContext (implements javax.faces.event.SystemEventListenerHolder)
    • javax.resource.spi.work.ExecutionContext
      • javax.resource.spi.work.TransactionContext (implements javax.resource.spi.work.WorkContext)
    • javax.el.Expression (implements java.io.Serializable)
      • javax.el.MethodExpression
      • javax.el.ValueExpression
        • javax.servlet.jsp.jstl.core.IndexedValueExpression
        • javax.servlet.jsp.jstl.core.IteratedValueExpression
    • javax.servlet.jsp.el.Expression
    • javax.servlet.jsp.el.ExpressionEvaluator
    • javax.el.ExpressionFactory
    • javax.faces.context.ExternalContext
      • javax.faces.context.ExternalContextWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.ExternalContextFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.view.facelets.Facelet
    • javax.faces.view.facelets.FaceletCache<V>
    • javax.faces.view.facelets.FaceletCacheFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.FacesContext
      • javax.faces.context.FacesContextWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.FacesContextFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.application.FacesMessage (implements java.io.Serializable)
    • javax.faces.application.FacesMessage.Severity (implements java.lang.Comparable<T>)
    • javax.faces.webapp.FacesServlet (implements javax.servlet.Servlet)
    • javax.faces.FactoryFinder
    • javax.mail.FetchProfile
    • javax.mail.FetchProfile.Item
      • javax.mail.UIDFolder.FetchProfileItem
    • javax.mail.Flags (implements java.lang.Cloneable, java.io.Serializable)
    • javax.mail.Flags.Flag
    • javax.faces.context.Flash (implements java.util.Map<K,V>)
      • javax.faces.context.FlashWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.FlashFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.convert.FloatConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.FloatHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.FloatWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.flow.Flow
    • javax.faces.flow.builder.FlowBuilder
    • javax.faces.flow.builder.FlowCallBuilder (implements javax.faces.flow.builder.NodeBuilder)
    • javax.faces.flow.FlowHandler
    • javax.faces.flow.FlowHandlerFactory
      • javax.faces.flow.FlowHandlerFactoryWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.flow.FlowNode
      • javax.faces.flow.FlowCallNode
      • javax.faces.flow.MethodCallNode
      • javax.faces.flow.ReturnNode
      • javax.faces.flow.SwitchNode
      • javax.faces.flow.ViewNode
    • javax.mail.Folder
    • javax.mail.event.FolderAdapter (implements javax.mail.event.FolderListener)
    • javax.ws.rs.core.Form
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
          • javax.mail.internet.MailDateFormat
    • javax.servlet.jsp.tagext.FunctionInfo
    • javax.el.FunctionMapper
    • javax.ws.rs.core.GenericEntity<T>
    • javax.xml.rpc.handler.GenericHandler (implements javax.xml.rpc.handler.Handler)
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet
    • javax.ws.rs.core.GenericType<T>
    • javax.security.auth.message.callback.GroupPrincipalCallback (implements javax.security.auth.callback.Callback)
    • javax.xml.rpc.handler.HandlerInfo (implements java.io.Serializable)
    • javax.mail.Header
      • javax.mail.internet.InternetHeaders.InternetHeader
    • javax.mail.internet.HeaderTokenizer
    • javax.mail.internet.HeaderTokenizer.Token
    • javax.resource.spi.work.HintsContext (implements javax.resource.spi.work.WorkContext)
    • javax.xml.ws.Holder<T> (implements java.io.Serializable)
    • javax.servlet.HttpConstraintElement
      • javax.servlet.HttpMethodConstraintElement
      • javax.servlet.ServletSecurityElement
    • javax.xml.ws.spi.http.HttpContext
    • javax.xml.ws.spi.http.HttpExchange
    • javax.xml.ws.spi.http.HttpHandler
    • javax.servlet.http.HttpUtils
    • javax.el.ImportHandler
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.ByteArrayInputStream
        • javax.mail.util.SharedByteArrayInputStream (implements javax.mail.internet.SharedInputStream)
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
          • javax.mail.util.SharedFileInputStream (implements javax.mail.internet.SharedInputStream)
      • javax.servlet.ServletInputStream
    • javax.faces.convert.IntegerConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.IntegerWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.interceptor.Interceptor.Priority
    • javax.mail.internet.InternetHeaders
    • javax.xml.rpc.holders.IntHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.ws.spi.Invoker
    • javax.servlet.jsp.jstl.core.IteratedExpression
    • javax.xml.bind.JAXB
    • javax.xml.bind.JAXBContext
    • javax.xml.bind.JAXBElement<T> (implements java.io.Serializable)
    • javax.xml.bind.JAXBElement.GlobalScope
    • javax.xml.bind.JAXBIntrospector
    • javax.json.Json
    • javax.json.spi.JsonProvider
    • javax.servlet.jsp.JspContext
      • javax.servlet.jsp.PageContext
    • javax.servlet.jsp.JspEngineInfo
    • javax.servlet.jsp.JspFactory
    • javax.servlet.jsp.tagext.JspFragment
    • javax.el.LambdaExpression
    • javax.faces.validator.LengthValidator (implements javax.faces.component.PartialStateHolder, javax.faces.validator.Validator)
    • javax.faces.lifecycle.Lifecycle
      • javax.faces.lifecycle.LifecycleWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.lifecycle.LifecycleFactory (implements javax.faces.FacesWrapper<T>)
    • javax.ws.rs.core.Link
    • javax.ws.rs.core.Link.JaxbLink
    • javax.servlet.jsp.jstl.fmt.LocaleSupport
    • javax.servlet.jsp.jstl.fmt.LocalizationContext
    • javax.faces.view.Location (implements java.io.Serializable)
    • javax.faces.convert.LongConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.LongHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.validator.LongRangeValidator (implements javax.faces.component.PartialStateHolder, javax.faces.validator.Validator)
    • javax.xml.rpc.holders.LongWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.enterprise.concurrent.ManagedExecutors
    • javax.xml.bind.Marshaller.Listener
    • javax.ws.rs.core.MediaType
    • javax.mail.Message (implements javax.mail.Part)
      • javax.mail.internet.MimeMessage (implements javax.mail.internet.MimePart)
    • javax.mail.Message.RecipientType (implements java.io.Serializable)
      • javax.mail.internet.MimeMessage.RecipientType
    • javax.mail.MessageContext
    • javax.mail.event.MessageCountAdapter (implements javax.mail.event.MessageCountListener)
    • javax.xml.soap.MessageFactory
    • javax.security.auth.message.MessagePolicy
    • javax.security.auth.message.MessagePolicy.TargetPolicy
    • javax.faces.view.facelets.Metadata
    • javax.faces.view.facelets.MetadataTarget
    • javax.faces.view.facelets.MetaRule
    • javax.faces.view.facelets.MetaRuleset
    • javax.faces.el.MethodBinding
    • javax.faces.flow.builder.MethodCallBuilder (implements javax.faces.flow.builder.NodeBuilder)
    • javax.faces.event.MethodExpressionActionListener (implements javax.faces.event.ActionListener, javax.faces.component.StateHolder)
    • javax.faces.validator.MethodExpressionValidator (implements javax.faces.component.StateHolder, javax.faces.validator.Validator)
    • javax.faces.event.MethodExpressionValueChangeListener (implements javax.faces.component.StateHolder, javax.faces.event.ValueChangeListener)
    • javax.el.MethodInfo
    • javax.xml.soap.MimeHeader
    • javax.xml.soap.MimeHeaders
    • javax.mail.internet.MimePartDataSource (implements javax.activation.DataSource, javax.mail.MessageAware)
    • javax.mail.internet.MimeUtility
    • javax.enterprise.deploy.shared.ModuleType
    • javax.mail.Multipart
      • javax.mail.internet.MimeMultipart
    • javax.servlet.MultipartConfigElement
    • javax.xml.rpc.NamespaceConstants
    • javax.faces.application.NavigationCase
      • javax.faces.application.NavigationCaseWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.flow.builder.NavigationCaseBuilder
    • javax.faces.flow.builder.NavigationCaseBuilder.RedirectBuilder
    • javax.faces.application.NavigationHandler
      • javax.faces.application.ConfigurableNavigationHandler
        • javax.faces.application.ConfigurableNavigationHandlerWrapper (implements javax.faces.FacesWrapper<T>)
      • javax.faces.application.NavigationHandlerWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.convert.NumberConverter (implements javax.faces.convert.Converter, javax.faces.component.PartialStateHolder)
    • javax.xml.rpc.holders.ObjectHolder (implements javax.xml.rpc.holders.Holder)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • javax.faces.context.ResponseStream
      • javax.servlet.ServletOutputStream
    • javax.servlet.jsp.tagext.PageData
    • javax.faces.flow.Parameter
    • javax.mail.internet.ParameterList
    • javax.xml.rpc.ParameterMode
    • javax.faces.context.PartialViewContext
      • javax.faces.context.PartialViewContextWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.context.PartialViewContextFactory (implements javax.faces.FacesWrapper<T>)
    • javax.batch.api.partition.PartitionPlanImpl (implements javax.batch.api.partition.PartitionPlan)
    • javax.mail.PasswordAuthentication
    • javax.resource.spi.security.PasswordCredential (implements java.io.Serializable)
    • javax.security.auth.message.callback.PasswordValidationCallback (implements javax.security.auth.callback.Callback)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.xml.bind.JAXBPermission
        • javax.xml.ws.WebServicePermission
      • javax.security.jacc.EJBMethodPermission
      • javax.security.jacc.EJBRoleRefPermission
      • javax.security.jacc.WebResourcePermission
      • javax.security.jacc.WebRoleRefPermission (implements java.io.Serializable)
      • javax.security.jacc.WebUserDataPermission
    • javax.persistence.Persistence
    • javax.persistence.spi.PersistenceProviderResolverHolder
    • javax.faces.event.PhaseId (implements java.lang.Comparable<T>)
    • javax.security.jacc.PolicyConfigurationFactory
    • javax.security.jacc.PolicyContext
    • javax.ws.rs.Priorities
    • javax.security.auth.message.callback.PrivateKeyCallback (implements javax.security.auth.callback.Callback)
    • javax.security.auth.message.callback.PrivateKeyCallback.AliasRequest (implements javax.security.auth.message.callback.PrivateKeyCallback.Request)
    • javax.security.auth.message.callback.PrivateKeyCallback.DigestRequest (implements javax.security.auth.message.callback.PrivateKeyCallback.Request)
    • javax.security.auth.message.callback.PrivateKeyCallback.IssuerSerialNumRequest (implements javax.security.auth.message.callback.PrivateKeyCallback.Request)
    • javax.security.auth.message.callback.PrivateKeyCallback.SubjectKeyIDRequest (implements javax.security.auth.message.callback.PrivateKeyCallback.Request)
    • javax.faces.el.PropertyResolver
    • javax.mail.Provider
    • javax.xml.ws.spi.Provider
    • javax.mail.Provider.Type
    • javax.xml.rpc.holders.QNameHolder (implements javax.xml.rpc.holders.Holder)
    • javax.jms.QueueRequestor
    • javax.mail.Quota
    • javax.mail.Quota.Resource
    • javax.faces.validator.RegexValidator (implements javax.faces.component.PartialStateHolder, javax.faces.validator.Validator)
    • javax.faces.render.Renderer
      • javax.faces.render.RendererWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.render.RenderKit
      • javax.faces.render.RenderKitWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.render.RenderKitFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.validator.RequiredValidator (implements javax.faces.validator.Validator)
    • javax.faces.application.ResourceHandler
      • javax.faces.application.ResourceHandlerWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.view.facelets.ResourceResolver
    • javax.ws.rs.core.Response
    • javax.ws.rs.core.Response.ResponseBuilder
    • javax.faces.render.ResponseStateManager
    • javax.servlet.jsp.jstl.sql.ResultSupport
    • javax.faces.flow.builder.ReturnBuilder (implements javax.faces.flow.builder.NodeBuilder)
    • javax.ws.rs.ext.RuntimeDelegate
    • javax.xml.soap.SAAJMetaFactory
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • javax.xml.bind.util.JAXBResult
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • javax.xml.bind.util.JAXBSource
    • javax.ejb.ScheduleExpression (implements java.io.Serializable)
    • javax.xml.bind.SchemaOutputResolver
    • javax.faces.event.ScopeContext
    • javax.mail.search.SearchTerm (implements java.io.Serializable)
      • javax.mail.search.AddressTerm
        • javax.mail.search.FromTerm
        • javax.mail.search.RecipientTerm
      • javax.mail.search.AndTerm
      • javax.mail.search.ComparisonTerm
        • javax.mail.search.DateTerm
          • javax.mail.search.ReceivedDateTerm
          • javax.mail.search.SentDateTerm
        • javax.mail.search.IntegerComparisonTerm
          • javax.mail.search.MessageNumberTerm
          • javax.mail.search.SizeTerm
      • javax.mail.search.FlagTerm
      • javax.mail.search.NotTerm
      • javax.mail.search.OrTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.AddressStringTerm
          • javax.mail.search.FromStringTerm
          • javax.mail.search.RecipientStringTerm
        • javax.mail.search.BodyTerm
        • javax.mail.search.HeaderTerm
        • javax.mail.search.MessageIDTerm
        • javax.mail.search.SubjectTerm
    • javax.security.auth.message.callback.SecretKeyCallback (implements javax.security.auth.callback.Callback)
    • javax.security.auth.message.callback.SecretKeyCallback.AliasRequest (implements javax.security.auth.message.callback.SecretKeyCallback.Request)
    • javax.resource.spi.work.SecurityContext (implements javax.resource.spi.work.WorkContext)
    • javax.faces.model.SelectItem (implements java.io.Serializable)
      • javax.faces.model.SelectItemGroup
    • javax.websocket.SendResult
    • javax.websocket.server.ServerEndpointConfig.Builder
    • javax.websocket.server.ServerEndpointConfig.Configurator
    • javax.mail.Service
      • javax.mail.Store
      • javax.mail.Transport
    • javax.xml.ws.Service
    • javax.xml.ws.spi.ServiceDelegate
    • javax.xml.rpc.ServiceFactory
    • javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
    • javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
    • javax.mail.Session
    • javax.faces.convert.ShortConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.ShortHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ShortWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.servlet.jsp.tagext.SimpleTagSupport (implements javax.servlet.jsp.tagext.SimpleTag)
    • javax.xml.soap.SOAPConnection
    • javax.xml.soap.SOAPConnectionFactory
    • javax.xml.soap.SOAPElementFactory
    • javax.xml.soap.SOAPFactory
    • javax.xml.soap.SOAPMessage
    • javax.xml.soap.SOAPPart (implements org.w3c.dom.Document, javax.xml.soap.Node)
    • javax.faces.view.StateManagementStrategy
    • javax.faces.application.StateManager
      • javax.faces.application.StateManagerWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.application.StateManager.SerializedView
    • javax.enterprise.deploy.shared.StateType
    • javax.xml.rpc.holders.StringHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.flow.builder.SwitchBuilder (implements javax.faces.flow.builder.NodeBuilder)
    • javax.faces.flow.SwitchCase
    • javax.faces.flow.builder.SwitchCaseBuilder
    • javax.faces.view.facelets.Tag
    • javax.servlet.jsp.tagext.TagAdapter (implements javax.servlet.jsp.tagext.Tag)
    • javax.faces.view.facelets.TagAttribute
    • javax.servlet.jsp.tagext.TagAttributeInfo
    • javax.faces.view.facelets.TagAttributes
    • javax.servlet.jsp.tagext.TagData (implements java.lang.Cloneable)
    • javax.servlet.jsp.tagext.TagExtraInfo
    • javax.servlet.jsp.tagext.TagFileInfo
    • javax.faces.view.facelets.TagHandler (implements javax.faces.view.facelets.FaceletHandler)
      • javax.faces.view.facelets.MetaTagHandler
        • javax.faces.view.facelets.DelegatingMetaTagHandler
          • javax.faces.view.facelets.ComponentHandler
          • javax.faces.view.facelets.FaceletsAttachedObjectHandler (implements javax.faces.view.AttachedObjectHandler)
            • javax.faces.view.facelets.BehaviorHandler (implements javax.faces.view.BehaviorHolderAttachedObjectHandler)
            • javax.faces.view.facelets.ConverterHandler (implements javax.faces.view.ValueHolderAttachedObjectHandler)
            • javax.faces.view.facelets.ValidatorHandler (implements javax.faces.view.EditableValueHolderAttachedObjectHandler)
    • javax.faces.view.facelets.TagHandlerDelegate
    • javax.faces.view.facelets.TagHandlerDelegateFactory (implements javax.faces.FacesWrapper<T>)
    • javax.servlet.jsp.tagext.TagInfo
    • javax.servlet.jsp.tagext.TagLibraryInfo
    • javax.servlet.jsp.tagext.TagLibraryValidator
      • javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV
      • javax.servlet.jsp.jstl.tlv.ScriptFreeTLV
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.faces.webapp.AttributeTag
      • javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
      • javax.servlet.jsp.jstl.core.ConditionalTagSupport
      • javax.faces.webapp.ConverterELTag
      • javax.faces.webapp.ConverterTag
      • javax.faces.webapp.FacetTag
      • javax.servlet.jsp.jstl.core.LoopTagSupport (implements javax.servlet.jsp.tagext.IterationTag, javax.servlet.jsp.jstl.core.LoopTag, javax.servlet.jsp.tagext.TryCatchFinally)
      • javax.faces.webapp.ValidatorELTag
      • javax.faces.webapp.ValidatorTag
    • javax.servlet.jsp.tagext.TagVariableInfo
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
        • javax.enterprise.deploy.spi.exceptions.ClientExecuteException
        • javax.enterprise.deploy.spi.exceptions.ConfigurationException
        • javax.ejb.CreateException
          • javax.ejb.DuplicateKeyException
        • javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
        • javax.enterprise.deploy.model.exceptions.DDBeanCreateException
        • javax.websocket.DecodeException
        • javax.websocket.DeploymentException
        • javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
        • javax.servlet.jsp.el.ELException
          • javax.servlet.jsp.el.ELParseException
        • javax.websocket.EncodeException
        • java.util.concurrent.ExecutionException
          • javax.enterprise.concurrent.AbortedException (implements java.io.Serializable)
          • javax.enterprise.concurrent.SkippedException (implements java.io.Serializable)
        • javax.ejb.FinderException
          • javax.ejb.ObjectNotFoundException
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.message.AuthException
        • javax.transaction.HeuristicCommitException
        • javax.transaction.HeuristicMixedException
        • javax.transaction.HeuristicRollbackException
        • javax.enterprise.deploy.spi.exceptions.InvalidModuleException
        • java.io.IOException
          • javax.ws.rs.core.NoContentException
          • java.rmi.RemoteException
            • javax.transaction.InvalidTransactionException
            • javax.transaction.TransactionRequiredException
            • javax.transaction.TransactionRolledbackException
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
          • javax.xml.bind.PropertyException
          • javax.xml.bind.UnmarshalException
          • javax.xml.bind.ValidationException
        • javax.xml.registry.JAXRException (implements javax.xml.registry.JAXRResponse)
          • javax.xml.registry.InvalidRequestException
          • javax.xml.registry.RegistryException
            • javax.xml.registry.DeleteException
            • javax.xml.registry.FindException
            • javax.xml.registry.SaveException
          • javax.xml.registry.UnexpectedObjectException
          • javax.xml.registry.UnsupportedCapabilityException
        • javax.jms.JMSException
          • javax.jms.IllegalStateException
          • javax.jms.InvalidClientIDException
          • javax.jms.InvalidDestinationException
          • javax.jms.InvalidSelectorException
          • javax.jms.JMSSecurityException
          • javax.jms.MessageEOFException
          • javax.jms.MessageFormatException
          • javax.jms.MessageNotReadableException
          • javax.jms.MessageNotWriteableException
          • javax.jms.ResourceAllocationException
          • javax.jms.TransactionInProgressException
          • javax.jms.TransactionRolledBackException
        • javax.servlet.jsp.JspException
          • javax.servlet.jsp.JspTagException
          • javax.servlet.jsp.SkipPageException
        • javax.mail.MessagingException
          • javax.mail.AuthenticationFailedException
          • javax.mail.FolderClosedException
          • javax.mail.FolderNotFoundException
          • javax.mail.IllegalWriteException
          • javax.mail.MessageRemovedException
          • javax.mail.MethodNotSupportedException
          • javax.mail.NoSuchProviderException
          • javax.mail.internet.ParseException
            • javax.mail.internet.AddressException
          • javax.mail.ReadOnlyFolderException
          • javax.mail.search.SearchException
          • javax.mail.SendFailedException
          • javax.mail.StoreClosedException
        • javax.transaction.NotSupportedException
        • javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException
        • javax.security.jacc.PolicyContextException
        • javax.ejb.RemoveException
        • javax.resource.ResourceException
          • javax.resource.spi.ApplicationServerInternalException
          • javax.resource.spi.CommException
          • javax.resource.spi.EISSystemException
          • javax.resource.spi.IllegalStateException
          • javax.resource.spi.InvalidPropertyException
          • javax.resource.spi.LocalTransactionException
          • javax.resource.NotSupportedException
          • javax.resource.spi.ResourceAdapterInternalException
          • javax.resource.spi.ResourceAllocationException
          • javax.resource.cci.ResourceWarning
          • javax.resource.spi.SecurityException
          • javax.resource.spi.SharingViolationException
          • javax.resource.spi.UnavailableException
            • javax.resource.spi.RetryableUnavailableException (implements javax.resource.spi.RetryableException)
          • javax.resource.spi.work.WorkException
            • javax.resource.spi.work.WorkCompletedException
            • javax.resource.spi.work.WorkRejectedException
              • javax.resource.spi.work.RetryableWorkRejectedException (implements javax.resource.spi.RetryableException)
        • javax.transaction.RollbackException
        • java.lang.RuntimeException
          • javax.batch.operations.BatchRuntimeException
            • javax.batch.operations.JobExecutionAlreadyCompleteException
            • javax.batch.operations.JobExecutionIsRunningException
            • javax.batch.operations.JobExecutionNotMostRecentException
            • javax.batch.operations.JobExecutionNotRunningException
            • javax.batch.operations.JobRestartException
            • javax.batch.operations.JobSecurityException
            • javax.batch.operations.JobStartException
            • javax.batch.operations.NoSuchJobException
            • javax.batch.operations.NoSuchJobExecutionException
            • javax.batch.operations.NoSuchJobInstanceException
          • javax.enterprise.context.ContextException
            • javax.enterprise.context.BusyConversationException
            • javax.enterprise.context.ContextNotActiveException
            • javax.enterprise.context.NonexistentConversationException
          • javax.xml.bind.DataBindingException
          • javax.enterprise.inject.spi.DefinitionException
          • javax.enterprise.inject.spi.DeploymentException
          • javax.ejb.EJBException
            • javax.ejb.AccessLocalException
            • javax.ejb.ConcurrentAccessException
              • javax.ejb.ConcurrentAccessTimeoutException
              • javax.ejb.IllegalLoopbackException
            • javax.ejb.EJBAccessException
            • javax.ejb.EJBTransactionRequiredException
            • javax.ejb.EJBTransactionRolledbackException
            • javax.ejb.NoMoreTimeoutsException
            • javax.ejb.NoSuchEJBException
            • javax.ejb.NoSuchEntityException
            • javax.ejb.NoSuchObjectLocalException
            • javax.ejb.TransactionRequiredLocalException
            • javax.ejb.TransactionRolledbackLocalException
          • javax.el.ELException
            • javax.el.MethodNotFoundException
            • javax.el.PropertyNotFoundException
            • javax.el.PropertyNotWritableException
          • javax.faces.FacesException
            • javax.faces.event.AbortProcessingException
            • javax.faces.convert.ConverterException
            • javax.faces.el.EvaluationException
              • javax.faces.el.MethodNotFoundException
              • javax.faces.el.PropertyNotFoundException
              • javax.faces.el.ReferenceSyntaxException
            • javax.faces.view.facelets.FaceletException
              • javax.faces.view.facelets.TagAttributeException
              • javax.faces.view.facelets.TagException
            • javax.faces.application.ProtectedViewException
            • javax.faces.component.UpdateModelException
            • javax.faces.validator.ValidatorException
            • javax.faces.application.ViewExpiredException
          • javax.enterprise.inject.InjectionException
            • javax.enterprise.inject.CreationException
            • javax.enterprise.inject.IllegalProductException
            • javax.enterprise.inject.ResolutionException
              • javax.enterprise.inject.AmbiguousResolutionException
              • javax.enterprise.inject.UnproxyableResolutionException
              • javax.enterprise.inject.UnsatisfiedResolutionException
          • javax.xml.rpc.JAXRPCException
          • javax.jms.JMSRuntimeException
            • javax.jms.IllegalStateRuntimeException
            • javax.jms.InvalidClientIDRuntimeException
            • javax.jms.InvalidDestinationRuntimeException
            • javax.jms.InvalidSelectorRuntimeException
            • javax.jms.JMSSecurityRuntimeException
            • javax.jms.MessageFormatRuntimeException
            • javax.jms.MessageNotWriteableRuntimeException
            • javax.jms.ResourceAllocationRuntimeException
            • javax.jms.TransactionInProgressRuntimeException
            • javax.jms.TransactionRolledBackRuntimeException
          • javax.json.JsonException
            • javax.json.stream.JsonGenerationException
            • javax.json.stream.JsonParsingException
          • javax.enterprise.event.ObserverException
          • javax.persistence.PersistenceException
            • javax.persistence.EntityExistsException
            • javax.persistence.EntityNotFoundException
            • javax.persistence.LockTimeoutException
            • javax.persistence.NonUniqueResultException
            • javax.persistence.NoResultException
            • javax.persistence.OptimisticLockException
            • javax.persistence.PessimisticLockException
            • javax.persistence.QueryTimeoutException
            • javax.persistence.RollbackException
            • javax.persistence.TransactionRequiredException
          • javax.ws.rs.ProcessingException
            • javax.ws.rs.client.ResponseProcessingException
          • javax.xml.rpc.soap.SOAPFaultException
          • javax.transaction.TransactionalException
          • javax.xml.bind.TypeConstraintException
          • javax.ws.rs.core.UriBuilderException
          • javax.validation.ValidationException
            • javax.validation.ConstraintDeclarationException
              • javax.validation.UnexpectedTypeException
            • javax.validation.ConstraintDefinitionException
            • javax.validation.ConstraintViolationException
            • javax.validation.GroupDefinitionException
          • javax.ws.rs.WebApplicationException
            • javax.ws.rs.ClientErrorException
              • javax.ws.rs.BadRequestException
              • javax.ws.rs.ForbiddenException
              • javax.ws.rs.NotAcceptableException
              • javax.ws.rs.NotAllowedException
              • javax.ws.rs.NotAuthorizedException
              • javax.ws.rs.NotFoundException
              • javax.ws.rs.NotSupportedException
            • javax.ws.rs.RedirectionException
            • javax.ws.rs.ServerErrorException
              • javax.ws.rs.InternalServerErrorException
              • javax.ws.rs.ServiceUnavailableException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException
              • javax.xml.ws.soap.SOAPFaultException
        • javax.xml.rpc.ServiceException
        • javax.servlet.ServletException
          • javax.servlet.UnavailableException
        • javax.websocket.SessionException
        • javax.xml.soap.SOAPException
        • javax.transaction.SystemException
        • javax.enterprise.deploy.spi.exceptions.TargetException
        • javax.transaction.xa.XAException
    • javax.ejb.TimerConfig
    • javax.jms.TopicRequestor
    • javax.mail.event.TransportAdapter (implements javax.mail.event.TransportListener)
    • javax.security.auth.message.callback.TrustStoreCallback (implements javax.security.auth.callback.Callback)
    • javax.enterprise.util.TypeLiteral<T> (implements java.io.Serializable)
    • javax.faces.component.UIComponent (implements javax.faces.event.ComponentSystemEventListener, javax.faces.component.PartialStateHolder, javax.faces.event.SystemEventListenerHolder, javax.faces.component.TransientStateHolder)
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIColumn
          • javax.faces.component.html.HtmlColumn
        • javax.faces.component.UICommand (implements javax.faces.component.ActionSource2)
          • javax.faces.component.html.HtmlCommandButton (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.html.HtmlCommandLink (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIData (implements javax.faces.component.NamingContainer, javax.faces.component.UniqueIdVendor)
          • javax.faces.component.html.HtmlDataTable (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIForm (implements javax.faces.component.NamingContainer, javax.faces.component.UniqueIdVendor)
          • javax.faces.component.html.HtmlForm (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIGraphic
          • javax.faces.component.html.HtmlGraphicImage (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIMessage
          • javax.faces.component.html.HtmlMessage
        • javax.faces.component.UIMessages
          • javax.faces.component.html.HtmlMessages
        • javax.faces.component.UINamingContainer (implements javax.faces.component.NamingContainer, javax.faces.component.StateHolder, javax.faces.component.UniqueIdVendor)
        • javax.faces.component.UIOutput (implements javax.faces.component.ValueHolder)
          • javax.faces.component.html.HtmlBody (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.html.HtmlDoctype
          • javax.faces.component.html.HtmlHead
          • javax.faces.component.html.HtmlOutputFormat
          • javax.faces.component.html.HtmlOutputLabel (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.html.HtmlOutputLink (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.html.HtmlOutputText
          • javax.faces.component.UIInput (implements javax.faces.component.EditableValueHolder)
            • javax.faces.component.html.HtmlInputFile (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.html.HtmlInputHidden
            • javax.faces.component.html.HtmlInputSecret (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.html.HtmlInputText (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.html.HtmlInputTextarea (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.UISelectBoolean
              • javax.faces.component.html.HtmlSelectBooleanCheckbox (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.UISelectMany
              • javax.faces.component.html.HtmlSelectManyCheckbox (implements javax.faces.component.behavior.ClientBehaviorHolder)
              • javax.faces.component.html.HtmlSelectManyListbox (implements javax.faces.component.behavior.ClientBehaviorHolder)
              • javax.faces.component.html.HtmlSelectManyMenu (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.UISelectOne
              • javax.faces.component.html.HtmlSelectOneListbox (implements javax.faces.component.behavior.ClientBehaviorHolder)
              • javax.faces.component.html.HtmlSelectOneMenu (implements javax.faces.component.behavior.ClientBehaviorHolder)
              • javax.faces.component.html.HtmlSelectOneRadio (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.UIViewParameter
          • javax.faces.component.UIOutcomeTarget
            • javax.faces.component.html.HtmlOutcomeTargetButton (implements javax.faces.component.behavior.ClientBehaviorHolder)
            • javax.faces.component.html.HtmlOutcomeTargetLink (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIPanel
          • javax.faces.component.html.HtmlPanelGrid (implements javax.faces.component.behavior.ClientBehaviorHolder)
          • javax.faces.component.html.HtmlPanelGroup (implements javax.faces.component.behavior.ClientBehaviorHolder)
        • javax.faces.component.UIParameter
        • javax.faces.component.UISelectItem
        • javax.faces.component.UISelectItems
        • javax.faces.component.UIViewAction (implements javax.faces.component.ActionSource2)
        • javax.faces.component.UIViewRoot (implements javax.faces.component.UniqueIdVendor)
    • javax.faces.webapp.UIComponentTagBase (implements javax.servlet.jsp.tagext.JspTag)
      • javax.faces.webapp.UIComponentClassicTagBase (implements javax.servlet.jsp.tagext.BodyTag, javax.servlet.jsp.tagext.JspIdConsumer)
        • javax.faces.webapp.UIComponentELTag (implements javax.servlet.jsp.tagext.Tag)
        • javax.faces.webapp.UIComponentTag (implements javax.servlet.jsp.tagext.Tag)
          • javax.faces.webapp.UIComponentBodyTag
    • javax.faces.component.UIViewParameter.Reference
    • javax.enterprise.inject.spi.Unmanaged<T>
    • javax.enterprise.inject.spi.Unmanaged.UnmanagedInstance<T>
    • javax.xml.bind.Unmarshaller.Listener
    • javax.ws.rs.core.UriBuilder
    • javax.mail.URLName
    • javax.validation.Validation
    • javax.xml.bind.util.ValidationEventCollector (implements javax.xml.bind.ValidationEventHandler)
    • javax.xml.bind.helpers.ValidationEventImpl (implements javax.xml.bind.ValidationEvent)
      • javax.xml.bind.helpers.NotIdentifiableEventImpl (implements javax.xml.bind.NotIdentifiableEvent)
      • javax.xml.bind.helpers.ParseConversionEventImpl (implements javax.xml.bind.ParseConversionEvent)
      • javax.xml.bind.helpers.PrintConversionEventImpl (implements javax.xml.bind.PrintConversionEvent)
    • javax.xml.bind.helpers.ValidationEventLocatorImpl (implements javax.xml.bind.ValidationEventLocator)
    • javax.servlet.jsp.tagext.ValidationMessage
    • javax.faces.el.ValueBinding
    • javax.el.ValueReference (implements java.io.Serializable)
    • javax.servlet.jsp.tagext.VariableInfo
    • javax.el.VariableMapper
    • javax.faces.el.VariableResolver
    • javax.ws.rs.core.Variant
    • javax.ws.rs.core.Variant.VariantListBuilder
    • javax.faces.flow.builder.ViewBuilder (implements javax.faces.flow.builder.NodeBuilder)
    • javax.faces.view.ViewDeclarationLanguage
      • javax.faces.view.ViewDeclarationLanguageWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.view.ViewDeclarationLanguageFactory (implements javax.faces.FacesWrapper<T>)
    • javax.faces.application.ViewHandler
      • javax.faces.application.ViewHandlerWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.view.ViewMetadata
    • javax.faces.application.ViewResource
      • javax.faces.application.Resource
        • javax.faces.application.ResourceWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.component.visit.VisitContext
      • javax.faces.component.visit.VisitContextWrapper (implements javax.faces.FacesWrapper<T>)
    • javax.faces.component.visit.VisitContextFactory (implements javax.faces.FacesWrapper<T>)
    • javax.xml.bind.annotation.W3CDomHandler (implements javax.xml.bind.annotation.DomHandler<ElementT,ResultT>)
    • javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.AddressingFeature
      • javax.xml.ws.soap.MTOMFeature
      • javax.xml.ws.RespectBindingFeature
    • javax.resource.spi.work.WorkAdapter (implements javax.resource.spi.work.WorkListener)
    • javax.resource.spi.work.WorkContextErrorCodes
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • javax.servlet.jsp.JspWriter
        • javax.servlet.jsp.tagext.BodyContent
      • javax.faces.context.ResponseWriter
        • javax.faces.context.ResponseWriterWrapper (implements javax.faces.FacesWrapper<T>)
          • javax.faces.context.PartialResponseWriter
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter
      • javax.ws.rs.core.Link.JaxbAdapter
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter
    • javax.xml.bind.annotation.XmlElement.DEFAULT
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
    • javax.xml.rpc.encoding.XMLType
    • javax.xml.bind.annotation.XmlType.DEFAULT
    • javax.enterprise.deploy.model.XpathEvent

Interface Hierarchy

  • javax.faces.component.ActionSource
    • javax.faces.component.ActionSource2
  • javax.enterprise.inject.spi.AfterBeanDiscovery
  • javax.enterprise.inject.spi.AfterDeploymentValidation
  • javax.enterprise.inject.spi.AfterTypeDiscovery
  • javax.enterprise.inject.spi.Annotated
    • javax.enterprise.inject.spi.AnnotatedCallable<X>
      • javax.enterprise.inject.spi.AnnotatedConstructor<X>
      • javax.enterprise.inject.spi.AnnotatedMethod<X>
    • javax.enterprise.inject.spi.AnnotatedConstructor<X>
    • javax.enterprise.inject.spi.AnnotatedField<X>
    • javax.enterprise.inject.spi.AnnotatedMember<X>
      • javax.enterprise.inject.spi.AnnotatedCallable<X>
        • javax.enterprise.inject.spi.AnnotatedConstructor<X>
        • javax.enterprise.inject.spi.AnnotatedMethod<X>
      • javax.enterprise.inject.spi.AnnotatedConstructor<X>
      • javax.enterprise.inject.spi.AnnotatedField<X>
      • javax.enterprise.inject.spi.AnnotatedMethod<X>
    • javax.enterprise.inject.spi.AnnotatedMethod<X>
    • javax.enterprise.inject.spi.AnnotatedParameter<X>
    • javax.enterprise.inject.spi.AnnotatedType<X>
  • javax.servlet.AsyncContext
  • javax.xml.ws.AsyncHandler<T>
  • javax.ws.rs.client.AsyncInvoker
  • javax.ws.rs.container.AsyncResponse
  • javax.faces.view.AttachedObjectHandler
    • javax.faces.view.ActionSource2AttachedObjectHandler
    • javax.faces.view.BehaviorHolderAttachedObjectHandler
    • javax.faces.view.EditableValueHolderAttachedObjectHandler
    • javax.faces.view.ValueHolderAttachedObjectHandler
      • javax.faces.view.EditableValueHolderAttachedObjectHandler
  • javax.faces.view.AttachedObjectTarget
    • javax.faces.view.ActionSource2AttachedObjectTarget
    • javax.faces.view.BehaviorHolderAttachedObjectTarget
    • javax.faces.view.EditableValueHolderAttachedObjectTarget
    • javax.faces.view.ValueHolderAttachedObjectTarget
      • javax.faces.view.EditableValueHolderAttachedObjectTarget
  • javax.persistence.metamodel.Attribute<X,Y>
    • javax.persistence.metamodel.CollectionAttribute<X,E>
    • javax.persistence.metamodel.ListAttribute<X,E>
    • javax.persistence.metamodel.MapAttribute<X,K,V>
    • javax.persistence.metamodel.PluralAttribute<X,C,E> (also extends javax.persistence.metamodel.Bindable<T>)
      • javax.persistence.metamodel.CollectionAttribute<X,E>
      • javax.persistence.metamodel.ListAttribute<X,E>
      • javax.persistence.metamodel.MapAttribute<X,K,V>
      • javax.persistence.metamodel.SetAttribute<X,E>
    • javax.persistence.metamodel.SetAttribute<X,E>
    • javax.persistence.metamodel.SingularAttribute<X,T> (also extends javax.persistence.metamodel.Bindable<T>)
  • javax.persistence.AttributeConverter<X,Y>
  • javax.faces.view.facelets.AttributeHandler
  • javax.persistence.AttributeNode<T>
  • javax.security.auth.message.config.AuthConfig
    • javax.security.auth.message.config.ClientAuthConfig
    • javax.security.auth.message.config.ServerAuthConfig
  • javax.security.auth.message.config.AuthConfigFactory.RegistrationContext
  • javax.security.auth.message.config.AuthConfigProvider
  • java.lang.AutoCloseable
    • java.io.Closeable
      • javax.json.stream.JsonGenerator (also extends java.io.Flushable)
      • javax.json.stream.JsonParser
      • javax.json.JsonReader
      • javax.json.JsonWriter
      • javax.websocket.Session
    • javax.jms.Connection
      • javax.jms.QueueConnection
        • javax.jms.XAQueueConnection (also extends javax.jms.XAConnection)
      • javax.jms.TopicConnection
        • javax.jms.XATopicConnection (also extends javax.jms.XAConnection)
      • javax.jms.XAConnection
        • javax.jms.XAQueueConnection (also extends javax.jms.QueueConnection)
        • javax.jms.XATopicConnection (also extends javax.jms.TopicConnection)
      • javax.jms.XAQueueConnection (also extends javax.jms.QueueConnection, javax.jms.XAConnection)
      • javax.jms.XATopicConnection (also extends javax.jms.TopicConnection, javax.jms.XAConnection)
    • javax.jms.JMSConsumer
    • javax.jms.JMSContext
      • javax.jms.XAJMSContext
    • javax.json.stream.JsonGenerator (also extends java.io.Closeable, java.io.Flushable)
    • javax.json.stream.JsonParser
    • javax.json.JsonReader
    • javax.json.JsonWriter
    • javax.jms.MessageConsumer
      • javax.jms.QueueReceiver
      • javax.jms.TopicSubscriber
    • javax.jms.MessageProducer
      • javax.jms.QueueSender
      • javax.jms.TopicPublisher
    • javax.jms.QueueBrowser
    • javax.jms.QueueConnection
      • javax.jms.XAQueueConnection (also extends javax.jms.XAConnection)
    • javax.jms.QueueReceiver
    • javax.jms.QueueSender
    • javax.jms.QueueSession
    • java.sql.ResultSet (also extends java.sql.Wrapper)
      • javax.resource.cci.ResultSet (also extends javax.resource.cci.Record)
    • javax.resource.cci.ResultSet (also extends javax.resource.cci.Record, java.sql.ResultSet)
    • javax.jms.Session (also extends java.lang.Runnable)
      • javax.jms.QueueSession
      • javax.jms.TopicSession
      • javax.jms.XAQueueSession
      • javax.jms.XASession
        • javax.jms.XAQueueSession
        • javax.jms.XATopicSession
      • javax.jms.XATopicSession
    • javax.websocket.Session
    • javax.jms.TopicConnection
      • javax.jms.XATopicConnection (also extends javax.jms.XAConnection)
    • javax.jms.TopicPublisher
    • javax.jms.TopicSession
    • javax.jms.TopicSubscriber
    • javax.servlet.http.WebConnection
    • javax.jms.XAConnection
      • javax.jms.XAQueueConnection (also extends javax.jms.QueueConnection)
      • javax.jms.XATopicConnection (also extends javax.jms.TopicConnection)
    • javax.jms.XAJMSContext
    • javax.jms.XAQueueConnection (also extends javax.jms.QueueConnection, javax.jms.XAConnection)
    • javax.jms.XAQueueSession
    • javax.jms.XASession
      • javax.jms.XAQueueSession
      • javax.jms.XATopicSession
    • javax.jms.XATopicConnection (also extends javax.jms.TopicConnection, javax.jms.XAConnection)
    • javax.jms.XATopicSession
  • javax.batch.api.Batchlet
  • javax.enterprise.inject.spi.BeanAttributes<T>
    • javax.enterprise.inject.spi.Bean<T> (also extends javax.enterprise.context.spi.Contextual<T>)
      • javax.enterprise.inject.spi.Decorator<T>
      • javax.enterprise.inject.spi.Interceptor<T>
    • javax.enterprise.inject.spi.Decorator<T>
    • javax.enterprise.inject.spi.Interceptor<T>
  • javax.enterprise.inject.spi.BeanManager
  • javax.enterprise.inject.spi.BeforeBeanDiscovery
  • javax.enterprise.inject.spi.BeforeShutdown
  • javax.faces.component.behavior.Behavior
    • javax.faces.component.behavior.ClientBehavior
  • javax.persistence.metamodel.Bindable<T>
    • javax.persistence.metamodel.CollectionAttribute<X,E>
    • javax.persistence.metamodel.EntityType<X> (also extends javax.persistence.metamodel.IdentifiableType<X>)
    • javax.persistence.metamodel.ListAttribute<X,E>
    • javax.persistence.metamodel.MapAttribute<X,K,V>
    • javax.persistence.metamodel.PluralAttribute<X,C,E> (also extends javax.persistence.metamodel.Attribute<X,Y>)
      • javax.persistence.metamodel.CollectionAttribute<X,E>
      • javax.persistence.metamodel.ListAttribute<X,E>
      • javax.persistence.metamodel.MapAttribute<X,K,V>
      • javax.persistence.metamodel.SetAttribute<X,E>
    • javax.persistence.metamodel.SetAttribute<X,E>
    • javax.persistence.metamodel.SingularAttribute<X,T> (also extends javax.persistence.metamodel.Attribute<X,Y>)
  • javax.xml.ws.Binding
    • javax.xml.ws.http.HTTPBinding
    • javax.xml.ws.soap.SOAPBinding
  • javax.xml.ws.BindingProvider
    • javax.xml.ws.Dispatch<T>
  • javax.validation.BootstrapConfiguration
  • javax.resource.spi.BootstrapContext
  • javax.validation.spi.BootstrapState
  • javax.persistence.Cache
  • javax.xml.rpc.Call
  • javax.xml.registry.CapabilityProfile
  • javax.validation.metadata.CascadableDescriptor
    • javax.validation.metadata.ParameterDescriptor (also extends javax.validation.metadata.ElementDescriptor)
    • javax.validation.metadata.PropertyDescriptor (also extends javax.validation.metadata.ElementDescriptor)
    • javax.validation.metadata.ReturnValueDescriptor (also extends javax.validation.metadata.ElementDescriptor)
  • javax.enterprise.inject.spi.CDIProvider
  • javax.batch.api.chunk.CheckpointAlgorithm
  • javax.batch.api.chunk.listener.ChunkListener
  • javax.persistence.spi.ClassTransformer
  • javax.security.auth.message.ClientAuth
    • javax.security.auth.message.config.ClientAuthContext
    • javax.security.auth.message.module.ClientAuthModule
  • javax.faces.component.behavior.ClientBehaviorHolder
  • javax.ws.rs.client.ClientRequestContext
  • javax.ws.rs.client.ClientRequestFilter
  • javax.ws.rs.client.ClientResponseContext
  • javax.ws.rs.client.ClientResponseFilter
  • java.lang.Cloneable
    • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, javax.resource.cci.Record, java.io.Serializable)
    • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, javax.resource.cci.Record, java.io.Serializable)
    • javax.resource.cci.Record (also extends java.io.Serializable)
      • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, java.io.Serializable)
      • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, java.io.Serializable)
      • javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
    • javax.resource.cci.ResultSet (also extends javax.resource.cci.Record, java.sql.ResultSet)
  • javax.websocket.CloseReason.CloseCode
  • javax.persistence.criteria.CommonAbstractCriteria
    • javax.persistence.criteria.AbstractQuery<T>
      • javax.persistence.criteria.CriteriaQuery<T>
      • javax.persistence.criteria.Subquery<T> (also extends javax.persistence.criteria.Expression<T>)
    • javax.persistence.criteria.CriteriaDelete<T>
    • javax.persistence.criteria.CriteriaQuery<T>
    • javax.persistence.criteria.CriteriaUpdate<T>
    • javax.persistence.criteria.Subquery<T> (also extends javax.persistence.criteria.AbstractQuery<T>, javax.persistence.criteria.Expression<T>)
  • javax.ws.rs.container.CompletionCallback
  • javax.jms.CompletionListener
  • javax.faces.el.CompositeComponentExpressionHolder
  • javax.ws.rs.core.Configurable<C>
    • javax.ws.rs.client.Client
    • javax.ws.rs.core.FeatureContext
    • javax.ws.rs.client.WebTarget
  • javax.validation.Configuration<T>
  • javax.ws.rs.core.Configuration
  • javax.validation.spi.ConfigurationState
  • javax.resource.cci.Connection
  • javax.xml.registry.Connection
    • javax.xml.registry.FederatedConnection
  • javax.ws.rs.container.ConnectionCallback
  • javax.jms.ConnectionConsumer
  • javax.jms.ConnectionFactory
    • javax.jms.QueueConnectionFactory
      • javax.jms.XAQueueConnectionFactory (also extends javax.jms.XAConnectionFactory)
    • javax.jms.TopicConnectionFactory
      • javax.jms.XATopicConnectionFactory (also extends javax.jms.XAConnectionFactory)
    • javax.jms.XAQueueConnectionFactory (also extends javax.jms.QueueConnectionFactory, javax.jms.XAConnectionFactory)
    • javax.jms.XATopicConnectionFactory (also extends javax.jms.TopicConnectionFactory, javax.jms.XAConnectionFactory)
  • javax.jms.ConnectionMetaData
  • javax.resource.cci.ConnectionMetaData
  • javax.resource.spi.ConnectionRequestInfo
  • javax.resource.cci.ConnectionSpec
  • javax.validation.metadata.ConstraintDescriptor<T>
  • javax.validation.ConstraintValidator<A,T>
  • javax.validation.ConstraintValidatorContext
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderCustomizableContext
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeBuilderDefinedContext
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.LeafNodeContextBuilder
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderCustomizableContext
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeBuilderDefinedContext
  • javax.validation.ConstraintValidatorContext.ConstraintViolationBuilder.NodeContextBuilder
  • javax.validation.ConstraintValidatorFactory
  • javax.validation.ConstraintViolation<T>
  • javax.ws.rs.container.ContainerRequestContext
  • javax.ws.rs.container.ContainerRequestFilter
  • javax.ws.rs.container.ContainerResponseContext
  • javax.ws.rs.container.ContainerResponseFilter
  • org.xml.sax.ContentHandler
    • javax.xml.bind.UnmarshallerHandler
  • javax.enterprise.context.spi.Context
    • javax.enterprise.context.spi.AlterableContext
  • javax.faces.component.ContextCallback
  • javax.ws.rs.ext.ContextResolver<T>
  • javax.enterprise.concurrent.ContextService
  • javax.enterprise.context.spi.Contextual<T>
    • javax.enterprise.inject.spi.Bean<T> (also extends javax.enterprise.inject.spi.BeanAttributes<T>)
      • javax.enterprise.inject.spi.Decorator<T>
      • javax.enterprise.inject.spi.Interceptor<T>
    • javax.enterprise.inject.spi.Decorator<T>
    • javax.enterprise.inject.spi.Interceptor<T>
  • javax.enterprise.context.Conversation
  • javax.faces.convert.Converter
  • javax.enterprise.context.spi.CreationalContext<T>
  • javax.persistence.criteria.CriteriaBuilder
  • javax.activation.DataSource
    • javax.mail.MultipartDataSource
  • javax.xml.bind.DatatypeConverterInterface
  • javax.enterprise.deploy.spi.DConfigBean
    • javax.enterprise.deploy.spi.DConfigBeanRoot
  • javax.enterprise.deploy.model.DDBean
    • javax.enterprise.deploy.model.DDBeanRoot
  • javax.batch.api.Decider
  • javax.websocket.Decoder
    • javax.websocket.Decoder.Binary<T>
    • javax.websocket.Decoder.BinaryStream<T>
    • javax.websocket.Decoder.Text<T>
    • javax.websocket.Decoder.TextStream<T>
  • javax.validation.groups.Default
  • javax.jms.DeliveryMode
  • javax.enterprise.deploy.model.DeployableObject
    • javax.enterprise.deploy.model.J2eeApplicationObject
  • javax.enterprise.deploy.spi.DeploymentConfiguration
  • javax.enterprise.deploy.spi.factories.DeploymentFactory
  • javax.enterprise.deploy.spi.DeploymentManager
  • javax.enterprise.deploy.spi.status.DeploymentStatus
  • javax.xml.rpc.encoding.DeserializationContext
  • javax.jms.Destination
    • javax.jms.Queue
      • javax.jms.TemporaryQueue
    • javax.jms.TemporaryQueue
    • javax.jms.TemporaryTopic
    • javax.jms.Topic
      • javax.jms.TemporaryTopic
  • javax.resource.spi.DissociatableManagedConnection
  • javax.xml.bind.annotation.DomHandler<ElementT,ResultT>
  • javax.servlet.jsp.tagext.DynamicAttributes
  • javax.ws.rs.container.DynamicFeature
  • javax.ejb.spi.EJBContainerProvider
  • javax.ejb.EJBContext
    • javax.ejb.EntityContext
    • javax.ejb.MessageDrivenContext
    • javax.ejb.SessionContext
  • javax.ejb.EJBLocalHome
  • javax.ejb.EJBLocalObject
  • javax.ejb.EJBMetaData
  • javax.xml.bind.Element
  • javax.validation.metadata.ElementDescriptor
    • javax.validation.metadata.BeanDescriptor
    • javax.validation.metadata.ConstructorDescriptor
    • javax.validation.metadata.CrossParameterDescriptor
    • javax.validation.metadata.ExecutableDescriptor
      • javax.validation.metadata.ConstructorDescriptor
      • javax.validation.metadata.MethodDescriptor
    • javax.validation.metadata.MethodDescriptor
    • javax.validation.metadata.ParameterDescriptor (also extends javax.validation.metadata.CascadableDescriptor)
    • javax.validation.metadata.PropertyDescriptor (also extends javax.validation.metadata.CascadableDescriptor)
    • javax.validation.metadata.ReturnValueDescriptor (also extends javax.validation.metadata.CascadableDescriptor)
  • javax.validation.metadata.ElementDescriptor.ConstraintFinder
  • javax.xml.registry.infomodel.EmailAddress
  • javax.websocket.Encoder
    • javax.websocket.Encoder.Binary<T>
    • javax.websocket.Encoder.BinaryStream<T>
    • javax.websocket.Encoder.Text<T>
    • javax.websocket.Encoder.TextStream<T>
  • javax.mail.EncodingAware
  • javax.websocket.EndpointConfig
    • javax.websocket.ClientEndpointConfig
    • javax.websocket.server.ServerEndpointConfig
  • javax.persistence.EntityGraph<T>
  • javax.persistence.EntityManager
  • javax.persistence.EntityManagerFactory
  • javax.persistence.EntityTransaction
  • javax.enterprise.event.Event<T>
  • java.util.EventListener
    • javax.faces.event.ActionListener
    • javax.faces.event.AjaxBehaviorListener
    • javax.servlet.AsyncListener
    • javax.faces.event.BehaviorListener
      • javax.faces.event.AjaxBehaviorListener
    • javax.faces.event.ComponentSystemEventListener
    • javax.resource.spi.ConnectionEventListener
    • javax.mail.event.ConnectionListener
    • javax.faces.model.DataModelListener
    • javax.el.ELContextListener
    • javax.faces.event.FacesListener
      • javax.faces.event.ActionListener
      • javax.faces.event.AjaxBehaviorListener
      • javax.faces.event.BehaviorListener
        • javax.faces.event.AjaxBehaviorListener
      • javax.faces.event.ComponentSystemEventListener
      • javax.faces.event.SystemEventListener
        • javax.faces.event.ViewMapListener
      • javax.faces.event.ValueChangeListener
      • javax.faces.event.ViewMapListener
    • javax.mail.event.FolderListener
    • javax.servlet.http.HttpSessionActivationListener
    • javax.servlet.http.HttpSessionAttributeListener
    • javax.servlet.http.HttpSessionBindingListener
    • javax.servlet.http.HttpSessionIdListener
    • javax.servlet.http.HttpSessionListener
    • javax.mail.event.MessageChangedListener
    • javax.mail.event.MessageCountListener
    • javax.faces.event.PhaseListener (also extends java.io.Serializable)
    • javax.enterprise.deploy.spi.status.ProgressListener
    • javax.servlet.ReadListener
    • javax.servlet.ServletContextAttributeListener
    • javax.servlet.ServletContextListener
    • javax.servlet.ServletRequestAttributeListener
    • javax.servlet.ServletRequestListener
    • javax.mail.event.StoreListener
    • javax.faces.event.SystemEventListener
      • javax.faces.event.ViewMapListener
    • javax.mail.event.TransportListener
    • javax.faces.validator.Validator
    • javax.faces.event.ValueChangeListener
    • javax.faces.event.ViewMapListener
    • javax.resource.spi.work.WorkListener
    • javax.servlet.WriteListener
  • javax.enterprise.inject.spi.EventMetadata
  • javax.jms.ExceptionListener
  • javax.ws.rs.ext.ExceptionMapper<E>
  • javax.validation.executable.ExecutableValidator
  • java.util.concurrent.Executor
    • java.util.concurrent.ExecutorService
      • javax.enterprise.concurrent.ManagedExecutorService
        • javax.enterprise.concurrent.ManagedScheduledExecutorService (also extends java.util.concurrent.ScheduledExecutorService)
      • javax.enterprise.concurrent.ManagedScheduledExecutorService (also extends javax.enterprise.concurrent.ManagedExecutorService, java.util.concurrent.ScheduledExecutorService)
      • java.util.concurrent.ScheduledExecutorService
        • javax.enterprise.concurrent.ManagedScheduledExecutorService (also extends javax.enterprise.concurrent.ManagedExecutorService)
    • javax.enterprise.concurrent.ManagedExecutorService
      • javax.enterprise.concurrent.ManagedScheduledExecutorService (also extends java.util.concurrent.ScheduledExecutorService)
    • javax.enterprise.concurrent.ManagedScheduledExecutorService (also extends javax.enterprise.concurrent.ManagedExecutorService, java.util.concurrent.ScheduledExecutorService)
    • java.util.concurrent.ScheduledExecutorService
      • javax.enterprise.concurrent.ManagedScheduledExecutorService (also extends javax.enterprise.concurrent.ManagedExecutorService)
  • javax.xml.registry.infomodel.ExtensibleObject
    • javax.xml.registry.infomodel.Association
    • javax.xml.registry.infomodel.AuditableEvent
    • javax.xml.registry.infomodel.Classification
    • javax.xml.registry.infomodel.ClassificationScheme
    • javax.xml.registry.infomodel.Concept
    • javax.xml.registry.infomodel.ExternalIdentifier
    • javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.RegistryObject, javax.xml.registry.infomodel.URIValidator)
    • javax.xml.registry.infomodel.ExtrinsicObject
    • javax.xml.registry.infomodel.Organization
    • javax.xml.registry.infomodel.PostalAddress
    • javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.RegistryObject, javax.xml.registry.infomodel.Versionable)
      • javax.xml.registry.infomodel.ClassificationScheme
      • javax.xml.registry.infomodel.ExtrinsicObject
      • javax.xml.registry.infomodel.RegistryPackage
      • javax.xml.registry.infomodel.Service
    • javax.xml.registry.infomodel.RegistryObject
      • javax.xml.registry.infomodel.Association
      • javax.xml.registry.infomodel.AuditableEvent
      • javax.xml.registry.infomodel.Classification
      • javax.xml.registry.infomodel.ClassificationScheme
      • javax.xml.registry.infomodel.Concept
      • javax.xml.registry.infomodel.ExternalIdentifier
      • javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.URIValidator)
      • javax.xml.registry.infomodel.ExtrinsicObject
      • javax.xml.registry.infomodel.Organization
      • javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.Versionable)
        • javax.xml.registry.infomodel.ClassificationScheme
        • javax.xml.registry.infomodel.ExtrinsicObject
        • javax.xml.registry.infomodel.RegistryPackage
        • javax.xml.registry.infomodel.Service
      • javax.xml.registry.infomodel.RegistryPackage
      • javax.xml.registry.infomodel.Service
      • javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.URIValidator)
      • javax.xml.registry.infomodel.SpecificationLink
      • javax.xml.registry.infomodel.User
    • javax.xml.registry.infomodel.RegistryPackage
    • javax.xml.registry.infomodel.Service
    • javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.RegistryObject, javax.xml.registry.infomodel.URIValidator)
    • javax.xml.registry.infomodel.SpecificationLink
    • javax.xml.registry.infomodel.User
  • javax.enterprise.inject.spi.Extension
  • javax.websocket.Extension
  • javax.websocket.Extension.Parameter
  • javax.faces.view.facelets.FaceletCache.MemberFactory<V>
  • javax.faces.view.facelets.FaceletHandler
  • javax.faces.FacesWrapper<T>
  • javax.faces.view.facelets.FacetHandler
  • javax.ws.rs.core.Feature
  • javax.persistence.criteria.FetchParent<Z,X>
    • javax.persistence.criteria.CollectionJoin<Z,E>
    • javax.persistence.criteria.Fetch<Z,X>
    • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.Path<X>)
      • javax.persistence.criteria.CollectionJoin<Z,E>
      • javax.persistence.criteria.Join<Z,X>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.ListJoin<Z,E>
      • javax.persistence.criteria.MapJoin<Z,K,V>
      • javax.persistence.criteria.PluralJoin<Z,C,E>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Root<X>
      • javax.persistence.criteria.SetJoin<Z,E>
    • javax.persistence.criteria.Join<Z,X>
      • javax.persistence.criteria.CollectionJoin<Z,E>
      • javax.persistence.criteria.ListJoin<Z,E>
      • javax.persistence.criteria.MapJoin<Z,K,V>
      • javax.persistence.criteria.PluralJoin<Z,C,E>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.SetJoin<Z,E>
    • javax.persistence.criteria.ListJoin<Z,E>
    • javax.persistence.criteria.MapJoin<Z,K,V>
    • javax.persistence.criteria.PluralJoin<Z,C,E>
      • javax.persistence.criteria.CollectionJoin<Z,E>
      • javax.persistence.criteria.ListJoin<Z,E>
      • javax.persistence.criteria.MapJoin<Z,K,V>
      • javax.persistence.criteria.SetJoin<Z,E>
    • javax.persistence.criteria.Root<X>
    • javax.persistence.criteria.SetJoin<Z,E>
  • javax.servlet.Filter
  • javax.servlet.FilterChain
  • javax.servlet.FilterConfig
  • javax.xml.registry.FindQualifier
  • java.io.Flushable
    • javax.json.stream.JsonGenerator (also extends java.io.Closeable)
  • javax.servlet.jsp.el.FunctionMapper
  • java.util.concurrent.Future<V>
    • javax.xml.ws.Response<T>
  • javax.validation.bootstrap.GenericBootstrap
  • javax.resource.spi.security.GenericCredential
  • javax.validation.metadata.GroupConversionDescriptor
  • javax.ejb.spi.HandleDelegate
  • javax.xml.rpc.handler.Handler
  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.LogicalHandler<C>
    • javax.xml.ws.handler.soap.SOAPHandler<T>
  • javax.xml.ws.handler.HandlerResolver
  • javax.websocket.server.HandshakeRequest
  • javax.websocket.HandshakeResponse
  • javax.xml.rpc.holders.Holder
  • javax.ws.rs.core.HttpHeaders
  • javax.servlet.http.HttpSession
  • javax.servlet.http.HttpSessionContext
  • javax.servlet.http.HttpUpgradeHandler
  • javax.enterprise.inject.spi.InjectionPoint
  • javax.enterprise.inject.spi.InjectionTargetFactory<T>
  • javax.resource.cci.Interaction
  • javax.ws.rs.ext.InterceptorContext
    • javax.ws.rs.ext.ReaderInterceptorContext
    • javax.ws.rs.ext.WriterInterceptorContext
  • javax.xml.registry.infomodel.InternationalString
  • javax.ws.rs.client.Invocation
  • javax.ws.rs.client.InvocationCallback<RESPONSE>
  • javax.interceptor.InvocationContext
  • javax.batch.api.chunk.listener.ItemProcessListener
  • javax.batch.api.chunk.ItemProcessor
  • javax.batch.api.chunk.ItemReader
  • javax.batch.api.chunk.listener.ItemReadListener
  • javax.batch.api.chunk.listener.ItemWriteListener
  • javax.batch.api.chunk.ItemWriter
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • javax.xml.rpc.handler.HandlerChain
      • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, javax.resource.cci.Record, java.io.Serializable)
      • javax.json.JsonArray (also extends javax.json.JsonStructure, java.util.List<E>)
      • java.util.List<E>
        • javax.xml.rpc.handler.HandlerChain
        • javax.resource.cci.IndexedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
        • javax.json.JsonArray (also extends javax.json.JsonStructure)
    • javax.xml.rpc.handler.HandlerChain
    • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, javax.resource.cci.Record, java.io.Serializable)
    • javax.enterprise.inject.Instance<T> (also extends javax.inject.Provider<T>)
    • javax.json.JsonArray (also extends javax.json.JsonStructure, java.util.List<E>)
    • java.util.List<E>
      • javax.xml.rpc.handler.HandlerChain
      • javax.resource.cci.IndexedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
      • javax.json.JsonArray (also extends javax.json.JsonStructure)
    • javax.validation.Path
  • javax.management.j2ee.statistics.JavaMailStats
  • javax.xml.registry.JAXRResponse
    • javax.xml.registry.BulkResponse
  • javax.jms.JMSProducer
  • javax.batch.runtime.context.JobContext
  • javax.batch.runtime.JobExecution
  • javax.batch.runtime.JobInstance
  • javax.batch.api.listener.JobListener
  • javax.batch.operations.JobOperator
  • javax.json.JsonArrayBuilder
  • javax.json.JsonBuilderFactory
  • javax.json.stream.JsonGeneratorFactory
  • javax.json.stream.JsonLocation
  • javax.json.JsonObjectBuilder
  • javax.json.stream.JsonParserFactory
  • javax.json.JsonReaderFactory
  • javax.json.JsonValue
    • javax.json.JsonArray (also extends javax.json.JsonStructure, java.util.List<E>)
    • javax.json.JsonNumber
    • javax.json.JsonObject (also extends javax.json.JsonStructure, java.util.Map<K,V>)
    • javax.json.JsonString
    • javax.json.JsonStructure
      • javax.json.JsonArray (also extends java.util.List<E>)
      • javax.json.JsonObject (also extends java.util.Map<K,V>)
  • javax.json.JsonWriterFactory
  • javax.servlet.jsp.JspApplicationContext
  • javax.servlet.descriptor.JspConfigDescriptor
  • javax.servlet.jsp.tagext.JspIdConsumer
  • javax.servlet.descriptor.JspPropertyGroupDescriptor
  • javax.servlet.jsp.tagext.JspTag
    • javax.servlet.jsp.tagext.BodyTag
    • javax.servlet.jsp.tagext.IterationTag
      • javax.servlet.jsp.tagext.BodyTag
    • javax.servlet.jsp.jstl.core.LoopTag
    • javax.servlet.jsp.tagext.SimpleTag
    • javax.servlet.jsp.tagext.Tag
      • javax.servlet.jsp.tagext.BodyTag
      • javax.servlet.jsp.tagext.IterationTag
        • javax.servlet.jsp.tagext.BodyTag
      • javax.servlet.jsp.jstl.core.LoopTag
  • javax.xml.registry.infomodel.Key
  • javax.enterprise.concurrent.LastExecution
  • javax.resource.spi.LazyAssociatableConnectionManager
  • javax.resource.spi.LazyEnlistableConnectionManager
  • javax.resource.spi.LazyEnlistableManagedConnection
  • javax.xml.registry.LifeCycleManager
    • javax.xml.registry.BusinessLifeCycleManager
  • javax.ws.rs.core.Link.Builder
  • javax.xml.registry.infomodel.LocalizedString
  • javax.resource.cci.LocalTransaction
  • javax.resource.spi.LocalTransaction
  • javax.xml.ws.LogicalMessage
  • javax.servlet.jsp.jstl.core.LoopTagStatus
  • javax.enterprise.concurrent.ManageableThread
  • javax.resource.spi.ManagedConnection
  • javax.resource.spi.ManagedConnectionMetaData
  • javax.enterprise.concurrent.ManagedTask
  • javax.enterprise.concurrent.ManagedTaskListener
  • java.util.Map<K,V>
    • javax.json.JsonObject (also extends javax.json.JsonStructure)
    • javax.xml.ws.handler.LogicalMessageContext
    • javax.resource.cci.MappedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.LogicalMessageContext
      • javax.xml.ws.handler.soap.SOAPMessageContext
    • javax.ws.rs.core.MultivaluedMap<K,V>
    • javax.xml.ws.handler.soap.SOAPMessageContext
  • javax.xml.bind.Marshaller
  • javax.jms.Message
    • javax.jms.BytesMessage
    • javax.jms.MapMessage
    • javax.jms.ObjectMessage
    • javax.jms.StreamMessage
    • javax.jms.TextMessage
  • javax.mail.MessageAware
  • javax.ws.rs.ext.MessageBodyReader<T>
  • javax.ws.rs.ext.MessageBodyWriter<T>
  • javax.xml.rpc.handler.MessageContext
    • javax.xml.rpc.handler.soap.SOAPMessageContext
  • javax.resource.spi.endpoint.MessageEndpoint
  • javax.resource.spi.endpoint.MessageEndpointFactory
  • javax.websocket.MessageHandler
    • javax.websocket.MessageHandler.Partial<T>
    • javax.websocket.MessageHandler.Whole<T>
  • javax.security.auth.message.MessageInfo
  • javax.validation.MessageInterpolator
  • javax.validation.MessageInterpolator.Context
  • javax.jms.MessageListener
  • javax.resource.cci.MessageListener
  • javax.security.auth.message.MessagePolicy.ProtectionPolicy
  • javax.security.auth.message.MessagePolicy.Target
  • javax.persistence.metamodel.Metamodel
  • javax.batch.runtime.Metric
  • javax.xml.soap.Name
  • javax.faces.component.NamingContainer
  • org.w3c.dom.Node
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Text
        • javax.xml.soap.Text (also extends javax.xml.soap.Node)
      • javax.xml.soap.Text (also extends javax.xml.soap.Node, org.w3c.dom.Text)
    • javax.xml.soap.Detail
    • javax.xml.soap.DetailEntry
    • org.w3c.dom.Element
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPElement (also extends javax.xml.soap.Node)
        • javax.xml.soap.Detail
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.Node
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element)
        • javax.xml.soap.Detail
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.Text (also extends org.w3c.dom.Text)
    • javax.xml.soap.SOAPBody
    • javax.xml.soap.SOAPBodyElement
      • javax.xml.soap.SOAPFault
    • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element, javax.xml.soap.Node)
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.SOAPEnvelope
    • javax.xml.soap.SOAPFault
    • javax.xml.soap.SOAPFaultElement
      • javax.xml.soap.Detail
    • javax.xml.soap.SOAPHeader
    • javax.xml.soap.SOAPHeaderElement
    • org.w3c.dom.Text
      • javax.xml.soap.Text (also extends javax.xml.soap.Node)
    • javax.xml.soap.Text (also extends javax.xml.soap.Node, org.w3c.dom.Text)
  • javax.faces.flow.builder.NodeBuilder
  • javax.enterprise.inject.spi.ObserverMethod<T>
  • javax.persistence.criteria.Order
  • javax.ws.rs.ext.ParamConverter<T>
  • javax.ws.rs.ext.ParamConverterProvider
  • javax.persistence.Parameter<T>
    • javax.persistence.criteria.ParameterExpression<T> (also extends javax.persistence.criteria.Expression<T>)
  • javax.validation.ParameterNameProvider
  • javax.mail.Part
    • javax.mail.internet.MimePart
  • javax.servlet.http.Part
  • javax.batch.api.partition.PartitionAnalyzer
  • javax.batch.api.partition.PartitionCollector
  • javax.batch.api.partition.PartitionMapper
  • javax.batch.api.partition.PartitionPlan
  • javax.batch.api.partition.PartitionReducer
  • javax.enterprise.inject.spi.PassivationCapable
  • javax.validation.Path.Node
    • javax.validation.Path.BeanNode
    • javax.validation.Path.ConstructorNode
    • javax.validation.Path.CrossParameterNode
    • javax.validation.Path.MethodNode
    • javax.validation.Path.ParameterNode
    • javax.validation.Path.PropertyNode
    • javax.validation.Path.ReturnValueNode
  • javax.ws.rs.core.PathSegment
  • javax.validation.Payload
  • javax.persistence.spi.PersistenceProvider
  • javax.persistence.spi.PersistenceProviderResolver
  • javax.persistence.spi.PersistenceUnitInfo
  • javax.persistence.PersistenceUtil
    • javax.persistence.PersistenceUnitUtil
  • javax.xml.registry.infomodel.PersonName
  • javax.security.jacc.PolicyConfiguration
  • javax.security.jacc.PolicyContextHandler
  • javax.websocket.PongMessage
  • javax.xml.ws.handler.PortInfo
  • javax.security.auth.message.callback.PrivateKeyCallback.Request
  • javax.enterprise.inject.spi.ProcessAnnotatedType<X>
    • javax.enterprise.inject.spi.ProcessSyntheticAnnotatedType<X>
  • javax.enterprise.inject.spi.ProcessBean<X>
    • javax.enterprise.inject.spi.ProcessManagedBean<X>
      • javax.enterprise.inject.spi.ProcessSessionBean<X>
    • javax.enterprise.inject.spi.ProcessProducerField<T,X>
    • javax.enterprise.inject.spi.ProcessProducerMethod<T,X>
    • javax.enterprise.inject.spi.ProcessSessionBean<X>
  • javax.enterprise.inject.spi.ProcessBeanAttributes<T>
  • javax.enterprise.inject.spi.ProcessInjectionPoint<T,X>
  • javax.enterprise.inject.spi.ProcessInjectionTarget<X>
  • javax.enterprise.inject.spi.ProcessObserverMethod<T,X>
  • javax.enterprise.inject.spi.ProcessProducer<T,X>
  • javax.enterprise.inject.spi.Producer<T>
    • javax.enterprise.inject.spi.InjectionTarget<T>
  • javax.enterprise.inject.spi.ProducerFactory<X>
  • javax.enterprise.deploy.spi.status.ProgressObject
  • javax.inject.Provider<T>
    • javax.enterprise.inject.Instance<T> (also extends java.lang.Iterable<T>)
  • javax.xml.ws.Provider<T>
  • javax.ws.rs.ext.Providers
  • javax.validation.bootstrap.ProviderSpecificBootstrap<T>
  • javax.persistence.spi.ProviderUtil
  • javax.persistence.Query
    • javax.persistence.StoredProcedureQuery
    • javax.persistence.TypedQuery<X>
  • javax.xml.registry.Query
  • javax.xml.registry.QueryManager
    • javax.xml.registry.BusinessQueryManager
    • javax.xml.registry.DeclarativeQueryManager
  • javax.mail.QuotaAwareStore
  • javax.ws.rs.ext.ReaderInterceptor
  • javax.resource.cci.RecordFactory
  • javax.naming.Referenceable
    • javax.resource.cci.ConnectionFactory (also extends javax.resource.Referenceable, java.io.Serializable)
    • javax.resource.Referenceable
      • javax.resource.cci.ConnectionFactory (also extends java.io.Serializable)
  • javax.servlet.Registration
    • javax.servlet.FilterRegistration
      • javax.servlet.FilterRegistration.Dynamic (also extends javax.servlet.Registration.Dynamic)
    • javax.servlet.FilterRegistration.Dynamic (also extends javax.servlet.FilterRegistration, javax.servlet.Registration.Dynamic)
    • javax.servlet.Registration.Dynamic
      • javax.servlet.FilterRegistration.Dynamic (also extends javax.servlet.FilterRegistration)
      • javax.servlet.ServletRegistration.Dynamic (also extends javax.servlet.ServletRegistration)
    • javax.servlet.ServletRegistration
      • javax.servlet.ServletRegistration.Dynamic (also extends javax.servlet.Registration.Dynamic)
    • javax.servlet.ServletRegistration.Dynamic (also extends javax.servlet.Registration.Dynamic, javax.servlet.ServletRegistration)
  • javax.security.auth.message.config.RegistrationListener
  • javax.xml.registry.RegistryService
  • java.rmi.Remote
    • javax.ejb.EJBHome
      • javax.management.j2ee.ManagementHome
    • javax.ejb.EJBObject
      • javax.management.j2ee.Management
    • javax.management.j2ee.Management
    • javax.management.j2ee.ManagementHome
  • javax.websocket.RemoteEndpoint
    • javax.websocket.RemoteEndpoint.Async
    • javax.websocket.RemoteEndpoint.Basic
  • javax.ws.rs.core.Request
  • javax.servlet.RequestDispatcher
  • javax.resource.spi.ResourceAdapter
  • javax.resource.spi.ResourceAdapterAssociation
    • javax.resource.spi.ActivationSpec
  • javax.resource.cci.ResourceAdapterMetaData
  • javax.ws.rs.container.ResourceContext
  • javax.ws.rs.container.ResourceInfo
  • javax.ws.rs.core.Response.StatusType
  • javax.servlet.jsp.jstl.sql.Result
  • javax.resource.cci.ResultSetInfo
  • javax.batch.api.chunk.listener.RetryProcessListener
  • javax.batch.api.chunk.listener.RetryReadListener
  • javax.batch.api.chunk.listener.RetryWriteListener
  • java.lang.Runnable
    • javax.resource.spi.work.DistributableWork (also extends java.io.Serializable, javax.resource.spi.work.Work)
    • javax.jms.QueueSession
    • javax.jms.Session (also extends java.lang.AutoCloseable)
      • javax.jms.QueueSession
      • javax.jms.TopicSession
      • javax.jms.XAQueueSession
      • javax.jms.XASession
        • javax.jms.XAQueueSession
        • javax.jms.XATopicSession
      • javax.jms.XATopicSession
    • javax.jms.TopicSession
    • javax.resource.spi.work.Work
      • javax.resource.spi.work.DistributableWork (also extends java.io.Serializable)
    • javax.jms.XAQueueSession
    • javax.jms.XASession
      • javax.jms.XAQueueSession
      • javax.jms.XATopicSession
    • javax.jms.XATopicSession
  • javax.ws.rs.ext.RuntimeDelegate.HeaderDelegate<T>
  • javax.security.auth.message.callback.SecretKeyCallback.Request
  • javax.ws.rs.core.SecurityContext
  • javax.websocket.SendHandler
  • java.io.Serializable
    • javax.enterprise.deploy.spi.status.ClientConfiguration
    • javax.resource.cci.ConnectionFactory (also extends javax.resource.Referenceable)
    • javax.resource.spi.ConnectionManager
    • javax.xml.rpc.encoding.Deserializer
    • javax.xml.rpc.encoding.DeserializerFactory
    • javax.resource.spi.work.DistributableWork (also extends javax.resource.spi.work.Work)
    • javax.ejb.EnterpriseBean
      • javax.ejb.EntityBean
      • javax.ejb.MessageDrivenBean
      • javax.ejb.SessionBean
    • javax.ejb.EntityBean
    • javax.ejb.Handle
    • javax.xml.rpc.handler.HandlerRegistry
    • javax.ejb.HomeHandle
    • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, javax.resource.cci.Record)
    • javax.resource.cci.InteractionSpec
    • javax.management.j2ee.ListenerRegistration
    • javax.resource.spi.ManagedConnectionFactory
    • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, javax.resource.cci.Record)
    • javax.ejb.MessageDrivenBean
    • javax.faces.event.PhaseListener (also extends java.util.EventListener)
    • javax.resource.cci.Record (also extends java.lang.Cloneable)
      • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, java.io.Serializable)
      • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, java.io.Serializable)
      • javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
    • javax.resource.cci.ResultSet (also extends javax.resource.cci.Record, java.sql.ResultSet)
    • javax.resource.spi.RetryableException
    • javax.xml.rpc.encoding.Serializer
    • javax.xml.rpc.encoding.SerializerFactory
    • javax.ejb.SessionBean
    • javax.ejb.TimerHandle
    • javax.resource.spi.TransactionSupport
    • javax.xml.rpc.encoding.TypeMappingRegistry
    • javax.resource.spi.work.WorkContext
    • javax.resource.spi.work.WorkContextProvider
  • javax.xml.rpc.encoding.SerializationContext
  • javax.websocket.server.ServerApplicationConfig
  • javax.security.auth.message.ServerAuth
    • javax.security.auth.message.config.ServerAuthContext
    • javax.security.auth.message.module.ServerAuthModule
  • javax.jms.ServerSession
  • javax.jms.ServerSessionPool
  • javax.xml.rpc.Service
  • javax.xml.rpc.server.ServiceLifecycle
  • javax.servlet.Servlet
    • javax.servlet.jsp.HttpJspPage
    • javax.servlet.jsp.JspPage
      • javax.servlet.jsp.HttpJspPage
  • javax.servlet.ServletConfig
  • javax.servlet.ServletContainerInitializer
  • javax.servlet.ServletContext
  • javax.xml.rpc.server.ServletEndpointContext
  • javax.servlet.ServletRequest
    • javax.servlet.http.HttpServletRequest
  • javax.servlet.ServletResponse
    • javax.servlet.http.HttpServletResponse
  • javax.servlet.SessionCookieConfig
  • javax.ejb.SessionSynchronization
  • javax.mail.internet.SharedInputStream
  • javax.servlet.SingleThreadModel
  • javax.batch.api.chunk.listener.SkipProcessListener
  • javax.batch.api.chunk.listener.SkipReadListener
  • javax.batch.api.chunk.listener.SkipWriteListener
  • javax.xml.registry.infomodel.Slot
  • javax.xml.soap.SOAPConstants
  • javax.servlet.jsp.jstl.sql.SQLExecutionTag
  • javax.faces.component.StateHolder
    • javax.faces.component.PartialStateHolder
    • javax.faces.component.StateHelper
  • javax.management.j2ee.statistics.Statistic
    • javax.management.j2ee.statistics.BoundaryStatistic
      • javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.RangeStatistic)
    • javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.BoundaryStatistic, javax.management.j2ee.statistics.RangeStatistic)
    • javax.management.j2ee.statistics.CountStatistic
    • javax.management.j2ee.statistics.RangeStatistic
      • javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.BoundaryStatistic)
    • javax.management.j2ee.statistics.TimeStatistic
  • javax.management.j2ee.statistics.Stats
    • javax.management.j2ee.statistics.EJBStats
      • javax.management.j2ee.statistics.EntityBeanStats
      • javax.management.j2ee.statistics.MessageDrivenBeanStats
      • javax.management.j2ee.statistics.SessionBeanStats
        • javax.management.j2ee.statistics.StatefulSessionBeanStats
        • javax.management.j2ee.statistics.StatelessSessionBeanStats
      • javax.management.j2ee.statistics.StatefulSessionBeanStats
      • javax.management.j2ee.statistics.StatelessSessionBeanStats
    • javax.management.j2ee.statistics.EntityBeanStats
    • javax.management.j2ee.statistics.JCAConnectionPoolStats
    • javax.management.j2ee.statistics.JCAConnectionStats
      • javax.management.j2ee.statistics.JCAConnectionPoolStats
    • javax.management.j2ee.statistics.JCAStats
    • javax.management.j2ee.statistics.JDBCConnectionPoolStats
    • javax.management.j2ee.statistics.JDBCConnectionStats
      • javax.management.j2ee.statistics.JDBCConnectionPoolStats
    • javax.management.j2ee.statistics.JDBCStats
    • javax.management.j2ee.statistics.JMSConnectionStats
    • javax.management.j2ee.statistics.JMSConsumerStats
    • javax.management.j2ee.statistics.JMSEndpointStats
      • javax.management.j2ee.statistics.JMSConsumerStats
      • javax.management.j2ee.statistics.JMSProducerStats
    • javax.management.j2ee.statistics.JMSProducerStats
    • javax.management.j2ee.statistics.JMSSessionStats
    • javax.management.j2ee.statistics.JMSStats
    • javax.management.j2ee.statistics.JTAStats
    • javax.management.j2ee.statistics.JVMStats
    • javax.management.j2ee.statistics.MessageDrivenBeanStats
    • javax.management.j2ee.statistics.ServletStats
    • javax.management.j2ee.statistics.SessionBeanStats
      • javax.management.j2ee.statistics.StatefulSessionBeanStats
      • javax.management.j2ee.statistics.StatelessSessionBeanStats
    • javax.management.j2ee.statistics.StatefulSessionBeanStats
    • javax.management.j2ee.statistics.StatelessSessionBeanStats
    • javax.management.j2ee.statistics.URLStats
  • javax.transaction.Status
  • javax.batch.runtime.context.StepContext
  • javax.batch.runtime.StepExecution
  • javax.batch.api.listener.StepListener
  • javax.resource.cci.Streamable
  • javax.ws.rs.core.StreamingOutput
  • javax.xml.rpc.Stub
  • javax.persistence.Subgraph<T>
  • javax.transaction.Synchronization
  • javax.ws.rs.client.SyncInvoker
    • javax.ws.rs.client.Invocation.Builder
  • javax.faces.event.SystemEventListenerHolder
  • javax.faces.view.facelets.TagConfig
    • javax.faces.view.facelets.BehaviorConfig
    • javax.faces.view.facelets.ComponentConfig
    • javax.faces.view.facelets.ConverterConfig
    • javax.faces.view.facelets.ValidatorConfig
  • javax.faces.view.facelets.TagDecorator
  • javax.servlet.descriptor.TaglibDescriptor
  • javax.enterprise.deploy.spi.Target
  • javax.enterprise.deploy.spi.TargetModuleID
  • javax.xml.registry.infomodel.TelephoneNumber
  • javax.faces.view.facelets.TextHandler
  • java.util.concurrent.ThreadFactory
    • javax.enterprise.concurrent.ManagedThreadFactory
  • javax.ejb.TimedObject
  • javax.ws.rs.container.TimeoutHandler
  • javax.ejb.Timer
  • javax.ejb.TimerService
  • javax.transaction.Transaction
  • javax.transaction.TransactionManager
  • javax.transaction.TransactionSynchronizationRegistry
  • javax.faces.component.TransientStateHolder
    • javax.faces.component.TransientStateHelper
  • javax.validation.TraversableResolver
  • javax.enterprise.concurrent.Trigger
  • javax.servlet.jsp.tagext.TryCatchFinally
  • javax.persistence.Tuple
  • javax.persistence.TupleElement<X>
    • javax.persistence.criteria.CollectionJoin<Z,E>
    • javax.persistence.criteria.CompoundSelection<X>
    • javax.persistence.criteria.CriteriaBuilder.Case<R>
    • javax.persistence.criteria.CriteriaBuilder.Coalesce<T>
    • javax.persistence.criteria.CriteriaBuilder.In<T>
    • javax.persistence.criteria.CriteriaBuilder.SimpleCase<C,R>
    • javax.persistence.criteria.Expression<T>
      • javax.persistence.criteria.CollectionJoin<Z,E>
      • javax.persistence.criteria.CriteriaBuilder.Case<R>
      • javax.persistence.criteria.CriteriaBuilder.Coalesce<T>
      • javax.persistence.criteria.CriteriaBuilder.In<T>
      • javax.persistence.criteria.CriteriaBuilder.SimpleCase<C,R>
      • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.FetchParent<Z,X>, javax.persistence.criteria.Path<X>)
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.Join<Z,X>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.PluralJoin<Z,C,E>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.Root<X>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Join<Z,X>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.ListJoin<Z,E>
      • javax.persistence.criteria.MapJoin<Z,K,V>
      • javax.persistence.criteria.ParameterExpression<T> (also extends javax.persistence.Parameter<T>)
      • javax.persistence.criteria.Path<X>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.FetchParent<Z,X>)
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.Join<Z,X>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.PluralJoin<Z,C,E>
              • javax.persistence.criteria.CollectionJoin<Z,E>
              • javax.persistence.criteria.ListJoin<Z,E>
              • javax.persistence.criteria.MapJoin<Z,K,V>
              • javax.persistence.criteria.SetJoin<Z,E>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.PluralJoin<Z,C,E>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.Root<X>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.Join<Z,X>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.PluralJoin<Z,C,E>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.Root<X>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.PluralJoin<Z,C,E>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Predicate
        • javax.persistence.criteria.CriteriaBuilder.In<T>
      • javax.persistence.criteria.Root<X>
      • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Subquery<T> (also extends javax.persistence.criteria.AbstractQuery<T>)
    • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.FetchParent<Z,X>, javax.persistence.criteria.Path<X>)
      • javax.persistence.criteria.CollectionJoin<Z,E>
      • javax.persistence.criteria.Join<Z,X>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.ListJoin<Z,E>
      • javax.persistence.criteria.MapJoin<Z,K,V>
      • javax.persistence.criteria.PluralJoin<Z,C,E>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Root<X>
      • javax.persistence.criteria.SetJoin<Z,E>
    • javax.persistence.criteria.Join<Z,X>
      • javax.persistence.criteria.CollectionJoin<Z,E>
      • javax.persistence.criteria.ListJoin<Z,E>
      • javax.persistence.criteria.MapJoin<Z,K,V>
      • javax.persistence.criteria.PluralJoin<Z,C,E>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.SetJoin<Z,E>
    • javax.persistence.criteria.ListJoin<Z,E>
    • javax.persistence.criteria.MapJoin<Z,K,V>
    • javax.persistence.criteria.ParameterExpression<T> (also extends javax.persistence.criteria.Expression<T>, javax.persistence.Parameter<T>)
    • javax.persistence.criteria.Path<X>
      • javax.persistence.criteria.CollectionJoin<Z,E>
      • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.FetchParent<Z,X>)
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.Join<Z,X>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.PluralJoin<Z,C,E>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.Root<X>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Join<Z,X>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.ListJoin<Z,E>
      • javax.persistence.criteria.MapJoin<Z,K,V>
      • javax.persistence.criteria.PluralJoin<Z,C,E>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Root<X>
      • javax.persistence.criteria.SetJoin<Z,E>
    • javax.persistence.criteria.PluralJoin<Z,C,E>
      • javax.persistence.criteria.CollectionJoin<Z,E>
      • javax.persistence.criteria.ListJoin<Z,E>
      • javax.persistence.criteria.MapJoin<Z,K,V>
      • javax.persistence.criteria.SetJoin<Z,E>
    • javax.persistence.criteria.Predicate
      • javax.persistence.criteria.CriteriaBuilder.In<T>
    • javax.persistence.criteria.Root<X>
    • javax.persistence.criteria.Selection<X>
      • javax.persistence.criteria.CollectionJoin<Z,E>
      • javax.persistence.criteria.CompoundSelection<X>
      • javax.persistence.criteria.CriteriaBuilder.Case<R>
      • javax.persistence.criteria.CriteriaBuilder.Coalesce<T>
      • javax.persistence.criteria.CriteriaBuilder.In<T>
      • javax.persistence.criteria.CriteriaBuilder.SimpleCase<C,R>
      • javax.persistence.criteria.Expression<T>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.CriteriaBuilder.Case<R>
        • javax.persistence.criteria.CriteriaBuilder.Coalesce<T>
        • javax.persistence.criteria.CriteriaBuilder.In<T>
        • javax.persistence.criteria.CriteriaBuilder.SimpleCase<C,R>
        • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.FetchParent<Z,X>, javax.persistence.criteria.Path<X>)
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.Join<Z,X>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.PluralJoin<Z,C,E>
              • javax.persistence.criteria.CollectionJoin<Z,E>
              • javax.persistence.criteria.ListJoin<Z,E>
              • javax.persistence.criteria.MapJoin<Z,K,V>
              • javax.persistence.criteria.SetJoin<Z,E>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.PluralJoin<Z,C,E>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.Root<X>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.Join<Z,X>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.PluralJoin<Z,C,E>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.ParameterExpression<T> (also extends javax.persistence.Parameter<T>)
        • javax.persistence.criteria.Path<X>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.FetchParent<Z,X>)
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.Join<Z,X>
              • javax.persistence.criteria.CollectionJoin<Z,E>
              • javax.persistence.criteria.ListJoin<Z,E>
              • javax.persistence.criteria.MapJoin<Z,K,V>
              • javax.persistence.criteria.PluralJoin<Z,C,E>
                • javax.persistence.criteria.CollectionJoin<Z,E>
                • javax.persistence.criteria.ListJoin<Z,E>
                • javax.persistence.criteria.MapJoin<Z,K,V>
                • javax.persistence.criteria.SetJoin<Z,E>
              • javax.persistence.criteria.SetJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.PluralJoin<Z,C,E>
              • javax.persistence.criteria.CollectionJoin<Z,E>
              • javax.persistence.criteria.ListJoin<Z,E>
              • javax.persistence.criteria.MapJoin<Z,K,V>
              • javax.persistence.criteria.SetJoin<Z,E>
            • javax.persistence.criteria.Root<X>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.Join<Z,X>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.PluralJoin<Z,C,E>
              • javax.persistence.criteria.CollectionJoin<Z,E>
              • javax.persistence.criteria.ListJoin<Z,E>
              • javax.persistence.criteria.MapJoin<Z,K,V>
              • javax.persistence.criteria.SetJoin<Z,E>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.PluralJoin<Z,C,E>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.Root<X>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.Predicate
          • javax.persistence.criteria.CriteriaBuilder.In<T>
        • javax.persistence.criteria.Root<X>
        • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.Subquery<T> (also extends javax.persistence.criteria.AbstractQuery<T>)
      • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.FetchParent<Z,X>, javax.persistence.criteria.Path<X>)
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.Join<Z,X>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.PluralJoin<Z,C,E>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.Root<X>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Join<Z,X>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.ListJoin<Z,E>
      • javax.persistence.criteria.MapJoin<Z,K,V>
      • javax.persistence.criteria.ParameterExpression<T> (also extends javax.persistence.criteria.Expression<T>, javax.persistence.Parameter<T>)
      • javax.persistence.criteria.Path<X>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.From<Z,X> (also extends javax.persistence.criteria.FetchParent<Z,X>)
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.Join<Z,X>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.PluralJoin<Z,C,E>
              • javax.persistence.criteria.CollectionJoin<Z,E>
              • javax.persistence.criteria.ListJoin<Z,E>
              • javax.persistence.criteria.MapJoin<Z,K,V>
              • javax.persistence.criteria.SetJoin<Z,E>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.PluralJoin<Z,C,E>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.Root<X>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.Join<Z,X>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.PluralJoin<Z,C,E>
            • javax.persistence.criteria.CollectionJoin<Z,E>
            • javax.persistence.criteria.ListJoin<Z,E>
            • javax.persistence.criteria.MapJoin<Z,K,V>
            • javax.persistence.criteria.SetJoin<Z,E>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.PluralJoin<Z,C,E>
          • javax.persistence.criteria.CollectionJoin<Z,E>
          • javax.persistence.criteria.ListJoin<Z,E>
          • javax.persistence.criteria.MapJoin<Z,K,V>
          • javax.persistence.criteria.SetJoin<Z,E>
        • javax.persistence.criteria.Root<X>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.PluralJoin<Z,C,E>
        • javax.persistence.criteria.CollectionJoin<Z,E>
        • javax.persistence.criteria.ListJoin<Z,E>
        • javax.persistence.criteria.MapJoin<Z,K,V>
        • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Predicate
        • javax.persistence.criteria.CriteriaBuilder.In<T>
      • javax.persistence.criteria.Root<X>
      • javax.persistence.criteria.SetJoin<Z,E>
      • javax.persistence.criteria.Subquery<T> (also extends javax.persistence.criteria.AbstractQuery<T>, javax.persistence.criteria.Expression<T>)
    • javax.persistence.criteria.SetJoin<Z,E>
    • javax.persistence.criteria.Subquery<T> (also extends javax.persistence.criteria.AbstractQuery<T>, javax.persistence.criteria.Expression<T>)
  • javax.persistence.metamodel.Type<X>
    • javax.persistence.metamodel.BasicType<X>
    • javax.persistence.metamodel.EmbeddableType<X>
    • javax.persistence.metamodel.EntityType<X> (also extends javax.persistence.metamodel.Bindable<T>, javax.persistence.metamodel.IdentifiableType<X>)
    • javax.persistence.metamodel.IdentifiableType<X>
      • javax.persistence.metamodel.EntityType<X> (also extends javax.persistence.metamodel.Bindable<T>)
      • javax.persistence.metamodel.MappedSuperclassType<X>
    • javax.persistence.metamodel.ManagedType<X>
      • javax.persistence.metamodel.EmbeddableType<X>
      • javax.persistence.metamodel.EntityType<X> (also extends javax.persistence.metamodel.Bindable<T>, javax.persistence.metamodel.IdentifiableType<X>)
      • javax.persistence.metamodel.IdentifiableType<X>
        • javax.persistence.metamodel.EntityType<X> (also extends javax.persistence.metamodel.Bindable<T>)
        • javax.persistence.metamodel.MappedSuperclassType<X>
      • javax.persistence.metamodel.MappedSuperclassType<X>
    • javax.persistence.metamodel.MappedSuperclassType<X>
  • javax.xml.rpc.encoding.TypeMapping
  • javax.mail.UIDFolder
  • javax.faces.component.UniqueIdVendor
  • javax.xml.bind.Unmarshaller
  • javax.ws.rs.core.UriInfo
  • javax.xml.registry.infomodel.URIValidator
    • javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.RegistryObject)
    • javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.RegistryObject)
  • javax.transaction.UserTransaction
  • javax.resource.spi.ValidatingManagedConnectionFactory
  • javax.xml.bind.ValidationEvent
    • javax.xml.bind.NotIdentifiableEvent
    • javax.xml.bind.ParseConversionEvent
    • javax.xml.bind.PrintConversionEvent
  • javax.xml.bind.ValidationEventHandler
  • javax.xml.bind.ValidationEventLocator
  • javax.validation.spi.ValidationProvider<T>
  • javax.validation.ValidationProviderResolver
  • javax.validation.Validator
  • javax.xml.bind.Validator
  • javax.validation.ValidatorContext
  • javax.validation.ValidatorFactory
  • javax.faces.component.ValueHolder
    • javax.faces.component.EditableValueHolder
  • javax.servlet.jsp.el.VariableResolver
  • javax.xml.registry.infomodel.Versionable
    • javax.xml.registry.infomodel.ClassificationScheme
    • javax.xml.registry.infomodel.ExtrinsicObject
    • javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.RegistryObject)
      • javax.xml.registry.infomodel.ClassificationScheme
      • javax.xml.registry.infomodel.ExtrinsicObject
      • javax.xml.registry.infomodel.RegistryPackage
      • javax.xml.registry.infomodel.Service
    • javax.xml.registry.infomodel.RegistryPackage
    • javax.xml.registry.infomodel.Service
  • javax.faces.component.visit.VisitCallback
  • javax.xml.ws.WebServiceContext
  • javax.websocket.WebSocketContainer
    • javax.websocket.server.ServerContainer
  • javax.resource.spi.work.WorkContextLifecycleListener
  • javax.resource.spi.work.WorkManager
    • javax.resource.spi.work.DistributableWorkManager
  • java.sql.Wrapper
    • java.sql.ResultSet (also extends java.lang.AutoCloseable)
      • javax.resource.cci.ResultSet (also extends javax.resource.cci.Record)
    • javax.resource.cci.ResultSet (also extends javax.resource.cci.Record, java.sql.ResultSet)
  • javax.ws.rs.ext.WriterInterceptor
  • javax.jms.XAConnectionFactory
    • javax.jms.XAQueueConnectionFactory (also extends javax.jms.QueueConnectionFactory)
    • javax.jms.XATopicConnectionFactory (also extends javax.jms.TopicConnectionFactory)
  • javax.transaction.xa.XAResource
  • javax.resource.spi.XATerminator
  • javax.transaction.xa.Xid
  • javax.enterprise.deploy.model.XpathListener

Annotation Type Hierarchy

  • javax.annotation.Priority (implements java.lang.annotation.Annotation)
  • javax.annotation.ManagedBean (implements java.lang.annotation.Annotation)
  • javax.annotation.Resources (implements java.lang.annotation.Annotation)
  • javax.annotation.Resource (implements java.lang.annotation.Annotation)
  • javax.annotation.PreDestroy (implements java.lang.annotation.Annotation)
  • javax.annotation.PostConstruct (implements java.lang.annotation.Annotation)
  • javax.annotation.Generated (implements java.lang.annotation.Annotation)
  • javax.annotation.security.RunAs (implements java.lang.annotation.Annotation)
  • javax.annotation.security.RolesAllowed (implements java.lang.annotation.Annotation)
  • javax.annotation.security.PermitAll (implements java.lang.annotation.Annotation)
  • javax.annotation.security.DenyAll (implements java.lang.annotation.Annotation)
  • javax.annotation.security.DeclareRoles (implements java.lang.annotation.Annotation)
  • javax.annotation.sql.DataSourceDefinitions (implements java.lang.annotation.Annotation)
  • javax.annotation.sql.DataSourceDefinition (implements java.lang.annotation.Annotation)
  • javax.batch.api.BatchProperty (implements java.lang.annotation.Annotation)
  • javax.decorator.Delegate (implements java.lang.annotation.Annotation)
  • javax.decorator.Decorator (implements java.lang.annotation.Annotation)
  • javax.ejb.TransactionManagement (implements java.lang.annotation.Annotation)
  • javax.ejb.TransactionAttribute (implements java.lang.annotation.Annotation)
  • javax.ejb.Timeout (implements java.lang.annotation.Annotation)
  • javax.ejb.Stateless (implements java.lang.annotation.Annotation)
  • javax.ejb.StatefulTimeout (implements java.lang.annotation.Annotation)
  • javax.ejb.Stateful (implements java.lang.annotation.Annotation)
  • javax.ejb.Startup (implements java.lang.annotation.Annotation)
  • javax.ejb.Singleton (implements java.lang.annotation.Annotation)
  • javax.ejb.Schedules (implements java.lang.annotation.Annotation)
  • javax.ejb.Schedule (implements java.lang.annotation.Annotation)
  • javax.ejb.Remove (implements java.lang.annotation.Annotation)
  • javax.ejb.RemoteHome (implements java.lang.annotation.Annotation)
  • javax.ejb.Remote (implements java.lang.annotation.Annotation)
  • javax.ejb.PrePassivate (implements java.lang.annotation.Annotation)
  • javax.ejb.PostActivate (implements java.lang.annotation.Annotation)
  • javax.ejb.MessageDriven (implements java.lang.annotation.Annotation)
  • javax.ejb.Lock (implements java.lang.annotation.Annotation)
  • javax.ejb.LocalHome (implements java.lang.annotation.Annotation)
  • javax.ejb.LocalBean (implements java.lang.annotation.Annotation)
  • javax.ejb.Local (implements java.lang.annotation.Annotation)
  • javax.ejb.Init (implements java.lang.annotation.Annotation)
  • javax.ejb.EJBs (implements java.lang.annotation.Annotation)
  • javax.ejb.EJB (implements java.lang.annotation.Annotation)
  • javax.ejb.DependsOn (implements java.lang.annotation.Annotation)
  • javax.ejb.ConcurrencyManagement (implements java.lang.annotation.Annotation)
  • javax.ejb.BeforeCompletion (implements java.lang.annotation.Annotation)
  • javax.ejb.Asynchronous (implements java.lang.annotation.Annotation)
  • javax.ejb.ApplicationException (implements java.lang.annotation.Annotation)
  • javax.ejb.AfterCompletion (implements java.lang.annotation.Annotation)
  • javax.ejb.AfterBegin (implements java.lang.annotation.Annotation)
  • javax.ejb.ActivationConfigProperty (implements java.lang.annotation.Annotation)
  • javax.ejb.AccessTimeout (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.SessionScoped (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.RequestScoped (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.NormalScope (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.Initialized (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.Destroyed (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.Dependent (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.ConversationScoped (implements java.lang.annotation.Annotation)
  • javax.enterprise.context.ApplicationScoped (implements java.lang.annotation.Annotation)
  • javax.enterprise.event.Observes (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Vetoed (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Typed (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.TransientReference (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Stereotype (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Specializes (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Produces (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.New (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Model (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Intercepted (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Disposes (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Default (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Decorated (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Any (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.Alternative (implements java.lang.annotation.Annotation)
  • javax.enterprise.inject.spi.WithAnnotations (implements java.lang.annotation.Annotation)
  • javax.enterprise.util.Nonbinding (implements java.lang.annotation.Annotation)
  • javax.faces.application.ResourceDependency (implements java.lang.annotation.Annotation)
  • javax.faces.application.ResourceDependencies (implements java.lang.annotation.Annotation)
  • javax.faces.bean.ViewScoped (implements java.lang.annotation.Annotation)
  • javax.faces.bean.SessionScoped (implements java.lang.annotation.Annotation)
  • javax.faces.bean.RequestScoped (implements java.lang.annotation.Annotation)
  • javax.faces.bean.ReferencedBean (implements java.lang.annotation.Annotation)
  • javax.faces.bean.NoneScoped (implements java.lang.annotation.Annotation)
  • javax.faces.bean.ManagedProperty (implements java.lang.annotation.Annotation)
  • javax.faces.bean.ManagedBean (implements java.lang.annotation.Annotation)
  • javax.faces.bean.CustomScoped (implements java.lang.annotation.Annotation)
  • javax.faces.bean.ApplicationScoped (implements java.lang.annotation.Annotation)
  • javax.faces.component.FacesComponent (implements java.lang.annotation.Annotation)
  • javax.faces.component.behavior.FacesBehavior (implements java.lang.annotation.Annotation)
  • javax.faces.convert.FacesConverter (implements java.lang.annotation.Annotation)
  • javax.faces.event.NamedEvent (implements java.lang.annotation.Annotation)
  • javax.faces.event.ListenersFor (implements java.lang.annotation.Annotation)
  • javax.faces.event.ListenerFor (implements java.lang.annotation.Annotation)
  • javax.faces.flow.builder.FlowDefinition (implements java.lang.annotation.Annotation)
  • javax.faces.flow.builder.FlowBuilderParameter (implements java.lang.annotation.Annotation)
  • javax.faces.flow.FlowScoped (implements java.lang.annotation.Annotation)
  • javax.faces.render.FacesRenderer (implements java.lang.annotation.Annotation)
  • javax.faces.render.FacesBehaviorRenderer (implements java.lang.annotation.Annotation)
  • javax.faces.validator.FacesValidator (implements java.lang.annotation.Annotation)
  • javax.faces.view.ViewScoped (implements java.lang.annotation.Annotation)
  • javax.faces.view.facelets.FaceletsResourceResolver (implements java.lang.annotation.Annotation)
  • javax.inject.Singleton (implements java.lang.annotation.Annotation)
  • javax.inject.Scope (implements java.lang.annotation.Annotation)
  • javax.inject.Qualifier (implements java.lang.annotation.Annotation)
  • javax.inject.Named (implements java.lang.annotation.Annotation)
  • javax.inject.Inject (implements java.lang.annotation.Annotation)
  • javax.interceptor.Interceptors (implements java.lang.annotation.Annotation)
  • javax.interceptor.InterceptorBinding (implements java.lang.annotation.Annotation)
  • javax.interceptor.Interceptor (implements java.lang.annotation.Annotation)
  • javax.interceptor.ExcludeDefaultInterceptors (implements java.lang.annotation.Annotation)
  • javax.interceptor.ExcludeClassInterceptors (implements java.lang.annotation.Annotation)
  • javax.interceptor.AroundTimeout (implements java.lang.annotation.Annotation)
  • javax.interceptor.AroundInvoke (implements java.lang.annotation.Annotation)
  • javax.interceptor.AroundConstruct (implements java.lang.annotation.Annotation)
  • javax.jms.JMSSessionMode (implements java.lang.annotation.Annotation)
  • javax.jms.JMSPasswordCredential (implements java.lang.annotation.Annotation)
  • javax.jms.JMSDestinationDefinitions (implements java.lang.annotation.Annotation)
  • javax.jms.JMSDestinationDefinition (implements java.lang.annotation.Annotation)
  • javax.jms.JMSConnectionFactoryDefinitions (implements java.lang.annotation.Annotation)
  • javax.jms.JMSConnectionFactoryDefinition (implements java.lang.annotation.Annotation)
  • javax.jms.JMSConnectionFactory (implements java.lang.annotation.Annotation)
  • javax.jws.WebService (implements java.lang.annotation.Annotation)
  • javax.jws.WebResult (implements java.lang.annotation.Annotation)
  • javax.jws.WebParam (implements java.lang.annotation.Annotation)
  • javax.jws.WebMethod (implements java.lang.annotation.Annotation)
  • javax.jws.Oneway (implements java.lang.annotation.Annotation)
  • javax.jws.HandlerChain (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandlers (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandler (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPBinding (implements java.lang.annotation.Annotation)
  • javax.jws.soap.InitParam (implements java.lang.annotation.Annotation)
  • javax.mail.MailSessionDefinitions (implements java.lang.annotation.Annotation)
  • javax.mail.MailSessionDefinition (implements java.lang.annotation.Annotation)
  • javax.persistence.Version (implements java.lang.annotation.Annotation)
  • javax.persistence.UniqueConstraint (implements java.lang.annotation.Annotation)
  • javax.persistence.Transient (implements java.lang.annotation.Annotation)
  • javax.persistence.Temporal (implements java.lang.annotation.Annotation)
  • javax.persistence.TableGenerator (implements java.lang.annotation.Annotation)
  • javax.persistence.Table (implements java.lang.annotation.Annotation)
  • javax.persistence.StoredProcedureParameter (implements java.lang.annotation.Annotation)
  • javax.persistence.SqlResultSetMappings (implements java.lang.annotation.Annotation)
  • javax.persistence.SqlResultSetMapping (implements java.lang.annotation.Annotation)
  • javax.persistence.SequenceGenerator (implements java.lang.annotation.Annotation)
  • javax.persistence.SecondaryTables (implements java.lang.annotation.Annotation)
  • javax.persistence.SecondaryTable (implements java.lang.annotation.Annotation)
  • javax.persistence.QueryHint (implements java.lang.annotation.Annotation)
  • javax.persistence.PrimaryKeyJoinColumns (implements java.lang.annotation.Annotation)
  • javax.persistence.PrimaryKeyJoinColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.PreUpdate (implements java.lang.annotation.Annotation)
  • javax.persistence.PreRemove (implements java.lang.annotation.Annotation)
  • javax.persistence.PrePersist (implements java.lang.annotation.Annotation)
  • javax.persistence.PostUpdate (implements java.lang.annotation.Annotation)
  • javax.persistence.PostRemove (implements java.lang.annotation.Annotation)
  • javax.persistence.PostPersist (implements java.lang.annotation.Annotation)
  • javax.persistence.PostLoad (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceUnits (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceUnit (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceProperty (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceContexts (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceContext (implements java.lang.annotation.Annotation)
  • javax.persistence.OrderColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.OrderBy (implements java.lang.annotation.Annotation)
  • javax.persistence.OneToOne (implements java.lang.annotation.Annotation)
  • javax.persistence.OneToMany (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedSubgraph (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedStoredProcedureQuery (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedStoredProcedureQueries (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedQuery (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedQueries (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedNativeQuery (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedNativeQueries (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedEntityGraphs (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedEntityGraph (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedAttributeNode (implements java.lang.annotation.Annotation)
  • javax.persistence.MapsId (implements java.lang.annotation.Annotation)
  • javax.persistence.MappedSuperclass (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyTemporal (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyJoinColumns (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyJoinColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyEnumerated (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKeyClass (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKey (implements java.lang.annotation.Annotation)
  • javax.persistence.ManyToOne (implements java.lang.annotation.Annotation)
  • javax.persistence.ManyToMany (implements java.lang.annotation.Annotation)
  • javax.persistence.Lob (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinTable (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinColumns (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.Inheritance (implements java.lang.annotation.Annotation)
  • javax.persistence.Index (implements java.lang.annotation.Annotation)
  • javax.persistence.IdClass (implements java.lang.annotation.Annotation)
  • javax.persistence.Id (implements java.lang.annotation.Annotation)
  • javax.persistence.GeneratedValue (implements java.lang.annotation.Annotation)
  • javax.persistence.ForeignKey (implements java.lang.annotation.Annotation)
  • javax.persistence.FieldResult (implements java.lang.annotation.Annotation)
  • javax.persistence.ExcludeSuperclassListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.ExcludeDefaultListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.Enumerated (implements java.lang.annotation.Annotation)
  • javax.persistence.EntityResult (implements java.lang.annotation.Annotation)
  • javax.persistence.EntityListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.Entity (implements java.lang.annotation.Annotation)
  • javax.persistence.EmbeddedId (implements java.lang.annotation.Annotation)
  • javax.persistence.Embedded (implements java.lang.annotation.Annotation)
  • javax.persistence.Embeddable (implements java.lang.annotation.Annotation)
  • javax.persistence.ElementCollection (implements java.lang.annotation.Annotation)
  • javax.persistence.DiscriminatorValue (implements java.lang.annotation.Annotation)
  • javax.persistence.DiscriminatorColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.Converts (implements java.lang.annotation.Annotation)
  • javax.persistence.Converter (implements java.lang.annotation.Annotation)
  • javax.persistence.Convert (implements java.lang.annotation.Annotation)
  • javax.persistence.ConstructorResult (implements java.lang.annotation.Annotation)
  • javax.persistence.ColumnResult (implements java.lang.annotation.Annotation)
  • javax.persistence.Column (implements java.lang.annotation.Annotation)
  • javax.persistence.CollectionTable (implements java.lang.annotation.Annotation)
  • javax.persistence.Cacheable (implements java.lang.annotation.Annotation)
  • javax.persistence.Basic (implements java.lang.annotation.Annotation)
  • javax.persistence.AttributeOverrides (implements java.lang.annotation.Annotation)
  • javax.persistence.AttributeOverride (implements java.lang.annotation.Annotation)
  • javax.persistence.AssociationOverrides (implements java.lang.annotation.Annotation)
  • javax.persistence.AssociationOverride (implements java.lang.annotation.Annotation)
  • javax.persistence.Access (implements java.lang.annotation.Annotation)
  • javax.persistence.metamodel.StaticMetamodel (implements java.lang.annotation.Annotation)
  • javax.resource.ConnectionFactoryDefinitions (implements java.lang.annotation.Annotation)
  • javax.resource.ConnectionFactoryDefinition (implements java.lang.annotation.Annotation)
  • javax.resource.AdministeredObjectDefinitions (implements java.lang.annotation.Annotation)
  • javax.resource.AdministeredObjectDefinition (implements java.lang.annotation.Annotation)
  • javax.resource.spi.SecurityPermission (implements java.lang.annotation.Annotation)
  • javax.resource.spi.Connector (implements java.lang.annotation.Annotation)
  • javax.resource.spi.ConnectionDefinitions (implements java.lang.annotation.Annotation)
  • javax.resource.spi.ConnectionDefinition (implements java.lang.annotation.Annotation)
  • javax.resource.spi.ConfigProperty (implements java.lang.annotation.Annotation)
  • javax.resource.spi.AuthenticationMechanism (implements java.lang.annotation.Annotation)
  • javax.resource.spi.AdministeredObject (implements java.lang.annotation.Annotation)
  • javax.resource.spi.Activation (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.WebServlet (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.WebListener (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.WebInitParam (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.WebFilter (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.ServletSecurity (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.MultipartConfig (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.HttpMethodConstraint (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.HttpConstraint (implements java.lang.annotation.Annotation)
  • javax.servlet.annotation.HandlesTypes (implements java.lang.annotation.Annotation)
  • javax.transaction.TransactionScoped (implements java.lang.annotation.Annotation)
  • javax.transaction.Transactional (implements java.lang.annotation.Annotation)
  • javax.validation.Valid (implements java.lang.annotation.Annotation)
  • javax.validation.ReportAsSingleViolation (implements java.lang.annotation.Annotation)
  • javax.validation.OverridesAttribute (implements java.lang.annotation.Annotation)
  • javax.validation.OverridesAttribute.List (implements java.lang.annotation.Annotation)
  • javax.validation.GroupSequence (implements java.lang.annotation.Annotation)
  • javax.validation.Constraint (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Size (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Size.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Pattern (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Pattern.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Past (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Past.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Null (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Null.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.NotNull (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.NotNull.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Min (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Min.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Max (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Max.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Future (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Future.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Digits (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.Digits.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.DecimalMin (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.DecimalMin.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.DecimalMax (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.DecimalMax.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.AssertTrue (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.AssertTrue.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.AssertFalse (implements java.lang.annotation.Annotation)
  • javax.validation.constraints.AssertFalse.List (implements java.lang.annotation.Annotation)
  • javax.validation.constraintvalidation.SupportedValidationTarget (implements java.lang.annotation.Annotation)
  • javax.validation.executable.ValidateOnExecution (implements java.lang.annotation.Annotation)
  • javax.validation.groups.ConvertGroup (implements java.lang.annotation.Annotation)
  • javax.validation.groups.ConvertGroup.List (implements java.lang.annotation.Annotation)
  • javax.websocket.OnOpen (implements java.lang.annotation.Annotation)
  • javax.websocket.OnMessage (implements java.lang.annotation.Annotation)
  • javax.websocket.OnError (implements java.lang.annotation.Annotation)
  • javax.websocket.OnClose (implements java.lang.annotation.Annotation)
  • javax.websocket.ClientEndpoint (implements java.lang.annotation.Annotation)
  • javax.websocket.server.ServerEndpoint (implements java.lang.annotation.Annotation)
  • javax.websocket.server.PathParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.QueryParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.PUT (implements java.lang.annotation.Annotation)
  • javax.ws.rs.Produces (implements java.lang.annotation.Annotation)
  • javax.ws.rs.POST (implements java.lang.annotation.Annotation)
  • javax.ws.rs.PathParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.Path (implements java.lang.annotation.Annotation)
  • javax.ws.rs.OPTIONS (implements java.lang.annotation.Annotation)
  • javax.ws.rs.NameBinding (implements java.lang.annotation.Annotation)
  • javax.ws.rs.MatrixParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.HttpMethod (implements java.lang.annotation.Annotation)
  • javax.ws.rs.HeaderParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.HEAD (implements java.lang.annotation.Annotation)
  • javax.ws.rs.GET (implements java.lang.annotation.Annotation)
  • javax.ws.rs.FormParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.Encoded (implements java.lang.annotation.Annotation)
  • javax.ws.rs.DELETE (implements java.lang.annotation.Annotation)
  • javax.ws.rs.DefaultValue (implements java.lang.annotation.Annotation)
  • javax.ws.rs.CookieParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.Consumes (implements java.lang.annotation.Annotation)
  • javax.ws.rs.ConstrainedTo (implements java.lang.annotation.Annotation)
  • javax.ws.rs.BeanParam (implements java.lang.annotation.Annotation)
  • javax.ws.rs.ApplicationPath (implements java.lang.annotation.Annotation)
  • javax.ws.rs.container.Suspended (implements java.lang.annotation.Annotation)
  • javax.ws.rs.container.PreMatching (implements java.lang.annotation.Annotation)
  • javax.ws.rs.core.Context (implements java.lang.annotation.Annotation)
  • javax.ws.rs.ext.Provider (implements java.lang.annotation.Annotation)
  • javax.ws.rs.ext.ParamConverter.Lazy (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlTransient (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSeeAlso (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaTypes (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchema (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRootElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRegistry (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlNs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMixed (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMimeType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlList (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlInlineBinaryData (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlIDREF (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlID (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnumValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnum (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElements (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementDecl (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttachmentRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorOrder (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRefs (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRef (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceProvider (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceClient (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebFault (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebEndpoint (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ServiceMode (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ResponseWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RespectBinding (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RequestWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.FaultAction (implements java.lang.annotation.Annotation)
  • javax.xml.ws.BindingType (implements java.lang.annotation.Annotation)
  • javax.xml.ws.Action (implements java.lang.annotation.Annotation)
  • javax.xml.ws.soap.MTOM (implements java.lang.annotation.Annotation)
  • javax.xml.ws.soap.Addressing (implements java.lang.annotation.Annotation)
  • javax.xml.ws.spi.WebServiceFeatureAnnotation (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.annotation.Resource.AuthenticationType
      • javax.batch.api.partition.PartitionReducer.PartitionStatus
      • javax.batch.runtime.Metric.MetricType
      • javax.batch.runtime.BatchStatus
      • javax.ejb.TransactionManagementType
      • javax.ejb.TransactionAttributeType
      • javax.ejb.LockType
      • javax.ejb.ConcurrencyManagementType
      • javax.enterprise.event.TransactionPhase
      • javax.enterprise.event.Reception
      • javax.enterprise.inject.spi.SessionBeanType
      • javax.enterprise.inject.spi.InterceptionType
      • javax.faces.application.ProjectStage
      • javax.faces.component.behavior.ClientBehaviorHint
      • javax.faces.component.html.HtmlSelectOneRadio.PropertyKeys
      • javax.faces.component.html.HtmlSelectOneMenu.PropertyKeys
      • javax.faces.component.html.HtmlSelectOneListbox.PropertyKeys
      • javax.faces.component.html.HtmlSelectManyMenu.PropertyKeys
      • javax.faces.component.html.HtmlSelectManyListbox.PropertyKeys
      • javax.faces.component.html.HtmlSelectManyCheckbox.PropertyKeys
      • javax.faces.component.html.HtmlSelectBooleanCheckbox.PropertyKeys
      • javax.faces.component.html.HtmlPanelGroup.PropertyKeys
      • javax.faces.component.html.HtmlPanelGrid.PropertyKeys
      • javax.faces.component.html.HtmlOutputText.PropertyKeys
      • javax.faces.component.html.HtmlOutputLink.PropertyKeys
      • javax.faces.component.html.HtmlOutputLabel.PropertyKeys
      • javax.faces.component.html.HtmlOutputFormat.PropertyKeys
      • javax.faces.component.html.HtmlOutcomeTargetLink.PropertyKeys
      • javax.faces.component.html.HtmlOutcomeTargetButton.PropertyKeys
      • javax.faces.component.html.HtmlMessages.PropertyKeys
      • javax.faces.component.html.HtmlMessage.PropertyKeys
      • javax.faces.component.html.HtmlInputTextarea.PropertyKeys
      • javax.faces.component.html.HtmlInputText.PropertyKeys
      • javax.faces.component.html.HtmlInputSecret.PropertyKeys
      • javax.faces.component.html.HtmlInputHidden.PropertyKeys
      • javax.faces.component.html.HtmlInputFile.PropertyKeys
      • javax.faces.component.html.HtmlHead.PropertyKeys
      • javax.faces.component.html.HtmlGraphicImage.PropertyKeys
      • javax.faces.component.html.HtmlForm.PropertyKeys
      • javax.faces.component.html.HtmlDoctype.PropertyKeys
      • javax.faces.component.html.HtmlDataTable.PropertyKeys
      • javax.faces.component.html.HtmlCommandLink.PropertyKeys
      • javax.faces.component.html.HtmlCommandButton.PropertyKeys
      • javax.faces.component.html.HtmlColumn.PropertyKeys
      • javax.faces.component.html.HtmlBody.PropertyKeys
      • javax.faces.component.visit.VisitResult
      • javax.faces.component.visit.VisitHint
      • javax.json.JsonValue.ValueType
      • javax.json.stream.JsonParser.Event
      • javax.jws.WebParam.Mode
      • javax.jws.soap.SOAPBinding.Style
      • javax.jws.soap.SOAPBinding.Use
      • javax.jws.soap.SOAPBinding.ParameterStyle
      • javax.persistence.ValidationMode
      • javax.persistence.TemporalType
      • javax.persistence.SynchronizationType
      • javax.persistence.SharedCacheMode
      • javax.persistence.PessimisticLockScope
      • javax.persistence.PersistenceContextType
      • javax.persistence.ParameterMode
      • javax.persistence.LockModeType
      • javax.persistence.InheritanceType
      • javax.persistence.GenerationType
      • javax.persistence.FlushModeType
      • javax.persistence.FetchType
      • javax.persistence.EnumType
      • javax.persistence.DiscriminatorType
      • javax.persistence.ConstraintMode
      • javax.persistence.CascadeType
      • javax.persistence.CacheStoreMode
      • javax.persistence.CacheRetrieveMode
      • javax.persistence.AccessType
      • javax.persistence.criteria.Predicate.BooleanOperator
      • javax.persistence.criteria.JoinType
      • javax.persistence.criteria.CriteriaBuilder.Trimspec
      • javax.persistence.metamodel.Type.PersistenceType
      • javax.persistence.metamodel.PluralAttribute.CollectionType
      • javax.persistence.metamodel.Bindable.BindableType
      • javax.persistence.metamodel.Attribute.PersistentAttributeType
      • javax.persistence.spi.PersistenceUnitTransactionType
      • javax.persistence.spi.LoadState
      • javax.resource.spi.TransactionSupport.TransactionSupportLevel
      • javax.resource.spi.AuthenticationMechanism.CredentialInterface
      • javax.servlet.annotation.ServletSecurity.EmptyRoleSemantic
      • javax.servlet.annotation.ServletSecurity.TransportGuarantee
      • javax.servlet.SessionTrackingMode
      • javax.servlet.DispatcherType
      • javax.transaction.Transactional.TxType
      • javax.validation.ElementKind
      • javax.validation.ConstraintTarget
      • javax.validation.constraints.Pattern.Flag
      • javax.validation.constraintvalidation.ValidationTarget
      • javax.validation.executable.ExecutableType
      • javax.validation.metadata.Scope
      • javax.validation.metadata.MethodType
      • javax.websocket.CloseReason.CloseCodes (implements javax.websocket.CloseReason.CloseCode)
      • javax.ws.rs.RuntimeType
      • javax.ws.rs.core.Response.Status (implements javax.ws.rs.core.Response.StatusType)
      • javax.ws.rs.core.Response.Status.Family
      • javax.xml.bind.annotation.XmlNsForm
      • javax.xml.bind.annotation.XmlAccessType
      • javax.xml.bind.annotation.XmlAccessOrder
      • javax.xml.ws.Service.Mode
      • javax.xml.ws.handler.MessageContext.Scope
      • javax.xml.ws.soap.AddressingFeature.Responses
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
  • Prev
  • Next
  • Frames
  • No Frames